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Chapter 1: Getting started


Installation and registration 

To install

1 Close any Adobe® applications that are open.


2 Insert the product CD into your computer’s CD drive.


3 Double-click the CD icon, and then follow the on-screen instructions.


After the installation, you may be prompted to activate your copy of the product. (See “To activate” on page 1.)


For more detailed instructions about installing the product, see the How To Install file on the product CD. For


instructions about uninstalling the product, see the How To Uninstall file on the product CD.


To activate 
Activation is a simple, anonymous process you must complete within 30 days of installing the product. Activation 

allows you to continue using the product, and it helps prevent casual copying of the product onto more computers 

than the license agreement allows. To learn more about activation, visit the Adobe website at 

www.adobe.com/activation/main.html. 

1 Start the product to access the Activation dialog box. (If you’ve just installed Adobe Creative Suite or Adobe 

Photoshop®, the Activation dialog box appears automatically.) 

2	 Follow the on-screen instructions. 

Important: If you intend to install the product on a different computer, you must first transfer the activation to that 

computer. To transfer an activation, choose Help > Transfer Activation. 

For more detailed instructions about activating the product and transferring an activation, see the How To Install file 

on the product CD. 

To register 
Register your Adobe product to receive complimentary support on installation and product defects and notifications 

about product updates. Registering your product also gives you access to the wealth of tips, tricks, and tutorials in 

Adobe Studio® and access to Adobe Studio Exchange, an online community where users download and share 

thousands of free actions, plug-ins, and other content for use with Adobe products. Adobe Studio is available in 

English, French, German, and Japanese. Find it from the home page of the Adobe website. 

❖ Do one of the following: 

•	 Install and activate the software to access the Registration dialog box, and then follow the on-screen instructions. 

An active Internet connection is required. 

•	 Register at any time by choosing Help > Registration. 
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See also 

“Adobe Studio” on page 7 

“Extras” on page 9 

Adobe Help Center 

About Adobe Help Center 
Adobe Help Center is a free, downloadable application that includes three primary features. 

Product Help Provides Help topics for Adobe Photoshop Elements and Adobe CS2 products installed on your 

system. (If none of these products are installed, Help topics for them aren’t available.) Help topics are updated period

ically and can be downloaded through Adobe Help Center preferences. 

Expert Support Provides information about Adobe Expert Support plans and lets you store details about plans 

you’ve purchased. If you have an active support plan, you can also use the Expert Support section to submit web 

cases—questions sent to Adobe support professionals over the web. To access links in the Expert Support section, 

you must have an active Internet connection. 

More Resources Provides easy access to the extensive resources on Adobe.com, including support pages, user 

forums, tips and tutorials, and training. You can also use this area to store contact information for friends, colleagues, 

or support professionals, or even websites you turn to for inspiration or troubleshooting information. 

Product Help, Expert Support, and More Resources in Adobe Help Center 

See also 

“Using Help” on page 3 

“To search Help topics” on page 5 

“To navigate Help” on page 4 

To check for updates 
Adobe periodically provides updates to software and to topics in Adobe Help Center. You can easily obtain these 

updates through Adobe Help Center. An active Internet connection is required. 

1 Click the Preferences button . 

2 In the Preferences dialog box, click Check For Updates. If updates are available, follow the on-screen directions to 

download and save them. 

 



3 ADOBE PHOTOSHOP CS2 
User Guide 

To set Adobe Help Center preferences 
1 Click the Preferences button . Set any of the following options:


Region Specifies your geographical location. Changing this option may affect which services are available to you.


Language Specifies the language in which Expert Support content is displayed. 

Display Renewal Reminders For Expert Support Contracts Displays reminder screens when your Expert Support 

plan has almost expired. Deselect this option if you’d like to turn off these reminders. 

Enable Auto Login For Web Case Submission Allows  you to submit support  questions over the  web.  This  option  is  

available only if you have an active Expert Support plan. 

User Interface Language Specifies the language in which Adobe Help Center interface text is displayed. 

Check For Updates Searches for new updates to software and Help topics as they become available from Adobe. 

Network Administrators Displays options for network administration. 

2	 Click OK. 

To display More Resources 
The More Resources section in Adobe Help Center provides easy access to some of the content and services available 

from the Adobe website, including support, training, and tutorials. 

❖ To display this section, click More Resources. 

To add contact information in More Resources 
1 Click More Resources, and then click Personal Contacts. 

2 Do any of the following: 

•	 To add a contact, click New, type the contact information you want to save, and click OK. 

•	 To edit a contact, click a contact in the list, click Edit, make changes to the information, and click OK. 

•	 To delete a contact, click a contact in the list, and then click Delete. To confirm the deletion, click Yes when 

prompted, or click No to cancel. 

Using Help 

Using Help 
The complete documentation for using your Adobe product is available in Help, a browser-based system you can 

access through Adobe Help Center. Help topics are updated periodically, so you can always be sure to have the most 

recent information available. For more information, see “To check for updates” on page 2. 

Important: Adobe Help systems include all of the information in the printed user guides, plus additional information 

not included in print. The Resources and Extras CD included with the software also includes a PDF version of the 

complete Help content, optimized for printing. 
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A B C D E 

Product Help section of Adobe Help Center 
A. Returns you to Help home page B. Adds bookmark for current topic C. Prints contents of right pane D. Opens Preferences dialog 
box E. Opens About Adobe Help Center window 

See also 

“To navigate Help” on page 4 

“To search Help topics” on page 5 

To navigate Help 
❖ Do any of the following: 

•	 To view Help for a product, choose the product name from the Help For menu. (To view only topics that apply 

across all Creative Suite products, choose Adobe Creative Suite.) 

•	 To expand or collapse a section, click the blue triangle to the left of the section name. 

•	 To display a topic , click its title. 

See also 

“To use bookmarks” on page 6 
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To search Help topics 
Search using words or phrases to quickly find topics. You can search Help for one product or for all Adobe products 

you’ve installed. If you find a topic that you may want to view again, bookmark it for quick retrieval. 

1	 In Adobe Help Center, click Product Help. 

2 Type one or more words in the Search box. To search across Help for all Adobe products you have installed, click 

the black triangle to the left of the Search box and choose Search All Help. 

Search Help for one product or for all products you’ve installed 

3 Click Search. Topics matching the search words appear in the navigation pane.


4 To view a topic, click its title.


5 To return to the navigation pane, do one of the following:


•	 Click the Home button. 

•	 Click the Back button. 

•	 Click Next Topic or Previous Topic. 

See also 

“To print a topic from Help” on page 5 

“To use bookmarks” on page 6 

Search tips 
Adobe Help search works by searching the entire Help text for topics that contain all of the words typed in the Search 

box. These tips can help you improve your search results in Help: 

•	 If you search using a phrase, such as “shape tool,” put quotation marks around the phrase. The search returns only 

those topics containing all words in the phrase. 

•	 Make sure that the search terms are spelled correctly. 

•	 If a search term doesn’t yield results, try using a synonym, such as “web” instead of “Internet.” 

To print a topic from Help

1 Select the topic you want to print, and click the Print button.


2 Choose the printer you’d like to use, and then click Print.
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To change the view 
By default, Adobe Help Center opens in Full view. Full view gives you access to the Product Help, Expert Support, 

and More Resources sections. Switch to Compact view when you want to see only the selected Help topic and you 

want to keep the Help window on top of your product workspace. 

❖ Click the view icon  to switch between Full and Compact views. 

To use bookmarks 
You can bookmark especially helpful topics for easy access, just as you bookmark pages in a web browser, and reread 

them at another time. 

1 Click the Bookmarks tab in the navigation pane to view the bookmarks. 

2 Do any of the following in the Bookmarks pane: 

•	 To create a bookmark, select the topic you want to mark, and click the Bookmark button . When the Bookmark 

dialog box appears, type a new name in the text box if desired, and then click OK. 

•	 To delete a bookmark, select it and click the Delete button. Click Yes to confirm the deletion. 

•	 To  rename  a bookmark,  select  it  and then click  the Rename button  .  In  the dialog box, type a new name for  the  

bookmark and then click OK. 

•	 To move a bookmark, select it and then click the Move Up button  or the Move Down button . 

Tips and training 

Learning resources 
Adobe provides a wide range of resources to help you learn and use Adobe products. 

•	 “Tutorials in Help” on page 7: Short step-by-step lessons through Adobe Help Center. 

•	 “Total Training Video Workshop CD” on page 7: Professional training videos from experts. 

•	 “Adobe Studio” on page 7: Videos, tips and tricks, and other learning material on Adobe products. 

•	 Adobe Creative Suite Design Guide (Adobe Creative Suite only): A full-color printed book about using Adobe 

Creative Suite 2 as a complete design and publishing toolbox, including five guided projects on print, web, and 

mobile workflows. 

•	 “Technical information” on page 8: Reference material, scripting guides, and other in-depth information. 

•	 “Other resources” on page 9: Training, books, user forums, product certification, and more. 

•	 Support: Complimentary and paid technical support options from Adobe. 

•	 “Extras” on page 9: Downloadable content and software. 

See also 

“About Adobe Help Center” on page 2 
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Tutorials in Help 
The Help system for each Adobe CS2 product includes several step-by-step tutorials on key features and concepts. 

These tutorials are also available in the complete, printable, PDF version of the Help contents, included on the 

Resources and Extras CD. 

To use these tutorials with the product, select the tutorial you want from the Contents pane in Adobe Help Center, 

and click the View icon  to switch to Compact view. Compact view keeps the Help window on top of the appli

cation windows, regardless of what window or application is selected. Drag an edge or a corner of the Help window 

to resize it. 

See also 

“Adobe Studio” on page 7 

“Total Training Video Workshop CD” on page 7 

“Other resources” on page 9 

Total Training Video Workshop CD 
Presented by experts in their fields, Total Training videos provide overviews, demos of key new features, and many 

useful tips and techniques for beginning and advanced users. Look for accompanying step-by-step instructions to 

selected Total Training videos in monthly updates to Adobe Studio. 

Short Total Training web videos on a variety of products and topics are also available in Adobe Studio, and complete 

Total Training courseware can be purchased online from the Adobe Store. 

See also 

“Adobe Studio” on page 7 

“Other resources” on page 9 

Adobe Studio 
Adobe Studio provides a huge  wealth  of  tips  and tricks,  tutorials,  and instructional  content in video,  Adobe PDF, and  

HTML, authored by experts from Adobe and its publishing partners. You can search the entire collection or sort by 

product, topic, date, and type of content; new content is added monthly. Adobe Studio is available in English, French, 

German, and Japanese. Find it from the home page of the Adobe website. 
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Tips and tutorials in Adobe Studio 

See also 

“Total Training Video Workshop CD” on page 7 

“Other resources” on page 9 

Technical information 
The Technical information folder on the Resources and Extras CD included with your Adobe product includes 

several useful documents in PDF, fully searchable and optimized for printing. These documents provide conceptual 

and reference material on various in-depth topics, such as scripting, transparency, and high-end printing. For 

complete developer documentation and resources, visit the Developers area of the Adobe website at 

http://partners.adobe.com/public/developer/main.html. For additional backgrounders and instructional content, 

visit Adobe Studio. 

The Resources and Extras CD also includes the entire Help content optimized for printing. Note that the Help 

content includes everything in the printed Adobe user guides, plus much more. 

See also 

“Adobe Studio” on page 7 

“Other resources” on page 9 
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Other resources 
Additional sources of information and help are available for Adobe products. 

•	 Visit the Training area of the Adobe website for access to Adobe Press books; online, video, and instructor-led 

training resources; Adobe software certification programs; and more. 

•	 Visit the Adobe user forums, where users share tips, ask questions, and find out how others are getting the most 

out of their software. User forums are available in English, French, German, and Japanese on the main Support 

page of your local Adobe website. 

•	 Visit the Support area of the Adobe website for additional information about free and paid technical support 

options. Top issues are listed by product on the Adobe U.S. and Adobe Japan websites. 

•	 Visit the Developers area of the Adobe website to find information for software and plug-in developers, including 

SDKs, scripting guides, and technical resources. 

•	 Click More Resources in Adobe Help Center to access many of the resources on the Adobe website and to create 

your own list of frequently visited user groups and websites and valuable contacts. 

•	 Look in Bridge Center for RSS feeds on the latest technical announcements, tutorials, and events. To access Bridge 

Center, select it in the Favorites panel in Adobe Bridge. (Bridge Center is available with Adobe Creative Suite only.) 

See also 

“To display More Resources” on page 3 

“Learning resources” on page 6 

Extras 
The Resources and Extras CD included with your CS2 product includes a Goodies folder that contains bonus content 

and files for use with your Adobe product. For more free content and add-ons, visit Adobe Studio Exchange, an 

online community where users download and share thousands of free actions, plug-ins, and other content for use 

with  Adobe products.  To  visit Adobe  Studio  Exchange, go to Adobe  Studio  from  the home page of the  Adobe website.  

In addition, your CS2 product includes Adobe Stock Photos, an integrated service available within Adobe Bridge that 

lets you search, view, try, and buy royalty-free stock photography from leading stock libraries. Because of the tight 

integration between Stock Photos and CS2 products, you can download images directly into your Adobe Illustrator®, 

Adobe InDesign®, and Adobe GoLive® projects. From Photoshop, you can open any downloaded image. 

See also 

“Adobe Studio” on page 7 

“About Adobe Stock Photos” on page 103 

“About Adobe Bridge” on page 79 

Other downloads 
The Downloads area of the Adobe website includes free updates, tryouts, and other useful software. In addition, the 

Plug-ins section of the Adobe Store provides access to thousands of plug-ins from third-party developers, helping 

you automate tasks, customize workflows, create specialized professional effects, and more. 

 



10 ADOBE PHOTOSHOP CS2 
User Guide 

See also 

“About Adobe Stock Photos” on page 103 

“Other resources” on page 9 

What’s new 

New features 

Workflow improvements 

Adobe Bridge Simplify file handling in Photoshop and within Adobe Creative Suite with Adobe Bridge, the next

generation file browser. Efficiently browse, tag, search, and process your images. (See “About Adobe Bridge” on 

page 79.) 

Color management improvements Maintain common color settings throughout the Adobe Creative Suite compo

nents. Print with the simplified printing interface for color management. (See “To synchronize color settings across 

Adobe applications” on page 254.) 

Version Cue® 2.0 Manage files and versions as a single user or in a small workgroup. Integrate with Adobe Bridge 

to manage files for your Photoshop and Adobe Creative Suite projects. (See “Version Cue managed projects” on 

page 113.) 

Enhanced photo capabilities 

Multi-image Camera Raw Process an entire photo  shoot in a fraction  of  the time.  With  support for  a comprehensive  

range of digital cameras, you can automatically adjust settings, convert to universal Digital Negative (DNG) format, 

and apply nondestructive edits to batches of images. (See “The Camera Raw plug-in” on page 207.) 

High Dynamic Range (HDR) Work with images in 32-bits-per-channel, extended dynamic range. Photographers 

can capture the full dynamic range of a scene with multiple exposures and merge the files into a single image. (See 

“About High Dynamic Range images” on page 201.) 

Optical lens correction Correct for lens aberrations such as barrel and pincushion distortion, chromatic aberration, 

and lens vignetting. Easily correct image perspective using the filter’s grid. (See “The Lens Correction filter” on 

page 351.) 

Noise reduction Reduce digital image noise, JPEG artifacts, and scanned film grain. (See “Reducing image noise” 

on page 353.) 

Smart Sharpen filter Sharpen images with new algorithms for better edge detection and reduced sharpening halos. 

Control the amount of sharpening in the highlights and shadows. (See “To use the Smart Sharpen filter” on 

page 355.) 

Spot Healing tool Quickly heal spots and blemishes without selecting source content. (See “To use the Spot Healing 

Brush tool” on page 369.) 

One-click red-eye correction Fix red eyes with one click. Set options to adjust pupil size and darkening amount. 

(See “To remove red eye” on page 371.) 

Blur filters Apply blur effects using new blur filters: Box Blur, Shape Blur, and Surface Blur. (See “Blur filters” on 

page 515.) 
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Productivity boosters 

Customizable menus Set up and save custom menus and workspaces, highlight new or commonly used menu 

items, and reduce on-screen clutter for easier access to the tools you need. (See “To define a set of menus” on 

page 65.) 

Image Processor Process a batch of files to multiple file formats. (See “About the Image Processor” on page 739.) 

All new PDF engine Comprehensive, customizable presets and PDF 1.6/Acrobat 7.0 compatibility. (See “Saving files 

in Photoshop PDF format” on page 656.) 

Script and action event manager Set JavaScripts and Photoshop actions to run automatically when a specified 

Photoshop event occurs. (See “To set scripts and actions to run automatically” on page 747.) 

UI font size customization Customize the size of text in the options bar, palettes, and the Layer Style dialog box. 

(See “To change the font size in the work area” on page 64.) 

Update Manager Automatically search for Photoshop updates. 

Variables Create data-driven graphics in Photoshop as you now do in ImageReady. (See “About data-driven 

graphics” on page 747.) 

Video preview Display your document on a video monitor using a Firewire (IEEE1394) link. (See “To preview your 

document on a video monitor” on page 708.) 

WYSIWYG Font menu Preview font families and font styles directly in the Font menu. (See “To choose a font family 

and style” on page 546.) 

Designer enhancements 

Vanishing Point Paste, clone, and paint image elements that automatically match the perspective planes in an 

image. (See “About Vanishing Point” on page 374.) 

Smart Objects Perform nondestructive transforms of embedded vector and of pixel data. Create multiple instances 

of embedded data and easily update all instances at once. (See “Smart Objects” on page 427.) 

Multiple layer control Work with layers as objects. Select multiple layers and move, group, align, and transform 

them. (See “Selecting layers” on page 399 and “To group and ungroup layers” on page 400.) 

Image Warp Easily create packaging mock-ups or other dimensional effects by wrapping an image around any 

shape or stretching, curling, and bending an image using Image Warp. (See “The Warp command” on page 364.) 

Animation Create animated GIF files in Photoshop much as you create animation in ImageReady. (See “Creating an 

animation” on page 614.) 

Japanese type features Format text with new character alignment (Mojisoroe) and more Kinsoku Shori types. (See 

“About Asian type” on page 563.) 

Smart Guides Align the content of layers as you move them using guidelines that appear only when you need them. 

(See “About guides and the grid” on page 60.) 

Integrated Adobe Online Services Access and download professional Adobe Stock Photos and share and print 

online with Adobe Photoshop Services. (See “About Adobe Stock Photos” on page 103.) 
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What’s changed 
If you've worked with a previous version of Photoshop, you'll find that some things work a little differently in 

Photoshop CS2. 

Layer grouping You can group layers using the keyboard shortcut Control+G (Windows) or Command+G 

(Mac OS). The shortcut for creating a clipping mask is now Control+Alt+G (Windows) or Command+Option+G 

(Mac OS). 

Layer linking and multiple layer selection Working with multiple layers is easier now because you can select 

multiple layers in the Layers palette or in the document window using the Move tool. The layer linking column was 

removed. To link layers, select multiple layers and click the link icon at the bottom of the Layers palette. Some menu 

commands that work on linked layers have been changed to work on multiple layers. 

To add or subtract layers from a selection in the Layers palette, Shift-click (or drag) in the document with the Move 

tool, with the Auto Select Layer option selected. Previously, Shift-clicking linked and unlinked layers. For more infor

mation, see “To select layers in the Layers palette” on page 399. 

Merging layers To merge all visible layers into a new layer, press Alt (Windows) or Option (Mac OS) and choose 

Layer > Merge Visible. Previously you created a new layer and selected it before merging. To merge any two layers, 

select them in the Layers palette and choose Layer > Merge Layers. You can still merge two adjacent layers in the 

Layers palette by selecting the top layer and choosing Layer Merge Down. 

Loading a selection To load a layer as a selection, Control-click (Windows) Command-click (Mac OS) the layer's 

thumbnail in the Layers palette. Previously you could click anywhere in the layer. 

Clipping mask visibility To hide all layers except the clipping mask layer and the layer it is clipped to, Alt-click 

(Windows) or Option-click (Mac OS) the layer’s visibility icon. Previously, Alt-clicking or Option-clicking hid all 

layers. 

File Browser Adobe Bridge handles  all the  tasks that you  previously  did in the  File  Browser.  Flagging  is  now handled  

by the star ratings. Files previously flagged are now marked with one star. In Bridge, Control+D (Windows) or 

Command+D (Mac OS) now duplicates an image rather than deselecting it in the thumbnail view. 

Placing a file Files that you place into Photoshop with the Place command now become Smart Objects. 
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Chapter 2: Tutorials


Tutorials 

Tutorials 
Below you will find a list of tutorials that will help you get started using Adobe Photoshop quickly. Before going


through the tutorials, it’s helpful to know how to create and save documents. See “To create a new image” on page 191


and “To save changes to the current file” on page 654.


For more advanced tutorials, go to Adobe Studio at http://studio.adobe.com. (A one-time registration is required.) 

See also 

“Correct color and tone” on page 13


“Correct defects” on page 16


“Select areas in an image” on page 18


“Create an image using layers” on page 20


“Add shapes to an image” on page 24


“Print with color management” on page 28


Correct color and tone 
You can fix photos that are dull, lack contrast, or have a color cast by adjusting the shadows, midtones, and highlights. 

In this tutorial, you’ll see how to adjust tonality and color. 

1. Evaluate your image. 

Evaluate the image brightness, contrast, and color. This image is dark, has little contrast, and its overall color is shifted 

toward blue. We can fix this image quickly using the Photoshop Levels dialog box. 
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2. Create a new Levels adjustment layer. 

Choose Layer > New Adjustment Layer > Levels and click OK in the New Layer dialog box. Rather than working 

directly on the image, we are going to make the tonal correction in an adjustment layer. Working in an adjustment 

layer leaves the original image untouched so you can discard your changes and restore the original image at any time. 

3. Evaluate the image histogram. 

The histogram in the center of the Levels dialog box shows how pixels are distributed in an image by graphing the 

number of pixels at each intensity level. It displays the relative number of pixels in the shadows (left part of the 

histogram), midtones (middle), and highlights (right). You can see that this image is not using the entire tonal range. 

Pixels don’t extend across the entire length of the histogram. 

4. Set the shadows and highlights. 

Move the black point input slider and the white point input slider (the black triangle and white triangle located 

directly beneath the histogram) inward from the edges of the histogram. The black point input slider adjusts pixels 

to value zero. All pixels at the level you set and any pixels below become black in the image. The white point input 

slider maps values at its position or above to 255, or pure white. After you adjust the sliders, the image will have more 

contrast. 
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5. Adjust the midtones. 

The middle input slider (the gray triangle below the histogram) adjusts the gamma, or contrast, of the midtone 

values. It moves the midtone (level 128) and changes the intensity values of the middle range of gray tones without 

significantly altering the highlights and shadows. 

Move the middle input slider to the left to lighten the image or to the right to darken the image. 

6. Remove the color cast. 

Select the Set Gray Point Eyedropper tool in the Levels dialog box (the middle eyedropper). Click an area in the 

image that should be gray. That area becomes neutral gray, and the color cast is removed. 

The Set Gray Point Eyedropper tool works best on images with easily identified neutral tones. Advanced users often 

use the Levels command to adjust individual channels and remove a color cast. 
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7. Finish up. 

When you’ve made all your adjustments, click OK to close the dialog box and accept your changes. Because you’ve 

used an adjustment layer, you can reopen the dialog box and see the adjustments you made. You can readjust any of 

the settings. 

To reopen the Levels dialog box, in the Layers palette double-click the left thumbnail in the adjustment layer. 

You’ve seen one way to adjust the color and tonal values in your image. Photoshop has many more tools to make these 

adjustments. For more information see “Correcting images in Photoshop” on page 274 and “Color adjustment 

commands” on page 274. 

Correct defects 
Some otherwise excellent photos are marred by blemishes or red eye (the reflection of the flash in the retina of the 

subject). The Red Eye tool fixes red eye with a single click. The Spot Healing Brush easily removes blemishes, 

unwanted objects from a uniform background, and other defects. In this tutorial, you’ll see how to correct red eye 

and remove blemishes. 
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1. Fix the red eye. 

Zoom  in  so  that  you can  easily  see the  problem area.  Select  the Red  Eye tool in the  toolbox and  click in the  red area  

of  the eye  to  correct it.  If  you aren’t satisfied  with  the result,  choose  Edit  > Undo and  try again  using a different  Pupil  

Size and Darken Amount setting. You can change these settings in the option bar at the top of the application 

window. 

2. Fix spots and blemishes. 

Select the Spot Healing Brush tool in the toolbox, and then set options for the tool. In the options bar at the top of 

the application  window, click  the triangle next to Brush  to  open  the Brush  picker. Drag the  Diameter  slider  to  change  

the brush size. Use a brush size that is about the size of the defect you want to fix. 

To remove any unwanted spots, click on the spot or drag the pointer over it. 
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Select areas in an image 
Adobe Photoshop  has selection  tools tailored for  different  selection tasks.  In  this  tutorial, you’ll learn  some  good  uses  

for these tools. 

1. Use the Magic Wand tool to select the background. 

If the object has a well-defined shape against a background that’s primarily one color, you can select the background 

using the Magic Wand tool. 

Select  the Magic  Wand  tool, and  then  click anywhere in the  background. The  marquee around the  background  area  

indicates that the background is now editable. Try dragging a paintbrush over the whole image to verify that only the 

background, and not the object, is affected. 
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2. Invert your selection. 

Because the background is easy to select, inverting the selection is a simple way to select the object. Choose Select > 

Inverse. Notice that the selection border changes to outline the object. 

This technique is useful for selecting objects that are sharply delineated against a background. Now you can make 

edits on the object, leaving the background intact. Choose Select > Deselect to try another selection tool. 

3. Use the Elliptical Marquee tool to select a detail. 

Select the Elliptical Marquee tool, and then drag to draw a selection border around a detail in the object. To 

reposition the selection border as you draw it, hold down the spacebar and drag the selection border to a new 

position. To move the selection border after it’s created, click anywhere inside the border and drag. 

4. Use the Magnetic Lasso to select part of an object. 

Select the Magnetic Lasso tool (hidden in the toolbox behind the Lasso tool), and then click and drag around part of 

the object in your photo. As you drag, Photoshop “snaps” the selection to the edges of the object. 

The Magnetic Lasso tool is especially suited for making freeform selections because it traces the edges of an object. 

It works best on areas with clearly defined edges. 

The tool places anchors as you drag (you can remove anchors by pressing the Delete key). To finish the selection 

border, click the starting anchor point (or double-click). Try moving the selection using the Move tool. Choose Edit > 

Undo to return the selection to its original position. Then choose Select > Deselect to deselect the object. 
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5. Add to a selection. 

Select the Marquee tool, and make a rough selection of the object in your photo. After you make the selection, you 

can add to the selection border without having to start over. Select the Magnetic Lasso tool, and select the Add To 

Selection option in the options bar. Refine your selection by dragging around the outside of the object (notice the 

small plus sign below the tool pointer). Release the mouse. The selection border now includes the area you selected 

with the Magnetic Lasso tool. 

Create an image using layers 
Layers give you complete creative control when you construct an image from different elements, such as a 

background color, text, shapes, and selections from other photographs. In this tutorial, you’ll see how to create a 

multilayered image, apply a layer mask, and then add a text layer. 

1. Open an image in Photoshop. 

Choose File > Open, or double-click a thumbnail in Adobe Bridge. 

By default, the Layers palette should be visible. If not, choose Window > Layers. The Layers palette displays each layer 

in the image, along with a thumbnail of the layer contents. 

 



21 ADOBE PHOTOSHOP CS2 
User Guide 

2. Convert the background layer. 

You need to convert the background to a regular layer if you want to use transparency in the layer.


In the Layers palette, double-click the background layer. Click OK in the New Layer dialog box.


You can now show or hide the layer. Click the eye icon next to a layer. Notice that the icon disappears and the layer


is hidden. Click the empty icon box again. The eye icon and the layer contents reappear.


3. Apply a layer mask. 

You can  use a layer mask to select and  display just the  part  of  the image  you want to use, without  altering  the image.  

Here you’ll mask the entire image except for a circular area containing the flower. 

Click and hold the Rectangular Marquee tool, and then select the Elliptical Marquee tool from the pop-up menu. 

Hold down the Shift key to constrain the selection to a circle, and then drag an area of the image. In the Layers palette, 

click Add Layer Mask. 

Now only the area you selected is visible. You can change the visible area by moving the mask around the image. First 

click the link icon to unlink the mask from the layer. Select the Move tool, click inside the mask, and drag to 

reposition it. When the mask is correctly positioned, click the link icon to relink the mask and the layer. Where you 

move the layer, the mask now moves with it. 
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4. Add a stroke effect. 

Click Add A Layer Style at the bottom of the Layers palette, and select Stroke from the menu. Select Stroke on the 

left side of the Layer Style dialog box, and make changes to the color, size, position, opacity, and blend mode of the 

stroke. 

5. Create a fill and add a new layer. 

Click Create A New Layer to add a new layer to the image. The new layer appears above the selected layer and 

becomes the selected layer. Click the Foreground color swatch and select a color from the Color Picker. Select the 

Paint Bucket tool (it’s hidden under the Gradient tool; click the triangle to show the hidden tools). Then click 

anywhere in the image to create the fill. 

6. Reorder the layers. 

Drag the new layer below the other layers. Changing the stacking order of your layers makes certain parts of the 

image appear in front of or behind other layers. 
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7. Add a text layer. 

In the Layers palette, click the top layer. Select the Text tool, and then click in the image. The I-beam cursor appears. 

In the options bar, change text size, font, style, or color to your liking. When you add text, Photoshop automatically 

places it on its own layer, where you can edit it separately from the rest of the image. 

To  edit  the text,  select  it  with  the Text tool,  and then change any  of  the settings in the  options bar. To move the  text,  

select the Move tool and drag the text. 

8. Add an effect to the text. 

Click Add A Layer Style and select Drop Shadow from the menu. You can change the color or angle of the shadow 

or make other adjustments in the Layer Style dialog box. 

In  the Layers palette,  you can  see which  effects were used on any  layer by clicking the  black triangle next to the  Layer  

Style button. The eye icon next to each layer style acts like a toggle. Click it to apply that style or to remove it from 

that layer. 
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Add shapes to an image 
Adobe Photoshop makes it easy to add shapes to an image: you can draw them using a variety of shape tools or select 

from a large assortment of predrawn shapes. You can arrange vector shapes on separate layers for easy modification 

and overlay  effects.  In  this  tutorial, you’ll learn  how to place  background  and foreground shapes in an image  and add  

some flair with gradient and layer effects. 

1. Open an Image in Photoshop. 

Choose File > Open or double-click a thumbnail in Adobe Bridge. You need to start with an image that has at least 

two layers. 

First you’ll add shapes to create a more interesting background. 
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2. Select the Rectangle tool. 

Select the Rectangle tool from the toolbox and then click the Shape Layers icon in the options bar. Now, the Rectangle 

tool creates a vector shape on a new layer. (Adjacent options let you create a path or a rasterized shape on the current 

layer.) 

3. Create a rectangle shape. 

In the Layers palette, select the bottom layer in your image. Click and drag to create a rectangle covering the right 

half of the image. The rectangle uses the foreground color by default. To change the color, double-click the layer 

thumbnail to display the Color Picker and select a new color. 

4. Add gradients to a shape. 

Now add two more rectangle shapes, this time with gradient effects. Using the Rectangle Shape tool, drag a new 

rectangle to cover the top left quarter of the image. Click the foreground color swatch and select a new color for this 

rectangle. Choose Layer > Change Layer Content > Gradient. Leave Gradient at the default setting, and set Style to 

Linear, angle to –50, and scale to 100%. Repeat these steps to create a second rectangle, this time with an angle of 20. 
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5. Load a complete set of custom shapes. 

Select the Custom Shape tool in the tool options bar. Click the Shape pop-up menu to open the Custom Shapes 

pop-up palette. 

Before selecting a custom shape, let’s add more shapes to the Custom Shapes pop-up palette. Click the black triangle 

and choose Preset Manager  from  the palette  menu. In the  Preset  Manager dialog box, make sure that Custom Shapes  

appears in the Preset Type pop-up menu, and then click Load. Navigate to the Custom Shapes folder (default path: 

Adobe Photoshop CS2/Presets/Custom Shapes) and select All. Click Load to load the full set of custom shapes. This 

loads all the predrawn shapes into the Custom Shapes palette. 

Click Done to close the Preset Manager. 

6. Draw a custom shape. 

Now add a custom shape to the foreground for an overlay effect. Select the top layer of the image, and use the 

foreground color swatch in the toolbox to select a color for the new shape. Select a custom shape from the Custom 

Shapes pop-up palette in the options bar. (For our image, we chose the sunburst shape.) Hold down the Shift key to 

constrain proportions, click and drag in the image to draw the shape. 

Because the  vector  shape is on its  own layer, it is easy to move or resize without  affecting other  elements  of  the image.  

Select  the layer  and then use  the Move tool to move the  shape,  or  choose  Edit  > Free Transform  to  resize, rotate,  flip,  

or skew it. 

 



27 ADOBE PHOTOSHOP CS2 
User Guide 

7. Fill the custom shape with a pattern. 

Next apply one of the Photoshop pattern effects to make the shape more interesting. Select the new shape in the 

Layers palette, and then choose Layer > Change Layer Content > Pattern. In the Pattern Fill dialog box, click the tiny 

inverted triangle next to the pattern swatch to open the Patterns pop-up palette. 

Before selecting a pattern, let’s load more patterns into the Patterns pop-up palette. Click the black triangle in the 

upper right corner of the Patterns pop-up palette and choose Preset Manager from the palette menu. In the Preset 

Manager dialog box, make sure that Patterns appears in the Preset Type pop-up menu, and then click Load. Navigate 

to the Patterns folder (default path: Adobe Photoshop CS2 /Presets/Patterns) and select the patterns you want. Click 

Load to add the selected patterns to the list of patterns in the Preset Manager, and then click Done to close the Preset 

Manager dialog box. 

In the Pattern Fill dialog box, select a pattern and then click OK to apply it to the custom shape. To change your shape 

back to a solid color or to a gradient, choose Layer > Change Layer Content and then choose either Solid Color or 

Gradient. 

8. Add a layer effect to the shape. 

To enhance your shape, you can add layer effects and then apply blending mode. With the shape layer selected, click 

the Add  A Layer  Style icon at the  bottom  of  the Layers palette  and choose Stroke from the  menu. In the  Layer Style  

dialog box, choose settings for the stroke style blending. You can also choose other options from the Styles menu on 

the left. Click OK to apply the layer effect. 

To blend the shape and layer effect with the other layers in the image, choose a blending mode from the Blending 

Mode  menu  at  the upper  left  of  the Layers palette.  To  remove  a layer  effect, select the  Layer Effect icon (a circle with  

an “f ”) in the Layers palette and drag it to the Delete (trash can) icon at the bottom of the Layers palette. 
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Print with color management 
The Photoshop Print With Preview feature helps you achieve predictable results when you print your photos. In this 

tutorial, you’ll learn how to adjust color management settings for the best possible prints. To follow these steps, you 

must have an ICC profile for your printer and paper type. For more information, see “To have Photoshop manage 

colors when printing” on page 715. 

Note: For best results, make sure that your monitor is calibrated and profiled correctly. 

1. Open the Print With Preview dialog box. 

Open your image in Photoshop and choose File > Print With Preview. The Print (Print With Preview) dialog box 

appears. Expand the dialog box by clicking the More Options button on the right side. If it is already expanded, the 

Fewer Options button is visible. 
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2. Set color management options. 

Choose Color Management from the pop-up menu below the preview thumbnail. 

Under Print, select the Document option. The image’s current profile is listed here. 

You want Photoshop  to  handle  the color  conversion  to  the printer’s  color space, so choose Let  Photoshop Determine  

Colors from the Color Handling pop-up menu under Options. 

Note: Later,  when  the printer  driver  dialog  box appears, make sure to turn off  the printer’s  color management so that the  

printer driver settings don’t conflict with the Photoshop color management settings. 

3. Select the printer profile. 

Choose  the profile  for your output device from the  Printer Profile  pop-up  menu. The  profile must be installed  in  the  

correct location to show up. See “To install a color profile” on page 266. 

4. Choose a rendering intent from the menu. 

The rendering intent specifies how Photoshop converts colors to the printers color space. Perceptual or Relative 

Colormetric are good choices for most photographs. 

5. Specify the printer driver settings and print the image. 

Click Print. The Print dialog box for your printer driver appears. The options you see depend on the printer driver. 

Make  sure  to  turn  off the  printer driver’s color  management  because you  chose to have Photoshop  convert the  colors  

to the printer profile. In some printer drivers, you need to select the No Color Management option. If you don’t turn 

off color management in the printer driver, you’ll get unpredictable results. 
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In this tutorial you learned how to print your image using a printer profile. You’ll also want to learn how to preview 

and adjust your image using softproofing to get the results you want from your printer. For more information, see 

“Soft-proofing colors” on page 259. 
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Chapter 3: Work area


Work area basics 

About the Welcome window 
When you launch Photoshop or ImageReady, the Welcome window automatically appears. Select the options in this 

window to learn about Photoshop or ImageReady by reading tutorials or by viewing a movie about new features. In 

Photoshop, you can also learn how to set up a color management system. 

Choose Help > Welcome Screen to display the window if it’s not already open. 

About the work area 
The Photoshop and ImageReady work area is arranged to help you focus on creating and editing images. 

A 

B 

F 

E 

D 

C 

G H 

Photoshop work area 
A. Menu bar B. Options bar C. Toolbox D. Go to Bridge E. Palette well F. Palettes G. Status bar H. Active image area 

The work area has these components: 

Menu bar Contains menus organized by tasks. For example, the Layers menu contains commands for working with


layers. In Photoshop, you can customize the menu bar by showing, hiding, or adding color to menu items.


Options bar Provides options for using a tool.


Toolbox Contains tools for creating and editing images.


Active image area Displays the active open file. The window containing an open file is also called the document


window. 
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Palette well Helps you organize the palettes in your work area. 

Palettes Help you monitor and modify images. You can customize the palette locations in the workspace. In 

Photoshop, you can also show, hide, or add color to items in palette menus. 

In Photoshop, you can change the font size of the text in the options bar, palettes, and tool tips. 

About the status bar 
The status bar is located at the bottom of every document window and displays useful information—such as the 

current magnification  and file size of the  active  image,  and brief  instructions  for using  the active tool.  The status bar  

also displays Version Cue information if you have Version Cue enabled. 

Note: In ImageReady, if the document window is wide enough, two image information boxes appear, enabling you to 

view two different information options for the image at the same time. You can also view copyright and authorship infor

mation that has been added to the file. This information includes standard file information and Digimarc watermarks. 

Photoshop automatically scans opened images for watermarks using the Digimarc Detect Watermark plug-in. If a 

watermark is detected, Photoshop displays a copyright symbol in the image window’s title bar and updates the Copyright 

& URL area of the File Info dialog box. 

To display file information in the document window 
1 Click the triangle in the bottom border of the document window. 

File information view options in Photoshop 

2 Choose a view option from the pop-up menu: 

Note: If you have Version Cue enabled, choose from the Show submenu. 

Version Cue Displays the Version Cue workgroup status of your document, such as open, unmanaged, unsaved, and 

so forth. This option is available only if you have Version Cue enabled. 

Document Sizes Information on the amount of data in the image. The number on the left represents the printing 

size of the image—approximately the size of the saved, flattened file in Adobe Photoshop format. The number on the 

right indicates the file’s approximate size, including layers and channels. 

Document Profile The name of the color profile used by the image. 

Document Dimensions The dimensions of the image. 

Scratch Sizes Information on the  amount  of  RAM and  the scratch disk used to process  the image. The  number  on  

the left represents the amount of memory currently being used by the program to display all open images. The 

number on the right represents the total amount of RAM available for processing images. 

Efficiency The percentage of time actually spent performing an operation instead of reading or writing to the 

scratch disk. If the value is below 100%, Photoshop is using the scratch disk and is therefore operating more slowly. 
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Timing The time it took to complete the last operation. 

Current Tool The name of the active tool. 

32-bit Exposure Option for adjusting the preview image for viewing 32-bits-per-channel high dynamic range 

(HDR) images on your computer monitor. The slider is available only when the document window displays an HDR 

image. 

Click anywhere in the  file  information area of the  status  bar to see  a thumbnail  preview showing  how your document  

(at its current image size) will be printed in the current page setup. 

Click the file information area in the status bar to see a thumbnail preview of how the image will be printed. 

See also 

“Version Cue managed projects” on page 113


“To adjust HDR image viewing” on page 204


To display image information in ImageReady

1 Click an image information box at the bottom of the document window.


2 Select a view option:


Original/Optimized File Size The file size of the original and optimized images. The first value indicates the file size


of the original image. The second value (present if the original image has been optimized) indicates the file size and


file format of the optimized image based on the current settings in the Optimize palette.


Optimized Information The file format, file size, number of colors, and dither percentage of the optimized image.


Image Dimensions The pixel dimensions of the image.


Watermark Strength The strength of the Digimarc digital watermark, if present, in the optimized image.


Undo/Redo Status The number of undos and redos that are available for the image.


Original in Bytes The size, in bytes, of the original, flattened image.


Optimized in Bytes The size, in bytes, of the optimized image.


Optimized Savings The reduction percentage of the optimized image, followed by the difference in bytes between


the original and optimized sizes.


Output Settings Output settings that control how HTML files are formatted, how files and slices are named, and


how background images are handled when you save an optimized image.


Size/Download Time The file size of the optimized image and estimated download time using the selected modem


speed.
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Note: Download  times may  vary  based on Internet traffic  and modem  compression  schemes.  The value  displayed is an  

approximation. 

See also 

“Adding digital copyright information” on page 689 

“To set output options” on page 647 

To jump between Photoshop and ImageReady 
You can easily jump between Photoshop and ImageReady to use features in both applications when preparing 

graphics for the web or other purposes. Jumping between the applications lets you use the full feature sets of both 

applications while maintaining a streamlined workflow. Files and documents updated in one application can be 

automatically updated in the other application. Jumping to an application eliminates the need to close the file in one 

application and reopen it in another. 

❖ Do one of the following: 

•	 Click the Edit In Photoshop button at the bottom of the toolbox.


• Choose File > Edit In Photoshop or File > Edit in ImageReady.


When you jump between Photoshop and ImageReady, the applications use a temp file for transferring changes.


Jumping to other applications 
In addition to jumping to current versions of Photoshop, you can jump to other graphics-editing applications and 

HTML-editing applications from within Photoshop and ImageReady. 

When you install Photoshop or ImageReady, Adobe graphics-editing and HTML-editing applications currently on 

your system are added to the Jump To submenu. You can add more applications, including non-Adobe applications, 

to the Jump To submenu. 

When you jump to a graphics-editing application, the original file is opened in the destination application. When 

you jump to an HTML editor, the optimized file and the HTML file are saved and opened in the destination appli

cation. If the image contains slices, all files for the full image are included. You can set a preference for automatically 

updating files when you jump to Photoshop or ImageReady after editing files in another application. 

To jump to another application from ImageReady 
1 Do one of the following: 

•	 Choose File > Jump To, and choose the desired application from the submenu. 

•	 If the desired application doesn’t appear in the Jump To submenu, choose Other Graphics Editor or Other HTML 

Editor to specify the application. 

2	 If the file has been modified since the last save, choose an option in ImageReady for saving the file: 

•	 Click Save, and save the file with its current name and location. 

•	 Click Save As, and save the file with a new name, in a new location, or both. 
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To add an application to the Jump To submenu

1 Create a shortcut (Windows) or an alias (Mac OS) for the application you want to add to the menu.


2 Drag the icon for the shortcut or alias into the Jump To Graphics Editor folder or the Jump To HTML Editor folder,


located in the Helpers folder inside the Photoshop program folder.


3 Restart ImageReady to view the application in the Jump To submenu.


To enable automatic file updates in ImageReady 
You can set a preference to automatically update a file when returning to ImageReady from another application. 

1	 Do one of the following: 

•	 (Windows) Choose Edit > Preferences > General. 

• (Mac OS) ImageReady > Preferences > General. 

2 Select Auto-Update Open Documents. 

Palettes and menus 

To use palettes 
❖ Palettes help you monitor and modify your work. You can customize the default palette arrangement in the 

following ways: 

•	 To hide or show all palettes, including the toolbox and options bar, press Tab. To hide or show all palettes except 

for the toolbox, press Shift+Tab. 

•	 To display a palette menu, position the pointer on the triangle in the upper right corner of the palette, and press 

the mouse button. 

•	 To change the size of a palette, drag any corner of the palette (Windows) or drag the size box at its lower right 

corner (Mac OS). Some palettes, such as the Color palette, cannot be resized by dragging. 

•	 To collapse a group of palettes to their titles only, double-click the palette’s tab, or click the Minimize button 

(Windows) or the Zoom box (Mac OS). You can open the palette menu even when the palette is collapsed. 
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Using palettes 
A. Click to collapse or expand a Mac OS palette B. Click to collapse or expand a Windows palette C. Click to display the palette menu 

•	 To make a palette appear at the front of its group, click the palette’s tab. 

•	 To move an entire palette group, drag its title bar. 

•	 To rearrange or separate a palette group, drag a palette’s tab. Dragging a palette outside an existing group creates 

a new palette window. 

•	 To move a palette to another group, drag the palette’s tab to that group. 

•	 To dock palettes so that they move together, drag a palette’s tab to the bottom of another palette. 

•	 To move an entire docked palette group, drag its title bar. 

Docking a palette in the palette well 

•	 To return palettes to their default sizes and positions, choose Window > Workspace > Reset Palette Locations 

(Photoshop) or Window > Workspace > Default Palette Locations (ImageReady). 

•	 (ImageReady) To show or hide options for palettes that include hidden options (the Optimize, Layer Options, and 

Slice palettes), click the double triangle icon in a palette tab to cycle through palette displays, or choose Show 

Options or Hide Options from the palette menu. 

A 

B 

ImageReady palette 
A. Click to show options for the palette B. Click to show options for the option set 

About the palette well 
The Photoshop  and ImageReady options  bars  include a palette well that helps  you organize and  manage  palettes. The  

palette well stores, or docks, palettes that you use frequently, so that you don’t have to keep them open on the work 

area. 

The palette well is available only when the screen resolution is greater than 800 pixels x 600 pixels (a setting of at least 

1024 x 768 is recommended). 
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Click a palette’s tab to use the palette in the palette well. The palette remains open until you click outside it or click 

the palette’s tab again. 

Docked palette in the palette well 

To enter values in palettes, dialog boxes, and the tool options bar 
❖ Do any of the following: 

•	 Type a value in the text box, and press Enter or Return (Mac OS only). 

•	 Drag the slider. 

•	 (Photoshop) Move the pointer over the title of a slider or pop-up slider. When the pointer turns to a pointing 

finger, drag the scrubby slider to the left or right. This feature is available only for selected sliders and pop-up 

sliders. 

•	 Drag the dial. 

•	 Click the arrow buttons in the palette to increase or decrease the value. 

•	 (Windows) Click the text box and then use the Up Arrow key and the Down Arrow key on the keyboard to 

increase or decrease the value. 

•	 Select a value from the menu associated with the text box. 

A B C 

D E 

Ways to enter values 
A. Menu arrow B. Scrubby slider C. Text box  D. Dial E. Slider 

See also 

“About scrubby sliders” on page 38 

About pop-up sliders 
Some palettes, dialog boxes, and options bars contain settings that use pop-up sliders (for example, the Opacity 

option in the Layers palette). If there is a triangle next to the text box, you can activate the pop-up slider by clicking 

the triangle. Position the pointer over the triangle next to the setting, hold down the mouse button, and drag the 

slider or angle radius to the desired value. Click outside the slider box or press Enter to close the slider box. To cancel 

changes, press the Esc key. 

To increase or decrease values in 10% increments when the pop-up slider box is open, hold down Shift and press the 

Up Arrow or Down Arrow key. 
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Using different kinds of pop-up sliders
A. Click to open pop-up slider box. B. Drag slider or angle radius.

(Photoshop) You can also “scrub” some pop-up sliders. For example, if you hold the pointer over the word “Fill” or

“Opacity” in the Layers palette, the pointer changes to the Hand icon. Then you can move the pointer left or right to

change the fill or opacity percentage.

About scrubby sliders
In some palettes, dialog boxes, and options bars, you can drag scrubby sliders to change option values. Scrubby

sliders are hidden until you position the pointer over the title of sliders and pop-up sliders. When the pointer changes

to a pointing finger, you drag to the left or right. Holding down the Shift key while dragging accelerates the scrubbing

by a factor of 10.

Hovering over the title of a slider or pop-up slider shows the scrubby slider

About pop-up palettes
Pop-up palettes provide easy access to available options for brushes, swatches, gradients, styles, patterns, contours,

and shapes. You can customize pop-up palettes by renaming and deleting items and by loading, saving, and replacing

libraries. You can also change the display of a pop-up palette to view items by their names, as thumbnail icons, or

with both names and icons.

Click a tool thumbnail in the options bar to show its pop-up palette. Click an item in the pop-up palette to select it.

Viewing the Brush pop-up palette in the options bar
A. Click to show the pop-up palette. B. Click to view the pop-up palette menu.

To rename or delete an item in a pop-up palette
❖ Select an item, click the triangle in the upper right corner of the pop-up palette, and choose one of the following:

Rename Lets you enter a new name for the item.

Delete Deletes an item in the pop-up palette.

A

B

A B
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Note: You can also delete an item in a pop-up palette by holding down Alt (Windows) or Option (Mac OS) and clicking 

the item. 

To customize the list of items in a pop-up palette

1 Click the triangle in the upper right corner of the pop-up palette to view the palette menu.


2 To return to the default library, choose the Reset command. You can either replace the current list or add the


default library to the current list.


3 To load a different library, do one of the following:


•	 Choose the Load command to add a library to the current list. Then select the library file you want to use, and 

click Load. 

•	 Choose the Replace command to replace the current list with a different library. Then select the library file you 

want to use, and click Load. 

•	 Choose a library file (displayed at the bottom of the palette menu). Then click OK to replace the current list, or 

click Append to add the current list. 

4 To  save  the current  list  as  a library  for later  use,  choose  the Save command. Then enter  a name for  the library  file,  

and click Save. 

(Mac OS) Include the extension of the library file name so that you can easily share the libraries across operating 

systems. Select Append File Extension Always in the File Handling Preferences to append extensions to file names. 

To change the display of items in a pop-up palette

1 Click the triangle in the upper right corner of the pop-up palette to view the palette menu.


2 Select a view option: Text Only, Small Thumbnail, Large Thumbnail, Small List, or Large List.


To display context menus 
Context menus  display commands relevant to the  active  tool, selection, or palette.  They  are distinct from the  menus  

across the top of the work area. 

Viewing the context menu for the Eyedropper tool 

1 Position the pointer over an image or palette item. 

2 Right-click (Windows) or Control-click (Mac OS). 
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Tools 

About tools and the toolbox 
The first time you start the application, the toolbox appears at the left side of the screen. You can move the toolbox 

by dragging its title bar. You can also show or hide the toolbox by choosing Window > Tools. 

Some tools in the toolbox have options that appear in the context-sensitive tool options bar. These include the tools 

that let you use type, select, paint, draw, sample, edit, move, annotate, and view images. Other tools in the toolbox 

allow you to change foreground/background colors, go to Adobe Online, work in different modes, and jump between 

Photoshop and ImageReady applications. 

You can expand some tools to show hidden tools beneath them. A small triangle at the lower right of the tool icon 

signals the presence of hidden tools. 

You can view information about any tool by positioning the pointer over it. The name of the tool appears in a tool tip 

below the pointer. Some tool tips contain links leading to additional information about the tool. 
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Toolbox overview 

ndicates default tool  * Keyboard shortcuts appear in parenthesis 

See also 

“Selection tools gallery” on page 42


“Crop and slice tools gallery” on page 42


“Retouching tools gallery” on page 42


“Painting tools gallery” on page 44


“Drawing and type tools gallery” on page 44


“Annotation, measuring, and navigation tools gallery” on page 45


“ImageReady-only tools gallery” on page 45
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Selection tools gallery 
Tools marked with an asterisk are available in Photoshop only. 

The marquee tools make The Move tool moves selec- The lasso tools make free- The Magic Wand tool selects 
rectangular, elliptical, single tions, layers, and guides. hand, polygonal (straight similarly colored areas. 
row, and single column selec edged), and magnetic* (snap
tions. to) selections. 

Crop and slice tools gallery 

The Crop tool trims images. The Slice tool creates slices.	 The Slice Select tool selects 
slices. 

Retouching tools gallery 
Tools marked with an asterisk are available in Photoshop only. 

The Spot Healing Brush The Healing Brush tool* The Patch tool* repairs im- The Red Eye tool* removes 
tool* removes blemishes and paints with a sample or pat- perfections in a selected area the red reflection caused by a 
objects tern to repair imperfections of  an  image using  a sample or  flash. 

in a image. pattern. 
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The Clone Stamp tool paints The Pattern Stamp tool* The Eraser tool erases pixels The Background Eraser 
with a sample of an image. paints with part of an image and restores parts of an im- tool* erases areas to trans

as a pattern. age to a previously saved parency by dragging. 
state. 

The Magic Eraser tool eras- The Blur tool* blurs hard The Sharpen tool* sharpens  The Smudge tool* smudges 
es solid-colored areas to edges in an image. soft edges in an image. data in an image. 
transparency with a single 
click. 

The Dodge tool* lightens ar- The Burn tool* darkens ar- The Sponge tool* changes 
eas in an image. eas in an image. the color saturation of an ar

ea. 
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Painting tools gallery 
Tools marked with an asterisk are available in Photoshop only. 

The Brush tool paints brush The Pencil tool paints hard- The Color Replacement The History Brush tool* 
strokes. edged strokes. tool* replaces a selected  color  paints a copy of the selected 

with a new color. state or snapshot into the cur
rent image window. 

The Art History brush tool* The gradient tools* create The Paint Bucket tool fills

paints with stylized strokes straight-line, radial, angle, similarly colored areas with

that simulate the look of dif- reflected, and diamond the foreground color.

ferent paint styles, using a se- blends between colors.

lected state or snapshot.


Drawing and type tools gallery 
Tools marked with an asterisk are available in Photoshop only. 

The path selection tools* The type tools  create type on The type mask tools* create The pen tools* let you draw

make shape or segment selec- an image. a selection in the shape of smooth-edged paths.

tions showing anchor points, type.

direction lines, and direction

points.


The shape tools and Line The Custom Shape tool* 
tool draw shapes and lines in makes customized shapes se
a normal layer or a shape lected from a custom shape 
layer. list. 
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Annotation, measuring, and navigation tools gallery 
Tools marked with an asterisk are available in Photoshop only. 

The annotation tools* make  The Eyedropper tool sam- The Measure tool* measures  The Hand tool moves an im
notes and audio annotations ples colors in an image. distances, locations, and an age within its window. 
that can be attached to an gles. 
image. 

The Zoom tool magnifies 
and reduces the view of an 
image. 

ImageReady-only tools gallery 

The image  map tools  define The Image Map Select tool The Tab Rectangle tool The Toggle Image  Map Visi
image map areas in an im selects image maps. draws a long rectangle with bility tool toggles between 
age. the top corners rounded. showing and hiding image 

The Pill Rectangle tool maps. 
draws a rectangle with 
rounded corners. 

The Toggle Slices Visibility The Preview Document tool The Preview in Default 
tool toggles between showing previews rollover effects di- Browser tool previews ani
and hiding slices in an image.  rectly in ImageReady. mations in a web browser. 
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To use a tool 
❖ Do one of the following: 

•	 Click a tool  in  the toolbox. If there  is  a small  triangle  at  a tool’s lower  right corner,  hold  down  the mouse  button  to  

view the hidden tools. Then click the tool you want to select. 

•	 Press the tool’s keyboard shortcut. The keyboard shortcut is displayed in its tool tip. For example, you can select 

the Move tool by pressing the V key. 

A 

B 

D E 

C 

F 

Using the selecting tools 
A. Toolbox B. Active tool C. Hidden tools D. Tool name E. Tool shortcut F. Hidden tool triangle 

Note: In ImageReady, click the downward-pointing triangle at the bottom of the hidden tools list to tear off a floating 

tool palette. Click the button at the top right (Windows) or top left (Mac OS) of the floating tool palette to close it. 

Clicking the triangle to “tear off ” a floating tool palette 

To cycle through hidden tools 
You can  select  a preference that allows you  to  cycle through  a set  of  hidden  tools by holding down the  Shift key. When  

this preference is not selected, you can cycle through a set of hidden tools by pressing the shortcut key (without 

holding down Shift). 

1 Choose Edit > Preferences > General (Windows) or Photoshop > Preferences > General (Mac OS). 

2 Select Use Shift Key For Tool Switch. 

To display or hide tool tips 
1 Do one of the following: 

•	 (Windows) Choose Edit > Preferences > General. 

• (Mac OS) Choose Photoshop > Preferences > General or choose ImageReady > Preferences > General. 

2 Select or deselect Show Tool Tips. 

Note: Tool tips may not be available in some dialog boxes. 
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About tool pointers 
In  most  cases,  the pointer  for a tool  is  the same as the  icon  for that tool;  you see  that  pointer when you  select  the tool.  

The default pointer for the marquee tools is the cross-hair pointer ; for the text tool, the default pointer is the I

beam ; and for the painting tools the default pointer is the Brush Size icon. 

Each default pointer has a different hotspot, where  an  effect  or  action  in  the image  begins. With most tools, you  can  

switch to precise cursors, which appear as cross hairs centered around the hotspot. 

To change tool pointers 
1 Do one of the following: 

•	 (Photoshop) Choose Edit > Preferences > Display & Cursors (Windows) or choose Photoshop > Preferences > 

Display & Cursors (Mac OS). 

•	 (ImageReady) Choose Edit > Preferences > Cursors (Windows) or choose ImageReady > Preferences > Cursors 

(Mac OS). 

2 Choose a tool pointer setting under Painting Cursors and/or Other Cursors: 

Standard Displays pointers as tool icons. 

Precise Displays pointers as cross hairs. 

Brush Size (painting cursors only) Displays the painting tool cursors as brush shapes representing the size of the


current brush. Brush Size cursors may not appear for very large brushes.


3 (Photoshop) Select Brush Cursor options if you selected Brush Size as the tool pointer setting:


Normal The pointer outline corresponds to approximately 50% of the area that the tool will affect. This option


shows the pixels that would be most visibly affected.


Full Size The pointer outline corresponds to nearly 100% of the area that the tool will affect, or nearly all the pixels


that would be affected.


Always Show Crosshair Displays cross hairs in the center of the brush shape. 

4 Click OK.


The Painting Cursors options control the pointers for the following tools:


•	 (Photoshop) Eraser, Pencil, Paintbrush, Healing Brush, Rubber Stamp, Pattern Stamp, Smudge, Blur, Sharpen, 

Dodge, Burn, and Sponge tools 

• (ImageReady) Paintbrush, Pencil, and Eraser tools 

The Other Cursors options control the pointers for the following tools: 

•	 (Photoshop) Marquee, Lasso, Polygonal Lasso, Magic Wand, Crop, Slice, Patch, Eyedropper, Pen, Gradient, Line, 

Paint Bucket, Magnetic Lasso, Magnetic Pen, Freeform Pen, Measure, and Color Sampler tools 

•	 (ImageReady) Marquee, Lasso, Magic Wand, Eyedropper, Paint Bucket, and Slice tools 

To toggle between standard and precise cursors in some tool pointers, press Caps Lock. 
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Using the options bar 
The options bar appears below the menu bar at the top of the work area. The options bar is context sensitive—it 

changes as you select different tools. Some settings in the options bar (such as painting modes and opacity) are 

common to several tools, and some (such as the Auto Erase setting for the Pencil tool) are specific to one tool. 

You can move the options bar in the work area by using the gripper bar, and you can dock it at the top or bottom of 

the screen. Tool tips appear when you position the pointer over a tool. To show or hide the options bar, choose 

Window > Options. 

A B 

Lasso options bar 
A. Gripper bar B. Tool tip 

(Photoshop) To return tools to their default settings, right-click (Windows) or Control-click (Mac OS) the tool icon 

in the options bar, and then choose Reset Tool or Reset All Tools from the context menu. 

(ImageReady) To return tools to their default settings, choose Edit > Preferences > General (Windows), or choose 

ImageReady > Preferences > General (Mac OS) and then click Reset All Tools. 

For more information on setting options for a specific tool, search for the tool’s name in Photoshop Help. 

Using tool presets 
Tool presets let you save and reuse tool settings. You can load, edit, and create libraries of tool presets using the Tool 

Preset picker in the options bar, the Tool Presets palette, and the Preset Manager. 

To choose a tool preset, click the Tool Preset picker in the options bar, and select a preset from the pop-up palette. 

You can also choose Window > Tool Presets and select a preset in the Tools Presets palette. 

A 

B 

C 

Viewing the Tool Preset picker 
A. Click the Tool Preset picker in the options bar to show the Tool Preset pop-up palette. B. Select a preset to change the tool’s options to the 
preset, which applies each time you select the tool until you choose Reset Tool from the palette menu. C. Deselect to show all tool presets; select 
to show presets for only the tool selected in the toolbox. 

To create a tool preset

1 Choose a tool, and set the options you want to save as a tool preset in the options bar.


2 Do one of the following:


• Click the Tool Preset button next to the tool at the left of the options bar. 

• Choose Window > Tool Presets to display the Tool Presets palette. 
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3 Do one of the following: 

• Click the Create New Tool Preset button . 

• Choose New Tool Preset from the palette menu. 

4 Enter a name for the tool preset, and click OK. 

To change the list of tool presets 
❖ Click the triangle to open the Tool Presets pop-up palette menu and choose one of the following: 

Show All Tool Presets Shows all loaded presets. 

Sort By Tool Sorts the presets by tool. 

Show Current Tool Presets Shows only the loaded presets for the active tool. You can also select the Current Tool 

Only option in the Tool Presets pop-up palette. 

Text Only, Small Text, or Large Text Determines how presets are displayed in the pop-up palette. 

Note: To create, load, and manage libraries of tool presets, see “About pop-up palettes” on page 38 and “About the Preset 

Manager” on page 67. 

Working with files 

To close windows 
❖ Do one of the following: 

• Choose File > Close to close the active window. 

• (Photoshop) Choose File > Close All to close all windows. 

• (ImageReady and Windows) Choose Window > Arrange > Close All to close all windows. 

To duplicate an image in Photoshop 
You can duplicate an entire image (including all layers, layer masks, and channels) into available memory without


saving to disk.


1 Open the image you want to duplicate.


2 Choose Image > Duplicate.


3 Enter a name for the duplicated image.


4 If you want to duplicate the image and merge the layers, select Duplicate Merged Layers Only. To preserve the


layers, make sure this option is deselected.


5 Click OK.


To duplicate an image in Photoshop and automatically append the word “copy” to its file name, hold down Alt 

(Windows) or Option (Mac OS) when you choose Image > Duplicate. 
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To duplicate an image in ImageReady 
Using duplicates in ImageReady lets you experiment and then compare several versions of the optimized image to the 

original. 

1 Open the image you want to duplicate. 

2 Do one of the following: 

• Select the Original tab at the top of the image window.


• Select the Optimized tab at the top of the image window.


3 Do one of the following:


• Hold down Alt (Windows) or Option (Mac OS), and drag the Original or Optimized tab from the image window.


• Choose Image > Duplicate.


4 Name the duplicate, specify whether to flatten the layers, and click OK.


Note: When you duplicate an image in Optimized, 2-Up, or 4-Up view, the duplicate image appears in the Original view 

in the duplicate image window. If you want a duplicate optimized image to appear in the Optimized, 2-Up, or 4-Up view, 

duplicate the original image, and then select the Optimized, 2-Up, or 4-Up tab in the duplicate image window. 

To close a file

1 Choose File > Close or File > Close All (Photoshop).


2 Choose whether or not to save the file:


• Click Yes (Windows) or Save (Mac OS) to save the file. 

• Click No (Windows) or Don’t Save (Mac OS) to close the file without saving it. 

To quit Photoshop or ImageReady 
1 Do one of the following: 

• (Windows) Choose File > Exit. 

• (Mac OS) Choose Photoshop > Quit or ImageReady > Quit. 

2 Choose whether or not to save any open files: 

• Click Yes (Windows) or Save (Mac OS) to save a file. 

• Click No (Windows) or Don’t Save (Mac OS) to close a file without saving it. 

Viewing images 

To change the screen mode 
You can use the screen mode options to view your images on your entire screen. You can show or hide the menu bar, 

title bar, and scroll bars. You can choose from the following: 

• The Standard screen mode is the default view, with menu bars, scroll bars, and other screen elements visible. 

• Full Screen With Menu Bar view enlarges your view of an image but keeps the menu bar visible. 

• (Photoshop) Full Screen mode lets you move the image around the screen to view different areas. 
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(Photoshop) Dragging an image in Full Screen mode

❖ Do one of the following:

• To display the default window, with the menu bar at the top and scroll bars on the side, choose View > Screen

Mode > Standard, or click the Standard button  in the toolbox.

• To display a full-screen window with a menu bar and a 50% gray background, but no title bar or scroll bars, choose

View > Screen Mode > Full Screen With Menu Bar, or click the Full Screen With Menu Bar button  in the

toolbox.

• To display a full-screen window with only a black background (no title bar, menu bar, or scroll bars), choose

View > Screen Mode > Full Screen, or click the Full Screen button  in the toolbox.

To view another area of an image
❖ Do one of the following:

• Use the window scroll bars.

• Select the Hand tool and drag to pan over the image.

Dragging the Hand tool to view another area of an image

• Drag the colored box (proxy view area) in the Navigator palette.

To use the Hand tool while another tool is selected, hold down the spacebar as you drag in the image.
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To use the Navigator palette 
You use the Navigator palette to quickly change the view of your artwork using a thumbnail display. The colored box 

in the Navigator (called the proxy view area) corresponds to the currently viewable area in the window. 

❖ Do one or more of the following: 

•	 To display the Navigator palette, select Window > Navigator. 

•	 To change the magnification, type a value in the text box, click the Zoom Out or Zoom In button, or drag the zoom 

slider. 

•	 To move the view of an image, drag the proxy view area in the image thumbnail. You can also click the image 

thumbnail to designate the viewable area. 

•	 To change the color of the proxy view area, select Palette Options from the palette menu. Select a preset color from 

the Color pop-up menu, or double-click the color box to choose a custom color. 

A 

C 

B 

D E F G 

Navigator palette 
A. Palette menu button B. Thumbnail display of artwork C. Proxy preview area D. Zoom text box E. Zoom Out button F. Zoom 
slider G. Zoom In button 

To zoom in or out 
❖ Do any of the following: 

•	 (Photoshop) Select the Zoom tool , and click either the Zoom In  or Zoom Out button  in the options 

bar. Click the area you want to magnify. 

•	 Select the Zoom tool. The pointer becomes a magnifying glass with a plus sign in its center. Click the center of the 

area that you want to magnify, or hold down Alt (Windows) or Option (Mac OS) and click the center of the area 

that you want to reduce. Each click magnifies or reduces the view to the previous preset percentage. 

Note: When  you use  the Zoom or Zoom Out  tool, each click  magnifies or reduces  the image  to  the next  preset  percentage  

and centers the display around the point you click. When the image has reached its maximum magnification level of 

1600% or minimum size of 1 pixel, the magnifying glass appears empty. 

•	 Select the Zoom tool and drag a dotted rectangle, called a marquee, around the  area  you want to magnify. To move  

the marquee around the artwork, hold down the spacebar and continue dragging until the marquee is in the 

desired location. 

•	 Choose View > Zoom In or View > Zoom Out. When the image reaches its maximum or minimum magnification, 

the command is dimmed. 

•	 Set the zoom level at the lower left corner of the document window or in the Navigator palette (Photoshop). 

•	 To display a file at 100%, choose View > Actual Pixels (Photoshop) or View > Actual Size (ImageReady). 

•	 To change the view to fit the document window, choose View > Fit In Window. 

(Photoshop) If your mouse has a scroll wheel, you can use it to zoom in or out after selecting the Zoom tool. Choose 

Edit > Preferences > General (Windows) or Photoshop > Preferences > General (Mac OS) and select the Zoom With 

Scroll Wheel option to enable this behavior. 
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To magnify by dragging

1 Select the Zoom tool.


2 Drag over the part of the image that you want to magnify.


Dragging the Zoom tool to magnify the view of an image 

The area inside  the zoom marquee  is  displayed at the  highest possible magnification. To move the  marquee around  

the artwork in Photoshop, begin dragging a marquee and then hold down the spacebar while dragging. 

To display an image at 100% 
❖ Do one of the following: 

• Double-click the Zoom tool in the toolbox. 

• Choose View > Actual Pixels (Photoshop) or View > Actual Size (ImageReady). 

• Enter 100% in the Status Bar and press Enter (Windows) or Return (Mac OS). 

Note: The 100% view of an image displays an image as it will appear in a browser (based on the monitor resolution and 

the image resolution). 

To fit an image to the screen 
❖ Do one of the following: 

• Double-click the Hand tool in the toolbox. 

• Choose View > Fit On Screen. 

• Select a zoom tool or the Hand tool, and click the Fit On Screen button in the options bar. 

These options scale both the zoom level and the window size to fit the available screen space. 

To automatically resize the window when zooming 
❖ With the Zoom tool active, select Resize Windows To Fit in the options bar. The window is resized when you 

magnify or reduce the view of the image. 

When Resize Windows To Fit is deselected (the default), the window maintains a constant size regardless of the 

image magnification. This can be helpful when using smaller monitors or working with tiled views. 

Note: To automatically resize the window when using keyboard shortcuts to reduce or magnify an image view, choose 

Edit > Preferences > General (Windows) or Photoshop > Preferences > General (Mac OS), then select the Zoom Resizes 

Windows preference and click OK. 

 



54 ADOBE PHOTOSHOP CS2 
User Guide 

To view images in multiple windows 
The document window is where your images appear. You can open multiple windows to display different images or 

different views of the same one. A list of open windows appears in the Window menu. To bring an open image to the 

front, choose the file name from the bottom of the Window menu. Available memory may limit the number of 

windows per image. 

(ImageReady) The document window lets you switch easily between original and optimized views of an image using 

tabs, and to view the original image and multiple versions of an optimized image simultaneously. 

1	 Do one of the following: 

•	 Choose Window > Arrange > New Window For [Image File Name]. 

• (ImageReady) Drag any tab away from the document window.


2 If you want to arrange the windows, choose Window > Arrange and then choose one of the following:


Cascade Displays windows stacked and cascading from the upper left to the lower right of the screen.


Tile Horizontally or Tile Vertically Displays windows edge to edge. As you close images, the open windows are 

resized to fill the available space. 

(Windows) Arrange Icons Aligns minimized image windows along the bottom of the screen. 

(Photoshop) You can use the Hand tool’s Scroll All Windows option to scroll through all open images. Select it in the 

options bar and drag in one image to scroll through all visible images. 

To zoom into or out of multiple images

1 Open one or more images, or copies of a single image.


2 Choose Window > Arrange > Tile Horizontally/Tile Vertically to display the images edge to edge.


3 Select the Zoom tool, and then do one of the following:


•	 Select Zoom All Windows in the options bar, and then click one of the images. The other images zoom in or out 

at the same time. 

•	 Choose Window > Arrange > Match Zoom. Hold down the Shift key and click one of the images. The other images 

zoom in or out at the same magnification. 

To match locations in images

1 Open one or more images, or multiple copies of a single image.


2 Choose either Window > Arrange > Tile Horizontally/Tile Vertically to display the images edge to edge.


3 Select the Hand tool, and then do one of the following:


•	 Select Scroll All Windows in the options bar, and then drag to view another area in one of the images. 

•	 Choose Window > Arrange > Match Location, hold down the Shift key, and click or drag an area in one of the 

images. The other images snap to the corresponding area. 

To match zoom and locations in images

1 Open one or more images, or multiple copies of a single image.


2 Choose Window > Arrange > Tile.


3 Choose Window > Arrange > Match Zoom And Location.
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Without Match Zoom And Location (top), and with Match Zoom And Location (bottom) selected 

4	 Select the Zoom tool or the Hand tool. 

5 Select one of the images, hold down the Shift key, and click in or drag an area of an image. The other images are 

magnified to the same percentage and snap to the area you clicked. 

About the Info palette 
The Info palette shows the color values beneath the pointer and, depending on the tool in use, gives other useful 

information. In Photoshop, the Info palette also displays a hint on using the selected tool, gives document status 

information, and can display 8-bit, 16-bit, or 32-bit values. 

(Photoshop) The Info palette displays the following information: 

•	 Depending on the option you specify, the Info palette displays 8-bit, 16-bit, or 32-bit values. 

•	 When displaying CMYK values, the Info palette displays an exclamation point next to the CMYK values if the 

color beneath the pointer or color sampler is out of the printable CMYK color gamut. 

•	 When a marquee tool is being used, the Info palette displays the x and y coordinates of the pointer position and 

the width (W) and height (H) of the marquee as you drag. 

•	 When the Crop tool or Zoom tool is being used, the Info palette displays the width (W) and height (H) of the 

marquee as you drag. The palette also shows the angle of rotation of the crop marquee. 

•	 When the Line tool, the Pen tool, or Gradient tool is being used, or when a selection is being moved, the Info 

palette displays the x and y coordinates of your starting position, the change in X (DX), the change in Y (DY), the 

angle (A), and the distance (D) as you drag. 

•	 When a two-dimensional transformation command is being used, the Info palette displays the percentage change 

in width (W) and height (H), the angle of rotation (A), and the angle of horizontal skew (H) or vertical skew (V). 

•	 When any color adjustment dialog box (for example, Curves) is being used, the Info palette displays before-and-

after color values for the pixels beneath the pointer and beneath color samplers. 

•	 If the Show Tool Hints option is enabled, you see hints for using the tool selected in the toolbox. 

•	 Depending on the options selected, the Info palette displays status information, such as document size, document 

profile, document dimensions, scratch sizes, efficiency, timing, and current tool. 

(ImageReady) The Info palette displays the following information: 

•	 The RGB numeric values of the color beneath the pointer 
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•	 The Opacity value of the pixels beneath the pointer 

•	 The hexadecimal value of the color beneath the pointer 

•	 The position, in the indexed color table, of the color beneath the pointer 

•	 The x and y coordinates of the pointer 

•	 The x and y coordinates of your starting position (before you click the image) and your ending position (as you 

drag in the image) when you use the Marquee tool, the shape tools, the Crop tool, and the Slice tool 

•	 The width (W) and height (H) of the selection as you drag when you use the Crop tool, the shape tools, the Slice 

tool, or the Zoom tool 

•	 The percentage change in width (W) and height (H), the angle of rotation (A), and the angle of horizontal skew 

(H) or vertical skew (V) when you use a Transform or Free Transform command 

See also 

“Viewing the color values of pixels” on page 279 

To use the Info palette 
The Info palette displays file information about an image and also provides feedback about the color values as you 

move a tool pointer over an image. Make sure the Info palette is visible in your work area if you want to view infor

mation while dragging in the image. 

1	 (Optional) Do one of the following if you need to display the Info palette: 

•	 Click the Info palette tab if it’s docked with other palettes. 

•	 Choose Window > Info. File information about the image is displayed at the bottom of the Info palette. You can 

change the information displayed by clicking the triangle in the upper right corner of the palette and choosing 

Palette Options from the palette menu. 

2 (Optional, Photoshop) Set the options for the information you want displayed in the Info Palette by doing any of 

the following: 

•	 Choose Palette Options from the Info palette menu and specify options in the Info Palette Options dialog box. 

•	 Click an eyedropper icon and choose display options from the pop-up menu. You can also use the pop-up menu 

to specify whether the Info palette displays 8-bit, 16-bit, or 32-bit values. 

•	 Click the cursor coordinates icon  and choose a unit of measurement.


3 Select a tool.


4 Move the pointer in the image, or drag in the image to use the tool. The following information may appear,


depending on which tool you’re using: 

Displays the numeric values for the color beneath the pointer. 

Displays the x and y coordinates of the pointer. 

Displays the width (W) and height (H) of a marquee or shape as you drag, or the width and height of an active 

selection. 
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To change the Info palette options

1 Click the triangle in the upper right corner to open the Info palette menu and choose Palette Options.


2 In the Info Palette Options dialog box, for First Color Readout, choose one of the following display options:


Actual Color Displays values in the current color mode of the image.


Proof Color Displays values for the output color space of the image.


A color mode Displays the color values in that color mode.


Total Ink Displays the total percentage of all CMYK ink at the pointer’s current location, based on the values set in


the CMYK Setup dialog box.


Opacity Displays the opacity of the current layer. This option does not apply to the background.


You can  also  set the  readout options  by  clicking  the eyedropper icon in the  Info  palette.  In  addition  to  the First  Color  

Readout options, you can also display 8-bit, 16-bit, or 32-bit values. 

3 For Second Color Readout, choose a display option from the list in step 2. For the second readout, you can also 

click the eyedropper icon in the Info palette and choose readout options from the pop-up menu. 

Clicking an eyedropper icon and choosing a readout mode from the pop-up menu 

4 For Ruler Units, choose a unit of measurement.


5 Under Status information, select from the following to display file information in the Info palette:


Document Sizes Displays information on the amount of data in the image. The number on the left represents the


printing size of the image—approximately the size of the saved, flattened file in Adobe Photoshop format. The


number on the right indicates the file’s approximate size including layers and channels.


Document Profile Displays the name of the color profile used by the image.


Document Dimensions Displays the dimensions of the image.


Scratch Sizes Displays information on the amount of RAM and the scratch disk used to process the image. The


number on the left represents the amount of memory that is currently being used by the program to display all open


images. The number on the right represents the total amount of RAM available for processing images.


Efficiency Displays the percentage of time spent performing an operation instead of reading or writing to the


scratch disk. If the value is below 100%, Photoshop is using the scratch disk and is therefore operating more slowly.


Timing Displays the amount of time it took to complete the last operation.


Current Tool Displays the name of the active tool.


6 (Optional) Select Show Tool Hints to display a hint for using a selected tool at the bottom of the Info palette.


7 Click OK.
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To change measurement units, click the cross-hair icon in the Info palette and choose from the menu. 

Rulers, the grid, and guides 

About rulers 
Rulers  help  you position images or elements precisely. When visible, rulers appear along the top and left side of the 

active window. Markers in the ruler display the pointer’s position when you move it. Changing the ruler origin (the 

(0, 0) mark on the top and left rulers) lets you measure from a specific point on the image. The ruler origin also deter

mines the grid’s point of origin. 

To show or hide rulers, choose View > Rulers. 

To change a ruler’s zero origin 
1 (Optional) Choose View > Snap To, then choose any combination of options from the submenu. This snaps the 

ruler origin to guides, slices, or document bounds. In Photoshop, you can also snap to the grid. 

2 Position the pointer over the intersection of the rulers in the upper left corner of the window, and drag diagonally 

down onto the image. A set of cross hairs appears, marking the new origin on the rulers. 

In Photoshop, you can hold down Shift as you drag to make the ruler origin snap to the ruler ticks. 

To reset a ruler’s origin to its default value, double-click the upper left corner of the ruler. 

Dragging to create new ruler origin 

See also 

“To use snapping” on page 62 
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To change the unit of measurement 
1 Do one of the following: 

•	 Double-click a ruler. 

•	 (Windows) Choose Edit > Preferences > Units & Rulers, or right-click the ruler and then choose a new unit from 

the context menu. 

•	 (Mac OS) Choose Photoshop > Preferences > Units & Rulers, or Control-click the ruler and then choose a new 

unit from the context menu. 

2	 For Rulers, choose a unit of measurement. 

Note: Changing the units on the Info palette automatically changes the units on the rulers. 

3 For Point/Pica Size, choose from the following options:


PostScript (72 points per inch) Sets a unit size compatible for printing to a PostScript device.


Traditional Uses 72.27 points per inch, as traditionally used in printing. 

4	 Click OK. 

To specify columns for an image 
Columns help you position images or elements precisely. The New, Image Size, and Canvas Size commands let you 

specify image width in terms of columns. Using columns is convenient when you plan to import an image into a 

page-layout program, such as Adobe InDesign®, and you want the image to fit exactly within a certain number of 

columns. 

1 Choose Edit > Preferences > Units & Rulers (Windows) or Photoshop > Preferences > Units & Rulers (Mac OS). 

2 Enter values for Width and Gutter. 

About the Measure tool 
The Measure tool  helps you position images or elements precisely. The Measure tool calculates the distance 

between any two points in the work area. When you measure from one point to another, a nonprinting line is drawn, 

and the options bar and Info palette show the following information: 

•	 The starting location (X and Y) 

•	 The horizontal (W) and vertical (H) distances traveled from the x and y axes 

•	 The angle measured relative to the axis (A) 

•	 The total distance traveled (D1) 

•	 The two distances traveled (D1 and D2), when you use a protractor 

All measurements except the angle are calculated in the unit of measure currently set in the Units & Rulers preference 

dialog box. 

If your document has an existing measuring line, selecting the Measure tool causes it to be displayed. 
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To measure between two points 
1 Select the Measure tool 

2 Drag from the starting point to the ending point. Hold down the Shift key to constrain the tool to 45˚ increments. 

3 To create a protractor from an existing measuring line, Alt-drag (Windows) or Option-drag (Mac OS) at an angle 

from one end of the measuring line, or double-click the line and drag. Hold down the Shift key to constrain the tool 

to multiples of 45˚. 

. 

To edit a measuring line or protractor 
1 Select the Measure tool 

2 Do one of the following: 

. 

•	 To resize the line, drag one end of an existing measuring line. 

•	 To move the line, place the pointer on the line away from either endpoint, and drag the line. 

•	 To remove the line, place the pointer on the line away from either endpoint, and drag the line out of the image. 

Note: You can drag out a measure line on an image feature that should be horizontal or vertical, and then choose 

Image > Rotate Canvas > Arbitrary. The correct angle of rotation required to straighten the image is automatically 

entered into the Rotate Canvas dialog box. 

About guides and the grid 
Guides  and the  grid  help  you position images or elements precisely. Guides appear as nonprinting  lines  that  float over  

the image. You can move and remove guides.You can also lock them so that you don’t move them by accident. 

The grid is useful for  laying  out elements symmetrically. The  grid  appears by default  as  nonprinting lines  but can  also  

be displayed as dots. 

Guides and grids behave in similar ways: 

•	 Selections, selection borders, and tools snap to a guide or the grid when dragged within 8 screen (not image) 

pixels. Guides also snap to the grid when moved. You can turn this feature on and off. 

•	 Guide spacing, along with guide and grid visibility and snapping, is specific to an image. 

•	 Grid spacing, along with guide and grid color and style, is the same for all images. 

You can use Smart Guides to help align shapes, slices, and selections. They appear automatically when you draw a 

shape, or create a selection or slide. You can hide Smart Guides if you need to. 

Smart guides appear automatically to help you align shapes, slices, and selections. 

Note: In ImageReady, you can create slices from guides. 
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See also 

“To create slices from guides” on page 573 

To show or hide a grid, guides, or smart guides 
❖ Do one of the following: 

•	 (Photoshop) Choose View > Show > Grid. 

•	 Choose View > Show > Guides. 

•	 View > Show > Smart Guides. 

•	 Choose View > Extras. In Photoshop, this command also shows or hides layer edges, selection edges, target paths, 

slices, and annotations, and, in ImageReady, selection edges, slices, auto slices, image maps, text bounds, and text 

selections. 

To place a guide 
1 If the rulers are not visible, choose View > Rulers. 

Note: For the most accurate readings, view the image at 100% magnification or use the Info palette. 

2	 Do one of the following to create a guide: 

•	 (Photoshop) Choose View > New Guide. In the dialog box, select Horizontal or Vertical orientation, enter a 

position, and click OK. 

•	 (ImageReady) Choose View > Create Guides. In the dialog box, specify guide options and click OK. 

•	 Drag from the horizontal ruler to create a horizontal guide. 

Dragging to create a horizontal guide 

•	 Hold down Alt (Windows) or Option (Mac OS), and drag from the vertical ruler to create a horizontal guide. 

•	 Drag from the vertical ruler to create a vertical guide. 

•	 Hold down Alt (Windows) or Option (Mac OS), and drag from the horizontal ruler to create a vertical guide. 

•	 (Photoshop) Hold down Shift  and drag from the  horizontal  or  vertical  ruler to create a guide that snaps  to  the ruler  

ticks. The pointer changes to a double-headed arrow when you drag a guide. 

3	 (Optional) If you want to lock all guides, choose View > Lock Guides. 
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To move a guide 
1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to activate the Move tool. (This


option does not work with the Hand tool or the Slice tool
 .)


2 Position the pointer over the guide (the pointer turns into a double-headed arrow).


3 Move the guide in any of the following ways:


•	 Drag the guide to move it. 

•	 Change the guide from horizontal to vertical, or vice versa, by holding down Alt (Windows) or Option (Mac OS) 

as you click or drag the guide. 

•	 (Photoshop) Align the guide with the ruler ticks by holding down Shift as you drag the guide. The guide snaps to 

the grid if the grid is visible and View > Snap To > Grid is selected. 

To remove guides from the image 
❖ Do one of the following: 

•	 To remove a single guide, drag the guide outside the image window. 

•	 To remove all guides, choose View > Clear Guides. 

To set guide and grid preferences 
1 Do one of the following: 

•	 (Windows) Choose Edit > Preferences > Guides, Grid, & Slices. 

•	 (Mac OS) Choose Photoshop > Preferences > Guides, Grid, & Slices. 

2 For Color, choose a color for the guides, the grid, or both. If you choose Custom, click the color box, choose a


color, and click OK.


3 For Style, choose a display option for guides or the grid, or both.


4 For Gridline Every, enter a value for the grid spacing. For Subdivisions, enter a value by which to subdivide the


grid.


If desired, change the units for this option. The Percent option creates a grid that divides the image into even sections.


For example, choosing 25 for the Percent option creates an evenly divided 4-by-4 grid.


5	 Click OK. 

See also 

“About the Color palette” on page 505 

To use snapping 
Snapping helps with precise placement of selection edges, cropping marquees, slices, shapes, and paths. However, 

sometimes snapping prevents you from correctly placing elements. You can enable or disable snapping using the 

Snap command. You can also specify different elements to which you want to snap when snapping is enabled. 

❖ Choose View > Snap. A check mark indicates that snapping is enabled. 
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To specify what to snap to 
❖ Choose View > Snap To, and choose one or more options from the submenu: 

Guides Snaps to guides. 

Grid Snaps to the grid. You cannot select this option when the grid is hidden. 

Slices Snaps to slice boundaries. You cannot select this option when slices are hidden. 

Document Bounds Snaps to the edges of the document. 

All Selects all Snap To options. 

None Deselects all Snap To options. 

A check mark indicates that the option is selected and snapping is enabled. 

If you want to enable snapping for only one option, make sure the Snap command is disabled, and then choose 

View > Snap To and choose an option. This automatically enables snapping for the selected option, and deselects all 

other Snap To options. 

To show or hide Extras 
Guides, grid, target paths, selection edges, slices, image maps, text bounds, text baselines, text selections, and annota

tions are nonprinting Extras that help you select, move, or edit images and objects. You can turn on or off an Extra 

or any combination of Extras without affecting the image. You can also show or hide Extras by choosing the Extras 

command in the View menu. 

Hiding Extras only suppresses the display of Extras. It does not turn off these options. 

❖ Do one of the following: 

•	 To show or hide Extras, choose View > Extras. A check mark appears next to all shown Extras in the Show 

submenu. 

•	 To turn on and show an Extra from a group of hidden Extras, choose View > Show and choose an Extra from the 

submenu. 

•	 To turn on and show all available Extras, choose View > Show > All. 

•	 To turn off and hide all Extras, choose View > Show > None. 

Note: Showing Extras causes color samplers to be shown as well, even though color samplers are not an option in the 

Show submenu. 
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Customizing the work area 

To manage workspaces 
You can customize the palette locations in a workspace. You can save custom workspaces and switch between them. 

In Photoshop, you can also customize menu items and keyboard shortcuts. In ImageReady, preset workspaces are 

available for certain tasks. 

❖ Choose Window > Workspace, and do one of the following: 

•	 To switch to a workspace, choose a workspace from the submenu. 

(Photoshop) Assign keyboard shortcuts to each workspace to navigate among them quickly. 

•	 (ImageReady) To switch to a factory-preset workspace for authoring interactive images or optimizing images for 

the web, choose Interactivity Palette Locations or Optimization Palette Locations. 

•	 To delete a custom workspace, choose Delete Workspace, select the workspace you want to delete, and click Delete. 

•	 (Photoshop) To reset palettes, shortcuts, and menus to their default positions or states, choose Default Workspace. 

•	 To reset palettes to their default positions, choose Reset Palette Locations (Photoshop) or Default Palette Locations 

(ImageReady). 

•	 (Photoshop) To reset menus to Photoshop defaults, choose Reset Menus. 

•	 (Photoshop) To reset keyboard shortcuts to Photoshop defaults, choose Reset Keyboard Shortcuts. 

See also 

“About customizing keyboard shortcuts” on page 754 

“To arrange palettes into a custom workspace” on page 64 

“To define a set of menus” on page 65 

“To use palettes” on page 35 

To change the font size in the work area 
You can change the size of the small font text that appears in the options bar, palettes, and tool tips. 

1	 Choose Edit > Preferences > General (Windows) or Photoshop > Preferences > General (Mac OS). 

2 Choose a size from the UI Font Size menu and click OK. The change takes effect the next time you start 

Photoshop. 

To arrange palettes into a custom workspace 
If you save the current palette locations, keyboard shortcut set, and menu set as a workspace, you can return to it 

even if you move or close a palette, or change to a different set of keyboard shortcuts or menus. In ImageReady, you 

can save the current palette locations. 

1 With the workspace in the configuration you want to save, choose Window > Workspace > Save Workspace. 

2 Enter a name for the workspace. 
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3 (Photoshop) Under Capture, select one or more options: 

Palette Locations Saves the current palette locations. 

Keyboard Shortcuts Saves the current set of keyboard shortcuts. 

Menus Saves the current set of menus. 

4	 Click OK. 

See also 

“About customizing keyboard shortcuts” on page 754 

“To define a set of menus” on page 65 

“To use palettes” on page 35 

To start with the last or default palette locations 
Selecting the Save Palette Locations preference causes Photoshop or ImageReady to display palettes in their last 

locations upon startup. If you  deselect  this  preference, Photoshop  or  ImageReady  displays  the palettes in their  default  

locations upon startup. 

❖ Do one of the following: 

•	 (Windows) Choose Edit > Preferences > General, and then select/deselect Save Palette Locations. 

•	 (Mac OS) Choose Photoshop > Preferences > General or choose ImageReady > Preferences > General, and then 

select/deselect Save Palette Locations. 

The change takes effect the next time you start the application. 

To define a set of menus 
1 Do one of the following: 

•	 Choose Edit > Menus.


• Choose Window > Workspace > Keyboard Shortcuts & Menus and click the Menus tab.


2 In the Keyboard Shortcuts and Menus dialog box, choose a set of menus from the Set menu (Photoshop Defaults


is the only option until you create a new set). For information on customizing keyboard shortcuts, see “About


customizing keyboard shortcuts” on page 754.


3 Choose a type from the Menu For menu:


Application Menus Lets you show, hide, or add color to items in the application menus.


Palette Menus Lets you show, hide, or add color to items in palette menus. 

4 Click the triangle next to a menu or palette name. 

5 Do one of the following: 

•	 To hide a menu item, click the Visibility button . 

•	 To show a menu item, click the empty Visibility button. 

•	 To add color to a menu item, click the color swatch and choose a color. 
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6 When you finish changing the menus, do one of the following: 

• To  save  all changes to the  current set  of  menus,  click the  Save  Set button  .  Changes to a custom  set are  saved.  If  

you’re saving changes to the Photoshop Defaults set, the Save dialog box opens. Enter a name for the new set and 

click Save. 

• To create a new set based on the current set of menus, click the Save Set As button . 

Note: If you haven’t saved the current set of changes, you can click Cancel to discard all changes and close the dialog box. 

7 In the Save dialog box, enter a name for the set and click Save. 

Choosing a color for a menu item using the Keyboard Shortcuts & Menus dialog box 

To delete a set of menus 
1 Do one of the following: 

• Choose Edit > Menus. 

• Choose Window > Workspace > Keyboard Shortcuts & Menus and click the Menu tab. 

2 In the Keyboard Shortcuts & Menus dialog box, choose a set of menus from the Set menu. 

3 Click the Delete Set icon . 

To temporarily show hidden menu items 
It’s possible to temporarily show items that you’ve hidden in a menu. After the menu closes, the items return to their 

hidden state. 

❖ Do one of the following: 

• From a menu with hidden items, choose Show All Menu Items. 

• Shift-click a menu with hidden items. 

To turn menu colors on or off

1 Choose Edit > Preferences > General (Windows) or Photoshop > Preferences > General (Mac OS).


2 Select or deselect Show Menu Colors.
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About the Preset Manager 
The Preset Manager lets you manage the libraries of preset brushes, swatches, gradients, styles, patterns, contours,


custom shapes, and preset tools that come with Photoshop. For example, you can use the Preset Manager to change


the current set of preset items or create new libraries. After you load a library in the Preset Manager, you can access


the library’s items in locations such as the options bar, palettes, dialog boxes, and so on.


In general, when you change a preset, Photoshop prompts you to save the changes as a new preset so that both the


original and changed preset remain available.


Each type of library has its own file extension and default folder. Preset files are installed on your computer inside


the Presets folder in the Adobe Photoshop CS2 application folder.


To  open  the Preset Manager, choose Edit  >  Preset  Manager.  Choose  an  option  from  the Preset Type menu to switch 


to a specific preset type.


You can adjust the configuration of presets by clicking the palette menu button and choosing a display mode from


the top section of the menu:


Text Only Displays the name of each preset item.


Small Thumbnail or Large Thumbnail Displays a thumbnail of each preset item.


Small List or Large List Displays the name and thumbnail of each preset item.


Stroke Thumbnail Displays a sample brush stroke and brush thumbnail of each brush preset. (This option is


available for brush presets only.)


To rearrange the list of items, drag an item up or down in the list.


Rearranging tool presets in the Preset Manager 

Note: To delete a preset in the Preset Manager, select the preset and click Delete. You can always use the Reset command 

to restore the default items in a library. 

To load a library of preset items 
❖ Do one of the following: 

•	 Click the triangle to the right of the Preset Type pop-up menu and then choose a library file from the bottom of 

the palette menu. Click OK to replace the current list, or click Append to add the current list. 

•	 To add a library to the current list, click Load, select the library file you want to add, and click Load. 

•	 To replace the current list with a different library, choose Replace [Preset Type] from  the palette  menu. Select the  

library file you want to use, and click Load. 

Note: Each type of library has its own file extension and default folder in the Presets folder in the Photoshop program 

folder. 
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To rename preset items

1 Select a preset item. Shift-click to select multiple items.


2 Do one of the following:


•	 Click Rename, and then enter a new name for the brush, swatch, and so on. 

•	 If the Preset Manager currently displays presets as thumbnails, double-click a preset, enter a new name, and 

click OK. 

•	 If the Preset Manager currently displays presets as a list or text only, double-click a preset, enter a new name inline, 

and press Enter (Windows) or Return (Mac OS). 

To delete preset items 
❖ Do one of the following: 

•	 Select a preset item, and click Delete. 

•	 Alt-click (Windows) or Options-click (Mac OS) the items you want to delete. 

To create a new library of presets 
1 Do one of the following: 

•	 To save all the presets in the list as a library, make sure that no items are selected. 

•	 To save a subset of the current list as a library, hold down Shift, and select the items you want to save. 

2	 Click Save Set, choose a location for the library, enter a file name, and click Save. 

You can save the library anywhere. However, if you place the library file in the appropriate Presets folder inside the 

Photoshop program folder, the library name will appear at the bottom of the palette menu after you restart 

Photoshop. 

To restore the default library of preset items 
❖ Choose Reset from the palette menu. You can either replace the current list or append the default library to the 

current list. 

Preferences 

About preferences 
Numerous program settings are stored in the Adobe Photoshop CS Prefs file, including general display options, file

saving options, cursor options, transparency options, and options for plug-ins and scratch disks. Most of these 

options are set in the Preferences dialog box. Preference settings are saved each time you quit the application. 

Unexpected behavior may indicate damaged preferences. If you suspect damage to preferences, restore preferences 

to their default settings. 
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To open a preferences dialog box 
1 Do one of the following: 

•	 (Windows) Choose Edit > Preferences and choose the desired preference set from the submenu. 

•	 (Mac OS) Choose Photoshop > Preferences or choose ImageReady > Preferences, and then choose the desired 

preference set from the submenu. 

2	 To switch to a different preference set, do one of the following: 

•	 Choose the preference set from the menu at the top of the dialog box. 

• Click Next to display the next preference set in the menu list; click Prev to display the previous preference set. 

For information on a specific preference option, see the index. 

To restore all preferences to default settings 
❖ Do one of the following: 

•	 Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac OS) as you start Photoshop or 

ImageReady. You are prompted to delete the current settings. 

•	 (Mac OS only) Open the Preferences folder in the Library folder, and drag the Adobe Photoshop CS Settings folder 

to the Trash. 

New Preferences files are created the next time you start Photoshop or ImageReady. 

To disable and enable warning messages 
Sometimes you will see messages containing warnings or prompts. You can suppress the display of these messages 

by  selecting the  Don’t Show Again  option  in  the message. You  can also globally redisplay  all messages that have been  

suppressed. 

1	 Do one of the following: 

•	 (Windows) Choose Edit > Preferences > General. 

• (Mac OS) Choose Photoshop > Preferences > General or choose ImageReady > Preferences > General. 

2 Click Reset All Warning Dialogs, and click OK. 

About plug-in modules 
Plug-in modules are software programs developed by Adobe Systems and by other software developers in 

conjunction with Adobe Systems to add features to Photoshop and ImageReady. A number of importing, exporting, 

and special-effects plug-ins come with your program. They are automatically installed in folders inside the 

Photoshop Plug-ins folder. 

You can select an additional Plug-ins folder for compatible plug-ins stored with another application. You can also 

create a shortcut (Windows) or an alias (Mac OS) for a plug-in stored in another folder on your system. You can then 

add the shortcut or alias to the plug-ins folder and use that plug-in with Photoshop and ImageReady. 

Once installed, plug-in modules appear as options in the Import or Export menu; as file formats in the Open, Save 

As, and Export Original (ImageReady) dialog boxes; or as filters in the Filter submenus. Photoshop and ImageReady 

can accommodate a large number of plug-ins. However, if the list of installed plug-in modules becomes too long, 

Photoshop or ImageReady may not be able to display all the plug-ins in their appropriate menus. If so, newly installed 

plug-ins appear in the Filter > Other submenu. 
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To install a plug-in module 
In Mac OS, you cannot run Photoshop in the Classic environment. Plug-ins originally intended to work on Mac OS 9 

won’t appear. 

❖ Do one of the following: 

•	 To install an Adobe Systems plug-in module, use the plug-in installer, if provided. You can also (Windows) install 

copy the module into the appropriate Plug-ins folder in the Photoshop program folder, or (Mac OS) drag a copy 

of the module to the appropriate Plug-ins folder in the Photoshop program folder. Make sure that the files are 

uncompressed. 

•	 To install a third-party plug-in module, follow the installation instructions that came with the plug-in module. If 

you cannot run a third-party plug-in, it may require a legacy Photoshop serial number. 

Note: If  you want to use  a plug-in  only  in  Photoshop or only in ImageReady,  or  when  a plug-in  is  compatible  with  only  

one of the applications, you can install the plug-in inside the Plug-ins folder in either the Adobe Photoshop Only folder 

or the Adobe ImageReady Only folder. 

To specify a legacy serial number 
1 Do one of the following: 

•	 (Windows) Choose Edit > Preferences > Plug-ins & Scratch Disk.


• (Mac OS) Choose Photoshop > Preferences > Plug-ins & Scratch Disk.


2 Enter the serial number from Photoshop CS or earlier in the Legacy Photoshop Serial Number text box.


 To select an additional plug-ins folder 
1 Do one of the following: 

•	 (Photoshop) Choose Edit > Preferences > Plug-ins & Scratch Disk (Windows) or choose Photoshop > 

Preferences > Plug-ins & Scratch Disk (Mac OS). 

•	 (ImageReady) Choose Edit > Preferences > Plug-ins (Windows) or choose ImageReady > Preferences > Plug-ins 

(Mac OS). 

2 Select Additional Plug-ins Folder.


3 Click Choose, and select a folder or directory from the list. Make sure that you do not select a location inside the


Plug-ins folder. To display the contents of a folder, double-click the directory (Windows) or click Open (Mac OS).


4 When you have highlighted the additional plug-ins folder, click OK (Windows) or Choose (Mac OS). 

5 Restart Photoshop or ImageReady for the plug-ins to take effect. 

To suppress the loading of plug-ins 
❖ Add a tilde ~ character at the beginning of the plug-in name, folder, or directory. That file (or all files in the folder) 

will be ignored by the application. 
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To view information about installed plug-ins 
❖ Do one of the following: 

•	 (Windows) Choose Help > About Plug-in and choose a plug-in from the submenu. 

•	 (Mac OS) Choose Photoshop > About Plug-in or choose ImageReady > About Plug-in, and then choose a plug-in 

from the submenu. 

Recovery and undo 

To use the Undo or Redo commands 
The Undo and  Redo  commands  let you  undo  or  redo  operations. You  can also use  the History  palette to undo or redo  

operations. 

❖ Choose Edit > Undo or Edit > Redo.


If an operation can’t be undone, the command is dimmed and changes to Can’t Undo.


You can set the Redo keystroke preference to be the same for Photoshop and ImageReady. In the General area of the 

Preferences dialog box, select a preference for the Redo key. You can also set the key to toggle between Undo and Redo. 

See also 

“About the History palette” on page 72 

To revert to the last saved version 
❖ Choose File > Revert. 

Note: Revert is added as a history state in the History palette and can be undone. 

To restore part of an image to its previously saved version 
❖ Do one of the following: 

•	 Use the History Brush tool  to paint with the selected state or snapshot on the History palette. 

•	 Use the Eraser tool  with the Erase To History option selected. 

•	 Select the area you want to restore, and choose Edit > Fill. For Use, choose History, and click OK. 

Note: To  restore the  image with a snapshot  of  the initial  state of the  document, choose History  Options from the  Palette  

menu and make sure that the Automatically Create First Snapshot option is selected. 

See also 

“To use the Eraser tool” on page 490 

“The Art History Brush tool” on page 472 

To cancel an operation 
❖ Hold down Esc until the operation in progress has stopped. In Mac OS, you can also press Command+period. 
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To receive notification when an operation is completed 
A progress bar  indicates that an operation  is  being performed. You  can interrupt  the operation  or  have  the program  

notify you when it has finished the operation. 

1	 Do one of the following: 

•	 (Windows) choose Edit > Preferences > General. 

• (Mac OS) choose Photoshop > Preferences > General or choose ImageReady > Preferences General. 

2 Do one of the following: 

•	 (Photoshop) Select Beep When Done. 

•	 (ImageReady) Select Notify When Done. In Mac OS, you can then choose System Alert to be notified through 

your system alert or Text To Speech to receive a spoken notification. 

3	 Click OK. 

About the History palette 
You can use the History palette to jump to any recent state of the image created during the current working session. 

Each time you apply a change to an image, the new state of that image is added to the palette. 

For example, if you select, paint, and rotate part of an image, each of those states is listed separately in the palette. 

When you select one of the states, the image reverts to how it looked when that change was first applied. You can 

then work from that state. 

You can also use the History palette to delete image states and, in Photoshop, to create a document from a state or 

snapshot. 

To display the History palette, choose Window > History, or click the History palette tab. 

A 

B 

C 

D 

Photoshop History palette 
A. Sets the source for the history brush B. Thumbnail of a snapshot C. History state D. History state slider 

Keep the following in mind when using the History palette: 

•	 Program-wide changes, such as changes to palettes, color settings, actions, and preferences, are not reflected in the 

History palette, because they are not changes to a particular image. 

•	 By default, the History palette lists the previous 20 states (Photoshop), or 32 states (ImageReady). You can change 

the number of remembered states by setting a preference. Older states are automatically deleted to free more 

memory for Photoshop. To keep a particular state throughout your work session, make a snapshot of the state. 

•	 Once  you close  and reopen the  document, all  states  and snapshots  from  the last working  session are  cleared from  

the palette. 

 



73 ADOBE PHOTOSHOP CS2 
User Guide 

•	 By default, a snapshot of the initial state of the document is displayed at the top of the palette. 

•	 States are added to the bottom of the list. That is, the oldest state is at the top of the list, the most recent one at the 

bottom. 

•	 Each state is listed with the name of the tool or command used to change the image. 

•	 By default, when you select a state, the states below it are dimmed. This way you can easily see which changes will 

be discarded if you continue working from the selected state. 

•	 By default, selecting a state and then changing the image eliminates all states that come after it. 

•	 If you select a state and then change the image, eliminating the states that came after, you can use the Undo 

command to undo the last change and restore the eliminated states. 

•	 By default, deleting a state deletes that state and those that came after it. If you choose the Allow Non-Linear 

History option, deleting a state deletes only that state. 

To revert to a previous image state 
❖ Do any of the following: 

•	 Click the name of the state. 

•	 Drag the slider  at the left of the state up or down to a different state. 

•	 (Photoshop) Choose Step Forward or Step Backward from the History palette menu or the Edit menu to move to 

the next or previous state. 

To delete one or more image states in Photoshop 
❖ Do one of the following: 

•	 Click the  name  of  the state, and  choose  Delete  from  the History  palette menu to delete that change and  those that  

came after it. 

•	 Drag the state to the Delete icon  to delete that change and those that came after it. 

•	 Choose Clear History from the palette menu to delete the list of states from the History palette, without changing 

the image. This option doesn’t reduce the amount of memory used by Photoshop. 

•	 Hold down Alt (Windows) or Option (Mac OS), and choose Clear History from the palette menu to purge the list 

of states without changing the image. If you get a message that Photoshop is low on memory, purging states is 

useful, because the command deletes the states from the Undo buffer and frees up memory. You can’t undo the 

Clear History command. 

•	 Choose Edit > Purge > Histories to purge the list of states for all open documents. You can’t undo this action. 

To delete all image states in ImageReady 
❖ Choose Clear Undo/Redo History from the History palette menu. 

Note: This action cannot be undone. 
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To create or replace a document with an image state 
❖ Do one of the following: 

•	 Drag a state or snapshot onto the New Document button . The history list for the newly created document will 

be empty. 

•	 Select a state or snapshot, and click the New Document button. The history list for the newly created document 

will be empty. 

•	 Select  a state  or  snapshot, and  choose  New Document from the  History palette  menu. The  history list for  the newly  

created document will be empty. 

•	 Drag a state onto an existing document. 

To save one or more snapshots or image states for use in a later editing session, create a new file for each state you 

save, and save each in a separate file. When you reopen your original file, plan to open the other saved files also. You 

can drag each file’s initial snapshot to the original image to access the snapshots again from the original image’s History 

palette. 

To set history options 
You can specify the maximum number of items to include in the History palette and set other options to customize


the palette.


1 Choose History Options from the History palette menu.


2 Select an option:


Automatically Create First Snapshot Automatically creates a snapshot of the initial state of the image when the


document is opened.


Automatically Create New Snapshot When Saving Generates a snapshot every time you save. 

Allow Non-Linear History Makes changes to a selected state without deleting the states that come after. Normally, 

when you select a state and change the image, all states that come after the selected one are deleted. In this way, the 

History palette can display a list of the editing steps in the order that they were made. By recording states in a 

nonlinear way, you  can select a state,  make  a change  to  the image, and  delete  just  that  state.  The change is appended  

at the end of the list. 

Show New Snapshot Dialog By Default Forces Photoshop to prompt you for snapshot names even when you use 

the buttons on the palette. 

Making a snapshot of an image 
The Snapshot command  lets  you make a temporary copy (or  snapshot) of any  state of the  image.  The new  snapshot  

is added to the list of snapshots at the top of the History palette. Selecting a snapshot lets you work from that version 

of the image. 

Snapshots are similar to the states listed in the History palette, but they offer additional advantages: 

•	 You can name a snapshot to make it easy to identify. 

•	 Snapshots can be stored for an entire work session. 

 



75 ADOBE PHOTOSHOP CS2 
User Guide 

•	 You can compare effects easily. For example, you can take a snapshot before and after applying a filter. Then select 

the first snapshot, and try the same filter with different settings. Switch between the snapshots to find the settings 

you like best. 

•	 With snapshots, you can recover your work easily. When you experiment with a complex technique or apply an 

action, take a snapshot  first.  If  you’re  not satisfied  with  the results,  you can  select  the snapshot to undo all  the steps.  

Note: Snapshots are not saved with the image—closing an image deletes its snapshots. Also, unless you select the Allow 

Non-Linear History option, selecting a snapshot and changing the image deletes all of the states currently listed in the 

History palette. 

To create a snapshot 
1 Select a state and do one of the following: 

•	 To automatically create a snapshot, click the New Snapshot button on the History palette, or if Automatically 

Create New Snapshot When Saving is selected in the history options, choose New Snapshot from the History 

palette menu. 

•	 To set options when creating a snapshot, choose New Snapshot from the History palette menu, or Alt-click 

(Windows) or Option-click (Mac OS) the New Snapshot button. 

2 Enter the name of the Snapshot in the Name text box. 

3 Choose the snapshot contents from the From menu:


Full Document Makes a snapshot of all layers in the image at that state


Merged Layers Makes a snapshot that merges all layers in the image at that state 

Current Layer Makes a snapshot of only the currently selected layer at that state 

To work with snapshots 
❖ Do one of the following: 

•	 To select a snapshot, click the name of the snapshot or drag the slider at the left of the snapshot up or down to a 

different snapshot. 

•	 To rename a snapshot, double-click the snapshot and enter a name. 

•	 To  delete  a snapshot,  select  the snapshot and  either  choose  Delete  from  the palette  menu, click  the Delete icon  

or drag the snapshot to the Delete icon. 

, 

Painting with a state or snapshot of an image 
The History Brush tool lets you paint a copy of one image state or snapshot into the current image window. This 

tool makes a copy, or sample, of the image and then paints with it. 

For example, you  might make a snapshot  of  a change  you made with a painting  tool  or  filter  (with the  Full  Document  

option selected when you create the snapshot). After undoing the change to the image, you could use the History 

Brush tool to apply the change selectively to areas of the image. Unless you select a merged snapshot, the History 

Brush tool paints from a layer in the selected state to the same layer in another state. 

The History Brush tool copies from one state or snapshot to another, but only at the same location. In Photoshop, 

you can also paint with the Art History Brush tool to create special effects. 
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See also 

“To use the Art History Brush tool” on page 472 

To paint with a state or snapshot of an image 
1 Select the History Brush tool 

2 Do one of the following in the options bar: 

. 

• Specify the opacity and blending mode. 

• Choose a brush and set brush options. 

3 In the History palette, click the left column of the state or snapshot to be used as the source for the History Brush


tool.


4 Drag to paint with the History Brush tool.


See also 

“About blending modes” on page 486 

“To create a brush and set painting options” on page 475 

About the Edit History Log 
You may need to keep careful track of what’s been done to a file in Photoshop, either for your own records, client 

records, or legal purposes. The Edit History Log helps you keep a textual history of changes made to an image. You 

can view the Edit History Log metadata using Adobe Bridge or the File Info dialog box. 

You can choose to export the text to an external log file, or you can store the information in the metadata of edited 

files. Storing many editing operations as file metadata increases file size; such files may take longer than usual to open 

and save. 

If you need to prove that the log file hasn’t been tampered with, keep the edit log in the file’s metadata, and then use 

Adobe Acrobat to digitally sign the log file. 

See also 

“To add metadata using the File Info dialog box” on page 98


To set Edit History Log options

1 Choose Edit > Preferences > General (Windows) or Photoshop > Preferences > General (Mac OS).


2 Click the History Log preference to toggle from on to off or vice versa.


3 In the History Log Options pane, choose one of the following options:


Metadata Stores metadata for each image.


Text File Exports the text to an external file. You are prompted to name the log file and choose a location in which


to store it.


Both Stores metadata in the file and creates a text file. 
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Note: If you want to save the text file in a different location or save another text file, click the Choose button, specify 

where to save the text file, name the file if necessary, and click Save. 

4 From the Edit Log Items menu, choose one of the following options: 

Sessions Keeps a record of each time your start or quit Photoshop and each time you open and close files (each 

image’s file name is included). 

Concise Includes the text that appears in the history palette in addition to the Sessions information. 

Detailed Includes the text that appears in the Actions palette in addition to the Concise information. Choose 

Detailed if you need a complete history of all changes made to files. 

Memory 

Assigning scratch disks 
When your system does not have enough RAM to perform an operation, Photoshop and ImageReady use a propri

etary virtual memory technology, also called scratch disks. A scratch disk is any drive or drive partition with free 

memory. By default, Photoshop  and ImageReady use  the hard drive  on  which the  operating system is installed  as  the  

primary scratch disk. 

In the Plug-ins & Scratch Disks preferences in Photoshop, you can change the primary scratch disk and designate a 

second, third, or fourth scratch disk to be used when the primary disk is full. Your primary scratch disk should be 

your fastest hard disk; make sure it has plenty of defragmented space available. 

The following guidelines can help you assign scratch disks: 

• For best performance, scratch disks should be on a different drive than any large files you are editing. 

• Scratch disks should be on a different drive than the one used for virtual memory. 

• Scratch disks should be on a local drive. That is, they should not be accessed over a network. 

• Scratch disks should be conventional (nonremovable) media. 

• RAID disks/disk arrays are good choices for dedicated scratch disk volumes. 

• Drives with scratch disks should be defragmented regularly. 

To change the scratch disk assignment

1 Choose Edit > Preferences > Plug-ins & Scratch Disks (Windows) or Photoshop > Preferences > Plug-ins &


Scratch Disks (Mac OS).


2 Choose the desired disks from the menus. You can assign up to four scratch disks of any size that your file system


supports.


3 Click OK.


4 Restart Photoshop for the change to take effect.
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To free memory 
The Purge command lets you free memory used by the Undo command, the History palette, or the clipboard. 

❖ Choose Edit > Purge, and choose the item type or buffer you want to clear. If it is already empty, the item type or 

buffer is dimmed. 

Note: The Purge command permanently clears from memory the operation stored by the command or buffer; Purge 

cannot be undone. For example, choosing Edit > Purge > Histories deletes all history states from the History palette. Use 

the Purge command when the amount of information in memory is so large that Photoshop’s performance is noticeably 

affected. 
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Chapter 4: Adobe Bridge


The basics of Bridge 

About Adobe Bridge 
Adobe Bridge is the control center for Adobe Creative Suite. You use it to organize, browse, and locate the assets you 

need to create content for print, the web, and mobile devices. Adobe Bridge keeps native PSD, AI, INDD, and Adobe 

PDF files as well as other Adobe and non-Adobe application files available for easy access.You can drag assets into 

your layouts as needed, preview them, and even add metadata to them. Bridge is available independently, as well as 

from within Adobe Photoshop, Adobe Illustrator, Adobe InDesign, and Adobe GoLive. 

File browsing From Bridge you can view, search, sort, manage, and process image files. You can use Bridge to create 

new folders; rename, move, and delete files; edit metadata; rotate images; and run batch commands. You can also 

view information about files and data imported from your digital camera. 

Version Cue If you have Adobe Creative Suite, you can use Bridge as a central location from which to use Adobe 

Version Cue. From Bridge, you can browse all the files in a project in one place without having to start the native 

application for each file, including non-Adobe application files. Also, you can create new Version Cue projects, delete 

projects, create versions, save alternates, and set access privileges in Bridge. See “Working with Version Cue in 

Bridge” on page 101. 

Bridge Center If you have Adobe Creative Suite, Adobe Bridge includes Bridge Center, the “dashboard” of Adobe 

Creative  Suite,  where you  can view news readers  in  your  web browser, see  your  most  recent  activity, read about  tips  

and tricks for using Adobe products, save groups of files, and more. Adobe Creative Suite users can also use Bridge 

to  specify color  management  settings  and access  scripts that help automate your workflow.  See “About Bridge Center”  

on page 92. 

Camera Raw If you have Adobe Photoshop installed, you can open and edit camera raw files from Bridge and save 

them in a Photoshop-compatible format. You can edit the image settings directly in the Camera Raw dialog box 

without starting Photoshop. If you don’t have Photoshop installed, you can still preview the camera raw files in 

Bridge. See “To open files in Bridge” on page 87. 

Stock Photos Click Adobe Stock Photos from the Favorites pane in Bridge to search leading stock libraries for 

royalty-free images. You can download low-resolution, complementary versions of the images and try them out in 

your projects before purchasing them. See “About Adobe Stock Photos” on page 103. 

Color management You can use Bridge to synchronize color settings across applications. This synchronization 

ensures that colors look the same no matter which Creative Suite application you view them in. See “To synchronize 

color settings across Adobe applications” on page 254. 

See also 

“The Bridge work area” on page 79 

The Bridge work area 
These are the main components of the Adobe Bridge window: 
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Bridge window in filmstrip view 
A. The Look In menu B. The Metadata panel C. The shortcuts buttons D. The content area 

The menu bar Contains commands specific to Bridge. In Windows®, the menu bar is at the top of the Bridge 

window. In Mac OS®, the menu bar is located at the top of the screen.


The Look In menu Lists the folder hierarchy, as well as favorite and recent folders. This menu gives you a quick way


to find folders containing the items you want to display. The menu is at the top of the Bridge window.


The shortcut buttons Help you work efficiently with your files. They are located to the right of the Look In menu, 

at the top of the Bridge window.


The Favorites panel Gives you quick access to folders as well as to Version Cue, Adobe Stock Photos, collections,


and Bridge Center (Adobe Creative Suite only). Like all panels, it’s located on the left side of the Bridge window.


The Folders panel Shows the folder hierarchy. Use it to navigate to the correct folder. 

The Preview panel Displays a preview of the selected file, separate from and typically larger than the thumbnail


image displayed in the content area. You can reduce or enlarge the preview.


The Metadata panel Contains metadata information for the selected file. If multiple files are selected, shared data


(such as keywords, date created, and exposure setting) is listed.


The Keywords panel Helps you organize your images by attaching keywords to them.


The content area Displays thumbnail previews of the items in the current folder, along with information about


those items.


The bottom of the Bridge window displays status information and contains buttons for toggling the display of the


panels, a slider for setting the size of thumbnails, and buttons for specifying the type of display in the content area.
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See also 

“To create and close Bridge windows” on page 81 

“To use Bridge in Compact mode” on page 81 

To start and quit Bridge, and to return to an application 
Do any of the following: 

• To open Bridge from an application, choose File > Browse from your application. 

• (Windows) To open Bridge directly, choose Adobe Bridge from the Start menu. 

• (Mac OS) To open Bridge directly, double-click the Adobe Bridge icon . By default, this is located in the Appli-

cations/Adobe Bridge folder. 

• To quit Bridge, choose File > Exit (Windows) or Bridge > Quit Bridge (Mac OS). 

• To return to the last open application that started Bridge, choose File > Return To [Application]. 

See also 

“About Adobe Bridge” on page 79 

“To manage files with Bridge” on page 88 

To create and close Bridge windows 
❖ Do one of the following: 

• Choose File > New Window to create a full-size Bridge window. 

• Choose File > Close Window. In Windows, this command quits Bridge as well. 

See also 

“The Bridge work area” on page 79 

“To use Bridge in Compact mode” on page 81 

To use Bridge in Compact mode 
Switch to Compact mode when you want to shrink the Bridge window, hiding the panels and simplifying the content 

area. A subset of common Bridge commands remains available from the pop-up menu at the top right of the window. 
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By default, the Compact mode Bridge window floats on top of all windows. (In Full mode, the Bridge window can 

move behind application windows.) This floating window is useful because it is always visible and usable as you work 

in different applications. For instance, you might use Compact mode after you select the files you plan to use, and 

then drag them into the application as you need them. 

1 Click the Switch To Compact Mode button 

2 Do any of the following: 

. 

•	 Choose commands from the menu at the top right of the Bridge window. 

•	 Click the Switch To Ultra Compact Mode button  to hide the content area, further minimizing the Bridge 

window. You can click the button again to return to Compact mode. 

•	 Click the Switch To Full Mode button to return to Full mode, displaying the content area and the panels, and 

letting Bridge move behind the current application window. 

See also 

“The Bridge work area” on page 79 

To adjust the Bridge window 
You can adjust the Bridge window by moving and resizing the panels. For example, you can enlarge the Preview panel 

to display bigger thumbnails. You can’t, however, move panels outside the Bridge window. 

❖ Do any of the following: 

•	 Drag a panel by its tab up or down into another panel area. 

•	 Drag the horizontal divider bar between panels to make them larger or smaller. 

•	 Drag the vertical divider bar between the panels and the content area right or left to resize the panels or content 

area. 

•	 Click the Show/Hide Panes button  at the lower left of the Bridge window to display or hide the panels. 

•	 Choose View, followed by the name of the panel you want to display or hide. 

See also 

“The Bridge work area” on page 79 

To select Bridge workspaces 
A Bridge workspace is a certain configuration or layout of the work area. You can select either a premade one or a 

custom one that you have previously saved. You can use a preset configuration or switch between different configu

rations best suited for specific tasks, such as sorting photos. 

Note: A Bridge workspace is different from a Version Cue Workspace. Your work in Bridge workspaces has no effect on 

the Version Cue Workspaces. 

❖ Choose Window, followed by the name of the workspace you want, or choose Window > Workspace, followed by


one of the following commands:


Lightbox Displays just the content area of Bridge, so that you can concentrate on viewing the files.


File Navigator Displays the content area in Thumbnails view, along with the Favorites panel and Folder panel. 
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Metadata Focus Displays the content area in Thumbnails view, along with the Metadata panel prominently shown. 

Filmstrip Focus Displays just the content area, in Filmstrip view. 

See also 

“To save and delete Bridge workspaces” on page 83 

To save and delete Bridge workspaces 
You can save the current Bridge layout (that is, the work area configuration) as a workspace and reuse it later. By 

saving Bridge in various configurations, you can work in (and quickly switch between) different layouts of the work 

area. For instance, you might use one workspace to sort new photos and another to work with Adobe InDesign files. 

Note: A Bridge workspace is different from a Version Cue Workspace. Your work in Bridge workspaces has no effect on 

Version Cue Workspaces. 

❖ Choose Window > Workspace, followed by one of these commands: 

Save Workspace Saves the current Bridge layout as a workspace so that you can reuse it later, even if you move a 

panel or change  the view in the  content area.  If  you choose this command,  enter a name  for the  workspace and  click  

Save. You can also assign a keyboard shortcut to the workspace and specify whether to save the location of the Bridge 

window as part of the workspace. 

Delete Workspace Deletes the saved workspace. If you choose this command, choose the workspace from the 

menu, and click Delete. 

Reset To Default Workspace Restores the workspace to the default configuration. 

See also 

“To select Bridge workspaces” on page 82 

To set Bridge preferences 
1 Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS). 

2 Select any of the preferences categories on the left: 

General Controls the general appearance settings. You can use this category to specify such preferences as how dark 

to make the content area for thumbnails, what information to show with thumbnails, and what to include in the 

Favorites panel. See “Bridge General preferences” on page 84. 

Metadata Controls which sections and fields are displayed in the Metadata panel. 

Labels Assigns names to each color label and specifies whether you need to press Control as part of the keyboard 

shortcut combination to apply labels and ratings to files. 

File Type Associations Specifies which application to use from Bridge to open files of the named type. For any file 

type, you can click the name of the application (or None) and click Browse to locate an application to use. You can 

also reset the file type associations to their default settings as well as hide any file types that don’t have an associated 

application. This affects only those files that you open with Bridge, and overrides the Explorer (Windows) and Finder 

(Mac OS) settings. 
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Adobe Stock Photos Specifies Adobe Stock Photos settings. See “To set Adobe Stock Photos preferences” on 

page 112. 

Advanced Specifies advanced settings, including cache options and language options. See “Bridge Advanced prefer

ences” on page 84. 

3 Click OK. 

Bridge General preferences 
Set any of the following General preferences and click OK: 

Background Specifies the darkness of the content area in which thumbnails are shown. 

Show Tooltips Specifies whether to display Bridge help information when you position the pointer over an item. 

(This preference does not affect settings for Version Cue tool tips, which display metadata for items.) 

Additional Lines Of Thumbnail Metadata Specifies whether to show additional metadata information with 

thumbnails in the content area. If you select this option, you can choose the type of metadata to show from the 

associated menu. You can display up to three extra lines of information. 

Favorites Items Specifies what items to show in the Favorites panel. Certain options are dimmed if you do not have 

those items. 

Reveal Scripts In Finder Opens the folder that contains scripts (the commands available in the Tools menu). 

Reset All Warning Dialogs Resets warning notices in Bridge to their default settings. 

See also 

“To set Bridge preferences” on page 83 

Bridge Advanced preferences 
Set any of the following Advanced preferences and click OK: 

Do Not Process Files Larger Than Specifies the maximum file size of documents for which Bridge automatically 

creates thumbnails. Displaying large files can slow performance. 

Number Of Recently Visited Folders To Display In The Look In Popup Sets the number of most recently viewed 

folders that appear in the Look In menu. 

Language Sets the language used in the Bridge interface. Select Automatic to set the language to the one specified 

for Bridge by the program that installed it. 

Show Camera Raw Interface On Open Opens camera raw files in the Adobe Camera Raw dialog box in Adobe 

Photoshop. 

Use A Centralized Cache File Places the two cache files created for each folder you view in a centralized folder. A 

centralized cache is generally easier to use than a distributed cache. For instance, when the cache is centralized, you 

don’t have to search in multiple, distributed locations if you want to remove the cache. To specify a new name or 

location for this centralized cache folder, click Choose. 

Use Distributed Cache Files When Possible Places the two cache files created for each folder you view in the 

viewed  folder, if possible.  For instance,  it’s  not possible to place  the cache  files in the  viewed  folder  if  that  folder  is  on  

a burned CD. In that case, Bridge places the cache files in the centralized folder instead. However, if you are burning 

a CD, using a distributed cache means that you don’t have to export the cache to the CD, because it is already in the 
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folder you are burning to the CD. Also, using distributed cache files preserves the cache in a folder if you rename that 

folder. See “To work with the cache in Bridge” on page 85. 

Note: Cache files are hidden files. To view them in Bridge, choose View > Show Hidden Files. 

See also 

“To set Bridge preferences” on page 83 

To work with the cache in Bridge 
The cache stores thumbnail, metadata, and file information to shorten loading times when you return to a previously 

viewed folder. However, storing the cache takes up disk space. 

Note: Purging the cache deletes the metadata cache and thumbnail cache. If the metadata can’t be written to a file, label 

and rating information is lost as well. 

❖ Choose any of the following commands from the Tools > Cache submenu: 

Build Cache For Subfolders Builds, as a background process, a cache for the selected folder and all the folders 

within it (except aliases/shortcuts to other folders), shortening the time spent waiting for the cache to be displayed 

as you look in subfolders. 

Purge Cache For This Folder Clears the cache for the selected folder. This command is useful if you suspect that the 

cache for a folder is old and needs to be regenerated. 

Purge Central Cache Clears the entire centralized cache and any distributed cache in the currently viewed folder, 

freeing room on the hard drive. The command does not otherwise clear local caches. 

Export Cache Exports the cache, allowing you to burn a CD with the cache already generated. Because the folder 

cache is written into the folder, the thumbnail cache and metadata cache are available after you burn the CD. This 

option is active only if you chose Use A Centralized Cache File in the Preferences dialog box. 

See also 

“About Adobe Bridge” on page 79 

Files and folders in Bridge 

To view file and folder thumbnails in Bridge 
The content area of Bridge displays thumbnails of the files and folders of the selected folder, along with information 

about them (depending on your view). 

You can specify how you want files and folders are displayed in the content area; for instance, you can decide how big 

thumbnails should be, how they should appear, and whether file information should be displayed. 

❖ Do any of the following: 

• Drag the Thumbnail slider  at the bottom of the Bridge window to adjust the size of thumbnails. You can also 

click the buttons at either side of the Thumbnail slider to minimize or maximize the thumbnails. 

• Click the  Thumbnail View button  at the  bottom  of  the Bridge window or choose View  >  As  Thumbnails  to  

display items in a grid. 
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•	 Click the Filmstrip View button or choose View > As Filmstrip to display thumbnails in a scrolling list along 

with an extra-large thumbnail of the currently selected item. Click the Back button or Forward button directly 

button

below the extra-large thumbnail to go to the previous or next thumbnail. Click the Switch Filmstrip Orientation

to change from a horizontal slide show to a vertical one. Note that you can page through a PDF preview 

in Filmstrip view. 

•	 Click the Details View button  or choose View > As Details to display a scrollable list of thumbnails along 

with information about the selected file, such as its creation date, file type, pixel size, and file size. For Version Cue 

files, there is additional information about the number of versions or alternates as well as enhanced status infor

mation along with the current version comment. 

•	 Click the Versions And Alternates View button  or choose View > As Versions And Alternates to display a 

scrollable list of thumbnails along with thumbnails of any Version Cue alternates and versions for each item. (Only 

the current file appears unless you have created an alternates group containing the file or created previous versions 

of the file.) Click Alternates View or Versions View at the top right of the content area to display thumbnails of 

alternates or versions. In Alternates View, you can also create alternates groups containing files that are not in the 

current folder. 

•	 Choose View > Show Thumbnail Only to view thumbnails without any text information listed. However, Version 

Cue tool tips still display Version Cue information when you position the pointer over the thumbnail. 

•	 Choose View > Slideshow to view thumbnails as a slide show that takes over the entire screen. This is a quick and 

easy way to display and work with large versions of all the graphics files in a folder. Instructions on how to use the 

slide show are displayed on the screen when you choose this command. 

Depending on the view you’re in, you can display extra file information by positioning the pointer over a thumbnail 

in the content area. For files in Version Cue projects, you can also choose File > Versions or File Alternate. This 

command opens a dialog box that lets you work with the file’s versions or alternates without having to select that view 

in the Bridge content area. 

To specify how files and folders are shown in Bridge 
You can specify what type of files and folders you want to display as thumbnails in the content area, as well as the 

order in which to display them. 

❖ Choose any of the following commands from the View menu: 

•	 Sort, followed by the order in which you want to sort files. Choose Ascending to sort in ascending rather than 

descending order. Choose Manually to sort by the last order in which you dragged the files. 

•	 Show Hidden Files to display hidden files, such as cache files and Version Cue files that have been provisionally 

removed (not permanently deleted) from Version Cue projects. 

•	 Show Folders to display folders as well as individual files. 

•	 Show All Files to display all files regardless of type, even non-Adobe files that Bridge doesn’t normally display. 

•	 Show Graphic Files Only to display only files in graphic file formats, such as EPS, JPEG, BMP, PS, TIFF, and GIF. 

•	 Show Camera Raw Files Only to display only camera raw files. 

•	 Show Vector Files Only to display only files created with drawing programs such as Adobe Illustrator, and EPS and 

PS files. 

•	 Refresh (or choose Refresh from the Folders panel menu) to update the content area. This is useful, for instance, 

when you perform certain Version Cue actions that don’t automatically refresh the view in the content area. 

Closing and reopening Bridge also refreshes the view. 
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You can also click Unfiltered at the top right of the Bridge window and choose the files you want to display based on 

their rating or label. The Unfiltered menu operates independently of the View > Sort commands. 

To navigate folders and files with Bridge 
❖ Do any of the following: 

•	 Select the Folders panel and click to select the folder you want. Click the plus sign (Windows) or triangle (Mac OS) 

next to a folder or double-click the folder to open subfolders within it. 

•	 Select the Favorites panel and click to select the folder you want. 

•	 Choose  a folder from the  Look  In  menu. You  can click  the Go Back button,  Go  Forward button,  or  Go  Up  button  

next to the menu to navigate within the current folder listed in the menu. 

See also 

“To specify how files and folders are shown in Bridge” on page 86 

To select files in Bridge 
Before you can work with a file, you need to select it. You can select more than one file at a time. 

❖ Do one of the following in the current folder: 

•	 Click the thumbnail of a file. 

•	 To select contiguous files, Shift-click them. 

•	 To select noncontiguous files, Ctrl-click (Windows) or Command-click (Mac OS) them. 

•	 To select all the files, choose Edit > Select All. 

•	 To select all labeled files, choose Edit > Select Labeled. 

•	 To select all unlabeled files, choose Edit > Select Unlabeled. 

•	 To select the opposite of the current selection, choose Edit > Invert Selection. 

•	 To deselect all selected files, choose Edit > Deselect All. 

See also 

“To manage files with Bridge” on page 88 

“To manage folders with Bridge” on page 89 

To open files in Bridge 
You can open files in Bridge, even files that were not made with Adobe Creative Suite applications. 

1 Select the file in the current folder. 

2 Do one of the following: 

•	 Choose File > Open. 

•	 Press Enter (Windows) or Return (Mac OS). 

•	 Double-click the file in the content area or Preview panel. 

•	 Choose File > Open With, followed by the name of the application with which to open the file. 
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• Drag the file into the working area of an application, such as an open Illustrator document. 

• Drag the file onto the application icon. 

• Choose File > Open With Camera Raw to edit the Adobe camera raw settings for the file. 

See also 

“To manage files with Bridge” on page 88 

“To manage folders with Bridge” on page 89 

To manage files with Bridge 
Adobe Bridge makes it easy to drag and drop files, move them between folders, copy and duplicate them, and 

otherwise manipulate them. 

Note: From Bridge, you can also use Adobe Version Cue to manage files you author in Adobe Creative Suite applications. 

You can create and manage revisions to files kept in Version Cue projects. Version Cue is also a convenient environment 

for collaborative file management in workgroups. You can manage not only Adobe Creative Suite files but also non-

Adobe files. 

❖ Do any of the following:


To delete files Select the files and click the Delete button
 , click Delete on your keyboard, choose File > Send To 

Recycle Bin (Windows), choose File > Move To Trash (Mac OS), drag the file to the Recycle Bin or Trash, or choose 

Edit > Cut. 

To copy files and folders Select the files or folders and choose Edit > Copy, or Ctrl-drag (Windows) or Option-drag 

(Mac OS) the file or folders to a different folder. 

To duplicate files Select the files and choose Edit > Duplicate. 

To paste files Choose Edit > Paste. 

To move files to another folder Select the files and drag them to a different folder. (When you search for Adobe 

Stock Photos, you can’t drag images to other areas, because some images may be comp thumbnails. To drag a comp 

image, first download it and then drag it from the downloaded comp’s folder.) 
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To quickly attach an image to an e-mail message, drag the image from Bridge and drop it into the e-mail message. 

To rename files Click the file name, type a new name, and press Enter (Windows) or Return (Mac OS). 

To manually reorder files in the content area Drag the file to a new location in the content area. 

To display the location of a file in the operating system Select the file and choose File > Reveal In Explorer 

(Windows) or File > Reveal In Finder (Mac OS). 

To find the location of a file in a collection Select a file and choose File > Reveal In Bridge. By default, if you select 

a file in a collection, it is listed as being located in the folder “File Results.” Selecting Reveal In Bridge moves you to 

the folder in which the file is located. 

To place files into an application Select the files and choose File > Place, followed by the name of the application. 

For instance, you can use this command to place a JPEG image into Illustrator. You can also drag files from Bridge 

into an application. Depending on the file, the document into which you want to place it may need to be open first. 

To eject attached media such as CDs and DVDs Select the medium and choose File > Eject. 

To drag files out of Bridge Select  the files  and drag them onto the  desktop or into another  folder. This action copies  

the file (Windows) or moves the file (Mac OS) onto the desktop or folder. 

To drag files into Bridge Select  one or more files  on  the desktop, in a folder, or in another  application that supports  

drag and drop, and drag them into the content area in Bridge. The files are moved from their current folder into the 

one displayed in Bridge. (If the file you are dragging is in a different mounted volume than Bridge, the file is copied 

into Bridge.) 

Drag a file or folder onto the Preview panel to display the contents of the folder in Bridge. 

See also 

“To search for files and folders with Bridge” on page 91 

“To batch-rename files with Bridge” on page 95 

“To run automated tasks with Bridge” on page 94 

“Working with Version Cue in Bridge” on page 101 

To manage folders with Bridge 
❖ Do any of the following: 

To create new folders Click the Create A New Folder button or Choose File > New Folder. Then, enter a name 

when the folder appears in the content area. 

To delete folders Select the folder and click the Delete button , press Delete on your keyboard, or choose File > 

Move To Recycle Bin (Windows) or File > Move To Trash (Mac OS). 

To add folders to Favorites Choose  a folder from the  Look  In  menu  or  Folders panel  or  select  it  in  the content  area.  

Then choose File > Add To Favorites. You can also drag the folder from the content area to the Favorites panel. 

To remove folders from Favorites In  the Favorites  panel,  select  the folder you  want  to  remove. Then choose File  >  

Remove From Favorites. 
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To reorganize folders in the Favorites panel Drag the folder to the desired location in the panel. 

To rename folders Click the folder name, type a new name, and press Enter (Windows) or Return (Mac OS). 

See also 

“About Adobe Bridge” on page 79 

“To manage files with Bridge” on page 88 

To rotate images with Bridge 
You can rotate the view of JPEG, PSD, TIFF, and camera raw file images in Bridge. Rotating an image in Bridge may 

rotate it in the application in which it was created as well. Rotating does not affect the data in the image file. 

1 Select one or more images in the content area. 

2 Do one of the following: 

• To rotate the images 90˚ clockwise, click the Rotate 90˚ Clockwise button  or choose Edit > Rotate 90˚


Clockwise.


• To rotate the images 90˚ counterclockwise, click the Rotate 90˚ Counterclockwise button  or choose


Edit > Rotate 90˚ Counterclockwise.


• To rotate the image 180˚, choose Edit > Rotate 180˚. 

See also 

“About Adobe Bridge” on page 79 

“To manage files with Bridge” on page 88 

To label files with Bridge 
Labeling files with a color is a flexible way to quickly mark a large number of files. Using the View > Sort menu or 

Unfilter button, you can choose to view files according to their label. 

For example, suppose you’ve just imported a large number of images and are viewing them in Bridge. As you review 

each new image, you can label those you want to keep. After this initial pass, you can use the Unfilter button to display 

and work on files you’ve labeled with a particular color. 

You can assign names to labels through the Preferences dialog box. The name is then added to the file’s metadata 

when you apply the label. 

Note: When you view folders, Bridge shows both labeled and unlabeled files until you choose another option. Also, 

purging the cache deletes labels from files that don’t support XMP write (such as BMP, DCS, Pict, PS6 PDF, and PSB 

files), locked files, or read-only files (such as files on CDs). 

1 Select one or more files. 

2 Do one of the following: 

• To label files, choose a color from the Label menu. 

• To remove labels from files, choose Label > No Label. 
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See also 

“About Adobe Bridge” on page 79 

“To specify how files and folders are shown in Bridge” on page 86 

To rate files with Bridge 
You can assign ratings to files, awarding from zero to five stars. Using the View > Sort menu or Unfilter button, you 

can choose to view files according to their rating. 

For example, suppose you’ve just imported a large number of images and are viewing them in Bridge. As you review 

each  new image, you  can rate them from best to worst. After  this  initial pass,  you can  view  only  files you’ve rated  with  

four or five stars and work on those. 

1 Select one or more files. 

2 Do any of the following: 

•	 In Thumbnail view, click the dot representing the number of stars you want to give the file. (Dots do not appear 

in very small thumbnail views. If necessary, rescale the thumbnail view until the dots appear.) 

•	 Choose a rating from the Label menu. 

•	 To add one star, choose Label > Increase Rating. 

•	 To remove one star, choose Label > Decrease Rating. 

•	 To remove all stars, choose Label > No Rating or click the No Rating icon  on the thumbnail of the file. 

See also 

“About Adobe Bridge” on page 79 

“To specify how files and folders are shown in Bridge” on page 86 

To search for files and folders with Bridge 
You can perform searches with Bridge. You can narrow your search by adding multiple search criteria. You can even 

save your search criteria as a collection, so that you can perform the same search again later. 

Note: For information on searching for Adobe Stock Photos with Bridge, see Help. 

1	 Choose Edit > Find.


2 In the Find dialog box, choose a source folder from the Look In menu. By default, the menu displays the currently


active folder. Click the Browse button to navigate to another folder.


3 (Optional) Select Include All Subfolders to expand the search to any subfolders in the source folder.


4 (Optional) Select Search Past Versions Of Version Cue Files to include past versions of Adobe Version Cue files,


as well as current ones, in the search.


5 (Optional) Select Show Find In A New Browser Window to display the search results in a new Bridge window. If


left unselected, the search results appear in the content area of the current window.


6 Choose a criterion for your search by selecting an option from the leftmost Criteria menu.


7 Select a limiter from the center Criteria menu.


8 Enter the search text in the text box at the right, if needed. You can enter basic search terms such as AND, OR, and


* (for wild cards). 
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9 To add search criteria, click the plus sign button. To remove search criteria, click the minus sign button. 

10 Click Find. Bridge displays the files that match the search criteria, and you can navigate through the files. 

11 (Optional) To save the search criteria to perform the same search again, click Save As Collection. Enter a name 

for the collection. Select Start Search From Current Folder to search from the same folder in the future. Then, click 

Save. The search criteria are saved in the Collections folder listed in the Favorites panel. 

See also 

“To manage files with Bridge” on page 88 

“To search with criteria saved as collections” on page 92 

To search with criteria saved as collections 
If you saved search criteria by using the Save As Collection option in the Find dialog box, you can run that search


again by using that collection.


1 Select Collections in the Favorites panel or Look In menu.


2 Double-click the collection you want.


A new Bridge window appears containing the results of the search.


See also 

“To manage files with Bridge” on page 88 

“To search for files and folders with Bridge” on page 91 

Bridge Center 

About Bridge Center 
If you are working with the Adobe Creative Suite, Bridge Center gives you quick access to your most recent files and 

folders, RSS newsreaders for the latest information, tips and tricks for using Adobe products, color management 

features, and Help documentation. It even lets you start new Version Cue projects. 

To display Bridge Center, select it in the Favorites panel. 

Note: If you don’t see Bridge Center in the Favorites panel, make sure that Center is selected in the General preferences. 

See “To set Bridge preferences” on page 83. 

Adobe Stock Photos Opens the Adobe Stock Photos home page in Bridge. 

Saved File Groups Lists sets of files that you have saved as a group, even if they are being used in separate applica

tions.  When  you create a saved file group, you  assemble  and name a set of files, which  Bridge  then  closes. When you  

open a saved file group, Bridge reopens the current version of those files, launching the appropriate Adobe Creative 

Suite applications as needed. See “To work with saved file groups in Bridge Center” on page 93. 

Note: Saved file groups do not preserve versions of files; groups always contain the most current version of the files. For 

instance, suppose  you include  the file logo.jpg in a saved file group. If you  open  the saved  file  group later, edit the  logo.jpg  

file, and save it in another group, both saved file groups will contain the same logo.jpg file. 
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Recent Folders Lists your most recently visited folders. See “To use recent folders or files from Bridge Center” on 

page 93. 

Recent Files Displays the most recently opened files. 

RSS Reader RSS displays shared web content, such as headlines from different websites and the latest information 

on products from Adobe. RSS stands for Really Simple Syndication and is an XML format used to gather and 

distribute web content while reducing traffic to websites. See “To use RSS content in Bridge Center” on page 94. 

Tips And Tricks Lists helpful tips and tricks for getting the most out of Adobe Creative Suite and other Adobe appli

cations. Click the Next button or Previous button to go to the next or previous tips and tricks topic. 

Note: Click Close  or  Open  located above  the bottom tabs to hide or reveal the  RSS  Reader  area  and Tips And  Tricks  area.  

New Version Cue Project Opens the New Version Cue project and displays a dialog box for creating a new project. 

Color Management/Open Color Settings Opens the Color Settings dialog box so that you can manage color for 

Adobe Creative Suite applications. Also displays the Adobe Creative Suite Color Settings state (Synchronize or 

Unsynchronize). 

Open Help Starts Adobe Help Center. 

To work with saved file groups in Bridge Center 
1 Click Bridge Center in the Favorites panel. 

Note: Bridge Center is available with Adobe Creative Suite only. 

2 In the Saved File groups, do any of the following: 

• To save your currently open files as a group, click the text Save Open Files into a File Group. 

• To open a saved file group, select the group and click the text Open this File Group. 

• To display a group in the content area, click the name of that file group. 

• To delete a saved file group, select the group and click Delete at the bottom. 

To use recent folders or files from Bridge Center 
1 Click Bridge Center in the Favorites panel. 

Note: Bridge Center is available with Adobe Creative Suite only. 

2 In the Recent Folders or Recent Files Group, do any of the following: 

• To display a folder in the content area, click that folder. 

• To sort the folders by name or date, click Name or Date. 

• To open a file in the default application, click the file thumbnail or file name. 

• To display the folder that contains a file, click the Shell icon  next to the file name. The folder is displayed in 

the content area. 

• To sort the folders by name, date, or type, click Name, Date, or Type. 
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To use RSS content in Bridge Center 
RSS (Really Simple Syndication) is an XML format for gathering and distributing web content. It displays web 

content, such as the latest information on Adobe products. 

1	 Click Bridge Center in the Favorites panel. 

Note: Bridge Center is available with Adobe Creative Suite only. 

2	 In the RSS Reader section, do any of the following: 

•	 To view content, click to select an RSS site from the list on the left, and then click to select a specific topic from the 

list on the right. If you want, click More to start your default web browser and display further information on the 

topic from that RSS website. 

•	 To add the URL of an RSS site, click the plus sign (+) at the top of the tab. 

•	 To delete an RSS site from the list, select the site and click the minus sign (-). 

•	 To specify how often to check RSS sites for updates, click Open Settings and enter a number specifying the interval, 

in hours. 

•	 To check the RSS sites for updates manually, Click Update Now. 

Running automated tasks with Bridge 

To run automated tasks with Bridge 
The Tools menu contains submenus for various commands available in the different Adobe Creative Suite applica

tions. For instance, if you have Adobe Photoshop installed, you can use the commands under the Tools > Photoshop 

submenu to make picture packages and create Photomerge panoramas using photos you select in Bridge. Running 

these tasks from Bridge saves time because you don’t have to open each file individually. 

Note: Third parties can also create and add their own items to the Tools menu for added functionality in Bridge. For 

information about creating your own scripts, see Bridge JavaScript Scripting Reference. 

1 Select  the files  or  folders you  want  to  use.  If  you select a folder, the  command is applied  where possible to all  files  

in the folder. 

2 Choose Tools > [Application], followed by the command you want. (If your application doesn’t have any 

automated tasks available, no application name appears in the menu.) 

For information about a particular command, see the documentation for that application. 

See also 

“About Adobe Bridge” on page 79 

“To manage files with Bridge” on page 88 

“To batch-rename files with Bridge” on page 95 
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To batch-rename files with Bridge 
You can rename files and folders in a group, or batch. When you batch-rename files, you can choose the same settings 

for all the selected files, saving time. 

1	 Do one of the following: 

•	 Select the files that you want to rename. 

• Select a folder in the Folders panel. The new setting will apply to all the files in the folder.


2 Choose Tools > Batch Rename.


3 Set the following options and click Rename:


•	 For Destination Folder, select whether you want to place the renamed files in the same folder or in a different 

folder, move them to another folder, or place a copy in another folder. If you select Move To Other Folder or Copy 

To Other Folder, click Browse to select the folder. 

•	 For New Filenames, choose elements from the menus or enter text into the text boxes. The specified elements and 

text  are combined to create the  new file name.  You can  click the  + button or - button  to  add or delete elements.  A  

preview of the new file name appears at the bottom of the dialog box. 

Note: If you choose Sequence Number, enter a number. The number is automatically incremented for each file named. 

•	 Select Preserve Current File Name In XMP Metadata if you want to retain the original file name in the metadata. 

•	 For Compatibility, select the operating systems with which you want renamed files to be compatible. The current 

operating system is selected by default, and you can’t deselect it. 

See also 

“About Adobe Bridge” on page 79 

“To manage files with Bridge” on page 88 

Metadata in Bridge 

About metadata 
Metadata is information about the file, such as its author, resolution, color space, copyright, and keywords applied 

to it. You can use metadata to streamline your workflow and organize your files. This information is stored in a 

standardized way using the Extensible Metadata Platform (XMP) standard on which Adobe Bridge and the Adobe 

Creative Suite applications are built. XMP is built on XML, and in most cases the information is stored in the file so 

that  it  isn’t lost.  If  it  is  not possible to store  the information  in  the file itself,  XMP  metadata  is  stored  in  a separate file  

called a sidecar file. 

Many of the powerful Bridge features that allow you to organize, search, and keep track of your files and versions 

depend on XMP metadata in your files. Bridge provides two ways of working with metadata: through the Bridge 

Metadata panel and through the File Info dialog box. These methods provide different views into the XMP metadata 

stored in the file. In some cases, multiple views may exist for the same property; for example, a property may be 

labeled Author in one view and Creator in another, but both refer to the same underlying property. Even if you 

customize these views for specific workflows, they remain standardized through XMP. The Advanced view in the File 

Info dialog box displays the fundamental values being stored. 

 



96 ADOBE PHOTOSHOP CS2 
User Guide 

Metadata that is stored in other formats, such as EXIF, IPTC (IIM), GPS, and TIFF, is synchronized and described 

with XMP so that it can be more easily viewed and managed. Other applications and features (for example, Adobe 

Version Cue) also use XMP to communicate and store information such as version comments. For instance, when 

you save a file  in  Version Cue, you  might add  the comment  that  you rotated  the file when you  worked  on  it. Later  on,  

you could use Bridge to navigate to that Version Cue project and search for the term “rotate” to locate that file. 

In most cases the metadata remains with the file even when the file format changes, for example, from PSD to JPG. 

Metadata is also retained when those files are placed in an Adobe InDesign layout. 

You can use the XMP Software Development Kit to customize the creation, processing, and interchange of metadata. 

For example, you  can use  the XMP  SDK to add  fields  to  the File Info dialog box. More information on XMP  and the  

XMP SDK is available from the Adobe Solutions Network (www.adobe.com/xmp). 

About the Metadata panel in Bridge 
From the Metadata panel, you can view and edit the metadata for selected files, use metadata to search for files, and 

use templates to append and replace metadata. Metadata preserves information about the contents, copyright status, 

origin, and history of documents. Version Cue uses metadata to manage files. 

You can specify the types of metadata displayed in the Metadata panel. 

Note: If you have applied metadata to an Adobe Acrobat® PDF file, some keywords may not appear; however, these 

keywords are still attached to the PDF file. 

Depending on the selected file, the following types of metadata appear in the Bridge Metadata panel: 

File Properties Describes the characteristics of the file, including the size, creation date, and modification date. 

IPTC Core Displays editable metadata. You can add captions to your files as well as copyright information. IPTC 

Core is a new specification that was approved by IPTC (International Press Telecommunications Council) in 

October 2004. It differs from the older IPTC (IIM, legacy) in that new properties have been added, some property 

names have changed, and some properties have been deleted. You can display the older IPTC (IIM, legacy) metadata 

by selecting it from the Metadata options in the Preferences dialog box. 

IPTC (IIM, legacy) Displays editable metadata. As with IPTC Core, you can add captions to your files as well as 

copyright information.This set of metadata is hidden by default, because it has been superseded by IPTC Core. 

However, you can choose it by selecting it from the Metadata options in the Preferences dialog box. 

Fonts Lists the fonts used in Adobe InDesign files. 

Swatches List the swatches used in Adobe InDesign files. 

Camera Data (Exif) Displays information assigned by digital cameras. EXIF information includes the camera 

settings used when the image was taken. 

GPS Displays navigational information from a global positioning system (GPS) available in some digital cameras. 

Photos without GPS information don’t have GPS metadata. 

Camera Raw Displays settings applied by the Camera Raw plug-in. 

Edit History Keeps a log of changes made to images with Photoshop. 

Adobe Stock Photos Lists information about images obtained from Adobe Stock Photos. 

Version Cue Lists any Version Cue version information about the file. 

Note: Depending on the applications you are using, custom panels for various properties may appear here as well. 
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See also 

“To add metadata using the File Info dialog box” on page 98 

“To view metadata with Bridge” on page 97 

“To specify the metadata displayed in the Metadata panel” on page 98 

To view metadata with Bridge 
❖ Do any of the following: 

•	 Select  one or more files  and view the  information in the  Metadata  panel.  If  you select multiple files, only metadata  

that is common to the files appears. Use the scroll bars to view hidden categories. Click the triangle to display 

everything within a category. 

You can  change  the font size in the  panel by choosing Increase Font Size or Decrease Font Size from the  panel menu.  

•	 Select one or more files and choose File > File Info. Then, select any of the categories listed on the left. 

•	 Choose View > As Details or View > As Versions And Alternates to display the metadata next to the thumbnails 

in the content area. This is especially useful for viewing Version Cue files. 

•	 Position  the pointer  over  a thumbnail  in  the content  area. (Metadata  appears in a tool  tip only if Show Tooltips is  

selected in General preferences.) 

See also 

“About Adobe Bridge” on page 79


“To create and close Bridge windows” on page 81


“About the Metadata panel in Bridge” on page 96


To edit metadata with Bridge

1 Click the pencil icon to the far right of the metadata field you want to edit.


2 Type in the text box to edit or add metadata.


3 Press Tab to move through metadata fields.


4 When you have finished editing the metadata, click the Apply button
 at the bottom of the Metadata panel. To 

cancel any changes you’ve made, click the Cancel button  at the bottom of the panel. 

See also 

“About the Metadata panel in Bridge” on page 96 

“To work with metadata templates in Bridge” on page 99 

“To apply metadata templates to files in Bridge” on page 100 
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To specify the metadata displayed in the Metadata panel 
1 Do one of the following: 

•	 Choose Preferences from the Metadata panel menu. 

•	 Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS), and then click Metadata from the list on 

the left side of the dialog box. 

2 Select the metadata fields that you want to display in the Metadata panel. 

3 Select the Hide Empty Fields option if you don’t want to view fields with no information in them. 

4 Click OK. 

See also 

“About Adobe Bridge” on page 79 

“To create and close Bridge windows” on page 81 

“About the Metadata panel in Bridge” on page 96 

To add metadata using the File Info dialog box 
The File Info dialog box displays camera data, other file properties, an edit history, copyright and authorship infor

mation (if any), and custom metadata panels (if the application has installed them). You can add metadata directly 

from the File Info dialog box. If you select multiple files, the dialog box shows where different values exist for a text 

field. Any information you add to a field is applied to all selected files. 

Note: You can also view metadata in the Metadata panel, in certain views in the content area, and by placing the pointer 

over the thumbnail in the content area. 

1	 Select one or more files. 

2	 Choose File > File Info. 

3	 Select any of the following from the list on the left side of the dialog box: 

Description Lets you enter document information about the file, such as document title, author, description, and 

keywords that can be used to search for the document. You can also choose text from the menu to the right of the 

text fields. To specify copyright information, select Copyrighted from the Copyright Status pop-up menu. Then enter 

the copyright notice string and the URL of the person or company holding the copyright. 

Categories Lets you enter information based on Associated Press categories. You can also choose text from the 

menu to the right of the text fields. The Categories option appears only if Adobe Photoshop is installed. 

History Displays Adobe Photoshop history log information for images saved with Photoshop. The History option 

appears only if Adobe Photoshop is installed. 

Camera Data 1 Displays read-only information about the camera and settings used to take the photo, such as make, 

model, shutter speed, and f-stop. The Camera Data 1 option appears only if Adobe Photoshop is installed. 

Camera Data 2 Lists read-only file information about the photo, including pixel dimensions and resolution. The 

Camera Data 2 option appears only if Adobe Photoshop is installed. 

Adobe Stock Photos Lists read-only information about images obtained from Adobe Stock Photos. 

 



99 ADOBE PHOTOSHOP CS2 
User Guide 

Origin Lets you enter file information that is useful for news outlets, including when and where the file was created, 

transmission information, special instructions for handling the file, and headline information. You can also choose 

text from the menu to the right of the text fields. 

Advanced Displays fields and structures for storing metadata using namespaces and properties, such as file format 

and XMP, EXIF, and PDF properties. You can do any of the following with the information listed: 

•	 Click Save to export the metadata to a text (.xmp) file. 

•	 Click Replace to replace the metadata in the existing files with metadata saved in an .xmp file. Values in existing 

properties are replaced with the new values. 

•	 Click Append to add the metadata in the existing files to metadata saved in an .xmp file. Values in existing 

properties are not replaced, and new values are appended or inserted where appropriate. 

•	 Click Delete to remove the currently selected Advanced property. You can Shift-click to select multiple properties. 

Note: Hold down the Option key to change these commands to Replace All, Append All, and Delete All. These commands 

then affect all information in the file; that is, EXIF information that is not modifiable by the user, such as the f-stop and 

the Photoshop file ID information, as well as user-modifiable information, such as document title and keywords. Holding 

down Option also displays the Reset button to restore the previous settings. 

4	 Click OK to apply the changes. 

See also 

“About Adobe Bridge” on page 79 

“To create and close Bridge windows” on page 81 

“About the Metadata panel in Bridge” on page 96 

To work with metadata templates in Bridge 
You can modify the metadata in the File Info dialog box and save it as a template for use with other files.


1 Create a new file using an Adobe Creative Suite application. This creates a file without metadata from any other


source.


2 Select the file.


3 Choose File > Info.


4 Enter the desired information in the File Info dialog box.


5 Choose any of the following from the menu at the upper right of the File Info dialog box:


•	 To save the metadata in the File Info dialog box as a template for use with other files, choose Save Metadata 

Template. Enter a name for the template and click Save. 

•	 To delete an existing metadata template, choose Delete Metadata Template. Choose the template you want to 

delete from the menu in the dialog box and click Delete. 

•	 To open the folder containing metadata templates, choose Show Templates. 

6 Click OK. You can now also apply metadata templates to files with the Append Metadata and Replace Metadata 

commands in the Tools menu and in the Metadata panel menu. 
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See also 

“About the Metadata panel in Bridge” on page 96 

“To apply metadata templates to files in Bridge” on page 100 

To apply metadata templates to files in Bridge 
After you have saved metadata for one file, you can apply it to others. 

1 Select one or more files.


2 Choose either of the following commands from the Metadata panel menu or the Tools menu:


•	 Append  Metadata, followed by the  name  of  the template.  This  command applies  the template metadata only where  

no metadata value or property currently exists in the file. 

•	 Replace Metadata, followed by the name of the template. This command completely replaces any existing metadata 

in the file with the metadata in the template. 

See also 

“About the Metadata panel in Bridge” on page 96 

“To add metadata using the File Info dialog box” on page 98 

To apply keywords to files with Bridge 
The Keyword panel lets you create and apply Bridge keywords to files. Keywords can be organized into categories 

called keyword sets. Using keywords, you identify files based on their content. Later, you can view all files with shared 

keywords as a group. 

Note: Bridge keywords are distinct from XMP keywords created with the File Info dialog box. The latter are displayed in 

Version Cue files in the “Other Metadata” section of the File Info dialog box. 

❖ Do any of the following: 

•	 To add a keyword to files, select one or more files. In the Keywords panel, click the box next to the name of the 

keyword you want to add. A check mark appears in the box next to the keyword when it’s added to a file. 

•	 To  add a set of keywords to files, select one  or  more  files.  In  the Keywords panel, click  the box  next  to  the name of  

the keyword set. A check mark appears in the box next to the keyword set when it’s added to a file. 

Create a group of frequently used keywords so that you can apply them as a group. 

•	 To remove keywords from a file, select the file, and then click the box next to the name of the keyword or keyword 

set that you want to remove. 

•	 To create a new keyword, click the New Keyword button  at the bottom of the panel or choose New Keyword 

from  the panel  menu. A new default  keyword name appears  in  the panel. To create the  new keyword, type over the  

default name and press Return. 

•	 To create a new keyword set, click the New Keyword Set button  at the bottom of the panel or choose New 

Keyword Set from the panel menu. A new default keyword set name appears in the panel. To create the new 

keyword set, type over the default name and press Return. 

•	 To rename a keyword or keyword set, select the keyword or keyword set and choose Rename from the panel menu. 

Then, type over the name in the panel and press Return. 
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Note: When you rename a keyword, the keyword’s name isn’t changed in files that currently contain it. The original 

name stays in the file. 

• To move a keyword to a different keyword set, drag the keyword from one set to another. 

• To  delete  a keyword, select the  keyword by clicking its  name, and  then  click the  Delete  Keyword button  at the  

bottom of the panel or choose Delete from the panel menu. 

Note: Keywords that you get from other users appear in the Other Keywords category until you recategorize them. To 

make these keywords permanent in Bridge, select the keyword and then choose Persistent from the context menu. 

• To find a file using the keyword, choose Find from the panel menu. 

Note: You can’t modify keywords in search results for Adobe Stock Photos. 

See also 

“About Adobe Bridge” on page 79 

“To search for files and folders with Bridge” on page 91 

Using Version Cue with Bridge 

Working with Version Cue in Bridge 
Adobe Bridge and Version Cue work together to give you an intuitive way to access and manage Version Cue files 

and projects. 

Bridge provides comprehensive visualization of and centralized command over all aspects of Version Cue files and 

projects. You can use Bridge to access Version Cue Workspaces, create a project in any of those workspaces, and 

create a project folder hierarchy. You can drag files into project folders and drag files from a project folder into non

project folders on your hard drive. You can also copy and move files within and between project folders. 

The search capabilities of Bridge enable you to locate project files using file information such as version comments, 

or keywords or fonts contained in your files. You can view files that have been deleted (but not permanently deleted) 

in projects and you can restore deleted files using Bridge. 

Working with versions in Bridge As  you save versions of project  files as they evolve,  you can  use the  Versions  View  

in Bridge to see all previous versions of the files, delete previous versions, and promote previous versions. You can 

get information not only about the current version of a file, but also about the version comment for each previous 

version without having to open the files in their native applications. However, if you need to view a previous version 

in more detail, you can use Bridge and Version Cue to open that version. You can view Version Cue file info 
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(metadata) in the Details view, Versions And Alternates view, in tooltips, and in the Metadata panel. Bridge is instru

mental in helping you create and track versions of non-Adobe file types that are in the projects in your Version Cue 

Workspace. When you use Bridge to open a file in a project, you can create a Version Cue version even if an appli

cation doesn’t have a Save A Version command. You can manage and use those versions as you would if they were 

created from files made by Adobe Creative Suite components. 

Working with alternates in Bridge Bridge also makes it easy to work with Version Cue alternates. You can use 

Bridge to designate files as alternates of each other, or to generate alternates from previous versions of a file. In the 

Alternates view, you can see the complete group of alternates that have been designated for a project file as well as 

which of these alternates is the primary (preferred) member of the group. A file’s inclusion in a group of alternates is 

indicated by an icon in all  Bridge  views as well as by text indications  in  the Details  and Versions And  Alternates  views.  

Alternates don’t have to be located within a single folder, and you can use Bridge to add files to an alternates group 

no matter where they are located in a project. In Alternates View, it’s easy to navigate to the folders that contain alter

nates. You can remove files from a group of alternates as well as dissolve the group completely in Bridge. 

Viewing Workspace, project, and file information Because you may not always be connected to the network on 

which a particular  Version Cue  Workspace is located, Bridge indicates  the availability of the  workspaces  and projects  

you’ve accessed by displaying different icons of workspaces and projects. When your Version Cue Workspace is 

online, you can view up-to-date status for all files you’ve created with Adobe Creative Suite components. This helps 

you understand whether a file is already in use, or whether another user has created a newer version. Normally, when 

you start  editing a project file in a Version Cue  Workspace,  the file’s status changes to In Use  because you’re making  

changes to the  file. However, you  can use  Bridge  to  mark  a file In Use  without having to open the  file. You  can cancel  

the Mark In Use indication at any time. You can also use Mark In Use to prepare project files for offline editing when 

you know you’ll be disconnected from a remote  Version Cue Workspace. When you come back online, you can use 

Bridge to synchronize your files with your workspace once the workspace is available again. For more information 

about working with Version Cue, see “Adobe Version Cue” in Help. 

Version Cue Workspace and project icons in Bridge 
Bridge displays status icons for Version Cue Workspaces and projects to let you know if they’re available, shared, 

local, or remote. 

• Available and Not Shared  Indicates a project that’s available and not shared with other users. 

• Available and Shared  Indicates a project that’s available and shared with other users. 

• Local Files Only  Indicates a project that contains only local files. 

• Workspace Not Available  Indicates a workspace that’s offline. 

• Workspace On Own Hard Drive  Indicates a workspace that’s local to your computer. 

• Remote Workspace Online  Indicates a remote workspace that’s available. 
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Adobe Stock Photos 

About Adobe Stock Photos 
Welcome to Adobe Stock Photos, the newest way to view, try, and buy royalty-free images from leading stock 

libraries. With Adobe Stock Photos, you won’t have to interrupt your design process to find quality images. Instead, 

from inside your favorite applications, you can use the powerful search capabilities of Adobe Stock Photos to find 

and download images. 

From Bridge, the Favorites pane gives you quick access to these stock images. With your computer connected to the 

Internet, simply click the Adobe Stock Photos icon to start browsing thousands of available images. Because of the 

tight integration between Stock Photos and Adobe Creative Suite components, you can download images from 

Adobe Stock Photos directly into your Illustrator, InDesign, and GoLive projects. From Photoshop, you can open any 

downloaded image. 

In the design process, you need the flexibility to try different images before deciding which one you want. Adobe 

Stock Photos gives you the option to download low-resolution, complementary (comp) versions of images you’re 

considering. You can work with the comps until you make your final decision, at which point you can purchase and 

download a high-resolution image. 

For maximum convenience, you can open an account with Adobe. The benefit of opening an account is that you 

enter your personal information only once, greatly simplifying the checkout process. You can also look back at 

previous purchases, and even download photos again after you purchase them. 

See also 

“About comp images” on page 106 

“Benefits of Stock Photos accounts” on page 109 

“Buying stock photos” on page 107 

Searching for images in Adobe Stock Photos 
There are  a few  ways  to  search  for images in Stock  Photos. If you  need  help  getting a project started, a broad search  

may yield a fund of possibilities and suggest areas to explore. If you have a clear idea of what you need, then you can 

use Advanced Search to narrow the field. 

Related keywords also help you find photos. After you find photos, you can start a new search by selecting one or 

more related keywords. Each image is associated with keywords that help you find similar images. The more 

keywords you select, the narrower the search results. 

Photos matching the search criteria appear as thumbnails in the main window. You can resize the thumbnail by 

dragging the Thumbnail slider at the bottom of the screen. When you click an image in search results, a comp image 

appears in the  Preview pane (it  may take several  seconds for  the image  to  appear  in  the pane).  To  enlarge the  comp,  

simply resize the Preview pane. You can view metadata information about the image in the Metadata pane under 

Adobe Stock Photos Metadata. 
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Your previous searches are automatically saved in Stock Photos in the Favorites pane. Click Previous Searches to 

display the list. To see the search results, double-click a search. To delete a search, select it and press the Delete key 

(Windows), right-click the search and then choose Send To Recycle Bin (Windows), or Control-click the search and 

choose Move To Trash (Mac OS). 

All thumbnails from recent searches are  saved on your computer.  Having  the thumbnails available  offline is helpful  

if you want to browse through the images when your computer isn’t connected to the Internet. However, the thumb

nails do take up some space on your hard drive. At some point, if you want to delete these thumbnails, delete the 

searches (as described above), or remove them manually from the default file location: My Documents/AdobeStock-

Photos/Previous Searches (Windows), or Documents/AdobeStockPhotos/Previous Searches (Mac OS). 

See also 

“To adjust the Bridge window” on page 82


“To view file and folder thumbnails in Bridge” on page 85


To search for stock photos

1 In Bridge, click Adobe Stock Photos in the Favorites pane.


2 In  the text box  at  the top  of  the screen,  type  the word or phrase that describes  the subject  of  the photos you  want 


to search for.


3 Click the Search button
  or press Enter. 

Images matching the search criteria are displayed in batches. (There is a preference for changing the number of 

images displayed in a batch.) To view more images, click More Results. Click a photo to view more information, such 

as its price and keywords associated with it. 

See also 

“Search tips” on page 105 

“To view image price and keywords” on page 105 

To use Advanced Search 
Advanced Search is a powerful tool that helps you find exactly the right photo. You can combine several search


criteria to narrow your results.


1 In Bridge, click Adobe Stock Photos in the Favorites pane.


2 Click the Advanced Search button


3 Search using any combination of the following options:


. 

•	 Type a descriptive keyword or keywords in the text box to find related images. Alternatively, type an image ID, if 

you know the ID of the photo you want to use. 

•	 To restrict searches to a specific media type, choose one or more options under Media Types. 

•	 To search by the orientation of the photo, select the acceptable shapes under Orientation. 

• Select the name of one or more providers to limit the search. 

4 Click the Search button to display images matching the search criteria. 
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See also 

“Search tips” on page 105 

To search with related keywords

1 In Bridge, click Adobe Stock Photos from the Favorites pane.


2 In  the text box  at  the top  of  the screen,  type  the word or phrase that describes  the subject  of  the photos you  want 


to search for.


3 In the search results, click a photo to select it.


4 Do one of the following:


• Click the Get Price & Keywords button. 

• Right-click the image (Windows) and choose Get Price & Keywords from the menu. 

5 When the Price & Keywords dialog box appears, select keywords under Keywords For This Image. The more


keywords you select, the narrower the search.


6 When you finish selecting keywords, click the Search Again button to begin a new search using the keywords.


To view image price and keywords 
You can view size and price information, as well as related keywords, in the Image Detail dialog box. 

1 In the search results window, click an image to select it. 

2 Do one of the following: 

• Click the Get Price & Keywords button. 

• Right-click the image (Windows) and choose Get Price & Keywords from the menu. 

3 To close the dialog box, click the Close button. 

Note: The currency displayed  in  the Price  & Keywords dialog box  may not  be  the native currency of your billing  country;  

it is the supported currency for purchases made from your country. When you purchase photos from Adobe Stock Photos, 

your credit card will be billed in the supported currency. 

Search tips 
Here are some helpful pointers for refining your searches: 

Misspelled words Double-check your search entries to make sure they’re spelled correctly. 

Trademarked names Brand names may not return full search results. Instead, search for the item by its general 

name. 

Exact phrase searches To view images that exactly match a phrase, type the whole phrase in the Search text box. 

You can enter Boolean operators such AND, OR, or NOT to narrow your search. 

Search by subject To search for a specific subject, use nouns that describe the main subject of a photo, such as 

“bicycle” or “house,” as well as adjectives that modify the nouns, such as “vintage” or “red.” To narrow the search 

further, use verbs that describe an action in the photo. 
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Search by concept Try searching with concepts, or perceptions, such as “romance,” “vitality”, “frustration,” or 

“excitement,” to find an inspiring image. 

Search by style To find photos that reflect a specific photographic or artistic technique, try searching on terms such 

as “profile”, “studio shot,” or “clipping path.” 

Comp images 

About comp images 
Comp images are free, nonwatermarked, low-resolution versions of stock photos that you can download to use in


mock-ups or other preliminary work. You can use comps to capture a feeling, idea, or concept before choosing the


final image for a project. Comps are not licensed for production, but you can use them in mock-ups or other prelim


inary work. Because comps are low-resolution images, they’re not suitable for printing or publishing. After an evalu


ation period, you can purchase a high-resolution version of the image to continue working with the photo.


Metadata is bundled with comp images. This metadata is read by Photoshop, InDesign, Illustrator, and GoLive, and


is used in each application to recognize images as stock photos, even if you rename them. Metadata allows you to


purchase high-resolution versions of images later, even after you move a comp to a project folder or create other


versions of the image. If you are about to send the photo to be printed, InDesign and Illustrator display a warning


that you are using a comp image.


You can view your downloaded comps by clicking Downloaded Comps in the Favorites pane, or you can navigate to


the default folder where comps are saved: My Documents/AdobeStockPhotos (Windows) or Documents/Adobe-


StockPhotos (Mac OS). You can move downloaded comps to any folder you want. To delete a comp in the Stock


Photos window, right-click it and then choose Send To Recycle Bin (Windows) or Control-click it and choose Move


To Trash (Mac OS).


For more information on using comps, see the terms of service (TOS), which describe when and for how long you


can use a comp. A Terms Of Service link is available on the main Adobe Stock Photos screen.


To download comps from Adobe Stock Photos

1 In the search results, click a photo to select it.


2 Do one of the following:


• Click the Download Comp button. 

• Right-click the photo (Windows) and select Download Comp from the menu. 

• Click Get Prices & Keywords and select Free Comp Image in the dialog box. Click the icon to download the comp. 

To view comps in an Adobe Creative Suite application 
From Adobe Stock Photos, you can open and edit a comp in Photoshop, Illustrator, InDesign, or GoLive. You can 

also drag a comp into an application. 

1 In the search results window, right-click the image you want to open. 

2 In the context menu, position the pointer over Open With, and then choose the name of the application in which 

you want to view a comp version of the image. 
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To view saved comps in Stock Photos 
To help you keep track of downloaded comps, you can view them in Bridge. If you decide to purchase a comp, put 

the comp in your shopping cart. 

1 In the Favorites pane, click Adobe Stock Photos. 

2 Click Downloaded Comps to see the comps. 

Buying stock photos 

Buying stock photos 
It’s simple to buy images through Adobe Stock Photos. When you find the photos you want to buy, put them in your 

shopping cart. The photos remain in your cart until you’re ready to complete your purchase. When you finish 

browsing, you can check out and have your images automatically downloaded to your computer. 

Having  an  account with Adobe  speeds  the checkout process. Because  your  contact and  billing information  is  saved,  

you can complete your purchase with just a few clicks. 

Adobe Stock Photos maintains a secure site, and you can rest assured that your personal information is kept in strict 

confidence. Any information you enter is used only for Adobe Stock Photos purposes. 

To view your photos, click Purchased Images in the Favorites pane, or navigate to the default Stock Photos folder: My 

Documents/AdobeStockPhotos (Windows) or Documents/AdobeStockPhotos (Mac OS). 

See also 

“To buy photos” on page 107 

“To buy photos directly from InDesign or Illustrator” on page 108 

To place photos in the shopping cart 
As you find photos you want to purchase, add them to the shopping cart until you’re ready to check out.


1 In the search results window, right-click a photo, and then choose Add To Cart from the context menu. You see a


dialog box confirming that the photo is your shopping cart.


2 Click OK to continue, or click View Shopping Cart to see the contents of your cart.


If you want to disable this dialog box, select Don’t Show Again.


To buy photos

1 To access your shopping cart, click the Shopping Cart icon.


2 Choose  a resolution for  the photos you  want  to  buy.  (You  can remove an item from the  shopping  cart  at  any time 


by clicking the Delete icon
 .)


3 Click Check Out.
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4	 Do one of the following: 

•	 If you have an Adobe account, enter your ID and password. 

•	 If you want to open an Adobe account, click Set Up An Account. You are prompted to enter your billing and 

account information. 

•	 If  you want to buy  the images without  an  account,  click Continue As Guest. You  are prompted to enter  your  billing  

information. Click Continue. 

5	 Do one of the following: 

•	 If you have an Adobe account, confirm your billing information and click Continue. 

•	 If you don’t have an Adobe account, enter your billing information and click Continue. 

6	 In the Order Summary page, confirm your choices. To delete a photo from the shopping cart, click the Delete icon. 

7 If you have a promotion code, enter it in the Promotion Code text box and click Apply. You see any changes made 

to your order as a result of applying the promotion code. 

8 Click the check box to accept the terms of the Adobe Stock Photos License Agreement (click the blue text to read 

the agreement). 

9 Finally, click the Purchase Now button to complete the checkout process. Your purchase is processed, then you’re 

prompted to download your photos. 

10 Click Start Download. After the photos are saved, click View Purchased Images if you want to start working with 

them right away. 

11 To view the receipt for your purchase, in the Thank You page click View Receipt. You can also monitor the 

progress of the download by clicking Open Download Status. When you finish, click Find More Images if you want 

to find new photos, or click Go To Your Account. 

If you have been working with a comp version of the image you purchased, you need to replace the comp with the 

high-resolution image in your art. 

Note: To delete the list of high-resolution images waiting for download from the Download Status screen, choose Edit > 

Preferences (Windows) or Bridge > Preferences (Mac OS). Select Adobe Stock Photos, and then click the Clear Now 

button. 

See also 

“To create a Stock Photos account” on page 109 

“To set Adobe Stock Photos preferences” on page 112 

To buy photos directly from InDesign or Illustrator 
To seamlessly integrate Adobe Stock Photos into your design process, you can use the Place command to use 

downloaded comps in your work. When you’re ready to purchase a photo, you can start the process from InDesign 

or Illustrator. Then, you can use the Links palette to replace the comp with the full image. 

1 In Illustrator or InDesign, right-click a comp image and then choose Purchase This Image from the menu. 

2 Adobe Stock Photos starts, and the photo is automatically placed in your shopping cart. 

3 After purchasing the image, return to Illustrator or InDesign, and then click Re-link in the Links palette. 
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4 Navigate to the Purchased Images folder in the Adobe Stock Photos folder: My Documents/AdobeStockPhotos 

(Windows), or Documents/AdobeStockPhotos (Mac OS). 

5	 Select the purchased image and then click OK. The comp is replaced with the full version of the photo. 

To view order details 
A benefit of having an Adobe account is that you can go back and view your previous orders. 

1 In Adobe Stock Photos, click the Your Account button


2 In the Your Account page, click View Order History.


3 The Your Order History page shows all of your previous orders. To view details about a particular order, click the


. 

order number (highlighted in blue). 

4 In  the Order  Detail  page, you  can see  the billing information, as well as a description of the  photos  you purchased.  

Click Return To Your Account if you’re done, or click Return To Order History if you want to review other orders. 

You can also redownload the photos you purchased. 

Stock Photos accounts 

Benefits of Stock Photos accounts 
Creating an Adobe account makes purchasing photos quick and easy. When you log in with your e-mail address and 

password, you can work with your account in several ways: 

Manage your profile After you complete the registration process, modify your account information anytime by 

clicking the Your Account link in the navigation bar. 

See your order history Track orders made through Adobe Creative Suite Stock Photos to check the specific items 

ordered, the total cost of the purchase, or the order date. 

Download previously purchased items again Access your order history and click Re-download to replace a lost or 

corrupted file for up to one year from the original purchase date. 

Shop with ease Purchase photos without providing profile information. Adobe Stock Photos automatically enters 

your name and address when you make any purchases. All your personal information is securely stored. 

To create a Stock Photos account 
1 In Adobe Stock Photos, do one of the following: 

•	 Click the Your Account button , and then click the Continue button under Set Up An Account. 

•	 If you have photos in the shopping cart, click the Shopping Cart icon, and then click Checkout. Click Set Up An 

Account. 

2 If you haven’t chosen your billing country, you see a dialog box with a list of countries. Choose the country of your 

billing address and click Continue. 

3 In the text boxes, type your e-mail address and choose a password (at least six characters long and containing a 

mix of letters and numbers). 
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4 Enter your billing address, and then type your payment information. The billing address must exactly match the


address where your credit card statements are mailed.


5 When you finish, click Continue.


After you create your account, Adobe Stock Photos sends a confirmation e-mail to the address you entered.


To log into your Stock Photos Account

1 In Adobe Stock Photos, click the Your Account button


2 When prompted, type your e-mail address and password, and then click Continue. If your login is successful, the


Your Account page appears.


If you’re having trouble logging into your account, make sure that you have spelled your e-mail address and password


correctly. Also make sure that you haven’t pressed the Caps Lock or Number Lock keys.


. 

To edit your Stock Photos account profile 
Your account profile includes your name and password settings.


1 Click the Your Account button


2 Log into your account.


3 In the Your Account page, click Edit Your Profile. Do any of the following:


. 

•	 To change your password, type a new word in the Password text box. Passwords can contain only letters and 

numbers and must be at least six characters long. 

•	 To sign up to get e-mail from Adobe Stock Photos about promotions or other special information, select the check 

box. 

4 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click 

Return To Your Account. 

To change Stock Photos account address information 
You can change your default billing address or add other addresses. Make sure that any new addresses match the 

address on your credit card billing statements exactly to avoid any problems. 

1 Click the Your Account button


2 Log into your account.


3 In the Your Account page, click Edit Your Address.


. 
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4	 Do any of the following: 

•	 To change the nickname associated with the default address, type a new name in the Billing Address Nickname 

text box. 

•	 Type any changes to the default address in the text boxes. 

•	 To add a new address to your account, click Add New Address, and then enter the information in the text boxes. 

•	 To edit a non-default address, click Edit under the address, and make any changes. 

•	 To make an address the default, click Set Default under the address. 

•	 To delete an address, click Delete under the address. 

5 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click 

Return To Your Account. 

To change Stock Photos account payment information 
You can change your saved credit card information, or add additional credit cards. Enter your credit card number 

without spaces or dashes. You can give each credit card a nickname to keep track of which card you’re using. 

1 Click the Your Account button


2 Log into your account.


3 In the Your Account page, click Edit Your Payment Information.


4 Do any of the following:


. 

•	 To change the nickname of the default credit card, type a new name in the Payment Nickname text box. 

•	 To change the default credit card number, type the new number in the Credit Card Number text box, and then 

choose the expiration date for the new card from the month and year menus. 

•	 To add a new card to your account, click Add New Payment Method, and then type a nickname and the card 

number. Enter the expiration date. 

•	 To delete a payment method, click Delete under the payment nickname. 

5 To confirm your changes, click Save. To go back to the main Your Account page without saving changes, click 

Return To Your Account. 

To download previously purchased images from Stock Photos 
To download images, you need to have a Stock Photos Account. You can download images onto a different computer 

than the one you used to purchase the photos originally (see the license agreement for information about restric

tions). 

1	 Click the Your Account button . 

2	 In the Your Account page, click View Order History. 

3 In the Your Order History page, click the order number (highlighted in blue) of the photo you want to download 

again. 

4 In the Order Detail page, click the arrow under Download. The photo is downloaded. By default, purchased 

images are located at My Documents/AdobeStockPhotos/PurchasedItems (Windows) or Documents/AdobeStock-

Photos/PurchasedItems (Mac OS). 

 



112 ADOBE PHOTOSHOP CS2 
User Guide 

To set Adobe Stock Photos preferences

1 In Adobe Bridge, choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).


2 Select Adobe Stock Photos from the list on the left.


3 Set any of the following preferences, and then click Save:


Thumbnails displayed per group To set how many thumbnail images are displayed in a search group, choose an


option from the Thumbnails Per Search Group menu.


Search language To search using a different language, select the language from the Search Language menu. Note


that you get the best results from most providers if you search in English. This setting doesn’t affect the interface


display language.


Destination folder for downloads To select a new default folder in which to store photos, downloaded comps, and


purchased photos, click Change Location. Click Reset to restore the default location.


Billing Country To change your default billing country, choose the name of the country from the Billing Country


menu. The currency displayed next to the Billing Country menu may not be the native currency of that country (not


all currencies are supported). Instead, it’s the currency Adobe allows for that country. Your credit card is billed in the


supported currency.


Alert messages To enable or disable the messages that appear when you download a comp or add a photo to your


shopping  cart, select or deselect Display  Message After  Downloading Comp or Display  Message After  Adding Image 


To Shopping Cart.


Automatic downloading to default folder To save your photos automatically to your default folder, select Auto-


Download Images After Purchasing Them. Deselect this option if you want to choose a location in which to save the


photos (for example, in a Version Cue project or other project-specific folder on your computer).


Downloading after lost connection To resume downloading automatically after a connection is lost, select


Resume Interrupted Downloads When Bridge Starts.
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Chapter 6: Adobe Version Cue


Using Adobe Version Cue 

Version Cue managed projects 
Adobe Version Cue® is an innovative set of features designed to increase your productivity when you work alone or 

collaborate with others. Version Cue integrates design management into your existing workflows within and across 

Adobe Creative Suite components, including Adobe Photoshop CS2, Adobe InDesign CS2, Adobe Illustrator CS2, 

Adobe GoLive CS2, Adobe Acrobat 7, and Adobe Bridge. You can also work with Version Cue in Adobe InCopy CS2. 

Version Cue streamlines the following tasks in Adobe Creative Suite: 

•	 Creating historical versions and branched alternates of your files. 

•	 Maintaining file security. 

•	 Organizing files into private or shared projects. 

•	 Browsing with file thumbnails, and searching file information and version comments. 

• Reviewing file information, comments, and file status in private and shared projects while you browse. 

In addition, you can use the Version Cue Workspace Administration for more advanced tasks: 

•	 Initiating and managing online reviews of PDF documents. 

•	 Duplicating, exporting, backing up, and restoring projects. 

•	 Viewing information about projects in the Version Cue Workspace. 

•	 Importing files to the Version Cue Workspace using FTP or WebDAV. 

•	 Deleting file versions in batches and removing file locks. 

•	 Creating a roster of project users and defining their project privileges. 

•	 Restricting access to a specific project. 

See also 

“Availability of Version Cue features” on page 113 

Availability of Version Cue features 
Different Version Cue features are available in different environments: 

•	 If you use Adobe Creative Suite, you have access to the full set of Version Cue features, including Version Cue 

Administration. 

•	 If you use only one component of Adobe Creative Suite, or if you use InCopy and not Adobe Creative Suite, you 

have  access  to  the features of the  Adobe dialog box  only. You  can use  Bridge, rather than the  Adobe dialog box, for  

file browsing. 
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Note: Acrobat 7 and GoLive access Version Cue features differently than other Adobe Creative Suite components and 

don’t use the Adobe dialog box. 

•	 If you don’t have Adobe Creative Suite, you can gain access to the full Version Cue feature set by participating in 

a shared project; that is, if another user on your network installs Adobe Creative Suite and gives you access to a 

Version Cue project in a Version Cue Workspace. 

See also 

“About the Adobe dialog box” on page 115 

“Getting the most out of Version Cue” on page 114 

Getting the most out of Version Cue 
In Version Cue, you create projects that you and other users access through Adobe Creative Suite components. 

Projects keep related files together in one place. Version Cue manages the files in these projects. Because Version Cue 

works in all Adobe Creative Suite components, your design process isn’t interrupted when you work on individual 

files within a project. 

You can use Version Cue in a single application, such as Photoshop CS2, to track changes to a file as you work on it. 

In addition, workgroups or an individual worker can use Version Cue across applications. Multiple users can manage 

projects that contain files from all Adobe Creative Suite components. Projects can include non-Adobe files, such as 

text documents, billing forms, or spreadsheets. When you keep all managed files related to a project in one place, you 

eliminate the task of tracking down important files. 

Here’s an example of how you might use Version Cue with Adobe Creative Suite: You start by creating a new project 

and adding a Photoshop file containing the main image for a printed piece. Then, you add art from Illustrator and 

text from InDesign. Next, you add GoLive web elements to leverage your printed content for use in a web page. As 

you and your team work on each piece of the project, Version Cue creates versions to keep track of changes. When 

it’s time to present the project, you create a PDF of each project file and use the Version Cue Administration utility 

to set up an online PDF review. Your customers, supervisors, or peer reviewers view and comment on the project 

using Acrobat. 

Working with Version Cue in GoLive 

Version Cue is tightly integrated with GoLive to manage the tasks specific to web page creation. Although you access 

Version Cue differently in GoLive than in Photoshop, Illustrator, InCopy, and InDesign, most of the same features 

are available. 

Working with Version Cue in Acrobat 

You access Version Cue from within Acrobat 7 much as you do in the other Adobe Creative Suite components; 

however, there are some differences. Most Version Cue features are available in Acrobat 7. For more information on 

using Version Cue in Acrobat 7, see Acrobat 7 Help. 

See also 

“Availability of Version Cue features” on page 113 
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About the Adobe dialog box 
In Adobe Creative Suite 2.0 components (except for GoLive and Acrobat 7) and InCopy CS2, you can use the Adobe 

dialog box when you choose the Open, Import, Export, Place, Save, or Save As commands, even if you don’t use 

Version Cue. The Adobe dialog box displays additional information, including thumbnails, which make it easy to 

identify files. You can use the Adobe dialog box when working with both Adobe and non-Adobe files. 

Note: In InDesign, if you deselect Always Save Preview Images With Documents in either the File Handling preferences 

or the Save As dialog box, you won’t see thumbnails for InDesign files in the Adobe dialog box or in Bridge. 

By default, when you choose the Open, Import, Export, Place, Save, or Save As commands, the operating system (OS) 

dialog box appears. To use the Adobe dialog box instead and set it as the default, click Use Adobe Dialog. Use the 

View menu options to customize the display. You can change back to the OS dialog box at any time by clicking Use 

OS Dialog. 

BA C 

The Adobe Dialog Box 
A. Favorites panel B. Project Tools menu C. View menu 

You can use the Adobe dialog box to accomplish these tasks: 

• Add frequently used files and folders to the Favorites panel for quick access. 

• View thumbnail images of files. 

• Determine whether a file is open in another Adobe Creative Suite application on your computer. 

• Rename or delete files (Mac OS only). 

• Connect to Bridge by using the Reveal In Bridge command. 

• View metadata about files in the Properties panel. Metadata includes author, keyword, and copyright information. 

• Access Version Cue projects and files as well as non-Version Cue files. 

• View detailed information about Version Cue projects, such as the status of individual files. 

• View and work with Version Cue versions and alternates. 

• Search for files in a Version Cue project. 

• Move Version Cue files to the Project Trash. 

• Determine which Version Cue files are in use, and who is using them. 

• Create a new Version Cue project, or connect to an existing Version Cue project. 
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See also 

“To view Version Cue Workspace, project, and file information” on page 121 

“Availability of Version Cue features” on page 113 

What’s new in Version Cue CS2 
In addition to enhanced performance and reliability, here are some key new features in Version Cue CS2: 

Integration with Adobe Bridge View Version Cue projects, work with versions, and make groups of alternates, all 

from one central place. From Bridge, you can search for and view all Version Cue files without opening individual 

Adobe Creative Suite components. You can manipulate files directly in Bridge to avoid delays as files open or as the 

components start up. 

Alternates Alternates allow you to leverage an asset and take your designs in a different direction. For example, if 

you want to radically transform a photo that is currently used in a project, but you don’t want to alter the original, 

you can create an alternate and work with it instead. Use alternates, in addition to versions, to manage your assets. 

See “About Version Cue alternates” on page 148. 

Version Cue PDF Review Host online PDF reviews from your own computer or another Version Cue Workspace. 

You can include in the review any PDF file in the project, and use the Automatic e-mail generation to quickly invite 

users to the review. Review comments are collected in the Version Cue Workspace where all reviewers can see and 

reference them as the review progresses. 

Ability to manage non-Adobe files Store non-Adobe files, such as text documents, schedule spreadsheets, and 

billing forms, in a Version Cue project. You can also create versions of non-Adobe files. See “To save a version of a 

non-Adobe file” on page 144. 

See also 

“Initiating a Version Cue PDF review” on page 172 

“Availability of Version Cue features” on page 113 

“Working with Version Cue in Bridge” on page 101 

To set Version Cue Workspace preferences 
Note: You can perform this task only if you have access to the full Version Cue feature set, which is available in Adobe 

Creative Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

Use Version Cue preferences to turn Version Cue off (it is on by default), specify Version Cue Workspace settings, 

choose the locations of Version Cue folders that hold data and backup files, export projects in your workspace, and 

check for updates to Version Cue. 

1 Do one of the following to access Version Cue CS2 preferences: 

• In Windows, double-click the Version Cue icon  in the system tray at the bottom right of the screen. 

• In Mac OS, click the Version Cue icon in the menu bar at the top of the screen and choose Version Cue CS2 

Preferences from the menu. 

2 Choose an option from the Version Cue CS2 menu. Choose On to turn on the Version Cue Workspace, or Off to 

turn the workspace off. 

3 To automatically turn on Version Cue when the computer starts (recommended), select Turn Version Cue CS2 On 

When The Computer Starts. 
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4 Choose one of the following from the Workspace Access menu:


This Workspace Is Visible To Others Gives others access to your shared Version Cue projects.


This Workspace Is Private Keeps your Version Cue Workspace hidden from other users. 

Note: If Version Cue is installed on a computer that uses a firewall and you want to share the workspace with others, 

make sure that TCP ports 3703 and 427 are left open and deselect the Internet Connection Firewall option (Windows 

only). For information, see Windows Help. 

5	 In the Settings tab, do any of the following: 

•	 From the Workgroup Size menu, choose the number of people who use the Version Cue Workspace on a typical 

day. This setting controls how the workspace handles the potential load. 

•	 From the Optimize For menu, choose the type of project you generally create. By default, this option is set to 

Mixed Media, to support workflows that involve both print media (such as InDesign files) and web content 

(created in GoLive). If you typically produce only print media, or if you create only web content, choose either 

Print Media or Web Media from the Optimize menu. 

•	 In the Memory Usage text box, enter the amount of RAM that you want to make available to Version Cue. The 

default is 128 MB. This setting allocates RAM to optimize interoperability between Version Cue and Adobe 

Creative Suite components. For more robust requirements, such a larger workgroup or many assets, set the RAM 

to 256 MB or higher. 

6 Select Show Version Cue CS2 Tray Icon (Windows) or Show Version Cue CS2 Status In Menu Bar (Mac OS) to 

keep the Version Cue menu icon visible, giving you quick access to Version Cue Administration and preferences. 

7	 Click the Locations tab and do one of the following: 

•	 To move the Data folder, where projects, file versions, and user IDs are stored, click the Choose button next to the 

current folder location. Select a new location (not a network drive) for the folder. You must choose a location on 

the computer in which the Version Cue Workspace is installed. Click OK. 

•	 To move the Backup folder, where project backups are stored, click the Choose button next to the current folder 

location. Select a new location for the folder. You must choose a location on the computer in which the Version 

Cue Workspace is installed. Click OK. 

Important: The workspace must be turned off before you change the folder locations. Do not attempt to move these 

folders manually or edit any  of  the files  in  the Version  Cue Data folder.  The Data folder contains files  that  maintain  the  

integrity of the Version Cue file versions, metadata, and project information. 

8 To export workspace data, click the Export tab, choose an export version and a location for the exported data, and 

then click Export. 

9 Click the Updates tab, and then click Check For Updates to see whether any updates are available online. If so, 

you’re prompted to install the updates. 

10 Click OK (Windows) or Apply Now (Mac OS). 

If prompted, click Yes (Windows) or Restart (Mac OS) to restart the Version Cue Workspace. (If Version Cue was 

running when you changed the settings, you are prompted to restart.) 

See also 

“To export a Version Cue project to your computer” on page 164 
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To turn Version Cue on or off 
By default, access to Version Cue is turned on in InCopy CS2 and in all Adobe Creative Suite components, except for 

Acrobat 7. If you disable Version Cue, you won’t have access to any Version Cue Workspace, which could affect files 

in a project. If you disable or enable Version Cue in any Adobe Creative Suite component, that change affects all other 

Adobe Creative Suite components except Acrobat 7 (you must always enable or disable Version Cue manually in 

Acrobat 7), Bridge, and GoLive (Version Cue is always enabled in Bridge and GoLive), and the Version Cue 

Workspace (this is controlled through the Version Cue CS 2 preferences). 

Photoshop CS2 Choose Edit > Preferences > File Handling (Windows) or Photoshop > Preferences > File Handling 

(Mac OS). Then select or deselect Enable Version Cue Workgroup File Management, and click OK. 

Illustrator CS2 Choose Edit > Preferences > File Handling & Clipboard (Windows) or Illustrator > Preferences > 

File Handling & Clipboard (Mac OS). Then select or deselect Enable Version Cue, and click OK. 

InDesign CS2 Choose Edit > Preferences > File Handling (Windows) or InDesign > Preferences > File Handling 

(Mac OS). Then select or deselect Enable Version Cue, and click OK. 

InCopy CS2 Choose Edit > Preferences > File Handling (Windows) or InCopy > Preferences > File Handling 

(Mac OS). Then select or deselect Enable Version Cue, and click OK. 

Acrobat 7 You must manually turn Version Cue on in Acrobat 7 to use it. Choose Edit > Preferences > General 

(Windows) or Acrobat > Preferences > General (Mac OS). Then select or deselect Enable Version Cue Workgroup 

File Management. 

Bridge Version Cue is always turned on in Bridge. 

GoLive Version Cue is always turned on in GoLive. 

See also 

“Availability of Version Cue features” on page 113 

Working with Version Cue projects 

About Version Cue projects 
Version Cue uses projects to store related files and folders. If you work independently, you create a project to gather 

all the files you need, view the files in Bridge, and use Version Cue features such as versions and alternates. In a 

workgroup, depending on your workflow, you can create one Version Cue project for files that everyone in your 

workgroup collaborates on, a different project for files that don’t require collaboration, and yet another project 

restricted to specific users. 

When you first open a Version Cue project, Version Cue creates a folder named “Version Cue” in your My 

Documents (Windows)  or  Documents (Mac  OS)  folder, and  adds  a folder for  the project  to  it. When you  open  a file  

from that project, Version Cue adds a working copy of  the file to the  project folder.  As  you edit and  save  intermediate  

changes to your file,  you are  actually  editing in the  working copy;  the original file on the  Version Cue  Workspace is  

protected. 

After you open a Version Cue project, a shortcut to that project appears in the list with other Version Cue Workspaces 

in  Bridge, or in the  Open, Place, or Save dialog boxes. Remote Version  Cue Workspaces also appear in this list after  

you access them. 
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Version Cue uses a special folder for each project: the documents folder. This folder is where  Version Cue  stores  non-

GoLive files for each project. When you access the project from Bridge, InCopy, or any Adobe Creative Suite 

component except Acrobat 7, Version Cue automatically opens the documents folder and temporarily displays the 

project title as the folder name. (If you access the project using Acrobat 7, the folder is named “documents”.) You’ll 

also see the documents folder if you open the working copies folder. 

If you create a new Version Cue project from GoLive, or if you add a new or existing website to a project, Version 

Cue creates three additional folders for that project: 

Web-content folder Contains the home page (index.html) as well as any website content, including pages, images, 

styles, and scripts. You can create separate Pages, Images, and Styles subfolders if necessary. Any files or folders 

uploaded to a production server should be stored in the web-content folder. Because GoLive uses this folder to 

manage a site as it’s created, be careful not to store other types of files in this folder. You can create any type and 

number of subfolders in the web-content folder. 

Web-data folder Stores different types of reusable site objects, such as Smart Objects, components, and templates. 

This folder contains data used to create the final site. To avoid broken links, missing styles, and similar problems, 

never store final website content in the web-data folder. 

Web-settings folder Stores only the saved settings in the GoLive Site Window and Site Settings dialog boxes. 

Viewing a Version Cue project in Bridge 

See also 

“To connect to a remote project” on page 120 

“Using working copies” on page 126 

“Availability of Version Cue features” on page 113 

To open a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1	 Do one of the following: 

•	 In Illustrator, InCopy, InDesign, or Photoshop choose File > Open. If the button is visible, click Use Adobe Dialog 

(if you see the Use OS Dialog button, you are already using the Adobe dialog box). Click Version Cue in the 

Favorites panel. 

•	 In Bridge, click Version Cue in the Favorites panel. Double-click Workspaces to view all available workspaces. 

•	 In Acrobat 7, choose File > Open. Click Version Cue. 
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2	 To open a Version Cue Workspace, double-click it. 

Note: If you don’t see a desired Version Cue Workspace, choose Refresh from the Tools menu. 

3	 To open a project, double-click it. 

If  the Use  Adobe Dialog button doesn’t  appear  in  the Open,  Save  As, Save A Copy, or Place  dialog  boxes,  make  sure  

that you’ve turned on the Version Cue preference in InCopy or in the Adobe Creative Suite component you’re using. 

See also 

“About the Adobe dialog box” on page 115 

“To connect to a remote project” on page 120 

“Adding files and folders to a project” on page 131 

“To set Version Cue Workspace preferences” on page 116 

To connect to a remote project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

When you need to work on Version Cue projects that are located remotely, on a different subnet, you can use the IP 

address of the computer to access that Version Cue Workspace. Workspaces on computers within your subnet should 

be visible automatically. 

1	 Do one of the following: 

•	 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. If you are using the OS Dialog box, click Use 

Adobe Dialog. Click Version Cue in the Favorites panel. Choose Connect To from the Project Tools menu . 

•	 In Bridge, choose Tools > Version Cue > Connect To. 

•	 In Acrobat, choose File > Open. Click Version Cue. Choose Connect To from the Project Tools menu. 

2 In the Connect To dialog box, enter the Version Cue Client URL (the Version Cue IP or DNS address), a colon, 

and the port number (3703), for example, http://153.32.235.230:3703. If you have connected to the workspace before, 

it’s not necessary to enter the port number. 

You can display the Version Cue Workspace Administration utility login page to identify the Version Cue Client 

URLs that remote users and WebDAV applications need to access the workspace. 

3 Click OK. After you connect to a remote Version Cue Workspace, the dialog box displays all available Version Cue 

projects in that workspace. 

A shortcut to the remote workspace is automatically included in your list of available Version Cue Workspaces. 

See also 

“About the Adobe dialog box” on page 115 

“To log into Version Cue Administration from an Adobe Creative Suite component” on page 157 

 



121 ADOBE PHOTOSHOP CS2 
User Guide 

To connect to a project using WebDAV 
The Version Cue Workspace can communicate with applications that are WebDAV enabled. When Version Cue is 

running on a server, you  can use  it  as  a WebDAV server.  However,  Version Cue's  native  versioning  features  are more  

sophisticated than those available through WebDAV. WebDAV capabilities are provided for legacy workflows. 

❖ Refer to your application’s  documentation for  information on using  its WebDAV features,  and then use  the Version  

Cue WebDAV Client URL, the port number (3703), “webdav”, and the project name to identify the project you want 

to work with, for example, http://153.32.235.230:3703/webdav/project_name 

See also 

“Availability of Version Cue features” on page 113 

To view Version Cue Workspace, project, and file information 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

For help on viewing information in Acrobat 7, see Acrobat Help.


1	 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open.


2 If the button is available, click Use Adobe Dialog (if you see the Use OS Dialog button instead, you are already


using the Adobe dialog box).


3 Click Version Cue in the Favorites panel.


You can resize the Favorites panel to display items with long names: place your cursor over the vertical line to the 

right of the Favorites panel and drag it to the right. 

4	 To change the display of Version Cue Workspaces, projects, or files in the dialog box, do any of the following: 

•	 To view the properties of a file, click the toggle  to display the Properties panel. 

•	 To change the display of project, choose a display option from the View menu . 

•	 To sort items in a column, while in detail view, click the column heading. Click the column heading again to 

reverse the order. 

•	 To show or hide columns of information while in list view, right-click (Windows) or Control-click (Mac OS) the 

Name column heading, and choose Show All, Hide All, or a column name. (The Name column can’t be hidden.) 

Visible columns have a check mark to the left of the column name. 

•	 To change the location of a column, drag the column heading to the left or right of another column heading 

(Windows), or press Command+Option and drag the column heading to the left or right of another column 

heading (Mac OS). The Name column can’t be moved. 

•	 To resize a column of information, drag the vertical dividing line between column headings or double-click the 

line to automatically resize the column to fit the widest item in it. 

5	 To display information about a file, project, or Version Cue Workspace, do one of the following: 

•	 Place the pointer over the item. A summary of file information appears in a tool tip. 

•	 Right-click (Windows) or Control-click (Mac OS) the file and choose Versions (to display information about a 

file’s versions) or Alternates (to display information about a file’s alternates). 

Note: If you’ve already opened the file in an Adobe Creative Suite component, file status information appears at the 

bottom of the file’s window. 
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See also 

“About the Adobe dialog box” on page 115 

“Version Cue file statuses” on page 128 

To view Version Cue Workspace, project, and file information in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

In Bridge, you can choose between two display views: Versions And Alternates View and Details View. Use the 

Versions And Alternates View to view thumbnails of files along with thumbnails of Version Cue alternates and 

versions. Use the Details View to view thumbnails as well as information about the number of versions or alternates, 

enhanced status information, and the current version comment. 

1 Start Bridge, and then click Version Cue in the Favorites panel. 

2 Click the Version Cue Workspace, project, or file to view its information, or place the pointer over the item to 

display a summary of information in a tool tip. 

See also 

“To view file and folder thumbnails in Bridge” on page 85 

“The Bridge work area” on page 79 

“Version Cue file statuses” on page 128 

“About Version Cue versions” on page 143 

“About Version Cue alternates” on page 148 

Creating and editing projects 
To begin using Version Cue, you need to create a Version Cue project. When you work with Version Cue, you decide 

what a project entails. For example, you can create a project to organize files for an entire publishing effort, or you 

can create a project to manage files for specific aspects of an advertising campaign. You can use a project to organize 

assets  related to a particular  customer  or  use a project to separate private  files from files  that  are worked on collabo

ratively. You can add files to projects at any time by using Bridge, InCopy, or any Adobe Creative Suite component. 

When you create a Version Cue project, you specify a project name, the Version Cue Workspace that hosts the 

project, and a project description. You specify whether to share the project or keep it private. Shared projects are 

available to other users; however, you can password-protect shared projects to restrict access to specific users. You 

can create private projects on a workspace installed on your computer. If you create a project on a computer that is 

used as a server, it must be shared to be accessible. 

You can create projects by using Bridge, InCopy, any Adobe Creative Suite component, or the Version Cue Admin

istration utility. The Version Cue Administration utility provides options for specifying advanced project properties. 

You create new Version Cue projects with it by importing a folder of files. These files are used as the project starting 

point. 
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The Project Tools menu contains frequently used commands 

See also 

“To create a project” on page 123 

“To edit Version Cue project properties” on page 162 

“To create a new Version Cue project from a folder” on page 161 

“To share or unshare a project” on page 125 

“To share or unshare a project from Bridge” on page 126 

“Availability of Version Cue features” on page 113 

To create a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

For information on creating a project in Acrobat 7, see Acrobat Help.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Choose New Project from the Project Tools menu


4 Choose a location for the project from the Location menu.


5 Enter a name for the project in the Project Name box and a description in the Project Info box. (The description


you enter appears as a tool tip when the pointer is over the project in the list of workspaces.)


. 
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6 To make this project and its files available to others, select Share This Project With Others. (If the Version Cue 

Workspace is on a computer other than your own, the Version Cue project is shared by default.) 

7	 Click OK. 

See also 

“About the Adobe dialog box” on page 115 

To create a project in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1 Start Bridge, and then click Version Cue in the Favorites panel.


2 Choose Tools > Version Cue > New Project.


3 Choose a location for the project from the Location menu.


4 Enter a name for the project in the Project Name box and a description in the Project Info box. The description


you enter appears as a tool tip when the pointer is over the project in the list of workspaces.


5 To make this project and its files available to others, select Share This Project With Others. (If the Version Cue


Workspace is on a computer being used as a server, the Version Cue project is shared by default.)


6 Click OK. The project opens automatically. No Items To Display appears in the Content Area until you add files


to the project.


See also 

“To add a file or folder to a project in Bridge” on page 132 

To edit the properties of a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1	 Do one of the following: 

•	 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS 

dialog box. Double-click the host Version Cue Workspace. Select the project, and then choose Edit Properties from 

the Project Tools menu. 

•	 In Bridge, select the project and then choose Tools > Version Cue > Edit Properties. 

•	 In  Acrobat 7, choose File  >  Open. Click  Version Cue. Select the  project,  and then choose Edit Properties from the  

Project Tools menu. 

2	 In the Edit Properties dialog box, do any of the following, and click Save: 

•	 To change the project name, enter a name in the Project Name text box. The new name will not be reflected on 

your (or your workgroup’s) working copies project folder until you disconnect from and reconnect to the project. 

•	 To change the description of the project, enter text in the Project Info box. 

•	 To  make  this  project and  its files  available to other  users,  select  Share This Project  With  Others. (If  the Version  Cue  

Workspace is on a computer being used as a server, the Version Cue project is shared by default.) To unshare a 
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shared project, deselect Share This Project With Others. Note, however, that this action does not delete any 

working copies currently in project folders on the workgroup’s computers. 

•	 To  view  the location of working  copies  on  your  computer, expand Local  Project Files. To open the  folder, choose  

Show Files (Windows) or Show Files in Finder (Mac OS). To change the location of the files, click Change Location 

and choose the new location for working copies. 

Note: Make sure that you use the Change Location feature to relocate working copies, rather than moving the project 

folder manually in the file system. 

•	 Click Advanced Administration to enable lock protection, edit or assign users, or require users to log into the 

project. When prompted, log into Version Cue Administration. Depending on your privileges, this option may not 

be available. 

3	 Click Cancel to close the Open dialog box (Version Cue saves your settings even though you clicked Cancel). 

See also 

“Disconnecting from projects” on page 137 

“Deleting files and folders” on page 139 

“To log into Version Cue Administration from an Adobe Creative Suite component” on page 157 

To share or unshare a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

At  any time,  you can  change  a project’s  shared  status. Projects on a Version Cue  Workspace that other  users can  access  

are shared by default and can’t be made private. Note that unsharing a project does not delete any working copies 

currently in the working copies project folders of your workgroup. 

Note: If  the Version  Cue Workspace  is  installed on a computer  that  uses  a firewall and  you want to share  the workspace  

with others, make sure that TCP ports 3703 and 427 are left open. If you’re using a Windows machine, deselect the 

Internet Connection Firewall option. (For information on the Internet Connection Firewall option, see Windows Help.) 

1	 Do one of the following: 

•	 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS 

Open dialog box. 

• In Acrobat 7, choose File > Open.


2 Click Version Cue in the Favorites panel, and then double-click the host Version Cue Workspace.


3 Select the project, and then do one of the following:


•	 To share the project, choose Share Project from the Project Tools menu
 . 

•	 To unshare the project, choose Unshare Project from the Project Tools menu. 

•	 Choose Edit Properties from the Project Tools menu. Select or deselect Share This Project With Others, and click 

Save. After you edit the project properties, click Cancel to close the Open dialog box (your settings are saved even 

though you clicked Cancel). 
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See also 

“About the Adobe dialog box” on page 115 

“To view Version Cue Workspace, project, and file information” on page 121 

To share or unshare a project from Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

At any time, you can make a project shared or unshared. You can keep a Version Cue project unshared only if it is on


your  own computer.  Projects  that  you create on a Version Cue  Workspace that is not  located on your own  computer 


are shared by default and can't be made private. Note that unsharing a project does not delete any working copies


that others may already have in the working copies project folder on their own computer.


1 Start Bridge, and then click Version Cue in the Favorites panel.


2 Double-click Workspaces.


3 Right-click (Windows) or Ctrl-click (Mac OS) the project and choose either Share Project or Unshare Project from


the menu.


You can also choose Edit > Properties, and then select or deselect Share This Project With Others, and click Save. 

See also 

“To view Version Cue Workspace, project, and file information in Bridge” on page 122 

Working with files in Version Cue 

Using working copies 
Version Cue projects and files reside in the Version Cue Workspace on the host computer. The master copies of files 

added to the project, including file versions and other file data, such as comments, version dates, and user IDs, are 

saved on this host computer. When you work in files from a Version Cue project, you’re editing a working copy of the 

master file on your computer, not the master file on the Version Cue Workspace, which remains protected and 

untouched. 

As you work, use the Save command to save changes periodically. This command does not create a new version of 

the master file but updates your working copy. A new version is created only when you choose the Save A Version 

command. This command first updates the working copy, and then adds a new version to the master file on the 

Version Cue Workspace. When the working copy of a file matches (is the same version as) the current version in the 

workspace, the file is synchronized. 

Using working copies of master files, several people can work with the most recent version of a master file. For 

example, if two people need access to the same illustration during overlapping periods of time, Version Cue lets each 

person work with a working copy of the most recent file version. The second person to access the illustration is 

informed that the file is already in use. At that time, the second person can decide whether to continue working with 

the file. Working copies give everyone flexible access to project files and allow work to proceed concurrently when 

necessary. 

Note: Two users can’t edit a file simultaneously in InCopy. 
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Working copies allow you to work on a file even when the host workspace is unavailable, or offline. Though some 

features, such as versions and alternates, can’t be used when you’re working offline, you can edit files and save your 

work. When the workspace is online again, you can save a version to update the master file. 

There are times when you may wish to delete the working copies of your project files. For example, you may want to 

free up space on your hard drive, or are completely finished working on the project. Version Cue lets you delete your 

working copies of project files by disconnecting from the project. Disconnecting from a project deletes the working 

copies  project folder on your hard drive. You  can do this at any  time  if  none  of  the working  copies  are In Use  by  you.  

If you accidentally disconnect from a project, new working copies are recreated the next time you access the project 

files. If a project is deleted from either the host workspace or your local computer, you can use working copies to 

recreate the project with the most current versions of the files. 

To relocate working copies of a project, edit the project’s properties and use the Change Location feature. For instruc

tions, see “To edit the properties of a project” on page 124. 

Note: Make sure that you use the Change Location feature to relocate working copies, rather than moving the project 

folder manually in the file system. 

See also 

“Creating and editing projects” on page 122 

“To create a project” on page 123 

“Disconnecting from projects” on page 137 

“Deleting files and folders” on page 139 

“Editing and synchronizing offline files” on page 152 

“To restore a file or folder deleted from a project” on page 142 

“Version Cue file statuses” on page 128 

“Availability of Version Cue features” on page 113 

File protection in Version Cue 
Version Cue automatically informs others that a file is being edited. Version Cue assigns In Use status to a file when 

you open and edit a file that isn’t being edited by another user. When you save a version, Version Cue removes the 

file’s In Use status. 

Note: In InCopy, you must choose File > Checkin after saving a version to remove the file’s In Use status. 

At times two people may need to work with a file simultaneously. For example, User A may begin editing a file but 

be called away before saving a version. If User B works on the file while User A is away, Version Cue ensures that the 

two files don’t overwrite each other in the project. User A’s working copy won’t reflect the changes made by User B, 

and vice versa. When finished with the file, both users can save a new version of the file to the Version Cue 

Workspace. Version Cue alerts all current users of the file about the presence of a new version in the Version Cue 

Workspace and gives them the option of downloading the latest version or continuing their current edits. Alterna-

tively, users  can save their  edits as an alternate.(Version  Cue alerts users  who have the  file  open  or  who re-open a file  

that was previously closed while In Use.) 

Note: Two users can’t edit a file simultaneously in InCopy. 
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You can use the Version Cue Workspace Administration utility to assign lock protection to a Version Cue project. 

Only the first user to begin editing an available file in a lock-protected project can save the next version of that file 

to  the Version  Cue project. Other  users who  edit  that  file  simultaneously  can’t save changes  to  a new  version of that  

file, even after the first user saves a version. These other users must save the changes as completely new files with 

their own version thread; however, they can designate their file as an alternate of the original file. 

The ability to access a file in a lock-protected project provides the flexibility to create proofs or experiment with the 

design, for example, and then close the file without saving changes. 

See also 

“Using working copies” on page 126 

“Availability of Version Cue features” on page 113 

Version Cue file statuses 
Files that are  managed by Version  Cue are  always  marked  with  a status icon that describes  the state  of  the file on the  

Version Cue  Workspace.  You can  view  a file’s status while  browsing  the files  in  a Version  Cue project, in Bridge,  and  

also in the document window’s Status area after opening a file from the Version Cue Workspace in an Adobe Creative 

Suite component. In Acrobat, the  status  is  displayed in the  title bar. A file  can have more than one  status  at  the same  

time (in some cases only one status is shown). 

Each file status has a corresponding icon: 

Open The file is open on your computer.  This  status  lets  you make informed decisions  about whether  it’s  appro

priate, for example, to place a file into a layout while the file is still being edited. The Open status is indicated only 

for files on your computer. 

In Use By Me You are editing the file. Version Cue assigns this status to a file when you make an edit to the file 

that  changes its  content.You can  manually  mark  a file in use  before  you edit it to indicate to others that you  intend  to  

make changes to the content. 

Synchronized The latest known version of the file is available for editing and you have a working copy of it on 

your computer. Version Cue assigns this status when you save a version of the file you’re editing, or when you 

manually synchronize a project. 

No Working Copy No local copy of the file exists. This status indicates that it will take a few moments to create 

a working copy before you can edit the file. 

In Use By <user name> Another user is editing the file and has not yet saved a new version. 

Conflicted Copies There is a version conflict, or both you and another user are editing the file. 

Only Copy The file in the working copies folder is the only copy known to Version Cue and has not been 

synchronized with the Version Cue Workspace. This scenario can occur when a file has been saved in an existing 

project for the first time while the workspace is offline. Because the workspace is offline, Version Cue displays the 

Offline Copy status until  the workspace  is  back  online,  and then changes the  status  to  Only  Copy. Version  Cue also  

displays this status if you drag a file from one folder into the working copies folder using the file system instead of 

Bridge (not recommended). You can edit the file, but it’s important  to  synchronize (upload  the file to the  workspace) 

after you save your changes. 

Offline Copy There is a local copy of the file in your working copies folder, but the Version Cue Workspace is 

offline. There is no way of checking whether the local copy is synchronized with the latest version on the workspace. 
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You can edit an offline copy and save these changes; however, you must save a version or synchronize the file once 

the workspace comes back online. 

Outdated Copy A local  copy  exists,  but there  is  a newer  version of the  file  in  the workspace. This status indicates  

that it will take a few moments to create an up-to-date working copy before you can edit the file. 

Unavailable The Version Cue Workspace is offline or you don’t have access privileges. There is no way of 

checking the status of the local copy with the workspace. You can edit the local copy and save these changes; however, 

you must save a version or synchronize the file once the workspace comes back online. 

Deleted The file or folder has  been  deleted from the  project,  but not  yet permanently  erased. (You can  restore a  

deleted file or folder). 

See also 

“Using working copies” on page 126 

“To synchronize files” on page 154 

“To edit a file in use by another user” on page 130 

“Deleting files and folders” on page 139 

“Availability of Version Cue features” on page 113 

To open a file from a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

After you add or save a file to a Version Cue project, the file is automatically managed by Version Cue. Managed files 

can’t be overwritten. If you  open  a file that’s in use  by  another user or that has  been  previously  edited  and saved  as  a  

new version, you are prompted to edit the most recent version. 

1	 Do one of the following: 

•	 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS 

dialog box, and then click Version Cue in the Favorites panel. 

•	 In Acrobat 7, choose File > Open, and then click Version Cue in the dialog box that appears.


• In Bridge, click Version Cue in the Favorites panel.


2 Double-click the host Version Cue Workspace.


3 Double-click the project that contains the file you want to open.


4 Select the file and click Open.


See also 

“To edit a file in use by another user” on page 130 

“To update a file with the most recent version” on page 130 

“About the Adobe dialog box” on page 115 

“To search for files in a project” on page 137 
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To reveal a file in Bridge 
❖ Right-click (Windows) or Ctrl-click (Mac OS) the file in the Open dialog box in InCopy or an Adobe Creative 

Suite component, and choose Reveal In Bridge. 

The file appears in the Bridge window. 

To edit a file in use by another user 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

If you don't notice that a file's status is In Use when you open it, Version Cue displays an In Use By alert to remind 

you that someone else is already editing a working copy of the file. 

Note: In InCopy, you can’t edit a file that’s in use by another user. 

1 Open the file, and click one of the following options when the In Use By alert appears: 

No, Close Document Closes the file without any alterations. 

Yes, Keep Open Keeps the file open so you can work on the document. 

2 If you continue working with the document and make a change to the content, Version Cue displays an alert to 

remind you that there is the possibility of creating conflicting copies. Click one of the following: 

Discard Changes Displays the most recent version of the file from the Version Cue Workspace and discards your 

changes to the working copy. 

Continue Editing Lets you edit the working copy without overwriting the changes made in another user’s working 

copy of the same file (Version Cue will prompt each user to save a new version of the file). 

3 If the project doesn’t have lock protection applied to it, you can save a new version of your edits. Version Cue 

displays an alert warning you that conflicting edits will occur if you continue. Click one of the following: 

Cancel Returns you to the open document without saving a version. 

Save Version Anyway Updates the master file in the Version Cue Workspace with the new version. (Version Cue 

displays an alert to the other user to note that a newer version of the file has been created by you.) 

At any point, you can close the document and discard any changes you’ve made. 

See also 

“To update a file with the most recent version” on page 130 

To update a file with the most recent version 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 
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If another user creates a new version of a file that you have open or that is still marked In Use By Me, Version Cue 

prompts you  to  update  your  document  with  the latest version  when  you open it or attempt  to  make  changes to it,  or  

when you bring the document window frontmost in a group of documents. 

❖ When the prompt appears, click one of the following: 

Discard Changes Updates the document with the most recent version from the Version Cue project. You can 

continue editing the file after it is updated. You lose any changes you’ve made even if you have already saved those 

changes to the working copy with a Save command. 

Continue Editing Leaves the document as is. You can continue editing the file without overwriting the changes in 

the more recent version. Instead, you’re prompted to either save a new version of the file when you close it, or to 

discard your changes. 

See also 

“To edit a file in use by another user” on page 130 

Adding files and folders to a project 
To save versions of a file and take advantage of Version Cue file management, you must add or save the file to a 

Version Cue project. You can add assets such as swatch libraries to projects to share them with your workgroup. You 

can also add non-Adobe files to Version Cue projects You can add files using any of the following methods: 

•	 Add files one at a time from within InCopy or in Adobe Creative Suite. 

•	 Drag one or more files or folders to a Version Cue project using Bridge. Use this method to copy files from one 

Version Cue project to another. 

•	 Drag files and folders from open windows on your computer's desktop to a Version Cue project displayed in a 

Bridge window. 

•	 Place files directly in the project’s working copies folder, and then synchronize the project to add the files. For more 

information, see “About Version Cue projects” on page 118. 

See also 

“To create a new Version Cue project from a folder” on page 161 

“Availability of Version Cue features” on page 113 

To add a file to a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

For information on adding a file to a project in Acrobat 7, see Acrobat Help.


1 Open the file in Illustrator, InCopy, InDesign, or Photoshop.


2 Choose File > Save As. Click Use Adobe Dialog if you’re using the OS dialog box.


3 Double-click the host Version Cue Workspace.


4 Double-click the project to open it.


5 Enter a comment for the first version in the Version Comments box, and click Save.
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See also 

“About the Adobe dialog box” on page 115 

To add a file or folder to a project in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1 Start Bridge. In Folders (in the Favorites panel), navigate to the folder in the Version Cue project to which you


want to add files.


2 Navigate to the folder that contains the files or folders you want to add to the project.


3 Select one or more files or folders, and drag them to the Version Cue folder icon you navigated to in step 1.


Note: To copy (not move) the files to a project, hold down Ctrl (Windows) or Option (Mac OS) as you drag the files to 

the project. 

See also 

“The Bridge work area” on page 79 

To add a file or folder from a desktop folder to a project in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1 Start Bridge, and click Version Cue in the Favorites panel.


2 Double-click Workspaces.


3 Double-click the Version Cue project and browse to the folder to which you want to add files.


4 Select files and folders in the open folder on your desktop.


5 Drag  these items  from  the open folder to the  Bridge  content area displaying the  Version Cue  folder  to  which you 


want to add files.


Note: To copy (not move) the files to a project, hold down Ctrl (Windows) or Option (Mac OS) as you drag the files to 

the project. 

See also 

“The Bridge work area” on page 79 

To add files to a project folder without Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 
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It’s best to add files using Bridge, but you can add files by dragging them into the documents folder of a Version Cue 

project. 

1	 Do one of the following: 

•	 Locate the project folder inside the My Documents/Version Cue (Windows) or Documents/Version Cue 

(Mac OS) folder on your computer. 

•	 If the project folder isn’t already in the My Documents/Version Cue (Windows) or Documents/Version Cue 

(Mac OS) folder on your hard disk, create a new folder inside the Version Cue folder. Give the folder the same 

name as the existing Version Cue project on the Version Cue Workspace. Inside the new project folder, create a 

new folder and name it documents. 

Note: These steps work only if the project already exists. You cannot create a new project using this method. 

2	 Move or copy the items you want to add to the documents folder.


3 In Illustrator, InCopy, InDesign, Photoshop, or Acrobat, choose File > Open. Click Use Adobe Dialog if you’re


using the OS dialog box.


4 Click Version Cue in the Favorites panel. Open the Version Cue Workspace, and select the project.


5 Choose Synchronize from the Project Tools menu
 . (Alternatively, you can select the project in Bridge and 

synchronize it.) Once the synchronization is complete, the files are added to the project. 

See also 

“Editing and synchronizing offline files” on page 152 

“About the Adobe dialog box” on page 115 

“About Version Cue projects” on page 118 

To copy or move files between projects or from a project to a desktop folder 
❖ Do one of the following: 

•	 To copy a file between projects, start Bridge and navigate to the project folder that contains the file you want to 

copy. Choose File > New Window to open a new Bridge window,  and navigate to the  project folder to which  you  

want to add the file. Drag the file from the first project folder to the destination project folder in the second Bridge 

window. 

•	 To copy a file from a project to a desktop folder, drag it from the project folder in Bridge to the desktop folder. 

Note: When you copy a file between projects or from a project to a desktop folder, Version Cue copies only the most 

current version. 

•	 To move a file between projects, copy it from one project folder to another in Bridge, and then permanently delete 

the file from the first project folder. For instructions on permanently deleting files, see “To delete files or folders 

from a project” on page 141 and “To delete a file or folder permanently” on page 142. 

•	 To move a file from a project to a desktop folder, drag it from the project folder in Bridge to the desktop folder, 

and then permanently delete the file from the first project folder. For instructions on permanently deleting files, 

see “To delete files or folders from a project” on page 141 and “To delete a file or folder permanently” on page 142. 

To save changes to a file 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 
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If  you want to save changes,  but aren't  ready to save a new version  as  you edit a file  you have opened from a Version  

Cue project, you can use the File > Save command to save your changes to the working copy on your computer. Until 

you save a new version to the shared Version Cue Workspace, these changes won’t be available to any other user. You 

can also close the file once you save changes to a file, and then reopen it and save a version later. 

❖ To save changes to your working copy, choose File > Save. 

To place a file from a project into a document 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

While you’re working with a Version Cue project in Illustrator, InCopy, InDesign, or Photoshop, you can add a file


to a document just as you normally would—by using the Place command. The Links palette (in Illustrator, InCopy,


and InDesign) displays additional information about placed files from Version Cue projects, identifying whether a


linked file is being edited, which user is doing the editing, whether it is a member of a group of alternates, and if so,


whether it is the primary (preferred) alternate. You can also use the Links palette to determine whether the linked


file needs to be updated to a newer version from the Version Cue Workspace.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Place.


2 Click Version Cue in the Favorites panel.


3 Double-click the host Version Cue Workspace.


4 Double-click the project containing the file you want to place.


5 Select the file, and click Place.


For complete information on placing files into documents in Adobe Creative Suite, see the specific application’s Help.


Note: When you place a file from a Version Cue project, a copy of that file is placed in your My Documents/Version Cue 

(Windows) or Documents/Version Cue (Mac OS) folder of working copies for that project. As a result, you can edit that 

file offline, while it’s disconnected from the Version Cue Workspace 

See also 

“Using the Links palette with project files” on page 135 

“About Version Cue alternates” on page 148 

To place a non-Version Cue file into a document 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1 With the document open in Illustrator, InCopy, InDesign, or Photoshop, navigate to the file you want to place.


2 Select the file, and click Place (Illustrator) or Open.


For complete information on placing files into documents in Adobe Creative Suite, see the specific application’s Help.


You should always add assets to a Version Cue project before placing them in a Version Cue-managed file. When you 

place a non-Version-Cue managed file into a managed file, you cannot keep track of the placed asset's versions, alter

nates, or status. 
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Using the Links palette with project files 
When Version Cue is enabled in Illustrator, InCopy, or InDesign, the Links palette identifies who is editing a linked 

file  from  a Version  Cue project. It also displays a linked file’s versions and  alternates  so  that  you can  promote and  use  

previous versions, update the document with the linked file’s alternates; you can even create versions of linked non-

Adobe files. 

The Links palette, including the File Status column, functions the same with Version Cue-managed files as it does 

with non-Version Cue-managed files. For example, if a newer version of a linked file is on the Version Cue 

Workspace, the Modified Artwork icon  appears; if a file is missing, the Missing Artwork icon  appears. To 

update a linked file from a Version Cue project, you use the same procedures used for files that aren’t managed by 

Version Cue. 

The Version Cue Edit Status column in the Links palette displays nothing if the linked file is available, or it displays 

a status icon. 

See Illustrator Help, InCopy Help, or InDesign Help for more information about working with the Links palette and 

placed files. 

See also 

“Availability of Version Cue features” on page 113 

“To view alternates and versions in the Links palette” on page 135 

“To replace a placed file with an alternate” on page 136 

“To replace a placed file with a previous version” on page 136 

“To replace a placed file with an alternate derived from a previous version” on page 136 

To view alternates and versions in the Links palette 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

When Version Cue is enabled in Illustrator, InCopy, or InDesign, you can view versions and alternates of a placed 

file from the Links palette. 

❖ Do one of the following: 

• To view versions of a placed file, choose Versions from the Links palette menu. 

• To view alternates of a placed file, choose Alternates from the Links palette menu. 

See also 

“Using the Links palette with project files” on page 135 

“To replace a placed file with an alternate” on page 136 

“To replace a placed file with a previous version” on page 136 

“To replace a placed file with an alternate derived from a previous version” on page 136 
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To replace a placed file with an alternate

1 In Illustrator, InCopy, or InDesign, select the file in the Links palette.


2 Choose Alternates from the Links palette menu.


3 Choose an alternate, and click Relink.


See also 

“Using the Links palette with project files” on page 135


“To view alternates and versions in the Links palette” on page 135


“To replace a placed file with a previous version” on page 136


“To replace a placed file with an alternate derived from a previous version” on page 136


To replace a placed file with an alternate derived from a previous version

1 In Illustrator, InCopy, or InDesign, select the file in the Links palette.


2 Click Edit Original and edit the file in its native application.


3 Choose File > Save As, and select Save As Alternate (rename the file if you save it in the original folder).


4 Close the file.


5 In Illustrator, InCopy, or InDesign, select the placed file in the Links palette.


6 Choose Alternates from the Links palette menu.


7 Select the Alternate you created in step 3, and click Relink.


See also 

“Using the Links palette with project files” on page 135


“To view alternates and versions in the Links palette” on page 135


“To replace a placed file with an alternate” on page 136


“To replace a placed file with a previous version” on page 136


To replace a placed file with a previous version

1 In Illustrator, InCopy, or InDesign, select the file in the Links palette.


2 Choose Versions from the Links palette menu.


3 Select a version and click Promote To Current. Enter a version comment if desired, and click Save.


See also 

“Using the Links palette with project files” on page 135


“To view alternates and versions in the Links palette” on page 135


“To replace a placed file with an alternate” on page 136


“To replace a placed file with an alternate derived from a previous version” on page 136
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To search for files in a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

Metadata is automatically added to Version Cue project files as you work with them. In addition, you can manually


add other information to files in Adobe Creative Suite through the File Info dialog box. You can quickly locate files


in a Version Cue project by searching for specific information such as titles, authors, copyright data, keywords, dates,


and locations. The search feature searches through existing files, as well as files deleted from projects. For infor


mation on searching in Acrobat 7, see Acrobat Help. You can also search for Version Cue project files in Bridge, both


by version comment and past versions.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open.


2 If the button is visible, click Use Adobe Dialog (if you see the Use OS Dialog button instead, you are already using


the Adobe dialog box).


3 Click Version Cue in the Favorites panel.


4 Double-click the host Version Cue Workspace.


5 Double-click the project you want to search.


6 Click Project Search


7 Enter information in Project Search.


If  you open an older  version of a file  found as the  result  of  a search,  the file name will be prefaced with Version  <X>  -. 


. 

Note: It  is  best  to  treat older versions as view-only when opened as the  result  of  a search.  Although  you can  edit  an  older  

version in its native application, do so only if you intend for this version to become a separate asset or to be used as an 

alternate. To edit a previous version, first promote it to the new, current version, and then make changes. 

See also 

“About the Adobe dialog box” on page 115 

“Version Cue file statuses” on page 128 

“To search for files and folders with Bridge” on page 91 

“Viewing and comparing versions” on page 144 

“To view a previous version in its native application” on page 146 

Disconnecting from projects 

Disconnecting from projects 
Disconnecting from a project erases the working copies of files on your computer while leaving the master copies on 

the Version Cue Workspace intact. Disconnecting also removes shortcuts to the project from Bridge and the Adobe 

dialog box. You may want to disconnect to free up more space on your hard drive. Or, you might disconnect from a 

project if someone  else  in  your  workgroup deletes  a project  from  the Version  Cue Workspace  (your working  copies  

are not touched by that deletion). 
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As long as you have saved a version of the working copies there is no harm in discarding them by disconnecting. 

When you access the project again, new working copies will be created for the current versions of the files you open. 

If  you have working  copies  with  the In Use  By  Me  status, you  will  not be permitted  to  disconnect  from  a project  until  

you have saved a version of those files. 

When you disconnect from a project, only the working copies and shortcuts on your computer are erased. Leaving 

the project intact on the workspace allows others, as well as yourself, to access the master files. When you delete a 

project,  all working  copies  and shortcuts  on  your  own computer,  along with the  master  copies  of  files and  folders in  

the Version Cue Workspace, are erased. However, any working copies and shortcuts on other computers your co

workers or you  previously  used  to  access  the project  are not  erased. To completely remove the  project and  erase those  

working copies and shortcuts, you must select the shortcut or project folder and disconnect, even though the project 

has already been deleted. 

You can disconnect from a Version Cue project by using Bridge, Photoshop CS2, Illustrator CS2, InCopy CS2, or 

InDesign CS2. GoLive CS2 uses a different method for deleting working copies of site files. Disconnect is not 

available in Acrobat 7. 

See also 

“Deleting files and folders” on page 139 

“To disconnect from a project in Bridge” on page 138 

“To disconnect from a project” on page 138 

“Using working copies” on page 126 

“Availability of Version Cue features” on page 113 

To disconnect from a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

Disconnecting from a project removes the files from your computer but doesn’t delete the project from the host


Version Cue Workspace. Disconnect is not available in Acrobat 7.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Open the Version Cue Workspace and select the project from which you want to disconnect.


4 Choose Disconnect from the Project tools menu.


Note: You can select any project icon or shortcut to the project when you want to disconnect. 

To disconnect from a project in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 
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Disconnecting from a project removes working copies of the project files from your computer but doesn’t delete the


project from the host Version Cue Workspace.


1 Start Bridge, and click Version Cue in the Favorites panel.


2 Double-click Workspaces, and navigate to the project from which you want to disconnect.


3 Right-click (Windows) or Ctrl-click (Mac OS) the project, and then choose Disconnect from the menu.


Note: You can select any project icon or shortcut to the project when you want to disconnect. 

Deleting files, folders, and projects 

Deleting files and folders 
Deleting a file or folder from Version Cue is a two-step process that safeguards against accidental deletions. The first 

step is deleting the file or folder and giving it the Deleted status. Deleting hides the file or folder from normal view 

but does not  erase it.  The second step is permanently  deleting  and erasing  the file or folder and  its previous versions.  

When you delete a folder, the folder and all folders and files nested inside it are hidden and given a Deleted status. 

When you permanently delete a folder, its entire contents are erased. 

Any user with appropriate privileges can delete files and folders unless the files or folders are marked In Use. In a 

workgroup, if a user is editing a file that you need to delete, you can reset the file’s lock by using the Version Cue 

Administration utility. 

You can restore files or folders that have a Deleted status. Restoring reinstates Version Cue management. Restored 

files and folders appear in their previous location in the project folder hierarchy. (Deleted files and folders maintain 

their relationship within the project hierarchy until they are permanently deleted.) 

In Bridge, InCopy, and in Adobe Creative Suite, you can show hidden and deleted files or folders, and view them in 

search results. Additionally, Version Cue has a Project Trash view from which you can view all deleted files in a 

project. Use Project Trash to view and handle all deleted files without navigating through the project folder hierarchy. 

You can delete individual files or folders in Bridge, InCopy, or any Adobe Creative Suite component. 

See also 

“Using working copies” on page 126 

“To delete a project in Bridge” on page 140 

“To disconnect from a project in Bridge” on page 138 

“To delete a Version Cue project in the Version Cue Administration utility” on page 163 

“Availability of Version Cue features” on page 113 
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Deleting projects 
Deleting a project from Version Cue permanently erases all of its master files (including versions and alternates) and 

folders from the Version Cue Workspace. This is a one-step process (with confirmation). Deleting a project automat

ically deletes the working copies of files on your computer as well as any shortcuts to that project. However, the 

working copies of files created on other users’ computers are not deleted until they disconnect from the deleted 

project.  You cannot restore  deleted projects directly in Version  Cue,  nor can  you delete a project if any  user  has files  

that are marked In Use.You can delete an entire Version Cue project in Bridge, InCopy, or any Adobe Creative Suite 

component. You can also delete projects by using the Version Cue Administration utility, if you have privileges to do 

so. 

To delete a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

For information about deleting a project from Acrobat 7, see Acrobat Help.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Do one of the following:


• Double-click the host Version Cue Workspace and select the project.


• Click the project shortcut.


4 Choose Delete from the Project Tools
  menu.


5 Click OK in the confirmation dialog box.


You can also delete projects using the Version Cue Administration utility.


See also 

“To delete a Version Cue project in the Version Cue Administration utility” on page 163 

“To disconnect from a project” on page 138 

“About the Adobe dialog box” on page 115 

To delete a project in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1 Start Bridge, and then click Version Cue in the Favorites panel.


2 Double-click Workspaces.


3 Right-click the project or the project shortcut, and then choose Delete Project from the menu.


4 Click OK to confirm the deletion.


To remove working copies of the files from the deleted project, you need to disconnect from the project.
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See also 

“To disconnect from a project in Bridge” on page 138 

“To delete a project” on page 140 

To delete files or folders from a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

Once you delete a file or folder from a project, you can then choose to permanently delete it or restore it with its


original data, including file versions and related information. For information about deleting files or folders from


Acrobat 7, see Acrobat Help.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Double-click the host Version Cue Workspace.


4 Double-click the project that contains the file or folder you want to delete.


5 Select the file or folder you want to delete.


6 Do one of the following:


• Choose Delete from the Project Tools menu 

• Drag the file to the Project Trash . 

Note: If Show Deleted files is not selected in the Project Tools menu, the file will become hidden and removed from view. 

If Show Deleted Files is selected, the file or folder will remain visible with the status Deleted. 

See also 

“To view Version Cue Workspace, project, and file information” on page 121 

To delete files from a project in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

Once you delete a file from a project, you can then choose to permanently delete it or restore it with its original data,


including file versions and related information.


1 In Bridge, click Version Cue in the Favorites panel, then double-click Workspaces.


2 Double-click the host Version Cue Workspace.


3 Double-click the project that contains the file you want to delete.


4 Select the file and click the Delete Item
  icon in the toolbar. 

Note: If Show Hidden and Deleted files is not selected in the View menu, the file will become hidden and removed from 

view. If Show Hidden and Deleted Files is selected, the file will remain visible with the status Deleted. 

See also 

“To view Version Cue Workspace, project, and file information” on page 121 

 



142 ADOBE PHOTOSHOP CS2 
User Guide 

To restore a file or folder deleted from a project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

For information on restoring files or folders in Acrobat 7, see Acrobat Help.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Double-click the host Version Cue Workspace.


4 Double-click the project that contains the file or folder you want to restore and do one of the following:


•	 Click Project Trash in the Favorites panel, select the file you want to restore, and choose Restore from the Project 

Tools menu . 

•	 Choose Show Deleted Items from the Project Tools menu (deleted file and folder names appear in gray in the 

dialog box). Select the file or folder you want to restore, and choose Restore from the Project Tools menu. 

5 Choose Refresh from the Project Tools menu to update the dialog box. 

The file or folder is restored to its original location in the Version Cue project. 

Note: To restore a file in a previously deleted folder, you must first restore the folder. Doing so restores the folder and all 

its contents. 

To delete a file or folder permanently 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

You can permanently delete and erase files or folders that have a Deleted status. For information about deleting a file


or folder permanently in Acrobat 7, see Acrobat Help.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Open the Version Cue Workspace and project that contains the file or folder you want to delete permanently.


4 Choose Show Deleted Items from the Project tools menu.


5 Select the file or folder you want to permanently delete, and choose Delete Permanent from the Project Tools


menu.


6	 Click OK. 

To delete a file permanently in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

You can permanently delete and erase files that have a Deleted status.


1 Start Bridge. In the Favorites panel, click Version Cue.


2 Double-click Workspaces, then double-click the project that contains the file you want to delete permanently.
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3 Right-click (Windows) or Control-click (Mac OS) the file, and choose Delete Permanent. 

4 Click OK to confirm the deletion. 

Version Cue versions 

About Version Cue versions 
Versions provide a convenient method of retaining work that was performed in different stages. At any point in your 

design process, you can save a version of the file, which Version Cue saves and tracks. Each version is a snapshot of 

the file. You can use versions to review ideas or changes with team members or a client before selecting a final version, 

or to recover from destructive changes. 

Version Cue prevents users from overwriting each other’s work. With this protection capability, multiple users can 

work on a file simultaneously. When more than one user is working on a file, Version cue alerts them all when one 

user saves a new version, allowing everyone to update the file and work in the latest version. 

Note: Two users cannot edit a file simultaneously in InCopy. 

You don’t have to save a version every time you save your changes. Using the File > Save command works the same 

way in Version Cue-managed files as in non-Version Cue files. You need only save a version when you want to create 

a snapshot of the file. For example, if you change the background color or some text in the layout, and then save a 

version, you can go back to the previous version without damaging your file. Instead of choosing File > Save As and 

saving a new copy of a design, you save a version, which allows you to track changes as they occur. 

If you want to continue your work using a previous version instead of the current version, promote the previous 

version to the next current version (do this instead of opening the previous version directly). This process keeps the 

previous version intact, should you decide to return to it again in the future. If you want a previous version, along 

with the current version, to be available for use in a project, you can save the previous version as a separate asset. 

When you do this, you can then make the previous version a member of a group of alternates, if desired. 

You can view previous versions in their native applications. When you no longer need to keep previous versions of 

files, you can delete them individually or in batches. 

See also 

“Viewing and comparing versions” on page 144 

“To save a version of a non-Adobe file” on page 144 

“About the Metadata panel in Bridge” on page 96 

“Availability of Version Cue features” on page 113 

To save a version 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 
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To save a new version of a file, you use the Save A Version command, which saves your changes to the Version Cue 

Workspace. Versions of a file can be subsequently compared using thumbnails, and viewed, deleted, or promoted 

using the Versions command. 

1 Do one of the following: 

• In Photoshop, Illustrator, InCopy, InDesign, or Acrobat 7, choose File > Save A Version. 

• In Bridge, choose Tools > Version Cue > Save A Version.


2 In the Save A Version dialog box, enter comments you want to associate with this version.


3 Click Save.


To save a version of a non-Adobe file 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

Bridge  opens files  in  their native applications so that you  can make changes. You  can save versions of non-Adobe  files  

only if (1) the files are in a Version Cue project and (2) the files have been opened through Bridge. After you create 

versions with this procedure, you can access them from the Versions dialog box in Adobe Creative Suite components, 

from InCopy, and from the Versions View of Bridge. 

1 Start Bridge. 

2 In the Favorites panel, click Version Cue, and then navigate to the project containing the file you want to save as


a version.


3 Double-click the file to open it.


4 When the file opens in its native application, make your changes, and save and close the file.


5 In Bridge, choose Tools > Version Cue > Save A Version.


6 In  the Save A Version dialog box, enter  comments  you want to associate  with  the version, and  then  click Continue. 


Note: You can save versions of nonembedded graphics, image, and text files in InCopy, InDesign, and Illustrator by using 

the Edit Original command in the Links palette. After editing the file, save it in its native application. Then, in the Links 

palette, select the file and use the Save Link Version command to save a version in the Version Cue project. For more 

information, see InCopy Help, InDesign Help, or Illustrator Help. 

Viewing and comparing versions 
Versions are always available for you to view and compare. Each version is treated as a separate file, which you can 

access through the Versions dialog box in all Adobe Creative Suite components and in InCopy. The Versions dialog 

box displays thumbnails of all file versions alongside comments, dates, and the login name of the user who created 

the version. Each version is numbered sequentially. You can view any version at any time. You can also promote a 

version, that is, make a previous version the current one. You can also delete versions if they are irrelevant or if you 

need to save disk space. When you delete older versions, the version numbers of the remaining versions remain the 

same. 

The Versions And Alternates view in Bridge displays versions of all the files in a project. This view is useful for 

comparing versions, because all the versions are available in one place for you to view or promote—you don’t need 

to search your hard drive for saved files. When you want to compare details of versions, you can choose to view each 

version in its native application. 
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The commenting features of Version Cue maintain a descriptive history of files. Each time you save or promote a 

version, you can describe what changes you made. This history helps you track changes made at different stages. Also, 

your version comments are searchable; you can search for a particular word to find a version quickly. 

Viewing versions in Bridge 

See also 

“To view file and folder thumbnails in Bridge” on page 85 

“Availability of Version Cue features” on page 113 

To view versions 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

After opening a file from a Version Cue Workspace, you can quickly access the previous version thumbnails, version


comments, and version dates by using the Versions dialog box.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Double-click the host Version Cue Workspace. Double-click the project to open it.


4 Click the name of the file whose versions you want to view.


5 Choose Versions from the Project Tools menu


6 In the Versions dialog box, do any of the following:


. 

•	 To create a new file version from an older version, select the version and click Promote To Current Version. 

•	 To open an earlier version in its own window and view details only or create a separate asset from the earlier 

version, click View Version. The version number appears in the file's title bar to remind you that you shouldn’t edit 

it. 

•	 To delete a version, select the version and click Delete. 
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In Acrobat 7, you can view the Versions dialog box by choosing File > Versions when a Version Cue-managed PDF 

file is open. 

You can view versions of a file while it’s open in an Adobe Creative Suite component: Choose Versions from the status 

menu at the bottom of the file window. 

See also 

“About the Adobe dialog box” on page 115 

“About Version Cue versions” on page 143 

To view versions in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

In Bridge, you can use the Versions And Alternates view to see all versions of all files in a project.


1	 Start Bridge, and then select Version Cue in the Favorites panel.


2 Choose View > As Versions And Alternates, or click the Versions And Alternates View icon (located at the lower


right corner).


3 Click the Versions View button in the upper right corner of the window.


4 Double-click a project to view the files.


You can also see previous versions of a file while in other Bridge views. Right-click (Windows) or Ctrl-click (Mac OS) 

any file in a Version Cue project and choose Versions. 

To view a previous version in its native application 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

❖ Do one of the following: 

•	 In the Versions dialog box, click the version you want to open and click View. 

Note: The version  number  appears in the  file’s  title bar  to  remind  you that it is not  the current  version and  you shouldn’t  

edit the file.The file status is Never Saved, because the previous version is only a snapshot of a previous stage of a file. 

•	 In Bridge, use the Versions And Alternates view, click the Versions View button in the upper-right corner of the 

window, right-click (Windows) or Control-click (Mac OS) a version, and choose View from the menu. 

Version Cue opens the previous version in its own window. You can then edit the previous version and save it as a 

new asset or as an alternate. If you edit the previous version, your changes won’t be reflected in the current version 

unless you promote the earlier version. 

See also 

“To view versions in Bridge” on page 146 

To promote a version 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 
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Promoting a previous  version automatically  saves a copy  of  that  previous  version as the  current version. Any  changes  

made between its creation and promotion don’t appear in the new current version. 

1	 Do one of the following: 

•	 In the Versions dialog box, select the version you want to promote, and click Promote To Current Version. 

•	 In Bridge, using the Versions and Alternates view, click the Versions View button in the upper right corner of the 

window, right-click (Windows) or Control-click (Mac OS) a version, and then choose Promote To Current 

Version from the  menu. If you  have  a working  copy  of  the file,  the status of the  file  changes to Outdated Copy until  

you open the file or synchronize. 

2	 Type a version comment in the Save A Version dialog box. Then click Continue to complete the promotion. 

To revert to the last version in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

❖ In Bridge, choose Tools > Version Cue > Revert To Last Version. 

See also 

“To delete file versions in a project” on page 165 

“To edit Version Cue project properties” on page 162 

To delete a version 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

❖ Do one of the following: 

•	 In the Versions dialog box, click the version you want to delete and click Delete. To delete multiple versions, Shift

click (Windows) or Control-click (Mac OS) the versions and click Delete. When prompted, confirm the deletion. 

•	 In Bridge, use the Versions And Alternates view, click the Versions View button in the upper right corner of the 

window, Right-click (Windows) or Control-click (Mac OS) the version, and then choose Delete from the menu. 

Note that the remaining versions are not renumbered. 

Using the Version Cue Administration utility, you can delete multiple previous versions of all files in a project simul

taneously if you have access privileges. By using this method, you can retain past versions by date or by number of 

versions to keep. 

See also 

“To delete file versions in a project” on page 165 

“To edit Version Cue project properties” on page 162 

“About the Version Cue Administration utility” on page 155 
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Version Cue alternates 

About Version Cue alternates 
Version Cue  makes it easy to manage variations of a design  through the  use of  alternates. For example, you can create 

alternates for variations of a design based on different versions or completely different photos for different editions 

of a publication. 

You can  use alternates in several  ways. For  instance, if you  make  extensive changes  to  a file,  it  may make more sense  

to save it as an alternate than a version. When you use alternates, your original file remains untouched and you’re 

free to continue your design work in a new direction. You can also create alternates for art you’re planning to use in 

different media, for example, a high-resolution alternate for print and a lower-resolution alternate for web use. Or, 

you can make alternates from files with totally different content. For example, suppose you are creating an article 

about fruit production. You might use a photo of an orange for the California edition, a photo of a banana for the 

Florida edition, and a photo of an apple for the Washington edition. You can save each photo as an alternate. 

You can access alternates from Bridge or directly from the Links palette in InCopy, InDesign, or Illustrator, making 

it easy to present a variety of design ideas to clients and creative directors. Version Cue protects alternates the same 

way as other assets. When you save an alternate, it appears as a separate file in its project, but Version Cue maintains 

a relationship between the original file and any alternates you create. 

Version Cue maintains relationships between alternates by creating alternates groups, which you can view together 

in the Alternates dialog box. You can manually group files into an alternates group by using the Make Alternates 

command. You create alternates from files in different folders by dragging them between Bridge windows. Using this 

method  you can  add files  from  additional  folders to the  group as well.  Thus, an alternates group  can contain  multiple  

files from multiple folders. You can make an alternate the primary, or preferred, alternate in a group. The primary 

alternate is designated by a special  status  icon, and  its name is in bold in the  Alternates  View. In the  Alternates  dialog  

box that appears in Adobe Creative Suite components and in InCopy (in the Links palette or Open dialog box), the 

primary alternate appears at the top of the list in the Alternates dialog box. 

You can change the primary alternate and remove alternates from the group by using Bridge or the Alternates dialog 

box in Adobe Creative Suite components or in InCopy. 

Note: Although you can create many alternates groups, a given file can be included in only one of these groups. Also, 

alternates must be located within a single project. Alternates are not available in Acrobat 7. 

Viewing alternates in Bridge 
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See also 

“Availability of Version Cue features” on page 113 

To save an alternate 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

If you have a file open and want to create your current work as an alternate to the previous versions, you must use 

the Save As command. 

1 Choose File > Save As.


2 In the Save As dialog box, select the Save As Alternate option at the bottom of the dialog box.


3 Click Save, and do one of the following:


• If you want to keep the same file name, save the alternates to a different folder. 

• If you want to save the alternate in the same folder, change the file name. 

The alternate is saved in the project file. 

Note: If you don’t change the folder or file name, Version Cue prompts you to create a new version of the file (not an 

alternate). 

To view alternates from Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

To quickly see which files have alternates, use the Versions And Alternates view in Bridge. This view includes thumb


nails of each alternate, shows the number of alternates, and indicates which alternate is the primary alternate in the


group. From this view, you can make changes to the alternates groups.


1 Start Bridge, and then select Version Cue in the Favorites panel.


2 Click the Versions And Alternates View icon. Then click Alternates View at the top of the screen.


3 Double-click a project to view alternates. To reveal an alternate’s location, right-click (Windows) or Control-click


(Mac OS) the alternate and choose Show File In Browser.


A file’s inclusion in a group of alternates is indicated by the Alternates icon
 and status information that displays 

how many alternates are associated with the file and whether the file is the primary alternate . 

You can also see alternates of a file while in other Bridge views. Right-click (Windows) or Ctrl-click (Mac OS) any 

file in a Version Cue project Select and choose Alternates. 

To view alternates 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 
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You can identify files with alternates in the Open, Place, Save, Import, and Export dialog boxes by looking in the


Alternates column, where the number of alternates is displayed. Alternates aren’t available in Acrobat 7.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Double-click the host Version Cue Workspace and the project containing the alternates.


4 Click the file for the alternates you want to view.


5 Choose Alternates from the Project Tools menu
 . 

Note: You can also view alternates from the Links palette in Illustrator or InDesign, or from the status menu at the 

bottom of a file window while the file is open in an Adobe Creative Suite component. To view alternates from the Links 

palette, choose Alternates from the Links palette menu. To view alternates while a file is open in an Adobe Creative Suite 

component, choose Alternates from the menu at the bottom of the file’s window. 

To make an alternate the primary 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

❖ Do one of the following: 

•	 In Bridge, click the Versions And Alternates View icon, and then click Alternates View at the top of the screen. 

Right-click (Windows) or Control-click (Mac OS) an alternate, and then choose Make Primary Alternate from the 

menu. 

•	 In the Alternates dialog box, select the alternate and then click Make Primary Alternate. Click Done to close the 

dialog box. (To learn how to access the Alternates dialog box, see “To view alternates” on page 149.) 

•	 In the Open, Save, Place, Import, and Export dialog boxes, right-click (Windows) or Ctrl-click (Mac OS) a file in 

a Version Cue project and choose Make Primary Alternate. 

See also 

“To view alternates from Bridge” on page 149 

“To view alternates” on page 149 

To remove an alternate 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

❖ Do one of the following: 

•	 In Bridge, click the Versions And Alternates View icon, and then click Alternates View at the top of the screen. 

Right-click (Windows) or Control-click (Mac OS) an alternate from the group on the right side of the window, 

and then choose Remove From Alternates Group. 

•	 In the Alternates dialog box, select the alternate, and then click Remove. Click Done to close the dialog box. (To 

learn how to access the Alternates dialog box, see “To view alternates” on page 149.) 

•	 In Open, Save, Place, Import and Export dialog boxes, right-click (Windows) or Ctrl-click (Mac OS) a file in a 

Version Cue project and choose Remove Alternate. 
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See also 

“To view alternates from Bridge” on page 149 

“To view alternates” on page 149 

To use the Make Alternates command 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

When you use the Make Alternates command, you can make different files alternates of each other in an alternates


group. You can select multiple files from more than one folder to make alternates.


1 In Illustrator, InCopy, InDesign, or Photoshop choose File > Open.


2 Navigate to the project containing the files you want to make alternates.


3 Shift-click or Control-click to select the files you want to make alternates. To view files in more than one folder,


click the triangle to the left of the folder name.


4 Right-click (Windows) or Control-click (Mac OS) one of the selected files, and then choose Make Alternates from


the menu.


Note: Although it is possible to reveal files in different projects by using the disclosure triangles, only files within a single 

project can be made alternates of each other. 

See also 

“To view alternates from Bridge” on page 149 

“To view alternates” on page 149 

To make alternates in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

When you make alternates in Bridge, you can make different files alternates of each other in an alternates group. 

Alternates are not available in Acrobat 7. 

❖ To make alternates in Bridge, do one of the following: 

•	 To make alternates from files in one folder in Bridge, navigate to the project containing the files you want to make 

alternates. In the Bridge window, Shift-click or Control-click to select the files you want to make alternates and 

choose Tools > Version Cue > Make Alternates. 

•	 To make alternates from files in multiple folders in Bridge, navigate to the project containing the files you want to 

make alternates, and click Alternates View in the upper right corner of the Bridge window. (If Alternates View 

doesn’t appear, click Versions and Alternates View in the lower right corner of the window.) Choose File > New 

Window, and navigate to a different folder in the same Version Cue project. Shift-click or Control-click to select 

the files you want to make alternates, and drag them to the right of the larger thumbnail showing the file being 

viewed in the Alternates view of the first Bridge window. 

•	 To make alternates from a past version of a file in Bridge, navigate to the project containing the file you want to 

make an alternate. Right-click the file and choose View. When the file opens in its native application, choose File > 

Save  As, and  either  save  the file in a different  folder  or  change  the file name.  Select  Alternates, and  then  click Save.  
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See also 

“To view alternates from Bridge” on page 149 

“To view alternates” on page 149 

To move an alternate to another alternates group 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

A file cannot be a member  of  more  than  one alternates group. To move an alternate  to  another group, you  must  first  

remove it from it’s original group and then add it to a new group. 

1 Remove the alternate from its group. For instructions, see “To remove an alternate” on page 150. 

2 Add the file to a new alternates group. For instructions, see “To save an alternate” on page 149 or “To make alter

nates in Bridge” on page 151. 

Editing and synchronizing offline files 

Editing and synchronizing offline files 
When  you need  to  work  on  files from a Version  Cue project  while the  Version Cue  Workspace is unavailable  on  the  

network, you can edit working copies on your computer. When the Version Cue Workspace is available again, you 

must synchronize your files with the workspace to save your latest version to the Version Cue Workspace. You can 

synchronize an entire project, just a folder in the project, or a selected file. 

Working copies are normally copied on your computer when you open a project from an online workspace. However, 

if you haven’t yet edited the file, you can prepare to work offline by synchronizing the entire Version Cue project, or 

just the files you need, while the workspace is still online to ensure that you have working copies. 

When you are working offline, you can’t create multiple versions because the Save A Version command is 

unavailable. 

In Version Cue CS2, if you intend to work on a file offline, you can manually mark the file In Use before you take 

your work offline. When you mark a file In Use, Version Cue creates a working copy of the file for you. (You can mark 

a file In Use even if you don’t intend to work offline.) Typically, when you’re editing a file, In Use appears when other 

users access a file. When a file’s status is In Use, Version Cue protects the file. When you synchronize your file, the 

status of the file returns to Synchronized. Mark In Use is not available in Acrobat 7. 

If you have edited an offline file recently, you can open it from the File > Open Recent menu. 

See also 

“Availability of Version Cue features” on page 113 
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To manually mark a file as In Use 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1	 Do one of the following: 

•	 In Bridge, click Version Cue in the Favorites panel. Navigate to the file. Select one or more files. Right-click 

(Windows) or Ctrl-click (Mac OS) a file, and then choose Mark In Use. 

•	 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Version Cue in the Favorites panel, and 

then navigate to the file. Select one or more files. Right-click (Windows) or Control-click (Mac OS) a file, and then 

choose Mark In Use. (Mark In Use is not available in Acrobat 7.) 

2 When you finish editing the file offline and the Version Cue workspace is again available, synchronize the file in 

Bridge or in any Adobe Creative Suite component. Version Cue automatically creates a new version of the file. If the 

workspace becomes available while you still have the file open, simply save a version. 

If you haven’t made any changes, you can manually cancel the In Use By Me status, by choosing Cancel Mark In Use 

from the context menu. 

See also 

“To synchronize files” on page 154 

“To synchronize files in Bridge” on page 154 

To edit working copies of files from an offline project 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

For information on editing offline files in Acrobat 7, see Acrobat Help.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Double-click the host Version Cue Workspace.


4 Double-click  the Version  Cue project  that  contains  the file.  It  may take Version  Cue a few seconds  to  verify  that  a 


Version Cue Workspace or project is unavailable.


5 Double-click a file to open it (the Offline Copy status allows you to open the file).


6 When you finish editing the file, choose File > Save to save the changes to the working copy. When the Version


Cue Workspace becomes available again, synchronize your files.


See also 

“Editing and synchronizing offline files” on page 152 

“To synchronize files” on page 154 

“To synchronize files in Bridge” on page 154 
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To synchronize files in Bridge 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

1 Start Bridge. In the Favorites panel, click Version Cue.


2 Double-click Workspaces.


3 Select the project that contains the master file, and do one of the following:


•	 To synchronize the entire project, right-click (Windows) or Control-click (Mac OS) the project, and then choose 

Synchronize. 

•	 To synchronize a file in the project, open the project, right-click (Windows) or Control-click (Mac OS) the folder 

or file, and choose Synchronize from the Project Tools menu. 

4 If the master file on the Version Cue Workspace is newer than your working copy and you’ve edited the working 

copy, a File Conflict dialog box appears. Specify one or more of the following: 

Apply The Following Action To All Subsequent Conflicts Automatically applies the selected option every time 

there is a file conflict. 

Save A Version Saves your working copy as a new file version to the Version Cue Workspace. 

Skip This File Prevents the most recent version from the Version Cue Workspace from being downloaded. (This 

option  also  prevents  a version  of  your  working copy form being  saved to the  workspace.) Choose this option only if  

you want to keep your edits and disregard the other changes in the master file. 

To synchronize files 
Note: You can perform this task only if you have access to the full Version Cue feature set, available in Adobe Creative 

Suite or in a shared workspace. See “Availability of Version Cue features” on page 113 for more information. 

For information on synchronizing files in Acrobat, see Acrobat Help.


1 In Illustrator, InCopy, InDesign, or Photoshop, choose File > Open. Click Use Adobe Dialog if you’re using the OS


dialog box.


2 Click Version Cue in the Favorites panel.


3 Select the project that contains the master file, and do one of the following:


•	 To synchronize the entire project, choose Synchronize from the Project Tools menu . 

•	 To synchronize just a folder or one or more files, open the project, select the folder or files that you want to 

synchronize, and choose Synchronize from the Project Tools menu. 

4 If the master file on the Version Cue Workspace is newer than your working copy and you’ve edited the working 

copy, a File Conflict dialog box appears. Specify one or more of the following: 

Apply The Following Action To All Subsequent Conflicts Automatically applies the selected option every time 

there is a file conflict. 

Save a Version Saves your working copy as a new file version to the Version Cue Workspace. 

Skip This File Prevents the most recent version from the Version Cue Workspace from being downloaded. (This 

option  also  prevents  a version  of  your  working copy from being  saved to the  workspace.) Choose this option only if  

you want to keep your edits and disregard the other changes in the master file. 
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The Version Cue Administration utility 

About the Version Cue Administration utility 
Using the Version Cue Administration utility, you can do more advanced tasks that affect a specified project or an 

entire Version Cue Workspace. 

The following table lists the Version Cue-related tasks that you can accomplish through an Adobe Creative Suite 

component and those that you can accomplish through the Version Cue Administration utility. 

Task Adobe Cre
ative Suite 
components 

Version Cue 
Administra
tion 

Create, edit, and delete Ver
sion Cue projects 

Yes Yes 

Share a project with anyone 
who is using Adobe Creative 
Suite, an Adobe Creative Suite 
component, or a WebDAV
enabled application 

Yes Yes 

Delete a file version Yes Yes 

Delete multiple file versions at 
once 

Yes Yes 

Create Version Cue projects 
from remote files via FTP 

No Yes 

Create Version Cue projects 
from remote files via WebDAV 

No Yes 

Import Version Cue 1.0 
projects 

No Yes 

Back up Version Cue projects 
and restore backup versions of 
a project 

No Yes 

View the amount of disk space 
a project uses, its lock protec
tion status, its creator, and its 
creation date 

No Yes 

Duplicate or export Version 
Cue projects 

No Yes 

Edit Version Cue Workspace 
preferences 

No Yes 

Add and edit users, and define 
their project privileges 

No Yes 

Change the properties of a 
Version Cue project to require 
users to log in before access
ing it 

No Yes 

View all users and their privi
leges for all projects in the Ver
sion Cue Workspace 

No Yes 
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Task Adobe Cre
ative Suite 
components 

Version Cue 
Administra
tion 

Remove all In Use locks in a 
project or those created by a 
specified user 

No Yes 

View Version Cue Workspace 
logs and reports 

No Yes 

Add files to an existing project Yes No 

Create file versions Yes No 

View file comments and other 
information 

Yes No 

Search for files using file infor
mation (metadata) 

Yes No 

Initiate and manage a web
based review of PDF files in 
Version Cue projects 

No Yes 

Logging into and out of the Version Cue Administration utility 
When you install Version Cue on your computer, Version Cue automatically creates a default user login ID with 

administrator privileges. You should change the password for this default user login, as it is publicly available for 

initial installation and setup. Until you change the default password, the default user login ID can only be used 

directly from the computer the Version Cue workspace is located on, not across a network. If the Administration 

utility is installed  on  your  computer, you  can start  using the  web-based  Version Cue  Administration  utility with the  

Version Cue default login ID (system) and password (system). 

Users working in a group with a login ID and password can log into the Version Cue Administration utility. The tasks 

that workgroup users can perform are limited by the privileges assigned to their Version Cue login ID by the admin

istrator. However, users whose access level is set to None can’t log into the Version Cue Administration utility. 

You can display the Version Cue Administration login web page in the following ways: 

•	 By opening the Version Cue preferences and clicking the Advanced Administration button. 

•	 By clicking the Advanced Administration button in GoLive CS2, Illustrator CS2, InCopy CS2, InDesign CS2, 

Photoshop CS2, or Acrobat 7. 

•	 By typing the IP address of the Version Cue Workspace directly into a web browser. 

•	 By selecting Advanced Administration from the Version Cue system tray icon (Windows) or the Version Cue 

menu (Mac OS). 

See also 

“Choosing user privileges” on page 169 
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To log into Version Cue Administration from an Adobe Creative Suite component 
You can log in the same way from InCopy CS2, InDesign CS2, Illustrator CS2, Photoshop CS2, and Acrobat 7.


1 Choose File > Open, and click the Use Adobe Dialog button in the dialog box.


2 Select the Version Cue Workspace you want to administer.


3 Choose Edit Properties from the Tools menu


4 Click Advanced Administration in the Edit Properties dialog box.


5 Type your assigned Version Cue login ID and password in the text boxes. (The default for both the ID and


. 

password is system.)


6 Click Log In.


To log into Version Cue Administration from GoLive CS

1 Open the Version Cue site file.


2 Choose Site > Version Control System > Open Version Cue Administration.


3 Type your assigned Version Cue login ID and password in the text boxes. (The default for both the ID and


password is system.)


4 Click Log In.


To log into Version Cue Administration from a web browser

1 In  a web  browser,  type  the IP or DNS  address of the  computer  on  which the  Version Cue  Workspace is installed. 


Precede the address with http:// and follow it with a colon and the port number, for example,


http://153.32.235.230:3703 (IP) or http://myserver.mycompany.com:3703 (DNS). The default port number is 3703.


Note: If you have Version Cue 1.0 installed on your computer, the default port number for Version Cue 2.0 is 50800. 

Once Version Cue 1.0 is uninstalled, Version Cue 2.0 defaults to 3703. 

2 A browser window displays the Adobe Version Cue Administration login page. Type your assigned Version Cue 

login ID and password in the text boxes. (The default for both the ID and password is system.) 

3	 Click Log In. 

To log into Version Cue Administration from the Version Cue Preferences dialog box 
1 Do one of the following: 

•	 (Windows) Double-click the Version Cue icon in the system tray. In the Edit Project Properties dialog box, click 

Advanced Administration. 

•	 (Windows) Right-click the Version Cue icon in the system tray and then choose Version Cue CS2 Preferences. 

On Windows, double-click the Version Cue icon to open the preferences dialog box. 

•	 (Mac OS) Click the Version Cue icon at the top of the screen, and then choose Advanced Administration from the 

menu. 

•	 (Mac OS) Control-click the Version Cue icon and choose Version Cue CS2 preferences. 
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On Mac OS, choose Version Cue CS2 Preferences to open the preferences dialog box 

2 Type your assigned Version Cue login ID and password in the text boxes. (The default for both the ID and 

password is system.) 

3 Click Log In. 

To log out of Version Cue Administration 
❖ Click Log Off at the top of the page. 

About Version Cue Administration integrity checks 
Each time the Version Cue Workspace restarts, it performs an integrity check and performs repairs if necessary. To 

ensure best performance, restart the Version Cue Workspace periodically so it can perform the integrity check and 

self-repair. 

To set Version Cue Workspace Administration preferences

1 Log into the Version Cue Administration utility.


2 Do one of the following:


• Click the Advanced tab, and then click Preferences.


• On the Home page, click Perform Advanced Tasks, and then click Preferences.


3 Set any of the following options:


Workspace Name To change the Version Cue Workspace name, type a name in the text box. This name identifies


the Version Cue Workspace in Adobe Creative Suite components using Version Cue.


Make This Version Cue Workspace Visible To Others. When selected, gives other computers access to the Version 

Cue Workspace. 

Note: If the Version Cue Workspace is installed on a Windows computer that uses a firewall and you want to share the 

workspace with others, make sure that TCP ports 3703 and 427 are left open and deselect the Internet Connection 

Firewall option (see Windows Help). 

Only Grant Access To Existing Users Specifies whether Version Cue projects are available to a user. Make sure to set 

access properties for each desired project and to edit the project’s list of assigned users. 

Log Level Defines the amount of information in reports generated by the Version Cue Workspace system. Choose 

a log level: Error to list only Version Cue Workspace errors; Warning to list workspace errors and warnings; or Info 

to list errors, warnings, and information about tasks performed. 

Log Size Sets the maximum size, in kilobytes, for a system report. To reduce the log file size by saving it as a 

compressed GZ file, select Compress Log File. 
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FTP Proxy Specifies the default FTP Proxy server for users importing projects from or exporting projects to an FTP 

server, or publishing with GoLive to an FTP server. 

HTTP Proxy Specifies the default HTTP Proxy server for users importing projects from or exporting projects to a 

WebDAV server, or publishing with GoLive to a WebDAV server. 

Color Scheme Sets the background colors of the tabs. 

4	 Click Save, and then restart Version Cue Administration. 

Migrating from Version Cue 1.0 to Version Cue 2.0 
If you currently use Version Cue 1.0, you need to migrate your projects and user data to Version Cue 2.0. Keep the 

following in mind: 

•	 Version Cue 1.0 and Version Cue 2.0 Workspaces can be installed and function on the same computer simulta

neously. 

•	 If  Version Cue  1.0  and Version  Cue 2.0  Workspaces  are installed  on  the same computer,  Adobe Creative Suite  1.0  

components work only with the Version Cue 1.0 Workspace, because they can communicate only with the port 

that the Version Cue 1.0 Workspace uses. 

Note: If you uninstall the Version Cue 1.0 Workspace and then restart the Version Cue 2.0 Workspace, the Version Cue 

2.0 Workspace then uses the Version Cue 1.0 Workspace’s port, allowing Adobe Creative Suite 1.0 components and Adobe 

Creative Suite 2.0 components to work with the Version Cue 2.0 Workspace. 

•	 If only the Version Cue 2.0 Workspace is installed, Adobe Creative Suite 1.0 components will work with it. 

•	 Adobe Creative Suite 2.0 components work only with Version Cue 2.0 Workspaces. 

•	 Adobe Creative Suite 1.0 components work with both Version Cue 1.0 and Version Cue 2.0 Workspaces simulta

neously as long as the workspaces are not located on the same computer. 

•	 You can import Version Cue 1.0 projects and users using the Administration utility (see “To migrate from Version 

Cue 1.0 to Version Cue 2.0” on page 159). 

To migrate from Version Cue 1.0 to Version Cue 2.0

1 After installing Version Cue 2.0, restart the Version Cue 1.0 Workspace. The activates a migration plug-in.


2 Log into the Version Cue Administration utility.


3 Click the Advanced tab, and then click Import Version Cue 1.0 Data.


4 Select the data you’d like to migrate to Version Cue 2.0:


•	 Projects and users. Click Next. Select the check box next to the name of any projects you want to import, and click 

Next. Then, select the check box next to the name of any users you want to import, and click Next. 

•	 Only projects. Click Next. Then, select the individual projects you want to import, and choose whether to import 

all the users assigned to those projects (at this point, you cannot select individual users; you must import either all 

users or no users). Click Next. If you choose to import the users, select the users you want to import, and click 

Next. 

•	 Only users. Click Next, and, in the next page, select the check box next to the name of any users you want to 

import. 

5	 When the migration process is complete, verify the information you’re importing, and confirm the migration. 

 



160 ADOBE PHOTOSHOP CS2 
User Guide 

6	 Uninstall Version Cue 1.0. 

7 Restart the Version Cue 2.0 Workspace. This resets the port to allow access from both Adobe Creative Suite 1.0 

and Adobe Creative Suite 2.0 components. 

Creating and editing projects in Version Cue 
Administration 

To create a new blank Version Cue project 
1 Do one of the following: 

•	 In the Home tab, click Create A Project. 

•	 Click the Projects tab, and then click New. 

2 In  the New  Project content  frame,  click Blank  Project to create an empty  Version Cue  project.  Click Next to display 


the Create Blank Project content frame.


3 Type a name for your project in the Project Name box.


4 To specify how to treat the imported content’s URL encoding, choose an option from the URL Encoding menu.


5 Set any of the following options:


Share This Project With Others Gives other users access to the project. Users can be on your subnetwork, or they


can be given the Version Cue Workspace IP or DNS address and port number to gain access to the Version Cue 

Workspace. 

Require Login For This Project Ensures that only users with a Version Cue login ID and password have access to 

the project. 

Enable Lock Protection For This Project Restricts file versioning to sequential versions. 

URL Encoding Specifies how the content’s URL encoding is treated. UTF-8 is the default setting. 

%HH Escaping Requires that a nonsafe character be encoded as a percent symbol (%) followed by two hexadecimal 

digits. 

6 Click Save.


7 If you chose to require login, do any of the following in the Assigned Users content frame, and then click Save:


•	 Choose  an  option  next  to  each  user  name  in  the Privileges column or choose an option from the  Set All  To  menu  

to define each user’s access. These options won’t work unless you select Require Login For This Project. 

•	 To let a user publish the project with GoLive CS2 to a specified FTP or WebDAV server, select the check box in 

the Publishing Privilege column next to the user name. 
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To create a new Version Cue project from a folder 
You can create a Version Cue project from the files in a folder on the computer where the Version Cue Workspace is 

installed. 

1 Log into Version Cue Administration. 

2 Do one of the following: 

•	 In the Home tab, click Create A Project.


• Click the Projects tab, and then click New.


3 In the New Project content frame, click Import From Folder.


4 Click Next to display  the Import Project  From  Folder  content frame. If the  content you’re importing  is  a website, 


select Import Folder As A Website to import the content to the project’s web-content folder. To specify the folder to


import from, click Browse and select any file in the folder; then click Open. Alternatively, you can type the path to


the desired Version Cue Workspace folder in the text box.


5 Type a name for your project in the Project Name box.


6 Set any of the following options:


Share This Project With Others Gives other users access to the project. Users can be on your subnetwork, or they


can be given the Version Cue Workspace IP or DNS address and port number to gain access to the workspace. 

Require Login For This Project Ensures that only users with a Version Cue login ID and password have access to 

the project. Note that if you  select  this  option  after a user  gains access,  the user can  still gain access without  logging  

in. Make sure that you change privileges as needed in the project’s list of users. 

Enable Lock Protection For This Project Restricts file versioning to sequential versions. 

URL Encoding Specifies how the content’s URL encoding is treated. UTF-8 is the default setting. 

%HH Escaping Requires that a nonsafe character be encoded as a percent symbol (%) followed by two hexadecimal 

digits. 

Comments Stores any remarks you type about the project. 

7	 Do any of the following in the Assigned Users content frame, and then click Save: 

•	 To define each user’s access to the project, choose an option next to each user name in the Privileges column or 

choose an option from the Set All To menu. These options won’t work unless you select Require Login For This 

Project. 

•	 To let a user publish the project with GoLive CS to a specified FTP or WebDAV server, select the check box in the 

Publishing Privilege column next to the user name. 

To create a new Version Cue project from a WebDAV server or FTP server

1 Log into Version Cue Administration.


2 Do one of the following:


•	 In the Home tab, click Create A Project.


• Click the Projects tab, and then click New.


3 In the New Project content frame, do one of the following:


•	 Click Import From WebDAV Server.


•	 Click Import From FTP Server.
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4	 Click Next to display the Import Project From Server content frame. 

5 If the content you’re importing is a website, select Import FTP/WebDAV As A Website to import the content to 

the project’s web-content folder. 

•	 In the FTP Server or WebDAV Server box, specify the WebDAV server from which to import files, and type the 

port number in the Port box. 

•	 To specify a folder, type its path in the Directory box. 

•	 If a user name and password are required to access the server, type that information in the User Name and 

Password boxes. 

• To use a proxy server to connect to the server, select Proxy.


6 Type a name for your project in the Project Name box.


7 To specify how to treat the imported content’s URL encoding, choose an option from the URL Encoding menu.


8 To comply with the URL syntax requiring nonsafe characters to be encoded as a percent symbol (%) followed by


two hexadecimal digits, select %HH Escaping.


9 Do any of the following, and then click Next:


•	 To give other Version Cue or WebDAV users access to the project, select Share This Project With Others. (Users 

must either be on your subnetwork or be given the Version Cue Workspace IP or DNS address and port number.) 

•	 To require users to log in with a Version Cue login ID and password before accessing the project, select Require 

Login For This Project. If selected, this option ensures that only Version Cue users you specify can log in and 

access the project. 

Note: If you select this option after other users have already accessed the project without being authenticated, those users 

can still access the project without logging into it. Make sure that you change their privileges as needed in the project’s 

list of assigned users. 

•	 To restrict file versioning to sequential versions, select Enable Lock Protection For This Project. 

• To include remarks regarding the project, type them in the Comments box. 

10 Do any of the following in the Assigned Users content frame, and then click Save: 

•	 To define each user’s access to the project, choose an option next to each user name in the Privileges column or 

choose an option from the Set All To menu. 

•	 To let a user publish the project with GoLive to a specified FTP or WebDAV server, select the check box in the 

Publishing Privilege column next to the user name. 

Note: You don’t  need  to  assign  users in order  to  give  others  access  to  your  Version Cue  project.  Just  make  sure  to  deselect  

Require Login For This Project in the project properties. 

To edit Version Cue project properties 
1 Log into the Version Cue Administration utility. 

2 Click the Projects tab, and then click a project name. 
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3 Set any of the following options: 

Share This Project With Others Gives other users access to the project. Users can be on your subnetwork, or be 

given the Version Cue Workspace IP or DNS address and port number. 

Require Login For This Project Ensures that only users with a Version Cue login ID and password have access to 

the project. Note that if you  select  this  option  after a user  gains access,  the user can  still gain access without  logging  

in. Make sure that you change privileges as needed in the project’s list of users. 

Enable Lock Protection For This Project Restricts file versioning to sequential versions. 

Comments Stores any remarks you type about the project. 

Backup Configuration Allows you to back up your project or edit backup settings. 

4 Click Save, or click Reset to return the properties to their original values. 

See also 

“To back up a Version Cue project” on page 166 

To duplicate a Version Cue project 
Duplicate a project to start new project with the same users and privileges. Version Cue duplicates the folder


hierarchy within the project structure, and you can use that as a basis for the new project. Delete any files from the


duplicated project that are no longer necessary.


1 Log into the Version Cue Administration utility.


2 Click the Projects tab.


3 Select the check box next to the name of the project, and click Duplicate.


4 In the Duplicate Project content frame, type a unique name for the project.


5 Edit the project properties.


6 Click Duplicate.


To delete a Version Cue project in the Version Cue Administration utility

1 Log into the Version Cue Administration utility.


2 Click the Projects tab, and do one of the following:


• To delete one or more projects, select the check box next to the name of each project you want to delete.


• To delete all listed projects, select the check box next to the Project Name column label.


3 Click Delete. The Delete Project content frame appears. Click Delete again, or click Cancel to cancel the deletion.
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To export a Version Cue project to your computer 
You can  export  the most recent version  of  all project  files from the  Version Cue  Workspace.  You can  use this export  

to move these files from one host computer (or server) to another or to create a package of the most recent files for 

output or simply to create an archive of the final versions.Version Cue still manages projects moved between 

computers.  If  you want to move a project,  you should decide whether  to  back  it  up  (so that all  past  versions  are also  

moved)  or  export  (so that only the  current versions of project  files are  moved).  For more information  about backing  

up a project, see “Backing up and restoring projects in the Version Cue Administration utility” on page 165. 

1 Log into the Version Cue Administration utility. 

2 Do one of the following: 

•	 Click the Projects tab. Select the check box next to the project you want to export, and click Export. 

•	 Click the Advanced tab, and then click Export Project. The Export Project content frame appears. Select the 

project you want to export from the Project Name menu. 

3 In the Export Project page, choose the name of the project you want to export, and then choose File from the 

Protocol menu. 

4 Click Browse, and specify the folder to which you want to export the project. Select any file in the folder, and click 

Open. 

5	 Click Export. 

You can also export a project by using the Version Cue preferences. For more information, see “To set Version Cue 

Workspace preferences” on page 116. 

To export a Version Cue project to an FTP or WebDAV server

1 Log into the Version Cue Administration utility.


2 Do one of the following:


•	 Click the Projects tab. Select the check box next to the project you want to export, and click Export. 

•	 Click the Advanced tab, and then click Export Project. The Export Project content frame appears. Choose the 

project you want to export from the Project Name menu. 

3 In the Export Project page, choose the name of the project you want to export and then choose either FTP or 

WebDAV from the Protocol menu. 

4 Specify the FTP or WebDAV server address in the Server Address text box. You don’t need to precede the address


with the chosen protocol. If you want, you can change the default port number in the Port box.


5 To specify a folder, type its path in the Directory box.


6 If a user name and password are required to access the server, type that information in the User Name and


Password boxes.


7	 To use a proxy server to connect to the server, select Proxy.


8 If you are connecting to the server through a firewall, or if you specified a port other than 21, select Use Passive


Mode. (This is an option only if you choose FTP in the Protocol menu.)


9 Click Export.
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To remove file locks from a Version Cue project 
A user with system administrator privileges or with project-specific Administer privileges can remove file locks. 

Removing file locks forces the removal of In Use status of files designated by specific project or by user throughout 

all the projects. 

1 Log into the Version Cue Workspace Administration utility. 

2 Click the Advanced tab , and then click Reset Locks (under Maintenance). 

3 Do any of the following: 

• Choose a project from the Project Name menu. 

• Choose a user from the User Name menu. 

4 Click Reset Locks to remove the specified file locks. 

To delete file versions in a project 
Each time you save a file version, the version is stored on the Version Cue Workspace database. This database creates 

a file version history that lets you quickly return to any former state of the file. Although a version history is useful, 

an  extensive history  takes up a lot of disk space  and can  degrade the  performance of the  Version Cue  Workspace.  It’s  

a good idea to clean up versions to improve performance. 

1 Log into the Version Cue Workspace Administration page. 

2 Click the Advanced tab , and then click Remove Old Versions. 

3 Choose a project from the Project Name menu. 

4 To delete versions, select Delete All Versions Older Than, and then choose a month, day, and year. 

5 To specify the maximum number of versions to remain in the workspace after you click Delete, select Number Of 

Versions To Keep, and then type a number in the text box. 

6 Click Delete. 

Backing up and restoring from Version Cue 
Administration 

Backing up and restoring projects in the Version Cue Administration utility 
The Version Cue Administration utility creates backups of all the information in a Version Cue project. Project 

backups are stored on the Version Cue file system, in the Backups folder. You can then easily restore a backup copy 

that represents a Version Cue project as it was on a specific date. Restored project backups do not replace the original 

Version Cue project; restored projects are given different project names. You can use a project backup to move a 

project from one Version Cue Workspace to another while retaining all the versions of that project. 

You can customize a backup configuration for your projects. You can back up a project using a new configuration or 

an existing configuration. A backup configuration includes the ability to schedule a recurring backup for the project. 
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To back up a Version Cue project 
The backup configuration used to back up a project is set in the Version Cue project preferences.


1 Log into the Version Cue Administration utility.


2 Click the Projects tab.


3 Select the check box next to the project name, and then click Backup.


4 In the Backup Name text box, accept the name, or type a new name.


5 Choose the project components you want to back up: Files (which is always selected), Project File Versions to back


up all versions of the files, Project Metadata to back up embedded information entered in Adobe Creative Suite


components, and Users/User Assignments to back up information about the users and their project privileges.


6 Click Backup. When the backup is complete, a status page appears.


See also 

“To edit Version Cue project properties” on page 162


To restore a Version Cue project backup copy

1 Log into the Version Cue Administration utility.


2 Click the Projects tab.


3 Click Backup List.


4 Click the name of the backup that you want to restore.


5 In the New Project Name box, type a name that is different from those of other projects in the Version Cue


Workspace.


6 Do any of the following, and then click Restore:


• To retain the list of users that were assigned to the project, select Restore Users. 

• To retain the same privileges for each assigned user, select Restore User Assignments. 

• To add remarks, type them in the Comments box. 

To create a new backup configuration 
New backup configurations are created in the project’s preferences. When you create a new configuration, it becomes 

the default for the project. 

Log into the Version Cue Administration utility.


Click the Projects tab.


Select the name of the project for which you want to create a new backup configuration.


Under Backup Configurations in the Edit Properties page, click New.


Type a name for the backup configuration in the Configuration Name box.


Select what you want to back up in the Include list of options: Files (which is always selected), Project File Versions


to back up all the versions of the project, Project Metadata to back up embedded information entered in Adobe 

Creative Suite components, and Users/User Assignments to back up information about the users and their project 

privileges. 

7 (Optional) Add remarks to the backup file in the Comments box. 
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8 Choose an option from the Repeat menu if you want backups to occur automatically (choose Don’t Repeat if you 

want to back up the project manually). 

9 Click Save to save the new configuration and to see a list of backup configurations. 

To back up all data in the Version Cue Workspace 
It’s important to back up projects in a Version Cue Workspace from time to time. Rather than doing this project by 

project, you can instead back up the complete Version Cue Workspace. You can also use this backup to move a 

complete workspace from one computer to another. If you restore  a backup copy of the  Version Cue  Workspace,  all  

current data on the workspace, including Version Cue projects, files, and versions, is replaced by the backup. 

Workspace backup files are saved to the default Backups folder in the Version Cue application folder. 

1 Log into the Version Cue Administration utility. 

2 Click the Advanced tab , and then click Backup Version Cue Data.


3 To add remarks about the workspace backup, type them in the Comments box.


4 Click Save. After the back up is complete, click OK to view the list of workspace backups.


To replace a project with a previous backup 
To replace current projects on a Version Cue Workspace with a previous version, you first restore the backup. When 

you do this, Version Cue Administration turns off automatically. You must restart Version Cue on the host 

workspace; it cannot be done remotely. 

1 Log into the Version Cue Administration utility. 

2 Click the Advanced tab, and then click Administer Backups. 

3 
browser. (Notice that the Version Cue icon in the system tray indicates that it’s off

Click the name of the backup you want to restore. Click Restore. The Version Cue Workspace turns off. Close the

.)


4 Turn on the Version Cue Workspace.


5 Log into the Version Cue Administration utility.


Working with users and privileges 

Creating and editing users 
All users with a Version Cue user name and login (except those whose access level is set to None) can log into the 

Version Cue Workspace Administration utility. However, the tasks they can perform are limited by the privileges 

assigned to their user names. 

To restrict the Version Cue projects that a user can access, you can edit the project’s existing user names. Or, to restrict 

access further, you can create new Version Cue user names and assign them to a specific project. Creating new names 

gives you the most control over a project. 

Note: Only users who have system administrator privileges can create new user names. 
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If you’ve configured the Version Cue Workspace to be visible to others in the Version Cue Administration utility, you 

don’t need to create and assign Version Cue user names to let other Adobe Creative Suite or WebDAV users access 

your Version Cue projects and the Version Cue Workspace. The users simply need either to be on your subnetwork 

or be given the Version Cue Workspace IP or DNS address and port number. After a user accesses the Version Cue 

Workspace without using a Version Cue user name, the user name for the user’s own computer is automatically 

added to the list of users in the Version Cue Workspace, and the password is left blank. 

If you’ve configured the Version Cue Workspace so it grants access only to existing users, you’ll need to create Version 

Cue user names to let other Adobe Creative Suite or WebDAV users access your Version Cue projects and the Version 

Cue Workspace. 

To create new Version Cue user names 
To create new user names in a Version Cue Workspace, you need system administrator privileges. 

1 Log into the Version Cue Administration utility. 

2 Do one of the following: 

• From the Home page, click Add A User.


• Click the Users tab, and then click New in the content frame.


3 In the New User content frame, choose the level of access to give the user from the Admin Access Level menu:


None Denies the user access to the Version Cue Workspace Administration utility, however, the user can access


Version Cue projects while working in an Adobe Create Suite component.


User Gives the user access to some administrator privileges, such as viewing other users’ information, creating new 

projects, and backing up and restoring projects. 

System Administrator Grants the user all privileges. 

4 Type the user’s name in the User Name box.


5 Type a unique login in the Login box. The login is needed in Adobe Creative Suite components, if a project


requires it, to log into the Version Cue Workspace Administration utility.


6 Type a password for the user in the Password box, and type it again in the Verify Password box.


7 (Optional) Type a phone number, an e-mail address, and comments in the remaining text boxes. Make sure to


enter an e-mail address if the user will participate in Version Cue PDF reviews and will receive invitation e-mails.


8 To  define  the user’s project  access, choose the  user’s  project privileges next to each project  name  in  the Privileges 


column. To give the user the same privileges for every project, choose an option from the Set All To menu.


9 To let a user publish a project to a specified FTP or WebDAV server, select the check box in the Publishing


Privilege column next to the project name.


10 Click Save.
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To edit a Version Cue user name 
To edit a user’s privileges, you need system administrator privileges. 

1 Log into the Version Cue Workspace Administration page. 

2 Do one of the following: 

• Click Edit Users in the Home page.


• Click the Users tab.


3 Click the user name of the user name you want to edit.


4 Edit the user properties and privileges.


5 Click Save.


To duplicate or delete a Version Cue user name 
You can duplicate a Version Cue user to set up a new user with the same project privileges as the original user.


Complete this procedure, and then change the duplicate user name and login as required.


1 Log into the Version Cue Workspace Administration page.


2 Click the Users tab.


3 Select the check box next to each user name you want to duplicate or delete. To select all listed user names, select


the check box next to the User Name column label.


4 Do one of the following:


• Click Duplicate. Edit the user’s properties in the Duplicate User content frame and click Save. 

• Click Delete. To confirm the deletion, click Delete in the Delete User content frame. 

Choosing user privileges 
Version Cue user logins are associated with one of three levels of privilege: None, User, or System Administrator. 

Users with privileges set to None can’t access the Version Cue Workspace Administration utility but can access 

Version Cue projects while working in an Adobe Creative Suite component or an application that supports WebDAV. 

The following table describes the privileges associated with the User and System Administrator levels. 

Administration utility task User System 
Administra
tor 

Create and update Version Cue 
user login IDs 

No Yes 

Read other Version Cue users’ 
login information 

Yes Yes 

Update own user login informa
tion excluding login ID privilege 
level 

Yes Yes 

Duplicate and delete user IDs No Yes 

Import and export user lists No Yes 
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Administration utility task User System 
Administra
tor 

Create new projects (users must 
have Project Creation Allowed 
selected in their privileges) 

Yes Yes 

Delete or restore project backups No Yes 

Perform all tasks listed in the 
Advanced content frame 

No Yes 

Change the Administration utility 
color scheme in the Advanced 
preferences 

Yes Yes 

Reset locks and remove file ver
sions from projects to which the 
user is assigned and also granted 
Administer privileges 

Yes Yes 

Back up, delete, and restore all 
Version Cue Workspace data 

No Yes 

View Version Cue Workspace 
information, logs, and reports; 
and save reports 

Yes Yes 

Delete reports for projects to 
which the user is assigned and 
also granted Administer privi
leges. 

Yes Yes 

To export a list of users 
If you want to add a set of users to another computer with a Version Cue Workspace, you can export the list and then


copy it to the UsersExport folder in the Version Cue application folder of another computer with a Version Cue


Workspace.


1 Log into the Version Cue Administration utility.


2 Click the Users tab.


3 Select the check box next to each user name you want to export. To select all listed user names, select the check


box next to the User Name column label.


4 Click Export List. The Export Users content frame displays the list of users to be exported.


5 Click Next, and type a name for the list in the Name box. If you like, type remarks in the Comments box.


6 Click Save. The Export Users content frame displays the list of exported users.


7 The location of the user list appears under the Export Users heading. To import this list into another Version Cue


Workspace, copy this file into the destined workspace’s Data/UsersExport folder in the Version Cue application


folder. Note that this folder can be moved and may be in a different location on the workspace.


To import users from a list

1 Log into the Version Cue Administration utility.


2 Click the Users tab, and then click Import List.
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3	 Click the name of the user list you want to import.


4 Select the check box next to each user name you want to import, or select the check box next to the User Name


column label to select all listed user names.


5 Click Next.


Viewing logs, reports, and workspace information 

Viewing Version Cue Workspace information and reports 
You can display the Version Cue Workspace version, name, licensee, serial number, Java version, database version, 

Version Cue client URL (IP or DNS address), WebDAV client URL, copyright, and patent information with the 

Version Cue Workspace Administration utility. 

Users who are working in Adobe Creative Suite can use the Version Cue Client URL to connect to Version Cue 

projects when they’re not on the workspace’s subnetwork. Users who are working in applications that support 

WebDAV can use the WebDAV Client URL to connect to Version Cue projects. 

You can also display and manage three kinds of reports (import, export, and publish) and the Version Cue Workspace 

log file, which tracks all server operations according to the level of detail you specify. 

Display time varies according to the size of the log file. The default log file size is 1024K. If the log file exceeds a 

specified size limit, the system creates a new log file and saves the old one. Log files are saved in the Logs folder, 

located in the Version Cue application folder. 

To view Version Cue Workspace information 
1 Log into the Version Cue Administration utility. 

2 Do any of the following: 

•	 Click the Home tab. Workspace information is listed under About This Workspace. 

•	 Click the Advanced tab, and then select Workspace Info. 

•	 Click About at the top of the page to display copyright and patent information. A window opens, listing infor

mation about the Version Cue Workspace. 

To view the Version Cue Workspace log file

1 Log into the Version Cue Administration utility.


2 Click the Advanced tab, and then select Workspace Log. The Workspace Log content frame displays information


about the Version Cue Workspace history.


3 Do any of the following:


•	 To change the number of rows displayed, choose an option from the Rows To Display menu. 

•	 To navigate to a different page of the log, click Next, End, Beginning, or Previous, if available. 

To view a Version Cue report

1 Log into the Version Cue Administration utility.


2 Click the Advanced tab, and then select Reports.
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3 Choose the type of report you want to view from the Reports menu.


4 To  view  available reports  from a single project, choose the  project name from the  Filter  By  menu. To view available 


reports from all projects on the Version Cue Workspace, choose All.


5 Click the  project’s name in the  Project Name column.  The content  frame displays the  report. Choose options  from 


the available menus to change how the report appears.


6 To save an HTML copy of the report to your computer, click Save, and specify a location.


7 To return to the report list, click Report List.


To delete Version Cue reports

1 Log into the Version Cue Administration utility.


2 Click the Advanced tab, and then select Reports.


3 Choose the type of report you want to delete from the Reports menu:


• To delete all reports from a single project, choose the project name from the Filter By menu.


• To delete all reports from two or more projects on the Version Cue Workspace, choose All.


4 Select the check box next to each project whose reports you want to delete. To select all project reports, select the


check box next to the Project Name column label.


5 Click Delete.


Version Cue PDF reviews 

About Version Cue PDF reviews 
Using Version Cue you can set up and conduct web-based reviews of PDF documents that are in a Version Cue 

Workspace. You can invite selected reviewers by e-mail, create the e-mail message in your e-mail program, and 

include a direct link to the review document in the e-mail. Invited reviewers only need Adobe Acrobat software and 

a Version Cue login to access the PDF document using their web browser. As the review progresses, reviewers upload 

their comments to the Version Cue Workspace. In an open review, all reviewers can see each other’s comments in the 

PDF document as the review progresses. 

You can specify when the review ends or stop a review at any time. When a review is complete, you can view all 

comments either in the context of the original document or as a list in the Version Cue Administration utility. When 

you view the comments in the context of the PDF document, all of the Acrobat commenting tools are available, 

including printing. 

Version Cue PDF reviews are especially useful in the late stages of a project when there isn’t time to arrange a tradi

tional paper-based review. They are also useful when reviewers are dispersed over a wide geographical area. Aggre

gated comments make it easy to summarize comments and track the progress of the review. 

Initiating a Version Cue PDF review 
You use the Version Cue Administration utility to initiate and manage a Version Cue PDF review. From the Version 

Cue PDF review area in the utility, you can start reviews and invite reviewers, find reviews in which you’re partici

pating, search for review documents, view review comments (as well as filter the comments by reviewer), stop 

reviews, and delete finished reviews. You can also reopen completed reviews. 
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Keep in mind the following requirements for using Version Cue PDF review: 

•	 To use Version Cue PDF review, reviewers need a Version Cue login name and privileges that allow them to log 

into the Version Cue Workspace hosting the review. 

•	 To view the PDF and add comments, users need Acrobat 7.0 Professional. For more information about 

commenting in Acrobat, see Acrobat Help. 

•	 To access a review, users need an Internet connection. 

To start a new Version Cue PDF review 
You can start a Version Cue PDF review for any version of any PDF document that is in a Version Cue Workspace, 

provided that you  have  appropriate privileges to access the  Version Cue  Administration  utility.  Only  one version  of  

a PDF document may be in active review at any point in time. 

At any time, to return to the main Version Cue CS2 Review page, click the Home button . To return to Version 

Cue Administration, click Version Cue CS2 Administration. 

1 Log into the Version Cue Administration utility. (For instructions, see “To log into Version Cue Administration 

from the Version Cue Preferences dialog box” on page 157 and “To log into Version Cue Administration from a web 

browser” on page 157.) 

2	 Click the Version Cue CS2 Review link at the top of the page. 

3	 Do one of the following: 

•	 In the main Version Cue CS2 Review page, click Start A Review. 

• Click the Documents tab, and choose Not Started from the Review Status menu.


4 In the Document List, click the name of the PDF document you want to review.


5 Choose the version you want to review, and then click Start Review.


6 In the Start Review page, enter review information:


•	 To set an end date for the review, select Deadline, and then choose the end date from the Year, Month, and Day 

menus. 

•	 To let reviewers see each other’s comments, select Open under Review Mode. Select Private if you want reviewers 

to see only their own comments. 

•	 If you want to add a description of the review, type the information in the Description box. 

•	 To add reviewers, select the reviewers’ names in the Reviewers section (click the check box next to the Reviewers 

column label to select or deselect all reviewers). 

Note: If a reviewer is outside your everyday workgroup and doesn’t have a Version Cue login, you’ll need to set one up 

in advance. You must also provide network access—typically through a firewall—for outside reviewers. 

7	 Click Next. 

8 To send an e-mail invitation to reviewers, select Send E-Mail Invitation, and then modify the Mail Subject and 

Mail Message as desired. In the E-Mail Recipients section, choose reviewers you wish to invite by e-mail. 

9	 Click Start Review to activate the review. 

10 If you chose to invite reviewers by e-mail, Version Cue starts your e-mail program and displays an e-mail message 

addressed to the reviewers. The e-mail includes a direct link to the document being reviewed. Confirm the contents 

of the review e-mail, and send it. 
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To locate PDF reviews 
After you locate a PDF review, you can open it, view or delete review comments, stop or restart a review, or delete


the review from the Version Cue Workspace.


1 Log into the Version Cue Administration utility.


2 Click the Version Cue CS2 Review link at the top of the page.


3 Do one of the following:


•	 If you don’t know the name of the PDF document under review, or want to view all active reviews, click Active 

Reviews in the Home tab. Alternatively, click the Documents tab and choose Active from the Review Status menu. 

•	 If you don’t know the name of the PDF document for which a review has been completed, or want to view all 

completed reviews, click Finished Reviews in the Home tab. Alternatively, click the Documents tab and choose 

Finished from the Review Status menu. 

•	 If you want to search for a PDF document that is under review or for which a review has been completed, click 

Search Documents in the Home tab, and choose search criteria from the Project Name, Review Status, and List 

Entries menus. To find a PDF document by its name, enter the name or part of it in the Document Name field. 

Click Search. 

To set viewing options in the Document List 
You can filter the Document List in the Documents tab by doing one or more of the following: 

•	 To display only PDF documents in a specific project, choose that project from the Project menu. 

•	 To limit the number of documents displayed, choose an option from the List Entries menu (use the arrows to the 

right of the List Entries menu to view additional files). 

•	 To limit the list according to document name, enter part of a document name in the Document Name field and 

press Enter (Windows) or Return (Mac OS). (To view all files again, delete the text in the Document Name field 

and press Enter or Return.) 

•	 To sort the list by the entries in a column, click the column heading. (Click the heading again to reverse the sort 

order.) 

To open an active or completed PDF review

1 Locate the active or completed review (see “To locate PDF reviews” on page 174).


2 Click the PDF document name in the Document List, and then select any of the versions in the Document History


list.


To stop a PDF review

1 Locate the active review (see “To locate PDF reviews” on page 174).


2 Click the PDF document name in the Document List.


3 In the Document History list, select the active review and click Stop Review.
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To restart a completed PDF review

1 Locate the completed review (see “To locate PDF reviews” on page 174).


2 Click the PDF document name in the Document List.


3 In  the Document History  list, select the  completed review and  click Start  Review. Adjust review settings as desired. 


Note: After you click Start Review, you see a series of screens that refer to starting, rather than restarting, a review. 

However, this procedure does restart the review of the existing document. 

See also 

“To start a new Version Cue PDF review” on page 173 

To delete a PDF review 
When you delete a review, Version Cue permanently removes the review comments. However, review comments for


a PDF file are also deleted if you permanently delete the file itself from the Version Cue Workspace. Note that if you


delete only a version of a PDF file from the workspace, the review comments for that version are deleted.


1 Locate the active or completed review (see “To locate PDF reviews” on page 174).


2 Click the PDF document name in the Document List.


3 In the Document History list, select a version and click Delete Review.


4 When Version Cue prompts you to delete the review, click Delete.


See also 

“Deleting files and folders” on page 139


To edit review settings

1 Locate the active or completed review (see “To locate PDF reviews” on page 174).


2 Click the PDF document name in the Document List.


3 Select one of the versions in the Document History list, and click Edit Review Settings.


4 Do any of the following:


•	 To  set or change  an  end date for  the review,  select  Deadline,  and then choose the  end date from the  Year, Month,  

and Day menus. 

•	 To let reviewers see each other’s comments, select Open under Review Mode. Select Private if you want reviewers 

to see only their own comments. 

•	 If you want to add or edit a description of the review, type the information in the Description box. 

•	 To add or remove reviewers, select or deselect the reviewers’ names in the Reviewers section (click the check box 

next to the Reviewers column heading to select or deselect all reviewers). 

5	 Click Next. 

6 To send an e-mail invitation to reviewers, select Send E-Mail Invitation, and then modify Mail Subject and Mail 

Message as desired. In the E-Mail Recipients section, choose reviewers you wish to invite by e-mail 

7 Click Save Review. If you chose to invite reviewers by e-mail, Version Cue starts your e-mail program and displays 

an e-mail message addressed to the reviewers. This e-mail includes a direct link to the document being reviewed. 

Confirm the contents of the review e-mail, and send it. 
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About PDF review comments 
Review comments include, in addition to the text of the comment itself, information about who created the comment


and when, what type of comment was created, and what page of the document the comment appears on. Different


comment types are distinguished by their icons. You can use any of the Acrobat commenting tools in a Version Cue


PDF review.


Version Cue stores review comments in the Version Cue Workspace. You can view comments in the Version Cue


Administration utility or directly in the PDF document. To view all review comments directly in the document, you


must access the document either by using the link from the review invitation or by opening the review document


from the Version Cue Administration utility. (If you open the review document from the Open dialog box in Acrobat


or from Bridge, the review comments aren’t visible.)


For more information about Acrobat commenting tools, search for “commenting” in Acrobat Help.


To view or delete PDF review comments

1 Locate the review (see “To locate PDF reviews” on page 174).


2 Click the PDF document in the Document List.


3 Do one of the following:


•	 To view all review comments directly in the PDF document, click the version name. 

•	 To view review comments in the Version Cue Administration utility, select the version in the Document History 

list and click View Comments. 

To view any of the comments in the context of the PDF document, select a comment and then click Open In Acrobat. 

•	 To delete review comments in the Version Cue Administration utility, select the comment and click Delete 

Comments. (To select all comments, click the check box next to the Page column heading.) 
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Chapter 7: Getting images into Photoshop 
and ImageReady 

Bitmap images and vector graphics 

Bitmap images and vector graphics 
Computer graphics fall into two main categories—bitmap and vector. You can work with both types of graphics in 

Photoshop and ImageReady; moreover, a Photoshop file can contain both bitmap and vector data. It’s helpful to 

understand the difference between the two categories as you create, edit, and import artwork. 

See also 

“Bitmap images” on page 177 

“Vector graphics” on page 177 

Bitmap images 
Bitmap images—technically called raster images—are made up of a grid of dots known as pixels. When working with 

bitmap images, you edit pixels rather than objects or shapes. Bitmap images are the most common electronic 

medium for continuous-tone images, such as photographs or digital paintings, because they can represent subtle 

gradations of shades and color. 

Bitmap images can lose detail when scaled on-screen because they are resolution-dependent, they contain a fixed 

number of pixels, and each pixel is assigned a specific location and color value. Bitmapped images can look jagged if 

they’re printed at too low a resolution because the size of each pixel is increased. 

24:1 

3:1 

Example of a bitmap image at different levels of magnification 

Vector graphics 
Vector graphics are made up of mathematically defined lines and curves called vectors. You can move, resize, or 

change the color of a line without losing the quality of the graphic. 

Vector graphics are resolution-independent—that is, they can be scaled to any size and printed at any resolution 

without losing detail or clarity. As a result, vector graphics are the best choice for representing bold graphics that must 

retain crisp lines when scaled to various sizes (logos, for example). 
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24:1 

3:1 

Example of a vector graphic at different levels of magnification 

Note: Because computer monitors can display images only on a grid, both vector graphics and bitmap images are 

displayed as pixels on-screen. 

Image size and resolution 

Pixel dimensions and image resolution 
The number of pixels along the height and width of a bitmap image is called the pixel dimensions of an image. The 

number of pixels per inch (ppi) printed on a page determines the image resolution. 

The amount of detail in an image depends on its pixel dimensions, whereas the image resolution controls how much 

space the pixels are printed over. For example, you can modify the resolution of an image without changing the actual 

pixel data in the image—all you change is the printed size of the image. However, if you want to maintain the same 

output dimensions, changing the resolution of the image requires a change in the total number of pixels. 
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A 

B C 

Pixel dimensions equal document (output) size times resolution. 
A. Original dimensions and resolution B. Decreasing the resolution without changing pixel dimensions (no resampling) C. Decreasing the 
resolution at same document size decreases pixel dimensions (resampling). 

In  Photoshop,  you can  change  the resolution of an image. In ImageReady,  the resolution of images is always 72 ppi,  

to optimize the images for online media. 

Example of an image at 72 ppi and 300 ppi 

When  printed,  an  image with a high  resolution  contains  more, and  therefore smaller, pixels than an image  with  a low  

resolution. Higher-resolution images can reproduce greater detail and subtler color transitions than lower-resolution 

images because of the density of the pixels in the images. High-quality images often look good at any print size. 
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You can’t improve a lower-quality image by printing it at a high resolution. Changing the print resolution of an image 

simply makes each pixel larger, which results in pixelation—output with large, coarse-looking pixels. Increasing the 

print resolution of an image doesn’t add any pixel information to the image. You can make a low-resolution image 

look its best by picking a print size that makes the most of the pixels it has. 

Important: Video files are displayed only at 72 ppi. Even if an image has a higher resolution than 72 ppi, the quality may 

not be very good when it’s displayed in a video-editing application. 

A B C 

Printing the same low-resolution image at different sizes 
A. Small print size B. Medium print size C. Large print size 

File size 
The file size of an image is the digital size of the image file, measured in kilobytes (K), megabytes (MB), or gigabytes 

(GB). File size is proportional to the pixel dimensions of the image. Images with more pixels may produce more detail 

at  a given  printed size,  but they require more disk space  to  store and  may be slower to edit and  print.  Image resolution  

thus becomes a compromise between image quality (capturing all the data you need) and file size. 

Another factor that affects file size is file format. Because of the varying compression methods used by GIF, JPEG, 

and PNG file formats, file sizes can vary considerably for the same pixel dimensions. Similarly, color bit-depth and 

the number of layers and channels in an image affect file size. 

Photoshop supports a maximum pixel dimension of 300,000 by 300,000 pixels per image. This restriction places 

limits on the print size and resolution available to an image. 

Monitor resolution 
Image data is translated directly into monitor pixels. This means that when the image resolution is higher than the 

monitor resolution, the image appears larger on-screen than its specified print dimensions. 

Monitor resolution depends on the size of the monitor plus its pixel setting. For example, a large image (800-by-600-

pixel dimension) shown on a 15-inch monitor would almost fill the screen, but on a larger monitor, the same image 

would take up less room on the screen, and each pixel would appear larger. 
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20" 

15" 

832 x 624 / 640 x 480 1024 x 768 / 640 x 480 

Example of an image displayed on monitors of various sizes and resolutions 

Note: When you are preparing an image for online display, pixel dimensions become especially important. Make sure 

that the size of an image allows room for the web browser window controls on smaller monitors. 

Printer resolution 
Printer resolution is measured by the number of ink dots per inch (dpi) produced by all laser printers, including 

imagesetters. 

Inkjet printers produce a microscopic spray of ink, not actual dots; however, most inkjet printers have an approx

imate resolution of 240 to 720 dpi. Many inkjet printer drivers offer simplified print settings for choosing higher 

quality printing. To determine your printer’s optimal resolution, check your printer documentation. 

See also 

“About desktop printing” on page 710 

“Preparing images for press” on page 718 

Screen frequency 
Screen frequency is the number of printer dots or halftone cells per inch used to print grayscale images or color 

separations. Also known as screen ruling or line screen, screen frequency is measured in lines per inch (lpi)—or lines 

of cells per inch in a halftone screen. The higher the resolution of the output device, the finer (higher) a screen ruling 

you can use. 

The relationship between image resolution and screen frequency determines the quality of detail in the printed 

image. To produce a halftone image of the highest quality, you generally use an image resolution that is from 1.5 to 

at most 2 times the screen frequency. But with some images and output devices, a lower resolution can produce good 

results. To determine your printer’s screen frequency, check your printer documentation or consult your service 

provider. 

Note: Some imagesetters and 600-dpi laser printers use screening technologies other than halftoning. If you are printing 

an image on a nonhalftone printer, consult your service provider or your printer documentation for the recommended 

image resolutions. 
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Screen frequency examples
A. 65 lpi: Coarse screen typically used to print newsletters and grocery coupons B. 85 lpi: Average screen typically used to print
newspapers C. 133 lpi: High-quality screen typically used to print four-color magazines D. 177 lpi: Very fine screen typically used for an-
nual reports and images in art books

Changing image size and resolution

Adjusting image size and resolution
After you have scanned or imported an image, you may want to adjust its size. In Photoshop, you use the Image Size

dialog box to adjust the pixel dimensions, print dimensions, and resolution of an image; in ImageReady, you can

adjust only the pixel dimensions of an image.

For assistance with resizing and resampling images in Photoshop, choose Help > Resize Image. This interactive

wizard helps you scale your images for print or online media.

Remember, bitmap and vector data can produce different results when you resize an image. Bitmap data is

resolution-dependent; therefore, changing the pixel dimensions of a bitmap image can degrade image quality and

sharpness. In contrast, vector data is resolution-independent; you can resize it without losing its crisp edges.

To display the current image size
You can display information about the current image size using the information box at the bottom of the application

window (Windows) or the document window (Mac OS).

❖ Do one of the following:

• (Photoshop) Press Alt (Windows) or Option (Mac OS), position the pointer over the file information box, and

hold down the mouse button. The box displays the width and height of the image (both in pixels and in the unit

of measurement currently selected for the rulers), the number of channels, and the image resolution.

• (ImageReady) Click an image information box, and select Image Dimensions from the pop-up menu. The box

displays the width and height of the image, in pixels.

Resampling
Resampling refers to changing the pixel dimensions (and therefore display size) of an image. When you downsample

(decrease the number of pixels), information is deleted from the image. When you resample up (increase the number

of pixels, or upsample), new pixels are added. You specify an interpolation method to determine how pixels are added

or deleted.

A B

C D

 



183 ADOBE PHOTOSHOP CS2 
User Guide 

A 

B 

C 

Resampling pixels 
A. Downsampled B. Original C. Resampled up (selected pixels displayed for each set of images) 

Keep in mind that resampling can result in poorer image quality. For example, when you resample an image to larger 

pixel dimensions, the image loses some detail and sharpness. Applying the Unsharp Mask filter to a resampled image 

can help refocus the image details. 

You can avoid the need for resampling by scanning or creating the image at a sufficiently high resolution. If you want 

to preview the effects of changing pixel dimensions on-screen or to print proofs at different resolutions, resample a 

duplicate of your file. 

See also 

“Sharpening images” on page 354 

Choosing an interpolation method 
When an image is resampled, an interpolation method is  used  to  assign  color values to any  new pixels that Photoshop  

creates, based on the color values of existing pixels in the image. Photoshop and ImageReady use sophisticated 

methods to preserve the quality and detail from the original image when you resample. 

In the General Preferences dialog box, you can specify which default interpolation method to use whenever you 

resample images using the Image Size or transformation commands. The Image Size command also lets you specify 

an interpolation method other than the default. 
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To specify the default interpolation method 
1 Do one of the following: 

• In Windows, choose Edit > Preferences > General. 

• (Photoshop) In Mac OS choose Photoshop > Preferences > General. 

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General. 

2 For Interpolation, choose one of the following options: 

Nearest Neighbor A fast but less precise method that replicates the pixels in an image. This method is for use with 

illustrations containing edges that are not anti-aliased, to preserve hard edges and produce a smaller file. However, 

this method can produce jagged effects, which become apparent when you distort or scale an image or perform 

multiple manipulations on a selection. 

Bilinear A method that adds pixels by averaging the color values of surrounding pixels. It produces medium-quality 

results. 

Bicubic A slower but more precise method based on an examination of the values of surrounding pixels. Using more 

complex calculations, Bicubic produces smoother tonal gradations than Nearest Neighbor or Bilinear. 

Bicubic Smoother A good method for enlarging images based on Bicubic interpolation but designed to produce 

smoother results. 

Bicubic Sharper A good method for reducing the size of an image based on Bicubic interpolation with enhanced 

sharpening. This method maintains  the detail in a resampled image. If Bicubic  Sharper oversharpens some areas  of  

an image, try using Bicubic. 

To change the pixel dimensions of an image in Photoshop 
When preparing images for online distribution, it’s useful to specify image size in terms of pixel dimensions. 

Changing pixel dimensions affects not only the size of an image on-screen but also its image quality and its printed 

characteristics—either its printed dimensions or its image resolution. 

1 Choose Image > Image Size. 

2 To maintain the current ratio of pixel width to pixel height, select Constrain Proportions. This option automati


cally updates the width as you change the height, and vice versa.


3 Under Pixel Dimensions, enter values for Width and Height. To enter values as percentages of the current dimen


sions, choose Percent as the unit of measurement. The new file size for the image appears at the top of the Image Size


dialog box, with the old file size in parentheses.


4 Make sure that Resample Image is selected, and choose an interpolation method.


5 If your image has layers with styles applied to them, select Scale Styles to scale the effects in the resized image. This


option is available only if you selected Constrain Proportions.


6 When you finish setting options, click OK.


For best results when you produce a smaller image, downsample and apply the Unsharp Mask filter. To produce a 

larger image, rescan the image at a higher resolution. 

To change the pixel dimensions of an image in ImageReady

1 Choose Image > Image Size.


2 To maintain the current ratio of pixel width to pixel height, select Constrain Proportions.
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3 Under New Size, enter values for Width, Height, or Percent. The New Size text field displays the new file size of 

the image. 

4	 (Optional) Select a interpolation method from the Quality pop-up menu. 

Note: Action options are used to record an action with image size options in ImageReady. 

See also 

“To record image size options (ImageReady)” on page 736 

Changing the print dimensions and resolution of an image 
When creating an image for print media, it’s useful to specify image size in terms of the printed dimensions and the 

image resolution. These two measurements, referred to as the document size, determine the total pixel count and 

therefore the file size of the image; document size also determines the base size at which an image is placed into 

another application. You can further manipulate the scale of the printed image using the Print With Preview 

command; however, changes you make using the Print With Preview command affect only the printed image, not 

the document size of the image file. 

If  you turn on resampling for  the image, you  can change  print dimensions and  resolution  independently (and change  

the total number of pixels in the image). If you turn off resampling, you can change either the dimensions or the 

resolution—Photoshop adjusts the other value automatically to preserve the total pixel count. For the highest print 

quality, it’s generally best to change the dimensions and resolution first, without resampling. Then resample only as 

necessary. 

See also 

“Positioning and scaling images” on page 713


“To set Photoshop print options” on page 712


To change the print dimensions and resolution of an image

1 Choose Image > Image Size.


2 Change the print dimensions, image resolution, or both:


•	 To change only the print dimensions or only the resolution and adjust the total number of pixels in the image 

proportionately, make sure that Resample Image is selected. Then choose an interpolation method. 

•	 To change the print dimensions and resolution without changing the total number of pixels in the image, deselect 

Resample Image. 

3 To maintain the current ratio of image width to image height, select Constrain Proportions. This option automat

ically changes the width as you change the height, and vice versa. 

4 Under Document Size, enter new values for the height and width. If desired, choose a new unit of measurement. 

Note that for Width, the Columns option uses the width and gutter sizes specified in the Units & Rulers preferences. 

5	 For Resolution, enter a new value. If desired, choose a new unit of measurement. 

To restore the initial values displayed in the Image Size dialog box, hold down Alt (Windows) or Option (Mac OS), 

and click Reset. 
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See also 

“To specify columns for an image” on page 59 

To view the print size on-screen 
❖ Do one of the following: 

• Choose View > Print Size. 

• Select the Hand tool or Zoom tool, and click Print Size in the options bar. 

The image is redisplayed in its approximate printed size, as specified in the Document Size area of the Image Size 

dialog box. The size and resolution of your monitor affect the on-screen print size. 

To determine a suggested resolution for an image 
If you plan to print your image using a halftone screen, the range of suitable image resolutions depends on the screen 

frequency of your output device. Photoshop can determine a recommended image resolution based on the screen 

frequency of your output device. 

Note: If your image resolution is more than 2.5 times the screen ruling, an alert message appears when you try to print 

the image. This means that the image resolution is higher than necessary for the printer. Save a copy of the file, and then 

reduce the resolution. 

1 Choose Image > Image Size.


2 Click Auto.


3 For Screen, enter the screen frequency for the output device. If necessary, choose a different unit of measurement.


Note that the screen value is used only to calculate the image resolution, not to set the screen for printing.


Note: To specify the halftone screen ruling for printing, you must use the Halftone Screens dialog box, accessible through 

the Print With Preview command. 

4 For Quality, select an option:


Draft Produces a resolution that is the same as the screen frequency (no lower than 72 pixels per inch).


Good Produces a resolution 1.5 times the screen frequency.


Best Produces a resolution 2 times the screen frequency.


See also 

“Selecting halftone screen attributes” on page 721 

Getting images from digital cameras 

Acquiring digital images from cameras 
You should copy images from a digital camera to your hard drive before editing them in Photoshop or ImageReady. 

If you use a media card reader, or if you connect to a camera that appears as a drive on your computer, you can use 

Adobe Bridge to move the  files to your destination  folder. You  can also use  the software that came with your camera,  

Windows Image Acquisition (WIA) or Image Capture (Mac OS). For more information on using Windows Image 

Acquisition or Image Capture, see your computer documentation. 
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To get images from a digital camera using Bridge 
1 Connect your media card reader or camera to your computer. The media card reader or camera must appear as a 

drive (volume) on your computer for this procedure to work. 

2 Open Bridge. 

3 (Optional) If necessary, click the Folders tab, browse to the location where you want to store your images, and 

create a destination folder. 

You can also click the Favorites tab and drag the destination folder into the Favorites palette. This makes it easier to 

access the folder in the future. 

4 Click the Folders tab and browse to the drive with your images.


5 Select the images. Make sure that the destination folder is visible in either the Favorites palette or the Folders


palettes.


6 Drag the images to the destination folder.


If  your  media card reader or camera appears  as  a volume on your desktop, you  can also drag the  image file from the  

volume into Bridge. 

To import images from a digital camera using WIA 
Certain digital cameras import images using Windows Image Acquisition (WIA) support. When you use WIA, 

Photoshop works with Windows and your digital camera or scanner software to import images directly into 

Photoshop. 

Note: WIA is available only in Windows XP. 

1 Choose File > Import > WIA Support.


2 Choose a destination in which to save your image files on your computer.


3 Make sure that Open Acquired Images in Photoshop is selected. If you are importing a large number of images,


or if you want to edit the images later, deselect Open Acquired Images.


4  To save the imported images directly into a folder whose name is the current date, select Unique Subfolder.


5 Click Start.


6 Select the digital camera from which to import images.


Note: If the name of your camera does not appear in the submenu, verify that the software and drivers were properly 

installed and that the camera is connected. 

7 Choose the image or images you want to import: 

• Click the image from the list of thumbnails to import the image. 

• Hold down Shift and click multiple images to import them at the same time. 

• Click Select All to import all available images. 

8 Click Get Picture to import the image. 
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Scanning images 

About scanning 
Before  you scan an image, make sure to install  the software necessary  for your scanner. To ensure a high-quality  scan,  

predetermine the optimum scanning resolution and dynamic range for your image. These preparatory steps can 

prevent unwanted color casts. 

Scanner drivers  are supported  by  the scanner  manufacturer, not  Adobe Systems  Incorporated. If you  have  problems  

with scanning, make sure that you are using the latest version of the scanner driver. 

When scanning images, try to scan similar images together. For example, it’s better to scan dark images with other 

dark images. The scanned output will be better, and it will be easier to correct your images. 

See also 

“Making color adjustments” on page 281 

Importing scanned images 
You can import scanned images directly from any scanner that has a Photoshop-compatible plug-in module or that 

supports the TWAIN interface. To import the scan using a plug-in module, choose the scanner name from the File > 

Import submenu. See your scanner documentation for instructions on installing the scanner plug-in. 

If your scanner does not have Photoshop-compatible scanner driver, import the scan using the TWAIN interface. 

If you can’t import the scan using the TWAIN interface, use the scanner manufacturer’s software to scan your images, 

and save the images as TIFF, PICT, or BMP files. Then open the files in Photoshop or ImageReady. 

See also 

“About plug-in modules” on page 69 

Importing scanned images using the TWAIN interface 
TWAIN is a cross-platform interface for acquiring images captured by certain scanners, digital cameras, and frame 

grabbers. The manufacturer of the TWAIN device must provide a Source Manager and TWAIN data source for your 

device to work with Photoshop and ImageReady. 

You must install the TWAIN device and its software and restart your computer before you can use it to import images 

into Photoshop and ImageReady. See the documentation provided by your device manufacturer for installation 

information. 

To import an image using the TWAIN interface in Photoshop 
❖ Choose File > Import, and choose the device you want to use from the submenu. 
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To import an image using the TWAIN interface in ImageReady

1 If you’re using the TWAIN device for the first time with ImageReady, choose File > Import > TWAIN Select. Then


select the device you want to use. You do not need to repeat this step for subsequent uses of the TWAIN module.


If more than one TWAIN device is installed on your system and you want to switch devices, use the TWAIN Select


command.


2	 To import the image, choose File > Import > TWAIN Acquire.


To import images from a scanner using WIA Support

1 Choose File > Import > WIA Support.


2 Choose a destination on your computer for saving your image files.


3 Click Start.


4 Make sure that Open Acquired Images in Photoshop is selected. If you have a large number of images to import,


or if you want to edit the images at a later time, deselect it.


5 Make sure that Unique Subfolder is selected if you want to save the imported images directly into a folder whose


name is the current date.


6 Select the scanner that you want to use.


Note: If the name of your scanner does not appear in the submenu, verify that the software and drivers were properly 

installed and that the scanner is connected. 

7 Choose the kind of image you want to scan:


Color Picture Uses the default settings for scanning color images.


Grayscale Picture Uses the default settings for scanning grayscale images. 

Black And White Picture or Text Uses the default settings. 

Adjust The Quality Of The Scanned Picture Uses custom settings. 

8 Click preview to view the scan. If necessary, drag the handles of the bounding box to adjust the size of the crop.


9 Click Scan.


10 The scanned image is saved in BMP format.


To estimate scan resolution 
You can determine the resolution for your scan using the original and final image dimensions and the resolution of 

your  output  device. Scan resolution translates into image  resolution  when  you open the  scanned image  in  Photoshop.  

1	 Do one of the following: 

•	 For laser printers and imagesetters, multiply the printer’s screen frequency by 2. To determine your printer’s screen 

frequency, check your printer documentation or consult your service provider. 

•	 For inkjet printers, check your printer documentation for the optimal resolution. Many dye sublimation printers 

and devices that print directly onto photographic paper have an optimal resolution of 300 to 400 dpi. 

2 Determine the ratio of the final image dimensions to the original image dimensions. For example, the ratio of a 

6-by-9-inch final image to a 2-by-3-inch original image is 3:1. 

3	 Multiply the result of step 1 by the result of step 2. 
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For example, suppose you are printing to an imagesetter with a screen frequency of 85 lpi and the ratio of the final 

image to the original is 3:1. First multiply 85 (the screen frequency) by 2 to get 170. Then multiply 170 by 3 to get a 

scan resolution of 510 ppi. If you are printing to an inkjet printer with an optimal resolution of 300 dpi, multiply 300 

by 3 to get a scan resolution of 900. 

Note: Different color separation procedures might require different ratios of image resolution to screen frequency. It’s a 

good idea to check with your service provider or print shop before you scan the image. 

To calculate the file size before scanning an image 
You can create a dummy file to predict the file size needed for the final output of your scan. 

1 In Photoshop, choose File > New. 

2 Enter the width, height, and resolution of your final printed image. The resolution should be 1.5 to 2 times the 

screen  frequency you  will  use to print. Make sure that the  mode  you plan to scan in is selected.  The New  dialog  box  

displays the file size. 

For example, suppose you want the final image to be 4 inches wide and 5 inches high. You plan to print it with a 

150-line screen using a 2:1 ratio, so you set the resolution to 300. The resulting file size is 5.15 MB. 

To produce the scan, enter the resulting file size in your scanner settings. Don’t worry about resolution or image 

dimensions. After you have scanned the image and imported it into Photoshop, use the Image Size command (with 

the Resample Image option deselected) to enter the correct width and height for the image. 

See also 

“Color modes” on page 227 

Optimizing the dynamic range of the scan 
Keep in mind that the human eye can detect a wider tonal range than can be printed. If your scanner allows, set the 

black and  white points before scanning  a file to produce  the best tonal  range and  capture the  widest  dynamic range.  

Then use Photoshop’s color adjustment tools to set the white and black points for the scanned image. 

See also 

“To adjust tonal range using Levels” on page 285 

To eliminate a color cast introduced by a scanner 
If your scanned image contains an unwanted color cast, you can perform a simple test to determine whether the cast 

was introduced by your scanner. If so, you can use the same test file to create a color-cast correction for all images 

scanned with the scanner. 

1 Make sure that your monitor has been calibrated. 

2 Open a new Photoshop file to create an 11-step wedge. Choose a size from the Preset menu in the New dialog box. 

Make sure the size is large enough for the step wedge to be reasonably scanned. The resolution should be at least 240 

pixels/inch. You can set the Color Mode as RGB and the Background Contents as either Transparent or White. 

3 Use the Linear Gradient tool  to create a blend from pure black to pure white. 

4 Choose Image > Adjustments > Posterize, and posterize the blend using 11 levels. 

5 Print the 11-step gray wedge on a black-and-white printer, and then scan it into Photoshop. 
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Note: You can  also  perform this test using  an  18-percent neutral  gray  card  or  an  11-step  gray  wedge from a photography  

store. 

6 Open the Info palette, and read the RGB values on-screen for each of the gray levels. Uneven R, G, and B values 

indicate a color cast. 

7 Use Levels or Curves to correct the color cast, and then save the dialog box settings. 

8 Open  the scanned  image you  want  to  correct,  reopen  the dialog box  you used to correct  the cast in step 7, and  load  

the saved settings. 

See also 

“To calibrate and profile your monitor” on page 265 

“To use Levels to correct a color cast” on page 286 

Creating, opening, and importing images 

To create a new image 
Use the New command to create a new, blank image. If you’ve copied a selection to the clipboard, the image dimen


sions and resolution are automatically based on that image data.


1 Choose File > New.


2 If desired, type a name for the image, and set the width and height.


(Photoshop) To match the width and height of the new image to that of any open image, choose a file name from the 

bottom section of the Windows menu. 

3 (Photoshop) Set the resolution and mode.


4 Select an option for the contents of the background layer (Photoshop) or first layer (ImageReady) of the image:


White Fills the background or first layer with white, the default background color.


Background Color Fills the background or first layer with the current background color.


Transparent Makes the first layer transparent, with no color values. The resulting document has a single, trans


parent layer as its contents.


5 Under Advanced, choose a color profile, or choose Don’t Color Manage This Document. For Pixel Aspect Ratio,


choose Square unless you’re using the image for video. In that case, choose another option to use non-square pixels.


6 When you finish, you can save the settings as a preset by clicking Save Preset, or you can click OK to open the new


file.


See also 

“Color modes” on page 227 

“Saving images for use in video” on page 704 

“About the foreground and background colors” on page 503 
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Opening files 
You can open files using the Open command and Open Recent command. In Photoshop, you can also open files 

using Adobe Bridge. 

Sometimes Photoshop may not be able to determine the correct format for a file. This can happen, for example, 

because the file has been transferred between two operating systems. Sometimes a transfer between Mac OS and 

Windows can cause the file format to be mislabeled. In such cases, you must specify the correct format in which to 

open the file. 

Note: Photoshop and ImageReady use plug-in modules to open and import many file formats. If a file format does not 

appear in the Open dialog box or in the File > Import submenu, you may need to install the format’s plug-in module. 

See also 

“About plug-in modules” on page 69


To open a file using the Open command

1 Choose File > Open.


2 Select  the name of the  file  you want to open.  If  the file does not  appear, select the  option  for showing  all files  from 


the Files Of Type (Windows) or Show (Mac OS) pop-up menu.


3 (Mac OS) Click Show Preview to preview the selected file. This option requires the Apple QuickTime extension.


Note: Previews appear faster if they are saved with the file. In Photoshop, select Always Save For Image Previews in the 

File Handling preferences to always save a preview; select Ask When Saving to save previews on a file-by-file basis. 

4	 Click Open. In some cases, a dialog box appears, letting you set format-specific options. 

Note: If a color profile warning message appears, specify whether to convert the pixels based on the file’s color profile. 

To open a recently used file 
❖ Choose File > Open Recent, and select a file from the submenu. 

To specify the number of files listed in the Open Recent submenu 
1 Do one of the following: 

•	 (Photoshop) Choose Edit > Preferences > File Handling (Windows), or choose Photoshop > Preferences > File 

Handling (Mac OS). 

•	 (ImageReady) Choose Edit > Preferences > General (Windows), or choose ImageReady > Preferences > General 

(Mac OS). 

2	 Do one of the following: 

•	 (Photoshop) Enter a number in the Recent File List Contains text box. 

•	 (ImageReady) Enter a number in the Recent Files text box. 
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To specify the file format in which to open a file 
❖ Do one of the following: 

•	 (Windows) Choose File > Open As, and select the file you want to open. Then choose the desired format from the 

Open As pop-up menu, and click Open. 

•	 (Mac OS) Choose File > Open, and choose All Documents from the Show pop-up menu. Then select the file you 

want to open, choose the desired file format from the Format pop-up menu, and click Open. 

Note: If the file does not open, then the chosen format may not match the file’s true format, or the file may be damaged. 

Opening PDF files 
Portable Document Format (PDF) is a versatile file format that can represent both vector and bitmap data. It has 

electronic document search and navigation features. PDF is the primary format for Adobe Illustrator and Adobe 

Acrobat. 

Some  PDF files  contain a single  image,  and others contain  multiple  pages and  images. When you  open  a PDF  file  in  

Photoshop, you can choose which pages or images to open and specify rasterization options. The pages or images are 

imported as Smart Objects in new documents. 

In Photoshop, you can also import PDF data using the Place command, the Paste command, and the drag-and-drop 

feature. The page or image is placed on a separate layer as a Smart Object. 

Note: You can’t bring PDF data into ImageReady. 

See also 

“PDF” on page 682 

“Smart Objects” on page 427 

“Placing files” on page 196 

“Using drag-and-drop to copy between applications” on page 332 

“Using the clipboard to copy between applications” on page 333 

To open a PDF file 
After you open a PDF document, you can import pages or images from it into new documents in Photoshop. You 

can also import pages or images from a PDF document using the Place command. 

1	 Do one of the following: 

•	 (Photoshop) Choose File > Open. 

•	 (Bridge) Select the PDF file and choose File > Open With > Adobe Photoshop CS2. Skip to step 3. 

2 In  the Open dialog box, select the  name  of  the file,  and click  Open. You  can change  which types  of  files are  listed  

by selecting an option from the Files Of Type (Windows) or Format (Mac OS) pop-up menu. 

3 In the Import PDF dialog box, choose Page or Image from the Select menu, depending on what elements of the 

PDF document you want to import. 

4 Select the pages or images you want to open by clicking the thumbnails. Shift-click to select more than one page 

or image. The number of selected items appears under the preview window. 
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Note: Use the Thumbnail Size menu to adjust the thumbnail view in the preview window. The Fit Page option fits one 

thumbnail in the preview window. A scroll bar appears if there are multiple items. 

5 To  give  the new  document  a name,  type  it  in  the Name text box. If you’re importing  more  than  one page or image,  

multiple documents open with the base name followed by a number. 

6 Under Page Options, choose from the Crop To menu to specify what part of the PDF document to include:


Bounding Box Crops to the smallest rectangular region that includes all the text and graphics of the page. This


option eliminates extraneous white space.


Media Box Crops to the original size of the page.


Crop Box Crops to the clipping region (crop margins) of the PDF file.


Bleed Box Crops to the region specified in the PDF file for accommodating limitations inherent in production


processes such as cutting, folding, and trimming.


Trim Box Crops to the region specified for the intended finished size of the page.


Art Box Crops to the region specified in the PDF file for placing the PDF data into another application.


7 Specify the following under Page Options:


Resolution Sets the resolution for the new document. See also “Pixel dimensions and image resolution” on page 178.


Mode Sets the color mode for the new document. See also “Color modes” on page 227.


Bit Depth Sets the bit depth for the new document. See also “About bit depth” on page 231.


Anti-aliased Minimizes jagged lines at the edges of an image. Deselect this option if you want a hard-edged


transition between pixels.


Transparent Background Reveals text or graphics beneath the PDF page. Deselect this option to place the PDF


page on a white background.


8 To suppress color profile warnings, select Suppress Warning.


9 Click OK.


See also 

“To place a file in Photoshop” on page 197 

Opening PostScript artwork 
Encapsulated PostScript (EPS) can represent both vector and bitmap data and is supported by virtually all graphic, 

illustration, and page-layout programs. Adobe applications that produce PostScript artwork include Adobe Illus

trator, Adobe Dimensions, and Adobe Streamline. When you open an EPS file containing vector art, it is rasterized— 

the mathematically defined lines and curves of the vector artwork are converted into the pixels or bits of a bitmap 

image. 

You can also bring PostScript artwork into Photoshop or ImageReady using the Place command, the Paste command, 

and the drag-and-drop feature. 
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See also 

“Placing files” on page 196 

“Using drag-and-drop to copy between applications” on page 332 

“Using the clipboard to copy between applications” on page 333 

To open an EPS file

1 Choose File > Open.


2 Select the file you want to open, and click Open.


3 Indicate the desired dimensions, resolution, and mode. To maintain the same height-to-width ratio, select


Constrain Proportions.


4 To minimize jagged lines at the edges of artwork, select Anti-aliased.


To turn off the Anti-alias PostScript option (ImageReady) 
The Anti-alias PostScript option removes jagged edges from a pasted or placed selection by making a subtle 

transition between the edges of the selection and its surrounding pixels. Deselecting this option decreases import 

time and results in a hard-edged, jagged transition between pixels when vector artwork is rasterized. 

Note: In Photoshop, you can deselect the Anti-alias option when you open or place a PDF or EPS file. 

1 Do one of the following: 

• (Windows) Choose Edit > Preferences > General. 

• (Mac OS) Choose ImageReady > Preferences > General. 

2 Deselect Anti-alias PostScript. 

To open a Photo CD file 
You can open Kodak Photo CD (PCD) files, including high-resolution files from Pro Photo CD discs. 

Note: You cannot save files in PCD format from Photoshop or ImageReady. 

1 Choose File > Open.


2 Select the PCD file you want to open, and click Open. If the file does not appear, select the option for showing all


files from the Files Of Type (Windows) or Show (Mac OS) menu.


3 Select options for the source image:


Pixel Size Specifies the pixel dimensions of the image. Keep in mind that the on-screen size of the opened image


depends on both the pixel size and resolution you choose.


Profile Specifies a device profile for color management.


4 Select options for the destination image:


Resolution Specifies the resolution of the opened image.


Color Space Specifies a color profile for the opened image.


Landscape or Portrait Specifies the orientation of the opened image. 
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See also 

“Pixel dimensions and image resolution” on page 178 

“To calibrate and profile your monitor” on page 265 

Importing anti-aliased PICT files (Mac OS) 
Choose File > Import > Anti-aliased PICT to import object-oriented PICT files (such as those created with 

MacDraw and Canvas) as smooth-edged, or anti-aliased, images. Because the entire PICT file must be held in 

memory for this module to operate, you may not be able to use the module with large PICT files. 

The Anti-aliased PICT dialog box indicates the current file size and dimensions. To change the image dimensions, 

enter new values for Width and Height. The file size is then updated. To maintain image proportions, select 

Constrain Proportions. 

You can choose Grayscale or RGB color mode for an anti-aliased PICT file. 

Importing PICT resources (Mac OS) 
The PICT Resource module lets you read PICT resources from a file—for example, from another application. To 

open a PICT resource, choose File > Import > PICT Resource. 

To preview a resource, click Preview. Click the arrows to step forward and backward through the resources. Note that 

the number displayed for Resource refers to the resource’s position in ascending order in the resource fork and not 

to the resource’s identification number. 

Note: In Photoshop, you can also open a file in the PICT Resource file format by choosing File > Open, choosing All 

Documents from the Show pop-up menu, selecting the file you want to open, choosing PICT Resource from the Format 

pop-up menu, and clicking Open. However, the Open command automatically opens the first resource in the file and 

does not display any other PICT resources in the file. 

Placing files 

Placing files 
The Place command places artwork as a Smart Object in the Photoshop file. Generally, the art is placed on a new 

layer. In Photoshop, you can place files in any Photoshop-supported format. In ImageReady, you can place files in 

any ImageReady-supported format with the exception of Photoshop (PSD) files containing CMYK images, PDF files, 

and Adobe Illustrator (AI) files. 

When you use the Place command, you can scale, position, skew, or rotate the art without degrading the image before 

clicking Commit , or pressing Enter (Windows) or Return (Mac OS) to place the art. In Photoshop, PDF, Illus

trator (AI), or EPS files are rasterized. After files are rasterized, vector data is no longer editable as paths and any text 

is no longer editable as type. 

You can retain (where possible) layers, masks, transparency, compound shapes, slices, image maps, and editable type 

when bringing your Illustrator art into Photoshop. In Illustrator, export the art in the Photoshop (PSD) file format. 

If your Illustrator art contains elements that Photoshop doesn’t support, the appearance of the artwork is preserved, but 

the layers are merged and the artwork is rasterized. 
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See also 

“Smart Objects” on page 427 

To place a file in Photoshop

1 Open the Photoshop document that is the destination for the placed artwork.


2 Do one of the following:


•	 (Photoshop) Choose File > Place, select the file you want to place, and click Open. 

•	 (Photoshop) Select and copy Illustrator (AI), EPS, or PDF artwork from the source document, and then paste it 

into the destination Photoshop document. You can also select the file and drag it into the Photoshop document. 

Skip to step 4. 

•	 (Bridge) Select the image file and choose File > Place > In Photoshop. Skip to step 4. 

3 In  the Open dialog box, select the  name  of  the file,  and click  Open. You  can change  which types  of  files are  listed  

by selecting an option from the Files Of Type (Windows) or Format (Mac OS) pop-up menu. 

4 If you are placing a PDF or Illustrator (AI) file, the Place PDF dialog box appears. Select the pages or images you 

want to place, set the Crop options, and click OK. See also “To set Place PDF dialog box options” on page 199 

The placed artwork  appears inside  a bounding box  at  the center of the  Photoshop image. The  artwork maintains  its  

original aspect ratio; however, if the artwork is larger than the Photoshop image, it is resized to fit. 

Note: You can also place Adobe Illustrator art by copying and pasting the art from Illustrator into a Photoshop 

document. See “To paste Adobe Illustrator art into Photoshop” on page 200. 

5	 (Optional) Reposition or transform the placed artwork by doing any of the following: 

•	 To reposition the placed art, position the pointer inside the bounding box of the placed artwork and drag, or in 

the options bar, enter a value for X to specify the distance between the center point of the placed artwork and the 

left edge of the image. Enter a value for Y to specify the distance between the center point of the placed artwork 

and the top edge of the image. 

•	 To scale the placed art, drag one of the corner handles of the bounding box or enter values for W and H in the 

options bar. 

•	 To rotate the placed art, position the pointer outside the bounding box (the pointer turns into a curved arrow) and 

drag, or enter a value (in degrees) for the Rotation option  in the options bar. The artwork rotates around the 

center point of the placed artwork. To adjust the center point, drag it to a new location, or click a handle on the 

Center Point icon  in the options bar. 

•	 To skew the placed art, hold down Ctrl (Windows) or Command (Mac OS) and drag a side handle of the bounding 

box. 

•	 To warp the placed art, choose Edit > Transform > Warp and then choose a warp from the Warp Style pop-up 

menu in the options bar. 

If you choose Custom from the Warp Style pop-up menu, drag the control points, a segment of the bounding box or 

mesh, or an area within the mesh to warp the image. 
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6 If you’re placing a PDF, EPS, or Adobe Illustrator file, set the Anti-alias option in the options bar as desired. To 

blend edge pixels during rasterization, select the Anti-alias option. To produce a hard-edged transition between edge 

pixels during rasterization, deselect the Anti-alias option. 

7	 Do one of the following: 

•	 Click Commit in the options bar or press Enter (Windows) or Return (Mac OS) to commit the placed artwork 

to a new layer. 

•	 Click Cancel  in the options bar, or press Esc to cancel the placement. 

See also 

“To scale, rotate, skew, distort, apply perspective, or warp” on page 361 

“To warp an item” on page 364 

To place a file in ImageReady 
1 Open the ImageReady image into which you want to place the file and choose File > Place. 

Note: In ImageReady, you cannot place a PSD file containing a CMYK image, PDF files, or Illustrator (AI) files. 

2 In the Place dialog box, click Choose, browse to select the file you want to place, and click Open. 

3 Select offset options: 

•	 From the Horizontal pop-up menu, choose an option for placing the file horizontally with respect to the image. 

In the Pixels text box, enter the number of pixels by which to offset the placed image horizontally. 

•	 From the Vertical pop-up menu, choose an option for placing the file vertically with respect to the image. In the 

Pixels text box, enter the number of pixels by which to offset the placed image vertically. 

Note: To enter a negative number (and offset the placed file to the left or below the image), type a hyphen (-) before the 

number. 

4 Click OK.


5 If you are placing an EPS file, specify any of the following in the Rasterize Options dialog box and click OK:


Width and Height Specifies the width and height values for the image size.


Constrain Proportions Maintains the same height-to-width ratio. 

Anti-aliased Minimizes the jagged appearance of the artwork’s edges as it is rasterized. 

6 If you’re placing a QuickTime movie file, select the following from the Open Movie dialog box, and click OK: 

From Beginning To End Imports the entire movie. 

Selected Range Only Imports a selected range of the movie. Hold down the Shift key while moving the slider in the 

Timeline or clicking the arrows. The selected footage is indicated by the darkened area in the Timeline. 

Limit To Every X Frame Specifies which frame of the selected range to import. Choose from the pop-up menu. 
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Holding down the Shift key while moving the slider in the Timeline to select a range of the QuickTime movie 

To set Place PDF dialog box options 
When  you place  a PDF  or  Adobe Illustrator  file, use  the Place  PDF dialog box  to  set options  for placing the  artwork. 


1 With the destination Photoshop document open, place a PDF or Adobe Illustrator file.


2 In  the Place  PDF dialog box, choose Page or Image  from  the Select menu,  depending on what elements of the  PDF 


document you want to import.


Note: Use the Thumbnail Size menu to adjust the thumbnail view in the preview window. The Fit Page option fits one 

thumbnail in the preview window. A scroll bar appears if there are multiple items. 

3 Under Options, choose from the Crop To menu to specify what part of the PDF or Illustrator (AI) document to


include:


Bounding Box Crops to the smallest rectangular region that includes all the text and graphics of the page. This


option eliminates extraneous white space.


Media Box Crops to the original size of the page.


Crop Box Crops to the clipping region (crop margins) of the PDF file.


Bleed Box Crops to the region specified in the PDF file for accommodating limitations inherent in production


processes such as cutting, folding, and trimming.


Trim Box Crops to the region specified for the intended finished size of the page.


Art Box Crops to the region specified in the PDF file for placing the PDF data into another application.


4 Select Transparent Background to reveal text or graphics beneath the PDF page. Deselect this option to place the


PDF page on a white background.


5 Click OK to close the Place PDF dialog box.


6 If necessary, set any positioning, scaling, skewing, rotating, warping, or anti-aliasing options in the options bar.


7 Click Commit
  to place the artwork as Smart Objects on separate layers of the destination document. 

See also 

“To place a file in Photoshop” on page 197 
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Pasting Adobe Illustrator art into Photoshop 
You can copy art from Adobe Illustrator and paste it into a Photoshop document. The copy-and-paste behavior can 

be specified: 

•	 To  automatically rasterize  the art  when  pasting it into a Photoshop document,  turn  off the  PDF and  the AICB (No  

Transparency Support) options in the File Handling & Clipboard preferences of Adobe Illustrator. 

•	 To paste the art as a Smart Object, rasterized image, path, or shape layer, turn on the PDF and the AICB (No Trans

parency Support) options in the File Handling & Clipboard preferences of Adobe Illustrator. 

See also 

“Smart Objects” on page 427 

To paste Adobe Illustrator art into Photoshop 
Note: If you want to paste the Adobe Illustrator art as a Smart Object, path, or shape layer, make sure to turn on the 

PDF and the AICB (No Transparency Support) options in the File Handling & Clipboard preferences of Adobe Illus

trator. 

1	 Open a file in Adobe Illustrator, select the art you want to copy, and choose Edit > Copy. 

2 In Photoshop, open the document that you want to paste the Adobe Illustrator art into and then choose Edit > 

Paste. 

Note: If the PDF and the AICB (No Transparency Support) options are turned off in the File Handling & Clipboard 

preferences of Adobe Illustrator, the art is automatically rasterized as it’s pasted into the Photoshop document. You can 

skip the rest of the steps in this procedure. 

3 In the Paste dialog box, select how you want to paste the Adobe Illustrator art and then click OK: 

Smart Object Pastes the art as a Vector Smart Object that can be scaled, transformed, or moved without degrading 

the image before it’s placed into the Photoshop document. As the art is placed, its file data is embedded in the 

Photoshop document and the art is rasterized on a separate layer. 

Pixels Pastes  the art  as  pixels  that  can be scaled,  transformed,  or  moved before it is rasterized and  placed  on  its own  

layer in the Photoshop document. 

Path Pastes the art as a path that can be edited with the pen tools, Path Selection tool, or Direct Selection tool. The 

path is pasted into the layer that’s selected in the Layers palette. 

Shape Layer Pastes the art as a new shape layer (a layer containing a path filled with the foreground color). 

4	 If you selected Smart Object or Pixels in the Paste dialog box, click Enter or Return to place the art. 

See also 

“Placing files” on page 196 

“Smart Objects” on page 427 

“Path segments, components, and points” on page 460 

“To create a shape on a shape layer” on page 450 
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High Dynamic Range images 

About High Dynamic Range images 
The dynamic range (ratio between dark and bright regions) in the visible world far exceeds the range of human vision 

and of images that are printed or displayed on a monitor. But whereas human eyes can adapt to very different 

brightness levels, most cameras and computer monitors can capture and reproduce only a fixed dynamic range. 

Photographers, motion picture artists, and others working with digital images must be selective about what’s 

important in a scene because they are working with a limited dynamic range. 

High Dynamic Range (HDR) images open up a world of possibilities because they can represent the entire dynamic 

range of the visible world. Because all the luminance values in a real-world scene are represented proportionately and 

stored in an HDR image, adjusting the exposure of an HDR image is like adjusting the exposure when photographing 

a scene in the real world. This capability lets you create blurs and other real-world lighting effects that look realistic. 

Currently, HDR images are used mostly in motion pictures, special effects, 3D work, and some high-end photog

raphy. 

A 

B 

C 

Merging images of different exposures to create an HDR image 
A. Image with shadow detail but highlights clipped B. Image with highlight detail but shadows clipped C.  HDR image containing the dy
namic range of the scene 

In Photoshop, the luminance values of an HDR image are stored using a floating-point numeric representation that’s 

32 bits long (32-bits-per-channel). The luminance values in an HDR image are directly related to the amount of light 

in a scene. This is not so with (non-floating point) 16-bits-per-channel and 8-bits-per-channel image files, which can 

store luminance values only from black to paper white; this represents an extremely small segment of the dynamic 

range in the real world. 
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You can create an HDR image using multiple photographs, each captured at a different exposure. In Photoshop, the 

Merge To HDR command lets you create HDR images from multiple photographs. Because an HDR image contains 

brightness levels that far exceed the display capabilities of a standard 24-bit monitor or the range of tones in a printed 

image, Photoshop lets you adjust the preview of the HDR image so it can be viewed on a computer monitor. Some 

Photoshop tools, adjustments, and filters can be used with HDR images. If you need to print the image or use 

Photoshop tools and filters that don’t work with HDR images, you can convert the HDR image to an 8- or 16-bits-

per-channel image. 

Working with HDR images 
Photoshop lets you use the following tools, adjustments, and filters with 32-bits-per-channel HDR images: 

Adjustments Channel Mixer, Photo Filter, and Exposure. 

Note: Although the Exposure command can be used with 8- and 16-bits-per-channel images, it is designed for making 

exposure adjustments to 32-bits-per-channel HDR images. 

Blend Modes Normal, Darken, Multiply, Lighten, Linear Dodge, and Difference. 

Editing Commands Fill, Stroke, Free Transform, Transform, Image Size, Canvas Size, Rotate Canvas, Crop (with 

rotation and resize), and Trim. 

File Formats Photoshop (PSD, PSB), Radiance (HDR), Portable Bit Map (PFM), OpenEXR, and TIFF. 

Note: Although Photoshop cannot save an HDR image in the LogLuv TIFF file format, it can open and read a LogLuv 

TIFF file. 

Filters Average, Box Blur, Gaussian Blur, Motion Blur, Radial Blur, Shape Blur, Surface Blur, Add Noise, Fibers, Lens 

Flare, Smart Sharpen, Unsharp Mask, De-Interlace, NTSC Colors, High Pass, and Offset. 

Modes RGB Color, Grayscale, conversion to 8 Bits/Channel or 16 Bits/Channel. 

Tools Marquee tools, Move tool, lasso tools, Crop tool, Slice tool, Clone Stamp tool, History Brush tool, Path 

Selection tool, Direct Selection tool, pen tools, annotation tools, Eyedropper tool, Color Sampler tool, Measure tool, 

Hand tool, and Zoom tool. Some tools work with supported blend modes only. 

See also 

“To use the Exposure adjustment” on page 292 

The Merge To HDR command 
Use the  Merge To HDR  command  to  combine multiple images (with  different  exposures)  of  the same image  or  scene,  

capturing the dynamic range of a scene in a single HDR image. You can choose to save the merged image as a 32-bits-

per-channel HDR image. 

Note: It’s also possible to use the Merge To HDR command to save the merged image as an 8- or 16-bits-per-channel 

image. However, only a 32-bits-per-channel image can store all the HDR image data; 8- and 16-bits-per-channel images 

will be clipped. 

Keep the following tips in mind when you take photos to be combined with the Merge To HDR command: 

•	 Secure the camera to a tripod. 

•	 Take enough photos to cover the full dynamic range of the scene. You can try taking at least five to seven photos, 

but you  might need to take more exposures  depending on the  dynamic range  of  the scene. The  minimum number  

of photos should be three. 
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•	 Vary the shutter speed to create different exposures. Changing the aperture changes the depth of field in each 

exposure and can produce lower-quality results. Changing the ISO or aperture may also cause noise or vignetting 

in the image. 

•	 In general, don’t use your camera’s auto-bracket feature, because the exposure changes are usually too small. 

•	 The exposure differences between the photos should be one or two EV (exposure value) steps apart (equivalent to 

about one or two f-stops apart). 

•	 Don’t vary the lighting; for instance, don’t use a flash in one exposure but not the next. 

•	 Make  sure  that  nothing is moving in the  scene.  Exposure  Merge works  only  with  differently  exposed images of the  

identical scene. 

To use the Merge To HDR command 
1 Do one of the following: 

•	 (Photoshop) Choose File > Automate > Merge To HDR.


• (Bridge) Select the images you want to use and choose Tools > Photoshop > Merge To HDR. Skip to step 3.


2 In the Merge To HDR dialog box, click Browse, browse to select the images, and click Open.


To remove an item, select it in the Merge To HDR dialog box and click Remove.


Note: If  you want to add  a folder of images or images that are  open  in  Photoshop,  choose  Folder or Open Files  from  the  

Use menu. 

3 (Optional)  Select  the Attempt  To  Automatically Align Source Images option if you  held  the camera in your hands  

when you photographed the multiple images. 

4	 Click OK. 

A second Merge To HDR dialog box displays thumbnails of the images being used in the merged result, a preview of 

the merged result, a Bit Depth menu, and a slider for setting the white point preview. 

5	 If necessary, do one of the following to set the view options for the merged result preview: 

•	 Click the Minus or Plus buttons below the preview image to zoom out or zoom in. 

•	 Choose a view percentage or mode from the pop-up menu below the preview image. 

6 (Optional) Deselect or select the thumbnails in the Sources filmstrip to specify which images to use in the merged 

image. 
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Selecting the thumbnails in the Sources filmstrip

7 Choose a bit depth for the merged image from the Bit Depth menu.

Note: Be sure to choose 32 Bits/Channel if you want the merged image to store the entire dynamic range data of the HDR

image.

8 Move the slider below the histogram to set the white point for previewing the merged image.

Important: If the merged image is being saved as a 32-bits-per-channel image, moving the slider adjusts the image

preview only. All the HDR image data remains intact in the 32-bits-per-channel HDR image file. The preview

adjustment is stored in the 32-bits-per-channel HDR image file and applied whenever the file is opened in Photoshop. If

you choose to save the merged image as an 8- or 16-bits-per-channel image, moving the slider applies exposure edits to

the image file. Any discarded image data will not be recoverable after the merged 8- or 16-bits-per-channel image is

created.

9 Click OK to create the merged image.

To adjust HDR image viewing
The dynamic range of HDR images exceeds the display capabilities of standard computer monitors. When you open

an HDR image in Photoshop, it can look very dark or washed out. Photoshop lets you adjust the preview so that the

monitor displays an HDR image whose highlights and shadows aren’t washed out or too dark. The preview settings

are stored in the HDR image file and are applied whenever the file is opened in Photoshop. Preview adjustments don’t

affect the HDR image file, all the HDR image information remains intact. Use the Exposure adjustment to make

exposure edits to the 32-bits-per-channel HDR image.

To view 32-bit readouts in the Info palette, click the Eyedropper icon in the Info palette and choose 32-Bit from the

pop-up menu.

1 Open a 32-bits-per-channel HDR image in Photoshop, and choose View > 32-Bit Preview Options.

2 In the 32-bit Preview Options dialog box, choose an option from the Method menu:

Exposure And Gamma Adjusts the brightness and contrast.

Highlight Compression Compresses the highlight values in the HDR image so they fall within the luminance values

range of the 8- or 16-bits-per-channel image file.
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3 If you chose Exposure And Gamma, move the Exposure and Gain sliders to adjust the brightness and contrast of 

the image preview. 

4	 Click OK. 

You can also adjust the preview of an HDR image open in Photoshop by clicking the triangle in the status bar of the 

document window and choosing 32-Bit Exposure from the pop-up menu. Move the slider to set the white point for 

viewing the HDR image. Since the adjustment is made per view, you can have the same HDR image open in multiple 

windows, each with a different preview adjustment. Preview adjustments made with this method are not stored in the 

HDR image file. 

See also 

“To use the Exposure adjustment” on page 292 

To convert from 32 bits to 8 or 16 bits per channel 
HDR images contain luminance levels that far exceed the luminance data that can be stored in 8- or 16-bits-per-

channel image files. Photoshop lets you make exposure and contrast corrections so that converting a 32-bits-per-

channel HDR image to 8 or 16 bits per channel results in an image with the dynamic range (tonal range) you want. 

1 Open a 32-bits-per-channel image and choose Image > Mode > 16 Bits/Channel or 8 Bits/Channel. 

2 In the HDR Conversion dialog box, choose a method for adjusting the brightness and contrast in the image: 

Exposure And Gamma Lets you manually adjust the brightness and contrast of the HDR image. 

Highlight Compression Compresses the highlight values in the HDR image so they fall within the luminance values 

range of the 8- or 16-bits-per-channel image file. No further adjustments are necessary; this method is automatic. 

Click OK to convert the 32-bits-per-channel image. 

Equalize Histogram Compresses the dynamic range of the HDR image while trying to preserve some contrast. No 

further adjustments are necessary; this method is automatic. Click OK to convert the 32-bits-per-channel image. 

Local Adaptation Adjusts the tonality in the HDR image by calculating the amount of correction necessary for local 

brightness regions throughout the image. 

3 (Optional) Click the arrow to display the toning curve and histogram. The histogram shows the luminance values 

in the original HDR image. The red tick marks along the horizontal axis are in 1 EV (approximately 1 f-stop) incre

ments. The toning curve is active only for the Local Adaptation method. 

4	 Do any of the following: 

•	 If you chose Exposure And Gamma, move the Exposure slider to adjust the gain and move the Gamma slider to 

adjust the contrast. 

•	 If you chose Local Adaptation, move the Radius slider to specify the size of the local brightness regions. Move the 

Threshold slider to specify how far apart two pixels’ tonal values must be before they’re no longer part of the same 

brightness region. You can also use the toning curve to make adjustments. 

Note: The toning curve usually lets you make limited changes from point to point and attempts to equalize your changes 

across the points. If you select the Corner option after inserting a point on the curve, the limit is removed and no equal

ization is performed when you insert and move a second point. You’ll notice that the curve becomes angular at a point 

with the Corner option applied. 
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Toning curve adjustment using the Corner option 
A. Inserting a point displays the Corner option. B. Adjusting new point makes the curve angular at the point where the Corner option is 
used. 

5 (Optional) To save your 32-bit toning options as a file, click Save. Type a name for the file in the Save dialog box


and click Save.


You can reuse the saved 32-bit toning option file. Click Load to convert another 32-bits-per-channel image to an 8


or 16-bits-per-channel image.


6 Click OK to convert the 32-bits-per-channel image.


See also 

“About the Curves dialog box” on page 286 
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Chapter 8: Camera raw files


Camera raw files in Photoshop and Bridge 

Camera raw files 
A camera raw file contains unprocessed picture data from a digital camera’s image sensor. Many digital cameras can 

save images files in camera raw format. In this way, photographers can interpret the image data rather than having 

the camera make the adjustments and conversions automatically. 

Camera raw image files contain the actual data captured by the sensor without any in-camera processing; these are 

the only files containing “pure” data. Working with camera raw files gives you maximum control; you can set the 

white balance, tonal range, contrast, color saturation, and sharpening. Think of camera raw files as your photo 

negative. You can reprocess the file at any time to achieve the results you want. 

To create raw files, you need to set your camera to save files in its own raw file format. In Adobe Bridge or Photoshop, 

you can process only those camera raw files obtained from supported cameras. Visit the adobe.com website to view 

a list of supported cameras. 

The Camera Raw plug-in 
The Camera Raw plug-in processes camera raw files with default image setting files based on Camera Raw’s built-in 

camera profiles for supported camera models and the EXIF data. Every camera model saves the camera raw image 

in a unique format, but Camera Raw can process many camera raw file formats. When you first view thumbnails and 

preview camera raw  files in Bridge,  you see  the files  with  the default  image settings applied. By default, Camera Raw  

also uses an Auto Adjustments option that applies image settings to a file by evaluating the image data in addition to 

using the Camera Raw default settings and the EXIF data. You can change the default settings, make advanced adjust

ments, and specify file saving options using the tools and controls in the Camera Raw dialog box. You can save 

settings for reuse or make them the default settings for a specific camera model. 

Use the Camera Raw plug-in to perform the following tasks: 

•	 Preview camera raw images in Bridge using the default image settings. 

•	 Apply settings to camera raw files in Bridge without opening the Camera Raw dialog box. 

•	 Copy and paste the settings from one camera raw image to another in Bridge. 

•	 Use the  default image  settings  and open camera raw  image files  directly in Photoshop  without opening  the Camera  

Raw dialog box. 

•	 Process the files in the Camera Raw dialog box and open the images in Photoshop, where you can do further 

editing and save them in a supported file format. 

•	 Process the files in the Camera Raw dialog box and either simply close the dialog box or save the camera raw 

images in a file format supported by Photoshop. 

•	 Automate the processing of a batch of camera raw files and save them in a Photoshop-supported file format using 

the Image Processor, the Batch command, or a droplet. 
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•	 Mark camera raw files for deletion as you process a batch of images in the Camera Raw dialog box, and send the 

rejected files to the Recycle Bin (Windows) or Trash (Mac OS) when you finish. 

•	 Save adjusted settings as the default image settings for a specific camera. See “To adjust the rendering of non

neutral colors in Camera Raw” on page 220. 

A I JE F GC DB H 

K	 L M N 

Camera Raw dialog box 
A. Filmstrip B. Toggle Filmstrip C. Tools D. Camera, file name, and some EXIF information E. Rotate buttons F. Mark for Delete 
button G. View options H. RGB values I. Histogram J. Camera Raw menu K. Zoom levels L. Workflow options M. Navigation 
arrows N. Adjustment sliders 

Note: You must have Photoshop  installed to open camera raw  files in Bridge.  However,  if  Photoshop is not  installed,  you  

can still preview the camera raw files in the Preview tab and as thumbnails. If a third-party application is associated 

with the camera raw file type, it’s possible to open the camera raw file in the third-party application from Bridge. 

When you make adjustments (including straightening and cropping the image) from the Camera Raw dialog box, 

the original camera raw file data is preserved. The adjustment settings are stored on a per-image basis in either the 

Camera Raw database file or in sidecar XMP files (files that accompany the original camera raw image file in the same 

folder). Choose a preference to specify where the settings are stored. The XMP files are useful if you plan to move 

the image files to a storage medium or another computer and want to retain the camera raw settings. You can use the 

Export Settings command to copy the settings in the Camera Raw database to sidecar XMP files or embed the 

settings in Digital Negative (DNG) files. 
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From the Camera Raw dialog box, you can save the processed files in Digital Negative (DNG), JPEG, TIFF, or 

Photoshop (PSD) formats. If you open the file in Photoshop, you can save the camera raw image in Photoshop

compatible formats such as PSD, JPEG, Large Document Format (PSB), TIFF, Cineon, Photoshop Raw, PNG, or 

Portable Bit Map. For more information on the Digital Negative format, see “Adobe Digital Negative format (DNG)” 

on page 679 or visit the adobe.com website. 

Note: The Camera Raw dialog box is automatically suppressed when you use a batch of camera raw files for a web photo 

gallery, picture package, or contact sheet, or when you use the Place command with camera raw files. 

You can save the camera raw settings for a specific camera or a specific lighting condition and reuse them to process 

another camera raw image file or a batch of files. 

See also 

“Camera Raw settings” on page 222 

“To process camera raw files in Camera Raw” on page 210 

“To open camera raw images in Photoshop” on page 210 

“Automating processing of camera raw images” on page 226 

“To save camera raw images in Camera Raw” on page 221 

Camera raw and Photoshop Raw files 
Although Photoshop can open and edit a camera raw image file, it cannot save an image in camera raw format. A 

Photoshop Raw format is available in Photoshop, but it’s not the same format used in camera raw image files. A 

camera raw image file contains the unprocessed bits from the camera’s CCD or CMOS. This data needs significant 

processing of the type performed by the Camera Raw plug-in. The Photoshop Raw format (.raw) is a flexible file 

format for transferring images between applications and computer platforms. 

Caches for camera raw files in Bridge 
When you view camera raw files in Adobe Bridge, the thumbnails and previews use either the camera raw default 

settings or your adjusted settings. The cache in Bridge and the Camera Raw cache store data for the file thumbnails, 

metadata, and file information. Caching this data shortens the loading time when you return to a previously viewed 

folder. 

The Camera Raw cache speeds loading of the Camera Raw dialog box and the recalculation of previews in Bridge 

after changes are made to the Camera Raw settings. The Camera Raw cache holds preparsed raw image data for the 

most recently accessed camera raw files. 

The cache in Bridge stores the calculated thumbnails, previews, and metadata for all kinds of images. 

Because the  caches  can become very large, you  may want to purge  the cache  or  limit  its size.  You can  also  purge and  

regenerate the cache if you suspect that it is corrupted or old. Purging the cache deletes thumbnail information and 

metadata added since the camera raw file was opened in Bridge. 

Note: The Camera Raw  cache holds  data  for about  200  images  for each gigabyte of disk storage  allocated to it.  By  default,  

the Camera Raw cache is set to a maximum size of 1 GB. You can increase its limit in the Camera Raw Preferences. 
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To work with the camera raw cache in Bridge 
1 In Bridge, do one of the following: 

•	 In the Camera Raw dialog box, click the triangle next to the Settings menu and choose Preferences from the 

Camera Raw menu. 

•	 (Windows) Choose Edit > Camera Raw Preferences. 

•	 (Mac OS) Choose Bridge > Camera Raw Preferences, or, with the Camera Raw dialog box open, choose 

Photoshop > Camera Raw Preferences. 

2	 Do any of the following: 

•	 To change the cache size, type a value in the Maximum Size text box. 

•	 To purge the camera raw cache, click the Purge Cache button. 

• To change the location of the camera raw cache, click Select Location, browse to the new location, and click Select. 

3 Click OK. 

See also 

“To work with the cache in Bridge” on page 85 

Processing and opening camera raw files in Photoshop 

To open camera raw images in Photoshop 
You can open one or more camera raw image files directly in Photoshop without opening the Camera Raw dialog 

box. Photoshop apples either the default camera raw image settings or your adjusted settings. 

❖ In Bridge, do one of the following: 

•	 Select one or more camera raw image files, hold down the Shift key, and choose File > Open. 

•	 Hold down the Shift key and double-click a camera raw image file. 

To process camera raw files in Camera Raw 
1 Do one of the following: 

•	 (Bridge) Select one or more camera raw files, and choose File > Open With > Photoshop CS2. The Camera Raw 

dialog box appears, with Open as the default button for opening the images in Photoshop. 

•	 (Bridge) Select one or more camera raw files and choose File > Open In Camera Raw. The Camera Raw dialog box 

appears, with Done as the default button for closing the dialog box after you adjust settings. 

•	 (Photoshop) Choose File  >  Open, browse to select one  or  more  camera  raw files, and  click Open.  The Camera Raw  

dialog box appears, with Open as the default button for opening the images in Photoshop. 

The Camera Raw dialog box opens with the camera raw image displayed in a preview window. The histogram shows 

the tonal range of the image with the current settings. As you make setting adjustments, the histogram automatically 

updates. If you selected more than one image, the Filmstrip appears on the left side of the Camera Raw dialog box. 

(You can show or hide the Filmstrip by clicking Toggle Filmstrip .) 

2 If you’re processing several camera raw files, select them from the Filmstrip. Use the arrows in the lower right 

corner of the preview window to navigate to the image you want to adjust. 
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Note: A caution icon appears in the thumbnails and preview image while the preview is generated from the cache. 

3 (Optional) Adjust the image view using controls and options such as zoom, shadows, and highlights. See “Camera 

Raw view controls” on page 213. 

Note: Selecting the Preview check box turns on a preview of any setting changes made to the current tab (Adjust, Detail, 

Lens, Curve, or Calibrate) combined with the settings in the hidden tabs. Deselecting the Preview check box displays the 

camera raw image with the original settings of the current tab combined with the settings in the hidden tabs. 

4 (Optional) Click the Rotate Image buttons  to rotate the image 90˚ counterclockwise or 90˚ clockwise. 

5 (Optional) Select the Color Sampler tool  to place up to four color samplers in the preview image. The RGB 

readouts for each sampler appear above the preview image. Click Clear Samplers to remove all the color samplers. 

See “Using the histogram and RGB levels in Camera Raw” on page 213 and “To view color values in an image” on 

page 280. 

6 (Optional) Choose workflow options (target color space profile, bit depth, pixel dimension, and resolution). Select 

or deselect Show Workflow Options to show or hide the menus. See “Camera Raw Workflow settings” on page 214. 

7 (Optional) To apply the settings used in the previous camera raw image or the default settings for your camera, 

choose an option from the Settings menu. In this way, you can quickly process images with similar lighting condi

tions. See “Camera Raw settings” on page 222 and “To apply saved Camera Raw settings” on page 224. 

8 Set options to adjust the white balance. See “White balance controls for camera raw files” on page 214. 

You can  monitor the  RGB values of pixels in your image  as  you adjust it in the  Camera  Raw dialog box. Position the  

Zoom tool, Hand tool, White Balance tool, Color Sampler tool, or Crop tool over the preview image to display the 

RGB values directly beneath the pointer. You can also place up to four color samplers in the preview image. The RGB 

values of each color sampler appear beneath the preview image. 

9 Make tonal adjustments using the Exposure, Shadow, Brightness, Contrast, and Saturation sliders, or select the 

Auto check boxes to make these adjustments automatically. There is no Auto check box for Saturation. See “Tonal 

adjustment controls for camera raw files” on page 216. 

Click an Auto check box to undo your manual adjustments and make the adjustments automatically. To restore all 

options to their initial settings, press Alt (Windows) or Option (Mac OS) and click Reset. 

Note: By default, the Auto check boxes are always selected in the Camera Raw dialog box. You change this default by 

choosing Use Auto Adjustments from the Camera Raw menu or changing the Camera Raw default so that all or some 

Auto check boxes are always unselected. See “To turn on or off the Auto adjustments in Camera Raw” on page 217. 

10 (Optional) Click the following tabs to make further adjustments: 

Detail Adjusts sharpening, or applies luminance smoothing or color noise reduction. See “To adjust sharpening in 

camera raw files” on page 218 and “Reducing noise in camera raw files” on page 218. 

Lens Compensates for chromatic aberration and vignetting introduced by a digital camera. See “To compensate for 

chromatic aberration in Camera Raw” on page 219 and “To compensate for lens vignetting” on page 220. 

Curve Adjusts tonality using a Curves adjustment. Use the Tone Curve menu to choose a preset adjustment. 

Calibrate Lets you correct a color cast in the shadows and adjust non-neutral colors to compensate for the difference 

between the behavior of your camera and Camera Raw’s built-in profile for your camera model. To save adjustments 

as the default settings for a specific camera, click the triangle next to the Settings menu. Then, from the Camera Raw 

dialog box menu, choose Save New Camera Raw Defaults. See “To remove a shadow color cast in camera raw files” 

on page 220 and “To adjust the rendering of non-neutral colors in Camera Raw” on page 220. 

 



212 ADOBE PHOTOSHOP CS2 
User Guide 

You can save image settings or a subset of settings for reuse on other camera raw images. You can also save adjusted 

settings as the default for a specific camera. For example, if you find that the Linear setting in the Curve tab works 

best with the images from your camera, you can choose Linear from the Tone Curve menu and then choose Save New 

Camera Raw Defaults from the Adobe Camera Raw dialog box menu. In the future, a Linear tone curve will be applied 

to images from the same camera. See “To save or reset Camera Raw settings” on page 223 

11 
Thumbnail pane and click Mark For Deletion . 

(Optional) If you are processing several images and want to delete one or more of them, select them in the 

A red cross appears over a marked image in the Thumbnail pane. The file is sent to the Recycle Bin (Windows) or 

Trash (Mac OS) when you close the Camera Raw dialog box. (If you decide to keep an image that you marked for 

deletion, select it in the Thumbnail pane and click Mark For Deletion again.) 

12 (Optional) To crop or straighten an image when the Camera Raw settings are applied, select the Crop tool 

or Straighten tool and drag over the image. To cancel the operation, press Esc or click the Crop tool and choose 

Clear Crop from the context menu. See “To crop or straighten images in Camera Raw” on page 217. 

If  you selected more than one  image in the  Camera  Raw dialog box, they are  all cropped  by  the same amount and  at  

the same place. 

13 Click one of the following buttons: 

Open Opens copies of the camera raw image files (with the Camera Raw settings applied) in Photoshop. You can 

edit the image further and save the images in a Photoshop-supported format. The original camera raw image file 

remains unaltered. The settings applied to the camera raw image are stored either in the camera raw database file or 

as a sidecar XMP file. 

Done Closes the Camera Raw dialog box and stores file settings either in the camera raw database file or as a sidecar 

XMP file. 

Save Applies the Camera Raw settings to the images and saves copies of them in a Photoshop-supported file format. 

In the Camera Raw Save Options dialog box, specify the destination for the saved files, a file-naming convention, and 

a file format: Digital Negative (DNG), JPEG, TIFF, or Photoshop. Press Alt (Windows) or Option (Mac OS) to 

suppress the Camera Raw Save Options dialog box and save the files using the last set of save options. See “To save 

camera raw images in Camera Raw” on page 221. 

When using the Save command in the Camera Raw dialog box, files are placed in a queue to be processed and saved. 

This is useful if you are processing several files in the Camera Raw dialog box and saving them in the same format. 

Click Alt+Save (Windows) or Option+Save (Mac OS) to suppress the Camera Raw Save Options dialog box when saving 

a file. The file is placed into the queue and saved in the background while you work on another file. In this way, the 

Camera Raw dialog box lets you set up an efficient “assembly line” for processing and saving images. 

Cancel Cancels the adjustments specified in the Camera Raw dialog box. 

After you process and edit a camera raw file using the Camera Raw plug-in, an icon  appears in the image 

thumbnail in Bridge. 

See also 

“Adobe Digital Negative format (DNG)” on page 679 
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Camera Raw view controls 
Zoom tool Sets the preview zoom to the next preset value when you click the preview image. Press Alt/Option 

and click to set the next lower zoom value. Drag the Zoom tool in the preview image to zoom in on a selected area. 

To return to 100%, double-click the Zoom tool. 

Hand tool Moves the image in the preview window if the preview image is set at a zoom level higher than 100%. 

Hold down the spacebar to use the Hand tool while using another tool. Double-click the Hand tool to fit the preview 

image to the window. 

Select Zoom Level Sets the magnification of the preview image. Choose a zoom setting from the menu or click the 

Select Zoom Level buttons. 

Preview Turns on a preview reflecting the changes to the current settings tab (Adjust, Detail, Lens, Curve, or 

Calibrate) combined with the settings in the hidden tabs. Turn Preview off to view the camera raw image with the 

original settings for the current tab combined with the settings in the hidden tabs. 

RGB Indicates the red, green, and blue values of the area of pixels directly below the pointer as you move it over the 

preview image. The values appear when you use the Zoom tool, Hand tool, White Balance tool, Color Sampler tool, 

Crop tool, or Straighten tool. 

Shadows and Highlights Displays shadow and highlight clipping. Clipped shadows appear in blue, and clipped 

highlights appear in red. Highlight clipping is shown if any one of the three RGB channels is clipped (fully saturated 

with no detail). Shadow clipping is shown if all three RGB channels are clipped (black with no detail). 

Using the histogram and RGB levels in Camera Raw 
The Camera Raw histogram shows all three channels (red, green, and blue) of the image simultaneously. The 

histogram changes automatically as you adjust the settings in the Camera Raw dialog box. 

As you move the Zoom tool, Hand tool, White Balance tool, Color Sampler tool, Crop tool, or Straighten tool over 

the preview image, you see, in the upper right corner of the dialog box, the RGB values of the area below the pointer. 

You can also select the Color Sampler tool and place up to four color samplers in the preview image. The RGB values 

appear above the preview image. To clear the color samplers, click Clear Samplers. 

The Camera Raw dialog box displays the RGB values of the area of pixels below the pointer. 

See also 

“About histograms” on page 275 

“Viewing the color values of pixels” on page 279 
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Camera Raw Workflow settings 
Space Specifies the target color space profile. Generally, this should be set to the same value as your Photoshop RGB 

working space. Keep in mind that the source profile for camera raw image files is usually the camera-native color 

space. The profiles listed in the Space menu are built into the Camera Raw plug-in. If you want to use a color space 

that’s not listed in the Space menu, choose ProPhoto RGB, and then convert to the working space of your choice 

when the file opens in Photoshop. 

Depth Specifies whether the file opens as an 8- or 16-bits-per-channel image in Photoshop. 

Size Specifies the  pixel size at which  to  open  the image. The  default is the  pixel size used to photograph the  image.  

Use the Size menu if you want to resample the image. 

For square-pixel cameras, the Size menu is mostly a convenience for the user. However, choosing a smaller-than-

native size is useful to speed processing when you are planning a smaller final image anyway. Picking a larger size is 

similar to upsampling in Photoshop. 

For non-square pixel cameras, the native size is the one that most closely preserves the total pixel count. Selecting a 

different size minimizes the resampling Camera Raw needs to perform, resulting in slightly higher image quality. The 

best quality size is marked with an asterisk (*) in the Size menu. 

Note: You can always change the pixel size of the image after it opens in Photoshop. 

Resolution Specifies the printing resolution at which the image will be printed or the amount of data in the image. 

This setting does not affect the actual pixels (pixel size of the image). For example, a 2048 x 1536 pixel image, when 

printed at 72 dpi, is approximately 28-1/2 x 21-1/4 inches. When printed at 300 dpi, the same image is approximately 

6-3/4 x 5-1/8 inches. You can also use the Image Size command to adjust resolution in Photoshop. 

Making tonal adjustments in Camera Raw 

White balance and camera raw files 
A digital camera records the white balance at the time of exposure as a metadata entry. The Camera Raw plug-in 

reads this value and makes it the initial setting when you open the file in the Camera Raw dialog box. This setting 

usually yields the correct color temperature, or nearly so. You can adjust it if the white balance is not quite right. 

The Adjust tab  in  the Photoshop  Camera  Raw dialog box  has three  controls  for correcting a color cast in your image.  

The Calibrate tab also has a control for correcting a shadow color cast (a color cast that remains in the shadows even 

after the white balance is adjusted). 

White balance controls for camera raw files 
White Balance Sets the color balance of the image to reflect the lighting conditions under which the photo was 

taken. In some cases, choosing a white balance from the White Balance menu provides satisfactory results. In many 

cases, you may want to customize the white balance using the Temperature and Tint adjustments. 

Note: The Camera Raw  plug-in can  read  the white  balance settings of some cameras. Leave  White Balance  set to As Shot  

to use the camera’s white balance settings. For cameras whose white balance settings are not recognized by the Camera 

Raw plug-in, leaving  White Balance  set to As Shot is the  same  as  choosing  Auto: the  Camera  Raw plug-in  reads the  image  

data and automatically adjusts the white balance. 

Temperature Fine-tunes the white balance to a custom color temperature. Set the color temperature using the 

Kelvin color temperature scale. Move the slider to the left to correct a photo taken with a lower color temperature of 
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light; the plug-in makes the image colors bluer to compensate for the lower color temperature (yellowish) of the

ambient light. Conversely, move the slider to the right to correct a photo taken with a higher color temperature of

light; the plug-in makes the image colors warmer (yellowish) to compensate for the higher color temperature (bluish)

of the ambient light.

Correcting the white balance
A. Moving the Temperature slider to the right corrects a photo taken with a higher color temperature of light B. Moving the Temperature
slider to the left corrects a photo taken with a lower color temperature of light C. Photo after color temperature adjustment

Tint Fine-tunes the white balance to compensate for a green or magenta tint. Move the slider to the left (negative

values) to add green to the photo; move it to the right (positive values) to add magenta.

To adjust the white balance quickly, select the White Balance tool, and then click an area in the preview image that

should be a neutral gray or white. The Temperature and Tint sliders automatically adjust to make the selected color

exactly neutral (if possible). If you’re clicking whites, choose a highlight area that contains significant white detail rather

than a specular highlight.

Using White Balance to click a neutral white area and resulting correction

A

C

B
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Tonal adjustment controls for camera raw files 
Exposure Adjusts the brightness or darkness of the image. Move the slider to the left to darken the image; move it 

to the right to brighten the image. The values are in increments equivalent to f-stops. An adjustment of +1.50 is 

similar to widening the aperture 1-1/2 stops. Similarly, an adjustment of –1.50 is similar to reducing the aperture 

1-1/2 stops. 

Hold down Alt (Windows) or Option (Mac OS) while moving the Exposure slider to preview where the highlights are 

clipped. (Clipping is the shifting of pixel values to either the highest highlight value or the lowest shadow value. 

Clipped areas are either completely white or completely black and have no image detail.) Move the slider until the 

highlights (not specular highlights) are completely clipped, and then reverse the adjustment slightly. Black indicates 

unclipped areas, and color indicates areas clipped in only one or two channels. 

Hold down Alt (Windows) or Option (Mac OS) while moving the Exposure slider to show clipped highlights. 

Shadows Specifies which input levels are mapped to black in the final image. Moving the slider to the right increases 

the areas that are mapped to black. This sometimes creates the impression of increased contrast in the image. Using 

the Shadows slider is similar to using the black point slider for input levels in the Photoshop Levels command. 

Hold down Alt (Windows) or Option (Mac OS) while moving the Shadow slider to preview where the shadows are 

clipped. Move the slider until the shadows begin to get clipped, and then reverse the adjustment slightly. Color 

indicates areas that are being clipped in one or two channels, and white indicates unclipped areas. 

Brightness Adjusts the brightness or darkness of the image, much as the Exposure slider does. However, instead of 

clipping the image in the highlights (areas that are completely white, no detail) or shadows (areas that are completely 

black, no detail), Brightness compresses the highlights and expands the shadows when you move the slider to the 

right. In general, use the Brightness slider to adjust the overall brightness or darkness after you set the white and black 

clipping points with the Exposure and Shadow sliders. 

Contrast Adjusts the midtones in an image. Higher values increase the midtone contrast, and lower values produce 

an image with less contrast. Generally, you use the Contrast slider to adjust the contrast of the midtones after setting 

the Exposure, Shadow, and Brightness values. 

Saturation Adjusts the color saturation of the image from –100 (pure monochrome) to +100 (double the 

saturation). 

See also 

“Using Levels to set highlights, shadows, and midtones” on page 284 
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To turn on or off the Auto adjustments in Camera Raw 
By default, the Auto check boxes are always selected in the Camera Raw dialog box. You change this default so that 

all or some Auto check boxes are always unselected. 

❖ Do any of the following: 

•	 In the Camera Raw dialog box, click the triangle next to the Settings menu and choose Use Auto Adjustments from 

the Camera Raw menu. 

When Use Auto Adjustments is unchecked, all or some Auto check boxes are always unselected. When Use Auto 

Adjustments is checked, the Auto check boxes are always selected. 

•	 Deselect the Auto check boxes, click the triangle next to the Settings menu, and choose Save New Camera Raw 

Defaults from the Camera Raw menu. 

Transforming images in Camera Raw 

To rotate images in Camera Raw 
❖ Click a Rotate Image button  to rotate the image 90˚ counterclockwise or 90˚ clockwise. 

To crop or straighten images in Camera Raw 
1 In the Camera Raw dialog box, select the Crop tool  or Straighten tool . 

2 (Optional) If you want the crop area constrained to specific proportions, click the Crop tool icon and choose a 

proportion from the pop-up menu. Choosing Custom opens the Custom Crop dialog box, where you can specify the 

proportions or the dimensions of the crop. Click OK. 

3	 Do one of the following: 

•	 To crop the image, drag the Crop tool over the image. 

• To straighten the image, drag the Straighten tool in the preview image to establish what’s horizontal or vertical. 

4 (Optional) To adjust the crop area, do one of the following: 

•	 To scale or rotate the crop area, drag just outside the bounding box handles. 

•	 To move the crop area, click in the bounding box and drag. 

If you selected several images in the Camera Raw dialog box, they are all cropped to the same size, with the crop 

applied in the same position. 

Note: To cancel the crop operation, press Esc with the Crop tool selected or click the Crop tool and choose Clear Crop 

from the pop-up menu. To cancel the crop and close the Camera Raw dialog box without processing the camera raw 

image file, click the Cancel button or deselect the Crop tool and press Esc. 

5	 Click Open, Done, or Save to apply the crop and process the camera raw image file. 

See also 

“Cropping images” on page 348 
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To adjust sharpening in camera raw files 
The Sharpness slider adjusts the image sharpening to provide the edge definition you wish. The Sharpness 

adjustment is a variation of the Photoshop Unsharp Mask filter, which locates pixels that differ from surrounding 

pixels based on the threshold you specify and increases the pixels’ contrast by the amount you specify. When opening 

a camera raw image file, the Camera Raw plug-in calculates the threshold to use based on camera model, ISO, and 

exposure compensation. You can choose whether sharpening is applied to all images or just to previews. 

1	 Zoom the preview image to at least 100%. 

2 Move the slider to the right to increase sharpening and to the left to decrease it. A value of zero turns off sharp

ening. In general, set the Sharpness slider to a lower value for cleaner images. 

If you don’t plan to edit the image extensively in Photoshop, use the Camera Raw’s Sharpness slider. If you do plan to 

edit the image extensively in Photoshop, turn off Camera Raw sharpening. Then use the sharpening filters in 

Photoshop as the last step after all other editing and resizing is complete. 

To specify whether the image or preview is sharpened 
1 Do one of the following: 

•	 In the Camera Raw dialog box, click the triangle next to the Settings menu and choose Preferences from the 

Camera Raw menu. 

•	 (Windows) In Adobe Bridge, choose Edit > Camera Raw Preferences. 

•	 (Mac OS) In Bridge, choose Bridge > Camera Raw Preferences, or with the Camera Raw dialog box opened in 

Photoshop, choose Photoshop > Camera Raw Preferences. 

2 In the Camera Raw Preferences dialog box, choose one of the following: 

All Images Applies sharpening to the camera raw image. 

Preview Images Only Applies sharpening only to the preview image and not the actual camera raw image. This 

option is for users who do not want to apply sharpening with the Camera Raw plug-in. 

Reducing noise in camera raw files 
The Detail tab of the Camera Raw dialog box has controls for reducing image noise, the extraneous visible artifacts 

that degrade image quality. Image noise includes luminance (grayscale) noise, which makes an image look grainy, 

and chroma (color) noise, which is usually visible as colored artifacts in the image. Photos taken with high ISO 

speeds or less-sophisticated digital cameras can have noticeable noise. 

The Luminance Smoothing slider reduces grayscale noise, and the Color Noise Reduction slider reduces chroma 

noise. Moving a slider to zero turns off its noise reduction. 

When making Luminance Smoothing or Color Noise Reduction adjustments, first zoom in on the preview image for 

a better view. 
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Moving  the Luminance  Smoothing slider to the  right reduces  grayscale noise, and  moving  the Color  Noise Reduction  slider  to  the right  reduces  
chroma noise. 

Chromatic aberration 
Chromatic aberration is a common defect caused by the failure of the lens to focus different frequencies (colors) to 

the same spot. In one type of chromatic aberration, the image from each color of light is in focus, but each image is 

a slightly different size. This type of aberration is seen as a complementary color fringing in areas away from the 

center of the image. For example, you may see a red fringe on the side of an object toward the center of the image, 

and cyan fringe on the side of the object away from the center of the image. 

Original image (left), and after fixing chromatic aberration (right) 

To compensate for chromatic aberration in Camera Raw 
1 Zoom into an area near the corner of the preview image. For the best results, the area should contain very dark or 

black detail against a very light or white background. Look for the color fringing. 

2 In the Lens tab, move one or more of the following sliders: 

Fix Red/Cyan Fringe Adjusts the size of the red channel relative to the green channel. This compensates for red/cyan 

color fringing. 

Fix Blue/Yellow Fringe Adjusts the size of the blue channel relative to the green channel. This compensates for 

blue/yellow color fringing. 
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Look at the preview image as you move the slider to the left or right. If you’re adjusting red/cyan color fringing, you 

can hold down Alt (Windows) or Option (Mac OS) to hide the blue/yellow color fringing. Similarly, hold down Alt 

(Windows) or Option (Mac OS) while adjusting the blue/yellow color fringing to hide the red/cyan color fringing. 

Your goal is to reduce the color fringing as much as possible. 

To compensate for lens vignetting 
Vignetting is a lens defect that causes the edges, especially the corners, of an image to be darker than the center. 

1 In the Lens tab, move the Vignetting Amount slider to the right (positive values) to lighten the corners of the 

image or move the slider to the left (negative values) to darken the corners of the image. You can also enter values in 

the Vignetting Amount text box. 

2 Move the Vignetting Midpoint slider to the left (lower value) to apply the Vignetting Amount adjustment to a 

larger  area  away  from  the corners, or move the  slider  to  the right  (higher value) to restrict the  adjustment  to  an  area  

closer to the corners. You can also enter a value in the Vignetting Midpoint text box. 

Calibrating color in camera raw images 

To remove a shadow color cast in camera raw files 
Sometimes a color cast remains in the shadow areas after you adjust the highlight white balance using the Temper

ature and Tint sliders. The Calibrate tab has a Shadow Tint slider to correct this remaining shadow color cast. 

❖ In  the Calibrate  tab,  move  the Shadow Tint slider to remove the  color cast in the  shadows.  The camera’s sensor and  

the white  balance affect which  colors  are adjusted.  Usually,  moving  the slider to the  left  (negative values)  adds  green  

to the shadow areas, and moving the slider to the right (positive values) adds magenta. 

To adjust the rendering of non-neutral colors in Camera Raw 
Sometimes colors rendered by the Camera Raw plug-in do not look as expected. The cause may be a difference


between a camera’s profile and Camera Raw’s built-in profile for that camera model. Alternatively, the photo may


have been taken under nonstandard lighting conditions beyond the compensating range of the Adobe Camera Raw


plug-in. The Calibrate tab has Hue and Saturation sliders to adjust the settings for Camera Raw’s built-in camera


profile to render non-neutral colors differently. You can also specify whether to use the profiles built into Camera


Raw or a profile built into the file itself.


1 In the Calibrate tab, choose a profile from the Camera Profile menu:


ACR 3.0 Uses the built-in camera profile of Camera Raw 3.0 for Photoshop CS2 and Adobe Creative Suite.


Important: The options that appear in the Camera Profile menu depend on whether a camera raw file has a profile 

embedded or whether it has been processed with a previous version of Camera Raw. Often, the Camera Profile menu 

only contains the ACR 3.0 option. 
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Embedded Uses the profile embedded in the camera raw file. 

ACR 2.4 Uses the built-in camera profile of Camera Raw 2.4 for Photoshop CS. The option is available for only 

certain cameras. Users who have fine-tuned their settings for the older Camera Raw built-in profile can select this 

option to use that profile instead. 

2 Use the Hue and Saturation sliders to adjust the red, green, and blue in the image. Look at the preview image as 

you make adjustments until the image looks correct to you. In general, adjust the hue first and then adjust its 

saturation. Moving the Hue slider to the left (negative value) is like a counterclockwise move on the color wheel, and 

moving it to the right (positive value) is like a clockwise move. Moving the Saturation slider to the left (negative 

value) desaturates the color, and moving it to the right (positive value) increases saturation. 

Adjustments made in the  Calibrate tab  affect  the selected image  in  the Camera Raw  dialog  box.  If  you want to save  

the adjustments and make them the default image settings for the files from a specific camera, click the triangle next 

to the Settings menu and choose Save New Camera Raw Defaults from the Camera Raw menu. 

Saving camera raw images 

To save camera raw images in Camera Raw 
The Camera Raw dialog box lets you save camera raw files in Photoshop-supported file formats.


1 In the Camera Raw dialog box, apply adjustments to one or more camera raw images.


2 Click the Save button.


3 In the Camera Raw Save Options dialog box, specify the following options:


Destination Specifies where to save the file. If necessary, click the Select Folder button and navigate to the location.


File Naming Specifies the naming convention used if you’re processing and saving more than one camera raw file. 

4 Choose a file format from the Format menu: 

Digital Negative Saves a copy of the camera raw file in the DNG file format. Specify save options by selecting any 

of  the following: Compressed (Lossless),  Uncompressed, Preserve Raw  Image,  or  Convert To Linear Image. You  can  

also specify a JPEG preview for the DNG file. 

JPEG Saves copies of the camera raw files in JPEG format. To specify the amount of compression, enter a value from 

0 to 12 or choose from the pop-up menu. Entering a higher value or choosing High or Maximum applies less 

compression, increasing file size and image quality. 

TIFF Saves copies of the camera raw files in TIFF format. Specify whether to apply no compression, or LZW or ZIP 

file compression. 

Photoshop Saves copies of the camera raw files in the PSD file format. You can specify whether to preserve cropped 

pixel data in the PSD file. 

5 Click Save. 

Note: The Digital Negative (DNG) format is Adobe’s proposed standard format for camera raw image files. DNG files 

are useful for archiving camera raw images because they contain the raw camera sensor data and data specifying how 

the image should look. Camera Raw image settings can be store in DNG files instead of in sidecar XMP files or the 

Camera Raw database. 
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See also 

“Photoshop format (PSD)” on page 678 

“Adobe Digital Negative format (DNG)” on page 679 

“JPEG format” on page 681 

“TIFF” on page 685 

Digital Negative saving options for Camera Raw 
Compressed (lossless) Applies a lossless compression to the DNG file. 

Convert To Linear Image Stores the image data in an interpolated (“demosaiced”) format. 

Embed Original Raw File Stores the entire original camera raw image data in the DNG file. 

JPEG Preview Specifies whether to embed a JPEG preview in the DNG file. If you decide to embed a JPEG preview, 

you can choose the preview size. If you embed JPEG previews, other applications can view the contents of the DNG 

file without parsing the camera raw data. 

Camera Raw settings 

Camera Raw settings 
In the Camera Raw dialog box, you can change the default image settings and save the adjusted settings as the new 

camera default. You can always restore the original Camera Raw default settings for the specific camera (click the 

triangle to the right of the Settings pop-up menu and choose Reset Camera Raw Defaults from the Camera Raw 

menu). Because Camera Raw can identify which camera was used to take an image, you can save different default 

image settings for different cameras. 

You can also save Camera Raw settings for a specific lighting condition and reapply them to images taken under 

similar conditions. Alternatively, you can save only a subset of the Camera Raw plug-in settings. In this way, you can 

create presets for custom white balances, specific lens settings, and so forth. In Adobe Bridge, you can also update all 

settings or a subset of the settings applied to camera raw images. 

When a camera raw image file is processed with Camera Raw, the image settings are stored in one of two places: the 

Camera Raw database file or a sidecar XMP file. You can set a preference to determine where settings are stored. 

Photoshop and Bridge remember the settings for each camera raw image file. When you reopen a camera raw image, 

all the settings sliders default to the values used when the file was last opened. Image attributes (target color space 

profile, bit depth, pixel size, and resolution) are not the stored with the settings. 

See also 

“To adjust the rendering of non-neutral colors in Camera Raw” on page 220 

“To specify where Camera Raw settings are stored” on page 223 

“To save or reset Camera Raw settings” on page 223 
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To specify where Camera Raw settings are stored 
1 Do one of the following: 

•	 In the Camera Raw dialog box, click the triangle next to the Settings menu to open the Camera Raw menu and 

choose Preferences. 

•	 (Windows) In Adobe Bridge, choose Edit > Camera Raw Preferences. 

•	 (Mac OS) Choose Bridge > Camera Raw Preferences, or with the Camera Raw dialog box opened in Photoshop, 

choose Photoshop > Camera Raw Preferences. 

2	 In the Camera Raw Preferences dialog box, choose one of the following from the Save Image Settings In menu: 

Camera Raw Database Stores the settings in a Camera Raw database file, generally located in the user’s Application 

Data folder as Document and Settings/user name/Application Data/Adobe/CameraRaw (Windows) or the user’s 

Preferences folder as Users/user name/Library/Preferences (Mac OS). This database is indexed by file content, so 

settings remain with the image even if you move or rename the image file. 

Sidecar “.xmp” Files Stores the settings in an XMP file in the same folder as the raw file with the same base name 

and an .xmp extension. This option is useful for long-term archiving of raw files with their associated settings, and 

for the exchange of raw files with associated settings in multiuser workflows. These same sidecar XMP files can store 

IPTC (International Press Telecommunications Council) data or other metadata associated with a camera raw image 

file. If you open files from a read-only volume such as a CD or DVD, be sure to copy the files to your hard drive before 

opening them. The Camera Raw plug-in cannot write an XMP file to a read-only volume and writes the settings to 

the Camera Raw database file instead. You can view XMP files in Bridge by choosing View > Show Hidden Files. 

If you store the camera raw settings in the Camera Raw database and plan to move the files to a different location 

(CD, DVD, another computer, and so forth), you can use the Export Settings command in the Camera Raw dialog 

box to export the settings to sidecar XMP files or embed them in DNG files. 

See also 

“To export Camera Raw settings” on page 225 

To save or reset Camera Raw settings 
1 In the Camera Raw dialog box, adjust the settings that you want to save. 

2	 Click the triangle next to the Settings menu and choose one of the following from the Camera Raw menu: 

Save Settings Saves the  current settings and  adds  them  to  the Settings menu.  In  the Save Raw  Conversion  Settings  

dialog box, name and save the settings. Save the setting to the Camera Raw settings folder so that it is visible in the 

Settings  menu. Settings saved  elsewhere disappear  from  the Settings menu as soon as you  choose  another setting. If  

this happens, use the Load Settings command in the Camera Raw menu and browse to find the setting. 

Save New Camera Defaults Saves the current settings as the new default settings for other images taken with the 

same camera. 

Reset Camera Raw Defaults Restores the original default settings for a specific camera. 
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To save a subset of settings

1 Click the triangle next to the Settings menu to display the Camera Raw menu, and choose Save Settings Subset.


2 Specify the settings to be saved by doing one of the following:


•	 Choose an option from the Subset menu. 

• Select or deselect settings in the Settings list.


3 Click Save.


4 In the Save Raw Conversion Settings dialog box, name the subset and save it to the Camera Raw settings folder.


This saved subset appears at the bottom of the Settings menu. 

To apply saved Camera Raw settings 
1 Do one of the following 

•	 Open one or more camera raw images in the Camera Raw dialog box, and click the triangle next to the Settings 

text box to display the Settings menu. 

• (Bridge) Select one or more camera raw images and choose Edit > Apply Camera Raw Settings.


2 From the Settings menu or the Apply Camera Raw Settings submenu, choose one of the following:


Image Settings Uses the settings from the selected camera raw image. This option is available only from the Settings


menu in the Camera Raw dialog box.


Camera Raw Defaults Uses the saved default settings for a specific camera. 

Previous Conversion Uses the settings from the previous image of the same camera. 

A saved setting Uses a setting that you saved. 

Note: You can also open the Camera Raw menu, choose Load Settings, and then browse to select a saved setting. 

To load Camera Raw settings 
Saved settings are not listed in the Settings menu (Camera Raw dialog box) or the Apply Camera Raw Settings 

submenu (Bridge or Photoshop) unless you save them to the Camera Raw settings folder. However, you can use the 

Load command to browse for and apply settings saved elsewhere. 

1 In the Camera Raw dialog box, click the triangle next to the Settings menu and choose Load Settings from the 

Camera Raw menu. 

2	 In the Load Raw Conversion Settings dialog box, browse to the settings file, select it, and click Load. 

To copy and paste Camera Raw settings 
In Bridge, you can copy and paste the Camera Raw settings from one camera raw image file to another. 

1	 In Bridge, select a camera raw image and choose Edit > Apply Camera Raw Settings > Copy Camera Raw Settings. 

2 Select one or more camera raw images and choose Edit > Apply Camera Raw Settings > Paste Camera Raw 

Settings. 
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You can also right-click (Windows) or Control-click (Mac OS) camera raw files to copy and paste using the context 

menu. 

3	 In the Paste Camera Raw Settings dialog box, do one of the following and then click OK: 

•	 To apply all settings including any crops, choose Everything from the Subset menu. 

•	 To apply all settings but not any crops, choose Settings from the Subset menu. 

•	 To apply one or more settings subsets, choose a setting from the Subset menu or select only the settings you want 

to apply. If necessary, deselect that settings that you don’t want applied. 

To apply settings to multiple camera raw image files in Camera Raw 
You can process multiple camera raw image files using the current settings or a subset of the current settings in the


Camera Raw dialog box.


1 In the Camera Raw dialog box, select an image in the Filmstrip and adjust the image settings if necessary.


2 Select more than one image in the Filmstrip and click the Synchronize button.


3 In the Synchronize dialog box, do one of the following:


•	 Choose a setting from the Synchronize menu. 

• Select the settings that you want to apply. 

4 Click OK. 

To clear settings applied to camera raw image files 
You can clear image settings applied to camera raw files and restore the Camera Raw default image settings.


1 In Bridge, select one or more camera raw image files.


2 Choose Edit > Apply Camera Raw Settings > Clear Camera Raw Settings.


To delete Camera Raw settings

1 Choose a saved setting from the Settings menu.


2 Click the triangle next to the Settings menu to display the Camera Raw menu.


3 Choose Delete Current Settings from the menu. The setting is deleted from the Camera Raw settings folder.


To export Camera Raw settings 
If you store file settings in the Camera Raw database, you can use the Export Settings command to copy the settings 

to sidecar XMP files or embed them in DNG files. This is useful for preserving the image settings with your camera 

raw files when you move them. 

1 Open the Camera Raw dialog box with the camera raw files whose settings you want to export. Make sure to select 

the thumbnails in the Filmstrip. 

2	 Click the triangle next to the Settings menu and choose Export Settings from the Camera Raw menu. 

The sidecar XMP files are created in the same folder as the camera raw image files. If you saved the camera raw image 

files in DNG format, the Camera Raw settings are embedded in the DNG files themselves. 
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Automating the Camera Raw workflow 

Automating processing of camera raw images 
You can create an action to automate the processing camera raw image files. You can automate the editing process, 

and the process of saving the files in formats such as PSD, DNG, JPEG, Large Document Format (PSB), TIFF, and 

PDF. In Photoshop, you can also use the Batch command, the Image Processor, or the Create Droplet command to 

process one or more camera raw image files. The Image Processor is especially useful for saving camera raw image 

files in different file formats during the same processing session. 

Here are some tips for automating the processing of camera raw image files: 

•	 When you record an action, do so with Image Settings chosen from the Settings menu of the Camera Raw dialog 

box. In this way, the settings particular to each image (from the Camera Raw database or sidecar XMP files) are 

used to play back the action. 

•	 If  you plan to use  the action with the  Batch command, you  may want to use  the Save As command  and choose the  

file format when saving the camera raw image. 

•	 When you use an action to open a camera raw file, the Camera Raw dialog box reflects the settings that were in 

effect when the action was recorded. You may want to create different actions for opening camera raw image files 

with different settings. 

•	 When using the Batch command, select Override Action “Open” Commands so that Open commands in the 

action refer to the batched files rather than the files specified by name in the action. Deselect Override Action 

“Open” Commands only if the action is to operate on open files or if the action contains Open commands for 

specific files required by the action. 

•	 When using the Batch command, select Suppress File Open Options Dialogs to prevent the Camera Raw dialog 

box from opening for each camera raw image being processed. 

•	 Using the Batch command, select Override Action “Save As” Commands if you want to use the Save As instruc

tions from the Batch command instead of the Save As instructions in the action. If you select this option, the action 

must contain a Save As command, because the Batch command does not automatically save the source files. 

Deselect Override Action “Save As” Commands to save the files processed by the Batch command in the location 

specified in the Batch dialog box. 

•	 When creating a droplet, in the Play area of the Create Droplet dialog box, select Suppress File Open Options 

Dialogs. This prevents the Camera Raw dialog box from opening for each camera raw image being processed. 

See also 

“To automate a task by recording an action” on page 731 

“To convert files with the Image Processor” on page 739 

“To batch-process files” on page 741 

“To create a droplet from an action in Photoshop” on page 743 
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Chapter 9: Color


Color modes 

Color modes 
Photoshop lets you choose a color mode for each document. The color mode determines what color method is used 

to display and print the image you’re working on. By selecting a particular color mode, you are choosing to work with 

particular color model (a numerical method for describing color). Photoshop bases its color modes on the color 

models that are useful for images used in publishing. You can choose from RGB (Red, Green, Blue), CMYK (Cyan, 

Magenta, Yellow, Black), Lab Color (based on CIE L* a* b*), and Grayscale. Photoshop also includes modes for 

specialized color output such as Indexed Color and Duotone. Color modes determine the number of colors, the 

number of channels, and the file size of an image. Choosing a color mode also determines which tools and file 

formats are available. 

Note: ImageReady only uses the RGB mode to work with images, because its documents are primarily intended for web 

display. 

RGB Color mode 
Photoshop’s RGB Color mode uses the RGB model, assigning an intensity value to each pixel. In 8-bits-per-channel 

images, the intensity values range from 0 (black) to 255 (white) for each of the RGB (red, green, blue) components 

in a color image. For example, a bright red color might have an R value of 246, a G value of 20, and a B value of 50. 

When the values of all three components are equal, the result is a shade of neutral gray. When the values of all compo

nents are 255, the result is pure white; when the values are 0, pure black. 

RGB images use three colors, or channels, to reproduce colors on-screen. In 8-bits-per-channel images, the three 

channels translate to 24 (8 bits x 3 channels) bits of color information per pixel. With 24-bit images, up to 16.7 million 

colors can be reproduced. With 48-bit (16-bits-per-channel) and 96-bit (32-bits-per-channel) images, even more 

colors can be reproduced. In addition to being the default mode for new Photoshop images, the RGB model is used 

by computer monitors to display colors. This means that when working in color modes other than RGB, such as 

CMYK, Photoshop interpolates the CMYK image to RGB for display on-screen. 

Although RGB is a standard color model, the exact range of colors represented can vary, depending on the appli

cation or display device. Photoshop’s RGB Color mode varies according to the working space setting that you specify 

in the Color Settings dialog box. 

Note: ImageReady uses only the RGB mode to work with images. 

See also 

“About color working spaces” on page 268 

CMYK Color mode 
In the CMYK mode, each pixel is assigned a percentage value for each of the process inks. The lightest (highlight) 

colors are assigned small percentages of process ink colors; the darker (shadow) colors higher percentages. For 

example, a bright red might contain 2% cyan, 93% magenta, 90% yellow, and 0% black. In CMYK images, pure white 

is generated when all four components have values of 0%. 
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Use the CMYK mode when preparing an image to be printed using process colors. Converting an RGB image into 

CMYK creates a color separation. If you start with an RGB image, it’s best to edit first in RGB and then convert to 

CMYK at the end of your process. In RGB mode, you can use the Proof Setup commands to simulate the effects of a 

CMYK conversion without changing the actual image data. You can also use CMYK mode to work directly with 

CMYK images scanned or imported from high-end systems. 

Although CMYK is a standard color model, the exact range of colors represented can vary, depending on the press 

and printing conditions. Photoshop’s CMYK Color mode varies according to the working space setting that you 

specify in the Color Settings dialog box. 

See also 

“About color working spaces” on page 268 

“Soft-proofing colors” on page 259 

Lab Color mode 
The Lab Color mode has a lightness component (L) that can range from 0 to 100. In the Adobe Color Picker, the a 

component (green-red axis) and the b component (blue-yellow axis) can range from +127 to –128. In the Color 

palette, the a component and the b component can range from +127 to –128. 

You can use Lab mode to work with Photo CD images, edit the luminance and the color values in an image indepen

dently, move images between systems, and print to PostScript Level 2 and Level 3 printers. To print Lab images to 

other color PostScript devices, convert to CMYK first. 

Lab images can be saved in Photoshop, Photoshop EPS, Large Document Format (PSB), Photoshop PDF, Photoshop 

Raw, TIFF, Photoshop DCS 1.0, or Photoshop DCS 2.0 formats. You can save 48-bit (16-bits-per-channel) Lab images 

in Photoshop, Large Document Format (PSB), Photoshop PDF, Photoshop Raw, or TIFF formats. 

Note: The DCS 1.0 and DCS 2.0 formats convert the file to CMYK when opened. 

Lab color is the intermediate color model Photoshop uses when converting from one color mode to another. 

Bitmap mode 
Bitmap mode uses one of two color values (black or white) to represent the pixels in an image. Images in Bitmap 

mode are called bitmapped 1-bit images because they have a bit depth of 1. 

Grayscale mode 
Grayscale mode uses different shades of gray in an image. In 8-bit images, there can be up to 256 shades of gray. Every 

pixel of a grayscale image has a brightness value ranging from 0 (black) to 255 (white). In 16 and 32-bit images, the 

number of shades in an image is much greater than in 8-bit images. Grayscale values can also be measured as 

percentages of black ink coverage (0% is equal to white, 100% to black). Images produced using black-and-white or 

grayscale scanners typically are displayed in Grayscale mode. 

Although Grayscale is a standard color model, the exact range of grays represented can vary, depending on the 

printing conditions. In Photoshop, Grayscale mode uses the range defined by the working space setting that you 

specify in the Color Settings dialog box. 
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These guidelines apply to converting images to and from Grayscale mode: 

•	 You can convert both Bitmap mode and color images to grayscale. 

•	 To convert a color image to a high-quality grayscale image, Photoshop discards all color information in the 

original image. The gray levels (shades) of the converted pixels represent the luminosity of the original pixels. 

You can mix information from the color channels to create a custom grayscale channel by using the Channel Mixer 

command. 

•	 When converting from grayscale to RGB, the color values for a pixel are based on its previous gray value. A 

grayscale image can also be converted to a CMYK image (for creating process-color quadtones without converting 

to Duotone mode) or to a Lab color image. 

See also 

“About color working spaces” on page 268 

Duotone mode 
Duotone mode creates monotone, duotone (two-color), tritone (three-color), and quadtone (four-color) grayscale 

images using one to four custom inks. 

See also 

“About duotones” on page 725 

Indexed Color mode 
Indexed Color mode produces 8-bit image files with at most 256 colors. When converting to indexed color, 

Photoshop builds a color lookup table (CLUT), which stores and indexes the colors in the image. If a color in the 

original image does not appear in the table, the program chooses the closest one or uses dithering to simulate the 

color using available colors. 

Because the palette of colors is limited, indexed color can reduce file size yet maintain the visual quality needed for 

multimedia presentations, web pages, and the like. Limited editing is available in this mode. For extensive editing, 

you should convert temporarily to RGB mode. Indexed color files can be saved in Photoshop, BMP, GIF, Photoshop 

EPS, Large Document Format (PSB), PCX, Photoshop PDF, Photoshop Raw, Photoshop 2.0, PICT, PNG, Targa, or 

TIFF formats. 

Multichannel mode 
Multichannel mode uses 256 levels of gray in each channel. Multichannel images are useful for specialized printing. 

Multichannel mode images can be saved in Photoshop, Photoshop 2.0, Photoshop Raw, or Photoshop DCS 2.0 

format. 

These guidelines apply to converting images to Multichannel mode: 

•	 Color channels in the original image become spot color channels in the converted image. 

•	 When you convert a color image to a multichannel image, the new grayscale information is based on the color 

values of the pixels in each channel. 

•	 Converting a CMYK image to Multichannel mode creates cyan, magenta, yellow, and black spot channels. 

•	 Converting an RGB image to Multichannel mode creates cyan, magenta, and yellow spot channels. 
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• Deleting a channel from an RGB, CMYK, or Lab image automatically converts the image to Multichannel mode. 

• To export a multichannel image, save it in Photoshop DCS 2.0 format. 

Adjusting the monitor display 

About monitors and color work 
Although the RGB color model used by computer monitors can display much of the visible spectrum, the video 

system sending data to a given monitor often limits how many colors can be displayed at once. By understanding 

how color data is measured in digital files and on-screen, you can better adjust color display settings to offset the 

limitations of your video system. For critical work, your monitor should be calibrated and characterized for use in a 

color management system. At the very least, your monitor should be calibrated to display colors as accurately as 

possible. 

See also 

“About monitor calibration and characterization” on page 264 

To speed up previews by adjusting the monitor display 
The Use Pixel Doubling preference option speeds up the preview of a tool or command’s effects by temporarily 

doubling the size of the pixels (halving the resolution) in the preview. This option has no effect on the pixels in the 

file; it simply provides faster previews with the tools and commands. 

1 Do one of the following: 

• In Windows, choose Edit > Preferences > Display & Cursors. 

• In Mac OS, choose Photoshop > Preferences > Display & Cursors. 

2 Select Use Pixel Doubling, and click OK. 

Adjusting color display for cross-platform variations 
RGB color display on a computer monitor varies with the operating system used by the computer. For example, an 

image appears darker on a Windows system than on a Mac OS computer (because the standard RGB color space is 

darker in Windows than in Mac OS). The Preview commands in ImageReady let you compensate for cross-platform 

differences in RGB color display during image preview. In Photoshop, you can simulate cross-platform differences 

by using the Macintosh RGB, Windows RGB, and Monitor RGB commands in the View > Proof Setup menu. 

RGB color display can also vary between Photoshop and ImageReady. In Photoshop, you can select from several RGB 

color spaces when editing images. As a result, images created in Photoshop may use an RGB color space that differs 

from  the monitor  RGB color  space used by ImageReady.  You can  adjust  the RGB  color display  during  image preview  

to compensate for differences between Photoshop and ImageReady. 

See also 

“Soft-proofing colors” on page 259 
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To adjust RGB color display for cross-platform variations (ImageReady) 
❖ Choose View > Preview and choose an option for adjusting the color display: 

Uncompensated Color Displays the image with the monitor gamma uncorrected. 

Standard Macintosh Color Displays the image with a gamma value of 1.8. 

Standard Windows Color Displays the image with a gamma value of 2.2. 

Use Embedded Color Profile Uses the embedded profile to display the image. 

These options adjust color display only. No changes are made to pixels in the image. 

You can edit your image in one window and view the same image with a different gamma value in a second window. 

Choose Window > Arrange > New Window For [File Name]. With the new window active, choose View > Preview 

and then choose a different gamma than the one used in the first window. 

To adjust RGB color display to match Photoshop color display (ImageReady) 
❖ Choose View > Preview > Use Embedded Color Profile. 

Note: To use the Use Embedded Color Profile command in ImageReady, you must first save the original image, with the 

color profile embedded, in Photoshop. Keep in mind that ImageReady does not use profiles in PNG or TIFF files. 

Channels and bit depth 

About color channels 
A working knowledge of color channels and bit depth is key to understanding how Photoshop stores and displays 

color information in images. Every Photoshop image has one or more channels, each storing information about color 

elements in the image. The number of default color channels in an image depends on its color mode. For example, a 

CMYK image has at least four channels, one each for cyan, magenta, yellow, and black information. Think of a 

channel as analogous to a plate in the printing process, with a separate plate applying each layer of color. 

In addition to these default color channels, extra channels, called alpha channels, can be added to an image for storing 

and editing selections as masks, and spot color channels can be added to add spot color plates for printing. 

An image can have up to 56 channels. By default, bitmap, grayscale, duotone, and indexed-color images have one 

channel; RGB and Lab images have three; and CMYK images have four. You can add channels to all image types 

except Bitmap mode images. 

See also 

“About masks and alpha channels” on page 338 

“About spot colors” on page 442 

About bit depth 
Bit depth—also called pixel depth or color depth—measures how much color information is available for displaying 

or printing each pixel in an image. 
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Greater bit depth (more bits of information per pixel) means more available colors and more accurate color repre

sentation in the digital image. For example, a pixel with a bit depth of 1 has two possible values: black and white. A 

pixel with a bit depth of 8 has 28, or 256, possible values. And a pixel with a bit depth of 24 has 224, or roughly 16 

million, possible values. Common values for bit depth range from 1 to 64 bits per pixel. 

A B 

C D 

Pixel depth 
A. 1-bit (Bitmap) B. 8-bit (Grayscale) C. 8-bit (Indexed Color) D. 24-bit (RGB) 

In most cases, Lab, RGB, grayscale, and CMYK images contain 8 bits of data per color channel. This translates to a 

24-bit Lab bit depth (8 bits x 3 channels), a 24-bit RGB bit depth (8 bits x 3 channels), an 8-bit grayscale bit depth (8 

bits x 1 channel), and a 32-bit CMYK bit depth (8 bits x 4 channels). Photoshop can also work with Lab, RGB, CMYK, 

multichannel, and grayscale images that contain 16 bits of data per color channel. Additionally, Photoshop can work 

with RGB and grayscale images that contain 32 bits of data per color channel. 

See also 

“About High Dynamic Range images” on page 201 

Converting between bit depths 
A 16- or 32-bits-per-channel image provides finer distinctions in color (but larger file size) than an 8-bits-per-

channel version of the same image. 

Photoshop provides the following support for working with 16-bits-per-channel images: 

• All tools in the toolbox, except the Art History Brush tool, can be used with 16-bits-per-channel images. 

• All color and tonal adjustment commands, except Variations, are available. 

• You can work with layers, including adjustment layers, in 16-bits-per-channel images. 

• Some filters, including Liquify, can be used with 16-bits-per-channel images. 

To take advantage of certain Photoshop features, such as Extract, Pattern Maker, and some filters, you can convert a 

16-bits-per-channel image to an 8-bits-per-channel image. It’s best if you do a Save As and convert a copy of the 

image file so the original file retains the full 16-bits-per-channel image data. 

Photoshop provides the following support for working with 32-bits-per-channel images: 
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•	 Crop with rotation and resize 

•	 Fill and stroke (no pattern fill, supported blend modes only) 

•	 Image Size and Canvas Size commands 

•	 Trim command 

•	 Arbitrary rotation and 90˚ rotation and flips 

•	 Blend modes: Normal, Multiply, Difference, Lighten, Darken, Linear Dodge 

•	 Free Transform command 

•	 The following tools in the toolbox: Clone Stamp tool (supported blend modes only), and History Brush (supported 

blend modes only) 

•	 Display of floating-point values in the Info palette 

•	 Conversion to 8- or 16-bits-per-channel documents, and conversion from 16-bits-per-channel to 32-bits-per-

channel 

•	 Conversion between RGB and Grayscale modes 

•	 Support of the following file formats: PSD/PSB, TIFF, LogLUV TIFF (read-only), Radiance HDR, PFM, OpenEXR 

•	 Support for the following image adjustment commands: Channel Mixer, Photo Filter, and Exposure. 

•	 Support for the following plug-in filters: Average, Radial Blur, Fibers, Lens Flare, DeInterlace, and NTSC Colors 

•	 Support for the following built-in filters: Surface Blur, Box Blur, Gaussian Blur, Motion Blur, Sampled/Shape Blur, 

Add Noise, Unsharp Mask, High Pass, Offset 

•	 Save Selection and Load Selection commands 

To work with certain Photoshop features, such as layers, filters, and adjustments, you can convert a 32-bits-per-

channel image to a 16-bits-per-channel image. Do a Save As and convert a copy of the image file so that the original 

file retains the full 32-bits-per-channel image data. 

Note: It’s also possible to convert a 32-bits-per-channel image to 8 bits per channel. See “To convert from 32 bits to 8 or 

16 bits per channel” on page 205. 

See also 

“About High Dynamic Range images” on page 201 

To convert between 8 bits and 16 bits per channel 
❖ Choose Image > Mode > 16 Bits/Channel or 8 Bits/Channel. 

To convert from 16 bits to 32 bits per channel 
1 Open a 16-bit image. If necessary, flatten the image. Only flat images can be converted to 32-bits-per-channel 

mode. 

2 Choose Image > Mode > 32 Bits/Channel. 

Note: It’s also possible to convert a 32-bits-per-channel image to 8-bits-per-channel. See “To convert from 32 bits to 8 or 

16 bits per channel” on page 205. 
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See also 

“About High Dynamic Range images” on page 201 

Converting between color modes 

Converting an image to another mode 
You can change an image from its original mode (source mode) to a different mode (target mode). When you choose 

a different color mode for an image, you permanently change the color values in the image. For example, when you 

convert an RGB image to CMYK mode, RGB color values outside the CMYK gamut (defined by the CMYK working 

space setting in the Color Settings dialog box) are adjusted to fall within gamut. As a result, some image data may be 

lost and can’t be recovered if you convert the image from CMYK back to RGB. 

Before converting images, it’s best to do the following: 

•	 Do as much editing as possible in the original image mode (usually RGB for images from most scanners or digital 

cameras, or CMYK for images from traditional drum scanners or imported from a Scitex system). 

•	 Save  a backup copy before converting.  Be  sure  to  save  a copy of your image  that  includes  all layers so that you  can  

edit the original version of the image after the conversion. 

•	 Flatten the file before converting it. The interaction of colors between layer blending modes changes when the 

mode changes. 

To convert an image to another mode 
❖ Choose  Image  >  Mode  and the  mode  you want from the  submenu.  Modes not  available for  the active image  appear  

dimmed in the menu. 

Images are flattened when converted to Multichannel, Bitmap, or Indexed Color mode, because these modes do not 

support layers. 

Making a conditional mode change 
You can specify conditions for a mode change so that the conversion can occur during an action, which  is  a series of  

commands  applied sequentially to a single  file  or  a batch  of  files.  When  a mode change is part of an action,  an  error  

can occur if the file being opened is not in the source mode specified in the action. For example, suppose one step in 

an action is to convert an image with a source mode of RGB to a target mode of CMYK. Applying this action to an 

image in Grayscale mode, or any other source mode besides RGB, results in an error. 

When you record an action, you can use the Conditional Mode Change command to specify one or more modes for 

the source mode and a mode for the target mode. 

To add a conditional mode change to an action

1 Start recording an action.


2 Choose File > Automate > Conditional Mode Change.


3 In the Conditional Mode Change dialog box, select one or more modes for the source mode. You can also use the


All or None buttons to select all possible modes or no mode.
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4 Choose a target mode from the Mode pop-up menu.


5 Click OK. The conditional mode change appears as a new step in the Actions palette.


See also 

“About actions” on page 729


To convert a color photo to black-and-white

1 Open the photo you want to convert to black-and-white.


2 Choose Image > Mode > Grayscale.


3 If asked to discard color info, click OK. Photoshop converts the colors in the image to black, white, and shades of


gray.


See also 

“To create monochrome images from RGB or CMYK images” on page 305 

“To colorize a grayscale image or create a monotone effect” on page 297 

Converting images to Bitmap mode 
Converting an image to Bitmap mode reduces the image to two colors, greatly simplifying the color information in 

the image and reducing its file size. 

When converting a color image to Bitmap mode, first convert it to Grayscale mode. This removes the hue and 

saturation information from the pixels and leaves just the brightness values. However, because only a few editing 

options are available for Bitmap mode images, it’s usually best to edit the image in Grayscale mode and then convert 

it to Bitmap mode. 

Note: Images in Bitmap mode are 1 bit per channel. You must convert a 16- or 32-bits-per-channel image to 8-bit 

Grayscale mode before converting it to Bitmap mode. 

To convert an image to Bitmap mode 
1 Do one of the following: 

• If the image is in color, choose Image > Mode > Grayscale. Then choose Image > Mode > Bitmap. 

• If the image is grayscale, choose Image > Mode > Bitmap. 

2 For Output,  enter a value for  the output resolution of the  Bitmap  mode  image,  and choose a unit  of  measurement. 


By default, the current image resolution appears as both the input and the output resolutions.


3 Choose one of the following bitmap conversion methods from the Use pop-up menu:


50% Threshold Converts pixels with gray values above the middle gray level (128) to white and pixels with gray


values below that level to black. The result is a very high-contrast, black-and-white representation of the image. 

Pattern Dither Converts an image by organizing the gray levels into geometric configurations of black and white 

dots. 

Diffusion Dither Converts an image by using an error-diffusion process, starting at the pixel in the upper left corner 

of the image. If the pixel’s value is above middle gray (128), the pixel is changed to white—if below it, to black. 

Because the original pixel is rarely pure white or pure black, error is inevitably introduced. This error is transferred 
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to surrounding pixels and diffused throughout the image, resulting in a grainy, filmlike texture. This option is useful


for viewing images on a black-and-white screen.


Halftone Screen Simulates the appearance of halftone dots in the converted image.


Custom Pattern Simulates the appearance of a custom halftone screen in the converted image.


Original grayscale image, and 50% Threshold conversion method 

Pattern Dither conversion method, and Diffusion Dither conversion method 

To convert a Bitmap mode image to Grayscale mode 
You can convert a Bitmap mode image to Grayscale mode in order to edit it. Keep in mind that a Bitmap mode image 

edited  in  Grayscale mode may  not look the  same  when  you convert  it  back  to  Bitmap  mode. For  example,  suppose a  

pixel that is black  in  Bitmap  mode  is  edited  to  a shade  of  gray  in  Grayscale mode.  When  the image  is  converted back  

to Bitmap mode, that pixel is rendered as white if its gray value is above the middle gray value of 128. 

1 Choose Image > Mode > Grayscale. 

2 Enter a value between 1 and 16 for the size ratio. 

The size ratio is the factor for scaling down the image. For example, to reduce a grayscale image by 50%, enter 2 for 

the size ratio. If you enter a number greater than 1, the program averages multiple pixels in the Bitmap mode image 

to  produce a single  pixel in the  grayscale image. This process  lets  you generate multiple shades of gray from an image  

scanned on a 1-bit scanner. 

Specifying the halftone screen for Bitmap mode images 
The Halftone Screen option in the Bitmap dialog box lets you convert a grayscale image to simulated halftone dots. 

Important: The halftone screen becomes  part  of  the image. If you  print the  image on a halftone  printer,  the printer  will  

use its  own halftone screen as well as the  halftone  screen  that  is  part  of  the image. On some printers,  the result is a moiré  

pattern. 
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To specify the halftone screen for Bitmap mode images 
1 Choose Image > Mode > Bitmap. 

2 Choose Halftone Screen from the Use menu; then click OK. The Halftone Screen dialog box opens. 

3 For Frequency, enter a value for the screen frequency, and choose a unit of measurement. Values can range from 

1 to 999 for lines per inch and from 0.400 to 400 for lines per centimeter. You can enter decimal values. 

The screen frequency specifies the ruling of the halftone screen in lines per inch (lpi). The frequency depends on the 

paper stock and type of press used for printing. Newspapers commonly use an 85-line screen. Magazines use higher 

resolution screens, such as 133-lpi and 150-lpi. Check with your print shop for correct screen frequencies. 

4 Enter a value for the screen angle in degrees from –180 to +180. 

The screen angle refers to the orientation of the screen. Continuous-tone and black-and-white halftone screens 

commonly use a 45˚ angle. 

5 For Shape, choose the dot shape you want. 

Original grayscale image, and Halftone Screen conversion: 53 lpi, 45˚ angle, round dot 

You can save and reuse halftone screen settings by using the Save and Load buttons in the Halftone Screen dialog box. 

Specifying custom halftone screens for Bitmap mode images 
The Custom Pattern option in the Bitmap dialog box simulates the effect of printing a grayscale image through a 

custom halftone screen. This method lets you apply a screen texture, such as a wood grain, to an image. To use this 

option, you must first define a pattern. 

You can create a pattern representing the texture you want and then screen the grayscale image to apply the texture. 

To cover the entire image, the pattern must be as large as the image. Otherwise, the pattern is tiled. For example, if 

you apply a 1-inch-by-1-inch pattern to a 4-inch-by-4-inch image, the pattern appears as 16 squares. Photoshop 

comes with several self-tiling patterns that can be used as halftone screen patterns. 

Because the Custom Pattern option simulates dark and light colors by making the halftone pattern thicker and 

thinner, it makes sense to choose a pattern that lends itself to thickness variations, typically one with a variety of gray 

shades. 

To prepare a black-and-white pattern for conversion, you can first convert the image to grayscale and then apply the 

Blur More filter several times. This blurring technique creates thick lines tapering from dark gray to white. 

See also 

“To fill a selection or a layer with a foreground or background color” on page 498 
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Converting to indexed color 

Converting to indexed color 
Converting to indexed color reduces the number of colors in the image to at most 256—the standard number of 

colors supported by the GIF and PNG-8 formats and many multimedia applications. This conversion reduces file size 

by deleting color information from the image. 

To convert to indexed color, you must start with an image that is 8 bits per channel and in either Grayscale or RGB 

mode. 

To convert a grayscale or RGB image to indexed color 
1 Choose Image > Mode > Indexed Color. 

Note: All visible layers will be flattened; any hidden layers will be discarded. 

For grayscale images, the conversion happens automatically. For RGB images, the Indexed Color dialog box appears. 

2 Select Preview in the Indexed Color dialog box to display a preview of the changes. 

3 Specify conversion options. 

See also 

“Conversion options for indexed-color images” on page 238 

Conversion options for indexed-color images 
When converting an RGB image to indexed color, you can specify a number of conversion options in the Indexed 

Color dialog box. 

Palette Type A number of palette types are available for converting an image to indexed color. For the Perceptual, 

Selective, and Adaptive options, you can choose using a local palette based on the current image’s colors. It’s also 

possible to use a master palette that was created in ImageReady. These are the available palette types: 

• Exact Creates a palette using the exact colors appearing in the RGB image—an option available only if the image 

uses 256 or fewer colors. Because the image’s palette contains all colors in the image, there is no dithering. 

• System (Mac OS) Uses the Mac OS default 8-bit palette, which is based on a uniform sampling of RGB colors. 

• System (Windows) Uses the Windows system’s default 8-bit palette, which is based on a uniform sampling of RGB 

colors. 

• Web Uses the 216-color palette that web browsers, regardless of platform, use to display images on a monitor 

limited to 256 colors. This palette is a subset of the Mac OS 8-bit palette. Use this option to avoid browser dither when 

viewing images on a monitor display limited to 256 colors. 

• Uniform Creates a palette by uniformly sampling colors from the RGB color cube. For example, if Photoshop takes 

six evenly spaced color levels each of red, green, and blue, the combination produces a uniform palette of 216 colors 

(6 cubed = 6 x 6 x 6 = 216). The total number of colors displayed in an image corresponds to the nearest perfect cube 

(8, 27, 64, 125, or 216) that is less than the value in the Colors text box. 

• Local (Perceptual) Creates a custom  palette by giving priority to colors for  which the  human eye  has greater  sensi

tivity. 
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• Local (Selective) Creates a color table similar to the Perceptual color table, but favoring broad areas of color and 

the preservation of web colors. This option usually produces images with the greatest color integrity. 

• Local (Adaptive) Creates a palette by sampling the colors from the spectrum appearing most commonly in the 

image. For example, an RGB image with only the colors green and blue produces a palette made primarily of greens 

and blues. Most images concentrate colors in particular areas of the spectrum. To control a palette more precisely, 

first select a part  of  the image  containing  the colors you  want  to  emphasize.  Photoshop weights  the conversion toward  

these colors. 

• Custom Creates a custom  palette using  the Color  Table dialog box. Either edit the  color table  and save it for  later  

use or click  Load  to  load  a previously created  color table. This option also displays the  current Adaptive palette,  which  

is useful for previewing the colors most often used in the image. 

• Previous Uses the custom palette from the previous conversion, making it easy to convert several images with the 

same custom palette. 

Number Of Colors For the Uniform, Perceptual, Selective, or Adaptive palette, you can specify the exact number of 

colors to be displayed (up to 256) by entering a value for Colors. The Colors text box controls only how the indexed 

color table is created. Adobe Photoshop still treats the image as an 8-bit, 256-color image. 

Color Inclusion And Transparency To specify colors to be included in the indexed color table or to specify trans

parency in the image, choose from the following options: 

• Forced Provides options to force the inclusion of certain colors in the color table. Black And White adds a pure 

black and a pure white to the color table; Primaries adds red, green, blue, cyan, magenta, yellow, black, and white; 

Web adds the 216 web-safe colors; and Custom lets you define custom colors to add. 

• Transparency Specifies whether to preserve transparent areas of the image during conversion. Selecting this 

option adds a special index entry in the color table for transparent colors. Deselecting this option fills transparent 

areas with the matte color, or with white if no matte color is chosen. 

• Matte Specifies the background color used to fill anti-aliased edges that lie adjacent to transparent areas of the 

image. When Transparency is selected, the matte is applied to edge areas to help blend the edges with a web 

background of the same color. When Transparency is deselected, the matte is applied to transparent areas. Choosing 

None for the matte creates hard-edged transparency if Transparency is selected; otherwise, all transparent areas are 

filled with 100% white. The image must have transparency for the Matte options to be available. 

Dithering Unless you’re using the Exact color table option, the color table may not contain all the colors used in the 

image. To simulate colors not in the color table, you can dither the colors. Dithering mixes the pixels of the available 

colors to simulate the missing colors. Choose a dither option from the menu, and enter a percentage value for the 

dither amount. A higher amount dithers more colors but may increase file size. You can choose from the following 

dither options: 

• None Does not dither colors but instead uses the color closest to the missing color. This tends to result in sharp 

transitions between shades of color in the image, creating a posterized effect. 

• Diffusion Uses an error-diffusion method that produces a less structured dither than the Pattern option. To 

protect colors in the image that contain entries in the color table from being dithered, select Preserve Exact Colors. 

This is useful for preserving fine lines and text for web images. 

• Pattern Uses a halftone-like square pattern to simulate any colors not in the color table. 

• Noise Helps to reduce seam patterns along the edges of image slices. Choose this option if you plan to slice the 

image for placement in an HTML table. 
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Customizing indexed color tables 
The Color Table command lets you make changes to the color table of an indexed-color image. These customization 

features are particularly useful with pseudocolor images—images displaying variations in gray levels with color rather 

than shades of gray, often used in scientific and medical applications. However, customizing the color table can also 

produce special effects with indexed-color images that have a limited number of colors. 

Note: To shift colors simply in a pseudocolor image, choose Image > Adjustments, and use the color adjustment 

commands in the submenu. 

To edit colors and assign transparency with a color table 
You can edit colors in the color table to produce special effects, or assign transparency in the image to a single color


in the table.


1 Open the indexed-color image.


2 Choose Image > Mode > Indexed Color.


3 In the Indexed Color dialog box, choose Custom from the Palette menu.


4 In  the Color  Table dialog box, click  or  drag in the  table to choose the  color or range  of  colors  you want to change. 


5 Choose a color and click OK.


If you are changing a range of colors, Photoshop creates a gradient in the color table between the starting and ending


colors. The first color you choose in the Color Picker is the beginning color for the range. When you click OK, the


Color Picker reappears so that you can choose the last color in the range.


The colors you selected in the Color Picker are placed in the range you selected in the Color Table dialog box.


6 Click OK in the Color Table dialog box to apply the new colors to the indexed-color image.


7 Click OK in the Indexed Color dialog box.


To assign transparency to a single color

1 Open the indexed-color image.


2 Choose Image > Mode > Indexed Color.


3 In the Indexed Color dialog box, choose Custom from the Palette menu. This opens the Color Table dialog box.


4 In the Color Table dialog box, select the Eyedropper tool
 , and click the desired color in the table or in the 

image. The sampled color is replaced with transparency in the image. 

Predefined color tables 
Your indexed color table can be modeled after the following predefined color tables: 

Custom Creates a palette you specify. 

Black Body Displays a palette based on the different colors a black body radiator emits as it is heated—from black 

to red, orange, yellow, and white. 

Grayscale Displays a palette based on 256 levels of gray—from black to white. 

Spectrum Displays a palette based on the colors produced as white light passes through a prism—from violet, blue, 

and green to yellow, orange, and red. 
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System (Mac OS) Displays the standard Mac OS 256-color system palette. 

System (Windows) Displays the standard Windows 256-color system palette. 

To choose a predefined table 
1 Open the indexed-color image. 

2 Do one of the following: 

•	 Choose Image > Mode > Color Table. 

•	 Choose Image > Mode > Indexed Color. In the Indexed Color dialog box, choose Custom from the Palette menu. 

This opens the Color Table dialog box. 

3	 In the Color Table dialog box, choose a predefined table from the Table menu. 

Saving and loading color tables 
You use  the Save and  Load  buttons in the  Color Table  dialog  box to save your indexed  color tables for  use with other  

Adobe Photoshop images. The color tables and swatch tables can also be loaded by ImageReady. After you load a 

color table into an image, the colors in the image change to reflect the color positions they reference in the new color 

table. 

Note: You can also load saved color tables into the Swatches palette. 

See also 

“About the Swatches palette” on page 506 

Choosing colors 

About the Adobe Color Picker 
You select a color in the Adobe Color Picker either by choosing from a color spectrum or by defining the color 

numerically. Through the Adobe Color Picker, you can set the foreground color, background color, and text color. In 

Photoshop, you can also use the Color Picker to set target colors in some color and tonal adjustment commands, the 

stop colors in the Gradient Editor, the filter color in the Photo Filter command, and the color in a fill layer, certain 

layer styles, and shape layers. 

When  you select a color in the  Adobe Color  Picker, it simultaneously displays the  numeric values for  HSB,  RGB,  Lab,  

CMYK, and hexadecimal numbers. This is useful for viewing how the different color modes describe a color. 

In the Adobe Color Picker, you can select colors based on the HSB (hue, saturation, brightness) or RGB (red, green, 

blue) color models, or specify a color based on its hexadecimal values. In Photoshop, you can also select colors based 

on the Lab color model, and on the CMYK (cyan, magenta, yellow, black) color model. You can configure the Adobe 

Color Picker so that you can choose only from web-safe colors or choose from several custom color systems. The 

color field in the Adobe Color Picker can display color components in HSB color mode, RGB color mode, and 

(Photoshop) Lab color mode. 

 



242 ADOBE PHOTOSHOP CS2 
User Guide 

Note: Although Photoshop and ImageReady use the Adobe Color Picker by default, you can set a preference to have 

Photoshop and ImageReady use a different color picker. For instance, you can use the built-in color pickers on your 

system or a plug-in color picker. Any plug-in color pickers you install appear under Color Picker in the General section 

of the Preferences dialog box. 

C DA B E 

F G H I 

Adobe Color Picker 
A. Picked color B. Original color C. Adjusted color D. Out-of-gamut alert icon E. Not web-safe alert icon F. Web Colors 
option G. Color field H. Color slider I. Color values 

To display the Adobe Color Picker 
Do one of the following: 

•	 In the toolbox, click the foreground or background color selection box. 

•	 In the Color palette, click the Set Foreground Color or Set Background Color selection box. 

•	 In the text tool options bar, click the color swatch. 

•	 (Photoshop) In the Layers palette, click the color swatch in a fill or shape layer. 

•	 (Photoshop) In the Gradient Editor, double-click a color stop. 

•	 (Photoshop) In the options bar of a shape or pen tool, click the color swatch. 

•	 (Photoshop) In the Layer Style dialog box for certain layer styles (such as Outer Glow and Inner Glow), click the 

Set Color box. 

•	 (Photoshop) In the dialog box of certain color and tonal adjustment commands, double-click an eyedropper or 

click a color swatch. Not every eyedropper lets you set a target color. For instance, double-clicking the eyedroppers 

in the Replace Color command does not open the Adobe Color Picker. 

Specifying a color using the color field and color slider 
With  the HSB, RGB, and  Lab color  modes,  you can  use the  color field  and the  color slider in the  Color Picker dialog  

box to select a color. 
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Note: The Lab color mode is available only in Photoshop. 

1 Click a component next to the HSB, RGB, or Lab values. 

2 Select a color by doing one of the following: 

•	 Drag the white triangles along the slider.


•	 Click in the color slider.


• Click in the color field.


When you select a color, a circular marker indicates the color’s position in the color field.


As  you adjust the  color using  the color  field and  color slider,  the numerical  values  are adjusted accordingly.  The color  

rectangle to the right of the color slider displays the new color in the top section of the rectangle. The original color 

appears at the bottom of the rectangle. Alerts appear if the color is not web-safe  or is (Photoshop) out of 

gamut . 

You can select a color outside the Adobe Color Picker. Moving the pointer over the document window changes it to 

the Eyedropper tool. You can then select a color by clicking in the image. The selected color is displayed in the Adobe 

Color Picker. You can move the Eyedropper tool anywhere on your desktop by clicking in the image and then holding 

down the mouse button. You can select a color by releasing the mouse button. 

See also 

“Web-safe colors” on page 245 

To specify a color using numeric values 
In the Adobe Color Picker, you can select a color in any of the four color models by specifying numeric values for 

each color component. 

Do one of the following: 

•	 (Photoshop) In CMYK color mode (the mode PostScript printers use), specify each component value as a 

percentage of cyan, magenta, yellow, and black. 

•	 In RGB color mode (the mode your monitor uses), specify component values from 0 to 255 (0 is black, and 255 is 

the pure color). 

•	 In HSB color mode, specify saturation and brightness as percentages; specify hue as an angle from 0˚ to 360˚ that 

corresponds to a location on the color wheel. 

•	 Enter a hexadecimal value in the # text box. For example, 000000 is black, ffffff is white, and ff0000 is red. 

•	 (Photoshop) In Lab mode, enter a lightness value (L) from 0 to 100, and an A value (green to magenta) and a B 

value(blue to yellow) from -128 to +127. 

 



244 ADOBE PHOTOSHOP CS2 
User Guide 

To use the Adobe Color Picker in HSB mode 
The Adobe Color Picker lets you select a color based on the HSB (hue, saturation, brightness) color model. When


you select a color in HSB mode, the Adobe Color Picker updates the RGB, Lab, CMYK, and hexadecimal values


accordingly. HSB mode is the default mode for the Adobe Color Picker.


1 Open the Adobe Color Picker.


2 In the HSB section of the dialog box, do one of the following:


•	 Click the  H option to display  all hues in the  color slider.  When  you select a hue in the  slider, the  color field  displays  

the saturation and brightness range of that hue, with the saturation increasing from left to right and the brightness 

increasing from bottom to top. 

•	 Click the S option to display all hues in the color field, with their maximum brightness at the top of the color field 

and their minimum at the bottom. The color slider displays the color that’s selected in the color field, with its 

maximum saturation at the top of the slider and its minimum saturation at the bottom. 

•	 Click the B option to display all hues in the color field, with their maximum saturation at the top of the color field 

and their minimum saturation at the bottom. The color slider displays the color that’s selected in the color field, 

with its maximum brightness at the top of the slider and its minimum brightness at the bottom. 

3 Select a color with a specific hue, saturation, and brightness by using a combination of the color slider and the 

color field or entering a numeric values in the H, S, and B text boxes. 

To work with the Adobe Color Picker in RGB mode 
In RGB (red, green, blue) mode, the color slider displays the range of color levels available for the selected color


component (R, G, or B). The color field displays the range for the remaining two components—one on the horizontal


axis, one on the vertical. For example, if you click the red component (R), the color slider displays the range of color


for red (0 is at the bottom of the slider, and 255 is at the top). The color field displays the values for blue on its


horizontal axis and for green on its vertical axis.


1 Open the Adobe Color Picker.


2 In the RGB section of the dialog box, do one of the following:


•	 Click the R option to display the red color component in the color slider, with its maximum brightness (255) at 

the top of the slider and its minimum brightness (0) at the bottom. When you set the color slider to minimum 

brightness, the color field displays colors created by the green and blue color components. Using the color slider 

to increase the red brightness mixes more red into the colors displayed in the color field. 

•	 Click the G option to display the green color component in the color slider, with its maximum brightness (255) at 

the top of the slider and its minimum brightness (0) at the bottom. When you set the color slider to minimum 

brightness, the color field displays colors created by the red and blue color components. Using the color slider to 

increase the green brightness mixes more green into the colors displayed in the color field. 

•	 Click the B option to display the blue color component in the color slider, with its maximum brightness (255) at 

the top of the slider and its minimum brightness (0) at the bottom. When you set the color slider to minimum 

brightness, the color field displays colors created by the green and red color components. Using the color slider to 

increase the blue brightness mixes more blue into the colors displayed in the color field. 

3 Select an RGB color using a combination of the color slider and the color field or entering numeric values in the 

R, G, and B text boxes. 
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To work with the Adobe Color Picker in Lab mode 
The Adobe  Color Picker lets  you select a color based  on  the Lab  color model. The  L value  specifies the  luminance of 


a color. The A value specifies how red or green a color is. The B value specifies how blue or yellow a color is.


1 Open the Adobe Color Picker.


2 In the Lab section of the dialog box, do one of the following:


•	 Click the L option to display all hues in the color field. You select a hue by either clicking in the color field or 

entering values in the A and B text boxes. The color slider displays the selected hue, with its maximum luminance 

at the top and its minimum luminance at the bottom. 

•	 Click the A option. Move the color slider to adjust the amount of red or green. Moving the slider or clicking in the 

color slider changes the range of colors displayed in the color field. The color field also displays the luminance, 

with maximum luminance at the top and minimum luminance at the bottom. The B (blue or yellow) color 

component is represented in the color field with blue on the left and yellow on the right. 

•	 Click the B option. Move the color slider to adjust the amount of yellow or blue. Moving the slider or clicking in 

the color slider changes the range of colors displayed in the color field. The color field also displays the luminance 

on the vertical axis, with maximum luminance at the top and minimum luminance at the bottom. The A (green 

or red) color component is represented in the color field with green on the left and red on the right. 

3 Select a color using a combination of the color slider and the color field or entering numeric values in the L, A, 

and B text boxes. 

Web-safe colors 
The web-safe colors are the 216 colors used by browsers regardless of the platform. The browser changes all colors in 

the image to these colors when displaying the image on an 8-bit screen. The 216 colors are a subset of the Mac OS 

8-bit color palettes. By working only with these colors, you can be sure that art you prepare for the web will not dither 

on a system set to display 256 colors. 

To select web-safe colors in the Adobe Color Picker 
❖ Select the Only Web Colors option in the lower left corner of the Color Picker. Any color you pick with this option 

selected is web-safe. 

To change a nonweb color to a web-safe color 
If you select a nonweb color, an alert cube  appears next to the color rectangle in the Adobe Color Picker. 

❖ Click the alert cube to select the closest web color. (If no alert cube appears, the color you chose is web-safe.)


To select a web-safe color using the Color palette

1 Click the Color palette tab, or choose Window > Color to view the Color palette.


2 Choose an option for selecting a web-safe color:


•	 Choose Make Ramp Web Safe from the Color palette menu. Any color you pick with this option selected is web

safe. 

•	 Choose Web Color Sliders from the Color palette menu (Photoshop), or choose any Slider option from the Color 

palette menu (ImageReady). By default, web color sliders snap to web-safe colors (indicated by tick marks) when 

you drag them. To override web-safe color selection, Alt-drag (Windows) or Option-drag (Mac OS) the sliders. 
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If you choose a nonweb color, an alert cube

Click the alert cube to select the closest web color.

 appears above the color ramp on the left side of the Color palette. 

In ImageReady, drag around the alert icon to select other close web colors. (If no alert cube appears, the color you 

chose is web-safe.) 

Note: In Photoshop, you must choose Web Color Sliders from the Color palette menu to view the web-safe alert cube. In 

ImageReady, you can view the alert cube with any color slider option. 

To select the closest CMYK equivalent for a nonprintable color 
Some colors in the RGB, HSB, and Lab color models, such as neon colors, cannot be printed because they have no 

equivalents in the CMYK model. When you select a nonprintable color, an alert triangle appears in the Color Picker 

dialog box and in the Color palette. The closest CMYK equivalent is displayed below the triangle. 

Note: The alert triangle is not available if you are using web-safe sliders. 

Click the alert triangle  that appears in the Color Picker dialog box or the Color palette. 

Printable colors are determined by your current CMYK working space as defined in the Color Settings dialog box. 

See also 

“About out-of-gamut colors” on page 283 

Choosing custom colors 
The Adobe Color Picker lets you choose custom colors from the Pantone® Matching System®, the Trumatch® 

Swatching System™, the Focoltone® Colour System, the Toyo Color Finder™ 1050 system, the ANPA-Color™ system, 

the HKS® color system, and the DIC Color Guide. 

To ensure that the final printed output is the color you want, consult your printer or service bureau and choose your 

custom color based on a printed color swatch. Manufacturers recommend that you get a new swatch book each year 

to compensate for fading inks and other damage. 

Important: Photoshop prints custom colors to CMYK (process color) plates in every image mode except Duotone. To 

print true spot color plates, create spot color channels. 

See also 

“About spot colors” on page 442


To choose a custom color

1 Open the Adobe Color Picker, and click Color Libraries.


The Custom Colors dialog box displays the color closest to the color currently selected in the Adobe Color Picker.


2 For Book, choose a color system.


3 Locate the color you want by entering the ink number or by dragging the triangles along the scroll bar.


4 Click the desired color patch in the list.
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Custom color systems 
The Adobe Color Picker supports various color systems: 

ANPA-COLOR Commonly used for newspaper applications. The ANPA-COLOR ROP Newspaper Color Ink Book 

contains samples of the ANPA colors. 

DIC Color Guide Commonly used for printing projects in Japan. For more information, contact Dainippon Ink & 

Chemicals, Inc., in Tokyo, Japan. 

FOCOLTONE Consists of 763 CMYK colors. Focoltone colors help avoid prepress trapping and registration problems 

by showing the overprints that make up the colors. A swatch book with specifications for process and spot colors, 

overprint charts, and a chip book for marking up layouts are available from Focoltone. For more information, contact 

Focoltone International, Ltd., in Stafford, United Kingdom. 

HKS swatches Used for printing projects in Europe. Each color has a specified CMYK equivalent. You can select 

from HKS E (for continuous stationery), HKS K (for gloss art paper), HKS N (for natural paper), and HKS Z (for 

newsprint). Color samplers for each scale are available. HKS Process books and swatches have been added to the 

color system menu. 

PANTONE Pantone® colors are used for spot-color reproduction. The Pantone System can render 1114 colors. 

Pantone Color guides and chip books are printed on coated, uncoated, and matte paper stocks to ensure accurate 

visualization of the printed result and better on-press control. You can print a solid Pantone color in CMYK. To 

compare a solid Pantone  color to its  closest process  color match, use  the  Pantone Solid to Process guide. The CMYK 

screen tint percentages are printed under each color. For more information, contact Pantone, Inc., in Carlstadt, NJ 

(www.pantone.com). 

TOYO Color Finder 1050 Consists of more than 1000 colors based on the most common printing inks used in Japan. 

The TOYO Process Color Finder book and swatches have been added to the color system menu. The TOYO Color 

Finder 1050 Book contains printed samples of Toyo colors and is available from printers and graphic arts supply 

stores. For more information, contact Toyo Ink Manufacturing Co., Ltd., in Tokyo, Japan. 

TRUMATCH Provides predictable CMYK color matching with more than 2000 achievable, computer-generated 

colors. Trumatch colors cover the visible spectrum of the CMYK gamut in even steps. The Trumatch Color displays 

up to 40 tints and shades of each hue, each originally created in four-color process and each reproducible in four 

colors on electronic imagesetters. In addition, four-color grays using different hues are included. For more infor

mation, contact Trumatch Inc., in New York City, New York. 

To use the Windows Color Picker 
(Windows only) 

1 Choose Edit > Preferences > General.


2 Choose Windows from the Color Picker menu, and click OK.


For more information, see your Windows documentation.
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To use the Apple Color Picker 
(Mac OS only) 

1 Do one of the following: 

• (Photoshop) Choose Photoshop > Preferences > General. 

• (ImageReady) Choose ImageReady > Preferences > General. 

2 For Color Picker, do one of the following: 

• (Photoshop) Choose Apple and click OK. 

• (ImageReady) Choose System, and click OK. 

For more information, see your Mac OS documentation. 

To return to the Adobe Color Picker after using another color picker 
1 Do one of the following: 

• In Windows, choose Edit > Preferences > General. 

• (Photoshop) In Mac OS, choose Photoshop > Preferences > General. 

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General. 

2 Choose Adobe from the Color Picker menu, and click OK. 

Using the color wheel 
If you’re new to adjusting color components, it helps to keep a diagram of the standard color wheel on hand when 

you work on color  balance.  You can  use the  color wheel  to  predict how  a change in one  color component  affects other  

colors and also how changes translate between RGB and CMYK color models. 
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Color wheel 
R. Red Y. Yellow G. Green C. Cyan B. Blue M. Magenta 

For example, you can decrease the amount of any color in an image by increasing the amount of its opposite on the 

color wheel—and vice versa. Colors that lie opposite each other on the standard color wheel are known as comple

mentary colors. Similarly, you can increase and decrease a color by adjusting the two adjacent colors on the wheel, 

or even by adjusting the two colors adjacent to its opposite. 
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In a CMYK image, you can decrease magenta either by decreasing the amount of magenta or by increasing its 

complement (by adding cyan and yellow). You can even combine these two corrections, minimizing their effect on 

overall lightness. In an RGB image, you can decrease magenta by removing red and blue or by adding green. All of 

these adjustments result in an overall color balance containing less magenta. 
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Chapter 10: Color management


Understanding color management 

Why colors sometimes don’t match 
No device in a publishing system is capable of reproducing the full range of colors viewable to the human eye. Each 

device operates within a specific color space which can produce a certain range, or gamut, of colors. 

A color  model determines the  relationship  between values,  and the  color space  defines the  absolute  meaning of those  

values as colors. Some color models have a fixed color space (such as Lab) because they relate directly to the way 

humans perceive color. These models are described as being device-independent. Other color models (RGB, HSL, 

HSB, CMYK, and so forth) can have many different color spaces. Because these models vary with each associated 

color space or device, they are described as being device-dependent. 

Because of these varying color spaces, colors can shift in appearance as you transfer documents between different 

devices. Color variations can result from differences in image sources (scanners and software produce art using 

different color spaces); brands of computer monitors; the way software applications define color; print media 

(newsprint paper reproduces a smaller gamut than magazine-quality paper); and other natural variations, such as 

manufacturing differences in monitors or monitor age. 

RGB 

A B 

C 

CMYK 

Color gamuts of various devices and documents 
A. Lab color space B. Documents (working space) C. Devices 

What is a color management system? 
Color-matching problems result from various devices and software using different color spaces. One solution is to 

have a system that interprets and translates color accurately between devices. A color management system (CMS) 

compares  the color  space in which  a color  was created  to  the color  space in which  the same color  will  be  output, and  

makes the necessary adjustments to represent the color as consistently as possible among different devices. 

A color management system translates colors with the help of color profiles. A profile is a mathematical description 

of a device’s color space. For example, a scanner profile tells a color management system how your scanner “sees” 

colors. Adobe applications use ICC profiles, a format defined by the International Color Consortium (ICC) as a 

cross-platform standard. (See “About color profiles” on page 263.) 
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Because no single color-translation method is ideal for all types of graphics, a color management system provide a 

choice of rendering intents, or translation methods, so that you can apply a method appropriate to a particular 

graphical element. For example, a color translation method that preserves correct relationships among colors in a 

wildlife photograph may alter the colors in a logo containing flat tints of color. (See “About rendering intents” on 

page 271.) 

Note: Don’t confuse color management with color correction. A color management system won’t correct an image that 

was saved with tonal or color balance problems. It provides an environment where you can evaluate images reliably in 

the context of your final output. 

Do you need color management? 
Without a color management system, your color specifications are device-dependent. You might not need color 

management if your production process is tightly controlled for one medium only. For example, you or your prepress 

service provider can tailor CMYK images and specify color values for a known, specific set of printing conditions. 

The value of color management increases when you have more variables in your production process. Color 

management is recommended if you anticipate reusing color graphics for print and online media, using various 

kinds of devices within a single medium (such as different printing presses), or if you manage multiple workstations. 

You will benefit from a color management system if you need to accomplish any of the following: 

•	 Get predictable and consistent color output on multiple output devices including color separations, your desktop 

printer, and your monitor. Color management is especially useful for adjusting color for devices with a relatively 

limited gamut, such as a four-color process printing press. 

•	 Accurately soft-proof (preview) a color document on your monitor by making it simulate a specific output device. 

(Soft-proofing is subject to the limitations of monitor display, such as room lighting conditions.) 

•	 Accurately evaluate and consistently incorporate color graphics from many different sources if they also use color 

management, and even in some cases if they don’t. 

•	 Send color documents to different output devices and media without having to manually adjust colors in 

documents or original graphics. This is valuable when creating images that will eventually be used both in print 

and online. 

•	 Print color correctly to an unknown color output device; for example, you could store a document online for 

consistently reproducible on-demand color printing anywhere in the world. 

Creating a viewing environment for color management 
Your work environment influences how you see color on your monitor and on printed output. For best results, 

control the colors and light in your work environment by doing the following: 

•	 View your documents in an environment that provides a consistent light level and color temperature. For example, 

the color characteristics of sunlight change throughout the day and alter the way colors appear on your screen, so 

keep shades closed or work in a windowless room. To eliminate the blue-green cast from fluorescent lighting, you 

can install D50 (5000˚ Kelvin) lighting. You can also view printed documents using a D50 lightbox. 

•	 View your document in a room with neutral-colored walls and ceiling. A room’s color can affect the perception of 

both monitor color and printed color. The best color for a viewing room is polychromatic gray. Also, the color of 

your clothing reflecting off the glass of your monitor may affect the appearance of colors on-screen. 
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•	 Remove colorful background patterns on your monitor desktop. Busy or bright patterns surrounding a document 

interfere with accurate color perception. Set your desktop to display neutral grays only. 

•	 View document proofs in the real-world conditions under which your audience will see the final piece. For 

example, you might want to see how a housewares catalog looks under the incandescent light bulbs used in homes, 

or view an office furniture catalog under the fluorescent lighting used in offices. However, always make final color 

judgements under the lighting conditions specified by the legal requirements for contract proofs in your country. 

Keeping colors consistent 

About color management in Adobe applications 
Adobe’s color  management  system  helps you  maintain  the appearance of colors as you  bring images in from external  

sources, edit documents and transfer them between Adobe applications, and output your finished compositions. 

This system is based on conventions developed by the International Color Consortium (ICC), a group responsible 

for standardizing profile formats and procedures so that consistent and accurate color can be achieved throughout a 

workflow. 

By  default,  color management is turned on in Adobe  applications. If you  purchased the  Adobe Creative Suite, color  

settings are synchronized across applications to provide consistent display for RGB and CMYK colors. This means 

that colors look the same no matter which application you view them in. 

Color settings for each Creative Suite application are synchronized in a central location through Adobe Bridge. 

If you decide to change the default settings, easy-to-use presets let you configure Adobe’s color management system 

to match common output conditions. You can also customize color settings to meet the demands of your particular 

color workflow. 

Keep in mind that the kinds of images you work with and your output requirements influence how you use color 

management. For example, there are different color-consistency issues for an RGB photo printing workflow, a CMYK 

commercial printing workflow, a mixed RGB/CMYK digital printing workflow, and an internet publishing workflow. 
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Basic steps for producing consistent color 

1. Consult with your production partners (if you have any) to ensure that all aspects of your color management 
workflow integrate seamlessly with theirs. 

Discuss how the color workflow will be integrated with your workgroups and service providers, how will software 

and hardware be configured for integration into the color management system, and at what level will color 

management be implemented. (See “Do you need color management?” on page 251.) 

For more information on common color management workflows, see the Color Workflow Guide on your application 

CD. 

2. Calibrate and profile your monitor. 

A monitor profile is the first profile you should create. Seeing accurate color is essential if you are making creative 

decisions involving the color you specify in your document. (See “To calibrate and profile your monitor” on 

page 265.) 

3. Add color profiles to your system for any input and output devices you plan to use, such as scanners and 
printers. 

The color management system uses profiles to know how a device produces color and what the actual colors in a 

document are. Device profiles are often installed when a device is added to your system. You can also use third-party 

software and hardware to create more accurate profiles for specific devices and conditions. If your document will be 

commercially printed, contact your service provider to determine the profile for the printing device or press 

condition. (See “About color profiles” on page 263 and “To install a color profile” on page 266.) 

4. Set up color management in Adobe applications. 

The default color settings are sufficient for most users. However, you can change the color settings by doing one of 

the following: 

•	 If you use multiple Adobe applications, use Bridge to choose a standard color management configuration and 

synchronize color settings across applications before working with documents. (See “To synchronize color settings 

across Adobe applications” on page 254.) 

•	 If you use only one Adobe application, or if you want to customize advanced color management options, you can 

change color settings for a specific application. (See “To set up color management for Illustrator, InDesign, and 

Photoshop” on page 254 or “To set up color management for GoLive” on page 254.) 

5. (Optional) Preview colors using a soft proof. 

After you  create  a document,  you can  use a soft  proof to preview  how colors will look when printed  or  viewed  on  a  

specific device. (See “Soft-proofing colors” on page 259.) 

Note: A soft proof  alone doesn’t  let you  preview how  overprinting  will  look  when  printed on an offset press. If you  work  

with Illustrator or InDesign documents that contain overprinting, turn on Overprint Preview to accurately preview 

overprints in a soft proof. 

6. Use color management when printing and saving files. 

Keeping the appearance of colors consistent across all of the devices in your workflow is the goal of color 

management. Leave color management options enabled when printing documents, saving files, and preparing files 

for online viewing. (See “Printing with color management” on page 261 and “Color-managing documents for online 

viewing” on page 258.) 
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To synchronize color settings across Adobe applications 
When you set up color management using Adobe Bridge, color settings are automatically synchronized across appli

cations. This synchronization ensures that colors look the same in all Adobe Creative Suite applications. 

If color settings are not synchronized, a warning message appears at the top of the Color Settings dialog box in every 

Creative Suite application. Adobe recommends that you synchronize color settings before you work with new or 

existing documents. 

1 Open Bridge. 

To open Bridge from another Creative Suite application, choose File > Browse from the application. To open Bridge 

directly, either choose Adobe Bridge from the Start menu (Windows) or double-click the Adobe Bridge icon (Mac 

OS). 

2 Choose Edit > Creative Suite Color Settings. 

3 Select a color setting from the list, and click Apply. 

If none of the default settings meet your requirements, select Show Expanded List Of Color Setting Files to view 

additional settings. To install a custom settings file, such as a file you received from a print service provider, click 

Show Saved Color Settings Files. 

To set up color management for Illustrator, InDesign, and Photoshop 
1 Choose Edit > Color Settings. 

2 Select a color setting from the Settings menu, and click OK. 

The setting you select determines the color working spaces used by the application, what happens when you open 

and import files with embedded profiles, and how the color management system converts colors. To view a 

description of a setting, select the setting and then position the pointer over the setting name. The description 

appears at the bottom of the dialog box. 

In certain situations, such as if your service provider supplies you with a custom output profile, you may need to 

customize specific options in the Color Settings dialog box. However, customizing is recommended for advanced 

users only. 

Note: If you work with more than one Adobe application, it is highly recommended that you synchronize your color 

settings across applications. (See “To synchronize color settings across Adobe applications” on page 254.) 

See also 

“To customize color settings” on page 268 

To set up color management for GoLive 
By default, GoLive’s color management system uses a standard web workflow in which you author web pages and 

import images in the sRGB color space. sRGB reflects the characteristic of the average PC monitor and is therefore 

applicable to the majority of web users. If you have a highly controlled distribution for your website (for example, 

you know that the majority of users will view the site using Apple Macintosh computers), you can override the 

standard web workflow. 

1 Choose Edit > Color Settings. 

2 If  you want to author web  pages in a color space  other than sRGB,  or  you want to preserve embedded profiles in  

RGB images, deselect Use Standard Web Workflow. 
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Adobe recommends that you leave the Use Standard Web Workflow option selected. 

3	 Select a color setting from the Settings menu, and click OK. 

The setting you select determines the color working space of the application, what happens when you open and 

import files with embedded profiles, and how the color management system converts colors. You can view the 

options for a color setting directly in the Color Settings dialog box. 

In most cases, it is best to use a standard color setting and not change specific options in the Color Settings dialog 

box. Customizing the working spaces, color management policies, and color conversion options is recommended for 

advanced users only. 

Note: If you work with more than one Adobe application, it is recommended that you synchronize your color settings 

across applications. (See “To synchronize color settings across Adobe applications” on page 254.) 

To change the appearance of CMYK black 
In Illustrator and InDesign, pure CMYK black (K=100) appears jet black (or rich black) when viewed on-screen, 

printed to a non-Postscript desktop printer, or exported to an RGB file format. If you prefer to see the difference 

between pure black and rich black as it will appear when printed on a commercial press, you can change the 

Appearance Of Black preferences. These preferences do not change the color values in a document. 

1 Choose Edit > Preferences > Appearance Of Black (Windows) or Application name > Preferences > Appearance 

Of Black (Mac OS). 

2	 Choose an option for On Screen: 

Display All Blacks Accurately Displays pure CMYK black as dark gray. This setting allows you to see the difference 

between pure black and rich black. 

Display All Blacks As Rich Black Displays pure CMYK black as jet black (RGB=000). This setting makes pure black 

and rich black appear the same on-screen. 

3 Choose an option for Printing/Exporting: 

Output All Blacks Accurately When printing to a non-Postscript desktop printer or exporting to an RGB file 

format, outputs pure CMYK black as using the color numbers in the document. This setting allows you to see the 

difference between pure black and rich black. 

Output All Blacks As Rich Black When printing to a non-Postscript desktop printer or exporting to an RGB file 

format, outputs pure CMYK black as jet black (RGB=000). This setting makes pure black and rich black appear the 

same. 

Managing process and spot colors 
When color management is on, any color you apply or create within an Adobe application automatically uses a color 

profile that corresponds to the document. If you switch color modes, the color management system uses the appro

priate profiles to translate the color to the new color model you choose. 

Keep in mind the following guidelines for working with process and spot colors: 

•	 Choose a CMYK working space that matches your CMYK output conditions to ensure that you can accurately 

define and view process colors. 

•	 Select colors from a color library. Adobe applications come with several standard color libraries, which you can 

load using the Swatches palette menu. 
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•	 (Illustrator and InDesign) Turn on Overprint Preview to get an accurate and consistent preview of spot colors. 

•	 (Illustrator and InDesign) Use Lab values (the default) to display predefined spot colors (such as colors from the 

TOYO, PANTONE, DIC, and HKS libraries) and convert these colors to process colors. Using Lab values provides 

the greatest accuracy and guarantees the consistent display of colors across Creative Suite applications. If you want 

the display and output of these colors to match earlier versions of Illustrator or InDesign, use CMYK equivalent 

values instead. For instructions on switching between Lab values and CMYK values for spot colors, search Illus

trator or InDesign Help 

Note: Color-managing spot colors provides a close approximation of a spot color on your proofing device and monitor. 

However, it is difficult to exactly reproduce a spot color on a monitor or proofing device because many spot color inks 

exist outside the gamuts of many of those devices. 

To share swatches between applications 
You can share the solid swatches you create in one Adobe CS2 application with any other Adobe CS2 application by 

saving a swatch library for exchange. The colors appear exactly the same across applications as long as your color 

settings are synchronized. 

1 In the Swatches palette, create the process and spot-color swatches you want to share, and remove any swatches 

you don’t want to share. 

Note: You cannot share the following types of swatches between applications: patterns, gradients, and the Registration 

swatch from Illustrator or InDesign; and book color references, HSB, XYZ, duotone, monitorRGB, opacity, total ink, and 

webRGB swatches from Photoshop. These types of swatches are automatically excluded when you save swatches for 

exchange. 

2 Select Save Swatches For Exchange from the Swatches palette menu, and save the swatch libraries in an easily 

accessible location. 

3 Load the swatch library into the Swatches palette for any other Adobe CS2 application. See that application’s Help 

for additional instructions. 

Color-managing imported images 

Color-managing imported images 
How imported images are integrated into a document’s color space depends on whether or not the image has an 

embedded profile: 

•	 When you import an image that contains no profile, the Adobe application uses the current document profile to 

define the colors in the image. 

•	 When you import an image that contains an embedded profile, color policies in the Color Settings dialog box 

determine how the Adobe application handles the profile. (See “Color Management Policy options” on page 270.) 

Using a safe CMYK workflow 
In Illustrator and InDesign, a safe CMYK workflow ensures that CMYK color numbers are preserved all the way to 

the final output device, as opposed to being converted by your color management system. This workflow is beneficial 

if you want to incrementally adopt color management practices. For example, you can use CMYK profiles to soft

proof and hard-proof documents without the possibility of unintended color conversions occurring during final 

output. 
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Illustrator and InDesign support a safe CMYK workflow by default. As a result, when you open or import a CMYK 

image with an embedded profile, the  application ignores  the profile  and preserves  the raw  color numbers. If you  want  

your application to adjust color numbers based on an embedded profile, change the CMYK color policy to Preserve 

Embedded Profiles in the Color Settings dialog box. You can easily restore the safe CMYK workflow by changing the 

CMYK color policy back to Preserve Numbers (Ignore Linked Profiles). 

You can override safe CMYK settings when you print a document or save it to PDF. However, doing so may cause 

colors to be reseparated. For example, pure CMYK black objects may be reseparated as rich black. For more infor

mation on color management options for printing and saving PDF files, search in Help. 

See also 

“Color Management Policy options” on page 270 

Preparing imported graphics for color management 
Use the following general guidelines to prepare graphics for being color-managed in Adobe applications: 

•	 Embed an ICC-compliant profile when you save the file. The file formats that support embedded profiles are 

JPEG, PDF, PSD (Photoshop), AI (Illustrator), INDD (InDesign), and TIFF. (See “To embed a color profile in a 

document” on page 266.) 

•	 If you plan to reuse a color graphic for multiple final output devices or media, such as for print, video, and the web, 

prepare the graphic using RGB or Lab colors whenever possible. If you must save in a color model other than RGB 

or Lab, keep a copy of the original graphic. RGB and Lab color models represent larger color gamuts than most 

output  devices can  reproduce,  retaining as much color  information as possible before being  translated  to  a smaller  

output color gamut. 

To view or change profiles for imported bitmap images 
InDesign  allows  you to view,  override, or disable  profiles  for imported bitmap images.  This  may be necessary  when  

you are importing an image containing no profile or an incorrectly embedded profile. For example, if the scanner 

manufacturer’s default profile was embedded but you have since generated a custom profile, you can assign the newer 

profile. 

1	 Do one of the following: 

•	 If the graphic is already in layout, select it and choose Object > Image Color Settings. 

•	 If you’re about to import the graphic, choose File > Place, select Show Import Options, locate and select the file, 

and click  Place.  Then  choose  Color Settings from the  menu  at  the top  of  the Image  Import  Options dialog box  that  

appears. 

2 For Profile, choose the source profile to apply to the graphic in your document. If a profile is currently embedded, 

the profile name appears at the top of the Profile menu. 

3 (Optional) For Rendering Intent, choose a rendering intent. In most cases, it’s best to use the default rendering 

intent. 

4	 Click OK. 
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Color-managing documents for online viewing 

Color-managing documents for online viewing 
Color management for online viewing is very different from color management for printed media. With printed 

media, you have far more control over the appearance of the final document. With online media, your document will 

appear on a wide range of possibly uncalibrated monitors and video display systems, significantly limiting your 

control over color consistency. 

When  you color-manage documents  that  will  be  viewed  exclusively on the  web,  Adobe recommends that you  use the  

sRGB color space. sRGB is the default working space for most Adobe color settings, but you can verify that sRGB is 

selected in the Color Settings dialog box of any Creative Suite application. With the working space set to sRGB, any 

RGB graphics you create will use sRGB as the color space. 

When working with images that have an embedded color profile other than sRGB, you should convert the image’s 

colors  to  sRGB  before  you save the  image for  use on the  web.  If  you want the  application to automatically  convert the  

colors to sRGB when you open the image, select Convert To Working Space as the RGB color management policy. 

In Photoshop and InDesign, you can also manually convert the colors to sRGB using the Edit > Convert To Profile 

command. 

See also 

“About color working spaces” on page 268 

“Color Management Policy options” on page 270 

Color-managing PDF documents for online viewing 
When you export Portable Document Format (PDF) files, you can choose to embed profiles. PDF files with 

embedded profiles reproduce color consistently in Acrobat 4.x or later running under a properly configured color 

management system. For information about color management in Acrobat software, see Acrobat online Help. 

Keep in mind that embedding color profiles increases the size of PDF files. RGB profiles are usually small (around 

3K); however, CMYK profiles can range from .5 to 2 MB. 

See also 

“Color-managing PDF files for printing” on page 262 

Color-managing HTML documents for online viewing 
Many  web browsers do not  support color  management. Of the  browsers  that  do  support color  management, not  all  

instances can be considered color-managed because they may be running on systems where the monitors are not 

calibrated. In addition, few web pages contain images with embedded profiles. If you manage a highly controlled 

environment, such as the intranet of a design studio, you may be able to achieve some degree of HTML color 

management for images by equipping everyone with a browser that supports color management and calibrating all 

monitors. 

You can approximate how colors will look on non-calibrated monitors by using the sRGB color space. In Adobe 

GoLive, you can also preview how colors will look in different browsers using options in the View palette. (See “To 

preview how colors will appear in a web browser” on page 261.) However, because color reproduction varies among 

uncalibrated monitors, you still won’t be able to anticipate the true range of potential display variations. 
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Proofing colors

Soft-proofing colors
In a traditional publishing workflow, you print a hard proof of your document to preview how its colors will look

when reproduced on a specific output device. In a color-managed workflow, you can use the precision of color

profiles to soft-proof your document directly on the monitor. You can display an on-screen preview of how your

document’s colors will look when reproduced on a particular output device. If you are authoring a website in GoLive,

you can also soft-proof how colors will look when viewed in different browsers and with different color profiles.

Keep in mind that the reliability of the soft proof depends upon the quality of your monitor, the profiles of your

monitor and output devices, and the ambient lighting conditions of your work environment.

Note: A soft proof alone doesn’t let you preview how overprinting will look when printed on an offset press. If you work

with Illustrator or InDesign documents that contain overprinting, turn on Overprint Preview to accurately preview

overprints in a soft proof.

Using a soft proof to preview the final output of a document on your monitor
A. Document in the working space B. Document’s color values are translated to color space of chosen proof profile (usually the output de-
vice’s profile). C. Monitor displays proof profile’s interpretation of document’s color values.

To soft-proof colors
1 In Illustrator, InDesign, or Photoshop, choose View > Proof Setup, and do one of the following:

• Choose a preset that corresponds to the output condition you want to simulate. (See “Soft proof presets” on

page 260.)

• Choose Custom (Photoshop and InDesign) or Customize (Illustrator) to create a custom proof setup for a specific

output condition. This option is recommended for the most accurate preview of your final printed piece. (See

“Custom soft proof options” on page 260.)

2 Choose View > Proof Colors to toggle the soft-proof display on and off. When soft proofing is on, a check mark

appears next to the Proof Colors command, and the name of the proof preset or profile appears at the top of the

document window.

To compare the colors in the original image and the colors in the soft proof, open the document in a new window

before you set up the soft proof.

A B C
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Soft proof presets 
Working CMYK Creates a soft proof of colors using the current CMYK working space as defined in the Color 

Settings dialog box. 

Document CMYK (InDesign) Creates a soft proof of colors using the document’s CMYK profile. 

Working Cyan Plate, Working Magenta Plate, Working Yellow Plate, Working Black Plate, or Working CMY 
Plates (Photoshop) Creates a soft proof of specific CMYK ink colors using the current CMYK working space. 

Macintosh RGB or Windows RGB (Photoshop and Illustrator) Creates a soft proof of colors in an image using 

either a standard Mac OS or Windows monitor as the proof profile space to simulate. Both options assume that the 

simulated device will display  your  document  without using  color management.  Neither option is available  for Lab  or  

CMYK documents. 

Monitor RGB (Photoshop and Illustrator) Creates a soft proof of colors in an RGB document using your current 

monitor color space as the proof profile space. This option assumes that the simulated device will display your 

document without using color management. This option is unavailable for Lab and CMYK documents. 

Custom soft proof options 
Device To Simulate Specifies the color profile of the device for which you want to create the proof. The usefulness 

of the chosen profile depends on how accurately it describes the device’s behavior. Often, custom profiles for specific 

paper and printer combinations create the most accurate soft proof. 

Preserve CMYK Numbers or Preserve RGB Numbers Simulates how the colors will appear without being 

converted to the color space of the output device. This option is most useful when you are following a safe CMYK 

workflow. (See “Using a safe CMYK workflow” on page 256.) 

Rendering Intent (Photoshop and Illustrator) When the Preserve Numbers option is deselected, specifies a 

rendering intent for converting colors to the device you are trying to simulate. (See “About rendering intents” on 

page 271.) 

Use Black Point Compensation (Photoshop) Ensures that the shadow detail in the image is preserved by 

simulating  the full dynamic  range of the  output  device. Select this option if you  plan  to  use black  point compensation  

when printing (which is recommended in most situations). 

Simulate Paper Color Simulates the dingy white of real paper, according to the proof profile. Not all profiles 

support this option. 

Simulate Black Ink Simulates the dark gray you really get instead of a solid black on many printers, according to the 

proof profile. Not all profiles support this option. 

In Photoshop, if you want the custom proof setup to be the default proof setup for documents, close all document 

windows before choosing the View > Proof Setup > Custom command. 

To save or load a custom proof setup in Photoshop

1 Choose View > Proof Setup > Custom.


2 Do either of the following:


•	 To save a custom proof setup, click Save. To ensure that the new preset appears in the View > Proof Setup menu, 

save the preset in the default location. 

•	 To load a custom proof setup, click Load. 
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To preview how colors will appear in a web browser 
Different web browsers use different color spaces. For example, most Windows browsers display colors using the


sRGB color space, while most Mac OS browsers display colors using the Apple RGB color space.You can preview how


colors will look when viewed in different browsers using options in GoLive’s View palette.


1 In GoLive, select the Layout Editor in the document window.


2 Click the Options tab in the View palette.


3 For Basic Profile, select the browser you want to emulate.


4 (Optional) For User Profiles, select an option from the Color submenu.


For example, if you want to preview how colors look when displayed using embedded profiles, select Use Embedded


Profiles. Or, if you want to preview how colors look when displayed in grayscale, select Mac Grayscale (Gray Gamma


1.8) or Windows Grayscale (Gray Gamma 2.2).


Note: The Safari browser (listed under the Basic Profile > Other menu) is currently the only browser that supports 

embedded color profiles. Therefore, selecting User Profiles > Color  > Use  Embedded Profiles does not  provide an accurate  

preview for any browser other than Safari. 

Each User Profiles > Color option you select overrides existing Basic Profile and User Profiles options. For example, 

if you select Explorer 6 Win for Basic Profile and then select Mac Colors (Apple RGB) for User Profiles > Color, 

GoLive displays colors using the Apple RGB color space. 

Color-managing documents when printing 

Printing with color management 
Color management options for printing let you specify how you want Adobe applications to handle the outgoing 

image data so the printer will print colors consistent with what you see on your monitor. Your options for printing 

color-managed documents depend on the Adobe application you use, as well as the output device you select. In 

general, you have the following choices for handling colors during printing: 

•	 Let the printer determine colors. (See “Letting the printer determine colors when printing” on page 261.) 

•	 Let the application determine colors. (See “Letting the application determine colors when printing” on page 262.) 

•	 (Photoshop and InDesign) Do not use color management. In this workflow, no color conversion occurs. You may 

also need to turn off color management in your printer driver. This method is useful primarily for printing test 

targets or generating custom profiles. 

Letting the printer determine colors when printing 
In this workflow, the application does no color conversion, but sends all necessary conversion information to the 

output device. This method is especially convenient when printing to inkjet photo printers, because each combi

nation of paper type, printing resolution, and additional printing parameters (such as high speed printing) requires 

a different profile. Most new inkjet photo printers come with fairly accurate profiles built into the driver, so letting 

the printer select the right profile saves time and alleviates mistakes. This method is also recommended if you are 

not familiar with color management. 

If you choose this option, it is very important that you set up printing options and turn on color management in your 

printer driver. Search Help for additional instructions. 
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If you select a PostScript printer, you can take advantage of PostScript color management. PostScript color 

management  makes it possible to perform  color composite  output  or  color separations  at  the raster image  processor  

(RIP)—a process called in-RIP separations—so that a program need only specify parameters for separation and let 

the device calculate  the final  color values.  PostScript  color-managed output workflows  require an output device that  

supports PostScript color management using PostScript level 2, version 2017 or higher; or PostScript 3. 

Letting the application determine colors when printing 
In this workflow, the application does all the color conversion, generating color data specific to one output device. 

The application uses the assigned color profiles to convert colors to the output device’s gamut, and sends the resulting 

values to the output device. The accuracy of this method depends on the accuracy of the printer profile you select. 

Use this workflow when you have custom ICC profiles for each specific printer, ink, and paper combination. 

If you choose this option, it is very important that you disable color management in your printer driver. Letting the 

application and the printer driver simultaneously manage colors during printing results in unpredictable color. 

Search Help for additional instructions. 

Obtaining custom profiles for desktop printers 
If  the output profiles that come with your printer  don’t produce  satisfactory  results,  you obtain custom profiles in the  

following ways: 

•	 Purchase a profile for your type of printer and paper. This is usually the easiest and least expensive method. 

•	 Purchase a profile for your specific printer and paper. This method involves printing a profiling target on your 

printer and paper, and providing that target to a company that will create a specific profile. This is more expensive 

than purchasing a standard profile, but can provide better results because it compensates for any manufacturing 

variations in printers. 

•	 Create your own profile using a scanner-based system. This method involves using profile-creation software and 

your own flatbed scanner to scan the profiling target. It can provide excellent results for matte surface papers, but 

not glossy papers. (Glossy papers tend to have fluorescent brighteners in them that look different to a scanner than 

they do in room light.) 

•	 Create your own profile using a hardware profile-creation tool. This method is expensive but can provide the best 

results. A good hardware tool can create an accurate profile even with glossy papers. 

•	 Tweak a profile created using one of the previous methods with profile-editing software. This software can be 

complex to use, but lets you correct problems with a profile or simply adjust a profile to produce results more to 

your taste. 

See also 

“To install a color profile” on page 266 

Color-managing PDF files for printing 
When you create Adobe PDF files for commercial printing, you can specify how color information is represented. 

The easiest way to do this is using a PDF/X standard; however, you can also specify color-handling options manually 

in the Output section of the PDF dialog box. For more information about PDF/X and how to create PDF files, search 

Help. 

 



263 ADOBE PHOTOSHOP CS2 
User Guide 

In general, you have the following choices for handling colors when creating PDF files: 

•	 (PDF/X-3) Do not convert colors. Use this method when creating a document that will be printed or displayed on 

various or unknown devices. When you select a PDF/X-3 standard, color profiles are automatically embedded in 

the PDF file. 

•	 (PDF/X-1a) Convert all colors to the destination CMYK color space. Use this method if you want to create a press

ready file that does not require any further color conversions. When you select a PDF/X-1a standard, no profiles 

are embedded in the PDF file. 

•	 (Illustrator and InDesign) Convert colors that have embedded profiles to the destination color space, but preserve 

the numbers for those colors without embedded profiles. You can manually select this option in the Output section 

of the PDF dialog box. Use this method if the document contains CMYK images that aren’t color-managed and 

you want to make sure that the color numbers are preserved. (See “Using a safe CMYK workflow” on page 256.) 

Note: All spot-color information is preserved during color conversion; only the process color equivalents convert to the 

designated color space. 

Working with color profiles 

About color profiles 
Precise, consistent color management requires accurate ICC-compliant profiles of all of your color devices. For 

example, without an accurate scanner profile, a perfectly scanned image may appear incorrect in another program, 

simply due to any difference between the scanner and the program displaying the image. This misleading represen

tation may cause you to make unnecessary, time-wasting, and potentially damaging “corrections” to an already satis

factory image. With an accurate profile, a program importing the image can correct for any device differences and 

display a scan’s actual colors. 

A color management system uses the following kinds of profiles: 

Monitor profiles Describe  how the  monitor is currently  reproducing color. This is the  first profile  you should create  

because it is absolutely essential for managing color. If what you see on your monitor is not representative of the 

actual colors in your document, you will not be able to maintain color consistency. (See “To calibrate and profile your 

monitor” on page 265.) 

Input device profiles Describe what colors an input device is capable of capturing or scanning. If your digital 

camera offers a choice of profiles, Adobe recommends that you select Adobe RGB. Otherwise, use sRGB (which is 

the default for most cameras). Advanced users may also consider using different profiles for different light sources. 

For scanner profiles, some photographers create separate profiles for each type or brand of film scanned on a scanner. 

Output device profiles Describe the color space of output devices like desktop printers and a printing press. The 

color management system uses output device profiles to properly map  the colors in an document to the  colors  within  

the gamut of an output device’s color space. The output profile should also take into consideration specific printing 

conditions, such as the type of paper and ink. For example, glossy paper is capable of displaying a different range of 

colors than a matte paper. 

Most printer drivers come with built-in color profiles. It’s a good idea to try these profiles before you invest in custom 

profiles. For information on how to print using the built-in profiles, see “Letting the printer determine colors when 
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printing” on page 261. For information on how to obtain custom profiles, see “Obtaining custom profiles for desktop 

printers” on page 262. 

Document profiles Define the specific RGB or CMYK color space of a document. By assigning, or tagging, a 

document with a profile, the application provides a definition of actual color appearances in the document. For 

example, R=127, G=12, B=107 is just a set of numbers that different devices will display differently. But when tagged 

with the AdobeRGB color space, these numbers specify an actual color or wavelength of light; in this case, a specific 

color of purple. 

When color management is on, Adobe applications automatically assign new documents a profile based on Working 

Space options in the Color Settings dialog box. Documents without associated profiles are known as untagged and 

contain only raw color numbers. When working with untagged documents, Adobe applications use the current 

working space profile to display and edit colors. (See “About color working spaces” on page 268.) 

To view the current document profile, select Document Color Profile in the status bar. 

A 

B 

C 

D 

Managing color with profiles 
A. Profiles describe the color spaces of the input device and the document. B. Using the profiles’ descriptions, the color management system 
identifies the document’s actual colors. C. The monitor’s profile tells the color management system how to translate the numeric values to 
the monitor’s color space. D. Using the output device’s profile, the color management system translates the document’s numeric values to the 
color values of the output device so the actual colors are printed. 

About monitor calibration and characterization 
Profiling software such as Adobe Gamma can both calibrate and characterize your monitor. Calibrating your monitor 

brings it into compliance with a predefined standard; for example, adjusting your monitor so that it displays color 

using the graphics arts standard white point color temperature of 5000 degrees Kelvin. Characterizing your monitor 

simply creates a profile that describes how the monitor is currently reproducing color. 
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Monitor calibration involves adjusting the following video settings, which may be unfamiliar to you. 

Brightness and contrast The overall level and range, respectively, of display intensity. These parameters work just 

as they do on a television. Adobe Gamma helps you set an optimum brightness and contrast range for calibration. 

Gamma The brightness of the midtone values. The values produced by a monitor from black to white are 

nonlinear—if you graph the values, they form a curve, not a straight line. Gamma defines the value of that curve 

halfway between black and white. 

Phosphors The substances that CRT monitors use to emit light. Different phosphors have different color character

istics. 

White point The color and intensity of the brightest white the monitor can reproduce. 

To calibrate and profile your monitor 
When you calibrate your monitor, you are adjusting it so it conforms to a known specification. Once your monitor 

is calibrated, the profiling utility lets you save a color profile. The profile describes the color behavior of the 

monitor—what  colors  can or cannot be displayed  on  the monitor  and how  the numeric  color values in an image  must  

be converted so that colors are displayed accurately. 

1 Make sure your monitor has been turned on for at least a half hour. This gives it sufficient time to warm up and 

produce more consistent output. 

2 Make sure your monitor is displaying thousands of colors or more. Ideally, make sure it is displaying millions of 

colors or 24-bit or higher. 

3 Remove colorful background patterns on your monitor desktop and set your desktop to display neutral grays. 

Busy patterns or bright colors surrounding a document interfere with accurate color perception. 

4	 Do one of the following to calibrate and profile your monitor: 

•	 In Windows, use the Adobe Gamma utility, located in the Control Panel. 

•	 In Mac OS, use the Calibrate utility, located in the System Preferences/Displays/Color tab. 

•	 For the best results, use third-party software and measuring devices. In general, using a measuring device such as 

a colorimeter along with software can create more accurate profiles because an instrument can measure the colors 

displayed on a monitor far more accurately than the human eye. 

Note: Monitor performance changes and declines over time; recalibrate and profile your monitor every month or so. If 

you find it difficult or impossible to calibrate your monitor to a standard, it may be too old and faded. 

Most profiling software automatically assigns the new profile as the default monitor profile. For instructions on how 

to manually assign the monitor profile, refer to the Help system for your operating system. 
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To install a color profile 
Color profiles are  often installed  when  a device is added to your system.  The accuracy  of  these profiles (often called  

generic profiles or canned profiles) varies from manufacturer to manufacturer. You can also obtain device profiles 

from your service provider, download profiles from the web, or create custom profiles using professional profiling 

equipment. 

•	 In Windows, right-click a profile and select Install Profile. Alternatively, copy the profiles into the 

WINDOWS\system32\spool\drivers\color folder (Windows XP) or the WINNT\system32\spool\drivers\color 

folder (Windows 2000). 

•	 In Mac OS, copy profiles into the /Library/Application Support/Adobe/Color/Profiles/Recommended folder. You 

can also copy profiles into the /Users/username/Library/ColorSync/Profiles folder. 

After installing color profiles, be sure to restart Adobe applications. 

See also 

“Obtaining custom profiles for desktop printers” on page 262 

To embed a color profile in a document 
In order to embed a color profile in a document you created in Photoshop, Illustrator, or InDesign, you must save or 

export the document in a format that supports ICC profiles. 

1 Save or export the document in one of the following file formats: Adobe PDF, PSD (Photoshop), AI (Illustrator), 

INDD (InDesign), JPEG, or TIFF. 

2 Select the option for embedding ICC profiles. The exact name and location of this option varies between applica

tions. Search Help in the relevant CS2 application for additional instructions. 

Changing the color profile for a document 
There are  very  few situations that require you  to  change  the color  profile for  a document.  This  is  because your appli

cation automatically assigns the color profile based on the settings you select in the Color Settings dialog box. The 

only times you should manually change a color profile are when preparing a document for a different output desti

nation or correcting a policy behavior that you no longer want implemented in the document. Changing the profile 

is recommended for advanced users only. 

You can change the color profile for a document in the following ways: 

•	 Assign  a new  profile.  The color  numbers in the  document  remain  the same,  but the  new profile  may dramatically  

change the appearance of the colors as displayed on your monitor. 

•	 Remove the profile so that the document in no longer color-managed. 

•	 (Photoshop and InDesign) Convert the colors in the document to the color space of a different profile. The color 

numbers are shifted in an effort to preserve the original color appearances. 
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To assign or remove a color profile from a document in Photoshop or Illustrator 
1 Choose Edit > Assign Profile. 

2 Select an option, and click OK: 

Don’t Color Manage This Document Removes the  existing  profile from the  document. Select this option only if you  

are sure that you do not want to color-manage the document. After you remove the profile from a document, the 

appearance of colors is defined by the application’s working space profiles, and you can no longer embed a profile in 

the document. 

Working [color model: working space] Assigns the working space profile to the document. 

Profile Lets you select a different profile. The application assigns the new profile to the document without 

converting colors to the profile space. This may dramatically change the appearance of the colors as displayed on 

your monitor. 

See also 

“Changing the color profile for a document” on page 266 

To assign or remove a color profile from a document in InDesign 
1 Choose Edit > Assign Profiles. 

2 For RGB Profile and CMYK Profile, select one of the following:


Discard (Use Current Working Space) Removes the existing profile from the document. Select this option only if


you are sure that you do not want to color-manage the document. After you remove the profile from a document,


the appearance of colors is defined by the application’s working space profiles, and you can no longer embed a profile


in the document.


Assign Current Working Space <working space> Assigns the working space profile to the document. 

Assign Profile Lets you select a different profile. The application assigns the new profile to the document without 

converting colors to the profile space. This may dramatically change the appearance of the colors as displayed on 

your monitor. 

3 Choose a rendering intent for each type of graphic in your document. For each graphic type, you can choose one 

of the four standard intents, or the Use Color Settings Intent, which uses the rendering intent currently specified in 

the Color Settings dialog box. For more information on rendering intents, search in Help. 

The graphic types include the following: 

Solid Color Intent Sets the rendering intent for all vector art (solid areas of color) in InDesign native objects. 

Default Image Intent Sets the default rendering intent for bitmap images placed in InDesign. You can still override 

this setting on an image-by-image basis. (See “To view or change profiles for imported bitmap images” on page 257.) 

After-Blending Intent Sets the rendering intent to the proofing or final color space for colors that result from trans

parency interactions on the page. Use this option when your document includes transparent objects. 

4 To preview the effects of the new profile assignment in the document, select Preview, and then click OK. 

See also 

“Changing the color profile for a document” on page 266 
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To convert colors in a document to another profile

1 In Photoshop or InDesign, choose Edit > Convert To Profile.


2 Under Destination Space, choose the color profile to which you want to convert the document’s colors. The


document will be converted to and tagged with this new profile.


3 Under Conversion Options, specify a color management engine, a rendering intent, and black point and dither


options. (See “Color Conversion options” on page 271.)


4 To flatten all layers of the document onto a single layer upon conversion, select Flatten Image.


5 To preview the effects of the conversion in the document, select Preview. This preview becomes more accurate if


you select Flatten Image.


See also 

“Changing the color profile for a document” on page 266 

Color settings 

To customize color settings 
For most color-managed workflows, it is best to use a preset color setting which has been tested by Adobe Systems. 

Changing specific options is recommended only if you are knowledgeable about color management and very 

confident about the changes you make. 

After you customize options, you can save them as a preset. Saving color settings ensures that you can reuse them 

and share them with other users or applications. 

•	 To save color settings as a preset, click Save in the Color Settings dialog box. To ensure that the application displays 

the setting name in the Color Settings dialog box, save the file in the default location. If you save the file to a 

different location, you must load the file before you can select the setting. 

•	 To load a color settings preset that’s not saved in the standard location, click Load in the Color Settings dialog box, 

select the file you want to load, and click Open. 

About color working spaces 
A working space is an intermediate color space used to define and edit color in Adobe applications. Each color model 

has a working space profile associated with it. You can choose working space profiles in the Color Settings dialog box. 

A working  space profile  acts  as  the source profile  for newly created  documents that use  the associated color  model.  

For example, if Adobe RGB (1998) is the current RGB working space profile, each new RGB document that you 

create will use colors within the Adobe RGB (1998) gamut. Working spaces also determine the appearance of colors 

in untagged documents. 

If you open a document embedded with a color profile that doesn’t match the working space profile, the application 

uses a color management policy to determine how to handle the color data. In most cases, the default policy is to 

preserve  the embedded profile. For  more  information on setting  up  color management policies,  see “About missing  

and mismatched color profiles” on page 269 and “Color Management Policy options” on page 270. 
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Working Space options 
To display working space options, choose Edit > Color Settings. 

To view a description of any profile, select the profile and then position the pointer over the profile name. The 

description appears at the bottom of the dialog box. 

RGB Determines the RGB color space of the application. In general, it’s best to choose Adobe RGB or sRGB, rather 

than the profile for a specific device (such as a monitor profile). 

sRGB is recommended when preparing images for the web, because it defines the color space of the standard monitor 

used  to  view  images  on  the web. sRGB is also a good  choice  when  working with images from consumer-level digital  

cameras, because most of these camera use sRGB as their default color space. 

Adobe RGB is recommended when preparing documents for print, because Adobe RGB’s gamut includes some 

printable colors (cyans and blues in particular) that can't be displayed using sRGB. Adobe RGB is also a good choice 

when working with images from professional-level digital cameras, because most of these camera use Adobe RGB as 

their default color space. 

CMYK Determines the CMYK color space of the application. All CMYK working spaces are device-dependent, 

meaning that they are based on actual ink and paper combinations. The CMYK working spaces Adobe supplies are 

based on standard commercial print conditions. 

Gray (Photoshop) Determines Grayscale color space of the application. 

Spot (Photoshop) Specifies the dot gain to use when displaying spot color channels and duotones. 

Adobe applications ship with a standard set of working space profiles that have been recommended and tested by 

Adobe Systems for most color management workflows. By default, only these profiles appear in the working space 

menus. To display additional color profiles that you have installed on your system, select Advanced Mode (Illustrator 

and InDesign) or More Options (Photoshop). A color profile must be bi-directional, that is, contain specifications 

for translating both into and out of color spaces in order to appear the working space menus. 

Note: In Photoshop, you can create custom working space profiles. However, Adobe recommends that you use a standard 

working space profile rather than creating a custom working space profile. For more information, see the Photoshop 

support knowledgebase at http://www.adobe.com/support/products/photoshop.html. 

About missing and mismatched color profiles 
For a newly created document, the color workflow usually operates seamlessly: unless specified otherwise, 

the document uses the working space profile associated with its color mode for creating and editing colors. 

However,  some  existing  documents may  not use  the working  space profile  that  you have specified,  and some existing  

documents may not be color-managed. It is common to encounter the following exceptions to your color-managed 

workflow: 

•	 You might open a document or import color data (for example, by copying and pasting or dragging and dropping) 

from a document that is not tagged with a profile. This is often the case when you open a document created in an 

application that either does not support color management or has color management turned off. 

•	 You might open a document or import color data from a document that is tagged with a profile different from the 

current working  space.  This  may be the  case  when  you open a document  that  has been created  using different  color  

management settings, or a document that has been scanned and tagged with a scanner profile. 

In either case, the application uses a color management policy to decide how to handle the color data in the document. 

(See “Color Management Policy options” on page 270.) 
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If the profile is missing or does not match the working space, the application may display a warning message, 

depending on options you set in the Color Settings dialog box. Profile warnings are turned off by default, but you 

can turn them on to ensure the appropriate color management of documents on a case-by-case basis. The warning 

messages vary between applications, but in general you have the following options: 

•	 (Recommended) Leave the document or imported color data as it is. For example, you can choose to use the 

embedded profile (if one exists), leave the document without a color profile (if one doesn’t exist), or preserve the 

numbers in pasted color data. 

•	 Adjust the document or imported color data. For example, when opening a document with a missing color profile, 

you can choose to assign the current working space profile or a different profile. When opening a document with 

a mismatched color profile, you can choose to discard the profile or convert the colors to the current working 

space.  When  importing color  data, you  can choose to convert  the colors to the  current working  space in order  to  

preserve their appearance. 

Color Management Policy options 
A color management policy determines how the application handles color data when you open a document or 

import an image. You can choose different policies for RGB and CMYK images, and you can specify when you want 

warning messages to appear. To display color management policy options, choose Edit > Color Settings. 

To view a description of a policy, select the policy and then position the pointer over the policy name. The description 

appears at the bottom of the dialog box. 

RGB, CMYK, and Gray Specifies a policy to follow when bringing colors into the current working space (either by 

opening files or importing images into the current document). (The Grayscale option is available for Photoshop and 

GoLive only.) Choose from the following options: 

• Preserve Embedded Profiles Always preserves embedded color profiles when opening files. This is the recom

mended option for most workflows because it provides consistent color management. One exception is if you’re 

concerned about preserving CMYK numbers, in which case you should select Preserve Numbers (Ignore Linked 

Profiles) instead. 

• Convert to Working Space Converts colors to the current working space profile when opening files and importing 

images. Select this option if you want to force all colors to use a single profile (the current working space profile). 

• Preserve Numbers (Ignore Linked Profiles) This option is available in InDesign and Illustrator for CMYK. 

Preserves color  numbers when opening  files and  importing images,  but still  allows  you to use  color management to  

view colors accurately in Adobe applications. Select this option if you want to use a safe CMYK workflow. (See “Using 

a safe CMYK workflow” on page 256.) In InDesign, you can override this policy on a per-object basis by choosing 

Object > Image Color Settings. 

• Off Ignores embedded color profiles when opening files and importing images, and does not assign the working 

space profile to new documents. Select this option if you want to discard any color metadata provided by the original 

document creator. 

Profile Mismatches: Ask When Opening Displays a message whenever you open a document tagged with a profile 

other than the current working space. You will be given the option to override the policy’s default behavior. Select 

this option if you want to ensure the appropriate color management of documents on a case-by-case basis. 

Profile Mismatches: Ask When Pasting Displays a message whenever color profile mismatches occur as colors are 

imported into a document via pasting or dragging-and-dropping. You will be given the option to override the policy’s 
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default behavior. Select this option if you want to ensure the appropriate color management of pasted colors on a 

case-by-case basis. 

Missing Profiles: Ask When Opening Displays a message whenever you open an untagged document. You will be 

given the option to override the policy’s default behavior. Select this option if you want to ensure the appropriate 

color management of documents on a case-by-case basis. 

Color Conversion options 
Color conversion options let you control how the application handles the colors in a document as it moves from one 

color space to another. Changing these options is recommended only if you are knowledgeable about color 

management and very confident about the changes you make. To display conversion options, choose Edit > Color 

Settings, and select Advanced Mode (Illustrator and InDesign) or More Options (Photoshop). 

Engine Specifies the Color Management Module (CMM) used to map the gamut of one color space to the gamut of 

another. For most users, the default Adobe (ACE) engine fulfills all conversion needs. 

To view a description of an engine or intent option, select the option and then position the pointer over the option 

name. The description appears at the bottom of the dialog box. 

Intent Specifies the rendering intent used to translate one color space to another. Differences between rendering 

intents are apparent only when you print a document or convert it to a different working space. 

Use Black Point Compensation Ensures that the shadow detail in the image is preserved by simulating the full 

dynamic range of the output device. Select this option if you plan to use black point compensation when printing 

(which is recommended in most situations). 

Use Dither (Photoshop) Controls whether to dither colors when converting 8-bit-per-channel images between 

color spaces. When the Use Dither option is selected, Photoshop mixes colors in the destination color space to 

simulate a missing color that existed in the source space. Although dithering helps to reduce the blocky or banded 

appearance of an image, it may also result in larger file sizes when images are compressed for web use. 

About rendering intents 
A rendering intent determines how a color management system handles color conversion from one color space to 

another. Different rendering intents use different rules to determine how the source colors are adjusted; for example, 

colors that fall inside the destination gamut may remain unchanged, or they may be adjusted to preserve the original 

range of visual relationships when translated to a smaller destination gamut. The result of choosing a rendering intent 

depends on the graphical content of documents and on the profiles used to specify color spaces. Some profiles 

produce identical results for different rendering intents. 

In general, it is best to use the default rendering intent for the selected color setting, which has been tested by Adobe 

Systems to meet industry standards. For example, if you choose a color setting for North America or Europe, the 

default rendering intent is Relative Colorimetric. If you choose a color setting for Japan, the default rendering intent is 

Perceptual. 
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You can select a rendering intent when you set color conversion options for the color management system, soft-proof 

colors, and print artwork: 

Perceptual Aims to preserve the visual relationship between colors so it’s perceived as natural to the human eye, 

even though the color values themselves may change. This intent is suitable for photographic images with lots of out-

of-gamut colors. This is the standard rendering intent for the Japanese printing industry. 

Saturation Tries to produce vivid colors in an image at the expense of color accuracy. This rendering intent is 

suitable for business graphics like graphs or charts, where bright saturated colors are more important than the exact 

relationship between colors. 

Relative Colorimetric Compares the extreme highlight of the source color space to that of the destination color 

space and shifts all colors accordingly. Out-of-gamut colors are shifted to the closest reproducible color in the desti

nation color space. Relative colorimetric preserves more of the original colors in an image than Perceptual. This is 

the standard rendering intent for printing in North America and Europe 

Absolute Colorimetric Leaves colors that fall inside the destination gamut unchanged. Out of gamut colors are 

clipped. No scaling of colors to destination white point is performed. This intent aims to maintain color accuracy at 

the expense of preserving relationships between colors and is suitable for proofing to simulate the output of a 

particular device. This intent is particularly useful for previewing how paper color affects printed colors. 

Advanced controls 
In Photoshop you display advanced controls for managing color by choosing Edit > Color Settings and selecting 

More Options. 

Desaturate Monitor Colors By Determines whether to desaturate colors by the specified amount when displayed 

on the monitor. When selected, this option can aid in visualizing the full range of color spaces with gamuts larger 

than that of the monitor. However, this causes a mismatch between the monitor display and the output. When the 

option is deselected, distinct colors in the image may display as a single color. 

Blend RGB Colors Using Gamma Controls how RGB colors blend together to produce composite data (for example, 

when you blend or paint layers using Normal mode). When the option is selected, RGB colors are blended in the 

color space corresponding to the specified gamma. A gamma of 1.00 is considered “colorimetrically correct” and 

should result in the fewest edge artifacts. When the option is deselected, RGB colors are blended directly in the 

document’s color space. 

Note: When you select Blend RGB Colors Using Gamma, layered documents will look different when displayed in other 

applications than they do in Photoshop. 
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Chapter 11: Making color and tonal 
adjustments 

Color and tonal corrections 

Before making color and tonal adjustments 
The powerful tools in Photoshop and ImageReady can enhance, repair, and correct the color and tonality (lightness, 

darkness, and contrast) in an image. Here are some items to consider before making color and tonal adjustments. 

•	 Work with a monitor that’s calibrated and profiled. For critical image editing, this is absolutely essential. 

Otherwise, the image you see on your monitor will look different when printed. 

•	 Whenever  you make a color or tonal  adjustment  to  an  image,  some  image information  is  discarded.  It’s  best  to  be  

judicious regarding the amount of correction you apply to an image. 

•	 (Photoshop) For critical work and maximum preservation of image data, it’s best if the image you work with is 16 

bits per channel (16-bit image) rather than 8 bits per channel (8-bit image). Data is discarded when you make tonal 

and color adjustments. The loss of image information is more critical in an 8-bit image than a 16-bit image. 

Generally, 16-bit images have a larger file size than 8-bit images. 

Note: If you jump back and forth between Photoshop and ImageReady, be aware that ImageReady converts 16-bit images 

to 8-bit for editing. After the images are saved in ImageReady, they are permanently converted to 8-bit images, and the 

discarded data is unrecoverable. However, if you are editing a 16-bit image in ImageReady and haven't saved it yet, you 

can return to Photoshop. Photoshop opens it as a 16-bit image without data loss. 

•	 Duplicate or make a copy of the image file. Working on a copy of your image preserves the original in the event 

you need to use the image in its original state. 

•	 Remove any flaws such as dust spots, blemishes, and scratches from the image before making color and tonal 

adjustments. 

•	 (Photoshop) Plan to use adjustment layers to adjust the tonal range and color balance of your image rather than 

applying an adjustment directly to the image layer itself. Adjustment layers let you go back and make successive 

tonal adjustments without discarding data from the image layer. Keep in mind that using adjustment layers adds 

to the file size of the image and demands more RAM from your computer. 

•	 (Photoshop) Open the Info or Histogram palette in Expanded view. As you evaluate and correct the image, both 

palettes display invaluable feedback on your adjustments. 

•	 You can make a selection or use a mask to confine your color and tonal adjustments to part of an image. Another 

way to apply color and tonal adjustments selectively is to set up your document with image components on 

different layers. Color and tonal adjustments are applied to only one layer at a time and affect only the image 

components on the targeted layer. 
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Correcting images in Photoshop 
Here is the general workflow you follow when you correct the tonality and color of an image: 

1 Use the histogram to check the quality and tonal range of the image. 

2 Adjust the color balance to remove unwanted color casts or to correct oversaturated or undersaturated colors. See 

“Color adjustment commands” on page 274. 

3 Adjust the tonal range. 

Begin tonal corrections by adjusting the values of the extreme highlight and shadow pixels in the image, setting an 

overall tonal range for the image. This process is known as setting the highlights and shadows or setting the white and 

black points. 

Setting the highlights and shadows typically redistributes the midtone pixels appropriately. However, you may need 

to adjust your midtones manually. See “Tonal adjustment methods” on page 275. 

4 (Optional) Make other color adjustments. 

After you correct the overall color balance of your image, you can make optional adjustments to enhance colors or 

produce special effects. 

5 Sharpen the edges of the image. 

As one of the final steps, use the Unsharp Mask filter to sharpen the clarity of edges in the image. The amount of 

sharpening required for an image varies according to the image quality produced by the digital camera or scanner 

you use. See “Sharpening images” on page 354. 

6 (Optional) Target the image for press characteristics. 

Use the Output sliders in the Levels dialog box or the Curves dialog box to bring important details in the highlights 

and shadows into the gamut of an output device, like a desktop printer. Do this if your image is being sent out to a 

printing press and you know the characteristics of the press. 

Because sharpening increases  the contrast of neighboring  pixels, it’s possible that some pixels in critical areas  might  

become unprintable on the press that you’re using. For this reason, it’s best to fine-tune the output settings after 

sharpening. For more information on adjusting the output settings, see “Setting highlight and shadow target values” 

on page 293. 

Color adjustment commands 
You can choose from the following color adjustment commands: 

Auto Color command Quickly corrects the color balance in an image. Although its name implies an automatic 

adjustment, you can fine-tune how the Auto Color command behaves. See “To remove a color cast with Auto Color” 

on page 309. 

Levels command Adjusts color balance by setting the pixel distribution for individual color channels. See “To use 

Levels to correct a color cast” on page 286. 

Curves command Provides up to 14 controls points for highlight, midtone, and shadow adjustments for individual 

channels. See “About the Curves dialog box” on page 286. 

Photo Filter command Makes color adjustments by simulating the effects of photographing with a Kodak Wratten 

or Fuji filter in front of a camera lens. See “To change the color balance using the Photo Filter command” on page 298. 

Color Balance command Changes the overall mixture of colors in an image. See “To use the Color Balance 

command” on page 298. 
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Hue/Saturation command Adjusts the hue, saturation, and lightness values of the entire image or of individual 

color components. See “The Hue/Saturation command” on page 295. 

Match Color command Matches the color from one photo to another photo, from one layer to another layer, and 

from a selection in an image to another selection in the same image or a different image. This command also adjusts 

the luminance and color range and neutralizes color casts in an image. See “To match the color in different images” 

on page 301. 

Replace Color command Replaces specified colors in an image with new color values. See “To replace the color of 

objects in an image” on page 304. 

Selective Color command Adjusts the amount of process colors in individual color components. See “To use the 

Selective Color command” on page 306. 

Channel Mixer command Modifies a color channel and makes color adjustments not easily done with other color 

adjustment tools. See “Mixing color channels” on page 304. 

Tonal adjustment methods 
There are several different ways to set an image’s tonal range: 

•	 Drag sliders along the histogram in the Levels dialog box. 

•	 Adjust the shape of the graph in the Curves dialog box. This method lets you adjust any point along a 0–255 tonal 

scale and provides the greatest control over an image’s tonal quality. 

•	 Assign target values to the highlight and shadow pixels using either the Levels or Curves dialog box. This can help 

preserve important highlight and shadow details in images being sent to a printing press or laser printer. You 

might also need to fine-tune the target values after sharpening. 

•	 Adjust the tonality in the shadow and highlight areas using the Shadow/Highlight command. This adjustment is 

especially useful for correcting photos in which strong backlighting silhouettes the subject or proximity to the 

camera flash overlightens the subject slightly. 

Viewing histograms and pixel values 

About histograms 
A histogram illustrates how pixels in an image are distributed by graphing the number of pixels at each color intensity 

level. The histogram shows whether the image contains enough detail in the shadows (shown in the left part of the 

histogram), midtones (shown in the middle), and highlights (shown in the right part) to make a good correction. 

The histogram also gives a quick picture of the tonal range of the image, or the image key type. A low-key image has 

detail concentrated in the shadows; a high-key image has detail concentrated in the highlights; and an average-key 

image has detail concentrated in the midtones. An image with full tonal range has a number of pixels in all areas. 

Identifying the tonal range helps determine appropriate tonal corrections. 
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A B C 

How to read a histogram 
A. Overexposed photo B. Properly exposed photo with full tonality C. Underexposed photo 

The Histogram palette offers many options for viewing tonal and color information about an image. By default, the 

histogram displays the tonal range of the entire image. To display histogram data for a portion of the image, first 

select that portion. 

To open the Histogram palette 
❖ Choose Window > Histogram or click the Histogram tab to open the Histogram palette. By default, the Histogram 

palette opens in Compact View with no controls or statistics, but you can adjust the view. 

A B 

C 

D 

E 

Histogram palette 
A. Channel menu B. Palette menu C. Uncached Refresh button D. Cached Data Warning icon E. Statistics 

To adjust the view of the Histogram palette 
❖ Choose a view from the Histogram palette menu . 

Expanded View Displays the histogram with statistics and with controls for choosing the channel represented by 

the histogram, viewing options in the Histogram palette, refreshing the histogram to display uncached data, and 

choosing a specific layer in a multilayered document. 

Compact View Displays a histogram with no controls or statistics. The histogram represents the entire image. 

All Channels View Displays individual histograms of the channels in addition to all the options of the Expanded 

View. The individual histograms do not include alpha channels, spot channels, or masks. 
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Histogram palette with all channels displayed and statistics hidden 

To view a specific channel in the histogram 
If you chose the Expanded View or All Channels View of the Histogram palette, you can choose a setting from the 

Channel menu. Photoshop remembers the channel setting if you switch from either Expanded View or All Channels 

View back to Compact View. 

•	 Choose an individual channel to display a histogram of the document’s individual channels, including color 

channels, alpha channels, and spot channels. 

•	 Depending on the image’s color mode, choose RGB, CMYK, or Composite to view a composite histogram of all 

the channels. This is the default view when you first choose Expanded View or All Channels View. 

•	 If the image is RGB or CMYK, choose Luminosity to display a histogram representing the luminance or intensity 

values of the composite channel. 

•	 If the image is RGB or CMYK, choose Colors to display a composite histogram of the individual color channels in 

color. 

In the All Channels View, choosing from the Channels menu affects only the topmost histogram in the palette. 
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To view channel histograms in color 
❖ From the Histogram palette, do one of the following: 

•	 In the All Channels View, choose Show Channels In Color from the palette menu. 

•	 In Expanded View or All Channels View, choose an individual channel from the Channel menu and choose Show 

Channels In Color from the palette menu. If you switch to Compact View, the channel continues to be shown in 

color. 

•	 In Expanded View or All Channels View, choose Colors from the Channel menu to show a composite histogram 

of  the channels in color. If you  switch  to  Compact View the  composite histogram  continues to be shown  in  color.  

To view histogram statistics 
By default, the Histogram palette displays statistics in the Expanded View and All Channels View. 

1 Choose Show Statistics in the Histogram palette menu. 

2 Do one of the following: 

•	 To view information about a specific pixel value, place the pointer in the histogram. 

• To view information about a range of values, drag in the histogram to highlight the range. 

The palette displays the following statistical information below the histogram: 

Mean Represents the average intensity value. 

Standard deviation (Std Dev) Represents how widely intensity values vary. 

Median Shows the middle value in the range of intensity values. 

Pixels Represents the total number of pixels used to calculate the histogram. 

Level Displays the intensity level of the area underneath the pointer. 

Count Shows the total number of pixels corresponding to the intensity level underneath the pointer. 

Percentile Displays the cumulative number of pixels at or below the level underneath the pointer. This value is


expressed as a percentage of all the pixels in the image, from 0% at the far left to 100% at the far right.


Cache Level Shows the  current image  cache used to create the  histogram.  When  the cache  level is higher than 1, the 


histogram is displayed faster because it is derived from a representative sampling of pixels in the image (based on the


magnification). The original image is cache level 1. At each level above level 1, four adjacent pixels are averaged to


arrive at a single pixel value. So, each level is half the dimensions (has 1/4 the number of pixels) of the one below.


When Photoshop needs to do a quick approximation, it can use one of the upper levels. Click the Uncached Refresh


button to redraw the histogram using the actual image pixels.


To view the histogram for a multilayered document

1 Choose Expanded View from the Histogram palette menu.


2 Choose a setting from the Source menu. (The Source menu is not available for single-layered documents.)


Entire Image Displays a histogram of the entire image, including all layers.


Selected Layer Displays a histogram of the layer that’s selected in the Layers palette. 

Adjustment Composite Displays a histogram of an adjustment layer selected in the Layers palette, including all the 

layers below the adjustment layer. 
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To preview histogram adjustments 
You can preview the effect to the histogram of any color and tonal adjustments.


❖ Select the Preview option in the dialog boxes of any color or tonal adjustment command.


The Histogram palette displays a preview of how the adjustment affects the histogram.


A 

B 

C D E 

Preview of histogram adjustment in the Histogram palette 
A. Original histogram B. Adjusted histogram C. Shadows D. Midtones E. Highlights 

To refresh the histogram display 
When a histogram is read from a cache instead of the document’s current state, the Cached Data Warning icon 

appears in the Histogram palette. Histograms based on the image cache are displayed faster and are based on a repre

sentative sampling of pixels in the image. You can set the cache level (from 2 to 8) in the Memory And Image Cache 

preference. 

❖ To refresh the histogram so that it displays all of the pixels of the original image in its current state, do one of the 

following: 

• Double-click anywhere in the histogram. 

• Click the Cached Data Warning icon . 

• Click the Uncached Refresh button . 

• Choose Uncached Refresh from the Histogram palette menu. 

For information about cache level, see “To view histogram statistics” on page 278. 

Viewing the color values of pixels 
You can  use the  Info  palette and  the Color  palette to see  the color  value of pixels as you  make  color corrections. This  

feedback is useful while you make color adjustments. For instance, referring to the color values can help when 

neutralizing a color cast or can alert you that a color is saturated. 

When you work with a color adjustment dialog box, the Info palette displays two sets of color values for the pixels 

under the pointer. The value in the left column is the original color value. The value in the right column is the color 

value after the adjustment is made. 
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Using Levels and Info palette to neutralize the tone of an image 

You can view the color of a single location using the Eyedropper tool , or you can use up to four Color 

Samplers  to display color information for one or more locations in the image. These samplers are saved in the 

image, so you can refer to them repeatedly as you work, even if you close and reopen the image. 

Color samplers and Info palette 

To view color values in an image 
1 Choose Window > Info to open the Info palette. 

2 Select the Eyedropper tool  or Color Sampler tool , and if necessary, choose a sample size in the options


bar:


Point Sample Reads the value of a single pixel.


3 By 3 Average Reads the average value of a 3-by-3 pixel area.


5 By 5 Average Reads the average value of a 5-by-5 pixel area. 

3 If you selected the Color Sampler tool , place up to four color samplers on the image. Click where you want to 

place a sampler. 
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4	 Open an adjustment dialog box (under Image > Adjustments). 

5 Make your adjustments in the dialog box and, before applying them, view the before and after color values in the 

Info palette: 

•	 To view color values using the Eyedropper tool , move the pointer over the area of the image you want to 

examine. Opening an adjustment dialog box activates the Eyedropper tool outside the dialog box. You still have 

access to the scroll controls and to the Hand and Zoom  tools using keyboard shortcuts. 

•	 To view the color values under the color samplers, look at the lower half of the Info palette. To place additional 

color samplers in the image while the adjustment dialog box is open, Shift-click in the image. 

The Color palette also shows the color value of pixels under the eyedropper. 

To move or delete a color sampler 
1 Select the Color Sampler tool 

2 Do one of the following: 

. 

•	 To move a color sampler, drag the sampler to the new location. 

•	 To delete a color sampler, drag the sampler out of the document window. Alternatively, hold down Alt (Windows) 

or Option (Mac OS) until the pointer becomes a scissors and click the sampler. 

•	 To delete all color samplers, click Clear in the options bar. 

•	 To delete a color sampler while an adjustment dialog box is open, hold down Alt+Shift (Windows) or 

Option+Shift (Mac OS), and click the sampler. 

To hide or show color samplers in an image 
❖ Choose View > Extras. A check mark indicates that color samplers are visible. 

To change the display of color sampler information in the Info palette 
•	 To  display or hide  color sampler  information in the  Info  palette,  choose  Color Samplers from the  palette menu.  A  

check mark indicates that the color sampler information is visible. 

• 

icon

To change the color space in which a color sampler displays values, move the pointer onto the color sampler

 in the Info palette, hold down the mouse button, and choose another color space from the menu. 

Understanding color adjustments 

Making color adjustments 
All Photoshop and ImageReady color adjustment tools work essentially the same way: They map an existing range 

of pixel values to a new range of values. The difference between the tools is the amount of control they provide. For 

an overview of the color adjustment tools, see “Tonal adjustment methods” on page 275. 

There are two ways to adjust the colors in an image. The first is to choose a command from the Image > Adjustments 

submenu. This method permanently alters the pixels in the active layer. 
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The second and more flexible method is to use an adjustment layer. Adjustment layers let you experiment with color 

and tonal adjustments without permanently modifying the pixels in the image. The color and tonal changes reside 

within the adjustment layer, which acts as a veil through which the underlying image layers appear. You must use 

Photoshop to create and edit adjustment layers; however, you can view existing adjustment layers in ImageReady. 

To open a color adjustment dialog box 
1 If you want to make adjustments to just a portion of your image, select that portion. If you make no selection, the 

adjustment is applied to the entire image. 

2 Do one of the following: 

• Choose Image > Adjustments, and choose a command from the submenu.


• (Photoshop) Create an adjustment layer. (See “To create an adjustment layer or fill layer” on page 425.)


• (Photoshop) Double-click the thumbnail of an existing adjustment layer in the Layers palette.


3 To see your adjustments in the image before accepting them, select Preview in the color adjustment dialog box.


To cancel changes without closing a color adjustment dialog box, hold down Alt (Windows) or Option (Mac OS) to 

change the Cancel button to Reset; then click Reset. This resets the dialog box to the values it had prior to your 

changes. 

To save and reapply settings in a dialog box 
The Save and Load buttons in the Levels, Curves (Photoshop), Hue/Saturation, Match Color (Photoshop), Replace 

Color (Photoshop), Selective Color (Photoshop), Channel Mixer (Photoshop), Shadow/Highlight (Photoshop), and 

Variations dialog boxes let you save your settings and apply them to other images. The procedure for saving and 

loading a setting in the Match Color command is slightly different. For saving and loading settings in the Match 

Color command, see “To save and apply settings in the Match Color command” on page 304. 

• To save a setting, click Save in the adjustment dialog box you are using. Name and save the settings. 

• To apply a saved setting, in an adjustment dialog box, click Load. Locate and load the saved adjustment file. 

If you apply the same adjustment often, consider recording and running the adjustment as an action or creating a 

droplet. 

Correcting in CMYK and RGB 
Even though you can perform all color and tonal corrections in RGB mode and nearly all adjustments in CMYK, you 

should choose a mode carefully. Whenever possible, avoid multiple conversions between modes, because color 

values are rounded and lost with each conversion. If an RGB image is to be used on-screen, you don’t have to convert 

it to CMYK mode. Conversely, if a CMYK scan is to be separated and printed, you don’t have to perform corrections 

in RGB mode. 
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If you must convert your image from one mode to another, it makes sense to perform most of your tonal and color 

corrections in RGB mode and use CMYK mode for fine-tuning. Advantages of working in RGB mode include the 

following: 

•	 You can save memory and improve performance because you are working with fewer channels. 

•	 The range of colors in RGB spaces is much larger than the range in CMYK spaces, and more colors are likely to be 

preserved after adjustments. 

Using the Proof Setup and Proof Color commands, you can preview composite CMYK colors and separation plates 

using the CMYK working space defined in the Color Settings dialog box. Or, you can preview colors using a custom 

CMYK color profile. 

You can edit an image in RGB mode in one window and view the same image in CMYK colors in another window. 

Choose Window > Arrange > New Window For (File Name) to open a second window with the image you’re working 

on. Make sure Working CMYK is chosen for Proof Setup and then use the Proof Color command to turn on the CMYK 

preview in one of the windows. 

About out-of-gamut colors 
A gamut is the range of colors that a color system can display or print. A color that can be displayed in RGB may be 

out of gamut, and therefore unprintable, for your CMYK setting. 

Photoshop automatically brings all colors into gamut when you convert an RGB image to CMYK. But you might 

want to identify the out-of-gamut colors in an image or correct them manually before converting to CMYK. 

In RGB mode, you can tell whether a color is out of gamut in the following ways: 

•	 In the Info palette, an exclamation point appears next to the CMYK values whenever you move the pointer over 

an out-of-gamut color. 

•	 In both the Color Picker and the Color palette, an alert triangle  appears and the closest CMYK equivalent is 

displayed whenever you select an out-of-gamut color. To select the CMYK equivalent, click the triangle or the 

color patch. 

•	 You can use the Gamut Warning command to search for out-of-gamut colors. 

To turn the highlighting of out-of-gamut colors on or off

1 Choose View > Proof Setup, and choose the proof profile on which you want to base the gamut warning.


2 Choose View > Gamut Warning. All pixels outside the gamut of the current proof profile space are highlighted.


To change the gamut warning color 
1 Do one of the following: 

•	 In Windows, choose Edit > Preferences > Transparency & Gamut. 

•	 In Mac OS, choose Photoshop > Preferences > Transparency & Gamut. 

2 Under Gamut Warning, click the color box to display the Color Picker. Then choose a new warning color, and 

click OK. For best results, use a color that is not already present in the image. 

3 Enter a value in the Opacity text box. Values can range from 0 to 100%. Use this setting to reveal more or less of 

the underlying image through the warning color. Then click OK. 
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Original image, and preview of out-of-gamut colors with green chosen for the gamut warning color 

Adjusting images with Levels, Curves, and Exposure 

About the Levels dialog box 
The Levels dialog box lets you correct the tonal range and color balance of an image by adjusting intensity levels of 

image shadows, midtones, and highlights. The Levels histogram is a visual guide for adjusting the image key tones. 

For more information on how to read a histogram, see “About histograms” on page 275. 

You can save settings made in the Levels dialog box for use on another image. See “To save and reapply settings in a 

dialog box” on page 282. 

A B C D E 

Levels dialog box 
A. Apply Auto Color Correction B. Open Auto Color Correction Options dialog box C. Shadows D. Midtones E. Highlights 

Using Levels to set highlights, shadows, and midtones 
The outer two Input Levels sliders map the black point and white point to the settings of the Output sliders. By 

default, the Output sliders are at level 0, where the pixels are completely black, and level 255, where the pixels are 

completely white. So, in the default position for the Output sliders, moving the black input slider maps the pixel value 

to level 0, and moving the white point slider maps the pixel value to level 255. The remaining levels are redistributed 

between levels 0 and 255. This redistribution increases the tonal range of the image, in effect increasing the overall 

contrast of the image. 

Note: When shadows are clipped, the pixels are completely black, with no detail. When highlights are clipped, the pixels 

are completely white, with no detail. 

The middle Input slider adjusts the gamma in the image. It moves the midtone (level 128) and changes the intensity 

values of the middle range of gray tones without dramatically altering the highlights and shadows. 
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To adjust tonal range using Levels 
1 Do one of the following: 

• Choose Image > Adjustments > Levels. 

• (Photoshop) Choose Layer > New Adjustment Layer > Levels. Click OK in the New Layer dialog box. 

2 To adjust tones for a specific color channel, choose an option from the Channel menu. 

To edit a combination of color channels at the same time, Shift-select the channels in the Channels palette before 

choosing the Levels command. The Channel menu then displays the abbreviations for the target channels—for 

example, CM for cyan and magenta. The menu also contains the individual channels for the selected combination. 

You must edit spot channels and alpha channels individually. Keep in mind that this method does not work in a 

Levels adjustment layer. 

3 To adjust the shadows and highlights manually, drag the black and white Input Levels sliders to the edge of the 

first group of pixels on either end of the histogram. 

For example, if you move the black point slider to the right at level 5, Photoshop maps all the pixels at level 5 and 

lower to level 0. Similarly, if you move the white point slider to the left at level 243, Photoshop maps all pixels at level 

243 and higher to level 255. The mapping affects the darkest and lightest pixels in each channel. The corresponding 

pixels in the other channels are adjusted proportionately to avoid altering the color balance. 

Note: You can also enter values directly into the first and third Input Levels text boxes. 

Adjusting black and white points with Levels Input sliders 

4 To adjust midtones, use the middle Input slider to make a gamma adjustment. 

Moving the middle Input slider to the left makes the overall image lighter. This slider adjustment maps a lower 

(darker) level up to the midpoint level between the Output sliders. If the Output sliders are in their default position 

(0 and 255), the midpoint is level 128. In this example, the shadows expand to fill the tonal range from 0 to 128, and 

the highlights are compressed. Moving the middle Input slider to the right has the opposite effect, making the image 

darker. 

Note: You can also enter a gamma adjustment value directly in the middle Input Levels text box. 
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Moving the middle slider adjusts the image gamma 

5 Click OK.


You can view the adjusted histogram in the Histogram palette.


To use Levels to correct a color cast

1 Do one of the following to open the Levels dialog box:


•	 Choose Image > Adjustments > Levels. 

• (Photoshop) Choose Layer > New Adjustment Layer > Levels. Click OK in the New Layer dialog box. 

2 Do one of the following to neutralize a color cast: 

•	 Double-click the Set Gray Point Eyedropper tool  in the Levels dialog box to display the Adobe Color Picker. 

Enter the values you want to assign to the neutral gray, and click OK. Then click in a part of the image that should 

be neutral gray. 

•	 Click Options in the Levels dialog box. Click the Midtones color swatch to display the Adobe Color Picker. Enter 

the values you want to assign to the neutral gray, and click OK. This method has the advantage of showing you a 

preview of the values you’re assigning. 

In general, assign equal color component values to achieve a neutral gray. For example, assign equal red, green, and 

blue values to produce a neutral gray in an RGB image. 

About the Curves dialog box 
The Curves dialog box, like the Levels dialog box, lets you adjust the entire tonal range of an image. But unlike Levels, 

which has only three adjustments (white point, black point, gamma), Curves lets you adjust up to 14 different points 

throughout an image’s tonal range (from shadows to highlights). You can also use Curves to make precise adjust

ments to individual color channels in an image. You can save settings made in the Curves dialog box for use in 

another image. See “To save and reapply settings in a dialog box” on page 282. 
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A 

B 

C 

D E F G H 

Curves dialog box 
A. Highlights B. Midtones C. Shadows D. Adjust curve by adding points E. Draw  a curve  with  the pencil  F. Set black point G. Set 
gray point H. Set white point 

When the Curves dialog box opens, the tonal range is represented as a straight diagonal line. The horizontal axis of 

the graph represents the original intensity values of the pixels (Input levels); the vertical axis represents the new color 

values (Output levels). 

By default, Curves displays the intensity values for RGB images in a range from 0 to 255, with black (0) at the bottom 

left corner. By default, Curves displays percentages for CMYK images in a range from 0 to 100, with highlights (0%) 

at  the bottom left corner.  To  reverse the  display of intensity  values  and percentages, click  the double arrow  below the  

curve. After the reversal, 0 is at the bottom right corner for RGB images; 0% is at the bottom right corner for CMYK 

images. 
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A B C D E F 

Default Curves dialog boxes for CMYK and RGB images 
A. Default orientation of CMYK tonal output bar B. CMYK Input and Output values in percentages C. Default orientation of CMYK ton
al input bar D. Default orientation of RGB tonal output bar E. RGB Input and Output values in intensity levels F. Default orientation of 
RGB tonal input bar 

•	 To make the Curves grid smaller, hold down Alt (Windows) or Option (Mac OS), and click the grid. Alt/Option-

click again to make the grid larger. 

•	 To make the Curves dialog box larger or smaller, click the icon in the lower right corner. 

Clicking the Auto button applies either an Auto Color, Auto Contrast, or Auto Levels correction, depending on the 

settings in the Auto Color Correction Options dialog box. For more information on specifying the settings for Auto 

Color, Auto Contrast, or Auto Levels, see “To set Auto Color Correction options” on page 309. 

Adjusting color and tonality with Curves 
Changing the shape of the curve in the Curves dialog box alters the tonality and color of an image. Bowing the curve 

upward or downward lightens or darkens the image, depending on whether the dialog box is set to display levels or 

percentages. The steeper sections of the curve represent portions of an image with more contrast. Conversely, flatter 

sections of the curve represent areas of lower contrast. 

If the Curves dialog box is set to display levels rather than percentages, the highlights are represented in the top right 

corner of the graph. Moving a point in the top portion of the curve primarily adjusts the highlights; moving a point 

in the center of the curve primarily adjusts the midtones; and moving a point in the bottom section of the curve 

primarily adjusts the shadows. Moving a point either down or to the right maps the Input value to a lower Output 

value, and the image darkens. Conversely, moving a point either up or to the left maps a lower Input value to a higher 

Output value, and the image lightens. So, if you want to lighten the shadows, move up a point near the bottom of the 

curve. And, if you want to darken highlights, move down a point near the top of the curve. 

Note: In general, only small curve adjustments are necessary to make tonal and color corrections to most images. 

To adjust color and tonality with Curves 
1 Do one of the following: 

•	 Choose Image > Adjustments > Curves. 

•	 Choose Layer > New Adjustment Layer > Curves. Click OK in the New Layer dialog box 

2 (Optional) To adjust the color balance of the image, choose the channel or channels that you want to adjust from 

the Channel menu. 
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To edit a combination of color channels at the same time, Shift-select the channels in the Channels palette before

choosing Curves. The Channel menu then displays the abbreviations for the target channels—for example, CM for

cyan and magenta. The menu also contains the individual channels for the selected combination. Keep in mind that

this method does not work in a Curves adjustment layer.

3 Add a point along the curve by doing one of the following:

• Click directly on the curve.

• (RGB images only) Ctrl-click (Windows) or Command-click (Mac OS) a pixel in the image.

Ctrl/Command-clicking pixels in the image is the best way to add points when you want to preserve or adjust specific

details in an image.

You can add up to 14 control points to the curve. To remove a control point, drag it off the graph, select it and press

Delete, or Ctrl-click (Windows) or Command-click (Mac OS) the control point. You cannot delete the endpoints of

the curve.

Ctrl-clicking (Windows) or Command-clicking (Mac OS) three areas of an image to add points to the curve. Lightening the highlights and dark-
ening the shadows is represented by an S-curve where the image contrast is increased.

To determine the lightest and darkest areas in an RGB image, drag over the image. The intensity values of the area

under the pointer, and the corresponding location on the curve, are displayed in the Curves dialog box. Dragging the

pointer over a CMYK image shows the percentages in the Color palette if it’s displaying CMYK values.

4 Do one of the following to adjust the shape of the curve:

• Click a point, and drag the curve until the image looks right to you.

• Click a point on the curve, and enter values in the Input and Output text boxes.

• Select the pencil at the bottom of the dialog box, and drag to draw a new curve. You can hold down Shift to

constrain the curve to a straight line, and click to define endpoints. When you finish, click Smooth if you want to

smooth the curve.

Points on the curve remain anchored until you move them. As a result, you can make an adjustment in one tonal area

while other areas remain unaffected.
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Keyboard shortcuts for Curves 
The following shortcuts work with the Curves dialog box: 

•	 Ctrl-click (Windows) or Command-click (Mac OS) in the image to set a point on the curve in the current channel 

specified in the Curves dialog box. 

•	 Shift+Ctrl-click (Windows) or Shift+Command-click (Mac OS) in the image to set a point on the curve for the 

selected color in each color component channel (but not in the composite channel). 

•	 Shift-click points on the curve to select multiple points. Selected points are filled with black. 

•	 Click in the grid, or press Ctrl-D (Windows) or Command-D (Mac OS) to deselect all points on the curve. 

•	 Press arrow keys to move selected points on the curve. 

•	 Press Ctrl+Tab (Windows) or Control+Tab (Mac OS) to move forward through control points on the curve. 

•	 Press Shift+Ctrl+Tab (Windows) or Shift+Control+Tab (Mac OS) to move backward through control points on 

the curve. 

To add contrast to a photo 
You can add contrast to an image in two ways, depending on the problem. 

If the image needs overall contrast because it doesn’t use the full tonal range, choose Image > Adjustments > Levels. 

Then drag the Shadow and Highlight input sliders inward until they touch the ends of the histogram. 

A	 B 

Image pixels don’t extend to the ends of the graph, indicating that the image is not using the full tonal range. 
A. Shadow Input slider B. Highlight Input slider 

If the image uses the full tonal range, but needs midtone contrast, choose Image > Adjustments > Curves. Drag the 

curve into an S shape. 

Increasing the slope in the middle of the curve increases contrast in the midtones. 

See also 

“Adjustment layers and fill layers” on page 423 
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Correcting color with the eyedroppers 
You can use the eyedroppers in the Levels or Curves dialog boxes to correct a color cast. It’s easier to color-balance 

an image by first identifying an area that should be neutral and then removing the color cast from that area. 

Depending on the image, you may want to use one or all three of the eyedroppers. The eyedroppers work best on an 

image with easily identified neutrals. 

Note: The Set Gray Point Eyedropper tool is used primarily for color correction and is unavailable when you work 

with grayscale images. 

For the best results, don’t use the eyedroppers in images that require a large adjustment to map a pixel to the 

maximum highlight or minimum shadow values. 

Important: Using the eyedroppers undoes any previous adjustment you made in Levels or Curves (Photoshop). If you 

plan to use the eyedroppers, it’s best to use them first and then fine-tune your adjustments with the Levels sliders or 

Curves points (Photoshop). 

To color correct using the eyedroppers 
1 Identify a highlight, midtone, and shadow area that should be neutral gray. Depending on the image and the result 

you want, you may need to identify only one area. 

Use a color sampler to mark a neutral area so that you can click it with an eyedropper later. 

2 Open  the Levels or Curves dialog box. Choose Image  > Adjustments,  and then choose Levels or Curves.  You can  

also use an adjustment layer. 

3 Double-click the Set Black Point tool , the Set Gray Point tool , or the Set White Point Eyedropper tool .


Use the Adobe Color Picker to specify a neutral target color.


If you’re working in RGB, enter the same values for R, G, and B to specify a neutral color. The neutral color should


be close as possible to the values of the color sampler.


If you want to preserve specific details in the shadow or highlight, specify a value for the Set Black Point and the Set


White Point Eyedropper tools that are within the gamut of the output device (printing press, laser printer, and so


forth).


4 With the targeted eyedropper, click the neutral area that you identified earlier. Make sure to use the appropriate


tool for the shadow and highlight.


5 Repeat steps 3 and 4 using a different eyedropper if necessary.


6 If necessary, make final adjustments in the Levels or Curves (Photoshop) dialog box.


7 Click OK. If you specified new target colors for an eyedropper, Photoshop asks whether you want to save the new


target colors as defaults.


To identify highlights and shadows in Levels

1 Open the Levels dialog box, and make sure the Preview option is selected.


Note: The Threshold mode in Levels is not available for CMYK images. 

2 Hold down Alt (Windows) or Option (Mac OS), and drag the white or black Input Levels triangle. 
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The image changes to Threshold mode, and a high-contrast preview image appears. The visible areas of the image 

indicate the lightest parts of the image if you are dragging the white slider, and the darkest parts if you are dragging 

the black  slider. If a color channel  is  selected  in  the Levels dialog box, the  black area indicates  where none of the  given  

color component exists. 

Image preview in Threshold mode 

3 Slowly drag the slider to the center of the histogram to identify areas in the image that are being clipped


(completely black or completely white). Use the pixels in these areas for targeting the black point and white point in


your image.


To identify highlights and shadows using Threshold

1 Choose Image > Adjustments > Threshold.


2 Select Preview.


3 To identify a representative highlight, drag the slider to the far right until the image becomes pure black. Drag the


slider slowly toward the center until some solid white areas appear in the image, and place a color sampler on one of


the areas. Press Shift to temporarily access the Color Sampler tool.


4 To identify a representative shadow, drag the slider to the far left until the image becomes pure white. Drag the


slider slowly toward the center until some solid black areas appear in the image, and place a color sampler on one of


the areas.


5 Click Cancel to close the Threshold dialog box without applying changes to the image.


You can use the Info palette readouts of the two color samplers to determine your highlight and shadow values.


See also 

“To view color values in an image” on page 280 

To use the Exposure adjustment 
The Exposure dialog box is designed for making tonal adjustments to HDR images, but it works with 8-bit and 16


bit images. Exposure works by performing calculations in a linear color space (gamma 1.0) rather than the image’s


current color space.


1 Choose Image > Adjustments > Exposure.


2 Set any of the following options:


Exposure Adjusts the highlight end of the tonal scale with minimal effect in the extreme shadows.


Offset Darkens the shadows and midtones with minimal affect on the highlights.


Gamma Adjusts the image gamma, using a simple power function. Negative values are mirrored around zero (that


is, they remain negative but still get adjusted as if they were positive).
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The eyedroppers adjust the image’s luminance values (unlike the Levels eyedroppers that affect all color channels). 

• The Set Black Point eyedropper sets the Offset, shifting the pixel you click to zero. 

• The Set White Point eyedropper sets the Exposure, shifting the point you click to white (1.0 for HDR images). 

• The Midtone eyedropper sets the Exposure, making the value you click middle gray. 

See also 

“About High Dynamic Range images” on page 201 

Targeting images for press 

Setting highlight and shadow target values 
Assigning (targeting) an image’s highlight and shadow values is necessary because most output devices (usually 

printing presses) cannot print detail in the blackest shadow values (near level 0) or the whitest highlight values (near 

level 255). Specifying the minimum shadow level and maximum highlight level helps to bring the important shadow 

and highlight details within the gamut of the output device. 

If you are printing an image on a desktop printer and your system is color-managed, you don’t need to set target 

values. The Photoshop color management system automatically makes adjustments to the image you see on the 

screen so that it prints properly on your profiled desktop printer. 

Using Levels to preserve highlight and shadow details for printing 
The Output Levels sliders let you set the shadow and highlight levels to compress the image into a range less than 0 

to 255. Use this adjustment to preserve the shadow and highlight details when an image is being printed on a press 

whose characteristics you know. For example, suppose there are important image details in the highlights with a 

value of 245, and the printing press that you’re using won’t hold a dot smaller than 5%. You can pull the highlight 

slider to level 242 (which is a 5% dot on the press) to shift the highlight detail from 245 to 242. Now, the highlight 

detail will safely print on that press. 

Generally, it is not a good idea to use the Output Levels sliders to target images with specular highlights. Your 

specular highlight will look gray rather than blow out to pure white. Use the highlight eyedropper for images with 

specular highlights. 
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Targeting shadows and highlights with Output Levels sliders

To set target values using the eyedroppers
1 Select the Eyedropper tool  in the toolbox. You can choose 3 by 3 Average from the Sample Size menu in the

Eyedropper tool options. This ensures a representative sample of an area rather than the value of a single screen pixel.

2 Open the Levels or Curves dialog box. Choose Image > Adjustments, and then choose Levels or Curves. You can

also use an adjustment layer.

When you open Levels or Curves, the Eyedropper tool  is active outside the dialog box. You still have access to

the scroll controls, the Hand tool, and the Zoom tool  through keyboard shortcuts.

3 Do one of the following to identify areas of highlights and shadows that you want to preserve in the image:

• Move the pointer around the image, and look at the Info palette to find the lightest and darkest areas that you want

preserved (not clipped to pure black or white). (See “Viewing the color values of pixels” on page 279.)

• Drag the pointer in the image, and look at the Curves dialog box to find the lightest and darkest points you want

to preserve. This method does not work if the Curves dialog box is set to the CMYK composite channel.

When identifying the lightest highlight details that you want targeted to a printable (lower) value, don’t include

specular highlights. Specular highlights such as the highlight glint in jewelry or a spot of glare are meant to be the

brightest points in an image. It’s usually desirable to clip specular highlight pixels (pure white, no detail) so that no

ink is printed on the paper.

You can also use the Threshold command to identify representative highlights and shadows before opening Levels or

Curves. (See “To convert images to black and white” on page 313.)

4 To assign highlight values to the lightest area of the image, double-click the Set White Point Eyedropper tool

in the Levels or Curves dialog box to display the Color Picker. Enter the values you want to assign to the lightest area

in the image, and click OK. Then click the highlight you identified in step 3.

If you accidentally click the wrong highlight, hold down Alt (Windows) or Option (Mac OS), and click Reset in the

Levels or Curves dialog box.

Depending on the output device, you can achieve a good highlight in an average-key image using CMYK values of

5, 3, 3, and 0, respectively, when you are printing on white paper. An approximate RGB equivalent is 244, 244, 244,

and an approximate grayscale equivalent is a 4% dot. You can approximate these target values quickly by entering 96

in the Brightness (B) text box under the HSB area of the Color Picker.

With a low-key image, you may want to set the highlight to a lower value to avoid too much contrast. Experiment

with Brightness values between 96 and 80.
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The pixel values are adjusted throughout the image proportionately to the new highlight values. Any pixels lighter

than the area you clicked are clipped (adjusted to level 255, pure white). The Info palette shows the values both before

and after the color adjustment.

Setting the target value for the Set White Point Eyedropper tool and then clicking a highlight to assign it the target value

5 To assign shadow values to the darkest area of the image that you want preserved, double-click the Set Black Point

Eyedropper tool  in the Levels or Curves dialog box to display the Color Picker. Enter the values you want to

assign to the darkest area in the image, and click OK. Then click the shadow you identified in step 3.

When you’re printing on white paper, you can usually achieve a good shadow in an average-key image using CMYK

values of 65, 53, 51, and 95. An approximate RGB equivalent is 10, 10, 10, and an approximate grayscale equivalent

is a 96% dot.You can approximate these values quickly by entering 4 in the Brightness (B) text box under the HSB

area of the Color Picker.

With a high-key image, you may want to set the shadow to a higher value to maintain detail in the highlights. Exper-

iment with Brightness values between 4 and 20.

Making hue/saturation and color balance corrections

The Hue/Saturation command
The Hue/Saturation command lets you adjust the hue, saturation, and brightness of a specific color component in an

image or simultaneously adjust all the colors in an image. In Photoshop, this command is especially good for fine-

tuning colors in a CMYK image so that they are in the gamut of an output device.

You can save settings in the Hue/Saturation dialog box and load them for reuse in other images. For more infor-

mation, see “To save and reapply settings in a dialog box” on page 282.
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To use the Hue/Saturation command 
1 Do one of the following: 

•	 Choose Image > Adjustments > Hue/Saturation. 

•	 (Photoshop) Choose Layer > New Adjustment Layer > Hue/Saturation. Click OK in the New Layer dialog box. 

The two color bars in the dialog box represent the colors in their order on the color wheel. The upper color bar 

shows the color before the adjustment; the lower bar shows how the adjustment affects all of the hues at full 

saturation. 

2	 (Photoshop) Choose which colors to adjust using the Edit pop-up menu: 

•	 Choose Master to adjust all colors at once. 

•	 Choose one of the other preset color ranges listed for the color you want to adjust. To modify the color range, see 

“To specify the range of colors adjusted in the Hue/Saturation command” on page 296. 

3	 For Hue, enter a value or drag the slider until you are satisfied with the colors. 

The values displayed in the text box reflect the number of degrees of rotation around the wheel from the pixel’s 

original color. A positive value indicates clockwise rotation; a negative value, counterclockwise rotation. Values can 

range from -180 to +180. 

0/360 

90270 
A 

B 

180 

Color wheel 
A. Saturation B. Hue 

4	 For Saturation, enter a value or drag the slider to the right to increase the saturation or to the left to decrease it. 

The color shifts away from or toward the center of the color wheel. Values can range from -100 (percentage of desat

uration, duller colors) to +100 (percentage of saturation increase). 

5 For Lightness, enter a value or drag the slider to the right to increase the lightness (add white to a color) or to the 

left to decrease it (add black to a color). Values can range from -100 (percentage of black) to +100 (percentage of 

white). 

Note: Click the Reset button to undo a setting in the Hue/Saturation dialog box. Press Alt (Windows) or Option 

(Mac OS) to change the Cancel button to Reset. 

To specify the range of colors adjusted in the Hue/Saturation command 

1 Do one of the following: 

•	 Choose Image > Adjustments > Hue/Saturation. 

• (Photoshop) Choose Layer > New Adjustment Layer > Hue/Saturation. Click OK in the New Layer dialog box. 

2 In the Hue/Saturation dialog box, choose a color from the Edit menu. 
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Four color wheel values (in degrees) appear in the dialog box. They correspond to the adjustment sliders that appear 

between the color bars. The two inner vertical sliders define the color range. The two outer triangle sliders show 

where the adjustments on a color range “fall off ” (fall-off is a feathering or tapering of the adjustments instead of a 

sharply defined on/off application of the adjustments). 

3	 Use either the eyedropper tools or the adjustment sliders to modify the range of colors. 

•	 Click or drag in the image with the Eyedropper tool to select a color range. To expand the range, click or drag 

in the image with the Add To Sample Eyedropper tool . To reduce the range of color, click or drag in the image 

with  the Subtract From Sample Eyedropper tool  .  While an eyedropper tool is selected,  you can  also  press Shift  

to add to the range, or Alt (Windows) or Option (Mac OS) to subtract from it. 

•	 Drag one of the white triangle sliders to adjust the amount of color fall-off (feathering of adjustment) without 

affecting the range. 

•	 Drag  the area between  the triangle and  the vertical bar  to  adjust  the range  without affecting  the amount of fall-off.  

•	 Drag the center area to move the entire adjustment slider (which includes the triangles and vertical bars) to select 

a different color area. 

•	 Drag one of the vertical white bars to adjust the range of the color component. Moving a vertical bar from the 

center of the adjustment slider and closer to a triangle increases the color range and decreases the fall-off. Moving 

a vertical bar closer to the center of the adjustment slider and away from a triangle decreases the color range and 

increases the fall-off. 

•	 Ctrl-drag (Windows) or Command-drag (Mac OS) the color bar so that a different color is in the center of the bar. 

BA C D E D C B 

Hue/Saturation adjustment slider 
A. Hue slider values B. Adjusts fall-off without affecting range C. Adjusts range without affecting fall-off D. Adjusts range of color and 
fall-off E. Moves entire slider 

If you modify the adjustment slider so that it falls into a different color range, the name in the Edit menu changes to 

reflect this change. For example, if you choose Yellow and alter its range so that it falls in the red part of the color bar, 

the name changes to Red 2. You can convert up to six of the individual color ranges to varieties of the same color 

range (for example, Red through Red 6). 

Note: By default, the range of color selected when you choose a color component is 30˚ wide, with 30˚ of fall-off on either 

side. Setting the fall-off too low can produce banding in the image. 

To colorize a grayscale image or create a monotone effect 
1 (Photoshop) If you are colorizing a grayscale image, choose Image > Mode > RGB Color to convert the image to 

RGB. 

2	 Do one of the following to open the Hue/Saturation dialog box: 

•	 Choose Image > Adjustments > Hue/Saturation. 

•	 (Photoshop) Choose Layer > New Adjustment Layer > Hue/Saturation. Click OK in the New Layer dialog box. 
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3 Select the Colorize option. If the foreground color is black or white, the image is converted to a red hue (0˚). If the 

foreground color is not black or white, the image is converted to the hue of the current foreground color. The 

lightness value of each pixel does not change. 

4 (Optional) Use the Hue slider to select a new color. Use the Saturation and Lightness sliders to adjust the 

saturation and lightness of the pixels. 

To use the Color Balance command 
The Color Balance command changes the overall mixture of colors in an image for generalized color correction. 

1 Make sure the composite channel is selected in the Channels palette. This command is available only when you’re 

viewing the composite channel. 

2 Do one of the following: 

• Choose Image > Adjustments > Color Balance. 

• Choose Layer > New Adjustment Layer > Color Balance. Click OK in the New Layer dialog box.


3 Select Shadows, Midtones, or Highlights to select the tonal range in which you want to focus the changes.


4 (Optional) Select Preserve Luminosity to prevent changing the luminosity values in the image while changing the


color. This option maintains the tonal balance in the image.


5 Drag a slider toward a color that you want to increase in the image; drag a slider away from a color that you want


to decrease in the image.


The values above the color bars show the color changes for the red, green, and blue channels. (For Lab images, the


values are for the A and B channels.) Values can range from -100 to +100. 

To change the color balance using the Photo Filter command 
The Photo Filter command mimics the technique of putting a colored filter in front of the camera lens to adjust the 

color balance and color temperature of the light transmitted through the lens and exposing the film. The Photo Filter 

command also lets you choose a color preset to apply a hue adjustment to an image. If you want to apply a custom 

color adjustment, the Photo Filter command lets you specify a color using the Adobe Color Picker. 

1 Do one of the following: 

• Choose Image > Adjustments > Photo Filter. 

• Choose Layer > New Adjustment Layer > Photo Filter. Click OK in the New Layer dialog box. 
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2 Choose the filter color, either a custom filter or a preset, from the Photo Filter dialog box. For a custom filter, select 

the Color option, click the color square, and use the Adobe Color Picker to specify a color for a custom color filter. 

For a preset filter, select the Filter option and choose one of the following presets from the Filter menu: 

Warming Filter (85 and LBA) and Cooling Filter (80 and LBB) Color conversion filters that tune the white balance 

in an image. If an image was photographed with a lower color temperature of light (yellowish), the Cooling Filter 

(80) makes the image colors bluer to compensate for the lower color temperature of the ambient light. Conversely, if 

the photo was taken with a higher color temperature of light (bluish), the Warming Filter (85) makes the image colors 

warmer to compensate for the higher color temperature of the ambient light. 

Warming Filter (81) and Cooling Filter (82) Use light-balancing filters for minor adjustments in the color quality 

of an image. The Warming Filter (81) makes the image warmer (more yellow), and the Cooling Filter (82) makes the 

image cooler (bluer). 

Individual Colors Apply a hue adjustment to the image depending on the color preset you choose. Your choice of 

color depends on how you’re using the Photo Filter command. If your photo has a color cast, you can choose a 

complementary color to neutralize the color cast. You can also apply colors for special color effects or enhancements. 

For example, the Underwater color simulates the greenish blue color cast in underwater photos. 

Make  sure  that  Preview is selected to view the  results of using  a color  filter. If you  don’t want the  image darkened by  

adding the color filter, be sure that the Preserve Luminosity option is selected. 

3 To adjust the amount of color applied to the image, use the Density slider or enter a percentage in the Density text 

box. A higher density results in a stronger color adjustment. 

4 Click OK. 

Improving shadow and highlight detail 

The Shadow/Highlight command 
The Shadow/Highlight command is suitable for correcting photos with silhouetted images due to strong backlighting 

or correcting subjects that have been slightly washed out because they were too close to the camera flash. The 

adjustment is also useful for brightening areas of shadow in an otherwise well-lit image. The Shadow/Highlight 

command does not simply lighten or darken an image; it lightens or darkens based on the surrounding pixels (local 

neighborhood) in the shadows or highlights. For this reason, there are separate controls of the shadows and the 

highlights. The defaults are set to fix images with backlighting problems. The Shadow/Highlight command also has 

a Midtone Contrast slider, Black Clip option, and White Clip option for adjusting the overall contrast of the image. 

Original image, and Shadow/Highlight Correction applied 
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To adjust the shadows and highlights in an image 
1 Choose Image > Adjustments > Shadow/Highlight. 

Make sure the Preview option is selected in the dialog box if you want the image to be updated as you make adjust

ments. 

2 Adjust the amount of lighting correction by moving the Amount slider or entering a value in the Shadows or 

Highlights percentage text box. Larger values provide either greater lightening of shadows or greater darkening of 

highlights. You can adjust both Shadows and Highlights in an image. 

3 For finer control, select Show More Options to make the additional adjustments. 

4 (Optional) Click the Save As Defaults button to save your current settings and make them the default settings for 

the Shadow/Highlights command. To restore the original default settings, hold down the Shift key while clicking the 

Save As Defaults button. 

Note: You can reuse Shadow/Highlight settings by clicking the Save button to save the current settings to a file and later 

using the Load button to reload them. For more information on saving and loading settings, see “To save and reapply 

settings in a dialog box” on page 282. 

5 Click OK. 

Shadow/Highlight command options 
Tonal Width Controls the range of tones in the shadows or highlights that are modified. Smaller values restrict the 

adjustments to the darker regions for shadow correction and the lighter regions for highlight correction. Larger 

values increase the range of tones that will be adjusted further into the midtones. For example, at 100% the shadow 

tonal width slider affects the shadows the most, the midtones are partially affected, but the brightest highlights are 

not affected. Tonal width varies from image to image. Too large a value may introduce halos around very dark or very 

light edges. The default settings attempt to reduce these artifacts. Halos may also occur when the Shadow or 

Highlight Amount values are too large. 

Tonal Width is set to 50% by default. If you find that you are trying to lighten a dark subject but the midtones or 

lighter regions are changing too much, try reducing Shadow Tone Width towards zero so that only the darkest regions 

are lightened. If, however, you need to brighten the midtones as well as the shadows, increase Shadows Tonal Width 

toward 100%. 

Radius Controls the size of the local neighborhood around each pixel. Neighboring pixels are used to determine 

whether a pixel is in the shadows or highlights. Moving the slider to the left specifies a smaller area, and moving it 

to the right specifies a larger area. The optimum local neighborhood size depends on the image. It’s best to exper

iment with the adjustment. If the radius is too large, the adjustment tends to brighten (or darken) the whole image 

rather than brightening the subject only. It’s best to set the radius to roughly the size of the subjects of interest in the 

image. Experiment with different Radius settings to obtain the best balance between subject contrast and differential 

brightening (or darkening) of the subject compared to the background. 

Color Correction Allows fine-tuning of the colors in regions of the image that have changed. This adjustment is 

available only in color images. For example, by increasing the setting of the Shadows Amount slider, you bring out 

colors  that  were  dark  in  the original image. You  may want these  colors  to  be  more  vivid or less vivid. Adjust the  Color  

Correction slider to achieve the best results. In general, increasing the values tends to produce colors that are more 

saturated, and decreasing the values produces colors that are less saturated. 
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Note: Because the Color Correction slider affects only changed portions of the image, the amount of color variation 

depends on how much shadow or highlight is applied. The greater the correction of shadows and highlights, the greater 

the range of color correction available. The Color Correction slider exerts subtle control over the darkened or lightened 

colors in the image. If you want to change the color hues or saturation of the whole image, use the Hue/Saturation 

command after applying the Shadow/Highlight command. 

Brightness Adjusts the brightness in a grayscale image. This adjustment is available only for grayscale images. 

Moving the Brightness slider to the left darkens a grayscale image, and moving the slider to the right lightens a 

grayscale image. 

Midtone Contrast Adjusts the contrast in the midtones. Move the slider to the left to reduce the contrast and to the 

right to increase the contrast. You can also enter a value in the Midtone Contrast text box. A negative value reduces 

contrast, and a positive value increases contrast. Increasing midtone contrast produces greater contrast in the 

midtones while tending to darken the shadows and lighten the highlights. 

Black Clip And White Clip Specifies how greatly the shadows and highlights are clipped to the new extreme shadow 

(level 0) and highlight (level 255) colors in the image. Larger values produce an image with greater contrast. Be 

careful not to make the clipping values too large, because doing so reduces detail in the shadows or highlights (the 

intensity values are clipped and rendered as pure black or pure white). 

Matching, replacing, and mixing colors 

The Match Color command 
The Match Color command matches colors between multiple images, between multiple layers, or between multiple 

color selections. It also lets you adjust the colors in an image by changing the luminance, changing the color range, 

and neutralizing a color cast. The Match Color command works only in RGB mode. 

When you use the Match Color command, the pointer becomes the Eyedropper tool. Use the Eyedropper tool while 

adjusting the image to view the color pixel values in the Info palette. This palette gives you feedback about changes 

in color values as you use the Match Color command. See “To view color values in an image” on page 280. 

The Match Color command matches the colors in one image (the source image) with those in another image (the 

target image). This is useful when you’re trying to make the colors in different photos consistent, or when certain 

colors (such as skin tones) in one image must match the colors in another image. 

In addition to matching the color between two images, the Match Color command can match the color between 

different layers in the same image. 

To match the color in different images 
1 (Optional) Make a selection in the images you want to match. This is useful when you are trying to match color 

regions (for example, facial skin tones) in one image with color regions in another. 

If you don’t make a selection, then the Match Color command matches the overall image statistics between images. 

2 Make the image that you want to target active, and then choose Image > Adjustments > Match Color. 

If you’re applying the Match Color command to a specific layer in the target image, make sure that layer is active 

when you choose the Match Color command. 
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3 From the Source menu in the Image Statistics area of the Match Color dialog box, choose the source image whose 

colors you’ll be matching in the target image. Choose None when you don’t want to reference a different image to 

calculate the color adjustment. With None chosen, the target image and the source image are the same. 

If  necessary,  use the  Layer menu to choose the  layer from the  source  image whose  colors  you want to match. You  can  

also choose Merged from the Layer menu to match the colors from all the layers in the source image. 

4	 If you made a selection in the image, do one or more of the following: 

•	 In the Destination Image area, select Ignore Selection When Applying Adjustment if you’re applying the 

adjustment to the entire target image. This option ignores the selection in the target image and applies the 

adjustment to the entire target image. 

•	 In  the Image  Statistics  area, select Use  Selection In Source To Calculate  Colors  if  you made a selection in the  source  

image and want to use the colors in the selection to compute the adjustment. Deselect this option to ignore the 

selection in the source image, and use the colors from the entire source image to compute the adjustment. 

•	 In the Image Statistics area, select Use Selection In Target To Calculate Adjustment if you made a selection in the 

target  image and  want  to  use the  colors  in  the selection  to  calculate the  adjustment. Deselect this option to ignore  

the selection in the target image and compute the adjustment by using the colors of the entire target image. 

5 To automatically remove a color cast in the target image, select the Neutralize option. Make sure the Preview 

option is selected so that your image is updated as you make adjustments. 

6 To increase or decrease the brightness in the target image, move the Luminance slider. Alternatively, enter a value 

in the Luminance text box. The maximum value is 200, the minimum is 1, and the default is 100. 

7 To adjust the color saturation in the target image, adjust the Color Intensity slider. Alternatively, enter a value in 

the Color Intensity text box. The maximum value is 200, the minimum is 1 (which produces a grayscale image), and 

the default is 100. 

8 To control the amount of adjustment applied to the image, move the Fade slider. Moving the slider to the right 

reduces the adjustment. 

9	 Click OK. 

To match the color of two layers in the same image 
1 (Optional) Make a selection in the layer you want to match. This is useful when matching a color region (for 

example, facial skin tones) in one layer with a region in another. 

If you don’t make a selection, then the Match Color matches the colors of the entire source layer. 

2 Make sure the layer you want to target (apply the color adjustment to) is active, and then choose Image > 

Adjustments > Match Color. 

3 From  the Source menu in the  Image Statistics area of the  Match Color  dialog  box,  make  sure  that  the image  in  the  

Source menu is the same as the target image. 

4 Use the Layer menu to choose the layer whose colors you want to match. You can also choose Merged from the 

Layer menu to match the colors from all the layers. 
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5	 If you made a selection in the image, do one or more of the following: 

•	 In the Destination Image area, select Ignore Selection When Applying Adjustment if you’re applying the 

adjustment  to  the entire target layer. This option ignores  the selection  in  the target layer  and applies  the adjustment  

to the entire target layer. 

•	 In  the Image  Statistics  area, select Use  Selection In Source To Calculate  Colors  if  you made a selection in the  source  

image and  want  to  use the  color in the  selection to compute  the adjustment.  Deselect  the this option to ignore the  

selection in the source layer and use the colors in the entire source layer to compute the adjustment. 

•	 In the Image Statistics area, select Use Selection In Target To Calculate Adjustment if you want to use only the 

colors in the selected area of the target layer to compute the adjustment. Deselect this option to ignore the selection 

and use the colors of the entire target layer to compute the adjustment. 

6 To automatically remove a color cast in the target layer, Select the Neutralize option. Make sure the Preview option 

is selected so that your image is updated as you make adjustments. 

7 To increase or decrease the brightness in the target layer, move the Luminance slider. Alternatively, enter a value 

in the Luminance text box. The maximum value is 200, the minimum is 1, and the default is 100. 

8 To adjust the range of color pixel values in the target layer, adjust the Color Intensity slider. Alternatively, enter a 

value in the Color Intensity text box. The maximum value is 200, the minimum is 1 (which produces a grayscale 

image), and the default is 100. 

9 To control the amount of adjustment applied to the image, adjust the Fade slider. Moving the slider to the right 

reduces the amount of adjustment. 

10 Click OK. 

To remove a color cast 
The Match Color command can adjust the brightness, color saturation, and color balance in an image. The advanced 

algorithms  in  the Match  Color command  give  you better control  over  luminance and  color components of the  image.  

Because you are adjusting the color in a single image rather than matching the colors between two images, the image 

you’re correcting is both the source and the target image. 

1	 Choose Image > Adjustments > Match Color. 

2 In the Image Statistics area, make sure None is chosen in the Source menu. The option specifies that the source 

and the target are the same image. 

3 To automatically remove a color cast, select the Neutralize option. Make sure the Preview option is selected so that 

your image is updated as you make adjustments. 

4 To increase or decrease the brightness in the image, adjust the Luminance slider. Moving the Luminance slider to 

the left darkens the image, and moving the slider to the right brightens the image. The luminance control tries not 

to clip pixels (change them to pure black/no detail or pure white/no detail) in either the shadows or highlights. 

However, it may clip pixels because an image can have only either 8-bit or 16-bit values. 

5 To expand or reduce the color pixel values in the image, adjust the Color Intensity slider. Moving the Color 

Intensity slider to the left reduces the color range, and the image becomes monochromatic. Moving the Color 

Intensity to the right increases the color range and intensifies the colors. 

6 To control the amount of adjustment applied to the image, adjust the Fade slider. Moving the slider to the right 

reduces the amount of adjustment. 
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Note: You can use the Match Color controls separately to apply a single correction to the image. For example, you can 

adjust only the Luminance slider to brighten/darken an image without affecting the color. Or you can use the controls in 

different combinations, depending on the color correction you’re making. 

7	 Click OK. 

To save and apply settings in the Match Color command 
•	 In the Image Statistics area of the Match Color dialog box, click the Save Statistics button. Name and save the 

settings. 

•	 In the Image Statistics area of the Match Color dialog box, click the Load Statistics button. Locate and load the 

saved settings file. 

To replace the color of objects in an image 
The Replace Color command lets you create a mask to select specific colors in an image and then replace those colors.


You can set the hue, saturation, and lightness of the selected areas. Or you can use the Color Picker to select the


replacement color. The mask created by the Replace Color command is temporary.


1 Choose Image > Adjustments > Replace Color.


2 Select a display option:


Selection Displays the mask in the preview box. Masked areas are black, and unmasked areas are white. Partially


masked areas (areas covered with a semitransparent mask) appear as varying levels of gray according to their opacity.


Image Displays the image in the preview box. This option is useful when you are working with a magnified image


or have limited screen space.


3	 To select the areas exposed by the mask, do one of the following:


•	 Use the Eyedropper tool  to click in the image or in the preview box to select the areas exposed by the mask. 

Shift-click or use the Add To Sample Eyedropper tool  to add areas; Alt-click (Windows), Option-click


(Mac OS), or use the Subtract From Sample Eyedropper tool
  to remove areas. 

•	 Double-click the Selection swatch. Use the Color Picker to target a color to be replaced. As you select a color in 

the Color Picker, the mask in the preview box is updated. 

4 Adjust the tolerance of the mask by dragging the Fuzziness slider or entering a value. This slider controls the 

degree to which related colors are included in the selection. 

5	 To change the color of the selected areas, do one of the following: 

•	 Drag the Hue, Saturation, and Lightness sliders (or enter values in the text boxes). 

• Double-click the Result swatch and use the Color Picker to select the replacement color. 

You can also save the settings you make in the Replace Color dialog box for reuse in other images. 

See also 

“To save and reapply settings in a dialog box” on page 282 

Mixing color channels 
The Channel Mixer command lets you create high-quality grayscale images by choosing the percentage contribution 

from each color channel. You can also create high-quality sepia-tone or other tinted images. Using the Channel 

Mixer, you can also make creative color adjustments not easily done with other color-adjustment tools. 
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The Channel Mixer modifies a targeted (output) color channel using a mix of the existing (source) color channels in


the image. Color channels are grayscale images representing the tonal values of the color components in an image


(RGB or CMYK). When you use the Channel Mixer, you are adding or subtracting grayscale data from a source


channel to the targeted channel. You are not adding or subtracting colors to a specific color component as you do


with the Selective Color command.


To create monochrome images from RGB or CMYK images

1 In the Channels palette, select the composite color channel.


2 Do one of the following to open the Channel Mixer dialog box:


• Choose Image > Adjustments > Channel Mixer. 

• Choose Layer > New Adjustment Layer > Channel Mixer. Click OK in the New Layer dialog box. 

3 Select the Monochrome option to set Gray as the output channel. This creates a color image that contains only 

gray values. 

4 Use the Source Channels sliders to control the amount of detail and contrast in the images you plan to convert to 

grayscale. 

Before adjusting the percentages of the source channels, view how each source channel affects the monochrome image. 

For example, in RGB, view the image with the Red channel set to +100% and the Green and Blue source channels 

set to 0%. Then, view the image with the Green source channel set to +100% and the other two channels set to 0%. 

Finally, view the image with Blue source channel set to +100% and the other channels set to 0%. When adjusting the 

percentages of the source channels, you often get the best results when the combined values of the source channels add up 

to 100%. 

5 (Optional) If you select and then deselect the Monochrome option, you can modify the blend of each channel 

separately, creating a hand-tinted appearance. 

Hand-tinted effect created by selecting (left) and deselecting (right) the Monochrome option 

6 (Optional) Drag the slider or enter a value for the Constant option. This option adjusts the grayscale value of the


output channel. Negative values add more black, and positive values add more white. A -200% value makes the


output channel completely black, and a +200% value makes the output channel completely white.


To mix color channels

1 In the Channels palette, select the composite color channel.


2 Do one of the following to open the Channel Mixer dialog box:


• Choose Image > Adjustments > Channel Mixer. 

• Choose Layer > New Adjustment Layer > Channel Mixer. Click OK in the New Layer dialog box. 

3 For Output Channel, choose the channel in which to blend one or more existing () channels. 
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Choosing an output channel sets the source slider for that channel to 100% and all other channels to 0%. For example, 

choosing Red as the output channel sets the Source Channels sliders to 100% for Red, and to 0% for Green and Blue 

(in an RGB image). 

4 Drag any source channel’s slider to the left to decrease the channel’s contribution to the output channel or to the 

right to increase it, or enter a value between -200% and +200% in the text box. Using a negative value inverts the 

source channel before adding it to the output channel. 

5 Drag the slider or enter a value for the Constant option. This option adjusts the grayscale value of the output 

channel. Negative values add more black, and positive values add more white. A -200% value makes the output 

channel completely black, and a +200% value makes the output channel completely white. 

You can also save the settings you make in the Channel Mixer dialog box for reuse on other images. 

See also 

“To save and reapply settings in a dialog box” on page 282 

To use the Selective Color command 
Selective color correction is a technique used by high-end scanners and separation programs to change the amount 

of process colors in each of the primary color components in an image. You can modify the amount of a process color 

in any primary color selectively—without affecting the other primary colors. For example, you can use selective color 

correction  to  dramatically decrease the  cyan  in  the green  component of an image  while leaving  the cyan in the  blue  

component unaltered. 

Even though Selective Color uses CMYK colors to correct an image, you can use it on RGB images. 

1 Make sure that the composite channel is selected in the Channels palette. The Selective Color command is 

available only when you’re viewing the composite channel. 

2 Do one of the following: 

• Choose Image > Adjustments > Selective Color. 

• Choose Layer > New Adjustment Layer > Selective Color. Click OK in the New Layer dialog box. 

3 Choose the color you want to adjust from the Colors menu at the top of the dialog box. Color sets consist of the 

primary additive and subtractive colors plus whites, neutrals, and blacks. 

4 For Method, select an option: 

Relative Changes the existing amount of cyan, magenta, yellow, or black by its percentage of the total. For example, 

if you start with a pixel that is 50% magenta and add 10%, 5% is added to the magenta (10% of 50% = 5%) for a total 

of 55% magenta. (This option cannot adjust pure specular white, which contains no color components.) 

Absolute Adjusts the color in absolute values. For example, if you start with a pixel that is 50% magenta and add 

10%, the magenta ink is set to a total of 60%. 

Note: The adjustment is based on how close a color is to one of the options in the Colors menu. For example, 50% 

magenta is midway between white and pure magenta and receives a proportionate mix of corrections defined for the two 

colors. 

5 Drag the sliders to increase or decrease the components in the selected color.


You can also save the settings you make in the Selective Color dialog box for reuse on other images.
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See also 

“To save and reapply settings in a dialog box” on page 282 

Making quick overall adjustments to images 

To use the Brightness/Contrast command 
The Brightness/Contrast command lets you make simple adjustments to the tonal range of an image. Unlike Curves 

and Levels, which apply proportionate (nonlinear) adjustments to the pixels in an image, Brightness Contrast makes 

the same amount of adjustment to every pixel (a linear adjustment). The Brightness/Contrast command is not 

recommended for high-end output because it can result in a loss of image detail. 

1	 Do one of the following: 

•	 Choose Image > Adjustments > Brightness/Contrast. 

• Choose Layer > New Adjustment Layer > Brightness/Contrast. Click OK in the New Layer dialog box.


2 Drag the sliders to adjust the brightness and contrast.


Dragging to the left decreases the level, and dragging to the right increases it. The number at the right of each slider


reflects the brightness or contrast value. Values can range from -100 to +100.


The Auto Levels command 
The Auto Levels command automatically adjusts the black point and white point in an image. This clips a portion of 

the shadows and highlights in each channel and maps the lightest and darkest pixels in each color channel to pure 

white (level 255) and pure black (level 0). The intermediate pixel values are redistributed proportionately. As a result, 

using Auto Levels increases the contrast in an image because the pixel values are expanded. Because Auto Levels 

adjusts each color channel individually, it may remove color or introduce color casts. 

Auto Levels gives good results in certain images with an average distribution of pixel values that need a simple 

increase in contrast. 

Note: By default, Auto Levels clips the white and black pixels by 0.1%—that is, it ignores the first 0.1% of either extreme 

when identifying the lightest and darkest pixels in the image. The default settings for Auto Levels can be changed in the 

Auto Color Correction Options dialog box. 

See also 

“To set Auto Color Correction options” on page 309 

To use the Auto Levels command 
1 Do one of the following: 

•	 Choose Image > Adjustments > Auto Levels. The application of Auto Levels is automatic with this option. You 

cannot adjust any of the options in the following steps. 

•	 (Photoshop) Choose Layer > New Adjustment Layer and choose either Levels or Curves. Click OK in the New 

Layer dialog box. 

2 In the Levels or Curves dialog box, click the Option button.


3 Select Enhance Per Channel Contrast under Algorithms in the Auto Color Correction Options dialog box.
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4 Adjust the amount of shadow and highlight values that are clipped, and adjust the target color for the midtones. 

5 Click OK to close the open dialog boxes to apply Auto Levels. 

See also 

“To set Auto Color Correction options” on page 309 

The Auto Contrast command 
The Auto Contrast command adjusts image contrast automatically. Because Auto Contrast does not adjust channels 

individually, it does not introduce or remove color casts. It clips the shadow and highlight values in an image and 

then maps the remaining lightest and darkest pixels in the image to pure white (level 255) and pure black (level 0). 

This makes the highlights appear lighter and shadows appear darker. 

By default, when identifying the lightest and darkest pixels in an image, Auto Contrast clips the white and black pixels 

by 0.5%—that is, it ignores the first 0.5% of either extreme. You can change this default using the Auto Color 

Correction Options found in the Levels and the Curves dialog boxes. 

Auto Contrast can improve the appearance of many photographic or continuous-tone images. It does not improve 

flat-color images. 

See also 

“To set Auto Color Correction options” on page 309 

To use the Auto Contrast command 
1 Do one of the following: 

•	 Choose Image > Adjustments > Auto Contrast. The application of Auto Contrast is automatic with this option. 

You cannot adjust any of the options in the following steps. 

•	 (Photoshop) Choose Layer > New Adjustment Layer and choose either Levels or Curves. Click OK in the New 

Layer dialog box. 

2 In the Levels or Curves dialog box, click the Option button.


3 Select the Enhance Monochromatic Contrast option under Algorithms in the Auto Color Correction Options


dialog box.


4 Adjust the amount of shadows and highlights that are clipped, and adjust the target color for the midtones. 

5 Click OK in open dialog boxes to apply Auto Contrast. 

See also 

“To set Auto Color Correction options” on page 309 

To change default Auto Contrast and Auto Level clipping values in ImageReady 
❖ Click Options in the Levels dialog box. Enter the percentage of extreme highlight and shadow pixels to clip, and 

click OK. A value between 0.5% and 1% is recommended. 
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To remove a color cast with Auto Color 
The Auto Color command adjusts the contrast and color of an image by searching the image to identify shadows, 

midtones, and highlights. By default, Auto Color neutralizes the midtones using a target color of RGB 128 gray and 

clips the shadows and highlight pixels by 0.5%. You can change these defaults in the Auto Color Correction Options 

dialog box. 

1	 Do one of the following: 

•	 Choose Image > Adjustments > Auto Color. The application of Auto Color is automatic with this option. You 

cannot adjust any of the options in the following steps. 

• Choose Layer > New Adjustment Layer and choose either Levels or Curves. Click OK in the New Layer dialog box.


2 In the Levels or Curves dialog box, click the Option button.


3 Select the Find Dark & Light option under Algorithms in the Auto Color Correction Options dialog box.


4 Select the Snap Neutral Midtones option.


5 Adjust the amount of shadows and highlights that are clipped, and adjust the target color for the midtones.


6 Click OK in open dialog boxes to apply Auto Color.


See also 

“To use Levels to correct a color cast” on page 286 

“To set Auto Color Correction options” on page 309 

To set Auto Color Correction options 
The Auto Color Correction options control tonal and color corrections applied by Auto Color, Auto Levels, Auto 

Contrast, and the Auto option in both Levels and Curves. The Auto Color Correction options let you specify shadow 

and highlight clipping percentages, and assign color values to shadows, midtones, and highlights. 

You can apply the settings during a single use of the Levels dialog box or Curves dialog box, or you can save the 

settings as default values when applying Auto Levels, Auto Contrast, Auto Color, and the Auto option in Levels and 

Curves. 
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C 

D 

Auto Color Correction Options dialog box 
A. Auto Contrast option B. Auto Levels option C. Auto Color option D. Set target colors, black point, and white point 

1	 Click the Options button in the Levels dialog box or Curves dialog box. 

2	 Specify the algorithm you want Photoshop to use to adjust the overall tonal range of an image: 

Enhance Monochromatic Contrast Clips all channels identically. This preserves the overall color relationship while 

making highlights appear lighter and shadows appear darker. The Auto Contrast command uses this algorithm. 

Enhance Per Channel Contrast Maximizes the tonal range in each channel to produce a more dramatic correction. 

Because each channel is adjusted individually, Enhance Per Channel Contrast may remove or introduce color casts. 

The Auto Levels command uses this algorithm. 

Find Dark & Light Colors Finds the average lightest and darkest pixels in an image and uses them to maximize 

contrast while minimizing clipping. The Auto Color command uses this algorithm. 

3 Select Snap Neutral Midtones if you want Photoshop to find an average nearly neutral color in an image and then 

adjust the gamma (midtone) values to make the color neutral. The Auto Color command uses this algorithm. 

4 To specify how much to clip black and white pixels, enter percentages in the Clip text boxes. A value between 0.0% 

and 1% is recommended. 

By default, Photoshop clips the black and white pixels by 0.1%—that is, it ignores the first 0.1% of either extreme 

when identifying the lightest and darkest pixels in the image. Because of the better output quality of today’s scanners 

and digital cameras, these default clipping percentages may be too high. 

5	 To assign (target) color values to the darkest, neutral, and lightest areas of an image, click a color swatch. 

6	 Do one of the following: 

•	 To use the settings in the current Levels or Curves dialog box, click OK. If you subsequently click the Auto button, 

Photoshop reapplies the same settings to the image. 

•	 To save the settings as the default, select Save as Defaults, and then click OK. The next time you open the Levels 

or Curves dialog box, you can apply the same setting by clicking the Auto button. The default clipping percentages 

are also used by the Auto Level, Auto Contrast, and Auto Color commands. 

Note: When you save the Auto Color Correction options as defaults for Auto Color, Auto Levels, and Auto Contrast, it 

does not matter what algorithm you select in step 2. The three auto-correction commands use only those values that you 

set for the target colors and clipping. The only exception is that the Auto Color command also uses the Snap Neutral 

Midtones option. 
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To use the Variations command 
The Variations command lets you adjust the color balance, contrast, and saturation of an image by showing you 

thumbnails of alternatives. 

This command is most useful for average-key images that don’t require precise color adjustments. It does not work 

on indexed-color images or 16-bit-per-channel images (Photoshop). 

1	 Choose Image > Adjustments > Variations. 

The two thumbnails at the top of the dialog box show the original selection (Original) and the selection with its 

currently selected adjustments (Current Pick). When you first open the dialog box, these two images are the same. 

As you make adjustments, the Current Pick image changes to reflect your choices. 

2 Select the Show Clipping option if you want to display a preview of areas in the image that will be clipped— 

converted to pure white or pure black—by the adjustment. Clipping can result in undesirable color shifts, as distinct 

colors in the original image are mapped to the same color. Clipping does not occur when you adjust midtones. 

3	 Select what to adjust in the image: 

Shadows, Midtones, or Highlights Adjusts the dark, middle, or light areas. 

Saturation Changes the degree of hue in the image. If you exceed the maximum saturation for a color, it may be 

clipped. 

4 Drag the Fine/Coarse slider to determine the amount of each adjustment. Moving the slider one tick mark doubles 

the adjustment amount. 

5	 Adjust the color and brightness: 

•	 To add a color to the image, click the appropriate color thumbnail. 

•	 To subtract a color, click the thumbnail for its opposite color. For example, to subtract cyan, click the More Red 

thumbnail. See “Using the color wheel” on page 248. 

•	 To adjust brightness, click a thumbnail on the right side of the dialog box. 

The effects of clicking the thumbnails are cumulative. For example, clicking the More Red thumbnail twice applies 

the adjustment twice. Each time you click a thumbnail, the other thumbnails change. The three Current Pick thumb

nails always reflect the current choices. 

You can also save the settings you make in the Variations dialog box for reuse on other images. For more information 

on saving and loading settings, see “To save and reapply settings in a dialog box” on page 282. 

To use the Equalize command 
The Equalize command redistributes the brightness values of the pixels in an image so that they more evenly 

represent the entire range of brightness levels. Equalize remaps pixel values in the composite image so that the 

brightest value represents white, the darkest value represents black, and intermediate values are evenly distributed 

throughout the grayscale. 
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You can  use the  Equalize command  when  a scanned  image appears  darker  than  the original and  you want to balance 


the values to produce a lighter image. Using Equalize together with the Histogram palette lets you see before-and-


after brightness comparisons.


1 (Optional) Select an area of the image to equalize.


2 Choose Image > Adjustments > Equalize.


3 If you selected an area of the image, select what to equalize in the dialog box, and click OK:


Equalize Selected Area Only Evenly distributes only the selection’s pixels.


Equalize Entire Image Based On Selected Area Evenly distributes all image pixels based on those in the selection. 

Applying special color effects to images 

To desaturate colors 
The Desaturate command converts a color image to grayscale values, but leaves the image in the same color mode. 

For example, it assigns equal red, green, and blue values to each pixel in an RGB image. The lightness value of each 

pixel does not change. 

This command has the same effect as setting Saturation to -100 in the Hue/Saturation dialog box. 

Note: If you are working with a multilayer image, Desaturate converts the selected layer only. 

❖ Choose Image > Adjustments > Desaturate. 

To invert colors 
The Invert command inverts the colors in an image. You can use this command as part of the process of making an 

edge mask to apply sharpening and other adjustments to selected areas of an image. 

Note: Because color  print film contains an orange mask in its  base, the  Invert  command cannot make accurate positive  

images from scanned color negatives. Be sure to use the proper settings for color negatives when scanning film. 

When you invert an image, the brightness value of each pixel in the channels is converted to the inverse value on the 

256-step color-values scale. For example, a pixel in a positive image with a value of 255 is changed to 0, and a pixel 

with a value of 5 is changed to 250. 

Do one of the following: 

• Choose Image > Adjustments > Invert. 

• (Photoshop) Choose Layer > New Adjustment Layer > Invert. Click OK in the New Layer dialog box. 
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To convert images to black and white 
The Threshold command converts grayscale or color images to high-contrast, black-and-white images. You can 

specify a certain level as a threshold. All pixels lighter than the threshold are converted to white; all pixels darker are 

converted to black. 

1	 Do one of the following: 

•	 Choose Image > Adjustments > Threshold. 

•	 Chose Layer > New Adjustment Layer > Threshold. Click OK in the New Layer dialog box. The Threshold dialog 

box displays a histogram of the luminance levels of the pixels in the current selection. 

2 Drag the slider below the histogram until the threshold level you want appears at the top of the dialog box, and 

click OK. As you drag, the image changes to reflect the new threshold setting. 

To posterize an image 
The Posterize command lets you specify the number of tonal levels (or brightness values) for each channel in an 

image and then maps pixels to the closest matching level. For example, choosing two tonal levels in an RGB image 

gives six colors: two for red, two for green, and two for blue. 

This command is useful for creating special effects, such as large, flat areas in a photograph. Its effects are most 

evident when you reduce the number of gray levels in a grayscale image, but it also produces interesting effects in 

color images. 

If you want a specific number of colors in your image, convert the image to grayscale and specify the number of levels 

you want. Then convert the image back to the previous color mode, and replace the various gray tones with the colors 

you want. 

1 Choose Image > Adjustments > Posterize.


2 Enter the number of tonal levels you want, and click OK.


To apply a gradient map to an image 
The Gradient Map command maps the equivalent grayscale range of an image to the colors of a specified gradient 

fill. If you specify a two-color gradient fill, for example, shadows in the image are mapped to one of the endpoint 

colors of the gradient fill, highlights are mapped to the other endpoint color, and midtones are mapped to the grada

tions in between. 

1	 Do one of the following: 

•	 Choose Image > Adjustments > Gradient Map. 

• Choose Layer > New Adjustment Layer > Gradient Map. Click OK in the New Layer dialog box. 

2 Specify the gradient fill you want to use: 

•	 To choose from a list of gradient fills, click the triangle to the right of the gradient fill displayed in the Gradient 

Map dialog box. Click to select the desired gradient fill, and then click in a blank area of the dialog box to dismiss 

the list. For information on customizing the gradient fill list, see “About the Preset Manager” on page 67. 

•	 To edit the gradient fill currently displayed in the Gradient Map dialog box, click the gradient fill. Then modify 

the existing gradient fill or create a new gradient fill using the Gradient Editor. (See “To create a smooth gradient” 

on page 494.) 
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By default, the shadows, midtones, and highlights of the image are mapped respectively to the starting (left) color,


midpoint, and ending (right) color of the gradient fill.


3 Select either, none, or both of the Gradient options:


Dither Adds random noise to smooth the appearance of the gradient fill and reduces banding effects.


Reverse Switches the direction of the gradient fill, reversing the gradient map.
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Chapter 12: Selecting


Making selections 

Selecting 
Making a selection is isolating one or more parts of your image. By selecting specific areas, you can edit and apply 

effects and filters to portions of your image while leaving the unselected areas untouched. 

There are separate sets of tools to make selections of bitmap and vector data. For example, to select bitmap pixels, 

you can use the marquee tools or the lasso tools. You can use commands in the Select menu to select all pixels, to 

deselect, or to reselect. 

To select vector data, you can use the pen or shape tools, which produce precise outlines called paths. For 32-bits-

per-channel images, only the pen tools are available to select vector data. You can convert paths to selections or 

convert selections to paths. 

Selections can be copied, moved, and pasted, or saved and stored in an alpha channel. Alpha channels store selections 

as grayscale images. You can add alpha channels to create and store masks. A mask is a selection that protects portions  

of an image from any editing or manipulations you apply. 

Note: To select a specified color or color subset within an existing selection or an entire image, you can use the Color 

Range command. 

See also 

“About masks and alpha channels” on page 338 

“To create an alpha channel and add a mask” on page 342 

“Converting paths to selection borders” on page 467 

“Selection tools gallery” on page 42 

To select all pixels on a layer within the canvas boundaries

1 Select the layer in the Layers palette.


2 Choose Select > All.


To deselect selections 
❖ Do one of the following: 

•	 Choose Select > Deselect. 

•	 If you are using the Rectangle Marquee tool, the Rounded Rectangle Marquee tool (ImageReady), the Elliptical 

Marquee tool, or the Lasso tool, click anywhere in the image outside the selected area. 

To reselect the most recent selection 
❖ Choose Select > Reselect. 
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To use the marquee tools 
The marquee tools let you select rectangles, ellipses, rounded rectangles (ImageReady), and 1-pixel rows and


columns. By default, a selection border is dragged from its corner.


1 Select a marquee tool:


Rectangular Marquee
 Makes a rectangular selection. 

Rounded Rectangle Marquee (ImageReady) Selects a rounded rectangle, such as a web page button. 

Elliptical Marquee Makes an elliptical selection. 

Single Row  or Single Column  Marquee Defines the border as a 1-pixel-wide row or column. 

2 Specify one of the selection options in the options bar. 

A B C D 

Selection options 
A. New B. Add To C. Subtract From D. Intersect With 

3 Specify a feathering setting in the options bar. Turn anti-aliasing on or off for the Rounded Rectangle Marquee 

tool or the Elliptical Marquee tool. 

4 For the Rectangle Marquee tool, the Rounded Rectangle Marquee tool, or the Elliptical Marquee tool, choose a 

style in the options bar: 

Normal Determines marquee proportions by dragging. 

Fixed Aspect Ratio Sets a height-to-width ratio. Enter values (decimal values are valid in Photoshop) for the aspect 

ratio. For example, to draw a marquee twice as wide as it is high, enter 2 for the width and 1 for the height. 

Fixed Size Specifies set values for the marquee’s height and width. Enter pixel values in whole numbers. Keep in 

mind that the number of pixels needed to create a 1-inch selection depends on the resolution of the image. 
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5 For aligning your selection to guides, a grid, slices, or document bounds, do one of the following to snap your

selection:

• (Photoshop) Choose View > Snap, or choose View > Snap To and choose a command from the submenu. The

marquee selection can snap to a document boundary and more than one Photoshop Extra. This is controlled in

the Snap To submenu.

• (ImageReady) Choose View > Snap To > Guides.

6 Do one of the following to make a selection:

• With the Rectangle Marquee tool, the Rounded Rectangle Marquee tool, or the Elliptical Marquee tool, drag over

the area you want to select. Hold down Shift as you drag to constrain the marquee to a square or circle (release the

mouse button before Shift to keep the shape constrained). To drag a marquee from its center, hold down Alt

(Windows) or Option (Mac OS) after you begin dragging.

Dragging a marquee from the corner of an image (left), and from the center of an image (right)

• With the Single Row or Single Column Marquee tool, click near the area you want to select, and then drag the

marquee to the exact location. If no marquee is visible, increase the magnification of your image view.

To reposition a rectangle, rounded rectangle, or elliptical marquee, first drag to create the border, keeping the mouse

button depressed. Then hold down the spacebar and continue to drag. Release the spacebar, but keep the mouse

button depressed, if you need to continue adjusting the selection border.

To use the Lasso tool
The Lasso tool is useful for drawing freeform segments of a selection border.

1 Select the Lasso tool , and select options. See “To set options for the Lasso, Polygonal Lasso, and Magnetic

Lasso tools” on page 319.

2 Drag to draw a freehand selection border.

3 To draw a straight-edged selection border, hold down Alt (Windows) or Option (Mac OS), and click where

segments should begin and end. You can switch between drawing freehand and straight-edged segments.

4 To erase recently drawn segments, hold down the Delete key until you’ve erased the fastening points for the

desired segment.

5 To close the selection border, release the mouse without holding down Alt (Windows) or Option (Mac OS).

To use the Polygonal Lasso tool
The Polygonal Lasso tool is useful for drawing straight-edged segments of a selection border.

1 Select the Polygonal Lasso tool , and select options. See “To set options for the Lasso, Polygonal Lasso, and

Magnetic Lasso tools” on page 319.

2 Click in the image to set the starting point.
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3	 Do one or more of the following: 

•	 To draw a straight segment, position the pointer where you want the first straight segment to end, and click. 

Continue clicking to set endpoints for subsequent segments. 

•	 To draw straight lines in 45˚ segments, hold down Shift as you move to click the next segment. 

•	 To draw a freehand segment, hold down Alt (Windows) or Option (Mac OS), and drag. When you finish, release 

Alt or Option and the mouse button. 

• To erase recently drawn straight segments, press the Delete key. 

4 Close the selection border: 

•	 Position the Polygonal Lasso tool pointer over the starting point (a closed circle appears next to the pointer), and 

click. 

•	 If the pointer is not over the starting point, double-click the Polygonal Lasso tool pointer, or Ctrl-click (Windows) 

or Command-click (Mac OS). 

To use the Magnetic Lasso tool 
When you use the Magnetic Lasso tool , the border snaps to the edges of defined areas in the image. The Magnetic 

Lasso tool is not available for 32-bits-per-channel images. 

The Magnetic Lasso tool is especially useful for quickly selecting objects with complex edges set against high-contrast 

backgrounds. 

1	 Select the Magnetic Lasso tool and, if necessary, set options in the options bar. 

2	 Click in the image to set the first fastening point. Fastening points anchor the selection border in place. 

3 To draw a freehand segment, either release or keep the mouse button depressed, and then move the pointer along 

the edge you want to trace. 

The most recent segment  of  the selection  border  remains active.  As  you move the  pointer,  the active segment  snaps  

to the strongest edge in the image, based on the detection width set in the options bar. Periodically, the Magnetic 

Lasso tool adds fastening points to the selection border to anchor previous segments. 

4 If the border doesn’t snap to the desired edge, click once to add a fastening point manually. Continue to trace the 

edge, and add fastening points as needed. 

Fastening points anchor selection border to edges 
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5 To switch temporarily to the other lasso tools, do one of the following:

• To activate the Lasso tool, hold down Alt (Windows) or Option (Mac OS), and drag with the mouse button

depressed.

• To activate the Polygonal Lasso tool, hold down Alt (Windows) or Option (Mac OS), and click.

6 To erase recently drawn segments and fastening points, press the Delete key until you’ve erased the fastening

points for the desired segment.

7 Close the selection border:

• To close the border with a freehand Magnetic segment, double-click, or press Enter or Return.

• To close the border with a straight segment, hold down Alt (Windows) or Option (Mac OS), and double-click.

• To close the border, drag back over the starting point and click.

To set options for the Lasso, Polygonal Lasso, and Magnetic Lasso tools
The Lasso tool options let you customize how the different lasso tools detect and select edges.

1 If needed, select the tool.

2 Specify one of the selection options in the options bar.

Selection options
A. New B. Add To C. Subtract From D. Intersect With

3 Specify feather and anti-aliasing options.

4 (Photoshop) For the Magnetic Lasso tool, set any of these options:

Width To specify a detection width, enter a pixel value for Width. The Magnetic Lasso tool detects edges only within

the specified distance from the pointer.

To change the lasso pointer so that it indicates the lasso width, press the Caps Lock key. Change the pointer while the

tool is selected but not in use.

Edge Contrast To specify the lasso’s sensitivity to edges in the image, enter a value between 1% and 100% for Edge

Contrast. A higher value detects only edges that contrast sharply with their surroundings; a lower value detects

lower-contrast edges.

Frequency To specify the rate at which the lasso sets fastening points, enter a value between 0 and 100 for

Frequency. A higher value anchors the selection border in place more quickly.

On an image with well-defined edges, try a higher width and higher edge contrast, and trace the border roughly. On

an image with softer edges, try a lower width and lower edge contrast, and trace the border more precisely.

Stylus Pressure If you are working with a stylus tablet, select or deselect the Stylus Pressure option. When the

option is selected, an increase in stylus pressure decreases the edge width.

While creating a selection, press the right bracket (]) to increase the Magnetic Lasso edge width by 1 pixel; press the

left bracket ([) to decrease the width by 1 pixel.

A B C D
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To use the Magic Wand tool 
The Magic Wand tool lets you select a consistently colored area (for example, a red flower) without having to trace 

its outline. You specify the color range, or tolerance, for the Magic Wand tool’s selection. 

You cannot use the Magic Wand tool on an image in Bitmap mode or on 32-bits-per-channel images. 

1 Select the Magic Wand tool . 

2 Specify one of the selection options in the options bar. The Magic Wand tool’s pointer changes depending on 

which option is selected. 

A B C D 

Selection options 
A. New B. Add To C. Subtract From D. Intersect With 

3 In the options bar, specify any of the following: 

Tolerance Determines the similarity or difference of the pixels selected. Enter a value in pixels, ranging from 0 to 

255. A low value selects the few colors very similar to the pixel you click. A higher value selects a broader range of 

colors. 

Anti-aliased Defines a smooth edge. 

Contiguous Selects only adjacent areas using the same colors. Otherwise, all pixels in the entire image using the 

same colors are selected. 

Sample All Layers Selects colors using data from all the visible layers. Otherwise, the Magic Wand tool selects colors 

from the active layer only. 

4 In the image, click the color you want to select. If Contiguous is selected, all adjacent pixels within the tolerance 

range are selected. Otherwise, all pixels in the tolerance range are selected. 

Selecting a specific color or color subset 
The Color Range command selects a specified color or color subset within an existing selection or an entire image. 

If you want to replace a selection, be sure to deselect everything before applying this command. The Color Range 

command is not available for 32-bits-per-channel images. 

To refine an existing selection, use the Color Range command repeatedly to select a subset of colors. For example, to 

select the green areas in a cyan selection, select Cyans in the Color Range dialog box, and click OK. Then reopen the 

Color Range dialog box, and select Greens. (The results are subtle because the technique selects parts of colors within 

a color mix.) 

To select a color range using sampled colors 
1 Choose Select > Color Range. 

2 For Select, choose the Sampled Colors tool . 
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3 Select one of the display options:

Selection Previews only the selection as you build it.

Image Previews the entire image. For example, you might want to sample from a part of the image that isn’t on-

screen.

To toggle between the Image and Selection previews in the Color Range dialog box, press Ctrl (Windows) or

Command (Mac OS).

4 Position the pointer over the image or preview area, and click to sample the colors you want included.

Sampling color

5 Adjust the range of colors using the Fuzziness slider or by entering a value. To decrease the range of colors selected,

decrease the value. The Fuzziness option partially selects pixels by controlling the degree to which related colors are

included in the selection (whereas the Tolerance option for the Magic Wand tool and the paint bucket increases the

range of colors that are fully selected).

Increasing fuzziness expands selection

6 Adjust the selection:

• To add colors, select the plus eyedropper, and click in the preview area or image.

• To remove colors, select the minus eyedropper, and click in the preview area or image.

To activate the plus eyedropper temporarily, hold down Shift. Hold down Alt (Windows) or Option (Mac OS) to

activate the minus eyedropper.
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7 To preview the selection in the image window, choose an option for Selection Preview:


None Displays no preview in the image window.


Grayscale Displays the selection as it would appear in a grayscale channel.


Black Matte Displays the selection in color against a black background.


White Matte Displays the selection in color against a white background.


Quick Mask Displays the selection using the current quick mask settings.


8 To revert to the original selection, hold down Alt (Windows) or Option (Mac OS), and click Reset.


To select a color range using preset colors

1 Choose Select > Color Range.


2 For Select, choose a color or tonal range. The Out-Of-Gamut option works only on RGB and Lab images. (An out-


of-gamut color is an RGB or Lab color that cannot be printed using process color printing.)


3 Click Selection to display the selected areas in the preview area.


4 To preview the selection in the image window, choose an option for Selection Preview:


None Displays no preview in the image window.


Grayscale Displays the selection as it would appear in a grayscale channel.


Black Matte Displays the selection in color against a black background.


White Matte Displays the selection in color against a white background.


Quick Mask Displays the selection using the current quick mask settings.


5 To revert to the original selection, hold down Alt (Windows) or Option (Mac OS), and click Reset.


Note: If you see the message “No pixels are more than 50% selected,” the selection border will not be visible. You may 

have selected a color, such as red, when the image didn’t contain the fully saturated color. 

To save and load color range settings 
❖ Use the Save and Load buttons in the Color Range dialog box to save and reuse the current settings. 

Creating selections from slices (ImageReady) 
If you create a slice in ImageReady, you can convert it to a selection.


1 Select a slice.


2 Choose Select > Create Selection From Slice.


See also 

“To select one or more slices” on page 577 
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Adjusting pixel selections

To move, hide, or invert a selection
You can move a selection border around an image, hide a selection border, and invert a selection so that the previ-

ously unselected part of the image is selected.

1 Using any selection tool, select New Selection  from the options bar, and position the pointer inside the

selection border. The pointer changes  to indicate that you can move the selection.

2 Drag the border to enclose a different area of the image. You can drag a selection border partly beyond the canvas

boundaries. When you drag it back, the original border reappears intact. You can also drag the selection border to

another image window.

Original selection border (left), and selection border moved (right)

You can apply geometric transformations to change the shape of a selection border.

See also

“Applying transformations” on page 360

To control the movement of a selection
• To constrain the direction to multiples of 45˚, begin dragging, and then hold down Shift as you continue to drag.

• To move the selection in 1-pixel increments, use an arrow key.

• To move the selection in 10-pixel increments, hold down Shift, and use an arrow key.

To hide or show selection edges
Do one of the following:

• Choose View > Extras. In Photoshop, this command shows or hides selection edges, grids, guides, target paths,

slices, and annotations. In ImageReady, this command shows or hides selection edges, layer edges, grids, guides,

smart guides, slices, auto slices, image maps, and text selections.

• Choose View > Show > Selection Edges. This toggles the view of the selection edges and affects the current

selection only. The selection edges reappear when you make a different selection.

See also

“To show or hide Extras” on page 63
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To select the unselected parts of an image 
❖ Choose Select > Inverse. 

You can use this option to select an object placed against a solid-colored background. Select the background using 

the Magic Wand tool and then inverse the selection. 

Adjusting selections manually 
You can use the selection tools to add to or subtract from existing pixel selections.


Before manually adding to or subtracting from a selection, set the feather and anti-aliasing values in the options bar


to the same settings used in the original selection.


To add to a selection or select an additional area

1 Make a selection.


2 Using any selection tool, do one of the following:


•	 Select the Add To Selection option  in the options bar, and drag. 

• Hold down Shift, and drag to add another selection.


A plus sign appears next to the pointer when you’re adding to a selection.


To subtract from a selection

1 Make a selection.


2 Using any selection tool, do one of the following:


•	 Select the Subtract From Selection option  in the options bar, and drag to intersect with other selections. 

• Hold down Alt (Windows) or Option (Mac OS), and drag to subtract another selection. 

A minus sign appears next to the pointer when you’re subtracting from a selection. 

To select only an area intersected by other selections

1 Make a selection.


2 Using any selection tool, do one of the following:


•	 Select the Intersect With Selection option  in the options bar, and drag. 

•	 Hold down Alt+Shift (Windows) or Option+Shift (Mac OS) and drag over the portion of the original selection 

that you want to select. 

An “x” appears next to the pointer when you’re selecting an intersected area. 

Intersected selections 
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To expand or contract a selection by a specific number of pixels 
1 Use a selection tool to make a selection. 

2 Choose Select > Modify > Expand or Contract. 

3 For Expand By or Contract By, enter a pixel value between 1 and 100, and click OK. 

The border is increased or decreased by the specified number of pixels. Any portion of the selection border running


along the canvas’s edge is unaffected.


To frame an existing selection with a new selection

1 Use a selection tool to make a selection.


2 Choose Select > Modify > Border.


3 Enter a value between 1 and 200 pixels for the border width of the new selection, and click OK.


The new selection frames the original selected area.


Original selection (left), and after Border command: 5 pixels (right) 

The Border command creates an anti-aliased selection. To paint a hard-edged border around a selection, use the 

Stroke command. 

See also 

“To fill a selection or a layer with a foreground or background color” on page 498 

To expand a selection to include areas with similar color 
Do one of the following: 

•	 (Photoshop) Choose Select > Grow to include all adjacent pixels falling within the tolerance range specified in the 

magic wand options. 

•	 Choose Select > Similar to include pixels throughout the image, not just adjacent ones, falling within the tolerance 

range. 

To increase the selection in increments, choose either command more than once. 

Note: You cannot use the Grow and Similar commands on Bitmap mode images or 32-bits-per-channel images. 

To clean up stray pixels in a color-based selection

1 Choose Select > Modify > Smooth.


2 For Sample Radius, enter a pixel value between 1 and 100, and click OK.
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Photoshop or ImageReady checks around each selected pixel to find any unselected pixels falling within the specified 

range. For example, if you enter 16 for the sample radius, the program uses each pixel as the center of a 33-by-33-

pixel area (16 pixels in the horizontal and vertical directions). If most pixels in the range are selected, any unselected 

pixels are added to the selection. If most pixels are unselected, any selected pixels are removed from the selection. 

Note: The relationship between physical distance and pixel distance depends on the resolution of the image. For example, 

5 pixels is a longer distance in a 72-ppi image than in a 300-ppi image. 

See also 

“Pixel dimensions and image resolution” on page 178 

Softening and refining the edges of selections 

Methods for softening the edges of a selection 
You can smooth the hard edges of a selection by anti-aliasing and by feathering.


Anti-aliasing Smooths the jagged edges of a selection by softening the color transition between edge pixels and


background pixels. Because only the edge pixels change, no detail is lost. Anti-aliasing is useful when cutting,


copying, and pasting selections to create composite images.


Anti-aliasing is available for the Lasso tool, the Polygonal Lasso tool, the Magnetic Lasso tool, the Rounded Rectangle


Marquee tool (ImageReady), the Elliptical Marquee tool, and the Magic Wand tool. (Select a tool to display its


options bar.) You must specify this option before using these tools. After a selection is made, you cannot add anti


aliasing.


Feathering Blurs edges by building a transition boundary between the selection and its surrounding pixels. This


blurring can cause some loss of detail at the edge of the selection.


You can define feathering for the Marquee tool, the Lasso tool, the Polygonal Lasso tool, or the Magnetic Lasso tool


as you use the tool, or you can add feathering to an existing selection. Feathering effects become apparent when you


move, cut, copy, or fill the selection.


To use anti-aliasing

1 Select the Lasso tool, the Polygonal Lasso tool, the Magnetic Lasso tool, the Rounded Rectangle Marquee tool


(ImageReady), the Elliptical Marquee tool, or the Magic Wand tool.


2 Select Anti-aliased in the options bar.


To define a feathered edge for a selection tool

1 Select any of the lasso or marquee tools.


2 Enter a Feather value in the options bar. This value defines the width of the feathered edge and can range from 0


to 250 pixels.


To define a feathered edge for an existing selection

1 Choose Select > Feather.


2 Enter a value for the Feather Radius, and click OK.
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Note: A small selection made with a large feather radius may be so faint that its edges are invisible and thus not

selectable. If you see the message “No pixels are more than 50% selected,” either decrease the feather radius or increase

the size of the selection. Or click OK to accept the mask at its current setting and create a selection in which you cannot

see the edges.

Selection without feathering and with feathering.
A. Selection with no feather, same selection filled with pattern B. Selection with feather, same selection filled with pattern

See also

“To create a temporary mask for use as a selection” on page 339

Removing fringe pixels from a selection
When you move or paste an anti-aliased selection, some of the pixels surrounding the selection border are included

with the selection. This can result in a fringe or halo around the edges of the pasted selection. These Matting

commands let you edit unwanted edge pixels:

• Defringe replaces the color of any fringe pixels with the colors of nearby pixels containing pure colors (those

without background color). For example, if you select a yellow object on a blue background and then move the

selection, some of the blue background is selected and moved with the object. Defringe replaces the blue pixels

with yellow ones.

• Remove Black Matte and Remove White Matte are useful when a selection is anti-aliased against a white or black

background and you want to paste it onto a different background. For example, anti-aliased black text on a white

background has gray pixels at the edges, which are visible against a colored background.

You can also remove fringe areas by using the Advanced Blending sliders in the Layer Styles dialog box to remove, or

make transparent, areas from the layer. In this case, you would make the black or white areas transparent. Alt-click

(Windows) or Option-click (Mac OS) the sliders to separate them; separating the sliders allows you to remove fringe

pixels and retain a smooth edge.

A

B
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To decrease fringe on a selection

1 Choose Layer > Matting > Defringe.


2 Enter a value in the Width text box to specify the area in which to search for replacement pixels. In most cases, a


distance of 1 or 2 pixels is enough.


3 Click OK.


To remove a matte from a selection 
❖ Choose Layer > Matting > Remove Black Matte or Layer > Matting > Remove White Matte. 

Moving, copying, and pasting selections and layers 

Moving selections and layers within an image 
The Move tool lets you drag a selection or layer to a new location in the image. With the Info palette open, you can 

track the exact distance of the move. You can also use the Move tool to align selections and layers and distribute layers 

within an image. 

See also 

“Selecting layers” on page 399 

To specify Move tool options 
1 Select the Move tool 

2 Select any of the following in the options bar: 

Auto Select Layer Selects the topmost layer that has pixels under the Move tool, rather than the selected layer. 

. 

Auto Select Groups Selects the layer group that the selected layer is in. 

Show Transform Controls Displays handles on the bounding box around the selected item. 
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To move a selection or layer 
1 Select the Move tool . 

To activate the Move tool when another tool is selected, hold down Ctrl (Windows) or Command (Mac OS). (This 

technique does not  work  with  the Pen  tool, the  Freeform  Pen tool,  the Path Selection  tool, the  Direct  Selection tool,  

the Hand tool, the Slice Select tool, or the anchor point tools.) 

2	 Do one of the following: 

•	 Move the pointer inside the selection border, and drag the selection to a new position. If you have selected multiple 

areas, all move as you drag. 

Original selection (left), and after the selection is moved with the Move tool (right) 

•	 Select the layer you want to move. Then drag the layer to a new position. 

To align selections and layers within an image 
1 Do one of the following: 

•	 To align the content of a layer to a selection, make a selection in the image. Then select a layer in the Layers palette. 

•	 To align the contents of multiple layers to a selection border, make a selection in the image. In the Layers palette, 

select the layers you want to align. Shift-click to select contiguous layers, Ctrl-click (Windows) or Command-click 

to select noncontiguous layers. 

•	 To  align the  contents  of  layers  with  the content  of  the active layer, select the  layers  you want to align to the  active  

layer. Shift-click to select contiguous layers, Ctrl-click (Windows) or Command-click to select non-contiguous 

layers. 

2	 Select the Move tool . 

3	 Select one or more alignment options in the options bar. 

A B C D E F 

Alignment options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 

See also 

“To link and unlink layers” on page 401 
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To distribute layers in an image 
1 In the Layers palette, select three or more layers. Shift-click to select contiguous layers, Ctrl-click (Windows) or 

Command-click to select noncontiguous layers. 

2 Select the Move tool 

3 Select one or more distribute options in the options bar. 

. 

A B C D E F 

Distribute options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 

See also 

“To link and unlink layers” on page 401 

Copying selections or layers 
You can use the Move tool to copy selections as you drag them within or between images, or you can copy and move 

selections using the Copy, Copy Merged, Cut, and Paste commands. Dragging with the Move tool saves memory 

because the clipboard is not used as it is with the Copy, Copy Merged, Cut, and Paste commands. 

Copy Copies the selected area on the active layer. 

Copy Merged Makes a merged copy of all the visible layers in the selected area. 

Paste Pastes  a cut  or  copied  selection into another  part  of  the image  or  into  another image  as  a new  layer.  If  you have  

a selection, the Paste command places the copied selection over the current selection. Without an active selection, 

Paste places the copied selection in the middle of the view area. 

Paste Into (Photoshop) Pastes a cut or copied selection inside another selection in the same image or a different 

image. The source selection is pasted onto a new layer, and the destination selection border is converted into a layer 

mask. 

Keep in mind that when a selection or layer is pasted between images with different resolutions, the pasted data 

retains its pixel dimensions. This can make the pasted portion appear out of proportion to the new image. Use the 

Image Size command to make the source and destination images the same resolution before copying and pasting, 

and then set the zoom of both images to the same magnification. 

Depending on your color management settings and the color profile associated with the file (or imported data), you 

may be prompted to specify how to handle color information in the file (or imported data). 

See also 

“To determine a suggested resolution for an image” on page 186 

“Masking layers” on page 432 

“To set up color management for Illustrator, InDesign, and Photoshop” on page 254 

To copy a selection 
1 Select the area you want to copy. 

2 Choose Edit > Copy or Edit > Copy Merged. 
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To copy a selection while dragging 
1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to activate the Move tool. 

2	 Hold down Alt (Windows) or Option (Mac OS), and drag the selection you want to copy and move. 

When copying between images, drag the selection from the active image window into the destination image window. 

If nothing is selected, the entire active layer is copied. As you drag the selection over another image window, a border 

highlights the window if you can drop the selection into it. 

Dragging a selection into another image 

To create multiple copies of a selection within an image 
1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to activate the Move tool. 

2 Copy the selection: 

•	 Hold down Alt (Windows) or Option (Mac OS), and drag the selection. 

•	 To copy the selection and offset the duplicate by 1 pixel, hold down Alt or Option, and press an arrow key. 

•	 To copy the selection and offset the duplicate by 10 pixels, press Alt+Shift (Windows) or Option+Shift (Mac OS), 

and press an arrow key. 

As long as you hold down Alt or Option, each press of an arrow key creates a copy of the selection and offsets it by 

the specified distance from the last duplicate. In this case, the copy isn’t made on a new layer. 

To paste one selection into another

1 Cut or copy the part of the image you want to paste.


2 Select the part of the image into which you want to paste the selection. The source selection and the destination


selection can be in the same image or in two different Photoshop images.


3 Choose Edit > Paste Into. The contents of the source selection appear masked by the destination selection.


In the Layers palette, the layer thumbnail for the source selection appears next to the layer mask thumbnail for the


destination selection. The layer and layer mask are unlinked—that is, you can move each one independently.
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C E 

D 

Using the Paste Into command 
A. Window panes selected B. Copied image C. Paste Into command D. Layer thumbnails and layer mask in Layers palette E. Pasted 
image repositioned 

4 Select  the Move tool  ,  or  hold  down  the Ctrl (Windows)  or  Command (Mac  OS)  key to activate the  Move  tool.  

Then drag the source contents until the part you want appears through the mask. 

5 To specify how much of the underlying image shows through, click the layer mask thumbnail in the Layers palette, 

select a painting tool, and edit the mask: 

• To hide more of the image underlying the layer, paint the mask with black. 

• To reveal more of the image underlying the layer, paint the mask with white. 

• To partially reveal the image underlying the layer, paint the mask with gray. 

6 If you are satisfied with your results, you can choose Layer > Merge Down to merge the new layer and layer mask 

with the underlying layer and make the changes permanent. 

See also 

“Masking layers” on page 432 

Using drag-and-drop to copy between applications 
The drag-and-drop feature lets you copy and move images between Photoshop or ImageReady and other applica

tions. 

In Windows, the application must be OLE-compliant. To duplicate an entire image by dragging and dropping, use 

the Move tool to drag the image. To copy an OLE object that contains PSD data, use the OLE clipboard. (See your 

Windows documentation.) 
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Dragging vector artwork from Adobe Illustrator or from other applications that use the Illustrator clipboard 

rasterizes the artwork—the mathematically defined lines and curves of the vector art are converted into the pixels or 

bits of a bitmap image. To copy the vector artwork as a path in Photoshop, hold down Ctrl (Windows) or Command 

(Mac OS) as you drag from Adobe Illustrator. To copy type, you must first convert it to outlines. 

Using the clipboard to copy between applications 
You can often use the Cut or Copy command to copy selections between Photoshop or ImageReady and other appli

cations. The cut or copied selection remains on the clipboard until you cut or copy another selection. 

In some cases, the contents of the clipboard are converted to a raster image. Photoshop prompts you when vector 

artwork will be rasterized. 

Note: The image is rasterized at the resolution of the file into which you paste it. 

To save clipboard contents when you quit Photoshop 
1 Do one of the following: 

• (Windows) Choose Edit > Preferences > General. 

• (Mac OS) Choose Photoshop > Preferences > General. 

2 Select  Export  Clipboard to save any  Photoshop contents on the  clipboard when you  quit  Photoshop.  If  you leave  

this deselected, the contents are deleted when you quit the program. 

To paste PostScript artwork from another application

1 In the supporting application, select your artwork, and choose Edit > Copy.


2 (Photoshop or ImageReady) Select the image into which you’ll paste the selection.


3 Choose Edit > Paste.


4 (Photoshop) In the Paste dialog box, select from the following Paste As options:


Smart Object Places the artwork in a new layer as a smart object.


Pixels Rasterizes the artwork as it is pasted. Rasterizing converts mathematically defined vector artwork to pixels.


Paths Pastes the copy as a path in the Paths palette. When copying type from Illustrator, you must first convert it to


outlines.


Shape Layer Creates a new shape layer that uses the path as a vector mask. 

Note: When copying artwork from Adobe Illustrator, Illustrator’s default clipboard preferences may prevent the Paste 

dialog box from appearing in Photoshop. Select AICB in the File Handling and Clipboard area of Illustrator’s Preferences 

dialog box if you want the Paste options to appear when you paste the artwork in Photoshop. 

5 If you chose Paste As Pixels in the previous step, you can choose Anti-aliased in the options bar to make a smooth 

transition between the edges of the selection and the surrounding pixels. 

Note: You can use the Matting commands if you have already merged data and are trying to reextract the rasterized 

data. 
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See also 

“Smart Objects” on page 427 

“About file formats” on page 678 

“Removing fringe pixels from a selection” on page 327 

Saving, loading, and deleting selections 

To save a selection

1 Make a selection using any of the selection tools.


2 Choose Select > Save Selection.


3 Specify the following Destination options in the Save Selection dialog box:


Document Chooses the active file as the source.


Channel Chooses a new channel or the channel containing the selection you want to load. 

Name Lets you enter a name for the selection. 

4 Select an Operation option to specify how to combine the selections if the destination image already has a 

selection: 

New Channel Saves the current selection in a new channel. 

Add To Channel Adds the current selection to existing selections in the destination channel. 

Subtract From Channel Subtracts the current selection from existing selections in the destination channel. 

Intersect With Channel Saves a selection from an area intersected by the current selection and existing selections


in the destination channel.


To remove (cut) an object from a photo

1 In the Layers palette, select the layer containing the object you want to remove.


2 Using a selection tool, select the object that you want to remove.


3 If you need to refine the selection, click the Quick Mask Mode button
  in the toolbox. Photoshop masks or 

covers the nonselected areas of the image in a translucent color. Select a brush and appropriate brush size in the 

options bar. Paint with black to add to the mask; paint with white to reveal more of the image. 

4 To remove the selected object, choose Edit > Cut. 

See also 

“The Extract filter” on page 336 

To delete a selection 
❖ Choose Edit > Clear, or press Backspace (Windows) or Delete (Mac OS). To cut a selection to the clipboard, 

choose Edit > Cut. 
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Deleting a selection on a background or on a layer with the Lock Transparency option selected in the Layers palette


replaces the original location with the background color. Deleting a selection on a layer without Lock Transparency


selected replaces the original area with the layer transparency.


To load a saved selection into an image

1 Choose Select > Load Selection.


2 Specify the Source options in the Load Selection dialog box:


Document Chooses the active file as the source.


Channel Chooses the channel containing the selection you want to load.


Invert Makes the nonselected areas selected.


3 Select an Operation option to specify how to combine the selections if the image already has a selection:


New Selection Adds the loaded selection.


Add To Selection Adds the loaded selection to any existing selections in the image.


Subtract From Selection Subtracts the loaded selection from existing selections in the image.


Intersect With Selection Saves a selection from an area intersected by the loaded selection and existing selections


in the image.


See also 

“To save a mask selection” on page 343 

To load a saved selection in ImageReady 
❖ Choose Select > Load Selection, and then choose an option from the submenu. 

See also 

“To save a mask selection” on page 343


To load a selection from another image

1 Open the two images you want to use.


2 Make the destination image active, and choose Select > Load Selection.


3 Specify the following options in the Load Selection dialog box:


Document Chooses the source image.


Channel Chooses the channel containing the selection you want to load as a mask.


Invert Makes the nonselected areas selected.


Operation Specifies how to combine the selections if the destination image already has a selection.


You can drag a selection from one open Photoshop image into another. 
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Extracting selections

The Extract filter
The Extract filter dialog box provides a sophisticated way to isolate a foreground object and erase its background on

a layer. Even objects with wispy, intricate, or undefinable edges may be clipped from their backgrounds with a

minimum of manual work. You use tools in the Extract dialog box to specify which part of the image to extract. You

can resize the dialog box by dragging its lower right corner.

For simpler cases, try using the Background Eraser tool.

When you extract the object, Photoshop erases its background to transparency. Pixels on the edge of the object lose

their color components derived from the background, so they can blend with a new background without producing

a color halo.

Selected area highlighted and filled, and extracted object

You can add back opacity to the background and create other effects by using the Edit > Fade command after an

extraction.

See also

“To use the Background Eraser tool” on page 492

“To blend effects” on page 513

To extract an object from its background
1 In the Layers palette, select the layer containing the object you want to extract. If you select a background layer, it

becomes a normal layer after the extraction. If the layer contains a selection, the extraction erases the background

only in the selected area.

To avoid losing the original image information, duplicate the layer or make a snapshot of the original image state.

2 Choose Filter > Extract, and then specify tool options:

Brush Size Enter a value, or drag the slider to specify the width of the Edge Highlighter tool . You also use the

Brush Size option to specify the width of the Eraser, Cleanup, and Edge Touchup tools.

Highlight Choose a preset color option for the highlight that appears around objects when you use the Edge

Highlighter tool, or choose Other to pick a custom color for the highlight.

Fill Choose a preset color option, or choose Other to pick a custom color for the area covered by the Fill tool.
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Smart Highlighting Select this option if you are highlighting a well-defined edge. The option helps you keep the 

highlight on the edge, and applies a highlight that is just wide enough to cover the edge, regardless of the current 

brush size. 

Note: If you use Smart Highlighting to mark an object edge that’s near another edge, decrease the brush size if conflicting 

edges pull the  highlight off  the object edge.  If  the object edge has  a uniform  color on one  side  and high-contrast edges  on  

the other side, keep the object edge within the brush area but center the brush on the uniform color. 

Specify Extraction options: 

Textured Image Select this option if the foreground or background of your image contains a lot of texture. 

Smooth Enter a value or drag the slider to increase or decrease the smoothness of the outline. It’s usually best to 

begin with zero or a small value to avoid unwanted blurring of details. If there are sharp artifacts in the extraction 

result, you can increase the Smooth value to help remove them in the next extraction. 

Channel Choose the alpha channel from the Channel menu to base the highlight on a selection saved in an alpha 

channel. The alpha channel should be based on a selection of the edge boundary. If you modify a highlight based on 

a channel, the  channel name in the  menu  changes to Custom.  Your  image must have an alpha  channel for  the Channel  

option to be available. 

Force Foreground Select this option if the object is especially intricate or lacks a clear interior. 

3 Select the Edge Highlighter tool , and draw to define the edge of the object you want to extract. Drag so that 

the highlight slightly overlaps both the foreground object and its background. Use a large brush to cover wispy, 

intricate edges where the foreground blends into the background, as with hair or trees. 

Use either the Zoom tool or the Hand tool to adjust the view as needed. 

If you need to erase the highlight, select the Eraser tool , and drag over the highlight. To erase the entire 

highlight, press Alt+Backspace (Windows) or Option+Delete (Mac OS). 

If the object has a well-defined interior, make sure that the highlight forms a complete enclosure. You do not need to 

highlight areas where the object touches the image boundaries. If the object lacks a clear interior, highlight the entire 

object. 

Note: You can’t highlight the entire object if you’ve selected Textured Image or Force Foreground. 

4 Define the foreground area by doing one of the following: 

• If the object has a well-defined interior, select the Fill tool . Click inside the object to fill its interior. Clicking 

a filled area again with the Fill tool removes the fill. 

• If you’ve selected Force Foreground, select the Eyedropper tool , and click inside the object to sample the 

foreground color, or click in the Color text box and use a color picker to select the foreground color. This technique 

works best with objects that contain tones of a single color. 

5 (Optional) Click Preview to preview the extracted object. Zoom in as needed, and set any of the following preview 

options: 

Show Choose a menu option to switch between views of the original and the extracted image. 

Display Choose a menu option to preview the extracted object against a colored matte background or a grayscale 

background. To display a transparent background, choose None. 

Show Highlight Shows the object’s highlight in the preview. 

Show Fill Shows the object’s fill in the preview. 

 



338 ADOBE PHOTOSHOP CS2 
User Guide 

6	 (Optional) Improve the extraction by doing one of the following: 

•	 Choose new Highlight and Fill options and draw again with the Edge Highlighter tool. Define the foreground area 

once more, and then preview the extracted object. 

• Specify new Extraction settings (Smooth, Force Foreground, or Color) and then preview the extracted object. 

When you are satisfied with the extraction, you can do the final touchups. 

7	 Touch up the extraction results by doing one of the following: 

•	 To erase background traces in the extracted area, use the Cleanup tool . The tool subtracts opacity and has a 

cumulative effect. You can also use the Cleanup tool to fill gaps in the extracted object. Hold down Alt (Windows) 

or Option (Mac OS) while dragging to add back opacity. 

•	 To edit the edge of the extracted object, use the Edge Touchup tool . The tool sharpens edges and has a 

cumulative effect. If there is no clear edge, the Edge Touchup tool adds opacity to the object or subtracts opacity 

from the background. 

You can  also  clean up the  image after  an  extraction by using  the Background Eraser and  History Brush  tools in the  

toolbox. 

8 Click OK to apply the final extraction. On the layer, all pixels outside the extracted object are erased to trans

parency. 

Using masks 

About masks and alpha channels 
When you select part of an image, the area that is not selected is “masked” or protected from editing. So, when you 

create  a mask,  you isolate  and protect  areas of an image  as  you apply  color changes, filters, or other  effects to the  rest  

of the image. You can also use masks for complex image editing such as gradually applying color or filter effects to 

an image. 

A B C 

Examples of masks 
A. Opaque mask used to protect the background and edit the butterfly B. Opaque mask used to protect the butterfly and color the 
background C. Semitransparent mask used to color the background and part of the butterfly 

In Photoshop, masks are stored in alpha channels. Masks and channels are grayscale images, so you can edit them 

like any other image. With masks and channels, areas painted black are protected, and areas painted white are 

editable. 
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Photoshop lets you create masks in the following ways: 

Quick Mask mode Lets you edit any selection as a mask. The advantage of editing your selection as a mask is that 

you can use almost any Photoshop tool or filter to modify the mask. For example, if you create a rectangular selection 

with the Marquee tool, you can enter Quick Mask mode and use the Paintbrush tool to expand or decrease the 

selection, or you can use a filter to distort the edges of the selection. You can also use selection tools, because the 

quick mask is not a selection. You can also save and load selections you make using Quick Mask mode in alpha 

channels. 

Alpha channels Let you save and load selections. You can edit alpha channels using any of the editing tools. When 

a channel is selected in the Channels palette, foreground and background colors appear as grayscale values. Storing 

selections as alpha channels creates more permanent masks than the temporary masks of Quick Mask mode. You can 

reuse stored selections or even load them into another image. 

Selection saved as an alpha channel in Channels palette 

Note: In Photoshop and ImageReady, it’s possible to create layer masks to isolate and protect areas of an image. Layer 

masks, and also vector masks in Photoshop, let you produce a mix of soft and hard masking edges on the same layer. By 

making changes to the layer mask or the vector masks, you can apply a variety of special effects. Because ImageReady 

doesn’t let you work with channels, its layer masks aren’t stored as alpha channels. 

See also 

“Masking layers” on page 432 

To create a temporary mask for use as a selection 
To use Quick Mask mode, start with a selection and then add to or subtract from it to make the mask. You can also 

create the mask entirely in Quick Mask mode. Color differentiates the protected and unprotected areas. When you 

leave Quick Mask mode, the unprotected areas become a selection. 

Note: A temporary Quick Mask channel appears in the Channels palette while you work in Quick Mask mode. However, 

you do all mask editing in the image window. 

1 Using any selection tool, select the part of the image you want to change. 

2 Click the Quick Mask mode button  in the toolbox. 

A color overlay (similar to a rubylith) covers and protects the area outside the selection. Selected areas are left unpro

tected by this mask. By default, Quick Mask mode colors the protected area using a red, 50% opaque overlay. 
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A 

C 

D 

B 

Selecting in Standard mode and Quick Mask mode 
A. Standard mode B. Quick Mask mode C. Selected pixels appear as white in channel thumbnail D. Rubylith overlay protects area out
side selection, and unselected pixels appear as black in channel thumbnail 

3 To edit the mask, select a painting tool from the toolbox. The swatches in the toolbox automatically become black 

and white. 

4 Paint with white to select more of an image (the color overlay is removed from areas painted with white). To 

deselect areas, paint over them with black (the color overlay covers areas painted with black). Painting with gray or 

another color creates a semitransparent area, useful for feathering or anti-aliased effects. (Semitransparent areas may 

not appear to be selected when you exit Quick Mask Mode, but they are.) 
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Painting in Quick Mask mode
A. Original selection and Quick Mask mode with green chosen as mask color B. Painting with white in Quick Mask mode adds to the
selection C. Painting with black in Quick Mask mode subtracts from the selection

5 Click the Standard Mode button in the toolbox to turn off the quick mask and return to your original image.

A selection border now surrounds the unprotected area of the quick mask.

If a feathered mask is converted to a selection, the boundary line runs halfway between the black pixels and the white

pixels of the mask gradient. The selection boundary indicates the transition between pixels that are less than 50%

selected and those that are more than 50% selected.

6 Apply the desired changes to the image. Changes affect only the selected area.

7 Choose Select > Deselect to deselect the selection, or save the selection by choosing Select > Save Selection.

You can convert this temporary mask to a permanent alpha channel by switching to standard mode and choosing

Select > Save Selection

To change the Quick Mask options
1 Double-click the Quick Mask Mode button  in the toolbox.

2 Choose from the following display options:

Masked Areas Sets masked areas to black (opaque) and selected areas to white (transparent). Painting with black

increases the masked area; painting with white increases the selected area. When this option is selected, the Quick

Mask button in the toolbox becomes a white circle on a gray background .

Selected Areas Sets masked areas to white (transparent) and selected areas to black (opaque). Painting with white

increases the masked area; painting with black increases the selected area. When this option is selected, the Quick

Mask button in the toolbox becomes a gray circle on a white background .

A

B

C
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To toggle between the Masked Areas and Selected Areas options for quick masks, Alt-click (Windows) or Option-click 

(Mac OS) the Quick Mask Mode button. 

3 To choose a new mask color, click the color box, and choose a new color.


4 To change the opacity, enter a value between 0% and 100%.


Both  the color  and opacity  settings  affect  only  the appearance of the  mask  and have no effect on how  underlying  areas 


are protected. Changing these settings may make the mask more easily visible against the colors in the image.


See also 

“About the Swatches palette” on page 506 

To create an alpha channel and add a mask 
You can create a new alpha channel and then use painting tools, editing tools, and filters to create a mask from the 

alpha channel. You can also save an existing selection in a Photoshop or ImageReady image as an alpha channel that 

appears in the Channels palette in Photoshop. 

1	 Do one of the following: 

•	 To create a new alpha channel using the current option settings, click the New Channel button at the bottom 

of the Channels palette. Skip to the note in step 6. 

•	 To create an alpha channel and specify option settings, either Alt-click (Windows) or Option-click (Mac OS) the 

New Channel button at the bottom of the Channels palette, or choose New Channel from the Channels 

palette menu. 

2 If you are specifying option settings, begin by typing a name for the alpha channel in the Name text box of the 

New Channel dialog box. 

3 To set a display option for the mask, select one of the following in the New Channel dialog box:


Masked Areas Sets masked areas to black (opaque) and selected areas to white (transparent). Painting with black


Mask button in the toolbox becomes a white circle on a gray background . 

increases the masked area; painting with white increases the selected area. When this option is selected, the Quick 

Selected Areas Sets masked areas to white (transparent) and selected areas to black (opaque). Painting with white 

increases the masked area; painting with black increases the selected area. When this option is selected, the Quick 

Mask button in the toolbox becomes a gray circle on a white background . 

4	 To specify the appearance of the mask, any of the following in the New Channel dialog box: 

•	 To choose a new mask color, click the color box and then use the Adobe Color Picker to select a new color. 

Click OK to close the Adobe Color Picker after selecting a color. 

•	 To change the opacity, enter a value between 0% and 100%. 

Both  the color  and opacity  settings  affect  only  the appearance of the  mask  and have no effect on how  underlying  areas  

are protected. Changing these settings may make the mask more easily visible against the colors in the image. 

5 Click OK to close the New Channel dialog box. 

6 (Optional)  Click the  eye icon  next to a color channel  or  the composite  color channel, such as RGB, to display  

the image with a color overlay showing the mask. 
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Note: When the new channel appears at the bottom of the Channels palette, it is the only channel visible in the image 

window unless you click a color channel or the composite color channel. 

7 Select a painting or editing tool and do one of the following to add or subtract from the mask created from the 

alpha channel: 

•	 To remove areas in the new channel, paint with white. 

•	 To add areas in the new channel, paint with black. 

•	 Add or remove areas using opacities less than 100%, set the opacity in the options bar of the painting or editing 

tool and then paint with white or black. You can also paint with a color to achieve lower opacities. 

See also 

“About masks and alpha channels” on page 338 

Properties of alpha channels 
An alpha channel has these properties: 

•	 Each image can contain up to 56 channels, including all color and alpha channels. 

•	 You can specify a name, color, mask option, and opacity for each channel. (The opacity affects the preview of the 

channel, not the image.) 

•	 All new channels have the same dimensions and number of pixels as the original image. 

•	 You can edit the mask in an alpha channel using painting tools, editing tools, and filters. 

Original mask (left), and after a filter was applied (right) 

•	 You can convert alpha channels to spot color channels. 

To save a mask selection 
You can save any selection as a mask in a new or existing alpha channel. 

1 Select the area or areas of the image that you want to isolate. 

2 Click the Save Selection button  at the bottom of the Channels palette. A new channel appears, named 

according to the sequence in which it was created. 
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To save a selection to a new or existing channel

1 In  Photoshop or ImageReady,  use a selection tool to select the  area  or  areas of the  image that you  want  to  isolate. 


2 Choose Select > Save Selection.


3 Specify the following in the Save Selection dialog box, and click OK:


Document Chooses a destination image for the selection. By default, the selection is placed in a channel in your


active image. You can choose to save the selection to a channel in another open image with the same pixel dimensions


or to a new image.


Channel Chooses a destination channel for the selection. By default, the selection is saved in a new channel. You can


choose to save the selection to any existing channel in the selected image or to a layer mask if the image contains


layers.


4 If  you’re  saving  the selection  as  a new  channel,  type  a name for  the channel  in  the Name text box. In ImageReady, 


you can change the default channel name if you want to.


5 If you’re saving the selection to an existing channel, select how to combine the selections:


Replace Channel Replaces the current selection in the channel.


Add to Channel Adds the selection to the current channel contents. 

Subtract From Channel Deletes the selection from the channel contents. 

Intersect With Channel Keeps the areas of the new selection that intersect with the channel contents. 

In Photoshop, you can select the channel in the Channels palette to see the saved selection displayed in grayscale. A 

selection saved in ImageReady will appear in a new or existing channel in the Photoshop Channels palette. 

To change an alpha channel’s options 
1 In the Channel palette, do one of the following: 

•	 Select the channel, click the triangle in the upper right corner of the Channels palette, and choose Channel 

Options from the palette menu. 

• Double-click the channel thumbnail in the Channels palette.


2 If you want to rename the channel, type the new name in the Name text box of the Channel Options dialog box.


3 To set a display option for the mask, select one of the following in the Channel Options dialog box:


Masked Areas Sets masked areas to black (opaque) and selected areas to white (transparent). Painting with black


increases the masked area; painting with white increases the selected area. When this option is selected, the Quick


Mask button in the toolbox becomes a white circle on a gray background
 . 

Selected Areas Sets masked areas to white (transparent) and selected areas to black (opaque). Painting with white 

increases the masked area; painting with black increases the selected area. When this option is selected, the Quick 

Mask button in the toolbox becomes a gray circle on a white background . 

Spot Color Converts an alpha channel to a spot color channel. 

4	 To specify the appearance of the mask, do the following in the Channel Options dialog box: 

•	 To choose a new mask color, click the color box, and choose a new color. 

•	 To change the opacity, enter a value between 0% and 100%. 

Both  the color  and opacity  settings  affect  only  the appearance of the  mask  and have no effect on how  underlying  areas  

are protected. Changing these settings may make the mask more easily visible against the colors in the image. 
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See also 

“About channels” on page 438 

“About spot colors” on page 442 

To load a saved selection from an alpha channel 
You can  reuse a previously  saved selection  by  loading it into an image. You  can also load the  selection into an image  

after you finish modifying an alpha channel. 

❖ Do one of the following in the Channels palette: 

•	 Select the alpha channel, click the Load Selection button  at the bottom of the palette, and then click the


composite color channel near the top of the palette.


•	 Drag the channel containing the selection you want to load onto the Load Selection button. 

•	 Ctrl-click (Windows) or Command-click (Mac OS) the channel containing the selection you want to load. 

•	 To add the mask to an existing selection, press Ctrl+Shift (Windows) or Command+Shift (Mac OS), and click the 

channel. 

•	 To subtract the mask from an existing selection, press Ctrl+Alt (Windows) or Command+Option (Mac OS), and 

click the channel. 

•	 To load the intersection of the saved selection and an existing selection, press Ctrl+Alt+Shift (Windows) or 

Command+Option+Shift (Mac OS), and select the channel. 

You can drag a selection from one open Photoshop image into another. 

 



346 

Chapter 13: Transforming and retouching


Changing the size of the work canvas 

Changing the canvas size 
The Canvas Size command lets you add or remove work space around an existing image. You can also use the


command to crop an image by decreasing the canvas area. In ImageReady, added canvas appears in the same color


or transparency as the background. In Photoshop, there are several options for the background of the added canvas.


If your image has a transparent background, the added canvas is transparent.


To change the size of the canvas

1 Choose Image > Canvas Size.


2 Do one of the following:


•	 Enter the dimensions for the canvas in the Width and Height boxes. (Photoshop) Choose the units of 

measurement you want from the drop-down menus next to the Width and Height boxes. 

•	 Select Relative, and enter the amount by which you want to increase or decrease the size of the canvas. (Enter a 

negative number to decrease the size of the canvas.) 

3 For Anchor, click a square to indicate where to position the existing image on the new canvas. 

4 (Photoshop) Choose an option from the Canvas Extension Color menu: 

•	 Foreground to fill the new canvas with the current foreground color 

•	 Background to fill the new canvas with the current background color 

•	 White, Black, or Gray to fill the new canvas with that color 

•	 Other to select a new canvas color using the Color Picker 

Note: The Canvas Extension Color menu isn’t available if an image doesn’t contain a background layer. 

5	 Click OK. 

Original canvas, and canvas added to right side of image using the foreground color 
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To make a photo frame 
You can make a photo frame by increasing the canvas size and filling it with a color. 

You can also use one of the prerecorded actions to make a styled photo frame. It’s best to do this on a copy of your 

photo. 

1 Open the Actions palette. Choose Window > Actions. 

2 Choose Photo Frames from the Actions palette menu. 

3 Choose one of the photo frame actions from the list. 

4 Click the Play Action button. 

The action plays, creating the frame around your photo. 

Rotating and flipping entire images 

Rotating and flipping entire images 
The Rotate Canvas commands let you rotate or flip an entire image. The commands do not work on individual layers 

or parts of layers, paths, or selection borders. 

A B C 

D E F 

Rotating images 
A. Flip Horizontal B. Original image C. Flip Vertical D. Rotate 90˚ CCW E. Rotate 180˚ F. Rotate 90˚ CW 

To rotate or flip an entire image 
❖ Choose Image > Rotate Canvas, and choose one of the following commands from the submenu:


180˚ Rotates the image by a half-turn.


90˚ CW Rotates the image clockwise by a quarter-turn.


90˚ CCW Rotates the image counterclockwise by a quarter-turn.


Arbitrary Rotates the image by the angle you specify. If you choose this option, enter an angle between –359.99 and


359.99 in the angle text box. (In Photoshop, you can select CW or CCW to rotate clockwise or counterclockwise.)


Then click OK.


 



348 ADOBE PHOTOSHOP CS2 
User Guide 

Flip Canvas Horizontal (Photoshop) or Flip Horizontal (ImageReady) Flips the image horizontally, along the 

vertical axis. 

Flip Canvas Vertical (Photoshop) or Flip Vertical (ImageReady) Flips the image vertically, along the horizontal 

axis. 

Cropping images 

Cropping images 
Cropping is the process of removing portions of an image to create focus or strengthen the composition. You can 

crop an image using the Crop tool  and the Crop command. You can also trim pixels using the Crop And 

Straighten and the Trim commands. 

Using the Crop tool 

To crop an image using the Crop tool

1 Select the Crop tool


2 If necessary, use the options bar to set any Crop tool options.


3 Drag over the part of the image you want to keep to create a marquee. The marquee doesn’t have to be precise—


you can adjust it later.


4 If necessary, adjust the cropping marquee:


. 

•	 To move the marquee to another position, place the pointer inside the bounding box and drag. 

•	 To scale the marquee, drag a handle. To constrain the proportions, hold down Shift as you drag a corner handle. 

•	 To rotate the marquee, position the pointer outside the bounding box (the pointer turns into a curved arrow), and 

drag. To move the center point around which the marquee rotates, drag the circle at the center of the bounding 

box. 

Note: In Photoshop, you can’t rotate the marquee for an image in Bitmap mode. 

5	 Do one of the following: 

•	 To complete the crop, press Enter (Windows) or Return (Mac OS), click the Commit button in the options bar, 

or double-click inside the cropping marquee. 

•	 To cancel the cropping operation, press Esc or click the Cancel button  in the options bar. 
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To set Crop tool options 
❖ Choose from the following in the options bar to set the mode of the Crop tool: 

•	 (Photoshop) To crop the image without resampling (default), make sure that the Resolution text box in the options 

bar is empty. You can click the Clear button to quickly clear all text boxes. 

•	 (Photoshop) To resample the image during cropping, enter values for the height, width, and resolution in the 

options bar. The  Crop  tool  won’t resample the  image unless the  width and/or height,  and resolution are  provided.  

If you’ve entered height and width dimensions and want the values quickly exchanged, click the Swaps Height And 

Width icon . 

Note: (Photoshop) You can click the triangle next to the Crop tool icon in the options bar to open the Tool Preset Picker 

and select a resampling preset. As with all Photoshop tools, you can create your own Crop tool preset. See also “To create 

a tool preset” on page 48. 

•	 (ImageReady) To crop the image without resampling, make sure that Fixed Size is deselected in the options bar. 

•	 (ImageReady) To resample the image during cropping, select Fixed Size, and enter a height and width in the 

options bar. 

•	 To resample an image based on the dimensions and resolution of another image, open the other image, select the 

Crop tool, and click Front Image in the options bar. (In ImageReady, you must select the Fixed Size option to 

access the Front Image button.) Then make the image you want to crop active. 

Resampling during cropping combines the function of the Image > Image Size command with that of the Crop tool. 

•	 Specify whether you want to hide or delete the cropped area. Select Hide to preserve the cropped area in the image 

file. You can make the hidden area visible by moving the image with the Move tool. Select Delete to discard the 

cropped area. 

Note: In Photoshop, the Hide option is not available for images that contain only a background layer. If you want to crop 

a background by hiding, convert the background to a regular layer first. In ImageReady, cropping a background by hiding 

automatically converts the background to a regular layer. 

•	 Specify whether you want to use a cropping shield to shade the area of the image that will be deleted or hidden. 

When Shield is selected, you can specify a color and opacity for the cropping shield. When Shield is deselected, 

the area outside the cropping marquee is revealed. 

See also 

“Resampling” on page 182 

“About the background layer” on page 396 

To crop an image using the Crop command 
In addition to the Crop tool, you can use the crop and trim commands to crop an image. 

1 Use a selection tool to select the part of the image you want to keep. 

2 Choose Image > Crop. 
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To crop an image using the Trim command

1 Choose Image > Trim.


2 In the Trim dialog box, select an option:


•	 Transparent Pixels to trim away transparency at the edges of the image, leaving the smallest image containing 

nontransparent pixels. 

•	 Top Left Pixel Color to remove an area the color of the upper left pixel from the image. 

• Bottom Right Pixel Color to remove an area the color of the lower right pixel from the image. 

3 Select one or more areas of the image to trim away: Top, Bottom, Left, or Right. 

Transforming perspective while cropping 
The Crop tool in Photoshop  has an additional option that allows you  to  transform the  perspective in an image. This  

is very useful when working with images that contain keystone distortion. Keystone distortion occurs when an object  

is photographed from an angle rather than from a straight-on view. For example, if you take a picture of a tall building 

from ground level, the edges of the building appear closer to each other at the top than they do at the bottom. 

A	 B 

C	 D 

Steps to transform perspective 
A. Draw initial cropping marquee B. Adjust cropping marquee to match the object’s edges C. Extend the cropping bounds D. Final 
image 

To transform the perspective in an image 
1 Select the Crop tool  and set the crop mode. 

2 Drag  the cropping  marquee around an object that was  rectangular in the  original  scene (although  it  doesn’t appear  

rectangular in the image). You’ll use the edges of this object to define the perspective in the image. The marquee 

doesn’t have to be precise—you’ll adjust it later. 
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Important: You must select an object that was rectangular in the original scene or Photoshop will not be able to

transform the perspective in the image.

3 Select Perspective in the options bar, and set the other options as desired.

4 Move the corner handles of the cropping marquee to match the object’s edges. This defines the perspective in the

image, so it is important to precisely match the object’s edges.

5 Drag the side handles to extend the cropping bounds while preserving the perspective.

Note: Do not move the center point of the cropping marquee. The center point needs to be in its original position in order

to perform perspective correction.

6 Do one of the following:

• Press Enter (Windows) or Return (Mac OS), click the Commit button in the options bar, or double-click inside

the cropping marquee.

• To cancel the cropping operation, press Esc or click the Cancel button  in the options bar.

If Photoshop displays an error, it is probably due to improper placement of the corner handles or center point. Click

Cancel to go back and adjust the cropping marquee; click Don’t Crop to cancel the cropping operation. An error may

also occur if you’re working with a previously cropped image.

To use the Crop And Straighten Photos command
The Crop and Straighten Photos command helps you make separate image files from multiple images in a single scan.

For best results, you should keep 1/8 inch between the images in your scan, and the background (typically the

scanner bed) should be a uniform color with little noise. The Crop and Straighten Photos command works best on

images with clearly delineated outlines.

If the Crop And Straighten Photos command cannot process a complex image file, use the Crop tool.

1 Open the scanned file that contains the images you want to separate.

2 Select the layer that contains the images. Alternatively, draw a selection border around one or more images to

generate just those images into separate files.

3 Choose File > Automate > Crop And Straighten Photos. The scanned images are processed, and then each image

opens in its own window.

If the Crop And Straighten Photos command incorrectly splits one of your images, make a selection border around

the image and some background, and then hold down Alt (Windows) or Option (Mac OS) when you choose the

command. The modifier key indicates only one image should be separated from the background.

Correcting image distortion

The Lens Correction filter
The Lens Correction filter fixes common lens flaws such as barrel and pincushion distortion, vignetting, and

chromatic aberration.

Barrel distortion is a lens defect that causes straight lines to bow out toward the edges of the image. Pincushion

distortion is the opposite effect, where straight lines bend inward.
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Examples of barrel distortion (left) and pincushion distortion (right) 

Vignetting is a defect where the edges, especially the corners, of an image are darker than the center. Chromatic 

aberration appears as a color fringe along the edges of objects caused by the lens focusing on different colors of light 

in different planes. 

Some lenses exhibit these defects depending on the focal length or the f-stop used. You can set the Lens Correction 

filter to use settings based on the camera, lens, and focal length used to make the image. 

You can also use the filter to rotate an image or fix image perspective caused by vertical or horizontal camera tilt. The 

filter’s image grid makes these adjustments easier and more accurate than using the Transform command. 

To correct image perspective and lens flaws 
1 Choose Filter > Distort > Lens Correction. 

2 Set the grid and image zoom. As you work you may want to adjust the grid lines to help you judge the amount of 

correction to make. See “To adjust the Lens Correction preview and grid” on page 353. 

3 (Optional) Choose a preset list of settings from the Settings menu. Lens Default uses settings that you previously 

saved for the camera, lens, focal length, and f-stop combination used to make the image. Previous Conversion uses 

the settings used in your last lens correction. Any group of custom settings you saved are listed at the bottom of the 

menu. See “Setting camera and lens defaults” on page 353. 

4 Set any of the following options to correct your image. 

Remove Distortion Corrects lens barrel or pincushion distortion. Move the slider to straighten horizontal and 

vertical lines that bend either away from or toward the center of the image. You can also use the Remove Distortion 

tool to make this correction. Drag toward the center of the image to correct for barrel distortion and toward the 

edge of the image to correct for pincushion distortion. Adjust the Edge option to specify how you want to handle any 

resulting blank image edges. 

Vignette Corrects images that have darkened edges caused by lens faults or improper lens shading. 

Amount Sets the amount of lightening or darkening along the edges of an image. 

Midpoint Specifies the width of area affected by the Amount slider. Specify a lower number to affect more of the 

image. Specify a higher number to restrict the effect to the edges of the image. 

Chromatic Aberration Corrects color fringing. Zoom in on the image preview to get a closer view of the fringing 

as you make the correction. For more information see “Chromatic aberration” on page 219. 

Fix Red/Cyan Fringe Compensates for red/cyan color fringing by adjusting the size of the red channel relative to the 

green channel. 

Fix Blue/Yellow Fringe Compensates for blue/yellow color fringing by adjusting the size of the blue channel relative 

to the green channel. 
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Vertical Perspective Corrects image perspective caused by tilting the camera up or down. Makes vertical lines in 

an image parallel. 

Horizontal Perspective Corrects image perspective, making horizontal lines parallel. 

Angle Rotates the  image to correct  for camera tilt or to make adjustments  after correcting perspective. You  can also  

use the Rotate Straighten tool  to make this correction. Drag along a line in the image that you want to make 

vertical or horizontal. 

Edge Specifies how to handle the blank areas that result from pincushion, rotation, or perspective corrections. You 

can fill blank areas with transparency or a color, or you can extend the edge pixels of the image. 

Scale Adjusts the image scale up or down. The image pixel dimensions aren’t changed. The main use is to remove 

blank areas of the image caused by pincushion, rotation, or perspective corrections. Scaling up effectively results in 

cropping the image and interpolating up to the original pixel dimensions. 

To adjust the Lens Correction preview and grid 
•	 To change the image preview magnification, use the Zoom tool or the zoom controls in the lower left side of the 

preview image. 

•	 To move the image in the preview window, select the hand tool and drag in the image preview. 

•	 To use the grid, select Show Grid at the bottom of the dialog box. Use the Size control to adjust the grid spacing 

and the Color control to change the color of the grid. You can move the grid to line it up with your image using 

the Move Grid tool . 

Setting camera and lens defaults 
You can save the settings in the Lens Correction dialog box to reuse with other images made with the same camera, 

lens, and focal length. Photoshop saves settings for distortion, vignetting, and chromatic aberration. Perspective 

correction settings are not saved. You can save and reuse settings in two ways: 

• 

menu

Manually save and load settings. Set options in the dialog box, and then choose Save Settings from the Settings

. To use the saved settings, choose them from the Settings menu. You can also load saved settings that 

don’t appear in the menu using the Load Settings command in the Settings menu. 

•	 Set a lens default. If your image has EXIF metadata for the camera, lens, focal length, and f-stop, you can save the 

current settings as a lens  default.  To  save  the settings,  click the  Set Lens Default  button. When you  correct an image  

that matches the camera, lens, focal length, and f-stop, the Lens Default option becomes available in the Settings 

menu. 

Reducing image noise 

Reducing image noise 
Image noise appears as random extraneous pixels that aren’t part of the image detail. Noise can be caused by photo

graphing with a high ISO setting on a digital camera, underexposure, or shooting in a dark area with a long shutter 

speed. Low-end consumer cameras usually exhibit more image noise than high-end cameras. Scanned images may 

have image noise caused by the scanning sensor. Often, the film’s grain pattern appears in the scanned image. 

Image noise can appear in two forms: luminance (grayscale) noise, which makes an image look grainy or patchy, and 

color noise, which is usually visible as colored artifacts in the image. 
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Luminance noise may be more pronounced in one channel of the image, usually the blue channel. You can adjust the


noise for each channel separately in Advanced mode. Before opening the filter, examine each channel in your image


separately  to  see if noise  is  prevalent in one  channel.  You preserve more image  detail  by  correcting  one channel  rather 


than making an overall correction to all channels.


To reduce image noise and JPEG artifacts

1 Choose Filter > Noise > Reduce Noise.


2 Zoom in on the preview image to get a better view of image noise.


3 Set options:


Strength Controls the amount of luminance noise reduction applied to all image channels.


Preserve Details Preserves edges and image details such as hair or texture objects. A value of 100 preserves the most


image detail, but reduces luminance noise the least. Balance the Strength and Preserve Details controls to fine-tune


noise reduction.


Reduce Color Noise Removes random color pixels. A higher value reduces more color noise. 

Sharpen Details Sharpens  the image. Removing noise  reduces image  sharpness.  Use the  sharpening  control in the  

dialog box or use one of the other Photoshop sharpening filters later to restore sharpness. 

Remove JPEG Artifacts Removes blocky image artifacts and halos caused by saving a image using a low JPEG 

quality setting. 

4 If luminance noise is more prevalent in one or two color channels, click the Advanced button and then choose the 

color channel from the Channel menu. Use the Strength and Preserve Details controls to reduce noise in that 

channel. 

Sharpening images 

Sharpening images 
Sharpening enhances the definition of edges in an image. Whether your images come from a digital camera or a 

scanner,  most  images  can benefit  from  sharpening. The  degree  of  sharpening  needed  varies  depending on the  quality  

of the digital camera or scanner. Keep in mind that sharpening cannot correct a severely blurred image. 

Notes and tips about sharpening: 

•	 Sharpen your image on a separate layer so that you can resharpen it later if you need to output it to a different 

medium. 

•	 If you sharpen your image on a separate layer, set the layer’s blending mode to Luminance to avoid color shifts 

along edges. 

•	 Sharpening increases image contrast. If you find that highlights or shadows are clipped after you sharpen, use the 

layer blending controls (if you sharpen a separate layer) to prevent sharpening in highlights and shadows. See “To 

specify a tonal range for blending layers” on page 413. 

•	 If you need to reduce image noise, do so before sharpening so that you don’t intensify the noise. 
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•	 Sharpen your image multiple times in small amounts. Sharpen the first time to correct blur caused by capturing 

your image (scanning it or taking it with your digital camera). After you’ve color corrected and sized your image, 

sharpen it again (or a copy of it) to add the appropriate amount of sharpening for your output medium. 

•	 If possible, judge your sharpening by outputting it to the final medium. The amount of sharpening needed varies 

among output media. 

For greatest control use the Unsharp Mask (USM) filter or the Smart Sharpen filter to sharpen your images. Although 

Photoshop also has the Sharpen, Sharpen Edges, and Sharpen More filter options, these filters are automatic and do 

not provide controls and options. 

You can sharpen your entire image or just a portion defined by a selection or mask. Because the Unsharp Mask and 

Smart Sharpen filters can be applied to only one layer at a time, you might need to merge layers or flatten your file 

to sharpen all image layers in a multilayered file. 

Note: Don’t be misled by the name Unsharp Mask, which comes from a darkroom technique used in traditional film

based photography. The filter sharpens images rather than the opposite. 

To use the Smart Sharpen filter 
The Smart Sharpen filter has sharpening controls not available with the Unsharp Mask filter. You can set the sharp


ening algorithm or control the amount of sharpening that occurs in shadow and highlight areas.


1 Zoom the document window to 100% to get an accurate view of the sharpening.


2 Choose Filter > Sharpen > Smart Sharpen.


3 Set the controls in the Sharpen tabs:


Amount Sets the amount of sharpening. A higher value increases the contrast between edge pixels, giving the


appearance of greater sharpness.


Radius Determines the number of pixels surrounding the edge pixels affected by the sharpening. The greater the


radius value, the wider the edge effects and the more obvious the sharpening.


Remove Sets the sharpening algorithm used to sharpen the image. Gaussian Blur is the method used by the Unsharp


Mask filter. Lens Blur detects the edges and detail in an image, and provides finer sharpening of detail and reduced


sharpening halos. Motion Blur attempts to reduce the effects of blur due to camera or subject movement. Set the


Angle control if you choose Motion Blur.


Angle Sets the direction of motion for the Motion Blur option of the Remove control.


More Accurate Processes the file longer for a more accurate removal of blurring. 

4 Adjust sharpening of dark and light areas using in the Shadow and Highlight tabs. (Click the Advanced button to 

display the tabs). If the dark or light sharpening halos appear too strong you can reduce them with these controls: 

Fade Amount Adjusts the amount of sharpening in the highlights or shadows. 

Tonal Width Controls the range of tones in the shadows or highlights that are modified. Move the slider to the left 

or right to decrease or increase the Tonal Width value. Smaller values restrict the adjustments to only the darker 

regions for shadow correction and only the lighter regions for highlight correction. 

Radius Controls the size of the area around each pixel that is used to determine whether a pixel is in the shadows or 

highlights. Moving the slider to the left specifies a smaller area, and moving it to the right specifies a larger area. 

5	 Click OK. 
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The Unsharp Mask filter 
The Unsharp Mask sharpens an image by increasing contrast along the edges in an image. The Unsharp Mask does 

not detect edges in an image. Instead, it locates pixels that differ in value from surrounding pixels by the threshold 

you specify. It then increases the contrast of neighboring pixels by the amount you specify. So, for neighboring pixels 

the lighter pixels get lighter and the darker pixels get darker. 

In addition, you specify the radius of the region to which each pixel is compared. The greater the radius, the larger 

the edge effects. 

Original image, and Unsharp Mask applied 

The degree of sharpening applied to an image is often a matter of personal choice. However, oversharpening an image 

produces a halo effect around the edges. 

Oversharpening an image produces a halo effect around the edges. 

The effects of the Unsharp Mask filter are more pronounced on-screen than in high-resolution output. If your final 

destination is print, experiment to determine what settings work best for your image. 

To sharpen a photo using Unsharp Mask 
1 (Optional) If your image is multilayered, select the layer containing the image you want to sharpen. You can apply 

Unsharp Mask to only one layer at a time, even if layers are linked or grouped. You can merge the layers before 

applying the Unsharp Mask filter. 

2 Choose Filter > Sharpen > Unsharp Mask. Make sure the Preview option is selected. 

Click the image in the preview window and hold down the mouse to see how the image looks without the sharpening. 

Drag in the preview window to see different parts of the image, and click + or – to zoom in or out. 

Although there is a preview window in the Unsharp Mask dialog box, it’s best to move the dialog box so you can 

preview the effects of the filter in the document window. 

3 Drag the Radius slider or enter a value to determine the number of pixels surrounding the edge pixels that affect 

the sharpening. The greater the radius value, the wider the edge effects. And the wider the edge effects, the more 

obvious the sharpening. 
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The Radius value varies according to the subject matter, the size of the final reproduction, and the output method. 

For high-resolution images, a Radius value between 1 and 2 is usually recommended. A lower value sharpens only 

the edge pixels, whereas a higher value sharpens a wider band of pixels. This effect is much less noticeable in print 

than on-screen, because a 2-pixel radius represents a smaller area in a high-resolution printed image. 

4 Drag the Amount slider or enter a value to determine how much to increase the contrast of pixels. For high

resolution printed images, an amount between 150% and 200% is usually recommended. 

5 Drag the Threshold slider or enter a value to determine how different the sharpened pixels must be from the 

surrounding area before they are considered edge pixels and sharpened by the filter. For instance, a threshold of 4 

affects all pixels that have tonal values that differ by a value or 4 or more, on a scale of 0 to 255. So, if adjacent pixels 

have tonal values of 128 and 129, they are not affected. To avoid introducing noise or posterization (in images with 

flesh tones, for example), use an edge mask or try experimenting with Threshold values between 2 and 20. The 

default Threshold value (0) sharpens all pixels in the image 

If applying Unsharp Mask makes already bright colors appear overly saturated, choose Edit > Fade Unsharp Mask 

and choose Luminosity from the Mode menu. 

Selective sharpening 
You can sharpen parts of your image by using a mask or a selection. This is useful when you want to prevent sharp

ening in certain parts of your image. For example, you can use an edge mask with the Unsharp Mask filter on a 

portrait to sharpen the eyes, mouth, nose, and outline of the head, but not the texture of the skin. 

Using an edge mask to apply the Unsharp Mask only to specific features in an image 

To sharpen a selection

1 With the image layer selected in the Layers palette, draw a selection.


2 Choose Filter > Sharpen > Unsharp Mask. Adjust the options and click OK.


Only the selection is sharpened, leaving the rest of the image untouched.
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To sharpen an image using an edge mask 
1 Create a mask to apply sharpening selectively. There are many ways to create an edge mask. Use your favorite 

method, or try this one: 

•	 Open the Channels palette and select the channel that displays the grayscale image with the greatest contrast in 

the document window. Often, this is the green or the red channel. 

Selecting a channel with the greatest contrast 

•	 Duplicate the selected channel. 

•	 With the duplicate channel selected, choose Filter > Stylize > Find Edges. 

•	 Choose Image > Adjustments > Invert to invert the image. 

Find Edges filter applied and image inverted 

•	 With the inverted image still selected, choose Filter > Other > Maximum. Set the radius to a low number and 

click OK to thicken the edges and randomize the pixels. 

•	 Choose Filter > Noise > Median. Set the radius to a low number and click OK. This averages the neighboring 

pixels. 

•	 Choose Image > Adjustment > Levels and set the black point high to get rid of random pixels. If necessary, you 

can also paint with black to retouch the final edge mask. 

Setting the black point high in Levels to eliminate random pixels in the edge mask 

•	 Choose Filter > Blur > Gaussian Blur to feather the edges. 
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Important: The Maximum, the Median, and the Gaussian Blur filters soften the edge mask so that the sharpening effects 

blend better in the final image. Although all three filters are used in this procedure, you can experiment using only one 

or two. 

2 In the Channels palette, Ctrl-click (Windows) or Command-click (Mac OS) the duplicate channel to make the 

edge mask a selection. 

3 In the Layers palette, select the image layer. Make sure the selection is still visible on the image. 

4 Choose Select > Inverse. 

5 With the selection active on the image layer, choose Filter > Sharpen > Unsharp Mask. Set the desired options and 

click OK.


To view your results, select the RGB channel in the Channels palette and deselect the selection in the image.


You can create an action to conveniently apply all the steps in the procedure. 

See also 

“About masks and alpha channels” on page 338 

Transforming objects 

Specifying an item to transform 
You can apply transformations to a selection, an entire layer, multiple layers, or a layer mask. In Photoshop, you can 

also apply transformations to a path, a vector shape, a vector mask, a selection border, or an alpha channel. 

Important: In Photoshop, you can apply transformations to 8-bit and 16-bit images. However, you must convert images 

to 8-bit RGB Color mode before you can edit them in ImageReady. 

A B 

C D 

Transforming an image 
A. Original image B. Layer flipped C. Selection border rotated D. Part of object scaled 
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To calculate the color values of pixels that are added or deleted during transformations, Photoshop and ImageReady 

use the interpolation method selected in the General area of the Preferences dialog box. This setting directly affects 

the speed and quality of the transformation. Bicubic interpolation, the default, is slowest but yields the best results. 

See also 

“Choosing an interpolation method” on page 183 

To select an item to transform 
❖ Do one of the following: 

•	 To transform an entire layer, make the layer active, and make sure nothing is selected. 

Important: You cannot transform the background layer. To transform it, first convert it to a regular layer. 

•	 To transform part of a layer, select the layer in the Layers palette, and then select part of the image on that layer. 

•	 To transform multiple layers, link the layers together in the Layers palette. 

•	 To transform a layer mask or a vector mask, unlink the mask and select the mask thumbnail in the Layers palette. 

•	 (Photoshop) To transform a path or vector shape, use the Path Selection tool  to select the entire path or the 

Direct Selection tool  to select part of the path. If you select one or more points on a path, only those path 

segments connected to the points are transformed. 

•	 (Photoshop) To transform a selection border, make or load a selection. Then choose Select > Transform Selection. 

•	 (Photoshop) To transform an alpha channel, select the channel in the Channels palette. 

See also 

“To link and unlink layers” on page 401 

“To select a path” on page 461 

Applying transformations 
The commands under the Transform submenu let you apply the following transformations to an item: 

•	 Scaling enlarges or reduces  an  item  relative  to  its  reference point, the fixed point around which transformations are 

performed. You can scale horizontally, vertically, or both horizontally and vertically. 

•	 Rotating turns an item around a reference point. By default, this point is at the center of the object; however, you 

can move it to another location. 

•	 Skewing lets you slant an item vertically and horizontally. 

•	 Distorting lets you stretch an item in all directions. 

•	 Applying perspective lets you apply one-point perspective to an item. 

•	 (Photoshop) Warping lets you manipulate the shape of an item. 

In Photoshop, you can perform several commands in succession before applying the cumulative transformation. For 

example, you can choose Scale and drag a handle to scale, and then choose Distort and drag a handle to distort. Then 

press Enter or Return to apply both transformations. In ImageReady, you can perform multiple types of transforma

tions at the same time using the Transform > Numeric command. 
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To set or move the reference point for a transformation 
All transformations are performed around a fixed point called the reference point. By default, this point  is  at  the center  

of the item you are transforming. However, you can change the reference point or move the center point to a different 

location using the reference point locator in the options bar. 

1 Choose a transformation command. A bounding box appears in the image. 

2 Do one of the following: 

•	 In the options bar, click a square on the reference point locator . Each square represents a point on the 

bounding box. For example, to move the reference point to the upper left corner of the bounding box, click the 

top left square on the reference point locator. 

•	 In the transform bounding box that appears in the image, drag the reference point . The reference point can be 

outside the item you want to transform. 

To scale, rotate, skew, distort, apply perspective, or warp

1 Select what you want to transform.


2 Choose Edit > Transform > Scale, Rotate, Skew, Distort, Perspective, or Warp.


Note: (Photoshop) If you are transforming a shape or entire path, the Transform menu becomes the Transform Path 

menu. If you are transforming multiple path segments (but not the entire path), the Transform menu becomes the 

Transform Points menu. 

3 (Optional) In the options bar, click a square on the reference point locator 

4 Do one or more of the following: 

. 

•	 If you chose Scale, drag a handle on the bounding box. Press Shift as you drag a corner handle to scale proportion

ately. When positioned over a handle, the pointer becomes a double arrow. 

•	 If you chose Rotate, move the pointer outside the bounding border (it becomes a curved, two-sided arrow), and 

then drag. Press Shift to constrain the rotation to 15˚ increments. 

•	 If you chose Skew, drag a side handle to slant the bounding box. 

•	 If you chose Distort, drag a corner handle to stretch the bounding box. 

•	 If you chose Perspective, drag a corner handle to apply perspective to the bounding box. 

•	 (Photoshop) If you chose Warp, choose a warp from the Warp Style pop-up menu in the options bar, or to perform 

a custom warp, drag the control points, a line, or an area within the mesh to change the shape of the bounding box 

and mesh. 

•	 For all types of transformations, enter a value in the options bar. For example, to rotate an item, specify degrees in 

the rotation  text box. 

5 (Optional) If desired, switch to a different type of transformation by selecting a command from the Edit > 

Transform submenu. 

Important: When you transform a bitmap image (versus a shape or path), the image becomes slightly less sharp each 

time you commit a transformation; therefore, performing multiple commands before applying the cumulative transfor

mation is preferable to applying each transformation separately. 
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6 (Optional)  If  you want to warp the  image,  click the  Switch  Between Free Transform  And Warp Mode button  

in the options bar. 

7	 When you finish, do one of the following: 

•	 Press Enter (Windows) or Return (Mac OS), click the Commit button in the options bar, or double-click inside 

the transformation marquee. 

•	 To cancel the transformation, press Esc or click the Cancel button  in the options bar. 

See also 

“To warp an item” on page 364


To flip or rotate precisely

1 Select what you want to transform.


2 Choose Edit > Transform and choose one of the following commands from the submenu:


•	 Rotate 180˚ to rotate by a half-turn 

•	 Rotate 90˚ CW to rotate clockwise by a quarter-turn 

•	 Rotate 90˚ CCW to rotate counterclockwise by a quarter-turn 

•	 Flip Horizontal to flip horizontally, along the vertical axis 

•	 Flip Vertical to flip vertically, along the horizontal axis 

Note: (Photoshop) If you are transforming a shape or entire path, the Transform command becomes the Transform Path 

command. If you are transforming multiple path segments (but not the entire path), the Transform command becomes 

the Transform Points command. 

To repeat a transformation 
❖ Choose Edit > Transform > Again, Edit > Transform Path > Again, or Edit > Transform Points > Again. 

To duplicate an item when transforming it 
❖ Hold down Alt (Windows) or Option (Mac OS) when selecting the Transform command.


To apply multiple transformations at the same time (ImageReady)

1 Select what you want to transform.


2 Choose Edit > Transform > Numeric.


3 Do one or more of the following, and click OK:


•	 Select Position and enter values for the new location in the X (horizontal position) and Y (vertical position) text 

boxes. Select Relative to specify the new position in relation to the current position. 

•	 Select Scale. Enter the dimensions in the Width and Height text boxes, or enter a scaling percentage in the Scale 

text box. Select Constrain Proportions to maintain the aspect ratio. 

•	 Select Skew and enter degrees in the Horizontal skew and Vertical skew text boxes. 

•	 Select Rotate. Enter degrees of rotation in the Angle text box, or drag in the circle to the right of the text box. 
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The Free Transform command 
The Free Transform command lets you apply transformations (rotate, scale, skew, distort, and perspective) in one 

continuous operation. In Photoshop, you can also apply a warp transformation. Instead of choosing different 

commands, you simply hold down a key on your keyboard to switch between transformation types. 

Note: (Photoshop) If you are transforming a shape or entire path, the Transform command becomes the Transform Path 

command. If you are transforming multiple path segments (but not the entire path), the Transform command becomes 

the Transform Points command. 

To transform freely

1 Select what you want to transform.


2 Do one of the following:


•	 Choose Edit > Free Transform. 

•	 If you are transforming a selection, pixel-based layer, or selection border, choose the Move tool . Then select 

Show Transform Controls (Photoshop) or Show Transform Box (ImageReady) in the options bar. 

•	 (Photoshop) If you are transforming a vector shape or path, select the Path Selection tool . Then select Show 

Transform Controls in the options bar. 

3	 Do one or more of the following: 

• To scale by dragging, drag a handle. Press Shift as you drag a corner handle to scale proportionately. 

• 

icon

To scale numerically, enter percentages in the Width and Height text boxes in the options bar. Click the Link

 to maintain the aspect ratio. 

•	 To rotate by dragging, move the pointer outside the bounding border (it becomes a curved, two-sided arrow), and 

then drag. Press Shift to constrain the rotation to 15˚ increments. 

•	 To rotate numerically, enter degrees in the rotation text box  in the options bar. 

•	 To distort relative to the center point of the bounding border, press Alt (Windows) or Option (Mac OS), and drag 

a handle. 

•	 To distort freely, press Ctrl (Windows) or Command (Mac OS), and drag a handle. 

•	 To skew, press Ctrl+Shift (Windows) or Command+Shift (Mac OS), and drag a side handle. When positioned over 

a side handle, the pointer becomes a white arrowhead with a small double arrow. 

•	 To skew numerically, enter degrees in the H (horizontal skew) and V (vertical skew) text boxes in the options bar. 

•	 To apply perspective, press Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS), and drag a corner 

handle. When positioned over a corner handle, the pointer becomes a gray arrowhead. 

•	 To warp, click the Switch Between Free Transform And Warp Modes button in the options bar. Drag control 

points  to  manipulate  the shape  of  the item or choose a warp  from  the Warp Style  pop-up  menu  in  the options  bar.  

After choosing from the Warp Style pop-up menu, you can still drag the control points. 

•	 To change the reference point, click a square on the reference point locator  in the options bar. 

•	 To move an item, enter values for the new location of the reference in the X (horizontal position) and Y (vertical 

position) text boxes in the options bar. In Photoshop, click the Relative Positioning button to specify the new 

position in relation to the current position. 
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To undo the last handle adjustment, choose Edit > Undo. 

4	 Do one of the following: 

•	 Press Enter (Windows) or Return (Mac OS), click the Commit button in the options bar, or double-click inside 

the transformation marquee. 

•	 To cancel the transformation, press Esc or click the Cancel button  in the options bar. 

Important: When you transform a bitmap image (versus a shape or path), the image becomes slightly less sharp each 

time you commit a transformation; therefore, performing multiple commands before applying the cumulative transfor

mation is preferable to applying each transformation separately. 

The Warp command 
The Warp command lets you drag control points to manipulate the shape of images, shapes, or paths, and so on. You 

can also warp using a shape in the Warp Style pop-up menu in the options bar. Shapes in the Warp Style pop-up 

menu are also malleable; drag their control points. 

When using the control points to distort an item, choosing View > Extras shows or hides the warp mesh and control 

points. 

Choosing a warp from the Warp Style pop-up menu in the options bar 

To warp an item

1 Select what you want to warp.


2 Do one of the following:


•	 Choose Edit > Transform > Warp. 

•	 If you chose a different transform command or the Free Transform command, click the Switch Between Free 

Transform And Warp Modes button  in the options bar. 

 



ADOBE PHOTOSHOP CS2
User Guide

365

3 Do one or more of the following:

• To warp using a specific shape, choose from the Warp Style pop-up menu in the options bar.

Dragging a control point to warp the mesh

• To the manipulate the shape, drag the control points, a segment of the bounding box or mesh, or an area within

the mesh. When adjusting a curve, use the control point handles. This is similar to adjusting the handles in the

curved segment of a vector graphic. See also “To reshape a curved segment” on page 463.

To undo the last handle adjustment, choose Edit > Undo.

Manipulating the shape of a warp
A. Original warp mesh B. Adjusting the handles, mesh segments, and areas within the mesh

• To change the orientation of the warp, click the Change The Warp Orientation button  in the options bar.

• To change the reference point, click a square on the Reference point locator  in the options bar.

• To specify the amount of warp using numeric values, enter the values in the Bend (set bend), X (set horizontal

distortion) and Y (set vertical distortion) text boxes in the options bar. You can’t enter numeric values if you have

chosen None or Custom from the Warp Style pop-up menu.

4 (Optional) To apply the warp using a more detailed algorithm, select High Quality in the options bar.

5 Do one of the following:

• Press Enter (Windows) or Return (Mac OS), click the Commit button in the options bar, or double-click inside

the transformation marquee.

• To cancel the transformation, press Esc or click the Cancel button  in the options bar.

Important: When you warp a bitmap image (versus a shape or path), the image becomes slightly less sharp each time

you commit a transformation; therefore, performing multiple commands before applying the cumulative transformation

is preferable to applying each transformation separately.

A B
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Retouching and repairing images 

The Clone Stamp tool 
The Clone Stamp tool  takes a sample of an image, which you can then apply over another image or part of the 

same image. You can also clone part of one layer over another layer. Each stroke of the tool paints on more of the 

sample. The Clone Stamp tool is useful for duplicating an object or removing a defect in an image. 

When you use the Clone Stamp tool, you set a sampling point on the area you want to apply over another area. By 

selecting Aligned in the options bar, you can reuse the most current sampling point, no matter how many times you 

stop and resume painting. When Aligned is deselected, you’ll reuse the same sampled pixels each time you paint. 

Because you can use any brush tip with the Clone Stamp tool, you have a lot of control over the size of the area you 

clone. You can also use opacity and flow settings in the options bar to finesse the way you apply the cloned area. You 

can sample from one  image and  apply the  clone in another  image,  as  long  as  both  images  are in the  same  color mode.  

Altering an image with the Clone Stamp tool 

To use the Clone Stamp tool 
.1 Select the Clone Stamp tool 

2 Choose a brush tip and set brush options for the blending mode, opacity, and flow in the options bar. 

3 Next, determine how you want to align the sampled pixels. Select Aligned in the options bar to sample pixels 

continuously, without losing the current sampling point, even if you release the mouse button. Deselect Aligned to 

continue to use the sampled pixels from the initial sampling point each time you stop and resume painting. 

4 Select Use All Layers in the options bar to sample data from all visible layers; deselect Use All Layers to sample 

only from the active layer. 

5 Set the sampling point by positioning the pointer in any open image and Alt-clicking (Windows) or Option

clicking (Mac OS). 

6 Drag over the area of the image you want to correct. 

See also 

“List of blending modes” on page 487 

“Retouching tools gallery” on page 42 
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To use the Pattern Stamp tool 
The Pattern Stamp tool lets you paint with a pattern. You can select a pattern from the pattern libraries or create your 

own patterns. 

.1 Select the Pattern Stamp tool 

2 Choose a brush tip and set brush options (blending mode, opacity, and flow) in the options bar. 

3 Select Aligned in the options bar to sample pixels continuously, without losing the current sampling point, even 

if you release the mouse button. Deselect Aligned to continue to use the sampled pixels from the initial sampling


point each time you stop and resume painting.


4 Select a pattern from the Pattern pop-up palette in the options bar.


5 If you’d like to apply the pattern with an impressionistic effect, select Impressionist.


6 Drag in the image to paint with the pattern.


See also 

“List of blending modes” on page 487 

“About patterns” on page 500 

The Healing Brush tool 
The Healing Brush tool lets you correct imperfections, causing them to disappear into the surrounding image. Like 

the cloning tools, you use the Healing Brush tool to paint with sampled pixels from an image or pattern. However, 

the Healing Brush tool also matches the texture, lighting, transparency, and shading of the sampled pixels to the 

pixels being healed. As a result, the repaired pixels blend seamlessly into the rest of the image. 

Sampled pixels and healed image 

To use the Healing Brush tool 
1 Select the Healing Brush tool 

2 Click the brush sample in the options bar and set brush options in the pop-up palette: 

. 

Note: If you’re using a pressure-sensitive digitizing tablet, choose an option from the Size menu to vary the size of the 

healing brush over the course of a stroke. Choose Pen Pressure to base the variation on the pen pressure. Choose Stylus 

Wheel to base the variation on the position of the pen thumbwheel. Choose Off if you don’t want to vary the size. 

3 Choose a blending mode from the Mode menu in the options bar. Choose Replace to preserve noise, film grain, 

and texture at the edges of the brush stroke. 

4 Choose a source to use for repairing pixels in the options bar: Sampled to use pixels from the current image, or 

Pattern to use pixels from a pattern. If you chose Pattern, select a pattern from the Pattern pop-up palette. 
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5 Select Aligned in the options bar to sample pixels continuously, without losing the current sampling point, even 

if you release the mouse button. Deselect Aligned to continue to use the sampled pixels from the initial sampling 

point each time you stop and resume painting. 

6 Select Use All Layers in the options bar to sample data from all visible layers. Deselect Use All Layers to sample 

only from the active layer. 

7 For the Healing Brush tool in sampling mode, set the sampling point by positioning the pointer in any open image 

and Alt-clicking (Windows) or Option-clicking (Mac OS). 

Note: If  you are  sampling  from  one image  and applying to another, both images must be in the  same  color mode unless  

one of the images is in Grayscale mode. 

8 Drag in the image. 

The sampled pixels are melded with the existing pixels each time you release the mouse button. Look in the status 

bar to view the status of the melding process. 

If there is a strong contrast at the edges of the area you want to heal, make a selection before you use the Healing 

Brush tool. The selection should be bigger than the area you want to heal but should precisely follow the boundary 

of contrasting pixels. When you paint with the Healing Brush tool, the selection prevents colors from bleeding in from 

the outside. 

See also 

“List of blending modes” on page 487 

“To create a brush and set painting options” on page 475 

“About patterns” on page 500 

“Retouching tools gallery” on page 42 

The Spot Healing Brush tool 
The Spot Healing Brush tool quickly removes blemishes and other imperfections in your photos. The Spot Healing 

Brush works similarly to the Healing Brush: it paints with sampled pixels from an image or pattern and matches the 

texture, lighting, transparency, and shading of the sampled pixels to the pixels being healed. Unlike the Healing 

Brush, the Spot Healing Brush doesn’t require you to specify a sample spot. The Spot Healing Brush automatically 

samples from around the retouched area. 

Using the Spot Healing Brush to remove a blemish 
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If you need to retouch a large area or need more control over the source sampling, you can use the Healing Brush 

instead of the Spot Healing Brush. 

To use the Spot Healing Brush tool 
The Spot Healing Brush quickly removes blemishes and other imperfections in your photos. You can either click once 

on a blemish, or click and drag to smooth away imperfections in an area. 

1 Select the Spot Healing Brush tool  from the toolbox. If necessary, click either the Healing Brush tool, Patch 

tool, or Red Eye tool to show the hidden tools and make your selection. 

2 Choose a brush size in the options bar. A brush that is slightly larger than the area you want to fix works best so 

that you can cover the entire area with one click. 

3 (Optional) Choose a blending mode from the Mode menu in the options bar. Choose Replace to preserve noise, 

film grain, and texture at the edges of the brush stroke. 

4 Choose a Type option in the options bar:


Proximity Match Uses the pixels around the edge of the selection to find an image area to use as a patch for the


selected area. If this option doesn’t provide a satisfactory fix, undo the fix and try the Create Texture option.


Create Texture Uses all the pixels in the selection to create a texture with which to fix the area. If the texture doesn’t 

work, try dragging through the area a second time. 

5 Select Use All Layers in the options bar to sample data from all visible layers. Deselect Use All Layers to sample 

only from the active layer. 

6 Click the area you want to fix, or click and drag over a larger area. 

See also 

“List of blending modes” on page 487 

“To create a brush and set painting options” on page 475 

“Retouching tools gallery” on page 42 

The Patch tool 
The Patch tool lets you repair a selected area with pixels from another area or a pattern. Like the Healing Brush tool, 

the Patch tool matches the texture, lighting, and shading of the sampled pixels to the source pixels. You can also use 

the Patch tool to clone isolated areas of an image. 

When repairing with pixels from the image, select a small area to produce the best result. 
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Using the Patch tool to replace pixels 

Patched image 

See also 

“Retouching tools gallery” on page 42 

To repair an area using sampled pixels 
1 Select the Patch tool 

2 Do one of the following: 

. 

•	 Drag in the image to select the area you want to repair, and select Source in the options bar. 

•	 Drag in the image to select the area from which you want to sample, and select Destination in the options bar. 

Note: You can also make a selection prior to selecting the Patch tool. 

3	 To adjust the selection, do one of the following: 

•	 Shift-drag in the image to add to the existing selection. 

•	 Alt-drag (Windows) or Option-drag (Mac OS) in the image to subtract from the existing selection. 

•	 Alt+Shift-drag (Windows) or Option+Shift-drag (Mac OS) in the image to select an area intersected by the 

existing selection. 

4	 Position the pointer inside the selection, and do one of the following: 

•	 If Source is selected in the options bar, drag the selection border to the area from which you want to sample. When 

you release the mouse button, the originally selected area is patched with the sampled pixels. 

•	 If Destination is selected in the options bar, drag the selection border to the area you want to patch. When you 

release the mouse button, the newly selected area is patched with the sampled pixels. 
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To repair an area using a pattern 
1 Select the Patch tool 

2 Drag in the image to select the area you want to repair. 

. 

Note: You can also make a selection prior to selecting the Patch tool. 

3	 To adjust the selection, do one of the following: 

•	 Shift-drag in the image to add to the existing selection. 

•	 Alt-drag (Windows) or Option-drag (Mac OS) in the image to subtract from the existing selection. 

•	 Alt-Shift-drag (Windows) or Option-Shift-drag (Mac OS) in the image to select an area intersected by the existing 

selection. 

4	 Select a pattern from the Pattern palette in the options bar, and click Use Pattern. 

To remove red eye 
The Red  Eye tool removes  red eye  in  flash photos of people and  white or green  reflections in flash  photos  of  animals.  

1	 Select the Red Eye tool . 

2 Click in the red eye. If you are not satisfied with the result, undo the correction, set one or more of the following


options in the options bar, and click the red eye again:


Pupil Size Sets the size of the pupil (dark center of the eye).


Darken Pupil Sets the darkness of the pupil. 

Red eye is caused by a reflection of the camera flash in the subject’s retina. You’ll see it more often when taking 

pictures in a darkened room because the subject’s iris is wide open. To avoid red eye, use the camera’s red eye 

reduction feature. Or, better yet, use a separate flash unit that you can mount on the camera farther away from the 

camera’s lens. 

To use the Color Replacement tool 
The Color Replacement tool simplifies replacing specific colors in your image. You can paint over a targeted color


with a corrective color. The Color Replacement tool doesn’t work in images in Bitmap, Indexed, or Multichannel


color modes.


1 Select the Color Replacement tool


2 Choose a brush tip in the options bar. Generally, you should keep the blending mode set to Color.


3 For the Sampling option, choose one of the following:


Continuous Samples colors continuously as you drag.


. 

Once Replaces the targeted color only in areas containing the color that you first click 

Background Swatch Replaces only areas containing the current background color. 

4 For the Limits option, select one of the following:


Discontiguous Replaces the sampled color wherever it occurs under the pointer.


Contiguous Replaces colors that are contiguous with the color immediately under the pointer


Find Edges Replaces connected areas containing the sampled color while better preserving the sharpness of


shape edges.
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5 For tolerance, enter a percentage value (ranging from 0 to 255) or drag the slider. Choose a low percentage to


replace colors very similar to the pixel you click, or raise the percentage to replace a broader range of colors.


6 To define a smooth edge in the corrected areas, select Anti-aliased.


7 Choose a foreground color that replaces the unwanted color.


8 Click the color you want to replace in the image.


9 Drag in the image to replace the targeted color.


See also 

“List of blending modes” on page 487 

To use the Smudge tool 
The Smudge tool simulates the effect you see when you drag a finger through wet paint. The tool picks up color where


the stroke begins and pushes it in the direction you drag.


1 Select the Smudge tool


2 Choose a brush tip and options for the blending mode in the options bar.


3 Select  Use All  Layers  in  the options  bar to smudge using  color data from all  visible layers.  If  this  is  deselected, the 


. 

Smudge tool uses colors from only the active layer.


4 Select Finger Painting in the options bar to smudge using the foreground color at the beginning of each stroke. If


this is deselected, the Smudge tool uses the color under the pointer at the beginning of each stroke.


5 Drag in the image to smudge the pixels.


In Photoshop, press Alt (Windows) or Option (Mac OS) as you drag with the Smudge tool to use the Finger Painting 

option. 

See also 

“List of blending modes” on page 487 

To use the Blur tool 
The Blur tool softens hard edges or reduces detail in an image. 

1 Select the Blur tool 

2 Do the following in the options bar: 

. 

•	 Choose a brush tip and set options for the blending mode and strength in the options bar. 

•	 Select Use All Layers in the options bar to blur using data from all visible layers. If this is deselected, the tool uses 

data from only the active layer. 

3	 Drag over the part of the image you want to blur. 

See also 

“Blur filters” on page 515 

“List of blending modes” on page 487 
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To use the Sharpen tool 
The Sharpen tool focuses soft edges to increase clarity or focus. 

1 Select the Sharpen tool 

2 Do the following in the options bar: 

. 

•	 Choose a brush tip and set options for the blending mode and strength in the options bar. 

•	 Select Use All Layers in the options bar to sharpen using data from all visible layers. If this is deselected, the tool 

uses data from only the active layer. 

3	 Drag over the part of the image you want to sharpen. 

See also 

“Sharpen filters” on page 522 

“List of blending modes” on page 487 

To use the Dodge tool or the Burn tool 
Used to lighten or darken areas of the image, the Dodge tool and the Burn tool are based on a traditional photog-

rapher’s technique for regulating exposure on specific areas of a print. Photographers hold back light to lighten an 

area on the print (dodging) or increase the exposure to darken areas on a print (burning). 

1	 Select the Dodge tool  or the Burn tool .


2 Choose a brush tip and set brush options in the options bar.


3 In the options bar, select one of the following:


•	 Midtones to change the middle range of grays


•	 Shadows to change the dark areas


• Highlights to change the light areas


4 Specify the exposure for the Dodge tool or the Burn tool.


5 (Photoshop) Click the airbrush button
  to use the brush as an airbrush. Alternatively, select the Airbrush


option in the Brushes palette.


6	 Drag over the part of the image you want to lighten or darken. 

See also 

“To select a preset brush” on page 473 

To use the Sponge tool 
The Sponge tool subtly changes the color saturation of an area. In Grayscale mode, the tool increases or decreases 

contrast by moving gray levels away from or toward the middle gray. 

1 Select the Sponge tool 

2 Choose a brush tip and set brush options in the options bar. 

. 
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3 In the options bar, select the way you want to change the color. 

• Saturate to intensify the color’s saturation 

• Desaturate to dilute the color’s saturation


4 Specify the flow for the Sponge tool.


5 Drag over the part of the image you want to modify.


See also 

“To select a preset brush” on page 473 

Vanishing Point 

About Vanishing Point 
Vanishing Point is a feature that lets you make perspective-correct edits in images that contain perspective planes— 

for instance, the sides of a building or any rectangular object. Using Vanishing Point, you specify the planes in an 

image, and then apply edits such as painting, cloning, copying or pasting, and transforming. All your edits honor the 

perspective of the plane you’re working in. With Vanishing Point, you’re no longer retouching an image as if all its 

contents are on a single flat plane facing you. Instead, you’re working dimensionally on the perspective planes in the 

image. When you use Vanishing Point to retouch, add, or remove content in an image, the results are more realistic 

because the edits are properly oriented and scaled to the perspective planes. 

Making edits on the perspective planes in an image 

To use Vanishing Point, you open the Vanishing Point dialog box (choose Filter > Vanishing Point), which contains 

tools for defining the perspective planes, tools for editing the image, and an image preview that you work in. You first 

specify the perspective planes in the preview image, and then you can paint, clone, copy, paste, and transform content 

in the planes. The Vanishing Point tools (Marquee, Stamp, Brush, and others) behave similarly to their counterparts 

in the main Photoshop toolbox. You can even use the same keyboard shortcuts to set the tool options. 
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Vanishing Point dialog box
A. Options B. Toolbox C. Preview of vanishing point session D. Zoom options

See also

“To define and adjust perspective planes in Vanishing Point” on page 378

“Vanishing Point tools” on page 380

“Keys for using Vanishing Point” on page 762

To use Vanishing Point
1 (Optional) Before choosing the Vanishing Point command, you can prepare your image by doing any of the

following:

• To put the results of your Vanishing Point work in a separate layer, first create a new layer before choosing the

Vanishing Point command.

If you create a new layer each time you use Vanishing Point, the results appear on a separate, editable layer. You can

then use such layer features as opacity, layer styles, and blending modes. Putting the Vanishing Point results in a

separate layer also preserves your original image.

• If you plan to clone the content in your image beyond the boundaries of the current image size, increase the canvas

size to accommodate the additional content. See also “To change the size of the canvas” on page 346.

B

D

C

A
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• If you plan to paste an item from the Photoshop clipboard into Vanishing Point, copy the item before choosing the

Vanishing Point command. The copied item can be from a different Photoshop document. If you’re copying type,

select the entire text layer and then copy to the clipboard.

• To confine the Vanishing Point results to specific areas of your image, either make a selection or add a mask to

your image before choosing the Vanishing Point command. See also “To use the marquee tools” on page 316 and

“About masks and alpha channels” on page 338.

Using a selection to confine edits to portions of the perspective planes

2 Choose Filter> Vanishing Point.

3 Select the Create Plane tool and define the four corner nodes of the plane surface. Try to use a rectangle object

in the image as a guide when creating the plane.

After creating the four corner nodes, you can move, scale, or reshape the plane. Keep in mind that your results

depend on how accurately the plane lines up with perspective of the image. If there’s a problem with the corner node

placement, the bounding box and grid turn either red or yellow. Move a corner node until the bounding box and grid

are blue, which indicates that the plane is valid. See also “To define and adjust perspective planes in Vanishing Point”

on page 378 and “Bounding box and grid alerts in Vanishing Point” on page 382.

Selecting a corner node

It’s a good idea to adjust the plane or use the Grid Size option to line up the perspective plane and grid with image

elements, such as the pattern in the floor, texture on a wall, or frame of a window.

4 (Optional) Select the Create Plane tool and Ctrl-drag (Windows) or Command-drag (Mac OS) an edge node of

the plane to tear off a perpendicular plane. You can also tear off a perpendicular plane from the one you just created.

All the planes you tear off from each other (as opposed to creating unrelated planes) keep your edits in the proper

scale and orientation throughout the image.

Ctrl-drag (Windows) or Command-drag (Mac OS) an edge node to tear off perpendicular planes.

 



ADOBE PHOTOSHOP CS2
User Guide

377

You can use your first Vanishing Point session for simply creating perspective planes and then clicking OK. The planes

appear in subsequent Vanishing Point sessions when you choose Filter > Vanishing Point. This is especially useful if

you plan to copy and paste an image into Vanishing Point and need to have a ready-made planes to target.

5 Do one or more of the following:

• To make a selection, select the Marquee tool  and drag in a plane. You can set the Marquee tool options

(Feather, Opacity, Heal, and Move Mode) at any time, either before or after making the selection. To select an

entire plane, double-click the Marquee tool in the plane.

When you move the Marquee tool, the Stamp tool, or the Brush tool into a plane, the bounding box is highlighted,

indicating that the plane is active.

• To clone a selection, select the Marquee or Transform tool and Alt-drag (Windows) or Option-drag (Mac OS) the

selection to tear off a copy. The selection becomes a floating selection, which you can scale, move, rotate, or clone

again using the Transform tool, or move or clone again using the Marquee tool. You can continue tearing off as

many copies as you want. When you move a selection in a plane, the selection conforms to the perspective of the

plane.

Tearing off a selection and moving a selection from one perspective plane to another

Pressing Ctrl+Shift+T (Windows) or Control+Shift+T (Mac OS) duplicates your last duplicating move. This is an

easy way to clone content multiple times.

• To move a selection, select the Marquee or Transform tool and drag the selection. Hold down the Shift key to

constrain the move.

• To rotate a selection, select the Transform tool and move the pointer near a node. When the pointer changes to a

curved double arrow, drag to rotate the selection. You can also select the Flip option to flip the selection horizon-

tally along the vertical axis of the plane or select the Flop option to flip the selection vertically along the horizontal

axis of the plane.

• To scale a selection, select the Transform tool and move the pointer on top of a node. When the pointer changes

to a straight double arrow drag to scale the selection.

• To fill a selection with another area of the image, select the Marquee tool, and then Ctrl-drag (Windows) or

Command-drag (Mac OS) a selection to the image area you want as the source image. You can also choose Source

for the Move Mode and drag the selection to the source image. The filled selection becomes a floating selection

that you can scale, rotate, move, or clone using the Transform tool, or move or clone using the Marquee tool.

• To paint with a sample of the image, select the Stamp tool and Alt-click (Windows) or Option-click (Mac OS) a

source area in a perspective plane. Now you can paint with the Stamp tool to clone the source anywhere in the

image. If you paint in a perspective plane, the Stamp tool paints the cloned area in perspective. For detailed infor-

mation, see also “To use the Stamp tool in Vanishing Point” on page 383 and “Vanishing Point tools” on page 380.

• To paint with a color, select the Brush tool, set the options for Diameter, Hardness, Opacity, and Heal. Click the

Brush Color box to open the Adobe Color Picker to select a color. Drag in the image to paint. When painting in a

plane, the brush size and shape scales and orients properly to the plane’s perspective. Shift-drag constrains the

stroke to a straight line.
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•	 To transform a floating selection, select the Transform tool  and scale, rotate, or move the floating selection. 

You can also select a Transform tool options to flip horizontally or flop vertically the floating selection in relation 

to the plane orientation. 

•	 To paste an item from the clipboard, press Ctrl+V or Command+V. Move the item into a plane and it conforms to 

the perspective. For detailed information, see also “To paste an item into Vanishing Point” on page 382. 

Note: If the plane is not the proper size to accommodate your painting, cloning, or transforming, select the Edit Plane 

tool and drag an edge node of the bounding box to scale the plane. 

Vanishing Point allows multiple undos. Press Ctrl+Z (Windows) or Command+Z (Mac OS) one or more times to 

undo an operation one or more times. Press Shift+Ctrl+Z (Windows) or Shift+Command+Z (Mac OS) to redo an 

operation. Press Alt (Windows) or Option (Mac OS) to change the Cancel button to Reset so that you can revert the 

image to its original state in the Vanishing Point dialog box. 

6	 Click OK. 

To preserve the perspective plane information in an image, save your document in PSD, TIFF, or JPEG format. 

See also 

“Keys for using Vanishing Point” on page 762 

“To create a brush and set painting options” on page 475 

To define and adjust perspective planes in Vanishing Point 
Vanishing Point lets you define rectangular planes that line up with the perspective in an image. The accuracy of the 

plane determines whether any edits or adjustments are properly scaled and oriented in your image. After you 

establish the four corner nodes, you can scale, move, or reshape to fine-tune the perspective plane. Sometimes, lining 

up the bounding box and grid of the plane with a texture or pattern in your image helps you accurately match the 

image’s perspective. 

1 With an image open in Photoshop, choose Filter > Vanishing Point. 

2 Select the Create Plane tool  and click in the preview image to add the corner node. Try to use a rectangular 

object or a plane area in the image as a guide when creating the perspective plane. To help with node placement, hold 

down the “x” key to zoom into the preview image. 

Note: As you add corner nodes, you can delete the last node if it’s not correct by pressing the Backspace key (Windows) 

or Delete key (Mac OS). 

3	 Select the Edit Plane tool  and do one or more of the following: 

•	 To reshape the perspective plane, drag a corner node. 

•	 To adjust the grid, enter a value in the Grid Size text box or click the down arrow and move the slider. You can also 

adjust the grid size when the Create Plane tool is selected. 

•	 To move the plane, click inside the plane and drag. 

•	 To scale the plane, drag an edge node in a segment of the bounding box. 
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Dragging an edge node to increase the size of a plane to accommodate your edits

Note: The bounding box and grid of a perspective plane is normally blue. If there’s a problem with the placement of the

corner nodes, the plane is invalid, and the bounding box and grid turn either red (severe problems resolving the plane’s

aspect ratio) or yellow (problems resolving the vanishing points of the perspective plane). When your plane is invalid,

move the corner nodes until the bounding box and grid are blue.

4 (Optional) To tear off a perpendicular plane, select the Create Plane or Edit Plane tool and Ctrl-drag (Windows)

or Command-drag (Mac OS) an edge node along the bounding box.

You can create as many planes as you want. To paint, clone, or transform and maintain a consistent scale and orien-

tation, it’s best to tear off additional planes rather than create unrelated planes. If a newly created plane does not

properly line up with the image, select the Edit Plane tool and move a corner node to adjust the plane. Adjustments

made to connected planes are constrained; when you adjust one plane, all the connected planes are affected.

Tearing off multiple planes keeps the planes related to each other so your edits are scaled and oriented in the proper perspective.

If you have overlapping planes, Ctrl-click (Windows) or Command-click (Mac OS) to cycle through the overlapping

planes.

Overlapping planes

See also

“Bounding box and grid alerts in Vanishing Point” on page 382

1

2 3

4

1

2

 



ADOBE PHOTOSHOP CS2
User Guide

380

Vanishing Point tools
Vanishing Point tools behave like their counterparts in the main Photoshop toolbox. You can use the same keyboard

shortcuts for setting tool options. Selecting a tool changes the available options in the Vanishing Point dialog box.

Edit Plane tool Selects, edits, moves, and resizes planes.

Create Plane tool Defines the four corner nodes of a plane and also adjusts the size and shape of the plane. Ctrl-

drag (Windows) or Command-drag (Mac OS) an edge node to tear off a perpendicular plane.

Marquee tool Makes square or rectangular selections. Drag in the preview image to create a selection. Alt-drag

(Windows) or Option-drag (Mac OS) a selection to tear off a copy of the selection. Ctrl-drag (Windows) or

Command-drag (Mac OS) a selection to fill the selection with a source image. Specify a value for Feather to blur the

edges of the selection. Specifying the Opacity determines to what degree the selection obscures or reveals the image

beneath it. Use the Healing menu to choose a blending mode: choose Off so the selection doesn’t blend with the

colors, shadows, and textures of the surrounding pixels; choose Luminance to blend the selection with the lighting

of the surrounding pixels; or choose On to blend the selection with the color, lighting, and shading of surrounding

pixels. Use the Move Mode menu to determine the behavior when you move a selection. Select Destination to select

the area you move the selection marquee to. Select Source to fill an area with a source image that you move the

selection marquee to (same as Ctrl-dragging or Command-dragging a selection). See also “To use the marquee tools”

on page 316.

Ctrl-dragging (Windows) or Command-dragging (Mac OS) a selection
A. Original selection B. Moving the selection to the source image C. The source image fills the original selection

Double-clicking the Marquee tool in a plane selects the entire plane.

Stamp tool Paints with a sample of the image. Alt-click (Windows) or Option-click (Mac OS) to establish a

sampling point and then drag in the image to paint with the Stamp tool. Each stroke paints on more of the sample.

You can customize the brush tip by entering values for the brush size (Diameter) and the size of the tool’s hard center

(Hardness). Specifying the Opacity determines to what degree the selection obscures or reveals the image beneath it.

Similar to the Clone Stamp tool, the Vanishing Point Stamp tool lets you paint strokes using blending modes and

specifying an Opacity. Use the Healing menu to choose a blending mode: choose Off to prevent the strokes from

blending with the colors, shadows, and textures of the surrounding pixels; choose Luminance to blend the strokes

A

C

B
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with the lighting of the surrounding pixels; or choose On to blend the strokes with the color, lighting, and shading 

of surrounding pixels. Select the Aligned option to sample pixels continuously without losing the current sampling 

point, even if you release the mouse. Deselect the Aligned option to continue using the sampled pixels from the initial 

sampling point each time you stop and resume painting. See also “To use the Stamp tool in Vanishing Point” on 

page 383 and “To use the Clone Stamp tool” on page 366. 

Brush tool Paints a selected color on the image. Double-click the Brush Color swatch to open the Adobe Color 

Picker and select a color, or select the Eyedropper tool and click in the preview image to specify a brush color. Drag 

in the image to paint. Shift-drag to constrain the stroke to a straight line. You can customize the brush tip by entering 

values for the brush size (Diameter) and the size of the tool’s hard center (Hardness). Specifying the Opacity deter

mines to what degree the  selection obscures or reveals  the image  beneath it.  To  paint with a blending mode,  use the  

Healing menu: choose Off to prevent the strokes from blending with the colors, shadows, and textures of the 

surrounding pixels; choose Luminance to blend the strokes with the lighting of the surrounding pixels; or choose On 

to blend the strokes with the color, lighting, and shading of surrounding pixels. 

The Brush tool honors marquee selections and can be used to paint a hard line along edge of the selection. For 

example, if you select an entire plane, you can paint a line along the perimeter of the plane. 

Transform tool Scales, rotates, and moves a floating selection by moving the bounding box handles. Its behavior 

is similar to using the Free Transform command on a rectangle selection. You can also flip a floating selection 

horizontally along the vertical axis of the plane or flop a floating selection vertically along the horizontal axis of the 

plane. Alt-drag (Windows) or Option-drag (Mac OS) a floating selection to tear off a copy of the selection. Ctrl-drag 

(Windows) or Command-drag (Mac OS) a selection to fill the selection with a source image. See also “To transform 

freely” on page 363. 

A B C 

Transform tool options 
A. Original selection B. Flip C. Flop 

Eyedropper tool Selects a color for painting when you click in the preview image. Click the Brush Color box to 

open the Adobe Color Picker. 

Zoom tool Magnifies the view of the image in the preview window. Click or click-drag to zoom in. Alt-click/drag 

(Windows) or Option-click/drag (Mac OS) to reduce the view of the image in the preview window. 

Hand tool Moves the image in the preview window. Drag in the window to move the view. 

See also 

“Keys for using Vanishing Point” on page 762 

“About the Adobe Color Picker” on page 241 
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To adjust viewing options in Vanishing Point 
❖ Do any of the following: 

•	 To  magnify or reduce the  preview image, select the  Zoom  tool  in  the Vanishing  Point dialog box, and  click or  

drag in the preview image to zoom in; hold down Alt (Windows) or Option (Mac OS), and click or drag in the 

preview image to zoom out. You can also specify a magnification level in the Zoom text box at the bottom of the 

dialog box, or click the Zoom Out  or the Zoom In  buttons. 

•	 To move the image in the preview window, select the Hand tool in the Vanishing Point dialog box, and drag in the 

preview image. Alternatively, hold down the spacebar with any tool selected, and drag in the preview image. 

•	 To show or hide the grid and boundaries of a perspective plane, select or deselect Show Edges. 

•	 To  adjust  the size of the  perspective plane  grid, select the  Edit  Plane  or the  Create  Plane  tool,  and then either  

enter a pixel value in the Grid Size text box or click the down arrow and move the slider. 

•	 To temporarily zoom into the preview image, hold down the “x” key. This is especially helpful for placing the 

corner nodes when defining a plane, and for working on details. 

Bounding box and grid alerts in Vanishing Point 
The bounding box and grid change colors to indicate the plane’s current condition. If your plane is invalid, move a 

corner node until the bounding box and grid are blue. 

Blue Indicates a valid plane. Keep in mind that a valid plane doesn’t guarantee results with the proper perspective. 

You must make sure that the bounding box and grid accurately line up with geometric elements or a plane area in 

the image. 

Red Indicates an invalid  plane.  Vanishing Point  cannot  calculate the  plane’s aspect ratio. You  won’t be able to tear off  

a perpendicular plane from a red invalid plane. Although it’s possible to make edits in a (red) invalid plane, the results 

will not be oriented properly. 

Yellow Indicates an invalid plane. All the vanishing points of the plane cannot be resolved. Although it’s possible to 

tear off a perpendicular plane or make edits in a yellow invalid plane, the results will not be oriented properly. 

To paste an item into Vanishing Point 
You can  paste an item from the  clipboard in Vanishing  Point.  The copied item can  be  from  the same document or a  

different  one.  Once  pasted  into  Vanishing Point, the  item  becomes a floating  selection that you  can scale, rotate,  move  

or clone. When the floating selection moves into a selected plane, it conforms to the plane’s perspective. 

A 

B	 C 

Pasting an item into Vanishing Point 
A. Copied pattern from a separate document B. Image with selection to confine results C. Pasted pattern moved into plane 
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For convenience, it’s recommended that you create perspective planes in a previous Vanishing Point session. 

1 Copy an item to the clipboard. The copied item can be from the same or different document. Keep in mind that 

you can paste only a raster (not vector) item. 

Note: If you’re copying type, select the entire text layer and then copy to the clipboard. You’ll be pasting a rasterized 

version of the type into Vanishing Point. 

2 (Optional) Create a new layer.


3 Choose Filter > Vanishing Point.


4 If necessary, create one or more planes in the image.


5 Paste the item. The item is now a floating selection in the preview image. By default, the Marquee tool is selected.


Important: After pasting the image in Vanishing Point, do not immediately use the Marquee tool to select a perspective 

plane. This deselects the pasted image so that it’s no longer a floating selection. 

To use the Stamp tool in Vanishing Point 
In  Vanishing Point, the  Stamp tool paints with sampled  pixels. The  cloned  image is oriented to the  perspective of the 


plane you’re painting in. The Stamp tool is useful for such tasks as blending and retouching image areas, cloning


portions of a surface to “paint out” an object, or cloning an image area to duplicate an object or extend a texture or


pattern.


1 With an image containing perspective planes open in Vanishing Point, select the Stamp tool


2 In the tool options area, set brush options for Diameter, Hardness, and Opacity.


3 Choose a Healing mode:


. 

•	 To paint without blending with the color, lighting, and shading of the surrounding pixels, choose Off. 

•	 To paint and blend the strokes with the lighting of the surrounding pixels while retaining the color of the sampled 

pixels, choose Luminance. 

•	 To paint and maintain the texture of the sampled image while blending with the colors, lighting, and shading of 

the surrounding pixels, choose On. 

4 Select Aligned to sample pixels continuously, without losing the current sampling point even when you release the 

mouse button. Deselect Aligned to continue using the sampled pixels from the initial sampling point each time you 

stop and resume painting. 

5	 Move the pointer into a plane and Alt-click (Windows) or Option-click (Mac OS) to set the sampling point. 

6	 Drag over the area of the image you want to paint. 

Using the Liquify filter 

The Liquify filter 
The Liquify filter lets you push, pull, rotate, reflect, pucker, and bloat any area of an image. The distortions you create 

can be subtle or drastic, which makes the Liquify command a powerful tool for retouching images as well as creating 

artistic effects. The Liquify filter can be applied to 8-bits-per-channel or 16-bits per-channel images. 
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Distorting an image using the Liquify filter 

Tools, options, and an image preview for the Liquify filter are available in the Liquify dialog box. To display the dialog 

box, choose Filter > Liquify. 

CBA 

Liquify dialog box 
A. Toolbox B. Preview image C. Options 
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To adjust viewing options in the Liquify dialog box 
❖ Do the following: 

•	 To magnify or reduce the preview image, select the Zoom tool in the Liquify dialog box, and click or drag in the 

preview image to zoom in; hold down Alt (Windows) or Option (Mac OS), and click or drag in the preview image 

to zoom out. Alternatively, you can specify a magnification level in the Zoom text box at the bottom of the dialog 

box. 

•	 To navigate in the preview image, select the Hand tool in the Liquify dialog box, and drag in the preview image. 

Alternatively, hold down the spacebar with any tool selected, and drag in the preview image. 

Distortion tools 
Several tools in the Liquify dialog box distort the brush area when you hold down the mouse button or drag. The 

distortion is concentrated at the center of the brush area, and the effect intensifies as you hold down the mouse 

button or repeatedly drag over an area. 

Forward Warp tool Pushes pixels forward as you drag. 

Shift-click  with  the Warp tool,  the Push Left tool,  or  the Mirror tool to create the  effect  of  dragging  in  a straight line  

from the previous point you clicked. 

Twirl Clockwise tool Rotates pixels clockwise as you hold down the mouse button or drag. To twirl pixels 

counterclockwise, hold down Alt (Windows) or Option (Mac OS) as you hold down the mouse button or drag. 

Pucker tool Moves pixels toward the center of the brush area as you hold down the mouse button or drag. 

Bloat tool Moves pixels away from the center of the brush area as you hold down the mouse button or drag. 

Push Left tool Moves pixels to the left when you drag the tool straight up (pixels move to the right if you drag 

down). You can also drag clockwise around an object to increase its size, or drag counterclockwise to decrease its size. 

To push pixels right when you drag straight up (or to move pixels left when you drag down), hold down Alt 

(Windows) or Option (Mac OS) as you drag. 

Mirror tool Copies pixels to the brush area. Drag to mirror the area perpendicular to the direction of the stroke 

(to the left of the stroke). Alt-drag (Windows) or Option-drag (Mac OS) to mirror the area in the direction opposite 

to that of the stroke (for example, the area above a downward stroke). Usually, Alt-dragging or Option-dragging gives 

better results when you have frozen the area you want to reflect. Use overlapping strokes to create an effect similar 

to a reflection in water. 

Turbulence tool Smoothly scrambles pixels. It is useful for creating fire, clouds, waves, and similar effects. 

Liquify tool options 
In the tool options area of the dialog box, set the following options: 

Brush Size Sets the width of the brush you’ll use to distort the image. 

Brush Pressure Sets the speed at which distortions are made when you drag a tool in the preview image. Using a 

low brush pressure makes changes occur more slowly, so it’s easier to stop them at exactly the right moment. 

Brush Rate Sets the speed at which distortions are applied when you keep a tool (such as the Twirl tool) stationary 

in the preview image. The higher the setting, the greater the speed at which distortions are applied. 

Brush Density Controls how a brush feathers at the edge. An effect is strongest in the center of the brush and lighter 

at the edge. 
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Turbulent Jitter Control how tightly the Turbulence tool scrambles pixels. 

Reconstruct Mode Used for the Reconstruct tool, the mode you choose determines how the tool reconstructs an 

area of the preview image. 

Select Stylus Pressure (Photoshop) Uses pressure readings from a stylus tablet. (This option is available only when 

you are working with a stylus tablet.) When selected, the brush pressure for the tools is the stylus pressure multiplied 

by the Brush Pressure value. 

See also 

“Reconstructing distortions” on page 387 

To distort an image 
Note: If a type layer or a shape layer is selected, you must rasterize the layer before proceeding, making the type or shape 

editable by the Liquify filter. To distort type without rasterizing the type layer, use the Warp options for the Type tool. 

1 Select the layer you want to distort. To change only part of the current layer, select that area.


2 Choose Filter > Liquify.


3 Freeze areas of the image that you don’t want to alter.


4 Choose any of the liquify tools to distort the preview image. Drag in the preview image to distort the image.


5 After distorting the preview image, you can use the Reconstruct tool
  or other controls to fully or partially 

reverse the changes or to change the image in new ways. 

6	 Do one of the following: 

•	 Click OK to close the Liquify dialog box and apply the changes to the active layer. 

•	 Click Cancel to close the Liquify dialog box without applying changes to the layer. 

•	 Click Restore All to revert all distortions to the preview image, leaving all options in their current settings. 

•	 Hold down Alt (Windows) or Option (Mac OS) and click Reset to revert all distortions to the preview image and 

reset all options to their defaults. 

You can use the Edit > Fade command to create additional effects. 

See also 

“To blend effects” on page 513 

Freezing areas 
By freezing areas of the preview image, you protect those areas from changes. Frozen areas are covered by a mask 

that you paint using the Freeze tool . You can also use an existing mask, selection, or transparency to freeze areas. 

You can view the mask in the preview image to help you apply distortions. 
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You can use the icons’ pop-up menus in the Mask Options area of the Liquify dialog box to choose how the frozen, 

or masked, areas of the preview image work. 

Using the Freeze tool Select the Freeze tool and drag over the area you want to protect. Shift-click to freeze in 

a straight line between the current point and the previously clicked point. 

Using a selection, mask, or transparency channel Choose Selection, Layer Mask, Transparency, or Quick Mask 

from the pop-up menu of any the five options in the Mask Options area of the dialog box. 

Freezing all thawed areas Click the Mask All button in the Mask Options area of the dialog box. 

Inverting thawed and frozen areas Click Invert All in the Mask Options area of the dialog box. 

Showing or hiding frozen areas Select or deselect Show Mask in the View Options area of the dialog box. 

Changing the color of frozen areas Choose a color from the Mask Color pop-up menu in the View Options area 

of the dialog box. 

Mask options with the Liquify filter 
When you have an existing selection or mask in an image, that information is retained when the Liquify dialog box 

opens. You can choose one of the following mask options: 

Replace Selection Shows the selection, mask, or transparency in the original image. 

Add To Selection Shows the mask in the original image, so that you can add to the selection using the Freeze 

tool. Adds selected pixels in channel to the current frozen area. 

Subtract From Selection Subtracts pixels in channel from the current frozen area. 

Intersect With Selection Uses only pixels that are selected and currently frozen. 

Invert Selection Uses selected pixels to invert the current frozen area. 

To thaw areas 
❖ Do any of the following: 

•	 Select the Thaw tool , and drag over the area. Shift-click to thaw in a straight line between the current point 

and the previously clicked point. 

•	 To thaw all frozen areas, click the None button in the Mask Options area of the dialog box. 

•	 To invert frozen and thawed areas, click Invert All in the Mask Options area of the dialog box. If you used a 

selection, transparency, or alpha channel to define the frozen area, the alpha channel name in the Channel pop-up 

menu changes to Custom. 

Reconstructing distortions 
After you  distort the  preview image, you  can use  a variety  of  controls  and reconstruction modes  to  reverse changes  

or redo the changes in new ways. Reconstructions can be applied two ways. You can apply a reconstruction to the 

entire image, smoothing out the distortion in unfrozen areas, or you can use the reconstruction tool to reconstruct 

specific areas. You can use the Freeze tool to prevent reconstruction of distorted areas. 
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C D 

Reconstruction based on distortions in frozen areas. 
A. Original image B. Distorted with frozen areas C. Reconstructed in Rigid mode (using button) D. Thawed, edges reconstructed in 
Smooth mode (using tool) 

To reconstruct an entire image 
1 Select a reconstruction mode from the Reconstruct Options area of the dialog box. 

2 Press the Reconstruct button in the Reconstruction Options area to apply the effect once. You can apply the recon

struction more than once to create a less distorted appearance. 

To remove all distortions 
❖ Click the Restore All button in the Reconstruct Option area of the dialog box. This removes distortions even in 

frozen areas. 

To reconstruct part of a distorted image 
1 Freeze areas you want to keep distorted. 

2 Select the Reconstruct tool . Choose one of these Reconstruct tool modes from the Brush Options area of the 

dialog box. 

3 Hold down the mouse button or drag over the area. Pixels move more quickly at the brush center. Shift-click to 

reconstruct in a straight line between the current point and the previously clicked point. 

To repeat distortions sampled from a starting point 
1 After distorting the preview image, choose one of these reconstruction modes from the Mode menu in the Tool 

Options area of the dialog box. 

2 Select the Reconstruct tool , and in the preview image, hold down the mouse button or drag from a starting 

point. 

This creates a copy of the distortion sampled at the starting point, much as the Clone tool does when you use it to 

paint a copy of an area. If there is no distortion, the effect is the same as using Revert mode. You can set new starting 

points and use the Reconstruct tool repeatedly to create a variety of effects. 
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Reconstruction modes 
You can choose one of the following reconstruction modes: 

Rigid Maintains right angles in the pixel grid (as shown by the mesh) at the edges between frozen and unfrozen 

areas, sometimes producing near-discontinuities at the edges. This restores the unfrozen areas so that they approx

imate their original appearance. (To restore their original appearance, use Revert reconstruction mode.) 

Stiff Acts  like  a weak magnetic field. At the  edges between  frozen  and unfrozen areas, the  unfrozen  areas take on the  

distortions of the frozen areas. As the distance from frozen areas increases, the distortions lessen. 

Smooth Propagates the distortions in frozen areas throughout unfrozen areas, with smoothly continuous distor

tions. 

Loose Produces effects similar to Smooth, with even greater continuity between distortions in frozen and unfrozen 

areas. 

Revert Scales back distortions uniformly without any kind of smoothing. 

Reconstruct tool modes 
The Reconstruct tool has three modes that use the distortion at the point where you first clicked the tool (start point) 

to reconstruct the area over which you use the tool. Every time you click, you set a new start point; so, if you want to 

extend an effect from one start point, don’t release the mouse button until you finish using the Reconstruct tool. 

Displace Reconstructs unfrozen areas to match the displacement at the start point for the reconstruction. You can 

use Displace to move all  or  part  of  the preview  image to a different  location. If you  click and  gradually spiral out  from  

the start point, you displace or move a portion of the image to the area you brush over. 

Amplitwist Reconstructs unfrozen areas to match the displacement, rotation, and overall scaling that exist at the 

start point. 

Affine Reconstructs unfrozen areas to match all distortions that exist at the start point, including displacement, 

rotation, horizontal and vertical scaling, and skew. 

Working with meshes 
Using a mesh  helps you  see and  keep  track of distortions. You  can choose the  size  and color  of  a mesh,  and save the  

mesh from one image and apply it to other images. 

•	 To add a mesh, select Show Mesh in the View Options area of the dialog box, and choose a mesh size, mesh color, 

and freeze color. 

•	 To show a mesh, select Show Mesh. When Show Mesh is selected, you can show or hide the preview image. Select 

Show Image in the View Options area of the dialog box to show the preview image; deselect Show Image to view 

only the mesh. 

•	 To save a distortion mesh, after distorting the preview image, click Save Mesh. Specify a name and location for the 

mesh file, and click Save. 

•	 To apply a distortion mesh, click Load Mesh, select the mesh file you want to apply, and click Open. If the image 

and distortion mesh aren’t the same size, the mesh is scaled to fit the image. 
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Working with backdrops 
You can choose to show only the active layer in the preview image, or you can show additional layers in the preview 

image as a backdrop. Using the Mode options, you can position the backdrop in front of or behind the active layer to 

keep track of your changes, or to line up a distortion with another distortion made in a different layer. 

Important: Only the active layer is distorted, even if other layers are displayed. 

Showing the backdrop Select Show Backdrop, and then choose an option from the Use pop-up menu. If you use 

All Layers, changes to the current target layer are not reflected in the backdrop layer. Specify an overlay opacity to 

change the blending between the target layer and the backdrop. The mode determines how the backdrop and the 

target layer are combined for the preview. Choose an option from the Mode pop-up menu. 

Hiding the backdrop Deselect Show Backdrop in the View Options area of the dialog box. 

Creating panoramic images using Photomerge 

About Photomerge 
The Photomerge™ command combines several photographs into one continuous image. For example, you can take 

five  overlapping photographs  of  a city skyline,  and then assemble them into a panorama. The  Photomerge  command  

can assemble photos that are tiled horizontally as well as vertically. 

Note: Photomerge converts 16-bits-per-channel and 32-bits-per-channel images to 8-bits-per-channel images. 

Source images (top), and completed Photomerge composition (bottom) 

To open Photomerge compositions, choose File > Automate > Photomerge and then click the Open Composition 

button. Choose the composition you want to open. 

Taking pictures for use with Photomerge 
Your source photographs play a large role in panoramic compositions. To avoid problems, follow these guidelines 

when taking pictures for use with Photomerge: 

Overlap images sufficiently Images should overlap by approximately 25% to 40%. If the overlap is less, Photomerge 

may not be able to automatically assemble the panorama. However, keep in mind that the images shouldn’t overlap 

too much. If images overlap by 70% or more, it can be difficult to work with them, and blending may not be as 

effective. Try to keep the individual photos at least somewhat distinct from each other. 

Use a consistent focal length Avoid using the zoom feature of your camera while taking your pictures. 
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Keep the camera level Although Photomerge can process slight rotations between pictures, a tilt of more than a few 

degrees can result in errors when the panorama is assembled. Using a tripod with a rotating head helps maintain 

camera alignment and viewpoint. 

When photographing a panoramic scene from a high place, the natural inclination is to keep the horizon level in the 

viewfinder. However, this actually produces a noticeable rotation between images. Try using a tripod to keep the 

camera level when taking photographs in this situation. 

Stay in the same position Try not to change your position as you take a series of photographs, so that the pictures 

are from the same viewpoint. Using the optical viewfinder with the camera held close to the eye helps keep the 

viewpoint consistent. Or try using a tripod to keep the camera in the same place. 

Avoid using distortion lenses Fish-eye and other distortion lenses can interfere with Photomerge. 

Maintain the same exposure Avoid using the flash in some pictures and not in others. The advanced blending 

feature in Photomerge helps smooth out different exposures, but extreme differences make alignment difficult. Some 

digital cameras change exposure settings automatically as you take pictures, so you may need to check your camera 

settings to be sure that all the images have the same exposure. 

Using the Photomerge dialog box 
The Photomerge dialog box contains tools for manipulating the composition, a lightbox for storing source images 

that are not in use, a work area for assembling the composition, and options for viewing and editing the composition. 

You can also zoom in and out to check the alignment of each file. 

A B 

D 

E 

Photomerge dialog box 
A. Lightbox B. Navigator view box C. Toolbox D. Work area E. Status bar 

Navigating in the Photomerge dialog box Do one or more of the following in the Photomerge dialog box: 

•	 Select the Hand tool and drag in the work area to move the view. 

•	 Drag the view box or the scroll bars in the Navigator thumbnail. The view box represents the boundaries of the 

work area. 

Zooming in the Photomerge dialog box Do one of the following: 

•	 Click the Zoom In icon  below the Navigator. 

•	 Use the Zoom tool  to zoom in. 

 



ADOBE PHOTOSHOP CS2
User Guide

392

• Click the Zoom Out icon  below the Navigator.

Using the lightbox You can use the lightbox to rearrange images in the Photomerge composition. To use the

lightbox, select the Select Image tool , and then do one or more of the following:

• Drag an image from the lightbox to the work area to add it to the composition.

• Drag an image from the work area to the lightbox to remove it from the composition.

• Double-click an image in the lightbox to add it to the composition.

Make sure Snap To Image is selected to automatically snap overlapping images into place when a commonality is

detected.

Rotating images Select the Select Image tool , and click the image you want to rotate. Select the Rotate tool ,

and then click near the edge of the image and drag in a circular motion around the center of the image.

To create a Photomerge composition
When you set up a Photomerge composition, you identify your source files, and the panorama is automatically

assembled. After the panorama is assembled, you can fine-tune the placement of the individual photos, if necessary.

1 Do one of the following:

• Choose File > Automate > Photomerge.

• In Adobe Bridge, choose Tools > Photoshop > Photomerge from the Bridge menu bar. Skip to step 5.

Note: In Bridge, choosing the Photomerge command uses all images currently displayed in Bridge. If you only want

specific images used, select them before choosing the Photomerge command.

2 In the Photomerge dialog box, choose an option from the Use pop-up menu:

Files Generates the Photomerge composition using individual files.

Folders Uses all the images stored in a folder to create the Photomerge composition. The files in the folder appear

in the dialog box.

Open Files Uses the image files you have open in Photoshop.

3 Click the Browse button to navigate to the source files or folder you want to use to create the Photomerge compo-

sition. Select Attempt To Automatically Arrange Source Images if you want Photoshop to try to line the images up

in their proper order. Deselect this option if you want to arrange the images in the lightbox yourself.

You can add more files by clicking the Browse button again and navigating to the source files. You can always remove

a file from the Source Files list by selecting the file and clicking the Remove button.

4 When you’ve added all the source files, click OK to create the Photomerge composition. The source files are

opened and assembled automatically. Sixteen-bits-per-channel images and 32-bits-per-channel are converted to

8-bits-per-channel images.

If the composition can’t be automatically assembled, a message appears on-screen. You can assemble the composition

manually in the Photomerge dialog box using the lightbox.

5 When the new panorama appears in the Photomerge dialog box, you can work with individual source files and

change your view of the work area. If you need to rearrange the order of the images, drag an image in the work area

to reposition it, or rearrange the images in the lightbox.

6 If necessary, adjust the vanishing point or blending settings of your composition.
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7 If you want to save each image in the composition in individual layers, select Keep as Layers. (This is useful if you 

need to correct the color of each image separately.) 

8 Do one of the following: 

• Click the OK button to generate the panorama as a new Photoshop file. The composition then opens in Photoshop. 

• Click the Save Composition As button to save the composition and open it again at a later time. 

See also 

“To run automated tasks with Bridge” on page 94 

Changing Photomerge composition settings 
Photomerge settings determine how source images appear in the Photomerge dialog box. Photoshop lets you adjust 

perspective and blend exposure differences to produce the best possible effect. 

The Vanishing Point tool selects the vanishing point image, which changes the perspective of the composition. By 

default,  the middle image  contains  the vanishing  point (it  has a blue  border  around  it  when  selected).  There can  only  

be one vanishing point. 

The Cylindrical Mapping and Advanced Blending options are used to process  the final  image.  The results  of  applying  

these options are visible only in Preview mode or in the final, generated image. 

To change the vanishing point of a composition 
1 Select Perspective in the Settings area of the Photomerge dialog box. 

2 Select the Vanishing Point tool , and click an image in the work area to place the vanishing point there. 

3 If necessary, use the Select Image tool  to adjust the position of the remaining images. A red border indicates 

that the selected image does not contain the vanishing point. 

When you apply perspective correction to a composition, the images without the vanishing point are linked to the 

image that contains the vanishing point. You can break this link by clicking the Normal button, by separating the 

images in the work area, or by dragging the image with the vanishing point back to the lightbox. When the link is 

broken, images return to their original shapes. 

The perspective correction works only up to a 120˚ angle of view, approximately. For a wider angle of view, deselect 

the Perspective option. 

To change the perspective of a composition, select the Vanishing Point tool, and click an image in the work area. 

Notice how the perspective of the composition changes according to which image contains the vanishing point. 
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To apply Advanced Blending or Cylindrical Mapping 
1 Select Composition options as desired: 

Cylindrical Mapping Reduces the “bow-tie” distortion that can occur when you apply perspective correction. You 

must select the Perspective option in order to apply cylindrical mapping. 

A 

B 

Adding Cylindrical Mapping 
A. Original B. Cylindrical Mapping applied 

Advanced Blending Minimizes color inconsistencies that result from blending images with exposure differences. 

When this option is selected, broad colors and tones are blended over a large area, while detailed colors and tones are 

blended over a smaller area. 

2 Click Preview. To return to edit mode, click Exit Preview. 
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Chapter 14: Layers


Layer Basics 

About layers 
Layers allow you to work on one element of an image without disturbing the others. Think of layers as sheets of 

acetate stacked one on top of the other. You can see through transparent areas of a layer to the layers below. You can 

change the composition of an image by changing the order and attributes of layers. In addition, special features such 

as adjustment layers, fill layers, and layer styles let you create sophisticated effects. 

Transparent areas on a layer let you see through to the layers below. 

A new image in Photoshop or ImageReady has a single layer. The number of additional layers, layer effects, and layer 

sets you can add to an image is limited only by your computer’s memory. 

Layer groups help you organize and manage layers. You can use groups to arrange your layers in a logical order and 

to reduce clutter in the Layers palette. You can nest groups within other groups. You can also use groups to apply 

attributes and masks to multiple layers simultaneously. 

About the Layers palette 
The Layers palette lists all layers, groups, and layer effects in an image. You can use the Layers palette to show and 

hide layers, create new layers, and work with groups of layers. You can access additional commands and options in 

the Layers palette menu. 
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A 

B 

C 

D 

F 

E 

Photoshop Layers palette 
A. Layers palette menu B. Group C. Layer D. Expand/Collapse Layer effects E. Layer effect F. Layer thumbnail 

•	 To display the Layers palette, choose Window > Layers. 

•	 To use the Layers palette menu, click the triangle in the upper right corner of the palette. It contains commands 

for working with layers. 

•	 To change the size of layer thumbnails, choose Palette Options from the Layers palette menu, and select a 

thumbnail size. 

•	 To change thumbnail contents, choose Palette Options from the Layers palette menu and select Entire Document 

to display the contents of the entire document. Select Layer Bounds to restrict the thumbnail to the object’s pixels 

on  the layer. Select the  Show  Group Thumbnails box  to  show  a composite  image of the  group rather than the  group  

icon. 

Turn off thumbnails to improve performance and save monitor space. 

•	 To expand and collapse groups (and layer sets in ImageReady), click the triangle to the left of a group folder. See 

“To view layers and groups within a group” on page 398. 

About the background layer 
When you create a new image with a white background or a colored background, the bottommost image in the 

Layers palette is called Background. An image can have only one background. You cannot change the stacking 

order of a background, its blending mode, or its opacity. However, you can convert a background to a regular layer. 

When you create a new image with transparent content, the image does not have a background layer. The 

bottommost layer is not constrained like the background layer; you can move it anywhere in the Layers palette, and 

change its opacity and blending mode. 

To convert a background into a layer 
1 Double-click Background in the Layers palette, or choose Layer > New > Layer From Background. 

2	 Set layer options. (See “To create a new layer or group” on page 397.) 

3	 Click OK. 
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To convert a layer into a background

1 Select a layer in the Layers palette.


2 Choose Layer > New > Background From Layer.


Any transparent pixels in the layer are converted to the background color.


Note: You cannot create a background by giving a regular layer the name Background—you must use the Background 

From Layer command. 

To create a new layer or group 
A new layer appears either above the selected layer or within the selected group in the Layers palette. 

1	 Do one of the following: 

•	 To create a new layer or group using default options, click the New Layer button or New Group button in 

the Layers palette. 

•	 Choose Layer > New > Layer or choose Layer > New > Group. 

•	 Choose New Layer or New Group from the Layers palette menu. 

•	 Alt-click (Windows) or Option-click (Mac OS) the New Layer button or New Group button in the Layers palette 

to display the New Layer dialog box and set layer options. 

•	 Ctrl-click (Windows) or Command-click (Mac OS) the New Layer button or New Group button in the Layers 

palette to add a layer below the currently selected layer. 

2 Set layer options, and click OK: 

Name Specifies a name for the layer or group. 

Use Layer Below To Create Clipping Mask This option is not available for groups. (See “To create a clipping mask” 

on page 437.) 

Color Assigns a color to the layer or group in the Layers palette. 

Mode Specifies a blending mode for the layer or group. (See “About blending modes” on page 410.) 

Opacity Specifies an opacity level for the layer or group. 

(Photoshop) Fill With Mode-Neutral Color Fills the layer with a preset, neutral color. 

To create a new layer with the same effects as an existing layer 
1 Select the existing layer in the Layers palette. 

2 Drag the layer to the New Layer button at the bottom of the Layers palette. The newly created layer contains all 

the effects of the existing one. 

To convert a selection into a new layer

1 Make a selection.


2 Do one of the following:


•	 Choose Layer > New > Layer Via Copy to copy the selection into a new layer. 

•	 Choose Layer > New > Layer Via Cut to cut the selection and paste it into a new layer. 
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To show or hide a layer, group, or style 
❖ Do one of the following: 

•	 In the Layers palette, click the eye icon next to a layer, group, or layer effect to hide its content in the document 

window. Click in the column again to redisplay the content. 

•	 Alt-click (Windows) or Option-click (Mac OS) an eye icon to display only the content for that layer or group. 

Photoshop remembers the visibility states of all layers before hiding them. If you don’t change the visibility of any 

other layer, Alt-clicking (Windows) or Option-clicking (Mac OS) in the eye column again restores the original 

visibility settings. 

•	 Drag through the eye column to change the visibility of multiple items in the Layers palette. 

Note: Only visible layers are printed. 

To view layers and groups within a group

1 Click the group in the Layers palette.


2 To open the group, do one of the following:


•	 Click the triangle to the left of the folder icon. 

•	 Right-click (Windows) or Control-click (Mac OS) the triangle to the left of the folder icon and choose Open This 

Group. 

•	 Alt-click (Windows) or Option-click (Mac OS) the triangle to open or close a group and the groups nested within 

it. 

To sample from all visible layers 
The default behavior of the Magic Wand, Smudge, Blur, Sharpen, Paint Bucket, Clone Stamp, and Healing Brush 

tools is to sample color  only  from  pixels  on  the active layer. This means  you can  smudge  or  sample  in  a single layer.  

❖ To smudge or sample pixels from all visible layers with these tools, select Use All Layers in the options bar. 

To change transparency preferences 
1 Do one of the following: 

•	 (Photoshop) In Windows, choose Edit > Preferences > Transparency & Gamut; in Mac OS, choose Photoshop > 

Preferences > Transparency & Gamut. 

•	 (ImageReady) In Windows, choose Edit > Preference > Transparency; in Mac OS, choose ImageReady > 

Preferences > Transparency. 

2 Choose a size and color for the transparency checkerboard, or choose None for Grid Size to hide the transparency 

checkerboard. 

3 (Photoshop) Select Use Video Alpha to enable Photoshop to send transparency information to your computer’s 

video board. This option requires hardware support—make sure that your computer’s video board allows images to 

be overlaid on top of a live video signal. 

4	 click OK. 
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Unifying layers in animations and rollovers 
The unify  buttons in the  Layers  palette determine  how the  changes you  make  to  a layer  in  the active rollover state  or  

animation frame apply to the other states in a rollover or frames in an animation. When a unify button is selected, 

changes apply to all states and frames; when a button is deselected, changes apply to only the active state or frame. 

(Photoshop) To display the unify buttons, choose Animation Options from the Layers palette menu and choose an 

option. Automate (the default) displays the animation controls when the Animation palette is visible. 

See also 

“To unify layers for rollovers and animations (ImageReady)” on page 613 

Selecting, grouping, and linking layers 

Selecting layers 
You can select one or more layers to work on them. For some activities, such as painting or making color and tone 

adjustments, you can work on only one layer at a time. A single selected layer is called the active layer. The  name  of  

the active layer appears in the title bar of the document window (Photoshop). 

For other activities, such as moving, aligning, transforming, or applying styles from the Styles palette, you can select 

and work on multiple layers at a time. 

You can select layers in the Layers palette or with the Move tool. 

You can also link layers. Unlike multiple layers selected at the same time, linked layers stay linked when you change 

the selection in the Layers palette. See “To link and unlink layers” on page 401. 

If you don’t see the desired results when using a tool or applying a command, you may not have the correct layer 

selected. Check the Layers palette to make sure that you’re working on the correct layer. 

To select layers in the Layers palette 
❖ Do one of the following: 

•	 Click a layer in the Layers palette. 

•	 To select multiple contiguous layers, click the first layer and then Shift-click the last layer. 

•	 To select multiple noncontiguous layers, Ctrl-click (Windows) or Command-click (Mac OS) them in the Layers 

palette. 

•	 To select all layers, choose Select > All Layers. 

•	 (Photoshop) To select all layers of a similar type (for example all type layers), choose Select > Select Similar Layers. 

•	 To have no layer selected, click in the Layers palette below the background or bottom layer, or choose Select > 

Deselect Layers. 
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To select layers in the document window 
1 Select the Move tool . 

2 Do one of the following: 

•	 (Photoshop) In the options bar, select Auto Select Layer and click in the document on the layer content you want 

to select. The topmost layer containing pixels under the cursor is selected. 

•	 (Photoshop) In the options bar, select Auto Select Group and click in the document on the content you want to 

select. The topmost group containing pixels under the cursor is selected. If you click an ungrouped layer, it 

becomes selected. 

•	 Right-click (Windows) or Control-click (Mac OS) in the image, and choose a layer from the context menu. The 

context menu lists all the layers that contain pixels under the current pointer location. 

•	 (ImageReady) In the options bar, select the Layer Select tool . Click in the document on a single layer to select 

it, in a group to select the entire group, or in a layer in a set to select only that layer. Note that you can’t select locked 

layers with this tool. 

•	 (ImageReady) In the options bar, select the Direct Select tool 

set to select the individual layer. 

To select a layer in a group 
1	 Click the group in the Layers palette. 

•	 Click the triangle to the left of the folder icon 

2 To open the group, do one of the following: 

. 

. Click in the document on a layer within a layer 

•	 Right-click (Windows) or Ctrl-click (Mac OS) the triangle to the left of the folder icon and choose Open This 

Group from the pop-up menu. (You can choose Open Other Groups to open groups that are not selected.) 

3	 Click the individual layer in the group. 

To group and ungroup layers 
1 Select multiple layers in the Layers palette. 

2 Do one of the following: 

•	 Choose Layer > Group Layers. 

•	 Alt-drag (Windows) or Option-drag (Mac OS) layers to the folder icon at the bottom of the Layers palette to group 

the layers. 

3	 To Ungroup the layers, select the group and choose Layer > Ungroup Layers. 

To add layers to a group 
❖ Do one of the following: 

•	 Select the group in the Layers palette and click the New Layer button . 

•	 Drag a layer to the group folder. 

•	 Drag a group folder into another group folder. The group and all of its layers move. 

•	 Drag an existing group to the New Group button . 
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To link and unlink layers 
You can link two or more layers or groups. Unlike multiple layers selected at the same time, linked layers retain their 

relationship until you unlink them. You can move, apply transformations, and create clipping masks from linked 

layers. 

1 Select the layers or groups in the Layers palette. 

2 Do one of the following: 

•	 Click the link icon  at the bottom of the Layers palette (Photoshop) or next to the layer (ImageReady). 

• (ImageReady) Choose Link Layers from the Layers palette menu. 

3 To unlink layers do one of the following: 

•	 Select a linked layer and click the link icon. 

•	 (Photoshop) To temporarily disable the linked layer, Shift-click the Link icon for the linked layer. A red X appears. 

Shift-click the link icon to enable the link again. 

•	 Select the linked layers and click the Link icon. To select all linked layers, select one of the layers and then choose 

Layer > Select Linked Layers. 

Working with groups and sets in ImageReady 
Layers you group in Photoshop become layer sets when you open the image in ImageReady. Layer sets you create in 

ImageReady become groups in Photoshop. The difference between groups and sets in ImageReady is the way that 

the Layer Select tool responds to a selection in the document window. In a layer set, the Layer Select tool selects 

individual layers in the set. With a group, the Layer Select tool selects the entire group when you click a layer that is 

part  of  the group. To make a layer set  into  a group, select the  layer set, choose Layer  > Layer  Set Options, and  select  

the Treat Layer Set As Group option. 

Moving, copying, and locking layers 

To change the order of layers and groups 
1 Do one of the following: 

•	 Drag the layer or group up or down in the Layers palette. Release the mouse button when the highlighted line 

appears where you want to place the layer or group. 

•	 To  move  a layer  into  a group, drag a layer to the  group folder  .  If  the group  is  closed, the  layer is placed at the  

bottom of the group. 

Note: If a group is expanded so that you can see all the layers within it, adding a layer beneath the expanded group 

automatically adds the layer to that group. To avoid this, collapse the group before adding the new layer. 

•	 Select a layer or group, choose Layer > Arrange, and choose a command from the submenu. If the selected item is 

in a group, the command applies to the stacking order within the group. If the selected item is not in a group, the 

command applies to the stacking order within the Layers palette. 

•	 To reverse the order of selected layers, choose Layer > Arrange > Reverse (Photoshop) or Layer > Reverse Layers 

(ImageReady). Note that these options appear dimmed if you do not have at least two layers selected. 

Note: By definition, the background layer is always at the bottom of the stacking order. Therefore, the Send To Back 

command places the selected item directly above the background layer. 
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Manipulating layer content 
After you select layers, you can move, transform, align, and distribute them. You can select layers in the Layers palette 

or directly in the document window. 

Showing the boundary or edges of the content in a layer can help you move and align the content. You can also 

display the transform handles for selected layers and groups so that you can resize or rotate them. 

Layer content with edges showing (left) and with transform mode selected (right) 

See also 

“To select layers in the Layers palette” on page 399 

“To select layers in the document window” on page 400 

To display the edges of content in a selected layer 
❖ Choose View > Show > Layer Edges. 

To display transform handles in a selected layer

1 Select the Move tool.


2 Do one of the following:


• (Photoshop) In the options bar, select Show Transform Controls. 

• (ImageReady) In the options bar, select Show Transform Box.


You can resize and rotate layer content using the transform handles. See “To transform freely” on page 363.


To move the content of layers

1 In the Layers palette, select the layers containing the objects you want to move.


2 Do one of the following:


• Select the Move tool in the toolbox. In the document window, drag any object on one of the selected layers. 

• Press an arrow key on the keyboard to nudge the objects by 1 pixel. 

• Hold down Shift and press an arrow key on the keyboard to nudge the objects by 10 pixels. 
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To align objects on different layers 
You can align the content of layers and groups using the Move tool. (See “Moving selections and layers within 

an image” on page 328.) 

1	 Do one of the following: 

•	 To align multiple layers, select the layers with the Move tool or in the Layers palette, or select a group. 

•	 To  align the  content of one  or  more  layers  to  a selection  border, make a  selection in the  image,  and then select the  

layers in the Layers palette. Use this method to align to any specified point in the image. 

2 Choose Layer > Align or Layer > Align Layers To Selection (Photoshop), and choose a command from the 

submenu. These same commands are available as Alignment buttons in the Move tool options bar. 

Top Edges Aligns the top pixel on the selected layers to the topmost pixel on all selected layers, or to the top edge 

of the selection border. 

Vertical Centers Aligns the vertical center pixel on each selected layers to the vertical center pixel of all the 

selected layers, or to the vertical center of the selection border. 

Bottom Edges Aligns the bottom pixel on the selected layers to the bottommost pixel on selected layers, or to 

the bottom edge of the selection border. 

Left Edges Aligns  the left pixel  on  the selected layers to the  left  pixel on the  leftmost  layer,  or  to  the left edge of  

the selection border. 

Horizontal Centers Aligns the horizontal center pixel on the selected layers to the horizontal center pixel of all 

the selected layers, or to the horizontal center of the selection border. 

Right Edges Aligns the right pixel on the linked layers to the rightmost pixel on all selected layers, or to the right 

edge of the selection border. 

To evenly distribute layers and groups 
1 Select three or more layers. 

2	 Choose Layer > Distribute and choose a command. Alternatively, select the Move tool and click a distribution

button in the options bar. 

Top Edges Spaces the layers evenly starting from the top pixel of each layer. 

Vertical Centers Spaces the layers evenly starting from the vertical center pixel of each layer. 

Bottom Edges Spaces the layers evenly starting from the bottom pixel of each layer. 

Left Edges Spaces the layers evenly starting from the left pixel of each layer. 

Horizontal Centers Spaces the layers evenly starting from the horizontal center of each layer. 

Right Edges Spaces the layers evenly starting from the right pixel on each layer. 

To distribute layers unevenly (ImageReady)

1 Select the Move tool.


2 Select the layers you wish to space.
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3 Enter a number in the text box to the right of the Distribution buttons in the options bar. This number equals the 

number of pixels that will separate the layers. You can choose different numbers for different combinations of layers 

or groups to create an uneven spacing pattern. 

4 Choose  the Distribute Layer  Vertical  Space or Distribute Layer  Horizontal  Space button to finish the  distribution  

process. 

You can specify the space between distributed layers. 

To rotate a layer

1 In the Layers palette, select the layer you want to rotate.


2 If anything is currently selected in the image, choose Select > Deselect.


3 Choose Edit > Transform > Rotate. A box defining the boundaries of the layer (called a bounding box) appears.


4 Move the pointer outside of the bounding box (the pointer becomes a curved, two-sided arrow), and then drag.


Press Shift to constrain the rotation to 15˚ increments.


5 When you’re satisfied with the results, press Enter (Windows) or Return (Mac OS), or click the check mark in the


options bar. To cancel the rotation, press Esc, or click the Cancel Transform icon on the options bar.


See also 

“Rotating and flipping entire images” on page 347 

“To scale, rotate, skew, distort, apply perspective, or warp” on page 361 

To duplicate a layer or group within an image

1 Select a layer or group in the Layers palette.


2 Do one of the following:


•	 Drag the layer or group to the New Layer button . 

•	 Choose Duplicate Layer or Duplicate Group from the Layers menu or the Layers palette menu. In Photoshop, enter 

a name for the layer or group, and click OK. 
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To duplicate a layer or group between images

1 Open the source and destination images.


2 In the Layers palette of the source image, select a layer or group.


3 Do one of the following:


•	 Drag the layer or group from the Layers palette into the destination image. 

•	 Select the Move tool , and drag from the source image to the destination image. The duplicate layer or group 

appears above the active layer in the Layers palette of the destination image. Shift-drag to move the image content 

to the same location it occupied in the source image (if the source and destination images have the same pixel 

dimensions) or to the center of the document window (if the source and destination images have different pixel 

dimensions). 

•	 (Photoshop) Choose Duplicate Layer or Duplicate Group from the Layers menu or the Layers palette menu. 

Choose the destination document from the Document pop-up menu, and click OK. 

•	 Choose Select > All to select all the pixels on the layer, and choose Edit > Copy. Then choose Edit > Paste in the 

destination image. 

To create a new document from a layer or group

1 Select a layer or group in the Layers palette.


2 Choose Duplicate Layer or Duplicate Group from the Layers menu or the Layers palette menu.


3 Choose New from the document pop-up menu, and click OK.


Locking layers 
You can lock layers fully or partially to protect their contents. For instance, you may want to lock a layer fully when 

you finish with it. You may want to lock a layer partially if it has the correct transparency and styles, but you are still 

deciding on positioning. When a layer is locked, a lock icon appears to the right of the layer name. The lock icon is 

solid when the layer is fully locked and hollow when the layer is partially locked. 

To lock all properties of a layer or group

1 Select a layer or group.


2 Do one of the following:


•	 Click the Lock All  option in the Layers palette. 

•	 (ImageReady) Choose Layer Options from the Layers palette menu, and select the Lock All option. 

Note: When a layer in a locked group has individual lock options applied to it, the lock icon is dimmed . 
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To partially lock a layer 
1 Select a layer. 

2 Click one or more lock options in the Layers palette. (In ImageReady, you can also choose Layer Options from the 

Layers palette menu.) Select one or more lock options: 

Lock Transparency Confines  editing to the  opaque  portions  of  the layer. This option is equivalent to the  Preserve  

Transparency option in earlier versions of Photoshop. 

Lock Image Prevents modification of the layer’s pixels using the painting tools. 

Lock Position Prevents the layer’s pixels from being moved. 

Note: For type layers, Lock Transparency and Lock Image are selected by default and cannot be deselected. 

To apply lock options to selected layers or a group

1 Select multiple layers or a group.


2 Choose Lock Layers or Lock All Layers In Group from the Layers menu or the Layers palette menu.


3 Select lock options, and click OK.


Managing layers 

To rename a layer or group 
As you add layers to an image, it’s helpful to give them names that reflect their content. Descriptive names make 

layers easy to identify in the palette. 

❖ Do one of the following: 

•	 Double-click the layer or group name in the Layers palette, and enter a new name. 

•	 Press Alt (Windows) or Option (Mac OS), and double-click the layer (not its name or thumbnail) in the Layers 

palette. Enter a new name in the Name text box, and click OK. 

•	 (Photoshop) Select a layer or group, and choose Layer Properties or Group Properties from the Layers menu or 

the Layers palette menu. Enter a new name in the Name text box, and click OK. 

•	 (ImageReady) Select a layer or set, and choose Layer Options or Layer Set Options from the Layers menu or the 

Layers palette menu. Enter a new name in the Name text box, and click OK. 
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To assign a color to a layer or group 
Color-coding layers and groups helps you locate related layers in the Layers palette. 

1	 Do one of the following: 

•	 (Photoshop) Select a layer or group, and choose Layer Properties or Group Properties from the Layers menu or 

the Layers palette menu. 

•	 (ImageReady) Select a layer or layer set, and choose Layer Options or Layer Set Options from the Layers menu or 

the Layers palette menu. 

•	 For groups, press Alt (Windows) or Option (Mac OS), and double-click the layer (not its name or thumbnail) in 

the Layers palette. 

2	 Choose a color from the Color pop-up menu, and click OK. 

To rasterize layers 
You cannot use the painting tools or filters on layers that contain vector data (such as type layers, shape layers, vector 

masks, or Smart Objects) and generated data (such as fill layers). However, you can rasterize these layers to convert 

their contents into a flat, raster image. 

❖ Select the layers you want to rasterize, choose Layer > Rasterize, and then choose an option from the submenu: 

Type Rasterizes the type on a type layer. Doesn’t rasterize any other vector data on the layer. 

Shape Rasterizes a shape layer. 

Fill Content Rasterizes the fill of a shape layer, leaving the vector mask. 

Vector Mask Rasterizes the vector mask of a shape layer, turning it into a layer mask. 

Smart Object Converts a Smart Object to a raster layer. 

Layer Rasterizes all vector data on the selected layers. 

All Layers Rasterizes all layers that contain vector and generated data. 

Note: To rasterize linked layers, select a linked layer, choose Layer > Select Linked Layers, and then rasterize the selected 

layers. 

To delete a layer or group 
Deleting layers that you no longer need reduces the size of your image file. 

1 Select one or more layers or groups in the Layers palette. 

2 Do one of the following: 

•	 To delete with a confirmation message, click the Delete icon. Alternatively, choose Layers > Delete > Layer or 

Delete Layer or Delete Group from the Layers palette menu. 

•	 To delete the layer or group without confirmation, drag it to the Delete icon or Alt-click (Windows) or Option

click (Mac OS) the Delete icon. 

•	 (Photoshop) To delete hidden layers, choose Layers > Delete > Hidden Layers. 

(Photoshop) To delete linked layers, select a linked layer, choose Layer > Select Linked Layers, and then delete the 

layers. 
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Exporting layers 
In Photoshop, you can export all layers or visible layers to separate files. Choose File > Scripts > Export Layers to 

Files. 

In ImageReady, you can export some or all layers of a document as files. You can export layers as Photoshop (PSD), 

GIF, JPEG, PNG 8, PNG 24, WBMP, or SWF files. See “To export layers as files in ImageReady” on page 675. 

Tracking file size 
File  size  depends on the  pixel dimensions of an image  and the  number  of  layers  it  contains. Images with more pixels  

may produce  more  detail  when  printed,  but they require more disk space  to  store and  may be slower to edit and  print.  

You should keep track of your file sizes to make sure the files are not becoming too large for your purposes. If the file 

is becoming too large, reduce the number of layers in the image or change the image size. 

You can view file size information for an image at the bottom of the application window. For more information, see 

“To display file information in the document window” on page 32. 

Merging and stamping layers 

Merging and stamping layers 
When you have finalized the content of layers, you can merge them to reduce the size of your image files. When you 

merge layers, the data on the top layers replaces the overlapped data on the lower layers. The intersection of all trans

parent areas in the merged layers remains transparent. 

Note: You cannot use an adjustment layer or fill layer as the target layer for a merge. 

In addition to merging layers, you can stamp them. Stamping allows you to merge the contents of more than one layer 

into a target layer while leaving the other layers intact. Typically, the selected layer is stamped down to the layer below 

it. 

Note: When you save a merged document, you cannot revert back to the unmerged state; the layers are permanently 

merged. 

To merge two layers or groups

1 Make sure that the layers and groups you want to merge are visible.


2 Select the layers and groups you want to merge.


3 Choose Layer > Merge Layers.


Note: You can merge two adjacent layers or groups by selecting the top item and then choosing Layer > Merge Down or 

Merge Group. You can merge linked layers by choosing Layer > Select Linked Layers and then merging the selected layers. 

(In ImageReady you can choose Layer > Merge Linked.) 

To merge layers in a clipping mask

1 Hide any layers that you do not want to merge.


2 Select the base layer in the clipping mask.


3 Choose Merge Clipping Mask from the Layers menu or the Layers palette menu.
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See also 

“Clipping masks” on page 436 

To merge all visible layers and groups in an image 
❖ Choose Merge Visible from the Layers palette or the Layers palette menu. 

To stamp multiple layers or linked layers 
When you stamp multiple selected layers or linked layers, Photoshop creates a new layer containing the merged


content.


1 Select multiple layers.


2 Press Ctrl+Alt+E (Windows) or Command+Option+E (Mac OS).


To stamp all visible layers 
❖ Select the layer or group that will contain the merged contents, and press Shift+Ctrl+Alt+E (Windows) or 

Shift+Command+Option+E (Mac OS). 

Alternatively, you can hold down Alt (Windows) or Option (Mac OS), and choose Layer > Merge Visible. The 

modified Merge command merges all the visible data into the current target layer. 

To flatten all layers 
Flattening reduces file size by merging all visible layers into the background and discarding hidden layers. Any trans

parent areas that remain are filled with white. 

Note: Converting an image between some color modes flattens the file. Save a copy of your file with all layers intact if 

you want to edit the original image after the conversion. 

1 Make sure that all the layers you want to keep are visible.


2 Choose Layer > Flatten Image, or choose Flatten Image from the Layers palette menu.


Setting opacity and blending options 

To specify opacity for a layer or group 
A layer’s  opacity determines to what degree it obscures or reveals  the layer  beneath it.  A layer  with  1%  opacity appears  

nearly transparent, whereas one with 100% opacity appears completely opaque. 
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Note: You cannot change the opacity of a background layer or a locked layer. You can, however, convert a background 

layer to a regular layer, which does support transparency. See “To convert a background into a layer” on page 396. 

1 Select a layer or group in the Layers palette. 

2 Do one of the following: 

•	 In the Layers palette, enter a value in the Opacity text box or drag the Opacity pop-up slider. 

•	 Choose Layer > Layer Style > Blending Options. Enter a value in the Opacity text box or drag the Opacity pop-up 

slider. 

•	 Select the Move tool and type a number indicating the percentage of opacity. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending Options, or choose Blending 

Options from the Add A Layer Style button at the bottom of the Layers palette menu. 

To specify fill opacity for a layer 
In addition to setting opacity, which affects any layer styles and blending modes applied to the layer, you can specify 

a fill opacity for layers. Fill opacity affects pixels painted in a layer or shapes drawn on a layer without affecting the 

opacity of any layer effects that have been applied to the layer. 

❖ Do one of the following: 

•	 (Photoshop) In the Layers palette, enter a value in the Fill Opacity text box or drag the Fill Opacity pop-up slider. 

•	 Double-click a layer thumbnail, choose Layer > Layer Style > Blending Options. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending Options, or choose Blending 

Options from the Add A Layer Style button at the bottom of the Layers palette. Enter a value in the Fill Opacity text box. 

About blending modes 
A layer’s blending mode determines how its pixels blend with underlying pixels in the image. You can create a variety 

of special effects using blending modes. 

By default, the blending mode of a group is Pass Through, which means that the group has no blending properties 

of its own. When you choose a different blending mode for a group, you effectively change the order in which the 

image components are  put together.  All of the  layers  in  the group  are put  together  first.  The composite  group is then  

treated as a single image and blended with the rest of the image using the selected blending mode. Thus, if you choose 

a blending mode other than Pass Through for the group, none of the adjustment layers or layer blending modes 

inside the group will apply to layers outside the group. 

Note: There is no Clear blending mode for layers. In addition, the Color Dodge, Color Burn, Darken, Lighten, Difference, 

and Exclusion modes are unavailable for Lab images. 

See also 

“List of blending modes” on page 487 
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To specify a blending mode for a layer or group

1 Select a layer or group in the Layers palette.


2 Choose a blending mode:


•	 In the Layers palette, choose an option from the Blend Mode pop-up menu. 

•	 Choose Layer > Layer Style > Blending Options, and then choose an option from the Blend Mode pop-up menu. 

Filling new layers with a neutral color 
You can’t apply certain filters (such as the Lighting Effects filter) to layers with no pixels. Selecting Fill With (Mode)-

neutral Color in the New Layer dialog box resolves this problem by first filling the layer with a preset, neutral color. 

This invisible, neutral color is assigned according to the layer’s blending mode. If no effect is applied, filling with a 

neutral color has no effect on the remaining layers. The Fill With Neutral Color option is not available for layers that 

use the Normal, Dissolve, Hue, Saturation, Color, or Luminosity modes. 

Specifying knockout options 
Knockout options let you specify which layers “punch through” to reveal content from other layers. For example, you 

can use a text layer to knock out a color adjustment layer and reveal a portion of the image using the original colors. 

As you plan your knockout effect, you need to decide which layer will create the shape of the knockout, which layers 

will be punched through, and which layer will be revealed. If you want to reveal a layer other than the Background, 

you can place the layers you want to use in a group or clipping mask. 

Farm logo with shallow knockout to Field layer 

To create a knockout 
1 Do one of the following in the Layers palette: 

•	 Position the layer that will create the knockout above the layers that will be punched through, and make the layer 

you want to reveal the  Background. (Choose  Layer  >  New  >  Background  From  Layer to convert  a regular  layer to  

the background.) 

•	 Place the layers you want to use in a group. The top layer in the group will punch through to the bottom layer in 

the group  or  the background.  If  you want to reveal the  background, make sure that the  blending mode of the  group  

is set to Pass Through (the default setting). 

•	 Place the layers you want to use in a clipping mask. The top layer in the group will punch through to the bottom 

layer in the group or the Background. (See “To create a clipping mask” on page 437.) If you want to reveal the 

bottom layer in the group, make sure that the Blend Clipped Layers As Group option is selected for the bottom 

layer. (See “Grouping blend effects” on page 412.) 

2	 Select the top layer (the layer that will create the knockout). 
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3 Double-click a layer thumbnail (Photoshop), choose Layer > Layer Style > Blending Options, or choose Blending 

Options from the Layers palette menu. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending Options, or choose Blending 

Options from the Add A Layer Style button at the bottom of the Layers palette menu. 

4	 Choose an option from the Knockout pop-up menu: 

•	 Select  Shallow to knock  out to the  first possible stopping  point,  such  as  the bottom of the  group or clipping  mask  

containing the knockout option. 

• Select Deep to knock out to the background. If there is no background, Deep knocks out to transparency.


5 Lower the fill opacity or change the blending mode to create the knockout effect.


6 click OK.


To exclude channels from blending 
You can restrict blending effects to a specified channel when you blend a layer or group. By default, all channels are 

included. When using an RGB image, for example, you can choose to exclude the red channel from blending; in the 

composite image, only the information in the green and blue channels is affected. 

1	 Do one of the following: 

•	 Double-click a layer thumbnail. 

•	 Choose Layer > Layer Style > Blending Options. 

•	 Choose Blending Options from the Add A Layer Style button at the bottom of the Layers palette. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending Options, or choose Blending 

Options from the Add A Layer Style button at the bottom of the Layers palette menu. 

2 In the Advanced Blending area of the Layer Style dialog box, deselect any channels you do not want to include 

when the layer is blended. 

Grouping blend effects 
By default, layers in a clipping mask are blended with the underlying layers using the blending mode of the


bottommost  layer in the  group.  However,  you can  choose  to  have  the blending mode of the  bottommost  layer apply 


only to that layer, allowing you to preserve the original blending appearance of the clipped layers. (See “To create a


clipping mask” on page 437.)


You can also apply the blending mode of a layer to layer effects that modify opaque pixels, such as Inner Glow or


Color Overlay, without changing layer effects that modify only transparent pixels, such as Outer Glow or Drop


Shadow.


To specify the scope of blending options

1 Select the layer that you want to affect.


2 Do one of the following:


•	 Double-click a layer thumbnail, choose Blending Options from the Layers palette menu (Photoshop), or choose 

Layer > Layer Style > Blending Options. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending Options, or choose Blending 

Options from the Add A Layer Style button at the bottom of the Layers palette menu. 
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3	 Specify the scope of blending options: 

•	 Select Blend Interior Effects As Group to apply the blending mode of the layer to layer effects that modify opaque 

pixels, such as Inner Glow, Satin, Color Overlay, and Gradient Overlay. 

•	 Select Blend Clipped Layers As Group to apply the blending mode of the base layer to all layers in the clipping 

mask. Deselecting this option, which is always selected by default, maintains the original blending mode and 

appearance of each layer in the group. 

A 

B	 C 

Advanced blending options 
A. Farm Logo and Paint Stroke layers each with its own blending mode B. Blend Interior Effects As Group option selected C. Blend Clipped 
Layers As Group option selected 

•	 Select Transparency Shapes Layers to restrict layer effects and knockouts to opaque areas of the layer. Deselecting 

this option, which is always selected by default, applies these effects throughout the layer. 

•	 Select Layer Mask Hides Effects to restrict layer effects to the area defined by the layer mask. 

•	 Select Vector Mask Hides Effects to restrict layer effects to the area defined by the vector mask. 

4	 Click OK. 

To specify a tonal range for blending layers 
The sliders in the Blending Options dialog box control which pixels from the active layer and from the underlying 

visible layers appear in the final image. For example, you can drop dark pixels out of the active layer or force bright 

pixels from the underlying layers to show through. You can also define a range of partially blended pixels to produce 

a smooth transition between blended and unblended areas. 

1 Double-click a layer thumbnail, choose Layer > Layer Style > Blending Options, or choose Add A Layer Style > 

Blending Options from the Layers palette menu. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending Options, or choose Blending 

Options from the Add A Layer Style button at the bottom of the Layers palette menu. 
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2	 In the Advanced Blending area of the Layer Style dialog box, choose an option from the Blend If pop-up menu. 

•	 Choose Gray to specify a blending range for all channels. 

•	 Select an individual color channel (for example, red, green, or blue in an RGB image) to specify blending in that 

channel. 

3 Use the This Layer and Underlying Layer sliders to set the brightness range of the blended pixels—measured on a 

scale from 0 (black) to 255 (white). Drag the white slider to set the high value of the range. Drag the black slider to 

set the low value of the range. 

To define a range of partially blended pixels, hold down Alt (Windows) or Option (Mac OS), and drag one half of a 

slider triangle. The two values that appear above the divided slider indicate the partial blending range. 

Keep the following guidelines in mind when specifying blending ranges: 

•	 Use the This Layer sliders to specify the range of pixels on the active layer that will blend, and therefore appear, in 

the final image. For example, if you drag the white slider to 235, pixels with brightness values higher than 235 will 

remain unblended and will be excluded from the final image. 

•	 Use the Underlying Layer sliders to specify the range of pixels in the underlying visible layers that will blend in the 

final image. Blended pixels are combined with pixels in the active layer to produce composite pixels, whereas 

unblended pixels show through overlying areas of the active layer. For example, if you drag the black slider to 19, 

pixels with brightness values lower than 19 will remain unblended and will show through the active layer in the 

final image. 

Layer effects and styles 

Layer effects and styles 
Photoshop and ImageReady provide a variety of effects—such as shadows, glows, bevels, overlays, and strokes—that 

let you quickly change the appearance of a layer’s contents. Layer effects are linked to the layer contents. When you 

move or edit the contents of the layer, the effects are modified correspondingly. For example, if you apply a drop 

shadow effect to a text layer, the shadow changes automatically as you edit the text. 

The effects that you apply to a layer become part of the layer’s custom style. When a layer has  a style, an “f  ”  icon  

appears to the right of the layer’s name in the Layers palette. You can expand the style in the Layers palette to view 

all the effects that compose the style and edit the effects to change the style. 

When you save a custom style, it becomes a preset style. Preset styles appear in the Styles palette and can be applied 

with a single click. Photoshop and ImageReady provide a variety of preset styles to fill a wide range of uses. 
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Illustration of a layer with a style 

Note: You cannot apply layer effects and styles to a background, a locked layer, or a group. 

Applying preset styles 
You can view and select preset styles from the Styles palette, from the Layer Styles dialog box, or, after you select a 

pen tool or shape tool, from the Layer Styles pop-up palette in the options bar. By default, applying a preset style 

replaces the current layer style. However, you can add the attributes of a second style to those of the current style 

using a keyboard modifier. 

The layer styles that come with Photoshop and ImageReady are grouped into libraries by function. For example, one 

library contains styles for creating web buttons; another library contains styles adding effects to text. 

To display the Styles palette, choose Window > Styles. 

To apply a preset style to a layer 
❖ Do one of the following: 

•	 Click a style in the Styles palette to apply it to the currently selected layers. 

•	 Drag a style from the Styles palette onto a layer in the Layers palette. 

•	 Drag a style from the Styles palette to the document window, and release the mouse button when the pointer is 

over the layer content to which you want to apply the style. 

Note: Hold down Shift as you click or drag to add (rather than replace) the style to any existing effects on the destination 

layer. 

•	 Choose Layer > Layer Style > Blending Options, and click the word Styles in the Layer Styles dialog box (top item 

in the list on the left side of the dialog box). Click the style you want to apply, and click OK. 

•	 When using a shape tool or pen tool in shape layers mode, select a style from the pop-up palette in the options bar 

before drawing the shape. 

See also 

“To load a library of preset styles” on page 422 

To apply a style from another layer 
❖ In the Layers palette, Alt-drag (Windows) or Option-drag (Mac OS) the style from a layer’s effect list to another 

layer. 
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To change how preset styles are displayed 
1 Click the triangle in the Styles palette, Layer Styles dialog box, or Layer Styles pop-up palette in the options bar 

(Photoshop). 

2 Choose a display option from the palette menu: 

•	 (Photoshop) Text Only to view the layer styles as a list. 

•	 Small Thumbnail or Large Thumbnail to view the layer styles as thumbnails. 

•	 Small List or (Photoshop) Large List to view the layer styles as a list, with a thumbnail of the selected layer style 

displayed. 

Custom styles 
You can create custom styles using one or more of the following effects: 

Drop Shadow Adds a shadow that falls behind the contents on the layer. 

Inner Shadow Adds a shadow that falls just inside the edges of the layer’s content, giving the layer a recessed 

appearance. 

Outer Glow and Inner Glow Add glows that emanate from the outside or inside edges of the layer’s content. 

Bevel and Emboss Add various combinations of highlights and shadows to a layer. 

Satin Applies interior shading that creates a satiny finish. 

Color, Gradient, and Pattern Overlay Fill the layer’s content with a color, gradient, or pattern. 

Stroke Outlines the object on the current layer using color, a gradient, or a pattern. It is particularly useful on hard

edged shapes such as type. 

To apply a custom style to a layer 
1 Select a single layer in the Layers palette. 

2 Do one of the following: 

•	 Click the Layer Styles button  at the bottom of the Layers palette and choose an effect from the list. 

• Choose an effect from the Layer > Layer Style submenu.


3 Set effect options in the Layer Style dialog box. See “Layer style options” on page 418.


4 Add other effects to the style, if desired. In the Layer Style dialog box, click the check box to the left of the effect


name to add the effect without selecting it.


To hide or show all layer styles in an image 
When a layer has a style, an “f ” icon  appears to the right of the layer’s name in the Layers palette. 

❖ Choose Layer > Layer Style > Hide All Layer Effects or Show All Layer Effects. 
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To expand or collapse layer styles in the Layers palette
❖ Do one of the following:

• Click the triangle  next to the layer styles icon  to expand the list of layer effects applied to that layer.

• Click the triangle to collapse the layer effects.

• To expand or collapse all of the layer styles applied within a group, hold down Alt (Windows) or Option (Mac OS)

and click the triangle or inverted triangle for the group. The layer styles applied to all layers within the group

expand or collapse correspondingly.

To edit a layer style
1 Do one of the following:

• In the Layers palette, double-click an effect displayed below the layer name. (Click the triangle next to the “f ”

icon  to display the effects contained in the style.)

• Choose Layer > Layer Style and the effect you want to edit.

2 Set one or more options in the Layer Style dialog box. See “Layer style options” on page 418.

Layer Style dialog box. Click a check box to apply the default settings without displaying the effect’s options.

Click an effect name to display the effect’s options.

You can edit multiple effects without closing the Layer Style dialog box. Select an effect on the left side of the dialog

box to display an effect’s options.
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Layer style options 
Angle Determines the lighting angle at which the effect is applied to the layer. In Photoshop, you can drag in the 

document window to adjust the angle of a Drop Shadow, Inner Shadow, or Satin effect. 

Anti-alias Blends the edge pixels of a contour or gloss contour. This option is most useful on shadows with a small 

size and complicated contour. 

Blend Mode Determines how the layer style blends with the underlying layers, which may or may not include the 

active  layer.  For example, an  inner  shadow  blends  with  the active layer  because the  effect  is  drawn  on  top of that layer,  

but a drop shadow blends only with the layers beneath the active layer. In most cases, the default mode for each effect 

produces the best results. See “List of blending modes” on page 487. 

Choke Shrinks the boundaries of the matte of an Inner Shadow or Inner Glow prior to blurring. 

Color Specifies the color of a shadow, glow, or highlight. You can click the color box and choose a color. 

Contour With solid-color glows, Contour allows you to create rings of transparency. With gradient-filled glows, 

Contour allows you to create variations in the repetition of the gradient color and opacity. In beveling and 

embossing, Contour allows you to sculpt the ridges, valleys, and bumps that are shaded in the embossing process. 

With shadows, Contour allows you to specify the fade. For more information, see “Modifying layer effects with 

contours” on page 419. 

Distance Specifies the offset distance for a shadow or satin effect. In Photoshop, you can drag in the document 

window to adjust the offset distance. 

Depth Specifies the depth of a bevel. It also specifies the depth of a pattern. 

Global Angle Turns on global lighting for the effect. Global lighting applies the same angle to all effects for which 

the Global Angle option is selected, giving the appearance of a single light source shining on the image. Deselect 

Global Angle to assign a local angle to Drop Shadow, Inner Shadow, and Bevel effects. 

Gloss Contour Creates a glossy, metallic appearance. Gloss Contour is applied after shading a bevel or emboss. 

Gradient Specifies the gradient of a layer effect. In Photoshop, click the gradient to display the Gradient Editor or 

click the inverted arrow and choose a gradient from the pop-up palette. In Photoshop, you can edit a gradient or 

create a new gradient using the Gradient Editor. In ImageReady, click the inverted arrow next to the gradient sample 

and select a gradient from the list, or choose a gradient type from the pop-up list. You can edit the color or opacity 

in the Gradient Overlay panel the same way you edit them in the Gradient Editor. For some effects, you can specify 

additional gradient options. Reverse flips the orientation of the gradient, Align With Layer uses the bounding box of 

the layer to calculate the gradient fill, and Scale scales the application of the gradient. You can also move the center 

of the gradient by clicking and dragging in the image window. Style specifies the shape of the gradient. 

Highlight or Shadow Mode Specifies the blending mode of a bevel or emboss highlight or shadow. 

Jitter Varies the application of a gradient’s color and opacity. 

Layer Knocks Out Drop Shadow Controls the drop shadow’s visibility in a semitransparent layer. 

Noise Specifies the number of random elements in the opacity of a glow or shadow. Enter a value or drag the slider. 

Opacity Sets the opacity of the layer effect. Enter a value or drag the slider. 

Pattern Specifies the pattern of a layer effect. In ImageReady, click the inverted arrow next to the pattern sample and 

choose a pattern from the list. In Photoshop, click the pop-up palette and choose a pattern. Click the New preset 

button  to create a new preset pattern based on the current settings. Click Snap To Origin to make the origin of 

the pattern the same as the origin of the document (when Link With Layer is selected), or to place the origin at the 

upper left corner of the layer (if Link With Layer is deselected). Select Link With Layer if you want the pattern to 
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move  along with the  layer as the  layer moves. Drag the  Scale slider or enter  a value  to  specify the  size  of  the pattern.  

Drag a pattern to position it in the layer; reset the position by using the Snap To Origin button. The Pattern option 

is not available if no patterns are loaded. 

Position Specifies the position of a stroke effect as Outside, Inside, or Center. 

Range Controls which portion or range of the glow is targeted for the contour. 

Size Specifies the amount of blur or the size of the shadow. 

Soften Blurs the results of shading to reduce unwanted artifacts. 

Source Specifies the source for an inner glow. Choose Center to apply a glow that emanates from the center of the 

layer’s content, or Edge to apply a glow that emanates from the inside edges of the layer’s content. 

Spread Expands the boundaries of the matte prior to blurring. 

Style Specifies the style of a bevel: Inner Bevel creates a bevel on the inside edges of the layer contents, Outer Bevel 

creates a bevel on the outside edges of the layer contents, Emboss simulates the effect of embossing the layer contents 

against the  underlying  layers, Pillow Emboss simulates  the effect of stamping the  edges of the  layer contents into the  

underlying layers, and Stroke Emboss confines embossing to the boundaries of a stroke effect applied to the layer. 

(The Stroke Emboss effect is not visible if no stroke is applied to the layer.) 

Technique Applies a technique. For bevel and emboss, Smooth blurs the edges of a matte slightly and is useful for 

all types of mattes, whether their edges are soft or hard. It does not preserve detailed features at larger sizes. Chisel 

Hard uses a distance measurement technique and is primarily useful on hard-edged mattes from anti-aliased shapes 

such as type. It preserves detailed features better than the Smooth technique. Chisel Soft uses a modified distance 

measurement technique and, although not as accurate as Chisel Hard, is more useful on a larger range of mattes. It 

preserves features better than the Smooth technique. For glows, Softer applies a blur and is useful on all types of 

mattes, whether their edges are soft or hard. At larger sizes, Softer does not preserve detailed features. Precise uses a 

distance measurement technique to create a glow and is primarily useful on hard-edged mattes from anti-aliased 

shapes such as type. It preserves features better than the Softer technique. 

Texture Applies a texture. Use Scale to scale the size of the texture. Select Link With Layer if you want the texture to 

move along with the layer as the layer moves. Invert inverts the texture. Depth varies the degree and direction 

(up/down) to which the texturing is applied. Snap To Origin makes the origin of the pattern the same as the origin 

of the document (if Link With Layer is deselected) or places the origin at the upper left corner of the layer (if Link 

With Layer is selected). Drag the texture to position it in the layer. 

Modifying layer effects with contours 
When  you create custom layer  styles, you  can use  contours  to  control the  shape of Drop Shadow,  Inner Shadow,  Inner  

Glow, Outer  Glow, Bevel  and Emboss,  and Satin  effects over a given range. For  example,  a Linear contour  on  a Drop  

Shadow causes the opacity to drop off in a linear transition. Use a Custom contour to create a unique shadow 

transition. Custom contours created in Photoshop can be used in ImageReady. 

You can select, reset, delete, or change the preview of contours in the Contour pop-up palette and Preset Manager. 
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A B  

Detail of Layer Style dialog box for Drop Shadow effect 
A. Click to display the Contour Editor dialog box. B. Click to display the pop-up palette. 

To create a custom contour

1 Select the Drop Shadow, Inner Shadow, Inner Glow, Outer Glow, Bevel and Emboss, Contour, or Satin effect in


the Layer Style dialog box.


2 Click the contour thumbnail in the Layer Style dialog box.


3 Click the contour to add points, and drag to adjust the contour. Or enter values for Input and Output.


4 To create a sharp corner instead of a smooth curve, select a point and click Corner.


5 To save the contour to a file, click Save and name the contour.


6 To store a contour as a preset, choose New.


7 Click OK. New contours are added at the bottom of the pop-up palette.


To load a contour 
❖ Click the contour in the Layer Style dialog box, and in the Contour Editor dialog box, choose Load. Go to the 

folder containing the contour library you want to load and click Open. 

To delete a contour 
❖ Click the inverted arrow next to the currently selected contour to view the pop-up palette. Press Alt (Windows) 

or Option (Mac OS), and click the contour you want to delete. 

To set a global lighting angle 
Using global light gives the appearance of a common light source shining on the image. 

❖ To set a global lighting angle for all layers, do one of the following: 

•	 Choose Layer > Layer Style > Global Light. In the Global Light dialog box, enter a value or drag the angle radius 

to set the angle and altitude, and click OK. 

•	 In  the Layer  Style dialog box  for Drop Shadow,  Inner Shadow,  or  Bevel,  select  Use Global Light. For  Angle,  enter  

a value or drag the slider, and click OK. 

The new lighting angle appears as the default for each layer effect that uses the global lighting angle. 
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To create a new preset style

1 In the Layers palette, select the layer containing the style that you want to save as a preset.


2 Do one of the following:


•	 Drag the selected layer into the Styles palette or onto the New Item button  in the Styles palette. 

•	 Click an empty area of the Styles palette. 

•	 Press Alt (Windows) or Option (Mac OS), and click the New Item button at the bottom of the Styles palette. 

•	 Choose New Style from the Styles palette menu. 

• Choose Layer > Layer Style > Blending Options, and click New Style in the Layer Style dialog box. 

3 Enter a name for the preset style, set style options, and click OK. 

To create a preset style from a single effect, drag the effect from the Layers palette to the Styles palette. 

To rename a preset style 
❖ Do one of the following: 

•	 Double-click a style in the Styles palette. If the Styles palette is set to display styles as thumbnails, enter a new name 

in the dialog box, and click OK. Otherwise, type a new name directly in the Styles palette, and press Enter 

(Windows) or Return (Mac OS). 

•	 Select  a style  in  the Styles area of the  Layer Styles dialog box. Then choose Rename Style  from  the pop-up menu,  

enter a new name, and click OK. 

•	 (Photoshop) When using a shape or pen tool, select a style from the Layer Style pop-up palette in the options bar. 

Then choose Rename Style from the pop-up palette menu. 

To delete a preset style 
❖ Do one of the following: 

•	 Drag a style to the Delete icon  at the bottom of the Styles palette. 

•	 Press Alt (Windows) or Option (Mac OS) and click the layer style in the Styles palette. 

•	 (Photoshop) Select a style in the Styles area of the Layer Styles dialog box. (See “Applying preset styles” on 

page 415.) Then choose Delete Style from the pop-up menu. 

•	 (Photoshop) When using a shape or pen tool, select a style from the Layer Style pop-up palette in the options bar. 

Then choose Delete Style from the pop-up palette menu. 

To save a set of preset styles as a library 
1 Do one of the following: 

•	 Choose Save Styles from the Styles palette menu. 

•	 Select Styles on the left side of the Layer Styles dialog box. Then choose Save Styles from the pop-up menu. 

•	 (Photoshop) When using  a shape  or  pen tool,  click the  layer style  thumbnail in the  options bar. Then choose Save  

Styles from the pop-up palette menu. 

2	 Choose a location for the style library, enter a file name, and click Save. 
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You can save the library anywhere. However, if you place the library file in the Presets/Styles folder inside the 

Photoshop program folder, the library name will appear at the bottom of the Styles palette menu when you restart 

the application. 

Note: You can also use the Preset Manager to rename, delete, and save libraries of preset styles. 

To load a library of preset styles 
1 Click the triangle in the Styles palette, Layer Style dialog box (Photoshop), or Layer Style pop-up palette in the 

options bar. 

2 Do one of the following: 

•	 Choose Load Styles (Photoshop) or Append Styles (ImageReady) to add a library to the current list. Then select 

the library file you want to use, and click Load. 

•	 Choose Replace Styles to replace the current list with a different library. Then select the library file you want to 

use, and click Load. 

•	 Choose a library file (displayed at the bottom of the palette menu). Then click OK to replace the current list, or 

click Append to append the current list. 

3 To return to the default library of preset styles, choose Reset Styles. You can either replace the current list or 

append the default library to the current list. 

Note: You can also use the Preset Manager to load and reset style libraries. See “About the Preset Manager” on page 67. 

To copy layer styles between layers 
Copying and pasting styles is an easy way to apply the same effects to multiple layers.


1 In the Layers palette, select the layer containing the style you want to copy.


2 Choose Layer > Layer Style > Copy Layer Style.


3 Select the destination layer in the palette, and choose Layer > Layer Style > Paste Layer Style.


The pasted layer style replaces the existing layer style on the destination layer or layers.


To copy layer styles between layers by dragging 
❖ Do one of the following: 

•	 In the Layers palette, Alt-drag (Windows) or Option-drag (Mac OS) a single layer effect from one layer to another 

to duplicate the layer effect, or drag the Effects bar from one layer to another to duplicate the layer style. 

•	 Drag  one or more layer  effects from the  Layers  palette to the  image to apply  the resulting  layer style  to  the highest  

layer in the Layers palette that contains pixels at the drop point. 

To scale a layer effect 
A layer style may have been fine-tuned for a target resolution and features of a given size. Using Scale Effects allows 

you to scale the effects in the layer style without scaling the object to which the layer style is applied. 

1 Select the layer in the Layers palette. 

2 Choose Layer > Layer Style > Scale Effects. 

3 Enter a percentage or drag the slider. 
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4 Select Preview to preview the changes in the image.


5 Click OK.


To remove an effect from a style

1 In the Layers palette, expand the layer style to see its effects.


2 Do one of the following:


• Drag the effect to the Delete icon. 

• (ImageReady) Select the effect, and choose Delete Effect from the Layers palette menu. 

To remove a style from a layer

1 In the Layers palette, select the layer containing the style you want to remove.


2 Do one of the following:


• In the Layers palette, drag the Effects bar to the Delete icon. 

• Choose Layer > Layer Style > Clear Layer Style. 

• Select the layer, and then click the Clear Style button  at the bottom of the Styles palette. 

• (ImageReady) Select an effect in the Layers palette, and choose Delete All Effects from the Layers palette menu. 

To convert a layer style to image layers 
To customize or fine-tune the appearance of layer styles, you can convert the layer styles to regular image layers. After 

you convert a layer style to image layers, you can enhance the result by painting or applying commands and filters. 

However, you can no longer edit the layer style on the original layer, and the layer style no longer updates as you 

change the original image layer. 

Note: The layers produced by this process  may not  result  in  artwork that exactly  matches the  version using  layer styles.  

In Photoshop, you may see an alert when you create the new layers. 

1 In the Layers palette, select the layer containing the layer style that you want to convert.


2 Choose Layer > Layer Style > Create Layers.


You can now modify and restack the new layers in the same way as regular layers. Some effects—for example, Inner


Glow—convert to layers within a clipping mask.


You can also drag a layer style to the New Layer button at the bottom of the Layers palette to generate a new layer


from an existing style.


Adjustment and fill layers 

Adjustment layers and fill layers 
An adjustment layer applies color and tonal adjustments to your image without permanently changing pixel values. 

For example, rather than making a Levels or Curves adjustment directly on your image, you can create a Levels or 

Curves  adjustment  layer.  The color  and tone adjustments  are stored in the  adjustment  layer and  apply to all  the layers  

below it. 
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Fill layers let you fill a layer with a solid color, a gradient, or a pattern. Unlike adjustment layers, fill layers do not 

affect the layers underneath them. 

Adjustment layers provide the following advantages: 

•	 Nondestructive edits. You can try different settings and re-edit the adjustment layer at any time. You can also 

reduce the effect of the adjustment by lowering the opacity of the adjustment layer. 

•	 Reduced loss of image data through combined multiple adjustments. Each time you adjust pixel values directly, 

you lose some image data. You can use multiple adjustment layers and make small adjustments. Photoshop 

combines all the adjustments before it applies them to the image. 

•	 Selective editing. Paint  on  the adjustment layer’s  image mask to apply  an  adjustment  to  part  of  an  image.  Later you  

can control which parts of the image are adjusted by re-editing the layer mask. You can vary the adjustment by 

painting on the mask with different tones of gray. 

•	 Ability to apply adjustments to multiple images. Copy and paste adjustment layers between images to apply the 

same color and tone adjustments. 

Adjustment layers increase the image’s file size, though no more than other layers. If you are working with many 

layers, you may want to reduce file size by merging the adjustment layers into the pixel content layers. Adjustment 

layers have many of the same characteristics as other layers. You can adjust their opacity and blending mode, and you 

can group them to apply the adjustment to specific layers. You can turn their visibility on and off to apply their effect 

or to preview the effect. 

Original (left); adjustment layer applied to barn only (center), which brings out detail in the barn; and adjustment layer applied to entire image 
(right), which lightens the entire image and pixelates the clouds 

Keep in mind that an adjustment layer affects all the layers below it. This means that you can correct multiple layers 

by making a single adjustment, rather than adjusting each layer separately. 

Note: You can apply and edit adjustment layers only in Photoshop; however, you can view them in ImageReady. 

Creating adjustment layers or fill layers 
Adjustment layers and fill layers have the same opacity and blending mode options as image layers. You can 

rearrange, delete, hide, and duplicate them just as you do image layers. By default, adjustment layers and fill layers 

have layer masks, as indicated by the mask icon to the left of the layer thumbnail. If a path is active when you create 

the adjustment or fill layer, a vector mask is created instead of a layer mask. 

To confine the effects of an adjustment layer to a group of layers, create a clipping mask consisting of those layers. 

You can place the adjustment layers in or at the base of the clipping mask. The resulting adjustment is confined to 

the layers inside the group. (Alternatively, you can create a layer set that uses any blending mode other than Pass 

Through.) 
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D
C

B 

Adjustment and fill layers 
A. Adjustment layer confined to Log Home layer only B. Layer thumbnail C. Fill layer D. Layer mask 

To create an adjustment layer or fill layer 
❖ Do one of the following: 

•	 Click the New Adjustment Layer button  at the bottom of the Layers palette, and choose a layer type. 

•	 Choose Layer > New Fill Layer, and choose an option from the submenu. Then name the layer, set other layer 

options, and click OK. 

•	 Choose  Layer  >  New Adjustment Layer, and  choose  an  option  from  the submenu. Then name the  layer,  set other  

layer options, and click OK. 

Note: To  confine the  effects of the  adjustment  layer or fill layer  to a selected area,  make  a selection, create a closed  path  

and select it, or select an existing closed path. When you use a selection, you create an adjustment layer or fill layer 

confined by a layer mask. When you use a path, you create an adjustment layer or fill layer confined by a vector mask. 

Adjustment and fill layer types 
For complete information on options for each adjustment layer type, search for that adjustment in Photoshop Help. 

Solid Color Specify a color. 

Gradient Click the gradient to display the Gradient Editor, or click the inverted arrow and choose a gradient from 

the pop-up palette. Set additional options if desired. Style specifies the shape of the gradient. Angle specifies the angle 

at which the gradient is applied. Scale changes the size of the gradient. Reverse flips the orientation of the gradient. 

Dither reduces banding by applying dithering to the gradient. Align With Layer uses the bounding box of the layer 

to calculate the gradient fill. You can drag in the image window to move the center of the gradient. 

Pattern Click the pattern, and choose a pattern from the pop-up palette. Click Scale, and enter a value or drag the 

slider to scale the pattern. Click Snap To Origin to make the origin of the pattern the same as the origin of the 

document. Select Link With Layer if you want the pattern to move along with the layer as the layer moves. When 

Link With Layer is selected, you can drag in the image to position the pattern while the Pattern Fill dialog box is open. 

Levels Specify values for the highlights, shadows, and midtones. 

Curves Adjust the intensity values of pixels along a 0–255 scale while keeping up to 15 other values constant. 

Color Balance Drag a slider toward a color that you want to increase in the image; drag a slider away from a color 

that you want to decrease. 

Brightness/Contrast Specify values for Brightness and Contrast. 

Hue/Saturation Choose which colors to edit, and specify values for Hue, Saturation, and Lightness. 
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Selective Color Choose  the color  you want to adjust,  and drag the  sliders to increase or decrease the  components  in  

the selected color. 

Channel Mixer Modify the color values in a channel by mixing them with other channels. 

Gradient Map Choose a gradient and set gradient options. 

Photo Filter Make color adjustments by simulating the effect of a filter in front of a camera lens. 

Invert Inverted adjustment layers don’t have options. 

Threshold Specify a threshold level. 

Posterize Specify the number of tonal levels for each color channel. 

To edit an adjustment or fill layer 
You can edit an adjustment or fill layer’s settings, or replace it with a different adjustment or fill type. 

You can also edit the mask of an adjustment layer or fill layer to control the effect that the layer has on the image. By 

default, all areas of an adjustment or fill layer are “unmasked” and are therefore visible. (See “Masking layers” on 

page 432.) 

1 Do one of the following: 

• Double-click the adjustment or fill layer’s thumbnail in the Layers palette. 

• Choose Layer > Layer Content Options. 

2 Make the desired adjustments, and click OK. 

Note: Inverted adjustment layers do not have editable settings. 

To change the type of adjustment or fill layer

1 Select the adjustment layer or fill layer that you want to change.


2 Choose Layer > Change Layer Content and select a different fill or adjustment layer from the list.


Merging adjustment layers or fill layers 
You can merge an adjustment or fill layer several ways: with the layer below it, with the layers in its own grouped 

layer,  with  the layers it is linked to,  and with all  other visible layers.  You cannot,  however,  use an adjustment layer  or  

fill layer as the target layer for a merge. When you merge an adjustment layer or fill layer with the layer below it, the 

adjustments are rasterized and become permanently applied within the merged layer. You can also rasterize a fill 

layer without merging it. (See “To rasterize layers” on page 407.) 

Adjustment layers and fill layers whose masks contain only white values do not add significantly to the file size, so it 

is not necessary to merge these adjustment layers to conserve file space. 
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Smart Objects 

Smart Objects 
A Smart Object is a container in which you can embed raster or vector image data, for instance, from another 

Photoshop or Adobe Illustrator file. The embedded data retains all its original characteristics and remains fully 

editable. You  can create a Smart Object in Photoshop  by  converting  one or more layers.  In  addition, you  can paste  or  

place the data in Photoshop from Illustrator. Smart Objects give you the flexibility to scale, rotate, and warp layers 

nondestructively in Photoshop. 

Once a Smart Object stores source data inside a Photoshop document, you can then work on a composite of that data 

in the image. When you want to modify the document (for example, scale it), Photoshop re-renders the composite 

data based on the source data. 

A Smart Object is really one file embedded in another. When you create one Smart Object from one or more selected 

layers, you are really creating a new (child) file that is embedded in the original (parent) document. 

Smart Objects are useful because they allow you to do the following: 

•	 Perform nondestructive transforms. For instance, you can scale a layer as much as you want without losing 

original image data. 

•	 Preserve data that Photoshop doesn’t handle natively, such as complex vector artwork from Illustrator. Photoshop 

automatically transforms the file into something that it recognizes. 

•	 Edit one layer to update multiple instances of the Smart Object. 

You can apply transforms (however, some options are unavailable; for example Perspective and Distort), layer styles, 

opacity, blend modes, and warps to Smart Objects. After you make a change, the layer is updated with the edited 

content. 

A regular layer and a Smart Object in the Layers palette. The icon in the lower right corner of the thumbnail indicates a Smart Object. 

See also 

“Bitmap images and vector graphics” on page 177 

To create and work with Smart Objects 
Smart Objects are created through different methods. 

❖ Do any of the following: 

•	 Use the Place command to import artwork into the Photoshop document. 

•	 Convert one or more layers into one Smart Object layer. Select one or more layers and choose Layer > Smart 

Objects > Group Into New Smart Object. The layers are bundled into one layer titled Smart Object. 
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•	 Duplicate an existing Smart  Object  to  create  two versions that refer  to  the same source contents.  The Smart  Objects  

can be linked so that when you edit one version, the second is updated as well. Or, the Smart Objects can be 

unlinked so that your edits to one Smart Object do not affect the other. (See “To create a new Smart Object from 

an existing Smart Object” on page 429.) 

•	 Drag selected PDF or Adobe Illustrator layers or objects into your Photoshop document. 

•	 Copy and paste art from Adobe Illustrator into your Photoshop document. For the greatest flexibility when 

pasting from Illustrator, make sure that both PDF and AICB (No Transparency Support) are enabled in the File 

Handling & Clipboard preferences of Adobe Illustrator. 

Note: To find out whether you are looking at a Smart Object thumbnail or a layer thumbnail in the Layers palette, 

position the cursor over the thumbnail to see the tool tip. You can also look for a small Smart Object icon in the lower 

right corner of the thumbnail. 

See also 

“To place a file in Photoshop” on page 197 

“To paste Adobe Illustrator art into Photoshop” on page 200 

To edit the source contents of a Smart Object 
Smart Objects let you edit their source contents. When making edits, the source content file is opened in either 

Photoshop (if the content is raster data or a camera raw file) or Adobe Illustrator (if the content is vector PDF or EPS 

data). 

Editing Smart Objects in Photoshop works much as it does with Smart Objects in GoLive, and Symbols and 

Envelopes in Illustrator. When the source content file is updated and saved, the edits appear in all instances of the 

Smart Object in the Photoshop document. 

1	 Select the Smart Object from the Layers palette, and do one of the following: 

•	 Choose Layer > Smart Objects > Edit Contents.


• Double-click the Smart Objects thumbnail in the Layers palette.


A dialog box opens, reminding you to save any changes you make to the source content file.


2 Click OK to close the dialog box.


The Smart Object opens with all its associated layers.


3 Make your edits to source content (child) file.


4 Choose File > Save to commit the changes. You can also close the source content file.


5 Return to the main (parent) Photoshop document containing the Smart Object. All instances of the Smart Object


have been updated.
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To export the contents of a Smart Object 
You can  export  the contents of a Smart Object fully  intact  to  any drive  or  directory  to  which you  have  access  permis

sions. 

1 Select the Smart Object from the Layers palette, and choose Layer > Smart Objects > Export Contents. The Save 

dialog box appears. 

2 Navigate to where you want the Smart Object exported and click Save. The Smart Object is saved in PSB format 

(for raster data) or PDF (for vector data). 

To replace the contents of a Smart Object 
Using the Replace Contents command lets you update one or multiple instances of a Smart Object at the same time.


1 Select the Smart Object, and choose Layer > Smart Objects > Replace Contents.


2 Navigate to the file you want to use and click Place.


3 Click OK. The new content is placed in the Smart Object. Linked Smart Objects are also updated.


See also 

“Placing files” on page 196 

To convert a Smart Object back to a layer 
Converting a Smart Object to a regular layer rasterizes the content at the current size. 

❖ Select the Smart Object, and choose Layer > Smart Objects > Convert To Layer or Layer > Rasterize > Smart 

Object. 

The Smart Object is converted to a layer again, and the Smart Object thumbnail disappears. If you want to re-create 

the Smart Object, reselect the layers and start from scratch. However, the new Smart Object won’t have the trans

forms you applied to the original one. 

To create a new Smart Object from an existing Smart Object 
You can copy a Smart Object along with its full contents. The new instance of the Smart Object can be linked or 

unlinked to the original, depending on how you create the duplicate. 

❖ In the Layers palette, select a Smart Object layer, and do one of the following: 

•	 To create a duplicate Smart Object that is linked to the original, choose Layer > New > Layer Via Copy. You can 

also  drag the  Smart Object layer  to  the Create A New Layer  icon  at  the bottom of the  Layers  palette.  Any edits  you  

make to the copy affect the original Smart Object and vice versa. 

•	 To create a duplicate Smart Object that is not linked to the original, choose Layer > Smart Objects > New Smart 

Object Via Copy. Any edits you make to the copy do not affect the original Smart Object and vice versa. 

A new Smart Object appears on the Layers palette with the same name as the original and “copy” as a suffix. You can 

rename it. 
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Layer comps 

About layer comps and the Layer Comps palette 
Designers often create multiple compositions or comps of a page layout to show clients. Using layer comps, you can 

create, manage, and view multiple versions of a layout in a single Photoshop or ImageReady file. Layer comps are 

fully interchangeable between Photoshop and ImageReady if the image color mode is RGB. 

A layer comp is a snapshot of a state of the Layers palette. Layer comps record three types of layer options: 

• Layer visibility—whether a layer is showing or hidden. 

• Layer position in the document. 

• Layer appearance—whether a layer style is applied to the layer and the layer’s blending mode. 

You create a comp by making changes to the layers in your document and updating the comp in the Layer Comps 

palette. You view comps by applying them in the document. You can export layer comps to separate files, to a single 

PDF, or to a web photo gallery. 

Choose Window > Layer Comps to show the palette. 

B 

C 

D 

A 

Layer Comps palette 
A. Apply Layer Comp icon B. Last Document State C. Selected comps D. Layer Comp Cannot Be Fully Restored icon 

To create a layer comp 
1 Choose Window > Layer Comps to display the Layer Comp palette. Click the Create New Layer Comp button 

at the bottom of the Layer Comps palette. The new comp reflects the current state of layers in the Layers palette. 

2 In the New Layer Comp dialog box, name the comp, add descriptive comments, and choose options to apply to 

layers: Visibility, Position, and Appearance. 

3 Click OK. Any new comp preserves the options you chose for the previous one, so you don’t have to make these 

choices again if you want the comps to be identical. 

To duplicate a comp, select a comp in the Layer Comps palette and drag the comp to the New Comps button. 
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To apply and view layer comps 
1 Do any of the following: 

•	 To view a layer comp, you first need to apply it in the document. In the Layer Comp palette, click the Apply Layer 

Comp icon  next to a selected comp. 

•	 To cycle through a view of all the layer comps, use the Previous  and Next  buttons at the bottom of the 

palette. 

•	 To cycle through a view of specific selected comps, select the comps in the Layer Comps palette and then click the 

Next and Previous buttons at the bottom of the palette. This cycles through only the comps you selected. 

•	 To restore the document to its state before you chose a layer comp, click the Apply Layer Comp icon  next to 

Last Document State at the top of the Layer Comp palette. 

To change and update a layer comp 
If you change the configuration of a layer comp, you need to update it.


1	 Select the layer comp in the Layer Comps palette.


2 Make changes to the layer’s visibility, position, or style. You may need to change the layer comp’s options to record


these changes.


3 To change your comp options, select Layer Comp Options from the palette menu and select additional options to


record layer position and style.


4 Click the Update Layer Comp button
  at the bottom of the palette. 

To clear layer comp warnings 
Certain actions create a state where the layer comp can no longer be fully restored. This happens when you delete a 

layer, merge a layer, convert a layer to a background, or convert a color mode. In such instances, a caution icon 

appears next to the layer comp name. 

❖ Do one of the following: 

•	 Ignore the warning, which may result in the loss of one or more layers. Other saved parameters may be preserved. 

•	 Update the comp, which results in the loss of the previously captured parameters but brings the comp up to date. 

•	 Click the caution icon to see the message explaining that the layer comp can’t be restored properly. Choose Clear 

to remove the alert icon and leave the remaining layers unchanged. 

•	 Right-click (Windows) or Control-click (Mac OS) the caution icon to see the pop-up menu that lets you choose 

either the Clear Layer Comp Warning or the Clear All Layer Comp Warnings command. 

To delete a layer comp 
❖ Do one of the following: 

•	 Select the layer comp in the Layer Comps palette and click the Delete icon in the palette, or choose Delete Layer 

Comp from the palette menu. 

•	 Drag it to the Delete icon in the palette. 
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To export layer comps 
You can export layer comps to individual files, to a PDF file containing multiple layer comps, and to a web photo 

gallery of layer comps. 

❖ Choose File > Scripts and then choose one of the following commands: 

Layer Comps To Files Exports all layer comps to individual files, one for each comp. 

Layer Comps To PDF Exports all layer comps to a PDF file. 

Layer Comps To WPG Exports all layer comps to a web photo gallery. 

Masking layers 

Masking layers 
You can use masks to show or hide portions of a layer or protect areas from edits. You can create two types of masks: 

• Layer masks are resolution-dependent bitmap images that are created with the painting or selection tools. 

• (Photoshop) Vector masks are resolution independent and are created with a pen or shape tool. 

In the Layers palette, both the layer and vector masks appear as an additional thumbnail to the right of the layer 

thumbnail. For the layer mask, this thumbnail represents the grayscale channel that is created when you add the layer 

mask. The vector mask thumbnail represents a path that clips out the contents of the layer. 

A 

B 

C 

D 

Masking layer 
A. Layer mask thumbnail B. Vector mask thumbnail C. Vector Mask Link icon D. New Layer Mask 

You can edit a layer mask to add or subtract from the masked region. A layer mask is a grayscale image, so areas you 

paint in black are hidden, areas you paint in white are visible, and areas you paint in shades of gray appear in various 

levels of transparency. 

Background painted with black, description card painted with gray, basket painted with white 
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If you are using a layer mask to hide portions of a layer, you can apply the mask to discard the hidden portions. 

A vector mask creates a sharp-edged shape on a layer and is useful anytime you want to add a design element with 

clean, defined edges. After you create a layer with a vector mask, you can apply one or more layer styles to it, edit 

them if needed, and instantly have a usable button, panel, or other web-design element. 

See also 

“About masks and alpha channels” on page 338


To add a mask that shows or hides the entire layer

1 Choose Select > Deselect to clear any selection borders in the image.


2 In the Layers palette, select the layer or group.


3 Do one of the following:


•	 To  create  a mask that reveals  the entire layer, click  the New  Layer Mask  button in the  Layers  palette,  or  choose  

Layer > Layer Mask > Reveal All. 

•	 To create a mask that hides the entire layer, Alt-click (Windows) or Option-click (Mac OS) the New Layer Mask 

button, or choose Layer > Layer Mask > Hide All. 

To add a layer mask that shows or hides part of a layer

1 In the Layers palette, select the layer or group.


2 Select the area in the image, and do one of the following:


•	 Click the New Layer Mask button  in the Layers palette to create a mask that reveals the selection. 

•	 Choose Layer > Layer Mask > Reveal Selection or Hide Selection. 

To apply a layer mask from another layer 
❖ Do one of the following: 

•	 To move the mask to another layer, drag the mask to the other layer. 

•	 To duplicate the mask, Alt-drag (Windows) or Option-drag (Mac OS) the mask to other layer. 

To edit a layer mask 
1 Click the layer mask thumbnail in the Layers palette to make it active. A border appears around the mask 

thumbnail. 

2 Select any of the editing or painting tools. 

Note: The foreground and background colors assume default grayscale values when the mask is active. 

3	 Do one of the following: 

•	 To subtract from the mask and reveal the layer, paint the mask with white. 

•	 To make the layer partially visible, paint the mask with gray. 

•	 To add to the mask and hide the layer or group, paint the mask with black. 

To edit the layer instead of the layer mask, select it by clicking its thumbnail in the Layers palette. A border appears 

around the layer thumbnail. 
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To paste a copied selection into a layer mask, Alt-click (Windows) or Option-click (Mac OS) the layer mask 

thumbnail in the Layers palette to select and display the mask channel. Choose Edit > Paste, drag the selection in the 

image to produce the desired masking effect, and choose Select > Deselect. Click the layer thumbnail in the Layers palette 

to deselect the mask channel. 

To select and display the layer mask channel 
❖ Do one of the following: 

•	 Alt-click (Windows) or Option-click (Mac OS) the layer mask thumbnail to view only the grayscale mask. To 

redisplay the layers, Alt-click or Option-click the layer mask thumbnail, or click an eye icon. 

•	 Hold down Alt+Shift (Windows) or Option+Shift (Mac OS), and click the layer mask thumbnail to view the mask 

on top of the layer in a rubylith masking color. Hold down Alt+Shift or Option+Shift, and click the thumbnail 

again to turn off the color display. 

To disable or enable a layer mask 
❖ Do one of the following: 

•	 Shift-click the layer mask thumbnail in the Layers palette. 

•	 Select  the layer  containing  the layer  mask you  want  to  disable or enable,  and choose Layer  > Layer  Mask  > Disable  

or Layer > Layer Mask > Enable. 

A red X appears over the mask thumbnail in the Layers palette when the mask is disabled, and the layer’s content 

appears without masking effects. 

To change the rubylith display for a layer mask 
1 Do one of the following: 

•	 Alt-click (Windows) or Option-click (Mac OS) the layer mask thumbnail to select the layer mask channel; then 

double-click the layer mask thumbnail. 

•	 Double-click the layer mask channel in the Channels palette. 

2 To choose a new mask color, in the Layer Mask Display Options dialog box, click the color swatch and choose a 

new color. 

3	 To change the opacity, enter a value between 0% and 100%. 

Both  the color  and opacity  settings  affect  only  the appearance of the  mask  and have no effect on how  underlying  areas  

are protected. For example, you may want to change these settings to make the mask more easily visible against the 

colors in the image. 

4	 Click OK. 

To add a vector mask that shows or hides the entire layer 
1 In the Layers palette, select the layer to which you want to add a vector mask. 

2 Do one of the following: 

•	 To create a vector mask that reveals the entire layer, choose Layer > Vector Mask > Reveal All. 

•	 To create a vector mask that hides the entire layer, choose Layer > Vector Mask > Hide All. 
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To add a vector mask that shows the contents of a shape 
1 In the Layers palette, select the layer to which to add a vector mask. 

2 Select a path or use one of the shape or pen tools to draw a work path. 

3 Choose Layer > Vector Mask > Current Path. 

To edit a vector mask 
❖ Click the  vector  mask thumbnail  in  the Layers palette  or  the thumbnail  in  the Paths  palette.  Then  change  the shape  

using the shape and pen tools. 

To remove a vector mask 
❖ Do one of the following in the Layers palette: 

•	 Drag the vector mask thumbnail to the Delete icon . 

•	 (Photoshop) Select the layer containing the vector mask you want to delete, and choose Layer > Vector Mask > 

Delete. 

To disable or enable a vector mask 
❖ Do one of the following: 

•	 Shift-click the vector mask thumbnail in the Layers palette. 

•	 (Photoshop) Select the layer containing the vector mask you want to disable or enable, and choose Layer > Vector 

Mask > Disable or Layer > Vector Mask > Enable. 

A red X appears over the mask thumbnail in the Layers palette when the mask is disabled, and the layer’s content 

appears without masking effects. 

To convert a vector mask to a layer mask 
❖ Select the layer containing the vector mask you want to convert, and choose Layer > Rasterize > Vector Mask. 

Important: After you rasterize a vector mask, you can’t change it back into a vector object. 

Unlinking layers and masks 
By default, a layer or group is linked to its layer mask or vector mask, as indicated by the link icon between the 

thumbnails in the Layers palette. The layer and its mask move together in the image when you move either one with 

the Move tool. Unlinking them lets you move them independently and shift the mask’s boundaries separately from 

the layer. 

•	 To unlink a layer from its mask, click the link icon in the Layers palette. 

•	 To reestablish the link between a layer and its mask, click between the layer and mask path thumbnails in the 

Layers palette. 
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To apply or delete a layer mask 
When you finish creating a layer mask, you can either apply the mask and make the changes permanent or delete the


mask without applying changes. Because layer masks are stored as alpha channels, applying and deleting layer masks


can help reduce file size.


1 Click the layer mask thumbnail in the Layers palette.


2 To remove the layer mask and make changes permanent, click the Delete icon
  at the bottom of the Layers 

palette, and then click Apply (Photoshop) or Yes (ImageReady). 

3 To  remove  the layer  mask without  applying  the changes,  click the  Delete  icon  at  the bottom of the  Layers  palette,  

and then click Delete (Photoshop) or No (ImageReady). 

You can also apply or delete layer masks using the Layer menu. 

See also 

“To save a selection” on page 334 

To load a layer or layer mask’s boundaries as a selection 
By loading a layer mask, you can quickly select all the opaque areas on a layer—that is, the areas within the layer 

boundaries. This is useful when you want to exclude transparent areas from a selection. You can also load the bound

aries of a layer mask as a selection. 

❖ Do one of the following: 

•	 In the Layers palette, Ctrl-click (Windows) or Command-click (Mac OS) the layer thumbnail or layer mask 

thumbnail. 

•	 To add the pixels to an existing selection, press Ctrl+Shift (Windows) or Command+Shift (Mac OS), and click the 

layer thumbnail or layer mask thumbnail in the Layers palette. 

•	 To subtract the pixels from an existing selection, press Ctrl+Alt (Windows) or Command+Option (Mac OS), and 

click the layer thumbnail or layer mask thumbnail in the Layers palette. 

•	 To load the intersection of the pixels and an existing selection, press Ctrl+Alt+Shift (Windows) or 

Command+Option+Shift (Mac OS), and click the layer thumbnail or layer mask thumbnail in the Layers palette. 

If you want to move all the contents of a layer, use the Move tool without loading a transparency mask. 

Clipping masks 
You can use the content of a layer to mask the layers above it. The transparent pixels of the bottom or base layer mask 

the content  of  layers  above it that are  part  of  a  clipping mask. The content of the base layer clips (reveals), the content 

of the layers above it in the clipping mask. 
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Clipping mask with Potatoes and Logo layers 

You can  use multiple layers in a clipping  mask,  but they must be successive layers.  The name of the  base  layer in the  

mask is underlined, and the thumbnails for the overlying layers are indented. The overlying layers display a clipping 

mask icon . 

The Blend Clipped Layers As Group option in the Layer Style dialog box determines whether the blending mode of 

the base affects the whole group or just the base. (See “Grouping blend effects” on page 412.) 

To create a clipping mask 
1 Arrange the layers in the Layers palette so that the base layer with the mask is below the layers that you want to 

mask. 

2 Do one of the following: 

•	 Hold down Alt (Windows) or Option (Mac OS), position the pointer over the line dividing two layers in the Layers 

palette (the pointer changes to two overlapping circles ), and click. 

• Select a layer in the Layers palette, and choose Layer > Create Clipping Mask.


The clipping mask is assigned the opacity and mode attributes of the bottommost layer in the group.


To duplicate a clipping mask to another layer 
1 Select the clipping mask. 

2 Alt-click (Windows) or Option-click (Mac OS) the mask and drag it to the destination layer. Make sure the desti

nation layer is highlighted before you release the mouse button; otherwise, the layer won’t receive the mask properly. 

To remove a layer from a clipping mask 
❖ Do one of the following: 

•	 Hold down Alt (Windows) or Option (Mac OS), position the pointer over the line separating two grouped layers 

in the Layers palette (the pointer changes to two overlapping circles ), and click. 

•	 In the Layers palette, select a layer in the clipping mask, and choose Layer > Release Clipping Mask. This 

command removes the selected layer and any layers above it from the clipping mask. 

To release all layers in a clipping mask

1 In the Layers palette, select the base layer in the clipping mask.


2 Choose Layer > Release Clipping Mask.
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Chapter 15: Using channels and spot 
colors 

Channels 

About channels 
Channels are grayscale images that store different types of information: 

•	 Color information channels are created  automatically when you  open  a new  image.  The image’s  color mode deter

mines the  number  of  color channels created. For  example,  an  RGB image  has a channel for  each  color (red,  green,  

and blue) plus a composite channel used for editing the image. 

•	 Alpha channels store selections as grayscale images. You can add alpha channels to create and store masks, which 

let you manipulate or protect parts of an image. 

•	 Spot color channels specify additional plates for printing with spot color inks. 

An image can have up to 56 channels. The file size required for a channel depends on the pixel information in the 

channel. Certain file formats, including TIFF and Photoshop formats, compress channel information and can save 

space. The size of an uncompressed file, including alpha channels and layers, appears as the rightmost value in the 

status bar at the bottom of the window when you choose Document Sizes from the pop-up menu. 

Note: As long as you save a file in a format supporting the image’s color mode, the color channels are preserved. Alpha 

channels are preserved only when you save a file in Photoshop, PDF, PICT, Pixar, TIFF, or raw formats. DCS 2.0 format 

preserves only spot channels. Saving in other formats may cause channel information to be discarded. 

See also 

“About spot colors” on page 442 

“About masks and alpha channels” on page 338 

Channels in ImageReady 
In ImageReady, you can work with alpha channels created in Photoshop by loading selections from alpha channels 

saved in the image. You can also save selections as alpha channels in ImageReady, load those alpha channels as selec

tions, and delete alpha channels. ImageReady commands for working with alpha channels are under the Select menu. 

You can’t view individual color channels and alpha channels, or create spot color channels in ImageReady. If you need 

to do more complex channel operations, edit the image in Photoshop. 

About the Channels palette 
The Channels palette lets you create and manage channels. The palette lists all channels in the image—composite 

channel first (for RGB, CMYK, and Lab images). A thumbnail of the channel’s contents appears to the left of the 

channel name; the thumbnail is automatically updated as you edit the channel. 
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A 

B 

C 

Channel types. 
A. Color channels B. Spot channels C. Alpha channels 

You can use the palette to view any combination of channels in the document window. For example, you can view an 

alpha channel and the composite channel together to see how changes made in the alpha channel relate to the entire 

image. 

Individual channels are displayed in grayscale. In RGB, CMYK, or Lab images, you can view the individual channels 

in color. (In Lab images, only the a and b channels appear in color.) If more than one channel is active, the channels 

always appear in color. 

You can  change  the default  to  show  the individual color  channels  in  color.  When  a channel  is  visible in the  image,  an  

eye icon  appears to its left in the palette. 

In alpha channels, selected pixels appear as white; unselected pixels appear as black (partially selected pixels appear 

as gray). These are the channel default options. 

If  you display  an  alpha channel  at  the same time as color  channels, the  alpha channel  appears as a transparent color  

overlay, analogous to a printer’s rubylith or a sheet of acetate. To change the color of this overlay or set other alpha 

channel options, choose Channel options from the Channels palette menu. 

Viewing thumbnails is a convenient way of tracking channel contents; however, turning off the display of thumbnails 

can improve performance. 

To display the Channels palette, choose Windows > Channels. 

To resize or hide channel thumbnails, choose Palette Options from the Channels palette menu. Click a thumbnail 

size or click None to turn off the display of thumbnails. 

To show or hide a channel 
❖ Click in the eye column next to the channel to show or hide that channel. (Click the composite channel to view all 

default color channels. The composite channel is displayed whenever all the color channels are visible.) 

To show or hide multiple channels, drag through the eye column in the Channels palette. 
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To show color channels in color 
1 Do one of the following: 

•	 In Windows, choose Edit > Preferences > Display & Cursors. 

• In Mac OS, choose Photoshop > Preferences > Display & Cursors. 

2 Select Color Channels in Color, and click OK. 

To select and edit channels 
You can select one or more channels in the Channels palette. The names of all selected, or active, channels are 

highlighted. Any editing changes you make apply to the active channels. 

B 

A 

C 

D 

Selecting multiple channels 
A. Not visible or editable B. Visible but not selected for editing C. Selected for viewing and editing D. Selected for editing but not 
viewing 

•	 To select a channel, click the channel name. Shift-click to select (or deselect) multiple channels. 

•	 To edit a channel, use a painting or editing tool to paint in the image. Paint with white to add the selected channel’s 

color at 100% intensity. Paint with a value of gray to add the channel’s color at a lower intensity. Paint with black 

to fully remove the channel’s color. 

To rearrange and rename alpha and spot channels 
You can move alpha or spot channels above the default color channels only if the image is in Multichannel mode. 

•	 To change the order of alpha or spot channels, drag the channel up or down in the Channels palette. When a line 

appears in the position you want, release the mouse button. 

Note: Spot colors are overprinted in the order of their appearance from top to bottom, in the Channels palette. 

•	 To rename an alpha or spot channel, double-click the channel’s name in the Channels palette, and enter a new 

name. 

To duplicate a channel 
If you are duplicating alpha channels between images, the channels must have identical pixel dimensions. You cannot 

duplicate a channel to a Bitmap-mode image. 

1	 In the Channels palette, select the channel to duplicate. 

2	 Choose Duplicate Channel from the Channels palette menu. 
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3 Type a name for the duplicate channel. 

4 For Document, do one of the following: 

•	 Choose a destination. Only open images with pixel dimensions identical to the current image are available. To 

duplicate the channel in the same file, select the channel’s current file. 

•	 Choose New to copy the channel to a new image, creating a multichannel image containing a single channel. Type 

a name for the new image. 

5	 To reverse the selected and masked areas in the duplicate channel, select Invert. 

To duplicate a channel in an image

1 In the Channels palette, select the channel you want to duplicate.


2 Drag the channel onto the New Channel button
  at the bottom of the palette. 

To duplicate a channel in another image

1 In the Channels palette, select the channel you want to duplicate.


2 Make sure that the destination image is open.


Note: The destination image does not have to have the same pixel dimensions as the duplicated channel. 

3	 Do one of the following: 

•	 Drag the channel from the Channels palette into the destination image window. The duplicated channel appears 

at the bottom of the Channels palette. 

•	 Choose Select > All, and then choose Edit > Copy. Select the channel in the destination image and choose Edit > 

Paste. The pasted channel overwrites the existing channel. 

To split channels into separate images 
You can split channels of flattened images only. Splitting channels is useful when you want to retain individual 

channel information in a file format that doesn’t preserve channels. 

❖ To split channels into separate images, choose Split Channels from the Channels palette menu. 

The original file is closed, and the individual channels appear in separate grayscale image windows. The title bars in 

the new windows show the original file name plus the channel. You save and edit the new images separately. 

To merge channels 
Multiple grayscale images can be combined as the channels of a single image. The images you want to merge must 

be in Grayscale mode, have the same pixel dimensions, and be open. The number of grayscale images you have open 

determines the color modes available when merging channels. For example, if you have three images open, you can 

merge them into an RGB image, if you have four images open, they can become a CMYK image. 

If you are working with DCS files that have accidentally lost their links (and so cannot be opened, placed, or printed), 

open the channel files, and merge them into a CMYK image. Then resave the file as a DCS EPS file. 

1 Open the grayscale images containing the channels you want to merge, and make one of the images active. 

You must have more than one image open for the Merge Channels option to be available. 

2	 Choose Merge Channels from the Channels palette menu. 
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3 For Mode,  choose  the color  mode  you want to create.  The number of channels appropriate  for the  mode  appears  

in the Channels text box. 

4 If necessary, enter a number in the Channels text box. 

If you enter a number that is incompatible with the selected mode, Multichannel mode is automatically selected. This 

creates a multichannel image with two or more channels. 

5 Click OK. 

6 For each channel, make sure the image you want is open. If you change your mind about the image type, click


Mode to return to the Merge Channels dialog box.


7 If you are merging channels into a multichannel image, click Next, and select the remaining channels.


Note: All channels of a multichannel image are alpha channels or spot channels. 

8 When you are finished selecting channels, click OK. 

The selected channels are merged into a new image of the specified type, and the original images are closed without 

any changes. The new image appears in an untitled window. 

Note: You cannot split and recombine (merge) an image with spot color channels. The spot color channel will be added 

as an alpha channel. 

To delete a channel 
You may  want  to  delete  spot  or  alpha channels you  no  longer need before saving an image. Complex  alpha channels  

can substantially increase the disk space required for an image. 

1 In Photoshop, select the channel in the Channels palette and do one of the following: 

• Alt-click (Windows) or Option-click (Mac OS) the Delete icon . 

• Drag the channel name in the palette to the Delete icon.


• Choose Delete Channel from the Channels palette menu.


• Click the Delete icon at the bottom of the palette, and then click Yes.


2 In ImageReady, choose Select > Delete Channel, and choose the channel from the submenu.


Note: When you delete a color channel from a file with layers, visible layers are flattened and hidden layers are discarded. 

This is done because removing a color channel converts the image to Multichannel mode, which does not support layers. 

An image isn’t flattened when you delete an alpha channel, a spot channel, or a quick mask. 

Adding spot colors 

About spot colors 
Spot colors are special premixed inks used instead of, or in addition to, the process color (CMYK) inks. Each spot 

color requires its own plate on the press. (Because a varnish requires a separate plate, it is considered a spot color, 

too.) 

If you are planning to print an image with spot colors, you need to create spot channels to store the colors. To export 

spot channels, save the file in DCS 2.0 format or PDF. 

Note: ImageReady supports Photoshop spot color channels as alpha channels. 
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Note the following when working with spot colors: 

•	 For spot color graphics that have crisp edges and knock out the underlying image, consider creating the additional 

artwork in a page-layout or illustration application. 

•	 To apply spot color as a tint throughout an image, convert the image to Duotone mode and apply the spot color to 

one of the duotone plates. You can use up to four spot colors, one per plate. 

•	 The names of the spot colors are printed on the separations. 

•	 Spot colors are overprinted on top of the fully composited image. Each spot color is printed in the order it appears 

in the Channels palette, with the topmost channel printing as the topmost spot color. 

•	 You cannot move spot colors above a default channel in the Channels palette except in Multichannel mode. 

•	 Spot colors cannot be applied to individual layers. 

•	 Printing an image with a spot color channel to a composite color printer will print the spot color at an opacity 

indicated by the Solidity setting. 

•	 You can merge spot channels with color channels, splitting the spot color into its color channel components. 

See also 

“About channels” on page 438 

“Printing color separations” on page 722 

To create a new spot channel 
You can create a new spot channel or convert an existing alpha channel to a spot channel. 

1 Choose Window > Channels to display the Channels palette. 

2 To fill a selected area with a spot color, make or load a selection. 

3 Do one of the following to create a channel: 

•	 Ctrl-click (Windows) or Command-click (Mac OS) the New Channel button  in the Channels palette. 

• Choose New Spot Channel from the Channels palette menu.


If you made a selection, that area is filled with the currently specified spot color.


4 Click the color box, and choose a color. Click Color Libraries to choose from a custom color system such as 

PANTONE or TOYO. 

If you select a custom color, your print service provider can more easily provide the proper ink to reproduce the image. 

5 Enter a name  for the  spot  channel.  If  you choose a custom  color,  the channel  automatically takes  the name of that  

color. 

Be sure to name spot colors so they’ll be recognized by other applications reading your file. Otherwise the file might 

not print. 

6	 For Solidity, enter a value between 0% and 100%. 

This option lets you simulate on-screen the density of the printed spot color. A value of 100% simulates an ink that 

completely covers the inks beneath (such as a metallic ink); 0% simulates a transparent ink that completely reveals 

the inks beneath (such as a clear varnish). You can also use this option to see where an otherwise transparent spot 

color (such as a varnish) will appear. 
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Solidity at 100% and solidity at 50% 

Note: The Solidity and color choice options affect only the on-screen preview and the composite print. They have no effect 

on the printed separations. 

See also 

“Choosing custom colors” on page 246 

To convert an alpha channel to a spot channel 
1 Do one of the following: 

• Double-click the alpha channel thumbnail in the Channels palette.


• Select the alpha channel in the Channels palette, and choose Channel Options from the palette menu.


2 Select Spot Color.


3 Click the color box, choose a color in the Color Picker, or click Color Libraries and choose a custom color.


Click OK.


4 Rename the channel if needed.


5 Click OK.


The areas of the channel containing grayscale values are converted to spot color.


6 To apply the color to the selected area of the channel, choose Image > Adjustments > Invert. 

See also 

“To create a new spot channel” on page 443 

To edit a spot channel to add or remove color 
1 Select the spot channel in the Channels palette. 

2 Use a painting or editing tool to paint in the image. Paint with black to add more spot color at 100% opacity; paint 

with gray to add spot color with lower opacity. 

Note: Unlike the Solidity option in the Spot Channel Options dialog box, the Opacity option in the painting or editing 

tool’s options determines the actual density of ink used in the printed output. 
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To change a spot channel’s color or solidity 
1 Double-click the spot channel thumbnail in the Channels palette. 

2 Click the color box, and choose a color. Click Color Libraries to choose from a custom color system such as 

PANTONE or TOYO. 

See also 

“To create a new spot channel” on page 443 

“Choosing custom colors” on page 246 

To merge spot channels

1 Select the spot channel in the Channels palette.


2 Choose Merge Spot Channel from the palette menu.


The spot color is converted to and merged with the color channels. The spot channel is deleted from the palette.


Merging spot channels flattens layered images. The merged composite reflects the preview spot color information,


including the Solidity settings. For example, a spot channel with a solidity of 50% will produce different merged


results than the same channel with a solidity of 100%.


In addition, the resulting merged spot channels usually don’t reproduce the same colors as the original spot channels,


because CMYK inks can’t represent the range of colors available from spot color inks.


To adjust overlapping spot colors 
To prevent overlapping spot colors from either printing over or knocking out the underlying spot color, remove one 

of the spot colors where they overlap. 

Use a printed sample of the overprinted inks to adjust your screen display to help you predict how colors will look 

when printed. 

Note: In some cases, such as when you use varnish and bump plates, you may want colors to overprint. 

1 In the Channels palette, select the spot channel with the color you want to print. 

2 Choose Select > Load Selection. 

To quickly select an image in a channel, hold down Ctrl (Windows) or Command (Mac OS), and click the channel 

in the Channels palette. 

3 For Channel, choose the spot channel from step 1, and click OK. 

4 To create a trap when knocking out the underlying color, choose Select > Modify > Expand or Contract, 

depending on whether the overlapping spot color is darker or lighter than the spot color beneath it. In the Channels 

palette, select the underlying spot channel that contains areas you want to knock out. Press Backspace (Windows) or 

Delete (Mac OS). 

This method can be used to knock out areas from any channels under a spot color, such as the CMYK channels. 

5 If a spot color in one channel overlaps more than one other spot color, repeat this process for each channel that 

contains areas you want removed. 
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See also 

“Creating color traps” on page 724 

Channel calculations 

Blending layers and channels 
You can use the blending effects associated with layers to combine channels within and between images into new 

images. You can use either the Apply Image command (on single and composite channels) or the Calculations 

command (on single channels). These commands offer two additional blending modes not available in the Layers 

palette—Add and Subtract. Although it’s possible to create new combinations of channels by copying channels into 

layers in the Layers palette, you may find it quicker to use the calculation commands to blend channel information. 

The calculation commands perform mathematical operations on the corresponding pixels of two channels (the 

pixels with identical locations on the image) and then combine the results in a single channel. Two concepts are 

fundamental to understanding how the calculation commands work. 

•	 Each pixel in a channel has a brightness value. The Calculations and Apply Image commands manipulate these 

values to produce the resulting composite pixels. 

•	 These commands overlay  the pixels in two  or  more  channels. Thus,  the images used for  calculations  must  have  the  

same pixel dimensions. 

To use the Apply Image command 
The Apply Image command lets you blend one image’s layer and channel (the source) with a layer and channel of the 

active image (the destination). 

1 Open the source and destination images, and select the desired layer and channel in the destination image. The 

pixel dimensions of the images must match for image names to appear in the Apply Image dialog box. 

Note: If the color modes of the two images differ (for example, one image is RGB and the other is CMYK), you can copy 

a single channel to another channel between images, but you cannot copy a composite channel to a composite channel in 

another image. 

2	 Choose Image > Apply Image. 

3 Choose the source image, layer, and channel you want to combine with the destination. To use all layers in the


source image, select Merged for Layer.


4 To preview the results in the image window, select Preview.


5 To use the negative of the channel contents in the calculation, select Invert.


6 For Blending, choose a blending option.


For information on the Add and Subtract options, see “About the Add and Subtract blending modes” on page 447.


For information on other blending options, see “List of blending modes” on page 487.


7	 Enter an Opacity value to specify the effect’s strength.
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8 To apply the results only to opaque areas in the result layer, select Preserve Transparency. 

9 If you want to apply the blending through a mask, select Mask. Then choose the image and layer containing the 

mask. For Channel, you can choose any color or alpha channel to use as the mask. You can also use a mask based on 

the active selection or the boundaries of the chosen layer (Transparency). Select Invert to reverse the masked and 

unmasked areas of the channel. 

To use the Calculations command 
The Calculations command lets you blend two individual channels from one or more source images. You can then 

apply the results to a new image or to a new channel or selection in the active image. You cannot apply the Calcula

tions command to composite channels. 

1 Open the source image or images. 

Note: If you are using more than one source image, the images must have the same pixel dimensions. 

2 Choose Image > Calculations.


3 To preview the results in the image window, select Preview.


4 Choose the first source image, layer, and channel. To use all the layers in the source image, choose Merged for


Layer.


5 To use the negative of the channel contents in the calculation, select Invert. For Channel, choose Gray if you want


to duplicate the effect of converting the image to grayscale.


6 Choose the second source image, layer, and channel, and specify options.


7 For Blending, choose a blending mode.


For information on the Add and Subtract options, see “About the Add and Subtract blending modes” on page 447.


For information on other blending options, see “List of blending modes” on page 487.


8 Enter an Opacity value to specify the effect’s strength.


9 If you want to apply the blending through a mask, select Mask. Then choose the image and layer containing the


mask. For Channel, you can choose any color or alpha channel to use as the mask. You can also use a mask based on


the active selection or the boundaries of the chosen layer (Transparency). Select Invert to reverse the masked and


unmasked areas of the channel.


10 For Result, specify whether to place the blending results in a new document or in a new channel or selection in


the active image.


About the Add and Subtract blending modes 
The Add and Subtract blending modes are available only for the Apply Image and Calculations commands. 

Add 

Adds the pixel values in two channels. This is a good way to combine nonoverlapping images in two channels. 

Because higher pixel values represent lighter colors, adding channels with overlapping pixels lightens the image. 

Black areas in both channels remain black (0 + 0 = 0). White in either channel results in white (255 + any value = 255 

or greater). 

Add mode divides the sum of the pixel values by the Scale amount and then adds the Offset value to the sum. For 

example, to find the average of the pixels in two channels, add them, divide by 2, and enter no Offset value. 

The Scale factor may be any number between 1.000 and 2.000. Entering a higher Scale value darkens the image. 
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The Offset value lets you lighten or darken the pixels in the destination channel by any brightness value between 

+255 and –255. Negative values darken the image; positive values lighten the image. 

Subtract 

Subtracts the pixel values in the source channel from the corresponding pixels in the target channel. As with Add 

mode, the result is then divided by the Scale factor and added to the Offset value. 

The Scale factor may be any number between 1.000 and 2.000. The Offset value lets you lighten or darken the pixels 

in the destination channel by any brightness value between +255 and –255. 
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Chapter 16: Drawing


About vector graphics 

About shapes and paths 
Vector shapes are lines and curves that you draw using the shape or pen tools. Vector shapes are resolution-

independent—they maintain crisp edges when resized, printed to a PostScript printer, saved in a PDF file, or 

imported into a vector-based graphics application. 

Paths are outlines that you can turn into selections, or fill and stroke with color. The outline of a shape is a path. You 

can easily change the shape of a path by editing its anchor points. You can draw shapes in ImageReady, but you can’t 

work directly with paths. 

When you work with the shape tools in Photoshop, you can draw in three different modes. You choose a mode by 

selecting an icon in the options bar when you have a shape or pen tool selected. 

Shape Layers Creates a shape on a separate  layer.  You can  use either the  shape tools  or  the pen  tools to create shape  

layers. Because they are easily moved, resized, aligned, and distributed, shape layers are ideal for making graphics for 

web pages. In Photoshop, you  can choose to draw multiple shapes on a layer.  A shape  layer consists of a fill  layer that  

defines the shape color and a linked vector mask that defines the shape outline. The outline of a shape is a path, which 

appears in the Paths palette. 

Paths Draws a work path on the current layer that you can then use to make a selection, create a vector mask, or fill 

and stroke with color to create raster graphics (much as you would using a painting tool). A work path is temporary 

unless you save it. Paths appear in the Paths palette. 

Fill Pixels Paints directly on a layer—much as a painting tool does. When you work in this mode, you are not 

creating vector graphics. You work with the shapes you paint just as you do with any raster image. The Pen tools don't 

work in this mode. 

A B C  

Drawing options 
A. Shape Layers B. Paths C. Fill Pixels 

See also 

“About work paths” on page 450 
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About work paths 
A work path is a temporary path that appears in the Paths palette and defines the outline of a shape. You can use paths 

in several ways: 

• Use a path as a vector mask to hide areas of a layer. (See “Masking layers” on page 432.) 

• Convert a path to a selection. (See “Converting paths to selection borders” on page 467.) 

• Fill or stroke a path with color. (See “Filling and stroking paths with color” on page 469.) 

Designate a saved path as a clipping path to make part of an image transparent when exporting the image to a page

layout or vector-editing application. (See “Using image clipping paths to create transparency” on page 701.) 

Drawing shapes 

To create a shape on a shape layer 
1 Select a shape tool or a Pen tool. Make sure that the Shape Layers button  is selected in the options bar. 

2 To choose the color of the shape, click the color swatch in the options bar, and then choose a color from the Color


Picker.


3 (Optional) Set tool options in the options bar. In Photoshop, click the inverted arrow next to the shape buttons to


view additional options for each tool. (See “Shape tool options” on page 452.)


4 (Optional) To apply a style to the shape, select a preset style from the Style pop-up menu in the options bar. (See


“To apply a preset style to a layer” on page 415.)


5 Drag in your image to draw a shape.


Hold down Shift to constrain a rectangle or rounded rectangle to a square, to constrain an ellipse to a circle, or to 

constrain the line angle to a multiple of 45˚. 

See also 

“To edit a shape” on page 453 

“Drawing and type tools gallery” on page 44 

To draw a custom shape 
1 Select the Custom Shape tool. 

2 Select a shape from the Custom Shape pop-up palette in the options bar. 

If you don’t find a shape you want in the palette, click the arrow in the upper right corner of the palette, and choose 

a different category of shapes. When asked to replace current shapes, click either Replace to view only the shapes in 

the new category or Append to add to the shapes already displayed. 

3 Drag in your image to draw the shape. 
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To draw a wheel shape 
You cut out a shape within an existing shape so that the layers underneath show through. This procedure shows you 

how to create a doughnut shape, but you can use this technique with any combination of the shape tools, including 

custom shapes. 

1 Select the Ellipse tool  in the toolbox. It may be hidden by one of the other shape tools or the Line tool . 

2 In the options bar at the top of the work area, select the Shape Layer button 

3 Drag in the document window to draw the shape. Hold down the Shift key while dragging to constrain the ellipse 

. 

to a circle.


4 In the options bar, select the Subtract From Shape Area button


5 Drag within the new shape to create the cutout. When you release the mouse, the image underneath the new shape


. 

shows through.


6 To reposition either shape, click the Path Selection tool
 in the toolbox (it may be hidden by the Direct Selection 

tool ), and select the path. Drag it to its new location or use the arrow keys on the keyboard to nudge it a pixel at 

a time. 

Shift-click to select more than one path. 

See also 

“To create a shape on a shape layer” on page 450 

To draw multiple shapes in a layer 
You can draw separate shapes on a layer, or use the Add, Subtract, Intersect, or Exclude options to modify the current


shape on a layer.


1 Select the layer to which you want to add shapes.


2 Select a drawing tool and set tool-specific options (see “Shape tool options” on page 452).


3 Choose one of the following in the options bar:


Add To Shape Area
 Adds the new area to the existing shapes or path. 

Subtract From Shape Area Removes the overlapping area from the existing shapes or path. 

Intersect Shape Areas Restricts the area to the intersection of the new area and the existing shapes or path. 

Exclude Overlapping Shape Areas Excludes the overlap area in the consolidated new and existing areas. 

4 Draw in the image. You can easily switch between drawing tools by clicking a tool button in the options bar. 

See also 

“To edit a shape” on page 453 

To select a custom shape 
1 Select the Custom Shape tool 

2 Select a shape from the Shape pop-up palette in the options bar. 

. 
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To save a shape or path as a custom shape

1 In the Paths palette, select a path—either a vector mask for a shape layer, a work path, or a saved path.


2 Choose Edit > Define Custom Shape, and enter a name for the new custom shape in the Shape Name dialog box.


The new shape appears in the Shape pop-up palette.


3 To save the new custom shape as part of a new library, select Save Shapes from the pop-up palette menu.


See also 

“About the Preset Manager” on page 67 

To create a rasterized shape 
You can create a rasterized shape by making a selection and filling it with the foreground color. You cannot edit a 

rasterized shape as a vector object. Raster shapes are created using the current foreground color. 

1 Select a layer. You cannot create a rasterized shape on a vector-based layer (for example, a type layer). 

2 Select a shape tool, and click the Fill Pixels button  in the options bar.


3 Set the following options in the options bar:


Mode Controls how the shape will affect the existing pixels in the image. (See “List of blending modes” on page 487.)


Opacity Determines to what degree the shape will obscure or reveal the pixels beneath it. A shape with 1% opacity 

appears nearly transparent, while one with 100% opacity appears completely opaque. 

Anti-Aliased Blends the edge pixels with the surrounding pixels. 

4 Set additional tool-specific options. See “Shape tool options” on page 452. 

5 Draw the shape. 

To create a rasterized shape (ImageReady) 
1 Select a layer that contains the shape you want to rasterize. 

2 Choose Layer > Rasterize > Shape. 

Shape tool options 
Arrowheads Start And End Adds arrowheads to a line. Select the Line tool and then select Start to add an arrow to 

the beginning of the line; select End to add an arrow to the end of the line. Select both options to add arrows on both 

ends. In ImageReady, click Shape to define the shape of the arrowhead; in Photoshop, the shape options appear in 

the pop-up dialog box. Enter values for Width and Length to specify the proportions of the arrowhead as a 

percentage of the line width (10% to 1000% for Width, and 10% to 5000% for Length). Enter a value for the concavity 

of the arrowhead (from –50% to +50%). The concavity value defines the amount of curvature on the widest part of 

the arrowhead, where the arrowhead meets the line. 

Note: In Photoshop, you can also edit an arrowhead directly using the vector selection and drawing tools. 

Circle (Photoshop) Constrains an ellipse to a circle. 

Corner Radius (ImageReady) Specifies the corner radius for rendering a rounded rectangle or tab rectangle. 

Defined Proportions (Photoshop) Renders a custom shape based on the proportions with which it was created. 

Defined Size (Photoshop) Renders a custom shape based on the size at which it was created. 
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Fixed Size Renders a rectangle, rounded rectangle, ellipse, or custom shape as a fixed shape based on the values you 

enter in the Width and Height text boxes. 

From Center (Photoshop) Renders a rectangle, rounded rectangle, ellipse, or custom shape from the center. 

Indent Sides By (Photoshop) Renders a polygon as a star. Enter  a percentage in the  text  box to specify the  portion  

of the star’s radius taken up by the points. A 50% setting creates points that are half the total radius of the star; a larger 

value creates sharper, thinner points; a smaller value creates fuller points. 

Proportional (Photoshop) Renders a rectangle,  rounded rectangle, or ellipse  as  a proportional shape  based on the  

values you enter in the Width and Height text boxes.


Radius (Photoshop) For rounded rectangles, specifies the corner radius. For polygons, specifies the distance from


the center of a polygon to the outer points.


Sides (Photoshop) Specifies the number of sides in a polygon.


Smooth Corners or Smooth Indents (Photoshop) Renders a polygon with smooth corners or indents.


Snap To Pixels (Photoshop) Snaps edges of a rectangle or rounded rectangle to the pixel boundaries.


Square (Photoshop) Constrains a rectangle or rounded rectangle to a square.


Unconstrained (Photoshop) Lets you set the width and height of a rectangle, rounded rectangle, ellipse, or custom


shape by dragging.


Weight Determines the width, in pixels, of a line.


To edit a shape 
A shape is a fill layer linked to a vector mask. You can easily change the fill to a different color, a gradient, or a pattern 

by editing the shape’s fill layer. You can also edit the shape’s vector mask to modify the shape outline, and apply a style 

to the layer. 

For information on transforming shapes in ImageReady, see “To transform freely” on page 363. 

•	 To change the color of a shape, double-click the shape layer’s thumbnail in the Layers palette, and choose a 

different color using the color picker. 

•	 To  fill  a shape  with  a pattern  or  gradient, select a shape layer  in  the Layers palette  and choose Layer  > Change  Layer  

Content > Gradient, and set gradient options. 

•	 To  fill  a shape  with  a pattern  or  gradient, select a shape layer  in  the Layers palette  and choose Layer  > Change  Layer  

Content > Pattern, and set pattern options. 

•	 To modify the outline of a shape, click the shape layer’s vector mask thumbnail in the Layers palette or Paths 

palette. Then change the shape using the shape and pen tools. 

•	 To move a shape without changing its size or proportions, hold down the spacebar while you drag the shape. 

See also 

“Adjusting path components” on page 464 

“Adjustment layers and fill layers” on page 423 

“The Free Transform command” on page 363 
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Pen tools 

To draw with the Pen tool 
The Pen tool creates straight lines and smooth flowing curves. You can use the pen tool in conjunction with the shape 

tools to create complex shapes. 

1 Select the Pen tool 

2 Set the following tool-specific options: 

. 

•	 To add an anchor point when you click a line segment or delete an anchor point when you click it, select Auto 

Add/Delete in the options bar. 

•	 To preview path segments as you draw, click the inverted arrow next to the shape buttons in the options bar, and 

select Rubber Band. 

3 Position the pen pointer where you want to begin to draw, and click to define the first anchor point. 

4 Click or drag to set anchor points for additional segments. 

5 Complete the path: 

•	 To end an open path, Ctrl-click (Windows) or Command-click (Mac OS) away from the path. 

•	 To close a path, position the pen pointer over the first anchor point. A small loop appears next to the pen tip when 

it is positioned correctly. Click to close the path. 

Create a new path in the Paths palette before you begin drawing to automatically save the work path as a named 

path. 

See also 

“Path segments, components, and points” on page 460


“To create a new work path” on page 459


To draw straight segments

1 Position the pen pointer where you want the straight segment to begin, and click to define the first anchor point.


2 Click again where you want the first segment of the straight line to end, or Shift-click to constrain the angle of the


segment to a multiple of 45˚.


3 Continue clicking to set anchor points for additional segments. The last anchor point is always a solid square,


indicating it is selected. Previously defined anchor points become hollow squares as you add further anchor points.


If the Auto Add/Delete option is selected in the options bar, you can click an existing point to delete it. 
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Drawing curves with the Pen tool 
You create curves by dragging the Pen tool in the direction you want the curve to go. Keep these guidelines in mind 

when drawing curves: 

•	 Always drag the first direction point in the direction of the bump of the curve, and drag the second direction point 

in the opposite direction to create a single curve. Dragging both direction points in the same direction creates an 

“S” curve. 

Drag in the opposite direction to create a smooth curve. Drag in the same direction to create an “S” curve. 

•	 When drawing a series of smooth curves, draw one curve at a time, placing anchor points at the beginning and 

end of each curve, not at the tip of the curve. 

•	 To decrease the file size and reduce the potential for printing errors, use as few anchor points as possible, and place 

them as far apart as possible. 

See also 

“Path segments, components, and points” on page 460 

To draw a curve 
1 Position the pointer where you want the curve to begin, and hold down the mouse button. The first anchor point 

appears. 

2 Drag in the direction you want the curve segment to be drawn. See “Drawing curves with the Pen tool” on 

page 455. 

Hold down the Shift key to constrain the tool to multiples of 45˚, and release the mouse button after you position the 

first direction point. 

The length and  slope of the  direction  line determine  the shape  of  the curve  segment.  You can  adjust  one or both sides  

of the direction line later. 

Drag in the direction of the curve to set the first anchor point. Drag in the opposite direction to complete the curve segment. 
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3 Position the pointer where you want the curve segment to end, and drag in the opposite direction to complete the 

segment. 

4	 Do one of the following: 

•	 To draw the next segment of a smooth curve, position the pointer where you want the next segment to end, and 

drag away from the curve. 

Drag away from the curve to create the next segment. 

•	 To change the direction of the curve sharply, release the mouse button, and then Alt-drag (Windows) or Option

drag (Mac OS) the direction point in the direction of the curve. Release the Alt (Windows) or Option (Mac OS) 

key and the mouse button, reposition the pointer where you want the segment to end, and drag in the opposite 

direction to complete the curve segment. 

•	 To break out the direction lines of an anchor point, Alt-drag (Windows) or Option-drag (Mac OS) the lines. 

Alt-drag or Option-drag the direction point toward the curve. Release the key, and drag in the opposite direction. 

To draw with the Freeform Pen tool 
The Freeform Pen tool lets you draw as if you were drawing with a pencil on paper. Anchor points are added automat

ically as you draw. You do not determine where the points are positioned, but you can adjust them once the path is 

complete. To draw with greater precision, use the Pen tool. 

1	 Select the Freeform Pen tool . 

2 To control how sensitive the final path is to the movement of your mouse or stylus, click the inverted arrow next 

to the shape buttons in the options bar, and enter a value between 0.5 and 10.0 pixels for Curve Fit. A higher value 

creates a simpler path with fewer anchor points. 

3 Drag the pointer in the image. As you drag, a path trails behind the pointer. When you release the mouse, a work 

path is created. 

4	 To continue the existing freehand path, position the pen pointer on an endpoint of the path, and drag. 

5 To complete the path, release the mouse. To create a closed path, drag the line to the initial point of the path (a 

circle appears next to the pointer when it is aligned). 
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See also 

“Path segments, components, and points” on page 460 

To draw using the magnetic pen options 
The Magnetic Pen is an option of the Freeform Pen tool that lets you draw a path that snaps to the edges of defined 

areas in your image. You can define the range and sensitivity of the snapping behavior, as well as the complexity of 

the resulting path. The Magnetic Pen and Magnetic Lasso tools share many of the same options. 

1	 To convert the Freeform Pen tool to the Magnetic Pen tool , select Magnetic in the options bar, or click the 

inverted arrow next to the shape buttons in the options bar, select Magnetic, and set the following: 

•	 For Width, enter a pixel value between 1 and 256. The Magnetic Pen detects edges only within the specified 

distance from the pointer. 

•	 For Contrast, enter a percentage value between 1 and 100 to specify the contrast required between pixels for that 

area to be considered an edge. Use a higher value for low-contrast images. 

•	 For Frequency, enter a value between 0 and 100 to specify the rate at which the Pen sets anchor points. A higher 

value anchors the path in place more quickly. 

•	 If you are working with a stylus tablet, select or deselect Pen Pressure. When this option is selected, an increase in 

pen pressure causes the width to decrease. 

2	 Click in the image to set the first fastening point. 

3	 To draw a freehand segment, move the pointer or drag along the edge you want to trace. 

The most recent segment of the border remains active. As you move the pointer, the active segment snaps to the 

strongest edge in the image, connecting the pointer to the last fastening point. Periodically, the Magnetic Pen adds 

fastening points to the border to anchor previous sections. 

Click to add fastening points, and continue tracing. 

4 If  the border doesn’t  snap  to  the desired  edge, click  once  to  add a fastening point  manually  and to keep the  border  

from moving. Continue to trace the edge and add fastening points as needed. If you make a mistake, press Delete to 

remove the last fastening point. 
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5	 To dynamically modify the properties of the Magnetic Pen, do one of the following: 

•	 Alt-drag (Windows) or Option-drag (Mac OS) to draw a freehand path. 

•	 Alt-click (Windows) or Option-click (Mac OS) to draw straight segments. 

•	 Press the open square bracket key ([) to decrease the Magnetic Pen width by 1 pixel; press the close square bracket 

key (]) to increase the pen width by 1 pixel. 

6	 Complete the path: 

•	 Press Enter (Windows) or Return (Mac OS) to end an open path. 

•	 Double-click to close the path with a magnetic segment. 

•	 Hold down Alt (Windows) or Option (Mac OS), and double-click to close the path with a straight segment. 

Paths 

About the Paths palette 
The Paths palette lists the name and a thumbnail image of each saved path, the current work path, and the current 

vector mask. Turning thumbnails off can improve performance. To view a path, you must first select it in the Paths 

palette. 

•	 To display the Paths palette, choose Window > Paths. 

•	 To select a path, click the path name in the Paths palette. Only one path can be selected at a time. 

•	 To deselect a path, click in the blank area of the Paths palette or press Esc. 

•	 To change the size of path thumbnails, choose Palette Options from the Paths palette menu and select a size, or 

select None to turn off the display of thumbnails. 

•	 To change a path’s stacking order, select the path in the Paths palette and drag the path up or down. When the 

heavy black line appears in the desired location, release the mouse button. 

Note: You cannot change the order of vector masks or working paths in the Paths palette. 

Managing paths 
When you use a pen or shape tool to create a work path, the new path appears as the work path in the Paths palette. 

The work path is temporary; you must save it to avoid losing its contents. If you deselect the work path without saving 

it and start drawing again, a new path will replace the existing one. 

When you use a pen or shape tool to create a new shape layer, the new path appears as a vector mask in the Paths 

palette. Vector masks are linked to their parent layer; you must select the parent layer in the Layers palette in order 

to list the clipping path in the Paths palette. You can remove a clipping path from a layer and convert a clipping path 

to a rasterized mask. For more information, see “To edit a vector mask” on page 435. 

Paths saved with an image appear when you open it again. In Windows, the Photoshop, JPEG, JPEG 2000, DCS, EPS, 

PDF, and TIFF formats support paths. In Mac OS, all available file formats support paths. 

Note: Paths in formats other than those listed here generally don’t survive a transition from Mac OS to Windows and 

back to Mac OS. 
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A 

B 

C 

Paths palette 
A. Saved path B. Temporary work path C. Vector mask path (appears only when shape layer is selected) 

To create a new path in the Paths palette 
•	 To create a path without naming it, click the New Path button  at the bottom of the Paths palette. 

•	 To create and name a path, make sure no work path is selected. Choose New Path from the Paths palette menu, or 

Alt-click (Windows) or Option-click (Mac OS) the New Path button at the bottom of the palette. Enter a name for 

the path in the New Path dialog box, and click OK. 

To create a new work path 
1 Select a shape tool or a pen tool, and click the Paths button  in the options bar. 

2 Set tool-specific options, and draw the path. For more information, see “Shape tool options” on page 452 and “To 

draw with the Pen tool” on page 454. 

3 Draw additional path components if desired. You can easily switch between drawing tools by clicking a tool button 

in the options bar. Choose a path area option to determine how overlapping path components intersect: 

Add To Path Area Adds the new area to overlapping path areas. 

Subtract From Path Area Removes the new area from the overlapping path area. 

Intersect Path Areas Restricts the path to the intersection of the new area and the existing area. 

Exclude Overlapping Path Areas Excludes the overlap area in the consolidated path. 

While drawing with a shape tool, hold down Shift to temporarily select the Add To Path Area option; hold down Alt 

(Windows) or Option (Mac OS) to temporarily select the Subtract From Path Area option. 

To save a work path 
•	 To save without renaming, drag the work path name to the New Path button at the bottom of the Paths palette. 

•	 To save and rename, choose Save Path from the Paths palette menu, enter a new path name in the Save Path dialog 

box, and click OK. 

To rename a saved path 
❖ Double-click the path name in the Paths palette, type a new name, and press Enter (Windows) or Return 

(Mac OS). 
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To delete a path

1 Click the path name in the Paths palette.


2 Do one of the following:


• Drag the path to the Delete icon  at the bottom of the Paths palette. 

• Choose Delete Path from the Paths palette menu. 

• Click the Delete icon at the bottom of the Paths palette, and click Yes. 

To delete a path without being asked to confirm, Alt-click (Windows) or Option-click (Mac OS) the Delete icon at 

the bottom of the Paths palette. 

Editing paths 

Path segments, components, and points 
A path consists of one or more straight or curved segments. Anchor points mark the endpoints of the path segments. 

On curved segments, each selected anchor point displays one or two direction lines, ending in direction points. The 

positions of direction lines and points determine the size and shape of a curved segment. Moving these elements 

reshapes the curves in a path. 

E 

A B 

C 

D 

A path 
A. Curved line segment B. Direction point C. Direction line D. Selected anchor point E. Unselected anchor point 

A path can  be  closed, with no beginning or end (for example, a circle), or open, with distinct  endpoints (for example, 

a wavy line). 

Smooth curves are connected by anchor points called smooth points. Sharply curved paths are connected by corner 

points. 

Smooth point and corner point 

When you move a direction line on a smooth point, the curved segments on both sides of the point are adjusted 

simultaneously. By comparison, when you move a direction line on a corner point, only the curve on the same side 

of the point as the direction line is adjusted. 
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Adjusting a smooth point and a corner point

A path does not have to be one connected series of segments. It can contain more than one distinct and separate path

components. Each shape in a shape layer is a path component, as described by the layer’s clipping path.

Separate path components selected

To select a path
Selecting a path component or path segment displays all of the anchor points on the selected portion, including any

direction lines and direction points if the selected segment is curved. Direction points appear as filled circles, selected

anchor points as filled squares, and unselected anchor points as hollow squares.

1 Do one of the following:

• To select a path component (including a shape in a shape layer), select the Path Selection tool , and click

anywhere inside the path component. If a path consists of several path components, only the path component

under the pointer is selected.

To display the bounding box along with the selected path, select Show Bounding Box in the options bar.

• To select a path segment, select the Direct Selection tool , and click one of the segment’s anchor points or drag

a marquee over part of the segment.
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Drag a marquee to select segments.

2 To select additional path components or segments, select the Path Selection tool or the Direct Selection tool, and

then hold down Shift while selecting additional paths or segments.

When the Direct Selection tool is selected, you can select the entire path or path component by Alt-clicking (Windows)

or Option-clicking (Mac OS) inside the path. To activate the Direct Selection tool when most other tools are selected,

position the pointer over an anchor point, and press Ctrl (Windows) or Command (Mac OS).

To change the overlap mode for the selected path component
1 Using the Path Selection tool , drag a marquee to select existing path areas.

2 Choose a shape area option in the options bar:

Add To Shape Area Adds the path area to overlapping path areas.

Subtract From Shape Area Removes the path area from overlapping path areas.

Intersect Shape Areas Restricts the area to the intersection of the selected path area and overlapping path areas.

Exclude Overlapping Shape Areas Excludes the overlap area.

To show or hide the selected path component
Do one of the following:

• Choose View > Show > Target Path.

• Choose View > Extras. This command also shows or hides a grid, guides, selection edges, annotations, and slices.

Adjusting path segments
You can also apply a transformation, such as scaling, rotating, flipping, or distorting, to a segment or anchor point.

See also

“Applying transformations” on page 360

To move a straight path segment
1 Select the Direct Selection tool , and select the segment you want to adjust. To adjust the angle or length of the

segment, select an anchor point.

2 Drag the selected segment to its new position.
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To move a curved segment 
1 Select the Direct Selection tool , and select the points or segments you want to move. Be sure to select both 

points anchoring the segment. 

2 Drag the selected anchor points or segments to new positions. Hold down Shift as you drag to constrain the 

movement to multiples of 45˚. 

Select points anchoring a curve. Then drag to move the curve. 

To reshape a curved segment 
1 Select the Direct Selection tool , and select the curved segment you want to adjust. Direction lines appear for 

that segment. 

2	 Adjust the curve: 

•	 To adjust the position of the segment, drag the segment. 

Click to select the curve segment. Then drag to adjust. 

•	 To adjust the shape of the segment on either side of a selected anchor point, drag the anchor point or the direction 

point. Hold down Shift as you drag to constrain movement to multiples of 45˚. 

Drag the anchor point, or drag the direction point. 

Note: You can also apply a transformation, such as scaling, rotating, flipping, or distorting, to a segment or anchor point. 

See “Applying transformations” on page 360. 
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To delete a segment 
1 Select the Direct Selection tool , and select the segment you want to delete. 

2 Press Backspace (Windows) or Delete (Mac OS) to delete the selected segment. Pressing Backspace or Delete 

again erases the rest of the path component. 

Adjusting path components 
You can reposition a path component (including a shape in a shape layer) anywhere within an image. You can copy 

components within an image or between two Photoshop images. Using the Path Selection tool, you can merge 

overlapping components into a single component. All vector objects, whether they are described by a saved path, a 

work path, or a vector mask, can be moved, reshaped, copied, or deleted. 

You can also use the Copy and Paste commands to duplicate vector objects between a Photoshop image and an image 

in another application, such as Adobe Illustrator. 

See also 

“Path segments, components, and points” on page 460 

To move a path or path component 
1 Select the path name in the Paths palette, and use the Path Selection tool  to select the path in the image. To 

select multiple path components, Shift-click each additional path component to add it to the selection. 

2 Drag the path to its new location. If you move any part of a path beyond the canvas boundaries, the hidden part 

of the path is still available. 

Dragging a path to a new location 

Note: If you drag a path so that the move pointer is over another open image, the path is copied to that image. 

To reshape a path component 
1 Select  the path name in the  Paths palette, and  use the  Direct  Selection tool  to select an anchor point  in  the path.  

2 Drag the point or its handles to a new location. 

To merge overlapping path components 
1 Select the path name in the Paths palette, and select the Path Selection tool . 

2 Click Combine in the options bar to create a single component from all overlapping components. 

 



465 ADOBE PHOTOSHOP CS2 
User Guide 

To copy a path component or path 
Do any of the following: 

•	 To copy a path component as you move it, select the path name in the Paths palette, and click a path component 

with the Path Selection tool . Then Alt-drag (Windows) or Option-drag (Mac OS) the selected path. 

•	 To copy a path without renaming it, drag the path name in the Paths palette to the New Path button  at the 

bottom of the palette. 

•	 To copy and rename a path, Alt-drag (Windows) or Option-drag (Mac OS) the path in the Paths palette to the New 

Path button at the bottom of the palette. Or select the path to copy, and choose Duplicate Path from the Paths 

palette menu. Enter a new name for the path in the Duplicate Path dialog box, and click OK. 

•	 To copy a path or path component into another path, select the path or path component you want to copy, and 

choose Edit > Copy. Then select the destination path, and choose Edit > Paste. 

To copy path components between two Photoshop files

1 Open both images.


2 In  the source image, use  the Path Selection  tool 
 to  select  the entire path or the  path  components  that  you want  

to copy. 

3	 To copy the path component, do any of the following: 

•	 Drag the path component from the source image to the destination image. The path component is copied to the 

active path in the Paths palette. 

•	 In the source image, select the path name in the Paths palette and choose Edit > Copy to copy the path. In the desti

nation image, choose Edit > Paste. You can also use this method to combine paths in the same image. 

•	 To paste the path component into the destination image, select the path component in the source image, and 

choose Edit > Copy. In the destination image, choose Edit > Paste. 

To delete a path component 
1 Select the path name in the Paths palette, and click a path component with the Path Selection tool 

2 Press backspace (Windows) or Delete (Mac OS) to delete the selected path component. 

. 

To align and distribute path components 
You can align and distribute path components that are described in a single path. For example, you can align the left 

edges of several shapes contained in a single layer or distribute several components in a work path along their 

horizontal centers. 
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Note: To align shapes that are on separate layers, use the Move tool. 

•	 To align components, use the Path Selection tool to select the components you want to align, and select one of 

the alignment options from the options bar. 

A B C D E F 

Alignment options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 

•	 To distribute components, select at least three components you want to distribute, and then select one of the 

distribute options from the options bar. 

A B C D E F 

Distribute options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 

To add an anchor point 
1 Select the Add Anchor Point tool , and position the pointer on the path where you want to add the anchor point 

(a plus sign appears next to the pointer). 

2	 Do one of the following: 

•	 To add an anchor point without changing the shape of the segment, click the path. 

•	 To add an anchor point and change the shape of the segment, drag to define direction lines for the anchor point. 

Note: If you have selected Auto Add/Delete in the options bar for the Pen tool or Freeform Pen tool, a point is added 

when you click a line segment, and an existing point is deleted when you click it. 

To delete an anchor point 
1 Select the Delete Anchor Point tool , and position the pointer on the anchor point to be deleted (a minus sign 

appears next to the pointer). 

2	 Delete the anchor point: 

•	 Click the anchor point to delete it and to reshape the path to fit the remaining anchor points. 

•	 Drag the anchor point to delete it and to change the shape of the segment. 

Note: If you have selected Auto Add/Delete in the options bar for the Pen tool or Freeform Pen tool, a point is added 

when you click a line segment, and an existing point is deleted when you click it. 
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To convert between a smooth point and a corner point 
1 Select the Convert Point tool , and position the pointer over the anchor point you want to change. 

To activate the Convert Point tool while the Direct Selection tool is selected, position the pointer over an anchor point, 

and press Ctrl+Alt (Windows) or Command+Option (Mac OS). 

2	 Convert the point: 

•	 To convert a smooth point to a corner point without direction lines, click the smooth anchor point. 

•	 To convert a smooth point to a corner point with direction lines, make sure the direction lines are visible. Then 

drag a direction point to break the pair of direction lines. 

Drag direction point to break direction lines. 

•	 To convert a corner point to a smooth point, drag away from the corner point to make direction lines appear. 

Click to create a corner point. Drag to create a smooth point. 

Converting between paths and selection borders 

borders into paths, using the Direct Selection tool

Converting paths to selection borders 
Paths provide smooth outlines that you can convert into precise selection borders. You also can convert selection

 for fine-tuning. 

You can define any closed path as a selection border. A closed path can be added to, subtracted from, or combined 

with the current selection. 

To convert a path to a selection border using the current settings

1 Select the path in the Paths palette.


2 To convert the path, do one of the following:


•	 Click the Load Path as a Selection button  at the bottom of the Paths palette. 

•	 Ctrl-click (Windows) or Command-click (Mac OS) the path thumbnail in the Paths palette. 
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To convert a path to a selection border and specify settings

1 Select the path in the Paths palette.


2 Do one of the following:


• Alt-click (Windows) or Option-click (Mac OS) the Load Path As A Selection button at the bottom of the Paths 

palette. 

• Alt-drag (Windows) or Option-drag (Mac OS) the path to the Load Path As A Selection button.


• Choose Make Selection from the Paths palette menu.


3 In the Make Selection dialog box, select a Rendering option:


Feather Radius Defines how far inside and outside the selection border the feather edge extends. Enter a value in


pixels.


Anti-aliased Creates a finer transition between the pixels in the selection and the surrounding pixels. Make sure the


Feather Radius is set to 0.


For more information on these options, see “Methods for softening the edges of a selection” on page 326.


4 Select an Operation option:


New Selection Selects only the area defined by the path.


Add To Selection Adds the area defined by the path to the original selection. 

Subtract From Selection Removes the area defined by the path from the current selection. 

Intersect With Selection Selects the area common to both the path and the original selection. If the path and 

selection do not overlap, nothing is selected. 

5 Click OK. 

To convert a selection to a path 
Any selection made with a selection tool can be defined as a path. The Make Work Path command eliminates any 

feathering applied to the selection. It can also alter the shape of the selection, depending on the complexity of the 

path and the tolerance value you choose in the Make Work Path dialog box. 

1 Make the selection, and do one of the following: 

• Click the Make Work Path button  at the bottom of the Paths palette to use the current tolerance setting 

without opening the Make Work Path dialog box. 

• Alt-click (Windows) or Option-click (Mac OS) the Make Work Path button at the bottom of the Paths palette. 

• Choose Make Work Path from the Paths palette menu. 

2 Enter a Tolerance value or use the default value in the Make Work Path dialog box. 

Tolerance values can range from 0.5 to 10 pixels and determine how sensitive the Make Work Path command is to 

slight changes in the selection shape. The higher the tolerance value, the fewer the anchor points used to draw the 

path  and the  smoother  the path.  If  the path is used as a clipping  path  and you  have  problems  printing  the image, use  

a higher tolerance value. (See “Printing image clipping paths” on page 702.) 

3 Click OK. The path appears at the bottom of the Paths palette. 
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Adding color to paths 

Filling and stroking paths with color 
A path created  with  the Pen  tool  does  not become an image  element until  you stroke or fill it.  The Fill Path command  

fills a path with pixels using a specified color, a state of the image, a pattern, or a fill layer. 

Path selected (left) and filled (right) 

The Stroke Path command paints the border of a path. The Stroke Path command allows you to create a paint stroke 

(using the current settings for your painting tools) that follows any path. This is completely different from the Stroke 

layer effect, which doesn’t mimic the effect of any of the painting tools. 

Path selected (left) and stroked (right) 

Important: When  you fill or stroke a path, the  color values appear on the  active  layer.  Make  sure  that  the layer  you want  

is active before beginning. You cannot fill or stroke a path when a layer mask or text layer is active. 

To fill a path using the current Fill Path settings

1 Select the path in the Paths palette.


2 Click the Fill Path button
  at the bottom of the Paths palette. 

To fill a path and specify options 
1 Select the path in the Paths palette. 

2 Fill the path: 

•	 Alt-click (Windows) or Option-click (Mac OS) the Fill Path button at the bottom of the Paths palette. 

•	 Alt-drag (Windows) or Option-drag (Mac OS) the path to the Fill Path button. 

•	 Choose  Fill  Path  from  the Paths  palette menu.  If  the selected path is a path  component,  this  command changes to  

Fill Subpath. 

3 For Use, choose the contents for the fill. (See “To fill a selection or a layer with a foreground or background color” 

on page 498.) 
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4 Specify an opacity for the fill. To make the fill more transparent, use a low percentage. A setting of 100% makes 

the fill opaque. 

5	 Choose a blending mode for the fill. (See “List of blending modes” on page 487.) 

The Mode list includes a Clear mode that lets you erase to transparency. You must be working in a layer other than 

the background to use this option. 

6 Choose Preserve Transparency to limit the fill to layer areas that contain pixels. (See “Locking layers” on 

page 405.) 

7	 Select a Rendering option: 

Feather Radius Defines how far inside and outside the selection border the feather edge extends. Enter a value in 

pixels. 

Anti-aliased Creates a finer transition between the pixels in the selection and the surrounding pixels by partially 

filling the edge pixels of the selection. 

For more information on these options, see “Methods for softening the edges of a selection” on page 326. 

8	 Click OK. 

To stroke a path using the current Stroke Path settings

1 Select the path in the Paths palette.


2 Click the  Stroke  Path  button 
 at  the bottom of the  Paths palette.  Each  click of the  Stroke  Path  button  builds  up  

the opacity of the stroke and in some cases makes it look thicker. 

See also 

“To stroke a path and specify options” on page 470 

To stroke a path and specify options 
1 Select the path in the Paths palette. 

2 Select the painting or editing tool you want to use to stroke the path. Set the tool options, and specify a brush from 

the options bar. You must specify the tool’s settings before opening the Stroke Path dialog box. For information on 

specific tool settings, see “To use the Smudge tool” on page 372 and “Painting” on page 471. 

3 To stroke the path, do one of the following: 

•	 Alt-click (Windows) or Option-click (Mac OS) the Stroke Path button  at the bottom of the Paths palette. 

•	 Alt-drag (Windows) or Option-drag (Mac OS) the path to the Stroke Path button. 

•	 Choose Stroke Path from the Paths palette menu. If the selected path is a path component, this command changes 

to Stroke Subpath. 

4 If you did not select a tool in step 2, choose a tool from the Stroke Path dialog box. 

5 Click OK. 
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Chapter 17: Painting


Painting tools 

Painting 
The painting tools change the color of pixels in an image. The Brush tool and the Pencil tool work like traditional 

drawing tools by applying color with brush strokes. The Gradient tool, Fill command, and Paint Bucket tool apply 

color to large areas. Tools like the Eraser tool, Blur tool, and Smudge tool modify the existing colors in the image. 

The power of painting in Photoshop is in the options that you can set to specify how a tool applies or modifies color. 

You can apply color gradually, with soft edges, with large brush strokes, with various brush dynamics, with different 

blending properties, and with brushes of different shapes. You can simulate spraying paint with an airbrush. 

You set tool options from the options bar. The options bar for the brush tool contains other palettes and menus of 

options: 

Brush Presets picker Stores saved brush tip settings, such as brush size, hardness, and airbrush, and the brush 

options available in the Brushes palette. 

Tool Presets picker Stores saved settings of a brush tip preset, other options from the options bar such as opacity or 

blending mode, and paint color. 

Brushes palette Contains numerous options for setting brush painting characteristics, such as color dynamics, 

brush shape dynamics, texture, and paint scattering. The Brushes palette also contains a panel from which you can 

choose a brush tip preset. 

To use the Brush tool or Pencil tool 
The Brush tool and the Pencil tool paint the current foreground color on an image. The Brush tool creates soft strokes 

of color. The Pencil tool creates hard-edged lines. 

1 Choose a foreground color. (See “To choose colors in the toolbox” on page 504.) 

2 Select the Brush tool  or Pencil tool . 

3 Set tool options in the options bar: 

•	 Choose a brush from the Brush Presets picker, and set brush options. (See “To select a preset brush” on page 473.) 

•	 Choose a blending mode from the Mode menu. (See “List of blending modes” on page 487.) 

•	 Specify an opacity by dragging the Opacity slider. Opacity specifies the amount of paint coverage applied by each 

stroke. 

•	 For the Brush tool, specify a flow rate by dragging the Flow slider. Flow specifies how quickly paint is applied. 

Press a number key to set a tool’s opacity in multiples of 10% (pressing 1 sets to 10%; pressing 0 sets to 100%). Use 

Shift and number key to set Flow. 
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•	 (Photoshop) Click the Airbrush button  to use the brush as an airbrush. 

•	 For the Pencil tool, select Auto Erase to paint the background color over areas containing the foreground color. 

(See “To use the Auto Erase option with the Pencil tool” on page 492.) 

4	 Do one or more of the following: 

•	 Drag in the image to paint. 

•	 To draw a straight line, click a starting point in the image. Then hold down Shift, and click an ending point. 

•	 When using the Brush tool as an airbrush, hold down the mouse button without dragging to build up color. 

See also 

“Painting tools gallery” on page 44 

To get the brush cursor back 
The painting tools have three possible cursors: the standard cursor (the icon from the toolbox), a cross hair , and 

a cursor sized to match the currently selected brush tip. For the Pen and Brush tools, the Caps Lock key acts like a 

toggle for changing between the standard cursor and the cross hair. 

To change the default shape of cursors for painting and other tools, choose Edit > Preferences > Display and Cursors. 

Select  the desired  cursors in both the  Painting  Cursors area and  the Other  Cursors area.  The sample cursors  change  

to reflect your choices. Click OK. 

The Art History Brush tool 
The Art History Brush tool paints with stylized strokes, using the source data from a specified history state or 

snapshot. By experimenting with different paint style, size, and tolerance options, you can simulate the texture of 

painting with different colors and artistic styles. 

Like the History Brush tool, the Art History Brush tool uses a specified history state or snapshot as the source data. 

The History Brush tool, however, paints by recreating the specified source data, while the Art History Brush tool uses 

that data along with the options you set to create different colors and artistic styles. 

For a variety of visual effects, experiment with applying filters or filling an image with a solid color before painting 

with the Art History Brush tool. Also try increasing the size of the image by a factor of 4 to soften the details. 

A B C 

Example of using the Art History Brush tool 
A. Original B. Using a small brush C. Using a large brush 

To use the Art History Brush tool 
1 In the History palette, click the left column of the state or snapshot to use as the source for the Art History Brush 

tool. A brush icon appears next to the source history state. 

2	 Select the Art History Brush tool . 
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3	 Do the following in the options bar: 

•	 Choose a brush from the Brush Presets picker, and set brush options. (See “To select a preset brush” on page 473.) 

•	 Choose a blending mode from the Mode menu. (See “About blending modes” on page 410.) 

•	 Choose an option from the Style menu to control the shape of the paint stroke. 

•	 For Area, enter a value to specify the area covered by the paint strokes. The greater the size, the larger the covered 

area and the more numerous the strokes. 

•	 For Tolerance, enter a value to limit the regions where paint strokes can be applied. A low tolerance lets you paint 

unlimited strokes anywhere in the image. A high tolerance limits paint strokes to areas that differ considerably 

from the color in the source state or snapshot. 

4	 Drag in the image to paint. 

Selecting brush presets 

To select a preset brush 
A preset brush  is  a saved  brush tip  with  defined characteristics  such  as  size, shape, and  hardness. You  can save preset  

brushes with the  characteristics that you  use often. You  can also save tool presets  for the  Brush tool that you  can select  

from the Tool Preset menu in the options bar. 

When you change the size, shape, or hardness of a preset brush, the change is temporary. The next time you choose 

that preset, the brush uses its original settings. To make your changes permanent, you need to create a new preset. 

See “To create a new preset brush” on page 485. 

1 Select a painting tool or editing tool, and click the Brush Preset pop-up menu in the options bar. 

2 Select a brush. 

Note: You can also select a brush in Photoshop from the Brushes palette. Be sure that Brush Presets on the left side of the 

palette is selected to view the loaded presets. 

3	 Change options for the preset brush (Photoshop). 

Diameter Temporarily changes the brush size. Drag the slider or enter a value. If the brush has a dual tip, both the 

primary and dual brush tips are scaled. 

Use Sample Size Uses the original diameter of the brush tip if the brush tip shape is based on a sample. 

Hardness Sets the amount of anti-aliasing for the brush tool. At 100%, the brush tool paints with the hardest brush 

tip, but is still anti-aliased. The Pencil always paints a hard edge that is not anti-aliased. 

See also 

“About the Brushes palette” on page 474 

“To create a tool preset” on page 48 
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To change how preset brushes are displayed 
Choose a display option from the Brush Preset picker menu  or Brushes palette menu: 

•	 Text Only to view the brushes as a list. 

•	 Small or Large Thumbnail to view the brushes as thumbnails. 

•	 Small or Large List to view the brushes as a list with thumbnails. 

•	 Stroke Thumbnail to view a sample brush stroke with each brush thumbnail. 

To dynamically preview brush strokes in the Brushes palette, make sure that Brush Preset is selected, and then 

position the pointer over a brush until the tool tip appears. Move the pointer over different brushes. The preview area 

at the bottom of the palette will display sample brush strokes. 

To change the preset brushes displayed in the palette 
1 To load a library of preset brushes, choose one of the following from the Brush Preset picker menu or Brushes 

palette menu: 

•	 Load Brushes to add a library to the current list. Select the library file you want to use, and click Load. 

•	 Replace Brushes  to  replace the  current list with a different  library.  Select  the library  file  you want to use, and  click  

Load. 

•	 A library file (displayed at the bottom of the palette menu). Click OK to replace the current list, or click Append 

to append the current list. 

2 To return to the default library of preset brushes, choose Reset Brushes from the Brush Preset picker menu or 

Brushes palette menu. You can either replace the current list or append the default library to the current list. 

Note: You can also use the Preset Manager to load and reset brush libraries. 

See also 

“To save a set of preset brushes as a library” on page 486 

“About the Preset Manager” on page 67 

Creating brushes and setting options 

About the Brushes palette 
The Brushes palette lets you select preset brushes and design custom brushes. The brush you select determines many 

characteristics of the resulting stroke. Photoshop provides a variety of preset brushes to fill a wide range of uses. In 

Photoshop, you can also create custom brushes using the Brushes palette. 
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A B  C  

Brushes palette with Brush Tip Shape options displayed 
A. Locked B. Unlocked C. Selected brush tip D. Brush settings E. Brush stroke preview F. pop-up menu G. Brush tip shapes 
(available when Brush Tip Shape option is selected) H. Brush options 

To display the Brushes palette and brush options 
1 Choose Window > Brushes, or click the palette button on the right side of the options bar if you have a painting 

tool, erasing tool, toning tool, or focus tool selected. 

2 Select  an  item  name  on  the left side  of  the palette. The  available options  for the  selected  item  appear  on  the right  

side of the palette. 

Click the check box to the left of the item name to enable or disable the item without viewing its options. 

To create a custom brush from an image 
1 Use any selection tool to select a part of an image to use as a custom brush. Feather should be set to 0 pixels if you 

want to create a brush with a sharp edge. The brush shape can be up to 2500 pixels by 2500 pixels in size. 

If you want to define a brush with soft edges, select pixels with gray values. (Colored brush shapes appear as gray 

values.) 

2 Choose Edit > Define Brush Preset. 

3 Name the brush, and click OK. 

To create a brush and set painting options 
1 Open the Brushes palette by clicking the brushes palette button in the options bar. Make sure the Brush tool is 

selected to see the button. 

2 In  the Brushes  palette,  choose  an  existing  brush preset to modify or select a brush shape  from  the Brush  Tip Shape  

panel of the Brushes palette. You can also create a new brush tip from an image. 
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3 Select Brush Tip Shape on the left side of the Brushes palette and set options. See “Brush tip shape options” on 

page 476. 

4 Set other options for the brush as needed. For more information about navigating in the palette, see “To display 

the Brushes palette and brush options” on page 475. 

See the following sections for information about the options. 

• “Brush shape dynamics” on page 479


• “Brush scattering” on page 480


• “Textured brush options” on page 481


• “Dual brushes” on page 482


• “Color dynamics Brush options” on page 483


• “Other dynamics brush options” on page 483


• “Other Brush options” on page 484


. To unlock the tip, click the lock icon . 

6 To save the brush for use later, choose New Brush Preset from the Brushes palette menu. 

5 To lock brush tip shape attributes, click the unlock icon


See also 

“About the Brushes palette” on page 474


“To create a custom brush from an image” on page 475


Brush tip shape options 
You can set the following brush tip shape options in the Brushes palette: 

Diameter Controls the size of the brush. Enter a value in pixels or drag the slider. 

Brush strokes with different diameter values 

Use Sample Size Resets the brush to its original diameter. This option is available only if the brush tip shape was 

created by sampling pixels in an image. 

Flip X Changes the direction of a brush tip on its x axis. 

 



477 ADOBE PHOTOSHOP CS2 
User Guide 

A B C 

Flipping a brush tip on its x axis. 
A. Brush tip in its default position B. Flip X selected C. Flip X and Flip Y selected 

Flip Y Changes the direction of a brush tip on its y axis. 

A B C 

Flipping a brush tip on its y axis. 
A. Brush tip in its default position B. Flip Y selected C. Flip Y and Flip X selected 

Angle Specifies the angle by which an elliptical or sampled brush’s long axis is rotated from horizontal. Type a value 

in degrees, or drag the horizontal axis in the preview box. 

Angled brushes create a chiseled stroke 

Roundness Specifies the ratio between the brush’s short and long axes. Enter a percentage value, or drag the points 

in the preview box. A value of 100% indicates a circular brush, a value of 0% indicates a linear brush, and interme

diate values indicate elliptical brushes. 

jAd usting roundness to compress a brush tip shape 

Hardness Controls the size of the brush’s hard center. Type a number, or use the slider to enter a value that is a 

percentage of the brush diameter. You can’t change the hardness of sampled brushes. 
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Brush strokes with different hardness values 

Spacing Controls the distance between the brush marks in a stroke. To change the spacing, type a number, or use 

the slider to enter a value that is a percentage of the brush diameter. When this option is deselected, the speed of the 

cursor determines the spacing. 

Increasing the spacing makes the brush skip 

While using  a preset brush, press  the [  key to decrease the  brush width; press  the ]  key to increase the  width.  For hard  

round, soft round, and calligraphic brushes, press Shift+[  to decrease the brush hardness; press Shift+]  to increase 

the brush hardness. 

See also 

“About the Brushes palette” on page 474 

“To create a brush and set painting options” on page 475 

Adding brush dynamics 
The Brushes palette provides many options for adding dynamic (or changing) elements to preset brush tips. For 

example, you can set options that vary the size, color, and opacity of brush marks over the course of a stroke. 

You work with two components when adding dynamics elements to a brush: 

•	 Jitter percentages specify the randomness of dynamic elements. At 0%, an element does not change over the course 

of a stroke; at 100%, an element has the maximum amount of randomness. 

•	 Options in the Control pop-up menus specify how you want to control the variance of dynamic elements. You can 

choose  not to control  the variance of an element, to fade an element  over  the specified number of steps, or to vary  

an element based on pen pressure, pen tilt, or position of the pen thumbwheel. 

Note: Pen controls are available only when you’re using a pressure-sensitive digitizing tablet such as the Wacom tablet. 

A warning icon appears if you select a pen control but have not installed a tablet. 
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See also 

“About the Brushes palette” on page 474 

“To create a brush and set painting options” on page 475 

Brush shape dynamics 
Shape dynamics determine the variance of brush marks in a stroke. 

Brush stokes without shape dynamics and with shape dynamics 

Size Jitter and Control Specifies how the size of brush marks vary in a stroke. For more information, see “Adding 

brush dynamics” on page 478. 

To specify the maximum percentage of jittering, type a number or use the slider to enter a value. To specify how you 

want to control the size variance of brush marks, choose an option from the Control pop-up menu: 

• Off Specifies no control over the size variance of brush marks. 

• Fade Fades the size of brush marks between the initial diameter and the minimum diameter in the specified 

number of steps. Each step is equal to one mark of the brush tip. The value can range from 1 to 9999. For example, 

entering 10 steps produces a fade in 10 increments. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the size of brush marks between the initial diameter and the 

minimum diameter based on the pen pressure, pen tilt, position of the pen thumbwheel, or rotation of the pen. 

Minimum Diameter Specifies the minimum percentage by which brush marks can scale when Size Jitter or Size 

Control is enabled. Type a number, or use the slider to enter a value that is a percentage of the brush tip diameter. 

Tilt Scale Specifies the scale factor applied to the height of the brush prior to rotation when Size Control is set to Pen 

Tilt. Type a number, or use the slider to enter a value that is a percentage of the brush diameter. 

Angle Jitter and Control Specifies how the angle of brush marks varies in a stroke. To specify the maximum 

percentage of jittering, enter a value that is a percentage of 360 degrees. To specify how you want to control the angle 

variance of brush marks, choose an option from the Control pop-up menu: 

• Off Specifies no control over the angle variance of brush marks. 

• Fade Fades the angle of brush marks between 0 and 360 degrees in the specified number of steps. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the angle of brush marks between 0 and 360 degrees based 

on the pen pressure, pen tilt, position of the pen thumbwheel, or rotation of the pen. 

• Initial Direction Bases the angle of brush marks on the initial direction of the brush stroke. 

• Direction Bases the angle of brush marks on the direction of the brush stroke. 

Roundness Jitter and Control Specifies how the roundness of brush marks varies in a stroke. To specify the 

maximum percentage of jittering, enter a percentage indicating the ratio between the brush’s short and long axes. To 
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specify how you want to control the roundness variance of brush marks, choose an option from the Control pop-up 

menu: 

• Off Specifies no control over the roundness variance of brush marks. 

• Fade Fades the roundness of brush marks between 100% and the Minimum Roundness value in the specified 

number of steps. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the roundness of brush marks between 100% and the 

Minimum Roundness value based on the pen pressure, pen tilt, position of the pen thumbwheel, or rotation of the 

pen. 

Minimum Roundness Specifies the minimum roundness for brush marks when Roundness Jitter or Roundness 

Control is enabled. Enter a percentage indicating the ratio between the brush’s short and long axes. 

See also 

“Adding brush dynamics” on page 478 

“To create a brush and set painting options” on page 475 

Brush scattering 
Brush scattering determines the number and placement of marks in a stroke. 

)Brush strokes without scattering (left) and with scattering (right

Scatter and Control Specifies how brush marks are distributed in a stroke. When Both Axes is selected, brush marks 

are distributed in a radial direction. When Both Axes is deselected, brush marks are distributed perpendicular to the 

stroke path. 

To specify the maximum percentage of scattering, enter a value. To specify how you want to control the scattering 

variance of brush marks, choose an option from the Control pop-up menu: 

• Off Specifies no control over the scattering variance of brush marks. 

• Fade Fades the scattering of brush marks from maximum scattering to no scattering in the specified number of 

steps. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the scattering of brush marks based on the pen pressure, pen 

tilt, position of the pen thumbwheel, or rotation of the pen. 

Count Specifies the number of brush marks applied at each spacing interval. 
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Note: If you increase the count without increasing the spacing or scattering values, painting performance may decrease. 

Count Jitter and Control Specifies how the number of brush marks varies for each spacing interval. To specify the 

maximum percentage of brush marks applied at each spacing interval, enter a value. To specify how you want to 

control the count variance of brush marks, choose an option from the Control pop-up menu: 

• Off Specifies no control over the count variance of brush marks. 

• Fade Fades the number of brush marks from the Count value to 1 in the specified number of steps. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the number of brush marks based on the pen pressure, pen 

tilt, position of the pen thumbwheel, or rotation of the pen. 

See also 

“Adding brush dynamics” on page 478 

“To create a brush and set painting options” on page 475 

Textured brush options 
A textured brush uses a pattern to make strokes look as if they are painted on textured canvas. 

)Brush strokes without texture (left) and with texture (right

Click the pattern sample and select a pattern from the pop-up palette. Set one or more of the following options: 

Invert Inverts the high and low points in the texture based on the tones in the pattern. When Invert is selected, the 

lightest areas in the pattern are the low points in the texture and therefore receive the least paint; the darkest areas in 

the pattern are the high points in the texture and therefore receive the most paint. When Invert is deselected, the 

lightest areas in the pattern receive the most paint; the darkest areas in the pattern receive the least paint. 

Scale Specifies the scale of the pattern. Type a number, or use the slider to enter a value that is a percentage of the 

pattern size. 

Texture Each Tip Specifies whether or not to render each tip individually as it is painted. When this option is not 

selected, the Depth variance options are not available. 

Mode Specifies the blending mode used to combine the brush and the pattern. (See “About blending modes” on 

page 410.) 

Depth Specifies how deeply the paint penetrates into the texture. Type a number, or use the slider to enter a value. 

At 100%, the low points in the texture do not receive any paint. At 0%, all points in the texture receive the same 

amount of paint, therefore hiding the pattern. 
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Minimum Depth Specifies the minimum depth to which paint can penetrate when Depth Control is set to Fade, Pen 

Pressure, Pen Tilt, or Stylus Wheel and Texture Each Tip is selected. 

Depth Jitter and Control Specifies how the depth varies when Texture Each Tip is selected. To specify the 

maximum percentage of jitter, enter a value. To specify how you want to control the depth variance of brush marks, 

choose an option from the Control pop-up menu: 

• Off Specifies no control over the depth variance of brush marks. 

• Fade Fades from the Depth Jitter percentage to the Minimum Depth percentage in the specified number of steps. 

• Pen Pressure, Pen Tilt, or Stylus Wheel Varies  the depth  based on the  pen pressure,  pen tilt,  or  position  of  the pen  

thumbwheel. 

See also 

“Adding brush dynamics” on page 478 

“To create a brush and set painting options” on page 475 

Dual brushes 
A dual brush uses two tips to create brush marks. Set options for the primary tip in the Brush Tip Shape section of 

the Brushes palette. Select a second brush tip from the Dual Brush section of the Brushes palette and set any of the 

following options. 

)Brush strokes created with a single tip (left) and with dual tips (right

Mode Sets a blending mode to use when combining brush marks from the primary tip and the dual tip. (See “List 

of blending modes” on page 487.) 

Diameter Controls the size of the dual tip. Enter a value in pixels, drag the slider, or click Use Sample Size to use the 

original diameter of the brush tip. (The Use Sample Size option is available only if the brush tip shape was created by 

sampling pixels in an image.) 

Spacing Controls the distance between the dual tip brush marks in a stroke. To change the spacing, type a number 

or use the slider to enter a percentage of the tip diameter. 

Scatter Specifies how dual tip brush marks are distributed in a stroke. When Both Axes is selected, dual tip brush 

marks are distributed in a radial direction. When Both Axes is deselected, dual tip brush marks are distributed 

perpendicular to the stroke path. To specify the maximum percentage of scattering, type a number or use the slider 

to enter a value. 

Count Specifies the number of dual tip brush marks applied at each spacing interval. Type a number, or use the slider 

to enter a value. 
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Color dynamics Brush options 
Color dynamics determine how the color of paint changes over the course of a stroke. 

)Brush strokes without color dynamics (left) and with color dynamics (right

Foreground/Background Jitter and Control Specifies how paint varies between the foreground color and 

background color. 

To  specify a percentage by which  the color  of  the paint  can vary,  type  a number or use  the slider to enter  a value. To  

specify how you want to control the color variance of brush marks, choose an option from the Control pop-up menu: 

• Off Specifies no control over the color variance of brush marks. 

• Fade Varies the color of paint between the foreground color and the background color in the specified number of 

steps. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the color of paint between the foreground color and the 

background color based on the pen pressure, pen tilt, position of the pen thumbwheel, or rotation of the pen. 

Hue Jitter Specifies a percentage by which the hue of the paint can vary in a stroke. Type a number, or use the slider 

to enter a value. A lower value changes the hue while maintaining a close proximity to the hue of the foreground 

color. A higher value increases the difference between hues. 

Saturation Jitter Specifies a percentage by which the saturation of the paint can vary in a stroke. Type a number, or 

use the slider to enter a value. A lower value changes the saturation while maintaining a close proximity to the 

saturation of the foreground color. A higher value increases the difference between saturation levels. 

Brightness Jitter Specifies a percentage by which the brightness of the paint can vary in a stroke. Type a number, or 

use the slider to enter a value. A lower value changes the brightness while maintaining a close proximity to the 

brightness of the foreground color. A higher value increases the difference between brightness levels. 

Purity Increases or decreases the saturation of the color. Type a number, or use the slider to enter a percentage 

between –100 and 100. At –100%, the color is fully desaturated; at 100%, the color is fully saturated. 

See also 

“Adding brush dynamics” on page 478 

Other dynamics brush options 
Other dynamics determine how paint changes over the course of a stroke. 

 



484 ADOBE PHOTOSHOP CS2 
User Guide 

)Brush strokes without paint dynamics (left) and with paint dynamics (right

Opacity Jitter and Control Specifies how the opacity of paint varies in a brush stroke, up to (but not exceeding) the 

opacity value specified in the options bar. To specify a percentage by which the opacity of the paint can vary, type a 

number or use the slider to enter a value. To specify how you want to control the opacity variance of brush marks, 

choose an option from the Control pop-up menu: 

• Off Specifies no control over the opacity variance of brush marks. 

• Fade Fades the opacity of paint from the opacity value in the options bar to 0 in the specified number of steps. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the opacity of paint based on the pen pressure, pen tilt, the 

position of the pen thumbwheel, or rotation of the pen. 

Flow Jitter and Control Specifies how the flow of paint varies in a brush stroke, up to (but not exceeding) the flow 

value specified in the options bar. 

To specify a percentage by which the flow of the paint can vary, type a number or use the slider to enter a value. To 

specify how  you want to control  the flow variance of brush  marks,  choose  an  option  from  the Control  pop-up  menu:  

• Off Specifies no control over the flow variance of brush marks. 

• Fade Fades the flow of paint from the flow value in the options bar to 0 in the specified number of steps. 

• Pen Pressure, Pen Tilt, Stylus Wheel, Rotation Varies the flow of paint based on the pen pressure, pen tilt, the 

position of the pen thumbwheel, or rotation of the pen. 

See also 

“Adding brush dynamics” on page 478 

“To create a brush and set painting options” on page 475 

Other Brush options 
Noise Adds additional randomness to individual brush tips. This option is most effective when applied to soft brush 

tips (brush tips that contain gray values). 

Wet Edges Causes paint to build up along the edges of the brush stroke, creating a watercolor effect. 

Airbrush Applies gradual tones to an image, simulating traditional airbrush techniques. The Airbrush option in the 

Brushes palette corresponds to the Airbrush option in the options bar. 

Smoothing Produces smoother curves in brush strokes. This option is most effective when you are painting quickly 

with a stylus; however, it may produce a slight lag time in stroke rendering. 

Protect Texture Applies the same pattern and scale to all brush presets that have a texture. Select this option to 

simulate a consistent canvas texture when painting with multiple, textured brush tips. 
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To copy textures between tools 
When you specify a texture for the current tool, you can copy the texture’s pattern and scale to all tools that support 

textures. For example, you can copy the current texture pattern and scale for the Brush tool to the Pencil, Clone 

Stamp, Pattern Stamp, History Brush, Art History Brush, Eraser, Dodge, Burn, and Sponge tools. 

❖ Choose Copy Texture to Other Tools from the Brushes palette menu. 

To clear brush options 
You can easily clear all brush options for a tool using the Clear Brush Controls command. 

❖ Choose Clear Brush Controls from the Brushes palette menu. 

To set brush pressure sensitivity for digitizing tablets 
Set brush sensitivity if you are using a pressure-sensitive digitizing tablet, such as the Wacom® tablet. 

1 Select the Brush tool , the Pencil tool , or other painting tool in the toolbox. 

2 Click the Brushes tab to bring the Brushes palette to the front or, if the palette isn’t open, choose Window > 

Brushes. 

3 To  make  the tool tip  size  change  with  pressure, select Shape  Dynamics  (be sure to click  the word,  not just the  check  

box) in the Brushes palette. Then choose Pen Pressure from the Controls menu under the Size Jitter slider control. 

4 To make the opacity change with pressure, select Other Dynamics. Then choose Pen Pressure from the Controls 

menu under the Opacity Jitter slider control. 

Note: You can  set pen  pressure  for  other brush  characteristics as well.  The Brush  palette contains controls that vary the  

angle, flow, scatter, texture depth, and roundness of the stroke according to pen pressure. 

See also 

“About the Brushes palette” on page 474 

“Brush shape dynamics” on page 479 

Creating and managing preset brushes 

To create a new preset brush 
You can  save  a customized brush  as  a preset brush  that  appears in the  Brushes palette,  Brush Preset picker,  and Preset  

Manager. 

Note: New preset brushes are saved in a Preferences file. If this file is deleted or damaged, or if you reset brushes to the 

default library, the new presets will be lost. To permanently save new preset brushes, save them in a library. 

1 Customize a brush.


2 Do one of the following in the Brushes palette or Brush Preset picker:


• Choose New Brush Preset from the palette menu, enter a name for the preset brush, and click OK. 

• Click the Create New Brush button . 
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To rename a preset brush 
Do one of the following: 

•	 Select a brush in the Brush Preset picker or Brushes palette, and choose Rename Brush from the palette menu. 

Enter a new name for the brush, and click OK. 

•	 If the Brushes palette is set to display brushes as thumbnails, double-click a brush, enter a new name, and click OK. 

•	 If the Brushes palette is set to display brushes as a list or text only, double-click a brush, enter a new name inline, 

and press Enter (Windows) or Return (Mac OS). 

To delete a preset brush 
•	 In the Brush Preset picker or Brushes palette, select a brush, and choose Delete Brush from the palette menu. 

•	 In the Brush Preset picker or Brushes palette, Alt-click (Windows) or Option-click (Mac OS) the brush you want 

to delete. 

•	 In the Brushes palette, select a brush and click the Delete icon , or drag a brush to the Delete icon. 

To save a set of preset brushes as a library 
1 Choose Save Brushes from the Brush Preset picker menu or Brushes palette menu. 

2 Choose a location for the brush library, enter a file name, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/Brushes folder inside the 

Photoshop program  folder, the  library name will appear at the  bottom  of  the Brush  Preset  picker  menu  and Brushes  

palette menu after you restart Photoshop. 

You can also use the Preset Manager to rename, delete, and save libraries of preset brushes. For more information, 

see “About the Preset Manager” on page 67. 

Blending modes 

About blending modes 
The blending mode specified in the options bar controls how pixels in the image are affected by a painting or editing 

tool. It’s helpful to think in terms of the following colors when visualizing a blending mode’s effect: 

•	 The base color is the original color in the image. 

•	 The blend color is the color being applied with the painting or editing tool. 

•	 The result color is the color resulting from the blend. 

See also 

“List of blending modes” on page 487 
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List of blending modes 
Choose from the Mode pop-up menu in the options bar. 

Normal Edits or paints each pixel to make it the result color. This is the default mode. (Normal mode is called 

Threshold when you’re working with a bitmapped or indexed-color image.) 

Dissolve Edits or paints each pixel  to  make  it  the result color. However, the  result  color is a random  replacement of  

the pixels with the base color or the blend color, depending on the opacity at any pixel location. 

Behind Edits or paints only on the transparent part of a layer. This mode works only in layers with Lock Trans

parency deselected and is analogous to painting on the back of transparent areas on a sheet of acetate. 

Clear Edits or paints each pixel and makes it transparent. This mode is available for the Shape tools (when fill 

region is selected), the Paint Bucket tool , the Brush tool , the Pencil tool , the Fill command, and the 

Stroke command. You must be in a layer with Lock Transparency deselected to use this mode. 

Darken Looks at the color information in each channel and selects the base or blend color—whichever is darker— 

as the result color. Pixels lighter than the blend color are replaced, and pixels darker than the blend color do not 

change. 

Multiply Looks at the  color information  in  each  channel and  multiplies  the base color  by  the blend  color.  The result  

color is always a darker color. Multiplying any color with black produces black. Multiplying any color with white 

leaves the color unchanged. When you’re painting with a color other than black or white, successive strokes with a 

painting tool produce progressively darker colors. The effect is similar to drawing on the image with multiple 

marking pens. 

Color Burn Looks at the color information in each channel and darkens the base color to reflect the blend color by 

increasing the contrast. Blending with white produces no change. 

Linear Burn Looks at the color information in each channel and darkens the base color to reflect the blend color by 

decreasing the brightness. Blending with white produces no change. 

Lighten Looks at the color information in each channel and selects the base or blend color—whichever is lighter— 

as the result color. Pixels darker than the blend color are replaced, and pixels lighter than the blend color do not 

change. 

Screen Looks at each channel’s  color information  and multiplies the  inverse of the  blend and  base  colors. The  result  

color is always a lighter color. Screening with black leaves the color unchanged. Screening with white produces white. 

The effect is similar to projecting multiple photographic slides on top of each other. 

Color Dodge Looks at the color information in each channel and brightens the base color to reflect the blend color 

by decreasing the contrast. Blending with black produces no change. 

Linear Dodge Looks at the  color information  in  each  channel and  brightens the  base  color to reflect  the blend  color  

by increasing the brightness. Blending with black produces no change. 

Overlay Multiplies or screens the colors, depending on the base color. Patterns or colors overlay the existing pixels 

while preserving the highlights and shadows of the base color. The base color is not replaced but is mixed with the 

blend color to reflect the lightness or darkness of the original color. 

Soft Light Darkens or lightens the colors, depending on the blend color. The effect is similar to shining a diffused 

spotlight on the image. 

If the blend color (light source) is lighter than 50% gray, the image is lightened as if it were dodged. If the blend color 

is darker than 50% gray, the image is darkened as if it were burned in. Painting with pure black or white produces a 

distinctly darker or lighter area but does not result in pure black or white. 
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Hard Light Multiplies or screens the colors, depending on the blend color. The effect is similar to shining a harsh 

spotlight on the image. 

If the blend color (light source) is lighter than 50% gray, the image is lightened, as if it were screened. This is useful 

for adding highlights to an image. If the blend color is darker than 50% gray, the image is darkened, as if it were multi

plied. This is useful for adding shadows to an image. Painting with pure black or white results in pure black or white. 

Vivid Light Burns or dodges the  colors  by  increasing  or  decreasing  the contrast,  depending on the  blend color. If the  

blend color (light source) is lighter than 50% gray, the image is lightened by decreasing the contrast. If the blend color 

is darker than 50% gray, the image is darkened by increasing the contrast. 

Linear Light Burns or dodges the colors by decreasing or increasing the brightness, depending on the blend color. 

If the blend color (light source) is lighter than 50% gray, the image is lightened by increasing the brightness. If the 

blend color is darker than 50% gray, the image is darkened by decreasing the brightness. 

Pin Light Replaces the colors, depending on the blend color. If the blend color (light source) is lighter than 50% gray, 

pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change. If the blend 

color is darker than 50% gray, pixels lighter than the blend color are replaced, and pixels darker than the blend color 

do not change. This is useful for adding special effects to an image. 

Difference Looks at the color information in each channel and subtracts either the blend color from the base color 

or the base color from the blend color, depending on which has the greater brightness value. Blending with white 

inverts the base color values; blending with black produces no change. 

Exclusion Creates an effect similar to but lower in contrast than the Difference mode. Blending with white inverts 

the base color values. Blending with black produces no change. 

Hue Creates a result color with the luminance and saturation of the base color and the hue of the blend color. 

Saturation Creates a result color with the luminance and hue of the base color and the saturation of the blend color. 

Painting with this mode in an area with no (0) saturation (gray) causes no change. 

Color Creates a result color with the luminance of the base color and the hue and saturation of the blend color. This 

preserves the gray levels in the image and is useful for coloring monochrome images and for tinting color images. 

Luminosity Creates a result  color with the  hue and  saturation  of  the base color  and the  luminance of the  blend color.  

This mode creates an inverse effect from that of the Color mode. 

See also 

“About blending modes” on page 410 

“Blending mode examples” on page 488 

Blending mode examples 

These examples show the result of painting part of the image’s face using each blending mode. 
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Original Image Normal, 100% opacity Normal, 50% opacity Dissolve, 50% opacity 

Behind Clear Darken Multiply 

Color Burn Linear Burn Lighten Screen 

Color Dodge Linear Dodge Overlay Soft Light 
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Hard Light Vivid Light Linear Light Pin Light 

Hard Mix Difference Exclusion Hue 

Saturation Color Luminosity, 80% opacity 

Erasing 

To use the Eraser tool 
The Eraser tool changes pixels in the image as you drag through them. If you’re working in the background or in a 

layer with transparency locked, the pixels change to the background color; otherwise, the pixels are erased to trans

parency. You can also use the eraser to return the affected area to a state selected in the History palette. 

1 Select the Eraser tool 

2 Do the following in the options bar: 

. 

•	 Choose a brush and set brush options (Photoshop), or choose a preset brush (ImageReady). This option is not 

available for Block mode. 

•	 Choose a mode for the eraser—Brush (Photoshop), Paintbrush (ImageReady), Airbrush (ImageReady), Pencil, or 

Block. 

•	 Specify an opacity to define the strength of the erasure. An opacity of 100% erases pixels completely. A lower 

opacity erases pixels partially. (This option is not available for Block mode in Photoshop.) 

•	 (Photoshop) In Brush mode, specify a flow rate. Flow specifies how quickly paint is applied by the tool. 

•	 (Photoshop) In Brush mode, click the airbrush button  to use the brush as an airbrush. 

•	 (Photoshop) To erase to a saved state or snapshot of the image, click the left column of the state or snapshot in the 

History palette, and then select Erase To History in the options bar. 
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Photoshop) To temporarily use the Eraser tool in Erase to History mode, hold down Alt (Windows) or Option

(Mac OS) as you drag in the image.

3 Drag through the area you want to erase.

To use the Magic Eraser tool
When you click in a layer with the Magic Eraser tool, the tool automatically changes all similar pixels. If you’re

working in the background, or in a layer with locked transparency, the pixels change to the background color;

otherwise, the pixels are erased to transparency. You can choose to erase contiguous pixels only or all similar pixels

on the current layer.

Example of erasing similar pixels

1 Select the Magic Eraser tool .

2 Do the following in the options bar:

• Enter a tolerance value to define the range of colors that can be erased. A low tolerance erases pixels within a range

of color values very similar to the pixel you click. A high tolerance erases pixels within a broader range.

• Select Anti-aliased to smooth the edges of the area you erase.

• Select Contiguous to erase only pixels contiguous to the one you click, or deselect to erase all similar pixels in the

image.

• Select Sample All Layers to sample the erased color using combined data from all visible layers.

• Specify an opacity to define the strength of the erasure. An opacity of 100% erases pixels completely. A lower

opacity erases pixels partially.

3 Click in the part of the layer you want to erase.

The Background Eraser tool
The Background Eraser tool lets you erase pixels on a layer to transparency as you drag; this allows you to erase the

background while maintaining the edges of an object in the foreground. By specifying different sampling and

tolerance options, you can control the range of the transparency and the sharpness of the boundaries.

The background eraser samples the color in the center of the brush, also called the hot spot, and deletes that color

wherever it appears inside the brush. It also performs color extraction at the edges of any foreground objects, so that

color halos are not visible if the foreground object is later pasted into another image.

Note: The background eraser overrides the lock transparency setting of a layer.

If you want to erase the background of an object with intricate or wispy edges, use the Extract command.
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To use the Background Eraser tool 
1 In the Layers palette, select the layer containing the areas you want to erase. 

2 Select the Background Eraser tool 

3 Click the brush sample in the options bar and set brush options in the pop-up palette: 

. 

•	 Choose settings for the Diameter, Hardness, Spacing, Angle, and Roundness options (see “Brush tip shape 

options” on page 476). 

•	 If you’re using a pressure-sensitive digitizing tablet, choose options from the Size and Tolerance menus to vary the 

size and tolerance of the background eraser over the course of a stroke. Choose Pen Pressure to base the variation 

on the pen pressure. Choose Stylus Wheel to base the variation on the position of the pen thumbwheel. Choose 

Off if you don’t want to vary the size or tolerance. 

4	 Do the following in the options bar: 

•	 Choose a Limits mode for erasing: Discontiguous to erase the sampled color wherever it occurs under the brush, 

Contiguous to erase areas that contain the sampled color and are connected to one another, and Find Edges to 

erase connected areas containing the sampled color while better preserving the sharpness of shape edges. 

•	 For Tolerance, enter a value or drag the slider. A low tolerance limits erasure to areas that are very similar to the 

sampled color. A high tolerance erases a broader range of colors. 

•	 Select Protect Foreground Color to prevent the erasure of areas that match the foreground color in the toolbox. 

•	 Choose a Sampling option: Continuous to sample colors continuously as you drag, Once to erase only areas 

containing the color that you first click, and Background Swatch to erase only areas containing the current 

background color. 

5 Drag through the area you want to erase. The Background Eraser tool pointer appears as a brush shape with a 

cross hair indicating the tool’s hot spot . 

To use the Auto Erase option with the Pencil tool 
The Auto Erase option for the Pencil tool lets you paint the background color over areas containing the foreground


color.


1 Specify foreground and background colors.


2 Select the Pencil tool


3 Select Auto Erase in the options bar.


4 Drag over the image.


If the center of the cursor is over the foreground color when you begin dragging, the area is erased to the background


. 

color. If the center of the cursor is over an area that doesn’t contain the foreground color when you begin dragging, 

the area is painted with the foreground color. 

Gradients 

To apply a gradient fill 
The Gradient tool creates a gradual blend between multiple colors. You can choose from preset gradient fills or create 

your own. 
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Note: The Gradient tool cannot be used with bitmap, indexed-color, or 16-bits-per-channel images. 

You fill an area with a gradient by dragging in the image. The starting point (where the mouse is pressed) and ending 

point (where the mouse is released) affect the gradient appearance, depending on the Gradient tool used. 

1 To fill part of the image, select the desired area. Otherwise, the gradient fill is applied to the entire active layer.


2 Select the Gradient tool


3 Choose a gradient fill in the options bar:


. 

•	 Click the triangle next to the gradient sample to pick a preset gradient fill. 

•	 Click inside  the gradient sample to view the  Gradient  Editor. Select a preset  gradient  fill, or create a new gradient  

fill. Then click OK. (See “To create a smooth gradient” on page 494.) 

4 Select an option for applying the gradient fill in the options bar: 

Linear gradient Shades from the starting point to the ending point in a straight line. 

Radial gradient Shades from the starting point to the ending point in a circular pattern. 

Angle gradient Shades in a counterclockwise sweep around the starting point. 

Reflected gradient Shades using symmetric linear gradients on either side of the starting point. 

Diamond gradient Shades from the starting point outward in a diamond pattern. The ending point defines one 

corner of the diamond. 

5	 Do the following in the options bar: 

•	 Specify a blending mode and opacity for the paint. (See “List of blending modes” on page 487.) 

•	 To reverse the order of colors in the gradient fill, select Reverse. 

•	 To create a smoother blend with less banding, select Dither. 

•	 To use a transparency mask for the gradient fill, select Transparency. (See “To specify the gradient transparency” 

on page 495.) 

6 Position the pointer in the image where you want to set the starting point of the gradient, and drag to define the 

ending point. To constrain the line angle to a multiple of 45˚, hold down Shift as you drag. 

About the Gradient Editor 
The Gradient Editor dialog box lets you define a new gradient by modifying a copy of an existing gradient. You can 

also add intermediate colors to a gradient, creating a blend between more than two colors. 
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B 

A 

D	 E 

Gradient Editor dialog box 
A. Palette menu B. Opacity stop C. Color stops D. Adjust values or delete the selected opacity or color stop E. Midpoint 

To create a smooth gradient

1 Select the Gradient tool


2 Click inside the gradient sample in the options bar to display the Gradient Editor dialog box.


3 To base the new gradient on an existing gradient, select a gradient in the Presets section of the dialog box.


4 Choose Solid from the Gradient Type pop-up menu.


5 To define the starting color of the gradient, click the left color stop


. 

 under the gradient bar. The triangle above 

the stop turns black , indicating that the starting color is being edited. 

6 To choose a color, do one of the following: 

•	 Double-click the color stop, or click the color swatch in the Stops section of the dialog box. Choose a color, and 

click OK. 

•	 Choose an option from the Color pop-up menu in the Stops section of the dialog box. 

•	 Position the pointer over the gradient bar (the pointer turns into the eyedropper), and click to sample a color, or 

click anywhere in the image to sample a color from the image. 

7 To define the ending color, click the right color stop under the gradient bar. Then choose a color. 

8 To adjust the location of the starting point or ending point, do one of the following: 

•	 Drag the corresponding color stop left or right to the location you want. 

•	 Click the corresponding color stop, and enter a value for Location in the Stops section of the dialog box. A value 

of 0% places the point at the far left end of the gradient bar; a value of 100%, at the far right end. 

9 To adjust the location of the midpoint (where the gradient displays an even mix of the starting and ending colors), 

drag the diamond below the gradient bar to the left or right, or click the diamond and enter a value for Location. 

10 To add intermediate colors to a gradient, click below the gradient bar to define another color stop. Specify the 

color and adjust the location and midpoint for the intermediate point as you would for a starting or ending point. 

11 To delete the color stop you are editing, click Delete. 
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12 To set the smoothness for the entire gradient, enter a value in the Smoothness text box, or drag the Smoothness


pop-up slider.


13 If desired, set transparency values for the gradient.


14 Enter a name for the new gradient.


15 To save the gradient as a preset, click New after you have finished creating the gradient.


Note: New presets are saved in a Preferences file. If this file is deleted or damaged, or if you reset presets to the default 

library, the new presets will be lost. To permanently save new presets, save them in a library. 

To specify the gradient transparency 
Each gradient fill contains settings that control the opacity of the fill at different locations on the gradient. For 

example, you can set the starting color to 100% opacity and have the fill gradually blend into an ending color with 

50% opacity. The checkerboard pattern indicates the amount of transparency in the gradient preview. 

1 Create a gradient. 

2 To  adjust  the starting opacity, click  the left opacity  stop  above the  gradient  bar.  The triangle below  the stop turns 


black, indicating that the starting transparency is being edited.


3 In the Stops section of the dialog box, enter a value in the Opacity text box, or drag the Opacity pop-up slider.


4 To adjust the opacity of the endpoint, click the right transparency stop above the gradient bar. Then set the opacity


in the Stops section.


5 To adjust the location of the starting or ending opacity, do one of the following:


• Drag the corresponding opacity stop to the left or right. 

• Select the corresponding opacity stop, and enter a value for Location. 

6 To adjust the location of the midpoint opacity (the point midway between the starting and ending opacities), do 

one of the following: 

• Drag the diamond above the gradient bar to the left or right. 

• Select the diamond and enter a value for Location. 

7 To delete the opacity stop you are editing, click Delete. 

8 To add an intermediate opacity to the mask, click above the gradient bar to define a new opacity stop. You can then 

adjust and move this opacity as you would for a starting or ending opacity. To remove an intermediate opacity, drag 

its transparency stop up and off the gradient bar. 

9 To create a preset gradient, enter a name in the Name text box and click New. This creates a new gradient preset 

with the transparency setting you specified. 

To create a noise gradient 
A noise gradient is a gradient that contains randomly distributed colors within the range of colors that you specify. 
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B 

C 

Gradient with different Noise values. 
A. 10% noise B. 50% noise C. 90% noise 

1 Select the Gradient tool


2 Click in the gradient sample in the options bar to display the Gradient Editor dialog box.


3 To base the new gradient on an existing gradient, select a gradient in the Presets section of the dialog box.


4 Choose Noise from the Gradient Type pop-up menu.


5 To set the roughness for the entire gradient, enter a value in the Roughness text box, or drag the Roughness pop-up


. 

slider.


6 To define the color model, choose a color model from the Color Model list.


7 To adjust the range of colors, drag the sliders. For each color component of the color model you’ve selected, you


can drag the sliders to define the range of acceptable values. For example, if you choose the HSB model, you can


restrict the gradient to blue-green hues, high saturation, and medium brightness.


8 Set the options to restrict colors or to add transparency.


9 To randomize a gradient that conforms to the settings, click the Randomize button until you find a setting you like.


10 To create a preset gradient, enter a name in the Name text box and click New. This creates a new preset gradient


with the settings you specified.


To save a set of preset gradients as a library 
1 Click Save in the Gradient Editor dialog box, or choose Save Gradients from the Gradient Picker menu in the 

options bar. 

2	 Choose a location for the gradient library, enter a file name, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/Gradients folder inside the 

Photoshop program folder, the library name will appear at the bottom of the palette menu after you restart 

Photoshop. 

See also 

“About the Preset Manager” on page 67 

To load a library of preset gradients 
❖ Do one of the following in the Gradient Editor dialog box: 

•	 Click Load to add a library to the current list. Select the library file you want to use, and click Load. 

•	 Choose Replace Gradients from the palette menu to replace the current list with a different library. Select the 

library file you want to use, and click Load. 

•	 Choose a library file from the bottom of the palette menu. Click OK to replace the current list, or click Append to 

append the current list. 
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Note: You can also choose Load Gradients, Replace Gradients, or choose a library of gradients from the Gradient Picker 

menu in the options bar. 

See also 

“About the Preset Manager” on page 67 

To return to the default library of preset gradients 
❖ Choose Reset Gradients from the palette menu. You can either replace the current list or append the default library 

to the current list. 

To change how preset gradients are displayed 
❖ Choose a display option from the palette menu: 

Text Only Displays the gradients as a list. 

Small or Large Thumbnail Displays the gradients as thumbnails. 

Small or Large List Displays the gradients as a list with thumbnails. 

To rename a preset gradient 
•	 If the palette is set to display gradients as thumbnails, double-click a gradient, enter a new name, and click OK. 

•	 If the palette is set to display gradients as a list or text only, double-click a gradient, enter a new name inline, and 

press Enter (Windows) or Return (Mac OS). 

Filling and stroking selections and layers 

To use the Paint Bucket tool 
The Paint Bucket tool fills adjacent pixels that are similar in color value to the pixels you click. 

Note: The Paint Bucket tool cannot be used with images in Bitmap mode. 

1 Choose a foreground color. (See “To choose colors in the toolbox” on page 504.)


2 Select the Paint Bucket tool


3 (Photoshop) Specify whether to fill the selection with the foreground color or with a pattern.


4 Specify a blending mode and opacity for the paint. (See “List of blending modes” on page 487.)


5 Enter the tolerance for the fill.


The tolerance defines how similar in color a pixel must be to be filled. Values can range from 0 to 255. A low tolerance


. 

fills pixels within a range of color values very similar to the pixel you click. A high tolerance fills pixels within a 

broader range. 

6	 To smooth the edges of the filled selection, select Anti-aliased. 

7 To fill only pixels contiguous to the one you click, select Contiguous; leave Contiguous unselected to fill all similar 

pixels in the image. 
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8 To fill pixels based on the merged color data from all visible layers, select All Layers.


9 Click the part of the image you want to fill. All specified pixels within the specified tolerance are filled with the


foreground color or pattern.


If you’re working on a layer and don’t want to fill transparent areas, make sure that the layer’s transparency is locked


in the Layers palette. (See “Locking layers” on page 405.)


To fill a selection or a layer with a foreground or background color

1 Choose a foreground or background color. (See “To choose colors in the toolbox” on page 504.)


2 Select the area you want to fill. To fill an entire layer, select the layer in the Layers palette.


3 Choose  Edit  > Fill to fill the  selection or layer. Or to fill a path, select the  path  and choose Fill Path from the  Paths 


palette menu.


4 In the Fill dialog box, choose one of the following options for Use, or select a custom pattern:


Foreground Color, Background Color, Black, 50% Gray, or White Fills the selection with the specified color.


Color Fills with a color you select from the Color Picker. 

Pattern Fills the selection with a pattern. Click the inverted arrow next to the pattern sample and select a pattern 

from the pop-up palette. You can load additional patterns using the pop-up palette menu. Select the name of a library 

of patterns or choose Load Patterns and navigate to the folder containing the patterns you want to use. 

History Restores the selected area to a state or snapshot of the image set as the source in the History palette. 

Note: If you fill a CMYK image using the Black option, Photoshop fills all the channels with 100% black. This may result 

in more ink than is allowable by the printer. For best results when filling a CMYK image, use the Foreground option with 

the foreground color set to an appropriate black. 

5 Specify the blending mode and opacity for the paint. (See “List of blending modes” on page 487.) 

6 If you’re working in a layer and want to fill only areas containing pixels, choose Preserve Transparency. 

7 Click the OK button to apply the fill. 

To apply a foreground color fill only to the areas that contain pixels, press Alt+Shift+Backspace (Windows) or 

Option+Shift+Delete (Mac OS). This preserves the transparency of the layer. To apply a background color fill only 

to the areas that contain pixels, press Ctrl+Shift+Backspace (Windows) or Command+Shift+Delete (Mac OS). 

To fill the work canvas

1 Set the foreground color you want to use for the canvas.


2 Select the Paint Bucket tool


3 In the options bar, set Fill to Foreground.


4 Hold down Shift, and click in the work canvas.


. 

Note: You need to be in full screen mode and viewing the menus to fill the work canvas. 
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To fill a selection with a pattern 
1 Select the part of the image you want to fill. 

2 Do one of the following: 

•	 Choose Edit > Fill. In the Fill dialog box, for Use, choose Pattern, select a pattern from the pop-up palette, and 

click OK. 

If Pattern is dimmed, you need to load a pattern library before you can select this option. 

•	 Select  the Paint  Bucket  tool  . In the  options bar, choose Pattern  from  the Fill pop-up menu and  select  a pattern  

from the Pattern pop-up palette. Then click to fill the selected area with the pattern. 

Note: You can load additional pattern libraries into the pop-up palette prior to making a selection. (See “To load a 

library of patterns” on page 501.) 

Stroking a selection or layer with color 
You can use the Stroke command to paint a colored border around a selection, layer, or path. This allows you to create


a softer border than one created using the Stroke layer style.


The Stroke layer style provides a resolution-independent method to stroke a shape. You can use the Stroke layer effect


when you want to stroke the entire layer.


If  you want a quick way  to  create  a stroke on the  current layer—without  necessarily following  the edge of the  layer— 


use the Stroke command.


To stroke a selection or layer

1 Choose a foreground color.


2 Select the area or layer you want to stroke.


3 Choose Edit > Stroke.


4 In the Stroke dialog box, specify the width of the hard-edged border.


5 For Location, specify whether to place the border inside, outside, or centered over the selection or layer bound


aries.


6 Specify an opacity and a blending mode. (See “List of blending modes” on page 487.)


7 If you’re working in a layer and want to stroke only areas containing pixels, select the Preserve Transparency


option. (See “Locking layers” on page 405.)


To stroke a path

1 Select the path in the Paths palette.


2 Choose Stroke Path from the palette menu.


3 In the Stroke Path dialog box, choose a tool to stroke the path.
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To draw a circle or square 
You can  draw a circle or square using  the elliptical or rectangular  marquee tools, and  then  add a line (called  a  stroke) 

to the selection marquee. Stroking a selection is a quick way to add a border or frame around an object. You can 

stroke any selection you create with the selection tools. 

1 In the Layers palette, click the New Layer button  to create a new layer for the circle or square. Isolating the 

circle or square on its own layer makes it easier to work with. 

2 Select the Elliptical Marquee tool  or the Rectangular Marquee tool  in the toolbox. 

3 Drag in the document window to create the shape. Hold down the Shift key while dragging to constrain the shape


to a circle or square.


4 Choose Edit > Stroke.


5 In  the Stroke dialog box, type a value for  Width,  and then click  the color  swatch  to  display the  Adobe Color  Picker. 


6 In the Adobe Color Picker, locate the color range you want using the triangle sliders on the color spectrum bar,


and then click the desired color in the color field. The color you select appears in the top half of the color swatch. The


original color remains in the bottom half. Click OK.


7 Set the location for the stroke in relationship to the marquee by choosing Inside, Center, or Outside. Adjust the


other settings as desired and click OK. Photoshop strokes the line using the color and stroke settings you set.


See also 

“Stroking a selection or layer with color” on page 499 

Creating and managing patterns 

About patterns 
A pattern  is  an  image that is repeated,  or  tiled, when you use it to fill a layer or selection. Photoshop and ImageReady 

come with a variety of preset patterns. 

In Photoshop, you can create new patterns and save them in libraries for use with different tools and commands. 

Preset patterns are displayed in pop-up palettes in the options bar for the Paint Bucket, Pattern Stamp, Healing Brush, 

and Patch tools, as well as in the Layer Style dialog box. You can change how patterns are displayed in the pop-up 

palettes by choosing a display option from the pop-up palette menu. You can also manage pattern presets using the 

preset manager. 

In ImageReady, you can define a single pattern, called the User Defined Pattern, which you can use to fill selections 

and layers. 

Photoshop also provides the Pattern Maker filter to create pattern presets, or fill a layer or selection with a custom 

pattern. 

See also 

“The Pattern Maker filter” on page 502 

“Using tool presets” on page 48 
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To define an image as a preset pattern 
1 Use the Rectangle Marquee tool  on any open image to select an area to use as a pattern. Feather must be set 

to 0 pixels. Note that large images may become unwieldy. 

2 Choose Edit > Define Pattern.


3 (Photoshop) Enter a name for the pattern in the Pattern Name dialog box.


Note: If you are using a pattern from one image and applying it to another, Photoshop converts the color mode. 

Photoshop comes with a set of Illustrator format files that you can use to define a preset pattern. Each file in the 

PostScript Patterns folder contains a single pattern that you can scale and render at any resolution. Open the file, 

select any rendering option, and then define the pattern. 

To load a library of patterns 
Choose one of the following from a Pattern pop-up palette menu: 

•	 Load Patterns to add a library to the current list. Select the library file you want to use, and click Load. 

•	 Replace Patterns to replace the current list with a different library. Select the library file you want to use, and click 

Load. 

•	 A library file (displayed at the bottom of the palette menu). Click OK to replace the current list, or click Append 

to append the current list. 

To save a set of preset patterns as a library 
1 Choose Save Patterns from a Pattern pop-up palette menu. 

2 Choose a location for the pattern library, enter a file name, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/Patterns folder inside the 

Photoshop program folder, the library name will appear at the bottom of the Pattern pop-up palette menus after you 

restart Photoshop. 

To return to the default library of patterns 
❖ Choose Reset Patterns from a Pattern pop-up palette menu. You can either replace the current list or append the 

default library to the current list. 

If you receive a Pattern Stamp tool preset that uses an undefined pattern, or if you erase the preset you’re using by 

resetting or replacing the pattern library, choose New Pattern from the Pattern pop-up palette menu to redefine the 

pattern. 

To rename a preset pattern

1 Select the pattern you want to rename, and choose Rename Pattern from the palette menu.


2 Enter a new name for the pattern, and click OK.
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To delete a preset pattern 
❖ Do one of the following: 

•	 Select the pattern you want to delete, and choose Delete Pattern from the palette menu. 

•	 Hold down Alt (Windows) or Option (Mac OS), position the pointer over a pattern (the pointer turns into 

scissors), and click. 

The Pattern Maker filter 
The Pattern Maker filter slices and reassembles an image to make a pattern. The Pattern Maker works in two ways: 

•	 Fills a layer or selection with a pattern. The pattern can be made of one large tile, or multiple duplicate tiles. 

• Creates tiles that you can save as a pattern preset and use with other images. 

You can generate multiple patterns from the same sample until you find one that you like. 

To generate a pattern using the Pattern Maker 
1 Do one of the following: 

•	 Select the layer that contains the area from which you want to generate the pattern. The layer you select will be 

replaced by the generated pattern, so it’s a good idea to make a copy of the layer first. 

•	 To generate a pattern in a new layer or file, make a rectangular selection of the image you are using to generate the 

pattern,  and choose Edit  >  Copy. Then add  a layer  to  the image, or create a new file with the  dimensions you  want  

the final image to have. 

2	 Choose Filter > Pattern Maker. 

3	 Specify the source of the pattern. 

•	 Choose Use Clipboard As Sample to use the contents of the clipboard if you copied an image before you opened 

the Pattern Maker. 

•	 Make a selection in the preview area with the Pattern Maker’s Marquee tool . To move the selection marquee, 

drag it to a different location. 

Note: You can use the Zoom and Hand tools to navigate in the preview area. Use Alt (Windows) or Option (Mac OS) 

with the Zoom tool to zoom out. The magnification appears at the bottom of the dialog box. 

4	 Specify the tile size. 

•	 Enter pixel dimensions in the Width and Height boxes.


• Click Use Image Size to generate a pattern with one tile that fills the layer.


5 Click Generate. You can press Esc to cancel the generation.


The preview area is tiled with the generated pattern.


•	 To switch between the generated preview and the source image, choose an option from the Show menu.


•	 To view the boundary of individual tiles, click Tile Boundaries.


•	 To offset the tiles in the generated pattern, choose a direction from the Offset pop-up menu and specify an offset 

amount in the Amount text box. The offset amount is a percentage of the tile dimension in the specified direction. 

The offset has no effect on saved pattern preset tiles. 
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6 Click Generate Again to generate additional patterns using the same options, or adjust the options and then click 

Generate Again. 

Smoothness Adjusts the sharp edges in the pattern. Increase the smoothness to reduce edges. 

Sample Detail Specifies the size of pattern slices in the tile. A high value maintains more of the original detail in the 

pattern. A low value uses smaller slices in the tile. Tiles take longer to generate when you use a high value. 

7 Navigate through the generated tiles in the Tile History panel to select the tile that you want to use to fill the layer 

or to save as a pattern preset. 

•	 To move through the tiles you’ve generated, click the First Tile button, Previous Tile button, Next Tile button, or 

Last Tile button. Or, type the number of the pattern preview you want to view, and press Enter (Windows) or 

Return (Mac OS). 

•	 To view how the tile looks as a repeating pattern in the preview area, make sure that Update Pattern Preview is 

selected. If tile previewing is slow, deselect this option, find the tile you want, and then select the option. 

•	 To delete a tile and pattern preview, navigate to the tile you want to delete, and click the Delete icon. 

•	 To save a tile as a preset pattern, navigate to the tile you want to save, and click the Preset Pattern button. Enter a 

preset name, and click OK. When you save a tile as a preset pattern, only a single tile is saved, not the full, generated 

pattern. 

A B C  D E F 

Tile History buttons 
A. Preset Pattern B. First Tile C. Previous Tile D. Next Tile E. Last Tile F. Delete icon 

8 When  you are  satisfied with a pattern preview  and you  have  saved the  tiles that you  might want to use  in  the future,  

click OK to fill the layer or selection. 

If you are creating preset patterns only, click Cancel to close the dialog box without filling the layer. 

See also 

“About the Preset Manager” on page 67 

Choosing foreground and background colors 

About the foreground and background colors 
Photoshop uses the foreground color to paint, fill, and stroke selections and the background color to make gradient 

fills and fill in the erased areas of an image. The foreground and background colors are also used by some special 

effects filters. 

You can designate a new foreground or background color using the Eyedropper tool, the Color palette, the Swatches 

palette, or the Adobe Color Picker. 

The default foreground color is black, and the default background color is white. (In an alpha channel, the default 

foreground is white, and the background is black.) 

 



504 ADOBE PHOTOSHOP CS2 
User Guide 

See also 

“About the Adobe Color Picker” on page 241 

To choose colors in the toolbox 
The current foreground color appears in the upper color selection box in the toolbox; the current background color 

appears in the lower box. 

A 

B 

C 

D 

Foreground and background color boxes in toolbox 
A. Foreground color box B. Default Colors icon C. Switch Colors icon D. Background color box 

•	 To change the foreground color, click the upper color selection box in the toolbox, and then choose a color in the 

Adobe Color Picker. 

•	 To change the background color, click the lower color selection box in the toolbox, and then choose a color in the 

Adobe Color Picker. 

•	 To reverse the foreground and background colors, click the Switch Colors icon in the toolbox. 

•	 To restore the default foreground and background colors, click the Default Colors icon in the toolbox. 

See also 

“About the Adobe Color Picker” on page 241 

To choose colors with the Eyedropper tool 
The Eyedropper tool samples color to designate a new foreground or background color. You can sample from the 

active image or from anywhere else on the screen. 

1	 Select the Eyedropper tool . 

2	 To change the sample size of the eyedropper, choose an option from the Sample Size menu: 

Point Sample Reads the precise value of the pixel you click. 

3 by 3 Average or 5 by 5 Average Reads the average value of the specified number of pixels within the area you 

click. 

3	 Do one of the following: 

•	 To select a new foreground color, click in the image. Alternatively, position the pointer over the image, press the 

mouse button, and drag anywhere on the screen. The foreground color selection box changes dynamically as you 

drag. Release the mouse button to pick the new color. 

•	 To select a new background color, Alt-click (Windows) or Option-click (Mac OS) in the image. Alternatively, 

position the pointer over the image, press Alt (Windows) or Options (Mac OS), press the mouse button, and drag 

anywhere on the screen. The background color selection box changes dynamically as you drag. Release the mouse 

button to pick the new color. 

To use the Eyedropper tool temporarily while using any painting tool, hold down Alt (Windows) or Option (Mac OS). 
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About the eyedropper sample size 
You can specify the area sampled by the Eyedropper tool. For example, you can set the eyedropper to sample the color 

values of a 3-by-3-pixel area under the pointer. Modifying the sample size of the eyedropper affects the color readouts 

displayed in the Info palette. 

A 

B 

Selecting a foreground color with the Eyedropper tool 
A. Point sample B. 5 x 5 average sample 

About the Color palette 
The Color palette displays the color values for the current foreground and background colors. Using the sliders in 

the Color palette, you can edit the foreground and background colors using different color models. You can also 

choose a foreground or background color from the spectrum of colors displayed in the color ramp at the bottom of 

the palette. 

• To display the Color palette, choose Window > Color, or click the Color palette tab. 

• To change the color model of the color sliders, choose a Sliders option from the Color palette menu. 

A 
B 

C 

D 

Color palette 
A. Foreground color B. Background color C. Slider D. Color ramp 

The Color palette may display the following alerts when you select a color: 

• In Photoshop, an exclamation point inside a triangle  appears above the left side of the color ramp when you 

choose a color that cannot be printed using CMYK inks. 

• A cube  appears above the left side of the color ramp when you choose a color that is not web-safe. 

See also 

“Web-safe colors” on page 245 

“About out-of-gamut colors” on page 283 

“Color modes” on page 227 
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To change the spectrum displayed in the color palette 
1 Choose an option from the Color palette menu: 

•	 RGB Spectrum, CMYK Spectrum (Photoshop), or Grayscale Ramp to display the spectrum of the specified color 

model. 

•	 Current Colors to display the spectrum of colors between the current foreground color and the current 

background color. 

2	 To display only web-safe colors, choose Make Ramp Web Safe. 

To change the spectrum of the color ramp quickly, Shift-click in the color ramp until you see the spectrum you want. 

See also 

“Web-safe colors” on page 245 

To select a color in the Color palette 
1 To edit the foreground or background color, make sure that its color selection box is active (outlined in black) in 

the Color palette. To make the foreground or background color selection box active, click the box. 

2 Do one of the following: 

•	 Drag the color sliders. By default, the slider colors change as you drag. In Photoshop, you can turn off this feature 

to improve performance by deselecting Dynamic Color Sliders in the General section of the Preferences dialog 

box. 

•	 Enter values next to the color sliders. 

•	 Click the color selection box, choose a color using the color picker and click OK. 

•	 Position the pointer over the color ramp (the pointer becomes the eyedropper), and click to sample a color. Alt

click to apply the sample to the nonactive color selection box. 

See also 

“About the Adobe Color Picker” on page 241 

About the Swatches palette 
The Swatches palette stores colors that you need to use often. You can add or delete colors from the palette or display 

different libraries of colors for different projects. 

To display the Swatches palette, choose Window > Swatches, or click the Swatches palette tab. 

To change how swatches are displayed 
❖ Choose a display option from the Swatches palette menu:


Small Thumbnail Displays a thumbnail of each swatch. This is the default view.


Small List Displays the name and thumbnail of each swatch. 
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To select a color in the Swatches palette 
•	 To choose a foreground color, click a color in the Swatches palette. 

•	 To choose a background color, Ctrl-click (Windows) or Command-click (Mac OS) a color in the Swatches palette. 

To load a library of swatches 
❖ Choose one of the following from the Swatches palette menu: 

•	 Load Swatches to add a library to the current list. Select the library file you want to use, and click Load. 

•	 Replace Swatches to replace the current list with a different library. Select the library file you want to use, and click 

Load. 

•	 A library file (displayed at the bottom of the palette menu). Click OK to replace the current list, or click Append 

to append the current list. 

See also 

“About the Preset Manager” on page 67 

“To share swatches between applications” on page 256 

To add a color to the Swatches palette 
❖ Do one of the following: 

•	 Decide  which color  you want to add  and make it the  foreground  color,  and then click  the New  Swatch  button  

in the Swatches palette. Alternatively, choose New Swatch from the Swatches palette menu. 

•	 (Photoshop) Decide which  color you  want  to  add,  and make it the  foreground  color.  Position  the pointer  over  an  

empty space in the bottom row of the Swatches palette (the pointer turns into the Paint Bucket tool), and click to 

add the color. Enter a name for the new color and click OK. 

Color selected from image (left), and added to Swatches palette (right) 

•	 (ImageReady) Drag the foreground color selection box or the background color selection box from the toolbox to 

the Swatches palette. 

•	 (ImageReady) Drag a swatch from the Color Table palette to the Swatches palette. 

Note: New colors are saved in the Preferences file so that they persist between editing sessions. To permanently save a 

color, save it in a library. 

To duplicate a color in the Swatches palette (ImageReady) 
❖ Select the color you want to duplicate, and choose New Swatch from the Swatches palette menu. 
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To delete a color from the Swatches palette 
1 Do one of the following: 

•	 Drag a swatch to the Delete icon . 

•	 (Photoshop) Hold down Alt (Windows) or Option (Mac OS), position the pointer over a swatch (the pointer turns 

into scissors), and click. 

•	 (ImageReady) Select a swatch, and choose Delete Swatch from the Swatches palette menu. 

To save a set of swatches as a library 
1 Choose Save Swatches from the Swatches palette menu. 

2 Choose a location for the swatch library, enter a file name, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/Swatches folder inside the 

Photoshop program folder, the library name will appear at the bottom of the Swatches palette menu after you restart 

the application. 

To return to the default library of swatches 
❖ Choose Reset Swatches from the Swatches palette menu. You can either replace the current list or append the 

default library to the current list. 
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Chapter 18: Applying filters for special 
effects 

Filters 

Using filters 
Filters let you change the look of your images, for instance by giving them the appearance of impressionistic paintings 

or mosaic tiles, or adding unique lighting or distortions. You can also use some filters to clean up or retouch your 

photos. The filters provided by Adobe appear in the Filter menu. Some filters provided by third-party developers are 

available as plug-ins. Once installed, these plug-in filters appear at the bottom of the Filter menu. 

To use a filter, choose the appropriate submenu command from the Filter menu. These guidelines can help you in 

choosing filters: 

•	 Filters are applied to the active, visible layer or a selection. 

•	 For 8-bits-per-channel images, most filters can be applied cumulatively through the Filter Gallery. All filters can 

be applied individually. 

•	 Filters cannot be applied to Bitmap-mode or indexed-color images. 

•	 Some filters work only on RGB images. 

•	 All filters can be applied to 8-bit images. 

•	 (Photoshop only) The following filters can be applied to 16-bit images: Liquify, Average Blur, Bilateral Blur, Blur, 

Blur More, Box Blur, Gaussian Blur, Lens Blur, Motion Blur, Radial Blur, Sampled Blur, Lens Correction, Add 

Noise, Despeckle, Dust & Scratches, Median, Reduce Noise, Fibers, Lens Flare, Sharpen, Sharpen Edges, Sharpen 

More, Smart Sharpen, Unsharp Mask, Emboss, Find Edges, Solarize, De-Interlace, NTSC Colors, Custom, High 

Pass, Maximum, Minimum, and Offset. 

•	 (Photoshop only) The following filters can be applied to 32-bit images: Average Blur, Bilateral Blur, Box Blur, 

Gaussian Blur, Motion Blur, Radial Blur, Sampled Blur, Add Noise, Fibers, Lens Flare, Smart Sharpen, Unsharp 

Mask, De-Interlace, NTSC Colors, High Pass, and Offset. 

•	 Some filters are processed entirely in RAM. If all your available RAM is used to process a filter effect, you may get 

an error message. 

Plug-in filters 
You can install plug-in filters developed by non-Adobe software developers. Once installed, the plug-in filters appear 

at the bottom of the Filter menu and work in the same way as built-in filters. 

If you are interested in creating plug-in modules, contact Adobe Systems Developer Support. 

Note: If you have problems or questions about a third-party plug-in, contact the plug-in’s manufacturer for support. 

See also 

“About plug-in modules” on page 69 
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Applying filters 

Previewing filters 
Applying filters—especially to large images—can be time-consuming. Some filters let you preview the effect before 

applying it. You can then choose to apply the filter or cancel the operation without wasting time. 

If the dialog box contains a preview window, use the following methods to preview the effect: 

• Drag in the preview window to center a specific area of the image in the window. 

• Use the + or – button under the preview window to zoom into or zoom out of the preview. 

• In some preview windows, you can click in the image to center a specific area of the image in the window. 

Some filters have dialog boxes that help you customize the filter effect. These filter names are followed by ellipses 

(…). 

To apply a filter 
1 Do one of the following: 

• To apply a filter to an entire layer, make sure that the layer is active or selected. 

• To apply a filter to an area of a layer, select that area. 

2 Choose a filter from the submenus in the Filter menu. 

If no dialog box appears, the filter effect is applied. 

3 If a dialog box appears, enter values or select options, and then click OK. 

The Filter Gallery 

The Filter Gallery 
The Filter Gallery lets you apply filters cumulatively and apply individual filters more than once. You can view 

thumbnail examples of what each filter does. You can also rearrange filters and change the settings of each filter 

you’ve applied to achieve the effect you want. Because it is so flexible, the Filter Gallery is often the best choice for 

applying filters. However, not all filters listed in the Filters menu are available in the Filter Gallery. 

To display the Filter Gallery, choose Filter > Filter Gallery. Clicking a filter category name displays thumbnails of 

available filter effects. 
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Filter Gallery dialog box
A. Preview B. Filter category C. Thumbnail of selected filter D. Show/Hide filter thumbnails E. Filters pop-up menu F. Options for
selected filter G. List of filter effects to apply or arrange H. Filter effect selected but not applied I. Filter effects applied cumulatively but
not selected J. Hidden filter effect

To change the preview display in the Filter Gallery dialog box
❖ Do one of the following

• Use the + or – button under the preview area to zoom into or zoom out of the image.

• Click the zoom bar (where the zoom percentage appears) to choose a zoom percentage.

• Click the Show/Hide button at the top of the dialog box to hide the filter thumbnails. Hiding the thumbnails

expands the preview area.

• Drag in the preview area with the Hand tool to see a different area of the image.

Applying and arranging filter effects
Filter effects are applied in the order you select them. You can rearrange filters after you apply them by dragging a

filter name to another position in the list of applied filters. Rearranging filter effects can dramatically change the way

your image looks. Click the eye icon  next to a filter to hide the effect in the preview image. You can also delete

applied filters by selecting the filter and clicking the Delete icon .

To save time when trying various filters, experiment by selecting a small, representative part of your image.

A B C D E
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Applying filters through the Filter Gallery. 
A. Original image B. Images each with a single filter applied C. Three filters applied cumulatively 

To apply filters from the Filter Gallery 
1 Do one of the following: 

•	 To apply a filter to an entire layer, make sure that the layer is active or selected.


• To apply a filter to an area of a layer, select that area.


2 Choose Filter > Filter Gallery.


3 Click a filter name to add the first filter. You may need to click the inverted triangle next to the filter category to


see the complete list of filters. Once added, the filter appears in the applied filter list at the lower right corner of the


Filter Gallery dialog box.


4 Enter values or select options for the filter you selected.


5 Do any of the following:


•	 To apply filters cumulatively, click the New Effect Layer icon
  and choose an additional filter to apply. Repeat 

this procedure to add more filters. 

•	 To rearrange applied filters, drag the filter to a new position in the applied filter list at the lower right corner of the 

Filter Gallery dialog box. 

• To remove applied filters, select a filter in the applied filter list and click the Delete icon 

6 When you’re satisfied with the results, click OK. 

. 
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Blending filter effects and setting options 

To blend effects 
The Fade command changes the opacity and blending mode of any filter, painting tool, erasing tool, or color 

adjustment. The Fade command blending modes are a subset of those in the painting and editing tools options 

(excluding the Behind and Clear modes). Applying the Fade command is similar to applying the filter effect on a 

separate layer and then using the layer opacity and blending mode controls. 

Note: The Fade command can also modify the effects of using the Extract command, Liquify command, and Brush 

Strokes filters. 

1 Apply a filter, painting tool, or color adjustment to an image or selection. 

2 Choose Edit > Fade. Select the Preview option to preview the effect. 

3 Drag the slider to adjust the opacity, from 0% (transparent) to 100%. 

4 Choose a blending mode from the Mode menu. 

Note: The Color Dodge, Color Burn, Lighten, Darken, Difference, and Exclusion blending modes do not work on Lab 

images. 

5 Click OK. 

See also 

“Brush tip shape options” on page 476 

“About blending modes” on page 486 

“Creating adjustment layers or fill layers” on page 424 

Defining undistorted areas 
The Displace,  Shear,  and Wave filters  in  the Distort  submenu and  the Offset filter in the  Other submenu  let you  treat  

areas undefined (or unprotected) by the filter in the following ways: 

Wrap Around Fills the undefined space with content from the opposite edge of the image. 

Repeat Edge Pixels Extends the colors of pixels along the edge of the image in the direction specified. Banding may 

result if the edge pixels are different colors. 

Set To Background (Offset filter only) Fills the selected area with the current background color. 

To use texture and glass surface controls 
The Conté Crayon, Glass, Rough Pastels, Texturizer, and Underpainting filters have texturizing options. These


options make images appear as if they were painted onto textures such as canvas and brick or viewed through glass


blocks.


1 From the Filter menu, choose Artistic > Rough Pastels, Artistic > Underpainting, Distort > Glass, Sketch > Conté


Crayon, or Texture > Texturizer.


2 For Texture, choose a texture type or choose Load Texture to specify a Photoshop file.


3 Drag the Scaling slider to increase or reduce the effect on the image surface.


4 Drag the Relief slider (if available) to adjust the depth of the texture’s surface.
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5 Select Invert to reverse the light and dark colors on the surface.


6 For Light Direction, indicate the direction from which the light source sheds light on the image.


Tips for creating special effects 

Creating edge effects 
You can use various techniques to treat the edges of an effect applied to only part of an image. To leave a distinct edge, 

simply apply the filter. For a soft edge, feather the edge, and then apply the filter. For a transparent effect, apply the 

filter, and then use the Fade command to adjust the selection’s blending mode and opacity. 

Applying filters to layers 
You can apply filters to individual layers or to several layers in succession to build up an effect. For a filter to affect a 

layer, the layer must be visible and must contain pixels—for example, a neutral fill color. 

Applying filters to individual channels 
You can apply a filter to an individual channel, apply a different effect to each color channel, or apply the same filter 

but with different settings. 

Creating backgrounds 
By applying effects to solid-color or grayscale shapes, you can generate a variety of backgrounds and textures. You 

might then blur these textures. Although some filters have little or no visible effect when applied to solid colors (for 

example, Glass), others produce interesting effects. 

Combining multiple effects with masks or duplicate images 
Using masks to create selection areas gives you more control over transitions from one effect to another. For example, 

you can filter the selection created with a mask. 

You can also use the History Brush tool to paint a filter effect onto part of the image. First, apply the filter to an entire 

image. Next, step back in the History palette to the image state before the filter was applied, and set the history brush 

source to the filtered state. Then paint the image. 

Improving image quality and consistency 
You can disguise faults, alter or enhance images, or create a relationship among images by applying the same effect 

to each. Use the Actions palette to record the steps you take to modify one image, and then apply this action to the 

other images. 

See also 

“To use the Actions palette” on page 729 
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Filter effects 

Artistic filters 
Filters from the Artistic submenu help you achieve painterly and artistic effects for a fine arts or commercial project. 

For example, use the Cutout filter for collages or for typography. These filters replicate natural or traditional media 

effects. All the Artistic filters can be applied through the Filter Gallery. 

Colored Pencil Draws an image using colored pencils on a solid background. Important edges are retained and 

given a rough crosshatch appearance; the solid background color shows through the smoother areas. 

For a parchment effect, change the background color just before applying the Colored Pencil filter to a selected area. 

Cutout Makes an image appear as though it were constructed from roughly cut pieces of colored paper. High

contrast images appear as if in silhouette, and colored images are built up from several layers of colored paper. 

Dry Brush Paints the edges of the image using a dry brush technique (between oil and watercolor). The filter 

simplifies an image by reducing its range of colors to areas of common color. 

Film Grain Applies an even pattern  to  the shadow tones  and midtones.  A smoother,  more  saturated pattern  is  added  

to the lighter areas. This filter is useful for eliminating banding in blends and visually unifying elements from various 

sources. 

Fresco Paints an image in a coarse style using short, rounded, and hastily applied daubs. 

Neon Glow Adds various types of glows to the objects in an image. This filter is useful for colorizing an image while 

softening its look. To select a glow color, click the glow box and select a color from the color picker. 

Paint Daubs Lets you choose from various brush sizes (from 1 to 50) and types for a painterly effect. Brush types 

include Simple, Light Rough, Dark Rough, Wide Sharp, Wide Blurry, and Sparkle. 

Palette Knife Reduces detail in an image to give the effect of a thinly painted canvas that reveals the texture under

neath. 

Plastic Wrap Coats the image in shiny plastic, accentuating the surface detail. 

Poster Edges Reduces the number of colors in an image (posterizes it) according to the posterization option you 

set, and finds the edges of the image and draws black lines on them. Large broad areas have simple shading, and fine 

dark detail is distributed throughout the image. 

Rough Pastels Applies strokes of pastel chalk on a textured background. In areas of bright color, the chalk appears 

thick with little texture; in darker areas, the chalk appears scraped off to reveal the texture. 

Smudge Stick Softens an image using short diagonal strokes to smudge or smear the darker areas. Lighter areas 

become brighter and lose detail. 

Sponge Creates images with highly textured areas of contrasting color, simulating the effect of sponge painting. 

Underpainting Paints the image on a textured background, and then paints the final image over it. 

Watercolor Paints the image in a watercolor style using a medium brush loaded with water and color, simplifying 

details. Where significant tonal changes occur at edges, the filter saturates the color. 

Blur filters 
The Blur filters soften a selection or an entire image, and are useful for retouching. They smooth transitions by 

averaging the pixels next to the hard edges of defined lines and shaded areas in an image. 
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Before (left) and after (right) using the Lens Blur filter; the background is blurred but foreground stays sharp 

Note: To apply a Blur filter to the edges of a layer, deselect the Preserve Transparency option in the Layers palette. 

Average Finds the average color of an image or selection, and then fills the image or selection with the color to 

create a smooth look. For example, if you select an area of grass, the filter changes the area into a homogeneous patch 

of green. 

Blur and Blur More Eliminate noise where significant color transitions occur in an image. Blur filters smooth 

transitions by averaging the pixels next to the hard edges of defined lines and shaded areas. The effect of the Blur 

More filter is three or four times stronger than that of the Blur filter. 

Box Blur (Photoshop only) Blurs an image based on the average color value of neighboring pixels. This filter is 

useful for creating special effects. You can adjust the size of the area used to calculate the average value for a given 

pixel; a larger radius results in greater blurring. 

Gaussian Blur Quickly blurs a selection by an adjustable amount. Gaussian refers to the bell-shaped curve that is 

generated when Photoshop applies a weighted average to the pixels. The Gaussian Blur filter adds low-frequency 

detail and can produce a hazy effect. 

Lens Blur (Photoshop only) Adds blur to an image to give the effect of a narrower depth of field so that some 

objects in the image stay in focus and others areas are blurred. You can use a simple selection to determine which 

areas are blurred, or you can provide a separate alpha channel depth map to describe exactly how you want the blur 

added. 

The Lens Blur filter uses the depth map to determine the position of pixels in an image. With a depth map selected, 

you can also use the cross-hair cursor to set the starting point of a given blur. You can use alpha channels and layer 

masks to create depth maps; black areas in an alpha channel are treated as though they’re at the front of the photo, 

and white areas are treated as if they’re far in the distance. 

To create a gradual blurring (none at the bottom to maximum at the top), create a new alpha channel and apply a 

gradient so that the channel is white at the top of the image and black at the bottom. Then select the Lens Blur filter 

and choose the alpha channel from the Source pop-up menu. To change the direction of the gradient, select the Invert 

check box. 

The way  the blur appears  depends on the  iris  shape you  choose. Iris shapes are  determined  by  the number of blades  

they contain. You can change blades of an iris by curving them (making them more circular) or rotating them. You 

can also reduce or magnify the preview by clicking the minus button or the plus button. See also “To use the Lens 

Blur filter” on page 517. 

Motion Blur Blurs in the specified direction (from –360º to +360º) and at a specified intensity (from 1 to 999). The 

filter’s effect is analogous to taking a picture of a moving object with a fixed exposure time. 
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Radial Blur Simulates the blur of a zooming or rotating camera to produce a soft blur. Choose Spin to blur along 

concentric circular lines, and then specify a degree of rotation. Choose Zoom to blur along radial lines, as if zooming 

into or out of the image, and specify a value from 1 to 100. Blur quality ranges from Draft (for fast but grainy results) 

or Good and Best for smoother results, which are indistinguishable from each other except on a large selection. 

Specify the origin of the blur by dragging the pattern in the Blur Center box. 

Shape Blur (Photoshop only) Uses the specified kernel to create the blur. Choose a kernel from the list of custom 

shape presets, and use the radius slider to adjust its size. You can load different shape libraries by clicking the triangle 

and choosing from the list. Radius determines the size of the kernel; the larger the kernel, the greater the blur. 

Smart Blur Blurs an image with precision. You can specify a radius, a threshold, and a blur quality. The Radius value 

determines the size of the area searched for dissimilar pixels. The Threshold value determines how dissimilar the 

pixels  must  be  before  they  are affected.  You also can  set a mode  for the  entire  selection (Normal) or for  the edges  of  

color transitions (Edge Only and Overlay). Where significant contrast occurs, Edge Only applies black-and-white 

edges, and Overlay Edge applies white. 

Surface (Photoshop only) Blurs an image while preserving edges. This filter is useful for creating special effects and 

for removing noise or graininess. The Radius option specifies the size of the area sampled for the blur. The Threshold 

option controls how much the tonal values of neighboring pixels must diverge from the center pixel value before 

being part of the blur. Pixels with tonal value differences less than the Threshold value are excluded from the blur. 

To use the Lens Blur filter 
1 Choose Filter > Blur > Lens Blur. 

2 For Preview, Choose Faster to generate quicker previews. Choose More Accurate to view the final version of the 

image. More Accurate previews take longer to generate. 

3 For Depth Map, choose a source (if you have one) from the Source pop-up menu. Drag the Blur Focal Distance 

slider to set the depth at which pixels are in focus. For example, if you set focal distance to 100, pixels at 1 and at 255 

are completely blurred, and pixels closer to 100 are blurred less. If you click in the preview image, the Blur Focal 

Distance slider changes to reflect the clicked location and brings the depth of the clicked location into focus. 

4 To invert the selection or alpha channel you’re using as the depth map source, select Invert. 

5 Choose an iris from the Shape pop-up menu. If you wish, drag the Blade Curvature slider to smooth the edges of 

the iris, or drag the Rotation slider to rotate it. To add more blur, drag the Radius slider. 

6 For Specular Highlight, drag the Threshold slider to select a brightness cutoff; all pixels brighter than the cutoff 

value are treated as specular highlights. To increase the brightness of the highlights, drag the Brightness slider. 

7 To add noise to an image, choose Uniform or Gaussian. To add noise without affecting color. choose Monochro

matic. Drag the Amount slider to increase or decrease noise. 

Blurring removes film grain and noise from the original image. To make the image look realistic and unretouched, 

you can return some of the removed noise to the image. 

8 Click OK to apply the changes to your image. 
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Brush Stroke filters 
Like the Artistic filters, the Brush Stroke filters give a painterly or fine-arts look using different brush and ink stroke 

effects. Some of the filters add grain, paint, noise, edge detail, or texture. All the Brush Stroke filters can be applied 

through the Filter Gallery. 

Accented Edges Accentuates the edges of an image. When the edge brightness control is set to a high value, the 

accents resemble white chalk; when set to a low value, the accents resemble black ink. 

Angled Strokes Repaints an image using diagonal strokes, with lighter and darker areas painted in strokes going in 

opposite directions. 

Crosshatch Preserves the  details and  features  of  the original image  while adding texture  and roughening the  edges  

of the colored areas with simulated pencil hatching. The Strength option (with values from 1 to 3) determines the 

number of hatching passes. 

Dark Strokes Paints dark areas with short, tight, dark strokes, and lighter areas with long, white strokes. 

Ink Outlines Redraws an image with fine narrow lines over the original details, in pen-and-ink style. 

Spatter Replicates the effect of a spatter airbrush. Increasing the options simplifies the overall effect. 

Sprayed Strokes Repaints an image, using its dominant colors, with angled, sprayed strokes of color. 

Sumi-e Paints an image in Japanese style, as if with a fully saturated brush applied to rice paper. Sumi-e creates soft, 

blurred edges with rich, inky blacks. 

Distort filters 
The Distort filters geometrically distort an image, creating 3D or other reshaping effects. Note that these filters can 

be very memory intensive. The Diffuse Glow, Glass, and Ocean Ripple filters can be applied through the Filter 

Gallery. 

Diffuse Glow Renders an image as though it were viewed through a soft diffusion filter. The filter adds see-through 

white noise, with the glow fading from the center of a selection. 

Displace Uses an image, called a displacement map, to determine how to distort a selection. For example, using a 

parabola-shaped displacement map, you can create an image that appears to be printed on a cloth held up by its 

corners. 

This filter creates displacement maps, using a flattened file saved in Adobe Photoshop format (except Bitmap mode 

images). You can also use the files in the Plug-Ins/Displacement Maps folder in the Photoshop program folder. 

Glass Makes an image appear as if it were being viewed through different types of glass.You can choose a glass effect 

or create your own glass surface as a Photoshop file and apply it. You can adjust scaling, distortion, and smoothness 

settings. When using surface controls with a file, follow the instructions for the Displace filter. 

Lens Correction The Lens Correction filter fixes common lens flaws such as barrel and pincushion distortion, 

vignetting, and chromatic aberration. 

Ocean Ripple Adds randomly spaced ripples to the surface of the image so that it appears to be underwater. 

Pinch Squeezes a selection. A positive value up to 100% shifts a selection toward its center; a negative value up to – 

100% shifts a selection outward. 

Polar Coordinates Converts a selection from its rectangular to polar coordinates, and vice versa, according to a 

selected option. You can use this filter to create a cylinder anamorphosis—an art form popular in the 18th century— 

in which the distorted image appears normal when viewed in a mirrored cylinder. 
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Ripple Creates an undulating pattern on a selection, like ripples on the surface of a pond. For greater control, use 

the Wave filter. Options include the number and size of ripples. 

Shear Distorts an image along a curve. Specify the curve by dragging the line in the box. You can adjust any point 

along the curve. Click Default to change the curve back to a straight line. In addition, you choose how to treat undis

torted areas. 

Spherize Gives objects a 3D effect by wrapping a selection around a spherical shape, distorting the image and 

stretching it to fit the selected curve. 

Twirl Rotates a selection more sharply in the center than at the edges. Specifying an angle produces a twirl pattern. 

Wave Works much as the Ripple filter does, but with greater control. Options include the number of wave gener

ators, the wavelength (distance from one wave crest to the next), the height of the wave, and the wave type: Sine 

(rolling), Triangle, or Square. The Randomize option applies random values. You can also define undistorted areas. 

To replicate wave results on other selections, click Randomize, set Number Of Generators to 1, and set the minimum 

and maximum Wavelength and Amplitude parameters to the same value. 

ZigZag Distorts a selection radially, depending on the radius of the pixels in your selection. The Ridges option sets 

the number of direction reversals of the zigzag from the center of the selection to its edge. You also specify how to 

displace the pixels: Pond Ripples displaces pixels to the upper left or lower right, Out From Center displaces pixels 

toward or away from the center of the selection, and Around Center rotates pixels around the center. 

To use the Displace filter 
The Displace filter shifts a selection using a color value from the displacement map—0 is the maximum negative


shift, 255 the maximum positive shift, and a gray value of 128 produces no displacement. If a map has one channel,


the image shifts along a diagonal defined by the horizontal and vertical scale ratios. If the map has more than one


channel, the first channel controls the horizontal displacement, and the second channel controls the vertical


displacement.


1 Choose Filter > Distort > Displace.


2 Enter the scale for the magnitude of the displacement.


When the horizontal and vertical scale are set to 100%, the greatest displacement is 128 pixels (because middle gray


produces no displacement).


3 If the displacement map is not the same size as the selection, specify how the map fits the image—select Stretch


To Fit to resize the map or Tile to fill the selection by repeating the map in a pattern.


4 Choose Wrap Around or Repeat Edge Pixels to determine how undistorted areas of the image are treated.


5 Click OK.


6 Select and open the displacement map. The distortion is applied to the image.
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Noise filters 
The Noise filters add or remove noise, or pixels with randomly distributed  color levels.  This  helps to blend  a selection  

into the surrounding pixels. Noise filters can create unusual textures or remove problem areas, such as dust and 

scratches. 

Add Noise Applies random pixels to an image, simulating the effect of shooting pictures on high-speed film. You 

can also use  the Add  Noise filter to reduce banding in feathered  selections  or  graduated fills  or  to  give  a more realistic  

look to heavily retouched areas. Options for noise distribution include Uniform and Gaussian. Uniform distributes 

color values of noise using random numbers between 0 and plus or minus the specified value, creating a subtle effect. 

Gaussian distributes color values of noise along a bell-shaped curve, creating a speckled effect. The Monochromatic 

option applies the filter to only the tonal elements in the image without changing the colors. 

Despeckle Detects the  edges in an image  (areas  where significant  color changes occur)  and blurs  all of the  selection  

except those edges. This blurring removes noise while preserving detail. 

Dust & Scratches Reduces noise by changing dissimilar pixels. To achieve a balance between sharpening the image 

and hiding defects, try various combinations of Radius and Threshold settings. Or apply the filter on selected areas 

in the image. See also “To use the Dust And Scratches filter” on page 520. 

Median Reduces noise in an image by blending the brightness of pixels within a selection. The filter searches the 

radius of a pixel selection for pixels of similar brightness, discarding pixels that differ too much from adjacent pixels, 

and replaces the center pixel with the median brightness value of the searched pixels. This filter is useful for elimi

nating or reducing the effect of motion on an image. 

Reduce Noise (Photoshop only) Reduces noise while preserving edges based on user settings affecting the overall 

image or individual channels. 

See also 

“Reducing image noise” on page 353


To use the Dust And Scratches filter

1 Choose Filter > Noise > Dust & Scratches.


2 If necessary, adjust the preview zoom ratio until the area containing noise is visible.


3 Drag  the Threshold  slider  left  to  0 to turn off  the value  so  that  all pixels in the  selection or image  can be examined. 


The Threshold value determines how dissimilar the pixels should be before they are eliminated.


Note: The Threshold slider gives greater control for values between 0 and 128—the most common range for images— 

than for values between 128 and 255. 

4 Drag the Radius slider left or right, or enter a value in the text box from 1 to 16 pixels. The Radius value determines 

the size of the area searched for dissimilar pixels. 

Increasing the radius blurs the image. Use the smallest value that eliminates the defects. 

5 Increase the threshold gradually by entering a value or by dragging the slider to the highest possible value that 

eliminates defects. 
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Pixelate filters 
The filters in the Pixelate submenu sharply define a selection by clumping pixels of similar color values in cells. 

Color Halftone Simulates the effect of using an enlarged halftone screen on each channel of the image. For each 

channel, the filter divides the image into rectangles and replaces each rectangle with a circle. The circle size is propor

tional to the brightness of the rectangle. See also “To use the Color Halftone filter” on page 521. 

Crystallize Clumps pixels into a solid color in a polygon shape. 

Facet Clumps pixels of solid or similar colors into blocks of like-colored pixels. You can use this filter to make a 

scanned image look hand-painted or to make a realistic image resemble an abstract painting. 

Fragment Creates four copies of the pixels in the selection, averages them, and offsets them from each other. 

Mezzotint Converts an image to a random pattern of black-and-white areas or of fully saturated colors in a color


image. To use the filter, choose a dot pattern from the Type menu in the Mezzotint dialog box.


Mosaic Clumps pixels into square blocks. The pixels in a given block are the same color, and the colors of the blocks


represent the colors in the selection.


Pointillize Breaks up the color in an image into randomly placed dots, as in a pointillist painting, and uses the


background color as a canvas area between the dots.


To use the Color Halftone filter

1 Choose Filter > Pixelate > Color Halftone.


2 Enter a value in pixels for the maximum radius of a halftone dot, from 4 to 127.


3 Enter a screen-angle value (the angle of the dot from the true horizontal) for one or more channels:


• For Grayscale images, use only channel 1. 

• For RGB images, use channels 1, 2, and 3, which correspond to the red, green, and blue channels. 

• For CMYK images, use all four channels, which correspond to the cyan, magenta, yellow, and black channels. 

• Click Defaults to return all the screen angles to their default values. 

4 Click OK. 

Render filters 
The Render filters create 3D shapes, cloud patterns, refraction patterns, and simulated light reflections in an image. 

You can also manipulate objects in 3D space, create 3D objects (cubes, spheres, and cylinders), and create texture fills 

from grayscale files to produce 3D-like effects for lighting. 

Clouds Generates a soft cloud pattern using random values that vary between the foreground and the background 

colors. To generate a more stark cloud pattern, hold down Alt (Windows) or Option (Mac OS) as you choose Filter > 

Render > Clouds. When you apply the Clouds filter, the image data on the active layer is replaced. 

Difference Clouds Uses randomly generated values that vary between the foreground and background color to 

produce a cloud pattern. The filter blends the cloud data with the existing pixels in the same way that the Difference 

mode blends colors. The first time you choose this filter, portions of the image are inverted in a cloud pattern. 

Applying the filter several times creates rib and vein patterns that resemble a marble texture. When you apply the 

Difference Clouds filter, the image data on the active layer is replaced. 

Fibers Creates the look of woven fibers using the foreground and background colors. You use the Variance slider to 

control how the colors vary (a low value produces long streaks of color, and a high value results in very short fibers 
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with more varied distribution of color). The Strength slider controls how each fiber looks. A low setting produces a 

loose weave, and a high setting produces short, stringy fibers. Click the Randomize button to change how the pattern 

looks; you can click the button a number of times until you find a pattern you like. When you apply the Fibers filter, 

the image data on the active layer is replaced. 

Try adding a gradient map adjustment layer to colorize the fibers. 

Lens Flare Simulates the refraction caused by shining a bright light into the camera lens. Specify a location for the 

center of the flare by clicking anywhere inside the image thumbnail or by dragging its cross hair. 

Lighting Effects Lets you produce myriad lighting effects on RGB images by varying 17 light styles, three light 

types, and four sets of light properties. You can also use textures from grayscale files (called bump maps) to produce  

3D-like effects and save your own styles for use in other images. See also “To use the Lighting Effects filter” on 

page 527. 

See also 

“To apply a gradient map to an image” on page 313 

Sharpen filters 
The Sharpen filters focus blurred images by increasing the contrast of adjacent pixels. 

Sharpen and Sharpen More Focus a selection and improve its clarity. The Sharpen More filter applies a stronger 

sharpening effect than does the Sharpen filter. 

Sharpen Edges and Unsharp Mask Find the areas in the image where significant color changes occur and sharpen 

them. The Sharpen Edges filter sharpens only edges while preserving the overall smoothness of the image. Use this 

filter to sharpen edges without specifying an amount. For professional color correction, use the Unsharp Mask filter 

to adjust the contrast of edge detail and produce a lighter and darker line on each side of the edge. This process 

emphasizes the edge and creates the illusion of a sharper image. 

Smart Sharpen (Photoshop only) Sharpens an image by letting you set the sharpening algorithm or control the 

amount of sharpening that occurs in shadows and highlights. 

See also 

“To use the Smart Sharpen filter” on page 355 

Sketch filters 
Filters in the Sketch submenu add texture to images, often for a 3D effect. The filters also are useful for creating a 

fine-arts or hand-drawn look. Many of the Sketch filters use the foreground and background color as they redraw 

the image. All the Sketch filters can be applied through the Filter Gallery. 

Bas Relief Transforms an image so that it appears carved in low relief and lit to accent the surface variations. Dark 

areas of the image take on the foreground color, and light colors use the background color. 

Chalk & Charcoal Redraws highlights and midtones with a solid midtone gray background drawn in coarse chalk. 

Shadow areas are replaced with black diagonal charcoal lines. The charcoal is drawn in the foreground color; the 

chalk, in the background color. 

Charcoal Creates a posterized, smudged effect. Major edges are boldly drawn, and midtones are sketched using a 

diagonal stroke. Charcoal is the foreground color, and the background is the color of the paper. 

 



523 ADOBE PHOTOSHOP CS2 
User Guide 

Chrome Renders the image as if it had a polished chrome surface. Highlights are high points, and shadows are low 

points in the reflecting surface. After applying the filter, use the Levels dialog box to add more contrast to the image. 

Conté Crayon Replicates the texture of dense dark and pure white Conté crayons on an image. The Conté Crayon 

filter uses the foreground color for dark areas and the background color for light areas. For a truer effect, change the 

foreground color to one of the common Conté Crayon colors (black, sepia, sanguine) before applying the filter. For 

a muted effect, change the background color to white, add some of the foreground color to the white background, 

and then apply the filter. 

Graphic Pen Uses fine, linear ink strokes to capture the details in the original image. The effect is especially striking 

with scanned images. The filter replaces color in the original image, using the foreground color for ink and the 

background color for paper. 

Halftone Pattern Simulates the effect of a halftone screen while maintaining the continuous range of tones. 

Note Paper Creates an image that appears to be constructed of handmade paper. This filter simplifies images and 

combines the effects of the Stylize > Emboss and Texture > Grain filters. Dark areas of the image appear as holes in 

the top layer of paper, revealing the background color. 

Photocopy Simulates the effect of photocopying an image. Large dark areas tend to be copied only around their 

edges, and midtones fall away to either solid black or solid white. 

Plaster Molds an image  from  3D  plaster,  and then colorizes  the result using  the foreground and  background  color.  

Dark areas are raised, and light areas are recessed. 

Reticulation Simulates the controlled shrinking and distortion of film emulsion to create an image that appears 

clumped in the shadows and lightly grained in the highlights. 

Stamp Simplifies the image so that it appears to be created with a rubber or wood stamp. This filter is best used with 

black-and-white images. 

Torn Edges Reconstructs the image so that it appears composed of ragged, torn pieces of paper, and then colorizes 

the image using the foreground and background colors. This filter is particularly useful for text or high-contrast 

objects. 

Water Paper Uses blotchy daubs that appear painted onto fibrous, damp paper, causing the colors to flow and blend. 

Stylize filters 
The Stylize filters produce a painted or impressionistic effect on a selection by displacing pixels and by finding and 

heightening contrast in an image. After using filters like Find Edges and Trace Contour that highlight edges, you can 

apply the Invert command to outline the edges of a color image with colored lines or to outline the edges of a 

grayscale image with white lines. 

Diffuse Shuffles pixels in a selection to soften focus according to the selected option: Normal moves pixels randomly 

(ignoring color values), Darken Only replaces light pixels with darker ones, and Lighten Only replaces dark pixels 

with lighter ones. Anisotropic shuffles pixels in the direction of the least change in color. 

Emboss Makes a selection appear raised or stamped by converting its fill color to gray and tracing the edges with 

the original fill color. Options include an embossing angle (from –360˚ to recess the surface, to +360˚ to raise the 

surface), height, and a percentage (1% to 500%) for the amount of color within the selection. To retain color and 

detail when embossing, use the Fade command after applying the Emboss filter. 

Extrude Gives a 3D texture to a selection or layer. See also “To use the Extrude filter” on page 524. 

 



524 ADOBE PHOTOSHOP CS2 
User Guide 

Find Edges Identifies the areas of the image with significant transitions and emphasizes the edges. Like the Trace 

Counter filter, Find Edges outlines the edges of an image with dark lines against a white background and is useful for 

creating a border around an image. 

Glowing Edges Identifies the edges of color and adds a neon-like glow to them. This filter can be applied cumula

tively with other filters through the Filter Gallery. (see “The Filter Gallery” on page 510.) 

Solarize Blends a negative and a positive image—similar to exposing a photographic print briefly to light during 

development. 

Tiles Breaks up an image into a series of tiles, creating an offset between the selection and its original position. You 

can choose one  of  the following  to  fill  the area between  the tiles: the  background  color,  the foreground color, a reverse  

version of the image, or an unaltered version of the image, which puts the tiled version on top of the original and 

reveals part of the original image underneath the tiled edges. 

Trace Contour Finds the transitions of major brightness areas and thinly outlines them for each color channel, for 

an effect similar to the lines in a contour map. 

Wind Places tiny horizontal lines in the image to create a windblown effect. Methods include Wind; Blast, for a more 

dramatic wind effect; and Stagger, which offsets the lines in the image. 

See also 

“To invert colors” on page 312 

To use the Extrude filter 
1 Choose Filter > Stylize > Extrude. 

2 Choose a 3D type: 

•	 Blocks creates objects with a square front face and four side faces. To fill the front face of each block with the 

average color of the block, select Solid Front Faces. To fill the front face with the image, deselect Solid Front Faces. 

• Pyramids creates objects with four triangular sides that meet at a point.


3 Enter a value in the Size text box to determine the length of any side of the object’s base, from 2 to 255 pixels.


4 Enter a value in the Depth text box to indicate how far the tallest object appears to protrude from the screen, from


1 to 255.


5 Choose a depth option:


•	 Random to give each block or pyramid an arbitrary depth.


• Level-based to make each object’s depth correspond to its brightness—bright protrudes more than dark.


6 Select Mask Incomplete Blocks to hide any object extending beyond the selection.


To use the Trace Contour filter 
1 Choose Filter > Stylize > Trace Contour. 

2 Choose an Edge option to outline areas in the selection: Lower outlines areas where the color values of pixels fall 

below the specified level, and Upper outlines areas where the color values fall above. 

3 Enter a threshold (Level) for evaluating color values (tonal level), from 0 to 255. Experiment to see what values 

bring out the best detail in the image. 
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Use the Info palette in Grayscale mode to identify a color value that you want traced. Then enter the value in the 

Level text box. 

See also 

“To use the Info palette” on page 56 

Texture filters 
Use the Texture filters to simulate the appearance of depth or substance, or to add an organic look. 

Craquelure Paints an image onto a high-relief plaster surface, producing a fine network of cracks that follow the 

contours of the image. Use this filter to create an embossing effect with images that contain a broad range of color or 

grayscale values. 

Grain Adds texture to an image by simulating different kinds of grain—Regular, Soft, Sprinkles, Clumped, 

Contrasty, Enlarged, Stippled, Horizontal, Vertical, and Speckle, available from the Grain Type menu. 

Mosaic Tiles Renders the image so that it appears to be made up of small chips or tiles and adds grout between the 

tiles. (In contrast, the Pixelate > Mosaic filter breaks up an image into blocks of different-colored pixels.) 

Patchwork Breaks up an image into squares filled with the predominant color in that area of the image. The filter 

randomly reduces or increases the tile depth to replicate the highlights and shadows. 

Stained Glass Repaints an image as single-colored adjacent cells outlined in the foreground color. 

Texturizer Applies a texture you select or create to an image. 

Video filters 
The Video submenu contains the De-Interlace and NTSC Colors filters. 

De-Interlace Smooths moving images captured on video by removing either the odd or even interlaced lines in a 

video image. You can choose to replace the discarded lines by duplication or interpolation. 

NTSC Colors Restricts the gamut of colors to those acceptable for television reproduction, to prevent oversaturated 

colors from bleeding across television scan lines. 

Other filters 
Filters in the Other submenu let you create your own filters, use filters to modify masks, offset a selection within an 

image, and make quick color adjustments. 

Custom Lets  you design your own  filter  effect. With the  Custom  filter, you  can change  the brightness values of each  

pixel in the image according to a predefined mathematical operation known as convolution. Each pixel is reassigned 

a value based on the values of surrounding pixels. This operation is similar to the Add and Subtract calculations for 

channels. 

You can  save  the custom filters  you create and  use them with other  Photoshop images.  See also “To  create  a Custom  

filter” on page 526. 

High Pass Retains edge details in the specified radius where sharp color transitions occur and suppresses the rest of 

the image. (A radius of 0.1 pixel keeps only edge pixels.) The filter removes low-frequency detail in an image and has 

an effect opposite to that of the Gaussian Blur filter. 
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It is helpful to apply the High Pass filter to a continuous-tone image before using the Threshold command or


converting the image to Bitmap mode. The filter is useful for extracting line art and large black-and-white areas from


scanned images.


Maximum and Minimum Are useful for modifying masks. The Maximum filter has the effect of applying a choke—


spreading out white areas and choking in black areas. The Minimum filter has the effect of applying a spread—


spreading out black areas and shrinking white areas. Like the Median filter, the Maximum and Minimum filters look


at individual pixels in a selection. Within a specified radius, the Maximum and Minimum filters replace the current


pixel’s brightness value with the highest or lowest brightness value of the surrounding pixels.


Offset Moves a selection a specified horizontal or vertical amount, leaving an empty space at the selection’s original


location. You  can fill the  empty area with the  current background color, with another  part  of  the image, or with your 


choice of fill if the selection is near the edge of an image.


Tile Maker (ImageReady only) Prepares an image for use as a tiled background. You can blend the edges of an


image to create a seamless background. You can also create a kaleidoscopic background in which an image is flipped


horizontally and vertically to create an abstract design.


To create a Custom filter

1 Choose Filter > Other > Custom. The Custom dialog box displays a grid of text boxes into which you can enter


numerical values.


2 Select the center text box, which represents the pixel being evaluated. Enter the value by which you want to


multiply that pixel’s brightness value, from –999 to +999.


3 Select a text box representing an adjacent pixel. Enter the value by which you want the pixel in this position multi


plied.


For example, to multiply the brightness value of the pixel to the immediate right of the current pixel by 2, enter 2 in


the text box to the immediate right of the center text box.


4 Repeat steps 2 and 3 for all pixels to include in the operation. You don’t have to enter values in all the text boxes.


5 For Scale, enter the value by which to divide the sum of the brightness values of the pixels included in the calcu


lation.


6 For Offset, enter the value to be added to the result of the scale calculation.


7 Click OK. The custom filter is applied to each pixel in the image, one at a time.


Use the Save and Load buttons to save and reuse custom filters.


Digimarc filters 
The Digimarc filters embed a digital watermark into an image to store copyright information. 

See also 

“Adding digital copyright information” on page 689 

Vanishing Point 
The Vanishing Point feature lets preserve correct perspective in edits of images that contain perspective planes, for 

instance, the sides of a building or any rectangular object. 
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See also 

“To use Vanishing Point” on page 375 

The Lighting Effects filter 

To use the Lighting Effects filter 
The Lighting Effects filter lets you produce myriad lighting effects on RGB images. You can also use textures from 

grayscale files (called bump maps) to produce 3D-like effects and save your own styles for use in other images. 

Note: The Lighting Effects filter works only on RGB images. 

1 Choose Filter > Render > Lighting Effects.


2 For Style, choose a style.


3 For Light Type, choose a type. If you’re using multiple lights, select and deselect On to turn individual lights on


and off.


4 To change the color of the light, click the color box in the Light Type area of the dialog box.


The color picker chosen in the General Preferences dialog box opens.


5 To set light properties, drag the corresponding slider for the following options:


Gloss Determines how much the surface reflects light (as on the surface of a piece of photographic paper) from


Matte (low reflectance) to Glossy (high reflectance).


Material Determines which is more reflective: the light or the object on which the light is cast. Plastic reflects the


light’s color; Metallic reflects the object’s color.


Exposure Increases (positive values) or decreases (negative values) light. A value of 0 has no effect.


Ambience Diffuses the light as if it were combined with other light in a room, such as sunlight or fluorescent light.


Choose a value of 100 to use only the light source, or a value of –100 to remove the light source. To change the color


of the ambient light, click the color box and use the color picker that appears.


To duplicate a light, Alt-drag (Windows) or Option-drag (Mac OS) the light within the preview window. 

6 To use a texture fill, choose a channel for Texture Channel. 

See also 

“About the Adobe Color Picker” on page 241 

“To use the Windows Color Picker” on page 247 
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Lighting Effects types 
You can choose from several light types: 

Omni Shines light in all directions from directly above the image—like a light bulb over a piece of paper. 

Directional Shines light from far away so that the light angle doesn’t change—like the sun. 

Spotlight Casts an elliptical beam of light. The line in the preview window defines the light direction and angle, and


the handles define the edges of the ellipse.


To adjust an Omni light

1 Choose Filter > Render > Lighting Effects.


2 For Light Type, choose Omni.


3 Adjust the light:


•	 To move the light, drag the center circle. 

•	 To increase or decrease the size of the light (like a light moving closer or farther away), drag one of the handles 

defining the edges of the effect. 

To adjust directional light using the preview window

1 Choose Filter > Render > Lighting Effects.


2 For Light Type, choose Directional.


3 Adjust the light:


•	 To move the light, drag the center circle. 

•	 To change the direction of the light, drag the handle at the end of the line to rotate the light’s angle. Ctrl-drag 

(Windows) or Command-drag (Mac OS) to keep the light’s height (line length) constant. 

•	 To change the height of the light, drag the handle at the end of the line. Shorten the line for a bright light, and 

lengthen it for a less intense one. A very short line produces pure white light; a very long one, no light. Shift-drag 

to keep the angle constant and change the height of the light (line length). 

To adjust the spotlight using the preview window

1 Choose Filter > Render > Lighting Effects.


2 For Light Type, choose Spotlight.


3 Adjust the light:


•	 To move the light, drag the center circle. 

•	 To increase the light angle, drag the handle to shorten the line. To decrease the light angle, drag to lengthen the 

line. 

•	 To stretch the ellipse or rotate the light, drag one of the handles. Shift-drag to keep the angle constant and change 

only the size of the ellipse. Ctrl-drag (Windows) or Command-drag (Mac OS) to keep the size constant and change 

the angle or direction of the spotlight. 

•	 To set the light focus (or spotlight intensity) and control how much of an ellipse is filled with light, drag the 

Intensity slider: full intensity (a value of 100) is brightest, normal intensity is about 50, negative intensity takes 

away light, and –100 intensity produces no light. Use the Focus slider to control how much of the ellipse is filled 

with light. 
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Lighting Effects styles 
Use the Style menu in the Lighting Effects dialog box to choose from 17 light styles. You can also create your own 

lighting style by adding lights to the Default setting. The Lighting Effects filter requires at least one light source. Only 

one light can be edited at a time, but all added lights are used to create the effect. 

2 O’clock Spotlight A yellow spotlight of medium (17) intensity with a wide (91) focus.


Blue Omni A blue overhead omni light of full (85) intensity with no focus.


Circle Of Light Four spotlights. White has full (100) intensity and a concentrated (8) focus. Yellow has strong


intensity (88) and a concentrated focus (3). Red has medium (50) intensity and a concentrated (0) focus. Blue has


full (100) intensity and medium (25) focus.


Crossing A white spotlight of medium (35) intensity with a wide (69) focus.


Crossing Down Two white spotlights of medium (35) intensity with a wide (100) focus.


Default A white spotlight of medium intensity with a wide focus.


Five Lights Down/Five Lights Up Five white spotlights, down or up, of full (100) intensity with a wide (60) focus.


Flashlight An omni yellow light of medium (46) intensity.


Flood Light A white spotlight of medium (35) intensity with a wide (69) focus.


Parallel Directional A directional blue light of full (98) intensity with no focus.


RGB Lights Red, blue, and green lights that produce a light of medium (60) intensity with a wide (96) focus.


Soft Direct Lights Two unfocused white and blue directional lights. White has a soft (20) intensity. Blue has a


medium (67) intensity.


Soft Omni A soft omni light of medium (50) intensity.


Soft Spotlight A white spotlight of full (98) intensity with a wide (100) focus.


Three Down Three white spotlights of soft (35) intensity with a wide (96) focus.


Triple Spotlight Three spotlights of slight (35) intensity with a wide (100) focus.


To add or delete a light 
❖ In the Lighting Effects dialog box, do one of the following: 

•	 To add a light, drag the light icon at the bottom of the dialog box into the preview area. Repeat as desired for a 

maximum of 16 lights. 

•	 To delete a light, drag the light by its center circle to the Delete icon at the lower right of the preview window. 

To create, save, or delete a Lighting Effects style 
❖ In the Lighting Effects dialog box, do one of the following: 

•	 To create a style, choose Default for Style and drag the light bulb icon at the bottom of the dialog box into the 

preview area. Repeat as desired for a maximum of 16 lights. 

•	 To save a style, click Save, name the style, and click OK. Saved styles include all the settings for each light and 

appear in the Style menu whenever you open the image. 

•	 To delete a style, choose a style, and then click Delete. 

 



530 ADOBE PHOTOSHOP CS2 
User Guide 

Using a Lighting Effects texture 
The Texture Channel in the Lighting Effects dialog box lets you use a grayscale texture, such as paper or water, to 

control how light reflects off an image. You can use any channel in your image (including a channel copied from a 

different image) as a texture, or you can create your own texture. For an embossed text effect, use a channel with 

white text on a black background, or vice versa. 

To use the Texture Channel in the Lighting Effects dialog box 
1 If necessary, create an alpha channel in your image and add texture. To use a texture from another image, copy 

and paste the image into a new channel. 

2 In the Lighting Effects dialog box, choose a channel from the Texture Channel menu: the image’s Red, Green, or 

Blue channel or any channel added to the image. 

3 Select White Is High to raise the white parts of the channel from the surface. Deselect this option to raise the dark 

parts. 

4 Drag the Height slider to vary the texture from Flat (0) to Mountainous (100). 

See also 

“To create an alpha channel and add a mask” on page 342 

Loading images and textures 

To load images and textures 
To produce their effects, some filters load and use other images, such as textures and displacement maps. These filters


include the Conté Crayon, Displace, Glass, Lighting Effects, Rough Pastels, Texture Fill, Texturizer, Underpainting,


and Custom filters. Not all of these filters load images or textures in the same way.


1	 Choose the filter you want from the appropriate submenu.


2 In the filter’s dialog box, choose Load Texture from the Texture pop-up menu, and locate and open a texture


image.


All textures must be in the Photoshop format. Most filters use only the grayscale information of a color file.


Improving filter performance 

To improve filter performance 
Some filter effects can be memory-intensive, especially when applied to a high-resolution image. 

❖ You can do one of the following to improve performance: 

•	 Try out filters and settings on a small portion of an image. 

•	 Apply the effect to individual channels—for example, to each RGB channel—if the image is large and you’re having 

problems with insufficient memory. (With some filters, effects vary if applied to the individual channel rather than 

the composite channel, especially if the filter randomly modifies pixels.) 
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•	 Free up memory before running the filter by using the Purge command. 

•	 Allocate more RAM to Photoshop. If necessary, exit other applications to make more memory available to 

Photoshop. 

•	 Try changing settings to improve the speed of memory-intensive filters, such as Lighting Effects, Cutout, Stained 

Glass, Chrome, Ripple, Spatter, Sprayed Strokes, and Glass filters. (For example, with the Stained Glass filter, 

increase cell size. With the Cutout filter, increase Edge Simplicity, decrease Edge Fidelity, or both.) 

•	 If  you plan to print  to  a grayscale  printer,  convert a copy  of  the image  to  grayscale before applying filters. However,  

applying a filter to a color image and then converting to grayscale may not have the same effect as applying the 

filter to a grayscale version of the image. 

See also 

“To use the Undo or Redo commands” on page 71 
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Chapter 19: Type


Creating type 

About type 
Type in Photoshop consists of mathematically defined shapes that describe the letters, numbers, and symbols of a 

typeface. Many typefaces are available in more than one format, the most common formats being Type 1 (also called 

PostScript fonts), TrueType, OpenType, New CID, and CID nonprotected (Japanese only). 

When you add type to an image, the characters are composed of pixels and have the same resolution as the image 

file—when you zoom in on characters you see jagged edges. However, Photoshop and ImageReady preserve the 

vector-based type outlines and use them when you scale or resize type, save a PDF or EPS file, or print the image to 

a PostScript printer. As a result, it’s possible to produce type with crisp, resolution-independent edges. 

There are three ways to create type: at a point, inside a paragraph, and, in Photoshop, along a path. 

•	 Point type is a horizontal or vertical line of text that begins where you click in the image. Entering text at a point 

is a useful way to add a few words to your image. 

•	 Paragraph type uses boundaries to control the flow of characters, either horizontally or vertically. Entering text this 

way is useful when you want to create one or more paragraphs, such as for a brochure. 

Type entered as point type (top) and in a bounding box (bottom) 

•	 (Photoshop) Type on a path flows along the edge of an open or a closed path. When you enter text horizontally, 

the characters are parallel to the baseline. When you enter text vertically, the characters are perpendicular to the 

baseline. In either case, the text flows in the direction in which points were added to the path. 

If you enter more text that can fit within a paragraph boundary or (in Photoshop) along a path, a small box or circle 

containing a plus symbol (+) appears in place of a handle at the corner of the boundary or anchor point at the end 

of the path. 

When you create type, a new type layer is added to the Layers palette. In Photoshop, you can also create a selection 

border in the shape of the type. 

Important: In Photoshop, a type layer is not created for images in Multichannel, Bitmap, or Indexed Color mode, 

because these modes do not support layers. In these image modes, type appears on the background as rasterized text. 

Photoshop also lets you set Asian text options. To do so, you must select Show Asian Text Options in the Type prefer

ences. 
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See also 

“Entering type on a path” on page 541 

“To display and set Asian type options” on page 564 

About the type tools in Photoshop 
Clicking in an image with a type tool puts the type tool in edit mode. When the tool is in edit mode, you can enter 

and edit characters as well as perform some other commands from the various menus; however, certain operations 

require that you first commit changes to the type layer. To determine whether a type tool is in edit mode, look in the 

options bar—if you see the Commit button  and the Cancel button , the type tool is in edit mode. 

See also 

“About tools and the toolbox” on page 40 

To commit changes to a type layer 
❖ Do one of the following: 

•	 Click the Commit button  in the options bar. 

•	 Press the Enter key on the numeric keypad. 

•	 Press Ctrl+Enter (Windows) or Command+Return (Mac OS). 

•	 Select any tool in the toolbox; click in the Layers, Channels, Paths, Actions, History, or Styles palette; or select any 

available menu command. 

To enter point type 
When you enter point type, each line of type is independent—the line expands or shrinks as you edit it, but it doesn’t 

wrap to the next line. The type you enter appears in a new type layer. 

1	 Do one of the following: 

•	 (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool . 

•	 (ImageReady) Select the Type tool . 

Note: To change between horizontal or vertical text in ImageReady, click the Change Text Orientation button in the tool 

options bar or choose Change Text Orientation from the Character palette menu. 

2 Click in the image to set an insertion point for the type. The small line through the I-beam marks the baseline of 

the type (the imaginary line on which type rests). For vertical type, the baseline marks the center axis of the 

characters. 

3	 Select additional type options in the options bar, Character palette, or Paragraph palette. 

4	 Enter the characters. To begin a new line, press Enter (Windows) or Return (Mac OS). 
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Note: (Photoshop) You can also transform point type while in edit mode. Hold down the Ctrl (Windows) or Command 

(Mac OS) key. A bounding box appears around the type. You can grab a handle to scale or skew the type. You can also 

rotate the bounding box. 

5	 (Photoshop) When you finish entering or editing the type, do one of the following: 

•	 Click the Commit button  in the options bar. 

•	 Press the Enter key on the numeric keypad. 

•	 Press Ctrl+Enter (Windows) or Command+Return (Mac OS). 

•	 Select any tool in the toolbox; click in the Layers, Channels, Paths, Actions, History, or Styles palette; or select any 

available menu command. 

To enter paragraph type 
When you enter paragraph type, the lines of type wrap to fit the dimensions of the bounding box. You can enter 

multiple paragraphs and select a paragraph justification option. 

You can resize the bounding box, causing the type to reflow within the adjusted rectangle. You can adjust the 

bounding box while you enter type or after you create the type layer. You can also use the bounding box to rotate, 

scale, and skew type. 

1	 Do one of the following: 

•	 (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool . 

•	 (ImageReady) Select the Type tool . 

Note: To change between horizontal or vertical text in ImageReady, click the Change Text Orientation button in the tool 

options bar or choose Change Text Orientation from the Character palette menu. 

2	 Do one of the following: 

•	 Drag diagonally to define a bounding box for the type. 

•	 Hold down Alt (Windows) or Option (Mac OS) as you click or drag to display the Paragraph Text Size dialog box. 

Enter values for Width and Height, and click OK. 

3	 Select additional type options in the options bar, Character palette, Paragraph palette, or Layer > Type submenu. 

4 
type than can fit in the bounding box, the overflow icon

Enter the characters. To begin a new paragraph, press Enter (Windows) or Return (Mac OS). If you enter more

 appears on the bounding box.


5 (Photoshop) If desired, resize, rotate, or skew the bounding box.


6 (Photoshop) Commit the type layer by doing one of the following:


•	 Click the Commit button  in the options bar. 

•	 Press the Enter key on the numeric keypad. 

•	 Press Ctrl+Enter (Windows) or Command+Return (Mac OS). 

•	 Select any tool in the toolbox; click in the Layers, Channels, Paths, Actions, History, or Styles palette; or select any 

available menu command. 

The type you enter appears in a new type layer. 
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To resize or transform a type bounding box 
1 Display the bounding box handles of paragraph type: 

•	 (Photoshop) With the Type tool active, select the type layer in the Layers palette, and click in the text flow in 

the image. 

•	 (ImageReady) With the Type tool active, select the type layer. 

Note: You can transform point type while in edit mode. Hold down the Ctrl (Windows) or Command (Mac OS) key, and 

a bounding box appears around the type. 

2	 Do one of the following: 

•	 To resize the bounding box, position the pointer over a handle—the pointer turns into a double arrow —and 

drag. Shift-drag to maintain the proportions of the bounding box. 

•	 (Photoshop) 

a curved, two-sided arrow

To rotate the bounding box, position the pointer outside the bounding border—the pointer turns into

—and drag. Shift-drag to constrain the rotation to 15˚ increments. To change the 

center of rotation, Ctrl-drag (Windows) or Command-drag (Mac OS) the center point to a new location. The 

center point can be outside the bounding box. 

•	 (Photoshop) To skew the bounding box, hold down Ctrl+Shift (Windows) or Command+Shift (Mac OS) and drag 

a side handle. The pointer turns into an arrowhead with a small double arrow . 

Skewing type using the bounding box 

•	 (Photoshop) To scale the type as you resize the bounding box, Ctrl-drag (Windows) or Command-drag (Mac OS) 

a corner handle. 

•	 (Photoshop) To resize the bounding box from the center point, Alt-drag (Windows) or Option-drag (Mac OS) a 

corner handle. 

Type layers 

About type layers 
After you create a type layer, you can edit the type and apply layer commands to it. You can change the orientation 

of the type, apply anti-aliasing, convert between point type and paragraph type, create a work path from type, or 

convert type to shapes. You can move, restack, copy, and change the layer options of a type layer as you do for a 

normal layer. You can also make the following changes to a type layer and still edit the type: 

•	 Apply transformation commands from the Edit menu, except for Perspective and Distort. 

Note: To apply the Perspective or Distort commands, or to transform part of the type layer, you must first rasterize the 

type layer, turning the type shapes into a pixel image. Keep in mind that rasterized type no longer has vector outlines and 

is uneditable as type. 
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•	 Use layer styles. 

•	 Use fill shortcuts. To fill with the foreground color, press Alt+Backspace (Windows) or Option+Delete (Mac OS); 

to fill with the background color, press Ctrl+Backspace (Windows) or Command+Delete (Mac OS). 

•	 Warp type to conform to a variety of shapes. 

See also 

“To edit text in a type layer” on page 538 

Rasterizing type layers 
Some commands and tools—such as filter effects and painting tools—are not available for type layers. You must 

rasterize the type before applying the command or using the tool. Rasterizing converts the type layer to a normal layer 

and makes  its contents uneditable as text.  A  warning  message appears  if  you choose a command or tool that requires  

a rasterized layer. Some warning messages provide an OK button that you can click to rasterize the layer. 

To convert a type layer to a normal layer, select the type layer and choose Layer > Rasterize > Type. 

To change the orientation of a type layer 
The orientation of a type layer determines the direction of type lines in relation to the document window (for point 

type) or the bounding box (for paragraph type). When a type layer is vertical, the type flows up and down; when a 

type layer is horizontal, the type flows from left to right. Don’t confuse the orientation of a type layer with the 

direction of characters in a type line. 

1 Select the type layer in the Layers palette. 

2 Do one of the following: 

•	 Select a type tool and click the Text Orientation button  in the options bar. 

•	 Choose Layer > Type > Horizontal, or choose Layer > Type > Vertical. 

•	 Choose Change Text Orientation from the Character palette menu. 

Specifying anti-aliasing 
Anti-aliasing lets you produce smooth-edged type by partially filling the edge pixels. As a result, the edges of the type 

blend into the background. 

Anti-aliasing set to None (left), and Strong (right) 
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When creating type for display on the web, consider that anti-aliasing greatly increases the number of colors in the 

original image. This limits your ability to reduce the number of colors in the image and thus to reduce the size of the 

image file. Anti-aliasing may also cause stray colors to appear along the edges of the type. When reducing file size 

and limiting the number of colors are most important, it may be preferable to avoid anti-aliasing, despite the jagged 

edges. Also, consider using larger type than you would use for print. Larger type is easier to view on the web and gives 

you more freedom in deciding whether to apply anti-aliasing. 

Note: When you use anti-aliasing, type may be rendered inconsistently at small sizes and low resolutions (such as the 

resolution used for web graphics). To reduce this inconsistency, deselect the Fractional Width option in the Character 

palette menu. 

Anti-aliasing options include: 

• None to apply no anti-aliasing 

• Sharp to make type appear at its sharpest 

• Crisp to make type appear somewhat sharp 

• Strong to make type appear heavier 

• Smooth to make type appear smoother 

To apply anti-aliasing to a type layer 
1 Select the type layer in the Layers palette. 

2 Do one of the following: 

• Choose an option from the anti-aliasing menu  in the options bar or the Character palette. 

• Choose Layer > Type, and choose an option from the submenu. 

To convert between point type and paragraph type 
You can convert point type to paragraph type to adjust the flow of characters within a bounding box. Alternatively,


you can convert paragraph type to point type to make each text line flow independently from the others. When you


convert from paragraph type to point type, a carriage return is added at the end of each line of type (with the


exception of the last line).


1 Select the type layer in the Layers palette.


2 Choose Layer > Type > Convert To Point Text, or Layer > Type > Convert To Paragraph Text.


Note: When you convert paragraph type to point type, all characters that overflow the bounding box are deleted. To 

avoid losing text, adjust the bounding box so that all type is visible prior to conversion. 

Editing text 

To insert the pointer in text 
❖ Select any type tool, make sure the type layer is active, and click in the text. 
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To edit text in a type layer 
You can insert new text, change existing text, and delete text in type layers. 

1	 Do one of the following: 

•	 (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool .


• (ImageReady) Select the Type tool.


2 Select the type layer in the Layers palette, or click in the text flow to automatically select a type layer.


3 Position the insertion point in the text, and do one of the following:


•	 Click to set the insertion point.


• Select one or more characters you want to edit.


4 Enter text as desired.


5 Commit the changes to the type layer.


To specify curly or straight quotes 
Typographer’s quotes, often called curly quotes or smart quotes, blend in with the curves of the font. Typographer’s 

quotes are traditionally used for quotation marks and apostrophes. Straight quotes are traditionally used as abbrevi

ations for feet and inches. 

1 Choose Edit > Preferences > Type (Windows) or Photoshop > Preferences > Type (Mac OS). 

2 Under Type Options, select or deselect Use Smart Quotes. 

To check and correct spelling 
When you check the spelling in a document, Photoshop questions any words that aren’t in its dictionary. If a 

questioned word is spelled correctly, you can confirm its spelling by adding the word to the dictionary. If a questioned 

word is misspelled, you can correct it. 

1 If necessary, in the Character palette, choose a language from the pop-up menu at the bottom of the palette. This 

is the dictionary Photoshop uses to check spelling. 

2 (Optional) Show or unlock type layers. The Check Spelling command does not check spelling in hidden or locked 

layers. 

3	 Do one of the following: 

•	 Select a type layer. 

•	 To check specific text, select the text. 

•	 To  check a word, place  the insertion  point in the  word. If you  selected  a type layer  and want to check  the spelling  

of only that layer, deselect Check All Layers. 

4 Choose Edit > Check Spelling. 

5 As Photoshop finds unfamiliar words and other possible errors, click one of the following: 

Ignore Continues the spelling check without changing the text. 

Ignore All Ignores the questioned word during the rest of the spelling check. 

Change Corrects a misspelling. Make sure that the correctly spelled word is in the Change To text box and click 

Change. If the suggested word is not the word you want, select a different word in the Suggestions text box or enter 

the correct word in the Change To text box. 

 



539 ADOBE PHOTOSHOP CS2 
User Guide 

Change All Corrects all instances of the misspelling in the document. Make sure that the correctly spelled word is 

in the Change To text box. 

Add Stores  the unrecognized word in the  dictionary, so that subsequent occurrences  are not  flagged as misspellings.  

To find and replace text 
1 (Optional) Show or unlock type layers. The Find And Replace Text command does not check spelling in hidden 

or locked layers. 

2 Do one of the following: 

• Select the layer containing the text that you want to find and replace. 

• Select a nontype layer if you have more than one text layer and you want to search all layers in the document. 

3 (Optional) If you selected a layer containing text, place the insertion point at the beginning of the text you want


to search.


4 Choose Edit > Find And Replace Text.


5 In the Find What box, type or paste the text you want to find. To change the text, type the new text in the Change


To text box.


6 Select one or more options to refine your search.


7 Click Find Next to begin the search.


8 Click one of the following buttons.


Change Replaces the found text with the revised text. To repeat the search, select Find Next.


Change All Searches for and replaces all occurrences of the found text. 

Change/Find Replaces the found text with the revised text and then searches for the next occurrence. 

Search options for finding and replacing text 
Search All Layers Searches  all layers in a document. This option is available  when  a nontype  layer is selected in the  

Layers palette. 

Forward Searches forward from an insertion point in the text. Deselect this option to search all the text in a layer, 

regardless of where the insertion point is placed. 

Case Sensitive Searches for a word or words that exactly match the case of the text in the Find What text box. For 

example, with the Case Sensitive option selected, a search for “PrePress” does not find “Prepress” or “PREPRESS.” 

Whole Word Only Disregards  the search text if it is embedded in a larger  word. For  example,  if  you are  searching for  

“any” as a whole word, “many” is disregarded. 

Specifying a language for text 

Assigning languages to text 
Photoshop and ImageReady use language dictionaries to check hyphenation. In Photoshop, language dictionaries are 

also used to check spelling. Each dictionary contains hundreds of thousands of words with standard syllable breaks. 

You can assign a language to an entire document or apply a language to selected text. 
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To enter text using a specific language dictionary, choose it from the pop-up menu in the lower left corner of the 

Character palette, select a type tool, and enter the text. 

Association of Cacto-A 
philes


Association of Cac-

B 

tophiles 

Association des Cactophi
les 

Examples of hyphenation for different languages 
A. “Cactophiles” in English USA B. “Cactophiles” in English UK C. “Cactophiles” in French 

To assign a language to selected text 
1 Select the text. 

2 In  the Character  palette,  choose  the appropriate dictionary from the  pop-up  menu  in  the bottom left corner of the  

palette. 

Note: If you select text with multiple languages or if the type layer has multiple languages, the pop-up menu in the 

Character palette is dimmed and displays the word “Multiple.” 

Warping type 

Warping type 
Warping lets you distort type to conform to a variety of shapes; for example, you can warp type in the shape of an arc 

or  a wave.  The warp style  you select is an attribute  of  the type layer—you  can change  a layer’s  warp  style at any  time  

to change the overall shape of the warp. Warping options give you precise control over the orientation and 

perspective of the warp effect. 

Note: You cannot warp type layers that include Faux Bold formatting or that use fonts without outline data (such as 

bitmap fonts). 

Example of type warped with Fish style 
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To warp type

1 Select a type layer.


2 Do one of the following:


• Select a type tool, and click the Warp button  in the options bar. 

• Choose Layer > Type > Warp Text. 

Note: (Photoshop) You can use the Warp command to warp text in a type layer. Choose Edit > Transform > Warp. 

3 Choose a warp style from the Style pop-up menu.


4 Select the orientation of the warp effect—Horizontal or Vertical.


5 If desired, specify values for additional warping options:


• Bend to specify how much warp is applied to the layer 

• Horizontal Distortion or Vertical Distortion to apply perspective to the warp 

See also 

“To warp an item” on page 364


To unwarp type

1 Select a type layer that has warping applied to it.


2 Select a type tool and click the Warp button
  in the options bar, or choose Layer > Type > Warp Text. 

3 Choose None from the Style pop-up menu, and click OK. 

Creating type on a path 

Entering type on a path 
You can enter type that flows along the edge of a work path created by a pen or a shape tool. 

When you enter type along a path, the type flows in the direction that anchor points were added to the path. Entering 

horizontal type on a path results in letters that are perpendicular to the baseline. Entering vertical type on a path 

results in text orientation parallel to the baseline. 

As you move a path or change its shape, the type conforms to the new path location or shape. 

|| 

e 
c 
h 
i

n
o

c 
a

c
t

u 
s 

e c h i n
o

c a c t u s 

cac tuscac tus

Example of horizontal and vertical type on an open path 
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Example of horizontal and vertical type on a closed path created by a shape tool

See also

“About work paths” on page 450

To enter type along a path
1 Do one of the following:

• Select the Horizontal Type tool  or the Vertical Type tool .

• Select the Horizontal Type Mask tool  or the Vertical Type Mask tool .

2 Position the pointer so that the baseline indicator of the type tool  is on the path and click. After you click, an

insertion point appears on the path.

The baseline indicator of the Type tool (left) and the Type tool with its baseline indicator on a path (right)

3 Enter the type. Horizontal type appears along the path, perpendicular to the baseline. Vertical type appears along

the path, parallel to the baseline.

For more control over vertical alignment of type on a path, use the Baseline Shift option in the Character palette. For

example, type a negative value in the Baseline Shift text box to lower the type.

See also

“To shift the baseline” on page 551

To move or flip type on a path
1 Select the Direct Selection tool  or Path Selection tool  and position it over the type. The pointer changes to

an I-beam with an arrow .

2 Do one of the following:

• To move text, click and drag the type along the path. Be careful not to drag across the path.

• To flip text to the other side of the path, click and drag the type across the path.
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Using the Direct Selection tool or Path Selection tool to move or flip type on a path

To move type across a path without changing the direction of the type, use the Baseline Shift option in the Character

palette. For example, if you created type that runs from left to right across the top of a circle, you can enter a negative

number in the Baseline Shift text box to drop the type so that it flows inside the top of the circle.

See also

“To shift the baseline” on page 551

To move a path with type
❖ Select the Path Selection tool  or the Move tool , and then click and drag the path to a new position. If you

use the Path Selection tool, make sure that the pointer does not change to an I-beam with an arrow or you’ll move

the type along the path.

To change the shape of a path with type
1 Select the Direct Selection tool .

2 Click an anchor point on the path and use the handles to change the shape of the path.

Creating paths, shapes, and selections from type

To create a work path from type
Creating a work path from type lets you work with the characters as vector shapes. A work path is a temporary path

that appears in the Paths palette and defines the outline of a shape. After you create a work path from a type layer,

you can save and manipulate it as you do any other path. You cannot edit characters in the path as text; however, the

original type layer remains intact and editable.

❖ Select a type layer, and choose Layer > Type > Create Work Path.

Note: You cannot create work paths from fonts that don’t include outline data (such as bitmap fonts).

See also

“Path segments, components, and points” on page 460

Ca Ca
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To convert type to shapes 
When you convert type to shapes, the type layer is replaced by a layer with a vector mask. You can edit the vector 

mask and apply styles to the layer; however, you cannot edit characters in the layer as text. 

❖ Select a type layer, and choose Layer > Type > Convert To Shape. 

Note: You cannot create shapes from fonts that don't include outline data (such as bitmap fonts). 

See also 

“About shapes and paths” on page 449 

To create a type selection border 
When you use the Horizontal Type Mask tool or Vertical Type Mask tool, you create a selection in the shape of the 

type. Type selections appear on the active layer, and can be moved, copied, filled, or stroked just like any other 

selection. 

1 Select the layer on which you want the selection to appear. For best results, create the type selection border on a 

normal image layer, not a type layer. 

2 Select the Horizontal Type Mask tool  or the Vertical Type Mask tool .


3 Select additional type options, and enter type at a point or in a bounding box.


A red mask appears over the active layer as you enter the type. After you click the Commit button
 , the type 

selection border appears in the image on the active layer. 

Formatting characters 

Formatting characters 
Photoshop and ImageReady give you precise control over individual characters in type layers, including their font, 

size, color, leading, kerning, tracking, baseline shift, and alignment. You can set type attributes before you enter 

characters or reset them to change the appearance of selected characters in a type layer. 

Before you can format individual characters, you must select them. You can select one character, a range of 

characters, or all characters in a type layer. 

To select characters 
1 Do one of the following: 

• (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool . 

• (ImageReady) Select the Type tool


2 Select the type layer in the Layers palette, or click in the text flow to automatically select a type layer.


3 Position the insertion point in the text, and do one of the following:


. 

• Drag to select one or more characters. 

• Click in the text and then Shift-click to select a range of characters. 

• Choose Select > All to select all the characters in the layer. 
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•	 Double-click a word to select it. Triple-click a line to select it. Quadruple-click a paragraph to select it. Quintuple

click anywhere in the text flow to select all characters in a bounding box. 

•	 To use the arrow keys to select characters, click in the text, and then hold down Shift and press the Right Arrow 

or Left Arrow key. To use the keys to select words, hold down Shift+Ctrl (Windows) or Shift+Command (Mac OS) 

and press the Right Arrow or Left Arrow key. 

4 To  select  all the  characters  in  a layer  without positioning  the insertion  point in the  text  flow, select the  type  layer  

in the Layers palette, and then double-click the layer’s type icon. 

Important: In Photoshop, selecting and formatting characters in a type layer puts the Type tool into edit mode. 

To show or hide selection highlighting (ImageReady) 
❖ Do one of the following: 

•	 Choose View > Show > Text Selection. 

•	 Choose View > Extras. This command shows or hides all selected items in the View > Show submenu. 

About the Character palette 
The Character palette provides options for formatting characters. Some formatting options are also available in the 

options bar. 

You can display the Character palette by doing one of the following: 

•	 Choose Window > Character, or click the Character palette tab if the palette is visible but not active. 

•	 With a type tool selected, click the Palette button  in the options bar. 

To  set an option in the  Character palette,  choose  a value  from  the pop-up menu on the  right side of the  option. For  

options with numeric values, you can also use the up and down arrows to set the value, or you can edit the value 

directly in the text box. When you edit a value directly, press Enter or Return to apply a value, Shift+Enter or 

Shift+Return to apply a value and then highlight the value just edited, or Tab to apply a value and move to the next 

text box in the palette. 

A H 

I 

J 

K 
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D 
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G 

F 

Character palette 
A. Font Family B. Font Size C. Vertical Scale D. Set Tsume option (Photoshop) E. Tracking F. Baseline 
Shift G. Language H. Font Style I. Leading J. Horizontal scale K. Kerning 

Note: You must select Show Asian Text Options in the Type preferences for the Set Tsume option to appear in the 

Character palette. 

You can access additional commands and options in the Character palette menu. To use this menu, click the triangle 

in the upper right corner of the palette. 
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See also 

“To use palettes” on page 35 

About fonts 
A font is a complete set of characters—letters, numbers, and symbols—that share a common weight, width, and style. 

When you select a font, you can select the font family and its type style independently.  The font family is a collection  

of fonts sharing an overall typeface design: for example, Times. A type style is a variant version of an individual font 

in the font family: for example, Regular, Bold, or Italic. The range of available type styles varies with each font. If a 

font doesn’t include the style you want, you can apply faux styles—simulated versions of bold, italic, superscript, 

subscript, all caps, and small caps styles. 

In addition to the fonts installed on your system, Photoshop uses font files in these local folders: 

Windows Program Files/Common Files/Adobe/Fonts 

Mac OS Library/Application Support/Adobe/Fonts 

If you install a Type 1, TrueType, OpenType, or CID font into the local Fonts folder, the font appears in Adobe appli

cations only. 

About character sets and alternate glyphs 
Typefaces include many characters in addition to the ones you see on your keyboard. Depending on the font, these 

characters can include ligatures, fractions, swashes, ornaments, ordinals, titling and stylistic alternates, superior and 

inferior characters, old-style figures, and lining figures. A glyph is a specific form of a character. For example, in 

certain fonts, the capital letter A is available in several forms, such as swash and small cap. 

To choose a font family and style 
1 Choose  a font family from the  Font  Family  menu  in  the Character  palette or options  bar.  If  more  than  one copy of  

a font is installed on your computer, an abbreviation follows the font name: (T1) for Type 1 fonts, (TT) for TrueType 

fonts, or (OT) for OpenType fonts. 

In Photoshop, the font family and font style menus display a preview of the font. You can specify the size of the 

preview in the Type preferences. 

(Photoshop) The Font Family menu in both the Character palette and the options bar shows a preview of available fonts. 
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You can choose a font family and style by typing its name in the text box. As you type, the name of the first font or 

style beginning with that letter appears. Continue typing until the correct font or style name appears. 

2	 To choose a font style, do one of the following: 

•	 Choose a font style from the Font Style menu in the Character palette or options bar. 

•	 If  the font family you  chose does not  include a bold  or  italic  style,  click the  Faux  Bold  button  or  the Faux Italic  

button in the Character palette to apply a simulated style. Alternatively, choose Faux Bold or Faux Italic from 

the Character palette menu. 

•	 Use a dynamic shortcut. Dynamic shortcuts are keyboard shortcuts that are available (in edit mode only) for Faux 

Bold, Faux Italic, All Caps, Small Caps, Superscript, Subscript, Underline, and Strikethrough. 

Note: You cannot apply Faux Bold formatting to warped type. 

To specify the size of the font family and font style preview

1 Choose Edit > Preferences > Type (Windows) or Photoshop > Preferences > Type (Mac OS).


2 Choose a size (Small, Medium, or Large) from the Font Preview Size menu.


To change the font on multiple layers

1 In the Layers palette, select the text layers you want to change.


2 In the Character palette, select type characteristics from the pop-up menus.


About type size 
The type size determines how large the type appears in the image. 

(Photoshop) The  default unit of measurement  for type is  points. One PostScript point is equal to 1/72 of an inch in a 

72-ppi image; however, you can switch between using the PostScript and traditional definitions of point size. You can 

change the default unit of measurement for type in the Units & Rulers area of the Preferences dialog box. 

(ImageReady) Pixels are the only unit of measurement for type because ImageReady is designed for creating images 

to be viewed online, where pixels are the standard unit of measurement. 

To choose a type size 
❖ In the Character palette or options bar, enter or select a new value for Size . 

(Photoshop) To use an alternate unit of measurement, enter the unit (in, cm, mm, pt, px, or pica) after the value in 

the Size text box. 

(Photoshop) To change the unit of measurement for type, choose Edit > Preferences > Units & Rulers (Windows) or 

Photoshop > Preferences > Units & Rulers (Mac OS), and choose a unit of measurement from the Type menu. 
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To define the point size unit

1 Choose Edit > Preferences > Units & Rulers (Windows) or Photoshop > Preferences > Units & Rulers (Mac OS).


2 For Point/Pica Size, select from the following options:


PostScript (72 points per inch) Sets a unit size compatible for printing to a PostScript device.


Traditional Uses 72.27 points per inch, as traditionally used in printing. 

3	 Click OK. 

To change the type color 
The type you enter is rendered in the current foreground color; however, you can change the color before or after you 

enter type. When editing existing type layers, you can change the color of individual, selected characters or of all type 

in a layer. 

❖ Do one of the following: 

•	 Click the Color selection box in the options bar or Character palette, and select a color using the Adobe Color 

Picker. In ImageReady, you can also select an option from the Color selection box pop-up menu: Foreground 

Color, Background Color, Other (to choose a color from the Adobe Color Picker), or a color from the pop-up 

palette. 

•	 Use fill shortcuts. To fill with the foreground color, press Alt+Backspace (Windows) or Option+Delete (Mac OS); 

to fill with the background color, press Ctrl+Backspace (Windows) or Command+Delete (Mac OS). 

•	 Apply an overlay layer style to the type layer to apply a color, gradient, or pattern on top of the existing color. You 

can’t apply an overlay layer style selectively, it affects all characters in the type layer. 

•	 Click the foreground color selection box in the toolbox, and select a color using the Adobe Color Picker. Alterna

tively, click a color in the Color palette, the Swatches palette, or (in ImageReady) the Color Table palette. If you use 

this method to change the color of an existing type layer, you must first select characters on that layer. 

•	 (ImageReady) You can drag a color from the toolbox color selection box, the Color palette, the Color Table palette, 

or the Swatches palette and drop it onto a type layer to automatically apply a color overlay style. 

See also 

“Layer effects and styles” on page 414 

To change the color of individual letters 
1 Select the Horizontal Type tool  (Photoshop) or the Type tool (ImageReady) in the toolbox.


2 In the Layers palette, select the layer containing the type.


3 In the document window, select the characters that you want to change.


4 In the options bar at the top of the work area, click the color swatch.


5 In the Adobe Color Picker, locate the color range you want using the triangle sliders on the color spectrum bar,


and then click the desired color in the color field. The color you select appears in the top half of the color swatch in


the Adobe Color Picker. The original color remains in the bottom half.


6 Click OK. The new color replaces the original color in the options bar and in the selected characters.


Note: You won’t see the new color in the characters until you deselect them or select something else. 

 



549 ADOBE PHOTOSHOP CS2 
User Guide 

See also 

“About the type tools in Photoshop” on page 533 

“Formatting characters” on page 544 

About leading 
The vertical space between lines of type is called leading (rhymes with sledding). For Roman type, leading is measured 

from the baseline of one line of text to the baseline of the line above it. The baseline is the invisible line on which most 

letters sit. You can apply more than one leading amount within the same paragraph; however, the largest leading 

value in a line of type determines the leading value for that line. 

Note: When working with horizontal Asian type, you can specify how leading is measured, either from baseline to 

baseline or from the top of one line to the top of the next. 

)Five-point type with 6-point leading (left) and with 12-point leading (right

See also 

“About Asian type” on page 563 

To set the leading

1 Select the characters you want to change. If you don’t select any text, the leading applies to new text you create.


2 In the Character palette, do one of the following:


• Choose the desired leading from the Leading menu . 

• Select the existing leading value, and enter a new value. 

To change the default auto leading percentage

1 Display the Paragraph palette.


2 Choose Justification from the palette menu.


3 For Auto Leading, enter a new default percentage.


About kerning and tracking 
Kerning is the process of adding or subtracting space between specific pairs of characters. Tracking is the process of 

loosening or tightening the spacing between the characters in selected text or an entire block of text. 
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You can automatically kern type using metrics kerning or optical kerning. Metrics kerning uses kern pairs, which are 

included with most fonts. Kern pairs contain information about the spacing of specific pairs of letters. Some of these 

are LA, P., To, Tr, Ta, Tu, Te, Ty, Wa, WA, We, Wo, Ya, and Yo. Photoshop uses metrics kerning by default so that 

specific pairs are automatically kerned when you import or type text. 

Some fonts include robust kern-pair specifications. However, when a font includes only minimal built-in kerning or 

none at all, or if you use two different typefaces or sizes in one or more words on a line, you may want to use the 

optical kerning option. Optical kerning adjusts the spacing between adjacent characters based on their shapes. 

You can also use manual kerning, which is ideal for adjusting the space between two letters. Tracking and manual 

kerning are cumulative, so you can first adjust individual pairs of letters, and then tighten or loosen a block of text 

without affecting the relative kerning of the letter pairs. 

Default kerning (top) and -40 manual kerning between A and C and between U and S (bottom) 

Positive kerning or tracking values move characters apart (adding to the default spacing); negative values move 

characters closer together (reducing the default spacing). Kerning and tracking values are measured in units that are 

1/1000 of an em space. The width of an em space is relative to the current type size. In a 1-point font, 1 em corre

sponds to 1 point; in a 10-point font, 1 em corresponds to 10 points. Kerning and tracking units are 1/1000 em. So, 

for example, 100 units in a 10-point font are equivalent to 1 point. 

)Default tracking (left), and tracking set to 350 (right

To adjust kerning 
1 Do any of the following: 

• 

(ImageReady) from the Kerning menu

To use a font’s built-in kerning information for selected characters, choose Metrics (Photoshop) or Auto

 in the Character palette. 

•	 To automatically adjust the spacing between selected characters based on their shapes, choose Optical from the 

Kerning menu in the Character palette. 

•	 To adjust kerning manually, place an insertion point between two characters, and in the Character palette, enter a 

pointer over the Kerning icon and drag the scrubby slider

numeric value in the Kerning text box, choose a numeric value from the Kerning pop-up menu, or position the

 to the left or right. 
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Note: If a range of text is selected, you can’t kern the text manually. Instead, use tracking. 

2 If you’re adjusting the kerning manually, commit changes to the type layer. 

To adjust tracking

1 Select the type you want to adjust.


2 In the Character palette, do one of the following:


• Enter a numeric value in the Tracking  text box. 

• Choose a numeric value from the Tracking pop-up menu. 

• Position the pointer over the Tracking icon and drag the scrubby slider  to the left or right. 

To adjust horizontal or vertical scale 
Horizontal scale and vertical scale specify the proportion between the height and width of the type. Unscaled


characters have a value of 100%. You can adjust scale to compress or expand selected characters in both width and


height. Scaling distorts the type, so it is generally preferable to use a font that is designed as condensed or expanded,


if one is available.


1 Select the type.


2 Enter a new percentage for Horizontally Scale
  or Vertically Scale  in the Character palette. 

To shift the baseline 
Baseline shift controls the distance of type from its baseline, either raising or lowering the selected type to create 

superscripts or subscripts. Shifting the baseline is especially useful when you’re hand-setting fractions or adjusting 

the position of picture fonts. 

1 Select the type that you want raised or lowered. 

2 In the Character palette, enter a value for Baseline Shift . A positive value moves horizontal type above 

and vertical type to the right of the baseline; a negative value moves type below or to the left of the baseline. 

Default baseline shift (left) and baseline shift of 10 points (right) 
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To underline or strike through text 
You can place a line under horizontal type, or to the left or right of vertical type. You can also place a line through 

horizontal or vertical type. The line is always the same color as the type color. 

1 Select the type you want to underline or strike through. 

2 Do any of the following: 

•	 To underline horizontal type, click the Underline button  in the Character palette. 

•	 To apply an underline to the left or right of vertical type, choose Underline Left or Underline Right from the 

Character palette menu. You can apply an underline to the left or right, but not to both sides. A check mark 

indicates that an option is selected. 

Note: The Underline Left and Underline Right options appear in the Character palette menu only when a type layer 

containing vertical type is selected. When working with vertical Asian type, you can add an underline on either side of 

the type line. 

•	 To apply a horizontal line through horizontal type or a vertical line through vertical type, click the Strikethrough 

button  in the Character palette. You can also choose Strikethrough from the Character palette menu. 

To rotate type 
❖ Do the following: 

•	 To rotate type, select the type layer and use any rotate command or the Free Transform command. For paragraph 

type, you can also select the bounding box and use a handle to rotate the type manually. 

•	 To rotate multiple characters in vertical Asian text, use the tate-chu-yoko. 

See also 

“To use tate-chu-yoko” on page 564 

“Applying transformations” on page 360 

To rotate vertical type characters 
When working with vertical type, you can rotate the direction of characters by 90˚. Rotated characters appear 

upright; unrotated characters appear sideways (perpendicular to the type line). 
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)Original type (left) and type without vertical rotation (right

1 Select the vertical type you want to rotate or unrotate. 

2 Choose Standard Vertical Roman Alignment from the Character palette menu. A check mark indicates that the 

option is selected. 

Note: You cannot rotate double-byte characters (full-width characters available only in Chinese, Japanese, and Korean 

fonts). Any double-byte characters in the selected range will not be rotated. 

To add a drop shadow to text 
Add a drop shadow to give depth to text in an image. 

1 In the Layers palette, select the layer containing the text to which you want to add a drop shadow. 

2 Click the Layer Style button  at the bottom of the Layers palette and choose Drop Shadow from the list that 

appears. 

3 If possible, position the Layer Style dialog box so that you can see the layer and its drop shadow. 

4 Adjust the settings to your liking. You can change various aspects of the shadow, including the way it blends with 

the layers below it, its opacity (how much the underlying layers show through), the angle of the light, and its distance 

from the text or object. 

5 When you’re satisfied with the drop shadow, click OK. 

To use the same drop shadow settings on another layer, drag the Drop Shadow layer in the Layers palette to the other 

layer. When you release the mouse button, Photoshop applies the drop shadow attributes to the layer. 

See also 

“Layer effects and styles” on page 414 

To fill type with an image 
You can fill type with an image by applying a clipping mask to an image layer placed above a text layer in the Layers 

palette. 

1 Open the file containing the image you want to use inside the text. 

2 Select the Horizontal Type tool  (Photoshop) or the Type tool (ImageReady) in the toolbox. 

3 Click the Character tab to bring the Character palette to the front or, if the palette isn’t open, choose Window >


Character.


4 In the Character palette, select the font and other type attributes for the text. Large, bold, thick letters work best.
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5 Click an insertion point in the document window and type the desired text. When you are satisfied with the text, 

press Ctrl+Enter (Windows) or Command+Return (Mac OS). 

6	 Click the  Layers  tab to bring  the Layers palette  to  the front  or, if the  palette isn’t  open, choose Windows  > Layers.  

7 (Optional) If the image layer is the background layer, double-click the image layer in the Layers palette to convert 

it from a background layer to a regular layer. 

Note: Background layers are locked and prevent you from moving them in the Layers palette. It’s necessary to convert 

background layers to regular layers to unlock them. 

8 (Optional) In the New Layer dialog box, you can rename the layer. Click OK to close the dialog box and convert


the image layer.


9 In the Layers palette, drag the image layer so that it is immediately above the text layer.


10 With the image layer selected, choose Layer > Create Clipping Mask. The image appears inside the text.


11 Select the Move tool
 , and then drag the image to adjust its placement within the text. 

To move the text instead of the image, select the text layer in the Layers palette and then use the Move tool to move 

the text. 

See also 

“Clipping masks” on page 436 

“About the type tools in Photoshop” on page 533 

“Formatting characters” on page 544 

Special characters 

To apply all caps or small caps 
You can enter or format type as uppercase characters, either all caps or small caps. When you format text as small 

caps, Photoshop and ImageReady automatically use the small-cap characters designed as part of the font, if available. 

If the font does not include small caps, Photoshop and ImageReady generate faux small caps. 

Regular capital letters (top) compared to small-cap letters (bottom) 

1 Select the type that you want to change. 

2 Do one of the following: 

•	 Click the All Caps button  or the Small Caps button  in the Character palette. 

•	 Choose All Caps or Small Caps from the Character palette menu. A check mark indicates that the option is 

selected. 
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To specify superscript or subscript characters 
Superscript and subscript text (also called superior and inferior text) is reduced-size text that is raised or lowered in 

relation to a font’s baseline. If the font does not include superscript or subscript characters, Photoshop generates faux 

superscript or subscript characters. 

1 Select the type that you want to change. 

2 Do one of the following: 

•	 Click the Superscript button  or the Subscript button  in the Character palette. 

•	 Choose Superscript or Subscript from the Character palette menu. A check mark indicates that the option is 

selected. 

Turning fractional widths off or on 
By default, type is displayed with the fractional widths option on. This option allows the spacing between characters 

to vary using fractions of whole pixels. In most situations, fractional character widths provide the best spacing for 

type appearance and readability. However, for type in small sizes (smaller than 20 points) displayed online, fractional 

widths could cause type to run together or have too much extra space, making it difficult to read. 

Turn off fractional widths when you want to fix type spacing in whole-pixel increments and prevent small type from 

running together. The fractional character width setting applies to all characters on a type layer—you cannot set the 

option for selected characters. 

To turn the feature off or on, choose Fractional Widths from the Character palette menu. A check mark next to 

Fractional Widths in the Character palette menu indicates that the option is selected. 

About Dynamic Shortcuts 
Dynamic Shortcuts are keyboard shortcuts that are accessible only when you are entering point or paragraph type, 

when type is selected, or when the I-beam is in text. You can view Dynamic Shortcuts in the Character palette menu 

when  they  are accessible. Dynamic  Shortcuts are  available for  type  options such as Faux Bold,  Faux  Italic, All  Caps,  

Small Caps, Superscript, Subscript, Underline, and Strikethrough. 

Dynamic shortcuts  appear  in  the Character  palette menu only when you  are entering point  or  paragraph type,  when  type  is  selected, or when  
the I-beam is in text. 
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To view text using the operating system layout 
The System Layout command lets you preview text using the operating system’s default text handling. This is useful 

when designing user interface elements, such as dialog boxes and menus. 

❖ Choose System Layout from the Character palette menu to turn system layout on or off. A check mark next to 

System Layout in the Character palette menu indicates that the option is selected. 

About missing fonts 
If a document uses fonts not installed on your system, you see an alert message when you open it. Photoshop 

indicates which fonts are missing and substitutes missing fonts with available matching fonts. When this happens, 

you can select the text and apply any other available font. 

OpenType character features 

About OpenType fonts 
The OpenType font standard was developed jointly by Adobe and Microsoft, and it brings the advantages of the 

PostScript  Type  1 and  TrueType  font  formats into a new format that takes  advantage of Unicode  character encoding.  

OpenType fonts use a single font file for both Windows and Macintosh computers, so you can move files from one 

platform to another without worrying about font substitution and other problems that cause text to reflow. 

When working with an OpenType font, you can automatically substitute alternate glyphs, such as ligatures, small 

capitals, fractions, and old style proportional figures, in your text. For Japanese OpenType fonts, you can use 

ligatures, discretionary ligatures, Fractions Japanese 78, Japanese Expert, Japanese Traditional, Proportional Metrics, 

Kana, and italics if the font provides them. In Photoshop, these options are in the Character palette menu. 

Substituting alternate glyphs in Adobe Garamond Pro 

OpenType fonts may include an expanded character set and layout features to provide richer linguistic support and 

advanced typographic control. Feature-rich OpenType fonts from Adobe with support for central European (CE) 

languages can be distinguished by the word “Pro,” which is part of the font name and appears in application font 

menus. OpenType fonts that don’t contain central European language support are labeled “Standard,” and are desig

nated by an “Std” suffix in the fonts’ menu names. All OpenType fonts can also be installed and used alongside 

PostScript Type 1 and TrueType fonts. 

 



557 ADOBE PHOTOSHOP CS2 
User Guide 

To apply OpenType features

1 Make sure you have an OpenType font chosen when using the Type tool. If you don’t select any text, the setting


applies to new text you create.


2 From the Character palette menu, choose one of the following from the OpenType submenu:


Standard Ligatures Are typographic replacements for certain pairs of characters, such as fi, fl, ff, ffi, and ffl.


Type with the Standard Ligatures and Discretionary Ligatures options unselected and selected 

Contextual Alternates Are alternative characters included in some script typefaces to provide better joining 

behavior. For example, when using Caflisch Script Pro with contextual alternatives enabled, the letter pair “bl” in the 

word “bloom” is joined so that it looks more like handwriting. 

Discretionary Ligatures Are typographic replacement characters for letter pairs such as ct, st, and ft. 

Note: Although the characters in ligatures appear to be joined, they are fully editable and do not cause the spelling 

checker to flag a word erroneously. 

Swash Substitutes swash glyphs, stylized letterforms with extended strokes (exaggerated flourishes).


Old Style Are numerals shorter than regular numerals, with some old style numerals descending below the type


baseline.


Stylistic Alternates Formats stylized characters that create a purely aesthetic effect.


Titling Alternatives Formats characters (usually all in capitals) designed for use in large-size settings, such as titles.


Ornaments Are devices that add a personal signature to the type family and can be used as title page decoration,


paragraph markers, dividers for blocks of text, or as repeated bands and borders.


Ordinals Automatically formats ordinal numbers (such as 1st and 2nd) with superscript characters. Characters such


as the superscript in the Spanish words segunda and segundo (2a and 2o) are also typeset properly.


Fractions Automatically formats fractions; numbers separated by a slash (such as 1/2) are converted to a shilling


fraction (such as
 ). 

See also 

“To set Asian OpenType font attributes” on page 566 
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Formatting paragraphs 

To format paragraphs 
A paragraph is any range of type with a carriage return at the end. You use the Paragraph palette to set options that 

apply to entire paragraphs, such as the alignment, indention, and space between lines of type. For point type, each 

line is a separate paragraph. For paragraph type, each paragraph can have multiple lines, depending on the dimen

sions of the bounding box. 

You can select paragraphs and then use the Paragraph palette to set formatting options for a single paragraph, 

multiple paragraphs, or all paragraphs in a type layer. 

1 Do one of the following to select paragraphs: 

• (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool . 

• (ImageReady) Select the Type tool 

2 Do one of the following: 

. 

• To apply formatting to a single paragraph, click in a paragraph. 

• To apply formatting to multiple paragraphs, make a selection within a range of paragraphs. 

• To apply formatting to all paragraphs in the layer, select the type layer in the Layers palette. 

About the Paragraph palette 

type tool and click the Palette button

You use the Paragraph palette to change the formatting of columns and paragraphs. To display the palette, choose

Window > Paragraph, or click the Paragraph palette tab if the palette is visible but not active. You can also select a

 in the options bar. 

To set options with numeric values in the Paragraph palette, you can use the up and down arrows or edit the value 

directly in the text box. When you edit a value directly, press Enter or Return to apply a value, Shift+Enter or 

Shift+Return to apply a value and then highlight the value just edited, or Tab to apply a value and move to the next 

text box in the palette. 

A 

B F 

G 

C 

D 

E 

Paragraph palette 
A. Alignment and justification B. Left indent C. First line left indent D. Space before paragraph E. Hyphenation F. Right 
indent G. Space after paragraph 

You can access additional commands and options in the Paragraph palette menu. To use this menu, click the triangle 

in the upper right corner of the palette. If the palette is docked, click the triangle in the palette tab. 
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To specify alignment 
You can align type to one edge of a paragraph (left, center, or right for horizontal type; top, center, or bottom for 

vertical type). Alignment options are available only for paragraph type. 

1 Do one of the following: 

• Select a type layer if you want all the paragraphs in that type layer to be affected. 

• Select the paragraphs you want affected.


2 In the Paragraph palette or options bar, click an alignment option.


The options for horizontal type are:


Left Align Text Aligns type to the left, leaving the right edge of the paragraph ragged.


Center Text Aligns type to the center, leaving both edges of the paragraph ragged.


Right Align Text Aligns type to right, leaving the left edge of the paragraph ragged.


The options for vertical type are:


Top Align Text Aligns type to the top, leaving the bottom edge of the paragraph ragged.


Center Text Aligns type to the center, leaving both the top and bottom edges of the paragraph ragged.


Bottom Align Text Aligns type to the bottom, leaving the top edge of the paragraph ragged.


To specify justification for paragraph type 
Text is said to be justified when it is aligned with both edges. You can choose to justify all text in a paragraph 

excluding the last line, or you can justify text in a paragraph including the last line. The settings you choose for justi

fication affect the horizontal spacing of lines and the aesthetic appeal of type on a page. Justification options are 

available only for paragraph type and determine word, letter, and glyph spacing. Justification settings apply only to 

Roman characters; double-byte characters available in Chinese, Japanese, and Korean fonts are not affected by these 

settings. 

1 Do one of the following: 

• Select a type layer if you want all the paragraphs in that type layer to be affected. 

• Select the paragraphs you want affected.


2 In the Paragraph palette, click a justification option.


The options for horizontal type are:


Justify Last Left Justifies all lines except the last, which is left-aligned.


Justify Last Centered Justifies all lines except the last, which is center-aligned.


Justify Last Right Justifies all lines except the last, which is right-aligned.


Justify All Justifies all lines including the last, which is force-justified.


The options for vertical type are:


Justify Last Top Justifies all lines except the last, which is top-aligned.


Justify Last Centered Justifies all lines except the last, which is center-aligned.


Justify Last Bottom Justifies all lines except the last, which is bottom-justified.


Justify All Justifies all lines including the last, which is force-justified.
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Note: Justification (right, center, and left align, and justify all) for type on a path starts at the insertion point and ends 

at the end of the path. 

To adjust word and letter spacing 
You can precisely control how Photoshop and ImageReady space letters and words and scale characters. Adjusting 

spacing options is especially useful when you work with justified type, although you can adjust spacing for unjus

tified type, too. 

Note: Spacing options are always applied to an entire paragraph. To adjust the spacing in a few characters but not an 

entire paragraph, use the Tracking option. 

1 Do one of the following: 

• Select a type layer if you want all the paragraphs in that type layer to be affected. 

• Select the paragraphs you want affected.


2 Choose Justification from the Paragraph palette menu.


3 Enter values for any of the following:


Word Spacing Adjusts the space between words that is created by pressing the spacebar. Word Spacing values can


range from 0% to 1000%; at 100%, no additional space is added between words. 

Letter Spacing Adjusts the distance between letters and includes kerning or tracking values. Letter Spacing values 

can range from –100% to 500%; at 0%, no space is added between letters. 

Glyph Scaling Adjusts the width of characters (a glyph is any font character). Glyph Spacing values can range from 

50% to 200%; at 100%, the width of characters is not scaled. 

Auto Leading Adjusts the leading automatically based on a percentage of the type size. 

For justified type, enter Minimum and Maximum values to define a range of acceptable spacing. For both justified 

and unjustified paragraphs, enter Desired values to set the spacing. 

To indent paragraphs 
Indention specifies the amount of space between type and the bounding box or line that contains the type. Indention 

affects only the selected paragraph or paragraphs, so you can easily set different indentions for paragraphs. 

1 Do one of the following: 

• Select a type layer if you want all the paragraphs in that type layer to be affected.


• Select the paragraphs you want affected.


2 In the Paragraph palette, enter a value for an indention option:


Indent Left Margin Indents from the  left  edge  of  the paragraph. For  vertical  type, this option controls the  indention 


from the top of the paragraph.


Indent Right Margin Indents from the right edge of the paragraph. For vertical type, this option controls the 

indention from the bottom of the paragraph. 

Indent First Line Indents the first line of type in the paragraph. For horizontal type, the first line indent is relative 

to the left indent; for vertical type, the first line indent is relative to the top indent. To create a first line hanging 

indent, enter a negative value. 
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When  working  with  Japanese  type, you  can use  the mojikumi setting  instead of the  Paragraph palette  to  specify the  

indent for the first line. If you specify the indent for the first line in the Paragraph palette, and specify mojikumi 

settings for the first line indent, the text is placed inside the total of both indents. 

To adjust paragraph spacing 
You can control the space above and below paragraphs using the paragraph spacing options. 

1 Do one of the following: 

• Select a type layer if you want all the paragraphs in that type layer to be affected. 

• Select the paragraphs you want affected.


2 In the Paragraph palette, enter a value for Add Space Before Paragraph
  and Add Space After Paragraph . 

To specify hanging punctuation for Roman fonts 
Hanging punctuation controls the alignment of punctuation marks for a specific paragraph. When Roman Hanging 

Punctuation is turned on, the following characters appear outside the margins: single quotes, double quotes, 

apostrophes, commas, periods, hyphens, em dashes, en dashes, colons, and semicolons. When a punctuation 

character is followed a quotation mark, both characters hang. 

Keep in mind that the paragraph alignment determines the margin from which the punctuation hangs. For left

aligned and right-aligned paragraphs, punctuation hangs off the left and right margin, respectively. For top-aligned 

and bottom-aligned paragraphs, punctuation hangs off the top and bottom margin, respectively. For centered and 

justified paragraphs, punctuation hangs off both margins. 

Paragraph without hanging punctuation (left) compared to paragraph with hanging punctuation (right) 

1 Do one of the following: 

• Select a type layer if you want all the paragraphs in that type layer to be affected. 

• Select the paragraphs you want affected. 

2 Choose Roman Hanging Punctuation from the Paragraph palette menu. A check mark indicates that the option 

is selected. 

Note: Double-byte punctuation marks available in Chinese, Japanese, and Korean fonts in the selected range will not 

hang when you use Roman Hanging Punctuation. Instead, use either Burasagari Standard or Burasagari Strong. These 

items are available only if you select Show Asian Text Options in the Type preferences. 

 



562 ADOBE PHOTOSHOP CS2 
User Guide 

See also 

“To choose a burasagari option” on page 570 

“To display and set Asian type options” on page 564 

Hyphenation and line breaks 

To adjust hyphenation 
The settings you choose for hyphenation affect the horizontal spacing of lines and the aesthetic appeal of type on a 

page. Hyphenation options determine whether words can be hyphenated and, if so, what breaks are allowable. 

❖ Do any of the following: 

•	 To turn automatic hyphenation on or off, select or deselect the Hyphenate option in the Paragraph palette. 

•	 To apply hyphenation to specific paragraphs, first select only the paragraphs in a type layer that you want to affect. 

•	 To choose a hyphenation dictionary, choose a language from the Language pop-up menu at the bottom of the 

Character palette. 

Note: Hyphenation settings apply only to Roman characters; double-byte characters available in Chinese, Japanese, and 

Korean fonts are not affected by these settings. 

To set automatic hyphenation options

1 Choose Hyphenation from the Paragraph palette menu.


2 Enter values for the following options:


Words Longer Than Letters Specifies the minimum number of characters for hyphenated words. The default value


is five letters.


After First Letters and Before Last Letters Specifies the minimum number of characters at the beginning or end of


a word that can be broken by a hyphen. For example, by specifying three for these values, aromatic would be


hyphenated as aro- matic instead of ar- omatic or aromat- ic.


Hyphen Limit Specifies the maximum number of hyphens that can appear on consecutive lines. Zero means


unlimited hyphens.


Hyphenation Zone Specifies the distance at the end of a line that will cause a word to break in unjustified type. This


option applies only when using the Single-line Composer.


3	 To prevent capitalized words from being hyphenated, deselect Hyphenate Capitalized Words. Then click OK.


To prevent unwanted word breaks 
You can prevent words from breaking at the end of lines—for example, proper names or words that might be misread 

when broken at the end of a line. You also can keep multiple words from breaking—for example, clusters of initials 

followed by a last name. 

1 Select the characters you want to prevent from breaking. 

2 Choose No Break from the Character palette menu. 
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Note: If many contiguous characters are entered with the No Break option selected, there won’t be a forced wrap. 

However, none of the type may be visible if the number of characters exceeds the type boundaries. 

About composition and composition methods 
The appearance of type on the page depends on a complex interaction of processes called composition. Using the 

word spacing, letter spacing, glyph spacing, and hyphenation options that you selected, Photoshop and ImageReady 

evaluate possible line breaks and choose the one that best supports the specified parameters. 

Photoshop and ImageReady offer two composition methods: the Adobe Every-line Composer and the Adobe Single

line Composer. Both composition methods evaluate possible breaks and choose the one that best supports the 

hyphenation and justification options you specify for a given paragraph. 

The Adobe Every-line Composer Considers a network of break points for a range of lines and thus optimizes earlier 

lines in the paragraph to eliminate especially unattractive breaks later on. Working with multiple lines of type results 

in more even spacing and fewer hyphens. 

The Adobe Every-line composer approaches composition by identifying possible breakpoints, evaluating them, and 

assigning a weighted penalty based on these principles: 

•	 The highest importance is given to evenness of letter and word spacing. Possible breakpoints are evaluated and 

penalized according to how much they deviate from optimal spacing. 

•	 Hyphenation is avoided when possible. Breakpoints that require hyphenation are penalized more than those that 

create uneven spacing. 

•	 Good breakpoints are preferred over bad breakpoints. After breakpoint penalty values are identified for a range of 

lines, they are squared, magnifying the bad breakpoints. The composer then uses the good breakpoints. 

The Adobe Single-line Composer Offers a traditional approach to composing type one line at a time. This option 

is useful if you prefer to have manual control over how lines break. The Adobe Single-line Composer uses the 

following principles when considering a breakpoint: 

•	 Compressed or expanded word spacing is preferable to hyphenation. 

•	 Hyphenation is preferable to compressed or expanded letter spacing. 

•	 If spacing must be adjusted, compression is better than expansion. 

To choose a composition method 
1 Select the paragraphs you want to affect. 

2 Choose Adobe Every-line Composer or Adobe Single-line Composer from the Paragraph palette menu. A check 

mark indicates which option is selected. 

Asian type 

About Asian type 
Photoshop provides several  options for  working with Chinese, Japanese,  and Korean type.  Characters  in  Asian fonts  

are often referred to as double-byte characters. 

Note: Your operating system must support the languages in which you wish to work. Consult your system software 

manufacturer for more information. 
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To display and set Asian type options 
By default, Photoshop hides Asian type options in the Character palette and Paragraph palette. To view and set


options for working with Chinese, Japanese, and Korean type, you must select Show Asian Text Options in the Prefer


ences dialog box. You can also control how font names are displayed—in English or in the native language.


1 Choose Edit > Preferences > Type (Windows) or Photoshop > Preferences > Type (Mac OS).


2 Select from the following options:


Show Asian Text Options Displays Asian type options in the Character and Paragraph palettes.


Show Font Names In English Displays Asian font names in English. 

To reduce spacing around Asian type characters 
Tsume reduces the space around a character by a specified percentage value. As a result, the character itself is not


stretched or squeezed. Instead, the space between the character’s bounding box and the em box is compressed. When


tsume is added to a character, spacing around both sides of the character is reduced by an equal percentage.


1 Select the characters you want to adjust.


2 In the Character palette, enter or select a percentage for Tsume
 . The greater the percentage, the tighter the 

compression between characters. At 100% (the maximum value), there is no space between the character’s bounding 

box and its em box. 

To specify how leading is measured in Asian type

1 Select the paragraphs you want to adjust.


2 From the Paragraph palette menu, choose one of the following:


Top-To-Top Leading Measures the spacing between lines of type from the top of one line to the top of the next line.


The first line of type in a paragraph is aligned flush with the top of the bounding box.


Bottom-To-Bottom Leading Measures the space between lines from the type baseline. Space appears between the


first line of type and the bounding box.


A check mark indicates which option is selected. The leading option you choose does not affect the amount of


leading between lines, only how the leading is measured.


Note: Top-To-Top Leading and Bottom-To-Bottom Leading are not available for vertical text. 

To use tate-chu-yoko 
Tate-chu-yoko (also called kumimoji and renmoji) is a block of horizontal type laid out within vertical type lines. 

Using tate-chu-yoko makes it easier to read half-width characters such as numbers, dates, and short foreign words 

in vertical text. 
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Numerals without tate-chu-yoko (left) compared to numerals rotated with tate-chu-yoko (right) 

1 Select the characters that you want to rotate.


2 Choose Tate-Chu-Yoko from the Character palette menu. A check mark indicates that the option is turned on.


Note: Using tate-chu-yoko does not prevent you from editing and formatting type; you can edit and apply formatting 

options to rotated characters just as you do to other characters. 

Aligning Asian type characters 
Mojisoroe is the alignment of characters in Asian type. When a line of text contains different sizes of characters, you 

can specify how to align text to the largest characters in the line: to the top, center or bottom of the em box (right, 

center, and left for vertical frames), to the roman baseline, or to the top or bottom of the ICF box (right or left for 

vertical frames). The ICF is the space where characters can be placed. 

A 

B 

C 

Character alignment options 
A. Small characters aligned to the bottom B. Small characters aligned to the middle C. Small characters aligned to the top 

See also 

“Asian OpenType options” on page 567 

To align Asian type characters 
❖ In the Character palette menu, choose an option from the Character Alignment submenu.


Roman Baseline Aligns the small characters in a line to the large character.


Embox Top/Right, Embox Center, or Embox Bottom/Left Aligns the small characters in a line to the specified


position of the large character’s em box. In vertical text frames, Embox Top/Right aligns the text to the right of the
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em box, Embox Center aligns the text with the center of the em box, and Embox Bottom/Left aligns the text to the


left of the em box.


ICF Top/Right and ICF Bottom/Left Aligns the small characters in a line to the ICF specified by the large characters.


In vertical text frames, ICF Top/Right aligns the text to the right of the ICF, and ICF Bottom/Left aligns the text to


the left of the ICF.


To specify left and right underlining with Asian type

1 Select the type.


2 Choose either Underline Left or Underline Right from the Character palette menu.


To set Asian OpenType font attributes 
Asian OpenType fonts may include a number of features that aren’t available in current PostScript and TrueType


fonts. It is usually best to use any weights of KozMinPro and KozGoPro OpenType fonts. These fonts have the largest


collection of glyphs of the Asian fonts produced by Adobe.


1 Select the characters or type objects to which you want to apply the setting. If you don’t select any text, the setting


applies to new text you create.


2 In the Character palette, make sure that an Asian OpenType Pro font is selected.


3 From the Character palette menu, choose an OpenType option.


4 Turn on the MSIME (Windows) or Kotoeri (Mac OS) input method.


5 Do one of the following:


•	 (Windows) Choose OS Start Menu > Accessory > System Tools > Character Code Table. 

• (Mac OS) Select Kotoeri input method by choosing Show Character Palette from the Kotoeri menu. 

6 Do one of the following: 

•	 (Windows) In the Character Code Table, select the Show Details option, and then choose All for Group and 

choose Unicode for Character Set. 

A 

B 

Character Code Table 
A. Font menu B. Show Details check box 

•	 (Mac OS) In the Kotoeri Character palette, set the display to All and then click the Glyph Catalog tab. 
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A 

C 

B 

Kotoeri Character palette 
A. View option B. Show More Options C. Font information 

7 (Mac OS) Set the Kotoeri Character palette font to the OpenType font you are using. 

8 Do one of the following: 

•	 (Windows) Select the character you want to use, click the Choose button, and then copy and paste it. 

•	 (Mac OS) Click the Show More Options button, select the character you want to use, and then either double-click 

the character or click the Input button. 

Asian OpenType options 
Additional OpenType options are available, depending on the font.


Japanese 78 Substitutes the standard glyph with the jp78-variant glyph.


Japanese Expert Substitutes the standard glyph with the expert-variant glyphs.


Japanese Traditional Substitutes the standard glyph with the traditional-variant glyph.


Proportional Metrics Substitutes the half-width and the full-width glyph with the proportional glyph.


Kana Substitutes the standard kana glyph with the horizontally optimized kana glyph for horizontal layout.


However, the differences are often very subtle.


Roman Italics Substitutes the standard proportional glyph with the italic glyph.


See also 

“To apply OpenType features” on page 557 
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To choose a mojikumi set 
Mojikumi specifies Japanese text composition for spacing of Japanese characters, roman characters, punctuation, 

special characters, line start, line end, and numbers. Photoshop includes several predefined mojikumi sets based on 

the Japanese Industrial Standard (JIS) X 4051-1995. 

❖ In the Paragraph palette, choose an option from the Mojikumi pop-up menu: 

None Turns off the use of mojikumi 

Mojikumi Set 1 Uses half-width spacing for punctuation 

Mojikumi Set 2 Uses full-width spacing for most characters except the last character in the line 

j jMo ikumi Set 1, and Mo ikumi Set 2 

Mojikumi Set 3 Uses full-width spacing for most characters and the last character in the line 

Mojikumi Set 4 Uses full-width spacing for all characters 

Mojikumi Set 3, and Mojikumi Set 4 
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To choose kinsoku shori settings for a paragraph 
Kinsoku shori specifies line breaks for Japanese text. Characters that cannot begin a line or end a line are known as 

kinsoku characters. Photoshop includes weak and maximum kinsoku sets based on the Japanese Industrial Standard 

(JIS) X 4051-1995. Weak kinsoku sets omit long vowel symbols and small hiragana characters. You can use these 

existing sets, or add or delete kinsoku characters to create new sets. 

❖ In the Paragraph palette, choose an option from the Kinsoku Shori pop-up menu: 

None Turns off the use of kinsoku shori. 

JIS Weak or JIS Maximum Prevents the following characters from beginning or ending a line: 

JIS Weak Set 

Characters that can’t begin a line 

Characters that can’t end a line 

JIS Maximum Set 

Characters that can’t begin a line 

Characters that can’t end a line 

To select a kinsoku line-breaking option 
Kinsoku shori or mojikumi must be selected to use the following line-breaking options.


❖ From the Paragraph palette menu, choose Kinsoku Shori Type and then choose one of the following methods:


Push In First Moves characters up to the previous line to prevent prohibited characters from ending or beginning a


line.


Push Out First Moves characters down to the next line to prevent prohibited characters from ending or beginning


a line.


Push Out Only Always moves characters down to the next line to prevent prohibited characters from ending or


beginning a line. A push-in is not attempted.


A check mark indicates which method is selected.
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To choose a burasagari option 
Burasagari lets single-byte periods, double-byte periods, single-byte commas, and double-byte commas fall outside


the paragraph bounding box.


❖ From the Paragraph palette menu, choose burasagari and then choose:


None Disables Japanese hanging punctuations when a Kinsoku set is in effect. Kinsoku Shori can still cause push


in or push-out behavior but does not hang Burasagari characters on or immediately outside the text frame.


Regular Enables Japanese hanging punctuations but allows burasagari characters to hang as little as possible. This


is the default Burasagari setting. With the Regular option, the behavior varies according to whether the line is


justified or not.


Force Enables Japanese hanging punctuation but forces the punctuation outside of the text frame when it needs to


hang, regardless of the justification or alignment setting. Hanging punctuation is never placed on the text frame as


in Burasagari Regular. Also, the position of the hanging punctuation can cause a slight expansion, even for nonjus


tified text.
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Chapter 20: Designing web pages


Designing for the web 

Designing web pages 
The graphics tools and features in Photoshop and ImageReady simplify most web-design tasks. 

Page design 

In ImageReady, preset document sizes for pages and banners, grids, guidelines, and Smart Guides simplify page 

layout. Both Photoshop and ImageReady let you add content to layouts using the text, drawing, and painting tools. 

In ImageReady, you can arrange and align content using layers, layer sets, and grouped layers. To experiment with 

different page compositions or to export variations of a page, use the Layer Comps palette. 

Slices 

When your page composition is ready for output to the web, both Photoshop and ImageReady provide the Slice tool 

to let you divide page layouts or complex graphics into areas and specify independent compression settings (and 

smaller file sizes). 

Rollovers 

You can use the Web Content palette in ImageReady to track slices and their rollover states. For example, you can 

create  a button for  a web  page  that  glows whenever the  user  moves the  pointer over it,  and you  can manage the  button  

states and activities in those states. 

Animations 

You can create simple web animations, both in Photoshop and ImageReady, with the Animation palette. You use this 

palette to determine, frame by frame, the appearance of an animation. You can export an animation as an animated 

GIF from Photoshop and as an animated GIF or SWF file from ImageReady. In ImageReady, you can create 

animation in conjunction with sets of slices, nested tables, percentage width tables, and remote rollovers (as you move 

the pointer over one image, a different image changes.) 

Export and image optimization 

When your page or graphic is ready for final export, you use the Save For Web dialog box (Photoshop) and the 

Optimization palette (ImageReady) to specify precisely how the page or graphic should be exported. 

Note: You can preview most web effects directly in Photoshop or ImageReady. However, the appearance of an image on 

the web depends on the operating system, color display system, and browser used to display the image. Be sure to preview 

images and pages in different browsers, on different operating systems, and with different color bit depths. 

Preparation in Adobe GoLive 

You can open Photoshop and ImageReady files directly in Adobe GoLive. Slices, URLs, and other web features in 

Photoshop files are accessible in GoLive for management and editing. 
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Automating the workflow 

Photoshop and ImageReady have a robust system for automating repetitive tasks. For example, ImageReady droplets 

allow designers to quickly convert a batch of images into a web-ready format. 

Slicing web pages 
A slice is a rectangular area of an image that you can use to create links, rollovers, and animations in the associated 

web page. Dividing an image into slices gives you better control over the function and file size of your image. 

You use slices to divide a source image into functional areas. When you save both the image and an HTML file, each 

slice is saved as an independent file with its own settings and color palette, and the proper links, rollover effects, and 

animation effects are preserved. 

Slices are also useful when you work with images that contain different types of data. For example, if you want to 

animate one area of an image (requiring GIF format) but want to optimize the rest of the image in JPEG format, you 

can isolate the animation using a slice. 

Web page divided into slices with a highlighted rollover slice 

When you work with slices, keep these basics in mind: 

•	 You can create a slice by using the Slice tool or by creating layer-based slices. 

•	 After you create a slice, you can select it using the Slice Select tool and then move it, resize it, or align it with 

other slices. 

•	 You can set options for each slice—such as content type, name, and URL—in the Slice Options dialog box 

(Photoshop) or the Slice palette (ImageReady). 

Slice types 
Slices are categorized by their content type (auto, image, no-image, table) and by the way they are created (user, layer

based). 

Slices created with the Slice tool are called user slices; slices based on the content of a layer are called layer-based slices. 

When you create a new user slice or layer-based slice, additional auto slices are generated to account for the remaining 

areas of the image. In other words, auto slices fill the space in the image that is not defined by user slices or layer

based slices. Auto slices are regenerated every time you add or edit user slices or layer-based slices. You can convert 

auto slices to user slices. Table slices contain nested tables. 
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User slices, layer-based slices, and auto slices look different—user slices and layer-based slices are defined by a solid 

line, whereas auto slices are defined by a dotted line. In addition, each type of slice displays a distinct icon. You can 

choose to show or hide auto slices, which can make your work with user- and layer-based slices easier to view. 

A subslice is a type of auto slice that is generated when you create overlapping slices. Subslices indicate how the image 

is divided when you save the optimized file. Although subslices are numbered and display a slice symbol, you cannot 

select or edit them separately from the underlying slice. Subslices are regenerated every time you arrange the stacking 

order of slices. 

Slices are created using different methods: 

• Auto slices are automatically generated. 

• User slices are created with the Slice tool. 

• Layer-based slices are created with the Layers palette. 

• Table slices are created with the Web Content palette in ImageReady. 

See also 

“Slice content types” on page 588 

Creating slices 

To create a slice with the Slice tool 
1 Select the Slice tool . Any existing slices automatically appear in the document window.


2 Choose a style setting in the options bar:


Normal Determines slice proportions as you drag.


Fixed Aspect Ratio Sets a height-to-width ratio. Enter whole numbers or decimals for the aspect ratio. For example, 

to create a slice twice as wide as it is high, enter 2 for the width and 1 for the height. 

Fixed Size Specifies the slice’s height and width. Enter pixel values in whole numbers. 

3 Drag over the area where you want to create a slice. Shift-drag to constrain the slice to a square. Alt-drag 

(Windows) or Option-drag (Mac OS) to draw from the center. Use View > Snap To to align a new slice to a guide or 

another slice in the image. See “To move or resize a user slice” on page 579. 

To create slices from guides 
1 Add guides to an image. 

2 Do one of the following: 

• (Photoshop) Select the Slice tool, and click Slices From Guides in the options bar. 

• (ImageReady) Choose Slices > Create Slices From Guides. 

When you create slices from guides, any existing slices are deleted. 

See also 

“To place a guide” on page 61 
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To create a slice from a selection (ImageReady)

1 Select a portion of the image.


2 Choose Select > Create Slice From Selection.


ImageReady creates a user slice based on the selection marquee. If the selection is feathered, the slice covers the full


selection (including the feathered edges). If the selection is nonrectangular, the slice covers a rectangular area large


enough to enclose the full selection.


Layer-based slices 
When you create a slice from a layer, the slice area encompasses all the pixel data in the layer. If you move the layer 

or edit the layer’s content, the slice area automatically adjusts to encompass the new pixels. 

A layer-based slice is updated when the source layer is modified. 

Layer-based slices are especially useful when you work with rollovers. If you apply an effect to the layer—such as a 

drop shadow or glow—to create a rollover state, the slice automatically adjusts to encompass the new pixels. 

However, do not use a layer-based slice when you plan to move the layer over a large area of the image during an 

animation, because the slice dimension may exceed a useful size. 

Layer-based slices are less flexible and have fewer options; however, you can convert (“promote”) a layer-based slice 

or an auto slice to a user slice at any time. 

To create a slice from a layer 
1 Select a layer in the Layers palette. 

2 Choose Layer > New Layer Based Slice. 

Converting auto slices to user slices 
You can move, duplicate, combine, divide, resize, delete, arrange, align, and distribute user slices. You can also apply 

different optimization settings to user slices. In contrast, all auto slices in an image are linked and share the same 

optimization settings. This is because auto slices are regenerated every time you create or edit a user slice or layer

based slice. 

If you select an auto slice and link it to a user slice, the user slice takes on the optimization settings of the auto slice. 

If  you select the  user  slice first, however, the  auto  slice is  promoted to a user slice. Unlinking promotes auto slices to 

user slices. See “To link slices (ImageReady)” on page 584. 
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To convert an auto slice to a user slice

1 Select one or more auto slices.


2 Do one of the following:


• (Photoshop) With the Slice Select tool selected, click Promote in the options bar. 

• (ImageReady) Choose Slices > Promote To User-slices. 

To convert a layer-based slice to a user slice 
Because a layer-based slice is tied to the pixel content of a layer, the only way to move, combine, divide, resize, and 

align it is to edit the layer. You can convert a layer-based slice to a user slice to unlink it from the layer. 

1 Select a layer-based slice. In ImageReady, you can select multiple slices. 

2 Do one of the following: 

• (Photoshop) Click Promote To User Slice in the options bar. 

• (ImageReady) Choose Slices > Promote To User-slices. 

Viewing slices 

Viewing slices 
You can view slices in Photoshop, the Photoshop Save For Web dialog box, and ImageReady. The following charac

teristics can help you identify and differentiate between slices: 

Slice lines Define the boundary of the slice. Solid lines indicate that the slice is a user slice or layer-based slice; 

dotted lines indicate that the slice is an auto slice. 

Slice colors Differentiate user slices and layer-based slices from auto slices. By default, user slices and layer-based 

slices have blue symbols, and auto slices have gray symbols. 

In addition, ImageReady and the Photoshop Save For Web dialog box use color adjustments to dim unselected slices. 

These adjustments are for display purposes only and do not affect the color of the final image. By default, the color 

adjustment for auto slices is twice the amount of that for user slices. 

Slice numbers Slices are numbered  from left to right and top to bottom, beginning in the upper left corner of 

the image. If you change the arrangement or total number of slices, slice numbers are updated to reflect the new 

order. 

Slice badges The Web Content palette uses a number of badges, or icons, to indicate certain conditions, and these 

icons also appear in the document itself: 

• User slice has Image content. 

• User slice has No Image content. 

• Slice is a layer based. 

• Slice is linked. 

• Slice includes a rollover effect. 

• Slice contains the active rollover state. 
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• Slice is a nested table. 

• Slice is a remote trigger. 

• Slice is a remote target. 

To show or hide slice badges (ImageReady)

1 In the Web Content palette, open the palette menu and choose Palette Options.


2 Select Show Slice Badges.


To show or hide slice boundaries 
❖ Do one of the following: 

•	 Choose View > Show > Slices. To hide and show slices along with other items, use the Extras command. See “To 

show or hide Extras” on page 63. 

•	 (ImageReady) Click the Visibility icon , to the left of the slice in the Web Content palette. 

Note: When you turn off a slice’s visibility with the Slices Visibility icon, ImageReady doesn’t output that slice when you 

choose Save Optimized. This is similar to layer visibility functionality. 

To show or hide auto slices 
❖ Do one of the following: 

•	 Select the Slice Select tool, and click Show Auto Slices or Hide Auto Slices in the options bar. 

•	 Choose View > Show > Slices. Auto slices appear with the rest of your slices. 

•	 (ImageReady) Choose View > Show > Auto Slices. 

To show or hide slice numbers 
1 Do one of the following: 

•	 In Windows, choose Edit > Preferences > Guides, Grid, & Slices. 

• In Mac OS, choose Photoshop > Preferences > Guides, Grid, & Slices. 

2 Under Slices, click Show Slice Numbers. 

To show or hide slice numbers and slice symbols (ImageReady) 
1 Do one of the following: 

•	 In Windows, choose Edit > Preferences > Slices. 

• In Mac OS, choose ImageReady > Preferences > Slices. 

2 Under Numbers and Symbols, select a size for display symbols: 

•	 None to display no numbers or symbols 

•	 The small icon to display small numbers and symbols 

•	 The large icon to display large numbers and symbols 

3 For Opacity, enter a value, or choose a value from the pop-up slider to change the opacity (transparency level) of 

numbers and symbols. 
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To show slice lines only (ImageReady) 
1 Do one of the following: 

•	 In Windows, choose Edit > Preferences > Slices. 

• In Mac OS, choose ImageReady > Preferences > Slices. 

2 Under Slice Lines, select Show Lines Only. 

To change the color of slice lines 
1 Do one of the following: 

•	 (Photoshop) In Windows, choose Edit > Preferences > Guides, Grid, & Slices; in Mac OS, choose Photoshop > 

Preferences > Guides, Grid, & Slices. 

•	 (ImageReady) In Windows, choose Edit > Preferences > Slices; in Mac OS, choose ImageReady > Preferences > 

Slices. 

2 Under Slice Lines, choose a color from the Line Color menu.


After the color change, selected slice lines are automatically displayed in a contrasting color.


To change slice color adjustments (ImageReady) 
1 Do one of the following: 

•	 In Windows, choose Edit > Preferences > Slices. 

•	 In Mac OS, choose ImageReady > Preferences > Slices. 

2 Enter a value, or choose a value from the Color Adjustments slider for User slices, Auto slices, or both. (The User


slices option controls color adjustments for both user slices and layer-based slices.)


This value determines the brightness and contrast (dimming) of unselected slices.


Selecting and organizing slices 

To select one or more slices 
Do one of the following: 

•	 Select the Slice Select tool  and click the slice in the image. When working with overlapping slices, click the 

visible section of an underlying slice to select it. 

•	 Select the Slice Select tool, and Shift-click to add slices to the selection. 

•	 Select the Slice Select tool, and click in an auto slice or outside the image area, and drag across the slices you want 

to select. (Clicking in a user slice and dragging moves the slice.) 

•	 (Photoshop) Choose File > Save For Web. In the dialog box, use the Slice tool to select a slice. 

•	 (ImageReady) Select a slice in the Web Content palette. Shift-click to select additional slices. 

•	 (ImageReady) To select all the user slices in a document, choose Slices > Select All User Slices. This selects all 

nonauto slices, including layer-based slices. 

When using either the Slice tool or the Slice Select tool, you can switch from one tool to the other by holding down 

Ctrl (Windows) or Command (Mac OS). 
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To save and load a slice selection (ImageReady) 
Save a slice selection to reselect specific slices quickly and accurately. 

1 Select one or more slices.


2 Choose Slices > Save Slice Selection.


3 Enter a name in the Selection Name text box, and click OK.


4 To load a slice selection, choose Slices > Load Slice Selection, and select the name of the slice selection from the


submenu. 

Note: To delete a slice selection, choose Slices > Delete Slice Selection, and select the name of the slice selection from the 

submenu. Deleting a slice selection does not delete the slices themselves. 

To use slice sets (ImageReady) 
In ImageReady, you can combine slices into sets and toggle the visibility of those sets in the Web Content palette. 

This lets you create different configurations for your web page, which is especially powerful when you combine this 

feature with layer compositions. You can create unique slice sets to match your various layer compositions. 

Note: You can place a slice in only one slice set at a time. 

•	 To create a slice set, select one or more slices and choose Slices > New Slice Set, or click the New Slice Set button 

in the Web Content palette. 

•	 To toggle the visibility of a slice set, click the Visibility icon  in the Web Content palette. 

See also 

“About layer comps and the Layer Comps palette” on page 430 

To delete a slice set 
1 In the Web Content palette, select the slice set you want to delete. 

Note: If the slice set is not visible in the palette, expand the Slices section of the palette by clicking the arrow next to the 

Slices section header. 

2	 Click the Delete icon  to remove the slice set.


3 Choose one of the following:


Set Only Deletes just the set itself.


Set And Contents Deletes the set and all its slices. 
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Modifying slices 

To move or resize a user slice 
You can move and resize user slices in Photoshop and ImageReady, but not in the Photoshop Save For Web dialog 

box. 

1 Select one or more user slices. 

2 Do one of the following: 

•	 To move a slice, move the pointer inside the slice selection border, and drag the slice to a new position. Press Shift 

to restrict movement to a vertical, horizontal, or 45˚ diagonal line. 

•	 To resize a slice, grab a side or a corner handle of the slice, and drag to resize the slice. If you select and resize 

adjacent slices, common edges shared by the slices are resized together. 

To snap slices to a guide, user slice, or other object

1 Select the options you want from the View > Snap To submenu.


2 Choose View > Snap. A check mark indicates that the option is turned on.


3 Move your selected slices as desired. The slices snap to any of your chosen objects within 4 pixels.


See also 

“To show or hide a grid, guides, or smart guides” on page 61 

To resize or move a user slice using numeric coordinates

1 Select one or more user slices.


2 Do one of the following:


•	 (Photoshop) Click the Options button in the options bar. You can also double-click a slice to show the options. 

•	 (ImageReady) Choose Window > Slice to open the Slice palette, and then choose Show Options from the palette 

menu  if the Dimension options are not showing. 

3 In the Dimensions area of the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), change one 

or more of the following options: 

X Specifies the distance in pixels between the left edge of the slice and the origin of the ruler in the document 

window. 

Y Specifies the distance in pixels between the top edge of the slice and the origin of the ruler in the document 

window. 

Note: The default origin of the ruler is the upper left corner of the image. 

W Specifies the width of the slice. 

H Specifies the height of the slice. 

Constrain Proportions (ImageReady) Preserves the current proportions of the slice. 
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To resize a layer-based slice using numeric dimensions (ImageReady)

1 Select a layer-based slice.


2 In  the Slice  palette,  in  the Layer  Based Dimensions options  area, change one  or  more  of  the following  Pad options: 


L Specifies the distance in pixels between the left edge of the slice and the left edge of the layer’s content.


T Specifies the distance in pixels between the top edge of the slice and the top edge of the layer’s content. 

R	 Specifies the distance in pixels between the right edge of the slice and the right edge of the layer’s content. 

B	 Specifies the distance in pixels between the bottom edge of the slice and the bottom edge of the layer’s content. 

To divide user slices and auto slices 
Use the Divide Slice dialog box to divide slices horizontally, vertically, or both. Divided slices are always user slices, 

regardless of whether the original is a user slice or an auto slice. 

Note: You cannot divide layer-based or nested table slices. 

1 Select one or more slices. 

2 Do one of the following: 

•	 (Photoshop) With the Slice Select tool selected, click Divide Slice in the options bar.


•	 (ImageReady) Choose Slices > Divide Slice.


• (ImageReady) Choose Divide Slice from the Slice palette menu.


3 Select Preview in the Divide Slice dialog box to preview the changes.


4 In the Divide Slice dialog box, select one or both of the following options:


Divide Horizontally Into Divides the slice lengthwise.


Divide Vertically Into Divides the slice widthwise. 

5	 Define how you want to divide each selected slice: 

•	 Select and enter a value for Slices Down or Slices Across to divide each slice evenly into the specified number of 

slices. 

•	 Select and enter a value for Pixels Per Slice to create slices with the specified number of pixels. If the slice cannot 

be divided evenly by than number of pixels, the remainder is made into another slice. For example, if you divide a 

slice that is 100 pixels wide into three new slices each 30 pixels wide, the remaining 10-pixel-wide area becomes a 

new slice. 

6	 Click OK. 

To duplicate slices 
You can create a duplicate slice with the same dimensions and optimization settings as the original. If the original


slice is a linked user slice, the duplicate is linked to the same collection of linked slices. Duplicate slices are always


user slices, regardless of whether the original is a user slice, a layer-based slice, or an auto slice.


In ImageReady, you can also copy and paste slices within or between documents.


1 Select a slice or multiple slices.


2 Alt-drag (Windows) or Option-drag (Mac OS) from inside the selection.
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See also 

“To link slices (ImageReady)” on page 584


To duplicate a slice using the Web Content palette (ImageReady)

1 Select a slice in the Web Content palette.


2 Choose Slices > Duplicate Slice or Duplicate Slice from the Web Content palette menu.


3 In the Duplicate Slice dialog box, select from the following options:


Duplicate Rollover States Maintains any rollover states associated with the original slice.


Duplicate Layers For Layer-Based Slices Duplicates a layer associated with a layer-based slice. 

4 From the position menu, choose an option for the position of the duplicate slice. The duplicate slice will adjoin 

the original slice in the position indicated. If the duplicate slice extends beyond the edge of the document, it will be 

truncated. 

5 Click OK. 

To copy and paste a slice (ImageReady)

1 Select one or more slices with the Slice Select tool.


2 Choose Copy Slice from the Edit menu.


3 If you want to paste the slice into another image, open and display that image.


4 Choose Paste Slice from the Edit menu. If you copy and paste in the same image, the pasted slice appears on top


of the original.


The Copy Slice and Paste Slice commands have the same keyboard shortcuts as the regular Copy and Paste


commands.


To combine slices (ImageReady) 
In ImageReady, you can combine two or more slices into a single slice. ImageReady determines the dimensions and 

position of the resulting slice from the rectangle created by joining the outer edges of the combined slices. If the 

combined slices are not adjacent or have different proportions or alignments, the newly combined slice may overlap 

other slices. 

The combined slice takes the optimization settings of the first slice in the series of slices you select before choosing 

the Combine Slices command. A combined slice is always a user slice, regardless of whether the original slices 

include auto slices. 

Note: You cannot combine layer-based slices. 

1 Select two or more slices. 

2 Choose Slices > Combine Slices. 

To change the stacking order of slices 
When slices overlap, the last slice you create is the top slice in the stacking order. You can change the stacking order 

to gain access to underlying slices. You can specify which slice is on the top and bottom of the stack and move slices 

up or down in the stacking order. 
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Note: You cannot arrange the stacking order of auto slices. 

1 Select a slice or multiple slices. 

2 Do one of the following: 

• Choose the Slice Select tool, and click a stacking order option in the options bar. 

A B C D 

Stacking order options 
A. Bring To Front B. Bring Forward C. Send Backward D. Send To Back 

• (ImageReady) Choose Edit > Arrange Slices and choose a stacking order command from the submenu. 

• (ImageReady) Drag the slice up or down in the Web Content palette. 

To align user slices 
You can align user slices along their top, bottom, left, or right edges, or along their vertical or horizontal centers. By 

aligning user slices, you can eliminate unneeded auto slices and generate a smaller, more efficient HTML file. 

Note: To align layer-based slices, align the contents of the layers. 

1 Select the user slices you want to align. 

2 Do one of the following: 

• Choose the Slice Select tool, and select an alignment option in the options bar. 

A B C D E F 

Alignment options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 

• (ImageReady) Choose Edit > Align Slices, and choose a command from the submenu. 

See also 

“To align objects on different layers” on page 403 

To distribute user slices 
You can distribute user slices evenly along the vertical or horizontal axis. By distributing user slices, you can eliminate 

unneeded auto slices and generate a smaller, more efficient HTML file. 
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Note: To distribute layer-based slices, distribute the contents of the layers. 

1 Select three or more user slices you want to distribute. 

2 Do one of the following: 

• Choose the Slice Select tool, and select a distribution option in the options bar. 

A B C D E F 

Distribute options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 

• Choose Edit > Distribute Slices, and choose a command from the submenu. 

See also 

“To align objects on different layers” on page 403 

To delete a slice 
When you delete a user slice or layer-based slice, auto slices are regenerated to fill the document area. 

Deleting a layer-based slice does not delete the associated layer; however, deleting the layer associated with a layer

based slice does delete the layer-based slice. 

Note: You cannot delete auto slices. If you delete all user slices and layer-based slices in an image, one auto slice layer 

remains. 

1 Select one or more slices. 

2 Do one of the following: 

• Choose the Slice or Slice Select tool and press the Backspace key or the Delete key. 

• (ImageReady) Choose Slices > Delete Slices, or choose Delete Slices from the Slice palette menu. 

• (ImageReady) Choose Delete Slice from the Web Content palette menu or click the Delete icon  in the Web 

Content palette. 

3 To delete all user slices and layer-based slices, do one of the following: 

• (Photoshop) Choose View > Clear Slices. 

• (ImageReady) Choose Slices > Delete All. 

To lock all slices 
Locking slices prevents you from resizing, moving, or otherwise changing them accidentally. 

❖ Choose View > Lock Slice. 

To optimize a slice 
You can optimize image slices using the Save For Web dialog box (Photoshop) or the Optimize palette (ImageReady). 
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All image slices use the optimization settings of the entire image until you apply new settings. If you select multiple 

slices with different optimization settings, only the controls that are applicable to all of the selected slices are visible. 

If settings for a control differ among slices, the control is blank. Any settings you choose are applied to all 

selected slices. 

❖ Do one of the following: 

•	 Select one or more image slices and specify options in the Save for Web dialog box or the Optimize palette. 

•	 Select  one or more image  slices  from  the Optimize pop-up menu,  and then choose Optimize to File Size.  Enter a  

desired file size, and choose Slice To Start With (Current Settings or Auto Select GIF/JPEG), and Slice To Use 

(Current, Each, or Total Of All). 

See also 

“To optimize an image for the web” on page 628 

To copy optimization settings between slices (ImageReady) 
1 Select the slice that uses the optimization settings you want to copy. 

2 Drag the Droplet icon  from the Optimize palette onto the slice to which you want to apply the optimization 

settings. 

To link slices (ImageReady) 
You share optimization settings between linked slices. When you apply optimization settings to a linked slice, all 

slices in the set are updated. 

Linked slices in GIF and PNG-8 format share a color palette and dither pattern. The dither pattern is applied across 

adjacent slice boundaries to prevent the appearance of seams between the slices. 

Note: You can also link slices in the Photoshop Save For Web dialog box. See “To work with slices in the Save For Web 

dialog box” on page 629. 

1	 Select two or more slices or slice sets to be linked. 

Note: If the first slice you select is a user slice, any auto slices you link to the first slice become user slices. If the first slice 

you select is an auto slice, any user slices you select are linked to the auto slice group. 

2	 Choose Slices > Link Slices For Optimization. 

Each linked set of user slices is assigned a different color for the slice graphics in the upper left corner of the slice. 

This helps to identify which slices are linked. 

To unlink user slices (ImageReady) 
•	 To unlink a user slice, select the slice, and then choose Slices > Unlink Slices. 

•	 To unlink all of the slices linked to a particular slice, select one of the slices in the Web Content palette, and choose 

Slices > Unlink Shared Links. 

•	 To unlink all user slices in an image, choose Slices > Unlink All. 
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Converting slices to nested HTML tables 

Converting slices to tables (ImageReady) 
When you convert a document containing slices to HTML, it is output as a single table; each individual slice is placed 

inside separate table cells. Slices are actually table cells. 

Optionally, you can choose to group slices into tables themselves, which are then nested inside the main table. You 

can nest only one level down, however; you cannot nest slices grouped into tables inside other slice group tables. 

A slice of type Table Slice is a slice that contains a table you’ve created, or a nested table. 

To create a table (ImageReady) 
You can select and group slices for output as separate, nested tables when converting a document to HTML. 

❖ Do one of the following: 

•	 Select multiple slices and then click the Group Slice Into Table button  in the Web Content palette. 

•	 Select multiple slices and then choose Slices > Group Slices Into Table. 

•	 Select a slice, and change the slice type from “Image” to “Table” in the Slice palette. Switch to the Table palette to 

set its attributes. ImageReady automatically creates a user slice to fill the table. 

in certain browsers. If this happens to your table, a yellow warning icon

Note: Certain slice layouts require ImageReady to generate spacer cells (spacer.gif images) to render the image properly

 appears in the table’s header in the Web 

Content palette. 

Viewing tables (ImageReady) 
In the Web Content palette, slices grouped as nested tables are indicated with the table icon . This same icon 

appears in your document window, with the borders of the slice table outlined in color. 

You can see tables in ImageReady’s Web Content palette or in the image in your document. 

You can also see your table in the Table palette. It has option areas for the table’s Dimensions, Auto Slicing method, 

and Cell Options. 
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Note: To edit the table, you need to select the table or one of its slices. 

To select a table (ImageReady) 
You can select tables in the document window or the Web Content palette. 

•	 In a document, use the Slice Select tool to select the table icon  in a slice. 

•	 In the Web Content palette, select the table directly by clicking its name. 

•	 In a document, select a slice with the Slice Select tool. 

Note: To select the outermost table in a document, you must use the Slice Select tool. 

To resize a table (ImageReady) 
You can resize a table by grabbing the side or corner handles or by adjusting its dimensions. 

1 Select a table. 

2 Do one of the following: 

•	 In the document window, grab a side or corner handle and drag to resize the table. 

•	 In the Dimensions options area of the Table palette, select Pixels and enter the dimensions in pixels (the default 

method). Press Enter (Windows) or Return (Mac OS). If you enter a width, the height changes automatically, and 

vice versa. 

•	 In the Dimensions options area of the Table palette, select Percentage and specify a percentage. Press Enter 

(Windows) or Return (Mac OS). If you specify the width or height as a percentage, the dimensions of the exported 

table are adjusted dynamically, to accommodate the browser window in which it is displayed. 

•	 Choose Slices > Resize Table To Slices. If your table is larger than the slices, this command shrinks the table to fit 

the slices. If the slice area is larger than the table, the table expands to reveal all of the child slices. 

To set table export options (ImageReady) 
When exporting slices for use on the web, Photoshop and ImageReady can optionally export an HTML file with 

instructions on displaying the slices properly in a browser. By default, this exported HTML file uses tables to ensure 

that the sliced composition retains its original appearance. The Table palette in ImageReady provides an additional 

level of control over how this formatting table is exported. 

Note: Changes you make to the structure of an exported HTML file are reflected solely in the browser image, not in the 

image in your work area. 

1	 Choose Window > Table. 

2 Select the table for which you want to set options. By default, the selected table is the top-level table encompassing


the entire composition area.


3 Enter a name for the table in the ID input box of the Table palette. Specifying a name for an exported table


increases conformity with web-accessibility standards.


4 From the Auto Slicing menu, choose a formatting preference:
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Note: Changing this preference may affect how auto slices are generated. 

Default Maintains the default table formatting.


As Columns (Rowspan) Favors the creation of vertical columns in an exported HTML table.


As Rows (Colspan) Favors the creation of horizontal rows in an exported HTML table.


Note: Changing this preference may affect how auto slices are generated. 

5 Set table cell options:


Border Determines the width, in pixels, of the border around the table.


Pad Determines the padding, in pixels, for each table cell. Padding is the space between the edge of a table cell and


its contents.


Space Determines the spacing, in pixels, between each table cell. Spacing is the distance between the edges of any


two table cells.


Note: It’s best to set the table HTML attributes only for tables that contain slices of type No Image. Changing these settings 

in tables containing Image slices can have undesirable results. 

To delete a nested table (ImageReady) 
You can delete tables you’ve nested inside slices with or without deleting the slices that contain them. In other words,


you can ungroup the slices so that they are no longer a table.


1 In the Web Content palette, select the nested table slice.


2 Do one of the following:


•	 Choose Delete Slice from the Web Content palette menu.


• Choose Slices > Delete Slice.


3 Choose one of the following:


Table Only Deletes only the table, keeping the slices intact.


Table And Contents Deletes the table and all its slices.


Slice output options 

To display the Slice Options dialog box 
Do one of the following: 

•	 Double-click a slice with the Slice Select tool. 

•	 With  the Slice  Select  tool  active, click  the Slice  Options button in the  options bar. This method is available  only  in  

the main Photoshop application, not in the Photoshop Save For Web dialog box. 

To display the Slice palette (ImageReady) 
❖ Choose Window > Slice, or select the Slice Select tool and click the palette button  in the options bar. 
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Slice content types 
You can specify how the slice data appears in a web browser when exported with an HTML file. The available options 

vary according to the application and the slice type you select. 

•	 Image slices contain image data, including rollover states. This is the default content type. 

•	 No Image slices let you create empty table cells that can be populated with text or a solid color. You can enter 

HTML text in a No Image slice. If you set the “Text is HTML” flag, the text is interpreted as HTML when viewed 

in a browser. Slices of type No Image aren’t exported as images and can be previewed in a browser. 

•	 (ImageReady) Table slices act as containers for a subset of slices that, upon export, are written into the HTML text 

file as a nested table. 

Note: Setting options for an auto slice promotes the slice to a user slice. 

To specify a slice content type 
1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice Select tool to display the Slice 

Options dialog box. 

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), select a slice type from the Type 

pop-up menu. 

To rename a slice 
As you add slices to an image, you may find it helpful to rename slices based on their content. By default, user slices 

are named according to the settings in the Output Options dialog box. Layer-based slices are given the name of the 

layer from which they are derived. 

❖ Do one of the following: 

•	 Select a slice. If you are working in Photoshop, double-click the slice with the Slice Select tool to display the Slice 

Options dialog box. In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), type a new 

name in the Name text box. 

Note: The Name text box is not available for No Image slice content. 

•	 (ImageReady) Double-click the slice name in the Web Content palette, and enter a new name. 

To choose a background color for a slice 
You can select a background color to fill the transparent area (for Image slices) or entire area (for No Image slices) of 

the slice. 

Photoshop and ImageReady do not display the selected background color—you must preview the image in a browser 

to view the effect of selecting a background color. 

1 Select a slice. If you are working in the Photoshop Save For Web dialog box, double-click the slice with the Slice 

Select tool to display the Slice Options dialog box. 

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), select a background color from the 

Background Color pop-up menu: 

•	 (Photoshop) Select None, Matte, Eyedropper (to use the color in the eyedropper sample box), White, Black, or 

Other (using the Adobe Color Picker). 

•	 (ImageReady) Select None, Matte, Foreground Color, Background Color, or Other (to use the Adobe Color 

Picker), or select a color from the pop-up palette. 
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To assign URL link information to an Image slice 
Assigning a URL to a slice makes the entire slice area a link in the resulting web page. When a user clicks the link, 

the web browser navigates to the specified URL and target frame. This option is available only for Image slices. 

1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice Select tool to display the Slice 

Options dialog box. 

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), enter a URL in the URL text box, 

or choose a previously created URL from the pop-up menu. You can enter a relative URL or absolute (full) URL. If 

you enter an absolute URL, be sure to include the proper protocol (for example, http://www.adobe.com, not 

www.adobe.com). For more information on using relative and full URLs, see an HTML reference. 

3 If desired, enter the name of a target frame in the Target text box, or choose an option from the Target menu: 

_blank Displays the linked file in a new window, leaving the original browser window open. 

_self Displays the linked file in the same frame as the original file. 

_parent Displays the linked file in its own original parent frameset. Use this option if the HTML document contains 

frames and the current frame is a child. The linked file appears in the current parent frame. 

_top Replaces the entire browser window with the linked file, removing all current frames.The name must match a 

frame name previously defined in the HTML file for the document. When a user clicks the link, the specified file 

appears in the new frame. 

Note: For more information on frames, see an HTML reference. 

To specify browser messages and Alt text 
You can specify what messages appear in the browser. These options are available only for Image slices and appear 

only in exported HTML files. 

1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice Select tool to display the Slice 

Options dialog box. 

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), type the desired text. 

Message Text/Status Bar Message Changes the default message in the browser’s status area for a selected slice or 

slices. By default, the slice’s URL, if any, is displayed. 

Alt Tag/Alt Specifies an Alt tag for a selected slice or slices. The Alt text appears in place of the slice image in 

nongraphical browsers. It also appears in place of the image while the image is downloading and as a tool tip in some 

browsers. 

Adding HTML text to a slice 
When you choose a slice of type No Image, you can enter text to be displayed in the slice area of the resulting web 

page. This is HTML text that you format using standard HTML tags. You can also select vertical and horizontal 

alignment options. For more information on specific HTML tags, see an HTML reference. 

Photoshop and ImageReady do not display HTML text in the document window; you must use a web browser to 

preview the text. Be sure to preview HTML text in different browsers, with different browser settings, and on 

different operating systems to confirm that your text is displayed correctly on the web. 

Note: The amount of text in a No Image slice can affect the layout of an exported page. 
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See also 

“To preview an optimized image in a browser” on page 597


To add HTML text to a slice

1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice Select tool to display the Slice


Options dialog box.


2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), select No Image from the Type


menu.


3 Type the desired text in the text box.


4 (Photoshop Save For Web dialog box and ImageReady) If the text includes HTML formatting tags, select the Text


Is HTML option. If you don’t select this option, HTML formatting tags are displayed as text in the resulting web page.


5 (Photoshop Save For Web dialog box and ImageReady) If desired, select options in the Cell Alignment section of


the dialog box:


Default Uses the browser’s default for horizontal alignment.


Left Aligns the text to the left side of the slice area. 

Center Aligns the text to the center of the slice area. 

Right Aligns the text to the right side of the slice area. 

Default Uses the browser’s default for vertical alignment. 

Top Aligns the text to the top of the slice area. 

Baseline Sets a common baseline for the first line of text in cells in the same row (of the resulting HTML table). Each 

cell in the row must use the Baseline option. 

Middle Centers the text vertically in the slice area. 

Bottom Aligns the text to the bottom of the slice area. 

Image maps 

About image maps (ImageReady) 
Image maps link an area of an image to a URL. You can set up multiple linked areas—called image map areas—in an 

image, with links to other web pages or multimedia files. 

When choosing between using slices or image maps to create hyperlinks, consider the following: 

•	 Using image maps keeps the exported image intact as a single file, whereas using slices causes the image to be 

exported as separate files (one per slice). 

•	 With image maps, you can link circular, polygonal, or rectangular areas in an image; with slices you can link only 

rectangular areas. 

•	 Image maps do not allow as much flexibility in optimization as slices. 

Note: To avoid unexpected results, do not create image map areas in slices that contain URL links—some browsers ignore 

either the image map links or the slice links. 
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You can  create  image map  areas using  an  Image Map  tool  or  a layer, and  then  set options  for the  image map  sections  

in the Image Map palette. 

•	 Tool-based image map areas. Create these using an Image Map tool; drag in the image to define the image map 

area. 

•	 Layer-based image map areas. Create these from a layer; the layer’s content defines the shape of the image map 

area. If you edit the layer’s content, the image map area automatically adjusts to accommodate the change. 

Note: If you add a rollover effect to an image map area, the area becomes a new slice. 

Layer-based rectangle image map compared to polygonal image map 

Important: If you overlap image map areas, the topmost area is active. 

To create an image map area using an image map tool (ImageReady) 
1 Select  the Rectangle  Image Map  tool  , the  Circle Image  Map tool  ,  or  the Polygon  Image Map  tool  in  the  

toolbox. 

2 (Optional) If you use the Rectangle or Circle Image Map, select Fixed Size to specify the dimensions of the image 

map area. Enter pixel values in whole numbers. If you use the Polygon tool, enter a value or choose a value from the 

Quality pop-up slider to set the number of segments in the polygon. 

3 Do one of the following to define the image map area: With the Rectangle or Circle Image Map tool, drag over the 

area you want to define. Shift-drag to constrain the area to a square or circle. Alt-drag (Windows) or Option-drag 

(Mac OS) to drag an image map area from its center. 

•	 With  the Polygon  Image Map  tool, click  in  the image  to  set the  starting  point.  Position  the pointer  where you  want  

the first straight segment to end, and click. Continue clicking to set endpoints for subsequent segments. Hold 

down Shift to constrain the segment to 45˚ increments. Shift+Option-drag (Mac OS) to constrain and draw from 

the center. To close the border, double-click, or position the pointer over the starting point (a closed circle appears 

next to the pointer) and click. 

To add points to a polygonal image map area, select the Image Map Select tool, and Shift-click where you want to 

add a point. To remove points from a polygonal image map area, select either the Image Map Select or the Polygon 

tool, and Alt-click (Windows) or Option-click (Mac OS) the points you want to remove. 

To create an image map area from a layer (ImageReady) 
1 In  the Layers palette, choose a layer from which  to  create  an  image map  area. (To  use multiple layers in one  image  

map area, first merge the layers.) 

2 Choose Layer > New Layer Based Image Map Area or choose Promote Layer Based Image Map Area from the 

Image Map palette menu. 
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To change the shape of a layer-based image map area (ImageReady)

1 Select a layer-based image map area by clicking it in the Web Content palette or by using the Image Map Select


tool
 . 

2 In  the Layer  Based Settings section  of  the Image  Map palette, choose an option from the  pop-up  menu  of  shapes:  

Rectangle, Circle, or Polygon. If you choose Polygon, enter a value or choose a value from the Quality pop-up slider 

to set the number of segments in the polygon. 

See also 

“To select an image map area (ImageReady)” on page 593 

To convert a layer-based image map area to a tool-based image map area 
(ImageReady) 
1 Select a layer-based image map area by clicking it in the Web Content palette or by using the Image Map Select 

tool . 

2 Choose  Promote Layer  Based Image  Map Area from the  Image Map  palette menu.  If  the layer  contains  multiple,  

nonoverlapping areas of pixel content, ImageReady creates multiple tool-based image map areas. 

See also 

“To select an image map area (ImageReady)” on page 593 

To show or hide image map areas (ImageReady) 
•	 Click the Image Map Visibility button  in the toolbox. This button works like a toggle to show or hide image 

map areas. 

•	 Choose View > Show > Image Maps. 

•	 Choose View > Extras. This command also shows or hides selection edges, slices, text bounds, text baseline, and 

text selections. 

Note: When you select the Image Map Select tool, image map areas are automatically shown. 

To set image map display preferences (ImageReady) 
Image map preferences determine how image map areas appear in the document window. You can set preferences 

for image map lines, line color, and color adjustments. 

1	 Do one of the following: 

•	 In Windows, choose Edit > Preferences > Image Maps.


• In Mac OS, choose ImageReady > Preferences > Image Maps.


2 To display image map lines only and deselect color adjustment display, select Show Lines Only.


3 To show a bounding box for circular image map areas, select Show Bounding Box.


4 To change the color of image map lines, choose a color from the Line Color menu. When you change the color of


image map lines, lines denoting selected areas change to a contrasting color.


5 To change the degree of color adjustment to the image map, enter a value, or choose a value from the Image Map


Overlay slider. The value determines the brightness and contrast of unselected image map areas.


 



593 ADOBE PHOTOSHOP CS2 
User Guide 

To display the Image Map palette (ImageReady) 
❖ Choose Window > Image Map, or click the palette button  to the right of the options bar for the Image Map 

Select tool . 

To rename an image map area (ImageReady)

1 Select an image map area.


2 In the Image Map palette, enter a new name in the Name text box.


To specify link options for an image map area (ImageReady) 
1 Select an image map area. 

2 In the Image Map palette, enter a URL, or choose a previously created URL from the URL menu. You can enter a


relative URL or absolute (full) URL. If you enter an absolute URL, be sure to include the proper protocol (for


example, http://www.adobe.com, not www.adobe.com). For more information on relative and absolute URLs, see an


HTML reference.


3 In the Image Map palette, enter the name of a target frame in the Target text box, or choose an option from the


Target menu:


_blank Displays the linked file in a new window, leaving the original browser window open.


_self Displays the linked file in the same frame as the original file. 

_parent Displays the linked file in its own original parent frameset. Use this option if the HTML document contains 

frames and the current frame is a child. The linked file appears in the current parent frame. 

_top Replaces the entire browser window with the linked file, removing all current frames. The name of the frame 

must match a frame name previously defined in the HTML file for the document. When a user clicks the link, the 

specified file appears in the new frame. 

Note: For more information on frames, see an HTML reference. 

4 In the Image Map palette, enter text for an Alt tag in the Alt text box. The Alt text appears in place of the image 

map area in nongraphical browsers.  In  many  browsers, it also appears  if  the user positions  the mouse  over  the image  

map area. 

To select an image map area (ImageReady) 
❖ Do one of the following: 

• In the Web Content palette, click the image map name. Shift-click to select multiple images. 

• With the Image Map Select tool , click an image map area in the image. Shift-click to add areas to the selection. 

You can also select multiple image map areas by clicking outside an image map area and dragging across the image 

map areas you want to select. 

To move a tool-based image map area (ImageReady)

1 Select one or more image map areas you want to move.


2 Position the pointer inside the image map area, and drag it to a new position. Press Shift to restrict movement to


a vertical, horizontal, or 45˚ diagonal line.


Note: To move a layer-based image map area, move or edit the layer. 
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To resize a tool-based image map area (ImageReady) 
1 Select an image map with the Image Map Select tool  or in the Web Content palette. 

Note: If  you select a polygonal image  map,  the cursor changes  to a white  arrow to show you  where to point  on  the handle.  

The other tools use the standard resize cursor. 

2 Grab a handle of the boundary box by holding the mouse button down while the cursor is over the handle. 

3 Drag a handle on the image map border to resize the image map area. 

Note: To resize a layer-based image map area, move or edit the layer. 

To resize and move a tool-based image map area using numeric coordinates

(ImageReady)

1 Select a rectangular or circular image map area.


2 In the Dimensions area of the Image Map palette, change one or more of the following options:


X Specifies the distance, in pixels, between the left edge of a rectangular image map area, or the center point of a


circular image map area, and the origin of the ruler in the document window.


Y Specifies the distance, in pixels, between the top edge of a rectangular image map area, or the center point of a


circular image map area, and the origin of the ruler in the document window.


Note: The default origin of the ruler is the upper left corner of the image. 

W Specifies the width of a rectangular image map area. 

H Specifies the height of a rectangular image map area. 

R	 Specifies the radius of a circular image map area. 

To duplicate an image map area (ImageReady) 
You can create a duplicate image map area with the same dimensions and settings as the original image map area. 

❖ Do one of the following: 

•	 Select one or more image map areas, and choose Duplicate Image Map Areas from the Image Map palette menu. 

•	 Select one or more image map areas, and Alt-drag (Windows) or Option-drag (Mac OS) from inside the image 

map area. 

•	 Select a image map in the Web Content palette, and choose Duplicate Image Map from the palette menu. 

•	 Select a number of image maps with the Image Map Select tool. Either right-click (Windows) or Control-click 

(Mac OS) with the cursor in one of the image maps. This brings up the context menu for image maps. Select 

Duplicate Image Map Areas. 

The duplicate image map area appears on top of the original (offset 10 pixels down and to the right), and becomes 

the current selection. You can move, resize, or otherwise modify it. 
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To arrange or align image maps (ImageReady) 
The Web Content palette displays the stacking order of image maps. The image map on the top of your stack takes 

precedence, so it’s helpful to be able to arrange them. 

1	 To change the stacking order, do one of the following: 

•	 Select  one or more image  map areas  you want to  arrange. You  can select a combination of tool-based image  map  

areas and layer-based image map areas. Then, with the Image Map Select tool active, click a stacking order option 

in the options bar. Alternatively, choose a stacking order command from the Image Map palette menu. 

A B C D 

Stacking order options 
A. Bring To Front B. Bring Forward C. Send Backward D. Send To Back 

•	 Drag an image map up or down in the Web Content palette. 

2 To align image maps, select a number of image maps with the Image Map Select tool. Either right-click (Windows) 

or Control-click (Mac OS) with the cursor in one of the image maps. This brings up the context menu for image 

maps. Select an Align option: Top Edges, Vertical Centers, Bottom Edges, Left Edges, Horizontal Centers, Right 

Edges. 

See also 

“To align tool-based image map areas (ImageReady)” on page 595 

“To use the Web Content palette (ImageReady)” on page 606 

To align tool-based image map areas (ImageReady) 
You can align and distribute tool-based image map areas to the top, bottom, left, right, and middle. 

Note: To align layer-based image map areas, first select the layers, and then choose an alignment option from the Edit > 

Align Linked submenu. 

1	 Select the tool-based image map areas you want to align or distribute. 

2	 With the Image Map Select tool active, select an alignment option in the options bar. 

A B C D E F 

Alignment options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 

3	 With the Image Map Select tool active, select a distribution option in the options bar. 

A B C D E F 

Distribute options 
A. Top B. Vertical Centers C. Bottom D. Left E. Horizontal Centers F. Right 
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To delete image maps (ImageReady) 
❖ Do one of the following: 

•	 Select the image map area and press the Backspace key or the Delete key. 

•	 Select the image map area and choose Delete Image Map Areas from the Image Map palette menu. 

•	 Select the image map in the Web Content palette and drag it to the Delete icon. 

•	 Select a number of image maps with the Image Map Select tool. Either right-click (Windows) or Control-click 

(Mac OS) while the cursor is in one of the image maps. This brings up the context menu for image maps. Select 

Delete Image Map Areas. 

Client-side and server-side image maps (ImageReady) 
ImageReady can create client-side and server-side image maps. In client-side image maps, the links are interpreted 

by the browser itself. In server-side image maps, the links are interpreted by the server. Because client-side image 

maps don’t need to contact the server to function, they are often significantly faster to navigate. By default, 

ImageReady saves image maps as client-side image maps. 

Important: Server-side image maps do not work in images that have multiple slices. 

You select an image map type in the Output Settings dialog box. If you select a server-side image map, ImageReady 

generates a separate map file based on the server option you select. However, you’ll need to update the path to the 

map file in your HTML file. 

See also 

“HTML output options” on page 647 

Previewing web graphics 

Previewing an image in a browser 
To get an idea of how an optimized image will look in a web page, you can preview the image in any browser installed 

on your system. The browser displays the image with a caption listing the image’s file type, pixel dimensions, file size, 

and compression specifications in the first paragraph, and file name and other HTML information in the second 

paragraph. You can add additional browsers to the menu, and specify which browser will be launched when using a 

keyboard shortcut. 

To add a browser 
1 Do one of the following: 

•	 (Photoshop) Choose File  >  Save  For Web, and  then  choose  Edit  List  from  the Select Browser  menu  at  the bottom  

of the dialog box. Click the Add button in the Browsers dialog box. 

•	 (ImageReady) Choose File > Preview In > Edit Browser List. Click the Add button in the Edit Browsers List dialog 

box. 

2 In the Preview In Other Browser dialog box, navigate to the browser application on your computer, and then click 

the Open button. The browser name appears in the Browsers dialog box. 
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To add all browsers on your computer 
❖ Do one of the following: 

•	 (Photoshop) Choose File  >  Save  For Web, and  then  choose  Edit  List  from  the Select Browser  menu  at  the bottom  

of the dialog box. Click the Find All button. All the browsers installed on your computer appear. Click the OK 

button. 

•	 (ImageReady) Choose File > Preview In > Edit Browser List. Click the Find All button. All the browsers installed 

on your computer appear. Click the OK button. 

To preview an optimized image in a browser 
❖ Do one of the following: 

•	 (Photoshop) Choose File > Save for web, and then choose the browser you want to use from the Select Browser 

menu. (Choose Other to select a browser not listed in the submenu.) You can also click the Preview In button 

to display the image in the default browser. 

•	 (ImageReady) Choose File > Preview In, and then choose an option from the submenu (choose Other to select a 

browser not listed in the submenu), or select a browser from the Preview In Browser tool in the toolbox. 

Creating web photo galleries 

Web photo galleries 
A web photo gallery is a web site that features a home page with thumbnail images and gallery pages with full-size 

images. Each page contains links that allow visitors to navigate the site. For example, when a visitor clicks a thumbnail 

image on the home page, the associated full-size image is loaded into a gallery page. You use the Web Photo Gallery 

command to automatically generate a web photo gallery from a set of images. 

Web photo gallery home page 

Photoshop provides a variety of styles for your gallery, which you can select using the Web Photo Gallery command. 

If you are an advanced user who knows HTML, you can create a new style or customize a style by editing a set of 

HTML template files. 

Each template for gallery styles comes with different options. If you’re using a preset style, some options may be 

dimmed, or unavailable in that particular style. 
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See also 

“Customizing web photo gallery styles” on page 601 

To create a web photo gallery

1 (Optional) Select the files or folder you want to use in Adobe Bridge.


Your images will be presented in the order in which they’re displayed in Bridge. If you’d rather use a different order,


change the order in Bridge.


2	 Do one of the following: 

•	 In Adobe Bridge, choose Tools > Photoshop > Web Photo Gallery. 

•	 In Photoshop, choose File > Automate > Web Photo Gallery. 

3 Choose a style for the gallery from the Styles pop-up menu. A preview of the home page for the chosen style


appears in the dialog box.


4 (Optional) Enter an e-mail address as the contact information for the gallery.


5 Choose the source files for your gallery from the Use menu.


Selected Images From Adobe Bridge Uses images you selected before opening the Web Photo Gallery dialog box.


Folder Uses images from folders you select using the Browse (Windows) or Choose (Mac OS) buttons. Select 

Include All Subfolders to include images inside any subfolders of the selected folder. 

6 Click Destination, and then select a folder in which to store the images and HTML pages for the gallery. Then 

click OK (Windows) or Choose (Mac OS). 

7 Select formatting options for the web gallery. Choose from the Options menu to display each set of options. See 

“Web photo gallery options” on page 599. 

8	 Click OK. Photoshop places the following HTML and JPEG files in your destination folder: 

•	 A home page for your gallery named index.htm or index.html,  depending on the  Extension options. Open this file  

in any web browser to preview your gallery. 

•	 JPEG images inside an images subfolder. 

•	 HTML pages inside a pages subfolder. 

•	 JPEG thumbnail images inside a thumbnails subfolder. 

See also 

“Making sure that your colors match” on page 599 
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Making sure that your colors match 
If  you work with photos in a wide-gamut  color working  space such as ProPhoto  RGB or Adobe  RGB,  you might  want  

to convert the image profile to sRGB before optimizing it or including it in a Web Photo Gallery. Most web browsers 

can’t read embedded color profiles and assume an sRGB profile. If your images look desaturated in a web gallery, 

convert them to sRGB in one of the following ways. It is a good idea to work with a copy of the images. 

•	 To convert a single image, choose Edit > Convert To Profile and then choose sRGB. See “To convert colors in a 

document to another profile” on page 268. 

•	 To convert a folder of images, use the Image Processor. Choose File > Scripts > Image Processor. See “To convert 

files with the Image Processor” on page 739. 

If you use the Image Processor, you can save the files directly to JPEG format in the size that you want them. If you 

do so, make sure to turn Resize Images off in the Large Image options. 

Web photo gallery options 
General Options for file extensions, encoding, and metadata. 

•	 Extension Uses either .htm or .html as the file name extension. 

•	 Use UTF 8 Encoding For URL Uses UTF-8 encoding. 

•	 Add Width And Height Attributes For Images Specifies dimensions, shortening download time. 

• Preserve All Metadata Maintains metadata info.


Banner Text options for the banner that appears on each page in the gallery. Enter text for each of these:


•	 Site Name The name of the gallery. 

•	 Photographer The name of the person or organization receiving credit for the photos in the gallery. 

•	 Contact Info The contact information for the gallery, such as a telephone number or a business address. 

•	 Date The date appearing on each page of the gallery. By default, Photoshop uses the current date. 

• Font and Font Size (Not always available) Options for the banner text. 

Large Images Options for the main images that appear on each gallery page. 

• Resize Images Resizes the source images for placement on the gallery pages. Choose a size from the pop-up menu 

or enter a size in pixels. For Constrain, choose which dimensions of the image you want to constrain during resizing. 

For JPEG Quality, choose an option from the pop-up menu, enter a value between 0 and 12, or drag the slider. The 

higher the value, the better the image quality and the larger the file. 

Note: Photoshop uses the default image interpolation method set in preferences. Choose Bicubic Sharper as the default 

for best results when reducing image size. See “To specify the default interpolation method” on page 184. 

•	 Border Size Specifies the width, in pixels, of the border around the image. 

• Titles Use Specifies options for displaying captions under each image. Select Filename to display the file name, or 

select Description, Credits, Title, and Copyright to display description text drawn from the File Info dialog box. 

•	 Font and Font Size Specify the font and size of the caption. 
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Thumbnails Options for the gallery home page, including the size of the thumbnail images. 

• Size Specifies the thumbnail size. Choose from the pop-up menu or enter a value in pixels for the width of each 

thumbnail. 

• Columns and Rows Specify the number of columns and rows in which to display thumbnails on the home page. 

This option doesn’t apply to galleries that use the Horizontal Frame Style or Vertical Frame Style. 

• Border Size Specifies the width, in pixels, of the border around each thumbnail. 

• Titles Specifies options for displaying captions under each thumbnail. Select Filename to display the file name, or 

select Description, Credits, Title, and Copyright to display description text drawn from the File Info dialog box. 

• Font and Font Size Specify the font and size of the caption. 

Custom Colors Options for colors of elements in the gallery. To change the color of an element, click its color swatch 

and then select a new color from the Adobe Color Picker. You can change the background color of each page 

(Background option) and of the banner (Banner option). 

Security Displays text over each image as a theft deterrent. 

• Content Specifies the text to be displayed. Select Custom Text to enter customized text. Select Filename, 

Description, Credits, Title, or Copyright to display text drawn from the File Info dialog box. 

• Font, Color, and Position Specify the font, color, and alignment of the caption. 

• Rotation options Place the text on the image at an angle. 

Web photo gallery styles 
Photoshop provides a variety of styles for your web photo gallery. If you are an advanced user who knows HTML,


you can create a new style or customize a style by editing a set of HTML template files.


The web photo gallery styles provided by Photoshop are stored in individual folders in the following locations:


Windows Program Files/Adobe/Photoshop CS/Presets/Web Photo Gallery.


Mac OS Adobe Photoshop CS/Presets/Web Photo Gallery.


The name of each folder in this location appears as an option in the Styles menu in the Web Photo Gallery dialog


box. Each folder contains the following HTML template files, which Photoshop uses to generate the gallery:


Caption.htm Determines the layout of the caption that appears below each thumbnail on the home page.


FrameSet.htm Determines the layout of the frame set for displaying pages.


IndexPage.htm Determines the layout of the home page.


SubPage.htm Determines the layout of the gallery pages with full-size images.


Thumbnail.htm Determines the layout of the thumbnails that appear on the home page.


Each template file contains HTML code and tokens. A token is a text string that is replaced by Photoshop when you


set its corresponding option in the Web Photo Gallery dialog box. For example, a template file may contain the


following TITLE element that uses a token as its enclosed text:


<TITLE>%TITLE%</TITLE>


When Photoshop generates the gallery using this template file, it replaces the token %TITLE% with the text that you


entered for Site Name in the Web Photo Gallery dialog box.
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To better understand an existing style, you can open and study its HTML template files using an HTML editor. 

Because only standard ASCII characters are required to create HTML documents, you can open, edit, and create 

these documents using a plain-text editor such as Notepad (Windows) or TextEdit (Mac OS). 

Customizing web photo gallery styles 
You can customize an existing web photo gallery style by editing one or more of its HTML template files. When 

customizing a style, you need to follow these guidelines so that Photoshop can generate the gallery correctly: 

•	 The style folder must contain these files: Caption.htm, IndexPage.htm, SubPage.htm, Thumbnail.htm, and 

FrameSet.htm. 

•	 You can rename the style folder but not the HTML template files in the folder. 

•	 You can have an empty Caption.htm file, and place the HTML code and tokens determining the layout of the 

caption in the Thumbnail.htm file. 

•	 You can replace a token in a template file with the appropriate text or HTML code, so that an option is set through 

the template file rather than through the Web Photo Gallery dialog box. For example, a template file may contain 

a BODY element with the following bgcolor attribute that uses a token as its value: 

bgcolor=%BGCOLOR% 

To set the background color of the page to red, you can replace the token %BGCOLOR% with “FF0000.” 

•	 You can add HTML code and tokens to the template files. All tokens must be in uppercase characters, and begin 

and end with the percent (%) symbol. For information on the tokens that you can use in the template files, see 

“Web photo gallery style tokens” on page 602. 

To customize or create a web photo gallery style 
1 Locate the folder that stores the existing web photo gallery styles. 

2 Do one of the following: 

•	 To customize a style, create a copy of the style folder, and store it in the same location as the existing style folders. 

•	 To create a new style, create a new folder for the new style, and store it in the same location as the existing style 

folders. 

The new or customized style (named for its folder) appears in the Styles menu in the Web Photo Gallery dialog box. 

3	 Using an HTML editor, do one of the following: 

•	 Customize the HTML template file. 

•	 Create the necessary HTML template files and store them inside the style folder. 

When creating the template files, make sure that you follow the guidelines for customization outlined in “Custom

izing web photo gallery styles” on page 601. 

Important: When customizing or creating a template for a gallery style, you should place each of the following tokens 

on a separate line in the HTML file: %CURRENTINDEX%, %NEXTIMAGE%, %NEXTINDEX%, %PAGE%, 

%PREVIMAGE%, and %PREVINDEX%. When generating specific pages of a gallery, Photoshop skips lines in a 

template that contain tokens that don’t apply to those pages. For example, when Photoshop generates the first gallery 

page, it skips any line in the template that contains the %PREVIMAGE% token, which determines the link to the previous 

gallery page. By keeping the %PREVIMAGE% token on a separate line, you ensure that Photoshop doesn’t ignore other 

tokens in the template. 
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Web photo gallery style tokens 
Photoshop uses tokens in the  HTML  template  files to define a default web  photo gallery  style.  Photoshop uses these 


tokens to generate a gallery based on user input in the Web Photo Gallery dialog box.


When customizing or creating a gallery style, you can add any token to any HTML template file, with the exception


of %THUMBNAILS% and %THUMBNAILSROWS%, which can appear only in the IndexPage.htm file. When


adding a token, keep in mind that you may also need to add HTML code to the file so that the token is used correctly.


You can use the following tokens in the HTML template files:


%ALINK% Determines the color of active links.


%ALT% Determines the name of an image file.


%ANCHOR% Provides the ability to return to the thumbnail of the image the user is viewing, rather than the


beginning of the index. This takes effect when the user clicks the Home button.


%BANNERCOLOR% Determines the color of the banner.


%BANNERFONT% Determines the font of the banner text.


%BANNERFONTSIZE% Determines the font size of the banner text.


%BGCOLOR% Determines the background color.


%CAPTIONFONT% Determines the font of the caption below each thumbnail on the home page.


%CAPTIONFONTSIZE% Determines the font size of the caption.


%CHARSET% Determines the character set used on each page.


%CONTENT_GENRATOR% Expands to “Adobe Photoshop CS Web Photo Gallery.”


%CURRENTINDEX% Determines the link for the current home page.


%CURRENTINDEXANCHOR% Resides in SubPage.htm and points to the first index page.


%DATE% Determines the date that appears on the banner.


%FILEINFO% Determines the image file information for a caption.


%FILENAME% Determines the file name of an image. Use this for metadata that appears as HTML text.


%FILENAME_URL% Determines the URL file name of an image. Use this for URL file names only.


%FIRSTPAGE% Determines the link for the first gallery page that appears in the right frame of a frame set.


%FRAMEINDEX% Determines the link for the home page that appears in the left frame of a frame set.


%HEADER% Determines the title of the gallery.


%IMAGEBORDER% Determines the border size of the full-size image on a gallery page.


%IMAGE_HEIGHT% Enables the Add Width And Height Attributes For Images check box. This allows the user to


download the attributes, reducing download time.


%IMAGE_HEIGHT_NUMBER% This token is replaced by a numeral (only) representing the width of the image.


%IMAGEPAGE% Determines the link to a gallery page.


%IMAGE_SIZE% If the Resize Images box is selected, this token contains the image pixel value used in the Large


Images panel. If the box is not selected, this token contains an empty string. This is useful for JavaScript in the 

templates, because it can show the maximum height and width values for all images for the generated site. 
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%IMAGESRC% Determines the URL for a full-size image on a gallery page. 

%IMAGE_WIDTH% Enables the Add Width And Height Attributes For Images check box. This allows the user to


download the attributes, reducing download time.


%IMAGE_WIDTH_NUMBER% This token is replaced by a numeral (only) representing the width of the image.


%LINK% Determines the color of links.


%NEXTIMAGE% Determines the link for the next gallery page.


%NEXTIMAGE_CIRCULAR% Sets the link from large preview image to next large preview image.


%NEXTINDEX% Determines the link for the next home page.


%NUMERICLINKS% Inserts numbered links on subpages to all large preview images.


%PAGE% Determines the current page location (for example, page 1 of 3).


%PHOTOGRAPHER% Determines the name of the person or organization receiving credit for the photos in the


gallery.


%PREVIMAGE% Determines the link for the previous gallery page.


%PREVINDEX% Determines the link for the previous home page.


%SUBPAGEHEADER% Determines the title of the gallery.


%SUBPAGETITLE% Determines the title of the gallery.


%TEXT% Determines the text color.


%THUMBBORDER% Determines the size of thumbnail borders.


%THUMBNAIL_HEIGHT% Enables the Add Width And Height Attributes For Images check box. This allows the


user to download the attributes, reducing download time. 

%THUMBNAIL_HEIGHT_NUMBER% This token is replaced with a numeral (only) representing the height of the


thumbnail.


%THUMBNAILS% This token is replaced with thumbnails using the Thumbnail.htm file for the frame styles. You


must place this token alone in a single, nonbreaking line in the HTML file. 

%THUMBNAIL_SIZE% Contains the thumbnail pixel value in the Thumbnails panel. This is useful for JavaScript in


the templates, as it can show the maximum height and width values for all thumbnails for the generated site.


%THUMBNAILSRC% Determines the link to a thumbnail.


%THUMBNAILSROWS% This token is replaced with rows of thumbnails using the Thumbnail.htm file for the


nonframe styles. You must place this token alone in a single, nonbreaking line in the HTML file. 

%THUMBNAIL_WIDTH% Enables the  Add Width  And Height Attributes For  Images  check box. This allows the  user 


to download the attributes, reducing download time.


%THUMBNAIL_WIDTH_NUMBER% This token is replaced by a numeral (only) representing the width of the


thumbnail.


%TITLE% Determines the title of the gallery.


%VLINK% Determines the color of visited links.
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Chapter 21: Rollovers and animations


Rollovers 

About rollovers (ImageReady) 
A rollover is a button or image on a web page that changes when a viewer moves the pointer over it or clicks it. The 

button itself can change or another item on the page, such as a photo or list of menu items, may appear. A remote 

rollover triggers a change in a web page element other than the button or image being rolled over. 

To create a rollover, you define the rollover image as a layer-based slice or a layer-based image map. Then you work 

with the Web Content palette and the Layers palette in ImageReady, doing any of the following to create different 

versions of the graphic: 

• Modify the contents of a layer by adding or changing a layer style or moving layer contents. 

• Replace the contents of an image with a new layer. 

• Replace the contents of a layer elsewhere on the page. 

• Add frames to create a rollover animation. 

Alternatively,  you can  apply one  of  the preset rollover styles from the  Styles  palette to an image  layer.  Rollover  styles  

are a quick and easy way to create rollovers or to reuse a rollover you’ve create with other graphics. See “To copy and 

paste rollover states (ImageReady)” on page 612. 

Rollover states 

Every rollover has two or more states that you create and manage in the Web Content palette. A state is defined by a 

specific configuration of the Layers palette, including layer location, styles, and other formatting options. 

A 

B 

C 

An image with three rollover states 
A. Normal state B. Over state C. Down state 

By default, an image has one state—the Normal state. The Normal state corresponds to the appearance of an image 

when  it  is  first loaded into a web browser  and no rollover effects  have  occurred. You  can add  image states that occur  

when a viewer performs a mouse action—such as rolling over or clicking over an area of the web page. 

Using layers 

When you add a new state to the image, you capture a snapshot of the slice or image map area in the previous state. 

You can then use the Layers palette to make changes to the image in the new state. You can change the layer’s style, 

visibility, and position to create rollover effects. 
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Illustration of a rollover. The button is on its own layer; effects are added to the layer to create a new appearance of the button for the Over 
state. The text for the word “EVENTS” is also on a separate layer. 

Saving the rollover 

When you save an image with rollover states along with an HTML file, ImageReady adds JavaScript code to the 

HTML file to specify rollover states, and each rollover state is saved as a separate image file. 

You can open the HTML file in GoLive for further editing, or import the separate rollover-state files into your GoLive 

page. When you use the separate files that ImageReady saves, GoLive automatically recognizes the related state files. 

See also 

“Editing layers in rollover states and animation frames (ImageReady)” on page 613 

“To create Selected state rollovers (ImageReady)” on page 610 

About the Web Content palette (ImageReady) 
(The Web Content palette lets you create, view, and set options for the rollover states in an image. In addition to 

rollover states, the Web Content palette can display slices, image maps, and animation frames. Displaying slices and 

image maps helps you keep track of the elements in an image that contain rollover effects. Displaying animation 

frames makes it easy to see which states of an image contain animations. 

A 

B 

C D E F 

The Web Content palette 
A. Image Map B. Slice C. Create Layer-Based Rollover button D. Group Slice Into Table button E. New Slice Set button F. Create 
Rollover State button 
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In addition to the slice badge icons, the following icons can appear in the Web Content palette. 

Slice visibility 

Slice has an active rollover state 

Targets slice state for remote rollover 

State has associated remote slice 

State has associated animation 

State has associated animation 

Slice is a nested table 

See also 

“Viewing slices” on page 575 

To use the Web Content palette (ImageReady) 
❖ Do any of the following: 

•	 To display the Web Content palette, choose Window > Web Content. A check mark indicates that the palette is 

visible. 

•	 To  access  commands  for working  with  rollovers,  click the  triangle  in  the upper  right corner of the  palette to display  

the palette menu. 

•	 To display slices and image maps in the Web Content palette, click the triangle next to the Image Maps  and 

Slices sections in the palette. An option in the Palette Options area of the Web Content palette menu toggles 

the display of slice badges, which are small icons on each slice that display the slice’s current properties. 

•	 To display animation frames in the Web Content palette, choose Palette Options from the Web Content palette 

menu. Select or deselect Include Animation Frames, and click OK. 

•	 To  change  the size of rollover thumbnails,  choose  Palette Options  from  the Web  Content palette  menu, and  select  

a thumbnail  size. For  sizes other  than  None, select Object Bounds or Entire  Document to determine  the contents  

of thumbnails. 

•	 To expand and collapse states, slices, and image maps, click the triangle to the left of an item in the Web Content 

palette. Alt-click (Windows) or Option-click (Mac OS) expands or contracts all options. 

Creating a rollover (ImageReady) 
Use the following general workflow to create a set of rollover buttons. You can make rollovers using layer-based slices 

or layer-based image maps. 

1. Create the content for the Normal state. 

If you are creating a rollover button, start by creating the button as you want it to look when the page is first loaded 

in a web browser. Make sure to put each button in a set of rollover buttons in a separate layer so that you can create 

a layer-based slice or image map. 

If you plan to completely replace the contents of the Normal state (as opposed to modifying the layer’s style), create 

contents for other states in other layers. 
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2. If using image maps, make each button a layer-based image map. 

Choose Layer > New Layer Based Image Map Area. You’ll need to add each state, including the first state. See “To 

add a rollover state (ImageReady)” on page 608. 

3. If using slices, make each button a layer-based rollover button. 

Click the  Create  Layer-Based Rollover button on the  Web Content  palette.  ImageReady  creates an image-based  slice  

and adds the Over state to the Web Content palette. See “To create a layer-based slice for a rollover (ImageReady)” 

on page 608. 

4. Add rollover states. 

Create additional rollover states as needed, or change the default Over state automatically created by the layer-based 

rollover button. See “To add a rollover state (ImageReady)” on page 608 and “To change a rollover state 

(ImageReady)” on page 608. 

5. Edit the layer content for the state to create the rollover effect. 

Select the state you want to work with in the Web Content palette. You can apply and change layer styles for each 

state, change the position of content in each layer, or change the visibility of a layer. If you are replacing the contents 

of one layer with another, make the first layer invisible and the second visible for that state. 

For more information on changes you can make to each state, see “Editing layers in rollover states and animation 

frames (ImageReady)” on page 613. 

You can use layer styles to create instant rollover effects. When working with layer-based slices, you can also save the 

series of states as a rollover style. (See “To apply a rollover style to a layer (ImageReady)” on page 609.) 

6. If you are creating a remote rollover, target the remote slice to the selected state. 

Use the  Pickwhip  icon  in  the Web  Content palette  to  point to the  slice that contains the  image for  the remote rollover.  

See “To create a remote rollover (ImageReady)” on page 609. 

7. Optimize the image. 

Choose a file format for the image and set optimization options in the optimization palette. See “To optimize an 

image for the web” on page 628. 

8. Preview the rollover. 

Preview the  rollover  in  ImageReady  as  you create it.  Then  preview it in various  web browsers used by your audience.  

See “To preview rollovers (ImageReady)” on page 611. 

9. Save the rollover. 

Save  a web  version of your rollover using  the File  >  Save  Optimized command. Make sure that the  output settings are  

set to save an HTML page along with the image files. ImageReady will write the JavaScript code for the rollover in 

the HTML page. 

See also 

“Editing layers in rollover states and animation frames (ImageReady)” on page 613 
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To create a layer-based slice for a rollover (ImageReady)

1 Select the layer in the Layers palette, or choose Layer > New Layer-Based Slice from the main menu. The content


of the layer will define the active area for the rollover.


2 Click the Create Layer-Based Rollover button
  in the Web Content palette. 

By default, ImageReady adds an Over state to the new slice. 

To add a rollover state (ImageReady)

1 In the Web Content palette or the image, select a slice or image map.


2 In the Web Content palette, click the Create Rollover State button


3 Use the default rollover state assigned by ImageReady, or select a different rollover state.


. 

See also 

“To change a rollover state (ImageReady)” on page 608 

“Rollover state options (ImageReady)” on page 608 

To change a rollover state (ImageReady) 
1 Do one of the following: 

• Double-click a rollover state in the Web Content palette. 

• Select a rollover state in the Web Content palette, and choose Rollover State Options from the palette menu. 

2 Select a state, and click OK. See “Rollover state options (ImageReady)” on page 608. 

Rollover state options (ImageReady) 
Choose from the following options when setting a rollover state. 

Over Activates the image when the viewer moves the pointer over (“rolls over”) the slice or image map area while 

the mouse button is not pressed. (Over is automatically selected for the second rollover state.) 

Down Activates the image when the viewer presses the mouse button while rolling over the slice or image map area. 

The state persists as long as the viewer keeps the mouse button pressed and the pointer is over the area. 

Click Activates the image when the viewer clicks the mouse while the pointer is over the slice or image map area. 

The state persists until the viewer moves the pointer out of the rollover area. 

Note: Different web browsers, or different versions of a browser, may process clicks and double-clicks differently. For 

example, some browsers leave the slice in the Click state after a click, and in the Up state after a double-click; other 

browsers use the Up state only as a transition into the Click state, regardless of single- or double-clicking. To ensure that 

your web page will function correctly, preview rollovers in various web browsers. 

Custom Activates the image of the specified name when the viewer performs the action defined in the corre

sponding JavaScript code. (You must create JavaScript code and add it to the HTML file for the web page for the 

Custom rollover option to function. See a JavaScript manual for more information.) 

Selected Activates the rollover state when the viewer clicks the slice or image map area. The Selected state persists 

until the viewer activates another Selected rollover state. Other rollover effects can occur while the Selected state is 

in effect. For example, a Selected state for one button and an Over state for another button can be in effect 
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neously. However, if both states use a layer, the layer attributes of the Selected state override those of the Over state. 

See “To create Selected state rollovers (ImageReady)” on page 610. 

Use As Default Selected State Activates the Selected state initially when the document is previewed in ImageReady 

or loaded into a web browser. 

Out Activates the rollover state when the viewer moves the pointer outside the slice or image map area. (The Normal 

state usually serves this purpose.) 

Up Activates the rollover state when the viewer releases the mouse button over the slice or image map area. (The 

Normal state usually serves this purpose.) 

None Preserves the  current state  of  the image  for later  use,  but does not  output  an  image when the  file  is  saved as a  

web page. 

To apply a rollover style to a layer (ImageReady) 
Rollover styles simplify rollover creation by allowing you to turn a layer into a rollover effect with a single click. A


rollover style includes all the attributes of a rollover, including its states and layer effects. When you apply a rollover


style to a layer, the layer becomes a layer-based slice. Rollover styles are indicated in the Styles palette by a triangle


in the upper left corner of the style thumbnail.


1 Select a layer in the Layers palette.


2 Choose Window > Styles, or click the Styles palette tab, to display the Styles palette.


3 Click the  thumbnail for  the rollover style  you want to apply. Rollover style  thumbnails  have  a triangle in the  upper 


left corner.


To create a rollover style (ImageReady) 
You can save rollover states and their effects as a rollover style with which you can create rollovers with similar 

characteristics. 

Note: You must use a layer-based slice to create a rollover style. 

1 In the Web Content palette, create the desired rollover states.


2 Apply the effects to each state by using predefined styles in the Styles palette or by manually setting layer effects


in the Layers palette.


3 In the Styles palette, click the Create New Style button
 , or choose New Style from the palette menu. 

4 Enter a name for the style, set style options, and click OK. The Include Rollover States option must be selected in


order to create a rollover style.


The new rollover style appears in the Styles palette. The thumbnail preview displays the effects in the Normal state.


To create a remote rollover (ImageReady) 
You can set up a rollover to show or hide the content of a slice on another part of your web page. ImageReady gives 

you control over which slices change on a rollover state, eliminating unwanted images and complexity. 
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Note: In Photoshop 7.0 and earlier versions, all changes made to a document would appear when in a rollover state. This 

sometimes caused users to create state changes they didn’t intend. In ImageReady CS, you have much more control over 

which slices change on a rollover state. 

1 Set up a rollover as you normally do. This becomes the button the user will click to display the remote content. See


“Creating a rollover (ImageReady)” on page 606.


2 Add the remote content to the document and create one or more slices to contain it.


3 For each rollover state, set the desired visibility of the remote content layers in the Layers palette.


4 Specify which remote slices you want to include when you optimize output files in one of these ways:


•	 To manually mark the remote slices for an individual button, go to the Slice column of the Web Content palette 

and select the  rollover  state that will trigger  the remote rollover (for example, Down or Click).  Drag  the Pickwhip  

icon  from the rollover state to the remote content slice in the document window. 

•	 To let ImageReady automatically find and mark all remote slices in the document, go to the Web Content palette 

menu and choose Find All Remote Slices. 

•	 To let ImageReady automatically find and mark remote slices for a selected state, go to the Web Content palette 

menu and choose Find Remote Slices For State. 

5	 Preview the remote rollover in a browser. See “To preview rollovers (ImageReady)” on page 611. 

To create Selected state rollovers (ImageReady) 
You can create a rollover button that stays selected until the viewer clicks another rollover button. A Selected state 

rollover is useful for creating navigation a bar that indicates which page the user is viewing. 

Web page navigation bar that indicates which page is displayed 

1 Create multiple rollovers with a Normal state. Give the buttons the appearance they should have when not 

selected. 

2 Add a new state to each button. Choose the Selected state option and edit the button to give it its clicked, or 

selected, appearance. 

3 If you want one of the buttons to look selected when the page first loads, double-click the Selected state of that 

button in the Web Content palette, and choose Use As Default Selected State. 

4 To generate a unique HTML page for each Selected state, choose File > Output Settings > Saving HTML, and then 

select Output Multiple HTML Files. ImageReady will create a separate page for each button in its Selected state. You 

then add the appropriate content for each page. 

 



611 ADOBE PHOTOSHOP CS2 
User Guide 

See also 

“Rollover state options (ImageReady)” on page 608 

To add animation to a rollover state (ImageReady) 
You can add multiple-frame animation to a rollover state. Adding animation to the Normal state causes the 

animation to play when the  image is loaded in a web browser. Adding animation  to  another type of state  causes  the  

animation to play when a user activates the state. 

1 In the Web Content palette, select the state in which you want to display an animation. 

2 Make sure that you can see the Create Animation Frame button and the New Animation Frame command. If they 

aren’t visible, choose Palette Options from the Web Content palette menu, and then select Include Animation 

Frames. 

3 Do one of the following to add frames to the animation: 

• Click the Create Animation Frame button in the Web Content palette or choose New Animation Frame from 

the palette menu. 

• Create frames in the Animation palette. 

See also 

“Creating an animation” on page 614 

To preview rollovers (ImageReady) 
You can preview rollover effects directly in the ImageReady document window by switching to document preview 

mode. All remote rollovers affect a previewed document. If a slice has a change that is ignored (not targeted), you 

can see it in an ImageReady preview, but not in a browser. 

To preview the rollover effect in your computer’s default web browser, click the Preview In Default Browser button in 

the toolbox. 

1 To view rollovers in document preview mode, do one of the following: 

• Click the Preview Document button  in the toolbox. 

• Choose Image > Preview Document. 

2 In the document window, perform the action that activates the rollover state. For example, position the mouse 

over the rollover slice or image map area to preview the Over state. Then click the slice or image map area to preview 

the Click state. 

Note: If a document contains a Selected state, synthetic states are generated for the other states in the Web Content 

palette. The synthetic state represents the appearance of the document when the Selected state is active. Synthetic states 

are generated automatically and cannot be edited. 

3 To exit rollover preview mode, do one of the following: 

• Select any tool in the toolbox. 

• Click the Cancel Preview button  in the options bar, or press Esc (Windows). 

• Deselect Preview Document in the Image menu. 

• Click the Preview Document button again to leave preview mode. 
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To copy and paste rollover states (ImageReady) 
You can copy a rollover state and paste it into another state in the current rollover or into a state in another rollover. 

Layers in the source state replace layers in the destination state. 

You can also copy frames from the Animation palette and paste them into the Web Content palette as states, or copy 

states from the Web Content palette and paste them into the Animation palette as frames. 

Note: Copy  commands  in  the Animation  palette and  the Web  Content palette  use an internal clipboard  available to these  

commands only. Copying frames or rollover states does not overwrite the primary ImageReady clipboard. 

1 Select a rollover state, and choose Copy Rollover State from the Web Content palette menu. 

2 Select a rollover state in which to paste the copied state: 

• Select a state in the current rollover.


• Open or display another rollover, and select a state.


3 Choose Paste Rollover State from the Web Content palette menu.


To duplicate a rollover state (ImageReady) 
Duplicating a state is an easy way to add existing animation frames to a new state. 

❖ Select a rollover state, and do one of the following: 

• Choose Duplicate Rollover State from the Web Content palette menu. 

• Drag the state to the Create Rollover State button 

The duplicate state and frames appear below the original state in the Web Content palette. 

. 

To move a state to another rollover (ImageReady) 
❖ Drag the state up or down in the Web Content palette. When the highlighted line appears in the desired position, 

release the mouse button. 

To delete rollover states (ImageReady) 
❖ Do one of the following: 

• To  delete  one state,  select  a rollover state,  and either click  the Delete icon  on the  Web Content  palette or choose  

Delete Rollover State from the Web Content palette menu. 

• To delete all states in a rollover, choose Delete Rollover from the Web Content palette menu. 
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Editing layers in rollover states and animation frames (ImageReady) 
Some changes you make to layers affect only the active rollover state or animation frame, while others affect every 

state and frame in which the layers are included. 

State- and frame-specific changes Affect  only  the active animation  frame or rollover state.  By  default,  changes you  

make to layers using Layers palette commands and options—including layer opacity, blending mode, visibility, 

position, and style—are state- and frame-specific. However, you can apply layer changes to all states in a rollover and 

all frames in an animation using the unify buttons in the Layers palette. (See “To unify layers for rollovers and anima

tions (ImageReady)” on page 613.) 

Note: Changes you make to layers in the Normal state or Frame 1—including layer opacity, blending mode, visibility, 

position, and style—affect all states or frames in which the layers are identical. For example, consider a slice that has a 

Normal state, an Over state, and a Down state. If the layers in the Normal and Over states are identical, and you apply 

a layer style in the Normal state, the layer style will also be applied in the Over state. 

Inclusive changes Affect every state and frame in which the layers are included. Changes you make to layer pixel 

values, using painting and editing tools, color and tone adjustment commands, filters, type, and other image-editing 

commands, are examples of inclusive changes. 

To unify layers for rollovers and animations (ImageReady) 
Changes you make to a layer’s visibility, position, and style apply only to the frame or state (unless you are working


with the Normal state or Frame 1). However, you can use the unify buttons in the Layers palette to apply changes to


all states in a rollover and all frames in an animation.


When  a unify  button  is  selected, changes apply  to  all states and  frames; when a button  is  deselected, changes  apply to 


only the active state or frame.


1 Select the layer you want to unify across frames or rollover states.


2 Select the frame or state you want to match


3 Select  one or more unify  buttons in the  Layers  palette.  If  the Unify  buttons are  not visible  in  the Photoshop  layers 


palette, choose Animation Options, and then an option from the Layers palette menu.


Unify Layer Position Applies changes you make to a layer’s position to all states in a rollover and all frames in an


animation.


Note: The Unify  Layer Position button places the  contents  of  the selected layer  in  the same place  on  every frame  in  your  

animation. If you’re trying to show the layer contents moving in the animation, do not use this button. 

Unify Layer Visibility button Applies changes you make to a layer’s visibility to all states in a rollover and all frames 

in an animation. 

Unify Layer Style button Applies changes you make to a layer’s style to all states in a rollover and all frames in an 

animation. 

To match an existing layer across rollover states and animation frames (ImageReady) 
The Match command applies the layer attributes of an existing state or frame to other states in a rollover and frames


in an animation.


1 In the Web Content palette, select the state or frame with the layer attributes you want to use.


2 Select the layer you want to match in the Layers palette.


3 Choose Layer > Match, or choose Match from the Layers palette menu.


 



614 ADOBE PHOTOSHOP CS2 
User Guide 

4 Select one of the following from the Match Layer dialog:


Current Animation Applies layer attributes for the selected frame to all frames in the animation.


Current Slice/Image Map’s States Applies layer attributes for the selected state to all states in the rollover. 

All Rollovers Applies layer attributes for the selected state to all states in all rollovers (in the image) that include the 

layer. 

5 Select the layer attributes you want to match (position, visibility, and style), and click OK. 

Note: The default setting, Propagate Frame 1 Changes, dynamically updates all rollover states and animation frames, 

based on a change in the first frame’s position, visibility, or layer style. If you want the changes in Frame 1 to remain only 

in Frame 1, turn off this option by toggling it in the Layers palette pop-up menu. 

Animations 

Creating an animation 
An animation is a sequence of images, or frames, that is displayed over time. Each frame varies slightly from the 

preceding frame, creating the illusion of movement when the frames are viewed in quick succession. 

You use the Animation palette and the Layers palette to create animation frames. In ImageReady you can also use 

the Web Content palette to add an animation to a rollover state. Each frame represents a configuration of layers in 

the Layers palette. 

Illustration of an animation. The unicycle image is on its own layer; the position of the layer changes in each frame of the animation. 

1. Add a frame to the animation palette. 

See “To add a frame to an animation” on page 615. 

2. Select a frame and edit the layers for that frame. 

You can do any of the following: 

• Turn visibility on and off for different layers 

• Change the position of layers to make layer content move 

• Change layer opacity to make content fade in or out 
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•	 Change the blending mode of layers 

•	 Add a style to layers 

For some types of animation, such as changing the color of an object, or completely changing the content in a frame, 

you need additional layers with the new content. For more information about the types of layer edits and how they 

affect animations, see “Editing layers in rollover states and animation frames (ImageReady)” on page 613. 

Photoshop and ImageReady also provide tools for keeping characteristics of a layer the same across frames. See “To 

unify layers for rollovers and animations (ImageReady)” on page 613. 

3. Edit layers for additional frames as needed. 

The number of frames you can create is limited only by the amount of system memory available to Photoshop or 

ImageReady. 

You can generate new frames with intermediate changes between two existing frames in the palette using the Tween 

command. This is a quick way to make an object move across the screen or to fade out an object. See “Tweening 

frames” on page 618. 

4. Set frame delay and looping options. 

You can assign a delay time to each frame and specify looping so that the animation runs continuously. 

5. Preview the animation. 

Use the controls in the animation palette to play the animation as you create it. Then preview the animation in your 

web browser. In Photoshop, use Save For Web to preview in a web browser. See “To preview an animation” on 

page 621. 

6. Optimize the animation for efficient download. 

See “Optimizing animations” on page 622. 

7. Save the animation. 

You can save the animation as an animated GIF. In Photoshop, use Save For Web. In ImageReady you can also save 

it in the SWF format. See “Saving files in SWF format (ImageReady)” on page 671. You can also save the animation 

in Photoshop format so you can rework the animation later. 

To use the Animation palette 
❖ Do any of the following: 

•	 To display the Animation palette, choose Window > Animation. A check mark indicates that the palette is visible. 

•	 To use the Animation palette menu, click the triangle in the upper right corner of the palette to access commands 

for working with animations. 

•	 To change the size of animation thumbnails, choose Palette Options from the Animation palette menu, select a 

thumbnail size, and click OK. 

To add a frame to an animation 
Adding frames is the first step in creating an animation. If you have an image open, the Animation palette displays 

the image as the first frame in a new animation. Each frame you add starts as a duplicate of the preceding frame. You 

then make changes to the frame using the Layers palette. 
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Note: In ImageReady, always create and edit frames in Original view. While you can view frames in an optimized view, 

the editing options are very limited. 

❖ Click the Duplicates Current Frame button  in the Animation palette. 

See also 

“To add animation to a rollover state (ImageReady)” on page 611 

To select a frame 
Before  you can  work  with  a frame, you  must  select  it  as  the current  frame.  The contents of the  current frame  appear  

in the document window. 

In the Animation palette, the current frame is indicated by a narrow border (inside the shaded selection highlight) 

around the frame thumbnail. Selected frames are indicated by a shaded highlight around the frame thumbnails. 

❖ Do one of the following: 

•	 Click a frame in the Animation palette. 

•	 (ImageReady) Click a frame in the Web Content palette. If necessary, expand the state that contains the animation 

to view its frames. 

•	 In the Animation palette or the Layers palette, click the Selects Next Frame button to select the next frame in 

the series as the current frame. 

•	 In the Animation palette or the Layers palette, click the Selects Previous Frame button to select the previous 

frame in the series as the current frame. 

•	 In the Animation palette, click the Selects First Frame button  to select the first frame in the series as the 

current frame. 

To select multiple frames 
❖ In the Animation palette, do one of the following: 

•	 To select contiguous multiple frames, Shift-click a second frame. The second frame and all frames between the 

first and second are added to the selection. 

•	 To select discontiguous multiple frames, Ctrl-click (Windows) or Command-click (Mac OS) additional frames to 

add those frames to the selection. 

•	 To select all frames, choose Select All Frames from the Animation palette menu. 

•	 To deselect a frame in a multiframe selection, Ctrl-click (Windows) or Command-click (Mac OS) that frame. 

To edit the image content of a frame

1 Select a frame.


2 Use the Layers palette to modify the image.


See also 

“To select a frame” on page 616 

“Editing layers in rollover states and animation frames (ImageReady)” on page 613 
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To change the position of a frame

1 Select the frame you want to move in the Animation palette or the Web Content palette (ImageReady).


2 Drag the selection to the new position.


Note: In the Animation palette, you can select and change the position of multiple frames. However, if you drag multiple 

discontiguous frames, the frames are placed contiguously in the new position. 

See also 

“To add animation to a rollover state (ImageReady)” on page 611


To reverse the order of frames

1 Select the frames you want to reverse. They do not have to be contiguous; you can reverse any selected frames.


2 Choose Reverse Frames from the Animation palette menu.


See also 

“To select multiple frames” on page 616 

To delete selected frames 
❖ Do one of the following in the Animation palette or the Web Content palette: 

• Select Delete Frame from the palette menu. 

• Click the Delete icon , and click Yes to confirm the deletion. 

• Drag the selected frame onto the Delete icon. 

See also 

“To select multiple frames” on page 616 

To delete an entire animation 
❖ Select Delete Animation from the Animation palette menu or the Web Content palette menu (ImageReady). 

To copy and paste layers between frames 
To understand what happens when you copy and paste a frame, think of a frame as a duplicate version of an image 

with a given layer configuration. When you copy a frame, you copy the configuration of layers (including each layer’s 

visibility setting, position, and other attributes). When you paste a frame, you apply that layer configuration to the 

destination frame. 

1 Select the frame you want to copy in the Animation palette or the Web Content palette (ImageReady). 

Note: In the Animation palette, you can select and copy multiple frames. 

2 Choose Copy Frame(s) from the Animation palette menu or the Web Content palette menu. 

3 Select a destination frame or frames in the current animation or another animation. 

4 Choose Paste Frame(s) from the Animation palette menu or the Web Content palette menu. 
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5	 Select a Paste method: 

Replace Frames Replaces the selected frames with the copied frames. When you paste frames into the same image, 

no new layers are added to the image; the attributes of each existing layer in the destination frames are replaced by 

those of each copied layer. When you  paste frames between  images, new  layers  are added to the  image;  however,  only  

the pasted layers are visible in the destination frames (the existing layers are hidden). 

Paste Over Selection Adds the contents of the pasted frames as new layers in the image. When you paste frames 

into the same image, using this option doubles the number of layers in the image. In the destination frames, the newly 

pasted layers are visible, and the original layers are hidden. In the nondestination frames, the newly pasted layers are 

hidden. 

Paste Before Selection or Paste After Selection Adds the copied frames before or after the destination frame. 

When you paste frames between images, new layers are added to the image; however, only the pasted layers are visible 

in the new frames (the existing layers are hidden). 

6 Select  Link  Added Layers if you  want  to  link pasted layers in the  Layers  palette.  Use this option when you  need  to  

reposition the pasted layers as a unit. 

7	 Click OK. 

Tweening frames 
You use the Tween command to automatically add or modify a series of frames between two existing frames— 

varying the layer attributes (position, opacity, or effect parameters) evenly between the new frames to create the 

appearance of movement. For example, if you want to fade out a layer, set the opacity of the layer in the starting frame 

to 100%; then set the opacity of the same layer in the ending frame to 0%. When you tween between the two frames, 

the opacity of the layer is reduced evenly across the new frames. 

The term tweening is derived from “in betweening,” the traditional animation term used to describe this process. 

Tweening significantly reduces the time required to create animation effects such as fading in or fading out, or 

moving an element across a frame. You can edit tweened frames individually after you create them. 

Using tweening to animate text position 

To create frames using tweening

1 To apply tweening to a specific layer, select it in the Layers palette.


2 Select a single frame or multiple contiguous frames.


•	 If you select a single frame, you choose whether to tween the frame with the previous frame or the next frame. 

•	 If you select two contiguous frames, new frames are added between the frames. 

•	 If you select more than two frames, existing frames between the first and last selected frames are altered by the 

tweening operation. 

•	 If you select the first and last frames in an animation, these frames are treated as contiguous, and tweened frames 

are  added  after the  last  frame.  (This tweening method is useful when the  animation is set  to  loop  multiple  times.)  
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3 Do one of the following: 

• Click the Tween button  in the Animation palette. 

• Select Tween from the Animation palette menu.


4 Specify the layer or layers to be varied in the added frames:


All Layers Varies all layers in the selected frame or frames.


Selected Layer Varies only the currently selected layer in the selected frame or frames.


5 Specify layer attributes to be varied:


Position Varies the position of the layer’s content in the new frames evenly between the beginning and ending


frames.


Opacity Varies the opacity of the new frames evenly between the beginning and ending frames.


Effects Varies the parameter settings of layer effects evenly between the beginning and ending frames.


6 If you selected a single frame in step 2, choose where to add frames from the Tween With menu:


Next Frame Adds frames between the selected frame and the following frame. This option is not available when you


select the last frame in the Animation palette. 

First Frame Adds frames between the last frame and first frame. This option is available only if you select the last


frame in the Animation palette.


Previous Frame Adds  frames  between the  selected  frame and  the preceding frame. This option is not  available when 


you select the first frame in the Animation palette. 

Last Frame Adds frames between the first frame and last frame. This option is available only if you select the first


frame in the Animation palette.


7 Enter a value, or use the Up or Down Arrow key to choose the number of frames to add. (This option is not


available if you selected more than two frames.) 

8 Click OK. 

To specify looping 
You select a looping option to specify how many times the animation sequence repeats when played.


1 Click the looping option selection box at the lower left corner of the Animation palette.


2 Select a looping option: Once, Forever, or Other.


3 If you selected Other, enter a value in the Set Loop Count dialog box, and click OK.
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To specify a delay time 
You can specify a delay—the time that a frame is displayed—for single frames or for multiple frames in an animation. 

Delay time is displayed in seconds. Fractions of a second are displayed as decimal values. For example, one-quarter 

of a second is specified as .25. If you set a delay on the current frame, every frame you create after that will remember 

and apply that delay value. 

1 Select one or more frames.


2 In the Animation palette, click the Delay value below the selected frame to view the Delay pop-up menu.


3 Specify the delay:


•	 Choose a value from the pop-up menu. (The last value used appears at the bottom of the menu.) 

•	 Choose Other, enter a value in the Set Frame Delay dialog box, and click OK. If you selected multiple frames, 

specifying a delay value for one frame applies the value to all frames. 

To add a new layer every time you create a frame 
When you create a new layer, it is visible in all frames of an animation. To hide a layer in a specific frame, select the 

frame in the Animation palette, and then hide the desired layer in the Layers palette. 

You can  use the  Create  Layer For  Each  New Frame  option  to  automatically add  a new  layer to the  image every  time  

you create a frame. The new layer is visible in the new frame but hidden in other frames. Using this option saves time 

when you are creating an animation that requires you to add a new visual element to each frame. 

❖ Choose Create Layer For Each New Frame from the Animation palette menu. A check mark indicates that the 

option is turned on. 

Setting the frame disposal method 
The frame disposal method specifies whether to discard the current frame before displaying the next frame. You 

select a disposal method when working with animations that include background transparency in order to specify 

whether the current frame will be visible through the transparent areas of the next frame. 

A 

B 

Frame disposal methods 
A. Frame with background transparency with Restore To Background option B. Frame with background transparency with Do Not Dispose 
option 

The Disposal Method icon indicates whether the frame is set to Do Not Dispose or Restore To Background . 

(No icon appears when Disposal Method is set to Automatic.) 
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To choose a disposal method 
1 Select a frame or frames for which you want to choose a disposal method. 

2 Right-click (Windows) or Control-click (Mac OS) the frame thumbnail to view the Disposal Method context 

menu. 

3 Choose a disposal method: 

Automatic Determines a disposal method for the current frame automatically, discarding the current frame if the 

next  frame contains layer  transparency. For  most  animations, the  Automatic option yields the  desired results  and is  

therefore the default option. 

Note: Choose the Automatic disposal option when using the Redundant Pixel Removal optimization option, to enable 

ImageReady to preserve frames that include transparency. 

Do Not Dispose Preserves the current frame as the next frame is added to the display. The current frame (and 

preceding frames) may show through transparent areas of the next frame. Use a browser to see an accurate preview 

of an animation using the Do Not Dispose option. 

Dispose (Photoshop) or Restore to Background (ImageReady) Discards the current frame from the display 

before the next frame is displayed. Only a single frame is displayed at any time (and the current frame does not 

appear through the transparent areas of the next frame). 

To flatten frames into layers 
You can flatten animation frames into layers. A single, composite layer is created for each frame, containing all of the 

layers in the frame. The original layers in the frame are hidden but preserved (in case they are needed for another 

frame). 

Note: If you save an animation as a GIF, the animation frames are flattened and the original layers are lost. You should 

save the original file in Photoshop file format to preserve layers for reediting. 

❖ In the Animation palette, choose Flatten Frames Into Layers from the palette menu. 

To preview an animation 
1 Click the Play button  in the Animation palette. The animation is displayed in the document window. The 

animation repeats indefinitely unless you specified another repeat value in the Play Options dialog box. 

2 To stop the animation, click the Stop button 

3 To rewind the animation, click the Selects First Frame button 

. 

. 

Note: To see a more accurate preview of the animation and timing, preview the animation in a web browser. Use the 

browser’s Stop and Reload commands to stop or replay the animation. In Photoshop, open the Save For Web dialog box 

and click the Preview In Browser button. 

See also 

“Previewing an image in a browser” on page 596 
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Optimizing animations 
After you complete your animation, you should optimize it for efficient download to a web browser. You optimize an 

animation in two ways: 

•	 Optimize  the frames to include  only  areas that change  from  frame to frame. This greatly  reduces the  file  size  of  the  

animated GIF. See “To optimize an image for the web” on page 628 and “Optimization options for GIF and PNG

8 formats” on page 635. 

•	 If you are saving your animation as a GIF image, optimize it as you would any GIF image. A special dithering 

technique is applied to animations to ensure that dither patterns are consistent across all frames and to prevent 

flickering during playback. Because of these additional optimization functions, more time may be required to 

optimize an animated GIF than to optimize a standard GIF. 

When optimizing the colors in an animation, use the Adaptive, Perceptual, or Selective palette. This ensures that the 

colors are consistent across frames. (See “Optimization options for GIF and PNG-8 formats” on page 635.) 

To optimize animation frames 
1 Choose Optimize Animation from the Animation palette menu. 

2 Set the following options: 

Bounding Box Crops each frame to the area that has changed from the preceding frame. Animation files created 

using this option are smaller but are incompatible with GIF editors that do not support the option. (This option is 

selected by default and is recommended.) 

Redundant Pixel Removal Makes transparent all pixels in a frame that are unchanged from the preceding frame. 

This option is selected by default and is recommended. The Transparency option in the Optimize palette must be 

selected for redundant pixel removal to work. (See “Optimization options for GIF and PNG-8 formats” on page 635.) 

Important: Set the frame disposal method to Automatic when using the Redundant Pixel Removal option. (See “Setting 

the frame disposal method” on page 620.) 

3	 Click OK. 

Saving and exporting animations 
You can save animations in several formats. 

GIF A standard format for saving animated images for viewing on the web. In Photoshop you use the Save For Web 

dialog box. In ImageReady you use the Optimize palette to set GIF options. See “Optimization options for GIF and 

PNG-8 formats” on page 635. 

QuickTime movie (ImageReady) (See “To save files in QuickTime Movie format (ImageReady)” on page 671.) 

SWF (Macromedia® Flash™) file (ImageReady) (See “Saving files in SWF format (ImageReady)” on page 671.) 

In ImageReady, you can also save each frame in an animation as a separate file. See “Exporting animation frames as 

files” on page 676. 
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Opening and importing files as animations 

To open animated GIFs (ImageReady) 
You can open an existing animated GIF in ImageReady. After you open the file, you can switch to Photoshop to edit 

the file. 

❖ Choose File > Open. 

The file opens as a stack of layers. Each layer corresponds to one frame. In each frame, the layer for that frame is 

visible, and the layers for the other frames are hidden. 

Opening existing animated GIF files is useful primarily for applying optimization settings to the files. The one-layer-

per-frame structure of imported animated GIF files may make it impractical to edit animation frames in other ways. 

To open a multilayer Photoshop file as frames 
You can easily create animated GIFs from existing multilayer Photoshop files. The content of each layer becomes a


frame in the Animation palette. The layers are placed in the Animation palette in their stacking order, with the


bottom layer becoming the first frame.


1 Choose File > Open, and select the Photoshop file to open.


2 Choose Make Frames From Layers from the Animation palette menu.


Each layer in the image appears as a frame in the Animation palette. The bottom layer in the Photoshop image is


Frame 1 in the Animation palette.


Choose Reverse Frames from the Animation palette menu to reverse the order of frames. 

To import a folder of files as frames (ImageReady) 
You can import a folder of files and use each file as a frame. Files can be in any format that Photoshop supports. Each 

file becomes a frame in the Animation palette. The files are placed in the Animation palette in alphabetical order by 

image file name. 

1 Place the files to be used as frames into a folder. Make sure that the folder contains only those images that are to 

be used as frames. The resulting animation will be more successful if all files have the same pixel dimensions. 

To have frames appear in the correct order in the animation, name the files in alphabetical or numeric order, with 

the file to be used as Frame  1 the  first in order. (You can  also  change  the order  of  the frames in the  Animation palette  

after you import the files.) 

2 Choose File > Import > Folder As Frames, and choose the folder to be imported. 

The files appear in the Animation palette as frames and in the Layers palette as layers, with each layer assigned to a 

separate frame. The image that is first alphabetically or numerically by file name is Frame 1 in the Animation palette 

and the bottom layer in the Layers palette. 
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To open QuickTime-compatible movies 
You can open movies in MOV, AVI, and FLIC formats to view and edit in ImageReady. 

1 Choose File > Open, and select the movie to open. 

2 Select the range of frames to import: 

•	 From Beginning to End to open the full file. 

•	 Selected Range Only to open selected frames. Drag the slider below the movie thumbnail to specify the starting 

point for the range, and then Shift-drag to specify the ending point. (A black bar on the slider indicates the range 

you select.) 

3 Select  Limit To Every  Frame to specify which  frames  to  include from the  selected  range. (You can  use this option  

with either range option.) 

4	 Click Open. 
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Chapter 22: Preparing Graphics for 
the Web 

Optimizing images 

About optimization 
When preparing images for the web and other online media, you often need to compromise between image display 

quality and the file size of the image. Photoshop and ImageReady provide several controls for compressing the file 

size of an image while optimizing its online display quality. 

You can save images for the web in two ways: 

•	 For basic optimization, the Photoshop Save As command lets you save an image as a GIF, JPEG, or PNG-24 file. 

Depending on the file format, you can specify image quality, background transparency or matting, color display, 

and downloading method. However, any web features—such as slices, links, animations, and rollovers—that 

you’ve added to a file are not preserved. See “To save a file in a different file format” on page 654. 

•	 For precise optimization, you can use the optimization features in Photoshop Save For Web or ImageReady to 

preview optimized images in different file formats and with different file attributes. You can view multiple versions 

of an image simultaneously and modify optimization settings as you preview the image to select the best combi

nation of settings for your needs. You can also specify transparency and matting, select options to control 

dithering, and resize the image to specified pixel dimensions or a specified percentage of the original size. 

When you save an optimized file using the Save For Web (Photoshop) or Save Optimized (ImageReady) command, 

you can choose to generate an HTML file for the image. This file contains all the necessary information to display 

your image in a web browser. 

Using the Save For Web dialog box 
In Photoshop, you use the Save For Web dialog box to select optimization options and preview optimized artwork. 

To open the Save For Web dialog box. choose, File > Save For Web. 
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Save For Web dialog box 
A. Toolbox B. Preview pop-up menu C. Optimize pop-up menu D. Color Table pop-up menu E. Zoom text box F. Original 
image G. Optimized image H. Preview In Browser menu 

Previewing images in the dialog box 

Click a tab at the top of the image area to select a display option: Original to view the image with no optimization, 

Optimized to view the image with the current optimization settings applied, 2-Up to view two versions of the image 

side by side, or 4-Up to view four versions of the image side by side. 

You can try different optimization settings and compare them side by side. If you work in 2-Up or 4-Up view, you 

must select a version before you apply optimization settings. A colored frame indicates which version is selected. 

To quickly transition to ImageReady, click the Edit In ImageReady button at the lower right of the dialog box. 

Navigating in the dialog box 

If the entire artwork is not visible in the Save For Web dialog box, you can use the Hand tool to bring another area 

into view. Select the Hand tool  (or hold down the spacebar), and drag in the view area to pan over the image. 

You can also use the Zoom tool to magnify or reduce the view. Select the Zoom tool , and click in a view to zoom 

in; hold down Alt (Windows) or Option (Mac OS), and click in a view to zoom out. You can also type a magnification 

percentage or choose one at the bottom of the dialog box. 
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Viewing optimized image information 

The annotation area below each image in the Save For Web dialog box provides optimization information. The 

annotation for the original image shows the file name and file size. The annotation for the optimized image shows 

the current optimization options, the size of the optimized file, and the estimated download time using the selected 

modem speed. You can choose a modem speed in the Preview pop-up menu. 

Previewing browser dither 

If an image contains more colors than the monitor can display, the browser will dither, or approximate, the colors 

that it cannot display by blending colors that it can. 

To show or hide the preview of browser dither, choose Browser Dither from the Preview pop-up menu. A check mark 

indicates that browser dithering is active. Activating Browser Dither does not affect final image output. 

To preview image gamma at different values 
The gamma value of a computer monitor affects how light or dark an image looks in a web browser. Because


Windows systems use a gamma of 2.2, images look darker on Windows than on Mac OS systems, which are normally


set to a gamma of 1.8. You can preview how your images will look on systems with different gamma values and make


gamma adjustments to the image to compensate. Activating a preview option does not affect final image output.


❖ Choose one of the following options by using the Save For Web dialog box Preview pop-up menu (Photoshop) or


by choosing an option from the View > Preview menu (ImageReady).


Uncompensated Color Makes no adjustments to image gamma. Uncompensated Color is the default setting.


Standard Windows Color Displays an adjustment based on the default Windows gamma. 

Standard Macintosh Color Displays an adjustment based on the default Macintosh gamma. 

Use Document Color Profile or Use Embedded Color Profile Adjusts the gamma to match any attached document 

color profile in a color-managed document. 

In ImageReady, you can edit your image in one window and view the same image with a different gamma value in 

a second window. Choose Window > Arrange > New Window For [File Name]. With the new window active, choose 

View > Preview, and then choose a different gamma value than the one used in the first window. 

To adjust the image gamma 
In ImageReady, use this simple adjustment to change the image gamma. In Photoshop, preview the image gamma 

you want to match, and then use the Levels command to make the image lighter or darker. 

1 In ImageReady, choose Image > Adjustment >Gamma, and make sure Preview is selected. 

2 Do one of the following: 

•	 Select Windows To Macintosh to adjust gamma for display in Mac OS. 

•	 Select Macintosh To Windows to adjust gamma for display in Windows. 

•	 Drag the Gamma slider, or enter a value in the text box between 0.1 and 9.99. The Gamma slider measures the 

amount of change from the current gamma value. (The slider does not indicate the actual gamma value.) 

Note: Images created in Photoshop 5.0 or later use the Windows gamma value (2.2) by default and are at the correct 

gamma for display in Windows with no adjustment. 
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See also 

“To preview image gamma at different values” on page 627 

“To adjust tonal range using Levels” on page 285 

To optimize an image for the web

1 Choose File > Save For Web (Photoshop) or open the Optimize palette (ImageReady).


2 Click a tab at the top of the dialog box (document window in ImageReady) to select a display option: Optimized,


2-Up, or 4-Up. If you select 4-Up, click the preview you want to optimize.


3 (Optional) If your image contains multiple slices, select one or more slices you want to optimize. See “To select


one or more slices” on page 577.


4 Select a preset optimization setting from the Preset menu, or set individual optimization options. The available


options change depending on the file format you select. See one of the following lists of settings:


•	 “Optimization options for GIF and PNG-8 formats” on page 635 

•	 “Optimization options for JPEG format” on page 633 

•	 “Optimization options for PNG-24 format” on page 634 

•	 “Optimization options for WBMP format” on page 634 

If you’re working in 4-Up mode, choose Repopulate Views from the Optimize menu to automatically generate lower

quality versions of the image after you change the optimization settings. 

5 Fine-tune the optimization settings until you are satisfied with the balance of image quality and file size. If your 

image contains multiple slices, be sure to optimize all the slices. 

6	 Do one of the following: 

•	 (Photoshop) Click Save in the Save For Web dialog box. 

•	 (ImageReady) Choose File > Save Optimized. Choose File > Save Optimized As to save an alternate version of the 

file with a different file name. 

7	 In the Save Optimized As dialog box, do the following, and then click Save: 

•	 Enter a file name, and select a location for the resulting file or files. 

•	 Select a Format option to specify what kind of files you want to save: HTML file and image files, only image files, 

or only an HTML file. 

•	 (Optional) Set output settings for HTML and image files. (See “To set output options” on page 647.) 

•	 If your image contains multiple slices, select an option for saving slices from the Slices menu: All Slices or Selected 

Slices. In ImageReady, you can also choose a saved slice selection from the list if you’ve saved a slice selection. 

(Photoshop) To reset optimization settings to the last saved version, press Alt (Windows) or Option (Mac OS), and 

click Reset. To keep the same settings the next time you open the Save For Web dialog box, press Alt/Option and click 

Remember. 

See also 

“Making sure that your colors match” on page 599 

“To create a droplet for automating Optimize palette settings (ImageReady)” on page 746 

“Previewing an image in a browser” on page 596 
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To save a file to e-mail

1 Open the image in Photoshop, and choose File > Save For Web.


2 Click the Optimize tab at the top of the Save For Web dialog box.


3 Choose JPEG Low from the Preset menu.


4 Click the Image Size tab.


5 Make sure that Constrain Proportions is selected and enter a width. For e-mail, 400 pixels is a good size. Use a


smaller size if your recipient has a slow Internet connection.


6 Click Save. Enter a file name and location in which to save the file. Under Format, make sure that Images Only is


selected. Click Save.


Now you are ready to e-mail the file. In some e-mail programs, you can drag the file into the body of the message. In


other programs, you use the Attach or Insert command.


See also 

“To optimize an image for the web” on page 628


To restore an optimized preview to the original version

1 Select an optimized version of the image in 2-Up or 4-Up mode.


2 In the Optimize panel/palette, choose Original from the Settings pop-up menu.


To save or delete optimization presets 
You can save optimization settings as a named set and apply the settings to other images. Settings that you save appear


in the Preset pop-up menu, together with the predefined named settings. If you edit a named set or a predefined set,


the Preset menu displays the term “Unnamed.”


1 Set optimization options as desired, and choose Save Settings from the Optimize palette menu.


2 Name the settings, and save them in the Presets/Optimized Settings folder inside the Photoshop program folder.


Note: If you save the settings in a location other than the Presets/Optimized Settings folder, they will not be available 

from the Preset pop-up menu. 

3	 To delete a preset, select the preset from Settings menu, and select Delete Settings from the Optimize menu. 

See also 

“To create a droplet for automating Optimize palette settings (ImageReady)” on page 746 

To work with slices in the Save For Web dialog box 
(Photoshop) 

If your image contains multiple slices, you must specify the slices to be optimized. You can apply optimization 

settings to additional slices by linking the slices. Linked slices in GIF and PNG-8 format share a color palette and 

dither pattern to prevent the appearance of seams between the slices. 

•	 To show or hide all slices in the Save For Web dialog box, click the Toggle Slices Visibility button . 

•	 To show or hide auto slices in the Save For Web dialog box, choose Hide Auto Slices from the Preview pop-up 

menu. A check mark indicates that slices are hidden. 
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• To select slices in the Save For Web dialog box, choose the Slice Select tool , and then click a slice to select it. 

Shift-click or Shift-drag to select multiple slices. 

Note: In the Save For Web dialog box, unselected slices are dimmed. This does not affect the color of the final image. 

• To view slice options in the Save For Web dialog box, select the Slice Select tool, and double-click a slice. 

• To link slices, select two or more slices and choose Link Slices from the Optimize pop-up menu . The link

icon  appears on the linked slices. 

• To unlink a slice, select the slice, and then choose Unlink Slice from the Optimize pop-up menu. 

• To unlink all slices in an image, choose Unlink All Slices from the Optimize pop-up menu. 

To compress a web graphic to a specific file size

1 (Photoshop) Choose File > Save For Web.


2 Click a tab at the top of the Save For Web dialog box or ImageReady document window to select a display option:


Optimized, 2-Up, or 4-Up. If you select 4-Up, select the preview you want to optimize.


3 (Optional) Select the slices you want to optimize and the file format you want to use.


4 Select Optimize To File Size from the Optimize menu (to the right of the Settings menu).


5 Enter the desired file size.


6 Select a Start With option:


Current Settings Uses the current file format.


Auto Select GIF/JPEG Automatically selects the format. 

7 Select a Use option to specify whether you want to apply the specified file size to current slice only, to each slice 

in the image, or to all slices. Click OK. 

To resize the image during optimization 
When optimizing an image in the Photoshop Save For Web dialog box, you can resize the image to specified pixel


dimensions or to a percentage of the original size.


1 Click the Image Size tab in the Save For Web dialog box.


2 To maintain the current proportions of pixel width to pixel height, select Constrain Proportions.


3 Enter values for Width, Height, or Percent.


4 Choose an interpolation method from the Quality pop-up menu. See “Choosing an interpolation method” on


page 183. Bicubic Sharper generally produces better results when you are reducing image size.


5 Click Apply.


See also 

“Resampling” on page 182 
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To view optimized images in ImageReady 
In ImageReady, you view and work with optimized images directly in the document window. You can view up to four 

versions of an optimized image simultaneously, and easily switch between the optimized and original (nonopti

mized) versions of an image. 

1 To preview optimized images, click a tab at the top of the document window to select a display option: Original, 

Optimized, 2-Up, or 4-Up. 

Note: To switch between views, press Ctrl+Y (Windows) or Command+Y (Mac OS). 

2 If you’re working in 2-Up or 4-Up view, you must select a view before you apply optimization settings. To select a 

view, click the view you want to select. A black frame indicates which view is selected. 

3 To hide or show optimization information below each preview, choose View > Hide Optimization Info or View > 

Show Optimization Info. 

You can choose a modem speed in the image information pop-up menu at the bottom of the document window. 

To use the Optimize palette (ImageReady) 
In ImageReady you use the Optimize palette to select optimization options. This palette corresponds to the Optimize 

panel in the Photoshop Save For Web dialog box. 

•	 To display the Optimize palette, choose Window > Optimize. 

•	 To show all the optimization options, click the Show Options control (double triangle icon) on the Optimize 

palette tab, or choose Show Options from the Optimize palette menu. 

•	 To display one set of options, click the Show Options control (triangle) for that set of options. 

•	 To choose an option from the Optimize palette menu, click the triangle in the upper right corner of the palette. 

To optimize and save images as SWF files (ImageReady) 
❖ In ImageReady, you can save image and animation files in the Macromedia Flash (SWF) format. Choose Export > 

Macromedia Flash (SWF) and set output options. See “SWF (ImageReady)” on page 685 for complete information 

on SWF exporting. 

Controlling optimization in ImageReady 
ImageReady automatically regenerates the optimized image in these circumstances: when you click the Optimized, 

2-Up, or 4-Up tab at the top of the document (if you have modified the image since the last optimization), when you 

change optimization settings with the optimized image displayed, or when you edit the original image. 

When auto-regeneration is turned off, the Regenerate button appears in the lower right corner of each optimized 

image view. A regeneration alert symbol also appears in the Color Table palette if the optimized image is in GIF or 

PNG-8 format, indicating that the color table is out of date. 

•	 To turn Auto Regenerate on or off, choose Auto Regenerate from the Optimize palette menu. A check mark 

indicates that the option is turned on. 

•	 To manually optimize an image, Click the Regenerate button in the lower right corner of the optimized image (if 

it appears), or choose Regenerate from the Optimize palette menu. 

Note: Manually optimizing an image does not turn auto-regeneration on. 

•	 To cancel optimization, click the Stop button next to the progress bar at the bottom of the image window. 
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To set ImageReady optimization preferences (ImageReady) 
You can set preferences in ImageReady to determine the default optimization settings and the default configuration 

of panels in 2-Up and 4-Up views. 

1 Do one of the following: 

• In Windows, choose Edit > Preferences > Optimization. 

• In Mac OS, choose ImageReady > Preferences > Optimization. 

2 Choose an option in the Default Optimization section: 

Previous Settings Applies the last-used optimization settings. 

Auto Selected GIF or JPEG Automatically optimizes the image in either GIF format or JPEG format. ImageReady 

selects GIF or JPEG based on an analysis of the image. 

Named Setting Uses one of the preset optimization settings. 

3 Under 2-Up Settings or 4-Up Settings, specify settings for the first, second, third, and fourth panes (third and


fourth panes apply to 4-Up view only):


Original Displays the original image in the specified pane. (This option is available for the first pane only.)


Current Displays the image with current Optimize palette settings in the specified pane. (This option is available for


all panes.)


Auto Displays a smaller optimized version of the image generated automatically by ImageReady, based on the


current Optimize palette settings. (This option is available for the second, third, and fourth panes.)


Named presets Select one of the named settings to display the optimized image with those settings. (This option is


available for the second, third, and fourth panes.)


4 Click OK. 

Web graphics formats and options 

Comparing web graphics formats 
The file format that you choose depends largely on the characteristics of the image. 

JPEG 

JPEG is the standard format for compressing continuous-tone images such as photographs. Optimizing an image as 

a JPEG format relies on lossy compression, which selectively discards data. 

GIF and PNG-8 

GIF is the standard format for compressing images with flat color and crisp detail, such as line art, logos, or illustra

tions with type. Like the GIF format, the PNG-8 format efficiently compresses solid areas of color while preserving 

sharp detail. (See “Optimization options for GIF and PNG-8 formats” on page 635.) 

PNG-8 and GIF files support 8-bit color, so they can display up to 256 colors. The process of determining which 

colors to use is called indexing, so images in GIF  and PNG-8  formats are  sometimes called  indexed color images. To 

convert an image to indexed color, Photoshop builds a color lookup table, which stores and indexes the colors in the 

image. If a color in the original image does not appear in the color lookup table, the application either chooses the 

closest color in the table or simulates the color using a combination of available colors. 
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PNG-24 

PNG-24 is suitable for compressing continuous-tone images; however, it produces much larger files than JPEG 

format. The advantage of using PNG-24 is that it can preserve up to 256 levels of transparency in an image. 

SWF 

The Macromedia® Flash™ (SWF) file format is a vector-based graphics file format for the creation of scalable, compact 

graphics for the web. Because the file format is vector-based, the artwork maintains its image quality at any 

resolution. The SWF format is ideal for the creation of animation frames, but you can also save raster images in SWF 

format or mix raster and vector graphics. See “Saving files in SWF format (ImageReady)” on page 671. 

WBMP 

WBMP format is the standard format for optimizing images for mobile devices, such as cell phones. WBMP supports 

1-bit color, which means that WBMP images contain only black and white pixels. 

See also 

“Using the Save For Web dialog box” on page 625 

“To optimize an image for the web” on page 628 

Optimization options for JPEG format 

C 

A 

B 

Optimization settings for JPEG 
A. File Format menu B. Compression Quality menu C. Optimize menu 

Quality Determines the level of compression. The higher the Quality setting, the more detail the compression 

algorithm preserves. However, using a high Quality setting results in a larger file size than using a low Quality setting. 

View the optimized image at several quality settings to determine the best balance of quality and file size. 

Optimized Creates an enhanced JPEG with a slightly smaller file size. The Optimized JPEG format is recommended 

for maximum file compression; however, some older browsers do not support this feature. 

Progressive Displays the image progressively in a web browser. The image appears as a series of overlays, enabling 

viewers to see a low-resolution version of the image before it downloads completely. The Progressive option requires 

use of the Optimized JPEG format. 

Note: Progressive JPEGs require more RAM for viewing and are not supported by some browsers. 

Blur Specifies the amount of blur to apply to the image. This option applies an effect identical to that of the Gaussian 

Blur filter and allows the file to be compressed more, resulting in a smaller file size. A setting of 0.1 to 0.5 is recom

mended. 

ICC Profile Preserves the ICC profile of the artwork with the file. Some browsers use ICC profiles for color 

correction. This option is available  only  after you  saved an image  with  an  ICC profile—it is not  available for  unsaved  

images. 
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Matte Specifies a fill color for pixels that were transparent in the original image. Click the Matte color swatch to 

select a color in the color picker, or select an option from the Matte menu: Eyedropper (to use the color in the 

eyedropper sample box), White, Black, or Other (to use the color picker). 

Pixels that were fully transparent in the original image are filled with the selected color; pixels that were partially 

transparent in the original image are blended with the selected color. 

Add Metadata (ImageReady) Includes image metadata with the image. Click Settings and then choose an option. 

See “Metadata output options” on page 651. 

See also 

“Using the Save For Web dialog box” on page 625 

“To optimize an image for the web” on page 628 

Optimization options for PNG-24 format 
Transparency and Matte Determine how transparent pixels in the image are optimized: 

To save an image with multilevel transparency, select Transparency and select None from the Matte menu. 

To make fully transparent pixels transparent and blend partially transparent pixels with a color, select Transparency 

and select a matte color. 

To fill fully transparent pixels with a color and blend partially transparent pixels with the same color, select a matte 

color and deselect Transparency. 

To select a matte color, click the Matte color swatch and select a color in the color picker. Alternatively, select an 

option from the Matte menu: Eyedropper (to use the color in the eyedropper sample box), White, Black, or Other (to 

use the color picker). 

Interlace Displays a low-resolution version of the image in a browser while the full image file is downloading. Inter

lacing can make downloading time seem shorter and can assure viewers that downloading is in progress. However, 

interlacing also increases file size. 

See also 

“Using the Save For Web dialog box” on page 625 

“To optimize an image for the web” on page 628 

Optimization options for WBMP format 
The Dithering Method and Dither options determine the method and amount of application dithering. For optimal 

compression, use the lowest percentage of dither that provides the detail you require. 

You can select one of the following dithering methods: 

No Dither Applies no dithering at all, rendering the image in purely black and purely white pixels. 

Diffusion Applies a random  pattern that is usually  less  noticeable  than  Pattern dither.  The dither effects  are diffused  

across adjacent pixels. If you select this algorithm, specify a Dither percentage to control the amount of dithering 

applied to the image. 

Note: Diffusion dither may cause detectable seams to appear across slice boundaries. Linking slices diffuses the dither 

pattern across all linked slices, and eliminates the seams. 
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Pattern Applies a halftone-like square pattern to determine the value of pixels. 

Noise Applies a random pattern similar to the Diffusion dithering, but without diffusing the pattern across adjacent 

pixels. No seams appear with the Noise algorithm. 

See also 

“Using the Save For Web dialog box” on page 625 

“To optimize an image for the web” on page 628 

Optimization options for GIF and PNG-8 formats 
In addition to the following options, you can also adjust the number of colors in the image’s color table. See “Custom

izing the color table for GIF and PNG-8 images” on page 638. 

D 

A 

B 

C 

Optimization settings for GIF 
A. File Format menu B. Color Reduction Algorithm menu C. Dithering Algorithm menu D. Optimize menu 

Lossy (GIF only) Reduces file size by selectively discarding data. A higher Lossy setting results in more data being 

discarded. You can often apply a Lossy value of 5–10, and sometimes up to 50, without degrading the image. The 

Lossy option can reduce file size by 5% to 40%. 

Note: You cannot use the Lossy option with the Interlaced option or with Noise or Pattern Dither algorithms. 

Color Reduction Method and Colors Specifies a method for generating the color lookup table and the number of 

colors you want in the color lookup table. You can select one of the following color reduction methods: 

• Perceptual Creates a custom color table by giving priority to colors for which the human eye has greater sensi

tivity. 

• Selective Creates a color table similar to the Perceptual color table, but favoring broad areas of color and the 

preservation of web colors. This color table usually produces images with the greatest color integrity. Selective is the 

default option. 

• Adaptive Creates a custom color table by sampling colors from the predominant spectrum in the image. For 

example, an image with only the colors green and blue produces a color table made primarily of greens and blues. 

Most images concentrate colors in particular areas of the spectrum. 

• (Restrictive) Web Uses the standard 216-color color table common to the Windows and Mac OS 8-bit (256-color) 

palettes. This option ensures that no browser dither is applied to colors when the image is displayed using 8-bit color. 

(This palette is also called the web-safe palette.) Using the web palette can create larger files, and is recommended 

only when avoiding browser dither is a high priority. 

• Custom Uses a color palette that is created or modified by the user. If you open an existing GIF or PNG-8 file, it 

will have a custom color palette. 

 



636 ADOBE PHOTOSHOP CS2 
User Guide 

Use the Color Table palette in the Save For Web dialog box to customize the color lookup table. 

•	 Black and White, Grayscale, Mac OS, Windows Use a set palette of colors. 

Dithering Method and Dither Determines the method and amount of application dithering. Dithering refers to the 

method of simulating colors not available in the color display system of your computer. A higher dithering 

percentage creates the appearance of more colors and more detail in an image, but can also increase the file size. For 

optimal compression, use the lowest percentage of dither that provides the color detail you require. Images with 

primarily solid colors may work well with no dither. Images with continuous-tone color (especially color gradients) 

may require dithering to prevent color banding. 

GIF image with 0% dither (left), and with 100% dither (right) 

You can select one of the following dithering methods: 

• Diffusion Applies a random pattern that is usually less noticeable than Pattern dither. The dither effects are 

diffused across adjacent pixels. 

•	 Pattern Applies a halftone-like square pattern to simulate any colors not in the color table. 

• Noise Applies a random pattern similar to the Diffusion dither method, but without diffusing the pattern across 

adjacent pixels. No seams appear with the Noise dither method. 

Transparency and Matte Determines how transparent pixels in the image are optimized. 

•	 To make fully transparent pixels transparent and blend partially transparent pixels with a color, select Trans

parency and select a matte color. 

•	 To fill fully transparent pixels with a color and blend partially transparent pixels with the same color, select a matte 

color and deselect Transparency. 

•	 To select a matte color, click the Matte color swatch and select a color in the color picker. Alternatively, select an 

option from the Matte menu: Eyedropper (to use the color in the eyedropper sample box), White, Black, or Other 

(to use the color picker). 
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A	 B 

C	 D 

Examples of transparency and matting 
A. Original image B. Transparency selected with a matte color C. Transparency selected with no matting D. Transparency deselected 
with a matte color 

Transparency Dithering When the Transparency option is selected, you can choose a method for dithering 

partially transparent pixels: 

•	 No Transparency Dither applies no dither to partially transparent pixels in the image. 

•	 Diffusion Transparency Dither applies a random pattern that is usually less noticeable than Pattern dither. The 

dither effects are diffused across adjacent pixels. If you select this algorithm, specify a Dither percentage to control 

the amount of dithering that is applied to the image. 

•	 Pattern Transparency Dither applies a halftone-like square pattern to partially transparent pixels. 

•	 Noise Transparency Dither applies a random pattern similar to the Diffusion algorithm, but without diffusing the 

pattern across adjacent pixels. No seams appear with the Noise algorithm. 

Example of Pattern Transparency dithering (left) and applied to a web page background (right) 
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Interlace Displays a low-resolution version of the image in a browser while the full image file is downloading. Inter

lacing can make downloading time seem shorter and can assure viewers that downloading is in progress. However, 

interlacing also increases file size. 

Web Snap Specifies a tolerance level for shifting colors to the closest web palette equivalents (and prevent the colors 

from dithering in a browser). A higher value shifts more colors. 

Use Unified Color Table (ImageReady) Uses the same color table for all rollover states. 

Add Metadata (ImageReady) Includes image metadata with the image. Click Settings and then choose an option. 

See “Metadata output options” on page 651. 

See also 

“Using the Save For Web dialog box” on page 625 

“To optimize an image for the web” on page 628 

Using the color table 

Customizing the color table for GIF and PNG-8 images 
You use  the Color  Table palette  in  ImageReady  and the  Photoshop Save For  Web dialog box  to  customize the  colors  

in optimized GIF and PNG-8 images. Reducing the number of colors often preserves image quality while reducing 

the file size of the image. 

You can add and delete colors in the color table, shift selected colors to web-safe colors, and lock selected colors to 

prevent them from being dropped from the palette. 

To view the color table for an optimized slice 
The color table for a slice appears in the Color Table panel in the Save For Web dialog box (Photoshop) or the Color 

Table palette (ImageReady). 

Note: In ImageReady, be careful not to confuse the Color Table palette with the Color palette or Swatches palette. You 

use the Color Table palette to optimize colors; you use the Color palette and Swatches palette to select colors. 

1 (ImageReady) Choose Window > Color Table. 

2 Select a slice that is optimized in GIF or PNG-8 format. The color table for the selected slice appears in the Color 

Table palette. 

Note: In ImageReady, the color table for the selected slice will not appear if Auto Regenerate is off. 

If an image has multiple slices, the colors in the color table may vary between slices (you can link the slices first to 

prevent this from happening). If you select multiple slices that use different color tables, the color table is empty and 

its status bar displays the message “Mixed.” 

To regenerate a color table (ImageReady) 
❖ Choose Rebuild Color Table from the Color Table palette menu. Use this command to generate a new color table 

when the Auto Regenerate option is off. (See “Controlling optimization in ImageReady” on page 631.) 
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To sort a color table 
Choose a sorting order from the Color Table palette menu: 

•	 Unsorted restores the original sorting order. 

•	 Sort By Hue sorts by the location of the color on the standard color wheel (expressed as a degree from 0 to 360). 

Neutral colors are assigned a hue of 0 and located with the reds. 

•	 Sort By Luminance sorts by the lightness or brightness of a color. 

•	 Sort By Popularity sorts by the colors’ frequency of occurrence in the image. 

To change the size of the color swatches (ImageReady) 
❖ Choose Small Swatches or Large Swatches from the Color Table palette menu. 

To add a new color to the color table 
You can add colors that were left out in building the color table. Adding a color to a dynamic table shifts the color in 

the palette closest to the new color. Adding a color to a fixed or Custom table adds an additional color to the palette. 

1 Deselect all colors in the color table. See “To select colors in the color table” on page 640. 

2 Choose a color by doing one of the following: 

•	 Click the color selection box in the Save For Web dialog box (Photoshop) or the toolbox (ImageReady), and 

choose a color from the color picker. 

•	 Select the Eyedropper tool in the Save For Web dialog box (Photoshop) or the toolbox (ImageReady) and click in 

the image. 

•	 Select the Eyedropper tool in the toolbox, click in the image, hold the mouse down, and drag anywhere on the 

desktop. You can use this option to select a color displayed in another application, such as a color in a web page 

displayed in a browser. 

• (ImageReady) Select a color from the Color palette or the Swatches palette. 

3 Do one of the following: 

•	 Click the New Color button  in the Color Table palette. 

•	 Select New Color from the Color Table palette menu. 

•	 (ImageReady) Drag the color from the color selection box, Color palette, or Swatches palette to the Color Table 

palette. 

To switch the color table to a Custom palette, hold down Ctrl (Windows) or Command (Mac OS) when you add the 

new color. 

The new color appears in the color table with a small white square in the lower right corner, indicating that the color 

is locked. (See “To lock a color” on page 641.) If the color table is dynamic, the original color is displayed in the upper 

left and the new color is displayed in the lower right. 

To select a color from the optimized image 
1 Select the Eyedropper tool in the Save For Web dialog box (Photoshop) or the toolbox (ImageReady). 

2 Click a color in the image. A white border appears around that color in the color table. Shift-click to select 

additional colors. 
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To select a color from another application (ImageReady) 
❖ Select the Eyedropper tool, click in the image, hold the mouse down, and drag anywhere on the desktop. You can 

use this option to select a color displayed  in  another application, such as a color in a web page displayed  in  a browser.  

To select colors in the color table 
•	 To select a color, click the color in the Color Table palette. 

•	 To select multiple colors in the color table, press Shift and click another color. All colors in the rows between the 

first and second selected colors are selected. To select a nonadjacent group of colors, press Ctrl (Windows) or 

Command (Mac OS) and click each color that you want to select. The Color Table palette menu also provides 

commands for selecting colors. 

•	 (ImageReady) To select colors based on a selection in the image, make a selection in the image and choose Select 

All From Selection from the Color Table palette menu. 

•	 To deselect all colors, choose Deselect All Colors from the Color Table palette menu. 

To view selected colors in an image (ImageReady) 
❖ Select the optimized image. Then click and hold a selected color in the Color Table palette to temporarily invert 

the color in the optimized image, enabling you to see which areas of the image contain the color. 

To view a contiguous group of colors, press Shift and click and hold another color. All colors in the rows between the 

first and second selected colors are inverted. 

To view a discontiguous group of colors, press Ctrl (Windows) or Command (Mac OS) and click each color that you 

want to select, and hold the mouse button down on any color in the group. 

To shift a color 
You can change a selected color in the color table to any other RGB color value. When you regenerate the optimized 

image, the selected color changes to the new color wherever it appears in the image. 

1	 Double-click the color in the color table to display the default color picker. 

2	 Select a color. 

The original color  appears at the  upper left of the  color swatch and  the new  color at the  lower right. The  small square  

at the lower right of the color swatch indicates that the color is locked. If you shift to a web-safe color, a small white 

diamond appears at the center of the swatch. 

To revert shifted colors to their original colors 
Do one of the following: 

•	 Double-click the swatch for the shifted color. The original color is selected in the color picker. Click OK to restore 

the color. 

•	 To revert all shifted colors in a color table (including web-shifted colors), choose Unshift All Colors from the Color 

Table palette menu. 
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To shift colors to the closest web palette equivalent 
To protect colors from dithering in a browser, you can shift the colors to their closest equivalents in the web palette. 

This ensures that the colors won’t dither when displayed in browsers on either Windows or Macintosh operating 

systems capable of displaying only 256 colors. 

1 Select one or more colors in the optimized image or color table. 

2 Do one of the following: 

•	 Click the Web Shift button  in the Color Table palette. 

•	 Choose Shift Selected Colors to Web Palette from the Color Table palette menu.The original color appears at the 

upper left of the color swatch and the new color at the lower right. The small white diamond  in the center of 

the color swatch indicates that the color is web-safe; the small square at the lower right of the color swatch indicates 

that the color is locked. 

3 To set a tolerance for shifting, enter a value for Web Snap or drag the pop-up slider. A higher value shifts more 

colors. 

To revert web-shifted colors to their original colors 
Do one of the following: 

•	 Select a web-shifted color in the color table and click the Web Shift button  in the Color Table palette. 

•	 To revert all web-shifted colors in the color table, choose Unshift All Web Shifted Colors from the Color Table 

palette menu. 

To map colors to transparency 
You can add transparency to an optimized image by mapping existing colors to transparency. 

1 Select one or more colors in the optimized image or color table. 

2 Do one of the following: 

•	 Click the Map Transparency button  in the Color Table palette. 

• Choose Map Selected Colors To Transparent from the Color Table palette menu. 

The transparency grid  appears in half of each mapped color. The small square at the lower right of the color 

swatch indicates that the color is locked. 

To revert transparency to its original colors 
Do one of the following: 

•	 Select the colors you want to revert and click the Map Transparency button or choose Unmap Selected Colors 

from Transparent from the Color Table palette menu. 

•	 To revert all transparency-mapped colors, choose Unmap All Transparent Colors. 

To lock a color 
You can lock selected colors in the color table to prevent them from being dropped when the number of colors is 

reduced and to prevent them from dithering in the application. 
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Note: Locking colors does not prevent them from dithering in a browser. 

1 Select one or more colors in the color table. 

2 Lock the color by doing one of the following: 

• Click the Lock button . 

• Choose Lock/Unlock Selected Colors from the Color Table palette menu. 

A white square  appears in the lower right corner of each locked color. 

To unlock a color

1 Click the locked color to select it.


2 Unlock the color by doing one of the following:


• Click the Lock button . 

• Choose Lock/Unlock Selected Colors from the Color Table palette menu. 

The white square disappears from the color swatch. 

To delete selected colors 
You can delete selected colors from the color table to decrease the image file size. When you delete a color, areas of 

the optimized image that previously included that color are re-rendered using the closest color remaining in the 

palette. 

When you delete a color, the color table automatically changes to a Custom palette. This is because the Adaptive, 

Perceptual, and Selective palettes automatically add the deleted color back into the palette when you reoptimize the 

image—the Custom palette does not change when you reoptimize the image. 

1 Select one or more colors in the color table. 

2 Delete the color by doing one of the following: 

• Click the Delete icon . 

• Choose Delete Color from the Color Table palette menu. 

To save a color table 
You can save color tables from optimized images to use with other images and to load color tables created in other 

applications. Once you load a new color table into an image, the colors in the optimized image are changed to reflect 

the colors in the new color table. 

1 Select Save Color Table from the Color Table palette menu. 

2 Name the color table and choose a location where it will be saved. By default, the color table file is given the 

extension .act (for Adobe Color Table). 

If you want to access the color table when selecting Optimization options for a GIF or PNG image, save the color 

table in the Presets/Optimized Colors folder inside the Photoshop program folder. 

3 Click Save. 

Important: When you reload the table, all shifted colors will appear as full swatches and will be unlocked. 
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To load a color table

1 Select Load Color Table from the Color Table palette menu.


2 Navigate to a file containing the color table you want to load—either an Adobe Color Table (.act) file, an Adobe


Color Swatch (.aco) file, or a GIF file (to load the file’s embedded color table).


3 Click Open.


Using master palettes (ImageReady) 
You can create a master palette to use with a group of GIF or PNG-8 images that will be placed on a CD-ROM or


other multimedia storage medium. When you include the master palette with a batch of images, all images display


using the same colors.


To build a master palette, add colors from a set of images and then build and save the master palette. To create a


master palette for a batch of images, add colors to the palette from other optimized images.


To create and apply a master palette

1 With an image displayed, choose Image > Master Palette > Clear Master Palette (if available). Clearing the master


palette ensures that colors from previous images are not included in the new palette.


2 Open an image whose colors you want to include in a master palette.


3 Choose Image > Master Palette > Add To Master Palette. All color information for the current image is added to


the master palette.


4 Repeat steps 2 and 3 for all images whose colors you want to include in the master palette.


5 In the Optimize palette, select optimization settings for the master palette.


6 Choose Image > Master Palette > Build Master Palette to create a new color table from the color information of


images used in steps 2, 3, and 4.


7 Choose Image > Master Palette > Save Master Palette.


8 Name the master palette and choose a location where it will be saved. By default, the master palette file is given


the extension .act (for Adobe Color Table).


If you want to access the color table when selecting optimization options for a GIF or PNG image, save the master


palette in the Presets/Optimized Colors folder in the Adobe Photoshop folder.


9	 Click Save. 

10 To  apply the  master  palette to the  image or images for  which it was  created,  open  the image  or  images  and select  

the master palette: 

•	 If the master palette appears in the Color Reduction Algorithm menu in the Optimize palette, select the master 

palette from this menu. (The Color Reduction Algorithm menu includes all palettes saved in the 

Presets/Optimized Colors folder in the Adobe Photoshop folder.) 

•	 Load the master palette. (See “To load a color table” on page 643.) 
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Using weighted optimization 

About weighted optimization 
Weighted optimization lets you vary optimization settings across an image using masks from text layers, shape layers, 

and alpha channels. This technique produces higher-quality results in critical image areas without greatly increasing 

file size. With weighted optimization, you can produce gradual variations in GIF, PNG-8, and WBMP dithering, 

lossy GIF settings, and JPEG compression. Weighted optimization also lets you favor colors in selected image areas 

when you generate a color table. 

Image without weighted optimization (left), and with weighted optimization on text layers and vector shapes (right) 

Photoshop and  ImageReady  automatically generate masks  when  you create a type  layer or a shape layer. You  can also  

manually create masks and store them in alpha channels. When you use a mask to apply optimization settings, the 

white areas  of  the mask describe the  highest level  of  image quality, whereas  the black  areas for  the mask describe the  

lowest level of image quality. (The level of optimization in gray areas of the mask decreases by a linear scale.) 

Weighted optimization is available for specific settings in the Optimize panel/palette, as indicated by the Mask 

button . To access the Weighted Optimization dialog box, click the mask button. 

Note: For the Lossy setting, a higher number actually means greater compression, as opposed to greater quality (as in 

most other settings). 

To create masks for use during optimization 
Do one or more of the following: 

•	 Create a type layer. 

•	 Create a shape layer. 

•	 (Photoshop) Save a selection as a mask, or create a new alpha channel and use the painting and editing tools to 

modify it. (See “About masks and alpha channels” on page 338.) 

•	 (ImageReady) Use a selection tool to select an area of the image. Either save the selection using the Select > Save 

Selection command, or choose the Save Selection command from the Channel pop-up menu in the Weighted 

Optimization dialog box. 

 



645 ADOBE PHOTOSHOP CS2 
User Guide 

To use masks to modify JPEG quality 
When you use masks to optimize the range of quality in a JPEG image, white areas of the masks yield the highest 

quality, and black areas of the masks yield the lowest quality. You can adjust the maximum and minimum level of 

quality in the Modify Quality Setting dialog box. 

1 In the Optimize panel/palette, choose a JPEG setting from the Preset menu, or choose JPEG from the file format 

menu. 

2	 Click the Mask button  to the right of the Quality text box.


3 Choose which masks to use:


All Text Layers Uses the masks from all text layers in the image.


All Vector Shape Layers Uses the masks from all shape layers in the image. 

Channel Specifies an alpha channel. (In ImageReady, you can choose Save Selection to create a new alpha channel 

based on the current selection.) 

4 To preview the results of the weighted optimization, select the Preview option. 

5 Define the quality range: 

•	 To set the highest level of quality, drag the right (white) tab on the slider, enter a value in the Maximum text box, 

or use the arrows to change the current value. 

•	 To set the lowest level of quality, drag the left (black) tab on the slider, enter a value in the Minimum text box, or 

use the arrows to change the current value. 

6	 Click OK. 

To use masks to modify GIF lossiness 
When you use masks to optimize the amount of lossiness (or quality reduction) in a GIF image, white areas of the 

masks yield the highest quality, and black areas of the masks yield the lowest quality. You can adjust the maximum 

and minimum level of quality reduction in the Modify Lossiness Setting dialog box. 

1 In the Optimize panel/palette, choose a GIF setting from the Preset menu, or choose GIF from the file format 

menu. 

2	 Click the Mask button  to the right of the Lossy text box.


3 Choose which masks to use:


All Text Layers Uses the masks from all text layers in the image.


All Vector Shape Layers Uses the masks from all shape layers in the image. 

Channel Specifies an alpha channel. (In ImageReady, you can choose Save Selection to create a new alpha channel 

based on the current selection.) 

4 To preview the results of the weighted optimization, select the Preview option. 

5 Define the quality range: 

•	 To set the highest level of quality, drag the left (white) tab on the slider, enter a value in the Minimum text box, or 

use the arrows to change the current value. 

•	 To set the lowest level of quality, drag the right (black) tab on the slider, enter a value in the Maximum text box, or 

use the arrows to change the current value. 
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Note: Lossiness is a reduction in quality; therefore, the highest level of image quality is defined by the Minimum value, 

and the lowest level of image quality is defined by the Maximum value. This is the opposite of the JPEG quality setting. 

6	 Click OK. 

To use masks to modify dithering 
When you use masks to optimize the amount of dithering in a GIF, PNG-8, or WBMP image, white areas of the 

masks yield the most dithering, and black areas of the masks yield the least dithering. You can adjust the maximum 

and minimum levels of dithering in the Modify Quality Setting dialog box. 

1 In the Optimize panel/palette, choose a GIF or PNG-8 setting from the Preset menu, or choose GIF or PNG-8 

from the file format menu. 

2	 Click the Mask button  to the right of the Dither text box.


3 Choose which masks to use:


All Text Layers Uses the masks from all text layers in the image.


All Vector Shape Layers Uses the masks from all shape layers in the image. 

Channel Specifies an alpha channel. (In ImageReady, you can choose Save Selection to create a new alpha channel 

based on the current selection.) 

4 To preview the results of the weighted optimization, select the Preview option. 

5 Define the dithering range: 

•	 To set the highest percentage of dithering, drag the right (white) tab on the slider, enter a value in the Maximum 

text box, or use the arrows to change the current percentage. 

•	 To set the lowest percentage of dithering, drag the left (black) tab on the slider, enter a value in the Minimum text 

box, or use the arrows to change the current percentage. 

6	 Click OK. 

To use masks to modify color reduction 
When you use masks to optimize the colors in a GIF or PNG-8 image, white areas of the masks indicate to the color


reduction algorithm which pixels are highly important, and black areas indicate which pixels are less important.


Thus, color is more greatly reduced in areas masked by black.


1 In the Optimize panel/palette, choose a GIF or PNG-8 setting from the Preset menu, or choose GIF or PNG-8


from the file format menu.


2 Choose a color-reduction algorithm and specify the maximum number of colors.


3 Click the Mask button
  to the right of the Color Reduction Algorithm pop-up menu.


4 Choose which masks to use:


All Text Layers Uses the masks from all text layers in the image.


All Vector Shape Layers Uses the masks from all shape layers in the image. 

Channel Specifies an alpha channel. (In ImageReady, you can choose Save Selection to create a new alpha channel 

based on the current selection.) 

5 To preview the results of the weighted optimization, select the Preview option. 

6 Click OK. 
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Output settings for web images 

To set output options 
Output settings control how HTML files are formatted, how files and slices are named, and how background images 

are handled when you save an optimized image. You set these options in the Output Settings dialog box. 

You can save your output settings and apply them to other files. 

1	 To display the Output Settings dialog box, do one of the following: 

•	 When you save an optimized image, choose Other from the Settings pop-up menu in the Save Optimized or Save 

Optimized As dialog box. The Save and Load options are not available when you use this method to access the 

Output Settings dialog box. 

•	 (ImageReady) Choose the desired preferences set from the File > Output Settings submenu or from the document 

window menu. Use this method if you want to load and save settings. 

•	 (Photoshop) Choose Edit Output Settings from the Optimize pop-up menu in the Save For Web dialog box. Use 

this method if you want to load and save settings. 

2	 (Optional) To display predefined output options, choose an option from the Settings pop-up menu. 

3 Edit each set of options as needed. To switch to a different set of options, choose an options set from the pop-up 

menu below the Settings menu. Alternatively, click Next to display the next set in the menu list; click Prev to display 

the previous set. 

4 (Optional) To save output settings, set the options as desired, and click Save. Type a file name, choose a location 

for the saved file, and click Save. 

You can save the output settings anywhere. However, if you place the file in the Presets/Optimized Output Settings 

folder inside the Photoshop program folder, the file will appear in the Settings pop-up menu in both Photoshop and 

ImageReady. 

5	 (Optional) To load output settings, click Load, select a file, and click Open. 

See also 

“Using the Save For Web dialog box” on page 625 

“To optimize an image for the web” on page 628 

HTML output options 
You can set the following options in the HTML set: 

Output XHTML Creates web pages meeting the XHTML standard on export. Choosing Output XHTML makes 

other output options that might conflict with this standard unavailable. Selecting this option automatically sets the 

Tags Case and Attribute Case options. 

Tags Case Specifies the capitalization for tags. 

Attribute Case Specifies the capitalization for attributes. 

Indent Specifies a method for indenting lines of code: using the authoring application’s tab settings, using a specified 

number of spaces, or using no indention. 

Line Endings Specifies a platform for line ending compatibility. 
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Encoding Specifies a default character encoding for the web page. 

Include Comments Adds explanatory comments to the HTML code. In ImageReady, this option is required when


you plan to update the resulting file using the File > Update HTML command.


Always Add Alt Attribute Adds the ALT attribute to IMG elements to comply with government web accessibility


standards. 

Always Quote Attributes Places quotation marks around all tag attributes. Placing quotation marks around


attributes is required for compatibility with certain early browsers and for strict HTML compliance.


Close All Tags Adds close tags for all HTML elements in the file for XHTML compliance.


Include Zero Margins On Body Tag Removes default internal margins in a browser window.


Saving HTML files 
In ImageReady, you can set the following options in the Saving HTML Files set:


Use Long Filename Extension (.html) Uses .html rather than .htm as the file extension for web pages.


Output Multiple HTML files Generates a unique HTML page for each slice containing a selected state.


HTML File Naming Sets naming conventions when multiple HTML files are generated.


Slice output options 
You can set the following options in the Slices set: 

Generate Table Aligns slices using an HTML table rather than a cascading stylesheet. 

Empty Cells Specifies how empty slices are converted to table cells. Select GIF, IMG W&H to use a 1-pixel GIF with 

width and height values specified on the IMG tag. Select GIF, TD W&H to use a 1-pixel GIF with width and height 

values specified on the TD tag. Select NoWrap, TD W&H to place a nonstandard NoWrap attribute on the table data 

and also place width and height values specified on the TD tags. 

TD W&H Specifies when to include width and height attributes for table data: Always, Never, or Auto (the recom

mended setting). 

Spacer Cells Specifies when to add one row and one column of empty spacer cells around the generated table: Auto 

(the recommended setting), Auto (Bottom), Always, Always (Bottom), or Never. For table layouts in which slice 

boundaries do not align, adding spacer cells can prevent the table from breaking apart in some browsers. 

Generate CSS Generates a cascading stylesheet rather than an HTML table. 

Referenced Specifies how slice positions are referenced in the HTML file when using CSS: 

• By ID Positions each slice using styles that are referenced by a unique ID. 

• Inline Includes style elements in the declaration of the block element <DIV> tag. 

• By Class Positions each slice using classes that are referenced by a unique ID. 

Default Slice Naming Choose elements from the pop-up menus or enter text into the fields to create default names 

for slices. Elements include the document name, the word slice, numbers or letters designating slices or rollover 

states, the slice creation date, punctuation, or none. 

 



649 ADOBE PHOTOSHOP CS2 
User Guide 

Image map output options (ImageReady) 
In ImageReady you can set the following options in the Image Maps set: 

Image Map Type Specifies what type of image map is created: 

• Client-Side Includes all required code for the image map in the image’s HTML file. 

• NCSA Server-Side Creates a separate .map file in addition to the HTML file, using NCSA specifications. 

• CERN Server-Side Creates a separate .map file in addition to the HTML file, using CERN specifications. 

Important: Photoshop and ImageReady cannot generate server-side image maps for images that contain slices. 

• Client-Side & NCSA Server-Side Creates both client-side- and server-side-compatible image maps, using NCSA 

specifications. 

• Client-Side & CERN Server-Side Creates both client-side- and server-side-compatible image maps, using CERN 

specifications. 

Note: Contact your Internet service provider to find out whether to use NCSA or CERN specification for server-side 

image maps. 

Image Map Placement Specifies the location of the image map declaration (the <MAP> tag) in the HTML file: 

• Top Places the image map declaration at the top of the HTML body section. 

• Body Places the image map declaration above the <IMG SRC> tag for the associated slice. 

• Bottom Places the image map declaration at the bottom of the HTML body section. 

Setting background output options 
You can set the following options in the Background set:


View Document As Specifies how HTML code is written to display the image as foreground or background.


• Image Displays the image in the foreground of a web page. You can then choose a background image or color to 

display behind the image. 

• Background Displays the image as a tiled background on the page. 

Background Image Specifies the location of a background image file. The file you specify is tiled behind the 

optimized image on the web page. 

BG Color Specifies a background color. Click the color box and choose a background color using the color picker, 

or choose an option from the pop-up menu. Matte uses the current matte color set in the Optimize palette. 
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File saving output options 
You set the following options in the Saving Files set: 

File Naming Choose elements from the pop-up menus or enter text into the fields to be used in the default names 

for all files. Elements include document name, slice name, rollover state, trigger name, trigger number, file creation 

date, slice number, punctuation, and file extension. Some options are relevant only if the file contains slices or 

rollover states. 

The fields let you change the order and formatting of the parts of the file name (for example, letting you indicate 

rollover state by an abbreviation instead of the full word). 

Filename Compatibility Select one or multiple options to make the file name compatible with Windows (permits 

longer file names), Mac OS 9 (file names may be truncated after 31 characters), and UNIX operating systems. 

Optimized Files Choose from the following: 

•	 Put Images In Folder specifies a folder name where optimized images are saved (available only with documents 

containing multiple slices). 

•	 Use Long Filename Extensions (ImageReady) saves files using four-letter extensions for JPEG and WBMP files, if 

desired. 

•	 Copy Background Image When Saving copies the background image file specified in the Background set into the 

images folder for the web page. 

•	 Include Copyright (Photoshop) includes copyright information with the image. See “To add metadata using the 

File Info dialog box” on page 98. 

To include title and copyright information with an image 
You can  add title  and copyright  information to a web page by entering information  in  the File Info dialog box. Title  

information appears in the web browser’s title bar when the image is exported with an HTML file. Copyright infor

mation is not displayed in a browser; however, it is added to the HTML file as a comment and to the image file as 

metadata. 

1 Choose File > File Info.


2 (ImageReady) Enter a title that will appear in the web browser’s title bar:


•	 (Photoshop) In the Description section of the File Info dialog box, enter the desired text in the Description text 

box. 

• (ImageReady) Enter the desired text in the Description text box. 

3 Enter copyright information: 

•	 (Photoshop) In the Description section of the File Info dialog box, enter the desired text in the Copyright Notice 

text box. 

• (ImageReady) Enter the desired text in the Copyright Notice text box. 

4 Click OK. 

See also 

“To add metadata using the File Info dialog box” on page 98 
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Metadata output options 
In ImageReady, you can set the following metadata output options. Make sure to select Add Metadata in the 

Optimize palette. 

Add Custom ImageReady Metadata Includes simple copyright and description information from the File Info 

dialog box. See “To add metadata using the File Info dialog box” on page 98. 

Add EXIF Metadata For JPEG images, includes information stored with digital photographs, including camera type, 

date and time of photo, and file size. 

Note: To view the complete EXIF information for a file, view the file in Adobe Bridge. 

Add XMP Metadata Adds an Adobe-specific set of information that provides information about the file and facili

tates the use of files by multiple Adobe applications. 

• Write minimal set of XMP Includes only a small subset of the complete XMP metadata set, including file modifi

cation and output times, file dimensions, and format. 

• Include Reference to Source File Adds to the XMP a block of information that provides the path to the original 

document. 

• Write XMP to separate files Writes XMP data for the file to a separate file, instead of being embedded in the image 

file. 

Working with hexadecimal color values 

To view hexadecimal color values in the Info palette: 
In ImageReady, hexadecimal values for colors are displayed automatically at the right of the Info palette, next to RGB 

color values. 

1 Choose Window > Info or click the Info palette tab to view the palette. 

2 (Photoshop) Choose Palette Options from the palette menu. Under First Color Readout or Second Color Readout,


choose Web Color from the Mode menu and click OK.


3 Position the pointer over the color you want to view hexadecimal values for.


To copy a color as a hexadecimal value 
In Photoshop, you copy a color as a hexadecimal value while in the main work area (not the Save For Web dialog 

box). 

1 Select a color to copy.


2 Copy the color by doing one of the following:


• Choose Copy Color As HTML from the Color palette menu. 

• (ImageReady) Choose Edit > Copy Foreground Color As HTML. 

The color is copied to the clipboard as the HTML COLOR attribute with the hexadecimal value 

(COLOR=#XXYYZZ). 
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With the Eyedropper tool selected, move the pointer over the color that you want to copy, and then right-click 

(Windows) or Control-click (Mac OS) and choose a copy color command from the context menu. In ImageReady, 

make sure to click the color first to make it the foreground color. 

3 To paste the color into an HTML file, open a destination application and choose Copy > Paste with the HTML file 

displayed. 

To copy a color as a hexadecimal value by dragging (ImageReady) 
❖ Drag the Foreground Color from the toolbox, or a selected color from the Color Table palette or the Swatches 

palette, into the HTML file in the destination application. 

Note: This feature is not supported by all text and HTML editing applications. 
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Chapter 23: Saving and exporting images


Saving images 

Saving image files 
The saving options vary between Photoshop and ImageReady. The primary focus of ImageReady is producing 

images for the web. If ImageReady doesn’t provide the file format or option you need, you can edit in Photoshop. 

To preserve all the Photoshop features in your edited image (layers, effects, masks, styles, and so forth), it’s best to 

save a copy of your image in Photoshop format (PSD). Like most file formats, PSD can support files only up to 2 GB 

in  size. In Photoshop, if you  are working  with  document  files larger than 2 GB, you  can save your image  in  the Large  

Document Format (PSB), Photoshop Raw (flattened image only), and TIFF (up to 4 GB in size only). 

You can save 16-bits-per-channel images only in the following formats using the Save As command: Photoshop, 

Photoshop PDF, Photoshop Raw, Large Document Format (PSB), Cineon, PNG, and TIFF. When using the Save For 

Web command with a 16-bits-per-channel image, Photoshop automatically converts the image from 16 bits per 

channel to 8 bits per channel. 

You can save 32-bits-per-channel images only in the following formats using the Save As command: Photoshop, 

OperEXR, Portable Bit Map, Radiance, and TIFF. 

You can use the following commands to save images: 

Save Saves changes you’ve made to the current file. In Photoshop, the file is saved in the current format; in 

ImageReady, the Save command always saves to PSD format. 

Save As Saves an image in a different location or under another file name. In Photoshop, the Save As command lets 

you save an image in a different format and with different options. In ImageReady, the Save As command always 

saves to PSD format. 

Export Original Document (ImageReady) Flattens  the layers in a copy  of  the original image  and saves  the copy in  

one of several file formats. Some information (such as slices and optimization settings) is not preserved when an 

original image is saved to file formats other than Photoshop. 

Save A Version (Photoshop) Lets you save different versions of a file and comment on each. This command is 

available for an image that is managed by a Version Cue Workspace. 

If you’re working with a file from an Adobe Version Cue project, the document title bar provides additional infor

mation about the status of the file. 

Save For Web (Photoshop), Save Optimized (ImageReady), and Save Optimized As (ImageReady) Save an 

optimized image for the web. 

See also 

“About file formats” on page 678 

“Version Cue managed projects” on page 113 

“About optimization” on page 625 
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To save changes to the current file 
❖ Choose File > Save. 

To save a file with a different name and location

1 Choose File > Save As.


2 Type a file name, and choose a location for the file.


3 Click Save.


To save a file in a different file format 
1 Do one of the following: 

• (Photoshop) Choose File > Save As. 

• (ImageReady) Choose File > Export > Original Document. 

Note: The Adobe Camera Raw plug-in can save camera raw image files in a different file format, such as Adobe Digital 

Negative (DNG). 

2 Do one of the following: 

• In Photoshop, choose a format from the Format menu. 

• In ImageReady, choose from the Save As Type (Windows) or Format (Mac OS) menu. 

Note: In  Photoshop,  if  you choose a format that does not  support all  features  of  the document,  a warning  appears at the  

bottom of the dialog box. If you see this warning, it’s best to save a copy of the file in Photoshop format or in another 

format that supports all of the image data. 

3 Specify a file name and location.


4 (Photoshop) In the Save As dialog box, select saving options.


5 Click Save.


In both Photoshop and ImageReady, a dialog box appears for choosing options when saving in some image formats.


To copy an image without saving it to your hard disk, use the Duplicate command. To store a temporary version of 

the image in memory, use the History palette to create a snapshot. 

See also 

“To duplicate an image in Photoshop” on page 49 

“Making a snapshot of an image” on page 74 

“To save camera raw images in Camera Raw” on page 221 
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File saving options 
You can set a variety of file saving options in the Save As dialog box. The availability of options depends on the image 

you are saving and the selected file format. For example, if an image doesn’t contain multiple layers, or if the selected 

file format doesn’t support layers, the Layers option is dimmed. If you have Version Cue enabled, additional options 

are available, such as the ability to save an alternate file and enter version comments. 

As A Copy Saves a copy of the file while keeping the current file open on your desktop. 

Alpha Channels Saves alpha  channel information  with  the image. Disabling this option removes  the alpha  channels  

from the saved image. 

Layers Preserves all layers in the image. If this option is disabled or unavailable, all visible layers are flattened or 

merged (depending on the selected format). 

Annotations Saves annotations with the image. 

Spot Colors Saves spot channel information with the image. Disabling this option removes spot colors from the 

saved image. 

Use Proof Setup, ICC Profile (Windows), or Embed Color Profile (Mac OS) Creates a color-managed document. 

Note: The following image preview and file extension options are available only if Ask When Saving is selected for the 

Image Previews and Append File Extension options in the File Handling Preferences dialog box. 

Thumbnail (Windows) Saves thumbnail data for the file.


Image Previews options (Mac OS) Save thumbnail data for the file. Thumbnails appear in the Open dialog box.


Use Lower Case Makes the file extension lowercase.


File Extension options (Mac OS) Specify the format for file extensions. Select Append to add the format’s extension


to a file name and Use Lower Case to make the extension lowercase. 

See also 

“To embed a color profile in a document” on page 266 

“Version Cue managed projects” on page 113 

“To set file saving preferences” on page 692 

Image Preview options for Mac OS 
The following options are set in the File Handling preferences (Photoshop > Preferences > File Handling).


Icon Displays a file icon on the desktop.


Full Size Saves a 72-ppi version for use in applications that can open only low-resolution Photoshop images.


Macintosh Thumbnail Displays the preview in the Open dialog box.


Windows Thumbnail Saves a preview for display on Windows systems.


Saving large documents 
Photoshop supports documents up to 300,000 pixels in either dimension and offers three file formats for saving 

documents with images having more than 30,000 pixels in either dimension. Keep in mind that most other applica

tions, including older versions of Photoshop, cannot handle files larger than 2 GB or images exceeding 30,000 pixels 

in either dimension. 
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To save documents larger than 2 GB 
❖ Choose File > Save As and choose one of the following file formats: 

Large Document Format (PSB) Supports documents of any pixel size and any file size. All Photoshop features are 

preserved in PSB files. Currently, PSB files are supported only by Photoshop CS. To save files in PSB format, you must 

select the Enable Large Document preference (under Preferences > File Handling). 

Photoshop Raw Supports documents of any pixel dimension or file size, but does not support layers. Large 

documents saved in the Photoshop Raw format are flattened. 

TIFF Supports files up to 4 GB in size. Documents larger than 4 GB cannot be saved in TIFF format. 

See also 

“Large Document Format” on page 681 

“Photoshop Raw format” on page 683 

“TIFF” on page 685 

To enable the Large Document Format

1 Choose Edit > Preferences > File Handling (Windows) or Photoshop > Preferences > File Handling (Mac OS).


2 Select the Enable Large Document Format (.psb) option.


Saving PDF files 

Saving files in Photoshop PDF format 
You can use the Save As command to save RGB, indexed-color, CMYK, grayscale, Bitmap-mode, Lab color, and 

duotone images in Photoshop PDF format. Because the Photoshop PDF document can preserve Photoshop data, 

such as layers, alpha channels, spot color, and annotations, you can open the document and edit the images in 

Photoshop CS2. You can also use the Photoshop PDF format to save multiple images in a multipage document or 

slide show presentation. 

For advanced users, the Photoshop PDF format offers options for making the document PDF/X compliant, which is 

essential, for example, when you send your document to a large commercial press. PDF/X (Portable Document 

Format Exchange) is a subset of Adobe PDF that eliminates color, font, and trapping variables that lead to printing 

problems. You can also specify security options for restricting access to the PDF document. The 128-bit RC4 

(Acrobat 6) encryption has an option for letting users view metadata and thumbnails in a secure PDF document 

using Adobe Bridge. 

You can save your PDF settings as a PDF preset for creating consistent Photoshop PDF files. Adobe PDF presets are 

shared across Adobe Creative Suite components, including Photoshop, InDesign, Illustrator, GoLive, and Acrobat. 

Adobe Creative Suite users can find more information about shared PDF settings for Adobe Creative Suite applica

tions in the PDF Integration Guide on the Creative Suite CD. 
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See also 

“PDF” on page 682 

“Creating a PDF presentation” on page 698 

“To save an Adobe PDF preset” on page 663 

To save a file in Photoshop PDF format 
1 Choose File > Save As and choose Photoshop PDF from the Format menu. You can select a Color option if you 

want to embed a color profile or use the profile specified with the Proof Setup command. You can also include layers, 

annotations, spot color, or alpha channels. Click Save. 

Note: The first time you save your document as a Photoshop PDF file, you see a dialog box explaining that you can 

override save options in the Save Adobe PDF dialog box. To prevent the dialog box from being shown again, select the 

option not to show in future. 

2 In the Save Adobe PDF dialog box, choose an Adobe PDF preset specifying whether the Photoshop PDF file will 

be  printed on a desktop printer  or  proofer,  sent  to  a commercial printer, distributed  by  e-mail,  displayed on the  web,  

and so on. For details, see “Adobe PDF presets” on page 658. 

Choosing a preset is the easiest way to set options for your Photoshop PDF file. After you choose a preset, click Save 

PDF to generate your Photoshop  PDF file.  If  you want to add  security  options or fine-tune the  saving  options for  the  

PDF, follow the remaining steps in this procedure. 

3 (Optional) Choose options from the Standard menu and the Compatibility menu to specify the PDF/X 

compliance and the Acrobat version compatibility for the PDF document. For more information, see “Adobe PDF 

standards” on page 659 and “Adobe PDF compatibility levels” on page 659. 

4 (Optional) Select General in the left pane of the Save Adobe PDF dialog box to set general PDF file saving options. 

For details of each option, see “General options for Adobe PDF” on page 660. 

Note: Users of previous Photoshop versions can open a PDF (containing Photoshop data) as a generic PDF with the 

layers flattened. Choose File > Open As and then choose Generic PDF from the Files Of Type menu (Windows) or choose 

File > Open and choose Generic PDF from the Format menu (Mac OS). 

5 (Optional) Select Compression in the left pane of the Save Adobe PDF dialog box to specify the compression and 

downsampling options for the PDF file. For more information, see “Compression and downsampling options for 

Adobe PDF” on page 661. 

6 (Optional) Select Output in the left pane of the Save Adobe PDF dialog box to specify color management and 

PDF/X options. For more information, see “Color management and PDF/X options for Adobe PDF” on page 662. 

7 (Optional) To add security to your PDF document, select Security in the left pane of the Save Adobe PDF dialog 

box. Specify the password and permissions options for your PDF document. See also “PDF document security 

options” on page 663. 

Note: The Encryption Level depends on the Compatibility setting of your PDF document. Choose a different Compati

bility setting to specify a higher or lower Encryption Level. 

8 (Optional) Select Summary in the left pane of the Save Adobe PDF dialog box. You can review the options you 

specified. 

9 (Optional) If you want to reuse the PDF save settings, click Save Preset and save your settings as a PDF preset. The 

new preset appears in the Adobe PDF Preset menu the next time you save a Photoshop PDF file and in the PDF 

Options dialog box in all Adobe Creative Suite components. See also “To save an Adobe PDF preset” on page 663. 

10 Click Save PDF. Photoshop closes the Save Adobe PDF dialog box and creates the PDF document file. 
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See also 

“About file compression” on page 678 

Adobe PDF presets 
A PDF  preset  is  a predefined collection of settings that you  can use  for creating consistent Photoshop  PDF files. These  

settings  are designed to balance  file  size  with  quality,  depending on how  the PDF  file  will  be  used. You  can also create  

custom presets. Adobe PDF presets are shared across Adobe Creative Suite components, including InDesign, Illus

trator, Photoshop, GoLive, and Acrobat. 

High Quality Print Creates PDF files that have higher resolution than the Standard job option file. Color and 

grayscale images with resolutions above 450 ppi are downsampled to 300 ppi, and monochrome images with resolu

tions above 1800 ppi are downsampled to 1200 ppi. This settings file prints to a higher image resolution and preserves 

the maximum amount of information about the original document. PDF files created with this settings file can be 

opened in Acrobat 5.0 and Acrobat Reader 5.0 and later. 

PDF/X-1a:2001 Checks incoming PostScript files for PDF/X-1a:2001 compliance and only creates a file that is 

PDF/X-1a compliant. If the file fails compliance checks, you see a warning message. You can cancel the save or 

continue by saving a file that is not marked as PDF/X-compliant. PDF/X-1a is an ISO standard for graphic content 

exchange. PDF/X-1a:2001 requires all fonts to be embedded, the appropriate PDF bounding boxes to be specified, 

and color to appear as CMYK, spot colors, or both. PDF/X-compliant files must contain information describing the 

printing condition for which they are prepared. For the PDF/X-1a:2001 settings file, the default output intent profile 

name is U.S. Web Coated (SWOP). PDF files created with this settings file can be opened in Acrobat 4.0 and Acrobat 

Reader 4.0 and later. 

PDF/X-3:2002 Checks incoming PostScript files for PDF/X-3:2002 compliance and only creates a file that is PDF/X-

3:2002 compliant. If the file fails compliance checks, you see a warning message. You can cancel the save or continue 

by saving a file that is not marked as PDF/X-compliant. Like PDF/X-1a, PDF/X-3 is an ISO standard for graphic 

content exchange. The main difference is that PDF/X-3 allows the use of color management and device-independent 

color in addition to CMYK and spot colors. PDF files created with this settings file can be opened in Acrobat 4.0 and 

Acrobat Reader 4.0 and later. 

Press Quality Creates PDF files for high-quality print production (for example, for digital printing or for separa

tions to an imagesetter or platesetter), but does not create files that are PDF/X-compliant. In this case, the quality of 

the content is the highest consideration. The objective is to maintain all the information in a PDF file that a 

commercial printer or prepress service needs to print the document correctly. Color and grayscale images with 

resolutions above 450 ppi are downsampled to 300 ppi, and monochrome images with resolutions above 1800 ppi are 

downsampled to 1200 ppi. The Press Quality settings file embeds subsets of fonts used in the document (if allowed) 

and creates a higher-resolution image than the Standard settings file does. When you export a document that uses 

fonts whose permission bits do not allow embedding, a warning message appears and the fonts are substituted. These 

PDF files can be opened in Acrobat 5.0 and Acrobat Reader 5.0 and later. 

Important: If  you’re  sending  a Photoshop  PDF file to a commercial  printer or prepress service, find out  what  the output  

resolution and other settings should be, or ask for a .joboptions file with the recommended settings. You may need to 

customize the Adobe PDF settings for a particular provider and then provide a .joboptions file of your own. Adobe PDF 

settings are saved as .joboptions files. 

Smallest File Size Creates PDF  files for  display on the  web or an intranet,  for distribution through  an  email system  

for on-screen viewing, or for display on smaller, more portable devices (such as cell phones). This set of options uses 

compression, downsampling, and a relatively low image resolution. It converts all colors to sRGB and does not embed 

fonts unless absolutely necessary. It also optimizes files for byte serving. These PDF files can be opened in Acrobat 

5.0 and Acrobat Reader 5.0 and later. 
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See also 

“Adobe PDF standards” on page 659 

“To save an Adobe PDF preset” on page 663 

Adobe PDF standards 
Choose an Adobe PDF standard from the Standards menu at the top of the Adobe PDF Options dialog box. 

Currently, the most widely used standards for a print publishing workflow are available in two different types of 

PDF/X formats, PDF/X-1a and PDF/X-3. For more information on PDF/X, see the ISO website and the Adobe 

website. 

None Does not use the PDF/X standard. 

PDF/X-1a (2001 and 2003) PDF/X-1a is an ISO standard for graphic content exchange. PDF/X-1a requires all fonts 

to be embedded, the appropriate PDF bounding boxes to be specified, and color to appear as CMYK, spot colors, or 

both. PDF/X-compliant files must contain information describing the printing condition for which they are 

prepared. PDF files created with PDF/X-1a compliance can be opened in Acrobat 4.0 and Acrobat Reader 4.0 and 

later. 

PDF/X-3 (2002 and 2003) Like PDF/X-1a, PDF/X-3 is an ISO standard for graphic content exchange. The main 

difference is that PDF/X-3 allows the use of color management and device-independent color (CIE Lab, ICC-based 

color spaces, CalRGB, and CalGray) in addition to CMYK and spot colors. You can use ICC color profiles to specify 

color data later in the workflow, at the output device. PDF files created with PDF/X-3 compliance can be opened in 

Acrobat 4.0 and Acrobat Reader 4.0 and later. 

Adobe PDF compatibility levels 
When  you create Photoshop  PDF files, you  need  to  decide  which PDF  version to use. You  can change the  PDF version  

by switching to a different preset or choosing a Compatibility option in the Adobe PDF Options dialog box. 

Generally speaking, you should use the most recent version (in this case version 1.6) unless there’s a specific need for 

backward compatibility, because the latest version will include all the latest features and functionality. However, if 

you’re creating documents that will be distributed widely, consider choosing Acrobat 4.0 (PDF 1.3) or Acrobat 5.0 

(PDF 1.4) to ensure that all users can view and print the document. The following table compares some of the 

functionality in Adobe PDF files created using the different compatibility settings. 
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Acrobat 4.0 (PDF 1.3) Acrobat 5.0 (PDF 1.4) Acrobat 6.0 (PDF 1.5) Acrobat 7.0 (PDF 1.6) 

PDF files can be opened with 
Acrobat 3.0 and Acrobat Reader 

PDF files can be opened with 
Acrobat 3.0 and Acrobat Reader 

Most PDF files can be opened 
with Acrobat 4.0 and Acrobat 

Most PDF files can be opened 
with Acrobat 4.0 and Acrobat 

3.0 and later. 3.0 and later. However, features Reader 4.0 and later. However, Reader 4.0 and later. However, 
specific to later versions may be 
lost or not viewable. A warning 
message appears if the PDF file 
version exceeds the PDF version 

features specific to later versions 
may be lost or not viewable. A 
warning message appears if the 
PDF file version exceeds the PDF 

features specific to later versions 
may be lost or not viewable. A 
warning message appears if the 
PDF file version exceeds the PDF 

supported by the application. version supported by the appli
cation. 

version supported by the appli
cation. 

ICC color management is sup- ICC color management is sup- ICC color management is sup- ICC color management is sup
ported. ported. ported. ported. 

Cannot contain artwork that Supports the use of live trans- Supports the use of live trans- Supports the use of live trans
uses live transparency effects. parency in artwork. parency in artwork. parency in artwork. 
Any transparency must be flat
tened prior to converting to PDF 
1.3. 

Layers are not supported. Layers are not supported. Preserves layers when creating 
PDF files from applications that 
support the generation of lay
ered PDF documents, such as 

Preserves layers when creating 
PDF files from applications that 
support the generation of lay
ered PDF documents, such as 

Illustrator CS or InDesign CS. Illustrator CS or InDesign CS. 

DeviceN color space with 8 colo- DeviceN color space with 8 colo- DeviceN color space with up to DeviceN color space with up to 
rants is supported. rants is supported. 31 colorants is supported. 31 colorants is supported. 

Pages can be up to 45 inches Pages can be up to 200 inches Pages can be up to 200 inches Pages can be up to 200 inches 
(114.3cm) in either dimension. (508cm) in either dimension. (508cm) in either dimension. (508cm) in either dimension. 

Double-byte fonts can be Double-byte fonts can be Double-byte fonts can be Double-byte fonts can be 
embedded. embedded. embedded. embedded. 

40-bit RC4 security supported. 128-bit RC4 security supported. 128-bit RC4 security supported. 128-bit RC4 and 128-bit AES 
(Advanced Encryption Stan
dard) security supported. 

General options for Adobe PDF 
You can set the following options in the General section of the Adobe PDF Options dialog box: 

Description Displays the description from the selected preset, and provides a place for you to edit the description. 

You can paste a description from the clipboard. If you edit the description of a preset, the word “(modified)” is added 

at the end of the preset name. If you change the settings of a preset, “[Based on <Current Preset Name>]” is added at 

the beginning. 

Preserve Photoshop Editing Capabilities Preserves Photoshop data in the PDF, such as layers, annotations, alpha 

channels, and spot colors. Photoshop PDF documents with this option can be opened only in Photoshop CS2. 

Embed Page Thumbnails Creates a thumbnail image of artwork. The thumbnail is displayed in the Illustrator Open 

or Place dialog boxes. 

Optimize For Fast Web View Optimizes the PDF file for faster viewing in a web browser. 

View PDF After Saving Opens the newly created PDF file in the default PDF viewing application. 
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Compression and downsampling options for Adobe PDF 
When saving artwork in Adobe PDF, you can compress text and line art, and compress and downsample bitmap 

images. Depending on the settings you choose, compression and downsampling can significantly reduce the size of 

a PDF file with little or no loss of detail and precision. 

The Compression area of the Adobe PDF Options dialog box is divided into three sections. Each section provides 

the following options for compressing and resampling color, grayscale, or monochrome images in your artwork. 

Downsampling If you plan to use the PDF file on the web, use downsampling to allow for higher compression. If 

you plan to print the PDF file at high resolution, do not use downsampling. Deselect the option to disable all 

downsampling options. 

Downsampling refers to decreasing the number of pixels in an image. To downsample color, grayscale, or 

monochrome images, choose an interpolation method—average downsampling, bicubic downsampling, or subsam-

pling—and enter the desired resolution (in pixels per inch). Then enter a resolution in the For Images Above text 

box. All images with resolution above this threshold are downsampled. 

The interpolation method you choose determines how pixels are deleted: 

• Average Downsampling Averages the pixels in a sample area and replaces the entire area with the average pixel 

color at the specified resolution. Average downsampling is the same as Bilinear resampling. 

• Bicubic Downsampling Uses a weighted average to determine pixel color, which usually yields better results than 

the simple averaging method of downsampling. Bicubic is the slowest but most precise method, resulting in the 

smoothest gradations. 

• Subsampling Chooses a pixel in the center of the sample area and replaces the entire area with that pixel color. 

Subsampling significantly reduces the conversion time compared with downsampling but results in images that are 

less smooth and continuous. Subsampling is the same as Nearest Neighbor resampling. 

Compression Determines the type of compression that is used. The Automatic option automatically sets the best 

possible compression and quality for the artwork contained in the file. For most files, this option produces satis

factory results. Use Automatic (JPEG) if you need the greatest compatibility. 

• ZIP compression Works well on images with large areas of single colors or repeating patterns, and for black-and-

white images that contain repeating patterns. ZIP compression can be lossless or lossy, depending on the Quality 

setting. 

• JPEG compression Is suitable for grayscale or color images. JPEG compression is lossy, which means that it 

removes image data and may reduce image quality; however, it attempts to reduce file size with a minimal loss of 

information. Because JPEG compression eliminates data, it can achieve much smaller file sizes than ZIP 

compression. 

• JPEG2000 Is the new international standard for the compression and packaging of image data. Like JPEG 

compression, JPEG2000 compression is suitable for grayscale or color images. It also provides additional advantages, 

such as progressive display. 

• CCITT and Run Length compression Are available only for monochrome bitmap images. CCITT (Consultative 

Committee on International Telegraphy and Telephony) compression is appropriate for black-and-white images and 

any images scanned with an image depth of 1 bit. Group 4 is a general-purpose method that produces good 

compression for most monochrome images. Group 3, used by most fax machines, compresses monochrome bitmaps 

one row  at  a time.  Run  Length compression  produces  the best results  for images that contain  large areas  of  solid black  

or solid white. 

Image Quality Determines the amount of compression that is applied. The available options depend on the 

compression method. For JPEG Compression, Photoshop provides Minimum, Low, Medium, High, and Maximum 
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Quality options. For ZIP compression, Photoshop provides 4-bit and 8-bit Quality options. If you use 4-bit ZIP 

compression with 4-bit images, or 8-bit ZIP compression with 4-bit or 8-bit images, the ZIP method is lossless; that 

is, data is not removed to reduce file size, so image quality is not affected. Using 4-bit ZIP compression with 8-bit 

data can affect the quality, however, because data is lost. 

Tile Size Specifies the size of the tiles used in images with JPEG 2000 compression. When low Image Quality values 

are used to optimize images smaller than 1024 x 1024 pixels, using the largest tile size produces better results. In 

general, a tile size of 1024 is best for most images. Lower tile sizes are generally used for images with small dimensions 

(for viewing on devices such as cell phones). 

Convert 16 Bit/Channel Image To 8 Bit/Channel Converts 16-bits-per-channel images to 8-bits-per-channel 

images. ZIP  is  the only compression  method  available if the  Convert 16 Bits option is unselected.  If  your  document’s  

Compatibility setting is Acrobat 5 (PDF 1.4) or earlier, the Convert 16 Bits option is unavailable, and images are 

automatically converted to 8 bits per channel. 

Color management and PDF/X options for Adobe PDF 
You can set the following options in the Output section of the Adobe PDF Options dialog box. Interactions between 

Output  options change depending on whether  Color Management is on or off  and which  PDF standard is selected.  

Color Conversion Specifies how to represent color information in the Adobe PDF file. When you convert color 

objects to RGB or CMYK, also select a destination profile from the pop-up menu. All spot color information is 

preserved during color conversion; only the process color equivalents convert to the designated color space. 

• No Conversion Preserves color data as is. This is the default when PDF/X-3 is selected. 

• Convert To Destination Converts all colors to the profile selected for Destination. Whether the profile is included 

or not is determined by the Profile Inclusion Policy. 

Note: When Convert To Destination is selected, and the Destination doesn’t match the document profile, a warning icon 

appears beside the option. 

Destination Describes the gamut of the final RGB or CMYK output device, such as your monitor or a SWOP 

standard. Using this profile, Photoshop converts the document’s color information (defined by the source profile in 

the Working Spaces section of the Color Settings dialog box) to the color space of the target output device. 

Profile Inclusion Policy Determines whether a color profile is included in the file. 

Output Intent Profile Name Specifies the characterized printing condition for the document. An output intent 

profile is required for creating PDF/X-compliant files. This menu is available only if a PDF/X standard (or preset) is 

selected in the Adobe PDF Options dialog box. The available options depend on whether color management is on or 

off. For example, if color management is off, the menu lists available printer profiles. If color management is on, the 

menu lists the same profile selected for Destination Profile (provided it is a CMYK output device), in addition to 

other predefined printer profiles. 

Output Condition Describes the intended printing condition. This entry can be useful for the intended receiver of 

the PDF document. 

Output Condition Identifier A pointer to more information on the intended printing condition. The identifier is 

automatically entered for printing conditions that are included in the ICC registry. 

Registry Name Indicates the web address for more information on the registry. The URL is automatically entered 

for ICC registry names. 
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PDF document security options 
In the Save Adobe PDF dialog box, you can set security options for your PDF document. These options specify the 

different access restrictions. 

Require A Password To Open The Document Requires the viewer to type a password to view the PDF document. 

Select this option and type a password in the Document Open Password text box. 

Important: If you forget a password, there is no way to recover it from the document. It’s a good idea to store passwords 

in a separate secure location in case you forget them. 

Use A Password To Restrict Printing, Editing And Other Tasks Restricts access to the PDF document. If the PDF 

file  is  opened  in  Adobe Acrobat, the  user  can view the  file  but must enter  the Permissions  password  to  edit, print, or  

do  other tasks  with  the file.  If  the file is opened in Photoshop, Illustrator, or InDesign,  the user must enter  the Permis

sions password to view, edit, print, or do other tasks with the PDF file. Select this option and type a password in the 

Permissions Password text box. 

Printing Allowed Specifies whether or not the viewer can print the PDF document. You can also choose whether 

the document can be printed at high or low resolution. 

Changes Allowed Specifies whether  or  not the  viewer  can make changes  to  the PDF  document. You  can specify the  

extent of the changes allowed. 

Enable Copying Of Text, Images And Other Content Lets the viewer access content in the PDF document. 

Enable Text Access Of Screen Reader Devices For The Visually Impaired Lets screen readers read the content of 

the PDF document. 

Enable Plaintext Metadata Lets applications access or search for metadata in the PDF document. 

To save an Adobe PDF preset 
Although the default PDF presets are based on best practices, you may discover that your workflow requires 

specialized PDF settings that aren’t available using any of the built-in presets. In this case, you can create and save 

your own custom presets for reuse in Photoshop or any product in the Adobe Creative Suite. 

In  Photoshop,  you can  save  the preset using  the Adobe  PDF Presets  command  or  clicking  the Save Preset button in  

the Save Adobe  PDF dialog box. Adobe  PDF presets  are saved  as  files with a .joboptions extension. This is useful,  for  

example,  if  you want your vendor or printer  to  send  you a .joboptions file with the  Adobe PDF  presets  that  work  best  

with their workflow. 

1	 Do one of the following: 

•	 Choose Edit > Adobe PDF Presets. 

•	 If you’re saving a Photoshop PDF document, click the Save Preset button in the Save Adobe PDF dialog box after 

you specify your PDF settings. Skip steps 2 and 3. 

2	 If you chose the Adobe PDF Presets command, do one of the following in the PDF Options Preset dialog box: 

•	 To create a new preset, click the New button in the PDF Options Preset dialog box. In the Edit PDF Preset dialog 

box, type a name for the preset in the Preset text box and specify your PDF settings. 

•	 To edit an existing custom preset, select the preset and click Edit. (You can’t edit the default presets.) 
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3 Set the PDF options.


4 Save your preset by doing one of the following:


•	 In the Edit PDF Preset dialog box, click OK. The new preset appears in the Adobe PDF Presets list. Click Done 

when you finish creating presets. 

•	 In the Save dialog box, type a name for the preset in the File Name text box and click Save. 

Adobe PDF presets are stored in Documents and Settings/All Users/Documents/Adobe PDF/Settings (Windows) or 

Library/Application Support/Adobe PDF/Settings (Mac OS). All the Adobe PDF presets you save in these locations 

are available in your other Adobe Creative Suite applications. 

Note: To save the PDF preset in a location other than the default, do one of the following: In the PDF Options Preset 

dialog  box,  click the  Save  As  button  and browse to the  destination.  In  the Save dialog box, browse to the  destination and  

click Save. 

See also 

“To save a file in Photoshop PDF format” on page 657 

To load, edit, or delete Adobe PDF presets 
Adobe PDF presets (creation settings) are available in Photoshop and other products in the Adobe Creative Suite. 

From the PDF Options Preset dialog box, you save, load, edit, or delete Adobe PDF presents. 

❖ Choose Edit > Adobe PDF Presets and do any of the following: 

•	 To save settings as a new preset, click the New button, specify settings in the Edit PDF Preset dialog box, and 

click OK. 

•	 To edit an Adobe PDF preset, select the preset in the Preset window, click the Edit button, and change settings in 

the Edit PDF Preset dialog box. 

Note: Although you can’t edit the Adobe PDF presets that were installed with Photoshop, you can select one of them and 

click the New button. In the Edit PDF Preset dialog box, you can modify the settings and save them as a new preset. 

•	 To delete an Adobe PDF preset, select the preset in the Preset window and click the Delete button. You can’t delete 

the Adobe PDF presets that were installed with Photoshop. 

•	 To load an Adobe PDF preset, click the Load button, select the preset file, and click the Load button. The preset is 

added to the Presets window. 

When you browse for an Adobe PDF preset to load, only files with the .joboptions extension are visible in the Load 

dialog box. 

•	 To close the PDF Options Preset dialog box, click the Done button. 

•	 To save a preset in a location other than the default, click the Save As button, give the preset a new name (if 

necessary), browse to the destination, and click Save. 

See also 

“To save an Adobe PDF preset” on page 663 
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Saving GIF, JPEG, and PNG files 

To save a file in GIF format 
You can use the Save As command to save RGB, Indexed Color, Grayscale, or Bitmap mode images directly in


CompuServe GIF (known as GIF) format. The image is automatically converted to Indexed Color mode.


1 Choose File > Save As and choose CompuServe GIF from the Format menu.


2 For RGB images, the Indexed Color dialog box appears. Specify conversion options and click OK.


3 Select a row order for the GIF file, and click OK:


Normal Displays the image in a browser only when download is complete.


Interlaced Displays low-resolution versions of the image in a browser as the file downloads. Interlacing makes


download time seem shorter, but it also increases file size.


Note: You can also save an image as one or more GIF files using the Save For Web command (Photoshop) or the Save 

Optimized command (ImageReady). 

See also 

“GIF” on page 680 

“About optimization” on page 625 

“Conversion options for indexed-color images” on page 238 

To save a file in JPEG format 
You can use the Save As command to save CMYK, RGB, and grayscale images in JPEG format. JPEG compresses file 

size by selectively discarding data. 

Note: You can also save an image as one or more JPEG files using the Save For Web command (Photoshop) or the Save 

Optimized command (ImageReady). 

1 Choose File > Save As and choose JPEG from the Format menu.


2 In the JPEG Options dialog box, select the options you want, and click OK.


Matte Offers matte color choices to simulate the appearance of background transparency in images that contain


transparency.


Image Options Specifies the image quality. Choose an option from the Quality menu, drag the Quality pop-up


slider, or enter a value between 0 and 12 in the Quality text box.


Format Options Specifies the format of your JPEG file.


Size Displays the estimated download time after you select a modem speed. (The Size preview is available only when


Preview is selected.)


Note: Some applications may not be able to read a CMYK file saved in JPEG format. In addition, if you find that a Java 

application can’t read your JPEG file (in any color mode), try saving the file without a thumbnail preview. 
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See also 

“Format options for saving a JPEG file” on page 666 

“About optimization” on page 625 

“About file compression” on page 678 

“Optimization options for GIF and PNG-8 formats” on page 635 

“JPEG format” on page 681 

Format options for saving a JPEG file 
Baseline (“Standard”) Uses a format recognized by most web browsers. 

Baseline Optimized Creates a file with optimized color and a slightly smaller file size. 

Progressive Displays a series of increasingly detailed versions of the image (you specify how many) as it downloads. 

Note: Not all web browsers support optimized and Progressive JPEG images. 

To save a file in JPEG 2000 format (optional Photoshop plug-in) 
To save files in the JPEG 2000 format, you must get the optional JPEG 2000 plug-in and install it in this location: 

Adobe Photoshop CS2/Plug-Ins/Adobe Photoshop Only/File Formats. This plug-in is available on the Photoshop 

CS2 installation CD in Goodies/Optional Plug-Ins/Photoshop Only/File Formats. Extended JPEG 2000 (JPF) format 

provides an expanded set of options compared to the standard JPEG 2000 (JP2) format. However, you can make files 

JP2 compatible by selecting the appropriate option in the JPEG 2000 dialog box. 

Note: You can’t save Duotone, Multichannel, or Bitmap mode images in JPEG 2000 format. To save these files in JPEG 

2000 format, first convert them to RGB Color mode. 

1 Choose File > Save As, and choose JPEG 2000 from the Format menu.


2 Specify a file name and location, select saving options, and click Save. The JPEG 2000 dialog box opens.


Note: If you want to save a JP2-compatible file, you must select the ICC Profile option (Windows) or the Embed Color 

Profile option (Mac OS) in the Save As dialog box. Otherwise, the JP2 Compatible option will be unavailable in the JPEG 

2000 dialog box. The JP2-compatible option slightly increases the JPF file size. Keep in mind that JP2 viewers are not 

required to support ICC profiles and metadata present in JPF files, so color fidelity and other features may not work as 

expected. 

3 (Optional) Enter a value in the File Size text box to set a target size for the saved file. The value in the Quality text 

box changes to reflect the best quality for the file size you enter. 

4 Select any of the following options: 

Lossless Compresses the image without losing image quality. Selecting this option creates a larger file. Deselect 

Lossless to create a smaller file. Then drag the Quality pop-up slider or enter a value in the Quality text box to specify 

the image quality. A higher value results in better image quality and a larger file size. 

If you specify an image quality that conflicts with a target file size you entered previously, Photoshop automatically 

changes the value in the File Size text box. 

Fast Mode Allows faster previewing or encoding of the image. Fast Mode does not support file-size control, 

progressive optimization, or lossy encoding with an integer wavelet filter. 

Include Metadata Includes file information. If your image file contains paths and you wish to store the paths infor

mation in the JPEG 2000 file, you must select the Metadata option. 
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Include Color Settings Includes the color profile embedded in an image.

Deselect the Include Metadata and Include Color Settings options to decrease the size of the image file.

Include Transparency Preserves transparency in the original image. The Include Transparency option is dimmed

if the image does not contain transparency.

JP2 Compatible Creates a file that can be displayed in viewing software that supports standard JPEG 2000 (JP2)

format but does not support extended JPEG 2000 (JPF) format.

5 Click the Advanced Options button to set the following options:

Compliance Specifies the devices with which the file is compliant. Currently, only general devices (such as web

browsers) are supported.

Wavelet Filter Specifies the type of numbers (coefficients) used to encode the file. Float is more accurate but cannot

be used for Lossless compression. Selecting the Lossless compression option automatically sets the Wavelet Filter

option to Integer.

Choose Float or Integer depending on your image and the result you want. Integer is usually the best option for an

overall consistent appearance in the image. Float may sharpen the image but could cause it to lose some quality

around the edges.

Tile Size Specifies the size of the tiles used in the image. When you use low quality values to optimize images smaller

than 1024 x 1024 pixels, using the largest tile size produces better results.

A tile size of 1024 is best for most images. When creating files with small dimensions (for cell phones, and so forth),

use a smaller tile size.

Metadata Format Specifies the metadata formats to include in the image file. JPEG2000 XML is JPEG 2000-specific

XML data; this option is available only if the image file contains this data. XMP is File Info data and EXIF is digital

camera data.

Color Settings Format Specifies the Color Settings Format to include in the image file. ICC Profile, the default

option, includes the full ICC profile specified in the Save As dialog box. The Restricted ICC Profile option is intended

for use in portable devices such as cell phones and PDAs. A Restricted ICC Profile must be in a JP2 file.

6 Choose an optimization order from the Order menu:

Growing Thumbnail Presents a sequence of small thumbnail images increasing in size until they reach the image’s

full size.

Progressive Presents increasingly detailed versions of the entire image as data becomes available (for example,

streaming over the web to a browser). Progressive JPEG images have a slightly larger file size, require more RAM for

viewing, and are not supported by all applications and JPEG 2000 viewing software.

Color Makes the image appear first as a grayscale image, then as a color image.

Region Of Interest Lets you choose an alpha channel to define a region of interest if your Photoshop document

contains one or more alpha channels.

After the alpha channel is loaded as a region of interest, choose an Enhance value to increase or decrease the quality

of the region of interest relative to the rest of the image. Note that Enhance does not change the file size of the image,

so enhancing the area inside the alpha channel decreases the quality of the area outside the alpha channel (and vice

versa).

The Region Of Interest and Enhance options are not available if your Photoshop document does not have an alpha

channel.
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Note: The channel (alpha, spot, or Quick Mask) used to define the region of interest is discarded in the final saved JPEG 

2000 file. 

7 To preview how the image will appear in JPEG 2000 viewing software, make sure you chose an optimization order 

in step 6. The Preview option takes into consideration how the image is optimized and opens the image accordingly. 

In the Download Preview area of the JPEG 200 dialog box, choose a download rate from the pop-up menu to view 

the estimated download time of the image, then click the Preview button. 

You can use the Set Preview Zoom pop-up menu to zoom in or out of the image for better viewing. You can also use 

the Zoom tool and the Hand tool to adjust the viewing area of your preview. 

8 Click OK to generate the JPEG 2000 image file. 

See also 

“JPEG format” on page 681 

To save a file in PNG format 
You can  use the  Save  As  command to save RGB, Indexed  Color,  Grayscale,  and Bitmap mode images in PNG  format.  

Note: You can also save an image as one or more PNG files using the Save For Web command (Photoshop) or the Save 

Optimized command (ImageReady). 

1 Choose File > Save As and choose PNG from the Format menu.


2 Select an Interlace option:


None Displays the image in a browser only when download is complete.


Interlaced Displays low-resolution versions of the image in a browser as the file downloads. Interlacing makes 

download time seem shorter, but it also increases file size. 

3 Click OK. 

See also 

“PNG format” on page 683 

“About optimization” on page 625 
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Saving files in other formats 

To save a file in Photoshop EPS format 
Virtually all page-layout, word-processing, and graphics applications accept imported or placed EPS (Encapsulated 

PostScript) files. To print EPS files, you should use a PostScript printer. Non-PostScript printers will print only the 

screen-resolution preview. 

1 Choose File > Save As and choose Photoshop EPS from the Format menu. 

2 In the EPS Options dialog box, select the options you want, and click OK: 

Preview Creates a low-resolution image to view in the destination application. Choose TIFF to share an EPS file 

between Windows and Mac OS systems. An 8-bit preview is in color and a 1-bit preview is in black and white with 

a jagged appearance. An 8-bit preview creates a larger file size than a 1-bit preview. See also “About bit depth” on 

page 231. 

Encoding Determines the way image data is delivered to a PostScript output device. 

Include Halftone Screen and Include Transfer Function Control print specifications for high-end commercial 

print jobs. Consult your printer before selecting these options. 

Transparent Whites Displays white areas as transparent. This option is available only for images in Bitmap mode. 

PostScript Color Management Converts file data to the printer’s color space. Do not select this option if you plan 

to place the image in another color-managed document. 

Note: Only PostScript Level 3 printers support PostScript Color Management for CMYK images. To print a CMYK 

image using PostScript Color Management on a Level 2 printer, convert the image to Lab mode before saving in EPS 

format. 

Include Vector Data Preserves any vector graphics (such as shapes and type) in the file. However, vector data in EPS 

and DCS files is available only to other applications; vector data is rasterized if you reopen the file in Photoshop. This 

option is only available if your file contains vector data. 

Image Interpolation Applies anti-aliasing to the printed low-resolution image. 

See also 

“Photoshop EPS format” on page 680 

Photoshop EPS encoding options 
ASCII or ASCII85 Encodes if you’re printing from a Windows system, or if you experience printing errors or other 

difficulties. 

Binary Produces a smaller file and leaves the original data intact. However, some page-layout applications and some 

commercial print spooling and network printing software may not support binary Photoshop EPS files. 

JPEG Compresses the file by discarding some image data. You can choose the amount of JPEG compression from 

very little (JPEG Maximum Quality) to a lot (JPEG Low Quality). Files with JPEG encoding can be printed only on 

Level 2 (or later) PostScript printers and may not separate into individual plates. 
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To save a file in Photoshop DCS format 
DCS (Desktop Color Separations) format is a version of EPS that lets you save color separations of CMYK or multi


channel files.


1 Choose File > Save As and choose Photoshop DCS 1.0 or Photoshop DCS 2.0 from the Format menu.


2 In the DCS Format dialog box, select the options you want, and click OK.


The dialog box includes all the options available for Photoshop EPS files. Additionally, the DCS menu gives you the


option of creating a 72-ppi composite file that can be placed in a page-layout application or used to proof the image:


DCS 1.0 format Creates one file for each color channel in a CMYK image. You can also create a fifth file: a grayscale


or color composite. To view the composite file, you must keep all five files in the same folder.


DCS 2.0 format Retains spot color channels in the image. You can save the color channels as multiple files (as for


DCS 1.0) or as a single file. The single-file option saves disk space. You can also include a grayscale or color


composite.


See also 

“Photoshop DCS 1.0 and 2.0 formats” on page 680 

To save a file in Photoshop Raw format 
The Photoshop Raw format is a file format for transferring images between applications and computer platforms. 

1 Choose File > Save As and choose Photoshop Raw from the Format menu. 

2 In the Photoshop Raw Options dialog box, do the following: 

•	 (Mac OS) Specify values for File Type and File Creator, or accept the default values. 

•	 Specify a Header parameter. 

•	 Select whether to save the channels in an interleaved or noninterleaved order. 

Note: The Photoshop Raw format is not the same as camera raw. 

See also 

“Camera raw and Photoshop Raw files” on page 209 

“Photoshop Raw format” on page 683 

To save a file in BMP format 
The BMP format is an image format for the Windows operating system. The images can range from black-and-white 

(1 byte per pixel) up to 24-bit color (16.7 million colors). 

1	 Do one of the following: 

•	 (Photoshop) Choose File > Save As and choose BMP from the Format menu. 

•	 (ImageReady) Choose File > Export > Original Document, and choose BMP from the Save As Type (Windows) 

or Format (Mac OS) menu. 

2	 Specify a file name and location, and click Save. 
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3 In the BMP Options dialog box, select a file format, specify the bit depth and, if necessary, select Flip Row Order. 

For more options, click Advanced Modes and specify the BMP options. 

4 Click Save. 

See also 

“BMP format” on page 679 

To save a 16-bits-per-channel file in Cineon format 
RGB images that are 16 bits per channel can be saved in Cineon format for use in the Kodak Cineon Film System. 

❖ Choose File > Save As and choose Cineon from the Format menu. 

See also 

“Cineon format” on page 680 

To save files in QuickTime Movie format (ImageReady) 
The QuickTime format is used to play back, create, and deliver multimedia. To save in the QuickTime Movie format, 

you need to install QuickTime on your computer. 

1 Choose File > Export > Original Document, and choose QuickTime Movie from the Save As Type (Windows) or 

Format (Mac OS) menu. 

2 Specify a file name and location, and click Save. 

3 In the Compression Settings dialog box, choose a compression from the pop-up menu, specify the compression 

options, and then click OK. 

When working in Photoshop, you must jump to ImageReady before saving a document (such as an animation) in 

QuickTime format. 

Saving files in SWF format (ImageReady) 
In ImageReady, you can export a document as a SWF file, which can then go directly to the web or be imported into 

the Macromedia® Flash™ application. In a multilayered PSD file, each layer of the PSD file can be exported as one 

SWF object, or each layer can be exported as separate SWF files using the Layers As Files command. When the entire 

PSD file is exported to one SWF file, animation frames are exported as SWF animation frames. URLs in slices and 

image maps are preserved when exported. Rollovers are ignored. The exported images do not change when you roll 

over them. 

Layers in a PSD file can be preserved when exported from ImageReady and then imported into Macromedia Flash. 

Use the Layers As Files command to export the individual layers as separate SWF files. When the SWF files are 

imported in a SWF document, they each appear on separate layers. You can also export individual animation frames as 

separate SWF files using the Animation As Files command. Again, each SWF file appears on a separate layer when 

imported into Macromedia Flash. 

See also 

“SWF (ImageReady)” on page 685 
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To export an ImageReady file in SWF format (ImageReady) 
1 Do one of the following: 

•	 Choose File > Export > Macromedia Flash SWF. 

•	 Choose File > Export > Original Document. In the Export Original dialog box, choose Macromedia Flash SWF 

from the Save As Type (Windows) or Format (Mac OS) menu. Enter a name for the SWF file, choose a destination, 

and click Save. 

If you chose File Export > Macromedia Flash SWF, the Macromedia Flash (SWF) Export dialog box opens, letting 

you select options for exporting to SWF format. 

2	 Under Export Options, select from the following options: 

Preserve Appearance Retains the appearance of the PSD file and may rasterize a text or shape layer if it cannot be 

exported natively to SWF. If Preserve Appearance is not selected, all effects that cause flattening or rasterization of 

vectors are dropped, including ones on raster layers. 

Generate HTML Generates HTML in addition to the SWF file. 

3 Select the Enable Dynamic Text option to map text variables to SWF dynamic text. SWF dynamic text disappears 

on import into Macromedia® Flash™. Therefore, mapping text variables to SWF dynamic text is useful only if the 

generated SWF file is going directly to the web. 

4 Under Bitmap Options, either leave the Format menu set at Auto Select or choose a file format used for bitmap 

images. If you choose JPEG, use the JPEG Quality option to specify how much compression to apply. 

5 Under Text Options, specify which characters to embed by choosing either None, Full Set, or Partial Set from the 

Embed Fonts menu. 

If you choose Partial Set, click any combination of the Include All Uppercase Characters, Include All Lowercase 

Characters, Include All Numbers, or Include All Punctuation buttons to specify the characters of the partial set. 

You can also enter specific characters to embed in the Extra text box. 

Note: Whenever possible, PSD text and vector layers are converted into SWF text and vector objects. If layer effects or 

blending modes prohibit a native mapping of text and vectors, you can flatten the layers into bitmap objects. 

6	 Click OK. 

When working in Photoshop, you can jump to ImageReady to save a document (such as an animation) in SWF 

format. 

7	 In the Export As Macromedia SWF dialog box, enter a name for the file, select a destination, and click Save. 

See also 

“SWF (ImageReady)” on page 685 

To export layers or animation frames as individual SWF files (ImageReady) 
1 Do one of the following: 

•	 Choose File > Export > Layers As Files. If you’re exporting only specific layers, select the layers in the Layers 

palette before you choose the Layers As Files command. 

•	 Choose File > Export > Animation As Files. If you’re exporting only specific frames, select the frames in the 

Animation palette before you choose the Animation As Files command. 
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2 In the Export Layers As Files dialog box, under File Options, click Browse (Windows) or Choose (Mac OS) to


select a destination for the exported files.


3 Enter a name in the Base Name text box to specify a common name for the files.


4 Set the Save Options.


5 Choose SWF from the Format menu under Format Options and set the options for your SWF files.


6 Click OK.


See also 

“SWF (ImageReady)” on page 685 

“To export layers as files in ImageReady” on page 675 

“Exporting animation frames as files” on page 676 

To save a file in Targa format 
The Targa (TGA) format supports images of any dimensions with between 1 and 32 bits of color. It is designed for 

Truevision hardware, but it is also used in other applications. 

1	 Do one of the following: 

•	 (Photoshop) Choose File > Save As and choose Targa from the Format menu. 

•	 (ImageReady) choose File > Export > Original Document, and choose Targa from the Save As Type (Windows) 

or Format (Mac OS) menu. 

2	 Specify a file name and location, and click Save. 

3 In the Targa Options dialog box, select a resolution, select the Compress (RLE) option if you want to compress the 

file, and then click OK. 

See also 

“Targa” on page 685 

To save a file in TIFF format using Photoshop 
TIFF is a flexible raster (bitmap) image format supported by virtually all paint, image-editing, and page-layout appli

cations. 

1 Choose File > Save As, choose TIFF from the Format menu, and click Save. 

2 In the TIFF Options dialog box, select the options you want, and click OK. 

Image Compression Specifies a method for compressing the composite image data. 

Pixel Order Writes the TIFF file with the channels data interleaved or organized by plane. Previously, Photoshop 

always wrote TIFF files with the channel order interleaved. Theoretically, the Planar order file can be read and written 

faster, and offers a little better compression. Both channel orders are backward compatible with earlier versions of 

Photoshop. 

Byte Order Selects the platform on which the file can be read. This option is useful when you don’t know what 

program the file may be opened in. Photoshop and most recent applications can read files using either IBM PC or 

Macintosh byte order. 
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Save Image Pyramid Preserves multiresolution information. Photoshop does not provide options for opening 

multiresolution files; the image opens at the highest resolution within the file. However, Adobe InDesign and some 

image servers provide support for opening multiresolution formats. 

Save Transparency Preserves transparency as an additional alpha channel when the file is opened in another appli

cation. Transparency is always preserved when the file is reopened in Photoshop or ImageReady. 

Layer Compression Specifies a method for compressing data for pixels in layers (as opposed to composite data). 

Many applications cannot read layer data and skip over it when opening a TIFF file. Photoshop, however, can read 

layer data in TIFF files. Although files that include layer data are larger than those that don’t, saving layer data elimi

nates the need to save and manage a separate PSD file to hold the layer data. Choose Discard Layers And Save A Copy 

if you want to flatten the image. 

Note: To have Photoshop prompt you before saving an image with multiple layers, select Ask Before Saving Layered TIFF 

Files in the File Handling area of the Preferences dialog box. 

See also 

“TIFF” on page 685


“About file compression” on page 678


To save a file in TIFF format using ImageReady

1 Choose File > Export > Original Document, and choose TIFF from the Save As Type (Windows) or Format


(Mac OS) menu.


2 Specify a file name and location, and click Save.


3 Select a compression method, and click OK.


See also 

“TIFF” on page 685 

Exporting layers as files 

To export layers to files in Photoshop 
In Photoshop, you can export and save layers as individual files using a variety of formats, including PSD, BMP, JPEG, 

PDF, Targa, and TIFF. You can apply different format settings to individual layers, or one format to all exported 

layers. Layers are  named automatically  as  they  are saved. You  can set  options to control  the generation of names. All  

format settings are saved with your Photoshop document for convenience when you use this feature again. 

1 Choose File > Scripts > Export Layers To Files. 

2 In the Export Layers To Files dialog box, under Destination, click Browse to select a destination for the exported 

files. By default, the generated files are saved in the sample folder as the source file. 

3 Enter a name in the File Name Prefix text box to specify a common name for the files. 

4 Select the Visible Layers Only option if you want to export only those layers that have visibility enabled in the 

Layers palette. Use this option if you don’t want all the layers exported. Turn off visibility for layers that you don’t 

want exported. 
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5	 Choose a file format from the File Type menu. Set options as necessary.


6 Select  the Include  ICC Profile  option  if  you want the  working space  profile embedded in the  exported  file. This is 


important for color-managed workflows.


7 Click Run.


To export layers as files in ImageReady 
In ImageReady, you can export and save layers as individual files using a variety of formats, including PSD, GIF, 

JPEG, PNG, WBMP, and SWF. You can apply different format settings to individual layers, or one format to all 

exported layers. Layers are named automatically as they are saved. You can set options to control the generation of 

names. All format settings are saved with your ImageReady document for convenience when you use this feature 

again. 

1 Choose File > Export > Layers As Files. If you’re exporting only specific layers, select the layers in the Layers 

palette before you choose the Layers as Files command. 

Note: Click a layer in the Layers palette to select it. Shift-click to select a series of layers. Ctrl-click (Windows) or 

Command-click (Mac OS) to select noncontiguous layers. 

2 In the Export Layers As Files dialog box, under File Options, click Choose to select a destination for the exported 

files. 

3	 Enter a name in the Base Name text box to specify a common name for the files. 

Click the Set button to set up specific options for file naming. Choose elements from the pop-up menus or enter text 

into the fields to be combined into the default names for all files. Elements include layer name, document name, layer 

number, file creation date, punctuation, and file extension. 

4	 Specify how you want to save the files by choosing from the following options: 

•	 For Export, select the layers to be exported by choosing either All Layers, Top Level Layers And Layer Sets, or 

Selected Layers. The Selected Layers option is available only if you select layers before choosing the Layers As Files 

command. If your multilayered document has a Background layer, you can select the Include Background option 

to include it in the export. 

•	 For Layer, choose a layer from the Layer pop-up menu if you are using a separate format for each layer. You can 

also use the navigation buttons  to choose the layer. 

Note: Select the Preview option in the Export Layers As Files dialog box to preview the layer you choose. 

•	 For Apply, choose either One Format For All Layers or Separate Format For Each Layer. 

5 Under Format Options, either choose a setting from the Preset pop-up menu or manually set the file format and 

compression. 

If  you’re  using a separate  format  for each layer, choose another  layer and  then  set the  format  options.  Do  this  for all  

the subsequent layers you’re exporting. 

You can save a custom setting for reuse. Adjust the settings. The Unnamed option is automatically chosen in the 

Preset menu. Click the Save Current Layer Settings icon , name the new setting, and save it to the Optimized 

Settings folder. You can also delete a setting by choosing it from the Preset menu and clicking the Delete icon . 

6	 Click OK. 

See also 

“About file compression” on page 678 
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Exporting animation frames as files 

Exporting animation frames as files 
You can export and save animation frames as individual files in a variety of formats. In Photoshop, you can export


animation frames as files in PSD, BMP, JPEG, PDF, Targa, and TIFF formats. In ImageReady, you can export


animation frames as files in GIF, JPEG, PNG, WBMP, and SWF formats.


In ImageReady, you can assign different format settings to individual frames or one format to all exported frames.


Frames are named automatically as they are saved. You can set options to control the generation of names. All format


settings are saved with your ImageReady document for convenience when using the feature again.


To export animation frames as files in Photoshop

1 In the Animation palette, click the triangle to open the palette menu and choose Flatten Frames Into Layers.


2 In the Layers palette, make sure that only the layers created from animation frames are visible. If necessary, turn


off the visibility of the layers that were not created from the animation frames. This is important for exporting only


the animation frames.


3 Choose File > Scripts > Export Layers To Files.


4 In the Export Layers To Files dialog box, under Destination, click Browse to select a destination for the exported


files. By default, the generated files are saved in the same folder as the source file.


5 Enter a name in the File Name Prefix text box to specify a common name for the files.


6 Select the Visible Layers Only option to export layers that have visibility enabled in the Layers palette. Use this


option so that only the layers created from the animation frames are exported.


7 Choose a file format from the File Type menu. Set any options if necessary.


8 Select  the Include  ICC Profile  option  if  you want the  working space  profile embedded in the  exported  file. This is 


important for color-managed workflows.


9 Click Run.


To export animation frames as files in ImageReady

1 Choose File > Export > Animation Frames as Files. If you’re exporting only specific frames, select the frames in


the Animation palette before you choose the Animation Frames As Files command.


Click a frame in the Animation palette to select it. Shift-click to select a series of frames. Ctrl-click (Windows) or


Command-click (Mac OS) to select noncontiguous frames.


2 In the Export Animation Frames As Files dialog box, under File Options, click Choose to select a destination for


the exported files.


3 Enter a name in the Base Name text box to specify a common name for the files.


Click the Set button to set up specific options for file naming. Elements include document name, frame number, file


creation date, punctuation, and file extension.


4 If you selected frames in the Animation palette before choosing the Animation Frames As Files command, you


can enable the Selected Frames Only option to export only the frames you selected. Deselecting this option exports


all the frames in your animation regardless of whether you selected them or not.
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To preview the exported image for a specific frame, select the Preview option and then use either the Preview menu 

or navigation buttons to choose the frame to preview. 

5 Under Format Options, either choose a setting from the Preset pop-up menu or manually set the file format and 

compression. 

You can save a custom setting for reuse by clicking the Save Current Format Preset icon , naming the new setting, 

and saving it to the  Optimized Settings folder.  You can  also  delete  a setting  by  choosing  it  from  the Preset menu and  

then clicking the Delete Current Format Preset icon . 

6 Click OK. 

Exporting images in ZoomView format 

Exporting images in ZoomView format 
ZoomView is a format for delivering high-resolution images over the web. With the Viewpoint Media Player, users 

can zoom into or out of an image and pan the image to see its various parts. 

When you export an image in ZoomView format, Photoshop creates the following files: 

• An MTX file that defines the image to be displayed. 

• An HTML file that loads the Viewpoint Media Player and points to the MTX file. 

• A folder containing tiles that are used to display the image. 

• A folder containing VBS and JavaScript scripts that are used by the HTML file. 

To export an image in ZoomView format

1 Choose File > Export > ZoomView.


2 Set the following options, and click OK:


Template Specifies a template for generating the MTX, HTML, and auxiliary files. Choose a template (Plain or With


Instructions) from the pop-up menu, or click the Load button to choose a different ZoomView Template (ZVT) file.


You can download additional templates from the Viewpoint website.


Output Location Specifies an output location. Click Folder and enter a name in the Base Name text box to specify


a common name for the files.


Path to Broadcast License File Specifies a URL for the broadcast license file. The Viewpoint Corporation requires


that all publishers of ZoomView content acquire a broadcast license. To apply for a key, click Get License.


Image Tile Options Lets you select a tile size to control how many pixels are in each tile. ZoomView technology uses


image tiling to load only the part of a high-resolution image that a user wants see. A tile size of 128 is recommended


for small images; a tile size of 256 is recommended for large images. To specify an amount of compression for each


tile image, choose an option from the Quality menu, drag the Quality pop-up slider, or enter a value between 0 and


13 in the Quality text box. Select Optimize Tables to create enhanced JPEGs with slightly smaller file sizes. This


option is recommended for maximum file compression.


Browser Options Specifies a width and height for the image in the Viewpoint Media Player. Select Preview in


Browser to launch your default web browser and load the generated HTML file after you click OK.
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File formats 

About file formats 
Graphics file formats differ in the way they represent image data (as pixels or as vectors), in compression technique, 

and in which Photoshop and ImageReady features they support. With a few exceptions (for instance Large 

Document Format (PSB), Photoshop Raw, and TIFF), most file formats cannot support documents larger than 2 GB. 

Note: If a supported file format does not appear in the appropriate dialog box or submenu, you may need to install the 

format’s plug-in module. 

See also 

“Saving image files” on page 653 

“About optimization” on page 625 

“About plug-in modules” on page 69 

About file compression 
Many file formats use compression to reduce the file size of bitmap images. Lossless techniques compress the file 

without removing image detail or color information; lossy techniques remove detail. The following are commonly 

used compression techniques: 

RLE (Run Length Encoding) Lossless compression; supported by some common Windows file formats. 

LZW (Lemple-Zif-Welch) Lossless compression; supported by TIFF, PDF, GIF, and PostScript language file formats. 

Most useful for images with large areas of single color. 

JPEG (Joint Photographic Experts Group) Lossy compression; supported by JPEG, TIFF, PDF, and PostScript 

language file formats. Recommended for continuous-tone images, such as photographs. JPEG uses lossy 

compression. To specify image quality, choose an option from the Quality menu, drag the Quality pop-up slider, or 

enter a value between 0 and 12 (Photoshop) or 0 and 100 (ImageReady) in the Quality text box. For the best printed 

results, choose maximum-quality compression. JPEG files can be printed only on Level 2 (or later) PostScript 

printers and may not separate into individual plates. 

CCITT A family of lossless compression techniques for black-and-white images; supported by the PDF and 

PostScript language file formats. (CCITT is an abbreviation for the French spelling of International Telegraph and 

Telekeyed Consultive Committee.) 

ZIP Lossless compression; supported by PDF and TIFF file formats. Like LZW, ZIP compression is most effective for 

images that contain large areas of single color. 

PackBits (ImageReady) Lossless compression that uses a run-length compression scheme; supported by the TIFF 

file format in ImageReady only. 

Photoshop format (PSD) 
Photoshop format (PSD) is the default file format and the only format, besides the Large Document Format (PSB), 

that supports most Photoshop features. Because of the tight integration between Adobe products, other Adobe appli

cations such as Adobe Illustrator, Adobe InDesign, Adobe Premiere, Adobe After Effects, and Adobe GoLive can 

directly import PSD files and preserve many Photoshop features. For more information, see Help for the specific 

Adobe applications. 
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When saving a PSD, you can set a preference to maximize file compatibility. This saves a composite version of a 

layered image in the file so it can be read by other applications, including previous versions of Photoshop. It also 

maintains the appearance of blended layers in the future. 

In Photoshop, 16-bits-per-channel and high dynamic range 32-bits-per-channel images can be saved as PSD files. 

To maximize compatibility when saving files 
1 Choose Edit > Preferences > File Handling (Windows) or Photoshop > Preferences > File Handling (Mac OS). 

2 Choose Always from the Maximize PSD File Compatibility menu. This saves a composite (flattened) image along 

with the layers of your document. 

Note: If  file  size  is  an  issue or if you’re opening  your  files only in Photoshop, turning  off Maximize  PSD File Compatibility  

reduces the file sizes significantly. In the Maximize PSD File Compatibility menu, choose either Ask to be asked whether 

to maximize compatibility when you save or Never to save your document without maximizing compatibility. 

If you edit or save an image using an earlier version of Photoshop, unsupported features are discarded. 

Photoshop 2.0 format 
(Mac OS) You can use this format to open an image in Photoshop 2.0 or to export an image to an application 

supporting only Photoshop 2.0 files. Saving in Photoshop 2.0 format flattens your image and discards layer infor

mation. 

Adobe Digital Negative format (DNG) 
Adobe Digital Negative (DNG) is a file format that contains the raw image data from a digital camera and metadata 

that defines what the data means. DNG, Adobe’s publicly available, archival format for camera raw files, is designed 

to provide compatibility and decrease the current proliferation of camera raw file formats. The Adobe Camera Raw 

plug-in can save camera raw image data in the DNG format. For more information about the Adobe Digital Negative 

(DNG) file format, visit www.adobe.com and search on the term “Adobe Digital Negative.” You’ll find comprehensive 

information and a link to a user forum. 

See also 

“To save camera raw images in Camera Raw” on page 221 

BMP format 
BMP is a standard Windows image format on DOS and Windows-compatible computers. BMP format supports 

RGB, Indexed Color, Grayscale, and Bitmap color modes. You can specify either Windows or OS/2® format and a bit 

depth up to 32 bits per channel for the image. For 4-bit and 8-bit images using Windows format, you can also specify 

RLE compression. 

BMP images are normally written bottom to top; however, you can select the Flip Row Order option to write them 

from top to bottom. You can also select an alternate encoding method by clicking Advanced Modes. (Flip Row Order 

and Advanced Modes are most relevant to game programmers and others using DirectX.) 
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Photoshop EPS format 
Encapsulated PostScript (EPS) language file format can contain both vector and bitmap graphics and is supported 

by virtually all graphics, illustration, and page-layout programs. EPS format is used to transfer PostScript artwork 

between applications. When you open an EPS file containing vector graphics, Photoshop rasterizes the image, 

converting the vector graphics to pixels. 

EPS format supports Lab, CMYK, RGB, Indexed Color, Duotone, Grayscale, and Bitmap color modes, and does not 

support alpha channels. EPS does support clipping paths. Desktop Color Separations (DCS) format, a version of the 

standard EPS format, lets you save color separations of CMYK images. You use DCS 2.0 format to export images 

containing spot channels.To print EPS files, you must use a PostScript printer. 

Photoshop uses the EPS TIFF and EPS PICT formats to let you open images saved in file formats that create previews 

but are not supported by Photoshop (such as QuarkXPress®). You can edit and use an opened preview image just as 

any other low-resolution file. An EPS PICT preview is available only in Mac OS. 

Note: EPS TIFF format and EPS PICT format are more relevant to earlier versions of Photoshop. The current version of 

Photoshop includes rasterization features for opening files that include vector data. 

Photoshop DCS 1.0 and 2.0 formats 
Desktop Color Separations (DCS) format is a version of the standard EPS format that lets you save color separations 

of CMYK images. You can use DCS 2.0 format to export images containing spot channels. To print DCS files, you 

must use a PostScript printer. 

Cineon format 
Developed by Kodak, Cineon is a 10-bits-per-channel digital format suitable for electronic composition, manipu

lation, and enhancement. Using the Cineon format, you can output back to film with no loss of image quality. The 

format is used in the Cineon Digital Film System, which transfers images originated on film to the Cineon format 

and back to film. 

Filmstrip format 
Filmstrip format is used for RGB animation or movie files created by Adobe Premiere®. If you resize, resample, 

remove alpha channels, or change the color mode or file format of a Filmstrip file in Photoshop, you won’t be able to 

save it back to Filmstrip format. For further guidelines, see Adobe Premiere Help. 

GIF 
Graphics Interchange Format (GIF) is the file format commonly used to display indexed-color graphics and images 

in Hypertext Markup Language (HTML) documents over the World Wide Web and other online services. GIF is an 

LZW-compressed format designed to minimize file size and electronic transfer time. GIF format preserves trans

parency in indexed-color images; however, it does not support alpha channels. 

IFF 
IFF (Interchange File Format) is available through an optional plug-in. It is a general-purpose data storage format 

that can associate and store multiple types of data. IFF is portable and has extensions that support still-picture, sound, 

music, video, and textual data. The IFF format includes Maya IFF and IFF (formerly Amiga IFF). 
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JPEG format 
Joint Photographic Experts Group (JPEG) format is commonly used to display photographs and other continuous

tone images in hypertext markup language (HTML) documents over the World Wide Web and other online services. 

JPEG format supports CMYK, RGB, and Grayscale color modes, and does not support alpha channels. Unlike GIF 

format, JPEG retains all color information in an RGB image but compresses file size by selectively discarding data. 

A JPEG image is automatically decompressed when opened. A higher level of compression results in lower image 

quality, and a lower level of compression results in better image quality. In most cases, the Maximum quality option 

produces a result indistinguishable from the original. 

JPEG 2000 format (Photoshop optional plug-in) 
JPEG 2000 is a file format that provides more options and greater flexibility than the standard JPEG (JPG) format. 

Using JPEG 2000, you can produce images with better compression and quality for both web and print publishing. 

To save files in the JPEG 2000 format, you must locate the optional JPEG 2000 plug-in and install it in this location: 

Adobe Photoshop CS/Plug-Ins/Adobe Photoshop Only/File Formats. You can find the plug-in on the Photoshop CS 

installation CD in Goodies/Optional Plug-Ins/Photoshop Only/File Formats. 

Note: To view JPEG 2000 image files on the web, your browser must have a plug-in that enables viewing JPEG 2000 files. 

Unlike traditional JPEG files, which are lossy, the JPEG 2000 format supports optional lossless compression. The 

JPEG 2000 format also supports 16-bit color or grayscale files and 8-bit transparency, and it can retain alpha channels 

and spot channels. Grayscale, RGB, CMYK, and Lab are the only modes supported by the JPEG 2000 format. 

The JPEG 2000 format also supports using a region of interest (ROI) to minimize file size and preserve quality in 

critical regions of an image. By using an alpha channel, you can specify the area (ROI) where the most detail should 

be preserved, allowing greater compression and less detail in other regions. 

See also 

“About masks and alpha channels” on page 338 

Large Document Format 
The Large Document Format (PSB) supports documents up to 300,000 pixels in any dimension. All Photoshop 

features, such as layers, effects, and filters, are supported. You can save high dynamic range, 32-bits-per-channel 

images as PSB files. Currently, if you save a document in PSB format, it can be opened only in Photoshop CS or 

Photoshop CS2. Other applications and earlier versions of Photoshop cannot open documents saved in PSB format. 

Note: Most other applications and older versions of Photoshop cannot support documents with file sizes larger than 2 GB. 

The Enable Large Document Format (.psb) option must be enabled in Preferences before you can save documents 

in PSB format. There is one exception: it is possible to open an existing PSB file and save it in PSB format even if the 

Enable Large Document Format (.psb) option is not selected in Preferences. 

See also 

“Saving large documents” on page 655 
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OpenEXR format 
OpenEXR (EXR) is a file format used by the visual effects industry for high dynamic range images. The film format 

has high color fidelity and a dynamic range suitable for use in motion picture production. Developed by Industrial 

Light and Magic, OpenEXR supports multiple lossless or lossy compression methods. An OpenEXR film can contain 

an arbitrary number of channels, and the format supports both 16-bit and 32-bit images. 

PCX 
PCX format is commonly used by IBM PC-compatible computers. Most PC software supports version 5 of PCX 

format. A standard VGA color palette is used with version 3 files, which do not support custom color palettes. 

PCX format supports Bitmap, Grayscale, Indexed Color, and RGB color modes, and does not support alpha channels. 

PCX supports the RLE compression method. Images can have a bit depth of 1, 4, 8, or 24. 

PDF 
Portable Document Format (PDF) is a flexible, cross-platform, cross-application file format. Based on the PostScript 

imaging model, PDF files accurately display and preserve fonts, page layouts, and both vector and bitmap graphics. 

In addition, PDF files can contain electronic document search and navigation features such as electronic links. PDF 

supports 16-bits-per-channel images. Adobe Acrobat also has a Touch Up Object tool for minor editing of images in 

a PDF. For more information about working with images in PDFs, see Acrobat Help. 

Note: The Touch Up Object tool is mainly for last-minute revisions to images and objects. It’s best to do image editing in 

Photoshop before saving as PDF. 

Photoshop and ImageReady recognize two types of PDF files: Photoshop PDF files and Generic PDF files. You can 

open both types of PDF files; however, you can save images only to Photoshop PDF format. 

Photoshop PDF files Created using the Photoshop Save As command. Photoshop PDF files can contain only a 

single image. 

Photoshop PDF format supports all of the color modes (except Multichannel mode) and features that are supported 

in standard Photoshop format. Photoshop PDF also supports JPEG and ZIP compression, except for Bitmap-mode 

images, which use CCITT Group 4 compression. 

Generic PDF files Created using  applications  other than Photoshop, such as Adobe  Acrobat and  Adobe Illustrator.  

They can contain multiple pages and images. When you open a Generic PDF file, Photoshop rasterizes the image. 

PICT File 
PICT format is used in Mac OS graphics and page-layout applications as an intermediary file format for transferring 

images between applications. PICT format supports RGB images with a single alpha channel and Indexed Color, 

Grayscale, and Bitmap mode images without alpha channels. PICT format is especially effective for compressing 

images with large areas of solid color. This compression can be substantial for alpha channels with their large areas 

of white and black. 

When saving an RGB image in PICT format, you can choose either a 16-bit or 32-bit pixel resolution. For bitmap and 

grayscale images, you can choose from 2, 4, or 8 bits per pixel. In Mac OS with QuickTime installed, four JPEG 

compression options are available. 

Note: In ImageReady, PICT format is supported in Mac OS only. 
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PICT Resource 
(Mac OS) A PICT resource is a PICT file but takes a name and resource ID number. The PICT Resource format 

supports  RGB images with a single  alpha channel, and  Indexed Color, Grayscale, and  Bitmap  mode  images  without  

alpha channels. 

You can use the Import command or the Open command to open a PICT resource. When saving a file as a PICT 

resource, you can specify the resource ID and resource name. As with other PICT files, you also specify bit depth and 

compression options. 

Pixar format 
The Pixar format is designed specifically for high-end graphics applications, such as those used for rendering three

dimensional images and animation. Pixar format supports RGB and grayscale images with a single alpha channel. 

PNG format 
Developed as a patent-free alternative to GIF, Portable Network Graphics (PNG) format is used for lossless 

compression and for display of images on the web. Unlike GIF, PNG supports 24-bit images and produces 

background transparency without jagged edges; however, some web browsers do not support PNG images. PNG 

format supports RGB, Indexed Color, Grayscale, and Bitmap mode images without alpha channels. PNG preserves 

transparency in grayscale and RGB images. 

Portable Bit Map format 
The Portable Bit  Map (PBM)  file  format, also known  as  Portable  Bitmap  Library and  Portable  Binary  Map,  supports  

monochrome bitmaps (1 bit per pixel). The format can be used for lossless data transfer because many applications 

support this format. You can even edit or create such files within a simple text editor. 

The Portable Bit Map format serves as the common language of a large family of bitmap conversion filters including 

Portable FloatMap (PFM), Portable Graymap (PGM), Portable Pixmap (PPM), and Portable Anymap (PNM). While 

the PBM file format stores monochrome bitmaps, PGM additionally stores grayscale bitmaps, and PPM can also 

store color bitmaps. PNM is not a different file format in itself, but a PNM file can hold PBM, PGM, or PPN files. 

PFM is a floating-point image format that can be used for 32-bits-per-channel HDR files. 

QuickTime Movie format (ImageReady) 
QuickTime Movie format is a cross-platform format used for time-based data, such as video and audio. In 

ImageReady, you can save animations as QuickTime movies and open existing QuickTime movies as animations in 

order to optimize them for the web. 

Note: (Windows) QuickTime must be installed on your computer for the QuickTime Movie format to appear in the Files 

Of Type menu. When working in Photoshop, you must jump to ImageReady before saving a document (such as an 

animation) in QuickTime format. 

Photoshop Raw format 
The Photoshop Raw format is a flexible file format for transferring images between applications and computer 

platforms. This format supports CMYK, RGB, and grayscale images with alpha channels, and multichannel and Lab 

images without alpha channels. Documents saved in the Photoshop Raw format can be of any pixel or file size, but 

they cannot contain layers. 

 



684 ADOBE PHOTOSHOP CS2 
User Guide 

The Photoshop Raw format consists of a stream of bytes describing the color information in the image. Each pixel is 

described in binary format, with 0 representing black and 255 white (for images with 16-bit channels, the white value 

is 65535). Photoshop designates the number of channels needed to describe the image, plus any additional channels 

in the image. You can specify the file extension (Windows), file type (Mac OS), file creator (Mac OS), and header 

information. 

In Mac OS, the file type is generally a four-character ID that identifies the file—for example, TEXT identifies the file 

as an ASCII text file. The file creator is also generally a four-character ID. Most Mac OS applications have a unique 

file creator ID that is registered with the Apple Computer Developer Services group. 

The Header parameter specifies how many bytes of information appear in the file before actual image information 

begins. This value determines the number of zeroes inserted at the beginning of the file as placeholders. By default, 

there is no header (header size = 0). You can enter a header when you open the file in Raw format. You can also save 

the file without a header and then use a file-editing program, such as HEdit (Windows) or Norton Utilities® 

(Mac OS), to replace the zeroes with header information. 

You can save the image in an interleaved or noninterleaved format. If you choose interleaved, the color values (red, 

green, and blue, for example) are stored sequentially. Your choice depends on requirements of the application that 

will open the file. 

Note: A Photoshop Raw image is not in the same file format as a camera raw image file from a digital camera. A camera 

raw image file is in a camera-specific proprietary format that is essentially a “digital negative,” with no filtering, white 

balance adjustments, or other in-camera processing. 

See also 

“Saving large documents” on page 655 

Radiance format 
Radiance (HDR) is a 32-bits-per-channel file format used for high dynamic range images. This format was originally 

developed for the Radiance system, a professional tool for visualizing lighting in virtual environments. The file 

format stores the quantity of light per pixel instead of just the colors to be displayed on-screen. The levels of 

luminosity accommodated by the Radiance format are far higher than the 256 levels in 8-bits-per-channel image file 

formats. Radiance (HDR) files are often used in 3D modeling. 

Scitex CT 
Scitex Continuous Tone (CT) format is used for high-end image processing on Scitex computers. Contact Creo to 

obtain utilities for transferring files saved in Scitex CT format to a Scitex system. Scitex CT format supports CMYK, 

RGB, and grayscale images and does not support alpha channels. 

CMYK images saved in Scitex CT format often have extremely large file sizes. These files are generated for input 

using a Scitex scanner. Images saved in Scitex CT format are printed to film using a Scitex rasterizing unit, which 

produces separations using a patented Scitex halftoning system. This system produces very few moiré patterns and 

is often demanded in professional color work—for example, ads in magazines. 
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SWF (ImageReady) 
The Macromedia Flash (SWF) file format is used for playing animated compositions. The animated compositions 

can provide website interactivity and navigation. Any browsers with the Macromedia Flash Player plug-in can read 

the SWF format. Because the SWF format can save animations as vector images to maintain a small file size, it is a 

good choice for animations with solid areas of color and sharp object definitions. A SWF file can also contain raster 

(bitmap) images and QuickTime movies. However, raster images and QuickTime movies increase the size of a SWF 

file significantly. 

Keep these features of the SWF format in mind: 

•	 You can also choose a compression format for any embedded bitmap, such as JPEG, Indexed, and Truecolor. The 

default format for the embedded bitmaps in an SWF file is JPEG. Note, however, that bitmap objects usually 

increase the composition’s file size. 

•	 The SWF format supports solid-color backgrounds only. Gradients or textures applied to the background of a 

composition are exported as a backdrop object—a bitmap object that appears behind all the other objects in the 

composition. 

•	 The SWF format is a streaming format, and the composition plays as soon as a certain amount of the file has 

downloaded. 

Note: When working in Photoshop, you must jump to ImageReady before saving a document (such as an animation) in 

SWF format. 

Targa 
The Targa® (TGA) format is designed for systems using the Truevision® video board and is commonly supported by 

MS-DOS color applications. Targa format supports 16-bit RGB images (5 bits x 3 color channels, plus one unused 

bit), 24-bit RGB images (8 bits x 3 color channels), and 32-bit RGB images (8 bits x 3 color channels plus a single 8-bit 

alpha channel). Targa format also supports indexed-color and grayscale images without alpha channels. When saving 

an RGB image in this format, you can choose a pixel depth and select RLE encoding to compress the image. 

TIFF 
Tagged-Image File Format (TIFF, TIF) is used to exchange files between applications and computer platforms. TIFF 

is a flexible bitmap image format supported by virtually all paint, image-editing, and page-layout applications. Also, 

virtually all desktop scanners can produce TIFF images. TIFF documents have a maximum file size of 4 GB. 

Photoshop CS supports large documents saved in TIFF format. However, most other applications and older versions 

of Photoshop do not support documents with file sizes greater than 2 GB. 

TIFF format supports CMYK, RGB, Lab, Indexed Color, and Grayscale images with alpha channels and Bitmap 

mode images without alpha channels. Photoshop can save layers in a TIFF file; however, if you open the file in 

another application, only the flattened image is visible. Photoshop can also save annotations, transparency, and 

multiresolution pyramid data in TIFF format. 

In Photoshop, TIFF image files have a bit depth of 8, 16, or 32 bits per channel. You can save high dynamic range 

images as 32-bits-per-channel TIFF files. 

See also 

“Saving large documents” on page 655 
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WBMP format 
WBMP format is the standard format for optimizing images for mobile devices, such as cell phones. WBMP supports 

1-bit color, which means that WBMP images contain only black and white pixels. 

See also 

“Comparing web graphics formats” on page 632 

Displaying and adding file and image information 

About file information 
File information—also called metadata—is important in all types of publishing. For example, Photoshop supports 

the information standard developed by the Newspaper Association of America (NAA) and the International Press 

Telecommunications Council (IPTC) to identify transmitted text and images. This standard includes entries for 

descriptions, keywords, categories, credits, and origins. 

You can find file information in these sources: 

Adobe Bridge Displays metadata and keywords for a selected file. 

File Info dialog box Displays camera data (EXIF), file properties, description and keywords, edit history, and 

copyright and authorship information that has been added to the file. You can also add or modify keywords, a 

description, and copyright information. You can open the File Info dialog box either in Bridge or in Photoshop. 

Status bar Displays information, such as such as the current magnification and file size of the active image, and brief 

instructions for using the active tool. 

Info palette The Info palette displays information about the color values beneath the pointer and, depending on the 

tool in use, other useful measurements. In Photoshop, the Info palette also displays a hint for using a selected tool, 

document status information, and can display 8-bit, 16-bit, or 32-bit values. 

In addition, Photoshop automatically scans opened images for Digimarc watermarks. If a watermark is detected, a 

product copyright symbol appears in the image window’s title bar along with the information in the Copyright 

Status, Copyright Notice, and Owner URL sections of the File Info dialog box. 

In Windows and Mac OS, you can add file information to files saved in Photoshop, Large Document Format (PSB), 

TIFF, JPEG, EPS, and PDF formats. In Mac OS, you can also add file information to files in other Photoshop

supported formats except GIF. The information you add is embedded in the file using XMP (Extensible Metadata 

Platform). XMP provides Adobe applications and workflow partners with a common XML framework that 

standardizes the creation, processing, and interchange of document metadata across publishing workflows. When 

you save files from Photoshop that contain keywords, those keywords are not displayed in Adobe Acrobat’s 

Document Properties dialog box when the file is opened in Acrobat. 

Note: It’s possible to add metadata in ImageReady using the options in the Optimize palette. 

See also 

“About the Metadata panel in Bridge” on page 96 

“To add metadata using the File Info dialog box” on page 98 

“To set the History Log preferences” on page 693 
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“Metadata output options” on page 651 

“About the status bar” on page 32 

“About the Info palette” on page 55 

To read a Digimarc watermark

1 Choose Filter > Digimarc > Read Watermark. If the filter finds a watermark, a dialog box displays the creator ID,


copyright year (if present), and image attributes.


2 Click OK, or for more information, choose from the following:


•	 If you have a web browser installed, click Web Lookup to have more information about the owner of the image. 

This option launches the browser and displays the Digimarc website, where contact details appear for the given 

creator ID. 

•	 Call the phone number listed in the Watermark Information dialog box to get information faxed back to you. 

Annotating images 
You can attach note annotations (notes) and audio annotations to an image in Photoshop. This is useful for associ

ating review comments, production notes, or other information with the image. Because Photoshop annotations are 

compatible with Adobe Acrobat, you can use them to exchange information with Acrobat users as well as Photoshop 

users. 

To  circulate a Photoshop document for  review  in  Acrobat,  save  the document in Portable Document Format (PDF)  

and ask reviewers to use Acrobat to add notes or audio annotations. Then import the annotations into Photoshop. 

Notes and audio annotations appear as small nonprintable icons on the image. They are associated with a location 

on the image rather than with a layer. You can hide and show annotations, open notes to view or edit their contents, 

and play audio annotations. You can also add audio annotations to actions, and set them to play during an action or 

during a pause in an action. 

Adding notes and audio annotations 
You can add notes and audio annotations anywhere on a Photoshop image canvas. When you create a note, a 

resizable window appears for typing text. When you record an audio annotation, you must have a microphone 

plugged into the audio-in port of your computer. 

You can also import both kinds of annotations from Photoshop documents saved in PDF or from Acrobat 

documents saved in PDF or Form Data Format (FDF). 

If you need to delete the annotations in your document, select either the Notes or the Audio Annotation tool and 

click Clear All in the tool options bar. All notes and audio annotations are deleted from your document. 

See also 

“To delete notes and audio annotations” on page 689 
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To create a note 
When adding a note to your document, you can use the standard editing commands for your system (Undo, Cut, 

Copy, Paste, and Select All) to edit the text. (Windows) Right-click the text area and choose the commands from the 

context menu. (Mac OS) Choose the commands from the Edit and Select menus. You can also use standard keyboard 

shortcuts for these editing commands. 

1 Select the Notes tool


2 In the options bar, enter or specify the following as needed:


Author Specifies the author’s name, which appears in the title bar of the notes window.


. 

Size Chooses the size for the note text. 

Color Selects a color for the note icon and the title bar of note windows. Clicking the color box opens the Adobe 

Color Picker so you can select a color. 

3 Click where you want to place the note, or drag to create a custom-sized window. 

4 Click inside the window, and type the text. If you type more text than fits in the note window, the scroll bar 

becomes active. Edit the text as needed: 

If you have the required software for different script systems (for example, Roman, Japanese, or Cyrillic) installed on 

your computer, you can switch between the script systems. Right-click (Windows) or Control-click (Mac OS) to 

display the context menu, and then choose a script system. 

5 To close the note to an icon, click the close box. 

To create an audio annotation 
1 Make sure that your computer has a built-in microphone, or attach a microphone. 

2 Select the Audio Annotation tool 

3 In the options bar, enter or specify the following as needed: 

Author Specifies the author’s name, which appears in the tool tip when you place the pointer over the audio 

annotation icon in your document. 

. 

Color Selects a color for the audio annotation icon. Clicking the color box opens the Adobe Color Picker, from


which you select a color.


4 Click where you want to place the annotation icon.


5 Click Start and then speak into the microphone. When you finish, click Stop.


To import annotations

1 Choose File > Import > Annotations.


2 Select  a PDF  or  FDF file that contains annotations, and  then  click Load.  The annotations  appear  in  the locations 


where they were saved in the source document.


Opening and editing annotations 
A note or audio annotation icon marks the location of an annotation on an image. When you move the pointer over 

an annotation icon and pause, a message displays the author name. You use the icons to open notes or play audio 

annotations. You can show, hide, or move the icons and edit the contents of notes. 
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Note: Resizing an image does not resize the annotation icons and note windows. The icons and note windows keep their 

locations relative to the image. Cropping an image removes any annotations in the cropped area; you can recover the 

annotations by undoing the Crop command. 

To open a note or play an audio annotation 
❖ Double-click the icon: 

•	 If you are opening a note, a window appears, displaying the note text. 

•	 If you are playing an audio annotation and have a sound card installed, the audio file begins to play. 

To show or hide annotation icons 
❖ Do one of the following: 

•	 Choose View > Show > Annotations. 

•	 Choose View > Extras. This command also shows or hides grids, guides, selection edges, target paths, and slices. 

To edit annotations 
❖ Do any of the following: 

•	 To move an annotation icon, move the pointer over the icon until it turns into an arrow, and then drag the icon. 

You can do this with any tool selected. Moving a note icon does not move its note window. 

•	 To move a note window, drag it by the title bar. 

•	 To edit the contents of a note, open the note, change any options, and add, delete, or change the text. You can use 

the same editing commands that you use when creating a note. 

To delete notes and audio annotations 
❖ Do any of the following: 

•	 To delete a note or audio annotation, select either the Notes or the Audio Annotation tool, right-click (Windows) 

or Control-click (Mac OS) the Note or Audio Annotation icon in the image, and choose Delete Note or Delete 

Audio Annotation, or press the Delete key. 

•	 To delete all notes or audio annotations, select either the Notes or the Audio Annotation tool and click Clear All 

in the tool options bar. You can also select either the Notes or the Audio Annotation tool, right-click (Windows) 

or Control-click (Mac OS) the Note or Audio Annotation icon in the image, and choose Delete All Notes or Delete 

All Annotations from the context menu. 

Adding and viewing digital copyright information 

Adding digital copyright information 
You can add copyright information to Photoshop images and notify users that an image is copyright-protected via a 

digital watermark that uses Digimarc ImageBridge technology. The watermark—a digital code added as noise to the 

image—is virtually imperceptible to the human eye. The Digimarc watermark is durable in both digital and printed 

forms, surviving typical image edits and file format conversions. 
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Embedding a digital watermark in an image lets viewers obtain information about the creator of the image. This 

feature is particularly valuable to image creators who license their work to others. Copying an image with an 

embedded watermark also copies the watermark and any information associated with it. 

For more detailed information on embedding Digimarc digital watermarks, refer to the Digimarc website at 

www.digimarc.com. 

Before adding a digital watermark 
Keep in mind the following considerations before embedding a digital watermark in your image. 

Color variation The image must contain some degree of variation or randomness in color to embed the digital 

watermark effectively and imperceptibly. The image cannot consist mostly or entirely of a single flat color. 

Pixel dimensions The Digimarc technology requires a minimum number of pixels to work. Digimarc recommends 

the following minimum pixel dimensions for the image to be watermarked: 

•	 100 pixels by 100 pixels if you don’t expect the image to be modified or compressed prior to its actual use. 

•	 256 pixels by 256 pixels if you expect the image to be cropped, rotated, compressed, or otherwise modified after 

watermarking. 

• 750 pixels by 750 pixels if you expect the image to appear ultimately in printed form at 300 dpi or greater. 

There is no upper limit on pixel dimensions for watermarking. 

File compression In general, a Digimarc watermark will survive lossy compression methods such as JPEG, though 

it is advisable to favor image quality over file size (a JPEG compression setting of 4 or higher works best). In addition, 

the higher the Watermark Durability setting you choose when embedding the watermark, the better the chances that 

the digital watermark will survive compression. 

Workflow Digital watermarking should be one of the very last tasks you perform on an image, except for file 

compression. 

Use the following recommended workflow: 

•	 Make all necessary modifications to your image until you are satisfied with its final appearance (this includes 

resizing and color correction). 

•	 Embed the Digimarc watermark. 

•	 If needed, compress the image by saving it in JPEG or GIF format. 

•	 If the image is intended for printed output, perform the color separation. 

•	 Read the watermark and use the signal strength meter to verify that the image contains a watermark of sufficient 

strength for your purposes. 

•	 Publish the digital watermarked image. 

See also 

“Using the Watermark Durability setting” on page 691 
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To embed a watermark 
To embed a digital watermark, you must first register with Digimarc Corporation—which maintains a database of 

artists, designers, and photographers and their contact information—to get a unique Digimarc ID. You can then 

embed the Digimarc ID in your images, along with information such as the copyright year or a restricted-use 

identifier. 

1 Open the image that you want to watermark. You can embed only one digital watermark per image. The Embed 

Watermark filter won’t work on an image that has been previously watermarked. 

If you’re working with a layered image, you should flatten the image before watermarking it; otherwise, the 

watermark will affect the active layer only. 

Note: You can add a digital watermark to an indexed-color image by first converting the image to RGB mode, embedding 

the watermark, and then converting the image back to Indexed Color mode. However, the results may be inconsistent. 

To make sure that the watermark was embedded, run the Read Watermark filter. 

2 Choose Filter > Digimarc > Embed Watermark.


3 If you are using the filter for the first time, click the Personalize button. Get a Digimarc ID by clicking Info to


launch your web browser and visit the Digimarc website at www.digimarc.com, or by contacting Digimarc at the


telephone number listed in the dialog box. Enter your PIN and ID number in the Digimarc ID text box, and click OK.


After you enter a Digimarc ID, the Personalize button becomes a Change button, allowing you to enter a new


Digimarc ID.


4 Enter a copyright year, transaction ID, or image ID for the image.


5 Select any of the following image attributes:


Restricted Use Limits the use of the image.


Do Not Copy Specifies that the image should not be copied. 

Adult Content Labels the image contents as suitable for adults only. (Within Photoshop, this option does not limit 

access to adult-only images, but future versions of other applications may limit their display.) 

6 For Target Output, specify whether the image is intended for monitor, web, or print display. 

7 For Watermark Durability, drag the slider or enter a value, as described in the next section. 

8 Select Verify to automatically assess the watermark’s durability after it is embedded. 

9 Click OK. 

Using the Watermark Durability setting 
The default Watermark Durability setting is designed to strike a balance between watermark durability and visibility 

in most images. However, you can adjust the Watermark Durability setting yourself to suit the needs of your images. 

Low values are less visible in an image but less durable, and may be damaged by applying filters or by performing 

some image-editing, printing, and scanning operations. High values are more durable but may display some visible 

noise in the image. 

Your setting should depend on the intended use of the image and on the goals you’ve set for your watermarks. For 

example, it may be quite acceptable to use a higher Watermark Durability setting with JPEG images posted on a 

website. The higher durability helps to ensure the persistence of the watermark, and the increased visibility often is 

not noticeable with medium-resolution JPEG images. Digimarc recommends experimenting with various settings as 

part of your testing process to determine which setting works best for the majority of your images. 
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Using the signal strength meter 
The signal strength meter helps you determine whether a watermark is durable enough to survive the intended use 

of the image. The signal strength meter is available only for images containing digital watermarks that you yourself 

have embedded. 

Digimarc recommends that you check the signal strength meter before publishing your images. For example, if you 

often compress watermarked images for inclusion in a website, check the meter before posting the images. You can 

also use the signal strength meter to gauge the effectiveness of different Watermark Durability settings that you are 

experimenting with. 

To check the signal strength meter 
❖ Choose Filter > Digimarc > Read Watermark. The signal strength meter appears at the bottom of the dialog box. 

You can also display the meter automatically by selecting Verify while embedding the watermark. 

Preferences for saving files 

To set file saving preferences 
1 Do one of the following: 

• (Windows) Choose Edit > Preferences > File Handling. 

• (Mac OS) Choose Photoshop > Preferences > File Handling. 

2 Set the following options: 

Image Previews Choose an option for saving image previews: Never Save to save files without previews, Always 

Save to save files with specified previews, or Ask When Saving to assign previews on a file-by-file basis. In Mac OS, 

you can select one or more preview types. 

File Extension (Windows) Choose an option for the three-character file extensions that indicate a file’s format: Use 

Upper Case to append file extensions using uppercase characters, or Use Lower Case to append file extensions using 

lowercase characters. 

Append File Extension (Mac OS) File extensions are necessary for files that you want to use on or transfer to a 

Windows system. Choose an option for appending extensions to file names: Never to save files without file exten

sions, Always to append file extensions to file names, or Ask When Saving to append file extensions on a file-by-file 

basis. Select Use Lower Case to append file extensions using lowercase characters. 

To toggle the Append File Extension option for a single file, hold down Option when you choose a file format in the 

Save As dialog box. 

Mac OS image preview options 
In Mac OS, you can select one or more of the following preview types (to speed the saving of files and minimize file 

size, select only the previews you need). 

Icon Uses the preview as a file icon on the desktop. 

Full Size Saves a 72-ppi version of the file for use in applications that can open only low-resolution Photoshop 

images. For non-EPS files, this is a PICT preview. 
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Macintosh Thumbnail Displays the preview in the Open dialog box. 

Windows Thumbnail Saves a preview that Windows systems can display. 

To set the History Log preferences 
By default, history log data about each session is saved as metadata embedded in the image file. You can specify where 

the history log data is saved and the level of detail contained in the history log. 

1 Choose Edit > Preferences > General (Windows) or Photoshop > Preferences > General (Mac OS).


2 Specify where to save the history log data:


Metadata Saves the history log as metadata embedded in the file.


Text File Saves the history log to a text file. Select Text File. In the Save dialog box, browse to the destination, give 

the text file a name, and click Save. 

Both Saves the history log as metadata and in a text file. Select Both. In the Save dialog box, browse to the desti

nation, give the text file a name and click the Save button. 

3 Choose from the Edit Log Items menu to specify the level of detail in the history log: 

Sessions Only Records the start time and date of every editing session. Does not include any information about 

edits made to the file. 

Concise Records every editing session on the file (both start and end times), and also includes edits recorded in the 

History palette. 

Detailed Records the  same  information as the  Concise option,  plus  such  information as the  path  of  the file and  an  

account of every edit made to the file (including detailed edits not recorded in the History palette, such as preference 

changes). 

See also 

“About file information” on page 686 

“To add metadata using the File Info dialog box” on page 98 

Creating multiple-image layouts 

Creating contact sheets 
Contact sheets let you easily preview and catalog groups of images by displaying a series of thumbnails on a single 

page. You can automatically create and place thumbnails on a page using the Contact Sheet II command. 
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A contact sheet 

To create a contact sheet 
1 Do one of the following: 

•	 (Photoshop) Choose File > Automate > Contact Sheet II. 

•	 (Bridge) Select a folder of images or specific image files. From the Bridge menu, choose Tools > Photoshop > 

Contact Sheet II. Unless you select specific images, the contact sheet will include all the images currently displayed 

in Adobe Bridge. You can select a different image folder or select other currently open images after the Contact 

Sheet II dialog box opens. 

Note: Click to select an image in Bridge. Shift-click to select a series of images. Ctrl-click (Windows) or Command-click 

(Mac OS) to select noncontiguous images. 

2 In the Contact Sheet II dialog box, specify the images to use by choosing one of the following from the Use menu 

in the Source Images area: 

Current Open Documents Uses any image that is currently open in Photoshop. 

Folder Lets you click Browse (Windows) or Choose (Mac OS) to specify the folder containing the images you want 

to use. Select Include All Subfolders to include images inside any subfolders. 

Selected Images From Bridge Uses images displayed in Bridge. All images in Bridge are used unless you select 

specific images before choosing the Contact Sheet II command. Images in subfolders are not included. 

3 In the Document area, specify the dimensions, resolution, and color mode for the contact sheet. Select Flatten All 

Layers to create a contact sheet with all images and text on a single layer. Deselect Flatten All Layers to create a contact 

sheet in which each image is on a separate layer and each caption is on a separate text layer. 

4	 In the Thumbnails area, specify layout options for the thumbnail previews. 

•	 For Place, choose whether to arrange thumbnails across first (from left to right, then top to bottom) or down first 

(from top to bottom, then left to right). 

•	 Enter the number of columns and rows that you want per contact sheet. The maximum dimensions for each 

thumbnail are displayed to the right, along with a visual preview of the specified layout. 

•	 Select Use Auto-Spacing to let Photoshop automatically space the thumbnails in the contact sheet. If you deselect 

Use Auto-Spacing, you can specify the vertical and horizontal space around the thumbnails. The contact sheet 

preview in the dialog box is automatically updated as you specify the spacing. 

•	 Select Rotate For Best Fit to rotate the images, regardless of their orientation, so they fit efficiently on a contact 

sheet. 
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When Rotate For Best Fit is deselected, thumbnails appear in their correct orientation (left). When it is selected, the pictures are rotated to 
achieve the best fit (right). 

5 Select Use Filename As Caption to label the thumbnails using their source image file names. Use the menu to 

specify a caption font and font size. 

6	 Click OK. 

Creating picture packages 
With the Picture Package command, you can place multiple copies of a source image on a single page, much as 

portrait studios do with school photos and other photo packages. You also have the option of placing different images 

on the same page. You can choose from a variety of size and placement options to customize your package layout. 

A picture package layout 

To put multiple photos into a picture package 
1 Do one of the following: 

•	 (Photoshop) Choose File > Automate > Picture Package. If you have multiple images open, Picture Package uses 

the frontmost image. 

•	 (Bridge) Choose Tools > Photoshop > Picture Package. The Picture Package command uses the first image listed 

in Bridge unless you select a specific image before giving the Picture Package command. 

If you’re using only the frontmost image or a selected image from Bridge, skip to step 3. 

2	 Add one or more images to the layout by doing one of the following: 

•	 In the Source Images area of the Picture Package dialog box, choose either File or Folder from the Use menu and 

click Browse (Windows) or Choose (Mac OS). If you choose Folder, you can select Include All Subfolders to 

include images inside any subfolders. 

•	 Click a placeholder in the preview layout and browse to select an image. 
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Click a placeholder in the Picture Package preview layout, then browse to select an image. 

• Drag an image from the desktop or a folder into a placeholder. 

Add an image to a picture package by dragging the image from the desktop into a placeholder. 

You can change any image in the layout by clicking a placeholder and browsing to select an image. 

3 In the Document area of the Picture Package dialog box, select page size, layout, resolution, and color mode. A 

thumbnail of the chosen layout appears on the right side of the dialog box. You can also create your own custom 

layouts. 

4 Select Flatten All Layers to create a picture package with all images and label text on a single layer. Deselect Flatten 

All Layers to create a picture package with separate image layers and text layers (for labels). If you place each image 

and label  on  a separate layer, you  can update your picture  package after  it’s  been  saved.  However,  the layers increase  

the file size of your picture package. 

5 In the Label area, choose the source for label text from the Content menu or choose None. If you choose Custom 

Text, enter the text for the label in the Custom Text field. 

6 Specify font, font size, color, opacity, position, and rotation for the labels. 

7 Click OK. 
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To customize a picture package layout 
You can modify existing layouts or create new layouts using the Picture Package Edit Layout feature. Your custom 

layouts are  saved as text files  and stored in the  Layouts folder inside  the Presets  folder. You  can then reuse  your  saved  

layouts. The Picture Package Edit Layout feature uses a graphic interface that eliminates the need to write text files 

to create or modify layouts. 

1	 Do one of the following: 

•	 (Photoshop) Choose File > Automate > Picture Package. 

•	 (Bridge) Choose Tools > Photoshop > Picture Package. 

2 In the Picture Package dialog box, choose a layout from the Layout menu if you’re creating a layout or customizing


an existing one.


3 Click the Edit Layout button.


4 In the Picture Package Edit Layout dialog box, enter a name for the custom layout in the Name text box.


5 (Optional) In the Layout area of the Picture Package Edit Layout dialog box, choose a size from the Page Size menu


or enter values in the Width and Height text boxes. You can use the Units menu to specify inches, centimeters, pixels, 

or millimeters. 

Dragging a placeholder to a new location in the Picture Package layout 

6 In  the Grid area of the  Picture Package  Edit  Layout  dialog  box,  select  the Snap To option to display a grid to help  

you position the elements in the custom layout. Enter a value in the Size text box to change the appearance of the grid. 

7	 To add or delete a placeholder, do one of the following: 

•	 Click Add Zone to add a placeholder to the layout. 

• Select a placeholder and click Delete Zone to delete it from the layout. 

8 To modify a placeholder, select a placeholder and do one of the following: 

•	 Enter values in the Width and Height text boxes to resize a placeholder. 

•	 Click and drag a handle to resize a placeholder. If you resize a rectangle placeholder with an image in it, Picture 

Package will snap the image within the vertical or horizontal placeholder, depending on the way the zone is being 

resized. 

•	 Enter values in the X and Y text boxes to move a placeholder. 

•	 Enter values in the Position and Size text boxes to position and size a placeholder. 

• Click and drag a placeholder to the location you want in the layout. 

9 Click Save. 
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Creating a PDF presentation 

Creating a PDF presentation 
The PDF Presentation command lets you use a variety of images to create a multipage document or slide show 

presentation. You can set options to maintain image quality in the PDF, specify security settings, and set the 

document to open automatically as a slide show. 

A 

B 

C 

PDF presentation as a slide show 
A. First slide B. Wipe Left transition C. Second slide 

To create a PDF presentation 
1 Do one of the following: 

•	 (Photoshop) Choose File > Automate > PDF Presentation. 

•	 (Bridge) Select the images you want to use and Choose Tools > Photoshop > PDF Presentation. If you don’t select 

the images you want to use, the presentation will contain all the images currently displayed in Bridge. 

Note: Click a file to select it. Shift-click to select a series of files. Ctrl-click (Windows) or Command-click (Mac OS) to 

select noncontiguous files. 

2 In the PDF Presentation dialog box, click Browse and navigate to add files to the PDF presentation. Select the Add 

Open Files option to add files already open in Photoshop. 

You can remove any unwanted file by selecting it in the Source Files window and clicking the Remove button. 

The files in the Source Files window are used to generate the pages in the PDF presentation, starting with the topmost 

file  for the  first page and  progressing down the  list  for subsequent pages. To  change  the sequence,  select  the file and  

drag it to a new position Source Files window. 

Note: If  you want a file  to  appear  more  than  once  in  your  PDF presentation,  select  the file and  click the  Duplicate button.  

You can then drag the duplicate file to the desired location in the Source Files window. 
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Dragging a file to a new position in the list 

3 In the Output Options area of the PDF Presentation dialog box, select from the following options:


Multi-Page Document Creates a PDF document with the images on separate pages.


Presentation Creates a PDF slide show presentation.


4 If  you selected Presentation as the  Output  Option, in the  Presentation  Options area,  you can  specify the  following 


options:


Advance Every [5] Seconds Specifies how  long  each  image is displayed  before  the presentation advances to the  next 


image. The default duration is 5 seconds.


Loop After Last Page Specifies that the presentation automatically starts over after reaching the end. Deselect this


option to stop the presentation after the final image is displayed.


Transition Specifies the transition when moving from one image to the next. Choose an transition from the


Transition menu.


5 Click Save.


6 In  the Save dialog box, enter  a name for  the PDF  presentation, select a destination for  the saved  file, and  then  click 


Save.


7 In the Save Adobe PDF dialog box, choose an Adobe PDF preset or specify save options for the PDF document.


8 Click Save PDF. Photoshop  closes  the Save Adobe  PDF dialog box  and creates  the PDF  presentation. A dialog  box 


appears telling you whether the PDF presentation was successfully created.


See also 

“About file compression” on page 678 

“To save a file in Photoshop PDF format” on page 657 
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Placing Photoshop images in other applications 

Placing Photoshop images in other applications 
Photoshop provides a number of features to help you use images in other applications. Because of the tight 

integration between Adobe products, many Adobe applications can directly import Photoshop (PSD) format files 

and use Photoshop features like layers, layer styles, masks, transparency, and effects. Additionally, programs such as 

Adobe GoLive can  use variables  set in ImageReady and  Photoshop (topmost text layer  only) when creating multiple  

iterations of an image. 

See also 

“About variables” on page 748 

To prepare images for page-layout programs 
How you prepare an image for a page-layout program depends upon the file formats the program recognizes: 

•	 Adobe InDesign 2.0 and later can place Photoshop PSD files. You do not need to save or export your Photoshop 

image to a different file format. Transparent areas are displayed and printed as expected. 

•	 Most other page-layout programs require you to save the image as a TIFF or EPS file. However, if the image 

contains fully transparent areas, you must first define those areas using a clipping path. Check the documentation 

for your page-layout program to determine the best format for importing Photoshop images. 

If the page-layout program cannot place Photoshop PSD files, follow these steps: 

1 If your image contains a transparent background or areas that you want to be transparent, create a clipping path 

around the opaque areas of the image. Even if you have deleted the background around the image, you must define 

the area with a clipping path before converting the file to TIFF or EPS format. Otherwise, areas that are transparent 

may appear as white in the page-layout program. 

2	 Choose File > Save As. 

3 In  the Save As dialog box, choose the  appropriate format from the  Format  menu. The  format  you choose depends  

upon the final output for the document. For printing to non-PostScript printers, choose TIFF. For printing to 

PostScript printers, choose Photoshop EPS. Then click Save. 

4 In the TIFF Options or EPS Options dialog box, set the following options. Leave any remaining options at their 

default setting, and click OK. 

•	 TIFF Options dialog box: set Image Compression to None. 

•	 EPS Options dialog box (Windows): set Preview to TIFF (8 bits/pixel) and Encoding to ASCII85. 

•	 EPS Options dialog box (Mac OS): set Preview to Mac (8 bits/pixel) and Encoding to ASCII85. 

If the layout program displays transparent areas as white, try printing the document. Some layout programs do not 

display clipping paths properly but print them as expected. 
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To use Photoshop artwork in Adobe Illustrator 
Adobe Illustrator can both open or place Photoshop files; you do not need to save or export your Photoshop image 

to a different file format. If you place an image into an open Illustrator file, you can incorporate the image as if it were 

any other element in the artwork, or you can maintain a link to the original file. Although you can’t edit a linked 

image within Illustrator, you can jump back to Photoshop, using the Edit Original command, to revise it. Once saved, 

any changes you make are reflected in the version in Illustrator. 

1 If the image file is open in Photoshop, save it as a Photoshop (PSD) file, and close the file. 

2 In Adobe Illustrator, do one of the following: 

•	 To open the file directly in Illustrator, choose File > Open. Locate the image in the Open File dialog box, and 

click OK. 

•	 To  incorporate the  image into an existing Illustrator  file, choose File  >  Place.  Locate  the file in the  Place dialog box,  

make sure the Link option is not selected, and click OK. 

•	 To place the image into a file but maintain a link to the original, choose File > Place. In the Place dialog box, locate 

the file, select the Link option, and click OK. Illustrator centers the image in the open illustration. A red X through 

the image indicates it is linked and not editable. 

3 If  you opened or placed the  image without  linking, the  Photoshop Import dialog box  appears.  Choose  the appro

priate option as follows, and click OK: 

•	 Convert Photoshop Layers To Objects to convert the layers to Illustrator objects. This option preserves masks, 

blending modes, transparency, and (optionally) slices and image maps. However, it does not support Photoshop 

adjustment layers and layer effects. 

•	 Flatten Photoshop Layers To A Single Image to merge all the layers into a single layer. This option preserves the 

look of the image, but you can no longer edit individual layers. 

Using image clipping paths to create transparency 
You can use image clipping paths to define transparent areas in images you place in page-layout applications. 

In addition, Mac OS users can embed Photoshop images in many word-processor files. 

For assistance with image clipping paths, choose Help > Export Transparent Image. This interactive wizard helps you 

prepare images with transparency for export to a page-layout application. 

You may want to use only part of a Photoshop image when printing it or placing it in another application. For 

example, you may want to use a foreground object and exclude the background. An image clipping path lets you 

isolate the foreground object and make everything else transparent when the image is printed or placed in another 

application. 

Image imported into Illustrator or InDesign without image clipping path (left), and with image clipping path (right) 
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See also 

“To save a path as an image clipping path” on page 702 

To save a path as an image clipping path 
1 Draw a work path that defines the area of the image you want to show. 

Note: Paths are vector-based; therefore, they have hard edges. You cannot preserve the softness of a feathered edge, such 

as in a shadow, when creating an image clipping path. 

2 In the Paths palette, save the work path as a path.


3 Choose Clipping Path from the Paths palette menu, set the following options, and click OK:


•	 For Path, choose the path you want to save. 

•	 For Flatness, leave the flatness value blank to print the image using the printer’s default value. If you experience 

printing errors, enter a flatness value to determine how the PostScript interpreter approximates the curve. The 

lower the flatness value, the greater the number of straight lines used to draw the curve and the more accurate 

the curve. Values can range from 0.2 to 100. In general, a flatness setting from 8 to 10 is recommended for high

resolution printing (1200 dpi to 2400 dpi), and a setting from 1 to 3 for low-resolution printing (300 dpi to 600 

dpi). 

4	 If you plan to print the file using process colors, convert the file to CMYK mode. 

5	 Save the file by doing one of the following: 

•	 To print the file using a PostScript printer, save in Photoshop EPS, DCS, or PDF format. 

•	 To print the file using a non-PostScript printer, save in TIFF format and export to Adobe InDesign, or to Adobe 

PageMaker® 5.0 or later. 

See also 

“About work paths” on page 450 

“To prepare images for page-layout programs” on page 700 

“To convert a selection to a path” on page 468 

“Converting an image to another mode” on page 234 

Printing image clipping paths 
Sometimes an imagesetter cannot interpret image clipping paths, or an image clipping path is too complex for a 

printer, resulting in a Limitcheck error or a general PostScript error. Sometimes you can print a complex path on a 

low-resolution printer without difficulty but run into problems when printing the same path on a high-resolution 

printer. This is because the lower-resolution printer simplifies the path, using fewer line segments to describe curves 

than the high-resolution printer does. 

You can simplify an image clipping path in the following ways: 

•	 Manually reduce the number of anchor points on the path. 

•	 Increase the tolerance setting used to create the path. To do this, load the existing path as a selection, choose Make 

Work Path from the Paths palette menu, and increase the tolerance setting (4 to 6 pixels is a good starting value). 

Then re-create the image clipping path. 
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See also 

“To delete an anchor point” on page 466 

“To convert a path to a selection border using the current settings” on page 467 

To export paths to Adobe Illustrator 
The Paths To Illustrator command lets you export Photoshop paths as Adobe Illustrator files. Exporting paths in this


way simplifies the task of combining Photoshop and Illustrator artwork or using Photoshop features with Illustrator


artwork. For example, you may want to export a pen tool path and stroke it to use as a trap with a Photoshop clipping


path you are printing in Illustrator. You can also use this feature to align Illustrator text or objects with Photoshop


paths.


1 Draw and save a path or convert an existing selection into a path.


2 Choose File > Export > Paths To Illustrator.


3 Choose a location for the exported path, and enter a file name. Make sure Work Path is chosen in the Write menu


to export the path.


4 Click Save.


5 Open the file in Adobe Illustrator. You can manipulate the path or use the path to align Illustrator objects that you


add to the file.


Note that the crop marks in Adobe Illustrator reflect the dimensions of the Photoshop image. The position of the


path within the Photoshop image is maintained, provided you don’t change the crop marks or move the path.


Object linking and embedding (OLE) (Windows only) 
Photoshop is an OLE 2.0 server, which means it supports embedding or linking an image in an OLE container appli

cation (usually a word-processing or page-layout program). For example, you can insert Photoshop files and selec

tions into other OLE applications such as Adobe PageMaker, Adobe FrameMaker, and Microsoft Word using copy 

and paste or other methods. 

•	 Linking lets you place a link in the OLE container file that refers to the Photoshop file on the hard drive. 

•	 Embedding lets you insert the Photoshop file into the OLE container file. 

After the image is in the container application, you can double-click it for editing in Photoshop. When you close the 

image in Photoshop, it is updated in the container application. 

To link or embed a selection or image in an OLE application 
❖ Do one of the following: 

•	 Copy a selection in Photoshop, and insert it in your OLE container application using the application’s Paste Special 

command. Refer to your word-processing or page-layout application documentation for more instructions. Pasted 

selections can only be embedded, not linked. 

•	 Use your OLE container application’s Insert Object command to insert a new Photoshop image or existing 

Photoshop file as an OLE-embedded or OLE-linked object. Refer to your word-processing or page-layout appli

cation documentation for instructions. 
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To insert an unlinked screen-resolution bitmap into an OLE application 
❖ With the Move tool , drag a selection to the OLE container application. When you drop the object, it appears 

as a 72-ppi bitmap, which cannot be automatically updated in Photoshop. 

To modify and update a linked or embedded image in an OLE application

1 Double-click the linked or embedded image in your word-processing or page-layout application to start


Photoshop (if it is not already running), and open the image for editing.


2 Modify the image as desired.


3 Do one of the following:


• For embedded images, close the file, or choose File > Update or File > Close & Return to [application name]. 

• For linked images, save and close the file. 

Note: You can also modify linked files without first opening the container document. The linked image is updated the 

next time you open the document in its OLE container application. 

Saving images for use in video and motion graphics 

Saving images for use in video 
In addition to supporting square pixel images, Photoshop supports nonsquare pixel images, allowing you to create 

documents that are displayed properly on devices such as video monitors. Use the preset file sizes in the Preset menu 

of the New file dialog box to create images at a size and pixel aspect ratio that compensates for scaling when the 

images are incorporated into video. The presets also create a document with nonprinting guides that delineate the 

action-safe and title-safe areas of the image. Using the preset file sizes, you can produce images for specific video 

systems—NTSC, PAL, or HDTV. 

To help you create images for video, Photoshop has a Pixel Aspect Ratio Correction viewing mode that displays your 

image at a specific aspect ratio. For more accurate previews, Photoshop also has a Video Preview command that lets 

you immediately preview your document on a display device, such as a video monitor. To use this feature, you must 

have the device connected to your computer via FireWire. See also “To preview your document on a video monitor” 

on page 708. 

When using a computer to create a document for video, keep in mind that an image on a computer monitor is made 

up of pixels that are essentially square. Video monitors display analog images, which do not not involve pixel shape. 

Nonsquare pixels are most commonly used by encoding devices for video. When importing an image created by a 

square-pixel graphics program into a video-editing program like Adobe Premiere, the square pixels are scaled to the 

nonsquare pixels for video encoding. This scaling results in a distorted image. 
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A 

B 

C 

Pixel aspect ratio scaling 
A. Square pixel image viewed on a computer monitor B. Square pixel image viewed on a video monitor C. Same image with the correct 
pixel aspect ratio viewed on a video monitor 

Also keep these considerations in mind when creating images for use in video: 

•	 Video-editing applications, such as Adobe Premiere, do not support 16-bits-per-channel images. 

•	 Some video-editing applications can import an individual layer from a multilayer Photoshop (PSD) file. 

•	 If your Photoshop image file has transparency, some video applications, such as Adobe Premiere, preserve it. 

•	 If your file uses a layer mask or multiple layers, you might not have to flatten the layers, but you might want to 

include a flattened copy of the PSD file in the PSD format to maximize backward compatibility. In this way, you 

will be able to import your Photoshop file successfully into video-editing applications such as Adobe Premiere. 

Photoshop provides actions that are useful for creating images for video. The actions automate tasks such as 

constraining the luminance range and saturation levels in an image to comply with broadcast standards, resizing and 

converting an image to nonsquare pixels for used in DVD slide shows (NTSC and PAL, standard and widescreen aspect 

ratios), creating an alpha channel from all currently visible layers, adjusting image areas that are likely to cause interlace 

flicker, and generating a title-safe overlay. 

To create images for use in video 
1 Create a new document. 

2 In the New dialog box, choose the appropriate preset from the Preset menu for the video system on which the 

image will be shown. 
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Video preset file size guides
A. Action safe area (outer rectangle) B. Title safe area (inner rectangle)

For more options, click the Advanced button  to specify a color profile and specific pixel aspect ratio.

Important: By default, nonsquare pixel documents open with Pixel Aspect Ratio Correction enabled. This scales the

image as it would look on the nonsquare-pixel output device (usually a video monitor).

3 (Optional) Choose View > Pixel Aspect Ratio Correction to turn off the scaling correction and view the image as

it displays on a computer (square pixel) monitor.

A circle in a NTSC DV 720 x 480 document viewed on a (square pixel) computer monitor with Pixel Aspect Ratio Correction turned on (top)
and Pixel Aspect Ratio Correction turned off (bottom)

You can simultaneously view an image with the Pixel Aspect Ratio Correction turned on and turned off. With the

nonsquare pixel image open and Pixel Aspect Ratio Correction enabled, choose Window > Arrange > New Window

for [name of document]. With the new window active, choose View > Pixel Aspect Ratio Correction to turn the

correction off.

4 If you have a display device, such as a video monitor, connected to your computer via FireWire, do one of the

following to preview your document on the device:

• To set output options before viewing your image on the device, choose File > Export > Video Preview.

• To view your image immediately on the device without setting any output options, choose File > Export > Send

Video Preview To Device.

A

B
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See also 

“To preview your document on a video monitor” on page 708 

To add images to a nonsquare pixel document 
❖ Do one of the following: 

• Copy and paste an image. 

• Drag an image from another document window. 

• Choose File > Place, select the file you want to place, and click the Place button. 

Photoshop automatically converts and scales the image to the pixel aspect ratio of the nonsquare pixel document. 

Images brought in from Adobe Illustrator are also properly scaled. 

See also 

“To create a new image” on page 191 

To assign a pixel aspect ratio value to an existing document 
❖ With the square pixel document open, choose Image > Pixel Aspect Ratio and select a pixel aspect ratio.


To create a custom pixel aspect ratio

1 With a document open, choose Image > Pixel Aspect Ratio > Custom Pixel Aspect Ratio.


2 In  the Save Pixel  Aspect  Ratio dialog box, enter  a value  in  the Factor text box, name the  custom  pixel aspect ratio, 


and click OK.


The new  custom  pixel aspect ratio  will  appear  in  the both the  Pixel Aspect Ratio  menu  of  the New  dialog  box and  in 


the Pixel Aspect Ratio submenu of the Image menu.


To delete a pixel aspect ratio

1 With a document open, choose Image > Pixel Aspect Ratio > Delete Pixel Aspect Ratio.


2 In the Delete Pixel Aspect Ratio dialog box, choose the option you want to delete from the Pixel Aspect Ratio


menu and click Delete.


To reset the pixel aspect ratios

1 With a document open, choose Image > Pixel Aspect Ratio > Reset Pixel Aspect Ratios.


2 In the dialog box, choose one of the following:


Append Replaces the current pixel aspect ratios with the default values plus any custom pixel aspect ratios. This


option is useful if you deleted a default value and want to restore it to the menu but also want to retain any custom


values.


Cancel Cancels the command. 

OK Replaces the current pixel aspect ratios with the default values. Custom pixel aspect ratios are discarded. 
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Saving images for use in motion graphics 
You can save images in Photoshop for use in motion graphics software such as Adobe After Effects. A Photoshop 

(PSD) file can be imported directly into an After Effects project with the option of preserving individual layers, layer 

styles, transparent areas and layer masks, and adjustment layers. Importing layers makes it easy to prepare still images 

for animation. 

You can reduce the rendering times and problems in After Effects by doing the following: 

•	 Organize and name layers. If you change a layer name or delete a layer in a Photoshop document after you have 

imported it into After Effects, After Effects will not be able to find the renamed or deleted layer. The After Effects 

Project window lists that layer as missing. 

•	 Make sure that each layer has a unique name, because After Effects manages layers by their names. Duplicate layer 

names can cause problems when you update footage. 

•	 If you want to import a composited version of a layered Photoshop file along with a layered version, choose Always 

for Maximize PSD File Compatibility in the File Handling Preferences dialog box. 

If you are creating a Photoshop file for export to After Effects for use in a video project, use one of the file size presets 

for video in the New File dialog box. 

To preview your document on a video monitor 
The Video Preview plug-in lets you preview your Photoshop document through FireWire on a display device, such 

as a video monitor. You can also adjust the aspect ratio for proper display of images. The Video Preview plug-in 

supports RGB, grayscale, and indexed images, either 8 or 16 bits per channel. (The plug-in converts 16-bits-per-

channel images to 8-bits-per-channel images.) The Video Preview plug-in does not support alpha channels. Trans

parency is displayed as black. 

Note: The Video Preview plug-in does not lock the display device. When Photoshop goes into the background on your 

computer and another application is brought into the foreground, the preview turns off and the device is unlocked so 

other applications can use it for preview purposes. 

1 Connect a display device, such as a video monitor, to your computer via FireWire. 

2 With a document open in Photoshop, do one of the following: 

•	 If you don’t want to set output options for viewing your document on a device, choose File > Export > Send Video 

Preview To Device. You can skip the rest of the steps in this procedure. 

•	 To set output options before viewing your document on the device, choose File > Export > Video Preview. 

The Video Preview dialog box opens. You see an alert if your document’s pixel aspect ratio doesn’t match the aspect 

ratio settings of the display device. 

Note: The Send Video Preview To Device command uses the previous settings in the Video Preview dialog box. 

3	 Under Device Settings, specify options for the device that will display the image: 

•	 (Mac OS only) To specify an output mode, select NTSC or PAL. If the output mode and the device do not match 

(for example, specifying NTSC for the output mode and connecting to a device in PAL mode), black patches 

appear on previewing. 

•	 To specify the aspect ratio of the display device, choose either Standard (4:3) or Widescreen (16:9) from the Aspect 

Ratio menu. 

Note: The Aspect Ratio setting determines which Placement options are available. 
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4 Under Image Options, choose a Placement Option to determine how the image appears in the display device: 

Center Places the center of the image at the center of the screen, cropping the portions that fall outside the display 

edges of the video preview device. 

Pillarbox Displays a 4:3 image on a 16:9 display with the center of the image at the center of the screen and gray 

bands on the left and right sides of the image. This option is available only if you chose Widescreen (16:9) for the 

device aspect ratio. 

Crop to 4:3 Displays a 16:9 image on a 4:3 display with the center of the image at the center of the screen and without 

distortion by cropping the left and right edges of the frame that fall outside the display edges of the video preview 

device. This option is available only if you chose Standard (4:3) for the device aspect ratio. 

Letterbox Scales a 16:9 image to fit on a 4:3 display. Gray bands appear on the top and bottom of the image due the 

difference in aspect ratio between the 16:9 image and the 4:3 display. This maintains the display aspect ratio without 

cropping or distorting the image. This option is available only if you chose Standard (4:3) for the device aspect ratio. 

Crop To 14:9/Letterbox Displays a widescreen image cropped to a 14:9 aspect ratio with black bands on the top and 

bottom of the image. This maintains the display aspect ratio without distorting the image. This option is available 

only if you chose Standard (4:3) for the device aspect ratio. 

5 Choose an option from the Image Size menu to control whether the document pixels are scaled to the device 

display: 

Do Not Scale Applies no vertical scaling to the image. The image is cropped if its height is greater than that of the 

video display. 

Scale To Fit Within Frame Increases or decreases the image height and width proportionally to fit in the video 

frame. With this option, a 16:9 image appears on a 4:3 display as letterbox, and a 4:3 image appears on a 16:9 display 

as pillarbox. 

6 Select the Apply Pixel Aspect Ratio To Preview check box to display the image using the document’s (nonsquare) 

pixel aspect ratio. Deselect this option to display the image as it appears on your computer (square pixel) monitor. 

By default, the Apply Pixel Aspect Ratio To Preview check box is selected to maintain the image’s pixel aspect ratio. 

In general, you would deselect this option if the document’s pixel aspect ratio is assumed to be square and you want 

to view the image as it would appear on a computer (square pixel) monitor. 

7 Click OK to export the document to the device display. 
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Chapter 24: Printing


Printing from Photoshop 

About printing 
Printing is the process of sending your image to an output device. You can print on paper or film (positive or 

negative), to a printing plate, or directly to a digital printing press. Whether you are printing an image on your 

desktop printer or sending it to a prepress facility, knowing a few basics about printing makes the print job go more 

smoothly and helps ensure that the finished image appears as intended. 

Types of printing For many Photoshop users, printing a file means sending the image to an inkjet printer. 

Photoshop can send your image to a variety of devices to be printed directly onto paper or converted to a positive or 

negative image on film. In the latter case, you can use the film to create a master plate for printing by a mechanical 

press. 

Types of images The simplest images, such as line art, use only one color in one level of gray. A more complex 

image, such as a photograph, has varying color tones. This type of image is known as a continuous-tone image. 

Halftoning To create the illusion of continuous tones in images, printers break images down into dots. For photos 

printed on a printing  press,  this  process is called  halftoning. Varying the sizes of the dots in a halftone screen creates 

the optical illusion of variations of gray or continuous color in the image. 

Note: Although inkjet printers also use dots to create the illusion of continuous tones, those dots are of uniform size and 

much smaller than the dots used by most printing presses. 

Color separation Artwork intended for commercial reproduction and containing more than one color must be 

printed on separate master plates, one for each color. This process, called color separation, generally calls for the use 

of cyan, yellow, magenta, and black (CMYK) inks. In Photoshop, you can adjust how the various plates are generated. 

Quality of detail The detail in a printed image depends on its resolution and screen frequency. The higher the 

resolution of an output device, the finer (higher) a screen ruling (lines per inch) you can use. Many inkjet printer 

drivers offer simplified print settings for higher quality printing. 

About desktop printing 
Unless you work in a commercial printing company or service bureau, you probably print images on a desktop 

printer, such as an inkjet, dye sublimation, or laser printer, and not to an imagesetter. Photoshop lets you control how 

your image is printed. 

 



711 ADOBE PHOTOSHOP CS2 
User Guide 

Monitors display images using light, whereas desktop printers reproduce images using inks, dyes, or pigments. For 

this reason, a desktop printer can’t reproduce all the colors displayed on a monitor. However, by incorporating certain 

procedures (such as a color management system) into your workflow, you can achieve predictable results when 

printing your images on a desktop printer. Keep these considerations in mind when working with an image that you 

intend to print: 

•	 If your image is in RGB mode, do not convert the document to CMYK mode when printing to a desktop printer. 

Work entirely in RGB mode. As a rule, desktop printers are configured to accept RGB data and use internal 

software to convert to CMYK. If you send CMYK data, most desktop printers apply a conversion anyway, with 

unpredictable results. 

•	 If you want to preview an image as printed on any device for which you have a profile, use the Proof Colors 

command. 

•	 To reproduce screen colors accurately on the printed page, you must incorporate color management into your 

workflow. Work with a monitor that is calibrated and characterized. You should also create a custom profile specif

ically for your printer and the paper you print on. Using the profile supplied with your printer (although better 

than using no profile at all) yields only mediocre results. 

See also 

“Soft-proofing colors” on page 259 

“About color profiles” on page 263 

Printing images 
Photoshop provides the following printing commands: 

Page Setup and Print Display options specific to your printer, printer drivers, and operating system. 

Print With Preview Displays Photoshop’s printing, output, and color management options. 

Print Online Allows you to send your print file directly to an online service that will do the printing for you. 

Print One Copy Prints one copy of a file without displaying a dialog box. 

Note: You cannot print images directly from ImageReady. If you have an image open in ImageReady and need to print 

it, use  the Edit In Photoshop  command to open the  image in Photoshop. Keep in mind that ImageReady images open at  

screen resolution (72 ppi); this resolution may not be high enough to produce a high-quality print. 

To print an image with current options 
❖ Do one of the following: 

•	 Choose File > Print, and click Print or OK. 

•	 To print one copy of a file without displaying a dialog box, choose File > Print One Copy. 

Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 
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To set printer and page setup options 
1 Choose File > Page Setup, or File > Print. 

2 Select a printer from the pop-up menu. 

3 Set additional options, such as paper size and layout, as desired. The available options depend on your printer, 

printer drivers, and operating system. 

If you plan to scale the printed image, choose Print With Preview and use the scaling options in the Print dialog box 

rather than the Page Setup dialog box. The Print dialog box is more helpful because it shows you a preview of the 

scaled image. Also, you don’t want to set the scaling options in both the Page Setup and Print dialog boxes. This 

applies scaling twice, and the resulting image may not be printed at the intended size. 

To set Photoshop print options 
1 Choose File > Print With Preview. 

A 

C 

D 

B 

Print With Preview dialog box 
A. Preview print B. Position and scale image C. Specify options to prepare a file for prepress D. Specify the document’s working space and 
choose a color management profile for printing on a desktop printer 

2 Make sure that More Options is selected (if it is, the Fewer Options button is displayed). Then do one or more of 

the following: 

• Adjust the position and scale of the image in relation to the selected paper size and orientation. 

• Set Output and Color Management options from the pop-up menu. 

3 Do one of the following: 

• Click Print to print the image. 

• Click Cancel to close the dialog box without saving the options. 

• Click Done to preserve the options and close the dialog box. 

• Hold down Alt (Windows) or Option (Mac OS) and click Print One to print one copy of the image. 
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•	 Hold down Alt (Windows) or Option (Mac OS) and click Reset to reset the print options. 

•	 Hold down Alt (Windows) or Option (Mac OS) and click Remember to save the print options without closing the 

dialog box. 

Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 

To preview the current image position and options 
•	 Position the pointer over the file information box (at the bottom of the application window in Windows or the 

document window in Mac OS) and hold down the mouse button. 

Positioning and scaling images 
You can adjust the position and scale of an image and preview how the image will be printed on the selected paper 

using the Print With Preview command. The shaded border at the edge of the paper represents the margins of the 

selected paper; the printable area is white. 

The base output size of an image is determined by the document size settings in the Image Size dialog box. Scaling 

an image in the Print With Preview dialog box changes the size and resolution of the printed image only. For example, 

if you scale a 72-ppi image to 50% in the Print With Preview dialog box, the image will print at 144 ppi; however, the 

document size settings in the Image Size dialog box will not change. 

Many printer drivers, such as AdobePS and LaserWriter, provide a scaling option in the Page Setup dialog box. This 

scaling affects everything on the page, including the size of all page marks such as crop marks and captions, whereas 

the scaling percentage provided by the  Print With Preview  command  affects only the  size  of  the printed  image (and  

not the size of page marks). 

Note: The Print With Preview command may not reflect accurate values for Scale, Height, and Width if you set a scaling 

percentage in the Page Setup dialog box. To avoid inaccurate scaling, specify scaling using the Print With Preview 

command rather than the Page Setup command; do not enter a scaling percentage in both dialog boxes. 

See also 

“Adjusting image size and resolution” on page 182 

To reposition an image on the paper 
1 Choose File > Print With Preview, and do one of the following: 

•	 Select Center Image to center the image in the printable area. 

•	 Deselect Center Image and then enter values for Top and Left to position the image numerically. 

•	 Deselect Center Image, and drag the image in the preview area. 

To scale the print size of an image 
1 Choose File > Print With Preview, and do one of the following: 

•	 Click Scale To Fit Media to fit the image within the printable area of the selected paper. 

•	 With Scale To Fit Media deselected, enter values for Height and Width to rescale the image numerically. 

•	 Select Show Bounding Box, and drag a bounding box handle in the preview area to achieve the desired scale. 
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To print part of an image

1 Use the Rectangle Marquee tool to select the part of an image you want to print.


2 Choose File > Print With Preview, select Print Selected Area, and click Print.


Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 

To print vector data 
If an image includes vector graphics, such as shapes and type, Photoshop can send the vector data to a PostScript 

printer. When you choose to include vector data, Photoshop sends the printer a separate image for each type layer 

and each vector shape layer. These additional images are printed on top of the base image, and clipped using their 

vector outline. Consequently, the edges of vector graphics print at the printer’s full resolution, even though the 

content of each layer is limited to the resolution of your image file. 

1 Choose File > Print With Preview. 

2 Make  sure  that  More  Options is selected (if  it  is, Fewer  Options is displayed),  and choose Output from the  pop-up  

menu. 

3 Select the Include Vector Data option. If necessary, you can select an encoding algorithm (ASCII, ASCII85, Binary, 

or JPEG) from the Encoding pop-up menu. This allows you to choose the way the data is saved and how much disk 

space it requires. If Include Vector Data is dimmed, your image doesn’t contain vector data. 

4 Click Print. 

Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 

Printing with color management 

To have your printer manage colors when printing 
If you don’t have a custom profile for your printer and paper type, you can let the printer driver handle the color 

conversion. See “Letting the printer determine colors when printing” on page 261. 

1 Choose File > Print With Preview. 

2 Make sure that More Options is selected (if it is, the Fewer Options button is displayed), and that Color 

Management is selected in the pop-up menu. 
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Click the More Options button to display options for prepress and color management 

3 In the Print area, select Document. The profile is displayed in parentheses on the same line. 

4 In the Options area, for Color Handling, choose Let Printer Determine Colors. 

5 (Optional) Choose a rendering intent for converting colors to the destination color space. Most non-PostScript 

printer drivers ignore this option and use the Perceptual rendering intent. (For more information, see “About 

rendering intents” on page 271.) 

6 Access the color management options for the printer driver from the second print dialog box, which automatically 

appears after you click Print. In Windows, click the Properties button to access the printer driver options. In Mac OS, 

use the pop-up menu from the second Print dialog box to access the printer driver options. 

For inkjet printer drivers, color management options are usually labeled ColorSync (Mac OS) or ICM (Windows). 

7 Specify the color management settings to let your printer driver handle the color management during printing. 

Every printer driver has different color management options. If it’s not clear how to turn on color management, 

consult your printer documentation. 

8 Click Print. 

Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 

See also 

“Printing with color management” on page 261 

To have Photoshop manage colors when printing 
If you have a custom color profile for a specific printer, ink, and paper combination, letting Photoshop manage colors 

may produce better results than letting the printer manage colors. See “Letting the application determine colors when 

printing” on page 262. 

1 Choose File > Print With Preview. 

2 Make sure that More Options is selected (if it is, the Fewer Options button is displayed) and that Color 

Management is selected in the pop-up menu. 
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3 In the Options area, for Color Handling, choose Let Photoshop Determine Colors. 

4 For Printer Profile, select the profile for your output device. 

The more accurately the profile describes the behavior of the output device and printing conditions (such as paper 

type), the more accurately the color management system can translate the numeric values of the actual colors in a 

document. (See “Obtaining custom profiles for desktop printers” on page 262.) 

5 (Optional) Set any of the following options. In most cases, it is best to use the default settings. 

Rendering Intent Specifies how Photoshop converts colors to the destination color space. (See “About rendering 

intents” on page 271.) 

Black Point Compensation Preserves the shadow detail in the image by simulating the full dynamic range of the 

output device. 

6 Access the color management options for the printer driver from the second print dialog box, which automatically 

appears after you click Print. In Windows, click the Properties button to access the printer driver options. In Mac OS, 

use the pop-up menu from the second Print dialog box to access the printer driver options. 

For inkjet printer drivers, color management options are usually labeled ColorSync (Mac OS) or ICM (Windows). 

7 Turn off color management for the printer so that the printer profile settings don’t override your profile settings. 

Every printer driver has different color management options. If it’s not clear how to turn off color management, 

consult your printer documentation. 

8 Click Print. 

Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 

See also 

“Printing with color management” on page 261 

To print a hard proof 
A hard proof (sometimes called a proof print or match print) is a printed simulation of what your final output on a 

printing press will look like. A hard proof is produced on an output device that’s less expensive than a printing press. 

Some inkjet printers have the resolution necessary to produce inexpensive prints that can be used as hard proofs. 

1 Choose View > Proof Setup, and select the output conditions you want to simulate. You can do this using a preset 

or by creating a custom proof setup. (See “To soft-proof colors” on page 259.) 

The view changes automatically according to the proof you chose, unless you chose Custom. In this case, the 

Customize Proof Condition dialog box appears. You must save custom proof settings for them to appear in the Proof 

Setup Preset menu of the Print With Preview dialog box. Follow the instructions to customize a proof. 

2 After you select a proof, choose File > Print With Preview. 

3 Make sure that More Options is selected (if it is, the Fewer Options button is displayed) and that Color 

Management is selected in the pop-up menu. 

4 In  the Print  area, select Proof. The  profile that appears  in  parentheses,  should  match the  proof setup  you selected  

earlier. 
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5 In the Options area, for Color Handling, choose Let Photoshop Determine Colors.


6 For Printer Profile, select the profile for your output device.


7 (Optional) Set any of the following options. In most cases, it is best to use the default settings.


Rendering Intent Specifies how Photoshop converts colors to the destination color space. When printing a hard


proof, you should choose either Absolute Colorimetric or Relative Colorimetric. (See “About rendering intents” on


page 271.)


Proof Setup Preset This  option  is  available if you  select  Proof from the  Print area.  From  the pop-up menu,  choose 


any customized proofs that exist locally on your hard drive.


Simulate Paper Color Simulates what colors look like on the paper of the simulated device. Using this option


produces the most accurate proof, but it is not available for all profiles.


Simulate Black Ink Simulates the brightness of dark colors of the simulated device. Using this option results in more


accurate proofs of dark colors, but it is not available for all profiles.


8 Access the color management options for the printer driver from the second print dialog box, which automatically


appears after you click Print. In Windows, click the Properties button to access the printer driver options. In Mac OS,


use the pop-up menu from the second Print dialog box to access the printer driver options.


For inkjet printer drivers, color management options are usually labeled ColorSync (Mac OS) or ICM (Windows). 

9 Turn off color management for the printer so that the printer profile settings don’t override your profile settings. 

Every printer driver has different color management options. If it’s not clear how to turn off color management, 

consult your printer documentation. 

10 Click Print. 

Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 

To print targets for creating custom profiles 
A target is a document you use when creating a custom profile. Generally, a target document with swatches is


supplied as part of a third-party color management software package. You print this document with all color


management turned off in both Photoshop and the printer driver. The third-party measuring instrument reads or


scans the printed target to create the custom profile.


1 Open the color target document in Photoshop.


2 Choose File > Print With Preview.


3 Make sure that More Options is selected (if it is, the Fewer Options button is displayed) and that Color


Management is selected in the pop-up menu that appears below.


4 In the Print area, select Document. The profile is displayed in parentheses on the same line.


5 In the Options area, from the Color Handling pop-up menu, choose No Color Management. When this option is


selected, Photoshop sends the RGB numbers in the file to the printer without conversion.


6 Access the color management options for the printer driver from the second print dialog box, which automatically


appears after you click Print. In Windows, click the Properties button to access the printer driver options. In Mac OS,


use the pop-up menu from the second Print dialog box to access the printer driver options.
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For inkjet printer drivers, color management options are usually labeled ColorSync (Mac OS) or ICM (Windows). 

7	 Turn off color management for the printer so that the printer profile settings don’t override your profile settings. 

Every printer driver has different color management options. If it’s not clear how to turn off color management, 

consult your printer documentation. 

8	 Click Print. 

Note: If you get a warning that your image is larger than the paper’s printable area, click Cancel, choose File > Print With 

Preview,  and select the  Scale To Fit  Media box. Click  Page  Setup to make any  changes to your paper  size  and layout,  and  

attempt to print the file again. 

Printing images to a commercial printing press 

Preparing images for press 
From Photoshop, you can prepare image files for offset lithography, digital printing, gravure, and other commercial 

printing processes. 

Generally, your workflow depends on the capabilities of the prepress facility. Before you begin a workflow for 

commercial printing, contact the prepress staff to learn their requirements. For example, they may not want you to 

convert to CMYK at any point because they may need to use prepress-specific settings. Here are some possible 

scenarios for preparing your image files to achieve predictable printing results: 

•	 Work entirely in RGB mode and make sure that the image file is tagged with the RGB working space profile. If 

your printer or prepress staff use a color management system, they should be able to use your file’s profile to make 

an accurate conversion to CMYK before producing the film and printing plates. 

•	 Work in RGB mode until you finish editing your image. Then convert the image to CMYK mode and make any 

additional color and tonal adjustments. Especially check the highlights and shadows of the image. Use the Levels, 

Curves, or Hue/Saturation command to make corrections. These adjustments should be very minor. Then send 

the CMYK file to the professional printer. 

•	 Place your RGB or CMYK image in Adobe InDesign or Adobe Illustrator. In general, most images printed on a 

commercial press are not printed directly from Photoshop but from a page-layout program like Adobe InDesign 

or a print-savvy program like Adobe Illustrator. For more information on importing Photoshop files into Adobe 

InDesign or Adobe Illustrator, see Adobe InDesign Help or the Adobe Illustrator Help. 

Here are a few issues to keep in mind when you work on an image intended for commercial printing: 

•	 If you know the characteristics of the press, you can specify the highlight and shadow output to preserve certain 

details. 

•	 If you use a desktop printer to preview the appearance of the final printed piece, keep in mind that a desktop 

printer cannot faithfully replicate the output of a commercial printing press. A professional color proof gives a 

more accurate preview of the final printed piece. 

•	 If you have a profile from commercial press, you can choose it with the Proof Setup command and then view a soft 

proof using the Proof Colors command. Use this method to preview the final printed piece on your monitor. 

Note: Some printers may prefer to receive your documents in PDF format, especially if the documents need to conform 

to PDF/X standards. See “To save a file in Photoshop PDF format” on page 657. 
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See also 

“Soft-proofing colors” on page 259 

Specifying prepress options 
The Print With Preview command includes options for preparing an image for output to an imagesetter or plate

setter. Among these are options for specifying page marks, halftone attributes, color channels as separate pages, and 

print encoding method. Generally, these output options should be specified only by prepress professionals or people 

knowledgeable about the commercial printing process. 

Setting output options 
If you are preparing your images for commercial printing directly from Photoshop, you can select and preview a 

variety of page marks and other output options using the Print With Preview command. 

177lpi 45o 

magenta black 

C DBA 

carnival series 

Olé No Moire  

cyan yellow

E F G H 

Page marks 
A. Gradient tint bar B. Label C. Registration marks D. Progressive color bar E. Corner crop mark F. Center crop 
mark G. Description H. Star target 

To set output options 
1 Choose File > Print With Preview. 

2 Select More Options (it is already selected if Fewer Options is displayed), and choose Output from the pop-up 

menu. 

Note: Options not supported by the designated printer are dimmed. 

3 Set one or more of the following options: 

Background Selects a background color to be printed on the page outside the image area. For example, a black or 

colored background may be desirable for slides printed to a film recorder. To use this option, click Background, and 

then select a color from the color picker. This is a printing option only; it does not affect the image itself. 

Border Prints a black border around an image. Type a number and choose a unit value to specify the width of the 

border. 
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Bleed Prints crop marks inside rather than outside the image. Use this option to trim the image within the graphic. 

Type a number and choose a unit value to specify the width of the bleed. 

Screen Sets the screen frequency and dot shape for each screen used in the printing process. 

Transfer Adjusts the transfer functions, traditionally used to compensate for dot gain or dot loss that may occur 

when an image is transferred to film. This option is recognized only when you print directly from Photoshop, or 

when you save the file in EPS format and print to a PostScript printer. Generally, it’s best to adjust for dot gain using 

the settings in the CMYK Setup dialog box. Transfer functions are useful, however, when compensating for a poorly 

calibrated output device. 

Interpolation Reduces the jagged appearance of a low-resolution image by automatically resampling up while 

printing. However, resampling may reduce the sharpness of the image quality. Some PostScript Level 2 (or higher) 

printers have interpolation capability. If your printer doesn’t, this option has no effect. 

Calibration Bars Prints an 11-step grayscale, a transition in density from 0 to 100% in 10% increments. With a 

CMYK color separation, a gradient tint bar is printed to the left of each CMYK plate, and a progressive color bar to 

the right. 

Note: Calibration bars, registration marks, crop marks, and labels are printed only if the paper is larger than the printed 

image. 

Registration Marks Prints registration marks on the image (including bull’s-eyes and star targets). These marks are 

used primarily for aligning color separations. 

Corner Crop Marks Prints crop marks where the page is to be trimmed. You can print crop marks at the corners. 

Center Crop Marks Prints crop marks where the page is to be trimmed. You can print crop marks at the center of 

each edge. 

Description Prints any description text entered in the File Info dialog box up to about 300 characters. Description 

text is always printed in 9-point Helvetica plain type. See “About file information” on page 686. 

Labels Prints the file name above the image. 

Emulsion Down Makes type readable when the  emulsion  is  down—that is,  when  the photosensitive layer  on  a piece  

of film or photographic paper is facing away from you. Normally, images printed on paper are printed with emulsion 

up, with type readable when the photosensitive layer faces you. Images printed on film are often printed with 

emulsion down. 

Negative Prints an inverted version of the entire output, including all masks and any background color. Unlike the 

Invert command in the Image menu, the Negative option converts the output, not the on-screen image, to a negative. 

If you print separations directly to film, you probably want a negative, although in many countries film positives are 

common. Check with your print shop to determine which is required. To determine the emulsion side, examine the 

film under a bright light after it has been developed. The dull side is the emulsion; the shiny side is the base. Check 

whether your print shop requires film with positive emulsion up, negative emulsion up, positive emulsion down, or 

negative emulsion down. 

See also 

“Resampling” on page 182 
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Selecting halftone screen attributes 
Halftone screen attributes include the screen frequency and dot shape for each screen used in the printing process. 

For color separations, the prepress person must also specify an angle for each of the color screens. Set the screens at 

different angles to ensure that the dots placed by the four screens blend into continuous color and do not produce 

moiré patterns. 

Halftone screens consist of dots that control how much ink is deposited at a specific location on-press. Varying their 

size and density creates the illusion of variations of gray or continuous color. For a process color image, four halftone 

screens are used: cyan, magenta, yellow, and black—one for each ink used in the printing process. 

45 

0 

Halftone screen with black ink 

105 90 75 

45 

0 

Halftone screens with process ink at different screen angles; correctly registered dots form rosettes. 

In traditional print production, a halftone is produced by placing a halftone screen between a piece of film and the


image and then exposing the film. In Photoshop, you specify the halftone screen attributes just before producing the


film or paper output. For best results, your output device (a PostScript imagesetter, for example) should be set to the


correct density limit, and your processor should be properly calibrated; otherwise, results can be unpredictable.


Before creating your halftone screens, check with your print shop for preferred frequency, angle, and dot settings.


(Use the default angle settings unless your print shop specifies changes.)


To define the attributes of a halftone screen

1 Choose File > Print With Preview.


2 Select  More  Options (it  is  already selected if Fewer  Options is displayed),  choose  Output  from  the pop-up menu, 


and click Screen.


3 In the Halftone Screens dialog box, choose whether to generate your own screen settings:


•	 Deselect Use Printer’s Default Screens to choose your own screen settings. 

•	 Select  Use Printer’s  Default Screens  to  use the  default halftone screen built  into  the printer. Photoshop  then  ignores  

the specifications in the Halftone Screens dialog box when it generates the halftone screens. 

4 For a grayscale halftone, enter a screen frequency from 1 to 999.999, and choose a unit of measurement. Enter a 

screen angle from –180 to +180 degrees. 
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5	 For a color separation, choose from the following options: 

•	 To have Photoshop determine and enter the best frequencies and angles for each screen, click Auto. In the Auto 

Screens dialog box, enter the resolution of the output device and the screen frequency you intend to use, and 

click OK. Photoshop enters the values in the Halftone Screens dialog box. Changing these values may result in 

moiré patterns. 

•	 If you are using a PostScript Level 2 (or higher) printer or an imagesetter equipped with an Emerald controller, 

make sure that the Use Accurate Screens option is selected in the Auto Screens dialog box (or in the Halftone 

Screens dialog box, if you’re entering the values manually). The Use Accurate Screens option lets the program 

access the correct angles and halftone screen frequencies for high-resolution output. If your output device is not a 

PostScript Level 2 (or higher) printer or is not equipped with an Emerald controller, this option has no effect. 

6 For Shape, choose the  dot shape  you want.  If  you want all  four  screens to use  the same dot  shape,  select  Use Same  

Shape For All Inks. 

Choosing Custom from the Shape menu displays the Custom Spot Function dialog box. You can define your own 

dot shapes by entering PostScript commands—useful for printing with nonstandard halftone algorithms. For infor

mation about using PostScript language commands, see the PostScript Language Reference published by Addison-

Wesley, or consult the imagesetter’s manufacturer. 

For optimal output on a PostScript printer, the image resolution should be 1.5 to 2 times the halftone screen 

frequency. If the resolution is more than 2.5 times the screen frequency, an alert message appears. If you are printing 

line art or printing to a non-PostScript printer, see your printer documentation for the appropriate image resolutions 

to use. 

7	 Click OK. 

See also 

“Pixel dimensions and image resolution” on page 178 

To save or load halftone screen settings 
❖ In the Halftone Screens dialog box, do one of the following: 

•	 To save settings, click Save. Choose a location for the saved settings, enter a file name, and click Save. 

•	 To load settings, click Load. Locate and select the settings, and click Load. 

Printing color separations 
When preparing your image for prepress and working with CMYK images or images with spot colors, you can print 

each color channel as a separate page. 
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Pantone 7453 C 

Each color channel printed as a separate page 

Note: If you are printing an image from another application and want to print spot channels to spot color plates, you 

must first save the file in DCS 2.0 format. DCS 2.0 preserves spot channels. This format is supported by applications such 

as Adobe InDesign and QuarkXPress. 

See also 

“To save a file in Photoshop EPS format” on page 669 

To print separations from Photoshop 
1 Make sure that your document is in CMYK Color or Multichannel mode, and then choose File > Print With 

Preview. 

2 Select More Options (it is already selected if Fewer Options is displayed), and choose Color Management from the 

pop-up menu. 

3 Choose Separations from the Color Handling pop-up menu. 

Note: Depending on the designated printer and printer drivers on your computer, these options may also appear in the 

Print dialog box (for setting printer options). In Windows, click the Properties button to access the printer driver options; 

in Mac OS, use the pop-up menu in the second Print dialog box that appears. 

4 Click Print. Separations are printed for each of the colors in the image. 

To prepare an image with spot channels for printing from another application 
1 If the image is a duotone, convert it to Multichannel color mode. 

2 Save the image in DCS 2.0 format. 

3 In the DCS 2.0 Format dialog box, deselect the Include Halftone Screen and the Include Transfer Function 

options. 

4 Open or import the image in Photoshop, and set your screen angles. Make sure that you’ve communicated to the 

printer the spot color you want for each of the color plates. 

Note: You can place a PSD file containing spot colors directly in InDesign without special preparation. 

See also 

“To save a file in Photoshop EPS format” on page 669 
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Choosing a print encoding method 
By default, the printer driver transfers binary information to PostScript printers; however, you can choose to transfer


image data using JPEG or ASCII85 encoding. (ASCII85 is a text-encoding method for binary data; it is more


compact than ASCII encoding.) These options are not available for non-PostScript printers, including many inkjet


printers.


Because JPEG-encoded files are smaller than binary files, they take less time to print; however, using JPEG encoding


decreases image quality. Only PostScript Level 2 (or higher) printers support JPEG encoding; if you send a JPEG


encoded file to a PostScript Level 1 printer, you may get PostScript language errors.


Some print spooler programs, computer networks, and third-party printer drivers don’t support binary files or JPEG


encoded files. Also, some PostScript output devices accept binary and JPEG-encoded image data only through their


AppleTalk and Ethernet ports, not their parallel or serial ports. In these situations, you can select the ASCII85


encoding method. However, ASCII85 files contain about twice as many characters and take twice as long to transfer


as binary files.


To change the encoding method

1 Choose File > Print With Preview.


2 Select More Options (it is already selected if Fewer Options is displayed), and choose Output from the pop-up


menu.


3 Select an option from the Encoding menu.


Creating color traps 
A trap is  an  overlap that prevents tiny gaps in the  printed image  caused  by  a slight  misregistration on press. Contact  

your service provider before you do any trapping. In most cases, your print shop determines whether trapping is 

needed. If so, the print shop staff will tell you what values to enter in the Trap dialog box. 

A. B. 

A B 

Trapping to correct misalignment 
Misregistration with no trap Misregistration with trap 
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Trapping is intended to correct the misalignment of solid colors. In general, you don’t need traps for continuous-tone 

images such as photographs. Excessive trapping may produce an outline effect. These problems may not be visible 

on-screen and might show up only in print. Photoshop uses standard rules for trapping: 

• All colors spread under black. 

• Lighter colors spread under darker colors. 

• Yellow spreads under cyan, magenta, and black. 

• Pure cyan and pure magenta spread under each other equally. 

To create a trap

1 Save  a version  of  the file in RGB  mode, in case you  want  to  reconvert the  image later. Then choose Image  > Mode  > 


CMYK Color to convert the image to CMYK mode.


2 Choose Image > Trap.


3 For Width, enter the trapping value provided by your print shop. Then select a unit of measurement, and click OK.


Consult your print shop to determine how much misregistration to expect.


Printing duotones 

About duotones 
You can create monotones, duotones, tritones, and quadtones in Photoshop. Monotones are grayscale images printed


with a single, nonblack ink. Duotones, tritones, and quadtones are grayscale images printed with two, three, and four


inks. In these images, colored inks, rather than different shades of gray, are used to reproduce tinted grays. For the


purposes of this discussion, duotone refers to monotones, tritones, and quadtones as well as duotones.


Duotones increase the tonal range of a grayscale image. Although a grayscale reproduction can display up to 256


levels of gray, a printing press can reproduce only about 50 levels of gray per ink. For this reason, a grayscale image


printed with only black ink can look significantly coarser than the same image printed with two, three, or four inks,


each individual ink reproducing up to 50 levels of gray.


Sometimes duotones are printed using a black ink and a gray ink—the black for shadows and the gray for midtones


and highlights. More frequently, duotones are printed using a colored ink for the highlight color. This technique


produces an image with a slight tint and significantly increases the dynamic range of the image. Duotones are ideal


for two-color print jobs with a spot color (such as a PANTONE Color) used for accent.


Because duotones use different color inks to reproduce different gray levels, they are treated in Photoshop as single


channel, 8-bit, grayscale images. In Duotone mode, you do not have direct access to the individual image channels


(as in RGB, CMYK, and Lab modes). Instead, you manipulate the channels through the curves in the Duotone


Options dialog box.


To convert an image to duotone

1 Convert the image to grayscale by choosing Image > Mode > Grayscale. Only 8-bit grayscale images can be


converted to duotones.


2 Choose Image > Mode > Duotone.


3 In the Duotone Options dialog box, select Preview to preview the image.
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4	 For the Type option, select Monotone, Duotone, Tritone, or Quadtone. 

5 Click the  color box  (the  solid square).  Then  use the  color picker or click  the Custom button in the  color picker to  

select an ink from the Custom Colors dialog box. 

Note: To produce fully saturated colors, specify inks in descending order—darkest at the top, lightest at the bottom. 

6 Click the curve box next to the color ink box and adjust the duotone curve for each ink color.


7 Set overprint colors, if necessary.


8 Click OK.


To  apply a duotone effect to only part of an image, convert  the duotone  image to Multichannel mode—this converts  

the duotone curves to spot channels. You can then erase part of the spot channel for areas that you want printed as 

standard grayscale. 

See also 

“About spot colors” on page 442 

To modify the duotone curve for a given ink 
In a duotone image, each ink has a separate curve that specifies how the color is distributed across the shadows and 

highlights. This curve maps each grayscale value in the original image to a specific ink percentage. 

1	 To preview any adjustments, select the Preview option. 

2	 Click the curve box next to the ink color box. 

The default duotone curve, a straight diagonal line, indicates that the grayscale values in the original image map to 

an equal percentage of ink. At this setting, a 50% midtone pixel is rendered with a 50% tint of the ink, a 100% shadow 

is rendered in 100% color, and so on. 

3 Adjust the duotone curve for each ink by dragging a point on the graph or by entering values for the different ink 

percentages. 

•	 In the curve graph, the horizontal axis moves from highlights (at the left) to shadows (at the right). Ink density 

increases as you move up the vertical axis. You can specify up to 13 points on the curve. When you specify two 

values along the curve, Photoshop calculates intermediate values. As you adjust the curve, values are automatically 

entered in the percentage text boxes. 

•	 The value you enter in the text box indicates the percentage of the ink color used to represent the grayscale value 

in the original image. For example, if you enter 70 in the 100% text box, a 70% tint of that ink color is used to print 

the 100% shadows. 

4	 Click Save in the Duotone Curve dialog box to save curves created with this dialog box. 

5 Click Load to load these curves or curves created in the Curves dialog box, including curves created using the 

Arbitrary Map option. 

You can use the Info palette to display ink percentages when you’re working with duotone images. Set the readout 

mode to Actual Color to determine what ink percentages will be applied when the image is printed. These values 

reflect any changes you’ve entered in the Duotone Curve dialog box. 

See also 

“About the Curves dialog box” on page 286 
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Specifying overprint colors 
Overprint colors are two unscreened inks printed on top of each other. For example, when you print a cyan ink over


a yellow ink, the resulting overprint color is green. The order in which inks are printed, as well as variations in the


inks and paper, can significantly affect the final results.


To predict how colors will look when printed, use a printed sample of the overprinted inks and adjust your screen


display accordingly. Keep in mind that this adjustment affects only how the overprint colors appear on-screen, not


when printed. Before adjusting these colors, make sure to calibrate your monitor.


To adjust the display of overprint colors

1 Choose Image > Mode > Duotone.


2 Click Overprint Colors. The Overprint Colors dialog box shows how the combined inks will look when printed.


3 Click the color swatch of the ink combination that you want to adjust.


4 Select the desired color in the color picker, and click OK.


5 Repeat steps 3 and 4 until you are satisfied with the ink combination. Then click OK.


Saving and loading duotone settings 
Use the Save button in the Duotone Options dialog box to save a set of duotone curves, ink settings, and overprint 

colors. Use the Load button to load a set of duotone curves, ink settings, and overprint colors. You can then apply 

these settings to other grayscale images. 

Photoshop includes several sample sets of duotone, tritone, and quadtone curves. These sets include some commonly 

used curves and colors. Use these sets as starting points when you create your own combinations. 

To view the individual colors of a duotone image 
Because duotones are single-channel images, your adjustments to individual printing inks are displayed as part of 

the final composite image. In some cases, you may want to view the individual “printing plates” to see how the 

individual colors will separate when printed (as you can with CMYK images). 

1 After specifying your ink colors, choose Image > Mode > Multichannel. 

The image is converted to Multichannel mode, with each channel represented as a spot color channel. The contents 

of each spot channel accurately reflect the duotone settings, but the on-screen composite preview may not be as 

accurate as the preview in Duotone mode. 

Note: If you make any changes to the image in Multichannel mode, you can’t revert to the original duotone state (unless 

you can access the duotone state in the History palette). To adjust the distribution of ink and view its effect on the 

individual printing plates, make the adjustments in the Duotone Curves dialog box before converting to Multichannel 

mode. 

2 Select the channel you want to examine in the Channels palette. 

3 Choose Edit > Undo Multichannel to revert to Duotone mode. 

Printing duotones 
When creating duotones, keep in mind that both the order in which the inks are printed and the screen angles you 

use have a significant effect on the final output. 
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Click the Auto button in the Halftone Screens dialog box to set the optimal screen angles and frequencies. Be sure to 

select Use Accurate Screens in the Auto Screens dialog box if you’re printing to a PostScript Level 2 (or higher) 

printer or an imagesetter equipped with an Emerald controller. 

Note: The recommended screen angles and frequencies for quadtones are based on the assumption that channel 1 is the 

darkest ink and channel 4 is the lightest ink. 

You do not have to convert duotone images to CMYK to print separations—simply choose Separations from the 

Profile pop-up menu in the Color Management section of the Print dialog box (for setting printer options). 

Converting to CMYK mode converts any custom colors to their CMYK equivalents. 

Exporting duotone images to other applications 
To export a duotone image to a page-layout application, you must first save the image in EPS or PDF format. 

(However, if the image contains spot channels, convert it to Multichannel mode and save it in DCS 2.0 format.) 

Remember to name custom colors using the appropriate suffix so that the importing application can recognize them. 

Otherwise, the application may not print the colors correctly, or it may not print the image at all. 
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Chapter 25: Automating Tasks


Actions 

About actions 
An action is a series of commands that you play back on a single file or a batch of files. For example, you can create 

an  action  that  applies an Image  Size  command  to  change  an  image to a specific  size  in  pixels, followed by an Unsharp  

Mask filter that resharpens the detail, and a Save command that saves the file in the desired format. 

Most commands and tool operations are recordable in actions. Actions can include stops that let you perform tasks 

that cannot be recorded (for example, using a painting tool). Actions can also include modal controls that let you 

enter values in a dialog box while playing an action. 

Both Photoshop and ImageReady include a number of predefined actions. You can use these actions as is, customize 

them to meet your needs, or create new actions. See “To load a set of actions” on page 738. 

In Photoshop, actions are stored in sets to help you organize your actions. 

Actions are the basis for droplets, which are small applications that automatically process all files that are dragged 

onto their icon. See “About droplets” on page 742. 

To use the Actions palette 
You use the Actions palette to record, play, edit, and delete individual actions. This palette also lets you save and load 

action files. 

A 

B 

C 

D E  

Photoshop Actions palette 
A. Action set B. Action C. Recorded commands D. Excluded command E. Modal control (toggles on or off) 

•	 To display the Actions palette, choose Window > Actions. 

•	 To expand and collapse sets, actions, and commands, click the triangle to the left of the set, action, or command 

in the Actions palette. Alt-click (Windows) or Option-click (Mac OS) the triangle to expand or collapse all actions 

in a set or all commands in an action. 

•	 To display actions as buttons (Photoshop), choose Button Mode from the Actions palette menu. Choose Button 

Mode again to return to list mode. You can’t view individual commands or sets in Button mode. 

•	 To select actions in the Action palette, click an action name. In Photoshop, Shift-click action names to select 

multiple, contiguous actions and Ctrl-click (Windows) or Command-click (Mac OS) action names to select 

multiple, discontiguous actions. 
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Playing actions 
Playing an action executes the series of commands you recorded in the active document. You can exclude specific 

commands from an action or play a single command. If the action includes a modal control, you can specify values 

in a dialog box or use a modal tool when the action pauses. 

Note: In Button mode, clicking a button executes the entire action—although commands previously excluded are not 

executed. 

To play an action on a file

1 Open the file.


2 Do one of the following:


•	 To play an entire action, select the action name, and click the Play button in the Actions palette, or choose Play 

from the palette menu. 

•	 If you assigned a key combination to the action, press that combination to play the action automatically. 

•	 To play part of an action, select the command from which you want to start playing, and click the Play button in 

the Actions palette, or choose Play from the palette menu. 

To play a single command in an action 
1 Select the command you want to play. 

2 Do one of the following: 

•	 Ctrl-click (Windows) or Command-click (Mac OS) the Play button in the Actions palette. 

•	 Press Ctrl (Windows) or Command (Mac OS), and double-click the command. 

To undo an entire action 
❖ Do one of the following: 

•	 (Photoshop) Take a snapshot in the History palette before you play an action, and then select the snapshot to undo 

the action. 

•	 (ImageReady) Choose Edit > Undo [action name]. 

To specify playback speed 
You can adjust an action’s playback speed or pause it to help you debug an action.


1 Choose Playback Options from the Actions palette menu.


2 Specify a speed:


Accelerated Plays the action at normal speed (the default).


Step By Step Completes each command and redraws the image before going on to the next command in the action. 

Pause For Specifies the  amount  of  time  Photoshop should pause  between carrying out  each  command in the  action.  

3 Select  Pause For  Audio Annotation to ensure that each audio  annotation  in  an  action  is  played  before  the next step  

in  the action is initiated. Deselect this option if you  want  an  action  to  continue  while an audio  annotation  is  playing.  

4	 Click OK. 
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To rearrange actions in the Actions palette 
❖ In the Actions palette, drag the action to its new location before or after another action. When the highlighted line 

appears in the desired position, release the mouse button. 

Recording actions 

Recording actions 
Keep in mind the following guidelines when recording actions: 

•	 You can record most—but not all—commands in an action. 

•	 You can record operations that you perform with the Marquee, Move, Polygon, Lasso, Magic Wand, Crop, Slice, 

Magic Eraser, Gradient, Paint Bucket, Type, Shape, Notes, Eyedropper, and Color Sampler tools—as well as those 

that you perform in the History, Swatches, Color, Paths, Channels, Layers, Styles, and Actions palettes. 

•	 Results depend on file and program setting variables, such as the active layer and the foreground color. For 

example, a 3-pixel Gaussian blur won’t create the same effect on a 72-ppi file as on a 144-ppi file.  Nor will Color 

Balance work on a grayscale file. 

•	 When you record actions that include specifying settings in dialog boxes and palettes, the action will reflect the 

settings in effect at the time of the recording. If you change a setting in a dialog box or palette while recording an 

action, the changed value is recorded. 

Note: Most dialog boxes retain the settings specified at the previous use. Check carefully that those are the values you 

want to record. 

•	 Modal operations and tools—as well as tools that record position—use the units currently specified for the ruler. 

A modal  operation or tool is one  that  requires  you to press  Enter or Return to apply  its effect,  such  as  transforming  

or cropping. Tools that record position include the Marquee, Slice, Gradient, Magic Wand, Lasso, Shape, Path, 

Eyedropper, and Notes tools. 

(Photoshop) If you record an action that will be played on files of different sizes, set the ruler units to percentages. As 

a result, the action will always play back in the same relative position in the image. 

•	 You can record the Play command listed on the Actions palette menu to cause one action to play another. 

•	 In ImageReady, you can drag a command from the History palette to the action in the Actions palette in which 

you want the command recorded. Commands in italics are not recordable in an action. 

•	 Photoshop and ImageReady cannot share actions. 

To automate a task by recording an action 
When you create a new action, the commands and tools you use are added to the action until you stop recording.


1 Open a file.


2 In the Actions palette, click the New Action button
 , or choose New Action from the Actions palette menu.


3 Enter a name for the action.


4 (Photoshop) Choose a set from the pop-up menu.
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5	 If desired, set one or both of the following options: 

•	 Assign a keyboard shortcut to the action. You can choose any combination of a function key, the Ctrl key 

(Windows) or Command key (Mac OS), and the Shift key (for example, Ctrl+Shift+F3), with these exceptions: In 

Windows, you cannot use the F1 key, nor can you use F4 or F6 with the Ctrl key. 

• (Photoshop) Assign a color for display in Button mode. 

6 Click Record. The Record button in the Actions palette turns red . 

Important: When recording the Save As command, do not change the file name. If you enter a new file name, Photoshop 

records the file name and uses that file name each time you run the action. Before saving, if you navigate to a different 

folder, you can specify a different location without having to specify a file name. 

7	 Perform the operations and commands you want to record. 

8 To stop recording, either click the Stop button, choose Stop Recording from the Actions palette menu, or press the 

Esc key. To resume recording in the same action, choose Start Recording from the Actions palette menu. 

To record a path 
The Insert Path command lets you include a complex path (a path created with a pen tool or pasted from Adobe Illus

trator) as part of an action. When the action is played back, the work path is set to the recorded path. You can insert 

a path when recording an action or after it has been recorded. 

1	 Do one of the following: 

•	 Start recording an action.


•	 Select an action’s name to record a path at the end of the action.


• Select a command to record a path after the command.


2 Select an existing path from the Paths palette.


3 Choose Insert Path from the Actions palette menu.


If  you record multiple Insert Path commands in a single  action, each path replaces the  previous  one in the  target  file. 


To add multiple paths, record a Save Path command using the Paths palette after recording each Insert Path


command.


Note: Playing actions that insert complex paths may require significant amounts of memory. If you encounter problems, 

increase the amount of memory available to Photoshop. 

About stops 
You can include stops in your action that let you perform a task that cannot be recorded (for example, using a 

painting tool). After you complete the task, click the Play button in the Actions palette to complete the action. You 

can insert a stop when recording an action or after it has been recorded. 

You can also display a short message when the action reaches the stop. For example, you can remind yourself what 

needs to be done before continuing with the action. Photoshop gives you the option of including a Continue button 

in the message box. This lets you check for a certain condition in the file (for example, a selection) and continue if 

nothing needs to be done. ImageReady automatically provides the Continue button. 
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To insert a stop 
1 Choose where to insert the stop by doing one of the following: 

•	 Select an action’s name to insert a stop at the end of the action. 

•	 Select a command to insert a stop after the command. 

2 Choose Insert Stop from the Actions palette menu. In ImageReady you can also click the Insert A Step button at


the bottom of the palette.


3 Type the message you want to appear.


4 (Photoshop) If you want the option to continue the action without stopping, select Allow Continue.


5 Click OK.


Setting modal controls 
A modal control pauses an action so that you can specify values in a dialog box or use a modal tool. You can set modal 

controls only for actions that launch dialog boxes or activate modal tools. If you do not set a modal control, dialog 

boxes do not appear when you play the action, and you cannot change the recorded values. 

A modal control is indicated by a dialog box icon  to the left of a command, action, or set in the Actions palette. 

A red dialog box icon indicates an action or set in which, some, but not all, commands are modal. In Photoshop, 

you must be in List mode—not Button mode—to set a modal control. 

To set a modal control 
❖ Do one of the following: 

•	 Click the box to the left of the command name to display the dialog box icon. Click again to remove the modal 

control. 

•	 To turn on or disable modal controls for all commands in an action, click the box to the left of the action name. 

•	 (Photoshop) To turn on or disable modal controls for all actions in a set, click the box to the left of the set name. 

To exclude or include a command 
You can exclude commands that you don’t want to play as part of a recorded action. In Photoshop, you must be in 

List mode—not Button mode—to exclude commands. 

1	 To expand the listing of commands in an action, click the triangle to the left of the action you want to work with. 

2 Click the check mark to the left of the specific command you wish to exclude; click again to include the command. 

To exclude or include all commands in an action, click the check mark to the left of the action name. 

When you exclude a command, its check mark disappears. In addition, the check mark of the parent action turns red 

to indicate that some of the commands within the action are excluded. 

Inserting nonrecordable commands 
You cannot record the painting and toning tools, tool options, View commands, and Window commands. However, 

you can insert many nonrecordable commands into an action using the Insert Menu Item command. 
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You can insert a command when recording an action, or after it has been recorded. An inserted command doesn’t 

execute until the action is played, so the file remains unchanged when the command is inserted. No values for the 

command are recorded in the action. If the command opens a dialog box, the dialog box appears during playback, 

and the action pauses until you click OK or Cancel. 

Note: When you use the Insert Menu Item command to insert a command that opens a dialog box, you cannot disable 

the modal control in the Actions palette. 

To insert a menu item in an action 
1 Choose where to insert the menu item: 

• Select an action’s name to insert the item at the end of the action. 

• Select a command to insert the item at the end of the command.


2 Choose Insert Menu Item from the Actions palette menu.


3 With the Insert Menu Item dialog box open, choose a command from its menu.


4 Click OK.


To overwrite a single command

1 In the Actions palette, double-click the command.


2 Enter the new values, and click OK.


To add commands to an action 
1 Do one of the following: 

• Select the action name to insert a new command at the end of the action. 

• Select a command in the action to insert a command after it.


2 Click the Record button, or choose Start Recording from the Actions palette menu.


3 Record the additional commands.


4 Click the Stop button to stop recording.


In ImageReady, you can drag any nonitalicized command from the History palette to the Actions palette without 

clicking the Record button or choosing Start Recording from the Actions palette menu. 

To record an action again

1 Select an action, and choose Record Again from the Actions palette menu.


2 For a modal tool, use the tool to create a different result, and press Enter (Windows) or Return (Mac OS).


3 For a dialog box, change the settings, and click OK to record them.
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About conditionals (ImageReady) 
A conditional is a statement of a situation that must be met before the next step of an action can take place. You set


both the condition and the steps to take if the condition is met. Conditionals are extremely useful in limiting the


range of items an action will work on. For instance, suppose you are importing hundreds of images into a web-based


photo gallery, but you have to resize any that are too large for your specifications. You can add a conditional to your


action that checks the size of every file and changes only the ones that are too large, thus saving much time and space.


Conditionals are also useful for nesting actions within actions, playing the nested action only under specified condi


tions.


To insert a conditional (ImageReady)

1 In the Actions palette, choose the step after which the conditional action should appear.


2 Choose  Insert  Conditional from the  Actions palette  menu, or click  the Insert Step button 
 at the  bottom  of  the  

palette and choose Insert Conditional. 

3	 Specify the circumstances under which the conditional action is executed and the condition itself: 

•	 Select Always to execute the conditional action every time. 

•	 Select Ask to display a dialog box asking the user whether the condition has been met. 

•	 Select Never if you don’t want the conditional action to be executed. 

•	 Use the remaining options (Image Aspect Ratio, Image Width, Image Height, and so on) to define the condition 

that must be met for the conditional actions to be performed. 

4 In the Perform The Following Actions area of the dialog box, choose an action to perform if the condition is met: 

Play Action Performs the action you choose from the pop-up menu. 

Include Specifies the number of steps to be performed before the action ends. The steps are performed only if the 

condition is met, and ignored otherwise. 

Skip Specifies a number of subsequent steps to be ignored if the condition is met. If the skip condition is not met, 

the steps are executed. 

Skip Remaining Steps In The Action Finishes the action without executing the remaining steps if the condition is 

met; otherwise, all steps are executed. 

Cancel Playing The Action Terminates the action at this point if the condition is met. 

Repeat Specifies the number of times the chosen number of previous steps are to be repeated.


Beep Plays an alert sound when the condition is met.


To edit a conditional (ImageReady)

1 In the Actions palette, click the triangle to the left of the conditional action to show its conditions and actions.


2 Double-click a condition or action to open the Conditional dialog box.


3 Change the condition or action and click OK.


To specify an output folder (ImageReady) 
If you include a Save Optimized step in your action or create a droplet from the action, you can specify the folder in 

which images are placed after the action is performed. 
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Note: In Photoshop, you can set an output folder when using the Batch command to process files. (See “To batch-process 

files” on page 741.) 

1 Select the action for which you want to specify an output folder in the Actions palette. 

2 Choose  Insert  Set Output Folder from the  Actions palette  menu, or click  the Insert Step button  at the  bottom  

of the palette and choose Insert Set Output Folder. 

3 Select a folder, and click OK. 

To record image size options (ImageReady) 
Resizing images is a typical step in preparing irregularly sized images for use on the web. You can automate this task


by creating an action that includes the Image Size command. ImageReady provides several options that give you


control over how an action resizes images.


1 Start recording an action.


2 Choose Image > Image Size, and enter the desired image dimensions.


3 Select Action Options.


4 Choose an option from the Fit Image By menu:


Width Constrains proportions using the new width value.


Height Constrains proportions using the new height value. 

Width & Height Constrains proportions using either the new width value or the new height value. 

Percent Constrains proportions using the new percentage value. 

5 Select Do Not Enlarge to prevent images that are smaller than the new dimensions from being resized. 

6 Click OK and continue recording the action. 

To insert optimization settings for selected slices (ImageReady) 
When you record a Save Optimized action step, ImageReady includes optimization settings for the entire image. You 

can insert optimization settings for individual slices using the Insert Set Optimization Settings command. 

1 Select the slice or slices for which you want to record optimization settings. 

2 Select the action in which you want to insert the optimization settings. 

3 Do one of the following: 

• Choose Insert Set Optimization Settings To [file format] from the Actions palette menu. 

• Drag the droplet icon  from the Optimize palette onto the Actions palette. 

• Click the Insert Step button at the bottom of the Actions palette. Choose Insert Set Optimization Settings To, 

and choose a format. 
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Managing actions 

To rearrange commands within an action 
❖ In the Actions palette, drag the command to its new location within the same or another action. When the 

highlighted line appears in the desired position, release the mouse button. 

To duplicate an action or command 
❖ Do one of the following: 

•	 Alt-drag (Windows) or Option-drag (Mac OS) the action or command to a new location in the Actions palette. 

When the highlighted line appears in the desired location, release the mouse button. 

•	 Select an action or command. Then choose Duplicate from the Actions palette menu. The copied action or 

command appears after the original. 

•	 Drag an action or command to the New Action button at the bottom of the Actions palette. The copied action or 

command appears after the original. 

In Photoshop, you can duplicate sets as well as actions and commands. 

To delete an action or command

1 In the Actions palette, select the action or command you want to delete.


2 Delete the action or command:


•	 Click the Delete icon  on the Actions palette. Click OK to delete the action or command. 

•	 Alt-click (Windows) or Option-click (Mac OS) the Delete icon to delete the selected action or command without 

displaying a confirmation dialog box. 

•	 Drag the action or command to the Delete icon on the Actions palette to delete the selected action or command 

without displaying a confirmation dialog box. 

•	 Choose Delete from the Actions palette menu. 

To delete all actions in the Actions palette 
❖ Choose Clear All Actions from the Actions palette menu. 

Even after clearing all actions, the Actions palette can be restored to its default set of actions. See “To save a set of 

actions” on page 738. 

To rename an action 
❖ Double-click the action name in the Actions palette and enter a new name.


To change action options

1 Select the action, and choose Action Options from the Actions palette menu.


2 Type a new name for the action, or change options. For more information about action options, see “Recording


actions” on page 731.


3 Click OK.
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Saving and loading actions 
By default, the Actions palette displays predefined actions (shipped with the application) and any actions you create. 

You can also load additional actions into the Actions palette. 

Note: Photoshop actions are not compatible with ImageReady, and vice versa. 

Actions are automatically saved to the Actions Palette folder in the Adobe Photoshop or Adobe ImageReady CS 

Settings  folder. If this file is lost or removed, the  actions you  created are  lost. You  can save your actions  to  a separate  

actions file so that you can recover them if necessary. In Photoshop, you can also load a variety of action sets that are 

shipped with the program. 

Note: The default location of the Adobe Photoshop CS Settings folder varies by operating system. Use your operating 

system’s Find command to locate this folder. 

To save a set of actions

1 Select a set.


2 Choose Save Actions from the Actions palette menu.


3 Type a name for the set, choose a location, and click Save.


You can save the set anywhere. However, if you place the file in the Presets/Photoshop Actions folder inside the


Photoshop program folder, the set will appear at the bottom of the Actions palette menu after you restart the appli


cation.


Press Ctrl+Alt (Windows) or Command+Option (Mac OS) when you choose the Save Actions command to save the 

actions in a text file. You can use this file to review or print the contents of an action. However, you can’t reload the 

text file back into Photoshop. 

To load a set of actions 
❖ Do one of the following: 

•	 Choose Load Actions from the Actions palette menu. Locate and select the action set file, and then click Load. (In 

Windows, Photoshop action set files have the extension .atn.) 

•	 Select an action set from the bottom of the Actions palette menu. 

To restore actions to the default set 
1 Choose Reset Actions from the Actions palette menu. 

2 Click OK to replace the current actions in the Actions palette with the default set, or click Append to add the set 

of default actions to the current actions in the Actions palette. 

Organizing sets of actions 
To help you organize your actions, you can create sets of actions and save the sets to disk. You can organize sets of 

actions for different types of work—such as print publishing and online publishing—and transfer sets to other 

computers. 
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Although ImageReady doesn’t allow you to create sets, you can manually organize actions in the ImageReady Actions 

folder. For example, if the Actions palette contains too many actions, create a new folder inside the ImageReady 

Actions folder and move less used actions from the ImageReady Actions folder to this new folder. The relocated actions 

are removed from the palette until you return them to the ImageReady Actions folder. 

•	 To create a new set of actions, click the New Set button  in the Actions palette or choose New Set from the 

palette menu. Then enter the name of the set, and click OK. 

Note: If you plan to create a new action and group it in a new set, make sure you create the set first. Then, the new set 

will appear in the set pop-up menu when you create your new action. 

•	 To move an action to a different set, drag the action to that set. When the highlighted line appears in the desired 

position, release the mouse button. 

•	 To rename a set of actions, choose Set Options from the pop-up menu in the Actions palette, enter the name of 

the set, and click OK. 

Processing a batch of files 

About the Image Processor 
The Image Processor converts and processes multiple files. Unlike the Batch command, the Image Processor lets you 

process files without first creating an action. You can do any of the following in the Image Processor: 

•	 Convert a set of files to either JPEG, PSD, or TIFF format; or convert files simultaneously to all three formats. 

•	 Process a set of camera raw files using the same options. 

•	 Resize images to fit within specified pixel dimensions. 

•	 Embed a color profile or convert a set of files to sRGB and save them as JPEG images for the web. 

•	 Include copyright metadata into the converted images. 

To convert files with the Image Processor 
The Image Processor works with Photoshop (PSD), JPEG, and camera raw files.


1 Choose > File > Scripts > Image Processor.


2 Select the images you want to process. You can choose to process any open files, or select a folder of files to process.


3 (Optional) Select Open First Image To Apply Settings to apply the same settings to all the images.


If you are processing a group of camera raw files taken under the same lighting conditions, you can adjust the setting


in the first image to your satisfaction and then apply the same settings to the remaining images.


Use this option with PSD or JPEG source images if the file’s color profile does not match your working profile. You


can choose a color profile in which to convert the first image and all images in the folder.


Note: The settings you apply with the Image Processor are temporary and used only with the Image Processor. The 

image’s current camera raw settings are used to process the image, unless you change them in the Image Processor. 

4	 Select the location where you want to save the processed files. 

If  you process  the same file multiple times  to  the same destination, each file is saved  with  its own  file  name  and not  

overwritten. 
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5 Select the file types and options to save.


Save As JPEG Saves images in JPEG format within a folder called JPEG in the destination folder.


Quality Sets the JPEG image quality between 0 and 12.


Resize To Fit Resizes the image to fit within the dimensions you enter in Width and Height. The image retains its


original proportions.


Convert Profile To sRGB Converts the color profile to sRGB. Make sure that Include ICC Profile is selected if you


want to save the profile with the image.


Save As PSD Saves images in Photoshop format within a folder called PSD in the destination folder.


Maximize Compatibility Saves a composite version of a layered image within the target file for compatibility with


applications that can't read layered images.


Save As TIFF Saves images in TIFF format within a folder called TIFF in the destination folder.


LZW Compression Saves the TIFF file using the LZW compression scheme.


6 Set other processing options.


Run Action Runs a Photoshop action. Choose the action set from the first menu and the action from the second


menu. The action set must be loaded in the Actions palette before they appear in these menus.


Copyright Info Includes any text you enter in the IPTC copyright metadata for the file. Text you include here


overwrites the copyright metadata in the original file.


Include ICC Profile Embeds the color profile with the saved files.


7 Click Run.


Before you process your images, click Save to save the current settings in the dialog box. The next time you need to 

process files using this group of settings, click Load and navigate to your saved Image Processor settings. 

The Batch command 
The Batch command runs an action on a folder of files. If you have a digital camera or a scanner with a document 

feeder, you can also import and process multiple images with a single action. Your scanner or digital camera may 

need an acquire plug-in module that supports actions. 

Note: If the third-party plug-in wasn’t written to import multiple documents at a time, it may not work during batch

processing or if used as part of an action. Contact the plug-in’s manufacturer for further information. 

You can also import PDF images from Acrobat Capture or other software programs. 

When batch-processing files, you can leave all the files open, close and save the changes to the original files, or save 

modified versions of the files to a new location (leaving the originals unchanged). If you are saving the processed files 

to a new location, you may want to create a new folder for the processed files before starting the batch. 

To  batch-process  using multiple actions, create a new action that plays  all the  other actions, and  then  batch-process  

using the new action. To batch-process multiple folders, create aliases within a folder to the other folders you want 

to process, and select the Include All Subfolders option. 

For better batch performance, reduce the number of saved history states and deselect the Automatically Create First 

Snapshot option in the History palette. 
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To batch-process files

1 Choose File > Automate > Batch.


2 Specify the action you want to use to process files from the Set and Action pop-up menus. The menus display


actions available in the Actions palette. You may need to choose a different set or load a set in the palette if you don’t


see your action.


3 Choose the files to process from the Source pop-up menu:


Folder Processes files in a folder you specify. Click Choose to locate and select the folder.


Import Processes images from a digital camera, scanner, or a PDF document. 

Opened Files Processes all open files. 

Bridge Processes selected files in Adobe Bridge. If no files are selected, the files in the current Bridge folder are 

processed. 

4 Set processing options: 

Override Action “Open” Commands Overrides Open commands in an action that refers to specific file names, 

rather than the batched files. Deselect Override Action “Open” Commands if the action was recorded to operate on 

open files or if the action contains Open commands for specific files that are required by the action. If you select this 

option, the action must contain an Open command or the source files will not open. 

Include All Subfolders Processes files in subdirectories of the specified folder. 

Suppress Color Profile Warnings Turns off display of color policy messages. 

Suppress File Open Options Dialogs Hides File Open Options dialog boxes. This is useful when batching actions


on camera raw image files. The default or previously specified settings will be used.


5 Choose a destination for the processed files from the Destination menu:


None Leaves the files open without saving changes (unless the action includes a Save command).


Save And Close Saves the files in their current location, overwriting the original files. 

Folder Saves the processed files to another location. Click Choose to specify the destination folder. 

6 If the action includes a Save As command, choose Override Action “Save As” Commands to make sure files are 

saved to the folder you specified (or to their original folder if you chose Save and Close.) To use this option, the action 

must contain a Save As command, whether or not it specifies a save location or file name; otherwise, no files will be 

saved. 

Some Save options are not available in the Batch command (such as JPEG compression or TIFF options). To use these 

options, record them in the action, then use the Override Action “Save As” Commands option to make sure that your 

files are saved where you specify in the Batch command. 

If you record an action that saves with a specified file name and folder and deselect Override Action “Save As” 

Commands, the same file will be overwritten each time. If you’ve recorded your Save As step in the action without 

specifying  a file name,  the Batch  command will save it to the  same  folder  each  time, but  will  use the  file  name  of  the  

document being saved. 
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7 If you chose Folder as the destination, specify a file-naming convention and select file compatibility options for 

the processed files: 

•	 For File Naming, select elements from the pop-up menus or enter text into the fields to be combined into the 

default names  for all  files.  The fields let  you change the  order and  formatting  of  the components of the  file  name.  

You must include at least one field that is unique for every file (for example, file name, serial number, or serial 

letter) to prevent files from overwriting each other. Starting Serial Number specifies the starting number for any 

serial number fields. Serial letter fields always start with the letter “A” for the first file. 

•	 For File Name Compatibility, choose Windows, Mac OS, and UNIX to make file names compatible with Windows, 

Mac OS, and UNIX operating systems. 

Saving files using the Batch command options usually saves the files in the same format as the original files. To create 

a batch process that saves files in a new format, record the Save As command followed by the Close command as part 

of your original action. Then choose Override Action “Save In” Commands for the Destination when setting up the batch 

process. 

8 Select an option for error processing from the Errors pop-up menu: 

Stop For Errors Suspends the process until you confirm the error message. 

Log Errors To File Records each error  in  a file without  stopping  the process. If errors are  logged  to  a file,  a message  

appears after processing. To review the error file, open with a text editor after the Batch command has run. 

To batch-process files in nested folders into different formats 
1 Process your folders as you would normally, until the Destination step. 

2 Choose Save And Close for the destination. You can specify options for Override Action “Save As” Commands to 

do the following: 

•	 If  the “Save  As” step in the  action  contains  a file name,  this  name  is  overridden  by  the name of the  document  being  

saved; all “Save As” steps are treated as if they were recorded without a file name. 

•	 The folder you specified in the “Save As” action step is overridden by the document’s original folder. 

Note: For this to work properly, you must have a “Save As” step in the action; the Batch command does not automatically 

save files. 

You can use this procedure, for instance, to sharpen, resize, and save images as JPEGs in their original folders. You 

create  an  action  that  has a sharpen step,  a resize step,  and then a “Save As JPEG”  step. When you  batch-process  this  

action, you  select  Include All  Subfolders, make the  destination Save And  Close,  and select Override Action “Save  As”  

Commands. 

Droplets 

About droplets 
A droplet is a small application that applies an action to one or more images that you drag onto the Droplet icon in 

Photoshop or in ImageReady. You can save a droplet on the desktop or to another location on disk. 
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A B 

Droplets 
A. Photoshop B. ImageReady 

Actions are the basis for creating droplets—you must create the desired action in the Actions palette prior to creating 

a droplet. (See “Recording actions” on page 731.) 

In ImageReady, you can also create droplets with the Optimize palette, so that you can apply Optimize palette settings 

to single images or batches of images. 

To create a droplet from an action in Photoshop 
1 Choose File > Automate > Create Droplet. 

2 Specify where to save the droplet. Click Choose in the Save Droplet In section of the dialog box and navigate to 

the location. 

3 Select the Action Set, and then designate which action you intend to use within the Set and Action menus. (Select 

the action in the Actions palette before you open the dialog box to preselect these menus.) 

4 Set Play options for the droplet: 

Override Action “Open” Commands Open commands in the action refer to the batched files, rather than to the file 

names specified in the  action. Deselect Override Action “Open” Commands if the  action  was recorded to operate  on  

open files or if the action contains Open commands for specific files that are required by the action. 

Include All Subfolders Processes files in subdirectories. 

Suppress Color Profile Warnings Turns off display of color profile messages. 

Suppress File Open Options Dialogs Hides File Open Options dialog boxes. This is useful when batching actions 

on camera raw image files. The default or previously specified settings will be used. 

5 Choose a destination for the processed files from the Destination menu: 

None Leaves the files open without saving changes (unless the action includes a Save command). 

Save And Close Saves the files in their current location, overwriting the original files. 

Folder Saves the processed files to another location. Click Choose to specify the destination folder. 

Note: You can record an action that saves using a specified file name and folder. If you do this and deselect Override 

Action “Save As” Commands, the same file is overwritten each time. If you record your Save As step in the action without 

specifying  a file name,  the droplet  saves it to the  same  folder each time but  uses  the file name of the  document  being saved.  

6 If the action includes a Save As command, choose Override Action “Save As” Commands to make sure files are 

saved to the folder you specified (or to their original folder if you chose Save And Close.) To use this option, the 

action must contain a Save As command, whether or not it specifies a save location or file name; otherwise, no files 

are saved. 

Some save options are not available in the Batch command (such as JPEG compression or TIFF options). To use these 

options, record them in the action, then use the Override Action “Save As” Commands option to make sure that your 

files are saved where you specify in the Batch command. 
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7 If you chose Folder as the destination, specify a file-naming convention and select file compatibility options for 

the processed files: 

•	 For File Naming, select elements from the pop-up menus or enter text into the fields to be combined into the 

default names for all files. Elements include document name, serial number or letter, file creation date, and file 

extension. Starting Serial Number specifies the starting number for any serial number fields. Serial letter fields 

always start with the letter “A” for the first file. 

•	 For Compatibility, choose Windows, Mac OS, and UNIX to make file names compatible with Windows, Mac OS, 

and UNIX operating systems. 

8 Select an option for error processing from the Errors pop-up menu: 

Stop For Errors Suspends the process until you confirm the error message. 

Log Errors To File Records each error  in  a file without  stopping  the process. If errors are  logged  to  a file,  a message 


appears after processing. To review the error file, open it in a text editor after the Batch command runs.


To create a droplet from an action in ImageReady (ImageReady)

1 For best results, make sure that the action contains at least one Set Optimization command. To add a Set Optimi


zation command, adjust the settings in the Optimize palette, and then drag the droplet icon
  from the Optimize 

palette onto the part of the Actions palette where you want to add that command. 

If you do not add a Set Optimization command to the droplet, ImageReady processes files using the optimization 

settings in effect at the time the droplet was created. 

2	 Create the droplet: 

•	 Drag the name of the action from the Actions palette onto the desktop. The droplet has the same name as the 

action it was created from. You can rename the droplet as you do other desktop icons. 

•	 Select an action, and choose Create Droplet from the Actions palette menu. Name the droplet, choose a location 

where the droplet will be saved, and click Save. 

Creating droplets for use on different operating systems 
When creating droplets that may be used in both Windows and Mac OS, keep the following compatibility issues in 

mind: 

•	 After moving a Photoshop droplet created in Windows to Mac OS, you must drag the droplet onto the Photoshop 

icon on your desktop. Photoshop updates the droplet for use in Mac OS and then runs the droplet. 

•	 After moving an ImageReady droplet from Windows to Mac OS, drag the droplet onto the ImageReady icon for 

use on the Mac OS. 

•	 When creating a droplet in Mac OS, use the .exe extension to make droplets compatible with both Windows and 

Mac OS. 

•	 References to file names are not supported between operating systems. If an action step references a file or folder 

name (such as an Open command, Save As command, or adjustment command that loads its settings from a file), 

execution pauses and the user is prompted for a file name. 
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To process a file with a droplet 
1 Drag a file or folder onto the droplet icon in Photoshop or in ImageReady. If the application you used to create the 

droplet is not currently running, the droplet starts the program. 

A B 

Droplets 
A. Photoshop B. ImageReady 

2	 In ImageReady, you can control droplet processing in the following ways: 

•	 To temporarily pause processing, click Pause in the Batch Process dialog Box. Click Resume to continue the 

processing. 

•	 To cancel processing, click Stop. 

To edit a droplet (ImageReady)

1 Double-click the droplet or Choose File > Open and select the action to open the droplet window. The droplet


window looks like a simplified version of the Actions palette.


2 Edit the droplet just as you edit an action:


•	 Change the order of commands by dragging them in the droplet list. 

•	 Delete commands by dragging them to the Delete icon . 

•	 Add a command by dragging a state from the History palette to the area of the droplet window in which you want 

the command recorded. 

To adjust droplet batch options (ImageReady) 
You can set batch options for a droplet before or after you create it. For example, you can set the droplet to operate 

in the background during execution, so that you can work in other applications while ImageReady processes images. 

1	 Do one of the following: 

•	 Before you create the droplet, select an action and choose Batch Options from the Actions palette menu. 

•	 After you create the droplet, double-click the droplet to open the droplet window, and double-click Batch Options 

at the top of the droplet list. 

2 Select Original (same name and folder) to save the original file with the same name and in the same folder. 

3 Select Optimized to save an optimized version of the file. Then do any of the following: 

•	 For In, choose the location in which you want to save the optimized file. 

•	 For If Duplicate File Name, choose how and whether to append numbers or letters to indicate the optimized file 

in cases of duplicate file names. 

•	 For Modify File Name For, choose whether ImageReady appends or rewrites the file name using Windows, 

Mac OS 9, or UNIX file-naming conventions. 
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4	 Select playback options: 

Run In Background Hides ImageReady during droplet execution, so that you can work in other applications while 

processing takes place. When you select Run In Background, other playback options requiring user input during 

processing are turned off, unless you specifically specify that ImageReady should come to the  foreground  to  request  

user input. ImageReady appears when the droplet completes execution. 

Note: ImageReady is not available for creating and modifying current images while background processing is taking 

place. 

Display Image Shows the images as they are being processed. 

Pause Before Save Stops the processing of each image before saving it. 

5 Choose error options from the Errors menu:


Stop Suspends the process until you confirm the error message.


Skip Step Skips steps in which errors are encountered. 

Skip File Skips files in which errors are encountered. 

To create a droplet for automating Optimize palette settings (ImageReady) 
You can save Optimize palette settings for use on individual images or batches of images by creating a droplet for the 

settings. The droplet lets you apply the compression settings to an image or batch of images that you drag onto the 

droplet icon. 

1 With  an  image displayed  in  the image  window, choose a compression format and  desired compression  options in  

the Optimize palette. (See “About optimization” on page 625.) 

2	 Create a droplet: 

•	 Drag the droplet icon  from the Optimize palette onto the desktop. ImageReady names the droplet according 

to its compression settings, including file format and color palette or quality setting information. You can rename 

the droplet as you do other desktop icons. 

•	 Click the droplet icon on the Optimize palette. Name the droplet, choose a location where the droplet will be 

saved, and click Save. 

•	 Choose Create Droplet from the Optimize palette menu. Name the droplet, choose a location where the droplet 

will be saved, and click Save. 

You can add optimization settings to an action by dragging the droplet icon in the Optimize palette to the Actions 

palette. 

Scripting 

About scripting 
Photoshop supports external automation through scripting. In Windows, you can use any scripting language that 

supports COM automation, such as Visual Basic. In Mac OS, you can use any language, such as AppleScript, that 

allows you to send Apple events. These languages are not cross-platform but can control multiple applications such 

as Adobe Photoshop, Adobe Illustrator, and Microsoft Office. 
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You can also use JavaScript on either platform. JavaScript support lets you write Photoshop scripts that run on either 

Windows or Mac OS. You must use external tools to edit and debug the scripts. 

Note: Refer to the scripting documentation included with your Photoshop application installation: Photoshop Apple-

Script Reference.pdf, Photoshop JavaScript Reference Guide.pdf, Photoshop Scripting Guide.pdf, and Photoshop 

VBScript Reference Guide.pdf. These guides can be found in Photoshop CS/Scripting Guide. 

To run a JavaScript 
❖ Choose File > Scripts and then select the script from the list. The scripts list includes all the script files saved with 

a .js or .jsx extension and saved in the Photoshop CS2/Presets/Scripts folder. To run a script saved in another location, 

choose File > Scripts > Browse and navigate to the script. 

To set scripts and actions to run automatically 
You can have an event, such as opening, saving, or exporting a file in Photoshop, trigger a JavaScript or a Photoshop


action. Photoshop provides several default events, or you can have any scriptable Photoshop event trigger the script


or action. See the Photoshop Scripting Guide for more information on scriptable events.


1 Choose File > Scripts > Scripts Events Manager.


2 Select Enable Events To Run Scripts/Actions.


3 From the Photoshop Event menu, choose the event that will trigger the script or action.


4 Select either Script or Action, and then choose the script or action to run when the event occurs.


Photoshop has several sample scripts you can choose. To run a different script, choose Browse and then navigate to


the script. For actions, choose the action set from the first pop-up menu and an action from that set in the second


menu. The action must be loaded in the Actions palette to appear in these menus.


5 Click Add. The event and its associated script or action are listed in the dialog box.


6 To disable and remove individual events, select the event in the list and click Remove. To disable all events, but


keep them in the list, deselect Enable Events To Run Scripts/Actions.


Creating data-driven graphics 

About data-driven graphics 
Data-driven graphics make it possible to produce multiple versions of an image quickly and accurately for print or 

web projects. For example, you can produce 100 versions of a web banner with different text and images, all based 

on a template design. 

You generate the graphics by exporting them from Photoshop or ImageReady, or you can create templates for use in 

other programs such as Adobe GoLive or Adobe Graphics Server. 

Follow these general steps to create graphics from templates and data sets: 

1. Create the base graphic to use as the template. 

Use layers to separate the elements that you want to change in the graphic. 
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2. Define variables in the graphic. 

Variables specify the parts of the image that change. (See “About variables” on page 748 and “To define variables” on 

page 749.)

3. Create or import the data sets. 

You can create the data sets in the template, or import them from a text file. (See “To define a data set” on page 750 

and “Importing data sets from external files” on page 752.)

4. Preview the document with each data set. 

To see how your final graphics will look, you can preview before you export all the files. (See “To preview or apply a 

data set” on page 751.)

5. Generate your graphics by exporting them with the data. 

In Photoshop you can export them as Photoshop (PSD) files. In ImageReady, you can also export optimized GIF and 

JPEG files or SWF files. (See “To generate graphics using data sets” on page 751.)

A 

B 

DaisyDaisy RoseRoseLilyLily

FlFlower 

C 

Creating different versions of an image using variables 
A. Source file template B. User defines layers as variables. C. Different versions of the image can be created, each with a different variable 
data set. 

About variables 
You use variables to define which elements in a template change. You can define three types of variables. Visibility 

variables show or hide the content of a layer. Pixel Replacement variables replace the pixels in the layer with pixels 

from another image file. Text Replacement variables replace a string of text in a type layer. 

Note: GoLive recognizes all text and visibility variables, but not Pixel Replacement variables. 
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C 

Two versions of an image based on the same template 
A. Visibility variable B. Pixel Replacement variable C. Text Replacement variable 

To define variables 
You cannot define variables for the Background layer.


1 Choose Image > Variables > Define.


2 Select a layer from the Layer pop-up menu that contains the content you want to define as a variable.


3 Select one or more types of variables:


Visibility Shows or hides the content of the layer.


Pixel Replacement Replaces the pixels in the layer with pixels from another image file. 

Text Replacement Replaces a string of text in a type layer. 

4	 Do one of the following: 

•	 Choose New Variable from the Name pop-up menu and enter a name for the variable. Variable names must begin 

with a letter, underscore, or colon and cannot contain spaces or special characters (except for periods, hyphens, 

underscores, and colons). 

•	 Choose an existing variable from the Name pop-up menu to link this layer to. Layers linked to the same variable 

are shown next to the Name menu, along with the link icon. 
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5 For Pixel Replacement variables, set the following options. In ImageReady, click Pixel Replacement Options to see 

the options. 

•	 Choose a method for scaling the replacement image: Fit scales the image so that it fits in the bounding box (which 

may leave parts of the bounding box empty), Fill scales the image so that it fills the bounding box entirely (which 

may cause the image to extend beyond the bounding box), As Is applies no scaling to the image, and Conform 

scales the image nonproportionally so that it fits in the bounding box. 

•	 Click a handle on the alignment icon  to choose an alignment for placing the image inside the bounding box. 

(This option is not available for Conform.) 

•	 Select Clip To Bounding Box to clip areas of the image that do not fit in the bounding box. This option is available 

only when the Fill or As Is replacement method is selected. (This option is not available for Conform.) 

6 To define variables for another layer, choose a layer from the Layer pop-up menu. An asterisk appears next to the 

name of a layer that contains variables. In Photoshop, you can use the navigation arrows to move between layers. 

7	 Click OK. 

To rename a variable

1 Choose Image > Variables > Define.


2 Choose the layer that contains the variable from the Layer pop-up menu.


3 To rename the variable, enter a name in the Name text box. Variable names must begin with a letter, underscore,


or colon and cannot contain spaces or special characters (except for periods, hyphens, underscores, and colons).


4 To remove the variable, deselect it.


To define a data set 
A data set is a collection of variables and associated data. You define a data set for each version of the graphic that 

you want to generate. 

1	 Do one of the following: 

•	 Choose Image > Variables > Data Sets. 

•	 If the Variables dialog box is open, choose Data Sets from the pop-up menu at the top of the dialog box, or click 

Next. 

Note: You must define at least one variable before you can edit the default data set. 

2	 Click the New Data Set button . In ImageReady, the first data set is automatically created. 

3 Select a variable from the Name pop-up menu or the list at the bottom of the dialog box. 

4 Edit the variable data: 

•	 For Visibility variables , select Visible to show the layer’s content or Invisible to hide the layer’s content. 

•	 For Pixel Replacement variables , click Select File (Photoshop) or Browse/Choose (ImageReady) and select a 

replacement image file. Click Do Not Replace before the data set is applied to leave the layer in its current state. 

Note: Do Not Replace does not reset to the file to its original state if another replacement has been applied previously. 

•	 For Text Replacement variables , enter a text string in the Value text box. 

5 Define additional data sets for each version of the graphic you want to generate. 
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You can edit, rename, or delete the data set later by first choosing it from the Data Set pop-up menu and editing its 

options. Use the arrow icons to move between data sets. Click the Delete icon to delete a data set. 

See also 

“Importing data sets from external files” on page 752 

To preview or apply a data set 
You can  apply a data  set’s contents to the  base  image while  leaving all  the variables  and data sets  intact. This changes  

the look of the PSD document to contain the values of the data set. You can also preview how each version of your 

graphic will look with each data set. 

Note: Applying a data set overwrites your original document. 

❖ Choose Image > Apply Data Set. Select the data set from the list and preview the image in the document window. 

To apply the data set, click Apply or OK (ImageReady Windows). Click cancel if you are previewing and don’t want 

to change the base image. 

You can also apply and preview a data set in the Data Set page of the Variables dialog box. 

To preview data-driven graphics in ImageReady 
Preview Document mode lets you preview how a template will look when it is rendered using different sets of data. 

1	 Enable Preview Document mode: 

•	 Choose Image > Preview Document. A check mark appears next to the command when Preview Document mode 

is enabled. 

• Click the Preview Document button in the tool box.


2 In the options bar, choose a data set from the Data Set pop-up menu, click the Previous Data Set button
 , or 

click the Next Data Set button . 

The data changes in the document window. 

Saving templates for use with other Adobe products 
You can  save  a template in PSD  format  for use  with  other Adobe  products,  such  as  Adobe Graphics Server (available  

only in English) and Adobe GoLive. For example, a GoLive user can place a PSD template in a page layout, bind its 

variables to a database using dynamic links, and then use Graphics Server to generate iterations of the artwork. 

Likewise, a developer working with Graphics Server can bind the variables in the PSD file directly to a database or 

another data source. 

For more information on using PSD templates to create data-driven graphics, see Adobe GoLive Help and the Adobe 

Graphics Server Developer Guide. 

To generate graphics using data sets 
After you define variables and one or more data sets, you can output, in batch mode, images using the data set values.


You can output images as PSD files. In ImageReady, you can also generate optimized GIF or JPEG files or SWF files.


1 Choose File > Export > Data Sets As Files.


2 Enter a base name for all files generated. You may create your own file-naming scheme if you want.
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3 Click the Choose button to select a destination directory for your files.


4 Choose data sets to export.


5 (ImageReady) In the Save As text box, choose an export format and set the format-dependent export parameters.


6 Click OK.


Note: When exporting to SWF format, you can see multiple images in one HTML file. This is useful for quick visual 

scans. For instance, you can check whether text was truncated, or choose a version from multiple data sets you’ve 

exported to one file. 

Importing data sets from external files 
You can quickly create a large number of data sets by creating an external text file that contains all the variable infor

mation and loading that file into a PSD document containing variables. One good way to accomplish this is to enter 

your data into a text file or Microsoft Excel spreadsheet and then export it to a tab or comma-separated file. 

The syntax of the external text file is as follows (where each line that starts with “Variable” or “Value” is an entire line 

by itself in your file): 

Va r  i  a  b  leNa me1<s ep>Va r  ia  b  l  eNa m e2<s  ep> <s  ep>Va r  ia  b  l  eNa m eN <nl>


Va l  u  e1-1<s  ep>Val  ue2-1<s  ep> <s  ep>Val  ueN-1<nl>


Va l  u  e1-2<s  ep>Val  ue2-2<s  ep> <s  ep>Val  ueN-2<nl>


Va l  u  e1-M<s ep>Val  ue2-M<s ep> <s  ep>Va l  ueN-M<nl>


All the variable names are listed on the first line, in the order that the values are given in subsequent lines. Each subse


quent line represents one data set, with the values for each variable given.


External text file syntax elements 

<sep> Either a comma-separated (CSV) or a 
tab (tab-delimited) file that separates 
each variable name or value. 

<nl> A newline character that ends each 
data set and can be a line feed, carriage 
return, or both. 

“true” and “false” Allowed values for a visibility variable. 

Spaces Spaces around the delimiter are 
removed when parsing the file; 
between words in a value string (e.g., 
two of a kind) spaces are maintained 
and leading and trailing spaces are 
maintained if enclosed in double 
quotes (e.g., “one kind ”). 

Double quotes Can be part of a value if preceded by 
another double quote (e.g., ““B”” would 
be “B” in the data set). 

If <sep> or <nl> is part of the variable value, then the entire value must be enclosed in double quotes.


All variables defined in the PSD document must be defined in the text file. An error is displayed if the number of


variables in the text file does not match the number in the document.


Example data set:


Using a template for flowers that holds variables for tulip and sunflower, you can set up a text file that looks like this:
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{co n t  ents  o  f  F lo  w erS  h  o  w.txt}  

Va r  i  a  b  le1 ,  Va r  i  a  b  le2 ,  Va r  i  a  b  le3  

tr  ue  ,  TULIP,  c : \My D o c  u  ments\t  u  l  i  p. j  pg  

fa ls  e  ,  S  UNFL OWER ,  c : \MyD o c  umen ts\s  unf  l  o  w er. j  pg  

fa ls  e  ,  CALL A LILY,  c : \My D o c  u  men ts\ca l la . j  pg  

tr  ue  ,  VI  O L ET,  c : \My D o c  u  men ts\vio  le t . j  p  g  

Note: You can  use a relative  path  for the  image location if the  text  file  is  in  the same folder as the  image file.  For example,  

the last item in the example can be: true, VIOLET, violet.jpg. 

To import a data set 
1 Do one of the following: 

• Choose File > Import > Variable Data Sets.


• Choose Image > Variables > Data Sets and click the Import button.


2 Navigate to the text file to import.


3 Set up your import options.


Use First Column For Data Set Names Names each data set using the content of the first column of the text file (the


values for the first variable listed). Otherwise, the data sets are named “Data Set 1, Data Set 2, and so on.”


Replace Existing Data Sets Deletes any existing data sets before importing. 

4 Set the encoding of the text file or leave the setting Automatic. 

5 Click OK. 
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Chapter 26: Keyboard Shortcuts


Customizing keyboard shortcuts 

About customizing keyboard shortcuts 
Photoshop lets you view a list of all shortcuts, and edit or create shortcuts. The Keyboard Shortcuts dialog box serves 

as a shortcut editor, and includes all commands that support shortcuts, some of which aren’t addressed in the default 

shortcut set. 

If the default shortcut set is insufficient, you can create additional sets. For example, you can create separate sets for 

different workspaces chosen from the Window > Workspace menu. 

In addition to using keyboard shortcuts, you can access many commands using context-sensitive menus. Context

sensitive menus display commands that are relevant to the active tool, selection, or palette. To display a context

sensitive menu, right-click (Windows) or Control-click (Mac OS) in the document window or palette. 

To define new keyboard shortcuts 
1 Do one of the following: 

• Choose Edit > Keyboard Shortcuts.


• Choose Window > Workspace > Keyboard Shortcuts & Menus and click the Keyboard Shortcuts tab.


2 Choose a set of shortcuts from the Set menu at the top of the Keyboard Shortcuts and Menus dialog box


(Photoshop Defaults is the only option until you create a new set).


3 Choose a shortcut type from the Shortcuts For menu:


Application Menus Lets you customize keyboard shortcuts for items in the menu bar.


Palette Menus Lets you customize keyboard shortcuts for items in palette menus. 

Tools Lets you customize keyboard shortcuts for tools in the toolbox. 

4 In the Shortcut column of the scroll list, select the shortcut you want to modify. 

5 Type a new shortcut. 

If the keyboard shortcut is already assigned to another command or tool in the set, an alert appears. Click Accept to 

assign the shortcut to the new command or tool and erase the previously assigned shortcut. After you reassign a 

shortcut, you can click Undo Changes to undo the change, or click Accept and Go To Conflict to assign a new 

shortcut to the other command or tool. 

6 When you finished changing shortcuts, do one of the following: 

• To save all changes to the current set of keyboard shortcuts, click the Save Set button . Changes to a custom set 

are saved. If you’re saving changes to the Photoshop Defaults set, the Save dialog box opens. Enter a name for the 

new set and click Save. 

• To create a new set based on the current set of shortcuts, click the Save Set As button . In the Save dialog box, 

enter a name for the new set in the Name text box, and click Save. The new keyboard shortcut set will appear in 

the pop-up menu under the new name. 

• To discard the last saved change without closing the dialog box, click Undo. 
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•	 To return a new shortcut to the default, click Use Default. 

•	 To export the displayed set of shortcuts, click Summarize. You can use this HTML file to display the set of shortcuts 

in a web browser. 

•	 To discard all changes and exit the dialog box, click Cancel. 

Note: If you haven’t saved the current set of changes, you can click Cancel to discard all changes and exit the dialog box. 

Click a command row and enter a shortcut key in the empty text box to add a new shortcut. 

To clear shortcuts from a command or tool

1 Choose Edit > Keyboard Shortcuts.


2 In the Keyboard Shortcuts dialog box, select the command or tool name whose shortcut you want to delete.


3 Click Delete Shortcut.


To delete a set of shortcuts

1 Choose Edit > Keyboard Shortcuts.


2 In the Set pop-up menu, choose the shortcut set that you want to delete.


3 Click the Delete icon
  and then OK to exit the dialog box. 

Default keyboard shortcuts 

Keys for selecting tools 
In Photoshop, shortcuts are customizable by using the Keyboard Shortcuts command. Choose Edit > Keyboard 

Shortcuts. For more information, see “To define new keyboard shortcuts” on page 754. 

Mac OS X users: In ImageReady, when the Use System Shortcuts preference is enabled, certain ImageReady keyboard 

shortcuts are usurped by OS X keyboard shortcuts. (For example, with the preference on, Command+H hides the 

application. With the preference off, Command+H shows/hides Extras.) To prevent this, press the Control key in 

addition to the shortcut or choose ImageReady > Preferences > General and deselect Use System Shortcuts. 
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Result Windows Mac OS 

Cycle through tools with the same shortcut Shift-press shortcut key (*when Use Shift Shift-press shortcut key (*when Use Shift 
key Key for Tool Switch preference is disabled) Key for Tool Switch preference is disabled) 

Cycle through hidden tools Alt-click + tool (*except add anchor point, Option-click + tool (*except add anchor 
delete anchor point, and convert point point, delete anchor point, and convert 
tools) point tools) 

Rectangular Marquee tool† M M 

Rounded Rectangle Marquee tool§ 

Elliptical Marquee tool 

Single Row Marquee tool M§ M§ 

Single Column Marquee tool M§ M§ 

Move tool V V 

Lasso tool L L 

Polygonal Lasso tool 

Magnetic Lasso tool* 

Magic Wand tool W W 

Crop tool C C 

Slice tool K K 

Slice Select tool K*, O§ K*, O§ 

Spot Healing Brush tool* J J 

Healing Brush tool* 

Patch tool* 

Red Eye tool* 

Brush tool B B 

Pencil tool 

Color Replacement tool* 

Clone Stamp tool S*, B§ S*, B§ 

Pattern Stamp tool* S S 

History Brush tool* Y Y 

Art History Brush tool* 

Eraser tool† E E 

Background Eraser tool* 

Magic Eraser tool 

Gradient tool* G G 

Paint Bucket tool 

Blur tool* R R 

Sharpen tool* 

Smudge tool* 
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Result Windows Mac OS 

Dodge tool* 

Burn tool* 

Sponge tool* 

O O 

Path Selection tool* 

Direct Selection tool* 

A A 

Horizontal Type tool 

Vertical Type tool* 

Horizontal Type mask tool* 

Vertical Type mask tool* 

T T 

Pen tool* 

Freeform Pen tool* 

P P 

Rectangle tool 

Rounded Rectangle tool 

Ellipse tool 

Polygon tool* 

Line tool 

Custom Shape tool* 

U 

U*, S§ 

U 

U*, S§ 

Notes tool* 

Audio Annotation tool* 

N N 

Eyedropper tool† 

Color Sampler tool* 

Measure tool* 

I I 

Hand tool† H H 

Zoom tool† Z Z 

Rectangle Image Map tool§ 

Circle Image Map tool§ 

Polygon Image Map tool§ 

P P 

Image Map Select tool§ J J 

Tab Rectangle tool§ 

Pill Rectangle tool§ 

R R 

* Not in ImageReady 

§ ImageReady only 

†Use same shortcut keys for Extract*, Liquify, and Pattern Maker* 
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Keys for selecting tools in the Extract toolbox 

Result Windows Mac OS 

Edge Highlighter tool B B 

Fill tool G G 

Eyedropper tool I I 

Cleanup tool C C 

Edge Touchup tool T T 

Keys for selecting tools in the Liquify toolbox 

Result Windows Mac OS 

Forward Warp tool W W 

Reconstruct tool R R 

Twirl Clockwise tool C C 

Pucker tool S S 

Bloat tool B B 

Push Left tool O O 

Mirror tool M M 

Turbulence tool T T 

Freeze Mask tool F F 

Thaw Mask tool D D 

Keys for working with Extract*, Liquify, and Pattern Maker* 

Result (Extract*, Liquify, and Pattern 
Maker*) 

Windows Mac OS 

Cycle through controls on right from top Tab Tab 

Cycle through controls on right from bot
tom 

Shift + Tab Shift + Tab 

Temporarily activate Hand tool Spacebar Spacebar 

Change Cancel to Reset Alt Option 

Result (Extract* and Liquify) Windows Mac OS 

Decreases or increases brush size Up or Down arrow keys Up or Down arrow keys 

 



ADOBE PHOTOSHOP CS2 759 
User Guide 

Result (Extract* and Pattern Maker*) Windows Mac OS 

Fit in window Control + 0 Command + 0 

Temporarily selects Zoom In tool Control + Spacebar Command + Spacebar 

Select Zoom Out tool Alt + Spacebar Option + Spacebar 

Result (Extract* only) Windows Mac OS 

Toggle between Edge Highlighter tool and Alt Option 
Eraser tool 

Toggle Smart Highlighting Control with Edge Highlighter tool selected Command with Edge Highlighter tool 
selected 

Remove current highlight Alt + Delete Option + Delete 

Highlight entire image Control + Delete Command + Delete 

Fill foreground area and preview extraction Shift-click with Fill tool selected Shift-click with Fill tool selected 

Move mask when Edge Touchup tool is Control-drag Command-drag 
selected 

Add opacity when Cleanup tool is selected Alt-drag Option-drag 

Toggle Show menu options in preview X X 
between Original and Extracted 

Enable Cleanup and Edge Touchup tools Shift + X Shift + X 
before preview 

Cycle through Display menu in preview F F 
from top to bottom 

Cycle through Display menu in preview Shift + F Shift + F 
from bottom to top 

Decrease/increase brush size by 1 Down Arrow/Up Arrow in Brush Size text Down Arrow or Up Arrow in Brush Size text 
box† box† 

Decrease/increase brush size by 1 Left Arrow/Right Arrow with Brush Size Left Arrow/Right Arrow with Brush Size 
Slider showing† Slider showing† 

Set strength of Cleanup or Edge Touch-up 0–9 0–9 
tool 

†Hold down Shift to decrease/increase by 10 

Result (Liquify only) Windows Mac OS 

Reverse direction for Bloat, Pucker, Push Alt + tool Option + tool 
Left, and Mirror tools 

Continually sample the distortion Alt-drag in preview with Reconstruct tool, Option-drag in preview with reconstruct 
Displace, Amplitwist, or Affine mode tool, Displace, Amplitwist or Affine mode 
selected selected 

Decrease/increase brush size by 2, or den- Down Arrow/Up Arrow in Brush Size, Den- Down Arrow/Up Arrow in Brush Size, Den
sity, pressure, rate, or turbulent jitter by 1 sity, Pressure, Rate, or Turbulent Jitter text sity, Pressure, Rate, or Turbulent Jittertext 

box† box† 
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Result (Liquify only) Windows Mac OS 

Decrease/increase brush size by 2, or den- Left Arrow/Right Arrow with Brush Size, Left Arrow/Right Arrow with Brush Size, 
sity, pressure, rate, or turbulent jitter by 1 Density, Pressure, Rate, or Turbulent Jitter Density, Pressure, Rate, or Turbulent Jitter 

slider showing† slider showing† 

Redo last step Control + Z Command + Z 

†Hold down Shift to decrease/increase by 10 

Result (Pattern Maker* only) Windows Mac OS 

Delete current selection Control + D Command + D 

Undo a selection move Control + Z Command + Z 

Generate or generate again Control + G Command + G 

Intersect with current selection Shift + Alt + select Shift + Option + select 

Toggle view: original/generated pattern X X 

Go to first tile in Tile History Home Home 

Go to last tile in Tile History End End 

Go to previous tile in Tile History Left Arrow, Page Up Left Arrow, Page Up 

Go to next tile in Tile History Right Arrow, Page Down Right Arrow, Page Down 

Delete current tile from Tile History Delete Delete 

Nudge selection when viewing the original Right Arrow, Left Arrow, Up Arrow, or Down Right Arrow, Left Arrow, Up Arrow, or Down 
Arrow Arrow 

Increase selection nudging when viewing Shift + Right Arrow, Left Arrow, Up Arrow, or Shift + Right Arrow, Left Arrow, Up Arrow, or 
the original Down Arrow Down Arrow 

* Not in ImageReady 

Keys for using the Filter Gallery 

Result Windows Mac OS 

Apply a new filter on top of selected Alt-click on a filter Option-click on a filter 

Open/close all disclosure triangles Alt-click on a disclosure triangle Option-click on a disclosure triangle 

Change Cancel button to Default Control Command 

Change Cancel button to Reset Alt Option 

Undo/Redo Control + Z Command + Z 

Step forward Control + Shift + Z Command + Shift + Z 

Step backward Control + Alt + Z Command + Option + Z 
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Keys for using the Camera Raw dialog box 

Result Windows Mac OS 

Zoom tool Z Z 

Hand tool H H 

White Balance tool I I 

Color Sampler tool S S 

Straighten tool A A 

Rotate image left L L 

Rotate image right R R 

Zoom in Control + - (hyphen) Command + - (hyphen) 

Zoom out Control + + (plus) Command + + (plus) 

Zoom In tool temporarily (except in Curves Control Command 
panel) 

White Balance tool (temporarily Shift Shift 

Select multiple points in Curves panel Click the first point, Shift-click additional Click the first point, Shift-click additional 
points points 

Add point to curve in Curves panel Control-click in preview Control-click in preview 

Move selected point in Curves panel (1 unit) Arrow keys Arrow keys 

Move selected point in Curves panel (10 
units) 

Open selected images in Camera Raw dia- Control + R Command + R 
log box from Bridge 

Open selected images from Bridge bypass- Control + O Command + O 
ing Camera Raw dialog 

Change Cancel button to Reset and Save Alt Option 
button to bypass Save dialog 

Display highlights that will be clipped in Alt-drag Exposure or Shadows sliders Option-drag Exposure or Shadows sliders 
Preview 

Skip file conversion when selecting multiple Shift Shift 
files (turn OK button to Skip) 

Keys for using Photomerge 

Result Windows Mac OS 

Select Image tool A A 

Rotate Image tool R R 

Set Vanishing Point tool V V 

Zoom tool Z Z 

Hand tool H H 
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Result Windows Mac OS 

Switch to Hand tool Spacebar Spacebar 

Step backward Control + Z Command + Z 

Step forward Control + Shift + Z Command + Shift + Z 

Move selected image 1 pixel Right Arrow, Left Arrow, Up Arrow, or Down 
Arrow 

Right Arrow, Left Arrow, Up Arrow, or Down 
Arrow 

Change Cancel to Reset Alt Option 

Show individual image border Alt-move pointer over image Option-move pointer over image 

Keys for using Vanishing Point 

Result Windows Mac OS 

Zoom tool Z Z 

Zoom 2x (temporary) X X 

Hand tool H H 

Switch to Hand tool (temporary) Spacebar Spacebar 

Zoom in Control + + (plus) Control + spacebar Command + + (plus), Command + spacebar 

Zoom out Control + - (hyphen), Alt + spacebar Command + -(hyphen), Option + spacebar 

Fit in view Control + 0 (zero), Double-click Hand tool Command + 0 (zero), Double-click Hand 
tool 

Zoom to center at 100% Double-click Zoom tool Double-click Zoom tool 

Increase brush size (Brush, Clone tools) ] ] 

Decrease brush size (Brush, Clone tools) [ [ 

Increase brush hardness (Brush, Clone tools) Shift + ] Shift + ] 

Decrease brush hardness (Brush, Clone 
tools) 

Shift + [ Shift + [ 

Undo last action Control + Z Command + Z 

Redo last action Control + Shift + D Command + Shift + Z 

Deselect all Control + D Command + D 

Hide selection and planes Control + H Command + H 

Move selection 1 pixel Arrow keys Arrow keys 

Move selection 10 pixels Shift + arrow keys Shift + arrow keys 

Copy Control + C Command + C 

Paste Control + V Command + V 

Repeat last duplicate and move Control + Shift + T Command + Shift + T 

Create a floating select from the current 
selection 

Control + Alt + T Command + Option + T 
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Result Windows Mac OS 

Fill a selection with image under the pointer Alt-drag Option-drag 

Create a duplicate of a floating selection Control + Alt-drag Command + Opt-drag 

Constrain dragging to 90 degree angles Shift-drag object Shift-drag object 

Select a plane under another selected plane Control-click the plane Command-click the pane 

Render plane grids Alt-click OK Option-click OK 

Delete last node while creating plane Backspace Backspace 

Exit plane creation Control + .(period) Command + . (period) 

Make a full canvas plane, square to the cam
era 

Double-click the Create Plane tool Double-click the Create Plane tool 

Keys for working with blending modes 

Result Windows Mac OS 

Cycle through blending modes Shift + + (plus) or – (minus) Shift + + (plus) or – (minus) 

Normal Shift + Alt + N Shift + Option + N 

Dissolve Shift + Alt + I Shift + Option + I 

Behind (Brush tool only) Shift + Alt + Q Shift + Option + Q 

Clear (Brush tool only) Shift + Alt + R Shift + Option + R 

Darken Shift + Alt + K Shift + Option + K 

Multiply Shift + Alt + M Shift + Option + M 

Color Burn Shift + Alt + B Shift + Option + B 

Linear Burn Shift + Alt + A Shift + Option + A 

Lighten Shift + Alt + G Shift + Option + G 

Screen Shift + Alt + S Shift + Option + S 

Color Dodge Shift + Alt + D Shift + Option + D 

Linear Dodge Shift + Alt + W Shift + Option + W 

Overlay Shift + Alt + O Shift + Option + O 

Soft Light Shift + Alt + F Shift + Option + F 

Hard Light Shift + Alt + H Shift + Option + H 

Vivid Light Shift + Alt + V Shift + Option + V 

Linear Light Shift + Alt + J Shift + Option + J 

Pin Light Shift + Alt + Z Shift + Option + Z 

Hard Mix Shift + Alt + L Shift + Option + L 

Difference Shift + Alt + E Shift + Option + E 

Exclusion Shift + Alt + X Shift + Option + X 
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Result Windows Mac OS 

Hue Shift + Alt + U Shift + Option + U 

Saturation Shift + Alt + T Shift + Option + T 

Color Shift + Alt + C Shift + Option + C 

Luminosity Shift + Alt + Y Shift + Option + Y 

Desaturate* Sponge tool + Shift + Alt + D Sponge tool + Shift + Option + D 

Saturate* Sponge tool + Shift + Alt + S Sponge tool + Shift + Option + S 

Dodge/burn shadows* Dodge tool/Burn tool + Shift + Alt + S Dodge tool/Burn tool + Shift + Option + S 

Dodge/burn midtones* Dodge tool/Burn tool + Shift + Alt + M Dodge tool/Burn tool + Shift + Option + M 

Dodge/burn highlights* Dodge tool/Burn tool + Shift + Alt + H Dodge tool/Burn tool + Shift + Option + H 

Set blending mode to Threshold for bitmap 
images, Normal for all other images* 

Shift + Alt + N Shift + Option + N 

* Not in ImageReady 

Keys for viewing images 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Cycles through open documents Control + Tab Control + Tab 

Close a file in Photoshop and open Bridge Shift-Control-W Shift-Command-W 

Toggle between Standard mode and Quick 
mask mode* 

Q Q 

Toggle between Standard screen mode, Full 
screen mode, and Full screen mode with 
menu bar 

F F 

Toggle image maps visibility§ A A 

Toggle slices visibility§ Q Q 

Preview document§ Y Y 

Preview in default browser§ Control + Alt + P Command + Option + P 

Edit in ImageReady* 

Edit in Photoshop§ 

Control + Shift + M Command + Shift + M 

Fit image in window Double-click Hand tool Double-click Hand tool 

Magnify 100% Double-click zoom tool Double-click zoom tool 

Switch to Hand tool (when not in text-edit 
mode) 

Spacebar Spacebar 

Switch to Zoom In tool Control + Spacebar Command + Spacebar 

Switch to Zoom Out tool Alt + Spacebar Option + Spacebar 
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Result Windows Mac OS 

Move zoom marquee while dragging with 
the zoom tool* 

Spacebar-drag Spacebar-drag 

Apply zoom percentage, and keep zoom 
percentage box active* 

Shift + Enter in Navigator palette Shift + Return in Navigator palette 

Zoom in on specified area of an image* Control-drag over preview in Navigator pal
ette 

Command-drag over preview in Navigator 
palette 

Scroll image with Hand tool* Spacebar-drag, or drag view area box in 
Navigator palette 

Spacebar-drag, or drag view area box in 
Navigator palette 

Scroll up or down 1 screen Page Up or Page Down† Page Up or Page Down† 

Scroll up or down 10 units Shift + Page Up or Page Down† Shift + Page Up or Page Down† 

Move view to upper left corner or lower 
right corner 

Home or End Home or End 

Toggle layer mask on/off as rubylith* \ (backslash) \ (backslash) 

* Not in ImageReady 

§ ImageReady only 

†Hold down Ctrl (Windows) or Command (Mac OS) to scroll left (Page Up) or right (Page Down) 

Keys for selecting and moving objects 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Reposition marquee while selecting‡ Any marquee tool (except single column Any marquee tool (except single column 
and single row) + spacebar-drag and single row) + spacebar-drag 

Add to, or intersect a selection Any selection tool + Shift-drag Any selection tool + Shift-drag 

Subtract from a selection Any selection tool + Alt-drag Any selection tool + Option-drag 

Intersect a selection Any selection tool + Shift-Alt-drag Any selection tool + Shift-Option-drag 

Constrain marquee to square or circle (if no Shift-drag Shift-drag 
other selections are active)‡ 

Draw marquee from center (if no other Alt-drag Option-drag 
selections are active)‡ 

Constrain shape and draw marquee from Shift + Alt-drag Shift + Option-drag 
center‡ 

Switch to Move tool Control (except when Hand, Slice, Path*, 
Shape*, Rectangle Image map§, Circle 
Image Map§, Polygon Image Map§, or any 

Command (except when Hand, Slice, Path*, 
Shape*, Rectangle Image map§, Circle 
Image Map§, Polygon Image Map§, or any 

Pen* tool is selected) Pen* tool is selected) 

Switch from Magnetic Lasso tool to Lasso Alt-drag Option-drag 
tool* 

Switch from Magnetic Lasso tool to polygo- Alt-click Option-click 
nal Lasso tool* 
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Result Windows Mac OS 

Apply/cancel an operation of the Magnetic Enter/Esc or Control+period Return/Esc or Command + period 
Lasso* 

Move copy of selection Move tool + Alt-drag selection‡ Move tool + Option-drag selection‡ 

Move selection area 1 pixel Any selection + Right Arrow, Left Arrow, Up Any selection + Right Arrow, Left Arrow, Up 
Arrow, or Down Arrow† Arrow, or Down Arrow† 

Move selection 1 pixel Move tool + Right Arrow, Left Arrow, Up Move tool + Right Arrow, Left Arrow, Up 
Arrow, or Down Arrow†‡ Arrow, or Down Arrow†‡ 

Move layer 1 pixel when nothing selected Control + Right Arrow, Left Arrow, Up Arrow,  Command + Right Arrow, Left Arrow, Up 
on layer or Down Arrow† Arrow, or Down Arrow† 

Increase/decrease detection width* Magnetic Lasso tool + [ or ] Magnetic Lasso tool + [ or ] 

Accept cropping or exit cropping Crop tool + Enter or Esc Crop tool + Return or Esc 

Toggle crop shield off and on* / (forward slash) / (forward slash) 

Make protractor* Measure tool + Alt-drag end point Measure tool + Option-drag end point 

Snap guide to ruler ticks (*except when Shift-drag guide Shift-drag guide 
View > Snap is unchecked) 

Convert between horizontal and vertical Alt-drag guide Option-drag guide 
guide 

* Not in ImageReady 

§ ImageReady only 

†Hold down Shift to move 10 pixels 

‡Applies to shape tools 

Keys for editing paths 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Select multiple anchor points Direct selection tool + Shift-click Direct selection tool + Shift-click 

Select entire path Direct selection tool + Alt-click Direct selection tool + Option-click 

Duplicate a path Pen (any pen tool), Path Selection or Direct Pen (any pen tool), Path Selection or Direct 
Selection tool + Control + Alt-drag Selection tool+ Command + Option-drag 

Switch from Path Selection, Pen, Add Control Command 
Anchor Point, Delete Anchor Point, or Con
vert Point tools, to Direct Selection tool 

Switch from Pen tool or Freeform Pen tool to Alt Option 
Convert Point tool when pointer is over 
anchor or direction point 

Close path Magnetic Pen tool-double-click Magnetic Pen tool-double-click 

Close path with straight-line segment Magnetic Pen tool + Alt-double-click Magnetic Pen tool + Option-double-click 
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Keys for painting objects 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Eyedropper tool Any painting tool + Alt or any shape tool + Any painting tool + Option or any shape 
Alt (*except when Paths option is selected) tool + Option (*except when Paths option is 

selected) 

Select background color Eyedropper tool + Alt-click Eyedropper tool + Option-click 

Color sampler tool* Eyedropper tool + Shift Eyedropper tool + Shift 

Deletes color sampler* Color sampler tool + Alt-click Color sampler tool + Option-click 

Sets opacity, tolerance, strength, or expo- Any painting or editing tool + number keys Any painting or editing tool + number keys 
sure for painting mode (e.g., 0 = 100%, 1 = 10%, 4 then 5 in quick (e.g., 0 = 100%, 1 = 10%, 4 then 5 in quick 

succession = 45%) (*When airbrush option succession = 45%) (*When airbrush option 
is enabled, use Shift + number keys) is enabled, use Shift + number keys) 

Sets flow for painting mode* Any painting or editing tool + Shift + num
ber keys (e.g., 0 = 100%, 1 = 10%, 4 then 5 in 
quick succession = 45%) (*When airbrush 
option is enabled, omit Shift) 

Any painting or editing tool + Shift + num
ber keys (e.g., 0 = 100%, 1 = 10%, 4 then 5 in 
quick succession = 45%) (*When airbrush 
option is enabled, omit Shift) 

Cycles through blending modes Shift + + (plus) or – (minus) Shift + + (plus) or – (minus) 

Fills selection/layer with foreground or Alt + Backspace, or Control + Backspace† Option + Delete, or Command + Delete† 

background color 

Fills from history* Control + Alt + Backspace† Command + Option + Delete† 

Displays Fill dialog box Shift + Backspace Shift + Delete 

Lock transparent pixels on/off / (forward slash) / (forward slash) 

Connects points with a straight line Any painting tool + Shift-click Any painting tool + Shift-click 

* Not in ImageReady 

§ ImageReady only 

†Hold down Shift to preserve transparency 

Keys for transforming selections, selection borders, and paths 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Transform from center or reflect Alt Option 

Constrain Shift Shift 

Distort Control Command 

Apply Enter Return 
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Result Windows Mac OS 

Cancel Control + . (period) or Esc Command + . (period) or Esc 

Free transform with duplicate data Control + Alt + T Command + Option + T 

Transform again with duplicate data Control + Shift + Alt + T Command + Shift + Option + T 

Keys for selecting, editing, and navigating through text 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Move type in image Control-drag type when Type layer is Command-drag type when Type layer is 
selected selected 

Select 1 character left/right or 1 line Shift + Left Arrow/Right Arrow or Down Shift + Left Arrow/Right Arrow or Down 
down/up, or 1 word left/right Arrow/Up Arrow, or Control + Shift + Left Arrow/Up Arrow, or Command + Shift + Left 

Arrow/Right Arrow Arrow/Right Arrow 

Select characters from insertion point to Shift-click Shift-click 
mouse click point 

Move 1 character left/right, 1 line down/up, Left Arrow/Right Arrow, Down Arrow/Up Left Arrow/Right Arrow, Down Arrow/Up 
or 1 word left/right Arrow, or Control + Left Arrow/Right Arrow Arrow, or Command + Left Arrow/Right 

Arrow 

Create a new text layer, when a text layer is Shift-click Shift-click 
selected in the Layers palette 

Select word, line, paragraph, or story Double-click, triple-click, quadruple-click, Double-click, triple-click, quadruple-click, 
or quintuple-click or quintuple-click 

Show/Hide selection on selected type Control + H Command + H 

Display the bounding box for transforming Control Command 
text when editing text, or activate Move 
tool if cursor is inside the bounding box* 

Scale text within a bounding box when Control-drag a bounding box handle Command-drag a bounding box handle 
resizing the bounding box* 

Move text box while creating text box Spacebar-drag Spacebar-drag 

* Not in ImageReady 

Keys for formatting type 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Align left, center, or right* Horizontal type tool + Control + Shift + L, C, 
or R 

Horizontal type tool + Command + Shift + L, 
C, or R 

Align top, center, or bottom* Vertical type tool + Control + Shift + L, C, or 
R 

Vertical type tool + Command + Shift + L, C, 
or R 

Return to default font style Control + Shift + Y Command + Shift + Y 
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Result Windows Mac OS 

Choose 100% horizontal scale* Control + Shift + X Command + Shift + X 

Choose 100% vertical scale* Control + Shift + Alt + X Command + Shift + Option + X 

Choose Auto leading* Control + Shift + Alt + A Command + Shift + Option + A 

Choose 0 for tracking* Control + Shift + Q Command + Control + Shift + Q 

Justify paragraph, left aligns last line* Control + Shift + J Command + Shift + J 

Justify paragraph, justifies all* Control + Shift + F Command + Shift + F 

Toggle paragraph hyphenation on/off* Control + Shift + Alt + H Command + Control + Shift + Option + H 

Toggle single/every-line composer on/off* Control + Shift + Alt + T Command + Shift + Option + T 

Decrease or increase type size of selected 
text 2 points or pixels 

Control + Shift + < or >† Command + Shift + < or >† 

Decrease or increase leading 2 points or pix
els 

Alt + Down Arrow or Up Arrow†† Option + Down Arrow or Up Arrow†† 

Decrease or increase baseline shift 2 points 
or pixels 

Shift + Alt + Down Arrow or Up Arrow†† Shift + Option + Down Arrow or Up Arrow†† 

Decrease or increase kerning/tracking 
20/1000 ems 

Alt + Left Arrow or Right Arrow†† Option + Left Arrow or Right Arrow†† 

* Not in ImageReady 

†Hold down Alt (Win) or Option (Mac OS) to decrease/increase by 10 

††Hold down Ctrl (Windows) or Command (Mac OS) to decrease/increase by 10 

Keys for slicing and optimizing 

Result Windows Mac OS 

Toggle browser dither for selected image 
pane in Optimized view§ 

Control + Shift + Y Command + Shift + Y 

Toggle through gamma previews in 
selected image pane§ 

Control + Alt + Y Command + Option + Y 

Toggle through Optimized/2up/4up/Origi-
nal window§ 

Control + Y Command + Y 

Toggle between Slice tool and Slice Selec
tion tool 

Control Command 

Draw square slice Shift-drag Shift-drag 

Draw from center outward Alt-drag Option-drag 

Draw square slice from center outward Shift + Alt-drag Shift + Option-drag 

Reposition slice while creating slice Spacebar-drag Spacebar-drag 

Open context-sensitive menu Right-click on slice Control-click on slice 

§ ImageReady only 
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Keys for using palettes 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 

Result Windows Mac OS 

Set options (except for Actions, Animation, Alt-click New button Option-click New button 
Styles, Brushes*, Tool Presets*, and Layer 
Comps palettes) 

Delete without confirmation (except for the Alt-click Delete button Option-click Delete button 
Brushes* palette) 

Apply value and keep text box active* Shift + Enter Shift + Return 

Load as a selection Control-click channel, layer, or path thumb- Command-click channel, layer, or path 
nail. Control + Alt-click layer in ImageReady thumbnail. Command + Option-click layer 

in ImageReady 

Add to current selection Control + Shift-click channel, layer, or path Command + Shift-click channel, layer, or 
thumbnail. Control + Shift + Alt-click layer in path thumbnail. Command + Shift + 
ImageReady Option-click layer in ImageReady 

Subtract from current selection* Control + Alt-click channel, path, or layer Command + Option-click channel, path, or 
thumbnail layer thumbnail 

Intersect with current selection* Control + Shift + Alt-click channel, path or Command + Shift + Option-click channel, 
layer thumbnail path, or layer thumbnail 

Show/Hide all palettes Tab Tab 

Show/Hide all palettes except the toolbox Shift + Tab Shift + Tab 
and options bar 

Highlight options bar Select tool and press Enter Select tool and press Return 

Increase/decrease units by 10 in a pop-up Shift + Up Arrow/Down Arrow Shift + Up Arrow/Down Arrow 
menu 

* Not in ImageReady 

Keys for using the Actions palette 

Result Windows Mac OS 

Turn command on and all others off, or Alt-click the check mark next to a command Option-click the check mark next to a com
turns all commands on* mand 

Turn current modal control on and toggle Alt-click Option-click 
all other modal controls* 

Change action set options Alt + double-click action set Option + double-click action set 

Display Options dialog box Double-click set or actions. Alt + double- Double-click set or actions. Alt + double
click set or action in ImageReady click set or action in ImageReady 

Play entire action Control + double-click an action Command + double-click an action 

Collapse/expand all components of an Alt-click the triangle Option-click the triangle 
action 

Play a command Control-click the Play button Command-click the Play button 
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Result Windows Mac OS 

Create new action and begin recording 
without confirmation 

Alt-click the New Action button Option-click the New Action button 

Select contiguous items of the same kind* Shift-click the action/command Shift-click the action/command 

Select non-contiguous items of the same 
kind* 

Control-click the action/command Command-click the action/command 

* Not in ImageReady 

Keys for using the Animation palette 

Result Windows Mac OS 

Select/deselect multiple contiguous frames Shift-click on second frame Shift-click on second frame 

Select/deselect multiple discontiguous Control-click on multiple frames Command-click multiple frames 
frames 

Paste using previous settings without dis- Alt + Paste Frames command from the pal- Option + Paste Frames command from the 
playing the dialog ette pop-up menu palette pop-up menu 

Keys for using the Brushes palette 

Result Windows Mac OS 

Delete brush* Alt-click brush Option-click brush 

Rename brush* Double-click brush Double-click brush 

Decrease/increase brush size* [ or ] [ or ] 

Decrease/increase brush softness/hardness 
in 25% increments* 

Shift + [ or ] Shift + [ or ] 

Select previous/next brush size* , (comma) or . (period) , (comma) or . (period) 

Select previous/next brush size§ [ or ] [ or ] 

Select first/last brush* Shift + , (comma) or . (period) Shift + , (comma) or . (period) 

Select first/last brush§ Shift + [ or ] Shift + [ or ] 

Display precise cross hair for brushes Caps Lock Caps Lock 

Toggle airbrush option* Shift + Alt + P Shift + Option + P 

* Not in ImageReady 

§ ImageReady only 
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Keys for using the Channels palette 

Result Windows Mac OS 

Set options for Save Selection as Channel Alt-click button Option-click button 
button 

Create a new spot channel Control-click Create New Channel button Command-click Create New Channel but
ton 

Select/deselect multiple color-channel Shift-click color channel Shift-click color channel 
selection 

Select/deselect alpha channel and Shift-click alpha channel Shift-click alpha channel 
show/hide as a rubylith overlay 

Display channel options Double-click alpha or spot channel thumb- Double-click alpha or spot channel thumb
nail nail 

Display composite ~ (tilde) ~ (tilde) 

Keys for using the Color palette 

Result Windows Mac OS 

Select background color Alt-click color in color bar Option-click color in color bar 

Display Color Bar menu Right-click color bar Control-click color bar 

Cycle through color choices Shift-click color bar Shift-click color bar 

Keys for using the Color Table palette (ImageReady) 

Result Windows Mac OS 

Select background color Alt-click swatch Option-click swatch 

Select multiple contiguous colors; last color Shift-click a second swatch Shift-click a second swatch 
clicked becomes foreground color 

Select discontiguous colors; last color Control-click multiple swatches Command-click multiple swatches 
clicked becomes foreground color 

Add current background color Alt-click New Color button or drag color Option-click New Color button or drag color 
proxy from Tools palette onto color table proxy from Tools palette onto color table 

Add current foreground color Click New Color button or drag color proxy Click New Color button or drag color proxy 
from Tools palette to New Color button from Tools palette to New Color button 

Keys for using the History palette 

Result Windows Mac OS 

Rename snapshot* Double-click snapshot name Double-click snapshot name 

Step forward through image states Control + Shift + Z Command + Shift + Z 

Step backward through image states* Alt + Shift + Z Option + Shift + Z 
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Result Windows Mac OS 

Duplicate any image state, except the cur
rent state* 

Alt-click the image state Option-click the image state 

Permanently clear history (no Undo)* Alt + Clear History (in History palette 
pop-up menu) 

Option + Clear History (in History palette 
pop-up menu) 

* Not in ImageReady 

Keys for using the Info palette 

Result Windows Mac OS 

Change color readout modes* Click eyedropper icon Click eyedropper icon 

Change measurement units* Click cross-hair icon Click cross-hair icon 

* Not in ImageReady 

Keys for using the Layer Comps palette 

Result Windows Mac OS 

Create new layer comp + box Alt-click Create New Layer Comp button Option-click Create New Layer Comp but
ton 

Opens Layer Comp Options dialog box Double-click layer comp Double-click layer comp 

Rename inline Double-click layer comp name Double-click layer comp name 

Select/deselect multiple contiguous layer 
comps 

Shift-click Shift-click 

Select/deselect multiple discontiguous 
layer comps 

Control-click Command-click 

Keys for using the Layers palette 

Result Windows Mac OS 

Load layer transparency as a selection Control-click layer thumbnail Command-click layer thumbnail 

Group layers Control + G Command + G 

Ungroup layers Control + Shift + G Command-Shift + G 

Create/release clipping mask Control + Alt + G Command-Option + G 

Select all layers Control + Alt + A Command + Option + A 

Merge visible layers Control + Shift + E Command + Shift + E 

Create new empty layer with dialog Alt-click New Layer button Option-click New Layer button 

Create new layer below target layer Control-click New Layer button Command-click New Layer button 

Select top layer Alt + . (period) Option + . (period) 

Select bottom layer Alt + , (comma) Option + , (comma) 

Add to layer selection in Layers palette Shift + Alt + [ or ] Shift + Option + [ or ] 
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Result Windows Mac OS 

Select next layer down/up Alt + [ or ] Option + [ or ] 

Move target layer down/up Control + [ or ] Command + [ or ] 

Merge a copy of all visible layers into target Control + Shift + Alt + E Command + Shift + Option + E 
layer 

Merge down Control + E Command + E 

Move layer to bottom or top Control + Shift + [ or ] Command + Shift + [ or ] 

Pass through blending mode for group Shift + Alt + P Shift + Option + P 

Copy current layer to layer below Alt + Merge Down command from the pal- Option + Merge Down command from the 
ette pop-up menu palette pop-up menu 

Copy all visible layers to new layer at top of Alt + Merge Visible command from the pal- Option + Merge Visible command from the 
stack ette pop-up menu palette pop-up menu 

Show/hide this layer/layer group only or all Right-click the eye icon Control-click the eye icon 
layers/layer groups 

Show/hide all other currently visible layers Alt-click the eye icon Option-click the eye icon 

Toggle lock transparency for target layer, or / (forward slash) / (forward slash) 
last applied lock 

Edit layer effect/style, options Double-click layer effect/style Double-click layer effect/style 

Hide layer effect/style Alt-double-click layer effect/style Option-double-click layer effect/style 

Reveal/hide all layers and effects§ Alt-click layer group expansion triangle Option-click layer group expansion triangle 

Edit layer style Double-click layer Double-click layer 

Disable/enable vector mask Shift-click vector mask thumbnail Shift-click vector mask thumbnail 

Open Layer Mask Display Options dialog Double-click layer mask thumbnail Double-click layer mask thumbnail 

Toggle layer mask on/off Shift-click layer mask thumbnail Shift-click layer mask thumbnail 

Toggle between layer mask/composite Alt-click layer mask thumbnail Option-click layer mask thumbnail 
image 

Toggle rubylith mode for layer mask on/off* \ (backslash), or Shift + Alt-click \ (backslash), or Shift + Option-click 

Select all type; temporarily select type tool Double-click type layer thumbnail Double-click type layer thumbnail 

Create a clipping mask Alt-click the line dividing two layers Option-click the line dividing two layers 

Rename layer Double-click the layer name Double-click the layer name 

Create new layer set below current Control-click New Layer Set button Command-click New Layer Set button 
layer/layer set 

Create new layer set with dialog Alt-click New Layer Set button Option-click New Layer Set button 

Create layer mask that hides all/selection Alt-click Add Layer Mask button Option-click Add Layer Mask button 

Create vector mask that reveals all/selection Control-click Add Layer Mask button Command-click Add Layer Mask button 

Create vector mask that hides all/selection Control + Alt-click Add Layer Mask button Command + Option-click Add Layer Mask 
button 

Display layer group properties Right-click on layer group, Double-click Control-click the layer group, double-click 
group group 
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Result Windows Mac OS 

Display layer options§ Alt + double-click layer Option + double-click layer 

Select/deselect multiple contiguous layers Shift-click Shift-click 

Select/deselect multiple discontiguous lay
ers 

Control-click Command-click 

* Not in ImageReady 

§ ImageReady only 

Keys for using the Paths palette 

Result Windows Mac OS 

Add path to selection Control + Shift-click path name Command + Shift-click path name 

Subtract the path from selection Control + Alt-click path name Command + Option-click path name 

Retain intersection of path as a selection Control + Shift + Alt-click path name Command + Shift + Option-click path name 

Hide path Control + Shift + H Command + Shift + H 

Set options for Fill Path with Foreground 
Color button, Stroke Path with Brush but
ton, Load Path as a Selection button, Make 
Work Path from Selection button, and Cre
ate New Path button 

Alt-click button Option-click button 

Keys for using the Swatches palette 

Result Windows Mac OS 

Create new swatch from foreground color* Click in empty area of palette Click in empty area of palette 

Select background color Control-click swatch Command-click swatch 

Delete color Alt-click swatch Option-click swatch 

Select multiple contiguous colors§ Shift-click on a second color Shift-click on a second color 

Select multiple discontiguous colors§ Control-click on multiple colors Command-click on multiple colors 

* Not in ImageReady 

§ ImageReady only 

Keys for using the Web Content palette (ImageReady) 

Result Windows Mac OS 

Edit image map name and show Image Map Double-click image map thumbnail Double-click image map thumbnail 
palette 

Edit mouse action for rollover state Double-click rollover state thumbnail Double-click rollover state thumbnail 
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Result Windows Mac OS 

Edit image slice name and show Slice pal- Double-click image slice thumbnail Double-click image slice thumbnail 
ette 

Toggle visibility of animation frames Right-click state with an animated frame Control-click state with an animated frame 
icon and select new state from context icon and select new state from context 
menu menu 

Create an image map rollover Control-click Create Layer-based Rollover Command-click Create Layer-based Roll
button over button 

Function keys 

Result Windows Mac OS 

Invoke Help F1 Help key 

Undo/Redo* F1 

Cut* F2 F2 

Copy* F3 F3 

Paste* F4 F4 

Show/Hide Brushes palette* 

Show/Hide Slice palette§ 

F5 F5 

Show/Hide Color palette F6 F6 

Show/Hide Layers palette F7 F7 

Show/Hide Info palette F8 F8 

Show/Hide Actions palette* F9 Option + F9*, Control + F9§ 

Show/Hide Optimize palette§ F10 Control + F10 

Show/Hide Animation palette§ F11 Control + F11 

Revert F12 F12 

Fill* Shift + F5 Shift + F5 

Feather Selection* Shift + F6 Shift + F6 

Inverse Selection* Shift + F7 Shift + F7 

* Not in ImageReady 

§ ImageReady only 

Keys for working with Adobe Bridge 
This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu 

commands or tool tips. 
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Result Windows Mac OS 

Open Adobe Bridge from other Creative 
Suite application 

Control + Alt + O, Control + Shift + O Command + Option + O, Command + Shift 
+ O 

Switch to the next open Bridge window Control + ~ Command + ~ 

Switch to previous Bridge window Shift + Control + ~ Shift + Command + ~ 

Switches to the next view (As Thumbnails. 
As Filmstrip, As Details, or As Versions And 
Alternates) 

Control + \ Command + \ 

Switch to user-defined workspaces Control + F6 through Control + F12 Command + F6 through Command + F12 

Switch to previous view Shift + Control + \ Shift + Command + \ 

Show all files Alt + Control + F Option + Command + F 

Show files with 1 or more stars Alt + Control + 1 Option + Command + 1 

Show files with 2 or more stars Alt + Control + 2 Option + Command + 2 

Show files with 3 or more stars Alt + Control + 3 Option + Command + 3 

Show files with 4 or more stars Alt+Control+4 Option + Command + 4 

Show files with 5 stars Alt + Control + 5 Option + Command + 5 

Show files with label 1 Alt + Control + 6 Option + Command + 6 

Show files with label 2 Alt + Control + 7 Option + Command + 7 

Show files with label 3 Alt + Control + 8 Option + Command + 8 

Show files with label 4 Alt + Control + 9 Option + Command + 9 

Open selected image in the Camera Raw 
dialog box in Bridge 

Control + R Command + R 

Open selected image with saved camera 
raw settings in Photoshop 

Shift + Control + O Shift + Command + O 

Copy camera raw settings from selected file Alt + Control + C Option + Command + C 

Paste camera raw settings into selected file Alt + Control + V Option + Command + V 

Mark selected Version Cue file as in use Shift + Control + M Shift + Command + M 

Synchronize local view and server view of 
selected Version Cue file 

Shift + Control + B Shift + Command + B 

Make selected Version Cue files alternates 
of each other. 

Shift + Control + G Shift + Command + G 

Create saved version of selected Version 
Cue file 

Shift + Control + V Shift + Command + V 

Open Version Cue Versions dialog box Shift + Alt + Control + V Shift + Option + Command + V 

Return to last application that launched 
Bridge 

Alt + Control + O Option + Command + O 

Delete selected file Control + Backspace Command + Backspace 

Move up a folder (in folder view) or a row Up Arrow Up Arrow 
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Result Windows Mac OS 

Move down a folder (in folder view) or a row Down Arrow Down Arrow 

Move up a level (in folder view) Control + Up Arrow Command + Up Arrow 

Move left one item Left Arrow Left Arrow 

Move right one item Right Arrow Right Arrow 

Move to the first item Home Home 

Move to the last item End End 

Add to selection (discontiguous) Control-click Command-click 

Refresh tree and thumbnail panes F5 F5 

Add an item to the selection Shift + Right Arrow, Left Arrow, Up Arrow, or Shift + Right Arrow, Left Arrow, Up Arrow, or 
Down Arrow Down Arrow 

Rotate image clockwise Control + ] Command + ] 

Rotate image counterclockwise Control + [ Command + [ 

Launch File Bridge in maximized state and Control-click the Open Bridge icon in the Command-click the Open Bridge icon in the 
auto-hide palettes options bar options bar 

Open File Info dialog box Control + Alt + I Command + Option + I 

Display Help F1 F1 

Keys for selecting in Version Cue 

Result Windows Mac OS 

Select all A + Control-click A + Command-click 

Select entries (selective) Control-click Command-click 

Select entries (range) Shift-click Shift-click 

Select next entry Down Arrow Down Arrow 

Select previous entry Up Arrow Up Arrow 

Select next entry (additive) Shift + Down arrow Shift + DownAarrow 

Select previous entry (additive) Shift + Up Arrow Shift + Up Arrow 

Select first entry Page Up or Home Page Up or Home 

Select last entry Page down or home Page Down or Home 

Keys for navigation in Version Cue 

Result Windows Mac OS 

Open folder Control + O Command + O 

New folder Control + N Command + N 

Up one level Backspace Command + Up Arrow 
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Result Windows Mac OS 

Open selected file Enter Return 

Delete selected file or files Delete Command + backspace 

Cancel dialog Escape Escape 

Keys for viewing in Version Cue 

Result Windows Mac OS 

Details Control + 1 Command + 1 

Icons Control + 2 Command + 2 

Thumbnails Control + 3 Command + 3 

Tiles Control + 4 Command + 4 
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Index


A 

Accented Edges filter 518


action sets 738


actions


about 729


adding commands to 734


adjusting tonal range and color


with 282


button mode in 729


creating new 731


deleting 737


duplicating 737


excluding commands from 733


inserting nonrecordable


commands in 733


inserting paths in 732


inserting stops in 732


loading in Photoshop 738


modal controls for 733


optimizing slices with 736


playing 730


processing files with droplets 745


rearranging 737


recording 731


recording again 734


recording tools in 733


recording with conditional


statements 735


renaming 737


resizing images with 736


saving in Photoshop 738


setting modal controls for 733


specifying output folders


during 735


undoing 730


Actions palette


about 729


keyboard shortcuts for 770


active layer 399


Actual Pixels view 53


Actual Size view 53


Adaptive color palette 239


Add Noise filter 520


Add option 447


Add To Favorites command 89


Add To Master Palette command 643


adding HTML text to slices 589


adjustment layers


about 281, 423


creating 424, 425


editing 426


merging 426


Adobe Acrobat


working with Version Cue 114


Adobe applications, integration


between 700


Adobe Bridge


See also Bridge window


about 79


adding files to Version Cue


projects 132


creating Version Cue projects


in 124


Creative Suite color settings 252,


254


deleting Version Cue files in 141,


142


deleting Version Cue projects


in 140


revealing Version Cue files in 130


Adobe Color Picker


about 241


alerts 246


choosing 248


choosing a custom color with 246


displaying 242


out-of-gamut alert in 243


RGB Color mode 244


selecting a CMYK color with 243


selecting HSB colors with 243


selecting web-safe colors with 245


specifying a hexadecimal color


in 243


specifying a Lab color with 245


Adobe Creative Suite color


settings 252


Adobe dialog box, in Version


Cue 115


Adobe Digital Negative file format


(DNG) 679


Adobe Every-line Composer 563


Adobe GoLive


working with Version Cue 114


Adobe Illustrator


files, opening 193, 194


importing art from by placing 196


using Photoshop files in 701


Adobe InDesign


metadata in 95


Adobe PDF presets. See PDF files


Adobe Premiere 680


Adobe Press 9


Adobe RGB color space 269


Adobe Single-line Composer 563


Adobe Stock Photos


See also Stock Photo accounts


about 103


buying 107, 108


comps 106


in Bridge 79


preferences 112


redownloading photos 111


search tips 105


searching with keywords 105


shopping cart 107


viewing order details 109


Adobe Studio 7


Adobe Studio Exchange 9


Adobe Version Cue


connecting to remote projects 120


disconnecting in 137


features, availability of 113


folders 119


in Bridge 79


migrating to version 2.0 159


projects folder 118


publishing projects with


GoLive 160
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Adobe Version Cue Administration 

utility 

about 156 

deleting projects in 163 

duplicating projects in 163 

editing project properties 163 

exporting projects 164 

setting workspace preferences 158 

Adobe Version Cue projects 

adding files to 131 

backup and restoration 165 

connecting to remote projects 120 

copying 164 

copying and moving files 

between 133 

creating and editing 122 

disconnecting from 138 

displaying information about 122 

opening 119 

opening files in 129 

properties 162 

restricting access to 167 

sharing 126 

synchronizing 152 

using lock protection in 162 

working copies 118 

Adobe Version Cue Workspaces 

changing the display of 121 

creating user IDs in 168 

deleting shortcuts 137 

displaying information about 171 

logs 158, 171 

renaming 158 

restarting 116 

setting preferences for 116 

airbrush 484 

alert messages, hiding and 

showing 69 

Align Layers command 403 

Align Slices command 582 

Align To Selection command 403 

aligning 

See also Snap command 

image maps 595 

layers 403 

linked layers 330 

selections 317 

shapes 465 

slices 582 

Alignment buttons 403 

alignment. See aligning 

All Caps command 554, 555 

all caps, in type 554 

All Channels View of Histogram 

palette 276 

Allow Non-Linear History option 75 

alpha channels

 See also channels 

about 339, 438 

adding texture with 530 

appearance of selected pixels 

in 439 

calculating 446 

converting to spot channel 444 

creating 342 

deleting 442 

file formats for saving 438 

file size of 438 

in JPEG 2000 files 667 

loading a saved selection from 345 

options for 344 

saving 655 

saving selection in 344 

ALT HTML element 589, 593 

alternate glyphs 

about 546 

in OpenType fonts 556 

alternates 

groups, in Version Cue 151 

in Version Cue 148 

making primary 150 

making, in Bridge 151 

moving to another alternates 

group 152 

removing 150 

saving, in Version Cue 149 

viewing, in Bridge 149 

viewing, in Version Cue 150 

anchor points 

adding 466 

converting 467 

creating 458, 466 

deleting 466 

angle 

brush option 477 

global lighting 420 

Angled Strokes filter 518 

Angular Gradient tool 493 

animated GIFs 

See animations 

animated GIFs in rollover state 611 

Animation As Files command 672 

animation frames 

See also animations 

adding layers to 620 

copying and pasting 617 

disposal method for 620 

editing 616, 617 

exporting as files 676 

flattening into layers 621 

tweening 618 

Animation Frames As Files 

command 676 

Animation palette 615 

animations

 See also animation frames 

about 614 

adding frames to 615, 616 

changes to Frame1 or Normal State 

in 613 

creating 614, 623 

delay time 620 

deleting 617 

editing layers in 613 

frame delay 620 

importing files as 623 

looping 619 

opening files as 623 

opening QuickTime movies as 624 

optimizing 622 

previewing 621 

saving 622 

annotations 

about 687 

adding 687 

audio 688 

creating 688 

deleting 689 

editing 689 

importing 688 
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opening 689


playing 689


playing in actions 730


saving 655


showing or hiding 689


viewing in Save For Web dialog


box 627


ANPA colors 247


anti-aliasing


Adobe Illustrator files 195


EPS files 195


layer styles 418


selections 326


type 536


Appearance Of Black preferences 255


Apple Color Picker 248


AppleScript 746


applications, jumping between 34


Apply Image command 446


Arrange command 401


Arrange Slices command 582


arrowhead options 452


Art History Brush tool 472


Artistic filters 515


As Details command 85


As Filmstrip command 85


As Versions And Alternates


command 85


Asian type


about 563


aligning characters in 565


composition options for 570


formatting exceptions in 561


kinsoku shori 569


line breaking options for 569


mojikumi 568


mojisoroe 565


OpenType font attributes 566


setting options for 564


tate-chu-yoko 564


tsume 564


aspect ratio 197


Assign Profile command 267


audio annotations. See annotations

authorship information, viewing 32


Auto Color command


about 309, 310


options for 309


Auto Contrast command


about 308


options for 309


Auto Levels command


about 307, 310


clipping defaults 307


options for 309


Auto Regenerate option 631


auto slices. See slices


automated tasks


resources for 8


automated tasks, running 94


automatic frame disposal 621


automating


See also actions


batch processing 740


batches of data sets 752


saving templates for other Adobe


applications 751


through scripting 746


using actions 729


using droplets 742


automating contact sheets 693


Average Blur filter 516


B 

background color


choosing 503, 507


editing with Color palette 506


filling selections with 498


Background Eraser tool 491


backgrounders 8


backgrounds


converting from layer 397


converting to layer 396


erasing 492


from filter effects 514


layer styles and 415


badges 575


barrel distortion 351


Bas Relief filter 522


base color (in blending modes) 486


base layer 436


base output size 713


baseline shift 551


Batch command 740


batch processing 740, 741, 742


Batch Rename command 95


Behind mode 487


Bevel And Emboss effect 416


Bilateral Blur filter 517


binary encoding, in EPS and DCS


files 669


bit depth 231, 232


bitmap images 177


Bitmap mode


about 228, 235


converting to Grayscale 236


Custom Pattern option 237


Paint Bucket tool 497


specifying halftone screen 236


using type 532


Black Body option 240


black point 190


black point compensation 271


black, appearance of 255


black-and-white images, creating 313


Blend Clipped Layers As Group


option 413


blend color 486


Blend Interior Effects as Group


option 413


blending modes


about 486


choosing 410


for channel calculations 446, 447


for layer groups 410


blending options, advanced 412


blends


grouping effects 412


restricting to channels 412


specifying range for 413


Blur and Blur More filters 516


Blur tool 372


BMP file format


about 679


saving in 670


Border command 325


bounding boxes


of circular image maps 592


of type 535
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Box Blur filter 516


Bridge Center 79


Bridge window


adjusting 82


main components 79


Bridge. See Adobe Bridge


brightness


adjusting 290


equalizing 311


Brightness/Contrast command 307


Bring Forward command 401


Bring To Front command 401


Browse command 81


browser dithering 636


browser messages 589


browsers, previewing in 596


brush cursor 472


Brush Stroke filters 518


brush tips


creating 475


shape options for 476


Brush tool 471


brushes


airbrush option for 484


clearing options 485


clearing options for 485


color dynamics of 483


dual 482


dynamic 478


preset 473


pressure sensitivity of 485


scattering 480


shape dynamics of 479


textured 481, 484


wet edge or watercolor 484


Brushes palette


about 474


keyboard shortcuts for 771


Build Cache For Subfolders


command 85


Build Master Palette command 643


bump maps 530


burasagari 570


Burn tool 373


Button Mode command 729


C 

cache


about 85


setting centralized and


distributed 84


Calculations command 447


camera data, adding to files 98


Camera Raw


See also camera raw files


about 207


database 223


preview controls 213


profile adjustments 220


workflow options 214


XMP files 223


camera raw files


about 207


automated batch processing 226


bit depth of 214


cache in Bridge 209


chromatic aberration in 219


color cast in shadows 220


copying and pasting settings in


Bridge 224


correcting a color cast in 220


cropping and straightening


images 217


Digital Negative saving


options 222


export settings 225


from non-square-pixel


cameras 214


from square-pixel cameras 214


histogram and RGB values 213


in Bridge 79


opening directly in Photoshop 210


pixel size in 214


printing resolution for 214


processing 210


reducing noise in 218


resampling 214


saving to other file formats 221


setting color profile and bit


depth 214


sharpening 218


sidecar XMP files 223


tonal adjustment controls for 216


vignetting in 220


white balance in 214


canceling operations 71


canvas


filling 498


resizing 346


Canvas Size command 346


capitalizing text 554


Cascading Style Sheet 648


CCITT compression 678


certification 9


Chalk & Charcoal filter 522


Change Layer Content command 426


Channel Mixer command


Constant option 305, 306


creating monochrome images 305


mixing channels 305


Output Channel option 305


channels


See also alpha channels, Channels


palette, color channels, spot


channels


bit depth 231


blending 446


calculating 446


color 438


color information and


deleting 442


duplicating 440


file size of 438


hiding and showing 439


inverting 306


layer mask 434


maximum number of 343


merging 441


mixing 304


optimizing images with 644


options for 344


Quick Mask 339


saving selections in 344


selecting 439


sequence of 343


source 305


splitting into separate images 441


thumbnails 438, 439


viewing 439
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viewing in Histogram palette 277


Channels palette


about 438


changing display of 439


rearranging channels in 440


selecting channels in 440


Character palette


about 545


type size 547


characters


special 546


characters. See type


Charcoal filter 522


Check Spelling command 538


chromatic aberration 219


Chrome filter 523


Cineon format


about 680


saving in 671


Circle Image Map tool 591


circles


drawing 500


CJK type. See Asian type


Clear command 334


Clear Layer Style command 423


Clear mode 487


Clear Slices command 583


client-side image maps 596


clipboard


clearing 78


copying between applications 333


Export Clipboard option 333


rasterizing images from 333


saving after quitting


Photoshop 333


clipping


about 284


in Auto Levels command 307


clipping groups 408


clipping masks


about 436


creating 437


duplicating 437


releasing 437


removing layers from 437


clipping paths


about 701


printing 702


Close command 49, 50


Close Window command 81


Clouds filter 521


CMYK color mode


out-of-gamut colors 283


selecting colors in 243


tonal and color adjustments in 282


CMYK color spaces


about 228


previewing 283


CMYK images


channel display 439


out-of-gamut colors 283


CMYK inks. See process color inks


collaborating, in Version Cue 122


collections


in Bridge 91, 92


color adjustments


See also tonal and color


adjustments


image map 592


slices 575


color balance


adjusting automatically 307


adjusting with Curves 288


generalized adjustments 311


Replace Color command 304


scanning and 190


Color Balance command 298


Color Burn mode 487


color casts


See also color balance


correcting with eyedroppers 291


correcting with Levels 286


Color Channels In Color option 440


color channels. See channels


color corrections. See tonal and color


adjustments


color depth. See bit depth


Color Dodge mode 487


color fill layers 425


Color Halftone filter 521


color management


See also color profiles, color


settings


about 250, 251, 252


appearance of CMYK black 255


basic steps for setting up 253


color settings reference 268


considerations for importing


images 256, 257


considerations for printing


documents 261


considerations for process and


spot colors 255


creating a viewing


environment 251


for online graphics 258


for PDF files 258, 262


in JPEG 2000 files 667


managing printing in


Photoshop 715


printing a hard proof 716


printing color targets 717


printing options 714


saving documents 655


soft-proofing colors 259, 261


synchronizing color settings 254


Color mode option 488


color modes


Bitmap 228


conditional mode change 234


converting Bitmap to


Grayscale 236


converting images between 229,


234


converting to Bitmap 235


converting to Indexed Color 238


Duotone 229


Grayscale 228


Grayscale mode 228


Indexed Color 238


Lab Color 228


Multichannel 229


number of channels


RGB 227


setting in new images 191


viewing in Histogram palette 277


Color palette


See also color palettes


about 505


alerts 246


selecting web-safe colors with 245
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Web Color Sliders command


in 246


color palettes


See also Color palette


Adaptive 239


Black Body option 240


customizing 240


Exact 238


for indexed-color conversions 238


Grayscale option 240


Mac OS 238, 241


matte color 239


number of colors 239


Perceptual 238


Selective 239


specifying background color 239


specifying colors 239


specifying transparency 239


Spectrum option 240


Uniform 238


web 238


Windows 238, 241


color pickers


Adobe Color Picker 241


Apple Color Picker 248


Windows Color Picker 247


color profiles


about 263


assigning and removing from


documents 266, 267


converting to another profile 268


creating monitor profiles 264, 265


embedding in documents 266


for desktop printers 262


for imported images 256, 257


installing 266


warning messages for 269


Color Range command


about 320


Fuzziness option of 321


saving settings with 322


selection preview 322


using preset colors with 322


color range, specifying for


composition 413


color reduction, modifying with


masks 646


color samplers


about 280


changing display of 281


moving 281


showing and hiding 281


color separations


about 710


adjusting traps 724


printing 723


color settings


See also color management


color conversions 271


color management policies 269,


270


customizing 268


for GoLive 254


for Illustrator, InDesign, and


Photoshop 254


presets for 268


rendering intents 271


synchronizing with other


applications 254


working spaces 268, 269


Color Table command 240


Color Table palette 638


color tables


adding colors to 639


Black Body option 240


customizing 240


deleting colors from 642


dithering 239


editing colors in 240, 640


for assigning transparency to


colors 240


for indexed-color conversions 238


Grayscale option 240


loading 642, 643


locking colors in 641


master palette for 643


matte color 239


saving 642


saving and loading 241


selecting a color from 639


shifting to web-safe colors 641


sorting by hue, luminance, or


popularity 639


specifying background color


with 239


specifying colors with 239


specifying transparency with 239


Spectrum option 240


swatch size 639


unified, in Optimize palette 638


using weighted optimization to


generate 646


color transitions, quality of 179


color traps 724


color values


previewing 279


specifying numerically 243


color wheel


about 248


complementary colors in 248


color, converting to grayscale 235


Colored Pencil filter 515


colors


See also background color, color


management


See also color management, color


models


deleting 642


for type 548


inverting in images 312


layers or groups 406


locking in Color Table palette 641


mapping to transparency 641


matching 301


reducing with weighted


optimization 646


shifting to another RGB value 640


shifting to prevent dithering 641


shifting to Web palette 641


columns


for precise positioning 59


Combine Slices command 581


Commands palette 71


commands, recording in actions 731


comments


entering for Version Cue


projects 162


commercial printing 718


compact mode 81


Compact view


 



786 INDEX 

of tutorials 7


Compact view of Histogram


palette 276


complementary colors. See color


wheel


composite channel 439


composition, of type 563


compression


about 678


PDF 661


Conditional Mode Change


command 234


conditionals 735


Conflicted Copies file status, in


Version Cue 128


Connect To command 120


Constant option 305


Contact Sheet II command 693


Conté Crayon filter 513, 523


content area 79


context menus


using 39


Contiguous option 371, 491


continuous-tone images


about 177


printing 710


contour libraries 420


contours 419


contrast


adjusting 290


adjusting automatically 308


Convert Direction Point tool 466


Convert To Paragraph Text


command 537


Convert To Point Text command 537


Convert To Profile command 268


Convert To Shapes command 544


convolution 525


cooling filters 299


Copy command 88


Copy Frames command 617


Copy Layer Style command 422


Copy Slice command 581


Copy State command 612


copying


See also Duplicate commands


animation frames 617


between applications 332


PostScript artwork from


clipboard 333


rollover states 612


selections 330


slices 581


styles 422


using drag and drop 332


while dragging 331


copyright information


adding 689


viewing 32


copyright information, adding 98


correcting mistakes


reverting to saved image 71


undoing last action 71


Craquelure filter 525


Create Droplet command


in Actions palette 744


in Automate submenu 743


in Optimize palette 746


Create Layers command 423


Create Slice From Guides


command 573


Create Slice From Selection


command 574


Create Work Path command (for


type) 543


Creative Suite color settings 254


Crop command 349


Crop tool 55, 348, 350


Crosshatch filter 518


Crystallize filter 521


curly quotes 538


Current Path command 435


curves


creating smooth and sharp 460


drawing 455


reshaping 463


Curves command


about 286


adding points with 289


adjusting color and tone with 288


adjusting color balance and tonal


range with 288


Auto options for 309


setting highlight and shadow


values with 293


setting target values with 294


shortcuts for 290


using eyedropper tools to adjust


tonality 291


custom color filter, in Photo Filter


command 299


Custom filter 525


custom ink colors, choosing in Adobe


Color Picker 246


Custom Spot Function option 722


Cut command 88, 334


Cutout filter 515


D 

Dark Strokes filter 518


Darken mode 487


data sets


applying 751


defining 750


importing from external files 752


using batches of 752


data-driven graphics


about 747, 750


applying data sets 751


generating graphics 751


variables 748


DCS file format


about 441, 680


binary encoding 669


DCS 1.0 670


DCS 2.0 670


for images with spot channels 723


JPEG encoding 669


saving files in 669


Decrease Font Size command 97


Decrease Rating command 91


Define Brush command 475


Define Pattern command 501


De-Interlace filter 525


Delete All command 583


Delete Anchor Point tool 466


Delete Color command 642


Delete command, in Version Cue 140


Delete Frame command 617


Delete Permanent command 142
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Delete Slice command 587


Delete Slice Selection command 578


Delete Slices command 583


Delete Workspace command 83


Deleted file status, in Version


Cue 129


deleting


alpha channels 442


channels 442


colors from swatch sets 508


colors in color table 642


files from Version Cue


projects 141, 142


files permanently from Version


Cue projects 142


locked selections 335


objects 334


projects in Version Cue 140


rollover states 612


selections 334


slice selections 578


slice sets 578


slices 583


versions with Version Cue


Administration utility 165


Desaturate command 312


Deselect All Colors command 640


Deselect All command 87


Deselect command 315


deselecting selections 315


See also selecting 

desktop printers 

color profiles for 262


Despeckle filter 520


detection width, Magnetic Lasso


tool 319


developer resources


scripting guides 9


SDK documentation 9


Diameter option 476, 482


Diamond Gradient tool 493


DIC Color Guide 247


Difference Clouds filter 521


Difference mode 488


Diffuse filter 523


Diffuse Glow filter 518


diffusion dither 637


Digimarc Detect Watermark plug


in 32


Digimarc filters


about 689


before adding 690, 691


reading a watermark 687


signal strength meter for 692


Watermark Durability setting


of 691


Digital Negative file format


about 679


saving options in Camera Raw 222


Directional lighting effect 528


Disconnect command 139


Displace filter 518


displacement maps 518


Display & Cursors preference 440


Dissolve mode 487


Distort filters 518


distortions


applied with Liquify filter 385


reconstructing 387


Distribute Layers command 403


Distribute Slices command 583


distributing


image maps 595


layers 403


shapes 465


dithering


about 239


browser 636


in animations 622


in linked slices 584


modifying with masks 646


No Dither setting 634


shifting to web-safe colors 641


transparency, in Optimize


palette 637


weighted optimization and 646


Divide Slices command 580


DNG (Digital Negative) 222, 679


document dimension, viewing 32


document profiles. See color profiles


document size


about 185


viewing 32


document window


viewing file information in 32


documents


keyboard shortcuts for 764


documents folder, in Version


Cue 119


Dodge tool 373


double-byte type. See Asian type


downloading


updates, plug-ins, and tryouts 9


downsampling


about 182


in PDF files 661


dpi (dots per inch) 181


drawing


circle or square 500


custom shape 450


doughnut or wheel shape 451


multiple shapes on a layer 451


shapes 450


drawing modes 449


Drop Shadow effect 416


droplets


about 742


applying to slices 584


batch options 745


compatibility issues 744


creating for various operating


systems 744


creating in ImageReady 744


creating in Photoshop 743


editing 745


in actions 736


processing files with 745


Dry Brush filter 515


dual brushes 482


Duotone mode 229


duotones


about 725


creating 725


curves 726


exporting to other applications 728


overprint colors 727


printing 727


saving and loading settings 727


viewing individual plates 727


Duplicate Channel command 440
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Duplicate command 49, 88


Duplicate Merged Layers Only


option 49


Duplicate Path command 465


Duplicate Slice command 581


duplicating


Version Cue projects 163


Dust & Scratches filter 520


Dynamic Color Sliders option 506


dynamic range 190


Dynamic Shortcuts 555


E 

edge effects 514


edge sensitivity, Lasso tool 319


edges


smoothing 468


Edit Properties command 124


effects


grouping blend 412


modifying with contours 419


removing 423


scaling 422


scaling effects in 422


eight-bits-per-channel images,


converting 233


Eject command 88


Elliptical Marquee tool 316


e-mail


saving to 629


Embed Color Profile option 655


Embed Watermark command 691


embedding


fonts in SWF files 672


Emboss filter 523


empty


cells 648


Enable Dynamic Text option 672


Encapsulated PostScript (EPS). See


EPS files


EPS files


about 680


binary encoding 669


JPEG encoding 669


opening 194


saving 669


saving for page layout 700


saving in DCS format 670


Equalize command 311


Erase To History mode (Eraser


tool) 491


Eraser tool 71, 490


erasing


about 490


backgrounds 492


fastening points in a selection 317


lasso segments 318


to history to restore previous


state 71


Events Manager 747


Every-line Composer 563


Exact color palette 238


Exclusion mode 488


EXIF 96


Expanded view of Histogram


palette 276


Export Cache command 85


Export Layers As Files command in


ImageReady 675


Export Layers To Files command in


Photoshop 674


Export Original Document


command 653, 654, 674


exporting


animation frames as files 676


duotones 728


layers as files 408


paths 703


transparency 701


Version Cue projects 164


Extensible Metadata Platform


(XMP) 95


Extract command, previewing


with 337


Extract filter 336


extracting objects from


background 336


Extras


See also names of individual Extras 

showing and hiding 63


target path 462


Extrude filter 523


eyedropper sample 505


Eyedropper tool


about 281


in Hue/Saturation command 297


F 

Facet filter 521


fastening point 318


feathering 326


file browsing, with Bridge 79


file compression. See compression


file conflicts in Adobe Version


Cue 154


file conflicts, in Version Cue 154


file formats


See also compression, Save For


Web dialog box, individual


format names


about 678


animation and movie 680


for nonsupported previews 680


supporting paths 458


File Info command 98


file information 686


file locks, removing in Version


Cue 165


file name extensions, preferences for


saving 692


file names


compatibility across operating


systems 650


File Navigator command 82


file protection, in Version Cue 127


file size


about 180


required for alpha channels 438


scanning and 190


tracking 408


file status


in Version Cue 128


file versions. See versions


files


batch renaming 95


extensions for 655


finding 91


labeling 90


managing 88


navigating 87


opening in Bridge 87


options for saving 650
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placing, in Version Cue 134


rating 91


saving preferences 692


selecting in Bridge 87


Fill command 498, 499


fill layers


about 424


creating 424


editing 426


merging 426


fill opacity 410


Fill tool 337


Fill With Neutral Color option 411


filling


layers 497


paths 469


selections 497


type 548


with background color 498


with foreground color 498


with gradients 492, 493


with history state 71


fills


keyboard shortcuts for 767


Filmstrip Focus command 82


Filmstrip format 680


Filter Gallery 510


filters


applying 510, 512


applying cumulatively 510


applying from Filter Gallery 510


Artistic 515


Blur 515


Brush Stroke 518


Colored Pencil 515


creating backgrounds with 514


creating special effects with 514


Cutout 515


Digimarc 526, 689


Distort 513, 518


Dry Brush 515


Fine Grain 515


for 16-bit images 509


for 8-bit images 509


Fresco 515


improving performance with 530


Lens Blur 516


Lighting Effects 527


Neon Glow 515


Noise 520


Other 525


Paint Daubs 515


Pixelate 521


plug-ins for 509


previewing 510, 512


Render 521


Repeat Edge Pixels option 513


Sharpen 522


Sketch 522


Stylize 523


Video 525


Wrap Around option 513


Find All Remote Slices command 610


Find And Replace command 539


Find command 91


Find Edges filter 524


Find Remote Slices For State


command 610


finding files and folders, with


Bridge 91


Fine Grain filter 515


Finger Painting option 372


Fit On Screen command 53


Flash file format. See SWF format


Flatten Frames Into Layers


command 621


Flatten Image command 409


flattening


images 409


flipping


images 347


FOCOLTONE color system 247


folders


finding 91


managing 89


navigating 87


understanding in Version Cue 119


font size


changing in Metadata panel 97


fonts


about 546


embedding in SWF files 672


families 546


missing 556


previewing family and styles 547


selecting 546


foreground color


choosing 503, 507


editing with Color palette 506


filling selections with 498


selecting with Eyedropper tool 504


forums 9


fractional character widths 555


fractions, in type 546


Fragment filter 521


frame delay 620


frames


adding 616


selecting 616


tweened 618


framing images 347


Free Transform command


about 363


in Info palette 56


Freeform Pen tool 456


frequency. See screen frequency


Fresco filter 515


fringe pixels, removing 327


FTP server


exporting Version Cue projects


to 164


publishing Version Cue projects


to 161, 162


specifying an FTP proxy server in


Version Cue 159


function keys 776


G 

Gamma command 627


gamma, previewing for web


images 627


Gamut Warning command 283


gamut, of colors 250


gamuts 283


Gaussian Blur filter 516


General preferences


Bridge 84


GIF file format


about 680


Interlaced option for 665
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Normal option for 665


optimization options for 635


web optimization settings 632


weighted optimization and 645,


646


Glass filter 513, 518


global lighting 420


Global Positioning System (GPS)


data 96


Glowing Edges filter 524


glyphs


about 546


in OpenType fonts 556


GoLive, opening Photoshop files


in 571


Goodies folder 9


GPS information in files 96


Gradient Editor dialog box 493


Gradient Fill tool, measuring


distance of gradient fill 55


Gradient Map command 313


Gradient tool 55


gradient tools. See individual gradient


tool names


gradients


applying 492, 493


creating 494


creating presets 495


fill layers 425


keyboard shortcuts for 767


library 496


mapping tonal range to 313


transparency 493, 496


Grain filter 525


Graphic Pen filter 523


graphics. See vector graphics


grayscale images


about 228


colorizing 297


converting from Bitmap mode 236


converting to black-and-white


images 313


converting to indexed color 238


creating by mixing channels 304


creating from color images 235,


312


halftone screen attributes for 721


storing selections in 438


grids 60


groups


adding layers to 400


blending modes 410


grouping layers 400


viewing 398


Grow command 325


guides


Smart Guides 60


Smart Guides, hiding 61


snapping 60


H 

halftone cell 181


Halftone Pattern filter 523


halftone screens


about 181


for Bitmap-mode conversions 237


halftones


about 721


Custom Spot Function option 722


saving settings of 722


selecting attributes for 721


Hand tool 51


handtinted images 305


hanging punctuation 561


Hard light mode 488


hard proof 716


Hardness option 477


HDR images


about 201


converting to 8 or 16 bits per


channel 205


Merge To HDR command 202,


203


viewing 204


working with 202


Help system


PDF version of 8


tutorials in 7


hexadecimal color values 243


Hide All Layer Styles command 416


Hide Auto Slice command 576


Hide Slice Number command 576


hiding and showing


alert messages 69


channels 439


grid and guides 61


layer styles 417


text selections 545


tool tips 46


using layer masks 433


High Dynamic Range images. See


HDR images


High Pass filter 525


high-key images 275


highlights


adjusting 373


adjusting with Levels 285


Histogram palette


about 276


adjusting histogram view 276


All Channels View 276


Compact View 276


displaying channels in color 278


Expanded View 276


previewing adjustments in 279


refreshing 279


showing 276


statistics 278


viewing a specific channel in 277


histograms


about 275


cache level 278


clipped values 292


reading 275


History Brush tool 71, 75


history information, adding to


files 98


history log 693


History palette


about 72


and batch processing 740


history states


deleting 73


options 74


painting with snapshot 75


replacing 490


reverting to previous 73


HKS color 247


horizontal scale of type, adjusting 551


HSB mode
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in Adobe Color Picker 242, 244


selecting colors in 243


HTML


ALT element 589, 593


cell alignment for text 590


MESSAGE element 589, 593


output settings 647, 648


target frame 589, 593


URLs in image maps 593


URLs in slices 589


HTTP Proxy server, specifying in


Version Cue 159


Hue mode 488


Hue/Saturation command


about 295


adjusting 296


colorizing grayscale images


with 297


modifying color range with


eyedroppers 297


specifying range of colors with 296


Hyphenation command 562


ICC Profile option 655


ICC profiles


See also color profiles


embedding in files 633


scanning and 190


IDs, in Version Cue 168


Illustrator. See Adobe Illustrator


Image Dimensions option 182


image map placement 649


Image Map tool 591


image map types 649


Image Map Visibility button 592


image maps


about 590


adding links to 593


aligning 595


arranging 595


bounding box areas 592


client-side 596


converting layer-based to tool


based 592


creating 591


duplicating 594


layer-based 591


modifying in image 595


server-side 596


tool-based 591


type 596


viewing 592


image noise 353


Image Previews option 655


Image Processor 739


Image Size command


changing pixel dimensions 184


recording in actions 736


using Auto option 186


images


See also bitmap images, optimizing


images, vector graphics


about 177


bit depth 231


color adjustments 274, 281


converting between bit depths 232


converting between color


modes 234


copying selections between 331


creating from history state 74


creating from snapshot 74


creating monochrome 305


creating new 191


displaying size of 182


flattening 409


for video 704


grayscale 228


handtinted 305


high-key 275


indexed-color conversion


options 238


loading selections into 335


low-key 275


maximum size of 180


noise in 218


pixel dimensions of 184


posterizing 313


preserving highlight and shadow


detail in 293


previewing for use in video 708


previewing in browser 596


print dimensions of 185


printing 710


pseudocolor 240


resampling 182


restoring 71


reverting to any state 72, 75


RGB 227


rotating or flipping 347


saving 653


scanning 188, 189


selective sharpening 357


sharpening 354, 355, 356


trimming 350


Import command 188, 196


Import Folder As Frames


command 623


Import Version Cue 1.0 Data


command 159


importing


See also scanning


anti-aliased PICT files 196


artwork by dragging 333


files as animation frames 623


Illustrator art 196


images with WIA support 189


PDF files 197


PICT resources 196


importing images with WIA 187


In Use By file status, in Version


Cue 128


In Use By alerts in Version Cue 130


In Use By Me file status, in Version


Cue 128


Increase Font Size command 97


Increase Rating command 91


indenting paragraphs 560


Indexed Color mode


about 238


conversion options 238


converting RGB and Grayscale


images to 238


using type with 532


Info palette


about 55


before-and-after color values in 55


color corrections display 55


options for 57


out-of-gamut colors 55


previewing color changes in 279
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showing 280


using 56


information box 182


Ink Outlines filter 518


inkjet printers 181


Inner Glow effect 416


Inner Shadow effect 416


input device profiles 263, 266


Insert Conditional command 735


Insert Menu Item command 733, 734


Insert Path command 732


Insert Set Optimization Settings


command 736


Insert Set Output Folder


command 736


Insert Stop command 733


installation, software 1


integration between Adobe


applications 700


International Color Consortium


(ICC) 252


International Press


Telecommunications


Council 223


interpolation methods 183, 360


Intersect With Channel option 344


Inverse command 324


Invert command 312


Invert Selection command 87


IPTC 223


IPTC (IIM, legacy) 96


IPTC Core 96


IPTC information 96


IPTC metadata, editing 97


J 

JavaScript 747


jitter


about 478


angle 479


color 483


count 481


flow 484


opacity 484


roundness 479


size 479


texture depth 482


JP2 format. See JPEG 2000 format


JPEG 2000 format


about 666, 681


alpha channels 667


Compliance option 667


defining a region of interest in 667


Growing Thumbnail option 667


Metadata Format option 667


optional plug-in 666


Progressive option 667


saving in 666


Tile Size option 667


Wavelet Filter option 667


JPEG artifacts 354


JPEG compression. See JPEG format


JPEG encoding, in EPS and DCS


files 669


JPEG format


about 681


compression 678


optimization options 633


options for saving 665


saving files in 665


specifying image quality 665


web optimization settings 632


weighted optimization and 645


JPF format. See JPEG 2000 format


Jump To command 34


jumping between applications 34


justifying type 559


K 

keyboard shortcuts 754


keystone distortion, correcting 350


keywords, applying to files, in


Bridge 100


kinsoku shori 569


knockouts


and spot colors 445


creating 411


Kotoeri Character palette 566


kumimoji 564


L 

Lab Color mode


about 228


in Adobe Color Picker 242, 245


Lab images


blending modes for 410


channel display in 439


Label commands, in Bridge 90


language


assigning in Bridge 84


languages, assigning to text 540


Large Document Format (PSB)


about 681


saving in 656


Lasso tool


options 319


stylus pressure options for 319


using 317


Lasso Width option 319


layer comps


applying and viewing 431


creating 430


deleting 431


updating 431


validating 431


working with 430


Layer Comps palette 430


layer edges 402


layer mask channel 434


Layer Mask Hides Effects option 413


layer masks


adjustment layers as 424


applying 436


disabling and enabling 434


discarding 436


displaying 434


displaying channel 434


editing 433


loading as selections 436


removing 436


Layer Match command 613


layer sets in ImageReady 401


layer styles


contours 419


custom 416


editing 423


expanding and collapsing 417


hiding and showing 416, 417


options for 417
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presets, creating 421


presets, deleting 421


presets, loading 422


presets, renaming 421


presets, saving 421


removing 423


rollover styles 612


scaling effects in 422


type layers 536


Layer Via Cut command 397


layer-based slices


about 574


creating 574


resizing 580


layers


See also type layers


adjustment layers, about 423


aligning 403


applying masks with 436


applying preset styles to 415


background 396


blending range and 413


changing stacking order of 401


clipping masks and 436


color-coding 407


converting styles to 423


copying and pasting styles in 422


creating custom styles with 416


creating new 397


creating slices from 574


creating vector masks with 433


deleting 407


discarding masks from 436


distributing 403


distributing in an image 330


duplicating 404


editing styles in 417


editing vector masks in 433


exporting 408


exporting to files 674


filling 497


filling with neutral color 411


flattening 409


flattening from animation


frames 621


grouping 400


hiding and showing 398


in animations 623


in channel calculations 446, 447


knockout 411


linking 401


loading boundaries as


selection 436


locking 405


masks 432


matching across rollover states 613


merging 408


modifying effects in 419


moving 328, 401, 402


new document from 405


opacity 409


painting transparency 487


rasterizing 407


removing effects 423


renaming 406


rotating 360, 404


sampling 398


saving 655


scaling 360


scaling effects in 422


selecting 399


selecting directly in document 400


showing edges 402


stroking 497


thumbnails 396


unifying 399


unlinking masks in 435


using masks to select opaque areas


of 436


viewing 398


viewing groups 398


Layers As Files command 672


Layers palette


about 395


keyboard shortcuts for 773


legacy Photoshop serial number 70


Lemple-Zif-Welch (LZW)


compression 678


Lens Blur filter 516


Lens Correction filter 351


Lens Flare filter 522


letter spacing 560


letters 532


letters. See type 

Levels command


about 284


adjusting gamma with 284


adjusting tonal range with 284, 285


adjusting tonality with


eyedroppers in 291


assigning highlight values with 293


assigning shadow values with 293


Auto options for 309


correcting color casts with 286


Input Levels sliders 284


Output Levels sliders 293


Set Gray Point eyedropper in 286


setting target values with 294


Threshold mode in 291


ligatures 546


Lightbox command 82


Lighten mode 487


lighting effects 420


Lighting Effects filter


about 522, 527


adding 529


creating styles with 529


textures in 530


Lighting Effects filter styles


Crossing 529


Crossing Down 529


Default 529


Five Lights Down 529


Five Lights Up 529


Flashlight 529


Flood Light 529


Parallel Directional 529


Lighting Effects types


Directional 528


Omni 528


Spotlight 528


Line tool, measuring distances


with 55


Linear Burn mode 487


Linear Dodge mode 487


Linear Gradient tool 493


Linear Light mode 488


lines


drawing 472
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Link Slices For Optimization


command 584


linked files


color management


considerations 256, 257


in Version Cue 134


Links palette


replacing placed files with


alternates 136


replacing placed files with previous


versions 136


using with Version Cue project


files 135


viewing alternates and versions


in 135


Liquify filter


applying meshes with 389


distorting images with 385


freezing and thawing areas


with 386


inverting frozen areas with 387


moving pixels right with 385


reconstructing 387


saving meshes with 389


setting tool options for 385


showing backdrops with 390


using mask options of 387


zooming in dialog box 385


Liquify filter tools


Bloat 385


Mirror 385


Pucker 385


Push Left 385


Reconstruct 387


Turbulence 385


Twirl Clockwise 385


Twirl Counterclockwise 385


Warp 385


Load Actions command 738


Load Slice Selection command 578


loading


actions 738


color tables 241, 642


contours 420


duotone curves 726


output settings 647


pattern libraries 499


tonal and color adjustment


settings 282


lock protection, in Version Cue 162,


165


Lock Slice command 583


Lock/Unlock Selected Colors


command 642


locking


colors 641


slices 583


locking layers


fully 405


multiple layers 406


partially 406


logins


creating in Version Cue


Administration utility 168


entering in Version Cue


Administration utility 156


privilege levels, in Version Cue 169


logs, in Version Cue 158, 171


looping, in animations 619


lossless compression


CCITT 678


LZW 678


RLE 678


ZIP 678


lossy compression


JPEG format and 678


modifying with masks in GIF


format 645


weighted optimization and 645


low-key images 275


lpi (lines per inch) 181


Luminosity mode 488


luminosity, viewing in Histogram


palette 277


M 

Mac OS


System color palette 238, 241


Macromedia Flash file format. See


SWF format


Magic Eraser tool 491


Magic Wand tool 320


Magnetic Pen tool 457


magnifying images 52, 53


Make Alternates command, in


Version Cue 151


Make Frames From Layers


command 623


Make Primary Alternate command,


in Version Cue 150


Make Selection command 468


Make Work Path command 468


mapping colors to transparency 641


Mark In Use command 153


marquee tools


about 316


coordinates in Info palette 55


Fixed Size option 316


mask editing colors 344


Masked Areas option 341


masking


layers 432


masks


about 338


adding to layers 433


and weighted optimization 644


applying 436


changing opacity of 342


channels saved as 344


choosing color of 342, 344


clipping 436


creating from a selection 343


creating in alpha channels 342


creating temporary 339


discarding 436


for type 544


for weighted optimization 644


modifying color reduction


with 646


modifying dithering with 646


modifying GIF lossiness with 645


modifying JPEG quality with 645


removing quick masks 341


saving as alpha channels 338


saving selections in 338


selecting opaque areas with 436


unlinking from layers 435


vector 433


master files, in Version Cue 126


master palette 643


Match Color comman
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about 301


Match Color command


adjusting color with 303


matching color between layers 302


matching colors 301


matte color


choosing 239


Matting commands


Defringe command 327


Remove Black Matte


command 327


Remove White Matte


command 327


Maximum filter 358


Measure tool 59


measuring


about 59


angle of rotation 55


changing units used for 59


using cropping marquee 55


using Line tool 55


Median filter 358, 520


median pixel values 278


Memory Usage preference 117


memory, freeing 78


menus


customizing 65


deleting a set of 66


turning colors on or off 66


viewing hidden items in 66


Merge Channels command 441


Merge Spot Channel option 445


Merge To HDR command 202, 203


Merge Visible Layers command 409


merging


adjustment or fill layers 426


all visible layers 409


channels 441


layers 408


stamped layers 409


MESSAGE HTML element 589, 593


metadata


about 95, 686


adding to documents 98


adding to web images 634


appending 100


applying as templates 100


editing 97


preferences for 98


replacing 100


searching for, in Version Cue 137


specifying types to display in


Metadata panel 98, 99


templates 99


viewing 97


Metadata Focus command 82


Metadata panel 96


metadata, specifying types to display


in Metadata panel 99


Mezzotint filter 521


midtones, adjusting with Levels 285


migrating to Adobe Version Cue


2.0 159


Minimum and Maximum filter 526


modal controls 733


modes. See blending modes, color


modes


Modify Lossiness Setting dialog


box 645


Modify Quality Setting dialog


box 646


moiré patterns in printing 721


Mojikumi


about 568


mojisoroe 565


monitor profiles 263, 264, 265


monitors


adjusting display 230


cross-platform differences


between 230


Photoshop and ImageReady


differences 230


monochrome, converting to 313


monotones. See duotones


Mosaic filter 521


Mosaic Tiles filter 525


Motion Blur filter 516


Move To Recycle Bin command 89


Move To Trash command 88, 89


Move tool 329


movies 671


QuickTime 683


moving


keyboard shortcuts for 765


layers 402


paths 464


selections 328


shapes 464


slices 579


MTX files 677


Multichannel mode


about 229


and deleted channels 442


using type 532


multiple copies. See duplicating


Multiply mode 487


N 

Navigator palette 52


negatives, creating 312


Neon Glow filter 515


New Color command 639


New command 191


New Folder command 89


New Layer Based Image Map Area


command 591


New Layer Based Slice command 574


New Project command 123


New Snapshot button 75


New View command 54


New Window command 81


No Label command 90


No Rating command 91


No Working Copy file status, in


Version Cue 128


noise


in brushes 484


in camera raw images 218


noise dither 637


noise gradients 495


Noise filters 520


None privilege, in Version Cue 169


nonprintable colors 246


nonsquare pixels 704


Normal mode 487


Normal state, for rollovers 604


Note Paper filter 523


notes. See annotations


NTSC Colors filter 525
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O 

Ocean Ripple filter 518


Offline Copy file status, in Version


Cue 128


Offset filter 526


OLE (Object Linking and


Embedding) 703


Omni lighting effect 528


one-bit images. See bitmap images


online images


See also optimizing web graphics


changing size of 184


creating master palette for 643


online training 9


Only Copy file status, in Version


Cue 128


opacity


fill 410


gradients 495


layer mask 434


of background layer 410


Quick Mask 342, 344


shown in Info palette 56


Open As command 193


Open command 193, 195, 624


images in Photoshop 192


in Bridge 87


Open file status, in Version Cue 128


Open Recent command 192


Open With Camera Raw


command 87


Open With command 87


OpenEXR format 682


opening


EPS files 194


files as animations 623


PDF files 193


Photo CD files 195


QuickTime movies as


animations 624


Opening and closing files, in


Bridge 81


OpenType fonts


about 556


installing locally 532


Optimize By Bounding Box


option 622


Optimize By Redundant Pixel


Removal option 622


Optimize palette


about 631


adding metadata in 634, 638


and XMP metadata 651


saving settings with droplets 746


specifying transparency dithering


in 637


specifying unified color table


in 638


optimizing


See also optimizing web graphics


about 625


animations 622


GIF and PNG-8 files 632


JPEG files 632


SWF (Flash) files 633


optimizing web graphics


automating 736, 742


basic procedure for 628


canceling 631


compressing to specific file


size 630


in ImageReady 631


preferences 632


restoring to original version 629


saving presets 629


slices 583


using Color Table panel for


slices 638


viewing optimized images in


ImageReady 631


weighted optimization 644


options bar


about 31


changing font size in 64


moving 48


ordinals 546


Original view, creating animations


in 616


Other filters 525


Outdated Copy file status, in Version


Cue 129


Outer Glow effect 416


outlining images 347


out-of-gamut alert in Color


Picker 243


out-of-gamut colors


about 283


shown in Info palette 55


output device profiles 262, 263, 266


Output Settings dialog box


displaying 647


formatting HTML files from 647


handling background image


from 647


HTML output options in 647


naming files and slices from 647


saved option sets in 647


switching to new option set in 647


Overlay mode 487


overprint colors 727


P 

page marks 719


page setup 710, 712


Paint Bucket tool 497


Paint Daubs filter 515


painting


options 486


tools for 471


with patterns 367


Palette Knife filter 515


palette menus, displaying 35


palette positions, restoring default 64


palette well 32, 36


palettes


See also pop-up palettes and


individual palette names


changing font size in 64


changing size of 35


docking and undocking 36


keyboard shortcuts for 770


moving 36


resetting to default positions 64


showing and hiding 35


Paragraph palette


about 558


paragraph type. See type


paragraphs


about 558


formatting 558


hanging punctuation 561
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indenting 560


word breaks 562


Pass Through blending mode 410


Paste command


in Bridge 88


Paste Into command 330


Paste Rollover State command 612


Paste Slice command 581


pasting


frames 617


PostScript artwork 333


rollover states 612


selections 331


slices 581


Patch tool 369


Patchwork filter 525


path components 460


copying 465


deleting 465


moving 464


overlapping 464


reshaping 464


paths


See also work paths


about 460


adjusting 462, 464


adjusting segments 462


clipping 701


closed 460


copying 465


created from type 543


creating new 459


defining transparency 701


deleting 460


distributing 465


drawing freehand 456


exporting to Illustrator 703


filling 469


from selection borders 468


managing 458


open 460


overlapping 462


printing 702


recording in actions 732


renaming 459


reordering in palette 458


repositioning 464


saving 459


selecting 458, 461


stroking 470


text on 541


Paths palette 458


Paths To Illustrator command 703


Pattern buffer 78


pattern dither 637


Pattern Maker 502


Pattern Stamp tool 367


patterns


about 500


defining image as 501


dithering 237


fill layers 425


filling selections with 498


generating with Pattern Maker 502


load library of 501


painting with 367


PostScript Pattern folder 501


saving library of 501


PCD format 195


PCX file format 682


PDF files


Adobe PDF preset 663


color management


considerations 258, 262


compliance with PDF/X


standard 659


compression 661


downsampling 661


opening 193


Photoshop PDF 682


presets 658


saving 656


security 663


PDF presentations


about 698


creating 698


PDF version capabilities 659


PDF, choosing which version to save


in 659


PDF/X-compliant files


color management


considerations 262


options 662


standards 659


Pen tool


about 454


drawing curves 455


drawing straight lines 454


pen tools 55


Pencil tool


about 471


auto erasing with 492


Perceptual color palette


about 238


number of colors 239


Persistent command 100


perspective


applying 363


changing by cropping 350


correcting 352


transforming 350


Photo CD files 195


Photo Filter command


about 298


cooling filters 299


custom color filters 299


warming filters 299


photo galleries


creating 597


styles 600


using tokens in 600, 602


Photocopy filter 523


Photomerge


adjusting perspective in 393


navigating in dialog box 391


selecting files to use in 392


setting vanishing point in 393


source photographs for 390


using from Bridge 392


using lightbox with 392


zooming in dialog box 391


Photoshop 2.0 format, opening files


in 679


Photoshop EPS format. See EPS files


Photoshop format 678


Photoshop legacy serial number 70


Photoshop PDF format 682


Photoshop Raw format


about 683
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saving in 670


PICT file format 196


about 682


PICT Resource 196


PICT Resource files 683


Picture Package command


about 695


customizing layouts 697


Pinch filter 518


pincushion distortion 351


Pixar format 683


Pixel Aspect Ratio Correction


command 706


pixel aspect ratios


assigning 707


customizing 707


deleting values 707


restoring default values 707


pixel depth. See bit depth 

pixel dimensions


changing 184


maximum 180


new channels 343


resampling and 182


viewing 182


pixel doubling 230


pixel values


mean 278


median 278


previewing 279


standard deviation 278


Pixelate filters 521


pixels


about 177


displaying color values of 55


histogram display of 278


selecting 315


Place command


about 196


in Bridge 88


in Version Cue 134


Plaster filter 523


Plastic Wrap filter 515


Playback Options command 730


plug-in modules


installing filters with 509


selecting folder for 70


plug-ins 9


for importing scanned images 188


for unsupported file format 678


in Adobe Store 9


Plug-Ins & Scratch Disks


preferences 70


PNG file format


about 683


Interlaced option 668


options for 668


saving files in 668


PNG-24 file format


optimization options 634


PNG-8 file format


optimization options 635, 646


web optimization settings 632


point size 547


point type 532


Pointillize filter 521


points, fastening 318


Polar Coordinates filter 518


Polygon Image Map tool 591


Polygonal Lasso tool 317


pop-up palettes


about 38


changing display of 39


customizing list of items in 39, 68,


474


Portable Bit Map format 683


Portable Document Format (PDF)


about 682


saving files in 656


positives, creating 312


Poster Edges filter 515


Posterize command


about 313


scanning and 190


posterizing images 313


PostScript


fonts 532


point size 59


PostScript Language Reference


Manual 722


ppi (pixels per inch) 178


See also resolution


preferences


anti-aliasing 195


color picker 248


gamut warning color 283


interpolation 184


optimization 632


palette location 64


plug-in module 70


Plug-Ins & Scratch Disks 77


recent file list 192


restoring to default settings 69


transparency display 398


Preferences command 

in Bridge 83


prepress options 719


Preserve Transparency option 491


preserving highlight and shadow


detail 293


preset brushes 473, 485


preset file sizes for video 704


preset styles 414


presets


brush 473


contour 419


gradient 495


PDF 658


style 414


Preview Document button in


toolbox 751


Preview Document command 611,


751


previewing


channel calculations 447


color and pixel values 279


extracted objects 337


font family and styles 547


in a browser 596


layers 398


printed image 186


rollovers 611


web pages 571


previewing colors. See soft-proofing


colors


previews, speeding up 230


Print command 710, 711


print dimensions, changing 185, 713


Print One Copy command 711


Print Options command 710
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printer driver color management 714


printer profile targets 717


printer’s marks 719


printer’s points 59


printing


about 710


about dpi 181


color management


considerations 261


color separations 723


color trapping before 724


commercial, preparing for 718


continuous-tone images 710


duotones 727


encoded image data 724


halftone attributes for 721


images 710


options for commercial


printing 719


options, setting 712


overprint colors 727


page setup for 712


part of an image 714


previewing before 186


scaling for 713


vector graphics 714


with color management 714


printing inks, density of 444


process color inks


about 442


simulating solidity 443


process colors


color management


considerations 255


Progressive option, for JPEG 2000


format 667


projects, sharing using Version Cue


Administration utility 162


Promote Layer Based Image Map


Area command 592


Promote To Current Version


command 147


Promote To User-Slice


command 575


Proof Color command 283


Proof Setup command 259, 283


Protect Foreground Color option 492


proxy view area 52


PSD format 678


publishing


Version Cue projects with


GoLive 160


Pucker tool 385


punctuation


hanging 561


punctuation, hanging 561


Purge Cache For This Folder


command 85


Purge Central Cache command 85


Purge command 78


Q 

quadtones. See duotones


Quick Mask mode


about 339


changing opacity with 342


options 341


turning off 341


QuickTime movies


about 683


opening as animations 624


saving as 671


quotation marks


about 538


R 

Radial Blur filter 517


Radial Gradient tool 493


Radiance format 684


Randomize option 496


raster images. See bitmap images


rasterizing


Illustrator artwork 333


layers 407


PDF files 196


PostScript artwork 194, 196


type layers 536


rating files, in Bridge 91


Rebuild Color Table command 638


Reconstruct tool 387


Reconstruct tool modes 389


reconstructing images 387


recording


actions 731


editing conditions during 735


excluding commands during 733


inserting conditions during 735


inserting stops in 732


paths 732


Pen tool paths 732


specifying output folders


during 735


Rectangle Image Map tool 591


Rectangular Marquee tool 316


Red Eye tool 371


reference material 8


reference point 361


Reflected Gradient tool 493


Refresh command 86


Refresh command, in Version


Cue 120


Regenerate button 631


remote rollovers 609


Remove From Favorites


command 89


Remove Layer Mask command 436


removing software 1


removing working copies, in Version


Cue 137


renaming files 95


Render filters 521


rendering intents 271


renmoji 564


Replace Channel option 344


Replace Color command 304


resampling


See also resizing


about 182


interpolation methods 183, 184


Reselect command 315


Reset Actions command 738


Reset Palette Locations option 64


Reset To Default Workspace


command 83


Resize Image command 182


Resize Image wizard 182


Resize Table To Slices command 586


resizing


about 182


during printing 713


images 182, 736
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images in Save For Web dialog


box 630


slices 579


type 535


resolution


about 178


changing 184


determining optimal 186


displaying 182


document size and 185


dpi 181


file size and 180


screen frequency and 181


Resources and Extras CD 8


restarting Version Cue 116


Restore command, in Version


Cue 142


Restore To Background option 621


restoring images 71


result color 486


Reticulation filter 523


Reveal In Bridge command 88, 115,


Reveal In Explorer command 88


Reveal In Finder command 88


Reverse Frames command 617


Revert command 71


Revert To Last Version


command 147


RGB color displays


adjusting in ImageReady 231


cross-platform differences 230


Photoshop and ImageReady


differences 230


RGB Color mode 227


in Adobe Color Picker 242, 244


selecting color in 243


tonal and color adjustments in 282


RGB color values in Info palette 55


RGB images


channel display 439


converting to indexed color 238


specifying colors numerically


in 243, 506


Ripple filter 519


Rollover Preview button 611


rollover states


 See also rollovers, rollover styles


about 604


changing 608


copying and pasting 612


creating new 608


deleting 612


duplicating 612


matching layers across 613


Normal state 604


options for 608


saving to web pages 610


rollover styles


 See also rollovers, rollover states


applying 609


creating 609


rollovers


 See also rollover states, rollover


styles


about 604


animated GIF in 611


copying and pasting 612


creating 606


creating remote 609


designing pages with 571


editing layers in 613


previewing 611


rearranging 612


saving 605


Rotate 180˚ command 90


Rotate 90˚ Clockwise command 90


Rotate 90˚ Counter-clockwise


command 90


Rotate Canvas command 347


rotating


images 347, 363


layers 360


layers and selections 363


rotating images 90


Rough Pastels filter 513, 515


Rounded Rectangle Marquee


tool 316


Roundness option 477


RSS feeds 9, 92


rulers


about 58


changing settings 59


zero origin 58


Run Length Encoding (RLE)


compression 678


S 

Sampled Blur filter 517


sampling


from layers 398


images with Clone Stamp tool 366


images with Healing Brush


tool 367


images with Patch tool 369


Saturation mode 488


saturation, adjusting 295, 373, 374


Save A Version command 144, 653


Save Actions command 738


Save As command 653, 654


Save command 653, 654


Save For Web command 625, 653


Save For Web dialog box


about 625


Color Table panel in 638


Image Size panel in 630


resizing images in 630


switching to ImageReady from 626


viewing annotations in 627


working with slices in 629


Save Master Palette command 643


Save Optimized As command 628,


653, 736

Save Optimized command 625, 653,


736


Save Selection command 344


Save Slice Selection command 578


Save Workspace command 83


saving


See also individual file format


names


actions in Photoshop 738


alpha channels 655


annotations 655


as a copy 655


color tables 241, 642


color-managed documents 655


copyright information 689


duotone curves 726


duotone settings 727


embedded watermarks 689
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for page layout 700


image previews 655


images 653


layers 655


optimized images 650


options 655


preferences 655


specifying file extensions when 692


spot channels 655


thumbnails 655


to Illustrator 701


tonal and color adjustment


settings 282


with lowercase file extensions 655


Scale Effects command 422


scaling


images during printing 713


layer styles 422


layers 360


scanner drivers 188


scanning 189


about 188


at correct resolution 183


at widest dynamic range 190


correcting color casts introduced


by 190


images 188


predicting file size for 190


selecting devices for 189


setting white and black points


before 190


Scitex format 684


scratch disks 77


scratch size, viewing 32


screen frequency


about 181


determining resolution 186


saving settings for 722


scanning and 189


setting 721


Screen mode 487


screen ruling 721


scripting


See also actions, automating,


droplets


for Photoshop automation 746


guides for 8


resources for 8


scripting guides


Adobe Bridge 94


for developers 9


Scripts Events Manager 747


scrubby sliders 38


SDK documentation 9


searching


in Version Cue projects 137


searching for files and folders 91


security


assigning user IDs in Version


Cue 167


Select All command 87


Select All From Selection


command 640


Select All User Slices command 577


Select Labeled command 87


Select Unlabeled command 87


selecting


See also selections, selection


borders


channels 445


color ranges 320


colors from all visible layers 320


contiguous pixels 320, 371


files, in Bridge 87


keyboard shortcuts for 765


layers 399


layers in a group 400


pixels 315


RGB colors 243


snapshots 75


type 544


selection borders


closing 317


converting to paths 468


defining paths 468


for type 544


framing with selection 325


from paths 467


snapping behavior of 60


stroking 325


selections


adding to 324


adding to channel 344


aligning 317


anti-aliasing 326


contracting 325


converting from slices 322


converting to layer 397


copying 330


copying between applications 332


copying while dragging 331


creating edge effects with 514


creating multiple copies of 331


creating with Quick Mask


mode 339


customizing for Magic Wand


tool 320


deleting 334


deselecting 315


dragging between documents 331


duplicating 331


editing in Quick Mask mode 339


erasing segments of 317


expanding 325


extracting 336


extracting from background 336


feathering 326


filling 497


freehand 317


from temporary masks 341


hiding and showing edges of 323


intersecting 324


intersecting in channel 344


inverting 324


loading 335


loading from an alpha channel 345


loading from another image 335


loading in ImageReady 335


moving 328


moving, hiding, or inverting 323


pasting 331


pasting in another selection 330


refining with Color Range


command 320


removing fringe pixels from 327


removing halos around 327


replacing in channel 344


saved as alpha channels 339


saving 334


saving as a mask 343


saving to a channel 344
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selecting similar pixels in 325


selecting unselected areas of 324


smoothing 325


snapping behavior of 60


softening edges of 326


softening with Color Range


command 321


stroking 497


subtracting from 324


subtracting from channel 344


tools and commands for


making 315


with straight-edged borders 317


Selective Color command 306


Selective color palette 239


selective sharpening 357


Send Backward command 401


Send To Back command 401


Send To Recycle Bin command 88


separations. See color separations


serial numbers, legacy 70


server-side image maps 596


Set Black Point eyedropper 291


Set Gray Point eyedropper 286


Set Optimization Settings


command 736


Set White Point eyedropper 291


Shadow/Highlight command 299,


shadows


adjusting 300, 373


adjusting with Levels 285


shape dynamics, for brushes 479


shape layers 449


Shape tool options 452


shapes


about 449


adding to 451


distributing 465


drawing 450


drawing custom 450


editing 453, 464


intersecting 451


multiple on a layer 451


overlapping 451


rasterizing 452


rasterizing in ImageReady 452


repositioning 464


saving custom 452


selecting custom 451


subtracting from 451


wheel 451


Share Project command 125


sharing projects


Adobe Creative Suite 125, 126


using Version Cue Administration


utility 162


Sharpen Edges filter 522


Sharpen filter 354, 522


Sharpen More filter 522


Sharpen tool 373


sharpening images 354, 355, 356


Shear filter 519


shifting colors to another RGB


value 640


shifting colors to prevent


dithering 641


shortcuts 754


Show All Files command 86


Show All Layer Styles command 416


Show Auto Slice command 576


Show Camera Raw Files Only


command 86


Show Channels command 439


Show Character command 545


Show Color Table command 638


Show File In Browser command 149


Show Folders command 86


Show Graphic Files Only


command 86


Show Hidden Files command 86


Show Rulers command 58


Show Slice Number command 576


Show Thumbnail Only command 85


Show Vector Files Only command 86


sidecar files 95, 223


Single Column Marquee tool 316


Single Row Marquee tool 316


Single-line Composer 563


sixteen-bits-per-channel images


converting to 32 bits-per


channel 233


support for 232


Sketch filters 522


skewing 363


Slice Options dialog box 572


Slice palette 587


slice sets


about 578


creating 578


deleting 578


showing and hiding 578


slice symbols 576


Slice tool 573


slices


about 572


adding HTML text to 589


adding links to 589


aligning 582


auto 572


background color of 588


badges in 575


boundaries of 576


brightness of 577


changing stacking order of 581


color of 575


combining 581


converting 322, 574, 575


converting auto to user 575


copying 581


creating from guides 573


creating from layers 574


creating with Slice tool 573


deleting 583


deleting selections in 578


dithering 584


duplicating 580


export options for 587


Image type 588


in actions 736


layer-based type 574


linking 584


locking 583


modifying 581


moving 579


nesting tables in 585


No Image type 588


numbering of 575


optimizing 583


pasting 581


 



803 INDEX 

promoting 574


renaming 588


resizing 579


selecting 577


slice lines 575, 577


snapping to 579


specifying browser messages in


export options 589


Table type 572


types of 572


unlocking 583


user type 572


viewing 575


viewing tables in 585


working with in Save For Web 629


sliders


pop-up sliders 37


scrubby sliders 38


Slideshow command 85


small caps 554


Small Caps command 554, 555


Smart Blur filter 517


Smart Guides 60, 61


Smart Highlighting option 337


Smart Objects


about 427


converting to layer 429


copying 429


editing 428


exporting 429


Smart Sharpen filter 355


smoothing


selection edges 468


selections 325


Smudge Stick filter 515


Smudge tool 372


Snap command 62, 317


Snap Neutral Midtones option of


Auto Color 310


Snapshot command 74


snapshots


clearing 72


of state 72


Soft light mode 487, 488


soft proofs 283


soft-proofing


about 259


in GoLive 261


in Photoshop, Illustrator and


InDesign 259


software


downloads 9


installing 1


plug-ins 9


removing 1


Solarize filter 524


Sort By Hue command 639


Sort By Luminance command 639


Sort By Popularity command 639


Sort command 86


spacer cells 648


Spacing option, brush 478, 482


special characters


about 546


in OpenType fonts 556


special effects with filters 514


spell-checking


about 538


Spherize filter 519


Splatter filter 518


Split Channels command 441


Sponge filter 515


Sponge tool 373


spot channels


See also channels


adding 443


merging 445


options 445


saving 655


spot colors


about 442


color management


considerations 255


trapping 445


Spotlight effect 528


Sprayed Strokes filter 518


square pixels 704


squares


drawing 500


sRGB color space 258, 269


stacking order


arranging for slices 581


of image maps 595


of layers 401


Stained Glass filter 525


Stamp filter 523


standard deviation pixel values 278


Standard mode button, for turning


off quick mask 341


standard screen mode 51


stars, rating files with 91


statistics, viewing in Histogram


palette 278


status bar


about 32


Stock Photo accounts


benefits 109


changing information 110, 111


creating 109


signing in 110


Stock Photos. See Adobe Stock


Photos


stops, inserting in recordings 732


straight quotes 538


strikethrough type 552


Stroke command 499


Stroke effect 416


Stroke Path command 499


strokes


keyboard shortcuts for 767


stroking


selection borders 325


selections 497, 500


styles


applying preset 415


converting to layers 423


copying and pasting in 422


creating custom 416


editing 417


preset 414


Styles palette 415


Stylize filters 523


Stylus Pressure option 319


subscript type


about 546


subslices 573


Subtract option 448


Sumi-e filter 518


superscript type
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about 546


support options 6


See also Help 

swashes


in type 546


swatches


sharing between applications 256


Swatches palette


about 506


keyboard shortcuts for 775


loading color table into 241


SWF format


about 633, 685


bitmap options for 672


embedding fonts in 672


Enable Dynamic Text option


in 672


saving in 671


text options for 672


Switch To Compact Mode button 81


Switch To Full Mode button 81


Synchronize command, in Version


Cue 154


Synchronized file status, in Version


Cue 128


synchronizing


color settings 252, 254


files, in Bridge 154


files, in Version Cue 154


synthetic states 611


System Administrator privileges, in


Version Cue 169


T 

table slices 572


tables


deleting 587


export options for 586


grouping slices in 585


nesting 585


resizing 586


selecting 586


viewing 585


tablet, setting pen pressure 485


Tagged-Image File Format (TIFF).


See TIFF format


Targa format 685


target channel 439


target color for eyedropper tools 291


target values, setting with Levels or


Curves 293


tate-chu-yoko 564


technical resources 9


technical support


complimentary and paid 6


on Adobe.com 9


templates, using with other Adobe


applications 751


text on a path 541


Text Selection command 545


text, keyboard shortcuts for 768


text. See type


Texture Channel 530


Texture filters 525


textures


copying between tools 485


for brushes 481


in Lighting Effects filter 530


protecting in brush strokes 484


Texturizer filter 513, 525


thirty-two-bits-per-channel images


converting to 8 or 16 bits per


channel 205


support for 232


Threshold command 292, 313


Threshold mode 291


Threshold slider 520


thumbnails


in PDF file 660


layer 396


resizing in Channels palette 440


resizing in Paths palette 458


saving 655


viewing in Open dialog box 192


TIFF format 685


about


saving files in 673


saving in for page layout 700


Tile Maker filter 526


Tiles filter 524


tips and tricks 7


tokens 600


syntax of 602


using in web photo gallery 602


tonal and color adjustment


commands


Auto Contrast 308


Hue/Saturation 295


Match Color 303


Replace Color 304


tonal and color adjustments


See also tonal and color adjustment


commands


about 274


automatic adjustments 307, 308


made in Curves dialog box 288


made with adjustment layers 281


saving 282


using tools and commands for 281


tonal range


adjusting with Curves 288


adjustment methods for 275


changing with adjustment


layers 282


checking in histogram 275


remapping pixels in channel 313


scanning and 190


tool hotspots 47


tool pointers 47


tool presets


about 48


creating 48


palettes for 49


tool tips 84


about 40


changing font size of 64


hiding 46


toolbox 31


tools


See also tool presets, individual tool


names


cycling through 46


fill 337


gallery of 45


keyboard shortcuts for 755


layer sampling 398


painting 471


recording in actions 731, 733


setting pointer appearance of 47


snapping behavior of 60


standard and precise cursors in 47
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viewing current 33


viewing hidden 40, 46


Tools commands, in Bridge 94


Tools Preset pop-up palette 49


Torn Edges filter 523


Total Training 7


Toyo colors 247


Trace Contour filter 524


training 7, 9


Transform command 55


transforming


layers 402


reference point 361


type 535


transforming objects


from the Edit menu 535


with Perspective and Distort


commands 535


transparency


applied with mask 340


canvas 346


channel display 439


dithering 637


gradients 493


in documents 398


resources for developers 8


Transparency & Gamut option 398


Trap command 725


trapping


adjusting overlapping spot


colors 445


Trim command 350


trimming images 350


tritones. See duotones


TrueType fonts 532


Trumatch color system 247


tryouts 9


Tsume option 564


tutorials 7, 13


TWAIN interface for scanners 188


tweening 618


Twirl Clockwise tool 385


Twirl filter 519


Two-dimensional (2D)


transformations 360


type


See also Asian type, fonts, type


formatting, type layers


about 532


adding drop shadow to 553


aligning Asian characters 565


Asian type options 564


assigning a language to 540


baseline shift 551


bounding box of 535


committing 533


composition of 563


creating 533


curly and straight quotes in 538


editing 538


filling 548


finding and replacing 539


formatting characters 544


formatting paragraphs 558


formatting through the Character


palette 545


fractional character widths 555


hanging punctuation 561


keyboard shortcuts for 768


on a path 541


orientation of 536


paragraph type 534


resizing 535


selecting 544


selection border around 544


setting Asian OpenType font


attributes 566


size of 547


spell-checking 538


style of 546


transforming 535


underlining or striking


through 552


unwarping 541


warping 540


work path for 543


Type 1 fonts 546


type layers


about 535


anti-aliased 536


changing orientation 536


rasterizing 536


transforming 535


unwarping 541


warping 540


Type tool 533


type, formatting


all caps and small caps 554


keyboard shortcuts for 768


missing fonts 556


OpenType fonts 556


special characters 546


with Paragraph palette 558


typographers’ quotes 538


U 

Unavailable file status, in Version


Cue 129


Uncached Refresh, in Histogram


palette 279


underlining type 552


Underpainting filter 513, 515


Undo command 71


Unfiltered menu 86


Ungroup command 437


Uniform color palette 238, 239


Unify Layer Position button 613


Unify Layer Style button 613


Unify Layer Visibility button 613


uninstallation, software 1


Unlink All command 584


Unlink Slices command 584


unlocking colors 642


unlocking slices 583


Unshare Project command 125


Unsharp Mask filter 355, 522


about 354, 356


after resampling 183


selective sharpening 357


Unshift All Colors command 641


unwarping type layers 541


updates 9


URLs


assigning to image maps 593


assigning to slices 589


Use Accurate Screens option 728


Use Adobe Dialog command 115


Use Embedded Color Profile


command 231


Use Unified Color Table option 638
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INDEX 

Use Video Alpha option 398


user forums 9


user IDs


creating in Version Cue


Administration utility 168


deleting or duplicating in Version


Cue Administration utility 169


user slices. See slices


users


assigning to Version Cue


projects 160, 161, 162


privilege levels, in Version Cue 169


variables


about 748


defining 749


Variations command 311


varnishes


See also process color inks


about 443


vector graphics


about 177, 449


printing 714


SWF (Flash) file format 633


type 532, 543


Vector Mask Hides Effects


option 413


vector masks


adding 434


converting to layer mask 435


disabling and enabling 435


editing 435


removing 435


versions


deleting in Version Cue 147


deleting with Version Cue


Administration utility 165


in Version Cue 126


promoting, in Version Cue 147


saving, in Version Cue 144


using, in Version Cue 143


viewing all, in Bridge 146


viewing and comparing in Version


Cue 144


vertical scale of type, adjusting 551


VGA color palette 682


video


previewing images for 704


saving images for 704


training 7


Video filters


De-Interlace 525


NTSC Colors 525


Video Preview plug-in 708


Viewpoint Media Player 677


vignetting


about 352


correcting in camera raw files 220


virtual memory 77


Vivid light mode 488


W 

Wacom tablet 478


warming filters 299


warnings, showing and hiding 69


Warp Text command 540


Warp tool 385


warping type layers 540


Water Paper filter 523


Watercolor filter 515


watermarks


embedding 689, 691


viewing in status bar 32


Watermark Durability Setting 691


Wave filter 519


WBMP format 686


web color palettes 238


Web Color Sliders command 246


Web Content palette 605


web file formats


GIF and PNG-8 632


JPEG 632


PNG-24 633


web graphics


color management


considerations 258


optimizing 625


web pages


designing 571


opening in Adobe GoLive 571


rollovers in 571


slices in 571


web photo galleries


creating 598


customizing 600


options for 599


styles 600


using tokens in 600, 602


Web Shift/Unshift Selected Colors


command 641


web-content folder


about 119


web-data folder 119


WebDAV servers


connecting to Cue projects 121


exporting Version Cue projects


to 164


publishing Version Cue projects


to 161, 162


web-safe alert, in Color Picker 243


web-safe colors


about 245, 635


changing to 245


selecting in Adobe Color


Picker 245


selecting in Color palette 245


weighted optimization


about 644


GIF and PNG-8 color


reduction 646


GIF and PNG-8 dithering 646


GIF lossiness 645


JPEG quality 645


masks and 644


wet edges, or watercolor, effect 484


white balance for camera raw


files 214


white point 190


WIA support 187, 189


Wind filter 524


Windows (Microsoft)


color palette 238


Color Picker 247


System color palette 241


WMMP optimization options 634


word breaks, preventing 562


word spacing 560


work paths


about 450
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INDEX 

converting selection to 468 

creating 458, 459 

Workgroup Size preference 117 

working files 

editing, in Version Cue 152 

using, in Version Cue 126 

working spaces, color 268, 269 

workspaces 

about 64


changing font size in 64


customizing menus in 65


deleting menus from 66


in Bridge 82


menu colors in 66


XHTML 

XHTML-compliant web pages 647 

XMP (eXtensible Metadata Platform) 

about 95 

XMP sidecar files 

in Camera Raw 223 

viewing in Bridge 223 

Z 

zero origin (rulers) 58 

ZigZag filter 519 

ZIP compression 678 

Zoom tool 55 

zooming 

dragging 53


in and out 52


ZoomView format 

about 677 

exporting images in 677 

 




