
 

 

 

Numbers ’08
User’s Guide



 

 

K

 

 Apple Inc.
© 2008 Apple Inc. All rights reserved. 

Under the copyright laws, this manual may not be 
copied, in whole or in part, without the written consent 
of Apple. Your rights to the software are governed by 
the accompanying software license agreement. 

The Apple logo is a trademark of Apple Inc., registered 
in the U.S. and other countries. Use of the “keyboard” 
Apple logo (Option-Shift-K) for commercial purposes 
without the prior written consent of Apple may 
constitute trademark infringement and unfair 
competition in violation of federal and state laws.

Every effort has been made to ensure that the 
information in this manual is accurate. Apple is not 
responsible for printing or clerical errors.

Apple
1 Infinite Loop
Cupertino, CA 95014-2084
408-996-1010
www.apple.com 

Apple, the Apple logo, AppleWorks, ColorSync, iMovie, 
iPhoto, iTunes, Keynote, Mac, Mac OS, Numbers, Pages, 
Quartz, and QuickTime are trademarks of Apple Inc., 
registered in the U.S. and other countries.

Finder, iWeb, iWork, Safari, and Spotlight are trademarks 
of Apple Inc.

AppleCare is a service mark of Apple Inc., registered in 
the U.S. and other countries. 

Adobe and Acrobat are trademarks or registered 
trademarks of Adobe Systems Incorporated in the U.S. 
and/or other countries. 

Other company and product names mentioned herein 
are trademarks of their respective companies. Mention 
of third-party products is for informational purposes 
only and constitutes neither an endorsement nor a 
recommendation. Apple assumes no responsibility with 
regard to the performance or use of these products.

019-1277 06/2008



 

 

 

    

 

 

 

3

 

1

 

Contents

 

Preface 16 Welcome to the 

 

Numbers User’s Guide

 

Chapter 1 18 Numbers Tools and Techniques
18

 

Spreadsheet Templates

 

20

 

The Numbers Window

 

21

 

Spreadsheet Viewing Aids

 

21

 

Zooming In or Out

 

21

 

The Sheets Pane

 

22

 

Print View

 

22

 

Alignment Guides

 

23

 

The Styles Pane

 

24

 

The Toolbar

 

25

 

The Format Bar

 

25

 

The Inspector Window

 

26

 

Formula Tools

 

28

 

The Media Browser

 

28

 

The Colors Window

 

29

 

The Font Panel

 

29

 

The Warnings Window

 

30

 

Keyboard Shortcuts and Shortcut Menus

 

Chapter 2 31 Working with a Numbers Spreadsheet
31

 

Creating, Opening, and Importing Spreadsheets

 

31

 

Creating a New Spreadsheet

 

33

 

Importing a Document

 

33

 

Opening an Existing Spreadsheet

 

34

 

Saving Spreadsheets

 

34

 

Saving a Spreadsheet

 

35

 

Undoing Changes

 

35

 

Automatically Saving a Backup Version of a Spreadsheet

 

35

 

Saving a Spreadsheet as a Template

 

36

 

Saving Search Terms for a Spreadsheet



 

4

 

Contents

 

36

 

Saving a Copy of a Spreadsheet

 

36

 

Closing a Spreadsheet Without Quitting Numbers

 

37

 

Using Sheets to Organize a Spreadsheet

 

37

 

Viewing Sheets

 

38

 

Adding and Deleting Sheets

 

38

 

Reorganizing Sheets and Their Contents

 

39

 

Changing Sheet Names

 

39

 

Dividing a Sheet into Pages

 

40

 

Setting a Spreadsheet’s Page Size

 

41

 

Using Headers and Footers

 

41

 

Arranging Objects on a Page

 

42

 

Setting Page Orientation

 

42

 

Setting Pagination Order

 

42

 

Numbering Pages

 

43

 

Setting Page Margins

 

Chapter 3 44 Using Tables
44

 

About Tables

 

45

 

Working with Tables

 

45

 

Adding a Table

 

45

 

Using Table Tools

 

48

 

Resizing a Table

 

48

 

Moving Tables

 

49

 

Naming Tables

 

49

 

Defining Reusable Tables

 

50

 

Copying Tables Among iWork Applications

 

51

 

Selecting Tables and Their Components

 

51

 

Selecting a Table

 

51

 

Selecting a Table Cell

 

52

 

Selecting a Group of Table Cells

 

52

 

Selecting a Row or Column

 

53

 

Selecting Table Cell Borders

 

54

 

Working with Content in Table Cells

 

54

 

Adding and Editing Cell Values

 

55

 

Working with Text in Cells

 

56

 

Working with Numbers in Cells

 

57

 

Working with Dates in Cells

 

57

 

Displaying Content Too Large for Its Cell

 

58

 

Formatting Cell Values

 

59

 

Using the Number Format

 

60

 

Using the Currency Format

 

61

 

Using the Percentage Format



 

Contents

 

5

 

62

 

Using the Date and Time Format

 

63

 

Using the Fraction Format

 

63

 

Using the Scientific Format

 

64

 

Using the Text Format

 

65

 

Using a Checkbox and Other Control Formats

 

67

 

Monitoring Cell Values

 

68

 

Adding Images or Color to Cells

 

68

 

Autofilling Table Cells

 

69

 

Working with Rows and Columns

 

69

 

Adding Rows

 

70

 

Adding Columns

 

70

 

Rearranging Rows and Columns

 

70

 

Deleting Table Rows and Columns

 

71

 

Using a Table Header Row or Column

 

72

 

Using a Footer Row

 

72

 

Hiding Rows and Columns

 

73

 

Resizing Table Rows and Columns

 

73

 

Alternating Row Colors

 

74

 

Working with Table Cells

 

74

 

Merging Table Cells

 

74

 

Splitting Table Cells

 

75

 

Formatting Table Cell Borders

 

76

 

Copying and Moving Cells

 

76

 

Adding Comments

 

77

 

Reorganizing Tables

 

77

 

Sorting Table Cells

 

78

 

Filtering Rows

 

Chapter 4 79 Working with Table Styles
79

 

Using Table Styles

 

80

 

Applying Table Styles

 

80

 

Modifying a Table’s Style

 

80

 

Modifying Table Style Attributes

 

81

 

Copying and Pasting Table Styles

 

81

 

Using the Default Table Style

 

82

 

Creating New Table Styles

 

82

 

Renaming a Table Style

 

82

 

Deleting a Table Style

 

Chapter 5 83 Using Formulas and Functions in Tables
83

 

Using Formulas

 

84

 

A Tour of Using Formulas



 

6

 

Contents

 

86

 

Performing Instant Calculations
87 Adding a Quick Formula
87 Performing a Basic Calculation Using Column Values
88 Performing a Basic Calculation Using Row Values
88 Removing a Formula
88 Using the Formula Editor
89 Adding a New Formula with the Formula Editor
89 Editing a Formula with the Formula Editor
90 Using the Formula Bar
90 Adding a New Formula with the Formula Bar
91 Editing a Formula with the Formula Bar
91 Using Cell References
91 Adding Cell References to a Formula
92 Copying or Moving Formulas with Cell References
93 Applying a Formula Once to Cells in a Column or Row
93 Handling Errors and Warnings
94 Using Operators
94 Performing Arithmetic Operations
95 Understanding the Arithmetic Operators
96 Understanding the Comparison Operators
96 Using Functions

Chapter 6 98 Using Charts
98 About Charts

101 Adding a Chart
102 Editing Charts
103 Changing the Plotting Orientation
103 Changing the Data Plotted in a Chart
103 Adding Data to a Chart
104 Adding Data to a Chart from Multiple Tables
104 Removing Data from a Chart
105 Replacing a Data Series
105 Deleting a Chart
105 Moving a Chart
105 Changing a Chart from One Type to Another
106 Formatting General Chart Attributes
106 Using a Legend
107 Using a Chart Title
107 Resizing a Chart
107 Rotating Charts
108 Adding Labels and Axis Markings
108 Showing Axes and Borders



Contents 7

109 Using Axis Titles
109 Showing Data Point Labels
110 Formatting the Value Axis
110 Placing Labels, Gridlines, and Tick Marks
112 Formatting the Elements in a Data Series
112 Formatting Titles, Labels, and Legends
113 Adding Descriptive Text to a Chart
113 Formatting Specific Types of Charts
113 Pie Charts
113 Selecting Individual Pie Wedges
114 Showing Series Names in a Pie Chart
114 Separating Individual Pie Wedges
114 Adding Shadows to Pie Charts and Wedges
115 Adjusting the Opacity of Pie Charts
115 Rotating 2D Pie Charts
115 Bar and Column Charts
115 Adjusting Spacing of Bar and Column Charts
116 Adding Shadows to Bar and Column Charts
116 Adjusting the Opacity of Bar and Column Charts
116 Area Charts and Line Charts
117 Scatter Charts
118 3D Charts

Chapter 7 119 Working with Text
119 Adding Text
119 Deleting, Copying, and Pasting Text
120 Selecting Text
120 Formatting Text Size and Appearance
121 Using the Format Bar to Format Text
121 Using the Format Menu to Format Text
121 Making Text Bold or Italic Using the Menus
121 Creating Outlined Text Using the Menus
122 Underlining Text Using the Menus
122 Changing Text Size Using the Menus
122 Making Text Subscript or Superscript Using the Menus
123 Changing Text Capitalization Using the Menus
123 Using the Font Panel to Format Text
124 Making the Font Panel Easy to Use
124 Changing Fonts Using the Font Panel
125 Changing Underlining Using the Font Panel
125 Adding a Strikethrough to Text Using the Font Panel
125 Changing Text Color Using the Font Panel



8 Contents

126 Changing the Paragraph Background Color Using the Font Panel
126 Creating Shadows on Text Using the Font Panel
126 Adding Accents and Special Characters
126 Adding Accent Marks
127 Viewing Keyboard Layouts for Other Languages
128 Typing Special Characters and Symbols
128 Using Smart Quotes
129 Using Advanced Typography Features
129 Adjusting Font Smoothing
130 Setting Text Alignment, Spacing, and Color
131 Aligning Text Horizontally
131 Aligning Text Vertically
132 Adjusting the Spacing Between Lines of Text
133 Adjusting the Spacing Before or After a Paragraph
133 Adjusting the Spacing Between Characters
133 Changing Text Color
134 Setting Tab Stops to Align Text
135 Setting a New Tab Stop
135 Changing a Tab Stop
135 Deleting a Tab Stop
136 Setting Indents
136 Setting Indents for Paragraphs
136 Changing the Inset Margin of Text in Objects
137 Setting Indents for Lists
137 Using Bulleted, Numbered, and Ordered Lists (Outlines)
137 Generating Lists Automatically
138 Using Bulleted Lists
139 Using Numbered Lists
140 Using Ordered Lists (Outlines)
141 Using Text Boxes and Shapes to Highlight Text
141 Adding Text Boxes
141 Presenting Text in Columns
142 Putting Text Inside a Shape
143 Formatting a Text Box or Shape
143 Using Hyperlinks
143 Linking to a Webpage
144 Linking to a Preaddressed Email Message
144 Editing Hyperlink Text
145 Inserting Page Numbers and Other Changeable Values
145 Automatically Substituting Text
146 Inserting a Nonbreaking Space



Contents 9

146 Checking for Spelling Mistakes
146 Finding Misspelled Words
147 Working with Spelling Suggestions
148 Finding and Replacing Text

Chapter 8 149 Working with Shapes, Graphics, and Other Objects
149 Selecting Objects
150 Copying or Duplicating Objects
150 Deleting Objects
150 Moving Objects
151 Moving an Object Forward or Backward
151 Aligning Objects
151 Aligning Objects Relative to Each Other
152 Spacing Objects Evenly on a Page
152 Using Alignment Guides
153 Creating New Alignment Guides
153 Setting Precise Positions of Objects
154 Modifying Objects
154 Resizing Objects
154 Flipping and Rotating Objects
155 Changing the Style of Borders
156 Framing Objects
156 Adding Shadows
158 Adding a Reflection
158 Adjusting Opacity
159 Grouping and Locking Objects
159 Grouping and Ungrouping Objects
160 Locking and Unlocking Objects
160 Filling Objects
160 Filling an Object with Color
161 Using the Colors Window
162 Filling an Object with an Image
164 Using Shapes
164 Adding a Predrawn Shape
164 Adding a Custom Shape
165 Making Shapes Editable
166 Manipulating Points of a Shape
166 Reshaping a Curve
167 Reshaping a Straight Segment
167 Transforming Corner Points into Curved Points and Vice Versa
168 Editing Specific Predrawn Shapes
168 Editing a Rounded Rectangle



10 Contents

168 Editing Single and Double Arrows
169 Editing a Star
169 Editing a Polygon
170 Using Media Placeholders
171 Working with Images
171 Importing an Image
172 Masking (Cropping) Images
172 Cropping an Image Using the Default (Rectangular) Mask
173 Masking an Image with a Shape
173 Unmasking an Image
173 Removing the Background or Unwanted Elements from an Image
174 Changing an Image’s Brightness, Contrast, and Other Settings
176 Using PDF Files as Graphics
177 Using Sound and Movies
177 Adding a Sound File
177 Adding a Movie File
178 Adjusting Media Playback Settings

Chapter 9 179 Adding Address Book Data to a Table
179 Using Address Book Fields
180 Mapping Column Names to Address Book Field Names
182 Adding Address Book Data to an Existing Table
182 Adding Address Book Data to a New Table

Chapter 10 183 Sharing Your Numbers Spreadsheet
183 Printing a Sheet
184 Choosing Printer Layout Options
185 Adjusting the Printed Color with ColorSync
186 Exporting to Other Document Formats
187 Sending a Spreadsheet to iWeb

Chapter 11 188 Designing Your Own Numbers Spreadsheet Templates
188 Designing a Template
188 Step 1:  Define Table Styles
189 Step 2:  Define Reusable Tables
189 Step 3:  Define Default Charts, Text Boxes, Shapes, and Images
189 Defining Default Attributes for Charts
190 Defining Default Attributes for Text Boxes and Shapes
190 Defining Default Attributes for Imported Images
191 Step 4:  Create Initial Spreadsheet Content
191 Predefining Tables and Other Objects for a Custom Template
191 Creating Media Placeholders for a Custom Template



Contents 11

192 Predefining Sheets for a Custom Template
192 Step 5:  Save a Custom Template

Chapter 12 193 Dictionary of Functions
193 About Functions
195 Date and Time Functions
196 Financial Functions
198 Logical Functions
198 Information Functions
199 Reference Functions
200 Numeric Functions
201 Trigonometric Functions
202 Statistical Functions
204 Text Functions
205 Function Descriptions
205 ABS
205 ACCRINT
206 ACCRINTM
206 ACOS
207 ACOSH
207 ADDRESS
208 AND
208 AREAS
209 ASIN
209 ASINH
209 ATAN
210 ATAN2
210 ATANH
210 AVEDEV
211 AVERAGE
211 AVERAGEA
212 CEILING
212 CHAR
213 CHOOSE
213 CLEAN
214 CODE
214 COLUMN
215 COLUMNS
215 COMBIN
216 CONCATENATE
216 CONFIDENCE
217 CORREL



12 Contents

217 COS
218 COSH
218 COUNT
219 COUNTA
220 COUNTBLANK
220 COUNTIF
221 COUPDAYBS
221 COUPDAYS
222 COUPDAYSNC
223 COUPNUM
224 COVAR
224 DATE
225 DATEDIF
226 DAY
226 DB
227 DDB
227 DEGREES
228 DISC
228 DOLLAR
229 EDATE
229 EVEN
230 EXACT
230 EXP
230 FACT
231 FALSE
231 FIND
232 FIXED
232 FLOOR
233 FORECAST
233 FV
234 GCD
234 HLOOKUP
235 HOUR
236 HYPERLINK
236 IF
237 INDEX
237 INDIRECT
238 INT
238 INTERCEPT
239 IPMT
240 IRR



Contents 13

240 ISBLANK
241 ISERROR
241 ISEVEN
241 ISODD
242 ISPMT
242 LARGE
243 LCM
244 LEFT
244 LEN
244 LN
245 LOG
245 LOG10
245 LOOKUP
246 LOWER
246 MATCH
247 MAX
248 MAXA
248 MEDIAN
248 MID
249 MIN
249 MINA
250 MINUTE
250 MIRR
250 MOD
251 MODE
251 MONTH
252 MROUND
252 NOT
253 NOW
253 NPER
254 NPV
254 ODD
255 OFFSET
255 OR
256 PERCENTILE
256 PI
257 PMT
257 POISSON
258 POWER
258 PPMT
259 PRICE



14 Contents

260 PRICEDISC
260 PRICEMAT
261 PROB
262 PRODUCT
262 PROPER
262 PV
263 QUOTIENT
263 RADIANS
264 RAND
264 RANDBETWEEN
264 RANK
265 RATE
266 REPLACE
266 REPT
267 RIGHT
267 ROMAN
268 ROUND
268 ROUNDDOWN
269 ROUNDUP
270 ROW
270 ROWS
270 SEARCH
271 SECOND
271 SIGN
271 SIN
272 SINH
272 SLN
273 SLOPE
273 SMALL
274 SQRT
274 STDEV
275 STDEVA
275 STDEVP
276 STDEVPA
277 SUBSTITUTE
277 SUM
278 SUMIF
278 SUMPRODUCT
279 SUMSQ
279 SYD
280 T



Contents 15

280 TAN
281 TANH
281 TIME
282 TIMEVALUE
282 TODAY
283 TRIM
283 TRUE
283 TRUNC
284 UPPER
284 VALUE
284 VAR
285 VARA
286 VARP
286 VARPA
287 VDB
288 VLOOKUP
289 WEEKDAY
289 YEAR

Index 290



Pr
ef

ac
e

16   

Welcome to the 
Numbers User’s Guide

This full-color PDF document provides extensive instructions 
for using Numbers.

Before using this document, you may want to look at the Numbers tutorial in iWork ’08 
Getting Started. It’s a quick way to prepare yourself to be a self-sufficient Numbers user. 
iWork ’08 Getting Started also provides additional resources for getting acquainted with 
Numbers, such as a tour of its features and how-to videos.

When you need detailed instructions to help you accomplish specific tasks, you’ll find 
them in this user’s guide. Most of the tasks in this guide are also available in online 
help.
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The following table tells you where to find information in this guide. In Numbers Help, 
you can find information by browsing or searching. 

For information about See

Using Numbers windows and 
tools to create and format 
spreadsheets

Chapter 1, “Numbers Tools and Techniques,” on page 18

Creating and saving Numbers 
spreadsheets, and managing 
sheets and pages

Chapter 2, “Working with a Numbers Spreadsheet,” on page 31

Creating, organizing, and 
formatting tables and values in 
them

Chapter 3, “Using Tables,” on page 44

Using table styles to change the 
appearance of tables

Chapter 4, “Working with Table Styles,” on page 79

Using formulas and functions for 
calculations in table cells

Chapter 5, “Using Formulas and Functions in Tables,” on page 83

Creating charts to graphically 
display numeric data in one or 
more tables

Chapter 6, “Using Charts,” on page 98

Formatting text in a Numbers 
spreadsheet

Chapter 7, “Working with Text,” on page 119

Using graphics, shapes, sound, 
and more to enhance a 
spreadsheet

Chapter 8, “Working with Shapes, Graphics, and Other Objects,” on 
page 149

Displaying Address Book data in 
tables

Chapter 9, “Adding Address Book Data to a Table,” on page 179

Printing and exporting 
spreadsheets and sending them 
to iWeb 

Chapter 10, “Sharing Your Numbers Spreadsheet,” on page 183

Creating custom Numbers 
templates

Chapter 11, “Designing Your Own Numbers Spreadsheet Templates,” 
on page 188

Using individual functions in 
table cells

Chapter 12, “Dictionary of Functions,” on page 193
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1 Numbers Tools and Techniques

This chapter introduces you to the windows and tools you 
use to work with Numbers spreadsheets.

When you create a Numbers spreadsheet, you first select a template to start from. 

Spreadsheet Templates
When you first open the Numbers application (by clicking its icon in the Dock or 
double-clicking its icon in the Finder), the Template Chooser window presents a variety 
of spreadsheet types from which to choose. 
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Pick the template that best fits your purpose. If you want to start from a plain 
spreadsheet, without preformatting, pick the Blank template. After selecting a 
template, click Choose to work with a new spreadsheet based on the selected 
template.

Templates contain predefined sheets, tables, and other elements that help you get 
started. 

Sheets let you divide information into groups of related objects. You might use one 
sheet for data from 2006 and another sheet for data from 2007.

Predefined tables usually contain text, formulas, and sample data. You can replace data 
in the predefined tables with your own data, and you can add columns and rows or 
reformat the tables. You can also add sheets and other objects, such as charts, images, 
and text.

Explanatory comments are included in some of the templates.
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The Numbers Window
The Numbers window has elements that help you develop and organize your 
spreadsheet. 

Â Quickly add a new sheet by clicking the Sheet button in the toolbar. After you add 
tables, charts, and other objects to a sheet, including imported graphics, movies, and 
sound, you can drag objects around on the Numbers canvas to rearrange them. 

Â Use the Sheets pane to see a list of the tables and charts on any sheet.
Â Apply predefined table styles listed in the Styles pane to change the appearance of a 

selected table.
Â Use the area in the lower left to perform instant calculations on values in selected 

table cells.

View the results of
calculations for values

in selected cells, and
drag calculations into

The sheet canvas:  
Create and edit tables, charts, and 
other objects on a sheet.

The Sheets pane:
See an overview
of the tables and

charts on the sheets
of your spreadsheet.

The Styles pane:  
Select a predefined table style 
to quickly format a table.

The Format Bar: 
Quickly format the 
selected object.

The toolbar:
Customize it to include the

tools you use most often.

The Formula Bar:  
Create and edit formulas 
in table cells.
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Â Use buttons in the toolbar to quickly add tables, charts, text boxes, media files, and 
other objects. 
For example, click the Tables button in the toolbar to add a new table that’s been 
preformatted for the template you’re using. All templates contain several 
preformatted tables for you to choose from.

See “The Toolbar” on page 24 to learn how to customize the toolbar so it includes 
the tools you use most often.

Â Use the Format Bar to quickly format a selected object.
Â Use the Formula Bar to add and edit formulas in table cells.

Spreadsheet Viewing Aids
As you work on your spreadsheet, you may want to zoom in or out to get a better view 
of what you are doing, or use other techniques for viewing the spreadsheet.

Zooming In or Out
You can enlarge (zoom in) or reduce (zoom out) your view of a sheet. 

Here are ways to zoom in or out of a sheet:
m Choose View > Zoom > zoom level.

m Choose a magnification level from the pop-up menu at the bottom left of the canvas.

When you view a sheet in Print View, decrease the zoom level to view more pages in 
the window at one time.

The Sheets Pane
The Sheets pane is located along the top left side of the Numbers canvas. It lets you 
quickly view and navigate to tables and charts in a sheet. 

See “Using Sheets to Organize a Spreadsheet” on page 37 for more information.

Click to show or hide a
sheet’s tables and charts. Click a table or chart in 

the list to select it and 
show it in the window.

Click to add a new sheet.
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Print View
When you want to print a sheet or make a PDF of it, you can use Print View to visualize 
the layout of objects on a sheet on individual pages. 

See “Dividing a Sheet into Pages” on page 39 to learn more about Print View.

Alignment Guides
As you move objects around in a spreadsheet, alignment guides automatically appear 
to help you position them on the page. See “Using Alignment Guides” on page 152 for 
details about using alignment guides.

Click to show or 
hide Print View.

Slide to shrink or enlarge all the 
sheet’s objects.

Footer area Header area 

Click to choose a page
zoom level that lets you

see more or fewer pages.

Click to view pages in
portrait (vertical)

orientation.

Click to view pages in
landscape (horizontal)

orientation.
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The Styles Pane
The styles pane lets you quickly apply predefined formatting to tables in a spreadsheet. 
Table styles define such attributes as color, text size, and cell border formatting of table 
cells.

To apply a table style, simply select the table and click a style in the Styles pane.

Switching from one table style to another takes only one click.

See “Using Table Styles” on page 79 for details.
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The Toolbar
The Numbers toolbar gives you one-click access to many of the actions you perform as 
you work in Numbers. As you discover which actions you perform most often, you can 
add, remove, and rearrange toolbar buttons to suit your working style.

To see a description of what a button does, hold your pointer over it.

The default set of toolbar buttons is shown below.

To customize the toolbar: 
1 Choose View > Customize Toolbar. The Customize Toolbar sheet appears.

2 Make changes to the toolbar as desired.

To add an item to the toolbar, drag its icon to the toolbar at the top. If you frequently 
reconfigure the toolbar, you can add the Customize button to it.

To remove an item from the toolbar, drag it out of the toolbar.

To restore the default set of toolbar buttons, drag the default set to the toolbar. 

To make the toolbar icons smaller, select Use Small Size.

To display only icons or only text, choose an option from the Show pop-up menu.

To rearrange items in the toolbar, drag them.

3 Click Done when you’ve finished.

You can perform several toolbar customization activities without using the Customize 
Toolbar sheet:

Â To remove an item from the toolbar, press the Command key while dragging the item 
out of the toolbar.
You can also press the Control key while you click the item, and then choose Remove 
Item from the shortcut menu. 

Â To move an item, press the Command key while dragging the item around in the 
toolbar.

To show and hide the toolbar, choose View > Show Toolbar or View > Hide Toolbar.

Add a sheet.

Add a formula.Add a table.

Add a chart, text box, 
shape, or comment.Sort and filter rows.

Show or hide Print View, 
comments, and more.

Open the Inspector window,
Media Browser, Colors

window, and Font panel.
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The Format Bar
Use the Format Bar, displayed beneath the toolbar, to quickly change the appearance 
of tables, charts, text, and other elements in your spreadsheet. 

The controls in the Format Bar vary with the object selected. To see a description of 
what a Format Bar control does, hold the pointer over it.

Here’s what the Format Bar looks like when a table or table cell is selected. 

To show and hide the format bar:
m Choose View > Show Format Bar or View > Hide Format Bar.

The Inspector Window
Most elements of your spreadsheet can be formatted using the Numbers inspectors. 
Each inspector focuses on a different aspect of formatting. For example, the Cells 
Inspector lets you format cells and cell values. Hold your pointer over buttons and 
other controls in the Inspector panes to see a description of what the controls do.

Opening multiple Inspector windows can make it easier to work on your spreadsheet. 
For example, if you open both the Graphic Inspector and the Cells Inspector, you’ll have 
access to all the image- and cell-formatting options.

Arrange text in table cells.

Format cell borders.

Add background
color to a cell.

Format cell values.
Manage headers

and footer.

Show or hide a table’s name.

Format text in table cells.

The buttons at the top of the 
Inspector window open the ten 
inspectors:  Document, Sheet, Table, 
Cells, Chart, Text, Graphics, Metrics, 
Hyperlink, and QuickTime.
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Here are ways to open an Inspector window:
m Click Inspector in the toolbar.

m Choose View > Show Inspector.

m To open another Inspector window, press the Option key while clicking an Inspector 
button.

After an Inspector window is open, click one of the buttons at the top to display a 
different inspector. Clicking the second button from the left, for example, displays the 
Sheet Inspector. 

Formula Tools
You add a formula to a table cell when you want to display a value in the cell that’s 
derived using a calculation. Numbers has several tools for working with formulas in 
table cells:
Â The Formula Editor lets you create and modify formulas. Open the Formula Editor by 

selecting a table cell and typing the equal sign (=). You can also open it by choosing 
Formula Editor from the Function pop-up menu in the toolbar.

Learn more about this editor in “Using the Formula Editor” on page 88.

Â The Formula Bar, always visible beneath the Format Bar, can also be used to create 
and modify formulas.

Instructions for adding and editing formulas using this tool are in “Using the Formula 
Bar” on page 90.

Move the Formula Editor
by grabbing here

and dragging.

Text field 
View or edit a formula.

Cancel button
Discard changes.

Accept button
Save changes.

Text field 
View or edit a formula.

Cancel button
Discard changes.

Accept button
Save changes.

Click to open the
Function Browser.
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Â Using the Function Browser is the fastest way to add a function. A function is a 
predefined formula that has a name (such as SUM and AVERAGE). 

To open the Function Browser, click the Function Browser button in the Formula Bar.

“Using Functions” on page 96 tells you how to use the Function Browser.

Click to open the 
Function Browser.
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The Media Browser
The Media Browser provides access to all the media files in your iPhoto library, your 
iTunes library, and your Movies folder. You can drag an item from the Media Browser to 
your spreadsheet or to an image well in an inspector.

Here are ways to open the Media Browser:
m Click Media in the toolbar.

m Choose View > Show Media Browser.

The Colors Window
You use the Mac OS X Colors window to choose colors for text, table cells, cell borders, 
and other objects. While you can also use the Format Bar to apply colors, the Colors 
window offers advanced color management options.

To open the Colors window:
m Click Colors in the toolbar.

For more information, see “Using the Colors Window” on page 161.

Click a button to view the files in 
your iTunes library, your iPhoto 
library, your Aperture library, or 
your Movies folder.

Drag a file to your 
spreadsheet.

Search for a file.
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The Font Panel
Using the Mac OS X Font panel, accessible from any application, you can change a 
font’s typeface, size, and other options. Use the Format Bar for quick font formatting, 
but use the Font panel for advanced font formatting.

To open the Font panel:
m Click Fonts in the toolbar.

For more detailed information about using the Font panel and changing the look of 
text, see “Using the Font Panel to Format Text” on page 123.

The Warnings Window
When you import a document into Numbers, or export a Numbers spreadsheet to 
another format, some elements might not transfer as expected. The Document 
Warnings window lists any problems encountered. 

If problems are encountered, you’ll see a message enabling you to review the warnings. 
If you choose not to review them, you can see the Warnings window at any time by 
choosing View > Show Document Warnings.

If you see a warning about a missing font, you can select the warning and click Replace 
Font to choose a replacement font.

You can copy one or more warnings by selecting them in the Document Warnings 
window and choosing Edit > Copy. You can then paste the copied text into an email 
message, text file, or some other window.
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Keyboard Shortcuts and Shortcut Menus
You can use the keyboard to perform many of the Numbers menu commands and 
tasks. To see a comprehensive list of keyboard shortcuts, open Numbers and choose 
Help > Keyboard Shortcuts.

Many objects also have shortcut menus with commands you can use on the object. 
Shortcut menus are especially useful for working with tables and charts.

To open a shortcut menu:
m Press the Control key while you click an object.
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2 Working with a Numbers 
Spreadsheet 

This chapter describes how to manage Numbers 
spreadsheets.

You can create a Numbers spreadsheet by opening Numbers and choosing a template. 
You can also import a document created in another application, such as Microsoft Excel 
or AppleWorks 6. This chapter tells you how to create new Numbers spreadsheets, as 
well as how to open existing spreadsheets and save spreadsheets. 

This chapter also provides instructions for using sheets and managing the layout of 
printed or PDF versions of Numbers sheets.

Creating, Opening, and Importing Spreadsheets
When you create a new Numbers spreadsheet, you pick a template to provide its initial 
format and content. You can also create a new Numbers spreadsheet by importing a 
document created in another application, such as Microsoft Excel or AppleWorks.

Creating a New Spreadsheet
To create a new Numbers spreadsheet, you pick the template that provides appropriate 
formatting and content characteristics.

Start with the Blank template to build your spreadsheet from scratch. Or select one of 
the many other templates to create a budget, plan a party, and more without having to 
do all the design work. Many templates include predefined tables, charts, and sample 
data to give you a head start with your spreadsheet.
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To create a new spreadsheet:
1 Open Numbers by clicking its icon in the Dock or by double-clicking its icon in the 

Finder.

If Numbers is open, choose File > New from Template Chooser.

2 In the Template Chooser window, select a template category in the left column to 
display related templates, and then select the template that best matches the 
spreadsheet you want to create. If you want to begin in a spreadsheet without any 
predefined content, select Blank. 

3 Click Choose. A new spreadsheet opens on your screen.

To open a Blank template and bypass the Template Chooser window when you create a 
new spreadsheet, select “Don’t show this dialog again.” To make the Template Chooser 
reappear when you create a new spreadsheet, choose Numbers > Preferences, click 
General, and then select “For New Documents:  Show Template Chooser dialog.” Or you 
can choose File > New from Template Chooser. 

You can also have Numbers automatically open a particular template every time you 
open Numbers or create a new spreadsheet. Choose Numbers > Preferences, click 
General, select “For New Documents:  Use template:  template name,” and then click 
Choose. Select a template name, and then click Choose.
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Importing a Document
You can create a new Numbers spreadsheet by importing a document created in 
Microsoft Excel or AppleWorks 6. Numbers can also import files in comma-separated 
value (CSV) format, tab-delimited format, and Open Financial Exchange (OFX) format.

From AppleWorks, you can only import spreadsheets.

Here are ways to import a document:
m Drag the document to the Numbers application icon. A new Numbers spreadsheet 

opens, and the contents of the imported document are displayed.

m Choose File > Open, select the document, and then click Open.

m You can import Address Book data to quickly create tables that contain names, phone 
numbers, addresses, and other information for your contacts. See “Using Address Book 
Fields” on page 179 for instructions.

If you can’t import a document, try opening the document in another application and 
saving it in a format Numbers can read, or copy and paste the contents into an existing 
Numbers spreadsheet.

You can also export Numbers spreadsheets to Microsoft Excel, PDF, and CSV files. See 
“Exporting to Other Document Formats” on page 186 for details.

Opening an Existing Spreadsheet
There are several ways to open a spreadsheet that was created using Numbers.

Here are ways to open a spreadsheet:
m To open a spreadsheet when you’re working in Numbers, choose File > Open, select 

the spreadsheet, and then click Open.

m To open a spreadsheet you’ve worked with recently, choose File > Open Recent and 
choose the spreadsheet from the submenu.

m To open a Numbers spreadsheet from the Finder, double-click the spreadsheet icon or 
drag it to the Numbers application icon.

If you see a message that a font or file is missing, you can still use the spreadsheet. 
Numbers lets you choose fonts to substitute for missing fonts. Or you can add missing 
fonts by quitting Numbers and adding the fonts to your Fonts folder (for more 
information, see Mac Help). To make missing movies or sound files reappear, add them 
to the spreadsheet again.
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Saving Spreadsheets
When you create a Numbers spreadsheet, all of the graphics are saved with the 
spreadsheet so they display correctly if the spreadsheet is opened on another 
computer. Fonts, however, are not included as part of the spreadsheet. If you transfer a 
Numbers spreadsheet to another computer, make sure the fonts used in the 
spreadsheet have been installed in the Fonts folder of that computer. 

You can choose whether to save audio and movie files with a Numbers spreadsheet. If 
you don’t save them with the spreadsheet, you need to transfer them separately to 
view the spreadsheet on another computer.

Saving a Spreadsheet
It’s a good idea to save your spreadsheet often as you work. After you’ve saved it for 
the first time, you can press Command-S to re-save it using the same settings. 

To save a spreadsheet for the first time:
1 Choose File > Save, or press Command-S.

2 In the Save As field, type a name for the spreadsheet.

3 If your file directory isn’t visible in the Where pop-up menu, click the disclosure triangle 
to the right of the Save As field.

4 Choose where you want to save the spreadsheet.

5 If you or someone else will open the spreadsheet on another computer, click Advanced 
Options and set up options that determine what’s copied into your spreadsheet.

Copy audio and movies into document:  Selecting this checkbox saves audio and video 
files with the spreadsheet, so the files play if the spreadsheet is opened on another 
computer. You might want to deselect this checkbox so that the file size is smaller, but 
media files won’t play on another computer unless you transfer them as well.

Copy template images into document:  If you don’t select this option and you open the 
spreadsheet on a computer that doesn’t have Numbers installed, the spreadsheet 
might look different. 

6 Click Save.

You can generally save Numbers spreadsheets only to computers and servers that use 
Mac OS X. Numbers is not compatible with Mac OS 9 computers and Windows servers 
running Services for Macintosh. If you must use a Windows computer, try using AFP 
server software available for Windows to do so.

If you plan to share the spreadsheet with others who don’t have Numbers installed on 
their computers, you can export it for use in another application. To learn about 
exporting your spreadsheet in other file formats, see “Exporting to Other Document 
Formats” on page 186.
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You can also send a spreadsheet to iWeb. For more information, see “Sending a 
Spreadsheet to iWeb” on page 187.

Undoing Changes 
If you don’t want to save changes you made to your spreadsheet since opening it or 
last saving it, you can undo them. 

Here are ways to undo changes:
m To undo your most recent change, choose Edit > Undo.

m To undo multiple changes, choose Edit > Undo multiple times. You can undo any 
changes you made since opening the spreadsheet or reverting to the last saved 
version.

m To restore changes you’ve undone using Edit > Undo, choose Edit > Redo one or more 
times.

m To undo all changes you made since the last time you saved your spreadsheet, choose 
File > “Revert to Saved” and then click Revert.

Automatically Saving a Backup Version of a Spreadsheet
Each time you save a spreadsheet, you can save a copy without the changes you made 
since last saving it. That way, if you change your mind about edits you have made, you 
can go back to (revert to) the backup version of the spreadsheet. 

Here are ways to create and use a backup version:
m To automatically save a backup version of a spreadsheet, choose Numbers > 

Preferences, click General, and then select “Back up previous version when saving.” 

The next time you save your spreadsheet, a backup version is created in the same 
location, with “Backup of” preceding the filename. Only one version—the last saved 
version—is backed up. Every time you save the spreadsheet, the old backup file is 
replaced with the new backup file.

m To revert to the last saved version after making unsaved changes, choose File > Revert 
to Saved. The changes in your open spreadsheet are undone.

Saving a Spreadsheet as a Template
When you save a spreadsheet as a template, it appears in the Template Chooser. 

To save a spreadsheet as a template:
m Choose File > Save as Template.

See “Designing a Template” on page 188 for additional details.
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Saving Search Terms for a Spreadsheet
You can store such information as author name and keywords in Numbers 
spreadsheets, and then use Spotlight to locate spreadsheets containing that 
information.

To store information about a spreadsheet:
1 Click Inspector in the toolbar, and then click the Document Inspector button.

2 In the Spotlight fields, enter or change information.

To search for spreadsheets containing Spotlight information, click the Spotlight icon at 
the top right of the menu bar, and then type what you want to search for.

Saving a Copy of a Spreadsheet
If you want to make a copy of your spreadsheet (for example, to create a backup copy 
or multiple versions), you can save it using a different name or location. (You can also 
automate saving a backup version, as “Automatically Saving a Backup Version of a 
Spreadsheet” describes.) 

To save a copy of a spreadsheet:
m Choose File > Save As and specify a name and location.

The spreadsheet with the new name remains open. To work with the previous version, 
choose File > Open Recent and choose the previous version from the submenu.

Closing a Spreadsheet Without Quitting Numbers
When you have finished working with a spreadsheet, you can close it without quitting 
Numbers.

To close the active spreadsheet and keep the application open:
m Choose File > Close or click the close button in the upper-left corner of the Numbers 

window.
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If you’ve made changes since you last saved the spreadsheet, Numbers prompts you to 
save.

Using Sheets to Organize a Spreadsheet
Like chapters in a book, sheets let you divide information into manageable groups. For 
example, you might want to place charts in the same sheet as the tables whose data 
they display. Or you may want to place all the tables on one sheet and all the charts on 
another sheet. You might want to use one sheet for keeping track of business contacts 
and other sheets for friends and relatives. 

The sheets in a spreadsheet and the tables and charts on each sheet are represented in 
the Sheets pane, located to the left of the canvas above the styles pane.

Only tables and charts are listed for any sheet, even if you have text, images, and other 
objects in your spreadsheet.

The order of a sheet’s tables and charts in the Sheets pane may not match their order 
in the spreadsheet, as “Reorganizing Sheets and Their Contents” on page 38 describes.

Viewing Sheets
The Sheets pane on the left of the Numbers window lists all the sheets in your 
spreadsheet and the tables and charts in each sheet. 

Here are ways to see a sheet’s tables and charts:
m To show or hide all a sheet’s tables and charts in the Sheets pane, click the triangle to 

the left of the sheet in the pane. 

m To display the contents of a sheet, click the sheet in the Sheets pane. 

When you’re working on a table or chart in the spreadsheet, the table or chart is 
highlighted in the Sheets pane.

Click to show or hide a
sheet’s tables and charts.

Click to add a new sheet.
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Adding and Deleting Sheets
There are several ways to add and delete sheets. 

Here are ways to create and remove sheets:
m To add a new sheet, click the Sheet button in the toolbar. You can also choose Insert > 

Sheet. 

A new sheet containing a predefined table is added at the bottom of the Sheets pane. 
You can move the sheet by dragging it to a new location in the Sheets pane.

m To add a sheet that’s a copy of a sheet in the spreadsheet, select the sheet to copy, 
choose Edit > Copy, select the sheet after which you want the copy located, and 
choose Edit > Paste.

m To delete a sheet and its contents, select it in the Sheets pane and press the Delete key.

When you add a sheet, Numbers assigns it a default name, but you can change the 
name, as “Changing Sheet Names” on page 39 describes.

Reorganizing Sheets and Their Contents
In the Sheets pane, you can move sheets around and reorder their tables and charts. 
You can also move tables and charts from one sheet to another. 

Reordering tables and charts in the Sheets pane doesn’t affect their location in a sheet. 
In a sheet in the Sheets pane, for example, you may want to place charts next to the 
tables they’re derived from, or list tables in the order in which you want to work on 
them. But in the sheet itself, you may want to present these objects in a different order 
(for example, when you lay out your spreadsheet for printing).

Here are ways to reorganize sheets in the Sheets pane:
m To move a sheet, select it and drag it to a new location in the pane. Sheets shift to 

make room for your insertion as you drag.

You can also select multiple sheets and move them as a group.

m To copy (or cut) and paste sheets, select the sheets, choose Edit > Cut or Edit > Copy, 
select the sheet after which you want to place the sheets you’re moving, and choose 
Edit > Paste.

m To move one or more tables and charts associated with a sheet, select them and drag 
them to a new location in the same sheet or to a different sheet.

You can also use cut/paste or copy/paste actions to move tables and charts in the 
pane.

To move an object within a sheet in the spreadsheet, select it and drag it to a different 
location, or use cut/paste or copy/paste actions. To place objects on specific pages, 
follow the instructions in “Dividing a Sheet into Pages” on page 39.
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Changing Sheet Names
A name distinguishes each sheet in the Sheets pane. The sheet name is assigned by 
default when you add a sheet, but you can change it to a more descriptive name. 

Here are ways to change a sheet’s name:
m In the Sheets pane, double-click the name and edit it.

m In the Sheet Inspector, edit the name in the Name field.

You can also change the names of a sheet’s tables and charts. See “Naming Tables” on 
page 49 and “Using a Chart Title” on page 107 for instructions.

Dividing a Sheet into Pages
Using Print View, you can view a sheet as individual pages, moving and resizing objects 
until you achieve the layout you want for a printed or PDF version of the sheet. You can 
also add headers, footers, page numbers, and more. 

Click to show or 
hide Print View.

Slide to shrink or enlarge all the 
sheet’s objects.

Footer area Header area 

Click to choose a page
zoom level that lets you

see more or fewer pages.

Click to view pages in
portrait (vertical)

orientation.

Click to view pages in
landscape (horizontal)

orientation.
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Here are ways to show or hide Print View:
m Click View in the toolbar, and then choose Show Print View or Hide Print View.

m Choose File > Show Print View, View > Show Print View, File > Hide Print View, or 
View > Hide Print View.

m Click the page icon next to the page zoom control in the lower left of the canvas.

When you use Print View, the zoom level you choose from the pop-up menu in the 
lower left determines how many pages you can view in the window at one time.

You set up page attributes, such as page orientation and margins, separately for each 
sheet, using the Sheet Inspector.

Setting a Spreadsheet’s Page Size
Before working with Print View, set the size of the pages to reflect the size of the paper 
you’ll be using.

To set the page size:
1 Click Inspector in the toolbar, and then click the Document Inspector button.

2 Choose a page size from the Paper Size pop-up menu.

Type a name for the sheet.

Shrink or enlarge all the sheet’s objects.

Set the page orientation and 
pagination order.

Set page margins.

Specify the sheet’s starting page number.
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Using Headers and Footers
You can have the same text appear on multiple pages in a sheet. Recurring information 
that appears at the top of the page is called a header; at the bottom it’s called a footer.

You can put your own text in a header or footer, and you can use formatted text fields. 
Formatted text fields allow you to insert text that is automatically updated. For 
example, inserting the date field shows the current date whenever you open the 
spreadsheet. Similarly, page number fields keep track of page numbers as you add or 
delete pages. 

To define the contents of a header or footer:
1 Click View in the toolbar and choose Show Print View.

2 To see header and footer areas, hover the pointer near the top or bottom of a page. 

You can also click View in the toolbar and choose Show Layout.

3 To add text to a header or footer, place the insertion point in the header or footer and 
insert text.

4 To add page numbers or other changeable values, see the instructions in “Inserting 
Page Numbers and Other Changeable Values” on page 145.

Arranging Objects on a Page
Resize objects, move them around on a page or between pages, and break up long 
tables across pages when you’re viewing a sheet in Print View. 

To show Print View, click View in the toolbar and choose Show Print View.

Here are ways to lay out objects on a selected sheet’s pages:
m To adjust the size of all the objects in the sheet in order to change the number of 

pages they occupy, use the Content Scale controls in the Sheet Inspector.

You can also drag the Content Scale slider at the bottom left of the canvas to resize 
everything on a sheet.

m To resize individual objects, select them and drag their selection handles or change the 
Size field values in the Metrics Inspector.

To resize a table, see “Resizing a Table” on page 48. To resize a chart, see “Resizing a 
Chart” on page 107. To resize other objects, see “Resizing Objects” on page 154.

m Header rows and header columns can be set to appear on each page if a table spans 
more than one page by selecting “Repeat header cells on each page” in the Table 
Inspector. You can also choose Table > Repeat Header Rows or Table > Repeat Header 
Columns.
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To avoid showing header rows or columns when a table spans pages, deselect “Repeat 
header cells on each page” in the Table Inspector or choose Table > Don’t Repeat 
Header Rows or Table > Don’t Repeat Header Columns. 

m Move objects from page to page by dragging them or by cutting and pasting them.

Setting Page Orientation
You can lay out pages in a sheet in a vertical orientation (portrait) or a horizontal 
orientation (landscape).

To set a sheet’s page orientation:
1 Click View in the toolbar and choose Show Print View.

2 Click Inspector in the toolbar, click the Sheet Inspector button, and click the 
appropriate page orientation button in the Page Layout area of the pane.

You can also click a page orientation button at the bottom left of the canvas.

Setting Pagination Order
You can order pages viewed in page mode from left to right or from top to bottom 
when you print them or create a PDF. 

To set pagination order:
m Click Inspector in the toolbar, click the Sheet Inspector button, and then click the top-

to-bottom or left-to-right button in the Page Layout area of the pane. 

Numbering Pages
You can display page numbers in a page’s header or footer. 

To number a sheet’s pages:
1 Select the sheet.

2 Click View in the toolbar and choose Show Print View.

3 Click View in the toolbar and choose Show Layout so you can see the headers and 
footers.

You can also see the headers and footers by hovering the pointer over the top or 
bottom of a page.

4 Click into the first header or footer to add a page number, following the instructions in 
“Inserting Page Numbers and Other Changeable Values” on page 145.

5 Click Inspector in the toolbar, click the Sheet Inspector button, and then specify the 
starting page number.

To continue page numbers from the previously selected sheet, select “Continue from 
previous sheet.”

To start the sheet’s page numbers at a particular number, use the Start At field.
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Setting Page Margins
In Print View, every sheet’s page has margins (blank space between the sheet’s edge 
and the edges of the paper). These margins are indicated onscreen by light gray lines, 
visible when you use layout view.

To set the page margins for a sheet:
1 Select the sheet in the Sheets pane.

2 Click View in the toolbar and choose Show Print View and Show Layout.

3 Click Inspector in the toolbar, and then click the Sheet Inspector button.

4 To set the distance between the layout margins and the left, right, top, and bottom 
sides of a page, enter values in the Left, Right, Top, and Bottom fields.

5 To set the distance between a header or a footer and the top or bottom edge of the 
page, enter values in the Header and Footer fields.

To print the spreadsheet using the largest printing area possible with any printer you 
use, select Use Printer Margins. Any margin settings specified in the Sheet Inspector will 
be ignored when you print.
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3 Using Tables

This chapter tells you how to add and format tables and 
cell values.

Several other chapters provide instructions that focus on particular aspects of tables:

Â To learn about using styles to format tables, see Chapter 4, “Working with Table 
Styles,” on page 79.

Â To learn about using formulas in table cells, see Chapter 5, “Using Formulas and 
Functions in Tables,” on page 83.

Â To learn about displaying table values in charts, see Chapter 6, “Using Charts,” on 
page 98.

About Tables
Tables help you organize, analyze, and present data. 

Numbers provides a wide variety of options for building and formatting tables and 
handling values of different types. You can also use special operations such as sorting 
and conditional formatting (a technique for automating the monitoring of cell values).

Â “Working with Tables” on page 45 teaches you how to add tables, resize them, move 
them, name them, and more.

Â “Selecting Tables and Their Components” on page 51 describes how to select tables, 
columns, and other table elements in order to work with them. 

Â “Working with Content in Table Cells” on page 54 tells you how to add text, numbers, 
dates, images, and other content to table cells as well as how to monitor cell values 
automatically.

Â “Working with Rows and Columns” on page 69 covers adding rows and columns, 
resizing them, and more.

Â “Working with Table Cells” on page 74 contains instructions for splitting cells, 
merging them, and copying and moving them as well as formatting cell borders.

Â “Reorganizing Tables” on page 77 describes how to sort and filter rows.  
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Working with Tables
Use a variety of techniques to create tables and manage their characteristics, size, and 
location. 

Adding a Table
While most templates contain one or more predefined tables, you can add additional 
tables to your Numbers spreadsheet. 

Here are ways to add a table:
m Click Tables in the toolbar and choose a predefined table from the pop-up menu.

You can add your own predefined tables to the pop-up menu. See “Defining Reusable 
Tables” on page 49 for instructions.

m Choose Insert > Table > table.

m To create a new table based on one cell or several adjacent cells in an existing table, 
select the cell or cells, click and hold the selection, and then drag the selection to the 
sheet. To retain values in the selected cells in the original table, hold down the Option 
key while dragging. 

See “Selecting Tables and Their Components” on page 51 to learn about cell selection 
techniques.

m To create a new table based on an entire row or column in an existing table, click the 
reference tab associated with the row or column, click and hold the reference tab, drag 
the row or column to the sheet, and then release the tab. To retain values in the 
column or row in the original table, hold down the Option key while dragging. 

Using Table Tools
You can format a table and its columns, rows, cells, and cell values using various 
Numbers tools.

Here are ways to manage table characteristics:
m Select a table and use the Format Bar to quickly format the table.

Arrange text in table cells.

Format cell borders.

Add background
color to a cell.

Format cell values.
Manage headers

and footer.

Show or hide a table’s name.

Format text in table cells.
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m Use the Table Inspector to access table-specific controls, such as fields for precisely 
controlling column width and row height. To open the Table Inspector, click Inspector 
in the toolbar, and click the Table Inspector button.

m Use the Cells Inspector to format cell values. For example, you can display a currency 
symbol in cells containing monetary values. 

You can also set up conditional formatting. For example, you can make a cell red when 
its value exceeds a particular number. 

To open the Cells Inspector, click Inspector in the toolbar, and click the Cells Inspector 
button.

Add a table name. 

Add and remove a header row, a header 
column, and a footer row.
Merge or split selected cells.

Adjust the size of rows and columns.

Set the style, width, and color of 
cell borders.

Add color or an image to a cell.

Change the behavior of the Return and 
Tab keys. See “Selecting a Table Cell” 
on page 51 for details.

Control the visibility of header 
cells in multipage tables.

Set up the format for displaying 
values in selected cells.

Select to wrap text in selected cells.

Use color to highlight cells 
whose values obey your rules.
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m Use table styles to adjust the appearance of tables quickly and consistently. See “Using 
Table Styles” on page 79 for more information.

m Use the reference tabs and handles that appear when you select a table cell to quickly 
reorganize a table, select all the cells in a row or column, add or delete rows and 
columns, and more. 

You also use reference tabs when you work with formulas (“Using Cell References” on 
page 91 tells you how).

m Use the Graphics Inspector to create special visual effects, such as shadows. To open 
the Graphics Inspector, click Inspector in the toolbar and then click the Graphics 
Inspector button.

m Access a shortcut menu by selecting a table or cell(s) and then holding down the 
Control key as you click again. 

You can also use the pop-up menus on the column and row reference tabs.

m Use the Formula Editor and Formula Bar to add and edit formulas. See “Using the 
Formula Editor” on page 88 and “Using the Formula Bar” on page 90 for details.

m Use the Formula Browser to add and edit functions. See “Using Functions” on page 96 
for details.

Drag the Table handle 
to move the table.

Reference tab letters can be 
used to refer to columns.

Click the Column handle to 
add one column. Drag it to 
add multiple columns.

Reference tab numbers can 
be used to refer to rows.

Drag the Column and Row 
handle down to add rows. Drag it 
to the right to add columns.

Click the Row handle to add one row. 
Drag it to add more rows.
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Resizing a Table
You can make a table larger or smaller by dragging one of its selection handles or by 
using the Metrics Inspector. You can also change the size of a table by resizing its 
columns and rows.

Here are ways to resize a table that’s selected:
m Drag one of the square selection handles that appear when a table is selected. See 

“Selecting a Table” on page 51 for instructions.

To maintain a table's proportions, hold down the Shift key as you drag to resize the 
table.

To resize from the table’s center, hold down the Option key as you drag.

To resize a table in one direction, drag a side handle instead of a corner handle.

m To resize by specifying exact dimensions, select a table or table cell, click Inspector in 
the toolbar, and then click the Metrics Inspector button. Using the Metrics Inspector, 
you can specify a new width and height, and you can change the table’s distance from 
the margins by using the Position fields. 

m If a table spans more than one page, you must use the Metrics Inspector to resize the 
table. To resize by adjusting the dimensions of rows and columns, see “Resizing Table 
Rows and Columns” on page 73.

Moving Tables
You can move a table by dragging it, or you can relocate a table using the Metrics 
Inspector.

Here are ways to move a table:
m If the table isn’t selected, click and hold at the edge of the table, and drag the table.

If the table is selected, drag the table while holding down the Table handle in the 
upper left.

m To constrain the movement to horizontal, vertical, or 45 degrees, hold down the Shift 
key as you drag.
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m To move a table more precisely, click any cell, click Inspector in the toolbar, click the 
Metrics Inspector button, and then use the Position fields to relocate the table.

m To copy a table and move the copy, hold down the Option key, click and hold at the 
edge of an unselected table, and drag.

Naming Tables
Every Numbers table has a name that’s displayed in the Sheets pane and can optionally 
be displayed above the table. The default table name (Table 1, Table 2, and so forth) 
can be changed, hidden, and formatted, but not moved or resized. 

Here are ways to work with table names:
m To change the name, edit it in the Sheets pane or in the Table Inspector’s Name field.

On any sheet, two tables can’t have the same name.

m To show the table name on the sheet, select Name in the Format Bar or the Table 
Inspector.

To hide the table name on the sheet, deselect Name.

m To format the name, make sure the table isn’t selected, select Name in the Format Bar 
or the Table Inspector, click the table name to select the name region on the sheet, and 
use the Format Bar, Font panel, or Text pane of the Text Inspector. 

m To increase the distance between the table name and the table body, select Name in 
the Table Inspector, click the name on the canvas, and then use the Text Inspector to 
modify the After Paragraph value.

Defining Reusable Tables
You can add your own tables to the menu of predefined tables that appears when you 
click Tables in the toolbar or choose Insert > Table. Reusable tables have the table style 
and geometry of your choice and can contain content (header text, formulas, and so 
forth). 

To define a reusable table:
1 Select a table.

2 Define a table style for the table. The table style determines the formatting of borders, 
background, and text in the table’s cells.

One way to define the table style is by following the instructions in “Modifying a Table’s 
Style” on page 80. 

Alternatively, you can use the default table style that’s in effect when you add a table to 
the spreadsheet that’s based on the reusable table. (See “Using the Default Table Style” 
on page 81 to learn about the default table style.) Step 7 tells you how to use this 
option.
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3 Define the table’s geometry.

To resize the table, see “Resizing a Table” on page 48 and “Resizing Table Rows and 
Columns” on page 73.

To define columns and rows, see “Working with Rows and Columns” on page 69.

To split or merge, and resize table cells, see “Splitting Table Cells” on page 74 or 
“Merging Table Cells” on page 74.

4 Add and format any content you want to reuse. See “Working with Content in Table 
Cells” on page 54 for instructions. Any formulas you add should refer only to cells in the 
table you’re defining.

5 Choose Format > Advanced > Capture Table.

6 Type a name for the table.

7 Select “Use the default style from the document” if you want the table to be styled 
using the default table style in effect when the table is added to the spreadsheet. 
Otherwise the table style used is the one you defined in step 2.

8 Click OK.

A copy of your reusable table can now be added to the current spreadsheet by 
choosing it from the menu of predefined tables that appears when you click Tables in 
the toolbar or choose Insert > Table.

To rearrange, rename, or delete tables on the menu, choose Format > Advanced > 
Manage Tables. Double-click a name to change the name of a predefined table. Select a 
table and click the up or down arrow buttons to move it up or down in the list of 
tables. Click the Delete (–) button to remove a table. Click Done when you’ve finished. 

The table and menu changes apply only to the current spreadsheet. If you want your 
reusable tables and menu changes to be available in other spreadsheets, save the 
spreadsheet as a template, using the instructions in “Designing a Template” on 
page 188.

Copying Tables Among iWork Applications
You can copy a table from one iWork application to another. 

The table retains its appearance, data, and other attributes, but some Numbers features 
aren’t supported in the other applications:

Â Rows or columns that are hidden in Numbers aren’t visible in the other applications 
until you select the table and choose Format > Table > Unhide All Rows or Unhide All 
Columns.

Â Comments added to Numbers table cells aren’t copied.
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To copy a table from one iWork application to another:
1 Select the table you want to copy, as “Selecting a Table” on page 51 describes.

2 Choose Edit > Copy.

3 In the other application, set an insertion point for the copied table, and then choose 
Edit > Paste.

Selecting Tables and Their Components
You select tables, rows, columns, table cells, and table cell borders before you work 
with them.

Selecting a Table
When you select a table, selection handles appear on the edges of the table. 

Here are ways to select a table:
m If the table cell isn’t selected, move your pointer to the edge of the table. When the 

pointer changes to include a black cross, and you can click to select the table.

m If a table cell or border segment is selected, click the Table handle in the upper left to 
select the table. You can also press Command-Return.

Selecting a Table Cell
When you select a cell, the border of the selected cell is highlighted. 

Selecting a cell also displays reference tabs along the top and sides of the table.

To select a single table cell:
1 Move the pointer over the cell. The pointer changes into a white cross.

2 Click the cell. 
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When a cell is selected, use the Tab, Return, and arrow keys to move the selection to an 
adjacent cell. Selecting “Return key moves to next cell” under Table Options in the Table 
Inspector sometimes changes the effect of the Return and Tab keys. 

Selecting a Group of Table Cells
You can select adjacent or nonadjacent cells. 

Here are ways to select a group of cells:
m To select adjacent table cells, select a single cell, and then hold down the Shift key as 

you select adjacent cells.

You can also click a cell, hold it, and then drag through a range of cells.

m To select nonadjacent table cells, hold down the Command key as you select cells. Use 
Command-click to deselect a cell in the group.

Selecting a Row or Column
Select rows and columns using their reference tabs. 

To select
If “Return key” option is 
selected

If “Return key” option isn’t 
selected

The next cell to the right Press Tab. 
If you press Tab when the last 
cell in a column is selected, a 
new column is added.
If you add or change data in the 
last column, press Tab twice to 
add a new column.

Press Tab. 
If you press Tab in the last 
column, the first cell in the next 
row is selected. 
If you press Tab in the last cell of 
the table, a new row is added.

The previous cell Press Shift-Tab. Press Shift-Tab.
If you press Shift-Tab in the first 
cell, the last cell is selected.

The next cell down Press Down Arrow or Return.
If you’ve been using the Tab key 
to navigate between cells, 
pressing Return selects the next 
cell down from the cell in which 
you started tabbing.
If you press Return when the last 
cell in a row is selected, a new 
row is added.
If you add or change data in the 
last cell, press Return twice to 
add a new row.

Press Down Arrow.

The next cell up Press Up Arrow or Shift-Return. Press Up Arrow.
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To select an entire row or column:
1 Select any table cell so that the reference tabs are showing.

2 To select a column, click its reference tab (above the column).

To select a row, click its reference tab (to the left of the row).

Selecting Table Cell Borders
Select cell border segments when you want to format them. A single border segment is 
one side of a cell. A long border segment includes all adjacent single border segments. 

Here are ways to select border segments:
m To select border segments in a single step, select a table, row, column, or cell.

Click the Borders button in the Format Bar, and choose an option from the pop-up 
menu.

A single (horizontal) 
border segment

A long (vertical) border 
segment

A long (horizontal) 
border segment

A single (vertical) border 
segment

Borders button
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You can also use the Cell Borders buttons in the Table Inspector to select a border 
segment.

m To select and deselect segments by clicking them in a table, use border selection 
mode. Choose Allow Border Selection from the Borders pop-up menu in the Format Bar 
or choose Table > Allow Border Selection, and then select the table you want to work 
with.

The pointer changes shape when it’s over a horizontal or vertical segment. The pointer 
appears to straddle the segment.

To select a long segment, click a cell’s horizontal or vertical border. To change the 
selection to a single segment, click it again.

Click to go back and forth between single-segment and long-segment selection.

To add a single or long segment to the selection, hold down the Shift or Command key 
while clicking.

To deselect a selected single segment, click it while holding down the Shift or 
Command key.

To stop using border selection mode, choose Disallow Border Selection from the 
Borders pop-up menu in the Format Bar or choose Table > Disallow Border Selection.

Working with Content in Table Cells
You can add text, numbers, and dates to table cells, and you can format values in cells. 
You can also add images and background color, as well as checkboxes, sliders, and 
other controls. And you can use autofilling to use the content in one or more cells to 
automatically add values to adjacent cells. 

Adding and Editing Cell Values
You can add, change, and delete the content in cells. 

Here are ways to add and edit values:
m If the cell is empty, select it and then type a value. “Selecting a Table Cell” on page 51 

tells you how to select cells.

m To replace specific content already in the cell, select the cell and then select what you 
want to replace by double-clicking; hold down the Shift key and select more content if 
you want to replace more. Type to replace the selected content.

The pointer looks like this when 
it’s over a horizontal segment.

The pointer looks like this when 
it’s over a vertical segment.
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m To replace everything in the cell, select the cell and then begin typing. 

If “Return key moves to next cell” isn’t selected in the Table Inspector, you can also 
select the cell and then press Return or Enter, which selects everything in the cell, and 
then start typing.

m To insert content within existing content, select the cell, click to set the insertion point, 
and begin typing.

m To undo changes made to a table cell since selecting the cell, press Esc.

m To delete the content of table cells, rows, or columns, select the cells, rows, or columns 
and then press the Delete key or choose Edit > Delete.

To delete the contents, background fill, and any style settings, choose Edit > Clear All. 
The default style is applied to the selection.

m To copy, paste, and move cell values, see the instructions in “Copying and Moving Cells” 
on page 76.

m To add formulas and functions to cells, see the instructions in “Using Formulas” on 
page 83 and “Using Functions” on page 96.

Working with Text in Cells
You can control the format and alignment of text in table cells, and you can use find/
replace and spell-checking features. 

When you type text into a cell, Numbers displays text that might be used to complete 
the cell content based on similar text elsewhere in the table. You can use the suggested 
text if it’s appropriate, or you can keep typing to override suggestions.

Here are techniques for working with text in table cells:
m To insert a line break, press Control-Return. 

m To insert a paragraph break, If “Return key moves to next cell” under Table Options in 
the Table Inspector isn’t selected, press Return. Otherwise, press Option-Return.

m To insert a tab in a table, press Option-Tab.

m To adjust text alignment, use the alignment buttons in the Format Bar.

The Text Inspector gives you additional text formatting options (click Inspector in the 
toolbar and click the Text Inspector button). 

Align text to the left, center, right; justify text; or 
align text to the left and numbers to the right.

Align text to the top, middle, 
or bottom of cells.
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m To control font attributes, use the text formatting buttons in the Format Bar.

You can also use the Font panel (click Fonts in the toolbar).

m To check spelling, follow the instructions in “Checking for Spelling Mistakes” on 
page 146.

m To find and optionally replace text in cells, follow the instructions in “Finding and 
Replacing Text” on page 148.

m To avoid having Numbers interpret what you type as a number, use the text format. 
See “Using the Text Format” on page 64 for details.

Note:  Text strings are ignored in functions that use values to perform calculations.

Working with Numbers in Cells
Some table operations, such as formulas and functions that perform mathematical 
operations, depend on cells containing numeric values. 

Here are techniques for working with numbers in table cells:
m In a numeric cell use only numbers (0 through 9) or one of the following characters: +, 

–, (, ), /, $, %, a period, E, or e.

m You can type some characters (such as %) into a cell, or you can use a cell format, as 
“Formatting Cell Values” on page 58 describes.

m To specify a negative number, precede it with the minus sign (–).

When you put a number in a table cell that’s too large to display, Numbers converts the 
number:

Â When a decimal number doesn’t fit in a cell, the number is rounded. For example, 
1.77777777777777777777 becomes 1.77777777777778.

Â When a whole number doesn’t fit in a cell, the number is displayed using scientific 
notation. For example, 77777777777777777777 becomes 7.7.77778E+19.
Scientific notation displays numbers using an exponent raised by the power of 10. 
The exponent is displayed following the E.

If the converted number still doesn’t fit, it’s clipped. See “Displaying Content Too Large 
for Its Cell” on page 57 for suggestions.

Instructions for using formulas and functions in table cells are in “Using Formulas” on 
page 83 and “Using Functions” on page 96.

Choose a font.

Choose a typeface.

Choose the font size.

Choose the text color.
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Working with Dates in Cells
Unless a cell has a date and time format associated with it, when you type a value that 
can be interpreted as a date or time value, Numbers might reformat the value. 

For example, if you type 1/22/45 or 1-22-45 into a table cell with the Automatic cell 
format and leave the cell, the value changes to Jan 22, 2045. If you enter a 2-digit year 
value greater than or equal to 50, Numbers adds the prefix “19”; otherwise Numbers 
adds the prefix “20.”

And if you type 12 pm, the value becomes 12:00 PM. You can edit the value if you need 
to change it.

See “Using the Date and Time Format” on page 62 to learn about the date and time 
format.

Displaying Content Too Large for Its Cell
When a cell is too small to display all its content, here is what happens: 
Â If the content is a number or date, a clipping indicator appears.

Â For other types of values, no clipping indicator appears. You can only see content 
that’s visible within the boundaries of its cell.

You can enlarge a cell so that more content is visible, and you can let numbers and 
dates spill into adjacent blank cells.

Here are ways to handle content too large for a cell:
m To let a numeric or date value in a cell spill into adjacent cells, deselect Wrap Text in Cell 

in the Cells Inspector. 

If the adjacent cells are empty, they’ll display spilled content. But if they contain data, 
content that doesn’t fit isn’t displayed and the clipping indicator appears.

To cause content to wrap instead of spill, select Wrap in the Format Bar or Wrap Text in 
the Cells Inspector.

m If cell values aren’t visible because columns are too narrow, you can use the Fit button 
next to the Column Width controls in the Table Inspector to make values visible. Select 
a cell, column(s), or the table, and then click the Fit button.

You can also resize a column by dragging the right border of its reference tab to the 
right, or by using the Column Width controls in the Table Inspector. 

The clipping indicator
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m If cell values aren’t visible because rows are too narrow, you can use the Fit button next 
to the Row Height controls in the Table Inspector to make values visible. Select a cell, 
row(s), or the table, and then click the Fit button. As row content is added or removed, 
row height automatically changes to match content height.

You can also resize a row by clicking the bottom border of its reference tab and 
dragging down, or by using the Row Height controls in the Table Inspector.

m You can also resize columns and rows to accommodate content by using the reference 
tabs.

To increase the height of a row to accommodate its largest content, double-click the 
lower border of the row’s reference tab. Column width does not adjust automatically 
when you make content changes.

To increase the width of a column to accommodate its largest content, double-click the 
right border of the column’s reference tab.

Formatting Cell Values
You can apply a format to a cell so its value is displayed in a particular way. For 
example, you can format cells that hold monetary values so that a currency symbol 
(such as $, £, or ¥) appears in front of numbers in them. Or you can format cells to 
contain controls, such as checkboxes and sliders, which are used to add or change cell 
values. 

When you use a cell format, you are only setting the display characteristics of a value. 
When the value is used in formulas, the actual value is used, not the formatted value. 
The only exception is when there are too many numbers following a decimal point, in 
which case the number is rounded.

You define cell formats using the Format Bar or the Cell Format pop-up menu in the 
Cells Inspector. To display cell values exactly as you type them, choose Automatic; 
otherwise, choose the item that provides the specific formatting you want to use.

Here are ways to work with cell formats:
m To add a value to an empty cell that has a format, select the cell and enter a value. The 

format is applied when you leave the cell.

m To apply a cell format to an existing value, select one or more cells that contain values. 
Use the Cells Inspector or the Format Bar to define a cell format. The format you define 
is applied to values in the selected cell(s). 

m To display a value exactly as you type it, select the cell, and then choose Automatic 
from the Format Bar or the Cell Format pop-up menu of the Cells Inspector. The value 
remains, but its formatting is removed.

m If you delete a value from a cell with a format, the format isn’t deleted. To delete the 
format, choose Automatic from the Format Bar or the Cell Format pop-up menu of the 
Cells Inspector.
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m After you define a cell format, you can associate the format with multiple cells by using 
autofilling. See “Autofilling Table Cells” on page 68 for instructions.

Using the Number Format
Use the number format to format the display of a number’s decimal places, thousands 
separator, and negative values. 

To define a number format that displays two decimal places, no thousands separator, 
and negative numbers with the negative symbol, select one or more cells and then 
click the Number Format button in the Format Bar. Use the Decrease Decimal Places 
and Increase Decimal Places buttons located nearby to change the number of decimal 
places.

For more control over the number format, use the Cells Inspector.

To define a number format using the Cells Inspector:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, and then click the Cells Inspector button.

3 Choose Number from the Cell Format pop-up menu.

4 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

5 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.

6 To specify whether to use a thousands separator, select Thousands Separator.

Number Format 
button

Increase Decimal 
Places button

Decrease Decimal 
Places button
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Using the Currency Format
Use the currency format to format the display of monetary values. 

To define a currency format that displays two decimal places, a thousands separator, 
and negative numbers with the negative symbol, select one or more cells and then 
click the Currency Format button in the Format Bar. Use the Decrease Decimal Places 
and Increase Decimal Places buttons located nearby to change the number of decimal 
places.

For more control over the currency format, use the Cells Inspector.

To define a currency format using the Cells Inspector:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, and then click the Cells Inspector button.

3 Choose Currency from the Cell Format pop-up menu.

4 To specify a currency symbol, choose an option from the Symbol pop-up menu.

You can maximize the number of options in the Symbol pop-up menu by choosing 
Numbers > Preferences and selecting “Show complete list of currencies in Cell 
Inspector” in the General pane.

5 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

6 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.

7 To specify whether to use a thousands separator, select Thousands Separator.

8 To display the currency symbol at the edge of the cell, select Accounting Style.

Currency Format 
button

Increase Decimal 
Places button

Decrease Decimal 
Places button
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Using the Percentage Format
Use the percentage format to display numeric values followed by the % symbol. 

If the value is used in a formula, its decimal number version is used. For example, a 
value that displays as 3% is used as 0.03 in a formula.

If you type 3% in a cell formatted using the automatic format and then apply the 
percentage format to the cell, the value displayed is 3%. However, if you type 3 in a cell 
formatted using the automatic format and then apply the percentage format to the 
cell, the value displayed is 300%.

To define a percentage format that displays two decimal places, a thousands separator, 
and negative numbers with the negative symbol, select one or more cells and then 
click the Percentage Format button in the Format Bar. Use the Decrease Decimal Places 
and Increase Decimal Places buttons located nearby to change the number of decimal 
places.

For more control over the percentage format, use the Cells Inspector.

To define a percentage format using the Cells Inspector:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, and then click the Cells Inspector button.

3 Choose Percentage from the Cell Format pop-up menu.

4 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

Percentage 
Format button

Increase Decimal 
Places button

Decrease Decimal 
Places button
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5 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.

6 To specify whether to use a thousands separator, select Thousands Separator.

If a cell you’re formatting already contains a value, the value is assumed to be a decimal 
value, and it’s converted into a percentage. For example, 3 becomes 300%. 

Using the Date and Time Format
Use the date and time format to display date and/or time values. 

To define a date and time format, click the More Cell Formats button in the Format Bar, 
select one or more cells, choose Date & Time from the pop-up menu, and then choose 
an option from the submenu.

For more control over the date and time format, use the Cells Inspector.

To define a date and time format using the Cells Inspector:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, and then click the Cells Inspector button.

3 Choose Date and Time from the Cell Format pop-up menu.

4 To specify how you want a date formatted, choose a format from the Date pop-up 
menu.

5 To specify how you want a time value formatted, choose a format from the Time pop-
up menu.

More Cell 
Formats button

Choose More to apply the template’s 
default date/time format and open 
the Cells Inspector.
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Using the Fraction Format
Use the fraction format to control the display of values smaller than 1. For example, 27.5 
displays as 27 1/2 when the format is Halves and as 27 4/8 when the format is Eighths.

To define a fractions format, select one or more cells, choose Fractions from the More 
Cell Formats pop-up menu in the Format Bar, and choose a format from the submenu.

You can also use the Cells Inspector.

To define a fraction format for selected cells using the Cells Inspector:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, and then click the Cells Inspector button.

3 Choose Fraction from the Cell Format pop-up menu.

4 Choose a display format from the Accuracy pop-up menu.

Using the Scientific Format
Use the scientific format to display numbers using an exponent raised by the power of 
10. The exponent is displayed following an “E.” For example, the value 5.00 in scientific 
format displays as 5.00E0. And the value 12345 displays as 1.2345E4. 

More Cell 
Formats button
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To define a scientific format that displays two decimal places, select one or more cells 
and then choose Scientific from the More Cell Formats button in the Format Bar.

For more control over the number of decimal places, use the Cells Inspector.

To define a scientific format for one or more cells using the Cells Inspector:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, and then click the Cells Inspector button.

3 Choose Scientific from the Cell Format pop-up menu.

4 Use the Decimals field to specify the number of decimal places to display.

Using the Text Format
Use the text format when you want all of a cell’s content to be treated as text, even 
when it’s a number.

Here are ways to define a text format for one or more selected cells:
m Click the More Cell Formats button in the Format Bar and then choose Text.

m Click Inspector in the toolbar, click the Cells Inspector button, and choose Text from the 
Cell Format pop-up menu.

More Cell Formats button

More Cell Formats button
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Using a Checkbox and Other Control Formats
You can add a checkbox, slider, stepper, or pop-up menu to a cell: 
Â A checkbox is for cells whose value indicates one of two states, such as on or off, or 

yes or no.
Â A slider is useful for quickly making large changes to numbers so you can see the 

effects of the changes on other cells in the table or on a chart.
Â A stepper lets you increase or decrease numbers in specific increments.
Â A pop-up menu lets you predefine the values a cell can contain.

When a cell is formatted to use a checkbox or pop-up menu, you can add or change a 
cell’s content only by using the control. Cells that use a slider or stepper let you type a 
value into the cell or use the control; when you click off the cell, the value changes 
depending on the settings you make when you define the slider and stepper.

Here are ways to add controls to cells:
m To add a checkbox, select the cell or cells. 

Click the Checkbox button in the Format Bar. Unchecked checkboxes are added to 
selected cells.

You can also click Inspector in the toolbar, and then click the Cells Inspector button. 
Choose Checkbox from the Cell Format pop-up menu, and then select the initial State 
(Checked or Unchecked).

Checkbox button
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m To add a slider, click the More Cell Formats button in the Format Bar and then choose 
Slider in the pop-up menu. A slider with default settings, visible in the Cells Inspector, is 
created. 

You can also open the Cells Inspector and choose Slider from the Cell Format pop-up 
menu.

In the Cells Inspector, change default settings if desired:

Minimum and Maximum:  Indicates the lowest and highest cell values.

Increment:  Indicates the amount by which the cell value increases or decreases when 
you move the slider (or arrow keys) one increment.

Position:  Lets you locate the slider to the right of the cell or at the bottom of the cell.

Display as:  Applies a number, currency, percentage, or scientific format to the cell 
values.

Decimals:  Indicates how many decimal places to display.

m To add a pop-up menu, click the More Cell Formats button in the Format Bar and then 
choose Pop-up Menu in the pop-up menu to create a pop-up menu with default 
settings.

You can also open the Cells Inspector and choose Pop-up Menu from the Cell Format 
pop-up menu.

In the Cells Inspector, edit the placeholder entries in the list by selecting them and 
typing values of your choice.

To add an item to the list, click + and type the item. If you specify a number, it’s treated 
as a number, not as text.

To remove an item, select it and click –.

More Cell Formats button
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m To add a stepper, click the More Cell Formats button in the Format Bar and then choose 
Stepper in the pop-up menu to create a stepper with default settings.

You can also open the Cells Inspector and choose Stepper from the Cell Format pop-up 
menu.

In the Cells Inspector, change the default settings if desired:

Minimum and Maximum:  Indicates the lowest and highest cell values.

Increment: Indicates the amount by which the cell value increases or decreases when 
you click the stepper control (or an arrow key) once.

Display as:  Applies a number, currency, percentage, or scientific format to the cell 
values.

Decimals:  Indicates how many decimal places to display.

Monitoring Cell Values
You can have Numbers change a cell’s fill and/or text color when its content exhibits a 
particular condition. 

You define simple rules that test for the condition and then change fill and/or text color 
if the condition is met. For example, you can define a rule that turns a cell blue if it 
contains a particular value and another rule that turns the cell green if it contains 
another value. 

You can apply a rule to a single cell or to a range of cells. Rules applied to multiple cells 
trigger color changes when any of the cells meet the rule’s condition. 

To define rules:
1 Select one or more cells. 

2 Click Inspector in the toolbar and click the Cells Inspector button.

3 Select Conditional Format, and then click “Show rules.”

4 Select “Highlight cells using the following rules.”

5 Choose a condition from the “Choose a rule” pop-up menu. 

The conditions in the top section of the menu apply tests to numeric values. 
Conditions for text values are in the middle section of the list, and date conditions are 
at the bottom.

Note that the Between condition requires that you specify two numbers. The condition 
is met if either of the numbers or any number in between them appears in the cell(s).

6 Provide additional information as required to fully specify a particular condition to test 
for.

7 Select Fill Color and/or Text Color and click the color wells (see “Using the Colors 
Window” on page 161) to define the background and value colors to apply to the cell if 
the condition is met.
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8 To add another rule, click + and repeat steps 5 through 7.

If more than one rule is defined for a cell and the cell’s content satisfies the conditions 
of multiple rules, the colors associated with the higher rule in the list of rules are 
applied to the cell.

To stop using a rule, click its – button to delete the rule, or deselect Fill Color and Text 
Color to disable the rule. To stop using a list of rules, deselect “Highlight cells using the 
following rules.”

Adding Images or Color to Cells
You can add graphics or color to individual table cells or to an entire table. 

To add an image or color to a table cell:
1 Select the cell.

2 Click Inspector in the toolbar, and then click the Table Inspector.

3 To add an image, choose Image Fill from the Cell Background pop-up menu. See 
“Filling an Object with an Image” on page 162 for instructions.

4 To add background color, choose Color Fill or Gradient Fill from the Cell Background 
pop-up menu. See “Filling an Object with Color” on page 160 for more information.

Autofilling Table Cells
Autofilling lets you use the content in one or more cells to automatically add values to 
adjacent cells. 

Here are ways to autofill table cells:
m To paste the content and fill of a cell into adjacent cells, select the cell and then drag 

the Fill handle in its lower right corner over the cells into which you want to paste. 

Any data, cell format, formula, or fill associated with the selected cell is pasted, but 
comments aren’t pasted. If any target cell contains data, autofilling overwrites that data 
with the value you’re repeating. 

m To paste the content and fill of a cell into one or more cells in the same row or column, 
select two or more adjacent cells. Choose Insert > Fill Right to assign selected cells the 
value that resides in the leftmost selected cell(s). Choose Insert > Fill Down to assign 
selected cells the value that resides in the topmost selected cell(s).

Any data, cell format, formula, or fill associated with the selected cell is pasted, but 
comments aren’t pasted. If any target cell contains data, autofilling overwrites that data 
with the value you’re repeating.

m You can also add values to cells based on value patterns. For example, if a cell contains 
a day of the week or a month, you can select the cell and then drag to the right or 
down to add the next day of the week or month to the adjacent cell.
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To create new values based on numeric patterns, select two or more cells before 
dragging. For example, if two selected cells contain 1 and 2, the values 3 and 4 are 
added when you drag through the adjacent two cells. And if two selected cells contain 
1 and 4, the values 7 and 10 are added when you drag through the adjacent two cells 
(values are incremented by 3).

Autofilling doesn’t set up an ongoing relationship among cells in the group. After 
autofilling, you can change the cells independently of each other. 

Working with Rows and Columns
You can quickly add or remove rows and columns, create a header row or column or a 
footer row, and more. 

When you insert, remove, resize, hide, or show rows or columns in a table, other objects 
on the sheet may be moved to avoid overlapping or to maintain relative object 
positions. To prevent automatic movement of objects, choose Numbers > Preferences 
and in the General pane deselect “Automatically move objects when tables resize.”

Adding Rows
You can add rows within a table or at the end of a table. 

If the table contains a footer row, rows added at the bottom of the table are added 
above the footer row. If the table has filtering criteria associated with it, you can’t add 
new rows until you stop filtering rows; see “Filtering Rows” on page 78 for instructions.

Here are ways to add rows:
m To add a single row, hover your pointer over a row’s reference tab to see its menu 

arrow, and then click the arrow and choose Add Row Above or Add Row Below from 
the pop-up menu. You can also choose these commands from the Table menu.

m To add a row at the end of the table, press Return when the last cell is selected. Press 
Return twice if you’ve just added or changed the cell value.

If “Return key moves to next cell” under Table Options in the Table Inspector isn’t 
selected, press Tab instead from the last cell in the row.

m To add one or more rows at the end of the table, you can use the Row handle in the 
lower left, visible when a cell is selected.

To add a row at the end of the table, click the Row handle once. 

To add multiple rows at the end of the table, drag the Row handle or the Column and 
Row handle (in the lower right) down.

To add rows and columns at the same time, drag the Column and Row handle 
diagonally.

m You can split cells into two equal rows. “Splitting Table Cells” on page 74 tells you how.
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Adding Columns
You can add new columns to a table. 

Here are ways to add columns:
m To add a single column, hover your pointer over a column’s reference tab to see its 

menu arrow. Click the arrow and then choose Add Column Before or Add Column After 
from the pop-up menu. You can also choose these commands from the Table menu.

m You can use the Tab key to add a column to the right side of the table when “Return 
key moves to next cell” under Table Options in the Table Inspector is selected. 

Press Tab once when the last cell is selected. Press Tab twice if you’ve just added or 
changed the cell value.

m To add one or more columns to the right side of a table, you can use the Column 
handle in the upper right, visible when a cell is selected.

To add a column to the right side of the table, click the Column handle once. 

To add multiple columns to the right side of the table, drag the Column handle or the 
Column and Row handle (in the lower right) to the right.

To add rows and columns at the same time, drag the Column and Row handle 
diagonally.

m You can split cells into two equal columns. “Splitting Table Cells” on page 74 tells you 
how.

Rearranging Rows and Columns
Using a row’s or column’s reference tab, you can move or copy the row or column to a 
different location in the same table or another table. 

Here are ways to rearrange rows and columns:
m To move a column or row to a different location in the same table or a different table, 

click the column or row reference tab, and then click and drag the reference tab. 
Release the tab when the bold line highlights where you want to insert the column or 
row.

m To insert a copy of a row or column elsewhere in the table or in another table, click the 
reference tab, click again, and hold down the Option key and the reference tab while 
you drag the column or row to the desired location.

You can also copy or move a single cell or a group of adjacent cells within or between 
tables. See “Copying and Moving Cells” for instructions.

Deleting Table Rows and Columns
There are several techniques available for deleting one or more rows or columns of a 
table. 
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Here are ways to delete rows or columns:
m Select the row(s) or column(s) or a cell in them, and then choose Table > Delete Row or 

Table > Delete Column.

m To delete a single row or column, hover your pointer over the row or column reference 
tab to see the menu arrow, and then choose Delete Row or Delete Column from the 
pop-up menu.

m To delete several adjacent rows or columns, select the rows or columns and choose 
Delete Selected Rows or Delete Selected Columns from the pop-up menu of a selected 
row’s or column’s reference tab.

m Drag the Row handle in the lower left or the Column handle in the lower right up to 
delete empty rows.

To remove rows with content, hold down the Option key while dragging.

m Drag the Column handle in the upper right inward to delete empty columns.

To remove columns with content, hold down the Option key while dragging.

Using a Table Header Row or Column
Use header rows and columns to label the data in rows and columns. Header rows and 
columns are formatted so that they stand out from the other rows and columns. A 
header row consists of the topmost cell in each column. A header column consists of 
the leftmost cell in each row. 

Header rows and header columns appear at the beginning of the table and on each 
page if the table spans more than one page. If a table spans multiple pages, editing the 
text or changing the look of the header row or column in one place changes it 
consistently throughout the table.

You can’t split a header row or footer row into multiple rows or header columns into 
multiple columns.

Here are ways to add or delete a header row or column:
m Select the table and then click the appropriate Header button in the Format Bar.

If the table has no header row or column, one is added. If the table has a header row or 
column, it’s deleted.

m Select the table. Click Inspector in the toolbar, click the Table Inspector button, and 
then click the appropriate Headers & Footer button.

Add a header column.

Add a header row.
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m Select the table and then choose one of the following from the Table menu: Add 
Header Row, Delete Header Row, Add Header Column, or Delete Header Column.

m If a table spans pages and you want to repeat headers at the top of each page, select 
“Repeat header cells on each page” in the Table Options area of the Table Inspector. 

The cells in a header row or header column are referred to as header cells. Header cells 
play an important role in making formulas in table cells easier to read and create. See 
“Using Cell References” on page 91 and “Applying a Formula Once to Cells in a Column 
or Row” on page 93 to learn more.

Using a Footer Row
Use a footer row when you want to draw attention to the last row in a table. A footer 
row can contain the same content as any other row, but its formatting makes it visually 
prominent. 

Here are ways to add or delete a footer row:
m Select the table and then click the Footer button in the Format Bar.

If the table has no footer row, one is added. If the table has a footer row, it’s deleted.

m Select the table. Click Inspector in the toolbar, click the Table Inspector button, and 
then click the appropriate Headers & Footer button.

If the table has no footer row, one is added. If the table has a footer row, it’s deleted.

m Select the table and then choose Add Footer Row or Delete Footer Row from the Table 
menu. 

Hiding Rows and Columns
Hide specific rows or columns when you want to avoid showing or using them but 
don’t want to delete them. While a row or column is hidden, it can’t be reformatted, 
merged, split, or otherwise manipulated. However, any formula that uses a hidden cell 
isn’t affected, and sorting takes hidden values into account. 

To hide a row or column:
m Choose Hide Row or Hide Column from a row or column reference tab’s pop-up menu.

To show hidden rows and columns, choose Table > Unhide All Rows or Table > Unhide 
All Columns.

Rows or columns that are hidden in Numbers tables aren’t visible when the tables are 
copied into other iWork ’08 applications. To see the hidden rows, select the table and 
choose Format > Table > Unhide All Rows or Unhide All Columns.

Add a footer row.
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Resizing Table Rows and Columns
Resize all rows and columns so they’re equal in size, or resize only specific rows and 
columns in a table. 

Here are ways to resize rows and columns:
m To make all rows the same size, select the table and choose Table > Distribute Rows 

Evenly. 

m To make all columns the same size, choose Table > Distribute Columns Evenly.

m To resize a single row, drag the bottom border of the row’s reference tab up or down. 

You can also select the row and use the Row Height field in the Table Inspector.

m To resize one column, drag the right border of the column’s reference tab right or left. 

You can also select a cell and use the Column Width field in the Table Inspector.

m To make several rows the same size, select one or more cells in the rows and choose 
Table > Distribute Rows Evenly. The rows don’t have to be adjacent.

You can also drag the bottom border of the reference tab of one of the rows up or 
down or use the Row Height field in the Table Inspector.

m To make several columns the same size, select one or more cells in the columns and 
choose Table > Distribute Columns Evenly. The columns don’t have to be adjacent.

You can also drag the right border of the reference tab of one of the columns left or 
right or use the Column Width field in the Table Inspector.

m To shrink a row or column in order to remove unused space when cell values don’t fill 
their cells, select a cell and click one of the Fit buttons in the Table Inspector. 

If cell content is clipped as a result of resizing, see “Displaying Content Too Large for Its 
Cell” on page 57 for options.

Alternating Row Colors
Use a different color background for alternate rows to give a table a banded effect. 

To alternate row colors:
1 Select the table.

2 Click Inspector in the toolbar and then click the Table Inspector button.

3 Select Alternating Row Color.

4 Click the adjacent color well to open the Colors Window, and then choose a color for 
the alternate rows. See “Using the Colors Window” on page 161 for instructions.

5 To change the fill attributes of the other rows, use the Cell Background controls in the 
Table Inspector. See “Filling an Object with Color” on page 160 for instructions.
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Working with Table Cells
You can split and merge table cells, resize them, format them, hide them, add 
comments, and more.

Merging Table Cells
Merging table cells combines adjacent cells into one, eliminating the borders so that 
they behave as a single cell. 

To merge table cells:
1 Select a group of two or more adjacent table cells. The group of cells you choose must 

form a rectangle, and they must be all body cells or all header cells.

2 Choose Table > Merge Cells.

You can also click the Merge button in the Table Inspector.

Merging horizontally contiguous cells containing only text or a mixture of text, 
numbers, formatted values, and formulas joins the content from all the original cells as 
text separated by tabs. Merging vertically contiguous cells containing only text or a 
mixture of text, numbers, formatted values, and formulas joins the content from all the 
cells as text separated by carriage returns. 

When you merge column cells, the cell background takes on the image or color that 
was in the topmost cell. When you merge row cells, the cell background takes on the 
image or color that was in the leftmost cell.

When a cell containing text, a number, a formula, or a cell format is merged with an 
empty cell, the new cell retains the content of the non-empty cell.

When a cell containing a number format is merged with an empty cell, the new cell 
retains the number format. 

Splitting Table Cells
Splitting cells divides each selected cell into two equal parts, horizontally (rows) or 
vertically (columns). Both of the new cells have identical background colors or images. 
Any text that was in the original cell remains in the topmost or leftmost cell. 

To split cells horizontally or vertically:
1 Select a table cell or cells. To split an entire row or column, select all the cells in the row 

or column. 

2 To split cells into rows, choose Table > Split into Rows. To split cells into columns, 
choose Table > Split into Columns.

You can also click the Split button in the Table Inspector.

3 To create smaller and smaller units, repeat steps 1 and 2 for the split cells.

To rejoin split cells, merge them as “Merging Table Cells” on page 74 describes.
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Formatting Table Cell Borders
You can change the line thickness and color of table cell borders. Or you can hide the 
cell border of any cell. 

To format table cell borders:
1 Select the cell border segments you want to format. See “Selecting Table Cell Borders” 

on page 53 for instructions.

2 Use the controls in the Format Bar or in the Table Inspector.

Stroke pop-up menu:  Lets you choose a stroke style. Choose None to hide borders.

Line thickness:  Controls the thickness of the stroke.

Color well:  Lets you choose a stroke color. 

When you click the color well in the Format Bar, a color matrix appears. Select a color 
by clicking it in the matrix, or click Show Colors to open the Colors window for 
additional color options.

When you click the color well in the Table Inspector, the Colors window opens. “Using 
the Colors Window” on page 161 provides instructions for using this tool.

Click to choose a stroke style.

Click to choose a line 
thickness.

Click to choose a 
stroke color.
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Copying and Moving Cells
You can use commands or dragging to move or copy table cells.

Here are ways to copy and move cells:
m To move cells within a table or to another table, select a cell or several adjacent cells, 

and then drag the selection by its border until the destination cells are selected. Any 
values in the destination cells are replaced.

m  To copy cells within or between tables, drag selected cells while holding down the 
Option key. Any values in the destination cells are replaced.

You can also copy cells by selecting them, choosing Edit > Copy, selecting destination 
cells, and then choosing Edit > Paste.

You can also paste a cell’s content into multiple cells, which don’t have to be adjacent to 
the copied cell or to each other. After copying a cell, select the destination cells and 
choose Edit > Paste. The cell’s contents are copied to all the destination cells, in the 
same or another table, replacing any existing content.

m To insert copied cells without overwriting destination cells, choose Insert > Copied 
Columns or Insert > Copied Rows after selecting destination cells.

Copied Columns:  Adds new columns to accommodate copied cells.

Copied Rows:  Adds new rows to accommodate copied cells.

When a cell value is replaced, so is any comment associated with the cell.

See “Rearranging Rows and Columns” on page 70 to learn how to copy and move rows 
and columns using the reference tabs.

See “Copying or Moving Formulas with Cell References” on page 92 to learn about 
techniques for duplicating or moving a cell that contains a formula.

Adding Comments
Use comments to record information about table cells. 

Here are ways to work with comments:
m To add a comment to a cell, select the cell and click Comment in the toolbar. Type in 

the comment box.

m To move a comment, drag it.

m To hide all comments, choose View > Hide Comments. A yellow marker appears in any 
table cell containing a comment.

To hide one comment, click the “–” in the upper right of the comment box.

m To show a hidden comment, click its marker.

To show all comments, choose View >Show Comments.
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m To delete a comment, click the X in the upper right of the comment box.

m To include comments when you print a sheet, show any comments you want to print, 
and then choose File > Print Sheet. 

Reorganizing Tables 
You can use sorting and filtering to reorganize the data in tables.
Â Sorting:  Lets you arrange values in some or all the cells in a column in ascending or 

descending order. Rows containing cells being sorted are reordered.
Â Filtering:  Lets you hide rows in a table that don’t contain the values you specify.

Sorting Table Cells
You can arrange values in some or all the cells in a column in ascending or descending 
order. Rows containing cells being sorted are reordered. Header cells aren’t sorted. 

Sorting takes into account values in hidden rows and hidden columns.

Here are ways to sort:
m To sort all the cells in a column, choose Sort Ascending or Sort Descending from the 

pop-up menu for the column’s reference tab.

You can also click Sort & Filter in the toolbar or choose Show Sort & Filter Panel from a 
reference tab’s pop-up menu. Use the pop-up menus under Sort to choose a column 
and sort order.

m To re-sort values after changing them, click Refresh in the Sort & Filter panel.

m To sort only some of the cells in a column, select the cells, open the Sort & Filter panel, 
choose a sort order, and then click Refresh.

m To sort all the cells in a column and then re-sort the results using another column’s 
values, open the Sort & Filter panel, choose a column and sort order in the Sort pop-up 
menus, click +, choose another column and sort order, and then click Refresh.

To use additional sort criteria, click + to define each one you want to add.
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The following table describes how different types of data are sorted in ascending or 
descending order. 

Filtering Rows
You can hide rows in a table that don’t contain the values you specify. 

To specify criteria for rows you want to show:
1 Select the table.

2 Click Sort & Filter in the toolbar or choose Show Sort & Filter Panel from a reference 
tab’s pop-up menu.

3 Select “Show rows that match the following,” and then choose the column whose 
values you want to use to create filter criteria.

4 Use the remaining controls to define the column value for rows you want to show.

5 To use additional filter criteria, click + to define each one you want to add.

If you choose “is in the top n values” or “is in the bottom n values,” all values matching 
the top or bottom n will be shown, which may be more than n.

Note:  You can’t add any new rows to the table until you stop filtering rows. To stop 
filtering rows in the table, deselect “Show rows that match the following.”

When you sort table cells, values in hidden rows are taken into account.

Type of data Ascending order Descending order

Text aA–zZ Zz–Aa

Dates Year (earliest first), then Month 
(January first), then day (1–31)

Year (most current first), then 
month (December first), then 
day (31–1)

Numbers –2, –1, 0, 1, and so on 1, 0, –1, –2, and so on

Cells containing only text, mixed 
with cells containing only 
numbers

–2, –1, 0, 1, and so on, then aA–
zZ

Zz–Aa, then 1, 0, –1, –2, and so 
on

Cells containing a mixture of 
text and numbers

Values starting with numbers 
first (1z, 1Z, a1, A1)

Values starting with text first (A1, 
a1, 1A, 1z)

Empty cells At the bottom At the bottom

Boolean (TRUE, FALSE) Below text and above an empty 
cell

Above text
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4 Working with Table Styles

This chapter explains how to use table styles to quickly and 
consistently manage the appearance of tables.

You can use different visual characteristics to distinguish different tables in your 
Numbers spreadsheet. For example, you can format a table containing inputs and 
assumptions using a blue background and matching borders, but format a table 
containing calculation results using a gray background and matching borders.

The simplest way to change the appearance of a table is to apply a table style to it. 
Table styles also ensure that tables are consistently formatted. 

The Numbers templates include a variety of table styles that are ready to use. You can 
also modify the template styles or create your own styles.

Using Table Styles
A table style is predefined formatting that you can apply to a table with the click of a 
mouse.

A table style predefines the following attributes:

Â The table background (color or image) and its opacity
Â The stroke, color, and opacity of the outside border of body cells, and the outside 

borders of the header row, header column, and footer row.
Â The background (color or image and opacity) and the text attributes of table cells, 

including header and footer cells
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Applying Table Styles
After applying a table style to a table, you can change any of the formatting defined by 
the style. Such a change is called an override. If you later assign a different style to the 
table, you can keep or remove any overrides you created. 

Here are ways to apply a table style:
m To replace a table’s existing style and remove any overrides, click the arrow to the right 

of the style you want to apply and then choose Clear and Apply Style.

You can also choose Format > Reapply Table Style.

m To replace a table’s existing style but keep any overrides, select the table and then click 
the name of a style in the Styles pane at the left of the window. You can also select a 
table, click the arrow to the right of the style you want to apply, and then choose Apply 
Style.

You can also drag a style name from the Styles pane to a table. The table doesn’t need 
to be selected in this case.

m To replace the style of all tables in a sheet but keep any overrides, drag a style name 
from the Styles pane to a sheet icon in the Sheets pane.

Modifying a Table’s Style
Most of the time you change the appearance of a table by applying a different table 
style. You can also redefine attributes of the style assigned to the table or use a copy/
paste style operation to modify a table’s style. 

Modifying Table Style Attributes
You can change a table’s appearance by modifying the attributes of the table’s style. 

Here are ways to modify table style attributes:
m To change the background color of a table, header cells, or body cells, select the table 

or cells and click the Fill well in the Format Bar. 

You can use the Cell Background controls in the Table Inspector to make more 
extensive changes to the selection. “Filling an Object with an Image” on page 162 and 
“Filling an Object with Color” on page 160 provide instructions for these controls.

To change the opacity of the background, use the Opacity controls in the Graphic 
Inspector. See “Adjusting Opacity” on page 158 for instructions.

m To change the stroke and color of table cell borders, follow the instructions in 
“Formatting Table Cell Borders” on page 75.
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m To format text in one or more cells, select the cells.

To modify the color, alignment, and spacing of text within a cell, use the Format Bar or 
the Text Inspector (click Inspector in the toolbar and click the Text Inspector button). 

To modify font attributes, use the Font panel (click Fonts in the toolbar).

If you want to use the changes you make to redefine the table style for the whole 
spreadsheet, click the arrow to the right of the style and then choose Redefine Style 
from Table. All tables in the spreadsheet that use the style are updated to reflect the 
changes you made, but overrides are maintained.

You can also create a new style using the changes you’ve made by clicking the arrow to 
the right of the style and then choosing Create New Style.

Copying and Pasting Table Styles
You can change a table’s appearance by copying and pasting table and table cell styles. 

Here are ways to copy and paste table styles:
m To copy a cell’s style, select the cell and choose Format > Copy Style.

m To apply a copied cell style to other cells, select the cells and choose Format > Paste 
Style.

m To paste a copied table using the spreadsheet’s default table style, choose Edit > Paste 
and Match Style.

Using the Default Table Style
Every spreadsheet has a table style that’s designated as the default table style. It’s the 
table style that’s applied to new tables. 

To change the default table style:
m Click the arrow to the right of the style you want to use as the default table style and 

then choose Set as Default Style for New Tables.

To use the default table style for a reusable table you define, follow the instructions in 
“Defining Reusable Tables” on page 49.



82 Chapter 4    Working with Table Styles 

 

Creating New Table Styles
You can create a new table style by reformatting a table and saving the formatting as a 
table style. 

To create a new table style:
1 Use the instructions in “Modifying Table Style Attributes” on page 80 to achieve the 

visual effects you want.

2 Select the table, click the arrow to the right of any style in the Styles pane, and then 
choose Create New Style.

3 Type a unique name for your new table style, and click OK.

The new table style now appears in the Styles pane and can be applied to any table in 
your spreadsheet.

To make a new table style available in other spreadsheets, create a template from the 
spreadsheet. See “Designing a Template” on page 188 for details.

Renaming a Table Style
You can change the name of a table style. 

To rename a table style:
1 Click the arrow to the right of the style in the Styles pane.

2 Choose Rename Style.

3 Edit the style name, making sure it’s unique in the spreadsheet.

4 Press Return.

Deleting a Table Style
When you delete a table style that’s used in a spreadsheet, you need to choose a 
different style to replace it.

To delete a style:
1 Click the arrow to the right of the style in the Styles pane.

2 Choose Delete Style.

3 If the style you want to delete is being used in the current spreadsheet, choose a style 
to replace it and then click OK.
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5 Using Formulas and Functions in 
Tables

This chapter tells you how to perform calculations in table 
cells using formulas and functions.

See Chapter 3, “Using Tables,” on page 44 for instructions for adding and formatting 
tables and data in them and Chapter 12, “Dictionary of Functions,” on page 193 for 
complete information about individual functions.

Using Formulas
A formula is a mathematical expression that uses operations to derive a value. You can 
add a formula to a table cell to display a value derived from values in other table cells. 

For example, you can add a formula to the bottom cell of a column that adds the 
numbers in all the other cells in the column. If any of the column values change, the 
total in the bottom cell changes automatically.

Formulas derive values by using operators and functions. 

Â Operators perform operations such as addition (+) and multiplication (*).
Here’s a formula that adds values: =A2 + 16. A2 is called a cell reference; A2 refers to 
the second cell in the first column. The value 16 is called a constant, because it’s a 
specific value that uses no operators or functions.

The value in cell A2 is added to the value 16, and the result is displayed in the cell 
that contains the formula.

Formulas always begin with an equal sign (=). For simplicity, the examples 
throughout the Numbers documentation omit the equal sign.

Â Functions are predefined, named operations, such as SUM and AVERAGE.
To use a function, you name the function and, in parentheses following the name, 
you provide the arguments it needs. Arguments specify the data the function will use 
when it performs its operations.
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Here’s a formula that adds the values in nine cells of the first column: SUM(A2:A10). 
There is one argument, A2:A10. The colon means the function should use the values 
in cells A2 through A10.

You don’t need to understand more than this to use formulas in tables. Templates (such 
as the Loan Comparison and Mortgage templates) and formula editing tools (such as 
the Formula Editor and the Formula Bar) make basic formulas easy to use.

A Tour of Using Formulas
Reviewing the formulas built into the Invoice template is a good introduction to 
Numbers formulas.

1 Create a new Numbers spreadsheet using the Invoice template. 

Open Numbers, in the Template Chooser click Business, select Invoice, and then click 
Choose.

The Invoice table in this template uses formulas to derive the values in the Cost 
column.

2 Double-click the topmost dollar value in the Cost column. The Formula Editor opens, 
revealing that the value is derived using a formula.

Header row names (Quantity and Unit Price) are used in the formula to refer to two 
cells. Using header text to refer to cells makes formulas more readable. But you can also 
use the letters and numbers in the reference tabs to refer to cells, as you’ll see in step 4.

A formula in each cell of 
the Cost column updates 
Cost values when values 
in other cells change.

The formula multiplies the value in 
the Quantity cell and the value in the 
Unit Price cell in the row. 

The asterisk symbol (*) is 
the multiplication operator.
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3 If the value in a Quantity cell or in a Unit Price cell changes, the formula associated with 
the Cost cell updates the value it displays. To see this happen, type a value in the 
Quantity and Unit Price cells in any row and notice how the value in the adjacent Cost 
cell is updated.

4 Double-click the cell in the Cost column that’s in the row containing Subtotal. In this 
formula, two cells are identified by using reference tab identifiers. When you use 
reference tab identifiers to identify a cell in a formula, you first specify the column letter 
and then you specify the row number.

The notation used to refer to a cell in a formula is called a cell reference. As you’ve seen, 
a cell reference can be created by using header text or by using a reference tab 
identifier.

5 The Subtotal formula uses a function named SUM.

A function is a predefined operation. The SUM function adds the values you specify 
within the parentheses. In this example, the SUM function adds the values in cells D2 
through D9. The colon (:) is a shorthand way of referring to a range of cells.

Columns are referenced 
alphabetically.

Rows are referenced 
numerically.

Cell D2 is the cell at the 
intersection of column D 
and row 2.
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6 The values in the Cost column are formatted for display using a cell format (currency). 

To see the cell format settings, close the Formula Editor by clicking outside the table. 
Then click the table, click any cell in the Cost column, click Inspector in the toolbar, and 
then click the Cells Inspector button.

See “Formatting Cell Values” on page 58 for more information about options for 
displaying values in table cells.

Performing Instant Calculations
In the lower left of the Numbers window, you can view the results of common 
calculations using values in two or more selected table cells.

To perform instant calculations:
1 Select two or more cells in a table. They don’t have to be adjacent.

The results of calculations using the values in those cells are instantly displayed in the 
lower left.

sum:  The sum of numeric values in selected cells.

avg:  The average of numeric values in selected cells.

min:  The smallest numeric value in selected cells.

max:  The largest numeric value in selected cells

count:  The number of numeric values and date/time values in selected cells.

Empty cells and cells that contain other kinds of values aren’t used in the calculations.

A $ is displayed in front
of numbers in the cells.

Numbers are displayed 
using two decimal places.

The results in the lower left 
are based on values in these 
two selected cells.
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2 To perform another set of instant calculations, select different cells.

If you find a particular calculation very useful and you want to incorporate it into a 
table, you can add it as a formula to an empty table cell. Simply drag sum, avg, or one 
of the other items in the lower left to an empty cell. The cell doesn’t have to be in the 
same table as the cells used in the calculations.

Adding a Quick Formula
An easy way to perform a basic calculation using values in a range of adjacent table 
cells is to add a quick formula using the pop-up menu visible when you click Function 
in the toolbar.

You can also choose Insert > Function and use the submenu that appears.

Here are operations you can perform using the pop-up menu or submenu:
m Choose one of the following to perform calculations using values in the selected cells. 

Empty cells and cells containing values that aren’t mentioned are ignored.

Sum:  Totals numeric values in the cells.

Average:  Calculates the arithmetic mean of numeric values in the cells.

Minimum:  Determines which numeric value in the cells is the smallest.

Maximum:  Determines which numeric value in the cells is the largest.

Count:  Determines how many of the values in the cells are numeric or date/time 
values.

Product:  Multiplies all the numeric values in the cells.

m Choose More Functions to open the Function Browser. See “Using Functions” on 
page 96 for details about this tool.

m Choose Formula Editor to open the Formula Editor. See “Using the Formula Editor” on 
page 88 for instructions.

Performing a Basic Calculation Using Column Values
Using the pop-up menu of the Function button in the toolbar makes it easy to perform 
basic calculations on adjacent values in a column and display the results.
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Here are ways to perform basic calculations using values in a column:
m To use values in a range of adjacent cells, select the cells, click Function in the toolbar, 

and choose a calculation from the pop-up menu.

Numbers places the formula and its result in the first empty cell beneath the selected 
cells. If there is no empty cell, Numbers adds a row to hold the result.

m To use all the values in a column, click the column’s header cell or reference tab, click 
Function in the toolbar, and choose a calculation from the pop-up menu.

Numbers places the formula and its result in a footer row. If a footer row doesn’t exist, 
Numbers adds one.

Performing a Basic Calculation Using Row Values
Using the pop-up menu of the Function button in the toolbar makes it easy to perform 
basic calculations on adjacent values in a row and display the results.

Here are ways to perform basic calculations using values in a row:
m To use values in a range of adjacent cells, select the cells, click Function in the toolbar, 

and choose a calculation from the pop-up menu.

Numbers places the formula and its result in the first empty cell to the right of the 
selected cells. If there is no empty cell, Numbers adds a column to hold the result.

m To use all the values in a row, click the row’s header cell or reference tab, click Function 
in the toolbar, and choose a calculation from the pop-up menu.

Numbers places the formula and its result in a new column.

Removing a Formula
If you no longer want to use a formula that's associated with a cell, you can quickly 
remove the formula.

To remove a formula from a cell:
1 Select the cell.

2 Press the Delete key.

Using the Formula Editor 
The Formula Editor lets you create and modify formulas. 

Move the Formula Editor
by grabbing here

and dragging. Text field 
View or edit a formula.

Cancel button
Discard changes.

Accept button
Save changes.
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Here are ways to open the Formula Editor:
m Select a table cell and then type the equal sign (=).

m Double-click a table cell that contains a formula.  

m Select a table cell, click Function in the toolbar, and then choose Formula Editor from 
the pop-up menu.

m Select a table cell and then choose Insert > Function > Formula Editor.

When the Formula Editor opens, it appears over the selected cell. To move the Formula 
Editor, hover the cursor over the left side of the Formula Editor until the cursor changes 
into a hand, then click and drag.

When you select a cell that contains a formula, its arguments are highlighted in color 
and the formula is displayed in the Formula Bar, which can also be used to edit a 
formula. See “Using the Formula Bar” on page 90 for details.  

Adding a New Formula with the Formula Editor
Use the Formula Editor to create a formula.

To add a new formula using the Formula Editor:
1 Select the cell in which you want to display the result of the formula.

2 Open the Formula Editor. For example, type the equal sign (=).

3 Use the text field to specify the formula, making sure the equal sign is the first 
character in your formula.

To learn techniques for including cell references in your formulas, see “Using Cell 
References” on page 91.

To learn about using operators in formulas, see “Using Operators” on page 94.

To learn how to insert a function into a formula, see “Using Functions” on page 96.

4 To save changes, press Return, press Enter, or click the Accept button in the Formula 
Editor. You can also click outside the table.

To close the Formula Editor and discard changes, press Esc or click the Cancel button in 
the Formula Editor.

Editing a Formula with the Formula Editor
You can use the Formula Editor when you want to edit a formula.

To edit a formula:
1 Double-click a table cell that contains a formula. The Formula Editor opens, with the 

formula displayed in the text field and its arguments highlighted in color. 

2 Make changes as required. You can use the arrow keys to move the insertion point 
around in the text field.
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3 To save changes, press Return, press Enter, or click the Accept button in the Formula 
Editor. You can also click outside the table.

To close the Formula Editor and discard changes, press Esc or click the Cancel button in 
the Formula Editor.

Using the Formula Bar
The Formula Bar, located beneath the Format Bar, lets you create and modify formulas 
in a selected cell.

If you click a selected formula cell, the Formula Editor opens and you can use it to edit 
your formula instead of using the Formula Bar. See “Editing a Formula with the Formula 
Editor” on page 89 for details.

Adding a New Formula with the Formula Bar
Use the Formula Bar to create a formula.

To add a new formula using the Formula Bar:
1 Select the cell in which you want to display the result of the formula.

2 Click in the text field of the Formula Bar to enter the formula. Make sure that the equal 
sign (=) is the first character in your formula.

To learn techniques for including cell references in your formulas, see “Using Cell 
References” on page 91.

To learn about using operators in formulas, see “Using Operators” on page 94.

To learn how to insert a function into a formula, see “Using Functions” on page 96.

3 To save changes, press Return, press Enter, or click the Accept button in the Formula 
Bar.

To discard changes, press Esc or click the Cancel button in the Formula Bar.

Text field 
View or edit a formula.

Cancel button
Discard changes.

Accept button
Save changes.

Click to open the
Function Browser.
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Editing a Formula with the Formula Bar
You can use the Formula Bar when you want to edit a formula.

To edit a formula:
1 Select a table cell that contains a formula. 

The formula is displayed in the text field of the Formula Bar, and its arguments are 
highlighted in color. 

2 Click in the Formula Bar, and make changes as required. You can use the arrow keys to 
move the insertion point around in the text field.

3 To save changes, press Return, press Enter, or click the Accept button in the Formula 
Bar.

To discard changes, press Esc or click the Cancel button in the Formula Bar.

Using Cell References
You use cell references to identify specific cells in formulas. For example, if you add a 
formula that averages the values in two cells, you use cell references to identify those 
cells. The cells can be in the same table as the cell with the formula, or they can be in 
another table on the same or a different sheet.

You can create cell references using the letters and numbers of reference tabs or using 
header cell names:

Â If your table has both a header row and a header column, you can identify a cell 
using the column name followed by the row name.
For example, if a column is named 2006 and a row is named Class Enrollment, the 
cell where the row and column intersect would be referred to as 2006 Class 
Enrollment.

Â You can use the letters and numbers of reference tabs to identify a specific cell. You 
specify the column letter and then the row number.
For example, C55 refers to the fifty-fifth row in the third column.

Adding Cell References to a Formula
To insert a cell reference, you can click a cell, click a reference tab, or select a range of 
cells when there’s an insertion point in the text field of the Formula Editor or the 
Formula Bar. You can also insert a cell reference by typing it.  

When you insert a cell reference by selecting cells or reference tabs, Numbers adds cell 
references that use header cell names if “Use header cell names as references” is 
selected in the General pane of Numbers preferences. 

When you type a cell reference that includes the name of a header cell, table, or sheet, 
Numbers displays a list of suggestions that match what you’ve started to type. You can 
select from the list or continue typing.  
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Here are ways to add a cell reference at the insertion point in the text field:
m To create a reference to a specific cell by using your mouse, click the cell. 

You can also type a reference to a specific cell. Use the column letter followed by the 
row number (A4) in the reference tabs or use the column name followed by the row 
name (2006 Class Enrollment).

If the other table is on a different sheet, click the sheet in the Sheets pane before 
selecting the cell.

To refer to a cell in a different table, use the table name followed by two colons (::) and 
then the cell identifier (Table 2::B5). To refer to a cell in a table on another sheet, use 
the sheet name first (Sheet 2::Table 2::2006 Class Enrollment) if the table name isn’t 
unique in the spreadsheet.

m To add a reference to a list of individual cells, click each cell. If the references are 
arguments in a function, Numbers automatically inserts a comma (,) between the 
references, which you can replace with a different character if needed. For example, if 
you’re in a location where the decimal separator is a comma, you can separate multiple 
cell references using a semicolon instead of a comma.

m To add a reference to a range of adjacent cells, drag over the cells you want to add.

You can also type or click the first cell, type a colon, and then type or click the last cell. 
For example B2:B5 refers to four cells in the second column. B2:C3 refers to two cells in 
the second column and two cells in the third column.

m To refer to all the cells in a column, click the column’s reference tab or click its header 
cell if there is one.

You can type the reference by using the column letter (C or C:C) or the column name if 
there’s a header cell. For example, SUM(B) or SUM(B:B) adds all the values in the cells of 
the second column.

m To refer to all the cells in a row, click the row’s reference tab or click its header cell if 
there is one.

You can type the reference by using the row number (1:1) or the row name if there’s a 
header cell. For example, SUM(1:1) adds all the values in the cells of the first row.

Copying or Moving Formulas with Cell References
You can copy or move a formula that contains cell references without invalidating the 
references.

Here are techniques for relocating formulas:
m To move a formula to a different cell, move the formula’s cell by dragging it to another 

cell.
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If the table is large and you want to move the formula to a cell that’s out of view, select 
the cell, choose Edit > Mark for Move, select the other cell, and then choose Edit > 
Move. For example, if the formula =A1 is in cell D1 and you want to move the same 
formula to cell X1, select D1, choose Edit > Mark for Move, select X1, and then choose 
Edit > Move. The formula =A1 appears in cell X1. 

m To move a cell that a formula refers to, move the cell by dragging it or use Edit > Mark 
for Move followed by Edit > Move.

For example, if the formula =A1 appears in cell D1 and you want to move cell A1 to cell 
D95, select A1, choose Edit > Mark for Move, select D95, and then choose Edit > Move. 
The formula in D1 becomes =D95. 

m To paste a copy of a formula in a different cell and use the same cell references in both 
formulas, place a dollar sign ($) in front of column and row identifiers (=$A$1). This 
technique creates what’s called an absolute cell reference.

For example, if the formula =A1 appears in cell D1 and you want to paste a copy of the 
formula in cell E1, change the formula to =$A$1, select D1, copy it, and paste the copy 
into E1. The formula $A$1 is copied into cell E1. If you didn’t change the formula to use 
an absolute cell reference the formula in E1 would be =B1.

Applying a Formula Once to Cells in a Column or Row
When a table has header cells, you can use them to quickly apply a formula to all the 
cells in a row or column. The values in the cells are recomputed using the formula. This 
formula is called a header formula.

To apply a header formula to cells in a column or row:
1 Select the header cell for the column or row. 

2 Open the Formula Editor. For example, type the equal sign (=).

3 Type the formula you want to apply to each cell in the column or row.

For example, to assign values to the cells of column C that are five times greater than 
the corresponding cell in column B, you’d use the formula B*5 or B:B*5.

The formula is duplicated in all the cells in the column or row. In this example, cell C4 
would contain the value computed by using the formula B4*5.

4 Click the Accept button or press Return or Enter to save the formula.

Handling Errors and Warnings
When a formula in a table cell is incomplete, contains invalid cell references, or is 
otherwise incorrect, or when an import operation creates an error condition in a cell, 
Numbers displays an icon in the cell. A blue triangle in the upper left of a cell indicates 
one or more warnings. A red triangle in the middle of a cell means that a formula error 
occurred.
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To view error and warning messages:
m Click the icon.

A message window summarizes each error and warning condition associated with the 
cell.

To have Numbers issue a warning when a cell referenced in a formula is empty, choose 
Numbers > Preferences and in the General pane select “Show warnings when formulas 
reference empty cells.”

Using Operators
Use operators in formulas to perform arithmetic operations and compare values:
Â Arithmetic operators perform arithmetic operations, such as addition and subtraction, 

and return numerical results.
Â Comparison operators compare two values and return TRUE or FALSE.

Performing Arithmetic Operations
To create a formula that performs an arithmetic operation, you use arithmetic 
operators. For example, to add three values in a column, you could create a formula 
that looks like this:  A2 + A3 + A5.

Here are the basic arithmetic operators. For complete information about arithmetic 
operators that Numbers supports, see “Understanding the Arithmetic Operators” on 
page 95. 

To add an arithmetic formula to a cell:
1 Select an empty cell for displaying the results of the formula.

2 Open the Formula Editor. For example, type an equal sign (=).

3 Enter the formula in the text field following the equal sign. 

For example, to enter the formula A3 * B5 + B6, in the text field following the equal 
sign you could click or type A3, type * (the multiplication operator), click or type B5, 
and then click B6 (if you don’t type an operator before clicking, Numbers adds the plus 
sign (+) automatically when you’re not specifying function arguments).

4 Click the Accept button or press Return or Enter to save the formula.

To perform this operation Use this arithmetic operator For example

Sum two values + A2 + B2

Subtract one value from another 
value

– A2 – B2

Multiply two values * A2 * B2

Divide one value by another 
value

/ A2 / B2
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Understanding the Arithmetic Operators 
Arithmetic operators in table cell formulas perform arithmetic operations and return 
numerical results. 

Here are the arithmetic operators (examples presume that cell A2 contains 20 and 
that B2 contains 2):

m The operator + returns the sum of two values.

For example, A2 + B2 returns 22.

m The operator – returns the difference between two values.

For example A2 – B2 returns 18.

m The operator * returns the product of two values.

For example, A2 * B2 returns 40.

m The operator / returns the result of dividing one value by another value.

For example, A2/B2 returns 10.

m The operator ^ returns the result of raising one value to the power of another value.

For example, A2 ^ B2 returns 400.

m The operator % returns the result of dividing a value by 100.

For example, A2% returns 0.2, formatted for display as 20%.

When a cell reference points to an empty cell, 0 is the value used.

When a cell reference points to a cell containing FALSE, 0 is used. If the cell contains 
TRUE, 1 is used. For example, TRUE + 1 returns 2.

Using a string with an arithmetic operator returns an error. For example, 3 + "hello" is 
not a correct arithmetic operation.
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Understanding the Comparison Operators 
Comparison operators compare two values and return TRUE or FALSE. 

Here are the comparison operators (examples presume that cell A2 contains 20 and 
that B2 contains 2):

m The operator = returns TRUE if two values are equal.

For example, A2 = B2 returns FALSE.

m The operator <> returns TRUE if two values aren't equal.

For example, A2<>B2 returns TRUE.

m The operator > returns TRUE if the first value is greater than the second value.

For example, A2 > B2 returns TRUE.

m The operator < returns TRUE if the first value is less than the second value.

For example, A2 < B2 returns FALSE.

m The operator >= returns TRUE if the first value is greater than or equal to the second 
value.

For example, A2 >= B2 returns TRUE.

m The operator <= returns TRUE if the first value is less than or equal to the second value.

For example, A2 <= B2 returns FALSE.

Strings are larger than numbers. For example, "hello" > 5 returns TRUE.

TRUE and FALSE can be compared with each other, but not with numbers or strings. 
TRUE > FALSE, and FALSE < TRUE, because TRUE is interpreted as 1 and FALSE is 
interpreted as 0. TRUE = 1 returns FALSE, and TRUE = "SomeText" returns FALSE.

Using Functions
A function is a predefined, named operation (such as SUM and AVERAGE) that you can 
use to perform a calculation in a table cell. 

There are several families of functions, ranging from financial functions that calculate 
interest rates, investment values, and more to statistical functions that calculate 
averages, probabilities, standard deviations, and more. See “About Functions” on 
page 193 for complete information about all the functions, including the arguments 
you specify to provide the data for functions to use in their calculations.

Although you can type a function into the text field of the Formula Editor or Formula 
Bar, you can also use the Function Browser to add a function to a formula. 



Chapter 5    Using Formulas and Functions in Tables 97

 

To use the Function Browser to add a function:
1 Select the cell in which you want to add a function.

2 Click the Function Browser button in the Formula Bar, or choose Insert > Function > 
More Functions. The Function Browser opens. 

3 Select a function.

To find a function, scroll through the list on the right, optionally subdividing the list by 
selecting a function category on the left. You can also search for a specific function 
within the selected function category by using the search field in the upper right.

4 Click Insert.

The Formula Editor is displayed in the cell, with the selected function in the text field, 
followed by one or more argument placeholders within parentheses. 

5 Use the Formula Editor or Formula Bar to replace each placeholder with a cell reference 
or other value or perform any additional formula editing required. 
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6 Using Charts

You can convert table data into attractive charts. This chapter 
describes how to create and format charts.

Numbers provides tools for creating visually appealing charts to present some or all of 
the data in one or more tables. By default, the appearance of charts is coordinated with 
the template you’re using, but you can adjust colors, textures, shadows, labels, and 
more to emphasize various chart elements.

About Charts
You can turn data that appears in one or more tables into charts. Charts can visually 
reveal trends or relationships that aren’t as apparent when you view the data in rows 
and columns. 

A chart is linked to data in the table or tables it’s based on. If you change table data, 
the chart updates automatically.

You can choose from a variety of chart types to present your data, including pie charts, 
line charts, bar charts, column charts, area charts, and scatter charts. Most charts have 
both two-dimensional and three-dimensional versions.

For example, a business may use a table to keep track of how many employees work in 
Region 1 and Region 2 each year. Such a table might have two rows (one for Region 1 
and one for Region 2) and four columns (one for each year from 2007 through 2010).
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There are several ways to represent the data in this table in a chart. In a bar chart, for 
example:
Â You can plot 2007 employee counts for Region 1 and Region 2 in side-by-side bars, 

followed by pairs of bars for 2008, 2009, and 2010. Such a chart would have two data 
series and four data sets.
Region 1 and Region 2 are called data series; each region is represented by a series of 
data values. Data values (data points) for each region are represented by bars that are 
grouped side by side in the chart; each group is called a data set (2007 is a data set, 
2008 is a data set, and so on).

Â Alternatively, you can change the chart orientation so that data points are grouped 
by region rather than by year. In this case, the years are data series and the regions 
are data sets. The bar chart would contain two groups of bars, one for Region 1 and 
one for Region 2.

The data sets contain one 
data point (one bar) from 
each of the data series.

These four bars represent 
one data series.

The chart legend denotes 
the two data series.

These two bars represent 
one data series.

The data sets contain one data 
point (one bar) from each of 
the four data series.
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When you select a chart, the cells plotted in it are highlighted in the related table. In 
addition, colored squares appear next to columns and rows in the table to show which 
color represents each data series in the chart. 

A button in the upper left of the table lets you switch between using columns and 
rows as data series.

You can also click a series element in the chart to view its related data in the chart and 
the underlying table.

Click this button to change 
the chart orientation.

These squares indicate 
which color represents 
each data series.

When the button looks like this, 
the columns are data series. 
Click the button to make rows 
the data series.

When the button looks like this, 
the rows are data series. Click 
the button to make columns 
the data series.

Selecting a bar highlights 
bars in the chart in the 
same data series as well as 
related values in the 
underlying table.
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Data series are represented differently in different kinds of charts:
Â In column charts and bar charts, a data series is represented by a series of bars in the 

same fill (color or texture). 
Â In a line chart (also called a graph), a data series is represented by a single line. 
Â In an area chart, a data series is represented by an area shape. 
Â In a pie chart, only a single data set (the first data point in each series) is represented 

on the chart.
Â In a scatter chart, two columns of data are used to plot values for a single data series. 

Each pair of values determines the position of one data point.

Adding a Chart
You can add a chart that shows all the data in a table or only data in selected cells of 
one or more tables. 

When you add a chart, Numbers defines default data series and axis labels, but you can 
change the series or the labels:

Â In most cases, if a table is square or if it’s wider than tall, the table rows are the 
default series. Otherwise, the columns are the default series. To change the data 
series, select the chart and then click a data series button in the upper left of the 
related table.

Â If a table contains header rows or cells, Numbers uses their contents to create default 
axis labels. In the absence of header cells, Numbers uses text in the first column or 
row as axis labels. Otherwise, placeholder text is used for labels.
Series labels identify the data series elements (individual bars, for example) in the 
chart.

Category labels identify data sets (groups of bars, for example) in the chart.

You can show and hide, edit, move, reorient, and format axis labels as “Adding Labels 
and Axis Markings” on page 108 describes.

These are category labels.

These are series labels.
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Here are ways to add a chart:
m To add a chart based on a table, select the table, click Charts in the toolbar, and choose 

a chart type from the pop-up menu.

The values in the table are plotted in the chart. If the table is empty, the chart is blank 
until you add values to table cells.

m To add a chart based on a range of adjacent table cells, click in a cell, and then click 
and drag to select other cells; you can also select a single cell and then hold down the 
Shift key to select cells. Then click Charts in the toolbar, and choose a chart type.

m To add a chart based on nonadjacent cells, hold down the Command key as you select 
cells from a table. Then click Charts in the toolbar, and choose a chart type.

m To add a chart based on data in more than one table, create a chart by selecting a table 
or cells in it. Then select the chart and Command-click or Command-drag cells in 
another table to add their data to the chart.

m To add a chart and a related table with placeholder values, make sure nothing is 
selected, click Charts in the toolbar, and choose a chart type.

m To add a scatter chart, see “Scatter Charts” on page 117.

m To draw a chart, hold down the Option key as you click Charts in the toolbar. Choose a 
chart type. The pointer changes into a crosshair; drag the crosshair across the canvas to 
create a chart that’s the size you want. To constrain the chart’s proportions, hold down 
the Shift key as you drag.

Editing Charts
You can change the data plotted in a chart, change the plotting orientation to switch 
data series and data sets, move data series, change the chart type, and more. 

On the pop-up menu, 2D 
charts are on the left, and 
3D charts are on the right.
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Changing the Plotting Orientation

A data series button in the upper left of the table lets you switch between using 
columns and rows as data series. 

To change the plotting orientation:
1 Select the chart.

2 Click the data series button.

Changing the Data Plotted in a Chart
When you change the data in a chart’s related table cells, the chart is automatically 
updated. But you can also add data to and remove data from a chart without affecting 
the related table.

Adding Data to a Chart
You can add data from cells that are adjacent or nonadjacent to cells already plotted, 
and you can add data in a new row or column.

Here are ways to add data to a chart:
m To add data from cells that aren’t adjacent to cells already plotted, select the chart and 

then Command-click or Command-drag the cells in the table.

m To add data from cells that are adjacent to cells already plotted, select the chart and 
then Shift-click the cells in the table.

m To extend the range of adjacent cells whose values are plotted, select the chart. In the 
table, drag the circular control in the lower right of the range to the right or down.

If the chart is a scatter chart, dragging lets you add only an even number of rows or 
columns.

Click this button to change the chart 
orientation. The button looks like this 
when columns are data series.
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m To add cells based on a new row or column, select the table and insert the row or 
column between cells that are already plotted. When you add data to the new cells, the 
data will be plotted in the chart.

Adding Data to a Chart from Multiple Tables
You can add data to a chart from cells that are in more than one table.

To chart data in multiple tables:
1 Create a chart based on data from one table.

2 Select cells in another table.

3 Drag the selected cells into the chart. They’re added as a new data series.

To view or change the chart’s source data, click a data series in the chart to see its table 
and cells of origin.

Removing Data from a Chart
You can delete values from only a chart, leaving them in the related table, or you can 
delete values from both a chart and its related table.

Here are ways to remove data from a chart:
m To remove a data point, select the table, select the cell in which the data resides, and 

press Delete. The value is removed from the table and the chart.

If you delete a column or row that is part of a two-column pair plotted in a scatter 
chart, the related two-value data point is removed from the chart.

m To remove multiple individual cell values, select the table, use Shift-click or Command 
click to select the cells, and then press Delete. The values are removed from both the 
table and the chart.

m To shrink the range of adjacent cells whose values are plotted, select the chart. In the 
table, drag the circular control in the lower right of the range up or to the left. The cells 
that are deselected are no longer represented in the chart but the values remain in the 
table.

m To remove a data series, click the chart, select an element in the series or click the 
series label in the table, and then press Delete. The values are removed from the chart 
but remain in the table.

m To remove a data set, click the chart, select the category label in the table, and press 
Delete. The values are removed from the chart but remain in the table.

If the category has no label in the table, click the data series button in the table to 
convert the category to a series, select the series that contains the data you want to 
remove, and press Delete.
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Replacing a Data Series
You can change the row or column on which a data series is based to a different row or 
column.

To replace a data series:
1 Select the chart.

2 Select the series you want to move, either by clicking the data series in the chart or by 
clicking the data series label in the table.

3 Drag the data series in the table to the row or column you want to use as a 
replacement.

Deleting a Chart
You can delete a chart by deleting its related table(s), or you can delete only the chart.

Here are ways to delete a chart:
m To remove the chart and not its related table(s), select it and press Delete.

m To remove both the chart and its related table(s), select the table(s) and press Delete.

Moving a Chart
You can move a chart within a spreadsheet by dragging it or by cutting and pasting it. 
Its connections to related cells are maintained.

Here are ways to move a chart:
m To move a chart to a different location on the same sheet, select it and drag it to the 

new location.

m To move a chart to a different sheet, in the sidebar select the chart and drag it to the 
new sheet.

You can also select the chart and cut it (Command-X), select the other sheet, and then 
paste it (Command-V). Drag the chart to refine its location on the sheet.

Changing a Chart from One Type to Another
You can change a chart’s type anytime you like.

To change a chart from one type to another:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then choose a 
different chart type from the pop-up menu that appears when you click the chart icon 
in the upper left.

If you switch to a pie chart, the first data point in each series is represented as a wedge. 
See “Pie Charts” on page 113.
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If you switch to a scatter chart, each point in the chart requires two values. If the chart is 
based on an odd number of rows or columns, the last row or column isn’t plotted. See 
“Scatter Charts” on page 117.

If you switch to a bar, column, area, or line chart, each series in the new chart 
corresponds to a row or column in the table.

If you switch to a 3D version of a chart, the Chart Inspector provides controls for 
managing object depth, lighting style, and more. See “3D Charts” on page 118.

Formatting you’ve applied to the chart you’re changing may not be applied to the new 
chart. For example, the color fill attribute of data point elements (bars, wedges, and so 
on) has a different default value for each type of chart. If you’ve changed a column fill 
color and then change the chart to be a bar chart, the fill color change isn’t retained. 

Â Depending on the type of chart, the attributes that may change when you change a 
chart’s type are show value label, value label position, text style, series stroke, series 
shadow, series fill, data point symbol, and data point fill. 

Â Bar/column charts and stacked bar/column charts share attributes except for value 
label position. Also, bar/column charts have separate fills.

Â 3D chart shadows are shared across chart types.

When you change a chart’s type and the new type has some of the same attributes, 
those attributes don’t change. Shared attributes include axes, gridlines, tick marks, axis 
labels, show minimum value, number format, borders, rotation, shadows, and 3D 
lighting style.

You’ll learn more about these attributes throughout the remainder of this chapter.

Formatting General Chart Attributes
You can resize and reposition charts and chart legends. You can add a title to a chart. 
You can format chart elements (fonts, textures, colors, axis and data point labels, and 
tick marks). You can adjust the angle and lighting style of 3D charts. 

Using a Legend
The chart legend describes the meaning of the colors used to plot data points in each 
data series.

You can show or hide a chart’s legend, and you can reposition it.
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Here are ways to work with a chart’s legend:
m To show the legend, select the chart and then select Show Legend in the Chart 

Inspector.

m To edit the labels in the legend, edit the series labels in the related table or select the 
legend and edit the text directly in the legend.

m To format the legend’s text, see “Formatting Titles, Labels, and Legends” on page 112.

m To hide the legend, select the chart and then deselect Show Legend in the Chart 
Inspector.

You can also select the legend and press Delete.

m To move the legend, select and then drag it.

Using a Chart Title
You can add a title to a chart. The title can be formatted.

Here are ways to work with a chart’s title:
m To add a title, select the chart and then select Show Title in the Chart Inspector. Replace 

the placeholder text with your title.

m To format the title’s text, see “Formatting Titles, Labels, and Legends” on page 112.

m To hide the title, select the chart and then deselect Show Title in the Chart Inspector.

Resizing a Chart
You can make a chart larger or smaller by dragging one of its selection handles or by 
using the Metrics Inspector.

Here are ways to resize a chart:
m Click the chart to select it, and then drag a selection handle.

m To maintain a chart’s proportions, hold down the Shift key as you drag to resize the 
chart. 

m To resize a chart in one direction, drag a side handle instead of a corner handle. 

m To resize by specifying exact dimensions, click Inspector in the toolbar, click the Metrics 
Inspector button, and then click Metrics. In this pane, you can specify a new width, 
height, and angle of rotation, and you can change the chart’s distance from the 
margins.

Rotating Charts
There are several techniques for rotating 2D charts. You can’t rotate (or flip) 3D charts. If 
a 3D chart is grouped with 2D charts, you can rotate the group, but only the 2D charts 
in the group will rotate.
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Here are ways to rotate 2D charts:
m Select the chart, hold down the Command key, move the pointer toward a selection 

handle until it changes to a curved, double-headed arrow, and then drag a selection 
handle.

m To rotate a chart in 45-degree increments, press the Shift and Command keys while 
dragging a selection handle.

m Click Inspector in the toolbar, click the Metrics Inspector button, and then drag the 
Rotate wheel or use the Angle controls to set the angle of the chart.

Pie charts can also be rotated using the Chart Inspector (see “Rotating 2D Pie Charts” 
on page 115).

Adding Labels and Axis Markings
Use the Axis pane in the Chart Inspector to format the grid and general look of chart 
axes.

Most charts have two axes, an X-axis and a Y-axis. Depending on the type of chart, data 
points are plotted on one of the axes and data sets are grouped on the other axis. The 
data point axis is called the value axis, and the data set axis is called the category axis.

Showing Axes and Borders
You can show any or all of these elements of a chart: the X-axis, the Y-axis, and chart 
borders.

To show axes and borders:
1 Select a chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.

3 Choose one or more items from the Axes & Borders pop-up menu to select the items.

A selected item has a checkmark next to it; choose the item again to deselect it.

Set attributes of labels, 
tick marks, and more.

Select units for values in 
the chart.

Show or hide axes and chart 
borders (2D charts only).

Set the range of values that 
appear on the chart grid.
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To format the border stroke and color, select the chart and use the line style controls 
on the Format Bar.

Using Axis Titles
You can add a title to a chart’s X-axis and Y-axis. The title can be formatted.

Here are ways to work with an axis title:
m To add an axis title, select the chart and then select Show Category Title from the X-

Axis or Show Value Title from the Y-Axis pop-up menu in the Axis pane of the Chart 
Inspector. Replace the placeholder text with your title.

m To format the title’s text, see “Formatting Titles, Labels, and Legends” on page 112.

m To hide an axis title, select the chart and then deselect Show Category Title from the X-
Axis or Show Value Title from the Y-Axis pop-up menu in the Axis pane of the Chart 
Inspector.

Showing Data Point Labels
You can display data point values on columns, bars, pie wedges, and other chart 
elements of 2D and 3D charts.

To format data point labels:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and click Series.

3 Choose Show Value from the Data Point Settings pop-up menu. 

To display the value as a percentage or logarithmic value instead of an absolute value, 
choose Percentage or Logarithmic in the X-Axis or Y-Axis pop-up menu on the Axis 
pane.

For pie charts, you display values as percentages by choosing Show Pie Values as 
Percentages from the Data Point Settings pop-up menu on the Series pane. To display 
the data series name for a wedge, choose Show Series Name from the Data Point 
Settings pop-up menu.

4 Select a label location from the Data Point Settings pop-up menu (for example, Middle 
or Below Right).

5 Specify the number of decimal places to display by entering a number in the Decimals 
field.

6 To format the data point labels, see “Formatting Titles, Labels, and Legends” on 
page 112.

Choose a line style.

Choose a line width.

Choose a line color.
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Formatting the Value Axis
You can set the values and units to be displayed along the value axis, the axis on which 
you read the data point values. For column charts (vertical bars), line charts, and area 
charts, the Y-axis is the value axis. For horizontal bar charts, the X-axis is the value axis. 
For scatter charts, both axes are value axes. (Pie charts don’t have a value axis. To read 
about formatting pie charts, see “Pie Charts” on page 113.)

To format the value axis:
1 Select a chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.

3 To set the value at the chart origin, type a number in the Minimum field (under Value 
Axis Format).

The Minimum value cannot be higher than the minimum value of your entire data set.

4 To set the highest number displayed on the value axis, type a number in the Maximum 
field.

The Maximum value cannot be lower than the maximum value of your entire data set.

5 To specify the number of axis markings between the minimum and maximum values, 
specify a number in the Steps field.

6 To display the minimum data value on the value axis, select Show Value Labels and 
Show Minimum Value from the Labels, Ticks, & Grids X-Axis or Y-Axis pop-up menu, 
depending on the chart.

7 To specify units for axis values, under Number Format type text in the Prefix or Suffix 
field (or choose a symbol from the pop-up menus).

8 To display values on the value axis as logarithmic values, choose Logarithmic from the 
X-Axis or Y-Axis pop-up menu, depending on the chart. This option is available only for 
2D bar/column charts that aren’t stacked and for line charts. You can’t plot negative 
values on the log axis.

9 To display values on the value axis of stacked charts as percentages, choose Percentage 
from the X-Axis or Y-Axis pop-up menu on the Axis pane.

For pie charts, you display values as percentages by choosing Show Pie Values as 
Percentages from the Data Point Settings pop-up menu.

Placing Labels, Gridlines, and Tick Marks
The X-Axis and Y-Axis pop-up menus in the Axis pane of the Chart Inspector provide an 
array of options for placing tick marks, labels, and gridlines along the value axis or the 
category axis. The options in these pop-up menus vary depending on the kind of chart 
you select.
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For vertical bar charts (column charts), line charts, and area charts, the Y-axis is the 
value axis and the X-axis is the category axis. For horizontal bar charts, the X-axis is the 
value axis. For scatter charts, both axes are value axes. For 3D charts, the X and Y axes 
are the same as their 2D counterparts.

To format axis markings:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.

3 To format the X-axis, choose an option from the X-Axis pop-up menu. The menu for a 
column chart looks like this:

4 To format the Y-axis, choose an option from the Y-Axis pop-up menu. Here’s what the 
menu looks like for a column chart:

5 To edit axis labels based on header column or row values, select the table and edit the 
labels.

If you want axis labels to differ from header column or row values, select the chart and 
edit the labels. Changing header cells no longer affects the axis labels after you edit the 
labels in the chart.

Place tick marks along the 
X-axis.

Show or hide the X-axis 
gridlines.

Set the text direction for 
the category axis labels.

Show or hide category 
axis labels and title.

Display values as 
logarithmic values.

Place tick marks along the 
Y-axis.

Show or hide the Y-axis 
gridlines.

Show or hide value axis labels.

Display values as logarithmic 
values or percentages.
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Formatting the Elements in a Data Series
You can use a variety of visual effects to enhance the appearance of data series 
elements, such as bars, wedges, and area shapes.

To format data series elements:
1 To format all data series, select the chart. 

To format elements in a single data series, select the chart and then click one of the 
elements in the series.

For all chart types except pie charts, selecting one element (such as a bar) of a series 
automatically selects the full series. For pie charts, you select individual wedges.

2 To fill series elements with specially designed colors or textures, click Inspector in the 
toolbar, click the Chart Inspector button, and then click Chart Colors.

Choose a fill type (for example, 3D Texture Fills) from the first pop-up menu, and 
choose a fill collection (for example, Marble or Wood) from the second pop-up menu. 

To fill all the elements in all the data series, click Apply All. The first fill is applied to 
elements in the first series, the second fill to elements in the second series, and so on.

To fill elements in a single data series, drag the fill to an element (bar, column, and so 
on) in the series. 

3 To adjust the opacity, stroke, shadow, and other graphical attributes of series elements, 
click the Graphic Inspector button. You can also use the Format Bar to control the fill 
color, opacity, and shadow of the entire chart or individual data series in the chart. 

4 To adjust series element colors, see “Filling an Object with Color” on page 160.

5 To use one of your own images to fill series elements, see “Filling an Object with an 
Image” on page 162.

6 To format data point labels, see “Showing Data Point Labels” on page 109.

“Formatting Specific Types of Charts” on page 113 provides instructions for formatting 
charts of particular types.

Formatting Titles, Labels, and Legends
You can change the size and appearance of chart and axis titles, axis labels, data point 
labels, and legends. 

To format the text of labels and legends:
1 Select the text you want to format. 

To format all chart titles and labels, click the chart to select it. If you select the text for 
one data point or axis label, all the text of that kind is also selected. You change the 
font for a chart legend separately.
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2 You can use the Format Bar to format font characteristics and style. For additional 
formatting options, use the Format menu or the Font panel. See “Using the Format 
Menu to Format Text” on page 121 and “Using the Font Panel to Format Text” on 
page 123 for instructions.

Adding Descriptive Text to a Chart
You can add descriptive text to a chart, such as when you want to provide background 
information for a particular data point.

To add text:
1 Create a text box. See “Adding Text Boxes” on page 141 for instructions.

2 Drag the text box to where you want it on the chart.

3 Type text in the text box.

Optionally group the chart and the text box so the text stays with the chart. Shift-click 
to select both the chart and the text box, and then choose Arrange > Group.

Formatting Specific Types of Charts
Different chart styles offer unique options for formatting their elements.

Pie Charts
For pie charts, Numbers plots only the first data point for each data series. If the data 
series are in rows, only the first column is charted; if the data series are in columns, only 
the first row is charted. 

Thus, one pie chart represents a single data set, and each wedge is one element in that 
set. You can chart any data set by moving it to the first row or column.

You can format a pie chart as a whole, or you can format individual wedges. 

Selecting Individual Pie Wedges
If you want to format one or more wedges, you need to select them first. 

Here are ways to select pie wedges in a selected pie chart:
m To select a single wedge, click it.

m To select all the wedges, select any wedge and press Command-A.

m To select nonadjacent wedges, hold down the Command key as you select each 
wedge.

m To select a continuous range of wedges, select the first wedge, and then hold down the 
Shift key as you select the last wedge.
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Showing Series Names in a Pie Chart
On pie charts, you can display series names. 

To show series names in a pie chart:
1 Select the chart or individual pie wedges.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Series. 

3 Choose Show Series Name from the Data Point Label pop-up menu.

4 Choose Inside or Outside from the Data Point Label pop-up menu.

Separating Individual Pie Wedges
To make pie wedges more visually prominent, you can separate them from the pie. You 
can add a series name to separated wedges to further enhance their prominence, as 
“Showing Data Point Labels” on page 109 describes. 

Here are ways to separate individual pie wedges:
m To move a single wedge away from the center of a 2D or 3D pie chart, select it and 

then drag it or use the Explode control on the Series pane of the Chart Inspector.

m To separate all the wedges away from the center of a 3D pie chart, select the chart 
before using the Explode control.

Adding Shadows to Pie Charts and Wedges
You can put shadows on individual pie wedges or on the pie as a whole. Putting 
shadows on individual wedges makes it look as if the wedges are on different layers. 

When you add a shadow to a pie wedge, it’s a good idea to separate it first. See 
“Separating Individual Pie Wedges,” earlier in this section, for instructions.

To add shadows:
1 Select the chart or individual pie wedges.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Series.

3 To add shadows to wedges, choose Individual from the Shadow pop-up menu.

To add shadows to the chart as a whole, choose Group from the Shadow pop-up 
menu.

4 To set shadow attributes, use the Graphic Inspector. See “Adding Shadows” on 
page 156 for instructions.

Set a pie wedge apart by 
using the Explode slider and 
giving it a series name.
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Adjusting the Opacity of Pie Charts
You can change the opacity of the chart and individual chart elements, such as the 
legend. See “Adjusting Opacity” on page 158 for more information. 

Rotating 2D Pie Charts
You can use various techniques for rotating a 2D pie chart. 

Here are ways to rotate a pie chart:
m Select the chart, click Inspector in the toolbar, click the Chart Inspector button, click 

Series, and then use the Rotation Angle wheel or field.

m Click Inspector in the toolbar, click the Metrics Inspector button, and then drag the 
Rotate wheel or use the Angle controls to set the angle of the chart.

m Select the chart, hold down the Command key and move the pointer toward a 
selection handle until it changes to a curved, double-headed arrow, and then drag a 
selection handle.

m To rotate the chart in 45-degree increments, press the Shift and Command keys while 
dragging a selection handle or the Rotate wheel.

Bar and Column Charts
You can apply shadows to individual data series or to the entire chart. You can adjust 
the opacity for the chart as a whole or for individual series (but not individual bars). You 
can also adjust the spacing between data sets or individual bars. 

Adjusting Spacing of Bar and Column Charts
You can adjust spacing between individual bars or data sets.

To adjust spacing:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Series.

3 To change the space between bars, type a value (or click the arrows) in the “Gap 
between bars” field.

To change the space between data sets, specify a value in the “Gap between sets” field.

The value is the percentage of the bar thickness. Decreasing the space between the 
bars makes them thicker. 

Separate the individual 
bars in the chart.

Separate the data sets 
in the chart.

Add shadows to bars 
or data sets.
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You can also move the pointer near a bar edge until it becomes a double-headed 
arrow, and then drag to make the bars thicker or thinner.

Adding Shadows to Bar and Column Charts
You can add shadows to each bar in the chart or to each group of bars.

If you want to add shadows to individual bars, it’s a good idea to separate them first. 
See “Adjusting Spacing of Bar and Column Charts” on page 115 for instructions.

To add shadows:
1 Select the chart.

2 Click Inspector in the toolbar, click Chart Inspector, and then click Series.

3 To add shadows to individual bars, choose Individual from the Shadow pop-up menu.

To add shadows to each group of bars, choose Group from the Shadow pop-up menu.

4 To set shadow attributes, use the Graphic Inspector. See “Adding Shadows” on 
page 156 for instructions.

Adjusting the Opacity of Bar and Column Charts
You can change the opacity of the chart and individual chart elements, such as the 
legend. See “Adjusting Opacity” on page 158 for more information. 

Area Charts and Line Charts
In area and line charts, you can use symbols (circles, triangles, squares, and diamonds) 
to represent data points.

The data points in this 
series are represented 
by triangles.

The data points in this 
series are represented 
by circles.
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Here are ways to format area charts and line charts:
m To format symbols, select a data series (area shape or line), click Inspector in the 

toolbar, click the Chart Inspector button, and then click Series. Choose a symbol from 
the Data Point Symbol pop-up menu.

Use the options on the Symbol Fill pop-up menu to add color or images to the 
symbols. See “Filling an Object with an Image” on page 162 and “Filling an Object with 
Color” on page 160 for instructions.

m To set the line color in line charts, select a line, click Inspector in the toolbar, click the 
Graphic Inspector button, and then use the Stroke controls. See “Changing the Style of 
Borders” on page 155 for instructions.

m To add shadows to line or area charts, select a data series (area shape or line), click 
Inspector in the toolbar, click the Graphic Inspector button, and then use the Shadow 
controls. See “Adding Shadows” on page 156 for instructions. 

Scatter Charts
Scatter charts display data differently than the other kinds of charts. They require at 
least two columns or rows of data to plot values for a single data series. To show 
multiple data series, you use additional two-column or two-row pairs. 

Each pair of values determines the position of one data point. The first data value in the 
pair is the X-axis of the point. The second data value is the Y-axis of the point.

Here are ways to work with a scatter chart:
m To add the default scatter chart and related table with placeholder data, make sure 

nothing is selected, click Charts in the toolbar, and choose the scatter chart.

m To set up a table that provides data for a scatter chart, use two columns or two rows of 
data for each data series. If the cells selected when you add the chart represent an odd 
number of rows or columns, the last row or column isn’t plotted.

m To format a symbol for a data series, see “Formatting the Elements in a Data Series” on 
page 112. 

m To specify axis settings, use the Axis pane of the Chart Inspector. Because both axes of 
scatter charts have values, value axis format settings apply to both X-axis and Y-axis. 
Each axis can have its own number format. See “Formatting the Value Axis” on page 110 
for instructions. 

Choose a symbol to use 
for data points.

Fill data point symbols 
with color or images.
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3D Charts
All the chart types except scatter charts can be displayed as 3D charts. 

Here are 2D and 3D versions of a pie chart.

And here are 2D and 3D versions of a line chart.

To define 3D scene settings:
1 Select a 3D chart. 

2 Click Inspector in the toolbar, click the Chart Inspector, and then click 3D Scene.

3 Modify the chart’s viewing angle, lighting style, and depth as desired using the 3D 
Scene controls.

Viewing angle arrows:  Drag an arrow to adjust the angle. Click the vertical arrow and 
drag up or down to move the chart up or down. Click the horizontal arrow and drag 
side to side to move the chart left or right. To move the chart both ways, click the 
intersection of the arrows and drag.

Lighting Style:  Choose an item from this pop-up menu to adjust the lighting effect.

Chart Depth:  Slide this control to increase or decrease the depth of the 3D elements.
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7 Working with Text

This chapter describes how to add and modify the 
appearance of text, including lists.

In Numbers spreadsheets, you can place text in text boxes, table cells, and shapes.

Adding Text
Add text by typing it in a table cell, text box, or shape. 
Â To learn about adding text to a text box or shape, see “Using Text Boxes and Shapes 

to Highlight Text” on page 141.
Â To learn how to add text to table cells, see “Working with Text in Cells” on page 55.
Â To add text that’s formatted as a list, see “Using Bulleted, Numbered, and Ordered 

Lists (Outlines)” on page 137.

Deleting, Copying, and Pasting Text
The Edit menu contains commands that help you perform text editing operations. 

Here are ways to edit text:
m To copy (or cut) and paste text, select the text and choose Edit > Copy or Edit > Cut. 

Click where you want to paste the text.

To have the copied text retain its style formatting, choose Edit > Paste.

To have the copied text take on the style formatting of the text around it, choose Edit > 
Paste and Match Style.

m To delete text, select the text and choose Edit > Delete or press the Delete key.

If you accidentally delete text, choose Edit > Undo to restore it.

When you use the Copy or Cut command, the selected text is placed in a holding area 
called the Clipboard, where it remains until you choose Copy or Cut again or you turn 
off your computer. The Clipboard holds the contents of only one copy or cut operation 
at a time.
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Selecting Text
Before you format or perform other operations on text, you need to select the text you 
want to work with. 

Here are ways to select text:
m To select one or more characters, click in front of the first character and drag across the 

characters you want to select.

m To select a word, double-click the word.

m To select a paragraph, click three times quickly in the paragraph.

m To select blocks of text, click the start of a text block, and then click the end of another 
text block while holding down the Shift key.

m To select from the insertion point to the beginning of the paragraph, press the Up 
Arrow key while holding down the Shift and Option keys.

m To select from the insertion point to the end of the paragraph, press the Down Arrow 
key while holding down the Shift and Option keys.

m To extend the selection one character at a time, press the Left Arrow or Right Arrow key 
while holding down the Shift key.

m To extend the selection one line at a time, press the Up Arrow or Down Arrow key 
while holding down the Shift key.

m To select multiple words or blocks of text that are not next to each other, select the first 
amount of text you want, and then select additional text while holding down the 
Command key.

Formatting Text Size and Appearance
You can change text font, color, style, and more using the Format menu, the Font 
panel, and the Format Bar.

The Format menu and Font panel are the primary methods for formatting table cell 
text. The Format Bar is a convenient tool for formatting text in text boxes and shapes. 
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Using the Format Bar to Format Text
The Format Bar makes changing the size and appearance of text in a text box, shape, or 
comment quick and easy. When text in a text box, shape, or comment is selected, you 
can change the font style and size, adjust the color of the text, make text bold or italics 
or underlined, align text, set line spacing, and format the text into columns.

Using the Format Menu to Format Text 
The items in the Font submenu of the Format menu give you basic control over the size 
and appearance of text.

Making Text Bold or Italic Using the Menus
You can make characters bold or italic.

To make text bold or italic:
1 Select the text you want to make bold or italic, or click where you want to type new 

text.

2 Choose Format > Font > Bold. Or choose Format > Font > Italic.

Some fonts contain several bold and italic typefaces. To choose from a variety of bold 
and italic typefaces, use the Font panel. See “Using the Font Panel to Format Text” on 
page 123.

Creating Outlined Text Using the Menus
You can change text to appear as a stenciled outline.

To create outlined text:
1 Select the text you want to make outlined, or click where you want to type new text.

2 Choose Format > Font > Outline.

Outlined text you create in Numbers may look different if the spreadsheet is opened in 
another application. If you plan to share a spreadsheet that contains outlined text with 
people who don’t have Numbers installed on their computers, export the spreadsheet 
as a PDF file and then share this file with others.

Change font typeface, 
style, and size.

Set color of text.

Make text bold, italics, 
or underlined.

Align text.

Set line spacing.

Divide text into 
columns.



122 Chapter 7    Working with Text 

 

Underlining Text Using the Menus
You can underline text and then format the underline to change the underline style or 
color.

To underline text:
1 Select the text you want to underline, or click where you want to type new text.

2 Choose Format > Font > Underline.

To modify the underline style or color, click Fonts in the toolbar and use the Text 
Underline button in the Font panel. See “Using the Font Panel to Format Text” on 
page 123.

Changing Text Size Using the Menus
You can change the point size of text to make the text larger or smaller.

To change the size of text:
1 Select the text you want to resize.

2 To change the text size in 1-point increments, choose Format > Font > Bigger. Or 
choose Format > Font > Smaller.

You can also add Bigger and Smaller icons to the toolbar. Choose View > Customize 
Toolbar, drag the icons to the toolbar, and then click Done.

To specify a precise size for selected text, click Fonts in the toolbar and use the Size 
controls in the Font panel. See “Using the Font Panel to Format Text” on page 123.

Making Text Subscript or Superscript Using the Menus
You can raise or lower text from its baseline.

To make text subscript or superscript:
1 Select the text you want to raise or lower, or click where you want to type new text.

2 To create a subscript or superscript that has a smaller font size than the text it 
accompanies, choose Format > Font > Baseline > Subscript. Or choose Format > Font > 
Baseline > Superscript.

3 To raise or lower text without reducing its font size, choose Raise or Lower from the 
Baseline submenu. 

4 To restore text to the same baseline as the body text, choose Use Default from the 
Baseline submenu.

You can add Subscript and Superscript icons to the toolbar. Choose View > Customize 
Toolbar, drag the icons to the toolbar, and then click Done. 
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Changing Text Capitalization Using the Menus
You can quickly make blocks of text all uppercase or lowercase, or format text as a title.

To change text capitalization: 
1 Select the text you want to change, or click where you want to type new text.

2 Choose Format > Font > Capitalization and choose an option from the submenu.

Choose All Caps to change the text to capitals.

Choose Small Caps to change the text to smaller capitals with larger capitals for 
uppercase letters.

Choose Title to change the text to a title format, which capitalizes the first letter of each 
word.

Choose None to change text from all capitals to initial caps. Uppercase characters, such 
as the first word of each sentence, are capitals but the rest are lowercase.

Using the Font Panel to Format Text
The Mac OS X Font panel gives you access to all the fonts installed on your computer. It 
provides a preview of the available typefaces (such as bold and italic) and sizes for each 
font. The buttons in the Font panel let you add underlines, strikethrough lines, color, 
and shadow to text. You can even change the background page color in the Font 
panel.

For information on installing fonts, creating and managing font collections, or 
troubleshooting font-related issues, see Mac Help.

To open the Font panel:
m Click Fonts in the toolbar.

Preview the selected typeface (you 
might need to choose Show Preview 
from the Action menu).

Select a typeface to 
apply to selected text in 
your document.

Select a font size to apply to 
selected text in your document.

The Action menu

Create interesting
text effects using these

pop-up menus.

Find fonts by typing a font 
name in the search field.

Apply a shadow to selected 
text. Modify the shadow 
using the opacity, blur, 
offset, and angle controls.
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You can change the appearance of any text in your spreadsheet by selecting it and 
then selecting options in the Font panel. When you make formatting changes in the 
Font panel, the selected text changes right away, so you can try different formatting 
options and quickly see what looks best.

Here is a summary of what the text effects pop-up menus do, from left to right:

Â The Text Underline pop-up menu lets you choose an underline style (such as single 
or double).

Â The Text Strikethrough pop-up menu lets you choose a strikethrough style (such as 
single or double).

Â The Text Color pop-up menu lets you apply a color to text.
Â The Document Color pop-up menu lets you apply a color behind a paragraph.
Â The Text Shadow button applies a shadow to selected text.
Â The Shadow Opacity, Shadow Blur, Shadow Offset, and Shadow Angle controls 

control the appearance of the shadow.

If you don’t see the text effects buttons, choose Show Effects from the Action pop-up 
menu in the lower-left corner of the Font panel.

Making the Font Panel Easy to Use
If you frequently use the Font panel, there are several techniques for saving time.

Here are tips for using the Font panel:
m To quickly locate fonts you frequently use, organize them into font collections. Click the 

Add (+) button to create a font collection, and then drag a typeface into the new 
collection. 

m To make it easy to change fonts often, leave the Font panel open. If it takes up too 
much space on your screen, you can shrink it by dragging its resize control (the 
bottom-right corner of the panel), so that only the font families and typefaces in your 
selected font collection are visible. To close the panel, click the Fonts button again or 
the Close button in the upper-left corner of the Font panel.

Changing Fonts Using the Font Panel
The Font panel gives you extensive control over fonts. Use size controls and 
typography settings to customize the appearance of your text. 

To modify the font of selected text:
1 Click Fonts in the toolbar.

2 In the Font panel, select a font style in the Family column and then select the typeface 
in the Typeface column.

If you don't see all the font families you know are installed on your computer, select All 
Fonts in the Collections column or type the name of the font you are looking for in the 
search field at the bottom of the Font panel.
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A preview of the selected font appears in the preview pane at the top of the Font 
panel. If you don't see a preview pane, choose Show Preview from the Action pop-up 
menu in the lower-left corner of the Font panel.

3 Adjust the font size using the size slider or other size controls.

4 Adjust the typography settings of the selected font by choosing Typography from the 
Action pop-up menu. In the Typography window, click the disclosure triangles to see 
and select the different typography effects that are available for the selected font. 
Different fonts have different typography effects available. See “Using Advanced 
Typography Features” on page 129 for more information.

Changing Underlining Using the Font Panel
You can use the Font panel to change the appearance of underlines.

To modify underlining of selected text:
1 Click Fonts in the toolbar.

2 Click the Text Underline button in the Font panel (the first button on the left), and 
choose None, Single, or Double from the pop-up menu.

3 To change the underline color, choose Color from the Text Underline pop-up menu, 
and then select a color in the Colors window.

Adding a Strikethrough to Text Using the Font Panel
You can mark text with a strikethrough line, and make the line’s color different from the 
text color.

To add a strikethrough to selected text:
1 Click Fonts in the toolbar.

2 Click the Text Strikethrough button (the second button from the left), and choose 
None, Single, or Double from the pop-up menu. A single or double strikethrough 
appears through the selected text in the same color as the text.

3 To change the strikethrough color, choose Color from the Text Strikethrough pop-up 
menu, and then select a color in the Colors window. The strikethrough takes on the 
color you select in the Colors window, but the text remains its original color.

Changing Text Color Using the Font Panel
Changes made to text color in the Font panel will override text color changes made in 
the Text Inspector, and vice versa. (To read about changing color using the Text 
Inspector, see “Changing Text Color” on page 133.)

To modify the color of selected text:
1 Click Fonts in the toolbar.

2 Click the Text Color button menu in the Font panel (the third button from the left), and 
then select a color in the Colors window. See “Using the Colors Window” on page 161 
for instructions.
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Changing the Paragraph Background Color Using the Font Panel
You can use the Font panel to add a color behind a paragraph.

To modify the background color of a selected paragraph:
1 Click Fonts in the toolbar.

2 Click the Document Color button in the Font panel (the fourth button from the left), 
and then select a color in the Colors window. See “Using the Colors Window” on 
page 161 for instructions.

Creating Shadows on Text Using the Font Panel
You can use the Font panel to create and format shadows on text.

To define shadows on selected text:
1 Click Fonts in the toolbar.

2 Click the Text Shadow button in the Font panel (the fifth button from the left).

3 Drag the shadow opacity slider (the first slider on the left) to the right to make the 
shadow darker.

4 Drag the shadow blur slider (the middle slider) to the right to make the shadow more 
diffuse.

5 Drag the shadow offset slider (the third slider) to the right to separate the shadow from 
the text.

6 Rotate the Shadow Angle wheel to set the direction of the shadow.

You can also set text shadows in the Graphic Inspector, as described in “Adding 
Shadows” on page 156.

Adding Accents and Special Characters
If you need to type characters with accent marks (such as ü), mathematical symbols, 
arrows, or other special characters, you can use the International preferences pane or 
the Character Palette. You can also see where characters are located on keyboards used 
for other languages by using the Keyboard Viewer (for example, you can see how the 
keys on an Italian keyboard are laid out). All of these are built-in tools of Mac OS X. 

Adding Accent Marks
You can use the Keyboard Viewer available in System Preferences to add accent marks 
to characters.

To add accent marks:
1 Choose Apple > System Preferences and click International.

2 Click Input Menu, then select the checkbox next to Keyboard Viewer.
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3 Choose Show Keyboard Viewer from the Input menu on the right side of the menu bar 
(the one that looks like a flag or alphabetical symbol).

The Keyboard Viewer shows the characters for your keyboard. (If you've selected a 
different keyboard layout or input method in the Input menu, it shows the characters 
for the selected keyboard layout.) For example, if U.S. is chosen in the Input menu, you 
see the characters that appear on a U.S. keyboard in the Keyboard Viewer.

4 To see the different accent marks that you can type highlighted in the Keyboard 
Viewer, press Option, or the Option and Shift keys.

The accent mark keys appear with white outlines. Depending on your keyboard, you 
may not need to press any of the modifier keys to see the accent keys.

5 Place the insertion point in your spreadsheet where you want to type.

6 Press the modifier key you pressed in step 4 (Shift, Option, Option-Shift, or none) and 
press the key on your keyboard that is in the same place as the accent you see in the 
Keyboard Viewer. Then release the modifier key and press the key for the character you 
want to accent.

The accent key modifies the key you type next. For example, on a U.S. keyboard, to 
make the é appear, press Option and E (the accent key), then press E (the letter on 
which you want that accent to appear).

Viewing Keyboard Layouts for Other Languages
You can use the Keyboard Viewer available in System Preferences to see where 
characters are located on keyboards used for other languages.

You must have fonts installed for the language you want to see in the Keyboard Viewer.

To see keyboard layouts for different languages:
1 Choose Apple > System Preferences and click International.

2 Click Input Menu, then select the checkbox next to Keyboard Viewer.

3 To see the character layout on keyboards used in different countries, select the On 
checkbox next to the country's keyboard layout or input method.

4 Choose Show Keyboard Viewer from the Input menu on the right side of the menu bar 
(the one that looks like a flag or alphabetical character).

The Keyboard Viewer shows the characters for the keyboard layout or input method 
selected in the Input menu. For example, if U.S. is chosen in the Input menu, you see 
the characters that appear on a U.S. keyboard in the Keyboard Viewer.

5 To see the keyboard layout for a different country, choose its keyboard layout from the 
Input menu.
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Typing Special Characters and Symbols
Using the Mac OS X Character Palette, you can insert special characters, such as 
mathematical symbols, letters with accent marks, arrows and other “dingbats,” and 
more. You can also use this palette to enter Japanese, Traditional Chinese, Simplified 
Chinese, and Korean characters, as well as characters from other languages.

To insert special characters or symbols:
1 Place the insertion point where you want the special character or symbol to appear.

2 Choose Edit > Special Characters to open the Character Palette (or choose Characters 
from the Action pop-up menu in the lower-left corner of the Font panel).

3 Choose the type of characters you want to see from the View pop-up menu at the top 
of the Character Palette. If you don't see the View menu, click the button in the upper-
right corner of the window to show the top portion of the window. Click this button 
again to hide the top portion of the window.

4 Click an item in the list on the left to see the characters that are available in each 
category.

5 Double-click the character or symbol on the right that you want to insert into your 
spreadsheet, or select the character and click Insert. 

If the character or symbol has variations, they appear at the bottom of the window 
when you click the Character Info triangle or Font Variation triangle at the bottom of 
the palette. Double-click one to insert it in your spreadsheet.

If the character doesn’t appear in your spreadsheet, Numbers may not support that 
character.

Using Smart Quotes
Smart quotes are opening and closing quotation marks that are curly; the opening 
quotation marks are different from the closing quotation marks. When you don’t use 
smart quotes, the marks are straight and the opening and closing marks don’t differ. 

To use smart quotes:
m Choose Numbers > Preferences, click Auto-Correction, and then select “Use smart 

quotes.” 

Smart quotes

Straight quotes
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Using Advanced Typography Features
Some fonts, such as Zapfino and Hoefler, have advanced typography features, which let 
you create different effects. If you are using a font in a text box that has different 
typography effects available, you can change many of the effects in the Font submenu 
of the Format menu. For example, you may be able to adjust the following:
Â Kern:  Place characters closer together or farther apart. 
Â Ligature:  Use or leave out stylish flourishes between letters or at the end or 

beginning of lines that combine two or more text characters into one glyph. 

In the Ligature submenu, choose Use Default to use ligature settings specified in the 
Typography window for the font you’re using, choose Use None to turn off ligatures 
for selected text, or choose Use All to turn on additional ligatures for the selected 
text.

Â Baseline:  Move text higher or lower than the text around it. 
Â Capitalization:  Convert characters to all capital letters, small capital letters, or initial 

capital letters (title style). 

Advanced typography features are available in the Typography window.

To open the Typography window: 
1 Click Fonts in the toolbar.

2 In the Font panel, choose Typography from the Action pop-up menu (in the lower-left 
corner).

Adjusting Font Smoothing
If the fonts on your screen look fuzzy, blurry, or jagged, you may want to adjust the font 
smoothing style or change the text size at which Mac OS X starts to smooth fonts.

To smooth the fonts on your screen:
1 Open System Preferences and click Appearance. 

2 Choose a font smoothing style from the pop-up menu at the bottom. Depending on 
the type of display you have, you may notice only small or no differences between 
smoothing styles.

3 If you plan to use small font sizes in your spreadsheet, choose a point size from the 
“Turn off text smoothing for font sizes” pop-up menu. When text smoothing (or 
“antialiasing”) is on, smaller fonts can be harder to read.

Ligature not used

Ligature used
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Setting Text Alignment, Spacing, and Color
The primary tools for adjusting alignment, spacing, and color are the Format Bar and 
the Text Inspector. You can make some horizontal alignment adjustments (such as 
centering text or aligning it on the left) by using the Format menu. 

Color, spacing, and alignment controls are also available on the Format Bar when text is 
selected. When text in a text box, comment, or shape is selected, you can set the color 
of text, align text, and set line spacing.

When you’re working with text in a table cell, you can use the Format Bar to align text 
both horizontally and vertically in the cell.

The Text pane of the Text Inspector gives you access to more alignment and line 
spacing settings. 

To open the Text pane of the Text Inspector:
m Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

Change font typeface, 
style, and size.

Set color of text.

Make text bold, italics, 
or underlined.

Align text.

Set line spacing.

Divide text into 
columns.

Align text horizontally.

Align text vertically.

Click to change the
color of selected text.

Horizontal alignment buttons:  
Click to align selected text left, right, 
center, or to the left and right, or using 
special table cell alignment.

Vertical alignment buttons:  
Click to align text to the top, 
center, or bottom of a text box, 
shape, or table cell.Character and

line spacing:
Adjust character, line,

and paragraph spacing
for selected text.

Drag to adjust the amount of space 
between text and the inside borders 
of text boxes, table cells, and shapes.

The Text Inspector
button
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Aligning Text Horizontally 
You can change the alignment of text in a column, table cell, text box, or shape so that 
text is aligned to the left or right border, centered, or aligned on both left and right 
(justified).

To align text left, center, right, or justified:
1 Select the text you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text. 

3 Click one of the five horizontal alignment buttons, located to the right of the color well. 
From left to right, these buttons have the following effects.

The Align Left button places each line of text against the left margin of the object.

The Center button sets the center of each line of text at the center of the object.

The Align Right button sets each line of text against the right margin of the object.

The Justify button spaces characters in each line so that the lines reach both the left 
and right margins of the object.

The Auto Align Table Cell button left justifies text and right justifies numbers in a table 
cell.

The five horizontal alignment buttons are also available on the Format Bar when a table 
cell is selected. The first four are available on the Format Bar when text in a text box, 
shape, or comment is selected.

You can also align text horizontally by choosing Format > Text > Align Left, Center, Align 
Right, Justify, Auto Align Table Cell.

If you want to indent the first line of text in a paragraph, or learn how to undo 
paragraph indenting, see “Setting Indents” on page 136.

Aligning Text Vertically 
You can change the alignment of paragraphs in a table cell, text box, or shape so that 
text is aligned to the top or bottom border or centered between them.

To align text to the top, center, or bottom of a text box, table cell, or shape:
1 Select the text box, table cell, or shape whose alignment you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text. 

3 Click one of the three vertical alignment buttons, located below Color & Alignment, to 
align text to the top, middle, or bottom of the table cell, text box, or shape.

The vertical alignment buttons are also available on the Format Bar when you’re 
working with a table cell.
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Adjusting the Spacing Between Lines of Text
You can increase or decrease the distance between lines of text.

To adjust spacing:
1 Select the text you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text. 

3 Move the Line slider left to decrease spacing or right to increase it.

To specify a precise line spacing value, type a point value in the Line field, or click the 
Up Arrow or Down Arrow next to the field.

4 Choose a line spacing option from the Line spacing pop-up menu that appears when 
you click the text below the line field.

Standard line spacing (Single, Double, Multiple):  The space between lines is proportional 
to font size. Use this when the relative distance between ascenders (parts of letters that 
extend to the top of the line) and descenders (parts of letters that extend below the 
line) should remain fixed. Single sets line spacing to single-spaced, and Double sets it 
to double-spaced. Multiple lets you set line spacing values lower than single, between 
single and double, or greater than double.

At Least:  The distance from one line to the next will never be less than the value you 
set, but it may be larger for larger fonts in order to prevent overlapping text lines. Use 
this when the distance between lines should remain fixed, but overlap is not desired if 
the text gets large.

Exactly:  The distance between the baselines. 

Between:  The value you set increases the space between the lines, instead of increasing 
the height of the lines. By contrast, double-spacing doubles the height of each line.

Line spacing can also be controlled by using the Line Spacing pop-up menu on the 
Format Bar when text is selected in a text box, shape, or comment.

Line spacing pop-up menu:  
Click the text below the Line 
field and choose a line spacing 
option.

Line field:  
Type a value (or click the arrows) 
to specify the space between 
lines of text in a paragraph.

Click to change the amount of 
space between lines of text.
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Adjusting the Spacing Before or After a Paragraph
You can increase or decrease the spacing before or after paragraphs.

To adjust the amount of space before or after a paragraph:
1 Select the paragraphs you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text. 

3 Drag the Before Paragraph or After Paragraph slider. You can also specify a precise value 
(5 pt, for example) in the text boxes.

If the Before Paragraph or After Paragraph values for adjacent paragraphs aren’t equal, 
the higher spacing value will be used. For example, if the current paragraph’s Before 
Paragraph value is 12 points and the paragraph preceding it has an After Paragraph 
value of 14 points, the spacing between paragraphs will be 14 points.

Spacing before a paragraph does not appear if the paragraph is the first paragraph in a 
text box, shape, or table cell. 

To set spacing around text in boxes, shapes, and table cells, use the Inset Margin 
control, described in “Changing the Inset Margin of Text in Objects” on page 136.

Adjusting the Spacing Between Characters
You can increase or decrease the amount of space between characters.

To adjust the amount of space between characters:
1 Select the text you want to change, or click where you want to type new text.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text. 

3 Drag the Character slider or specify a new percentage in the Character field.

You can also adjust the space between selected characters by choosing Format > 
Font > Kern and choosing an option from the submenu.

Changing Text Color 
You can change text color by using the Format Bar, the Text Inspector, and the Font 
panel. Changes you make with any of these tools overrides color changes already made 
with the other tools.

Before changing text color, select the text whose color you want to change, or click in 
the text to set the insertion point.
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Here are ways to change text color:
m Click the Text Color color well in the Format Bar. In the color matrix that appears, select 

a color by clicking it or click Show Colors to open the Colors window for additional 
color options.

m Click Inspector in the toolbar, click the Text Inspector button, click Text, and then click 
the color well. The Colors window opens.

“Using the Colors Window” on page 161 provides instructions for using the Colors 
window.

Setting Tab Stops to Align Text
You can align text at specific points by setting tab stops in a text box, table cell, or 
shape. When you press the Tab key (or Option-Tab when you’re working in a table cell), 
the insertion point (and any text to the right of it) moves to the next tab stop, and text 
you type starts at that point. 

You can work with tab stop settings by manipulating the tab symbols on the horizontal 
rulers. You can see symbols for existing tab stops on the horizontal ruler when you click 
View in the toolbar, choose Show Rulers, and then select some text on a page.

To set tab stops in lists, see “Using Bulleted, Numbered, and Ordered Lists (Outlines)” on 
page 137 for information about indenting items in lists.

Here are ways to work with rulers: 
m To show or hide rulers, click View in the toolbar and choose Show Rulers or Hide Rulers.

m To change the units of measure in the rulers, choose Numbers > Preferences, click 
Rulers, and choose an item from the Ruler Units pop-up menu. 

Blue tab symbols appear on 
the horizontal ruler when you 
select tabbed text.

Decimal tab

Right tab

Center tab

Left tab
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Setting a New Tab Stop
You use the horizontal ruler to add a new tab stop. 

To create a new tab stop:
1 Click View in the toolbar and choose Show Rulers.

2 Click the horizontal ruler to place a tab symbol where you want to set the tab stop.

3 Control-click the tab symbol and choose an option from the shortcut menu. 

Left Tab:  Aligns the left side of text with the tab stop.

Center Tab:  Places the center of text at the tab stop.

Right Tab:  Aligns the right side of text with the tab stop.

Decimal Tab:  For numbers, aligns the decimal character (such as a period or comma) 
with the tab stop. 

You can also double-click the tab symbol repeatedly until the type of tab you want 
appears.

Changing a Tab Stop
You can change the location and type of tab stops using the horizontal ruler. 

To change tab stops:
1 Click View in the toolbar and choose Show Rulers.

2 To move a tab stop, drag its blue tab symbol in the horizontal ruler.

3 To change the tab to a different type, Control-click the tab symbol and choose an 
option from the shortcut menu. Or double-click the tab symbol in the ruler repeatedly 
until the type of tab you want appears.

Deleting a Tab Stop
You can quickly remove a tab stop using the horizontal ruler. 

To delete a tab stop:
1 Click View in the toolbar and choose Show Rulers.

2 Drag the tab symbol off the horizontal ruler.

Choose from among 
these tab types.
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Setting Indents
You can modify the amount of space between text and the inside border of a text box, 
shape, table cell, or comment.

Setting Indents for Paragraphs 
You can change indentation by dragging the indentation controls on the text ruler. 

To set indents using the rulers:
1 Click View in the toolbar, and then choose Show Rulers.

2 To change the right indent, drag the right indent symbol (downward blue triangle on 
the right side of the horizontal ruler) to the position where you want the right edge of 
the paragraph to end.

3 To change the left indent, drag the left indent symbol (downward blue triangle on the 
left side of the ruler) to where you want the left edge of the paragraph to begin. 

To change the left margin independently from the left indent, hold down the Option 
key as you drag.

4 To change the first line indent, drag the first line indent (blue rectangle) to where you 
want the first line to start. 

If you want the first line to remain flush with the left margin, make sure the rectangle 
aligns with the left indent symbol. 

If you want to create a hanging indent, drag the rectangle to the left of the left indent 
symbol.

To use the ruler settings elsewhere in your spreadsheet, choose Format > Text > Copy 
Ruler and Format > Text > Paste Ruler.

Changing the Inset Margin of Text in Objects
You can change the amount of space between text and the inside border of a text box, 
shape, or table cell. This measurement is called the inset margin. The amount of space 
you specify is applied equally around the text on all sides.

To set the spacing between text and the inside border of its object:
1 If there’s no insertion point in the object, select the object.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text. 

First line indent Right indent

Left indent
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3 Drag the Inset Margin slider to the right to increase the space between text and the 
inside border of the object, or type a number in the Inset Margin box and press Return. 
You can also click the arrows to increase and decrease space.

Setting Indents for Lists
To manage the indentation of bullets, numbers, and text that accompanies them in 
bulleted lists, numbered lists, and ordered lists, you use the Text Inspector. See “Using 
Bulleted, Numbered, and Ordered Lists (Outlines)” for details.

Using Bulleted, Numbered, and Ordered Lists (Outlines)
Numbers provides pre-formatted bullet and numbering styles for creating simple or 
ordered lists (outlines). Bulleted and numbered lists are simple lists without the nested 
hierarchies of information like those you would see in an outline.

Generating Lists Automatically
When you use automatic list generation, Numbers automatically formats a list for you 
based on what you type. To use this feature, first choose Numbers > Preferences, click 
Auto-Correction, and make sure that “Automatically detect lists” is selected. 

Here are ways to automatically generate lists:
m To create a bulleted list, press Option-8 to type a bullet (•), a space, and some text. Then 

press Return; if you’re working in a table cell and “Return key moves to next cell” is 
selected in the Table Inspector, press Option-Return instead.

m To create a list with labels that are asterisks (*) or hyphens (-), type an asterisk or a 
hyphen, a space, and some text. Then press Return; if you’re working in a table cell and 
“Return key moves to next cell” is selected in the Table Inspector, press Option-Return 
instead.

m To create a list with labels that are numbers, letters, or Roman numerals, type the 
number, letter, or Roman numeral; a period; a space; and some text. Then press Return; 
if you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, press Option-Return instead.

You can use any of the character formats on the numbering style pop-up menu in the 
Text Inspector. To access this menu, in the Text Inspector click Bullets and choose 
Numbers from the Bullets & Numbering pop-up menu.

m To end your list, press Return twice. If you’re working in a table cell and “Return key 
moves to next cell” is selected in the Table Inspector, press Option-Return instead.

Specify how much space you 
want around text inside a text 
box, shape, or table cell.
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Using Bulleted Lists
Although you can use automatic list generation to create a simple bulleted list, using 
the Text Inspector gives you many options for formatting bulleted lists. See “Generating 
Lists Automatically” on page 137 for information about automatic list generation. 

To add and format a bulleted list using the Text Inspector:
1 Place the insertion point where you want the list to begin.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Bullets.

3 Choose a bullet style from the Bullets & Numbering pop-up menu.

To use a typed character as a bullet, choose Text Bullets and choose a character from 
the list or type a new character in the field.

To use one of the image bullets that comes with Numbers, choose Image Bullets and 
choose an image from the scrolling list.

To use your own image as a bullet, choose Custom Image and choose an image in the 
Open dialog that appears.

4 To change the size of an image bullet, specify a percentage of the original image size in 
the Size field. Or, select the “Scale with text” checkbox and specify a percentage of the 
text size; this option maintains the image-to-text size ratio of the bullets even if you 
later change the font size of text.

5 To adjust the space between bullets and the left margin, use the Bullet Indent field. To 
adjust the space between bullets and text, use the Text Indent field.

6 To position bullets higher or lower relative to text in a text box or shape, use the Align 
field.

Use these techniques to add and indent bulleted items in your list:

Â To add a new topic at the current indent level, press Return. If you’re working in a 
table cell and “Return key moves to next cell” is selected in the Table Inspector, press 
Option-Return instead.

Â To create an unbulleted paragraph within a topic, press Return while holding down 
the Shift key. If you’re working in a table cell and “Return key moves to next cell” is 
selected in the Table Inspector, press Control-Return instead.

Â To enter a new topic at the next lower indent level, press Tab. To enter a new topic at 
the next higher level, press Shift-Tab. You can also click and hold a bullet, and then 
drag to the right, to the left, down and to the right, or down and to the left.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, use the Indent Level controls in the Bullets pane of the Text Inspector 
to change the level of entries.
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Â To return to regular text at the end of your list, press Return and choose No Bullets 
from the Bullets & Numbering pop-up menu. You may also need to adjust the indent 
level.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, press Option-Return instead of Return.

Using Numbered Lists
Although you can use automatic list generation to create a simple numbered list, using 
the Text Inspector gives you many options for formatting numbered lists. See 
“Generating Lists Automatically” on page 137 for information about automatic list 
generation. 

To add and format a numbered list:
1 Place the insertion point where you want the list to begin.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Bullets.

3 Choose Numbers from the Bullets & Numbering pop-up menu, and then choose a 
numbering style from the pop-up menu directly below it.

4 To adjust the space between numbers and the left margin, use the Number Indent 
field. To adjust the space between numbers and text, use the Text Indent field.

Use these techniques to add and indent items in your list:

Â To add a new topic at the current indent level, press Return. If you’re working in a 
table cell and “Return key moves to next cell” is selected in the Table Inspector, press 
Option-Return instead.

Â To create an unnumbered paragraph within a topic, press Return while holding 
down the Shift key. If you’re working in a table cell and “Return key moves to next 
cell” is selected in the Table Inspector, press Control-Return instead.

Â To enter a new topic at the next lower indent level, press Tab. To enter a new topic at 
the next higher level, press Shift-Tab. You can also click and hold a number, and then 
drag to the right, to the left, down and to the right, or down and to the left.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, use the Indent Level controls in the Bullets pane of the Text Inspector 
to change the level of entries.

Â To return to regular text at the end of your list, press Return and choose No Bullets 
from the Bullets & Numbering pop-up menu. You may also need to adjust the indent 
level.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, press Option-Return instead of Return.

Â To add an existing paragraph to a numbered list, click the paragraph, choose a 
numbering style, and click “Continue from previous.”
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Â To start a new numbered sequence in a list, click “Start at” and specify the number 
you want the sequence to begin with.

If you want items in your list to have labeled subtopics (like in an outline), use an 
ordered list instead of a numbered list.

Using Ordered Lists (Outlines)
Ordered lists (or outlines) provide different numbering styles for each indent level in a 
list, allowing you to create a hierarchy of information. For example:
Â You can create an outline using a numbering sequence such as the following as you 

proceed from the highest level to lower levels: I, A, 1, a), (1), (a), i), (1), and (a).
Â You can create a legal style outline, which appends an additional number or letter at 

each lower level: 1, 1.1, 1.1.1, and so on. 

You can add and format ordered lists using the Text Inspector.

To add and format an ordered list:
1 Place the insertion point where you want the list to begin.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Bullets.

3 To create a legal style list, choose Tiered Numbers from the Bullets & Numbering pop-
up menu. Otherwise, choose Numbers instead.

4 Choose a numbering style from the pop-up menu directly below it.

5 To adjust the space between numbers and the left margin, use the Number Indent 
field. To adjust the space between numbers and text, use the Text Indent field.

Use these techniques to add and indent items in your list:
Â To add a new topic at the current indent level, press Return. If you’re working in a 

table cell and “Return key moves to next cell” is selected in the Table Inspector, press 
Option-Return instead.

Â To create an unnumbered paragraph within a topic, press Return while holding 
down the Shift key. If you’re working in a table cell and “Return key moves to next 
cell” is selected in the Table Inspector, press Control-Return instead.

Â To enter a new topic at the next lower indent level, press Tab. To enter a new topic at 
the next higher level, press Shift-Tab. To move among levels you can also click and 
hold a number, and then drag to the right, to the left, down and to the right, or 
down and to the left.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, use the Indent Level controls in the Bullets pane of the Text Inspector 
to change the level of entries.
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Â To return to regular text at the end of your list, press Return and choose No Bullets 
from the Bullets & Numbering pop-up menu. You may also need to adjust the indent 
level.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, press Option-Return instead of Return.

Â To add an existing paragraph to a numbered list, click the paragraph, choose a 
numbering style, and then click “Continue from previous.”

Â To start a new numbered sequence in a list, click “Start at” and specify the number 
you want the sequence to begin with.

Using Text Boxes and Shapes to Highlight Text
Use text boxes and shapes to make text stand out. 

Adding Text Boxes
You can add a text box to a sheet and drag it to position it. 

To create a text box:
1 Click Text Box in the toolbar (or choose Insert > Text Box). 

2 In the text box that appears, double-click the text and type.

Text boxes automatically grow or shrink to accommodate the length of your text. 

3 When you’ve finished typing, click outside the text box. Or, to stop editing text and 
select the text box, press Command-Return. 

4 Drag the handles on the text box to change its width.

5 Drag the text box to position it on the sheet.

You can’t make a text box taller by dragging up or down. However, you can force the 
box to grow vertically by dragging the selection handles inward to make the box 
narrower.

You can also draw a text box. Option-click Text Box in the toolbar, and drag the pointer 
across the spreadsheet window to create a text box that’s the size you want.

For more information about modifying text boxes, see “Formatting a Text Box or Shape” 
on page 143.

Presenting Text in Columns
You can organize text in a text box or a rectangular shape into columns. When text has 
filled one column, it flows into the next column. 
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Use the Columns pop-up menu in the Format Bar to quickly divide text into 1 through 
4 columns in a selected text box or rectangular shape.

For more options, use the Text Inspector.

To create and format columns using the Text Inspector:
1 Select the text box or rectangular shape with text you want to divide into columns.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Columns.

3 To indicate how many columns you want, use the Columns field.

4 To use equal-width columns, select “Equal column width.”

To set up different column widths, deselect “Equal column width,” double-click a 
Column value, and type a new width.

5 To change the distance between columns, double-click a Gutter value and change it.

Putting Text Inside a Shape
 All shapes, except lines, can contain text. 

To add text to a shape:
1 Place a shape where you want it on a sheet. To learn about adding shapes, see “Adding 

a Predrawn Shape” on page 164 and “Adding a Custom Shape” on page 164.

2 Double-click the shape and type the text you want. If the text extends beyond the 
border of the shape, a clipping indicator appears.

3 To resize the shape, select it and drag the selection handles. (If the insertion point is 
inside the shape, press Command-Return to get out of text editing mode and select 
the shape.)

You can format the text within a shape. You can also rotate a shape while keeping its 
text horizontal. After rotating the shape choose Format > Shape > Reset Text and 
Object Handles.

The clipping indicator shows 
that text extends beyond the 
borders of a shape.
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4 To add text to a shape that’s part of a group, double-click in the text area of any shape 
in the group. If you resize the group, everything resizes except for the text. Of course, 
you can still select text and change its font size. 

See “Grouping and Locking Objects” on page 159 for details about grouping objects.

Formatting a Text Box or Shape
You can change the amount of space between text and the inside border of a text box, 
shape, or table cell. See “Changing the Inset Margin of Text in Objects” on page 136 for 
instructions. 

Use the Format Bar and Graphic Inspector to format borders, shadows, opacity, color 
fill, and more for text boxes or shapes. For more information about setting object 
properties, see “Modifying Objects” on page 154 and “Filling Objects” on page 160.

Using Hyperlinks
Hyperlinks are used in spreadsheets that will be viewed onscreen, either as HTML files 
or as Numbers spreadsheets. You can add hyperlinks to open an email message or a 
webpage on the Internet.

Linking to a Webpage
You can add a hyperlink that opens a webpage in your default web browser.

To add hypertext that opens a webpage:
1 Select the text that you want to turn into a hyperlink.

If you use text that starts with “www” or “http,” the text automatically becomes a 
hyperlink. To turn off this feature, choose Numbers > Preferences, click Auto-Correction, 
and deselect “Automatically detect email and web addresses.” This setting is computer-
specific, so if the spreadsheet is opened on a computer with a different setting, that 
computer’s setting is used instead. 

2 Click Inspector in the toolbar, click the Hyperlink Inspector button, and then select 
“Enable as a hyperlink.”

3 Choose Webpage from the Link To pop-up menu.

Use this type of hyperlink To go to Notes

Webpage A page in a web browser Provide the URL of the page you 
want to open.

Email Message A new mail message with the 
specified subject and addressee

Type the address of the email 
recipient and a subject line.
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4 Type the webpage’s address in the URL field.

Linking to a Preaddressed Email Message
You can add a hyperlink that you can click to create a preaddressed email message in 
your default mail application.

To add hypertext that links to an email message:
1 Select the text that you want to turn into a hyperlink.

If you include an email address in a spreadsheet, the text automatically becomes a 
hyperlink. To turn off this feature, choose Numbers > Preferences, click Auto-Correction, 
and then deselect “Automatically detect email and web addresses.” This setting is 
computer-specific, so if the spreadsheet is opened on a computer with a different 
setting, that computer’s setting is used instead. 

2 Click Inspector in the toolbar, click the Hyperlink Inspector button, and then select 
“Enable as a hyperlink.”

3 Choose Email Message from the Link To pop-up menu.

4 Type the email address of the intended recipient in the To field.

5 Optionally type a subject line in the Subject field.

Editing Hyperlink Text
There are several ways to edit hyperlink text.

Here are ways to edit hyperlink text:
m Make hyperlinks inactive, change the hyperlink text, then reactivate hyperlinks. Activate 

and deactivate hyperlinks by clicking Inspector in the toolbar, clicking the Hyperlink 
Inspector button, and then selecting “Make all hyperlinks inactive.” 

Type the URL that you want 
to link to.

The Hyperlink Inspector button

Select to disable all hyperlinks 
so you can easily edit them.

Type the message subject.

Type the email address of the 
message recipient.
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m Click outside the hyperlink text, and use the arrow keys to move the insertion point 
into the text. 

Inserting Page Numbers and Other Changeable Values
You can insert such values as page numbers, page count, and date and time in a 
spreadsheet by using formatted text fields, which are automatically updated by 
Numbers when they change. Although values such as these are common in headers 
and footers (see “Using Headers and Footers” on page 41), you can insert formatted 
text fields anywhere in your spreadsheet. 

Here are ways to insert formatted text fields:
m To add page numbers, place the insertion point where you want the page number to 

appear, and then choose Insert > Page Number.

To change the page number format, Control-click a page number and choose a new 
number format.

m To add the total page count, place the insertion point where you want the page count 
to appear, and then choose Insert > Page Count.

To include the total page count with each page number, such as “2 of 10,” add a page 
number, type “of,” and then choose Insert > Page Count.

To change the page count format, Control-click a page count and choose a new 
number format.

m To add and format the date and/or time, place the insertion point where you want the 
value to appear, and then choose Insert > Date & Time.

To change the date and time format, Control-click the date and time value, choose Edit 
Date & Time, and then choose a date and time format from the pop-up menu. If you 
want the spreadsheet to always show the current date and time, select “Automatically 
update on open.”

Automatically Substituting Text
Numbers can be set to recognize and replace text you don’t want with text you do 
want. For example, when you type “teh,” Numbers can automatically change it to “the.”

To set up automatic text substitution:
1 Choose Numbers > Preferences. 

2 Click Auto-Correction and make settings as desired.

To automatically convert single and double quotation marks to smart quotes so that 
opening and closing quotation marks are not identical, select “Use smart quotes.”

To make sure that the first word in a sentence begins with a capital letter, select “Fix 
capitalization.”
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To automatically convert the letters in “1st,” “2nd,” “3rd,“ and so on into superscripts, 
select “Superscript numerical suffixes.”

To set Numbers to automatically detect that something you’ve typed is an email 
address or a URL, select “Automatically detect email and web addresses.” Email and 
web addresses you type automatically become hyperlinks for Mail or Safari.

To use automatic list generation, select “Automatically detect lists.” 

To replace one or more characters with one or more different characters, select “Symbol 
and text substitution.” Then use the rows in the table to define and activate specific 
substitutions. For example, when you type (c), you can have Numbers automatically 
convert it to © by putting a checkmark in the On column. To add a row to the table to 
define your own substitution, click the Add (+) button. To remove a selected item, click 
the Delete (–) button.

After you specify substitution settings, they’ll apply to any text you change or add in 
any Numbers spreadsheets.

Inserting a Nonbreaking Space
You can insert a nonbreaking space between words to make sure that the words 
always appear in the same line of text. 

To insert a nonbreaking space:
m Press the Space bar while holding down the Option key.

Checking for Spelling Mistakes
Numbers can catch spelling errors in your spreadsheet and help you find alternative 
spellings for misspelled words.

Finding Misspelled Words
You can set the spell checker to flag spelling errors as you type, or you can check your 
entire spreadsheet or selected text at any time. 

Misspelled words appear with a red dashed line below them. 

Here are ways to find misspelled words:
m To check spelling as you type, choose Edit > Spelling > Check Spelling as You Type.

To turn off spell checking as you type, click Edit > Spelling > Check Spelling as You Type 
to deselect it (make sure the checkmark is not visible next to the menu command).

m To check spelling from the insertion point to the end of the spreadsheet, click to place 
the insertion point and choose Edit > Spelling > Check Spelling. To limit spell checking 
to a specific part of the spreadsheet, select the text you want to check before choosing 
the command.
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The first misspelled word found is highlighted. You can correct it or choose the same 
menu command again to continue checking the spreadsheet. 

To go through the text more quickly, press Command-semicolon (;) to continue 
checking the spreadsheet.

m To check spelling and view suggestions for misspelled words, choose Edit > Spelling > 
Spelling.

The Spelling window opens, and you can use it as “Working with Spelling Suggestions” 
describes.

Working with Spelling Suggestions
Use the Spelling window to work with alternative spellings. 

To work with spelling suggestions:
1 Choose Edit > Spelling > Spelling.

The Spelling window opens and the first misspelled word is highlighted.

2 Make sure that the correct language is selected in the Dictionary pop-up menu. Each 
language uses a different spelling dictionary.

3 To replace the incorrect spelling in the text, double-click the correct word or spelling in 
the Guess list.

4 If the correct word doesn’t appear in the Guess list but you know the correct spelling, 
select the misspelled word in the Spelling window, type the correct word, and click 
Correct.

5 If the current spelling is correct and you want to leave it as it is, click Ignore or Learn. 
Use Learn if the term is one you use often and you want to add the term to the spelling 
dictionary. 

If you used Learn and later decide you don’t want the word in the dictionary, type the 
word into the text field below the Guess list, and then click Forget.

6 If no alternate spellings appear in the Guess list, select the misspelled word in the 
Spelling window and try a different spelling. Click Guess to see whether new 
possibilities appear in the Guess list.

7 Click Find Next and repeat steps 3 through 6 until you find no more spelling errors.

You can also hold down the Control key and click a misspelled word. From the pop-up 
menu you can choose an optional alternative spelling, click Learn, or click Ignore.
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Finding and Replacing Text
You can find every instance of a word or phrase in your spreadsheet, and optionally 
change it to something else. 

Here are ways to find and replace text:
m Choose Edit > Find > Find, click Simple or Advanced to set up find/replace criteria, and 

then click a button to conduct find/replace operations.

Simple:  In the Find field, type the text you want to find, and type any text you want to 
replace it with in the Replace field.

Advanced:  In addition to typing Find and Replace text, you can set up additional find/
replace criteria. Use the help tags to understand the fields that appear.

Replace All:  Automatically conducts the find/replace operation without your review.

Replace:  Replaces the current selection with the replacement text.

Replace & Find:  Replaces the current selection with the replacement text and 
immediately finds the next occurrence of the Find text.

Next or Previous:  Finds the next or previous occurrence of the Find text without 
replacing it, starting with the current sheet or selected cell(s) and searching forward or 
backward through the spreadsheet.

m Use the other commands on the Edit > Find submenu.

Find Next or Find Previous:  Finds the next or previous occurrence of the current Find 
text without replacing it, starting with the current sheet or selected cell(s) and 
proceeding forward or backward through the spreadsheet.

Use Selection for Find:  Finds the next occurrence of the selected text.

Jump to Selection:  Displays the selected text when it’s not currently in view.
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8 Working with Shapes, Graphics, 
and Other Objects

This chapter describes techniques for adding and modifying 
images, shapes, sound, and other objects.

An object is an item you can add to a spreadsheet and then manipulate. Images, 
shapes, movies, sound files, tables, charts, and text boxes are all objects.

Images include photographs or PDF files. Movies and sound are for spreadsheets that 
will be viewed onscreen. Shapes include simple predrawn shapes (such as triangles and 
arrows) and custom shapes that you draw yourself. Text boxes hold text.

Selecting Objects
Before you can move, modify, or perform other operations on objects, you must select 
them. A selected object has handles that let you move or manipulate the object. 

Here are ways to select and deselect objects:
m To select a single object, click anywhere on the object (to select an object that has no 

fill, click the edge).

m To select several objects, hold down the Shift key as you click objects.

m To select all the objects in a sheet, select the sheet and press Command-A or choose 
Edit > Select All.

m To select an object that’s part of a group, you must first ungroup the objects. Select the 
group, and then choose Arrange > Ungroup.

m To deselect objects in a group of selected objects, hold down the Command key, and 
then click objects you want to deselect.
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Copying or Duplicating Objects
The technique you use to copy an object depends on where you want to place the 
copy. When the copy will be far from the original or in another sheet or spreadsheet, 
copying and pasting is generally easier. When you're working with an object that is 
near the original, duplicating is generally easier. 

Here are ways to copy objects:
m To copy and paste an object, select it, and then choose Edit > Copy. Click the sheet in 

which you want the copy to appear. Choose Edit > Paste.

m To copy an object within the same sheet, you can hold down the Option key while you 
drag the object.

You can also duplicate the object. Select the object and choose Edit > Duplicate. The 
copy appears on top of the original, slightly offset. Drag the copy to the desired 
location.

m To copy an image between Numbers spreadsheets, select the image and drag its icon 
from the File Info field in the Metrics Inspector to a sheet in the other Numbers file.

You can also use Edit > Copy and Edit > Paste. 

Deleting Objects
Deleting objects is quick and easy. 

To delete objects:
m Select the object(s) and press the Delete key.

If you accidentally delete an object, choose Edit > Undo Delete.

Moving Objects
You can drag objects or cut and paste them to move them. 

Here are ways to move objects:
m Click the object to select it (the selection handles appear), and then drag it to a new 

location.

m To constrain the object’s motion to horizontal, vertical, or a 45 degree angle, start 
dragging the object while holding down the Shift key.

m To move the object in small increments, press one of the arrow keys, causing the object 
to move a point at a time. To move the object ten points at a time, hold down the Shift 
key while pressing an arrow key.

m To show the position of the object when you move it, choose Numbers > Preferences, 
and then select “Show size and position when moving objects” in the General pane. 
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m To precisely align objects by their edges or centers, you can use alignment guides. See 
“Using Alignment Guides” on page 152 for details.

m Select the object and choose Edit > Cut. Place the insertion point where you want the 
object to appear, and then choose Edit > Paste.

Avoid dragging an object by the selection handles because you may inadvertently 
resize the object.

Moving an Object Forward or Backward
When objects overlap or when text and objects overlap, you can change the order of 
objects in the stack. 

To move an object in front or in back of text or another object:
1 Select the object you want to move.

2 To move an object a layer at a time, choose Arrange > Bring Forward or Arrange > 
Send Backward.

3 To move an object to the very top or bottom of the stack, choose Arrange > Bring to 
Front or Arrange > Send to Back.

If you frequently layer objects, you can add the Front, Back, Forward, and Backward 
buttons to the toolbar to work more efficiently. To learn about customizing the toolbar, 
see “The Toolbar” on page 24.

Aligning Objects
There are various ways to align objects.

Aligning Objects Relative to Each Other
You can quickly align objects relative to one another if they appear on the same page. 

To align objects:
1 Select the objects you want to align.

2 Choose Arrange > Align Objects, and then choose one of the alignment options in the 
submenu.

Left:  Positions objects so that their left edges align vertically to the first object you 
select.

Center:  Positions objects so that their centers align vertically to the first object you 
select.

Right:  Positions objects so that their right edges align vertically to the first object you 
select.

Top:  Positions objects so that their top edges align horizontally to the first object you 
select.
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Middle:  Moves objects vertically so that their centers align horizontally to the first 
object you select.

Bottom:  Positions objects so that their bottom edges align horizontally to the first 
object you select.

You can also align objects relative to one another by dragging them and using 
alignment guides to determine when the objects are correctly positioned. See “Using 
Alignment Guides” for more information.

Spacing Objects Evenly on a Page
You can quickly place an equal amount of space between objects, regardless of their 
size.

To space objects evenly:
1 Select the objects.

2 Choose Arrange > Distribute Objects, and then choose an option from the submenu.

Horizontally:  Adjusts the horizontal spacing between objects.

Vertically:  Adjusts the vertical spacing between objects.

Using Alignment Guides
You can turn on alignment guides to help you align objects on a sheet. 

Alignment guides will appear when the center or edge of an object aligns with the 
center or edge of another object, depending upon your preferences. 

Alignment guides aren’t visible when you print your spreadsheet; they are visible only 
when you’re editing a spreadsheet.

To set up alignment guides:
1 Choose Numbers > Preferences, and then click General. 

2 To show or hide guides when an object’s center aligns with another object, select or 
deselect “Show guides at object center.”

3 To show or hide guides when an object’s edges align with another object, select or 
deselect “Show guides at object edges.”

4 To change the color of alignment guides, click the color well and select a color in the 
Colors window.

Alignment guide settings apply to all spreadsheets viewed in Numbers until you 
change the settings again.

To temporarily hide alignment guides, hold down the Command key while you drag an 
object.

You can also create your own alignment guides to help you place objects.
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Creating New Alignment Guides
You can create your own alignment guides to help you place objects.

To create an alignment guide:
1 If you’re editing text in an object or if you’re editing the content of a table cell, select an 

object or click the canvas.

2 Click View in the toolbar, and then choose Show Rulers.

3 Place the pointer over a ruler, click, and drag onto the page. An alignment guide 
appears.

4 Drag the guide where you want it on the page.

To remove an alignment guide that you’ve created, drag it off the edge of the page.

Setting Precise Positions of Objects
You use the Metrics Inspector to precisely locate objects. 

To set the precise position of an object:
1 Select the object you want to position.

2 Click Inspector in the toolbar, and then click the Metrics Inspector button.

3 Enter X and Y values in the Position fields.

The specified coordinates determine the position of the upper-left corner of the 
object’s container box.

Â The X value is measured from the left edge of the layout.
Â The Y value is measured from the top edge of the layout.

If an object is rotated, the X and Y coordinates specify the upper-left corner of the 
rotated container box.

When you enter X and Y coordinates for line positions in the Metrics Inspector, the Start 
coordinates represent the first endpoint you created. If you later flip or rotate the line, 
the Start coordinates continue to represent the first endpoint.

Position a fixed line on 
the page by specifying X 
and Y coordinates for its 
second endpoint.

Position a fixed line on 
the page by specifying X 
and Y coordinates for its 
first endpoint.
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Modifying Objects
You can resize objects, change their orientation, modify their border styles, add 
shadows and reflections to them, and adjust their opacity. 

Resizing Objects
You can resize an object by dragging its handles or typing exact dimensions. 

Here are ways to resize objects:
m To resize an object by dragging, select the object and then drag one of its selection 

handles. To resize an object in one direction, drag a side handle instead of a corner 
handle. 

To resize the object from its center, press the Option key as you drag.

To maintain an object's proportions, hold down the Shift key as you drag. You can also 
click Inspector in the toolbar, click the Metrics Inspector button, and then select 
“Constrain proportions” before dragging.

To show the size of an object when you drag a selection handle, choose Numbers > 
Preferences, and then select “Show size and position when moving objects” in the 
General pane. 

m To resize an object using exact proportions, select the object, click Inspector in the 
toolbar, click the Metrics Inspector button, and then use the Width and Height controls. 

m To resize several objects at once, select the objects, click Inspector in the toolbar, click 
the Metrics Inspector button, and then type new values in the Width and Height fields.

m Select the object, and then click Original Size in the Metrics Inspector.

Flipping and Rotating Objects
You can flip or rotate any object. For example, if you have an image of an arrow that 
you want to use in your spreadsheet, but you need it to point in a different direction, 
you can reverse its direction vertically or horizontally, or point it at any angle. 

Here are ways to change an object’s orientation:
m To flip an object horizontally or vertically, select the object, and then choose Arrange > 

Flip Horizontally or Arrange > Flip Vertically.

You can also click Inspector in the toolbar, click the Metrics Inspector button, and then 
use the Flip buttons.

m To rotate an object, select the object, hold down the Command key and move the 
pointer toward a selection handle until it changes to a curved, double-headed arrow, 
and then drag a selection handle.

To rotate an object in 45-degree increments, press the Shift and Command keys while 
dragging a selection handle.
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You can also click Inspector in the toolbar, click the Metrics Inspector button, and then 
drag the Rotate wheel or use the Angle controls to set the angle of the object.

m To rotate a shape but keep its text horizontal, after rotating the shape choose Format > 
Shape > Reset Text and Object Handles.

Changing the Style of Borders
For shapes, chart elements, and text boxes, you can choose a line style and color for the 
object’s border, or you can specify no border. You can also put a border around 
imported images. 

You can use the Format Bar to change the line style, line thickness, and line color of the 
border around one or more selected objects.

You can use the Graphic Inspector to make additional adjustments.

To change the border style by using the Graphic Inspector:
1 Select the object(s) that you want to modify.

2 Click Inspector in the toolbar, and then click the Graphic Inspector button. 

3 Choose Line from the Stroke pop-up menu.

4 Choose a line style from the pop-up menu.

5 To change the line thickness, type a value in the size field (or click the arrows).

6 To change the line color, click the color well and select a color.

7 To give a line endpoints, such as arrowheads or circles, choose left and right endpoints 
from the pop-up menus.

To change table and table cell borders, follow the instructions in “Formatting Table Cell 
Borders” on page 75.

Choose a line style.

Choose a line width.

Choose a line color.

Enter the line thickness in 
this field.

Choose line endpoints from 
these pop-up menus.

Choose a solid line,
dotted line, dashed line,

or another line style.

Click the color well to 
choose a line color.
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Framing Objects
Enclose your images, shapes, text boxes, movies, and media placeholders with 
graphical borders, known as picture frames.

Here are ways to work with picture frames:
m To add a picture frame, select the object, click Inspector in the toolbar, and then click 

the Graphic Inspector button. 

Choose Picture Frame from the Stroke pop-up menu, and then click the thumbnail to 
choose one. Click the Color well to choose a color for the picture frame.

Some picture frames can be adjusted. To adjust your frame, use the Scale slider or type 
a specific percentage in the adjacent field.

m To change a picture frame, select a framed media or media placeholder, click Inspector 
in the toolbar, and then click the Graphic Inspector button. Choose Picture Frame from 
the Stroke pop-up menu, and then click the arrow next to the thumbnail to choose a 
new picture frame.

m To remove a picture frame from your media or media placeholder, select the media or 
media placeholder and then choose a line style (or None) from the Stroke pop-up 
menu.

Adding Shadows
Shadows give your objects an appearance of depth. An object’s shadow appears on 
any object behind it. You can create a variety of shadow effects, or remove the shadow 
from an object.

Click to open a pop-up 
menu that lets you choose 
a picture frame style.
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To quickly add or remove a shadow, you can select the object and then select or 
deselect Shadow in the Format Bar. The Graphic Inspector gives you more extensive 
control over shadow formatting.

To add a shadow to an object using the Graphic Inspector:
1 Select the object.

2 Click Inspector in the toolbar, and then click the Graphic Inspector button. 

3 Select Shadow to add a shadow to the object. Deselect Shadow to make a shadow go 
away.

4 Set the angle for the shadow using the Angle controls.

5 To set how far the shadow is from the object, use the Offset controls. A high shadow 
offset value makes an object’s shadow appear longer and slightly separated from the 
object.

6 To adjust the softness of the shadow’s edge, use the Blur controls. A high blur value 
makes the object’s shadow appear more diffuse; a low value gives the shadow more 
sharply defined edges.

7 To change the shadow’s transparency, use the Opacity controls. Don’t use the Opacity 
slider at the bottom of the Graphic Inspector, which is for controlling the opacity of the 
object itself.

8 To change the color for the shadow, click the Shadow color well and select a color.

You can also use the Graphic Inspector shadow controls to add shadows to text. Select 
the text to which you want to add shadows, and use the controls as described above.

Change the shadow
color in the color well.

Select the checkbox 
to add a shadow to a 
selected object.

Change the angle of 
the shadow with the 
Angle wheel.

Offset, Blur, and Opacity 
values can change the 
look of the shadow.

This object has
the default shadow

properties.

This object’s shadow is
set to a different angle.

This object’s shadow has 
a high offset value.

This object’s shadow has 
the lowest blur factor.

This object has a different 
shadow color.

This object’s shadow has 
a high blur factor.
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Adding a Reflection
You can add a reflection to an object that reflects vertically downward. 

You can add or remove a reflection by selecting an object and then selecting or 
deselecting Reflection in the Format Bar. Using the Graphic Inspector, you can also 
control the amount of reflection.

To add a reflection to an object using the Graphic Inspector:
1 Select the object.

2 Click Inspector in the toolbar, and then click the Graphic Inspector button. 

3 Select Reflection and drag the slider to increase or decrease the amount of reflection.

Adjusting Opacity
You can create interesting effects by making objects more opaque or less opaque. 

When you put a low-opacity object on top of another object, for example, the bottom 
object shows through the top object. Depending on how high or low you set the 
opacity, the objects below can be highly visible, partly obscured, or completely blocked 
from view (at 100-percent opacity). 

Here are ways to change a selected object’s opacity:
m Use the Opacity pop-up menu in the Format Bar to choose an opacity percentage.

m For finer control, click Inspector in the toolbar, click the Graphic Inspector button, and 
drag the Opacity slider or enter a percentage in the adjacent field. 



Chapter 8    Working with Shapes, Graphics, and Other Objects 159

 

For shapes, you can set opacity for fill and stroke colors separately from object opacity. If 
you move the Opacity slider in the Colors window to modify a fill or stroke color, that 
opacity value becomes maximum object opacity. Then, when you change the object 
opacity in the Graphic Inspector, you are changing it relative to the opacity you set in 
the Colors window.

 

If you change an object's opacity and then can't restore the object's fill color to 100%, it 
may be because the opacity was set to less than 100% in the Colors window. To fix it, 
select the object, choose View > Show Colors, and then set the opacity in the Colors 
window to 100%.

Grouping and Locking Objects
Group objects you want to keep together, and lock objects you don’t want to 
inadvertently move. 

Grouping and Ungrouping Objects
You can group objects (except tables) together so that they can be moved, copied, 
resized, and oriented as a single object. You can edit text associated with a shape or 
text object in a group, but you can’t modify other attributes of individual objects in the 
group. 

To group objects:
1 Hold down the Command (or Shift) key as you select the objects you want to group. 

The objects can’t be locked.

2 Choose Arrange > Group. 

To ungroup a grouped object, select the group, and then choose Arrange > Ungroup. If 
the group is locked, unlock it first.

This circle is set to 100% opacity in the 
Graphic Inspector. The fill color was set 
to 50% opacity in the Colors window. 
The circle’s outline was set to 100% 
opacity in the Colors window.

This circle is set to 
100% opacity in the 
Graphic Inspector.

This circle is set to 50% opacity 
in the Graphic Inspector.
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Locking and Unlocking Objects
You can lock objects to avoid inadvertently moving them as you work. 

After you lock individual or grouped objects, you can’t move, delete, or modify them 
until you unlock them. A locked object can be selected, copied, or duplicated; when 
you copy or duplicate a locked object, the new object is also locked.

To lock objects:
1 Hold down the Command (or Shift) key as you select the objects you want to lock.

2 Choose Arrange > Lock.

To unlock an object, select the object, and then choose Arrange > Unlock.

Filling Objects
Fill an object with a solid color, a color gradient, or an image.

Filling an Object with Color
Use the Format Bar to quickly add a fill color to a selected object. Click the Fill well and 
then choose a color from the color matrix or click Show Colors to open the Colors 
window for more choices. Use the Opacity control to adjust the degree of color 
transparency.

Use the Graphic Inspector to fill an object with a solid color or a color gradient, in 
which two colors gradually blend with each other. 

To change an object’s fill color by using the Graphic Inspector:
1 Select the object.

2 Click Inspector in the toolbar, and then click the Graphic Inspector button.

3 To apply a solid fill color, choose Color Fill from the Fill pop-up menu. Click the color 
well below the Fill pop-up menu to open the Colors window, and then select a color in 
the Colors window.

4 To fill an object with a color gradient, choose Gradient Fill from the Fill pop-up menu. 
Click each color well and choose each color in the Colors window.

To set a direction for the gradient, use the Angle wheel or field. To flip it horizontally or 
vertically, click the Angle arrow buttons.
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To invert the gradient, click the double-headed arrow next to the color wells.

Instructions for using the Colors Window follow.

Using the Colors Window
You use the Colors window to select color for objects.

You can use the color wheel in the Colors window to select colors. The color you select 
appears in the box at the top of the Colors window. You can save that color for future 
use by placing it in the color palette.

To apply the colors you select in the Colors window to an object on the page, you must 
place the color in the appropriate color well in an Inspector pane. You can select a color 
well in one of the Inspectors, and then click a color in the color wheel. Or you can drag 
a color from the color palette or color box to a color well in one of the Inspectors.

Click each color well
to select colors.

Flip the gradient orientation or 
set its direction by using the 
arrow buttons or the Angle 
wheel, or by typing a value.

Click the double-headed 
arrow to invert the gradient.

The color selected in the color 
wheel appears in this box. (The 
two colors in this box indicate the 
opacity is set to less than 100%.)

Use the slider to set lighter or 
darker hues in the color wheel.

Drag colors from the color box to 
store them in the color palette.

Click to select a color
in the color wheel.

Drag the Opacity slider to the left to 
make the color more transparent.

Click the Search icon
and then click any
item on the screen
to match its color.

Click a button to view
different color models.
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To select a color:
1 Open the Colors window by clicking Colors in the toolbar or clicking a color well in one 

of the inspectors.

2 Click anywhere in the color wheel. The selected color is displayed in the color box at 
the top of the Colors window.

3 To make the color lighter or darker, drag the slider on the right side of the Colors 
window.

4 To make the color more transparent, drag the Opacity slider to the left or enter a 
percentage value in the Opacity field. 

5 To use the color palette, open it by dragging the handle at the bottom of the Colors 
window. Save a color in the palette by dragging a color from the color box to the color 
palette. To remove a color from the palette, drag a blank square to the color you want 
to remove.

6 To match the color of another item on the screen, click the magnifying glass to the left 
of the color box in the Colors window. Click the item on the screen whose color you 
want to match. The color appears in the color box. Select the item you want to color in 
the spreadsheet, and drag the color from the color box to the item.

Filling an Object with an Image
You can fill a shape, text box, table, table cell, chart background, or chart series with an 
image.

To fill an object with an image:
1 Select the object you want to fill with an image.

2 If the Graphic Inspector isn’t open, click Inspector in the toolbar and click the Graphic 
Inspector button.

3 In the Graphic Inspector, choose Image Fill or Tinted Image Fill, and then choose an 
image. 

You can also drag an image file from the Finder or Media Browser to the image well in 
the Graphic Inspector or directly to a table cell or chart series. 

Use the pop-up menu to 
set the size of the image 
within the object.

To change the image, 
drag an image to the 
image well.
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4 Choose an image scale from the pop-up menu.

Scale To Fit:  Resizes the image to fit the object’s dimensions as well as possible. If the 
object’s shape is different from the original image’s, parts of the image may not appear; 
blank space may also appear around the image.

Scale To Fill:  Makes the image appear larger or smaller, sizing it to leave minimum space 
around the image, even if the object and image have different shapes.

Stretch:  Sizes the image to fit the object’s dimensions but distorts it if the object has a 
shape different from the original image.

Original Size:  Places the image inside the object without altering its original 
dimensions. If the image is larger than the object, you see only a part of the image in 
the object. If the image is smaller than the object, there is blank space around it.

Tile:  Repeats the image inside the object, if the image is smaller than the object. If the 
image is larger than the object, you see only part of the image inside the object.

5 To place a transparent tint over the image, choose Tinted Image Fill from the Fill pop-
up menu.

Click the color well next to the Choose button, and then select a tint color in the Colors 
window. Drag the Opacity slider in the Colors window to make the tint darker or 
lighter. (If you drag the Opacity slider in the Graphic Inspector, it will change the 
opacity of both the tint and the image.)

Scale to Fill

Tile (large image)

Original Size

StretchScale to Fit

Tile (small image)

Tile (large image)

Click to select a tint color 
for the image.
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Using Shapes
Numbers comes with predrawn shapes. You can also create your own custom shapes.

Adding a Predrawn Shape
You can insert predrawn shapes, such as triangles, arrows, circles, and rectangles, to use 
as simple graphics.

Here are ways to add a predrawn shape:
m Click Shapes in the toolbar, and then choose a shape from the Shapes submenu. 

You can also choose Insert > Shape > shape type.

m You can also draw a shape. Option-click Shapes in the toolbar, release the Option key, 
choose a shape, and then drag the crosshair pointer across the sheet to create a shape 
that’s the size you want.

To constrain the shape (for example, to keep triangles equal on all sides), press the Shift 
key as you drag.

Adding a Custom Shape
You can use the Draw tool to create your own shapes. 

To create a custom shape:
1 Click Shapes in the toolbar, and then select the Draw tool icon. You can also choose 

Insert > Shape > Draw a Shape.

The pointer changes from an arrow to a small pen tip. 

2 Click anywhere on a sheet to create the first point of the custom shape.

3 To create a second point and connect it with the first point using a straight line, click a 
second location. 

To create a curved segment instead of a straight one, click in the second location and 
then drag the mouse to change the curve angle or extend the curve. Release the 
mouse when you’re satisfied with the curve.

The line that connects the two points has the default stroke style for the template 
you’re using. You can change the line into another kind of line later using the Stroke 
settings in the Graphic Inspector. 
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4 Repeat step 3 to create additional points as required. Every time you add a new point, 
Numbers connects it with the preceding point using a line with the current stroke and 
with the first point using no stroke, and fills the shape with the default fill color for the 
template you’re using. You can change the fill color later using the Fill settings in the 
Graphic Inspector.

To delete a segment you’ve just created, press Delete. Pressing Delete again removes 
the preceding segment, too.

5 To stop drawing and close the shape (add a solid line between the last and first points), 
click the first point.

To stop drawing and leave the shape open (no line between the last and first points) so 
that you can work with it more later, press the Esc (Escape) key or double-click the last 
point created. 

To finish and close an open shape, click once in the shape to select it, and then click it a 
second time to show its points. Double-click one of the two points at either end of the 
open segment. The pointer changes to a pen tip.

If you want to add additional points, click other locations as needed. When you’re ready 
to stop drawing and close the shape, click the point at the end of the open segment.

Making Shapes Editable
Before you can edit the points of a shape, you need to make the shape editable. 

Here are ways to make shapes editable:
m To edit individual points of a predrawn shape, select the shape and then choose 

Format > Shape > Make Editable.

Red dots appear on the shape. Drag the points to edit the shape. Later, to edit a 
predrawn shape that has been made editable, click it twice slowly.

m To make a custom shape editable, click once in the shape to select it, and then click a 
second time to show its points.

Here’s the open segment.
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Manipulating Points of a Shape
You can change the contour of a shape by adding, moving, or deleting its points. First 
you need to make the shape editable, as described in “Making Shapes Editable” on 
page 165. 

Here are ways to manipulate a shape’s points:
m To add a point, make the shape editable, press the Option key, and hold the pointer 

over the shape’s border. The pointer changes into a pen tip with a plus sign (+). Click 
the location on the border where you want to add a point, and move the point if 
needed.

m To move a point, make the shape editable, click the point, and then drag it to another 
location. You can move several points at the same time by Shift-clicking multiple points 
and then dragging. 

m To delete a point, make the shape editable, click the point, and then press the Delete 
key. You can delete several points at the same time by Shift-clicking multiple points 
and then pressing Delete.

Reshaping a Curve
You can expand or contract a curve, or change its angle. 

To reshape a curve:
1 Make the shape editable.

2 Click a red circular control on the curve you want to reshape. A control handle appears 
on both sides of the circular control.

Click a point and drag it 
to change the shape.

Drag a control handle 
or rotate one or both 
control handles to 
change the curve.

You can also drag a point 
to modify the curve.
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3 To expand or contract the curve, drag the circular control or one of the control handles.

4 To change the angle of the curve, move the control handles clockwise or counter-
clockwise. You achieve different effects when you move the handles together or 
independently of each other. Experiment until you achieve the desired effect.

To move the control handles together, press the Option key, and then drag one or the 
other of them. 

To move only one control handle, press the Command key before dragging a handle.

Reshaping a Straight Segment
You can change the angle between two segments, or change the length of a segment. 

To reshape a straight segment:
1 Make the shape editable.

2 Click a corner point.

3 To change the angle between the two attached segments, drag the point clockwise or 
counter-clockwise.

4 To change the length of one of the segments, drag the point out or in.

Transforming Corner Points into Curved Points and Vice Versa
You can change one or more points into curves or curves into points. 

Here are ways to transform corner points into curved points and vice versa:
m To change a corner point into a curved point, make the shape editable, and then 

double-click the corner point.

m To change a curved point into a corner point, make the shape editable, and then 
double-click the curved point.

m To change all corner points in one or more shapes into curved points, make the shapes 
editable, select the shape(s), and then choose Format > Shape > Smooth Path. 

m To change all curved points in one or more shapes into corner points, make the shapes 
editable, select the shape(s), and then choose Format > Shape > Sharpen Path.

After a shape is editable, you can use the Smooth Path and Sharpen Path commands 
without making the shape editable again.
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Editing Specific Predrawn Shapes
Some predrawn shapes have special built-in editing controls. 

Editing a Rounded Rectangle
The rounded rectangle has a circular control that lets you change the corners. 

To edit a rounded rectangle:
m Select the shape, and drag its circular control to the left to straighten the corners and 

to the right to round them.

Editing Single and Double Arrows
The arrows have three special controls. 

Here are ways to edit single and double arrows after selecting them:
m Drag the selection handle on the arrow’s tail or arrowhead to increase or decrease the 

tail’s length and width without changing the shape of the arrowhead.

m Drag the circular control up or down to change the width of the tail.

m Drag the circular control left or right to resize the arrowhead.

Drag to straighten or 
round the corner.

Drag to change
the tail length.

Drag up or down to 
change the width of the 
tail. Drag left or right to 
resize the arrowhead.
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Editing a Star
The star shape has a slider for increasing and decreasing the number of points in the 
star and a circular control for changing the angles between points. 

Here are ways to edit a star:
m When you select a star shape, the slider appears. Drag the slider to increase or decrease 

the number of points in the star.

m Drag the circular control to change the angles between points in the star.

Editing a Polygon
The polygon has a slider for increasing and decreasing the number of sides in the 
polygon. 

To edit a polygon:
m When you select the polygon, the slider appears. Drag the slider to increase or 

decrease the number of sides in the polygon.

Drag to change the angles 
between points in the star.

View the number of points 
currently in the star.

Drag to increase or 
decrease the number 
of points in the star.

Drag to increase or 
decrease the number of 
sides in the polygon.

View the number of sides 
currently in the polygon.
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Using Media Placeholders
Some Numbers templates contain media placeholders. You can drag your own images, 
movies, and audio files to these placeholders, and your media file is automatically sized 
and positioned for you. You can easily replace an item in a media placeholder by 
dragging a new file to it; you don’t have to delete the old file first.

You can recognize a media placeholder by letting the pointer rest over it; a help tag 
appears instructing you to drag your own image into its place.

Here are ways to work with media placeholders:
m Drag a file from the Media Browser, Finder, or other application to the media 

placeholder.

To open the Media Browser, click Media in the toolbar. Click a button at the top of the 
window to look for photos, audio files, or movies.

m To change the content of a media placeholder, drag a new media file to the existing 
content.

Second, choose a source.

First, click a button to 
access your media files. 

Third, drag an item to the 
document or to an image 
well in one of the 
Inspectors.

Search for a file by typing 
its name here.
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m To convert a placeholder image into an ordinary image, select the image, choose 
Format > Advanced, and then deselect “Define as Media Placeholder” in the submenu. 
To replace an ordinary image, you must first delete it.

m To delete a media placeholder, select it and press the Delete key.

m To create a media placeholder, follow the instructions in “Creating Media Placeholders 
for a Custom Template” on page 191.

Working with Images
Numbers accepts all QuickTime-supported formats, including the following graphics 
file types:
Â TIFF
Â GIF
Â JPEG
Â PDF
Â PSD
Â EPS
Â PICT

After importing an image into a spreadsheet, you can mask (crop) it and change its 
brightness and other settings. You can place an image inside a shape, text box, chart 
element, or table cell. Numbers also lets you work with graphics with transparency 
(alpha-channel graphics). 

Importing an Image
Import an image directly from the Finder or from the Media Browser. 

Here are ways to import an image file:
m Drag an image file from the Finder to the spreadsheet and position it where you want 

it.

m Click Media in the toolbar, click Photos in the Media Browser window, select the album 
where your picture is located, and then drag a thumbnail to position it where you want 
it.

m Choose Insert > Choose, select the file, and then click Insert. Drag the image to position 
it where you want it.

m To add an image file using a media placeholder, see “Using Media Placeholders” on 
page 170.
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Masking (Cropping) Images
You can crop images without actually changing the image files by masking parts of 
them. 

Cropping an Image Using the Default (Rectangular) Mask
You can use a rectangular mask to define the boundaries of an image. 

To crop an image using the default (rectangular) mask:
1 Import the image you want to mask (see “Importing an Image” on page 171 for 

instructions).

2 Select the image, and then choose Format > Mask. A resizable mask appears over the 
image, and some controls appear.

3 To resize the image, move the slider left or right.

4 Refine the mask.

Drag the selection handles to resize the mask. To constrain the mask’s proportions, hold 
down the Shift key as you drag the selection handles.

To rotate the mask, hold down the Command key as you drag a corner selection 
handle.

Place the mask over the part of the image you want to show. You can click at the edge 
of the selected mask and drag the mask. Or you can click in the image outside the 
mask and drag the image.

5 To make only the area under the mask visible, double-click the mask, press Return, click 
outside the image, or click Edit Mask. The borders of the masked image are dotted 
lines.

6 To resize or rotate the masked image, drag or Command-drag its selection handles.

7 To deselect the image and hide the mask controls, click outside the image.

To view the whole image, double-click it. To edit the mask, click Edit Mask.

Resize the mask by 
dragging its selection 
handles.

Drag the mask to center 
it over the part of the 
image you want to show.

Drag the slider to resize 
the image.
Click to show or hide the 
area outside the mask.
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Masking an Image with a Shape
You can use a shape to define the boundaries of an image. 

To mask an image with a shape:
1 Select the image and choose Format > “Mask with Shape” > shape.

You can also Shift-click to select a shape and an image, and then click Mask in the 
toolbar (or choose Format > “Mask with Selected Shape”).

2 Drag the image to position the part you want to show. To move the mask, click the 
dotted edge of the mask and drag it.

3 To resize the image, drag the slider above the Edit Mask button.

4 To resize the mask, drag the selection handles.

5 To make only the area under the mask visible, double-click the mask or image, press 
Return, click outside the image, or click Edit Mask. 

6 To resize the masked image, click Edit Mask and drag the selection handles.

7 To deselect the image and hide the mask controls, click outside the image.

To modify a masked image, double-click it.

Note:  If you use a shape containing text as a mask, the text is deleted. To restore the 
text, choose Edit > “Undo Mask with Shape.” 

You can also drag an image to mask a shape with an image.

Unmasking an Image
You can remove a mask and restore the original image.

To unmask an image:
m Select the masked image, and then choose Format > Unmask.

Removing the Background or Unwanted Elements from an Image
The Alpha tool enables you to convert certain colors in an image to transparent. This 
feature is useful for removing an unwanted background or other colors. 

You’ll get the best results removing solid colors with clear boundaries around them. To 
remove areas that are less distinct, select a smaller area and repeat the process.

To remove unwanted elements:
1 Select the image.

2 Choose Format > Instant Alpha.
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3 Click the color you want to make transparent, and then drag slowly over it.

As you drag, the selection grows to include the area that uses the same color. You can 
control how much of the image is selected by dragging less or more.

4 Repeat step 3 as many times as you like.

5 Press Return or click outside the image when you’re done.

You can restore the parts removed from the image at any time. To revert to the original 
image, choose Format > Remove Instant Alpha. To restore parts of the image removed 
using Instant Alpha, choose Edit > Undo Instant Alpha until the parts have been 
restored.

Changing an Image’s Brightness, Contrast, and Other Settings
You can change the brightness, contrast, and other settings of images to improve their 
quality or to create interesting effects. Adjustments you make don’t affect the original 
image; they affect only the image’s appearance in Numbers.

To adjust an image:
1 Select the image.

Dragging selects the
contiguous area that
uses the same color.

Dragging more here...

...selects more of 
the image.
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2 Choose View > Show Adjust Image to open the Adjust Image window.

3 Use the controls to make adjustments.

Enhance button:  Automatically adjusts the image.

Brightness:  Adjusts the lightness of the image.

Contrast:  Adjusts the contrast of light and dark tones. You can make shadows darker, 
sharpen the edges of objects, and make colors stand out more. If you increase the 
contrast of a photo a lot, it looks more like an illustration.

Saturation:  Changes the color intensity.

Temperature:  Introduces more warmth (more orange tones) or coldness (more blue 
tones).

Tint:  Changes the amount of red or green tones in the image.

Sharpness:  Sharpens or softens the image’s focus.

Exposure:  Adjusts shadows and highlights.

The histogram:  Helps you understand the relationship between shadows (depicted on 
the left side of the display) and highlights (depicted on the right side) in your image.

Levels:  Changes the levels of light and dark tones.

Auto Levels:  Has Numbers enhance colors automatically.

Adjust the contrast of light 
and dark tones.

Change the color intensity.
Introduce more

warmth or coolness. Change the amount of red 
or green tones.

Sharpen or soften
the focus.

Adjust shadows and highlights.

Understand the relationship 
between shadows and highlights.

Change the levels of dark 
and light tones.

Restore original settings.

Enhance colors automatically.

Adjust the lightness.
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4 To restore the original settings, click Reset Image. 

To save any changes you made, save the spreadsheet. The settings at the time you save 
the spreadsheet are visible anytime you open the Adjust Image window.

Using PDF Files as Graphics
If you intend to greatly enlarge or reduce a graphic’s dimensions, consider converting it 
to a PDF file before bringing it into Numbers. PDF files don’t lose their crispness when 
they are significantly resized. Other file types may not retain their clarity as well when 
they are enlarged or reduced. 

PDF files also provide a great way to move tabular data from Excel or AppleWorks 
documents into Numbers. If you have extensively formatted tables in Excel or an 
AppleWorks spreadsheet that you want to display in your spreadsheet, you can save 
the spreadsheet as a PDF file and then place that PDF file on a page as you would any 
other external graphics file.

To convert an Excel or AppleWorks file to a PDF file: 
1 In your Excel or AppleWorks spreadsheet, select the table range you want to display in 

your spreadsheet.

2 Choose File > Print.

3 In the Print dialog, choose Save as PDF from the PDF pop-up menu.

4 In the Save dialog, type a name for the PDF file and select a location, and then click 
Save.

You can copy a range of cells in an Excel document and paste the cells and their 
contents directly into your spreadsheet. Numbers creates a new table to hold the Excel 
data.

You can also convert an image to a PDF file by using Grab. Open Grab (it’s in the 
Applications/Utilities folder). Choose Capture > Selection to select what you want to 
create an image of. Choose File > Print to save the image as a PDF.
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Using Sound and Movies
You can add sound, movies, and Flash files to your spreadsheet if it will be viewed 
onscreen as a Numbers file. The movie or sound file plays when you double-clicks its 
icon.

Note:  Some media files are protected under copyright law. Also, some downloaded 
music may be played only on the computer where the download occurred. Make sure 
you have permission to use the files you want to include.

Numbers accepts any QuickTime or iTunes file type, including the following:

Â MOV
Â FLASH
Â MP3
Â MPEG-4
Â AIFF
Â AAC

Important:  To make sure that the movies and other media can be played and viewed 
when your document is transferred to another computer, make sure that “Copy audio 
and movies into document” is selected; after you choose Save or Save As, click the 
disclosure triangle next to the field, and then click Advanced Options.

Adding a Sound File
Add a sound file that plays when you double-click its icon.

Here are ways to add a sound file:
m Drag a sound file from the Finder to a sheet.

m Click Media in the toolbar, click Audio, select an audio file, and then drag the file to the 
sheet.

m To add a sound file using a media placeholder, see “Using Media Placeholders” on 
page 170.

Adding a Movie File
Add a movie file that plays when you double-click it.

Here are ways to add a movie:
m Drag a movie file from the Finder to a sheet.

m Click Media in the toolbar, click Movies, select a file, and then drag it to the sheet.

To see your movies listed in the Movies pane of the Media Browser, you must place 
them in the Movies folder, in iTunes, or in iPhoto.
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m Choose Insert > Choose, select the movie file, and then click Insert.

m To add a movie file using a media placeholder, see “Using Media Placeholders” on 
page 170.

Adjusting Media Playback Settings
In the QuickTime Inspector, you can change such settings as when to start and stop a 
movie, and the frame to display until the movie starts playing. 

To set media playback preferences:
1 Click Inspector in the toolbar, and then click the QuickTime Inspector button.

2 Click the movie or sound object to select it.

3 To start and stop the movie at particular frames or times, drag the Start and Stop 
sliders.

4 To specify which frame of a movie to display until the movie starts playing (called the 
“poster frame”), drag the Poster Frame slider until the movie displays the image you 
want.

5 Choose a repeat option from the Repeat pop-up menu:

None:  Play only once.

Loop:  Repeat continuously.

Loop Back and Forth:  Play backward and forward continuously.

6 To increase or decrease the playback volume, drag the Volume slider to the right or left.

Set the
playback volume.

Set playback repeat options.

Select the frame
to display until the

movie begins playing.

Use these controls to view 
the movie or play sound as 
you edit your spreadsheet.

The QuickTime 
Inspector button

Start and stop a movie at 
particular times.
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9 Adding Address Book Data 
to a Table

This chapter tells you how to add contact information stored 
in Address Book and vCards to a Numbers table.

Address Book fields are a rich source of names, phone numbers, addresses, and other 
data for people. You can use Address Book data to quickly create tables that 
consolidate information you need for business contacts, personal friends, holiday 
correspondents, and so on.

Using Address Book Fields
You can insert data from Address Book fields into Numbers tables. You can also insert 
data from a virtual address card (vCard) that someone has sent you.

When a table has a header row containing names that match Address Book or vCard 
field names, you can add contact data by dragging cards to the table. You can also 
create a new table by dragging cards to the canvas.
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Mapping Column Names to Address Book Field Names
The following table summarizes the Address Book fields that Numbers supports. The 
synonyms are alternative names you can use to add a particular Address Book field 
value. 

Address Book field names Field name synonyms

Prefix Name title, Name prefix

Last name Last, Surname

First name First, Given name, Forename

Suffix Name suffix, Professional suffix, Academic suffix

Nickname

Maiden name

Job title

Department Job department

Company

Phone (first available number)

Main phone

Work phone

Home phone

Mobile Mobile phone, Mobile telephone, Cell phone, Cell telephone, 
Cellular, Cellular phone, Cellular telephone

Home fax

Work fax

Pager Beeper

Other phone

Email (first available address) Email address

Work email

Home email

Other email

URL (first available URL)

Work URL

Home URL

Other URL

Birthday

AIM (first available address) IM, IM handle, IM name, IM address, Chat, Chat handle, Chat name, 
Chat address

Work AIM Work IM, Work IM handle, Work IM name, Work IM address, Work 
chat handle, Work chat name, Work chat address
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Home AIM Home IM, Home IM handle, Home IM name, Home IM address, 
Home chat, Home chat handle, Home chat name, Home chat 
address

Other AIM Other IM, Other IM handle, Other IM name, Other IM address, Other 
chat, Other chat handle, Other chat name, Other chat address

Yahoo

Work Yahoo

Home Yahoo

Other Yahoo

Address

Street address (first available 
street address)

Street

City (first available city) Town

State (first available state)

Zip Zip code, Postal code

Country (first available country)

Work address

Work street address Work street, Work address

Work city Work town

Work state

Work zip Work zip code, Work postal code

Work country

Home Address

Home street address Home street, Home address

Home city Home town

Home state

Home zip Home zip code, Home postal code

Home country

Other address

Other street address Other street, Other address

Other city Other town

Other state

Other zip Other zip code, Other postal code

Other country

Note Notes

Address Book field names Field name synonyms
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Adding Address Book Data to an Existing Table
You can add data from Address Book or from a vCard to an existing table if the table’s 
header row contains names that match the field names listed in “Mapping Column 
Names to Address Book Field Names” on page 180. 

To add contact data to an existing table:
1 Identify the Address Book or vCard fields whose values you want to copy into the table.

2 Make sure the table has a header row whose cells contain supported Address Book or 
vCard field names.

Data in fields that can’t be mapped to a header row cell won’t be added to the table.

3 In Address Book, select one or more contacts or groups and drag them to the table. 

You can also drag one or more vCards to the table.

If necessary to accommodate all the data, rows are added.

If a contact’s data already exists in the table, another row for the contact is still added. 
You can detect duplicate rows using sorting, as “Sorting Table Cells” on page 77 
describes.

Adding Address Book Data to a New Table
You can use data from Address Book or from a vCard to create a new table that 
contains a row for individual contacts. 

Here are ways to create a new table that contains contact data:
m In Address Book, select one or more cards or a group and drag the selection to the 

canvas. 

m Drag one or more vCards to the canvas.

The table contains a column for each Address Book or vCard field named, as “Mapping 
Column Names to Address Book Field Names” on page 180 indicates. However, only 
fields named Last name, First name, Phone, and Email are initially visible; the other 
columns are hidden. To view the hidden columns, choose Table > Unhide All Columns. 
You can delete or rename columns as required.
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10 Sharing Your Numbers 
Spreadsheet

This chapter describes the various ways you can distribute 
your Numbers spreadsheet so others can view or use it.

In addition to printing or faxing your spreadsheet, you can share your spreadsheet 
electronically. By exporting to other document formats, you can collaborate with others 
who use Excel and other applications. You can also send a document directly to iWeb 
to attach it to a blog entry.

Printing a Sheet
You can use Print View to lay out a sheet across pages before printing the sheet. 

To print a sheet:
1 To format a sheet into pages, see “Dividing a Sheet into Pages” on page 39.

2 Select the sheet you want to print.

3 Choose File > Print Sheet.

4 To preview the sheet before printing it, click the Preview button in the Print dialog. The 
sheet opens in Preview, which shows what individual pages will look like when printed. 
For information about using Preview, see Preview Help. Choose Help > Preview Help 
when the Preview window is active.

Select Soft Proof at the bottom-left corner of the Preview window to take your printer’s 
capabilities into account. For example, if you’re printing a color document to a black-
and-white printer, selecting Soft Proof previews the document in black and white.

Click Print to print your sheet directly from the Preview window. Click Cancel, click in 
your sheet, and then choose File > Print Sheet to set up additional printing options.

5 Choose the printer you want to use from the Printer pop-up menu. 
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Type the number of copies you want to print in the Copies field, and then select 
Collated if you want each group of pages to print together in order before printing the 
next group. If you want to print a batch of page 1, then page 2, then page 3, and so on, 
deselect the checkbox.

6 Use the Copies & Pages pop-up menu in the Print dialog to select printing options. You 
can print your sheet in reverse order, print only odd or even pages, print a cover page 
(separator page), and more. 

See “Choosing Printer Layout Options” to learn how to print double-sided and 
“Adjusting the Printed Color with ColorSync” on page 185 to learn how to manage color 
settings.

7 Click Print.

Choosing Printer Layout Options
Print double-sided and set other printer options that control how a sheet is printed. 

To select layout options:
1 Choose File > Print Sheet.

2 Choose Layout from the pop-up menu below the Presets pop-up menu in the Print 
dialog.

3 To print several pages on a single sheet of paper, choose Layout from the pop-up menu 
below the Presets pop-up menu.

Choose the number of pages you want to appear on each page from the “Pages per 
Sheet” pop-up menu. Select a layout direction, and then choose the line style you want 
to separate each printed page from the Border pop-up menu.

Print left to right first, 
then down.

Print pages right to 
left first, then down.

Print pages top to 
bottom first, then 
across to the right.
Print pages top to 
bottom first, then 
across to the left.

See a preview of 
your layout.

Select double-sided 
printing options.

Choose a line style to
separate the pages

when printing multiple
pages per sheet.
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4 To print double-sided, choose Layout from the pop-up menu below the Presets pop-up 
menu, and then select a binding option.

Long-Edge Binding:  Prints the pages for lengthwise binding.

Short-Edge Binding:  Prints the pages for binding on the short side of the paper.

Not all printers can print double-sided. Check the documentation that came with your 
printer.

5 To save your printing options as a preset that you can use later instead of respecifying 
options, choose Save As from the Presets pop-up menu in the Print dialog and then 
type a name for the preset.

To use the same settings in the future, choose the preset’s name from the Presets pop-
up menu.

Adjusting the Printed Color with ColorSync
You can make printed sheets lighter, darker, or sepia-toned, or add other effects by 
adding a Quartz filter to your printer output. The filter uses ColorSync technology to 
modify the printed sheet without modifying the sheet itself. 

Not all printers can print in color. Check the documentation that came with your 
printer.

To adjust the printed color:
1 Choose File > Print Sheet.

2 Choose ColorSync from the pop-up menu below the Presets pop-up menu in the Print 
dialog.

3 Choose an option from the Color Conversion pop-up menu.

Standard:  Uses the default settings in Numbers to control the color management of 
the printed sheet.

In Printer:  Lets the printer you’re using control the color management of the printed 
sheet.

4 Choose an option from the Quartz Filter pop-up menu.

To see a preview of the printed sheet with the Quartz filter you have chosen, click 
Preview.

After you have selected the Quartz filter you want, you can save this setting as part of 
your preset. 
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For more information about ColorSync and Quartz filters, see ColorSync Utility Help by 
opening the ColorSync application (located in Applications/Utilities), and then 
choosing Help > ColorSync Utility Help.

Exporting to Other Document Formats
You can share your Numbers spreadsheets across different platforms by exporting 
them to a file in Excel, PDF, or comma-separated values (CSV) format.

To export a spreadsheet to another file format:
1 Choose File > Export.

2 Choose a document format.

PDF:  PDF files can be created using an image quality of good, better, or best. They can 
be viewed or printed in Preview, viewed or printed in Safari, and edited with a PDF 
application. Choose All Sheets from the Layout pop-up menu to create a PDF that 
shows each sheet on a separate page. Choose Current Sheet from the Layout pop-up 
menu to create a paginated PDF of the selected sheet.

Excel:  These files can be opened and edited in Microsoft Excel on a Mac OS X computer 
or on a Windows computer. Each table is converted to an Excel worksheet, and all other 
objects are placed on separate worksheets if there’s more than one table. If you don’t 
want a summary worksheet included for multi-worksheet exports, select “Never include 
a summary worksheet” in the export dialog. Some of the formula calculations may 
differ in Excel.

CSV:  Many spreadsheet applications can open a file in CSV format. In a CSV file, cell 
values in each row are separated using a comma, and rows are separated using an end-
of-line character. Each table is placed in its own CSV file, and all the files are placed in a 
folder. No graphics are exported. The last calculated values are exported.

3 Click Next.

4 Type a new name for the document.

5 Choose where you want to save the document.

6 Click Export.

The ColorSync Utility icon
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Sending a Spreadsheet to iWeb
If you use (or intend to use) iWeb to create a website, you can send a Numbers 
spreadsheet directly to your iWeb blog or podcast. The spreadsheet becomes an 
attachment that your website visitors can download.

To send a spreadsheet to iWeb:
1 Make sure you have iWeb ’08 or later installed.

2 Open your Numbers spreadsheet, and then choose File > Send to iWeb > PDF or 
choose File > Send to iWeb > Numbers Document.

PDF creates a PDF version of your spreadsheet. 

Numbers Document creates an archive version of your spreadsheet.

3 If iWeb wasn’t open, it opens, and you can choose a new or existing blog or podcast to 
attach your spreadsheet to. If you have only one blog or podcast, the spreadsheet is 
attached to it.

When you publish your website, visitors who subscribe to your blog or podcast will 
automatically get the latest attachments sent to their iTunes library (PDF publish only).

For more information about using iWeb to design and publish webpages, open iWeb 
and choose Help > iWeb Help.
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11 Designing Your Own Numbers 
Spreadsheet Templates

This chapter is for designers who want to create their own 
spreadsheet templates.

This chapter assumes you are already familiar with the features of Numbers described 
in earlier chapters.

Designing a Template
The templates that come with Numbers provide ideas for designing the look of charts, 
tables, and other objects. 

To create your own templates, you can do something as simple as adding your 
company logo to an existing template. Or you can modify these attributes of a 
Numbers template:

Â Table styles
Â Reusable tables available when you click Tables in the toolbar
Â Default formatting for different types of charts
Â Default attributes of text boxes, shapes, and images
Â The number and names of sheets
Â Predefined content on sheets, such as text, tables, and media placeholders

You can also start with a blank spreadsheet and create a new template.

Step 1:  Define Table Styles
A template has one or more table styles that let you format a selected table in a single 
click. Table styles are useful for applying consistent formatting to tables.

You can use or redefine the table styles in a Numbers template, or you can create your 
own styles. See “Using Table Styles” on page 79 to learn how.
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Step 2:  Define Reusable Tables 
A template has one or more reusable tables, which let you add tables that have already 
been styled and sized. They can also contain predefined content, such as formulas and 
text.

When using a template, you add a reusable table by clicking Tables in the toolbar and 
choosing a table from the pop-up menu.

You can use or redefine the reusable tables in a Numbers template, or you can create 
your own. “Defining Reusable Tables” on page 49 provides instructions.

Step 3:  Define Default Charts, Text Boxes, Shapes, and 
Images
A template has default values defined for the following objects, which take effect when 
a template user adds one of them:
Â Charts
Â Text boxes
Â Shapes
Â Imported images

You can use the default settings that already exist in the template you started with, or 
you can change the settings.

Defining Default Attributes for Charts
You can set the default appearance of each chart type. Default attributes must be set 
individually for each chart type.

To set default chart attributes:
1 Place a chart on the page by clicking Charts in the toolbar and choosing a chart type.

2 Select the chart, and then set its attributes. 

To resize a chart, rotate it, and set other attributes that charts have in common, see 
“Formatting General Chart Attributes” on page 106. 

To learn how to format pie charts, bar charts, and other specific chart types, see 
“Formatting Specific Types of Charts” on page 113.

3 Repeat steps 1 and 2 for each chart type for which you want to define default 
attributes.

4 Select a chart, and then choose Format > Advanced > Define Default Style for chart 
type.

Repeat this action for each chart you’re defining default settings for.

5 Delete the charts from the spreadsheet.
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Defining Default Attributes for Text Boxes and Shapes
The default attributes of text boxes and shapes determine their fill, stroke, shadow, and 
opacity when they’re first inserted on a page. Default attributes also determine the 
appearance of text you place in the boxes or shapes.

To define default text boxes and shapes:
1 Add the objects to a sheet.

Click Text Box in the toolbar to add a text box, and click Shapes in the toolbar and 
choose any shape.

2 To set up attributes for text within the text box or shape, select the object, add text to 
it, then format the text attributes. 

See “Formatting Text Size and Appearance” on page 120 for instructions.

3 To set up object attributes, select the text box or shape and then follow the 
instructions in “Modifying Objects” on page 154 and “Filling an Object with Color” on 
page 160.

4 Save the text box and shape as default objects.

To save the text box, select it and then choose Format > Advanced > Define Default 
Text Box Style.

To save the shape, select it and then choose Format > Advanced > Define Default 
Shape Style.

5 Delete the text box and shape from the sheet.

Defining Default Attributes for Imported Images
For imported graphics, you can set default shadows, opacity, borders, and more.

To set default image attributes:
1 Import an image as “Importing an Image” on page 171 describes.

2 Select the image, and then set its attributes. 

To format borders around the image, see “Changing the Style of Borders” on page 155 
and “Framing Objects” on page 156.

To add a shadow, see “Adding Shadows” on page 156 for instructions.

To add a reflection, see “Adding a Reflection” on page 158.

To adjust the image’s transparency, see “Adjusting Opacity” on page 158.

3 Choose Format > Advanced > Define Default Image Style.

4 Delete the image from the page.
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Step 4:  Create Initial Spreadsheet Content
You can use predefined content to model the look of a finished spreadsheet or to 
provide instructions and other productivity aids for template users.

Predefining Tables and Other Objects for a Custom Template
Add tables, charts, text boxes, images, shapes, and other initial content to your 
templates to help users be more productive and to make the objects in the 
spreadsheet visually appealing. 

For example, you can:

Â Add names to tables and titles to charts and their axes
Â Add formulas and other predefined content to table cells
Â Set up cells so their values are displayed in particular ways, for example, using a 

number format or checkboxes
Â Create text boxes or comments that provide instructions and suggestions for using 

the template
Â Use color to heighten the prominence of particular elements in tables and charts

Creating Media Placeholders for a Custom Template
When you drag your own image, movie, or audio file to a media placeholder, your 
media is automatically sized and positioned for you. You can easily replace media in the 
media placeholder by dragging a new file to it; you don’t have to delete the old file 
first.

To create a media placeholder:
1 Add an image, audio file, or movie to the spreadsheet.

See “Importing an Image” on page 171, “Adding a Sound File” on page 177, and “Adding 
a Movie File” on page 177 for instructions.

2 Select the imported object and move it to the location where you want it to be in the 
spreadsheet, as “Moving Objects” on page 150 describes.

3 Format the imported object, as “Modifying Objects” on page 154 describes.

4 Select the object, and then choose Format > Advanced > Define as Media Placeholder.

To delete a media placeholder, select it, and then press the Delete key.
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Predefining Sheets for a Custom Template
Add multiple sheets to a template when it contains content you want to separate into 
groups.

Here are ways to set up sheets for a template:
m You can add sheets to or remove sheets from a Numbers template. See “Adding and 

Deleting Sheets” on page 38 for details.

m To move sheets around and reorder their content, see “Reorganizing Sheets and Their 
Contents” on page 38.

Step 5:  Save a Custom Template
You can save your new template so that it appears in the Template Chooser. 

To save a custom template:
1 Choose File > Save as Template.

2 Type a name for the template.

3 Specify a folder in which to save your template.

By default, it will be saved in your home folder in Library/Application Support/iWork/
Numbers/Templates/My Templates/ and it will appear in the My Templates pane of the 
Template Chooser.

To save it in another location in your home folder, go to Library/Application Support/
iWork/Numbers/Templates/ and create a new folder. The folder name is used as the 
template category in the Template Chooser.

4 Click Save.

To delete a custom template, in the Finder navigate to the folder in which you saved 
the template, and drag the template to the Trash. 
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12 Dictionary of Functions

This chapter describes functions you can use in cell formulas.

This chapter describes each of the functions you can use in a table cell formula. For 
information about using functions in table cell formulas, see “Using Formulas” on 
page 83 and “Using Functions” on page 96.

About Functions
A function is a named operation that you can include in a formula to perform a 
calculation or to manipulate data in a table cell.

Numbers provides 168 functions that do things such as perform common 
mathematical or financial operations, retrieve cell values based on a search, manipulate 
strings of text, or get the current date and time. Each function has a name followed by 
one or more arguments enclosed in parentheses. You use arguments to provide the 
values that the function needs to perform its work.

For example, the following formula contains a function named SUM with a single 
argument (a range of cells) that adds the values in column A, rows 2 through 10:

=SUM(A2:A10)

The number and types of arguments vary for different functions. Possible arguments 
include:

Â Constants, such as a number, a text string, or Boolean TRUE or FALSE—for example, 
CONCATENATE(“cat”, “s”)

Â A calculation, including a Boolean value—for example, OR(4<1, 5<6)
Â The address of a table cell or a range of cells—for example, LOOKUP(5, C2:C6, D2:D6)
Â Another function—for example, WEEKDAY(TODAY()).

Note:  Character strings are ignored in functions that use values to perform calculations.
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The following table defines terms that are commonly used in function descriptions. 

There are several categories of functions. For example, some functions perform 
calculations on date and time values, logical functions give a Boolean (TRUE or FALSE) 
result, and other functions perform financial calculations. Following a brief introduction 
to the function categories, this chapter defines each function individually, in 
alphabetical order by function name.

Term or symbol Meaning

italic An argument you replace with an actual value or a reference to a 
cell containing a value.

commas and semicolons The syntax descriptions for functions use commas to separate 
arguments. If your International System Preferences are set up to 
use the comma as a decimal separator, separate arguments using a 
semicolon instead of a comma.

[ brackets ] Surround an optional argument. If you omit an optional argument 
in the middle of a list of arguments, be sure to include the 
separator that precedes the missing argument. For example, to 
omit the second argument, arg2, from a list of three arguments, 
you would type FUNCTION(arg1, , arg3).

. . . (ellipses) The preceding argument can be repeated as many times as 
necessary.

integer A number with no fractional part.

logical expression An expression that has the Boolean value TRUE or FALSE.

numeric expression An expression that produces a number.

string A contiguous sequence of characters.

text expression An expression that produces a string.

date-time Any Numbers date/time value. While you can choose to display 
only date or time in a cell, all Numbers date or time values contain 
both the date and time.
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Date and Time Functions
The date and time functions perform calculations on date, time, or numeric 
expressions.

Numbers includes these date and time functions.

Function Description

DATE (page 224) Combines individual year, month, and day numbers into a single 
date.

DATEDIF (page 225) Finds the time interval between two dates.

DAY (page 226) Extracts the day number from a date.

EDATE (page 229) Finds the date some number of months before or after a given 
date.

HOUR (page 235) Extracts the hour (in the range 0 through 23) from a date.

MINUTE (page 250) Extracts the minutes from a date.

MONTH (page 251) Extracts the month number from a date.

NOW (page 253) Gets the current date and time from the computer’s clock.

SECOND (page 271) Extracts the seconds from a date.

TIME (page 281) Converts hours, minutes, and seconds into a time format.

TIMEVALUE (page 282) Converts a date, a time, or a text string to a decimal fraction of a 
24-hour day.

TODAY (page 282) Gets the current system date and formats the cell to display the 
date but not the time.

WEEKDAY (page 289) Converts a date to a number representing the day of the week.

YEAR (page 289) Extracts the year number from a date.
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Financial Functions
These functions operate on numbers and require numeric expressions as arguments. 
Unless otherwise stated, these functions return numeric values.

Numbers provides these financial functions.

Function Description

ACCRINT (page 205) Calculates the total accrued interest for a security that pays 
periodic interest.

ACCRINTM ()page 206 Calculates the total accrued interest for a security that pays interest 
at maturity.

COUPDAYBS (page 221) Counts the number of days from the beginning of the coupon 
period in which settlement of a security occurs to the settlement 
date.

COUPDAYS (page 221) Counts the number of days in the coupon period in which 
settlement of a security occurs.

COUPDAYSNC (page 222) Counts the number of days from the settlement date of a security 
to the end of the coupon period in which settlement occurs.

COUPNUM (page 223) Counts the number of coupons to be paid on a security between 
the settlement date and the maturity date.

DB (page 226) Calculates the depreciation of an asset for a specified period using 
the fixed-declining balance method.

DDB (page 227) Calculates the depreciation of an asset based on a specified 
depreciation rate. If you don’t specify a rate, it defaults to the 
double-declining balance method.

DISC (page 228) Calculates the discount rate of a security.

FV (page 233) Calculates the future value of an investment, given a series of fixed, 
periodic added payments, the interest rate, and the number of 
periods.

IPMT (page 239) Calculates the interest portion of a payment for a loan or 
investment based on periodic fixed payments and a fixed interest 
rate.

IRR (page 240) Calculates the internal rate of return for an investment that is based 
on a series of cash flows.

ISPMT (page 242) Calculates the interest due for a particular payment period of an 
investment.

MIRR ()page 250 Calculates the modified internal rate of return of a series of periodic 
cash flows.

NPER (page 253) Calculates the number of payment periods for a loan or investment 
based on fixed payments and a fixed interest rate.
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NPV (page 254) Calculates the net present value of an investment based on a series 
of future cash flows and a fixed interest rate.

PMT (page 257) Calculates fixed, periodic payments given a fixed interest rate, a 
number of periods, the present value, the future value, and the 
type of payments.

PPMT (page 258) Calculates the principal portion of a payment for a loan or 
investment based on periodic fixed payments and a fixed interest 
rate.

PRICE (page 259) Calculates the price for a security that pays periodic interest per 
$100 par value.

PRICEDISC (page 260) Calculates the price of a discounted security per $100 par value.

PRICEMAT (page 260) Calculates the price of a security that pays interest at maturity per 
$100 par value.

PV (page 262) Calculates the present value of an investment, given a series of 
fixed, periodic payments and a fixed interest rate.

RATE (page 265) Calculates the interest rate of an annuity (a fixed sum paid 
periodically over a specified period of time).

SLN (page 272) Calculates the straight-line depreciation of an asset during a 
period.

SYD (page 279) Calculates the sum-of-years’-digits depreciation of an asset during 
a particular period.

VDB (page 287) Calculates the depreciation of an asset over a chosen time interval.

Function Description
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Logical Functions
The logical functions evaluate the logical truth or falsehood of expressions and return 
TRUE, FALSE, or a value assigned by the function.

Numbers provides these logical functions.

Information Functions
Information functions return information about the contents of a cell or argument.

Numbers provides these information functions.

Function Description

AND (page 208) Returns TRUE if all arguments are true and FALSE otherwise.

FALSE (page 231) Returns the value FALSE for compatibility with older spreadsheet 
applications.

IF (page 236) Returns one of two values depending on whether a specified 
expression is TRUE or FALSE.

NOT (page 252) Returns the negation of an expression’s Boolean value.

OR (page 255) Returns TRUE if any argument is true.

TRUE (page 283) Returns the value TRUE for compatibility with older spreadsheet 
applications.

Function Description

ISBLANK (page 240) Returns TRUE if the specified cell is empty and FALSE otherwise.

ISERROR (page 241) Returns TRUE if the expression in the function’s argument evaluates 
to an error and FALSE otherwise.

ISEVEN (page 241) Returns TRUE if the value is even and FALSE otherwise.

ISODD (page 241) Returns TRUE if the value is odd and FALSE otherwise.
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Reference Functions
Reference functions help you find data in tables and retrieve data from cells.

Numbers provides these reference functions.

Function Description

ADDRESS (page 207) Constructs a cell address string from separate row, column, and 
table identifiers.

AREAS (page 208) Counts how many cell ranges are in the argument.

CHOOSE (page 213) Uses an index value to retrieve a particular value from a set of 
values.

COLUMN (page 214) Returns the column number of a cell or, if no cell is specified, the 
column number of the cell that contains the COLUMN function.

COLUMNS (page 215) Counts how many columns are in a range of cells.

HLOOKUP (page 234) Retrieves a value from a range of rows by using the top row values 
to pick a column and a row number to pick a row in that column.

HYPERLINK (page 236) Creates a clickable link that opens a webpage or new email 
message window.

INDEX (page 237) Retrieves the value found in, or a reference to, the cell at the 
intersection of a specified row and column within a range of cells.

INDIRECT (page 237) Retrieves the value at, or a reference to, a specified address.

LOOKUP (page 245) Retrieves a value from one range of cells based on a search match 
in a second range.

MATCH (page 246) Finds the position of a search value within a range.

OFFSET (page 255) Retrieves one or more values a given number of rows and columns 
from a specified base cell.

ROW (page 270) Returns the row number of a cell or, if no cell is specified, the row 
that contains the ROW function.

ROWS (page 270) Counts how many rows are in a range of cells.

VLOOKUP (page 288) Retrieves a value from a range of columns by using the left column 
of values to pick a row and a column number to pick a column in 
that row.



200 Chapter 12    Dictionary of Functions 

 

Numeric Functions 
The numeric functions calculate commonly used mathematical values.

Numbers provides these numeric functions.

Function Description

ABS (page 205) Calculates the absolute value of a number.

CEILING (page 212) Rounds a number away from zero to the nearest multiple of a 
specified factor.

COMBIN (page 215) Finds the number of different ways you can combine a number of 
items into groups of a specific size.

EVEN (page 229) Rounds a number away from zero to the next even number.

EXP (page 230) Calculates e to the power of a number.

FACT (page 230) Calculates the factorial of a number.

FLOOR (page 232) Rounds a number toward zero to the nearest multiple of a 
specified factor.

GCD (page 234) Calculates the greatest common divisor of a set of numbers.

INT (page 238) Returns the nearest integer less than or equal to a number.

LCM (page 243) Finds the least common multiple of a set of numbers.

LN (page 244) Calculates the natural logarithm of a number.

LOG (page 245) Calculates the logarithm of a number with a specified base.

LOG10 (page 245) Calculates the base-10 logarithm of a number.

MOD (page 250) Calculates the remainder of a division.

MROUND (page 252) Rounds a number to the nearest multiple of a specified factor.

ODD (page 254) Rounds a number away from zero to the nearest odd number.

PI (page 256) Returns an approximation of pi accurate to 15 decimal places.

POWER (page 258) Raises a number to a power, like the ^ operator.

PRODUCT (page 262) Calculates the product of a set of numbers.

QUOTIENT (page 263) Calculates the integer quotient (without remainder) of two 
numbers.

RAND (page 264) Generates a random number greater than or equal to 0 and less 
than 1.

RANDBETWEEN (page 264) Generates a random integer in an inclusive range.

ROMAN (page 267) Converts a number to Roman numerals.

ROUND (page 268) Rounds a number to a specified number of digits.

ROUNDDOWN (page 268) Rounds a number toward zero to the specified number of places.

ROUNDUP (page 269) Rounds a number away from zero to the specified number of 
places
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Trigonometric Functions
The trigonometric functions take radians as arguments.

Numbers provides these trigonometric functions.

SIGN (page 271) Returns 1 when the argument is positive, –1 when the argument is 
negative, and 0 when it’s zero.

SQRT (page 274) Calculates the square root of a number.

SUM (page 277) Calculates the sum of a set of numbers.

SUMIF (page 278) Calculates the sum of a set of numbers that satisfy a specified 
condition.

SUMPRODUCT (page 278) Calculates the sum of the products of corresponding numbers in 
two or more ranges.

SUMSQ (page 279) Calculates the sum of the squares of a set of numbers.

TRUNC (page 283) Truncates a decimal number to a specified number of digits.

Function Description

Function Description

ACOS (page 206) Calculates the inverse cosine (arccosine) in the range 0 to pi 
radians.

ACOSH (page 207) Calculates the inverse hyperbolic cosine of a number.

ASIN (page 209) Calculates the inverse sine (arcsine) in the range –pi/2 through pi/2 
radians.

ASINH (page 209) Calculates the hyperbolic arcsine (inverse hyperbolic sine).

ATAN (page 209) Calculates the inverse tangent (arctangent) in the range –pi/2 
through pi/2 radians.

ATAN2 (page 210) Finds the angle, relative to the positive x-axis, of a line passing 
through the origin and a specified point.

ATANH (page 210) Calculates the inverse hyperbolic tangent of a number.

COS (page 217) Calculates the cosine of an angle expressed in radians.

COSH (page 218) Calculates the hyperbolic cosine of a number.

DEGREES (page 227) Converts radians to degrees.

RADIANS (page 263) Converts degrees to radians.

SIN (page 271) Calculates the sine of an angle expressed in radians.

SINH (page 272) Calculates the hyperbolic sine of a number.

TAN (page 280) Calculates the tangent of an angle expressed in radians.

TANH (page 281) Calculates the hyperbolic tangent of a number.
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Statistical Functions
Statistical functions perform statistical calculations and require numeric expressions as 
arguments. The numeric expression can be a number, cell reference, or range. Unless 
otherwise stated, statistical functions result in a number.

Numbers provides these statistical functions.

Function Description

AVEDEV (page 210) Calculates the average difference (deviation) of data points from 
their arithmetic mean (average).

AVERAGE (page 211) Calculates the average (arithmetic mean) of a set of numbers.

AVERAGEA (page 211) Calculates the average (arithmetic mean) of a set of values 
including numbers, text, and Boolean values.

CONFIDENCE (page 216) Returns a value for creating a statistical confidence interval for a 
sample of a specified size from a population with a known 
standard deviation; assumes values in sample are normally 
distributed.

CORREL (page 217) Calculates the correlation between two data sets based on linear 
regression analysis.

COUNT (page 218) Counts the number of arguments and referenced cells that contain 
numbers, numeric expressions, or dates.

COUNTA (page 219) Counts the number of arguments and referenced cells that are not 
empty.

COUNTBLANK (page 220) Counts the number of cells in a range that are empty.

COUNTIF (page 220) Counts the number of cells in a range that satisfy a condition.

COVAR (page 224) Calculates the covariance of two data sets.

FORECAST (page 233) Calculates the y (dependent) value that corresponds to a chosen x 
(independent) value by using linear regression analysis of known 
value pairs.

INTERCEPT (page 238) Calculates the y-intercept of the best-fit line for a data set using 
linear regression analysis.

LARGE (page 242) Retrieves the nth-largest value in a range.

MAX (page 247) Finds the largest number in a set.

MAXA (page 248) Finds the largest value in a set that includes numbers, text, and 
Boolean values.

MEDIAN (page 248) Finds the median value in a set of numbers.

MIN (page 249) Finds the smallest number in a set.

MINA (page 249) Finds the smallest value in a set that includes numbers, text, and 
Boolean values.

MODE (page 251) Finds the most frequently occurring value in a set of numbers.
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PERCENTILE (page 256) Finds the value within a range of values that corresponds to a 
particular percentile.

POISSON (page 257) Calculates event rate probabilities based on the Poisson 
distribution.

PROB (page 261) Calculates the probability of a range of values if you know the 
individual probability of each value.

RANK (page 264) Finds the rank of a number within a range of numbers.

SLOPE (page 273) Finds the slope of the best-fit line for a data set based on linear 
regression analysis.

SMALL (page 273) Retrieves the nth-smallest value in a range.

STDEV (page 274) Calculates the standard deviation of a set of numbers based on the 
sample (unbiased) variance.

STDEVA (page 275) Calculates the standard deviation of a set of values, including text 
and Boolean values, based on the sample (unbiased) variance.

STDEVP (page 275) Calculates the standard deviation of a set of numbers based on the 
population (true) variance.

STDEVPA (page 276) Calculates the standard deviation of a set of values, including text 
and Boolean values, based on the population (true) variance.

VAR (page 284) Calculates the sample (unbiased) variance of a set of numbers.

VARA (page 285) Calculates the sample (unbiased) variance of a set of values, 
including text and Boolean values.

VARP (page 286) Calculates the population (true) variance of a set of numbers.

VARPA (page 286) Calculates the population (true) variance of a set of values, 
including text and Boolean values.

Function Description
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Text Functions
The text functions help you work with strings of characters.

Numbers provides these text functions.

Function Description

CHAR (page 212) Returns the character that corresponds to a numeric Unicode 
character code.

CLEAN (page 213) Removes most common nonprinting characters (Unicode character 
codes 0–31) from text.

CODE (page 214) Returns the Unicode code number of the first character in a string.

CONCATENATE (page 216) Concatenates strings.

DOLLAR (page 228) Converts a number to a string written as a dollar amount with a 
specified number of decimal places.

EXACT (page 230) Returns TRUE if the argument strings are identical, including case.

FIND (page 231) Finds the starting position of one string within another, matching 
both character and case but not allowing wildcards.

FIXED (page 232) Rounds a number to a specified number of places and converts the 
result to a string.

LEFT (page 244) Retrieves the specified number of characters from the left end of a 
string.

LEN (page 244) Finds the number of characters in a string.

LOWER (page 246) Converts all uppercase characters in text to lowercase.

MID (page 248) Extracts characters from a string starting at a specified position.

PROPER (page 262) Changes the first character in each word of a string to uppercase 
and all other characters to lowercase.

REPLACE (page 266) Replaces part of a string with characters from a second string.

REPT (page 266) Repeats text a specified number of times.

RIGHT (page 267) Retrieves the specified number of characters from the right end of 
a string.

SEARCH (page 270) Finds the starting position of one string within another, ignoring 
case but allowing wildcards.

SUBSTITUTE (page 277) Replaces part of a string with new text.

T (page 280) Retrieves text from a cell.

TRIM (page 283) Removes spaces from text, leaving only single spaces between 
words.

UPPER (page 284) Converts text to uppercase.

VALUE (page 284) Converts a number formatted as text to a regular number.
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Function Descriptions
The function descriptions in this section are arranged in alphabetical order by function 
name.

ABS
The ABS function calculates the absolute value of a number. The result is either a 
positive number or zero.

ABS(number)
Â number:  A number, a numeric expression, or a reference to a cell containing a 

numeric expression.
  

ACCRINT
The ACCRINT function calculates the total accrued interest for a security that pays 
periodic interest.

ACCRINT(issue, first, settle, rate, par, frequency, [day-count])
Â issue:  The date when the security was issued.
Â first:  The date of the first interest payment.
Â settle:  The settlement date, usually the date when the security was purchased.
Â rate:  The coupon rate of the security, expressed as a percentage from 0 to 1.
Â par:  The face value of the security.
Â frequency:  The number of coupon payments each year.

1 means annual payments.

2 means semiannual payments (twice per year).

4 means quarterly payments (four times per year).

Â day-count:  Optional; specifies the number of days per month and days per year used 
in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

Examples

If cell A1 contains 5, ABS(A1) returns 5.
 
ABS(8-5) returns 3.

ABS(5-8) returns 3.

ABS(0) returns 0.

If cell A1 is empty, ABS(A1) returns 0.
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3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

ACCRINTM
The ACCRINTM function calculates the total accrued interest for a security that pays 
interest at maturity.

ACCRINTM(issue, settle, rate, par, [day-count])
Â issue:  The date when the security was issued.
Â settle:  The date of the settlement, usually the date when the security was purchased.
Â rate:  The coupon rate of the security, expressed as a percentage from 0 to 1.
Â par:  The face value of the security.
Â day-count:  Optional; specifies the number of days per month and days per year used 

in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

ACOS
The ACOS function calculates the inverse cosine (arccosine) of a number. While the COS 
function takes an angle and returns its cosine, the ACOS function does the opposite; it 
takes a cosine value and returns a corresponding angle. The resulting angle is 
expressed in radians, in the range 0 to pi.

ACOS(cos)
Â cos:  A cosine value in the range –1 through 1.

Examples

If A1:A7 contain 1/1/2000, 3/1/2000, 7/1/2000, 0.10, 1000, 2, 0:
 
ACCRINT(A1, A2, A3, A4, A5, A6, A7) returns 50.

Examples

If A1:A5 contain 1/1/2000, 10/1/2000, 0.10, 1000, 0:
 
ACCRINTM(A1, A2, A3, A4, A5) returns 75.
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Notes
To see the resulting angle in degrees instead of radians, use the DEGREES function.
  

ACOSH
The ACOSH function calculates the inverse hyperbolic cosine of a number.

ACOSH(number)
Â number:  A number greater than or equal to 1.
  

ADDRESS
The ADDRESS function constructs a cell address string from separate row, column, and 
table identifiers.

ADDRESS(row, column, [type], [style], [table])
Â row:  The row number of the address.
Â column:  The column number of the address.
Â type:  Optional; a number specifying whether the row and column numbers are 

relative or absolute:
1 or missing treats row and column as absolute references.

2 treats the row number as an absolute reference and the column number as a 
relative reference.

3 treats the row number as a relative reference and the column number as an 
absolute reference.

4 treats both row and column numbers as relative references.

Â style:  Optional; the address style:
TRUE, 1, or omitted formats the address using the A1 style, in which the letter 
specifies the column and the number specifies the row. 

FALSE formats the address using the R1C1 style, which isn’t supported and returns an 
error.

Examples

ACOS(SQRT(2)/2) returns 0.785398163397448, which is approximately pi/4.

ACOS(0.54030230586814) returns 1.

DEGREES(ACOS(.5)) returns 60, the degree measure of an angle that has a cosine of 0.5.

Examples

ACOSH(10.0676619957778) returns 3.

ACOSH(COSH(5)) returns 5.
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Â table:  Optional; the name of the table. If the table is on another sheet, you must also 
include the name of the sheet.

  

AND
The AND function returns TRUE if all arguments are true and FALSE otherwise (logical 
conjunction).

AND(expression, [expression, . . .])
Â expression:  A logical or numeric expression, or a reference to a cell containing such 

an expression.

Notes
If expression is numeric, a value of 0 is interpreted as FALSE and any nonzero value is 
interpreted as TRUE.
  

AREAS
The AREAS function counts the number of ranges the function references.

AREAS(ranges)
Â ranges:  One or more ranges of cells. To specify more than one range, enclose the 

references in a second set of parentheses.

Examples

ADDRESS(3,5) creates the address $E$3.

ADDRESS(3,5,2) creates the address E$3.

ADDRESS(3,5,3) creates the address $E3.

ADDRESS(3,5,4) creates the address E3.

ADDRESS(3,3,,, “Sheet 2 :: Table 1”) creates the address Sheet 2 :: Table 1 :: $C$3.

Examples

AND(TRUE, TRUE) returns TRUE because both arguments are true.

AND(1, 0, 1, 1) returns FALSE because one of the arguments is a numeric 0, which is interpreted as 
FALSE.

AND(A5>50,A5<100) returns TRUE if cell A5 contains a number between 50 and 100.
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ASIN
The ASIN function returns the arcsine (the inverse sine) of a number. While the SIN 
function takes an angle and returns the sine, the ASIN function takes a sine and returns 
the corresponding angle. The result is expressed in radians, in the range –pi/2 to pi/2 (–
90 to 90 degrees).

ASIN(sin)
Â sin:  A sine value in the range –1 through 1.

Notes
To see the resulting angle in degrees instead of radians, use the DEGREES function.
  

ASINH
The ASINH function calculates the inverse hyperbolic sine of a number.

ASINH(number)
Â number:  Any number.
  

ATAN
The ATAN function calculates the inverse tangent (arctangent) of a number and returns 
the corresponding angle in radians, in the range –pi/2 through pi/2 (–90 through 90 
degrees).

ATAN(number)
Â number:  A tangent value for which you want to find the corresponding angle.

Examples

AREAS(A1:F8) returns 1.

AREAS(C2:C8 B6:E6) returns 1.

AREAS((A1:F8, A10:F18)) returns 2.

AREAS((A1:C1, A3:C3, A5:C5)) returns 3.

Examples

ASIN(0.8411470984807897) returns 1, the radian measure (approximately 57.3 degrees) of the angle 
that has a sine of 0.8411470984807897.

DEGREES(ASIN(0.5)) returns 30, the degree measure of the angle that has a sine of 0.5.

Examples

ASINH(27.2899171971277) returns 4.

ASINH(SINH(1)) returns 1.
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Notes
To see the resulting angle in degrees instead of radians, use the DEGREES function.
  

ATAN2
The ATAN2 function calculates the angle, relative to the positive x-axis, of the line 
passing through the origin and the specified point. The angle is expressed in radians, in 
the range –pi through pi.

ATAN(x, y)
Â x:  The x-coordinate of the point the line passes through.
Â y:  The y-coordinate of the point the line passes through.

Notes
To see the resulting angle in degrees instead of radians, use the DEGREES function.
  

ATANH
The ATANH function calculates the inverse hyperbolic tangent of a number.

ATANH(number)
Â number:  Any number between –1 and 1.
  

AVEDEV
The AVEDEV function calculates the average difference (deviation) of the data points 
from their arithmetic mean (average).

AVEDEV(datapoint, [datapoint, . . .])
Â datapoint:  One or more numbers, numeric expressions, or references to cells 

containing numbers or numeric expressions.

Examples

ATAN(1) returns the angle measure 0.785398163 radians (45 degrees), which has a tangent of 1.

DEGREES(ATAN(1)) returns 45.

Examples

ATAN2(1, 1) returns 0.78539816 radians (45 degrees), the angle of a line segment from the origin to 
point (1,1).

DEGREES(ATAN2(5,5)) returns 45.

Examples

ATANH(0.995054753686731) returns 3.

ATANH(TANH(2)) returns 2.
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AVERAGE
The AVERAGE function calculates the average (arithmetic mean) of a set of numbers.

AVERAGE(number, [number, . . .])
Â number:  One or more numbers, numeric expressions, or references to cells 

containing numbers or numeric expressions.

Notes
To calculate the average, AVERAGE divides the sum of the numbers by the number of 
numbers.

Table cells containing text values or Boolean values (TRUE or FALSE) are ignored. Text 
values included as arguments result in an error. Referenced text is ignored with no 
warning.

  

AVERAGEA
The AVERAGEA function calculates the average (arithmetic mean) of a set of values, 
including text and Boolean values.

AVERAGEA(value, [value, . . .])
Â value:  One or more numeric or Boolean values or references to cells containing 

numeric, textual, or Boolean values.

Notes
Unlike the AVERAGE function, which ignores cells that don’t contain numbers, 
AVERAGEA assigns a value of 0 to any text value, 0 to the Boolean value FALSE, and 1 to 
the Boolean value TRUE and includes those values in the computation.

For a data set containing only numbers, AVERAGEA returns the same result as AVERAGE.

Examples

AVEDEV(2,2,2,4,4,4) returns 1.

AVEDEV(2,2,2,2,3,3,3,3,4,4,4,4) returns 0.6666667.

Examples

AVERAGE(4,4,4,6,6,6) returns 5.

AVERAGE(2,2,2,2,3,3,3,3,4,4,4,4) returns 3.
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CEILING
The CEILING function rounds a number away from zero to the nearest multiple of the 
specified factor.

CEILING(number, factor)
Â number:  A number, numeric expression, or references to a cell containing a numeric 

expression.
Â factor:  The number whose multiples you want to round to. factor must have the 

same sign as number.

Notes
To round down (toward zero) instead of up, use the FLOOR function.

Other functions related to rounding numbers: INT, ROUND, ROUNDUP, ROUNDDOWN, 
TRUNC.

  

CHAR
The CHAR function returns the character that corresponds to a numeric Unicode 
character code.

CHAR(code-number)
Â code-number:  A number from 1 through 65535 for which you want to generate the 

corresponding character.

Examples

AVERAGEA(A1:A4) returns 2.5 if cells A1 through A4 contain 4, a, 6, b. The text values are counted as 
zeros in the sum of 10 and included in the count of values (4). Compare with AVERAGE(A1:A4), which 
ignores the text values completely for a sum of 10, a count of 2, and an average of 5.

AVERAGEA(A1:A4) returns 4 if cells A1 through A4 contain 5, a, TRUE, 10. The text value counts zero 
and TRUE counts 1 for a sum of 16 and a count of 4.

AVERAGEA(A1:A4) returns 0.25 if cells A1 through A4 contain FALSE, FALSE, FALSE, TRUE. Each FALSE 
counts zero and TRUE counts 1 for a sum of 1 and a count of 4.

Examples

CEILING(0.25,1) returns 1.

CEILING(1.25,1) returns 2.

CEILING(-1.25,-1) returns -2.

CEILING(5,2) returns 6.

CEILING(73,10) returns 80.

CEILING(7,2.5) returns 7.5.
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Notes
Not all numbers in a character are associated with a printable character.

You can use the Character Palette, which you can enable in International preferences, 
to view entire sets of characters and their codes.

You can use the CODE function to find the numeric code for a specific character.

  

CHOOSE
The CHOOSE function uses a specified index value to retrieve a value from a set of 
values.

CHOOSE(index, value, [value, . . .])
Â index:  A numeric expression.
Â value:  One or more values, which can be text, a numeric expression, or a cell 

reference.
  

CLEAN
The CLEAN function removes most common nonprinting characters (Unicode character 
codes 0–31) from text. This can be helpful if text you paste from another application 
contains unwanted question marks, spaces, boxes, or other unexpected characters.

CLEAN(text)
Â text:  The text from which you want to remove nonprinting characters.

Notes
There are some less common nonprinting characters that are not removed by CLEAN 
(character codes 127, 129, 141, 143, 144, and 157). To remove these, you can use the 
SUBSTITUTE function to replace them with a code in the range 0–31 before you use the 
CLEAN function.

You can use the TRIM function to remove extra spaces in text.

Examples

CHAR(98.6) returns "b", which is represented by the code 98.

CODE("b") returns 98.

Examples

If cells A1:A7 contain Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday:
  
CHOOSE(4, A1, A2, A3, A4, A5, A6, A7) returns Thursday.

CHOOSE(3,"1st","second",7,"last") returns 7, the third value in the list.
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CODE
The CODE function returns the Unicode code number of the first character in a 
specified string.

CODE(text)
Â text:  A text expression or reference to a cell containing a text expression.

Notes
You can use the Character Palette, which you can enable in International preferences, 
to view the code for a particular character.

You can use the CHAR function to do the opposite of the CODE function: convert a 
numeric code into a text character.

  

COLUMN
The COLUMN function returns the column number of the specified cell or, if no cell is 
specified, the column number of the cell that contains the function.

COLUMN([cell])
Â cell:  Optional; a cell reference. If omitted, COLUMN returns the column number of 

the cell that contains the formula.
  

Examples

Suppose you copy what you believe to be the text "a b c d e f" from another application and paste it 
into cell A1, but instead see "a b c   ?  ?d e f". You can try using CLEAN to remove the unexpected 
characters:
  
CLEAN(A1) returns "a b c d e f".

Examples

CODE("A") returns 65, the character code for uppercase "A".

CODE("abc") returns 97 for lowercase "a".

CHAR(97) returns "a".

CODE(A3) returns "102" for lowercase "f".

CODE(" ") gives 1488.

Examples

COLUMN(B7) returns 2, the absolute column number of column B.

COLUMN() returns the column number of the cell that contains the function.
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COLUMNS
The COLUMNS function counts how many columns are in a range of cells.

COLUMNS(cell-range)
Â cell-range:  A range of cells in a table.

Notes
If you select an entire row for cell-range, Numbers returns the total number of cells in 
the row, which changes when you resize the table.
  

COMBIN
The COMBIN function finds the number of different ways you can combine a number of 
items into groups of a specific size, ignoring the order within the groups.

COMBIN(items, size)
Â items:  The total number of items that can be combined.
Â size:  The number of items combined in each group.

Notes
Remember that combinations are not the same as permutations. The order of the items 
in a group is ignored for combinations but not for permutations. For example, (1, 2, 3) 
and (3, 2, 1) are the same combination but two unique permutations.
  

Examples

COLUMNS(B3:D10) returns 3, the number of columns in the range (columns B, C, and D).

COLUMNS(5:5) returns the total number of columns in row 5.

Examples

COMBIN(3, 2) returns 3, the number of unique groups you can create if you start with 3 items and 
group them 2 at a time.

COMBIN(3.2, 2.3) returns 3. Fractional parts are dropped.

Both COMBIN(5, 2) and COMBIN(5,3) return 10.
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CONCATENATE
The CONCATENATE function joins (concatenates) strings.

CONCATENATE(string, [string, . . .])
Â string:  A string or a reference to a cell containing a string. To include a string in an 

argument, place quotation marks around it.

Notes
You can also use the & operator to concatenate strings.
  

CONFIDENCE
The CONFIDENCE function returns a value for creating a statistical confidence interval 
for a sample of a specified size from a population with a known standard deviation. The 
confidence estimate assumes that values in the sample are normally distributed.

CONFIDENCE(alpha, stdev, size)
Â alpha:  The probability that the true population value lies outside the interval. So, 1 

minus alpha is the confidence level that the true population value lies within the 
interval centered on the sample value. An alpha of 0.05 corresponds to a confidence 
level of 0.95, or 95%.

Â stdev:  The standard deviation of the population.
Â size:  The size of the sample.
  

Examples

If cell A1 contains Lorem and cell B1 contains Ipsum, CONCATENATE(B1,", ",A1) returns "Ipsum, Lorem".

CONCATENATE("a", "b","c") returns "abc".

"a"&"b"&"c" returns "abc".

Examples

CONFIDENCE(0.05, 1, 10) returns 0.62. If the mean of the sample values is 100, then with 95% 
confidence the population mean falls in the range 99.38–100.62.

CONFIDENCE(0.1, 1, 10) returns 0.52. If the mean of the sample values is 100, then with 90% 
confidence the population mean falls in the range 99.48–100.52.

CONFIDENCE(0.05, 1, 20) returns 0.44.

CONFIDENCE(0.05, 1, 30) returns 0.36.

CONFIDENCE(0.05, 1, 40) returns 0.31.
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CORREL
The CORREL function calculates the correlation between two data sets based on linear 
regression analysis.

CORREL(y-range, x-range)
Â y-range:  A range of cells containing the dependent variable (y).
Â x-range:  A range of cells containing the independent variable (x).
  

COS
The COS function calculates the cosine of an angle expressed in radians.

COS(radian-angle)
Â radian-angle:  A number representing an angle in radians.

Notes
To work with angles in radians, use the RADIANS function to convert the degrees to 
radians. See the second example below.

To express radians as a multiple of pi, use the PI function. See the third and fourth 
examples below.

  

Examples

Given the following table: 
  

CORREL(D2:D7, E2:E7) returns 1.

CORREL(B2:B7, A2:A7) returns 0.977265.

Examples

COS(1) returns 0.540302306, the cosine of 1 radian (approximately 57.3 degrees).

COS(RADIANS(60)) returns 0.5, the cosine of 60 degrees.

COS(PI()/3) returns 0.5, pi/3 radians (60 degrees).

COS(PI()) returns -1, the cosine of pi radians (180 degrees).
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COSH
The COSH function calculates the hyperbolic cosine of a number.

COSH(number)
Â number:  Any real number.
  

COUNT
The COUNT function counts the number of arguments and referenced cells that 
contain numbers, numeric expressions, or dates.

COUNT(value, [value, . . .])
Â value:  One or more numbers.

Notes
To count any cell that contains any type of value (that is, any cell that is not empty), use 
the COUNTA function.
  

Examples

COSH(0) returns 1.

COSH(1) returns 1.543.

COSH(5) returns 74.21.

COSH(10) returns 11,013.233.

Examples

Given the following table: 
  

COUNT(A1:E1) returns 5.

COUNT(A2:E2) returns 0.

COUNT(A3:E3) returns 3.

COUNT(A4:E4) returns 0.

COUNT(A5:E5) returns 2.

COUNT(1, SUM(4, 5)) returns 2.



Chapter 12    Dictionary of Functions 219

 

COUNTA
The COUNTA function counts the number of arguments and referenced cells that are 
not empty.

COUNTA(value, [value, . . .])
Â value:  A reference to one or more cells or an argument containing a value.

Notes
To count only cells or arguments that contain numbers or dates, use the COUNT 
function.

  

Examples

Given the following table: 
  

COUNTA(A1:E1) returns 5.

COUNTA(A2:E2) returns 5.

COUNTA(A3:E3) returns 5.

COUNTA(A4:E4) returns 5.

COUNTA(A5:E5) returns 2.

COUNTA(1, "a", TRUE, FALSE) returns 4.

COUNTA(1, SUM(4, 5)) returns 2.
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COUNTBLANK
The COUNTBLANK function counts the number of cells in a range that are empty.

COUNTBLANK(range)
Â range:  A single range of cells.
  

COUNTIF
The COUNTIF function counts the number of cells in a range that satisfy a condition.

COUNTIF(test-range, condition)
Â test-range:  The range of cells to be tested.
Â condition:  The conditional test that results in a logical TRUE or FALSE.

Notes
For more information on the comparison operators you can use in the conditional test, 
see “Understanding the Comparison Operators” on page 96.
  

Examples

Given the following table: 
  

COUNTBLANK(A1:E1) returns 0.

COUNTBLANK(A2:E2) returns 1.

COUNTBLANK(A3:E3) returns 2.

COUNTBLANK(A4:E4) returns 1.

COUNTBLANK(A5:E5) returns 5.

Examples

If cells A1:A8 contain 1, 2, 3, 4, 5, 6, 7, 8: 
  
COUNTIF(A1:A8, "<4") returns 3.

COUNTIF(A1:A8, ">4") returns 4.

COUNTIF(A1:A8, ">=4") returns 5.
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COUPDAYBS
The COUPDAYBS function counts the number of days from the beginning of the 
coupon period in which settlement of a security occurs to the settlement date.

COUPDAYBS(settle, maturity, frequency, [day-count])
Â settle:  The date of the settlement, usually the date when the security was purchased.
Â maturity:  The date the security matures (expires).
Â frequency:  The number of coupon payments each year.

1 means annual payments.

2 means semiannual payments (twice per year).

4 means quarterly payments (four per year).

Â day-count:  Optional; specifies the number of days per month and days per year used 
in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

COUPDAYS
The COUPDAYS function counts the number of days in the coupon period in which 
settlement of a security occurs.

COUPDAYS(settle, maturity, frequency, [day-count])
Â settle:  The date of the settlement, usually the date when the security was purchased.
Â maturity:  The date the security matures (expires).
Â frequency:  The number of coupon payments each year.

1 means annual payments.

2 means semiannual payments (twice per year).

Examples

If A1:A4 contain 9/1/2000, 1/1/2001, 4, 1: 
  
COUPDAYBS(A1, A2, A3, A4) returns 62 (the number of days from July 1, the beginning of the current 
coupon period, to September 1, on the basis of 31 days in July and August).

COUPDAYBS(A1, A2, A3, 0) returns 60 (the number of days for the same period as the previous 
example, but on the basis of 30 days per month).

COUPDAYBS(DATE(2000,7,4), A2, 2, 0) returns 3 (the number of days from July 1 to July 4).



222 Chapter 12    Dictionary of Functions 

 

4 means quarterly payments (four per year).

Â day-count:  Optional; specifies the number of days per month and days per year used 
in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

COUPDAYSNC
The COUPDAYSNC function counts the number of days from the settlement date of a 
security to the end of the coupon period in which settlement occurs.

COUPDAYBS(settle, maturity, frequency, [day-count])
Â settle:  The date of the settlement, usually the date when the security was purchased.
Â maturity:  The date the security matures (expires).
Â frequency:  The number of coupon payments each year.

1 means annual payments.

2 means semiannual payments (twice per year).

4 means quarterly payments (four per year).

Â day-count:  Optional; specifies the number of days per month and days per year used 
in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

Examples

If A1:A4 contain 9/1/2000, 1/1/2001, 4, 0: 
  
COUPDAYS(A1, A2, A3, A4) returns 90 (the number of days in July, August, and September using the 
30/360 day count basis).

COUPDAYS(A1, A2, A3, 1) returns 92 (the number of days in July, August, and September using the 
actual/actual day count basis).

COUPDAYS(A1, A2, A3, 2) returns 90 (the number of days in July, August, and September using the 
actual/360 day count basis).

COUPDAYS(A1, A2, A3, 3) returns 91.25 (the number of days in July, August, and September using the 
actual/365 day count basis).

COUPDAYS(A1, A2, A3, 4) returns 90 (the number of days in July, August, and September using the 
30E/360 day count basis).
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2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

COUPNUM
The COUPNUM function counts the coupons to be paid for a security between the 
settlement date and the maturity date.

COUPNUM(settle, maturity, frequency, [day-count])
Â settle:  The date of the settlement, usually the date when the security was purchased.
Â maturity:  The date the security matures (expires).
Â frequency:  The number of coupon payments each year.

1 means annual payments.

2 means semiannual payments (twice per year).

4 means quarterly payments (four per year).

Â day-count:  Optional; specifies the number of days per month and days per year used 
in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

Examples

If A1:A4 contain 9/1/2000, 1/1/2001, 4, 1: 
  
COUPDAYSNC(A1, A2, A3, A4) returns 30 (the number of days from September 1 to the next coupon 
date, October 1, on the basis of 30 days in September).

COUPDAYSNC(DATE(2000,8,1), A2, A3, A4) returns 61 (the number of days from August 1 to the next 
coupon date, October 1, on the basis of 31 days in August and 30 days in September).

COUPDAYSNC(DATE(2000,8,1), A2, A3, 0) returns 60 (the number of days from August 1 to the next 
coupon date, October 1, on the basis of 30 days in August and 30 days in September).
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COVAR
The COVAR function calculates the covariance of two data sets.

COVAR(range1, range2)
Â range1:  A reference to the cells containing the first data set.
Â range2:  A reference to the cells containing the second data set. The dimensions of 

range1 and range2 must be the same.

Notes
If the two data sets are identical, the covariance is the same as the population variance.
  

DATE
The DATE function combines separate year, month, and day values into a single date.

DATE(year, month, day)
Â year:  A year number.
Â month:  A month number.
Â day:  A day number.

Notes
Year values aren’t converted. If you specify 10, the year 10 is evaluated, not the year 1910 
or 2010.
  

Examples

If A1:A4 contain 2/1/2000, 1/1/2001, 4, 0: 
  
COUPNUM(A1, A2, A3, A4) returns 4.

COUPNUM(DATE(2000,6,1), A2, A3, A4) returns 3.

COUPNUM(DATE(2000,9,1), A2, A3, A4) returns 2.

COUPNUM(DATE(2000,11,1), A2, A3, A4) returns 1.

Examples

If range1 (C3:H3) contains 3.4, 3.7, 4, 4.4, 5.1, 5.4 and range2 (C2:H2) contains 2.1, 3.3, 4.5, 5.5, 6.4, 7.2: 
  
COVAR(C3:H3, C2:H2) returns 1.234.

Examples

DATE(1959,2,14) returns Feb 14, 1959, which is displayed according to the cell’s current format.
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DATEDIF
The DATEDIF function finds the number of days, months, or years between two dates.

DATEDIF(start-date, end-date, method)
Â start-date:  The starting date.
Â end-date:  The ending date.
Â method:  Specifies whether the time difference is expressed in years, months, or days 

and how the calculation handles dates in different years or months:
"D" counts the days between the dates.

"M" counts the months between the dates.

"Y" counts the years between the dates.

"MD" counts the days between the starting and ending days of the month, ignoring 
months and years. If the starting day is after the ending day, the count starts from 
the ending day as if it were in the preceding month. The year of the end-date is used 
to check for a leap year.

"YM" counts the number of whole months between start-date and end-date, ignoring 
the year. If the starting month/day is before the ending month/day, the dates are 
treated as though they are in the same year. If the starting month/day is after the 
ending month/day, the dates are treated as though they are in consecutive years.

"YD" counts the number of days between the starting month/day and ending 
month/day, ignoring years.

  

Examples

If A1 contains "4/6/88" and A2 contains "10/30/06" then: 
  
DATEDIF(A1,A2,"D") returns 6781, the number of days between April 6, 1988, and October 30, 2006.

DATEDIF(A1,A2,"M") returns 222, the number of whole months between April 6, 1988, and October 30, 
2006.

DATEDIF(A1,A2,"Y") returns 18, the number of whole years between April 6, 1988, and October 30, 
2006.

DATEDIF(A1,A2,"MD") returns 24, the number of days between the sixth day of a month and the 
thirtieth day of the same month.

DATEDIF(A1,A2,"YM") returns 6, the number of months between April and the following October in 
any year.

DATEDIF(A1,A2,"YD") returns 207, the number of days between April 6 and the following October 30 in 
any year.

DATEDIF(A1,NOW(),"Y") & " years, " & DATEDIF(A1,NOW(),"YM") & " months, and " & 
DATEDIF(A1,NOW(),"MD") & " days" returns the current age of someone born on April 6, 1988.
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DAY
The DAY function extracts the day number from a date.

DAY(date-time)
Â date-time:  Any valid Numbers date.
  

DB
The DB function calculates the depreciation of an asset for a specified period using the 
fixed-declining balance method.

DB(cost, salvage, life, period, [first-year-months])
Â cost:  The initial cost of the asset.
Â salvage:  The salvage value of the asset.
Â life:  The number of periods over which the asset is depreciating.
Â period:  The period for which you want to calculate the depreciation.
Â first-year-months:  Optional; the number of months in the first year. If omitted, 12 is 

assumed.
  

Examples

DAY("4/6/88 11:59:22 AM") returns 6.

Examples

If A2:E2 contain 1000, 100, 4,1,12: 
  
DB(A2, B2, C2, D2, E2) returns $438.

DB(A2, B2, C2, 2, E2) returns $246.16.

DB(A2, B2, C2, 3, E2) returns $138.34.

DB(A2, B2, C2, 4, E2) returns $77.75.

DB(A2, B2, C2, D2, 9) returns $328.50.

DB(A2, B2, C2, D2, 6) returns $219.

DB(A2, B2, C2, D2, 3) returns $109.50.
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DDB
The DDB function calculates the depreciation of an asset based on a specified 
depreciation rate. If you don’t specify a rate, it defaults to the double-declining balance 
method.

DDB(cost, salvage, life, period, [factor])
Â cost:  The initial cost of the asset.
Â salvage:  The salvage value of the asset.
Â life:  The number of periods over which the asset is depreciating.
Â period:  The period for which you want to calculate the depreciation. Must use the 

same time units as life.
Â factor:  Optional; a number that determines the depreciation rate. The higher the 

number, the more rapid the depreciation. If omitted, 2 (for double-declining) is 
assumed.

  

DEGREES
The DEGREES function converts radians to degrees.

DEGREES(radians)
Â radians:  A number representing the size of the angle in radians.
  

Examples

DDB(1000, 100, 4, 1) returns $500.

DDB(1000, 100, 4, 2) returns $250.

DDB(1000, 100, 4, 3) returns $125.

DDB(1000, 100, 4, 4) returns $25.

DDB(1000, 100, 4, 1, 1) returns $250.

DDB(1000, 100, 4, 1, 3) returns $750.

DDB(1000, 100, 4, 2, 3) returns $150.

DDB(1000, 100, 4, 3, 3) returns $0.

Examples

DEGREES(PI()) returns 180 (pi radians = 180 degrees).

DEGREES(1) returns 57.2957795130823, which is approximately the number of degrees per radian.
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DISC
The DISC function calculates the discount rate of a security.

DISC(settle, maturity, price, value, [day-count])
Â settle:  The date of the settlement, usually the date when the security was purchased.
Â maturity:  The date the security matures (expires).
Â price:  The cost of the security per $100 par value.
Â value:  The redemption value per $100 par value.
Â day-count:  Optional; specifies the number of days per month and days per year used 

in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

DOLLAR
The DOLLAR function converts a number to a string written as a dollar amount with 
the specified number of decimal places.

DOLLAR(number, [places])
Â number:  The number you want to convert. It can be a number, numeric expression, 

or a reference to a cell containing a numeric expression.
Â places:  Optional; a positive number represents the number of digits you want to 

have to the right of the decimal point. If omitted, 2 is assumed. A negative number 
specifies digits to round to the left of the decimal point.

Notes
The DOLLAR function uses standard arithmetical rounding; if the most significant digit 
being dropped is 5 or greater, the result is rounded up.

Examples

If A1:E1 contain 1/1/2000, 1/1/2001, 90, 100, 0: 
  
DISC(A1, B1, C1, D1, E1) returns 10%.

DISC(A1, B1, 80, D1, E1) returns 20%.

DISC(A1, B1, C1, 110, E1) returns 18%.
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EDATE
The EDATE function finds a new date some number of months before or after a given 
date.

EDATE(date, month-offset)
Â date:  The starting date.
Â month-offset:  The number of months before or after date. The month-offset is 

negative for a date earlier than date.
  

EVEN
The EVEN function rounds a number away from zero to the next even number.

EVEN(number)
Â number:  The number you want to round. It can be a number, a numeric expression, 

or a reference to a cell containing a numeric expression.

Notes
To round to an odd number, use the ODD function.
  

Examples

DOLLAR(2323.124) returns $2,323.12.

DOLLAR(2323.125) returns $2,323.13.

DOLLAR(99.554, 0) returns $100.

DOLLAR(12, 3) returns $12.000.

DOLLAR(-12, 3) returns ($12.000), with parentheses indicating a negative amount.

DOLLAR(123, -1) returns $120.

Examples

EDATE("1/15/2000", 1) returns 2/15/2000, the date one month later.

EDATE("1/15/2000", -24) returns 1/15/1998, the date 24 months earlier.

Examples

EVEN(1) returns 2.

EVEN(2) returns 2.

EVEN(2.5) returns 4.

EVEN(-2.5) returns -4.

EVEN(0) returns 0.
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EXACT
The EXACT function returns TRUE if the argument strings are identical in case and 
characters.

EXACT(string1, string2)
Â string1:  A text expression. To include the string as the argument, place quotation 

marks around it.
Â string2:  The second text expression.
  

EXP
The EXP function calculates e to the power of a number.

EXP(number)
Â number:  The power to which you want to raise e. It can be a number, a numeric 

expression, or a reference to a cell containing a numeric expression.
  

FACT
The FACT function calculates the factorial of a nonnegative number.

FACT(number)
Â number:  A nonnegative number.

Notes
Any fractional part of number is truncated before the calculation.
  

Examples

EXACT("toledo", "toledo") returns TRUE.

EXACT("Toledo", "toledo") returns FALSE.

EXACT(toledo", "tol" & "edo") returns TRUE.

Examples

EXP(1) returns 2.71828182845905, an approximation of e.

EXP(LN(5)) returns 5. EXP is the inverse of the LN function.

Examples

FACT(5) returns 120, or 1 * 2 * 3 * 4 * 5.

FACT(0) returns 1.

FACT(4.5) returns 24. The fraction is dropped and 4! computed.

FACT(-1) returns an error; the number must be nonnegative.
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FALSE
The FALSE function returns the Boolean value FALSE. It is included so you can use 
spreadsheets created with some older spreadsheet applications. You can specify a 
Boolean value of FALSE by simply typing “false” (without quotation marks) into a cell or 
function argument.

FALSE()
Â No arguments (but you must include the parentheses).

Notes
You can type the word FALSE into a cell or formula instead of using the FALSE() 
function.
  

FIND
The FIND function finds the starting position of one string within another. The search is 
case sensitive and spaces are counted. Wildcards are not allowed.

FIND(target, string, [start])
Â target:  The text you want to find. If you’re including the actual text as the argument, 

surround it with quotation marks.
Â string:  The text you want to search. If you’re including the actual text as the 

argument, surround it with quotation marks.
Â start:  Optional; a number specifying the character position in the target string where 

you want to start the search. If omitted, the search starts with the first character in 
target.

Notes
To use wildcards in your search, use the SEARCH function.
  

Examples

FALSE() returns the Boolean value FALSE.

AND(1,FALSE()) returns the Boolean value FALSE.

Examples

FIND("e","where on earth") returns 3 ("e" is the third character in the string "where on earth").

FIND("e","where on earth", 8) returns 10 ("e" in earth is the first "e" found starting from character 8, the 
"n" in "on").
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FIXED
The FIXED function rounds a number to the specified number of decimal places and 
then converts the result to text.

FIXED(number, [places], [commas])
Â number:  A number.
Â places:  Optional; a number specifying the number of decimal places you want in the 

result.
Â commas:  Optional Boolean value; specifies whether to use position separators in the 

whole portion of the resulting number.
FALSE or 0 leaves out position separators in the resulting number.

TRUE, 1, or omitted includes position separators in the resulting number.

  

FLOOR
The FLOOR function rounds a number toward zero to the nearest multiple of the 
specified factor.

FLOOR(number, factor)
Â number:  A number, numeric expression, or reference to a cell containing a numeric 

expression.
Â factor:  The number whose multiples you want to round to. factor must have the 

same sign as number.

Notes
To round away from zero instead of toward zero, use the CEILING function.

Other functions related to rounding numbers: INT, ROUND, ROUNDUP, ROUNDDOWN, 
TRUNC.

Examples

FIXED(6789.123, 2) returns "6,789.12."

FIXED(6789.123, 1, 1) returns "6789.1."

FIXED(6789.123, -2) returns "6,800."

FIXED(12.4, 0) returns "12."

FIXED(12.5, 0) returns "13."

FIXED(4, -1) returns "0."

FIXED(5, -1) returns "10."
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FORECAST
The FORECAST function uses linear regression analysis of known value pairs to find the 
y (dependent) value that corresponds to a chosen x (independent) value.

FORECAST(x, y-values, x-values)
Â x:  The x value for which you want to find a corresponding y value.
Â y-values:  A range of cells containing the known y values. Must be the same size as x- 

values.
Â x-values:  A range of cells containing the known x values.

Notes
You can use the SLOPE and INTERCEPT functions to find the equation used to calculate 
forecast values.
  

FV
The FV function calculates the future value of an investment, given a series of fixed, 
periodic added payments, interest rate, and number of periods. FV stands for future 
value.

FV(rate, num-periods, [payment], [present-value], [when-due])
Â rate:  The interest rate per period.
Â num-periods:  The number of periods.
Â payment:  Optional; the added payment to be made per period, specified as a 

negative number. If omitted, you must include present-value.

Examples

FLOOR(0.25,1) returns 0.

FLOOR(1.25,1) returns 1.

FLOOR(5,2) returns 4.

FLOOR(73,10) returns 70.

FLOOR(-0.25,-1) returns 0.

FLOOR(9,2.5) returns 7.5.

Examples

Given the following table: 
  

FORECAST(9, A3:F3, A2:F2) returns 19.
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Â present-value:  Optional; the present value of the investment, specified as a negative 
number.

Â when-due:  Optional; specifies whether payments are due at the beginning or end of 
each period:
0 (or omitted) means payments are at the end of each period. 

1 means payments are at the beginning of each period. 

  

GCD
The GCD function finds the greatest common divisor of the specified numbers. 
Sometimes called the greatest common factor, the greatest common divisor is the 
largest integer that divides each of the numbers with no remainder.

GCD(number, [number, . . .])
Â number:  One or more positive numbers or numeric expressions, or references to cells 

containing positive numbers or numeric expressions.

Notes
All arguments must be greater than or equal to zero.
  

HLOOKUP
The HLOOKUP function retrieves a value from a range of rows by using the top row 
values to pick a column and a row number to pick a row. You can specify whether to 
search for the closest match or an exact match.

HLOOKUP(search-value, cell-range, row, [exact-match])
Â search-value:  The value you want to look for in the top row to choose a column. Can 

be numeric, textual, or logical.
Â cell-range:  The range of cells containing your data. The top row contains the data to 

be searched; the remaining rows contain values you want to retrieve.
Â row:  A numeric expression that specifies the row that contains the value you want to 

retrieve. The top row of the cell range is row 1.

Examples

FV(5%,10,-300,-3000,0) calculates the value in 10 years of a $3000 initial investment, with an added 
payment of $300 at the end of each year, at an annual rate of 5%. The future value in this example is 
$8660.05 (when using a number format with a precision of 2).

Examples

GCD(8, 10) returns 2.

GCD(99, 102, 105) returns 3.

GCD(34, 51) returns 17.
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Â exact-match:  Optional Boolean value; determines whether an exact match is 
required:
TRUE, 1, or omitted selects the column with the largest top-row value that is less 
than the search value if there is no exact match.

FALSE or 0 returns an error if there is no exact match.

  

HOUR
The HOUR function extracts the hour from a date/time value. The hour is represented, 
using a 24-hour clock, by a number from 0 through 23.

HOUR(date-time)
Â date-time:  Any valid Numbers date.
  

Examples

Given the following table: 
  

HLOOKUP(20,A1:E4,2) returns "E."

HLOOKUP(39,A1:E4,2) returns "E."

HLOOKUP("M",A2:E4,2) returns "dolor."

HLOOKUP("C",A2:E3,2) returns "lorem."

HLOOKUP("blandit",A3:E4,2) returns "5."

HLOOKUP("C",A2:E4,3, TRUE) returns "1."

HLOOKUP("C",A2:E4,3, FALSE) warns that the value can’t be found (because there is no exact match).

Examples

HOUR(NOW()) returns the current hour of the day.

HOUR("4/6/88 11:59:22 AM") returns 11.
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HYPERLINK
The HYPERLINK function creates a clickable link that opens a webpage or new email 
message window.

HYPERLINK(url, [link-text])
Â url:  A standard universal resource locator.
Â link-text:  Optional; the text that appears as a clickable link in the cell. If you omit this 

argument, the URL is used as the link text.
  

IF
The IF function returns one of two values depending on whether a specified expression 
is TRUE or FALSE.

IF(expression, [if-true], [if-false])
Â expression:  A logical or numeric expression, or a reference to a cell containing such 

an expression.
Â if-true:  Optional; the value that is returned if condition is true. If completely omitted 

(no comma), returns 1. If blank (comma but not value), returns TRUE.
Â if-false:  Optional; the value that is returned if condition is false. If completely omitted 

(no comma), the if-true expression is returned. If blank (comma but not value), 
returns FALSE.

Notes
If condition is a numeric expression, a value of 0 is interpreted as false and any nonzero 
value is interpreted as true.
  

Examples

HYPERLINK("http://www.apple.com","Apple") creates a link with the text Apple that opens the default 
web browser to the Apple homepage.

HYPERLINK("mailto:janedoe@example.com?subject=Quote Request", "Get Quote") creates a link with 
the text Get Quote that opens the default email application and addresses a new message to 
janedoe@example.com with the subject line Quote Request.

Examples

IF(A5>=0, "Nonnegative","Negative") returns the text "Nonnegative" if cell A5 contains a number 
greater than or equal to zero. Otherwise, it returns "Negative".

IF(AND(A8,A9),1,0) behaves like the Boolean AND operation. The function returns the numeric value 1 
when both cells A8 and A9 contain 1 but returns the numeric value 0 if either cell contains a zero.
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INDEX
The INDEX function retrieves the value in the cell located at the intersection of the 
specified row and column within a range of cells. You specify the location by indicating 
how many rows down and how many columns to the right the cell is in relation to the 
upper-left corner of the range. 

INDEX(cell-range, [row], [column], [area])
Â cell-range:  A range or list of ranges containing the values you want to return. If more 

than one range is given (specified in a list surrounded by parentheses), the area 
argument specifies which range to give a result from.

Â row:  Optional; the number of the cell’s row, counting from top to bottom with the 
topmost cell in the cell range numbered 1. If omitted, you must include column.

Â column:  Optional; the number of the cell’s column, counting from left to right with 
the leftmost cell in the cell range numbered 1. If omitted, you must include row.

Â area:  Optional; the number of the area in cell-range if it includes more than one.
  

INDIRECT
The INDIRECT function returns a reference to an address specified as a string.

INDIRECT(address, [style])
Â address:  A string representing a cell address or a reference to a cell that contains a 

cell address.
Â style:  Optional; address style used in address.

TRUE, 1, or omitted indicates the A1 style address.

FALSE or 0 returns an error indicating that the R1C1 style isn’t supported.

Examples

Given the following table: 
  

INDEX(B2:E5,1,1) returns 2.

INDEX(B2:E5,3,2) returns 1024.

INDEX(B2:E5,2,3) returns 128.

INDEX(B2:E5,1,5) returns an error because the range contains only four columns.
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INT
INT returns the nearest integer that is less than or equal to the number.

INT(number)
Â number:  The number you want to convert to an integer. It can be a number, a 

numeric expression, or a reference to a cell containing a numeric expression.

Notes
Other functions related to rounding numbers: CEILING, ROUND, ROUNDUP, 
ROUNDDOWN, TRUNC.
  

INTERCEPT
The INTERCEPT function calculates the y-intercept of the best-fit line for the data set 
using linear regression analysis.

INTERCEPT(y-range, x-range)
Â y-range:  A list of values for the dependent variable y. Must be the same size as x-

range.
Â x-range:  A range of cells containing values for the independent variable x. Must be 

the same size as y-range.

Notes
To find the slope of the best-fit line, use the SLOPE function.

Examples

If cell A1 contains 99 and A20 contains A1, then: 
  
INDIRECT(A20) returns 99, the contents of cell A1.

Examples

INT(1.49) returns 1.

INT(1.50) returns 1.

INT(1.23456) returns 1.

INT(1111.222) returns 1111.

INT(-2.2) returns -3.

INT(-2.8) returns -3.
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IPMT
The IPMT function calculates the interest portion of a payment for a loan or investment 
at a specified period based on fixed, periodic payments and a fixed interest rate.

IPMT(rate, period, num-periods, present-value, [future-value], [when-due])
Â rate:  The interest rate for each period.
Â period:  The period for which you want to find the interest.
Â num-periods:  The number of periods in the life of the investment.
Â present-value:  The present value of the loan or investment.
Â future-value:  Optional; the target future value, if this in an investment. If omitted, 

assumed to be 0.
Â when-due:  Optional; specifies whether payments are made at the beginning or end 

of each period:
0 (or omitted) means payments are at the end of each period. 

1 means payments are at the beginning of each period. 

Notes
Be sure that the interest rate is expressed as the rate per period. For example, if the 
interest rate is 10% per year and the payment period is monthly, the rate used in the 
function should be 0.1/12 (approximately 0.00833 per month).
  

Examples

Given the following table: 
  

INTERCEPT(A2:F2, A1:F1) returns 1.

SLOPE(A2:F2, A1:F1) returns 2.

INTERCEPT(A5:F5, A4:F4) returns 2.392.

Examples

To find the interest portion of the first payment on a $1000 loan at 12% annual interest with payments 
due at the end of each month: 
  
IPMT(0.12/12, 1, 12, 1000) returns -$10.
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IRR
The IRR function calculates the internal rate of return for an investment that is based on 
a series of potentially irregular cash flows rather than fixed-interest income. The rate 
returned is the rate that makes the net present value of a series of cash flows 0.

IRR(flows-range, [estimate])
Â flows-range:  A range of cells that contain cash flow values. Positive values represent 

income. Negative values represent expenditures. All values must represent equal 
time intervals.

Â estimate:  Optional; an initial estimate for the rate of return. If omitted, 10% is used. 
Try adjusting the estimate if IRR fails to return a result.

  

ISBLANK
The ISBLANK function returns TRUE if the specified cell is empty and FALSE otherwise.

ISBLANK(cell)
Â cell:  A reference to a table cell.
  

Examples

If cells A1:F1 contain -1000, 50, 50, 50, 50, 1050: 
  
IRR(A1:F1) returns 5%, the rate of return if you invest $1,000 and receive $50 per year for 4 years and a 
final payment of $1,050 in the fifth year.

To find the rate of return if you pay $20,000 for a machine, run the machine for 5 years generating 
$8,000 per year, and then sell the machine at the end of the fifth year for $2,000, enter -20000, 8000, 
8000, 8000, 8000, 10000 in cells A1:A6 and use the formula IRR(A1:A6). The value 30.06% is returned.

Examples

Given the following table: 
  

ISBLANK(A1) returns TRUE.

ISBLANK(B2) returns FALSE.
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ISERROR
The ISERROR function returns TRUE if the expression in the function’s argument 
evaluates to an error and FALSE otherwise.

ISERROR(cell)
Â cell:  A reference to a table cell that contains a formula.
  

ISEVEN
The ISEVEN function returns TRUE if the value is even (leaves no remainder when 
divided by 2) and FALSE otherwise.

ISEVEN(number)
Â number:  A number, numeric expression, or reference to a cell containing a numeric 

expression.

Notes
Fractional parts of a number are ignored.

Dates are not considered even or odd; if value is a date, an error is returned.

  

ISODD
The ISODD function returns TRUE if the value is odd (leaves a remainder when divided 
by 2) and FALSE otherwise.

ISODD(number)
Â number:  A number, numeric expression, or reference to a cell containing a numeric 

expression.

Notes
Fractional parts of a number are ignored.

Dates are not considered even or odd; if value is a date, an error is returned.

Examples

If cell A1 contains =QUOTIENT(3,0): 
  
ISERROR(A1) returns TRUE. (You can’t divide by 0.)

Examples

ISEVEN(2) returns TRUE.

ISEVEN(2.75) returns TRUE.

ISEVEN(3) returns FALSE.
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ISPMT
The ISPMT function calculates the interest due for a particular payment period of an 
investment. 

ISPMT(rate, period, num-periods, present-value)
Â rate:  The interest rate for each period.
Â period:  The period for which you want to find the interest.
Â num-periods:  The number of periods in the life of the investment.
Â present-value:  The present value of the loan or investment.

Notes
This function, which duplicates the capabilities of the IPMT function, helps you to use 
spreadsheets from older spreadsheet applications.

Be sure that the interest rate is expressed as the rate per period. For example, if the 
interest rate is 10% per year and the payment period is monthly, the rate used in the 
function should be 0.1/12 (approximately 0.00833 per month).

  

LARGE
The LARGE function retrieves the nth-largest value within a range. The largest value is 
ranked number 1.

LARGE(range, n)
Â range:  The array of cells containing the values.
Â n:  A number representing the size ranking of the value you want to retrieve (1 is 

largest, 2 is second-largest, and so on).

Notes
If n is omitted, is less than or equal to 0, or is greater than the number of values in the 
range, an error is returned.

Examples

ISODD(3) returns TRUE.

ISODD(3.75) returns TRUE.

ISODD(2) returns FALSE.

Examples

To find the interest portion of the first payment on a $1000 loan at 12% annual interest with payments 
due at the end of each month: 
  
IPMT(0.12/12, 1, 12, 1000) returns -$10.
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LCM
The LCM function finds the least common multiple of the specified numbers. 
Sometimes called the lowest or smallest common multiple, the least common multiple 
is the smallest integer that is a multiple of the specified numbers.

LCM(number, [number, . . .])
Â number:  Zero or one or more positive numbers or numeric expressions, or references 

to cells containing positive numbers or numeric expressions. Fractional parts are 
ignored. Negative numbers are not allowed.

  

Examples

Given the following table: 
  

LARGE(A2:E2, 1) returns 50, the largest value in the range.

LARGE(A2:E2, 2) returns 40, the second-largest value in the range.

LARGE(A2:E2, 5) returns 10, the fifth-largest value in the range.

LARGE(A2:E2) displays an error; you must specify n.

LARGE(A2:E2, 0) displays an error; n must be greater than 0.

LARGE(A2:E2, 6) displays an error; you can’t find the sixth out of five values.

Examples

LCM(2, 3) returns 6.

LCM(34, 68) returns 68.

LCM(30, 40, 60) returns 120.

LCM(30.25, 40.333, 60.5) returns 120 (the fractional parts are ignored).

LCM(2, -3) displays an error (negative numbers are not allowed).
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LEFT
The LEFT function retrieves the specified number of characters from the left end of a 
string.

LEFT(text, [length])
Â text:  A text expression.
Â length:  Optional; the number of characters to retrieve. If omitted, the leftmost 

character is retrieved.
  

LEN
The LEN function counts the number of characters in a string. The count includes all 
spaces, numbers, and special characters.

LEN(text)
Â text:  A text expression.
  

LN
The LN function calculates the natural logarithm of a number, the power to which e 
must be raised to produce the number.

LN(number)
Â number:  A positive number, a numeric expression, or a reference to a cell containing 

a positive numeric expression.
  

Examples

LEFT("one two three", 2) returns "on".

LEFT("abc") returns "a".

Examples

LEN("12345") returns 5.

LEN("   abc   def   ") returns 15, the sum of the six letters plus the three leading, three trailing, and 
three separating spaces.

Examples

LN(2.71828) returns approximately 1, the power to which e must be raised to produce 2.71828.

LN(EXP(1)) returns 1. LN is the inverse of the EXP function.
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LOG
The LOG function calculates the logarithm of a number with a specified base.

LOG(number, [base])
Â number:  A positive number.
Â base:  Optional; a positive number not equal to 1. If omitted, 10 is used.
  

LOG10
The LOG10 function calculates the base-10 logarithm of a number.

LOG10(number)
Â number:  A positive number.

Notes
To find the logarithm for a base other than 10, use the LOG function.
  

LOOKUP
The LOOKUP function finds a match to your search value in one range, then retrieves 
the value in the cell with the same relative position in a second range.

LOOKUP(search-value, search-range, [result-range])
Â search-value:  The text or numeric expression you want to search for in the search 

range.
Â search-range:  The range of cells that you want to search for the search value.
Â result-range:  Optional; If omitted, the result is returned from the last row or column 

of search-range, whichever is the longer dimension.

Examples

LOG(8, 2) returns 3.

LOG(100, 10) and LOG(100) both return 2.

LOG(5.0625, 1.5) returns 4.

Examples

LOG10(1) returns 0.

LOG10(10) returns 1.

LOG10(100) returns 2.

LOG10(1000) returns 3.
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LOWER
The LOWER function converts uppercase characters in text to lowercase.

LOWER(text)
Â text:  A text expression or reference to a cell containing a text expression.
  

MATCH
The MATCH function finds the position of a value within a row or column range. Cell 
numbering starts with 1 at the top or left cell for vertical and horizontal ranges, 
respectively. Searches are performed top-to-bottom and left-to-right.

MATCH(search-value, cell-range, [method])
Â search-value:  The text or numeric expression you want to find.
Â cell-range:  A range of cells within a single row or column.
Â method:  Optional; specifies how value matching is performed:

1 (or omitted) matches the cell containing the largest value less than or equal to 
search-value.

0 matches the first cell with a value that matches search-value exactly.

–1 matches the cell containing the smallest value greater than or equal to search-
value.

Examples

Given the following table: 
  

LOOKUP("C", A1:F1, A2:F2) returns 30.

LOOKUP(40, A2:F2, A1:F1) returns D.

LOOKUP("B", A1:C1, D2:F2) returns 50.

Examples

LOWER("UPPER") returns "upper".

LOWER("Lower") returns "lower".

LOWER("MiXeD") returns "mixed".
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Notes
When searching for text, case is ignored.

MATCH works only on a range that is part of a single row or column; you can’t use it to 
search a two-dimensional table.

  

MAX
The MAX function finds the largest number in a set.

MAX(number, [number, . . .])
Â number:  A series of numbers, numeric expressions, or references to cells containing 

numbers or numeric expressions.

Notes
Cells that don’t contain numbers are ignored. 

Text entered directly in the arguments results in an error.

  

Examples

Given the following table: 
  

MATCH(40, A1:A5) returns 4.

MATCH(40, E1:E5) returns 1.

MATCH(35, E1:E5, 1) returns 3 (30 is the largest value less than or equal to 35).

MATCH(35, E1:E5, -1) returns 1 (40 is the smallest value greater than or equal to 35).

MATCH(35, E1:E5, 0) displays an error (no exact match can be found).

Examples

MAX(5, 5, 5, 5, 6) returns 6.

MAX(1, 2, 3, 4, 5) returns 5.
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MAXA
The MAXA function finds the largest number in a set of values. In addition to numeric 
values, text values and logical FALSE are counted as 0 and logical TRUE is counted as 1.

MAXA(value, [value, . . .])
Â value:  A series of numbers or numeric expressions, or references to cells containing 

numbers, numeric expressions, text, or Boolean values.

Notes
Text entered directly in the arguments results in an error.
  

MEDIAN
The MEDIAN function finds the median value in a set of numbers. The median is the 
“middle” value in the sense that half the numbers in the set are less than the median 
and half are greater.

MEDIAN(number, [number, . . . ])
Â number:  A series of numbers, numeric expressions, or references to cells containing 

numbers or numeric expressions.

Notes
If there is an even number of values in the set, the MEDIAN function returns the 
average of the two middle values.
  

MID
The MID function extracts the specified number of characters from a string starting at 
the specified position.

MID(text, start, length)
Â text:  A text expression.
Â start:  The number of the first character to extract. Position 1 is the first character in 

the string.
Â length:  The number of characters to extract.

Examples

MAXA(1, 2, 3, 4) returns 4.

MAXA(A1:C1), where A1:C1 contains -1, -10, hello, returns 0.

Examples

MEDIAN(1, 2, 3, 4, 5) returns 3.

MEDIAN(1, 2, 3, 4, 5, 6) returns 3.5.

MEDIAN(5, 5, 5, 5, 6) returns 5.
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MIN
The MIN function finds the smallest number in the list of arguments.

MIN(number, [number, . . .])
Â number:  A series of numbers, numeric expressions, or references to cells containing 

numbers or numeric expressions.

Notes
Cells that don’t contain numbers are ignored.

Text entered directly in the arguments results in an error.

  

MINA
The MINA function finds the smallest number in a set of values. In addition to numeric 
values, text values and logical FALSE are counted as 0 and logical TRUE is counted as 1.

MINA(value, [value, . . .])
Â values:  A series of numbers or numeric expressions, or references to cells containing 

numbers, numeric expressions, text, or Boolean values. Text values are evaluated as 0.

Notes
Text entered directly in the arguments results in an error.
  

Examples

MID("lorem ipsum dolor sit amet",7, 5) returns "ipsum".

MID("1234567890",4,3) returns "456".

MID("shorten", 5, 20) returns "ten".

Examples

MIN(5, 5, 5, 5, 6) returns 5.

MIN(1, 2, 3, 4, 5) returns 1.

Examples

MINA(1, 2, 3, 4) returns 1.

MINA(A1:C1), where A1:C1 contains -1, -10, hello, returns -10.

MINA(A1:C1), where A1:C1 contains 1, 10, hello, returns 0.
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MINUTE
The MINUTE function extracts the minutes from a date or time.

MINUTE(date-time)
Â date-time:  Any valid Numbers date or time value.
  

MIRR
The MIRR function calculates the modified internal rate of return of a series of periodic 
cash flows. MIRR stands for modified internal rate of return.

MIRR(cash-flows, finance-rate, reinvest-rate)
Â cash-flows:  One or more future cash flows. Values are ranges or arrays.
Â finance-rate:  The interest rate on cash-flows.
Â reinvest-rate:  The rate at which positive cash flows can be reinvested.
  

MOD
The MOD function calculates the remainder upon division.

MOD(number, divisor)
Â number:  The dividend. It’s a number, cell reference, or the result of an arithmetic 

operation.
Â divisor:  Any number but 0. The sign of the result matches that of the dividend, no 

matter what the sign of the divisor is.

Notes
When both a positive and a negative remainder exist, MOD returns the remainder 
whose sign matches the sign of the divisor. 

When computing MOD(a, b), MOD gives a number r such that a = bk + r, where r is 
between 0 and b, and k is an integer. 

MOD(a,b) is equivalent to a–b*INT(a/b).

Examples

MINUTE("4/6/88 11:59:22 AM") returns 59.

Examples

MIRR({-5000, 2000, 4000, -2000, 5000}, 0.1, 0.15) returns 19.66% (when using the percent number 
format).
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MODE
The MODE function finds the most frequently occurring value in a set of numbers.

MODE(number, [number, . . .])
Â number:  A set of numbers, numeric expressions, or references to cells containing 

numbers or numeric expressions.

Notes
If more than one number occurs multiple times in the arguments, MODE returns the 
first qualifying number.

If no value occurs more than once, MODE reports an error.

  

MONTH
The MONTH function extracts the month number from a date.

MONTH(date)
Â date-time:  Any valid Numbers date.
  

Examples

MOD(6, 3) returns 0.

MOD(7, 3) returns 1.

MOD(8, 3) returns 2.

MOD(-8, 3) returns 1.

MOD(4.5, 2) returns 0.5.

MOD(7, 0.75) returns 0.25.

Examples

MODE(5, 5, 5, 5, 6) returns 5.

MODE(1, 2, 3, 4, 5) returns an error.

MODE(2, 2, 4, 6, 6) returns 2.

MODE(6, 6, 4, 2, 2) returns 6.

Examples

MONTH("April 6, 1988 11:59:22 AM") returns 4.
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MROUND
The MROUND function rounds a number to the nearest multiple of a specified factor.

MROUND(number, factor)
Â number:  The number you want to round. It can be a numeric expression, or a 

reference to a cell containing a numeric expression.
Â factor:  The number whose multiples you want to round to.

Notes
Relative number size is based on magnitude (distance from 0).

Both arguments must have the same sign.

  

NOT
The NOT function evaluates the truth value of an expression and then returns the 
reverse. If the expression is true, the function returns FALSE; if the expression is false, 
the function returns TRUE.

NOT(expression)
Â expression:  A logical or numeric expression. 

Notes
If expression is a numeric expression, a value of 0 is interpreted as false and any nonzero 
value is interpreted as true.
  

Examples

MROUND(2, 3) returns 3.

MROUND(4, 3) returns 3.

MROUND(4.4999, 3) returns 3.

MROUND(4.5, 3) returns 6.

MROUND(-4.5, 3) returns an error.

Examples

NOT(0) returns TRUE because 0 in interpreted as FALSE.

OR(A9, NOT(A9)) always returns TRUE because either A9 or its opposite will always be true.

NOT(OR(FALSE,FALSE)) mimics a logical NOR. In this case, it returns TRUE because neither argument of 
the logical OR is true.
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NOW
The NOW function gets the current date and time from the computer’s clock. Time 
zones aren’t taken into account.

NOW()
Â No arguments (but you must include the parentheses).

Notes
The displayed date and time are updated every time you open or modify your 
document.

Whether you see the date, the time, or both depends on the cell formatting. See “Using 
the Date and Time Format” on page 62 for more information.

You can use the TODAY function to get the current date; the value returned is 
formatted to hide the time, which is always set to 12:00.

  

NPER
The NPER function calculates the number of payment periods for a loan or investment 
based on fixed payments and a fixed interest rate.

NPER(rate, payment, present value, [future value], [when-due])
Â rate:  The interest rate per period.
Â payment:  The payment to be made per period.
Â present-value:  The present value of the investment.
Â future-value:  Optional; the future value of the investment or cash value remaining 

after final payment. If omitted, future value is assumed to be 0.
Â when-due:  Optional; specifies whether payments are made at the beginning or end 

of each period:
0 (or omitted) means payments are at the end of each period. 

1 means payments are at the beginning of each period.

Notes
Be sure that the rate is expressed as the rate per period. For example, if the interest rate 
is 10% per year and the payment period is monthly, the rate used in the function 
should be 0.1/12 (approximately 0.00833 per month).

Examples

If your document is updated on October 4, 2008, NOW() returns October 4, 2008 10:47 AM unless the 
cell holding the return value is otherwise formatted.
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NPV
The NPV function calculates the net present value of an investment based on a series of 
future cash flows, assuming a fixed interest rate.

NPV(rate, cash-flow, [cash-flow, . . .])
Â rate:  The fixed interest rate.
Â cash-flow:  One or more cash flows, such as payments (negative values) or income 

(positive values). Specify the values in chronological order. Ranges can be used for 
values.

  

ODD
The ODD function rounds a number away from zero to the next odd number.

ODD(number)
Â number:  The number you want to round. It can be a number, numeric expression, or 

a reference to a cell containing a numeric expression.

Notes
To round to an even number, use the EVEN function.
  

Examples

NPER(0.1/12,-100,1000) returns 10.5 months, which you would round to 11, the time it takes to pay off a 
$1,000 loan at an annual interest rate of 10% if you make monthly payments of $100.

Examples

NPV(10%,-5000,0,10000,10000,10000) returns $16007.04 (when using the currency number format). The 
return value indicates that the net present value of a $5,000 investment at 10% interest, followed by 
an income flow of $0, $10,000, $10,000, and $10,000, is $16,007.04 after four years.

Examples

ODD(1) returns 1.

ODD(2) returns 3.

ODD(2.5) returns 3.

ODD(-2.5) returns -3.

ODD(0) returns 1.
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OFFSET
The OFFSET function retrieves a range of cells that is the specified number of rows and 
columns away from the specified base cell.

OFFSET(base, row-offset, column-offset, [rows], [columns])
Â base:  The address of the cell from which the offsets are measured.
Â row-offset:  The number of rows from the base cell to the target cell. 0 means the 

target cell is in the same row as the base cell. A negative number means the target is 
to the left of the base.

Â column-offset:  The number of columns from the base cell to the target cell. 0 means 
the target is in the same column as the base cell. A negative number means the 
target is above the base.

Â rows:  Optional; the number of rows to retrieve starting with the offset location. If 
omitted, 1 is used.

Â columns:  Optional; the number of columns to retrieve starting with the offset 
location. If omitted, 1 is used.

  

OR
The OR function returns TRUE if any argument is true and FALSE otherwise.

OR(expression, [expression, . . .])
Â expression:  One or more logical or numeric expressions.

Notes
If expression is a numeric expression, a value of 0 is interpreted as FALSE and any 
nonzero value is interpreted as TRUE.
  

Examples

OFFSET(A1,5,5) returns the value in cell F6 (the cell 5 columns to the right and 5 rows below cell A1).

OFFSET(G33,0,-1) returns the value in the cell to the left of G33 (the value in F33).

Examples

OR(A1+A2<100,B1+B2<100) returns false if the sums of the indicated cells are both greater than or 
equal to 100, and true if at least one of the sums is less than 100. 

OR(5,0,6) returns true because at least one argument is not zero.
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PERCENTILE
The PERCENTILE function finds the value within a range of values that corresponds to a 
particular percentile.

PERCENTILE(data, percentile)
Â data:  A range of cells containing the data.
Â percentile:  The percentile value you want to find.
  

PI
The PI function returns the approximate value of pi, the ratio of a circle’s circumference 
to its diameter, accurate to 15 decimal places.

PI()
Â No arguments (but you must include the parentheses).
  

Examples

Given the following table:
  

PERCENTILE(A2:E2, 0.5) returns 80, the 50th percentile of the range.

PERCENTILE(A4:E4, 0.5) returns 90, the 50th percentile of the range.

Examples

PI() returns 3.14159265358979.

SIN(PI()/2) returns 1, the sine of PI/2 radians or 90 degrees.
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PMT
The PMT function calculates fixed, periodic payments, given the interest rate, number 
of periods, present value, future value, and type of payment.

PMT(rate, num-periods, present-value, [future-value], [when-due])
Â rate:  The interest rate per period.
Â num-periods:  The number of periods.
Â present-value:  The present value of the investment.
Â future-value:  Optional; the future value of the investment or cash value remaining 

after final payment. If omitted, future-value is assumed to be 0.
Â when-due:  Optional; specifies whether payments are made at the beginning or end 

of each period:
0 (or omitted) means payments are at the end of each period. 

1 means payments are at the beginning of each period. 

Notes
To break down a payment into principal and interest components, you can use the 
PPMT and IPMT functions.
  

POISSON
The POISSON function uses the Poisson distribution to calculate the probability that a 
specific number of events will occur.

POISSON(events, mean, cumulative)
Â events:  The number of events (arrivals) for which you want to calculate the 

probability.
Â mean:  The known average rate of events.
Â cumulative:  Determines whether the reported probability is cumulative:

TRUE calculates the probability that there will be the specified number of arrivals or 
fewer (also called the cumulative probability).

FALSE calculates the probability that there will be the specified number of arrivals 
(sometimes called the probability mass).

Examples

PMT(10%/12,36,10000,0) returns -$322.67. The return value indicates that a $12,000 purchase minus a 
$2,000 down payment (or $10,000) over 36 months at a 10% interest rate requires monthly payments 
of $322.67.
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POWER
The POWER function raises a number, the base, to a power, the exponent. Produces the 
same result as the ^ operator.

POWER(base, exponent)
Â base:  The number that you want to raise to a power.
Â exponent:  The power to which you want to raise the base number.

Notes
You can also use the exponentiation operator ^ to raise a number to a power: 
POWER(2, 3) has the same result as 2^3.
  

PPMT
The PPMT function calculates the principal portion of a payment for a loan or 
investment at a specified period based on periodic fixed payments and a fixed interest 
rate.

PPMT(rate, period, num-periods, present-value, [future-value], [when-due])
Â rate:  The interest rate for each period.
Â period:  The period for which you want to find the principal.
Â num-periods:  The number of periods in the life of the investment.
Â present-value:  The present value of the loan or investment.
Â future-value:  Optional; the target future value, if this in an investment. If omitted, 

assumed to be 0.
Â when-due:  Optional; specifies whether payments are made at the beginning or end 

of each period:
0 (or omitted) means payments are at the end of each period. 

1 means payments are at the beginning of each period. 

Examples

For a mean of 10 and an arrival rate of 8:
  
POISSON(8, 10, FALSE) returns 0.112599.

Examples

POWER(2, 3) returns 8.

POWER(2, 10) returns 1024.

POWER(0.5, 3) returns 0.125.

POWER(100, 0.5) returns 10.
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Notes
Be sure that the interest rate is expressed as the rate per period. For example, if the 
interest rate is 10% per year and the payment period is monthly, the rate used in the 
function should be 0.1/12 (approximately 0.00833 per month).
  

PRICE
The PRICE function calculates the price of a security that pays periodic interest per $100 
par value.

PRICE(settle, maturity, rate, yield, value, frequency, [day-count])
Â settle:  The settlement date.
Â maturity:  The date when the security expires.
Â rate:  The annual coupon rate.
Â yield:  The annual yield of the security.
Â value:  The redemption value on the maturity date. Expressed per $100 par value.
Â frequency:  The number of coupon payments each year.

1 means annual payments.

2 means semiannual payments (twice per year).

4 means quarterly payments (four per year).

Â day-count:  Optional; specifies the number of days per month and days per year used 
in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

Examples

To find the principal portion of the first payment on a $1000 loan at 12% annual interest with 
payments due at the end of each month:
  
PPMT(0.12/12, 1, 12, 1000) returns -$78.85.

Examples

If cells A1:F1 contain1/1/2000, 1/1/2001, 0.05, 0.1, 100, 2:
  
PRICE(A1, A2, A3, A4, A5, A6) returns 95.35157.
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PRICEDISC
The PRICEDISC function calculates the price of a discounted security per $100 par value.

PRICEDISC(settle, maturity, discount, value, [day-count])
Â settle:  The settlement date.
Â maturity:  The date when the security expires.
Â discount:  The discount rate.
Â value:  The redemption value on the maturity date. Expressed per $100 par value.
Â day-count:  Optional; specifies the number of days per month and days per year used 

in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

  

PRICEMAT
The PRICEMAT function calculates the price of a security that pays interest at maturity 
per $100 par value.

PRICEMAT(settle, maturity, issue, rate, yield, [day-count])
Â settle:  The settlement date.
Â maturity:  The date when the security expires.
Â issue:  The issue date of the security.
Â rate:  The redemption value on the maturity date. Expressed per $100 par value.
Â yield:  The annual yield.
Â day-count:  Optional; specifies the number of days per month and days per year used 

in the calculations (sometimes called the day count basis).
0 or omitted uses 30/360 (30 days for each month, 360 days in a year).

1 uses actual/actual (the number of days shown on a calendar).

2 uses actual/360 (calendar days for each month but 360 days per year).

3 uses actual/365 (calendar days for each month but 365 days per year).

4 uses 30E/360 (European 30/360).

Examples

If cells A1:D1 contain 1/1/2000, 1/1/2001, 0.1, 100:
  
PRICEDISC(A1, B1, C1, D1) returns 90.
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PROB
The PROB function calculates the probability of a range of values if you know the 
probabilities of the individual values.

PROB(values, probabilities, lower, [upper])
Â values:  A range of cells containing data values.
Â probabilities:  A range of cells containing the probability of each corresponding value 

in values. The sum of the probabilities must add up to 1.
Â lower:  The lower limit of the range for which you want to find the probability.
Â upper:  Optional; the upper limit of the range for which you want to find the 

probability. If omitted, PROB finds the probability of the single number specified for 
lower.

  

Examples

If cells A1:E1 contain 1/1/2000, 1/1/2010, 1/1/1999, 0.1, 0.1:
  
PRICEMAT(A1, B1, C1, D1, E1) returns 95.

Examples

Given the following table:
  

PROB(A1:A10, C1:C10, 4, 6) returns 0.3, the probability that the value is 4, 5, or 6.

PROB(A1:A10, C1:C10, 5, 9) returns 0.5, the probability that the value is 5 or greater.

PROB(A1:A10, E1:E10, 4, 6) returns 0.59, the probability that the value is 4, 5, or 6.

PROB(A1:A10, E1:E10, 6) returns 0.21, the probability that the value is 6.
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PRODUCT
The PRODUCT function calculates the product of the numbers in the arguments.

PRODUCT(number, [number, . . .])
Â number:  One or more numbers or numeric expressions, or references to cells 

containing numbers or numeric expressions.

Notes
Empty cells in a range are ignored and do not affect the result.
  

PROPER
The PROPER function changes the first character in each word of text to uppercase. All 
other characters are changed to lowercase.

PROPER(text)
Â text:  A text expression.

Notes
Any character following a nonalphabetic character is treated as the first letter in a word. 
So, for example, any letter following a hyphen is capitalized.
  

PV
The PV function calculates the present value of an investment, which is the current 
value of a series of future payments, based on a specific periodic interest rate over a 
given number of periods for a given payment amount. PV stands for present value.

PV(rate, num-periods, [payment], [future-value], [when-due])
Â rate:  The interest rate per period.
Â num-periods:  The number of periods.
Â payment:  Optional; the payment to be made per period. If omitted, you must include 

future-value.

Examples

PRODUCT(2, 4) returns 8.

PRODUCT(0.5, 5, 4, 5) returns 50.

Examples

PROPER("lorem ipsum") returns "Lorem Ipsum".

PROPER("lorem’s ip-sum") returns "Lorem’s Ip-Sum".

PROPER("1a23 b456") returns "1A23 B456".
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Â future-value:  Optional; the future value of the investment or cash value remaining 
after final payment. If omitted, future value is assumed to be 0 and you must include 
payment.

Â when-due:  Optional; specifies whether payments are made at the beginning or end 
of each period:
0 (or omitted) means payments are at the end of each period. 

1 means payments are at the beginning of each period. 

  

QUOTIENT
The QUOTIENT function finds the integer quotient of two numbers, that is, the whole 
part of the quotient with the fractional part (or remainder) truncated.

QUOTIENT(dividend, divisor)
Â dividend:  The number you want to divide.
Â divisor:  The number you want to divide by.
  

RADIANS
The RADIANS function converts degrees to radians, the standard angle measure used 
for trigonometric functions.

RADIANS(degrees)
Â degrees:  A numeric expression.
  

Examples

PV(10%,5,-100,5000) returns -$2725.53, unless the cell holding the return value has been formatted. 
The return value indicates that to accumulate $5,000 in five years, when making payments of $100 at 
the end of each year, you would have to invest $2,725.53 now, at an interest rate of 10%.

Examples

QUOTIENT(5, 2) returns 2.

QUOTIENT(-5, 2) returns -2.

QUOTIENT(5.99, 2) returns 2.

QUOTIENT(6, 2) returns 3.

QUOTIENT(5, 6) returns 0.

Examples

RADIANS(90) returns 1.5708 (90 degrees is approximately 1.5708 radians).

RADIANS(57.2957795130823) returns 1 (1 radian is approximately 57.296 degrees).
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RAND
The RAND function generates a random number greater than or equal to 0 and less 
than 1.

RAND()
Â No arguments (but you must include the parentheses).

Notes
Any time you change a value in the table, a new random number is generated.
  

RANDBETWEEN
The RANDBETWEEN function generates a random integer in the range of the specified 
minimum and maximum.

RANDBETWEEN(min, max)
Â min:  The smallest number.
Â max:  The largest number.

Notes
Any time you change a value in the table, a new random number is generated.
  

RANK
The RANK function finds the rank of a number within a range of numbers. You can 
choose to rank the numbers from largest down, or smallest up.

RANK(number, range, [order])
Â number:  The number whose rank you want to find.
Â range:  A reference to the range within which you want to rank number.
Â order:  Optional: specifies whether the smallest or the largest value in the range is 

ranked 1.
0 (or omitted) ranks the number as if the largest value in the array has ranking 1.

Any other number ranks the number as if the smallest value in the array as ranking 1.

Examples

RAND() returns, for example, 0.67, 0.12, 0.8, and 0.9 after 4 recalculations.

Examples

RANDBETWEEN(1, 10) returns, for example, 7, 2, 9, 3, and 9 during subsequent recalculations.
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Notes
Equal numbers are ranked the same, but each counts as a rank position, so the next 
different number doesn’t get the next rank position. (Just like in sports competitions, if 
there’s a tie for first place, the next competitor gets third place, not second.) See the 
examples.
  

RATE
The RATE function calculates the interest rate of an annuity (a fixed sum paid 
periodically over a specified period of time). If either present-value or num-periods is 0, 
the function returns an error.

RATE(num-periods, [payment], present-value, [future-value], [when-due], [estimate])
Â num-periods:  The number of payment periods.
Â payment:  Optional; the amount of the fixed, periodic payment. If omitted, you must 

include future-value.
Â present-value:  The present value of the investment.
Â future-value:  Optional; the future value of the investment. If omitted, is assumed to 

be 0.
Â when-due:  Optional; specifies whether payments are made at the beginning or end 

of each period:
0 (or omitted) means payments are at the end of each period. 

1 means payments are at the beginning of each period. 

Examples

Given the following table:
  

RANK(20, A2:E8) returns 7. 

RANK(20, A2:E2) returns 4 (50 ranks first).

RANK(20, A2:E2, 1) returns 2 (10 ranks first).

RANK(10, A4:E4) returns 5 (10 is the smallest in the range).

RANK(4, A6:E7, 1) returns 4.

RANK(5, A6:E7, 1) returns 6 (because there are two 4’s).
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Â estimate:  Optional; an initial rough estimate of the interest rate. If omitted, 10% is 
used. Try adjusting the estimate if RATE fails to return a result.

  

REPLACE
The REPLACE function replaces part of a string with characters from a second string. 
The text to be replaced is specified by its length and position in the text.

REPLACE(current-text, start, length, new-text)
Â current-text:  A text expression.
Â start:  A number indicating the first character to replace.
Â length:  The number of characters to replace.
Â new-text:  The replacement text.

Notes
The new text doesn’t need to be the same length as the removed text.
  

REPT
The REPT function repeats text a specified number of times.

REPT(text, copies)
Â text:  The text expression to be repeated.
Â copies:  The number of times text is repeated.
  

Examples

RATE(10*12,,-5000,20000) returns 1.16% (when using a fixed number format with a precision of 4). The 
return value indicates that a monthly interest rate of 1.16% (or 13.9% annually) is required for $5,000 to 
grow to $20,000 in 10 years. The number of years is multiplied by 12 to find the number of monthly 
payments.

Examples

REPLACE("received applicant’s forms",10, 9,"Frank") returns "received Frank’s forms".

Examples

REPT("*",5) returns "*****".

REPT("ha",3) returns "hahaha".
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RIGHT
The RIGHT function retrieves the specified number of characters from the right end of a 
string.

RIGHT(text, [length])
Â text:  A text expression.
Â length:  Optional; the number of characters you want to retrieve. If omitted, returns 1 

character.
  

ROMAN
The ROMAN function converts a number to Roman numerals.

ROMAN(number, [style])
Â number:  The Arabic numeral that you want to convert. Must be nonnegative and less 

than 4000.
Â style:  Optional; determines how strictly the classical rules for forming Roman 

numerals are applied:
0 (or TRUE, or omitted) uses the most strict classical rules. When a smaller numeral 
precedes a larger to indicate subtraction, the smaller must be a power of 10 and can 
precede a number no more than 10 times its size. For example, 999 is represented as 
CMXCIX, but not LMVLIV.

1 relaxes the strict classical rule by one degree. When a smaller number precedes a 
larger, the smaller need not be a power of 10 and the relative size rule is extended by 
one numeral. For example, 999 can be represented as LMVLIV, but not XMIX.

2 relaxes the classical rule by two degrees. When a smaller number precedes a larger, 
the relative size rule is extended by two numerals. For example, 999 can be 
represented as XMIX, but not VMIV.

3 relaxes the classical rule by three degrees. When a smaller number precedes a 
larger, the relative size rule is extended by two numerals. For example, 999 can be 
represented as VMIV, but not IM.

4 or FALSE relaxes the classical rule by four degrees. When a smaller number 
precedes a larger, the relative size rule is extended by two numerals. For example, 
999 can be represented as IM.

Examples

RIGHT("one two three", 2) returns "ee".

RIGHT("abc") returns "c".
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ROUND
The ROUND function rounds a number to the specified number of places. 

ROUND(number, digits)
Â number:  The number you want to round. It can be a numeric expression in the 

function or a reference to a cell containing a numeric expression.
Â digits:  The number of digits you want to round to, relative to the decimal point. A 

positive number represents digits (decimal places) to the right of the decimal point. 
A negative number specifies digits to the left of the decimal point.

Notes
Other functions related to rounding numbers: CEILING, INT, ROUNDUP, ROUNDDOWN, 
TRUNC.
  

ROUNDDOWN
The ROUNDDOWN function rounds a number toward zero to the specified number of 
places.

ROUNDDOWN(number, digits)
Â number:  The number you want to round. It can be a numeric expression in the 

function or a reference to a cell containing a numeric expression.
Â digits:  The number of digits of the result relative to the decimal point. A positive 

number represents digits (decimal places) to the right of the decimal point. A 
negative number specifies digits to the left of the decimal point.

Examples

ROMAN(12) returns XII.

ROMAN(999) returns CMXCIX.

ROMAN(999,1) returns LMVLIV.

ROMAN(999,2) returns XMIX.

ROMAN(999,3) returns VMIV.

ROMAN(999,4) returns IM.

Examples

ROUND(1.49,0) returns 1.

ROUND(1.50,0) returns 2.

ROUND(1.23456,3) returns 1.235.

ROUND(1111.222,-2) returns 1100.

ROUND(-2.2,0) returns -2.

ROUND(-2.8,0) returns -3.
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Notes
Other functions related to rounding numbers: CEILING, INT, ROUND, ROUNDUP, TRUNC.
  

ROUNDUP
The ROUNDUP function rounds a number away from zero to the specified number of 
places.

ROUNDUP(number, digits)
Â number:  The number you want to round. It can be a number, numeric expression, or 

a reference to a cell containing a numeric expression.
Â digits:  The number of digits of the result relative to the decimal point. A positive 

number represents digits (decimal places) to the right of the decimal point. A 
negative number specifies digits to the left of the decimal point.

Notes
Other functions related to rounding numbers: CEILING, INT, ROUND, ROUNDDOWN, 
TRUNC.
  

Examples

ROUNDDOWN(1.49,0) returns 1.

ROUNDDOWN(1.50,0) returns 1.

ROUNDDOWN(1.23456,3) returns 1.234.

ROUNDDOWN(1111.222,-2) returns 1100.

ROUNDDOWN(-2.2,0) returns -2.

ROUNDDOWN(-2.8,0) returns -2.

Examples

ROUNDUP(1.49,0) returns 2.

ROUNDUP(1.50,0) returns 2.

ROUNDUP(1.23456,3) returns 1.235.

ROUNDUP(1111.222,-2) returns 1200.

ROUNDUP(-2.2,0) returns -3.

ROUNDUP(-2.8,0) returns -3.
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ROW
The ROW function returns the row number of the specified cell.

ROW([cell])
Â cell:  Optional; a reference to a single cell. If not provided, ROW returns the row of the 

cell containing the function.
  

ROWS
The ROWS function counts how many rows are in the specified range of cells.

ROWS(cell-range)
Â cell-range:  A reference to a range of cells.

Notes
If you select an entire column for cell-range, Numbers returns the total number of cells 
in the column, which changes when you resize the table.
  

SEARCH
The SEARCH function finds the starting position of one string within another, ignoring 
case but allowing wildcards.

SEARCH(search-text, where-to-look, [start])
Â search-text:  The string you want to find. You can include an asterisk (*) to match any 

number of characters or a question mark (?) to match any single character.
Â where-to-look:  The text in which you want to look for the string.
Â start:   Optional; a number indicating the position in the text where you want to start 

the search. If omitted, the search starts at the beginning of the text.

Examples

ROW(B7) returns 7, the number of row 7.

ROW() returns the absolute row number of the cell containing the function.

Examples

ROWS(A11:D20) returns 10, the number of rows from 11 through 20.

ROWS(D:D) returns the total number of rows in column D.
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SECOND
The SECOND function extracts the seconds from a date.

SECOND(datetime)
Â date-time:  Any valid Numbers date or time value.
  

SIGN
The SIGN function returns 1 when the argument number is positive, –1 when it is 
negative, and 0 when it is zero.

SIGN(number)
Â number:  The number you want to find the sign of. It can be a reference to a cell 

containing a number.
  

SIN
The SIN function calculates the sine of an angle in radians.

SIN(radian-angle)
Â radian-angle:  The angle in radians.

Notes
If you measure angles in degrees instead of radians, you can use the RADIANS function 
to convert degrees to radians for the SIN function.

If you want to express radians as a multiple of pi, you can use the PI() function to 
provide a value for pi.

Examples

SEARCH("ra", "abracadabra") returns 3; the first occurrence of the string "ra" starts at the third 
character in "abracadabra".

SEARCH("ra", "abracadabra", 5) returns 10, the position of the first occurrence of string "ra" when you 
start looking at position 5.

Examples

SECOND("4/6/88 11:59:22 AM") returns 22.

Examples

SIGN(2) returns 1.

SIGN(0) returns 0.

SIGN(-2) returns -1.

SIGN(A4) returns -1 if cell A4 contains -2.
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SINH
The SINH function calculates the hyperbolic sine of the specified number.

SINH(number)
Â number:  Any number.
  

SLN
The SLN function calculates the straight-line depreciation of an asset during a period.

SLN(cost, salvage, life)
Â cost:  The original cost or value of the asset.
Â salvage:  The salvage value of the asset.
Â life:  The number of periods over which the depreciation is spread.
  

Examples

SIN(1) returns 0.841470985, the sine of 1 radian (approximately 57.3 degrees).

SIN(RADIANS(30)) returns 0.5, the sine of 30 degrees.

SIN(PI()/2) returns 1, the sine of PI/2 radians (90 degrees).

Examples

SINH(0) returns 0.

SINH(1) returns 1.175.

SINH(5) returns 74.203.

SINH(10) returns 11013.233.

Examples

SLN(10000, 1000, 6) returns $1500, the depreciation per year, in dollars, of an asset that originally costs 
$10,000 but is worth only $1,000 after 6 years.



Chapter 12    Dictionary of Functions 273

 

SLOPE
The SLOPE function calculates the slope of the best-fit line for the data set based on 
linear regression analysis.

SLOPE(y-range, x-range)
Â y-range:  A range of cells containing the dependent variable y. Must be the same size 

as x-range.
Â x-range:  A range of cells containing the independent variable x. Must be the same 

size as y-range.

Notes
To find the y-intercept of the best-fit line, use the INTERCEPT function.
  

SMALL
The SMALL function retrieves the nth-smallest value in a range. The smallest value is 
ranked number 1.

SMALL(range, rank)
Â range:  The array of cells containing the values.
Â rank:  A number representing the rank of the value you want to return (smallest is 

ranked 1, second-smallest is ranked 2, and so on).

Notes
If rank is omitted, is less than or equal to 0, or is greater than the number of values in 
the array, an error is returned.

Examples

Given the following table:
  

SLOPE(A2:F2, A1:F1) returns 2.

INTERCEPT(A2:F2, A1:F1) returns 1.

SLOPE(A5:F5, A4:F4) returns 0.402.
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SQRT
The SQRT function calculates the square root of a number.

SQRT(number)
Â number:  A nonnegative numeric expression.
  

STDEV
The STDEV function calculates the standard deviation of a set of values based on their 
sample (unbiased) variance. This is appropriate when the specified values represent 
only a sample of a larger population.

STDEV(number, [number, . . .])
Â number:  One or more numbers or cell references.

Notes
The standard deviation is the square root of the variance returned by the VAR function.

If the values you are analyzing represent the entire data set or population, you might 
want to use the STDEVP function instead.

Cells that don’t contain numbers are ignored. If you want to include text or Boolean 
values in the computation, use the STDEVA function.

Examples

Given the following table:
  

SMALL(A2:E2, 1) returns 10, the smallest value in the array.

SMALL(A2,E2, 2) returns 20, the third-smallest value in the array.

SMALL(A2:E2, 5) returns 50, the longest value in the array.

SMALL(A1:A5, 0) displays an error; rank must be greater than 0.

SMALL(A1:A5, 6) displays an error; you can’t find the sixth out of five values.

Examples

SQRT(16) returns 4.

SQRT(12.25) returns 3.5, the square root of 12.25.
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STDEVA
The STDEVA function calculates the standard deviation of a set of values, including text 
and Boolean values, based on the sample (unbiased) variance.

STDEVA(value, [value, . . .])
Â value:  One or more numeric or Boolean values or references to cells containing 

numeric, textual, or Boolean values.

Notes
Unlike the STDEV function, which ignores cells that don’t contain numbers, STDEVA 
assigns a value of 0 to any text value, 0 to the Boolean value FALSE, and 1 to the 
Boolean value TRUE and includes them in the computation.

Entering text directly results in an error. Referencing a cell containing text is evaluated 
as 0. Boolean values can be entered directly or as cell references.

For a data set containing only numbers, STDEVA returns the same result as STDEV.

  

STDEVP
The STDEVP function calculates the standard deviation of a set of values based on their 
population (true) variance. This is appropriate when the specified values are the entire 
population.

STDEVP(number, [number, . . .])
Â number:  A series of numbers or cell references.

Notes
The standard deviation is the square root of the variance returned by the VARP 
function.

Examples

STDEV(5, 5, 5, 5, 6) returns a standard deviation of 0.447 based on an average of 5.2.

STDEV(1, 2, 3, 4, 5) returns a standard deviation of 1.58 based on an average of 3.

STDEV(1, 1, 1, 1, 6) returns a standard deviation of 2.24 based on an average of 2.

STDEV(2, 2, 4, 6, 6) returns a standard deviation of 2 based on an average of 4. Compare with 
STDEVP(2, 2, 4, 6, 6), which uses the population (true) variance to return a standard deviation of 1.79.

Examples

STDEVA(TRUE, TRUE, TRUE, TRUE, 6) returns 2.24. Each TRUE value is counted as a 1.

STDEVA("a", 3, 6, 3, "b") displays an error.
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If the values you are analyzing are only a sample of a larger population, you might 
want to use the STDEV function instead.

Cells that don’t contain numbers are ignored. If you want to include text or Boolean 
values in the computation, use the STDEVPA function.

  

STDEVPA
The STDEVPA function calculates the standard deviation of a set of values, including 
text and Boolean values, based on the population (true) variance.

STDEVPA(value, [value, . . .])
Â value:  One or more numeric or Boolean values or references to cells containing 

numeric, textual, or Boolean values.

Notes
Unlike the STDEVP function, which ignores cells that don’t contain numbers, STDEVPA 
assigns a value of 0 to any text value, 0 to the Boolean value FALSE, and 1 to the 
Boolean value TRUE and includes them in the computation.

Entering text directly results in an error. Referencing a cell containing text is evaluated 
as 0. Boolean values can be entered directly or as cell references.

If the values you are analyzing are only a sample of a larger population, you might 
want to use the STDEVA function instead.

  

Examples

STDEVP(5, 5, 5, 5, 6) returns a standard deviation of 0.4 based on an average of 5.2.

STDEVP(1, 2, 3, 4, 5) returns a standard deviation of 1.41 based on an average of 3.

STDEVP(1, 1, 1, 1, 6) returns a standard deviation of 2 based on an average of 2.

STDEVP(2, 2, 4, 6, 6) returns a standard deviation of 1.79 based on an average of 4. Compare with 
STDEV(2, 2, 4, 6, 6), which uses the sample (unbiased) variance to return a standard deviation of 2.

Examples

STDEVPA(TRUE, TRUE, TRUE, TRUE, 6) returns 2. Each TRUE value is counted as a 1.

STDEVPA("a", 3, 6, 3, "b") displays an error.
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SUBSTITUTE
The SUBSTITUTE function replaces a string of characters with new text. You can replace 
individual characters, whole words, or strings of characters within words. If a string 
occurs more than once in the text, you can specify which occurrences to change.

SUBSTITUTE(text, old, new, [occurrence])
Â text:  The text within which you want to replace characters.
Â old:  The string of characters you want to replace.
Â new:  The string of characters that will replace the old string.
Â occurrence:  Optional; specifies which occurrence of the old string is replaced if there 

is more than one. If omitted, all occurrences of the string are replaced.
  

SUM
The SUM function calculates the sum of a set of numbers. The numbers can be in 
individual cells, in ranges of cells, or included directly as arguments to the function.

SUM(number, [number, . . .])
Â number:  One or more numbers, numeric expressions, or references to a cell or range 

of cells containing numbers or numeric expressions.
  

Examples

SUBSTITUTE("a b c d e f", "b", "B") returns "a B c d e f".

SUBSTITUTE("a a b b b c", "a", "A", 2) returns "a A b b b c".

SUBSTITUTE("a a b b b c", "b", "B") returns "a a B B B c".

SUBSTITUTE("aaabbccc", "bc", "BC", 2) returns "aaabbccc".

Examples

SUM(A1:A4) adds the numbers in four cells.

SUM(A1:D4) adds the numbers in a square array of sixteen cells.

SUM(A1:A4, 100) adds the numbers in four cells plus100.
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SUMIF
The SUMIF function calculates the sum of a set of numbers, but includes only numbers 
that satisfy a specified condition. The condition that determines whether each number 
is included can be performed on the number itself or on a corresponding value in a 
second range of values.

SUMIF(test-range, "condition", [sum-range])
Â test-range:  A reference to the range of cells containing values to test. Must be the 

same dimensions as sum-range.
Â "condition":  Any comparison statement that results in a logical TRUE or FALSE value.
Â sum-range:  Optional; a reference to the range of cells containing the numbers to be 

added. Must have the same dimensions as test-range. If omitted, test-range is used.

Notes
For more information on the comparison operators you can use in the conditional test, 
see “Understanding the Comparison Operators” on page 96.
  

SUMPRODUCT
The SUMPRODUCT function calculates the sum of the products of corresponding 
numbers in two or more ranges of numbers. The ranges must have the same 
dimensions.

SUMPRODUCT(range, range, [range, . . .])
Â range:  A reference to a range of cells containing numbers or numeric expressions.

Examples

Given the following table:
  

SUMIF(A1:A8, "<5") returns 10.

SUMIF(A1:A8, "<5", B1:B8) returns 100.

SUMIF(D1:F3, "=c", D5:F7) returns 27.

SUMIF(B1:D1, 1) or SUMIF(B1:D1, SUM(1)) both total all the occurrences of 1 in the range.
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Notes
If any cell in any of the ranges contains a nonnumeric value, values in corresponding 
cells are not included in the calculation.
  

SUMSQ
The SUMSQ function calculates the sum of the squares of a set of numbers. The 
numbers can be in individual cells, in ranges of cells, or included directly as arguments 
to the function.

SUMSQ(number, [number, . . .])
Â number:  A number, a numeric expression, or a reference to a cell or range of cells 

containing numbers or numeric expressions.
  

SYD
The SYD function calculates the sum-of-years’-digits depreciation of an asset during a 
particular period.

SYD(cost, salvage, life, period)
Â cost:  The initial cost of the asset.
Â salvage:  The salvage value of the asset.
Â life:  The number of periods over which the asset is depreciating.
Â period:  The period for which you want to calculate the depreciation allowance.
  

Examples

SUMPRODUCT(3,4) returns 12.

SUMPRODUCT({1, 2}, {3, 4}) = 3 + 8 = 11.

Examples

SUMSQ(3,4) returns 25.

SUMSQ(A1:A4) adds the squares of the list of four numbers.

SUMSQ(A1:D4) adds the squares of the 16 numbers in a square array of cells.

SUMSQ(A1:A4, 10) adds the squares of the numbers in four cells plus 100.

SQRT(SUMSQ(3,4)) returns 5, using the Pythagorean theorem to find the length of the hypotenuse of 
a triangle with sides 3 and 4.

Examples

SYD(10000, 1000, 9, 1) returns $1,800, the depreciation value of a $10,000 asset after 1 year if the 
asset’s salvage value is $1,000 after a 9-year life.
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T
The T function retrieves text from a cell. If the cell doesn’t contain a string, T returns an 
empty string.

T(cell)
Â cell:  A reference to the cell from which you want to retrieve text.

Notes
This function is included so you can use spreadsheets created with older spreadsheet 
applications that might use it.
  

TAN
The TAN function calculates the tangent of an angle, the ratio of the sine to the cosine.

TAN(radian-angle)
Â radian-angle:  An angle in radians.

Notes
If you measure angles in degrees instead of radians, you can use the RADIANS function 
to convert degrees to radians for the TAN function.

If you want to express radians as a multiple of pi, you can use the PI() function to 
provide a value for pi.

  

Examples

If cell A1 contains "text" and cell B1 is empty:
  
T(A1) returns "text" and T(B1) returns nothing.

Examples

TAN(1) returns 1.557407725, the tangent of 1 radian (approximately 57.3 degrees).

TAN(RADIANS(45)) returns 1, the tangent of a 45-degree angle.

TAN(3*PI()/4) returns -1.
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TANH
The TANH function returns the hyperbolic tangent of the specified number.

TANH(number)
Â number:  Any number.
  

TIME
The TIME function converts hours, minutes, and seconds into a time format.

TIME(hours, minutes, seconds)
Â hours:  The number of hours (using a 24-hour clock).
Â minutes:  The number of minutes.
Â seconds:  The number of seconds.

Notes
You can specify hour, minute, and second values greater than 23, 59, and 59, 
respectively. If the hours, minutes, and seconds add up to more than 24 hours, 
Numbers subtracts 24 hours repeatedly until the sum is less than 24 hours.

You can also specify fractional values for hours, minutes, or seconds.

To convert a time that is a string, use the TIMEVALUE function.

  

Examples

TANH(0) returns 0.

TANH(1) returns 0.762.

TANH(5) returns 0.999909.

TANH(10) returns 0.999999996.

Examples

TIME(12, 0, 0) returns 12:00 PM.

TIME(16, 45, 30) returns 4:45 PM.

TIME(0, 900, 0) returns 3:00 PM.

TIME(60, 0, 0) returns 12:00 PM.

TIME(4.25, 0, 0) returns 4:00 AM.
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TIMEVALUE
The TIMEVALUE function converts a date, a time, or a text string to a decimal fraction of 
a 24-hour day.

TIMEVALUE(date-time)
Â date-time:  A date, a time, or a text string in any of the Numbers date and time 

formats.

Notes
To convert a time that is formatted as a time value instead of a string, use the TIME 
function.
  

TODAY

The TODAY function gets the current system date and formats the cell to display just 
the date, not the time. The time is always set to 12:00.

TODAY()
Â No arguments (but you must include the parentheses).

Notes
The displayed date is updated every time you open or modify your document.

You can use the NOW function to get the current date and time already formatted to 
display both.

  

Examples

TIMEVALUE("4/6/88 12:00") returns 0.5 (noon represents one-half of the day).

TIMEVALUE("12:00:59") returns 0.5007 (rounded to four decimal places of accuracy).

TIMEVALUE("9:00 pm") returns 0.875 (21 hours, or 9 PM, divided by 24).

Examples

When calculated on April 6, 1988, TODAY() returns Apr 6, 1988.
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TRIM
The TRIM function removes extra spaces from text. TRIM removes all spaces before the 
first character, all spaces after the last character, and all duplicate spaces between 
characters, leaving only single spaces between words.

TRIM(text)
Â text:  The text from which you want to remove extra spaces.
  

TRUE
The TRUE function returns the Boolean value TRUE. It is included so you can use 
spreadsheets created with some older spreadsheet applications. You can specify a 
Boolean value of TRUE by simply typing “true” (without quotation marks) into a cell or 
function argument.

TRUE()
Â No arguments (but you must include the parentheses).

Notes
You can type the word TRUE into a cell or formula instead of using the TRUE() function.
  

TRUNC
The TRUNC function truncates a decimal number to the specified number of digits.

TRUNC(number, [digits])
Â number:  A numeric expression indicating the number you want to truncate.
Â digits:  Optional; the number of digits of the result relative to the decimal point. A 

positive number represents digits (decimal places) to the right of the decimal point. 
A negative number specifies digits to the left of the decimal point, which are 
replaced with zeros. If omitted, 0 is used.

Examples

TRIM("     spaces      spaces     spaces      ") returns "spaces spaces spaces".

Examples

TRUE() returns the Boolean value TRUE.

AND(1,TRUE()) returns the Boolean value TRUE.

AND(1,TRUE) behaves exactly like the preceding example.
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UPPER
The UPPER function converts text to uppercase.

UPPER(text)
Â text:  The text you want to convert to uppercase.
  

VALUE
The VALUE function converts a number formatted as text into a regular number.

VALUE(text)
Â text:  The text-formatted number you want to convert.

Notes
You’ll probably never need to use the VALUE function; Numbers converts numbers in 
text automatically for you. The VALUE function is included so you can use spreadsheets 
created with some older spreadsheet applications.
  

VAR
The VAR function calculates the sample (unbiased) variance of a set of values.

VAR(number, [number, . . .])
Â number:  One or more numbers or numeric expressions, or one or more references to 

numbers or numeric expressions.

Examples

TRUNC(1.49,0) returns 1.

TRUNC(1.50,0) returns 1.

TRUNC(1.23456,3) returns 1.234.

TRUNC(1111.222,-2) returns 1100.

TRUNC(-2.2,0) returns -2.

TRUNC(-2.8,0) returns -2.

Examples

UPPER("a b c") returns "A B C".

UPPER("First") returns "FIRST".

Examples

VALUE("22") returns the number 22.

VALUE(RIGHT("The year 1953", 2)) returns the number 53.
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Notes
The VAR function divides the sum of the squares of the deviations of the data points by 
one less than the number of values to find the sample, or unbiased, variance (as 
opposed to the population, or true, variance). This is appropriate if the data points are 
only a sample of a larger data set. If the specified numbers make up the entire data set, 
you should use the VARP function to find the population (true) variance.
  

VARA
The VARA function calculates the sample (unbiased) variance of a set of values, 
including text and Boolean values. Text values and the Boolean value FALSE are 
included as if they are the number 0, logical TRUE as a 1.

VARA(value, [value, . . .])
Â value:  One or more numeric or Boolean values or references to cells containing 

numeric, textual, or Boolean values.

Notes
The VARA function divides the sum of the squares of the deviations of the data points 
by one less than the number of values to find the sample, or unbiased, variance (as 
opposed to the population, or true, variance). This is appropriate if the data points are 
only a sample of a larger data set. If the specified numbers make up the entire data set, 
you should use the VARP function to find the population (true) variance.

For a data set containing only numbers, VARA returns the same result as VAR.

  

Examples

VAR(5, 5, 5, 5, 6) returns a variance of 0.2 based on an average of 5.2.

VAR(1, 2, 3, 4, 5) returns a variance of 2.5 based on an average of 3.

VAR(1, 1, 1, 1, 6) returns a variance of 5 based on an average of 2.

VAR(2, 2, 4, 6, 6) returns a variance of 4 based on an average of 4.

Examples

VARA(TRUE, TRUE, TRUE, TRUE, 6) returns 5. Each TRUE counts as 1.

VARA("a", 3, 6, 3, "b") displays an error.
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VARP
The VARP function calculates the population (true) variance of a set of numbers.

VARP(number, [number, . . .])
Â number:  One or more numbers or numeric expressions, or references to cells 

containing numbers or numeric expressions.

Notes
The VARP function divides the sum of the squares of the deviations of the data points 
by the number of values to find the population, or true, variance (as opposed to the 
sample, or unbiased, variance). This is appropriate if the data points make up the entire 
data set. If the specified numbers are only a sample of a larger data set, you should use 
the VAR function to find the sample (unbiased) variance.
  

VARPA
The VARPA function calculates the population (true) variance of a set of values, 
including text values and Boolean values. Text values and the Boolean value FALSE are 
included as if they are the number 0, logical TRUE as a 1.

VARPA(value, [value, . . .])
Â value:  One or more numeric or Boolean values or references to cells containing 

numeric, textual, or Boolean values.

Notes
The VARPA function divides the sum of the squares of the deviations of the data points 
by the number of values to find the population, or true, variance (as opposed to the 
sample, or unbiased, variance). This is appropriate if the data points make up the entire 
data set. If the specified numbers are only a sample of a larger data set, you should use 
the VARA function to find the sample (unbiased) variance.

For a data set containing only numbers, VARPA returns the same result as VARP.

  

Examples

VARP(5, 5, 5, 5, 6) returns a variance of 0.16 based on an average of 5.2.

VARP(1, 2, 3, 4, 5) returns a variance of 2 based on an average of 3.

VARP(1, 1, 1, 1, 6) returns a variance of 4 based on an average of 2.

VARP(2, 2, 4, 6, 6) returns a variance of 3.2 based on an average of 4.

Examples

VARPA(TRUE, TRUE, TRUE, TRUE, 6) returns 4. Each TRUE counts as 1.

VARPA("a", 3, 6, 3, "b") displays an error.
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VDB
The VDB (variable declining balance) function calculates the depreciation of an asset 
over a chosen time interval, using either the double-declining method or another rate 
that you specify.

VDB(cost, salvage, life, start, end, [factor], [no-switch])
Â cost:  The initial cost of the asset.
Â salvage:  The salvage value of the asset.
Â life:  The number of periods over which the asset is depreciated.
Â start:  The first period for which you want to start the depreciation calculation.
Â end:  The last period you want to include in the depreciation calculation.
Â factor:  Optional; a number that determines the depreciation rate. The higher the 

number, the more rapid the depreciation. If omitted, 2 (for double-declining) is 
assumed.

Â no-switch:  Optional; controls whether the function switches to straight-line 
depreciation when that value is greater than the amount from the variable declining 
method.

  

Examples

If A2:E2 contains 10000, 1000, 9, 0, 1:
  
VDB(A2, B2, C2, D2, E2) returns $2222.22, the first year’s depreciation for a $10,000 asset with a 9-year 
life at the end of which it can be salvaged for $1,000.

VDB(A2, B2, C2, 1, 2) returns $1,728.40, the second year’s depreciation.

VDB(A2, B2, C2, 8, 9, 2, FALSE) returns $339.20, the last year’s depreciation if allowed to switch to 
straight-line depreciation.

VDB(A2, B2, C2, 8, 9, 2, TRUE) returns $297.60, the last year’s depreciation if not allowed to switch to 
straight-line depreciation.

VDB(1000, 100, 4, 0, 1) returns $500.
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VLOOKUP
The VLOOKUP function retrieves a value from a range of columns by using a match 
with a left column value to choose the row and a column number to choose the 
column in that row.

VLOOKUP(search-value, cell-range, column, [exact-match])
Â search-value:  The value you want to look for in the left column of the range to 

choose a row.
Â cell-range:  The range of cells containing your data. The left column contains the data 

to be searched; the remaining rows contain values you can retrieve.
Â column:  A number that specifies the relative column number of the cell from which 

you want to retrieve the value. The left column of the range is column 1.
Â exact-match:  Optional Boolean value; determines whether an exact value is required:

TRUE, 1, or omitted selects the column with the largest top-row value that is less 
than the search value if there is no exact match.

FALSE or 0 returns an error if there is no exact match.

  

Examples

Given the following table:
  

VLOOKUP(20, B2:E6, 2) returns E.

VLOOKUP(21, B2:E6, 2) returns E.

VLOOKUP("M", C2:E6, 2) returns dolor.

VLOOKUP("blandit", D2:E6, 2) returns 5.

VLOOKUP(21, B2:E6, 2, FALSE) returns an error because no value in the left column exactly matches 21.
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WEEKDAY
The WEEKDAY function converts a date to a number that represents the day of the 
week using one of three numbering schemes.

WEEKDAY(date-time, [number-scheme])
Â date-time:  A date in any of the accepted date formats or a reference to a cell 

containing such a date.
Â number-scheme:  Optional; a single digit that specifies how days are numbered:

1 or omitted counts Sunday = day 1, Saturday = day 7.

2 counts Monday = 1 through Sunday = 7.

3 counts Monday = 0 through Sunday = 6.

  

YEAR
The YEAR function extracts the year number from a date.

YEAR(date-time)
Â date-time:  A date or a reference to a cell containing a date.
  

Examples

WEEKDAY("Apr 6, 1988", 1) returns 4 (Wednesday, the fourth day if you start counting Sunday as day 
1).

WEEKDAY("Apr 6, 1988") returns the same value as the preceding example (numbering scheme 1 is 
used if no number-scheme argument is specified).

WEEKDAY("Apr 6, 1988”, 2) returns 3 (Wednesday, the third day if you start counting Monday as day 1).

WEEKDAY("Apr 6, 1988”, 3) returns 2 (Wednesday, day number 2 if you start counting Monday as day 
0).

Examples

YEAR("April 6, 1988") returns 1988.

YEAR(NOW()) returns 2006 when evaluated on June 4, 2006.
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3D charts
defining scene settings  118
modifying the viewing angle  118

A
ABS mathematical function  205
ACCRINT financial function  205
ACCRINTM financial function  206
ACOSH trigonometric function  207
ACOS trigonometric function  206
Address Book

adding contact data to a new table  182
adding contact data to an existing table  182
fields supported  180

ADDRESS lookup function  207
Adjust Image window  174
alignment guides

creating new  153
using  152

AND logical function  208
area and line charts

adding shadows  117
formatting symbols  117
setting line color  117

AREAS lookup function  208
arrows, predrawn

adding  164
editing  168

ASINH trigonometric function  209
ASIN trigonometric function  209
ATAN2 trigonometric function  210
ATANH trigonometric function  210
ATAN trigonometric function  209
AVEDEV statistical function  210
AVERAGEA statistical function  211
AVERAGE statistical function  211

B
bar and column charts

adding shadows  116
adjusting opacity  116

adjusting spacing  115
bulleted text

adding new  138
rearranging and editing  138

C
CEILING mathematical function  212
Character Palette  128
characters in other languages  127
CHAR text function  212
charts

adding  101
adding data from multiple tables  104
adding descriptive text  113
adding labels and axis markings  108
changing chart type  105
changing plotting orientation  103
choosing chart type  102
copying data into  103
editing data  103
formatting  106, 113
formatting data series elements  112
formatting the value axis  110
formatting titles, labels, and legends  112
placing grid labels and tick marks  110
replacing a data series  105
repositioning a legend  106
resizing  107
rotating  107
showing and hiding a legend  106
showing axes and borders  108
understanding data series  99

CHOOSE lookup function  213
CLEAN text function  213
closing a spreadsheet  36
CODE text function  214
Colors window  161
COLUMN lookup function  214
COLUMNS lookup function  215
COMBIN mathematical function  215
CONCATENATE text function  216
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conditional formatting  67
CONFIDENCE statistical function  216
CORREL statistical function  217
COSH trigonometric function  218
COS trigonometric function  217
COUNTA statistical function  219
COUNTBLANK statistical function  220
COUNTIF statistical function  220
COUNT statistical function  218
COUPDAYBS financial function  221
COUPDAYS financial function  221
COUPDAYSNC financial function  222
COUPNUM financial function  223
COVAR statistical function  224
custom templates

creating  188
creating initial content  191
defining default attributes  189
defining reusable tables  189
defining table styles  188
saving  192

D
date and time functions  195
DATE date/time function  224
DATEDIF date/time function  225
DAY date/time function  226
DB financial function  226
DDB financial function  227
DEGREES trigonometric function  227
DISC financial function  228
Document Inspector  36, 40
DOLLAR financial function  228
Draw tool  164

E
EDATE date/time function  229
EVEN mathematical function  229
EXACT text function  230
EXP mathematical function  230
exporting a file

as a CSV file  186
as an Excel file  186
as a PDF file  186

F
FACT mathematical function  230
FALSE logical function  231
financial functions  196
Find & Replace dialog  148
FIND text function  231
FIXED mathematical function  232
FLOOR mathematical function  232

font smoothing  129
FORECAST statistical function  233
Format Bar  25
formatting text

adjusting character spacing  133
adjusting line spacing  132
adjusting paragraph spacing  133
changing capitalization  123, 129
changing color  125
changing horizontal text alignment  131
changing paragraph background color  126
changing size and appearance  120
changing the inset margin  136
changing vertical text alignment  131
creating shadows  126
setting paragraph indents  136

Formula Editor  88
formulas

adding a quick formula  87
adding new  89, 90
adding to multiple cells  93
basic calculation using column values  87
basic calculation using row values  88
deleting  88
editing  89, 91
functions  96
operators  94
performing arithmetic operations  94
performing instant calculations  86
saving or discarding changes  90
using cell references  91

formula tools  26
functions

date and time  195
financial  196
information  198
logical  198
lookup  199
numeric  200
overview of  193
statistical  202
text  204
trigonometric  201
using functions  96

FV financial function  233

G
GCD mathematical function  234
Graphic Inspector  112, 155, 156, 157, 158, 160, 162, 

164

H
headers and footers  41
HLOOKUP lookup function  234
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HOUR date/time function  235
Hyperlink Inspector  143, 144
HYPERLINK lookup function  236
hyperlinks

editing hyperlink text  144
to a preaddressed email message  144
to a webpage  143
types of links  143

I
IF logical function  236
image formats supported  171
images

adjusting brightness  175
adjusting contrast  175
adjusting exposure  175
adjusting saturation  175
adjusting sharpness  175
adjusting temperature  175
Auto Levels  175
automatically adjusting  175
histogram  175
masking (cropping)  172
placing inside an object  162
scaling  163
tiling  163
tinting  163

importing a file
by dragging  33
by menu  33
file formats supported  33
from other applications  33

INDEX lookup function  237
INDIRECT lookup function  237
information functions  198
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opening  26
opening multiple  26
using for formatting  25

Inspector window  25
Instant Alpha  173
INTERCEPT statistical function  238
INT mathematical function  238
IPMT financial function  239
IRR financial function  240
ISBLANK information function  240
ISERROR information function  241
ISEVEN information function  241
ISODD information function  241
ISPMT financial function  242

K
keyboard shortcuts

using  30

viewing a list of shortcuts in help  30
Keyboard Viewer  126

L
LARGE statistical function  242
LCM mathematical function  243
LEFT text function  244
LEN text function  244
lists

automatically generating  137
bulleted  138
numbered  139
ordered (outlines)  140
using  137

LN mathematical function  244
LOG10 mathematical function  245
logical functions  198
LOG mathematical function  245
lookup functions  199
LOOKUP lookup function  245
LOWER text function  246

M
MATCH lookup function  246
MAXA statistical function  248
MAX statistical function  247
Media Browser  28
media files

adding a movie  177
adding sound  177

media formats supported  177
MEDIAN statistical function  248
media placeholders  170, 191
Metrics Inspector  41, 48, 107, 108, 115
MID text function  248
MINA statistical function  249
MIN statistical function  249
MINUTE date/time function  250
MIRR financial function  250
MODE statistical function  251
MOD mathematical function  250
MONTH date/time function  251
movie and sound file types supported  177
MROUND mathematical function  252

N
NOT logical function  252
NOW date/time function  253
NPER financial function  253
NPV financial function  254
numbers

currency format  60
date and time format  62
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fraction format  63
number format  59
percentage format  61
scientific format  63

numeric functions  200

O
objects

adding a custom shape  164
adding a movie file  177
adding an image  171
adding a predrawn shape  164
adding a sound file  177
adding color and color gradients  160
adding reflections  158
adding shadows  156
adjusting opacity  158
aligning  151
changing the border style  155
changing the stacking order  151
copying  150
deleting  150
duplicating  150
flipping  154
grouping and ungrouping  159
locking and unlocking  160
modifying  154
moving  150
positioning  151
positioning precisely  153
resizing  154
rotating  154
selecting and deselecting  149

ODD mathematical function  254
OFFSET lookup function  254, 255
operators

arithmetic  94, 95
comparison  96

OR logical function  255

P
page numbers

adding  41, 145
PDF files

creating in AppleWorks  176
creating in Excel  176
exporting to  186
using as images  176

PERCENTILE statistical function  256
pie charts

adding shadows  114
adjusting opacity  115
rotating  115
selecting individual wedges  113

separating individual wedges  114
showing a series name in  114

PI mathematical function  256
placeholders  170
PMT financial function  257
POISSON statistical function  257
polygon shape

adding  164
editing  169

POWER mathematical function  258
PPMT financial function  258
Preferences  32, 35, 60, 91, 126, 127, 128, 129, 134, 

137, 143, 144, 145, 150, 152, 154
PRICEDISC financial function  260
PRICE financial function  259
PRICEMAT financial function  260
printing

adjusting color with ColorSync  185
arranging objects on pages  41
choosing printer layout options  184
numbering pages  42
paginating a sheet  39
setting margins  43
setting page order  42
setting page orientation  42
setting page size  40
using headers and footers  41
using the Print dialog  183

PROB statistical function  261
PRODUCT mathematical function  262
PROPER text function  262
PV financial function  262

Q
QuickTime Inspector  178
QUOTIENT mathematical function  263

R
RADIANS trigonometric function  263
RANDBETWEEN mathematical function  264
RAND mathematical function  264
RANK statistical function  264
RATE financial function  265
rectangle, rounded

adding  164
editing  168

REPLACE text function  266
REPT text function  266
RIGHT text function  267
ROMAN mathematical function  267
ROUNDDOWN mathematical function  268
ROUND mathematical function  268
ROUNDUP mathematical function  269
ROW lookup function  270
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ROWS lookup function  270
ruler

showing and hiding  134
using to change a tab stop  135
using to delete a tab stop  135
using to set a new tab stop  135
using to set paragraph indents  136

S
saving

as a template  35
a spreadsheet  34
automatic backup version  35
copy of spreadsheet  36
Spotlight  36
undoing changes made since  35
with template images  34

scatter chart
formatting symbols  117
specifying axis settings  117

searching for text  148
SEARCH text function  270
SECOND date/time function  271
shapes

adding custom  164
adding predrawn  164
cropping using the default (rectangular) 

mask  172
editing predrawn  168
formatting text in  143
making editable  165
manipulating points  166
reshaping a curve  166
reshaping a straight segment  167
transforming corner points into curved points 

and vice versa  167
using as masks  173
using the Draw tool  164

sheets
adding and deleting  38
printing  183
renaming  39
reorganizing  38
showing and hiding tables and charts  37
using to organize a spreadsheet  37
viewing  37
viewing the contents of  37

shortcut menus  24, 30
SIGN mathematical function  271
SINH trigonometric function  272
SIN trigonometric function  271
SLN financial function  272
SLOPE statistical function  273
SMALL statistical function  273

smart quotes  128
sound file types supported  177
special characters and symbols

inserting  128
spelling check

finding misspelled words  146
working with spelling suggestions  147

spreadsheet
choosing a template  31
creating  31
opening existing  33
setting margins  43
setting page orientation  42
setting page size  40

SQRT mathematical function  274
star shape

adding  164
editing  169

statistical functions  202
STDEVA statistical function  275
STDEVPA statistical function  276
STDEVP statistical function  275
STDEV statistical function  274
SUBSTITUTE text function  277
SUMIF mathematical function  278
SUM mathematical function  277
SUMPRODUCT mathematical function  278
SUMSQ mathematical function  279
SYD financial function  279

T
table cells

adding and editing content  54
adding checkboxes and other controls  65
adding comments to  76
adding images  68
autofilling  68
defining rules  67
enlarging so content fits  57
filtering rows  78
formatting borders  75
formatting numbers  59
merging adjacent cells into one  74
monitoring cell values with rules  67
resizing  57
selecting  51
selecting a group of cells  52
selecting borders  53
sorting  77
splitting into equal parts  74
using checkboxes and other controls  65
working with dates  57
working with numbers  56
working with text  55
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tables
adding  45
adding color banding to rows  73
adding columns  70
adding rows  69
copying among iWork applications  50
creating a footer row  72
creating a header row or column  71
defining reusable  49
deleting rows and columns  70
filtering (hiding) rows  78
formatting controls  65
formulas  83
hiding rows and columns  72
moving  48
naming  49
predefined  49
rearranging rows and columns  70
resizing  48
resizing rows and columns  73
selecting  51
selecting a row or column  52
using comments within  76
working with rows and columns  69

table styles
applying  80
copying and pasting  81
creating new  82
modifying  80
renaming  82
reverting to default  81

tab stops
changing  135
deleting  135
setting new  135
using rulers to set  134

TANH trigonometric function  281
TAN trigonometric function  280
Template Chooser  18, 32
templates

choosing  18
designing your own  188
saving a spreadsheet as  35

text
adding  119
adding text boxes  141
automatic substitution  145
editing  119
formatting size and appearance  120
in table cells  55
nonbreaking space  146

presenting in columns  141
selecting  120
setting alignment, spacing, and color  130
setting indents  136
setting tab stops to align  134
using lists  137

text functions  204
Text Inspector  49, 55, 81, 125, 130, 131, 132, 133, 

136, 137, 141
TIME date/time function  281
TIMEVALUE date/time function  282
TODAY date/time function  282
toolbar

customizing  24
trigonometric functions  201
TRIM text function  283
TRUE logical function  283
TRUNC mathematical function  283
T text function  280
typography

changing capitalization  129
changing the baseline  129
changing tracking  129
customizing the appearance of text  124
using ligatures  129

Typography window  129

U
undoing changes  35
UPPER text function  284

V
VALUE text function  284
VARA statistical function  285
VARPA statistical function  286
VARP statistical function  286
VAR statistical function  284
VDB financial function  287
VLOOKUP lookup function  288

W
Warnings window  29
WEEKDAY date/time function  289

Y
YEAR date/time function  289

Z
zooming in or out  21
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