
Implementing Embedded Voicemail for
Avaya B5800 Branch Gateway

Release 6.2
18-604098

Issue 1
June 2012



© 2012 Avaya Inc.

All Rights Reserved.

Notice

While reasonable efforts have been made to ensure that the
information in this document is complete and accurate at the time of
printing, Avaya assumes no liability for any errors. Avaya reserves the
right to make changes and corrections to the information in this
document without the obligation to notify any person or organization of
such changes.

Documentation disclaimer

“Documentation” means information published by Avaya in varying
mediums which may include product information, operating instructions
and performance specifications that Avaya generally makes available
to users of its products. Documentation does not include marketing
materials. Avaya shall not be responsible for any modifications,
additions, or deletions to the original published version of
documentation unless such modifications, additions, or deletions were
performed by Avaya. End User agrees to indemnify and hold harmless
Avaya, Avaya's agents, servants and employees against all claims,
lawsuits, demands and judgments arising out of, or in connection with,
subsequent modifications, additions or deletions to this documentation,
to the extent made by End User.

Link disclaimer

Avaya is not responsible for the contents or reliability of any linked Web
sites referenced within this site or documentation provided by Avaya.
Avaya is not responsible for the accuracy of any information, statement
or content provided on these sites and does not necessarily endorse
the products, services, or information described or offered within them.
Avaya does not guarantee that these links will work all the time and has
no control over the availability of the linked pages.

Warranty

Avaya provides a limited warranty on its Hardware and Software
(“Product(s)”). Refer to your sales agreement to establish the terms of
the limited warranty. In addition, Avaya’s standard warranty language,
as well as information regarding support for this Product while under
warranty is available to Avaya customers and other parties through the
Avaya Support Web site: http://support.avaya.com. Please note that if
you acquired the Product(s) from an authorized Avaya reseller outside
of the United States and Canada, the warranty is provided to you by
said Avaya reseller and not by Avaya.

Licenses

THE SOFTWARE LICENSE TERMS AVAILABLE ON THE AVAYA
WEBSITE, HTTP://SUPPORT.AVAYA.COM/LICENSEINFO/ ARE
APPLICABLE TO ANYONE WHO DOWNLOADS, USES AND/OR
INSTALLS AVAYA SOFTWARE, PURCHASED FROM AVAYA INC.,
ANY AVAYA AFFILIATE, OR AN AUTHORIZED AVAYA RESELLER
(AS APPLICABLE) UNDER A COMMERCIAL AGREEMENT WITH
AVAYA OR AN AUTHORIZED AVAYA RESELLER. UNLESS
OTHERWISE AGREED TO BY AVAYA IN WRITING, AVAYA DOES
NOT EXTEND THIS LICENSE IF THE SOFTWARE WAS OBTAINED
FROM ANYONE OTHER THAN AVAYA, AN AVAYA AFFILIATE OR AN
AVAYA AUTHORIZED RESELLER; AVAYA RESERVES THE RIGHT
TO TAKE LEGAL ACTION AGAINST YOU AND ANYONE ELSE
USING OR SELLING THE SOFTWARE WITHOUT A LICENSE. BY
INSTALLING, DOWNLOADING OR USING THE SOFTWARE, OR
AUTHORIZING OTHERS TO DO SO, YOU, ON BEHALF OF
YOURSELF AND THE ENTITY FOR WHOM YOU ARE INSTALLING,
DOWNLOADING OR USING THE SOFTWARE (HEREINAFTER
REFERRED TO INTERCHANGEABLY AS “YOU” AND “END USER”),
AGREE TO THESE TERMS AND CONDITIONS AND CREATE A
BINDING CONTRACT BETWEEN YOU AND AVAYA INC. OR THE
APPLICABLE AVAYA AFFILIATE ( “AVAYA”).

Avaya grants End User a license within the scope of the license types
described below. The applicable number of licenses and units of
capacity for which the license is granted will be one (1), unless a

different number of licenses or units of capacity is specified in the
Documentation or other materials available to End User. “Designated
Processor” means a single stand-alone computing device. “Server”
means a Designated Processor that hosts a software application to be
accessed by multiple users. “Software” means the computer programs
in object code, originally licensed by Avaya and ultimately utilized by
End User, whether as stand-alone Products or pre-installed on
Hardware. “Hardware” means the standard hardware originally sold by
Avaya and ultimately utilized by End User.

License types

Designated System(s) License (DS). End User may install and use
each copy of the Software on only one Designated Processor, unless
a different number of Designated Processors is indicated in the
Documentation or other materials available to End User. Avaya may
require the Designated Processor(s) to be identified by type, serial
number, feature key, location or other specific designation, or to be
provided by End User to Avaya through electronic means established
by Avaya specifically for this purpose.

Copyright

Except where expressly stated otherwise, no use should be made of
materials on this site, the Documentation, Software, or Hardware
provided by Avaya. All content on this site, the documentation and the
Product provided by Avaya including the selection, arrangement and
design of the content is owned either by Avaya or its licensors and is
protected by copyright and other intellectual property laws including the
sui generis rights relating to the protection of databases. You may not
modify, copy, reproduce, republish, upload, post, transmit or distribute
in any way any content, in whole or in part, including any code and
software unless expressly authorized by Avaya. Unauthorized
reproduction, transmission, dissemination, storage, and or use without
the express written consent of Avaya can be a criminal, as well as a
civil offense under the applicable law.

Third-party components

Certain software programs or portions thereof included in the Product
may contain software distributed under third party agreements (“Third
Party Components”), which may contain terms that expand or limit
rights to use certain portions of the Product (“Third Party Terms”).
Information regarding distributed Linux OS source code (for those
Products that have distributed the Linux OS source code), and
identifying the copyright holders of the Third Party Components and the
Third Party Terms that apply to them is available on the Avaya Support
Web site: http://support.avaya.com/Copyright.

Preventing Toll Fraud

“Toll fraud” is the unauthorized use of your telecommunications system
by an unauthorized party (for example, a person who is not a corporate
employee, agent, subcontractor, or is not working on your company's
behalf). Be aware that there can be a risk of Toll Fraud associated with
your system and that, if Toll Fraud occurs, it can result in substantial
additional charges for your telecommunications services.

Avaya Toll Fraud Intervention

If you suspect that you are being victimized by Toll Fraud and you need
technical assistance or support, call Technical Service Center Toll
Fraud Intervention Hotline at +1-800-643-2353 for the United States
and Canada. For additional support telephone numbers, see the Avaya
Support Web site: http://support.avaya.com. Suspected security
vulnerabilities with Avaya products should be reported to Avaya by
sending mail to: securityalerts@avaya.com.

Trademarks

The trademarks, logos and service marks (“Marks”) displayed in this
site, the Documentation and Product(s) provided by Avaya are the
registered or unregistered Marks of Avaya, its affiliates, or other third
parties. Users are not permitted to use such Marks without prior written
consent from Avaya or such third party which may own the Mark.
Nothing contained in this site, the Documentation and Product(s)
should be construed as granting, by implication, estoppel, or otherwise,
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any license or right in and to the Marks without the express written
permission of Avaya or the applicable third party.

Avaya is a registered trademark of Avaya Inc.

All non-Avaya trademarks are the property of their respective owners,
and “Linux” is a registered trademark of Linus Torvalds.

Downloading Documentation

For the most current versions of Documentation, see the Avaya
Support Web site: http://support.avaya.com.

Contact Avaya Support

See the Avaya Support Web site: http://support.avaya.com for product
notices and articles, or to report a problem with your Avaya product.
For a list of support telephone numbers and contact addresses, go to
the Avaya Support Web site: http://support.avaya.com, scroll to the
bottom of the page, and select Contact Avaya Support.
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Chapter 1: Embedded Voicemail overview

Embedded Voicemail provides basic voice mail mailbox services for all users and hunt groups created on
the B5800 Branch Gateway without requiring a separate server PC. In addition to basic voice mail mailbox
services, Embedded Voicemail provides auto attendant services. The B5800 Branch Gateway System
SD card stores the prompts for the auto attendant operation and acts as the message store for Embedded
Voicemail messages. Embedded Voicemail is configured in the B5800 Branch Gateway configuration
using the IP Office Manager application.

Mailbox features
The B5800 Branch Gateway system automatically creates an Embedded Voicemail mailbox
for every user and hunt group in the B5800 Branch Gateway configuration.

• For users, the mailbox is automatically used to answer calls that ring unanswered for the
user's configured No Answer Time. The mailbox is also used in other situations where
the B5800 Branch Gateway would have otherwise returned a busy tone, for example
when the user is set to Do Not Disturb.

• For hunt groups, the mailbox is used when a call has rung for the group's Voicemail
Answer Time.

• For security, a voicemail access code can be assigned to any mailbox. This can be
changed by the mailbox user or the system administrator.

• For user mailboxes, message waiting indication is provided to the user's B5800 Branch
Gateway phone extension.

• For hunt group mailboxes, message waiting indication can be assigned to specified
users.

• Various dialing short codes can be used to control voicemail features and for actions such
as collecting messages, leaving messages, and turning voicemail on and off. See Default
short codes on page 63 for more information.
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Embedded Voicemail capacities

Feature Description
Memory card • Avaya System SD card — must contain the

unique Feature Key serial number which is used for
generating and validating licenses entered into the
B5800 Branch Gateway configuration.

• Optional SD card — this card is not required for
normal B5800 Branch Gateway operation. The
Optional SD card slot can be used for various
maintenance actions. Non-Avaya cards can be
used in the Optional SD card slot as long as they
match or exceed the following standard: 4SDHC
4GB minimum Class 2+, single partition FAT32
format.

Compression method Uses G711. VCM not required.

Storage 25 hours.
15 hours by default. An additional 5 hours is added
for each 2 additional channels licensed.

Maximum simultaneous
connections

6 channels maximum.
If there are no Embedded Messaging Port licenses
in the PLDS license file, no channels are available.
Number of simultaneous connections depends on
the number configured in the VoiceMail Ports field
(in System > Voicemail tab) and also on the number
of Embedded Messaging Port licenses.

Maximum individual message length Adjustable between 30 and 180 seconds.

Auto Attendant Yes

Supported languages
• Arabic (ara)
• Chinese (Hong Kong)
• Chinese–Mandarin (chs)
• Danish (dan)
• Dutch (nld)

Embedded Voicemail overview
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• English UK (eng)
• English US (enu)
• Finnish (fin)
• French (fra)
• French Canadian (frc)
• German (deu)
• Italian (ita)
• Korean (kor)
• Norwegian (nor)
• Portuguese (ptg)
• Portuguese-Brazilian (ptb)
• Russian (rus)
• Spanish (esp)
• Spanish–Argentina (ess)
• Spanish–Mexico (esm)
• Swedish (sve)

The B5800 Branch Gateway system Locale setting is used to determine the default language
prompts used. A Locale setting is set for the whole B5800 Branch Gateway system. For
individual users and incoming call routes the system locale can be overridden.

For calls to voicemail, the locale used is determined as follows:
• The user Locale, if set, is used if the caller is internal.
• The incoming call route Locale, if set, is used if caller is external.
• If no user or incoming call route Locale is applicable, the system Locale is used.
• A short code Locale, if set, is used and overrides the options above if the call is routed to

voicemail using the short code.

Fallback languages
If a selected locale is not supported, Embedded Voicemail uses a fallback language.

If your voicemail configuration requires a locale that has not been downloaded to the B5800
Branch Gateway, a warning message displays to indicate which locale is missing. If you do not
add the locales, Manager will use the fallback languages listed in the table below.

Locale selected in Manager Fallback Languages
Arabic (ara) eng > enu

Fallback languages
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Locale selected in Manager Fallback Languages
Argentina (ess) esp > eng > enu

Bahrain (arh) ara > eng > enu

Belgium–French (frb) fra > frc > eng

Belgium–Dutch (nlb) nld > eng > enu

Brazilian Portuguese (ptb) pt > eng > enu

Chile (esl) esm > esp > enu

Chinese–Cantonese (zzh) eng > enu

Chinese–Madarin (chs) eng > enu

Colombia (eso) esm > esp > enu

Danish (dan) eng > enu

Dutch (nld) eng > enu

Egypt (are) ara > eng > enu

English UK (eng) enu

English US (enu) eng

Finnish (fin) eng > enu

French (fra) frc > eng > enu

French Canadian (frc) fra > enu > eng

German (deu) eng > enu

Italian (ita) eng > enu

Korean (kor) eng > enu

Kuwait (ark) ara > eng > enu

Latin Spanish (esm) esp > enu > eng

Morocco–French (arm) fra > frc > eng

Norwegian (nor) eng > enu

Oman (aro) ara > eng > enu

Peru (esr) esm > esp > enu

Polish (pl) eng > enu >

Portuguese (ptg) ptb > eng > enu

Qatar (arq) ara > eng > enu

Russian (rus) eng > enu >

Spanish (esp) esm > eng > enu

Embedded Voicemail overview
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Locale selected in Manager Fallback Languages
Swedish (sve) eng > enu

Switzerland–French (frs) eng

Switzerland–German (des) deu > eng > enu

Switzerland–Italian (its) ita > eng > enu

Taiwan (cht) chs > eng> enu

Venezuela (esv) esm > esp > enu

Licensing
The B5800 Branch Gateway Embedded Messaging Ports license is required to support
Embedded Voicemail. Embedded Messaging Port licenses must be purchased with sufficient
quantity to support the configured number of ports. There is a maximum capacity of 6 voice
mail ports. For more information about licensing, see Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

Park and Page feature
Park and Page can be configured for a user's voicemail mailbox or for calls answered by the
auto attendant. The Park and Page feature allows a call to be parked while a page is made to
a hunt group or extension. A caller can press a digit and the call is parked while an
announcement is made to a paging zone, overhead paging system, or both. The page is
repeated based on how the feature is configured until the parked call is picked up or the park
timeout occurs. If the park timeout occurs, the caller hears the Park and Page error prompt
and is then returned to the call flow that initiated the Park and Page and hears either the
subscriber's personal greeting or the auto attendant main menu prompt.

The called party can use a short code or a programmed button on their phone to park and
unpark incoming calls. For more information about short codes and button programming, see
the Manager on-line help. The called party can also use the Conference button or the Answer
soft key on their phone while the Page is occurring.

For the procedures to configure Park and Page for a voicemail mailbox or for an auto attendent,
see:

• Configuring Park and Page for a voicemail mailbox on page 32

• Configuring Park and Page for an auto attendant on page 51

Licensing
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Management
The primary method for configuring and managing the branches in a B5800 Branch Gateway
system is centrally using Avaya Aura® System Manager R6.2. Avaya Aura® System Manager
is a central management system that delivers a set of shared management services and a
common console for different components of the Avaya Aura® solution. System Manager
provides a single access interface to administer multiple branch locations and multiple
distributed B5800 Branch Gateway users. System Manager also launches IP Office Manager
in the appropriate mode where you can remotely administer individual B5800 Branch
Gateways.

For more information about managing B5800 Branch Gateway systems, see Implementing the
Avaya B5800 Branch Gateway for an Avaya Aura® Configuration, document number
18-603853.

To launch IP Office Manager from System Manager to edit a B5800 Branch Gateway system
configuration, including configuring Embedded Voicemail for a branch, see Editing a B5800
Branch Gateway system configuration from System Manager on page 16.

Embedded Voicemail auto attendant with central voicemail
system configured

The B5800 Branch Gateway system can be configured to use Avaya Aura Messaging, Modular
Messaging over SIP, or CallPilot as its voicemail server. When any of these are used as the
central voicemail system, at each branch you have the option to still use the local Embedded
Voicemail for auto attendant operation and for announcements to waiting calls. Note that for
this configuration, Embedded Voicemail licenses are still required.

For more information, see the following documents:

• Implementing the B5800 Branch Gateway for an Avaya Aura® Configuration, document
number 18-603853

• Implementing the B5800 Branch Gateway for a Communication Server 1000
Configuration, document number 03-604053

Embedded Voicemail overview
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Related resources

Related documents
Ensure that you have read this document before starting the installation. Additional documents
you may need to consult are as follows:

• Implementing the B5800 Branch Gateway for an Avaya Aura® Configuration, document
number 18-603853

• Implementing the B5800 Branch Gateway for a Communication Server 1000
Configuration, document number 03-604053

All documentation for B5800 Branch Gateway is available on the Avaya support web site, 
http://support.avaya.com.

Avaya Mentor videos
Avaya Mentor is an Avaya-run channel on YouTube that includes technical content on how to
install, configure, and troubleshoot Avaya products.

Visit http://www.youtube.com/AvayaMentor and do one of the following:

• Enter a key word or key words in the Search channel to search for a specific product
or topic.

• Click the name of a playlist to scroll through the posted videos.

Related resources
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Chapter 2: Embedded Voicemail
implementation

Embedded Voicemail uses the System SD card that is installed in the B5800 Branch Gateway control unit.
Installation of an additional memory card is not required. The System SD card stores the prompts for the
auto attendant operation and acts as the message store for Embedded Voicemail messages.

Embedded Voicemail is configured from IP Office Manager. Avaya Aura® System Manager launches IP
Office Manager in the appropriate mode where you can remotely administer Embedded Voicemail on
individual B5800 Branch Gateways. See Management on page 12 for more information. Also see Editing
a B5800 Branch Gateway system configuration from System Manager on page 16.

 Note:
Some tasks in this document are performed using Manager that is installed on a PC for the branch and
cannot be performed using Manager that is accessed from System Manager.

Implementing Embedded Voicemail
Before you begin
Confirm the following requirements have been met:

• There is a B5800 Branch Gateway System SD card installed in the control unit.
• The IP Office Administrator Applications DVD matches the software release of the B5800

Branch Gateway system.
• The PC is connected to the B5800 Branch Gateway network with the IP Office Manager

application installed.

About this task
On new or defaulted systems, Embedded Voicemail is enabled by default. To implement
Embedded Voicemail you must perform the tasks provided below.

Procedure

1. Upgrade the prompts on the System SD card to match the software level of the
B5800 Branch Gateway system. See About upgrading prompts on page 16.
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2. Configure Embedded Voicemail to set features such as number of voicemail ports
that are licensed for the system, Maximum Record Time, and Locale. See 
Configuring Embedded Voicemail on page 19.

3. Upload a PLDS license file that contains the Embedded Messaging ports licenses.
See Implementing the B5800 Branch Gateway for an Avaya Aura® Configuration,
document number 18-603853, for more information.

Editing a B5800 Branch Gateway system configuration from
System Manager

Before you begin
Confirm that Avaya Aura® System Manager has been set up to launch IP Office Manager. For
more information, see Implementing the Avaya B5800 Branch Gateway for an Avaya Aura ®

Configuration, document number 18-603853.

About this task
Use this procedure to launch IP Office Manager from System Manager to configure Embedded
Voicemail for a B5800 Branch Gateway system.

Procedure

1. From the System Manager console, under Elements, select B5800 Branch
Gateway.

2. In the left navigation pane, click System Configuration.

3. On the B5800 Branch Gateway System Configuration page, select the B5800
Branch Gateway device whose system configuration you want to edit.

4. Click Edit.
The IP Office Manager application is launched.

About upgrading prompts
When you install a new System SD card in B5800 Branch Gateway systems, or upgrade an
existing card, a default set of languages is loaded on the card. You can upload additional
language prompt sets if required. For example, when you upgrade to a new release of B5800
Branch Gateway, it is possible that new features require additional prompts. See Uploading
additional language prompts on page 17 for more information.

Embedded Voicemail implementation
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You can also reload languages that are already installed on the System SD card. For example,
you can reload languages if new prompts have been added in a maintenance release. See 
Reloading language prompts on page 17 for more information.

All the prompts for Embedded Voicemail are found in the LVMSound folder after the IP Office
Administrator Applications are installed.

Uploading additional language prompts
About this task
You can perform this task on active systems only. The Add/Display VM Locales button is not
available for offline configurations.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click System.

3. Click the Voicemail tab.

4. Click the Add/Display VM Locales button.

5. Select the prompt set you want to upload.

6. Click OK to save the changes.

7. Select File > Save Configuration to merge the changes back to the system.

Reloading language prompts
About this task
Use this task to reload language prompts that are already installed on the System SD card.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. Select File > Advanced > Upgrade.

About upgrading prompts
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3. In the IP Office Upgrade Wizard window, click the check box for the appropriate
system.

4. Click Upgrade.

5. Click the Upload System Files check box to select this option.

6. Click OK to save the changes.

7. Select File > Save Configuration to merge the changes back to the system.

Checking the prompt sets
About this task
The additional Embedded Voicemail features added in new B5800 Branch Gateway releases
require new prompts. Missing prompts can be reported in IP Office System Monitor by enabling
the Error trace options. Error messages are output at regular intervals.

Procedure

1. From the Start menu select Programs > IP Office.

2. Select Monitor.

3. Select File > Select Unit.
The Select System to Monitor window opens.

4. Enter the Control Unit IP Address and password.
Depending on the IP Office system's configuration, the password required is either
the system password or the separate monitor password if set.

5. Select Filters > System > Error.

6. Click OK.
Error messages like the following example are output at regular intervals:
158267586mS ERR: EVM 7p0 upgrade file clips missing
158267587mS ERR: EVM 7p2 upgrade file clips missing

Transferring the prompt files using IP Office Manager
About this task
Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System

Embedded Voicemail implementation

18     Implementing Embedded Voicemail for Avaya B5800 Branch Gateway June 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Implementing Embedded Voicemail for Avaya B5800 Branch Gateway


Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. Select File > Advanced > Embedded File Management.

3. In the Select IP Office window, click the check box for the appropriate system.

4. Click OK.

5. In the IP Office Embedded File Management window, do the following:enter the
Service User Name and Service User Password.

a. In the Service User Name field, enter the appropriate user name.
b. In the Service User Password field, enter the appropriate password.

6. Click OK.

7. Select File > Upload System Files.
The prompt files installed with IP Office Manager and the B5800 Branch Gateway
firmware files are transferred.

 Caution:
Do not transfer prompt files if the level of IP Office Manager software is not
appropriate for the B5800 Branch Gateway system.

Configuring Embedded Voicemail
About this task
Embedded Voicemail is the default voicemail configuration for B5800 Branch Gateway.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click System.

3. Click the Voicemail tab.

4. In the Voicemail Type drop-down box, select Embedded Voicemail.

Configuring Embedded Voicemail
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 Note:
Fields applicable to this mode of voicemail support are enabled. If the field is not
applicable, the field is disabled.

5. If you want the users to be presented with a display menu for access to their mailbox,
check the Messages Button Goes to Visual Voice check box. For more
information, see the IP Office Manager on-line help.

6. In the Minimum Password Length field, use the up and down arrows to set the
appropriate minimum password length.

7. In the Maximum Record Time field, use the up and down arrows to set the
maximum record time in seconds for recorded announcement prompts, auto
attendant prompts, messages, and voicemail greetings (except Name recordings
that have a maximum record time of 5 seconds).

8. In the VoiceMail ports field, use the up and down arrows to set the number of
voicemail ports. This field must match the number of voicemail ports that are
licensed for the system.

9. In the Reception/Breakout (DTMF 0) drop-down box, select the number to which
a caller is transferred if they press 0 while listening to the mailbox greeting rather
than leaving a message. Do one of the following:

a. To configure Park and Page for this DTMF breakout, select Park & Page and
then do the following:

i. In the Paging Number drop-down box, select the appropriate hunt
group or user extension.

ii. In the Retries field, use the up and down arrows to set the number
of times to repeat the page.

iii. In the Retry timeout field, use the up and down arrows to set the
amount of time to elapse before the page is repeated. The time is
set in 15–second increments.

b. To configure Centrex Transfer for this DTMF breakout, select Centrex Transfer
and then enter the transfer number in the Transfer Number field.

c. To configure an extension number for this DTMF breakout, select the
appropriate extension number from the Reception/Breakout (DTMF 0) drop-
down box.

 Note:
You can also enter an external number in this field.

10. For the Breakout (DTMF 2) drop-down box, repeat step 9.

11. For the Breakout (DTMF 3) drop-down box, repeat step 9.

12. In the SIP Name field, enter the appropriate name.

13. In the SIP Display Name (Alias) field, enter the appropriate name.

Embedded Voicemail implementation
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14. In the Contact field, enter the appropriate name.

15. Configure the Anonymous check box as appropriate. This feature is enabled when
this check box is selected.

 Note:
For more information about the fields in the SIP Settings section, see the IP Office
Manager on-line help.

Configuring Embedded Voicemail
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Chapter 3: User mailbox configuration

Embedded Voicemail creates a mailbox for each user on the B5800 Branch Gateway system. Calls are
routed to the mailbox whenever the user's extension is busy or does not answer within the users allocated
No Answer Time. This includes calls that are forwarded to another internal destination.

This chapter describes how to configure an individual user's mailbox by configuring the user settings in
IP Office Manager. An individual user's mailbox can also be configured through the mailbox and system
short codes (see the IP Office Embedded Voicemail User Guide for more information)

User mailbox features include:

• Message Waiting Indication – If supported by the user's current telephone, the user will receive
message waiting indication whenever their mailbox contains new messages. The type of message
waiting indication will depend on the telephone.

Mailbox access – The standard default short code (*17) can be used to access an extension's
associated user mailbox. Other methods of mailbox access can be configured. The MESSAGES
button on phones, which normally emulates *17, can be configured to access Visual Voice mode on
phones that support Visual Voice. This is done using the Messages Button Goes To Visual Voice
(System > Voicemail) option.

• Ringback – Embedded Voicemail can be set to ring the user whenever they have new messages in
their mailbox. This ringback is triggered after the completion of a call at the user's extension. Ringback
from a hunt group mailbox containing new messages may also occur if the user is configured to
receive hunt group message waiting indication.

• Voicemail on or off – Sending calls to the user's mailbox can be switched off. Note however that
this does not stop other methods of leaving messages directly in the user's mailbox.

• Access code – An access code can be assigned to the mailbox. Anyone accessing the mailbox
must first enter this code before they can collect messages. The access code can be reset by the
user once they are in their mailbox.

• Voicemail Reception and breakout numbers – Setting a Voicemail Reception number for a user
allows callers leaving a message in their mailbox to dial 0 or *0 to be transferred to that number. If
used, this feature should be announced in the mailbox greeting prompt. Two transfer numbers can
also be entered. The user can record a message stating that the caller can press 2 or *2, or 3 or *3
to transfer to the specified telephone numbers. Breakout numbers can also be used for Park and
Page.

• Announcements – Embedded Voicemail allows announcements to calls waiting to be answered by
users. This is similar to the announcements provided for hunt groups, with announcements being
played to callers waiting to be answered. Due to the overlap of various timeouts, the use of user
announcements is not recommended in conjunction with forwarding and voicemail.

• Voicemail Email – A user can have notification of new messages sent to their email address. The
notification can be a simple alert to tell them they have a new message or the voicemail message
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can be sent if required. See Configuring voicemail email integration on page 27 for more
information.

Changing a user's voicemail configuration
About this task
Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

 Caution:
Mailboxes are created based on each user's unique user name within the B5800 Branch
Gateway configuration. Changing a user name associates that user with a new mailbox. If
it is necessary to change a user name, ensure that they have played and deleted all their
messages first. If a user name is changed without clearing the original mailbox, you must
create a short code based on the old user name in order to access the old mailbox.

Use this task to change the voicemail configuration for an individual. A lock symbol indicates
that the setting can also be set and locked through user rights. See the IP Office Manager on-
line help or user documentation for more information.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. In the left navigation pane, click User.

3. Select the individual user whose voicemail configuration you want to change.

4. Click the Voicemail tab.

5. Change the fields as appropriate. See Voicemail tab field descriptions on page 25
for more information.

6. Click OK to save the changes.

7. Repeat steps 3 through 6 for each user as appropriate.

8. Select File > Save Configuration to merge the changes back to the system.

User mailbox configuration
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Voicemail tab field descriptions

Name Description

Voicemail Code Default = Blank, Range = 0 (no code) to 15 digits. This
field can be used to set a mailbox access code. That
code must then be entered by anyone attempting to
retrieve messages from the mailbox. If remote access is
attempted to a mailbox that has no voicemail code set,
the prompt,  "Remote access is not configured on this
mailbox" is played.
The mailbox user can change the code by dialing *04
after having entered the mailbox.
Some rules apply to the voicemail code when the
minimum password length is set to a value other than
none. The voicemail code cannot be:

• the same as the extension number

• the same as the previous one

• consecutive digits

• a single repeated digit

• a code with fewer digits than the minimum password
length

The user can change their voicemail code and access
their mailbox from Visual Voice.

Voicemail On Default = On. When on, calls to the hunt group's number
will divert to voicemail if all available group members are
busy or do not answer within the group's set allocated
answer interval. Note that selecting off does not disable
use of the user's mailbox. Messages can still be forward
to their mailbox. The mailbox can also still be accessed
to collect messages.

Voicemail Help Default = Off. This setting is not used for Embedded
Voicemail. Help can be accessed by dialing *4 after
accessing the mailbox.

Voicemail Ringback Default = Off. When enabled, and a new message has
been received, the voicemail server calls the user's
extension to attempt to deliver the message each time
the telephone is put down. Voicemail will not ring the
extension more than once every 30 seconds.

Voicemail Email Reading Default = Off. This setting is not used for Embedded
Voicemail.

Changing a user's voicemail configuration
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Name Description

UMS Web Services Default = Off. This setting is not used for Embedded
Voicemail.

Voicemail Email Default = Blank (No voicemail email features). This field
is used to set the user or group email address used for
voicemail email operation. When an address is entered,
additional Voicemail Email controls described below are
selectable.

Voicemail Email Default = Off. If an email address is entered for the user
or group, the Off, Copy, Forward, and Alert options
become selectable. These options control the mode of
automatic voicemail email operation provided by the
voicemail server whenever the voicemail mailbox
receives a new voicemail message.

Off If set to Off, none of the options below are used for
automatic voicemail email. Users can also select this
mode by dialing *03 from their extension.

Copy If set to Copy, each time a new voicemail message is
received in the voicemail mailbox, a copy of the
message is attached to an email and sent to the email
address. There is no mailbox synchronization between
the email and voicemail mailboxes. For example,
reading and deleting the email message does not affect
the message in the voicemail mailbox or the message
waiting indication provided for that new message.

Forward If set to Forward, each time a new voicemail message
is received in the voicemail mailbox, that message is
attached to an email and sent to the email address. No
copy of the voicemail message is retained in the
voicemail mailbox and their is no message waiting
indication. Like the Copy option, there is no mailbox
synchronization between the email and voicemail
mailboxes. Users can also select this mode by dialing
*01 from their extension.

Alert If set to Alert, each time a new voicemail message is
received in the voicemail mailbox, a simple email
message is sent to the email address. This is an email
message announcing details of the voicemail message
but with no copy of the voicemail message attached.
Users can also select this mode by dialing *02 from their
extension.

DTMF Breakout When a caller is directed to voicemail to leave a
message, they can be given the option to be transferred
to a different extension. The mailbox greeting message
needs to be recorded telling the caller the options
available. The extension numbers that they can be
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Name Description

transferred to are entered in the DTMF breakout fields
described below.
System default values can be set for these numbers and
are used unless a different number is set within these
user settings. These values can also be set using User
Rights.

Reception / Breakout (DTMF 0) The number to which a caller is transferred if they press
0 or *0 while listening to the mailbox greeting rather than
leaving a message. The caller can also press 0 or *0
after they listen to the greeting or while leaving a
message.
Breakout numbers can also be used for Park and
Page.

Breakout (DTMF 2) The number to which a caller is transferred if they press
2 or *2 while listening to the mailbox greeting rather than
leaving a message. The caller can also press 2 or *2
after they listen to the greeting or while leaving a
message.
Breakout numbers can also be used for Park and
Page.

Breakout (DTMF 3) The number to which a caller is transferred if they press
3 or *3 while listening to the mailbox greeting rather than
leaving a message. The caller can also press 3 or *3
after they listen to the greeting or while leaving a
message.
Breakout numbers can also be used for Park and
Page.

Configuring voicemail email integration
Before you begin
Obtain details of the customer's SMTP email server. It may be necessary to configure a user
account on that server in order for it to accept and relay emails from the B5800 Branch
Gateway.

About this task
Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

Configuring voicemail email integration
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Voicemail email integration uses the B5800 Branch Gateway system's SMTP settings to send
messages to the customer's email server. That server then forwards those messages into the
user email mailboxes.

Once enabled, users can select to have an email alert about each new voicemail message or
to have the voicemail message forwarded to their email mailbox. In addition, when listening to
a message in their voicemail mailbox, they can forward it to their email mailbox.

 Caution:
Any .wav files sent across a network creates a high loading on the network and network
servers. A one-minute message requires a 1MB .wav file.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. In the left navigation pane, click System.

3. Click the SMTP tab.

4. Complete the following fields to match the customer SMTP server.

• IP Address

• Port

• Email From Address

• Server Requires Authentication

See SMTP tab field descriptions on page 29 for more information.

5. In the left navigation pane, click User.

6. Select the individual user.

7. Click the Voicemail tab.

8. In the Voicemail Email field, enter the user's email address.

9. In the Voicemail Email section, click one of the following radio buttons to select the
type of Voicemail Email function alerts for the user:

• Off – Don't send email alerts for new messages. Users can select this
themselves by dialing *03.

• Copy – Send a copy of each new message received to the user's email
address. Users cannot select this mode themselves.

• Forward – Forward each new message received to the user's email address,
deleting the message from their mailbox. Users can select this themselves by
dialing *01.

• Alert – Send an email alert for each new message received. Users can select
this themselves by dialing *02.

10. Click OK to save the changes.

User mailbox configuration
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11. Select File > Save Configuration to merge the changes back to the system.

12. If the SNMP configuration was changed, restart the system.

SMTP tab field descriptions

Name Description

IP Address The IP address of the customer's SMTP server. If not on
the same subnet as the B5800 Branch Gateway LAN,
an IP route must also be added.

Port The SMTP listening port of the server. The default is
25.

Email From Address This is the address used by the B5800 Branch Gateway.
Some servers only relay messages from recognized full
addresses or addresses in the same domain.

Server Requires
Authentication

If the server requires a user account to receive and send
emails, enter the details of an account configured on that
server for use by the B5800 Branch Gateway.

Use Challenge Response
Authentication (CRAM-MD5)

If SMTP uses CRAM-MD5, this option should be
selected.

Announcements
Announcements are played to callers waiting to be answered. This includes callers being
presented to hunt group members, for example, ringing and callers queued for presentation.
 

• If no voicemail channel is available for an announcement, the announcement is not
played.

• Calls can be answered during the announcement.

• If a call is rerouted to a hunt group's Night Service Group or Out of Service Fallback Group,
the announcements of the new group are applied.  

• If a call overflows, the announcements of the original group are still applied, not those of
the overflow group.

Announcements
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• For announcements configured for hunt groups to be used effectively, the hunt group's
Voicemail Answer Time must be extended or Voicemail On must be unselected.

• For announcements configured for users to be used effectively, the user's No Answer
Time must be extended or Voicemail On must be unselected.

Configuring announcements
Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. In the left navigation pane, do one of the following:

• To configure an announcement for a user, click User.

• To configure an announcement for a hunt group, click Hunt Group.

3. Click the Announcements tab.

4. Set the fields to the appropriate values. See Announcements tab field
descriptions on page 30 for more information.

5. Click OK to save the changes.

6. Select File > Save Configuration to merge the changes back to the system.

Announcements tab field descriptions

Name Description

Announcements On Default = Off. This setting enables or disables
announcements.

Wait before 1st announcement Default = 10 seconds. Range = 0 to 9999 seconds. This
setting sets the time delay from the calls presentation,
after which the first announcement should be played to
the caller. If Synchronize Calls is selected, the actual
wait may differ.

Post announcement tone Default = Music on hold. Following the first
announcement, you can select whether the caller should
hear music on hold, ringing, silence until answered, or
hear another announcement.

2nd Announcement Default = On. If selected, a second announcement can
be played to the caller if they have still not been
answered.

User mailbox configuration
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Name Description

Wait before 2nd announcement Default = 20 seconds. Range = 0 to 9999 seconds. This
setting sets the wait between the first and the second
announcement. If Synchronize Calls is selected, the
actual wait may differ.

Repeat last announcement Default = On. If selected, the last announcement played
to the caller is repeated until the call is answered or the
caller hangs up.

Wait before repeat Default = 20 seconds.  Range = 0 to 9999 seconds. If
Repeat last announcement is selected, this setting is
applied between each repeat of the last announcement.
If Synchronize Calls is selected, this value is grayed
out and set to match the Wait before 2nd
announcement setting.

Synchronize calls Default = Off. This option can be used to restrict how
many voicemail channels are required to provide the
announcements.

 Note:
This option is available only when configuring
announcements for hunt groups. It is not available
when configuring announcements for users.

• Off (check box not checked) – Announcements are
played individually for each call. This requires a
separate voicemail channel each time an
announcement is played to each caller. While this
ensures accurate following of the wait settings
selected, it does not make efficient use of voicemail
channels.

• On (check box checked) – If a required
announcement is already being played to another
caller, subsequent callers wait until the announcement
has been completed and can be restarted. In addition,
when a caller has waited for the set wait period and
the announcement is started, any other callers waiting
for the same announcement, hear it even if they have
not waited for the wait period. Using this setting, the
maximum number of voicemail channels ever needed
is one or two depending on the number of selected
announcements.

Announcement recordings
There are no default queue announcements for user and hunt groups. The maximum length
for announcements is set according to the number of seconds configured in the Maximum

Announcements
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Record Time field provided in the System > Voicemail tab. The maximum value that can be
configured in the Maximum Record Time field is 180 seconds. There are two default short
codes that enable you to record announcements. On existing and upgraded systems these or
similar short codes need to be added manually. The default short codes are:

*91N; / N “.1” / Record Message: Used to record an announcement 1. For example, to record
announcement 1 for a hunt group on extension 300, dial *91300# and follow the instructions
to record the new announcement.

*92N; / N “.2” / Record Message: Used to record an announcement 2. For example, to record
announcement 2 for a hunt group on extension 300, dial *92300# and follow the instructions
to record the announcement.

Configuring Park and Page for a voicemail mailbox
About this task
This procedure provides the steps required to configure Park and Page for a subscriber's
mailbox.

Park and Page requires a licensed voicemail port.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click System.

3. Click the Voicemail tab.

4. Confirm that Embedded Voicemail appears in the Voicemail Type drop-down
box.

 Note:
If Avaya Aura Messaging or Modular Messaging over SIP appears in the
Voicemail Type drop-down box, the DTMF Breakout section is disabled. You
cannot configure Park and Page for Avaya Aura Messaging or Modular
Messaging over SIP subscriber mailboxes.

5. To configure Park and Page for the extension the caller is transferred to when the
caller presses 0, in the Reception/Breakout (DTMF 0) drop-down box, select Park
and Page and then do the following:

a. In the Paging Number drop-down box, select the appropriate hunt group or
user extension.
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b. In the Retries field, use the up and down arrows to set the number of times to
repeat the page.

c. In the Retry timeout field, use the up and down arrows to set the amount of
time to elapse before the page is repeated. The time is set in 15–second
increments.

6. To configure Park and Page for the extension the caller is transferred to when the
caller presses 2, in the Breakout (DTMF 2) drop-down box, select Park and Page
and then do the following:

a. In the Paging Number drop-down box, select the appropriate hunt group or
user extension.

b. In the Retries field, use the up and down arrows to set the number of times to
repeat the page.

c. In the Retry timeout field, use the up and down arrows to set the amount of
time to elapse before the page is repeated. The time is set in 15–second
increments.

7. To configure Park and Page for the extension the caller is transferred to when the
caller presses 3, in the Breakout (DTMF 3) drop-down box, select Park and Page
and then do the following:

a. In the Paging Number drop-down box, select the appropriate hunt group or
user extension.

b. In the Retries field, use the up and down arrows to set the number of times to
repeat the page.

c. In the Retry timeout field, use the up and down arrows to set the amount of
time to elapse before the page is repeated. The time is set in 15–second
increments.

8. Click OK.

9. Select File > Save Configuration.

Configuring Park and Page for a voicemail mailbox
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Chapter 4: Hunt group mailbox
configuration

Embedded Voicemail creates a mailbox for each hunt group on the B5800 Branch Gateway system. Calls
are sent to the mailbox only when each available group member has been rung for the group's set ring
time.

This chapter describes how to configure the group mailbox through the hunt group settings in IP Office
Manager. A group mailbox can also be configured through the mailbox and system short codes (see the
IP Office Embedded Voicemail User Guide for more information).

Hunt group mailbox features include:

• Message Waiting Indication – By default there is no message waiting indication to any user for hunt
group messages. Users must be configured individually. For more information, see Configuring
Message Waiting Indication on page 38.

• Mailbox access – By default there is no mailbox access to hunt group mailboxes to collect
messages. Users assigned hunt group message waiting indication may also gain access depending
on their phone type. Otherwise an access short code must be created for the hunt group. For more
information, see Hunt group mailbox access on page 39.

• Ringback – Embedded Voicemail can be set to ring the user whenever they have new messages in
a hunt group mailbox for which they receive message waiting indication. This ringback is triggered
after the completion of a call at the user's extension.

• Voicemail on or off – Sending calls to the group's mailbox can be switched off. Note however that
this does not stop other methods of leaving messages directly in the mailbox.

• Access code – An access code can be assigned to the mailbox. Anyone accessing the mailbox
must first enter this code before they can collect messages. The access code can be reset by the
user once they are in the mailbox.

Configuring a group mailbox
About this task

 Caution:
Mailboxes are created based on the unique group name within the B5800 Branch Gateway
configuration. Changing a group name associates that group with a new mailbox. If it is
necessary to change a group name, ensure that users have played and deleted all
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messages first. If a group name is changed without clearing the original mailbox, you must
create a short code based on the old group name in order to access the old mailbox.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click Hunt Group

3. Select the hunt group for which you want to create a mailbox.

4. Click the Voicemail tab.

5. Change the fields as appropriate. See Voicemail tab field descriptions on page 36
for more information.

6. Click OK to save the changes.

7. Repeat steps 3 through 6 for each hunt group as appropriate.

8. Select File > Save Configuration to merge the changes back to the system.

Voicemail tab field descriptions

Name Description

Voicemail Code Default = Blank, Range = 0 (no code) to 15 digits. This
field can be used to set a mailbox access code. That
code must then be entered by anyone attempting to
retrieve messages from the mailbox. If remote access is
attempted to a mailbox that has no voicemail code set,
the prompt,  "Remote access is not configured on this
mailbox" is played.
The mailbox user can change the code by dialing *04
after having entered the mailbox.
Some rules apply to the voicemail code when the
minimum password length is set to a value other than
none. The voicemail code cannot be:

• the same as the extension number

• the same as the previous one

• consecutive digits

• a single repeated digit

• a code with fewer digits than the minimum password
length

Hunt group mailbox configuration

36     Implementing Embedded Voicemail for Avaya B5800 Branch Gateway June 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Implementing Embedded Voicemail for Avaya B5800 Branch Gateway


Name Description

Voicemail On Default = On. When on, calls to the hunt group's number
will divert to voicemail if all available group members are
busy or do not answer within the group's set allocated
answer interval. Note that selecting Off does not disable
use of the user's mailbox. Messages can still be forward
to their mailbox. The mailbox can also still be accessed
to collect messages.

Voicemail Answer Time (secs) Default = 45 seconds, Range = 1 to 99999 seconds. This
setting sets how long a call should be presented to a
hunt group and its overflow groups, if set, before going
to voicemail. When exceeded, the call goes to voicemail
(if available) regardless of any announcements,
overflow, or queuing. If set to Off, voicemail is used
when all available members of the hunt group have been
alerted for the No Answer Time.

Voicemail Email Default = Blank (No voicemail email features). This field
is used to set the user or group email address used for
voicemail email operation. When an address is entered,
additional Voicemail Email controls described below are
selectable.

Voicemail Email Default = Off. If an email address is entered for the user
or group, the Off, Copy, Forward, and Alert options
become selectable. These options control the mode of
automatic voicemail email operation provided by the
voicemail server whenever the voicemail mailbox
receives a new voicemail message.

Off If set to Off, none of the options below are used for
automatic voicemail email. Users can also select this
mode by dialing *03 from their extension.

Copy If set to Copy, each time a new voicemail message is
received in the voicemail mailbox, a copy of the
message is attached to an email and sent to the email
address. There is no mailbox synchronization between
the email and voicemail mailboxes. For example,
reading and deleting the email message does not affect
the message in the voicemail mailbox or the message
waiting indication provided for that new message.

Forward If set to Forward, each time a new voicemail message
is received in the voicemail mailbox, that message is
attached to an email and sent to the email address. No
copy of the voicemail message is retained in the
voicemail mailbox and their is no message waiting
indication. Like the Copy option, there is no mailbox
synchronization between the email and voicemail

Configuring a group mailbox
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Name Description

mailboxes. Users can also select this mode by dialing
*01 from their extension.

Alert If set to Alert, each time a new voicemail message is
received in the voicemail mailbox, a simple email
message is sent to the email address. This is an email
message announcing details of the voicemail message
but with no copy of the voicemail message attached.
Users can also select this mode by dialing *02 from their
extension.

Voicemail Help Default = Off. This setting is not used for Embedded
Voicemail. Help can be accessed by dialing *4 after
accessing the mailbox.

Broadcast Default = Off. This setting is not used for Embedded
Voicemail.

UMS Web Services Default = Off. This setting is not used for Embedded
Voicemail.

Configuring Message Waiting Indication
About this task
Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

By default, no message waiting indication is sent to any user for a hunt group mailbox. The
following task shows how to give a user message waiting indication from a hunt group's
mailbox. The method of indication will depend on the type of telephone the user has.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. In the left navigation pane, click User.

3. Select the individual user who requires hunt group message waiting indication.

4. Click the Source Numbers tab.

5. Click Add.

6. In the Source Number field, enter H followed by the name of the hunt group.

Hunt group mailbox configuration
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For example, for the hunt group Main, enter HMain.

7. Click OK.

8. Repeats steps 3 through 7 for any other hunt groups for which the user requires
message waiting indication.

9. Select File > Save Configuration to merge the changes back to the system.

Hunt group mailbox access
By default, no user has access to a hunt group mailbox until specifically configured for such
access. Hunt group mailboxes can be accessed using the following methods:

• Message Waiting Indication access

• Short code and button access

• Remote access

Message Waiting Indication access methods
Users who have been assigned hunt group message waiting indication are also given methods
to access the hunt group mailbox. The method depends on what type of telephone or software
the user has.

Avaya 4400 Series telephone users
DS display phone users on telephone models with a MENU key also gain access once they
have been configured for hunt group message waiting. The hunt group name is then displayed
when the user presses MENU, Msgs, or Voice.

For more information, see the telephone user guide.

Voicemail ringback
If a user has voicemail ringback enabled, ringback will occur for new group messages as well
as new personal messages. Ringback for personal messages takes place before any ringback
for new group messages.

Visual Voice
If Visual Voice is available, the user will see the name of the hunt group listed. The number of
new calls are shown in brackets next to the hunt group name.

Hunt group mailbox access
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Short code and button access
A short code can be created for hunt group mailbox access, as shown in the following table.
This can be a system-wide or user-specific short code. For information about setting up short
codes, see the IP Office Manager on-line help or user guide.

Field Contains…
Code *99

Feature Voicemail Collect

Telephone Number “?Sales”

Line Group Id 0

The Voicemail Collect feature and hunt group mailbox name can also be assigned to a user's
programmable button.

Remote access
The standard methods for remote mailbox access apply to users or to hunt groups. See 
Remote mailbox access on page 57 for more information.

Announcements
Announcements are played to callers waiting to be answered. This includes callers being
presented to hunt group members, for example, ringing and callers queued for presentation.
 

• If no voicemail channel is available for an announcement, the announcement is not
played.

• Calls can be answered during the announcement.

• If a call is rerouted to a hunt group's Night Service Group or Out of Service Fallback Group,
the announcements of the new group are applied.  

• If a call overflows, the announcements of the original group are still applied, not those of
the overflow group.

• For announcements configured for hunt groups to be used effectively, the hunt group's
Voicemail Answer Time must be extended or Voicemail On must be unselected.

• For announcements configured for users to be used effectively, the user's No Answer
Time must be extended or Voicemail On must be unselected.

Hunt group mailbox configuration

40     Implementing Embedded Voicemail for Avaya B5800 Branch Gateway June 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Implementing Embedded Voicemail for Avaya B5800 Branch Gateway


Configuring announcements
Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. In the left navigation pane, do one of the following:

• To configure an announcement for a user, click User.

• To configure an announcement for a hunt group, click Hunt Group.

3. Click the Announcements tab.

4. Set the fields to the appropriate values. See Announcements tab field
descriptions on page 30 for more information.

5. Click OK to save the changes.

6. Select File > Save Configuration to merge the changes back to the system.

Announcement recordings
There are no default queue announcements for user and hunt groups. The maximum length
for announcements is set according to the number of seconds configured in the Maximum
Record Time field provided in the System > Voicemail tab. The maximum value that can be
configured in the Maximum Record Time field is 180 seconds. There are two default short
codes that enable you to record announcements. On existing and upgraded systems these or
similar short codes need to be added manually. The default short codes are:

*91N; / N “.1” / Record Message: Used to record an announcement 1. For example, to record
announcement 1 for a hunt group on extension 300, dial *91300# and follow the instructions
to record the new announcement.

*92N; / N “.2” / Record Message: Used to record an announcement 2. For example, to record
announcement 2 for a hunt group on extension 300, dial *92300# and follow the instructions
to record the announcement.

Announcements
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Chapter 5: Auto attendant configuration

In addition to basic voicemail operation, Embedded Voicemail supports auto attendant services. Up to 40
auto attendants are supported.

Each auto attendant consists of:

• Actions – Each of the normal DTMF dialing keys; *, # and 0 to 9, can be assigned to an action.
Callers can dial through prompts, that is, press an action key while listening to the greeting prompts.
You can also assign an action to the Fax key. If a transfer action is set, on detecting fax tone the auto
attendant routes the call to the fax transfer destination as specified using the Transfer action.

• Centrex transfer – A feature provided by some line providers on external analog lines. It allows the
recipient of a call to transfer the call to another external number. The line provider performs the
transfer and the line becomes free. If this feature is not used, transferring an external call to another
external number occupies both an incoming line and outgoing line for the duration of the call.

• Dial by name – Callers can dial the name of the user they want to speak with. A list of matching
names is then played to them from which they can make a selection.

• Dial by number – Callers can dial the required extension number. There is no prompt  associated
with the action. If a prompt is required, it is part of the menu prompt. Unexpected results may occur
if the dial plan is not a uniform length. Hunt group and user extension numbers should all be the
same length.

• Normal transfer – Transfers the caller to a specified number. This is a supervised transfer, that is,
if busy or unanswered the call will follow the settings of the target user or hunt group. If the destination
field is left blank, callers can dial the extension number that they require, however no prompts will
be played.

• Not Defined – Take no action.

• Park and Page – The call is parked while the system sends a page to the designated extension or
hunt group.

• Replay greeting – Repeat the menu greeting.

• Transfer – Callers are transferred to the selected destination. This action is used with the Fax key
so that when a fax tone is detected, the call is transferred to the specified extension.

• Transfer to attendant – Used to access one auto attendant from another.

• Prompts – Separate morning, afternoon and evening (out of hours) greeting prompts can be
recorded. Which prompt is used is defined by associated time profiles. The greeting prompt is
followed by a menu options prompt. This is used to inform the caller of the auto attendant options.
For more information, see Prompt recordings on page 46. In situations where time profiles are
absent, overlap, or conflict; the order of precedence is given to time profiles assigned to Morning,
Afternoon, and then Evening.
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Creating an auto attendant
About this task

 Note:
If you are going to use time profiles in the auto attendant, the time profile has to be created
before creating the auto attendant. For more information, see the IP Office Manager on-line
help.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, right-click Auto Attendant and select New.

3. In the Auto Attendant tab, complete the fields as appropriate. See Auto Attendant
tab field descriptions on page 45 for more information.

4. Click the Actions tab to define the actions available to callers depending on which
DTMF key they press. Then do the following:

a. To define the auto attendant action when the 0 key is pressed, click the row that
begins with 0.

b. Click Edit.
c. In the Action drop-down box, select the appropriate action.

 Note:
See the Manager on-line help for a description of each action.

d. In the Destination drop-down box, select the appropriate destination.
e. Click OK.
f. Repeat steps a through e for each key that requires a definition for this auto

attendant.

5. Click OK to save the auto attendant.
Short codes are automatically created for the auto attendant and the codes can be
viewed in the Auto Attendant tab.

6. Select File > Save Configuration to save the changes back to the system.

7. To record prompts for the auto attendant using the short codes created, see Prompt
recordings on page 46.
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Auto Attendant tab field descriptions

Name Description

Name Range = Up to 15 characters. This field sets the name
for the auto-attendant service. External calls can be
routed to the auto attendant by entering AA: Name in
the destination field of an Incoming Call Route.

Maximum Inactivity Default = 8 seconds; Range = 1 to 20 seconds. This field
sets how long after playing the prompts the Auto
Attendant should wait for a valid key press. If exceeded,
the caller is either transferred to the Fallback Extension
set within the Incoming Call Route used for their call or
else the caller is disconnected.

Enable Local Recording Default = On. When off, use of short codes to record
auto-attendant prompts is blocked. The short codes can
still be used to playback the greetings.

Direct Dial-By-Number Default = Off. This setting affects the operation of any
key presses in the auto attendant menu set to use the
Dial By Number action.

• If selected, the key press for the action is included in
any following digits dialed by the caller for extension
matching. For example, if 2 is set in the actions to Dial
by Number, a caller can dial 201 for extension 201.

• If not selected, the key press for the action is not
included in any following digits dialed by the caller for
extension matching. For example, if 2 is set in the
actions to Dial by Number, a caller must dial 2 and then
201 for extension 201.

Dial by Name Match Order Default = First Name/Last Name. Determines the name
order used for the Dial by Name function. The options
are First then Last or Last then First.

AA Number This number is assigned by the B5800 Branch Gateway
and cannot be changed. It is used in conjunction with
short codes to access the auto attendant service or to
record auto attendant greetings.

Morning/Afternoon/Evening/
Menu Options  

Each auto-attendant can consist of three distinct time
periods, defined by associated time profiles. A greeting
can be recorded for each period. The appropriate
greeting is played to callers and followed by the Menu
Options greeting which should list the available
actions.

Creating an auto attendant
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Name Description

Time Profile The time profile that defines each period of auto
attendant operation. When there are overlaps or gaps
between time profiles, precedence is given in the order
morning, afternoon and then evening.

Recording Name Default = Blank. Range = Up to 31 characters. This field
appears next to the short code used for manually
recording auto attendant prompts. It is only used if using
pre-recorded .wav files as greetings rather than
manually recording greetings using the indicated short
codes. If used, note that the field is case sensitive and
uses the name in the file header that is embedded within
the .wav file rather than the actual file name.
The utility for converting .wav files to the correct format
is provided with Manager and can be launched via File
> Advanced > LVM Greeting Utility. Files then need to
be manually transferred to the Embedded Voicemail
memory card.

Short code These fields indicate the system short codes
automatically created to allow recording of the time
profile greeting.

Prompt recordings
When a new auto attendant is created, a number of short codes are automatically added to
the system short codes table. The short codes allow the recording of the various auto attendant
prompts. The appropriate number to dial is indicated against each greeting on the Auto
Attendant tab in IP Office Manager.

The telephone number part takes the form AA: Name.x, where Name is the name of the auto
attendant service, and x is 1 for the morning greeting, 2 for the afternoon greeting, 3 for the
evening greeting, and 4 for the menu options prompt.

The number can also take the form AA: N.x where N is the auto attendant number and x is 1
for the morning greeting, 2 for the afternoon greeting, 3 for the evening greeting and 4 for the
menu options prompt.

When using any of these short codes, you hear the options:
• 1 to hear the current prompt.
• 2 to record a new prompt.
• 3 to save the new prompt.

Short codes for recording Page prompts: To support the Park and Page feature, the short
codes *800XX, *801XX...*809XX, *850XX, and *851XX are automatically created to record
Page prompts. These short codes use a telephone number in the form of AA:N.Y where N is
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the auto attendant number that is dialed and Y is from 00 to 11 for the key programmed for
Park and Page.

 Note:

• To prevent abuse of these default short codes, they can be deleted or changed. They
can also be removed from the system short codes section and rebuilt in the user short
codes of a trusted user. Alternately, disabling the Enabling Local Recording option
stops the use of short codes to record the auto attendant greetings.

• Using the Dial feature, the short codes can be assigned to a programmable button.
This allows quick access and recording of any prompts that change frequently.

Routing incoming calls to an auto attendant
About this task
You can specify an auto attendant as a destination in the B5800 Branch Gateway Incoming
Call Routes table. Internal callers can access an auto attendant through a programmed DSS
button.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click Incoming Call Route.
3. Select the appropriate route.
4. Click the Standard tab and confirm that the settings match the calls you expect to

be routed to the auto attendant.
For more information, see the IP Office Manager on-line help.

5. Click the Destination tab.
6. In the Destination drop-down box, select the auto attendant.

The names of the configured auto attendants are shown prefixed with AA:.

In this example, the Fallback Extension has also been set to route calls to a hunt
group. The Fallback Extension setting is used for callers in the auto attendant who

Routing incoming calls to an auto attendant
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do not make a valid key press within the auto attendant's Maximum Inactivity
time.

Using time profiles, you can add additional destination sets to use the auto attendant
at certain times of day or to use different auto attendants at different times.

7. Click OK.

8. Select File > Save Configuration to save the changes back to the system.

About transferring calls to an auto attendant
Normally calls are directed to an auto attendant by an B5800 Branch Gateway incoming call
route. However it can also be useful to transfer calls received at an internal extension to an
auto attendant.

You can transfer calls to an auto attendant using:

• Programmed buttons

• SoftConsole

• Short codes

Programmed buttons
Avaya telephones with programmable buttons can be programmed to access auto attendant
services.

Creating an auto attendant button

About this task
Use this procedure to set up a programmed button so that a user can use the button to transfer
calls to the auto attendant.

Procedure

1. From the B5800 Branch Gateway system configuration, set the action of one of the
user's programmable buttons to Dial.

2. Set the associated telephone number to AA:Name where Name matches the name
of the auto attendant.
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3. Select File > Save Configuration to save the changes back to the system.

Transferring a call using a programmed button

Procedure

1. Place the call on hold.

2. Press the button programmed for the auto attendant.

3. Hang up the call at their extension.
A blind transfer of the held call to the auto attendant occurs.

Short codes
The Auto Attendant short code feature can be used to connect to a particular auto attendant.
The Telephone Number field takes the form AA: followed by the auto attendant service
name.

Once a short code for a particular auto attendant has been created, callers can be
transferred.

Example
In this example, dialing *98 connects the user with the auto attendant named Example.

Field Contains…
Code *98

Feature Auto Attendant

Telephone Number “AA:Example”

Line Group Id 0

Transferring calls using short codes

Procedure

1. Press TRANSFER.

2. Dial the auto attendant short code.

About transferring calls to an auto attendant
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3. Press TRANSFER again to complete the process.

Using an auto attendant to access voicemail
About this task
A useful function in auto attendants is to let callers access their own voicemail mailbox. This
can be achieved by first creating a short code and then using the short code as an auto
attendant destination. Use this procedure to create a short code for remote access.

Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. Do one of the following:

• To create remote access for a user, in the left navigation pane click User and
then select the appropriate user.

• To create remote access for a hunt group, in the left navigation pane click Hunt
Group and then select the appropriate hunt group.

3. Click the Voicemail tab.

4. Ensure that a Voicemail Code has been set.
Remote access cannot work without a voicemail code.

5. In the left navigation pane, right-click Shortcode and select New.

6. Create a short code as in the following example:

Field Contains…
Code *99

Feature Voicemail Collect

Telephone Number ?

Line Group Id 0

7. Click OK to add the new short code.
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8. Create an auto attendant and select the key that the caller should use. See Creating
an auto attendant on page 44 for more information.

a. Set the Action to Normal Transfer.
b. In the Destination drop-down box, type the short code.

Following the example shown in step 6, type *99.

9. Click OK.

10. Select File > Save Configuration to save the changes back to the system.
External callers to the auto attendant who select the right option are asked to enter
the mailbox number and then the mailbox access code. If entered correctly, they
can collect messages.

Configuring Park and Page for an auto attendant
Before you begin
This procedure provides the steps required to configure Park and Page for an auto attendant.
To create an auto attendant for the B5800 Branch Gateway system, see Creating an auto
attendant on page 44.

Park and Page requires a licensed voicemail port.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click Auto Attendant.

3. Select the auto attendant for which you want to configure Park and Page.

4. Click the Actions tab.

5. Click the key (1 to 9, *, or #) for which you want to configure Park and Page.

6. Click Edit.

7. In the Edit Action section, in the Action drop-down box, select Park And Page.

8. In the Park ID field, enter the park slot base number (maximum is eight).

9. In the Paging Number drop-down box, select the extension or hunt group to which
you want to configure Park And Page.

10. In the Retry Count box, use the up and down arrows to select the number of page
retries. You can select up to 5 retries.

Configuring Park and Page for an auto attendant
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11. In the Retry timeout field, use the up and down arrows to set the amount of time
to elapse before the page is repeated. The time is set in 15–second increments.

12. If you are using a pre-recorded .wav file as a greeting, in the Recording Name drop-
down box, select the appropriate file (the .wav file converted into a .c11 file).

 Note:
This field is case sensitive and uses the name embedded within the .wav file
header rather than the actual file name.

13. Click OK.

14. Select File > Save Configuration.

Park and Page prompt recordings
When you add an auto attendant, four system short codes are automatically created. The short
codes *81XX, *82XX, *83XX, and *84XX are automatically added for use with all auto
attendants for the morning, afternoon, evening, and menu option greeting respectively. These
system short codes use a telephone number in the form of AA:”N”.”Y” where N is the auto
attendant number that is dialed and Y is 1, 2, 3, or 4 for the morning, afternoon, evening, or
menu option greeting.

To support the Park and Page feature, the short codes *800XX, *801XX...*809XX, *850XX,
and *851XX are automatically created to record Page prompts. These short codes use a
telephone number in the form of AA:N.Y where N is the auto attendant number that is dialed
and Y is from 00 to 11 for the key programmed for Park and Page.

Named announcement files
Pre-recorded files can be converted and used as auto attendant greetings. This allows
greetings to be recorded by methods other than through the B5800 Branch Gateway phone
short codes. It also allows the same greeting to be shared by several auto attendants.

Preventing over recording of uploaded files
About this task
Once uploaded to the B5800 Branch Gateway, converted files can be recorded over using the
default short codes for recording auto attendant greetings. Use this procedure to prevent this
from happening.

Auto attendant configuration

52     Implementing Embedded Voicemail for Avaya B5800 Branch Gateway June 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Implementing Embedded Voicemail for Avaya B5800 Branch Gateway


Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click Auto Attendant.

3. Select the appropriate auto attendant.

4. On the Auto Attendant tab, uncheck the Enable Local Recording check box to
deselect this option.

5. Click OK.

6. Select File > Save Configuration to save the changes back to the system.

Converting the recordings
Before you begin
The original recording must be in one of the following WAV file formats:

• PCM/Uncompressed
• 8000 KHz, 16bit, Mono

If it is in a different format, convert the file using a tool such as Windows Sound Recorder.

About this task
This task converts the source WAV file recording to the format required by Embedded
Voicemail.

Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. Select File > Advanced > LVM Greeting Utility.

3. Next to the Input File field, click the … button and select the WAV file.

4. Next to the Output File field, click the … button and select the location where you
want the converted file saved.

Named announcement files
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5. In the Recording Name field, enter a name for the file (up to 8 characters with no
spaces) and end the file name with  .c11. This is the name that will be entered into
the B5800 Branch Gateway configuration to use the recording.

 Note:
The name value is case sensitive.

6. Ensure that the Format matches that selected for the Output File settings chosen
above.

7. In the Format drop-down box, select G711.

8. Click OK.

Editing an auto attendant to use named recordings
Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click Auto Attendant.

3. Select the auto attendant you want to edit.

4. In the Auto Attendant tab, in the appropriate Recording Name field, enter the
name of the greeting to be used.
This is the Recording Name entered during the file conversion, not the actual file
name. It is case sensitive.

5. If only converted greeting files are to be used with the auto attendant, disable the
Enable Local Recording option to stop any system user recording over the file.

6. Select File > Save Configuration to save the changes back to the system.

Transferring the recording to the System SD card
About this task
Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System

Auto attendant configuration
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Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. Select File > Advanced > Embedded File Management.

3. In the Select IP Office window, click the check box for the appropriate system.

4. Click OK.

5. In the IP Office Embedded File Management window, enter the service user name
and password.

6. Click OK.

7. Drag and drop the Recording Name file into the DYNAMIC\LVMAIL\AAG folder on
the System SD card.

Dial By Name
The Dial By Name feature can be selected as an auto attendant option. Callers selecting this
option are asked to dial the name they require and then press #. The recording name prompts
of matching users are then used to allow the caller to make their selection.

The name order (First then last or Last then First) is set through the Dial by Name Match
Order setting in the auto attendant on the Auto Attendant tab.

The name used for matching is taken from the user's configuration within the B5800 Branch
Gateway configuration. The Full Name is used if set, otherwise the Name is used.

Users are excluded from Dial By Name if they:

• Are marked as Ex Directory (User > User) in the B5800 Branch Gateway
configuration.

• Do not have a recorded mailbox name prompt. They can record their own name by dialing
*05 after accessing their mailbox.

The Dial By Name feature assumes that a standard ITU lettered dialing pad is being used.

Dial By Name
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How Dial By Name works

1. The caller gets a prompt to dial the name they require and then press #.

For example, dialing 527 matches names starting with JAS (for example “Jason”)
and KAR (for example “Karl”).

Callers can also press *# to exit without making a selection.
2. If no matches are found, the caller is given the option to retry.
3. If 10 or less matches are found, the matching mailbox name greetings are played

as part of a selection list.

For example, "Press 1 for …" , "Press 2 for …" , "Press 3 for …" , etc.
4. If more then 10 matches are found, the caller is prompted to either press # to hear

the first 10 matches or to dial more characters to reduce the number of matches. If
they select to play the list, after each set of 10 matches they can either make a
selection or follow the prompts for other options.

Auto attendant configuration
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Chapter 6: Miscellaneous

Remote mailbox access
Remote mailbox access is accessing a mailbox from any location that does not match the
mailbox user's or hunt group's number. That includes both internal and external access.

Remote access is possible only if the mailbox user or hunt group has a voicemail code set in
the B5800 Branch Gateway configuration.

You can enable remote mailbox access using any of the following methods:

• Direct from an incoming call route

• Using a short code

• Via an auto attendant

Direct from an incoming call route
An incoming call route can be configured to enable remote access to a mailbox. The option
Voicemail can be selected as the Destination and/or Night Service Destination of an Incoming
Call Route.

Using a short code
A short code can be created that uses the Voicemail Collect feature but without a mailbox name
specified in the Telephone Number field. An example is shown below. This short code could
be utilized by users on the system as the destination in an Incoming Call Route or as the
destination for a auto attendant option.

Field Contains…
Code *99

Feature Voicemail Collect

Telephone Number ?

Line Group Id 0

Via an auto attendant
An auto attendant can be used to enable remote access to a mailbox. A short code similar to
the example above could be entered as the Destination for one of the auto attendant Normal
Transfer key options. For more information, see Using an auto attendant to access
voicemail on page 50.
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Monitoring Embedded Voicemail
About this task
Use the IP Office Monitor application to observe the operation of Embedded Voicemail.

Procedure

1. From the Start menu select Programs > IP Office.

2. Select Monitor.

3. From the File menu, click Select Unit.
The Select System to Monitor window opens.

4. Enter the Control Unit IP Address and password.
Depending on how the system is configured, the password required is either the
system password or the separate monitor password if set.

5. Check that the Control Unit Type is set to IP Office.

6. Click OK.
The Monitor application attempts to connect with the control unit. If successful,
output similar to the following appears.
********** SysMonitor v6.0 (11031) **********
********** contact made with 192.168.42.119 at 10:08:25 15/11/2006 
**********
********** System (192.168.42.119) has been up and running for 1day, 
19hrs, 3mins and 7secs(154987775mS) **********
 154987776mS PRN: Monitor Started IP=192.168.42.130 IP 500 4.0(11031) 
IP500_40
  (IP Office: Supports Unicode, System Locale is eng)
154987776mS PRN: LAW=A PRI=0, BRI=4, ALOG=4, ADSL=0 VCOMP=32, MDM=0, 
WAN=0, MODU=0 LANM=0 CkSRC=1
VMAIL=1(VER=2 TYP=3) CALLS=0(TOT=6)
 154987778mS LIST2: IFACE(4) "LAN1","LAN2","DialIn","RemoteManager"
A:\lvmail\ENG\*.*
 155088356mS PRN: LVM Flash A:  NextFlashItemScan: Scanning A:\lvmail\ITA
\*.*
155088456mS PRN: LVM Flash A:  NextFlashItemScan: Finished Scanning A:
\lvmail\ITA\*.*
 155088462mS PRN: LVM Flash A:  NextFlashItemScan: Finished Scanning A:
\lvmail\*.*
 155088462mS PRN: LVM Flash A:  NextFlashItemScan: END-OF-LIST found
 155088462mS PRN: LVM FlashMan:  FiveMinuteActions: called    2006/11/15 
10:10:02
155088520mS PRN: LVM FlashMan:  FiveMinuteActions: Free: 955.9 MBytes 
( 92% )
 155088520mS PRN:                 33 Hours 11 Minutes Approx. Remaining
 155088520mS PRN:                 FMML Size: 27

7. Select Filters > Trace Options.

8. To include Embedded Voicemail events on the monitor trace, do the following:

Miscellaneous

58     Implementing Embedded Voicemail for Avaya B5800 Branch Gateway June 2012
Comments? infodev@avaya.com

mailto:infodev@avaya.com?subject=Implementing Embedded Voicemail for Avaya B5800 Branch Gateway


a. On the Call tab, select the options that you want to monitor in the Embedded
Voicemail section.

b. On the System tab, select Print.
The Trace Color selection on the System tab is applied to Embedded
Voicemail events.

9. Click OK.

Result
Embedded Voicemail events are now shown in the Monitor trace when running. These events
are all prefixed LVM.

Monitoring Embedded Voicemail housekeeping
About this task
Embedded Voicemail performs housekeeping approximately every 5 minutes, subject to other
system activity. You can observe the Embedded Voicemail housekeeping by enabling the
House Keeping trace option.

Procedure

1. From the Start menu select Programs > IP Office.

2. Select Monitor.

3. Select File > Select Unit.
The Select System to Monitor window opens.

4. Enter the Control Unit IP Address and password.
Depending on how the system is configured, the password required is either the
system password or the separate monitor password if set.

5. Select Filters > Trace Options.

6. On the All Settings window, under Embedded Voicemail, click the check box for
Housekeeping to select this option.

7. Click OK.
Output similar to the following appears. Details include the approximate remaining
message capacity of the memory card.
156165753mS LVM(housekeeping): FlashMan:  FiveMinuteActions: called   
 2009/01/29 06:52:55
156165796mS LVM(housekeeping): FlashMan:  FiveMinuteActions: Free: 426.4 
MBytes ( 81% )
156165796mS LVM(housekeeping):                 14 Hours 48 Minutes Approx. 

Monitoring Embedded Voicemail housekeeping
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Remaining
156165796mS LVM(housekeeping):                 FMML Size: 35

Result
Embedded Voicemail events are now shown in the Monitor trace when running. These events
are all prefixed LVM.

Configuring buttons
About this task
The same features used for Embedded Voicemail short codes can also be assigned to
telephone buttons.

Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. In the left navigation pane, click User.

3. Click the required user.

4. Click the Button Programming tab.

5. Click the button line that you want to change.

6. Click Edit.
The Edit Button fields are shown at the bottom of the window.

7. Next to the Action field, click the … button.

8. Select Advanced > Voicemail to display the list of voicemail features.

9. Configure the fields as appropriate. See Button Programming tab field
descriptions on page 61 for more information.

10. Repeat steps 4 through 9 for all the keys required.

11. Click OK.

12. Repeat this procedure for other users as required.

13. Select File > Save Configuration to save the changes back to the system.
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Button Programming tab field descriptions

Name Description

Voicemail Collect Allows access to a mailbox to collect or leave messages.
The mailbox and action are determined by the
associated telephone number. This takes the form ?
Name for message collection and #Name for leaving a
message. The Name variable must match the user or
hunt group name set in the B5800 Branch Gateway
configuration. On suitable phones the DSS key displays
VMCol followed by the name.

Voicemail Off This option switches the diversion of calls to the user or
group mailbox off.

Voicemail On This option switches the diversion of calls to the user or
group mailbox on. When programmed on a DSS key, the
action toggles so no separate Voicemail Off key is
required. On suitable phones the DSS key displays
VMCol.

Voicemail Ringback Off This option switches new message ringback notification
off.

Voicemail Ringback On This option switches new message ringback notification
on. When programmed on a DSS key, the action toggles
so that no separate Voicemail Ringback Off key is
required. On suitable phones the DSS key displays
VMRB+.

Visual Voice
A user can be provided a display menu to use for access to their mailbox. The menu provides
the user with options to listen to messages, send messages, and change their greetings and
password.

Configuring a Visual Voice button
About this task
Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch

Button Programming tab field descriptions

Implementing Embedded Voicemail for Avaya B5800 Branch Gateway June 2012     61



Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.

 Note:
The Visual Voice feature is not available on all telephones. It requires an Avaya telephone
with a multi-line (more than two) display.

Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. In the left navigation page, click User.

3. Click the required user.

4. Click the Button Programming tab.

5. Click the button line that you want to change.

6. Right-click in the Action field.

7. Select Emulation > Visual Voice.

8. Click OK to save the button details for the selected user.

9. Repeat this procedure for other users as required.

10. Select File > Save Configuration to save the changes back to the system.

Configuring the MESSAGES button
About this task
You can configure the MESSAGES button to activate Visual Voice rather than access the
spoken voicemail prompts.

Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit to edit the system configuration for the device. IP Office Manager will be
launched on your PC. For more information, see Editing a B5800 Branch Gateway
system configuration from System Manager on page 16.

2. In the left navigation pane, click System.

3. Click the Voicemail tab.

4. Click the Messages Button Goes to Visual Voice check box to select this
option.
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5. Click OK.

6. Select File > Save Configuration to save the changes back to the system.

Default short codes
The following default system short codes can be used with Embedded Voicemail.

Feature Code Description
Collect Messages *17 Users can access the

mailbox associated with their
extension.

Voicemail On/Off *18/*19 Switches the diverting of
callers to the user's mailbox
on or off.

Voicemail Ringback On/Off *48/*49 Switches new message
ringback to the user on or
off.

Record Message The Record Message feature is used to record
announcements that are used when callers to a hunt group
are queued.

*91N To record an Announcement
1 for a hunt group.

*92N To record an Announcement
2 for a hunt group.

Short code features
Additional short codes can be added as required using the short code features listed below.
For more information about short codes, refer to the IP Office Manager on-line help and user
document.

Voicemail Collect
This short code feature can be used to create short codes for collecting or leaving messages.
The exact action is set by the use of either ? or # in the telephone number. For example, “?Main”
indicates collection of messages in the mailbox called Main. “#Main” indicates that a user wants
to leave a message in the mailbox called Main. Note that the quotation marks are required,
and the name must match the user or hunt group whose mailbox is being accessed. For
example:

Default short codes
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Field Contains…
Code *99

Feature Voicemail Collect

Telephone Number “?Main”

Line Group Id 0

Question mark
Using just ? in the Telephone Number without quote marks and without a mailbox name allows
remote access. The user would be prompted to enter the mailbox number and then the mailbox
access code if set.

Voicemail On/Voicemail Off
These two features switch the diversion of calls to the user mailbox on/off. No telephone
number is required for either of these features.

Voicemail Ringback On/Off
These two features switch new message ringback notification on/off. No telephone number is
required for either of these features.

Auto Attendant
This feature is used for the recording of auto attendant prompts and greetings. Normally the
short codes for this are created automatically. However they can be deleted and reassigned
as required.

Record Message
Allows the recording of announcement messages for users and hunt groups.

Shutdown Embedded Voicemail
Allows the Embedded Voicemail service provided by the System SD card to be disabled. The
System SD card should be disabled before removing it from the system. Although this short
code is available, the preferred method to use to disable the System SD card is to use the
memory card shutdown command available in IP Office Manager under File > Advanced >
Memory Card Command > Shutdown.

Startup Embedded Voicemail
Allows an Embedded Voicemail service that has been shutdown to be restarted.

Memory card removal

 Warning:
Memory cards should always be shut down before being removed when the system is
running. Though the card slot LEDs indicate when data is being written to a card, lack of
flashing LEDs is not a sufficient safeguard. Shutting down the card will disable embedded
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voicemail if being used. If the System SD card is removed, features licensed by the card's
Feature Key serial number will continue operating for up to 2 hours.

Card services can be restarted by either reinserting the card or using a Start Up command.

Shutting down a memory card using Manager
Procedure

1. From the System Manager console, select the B5800 Branch Gateway device and
click Edit. IP Office Manager will be launched on your PC. For more information,
see Editing a B5800 Branch Gateway system configuration from System
Manager on page 16.

2. Select File > Advanced > Memory Card Command > Shutdown.
The following prompt appears: Shutting down a memory card may cause service
loss. Continue?

3. Click Yes.

4. In the Select IP Office window, click the check box for the appropriate system.

5. Click OK.

6. At the back of the control unit, confirm that the appropriate memory card LED is
off.

7. Remove the card.

Shutting down a memory card using System Status
Procedure

1. Open System Status and access the status output.

2. In the navigation pane, select System > Memory Cards.

3. Click System SD or Optional SD.

4. At the bottom of the window, click Shutdown.

5. At the back of the control unit, confirm that the appropriate memory card LED is
off.

6. Remove the card.

Memory card removal
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Shutting down a memory card using a system phone
About this task
To shut down a memory card using a system phone, you must be administered as a System
Phone user. You can shut down a memory card using a 1400, 1600, or 9600 series phone.
Your Login Code is used to restrict access to some system administration functions on the
phone.

Procedure

1. Select Features > Phone User > System Admin.

2. Enter your B5800 Branch Gateway user login code.

3. Select Memory Card.

4. Select System for the System SD card or Option for the Optional SD card.

5. Select Shutdown.

6. At the back of the control unit, confirm that the appropriate memory card LED is
off.

7. Remove the card.

Memory card startup
Reinserting a memory card into a system that is already switched on will automatically restart
card operation. However, if the card has been shutdown but not removed, it can be restarted
without requiring a reboot.

Starting up a memory card using Manager
About this task
Use this task to restart a memory card without removing and reinserting it.

Perform this task using IP Office Manager that is installed on a PC for the branch. You cannot
perform this task from Manager that is accessed from System Manager. If the B5800 Branch
Gateway is centrally managed by System Manager, you must disable the System Manager
administration feature for the branch (by disabling Under SMGR Administration in Security
Settings) before you perform this task. For more information, see “Disabling the System
Manager administration feature for the branch” in Implementing the B5800 Branch Gateway
for an Avaya Aura® Configuration, document number 18-603853.
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Procedure

1. Open IP Office Manager and receive the B5800 Branch Gateway configuration.

2. Select File > Advanced > Memory Card Command > Startup.

3. In the Select IP Office window, click the check box for the appropriate system.

4. Click OK.

Starting up a memory card using System Status
About this task
Use this task to restart a memory card without removing and reinserting it.

Procedure

1. Open System Status and access the status output.

2. In the navigation pane, select System > Memory Cards.

3. Click System SD or Optional SD.

4. At the bottom of the window, click Startup.

Starting up a card using a system phone
About this task
A user configured as a system phone user can perform this procedure using a 1400, 1600, or
9600 Series phone (excluding XX01, XX02 and XX03 models). The user's login code is used
to restrict access to system administration functions on the phone.

Procedure

1. Select Features > Phone User > System Admin.

2. Enter your B5800 Branch Gateway user login code.

3. From the menu select Memory Card.

4. Choose one of the following:

• Select System for the System SD card

• Select Option for the Optional SD card.

Memory card startup
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5. Select Startup.
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