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The information in this document is subject to change without notice. The statements, configurations, technica
and recommendations in this document are believed to be accurate and reliable, but are presented without ex
implied warranty. Users must take full responsibility for their applications of any products specified in this docu
The information in this document is proprietary to Bay Networks, Inc. 

The software described in this document is furnished under a license agreement and may only be used in acc
with the terms of that license. A summary of the Software License is included in this document.

Trademarks
AN, BCN, BLN, BN, and Bay Networks are registered trademarks and BayRS, BCC, and the Bay Networks lo
trademarks of Bay Networks, Inc.

Internet Explorer, Microsoft, MS, MS-DOS, Win32, Windows, and Windows NT are registered trademarks of 
Microsoft Corporation.

All other trademarks and registered trademarks are the property of their respective owners.

Restricted Rights Legend
Use, duplication, or disclosure by the United States Government is subject to restrictions as set forth in subpa
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

Notwithstanding any other license agreement that may pertain to, or accompany the delivery of, this computer
software, the rights of the United States Government regarding its use, reproduction, and disclosure are as se
the Commercial Computer Software-Restricted Rights clause at FAR 52.227-19.

Statement of Conditions
In the interest of improving internal design, operational function, and/or reliability, Bay Networks, Inc. reserves
right to make changes to the products described in this document without notice.

Bay Networks, Inc. does not assume any liability that may occur due to the use or application of the product(s
circuit layout(s) described herein.

Portions of the code in this software product may be Copyright © 1988, Regents of the University of California
rights reserved. Redistribution and use in source and binary forms of such portions are permitted, provided th
above copyright notice and this paragraph are duplicated in all such forms and that any documentation, adver
materials, and other materials related to such distribution and use acknowledge that such portions of the softw
developed by the University of California, Berkeley. The name of the University may not be used to endorse o
promote products derived from such portions of the software without specific prior written permission.

SUCH PORTIONS OF THE SOFTWARE ARE PROVIDED “AS IS” AND WITHOUT ANY EXPRESS OR 
IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

In addition, the program and information contained herein are licensed only pursuant to a license agreement t
contains restrictions on use and disclosure (that may incorporate by reference certain limitations and notices 
by third parties).

Bay Networks, Inc. Software License Agreement
NOTICE:  Please carefully read this license agreement before copying or using the accompanying software or
installing the hardware unit with pre-enabled software (each of which is referred to as “Software” in this Agree
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BY COPYING OR USING THE SOFTWARE, YOU ACCEPT ALL OF THE TERMS AND CONDITIONS OF 
THIS LICENSE AGREEMENT. THE TERMS EXPRESSED IN THIS AGREEMENT ARE THE ONLY TERMS 
UNDER WHICH BAY NETWORKS WILL PERMIT YOU TO USE THE SOFTWARE. If you do not accept these
terms and conditions, return the product, unused and in the original shipping container, within 30 days of purc
obtain a credit for the full purchase price.

1. License Grant. Bay Networks, Inc. (“Bay Networks”) grants the end user of the Software (“Licensee”) a pers
nonexclusive, nontransferable license: a) to use the Software either on a single computer or, if applicable, on 
authorized device identified by host ID, for which it was originally acquired; b) to copy the Software solely for ba
purposes in support of authorized use of the Software; and c) to use and copy the associated user manual so
support of authorized use of the Software by Licensee. This license applies to the Software only and does not
to Bay Networks Agent software or other Bay Networks software products. Bay Networks Agent software or o
Bay Networks software products are licensed for use under the terms of the applicable Bay Networks, Inc. So
License Agreement that accompanies such software and upon payment by the end user of the applicable lice
for such software. 

2. Restrictions on use; reservation of rights. The Software and user manuals are protected under copyright laws
Bay Networks and/or its licensors retain all title and ownership in both the Software and user manuals, includi
revisions made by Bay Networks or its licensors. The copyright notice must be reproduced and included with 
copy of any portion of the Software or user manuals. Licensee may not modify, translate, decompile, disassem
for any competitive analysis, reverse engineer, distribute, or create derivative works from the Software or user m
or any copy, in whole or in part. Except as expressly provided in this Agreement, Licensee may not copy or tra
the Software or user manuals, in whole or in part. The Software and user manuals embody Bay Networks’ an
licensors’ confidential and proprietary intellectual property. Licensee shall not sublicense, assign, or otherwise
disclose to any third party the Software, or any information about the operation, design, performance, or 
implementation of the Software and user manuals that is confidential to Bay Networks and its licensors; howe
Licensee may grant permission to its consultants, subcontractors, and agents to use the Software at Licensee
provided they have agreed to use the Software only in accordance with the terms of this license.

3. Limited warranty.  Bay Networks warrants each item of Software, as delivered by Bay Networks and proper
installed and operated on Bay Networks hardware or other equipment it is originally licensed for, to function 
substantially as described in its accompanying user manual during its warranty period, which begins on the da
Software is first shipped to Licensee. If any item of Software fails to so function during its warranty period, as th
remedy Bay Networks will at its discretion provide a suitable fix, patch, or workaround for the problem that ma
included in a future Software release. Bay Networks further warrants to Licensee that the media on which the
Software is provided will be free from defects in materials and workmanship under normal use for a period of 9
from the date Software is first shipped to Licensee. Bay Networks will replace defective media at no charge if 
returned to Bay Networks during the warranty period along with proof of the date of shipment. This warranty do
apply if the media has been damaged as a result of accident, misuse, or abuse. The Licensee assumes all res
for selection of the Software to achieve Licensee’s intended results and for the installation, use, and results ob
from the Software. Bay Networks does not warrant a) that the functions contained in the software will meet the
Licensee’s requirements, b) that the Software will operate in the hardware or software combinations that the L
may select, c) that the operation of the Software will be uninterrupted or error free, or d) that all defects in the
operation of the Software will be corrected. Bay Networks is not obligated to remedy any Software defect that 
be reproduced with the latest Software release. These warranties do not apply to the Software if it has been (i)
except by Bay Networks or in accordance with its instructions; (ii) used in conjunction with another vendor’s pr
resulting in the defect; or (iii) damaged by improper environment, abuse, misuse, accident, or negligence. TH
FOREGOING WARRANTIES AND LIMITATIONS ARE EXCLUSIVE REMEDIES AND ARE IN LIEU OF ALL 
OTHER WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Licensee is responsible for the security
its own data and information and for maintaining adequate procedures apart from the Software to reconstruct 
altered files, data, or programs.

4. Limitation of liability.  IN NO EVENT WILL BAY NETWORKS OR ITS LICENSORS BE LIABLE FOR ANY 
COST OF SUBSTITUTE PROCUREMENT; SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES; OR ANY DAMAGES RESULTING FROM INACCURATE OR LOST DATA OR LOSS OF USE OR 
300019-B Rev. 00 iii
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PROFITS ARISING OUT OF OR IN CONNECTION WITH THE PERFORMANCE OF THE SOFTWARE, EVE
IF BAY NETWORKS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT 
SHALL THE LIABILITY OF BAY NETWORKS RELATING TO THE SOFTWARE OR THIS AGREEMENT 
EXCEED THE PRICE PAID TO BAY NETWORKS FOR THE SOFTWARE LICENSE.

5. Government Licensees. This provision applies to all Software and documentation acquired directly or indirec
by or on behalf of the United States Government. The Software and documentation are commercial products, 
on the open market at market prices, and were developed entirely at private expense and without the use of a
Government funds. The license to the U.S. Government is granted only with restricted rights, and use, duplica
disclosure by the U.S. Government is subject to the restrictions set forth in subparagraph (c)(1) of the Comme
Computer Software––Restricted Rights clause of FAR 52.227-19 and the limitations set out in this license for c
agencies, and subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause of DFAR
252.227-7013, for agencies of the Department of Defense or their successors, whichever is applicable.

6. Use of Software in the European Community. This provision applies to all Software acquired for use within th
European Community. If Licensee uses the Software within a country in the European Community, the Softwa
Directive enacted by the Council of European Communities Directive dated 14 May, 1991, will apply to the 
examination of the Software to facilitate interoperability. Licensee agrees to notify Bay Networks of any such 
intended examination of the Software and may procure support and assistance from Bay Networks.

7. Term and termination. This license is effective until terminated; however, all of the restrictions with respect t
Bay Networks’ copyright in the Software and user manuals will cease being effective at the date of expiration 
Bay Networks copyright; those restrictions relating to use and disclosure of Bay Networks’ confidential informa
shall continue in effect. Licensee may terminate this license at any time. The license will automatically termina
Licensee fails to comply with any of the terms and conditions of the license. Upon termination for any reason,
Licensee will immediately destroy or return to Bay Networks the Software, user manuals, and all copies. Bay 
Networks is not liable to Licensee for damages in any form solely by reason of the termination of this license.

8. Export and Re-export. Licensee agrees not to export, directly or indirectly, the Software or related technical 
or information without first obtaining any required export licenses or other governmental approvals. Without lim
the foregoing, Licensee, on behalf of itself and its subsidiaries and affiliates, agrees that it will not, without firs
obtaining all export licenses and approvals required by the U.S. Government: (i) export, re-export, transfer, or
any such Software or technical data, or any direct product thereof, to any country to which such exports or re-
are restricted or embargoed under United States export control laws and regulations, or to any national or res
such restricted or embargoed countries; or (ii) provide the Software or related technical data or information to 
military end user or for any military end use, including the design, development, or production of any chemica
nuclear, or biological weapons.

9. General. If any provision of this Agreement is held to be invalid or unenforceable by a court of competent 
jurisdiction, the remainder of the provisions of this Agreement shall remain in full force and effect. This Agreem
will be governed by the laws of the state of California.

Should you have any questions concerning this Agreement, contact Bay Networks, Inc., 4401 Great America P
P.O. Box 58185, Santa Clara, California 95054-8185.

LICENSEE ACKNOWLEDGES THAT LICENSEE HAS READ THIS AGREEMENT, UNDERSTANDS IT, AND 
AGREES TO BE BOUND BY ITS TERMS AND CONDITIONS. LICENSEE FURTHER AGREES THAT THIS 
AGREEMENT IS THE ENTIRE AND EXCLUSIVE AGREEMENT BETWEEN BAY NETWORKS AND 
LICENSEE, WHICH SUPERSEDES ALL PRIOR ORAL AND WRITTEN AGREEMENTS AND 
COMMUNICATIONS BETWEEN THE PARTIES PERTAINING TO THE SUBJECT MATTER OF THIS 
AGREEMENT. NO DIFFERENT OR ADDITIONAL TERMS WILL BE ENFORCEABLE AGAINST BAY 
NETWORKS UNLESS BAY NETWORKS GIVES ITS EXPRESS WRITTEN CONSENT, INCLUDING AN 
EXPRESS WAIVER OF THE TERMS OF THIS AGREEMENT.
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Preface

This guide describes how to configure and use the Bay Networks® HTTP Server, 
an embedded Web-based router management tool included with the Bay Netw
router operating system software and accessible from any standard Web bro
Using HTTP Server software, you can monitor network devices, viewing 
summary, fault, and statistical information on a device-by-device basis.

You can use the Bay Command Console (BCC™) or Site Manager to configure the
HTTP Server software on a router. In this guide, you will find configuration 
instructions using both the BCC and Site Manager. 

Before You Begin

Before using this guide, you must complete the following procedures. For a n
router:

• Install the router (see the installation guide that came with your router).

• Connect the router to the network and create a pilot configuration file (se
Quick-Starting Routers).

• Configure IP on the router (see Configuring IP Services).

Make sure that you are running the latest version of Bay Networks BayRS™ and 
Site Manager software. For information about upgrading BayRS and Site 
Manager, see the upgrading guide for your version of BayRS.
300019-B Rev. 00 ix
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Text Conventions

This guide uses the following text conventions:

angle brackets (< >) Indicate that you choose the text to enter based on
description inside the brackets. Do not type the 
brackets when entering the command. 

Example: If the command syntax is:
ping  <ip_address>, you enter:
ping  192.32.10.12

bold text Indicates command names and options and text that
you need to enter.

Example: Enter show ip {alerts | routes }.

Example: Use the dinfo  command. 

braces ({}) Indicate required elements in syntax descriptions 
where there is more than one option. You must choo
only one of the options. Do not type the braces when
entering the command.

Example: If the command syntax is:
show ip {alerts | routes }, you must enter either:
show ip alerts or show ip routes , but not both.

brackets ([ ]) Indicate optional elements in syntax descriptions. D
not type the brackets when entering the command.

Example: If the command syntax is: 
show ip interfaces [-alerts ], you can enter either:
show ip interfaces or show ip interfaces -alerts .

ellipsis points (. . . ) Indicate that you repeat the last element of the 
command as needed.

Example: If the command syntax is:
ethernet/2/1  [<parameter> <value>] . . . , you enter
ethernet/2/1 and as many parameter-value pairs as 
needed.
x 300019-B Rev. 00
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italic text Indicates file and directory names, new terms, book 
titles, and variables in command syntax descriptions.
Where a variable is two or more words, the words are
connected by an underscore.

Example: If the command syntax is:
show at < valid_route>
valid_route is one variable and you substitute one valu
for it.

screen text Indicates system output, for example, prompts and 
system messages.

Example: Set Bay Networks Trap Monitor Filters

separator ( > ) Shows menu paths. 

Example: Protocols > IP identifies the IP option on th
Protocols menu. 

vertical line ( | ) Separates choices for command keywords and 
arguments. Enter only one of the choices. Do not typ
the vertical line when entering the command.

Example: If the command syntax is:
show ip {alerts | routes }, you enter either:
show ip alerts or show ip routes , but not both.
300019-B Rev. 00 xi
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Bay Networks Technical Publications

You can now print Bay Networks technical manuals and release notes free, 
directly from the Internet. Go to support.baynetworks.com/library/tpubs/. Find the 
Bay Networks product for which you need documentation. Then locate the 
specific category and model or version for your hardware or software product
Using Adobe Acrobat Reader, you can open the manuals and release notes, 
for the sections you need, and print them on most standard printers. You can
download Acrobat Reader free from the Adobe Systems Web site, 
www.adobe.com.

You can purchase Bay Networks documentation sets, CDs, and selected tec
publications through the Bay Networks Collateral Catalog. The catalog is loc
on the World Wide Web at support.baynetworks.com/catalog.html and is divided 
into sections arranged alphabetically: 

ARP Address Resolution Protocol

BootP Bootstrap Protocol

FDDI Fiber Distributed Data Interface

FTP File Transfer Protocol

HSSI High-Speed Sserial Interface

HTTP Hypertext Transfer Protocol

ICMP Internet Control Message protocol

IP Internet Protocol

IPX Internet Packet Exchange

MAC media access control

RIP Routing Information Protocol

SAP Service Advertising Protocol

SMDS Switched Multimegabit Data Service

SNMP Simple Network Management Protocol

TCP Transaction Control Protocol
xii 300019-B Rev. 00
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• The “CD ROMs” section lists available CDs.

• The “Guides/Books” section lists books on technical topics.

• The “Technical Manuals” section lists available printed documentation se

Make a note of the part numbers and prices of the items that you want to ord
Use the “Marketing Collateral Catalog description” link to place an order and
print the order form.

How to Get Help

For product assistance, support contracts, or information about educational 
services, go to the following URL:

http://www.baynetworks.com/corporate/contacts/

Or telephone the Bay Networks Technical Solutions Center at:

800-2LANWAN
300019-B Rev. 00 xiii
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Chapter 1
Starting and Configuring the HTTP Server

The Bay Networks HTTP Server is an embedded Web-based router manage
tool included with the Bay Networks router operating system software and 
accessible from any standard Web browser. Using HTTP Server software, you
monitor network devices, viewing summary, fault, and statistical information o
device-by-device basis.

Before you can use the HTTP Server to monitor a router, you must configure
enable the HTTP Server software on the router using the Quick-Start installa
script install.bat, the Bay Command Console (BCC™), or Site Manager.

Browser Requirements
Starting the HTTP Server Using install.bat
Starting the HTTP Server Using the BCC
Starting the HTTP Server Using Site Manager
Setting HTTP Server Security

Go to “Starting and Configuring the HTTP Server.”

Browser Requirements

Your Web browser must support frames, Java applets, and cascading style s
for example, Netscape 4.0 or higher and Microsoft® Internet Explorer® 4.0 or 
higher. If you have changed the default settings for these browsers, you mus
ensure that Java is enabled. If you configure digest authentication, your brow
must be enabled for this capability; otherwise, authentication reverts to basic

Caution:  Internet Explorer lets you store your browser password. For 
security reasons, it is wise not to store your password.
300019-B Rev. 00 1-1
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Go to “Starting and Configuring the HTTP Server.”

Starting the HTTP Server Using install.bat  

A new router comes with a flash memory card containing the software image
the router, two configuration files (config and ti.cfg), and the Quick-Start script 
install.bat.

The Quick-Start installation script creates an initial IP network interface on th
router, so that your router can communicate with the configuration workstatio
from which you will manage the router. The install.bat script prompts you to enter
the network information that dynamically configures the initial IP interface.

As the following example shows, the script asks whether you want to enable
HTTP. Answer yes to this question. (The default is no.)

Step 7. Enable HTTP

Enable the HTTP (Web) Server
----------------------------

Do you want to enable the HTTP (Web) server? (y/n)[n]: y

HTTP server enabled.

When you enable the HTTP Server during the Quick-Start procedure, you ca
the HTTP Server with its default configuration settings after completing the 
install.bat procedure. For information on modifying the default HTTP Server 
settings, see Customizing HTTP Parameters.

After you run the install.bat script, you can install Site Manager software, as 
described in Quick-Starting Routers.

Go to “Starting and Configuring the HTTP Server.”

Note: For complete instructions on running the install.bat script and verifying 
that the installation is successful, see Quick-Starting Routers.
1-2 300019-B Rev. 00
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Starting the HTTP Server Using the BCC or Site Manager

If you did not use the Quick-Start procedure to start the HTTP Server, you ca
start it using the BCC or Site Manager. When you complete this procedure, t
HTTP Server software is configured on the router. Before you start the HTTP
Server, verify that you have configured IP on an interface.

You can start the HTTP Server using default values for all parameters. For 
information on modifying the default HTTP Server settings, see Customizing 
HTTP Parameters.

Using the BCC

Adding the HTTP Server to a router automatically loads TCP on all slots. To 
the HTTP Server to a router, navigate to the box prompt and enter:

http

For example, the following command adds HTTP Server to a router:

box# http
http#

Go to “Starting and Configuring the HTTP Server.”
300019-B Rev. 00 1-3
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Using Site Manager

You can configure HTTP Server software in any Configuration Manager mod
To start HTTP Server software, complete the following tasks:

Go to “Starting and Configuring the HTTP Server.”

Setting HTTP Server Security

The HTTP Server allows access to device information from anywhere in the 
network. To protect your network information, you can implement security 
controls. The HTTP Server offers access control through: user name/passwo
security, basic access or digest authentication, and network address filtering

User Name/Password Security Concepts
Basic Access Authentication
Digest Authentication
Network Address Filtering

Site Manager Procedure

You do this System responds

1. In the Configuration Manager window, 
choose Protocols .

The Protocols menu opens.

2. Choose Global Protocols . The Global Protocols menu opens.

3. Choose TCP. The TCP menu opens.

4. Choose Create TCP. You return to the Configuration Manager 
window.

5. Choose Protocols . The Protocols menu opens.

6. Choose Global Protocols . The Global Protocols menu opens.

7. Choose HTTP. The HTTP menu opens.

8. Choose Create HTTP. You return to the Configuration Manager 
window.
1-4 300019-B Rev. 00
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User Name/Password Security Concepts

The HTTP Server controls access to network device information by grouping
information into collections, called realms, that share the same security attribute
The HTTP Server defines two security realms on the router: User and Manag
These are the same as the login names for the Technician Interface. Similarl
user name/password authorization mechanism controls access to each realm

• User access privileges let you view information. 

• Manager access privileges grant complete access to the router, letting yo
example, enable and disable an interface.

Before allowing any Manager-level operations, however, the HTTP Server 
requires that the system administrator set a nonnull Manager password. If th
system administrator does not set a User password, the HTTP Server accep
empty (null) string as the password. Generally, the system administrator sets
passwords using Technician Interface commands, just as for console access
through the Technician Interface. 

If you have User privileges and attempt to access information requiring Mana
privileges (or, if you attempt to use the Manager login with a null password), 
HTTP Server prompts you for the Manager password. If you do not provide t
appropriate password, an error message appears, and you cannot perform th
operation. You control the level of access authentication protection when you
configure the Authentication parameter.

For specific information about how to set user names and passwords, see Using 
Technician Interface Software. For information about securing a router as part o
the Quick-Start procedure, see Quick-Starting Routers.

Basic Access Authentication

In basic access authentication, the user name and password are passed over th
network as clear text. While this serves to verify the identity of the user, the 
information is vulnerable to anyone with a sniffer or similar device.
300019-B Rev. 00 1-5
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Digest Authentication

Digest authentication, based on RFC 2069, uses an encrypted password to ver
user’s identity. Like basic access authentication, digest uses a challenge-res
model. To use digest authentication, you must configure the HTTP Server 
Authentication parameter as digest and your browser must be capable of 
supporting digest authentication. If your browser lacks this capability, the HT
Server reverts to basic authentication.

Network Address Filtering

For additional security, you can implement IP access control filters when you
configure IP on the router. These filters further restrict access to the router, 
limiting access to specific IP addresses or IP address ranges. 

You must also ensure that IP is appropriately configured to support HTTP. To
this, you must ensure that:

• The configuration for the IP service also has HTTP configured.

• The appropriate access policy filters are configured for HTTP.

Specify these requirements as part of the IP configuration process, using the 
For additional information about IP access control filters and how to configur
them, see Configuring IP Utilities. For general instructions about using the BCC
see Using the Bay Command Console (BCC).

Using a Domain Name Instead of an IP Address

By specifying the Domain Name parameter, you let the server be accessible
domain name, rather than by IP address. The Domain Name parameter must
to the domain name that a DNS lookup would return for the router. The name
consist of any valid string of characters that constitute a domain name.

Accept the default value, no domain name, to indicate that the server is acce
only by the IP address; or specify a domain name to use instead of the IP ad

Go to “Starting and Configuring the HTTP Server.”
1-6 300019-B Rev. 00
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Customizing HTTP Parameters

Adding the HTTP Server to a router automatically enables HTTP on the route
using port 80, sets access authentication to basic, and uses the IP address to
the router. You can change these settings using either the BCC or Site Mana

Using the BCC

To change these parameter settings, first navigate to the http prompt. 

To disable http on the router, enter:
disable

For example:
http# disable

To change the port number, enter:
port  <port_number>
For example:

http#  port 81

To specify access authentication level, enter:
digest  or basic

For example, the following command configures digest authentication:
box# http
http# digest
http#

To specify the use of a domain name for the router, enter:
domain-name  <domain_name>

For example, the following command allows the use of the domain name, 
“myrouter”:
http# domain-name myrouter

Go to “Starting and Configuring the HTTP Server.”
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Using Site Manager

To configure or change the HTTP Server parameters, first create HTTP on th
router, then complete the following tasks:

Go to “Starting and Configuring the HTTP Server.”

Site Manager Procedure

You do this System responds

1. In the Configuration Manager window, 
choose Protocols > Global Protocols > 
HTTP > Global .

The Edit HTTP Global Parameters 
window opens.

2. Set the Enable/Disable  parameter to 
Enabled  to enable the HTTP Server or to 
Disabled  to disable the HTTP Server.

3. Specify the Port  number on which you 
enabled the HTTP Server.

4. Set the Authentication  parameter to 
Basic  or Digest .

5. Specify the Domain Name to use for the 
router. To use the IP address instead of a 
domain name, leave this parameter value 
blank.

6. Click on OK. You return to the Configuration Manager 
window.
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Chapter 2
HTTP Server Concepts

HTTP Server software lets you access device information from anywhere in 
network using any standard Web browser that conforms to HTTP and HTML
specifications. The HTTP Server is part of the router operating system for all 
Networks non-VME-based GAME routers. This chapter provides an overview
the HTTP Server.

What the HTTP Server Does
Navigating the HTTP Server Interface

To obtain Web-accessible data, you must configure the HTTP Server softwar
the router. Chapter 1, “Starting and Configuring the HTTP Server,” summarizes 
the configuration procedure.

What the HTTP Server Does

The HTTP Server is a graphical user interface (GUI) that lets you view real-ti
device summaries, events, alerts, and statistics. The HTTP Server graphical
displays information similar to (and a superset of) the text-only information 
available through the BCC show , enable , and disable  commands. Through this 
point-and-click interface, you also have direct access to online documentation
Bay Networks Technical Support. 

The information that you gather through the HTTP Server interface can help 
monitor your network’s performance on a device-by-device basis. You can see
example, where congestion is occurring or where transmission or reception 
problems exist. For detailed information about interpreting this information, re
to Troubleshooting Routers and Event Messages for Routers.
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You see a multiframe window when you specify a device in your browser’s 
location field or when you click on the Summary folder icon, then on the Info ic
in the navigational frame. 

• Banner -- The top frame shows the Bay Networks logo and the device typ
The banner also identifies the device by name, specifies its physical loca
and IP address, and lists the name of the contact person responsible for 
device. The IP address is a link that you can click on to establish a Telne
connection to the device.

• Navigational frame -- The frame on the left contains links to each monitor
function. Initially, these links are all folders. The folders (and the docume
they contain) in the navigational frame are active links to device informat

• Display frame -- The large frame on the lower right side displays the retrie
web data.

Navigating the HTTP Server Interface

The navigational frame contains the following expandable folders: 

• Summary -- System information, hardware status, PROM information, 
software image information, system resource information, and system tas
information

• Fault -- Circuit alerts and the event log

• Statistics -- Services, ports, and protocols

• Support -- Help, release notes, technical manuals, and customer support

Click on each folder in turn to display the information for the device you are 
monitoring. 

• To show the types of data a folder contains, click on the folder icon. The 
folder opens, revealing document icons representing the types of data wi
that folder. 

• To view a specific data type within a folder, click on its document icon. 

• To close (that is, collapse) a folder’s contents, click again on the folder ic
2-2 300019-B Rev. 00
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Chapter 3
Monitoring Routers Using the HTTP Server

This chapter describes how to use the HTTP Server to monitor the operation
individual routers on your network. For specific descriptions of how to use the
information from the HTTP (Web) Server to troubleshoot the devices in your 
network, refer to Troubleshooting Routers.

Getting Help
Specifying a Router to Monitor
Viewing Overall System Status

Info
Hardware
PROMs
Software
Resources
Tasks

Getting Help

After opening one of these links, choose File > Close to return to the HTTP Se
page on the Web browser. Clicking on File > Exit shuts down the browser. Th
Back button may not be available on linked pages.

For this information Click on Support, then on 

HTTP Server interface help Help icon

Release Notes Release Notes icon

Bay Networks documentation Documentation icon

Bay Networks technical support Bay Networks Technical Solutions Center icon
300019-B Rev. 00 3-1
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Go to “Monitoring Routers Using the HTTP Server.”

Specifying a Router to Monitor

1. Start your Web browser. 

2. In the Location field, enter:

http://< router_IP_address>

router_IP_address is an IP address on the device that you want to monitor, for
example: 
http://192.168.12.54

The browser displays a summary window for the specified device.

Go to “Monitoring Routers Using the HTTP Server.”

Viewing Overall System Status

Use the summary information to get an overall picture of the operational stat
the router. The summary provides hardware and software information includi
this router’s configuration and its internal resource usage. To see the types o
summary information available, click on the Summary folder icon in the 
navigational frame.
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The following table lists the icons within the Summary folder and the informat
that each displays when you click on it.

For detailed information about interpreting the information obtained through t
interface, refer to Troubleshooting Routers.

Icon
Shows 
information for Displayed summary information

Info System • Device name -- the mnemonic name that the 
system administrator assigns 

• Location -- the location, as defined by the 
system administrator 

• Contact person responsible for that device, as 
defined by the system administrator 

• Up time -- the time elapsed since the last 
device reset 

• MIB version -- the version number of the 
management information base (MIB) for the 
router software 

• Software version -- the version number and 
creation date and time of the router software 
image 

Hardware Specific device • Model name and serial number 
• Type, revision, and serial number of the 

processor and link module in each slot. 

PROMs PROM modules 
in the device

For the Boot PROM and for the Diagnostic PROM 
in that slot:
• Revision number
• Date and time of installation

Software Software image 
on the specified 
device

For each router slot:
• Name of the software image file
• Source of that image
• Date and time the image was created
• Name of the configuration file

Resources System 
resources on the 
specified 
hardware device

For each router slot, usage data for:
• CPU
• Memory
• Buffers

Tasks System tasks on 
the specified 
hardware device

For each active task:
• Name of each task
• Usage data for the CPU, memory, and buffers
• Slots on which the task is running
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Chapter 4
Monitoring Circuit Alerts and Events

With the HTTP Server, you can view the events and alerts generated by the 
entities on the router. When you click on the Fault icon, the folder opens and
displays two document icons. Click on these document icons to view:

• All circuit alerts on the router

• All, or a selection of, event log messages

You must first have configured and enabled the HTTP Server on your router,
described in “Starting and Configuring the HTTP Server.” For a detailed 
description of how to isolate and correct problems with a specific device, refe
Troubleshooting Routers.

Fault Icon
Displaying Circuit Alerts
Viewing the Event Log

Fault Icon

Clicking on Fault in the navigational frame reveals two additional choices. Yo
can view:

• All circuit alerts on the router

• All, or a selection of, event log messages

Go to “Monitoring Circuit Alerts and Events.”
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Displaying Circuit Alerts

A circuit alert indicates a condition, such as a port/interface that has been bro
down unexpectedly, that requires your immediate attention. To view any 
exceptional status conditions for any interface on the router, click on Fault > 
Circuit Alert in the navigational frame.

For each index item, the circuit alerts display shows:

• Index number

• Circuit name

• Administrative state

• Operational state

• Type

• MAC address

• Maximum transmission unit (MTU)

• Line speed

Go to “Monitoring Circuit Alerts and Events.”

Viewing the Event Log

An event is something that happens to the operating status of a router. The ro
stores each event as a single entry in a memory-resident log file. The event lo
a router is the composite of all the events that occur for all the processors in 
router. 

An event message provides a brief description of an event, along with the ev
code associated with that event. Use the event code to look up the meaning 
message and what you must do about it in the events database. 

To view the events for a router, click on Fault > Events in the navigational fra

Filtering What the Event Log Shows
Interpreting Event Messages

Go to Monitoring Circuit Alerts and Events.
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Filtering What the Event Log Shows

By default, the event log display shows Fault, Warning, and Info event messa

• To show other event messages, click on the check boxes to select the 
appropriate Event Message Severity Levels. 

• To restrict the display to one or more specific slots or entities and to show
only events that happen after a specific date and time, fill in the fields in t
frame, separating individual entries with spaces. 

Go to “Monitoring Circuit Alerts and Events.”

Interpreting Event Messages

Event Messages for Routers provides detailed information about interpreting 
event messages and taking appropriate action. Most messages document ro
occurrences that do not require you to do anything. The following table lists a
briefly describes the severity levels.

Return to Monitoring Circuit Alerts and Events.

Note: All entity names are case-sensitive. For a list of entity names, refer to 
the events database.

Event Message Severity Levels

Severity Description

Fault Major service disruption, usually caused by a configuration, network, 
or hardware problem. The entities involved keep restarting until the 
problem is resolved either by the router itself or by you.

Warning Service acted in an unexpected manner.

Info Routine event. Usually, no action is required.

Trace Detailed history of everything that happens on the router. Because of 
the amount of information that the Trace function records, Bay 
Networks recommends viewing this type of message only when 
diagnosing specific network problems.

Debug Information that Bay Networks Customer Support uses. With few 
exceptions, these messages do not appear in Event Messages for 
Routers.
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Chapter 5
Viewing Router Services Statistics

Examining the router’s statistics along with the event log can give you a pictur
how well your router is working. When you click on Statistics in the navigation
frame, the folder opens to show the Services, Ports, and Protocols folders, e
containing subordinate links. This chapter shows the Services statistics. For 
statistics, go to Chapter 6, “Viewing Router Port Statistics,” and for Protocol 
statistics, go to Chapter 7, “Viewing Router Protocol Statistics.” 

Router Services Statistics
Using the HTTP Server to View HTTP Statistics
Using the Statistics Manager to View HTTP Server Statistics

Router Services Statistics

You can display router services statistics either through the Web interface, by
clicking on Statistics > Services in the navigational frame, or by using the Sit
Manager Statistics Manager. For information on using the Statistics Manager
Using the Statistics Manager to View HTTP Server Statistics. 

Note: This guide presents the details of the HTTP statistics. Detailed 
descriptions of statistics for the other services are in the guides for each 
service.
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Using the Web interface, clicking on Statistics > Services displays links to the
statistics for each service.

Go to “Viewing Router Services Statistics”.

To see these 
statistics Use this path

TFTP Statistics > Services > TFTP

TCP Statistics > Services > TCP

FTP Statistics > Services > FTP 

Telnet Statistics > Services > Telnet

BootP

• Traffic
• Interfaces
• Clients
• Preferred servers
• Relay agents

Statistics > Services > Bootp 
This reveals several subordinate links: Traffic, Interfaces, Clients, 
Preferred Srv (Servers), and Relay Agents. 

Statistics > Services > Bootp > Traffic
Statistics > Services > Bootp > Interfaces
Statistics > Services > Bootp > Clients
Statistics > Services > Bootp > Preferred Srv
Statistics > Services > Bootp > Relay Agents

SNMP

• Counters
• Communities
• Entity traps
• Exceptions

Statistics > Services > SNMP
This reveals the following subordinate links: Counters, 
Communities, Entity Traps, and Exceptions.

Statistics > Services > SNMP > Counters
Statistics > Services > SNMP > Communities*
Statistics > Services > SNMP > Entity Traps
Statistics > Services > SNMP > Exceptions

* You must have Manager-level access privileges to view the statistics for SNMP communities. If you 
logged in with user-level privileges, HTTP prompts you to enter the manager login name and 
password.

HTTP

• Configuration
• Counters
• Requests
• Responses

Statistics > Services > HTTP
This reveals the following subordinate links: Configuration, 
Counters, Requests, and Responses. 

Statistics > Services > HTTP > Configuration
Statistics > Services > HTTP > Counters
Statistics > Services > HTTP > Requests
Statistics > Services > HTTP > Responses
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Using the HTTP Server to View HTTP Statistics

You can display HTTP Server statistics either through the Web interface, by 
clicking on Statistics > Services > HTTP in the navigational frame, or by using
Site Manager Statistics Manager. 

HTTP Configuration Statistics
HTTP Counters
HTTP Request Statistics
HTTP Response Statistics
Using the Statistics Manager to View HTTP Server Statistics

HTTP Configuration Statistics

HTTP configuration statistics provide the following information:

HTTP Counters

HTTP counters provide the following information:

HTTP Statistic Meaning

State Whether the server is enabled or disabled

Status Whether the server is currently up, down, initializing, or not present

Port The port number on which this server listens to requests

Authentication The level of access authentication security in use

Domain Name The domain name, if any, that can be used to access this router

HTTP Statistic Meaning

Total Requests 
Received

The total number of requests that this entity received

Total Request 
Errors

The total number of request errors that this entity detected (as server)

Total Request 
Discards

The total number of requests that this entity discarded (as server)

Total Responses The total number of responses that this entity generated or received

Total In 
Unknowns

The total number of unknown messages that this entity received
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HTTP Request Statistics

HTTP request statistics provide the following information:

HTTP Response Statistics

HTTP response statistics include:

Go to “Viewing Router Services Statistics”.

Using the Statistics Manager to View HTTP Server Statistics 

To use Site Manager Statistics Manager tool to view statistical information for
HTTP Server, click on Statistics on the toolbar or, from the Site Manager me
choose Tools > Statistics Manager. Select the router that you want to monitor
Statistics Manager window appears, showing the device IP address and, for 
circuit on that device, showing the slot, connector, type, and protocols.

Total Rx Octets The total number of bytes that this entity received

Total Tx Octets The total number of bytes that this entity transmitted

Total Time Outs The total number of timeouts for this entity

Start Time The date and time that the HTTP services were enabled

HTTP Statistic Meaning

Method The HTTP standard request method to which these statistics apply

Total In The number of requests of this type that this entity received

In Last Time The date and time the last request was received

HTTP Statistic Meaning

Status An HTTP standard code and message description indicating the status 
of the response

Total Out The number of times this response was generated

Out Last Time The date and time the most recent response was sent
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Selecting the Windows to Display
Starting the Statistics Launch Facility
Viewing HTTP Statistics

Selecting the Windows to Display

Use the Screen Manager tool to select the windows to display. In the Statistic
Manager window, click on Tools > Screen Manager. Add the HTTP windows 
the list of those to display, then exit the Screen Manager.

Starting the Statistics Launch Facility

In the Statistics Manager window, click on Tools > Launch Facility to display 
Statistics Launch Facility window, which lets you choose the type of statistica
information that you want to view for this device.

Click on the line that indicates the type of information you want to display, the
click on Launch. To return to this window, click on File > Exit in the resulting 
window. 

Viewing HTTP Statistics

Each statistical window shows the window name (name.dat), window description, 
SNMP agent IP address, and number of elements in the display. 

To see these 
statistics Choose this option What the window shows for each element

HTTP requests httpreq.dat HTTP request statistics: 
• Methods
• Total requests (Total In) for each method

HTTP responses httpresp.dat HTTP response statistics:
• Status
• Number of times the server responds for 

each status type (TotalOut)
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HTTP server 
configuration

httpsrv.dat HTTP server configuration statistics:
• State (enabled or disabled)
• Operational status
• Port number
• Access authorization level
• Domain name

HTTP summary 
statistics

httpsum.dat HTTP summary statistics (overview of the 
router’s current state):
• Total requests received
• Total request errors
• Total discarded requests
• Total responses
• Total unknown inputs
• Total bytes received
• Total bytes sent
• Total timeouts
• Start time

To see these 
statistics Choose this option What the window shows for each element
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Chapter 6
Viewing Router Port Statistics

Clicking on Statistics > Ports displays the following folders in the navigationa
frame:

• Summary

• Ethernet

• Serial

• FDDI

• HSSI

• Token Ring

To get statistical information about any port type, click on the appropriate link
Each port-type folder contains links to summary statistics, traffic (number of 
packets transmitted and received) statistics, receive error statistics, and tran
error statistics. All but Ethernet also display system error statistics. The follow
sections summarize these displays. 

Changing the Administrative Status of a Port
Viewing Traffic Statistics for All Ports
Viewing Ethernet Port Statistics
Viewing Serial Port Statistics
Viewing FDDI Port Statistics
Viewing HSSI Port Statistics
Viewing Token Ring Port Statistics
300019-B Rev. 00 6-1
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Changing the Administrative Status of a Port

A user who has Manager-level access privileges can click on the first column
the table in the summary statistics window for any port type to enable or disa
(that is, change the administrative setting of) the port. 

The Enabled column displays the administrative setting, but it is not a clickab
link. The State column shows the operational state of the port (up or down). I
Enabled column shows that the port is enabled, but the State column shows 
the port is down, there is a problem with the port.

Viewing Traffic Statistics for All Ports

To view traffic statistics for all ports, click on Statistics > Ports > Summary.

Viewing Ethernet Port Statistics

Clicking on Statistics > Ports > Ethernet in the navigational frame reveals the
following subordinate links: Summary, Traffic, Rx Errors, and Tx Errors.

Caution: If you disable the interface through which your Web browser is 
communicating with a router, you will no longer be able to monitor that 
router’s operation with the HTTP Server.

To see these 
statistics Use this path

Summary Statistics > Ports > Ethernet > Summary

Traffic Statistics > Ports > Ethernet > Traffic

Rx Errors Statistics > Ports > Ethernet > Rx Errors

Tx Errors Statistics > Ports > Ethernet > Tx Errors
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Viewing Serial Port Statistics

Clicking on Statistics > Ports > Serial in the navigational frame reveals the 
following subordinate links: Summary, Traffic, Rx Errors, Tx Errors, and 
Sys Errors.

Viewing FDDI Port Statistics

Clicking on Statistics > Ports > FDDI in the navigational frame reveals the 
following subordinate links: Summary, Traffic, Rx Errors, Tx Errors, and 
Sys Errors.

To see these 
statistics Use this path

Summary Statistics > Ports > Serial > Summary

Traffic Statistics > Ports > Serial > Traffic

Rx Errors Statistics > Ports > Serial > Rx Errors

Tx Errors Statistics > Ports > Serial > Tx Errors

Sys Errors Statistics > Ports > Serial > Sys Errors

To see these 
statistics Use this path

Summary Statistics > Ports > FDDI > Summary

Traffic Statistics > Ports > FDDI > Traffic

Rx Errors Statistics > Ports > FDDI > Rx Errors

Tx Errors Statistics > Ports > FDDI > Tx Errors

Sys Errors Statistics > Ports > FDDI > Sys Errors
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Viewing HSSI Port Statistics

Clicking on Statistics > Ports > HSSI in the navigational frame reveals the 
following subordinate links: Summary, Traffic, Rx Errors, Tx Errors, and 
Sys Errors.

Viewing Token Ring Port Statistics

Clicking on Statistics > Ports > Token Ring in the navigational frame reveals 
following subordinate links: Summary, Traffic, Rx Errors, Tx Errors, and 
Sys Errors.

To see these 
statistics Use this path

Summary Statistics > Ports > HSSI > Summary

Traffic Statistics > Ports > HSSI > Traffic

Rx Errors Statistics > Ports > HSSI > Rx Errors

Tx Errors Statistics > Ports > HSSI > Tx Errors

Sys Errors Statistics > Ports > HSSI > Sys Errors

To see these 
statistics Use this path

Summary Statistics > Ports > Token Ring > Summary

Traffic Statistics > Ports > Token Ring > Traffic

Rx Errors Statistics > Ports > Token Ring > Rx Errors

Tx Errors Statistics > Ports > Token Ring > Tx Errors

Sys Errors Statistics > Ports > Token Ring > Sys Errors
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Chapter 7
Viewing Router Protocol Statistics

Clicking on Statistics > Protocols displays the following folders in the 
navigational frame:

• IP

• IPX

• AppleTalk

To get statistical information about any protocol type, click on the appropriate
link. Each protocol folder contains links to summary statistics, traffic statistics
(number of packets transmitted and received), and interface statistics, as wel
other statistics specific to that protocol. The following sections show and brie
describe these displays. 

Changing the Administrative Status of a Port
Viewing IP Statistics
Viewing IPX Statistics
Viewing AppleTalk Statistics

Changing the Administrative Status of a Port

A user who has Manager-level access privileges can click on a radio button i
first column of the table in the interface statistics window for any protocol type
enable or disable (that is, change the administrative setting of) the port 

Caution: If you disable the interface through which your Web browser is 
communicating with a router, you will no longer be able to monitor that 
router’s operation with the HTTP Server.
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The Enabled column displays the administrative setting, but it is not a clickab
link. The State column shows the operational state of the interface (up or dow
the Enabled column shows that the interface is enabled, but the State colum
shows that the interface is down, there is a problem with the interface.

Viewing IP Statistics

Clicking on Statistics > Protocols > IP in the navigational frame reveals the 
following subordinate links: Global, Traffic, Interfaces, Routes, ARP Cache, R
and ICMP.

Viewing IPX Statistics

Clicking on Statistics > Protocols > IPX in the navigational frame reveals the 
following subordinate links: Global, Traffic, Interfaces, Forwarding, Hosts, 
Routes, Services, RIP, and SAP.

To see these 
statistics Use this path

Global Statistics > Protocols > IP > Global

Traffic Statistics > Protocols > IP > Traffic

Interfaces Statistics > Protocols > IP > Interfaces

Routes Statistics > Protocols > IP > Routes

ARP Cache Statistics > Protocols > IP > ARP Cache

RIP Statistics > Protocols > IP > RIP

ICMP

• Counters
• Received
• Transmitted

Statistics > Protocols > IP > ICMP
This reveals the following subordinate links: Counters, Received, and 
Transmitted.

Statistics > Protocols > IP > ICMP > Counters
Statistics > Protocols > IP > ICMP > Received
Statistics > Protocols > IP > ICMP > Transmitted
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Viewing AppleTalk Statistics

Clicking on Statistics > Protocols > AppleTalk in the navigational frame revea
the following subordinate links: Global, Traffic, Interfaces, Routes, ARP Cach
and Zones.

To see these 
statistics Use this path

Global Statistics > Protocols > IPX > Global

Traffic Statistics > Protocols > IPX > Traffic

Interfaces Statistics > Protocols > IPX > Interfaces

Forwarding Statistics > Protocols > IPX > Forwarding

Hosts Statistics > Protocols > IPX > Hosts

Routes Statistics > Protocols > IPX > Routes

Services Statistics > Protocols > IPX > Services

RIP Statistics > Protocols > IPX > RIP

SAP Statistics > Protocols > IPX > SAP

To see these 
statistics Use this path

Global Statistics > Protocols > AppleTalk > Global

Traffic Statistics > Protocols > AppleTalk > Traffic

Interfaces Statistics > Protocols > AppleTalk > Interfaces

Routes Statistics > Protocols > AppleTalk > Routes

ARP Cache Statistics > Protocols > AppleTalk > ARP Cache

RIP Statistics > Protocols > AppleTalk > RIP

Zones Statistics > Protocols > AppleTalk > Zones
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Appendix A
Site Manager Parameters

This appendix contains the Site Manager parameter descriptions for the HTT
Server. You can display the same information using Site Manager or the BCC
online Help.

For each parameter, this appendix provides the following information:

• Parameter name

• Configuration Manager menu path

• Default setting

• Valid parameter options

• Parameter function

• Instructions for setting the parameter

• Management information base (MIB) object ID

The Technician Interface allows you to modify parameters by issuing set  and 
commit commands with the MIB object ID. This process is equivalent to 
modifying parameters using Site Manager. For more information about using
Technician Interface to access the MIB, see Using Technician Interface Software.

Caution: The Technician Interface does not verify the validity of your 
parameter values. Entering an invalid value can corrupt your configuration.
300019-B Rev. 00 A-1
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Site Manager Parameters

The Edit HTTP Global Parameters window contains the parameters that you
configure for the HTTP Server. To access the Edit HTTP Global Parameters 
window, complete the following tasks:

The parameter descriptions follow.

Site Manager Procedure

You do this System responds

1. In the Configuration Manager window, 
choose Protocols .

The Protocols menu opens.

2. Choose Global Protocols . The Global Protocols menu opens.

3. Choose HTTP. The HTTP menu opens.

4. Choose Global . The Edit HTTP Global Parameters 
window opens.

Parameter: Enable/Disable

Path: Configuration Manager > Protocols > Global Protocols > HTTP > Global
Default: When you enable the HTTP Server, this parameter is automatically set to 

Enabled.
Options: Enabled | Disabled

Function: Enables or disables the HTTP Server on this interface. 
Instructions: To prohibit the use of the HTTP Server on this interface, set this paramete

to Disabled.
MIB Object ID: 1.3.6.1.4.1.18.3.5.3.22.1.1.2

Parameter: Port

Path: Configuration Manager > Protocols > Global Protocols > HTTP > Global
Default: 80
Options: 0 to 4096

Function: Specifies the port number on which you enable the HTTP Server.
Instructions: Accept the default value, 80, or specify a value from 0 to 4096.

MIB Object ID: 1.3.6.1.4.1.18.3.5.3.22.1.1.4
A-2 300019-B Rev. 00
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Parameter: Authentication

Path: Configuration Manager > Protocols > Global Protocols > HTTP > Global
Default: Basic
Options: Basic | Digest

Function: Specifies the type of authentication to use on this interface: basic or digest
Basic authentication verifies the user's identity using the user name and 
password passed over the network as clear text. Digest authentication uses
encrypted password. If you specify digest authentication, but your browser d
not support this, authentication reverts to basic.

Instructions: Accept the default value Basic, or specify Digest.
MIB Object ID: 1.3.6.1.4.1.18.3.5.3.22.1.1.7

Parameter: Domain Name

Path: Configuration Manager > Protocols > Global Protocols > HTTP > Global
Default: None
Options: Any valid string of characters constituting a domain name

Function: Lets the server be accessible by a domain name, rather than by IP addres
Domain Name parameter must be set to the domain name that a DNS look
would return for the router.

Accept the default value, no domain name, to indicate that the server is 
accessible only by the IP address; or specify a domain name to use instead
IP address.

Instructions: Accept the default value, no domain name, to indicate that the server is 
accessible only by the IP address; or specify a domain name to use instead
IP address.

MIB Object ID: 1.3.6.1.4.1.18.3.5.3.22.1.1.8
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Appendix B
Show Commands for the HTTP Server

Use the Bay Command Console (BCC) show  command to display statistical 
information about the HTTP Server on the router. The statistics available thro
the BCC are a subset of the information available through the HTTP Server 
interface itself. See Using the Bay Command Console for information about show  
scripts command syntax.

This chapter contains the following information about show commands:

• Sample show Command Output
• Online Help for show Commands
• Show Commands for the HTTP Server

• show http summary
• show http requests
• show http responses
300019-B Rev. 00 B-1
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Sample show Command  Output

The show command displays summary information about the HTTP Server o
the router. For example, if you enter the command:

bcc> show http requests

You see this type of output:

show http requests                                  Sep 21, 1998 
11:48:04 [EDT]

Method  Total In  In Last Time
------  --------  ----------------------------
get          186  Sep 21 1998 14:20:57 [GMT-5]
head           0
trace          0
post           0
options        0
put            0
delete         0

Online Help for show Commands

You can display a list of available command options by entering show  or show  
<option> without additional options or with a question mark as an option. For 
example, entering show or show http ?  at the BCC prompt displays the list of al
show  or show http keyword (subcommand) options.
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Show Commands for the HTTP Server

The show http  or show http ? command lists the keywords (also called 
subcommands) available with this command. These keywords are:

• summary

• requests

• responses

The show http <keyword> command displays information about the HTTP Serv
activity on the router.

The HTTP Server show http  commands have no command arguments, filter 
flags, or filter arguments. The router shows information for all applicable entr

show http summary

The show http summary command displays summary statistics about HTTP 
services on the router.

The output contains the following information:

Total Requests 
Received

The total number of requests the router received.

Total Request Errors The number of received requests that were in error.

Total Request 
Discards

The number of received requests that were discarded.

Total Responses The number of router responses.

Total In Unknowns The number of unrecognizable requests received.

Total Rx Octets The number of received octets.

Total Tx Octets The number of transmitted octets.

Total Time Outs The number of time outs that occurred since the last reset.

Start Time The time of the last router reset.
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show http requests

The show http requests command displays HTTP request statistics for the 
router.

The output contains the following information:

show http responses

The show http requests command displays HTTP response statistics for the 
router.

The output contains the following information:

Method An HTTP keyword indicating a type of request.

Total In The number of requests received.

In Last Time The time the most recent request was received.

Status A numeric status code and a brief interpretation for a response 
category.

Total Out The number of responses sent.

Out Last Time The time the most recent response was sent.
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A

access control filtering, 1-6

acronyms, xi

administrative status of a port, changing, 7-1

alert, circuit, 4-2

AppleTalk statistics, 7-3

authentication
basic, 1-5
configured, 5-3
digest, 1-6

Authentication parameter, A-3

B

basic access authentication, 1-5

BCC show command, B-1

BCC, using to start the HTTP Server, 1-3

BootP statistics, 5-2

browser requirements, 1-1

C

cascading style sheets, 1-1

changing HTTP parameters, 1-7

circuit Alert, 4-1

circuit alert
displaying, 4-2

configuration files, initial, 1-2

configuration statistics, HTTP, 5-3

conventions, text, x

counters, HTTP, 5-3

customizing HTTP parameters, 1-7
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D

debug event, meaning, 4-3

device monitoring, 3-1

digest authentication, 1-6

DNS, 1-6

Domain, A-3

domain name
configured, 5-3

domain name instead of IP address, 1-6

Domain Name parameter, 1-6, A-3

E

Edit HTTP Global Parameters window, A-2

educational services, xii

Enable/Disable parameter, A-2

enabling HTTP Server, 1-1

Ethernet port statistics, 6-2

event, 4-1
viewing, 4-2

event log
filtering, 4-3
interpreting, 4-3
severity levels, 4-3

Events icon, 4-2

F

fault event, meaning, 4-3

FDDI port statistics, 6-3

filtering the event log, 4-3

flash memory card, 1-2
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folder icon, 2-2

frames, 1-1

FTP statistics, 5-2

G

GAME, 2-1

getting help, 3-1

H

hardware icon, 3-3

help for show commands, B-2

help, getting, 3-1

HSSI port statistics, 6-4

HTTP authentication, configured, 5-3

HTTP configuration statistics, 5-3

HTTP counters, 5-3

HTTP domain name, 5-3

HTTP parameters, customizing
BCC, 1-7
Site Manager, 1-8

HTTP port, 5-3

HTTP request statistics, 5-4

HTTP requests, 5-5

http requests, B-4

HTTP response statistics, 5-4

HTTP responses, 5-5

http responses, show command, B-4

HTTP Server
concepts, 2-1
starting, 1-1
starting and configuring, 1-1
statistics, 5-3

HTTP server configuration statistics, 5-6

HTTP Site Manaager parameter
Enable/Disable, A-2

HTTP Site Manager parameter
Authentication, A-3
Domain Name, A-3

HTTP state, 5-3

HTTP statistics, 5-2
viewing, 5-5

HTTP status, 5-3

HTTP summary statistics, 5-6

http summary, show command, B-3

httpreq.dat, 5-5

httpresp.dat, 5-5

httpsrv.dat, 5-6

httpsum.dat, 5-6

I

ICMP statistics, 7-2

icon
Circuit Alert, 4-2
Events, 4-2
Hardware, 3-3
Info, 3-3
support folder, 2-2
tasks, 3-3

in last time, HTTP statistic, 5-4

info event, meaning, 4-3

Info icon, 3-3

install.bat script, 1-2

IP access control filter, 1-6

IP address
replacing with domain name, 1-6

IP statistics, 7-2

IPX statistics, 7-2

J

Java applets, 1-1

M

Max Cache Age (seconds) parameter, A-3

Max Cache Count parameter, A-3

method, HTTP statistic, 5-4

modifying HTTP parameters, 1-7

monitoring, 4-1

monitoring device operation, 3-1
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N

network address filtering, 1-6

O

online help for show commands, B-2

out last time, HTTP statistic, 5-4

P

parameters
Site Manager, A-1

Port parameter, A-2

port statistics, 6-1
Ethernet, 6-2
FDDI port, 6-3
HSSI, 6-4
serial, 6-3
traffic (all), 6-2

port status, changing, 7-1

port, HTTP, 5-3

port, troubleshooting, 6-2, 7-2

product support, xii

protocol statistics, 7-1

publications
Bay Networks, xi

Q

Quick-Start procedure, 1-2

R

received (rx) octets, HTTP statistic, 5-4

request discards, HTTP statistic, 5-3

request errors, HTTP statistic, 5-3

request statistics, 5-5

requests received, HTTP statistic, 5-3

requests, show, B-4

requirements, browser, 1-1

response (status) code, 5-4

response statistics, 5-5

responses
HTTP statistic, 5-3
show command, B-4

router
specifying, 3-2

router monitoring, 3-1

router protocol statistics, 7-1

router statistics, 5-1

S

security, setting, 1-4

serial port statistics, 6-3

server configuration statistics, 5-6

severity levels, events, 4-3

show command, BCC, B-1

show commands
command syntax, B-2
config, B-2
online Help for, B-3

show commands, help, B-2

show http requests, B-4

show http responses command, B-4

show http summary command, B-3

Site Manager
parameter descriptions, A-1
Statistics Manager, 5-4
using to start the HTTP Server, 1-4, 1-8

SNMP statistics, 5-2

specifying a router to monitor, 3-2

start time, HTTP statistic, 5-4

starting HTTP Server, 1-1
BCC, 1-3
Site Manager, 1-4

state
HTTP, 5-3

statistics
AppleTalk, 7-3
Ethernet port, 6-2
FDDI port, 6-3
HSSI port, 6-4
HTTP, 5-3
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HTTP configuration, 5-3
HTTP request, 5-4
HTTP requests, 5-5
HTTP response, 5-4
HTTP responses, 5-5
HTTP server configuration, 5-6
HTTP summary, 5-6
ICMP, 7-2
IP, 7-2
IPX, 7-2
port, 6-1
router protocol, 7-1
serial port, 6-3
token ring portport statistics

token ring, 6-4
traffic, all ports, 6-2
viewing, 5-1

Statistics Launch Facility, 5-5

Statistics Manager, 5-1, 5-3, 5-4

statistics, available, 5-1

status of a port, changing, 7-1

status, HTTP, 5-3

status, HTTP statistic, 5-4

summary
http show command, B-3
system status, 3-2

summary statistics, 5-6

support folder icon, 2-2

support, Bay Networks, xii

system status, summary, 3-2

T

Tasks icon, 3-3

TCP statistics, 5-2

technical publications, xi

technical support, xii

Telnet statistics, 5-2

text conventions, x

TFTP statistics, 5-2

time outs, HTTP statistic, 5-4

token ring port statistics, 6-4

total in unknowns, HTTP statistic, 5-3

total in, HTTP statistic, 5-4

total out, HTTP statistic, 5-4

total request discards, HTTP statistic, 5-3

total request errors, HTTP statistic, 5-3

total requests received, HTTP statistic, 5-3

total responses, HTTP statistic, 5-3

total rx octets, HTTP statistic, 5-4

total time outs, HTTP statistic, 5-4

total tx octets, HTTP statistic, 5-4

trace event, meaning, 4-3

traffic statistics for all ports, 6-2

transmitted (tx) octets, HTTP statistic, 5-4

troubleshooting a port, 6-2, 7-2

U

unknowns, HTTP statistic, 5-3

W

warning event, meaning, 4-3
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