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 Chapter 1

• • • • • •
 Getting Started

What is BrightAuthor?
BrightAuthor is a software application that helps you create presentations for your digital sign or 
kiosk. You can play your BrightAuthor presentations on BrightSign models: HD110, HD210, 
HD210w, HD410, HD810, HD1010, and HD1010w. Your presentations can include any of the 
following types of contents:

• Images
• Pre-recorded videos
• Live videos (HD810, HD1010, and HD1010w only)
• Audio
• RSS 
• SignChannel (HD210, HD210w, HD1010, and HD1010w only, subscription required, 

go to www.signchannel.com for details)
• Text
• Date or time
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What kind of presentations can I create?
You can create two types of presentations with BrightAuthor:

• Non-interactive: A slide show or video that plays as a continuous loop. You can play non-
interactive presentations on all BrightSign models that are compatible with BrightAuthor.

• Interactive: A presentation that requires input from the user via a button board, keyboard, 
mouse, or similar input device. To play interactive presentations, you must use an HD210, 
HD210w, HD410, HD810, HD1010, or HD1010w.

What type of layouts can I use?
You can choose from a variety of ready-to-use layout templates or create your own layout 
template. Layout templates fall into two basic categories:

• Full screen: A slide show or video that occupies the full screen.
• Multi-zone: A presentation with different types of content in each region of the screen. The 

screen can include one video zone, and multiple Clock, Text, Ticker, or Image zones. 

Step 1: Get the hardware you need
To create presentations with BrightAuthor, you need a PC that meets or exceeds the following 
minimum requirements:
• 2.3 GHz CPU 
• 2 GB RAM required (4 GB recommended)
• 100 MB available hard disk space for program files (additional disk space required if storing 

content and/or presentations on your hard disk)
• One of these operating systems: 

• Windows XP with SP2 or SP3
• Windows Vista 32 or 64 bit
• Windows7 32 or 64 bit
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To play presentations you create with BrightAuthor, you need the following hardware: 
BrightSign Any of the following models:
• HD110
• HD210 and HD210w
• HD410
• HD810
• HD1010 and HD1010w
Display Any monitor, TV, or Elo touch screen with one of the following types of inputs:
• VGA
• Component (HD810, HD1010, and HD1010w only)
• HDMI
Storage card Either of the following:
• USB Flash card (HD810, HD1010, and HD1010w only)
• SD card
• SDHC card
Card Reader/Writer (not required with USB Flash card) The card reader/writer must be 
connected to your PC and must be compatible with your storage card.

Input device (HD410, HD810, HD1010, and HD1010w only) One or more of the following types 
of input devices:
• Elo Touch Screens that support an HID driver (HD810, HD1010, and HD1010w only)
• Many brands of USB Keyboards
• Many brands of USB Mouse or Trackballs
• Many brands of USB Bar Code Scanners (these appear as a keyboard)
• Quadravox Serial Button Board
• AMX, Crestron, and similar control devices (serial & ethernet)
• Any GPIO button, signal, or LED (your custom board or led display). BrightSign has a test 

button board available for purchase on our estore.
• PC via serial port
• IR remote control using the NEC Remote Control Protocols. You can purchase a compatible 

remote from BrightSign (see Appendix A for remote control codes).
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Step 2: Install the BrightAuthor software
Download the latest software and install it on your PC.

NOTE: BrightAuthor requires the latest version of Microsoft .Net Framework. If this component is 
not already on your PC, BrightAuthor installs it during the installation. However, if BrightAuthor 
needs to install Microsoft .Net Framework, the installation may take up to 45 minutes to complete 
and you may need to restart your PC to complete the installation process.

1 Go to the BrightSign web site www.brightsign.biz/support.
2 Click the BrightAuthor Downloads link.
3 Follow the onscreen instruction to install the software on your PC. 

Step 3: Launch the BrightAuthor application
1 Double-click the BrightAuthor icon on your desktop.
2 (Optional) If prompted, sign in to BrightSign Network (account required). See Publishing a 

presentation using BrightSign Network for details.

Step 3: Add your content
Your BrightAuthor presentations can include the following types of media files:

• Video files. You can use a single file as a loop, or multiple files.  Video files can be MPEG-2 files 
that are saved as transport or program streams, MPEG-1 files that are saved as system streams, 
or H.264 files that are saved as transport streams. Supported file extensions: TS, VOB, and MPG

• Audio files. Any MP3 audio (in a video or mp3 file) must have a sample rate of 48 kHz, 
44.1 kHz, or 32 kHz. 

• Image files. For still images, use BMP, PNG, and JPEG files. The maximum supported resolution 
is 1920x1080.
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Step 4: Create your presentations
Now you’re ready to start using your BrightAuthor to create presentations. Just add your content 
and follow the directions in the next chapter of this guide to create your presentations.

Step 5: Publish your presentations
After create presentations, use the publishing feature to deliver them to your BrightSign units. 
See Publishing Presentations for details.
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 Chapter 2

• • • • • •
 Creating Presentations

Creating a full-screen presentation
In a full-screen presentation, your images or video occupy the entire screen.

1 Create a new presentation project:
a Double-click the BrightAuthor icon on your 

desktop.
b In the Create a new BrightSign project window, 

enter a name for the presentation in the Save As 
field.

TIP: If you do not see the Create a new BrightSign project 
window, do the following to open it: on the menu bar, 
click File > New.

c In the Where field, enter the folder where you want 
to store the presentation. To navigate to the folder 
you want to select, click Browse.

d Select your BrightSign Model, Connector type, and Screen resolution. 
e Select a Monitor overscan setting to control how the image fills the display screen:

• No overscan: Displays images all the way to the edge of the video signal.
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• Overscan action safe: Restricts the image display to an area that is compatible with 
most displays.

• Overscan title safe: Restricts the image display to an area that is much smaller than the 
image generated by the video signal.

NOTE: Don’t be afraid to experiment to find the overscan setting that works best with your display.

f Click Create.
2 Click the Full Screen template, and then click 

Choose.
3 Add your Media Library:

a On the left side of the screen, click Browse.
b Navigate to the folder where your content is 

stored.
c Click OK.
NOTE: If you have a lot of large files in your content 
folder, it may take a while for the thumbnail images 
to appear.

4 Add media files to your presentation by 
dragging files from the Media Library folders to 
the playlist area. 
• To select a series of adjacent media files, press 

Shift+Click as you select the files.
• To select a group of non-adjacent files, press Ctrl+Click as you select the files.
• To arrange the files in the order in which you want them to play, drag the thumbnails in the 

playlist area.
• To remove an item from a playlist, highlight it in the playlist area and press Delete on your 

PC keyboard.
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• (HD410, HD810, HD1010, and HD1010w only) To enable the presentation to respond to user 
input, see Making a presentation interactive for details.

5 HD810, HD1010, and HD1010w only (Optional) Add Live Video to your playlist:
a Click the Other tab on the left side of the screen.
b Drag the Live Video  icon to the 

playlist area. To add more than one 
live video sequence, drag the Live 
Video icon to your playlist again for 
each sequence you want to add.
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c (Optional) Set the video volume: Right-click Live Video 
in the playlist area, select Edit, and then enter the 
settings you want to apply to the selected item. 

TIP: To remove a Live Video item from a playlist, highlight it in 
the playlist area and press Delete on your PC keyboard.

6 HD210, HD210w, HD1010, and HD1010w only 
(Optional) Add SignChannel content to your playlist:
a Click the Other tab on the left side of the screen.
b Drag the SignChannel  icon to the playlist area.
TIP: To remove a SignChannel item from a playlist, highlight it in the playlist area and press 
Delete on your PC keyboard.

7 (Optional) Rename the playlist: 
a Click Edit in the upper-right corner of the 

playlist area.
b Enter a new name for the playlist.
c Click OK.

8 (Optional) Set playback options:
• To edit settings for a single item, right-click the thumbnail 

in the playlist area, select Edit, and then choose the 
settings you want to apply to the selected item.

• To edit settings for multiple items, press Ctrl+Click to 
select the items in the playlist area. On the menu bar, click 
Edit > Selected Items, and then choose the settings you want to apply to all selected items.

9 On the menu bar, click File > Save to store your presentation. 
NOTE: To save the presentation with a different name or in a different folder, select Save As 
instead of Save.

10 Publish your presentation. See Publishing Presentations for details.
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Creating a multi-zone presentation
In a multi-zone presentation, BrightAuthor divides the screen into rectangles called zones. You 
can play different content in each zone and each zone supports a specific type of content. 
BrightAuthor provides a handful of multi-zone templates. You can choose one of the existing 
templates, or create your own (see Customizing template layouts). 

When using a multi-zone template, you need to know which type of content you can include in 
each zone. The color-coded key at the bottom of the template screen shows the available 
content types, and the color-coded templates indicate which type of content you can include in 
each zone of the templates. The following list describes the available content types:

• Images: Plays images. You can include multiple Images zones. 
• Ticker: Plays an RSS feed or pre-defined text strings. You can include multiple Ticker zones.
• Clock: Displays the time or date. You can include multiple Clock zones.
• Video or Images: Plays videos and images. You can include only one Video or Images zone.
• Video Only: Plays videos. You can include only one Video Only zone.
• Background Image: Places an image in the background of your presentation. All other zones 

appear on top of the background image. When using a background image, you cannot 
include a Video Only zone or a Video or Images zone. You can include only one Background 
Image zone.

NOTE: You can include only one zone with video per presentation. Therefore you must choose 
between a Video or Images zone, a Video Only zone, or a Background Image zone. You cannot 
have more than one of these zone types in the same presentation.
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1 Create a new presentation project:
a Double-click the BrightAuthor icon on your 

desktop.
b In the Create a new BrightSign project window, 

enter a name for the presentation in the Save As 
field.

TIP: If you don’t see the Create a new BrightSign project 
window, do the following to open it: on the menu bar, 
click File > New.

c In the Where field, enter the folder where you want 
to store the presentation. To navigate to the folder 
you want to select, click Browse.

d Select your BrightSign Model, Connector type, and Screen resolution. 
e Select a Monitor overscan setting to control how the image fills the display screen:

• No overscan: Displays images all the way to the edge of the video signal.
• Overscan action safe: Restricts the image display to an area that is compatible with 

most displays.
• Overscan title safe: Restricts the image display to an area that is much smaller than the 

image generated by the video signal.
2 Click the multi-zone template you want to use, and then click Choose.
3 Add your Media Library:

a On the left side of the screen, click Browse.
b Navigate to the folder where your content is stored.
c Click OK.
NOTE: If you have a lot of large files in your content folder, it may take a while for the thumbnail 
images to appear.
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4 Add content to each zone 
in your presentation:
a Click the zone you want 

to populate. 
NOTE: Each zone has its own 
playlist.

b Drag items from the 
Media Library folders to 
the playlist area. 
• To select a series of 

adjacent files, press 
Shift+Click as you 
select the files.

• To select a group of 
non-adjacent files, 
press Ctrl+Click as 
you select the files.

• To arrange the files in the order in which you want them to play, drag the thumbnails in the 
playlist area.

• To add an RSS feed, select the Ticker zone, click the RSS tab drag the New RSS Feed icon 
onto the playlist, when prompted, enter the URL, and then click OK. Repeat this step to add 
additional RSS feeds.

• To add a text feed, create a text file that contains the text. Insert a line break between each 
text item in the text file. Save the text file and place it in your Media Library folder. Select 
the Ticker zone, click the Text tab, and then drag the text file onto the playlist. Repeat this 
step to add additional text files.

• To remove an item from a playlist, highlight it in the playlist area and press Delete on your 
PC keyboard.
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• (HD410, HD810, HD1010, and HD1010w only) To enable the presentation to respond to 
user input, see Making a presentation interactive for details.

• (HD810, HD1010, and HD1010w only) To add live video, click the Other tab on the left side 
of the screen and drag the Live Video  icon to the playlist area.

• (HD210, HD210w, HD1010, and HD1010w only) To add SignChannel content click the 
Other tab on the left side of the screen and drag the SignChannel  icon to the playlist 
area.

c Repeat steps a and b for the remaining zones.
5 (Optional) Set playback options:

• To edit settings for a single item, right-click the thumbnail in the playlist area and select Edit, 
and then choose the settings you want to apply to the selected item.

• To edit settings for multiple items, press Ctrl+Click to select the items in the playlist area. On 
the menu bar, click Edit > Selected Items, and then choose the settings you want to apply to 
all of the selected items.

6 (Optional) Rename the playlists: 
a For each playlist, click Edit in the upper-right corner of the playlist area.
b Enter a new name for the selected playlist.
c Click OK.

7 (Optional) Set zone properties. See Setting zone properties for details. 
8 On the menu bar, click File > Save to store your presentation. 

NOTE: To save the presentation with a different name or in a different folder, select Save As 
instead of Save.

9 Publish your presentation. See Publishing Presentations for details.
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Making a presentation interactive
You can use BrightAuthor to make presentations interactive. Interactive presentations respond 
to interactive events, such as input from buttons or other GPIO devices, or from devices 
connected to a BrightSign communication port. The supported communication methods vary 
by BrightSign model.

RS232 serial devices: HD410, HD810, HD1010, and HD1010w

USB devices (such as touch screens, mice, keyboards, barcode scanners, IR remote 
controls): HD810, HD1010, and HD1010w (see Appendix A for remote control codes)

Ethernet devices: HD210, HD210w, HD1010, and HD1010w

1 Open a presentation project:
NOTE: If you haven’t already created a presentation project, see Creating a full-screen 
presentation or Creating a multi-zone presentation for details.

a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open.
c Select the presentation you want to open.
d Click Open. 
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2 Choose the Home screen:
The Home  icon identifies 
the Home screen in your 
playlist. The Home screen is 
the first media file (video or 
image) in the playlist, and it is 
where the presentation 
begins. It usually includes 
either of the following:

• An attract video that 
loops until the user 
provides input

• A list of options from 
which the user can choose 
the next action

a Click the Edit tab.
b On the left side of the screen, click any zone (except a ticker or clock zone) that you want to 

make interactive. 
c On the right side of the playlist area, click interactive.
d Drag the media file you want to use as the first file in your presentation (Home screen) to the 

playlist. 
TIP: If the item you want to use as your Home screen is already in your playlist, double-click that 
item to open the Media Properties window, check the Set as initial state box, and then click OK. 

e Repeat steps b – d for any other zones you want to make interactive.
3 If you haven’t already done so, add media files to each of the zones in your presentation. See 

Creating a full-screen presentation or Creating a multi-zone presentation for details.
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4 Define interactive events:
a In the playlist toolbar, 

click the interactive 
event button you want 
to define. For example, 
to define what happens 
when the user presses 
button 1 on a button 
board, click .

b Click the file name 
below the Home 
screen’s thumbnail 
image (the pointer 
changes to a hand).

c Drag the hand pointer 
to the thumbnail image 
of the media file you want to play when the user presses the button you selected in step (a). 

d Repeat steps a – c to define the remaining interactive events. Note that subsequent 
interactions can start with any item. (They don’t need to start with the Home screen.) 

For example, you can set the first interaction to display an image when the user presses 
button 1 from the Home screen. You can set a second interaction to display a second image 
if the user presses button 1 a second time while the first image is displayed. 

If you don’t see the button you want in the playlist toolbar, click the arrow to the left of the 
Zoom control to display more toolbar buttons. You can also access Event icons by clicking the 
events tab under Media Library. However, when you use the events tab, you need to select 
the next event from the Specify next state list instead of dragging to the target item.
 18 
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Interactions can include any of the following events:

Event Icon Description

Displays an item for a predetermined period of time before the next action occurs 
automatically. To create a Timeout event, drag the Timeout icon onto the item to which it 
applies and then drag to the target item. To define the length of the timeout interval double-
click the Timeout icon below the item to open the Timeout Event window. In the Specify 
timeout (seconds) field, enter the number of seconds you want the item to display, and 
then click OK.

Sets the action that occurs after a video or audio file finishes playing.

Sets the action that occurs when a specific GPIO button/input is pressed or activated. By 
default, the playlist toolbar includes several GPIO buttons which you can use to define 
interactions. To define a GPIO interaction, click the GPIO button on the Event bar and then 
drag a line from the trigger item to the target item. 

Sets the action that occurs when the user touches the specified rectangular area on a 
touchscreen. To define the area, drag the Rectangular Touch icon onto the item to which it 
applies and then drag to the target item. When the Add Touch Event window opens, drag 
the box to resize the touch area (or enter the exact Size and Position), and then click OK.

Sets the action that occurs when BrightSign receives input from a network device. Use this 
event when you want an external device to control BrightSign using UDP (User Datagram 
Protocol or Universal Datagram Protocol). To define the trigger, drag the UDP Input icon 
onto the item to which it applies and then drag to the target item. When the UDP Input 
Event window opens, enter the network address for the external device in the Specify UDP 
input field, and then click OK.
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Sets the action that occurs when BrightSign receives input from a device connected to the 
USB (Universal Serial Bus) port. To define the trigger, drag the USB Input icon onto the item 
to which it applies and then drag to the target item. When the USB Input Event window 
opens, enter the USB input that triggers the next event in the Specify USB input field, and 
then click OK.

Synchronizes content in another zone. To define the link, drag the Link Zones icon onto the 
item to which it applies. When the Link Zones Event window opens, enter the trigger in the 
Specify link keyword field, and then click OK.

Synchronizes content with another BrightSign on the same network. To define the 
connection, drag the Synchronize icon onto the item to which it applies. When the 
Synchronize Event window opens, enter the trigger in the Specify synchronization 
keyword field, and then click OK.

Sets the action that occurs when BrightSign receives specific input from a device connected 
to the serial port. To define the input, drag the Serial Input icon onto the item to which 
it applies and then drag to the target item. When the Serial Input Event window opens, 
enter the serial string that triggers the next event in the Specify serial input field, and 
then click OK.

Sets the action that occurs when BrightSign receives specific input from a keyboard. To 
define the keyboard input, drag the Keyboard Input icon onto the item to which it applies. 
When the Keyboard Input Event window opens, enter the keyboard input that triggers the 
next event in the Specify keyboard input field, and then click OK.

Sets the action that occurs when BrightSign receives specific input from a remote control. To 
define the remote input, drag the Remote Input icon onto the item to which it applies and 
then drag to the target item. When the Remote Input Event window opens, enter the remote 
character that triggers the next event in the Specify remote input field, and then click OK. 
For more info, see Appendix A for remote control codes.

Event Icon Description
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Adding commands to your playlists
To add extended functions to your presentations, you can connect devices to the ports on your 
BrightSign and then add commands to your playlist to control these devices. For example, you 
can connect a projector to BrightSign’s serial port and then create a playlist to turn it on and 
another playlist to turn it off. You can then use the playlist scheduling feature to automatically 
turn the projector on in the morning and off in the evening.

1 Open an interactive presentation project:
NOTE: If you haven’t already created an interactive presentation project, see Making a 
presentation interactive for details.

a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open.
c Select the presentation you want to open.
d Click Open. 

2 In the playlist area, double-click the media file to which you want to apply the command.
3 In the Media Properties window, click 

Advanced.
4 Click Add Command.
5 Select the command you want to add 

from the list and enter the appropriate 
parameter for that command. The 
commands vary based on the type of 
content you selected and may include 
any of the following: 
• Send UDP: Sends a command to the 

device using UDP protocols. 
• Serial-send string (CR): Sends a string to a serial device. This command adds a carrier return 

at the end of the string.
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• Serial-send string (no CR): Sends a string to a serial device. This command does not add a 
carrier return at the end of the string.

• Serial-send byte: Sends a byte to a serial device.
• GPIO On: Turns on the specified GPIO outputs. Other GPIO output are not affected.
• GPIO Off: Turns off the specified GPIO output.
• Set GPIO Set State: Enables you to turn each GPIO line on or off.
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 Chapter 3

• • • • • •
 Publishing Presentations

After you create and save a presentation, you’re ready to publish it and play it on your BrightSign. 
There are three ways to publish a presentation:

• Local Storage
• BrightSign Network
• Simple File Networking
The following sections describe each of these publication methods.

Publishing a presentation using Local Storage
Publishing a presentation using Local Storage enables you to copy your presentation to an SD 
card which you can insert directly into your BrightSign. A BrightSign account is not required. 
When you want to change or replace your presentation, you must save a copy of the new 
presentation on an SD card and insert it into your BrightSign.

1 Open the presentation project you want to publish:
a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open.
c Select the presentation you want to open.
d Click Open. 
23 
• 
• 
•
•
•



• 
2 Select the presentation 
you want to publish:
a Click the Publish tab on 

the upper-left side of 
the screen.

b Click Local Storage 
(below the Publish tab).

c Under Presentations, 
click Browse, select the 
folder where your 
presentations are 
located, and then click 
OK. 

d Select the 
presentation(s) you 
want to publish from 
the list of presentations.

3 Create a schedule for the presentation.
a Drag the presentation(s) to the time slots during which you want them to play. To play a 

presentation 24 hours a day, drag the presentation onto the schedule, double-click the 
presentation, select Active all day, every day, and then click OK.

b If prompted, indicate whether you want to replace the existing schedule and then click OK.
TIP: To change the date, use the controls above the calendar grid.

4 Publish the presentation on your SD card:
a Insert an SD card into your card reader.
b (Optional) Under Firmware, select an update option.
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c Under Publish to, click Browse, select the drive where your SD card is located, and then 
click OK.

d Click Publish Schedule.
e When the Publish complete message appears, click OK.

Publishing a presentation using BrightSign Network
Publishing a presentation using BrightSign Network enables you to distribute your presentation 
to your BrightSign units via an Internet connection. To publish via BrightSign Network, you must 
first contact BrightSign to obtain an account name, a user name, and a password. You must also 
upload your presentation to the BrightSign Network server and then add your BrightSign units 
to your network (see Adding BrightSign units to your BrightSign Network).

1 Open the presentation project you want to publish:
a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open.
c Select the presentation you want to open.
d Click Open. 
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2 Upload your presentation to the BrightSign Network server:
a On the menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter your Account, User name, and Password, and then click Sign In.
c On the Edit tab, click Upload to network (in the upper-right corner).
d When the upload is complete, click OK.

3 Select the group and 
presentation you want to 
publish:
a Click the Publish tab on 

the upper-left side of the 
screen.

b Click BrightSign 
Network (above the 
calendar).

c Under Select Group to 
Schedule, select the 
group to which you 
want the presentation 
to belong. For details on 
setting up groups, see 
Creating groups in your 
BrightSign Network.

d Under Presentations, select the presentation you want to publish.
4 Create a schedule for the presentation.

a Drag the presentation(s) to the time slots during which you want them to play. To play a 
presentation 24 hours a day, drag the presentation onto the schedule, double-click the 
presentation, select Active all day, every day, and then click OK.
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b If prompted, indicate whether you want to replace the existing schedule and then click OK.
TIP: To change the date, use the controls above the calendar grid.

5 Publish the presentation:
a (Optional) Under Firmware, select an update option.
b Click Publish Schedule.
c When the Publish complete message appears, click OK.

Publishing a presentation using Simple File Networking
Publishing a presentation using Simple File Networking enables you to distribute your 
presentation to your BrightSign units via a web folder. To use Simple File Networking, you must 
first add each unit to your network (see Adding BrightSign units to your Simple File Network).

1 Open the presentation project you want to publish:
a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open.
c Select the presentation you want to open.
d Click Open. 

2 Select the presentation you want to publish:
a Click the Publish tab on the upper-left side of the screen.
b Click Simple File Networking (above the calendar).
c Under Presentations, click Browse, select the folder where your presentations are located, 

and then click OK. 
d Select the presentation(s) you want to publish.
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3 Create a schedule for the presentation.
a Drag the presentation(s) to the time slots during which you want them to play. To play a 

presentation 24 hours a day, drag the presentation onto the schedule, double-click the 
presentation, select Active all day, every day, and then click OK.

b If prompted, indicate whether you want to replace the existing schedule and then click OK.
TIP: To change the date, use the controls above the calendar grid.
•
•
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4 Publish the presentation:
a (Optional) Under Firmware, select an update option.
b Under Web folder URL, enter the URL for the web folder.
IMPORTANT: The Web folder URL must be identical to the URL you entered when you set up your 
Simple File network. See Adding BrightSign units to your Simple File Network for details.

c Under Publish to, click Browse, select the location where you want to store the files, and 
then click OK.
• If you have a mapped drive or shortcut that points to your web folder, publish your 

presentation to that location.
• If you use FTP to transfer files to your web folder, publish your presentation to a folder on 

your computer and then use FTP software to copy the files to your web folder.
d Click Publish Schedule.
e When the Publish complete message appears, click OK.
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 Chapter 4

• • • • • •
 Adding Units to Your Network

If you’re using BrightSign Network or Simple File Networking to publish your presentations, you 
must add your BrightSign units to your network. The following sections describe how to add 
units to your network.

Adding BrightSign units to your BrightSign Network
To publish and manage presentations using BrightSign Network, you must first contact 
BrightSign to obtain an account name, user name and password. After you obtain your account 
credentials, you need to add your BrightSign units to your network by creating and installing a 
setup file for each unit. The setup file provides details about your network and BrightSign 
Network connections, where the presentations associated with the selected group are stored, 
and when to run the presentations.

1 Sign in to your BrightSign Network account:
a On the menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter your Account, User name, and Password, and then click Sign In.

2 On the menu bar, click Tools > Setup BrightSign Unit.
3 Under Name Specification, do the following:

a Enter a Name and Description for this unit.
b Select whether you want to append the unit ID to the name or to use the name only.
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4 Under Network Properties, 
set the following:
• Time zone: Select the time 

zone where this unit is 
located.

• Time server: Select the 
clock for this unit.

• IP address: Indicate 
whether the IP is auto-
generated or static. If 
you’re using a static IP 
address, enter parameters.

5 Under Firmware, indicate 
whether you want to 
update the firmware and to 
which version.

6 Under Unit Configuration, click Networked with BrightSign Network, and then specify 
the following:
• Group: Assigns this unit to the specific group in which you published the presentation (see 

Creating groups in your BrightSign Network and Publishing a presentation using 
BrightSign Network).

• Network Connection Frequency: Sets how often this unit checks the server for updates.
• Limit content downloads: Sets a timeframe during which downloads can take place.

7 Create and install the setup file: 
a Click Create Setup Files.
b Select an SD or SDHC card or a USB Flash drive to store the setup files.
c Turn off the BrightSign unit and insert the card or Flash drive into the unit.
d Turn on the BrightSign unit.
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If the unit is connected to the network and you’ve already scheduled and published 
presentation(s) for this unit, the unit retrieves the presentation(s) and displays them at the 
scheduled time.

Adding BrightSign units to your Simple File Network
To publish and manage presentations using Simple File Networking, you must first add your 
BrightSign units to your network by creating and installing a setup file for each unit. The setup 
file provides details about your network, the web folder associated with a unit, where 
presentations are stored, and when to check for updates.

1 On the menu bar, click Tools > Setup BrightSign Unit.
2 Under Name Specification, do the following:

a Enter a Name and Description for this unit.
b Select whether you want to append the unit ID to the name or to use the name only.

3 Under Network Properties, 
set the following:
• Time zone: Select the time 

zone where this unit is 
located.

• Time server: Select the 
clock for this unit.

• IP address: Indicate 
whether the IP is auto-
generated or static. If 
you’re using a static IP 
address, enter parameters.
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4 Under Firmware, indicate whether you want to update the firmware and to which version.
5 Under Unit Configuration, click Networked with Simple File Networking, and then 

specify the following:
• URL for the web folder: Sets the location from which this unit downloads presentations. Do 

not use trailing slashes in your URL; some web servers do not support trailing slashes.
IMPORTANT: The URL for the web folder must be identical to the Web folder URL you enter when 
you publish your presentation (see Publishing a presentation using Simple File Networking). 

• Network Connection Frequency: Sets how often this unit checks the web folder for updates.
• Limit content downloads: Sets a timeframe during which downloads can take place.

6 Create and install the setup file: 
a Click Create Setup Files.
b Select an SD or SDHC card or a USB Flash drive to store the setup files.
c Turn off the BrightSign unit and insert the card or Flash drive into the unit.
d Turn on the BrightSign unit.
If the unit is connected to the network and you’ve already scheduled and published 
presentation(s) for this unit, the unit retrieves the presentation(s) and displays them at the 
scheduled time.
•
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 Chapter 5

• • • • • •
 Customizing Presentations

Setting zone properties
Whether you’re creating a full-screen presentation with a single zone or a multi-zone 
presentation, you can customize the settings for each zone in your presentation as 
described in this section. For information about changing the default zone settings, 
see Setting default properties.

1 Open a presentation project:
NOTE: If you haven’t already created a presentation project, see Creating a full-screen 
presentation or Creating a multi-zone presentation for details.

a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open.
c Select the presentation you want to open.
d Click Open. 

2 In the upper-left corner, click the zone for which you want to change the properties.
3 Click Zone Properties.
4 Set any of the following:

NOTE: The settings vary based on your BrightSign model and the type of zone you selected. 
34 
• 
• 
•
•
•



• 
View Mode
• Scale to Fit: Scales the video to fill the screen 

without maintaining the aspect ratio. Images may 
appear stretched.

• Letterboxed and Centered: Centers the image and 
adds black borders. The aspect ratio is maintained.

• Fill Screen and Centered: Centers the image and 
fills the screen. The aspect ratio is maintained.

Image Mode
• Center Image: Centers the image without scaling 

(may result in cropping if the image is larger than 
the current videomode resolution).

• Scale to Fit: Scales the image to fit the display. The whole image is displayed as large as 
possible with correct aspect ratio.

• Scale to Fill and Crop: Scales the image to fill the display while maintaining aspect ratio.
• Scale to Fill: Scales the image to fill the screen without maintaining aspect ratio.

Live Video
Sets attributes for a live video feed. You can select the Input and Video Standard types and enter 
parameters for Brightness, Contrast, Saturation, and Hue.

Number of Lines
Sets the number of lines of text in a Ticker zone.

Time to Display Each Line
Sets how long each line of text displays in a Ticker zone.

Rotation
Sets the angle of the text in a Ticker zone.

Alignment
Sets whether the text is left aligned, right aligned, or centered in a Ticker zone.
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Text Appearance
Sets whether the text is animated or static in a Ticker zone.

Foreground Text Color
Sets the text color in Ticker or Clock 
zones.

Background Text Color 
Sets the color of the background behind 
the text in Ticker or Clock zones. 

Transparency
Sets the transparency of the text in 
Ticker or Clock zones.

Font
Sets the font of the text in Ticker or 
Clock zones. You can use any TrueType 
font.

Background Bitmap
Adds the specified file as a background image. You can add a background bitmap to Ticker or 
Clock zones. You can also indicate whether you want to stretch the image to fill the zone region. 

Safe Text Region
Defines the location and size of the text region within the zone.
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Setting presentation properties
Presentation properties apply to your entire presentation. The default settings are based on your 
current default property settings (see Setting default properties).

1 Open a presentation project:
NOTE: If you haven’t already created a presentation project, see Creating a full-screen 
presentation or Creating a multi-zone presentation for details.

a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open.
c Select the presentation you want to open.
d Click Open. 

2 On the menu bar, click File > Presentation Properties.
3 Click the Main tab and set any of the following:

• Connector type: Indicates the type of display that is 
connected to the BrightSign on which you want to run the 
presentation: VGA, HDMI, or Component.

• Screen resolution: Sets the display resolution. Choose a 
resolution that is compatible with the display that is 
connected to your BrightSign.

• RSS Update Frequency: Sets how often BrightSign checks 
for RSS feed updates.

• Background screen color: Sets the backdrop color for your 
sign. Click Choose, select a color, and then click OK.

• Language: Sets the date and time format in the Clock zone.
4 Click the I/O tab and click Input or Output next to each 

GPIO port to indicate whether the port is sending or 
receiving information.
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5 Click the Interactive tab and set any of the following:
• Serial: Sets the parameters for serial communications. You 

can select the Baud rate, Data bits, Parity, and Stop bits.
• UDP: Sets the parameters for UDP communications. You 

can specify the UDP Destination Address (in dotted quad 
form), the UDP Destination Port, and the UDP Receiver 
Port.

• Touch: Reverses the coordinates of the touch screen. Use 
this option only if the touch screen coordinates appear to 
be reversed.

6 Click OK.

Customizing template layouts
If the predefined template layouts do not meet your 
needs, you can create your own templates.

1 Create a new presentation project:
a Double-click the BrightAuthor icon on your desktop.
b In the Create a new BrightSign project window, 

enter a name for the presentation in the Save As field.
TIP: If you do not see the Create a new BrightSign project 
window, do the following to open it: on the menu bar, 
click File > New.
 38 
• 
• 
•
•
•



• 
c In the Where field, enter the folder where you want to store the presentation. To navigate to 
the folder you want to select, click Browse.

d Select your BrightSign Model, Connector type, and Screen resolution. 
e Select a Monitor overscan setting to control how the image fills the display screen:

• No overscan: Displays images all the way to the edge of the video signal.
• Overscan action safe: Restricts the image display to an area that is compatible with 

most displays.
• Overscan title safe: Restricts the image display to an area that is much smaller than the 

image generated by the video signal.
2 Click the template that is most similar to the layout you want to use, and then click Choose.
3 Click Layout (below the Edit tab) 

and do any of the following:
• Resize a zone by clicking the 

zone and then dragging the 
selection handles, or enter the 
Size and Position information 
on the left side of the screen.

• Make two or more zones the 
same size by pressing 
Ctrl+Click to select the zones 
you want to resize. On the 
menu bar, click Format > Make 
Same Size and then select a 
resize option.

• Align two or more zones by 
pressing Ctrl+Click to select 
the zones you want to align. On 
the menu bar, click Format > 
Align and then select an 
alignment option.
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• Center a zone on the screen by clicking the zone you want to center. On the menu bar, click 
Format > Center in Form and then select Horizontally or Vertically.

• Remove an unwanted zone by clicking the zone and then pressing Delete on your keyboard.
• Add a zone by clicking Add Zone, entering a Zone name, selecting the Zone Type, and then 

dragging the rectangle to the appropriate size and location.
• Rename a zone by entering a new label in the Name field on the left side of the screen.
TIP: You can place an Image zone, a Ticker zone, or a Clock zone on top of a Video Only zone. You 
can then use the transparency settings in the Ticker or Clock zone to control how much of the 
underlying video is visible. Note that you cannot place zones on top of a Video or Images zone.

4 Click Save Template (in the bottom of the left pane), enter a name for the template, and 
then click OK.
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Setting default properties
When you create or add to a presentation project, the initial settings are based on the default 
properties. If you often use the same set of properties, you can streamline the development 
process by changing the default property settings to match the settings you use most often. 

NOTE: Changing the default properties does not change an 
existing presentation. To modify presentation, zone, or item 
properties, open the presentation and then change and 
save the new settings. 

1 On the menu bar, click Edit > Preferences.
2 Click the Sign tab and select the default sign settings:

RSS Update Frequency
Sets how often RSS feeds are updated.

Time zone
Sets the default time zone for presentation schedules.

Background Screen Color
Sets the default background color. Click Choose, select a 
color, and then click OK.

GPIO Configuration
Sets whether each of the GPIO ports is an input port or 
an output port.
 41 
• 
• 
•
•
•



• 
3 Click the Video tab and select the default video settings:
NOTE: The settings vary based on your BrightSign model. 

View Mode
• Scale to Fill: Scales the video to fill the screen without 

maintaining the aspect ratio. Images may appear stretched.
• Letterboxed and Centered: Centers the image and adds 

black borders. The aspect ratio is maintained.
• Fill Screen and Centered: Centers the image and fills the 

screen. The aspect ratio is maintained.
Volume
Sets the volume level by specifying a value between 0 and 100. 
100 is full volume.

LiveVideo
Sets the default attributes for live video feeds. You can select Input and Video Standard types and 
enter parameters for Brightness, Contrast, Saturation, Hue, Volume, and Time on Screen.

4 Click the Images tab and select the default image settings:
Image Mode
• Center Image: Centers the image without scaling (may 

result in cropping if the image is larger than the current 
videomode resolution).

• Scale to Fit: Scales the image to fit the display. The whole 
image displays as large as possible with correct aspect ratio.

• Scale to Fill and Crop: Scales the image to fill the display 
while maintaining aspect ratio.

• Scale to Fill: Scales the image to fill the screen without maintaining aspect ratio.
Slide Transition
Sets the effect between images.

Slide Delay Interval
Sets the how long each image displays.
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5 Click the Ticker tab and select the 
default ticker settings:

Number of Lines
Sets the number of lines of text in a 
Ticker zone.

Time to Display Each Line
Sets the how long each line of text 
displays in a Ticker zone.

Rotation
Sets the angle of the text in a Ticker 
zone.

Alignment
Sets whether the text is left aligned, 
right aligned, or centered in a Ticker 
zone.

Text Appearance
Sets whether the text is animated or static in a Ticker zone.

Foreground Text Color
Sets the text color in Ticker zones.

Background Text Color 
Sets the color of the background behind the text in Ticker zones. 

Transparency
Sets the transparency of the text in Ticker zones.

Font
Sets the font of the text in Ticker zones. You can use any TrueType font. Click Browse to select a 
font. Click Reset to System Font to make the current font the default system font.
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Background Bitmap
Adds the specified file as a background image. You can add a background bitmap to Ticker zones. 
You can also indicate whether you want to stretch the image to fill the zone region. 

Safe Text Region
Defines the location and size of the text region within the zone.

6 Click the Clock tab and select the 
default clock settings:

Language
Sets the date and time format. 
Select a language to use a 
predefined format. To customize a 
format, click Customize, enter the 
settings you want to use, and then 
click OK.

Foreground Text Color
Sets the text color in Clock zones.

Background Text Color 
Sets the color of the background behind the text in Clock zones. 

Transparency
Sets the transparency of the text in Clock zones.

Font
Sets the font of the text in Clock zones. You can use any TrueType font.

Background Bitmap
Adds the specified file as a background image. You can add a background bitmap to Clock zones. 
You can also indicate whether you want to stretch the image to fill the zone region. 

Safe Text Region
Defines the location and size of the text region within the zone.
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7 Click the Interactive tab and set any of the following:

Serial
Sets the default parameters for serial communications. You 
can select the Baud rate, Data bits, Parity, and Stop bits.

UDP
Sets the default parameters for UDP communications. You 
can specify the UDP Destination Address (in dotted quad 
form), the UDP Destination Port, and the UDP Receiver Port.

Touch
Reverses the coordinates of the touch screen. Use this option 
only if the touch screen coordinates appear to be reversed.

8 Click OK.
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 Chapter 6

• • • • • •
 Managing Your BrightSign Network

Viewing unit status on your BrightSign Network
Viewing network status enables you to see unit activation status, the group to which the unit is 
assigned, and which presentations are associated with that unit.

1 Sign in to your BrightSign Network account:
a On the menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter 

your Account, User 
name, and 
Password, and then 
click Sign In.

2 Click the Manage tab 
on the upper-left side 
of the screen.

3 Click Status (below the 
Manage tab).

4 Click a group to view 
details for that group.
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5 (Optional) Sort the Status view by clicking the column you want to use as the sort criteria. 
For example, to sort by Status, click the Status column. To switch between ascending and 
descending order, click Status again. 
NOTE: When a presentation is active, you cannot delete it.

Creating groups in your BrightSign Network
Groups enable you to test your presentation and then distribute them to a specific set of 
BrightSigns. For example, you can create groups based on the region or department in which the 
BrightSigns reside. 

BrightAuthor includes two default groups: Default and LocalTest. LocalTest is the group you use 
to test your presentations on your local network.

1 Click the Manage tab on the upper-left side of the screen.
2 Click Status (below the Manage tab).
3 Click Add Groups (in the lower-left corner of the screen).
4 Enter the name of the group you want to add, and then click OK.

Viewing presentation status on your BrightSign Network
Viewing presentation status enables you to see which presentations you’ve uploaded to your 
BrightSign Network, which presentations are active, and when presentations were last modified.

1 Sign in to your BrightSign Network account:
a On the menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter your Account, User name, and Password, and then click Sign In.
•
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2 Click the Manage tab on 
the upper-left side of the 
screen.

3 Click Presentations (below 
the Manage tab).

4 Click a presentation to view 
which groups are currently 
using the presentation.

5 (Optional) Sort the 
Presentation view by 
clicking the column you 
want to use as the sort 
criteria. For example, to sort 
by Name, click the Name 
column. To switch between 
ascending and descending 
order, click Name again. 
NOTE: When a presentation is active, you cannot delete it.
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Viewing your library on your BrightSign Network
Viewing your library enables you to see the content you’ve uploaded to your BrightSign Network. 

1 Sign in to your BrightSign Network account:
a On the menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter your Account, User name, and Password, and then click Sign In.

2 Click the Manage tab on 
the upper-left side of the 
screen.

3 Click Library (below the 
Manage tab).

4 Do any of the following:
• Identify which items are 

currently in use in a 
presentation. A green 
checkmark indicates the 
item is in use. You cannot 
delete an item when it is 
in use.

• Switch between 
thumbnail and list view. 
Click the icons in the 
upper-right part of the 
screen.

• View item info. Right-click an item and select Info to see the file size, type, date modified, 
date uploaded and presentations that are using the item.

• Delete an item. Right-click an item and select Delete. Remember that you cannot delete an 
item when it is in use.
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• Refresh the Library display. Click Refresh in the upper-right corner.
NOTE: The thumbnails you see in Library view are based on the codecs available on your PC. If an 
image does not display properly, you may not have the necessary codecs on your PC.
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 Chapter 7

• • • • • •
 Frequently Asked Questions

To view additional Frequently Asked Questions, go to support.brightsign.biz/forums.

Can I use BrightAuthor with the HD600 or HD2000?
No, BrightAuthor only supports the HD110, HD210, HD210w, HD410, HD810, HD1010, and 
HD1010w, and we do not plan to add support for the HD600 or HD2000.

Can I open the autoplay.xml file using BrightAuthor?
No. The autoplay.xml file that is generated when you publish a presentation is a playlist file. This 
file includes only the information required for playback on a BrightSign. This file is not the same 
as a presentation project file.

How do I use a different font?
To use a different font, browse to a folder on your computer that has a true type font. This font 
will be copied to the SD card when you publish the presentation. You can use your own custom 
font or download free TrueType fonts from the web.

Can I export a template?
Yes. While there isn't a template export option, you can save the presentation project you're 
using with the new template. You can then open the presentation project on another computer, 
click the Layout tab, and select Save Template.
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Can I use the schedule feature on the HD110 or HD410?
No. Only network-enabled units that set the time over the network, or the HD810, with a real-
time clock, can use the schedule feature.

Why does BrightAuthor take a long time to process my folder?
If the folder you selected has a large number of images and videos, the files list on the Playlist tab 
may take a couple minutes to update. Please be patient.

Why can’t BrightAuthor locate my files when I try to publish my presentation?
If you copy a presentation project from one computer to another computer, or if you move or 
rename files used in a BrightAuthor presentation, BrightAuthor cannot locate your files and you 
get an error when you try to publish. To resolve the error, you must remove the files from each 
playlist in your presentation, and then add them again.

Why are some of my videos missing thumbnails in the Files tab?
The thumbnails are generated by codecs installed on your computer. If you don't see thumbnails 
for your transport streams, for example, you can try downloading a codec such as K-Lite.

What do I do if BrightAuthor crashes while I'm using it?
For any errors or crashes you encounter with BrightAuthor, post a description of the problem in 
the forums and be sure to include the following information:

• Steps to duplicate the problem (or indicate that you can't duplicate it)
• Any error dialogs you saw, and any text from the error dialog
• The contents of your event log right after the crash. You can find the log in this folder: 

C:\Users\Owner\AppData\Local\BrightSign\BrightAuthor\. Look for a subfolder named after 
the BrightAuthor version number, such as 1.0.1.6

• A copy of the presentation project where you experience this problem
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 Appendix A

• • • • • •
 Remote Control Protocols

Follow these steps to set up your BrightSign to communicate with a remote control:

a Create an interactive presentation (see Making a presentation interactive).
b Select Remote Input as the input device.
c Enter any of the following remote control codes:

remoteCommands[0]="WEST"
remoteCommands[1]="EAST"
remoteCommands[2]="NORTH"
remoteCommands[3]="SOUTH"
remoteCommands[4]="SEL"
remoteCommands[5]="EXIT"
remoteCommands[6]="PWR"
remoteCommands[7]="MENU"
remoteCommands[8]="SEARCH"
remoteCommands[9]="PLAY"
remoteCommands[10]="FF"
remoteCommands[11]="RW"
remoteCommands[12]="PAUSE"
remoteCommands[13]="ADD"
remoteCommands[14]="SHUFFLE"
remoteCommands[15]="REPEAT"
remoteCommands[16]="VOLUP"
remoteCommands[17]="VOLDWN"
remoteCommands[18]="BRIGHT"
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