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 Enter a new visit card in the archive 

 Delete current visit card from the archive 

 Edit the current visit card 

Test Card 

It contains all the information about the test. 

To move within the database use the following buttons: 

 Delete current test from the archive. 

 Edit the current test 

Import/export a Tests card 
This function allows to import /export a test card with the respective visit and patient 
card. 

1. Select the patient. 

2. Choose the test and press the key by side. All data will be imported/exported in the 
XPO file format (Cosmed proprietary). 

Diagnosis Database 
The program allows to manage a diagnosis database, whose records are composed by a 
diagnosis ID code and a string of text. 

The report of the visits can be done either by typing the desired text in the field 
“Diagnosis” of the Visit Card or, more quickly, retrieving from the diagnosis database 
the desired one. 

If you want to insert, modify or delete a diagnosis from the database select Database 
Diagnosis... from the File menu. 
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Spirometry program settings 

The software allows to configure some options selecting Configure from the Option  
menu. 

 

Graphs 

All the graphs visualised and/or printed can be customised in colours and appearance. 

1. Select the desired colours of the curves (5 curves max can be overlapped on the 
same graph). 

2. Enable or disable the Grid option. 

3. Enable or disable the Show Info Test option. 

Serial port 

You must select the serial port RS 232 that will be used to connect the Quark b2 with the 
PC. 

To select the serial port, click on the proper COM button (the selected port must be 
different from the mouse one). 

Units of measurements 

It is possible to configure the units of measurements, weight and height, for printing and 
viewing. 

To select the units of measurement click on cm/Kg or in/lb according to the desired 
format. 

Using extra fields  

The Patient’s database is organised in 3 different cards (Patient card, Visit Card and 
Test card.) where it is possible to store the information about patients and visits . 

Besides the standard information, it is possible to customise some fields (user free 
fields), entering and labelling measurements coming from other devices. 

The  customisable free fields are: 

• 3 fields in the Patient Card (Patient’s information) 

• 3 fields in the Visit Card (information about the visits) 

• 3 fields (2 numeric) in the Test card  information about Test) 

Customise the fields 

In the group User free fields type the desired text in the 9 fields available. 

 

 

 



 

70 - K4 b2 User Manual 
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Recommendations for the exercise testing 

The evaluation of the cardiorespiratory function 
The physical training requires the interaction of physiological mechanisms that allow 
the cardiovascular and respiratory systems to supply the increasing demand of energy 
due to the contraction of the muscles. 

During the training the systems are both engaged, an adequate answer to the effort is the 
measure of theirs health state. 

The increase of the metabolic rate, during the exercise, needs an appropriate increase of 
oxygen in the muscles. At the same time, the CO2 muscles production must be removed 
in order to avoid the lactic acid making. 

To satisfy the increase in the gas exchange, necessary to the muscles during the 
exercise, is requested the intervention of many physiological mechanisms. This process 
involves lungs, the pulmonary circulation, the heart and the peripheral circulation. 

Precautions 
The physician has the responsibility that the patient subjects to the test is a suitable 
person able to execute an effort test. 

Laboratory 

The room, in which the test is performed, must be big enough to contain the whole 
necessary equipment, allowing an easier accessibility to the patient in case of 
emergency. 

In the room should be placed a thermometer and a hygrometer; the heart frequency and 
the perceived values of the effort rise as much as the ambient temperature increases, and 
the variability of the cardiovascular response grows for humidity values higher of 60%. 
Generally it is considered 22°C the temperature adequate for the test execution, even for 
short efforts, values till 26°C can be considered acceptable in presence of an efficient air 
ventilation. 

Ending the test 

The patient should be monitored with ECG for at least 8 minutes, in resting conditions 
or until he returns to the pre-exercise conditions. 

Preparing the patient 
To enhance the value of a diagnostic test it’s very important patient collaboration. In 
most cases a well-informed patient will make a better effort (in relation to his 
conditions) and will allow a reliable interpretation of the test. For this reason every 
ergometric test must be preceded from a precise training of the patient. 

Before testing 

The physician applying the exam must be provided with a written request including a 
brief description of the diagnosis (confirmed or suspected ), the request’s reason and the 
patient therapy carried out showing the dose and time of the drug assumption. 

To standardise the response to the test and reduce the patient’s anxiety it’s suggested to 
provide him either written (before the exam) or oral (at the same time of the test) 
information. At the scheduling time detailed instructions should be delivered to the 
patient, consisting in smoke and food abstinence three hours before an ergometric test, 
or eight hours before a scintigraphic test. 

Test are usually executed supporting the therapeutic outline in progress, but sometimes 
it could be necessary to stop some drugs, such as b-block or calcium antagonist, which 
could impair the effort response reducing the diagnostic accuracy of the exam. 

The patient must wear comfortable suit and gymnastic shoes and two hours before test 
stop any kind of drugs, eat light and  avoid coffee and smoke. 
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It’s very important acquire information on the patient’s clinical past before performing 
the test. Keep attention in particular way to the use of drugs, tobacco, to the physical 
fitness and symptoms produced with the exercise. 

Patient assent 

The patient is informed that he will be submitted to a maximum effort, which could be 
stopped at any moment, and of the risks of the test execution. 

Ending the test 

Test may end when the maximum value of the oxygen consumption has been reached 
and the patient’s response established. 
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Real time test 

Before starting exercise test type a new patient information or choose one from the list 
of patient in the file. As soon as a patient has been entered the software is ready to start 
a test. The name of the active patient is shown on the status bar of the program window. 

Start a test 

Start the test as described in the chapter Operating modes. If you use the device in 
Holter mode, please skip this until Data management. The following is applicable only 
to tests performed with the PC (telemetry or serial mode). 

The software environment will change showing a new Menu bar and toolbar while the 
first data will be displayed in a table format. 

 
At this point the software starts showing data on the monitor but without saving them, 
this in order to monitor the patient before starting the test. To start storing data press F2. 

Abort the test without saving data 

Choose Abort from the Test menu or press Alt+F3. 

End the test saving data 

1. Choose End from the Test menu or press F3. 

2. Choose Yes to end the test or No to continue. 

View data in real-time 
The visualisation features and capabilities of the data and graphs are identical to the 
ones described in the Data management chapter. Starting the test a small window will 
appear on the right corner displaying  time, bmp and, if selected before, the ergo 
protocol and trainer. 

 

View graphs in real-time 

1. Choose Graph from the View menu. 

2. Follow the instructions described in data management section to edit  the graphs. 

Parameters to view 
While the test is running, it is possible to choose the parameters to view. 

1. Select Parameters to view/Test execution… from the Options menu. 

2. Select the parameters and confirm. 
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Manual protocol 
If you are using the K4 b2 with a treadmill without serial interface, it is possible to enter 
manually from the PC the event, the phase and the marker. 

Enter Load and Phase 

1. During the test select Load from the Events menu. 

2. Select the phase and/or type the value of the load and press OK to confirm. 

Set the markers 

Select Marker from the Events menu. 

Automatic protocol 
The software allows to automatically control  the ergometer according to the protocol 
previously selected. Anyway it is allowed to change it even after the test is started. 

Modify the load during the test 

1. During the test choose Ergometric protocol from the Events menu. 

2. Select the row corresponding to the desired load and press OK to confirm. 

Set the BPM alarm 
The software allows the user to set the alarm level for the heart rate, in order to monitor 
the patient response. 

Enter the BPM 

1. Choose BPM alarm from the Events menu. 

2. Set the alarm by moving the scroll bar and press OK to confirm. 

It also allows to enable or disable the acoustic alarm by the option "Acoustic alarm". 

sss 
Tip: pressing the Shift key 
while choosing  the marker 
option will allow  you to enter 
the label for that marker. 
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Data management 

As soon as the test has been completed or downloaded, all data stored can be retrieved 
for a complete management. 

Viewing data 
Data can be viewed in the following formats: 

Table form numeric values of the various parameters (columns) corresponding to 
each step (rows). 

Graphic form graphical presentation on Y1, Y2, X charts. 

Summary results of the test and statistical analysis of the blocks. 

Predicted predicted values, maximum value measured. 

View data in table form 

1. Select Data… from the View menu. 

2. Select the test to visualise in the list box and press OK 

 

Creating graphs 
The software is provided with powerful functions for creating charts. You can add  
custom graphs to create exactly what  you need. 

View data in graph form 

1. Choose Graph… from the View menu. 

2. Select the tests to visualise from the list and press OK 

3. Choose the parameters you require on the X, Y1 and eventually for Y2; select if 
necessary some of the following options by pressing the more button and press OK 
to confirm. 

It is possible to access quickly 5 common graphs from the View/Graph… dialog box. 

sss 
Note: Double-click in the 
window to open the edit test.
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Right-clicking, the graph can be exported in bmp file format. 

Customise the graphs 

1. With a graph on the screen, choose Customise graph from the View menu. 

2. On the Customise graph dialog box, select options to obtain the wished graph. 

 

Option Function 

Grid on X, Y axes show the grid lines in correspondence with x or y axes that 
make the graph easier for you to analyse data. 

Autoscale maximum and minimum values of the graph will be measured 
automatically. 

Ignore 0 points with 0 value measured won't be shown. 

Not interpolated make the graph scattered. 

Marker highlight with a symbol all steps of the test in which the marker 
button was pressed. 

Squared makes the graph a square 

Without recovery exclude from the graph all points of the recovery phase. 

Mark points marks each point with a symbol 

Min. Max. allows to set manually the axes values. 

Step Set the axes' scale step. 

Switch from graph to data and vice versa 

When the active window is a graph (or a report in data form), it is possible  to view very 
quickly  the data (or the graph) corresponding to that test. 

Choose Current test data (if the active window is a graph) or Current test graph… 
(if the active window is a data report) from the View menu. 

sss 
Note: Double-click in the graph 
window to open the edit test 



 

78 - K4 b2 User Manual 

Viewing predicted values 
For some parameter it is possible to compare the maximum value measured during the 
test with its predicted value and the LT value both in percentage and absolute. 

View predicted values 

Choose Predicted from the View menu. 

 

Anaerobic (Lactate) Threshold detection 
The software allows to detect the Lactate Threshold (Anaerobic Threshold) according to 
the "Modified V-slope method" reference. The LT can be detected both manually and 
automatically. 

View the Lactate Threshold 

Choose Lactate Threshold from the View menu. 

Detect the Lactate Threshold 

1. Choose Calculate LT from the Test menu. 

2. For calculating it automatically on the "Lactate Threshold" dialog box click on the 
Auto detect button. 

3. For adjusting manually the point you want to detect, move the scroll bar on the 
dialog box by pressing the arrow buttons. Data and graph of the LT will be 
automatically redrawn. 

4. Press Ok button to save your choices. 

 

Customise graphs for the LT viewing 

The software allows to customise two of the three graphs for the LT visualisation. 

1. Choose Lactate Threshold from the Options menu. 

2. Choose the parameters you want to be shown on the LT window and press OK to 
confirm your choices. 

sss 
Note: Double-click in the 
window to open the 
corresponding dialog box. 
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Fittings 
The purpose of the fitting function is to find the function that fits as better as possible 
the measured data. 

The software allows to fit data according to 3 different functions: 

Model Function Algorithm Available for 

Linear Y=A*X+B Least squares Any Y vs any X graph 
 

Mono-Exp Y=A+B*exp[(t-t0)/tau] Levemberg Marquardt Any Y vs Time Graph 
 

Mean value 
This function is available only if the active window is a single Y graph (i.e. VO2 vs time 
or VO2 vs Load). 

 

Fit a graph with a linear regression 

1. Make active the graph window (any Y vs any X graph). 

2. Right-click and select Fitting. 

3. Choose Linear in the type combo box 

4. Select the first point (X1) moving the mouse on the desired place in the graph 
pressing the Left key or using the + and – keys. 

5. Select the second point (X2) moving the mouse on the desired place in the graph 
pressing the Right key or using the + and – keys. 

6. Press OK to confirm. 

Fit a graph with a Mono-exponential regression 

 
1. Make active the graph window (any Y vs any X graph). 

2. Right-click and select Fitting. 

3. Choose Mono-exponential in the type combo box 

4. Select the first point (X1) moving the mouse on the desired place in the graph 
pressing the Left key or using the + and – keys. 

5. Select the second point (X2) moving the mouse on the desired place in the graph 
pressing the Right key or using the + and – keys. 

6. Enter (if necessary) the initial values of A, B and TAU (these are the values from 
which the iterative algorithm starts in order to reach the best values; the closer are 
the initial coefficients to the best ones the higher is the possibility to reach the best 
fit). 

7. Press OK to confirm. 
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Calculate the "Mean Value" 

1. Make active the graph window (any Y vs any X graph). 

2. Right-click and select Fitting. 

3. Choose Mean value in the type combo box 

4. Select the first point (X1) moving the mouse on the desired place in the graph 
pressing the Left key or using the + and – keys. 

5. Select the second point (X2) moving the mouse on the desired place in the graph 
pressing the Right key or using the + and – keys. 

6. Press OK to confirm. 

Note: The results of the O2 Fittings function are not stored therefore, in order to keep 
the information, print the page using File/print Active Window. 

Oxygen Kinetic 
This function is available only if the active window is a VO2 vs time graph and it has a 
sense only with Constant Load Exercise Tests. 

The aim of this function is to find the dynamic response of the rising and falling edges 
of the VO2 together with the Oxygen Deficit  and Oxygen Debt. 

 

Run the O2 Kinetic function 

1. Make active a VO2 vs Time graph window. 

2. Press the right key of the mouse and select O2 Kinetic. 

3. Select the beginning of the exercise phase (t1) moving the mouse on the desired 
place in the graph pressing the Left key or using the + and - keys. 

4. Select the beginning of the exercise phase (t2) moving the mouse on the desired 
place in the graph pressing the Right key or using the + and - keys. 

5. Enter (if necessary) the initial values for A, B and Tau (these are the values from 
which the iterative algorithm starts in order to reach the best values; the closer are 
the initial coefficients to the best ones the higher is the possibility to reach the best 
fit) and press OK. You can lock data checking the relative field 
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Information about the Test 
The Test Information dialog box shows all the information concerning environmental 
data, patient data and some data about the test 

View the Information 

Choose Information from the View menu. 

 

Modify the information 

1. Press the Modify button on the Information dialog box. 

2. Change the values you want to modify and press OK to confirm. 

The software allows to assess the energy expenditure and metabolism substratum. In 
order to measure FAT and CHO, type the UN (Ureic Nitrogen) value into the field. All 
the nutritional parameter will be recalculate considering the UN value. 

Summary 
The summary feature allows to summarise test results according to the workload  and 
phase during the test. 

View the summary 

1. Choose Summary from the View menu. 

2. The summary of the current test (active window) will be displayed. 

 

Print the data 
It is possible to print graphs and data by means of two functions: Print report and 
Print current window. The last one is active only if the active window is a graph or a 
data report. 

sss 
Tip: double-clicking on the 
Summary window the 
function Options/Summary 
is activated by which you 
may configure the structure 
of the data. 
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Print the current window 

1. Be sure that the current active window is the graph or the report you desire to print. 

2. Select Print current window from File menu. 

3. Press OK to print, or Setup to customise the print. 

Print the report 

1. Select the report to be printed from File menu. 

2. Press OK to print, or Setup to customise the print. 

3. To only view the report, without printing it, press Shift during the selection. 

View the report 
This function allows to show a preview of a selected report. 

1. Select Report from the View menu. 

2. Select the test and the report to visualise and press OK to confirm. 
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Data Editing 

The software allows the user to edit the data acquired during the test in the following 
ways: 

• deleting one or more steps 

• editing row data  

• input new parameters 

• data filtering (averaging or smoothing) 

• advanced data elaboration 

After data elaboration it is always possible to restore the original data file by pressing 
the Restore button . 

If you want to save permanently all the changes, press Overwrite; being aware this 
function replaces the original test definitely. 

Editing values and input numerical values 

1. Choose Edit test from the Test menu. 

2. Select the cell containing the value you want to replace with others values and press 
OK to confirm the editing. 

The software will recompute all the parameters. Both the tables and the graphs will be 
automatically updated. 

 

Data filtering 

 
1. Choose Edit test from the Test menu. 

2. Press the button Filtering and choose the option Discard invalid steps to 
automatically eliminate all the invalid steps 

3. Press the button Filtering and choose the option Averaging and type the desired 
value for points Ave/smooth to perform an averaging of the all acquired steps. This 
feature reduces the size of the original test. 

4. Press the button Filtering, select the option Smoothing and type the desired value 
for points. This feature doesn't  reduce the size of the original test, although it 
smoothes the fluctuation of data. 

sss 
Nota: In Data view, double-
click in the window to enter 
in “Data Editing”. 
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Using the User fields 

The software is provided with three free fields in which the user may enter values 
coming from others devices such as lactate, blood pressure etc. 

To define the user fields: 

1. Choose User Fields from the Options menu 

2. Type the desired text in the input fields and press OK. 

To enter values in the user fields: 

1. Choose Edit test from the Test menu. 

2. Scroll horizontally until the fields USER 1, 2 and 3. 

3. Enter the desired values and press OK to confirm. 

Deleting steps 

This feature is useful whenever some steps acquired during the test are to be discarded 
(steps acquired before the start of the test, patient disconnected from the face mask....). 

1. Choose Edit tests from the Test menu. 

2. Position the cursor on the step you want to delete and press the button Delete step. 

Advanced Editing 

This feature allows to perform some advanced editing of the data stored in the software. 

1. Choose Edit test from the Test menu. 

2. Press the Advanced button and select from the following options: 

 

Option Function 

Delete steps deletes the steps meeting the selection criteria 

Smoothing applies a moving average to the selected parameter 

Edit parameter edits a parameter according to the selected criteria 

Edit parameter Specifications 

Value replaces the value of the selected parameter with a new one. 

Correction % applies a percentage correction to the value of the selected 
parameter. 

Offset adds an offset to the value of the selected parameter. 

Formula... replaces the value of the selected parameter with a 
mathematical function. 

Time range Specifications 

From, To specifies the time range. 

All steps applies the editing from the beginning to the end of the test. 



 

 Chapter 7 - Exercise Testing - 85 

Apply to Specifications 

Parameter specifies the reference parameter 

>, >=, =, <, <=, <> higher than, higher or equal, equal to, lower than, lower or 
equal, different 

Value/Formula… specifies the value (mathematical expression) compared 
with the value of the specified parameter. 

All steps do not use any selection criteria. 

Restore the original test 

To cancel all the editing, in the "Edit Test" dialog box press the Restore button, confirm 
your choice by pressing yes. 

Overwrite the original test 

To save all the editing, replacing the original test with the modified one, in the "Edit 
Test" dialog box press the Overwrite button, confirm your choice by pressing yes. 

Customise the desktop 

Customise the display colours 

1. Select Colors from Options menu. 

2. Select the item to be modified. 

3. Press Change and select the desired colour. 

Smart edit 
This function is useful to correct data from artefacts; the noise affecting the measured 
data can be reduced in 2 different ways: 

Graphical noise suppression using the mouse 

Threshold noise suppression applying a filter to the measured data 

 

Apply the graphical noise suppression 

1. Make active a graph or a data window corresponding to the test that you want to 
modify. 

2. Press the right key of the mouse and select Smart Edit. 

3. Select the parameter that you want to modify. 

4. Point the mouse on the position where the graph presents the artefacts, click the 
Right key and, keeping pressed the key, drag the point on the desired place. 

5. If you want to cancel the edit press the Left key of the mouse. 

6. Repeat the above mentioned procedure for the all parameters and press OK. 

Apply the threshold noise suppression 

1. Make active a graph or data window corresponding to the test that you want to 
modify. 

2. Press the Right key of the mouse and select Smart Edit. 

3. Select the parameter that you want to modify. 

4. Set a Noise(%) Threshold (as a percentage of the parameter value) above which 
any peak will be considered an artefact. 

5. Press Execute and eventually Undo if you are not satisfied. 

6. Press OK to confirm. 
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Customise the parameters 
The software allows the user to create customised parameters and predicted values, 
derived from the standard parameters (the ones that are calculated by default) through 
any mathematical formula. 

All the customised parameters can be used freely for viewing and printing purposes. 

 

Create a new parameter 

1. Choose Customise parameters  from the Options menu. 

2. Press the New button if you want to create a new parameter or Modify if you want 
to modify an existing one 

3. Type the desired value in the fields "Name", "unit of meas", "integers", "decimals" 
and "summary" (to present the parameter in the summary) and press the Formula 
button. 

4. Insert the mathematical formula by using the appropriate tools and press OK twice 
to confirm. 

Create a new predicted parameter 

1. Choose Customise predicted from the Options menu 

2. Press the New button if you want to create a new parameter or Modify if you 
intend to modify an existing one 

3. Type the desired value in the fields "Name", "unit of meas", "integers", "decimals". 

4. Select the group of the predicted values from the options boxes. 

5. Select the reference parameter in the "Compared to" list box. 

6. Press the buttons in the calculation group and insert the mathematical formulas for 
men and women, adults and paediatrics. Press OK twice to confirm. 

Once you create the new predicted you can see it in the predicted window. 
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Exporting data 
With this function you can export the tests data and parameters in different file formats: 

• *.xpo (Cosmed proprietary file format) 

• *.txt (ASCII) 

• *.xls (Microsoft Excel) 

• *.wk1 (Lotus 123) 

Export a test 

1. Choose Export Tests from the Test menu. 

2. Select the test to export from the list box and press OK to confirm. 

3. Select the file output format from the list box, click on *.xpo, *.txt, *.xls or *. wk1. 
If you selected ASCII format, by clicking on Text button you can then select the 
Thousands sep. and Column sep. according to the program you want to use. With 
the xpo Cosmed format you can import/export the tests performed on another K4 
b2 equipment. 

4. Select the folder, type the file name and press OK to confirm. 

 

DDE with Excel 

If Microsoft Excel is installed on your PC, you can export a test simply pressing a 
button on the toolbar. 

To send a test to Excel, select Send to Excel from the Test menu. 

The program will show a status bar indicating the data transmission to Excel. At the end 
of the process a new sheet with all test data will be opened ready to be edited with the 
powerful functions of Microsoft Excel. 

sss 
Note: The DDE function is 
available only if the user PC 
has Microsoft Excel 
installed. 



 

88 - K4 b2 User Manual 

Creating Test Protocols 

The software allows to create different exercise protocols to use during the test. The 
load of the ergometer is automatically controlled by the software that change it 
according to the defined protocol. 

Create a new protocol 

1. Choose Real Time > Ergom. Tests Protocols from the Options menu. 

2. Press New and enter a name for the protocol. 

3. In the field "Message Time" type a number that means to get a message to advise 
when switching to the next load. 

4. Enable the "Drive Ergometer" check box to let the software control the ergometer. 
Select the "Initial Command" if the ergometer need it. 

5. Enabling the option "Relative Increments", the loads refer to the previous step. 

6. Press Generate and enter the values to generate a protocol from only one load (i.e. 
30 Watt each minute for a total of 20 steps) and press OK to confirm. 

7. Press Add if you want to add a new step. 

8. To edit a step, select it from the list and change the relative values in the Edit boxes 
below the list. Press the Tab button to save changes. 

9. To delete a step, highlight the step and press Delete. 
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Software configuration 

The software can be customised as you wish. Most of the feature are easily editable to 
be tailored according to different purposes. 

Data viewing 
The software allows to calculate a huge number of parameters; it is advisable, in order 
to simplify the analysis of the results, view in the data window the only desired 
parameters. 

Select the parameters to view 

1. Choose Parameters to view/Test visualisation… from the Options menu. 

2. Select the parameters you require to view. 

3. Press OK to confirm the selected configuration. 

Select the parameters to view during the test 

1. Choose Parameters to view/Test execution… from the Options menu. 

2. Select the parameters you require to view. 

3. Press OK to confirm the selected configuration. 

Sort the parameters 

It is possible to sort the parameters (both for viewing and printing purposes) according 
to the desired order. 

1. Select Sorting parameters from the Options menu. 

2. Move the parameters in the order you want by pressing and holding the left mouse 
button. 

3. Press OK to maintain the current configuration. 

Steady State 
The program has an algorithm to tag sets of steps as Steady State. 

The algorithm considers belonging to the Steady State the only consecutive steps that 
meet  the following conditions: 

• The value of VO2, VE and R do not vary from their mean values more than 
Threshold (%); 

• The number of consecutive steps that met the preceding criteria are at least 
Minimum number of steps. 

 

Customise the Steady State detection criteria 

1. Choose Steady State from the Options menu 

2. Type the desired values for Minimum number of steps, VO2 threshold (%), VE 
threshold (%) and R threshold. 

The steps which satisfy these conditions will be highlighted with a yellow bar. 
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Printout reports 

The software allows the user to printout data and graphics according to 4 customisable 
reports. Further it allows the user to customise a printout header that will be printed in 
each page. 

Set up the printout 

1. Choose Reports from the Options menu. 

2. Define the desired features of the report and confirm. Enabling the option "Graphs 
in one page" all the graphs selected in the report will be printed in one page. 

3. Type the name you want apply to the report and press OK to save changes. 

 

Select parameters to be printed 

K4 b2 allows to print a large number of parameters; it is advisable, in order to simplify 
the analysis of the results, to printout desired parameters only. 

1. In the report configuration window select Parameters. 

2. Select the parameters you require to be printed in the data printout. The number of 
parameters which can be printed depends upon the size of the paper in use (see 
Printer Layout) and from the orientation of the sheet. 

3. Press OK to confirm the selected configuration. 

Customise the printout header 

1. Choose Printout header from the Options menu. 

2. On the "Report Header" dialog box type the text of the header. 

3. To insert an image click the Logo button. An image editor will be opened, draw the 
own logo and close the image editor to save changes. 

4. Press OK to save the Printout header. 
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Electronic reports (*.pdf) 

If an Adobe PDF writer “Printer Driver” is installed and set as the default printer, it is 
possible to store the printout report automatically in any location of the HD or 
eventually LAN paths according to a customizable filename format. 

It is possible to define the created filename format selecting Options/Printout 
header..., and then Name format… 

 

Print the current window 
The print current window function is enabled when the active window is a graph or a 
data report. 

1. Select Print current window from File menu. 

2. Press OK to print, or Setup to customise the print. 

Print the customised report 
This function is enabled only after having customised a report. 

1. Select the customised report from File menu. 

3. Set the sheet format and press OK.  
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Events management during exercise testing 

By using K4 b2 in serial mode, beside standard measurements, the software allows also 
to save some extra "events". They are so called "events" since they are not continuously 
stored during the test but they can be saved upon user selection. 

Flow Volume loops 
This test is useful during exercise to detect abnormalities in the mechanics of ventilation 
in patients with pulmonary/ventilatory limitations to exercise. 

The test consists in acquiring some flow/volume loops during exercise at different 
workloads and overlapping them on the rest maximal flow/volume loop of a Forced 
Vital Capacity test. 

The majors information that you can get from this manoeuvres are the flow reserve 
(flow distance from the peak flow of the F/V loop during exercise to the corresponding 
flow on the superimposed F/V loop at rest) and the volume reserve (volume distance 
from the maximum volume of the F/V loop during exercise to the corresponding 
volume on the superimposed F/V loop at rest). 

The manoeuvre consists in the following phases: 

• Acquiring some Flow/Volume loops during the exercise 

• Making the patient inspire completely up to TLC level (this is necessary to place 
the loop correctly into the rest F\V loop of the forced Vital Capacity test) 

• Overlapping the F/V loop acquired during exercise and the F/V loop performed at 
rest. 

Flow Volume loop during the test 

1. Start with normal Exercise test and begin the memorisation of breath values (F2) 

2. During a steady state select F/V loops form Test/Event... 

3. As soon as 2 or 3 complete loops have been acquired ask the patient to inspire 
completely up to TLC level and press F3 to stop the acquisition. 

O2, CO2 vs Time 
The O2, CO2 event is useful to check the real-time readings of the O2 and CO2 signals 
during the test. 

O2, CO2 vs Time during the test 

1. Start with normal Exercise test and begin the memorisation of breath values (F2) 

2. During a steady state select O2, CO2 vs Time from Test/Event... 

3. As soon as 5 or 6 complete breaths have been acquired press F3 to stop the 
acquisition. 
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O2 Saturation (optional) 
The O2 Saturation event is useful to check the quality of SpO2 signal acquired by the on-
board Oxymeter (if available) during the test. 

O2 Saturation during the test 

1. Start with normal Exercise test and begin the memorisation of breath values (F2). 

2. Select O2 Saturation from Test/Event... 

3. As soon as 5 or 6 complete pulses have been acquired press F3 to stop the 
acquisition. 

Spirogram 
The spirogram event allows to display and store the volume/time plot. 

 

Spirogram during the test 

1. Start with normal Exercise test and begin the memorisation of breath values (F2). 

2. During a steady state select Spirogram  form Test/Event... 

3. Acquire volume/time  plot until the window is filled and press F3 to stop the 
acquisition. 

View the events after the test 
1. Select Data... from the View menu 

2. Select the test during which spirogram event has been carried out in the list box and 
press OK 

3. Select View... from the Events menu, choose the desired  event  and press OK. 

4. Select Print Current Window... from the File menu to print the F/V curve page. 

It is possible to edit the F/V loops event in the following way: 

5. Select Edit... from the Event menu to change the F/V loop at rest (the list contains 
all the FVC test carried out by the same Patient with the Spirometry software) and 
press OK. 

It is possible to edit the Cardiac Output event in the following way: 

5. Select Edit... from the Event menu to change the parameters measured during the 
steady state before the rebreathing, the CO2 concentration at the equilibrium and the 
calculation method. 

Raw data 
It's a particular feature with which the user can check and save some parameters (CO2 
output, O2 concentration and volumes) in Ascii file format in a archive apart at a 
sampling rate of 25 Hz. 
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Save Raw data 

1. During the test choose Event from Events menu. 

2. Select Raw Data from the list. 

3. On the save data box give a name to the file and select the destination folder. 

4. To stop saving Raw data press the stop icon or press F3 on the keyboard. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 




