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Managing ITP Networks Using SGM

This chapter provides details on using SGM to discover and manage your ITP 
networks. It includes the following sections:

• Becoming the Root User (Solaris Only), page 3-2

• Configuring SNMP, page 3-2

• Discovering the Network, page 3-6

• Configuring Seed Files, page 3-20

• Working with Views, page 3-26

• Working with Linksets, page 3-37

• Working with Nodes, page 3-91

• Working with Signaling Points, page 3-136

• Working with Links, page 3-170

• Working with Events, page 3-235

• Viewing the Topology of the Network, page 3-259

• Viewing Server Status Information, page 3-274

• Finding Information in a Window, page 3-278

• Resizing, Sorting, and Hiding Table Columns, page 3-279

• Viewing Online Help, page 3-280

• Editing an ITP Route Table File, page 3-281

• Editing a Global Title Translation Table, page 3-290

• Working with SGM Statistics Reports, page 3-334
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• Printing SGM Windows, page 3-398

• Connecting to a New Server, page 3-399

• Integrating SGM with Other Products, page 3-401

• Using the Windows Start Menu, page 3-403

Becoming the Root User (Solaris Only)
Some SGM procedures require you to be logged in as the root user.

Caution As the root user, you can adversely affect your operating environment if you are 
unaware of the effects of the commands you use. If you are a relatively 
inexperienced UNIX user, limit your activities as the root user to the tasks 
described in this manual.

If you are not logged in, log in as the root user:

> login: root

> Password: root-password 

If you are already logged in, but not as the root user, use the su command to 
change your login to root:

# su

# Password: root-password

Configuring SNMP
If SGM User-Based Access is disabled, or if it is enabled and you are a Network 
Administrator or System Administrator, SGM enables you to view and change 
some SNMP settings. (For more information about user authorization levels in 
SGM, see the “Configuring SGM User Authentication Levels (Solaris Only)” 
section on page 4-6.)
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Note If you want to change SNMP settings, do so before running Discovery.

To change SNMP settings in SGM:

Step 1 Start the SGM client, as described in the “Starting SGM” section on page 2-2.

Step 2 Select Edit > SNMP Configuration from the SGM Main Menu. (If you have 
implemented SGM User-Based Access, this option is available to users with 
authentication level Network Administrator [Level 4] and higher.) SGM displays 
the SNMP Configuration Dialog (Figure 3-1).

Figure 3-1 SNMP Configuration Dialog

The SNMP settings table displays SNMP information for nodes in SGM.

Step 3 (Optional) To delete a node, select it and click Delete.
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Step 4 (Optional) To change the IP address or DNS name of a node, select the node and 
enter the new address or name in the IP Address Range or Hostname field.

• IP addresses use the format x.x.x.x, where each x has one of the following 
values:

– An integer in the range 0 through 255.

– A range of integers separated by a dash (-), such as 10-60.

– An asterisk (*), which is equivalent to specifying 0-255.

• Unlike IP addresses, you cannot specify a range of node names or use 
wildcards in node names. Each node name corresponds to a single node in the 
network.

The default value for this field is the IP address *.*.*.*, which SGM uses for all 
nodes not covered by other IP address ranges or names.

Click Update to apply the new IP address to the selected node.

Step 5 (Optional) Nodes use SNMP community names for read access to the information 
maintained by the SNMP agent on the ITP. To change the SNMP community name 
for a node, select the node and enter the new name in the Read Community field. 
This name must match the name used by the node. The default name is public.

Click Update to apply the new SNMP community name to the selected node.

For information about exporting SNMP community names from CiscoWorks2000 
Resource Manager Essentials (RME), see the “Importing SNMP Community 
Names from CiscoWorks2000 (Solaris Only)” section on page 5-2.

Step 6 (Optional) If you determine that SGM waits too long for a response from a node, 
or does not wait long enough, you can change the timeout value. To change the 
time, in seconds, that SGM waits for a response from a node, select the node and 
enter the new timeout value in the Timeout (secs) field. The valid range is 1 to 60 
seconds. The default value is 1 second.

Click Update to apply the new timeout to the selected node.

Step 7 (Optional) If you determine that SGM retries a node too many times, or not 
enough times, you can change the number of retries. To change the number of 
times SGM attempts to connect to a node, select the node and enter the new 
number in the Retries field. The valid range is 0 to 99. The default value is 
2 retries.

Click Update to apply the new retries value to the selected node.
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Step 8 (Optional) If you determine that SGM polls a node too often, or not often enough, 
you can change the poll interval. To change the time, in minutes, between polls 
for a node, select the node and enter the new interval in the Poll Interval (mins) 
field. The valid range is 5 to 1440. The default value is 15 minutes.

Click Update to apply the new poll interval to the selected node.

Step 9 (Optional) To add a new node or range of nodes, enter the SNMP information in 
the appropriate fields and click Add. The new SNMP settings are added to the 
SGM database.

When you are satisfied with all of your changes to the SNMP settings, select the 
File > Save menu option. SGM saves the changes, updates the SNMP information 
on the SGM server in real time, and closes the SNMP Configuration Dialog.

Note If another user modifies and saves the SNMP configuration before you 
save your changes, SGM asks if you want to overwrite that user’s 
changes. If you choose to do so, the other user’s changes are overwritten 
and lost. If you choose not to do so, your changes are lost.

For more information about SNMP, refer to “Configuring SNMP Support” in the 
Cisco IOS Release 12.2 Configuration Fundamentals Configuration Guide, 
Part 3, Cisco IOS System Management.

SGM also provides the following SNMP-related commands:

• To set a new default SNMP read community name, use the sgm snmpcomm 
command.

• To change the file used for SNMP parameters, such as community names, 
timeouts, and retries, use the sgm snmpconf command.

• To query a host using SNMP GetRequests, use the sgm snmpget command.

• To query a host using SNMP GetNextRequests, use the sgm snmpnext 
command.

• To query a host, using SNMP GetNextRequests to “walk” through the MIB, 
use the sgm snmpwalk command.

For more information on the use of these commands, see the “SGM Commands 
and Descriptions” section on page B-2.
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Discovering the Network
SGM uses a Discovery process to populate the SGM database, discovering the 
nodes, signaling points, linksets, and links in your network.

You can run Discovery if SGM User-Based Access is disabled, or if it is enabled 
and you are a Network Administrator or System Administrator. (For more 
information about user authorization levels in SGM, see the “Configuring SGM 
User Authentication Levels (Solaris Only)” section on page 4-6.)

Related Topics:

• Backing Up or Restoring SGM Files (Solaris Only), page 5-47

• Configuring Seed Files, page 3-20

• Investigating Data Problems, page 6-2

• Verifying Discovery, page 6-1
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To discover the network in SGM:

Step 1 Start the SGM client, as described in the “Starting SGM” section on page 2-2.

Step 2 Select Edit > Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Figure 3-2 Discovery Dialog

If you start the SGM client and the SGM database is empty (including the very 
first time you start the SGM client), SGM automatically opens the Discovery 
Dialog so you can run Discovery and populate the database.

Step 3 Select the Seed Settings tab, if it is not already selected. SGM displays the Seed 
Settings panel, which enables you to create, save, load, and delete SGM seed files. 
Seed files are lists of seed nodes, which SGM uses to discover the nodes, signaling 
points, linksets, and links in your network.
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Step 4 Load one or more seed nodes, using one of the following procedures:

• Enter the name or IP address of a seed node in the IP Address or DNS 
Hostname field, and click Add Node.

SGM displays details of the SNMP settings for the seed nodes in the right 
pane of the window.

Continue adding seed nodes until you are certain that SGM will be able to 
discover the entire network.

• If you have already created and saved a seed file, select File > Load Seeds 
from the Discovery Dialog menu. SGM displays the Load File Dialog: Seed 
File List dialog (Figure 3-3).

Figure 3-3 Load File Dialog: Seed File List Dialog

The Load File Dialog: Seed File List dialog contains the following fields:

– Type—Icon indicating whether the item in the table is a file or a folder.

– Name—Name of the seed file or folder.

– Last Modified—Date and time the seed file or folder was last modified.
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– Size (bytes)—Size of the seed file or folder, in bytes.

– Make this my preferred start option—Specifies whether the selected 
seed file is to be loaded automatically whenever this SGM client is 
started or the Discovery Dialog is opened. By default, this checkbox is 
cleared for all seed files. That is, no seed file is loaded automatically 
when the SGM client is started or the Discovery Dialog is opened.

– Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To load a seed file, select the seed file in the list and click OK.

SGM closes the Load File Dialog: Seed File List dialog, loads the seed file, 
and returns to the Discovery Dialog. SGM lists all of the seed nodes in the 
seed file in the left pane of the window, and displays details of the SNMP 
settings for the seed nodes in the right pane.

To close the Load File Dialog: Seed File List dialog without loading a seed 
file, click Cancel.

Step 5 Select the Discovery tab, or click Next. SGM displays the Discovery panel 
(Figure 3-4), which enables you to discover the nodes, signaling points, linksets, 
and links in your network. (If you enter a seed node IP address or name in the IP 
Address or DNS Hostname field, then click Next, SGM automatically adds the 
seed node before displaying the Discovery panel.) 
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Figure 3-4 Discovery Panel

Step 6 (Optional) Specify the extent of the network discovery.

• To discover the entire network, select the Entire Network checkbox. This is 
called recursive discovery, and it is the default setting. Select this checkbox 
when you run Discovery for the very first time.

With this checkbox selected, SGM discovers all seed nodes and attempts to 
manage them; then attempts to discover and manage all ITP nodes that are 
adjacent to those seed nodes (unless the nodes are connected by serial links 
only); then attempts to discover and manage all ITP nodes that are adjacent 
to those nodes; and so on, until SGM has discovered the entire network.

• To rediscover only seed nodes, clear the Entire Network checkbox. This is 
called nonrecursive discovery.

With this checkbox cleared, SGM discovers all seed nodes and attempts to 
manage them, then labels all nodes that are adjacent to those seed nodes 
Unmanaged.
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If you run Discovery with Entire Network cleared, then you run Discovery with 
Entire Network selected, any Unmanaged nodes in the first Discovery are not 
rediscovered by the second Discovery.

To recover from this situation and generate a new, complete, and reliable SGM 
database, you must perform one of the following procedures:

a. Run Discovery again, with both Entire Network and Delete Existing Data 
selected.

b. Change the Unmanaged nodes to managed status. See the “Unmanaging and 
Managing a Node” section on page 3-133 for more information.

c. Poll the nodes that were Unmanaged in the first Discovery. See the “Polling 
a Node” section on page 3-134 for more information.

Step 7 (Optional) Specify whether SGM is to keep or delete the existing database when 
discovering the network:

• To keep all existing network data in the SGM database before rediscovering 
the network, clear the Delete Existing Data checkbox. This is the default 
setting. Clear this checkbox when you run Discovery for the very first time.

• To delete all existing network data from the SGM database before 
rediscovering the network, select the Delete Existing Data checkbox. 
Choose this option if you know that network elements have been deleted from 
your network since the last Discovery.

Note If you discover the network with Delete Existing Data selected, SGM 
stops any real-time polls that are running and issues appropriate 
messages.
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Step 8 Click Discover Network to begin Discovery.

When Discovery begins:

• The Discover Network button is grayed-out.

• The “Discovery In Progress” message is displayed at the bottom of the 
Discovery Dialog.

• The “Discovery In Progress” message is displayed in the title bar of all SGM 
client windows.

Discovery progresses in bursts. You might see a number of updates, followed by 
a pause, followed by more updates. The information displayed in SGM windows 
is not fully updated until Discovery is complete.

By default, Discovery times out after 600 seconds (10 minutes). To change the 
Discovery timeout, change the value of the DISCOVERY_TIMELIMIT entry in 
the Server.properties file:

• If you installed SGM in the default directory, /opt, then the location of the 
Server.properties file is /opt/CSCOsgm/properties/Server.properties.

• If you installed SGM in a different directory, then the Server.properties file is 
located in that directory.

Because SGM is an asynchronous system, with the SGM server contacting clients 
one at a time, and because clients might run at different speeds, the information 
displayed by SGM clients during Discovery might not always be synchronized.

Step 9 (Optional) To stop the Discovery process at any time, click Stop Discovery. For 
example, if you click Discover Network, then you realize that you loaded a seed 
node that you did not intend to load, you can click Stop Discovery to stop the 
Discovery process.

Note If you stop the Discovery process, the information in the SGM database 
is incomplete and unreliable. To generate a new, complete, and reliable 
SGM database, you must run Discovery again, with Delete Existing 
Data selected.

Step 10 When the “Discovery In Progress” message disappears, Discovery is complete. 
The Discovered Nodes section of the Discovery panel (Figure 3-5) lists all nodes 
that were discovered by SGM. By default, this table is sorted by Status.
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Figure 3-5 Discovery Panel with Discovered Nodes

By default, SGM displays all of the columns in the Discovered Nodes section 
except Internal ID, ITP Uptime, Reboot Reason, and Last Status Change. To 
display these columns, or to hide other columns, see the procedures in the 
“Modifying Node Table Column Settings” section on page 5-16.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.
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The Discovered Nodes section displays the following information for each 
discovered node:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Name—Name or IP address of the discovered node.

• Primary SNMP Address—IP address of the node, used by SNMP to poll the 
node. (There might be other IP addresses on the node that are not the primary 
SNMP address.)

• CLLI Code—COMMON LANGUAGE Location Identification Code for the 
node. A CLLI code is a standardized 11-character identifier that uniquely 
identifies the geographic location of the node. If the node has no CLLI code 
configured, this field is blank.

• Device Type—Device type of the node. Possible values are:

– Cisco2650—Cisco 2650 series router

– Cisco2650XM—Cisco 2650XM series router

– Cisco2651—Cisco 2651 series router

– Cisco2651XM—Cisco 2651XM series router

– Cisco7204—Cisco 7204 series router

– Cisco7204VXR—Cisco 7204VXR series router

– Cisco7206—Cisco 7206 series router

– Cisco7206VXR—Cisco 7206VXR series router

– Cisco7507—Cisco 7507 series router

– Cisco7507mx—Cisco 7507mx series router

– Cisco7507z—Cisco 7507z series router

– Cisco7513—Cisco 7513 series router

– Cisco7513mx—Cisco 7513mx series router

– Cisco7513z—Cisco 7513z series router

– IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

– Unknown—SGM is unable to determine the device type.
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• ITP MIB Level—MIB conformance level used by the ITP, such as ITP MB5.

• ITP Uptime—Time the ITP has been up, in weeks, days, hours, minutes, and 
seconds.

• Reboot Reason—Reason for the last reboot of the ITP.

• Notes—Indicates whether there is a note associated with the node.

• Events—Indicates whether there is a recent event associated with the node.

During Discovery, SGM might flag most nodes with an event icon. If the 
event icons are too distracting, select Edit > Clear All Events from the SGM 
Main Menu to remove them.

• Last Status Change—Date and time that the status of the node last changed.

• Status—Current status of the node. Possible values are:

– Active (green ball)—The node is currently fully functional.

– Discovering (gray ball)—The node is being discovered, and SNMP 
queries have been sent to the device.

– Polling (gray ball)—The node is being polled.

– Unknown (red ball)—The node failed to respond to an SNMP request. 
SGM sets all associated signaling points, linksets, and links to 
Unknown.

– Unmanaged (gray ball)—One of the following situations exists:

– The node is known indirectly by SGM. In other words, SGM knows the 
device exists but there is no known SNMP stack on the device for SGM 
to query.

– An SGM user has set the node to Unmanaged status, to prevent SGM 
from polling the node.

If the associated signaling points are referenced via linksets to other 
signaling points, SGM automatically sets all associated signaling points 
to Unmanaged, and deletes all associated linksets and links, as well as 
all linksets and links that reference the node as an adjacent node.

If the associated signaling points are not referenced to other signaling 
points, SGM automatically deletes the signaling points, all associated 
linksets and links, and all linksets and links that reference the node as an 
adjacent node.
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– Waiting (gray ball)—The node is in the Discovery queue but is not 
currently being discovered.

– Warning (yellow ball)—The node is active, but one or more associated 
signaling points, linksets, or links is in Failed, Unavailable, Unknown, 
or Warning status and is not Ignored.

• Status Reason—Reason for the current status of the node. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.
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If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

The “Viewing Detailed Information for a Link” section on page 3-175 
displays additional information about the causes of link failures.

The “Viewing Detailed Information for a Linkset” section on page 3-42 
displays additional information about the causes of linkset failures.

All discovered nodes are placed in a DEFAULT configuration view, which is 
stored on the SGM server and shared by all SGM clients. Initially, all clients use 
the DEFAULT view. Clients can then create their own views, which are subsets of 
the DEFAULT view, to meet their individual needs. However, the DEFAULT view 
stored on the SGM server cannot be modified by the clients. It is always available, 
for users who need to view the entire network.

All other SGM windows (Node, Signaling Point, Linkset, Topology, and so on) 
are also populated with the newly discovered network data.

Step 11 (Optional) To delete a node or nodes from the Discovery database, select the 
nodes and click Delete Node. SGM deletes the nodes without asking for 
confirmation.

Step 12 (Optional) Examine the Discovered Nodes table to verify that SGM discovered all 
of the nodes in the network. If you suspect that SGM did not discover all of the 
nodes, see the “Verifying Discovery” section on page 6-1 for troubleshooting 
information. You might need to add more seed nodes and run Discovery again.

Step 13 When you are satisfied that SGM discovered all of the nodes in the network, save 
the list of seed nodes in a seed file, using one of the following procedures:

• To save the changes you have made to the seed file without changing the name 
of the file, select File > Save from the Discovery Dialog menu.

• To save the changes you have made to the seed file with a new name, select 
File > Save As from the Discovery Dialog menu. SGM displays the Save File 
Dialog: Seed File List dialog (Figure 3-6).
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Figure 3-6 Save File Dialog: Seed File List Dialog

The Save File Dialog: Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.

• Filename—Name by which you want to save the seed file.

If you create a new seed file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system. However, 
if you include any spaces in the new name, SGM converts those spaces to 
dashes. For example, SGM saves file “a b c” as “a-b-c”.
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• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started or the 
Discovery Dialog is opened. By default, this checkbox is cleared for all seed 
files. That is, no seed file is loaded automatically when the SGM client is 
started or the Discovery Dialog is opened.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To save the seed file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old seed file, select the 
name in the list and click OK.

SGM saves the seed file with the new name, closes the Save File Dialog: Seed File 
List dialog, and returns to the Discovery Dialog.

Note If another user modifies and saves the seed file before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If you 
choose to do so, the other user’s changes are overwritten and lost. If you 
choose not to do so, your changes are lost, unless you save the seed file to 
a different filename.

SGM stores the seed file in the seed file directory on the SGM server:

• If you installed SGM in the default directory, /opt, then the SGM seed file 
directory is /opt/CSCOsgm/seeds.

• If you installed SGM in a different directory, then the SGM seed file directory 
is located in that directory.

To delete a seed file from the seed file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Save File Dialog: Seed File List dialog.

To close the Save File Dialog: Seed File List dialog without saving the seed file 
or saving any changes to the seed file list, click Cancel.
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You can run Discovery multiple times to attempt to discover additional nodes 
based on the IP address defined in the Stream Control Transmission Protocol 
(SCTP) linksets. If you are using a separate management VLAN to manage your 
nodes, but private or unreachable IP addresses for your SCTP connectivity, clear 
the Entire Network checkbox in the Discovery Dialog. Otherwise, Discovery 
attempts to reach those nodes continuously. Instead, enter all nodes to be 
discovered directly into the seed list and do a nonrecursive Discovery.

Configuring Seed Files
SGM enables you to create, save, load, and delete SGM seed files.

This section includes the following information:

• Creating a New Seed File, page 3-20

• Modifying an Existing Seed File, page 3-22

• Creating and Modifying Seed Files Using a Text Editor, page 3-24

Related Topics:

• Discovering the Network, page 3-6

Creating a New Seed File
To create a new seed file in SGM:

Step 1 Select Edit > Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Seed Settings tab, if it is not already selected. SGM displays the Seed 
Settings panel.

Step 3 Enter the name or IP address of a seed node in the IP Address or DNS Hostname 
field, and click Add Node. SGM displays details of the SNMP settings for the 
seed node in the right pane of the window.

Continue to add as many seed nodes as necessary.
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Step 4 When you are ready to save the list of seed nodes in a new seed file, select File > 
Save As from the Discovery Dialog menu. SGM displays the Save File Dialog: 
Seed File List dialog (Figure 3-6).

The Save File Dialog: Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.

• Filename—Name by which you want to save the seed file. You can use any 
letters, numbers, or characters in the name that are allowed by your operating 
system. However, if you include any spaces in the new name, SGM converts 
those spaces to dashes. For example, SGM saves file “a b c” as “a-b-c”.

• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started or the 
Discovery Dialog is opened. By default, this checkbox is cleared for all seed 
files. That is, no seed file is loaded automatically when the SGM client is 
started or the Discovery Dialog is opened.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

Enter the new name and click OK. SGM saves the seed file with the new name, 
closes the Save File Dialog: Seed File List dialog, and returns to the Discovery 
Dialog.

SGM stores the new seed file in the seed file directory on the SGM server:

• If you installed SGM in the default directory, /opt, then the SGM seed file 
directory is /opt/CSCOsgm/seeds.

• If you installed SGM in a different directory, then the SGM seed file directory 
is located in that directory.
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Modifying an Existing Seed File
To modify an existing seed file in SGM:

Step 1 Select Edit > Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Seed Settings tab, if it is not already selected. SGM displays the Seed 
Settings panel.

Step 3 Select File > Load Seeds from the Discovery Dialog menu. SGM displays the 
Load File Dialog: Seed File List dialog (Figure 3-3).

The Load File Dialog: Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.

• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started or the 
Discovery Dialog is opened. By default, this checkbox is cleared for all seed 
files. That is, no seed file is loaded automatically when the SGM client is 
started or the Discovery Dialog is opened.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To load a seed file, select the seed file in the list and click OK.

SGM closes the Load File Dialog: Seed File List dialog, loads the seed file, and 
returns to the Discovery Dialog. SGM lists all of the seed nodes in the seed file in 
the left pane of the window, and displays details of the SNMP settings for the seed 
nodes in the right pane.

To close the Load File Dialog: Seed File List dialog without loading a seed file, 
click Cancel.

Step 4 (Optional) To add another seed node to the seed file, enter the name or IP address 
of the seed node in the IP Address or DNS Hostname field, and click Add Node.

Step 5 (Optional) To delete a seed node from the seed file, select the seed node and click 
Delete Node.
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Step 6 When you are ready to save the modified seed file, use one of the following 
procedures:

• To save the changes you have made to the seed file without changing the name 
of the file, select File > Save from the Discovery Dialog menu.

• To save the changes you have made to the seed file with a new name, select 
File > Save As from the Discovery Dialog menu. SGM displays the Save File 
Dialog: Seed File List dialog (Figure 3-6).

The Save File Dialog: Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.

• Filename—Name by which you want to save the seed file.

If you create a new seed file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system. However, 
if you include any spaces in the new name, SGM converts those spaces to 
dashes. For example, SGM saves file “a b c” as “a-b-c”.

• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started or the 
Discovery Dialog is opened. By default, this checkbox is cleared for all seed 
files. That is, no seed file is loaded automatically when the SGM client is 
started or the Discovery Dialog is opened.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To save the seed file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old seed file, select the 
name in the list and click OK.

SGM saves the seed file with the new name, closes the Save File Dialog: Seed File 
List dialog, and returns to the Discovery Dialog.
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Note If another user modifies and saves the seed file before you save your changes, 
SGM asks if you want to overwrite that user’s changes. If you choose to do so, the 
other user’s changes are overwritten and lost. If you choose not to do so, your 
changes are lost, unless you save the seed file to a different filename.

SGM stores the seed file in the seed file directory on the SGM server:

• If you installed SGM in the default directory, /opt, then the SGM seed file 
directory is /opt/CSCOsgm/seeds.

• If you installed SGM in a different directory, then the SGM seed file directory 
is located in that directory.

To delete a seed file from the seed file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: Seed File List dialog.

To close the Save File Dialog: Seed File List dialog without saving the seed file 
or saving any changes to the seed file list, click Cancel.

Creating and Modifying Seed Files Using a Text Editor
A seed file is simply an unformatted list of seed node names. To create a seed file 
using a text editor, simply create a file and list the seed node names, one on each 
line, with no other formatting:

new-york-a

new-york-b

chicago-c
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When you save and name the seed file, keep the following considerations in mind:

• You can use any letters, numbers, or characters in the name that are allowed 
by your operating system.

• SGM saves the seed file with a .see file extension.

• SGM saves the seed file in the SGM server’s seed file directory, seeds:

– If you installed SGM in the default directory, /opt, then the seed file 
directory is /opt/CSCOsgm/seeds/.

– If you installed SGM in a different directory, then the seed file directory 
is located in that directory.

When SGM loads the seed file, it verifies the syntax of the file, deleting blank 
lines and extraneous leading and trailing spaces as needed. SGM also verifies that 
each seed node name resolves to a valid IP address. If a name does not resolve to 
a valid IP address, SGM logs the erroneous entry and ignores it.

For example, given the following seed file:

new-york-a<space>

<space>new-york-b

zzzzzzzzzzzz

<blank line>

<tab>chicago-c<tab>

SGM loads the following entries:

new-york-a

new-york-b

chicago-c
3-25
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Views
Working with Views
When SGM discovers your network, all discovered nodes, signaling points, 
linksets, and links are placed in a DEFAULT configuration view, which is stored 
on the SGM server and shared by all SGM clients. The DEFAULT view cannot be 
modified by the clients. It is always available, for users who need to view the 
entire network.

Initially, all clients use the DEFAULT view. However, SGM enables you to create 
your own, client-specific views, which are subsets of the DEFAULT view, to meet 
your individual needs.

You can choose the nodes you are interested in managing, remove all other nodes 
from your view, and modify the layout of the topology map in the Topology 
window. You can save all of this customized information in a view, set that view 
as the default view for the SGM client, and use the SGM client from then on to 
manage only the part of the network you are interested in, with the settings you 
prefer.

You can also create many different views on a given SGM client, with each view 
devoted to a different aspect of the network. You can then switch between views 
to manage different parts of the network, or switch to the DEFAULT view to see 
the entire network.

If a given SGM client is used by more than one person, each user can create his 
or her own personal view.

To help you keep track of which view you are currently using, most SGM 
windows display the following information:

• In the title bar, the name of the system on which the SGM server is running.

• In the bottom right corner:

– The name of the current view.

– The text (New Nodes Exist), if there is at least one newly discovered 
node or signaling point in the network that has not been added to your 
current view. To add the node to your current view, see the “Viewing the 
Topology of the Network” section on page 3-259. To exclude the node 
from your current view, see Step 6 in this section.

– The text (Modified), if the view has been modified but not yet saved. You 
must save the view if you want to save your changes. See Step 10 in this 
section for more details.
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If your personal default view has been deleted, then the next time you launch the 
client SGM informs you that your default view has been deleted and that your 
view has been reset to the DEFAULT view. To choose another view as your default 
view, use the Load File Dialog: View List. See the “Loading a Client-Specific 
View” section on page 3-35 for details.

This section includes the following information:

• Creating a View, page 3-27

• Loading the DEFAULT View, page 3-35

• Loading a Client-Specific View, page 3-35

Related Topics:

• Discovering the Network, page 3-6

• Modifying Preference Settings, page 5-3

• Modifying the Message Display, page 5-20

• Viewing the Topology of the Network, page 3-259

Creating a View
To create a client-specific network view:

Step 1 Before creating a client-specific network view, make sure that Discovery has been 
run at least once, and there is data in the server’s SGM database. See the 
“Discovering the Network” section on page 3-6 for details.

Step 2 Select Edit > Network Views from the SGM Main Menu. SGM displays the 
Network View Editor window (Figure 3-7).
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Figure 3-7 Network View Editor Window

The Nodes panel and Signaling Points panel display:

• New nodes and signaling points that have been found by SGM.

• All nodes and signaling points that are in the current view.

• All nodes and signaling points that have been excluded from the current view.

The Nodes panel and Signaling Points panel also enable you to move nodes and 
signaling points into and out of the current view. All changes made in these panels 
are reflected in topology tables and maps as soon as you make the changes.

To display the Nodes panel, select the Nodes tab.

To display the Signaling Points panel, select the Signaling Points tab.

Step 3 (Optional) If you have already saved a view and you want to modify it, select the 
File > Load menu option. SGM prompts you for the name of the view you want 
to load. Enter the name of the view, or accept the default view name, then click 
OK to load the view.
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Step 4 (Optional) The Nodes In Current View table lists the nodes that are in the current 
view. If there are nodes listed in the Nodes In Current View table that you do not 
want to manage, you can remove them from the current view. To do so, select one 
or more nodes in the Nodes In Current View table, then click the right-arrow 
button to move the nodes to the Nodes Excluded from View table.

Note If you are using an SGM client with the DEFAULT view set, SGM 
automatically adds all newly discovered nodes to the Nodes In Current 
View table as soon as they are discovered.

If you delete a node, SGM removes it from the Nodes In Current View 
table. If SGM then discovers the node, SGM places it in the New Nodes 
Found table. To see this node again in your current view, you must move 
it into the Nodes In Current View table.

At times, you might want to make an existing node a new node. To do so, select 
one or more nodes in the Nodes In Current View table, then click the left-arrow 
button to move the nodes to the New Nodes Found table.

Step 5 (Optional) The Nodes Excluded from View table lists the nodes that have been 
excluded from the current view. To add these nodes to the current view, select 
them in the Nodes Excluded from View table and click the left-arrow button to 
move the node to the Nodes In Current View table.

At times, you might want to make an excluded node a new node. To do so, select 
one or more nodes in the Nodes Excluded From View table, click the left-arrow 
button to move the node to the Nodes In Current View table, then click the next 
left-arrow button to move the nodes to the New Nodes Found table.

Step 6 (Optional) The New Nodes Found table displays newly discovered nodes, based 
on the following criteria:

• If you are using an SGM client with the DEFAULT view set, this table never 
contains any nodes. In the DEFAULT view, SGM adds all newly discovered 
nodes to the Nodes In Current View table as soon as they are discovered.

• If you are using an SGM client with a custom view set, this table contains all 
nodes discovered since the Network View Editor window was opened in this 
session that have not been excluded in the Nodes Excluded from View table, 
or that are not in the current view.
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When SGM discovers one or more new nodes in the network, SGM also takes the 
following actions:

• SGM broadcasts the discovery of the new nodes to all SGM clients.

• SGM displays the text (New Nodes Exist) in the bottom right corner of most 
SGM windows.

• SGM adds graphical elements for the newly discovered nodes to the topology 
new signaling point panel in the left pane of the Topology window. For more 
information, see the “Viewing the Topology of the Network” section on 
page 3-259.

To add a newly discovered node to the current view, select one or more nodes and 
click the right-arrow button to move them to the Nodes In Current View table.

To exclude a newly discovered node from the current view, select the node, click 
the right-arrow button to move the node to the Nodes In Current View table, then 
click the next right-arrow button to move the node to the Nodes Excluded From 
View table.

Step 7 (Optional) The Signaling Points In Current View table lists the signaling points 
that are in the current view. If there are signaling points listed in the Signaling 
Points In Current View table that you do not want to manage, you can remove 
them from the current view. To do so, select one or more signaling points in the 
Signaling Points In Current View table, then click the right-arrow button to move 
the signaling points to the Signaling Points Excluded from View table.

Note If you are using an SGM client with the DEFAULT view set, SGM 
automatically adds all newly discovered signaling points to the Signaling 
Points In Current View table as soon as they are discovered.

If you delete a signaling point, SGM removes it from the Signaling Points 
In Current View table. If SGM then discovers the signaling point, SGM 
places it in the New Signaling Points Found table. To see this signaling 
point again in your current view, you must move it into the Signaling 
Points In Current View table.

At times, you might want to make an existing signaling point a new signaling 
point. To do so, select one or more signaling points in the Signaling Points In 
Current View table, then click the left-arrow button to move the signaling points 
to the New Signaling Points Found table.
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Step 8 (Optional) The Signaling Points Excluded from View table lists the signaling 
points that have been excluded from the current view. To add these signaling 
points to the current view, select them in the Signaling Points Excluded from View 
table and click the left-arrow button to move the signaling point to the Signaling 
Points In Current View table.

At times, you might want to make an excluded signaling point a new signaling 
point. To do so, select one or more signaling points in the Signaling Points 
Excluded From View table, click the left-arrow button to move the signaling point 
to the Signaling Points In Current View table, then click the next left-arrow button 
to move the signaling points to the New Signaling Points Found table.

Step 9 (Optional) The New Signaling Points Found table displays newly discovered 
signaling points, based on the following criteria:

• If you are using an SGM client with the DEFAULT view set, this table never 
contains any signaling points. In the DEFAULT view, SGM adds all newly 
discovered signaling points to the Signaling Points In Current View table as 
soon as they are discovered.

• If you are using an SGM client with a custom view set, this table contains all 
signaling points discovered since the Network View Editor window was 
opened in this session that have not been excluded in the Signaling Points 
Excluded from View table, or that are not in the current view.

When SGM discovers one or more new signaling points in the network, SGM also 
takes the following actions:

• SGM broadcasts the discovery of the new signaling points to all SGM clients.

• SGM displays the text (New Signaling Points Exist) in the bottom right 
corner of most SGM windows.

• SGM adds graphical elements for the newly discovered signaling points to the 
topology new signaling point panel in the left pane of the Topology window. 
For more information, see the “Viewing the Topology of the Network” section 
on page 3-259.

To add a newly discovered signaling point to the current view, select one or more 
signaling points and click the right-arrow button to move them to the Signaling 
Points In Current View table.

To exclude a newly discovered signaling point from the current view, select the 
signaling point, click the right-arrow button to move the signaling point to the 
Signaling Points In Current View table, then click the next right-arrow button to 
move the signaling point to the Signaling Points Excluded From View table.
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Step 10 When you are satisfied with the changes you have made to the view, use one of 
the following procedures to save the view:

• To save the changes you have made to the view without changing the name of 
the file, select File > Save from the Network View Editor menu.

Note You cannot save changes to the DEFAULT view. If you are currently 
using the DEFAULT view and you select File > Save, SGM displays 
the Save File Dialog: View List dialog (Figure 3-8).

• To save the changes you have made to the view with a new name, select File 
> Save As from the Discovery Dialog menu. SGM displays the Save File 
Dialog: View List dialog (Figure 3-8).

Figure 3-8 Save File Dialog: View List Dialog
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The Save File Dialog: View List dialog contains the following fields:

– Type—Icon indicating whether the item in the table is a file or a folder.

– Name—Name of the view file or folder.

– Last Modified—Date and time the view file or folder was last modified.

– Size (bytes)—Size of the view file or folder, in bytes.

– Filename—Name by which you want to save the view. You must specify 
a name other than DEFAULT. You cannot save changes to the DEFAULT 
view.

If you create a new view name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system. 
However, if you include any spaces in the new name, SGM converts those 
spaces to dashes. For example, SGM saves file “a b c” as “a-b-c”.

– Make this my preferred start option—Specifies whether the selected 
view is to be loaded automatically whenever the associated preferences 
file is loaded:

- To load the selected view, select the view, then select this checkbox.

- To load the last-used view, clear the checkbox. This is the default 
setting.

– Number of Files—Total number of view files and folders (displayed in 
bottom left corner).

To save the view with a new name, use one of the following procedures:

– To save the file with a completely new name, enter the new name and 
click OK.

– To save the file with an existing name, overwriting an old view, select the 
name in the list and click OK.

SGM saves the view with the new name, closes the Save File Dialog: View 
List dialog, and returns to the Discovery Dialog.

Note If another user modifies and saves the view before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If 
you choose to do so, the other user’s changes are overwritten and lost. 
If you choose not to do so, your changes are lost, unless you save the 
view to a different filename.
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SGM stores the view in the view file directory on the SGM server:

– If you installed SGM in the default directory, /opt, then the SGM view 
file directory is /opt/CSCOsgm/views.

– If you installed SGM in a different directory, then the SGM view file 
directory is located in that directory.

To delete a view from the view list, select a file and click Delete. SGM issues 
an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: View List dialog.

To close the Save File Dialog: View List dialog without saving the view or 
saving any changes to the view list, click Cancel.

Step 11 (Optional) To close the Network View Editor window at any time, click File > 
Close. If you have modified the view, SGM asks if you want to apply the changes 
before leaving the window:

• Click Yes to apply the changes to the current view. SGM applies the changes 
to all SGM windows immediately. SGM then asks if you want to make this 
the default view:

– Click Yes to make this view the new default view. In the future, when this 
client is started, this will be the default view.

– Click No to retain your old default view.

SGM closes the Network View Editor window.

• Click No to keep the current view as-is, without applying any changes. SGM 
closes the Network View Editor window.

• Click Cancel to close the prompt window and return to the Network View 
Editor window without applying any changes to the current view.

If you are working in a custom view (that is, not in the DEFAULT view) and you 
exit the SGM client, SGM automatically saves any changes you made to the view.
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Loading the DEFAULT View
To load the DEFAULT network view:

Step 1 Select Edit > Network Views from the SGM Main Menu. SGM displays the 
Network View Editor window (Figure 3-7).

Step 2 Select File > Load DEFAULT View from the Discovery Dialog menu. SGM 
loads the DEFAULY view.

Loading a Client-Specific View
To load a client-specific network view:

Step 1 Select Edit > Network Views from the SGM Main Menu. SGM displays the 
Network View Editor window (Figure 3-7).

Step 2 Select File > Load from the Discovery Dialog menu. SGM displays the Load File 
Dialog: View List dialog (Figure 3-9).
3-35
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Views
Figure 3-9 Load File Dialog: View List Dialog

The Load File Dialog: View List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the view file or folder.

• Last Modified—Date and time the view file or folder was last modified.

• Size (bytes)—Size of the view file or folder, in bytes.

• Make this my preferred start option—Specifies whether the selected view 
is to be loaded automatically whenever the associated preferences file is 
loaded:

– To load the selected view, select the view, then select this checkbox.

– To load the last-used view, clear the checkbox. This is the default setting.

• Number of Files—Total number of view files and folders (displayed in 
bottom left corner).

To load a view, select the view in the list and click OK.
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SGM closes the Load File Dialog: View List dialog, loads the view, and returns to 
the Network View Editor window.

To close the Load File Dialog: View List dialog without loading a view, click 
Cancel.

Working with Linksets
SGM enables you to view information about all discovered linksets, including 
their associated nodes, status, and other important information.

This section includes the following information:

• Viewing Basic Information for Linksets, page 3-38

• Viewing Detailed Information for a Linkset, page 3-42

• Viewing Real-Time Data for a Linkset, page 3-54

• Editing a Linkset, page 3-84

• Viewing Notes for a Linkset, page 3-87

• Deleting a Linkset, page 3-88

• Ignoring a Linkset, page 3-90

• Viewing Ignored Linksets, page 3-90

Related Topics:

• Modifying Preference Settings, page 5-3

• Resizing, Sorting, and Hiding Table Columns, page 3-279

• Viewing the Topology of the Network, page 3-259

• Working with Links, page 3-170

• Working with Nodes, page 3-91

• Working with Signaling Points, page 3-136
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Viewing Basic Information for Linksets
To view basic information for linksets, select Linksets in the left pane of the SGM 
Main Window. SGM displays the Linkset Window (Figure 3-10).

Figure 3-10 Linkset Window

The Linkset Window displays information about the linksets that have been 
discovered by SGM.

Linksets that are associated with nodes that are excluded from the current view 
are not displayed in the Linkset Window. See the “Creating a View” section on 
page 3-27 for more information about excluding nodes.

By default, SGM displays all of the columns in the Linkset Window except 
Internal ID, Name, Local Point Code, Adj Point Code, and Notes. To display 
these columns, or to hide other columns, see the procedures in the “Modifying 
Linkset Table Column Settings” section on page 5-18.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.
3-38
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Linksets
You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

The Linkset Window displays the following information for each discovered 
linkset:

• Internal ID—The internal ID of the linkset. The internal ID is a unique ID 
for every event, link, linkset, signaling point, and node, assigned by SGM for 
its own internal use. It can also be useful when the TAC is debugging 
problems.

• Name—Name of the linkset.

• Local Point Code—Point code of the primary node for the linkset.

• Adj Point Code—Point code of the adjacent node for the linkset.

• Linkset Type—Type of linkset, which SGM determines by examining the 
links defined in the linkset. Possible linkset types are:

– HSL—The links in this linkset use the SS7-over-ATM (Asynchronous 
Transfer Mode) high-speed protocol.

– SCTPIP—The links in this linkset use the Stream Control Transmission 
Protocol (SCTP) IP transport protocol.

– Serial—The links in this linkset use the serial SS7 signaling protocol.

– Mixed—The links in this linkset are of two or more types. (This 
arrangement is not recommended.)

– Virtual—The links in this linkset are virtual links, which connect 
signaling point instances running on the same device. SGM does not poll 
virtual linksets, nor does it display real-time data or accounting statistics 
for virtual linksets.

– Other—No links have been defined for this linkset.

• Links—Total number of links in the linkset.

• Active Links—Number of links in the linkset that are Active.

• Congested Links—Number of links in the linkset that are Congested.

• Ignored—Indicates whether the linkset is to be included when aggregating 
and displaying SGM status information.

• Notes— Indicates whether there is a note associated with the linkset.
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• Events—Indicates whether there is a recent event associated with the linkset.

– To delete the event icon from SGM displays for a specific linkset, for this 
SGM client only, select the linkset and click the icon.

– To delete the event icon from SGM displays for all linksets, for this SGM 
client only, select Edit > Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most linksets with an event 
icon. If the event icons are too distracting, use the Edit > Clear 
All Events menu option to remove them.

• Last Status Change—Date and time that the status of the linkset last 
changed.

• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.

– Shutdown (blue ball)—An ITP administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.

– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

• Status Reason—Reason for the current status of the linkset. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string
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– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

The “Viewing Detailed Information for a Link” section on page 3-175 
displays additional information about the causes of link failures.

The “Viewing Detailed Information for a Linkset” section on page 3-42 
displays additional information about the causes of linkset failures.
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Viewing Detailed Information for a Linkset
SGM can display detailed information about a selected linkset, including its 
associated links, status, and other information.

To display detailed information for a linkset, use one of the following procedures:

• Select Linksets in the left pane of the SGM Main Window, right-click a 
linkset in the right pane, then select View >Configuration Details in the 
right-click menu.

• Select the turner beside Linksets in the left pane of the SGM Main Window, 
then select a linkset.

SGM displays the Linkset Details Window (Figure 3-11).

Figure 3-11 Linkset Details Window

Detailed information for the selected linkset is displayed in the left column, and 
for the adjacent linkset in the right column.

Updates for the linkset that are received from the SGM server are reflected 
automatically in this window.
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Changes you make in this pane might not be reflected throughout SGM until the 
next poll (by default, every 15 seconds). For information about changing the 
polling interval, see the “Viewing Detailed Information for a Link” section on 
page 3-175.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

Links Tab

To view information about the links that are associated with the selected linkset, 
select the Links tab. SGM displays the linksets in the top table, and the links in 
the bottom table.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

By default, SGM displays all of the columns in the Link Table except Internal 
ID, Congestion Level, and Last Status Change. To display these columns, or to 
hide other columns, see the procedures in the “Modifying Linkset Table Column 
Settings” section on page 5-18.

The Link Table displays the following information about links that are associated 
with the selected linkset:

• Internal ID—Internal ID of the link. The internal ID is a unique ID for every 
event, linkset, link, signaling point, and node, assigned by SGM for its own 
internal use. It can also be useful when the TAC is debugging problems.

• Node—Name of the node associated with the link.

• Signaling Point—Name of the signaling point associated with the link.

• Linkset—Name of the linkset associated with the link.

• SLC—Signaling link code (SLC) ID for the link.
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• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTPIP—The link uses the Stream Control Transmission Protocol 
(SCTP) IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Congestion Level—Indicates whether there is congestion on the link. A link 
is congested if it has too many packets waiting to be sent. This condition 
could be caused by the failure of an element in your network.

Possible values for the Congestion Level field are:

– None—The link is not congested.

– Low—The link is slightly congested.

– High—The link is congested.

– Very High—The link is very congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.

• Ignored—Indicates whether the link is to be included when aggregating and 
displaying SGM status information:

– Clear the checkbox to include the link. This is the default setting.

– Select the checkbox to exclude the link.

This field can be edited by users with authentication level Power User (Level 
2) and higher.

• Notes—Indicates whether there is a note associated with the link.
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• Events—Indicates whether there is a recent event associated with the link.

– To delete the event icon from SGM displays for a specific link, select the 
link and click the icon.

– To delete the event icon from SGM displays for all links, select 
Edit>Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most links with an event icon. If the 
event icons are too distracting, use the Edit>Clear All Events menu 
option to remove them.

• Last Status Change—Date and time that the status of the link last changed.

• Status—Current status of the link. Possible values are:

– Active (green ball)—The link is currently fully functional.

– Blocked (red ball)—Traffic on this link is disabled by protocol.

– Failed (red ball)—An error is preventing traffic from flowing on this 
link, or the associated linkset has been set to Shutdown status.

A link can be Failed from an MTP3 perspective, but control messages 
might still be sent or received on the link, resulting in changing 
packet/second and bit/second rates. The rates might also be different at 
each end of the link, depending on the reason for the failure and the 
timing related to each endpoint.

– InhibitLoc (blue ball)—A local ITP administrator has set the link to 
prevent traffic from flowing.

– InhibitRem (blue ball)—A remote ITP administrator has set the link to 
prevent traffic from flowing.

– Shutdown (blue ball)—An ITP administrator has set the link to prevent 
traffic from flowing.
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– Unknown (red ball)—Either the node associated with this link has failed 
to respond to an SNMP request, or SGM found that the link no longer 
exists.

When you physically delete a link, the Status field displays Unknown 
until you delete the link from the SGM database.

– Warning (yellow ball)—The link is active and traffic is flowing, but one 
or more of the following situations has occurred:

– The link is congested.

– The link has exceeded the defined Receive Utilization % or Send 
Utilization %.

– One or more of the local or remote IP addresses defined for SCTP is 
not active.

• Status Reason—Reason for the current status of the link. Possible values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive
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– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Configuration Data Tab: Naming Information

To view naming information for the selected linkset, select the Configuration 
Data tab.

The Naming Information sub-section displays the following information for the 
selected linkset:

• Name—Name of the linkset.

• Local Point Code—Point code of the primary node for the linkset.

• Adj Point Code—Point code of the adjacent node for the linkset.

• Last Status Change—Date and time that the status of the linkset last 
changed.

• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.

– Shutdown (blue ball)—An ITP administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.
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– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

• Status Reason—Reason for the current status of the linkset. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.
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If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Configuration Data Tab: Description

To view descriptive information for the selected linkset, select the Configuration 
Data tab.

The Description sub-section contains a description of the linkset. If the linkset has 
no description, this sub-section is blank.

Configuration Data Tab: General Information

To view general information for the selected linkset, select the Configuration 
Data tab.

The General Information sub-section displays the following information for the 
selected linkset:

• Linkset Type—Type of linkset, which SGM determines by examining the 
links defined in the linkset. Possible linkset types are:

– HSL—The links in this linkset use the SS7-over-ATM (Asynchronous 
Transfer Mode) high-speed protocol.

– SCTPIP—The links in this linkset use the Stream Control Transmission 
Protocol (SCTP) IP transport protocol.

– Serial—The links in this linkset use the serial SS7 signaling protocol.

– Mixed—The links in this linkset are of two or more types. (This 
configuration is not recommended.)

– Virtual—The links in this linkset are virtual links, which connect 
signaling point instances running on the same device. SGM does not poll 
virtual linksets, nor does it display real-time data or accounting statistics 
for virtual linksets.

– Other—No links have been defined for this linkset.
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• Is Ignored—Indicates whether the linkset is Ignored (that is, whether the 
linkset is to be included when aggregating and displaying SGM status 
information).

• Inbound ACL—Inbound IP access control list (ACL) number for the linkset. 
If there is no inbound ACL for the linkset, this field displays 0.

• Outbound ACL—Outbound ACL number for the linkset. If there is no 
outbound ACL for the linkset, this field displays 0.

Configuration Data Tab: Links Information

To view links information for the selected linkset, select the Configuration Data 
tab.

The Links Information sub-section displays the following information for the 
selected linkset:

• Links—Total number of links in the linkset.

• Active Links—Number of links in the linkset that are Active.

• Congested Links—Number of links in the linkset that are Congested.

Notes Tab

To view notes for the selected linkset, select the Notes tab.

The Notes section displays:

• Notes associated with the selected linkset in the left column.

• Notes associated with the adjacent linkset in the right column.

• The date and time the notes associated with each linkset were last updated, or 
the phrase Not Set if there are no notes associated with the linkset.

• The phrase No Notes if there are no notes associated with the linkset.

Recent Events Tab

To view information about all recent events associated with the linkset, select the 
Recent Events tab. SGM displays the Recent Events table for the linkset 
(Figure 3-12).
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Figure 3-12 Recent Events Table for a Linkset

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Ack Time, Node, SP, Linkset, and Link. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Event 
Table Column Settings” section on page 5-19.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

The Recent Events table enables you to perform event-related tasks, such as 
setting filters and acknowledging events. For more information about these tasks, 
see the “Working with Events” section on page 3-235.
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The Recent Events table displays the following information for the selected 
linkset:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.

– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.
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– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.
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• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

ITP Access Lists Tab

To view information about all access lists associated with the selected linkset and 
its adjacent linkset, select the ITP Access Lists tab.

For each linkset, the ITP Access Lists section displays the following information:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• Linkset—Name of the linkset for which access lists are being displayed.

• In—Inbound access lists for the linkset. If the linkset has no inbound access 
lists, this field displays None.

• Out—Outbound access lists for the linkset. If the linkset has no outbound 
access lists, this field displays None.

• List #—Access list number configured on the node and applied to the linkset. 
ITP uses access list numbers 2700 through 2799.

• Access List—List of commands in the access list.

Viewing Real-Time Data for a Linkset
SGM enables you to display detailed statistics for a selected linkset, including its 
associated links, status, and other information. Detailed information for the 
selected linkset is displayed in the left column, and for the adjacent linkset in the 
right column.

To display detailed statistics for a linkset, select Linksets in the left pane of the 
SGM Main Window, right-click a linkset in the right pane, then select 
View >Real-Time Data and Charts in the right-click menu. SGM displays the 
Statistics Details Window for a Linkset (Figure 3-13).
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Figure 3-13 Statistics Details Window for a Linkset

Updates for the linksets that are received from the SGM server are reflected 
automatically in this window.

Changes you make in this window might not be reflected throughout SGM until 
the next poll (by default, every 15 seconds). For information about changing the 
polling interval, see the “Viewing Detailed Information for a Link” section on 
page 3-175.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.
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Configuration Data Tab: Naming Information

To view naming information for the selected linkset, select the Configuration 
Data tab.

The Naming Information sub-section displays the following information for the 
selected linkset:

• Name—Name of the linkset.

• Local Point Code—Point code of the primary node for the linkset.

• Adj Point Code—Point code of the adjacent node for the linkset.

• Last Status Change—Date and time that the status of the linkset last 
changed.

• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.

– Shutdown (blue ball)—An ITP administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.

– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

• Status Reason—Reason for the current status of the linkset. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device
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– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Configuration Data Tab: Description

To view descriptive information for the selected linkset, select the Configuration 
Data tab.

The Description sub-section contains a description of the linkset. If the linkset has 
no description, this sub-section is blank.
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Configuration Data Tab: General Information

To view general information for the selected linkset, select the Configuration 
Data tab.

The General Information sub-section displays the following information for the 
selected linkset:

• Linkset Type—Type of linkset, which SGM determines by examining the 
links defined in the linkset. Possible linkset types are:

– HSL—The links in this linkset use the SS7-over-ATM (Asynchronous 
Transfer Mode) high-speed protocol.

– SCTPIP—The links in this linkset use the Stream Control Transmission 
Protocol (SCTP) IP transport protocol.

– Serial—The links in this linkset use the serial SS7 signaling protocol.

– Mixed—The links in this linkset are of two or more types. (This 
configuration is not recommended.)

– Virtual—The links in this linkset are virtual links, which connect 
signaling point instances running on the same device. SGM does not poll 
virtual linksets, nor does it display real-time data or accounting statistics 
for virtual linksets.

– Other—No links have been defined for this linkset.

• Is Ignored—Indicates whether the linkset is Ignored (that is, whether the 
linkset is to be included when aggregating and displaying SGM status 
information).

• Inbound ACL—Inbound IP access control list (ACL) number for the linkset. 
If there is no inbound ACL for the linkset, this field displays 0.

• Outbound ACL—Outbound ACL number for the linkset. If there is no 
outbound ACL for the linkset, this field displays 0.
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Configuration Data Tab: Links Information

To view links information for the selected linkset, select the Configuration Data 
tab.

The Links Information sub-section displays the following information for the 
selected linkset:

• Links—Total number of links in the linkset.

• Active Links—Number of links in the linkset that are Active.

• Congested Links—Number of links in the linkset that are Congested.

Notes Tab

To view notes for the selected linkset, select the Notes tab.

The Notes section displays:

• Notes associated with the selected linkset in the left column.

• Notes associated with the adjacent linkset in the right column.

• The date and time the notes associated with each linkset were last updated, or 
the phrase Not Set if there are no notes associated with the linkset.

• The phrase No Notes if there are no notes associated with the linkset.

Recent Events Tab

To view information about all recent events associated with the linkset, select the 
Recent Events tab. SGM displays the Recent Events table for the linkset 
(Figure 3-12).

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Ack Time, Node, SP, Linkset, and Link. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Event 
Table Column Settings” section on page 5-19.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.
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The Recent Events section enables you to perform event-related tasks, such as 
setting filters and acknowledging events. For more information about these tasks, 
see the “Working with Events” section on page 3-235.

The Recent Events table displays the following information for the selected 
linkset:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.

– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.
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– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.
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• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

ITP Access Lists Tab

To view information about all access lists associated with the selected linkset and 
its adjacent linkset, select the ITP Access Lists tab.

For each linkset, the ITP Access Lists section displays the following information:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• Linkset—Name of the linkset for which access lists are being displayed.

• In—Inbound access lists for the linkset. If the linkset has no inbound access 
lists, this field displays None.

• Out—Outbound access lists for the linkset. If the linkset has no outbound 
access lists, this field displays None.

• List #—Access list number configured on the node and applied to the linkset. 
ITP uses access list numbers 2700 through 2799.

• Access List—List of commands in the access list.

Statistics Tab: Packet Information

To view packet information for the selected link, select the Statistics tab.
3-62
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Linksets
The Packet Information sub-section displays the following information for the 
selected link:

• Sent Per Sec—Number of packets sent by the linkset per second. This field 
initially displays the phrase Waiting for second poll. After two polling 
cycles, SGM populates this field with actual calculated rates.

• Received Per Sec—Number of packets received by the linkset per second. 
This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

• Drops—Total number of packets that have been dropped by the linkset.

Statistics Tab: Bit Information or Byte Information

To view bit information for the selected linkset (or byte information, if you 
cleared the Show Details in Bits Instead of Bytes checkbox in the Preferences 
Window), select the Statistics tab.

The Bit Information or Byte Information sub-section displays the following 
information for the selected linkset:

• Sent Per Sec—Number of bits or bytes (as set in the Preferences window) 
sent by the linkset per second. This field initially displays the phrase Waiting 
for second poll. After two polling cycles, SGM populates this field with 
actual calculated rates.

• Received Per Sec—Number of bits or bytes (as set in the Preferences 
window) received by the linkset per second. This field initially displays the 
phrase Waiting for second poll. After two polling cycles, SGM populates 
this field with actual calculated rates.
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Statistics Tab: Utilization Information

To view utilization information for the selected linkset, select the Statistics tab.

The Utilization Information sub-section displays the following information for 
the selected linkset:

• Send Plan Capacity—Planned capacity of the linkset to send, in bits per 
second.

– For a linkset of type Serial or HSL, available bandwidth for the linkset.

– For a linkset of type SCTPIP or Mixed, set on the ITP using the 
plan-capacity CS7 linkset configuration command.

If Send Plan Capacity is not set on the ITP for this linkset, this field 
displays the value 0.

– For a linkset of type Other, this field always displays the value 0.

• Send Utilization—Amount of the linkset’s send capacity being used, as a 
percentage or in Erlangs (as set in the Preferences window), calculated using 
the following formula:

Send Utilization = (Bits Sent Per Sec)/Planned Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a linkset of type SCTPIP or Mixed, if Send Plan Capacity is not set 
on the ITP for this linkset, this field displays the phrase Set Plan 
Capacity on ITP.

– For a linkset of type Other, this field always displays the phrase Set Plan 
Capacity on ITP.

• Receive Plan Capacity—Planned capacity of the linkset to receive, in bits 
per second.

– For a linkset of type Serial or HSL, available bandwidth for the linkset.

– For a linkset of type SCTPIP or Mixed, set on the ITP using the 
plan-capacity CS7 linkset configuration command.

If Receive Plan Capacity is not set on the ITP for this linkset, this field 
displays the value 0.

– For a linkset of type Other, this field always displays the value 0.
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• Receive Utilization—Amount of the linkset’s receive capacity being used, as 
a percentage or in Erlangs (as set in the Preferences window), calculated 
using the following formula:

Receive Utilization = (Bits Received Per Sec)/Receive Plan Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a linkset of type SCTPIP or Mixed, if Receive Plan Capacity is not 
set on the ITP for this linkset, this field displays the phrase Set Plan 
Capacity on ITP.

– For a linkset of type Other, this field always displays the phrase Set Plan 
Capacity on ITP.

Statistics Tab: Service Information

To view service information for the selected linkset, select the Statistics tab.

The Service Information sub-section displays the following information for the 
selected linkset:

• MTP3 Accounting Enabled—Indicates whether the collection of MTP3 
accounting statistics is enabled for the linkset.

• GTT Accounting Enabled—Indicates whether the collection of GTT 
accounting statistics is enabled for the linkset. For Cisco IOS software 
releases prior to 12.2(4)MB10, this field displays Unknown.

• Duration In Service %—Percentage of time the linkset has been in service 
since the last reboot of the ITP, or since ITP last reset the counters.

• Duration Out Of Service %—Percentage of time the linkset has been out of 
service since the last reboot of the ITP, or since ITP last reset the counters.
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Charts Tab: ReceivedUtilization

To view real-time ReceivedUtilization information for the selected linkset, select 
the Charts tab. SGM displays the ReceivedUtilization chart (Figure 3-14).

Figure 3-14 ReceivedUtilization Chart for a Linkset
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The ReceivedUtilization chart displays the following information for the selected 
linkset:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Received Utilization Chart. Valid selections are 1, 2, 
5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.

• Received Utilization Chart—Displays the average Receive Utilization % 
for all links on the linkset as a function of time, and optionally the Receive 
Utilization % for up to 16 individual links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the receive utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Received Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

• Show threshold line for:—Draws a horizontal line on the Received 
Utilization Chart, indicating the receive threshold for the selected link.

If you do not want to draw a threshold line, select None. This is the default 
setting.

• Scale to threshold—Scales the Received Utilization Chart in order to draw 
the threshold selected in the Show threshold line for field:

– To scale the chart, select this checkbox.

– To remove the scaling from the chart, clear this checkbox. This is the 
default setting.

The Scale to threshold checkbox is not available if the Show threshold line 
for: field is set to None.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
3-68
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Linksets
Charts Tab: SendUtilization

To view real-time SendUtilization information for the selected linkset, select the 
Charts tab. SGM displays the SendUtilization chart (Figure 3-15).

Figure 3-15 SendUtilization Chart for a Linkset
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The SendUtilization chart displays the following information for the selected 
linkset:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Send Utilization Chart. Valid selections are 1, 2, 5, 10, 
20, 40, or 60 minutes. The default selection is 5 minutes.

• Send Utilization Chart—Displays the average Send Utilization % for all 
links on the linkset as a function of time, and optionally the Send 
Utilization % for up to 16 individual links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the send utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Send Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

• Show threshold line for:—Draws a horizontal line on the Send Utilization 
Chart, indicating the receive threshold for the selected link.

If you do not want to draw a threshold line, select None. This is the default 
setting.

• Scale to threshold—Scales the Send Utilization Chart in order to draw the 
threshold selected in the Show threshold line for field:

– To scale the chart, select this checkbox.

– To remove the scaling from the chart, clear this checkbox. This is the 
default setting.

The Scale to threshold checkbox is not available if the Show threshold line 
for: field is set to None.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Charts Tab: PktsRcvdPerSec

To view real-time packets-received-per-second information for the selected link, 
select the Charts tab. SGM displays the PktsRcvdPerSec chart (Figure 3-16).

Figure 3-16 PktsRcvdPerSec Chart for a Linkset
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The PktsRcvdPerSec chart displays the following information for the selected 
link:

SGM displays the following information in the PktsRcvdPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Received Chart. Valid selections are 1, 2, 5, 
10, 20, 40, or 60 minutes. The default selection is 5 minutes.

• Packets Received Chart—Displays the Packets Received Per Sec for the 
linkset as a function of time, including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets received per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Packets Received Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Charts Tab: PktsSentPerSec

To view real-time packets-sent-per-second information for the selected link, 
select the Charts tab. SGM displays the PktsSentPerSec chart (Figure 3-17).
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Figure 3-17 PktsSentPerSec Chart for a Linkset

The PktsSentPerSec chart displays the following information for the selected link:

SGM displays the following information in the PktsSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Sent Chart. Valid selections are 1, 2, 5, 10, 20, 
40, or 60 minutes. The default selection is 5 minutes.
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• Packets Sent Chart—Displays the Packets Sent Per Sec for the linkset as a 
function of time, including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Packets Sent Chart, up to 16 total links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Charts Tab: BitsRcvdPerSec

To view real-time bits-received-per-second information for the selected link (or 
bytes-received-per-second information, if you cleared the Show Details in Bits 
Instead of Bytes checkbox in the Preferences Window), select the Charts tab. 
SGM displays the BitsRcvdPerSec chart (Figure 3-18).

Figure 3-18 BitsRcvdPerSec Chart for a Linkset
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The BitsRcvdPerSec chart displays the following information for the selected 
link:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Received Chart or Bytes Received Chart. Valid 
selections are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 
5 minutes.

• Bits Received Chart or Bytes Received Chart—Displays the Bits Received 
Per Sec or Bytes Received Per Sec for the linkset as a function of time, 
including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes (as set in the Preferences window) 
received per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Bits Received Chart or Bytes Received 
Chart, up to 16 total links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Charts Tab: BitsSentPerSec

To view real-time bits-sent-per-second information for the selected link (or 
bytes-sent-per-second information, if you cleared the Show Details in Bits 
Instead of Bytes checkbox in the Preferences Window), select the Charts tab. 
SGM displays the BitsSentPerSec chart (Figure 3-19).
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Figure 3-19 BitsSentPerSec Chart for a Linkset

The BitsSentPerSec chart displays the following information for the selected link:

SGM displays the following information in the BitsSentPerSec or 
BytesSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Sent Chart or Bytes Sent Chart. Valid selections 
are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.
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• Bits Sent Chart or Bytes Sent Chart—Displays the Bits Sent Per Sec or 
Bytes Sent Per Sec for the linkset as a function of time, including data for up 
to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes (as set in the Preferences window) 
sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Bits Sent Chart or Bytes Sent Chart, up 
to 16 total links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.
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To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Charts Tab: Drops

To view drops information for the selected link, select the Charts tab. SGM 
displays the Drops chart (Figure 3-20).

Figure 3-20 Drops Chart for a Linkset
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The Drops chart displays the following information for the selected link:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Drops Chart. Valid selections are 1, 2, 5, 10, 20, 40, or 
60 minutes. The default selection is 5 minutes.

• Drops Chart—Displays the Drops for the linkset as a function of time, 
including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of drops for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
3-83
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Linksets
• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Drops Chart, up to 16 total links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Editing a Linkset
SGM enables you to annotate a linkset, attaching a descriptive string to the 
linkset.

To annotate a linkset:

Step 1 Right-click a linkset in a window.

Step 2 Select Edit Notes in the right-click menu. SGM displays the Edit Notes Dialog 
for a Linkset (Figure 3-21).
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Figure 3-21 Edit Notes Dialog for a Linkset

If both ends of the linkset are known to SGM, one is displayed in the top half of 
the Edit Notes Dialog for a Linkset, the other in the bottom half. If only one end 
is known to SGM, only that end is displayed.
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The Edit Notes Dialog for a Linkset displays the name of the linkset and the date 
and time the Notes field for the linkset was last updated. If there is no note 
currently associated with the linkset, the Notes Last Updated field displays the 
value Not Set.

Step 3 In the Notes field, enter any important information about the linkset, such as a 
detailed description, its location, its service history, and so on.

Step 4 Click Save to save the annotations and exit the Edit Notes Dialog for a Linkset.
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Viewing Notes for a Linkset
SGM enables you to view the notes that have been attached to linksets.

To view a note, right-click a linkset in a window, then select View > Notes in the 
right-click menu. (The Notes option is grayed-out if there is no note associated 
with the selected linkset.) SGM displays the Linkset Notes dialog (Figure 3-22).

Figure 3-22 Linkset Notes Dialog

The Linkset Notes dialog displays the following information:

• Name—Name of the linkset.

• Notes Last Updated—Date and time the Notes field for the linkset was last 
updated.

• Notes—Notes associated with the linkset.

Click OK to close the Linkset Notes dialog.
3-87
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Linksets
Deleting a Linkset
After Discovery, the linksets in your network are known to SGM and added to the 
SGM database. Physically deleting linksets from your network is not the same as 
deleting them from the SGM database. The following sections describe the 
differences between deleting linksets from your network and from the SGM 
database, and the procedures for doing so:

• Deleting a Linkset from Your Network, page 3-88

• Deleting a Linkset from the SGM Database, page 3-88

Deleting a Linkset from Your Network

If you physically delete a known linkset from your network, it remains in the SGM 
database, SGM labels it Unknown, and it is the system administrator’s 
responsibility to delete it from the SGM database, if you choose to do so. SGM 
labels all associated nodes Warning and all associated links Unknown.

When you redefine the linkset (that is, when you define a linkset with the same 
destination point code as the original linkset, but not necessarily with the same 
linkset name), SGM rediscovers the linkset and labels it with the appropriate 
status (such as Active).

Deleting a Linkset from the SGM Database

Typically, you delete a linkset in the SGM database for one of the following 
reasons:

• You have physically deleted the linkset from your network. This is the most 
common reason for deleting a linkset from the SGM database.

• The linkset is Unknown or Unavailable, you are aware of the reason, and you 
no longer want to see it in SGM displays. For example, the linkset might be 
associated with a node that was removed from the network, or it might be a 
previously discovered linkset associated with a test lab device.

If you have physically deleted a known linkset from your network, and you then 
delete it from SGM, it is no longer in the SGM database, it does not appear in 
SGM windows, and it is not discovered when you run Discovery.
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If you have not physically deleted a known linkset from your network, and you 
delete it from SGM, SGM also automatically deletes all associated links from the 
SGM database. However, at the next poll SGM finds the linkset and associated 
links and adds them back to the SGM database, setting the status appropriately. If 
this happens, do not delete the linkset again. Instead, set it to Ignored. See the 
“Ignoring a Linkset” section on page 3-90 for more information.

Note If you delete a linkset from the SGM database, the linkset is deleted for all SGM 
clients and views connected to that SGM server.

If you delete all linksets to an Unmanaged node, SGM does not automatically 
delete the node. Instead, you must manually delete the node. See the “Deleting a 
Node” section on page 3-130 for more information.

To delete a linkset from the SGM database, use one of the following procedures:

• Select one or more linksets in a window, then select Edit > Delete from the 
SGM Main Menu.

• Right-click a linkset in a window, then select Delete Item in the right-click 
menu. (You cannot delete more than one linkset at a time from the right-click 
menu.)

SGM asks you to confirm the deletion:

• Select Yes to delete the selected linksets. SGM deletes the linksets and all 
associated links from the SGM database. However, if the linksets were not 
physically deleted from your network, then at the next poll SGM finds the 
linksets and their associated links and adds them back to the SGM database, 
setting the status appropriately.

• Select No to return to the window without deleting any linksets or links from 
the SGM database.

You can also use the sgm delete linkset command to delete one or more linksets 
from the SGM database. See the “SGM Commands and Descriptions” section on 
page B-2 for more information on the use of this command.
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Ignoring a Linkset
You can instruct SGM to ignore a linkset when it aggregates and displays network 
data. Setting linksets to Ignored prevents known linkset problems from affecting 
SGM displays for associated nodes. In effect, you are preventing a known 
problem from distracting you from other, more urgent network problems.

For example, you can set a linkset to Ignored before shutting down the linkset for 
maintenance.

Note If you set a linkset to Ignored, the linkset is ignored for all SGM clients and views 
connected to that SGM server.

Also, if you set a linkset to Ignored, make a note of the change, and do not forget 
to reset the linkset when the problem is corrected or the maintenance is complete.

To set a linkset to Ignored in the Linkset Window, select the Ignored checkbox 
for the linkset you want SGM to ignore.

To set a linkset to Ignored in the Topology window, select a linkset in the 
topology map, then, in the left pane, select the Ignored checkbox for the linkset 
you want SGM to ignore.

Viewing Ignored Linksets
To display all linksets that are Ignored, display the Linkset Window and click the 
Ignored column header. SGM displays all ignored linksets at the top of the table.
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Working with Nodes
SGM enables you to view information about all discovered nodes, including their 
IP addresses, status, and other important information.

This section includes the following information:

• Viewing Basic Information for Nodes, page 3-92

• Viewing Detailed Information for a Node, page 3-96

• Viewing CPU Statistics for a Node, page 3-121

• Editing a Node, page 3-124

• Viewing Notes for a Node, page 3-128

• Deleting a Node, page 3-130

• Unmanaging and Managing a Node, page 3-133

• Polling a Node, page 3-134

• Excluding a Node from a View, page 3-136

Related Topics:

• Modifying Preference Settings, page 5-3

• Resizing, Sorting, and Hiding Table Columns, page 3-279

• Viewing the Topology of the Network, page 3-259

• Working with Links, page 3-170

• Working with Linksets, page 3-37

• Working with Signaling Points, page 3-136
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Viewing Basic Information for Nodes
To view basic information for nodes, select Nodes in the left pane of the SGM 
Main Window. SGM displays the Node Window (Figure 3-23).

Figure 3-23 Node Window

The Node Window displays information about the nodes that have been 
discovered by SGM.

By default, SGM displays all of the columns in the node table except Internal ID, 
ITP Uptime, Reboot Reason, and Last Status Change. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Node 
Table Column Settings” section on page 5-16.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details. By default, this table is sorted by Status.
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The Node Window displays the following information for each discovered node:

• Internal ID—Internal ID of the node. The internal ID is a unique ID for every 
event, link, linkset, signaling point, and node, assigned by SGM for its own 
internal use. It can also be useful when the TAC is debugging problems.

• Name—Name or IP address of the node.

• Primary SNMP Address—IP address of the node, used by SNMP to poll the 
node. (There might be other IP addresses on the node that are not the primary 
SNMP address.)

• CLLI Code—COMMON LANGUAGE Location Identification Code for the 
node. A CLLI code is a standardized 11-character identifier that uniquely 
identifies the geographic location of the node. If the node has no CLLI code 
configured, this field is blank.

• Device Type—Device type of the node. Possible values are:

– Cisco2650—Cisco 2650 series router

– Cisco2650XM—Cisco 2650XM series router

– Cisco2651—Cisco 2651 series router

– Cisco2651XM—Cisco 2651XM series router

– Cisco7204—Cisco 7204 series router

– Cisco7204VXR—Cisco 7204VXR series router

– Cisco7206—Cisco 7206 series router

– Cisco7206VXR—Cisco 7206VXR series router

– Cisco7507—Cisco 7507 series router

– Cisco7507mx—Cisco 7507mx series router

– Cisco7507z—Cisco 7507z series router

– Cisco7513—Cisco 7513 series router

– Cisco7513mx—Cisco 7513mx series router

– Cisco7513z—Cisco 7513z series router

– IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

– Unknown—SGM is unable to determine the device type.

• ITP MIB Level—MIB conformance level used by the ITP, such as ITP MB5.
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• ITP Uptime—Time the ITP has been up, in weeks, days, hours, minutes, and 
seconds.

• Reboot Reason—Reason for the last reboot of the ITP.

• Notes—Indicates whether there is a note associated with the node.

• Events—Indicates whether there is a recent event associated with the node.

– To delete the event icon from SGM displays for a specific node, for this 
SGM client only, select the node and click the icon.

– To delete the event icon from SGM displays for all nodes, for this SGM 
client only, select Edit > Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most nodes with an event icon. If 
the event icons are too distracting, use the Edit > Clear All Events 
menu option to remove them.

• Last Status Change—Date and time that the status of the node last changed.

• Status—Current status of the node. Possible values are:

– Active (green ball)—The node is currently fully functional.

– Discovering (gray ball)—The node is being discovered, and SNMP 
queries have been sent to the device.

– Polling (gray ball)—The node is being polled.

– Unknown (red ball)—The node failed to respond to an SNMP request. 
SGM sets all associated signaling points, linksets, and links to 
Unknown.

– Unmanaged (gray ball)—One of the following situations exists:

– The node is known indirectly by SGM. In other words, SGM knows the 
device exists but there is no known SNMP stack on the device for SGM 
to query.

– An SGM user has set the node to Unmanaged status, to prevent SGM 
from polling the node.

If the associated signaling points are referenced via linksets to other 
signaling points, SGM automatically sets all associated signaling points 
to Unmanaged, and deletes all associated linksets and links, as well as 
all linksets and links that reference the node as an adjacent node.
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If the associated signaling points are not referenced to other signaling 
points, SGM automatically deletes the signaling points, all associated 
linksets and links, and all linksets and links that reference the node as an 
adjacent node.

– Waiting (gray ball)—The node is in the Discovery queue but is not 
currently being discovered.

– Warning (yellow ball)—The node is active, but one or more associated 
signaling points, linksets, or links is in Failed, Unavailable, Unknown, 
or Warning status and is not Ignored.

• Status Reason—Reason for the current status of the node. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.
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The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

The “Viewing Detailed Information for a Link” section on page 3-175 
displays additional information about the causes of link failures.

The “Viewing Detailed Information for a Linkset” section on page 3-42 
displays additional information about the causes of linkset failures.

Viewing Detailed Information for a Node
SGM can display detailed information about a selected node, including its CLLI 
code, point code, status, and other information.

To display detailed information for a node, use one of the following procedures:

• Select Nodes in the left pane of the SGM Main Window, right-click a node in 
the right pane, then select View >Configuration Details in the right-click 
menu.

• Select the turner beside Nodes in the left pane of the SGM Main Window, 
then select a node.

SGM displays the Node Details Window (Figure 3-24).
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Figure 3-24 Node Details Window

Updates for the node that are received from the SGM server are reflected 
automatically in this window.

Changes you make in this window might not be reflected throughout SGM until 
the next poll (by default, every 15 seconds). For information about changing the 
polling interval, see the “Viewing Detailed Information for a Linkset” section on 
page 3-42.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

Signaling Points Tab: Signaling Points

To view information about the signaling points that are associated with the 
selected node, select the Signaling Points tab. SGM displays the linksets in the 
top table, and the links in the bottom table.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.
3-97
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Nodes
If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

By default, SGM displays all of the columns in the Signaling Point Table except 
Internal ID, Instance ID, and Last Status Change. To display these columns, or 
to hide other columns, see the procedures in the “Modifying Node Table Column 
Settings” section on page 5-16.

The Signaling Point Table displays the following information about signaling 
points that are associated with the selected node:

• Internal ID—Internal ID of the signaling point. The internal ID is a unique 
ID for every event, link, linkset, node, and signaling point, assigned by SGM 
for its own internal use. It can also be useful when the TAC is debugging 
problems.

• Name—Name of the signaling point.

• Node—Name of the node associated with this signaling point.

• Instance ID—ID of the instance associated with the signaling point.

• Instance Name—Name of the instance associated with the signaling point.

• Point Code—Primary point code of the signaling point.

• Variant—SS7 protocol variant. Valid variants are:

– ANSI

– China

– ITU

• Network Indicator—Determines the type of call that is being placed. Valid 
values are:

– National—National-bound call. SGM routes national calls through the 
national network.

– NationalSpare—National-bound call, used in countries in which more 
than one carrier can share a point code. In those countries, networks are 
differentiated by the Network Indicator.
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– International—International-bound call. SGM forwards 
international-bound calls to an STP pair that acts as an international 
gateway.

– InternationalSpare—International-bound call, used in countries in 
which more than one carrier can share a point code. In those countries, 
networks are differentiated by the Network Indicator.

• Notes—Indicates whether there is a note associated with the signaling point.

• Events—Indicates whether there is a recent event associated with the 
signaling point. During Discovery, SGM might flag most signaling points 
with an event icon. If the event icons are too distracting, select Edit > Clear 
All Events from the SGM Main Menu to remove them.

• Last Status Change—Date and time that the status of the signaling point last 
changed.

• Status—Current status of the signaling point. Possible values are:

– Active (green ball)—The signaling point is currently fully functional.

– Unknown (red ball)—One of the following conditions occurred:

– SGM cannot poll the node associated with the signaling point. SGM 
sets all signaling points, linksets, and links associated with the node to 
Unknown.

– The signaling point has been unconfigured on the ITP, or the 
configuration is incomplete. At the next poll, SGM determines that the 
signaling point does not exist, and sets the signaling point and all 
associated linksets and links to Unknown.

– Unmanaged (gray ball)—An SGM user has set the signaling point to 
Unmanaged status, to prevent SGM from polling the signaling point. 
SGM automatically deletes all associated links and linksets.

– Warning (yellow ball)—The signaling point is active, but one or more 
associated links or linksets is in Failed, Unavailable, Unknown, or 
Warning status and is not flagged as Ignored.

• Status Reason—Reason for the current status of the signaling point. Possible 
values are:

– None

– SGM Restart

– Unsupported Configuration
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– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Signaling Points Tab: Linksets

To view information about the linksets that are associated with the selected node, 
select the Signaling Points tab. SGM displays the linksets in the top table, and the 
links in the bottom table.
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To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

Linksets that are associated with nodes that are excluded from the current view 
are not displayed in the Linkset Table. See the “Creating a View” section on 
page 3-27 for more information about excluding nodes.

By default, SGM displays all of the columns in the Linkset Table except Internal 
ID, Congestion Links, and Last Status Change. To display these columns, or to 
hide other columns, see the procedures in the “Modifying Linkset Table Column 
Settings” section on page 5-18.

The Linkset Table displays the following information about linksets that are 
associated with the selected node:

• Internal ID—Internal ID of the linkset. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Name—Name of the linkset.

• Local Point Code—Point code of the primary node for the linkset.

• Adj Point Code—Point code of the adjacent node for the linkset.

• Linkset Type—Type of linkset, which SGM determines by examining the 
links defined in the linkset. Possible linkset types are:

– HSL—The links in this linkset use the SS7-over-ATM (Asynchronous 
Transfer Mode) high-speed protocol.

– SCTPIP—The links in this linkset use the Stream Control Transmission 
Protocol (SCTP) IP transport protocol.

– Serial—The links in this linkset use the serial SS7 signaling protocol.

– Mixed—The links in this linkset are of two or more types. (This 
configuration is not recommended.)
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– Virtual—The links in this linkset are virtual links, which connect 
signaling point instances running on the same device. SGM does not poll 
virtual linksets, nor does it display real-time data or accounting statistics 
for virtual linksets.

– Other—No links have been defined for this linkset.

• Links—Total number of links in the linkset.

• Active Links—Number of links in the linkset that are Active.

• Congested Links—Number of links in the linkset that are Congested.

• Ignored—Indicates whether the linkset is to be included when aggregating 
and displaying SGM status information:

– Clear the checkbox to include the linkset. This is the default setting.

– Select the checkbox to exclude the linkset.

This field can be edited by users with authentication level Power User (Level 
2) and higher.

• Notes—Indicates whether there is a note associated with the linkset.

• Events—Indicates whether there is a recent event associated with the linkset.

– To delete the event icon from SGM displays for a specific linkset, select 
the linkset and click the icon.

– To delete the event icon from SGM displays for all linksets, select 
Edit>Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most linksets with an event icon. If 
the event icons are too distracting, use the Edit>Clear All Events menu 
option to remove them.

• Last Status Change—Date and time that the status of the linkset last 
changed.
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• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.

– Shutdown (blue ball)—An ITP administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.

– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

• Status Reason—Reason for the current status of the linkset. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive
3-103
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Nodes
– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Signaling Points Tab: Links

To view information about the links that are associated with the selected node, 
select the Signaling Points tab. SGM displays the linksets in the top table, and the 
links in the bottom table.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

By default, SGM displays all of the columns in the Link Table except Internal 
ID, Congestion Level, and Last Status Change. To display these columns, or to 
hide other columns, see the procedures in the “Modifying Linkset Table Column 
Settings” section on page 5-18.

The Link Table displays the following information about links that are associated 
with the selected node:

• Internal ID—Internal ID of the link. The internal ID is a unique ID for every 
event, linkset, link, signaling point, and node, assigned by SGM for its own 
internal use. It can also be useful when the TAC is debugging problems.

• Node—Name of the node associated with the link.
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• Signaling Point—Name of the signaling point associated with the link.

• Linkset—Name of the linkset associated with the link.

• SLC—Signaling link code (SLC) ID for the link.

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTPIP—The link uses the Stream Control Transmission Protocol 
(SCTP) IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Congestion Level—Indicates whether there is congestion on the link. A link 
is congested if it has too many packets waiting to be sent. This condition 
could be caused by the failure of an element in your network.

Possible values for the Congestion Level field are:

– None—The link is not congested.

– Low—The link is slightly congested.

– High—The link is congested.

– Very High—The link is very congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.

• Ignored—Indicates whether the link is to be included when aggregating and 
displaying SGM status information:

– Clear the checkbox to include the link. This is the default setting.

– Select the checkbox to exclude the link.

This field can be edited by users with authentication level Power User (Level 
2) and higher.

• Notes—Indicates whether there is a note associated with the link.
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• Events—Indicates whether there is a recent event associated with the link.

– To delete the event icon from SGM displays for a specific link, select the 
link and click the icon.

– To delete the event icon from SGM displays for all links, select 
Edit>Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most links with an event icon. If the 
event icons are too distracting, use the Edit>Clear All Events menu 
option to remove them.

• Last Status Change—Date and time that the status of the link last changed.

• Status—Current status of the link. Possible values are:

– Active (green ball)—The link is currently fully functional.

– Blocked (red ball)—Traffic on this link is disabled by protocol.

– Failed (red ball)—An error is preventing traffic from flowing on this 
link, or the associated linkset has been set to Shutdown status.

A link can be Failed from an MTP3 perspective, but control messages 
might still be sent or received on the link, resulting in changing 
packet/second and bit/second rates. The rates might also be different at 
each end of the link, depending on the reason for the failure and the 
timing related to each endpoint.

– InhibitLoc (blue ball)—A local ITP administrator has set the link to 
prevent traffic from flowing.

– InhibitRem (blue ball)—A remote ITP administrator has set the link to 
prevent traffic from flowing.

– Shutdown (blue ball)—An ITP administrator has set the link to prevent 
traffic from flowing.
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– Unknown (red ball)—Either the node associated with this link has failed 
to respond to an SNMP request, or SGM found that the link no longer 
exists.

When you physically delete a link, the Status field displays Unknown 
until you delete the link from the SGM database.

– Warning (yellow ball)—The link is active and traffic is flowing, but one 
or more of the following situations has occurred:

– The link is congested.

– The link has exceeded the defined Receive Utilization % or Send 
Utilization %.

– One or more of the local or remote IP addresses defined for SCTP is 
not active.

• Status Reason—Reason for the current status of the link. Possible values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive
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– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Configuration Data Tab: Naming Information

To view naming information for the selected node, select the Configuration Data 
tab.

The Naming Information sub-section displays the following information for the 
selected node:

• Display Name—Name of the node.

• IP Address or DNS Hostname—IP address or DNS name of the node, as 
discovered by SGM. However, if you modified your preferences to identify 
nodes by their IP addresses, then that is how the node is identified in this 
field. For more information, see the “Modifying Preference Settings” section 
on page 5-3.

• CLLI Code—COMMON LANGUAGE Location Identification Code for the 
node. A CLLI code is a standardized 11-character identifier that uniquely 
identifies the geographic location of the node. If the node has no CLLI code 
configured, this field is blank.

• Icon Name—Name of the graphic icon to assign to this node in topology 
maps. SGM automatically assigns an appropriate icon to each discovered 
Cisco ITP, and to Unknown nodes, but you can use this field to assign a 
different icon.

When SGM discovers a single-instance node, it assigns the icon that 
corresponds to the node. When SGM discovers a multi-instance node, it 
assigns a separate icon for each unique signaling point instance.
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Valid values are:

– Cisco2600—Cisco 2650, Cisco 2650XM, Cisco 2651, Cisco 2651XM

– Cisco7204—Cisco 7204, Cisco 7204VXR

– Cisco7206—Cisco 7206, Cisco 7206VXR

– Cisco7507—Cisco 7507, Cisco 7507mx, Cisco 7507z

– Cisco7513—Cisco 7513, Cisco 7513mx, Cisco 7513z

– IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

– MSC—Mobile switching center. You can assign this icon to an unknown 
node if you know that it is an MSC.

– SCP—Service control point. You can assign this icon to an unknown 
node if you know that it is an SCP.

– SSP—Service switching point. You can assign this icon to an unknown 
node if you know that it is an SSP.

– STP—Signal transfer point. You can assign this icon to an unknown node 
if you know that it is an STP.

– SignalingPoint—An SCP, SSP, or STP, or an ITP instance.

– Unknown—SGM is unable to determine the node type.

• Device Type—Device type of the node. Possible values are:

– Cisco2650—Cisco 2650 series router

– Cisco2650XM—Cisco 2650XM series router

– Cisco2651—Cisco 2651 series router

– Cisco2651XM—Cisco 2651XM series router

– Cisco7204—Cisco 7204 series router

– Cisco7204VXR—Cisco 7204VXR series router

– Cisco7206—Cisco 7206 series router

– Cisco7206VXR—Cisco 7206VXR series router

– Cisco7507—Cisco 7507 series router

– Cisco7507mx—Cisco 7507mx series router

– Cisco7507z—Cisco 7507z series router
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– Cisco7513—Cisco 7513 series router

– Cisco7513mx—Cisco 7513mx series router

– Cisco7513z—Cisco 7513z series router

– IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

– Unknown—SGM is unable to determine the device type.

• Last Status Change—Date and time that the status of the node last changed.

• Status—Current status of the node. Possible values are:

– Active (green ball)—The node is currently fully functional.

– Discovering (gray ball)—The node is being discovered, and SNMP 
queries have been sent to the device.

– Polling (gray ball)—The node is being polled.

– Unknown (red ball)—The node failed to respond to an SNMP request. 
SGM sets all associated signaling points, linksets, and links to 
Unknown.

– Unmanaged (gray ball)—One of the following situations exists:

– The node is known indirectly by SGM. In other words, SGM knows the 
device exists but there is no known SNMP stack on the device for SGM 
to query.

– An SGM user has set the node to Unmanaged status, to prevent SGM 
from polling the node.

If the associated signaling points are referenced via linksets to other 
signaling points, SGM automatically sets all associated signaling points 
to Unmanaged, and deletes all associated linksets and links, as well as 
all linksets and links that reference the node as an adjacent node.

If the associated signaling points are not referenced to other signaling 
points, SGM automatically deletes the signaling points, all associated 
linksets and links, and all linksets and links that reference the node as an 
adjacent node.
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– Waiting (gray ball)—The node is in the Discovery queue but is not 
currently being discovered.

– Warning (yellow ball)—The node is active, but one or more associated 
signaling points, linksets, or links is in Failed, Unavailable, Unknown, 
or Warning status and is not Ignored.

• Status Reason—Reason for the current status of the node. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.
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If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Configuration Data Tab: Descriptive Information

To view descriptive information for the selected node, select the Configuration 
Data tab.

The Descriptive Information sub-section displays the following information for 
the selected node:

• MIB Level—MIB conformance level used by the ITP, such as ITP MB5.

Note ITP Version and MIB Level might not have a one-to-one 
correspondence, because multiple ITP versions can use the same MIB 
level if there are no changes to the MIBs between versions. For example, 
ITP versions 12.2(4)MB5 and 12.2(4)MB6 both use MIB level ITP MB5.

• ITP Version—Version of IOS that is installed on the ITP.

Configuration Data Tab: IP Addresses for SNMP

To view SNMP IP address information for the selected node, select the 
Configuration Data tab.

The IP Addresses for SNMP sub-section displays the following information for 
the selected node:

• IP Address—IP addresses associated with this node, including the primary 
SNMP address and all backup IP addresses, that are intended for SNMP.

• Last Regular Poll Time—Date and time of the last full poll of the node for 
ITP-related MIBs (as opposed to a demand poll for just one linkset’s worth of 
data).

If the IP address has never been polled, SGM displays the phrase Never 
Polled.

If there are no IP addresses defined for the node that are intended for SNMP, this 
field displays the phrase There are no other IP addresses defined for this node.
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Configuration Data Tab: IP Addresses Not for SNMP

To view non-SNMP IP address information for the selected node, select the 
Configuration Data tab.

The IP Addresses Not for SNMP sub-section displays the following information 
for the selected node:

• IP Address—IP addresses associated with this node that are not intended for 
SNMP.

If there are no IP addresses defined for the node that are not intended for SNMP, 
this field displays the phrase There are no other IP addresses defined for this 
node.

Configuration Data Tab: ITP Uptime Information

To view ITP uptime information for the selected node, select the Configuration 
Data tab.

The ITP Uptime Information sub-section displays the following information for 
the selected node:

• ITP Uptime—Time the ITP has been up, in weeks, days, hours, minutes, and 
seconds.

• Reboot Reason—Reason for the last reboot of the ITP.

Configuration Data Tab: Polling Information

To view polling information for the selected node, select the Configuration Data 
tab.

The Polling Information sub-section displays the following information for the 
selected node:

• First Discovered—Date and time that the node was first discovered by SGM.

• Last Poll IP Address—Last IP address that was polled for this node. For a 
non-ITP node, this field is left blank.

• Last Full Poll Time—Date and time of the last full poll of the node for 
ITP-related MIBs (as opposed to a demand poll for just one linkset’s worth of 
data). For a non-ITP node, this field is left blank.
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• Last SGM Poll Response (secs)—Time, in seconds, taken by this node to 
respond to the last SGM poll request. For a non-ITP node, this field is left 
blank.

• Avg. SGM Poll Response (secs)—Average time, in seconds, taken by this 
node to respond to SGM poll requests. For a non-ITP node, this field is left 
blank.

Notes Tab

To view notes for the selected node, select the Notes tab.

The Notes section displays:

• Notes associated with the node.

• The date and time the notes associated with the node were last updated, or the 
phrase Not Set if there are no notes associated with the node.

• The phrase No Notes if there are no notes associated with the node.
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Recent Events Tab

To view information about all recent events associated with the node, select the 
Recent Events tab. SGM displays the Recent Events table for the node 
(Figure 3-25).

Figure 3-25 Recent Events Table for a Node

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Ack Time, Node, SP, Linkset, and Link. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Event 
Table Column Settings” section on page 5-19.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.
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The Recent Events section enables you to perform event-related tasks, such as 
setting filters and acknowledging events. For more information about these tasks, 
see the “Working with Events” section on page 3-235.

The Recent Events table displays the following information for the selected node:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.

– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.
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– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.
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• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

Syslog Tab

To view all messages in the ITP system log for the selected node, select the Syslog 
tab.

The Syslog table displays the following information for the selected node:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• Timestamp—Date and time of the syslog message from the ITP.

• Severity—Severity of the syslog message. Possible values are:

– Alert—Messages that require immediate action.

– Critical—Critical conditions.

– Debug—Debug messages, log FTP commands, and WWW URLs.

– Emergency—System unusable messages.

– Error—Error messages.

– Info—Information messages.

– Notice—Normal but significant conditions.

– Warning—Warning messages.

• Facility—Name of the facility that generated the syslog message, such as 
SYS, SNMP, CS7MTP3, or CS7PING.

• Name—Short text identifier for the message type. A facility name in 
conjunction with a message name uniquely identifies a syslog message type.

• Message—Text of the syslog message.
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CPU Processes Tab

To view CPU utilization information for the selected node, select the CPU 
Processes tab.

The CPU Processes table is not available if the node is in Discovery, Polling, 
Unknown, or Unmanaged status.

The CPU Processes table displays one CPU Utilization Percentage table for each 
active Route Switch Processor (RSP) CPU.

The CPU Utilization Processes table displays the following information for the 
selected node:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• PID—Process identifier.

• Name—Name of the process.

• Time Created—Total time since the process was created.

• Total Runtime—CPU time the process has used.

• Times Invoked—Number of times the process has been invoked.

• Average Runtime—Average CPU time for each process invocation.

• 5 Sec %—Average CPU utilization percentage for the node over the last 
5 seconds.

• 1 Min %—Average CPU utilization percentage for the node over the last 
minute.

• 5 Min %—Average CPU utilization percentage for the node over the last 
5 minutes.

• Priority—Process queue priority. Possible values are:

– Low

– Normal

– High

– Critical
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Trap Host Configuration

To view all trap settings for the selected node, as well as all hosts and port 
numbers to which the node sends traps, select the Trap Host Configuration tab.

If you have implemented SGM User-Based Access, this option is available to 
users with authentication level System Administrator (Level 5) and higher.

The Trap Host Configuration table displays the following information for the 
selected node:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• Release 2 Trap Settings—Indicates whether the following ITP release 
12.2(4)MB4 trap settings are enabled:

– SCTP Remote Address Change

– Linkset State Change

– Link State Change

– Link Congestion State Change

– Link Receive Utilization Change

– Link Send Utilization Change

– Route State Change

– GTT MAP State Change

• Release 3 Trap Settings—Indicates whether the following ITP release 
12.2(4)MB5 through 12.2(4)MB9a trap settings are enabled:

– ASP State Change

– AS State Change

– SGMP State Change

This column might not be displayed if the ITP does not support ITP release 
12.2(4)MB5 through 12.2(4)MB9a traps.
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• Release 4 Trap Settings—Indicates whether the following ITP release 
12.2(4)MB10 trap settings are enabled:

– Linkset State Change

– Link State Change

– Link Congestion State Change

– Link Receive Utilization Change

– Link Send Utilization Change

– Route Destination State Change

– Route Mgmt. State Change

– Route Table Load

– GTT MAP State Change

– GTT Table Load

– ASP Congestion Change

– SGMP Congestion Change

This column might not be displayed if the ITP does not support ITP release 
12.2(4)MB10 traps.

• IP Address—IP address of a host to which the node sends traps.

• Port—Port to which the node sends traps.

• Trap Version—Trap version sent to this IP address and port.

• Community String—SNMP community name used by the node for read 
access to the information maintained by the SNMP agent on the ITP.

Viewing CPU Statistics for a Node
SGM enables you to display the CPU utilization percentage for a node as a 
function of time. SGM displays one CPU Utilization Percentage chart for each 
active Route Switch Processor (RSP) CPU.

To display CPU Utilization Percentage charts for a node, right-click a node in a 
window, then select View > Real-Time Data and Charts from the right-click 
menu. (This option is available only if SGM can poll the node.) SGM displays the 
SGM Real-Time Statistics: CPU Statistics window (Figure 3-26).
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Figure 3-26 SGM Real-Time Statistics: CPU Statistics Window

The SGM Real-Time Statistics: CPU Statistics window displays the following 
information for the selected node:

• Node—Name of the node for which CPU statistics are being displayed. To 
see detailed information for the node, click the node name.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the CPU Utilization Chart. Valid selections are 1, 2, 5, 10, 
20, 40, or 60 minutes. The default selection is 5 minutes.

• Last Poll Error—Date and time the last polling error message was received 
by the node. If there have been no polling errors, SGM displays None.
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• CPU Utilization Chart—Displays the CPU utilization percentage for the 
node as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the CPU utilization percentage for that data point.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• Time Average—Displays three color-coded icons, one for each average 
calculation: 5 seconds, 1 minute, and 5 minutes.

To remove the data for a given average from the chart, click the icon in this 
field. To return the data to the chart, click the icon again.

• Reset—If you scrolled or zoomed the chart, resets the chart to the default 
view and scaling.

• Grid On—Superimposes a graphic grid on the chart. The grid can make the 
data easier to read.

• Grid Off—Removes the graphic grid from the chart.

• Close—Closes the SGM Real-Time Statistics: CPU Statistics window.

• Help—Displays online help for the current window.
3-123
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Nodes
Editing a Node
SGM enables you to edit the following aspects of a node:

• Editing Node Properties, page 3-124

• Attaching a Note to a Node, page 3-126

• Editing SNMP IP Addresses for a Node, page 3-127

Editing Node Properties

To edit a node’s properties, such as its name, telnet address, or associated icon, 
right-click the node in a window, select Edit>Properties in the right-click menu. 
SGM displays the Edit Properties Dialog for a Node (Figure 3-27).

Figure 3-27 Edit Properties Dialog for a Node

By default, the Name field displays the node’s DNS name, as discovered by SGM. 
However, if you modified your preferences to identify nodes by their 
IP addresses, then that is how the node is identified in this field. For more 
information, see the “Modifying Preference Settings” section on page 5-3.

You can also use the Name field to specify a new, more meaningful name for the 
node, keeping in mind the following considerations:

• You can change an ITP node's name to a new name or IP address.

• A new name can be from 1 to 30 characters, and can contain any letters, 
numbers, or special characters, but no periods (.). If you enter a name that 
contains a period, SGM beeps and retains the current name.
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• A new IP address must use the x.x.x.x format, where x is between 0 and 255, 
and must contain only numbers and periods, but no letters or special 
characters. If you enter an IP address that contains any letters or special 
characters, SGM beeps and retains the current name.

• If you leave the Name field blank, SGM reverts to the node’s default name 
(the DNS name for an ITP node, the point code for a non-ITP node).

• The new node name is used when launching context-based applications, such 
as CiscoWorks2000. Therefore, if the new name you enter is not the node’s 
DNS name, and the application knows the node by its DNS name, context 
links into the application for that node might not work.

You can use the Telnet Address field to specify a new Telnet IP address and 
optional port number, to pass to the Telnet command. If you specify a port 
number, separate the IP address from the port number with a space, such as: 
sgm-sun8.cisco.com 2048

The Icon Name drop-down list box displays the name of the graphic icon to 
assign to this node in topology maps. SGM automatically assigns an appropriate 
icon to each discovered Cisco ITP, and to Unknown nodes, but you can use this 
field to assign a different icon (for example, if you know that a given Unknown 
node is a mobile switching center).

When SGM discovers a single-instance node, it assigns the icon that corresponds 
to the node. When SGM discovers a multi-instance node, it assigns a separate icon 
for each unique signaling point instance.

Valid values are:

• Cisco2600—Cisco 2650, Cisco 2650XM, Cisco 2651, Cisco 2651XM

• Cisco7204—Cisco 7204, Cisco 7204VXR

• Cisco7206—Cisco 7206, Cisco 7206VXR

• Cisco7507—Cisco 7507, Cisco 7507mx, Cisco 7507z

• Cisco7513—Cisco 7513, Cisco 7513mx, Cisco 7513z

• IPDevice—IP device, other than those listed above. You can assign this icon 
to an unknown node if you know that it is an IP device.

• MSC—Mobile switching center. You can assign this icon to an unknown 
node if you know that it is an MSC.

• SCP—Service control point. You can assign this icon to an unknown node if 
you know that it is an SCP.
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• SSP—Service switching point. You can assign this icon to an unknown node 
if you know that it is an SSP.

• STP—Signal transfer point. You can assign this icon to an unknown node if 
you know that it is an STP.

• SignalingPoint—An SCP, SSP, or STP, or an ITP instance.

• Unknown—SGM is unable to determine the node type.

At any time, you can click Cancel to exit the dialog without saving any changes.

When you are satisfied with your changes, click Save. SGM saves your changes 
and updates all SGM windows to reflect your changes.

Attaching a Note to a Node

To attach a note to a node, right-click the node in a window, then select 
Edit>Notes in the right-click menu. SGM displays the Edit Notes Dialog for a 
Node (Figure 3-28).

Figure 3-28 Edit Notes Dialog for a Node
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The Note Last Updated field displays the date and time the Notes field for this 
node was last updated. If there is no note currently associated with this node, this 
field displays the value Not Set.

In the Notes field, enter any important information about the node, such as a 
detailed description, its location, its service history, and so on. When you annotate 
a node, the topology map in the Topology window displays a note icon in the 
upper left corner of the node element.

At any time, you can click Cancel to exit the dialog without saving any changes.

When you are satisfied with your changes, click Save. SGM saves your changes 
and updates all SGM windows to reflect your changes.

Editing SNMP IP Addresses for a Node

SGM enables you to determine which IP addresses are to be used for SNMP 
polling.

To edit a node’s SNMP IP addresses, right-click an ITP node in a window, select 
Edit>SNMP IP Addresses in the right-click menu. SGM displays the Edit 
SNMP IP Addresses Dialog.

The IP Addresses for SNMP field lists all IP addresses associated with this ITP 
node that SGM can use for SNMP polling:

• By default, SGM places all discovered IP addresses in this list, in the order 
in which they are discovered. SGM uses the IP address at the top of the list as 
the primary SNMP address for the node.

During SNMP polling of the node (both status polling and demand polling), 
SGM first tries the primary SNMP address. If the primary is unavailable, 
SGM tries the other IP addresses, one-by-one, in descending order.

• To assign a new primary SNMP address, or to change the order of the 
secondary IP addresses, use the Raise Priority and Lower Priority buttons 
to move the IP addresses up and down in the list.
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• You can also select IP addresses that you do not want SGM to use for SNMP 
polling. This is useful, for example, to separate management traffic from 
SMS traffic. To remove an IP address from the list, click Remove. The IP 
address is removed from the IP Addresses for SNMP list and appears in the 
Available ITP IP Addresses list, and is no longer used by SGM for SNMP 
polling. The Available ITP IP Addresses field lists all P addresses associated 
with this ITP node that you do not want SGM to use for SNMP polling. SGM 
does not send SNMP queries to IP addresses in this list.

To enable an IP address for SNMP polling again, select the address in the 
Available ITP IP Addresses list and click Add. The IP address moves back 
into the IP Addresses for SNMP list and is again available for SNMP 
polling.

If you remove all IP addresses from the IP Addresses for SNMP list, the 
node is effectively removed from the network, and SGM automatically labels 
the node Unmanaged in all SGM windows.

At any time, you can click Cancel to exit the dialog without saving any changes.

When you are satisfied with your changes, click Save. SGM saves your changes 
and updates all SGM windows to reflect your changes.

Viewing Notes for a Node
SGM enables you to view the notes that have been attached to nodes.

To view a note, right-click a node in a window, then select View> Notes in the 
right-click menu. (The Notes option is grayed-out if there is no note associated 
with the selected node.) SGM displays the Notes for Node dialog (Figure 3-29).
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Figure 3-29 Notes for Node Dialog

The Notes for Node dialog displays the following information:

• The name of the node is displayed in the title of the window (for example, 
Notes for sgm-2600a.)

• Last Updated—Date and time the Notes field for the node was last updated.

• Notes—Notes associated with the node.

Click OK to close the Notes for Node dialog.
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Deleting a Node
After Discovery, the nodes in your network are known to SGM and added to the 
SGM database. Physically deleting nodes from your network is not the same as 
deleting them from the SGM database. The following sections describe the 
differences between deleting nodes from your network, from the SGM database, 
and from the SGM Discovery database, and the procedures for doing so:

• Deleting a Node from Your Network, page 3-130

• Deleting a Node from the SGM Database, page 3-130

• Deleting a Node from the SGM Discovery Database, page 3-132

Deleting a Node from Your Network

If you physically delete a known node from your network (for example, by 
powering down an ITP), it remains in the SGM database, SGM labels it 
Unknown, and it is the system administrator’s responsibility to delete it from the 
SGM database, if you choose to do so. SGM also labels all associated linksets and 
links Unknown because SGM attempts to poll the node and gets no response.

Deleting a Node from the SGM Database

Typically, you delete a node from the SGM database for one of the following 
reasons:

• You have physically deleted the node from your network. This is the most 
common reason for deleting a node from the SGM database.

• The node is Unknown or Unmanaged, you are aware of the reason, and you 
no longer want to see it in SGM displays. For example, the node might be a 
test lab device.

• If you delete all linksets to an Unmanaged node, SGM does not 
automatically delete the node. Instead, you must manually delete the node.

If you have physically deleted a known node from your network, and you then 
delete it from SGM, it is no longer in the SGM database, it does not appear in 
SGM windows, and it is not discovered when you run Discovery.
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Be aware of the following special situations:

• If you have not physically deleted a known node from your network, and you 
delete it from SGM, SGM removes the node from the poll list, and at the next 
poll SGM returns the node to the DEFAULT view, and labels the node as a 
new node if you are using a custom view.

• If a node has at least one adjacent node in Active, Discovering, Waiting, or 
Warning state, you cannot delete the node. If you try to do so, SGM cancels 
the deletion.

If either of these situations occurs, do not delete the node again. Instead, perform 
one of the following actions:

• Label the node Unmanaged. See the “Unmanaging and Managing a Node” 
section on page 3-133 for more details.

• Remove the node from your view. See the “Working with Views” section on 
page 3-26 for more details.

Note If you delete a node from the SGM database, the node is deleted for all SGM 
clients and views connected to that SGM server.

To delete a node from the SGM database, use one of the following procedures:

• Select one or more nodes in a window, then select Edit > Delete from the 
SGM Main Menu.

• Right-click a node in a window, then select Delete Item in the right-click 
menu. (You cannot delete more than one node at a time from the right-click 
menu.)

SGM asks you to confirm the deletion:

• Select Yes to delete the selected nodes. SGM deletes the nodes from the SGM 
database.

• Select No to return to the window without deleting any nodes from the SGM 
database.

You can also use the sgm delete node command to delete one or more nodes from 
the SGM database. See the “SGM Commands and Descriptions” section on 
page B-2 for more information on the use of this command.
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Note If you delete a node, SGM removes it from the Nodes In Current View table of the 
Network View Editor window. If SGM then rediscovers the node, SGM places it 
in the New Nodes Found table of the Network View Editor window. To restore the 
node to your current view, you must move it into the Nodes In Current View table. 
For more information, see the “Working with Views” section on page 3-26.

Deleting a Node from the SGM Discovery Database

If you want to completely eliminate a given node from the SGM database, you can 
delete it from the SGM Discovery database, ensuring that it is never even 
discovered by SGM.

Note If you delete a node from the SGM Discovery database, the node is deleted for all 
SGM clients and views connected to that SGM server.

To delete a node from the SGM Discovery database:

Step 1 Select Edit > Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Discovery tab. SGM displays the Discovery panel (Figure 3-4).

Step 3 In the Discovered Nodes table, select the node or nodes you want to delete.

Step 4 Click Delete Node. SGM deletes the nodes from the Discovery database, without 
asking for confirmation. The nodes will no longer be discovered by SGM.
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Unmanaging and Managing a Node
SGM enables you to label a node Unmanaged, and to remove the Unmanaged 
status from a node.

In some situations, you might not want to see a given node or nodes in SGM 
displays, but you might be unable to delete it from the SGM database. For 
example:

• If you have not physically deleted a known node from your network, and you 
delete it from SGM, SGM removes the node from the poll list, and at the next 
poll SGM returns the node to the DEFAULT view, and labels the node as a 
new node if you are using a custom view.

• If a node has at least one adjacent node in Active, Discovering, Waiting, or 
Warning state, you cannot delete the node. If you try to do so, SGM cancels 
the deletion.

If these situations, you can label the node Unmanaged. When you label a node 
Unmanaged, SGM removes the node from the poll list.

Note If you label a node Unmanaged, the node is Unmanaged for all SGM clients and 
views connected to that SGM server.

To label a node Unmanaged:

Step 1 Select a node in a window.

You cannot label a node Unmanaged if it has a Device Type of Unknown:

• If you select a node with a Device Type of Unknown, then this menu option 
is grayed-out and cannot be selected.

• If you select more than one node, and at least one of them has a Device Type 
of Unknown, then this menu option is grayed-out and cannot be selected.

Step 2 Select Edit > Unmanage from the SGM Main Menu, or Unmanage from the 
right-click menu. SGM labels the selected node Unmanaged and removes it from 
the poll list.
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You can also remove the Unmanaged status from a node, when you are ready to 
return the node to the SGM poll list. To remove the Unmanaged status from a 
node:

Step 1 Select a node in a window.

You cannot remove the Unmanaged status from a node with a Device Type of 
Unknown:

• If you select a node with a Device Type of Unknown, then this menu option 
is grayed-out and cannot be selected.

• If you select more than one node, and at least one of them has a Device Type 
of Unknown, then this menu option is grayed-out and cannot be selected.

Step 2 Select Edit > Manage from the SGM Main Menu, or Manage from the right-click 
menu. SGM removes the Unmanaged status from the selected node, returns it to 
the poll list, and polls it immediately.

Polling a Node
SGM automatically polls nodes at specified intervals. However, you can also 
request an immediate poll for a node.

To poll a node from the Discovery Dialog, use the following procedure:

Step 1 Select Edit > Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Discovery tab. SGM displays the Discovery panel (Figure 3-5). The 
Discovered Nodes section of the Discovery panel lists all discovered nodes.

Step 3 Select one or more nodes. You cannot poll a node with a Primary SNMP Address 
of N/A:

• If you select a node with a Primary SNMP Address of N/A, then the Poll 
Node button is grayed-out and cannot be selected.

• If you select more than one node, and even one of them has a Primary SNMP 
Address of N/A, then the Poll Node button is grayed-out and cannot be 
selected.
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Step 4 Click Poll Node. SGM begins a poll of the selected nodes. During polling, the 
Poll Node button is grayed-out, the “Selected nodes are being polled” message is 
displayed at the bottom of the Discovery Dialog, and individual nodes might 
display the Polling status.

• If the node has only one IP address for SGM to poll, and the poll fails or times 
out, SGM issues an error message.

• If the node has more than one IP address for SGM to poll, and the polls of one 
or more IP addresses fail or time out, SGM issues warning messages. If all 
polls fail or time out, SGM issues an error message.

Step 5 When the “Selected nodes are being polled” message disappears and no nodes are 
in Polling status, polling is complete. The SGM database immediately reflects 
any new or changed data for the selected nodes.

To poll one or more nodes, retaining all currently known linksets in the SGM 
database, use one of the following procedures:

• Select one or more nodes in a window, then select Edit > Poll Nodes > 
Normal Poll in the SGM Main Menu. SGM polls all selected ITP nodes.

• Select one or more linksets in a window, then select Edit > Poll Nodes > 
Normal Poll in the SGM Main Menu. SGM polls all primary and adjacent 
ITP nodes associated with the selected linksets.

• Select an ITP node or adjacent node in the Details Window, then select Edit 
> Poll Nodes > Normal Poll in the SGM Main Menu. SGM polls that node.

• Select a linkset or link in the Details Window, then select Edit > Poll Nodes 
> Normal Poll in the SGM Main Menu. SGM polls the ITP node and adjacent 
node associated with the linkset or link.

• Right-click an ITP node in a window, then select Poll Node > Normal Poll 
in the right-click menu. SGM polls the node.

Normal Poll retains all linksets associated with polled nodes, even linksets that 
have been deleted and are therefore in Unknown status.
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To poll one or more nodes, removing and then rediscovering all associated 
linksets, use one of the following procedures:

• Select one or more nodes in a window, then select Edit > Poll Nodes > Clean 
Poll in the SGM Main Menu. SGM polls all selected ITP nodes.

• Select one or more linksets in a window, then select Edit > Poll Nodes > 
Clean Poll in the SGM Main Menu. SGM polls all primary and adjacent ITP 
nodes associated with the selected linksets.

• Select an ITP node or adjacent node in the Details Window, then select Edit 
> Poll Nodes > Clean Poll in the SGM Main Menu. SGM polls that node.

• Select a linkset or link in the Details Window, then select Edit > Poll Nodes 
> Clean Poll in the SGM Main Menu. SGM polls the ITP node and adjacent 
node associated with the linkset or link.

• Right-click an ITP node in a window, then select Poll Node > Clean Poll in 
the right-click menu. SGM polls the node.

Clean Poll removes all associated linksets before polling the nodes.

Excluding a Node from a View
To exclude a node from the current view, right-click the node in a window, then 
select Exclude from View in the right-click menu. SGM excludes the node from 
the current view. See the “Creating a View” section on page 3-27 for more 
information about excluding nodes from views.

Working with Signaling Points
SGM enables you to view information about all discovered signaling points, 
including their associated nodes, status, and other important information.

Note In a multi-instance network, the signaling point name has the format 
pointcode:instanceName.

In a multi-instance network, SGM does not display signaling points that are only 
partly configured (that is, the variant and network name are configured, but not 
the primary point code).
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This section includes the following information:

• Viewing Basic Information for Signaling Points, page 3-137

• Viewing Detailed Information for a Signaling Point, page 3-141

• Editing a Signaling Point, page 3-162

• Viewing Notes for a Signaling Point, page 3-166

• Deleting a Signaling Point, page 3-167

• Unmanaging and Managing a Signaling Point, page 3-169

• Excluding a Signaling Point from a View, page 3-170

Related Topics:

• Modifying Preference Settings, page 5-3

• Resizing, Sorting, and Hiding Table Columns, page 3-279

• Viewing the Topology of the Network, page 3-259

• Working with Links, page 3-170

• Working with Linksets, page 3-37

• Working with Nodes, page 3-91

Viewing Basic Information for Signaling Points
To view basic information for signaling points, select Signaling Points in the left 
pane of the SGM Main Window. SGM displays the Signaling Point Window 
(Figure 3-30).
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Figure 3-30 Signaling Point Window

The Signaling Point Window displays information about the signaling points that 
have been discovered by SGM.

By default, SGM displays all of the columns in the Signaling Point Window 
except Internal ID, Instance ID, and Last Status Change. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Linkset 
Table Column Settings” section on page 5-18.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.
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The Signaling Point Window displays the following information for all 
discovered signaling points:

• Internal ID—Internal ID of the signaling point. The internal ID is a unique 
ID for every event, link, linkset, node, and signaling point, assigned by SGM 
for its own internal use. It can also be useful when the TAC is debugging 
problems.

• Name—Name of the signaling point.

• Node—Name of the node associated with this signaling point.

• Instance ID—ID of the instance associated with the signaling point.

• Instance Name—Name of the instance associated with the signaling point.

• Point Code—Primary point code of the signaling point.

• Variant—SS7 protocol variant. Valid variants are:

– ANSI

– China

– ITU

• Network Indicator—Determines the type of call that is being placed. Valid 
values are:

– National—National-bound call. SGM routes national calls through the 
national network.

– NationalSpare—National-bound call, used in countries in which more 
than one carrier can share a point code. In those countries, networks are 
differentiated by the Network Indicator.

– International—International-bound call. SGM forwards 
international-bound calls to an STP pair that acts as an international 
gateway.

– InternationalSpare—International-bound call, used in countries in 
which more than one carrier can share a point code. In those countries, 
networks are differentiated by the Network Indicator.

• Notes—Indicates whether there is a note associated with the signaling point.
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• Events—Indicates whether there is a recent event associated with the 
signaling point.

During Discovery, SGM might flag most signaling points with an event icon. 
If the event icons are too distracting, select Edit > Clear All Events from the 
SGM Main Menu to remove them.

• Last Status Change—Date and time that the status of the signaling point last 
changed.

• Status—Current status of the signaling point. Possible values are:

– Active (green ball)—The signaling point is currently fully functional.

– Unknown (red ball)—One of the following conditions occurred:

– SGM cannot poll the node associated with the signaling point. SGM 
sets all signaling points, linksets, and links associated with the node to 
Unknown.

– The signaling point has been unconfigured on the ITP, or the 
configuration is incomplete. At the next poll, SGM determines that the 
signaling point does not exist, and sets the signaling point and all 
associated linksets and links to Unknown.

– Unmanaged (gray ball)—An SGM user has set the signaling point to 
Unmanaged status, to prevent SGM from polling the signaling point. 
SGM automatically deletes all associated links and linksets.

– Warning (yellow ball)—The signaling point is active, but one or more 
associated links or linksets is in Failed, Unavailable, Unknown, or 
Warning status and is not flagged as Ignored.

• Status Reason—Reason for the current status of the signaling point. Possible 
values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP
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– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Viewing Detailed Information for a Signaling Point
SGM can display detailed information about a selected signaling point, including 
its associated linksets, links, status, and other information.

To display detailed information for a signaling point, use one of the following 
procedures:

• Select Signaling Points in the left pane of the SGM Main Window, 
right-click a signaling point in the right pane, then select 
View >Configuration Details in the right-click menu.

• Select the turner beside Signaling Points in the left pane of the SGM Main 
Window, then select a signaling point.
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SGM displays the Signaling Point Details Window (Figure 3-31).

Figure 3-31 Signaling Point Details Window

Updates for the signaling point that are received from the SGM server are 
reflected automatically in this window.

Changes you make in this window might not be reflected throughout SGM until 
the next poll (by default, every 15 seconds). For information about changing the 
polling interval, see the “Viewing Detailed Information for a Linkset” section on 
page 3-42.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

Linksets Tab: Linksets

To view information about the linksets that are associated with the selected 
signaling point, select the Linksets tab. SGM displays the linksets in the top table, 
and the links in the bottom table.
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To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

Linksets that are associated with nodes that are excluded from the current view 
are not displayed in the Linkset Table. See the “Creating a View” section on 
page 3-27 for more information about excluding nodes.

By default, SGM displays all of the columns in the Linkset Table except Internal 
ID, Congestion Links, and Last Status Change. To display these columns, or to 
hide other columns, see the procedures in the “Modifying Linkset Table Column 
Settings” section on page 5-18.

The Linkset Table displays the following information about linksets that are 
associated with the selected signaling point:

• Internal ID—Internal ID of the linkset. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Name—Name of the linkset.

• Local Point Code—Point code of the primary node for the linkset.

• Adj Point Code—Point code of the adjacent node for the linkset.

• Linkset Type—Type of linkset, which SGM determines by examining the 
links defined in the linkset. Possible linkset types are:

– HSL—The links in this linkset use the SS7-over-ATM (Asynchronous 
Transfer Mode) high-speed protocol.

– SCTPIP—The links in this linkset use the Stream Control Transmission 
Protocol (SCTP) IP transport protocol.

– Serial—The links in this linkset use the serial SS7 signaling protocol.

– Mixed—The links in this linkset are of two or more types. (This 
configuration is not recommended.)
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– Virtual—The links in this linkset are virtual links, which connect 
signaling point instances running on the same device. SGM does not poll 
virtual linksets, nor does it display real-time data or accounting statistics 
for virtual linksets.

– Other—No links have been defined for this linkset.

• Links—Total number of links in the linkset.

• Active Links—Number of links in the linkset that are Active.

• Congested Links—Number of links in the linkset that are Congested.

• Ignored—Indicates whether the linkset is to be included when aggregating 
and displaying SGM status information:

– Clear the checkbox to include the linkset. This is the default setting.

– Select the checkbox to exclude the linkset.

This field can be edited by users with authentication level Power User (Level 
2) and higher.

• Notes—Indicates whether there is a note associated with the linkset.

• Events—Indicates whether there is a recent event associated with the linkset.

– To delete the event icon from SGM displays for a specific linkset, select 
the linkset and click the icon.

– To delete the event icon from SGM displays for all linksets, select Edit 
> Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most linksets with an event icon. If 
the event icons are too distracting, use the Edit > Clear All Events menu 
option to remove them.

• Last Status Change—Date and time that the status of the linkset last 
changed.

• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.
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– Shutdown (blue ball)—An ITP administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.

– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

• Status Reason—Reason for the current status of the linkset. Possible values 
are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.
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The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Linksets Tab: Links

To view information about the links that are associated with the selected signaling 
point, select the Linksets tab. SGM displays the linksets in the top table, and the 
links in the bottom table.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

By default, SGM displays all of the columns in the Link Table except Internal 
ID, Congestion Level, and Last Status Change. To display these columns, or to 
hide other columns, see the procedures in the “Modifying Linkset Table Column 
Settings” section on page 5-18.

The Link Table displays the following information about links that are associated 
with the selected signaling point:

• Internal ID—Internal ID of the link. The internal ID is a unique ID for every 
event, linkset, link, signaling point, and node, assigned by SGM for its own 
internal use. It can also be useful when the TAC is debugging problems.

• Node—Name of the node associated with the link.

• Signaling Point—Name of the signaling point associated with the link.

• Linkset—Name of the linkset associated with the link.

• SLC—Signaling link code (SLC) ID for the link.
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• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTPIP—The link uses the Stream Control Transmission Protocol 
(SCTP) IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Congestion Level—Indicates whether there is congestion on the link. A link 
is congested if it has too many packets waiting to be sent. This condition 
could be caused by the failure of an element in your network.

Possible values for the Congestion Level field are:

– None—The link is not congested.

– Low—The link is slightly congested.

– High—The link is congested.

– Very High—The link is very congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.

• Ignored—Indicates whether the link is to be included when aggregating and 
displaying SGM status information:

– Clear the checkbox to include the link. This is the default setting.

– Select the checkbox to exclude the link.

This field can be edited by users with authentication level Power User (Level 
2) and higher.

• Notes—Indicates whether there is a note associated with the link.
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• Events—Indicates whether there is a recent event associated with the link.

– To delete the event icon from SGM displays for a specific link, select the 
link and click the icon.

– To delete the event icon from SGM displays for all links, select Edit > 
Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most links with an event icon. If the 
event icons are too distracting, use the Edit > Clear All Events menu 
option to remove them.

• Last Status Change—Date and time that the status of the link last changed.

• Status—Current status of the link. Possible values are:

– Active (green ball)—The link is currently fully functional.

– Blocked (red ball)—Traffic on this link is disabled by protocol.

– Failed (red ball)—An error is preventing traffic from flowing on this 
link, or the associated linkset has been set to Shutdown status.

A link can be Failed from an MTP3 perspective, but control messages 
might still be sent or received on the link, resulting in changing 
packet/second and bit/second rates. The rates might also be different at 
each end of the link, depending on the reason for the failure and the 
timing related to each endpoint.

– InhibitLoc (blue ball)—A local ITP administrator has set the link to 
prevent traffic from flowing.

– InhibitRem (blue ball)—A remote ITP administrator has set the link to 
prevent traffic from flowing.

– Shutdown (blue ball)—An ITP administrator has set the link to prevent 
traffic from flowing.
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– Unknown (red ball)—Either the node associated with this link has failed 
to respond to an SNMP request, or SGM found that the link no longer 
exists.

When you physically delete a link, the Status field displays Unknown 
until you delete the link from the SGM database.

– Warning (yellow ball)—The link is active and traffic is flowing, but one 
or more of the following situations has occurred:

– The link is congested.

– The link has exceeded the defined Receive Utilization % or Send 
Utilization %.

– One or more of the local or remote IP addresses defined for SCTP is 
not active.

• Status Reason—Reason for the current status of the link. Possible values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive
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– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Configuration Data Tab: Naming Information

To view naming information for the selected signaling point, select the 
Configuration Data tab.

The Naming Information sub-section displays the following information for the 
selected signaling point:

• Name—Name of the signaling point.

• Instance Name—Name of the instance associated with the signaling point.

• Instance ID—ID of the instance associated with the signaling point.

• Icon Name—Name of the graphic icon to assign to this signaling point in 
topology maps. SGM automatically assigns an appropriate icon to each 
discovered Cisco ITP, and to Unknown nodes, but you can use this field to 
assign a different icon.

When SGM discovers a single-instance node, it assigns the icon that 
corresponds to the node. When SGM discovers a multi-instance node, it 
assigns a separate icon for each unique signaling point instance.

Valid values are:

– Cisco2600—Cisco 2650, Cisco 2650XM, Cisco 2651, Cisco 2651XM

– Cisco7204—Cisco 7204, Cisco 7204VXR

– Cisco7206—Cisco 7206, Cisco 7206VXR

– Cisco7507—Cisco 7507, Cisco 7507mx, Cisco 7507z
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– Cisco7513—Cisco 7513, Cisco 7513mx, Cisco 7513z

– IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

– MSC—Mobile switching center. You can assign this icon to an unknown 
node if you know that it is an MSC.

– SCP—Service control point. You can assign this icon to an unknown 
node if you know that it is an SCP.

– SSP—Service switching point. You can assign this icon to an unknown 
node if you know that it is an SSP.

– STP—Signal transfer point. You can assign this icon to an unknown node 
if you know that it is an STP.

– SignalingPoint—An SCP, SSP, or STP, or an ITP instance.

– Unknown—SGM is unable to determine the node type.

• Last Status Change—Date and time that the status of the signaling point last 
changed.

• Status—Current status of the signaling point. Possible values are:

– Active (green ball)—The signaling point is currently fully functional.

– Unknown (red ball)—One of the following conditions occurred:

– SGM cannot poll the node associated with the signaling point. SGM 
sets all signaling points, linksets, and links associated with the node to 
Unknown.

– The signaling point has been unconfigured on the ITP, or the 
configuration is incomplete. At the next poll, SGM determines that the 
signaling point does not exist, and sets the signaling point and all 
associated linksets and links to Unknown.

– Unmanaged (gray ball)—An SGM user has set the signaling point to 
Unmanaged status, to prevent SGM from polling the signaling point. 
SGM automatically deletes all associated links and linksets.

– Warning (yellow ball)—The signaling point is active, but one or more 
associated links or linksets is in Failed, Unavailable, Unknown, or 
Warning status and is not flagged as Ignored.
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• Status Reason—Reason for the current status of the signaling point. Possible 
values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.
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Configuration Data Tab: Description

To view descriptive information for the selected signaling point, select the 
Configuration Data tab.

The Description sub-section contains a description of the signaling point. If the 
signaling point has no description, this sub-section is blank.

Configuration Data Tab: Point Code

To view point code information for the selected signaling point, select the 
Configuration Data tab.

The Point Code sub-section displays the following information for the selected 
signaling point:

• Point Code—Primary point code of the signaling point.

• Variant—SS7 protocol variant. Valid variants are:

– ANSI

– China

– ITU

• Network Indicator—Determines the type of call that is being placed. Valid 
values are:

– National—National-bound call. SGM routes national calls through the 
national network.

– NationalSpare—National-bound call, used in countries in which more 
than one carrier can share a point code. In those countries, networks are 
differentiated by the Network Indicator.

– International—International-bound call. SGM forwards 
international-bound calls to an STP pair that acts as an international 
gateway.

– InternationalSpare—International-bound call, used in countries in 
which more than one carrier can share a point code. In those countries, 
networks are differentiated by the Network Indicator.

• Network Name—Name of the network associated with the signaling point.
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Configuration Data Tab: Capability Point Code

To view capability point code information for the selected signaling point, select 
the Configuration Data tab.

The Capability Point Code sub-section displays the following information for the 
selected signaling point:

• Point Code—Capability point code of the signaling point.

• Variant—SS7 protocol variant. Valid variants are:

– ANSI

– China

– ITU

• Network Indicator—Determines the type of call that is being placed. Valid 
values are:

– National—National-bound call. SGM routes national calls through the 
national network.

– NationalSpare—National-bound call, used in countries in which more 
than one carrier can share a point code. In those countries, networks are 
differentiated by the Network Indicator.

– International—International-bound call. SGM forwards 
international-bound calls to an STP pair that acts as an international 
gateway.

– InternationalSpare—International-bound call, used in countries in 
which more than one carrier can share a point code. In those countries, 
networks are differentiated by the Network Indicator.

• Network Name—Name of the network associated with the signaling point.
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Configuration Data Tab: QoS Information

To view quality of service (QoS) information for the selected signaling point, 
select the Configuration Data tab.

The QoS Information sub-section displays the following information for the 
selected signaling point:

• QoS—Quality of service (QoS) class of the signaling point. Valid QoS 
classes range from 1 through 7. ALL indicates that the signaling point 
accepts all QoS classes.

• ToS—Type of service (ToS) of the signaling point.

• DSCP—IP differentiated-services-code-point (DSCP) of the signaling point.

Notes Tab

To view notes for the selected signaling point, select the Notes tab.

The Notes section displays:

• Notes associated with the signaling point.

• The date and time the notes associated with the signaling point were last 
updated, or the phrase Not Set if there are no notes associated with the 
signaling point.

• The phrase No Notes if there are no notes associated with the signaling point.

Recent Events Tab

To view information about all recent events associated with the signaling point, 
select the Recent Events tab. SGM displays the Recent Events table for the 
signaling point (Figure 3-32).
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Figure 3-32 Recent Events Table for a Signaling Point

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Ack Time, Node, SP, Linkset, and Link. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Event 
Table Column Settings” section on page 5-19.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

The Recent Events section enables you to perform event-related tasks, such as 
setting filters and acknowledging events. For more information about these tasks, 
see the “Working with Events” section on page 3-235.
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The Recent Events table displays the following information for the selected 
signaling point:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.

– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.
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– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.
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• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

ITP Access Lists Tab

To view information about all access lists associated with the selected signaling 
point, select the ITP Access Lists tab.

For each linkset associated with the selected signaling point, the ITP Access Lists 
section displays the following information:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• Linkset—Name of the linkset for which access lists are being displayed.

• In—Inbound access lists for the linkset. If the linkset has no inbound access 
lists, this field displays None.

• Out—Outbound access lists for the linkset. If the linkset has no outbound 
access lists, this field displays None.

• List #—Access list number configured on the node and applied to the linkset. 
ITP uses access list numbers 2700 through 2799.

• Access List—List of commands in the access list.

Route Detail Tab

To view detailed information about routes associated with the selected signaling 
point, including dynamic and shadow routes, select the Route Detail tab.

The Route Detail table displays the following information for the selected 
signaling point:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.
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• Destination Point Code—Destination point code for packets on the selected 
signaling point. The destination point code is the point code to which a given 
packet is routed.

• Mask—Mask length for packets on the selected signaling point. The mask 
length is the number of significant leading bits in the point code. The mask 
length is always 14 for ITU and 24 for ANSI.

• Cost—Cost of the route to the destination, relative to other routes. The valid 
costs range from 1 (lowest cost and highest priority) through 9 (highest cost 
and lowest priority).

• Destination Linkset—Destination linkset associated with the destination 
point code. The destination linkset is also known as the output linkset.

• QoS—Quality of service (QoS) class of the route, as configured by the 
network administrator. Valid QoS classes range from 1 through 7; ALL 
indicates that the route accepts all QoS classes.

• Access—Status of the destination. Possible values are:

– Accessible

– Inaccessible

– Restricted

– Unknown

• Management Status—Accessibility of the destination from the adjacent 
point code at the remote end of the signaling point. Possible values are:

– Allowed—Traffic is allowed on the route without restriction.

– Prohibited—Traffic is prohibited on the route.

– Restricted—Traffic is restricted on the route.

– Unknown—Accessibility cannot be determined.

• Route Status—Status of the route. Possible values are:

– Available

– Restricted

– Unavailable
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GTT MAP Status Tab

To view detailed information about all GTT MAPs associated with the selected 
signaling point, select the GTT MAP Status tab.

The GTT MAP Status table displays the following information for the selected 
signaling point:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• Point Code—Primary point code for the GTT MAP.

• Subsystem Number—Primary subsystem number (SSN) for the GTT MAP.

• Point Code Status—Status of the primary point code. Possible values are:

– Allowed

– Prohibited—Either the point code cannot be reached, or the point code 
is labeled Prohibited by the SCCP protocol.

• Subsystem Number Status—Status of the primary SSN. Possible values are:

– Allowed

– Prohibited—Either the remote subsystem cannot be reached, or the 
subsystem is labeled Prohibited by the SCCP protocol.

• Congestion Level—MTP3 congestion level for the primary point code. 
Possible values are:

– No congestion—Corresponds to None. The link is not congested.

– Congestion level 1—Corresponds to Low. The link is slightly congested.

– Congestion level 2—Corresponds to High. The link is congested.

– Congestion level 3—Corresponds to Very High. The link is very 
congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.
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MTP3 Event Log Tab

To view the most recent MTP3 events associated with the selected signaling point, 
select the MTP3 Event Log tab.

The MTP3 Event Log table displays the following information for the selected 
signaling point:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

• Logged Events—Total number of MTP3 events that have been logged for this 
signaling point.

• Dropped Events—Total number of MTP3 events that have been dropped for 
this signaling point.

• Max Events—Maximum number of events that the event history can contain. 
When event history table is full, the oldest entries are deleted as new entries 
are added.

• Allowed Events—ITP parameter that specifies the absolute maximum for the 
Max Events field. That is, for this ITP device, the Max Events field can 
range from 0 to the value specified by the Allowed Events field.

• Index—Event number, assigned to the event by SGM.

• Message—Message text for the event.

Editing a Signaling Point
SGM enables you to edit the following aspects of a signaling point:

• Editing Signaling Point Properties, page 3-163

• Attaching a Note to a Signaling Point, page 3-165
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Editing Signaling Point Properties

To edit a signaling point’s properties, such as its name or associated icon, 
right-click the signaling point in a window, select Edit> Properties in the 
right-click menu. SGM displays the Edit Properties Dialog for a Signaling Point 
(Figure 3-33).

Figure 3-33 Edit Properties Dialog for a Signaling Point

By default, the Name field displays the signaling point’s point code and network 
name, as discovered by SGM (for example, 1.22.0:net0). However, you can use 
this field to specify a new, more meaningful name for the signaling point, keeping 
in mind the following considerations:

• The new name can be from 1 to 30 characters, and can contain any letters, 
numbers, or special characters. If you enter a name that is longer than 30 
characters, SGM beeps and retains the current name.

• If you leave the Name field blank, SGM reverts to the signaling point’s point 
code, without the network name.

The Icon Name drop-down list box displays the name of the graphic icon to 
assign to this signaling point in topology maps. SGM automatically assigns an 
appropriate icon to each discovered Cisco ITP, and to Unknown signaling points, 
but you can use this field to assign a different icon (for example, if you know that 
a given Unknown signaling point is a mobile switching center).

When SGM discovers a single-instance node, it assigns the icon that corresponds 
to the node. When SGM discovers a multi-instance node, it assigns a separate icon 
for each unique signaling point instance.
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Valid values are:

• Cisco2600—Cisco 2650, Cisco 2650XM, Cisco 2651, Cisco 2651XM

• Cisco7204—Cisco 7204, Cisco 7204VXR

• Cisco7206—Cisco 7206, Cisco 7206VXR

• Cisco7507—Cisco 7507, Cisco 7507mx, Cisco 7507z

• Cisco7513—Cisco 7513, Cisco 7513mx, Cisco 7513z

• IPDevice—IP device, other than those listed above. You can assign this icon 
to an unknown signaling point if you know that it is an IP device.

• MSC—Mobile switching center. You can assign this icon to an unknown 
signaling point if you know that it is an MSC.

• SCP—Service control point. You can assign this icon to an unknown 
signaling point if you know that it is an SCP.

• SSP—Service switching point. You can assign this icon to an unknown 
signaling point if you know that it is an SSP.

• STP—Signal transfer point. You can assign this icon to an unknown signaling 
point if you know that it is an STP.

• SignalingPoint—An SCP, SSP, or STP, or an ITP instance.

• Unknown—SGM is unable to determine the signaling point type.

At any time, you can click Cancel to exit the dialog without saving any changes.

When you are satisfied with your changes, click Save. SGM saves your changes 
and updates all SGM windows to reflect your changes.
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Attaching a Note to a Signaling Point

To attach a note to a signaling point, right-click the signaling point in a window, 
then select Edit> Notes in the right-click menu. SGM displays the Edit Notes 
Dialog for a Signaling Point (Figure 3-34).

Figure 3-34 Edit Notes Dialog for a Signaling Point

The Note Last Updated field displays the date and time the Notes field for this 
signaling point was last updated. If there is no note currently associated with this 
signaling point, this field displays the value Not Set.

In the Notes field, enter any important information about the signaling point, such 
as a detailed description, its location, its service history, and so on. When you 
annotate a signaling point, the topology map in the Topology window displays a 
note icon in the upper left corner of the signaling point element.

At any time, you can click Cancel to exit the dialog without saving any changes.

When you are satisfied with your changes, click Save. SGM saves your changes 
and updates all SGM windows to reflect your changes.
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Viewing Notes for a Signaling Point
SGM enables you to view the notes that have been attached to signaling points.

To view a note, right-click a signaling point in a window, then select View >Notes 
in the right-click menu. (The Notes option is grayed-out if there is no note 
associated with the selected signaling point.) SGM displays the Notes for 
Signaling Point dialog (Figure 3-35).

Figure 3-35 Notes for Signaling Point Dialog

The Notes for Signaling Point dialog displays the following information:

• The name of the signaling point is displayed in the title of the window (for 
example, Notes for 1.60.2:net2.)

• Last Updated—Date and time the Notes field for the signaling point was last 
updated.

• Notes—Notes associated with the signaling point.

Click OK to close the Notes for Signaling Point dialog.
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Deleting a Signaling Point
After Discovery, the signaling points in your network are known to SGM and 
added to the SGM database. Physically deleting signaling points from your 
network is not the same as deleting them from the SGM database. The following 
sections describe the differences between deleting signaling points from your 
network and from the SGM database, and the procedures for doing so:

• Deleting a Signaling Point from Your Network, page 3-167

• Deleting a Signaling Point from the SGM Database, page 3-167

Deleting a Signaling Point from Your Network

If you physically delete a known signaling point from your network, it remains in 
the SGM database, SGM labels it Unknown, and it is the system administrator’s 
responsibility to delete it from the SGM database, if you choose to do so. SGM 
also labels all associated linksets and links Unknown because SGM attempts to 
poll the signaling point and gets no response.

Deleting a Signaling Point from the SGM Database

Typically, you delete a signaling point from the SGM database for one of the 
following reasons:

• You have physically deleted the signaling point from your network. This is 
the most common reason for deleting a signaling point from the SGM 
database.

• The signaling point is Unknown or Unmanaged, you are aware of the reason, 
and you no longer want to see it in SGM displays. For example, the signaling 
point might be a test lab device.

• If you delete all linksets to an Unmanaged signaling point, SGM does not 
automatically delete the signaling point. Instead, you must manually delete 
the signaling point.

If you have physically deleted a known signaling point from your network, and 
you then delete it from SGM, it is no longer in the SGM database, it does not 
appear in SGM windows, and it is not discovered when you run Discovery.
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Be aware of the following special situations:

• If you have not physically deleted a known signaling point from your 
network, and you delete it from SGM, SGM removes the signaling point from 
the poll list, and at the next poll SGM returns the signaling point to the 
DEFAULT view, and labels the signaling point as a new signaling point if you 
are using a custom view.

• If a signaling point has at least one adjacent signaling point in Active, 
Discovering, Waiting, or Warning state, you cannot delete the signaling 
point. If you try to do so, SGM cancels the deletion.

If either of these situations occurs, do not delete the signaling point again. Instead, 
perform one of the following actions:

• Label the signaling point Unmanaged. See the “Unmanaging and Managing 
a Signaling Point” section on page 3-169 for more details.

• Remove the signaling point from your view. See the “Working with Views” 
section on page 3-26 for more details.

Note If you delete a signaling point from the SGM database, the signaling point is 
deleted for all SGM clients and views connected to that SGM server.

To delete a signaling point from the SGM database, use one of the following 
procedures:

• Select one or more signaling points in a window, then select Edit> Delete 
from the SGM Main Menu.

• Right-click a signaling point in a window, then select Delete Item in the 
right-click menu. (You cannot delete more than one signaling point at a time 
from the right-click menu.)

SGM asks you to confirm the deletion:

• Select Yes to delete the selected signaling points. SGM deletes the signaling 
points from the SGM database.

• Select No to return to the window without deleting any signaling points from 
the SGM database.

You can also use the sgm delete sp command to delete one or more signaling 
points from the SGM database. See the “SGM Commands and Descriptions” 
section on page B-2 for more information on the use of this command.
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Note If you delete a signaling point, SGM removes it from the Signaling Points In 
Current View table of the Network View Editor window. If SGM then rediscovers 
the signaling point, SGM places it in the New Signaling Points Found table of the 
Network View Editor window. To restore the signaling point to your current view, 
you must move it into the Signaling Points In Current View table. For more 
information, see the “Working with Views” section on page 3-26.

Unmanaging and Managing a Signaling Point
SGM enables you to label a signaling point Unmanaged, and to remove the 
Unmanaged status from a signaling point.

In some situations, you might not want to see a given signaling point in SGM 
displays, but you might be unable to delete it from the SGM database. For 
example:

• If you have not physically deleted a known signaling point from your 
network, and you delete it from SGM, SGM removes the signaling point from 
the poll list, and at the next poll SGM returns the signaling point to the 
DEFAULT view, and labels the signaling point as a new signaling point if you 
are using a custom view.

• If a signaling point has at least one adjacent signaling point in Active or 
Warning state, you cannot delete the signaling point. If you try to do so, 
SGM cancels the deletion.

If these situations, you can label the signaling point Unmanaged. When you label 
a signaling point Unmanaged, SGM removes the signaling point from the poll 
list.

Note If you label a signaling point Unmanaged, the signaling point is Unmanaged for 
all SGM clients and views connected to that SGM server.

To label a signaling point Unmanaged, right-click a signaling point in a window, 
then select Unmanage from the right-click menu. SGM labels the selected 
signaling point Unmanaged and removes it from the poll list.
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You can also remove the Unmanaged status from a signaling point, when you are 
ready to return the signaling point to the SGM poll list. To remove the 
Unmanaged status from a signaling point, right-click a signaling point in a 
window, then select Manage from the right-click menu. SGM removes the 
Unmanaged status from the selected signaling point, returns it to the poll list, and 
polls it immediately.

Excluding a Signaling Point from a View
To exclude a signaling point from the current view, right-click the signaling point 
in a window, then select Exclude from View in the right-click menu. SGM 
excludes the signaling point from the current view. See the “Creating a View” 
section on page 3-27 for more information about excluding signaling points from 
views.

Working with Links
SGM enables you to view detailed information about all discovered links, 
including their associated nodes, status, events, and other information.

This section includes the following information:

• Viewing Basic Information for Links, page 3-171

• Viewing Detailed Information for a Link, page 3-175

• Viewing Real-Time Data for a Link, page 3-186

• Editing a Link, page 3-230

• Viewing Notes for a Link, page 3-232

• Deleting a Link, page 3-233

• Ignoring a Link, page 3-235

• Viewing Ignored Links, page 3-235

Related Topics:

• Working with Linksets, page 3-37

• Working with Nodes, page 3-91
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• Working with Signaling Points, page 3-136

• Viewing the Topology of the Network, page 3-259

• Modifying Preference Settings, page 5-3

Viewing Basic Information for Links
To view basic information for links, select Links in the left pane of the SGM Main 
Window. SGM displays the Link Window (Figure 3-36).

Figure 3-36 Link Window

The Link Window displays information about the links that have been discovered 
by SGM.

By default, SGM displays all of the columns in the link table except Internal ID, 
Congestion Level, and Last Status Change. To display these columns, or to hide 
other columns, see the procedures in the “Modifying Linkset Table Column 
Settings” section on page 5-18.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.
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If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

The Link Window displays the following information:

• Internal ID—Internal ID of the link. The internal ID is a unique ID for every 
event, linkset, link, signaling point, and node, assigned by SGM for its own 
internal use. It can also be useful when the TAC is debugging problems.

• Node—Name of the node associated with the link.

• Signaling Point—Name of the signaling point associated with the link.

• Linkset—Name of the linkset associated with the link.

• SLC—Signaling link code (SLC) ID for the link.

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTPIP—The link uses the Stream Control Transmission Protocol 
(SCTP) IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Congestion Level—Indicates whether there is congestion on the link. A link 
is congested if it has too many packets waiting to be sent. This condition 
could be caused by the failure of an element in your network.

Possible values for the Congestion Level field are:

– None—The link is not congested.

– Low—The link is slightly congested.

– High—The link is congested.

– Very High—The link is very congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.
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• Ignored—Indicates whether the link is to be included when aggregating and 
displaying SGM status information:

– Clear the checkbox to include the link. This is the default setting.

– Select the checkbox to exclude the link.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

• Notes—Indicates whether there is a note associated with the link.

• Events—Indicates whether there is a recent event associated with the link.

– To delete the event icon from SGM displays for a specific link, select the 
link and click the icon.

– To delete the event icon from SGM displays for all links, select Edit > 
Clear All Events from the SGM Main Menu.

Note During Discovery, SGM might flag most links with an event icon. If the 
event icons are too distracting, use the Edit > Clear All Events menu 
option to remove them.

• Last Status Change—Date and time that the status of the link last changed.

• Status—Current status of the link. Possible values are:

– Active (green ball)—The link is currently fully functional.

– Blocked (red ball)—Traffic on this link is disabled by protocol.

– Failed (red ball)—An error is preventing traffic from flowing on this 
link, or the associated linkset has been set to Shutdown status.

A link can be Failed from an MTP3 perspective, but control messages 
might still be sent or received on the link, resulting in changing 
packet/second and bit/second rates. The rates might also be different at 
each end of the link, depending on the reason for the failure and the 
timing related to each endpoint.

– InhibitLoc (blue ball)—A local ITP administrator has set the link to 
prevent traffic from flowing.

– InhibitRem (blue ball)—A remote ITP administrator has set the link to 
prevent traffic from flowing.
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– Shutdown (blue ball)—An ITP administrator has set the link to prevent 
traffic from flowing.

– Unknown (red ball)—Either the node associated with this link has failed 
to respond to an SNMP request, or SGM found that the link no longer 
exists.

When you physically delete a link, the Status field displays Unknown 
until you delete the link from the SGM database.

– Warning (yellow ball)—The link is active and traffic is flowing, but one 
or more of the following situations has occurred:

– The link is congested.

– The link has exceeded the defined Receive Utilization % or Send 
Utilization %.

– One or more of the local or remote IP addresses defined for SCTP is 
not active.

• Status Reason—Reason for the current status of the link. Possible values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive
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– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Viewing Detailed Information for a Link
SGM can display detailed information about a selected link, including its 
associated node, status, and other information.

To display detailed information for a link, use one of the following procedures:

• Select Links in the left pane of the SGM Main Window, right-click a link in 
the right pane, then select View >Configuration Details in the right-click 
menu.

• Select the turner beside Links in the left pane of the SGM Main Window, then 
select a link.

SGM displays the Link Details Window (Figure 3-37).
3-175
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Links
Figure 3-37 Link Details Window

Detailed information for links associated with the selected linkset is displayed in 
the left column, and for links associated with the adjacent linkset in the right 
column.

Updates for the links that are received from the SGM server are reflected 
automatically in this window.

Changes you make in this pane might not be reflected throughout SGM until the 
next poll (by default, every 15 seconds). For information about changing the 
polling interval, see the “Viewing Detailed Information for a Link” section on 
page 3-175.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.
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Configuration Data Tab: General Information

To view general information for the selected link, select the Configuration Data 
tab.

The General Information sub-section displays the following information for the 
selected link:

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTPIP—The link uses the Stream Control Transmission Protocol 
(SCTP) IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Is Ignored—Indicates whether the link is Ignored (that is, whether the link 
is to be included when aggregating and displaying SGM status information).

• Association ID—For a link of type HSL, Serial, or Virtual, this field has a 
value of 0. For a link of type SCTP, the index into the SNMP SCTP 
association table.

Configuration Data Tab: Interface Information

To view interface information for the selected link, select the Configuration Data 
tab.

The Interface Information sub-section displays the following information for the 
selected link:

• QoS—(SCTP links only) Quality of service (QoS) class of the link.

• Local Port—(SCTP links only) Local port for the link.

• Remote Port—(SCTP links only) Remote port for the link.

• Interface Name—(HSL, Serial, and Virtual links only) Name of the 
interface.

• Interface Index—(HSL, Serial, and Virtual links only) Index into the SNMP 
interface table.
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Configuration Data Tab: Local IP Address Information (SCTP Links Only)

To view local IP address information for the selected SCTP link, select the 
Configuration Data tab.

The Local IP Address Information sub-section displays the following information 
for the selected link:

• IP Address—Local IP address associated with the link.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.

Configuration Data Tab: Remote IP Address Information (SCTP Links Only)

To view remote IP address information for the selected SCTP link, select the 
Configuration Data tab.

The Remote IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Remote IP address associated with the link.

• Type—Indicates the designated primary IP address for the link (Primary) 
and the IP address currently being used by the link (Effective).

Usually, the same IP address is both Primary and Effective. However, if the 
primary IP address is down for some reason, a different IP address is used by 
the link and is labeled Effective.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.
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Configuration Data Tab: Configured Local IP Address Information (SCTP Links Only)

To view configured local IP address information for the selected SCTP link, select 
the Configuration Data tab.

The Configured Local IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Configured local IP address associated with the link.

• Interface Name—Primary IP address and interface name of the link. The 
primary IP address is the first CS7 local IP address configured in the ITP. For 
example, if the following IP addresses are configured in the ITP:

cs7 local-peer 4180
local-ip 128.3.0.77
local-ip 128.3.0.254

Then SGM uses 128.3.0.77 as the primary IP address. If at any time that IP 
address is deleted from the ITP configuration, or if a new IP address is added 
to the beginning of the list, SGM detects the change and automatically 
updates this field to reflect the new primary IP address.

If the link has no interface name, this field is blank.

Status Summary Tab: Status Information

To view status information for the selected link, select the Status Summary tab.

The Status Information sub-section displays the following information for the 
selected link:

• Last Status Change—Date and time that the status of the link last changed.

• Status—Current status of the link. Possible values are:

– Active (green ball)—The link is currently fully functional.

– Blocked (red ball)—Traffic on this link is disabled by protocol.

– Failed (red ball)—An error is preventing traffic from flowing on this 
link, or the associated linkset has been set to Shutdown status.

A link can be Failed from an MTP3 perspective, but control messages 
might still be sent or received on the link, resulting in changing 
packet/second and bit/second rates. The rates might also be different at 
each end of the link, depending on the reason for the failure and the 
timing related to each endpoint.
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– InhibitLoc (blue ball)—A local ITP administrator has set the link to 
prevent traffic from flowing.

– InhibitRem (blue ball)—A remote ITP administrator has set the link to 
prevent traffic from flowing.

– Shutdown (blue ball)—An ITP administrator has set the link to prevent 
traffic from flowing.

– Unknown (red ball)—Either the node associated with this link has failed 
to respond to an SNMP request, or SGM found that the link no longer 
exists.

When you physically delete a link, the Status field displays Unknown 
until you delete the link from the SGM database.

– Warning (yellow ball)—The link is active and traffic is flowing, but one 
or more of the following situations has occurred:

– The link is congested.

– The link has exceeded the defined Receive Utilization % or Send 
Utilization %.

– One or more of the local or remote IP addresses defined for SCTP is 
not active.

• Congestion Level—Indicates whether there is congestion on the link. A link 
is congested if it has too many packets waiting to be sent. This condition 
could be caused by the failure of an element in your network.

Possible values for the Congestion Level field are:

– None—The link is not congested.

– Low—The link is slightly congested.

– High—The link is congested.

– Very High—The link is very congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.

• Receive Utilization—Indicates whether, on average, the link is under its 
configured receive utilization threshold (UnderThreshold) or over the 
threshold (OverThreshold).
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• Send Utilization—Indicates whether, on average, the link is under its 
configured send utilization threshold (UnderThreshold) or over the 
threshold (OverThreshold).

• Status Reason—Reason for the current status of the link. Possible values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded

– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.
3-181
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Links
If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Status Summary Tab: Local IP Address Information (SCTP Links Only)

To view local IP address information for the selected SCTP link, select the Status 
Summary tab.

The Local IP Address Information sub-section displays the following information 
for the selected link:

• IP Address—Local IP address associated with the link.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.

Status Summary Tab: Remote IP Address Information (SCTP Links Only)

To view remote IP address information for the selected SCTP link, select the 
Status Summary tab.

The Remote IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Remote IP address associated with the link.

• Type—Indicates the designated primary IP address for the link (Primary) 
and the IP address currently being used by the link (Effective).

Usually, the same IP address is both Primary and Effective. However, if the 
primary IP address is down for some reason, a different IP address is used by 
the link and is labeled Effective.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.
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Notes Tab

To view notes for the selected link, select the Notes tab.

The Notes section displays:

• Notes associated with the selected link in the left column.

• Notes associated with the adjacent link in the right column.

• The date and time the notes associated with each link were last updated, or 
the phrase Not Set if there are no notes associated with the link.

• The phrase No Notes if there are no notes associated with the link.

Recent Events Tab

To view information about all recent events associated with the link, select the 
Recent Events tab. SGM displays the Recent Events table for the link 
(Figure 3-38).

Figure 3-38 Recent Events Table for a Link

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Ack Time, Node, SP, Linkset, and Link. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Event 
Table Column Settings” section on page 5-19.
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To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

The Recent Events section enables you to perform event-related tasks, such as 
setting filters and acknowledging events. For more information about these tasks, 
see the “Working with Events” section on page 3-235.

The Recent Events table displays the following information for the selected link:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.

– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.
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– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.

– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.
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• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.

• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

Viewing Real-Time Data for a Link
SGM enables you to display detailed statistics for a selected link. Detailed 
information for links associated with the selected linkset is displayed in the left 
column, and for links associated with the adjacent linkset in the right column.

To display detailed statistics for a link, select Links in the left pane of the SGM 
Main Window, right-click a link in the right pane, then select View >Real-Time 
Data and Charts in the right-click menu. SGM displays the Statistics Details 
Window for a Link (Figure 3-39).
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Figure 3-39 Statistics Details Window for a Link

Updates for the links that are received from the SGM server are reflected 
automatically in this window.

Changes you make in this window might not be reflected throughout SGM until 
the next poll (by default, every 15 seconds). For information about changing the 
polling interval, see the “Viewing Detailed Information for a Link” section on 
page 3-175.
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Note Each link is identified by its signaling link code ID (SLC). An asterisk indicates 
that a link is not configured, or that a poll could not get data for the link. For 
example, SLC (*)3 means there is no link associated with the selected linkset for 
SLC 3, and SLC 3(*) means there is no link associated with the adjacent linkset 
for SLC 3.

Select one of the SLCs. SGM displays the Statistics Details Window for a Link 
for that link.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

Configuration Data Tab: General Information

To view general information for the selected link, select the Configuration Data 
tab.

The General Information sub-section displays the following information for the 
selected link:

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTPIP—The link uses the Stream Control Transmission Protocol 
(SCTP) IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Is Ignored—Indicates whether the link is Ignored (that is, whether the link 
is to be included when aggregating and displaying SGM status information).

• Association ID—For a link of type HSL, Serial, or Virtual, this field has a 
value of 0. For a link of type SCTP, the index into the SNMP SCTP 
association table.
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Configuration Data Tab: Interface Information

To view interface information for the selected link, select the Configuration Data 
tab.

The Interface Information sub-section displays the following information for the 
selected link:

• QoS—(SCTP links only) Quality of service (QoS) class of the link.

• Local Port—(SCTP links only) Local port for the link.

• Remote Port—(SCTP links only) Remote port for the link.

• Interface Name—(HSL, Serial, and Virtual links only) Name of the 
interface.

• Interface Index—(HSL, Serial, and Virtual links only) Index into the SNMP 
interface table.

Configuration Data Tab: Local IP Address Information (SCTP Links Only)

To view local IP address information for the selected SCTP link, select the 
Configuration Data tab.

The Local IP Address Information sub-section displays the following information 
for the selected link:

• IP Address—Local IP address associated with the link.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.
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Configuration Data Tab: Remote IP Address Information (SCTP Links Only)

To view remote IP address information for the selected SCTP link, select the 
Configuration Data tab.

The Remote IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Remote IP address associated with the link.

• Type—Indicates the designated primary IP address for the link (Primary) 
and the IP address currently being used by the link (Effective).

Usually, the same IP address is both Primary and Effective. However, if the 
primary IP address is down for some reason, a different IP address is used by 
the link and is labeled Effective.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.

Configuration Data Tab: Configured Local IP Address Information (SCTP Links Only)

To view configured local IP address information for the selected SCTP link, select 
the Configuration Data tab.

The Configured Local IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Configured local IP address associated with the link.

• Interface Name—Primary IP address and interface name of the link. The 
primary IP address is the first CS7 local IP address configured in the ITP. For 
example, if the following IP addresses are configured in the ITP:

cs7 local-peer 4180
local-ip 128.3.0.77
local-ip 128.3.0.254

Then SGM uses 128.3.0.77 as the primary IP address. If at any time that IP 
address is deleted from the ITP configuration, or if a new IP address is added 
to the beginning of the list, SGM detects the change and automatically 
updates this field to reflect the new primary IP address.

If the link has no interface name, this field is blank.
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Status Summary Tab: Status Information

To view status information for the selected link, select the Status Summary tab.

The Status Information sub-section displays the following information for the 
selected link:

• Last Status Change—Date and time that the status of the link last changed.

• Status—Current status of the link. Possible values are:

– Active (green ball)—The link is currently fully functional.

– Blocked (red ball)—Traffic on this link is disabled by protocol.

– Failed (red ball)—An error is preventing traffic from flowing on this 
link, or the associated linkset has been set to Shutdown status.

A link can be Failed from an MTP3 perspective, but control messages 
might still be sent or received on the link, resulting in changing 
packet/second and bit/second rates. The rates might also be different at 
each end of the link, depending on the reason for the failure and the 
timing related to each endpoint.

– InhibitLoc (blue ball)—A local ITP administrator has set the link to 
prevent traffic from flowing.

– InhibitRem (blue ball)—A remote ITP administrator has set the link to 
prevent traffic from flowing.

– Shutdown (blue ball)—An ITP administrator has set the link to prevent 
traffic from flowing.

– Unknown (red ball)—Either the node associated with this link has failed 
to respond to an SNMP request, or SGM found that the link no longer 
exists.

When you physically delete a link, the Status field displays Unknown 
until you delete the link from the SGM database.

– Warning (yellow ball)—The link is active and traffic is flowing, but one 
or more of the following situations has occurred:

– The link is congested.

– The link has exceeded the defined Receive Utilization % or Send 
Utilization %.

– One or more of the local or remote IP addresses defined for SCTP is 
not active.
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• Congestion Level—Indicates whether there is congestion on the link. A link 
is congested if it has too many packets waiting to be sent. This condition 
could be caused by the failure of an element in your network.

Possible values for the Congestion Level field are:

– None—The link is not congested.

– Low—The link is slightly congested.

– High—The link is congested.

– Very High—The link is very congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.

• Receive Utilization—Indicates whether, on average, the link is under its 
configured receive utilization threshold (UnderThreshold) or over the 
threshold (OverThreshold).

• Send Utilization—Indicates whether, on average, the link is under its 
configured send utilization threshold (UnderThreshold) or over the 
threshold (OverThreshold).

• Status Reason—Reason for the current status of the link. Possible values are:

– None

– SGM Restart

– Unsupported Configuration

– Unconfigured

– SNMP Timeout

– Device is unreachable, possibly wrong community string

– Not ITP Device

– Not Configured for ITP

– MIB Data Error

– SNMP Exception

– SignalingPoint Inactive

– Linkset Inactive

– Link Congested

– Link Send Utilization Threshold Exceeded
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– Link Receive Utilization Threshold Exceeded

– Link Local Interface Inactive

– Link Remote Interface Inactive

– Link Inactive

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the sgm cleandiscover command to delete all current network data 
and begin a clean discovery of the ITP network. If the status reason is still 
Unsupported Configuration, enter the sgm clean command to restore the 
SGM server to a “clean” state, such as would exist after a new installation of 
SGM. For more information on the use of these commands, see the “SGM 
Commands and Descriptions” section on page B-2.

Status Summary Tab: Local IP Address Information (SCTP Links Only)

To view local IP address information for the selected SCTP link, select the Status 
Summary tab.

The Local IP Address Information sub-section displays the following information 
for the selected link:

• IP Address—Local IP address associated with the link.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.
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Status Summary Tab: Remote IP Address Information (SCTP Links Only)

To view remote IP address information for the selected SCTP link, select the 
Status Summary tab.

The Remote IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Remote IP address associated with the link.

• Type—Indicates the designated primary IP address for the link (Primary) 
and the IP address currently being used by the link (Effective).

Usually, the same IP address is both Primary and Effective. However, if the 
primary IP address is down for some reason, a different IP address is used by 
the link and is labeled Effective.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.

Notes Tab

To view notes for the selected link, select the Notes tab.

The Notes section displays:

• Notes associated with the selected link in the left column.

• Notes associated with the adjacent link in the right column.

• The date and time the notes associated with each link were last updated, or 
the phrase Not Set if there are no notes associated with the link.

• The phrase No Notes if there are no notes associated with the link.

Recent Events Tab

To view information about all recent events associated with the link, select the 
Recent Events tab. SGM displays the Recent Events table for the link 
(Figure 3-38).

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Ack Time, Node, SP, Linkset, and Link. To display these 
columns, or to hide other columns, see the procedures in the “Modifying Event 
Table Column Settings” section on page 5-19.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.
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If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

The Recent Events section enables you to perform event-related tasks, such as 
setting filters and acknowledging events. For more information about these tasks, 
see the “Working with Events” section on page 3-235.

The Recent Events table displays the following information for the selected link:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.

– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.
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– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.

– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.
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• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.

• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

Status Details Tab

To view detailed status information for the selected link, select the Status Details 
tab.

The Status Details section displays the following information for the selected 
link:

• Protocol State Details—Detailed information about the state of the protocol 
for this link. Possible values are:

– Changeback control(TCBC): Changeback control is buffering data on 
this link

– Changeover control(TCOC): Changeover control is buffering data on this 
link

– Link availability control(TLAC): Adjacent Signalling point is restarting

– Link availability control(TLAC): Emergency changeover is in progress 
on this link

– Link availability control(TLAC): Changeback is in progress on this link

– Link availability control(TLAC): Changeover is in progress on this link

– Link availability control(TLAC): The last changeover operation failed on 
this link

– Link availability control(TLAC): Inhibit command will be retried

– Link availability control(TLAC): Management request in progress for 
this link

– Link availability control(TLAC): Signalling point is in the process of a 
restart

– Signalling routing control(TSRC): Changeover request is complete
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– Signalling routing control(TSRC): Adjacent Signalling Point is 
restarting

– Link availability control(TLAC): Link has been inhibited by a local 
management operation

– Link availability control(TLAC): LInk has been inhibited by a remote 
management operation

– Link availability control(TLAC): Link is blocked because of a local 
processor outage

– Link availability control(TLAC): Link is blocked because of a remote 
processor outage

• Link Test Results—Indicates the results of the link test. Possible results are:

– No Errors—The link did not detect any errors.

– Undefined OPC (Origination Point Code)—A signaling link test 
message was received with an undefined OPC. This can occur when a 
serial link is connected incorrectly, or when an SCTP link is configured 
incorrectly. This differs from Incorrect OPC because the signaling point 
is unaware of the point code in question. The point code is not defined 
for any linkset on this ITP.

– Incorrect OPC (Origination Point Code)—A signaling link test 
message was received with an incorrect OPC. This can occur when a 
serial link is connected incorrectly, or when an SCTP link is configured 
incorrectly. This differs from Undefined OPC because the signaling 
point is aware of the point code in question, and the point code is defined 
for a linkset on this ITP, but the point code is not correct for the current 
linkset.

– Undefined SLC (Signaling Link Code)—A signaling link test message 
was received with an undefined SLC. This can occur when a serial link 
is connected incorrectly, or when an SCTP link is configured incorrectly. 
The link is connected to the correct linkset, but the linkset does not have 
a definition for the SLC in question.

– Incorrect SLC (Signaling Link Code)—A signaling link test message 
was received with an incorrect SLC. This can occur when a serial link is 
connected incorrectly, or when an SCTP link is configured incorrectly. 
The link is connected to the correct linkset, but to the wrong link within 
that linkset. That is, the signaling test receives the test packet on the 
wrong link.
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– Incorrect NI (Network Indicator)—A signaling link test message was 
received with an incorrect NI. This can occur when links are connected 
to the correct linkset and link, but the NIs of the two adjacent point codes 
are not the same.

– Bad Pattern—A signaling link test message was received with an 
incorrect test pattern. This error occurs because the test pattern is corrupt. 
This usually indicates a hardware or configuration issue related to the 
physical format of the data on the links, caused by a variant mismatch or 
incorrect definitions on the physical link.

– Non Adjacent—Received a signaling link test message from a 
non-adjacent node.

– Failed—Unable to run the test, or no response was received within the 
specified interval.

• Link Fail Reason—If the link failed the link test, indicates the reason for the 
failure. Possible reasons are:

– None—No additional reason available.

– Changeover in progress—Changeover is in progress. This message is 
used to divert traffic away from a failed link.

– Management disconnect request—An MTP3 sent a request to stop the 
link.

– Link alignment lost—Link alignment is lost.

A link is in alignment when signal units are received in sequence, and 
with the proper number of octets. The signal unit must be a total length 
of eight-bit multiples. If the signal unit is not of eight-bit multiples, or if 
the signaling information field (SIF) exceeds the 272-octet capacity, the 
signaling unit is considered to be in error. If excessive errors are 
encountered on a link, it is considered to be out of alignment.

For M2PA links, this state reason is generated when the M2PA alignment 
timer T1 expires. This could indicate that the remote link is shutdown, or 
that there are intermittent IP connectivity problems.

– Link connection lost—Link connection is lost.

– Local Disconnect—A request to disconnect the link has been received, 
but the link is already disconnected.

– Remote Disconnect—A remote disconnect request has been received.
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– Signal unit error rate monitor failure—The signal unit error rate 
monitor has failed.

– T1 timeout no FISU received—A T1 timeout no FISU has been 
received. This timer avoids message mis-sequencing during changeover.

– T2 timeout no SIO received—A T2 timeout no SIO has been received. 
This timer waits for a changeover acknowledgment.

– T3 timeout no SIN received—A T3 timeout no SIN has been received. 
This timer controls diversion-delay to avoid mis-sequencing on 
changeback.

– T6 timeout excessive congestion—A T6 timeout excessive congestion 
has been received. This timer avoids message mis-sequencing on 
controlled rerouting.

– T7 timeout excessive acknowledgement delay—A T7 timeout 
excessive acknowledgment delay has been received. The T7 timer 
prevents a signaling point from waiting too long for a positive or negative 
acknowledgment. Usually, an acknowledgment is sent when a signaling 
point becomes idle and does not have any more traffic to transmit. When 
congestion occurs at a signaling point, or an extreme amount of traffic is 
present, it is possible that T7 could time out and force retransmission of 
messages.

– Link proving failure—A link proving failure occurred.

– Abnormal BSN received—An abnormal Backward Sequence Number 
(BSN) has been received.

– Abnormal FIB received—An abnormal Forward Indicator Bit (FIB) has 
been received.

– Abnormal SIB received—An abnormal Status Indicator Busy (SIB) has 
been received.

– Abnormal LSSU received—An abnormal Link Status Signal Unit 
(LSSU) has been received.

– Peer not ready—An MTP3 tried to bring up a link that is still cleaning 
up after being stopped. In some cases, the MTP3 does not changeover 
after a link failure, so the M2PA/SCTP waits for an event that will not 
occur. When an MTP3 tries to bring up the link again, the previous 
control structures have to be cleaned up first. If M2PA gets a start request 
from an MTP3, and the previous structures are still being held, M2PA 
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cleans them up and sends a “PEER NOT READY” to the MTP3. A 
subsequent request to start the link from the MTP3 will then cause the 
link to come up.

– Communication lost—M2PA/SCTP has determined that the remote end 
signaling point is no longer reachable. Possible reasons include:

– The maximum number of consecutive retries of a packet has been 
reached.

– In the absence of data, SGM failed to receive heartbeat ACKs in 
response to heartbeats, for the maximum number of retries.

– No Listen posted—An MTP3 tried to start a link, but the local-peer port 
associated with the link is not available, probably because of a bad 
configuration.

– Unable to allocate buffer—M2PA/SCTP cannot get buffers for sending 
or receiving packets. Buffer problems can be temporary or permanent. 
Temporary buffer problems will generally clear with little side effects. 
Permanent buffer problems can lead to failed linksets or links.

– Link card removed—A link card has been removed.

– Link card inserted—A link card has been inserted.

– False link congestion—A false link congestion indication has been 
received.

– Configuration downloading—The configuration is downloading.

Statistics Tab: Packet Information

To view packet information for the selected link, select the Statistics tab.

The Packet Information sub-section displays the following information for the 
selected link:

• Sent Per Sec—Number of packets sent by the link per second. This field 
initially displays the phrase Waiting for second poll. After two polling 
cycles, SGM populates this field with actual calculated rates.

• Received Per Sec—Number of packets received by the link per second. This 
field initially displays the phrase Waiting for second poll. After two polling 
cycles, SGM populates this field with actual calculated rates.

• Drops—Total number of packets that have been dropped by the link.
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• Transmit Queue Depth—Number of packets waiting to be sent on by the 
link.

• Transmit Queue High Depth—Highest level reached by the transmit queue 
since the last reboot of the ITP, or since ITP last reset the averages as a result 
of bad data.

• Transmit Queue High Reset—Level at which the link is to reset the transmit 
queue. If the link is never to reset the transmit queue, this field displays 
Never.

• Signal Link Test—Indicates whether test packets are being sent on the link. 
Valid values are:

– true (1)—Test packets are being sent.

– false (2)—Test packets are not being sent.

Statistics Tab: Bit Information or Byte Information

To view bit information for the selected link (or byte information, if you cleared 
the Show Details in Bits Instead of Bytes checkbox in the Preferences Window), 
select the Statistics tab.

The Bit Information or Byte Information sub-section displays the following 
information for the selected link:

• Sent Per Sec—Number of bits or bytes (as set in the Preferences window) 
sent by the link per second. This field initially displays the phrase Waiting 
for second poll. After two polling cycles, SGM populates this field with 
actual calculated rates.

• Received Per Sec—Number of bits or bytes (as set in the Preferences 
window) received by the link per second. This field initially displays the 
phrase Waiting for second poll. After two polling cycles, SGM populates 
this field with actual calculated rates.
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Statistics Tab: LSSU Information

To view Links Status Signal Unit (LSSU) information for the selected link, select 
the Statistics tab.

The LSSU Information sub-section displays the following information for the 
selected link:

• LSSU Packets Sent—Total number of LSSU packets sent by the link.

• LSSU Packets Received—Total number of SS7 Message Transfer Part Layer 
2 (MTP2) LSSU packets received by the link.

Statistics Tab: Utilization Information

To view utilization information for the selected link, select the Statistics tab.

The Utilization Information sub-section displays the following information for 
the selected link:

• Send Plan Capacity—Planned capacity of the link to send, in bits per 
second.

– For a link of type Serial or HSL, available bandwidth for the link.

– For a link of type SCTPIP, set on the ITP using the plan-capacity CS7 
link configuration command.

If Send Plan Capacity is not set on the ITP for this link, this field 
displays the value 0.

– For a link of type Other, this field always displays the value 0.

• Send Utilization—Amount of the link’s send capacity being used, as a 
percentage or in Erlangs (as set in the Preferences window), calculated using 
the following formula:

Send Utilization = (Bits Sent Per Sec)/Planned Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a link of type SCTPIP or Mixed, if Send Plan Capacity is not set 
on the ITP for this link, this field displays the phrase Set Plan Capacity 
on ITP.

– For a link of type Other, this field always displays the phrase Set Plan 
Capacity on ITP.
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• Send Threshold %—Indicates when a cItpSpLinkSentUtilChange is to be 
generated for the link, as a percent of its total send capacity. For example, if 
Send Plan Capacity is 64000 bits per second, and Send Threshold % is 50, 
then a cItpSpLinkSentUtilChange notification is generated when the link 
reaches 50% of 64000, or 32000 bits per second.

• Receive Plan Capacity—Planned capacity of the link to receive, in bits per 
second.

– For a link of type Serial or HSL, available bandwidth for the link.

– For a link of type SCTPIP, set on the ITP using the plan-capacity CS7 
link configuration command.

If Receive Plan Capacity is not set on the ITP for this link, this field 
displays the value 0.

– For a link of type Other, this field always displays the value 0.

• Receive Utilization—Amount of the link’s receive capacity being used, as a 
percentage or in Erlangs (as set in the Preferences window), calculated using 
the following formula:

Receive Utilization = (Bits Received Per Sec)/Receive Plan Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a link of type SCTPIP or Mixed, if Receive Plan Capacity is not set 
on the ITP for this link, this field displays the phrase Set Plan Capacity 
on ITP.

– For a link of type Other, this field always displays the phrase Set Plan 
Capacity on ITP.

• Receive Threshold %—Indicates when a cItpSpLinkRcvdUtilChange is to 
be generated for the link, as a percent of its total receive capacity. For 
example, if Receive Plan Capacity is 64000 bits per second, and Receive 
Threshold % is 50, then a cItpSpLinkRcvdUtilChange notification is 
generated when the link reaches 50% of 64000, or 32000 bits per second.
3-204
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Links
Statistics Tab: Service Information

To view service information for the selected link, select the Statistics tab.

The Service Information sub-section displays the following information for the 
selected link:

• Duration In Service %—Percentage of time the link has been in service 
since the last reboot of the ITP, or since ITP last reset the counters.

• Duration Out Of Service %—Percentage of time the link has been out of 
service since the last reboot of the ITP, or since ITP last reset the counters.

Q.752 Measurements Tab: Error Information

To view Q.752 error information for the selected link, select the Q.752 
Measurements tab.

The Error Information sub-section displays the following information for the 
selected link:

• Link Failure Count—Number of times the link was unavailable for 
signaling.

• Alignment Error Count—Number of errors detected during link alignment. 
Link alignment takes place at start up, or when trying to bring up a failed link.

• Negative ACKs Count—Number of errors detected during link 
acknowledgement. 

Q.752 Measurements Tab: Inhibited Information

To view Q.752 inhibited information for the selected link, select the Q.752 
Measurements tab.

The Inhibited Information sub-section displays the following information for the 
selected link:

• Local Inhibit Onset—Number of times a local ITP administrator has 
inhibited the link (that is, set the link to prevent traffic from flowing).

• Local Inhibit Duration—Total time the link has been locally inhibited.

• Remote Inhibit Onset—Number of times a remote ITP administrator has 
inhibited the link.

• Remote Inhibit Duration—Total time the link has been remotely inhibited.
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Q.752 Measurements Tab: Retransmitted Information

To view Q.752 retransmitted information for the selected link, select the Q.752 
Measurements tab.

The Retransmitted Information sub-section displays the following information for 
the selected link:

• Packet Retransmitted Count—Number of packets retransmitted by the link.

• Byte Retransmitted Count—Number of bytes retransmitted by the link.

Q.752 Measurements Tab: Congested Information

To view Q.752 congested information for the selected link, select the Q.752 
Measurements tab.

The Congested Information sub-section displays the following information for the 
selected link:

• Congestion Occurrences—Number of times congestion has occurred on the 
link.

• Congestion Duration—Total time the link has been congested.

• Congestion Level—Level of congestion: 1, 2, or 3.

• Packets Lost—Number of packets lost by the link as a result of congestion 
at each level.

• Times At Level With Packet Loss—Number of times the link has been 
congested and has lost packets at each level.

Interface Details Tab: Configuration Information

To view detailed interface configuration information for the selected link, select 
the Interface Details tab.

The Configuration Information sub-section displays the following information for 
the selected link:

• Type—Type of interface, such as Ethernet.

• MTU—Size, in bytes, of the largest datagram that can be sent or received on 
the interface.

• Speed (Bits/Sec)—Estimate, in bits per second, of the interface's current 
bandwidth. If the interface does not vary in bandwidth, or if no accurate 
estimate can be made, this field displays the nominal bandwidth.
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• IP Address—(SCTP links only) IP address corresponding to the 
media-dependent “physical” address. If the interface does not have such an 
address (for example, a serial line), this field displays N/A.

• IP Mask—(SCTP links only) Subnet mask corresponding to the 
media-dependent “physical” address. If the interface does not have such an 
address (for example, a serial line), this field displays N/A.

• Physical Address—(SCTP links only) Address of the interface at the 
protocol layer immediately “below” the network layer in the protocol stack. 
If the interface does not have such an address (for example, a serial line), this 
field displays N/A.

Interface Details Tab: Status Information

To view detailed interface status information for the selected link, select the 
Interface Details tab.

The Status Information sub-section displays the following information for the 
selected link:

• ITP Uptime—Time the link has been up, in weeks, days, hours, minutes, and 
seconds.

• Admin Status—Desired state of the interface. Possible values are:

– Up

– Down

– Testing

• Operational Status—Current operational state of the interface. Possible 
values are:

– Up

– Down

– Testing

– Unknown

– Dormant
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• Line Protocol Status—Current state of the line protocol. Possible values are:

– Up—Software processes that handle the line protocol consider the line to 
be usable (that is, keepalives are successful).

– Down—Software processes that handle the line protocol consider the 
line to be unusable.

You can use the Line Protocol together with Operational Status to 
troubleshoot interface connection problems. For example, if Operational 
Status is Up, but Line Protocol is Down, the interface has detected a carrier 
on the physical layer, but there might be clocking or framing problems.

Interface Details Tab: Statistics Information

To view detailed interface statistics information for the selected link, select the 
Interface Details tab.

The Statistics Information sub-section displays the following information for the 
selected link:

• Bytes In per Sec—Number of bytes received on the interface per second, 
including framing characters.

• Bytes Out per Sec—Number of bytes sent on the interface per second, 
including framing characters.

• Packets In per Sec—Number of packets delivered per second to a 
higher-layer protocol.

• Packets Out per Sec—Total number of packets that higher-level protocols 
requested to be sent to the network per second, including those that were 
discarded or not sent.
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Interface Details Tab: Errors Information

To view detailed interface errors information for the selected link, select the 
Interface Details tab.

The Errors Information sub-section displays the following information for the 
selected link:

• In Discards—Number of inbound packets that were discarded, even though 
no errors were detected to prevent their delivery to a higher-layer protocol. 
For example, a packet might be discarded to free buffer space.

• Out Discards—Number of outbound packets that were discarded, even 
though no errors were detected to prevent their delivery to a higher-layer 
protocol. For example, a packet might be discarded to free buffer space.

• In Errors—Number of inbound packets that contained errors that prevented 
their delivery to a higher-layer protocol.

• Out Errors—Number of outbound packets that were not sent because of 
errors.

M2PA Peer Config Details Tab: Configuration Information (SCTP Links Only)

To view detailed M2PA peer configuration information for the selected SCTP 
link, select the M2PA Peer Config Details tab.

The Configuration Information sub-section displays the following information for 
the selected link:

• Status—Current status of the SCTP association. Possible values are:

– Closed

– CookieWait

– CookieEchoed

– DeleteTCB

– Established

– ShutdownAckSent

– ShutdownPending

– ShutdownReceived

– ShutdownSent

For detailed information about each status, refer to RFC 2960, Stream 
Control Transmission Protocol.
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• Uptime—Time the link has been up, in weeks, days, hours, minutes, and 
seconds.

• Remote Port—Remote port number for the SCTP association.

• Local Port—Local port number for the SCTP association.

• Primary IP Address—Designated primary IP address for the SCTP 
association.

• Effective IP Address—IP address currently being used by the SCTP 
association.

M2PA Peer Config Details Tab: Local IP Address Information (SCTP Links Only)

To view detailed M2PA peer local IP address information for the selected SCTP 
link, select the M2PA Peer Config Details tab.

The Local IP Address Information sub-section displays the following information 
for the selected link:

• IP Address—Local IP addresses associated with the link.

• Uptime—Time each local IP address associated with the link has been up, in 
weeks, days, hours, minutes, and seconds.

M2PA Peer Config Details Tab: Remote IP Address Information (SCTP Links Only)

To view detailed M2PA peer remote IP address information for the selected SCTP 
link, select the M2PA Peer Config Details tab.

The Remote IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Remote IP addresses associated with the link.

• Uptime—Time each remote IP address associated with the link has been up, 
in weeks, days, hours, minutes, and seconds.

• Retry Timeout (msecs)—Time, in milliseconds, that SGM waits between 
attempts to connect to the remote IP address.

• Maximum Retries—Maximum number of times SGM will attempt to 
connect to the remote IP address.

• Retries—Number of times SGM has attempted to connect to the remote IP 
address.
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M2PA Peer Config Details Tab: Transmission Configuration Information

To view detailed M2PA peer transmission configuration information for the 
selected link, select the M2PA Peer Config Details tab.

The Transmission Configuration Information sub-section displays the following 
information for the selected link:

• MTU—Maximum transmission unit (MTU) size to be used by this SCTP 
association. This is the smallest MTU size supported by any of the IP 
addresses used by the SCTP association.

• In Streams—Inbound streams as negotiated when the SCTP association was 
started.

• Out Streams—Outbound streams as negotiated when the SCTP association 
was started.

• Maximum Retries—Maximum number of data retransmissions in the SCTP 
association context.

• Local Receive Window Size—Current local receive window size for this 
SCTP association.

• Remote Receive Window Size—Current local send window size for this 
SCTP association.

• Initial Retry Timeout (msecs)—Initial timeout value, in milliseconds, 
permitted by the SCTP implementation for the retry timeout.

• Minimum Retry Timeout (msecs)—Minimum timeout value, in 
milliseconds, permitted by the SCTP implementation for the retry timeout.

• Maximum Retry Timeout (msecs)—Maximum timeout value, in 
milliseconds, permitted by the SCTP implementation for the retry timeout.

• Bundle Chunks—Indicates whether the SCTP protocol allows chunks to be 
bundled into a single datagram. Valid values are:

– true (1)—Chunks are bundled.

– false (2)—Chunks are not bundled.

• Bundle Timeout (msecs)—Time, in milliseconds, to wait to allow data 
chunks to accumulate so that they can be transmitted in the same datagram.
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M2PA Peer Stats Details Tab: Remote IP Address Information (SCTP Links Only)

To view detailed M2PA peer remote IP address statistics information for the 
selected SCTP link, select the M2PA Peer Stats Details tab.

The Remote IP Address Information sub-section displays the following 
information for the selected link:

• IP Address—Remote IP addresses associated with the link.

• Smoothed Round Trip Time (msecs)—Average, in milliseconds, of all 
round-trip times between the local and remote systems on an IP network.

• Failure Count—Number of times the remote IP address was marked as 
failed.

• Heartbeat Status—Current status of the heartbeat associated with the 
remote IP address. Valid values are Active and Inactive.

• IP Status—Current status of the remote IP address. Valid values are Active 
and Inactive.

M2PA Peer Stats Details Tab: Statistics Information (per sec) Rates

To view detailed M2PA peer statistics information for the selected link, select the 
M2PA Peer Stats Details tab.

The Statistics Information (per sec) Rates sub-section displays the following 
information for the selected link:

• Packets Sent—Number of IP datagrams sent per second by this SCTP 
association.

• Packets Received—Number of IP datagrams received per second by this 
SCTP association.

• Control Chunks Sent—Number of control chunks sent per second by this 
SCTP association.

• Control Chunks Received—Number of control chunks received per second 
by this SCTP association.

• Ordered Chunks Sent—Number of ordered chunks sent per second by this 
SCTP association.

• Ordered Chunks Received—Number of ordered chunks received per second 
by this SCTP association.

• Unordered Chunks Sent—Number of unordered chunks sent per second by 
this SCTP association.
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• Unordered Chunks Received—Number of unordered chunks received per 
second by this SCTP association.

• Retransmitted Chunks—Number of chunks retransmitted per second by 
this SCTP association.

• Retransmitted Fast Chunks—Number of fast chunks retransmitted per 
second by this SCTP association.

Charts Tab: ReceivedUtilization

To view real-time ReceivedUtilization information for the selected link, select the 
Charts tab. SGM displays the ReceivedUtilization chart (Figure 3-40).

Figure 3-40 ReceivedUtilization Chart for a Link
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The ReceivedUtilization chart displays the following information for the selected 
link:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Received Utilization Chart. Valid selections are 1, 2, 
5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.

• Received Utilization Chart—Displays the Receive Utilization % for the 
link as a function of time, as well as the average Receive Utilization % for 
all links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the receive utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
3-214
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Links
• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Received Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Charts Tab: SendUtilization

To view real-time SendUtilization information for the selected link, select the 
Charts tab. SGM displays the SendUtilization chart (Figure 3-41).

Figure 3-41 SendUtilization Chart for a Link
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The SendUtilization chart displays the following information for the selected link:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Send Utilization Chart. Valid selections are 1, 2, 5, 10, 
20, 40, or 60 minutes. The default selection is 5 minutes.

• Send Utilization Chart—Displays the Send Utilization % for the link as a 
function of time, as well as the average Send Utilization % for all links on 
the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the send utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Send Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Charts Tab: PktsRcvdPerSec

To view real-time packets-received-per-second information for the selected link, 
select the Charts tab. SGM displays the PktsRcvdPerSec chart (Figure 3-42).
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Figure 3-42 PktsRcvdPerSec Chart for a Link

The PktsRcvdPerSec chart displays the following information for the selected 
link:

SGM displays the following information in the PktsRcvdPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Received Chart. Valid selections are 1, 2, 5, 
10, 20, 40, or 60 minutes. The default selection is 5 minutes.
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• Packets Received Chart—Displays the Packets Received Per Sec for the 
link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets received per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Received Chart. To remove the data for a link from the chart, click 
the icon in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Charts Tab: PktsSentPerSec

To view real-time packets-sent-per-second information for the selected link, 
select the Charts tab. SGM displays the PktsSentPerSec chart (Figure 3-43).
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Figure 3-43 PktsSentPerSec Chart for a Link

The PktsSentPerSec chart displays the following information for the selected link:

SGM displays the following information in the PktsSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Sent Chart. Valid selections are 1, 2, 5, 10, 20, 
40, or 60 minutes. The default selection is 5 minutes.
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• Packets Sent Chart—Displays the Packets Sent Per Sec for the link as a 
function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Sent Chart. To remove the data for a link from the chart, click the 
icon in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Charts Tab: BitsRcvdPerSec

To view real-time bits-received-per-second information for the selected link (or 
bytes-received-per-second information, if you cleared the Show Details in Bits 
Instead of Bytes checkbox in the Preferences Window), select the Charts tab. 
SGM displays the BitsRcvdPerSec chart (Figure 3-44).

Figure 3-44 BitsRcvdPerSec Chart for a Link
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The BitsRcvdPerSec chart displays the following information for the selected 
link:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Received Chart or Bytes Received Chart. Valid 
selections are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 
5 minutes.

• Bits Received Chart or Bytes Received Chart—Displays the Bits Received 
Per Sec or Bytes Received Per Sec for the link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes (as set in the Preferences window) 
received per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Received Chart or Bytes Received Chart. To remove the data for a link 
from the chart, click the icon in this field. To return the data to the chart, click 
the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Charts Tab: BitsSentPerSec

To view real-time bits-sent-per-second information for the selected link (or 
bytes-sent-per-second information, if you cleared the Show Details in Bits 
Instead of Bytes checkbox in the Preferences Window), select the Charts tab. 
SGM displays the BitsSentPerSec chart (Figure 3-45).
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Figure 3-45 BitsSentPerSec Chart for a Link

The BitsSentPerSec chart displays the following information for the selected link:

SGM displays the following information in the BitsSentPerSec or 
BytesSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Sent Chart or Bytes Sent Chart. Valid selections 
are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.
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• Bits Sent Chart or Bytes Sent Chart—Displays the Bits Sent Per Sec or 
Bytes Sent Per Sec for the link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes (as set in the Preferences window) 
sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Sent Chart or Bytes Sent Chart. To remove the data for a link from the 
chart, click the icon in this field. To return the data to the chart, click the icon 
again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Charts Tab: Drops

To view drops information for the selected link, select the Charts tab. SGM 
displays the Drops chart (Figure 3-46).

Figure 3-46 Drops Chart for a Link
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The Drops chart displays the following information for the selected link:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
adjacent linkset, select it in this list box.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Drops Chart. Valid selections are 1, 2, 5, 10, 20, 40, or 
60 minutes. The default selection is 5 minutes.

• Drops Chart—Displays the Drops for the link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of drops for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Ctrl and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Shift 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Drops Chart. To remove the data for a link from the chart, click the icon in 
this field. To return the data to the chart, click the icon again.
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To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Editing a Link
SGM enables you to annotate a link, attaching a descriptive string to the link.

To annotate a link, right-click a link in a window, then select Edit Notes in the 
right-click menu.

SGM displays the Edit Notes Dialog for a Link (Figure 3-47).
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Figure 3-47 Edit Notes Dialog for a Link

The Edit Notes Dialog for a Link displays the name of the link and the date and 
time the Notes field for the link was last updated. If there is no note currently 
associated with the link, the Last Update field displays the value Not Set.
3-231
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Links
In the Notes field, enter any important information about the link, such as a 
detailed description, its location, its service history, and so on.

Click Save to save the annotations and exit the Edit Notes Dialog for a Link.

Viewing Notes for a Link
SGM enables you to view the notes that have been attached to links.

To view a note, right-click a link in a window, then select View >Notes in the 
right-click menu. (The Notes option is grayed-out if there is no note associated 
with the selected link.)

SGM displays the Link Notes dialog (Figure 3-48).

Figure 3-48 Link Notes Dialog
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The Link Notes dialog displays the following information:

• Name—Name of the link.

• Notes Last Updated—Date and time the Notes field for the link was last 
updated.

• Notes—Notes associated with the link.

Click OK to close the Link Notes dialog.

Deleting a Link
After Discovery, the links in your network are known to SGM and added to the 
SGM database. Physically deleting links from your network is not the same as 
deleting them from the SGM database. The following sections describe the 
differences between deleting links from your network and from the SGM 
database, and the procedures for doing so:

• Deleting a Link from Your Network, page 3-233

• Deleting a Link from the SGM Database, page 3-234

Deleting a Link from Your Network

If you physically delete a known link from your network, it remains in the SGM 
database, and SGM labels it Unknown, and it is the system administrator’s 
responsibility to delete it from the SGM database, if you choose to do so. The Link 
Details Window also displays -1 in the Xmit Queue field. SGM labels all 
associated nodes, signaling points, and linksets Warning.

When you redefine the link (that is, when you define a link with the same 
signaling link code ID [SLC] as the original link), SGM rediscovers the link and 
labels it with the appropriate status (such as Active).
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Deleting a Link from the SGM Database

Typically, you delete a link in the SGM database for one of the following reasons:

• You have physically deleted the link from your network. This is the most 
common reason for deleting a link from the SGM database.

• The link is Blocked, Failed, or Unknown, you are aware of the reason, and 
you no longer want to see it in SGM displays. For example, the link might be 
associated with a linkset that was removed from the network, or it might be a 
previously discovered link associated with a test lab device.

If you have physically deleted a known link from your network, and you then 
delete it from SGM, it is no longer in the SGM database, it does not appear in 
SGM windows, and it is not discovered when you run Discovery.

If you have not physically deleted a known link from your network, and you delete 
it from SGM, at the next poll SGM finds the link and adds it back to the SGM 
database, setting the status appropriately. If this happens, do not delete the link 
again. Instead, set it to Ignored. See the “Ignoring a Link” section on page 3-235 
for more information.

Note If you delete a link from the SGM database, the link is deleted for all SGM clients 
and views connected to that SGM server.

To delete a link from the SGM database, use one of the following procedures:

• Select a link in the Link Details window (Figure 3-37), then select Edit > 
Delete from the SGM Main Menu.

• Right-click a link in the Link Details window, then select Delete Link from 
the right-click menu.

SGM asks you to confirm the deletion.

• Select Yes to delete the selected link. SGM deletes the link from the SGM 
database. However, if the link was not physically deleted from your network, 
then at the next poll SGM finds the link and adds it back to the SGM database, 
setting the status appropriately.

• Select No to return to the Link Details window without deleting the link from 
the SGM database.
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Ignoring a Link
You can instruct SGM to ignore a link when it aggregates and displays network 
data. Setting links to Ignored prevents known link problems from affecting SGM 
displays for associated linksets and nodes. In effect, you are preventing a known 
problem from distracting you from other, more urgent network problems.

For example, you can set a link to Ignored before shutting down the link for 
maintenance.

Note If you set a link to Ignored, the link is ignored for all SGM clients and views 
connected to that SGM server.

Also, if you set a link to Ignored, make a note of the change, and do not forget to 
reset the link when the problem is corrected or the maintenance is complete.

To set a link to Ignored, right-click the link in the Link Details window 
(Figure 3-37), then select Ignore from the right-click menu.

Viewing Ignored Links
To display all links that are Ignored, display the Link Window and click the 
Ignored column header. SGM displays all ignored links at the top of the table.

Working with Events
SGM enables you to view detailed information about all discovered events, 
including their associated nodes, signaling points, linksets, links, and other 
information.

This section includes the following information:

• Viewing Basic Information for All Events, page 3-236

• Viewing Events for a Specific Object, page 3-240

• Viewing Detailed Information for an Event, page 3-243

• Viewing Real-Time Data for an Event, page 3-244
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• Setting an Event Filter, page 3-244

• Viewing Event Properties, page 3-253

• Attaching a Note to an Event, page 3-256

• Viewing Notes for an Event, page 3-258

Related Topics:

• Modifying the SGM Event Configuration File (Solaris Only), page 5-26

• Modifying Preference Settings, page 5-3

• Setting Sounds for Events at an SGM Client, page 5-40

• Viewing the Topology of the Network, page 3-259

• Working with Links, page 3-170

• Working with Linksets, page 3-37

• Working with Nodes, page 3-91

Viewing Basic Information for All Events
To view basic information for all events, select Events in the left pane of the SGM 
Main Window. SGM displays the Event Window (Figure 3-49).
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Figure 3-49 Event Window

The Event Window displays information about the events delivered by the SGM 
event logger and event processor for all nodes, signaling points, linksets, and links 
in the current network view.

Note You can display more than one Event Window at one time. This enables you to 
view multiple Event Windows at the same time, with different event filtering in 
each window or dialog.

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Ack Time, Node, and Linkset. To display these columns, or to 
hide other columns, see the procedures in the “Modifying Event Table Column 
Settings” section on page 5-19.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.
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The Event Window provides the following toolbar buttons:

• Set Filter—Opens the Event Filter dialog.

• Apply Filter—Activates and deactivates the event filter specified in the 
Event Filter dialog:

– If the filter is activated, SGM displays only those events that pass the 
filter.

– If the filter is deactivated, SGM displays all events.

• Acknowledge—Makes s the selected event or events acknowledged.

• Unacknowledge—Makes the selected event or events unacknowledged.

• Event Properties—Opens the Event Properties window.

• Edit Notes—Opens the Edit Event Dialog.

• Time Difference—Displays the difference in days, minutes, hours, and 
seconds between two events.

• Find—Finds a specific event.

• Help for Event—Displays context-sensitive help for the selected event in a 
separate Web browser.

The Event Window displays the following information for each event:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.
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– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.

– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.
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• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.

• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Message associated with the event.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

Viewing Events for a Specific Object
To display the Recent Events panel, with events displayed for only the selected 
node, signaling point, linkset, or link, right-click a node, signaling point, linkset, 
or link in a window, then select View >Events from the right-click menu.

• If you right-clicked a node, SGM displays the Recent Events panel for the 
node (Figure 3-25). For more information, see the “Viewing Detailed 
Information for a Node” section on page 3-96.

• If you right-clicked a signaling point, SGM displays the Recent Events panel 
for the signaling point (Figure 3-32).

• If you right-clicked a linkset, SGM displays the Recent Events panel for the 
linkset (Figure 3-12).

• If you right-clicked a link, SGM displays the Recent Events panel for the link 
(Figure 3-38).
3-240
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Events
By default, SGM displays all of the columns in the Recent Events panel except 
Internal ID, Note, Ack By, Ack Time, Node, SP, Linkset, and Link. To display 
these columns, or to hide other columns, see the procedures in the “Modifying 
Event Table Column Settings” section on page 5-19.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-279 for more details.

The Recent Events panel enables you to perform event-related tasks, such as 
setting filters and acknowledging events. For more information about these tasks, 
see the “Working with Events” section on page 3-235.

The Recent Events panel displays the following information for the selected node:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, signaling point, and node, assigned by SGM for its 
own internal use. It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, use the Acknowledge toolbar 
button.

– To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.

– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.
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– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.

– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—If you have not implemented SGM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented SGM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.
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• Ack Time—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• SP—Name of the signaling point associated with the event. If there is no 
signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.

• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

Viewing Detailed Information for an Event
SGM enables you to display detailed configuration information for the node, 
signaling point, linkset, or link associated with a specific event.

To display detailed information for an event, select Events in the left pane of the 
SGM Main Window, right-click an event in a window, then select 
View >Configuration Details in the right-click menu.

• If the event is associated with a node, SGM displays the Configuration Data 
tab of the Node Details Window (Figure 3-24). For more information, see the 
“Viewing Detailed Information for a Node” section on page 3-96.

• If the event is associated with a signaling point, SGM displays the 
Configuration Data tab of the Signaling Point Details Window (Figure 3-31). 
For more information, see the “Viewing Detailed Information for a Signaling 
Point” section on page 3-141.

• If the event is associated with a linkset, SGM displays the Configuration Data 
tab of the Linkset Details Window (Figure 3-11). For more information, see 
the “Viewing Detailed Information for a Linkset” section on page 3-42.
3-243
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Events
• If the event is associated with a link, SGM displays the Configuration Data 
tab of the Link Details Window (Figure 3-37). For more information, see the 
“Viewing Detailed Information for a Link” section on page 3-175.

Viewing Real-Time Data for an Event
SGM enables you to display detailed statistics for the node, linkset, or link 
associated with a specific event.

To display detailed statistics for an event, select Events in the left pane of the 
SGM Main Window, right-click an event in the right pane, then select 
View >Real-Time Data and Charts in the right-click menu.

• If the event is associated with a node, SGM displays the SGM Real-Time 
Statistics: CPU Statistics window (Figure 3-26). For more information, see 
the “Viewing CPU Statistics for a Node” section on page 3-121.

• If the event is associated with a linkset, SGM displays the Statistics Details 
Window for a Linkset (Figure 3-13). For more information, see the “Viewing 
Real-Time Data for a Linkset” section on page 3-54.

• If the event is associated with a link, SGM displays the Statistics Details 
Window for a Link (Figure 3-37). For more information, see the “Viewing 
Real-Time Data for a Link” section on page 3-186.

Setting an Event Filter
To modify the way SGM presents event information, use the following procedure:

Step 1 Select Event Tools > Set Filter from the SGM Main Menu. SGM displays the 
Event Filter dialog with the Properties tab selected (Figure 3-50).
3-244
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Events
Figure 3-50 Event Filter Dialog, Showing Event Properties

Step 2 (Optional) To specify which event categories you want to display in the Event 
Window, select the Properties tab and modify the following settings:

• Status—Checkbox used to indicate whether Status events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• Edit—Checkbox used to indicate whether Edit events are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

• OverWrite—Checkbox used to indicate whether OverWrite events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.
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• Trap—Checkbox used to indicate whether Trap events are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

• Ignore—Checkbox used to indicate whether Ignore events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• Poll—Checkbox used to indicate whether Poll events are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

• Create—Checkbox used to indicate whether Create events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• Login—Checkbox used to indicate whether Login events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• Purge—Checkbox used to indicate whether Purge events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• Delete—Checkbox used to indicate whether Delete events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• LoginDisable—Checkbox used to indicate whether LoginDisable events are 
to be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Discover—Checkbox used to indicate whether Discover events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• LoginFail—Checkbox used to indicate whether LoginFail events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

To select all event category checkboxes. click Select All.

To clear all event category checkboxes, click Deselect All.

Note These are the default categories; there might be additional categories, as 
defined by the SGM system administrator. For information about custom 
categories, see the “Modifying the SGM Event Configuration File 
(Solaris Only)” section on page 5-26.
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Step 3 (Optional) To specify which event severities you want to display in the Event 
Window, select the Properties tab and modify the following settings:

• None—Checkbox used to indicate whether events of severity None are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• Normal—Checkbox used to indicate whether events of severity Normal are 
to be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Admin—Checkbox used to indicate whether events of severity Admin are to 
be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Warning—Checkbox used to indicate whether events of severity Warning are 
to be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Error—Checkbox used to indicate whether events of severity Error are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

Note There might be additional custom severities, as defined by your SGM 
System Administrator. For information, see the “Modifying the SGM 
Event Configuration File (Solaris Only)” section on page 5-26.
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Step 4 (Optional) To further define the event filter for the Event Window, select the 
Properties tab and modify the following settings:

• Acknowledged—Checkbox used to indicate whether only acknowledged 
events are to be displayed in the Event Window. The default setting for this 
checkbox is cleared.

• Unacknowledged—Checkbox used to indicate whether only 
unacknowledged events are to be displayed in the Event Window. The default 
setting for this checkbox is selected.

• Time Before—Checkbox used to indicate whether only events logged by 
SGM prior to a specified date and time are to be displayed in the Event 
Window. The default setting for this checkbox is cleared.

• Time Before Field—Specifies the date and time prior to which events logged 
by SGM are to be displayed in the Event Window. This field is grayed-out 
unless the Time Before checkbox is selected.

• Time After—Checkbox used to indicate whether only events logged by SGM 
after a specified date and time are to be displayed in the Event Window. The 
default setting for this checkbox is cleared.

• Time After Field—Specifies the date and time after which events logged by 
SGM are to be displayed in the Event Window. This field is grayed-out unless 
the Time After checkbox is selected.

• Message Contains—Checkbox used to indicate whether only events that 
contain the specified message text are to be displayed in the Event Window. 
The default setting for this checkbox is cleared.

• Match Case—Checkbox used to indicate whether only events that match the 
case of the text in the Message Contains field are to be displayed in the Event 
Window. This field is grayed-out unless the Message Contains checkbox is 
selected. If the Message Contains checkbox is selected, the default setting 
for this checkbox is cleared.

These settings are applied to all event displays in the current view.
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Step 5 (Optional) To specify the node, signaling point, linkset, and link for which SGM 
is to display events in the Event Window, select the Selected Objects tab. SGM 
displays the Event Filter dialog with the Selected Objects tab highlighted 
(Figure 3-51).

Figure 3-51 Event Filter Dialog, Showing Event Selected Objects
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You can modify the following settings:

• Node—Drop-down list box of all nodes that have been discovered by SGM:

– If you want to filter events based on a node, select a node from the 
drop-down list box.

– If you do not want to filter events based on a node, select None. SGM 
grays-out the SP, Linkset, and Link fields. This is the default setting.

• SP—Drop-down list box of all signaling points associated with the selected 
node:

– If you want to filter events based on a signaling point, select a signaling 
point from the drop-down list box.

– If you do not want to filter events based on a signaling point, select None. 
SGM grays-out the Linkset and Link fields. This is the default setting.

• Linkset—Drop-down list box of all linksets associated with the selected 
signaling point:

– If you want to filter events based on a linkset, select a linkset from the 
drop-down list box.

– If you do not want to filter events based on a linkset, select None. SGM 
grays-out the Link field. This is the default setting.

• Link—Drop-down list box of all links that have been discovered by SGM:

– If you want to filter events based on a link, select a link from the 
drop-down list box.

– If you do not want to filter events based on a link, select None. This is 
the default setting.

• To restore Node to None, grays-out SP, Linkset, and Link, click Reset.

Step 6 (Optional) To load an existing event filter, click Load in the Event Filter dialog. 
SGM displays the Load File Dialog: Load Filter dialog (Figure 3-52).
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Figure 3-52 Load File Dialog: Load Filter Dialog

The Load File Dialog: Load Filter dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the event filter file or folder.

• Last Modified—Date and time the event filter file or folder was last 
modified.

• Size (bytes)—Size of the event filter file or folder, in bytes.

• Number of Files—Total number of event filter files and folders (displayed in 
bottom left corner).

To load an event filter file, enter the name of the file or select it in the list and click 
OK. SGM loads the event filter file, closes the Load File Dialog: Load Filter 
dialog, and returns to the Event Filter dialog.

To delete an event filter file from the event filter file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.
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To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: Load Filter dialog.

To close the Load File Dialog: Load Filter dialog without loading an event filter 
file or saving any changes to the event filter file list, click Cancel.

Step 7 (Optional) To apply any changes you made to the event filter without closing the 
Event Filter dialog, click Apply.

Step 8 (Optional) To close the Event Filter dialog without saving any changes to the 
event filter file or event filter file list, click Cancel.

Step 9 When you are satisfied with the filter settings, click Save. SGM displays the Save 
File Dialog: Save Filter dialog (Figure 3-53).

Figure 3-53 Save File Dialog: Save Filter Dialog

The Save File Dialog: Save Filter dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the event filter file or folder.
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• Last Modified—Date and time the event filter file or folder was last 
modified.

• Size (bytes)—Size of the event filter file or folder, in bytes.

• Filename—Name by which you want to save the event filter file.

If you create a new event filter file name, you can use any letters, numbers, 
or characters in the name that are allowed by your operating system. 
However, if you include any spaces in the new name, SGM converts those 
spaces to dashes. For example, SGM saves file “a b c” as “a-b-c”.

• Number of Files—Total number of event filter files and folders (displayed in 
bottom left corner).

To save the event filter file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old event filter file, 
select the name in the list and click OK.

SGM saves the event filter file with the new name, closes the Save File Dialog: 
Save Filter dialog, and returns to the Event Filter dialog.

To delete an event filter file from the event filter file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: Save Filter dialog.

To close the Save File Dialog: Save Filter dialog without saving the event filter 
file or saving any changes to the event filter file list, click Cancel.

Viewing Event Properties
SGM enables you to view detailed information about a selected event, including 
its associated node, signaling point, linkset, status, and other information.

To view detailed information about an event, right-click the event in a window, 
then select Event Properties in the right-click menu.

SGM displays the Event Properties Dialog (Figure 3-54).
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Figure 3-54 Event Properties Dialog

The Event Properties dialog provides the following information for the selected 
event:

• Properties Tab—Displays detailed information about the selected event.

• Message—Message text for the event.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node, signaling point, 
linkset, or file.

– Discover—Discovery event, such as Discovery beginning.
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– Edit—Edit event. A user has edited a node, signaling point, linkset, or 
link.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.

– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-26 for more 
information.

• Timestamp—Date and time the event was logged.

• Acknowledged—Indicates whether the event has been acknowledged.
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• Acknowledged By—Name of the device that last acknowledged the event. If 
no one has acknowledged the event, this field is blank.

• Ack Timestamp—Date and time the event was last acknowledged or 
unacknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• Signaling Point—Name of the signaling point associated with the event. If 
there is no signaling point associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.

• Link—Name of the link associated with the event. If there is no link 
associated with the event, None is displayed.

• Notes Tab—Displays notes associated with this event.

• Last Update—Date and time the Notes field for this event was last updated. 
If there is no note currently associated with this event, this field displays the 
value Not Set.

• Notes—Notes associated with this event. If there is no note currently 
associated with this event, this field displays the value No Notes.

Attaching a Note to an Event
SGM enables you to annotate an event, attaching a descriptive string to the event.

To annotate an event, right-click an event in the Event Window, then select Edit 
Notes in the right-click menu.

SGM displays the Edit Event Dialog (Figure 3-55).
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Figure 3-55 Edit Event Dialog

The Edit Event Dialog displays the message text of the event and the date and time 
the Notes field for the event was last updated. If there is no note currently 
associated with the event, the Last Update field displays the value Not Set.

In the Notes field, enter any important information about the event, such as its 
associated node, signaling point, or linkset, what triggered the event, how often it 
has occurred, and so on.

Click Save to save the annotations and exit the Edit Event Dialog.
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Viewing Notes for an Event
SGM enables you to view the notes that have been attached to events.

To view a note, use one of the following procedures:

• Select an event in a window, then select View > Notes from the SGM Main 
Menu.

• Right-click an event in the Event Window, then select View > Notes in the 
right-click menu.

If the event has an attached note, SGM displays the Event Notes dialog 
(Figure 3-56). (If the event does not have an attached note, SGM displays the 
message, “The event does not have any notes.”)

Figure 3-56 Event Notes Dialog
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The Event Notes dialog displays the following information:

• Name—Message text of the event.

• Last Updated—Date and time the Notes field for the event was last updated.

• Notes—Notes associated with the event.

Click OK to close the Event Notes dialog.

Viewing the Topology of the Network
In addition to tabular (text) views of your network, SGM provides a topology 
(graphical) view of the signaling points and linksets in your network, including 
adjacent legacy SS7 devices, and enables you to customize the view to meet your 
needs.

Related Topics:

• Modifying Preference Settings, page 5-3

• Working with Links, page 3-170

• Working with Linksets, page 3-37

• Working with Nodes, page 3-91

• Working with Views, page 3-26

To view the topology of your network:

Step 1 Use one of the following procedures:

• Select View > Show Topology from the SGM Main Menu.

• Right-click a signaling point, linkset, link, or event, then select View > 
Center in Topo in the right-click menu.

SGM displays the Topology window (Figure 3-57).
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Figure 3-57 Topology Window

The Topology Window displays tabular information about signaling points and 
linksets in the left pane and the graphical topology map in the right pane.

Linksets that are associated with signaling points that are excluded from the 
current view are not displayed in the topology map. See the “Creating a View” 
section on page 3-27 for more information about excluding signaling points.
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SGM automatically assigns the following node elements:

• Cisco 2650 series router

• Cisco 2650XM series router

• Cisco 2651 series router

• Cisco 2651XM series router

• Cisco 7204 series router

• Cisco 7204VXR series router

• Cisco 7206 series router

• Cisco 7206VXR series router

• Cisco 7507 series router

• Cisco 7507mx series router

• Cisco 7507z series router

• Cisco 7513 series router

• Cisco 7513mx series router

• Cisco 7513z series router

• IP device, other than other than those listed above (if assigned by a user; see 
the “Editing a Node” section on page 3-124 for more details)

• Signaling point—An SCP, SSP, or STP, or an ITP instance.

• SS7—SGM is unable to determine the node type.

In addition, users can assign the following node elements (see the “Editing a 
Node” section on page 3-124 for more details):

• MSC—Mobile switching center

• SCP—Service control point

• SSP—Service switching point

• STP—Signal transfer point
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A line indicates a single logical connection configured between two nodes:

• A line that ends in a diamond or circle indicates that the connection has a 
configured linkset, associated with that node.

• A line that does not end in a diamond or circle indicates that the linkset is not 
configured on that ITP or cannot be displayed because SGM is not managing 
that node.

• A heavy line indicates that there are two or more linksets configured between 
two signaling points.

The color of a graphical element indicates its current status.

• For nodes, the possible colors are:

– Green—The node is currently in Active status.

– Yellow—The node is currently in Warning status.

– Gray—The node is currently in Discovering, Polling, Unmanaged, or 
Waiting status.

– Red—The node is currently in Unknown status.

• For linksets (diamonds or circles), the possible colors are:

– Green—The linkset is in Active status.

– Blue—The linkset is in Shutdown status.

– Yellow—The linkset is in Warning status.

– Red—The linkset is in either Unavailable or Unknown status.

Note If there is more than one linkset configured on the connection, the status 
color is an aggregation of the status of every linkset on that connection.

A note icon in the upper left corner of a node element means the node has been 
annotated. That is, a user has attached a descriptive string to the node. A dot in 
the diamond or circle at the end of the line means a note has been attached to the 
linkset.

An event icon (orange triangle) in the upper right corner of a node element means 
there is a recent event associated with the node.

The topology map also provide right-click menus for linksets and signaling 
points.
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Step 2 The topology signaling point table in the left pane of the Topology window 
displays the name and status of the signaling points that are currently displayed 
in the topology map. To display the topology signaling point table, select the 
Tables tab in the left pane. By default, this table is sorted by Status.

To redraw the topology map centered on a specific signaling point, double-click 
on the signaling point in this table.

You cannot select more than one signaling point at a time in this table.

Step 3 The topology linkset table in the left pane of the Topology window displays the 
name and status of the linksets that are displayed in the topology map. To display 
the topology linkset table, select the Tables tab in the left pane of the Topology 
Window, then select a signaling point in the topology signaling point table, or a 
signaling point in the topology map. The topology linkset table is displayed below 
the topology signaling point table.

To redraw the topology map centered on a specific linkset, double-click on the 
linkset in this table.

You cannot select more than one linkset at a time in this table.

Step 4 (Optional) In the topology linkset table, you can select the Ignored checkbox to 
ignore a linkset when displaying SGM data, or clear the checkbox to include the 
linkset. For more information, see the “Ignoring a Linkset” section on page 3-90.

Step 5 (Optional) To highlight an element in the topology signaling point table or 
topology linkset table in the left pane, click it in the topology map:

• Click a signaling point to highlight the signaling point in the topology 
signaling point table, and to display any associated linksets in the topology 
linkset table.

• Click a single line, a heavy line, a diamond, or a circle, to display the 
following information:

– Highlight the closest associated node in the topology signaling point 
table. For example, if there is a line connecting node sgm-2600a and 
node sgm-2600b, and you click the line closer to node sgm-2600a, then 
that node is highlighted in the topology signaling point table.

– Display all linksets (if any) associated with that node in the topology 
linkset table.

– Highlight the clicked linkset (if it is configured) in the topology linkset 
table.
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Step 6 To see mouse over help popup in the topology map, place the cursor over a 
signaling point or linkset. When you place the cursor over a linkset, the mouse 
over help popup is displayed from the perspective of the closest signaling point.

Note You can turn off mouse over help. For details, see Step 5 in the 
“Modifying Overall Preference Settings” section on page 5-5.

Step 7 (Optional) To make the topology map twice as large, click the Zoom the map by 
a factor of 200% button, or select Topology Tools > Zoom > In from the SGM 
Main Menu.

Step 8 (Optional) To make the topology map half as large, click the Zoom the map by a 
factor of 50% button, or select Topology Tools > Zoom > Out from the SGM 
Main Menu.

Step 9 (Optional) To zoom the topology map by a selected percentage, click the Select a 
map viewing factor button, then either select a percentage from the drop-down 
list box, or enter a percentage and click Enter. Valid values are integers in the 
range 5 through 400.

Step 10 (Optional) To zoom in on a selected area of the topology map, click the Zoom in 
on an area button, or select Topology Tools > Zoom > Area from the SGM Main 
Menu, then click in the topology map and drag a rectangle around the area you 
want to zoom in on. SGM expands the selected area to fill the topology map.

Step 11 (Optional) To adjust the size of the topology map to fit in the window, click the 
Zoom to fit window button, or select Topology Tools > Zoom > Fit from the 
SGM Main Menu. This is the default setting the first time the map is displayed.

Step 12 (Optional) To display the topology map in a circular layout, click the Circular 
layout button, or select Topology Tools > Layout > Circular from the SGM Main 
Menu.
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Step 13 (Optional) To display the topology map in a spring layout, click the Spring layout 
button, or select Topology Tools > Layout > Spring In a spring layout, nodes 
with the most links are drawn closer to the center of the map, while nodes with 
fewer links are drawn farther away. This is the default setting the first time the 
map is displayed.

Note You can modify how far apart nodes are spaced when SGM draws the 
spring layout. For details, see Step 5 in the “Modifying Overall 
Preference Settings” section on page 5-5.

Step 14 (Optional) To create a custom layout for the topology map, move the signaling 
points around, grouping them or isolating them to meet your needs.

To move a single signaling point, click the left mouse button to select the 
signaling point in the map and, while holding down the left mouse button, move 
the mouse to move the signaling point to its new position.

To move more than one signaling point at the same time, use the following 
procedure:

a. Press and hold down the Shift key on your keyboard.

b. Still holding down Shift, click the left mouse button to select the signaling 
points you want to move in the map.

c. Still holding down Shift, select one of the signaling points you want to move 
and hold down the left mouse button.

d. Still holding down both Shift and the left mouse button, move the mouse to 
move the signaling points to their new position. The moved signaling points 
keep their positions relative to each other.

e. Release both Shift and the left mouse button.

When you are satisfied with the new topology map layout, select File > Save View 
from the SGM Main Menu. SGM saves the changes you have made to the network 
view, including any changes you have made to the topology map layout.

Step 15 (Optional) To restore the topology map to the way it looked in the last saved view, 
select Topology Tools > Restore Positions from the SGM Main Menu. SGM 
restores the view.
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Step 16 (Optional) Some topology maps are so large and complex that it can be difficult 
to find a specific signaling point or linkset.

If the signaling point or linkset is listed in the tables in the left pane of the 
Topology Window, simply select the signaling point or linkset, and SGM 
highlights it in the topology map.

If the signaling point or linkset is not listed in the tables, use the following 
procedure:

a. Click the Find signaling points or linksets (binoculars) button in the 
Topology Window, or select Edit > Find from the SGM Main Menu. SGM 
displays the Find Signaling Points or Linksets dialog, which enables you to 
find and highlight a signaling point or linkset in the Topology Window

b. In the Search string field, enter a character string for which SGM is to 
search.

c. To search for a linkset, select the Linksets checkbox. To search for a 
signaling point, select the Signaling Points checkbox, then select or clear the 
Name and Point Code checkboxes, to further widen or refine the search.

d. Click OK to launch the search.

If no matching signaling point or linkset is found, SGM displays an 
appropriate message.

If exactly one signaling point or linkset is found that matches the Search 
string, SGM highlights the signaling point or linkset in the Tables panel of 
the Topology window, and zooms in on the selected signaling point or linkset 
in the topology map.

If more than one signaling point or linkset is found that matches the Search 
string, SGM displays the Choose dialog, enabling you to select from a list of 
the found objects. SGM then highlights the selected signaling point or linkset 
in the Tables panel of the Topology window, and zooms in on the selected 
signaling point or linkset in the topology map.

Step 17 (Optional) To scroll around in the topology map, click anywhere in the map, then 
click the arrow, Page Up, and Page Down keys.

Step 18 (Optional) To redraw the topology map centered on a specific signaling point or 
linkset, double-click on the signaling point or linkset in the topology signaling 
point table in the left pane of the window.
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Step 19 (Optional) To display detailed information about an element in the map, 
double-click it, then respond to SGM’s prompts:

• Double-click a signaling point to display the Details Window for that 
signaling point.

• Double-click a single line, or a diamond or circle at the end of a single line, 
to display the Linkset Details Window for that linkset.

• Double-click a heavy line, or a diamond or circle at the end of a heavy line, 
to display the Selection Dialog. Then select one of the linksets to display the 
Linkset Details Window for that linkset.

Step 20 (Optional) To display the topology new signaling point panel, select the New 
Signaling Points tab in the left pane. The topology new signaling point panel 
displays graphical elements for newly discovered signaling points, based on the 
following criteria:

• If you are using an SGM client with the DEFAULT view set, this panel never 
contains any signaling points. In the DEFAULT view, SGM adds all newly 
discovered signaling points to the topology map as soon as they are 
discovered.

• If you are using an SGM client with a custom view set, this panel contains all 
signaling points discovered since the Topology window was opened in this 
session that have not been excluded in the Signaling Points Excluded from 
View table of the Network View Editor window, or that are not in the current 
view.

a. (Optional) To add a newly discovered signaling point to the topology map, 
select one or more signaling points in the topology new signaling point panel 
and drag them to the map while holding down the left mouse button.

b. (Optional) To exclude a newly discovered signaling point from the topology 
new signaling point panel, see the “Working with Views” section on 
page 3-26.
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Step 21 (Optional) To display the topology excluded signaling point panel, select the 
Excluded Signaling Points tab in the left pane. The topology new signaling point 
panel displays graphical elements for excluded signaling points. Excluded 
signaling points are signaling points that you have chosen not to manage, that you 
have moved to the Signaling Points Excluded from View table of the Network 
View Editor window. (See the “Creating a View” section on page 3-27 for more 
information about excluding signaling points from views.)

To add an excluded signaling point to the topology map, select the signaling point 
and drag it to the map while holding down the left mouse button. When you do so, 
the signaling point is no longer an excluded node, and it is removed from the 
Signaling Points Excluded from View table of the Network View Editor window.

Step 22 (Optional) To print the topology map, see the “Printing SGM Windows” section 
on page 3-398.

Step 23 (Optional) To save the topology map as a JPEG file, select Topology Tools > Save 
as JPEG from the SGM Main Menu. SGM displays the Save as JPEG dialog 
(Figure 3-58).

Figure 3-58 Save as JPEG Dialog
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The Save as JPEG dialog provides the following options:

• To save the entire topology map as a JPEG file, select All.

• To save just the portion of the topology map displayed in the current window 
as a JPEG file, select Current Window.

• To specify the quality of the JPEG file, select a Quality level, from 0 (lowest 
quality) to 1.0 (highest quality). The default setting is 0.7, which is sufficient 
for most JPEG files.

• To specify the size of the JPEG file, in pixels, choose a value from the Max. 
Size drop-down list box. The valid range is 400 pixels to 2400 pixels. The 
default value is 400 pixels, which is sufficient for most JPEG files.

• To specify a name for the JPEG file, enter the name in the Name field, or 
accept the default filename, out.jpg.

The default directory for the JPEG file is the directory in which you installed 
the SGM client:

– In Solaris, the default installation directory for the SGM client is 
/opt/CSCOsgmClient.

– In Windows, the default installation directory for the SGM client is 
C:\Program Files\SGMClient\.

– If you installed the SGM client in a different directory, then the 
installation directory is located in that directory.

To save the JPEG file in the default directory, click Save. SGM saves the 
JPEG file and closes the Save as JPEG dialog. Continue with Step 24.

If you do not want to save the JPEG file to the default directory, click Browse 
to select a different directory. SGM displays the Save dialog for a topology 
map (Figure 3-59).
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Figure 3-59 Save Dialog for a Topology Map

The Save dialog for a topology map provides the following options:

– To select the directory in which you want to save the topology map JPEG 
file, either accept the default directory displayed in the Save In field, or 
select a new directory from the drop-down list box.

– To display the sub-folders and files that are in the folder that is up one 
level from the currently displayed folder, click the Up One Level button.

– To display the sub-folders and files that are on your workstation desktop, 
click the Desktop button.

– To create a new sub-folder in the displayed folder, click the Create New 
Folder button.

– To display only icons for sub-folders and files, click the List button.

– To display detailed information for sub-folders and files, including their 
size, type, date they were last modified, and so on, click the Details 
button.
3-270
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Viewing the Topology of the Network
– To specify a name for the JPEG file, enter the name in the File Name 
field, or select a file from those listed in the Save In field.

– To specify the type of file to save, and to display all files of that type in 
the selected directory, select a file type from the Files of Type drop-down 
list box:

– All files—Displays all files in the selected directory, and saves the 
topology map file as a JPEG file.

– jpg files—Displays only JPEG files in the selected directory, and saves 
the topology map file as a JPEG file.

When you are satisfied with the settings, click Save. SGM closes the Save 
dialog for a topology map and populates the Name field in the Save as JPEG 
dialog with the new name and directory.

To save the JPEG file in the new directory, click Save. SGM saves the JPEG 
file and closes the Save as JPEG dialog.

Step 24 (Optional) You can activate a magnetic grid on the topology map. With the grid 
activated, objects “snap” to align with the grid when you move them.

To activate or modify the magnetic topology grid, select Topology Tools > 
Magnetic Grid from the SGM Main Menu. SGM displays the Magnetic Grid 
Settings dialog (Figure 3-60).

Figure 3-60 Magnetic Grid Settings Dialog
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The Magnetic Grid Settings dialog provides the following options:

• To activate the grid, select the Grid Activated checkbox.

To deactivate the grid, clear the Grid Activated checkbox.

• To display the grid on the topology map, select the Grid Activated checkbox, 
then select the Display Grid checkbox.

To hide the grid on the topology map, clear the Display Grid checkbox.

• To specify the spacing between lines on the grid, in pixels, select the Grid 
Activated checkbox, then select a Grid Spacing level. The valid range is 
0 pixels to 150 pixels. The default setting is 50 pixels, which is sufficient for 
most topology maps.

• To specify a color for the grid, select the Grid Activated checkbox, then click 
Select in the Grid Color field. SGM opens the Pick Grid Color dialog 
(Figure 3-61).

Figure 3-61 Pick Grid Color Dialog
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The Pick Grid Color dialog provides the following options:

– To select a grid color from a set of color swatches (the recommended 
method), click the Swatches tab and select a swatch.

– To select a grid color based on color hue, saturation, and brightness 
(HSB), click the HSB tab, then use one of the following procedures:

- Select a color range on the vertical color bar, then select a specific color 
by moving the cursor around on the color square.

- Enter specific values in the hue (H), saturation (S), and brightness (B) 
fields.

– To select a grid color based on the red, green, and blue (RGB) content of 
the color, click the RGB tab, then select values for the Red, Green, and 
Blue fields.

– To reset the grid color to its initial setting, click Reset.

Whichever method you choose, the selected color is displayed in the Preview 
field. When you are satisfied with the color, click OK. SGM saves the grid 
color setting and closes the Pick Grid Color dialog.

When you are satisfied with the magnetic grid settings, click OK. SGM saves the 
new grid settings and closes the Magnetic Grid Settings dialog

Note Magnetic grid settings, including the grid color, are not saved when you 
save the view.

To close the Magnetic Grid Settings dialog without changing any settings, click 
Cancel.

Step 25 (Optional) To hide all non-ITP nodes and linksets on the topology map (the 
default setting), click the Hide/Show Non-ITP Devices button. (The hidden 
signaling points and linksets are still shown in the left pane.) To display all hidden 
nodes and linksets on the topology map, click the Hide/Show Non-ITP Devices 
button again. This setting, with non-ITP nodes and linksets either hidden or 
shown, is saved when you save the view.
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Step 26 (Optional) To have SGM hide linkset lines as you drag an object around the 
topology map, then draw the linkset lines when you drop the object in its final 
position, click the Node Dragging Optimizer button to turn it on. This is the 
default setting.

To have SGM continually redraw linkset lines as you drag an object around the 
topology map, click the Node Dragging Optimizer button to turn it off.

This setting, with the Node Dragging Optimizer on or off, is saved when you save 
the view.

Step 27 When you are ready to close the Topology Window, select File > Save View from 
the SGM Main Menu. SGM prompts you to save any changes you made to the 
network view, including any changes you have made to the topology map layout, 
and closes the window.

Viewing Server Status Information
SGM can display detailed information about the processes, pollers, tasks, and 
clients for the server to which you are connected, and which is currently running 
the SGM server.

To display server status information, select View > Server> Status Information 
in the SGM Main Menu. SGM displays the Server Status Information window 
(Figure 3-62).
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Figure 3-62 Server Status Information Window

The Server Status Information window displays the following information about 
polling:

• Current Poll Interval—Poll interval used to collect data for the table.

• Last Poll—Time the last poll was run. This field initially displays the phrase 
Polling device. After the first polling cycle, SGM populates this field with the 
actual time of the last poll.

To force an immediate poll at any time, and to refresh the Server Status 
Information window with the latest data, click Update.

To close the Server Status Information window at any time, click Close.

The Processes section displays the following information about the processes that 
are managed by the SGM serve Process Manager:

• Name—Name of the process, such as sgmDataServer.

• Version—Version number of the process application, such as 3.0.0.L1.

• Process ID—Number to uniquely identify the process.
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• State—Current state of the process. Valid values are:

– Initial (yellow ball)—Process is being initialized.

– Starting (yellow ball)—Process has been started but is not yet in Ready 
state.

– Ready (green ball)—Process has been started and is currently running.

– Stopping (red ball)—Process is being stopped.

– Stopped (red ball)—Process has been stopped.

• Last Message—Status message that reflects the current state of the process, 
such as Running.

The Processes section displays the following information about the processes that 
are not managed by the SGM serve Process Manager:

• Name—Name of the process, such as sgmNameServer.

• Process ID—Number to uniquely identify the process.

• Is Running—Indicates whether the process is running (true) or not (false).

The Pollers table displays the following information about the detail and demand 
pollers that are currently being processed by the SGM server:

• Poller ID—Number to uniquely identify each SGM detail poller that is 
currently active. SGM detail pollers collect detailed data (such as real-time 
data, statistics, route detail, GTT MAP status, and so on) that is not collected 
by the regular SGM poller.

• Client Host—Name of the SGM client that started the detail poller.

• Interval—Poll interval for the detail poller, in hours, minutes, and seconds.

• Iteration—Number of times the detail poller is to poll. If this field displays 
Forever, the detail poller will never stop polling, until requested to stop by 
the SGM client.

• Next Poll—Time until the next poll, in hours, minutes, and seconds.

• Description—Description of the detail poller.
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The Tasks table displays the following information about the long-running 
services being performed by the SGM server:

• Task ID—Number to uniquely identify the task.

• Interval—Time between runs for the task, in hours, minutes, and seconds.

• Iteration—Number of times the task is to run. If this field displays Forever, 
the task will never stop polling.

• Next Execution—Time until the next run for the task, in hours, minutes, and 
seconds.

• State—Current state of the task. Valid values are:

– None—Task is stopped.

– Waiting—Task is waiting to transition to Ready or Running state.

– Ready—Task is ready to execute but is not yet in Running state.

– Running—Task has been started and is currently executing.

– Pending—Task was in Ready state when it was canceled by a user. The 
task is pending final removal from the scheduler.

– Error—Task encountered an error.

– Dying—Task was in Running state when it was canceled by a user. The 
task continues to run in Dying state until it completes, then it is removed 
from the scheduler.

• Description—Description of the task.

The Tasks table displays the following information about the SGM clients that are 
currently connected to the SGM server:

• Process Name—Name of an SGM client that is currently connected to the 
server.

• User Name—Name of an SGM client user who is currently logged in and 
connected to the server.

• Is Sleeping—Indicates whether the thread that is responsible for delivering 
messages is sleeping (true) or not (false).

• Sleep Time—Time in seconds the thread that is responsible for delivering 
messages has been sleeping.

• Queue Size—Number of messages waiting to be sent to the SGM client.
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Finding Information in a Window
Sometimes it can be difficult to find a specific piece of information, such as a node 
name or event text, in a window. SGM enables you to search for a character string 
in the Node, Signaling Point, Linkset, and Event Windows.

Note To find a specific signaling point or linkset in the Topology Window, see Step 16 
in the “Viewing the Topology of the Network” section on page 3-259.

Related Topics:

• Working with Events, page 3-235

• Working with Linksets, page 3-37

• Working with Nodes, page 3-91

To find a character string in a window:

Step 1 In the Node, Signaling Point, Linkset, or Event Window, select Edit > Find from 
the SGM Main Menu. SGM displays the Find dialog (Figure 3-63).

Figure 3-63 Find Dialog

Step 2 In the What field, enter the character string for which you want SGM to search. 
This can be any character string: all or part of a node name, linkset name, point 
code, event text, status, and so on.

Step 3 (Optional) If you want SGM to search for only character strings that match the 
case of the text in the What field, select the Match Case checkbox. If you do not 
care about case-matching, clear the checkbox. (This is the default setting.)
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Step 4 (Optional) If you want SGM to search forward (down and to the right) in the 
window, select the Search Forward radio button. This is the default setting.

If you want SGM to search backward (up and to the left) in the window, select the 
Search Backward radio button.

The Search Forward and Search Backward radio buttons are mutually 
exclusive.

Step 5 Click Find. SGM launches the search:

• If a matching character string is found in the window, SGM highlights the 
first line that contains the string.

To find the next occurrence of the string, click Find again.

You can continue to click Find until there are no more matches in the window. 
At that time, SGM displays an appropriate message in the dialog, such as 
Bottom of table reached.

• If no matching character string is found, SGM displays an appropriate 
message in the dialog, such as Bottom of table reached.

Step 6 When you are done searching, click Close. SGM closes the Find dialog.

Resizing, Sorting, and Hiding Table Columns
The columns in some tables in SGM can be resized, sorted, or hidden to meet your 
specific needs. SGM automatically saves your new settings and, thereafter, 
launches the client with the new settings.

• To make a column wider or narrower, click the column divider in the header 
and move the divider to the right or left while holding down the left or right 
mouse button.

Depending on your system, as well as other factors, SGM windows can 
sometimes display so small that text is illegible, and columns and text entry 
fields are very narrow and unusable. If this happens, resize the window and 
widen the individual columns until the information is again legible and the 
columns and text entry fields are usable.
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• To sort a table based on the data in a column, left-click in the column header. 
The table is sorted alphanumerically from top to bottom, based on the data in 
the selected column. To sort the table in reverse order, left-click in the column 
header a second time. If two entries in the selected column are identical, SGM 
sorts those rows based on the data in the remaining table columns, moving left 
to right.

• To sort a route table, click Sort Table. SGM sorts the entries in the route table 
field-by-field, beginning with Dest. Point Code, then Mask, Cost, 
Dest.Linkset, and finally QoS.

• To delete a column altogether, see the “Modifying Preference Settings” 
section on page 5-3.

Related Topics:

• Viewing the Topology of the Network, page 3-259

• Working with Links, page 3-170

• Working with Linksets, page 3-37

• Working with Nodes, page 3-91

Viewing Online Help
SGM provides the following online help options in the SGM Main Menu:

• To display the table of contents for the SGM online help in a Web browser, 
select Help > Topics.

• To display online help for the current window in a Web browser, click Help 
> Window.

• To display build date, version, SSL support, and copyright information about 
the SGM application in a Web browser, click Help > About.

Related Topics:

• Viewing the SGM Technical Documentation, page 7-122
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Editing an ITP Route Table File
ITP uses a route table to select the appropriate signaling path for each message, 
or signal unit, that it must forward. The route table provides the destination point 
code of the packet and the linkset name that can be used to forward the packet.

SGM enables you to edit ITP route table files for an ITP.

To edit a route table file using SGM:

Step 1 Open the route table file, using one of the following procedures:

• To open a route table file from a file, select Edit > Route Table > From File 
from the SGM Main Menu, select the name of a route table file, then click 
OK.

If the selected route table file contains incorrect linkset entries (for example, 
if your network configuration changed since the last time the route table file 
was saved), SGM displays the Replace Linkset Dialog (Figure 3-64).

Figure 3-64 Replace Linkset Dialog
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The Replace Linkset Dialog enables you to quickly replace incorrect linkset 
entries in route table files:

– To replace an incorrect linkset with a correct linkset, select an incorrect 
linkset in the Linksets That Are No Longer Valid table, then select a 
correct linkset from the Auto Replace with Linkset drop-down list box, 
then click Apply. SGM automatically replaces the incorrect linkset with 
the selected correct linkset in all affected entries in the route table file.

– To remove all entries that contain an incorrect linkset from the route table 
fie, select an incorrect linkset in the Linksets That Are No Longer Valid 
table, then select the Remove Entries Containing Selected Linkset 
checkbox, then click Apply. SGM automatically removes all entries that 
contain the incorrect linkset from the route table file.

– When you have corrected all incorrect linksets in the route table file, 
click Done. SGM displays the Route Table Dialog (Figure 3-66).

If the selected route table file does not contain any incorrect linkset entries, 
SGM displays the Route Table Dialog (Figure 3-66).

• To open a route table file from an ITP, use one of the following procedures:

– Select a node, signaling point, or linkset on a window, then select Edit > 
Route Table > From ITP from the SGM Main Menu. (If you select an 
Unmanaged node, this option is grayed-out and cannot be selected.)

– Right-click a signaling point on a window, then select Edit Route Table 
from the right-click menu. (If you select an Unmanaged signaling point, 
this option is grayed-out and cannot be selected.)

SGM displays the Choose Signaling Point dialog (Figure 3-65), which 
enables you to select the signaling point whose route table you want to edit.

Figure 3-65 Choose Signaling Point Dialog
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From the drop-down list box of signaling points, select the signaling point 
with the point code, variant, and network name that matches the route table 
file you want to edit.

– If you select a signaling point that has the wrong variant, SGM displays 
the message, “Point code out of range.”

– If you select a signaling point that has the correct variant but the wrong 
instance, SGM displays the Replace Linkset Dialog, prompting you to 
replace or remove most or all of the linksets.

SGM reads the active route table from the ITP and displays it in the Route 
Table Dialog (Figure 3-66).

Figure 3-66 Route Table Dialog

The route table lists destination point codes and associated destination linkset 
names, as well as other important information used to route packets on a node.

Press Enter to move down to the next row in the route table; press Tab to move 
to the next field.
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You can resize each column in the route table, but you cannot sort the table based 
on the information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-279 for more details.

Step 2 The Row Num field displays a unique number for each entry in the route table. 
You cannot edit this field, but the number might change as you add entries to or 
delete entries from the route table.

Step 3 The Destination Point Code field displays the destination point code for packets 
on the selected node. The destination point code is the point code to which a given 
packet is routed. To edit the destination point code, enter the new code in this 
field.

If you enter a new destination point code that is less restrictive than the mask, 
SGM displays a message to that effect at the bottom of the Route Table Dialog, 
and performs one of the following actions:

• If you modified an existing point code, SGM restores the previous point code.

• If you entered an entirely new point code, SGM leaves this field blank.

For example, a destination point code of 7.7.7, which specifies 14 bits, is less 
restrictive than a mask of 7.255.0, which specifies only 11 bits. SGM ignores the 
extra bits in the last digit of the destination point code and converts it to 7.7.0.

Step 4 The Mask field specifies the significant bits of the point code:

• For ANSI and China standard networks using the default 24-bit point code 
format, the default mask is 255.255.255.

• For ITU networks using the default 14-bit point code format, the default mask 
is 7.255.7.

To edit the mask, make the changes in this field.

If you enter a new mask, the binary conversion of the mask cannot contain ones 
(1) to the right of zeros (0). For example:

• 7.255.7 is a valid mask because it converts to binary 111.11111111.111.

• 7.255.1 is not a valid mask because it converts to binary 111.11111111.001.

If you enter an invalid mask, such as 7.255.1, SGM displays a message to that 
effect at the bottom of the Route Table Dialog, and performs one of the following 
actions:

• If you modified an existing mask, SGM restores the previous mask.

• If you entered an entirely new mask, SGM leaves this field blank.
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If you enter a new mask that is more restrictive than the destination point code, 
SGM asks if you want to adjust the point code automatically based on the new 
mask:

• Click Yes if you want to adjust the point code. For example, if the point code 
is 7.7.7, and you enter the new mask 7.255.0, SGM automatically adjusts the 
point code to 7.7.0.

• Click No if you do not want to adjust the point code:

– If you modified an existing mask, SGM restores the previous mask.

– If you entered an entirely new mask, SGM leaves this field blank.

Step 5 The Cost field displays the cost of the route to the destination, relative to other 
routes. To edit the cost, select a cost from the drop-down list box in this field. The 
valid costs range from 1 (lowest cost and highest priority) through 9 (highest cost 
and lowest priority).

Note If you configure two routes to the same device and do not specify a cost 
for one of them, then the cost for that device defaults automatically to 5. 
The default cost appears here in the Cost column, and in the output of 
the show cs7 route command.

Similarly, if you add a new line to this table and leave the Cost column 
blank, SGM automatically enters a default cost of 5.

Linksets with the same cost form a combined linkset. Do not specify 
more than two linksets with the same cost, under the same destination 
point code and mask.

Step 6 The Destination Linkset field displays the destination linkset associated with the 
destination point code. The destination linkset is also known as the output linkset. 
To edit the destination linkset, select a destination linkset from the drop-down list 
box in this field.

Step 7 (Optional) The QoS field displays the quality of service (QoS) class of the route, 
as configured by the network administrator. To edit the QoS class of the route, 
select a QoS class from the drop-down list box in this field.

When you change the QoS class for a route, SGM automatically changes the QoS 
classes for the all other routes in that route set (that is, all other routes with the 
same Destination Point Code) to the new class.
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Step 8 (Optional) To add a new route to the route table, select the Dest. Point Code field 
in a blank row, then fill in the fields with values for the new route.

Step 9 (Optional) To delete an existing route from the route table, select one or more 
routes and click Delete. SGM removes the selected route or routes from the route 
table, without asking for confirmation.

Step 10 (Optional) To load an existing route table file, or to modify the list of route table 
files, select File > Load from the route table menu. SGM displays the Load File 
Dialog: Route Table File List (Figure 3-67).

Figure 3-67 Load File Dialog: Route Table File List

The Load File Dialog: Route Table File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the route table file or folder.

• Last Modified—Date and time the route table file or folder was last 
modified.
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• Size (bytes)—Size of the route table file or folder, in bytes.

• Number of Files—Total number of route table files and folders (displayed in 
bottom left corner).

To load a route table file, enter the name of the file or select it in the list and click 
OK. SGM loads the route table file, closes the Load File Dialog: Route Table File 
List, and returns to the Route Table Dialog.

To delete a route table file from the route table file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: Route Table File List.

To close the Load File Dialog: Route Table File List without loading a route table 
file or saving any changes to the route table file list, click Cancel.

Step 11 (Optional) To revert to the last saved version of the route table file, select 
File >Revert from the route table menu. SGM displays the last saved version of 
the file.

Step 12 (Optional) To save the changes you have made to the route table file, or to modify 
the list of route table files, use one of the following procedures:

• To save the changes you have made to the route table file without changing 
the name of the file, select File > Save from the route table menu.

• To save the changes you have made to the route table file with a new name, 
select File > Save As from the route table menu. SGM displays the Save File 
Dialog: Route Table File List dialog (Figure 3-68).
3-287
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Editing an ITP Route Table File
Figure 3-68 Save File Dialog: Route Table File List Dialog

The Save File Dialog: Route Table File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the route table file or folder.

• Last Modified—Date and time the route table file or folder was last 
modified.

• Size (bytes)—Size of the route table file or folder, in bytes.

• Filename—Name by which you want to save the route table file.

If you create a new route table file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system. However, 
if you include any spaces in the new name, SGM converts those spaces to 
dashes. For example, SGM saves file “a b c” as “a-b-c”.

• Number of Files—Total number of route table files and folders (displayed in 
bottom left corner).
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To save the route table file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old route table file, 
select the name in the list and click OK.

SGM saves the route table file with the new name, closes the Save File Dialog: 
Route Table File List dialog, and returns to the Route Table Dialog.

Note If another user modifies and saves the route table file before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If you 
choose to do so, the other user’s changes are overwritten and lost. If you 
choose not to do so, your changes are lost, unless you save the route table 
file to a different filename.

SGM stores the modified route table file in the route table file directory on the 
SGM server:

• If you installed SGM in the default directory, /opt, then the SGM route table 
file directory is /opt/CSCOsgm/routes.

• If you installed SGM in a different directory, then the SGM route table file 
directory is located in that directory.

You can use the sgm routedir command to change the directory in which SGM 
stores ITP route table files. See the “SGM Commands and Descriptions” section 
on page B-2 for information about the use of this command.

To delete a route table file from the route table file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: Route Table File List dialog.

To close the Save File Dialog: Route Table File List dialog without saving the 
route table file or saving any changes to the route table file list, click Cancel.

Step 13 (Optional) To exit the Route Table Dialog without saving any changes, click 
Cancel.
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Step 14 Copy the modified route table file from the SGM routes directory to a location that 
the ITP can reach via TFTP.

Step 15 TFTP the modified route table file back to the ITP.

Editing a Global Title Translation Table
SGM enables you to configure Global Title Translation (GTT) entries using the 
SGM GUI.

A global title is an application address, such as an 800 number, calling card 
number, or mobile subscriber identification number. GTT is the process by which 
the Signaling Connection Control Part (SCCP) translates a global title into the 
point code and subsystem number (SSN) of the destination service switching 
point (SSP) where higher layer protocol processing occurs. GTT entries are stored 
in GTT files, which are comma-separated value (CSV) text files with point codes 
written in hexadecimal notation.

Note SGM 3.0 supports only GTT files with file format versions 2.0, 3.0, 3.1, or 4.0. 
You can load GTT files that use lower or higher file format versions, but fields or 
features that are unique to the lower or higher version are not displayed, they are 
removed from the GTT file the next time it is saved, and the file is saved as a 
version 2.0, 3.0, 3.1, or 4.0 file.

For more detailed information about GTT, including configuration procedures and 
scenarios, see the IP Transfer Point (ITP) feature module for Cisco IOS software 
release 12.2(4)MB4 or later.
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To edit a GTT file using SGM:

Step 1 Launch the SGM GTT client, using one of the following procedures:

• Select Products > Global Title Configurator from the SGM Main Menu.

• Select Start > Programs > Cisco SGM Client > Launch SGM GTT Client 
in Windows.

• Enter the sgm gttclient command. See the “SGM Commands and 
Descriptions” section on page B-2 for more information on the use of this 
command.

Note The GTT Configurator runs as a separate application in SGM, so it 
requires a separate login, just like the SGM client.

Step 2 SGM displays the Startup Options dialog, which enables you to load a specific 
GTT file, or to create a new GTT file.

• If you choose to load an existing GTT file, SGM displays the Load File 
Dialog: GTT File List. See Step 22 for more information. Select a GTT file 
to load.

• If you choose to create a new GTT file, SGM displays the Create New Table 
Dialog. See Step 21 for more information. Create the new GTT file.

SGM displays the GTT Configurator window, with the Selectors and GTA tab 
selected (Figure 3-69).
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Figure 3-69 GTT Configurator, Showing Selectors and GTA Tab

The GTT Configurator window provides a set of tabs, each of which launches a 
specific GTT panel. Each panel is composed of a series of tables that contain GTT 
data. Some of the tables might be blank at first, while others are populated with 
rows of data.

You can edit the values in each row in each table, either by typing over the current 
value, or by selecting a new value from a drop-down list box.

To reset a cell to its previous value, press Esc. (If you have edited more than one 
cell in a row, pressing Esc resets all cells in the row.) To commit your changes, 
click outside the row. Once you have committed your changes, pressing Esc does 
not reset the cells in the row.

Step 3 (Optional) SGM enables you to modify the following aspects of the GTT 
Configurator window to meet your needs:

• Size and location of the main GTT Configurator window

• Variant and version of the last saved GTT file
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• Current selected tab (Selectors and GTA, App Group, MAPs, CPC, or 
Address Conversion)

• For each panel, the location of tables on that panel

• For each table:

– Column widths

– Sort-by column, and whether the sort is ascending or descending

SGM also enables you to save your modifications in a GTT preferences file, load 
an existing GTT preferences file, and modify the list of GTT preferences files.

To save your current preferences, or to modify the list of GTT preferences files, 
use one of the following procedures:

• To save the changes you have made to the GTT preferences file without 
changing the name of the file, select Edit > Preferences > Save from the GTT 
menu.

• To save the changes you have made to the GTT preferences file with a new 
name, select Edit > Preferences > Save As from the GTT menu. SGM 
displays the Save File Dialog: GTT Preferences File List (Figure 3-70).
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Figure 3-70 Save File Dialog: GTT Preferences File List

The Save File Dialog: GTT Preferences File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT preferences file or folder.

• Last Modified—Date and time the GTT preferences file or folder was last 
modified.

• Size (bytes)—Size of the GTT preferences file or folder, in bytes.

• Filename—Name by which you want to save the GTT preferences file. If you 
create a new GTT preferences file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system.

• Number of Files—Total number of GTT preferences files and folders 
(displayed in bottom left corner).
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To save the GTT preferences file with a new name, use one of the following 
procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old GTT preferences 
file, select the name in the list and click OK.

SGM saves the GTT file with the new name, closes the Save File Dialog: GTT 
Preferences File List, and returns to the GTT Configuration window.

Note If another user modifies and saves the GTT preferences file before you 
save your changes, SGM asks if you want to overwrite that user’s 
changes. If you choose to do so, the other user’s changes are overwritten 
and lost. If you choose not to do so, your changes are lost, unless you 
save the GTT preferences file to a different filename.

When you save a GTT file or GTT preferences file, SGM makes note of your 
preferences on the SGM client and server, including the variant and version of 
GTT being used. SGM saves the user’s preferences to the SGM server when the 
GTT client exits successfully.

Thereafter, whenever you launch the GTT client, SGM searches for your GTT 
preferences. If SGM finds your preferences on the SGM server, SGM launches the 
GTT client with those preferences. Otherwise, SGM launches the GTT client with 
the default GTT preferences file (ITU variant and version 1.0).

To delete a GTT preferences file from the GTT preferences file list, select a file 
and click Delete. SGM issues an informational message containing the name and 
location of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: GTT Preferences File List.

To close the Save File Dialog: GTT Preferences File List without saving the GTT 
preferences file or saving any changes to the GTT preferences file list, click 
Cancel.

Step 4 (Optional) To load an existing GTT preferences file, select Edit > Preferences > 
Load from the GTT menu. SGM displays the Load File Dialog: GTT Preferences 
File List (Figure 3-71).
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Figure 3-71 Load File Dialog: GTT Preferences File List

The Load File Dialog: GTT Preferences File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT preferences file or folder.

• Last Modified—Date and time the GTT preferences file or folder was last 
modified.

• Size (bytes)—Size of the GTT preferences file or folder, in bytes.

• Number of Files—Total number of GTT preferences files and folders 
(displayed in bottom left corner).

To load a GTT preferences file, enter the name of the file or select it in the list and 
click OK. SGM loads the GTT preferences file, closes the Load File Dialog: GTT 
Preferences File List, and returns to the GTT Configuration window.

To delete a GTT preferences file from the GTT file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.
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To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: GTT Preferences File List.

To close the Load File Dialog: GTT Preferences File List without loading a GTT 
preferences file or saving any changes to the GTT preferences file list, click 
Cancel.

Step 5 (Optional) To revert to the last saved version of the GTT file, select File> Revert 
from the route table menu. SGM displays the last saved version of the file.

Step 6 Select the Selectors and GTA tab if you are primarily interested in displaying 
data for a specific GTT selector, and seeing the GTA entries for that selector. SGM 
displays the Selectors and GTA panel.

A GTT selector defines the parameters that select the translation table used to 
translate an SCCP message to its next or final destination.

A Global Title Address (GTA) entry is associated with a selector and defines the 
result of a translation for a particular address mask. The result of a GTA entry can 
be either a final translation or an intermediate translation

When you launch the Selectors and GTA panel, the Selector Table and the other 
tables might or might not be populated with data.

• To populate the Selector Table, right-click within the table and select Add 
from the right-click menu.

See Step 12 for more information about adding entries to the Selector Table.

• To populate the GTA Table, select a row in the Selector Table. The GTA Table 
is populated with all associated GTA entries. If the GTA Table remains blank, 
the selected row has no associated GTA entries.

If the GTA Table remains blank, the selected row has no associated GTA 
entries. You can also add entries to the GTA Table, by right-clicking within 
the table and selecting Add from the right-click menu. See Step 13 for more 
information about adding entries to the GTA Table.

• To populate the App Group Table, select a row in the GTA Table that has an 
associated Application Group. The App Group Table is populated with all 
application group entries for that application group name.

You can also add entries to the App Group Table, by right-clicking within the 
table and selecting Add from the right-click menu. See Step 15 for more 
information about adding entries to the App Group Table.
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• To populate the MAP Table, select a row in the GTA Table that does not have 
an associated Application Group. The MAP Table is populated with all MAP 
entries that match the selected row's point code-SSN combination.

You can also add entries to the MAP Table, by right-clicking within the table 
and selecting Add from the right-click menu. See Step 16 for more 
information about adding entries to the MAP Table.

• To populate the CPC List, select a row in the MAP Table that has an 
associated CPC List Name. The CPC List is populated with all point codes 
in that CPC list.

You can also add entries to the CPC List, by right-clicking within the list and 
selecting Add from the right-click menu. See Step 17 for more information 
about adding entries to the CPC List.

The Selector Table displays the following information:

• Name—Name of the selector.

• Translation Type—Translation type used by the selector. Valid values are 
integers in the range 0 through 255.

• Global Title Indicator—Global title indicator for the selector. Valid values 
are integers in the range 2 and 4.

• Numbering Plan—(China and ITU only) Numbering plan for the selector. 
Valid values are integers in the range 0 through 15.

• Nature of Address Indicator—(China and ITU only) Nature of address 
indicator for the selector. Valid values are integers in the range 0 through 127.

• Pre-Address Conversion—GTT address conversion table to apply prior to 
performing local GTT translation.

If there is an address conversion table name in this field, the referenced table 
must exist, and it must contain at least one address conversion entry.

If this field is blank, no address conversion is needed.

• Post-Address Conversion—GTT address conversion table to apply after 
performing local GTT translation.

If there is an address conversion table name in this field, the referenced table 
must exist, and it must contain at least one address conversion entry.

If this field is blank, no address conversion is needed.

• QoS—Quality of service (QoS) class of the selector. Valid QoS classes range 
from 1 through 7. ALL indicates that the selector accepts all QoS classes.
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The GTA Table displays the following information:

• Name—Name of the selector associated with this GTA.

• Global Title Address Digits—Address digits for the GTA.

• Point Code—Destination point code for the GTA.

• Routing Indicator—Routing indicator for the GTA. Valid values are:

– none—No routing indicator.

– gt—Route on the global title.

– pcssn—Route on the point code and SSN.

This field is grayed-out if Configure By App Group is selected.

• Subsystem Number—Destination SSN for the GTA. Valid values are 
integers in the range 2 through 255.

• New Translation Type—Translation type to be used by the GTA. Valid 
values are integers in the range 0 through 255.

• Application Group—Name of the application group that is to provide the 
point code, routing indicator, and SSN to be used by the GTA.

• Application Server Name—Name of the application server that is to provide 
the point code, routing indicator, and SSN to be used by the GTA.

For ITPs with multiple-instances enabled, do not use the same application 
group name in two or more different instances. For example, if you use 
application group name appgrp1 in instance 1, then do not use appgrp1 in 
instance 0, or any other instance.

• QoS—Quality of service (QoS) class of the GTA. Valid QoS classes range 
from 1 through 7. ALL indicates that the GTA accepts all QoS classes.

The App Group Table displays the following information:

• Name—Name of the application group.

• Multiplicity—Multiplicity setting for the application group. Valid values 
are:

– sha—Share equally between all destinations.

– cos—Use the destination with the least cost, if available.

– cgp—Use SCCP calling party address (CGPA) load sharing, if available.
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• Cost—Relative cost of the application group. Valid values are integers in the 
range 1 through 8.

• Point Code—Destination point code for the application group.

• Routing Indicator—Routing indicator for the application group. Valid 
values are:

– none—No routing indicator.

– gt—Route on the global title. This is the default routing indicator.

– pcssn—Route on the point code and SSN.

• Subsystem Number—Destination SSN for the application group. Valid 
values are integers in the range 2 through 255.

• Application Server Name—Name of the application server.

The MAP Table displays the following information:

• Primary Pt. Code—Primary point code for the MAP.

• Primary SSN—Primary SSN for the MAP. Valid values are integers in the 
range 2 through 255.

• Multiplicity—Multiplicity setting for the MAP. Valid values are:

– dom—Dominant. Always translate to the primary point code-SSN 
combination if it is available. Translate to the backup point code-SSN 
combination only if the primary combination is not available.

– sha—Share equally between the primary point code-SSN combination 
and the backup point code-SSN combination.

– sol—Solitary MAP. There is no alternate if the point code or SSN is not 
available.

• Backup Pt. Code—Backup point code for the MAP.

• Backup SSN—Backup SSN for the MAP. Valid values are integers in the 
range 2 through 255.

• Re-route if Congested—Indicates whether the MAP is to be routed to the 
backup point code-SSN combination if the primary combination is 
congested:

– If the checkbox is selected, the MAP is routed to the backup combination 
when the primary combination is congested.

– If the checkbox is cleared, the MAP is not routed to the backup.
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• Adjacency—Indicates whether a point code-SSN combination is to be 
considered adjacent to the local node for SCCP management:

– If the checkbox is selected, the point code-SSN combination is 
considered adjacent to the local node.

– If the checkbox is cleared, the point code-SSN combination is not 
considered adjacent to the local node.

• CPC List Name—Name of the CPC list associated with this MAP.

The CPC List displays the following information:

• Point Code—Point codes in the selected CPC list.

Step 7 Select the App Group tab if you are primarily interested in displaying data for 
application groups. SGM displays the App Group panel.

An application group is an alternative result for the explicit point code and SSN 
in a GTA entry. You can use an application group entry for intermediate 
translation, for load-sharing across more than two destinations, or for 
load-sharing of intermediate translation.

When you launch the App Group panel, the App Group Table and Selector Table 
might or might not be populated with data.

• To add entries to the App Group Table, right-click within the table and select 
Add from the right-click menu. See Step 15 for more information about 
adding entries to the App Group Table.

• To add entries to the Selector Table, right-click within the table and select 
Add from the right-click menu. See Step 12 for more information about 
adding entries to the Selector Table.

• To populate the MAP Table, select a row in the App Group Table. The MAP 
Table is populated with all MAP entries that match the selected row's point 
code-SSN combination.

You can also add entries to the MAP Table, by right-clicking within the table 
and selecting Add from the right-click menu. See Step 16 for more 
information about adding entries to the MAP Table.
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• To populate the CPC List, select a row in the MAP Table that has an 
associated CPC List Name. The CPC List is populated with all point codes 
in that CPC list.

You can also add entries to the CPC List, by right-clicking within the list and 
selecting Add from the right-click menu. See Step 17 for more information 
about adding entries to the CPC List.

• To populate the GTA Table, select a row in the Selector Table. The GTA Table 
is populated with all associated GTA entries.

If the GTA Table remains blank, the selected row has no associated GTA 
entries. You can also add entries to the GTA Table, by right-clicking within 
the table and selecting Add from the right-click menu. See Step 13 for more 
information about adding entries to the GTA Table.

The App Group panel displays the same information as the Selectors and GTA 
panel, but from the perspective of the application groups.

Step 8 Select the MAPs tab if you are primarily interested in displaying data for MAPs. 
SGM displays the MAPs panel.

A mated application (MAP) entry has two main purposes:

• MAP entries are used internally by the SCCP application to track point code 
states and SSN states, such as congestion and availability.

• MAP entries are used to define backups or alternates for point code-SSN 
combination.

When you launch the MAPs panel, the MAP Table and Selector Table might or 
might not be populated with data.

• To add entries to the MAP Table, right-click within the table and select Add 
from the right-click menu. See Step 16 for more information about adding 
entries to the MAP Table.

• To add entries to the Selector Table, right-click within the table and select 
Add from the right-click menu. See Step 12 for more information about 
adding entries to the Selector Table.

• To populate the CPC List, select a row in the MAP Table that has an 
associated CPC List Name. The CPC List is populated with all point codes 
in that CPC list.

You can also add entries to the CPC List, by right-clicking within the list and 
selecting Add from the right-click menu. See Step 17 for more information 
about adding entries to the CPC List.
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• To populate the App Group Table and GTA Table, select a row in the MAP 
Table. The App Group Table and GTA Table are populated with all 
application group and GTA entries that match the selected row's point 
code-SSN combination.

If the App Group Table or GTA Table remains blank, the selected row has no 
associated application group or GTA entries.

You can add entries to the App Group Table, by right-clicking within the table 
and selecting Add from the right-click menu. See Step 15 for more 
information about adding entries to the App Group Table.

You can add entries to the GTA Table, by right-clicking within the table and 
selecting Add from the right-click menu. See Step 13 for more information 
about adding entries to the GTA Table.

The MAPs panel displays the same information as the Selectors and GTA panel, 
but from the perspective of the MAPs.
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Step 9 Select the CPC tab if you are primarily interested in displaying data for concerned 
point code names. SGM displays the CPC panel (Figure 3-72).

Figure 3-72 GTT Configurator, Showing CPC Tab

A concerned point code (CPC) is a node that is to be notified when the status of 
the associated SSN changes.

When you launch the CPC panel, the Concerned Pt. Code Name List is populated 
with data. To populate the CPC List and MAP Table, select a row in the Concerned 
Pt. Code Name List. The CPC List and MAP Table are populated with all point 
codes and MAP entries that match that concerned point code name.

The CPC panel displays the CPC List and MAP Table, as well as the Concerned 
Pt. Code Name List. The Concerned Pt. Code Name List displays the CPC List 
Name, which is the name of the CPC list to be added. Enter 1-to-12-character 
alphanumeric string.
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To copy one or more point codes from one CPC list to another, select a CPC list 
in the CPC List Name column. SGM displays the point codes associated with that 
CPC list in the Point Code column. Select one or more of the point codes and drag 
them to the new CPC list while holding down the left mouse button.

Note SGM copies the point codes to the new CPC list; it does not move them 
from the old CPC list. If you want to move the point codes, you must 
copy them to the new CPC list, then delete them from the old CPC list.

Step 10 Select the Address Conversion tab if you are primarily interested in displaying 
GTT address conversion tables. SGM displays the Address Conversion panel 
(Figure 3-73).

Figure 3-73 GTT Configurator, Showing Address Conversion Tab
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The Address Conversion Table displays the following information:

• Name—Name of the GTT address conversion table. Enter a 1-to-12 character 
name.

• Numbering Plan—(China and ITU only) Numbering plan associated with 
the address conversion table. For all addresses that are converted, the 
numbering plan is converted to the value of this field. The valid range is 
0 to 15.

• Nature of Address Indicator—(China and ITU only) Nature of address 
indicator associated with the address conversion table. For all addresses that 
are converted, the nature of address indicator is converted to the value of this 
field. The valid range is 0 to 127.

The Conversion Entry Table displays the following information:

• In Address—Input SCCP address entry. Enter an address as a 1 to 15 digit 
hexadecimal string.

• Out Address—Output SCCP address entry. Enter an address as a 1 to 15 
digit hexadecimal string.

• Numbering Plan—(China and ITU only) Numbering plan associated with 
this entry in the address conversion table. If specified, the value of this field 
overrides the value of the Numbering Plan field in the Address Conversion 
Table, for this entry. The valid range is 0 to 15.

• Nature of Address Indicator—(China and ITU only) Nature of address 
indicator associated with this entry in the address conversion table. If 
specified, the value of this field overrides the value of the Nature of Address 
Indicator field in the Address Conversion Table, for this entry. The valid 
range is 0 to 127.

The Selector Table for Address Conversion displays the following information:

• Name—Name of the selector.

• Translation Type—Translation type used by the selector. Valid values are 
integers in the range 0 through 255.

• Global Title Indicator—Global title indicator for the selector. Valid values 
are integers in the range 2 and 4.

• Numbering Plan—(China and ITU only) Numbering plan for the selector. 
Valid values are integers in the range 0 through 15.
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• Nature of Address Indicator—(China and ITU only) Nature of address 
indicator for the selector. Valid values are integers in the range 0 through 127.

• Pre-Address Conversion—GTT address conversion table to apply prior to 
performing local GTT translation.

If there is an address conversion table name in this field, the referenced table 
must exist, and it must contain at least one address conversion entry.

If this field is blank, no address conversion is needed.

• Post-Address Conversion—GTT address conversion table to apply after 
performing local GTT translation.

If there is an address conversion table name in this field, the referenced table 
must exist, and it must contain at least one address conversion entry.

If this field is blank, no address conversion is needed.

• QoS—Quality of service (QoS) class of the selector. Valid QoS classes range 
from 1 through 7. ALL indicates that the selector accepts all QoS classes.

Step 11 (Optional) To change the variant and instance ID associated with a GTT file select 
Edit>Version and Instance from the GTT menu. SGM displays the Edit GTT 
Table dialog (Figure 3-74).

Figure 3-74 Edit GTT Table Dialog
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The Edit GTT Table dialog contains the following fields and buttons:

• Variant—SS7 protocol variant. You cannot edit this field.

• Version—Version of the file format to be used by the GTT. Valid versions are:

– 2.0 (MB5, MB6)—Corresponds to ITP software releases 12.2(4)MB5 
and 12.2(4)MB6. Allows GTT translation to an application server.

– 3.0 (MB7, MB8)—Corresponds to ITP software releases 12.2(4)MB7 
and 12.2(4)MB8. Allows local point codes in GTT tables.

– 3.1 (MB9, MB9a)—Corresponds to ITP software releases 12.2(4)MB9 
and 12.2(4)MB9a. Two or more entries in the same application group can 
have the same cost. This is the default version in SGM.

– 4.0 (MB10+)—Corresponds to ITP software release 12.2(4)MB10 or 
greater. Supports multiple instances on a single node.

SGM 3.0 does not support version 1.0, which corresponds to ITP software 
release 12.2(4)MB4. You can load a version 1.0 file into SGM, but fields or 
features that are unique to version 1.0 are not displayed, they are removed 
from the GTT file the next time it is saved, and the file is saved as a version 
2.0 file.

• Instance ID—ID of the instance used by the GTT. Valid IDs are 0 to 7. The 
default instance ID is 0. This list box is available only if Version 4.0 or later 
is selected.

Enter or select values for the new variant and instance ID, then click OK. SGM 
saves your changes to the GTT file.

To close the Edit GTT Table dialog at any time without saving any changes to the 
GTT file, click Cancel.

Step 12 (Optional) To add a new selector to a Selector Table, select a Selector Table, then 
use one of the following procedures:

• Select Edit > Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the Selector Add Dialog (Figure 3-75).
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Figure 3-75 Selector Add Dialog

The Selector Add Dialog contains the following fields:

• Selector Name—Name of the selector to be added. Enter 1-to-12-character 
alphanumeric string.

• Translation Type—Translation type to be used by the selector. Enter an 
integer in the range 0 through 255.

• Global Title Indicator—Global title indicator for the selector. Select a value 
from the drop-down list box. Valid values are:

– 2

– 4—This is the default value.

• Numbering Plan—(China and ITU only) Numbering plan for the selector. 
Enter an integer in the range 0 through 15. This field is grayed-out if Global 
Title Indicator is set to 2.

• Nature of Addr. Indicator—(China and ITU only) Nature of address 
indicator for the selector. Enter an integer in the range 0 through 127. This 
field is grayed-out if Global Title Indicator is set to 2.

• Pre-Conversion Table name—GTT address conversion table to apply prior 
to performing local GTT translation.

If there is an address conversion table name in this field, the referenced table 
must exist, and it must contain at least one address conversion entry.

If this field is blank, no address conversion is needed.
3-309
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Editing a Global Title Translation Table
• Post-Conversion Table name—GTT address conversion table to apply after 
performing local GTT translation.

If there is an address conversion table name in this field, the referenced table 
must exist, and it must contain at least one address conversion entry.

If this field is blank, no address conversion is needed.

• QoS—Quality of service (QoS) class of the selector. Select a value from the 
drop-down list box. Valid QoS classes range from 1 through 7. Select ALL if 
you want the selector to accept all QoS classes. The default value is ALL.

Enter or select values for the new selector, then click Add. SGM adds the selector 
to the Selector Table.

When you are done adding selectors, click Close to close the Selector Add Dialog.

Step 13 (Optional) To add a new GTA entry to a GTA Table, select a GTA Table, then use 
one of the following procedures:

• Select Edit > Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the Selector Add Dialog (Figure 3-76).
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Figure 3-76 GTA Add Dialog

The GTA Add Dialog contains the following fields:

• Selector Name—Name of the selector associated with this GTA. You cannot 
edit this field.

• Global Title Addr. Digits—Address digits for the GTA. Enter a 1 to 15 digit 
hexadecimal string.

• QoS—Quality of service (QoS) class of the GTA. Select a value from the 
drop-down list box. Valid QoS classes range from 1 through 7. Select ALL if 
you want the GTA to accept all QoS classes. The default value is ALL.
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• Configure By Point Code—Indicates whether to configure the GTA by point 
code. To configure the GTA by point code, select this radio button.

SGM makes the Config By Point Code fields available, and grays-out the 
Config By App Group fields. This is the default setting.

• Configure By App Group—Indicates whether to configure the GTA by 
application group. To configure the GTA by application group, select this 
radio button.

SGM makes the Config By App Group fields available, and grays-out the 
Config By Point Code fields.

• Configure By Application Server Name—Indicates whether to configure 
the GTA by application server name. To configure the GTA by application 
server name, select this radio button.

SGM replaces the Config By Point Code fields with the Config By 
Application Server name fields, and grays-out the Config By App Group 
fields.

• Point Code—Destination point code for the GTA. Enter a point code. This 
field is available only if Configure By Point Code is selected.

• Routing Indicator—Routing indicator for the GTA. Select a value from the 
drop-down list box. Valid values are:

– gt—Route on the global title. This is the default routing indicator.

– pcssn—Route on the point code and SSN.

This field is available only if Configure By Point Code or Configure By 
Application Server Name is selected.

• Subsystem Number—Destination SSN for the GTA. Enter an integer in the 
range 2 through 255. This field is mutually exclusive with the New 
Translation Type field. This field is available only if Configure By Point 
Code or Configure By Application Server Name is selected.

• New Translation Type—Translation type to be used by the GTA. Enter an 
integer in the range 0 through 255. This field is mutually exclusive with the 
Subsystem Number field. This field is available only if Configure By Point 
Code or Configure By Application Server Name is selected.
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• App. Group—Name of the application group that is to provide the point 
code, routing indicator, and SSN to be used by the GTA. Enter the name of an 
application group. This field is available only if Configure By App Group is 
selected.

• Application Server Name—Name of the application server that is to provide 
the point code, routing indicator, and SSN to be used by the GTA. Enter the 
name of an application server. This field is available only if Configure By 
Application Server Name is selected.

Enter or select values for the new GTA entry, then click Add. SGM adds the GTA 
entry to the GTA Table.

When you are done adding GTA entries, click Close to close the GTA Add Dialog.

Step 14 (Optional) To search the GTA Table for the Global Title Address Digits for a 
specific selector, select the Selectors and GTA tab, then select View > Phone 
Number Config from the GTT menu. SGM displays the The Phone Number 
Lookup Dialog (Figure 3-77).
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Figure 3-77 Phone Number Lookup Dialog

The Phone Number Lookup Dialog contains the following tables, field, and 
buttons:

• Selector Table—Selector Table associated with the GTA Table to be 
searched. Select one or more Selector Tables. For descriptions of the fields in 
this table, and the other tables in the Phone Number Lookup Dialog, see 
Step 6.

• Phone Number—GTA digits to be searched for in the GTA Table.

• Perform Lookup—Launches the search for the GTA digits.
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• Pre-Address Conversion Entry Used—Entry in the GTT address 
conversion table used for pre-address conversion, if the Selector Table being 
searched performs pre-address conversion.

For China and ITU variants, pre-address conversion might result in a 
numbering plan or nature of address indicator that is different from the 
selected Selector Table. If this occurs, SGM searches for a selector in the 
Selector Table that matches the new numbering plan and nature of address 
indicator:

– If SGM finds a matching selector, SGM uses that selector to complete the 
search.

– If SGM does not find a matching selector, the search fails.

• Pre-Address Conversion Results—Results of the pre-address conversion 
(converted address, numbering plan, and nature of address indicator), if the 
Selector Table being searched performs pre-address conversion.

• Selector Entry Used—Selector Entry that was searched.

• GTA Entry Found—GTA Table in which the GTA digits were found.

• MAP Table—MAP Table, if any, associated with the GTA Table in which the 
GTA digits were found.

• CPC List—CPC List, if any, associated with the GTA Table in which the 
GTA digits were found.

• Post-Address Conversion Entry Used—Entry in the GTT address 
conversion table used for post-address conversion, if the Selector Table being 
searched performs post-address conversion.

• Post-Address Conversion Results—Results of the post-address conversion 
(converted address, numbering plan, and nature of address indicator), if the 
Selector Table being searched performs post-address conversion.

To search for Global Title Address Digits, select a Selector Table and enter a 
telephone number or prefix as a 1 to 15 digit hexadecimal string. For example, to 
search for a specific telephone number, such as 919-555-6384, enter 9195556384. 
To search for all entries that begin with the 919-555 telephone prefix, enter 
919555.
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Click Perform Lookup to launch the search:

• If one or more matching entries are found, displays the entries that contained 
the GTA digits in the GTA Table.

• If the Selector Table being searched performs pre-address conversion, the 
converted address, numbering plan, and nature of address indicator are 
displayed in the Pre-Address Conversion Results field.

• If the Selector Table being searched performs post-address conversion, the 
converted address, numbering plan, and nature of address indicator are 
displayed in the Post-Address Conversion Results field.

• If no matching entries are found, or if the Selector Table has no associated 
GTA Table, displays Could not find GTA for selector and phone number 
at the bottom of the window.

Step 15 (Optional) To add a new application group entry to an App Group Table, select an 
App Group Table, then use one of the following procedures:

• Select Edit > Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the App Group Add Dialog (Figure 3-78).
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Figure 3-78 App Group Add Dialog

The App Group Add Dialog contains the following fields:

• App. Group—Name of the application group to be added. Enter 
1-to-12-character alphanumeric string.

• Multiplicity—Multiplicity setting for the application group. Select a value 
from the drop-down list box. Valid values are:

– sha—Share equally between all destinations. This is the default value.

– cos—Use the destination with the least cost, if available.

– cgp—Use SCCP calling party address (CGPA) load sharing, if available.

• Cost—Relative cost of the application group. Select a relative cost, 
1 through 8, from the drop-down list box. The default value is 1.

• Point Code—Destination point code for the application group. Select this 
radio button and enter a point code. This field is mutually exclusive with 
Application Server Name.

• Application Server Name—Name of the application server. Select this radio 
button and enter an application server name. This field is mutually exclusive 
with Point Code.
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• Routing Indicator—Routing indicator for the application group. Select a 
value from the drop-down list box. Valid values are:

– gt—Route on the global title. This is the default routing indicator.

– pcssn—Route on the point code and SSN.

• Subsystem Number—Destination SSN for the application group. Enter an 
integer in the range 2 through 255.

Enter or select values for the new application group entry, then click Add. SGM 
adds the application group entry to the App Group Table.

When you are done adding application group entries, click Close to close the App 
Group Add Dialog.

Step 16 (Optional) To add a new MAP entry to a MAP Table, select a MAP Table, then 
use one of the following procedures:

• Select Edit > Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the MAP Add Dialog (Figure 3-79).
3-318
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Editing a Global Title Translation Table
Figure 3-79 MAP Add Dialog

The MAP Add Dialog contains the following fields:

• Primary Pt. Code—Primary point code for the MAP. Enter a point code.

• Primary SSN—Primary SSN for the MAP. Enter an integer in the range 
2 through 255.

• Multiplicity—Multiplicity setting for the MAP. Select a value from the 
drop-down list box. Valid values are:

– dom—Dominant. Always translate to the primary point code-SSN 
combination if it is available. Translate to the backup point code-SSN 
combination only if the primary combination is not available.

– sha—Share equally between the primary point code-SSN combination 
and the backup point code-SSN combination. This is the default value.

– sol—Solitary MAP. There is no alternate if the point code or SSN is not 
available.

• Backup Pt. Code—Backup point code for the MAP. Enter a point code.

• Backup SSN—Backup SSN for the MAP. Enter an integer in the range 
2 through 255.
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• CPC List Name—Name of the CPC list to be associated with this MAP. 
Enter a CPC list name.

• Re-route if Congested—Indicates whether the MAP is to be routed to the 
backup point code-SSN combination if the primary combination is 
congested:

– If you want to route the MAP to the backup combination when the 
primary combination is congested, select the checkbox.

– If you do not want to route the MAP to the backup, clear the checkbox. 
This is the default setting.

• Adjacency—Indicates whether a point code-SSN combination is to be 
considered adjacent to the local node for SCCP management:

– If you want the point code-SSN combination be considered adjacent to 
the local node, select the checkbox.

– If you do not want the point code-SSN combination be considered 
adjacent to the local node, clear the checkbox. This is the default setting.

Enter or select values for the new MAP entry, then click Add. SGM adds the MAP 
entry to the MAP Table.

When you are done adding MAP entries, click Close to close the MAP Add 
Dialog.
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Step 17 (Optional) To add a new CPC list to a CPC Table, select a Concerned Pt. Code 
Name List or a CPC List, then use one of the following procedures:

• Select Edit > Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the CPC Add Dialog (Figure 3-80).

Figure 3-80 CPC Add Dialog

The CPC Add Dialog contains the following fields:

• CPC List Name—Name of the CPC list to be added. Enter 1-to-12-character 
alphanumeric string.

• Concerned Pt. Code List—One or more CPCs to be added to the new CPC 
list. Enter one or more CPCs, separated by spaces.

Enter or select values for the new CPC list, then click Add. SGM adds the CPC 
list to the MAP Table.

When you are done adding CPC lists, click Close to close the CPC Add Dialog.
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Step 18 (Optional) To add a new Address Conversion Table, select an Address Conversion 
Table, then use one of the following procedures:

• Select Edit>Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the Address Conversion Add Dialog for a Table (Figure 3-81).

Figure 3-81 Address Conversion Add Dialog for a Table

The Address Conversion Add Dialog for a Table contains the following fields:

• Name—Name of the GTT address conversion table. Enter a 1-to-12 character 
name.

• Numbering Plan—(China and ITU only) Numbering plan associated with 
the address conversion table. For all addresses that are converted, the 
numbering plan is converted to the value of this field. The valid range is 
0 to 15.

• Nature of Address Indicator—(China and ITU only) Nature of address 
indicator associated with the address conversion table. For all addresses that 
are converted, the nature of address indicator is converted to the value of this 
field. The valid range is 0 to 127.

Enter or select values for the new Address Conversion Table, then click Add. 
SGM adds the Address Conversion Table to the GTT file.

When you are done adding Address Conversion Tables, click Close to close the 
Address Conversion Add Dialog for a Table.
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Step 19 (Optional) To add a new entry to a Conversion Entry Table, select a Conversion 
Entry Table, then use one of the following procedures:

• Select Edit>Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the Address Conversion Add Dialog for an Entry (Figure 3-82).

Figure 3-82 Address Conversion Add Dialog for an Entry

The Address Conversion Add Dialog for an Entry contains the following fields:

• Name—Name of the GTT address conversion table. Enter a 1-to-12 character 
name. If the table name does not already exist, SGM creates a new address 
conversion table with this name.

• Numbering Plan—(China and ITU only) Numbering plan associated with 
the address conversion table. For all addresses that are converted, the 
numbering plan is converted to the value of this field. The valid range is 
0 to 15.

• Nature of Address Indicator—(China and ITU only) Nature of address 
indicator associated with the address conversion table. For all addresses that 
are converted, the nature of address indicator is converted to the value of this 
field. The valid range is 0 to 127.
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• In Address—Input SCCP address entry. Enter an address as a 1 to 15 digit 
hexadecimal string.

• Out Address—Output SCCP address entry. Enter an address as a 1 to 15 
digit hexadecimal string.

• Numbering Plan—(China and ITU only) Numbering plan associated with 
this entry in the address conversion table. If specified, the value of this field 
overrides the value of the Numbering Plan field in the Address Conversion 
Table, for this entry. The valid range is 0 to 15.

• Nature of Address Indicator—(China and ITU only) Nature of address 
indicator associated with this entry in the address conversion table. If 
specified, the value of this field overrides the value of the Nature of Address 
Indicator field in the Address Conversion Table, for this entry. The valid 
range is 0 to 127.

Enter or select values for the new entry, then click Add. SGM adds the entry to 
the Conversion Entry Table.

When you are done adding entries, click Close to close the Address Conversion 
Add Dialog for an Entry.

Step 20 (Optional) To delete one or more rows from a table, select the rows, then select 
Edit > Delete from the GTT menu or Delete from the right-click menu. SGM 
displays the Confirm Delete Dialog to confirm the deletion:

• To delete the selected rows, click Yes. The rows are deleted from the table and 
the Confirm Delete Dialog is closed.

• To retain the selected rows, click No. The rows are kept in the table and the 
Confirm Delete Dialog is closed.

You can select more than one row to delete, but all selected rows must be in the 
same table. For example, you cannot delete rows from both the Selector Table and 
the MAP Table at the same time.

If deleting a row from a table “orphans” one or more rows in the table, such that 
no remaining entries reference the orphaned rows, SGM displays the number of 
orphaned rows and asks whether you want to also delete the orphaned rows. (SGM 
displays the number of rows and not the rows themselves, because there could be 
thousands of orphaned rows.)

Step 21 (Optional) To create a new GTT file, select File > New Table from the GTT menu. 
SGM displays the Create New Table Dialog (Figure 3-83).
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Figure 3-83 Create New Table Dialog

The Create New Table Dialog contains the following fields:

• Variant—SS7 p[rotocol variant. Valid variants are:

– ANSI

– China

– ITU

• Version—Version of the file format to be used by the GTT. Valid versions are:

– 2.0 (MB5, MB6)—Corresponds to ITP software releases 12.2(4)MB5 
and 12.2(4)MB6. Allows GTT translation to an application server.

– 3.0 (MB7, MB8)—Corresponds to ITP software releases 12.2(4)MB7 
and 12.2(4)MB8. Allows local point codes in GTT tables.

– 3.1 (MB9, MB9a)—Corresponds to ITP software releases 12.2(4)MB9 
and 12.2(4)MB9a. Two or more entries in the same application group can 
have the same cost. This is the default version in SGM.

– 4.0 (MB10+)—Corresponds to ITP software release 12.2(4)MB10 or 
greater. Supports multiple instances on a single node.

SGM 3.0 does not support version 1.0, which corresponds to ITP software 
release 12.2(4)MB4. You can load a version 1.0 file into SGM, but fields or 
features that are unique to version 1.0 are not displayed, they are removed 
from the GTT file the next time it is saved, and the file is saved as a version 
2.0 file.

• Instance ID—ID of the instance to be used by the GTT. Valid IDs are 0 to 7. 
The default instance ID is 0. This list box is available only if Version 4.0 or 
later is selected.
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Select a variant, version, and instance for the new GTT file, then click OK. SGM 
creates the new GTT file and closes the Create New Table Dialog.

To close the Create New Table Dialog without creating a new GTT file, click 
Cancel.

Step 22 (Optional) To load an existing GTT file, or to modify the list of GTT files, select 
File > Load from the GTT menu. SGM displays the Load File Dialog: GTT File 
List (Figure 3-84).

Figure 3-84 Load File Dialog: GTT File List

The Load File Dialog: GTT File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT file or folder.

• Last Modified—Date and time the GTT file or folder was last modified.
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• Size (bytes)—Size of the GTT file or folder, in bytes.

• Number of Files—Total number of GTT files and folders (displayed in 
bottom left corner).

To load a GTT file, enter the name of the file or select it in the list and click OK. 
SGM closes the Load File Dialog: GTT File List and displays the Progress Dialog 
(Figure 3-85).

Figure 3-85 Progress Dialog

The Progress Dialog displays the progress of the GTT file load, as well as any 
messages generated while loading the file.

To stop loading the file, click Cancel.

When the file has been loaded, click OK. SGM closes the Progress Dialog, loads 
the GTT file, and returns to the GTT Configuration window.

When you load a GTT file, the name of the server associated with the GTT client 
and the filename are displayed in the window name:

SGM: GTT Configurator -- sgm-sun8 -- GTT.File.1
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If you have not yet loaded or saved a GTT file, SGM displays No File Loaded in 
place of the GTT file name.

To delete a GTT file from the GTT file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: GTT File List.

To close the Load File Dialog: GTT File List without loading a GTT file or saving 
any changes to the GTT file list, click Cancel.

Step 23 SGM strongly recommends that you to check the semantics of a GTT file against 
a specific ITP, validating the following data in the GTT file:

• ITP Point Code—For version 2.0 GTT files, the point code in the GTT file 
cannot be the same as the ITP's primary, secondary, or capability point code. 
If it is the same, SGM generates an Error.

This is not a restriction for GTT files of version 3.0 or later.

• Route Table—The ITP’s route table must contain all point codes in the GTT 
file, other than the ITP’s primary, secondary, or capability point code. If the 
route table does not contain the point codes, SGM generates an Error.

• Route Status—All route entries for point codes in the GTT file, other than 
the ITP’s primary, secondary, or capability point code, must be available. If 
they are not, SGM generates a Warning.

• GTA and Application Group—If either the GTA or the application group is 
configured by an application server, then that application server must exist on 
the ITP. If it does not exist, SGM generates an Error.

If the application server exists on the ITP, but it is not available, SGM 
generates a Warning.

For example, ITP limits XUA configuration to instance 0. The SGM semantic 
check verifies that XUA is not configured on any other instance.

To check the semantics of a GTT file, select File > Semantic Check from the 
GTT menu. SGM displays the Semantic Check GTT dialog (Figure 3-86).
3-328
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Editing a Global Title Translation Table
Figure 3-86 Semantic Check GTT Dialog

The Semantic Check GTT dialog contains the following fields:

• ITP Name or IP Address—Name or IP address of the ITP against which to 
check the GTT file.

Enter the name or IP address of an ITP and click OK. SGM closes the Semantic 
Check GTT dialog and opens the Progress Dialog (Figure 3-85).

The Progress Dialog displays the progress of the semantic check for the GTT file, 
as well as any messages generated while checking the file.

To cancel the check, click Cancel.

When the check is complete, click OK. SGM closes the Progress Dialog and 
returns to the Semantic Check GTT dialog.

To close the Semantic Check GTT dialog without checking the semantics of the 
GTT file, click Cancel.

Note You can also use the sgm gttcheck command to semantics of a GTT file. 
For more information on the use of this command, see the “SGM 
Commands and Descriptions” section on page B-2.

Step 24 (Optional) To display basic information about the currently displayed GTT file, 
select View > GTT Table Info from the GTT menu. SGM displays the GTT Table 
Info Dialog (Figure 3-87).
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Figure 3-87 GTT Table Info Dialog

The GTT Table Info Dialog contains the following fields:

• Filename—Name of the GTT file.

• Version—Version of the file format to be used by the GTT. Valid versions are:

– 2.0 (MB5, MB6)—Corresponds to ITP software releases 12.2(4)MB5 
and 12.2(4)MB6. Allows GTT translation to an application server.

– 3.0 (MB7, MB8)—Corresponds to ITP software releases 12.2(4)MB7 
and 12.2(4)MB8. Allows local point codes in GTT tables.

– 3.1 (MB9, MB9a)—Corresponds to ITP software releases 12.2(4)MB9 
and 12.2(4)MB9a. Two or more entries in the same application group can 
have the same cost. This is the default version in SGM.

– 4.0 (MB10+)—Corresponds to ITP software release 12.2(4)MB10 or 
greater. Supports multiple instances on a single node.

SGM 3.0 does not support version 1.0, which corresponds to ITP software 
release 12.2(4)MB4. You can load a version 1.0 file into SGM, but fields or 
features that are unique to version 1.0 are not displayed, they are removed 
from the GTT file the next time it is saved, and the file is saved as a version 
2.0 file.

• Variant—SS7 p[rotocol variant. Valid variants are:

– ANSI

– China

– ITU
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• Instance ID—ID of the instance used by the GTT. Valid IDs are 0 to 7. The 
default instance ID is 0. If there is no instance associated with the GTT, this 
field displays N/A.

• Last Modified—Date and time the GTT file was last modified.

• Total Entries—Total number of entries in the GTT file.

Click OK to close the GTT Table Info Dialog.

Step 25 (Optional) To save the changes you have made to the GTT file, or to modify the 
list of GTT files, use one of the following procedures:

• To save the changes you have made to the GTT file without changing the 
name of the file, select File > Save from the GTT menu.

• To save the changes you have made to the GTT file with a new name, select 
File > Save As from the GTT menu. SGM displays the Save File Dialog: GTT 
File List (Figure 3-88).

Figure 3-88 Save File Dialog: GTT File List
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The Save File Dialog: GTT File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT file or folder.

• Last Modified—Date and time the GTT file or folder was last modified.

• Size (bytes)—Size of the GTT file or folder, in bytes.

• Filename—Name by which you want to save the GTT file.

If you create a new GTT file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system. However, 
if you include any spaces in the new name, SGM converts those spaces to 
dashes. For example, SGM saves file “a b c” as “a-b-c”.

• Number of Files—Total number of GTT files and folders (displayed in 
bottom left corner).

To save the GTT file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old GTT file, select the 
name in the list and click OK.

SGM closes the Save File Dialog: GTT File List and displays the Progress Dialog 
(Figure 3-85).

The Progress Dialog displays the progress of the GTT file save, as well as any 
messages generated while saving the file.

To stop saving the file, click Cancel.

When the file has been saved, click OK. SGM closes the Progress Dialog, saves 
the GTT file with the new name, and returns to the GTT Configuration window.

Note If another user modifies and saves the GTT file before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If you 
choose to do so, the other user’s changes are overwritten and lost. If you 
choose not to do so, your changes are lost, unless you save the GTT file 
to a different filename.
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To delete a GTT file from the GTT file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog: GTT File List.

To close the Save File Dialog: GTT File List without saving the GTT file or saving 
any changes to the GTT file list, click Cancel.

Step 26 When you are ready to exit the GTT Configurator window, select File > Exit from 
the GTT menu.

If you have made any changes to the GTT file, SGM asks if you want to save the 
changes before leaving the window:

• Click Yes to save the changes.

SGM opens the Save File Dialog: GTT File List, which enables you to save 
the GTT file with a new name, or overwrite an existing GTT file.

SGM then opens the Save File Dialog: GTT Preferences File List, which 
enables you to save the GTT preferences file with a new name, or overwrite 
an existing GTT preferences file.

• Click No to close the prompt window.

SGM automatically saves your GTT preferences, then closes the GTT 
Configurator window without saving any changes to the GTT file.

By default, GTT files and GTT preferences files are located in the SGM 
installation directory:

• If you installed SGM in the default directory, /opt, then the default directory 
is /opt/CSCOsgm/gtt.

• If you installed SGM in a different directory, then the default directory is 
located in that directory.

To change the directory in which SGM stores GTT files, use the sgm gttdir 
command. See the “SGM Commands and Descriptions” section on page B-2 form 
more information on the use of this command.
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Working with SGM Statistics Reports
Once every hour, SGM gathers critical information from all known nodes, 
signaling points, linksets, and links. SGM then uses that information to calculate 
statistics, and generates reports based on those statistics.

SGM enables you to:

• View and export detailed network link and linkset statistics summary reports.

• View and export detailed accounting statistics reports.

• Create, view, and export custom statistics reports.

• View and export point code inventory reports.

• Modify the way SGM displays information in reports.

By default, SGM stores all reports in the report files directory, /reports:

• If you installed SGM in the default directory, /opt, then the default report files 
directory is /opt/CSCOsgm/reports.

• If you installed SGM in a different directory, then the default report files 
directory is located in that directory.

The /reports directory contains the following subdirectories:

• /daily—Contains all daily report files, stored in .Z format.

• /exportdaily—Contains all daily report files, edited and formatted for export, 
stored as Zip files.

• /hourly—Contains all hourly report files, stored in .Z format.

• /exporthourly—Contains all hourly report files, edited and formatted for 
export, stored as Zip files.

• /exportrolling—Contains all rolling report files, edited and formatted for 
export, stored as Zip files. SGM rebuilds the files in this subdirectory every 
hour.
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• /custom—Contains all custom report files. These are the report files 
generated using the sgm accstats and sgm linkstats commands.

Each file is identified with a unique ID tag, specified when the sgm accstats 
or sgm linkstats command was entered. If the user did not specify an ID tag, 
SGM uses the process ID of the sgm accstats or sgm linkstats command.

• /etc—Contains additional files used by the SGM reporting scripts and Web 
pages, including the nodes.include, linksets.include, nodes.exclude, and 
linksets.exclude files, if they exist.

This section includes the following information:

• Modifying the Way SGM Handles Statistics Reports (Solaris Only), 
page 3-335

• Changing the SGM Reports Directory (Solaris Only), page 3-342

• Viewing SGM Network Statistics Reports, page 3-343

• Viewing SGM Accounting Statistics Reports, page 3-364

• Generating and Viewing Custom SGM Statistics Reports, page 3-369

• Viewing SGM Point Code Inventory Reports, page 3-390

• Viewing SGM Statistics Reports Logs, page 3-394

Modifying the Way SGM Handles Statistics Reports (Solaris 
Only)

SGM enables you to modify the following aspects of statistics reports:

• To specify whether SGM is to generate network statistics reports, enter the 
sgm statreps [disable | enable] command:

– To generate network statistics reports, enter sgm statreps enable. This is 
the default setting.

– To not generate network statistics reports, enter sgm statreps disable.
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• To specify whether SGM is to generate network statistics reports in export 
format, enter the sgm statreps [export | noexport] command:

– To generate network statistics reports in export format, enter 
sgm statreps export. This is the default setting.

– To not generate network statistics reports in export format, enter 
sgm statreps noexport.

• To specify whether SGM is to generate accounting statistics reports, enter the 
sgm statreps [acct | noacct] command:

– To generate accounting statistics reports, enter sgm statreps acct. 
Accounting must be enabled on the links in order for SGM to generate 
accounting statistics.

– To not generate accounting statistics reports, enter sgm statreps noacct. 
This is the default setting.

• To specify whether SGM is to include links that use the Stream Control 
Transmission Protocol (SCTP) IP transport protocol in network statistics 
reports, enter the sgm statreps [iplinks | noiplinks] command:

– To include SCTPIP links, enter sgm statreps iplinks. This is the default 
setting.

– To not include SCTPIP links, enter sgm statreps noiplinks.

• To specify whether SGM is to include links that do not have planned send and 
receive capacities in network statistics reports, enter the sgm statreps 
[nullcaps | nonullcaps] command:

– To include links that do not have planned send and receive capacities, 
enter sgm statreps nullcaps. This is the default setting.

– To not include links that do not have planned send and receive capacities, 
enter sgm statreps nonullcaps.

• To set the time mode for dates in network statistics reports, enter the 
sgm statreps timemode [12 | 24] command:

– To use 24-hour time, also called military time, enter sgm statreps 
timemode 24. 1:00 in the afternoon is 13:00. This is the default setting.

– To use 12-hour time, with AM and PM, enter sgm statreps 
timemode 12. 1:00 in the afternoon is 1:00 PM.
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• To specify whether SGM is to verify that a disk has at least 10 MB of space 
remaining before generating network statistics reports, enter the 
sgm statreps [diskcheck | nodiskcheck] command:

– To verify the disk space, enter sgm statreps diskcheck. This is the 
default setting.

– To not verify the disk space, enter sgm statreps nodiskcheck.

• To specify whether SGM is to display a gray background in the Send 
Utilization or Receive Utilization cell in a network statistics report, if the 
following condition is met:

Current Utilization > factor * Long-Term Utilization

enter the sgm statreps utilratio command. The default value for factor is 1.5.

• To specify whether SGM is to display a gray background in the InSrv cell in 
a network statistics report, if the following condition is met:

Current In-Service < factor * Long-Term In-Service

enter the sgm statreps servratio command. The default value for factor 
is 0.95.

• To set the maximum number of days SGM is to archive hourly network 
statistics reports, enter the sgm statreps hourlyage or sgm rephourlyage 
command. The default setting is 31  days.

• To set the maximum number of days SGM is to archive daily network 
statistics reports, enter the sgm statreps dailyage or sgm repdailyage 
command. The default setting is 90  days.

• To set the maximum number of days SGM is to archive custom network 
statistics reports, enter the sgm repcustage command. The default setting is 
10  days.

• To specify whether SGM is to show real node names or display names in Web 
pages, enter the sgm webnames command:

– To show the real DNS names of nodes, as discovered by SGM, enter sgm 
webnames real. This is the default setting.

– To show display names, enter sgm webnames display. Display names 
are new names that you specify for nodes. For more information about 
display names, see the “Editing a Node” section on page 3-124.
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• To specify whether SGM is to display send and receive utilization for linksets 
and links as percentages or in Erlangs in Web pages, enter the sgm webutil 
command:

– To display utilization as a percentage, enter sgm webutil percent. This 
is the default setting.

– To show display utilization in Erlangs, enter sgm webutil erlangs.

See the “Working with SGM Statistics Reports” section on page 3-334 for 
more information on send and receive utilization for linksets and links.

• To display the current status of all SGM network statistics report parameters, 
enter the sgm statreps status command.

• To display the timer file for SGM network statistics reports, enter the 
sgm statreps timer command. The timer file is useful for identifying how 
much time SGM spends gathering report data and generating reports.

• To include only specific nodes or signaling points in reports, create the 
user-defined nodes.include file and list the nodes and signaling points in the 
file. Only those nodes and signaling points will be included in automatically 
generated SGM accounting statistics and network statistics reports, as well as 
in custom reports that were generated with the default keyword (or no 
node-list keyword at all) on the sgm accstats or sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the nodes.include 
file is located at /opt/CSCOsgm/reports/etc/nodes.include.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/nodes.include file is located in that directory.

– Each line in the nodes.include file must contain a single node name, or 
node name and signaling point name, that matches exactly the real, fully 
qualified node name of the node, and each line must end with a colon (:). 
For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:
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To include a specific signaling point, specify the node name and 
signaling point:

sgm-75-59a.cisco.com;net0:

sgm-26-51a.cisco.com;net1:

– Wildcard matching is not supported.

– If a node or signaling point appears in both the nodes.include file and the 
nodes.exclude file, it is excluded. That is, excluding a node or signaling 
point overrides including the same node or signaling point.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.include file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-374 for more 
information on the special include file.

• To include only specific linksets in reports, create the user-defined 
linksets.include file and list the linksets in the file. Only those linksets will be 
included in automatically generated SGM accounting statistics and network 
statistics reports, as well as in custom reports that were generated with the 
default keyword (or no node-list keyword at all) on the sgm accstats or 
sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the 
linksets.include file is located at 
/opt/CSCOsgm/reports/etc/linksets.include.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/linksets.include file is located in that directory.

– Each line in the linksets.include file must contain a single linkset name 
that matches exactly the real, fully qualified linkset name of the linkset, 
including the node name and signaling point name. For example:

sgm-75-59a.cisco.com;net0:linkset2

sgm-26-51a.cisco.com;net1:linkset1

– Wildcard matching is not supported.
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– If a linkset appears in both the linksets.include file and the 
linksets.exclude file, it is excluded. That is, excluding a linkset overrides 
including the same linkset.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.include file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-374 for more 
information on the special include file.

• To exclude specific nodes or signaling points from reports, create the 
user-defined nodes.exclude file and list the nodes and signaling points in the 
file. Those nodes and signaling points will be excluded from automatically 
generated SGM accounting statistics and network statistics reports, as well as 
from custom reports that were generated with the default keyword (or no 
node-list keyword at all) on the sgm accstats or sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the nodes.exclude 
file is located at /opt/CSCOsgm/reports/etc/nodes.exclude.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/nodes.exclude file is located in that directory.

– Each line in the nodes.exclude file must contain a single node name, or 
node name and signaling point name, that matches exactly the real, fully 
qualified node name of the node, and each line must end with a colon (:). 
For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

To exclude a specific signaling point, specify the node name and 
signaling point:

sgm-75-59a.cisco.com;net0:

sgm-26-51a.cisco.com;net1:

– Wildcard matching is not supported.
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– If a node or signaling point appears in both the nodes.include file and the 
nodes.exclude file, it is excluded. That is, excluding a node or signaling 
point overrides including the same node or signaling point.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.exclude file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-374 for more 
information on the special include file.

• To exclude specific linksets from reports, create the user-defined 
linksets.exclude file and list the linksets in the file. Those linksets will be 
excluded from automatically generated SGM accounting statistics and 
network statistics reports, as well as from custom reports that were generated 
with the default keyword (or no node-list keyword at all) on the sgm accstats 
or sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the 
linksets.exclude file is located at 
/opt/CSCOsgm/reports/etc/linksets.exclude.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/linksets.exclude file is located in that directory.

– Each line in the linksets.exclude file must contain a single linkset name 
that matches exactly the real, fully qualified linkset name of the linkset, 
including the node name and signaling point name. For example:

sgm-75-59a.cisco.com;net0:linkset2

sgm-26-51a.cisco.com;net1:linkset1

– Wildcard matching is not supported.

– If a linkset appears in both the linksets.include file and the 
linksets.exclude file, it is excluded. That is, excluding a linkset overrides 
including the same linkset.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.exclude file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-374 for more 
information on the special include file.
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• To use PAGER to display the contents of the system reports log, enter the 
sgm replog command. The reports log lists all messages related to the 
creation and maintenance of SGM reports.

To clear the log and restart the server, enter sgm replog clear.

To display the contents of the log in reverse order, with the most recent 
commands at the beginning of the log, enter sgm replog -r.

For more information about the reports log, see the “Viewing the SGM 
System Reports Log” section on page 3-394.

• To remove all data from SGM network statistics reports, restoring the reports 
to a “clean” state, enter the sgm statreps clean command.

• To remove all data from one or more SGM custom statistics reports, restoring 
the reports to a “clean” state, enter the sgm statreps cleancustom command.

– To clean all custom reports, enter sgm statreps cleancustom.

– To clean a single custom report, enter sgm statreps cleancustom tag, 
where tag is the ID tag of the custom report you want to clean.

For more information about each of these commands, including valid ranges and 
default settings, see the “SGM Commands and Descriptions” section on page B-2.

Each of these commands requires you to be logged in as the root user, as described 
in the “Becoming the Root User (Solaris Only)” section on page 3-2, or as a super 
user, as described in the “Specifying a Super User (Solaris Only)” section on 
page 4-22.

Changing the SGM Reports Directory (Solaris Only)
You can change the directory in which SGM stores reports.

To change the SGM report files directory, log in as the root user, as described in 
the “Becoming the Root User (Solaris Only)” section on page 3-2, or as a super 
user, as described in the “Specifying a Super User (Solaris Only)” section on 
page 4-22, and enter the following commands:

# cd /opt/CSCOsgm/bin

# ./sgm repdir directory

where directory is the new directory.
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Note This command copies all files in the current directory to the new directory. If you 
are logged in as the super user, and you do not own the new directory, you might 
not be able to copy the files. If that is the case, you must specify a directory that 
you own, or you must log in as the root user.

Viewing SGM Network Statistics Reports
SGM enables you to view hourly and daily statistics summary reports for links 
and linksets. You can also export the reports.

SGM enables you to view the following network statistics reports for linksets:

• Viewing the Linkset Statistics Hourly Reports, page 3-344

• Viewing the Linkset Statistics Daily Summary Reports, page 3-346

SGM enables you to view the following network statistics reports for links:

• Viewing the Link Statistics Hourly Reports, page 3-349

• Viewing the Link Statistics Daily Summary Reports, page 3-354

• Viewing the Five Day Link Utilization Report, page 3-359

SGM enables you to view the following network statistics reports export files:

• Viewing the Hourly Network Statistics Export Files, page 3-361

• Viewing the Daily Network Statistics Export Files, page 3-362

• Viewing the Rolling Network Statistics Export Files, page 3-363
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Viewing the Linkset Statistics Hourly Reports

SGM enables you to view hourly summaries of statistics for all linksets known to 
SGM on the specified date and hour.

To view hourly summaries of statistics, select Linkset Hourly from the menu bar 
of any SGM Network Statistics or Accounting Statistics Web page. SGM displays 
the Linkset Statistics: Hourly Reports page, which displays hourly linkset 
statistics summary reports, archived by date, and by hour:

• To view an archived report showing all hourly linkset statistics summary 
reports for an entire day, click a date. SGM displays the Linkset Statistics: 
Daily All Hours Report page for that date.

• To view an archived report showing all hourly linkset statistics summary 
reports for a specific date and hour, click an hour. SGM displays the Linkset 
Statistics: Hourly Report page for that date and hour.

The Linkset Statistics: Daily All Hours Report and Linkset Statistics: Hourly 
Report pages both display the following information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly linkset statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Linkset Data 
Record page for that linkset, date, and hour, in text format. The Linkset Data 
Record can be useful when the TAC is debugging problems.

• Hour—(Linkset Statistics: Daily All Hours Report page only) Hour for 
which the link statistics summary report was created, for the specified date.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Inst Name—Name of instance for the linkset.

• Sig Point—Name of signaling point for the linkset. To see statistics for only 
a selected signaling point, click the signaling point.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.
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• Hourly InSrv—Percentage of time the linkset was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the linkset was in service 
since SGM polling began for the linkset, or since SGM last reset the averages 
as a result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Linkset 
Statistics: Daily All Hours Report and Linkset Statistics: Hourly Report pages:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-279 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing the Linkset Statistics Daily Summary Reports

SGM enables you to view a daily summary of statistics for all linksets known to 
SGM on a specified date.

To view a daily summary of statistics, select Linkset Daily from the menu bar of 
any SGM Network Statistics or Accounting Statistics Web page. SGM displays 
the Linkset Statistics: Daily Summary Reports page, which displays daily linkset 
statistics summary reports, archived by date. Each archived file contains a daily 
summary of statistics for all linksets known to SGM on a specified date.
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To view an archived linkset statistic summary report, click a date. SGM displays 
the Linkset Statistics: Daily Summary Report page for that date.

The Linkset Statistics: Daily Summary Report table displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Inst Name—Name of instance for the linkset.

• Sig Point—Name of signaling point for the linkset. To see statistics for only 
a selected signaling point, click the signaling point.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.

• Daily InSrv—Average percentage of time the linkset was in service on the 
specified date.

• Long Term InSrv—Average percentage of time the linkset was in service 
since SGM polling began for the linkset, or since SGM last reset the averages 
as a result of bad data.

• Daily Low InSrv—Lowest hourly in-service percentage for the linkset, for 
the specified date.

• Low Srv Hour—Hour in which the lowest in-service percentage occurred, 
for the specified date.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Linkset 
Statistics: Daily Summary Report page:

• You can sort the Linkset Statistics: Daily Summary Report page based on the 
information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-279 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing the Link Statistics Hourly Reports

SGM enables you to view hourly link statistics summary reports for an entire day, 
or for a specific date and hour.

To view hourly link statistics summary reports, select Link Hourly from the 
menu bar of any SGM Network Statistics or Accounting Statistics Web page. 
SGM displays the Link Statistics: Hourly Reports page, which displays hourly 
link statistics summary reports, archived by date, and by hour:

• To view an archived report showing all hourly link statistics summary reports 
for an entire day, click a date. SGM displays the Link Statistics: Daily All 
Hours Report page for that date.

• To view an archived report showing all hourly link statistics summary reports 
for a specific date and hour, click an hour. SGM displays the Link Statistics: 
Hourly Report page for that date and hour.
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The Link Statistics: Daily All Hours Report and Link Statistics: Hourly Report 
pages both display the following information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly link statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Link Data 
Record page for that link, date, and hour, in text format. The Link Data 
Record can be useful when the TAC is debugging problems.

• Hour—(Link Statistics: Daily All Hours Report page only) Hour for which 
the link statistics summary report was created, for the specified date.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Inst Name—Name of instance for the link.

• Sig Point—Name of signaling point for the link. To see statistics for only a 
selected signaling point, click the signaling point.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTP—The link uses the Stream Control Transmission Protocol (SCTP) 
IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Send Util or Send Erls—Average Send Utilization for the link, expressed as 
either a utilization percentage or a number of Erlangs (as set in the 
Preferences window), for the specified date and hour.

If the planned send capacity is not set for the link, this field displays NoCap.
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• L Term Send Util or L Term Send Erls—Long-term average Send 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), since SGM polling 
began for the link, or since SGM last reset the averages as a result of bad data.

If the planned send capacity is not set for the link, this field displays NoCap.

• Recv Util or Recv Erls—Average Receive Utilization for the link, expressed 
as either a utilization percentage or a number of Erlangs (as set in the 
Preferences window), for the specified date and hour.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• L Term Recv Util or L Term Recv Erls—Long-term average Receive 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), since SGM polling 
began for the link, or since SGM last reset the averages as a result of bad data.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date and 
hour.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date 
and hour.

• Drop—Total number of drops on the specified date and hour.

• Hourly InSrv—Percentage of time the link was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the link was in service since 
SGM polling began for the link, or since SGM last reset the averages as a 
result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Link 
Statistics: Daily All Hours Report and Link Statistics: Hourly Report pages:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-279 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
3-352
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with SGM Statistics Reports
• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.

• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.
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Viewing the Link Statistics Daily Summary Reports

SGM enables you to view a daily summary of statistics for all links known to 
SGM on a specified date.

To view a daily summary of statistics, use one of the following procedures:

• Select View > Reports > Network Statistics from the SGM Main Menu.

• Select Network Statistics Reports from the SGM Server Home Page.

• Select Link Daily from the menu bar of any SGM Network Statistics or 
Accounting Statistics Web page.

SGM displays the Link Statistics: Daily Summary Reports page, which displays 
daily link statistics summary reports are archived by date. Each archived file 
contains a daily summary of statistics for all links known to SGM on a specified 
date.

To view an archived link statistic summary report, click a date. SGM displays the 
Link Statistics: Daily Summary Report page for that date (Figure 3-89).

Figure 3-89 Link Statistics: Daily Summary Report Page
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The Link Statistics: Daily Summary Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Inst Name—Name of instance for the link.

• Sig Point—Name of signaling point for the link. To see statistics for only a 
selected signaling point, click the signaling point.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTP—The link uses the Stream Control Transmission Protocol (SCTP) 
IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Avg Send Util or Avg Send Erls—Average Send Utilization for the link, 
expressed as either a utilization percentage or a number of Erlangs (as set in 
the Preferences window), for the specified date.

If the planned send capacity is not set for the link, this field displays NoCap.

• Peak Send Util or Peak Send Erls—Highest hourly Average Send 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), for the specified date.

• Peak Send Hour—Hour in which the Peak Send Utilization for the link 
occurred, for the specified date.
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• L Term Send Util or L Term Send Erls—Long-term average Send 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), since SGM polling 
began for the link, or since SGM last reset the averages as a result of bad data.

If the planned send capacity is not set for the link, this field displays NoCap.

• Avg Recv Util or Avg Recv Erls—Average Receive Utilization for the link, 
expressed as either a utilization percentage or a number of Erlangs (as set in 
the Preferences window), for the specified date.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Peak Recv Util or Peak Recv Erls—Highest hourly Average Receive 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), for the specified date.

• Peak Recv Hour—Hour in which the Peak Receive Utilization for the link 
occurred, for the specified date.

• L Term Recv Util or L Term Recv Erls—Long-term average Receive 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), since SGM polling 
began for the link, or since SGM last reset the averages as a result of bad data.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date.

• Drop—Total number of drops on the specified date.

• Daily InSrv—Average percentage of time the link was in service on the 
specified date.

• Long Term InSrv—Average percentage of time the link was in service since 
SGM polling began for the link, or since SGM last reset the averages as a 
result of bad data.

• Daily Low InSrv—Lowest hourly in-service percentage for the link, for the 
specified date.

• Low Srv Hour—Hour in which the lowest in-service percentage occurred, 
for the specified date.
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If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Link 
Statistics: Daily Summary Report page:

• You can sort the Link Statistics: Daily Summary Report page based on the 
information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-279 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.

• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.
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Viewing the Five Day Link Utilization Report

The Five Day Link Utilization Report page displays send and receive utilization 
percentages for all links for the last five (5) days.

To access the Five Day Link Utilization Report page, select Five Day Link Util 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page. SGM displays the five day utilization report for the specified link.

The Five Day Link Utilization Report page displays the following information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

The default sort order is day one, Send Utilization for the link, descending.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Inst Name—Name of instance for the link.

• Sig Point—Name of signaling point for the link. To see statistics for only a 
selected signaling point, click the signaling point.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.

• Send Util or Send Erls—Send Utilization for the link, expressed as either a 
utilization percentage or a number of Erlangs (as set in the Preferences 
window), for each of the last five days. If the planned send capacity is not set 
for the link, this field displays NoCap.

• Recv Util or Recv Erls—Receive Utilization for the link, expressed as either 
a utilization percentage or a number of Erlangs (as set in the Preferences 
window), for each of the last five days. If the planned receive capacity is not 
set for the link, this field displays NoCap.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Five Day 
Link Utilization Report page:

• You can sort the Five Day Link Utilization Report page based on the 
information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-279 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.

• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.

Viewing the Hourly Network Statistics Export Files

The Hourly Network Statistics Export Files page displays all archived SGM 
hourly network statistics summary reports, for all links and linksets known to 
SGM, for the server to which you are connected, stored as downloadable Zip files.

To access the Hourly Network Statistics Export Files page, select Hourly Export 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page.
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On the Hourly Network Statistics Export Files page, the Zip files are archived by 
type (linkset or link), date, and hour. For example, 
sgmLinksetStats.2002-10-15-08.csv.zip is the Zip file that contains the hourly 
linkset statistics summary report for the 8th hour on October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with an 
hourly network statistics summary report for all links or linksets that were known 
to SGM on that date and hour. You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Link Statistics Hourly Export File Format” section on page F-4 for 
detailed information about the format of hourly link statistics export files.

See the “SGM Linkset Statistics Hourly Export File Format” section on page F-6 
for detailed information about the format of hourly link and linkset statistics 
export files.

Viewing the Daily Network Statistics Export Files

The Daily Network Statistics Export Files page displays all archived SGM daily 
network statistics summary reports, for all links and linksets known to SGM, for 
the server to which you are connected, stored as downloadable Zip files.

To access the Daily Network Statistics Export Files page, select Daily Export 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page.

On the Daily Network Statistics Export Files page, the Zip files are archived by 
type (linkset or link) and date. For example, 
sgmLinksetStats.DailySum.2002-10-15.csv.zip is the Zip file that contains the 
daily linkset statistics summary report for October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with a 
daily network statistics summary report for all links or linksets that were known 
to SGM on that date and hour. You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Link Statistics Daily Export File Format” section on page F-3 for 
detailed information about the format of daily link statistics export files.
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See the “SGM Linkset Statistics Daily Export File Format” section on page F-5 
for detailed information about the format of daily link and linkset statistics export 
files.

Viewing the Rolling Network Statistics Export Files

The Rolling Network Statistics Export Files page displays concatenated SGM 
hourly and daily network statistics summary reports, for all links and linksets 
known to SGM, for the server to which you are connected, stored as downloadable 
Zip files.

To access the Rolling Network Statistics Export Files page, select Rolling Export 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page.

On the Rolling Network Statistics Export Files page, the Zip files are archived by 
type (linkset or link) and number of days (7 or 30). For example:

• sgmLinksetStats.RollingSevenDayAllHours.csv.zip is the Zip file that 
contains the hourly linkset statistics summary reports for the last seven (7) 
days, concatenated into one comma-separated value (CSV) text file.

• sgmLinksetStats.Rolling30DayAllDays.csv.zip is the Zip file that contains 
the daily linkset statistics summary reports for the last 30 days, concatenated 
into one comma-separated value (CSV) text file.

• sgmLinkStats.RollingSevenDayAllHours.csv.zip is the Zip file that 
contains the hourly link statistics summary reports for the last seven (7) days, 
concatenated into one comma-separated value (CSV) text file.

• sgmLinkStats.Rolling30DayAllDays.csv.zip is the Zip file that contains the 
daily link statistics summary reports for the last 30 days, concatenated into 
one comma-separated value (CSV) text file.

SGM creates a new set of files every hour.

You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Rolling Network Statistics Export File Formats” section on 
page F-7 for detailed information about the format of rolling statistics export files.
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Viewing SGM Accounting Statistics Reports
SGM enables you to view accounting statistics reports. You can also export the 
reports.

SGM enables you to view the following accounting statistics reports:

• Viewing the Accounting Statistics Daily Detail Reports, page 3-364

• Viewing the Daily Accounting Statistics Export Files, page 3-368

Viewing the Accounting Statistics Daily Detail Reports

SGM enables you to view a daily summary of accounting statistics for SGM on a 
specified date. Accounting statistics are displayed based on the node, signaling 
point, linkset, originating point code (OPC), the destination point code (DPC), the 
type of SS7 traffic (such as ISUP or SCCP), and whether the traffic passed or 
failed the Gateway Screening test at the ITP.

To view a daily summary of accounting statistics, use one of the following 
procedures:

• Select View > Reports > Accounting Statistics from the SGM Main Menu.

• Select Accounting Statistics Reports from the SGM Server Home Page.

• Select Accounting Daily from the menu bar of any SGM Network Statistics 
or Accounting Statistics Web page.

SGM displays the Accounting Statistics: Daily Detail Reports page, which 
displays daily accounting statistics reports, archived by date. Each archived file 
contains a daily summary of accounting statistics for SGM on a specified date.

To view an archived accounting statistic report, click a date. SGM displays the 
Accounting Statistics: Daily Detail Report page for that date (Figure 3-90).
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Figure 3-90 Accounting Statistics: Daily Detail Report Page

The Accounting Statistics: Daily Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly accounting 
statistics report.

To see the entire detailed report, click the ID. SGM displays the Accounting 
Data Record # X for Date for that date and hour. The Accounting Data Record 
# X for Date can be useful when the TAC is debugging problems.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Inst Name—Name of instance for the linkset.

• Sig Point—Name of signaling point for the linkset. To see statistics for only 
a selected signaling point, click the signaling point.
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• Linkset—Name of the linkset. To see statistics for only a selected linkset, 
click the linkset name.

• Gateway Screening—Indicates whether the traffic passed or failed the 
Gateway Screening test at the ITP. To see only statistics that passed or failed 
for a specific linkset, select a linkset and click Pass or Fail.

• OPC—Originating point code of the traffic, which is a unique identifier for 
each set of statistics. To see only statistics that match a specific OPC for a 
given linkset, find the linkset and click the point code.

• DPC—Destination point code of the traffic. To see only statistics that match 
a specific DPC for a given linkset, find the linkset and click the point code.

• SI—Service indicator, which indicates the type of SS7 traffic, such as ISUP 
or SCCP. To see only detailed information for a specific type of SI, click the 
SI type.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date.

• Send Bytes—Total number of bytes sent on the specified date.

• Recv Bytes—Total number of bytes received on the specified date.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Accounting 
Statistics: Daily Detail Report page:

• You can sort the Accounting Statistics: Daily Detail Report page based on the 
information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-279 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing the Daily Accounting Statistics Export Files

The Daily Accounting Statistics Export Files page displays all archived SGM 
daily accounting statistics reports for the server to which you are connected, 
stored as downloadable Zip files.

To access the Daily Accounting Statistics Export Files page, select Accounting 
Export from the menu bar of any SGM Network Statistics or Accounting 
Statistics Web page.

On the Daily Accounting Statistics Export Files page, the Zip files are archived 
by date. For example, sgmAccStats.DailyDetail.2002-10-15.csv.zip is the Zip 
file that contains the daily accounting statistics report for October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with a 
daily accounting statistics report for that date. You can download the Zip files and 
unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Daily and Hourly Accounting Statistics Export File Format” 
section on page F-2 for detailed information about the format of accounting 
statistics export files.
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Generating and Viewing Custom SGM Statistics Reports
SGM enables you to create custom link and linkset statistics summary reports, and 
custom accounting reports. You can also export the reports.

This section contains the following information:

• Generating a Custom Network Statistics Report, page 3-369

• Generating a Custom Accounting Statistics Report, page 3-372

• Including Specific Nodes in Custom Reports, page 3-374

• Including Specific Linksets in Custom Reports, page 3-376

• Excluding Specific Nodes from Custom Reports, page 3-377

• Excluding Specific Linksets from Custom Reports, page 3-378

• Viewing the Custom Network Statistics Export Files, page 3-379

• Viewing a Custom Accounting Statistics Report, page 3-380

• Viewing a Custom Link Statistics Summary Report, page 3-383

• Viewing a Custom Linkset Statistics Summary Report, page 3-387

Generating a Custom Network Statistics Report

To create a custom link and linkset statistics summary report for SGM, use the 
following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Solaris 
Only)” section on page 3-2, or as a super user, as described in the “Specifying a 
Super User (Solaris Only)” section on page 4-22.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./sgm linkstats [node-list [id-tag]] [sort-option] [quiet]
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• (Optional) To include or exclude specific nodes or linksets in the report, use 
the node-list argument. See the following sections for more information:

– Including Specific Nodes in Custom Reports, page 3-374

– Including Specific Linksets in Custom Reports, page 3-376

– Excluding Specific Nodes from Custom Reports, page 3-377

– Excluding Specific Linksets from Custom Reports, page 3-378

• (Optional) If you specify a node-list, you can also specify an id-tag to identify 
the report. The id-tag can be any meaningful character string, but it cannot 
contain any spaces. The default value for id-tag is the process ID of the 
sgm linkstats command.

• (Optional) To specify a sort order for the report, specify one of the following 
keywords for the sort-option argument:

– -sis—Sort based on average in-service percentage for each link (Daily 
InSrv), in descending order.

– -sls—Sort based on the linkset name, in ascending order.

– -sos—Sort based on the average out-of-service percentage for each link, 
in descending order.

– -sru—Sort based on the average Receive Utilization for each link (Avg 
Receive Util or Avg Receive Erls), in descending order.

– -ssu—Sort based on the average Send Utilization for each link (Avg Send 
Util or Avg Send Erls), in descending order. This is the default setting.

• (Optional) To disable automatic output to the terminal when running this 
command in a script, specify the quiet keyword. SGM generates the report in 
export format, which you can view using the SGM Web interface.

For example, to generate a custom link and linkset statistics summary report, that 
includes only links and linksets associated with node sgm-2600a.cisco.com, 
sorted in ascending order based on the linkset name, and identified by ID tag 
test1, enter the following command:

# ./sgm linkstats sgm-2600a.cisco.com test1 -sls
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Step 3 (Optional) If this is the first time you are using the sgm linkstats command to 
generate a report, you must enter the command two more times:

• The first entry gets the first set of raw data.

• The second entry calculates begins calculating useful link and linkset 
statistics.

• The third entry continues to calculate statistics, calculates long-term 
averages, and, if the data being collected appears valid, begins generating the 
report.

Thereafter, you need only enter this command once to generate the report.

Step 4 SGM generates the custom link and linkset statistics summary report and stores it 
in the /custom directory, identified by its ID tag.

For example, if you entered the command:

# ./sgm linkstats sgm-2600a.cisco.com test1 -sls

SGM generates the following reports:

sgmLinkStats.custom.test1.2002-10-27.csv.zip

sgmLinksetStats.custom.test1.2002-10-27.csv.zip

If you installed SGM in the default directory, /opt, then the /custom directory is 
located at /opt/CSCOsgm/reports/custom.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the /custom directory is located in 
that directory.

Step 5 For information on viewing the report, see the “Viewing the Custom Network 
Statistics Export Files” section on page 3-379.
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Generating a Custom Accounting Statistics Report

To create a custom accounting statistics report for SGM, use the following 
procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Solaris 
Only)” section on page 3-2, or as a super user, as described in the “Specifying a 
Super User (Solaris Only)” section on page 4-22.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./sgm accstats [node-list [id-tag]] [sort-option] [quiet]

• (Optional) To include or exclude specific nodes or linksets in the report, use 
the node-list argument. See the following sections for more information:

– Including Specific Nodes in Custom Reports, page 3-374

– Including Specific Linksets in Custom Reports, page 3-376

– Excluding Specific Nodes from Custom Reports, page 3-377

– Excluding Specific Linksets from Custom Reports, page 3-378

• (Optional) If you specify a node-list, you can also specify an id-tag to identify 
the report. The id-tag can be any meaningful character string, but it cannot 
contain any spaces. The default value for id-tag is the process ID of the 
sgm accstats command.

• (Optional) To specify a sort order for the report, specify one of the following 
keywords for the sort-option argument:

– -sdp—Sort based on the destination point code (DPC) of the node, in 
descending order.

– -sno—Sort based on the node name, in ascending order.

– -sop—Sort based on the originating point code (OPC) of the node, in 
descending order.

– -srb—Sort based on number of bytes received, in descending order.

– -srm—Sort based on number of MTP3 MSUs received, in descending 
order.

– -ssb—Sort based on number of bytes sent, in descending order.
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– -ssi—Sort numerically based on service indicator (SI), in ascending 
order.

– -ssm—Sort based on number of MTP3 MSUs sent, in descending order.

• (Optional) To disable automatic output to the terminal when running this 
command in a script, specify the quiet keyword. SGM generates the report in 
export format, which you can view using the SGM Web interface.

For example, to generate a custom accounting statistics report, that includes only 
information for node sgm-2600a.cisco.com, sorted in ascending order based on 
the node name, and identified by ID tag test1, enter the following command:

# ./sgm accstats sgm-2600a.cisco.com test1 -sno

Step 3 (Optional) If this is the first time you are using the sgm accstats command to 
generate a report, you must enter the command two more times:

• The first entry gets the first set of raw data.

• The second entry calculates begins calculating useful accounting statistics.

• The third entry continues to calculate statistics, calculates long-term 
averages, and, if the data being collected appears valid, begins generating the 
report.

Thereafter, you need only enter this command once to generate the report.

Step 4 SGM generates the custom accounting statistics report and stores it in the /custom 
directory, identified by its ID tag.

For example, if you entered the command:

# ./sgm accstats sgm-2600a.cisco.com test1 -sno

SGM generates the following reports:

sgmAccStats.custom.test1.2002-10-27.csv.zip

sgmAccStats.custom.test1.2002-10-27.csv.zip
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If you installed SGM in the default directory, /opt, then the /custom directory is 
located at /opt/CSCOsgm/reports/custom.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the /custom directory is located in 
that directory.

Step 5 For information on viewing the report, see the “Viewing the Custom Network 
Statistics Export Files” section on page 3-379.

Including Specific Nodes in Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to limit the report to one or more specific nodes.

• To generate a report that includes all nodes known to SGM, specify all in 
place of the node-list argument in the sgm accstats or sgm linkstats 
command. For example, the following command generates an accounting 
statistics report for all nodes:

./sgm accstats all

• To generate a report for a single node, specify the node name in place of the 
node-list argument in the sgm accstats or sgm linkstats command. The node 
name must match exactly the node name as discovered by SGM, including the 
domain name. For example, the following command generates an accounting 
statistics report for node sgm-2600a.cisco.com:

./sgm accstats sgm-2600a.cisco.com

• To generate a report that includes only the nodes and signaling points listed 
in the user-defined nodes.include file, create the file, then specify default in 
place of the node-list argument in the sgm accstats or sgm linkstats 
command. This is also the default setting for this command, if you do not 
specify a node-list keyword.

For example, the following command generates an accounting statistics 
report that includes only the nodes and signaling points specified in the 
nodes.include file:

./sgm accstats default
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Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the nodes.include 
file is located at /opt/CSCOsgm/reports/etc/nodes.include.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/nodes.include file is located in that directory.

– Each line in the nodes.include file must contain a single node name, or 
node name and signaling point name, that matches exactly the real, fully 
qualified node name of the node, and each line must end with a colon (:). 
For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

To include a specific signaling point, specify the node name and 
signaling point:

sgm-75-59a.cisco.com;net0:

sgm-26-51a.cisco.com;net1:

– Wildcard matching is not supported.

– If a node or signaling point appears in both the nodes.include file and the 
nodes.exclude file, it is excluded. That is, excluding a node or signaling 
point overrides including the same node or signaling point.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.include file.

• To generate a report that includes only a group of nodes or signaling points 
other than the nodes and signaling points listed in the nodes.include file, 
create a file that contains the list of nodes and signaling points to be included 
and specify the full path and name of the file in place of the node-list 
argument in the sgm accstats or sgm linkstats command.

For example, the following command generates an accounting statistics 
report that includes only the nodes and signaling points specified in the 
/opt/CSCOsgm/reports/etc/specialnodes.include file:

./sgm accstats /opt/CSCOsgm/reports/etc/specialnodes.include
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Keep in mind the following considerations:

– Each line in the special include file must contain a single node name, or 
node name and signaling point name, that matches exactly the real, fully 
qualified node name of the node, and each line must end with a colon (:). 
For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

To include a specific signaling point, specify the node name and 
signaling point:

sgm-75-59a.cisco.com;net0:

sgm-26-51a.cisco.com;net1:

– Wildcard matching is not supported.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.include, linksets.include, 
nodes.exclude, and linksets.exclude files, if they exist.

Including Specific Linksets in Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to limit the report to one or more specific linksets.

To generate a report that includes only the linksets listed in the user-defined 
linksets.include file, create the file, then specify default in place of the node-list 
argument in the sgm accstats or sgm linkstats command.

For example, the following command generates an accounting statistics report 
that includes only the linksets specified in the linksets.include file:

./sgm accstats default
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Keep in mind the following considerations:

• If you installed SGM in the default directory, /opt, then the linksets.include 
file is located at /opt/CSCOsgm/reports/etc/linksets.include.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the 
/reports/etc/linksets.include file is located in that directory.

• Each line in the linksets.include file must contain a single linkset name that 
matches exactly the real, fully qualified linkset name of the linkset, including 
the node name and signaling point name. For example:

sgm-75-59a.cisco.com;net0:linkset2

sgm-26-51a.cisco.com;net1:linkset1

• Wildcard matching is not supported.

• If a linkset appears in both the linksets.include file and the linksets.exclude 
file, it is excluded. That is, excluding a linkset overrides including the same 
linkset.

• If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.include file.

Excluding Specific Nodes from Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to exclude one or more specific nodes or signaling points from 
the report.

To generate a report that excludes the nodes and signaling points listed in the 
user-defined nodes.exclude file, create the file, then specify default in place of the 
node-list argument in the sgm accstats or sgm linkstats command.

For example, the following command generates an accounting statistics report 
that excludes the nodes and signaling points specified in the nodes.exclude file:

./sgm accstats default
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Keep in mind the following considerations:

• If you installed SGM in the default directory, /opt, then thenodes.exclude file 
is located at /opt/CSCOsgm/reports/etc/nodes.exclude.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the/reports/etc/nodes.exclude 
file is located in that directory.

• Each line in the nodes.exclude file must contain a single node name, or node 
name and signaling point name, that matches exactly the real, fully qualified 
node name of the node, and each line must end with a colon (:). For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

To exclude a specific signaling point, specify the node name and signaling 
point:

sgm-75-59a.cisco.com;net0:

sgm-26-51a.cisco.com;net1:

• Wildcard matching is not supported.

• If a node or signaling point appears in both the nodes.include file and the 
nodes.exclude file, it is excluded. That is, excluding a node or signaling point 
overrides including the same node or signaling point.

• If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.exclude file.

Excluding Specific Linksets from Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to exclude one or more specific linksets from the report.

To generate a report that excludes the linksets listed in the user-defined 
linksets.exclude file, create the file, then specify default in place of the node-list 
argument in the sgm accstats or sgm linkstats command.
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For example, the following command generates an accounting statistics report 
that excludes the linksets specified in the linksets.exclude file:

./sgm accstats default

Keep in mind the following considerations:

• If you installed SGM in the default directory, /opt, then the linksets.exclude 
file is located at /opt/CSCOsgm/reports/etc/linksets.exclude.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the 
/reports/etc/linksets.exclude file is located in that directory.

• Each line in the linksets.exclude file must contain a single linkset name that 
matches exactly the real, fully qualified linkset name of the linkset, including 
the node name and signaling point name. For example:

sgm-75-59a.cisco.com;net0:linkset2

sgm-26-51a.cisco.com;net1:linkset1

• Wildcard matching is not supported.

• If a linkset appears in both the linksets.include file and the linksets.exclude 
file, it is excluded. That is, excluding a linkset overrides including the same 
linkset.

• If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.exclude file.

Viewing the Custom Network Statistics Export Files

The Custom Network Statistics Export Files page displays all archived SGM 
custom network and accounting statistics reports for the server to which you are 
connected, stored as downloadable Zip files. Custom statistics reports are those 
that are generated using the sgm accstats and sgm linkstats commands.

To access the Custom Network Statistics Export Files page, select Custom 
Export from the menu bar of any SGM Network Statistics or Accounting 
Statistics Web page.
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The Custom Network Statistics Export Files page displays the following 
information:

• Export File—Name of the custom statistics export ZIP file, archived by type 
(linkset or link), date, and hour. For example, 
sgmLinksetStats.custom.20867.2002-10-15-16.csv.zip is the Zip file that 
contains the custom linkset statistics summary report with ID tag 20867 for 
the 16th hour on October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with 
a daily statistics report for that date. You can download the Zip files and unzip 
them.

To download a Zip file, click a filename, then save the file to a location of 
your choice.

See the “SGM Custom Network Statistics Export File Formats” section on 
page F-2 for detailed information about the format of custom statistics export 
files.

• ID Tag—Identifier for the custom report, specified when you entered the 
sgm accstats or sgm linkstats command. If you did not specify an ID tag, 
this field displays the process ID of the command that generated the report.

• Start—Date and time the custom report began.

• Finish—Date and time the custom report ended.

• View—Enables you to view the custom report in HTML or ASCII.

For more information about viewing custom reports, see the following 
sections:

– Viewing a Custom Accounting Statistics Report, page 3-380

– Viewing a Custom Link Statistics Summary Report, page 3-383

– Viewing a Custom Linkset Statistics Summary Report, page 3-387

Viewing a Custom Accounting Statistics Report

The Accounting Statistics: Custom Detail Report page displays a custom 
summary of accounting statistics for SGM. Accounting statistics are displayed 
based on the node, signaling point, linkset, originating point code (OPC), the 
destination point code (DPC), the type of SS7 traffic (such as ISUP or SCCP), and 
whether the traffic passed or failed the Gateway Screening test at the ITP.
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To access the Accounting Statistics: Custom Detail Report page, click HTML in 
the View column beside a custom accounting statistics report on the Custom 
Network Statistics Export Files page. SGM displays the custom accounting 
statistics report.

The Accounting Statistics: Custom Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly accounting 
statistics report.

To see the entire detailed report, click the ID. SGM displays the Accounting 
Data Record # X for Date for that date and hour, in text format. The 
Accounting Data Record # X for Date can be useful when the TAC is 
debugging problems.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Inst Name—Name of instance for the linkset.

• Sig Point—Name of signaling point for the linkset. To see statistics for only 
a selected signaling point, click the signaling point.

• Linkset—Name of the linkset. To see statistics for only a selected linkset, 
click the linkset name.

• Gateway Screening—Indicates whether the traffic passed or failed the 
Gateway Screening test at the ITP. To see only statistics that passed or failed 
for a specific linkset, select a linkset and click Pass or Fail.

• OPC—Originating point code of the traffic, which is a unique identifier for 
each set of statistics. To see only statistics that match a specific OPC for a 
given linkset, find the linkset and click the point code.

• DPC—Destination point code of the traffic. To see only statistics that match 
a specific DPC for a given linkset, find the linkset and click the point code.

• SI—Service indicator, which indicates the type of SS7 traffic, such as ISUP 
or SCCP. To see only detailed information for a specific type of SI, click the 
SI type.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date.
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• Recv MSUs—Total number of MTP3 MSUs received on the specified date.

• Send Bytes—Total number of bytes sent on the specified date.

• Recv Bytes—Total number of bytes received on the specified date.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Accounting 
Statistics: Custom Detail Report page:

• You can sort the Accounting Statistics: Custom Detail Report page based on 
the information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-279 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing a Custom Link Statistics Summary Report

SGM enables you to view custom link statistics summary reports.

To view a custom link statistics summary report, click HTML in the View column 
beside a custom link statistics summary report on the Custom Network Statistics 
Export Files page. SGM displays the custom link statistics summary report, which 
is a custom summary of statistics for all links known to SGM when the report was 
generated.
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The Link Statistics: Custom Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly link statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Link Data 
Record page for that link, date, and hour, in text format. The Link Data 
Record can be useful when the TAC is debugging problems.

• Hour—Hour for which the link statistics summary report was created, for the 
specified date.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Inst Name—Name of instance for the link.

• Sig Point—Name of signaling point for the link. To see statistics for only a 
selected signaling point, click the signaling point.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTP—The link uses the Stream Control Transmission Protocol (SCTP) 
IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

– Virtual—The link is a virtual link, which connects signaling point 
instances running on the same device. SGM does not poll virtual links, 
nor does it display real-time data or accounting statistics for virtual links.

• Send Util or Send Erls—Average Send Utilization for the link, expressed as 
either a utilization percentage or a number of Erlangs (as set in the 
Preferences window), for the specified date and hour.

If the planned send capacity is not set for the link, this field displays NoCap.
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• L Term Send Util or L Term Send Erls—Long-term average Send 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), since SGM polling 
began for the link, or since SGM last reset the averages as a result of bad data.

If the planned send capacity is not set for the link, this field displays NoCap.

• Recv Util or Recv Erls—Average Receive Utilization for the link, expressed 
as either a utilization percentage or a number of Erlangs (as set in the 
Preferences window), for the specified date and hour.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• L Term Recv Util or L Term Recv Erls—Long-term average Receive 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs (as set in the Preferences window), since SGM polling 
began for the link, or since SGM last reset the averages as a result of bad data.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date and 
hour.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date 
and hour.

• Drop—Total number of drops on the specified date and hour.

• Hourly InSrv—Percentage of time the link was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the link was in service since 
SGM polling began for the link, or since SGM last reset the averages as a 
result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Link 
Statistics: Custom Detail Report page:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-279 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.

• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.

Viewing a Custom Linkset Statistics Summary Report

SGM enables you to view custom linkset statistics summary reports.

To view a custom linkset statistics summary report, click HTML in the View 
column beside a custom linkset statistics summary report on the Custom Network 
Statistics Export Files page. SGM displays the custom linkset statistics summary 
report, which is a custom summary of statistics for all linksets known to SGM 
when the report was generated.
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The Linkset Statistics: Custom Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly linkset statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Linkset Data 
Record page for that linkset, date, and hour, in text format. The Linkset Data 
Record can be useful when the TAC is debugging problems.

• Hour—Hour for which the link statistics summary report was created, for the 
specified date.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Inst Name—Name of instance for the linkset.

• Sig Point—Name of signaling point for the linkset. To see statistics for only 
a selected signaling point, click the signaling point.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.

• Hourly InSrv—Percentage of time the linkset was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the linkset was in service 
since SGM polling began for the linkset, or since SGM last reset the averages 
as a result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Linkset 
Statistics: Custom Detail Report page:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-279 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing SGM Point Code Inventory Reports
SGM enables you to view current and daily point code inventory reports. You can 
also export the reports.

SGM enables you to view the following point code inventory reports:

• Viewing the Current Point Code Inventory, page 3-391

• Viewing the Daily Point Code Inventory Daily Reports, page 3-392

• Viewing the Daily Point Code Inventory Export Files, page 3-394
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Viewing the Current Point Code Inventory

The Current Point Code Inventory page displays all point codes that are currently 
being used by all nodes that are known to SGM.

To access the Current Point Code Inventory page, use one of the following 
procedures:

• Select View > Reports > Point Code Inventory from the SGM Main Menu.

• Select Point Code Inventory Reports from the SGM Server Home Page.

• Select Current Point Codes from the menu bar of any SGM Point Code 
Inventory Web page.

SGM displays the Current Point Code Inventory page (Figure 3-91).

Figure 3-91 Current Point Code Inventory Page
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The Current Point Code Inventory page displays the following information:

• Number and Sort Order (in header)—Displays the number of point codes 
in the table, the column by which the table is sorted, and whether the sort is 
in ascending or descending order.

• Signaling Point—Signaling point that is currently being used by a node.

To sort the point codes by signaling point in descending order, click the 
Signaling Points header.

Click again to sort the point codes in ascending order.

• Point Code—Point code that is currently being used by a node.

To sort the point codes by point code in ascending order, click the Point 
Codes header. This is the default display.

Click again to sort the point codes in descending order.

• Node Name—Name or IP address of the node.

To see detailed information for the node, click the node name.

To sort the point codes by node in descending order, click the Node Name 
header.

Click again to sort the point codes in ascending order.

• Point Code Type—Type of point code:

– Primary—Main point code used by a node.

– Secondary—Alternate or backup point code used by a node.

– Capability—Shared by more than one node, each of which is also 
assigned a “real” point code. Also called an alias point code.

To sort the point codes by type in ascending order, click the Point Code Type 
header.

Click again to sort the point codes in descending order.

Viewing the Daily Point Code Inventory Daily Reports

The Point Code Inventory: Daily Reports page displays all archived SGM daily 
point code inventory reports for the server to which you are connected.

To access the Point Code Inventory: Daily Reports page, select Daily Point Codes 
from the menu bar of any SGM Point Code Inventory Web page.
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On the Point Code Inventory: Daily Reports page, point code inventory reports are 
archived by date. Each archived file contains a list of all point codes that were 
being used by all nodes that were known to SGM on that date.

To view an archived point code inventory report, click a date. SGM displays the 
Point Code Inventory: Date page, which displays the archived list of point codes 
for that date, including the following information:

• Number and Sort Order (in header)—Displays the number of point codes 
in the table, the column by which the table is sorted, and whether the sort is 
in ascending or descending order.

• Signaling Point Name—Name of the signaling point.

To sort the point codes by signaling point in descending order, click the 
Signaling Point Name header.

Click again to sort the point codes in ascending order.

• Point Code—Point code that was being used by a node on the specified date.

To sort the point codes by point code in ascending order, click the Point 
Codes header. This is the default display.

Click again to sort the point codes in descending order.

• Node Name—Name or IP address of the node.

To see detailed information for the node, click the node name.

To sort the point codes by node in descending order, click the Node Name 
header.

Click again to sort the point codes in ascending order.

• Point Code Type—Type of point code:

– Primary—Main point code used by a node.

– Secondary—Alternate or backup point code used by a node.

– Capability—Shared by more than one node, each of which is also 
assigned a “real” point code. Also called an alias point code.

To sort the point codes by type in ascending order, click the Point Code Type 
header.

Click again to sort the point codes in descending order.
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Viewing the Daily Point Code Inventory Export Files

The Daily Point Code Inventory Export Files page displays all archived SGM 
daily point code inventory reports for the server to which you are connected, 
stored as downloadable Zip files.

To access the Daily Point Code Inventory Export Files page, select Daily Point 
Code Export from the menu bar of any SGM Point Code Inventory Web page.

On the Daily Point Code Inventory Export Files page, the Zip files are archived 
by date. For example, sgmPointCodes.DailyInv.2002-10-15.csv.zip is the Zip 
file that contains the daily point code inventory report for October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with a 
list of all point codes that were being used by all nodes that were known to SGM 
on that date. You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Point Code Inventory Export File Format” section on page F-7 for 
detailed information about the format of point code inventory export files.

Viewing SGM Statistics Reports Logs
SGM enables you to view a log that contains all messages pertaining to SGM 
reports, and a display of the current values of SGM report parameters and timers.

This section contains the following information:

• Viewing the SGM System Reports Log, page 3-394

• Viewing the SGM System Report Parameters and Timers, page 3-395

Viewing the SGM System Reports Log

The SGM System Reports Log: Last X Messages page displays the message log 
for SGM reports for the server to which you are connected, and which is currently 
running the SGM server.
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To access the SGM System Reports Log: Last X Messages page, use one of the 
following procedures:

• Select System Report Log from the SGM Server Home Page.

• Select Log from the menu bar of any SGM Network Statistics or Accounting 
Statistics Web page.

• Enter the sgm replog command. See the “SGM Commands and Descriptions” 
section on page B-2 for more information on the use of this command.

The SGM System Reports Log: Last X Messages page displays the following 
information:

• Last Update (in header)—Date and time the information on the page was 
last updated by SGM.

• Row—Message number, assigned to the message by SGM.

• Time—Date and time the message was logged.

• Type—Type of message. Possible types are:

– Error

– Info

• Message—Text of the message.

Viewing the SGM System Report Parameters and Timers

The SGM System Report Parameters and Timers page displays the current values 
of report parameters and timers for the server to which you are connected, and 
which is currently running the SGM server.

To access the SGM System Report Parameters and Timers page, select System 
Report Parameters from the SGM Server Home Page, or select Params from the 
menu bar of any SGM Network Statistics or Accounting Statistics Web page.
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The SGM System Report Parameters and Timers page displays the following 
information:

• Server Name (in header)—Name of the SGM server for which report 
parameter and timer settings are being displayed.

• Report Dir—Path and name of the directory in which SGM stores reports. 
The default reports directory is /opt/CSCOsgm/reports, but you can change 
the reports directory using the sgm repdir command. For more information, 
see the description of the sgm repdir command in the “SGM Commands and 
Descriptions” section on page B-2.

• Status—Indicates whether SGM is to generate network statistics reports. For 
more information, see the description of the sgm statreps [disable | enable] 
command in the “SGM Commands and Descriptions” section on page B-2.

• ExportReports—Indicates whether SGM is to generate network statistics 
reports in export format. For more information, see the description of the sgm 
statreps [export | noexport] command in the “SGM Commands and 
Descriptions” section on page B-2.

• AcctReports—Indicates whether SGM is to generate accounting statistics 
reports. For more information, see the description of the sgm statreps 
[acct | noacct] command in the “SGM Commands and Descriptions” section 
on page B-2.

• IPLinks—Indicates whether SGM is to include links that use the Stream 
Control Transmission Protocol (SCTP) IP transport protocol in network 
statistics reports. For more information, see the description of the sgm 
statreps [iplinks | noiplinks] command in the “SGM Commands and 
Descriptions” section on page B-2.

• NullCaps—Indicates whether SGM is to include links that do not have 
planned send and receive capacities in network statistics reports. For more 
information, see the description of the sgm statreps [nullcaps | nonullcaps] 
command in the “SGM Commands and Descriptions” section on page B-2.

• TimeMode—Indicates the time mode for dates in network statistics reports. 
For more information, see the description of the sgm statreps timemode 
[12 | 24] command in the “SGM Commands and Descriptions” section on 
page B-2.
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• DiskCheck—Indicates whether SGM is to verify that a disk has at least 
10 MB of space remaining before generating network statistics reports. For 
more information, see the description of the sgm statreps 
[diskcheck | nodiskcheck] command in the “SGM Commands and 
Descriptions” section on page B-2.

• UtilRatio—Indicates whether SGM is to display a gray background in the 
Send Utilization or Receive Utilization cell in a network statistics report, if 
the following condition is met:

Current Utilization > factor * Long-Term Utilization

For more information, see the description of the sgm statreps utilratio 
command in the “SGM Commands and Descriptions” section on page B-2.

• ServRatio—Indicates whether SGM is to display a gray background in the 
InSrv cell in a network statistics report, if the following condition is met:

Current In-Service < factor * Long-Term In-Service

For more information, see the description of the sgm statreps 
[disable | enable] command in the “SGM Commands and Descriptions” 
section on page B-2.

• HourlyAge—Indicates the maximum number of days SGM is to archive 
hourly network statistics reports. For more information, see the description of 
the sgm statreps hourlyage and sgm rephourlyage commands in the “SGM 
Commands and Descriptions” section on page B-2.

• DailyAge—Indicates the maximum number of days SGM is to archive daily 
network statistics reports. For more information, see the description of the 
sgm statreps dailyage and sgm repdailyage commands in the “SGM 
Commands and Descriptions” section on page B-2.

• CustomAge—Indicates the maximum number of days SGM is to archive 
custom network statistics reports. For more information, see the description 
of the sgm repcustage command in the “SGM Commands and Descriptions” 
section on page B-2.

• WebNames—Indicates whether SGM is to show real node names or display 
names in Web pages. For more information, see the description of the sgm 
webnames [display | real] command in the “SGM Commands and 
Descriptions” section on page B-2.
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• WebUtil—Indicates whether SGM is to display send and receive utilization 
for linksets and links as percentages or in Erlangs, in Web pages. For more 
information, see the description of the sgm webutil [percent | erlangs] 
command in the “SGM Commands and Descriptions” section on page B-2.

• Timer file for last report run—Indicates timer activities during the last 
report run by SGM. The timer file is useful for identifying how much time 
SGM spends gathering report data and generating reports.

Printing SGM Windows
You can print most SGM windows, as well as the topology map, for those times 
when you need hardcopy.

To print an SGM window, use one of the following procedures:

• From most SGM windows, select File > Print from the SGM Main Menu.

• From the Topology Window, select File > Print > All from the SGM Main 
Menu, if you want to print the map of your entire network, not just the part 
that is visible in the current topology map view.

• From the Topology Window, select File > Print > Display from the SGM 
Main Menu, if you want to print just the part of your network that is visible 
in the current topology map, not the map of your entire network.

SGM displays the Print dialog (Figure 3-92).
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Figure 3-92 Print Dialog

The Print dialog enables you to specify print settings, such as which printer to 
print to, whether to send output to a file (the default location for the print file is 
your home directory), and whether to print duplex.

When you are satisfied with your print settings, click Print. SGM prints the map.

To exit the Print dialog at any time without printing, click Cancel.

Connecting to a New Server
SGM enables you to connect the client to a new SGM server. For example, you 
can monitor two or more networks from the same SGM client, simply by 
switching servers. Or, if you have two SGM servers monitoring the same network, 
and one server fails, the SGM client automatically switches to the secondary 
server.
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To connect the client to a new server:

Step 1 (Optional) If you want to determine the default host name before you connect to 
the new server, it is contained in the SERVER_NAME entry in the 
System.properties file:

• If you installed SGM in the default directory, /opt, then the location of the 
System.properties file is /opt/CSCOsgm/properties/System.properties.

• If you installed SGM in a different directory, then the System.properties file 
is located in that directory.

Step 2 Select File > Connect to New Server from the SGM Main Menu. SGM displays 
the Connect to New Server Dialog (Figure 3-93).

Figure 3-93 Connect to New Server Dialog

Step 3 Enter the name of the new server, or its IP address, in the Server Name or IP 
Address field.

Step 4 Enter the SGM Naming Server UDP port number for the new server in the Name 
Server Port field. The default value is 44742.

Step 5 Click OK. SGM stops the SGM client, then restarts the client connected to the 
new server.
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Integrating SGM with Other Products
SGM does not require either CiscoWorks2000 or HP OpenView, but SGM does 
integrate with those products to provide added value. See the following sections 
for more information:

• Integrating SGM with HP OpenView, page 3-401

• Integrating SGM with CiscoWorks2000, page 3-402

Integrating SGM with HP OpenView
SGM can integrate with HP OpenView during installation, registering to receive 
forwarded traps. See the “Installing SGM on Solaris” chapter of the Cisco 
Signaling Gateway Manager Installation Guide for more information.

You can also integrate SGM with HP OpenView after installation, using the 
sgm trapsetup command. See the “SGM Command Reference” section on 
page B-1 for more information.

If you select HP OpenView as the source of traps in SGM, keep the following 
considerations in mind:

• If HP OpenView is not running when you start the SGM servers, SGM’s 
sgmTrapReceiver process cannot start and is labeled Stopped.

• If HP OpenView is running when you start the SGM servers, but ovtrapd (HP 
OpenView’s trap receiver process) is not running, sgmTrapReceiver starts and 
is reported as Running, but it cannot receive traps.

• If you start the SGM servers, then start HP OpenView, sgmTrapReceiver does 
not start automatically. You must start sgmTrapReceiver using the Process 
Manager.

• If sgmTrapReceiver is running and HP OpenView is stopped using the ovstop 
command, sgmTrapReceiver stops itself, and does not start automatically 
when HP OpenView is restarted. You must start sgmTrapReceiver using the 
Process Manager.

• If sgmTrapReceiver is running and ovtrapd stops running for any reason, 
sgmTrapReceiver cannot detect that ovtrapd is no longer running. 
sgmTrapReceiver continues running but cannot receive traps until ovtrapd is 
restarted. When ovtrapd is restarted, sgmTrapReceiver begins receiving traps 
again automatically.
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Integrating SGM with CiscoWorks2000
SGM can integrate with CiscoWorks2000 during installation, registering with 
CiscoWorks2000 as an installed application. See the “Installing SGM on Solaris” 
and “Installing SGM on Windows” chapters of the Cisco Signaling Gateway 
Manager Installation Guide for more information.

You can also integrate SGM with CiscoWorks2000 after installation, using the 
sgm cw2ksetup command. See the “SGM Command Reference” section on 
page B-1 for more information.

When SGM is integrated with CiscoWorks2000, you can launch the 
CiscoWorks2000 Device Center and CiscoView from the SGM Main Menu. See 
the following sections for more information:

• Launching the CiscoWorks2000 Device Center, page 3-402

• Launching CiscoView, page 3-403

Launching the CiscoWorks2000 Device Center

The CiscoWorks2000 Device Center provides a number of useful Web-based 
device-monitoring functions, including reachability trends, response time trends, 
interface status, Syslog browsing, and a detailed inventory.

To link SGM to the Device Center:

Step 1 Make sure CiscoWorks2000 is installed in the network.

Step 2 Select a node that you know CiscoWorks2000 is monitoring, or an associated 
linkset, in a window. If you select a non-ITP node, or a node with a status of 
Unmanaged or a Device Type of Unknown, the CiscoWorks2000 menu option 
is grayed-out.

Step 3 Select Products > CiscoWorks2000 > Device Center from the SGM Main Menu.

Step 4 At the prompt, enter a CiscoWorks2000 user ID and password. SGM links to 
CiscoWorks2000 Device Center dashboard.
3-402
Cisco Signaling Gateway Manager User Guide

78-15589-01



 

Chapter 3 Managing ITP Networks Using SGM
Using the Windows Start Menu
Launching CiscoView

CiscoView provides a real-time, color-coded, graphical representation of Cisco 
ITPs. You can use CiscoView to quickly identify an incorrect status on a port or 
interface. If you are running CiscoWorks2000 on UNIX or Windows, you can 
access CiscoView through the link to the Web version of CiscoWorks2000.

To link SGM to CiscoView:

Step 1 Select a node that you know CiscoWorks2000 is monitoring, or an associated 
linkset, in a window. If you select a non-ITP node, or a node with a status of 
Unmanaged or a Device Type of Unknown, the CiscoWorks2000 menu option 
is grayed-out.

Step 2 Select Products > CiscoWorks2000 >CiscoView from the SGM Main Menu.

Step 3 At the prompt, enter a CiscoWorks2000 user ID and password. SGM links to 
CiscoView.

Using the Windows Start Menu
This section includes the following information:

• Launching the SGM Client, page 3-404

• Launching the SGM GTT Client, page 3-404

• Changing the Default SGM Server Name, page 3-404

• Changing the Default SGM Telnet Path, page 3-405

• Launching the SGM DOS Prompt, page 3-405

• Launching the SGM SSL Certificate Tool, page 3-406

• Uninstalling SGM, page 3-406

• Viewing the SGM README File, page 3-406
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Launching the SGM Client
To launch the SGM Client, use one of the following procedures:

• Double-click the SGM icon on the desktop.

• Select Start > Programs > Cisco SGM Client > Launch SGM Client from 
the Windows Start menu.

SGM launches the SGM Client.

Launching the SGM GTT Client
To launch the SGM GTT Client, select Start > Programs > Cisco SGM Client > 
Launch SGM GTT Client from the Windows Start menu.

SGM launches the SGM GTT Client.

Changing the Default SGM Server Name
If there is a failure of the IP address or host name to which your SGM client is 
bound, you can change the default SGM server name from the Windows Start 
menu.

To change the default SGM server name, use the following procedure:

Step 1 Close all open SGM windows.

Step 2 Select Start > Programs > Cisco SGM Client > Modify Default SGM Server  
Name. SGM opens a DOS window, and asks you to enter the name of the new 
default SGM server.

Step 3 Type the name of the new default SGM server, and press Enter. SGM sets the 
default server to the new name you entered.

See the “Connecting to a New Server” section on page 3-399 for more 
information about changing the default SGM server name.
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Changing the Default SGM Telnet Path
SGM provides a default Telnet interface for Telnet sessions, but you can also 
specify a path to a different Telnet application, if you prefer.

To specify the path to the new Telnet application, use the following procedure:

Step 1 Select Start > Programs > Cisco SGM Client > Modify Default SGM Telnet  
Path. SGM opens a DOS window, and asks you to enter the full Telnet executable 
pathname.

Step 2 Type the new pathname, and press Enter. If you do not enter a new pathname, 
SGM uses the system default Telnet executable. SGM asks you to enter any 
special parameters you want to pass to the new Telnet application. The default is 
n, for no special parameters.

Step 3 Type the special parameters you want to pass to the new Telnet application, and 
press Enter. SGM uses the new Telnet application for all Telnet sessions on the 
SGM client, such as when you select View > Telnet to > ITP.

Step 4 Close the DOS window.

Launching the SGM DOS Prompt
To launch a DOS prompt for SGM from the Windows Start menu, select Start > 
Programs > Cisco SGM Client > SGM DOS Prompt. SGM opens a DOS 
window, starting in the bin directory:

• If you installed the SGM client in the default directory, C:\Program Files, 
then the DOS prompt starts at C:\Program Files\SGMClient\bin.

• If you installed the SGM client in a different directory, then the bin directory 
is located in that directory.
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Launching the SGM SSL Certificate Tool
To launch the SGM SSL Certificate Tool from the Windows Start menu, select 
Start > Programs > Cisco SGM Client > SGM SSL Certificate Tool.

Uninstalling SGM
You can uninstall SGM from the Windows Start menu. For details, see the 
“Uninstalling SGM” section of the Cisco Signaling Gateway Manager 
Installation Guide.

Viewing the SGM README File
The SGM README file contains late-breaking information about SGM that 
might not be found in the other product documentation. To open the SGM 
README file from the Windows Start menu, select Start > Programs > 
Cisco SGM Client > View README.
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