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Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evid
by receipts or other documentation. National Instruments will, at its option, repair or replace software media that 
execute programming instructions if National Instruments receives notice of such defects during the warranty pe
National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outs
of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping
of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this manual is accurate. The document has been carefully re
for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the 
make changes to subsequent editions of this document without prior notice to holders of this edition. The reader
consult National Instruments if errors are suspected. In no event shall National Instruments be liable for any dam
arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS 
ANY WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’ S RIGHT TO RECOVER DAMAGES CAUSED 
BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL  INSTRUMENTS SHALL BE LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE 
CUSTOMER. NATIONAL  INSTRUMENTS WILL  NOT BE LIABLE  FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, 
OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of 
National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence.
Any action against National Instruments must be brought within one year after the cause of action accrues. Natio
Instruments shall not be liable for any delay in performance due to causes beyond its reasonable control. The wa
provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to 
the National Instruments installation, operation, or maintenance instructions; owner’s modification of the product;
owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third partie
or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mecha
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, wit
the prior written consent of National Instruments Corporation.

Trademarks
CVI™, IMAQ™, LabVIEW™, and NI-IMAQ™ are trademarks of National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

WARNING REGARDING MEDICAL AND CLINICAL USE OF NATIONAL INSTRUMENTS PRODUCTS
National Instruments products are not designed with components and testing intended to ensure a level of reliab
suitable for use in treatment and diagnosis of humans. Applications of National Instruments products involving m
or clinical treatment can create a potential for accidental injury caused by product failure, or by errors on the part
user or application designer. Any use or application of National Instruments products for or involving medical or cl
treatment must be performed by properly trained and qualified medical personnel, and all traditional medical safeg
equipment, and procedures that are appropriate in the particular situation to prevent serious injury or death should
continue to be used when National Instruments products are being used. National Instruments products are NOT i
to be a substitute for any form of established process, procedure, or equipment used to monitor or safeguard huma
and safety in medical or clinical treatment.
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IMAQ Vision Builder is a tool that you can use to prototype and test ima
processing applications. The IMAQ Vision Builder Tutorial contains 
information you need to install and run IMAQ Vision Builder and begin
building imaging applications.

This manual is designed to teach you the fundamental features of IMA
Vision Builder through interactive discussion and examples. To get the
most out of this manual, read it at your computer so you can test the 
concepts and perform the example tutorials in IMAQ Vision Builder.

Organization of This Manual
The IMAQ Vision Builder Tutorial is organized as follows:

• Chapter 1, System Requirements and Installation, lists system 
requirements and installation instructions and introduces the IMAQ
Vision Builder environment.

• Chapter 2, Introduction to Image Processing with IMAQ Vision 
Builder, describes how you can use IMAQ Vision Builder to create
and test your own image processing algorithms. It explains what ty
of images that IMAQ Vision Builder can load and process and how
get started in IMAQ Vision Builder.

• Chapter 3, Analyzing the Structure of a Metal Using Blob Analysis, 
describes blob analysis and provides step-by-step directions for 
completing a blob analysis tutorial in IMAQ Vision Builder.

• Chapter 4, Using Gauging for Part Inspection, describes gauging and
provides step-by-step directions for completing a part inspection 
tutorial in IMAQ Vision Builder.

• Appendix A, Customer Communication, contains forms you can use to
request help from National Instruments or to comment on our produ
and manuals.

• The Glossary contains an alphabetical list and description of terms
used in this manual, including abbreviations, acronyms, metric 
prefixes, mnemonics, and symbols. 

• The Index contains an alphabetical list of key terms and topics in th
manual, including the page where you can find each one.
© National Instruments Corporation ix IMAQ Vision Builder Tutorial
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Conventions Used in This Manual
The following conventions are used in this manual:

<> Angle brackets enclose the name of a key on the keyboard—for exam
<Enter>.

» The » symbol leads you through nested menu items and dialog box opt
to a final action. The sequence Binary»Threshold directs you to pull down 
the Binary  menu and select the Threshold item.

This icon to the left of bold italicized text denotes a note, which alerts y
to important information.

bold Bold text denotes tooltips and the names of menus, menu items, 
parameters, and dialog box buttons or options.

bold italic Bold italic text denotes a note and tip.

italic Italic text denotes emphasis, a cross reference, or an introduction to a
concept. This font also denotes text from which you supply the appropr
word or value, as in Windows 3.x.

monospace Text in this font denotes text or characters that you should literally ent
from the keyboard. This font is also used for the proper names of disk
drives, paths, directories, programs, filenames and extensions.

paths Paths in this manual are denoted using backslashes (\) to separate d
names, directories, folders, and files.

Related Documentation
The following documents contain information you might helpful as you
read this manual and perform the tutorials:

• IMAQ Vision Builder online help, which you can access from the 
IMAQ Vision Builder Help menu.

• Image Processing Manual in PDF format, which you can access from
the Windows Start menu (Start»Programs»National Instruments 
IMAQ Vision Builder ). This manual contains conceptual informatio
about imaging.
IMAQ Vision Builder Tutorial x © National Instruments Corporation
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If you have purchased IMAQ Vision software from National Instrument
you have at least one of the following manuals, depending on which 
development environment you use. These manuals provide basic 
information about image processing and the IMAQ Vision functions.

• IMAQ Vision for G Reference Manual

• IMAQ Vision for LabWindows/CVI

• Getting Results with ComponentWorks IMAQ Vision

Customer Communication
National Instruments wants to receive your comments on our products
and manuals. We are interested in the applications you develop with o
products, and we want to help if you have problems with them. To mak
easy for you to contact us, this manual contains comment and configura
forms for you to complete. These forms are in Appendix A, Customer 
Communication, at the end of this manual.
© National Instruments Corporation xi IMAQ Vision Builder Tutorial



© National Instruments Corporation 1-1 IMAQ Visio
1

d 

r 

it) 

 

System Requirements 
and Installation

This chapter lists system requirements and installation instructions an
introduces the IMAQ Vision Builder environment.

System Requirements
To run IMAQ Vision Builder, your computer must meet the following 
minimum requirements:

• Personal computer using at least a 133 MHz Pentium or higher 
microprocessor (233 MHz Pentium MMX or higher microprocesso
recommended)

• Microsoft Windows 95/98 or Windows NT version 4.0

• 800 × 600 resolution (or higher) video adapter, 65536 colors (16 b
or higher.

• National Instruments IMAQ hardware and NI-IMAQ 2.0 or later for
Windows 95/98 or Windows NT (if you are acquiring images with 
National Instruments IMAQ hardware)

• Minimum of 32 MB RAM (64 MB recommended)

• Minimum of 30 MB of free hard disk space

Note You need Excel 97 installed on your computer to complete a few steps in the 
second tutorial.
n Builder Tutorial
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Installing IMAQ Vision Builder

Note To install IMAQ Vision Builder on a Windows NT system, you must be logged i
with Administrator privileges.

1. Insert the IMAQ Vision Builder CD into your computer.

If the CD startup screen does not appear, use the Windows Explor
run the SETUP.EXE program in the \Setup  directory on the CD.

2. Follow the setup instructions you see on your screen.

By default, the IMAQ Vision Builder installation program creates a new
folder, \Program  Files\National  Instruments\IMAQ  Vision  
Builder\ , that contains the following items:

• Program folder—IMAQ Vision Builder.exe , the online help file, 
function libraries, and other related program files

• Readme.txt—Late-breaking information about IMAQ Vision Builde
known limitations, and bugs

• Examples folder—Images and scripts that you need to complete t
example tutorials in this manual

• Manuals folder—PDF versions of the Image Processing Manual and 
this manual

Launching and Exiting IMAQ Vision Builder
To launch IMAQ Vision Builder in Windows, point to 
Start»Programs»National Instruments IMAQ Vision Builder» 
IMAQ Vision Builder .

To quit IMAQ Vision Builder, follow these steps:

1. Close open parameter windows.

2. Save your script and images, if you want to keep them.

3. Select File»Exit.
IMAQ Vision Builder Tutorial 1-2 © National Instruments Corporation
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IMAQ Vision Builder Environment
IMAQ Vision Builder is a tool that you can use to prototype and test ima
processing applications. To prototype your image processing applicat
you build custom algorithms with the IMAQ Vision Builder scripting 
feature. The scripting feature records every step of your processing 
algorithm. After completing the algorithm, you can test it on other imag
to make sure it works.

The algorithm is recorded in a Builder file. Builder files are ASCII text files 
that list the processing functions and relevant parameters for an algor
that you create in IMAQ Vision Builder. You can implement the algorith
defined by the Builder file in any development environment, such as 
LabVIEW, LabWindows/CVI, or Visual Basic using the IMAQ Vision 
machine vision and image processing library. Refer to Implementing the 
Algorithm in LabVIEW in Chapter 3, Analyzing the Structure of a Metal 
Using Blob Analysis, for an example of a Builder file and its LabVIEW 
implementation.

Features
IMAQ Vision Builder offers the following features:

• Script window—Records a series of image processing steps and 
settings you use for each of those steps. You can run scripts on si
images or image collections (batch processing). You can modify a
save scripts.

• Image Browser—Contains all of the images currently loaded in IMA
Vision Builder. Through the Image Browser, you can select an ima
that you want to process by double clicking on it.

• Acquisition window—Displays the Interface window (IMAQ 
hardware and channels available) and the property pages for the IM
hardware device.

• Processing window—Updates the image as you change paramete
Because this view immediately reflects the changes you have mad
the parameters window, you can continue modifying parameters u
you get the desired result.

• Parameter window—Displays parameters that you can set for an im
processing function. Each IMAQ Vision function available through th
menus has a parameter window where you set the parameters for
function. 
© National Instruments Corporation 1-3 IMAQ Vision Builder Tutorial
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• Reference window—Displays the original version of the image (ima
source) as you manipulate it in the processing window.

• Tools Palette—Displays a collection of tools for selecting regions o
interest (ROI), zooming in and out, and changing the image palett

Image Analysis Functions
IMAQ Vision Builder also offers several image analysis functions, 
including the following:

• Histogram—Counts the total number of pixels in each grayscale va
and graphs it.

• Line Profile—Returns the grayscale values of the pixels along a lin
that you draw with the line tool from the Tools palette and graphs 

• Particle Analysis—Computes more than 40 measurements on obj
in an image, including the perimeter and area of holes in an objec
the image.

• 3D View—Displays an image using an isometric view. Each pixel 
from the image source is represented as a column of pixels in the
3D view. The pixel value corresponds to the altitude.

Image Processing Functions
IMAQ Vision Builder includes a comprehensive set of functions for ima
processing, including the following:

• Filtering—Functions for smoothing, edge detection, and convolutio

• Morphology—Functions to modify the shape of objects in an imag
including erosion, dilation, opening, and closing.

• Thresholding—Functions that enable you to select ranges of pixel
values in grayscale and color images.

• Particle Filtering—Functions to filter objects based on shape 
measurements.

Machine Vision Functions
IMAQ Vision Builder also offers several machine vision functions, 
including the following:

• Edge Detection—Finds edges along a line that you draw with the l
tool from the Tools palette.

• Search-Correlate—Performs template matching on gray-scale ima
using correlation.
IMAQ Vision Builder Tutorial 1-4 © National Instruments Corporation
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• Shape Matching—Searches for the presence of a template in the im
and specifies the location of matching shapes.

• Circle Detection—Finds the center and radius of circular particles 
an image.

• Caliper—Computes measurements such as distances, areas, and
angles based on results returned from other machine vision and im
processing functions.

Getting Help
As you work with IMAQ Vision Builder, you might need to consult othe
sources if you have questions. The following sources can provide you w
more specific information about IMAQ Vision, image acquisition (IMAQ
hardware, and imaging.

IMAQ Vision Builder Online Help
IMAQ Vision Builder offers tooltips and online help that you can access
the following ways:

• Access the IMAQ Vision Builder online help by selecting Online Help 
from the Help menu. There you can find information not available i
this manual, such as function descriptions and directions for 
performing image processing functions.

• Tooltips appear when you move the mouse cursor over a button in
Processing toolbar, Tools palette, Script window, Reference windo
Acquisition window, or Image Browser.

• Press the Help button in any function parameter window to get 
information about that function and its parameters.

IMAQ Vision Manuals
If you have purchased IMAQ Vision software from National Instrumen
you have one of the following manuals, depending on the developmen
environment you use. These manuals provide basic information about
image processing and the IMAQ Vision functions.

• IMAQ Vision for G Reference Manual

• IMAQ Vision for LabWindows/CVI

• Getting Results with ComponentWorks IMAQ Vision
© National Instruments Corporation 1-5 IMAQ Vision Builder Tutorial
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National Instruments Web Site
The National Instruments Web site provides information about IMAQ 
hardware and software. Visit the site at www.natinst.com/imaq .

From the IMAQ site, you can locate information about new IMAQ Visio
features, machine vision problems and solutions, using MMX technolo
on machine vision applications, and selecting the appropriate IMAQ 
hardware, cameras, lenses, and lighting equipment for your applicatio

IMAQ Vision Builder Scripts
You installed several example scripts when you installed IMAQ Vision
Builder. You can run these scripts to learn more about IMAQ Vision 
Builder scripting capabilities. You also can customize these scripts for y
own applications. By default, the scripts are installed at \Program 

Files\National Instruments\IMAQ Vision Builder\Examples .
IMAQ Vision Builder Tutorial 1-6 © National Instruments Corporation
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Introduction to Image 
Processing with IMAQ Vision 
Builder

This chapter describes how you can use IMAQ Vision Builder to create 
test your own image processing algorithms. It explains what types of 
images that IMAQ Vision Builder can load and process and how to ge
started in IMAQ Vision Builder.

Images
An image is light intensity as a function of spatial coordinates

f(x, y)

where f is the light intensity of the point (x, y), and x and y represent the 
spatial coordinates of a picture element (abbreviated pixel).

The spatial reference of the pixel with the coordinates (0, 0) is located a
upper-left corner of the image, as shown in Figure 2-1.

Figure 2-1.  Spatial Reference of the (0,0) Pixel

Properties
Images have three properties: resolution, pixel depth, and number of 
planes.

• Resolution—The number of rows and columns of pixels. An image
composed of m rows and n columns has a resolution of . This m n×
n Builder Tutorial
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image has n pixels along its horizontal axis and m pixels along its 
vertical axis.

• Pixel Depth—The number of bits (n) used to code the intensity of a 
pixel. For a given n, a pixel can take 2n different values. For example,
if n equals 8-bits, a pixel can take 256 different values ranging from
to 255. If n equals 16 bits, a pixel can take 65,536 different values 
ranging from –32,768 to 32,767. 

The number of values a pixel can take on is called definition, which is 
the number of colors or shades that you can see in the image. 

• Number of Planes—The number of arrays of pixels that compose 
image. A gray-level or pseudo-color image is composed of one pla
while an RGB image is composed of three planes (one for the red
component, one for the blue, and one for the green), as shown in 
Figure 2-2.

Figure 2-2.  Number of Planes in an Image

In gray-level images, there is a single intensity value per pixel. In 
three-plane or true-color images, the RGB intensities of a pixel are
coded into three different values, corresponding to the red, green,
blue components.

R
G
B

R
G
B

To
 M

on
ito

r

(R+G+B)

CLUT
or Palette

Color

Gray Level
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Types
IMAQ Vision Builder can manipulate three types of images: gray-level
color, and complex images.

• Gray-Level Images—Gray-level images are composed of a single
plane of pixels. Standard gray-level formats are BMP, TIFF, and AIP
Standard 16-bit gray-level formats are TIFF and AIPD. AIPD is an
internal file format that offers the advantage of storing the spatial 
calibration of an image. Gray-level images that use other formats 
have a pixel depth of 8-bit, 16-bit, or 32-bit (floating point) can be 
imported into the IMAQ Vision libraries.

• Color Images—Color images are composed of three planes of pixe
which each pixel has a red, green, and blue intensity, each coded
8-bit planes. Color images coded using the RGB-chunky standard
contain an extra 8-bit plane, called the alpha channel. These images 
have a definition of 32-bit or 4 × 8-bit. Standard color formats are 
BMP, TIFF, and AIPD. 

• Complex Images—Complex images are composed of complex dat
which pixel values have a real part and an imaginary part. Such ima
are derived from the Fast Fourier Transform of gray-level images. F
representations of a complex image can be given: the real part, 
imaginary part, magnitude, and phase.

Getting Started in IMAQ Vision Builder
This section describes the software-specific terminology that you need
complete the tutorials in this manual and understand the online help. T
only way to understand how IMAQ Vision Builder works and what you c
accomplish with IMAQ Vision Builder is by using it.

In this short example, you load images into IMAQ Vision Builder and 
perform one image processing function—a threshold. Thresholding 
isolates particles so that you can keep those that interest you and rem
those that do not. Thresholding also converts the image from a graysc
image, with pixel values ranging from 0 to 255, to a binary image, with
pixel values of 0 or 1.

Follow these steps to get started in IMAQ Vision Builder.

1. Launch IMAQ Vision Builder from the Start menu 
(Start»Programs»National Instruments IMAQ Vision 
Builder»IMAQ Vision Builder ). 

2. To load images, select File»Open Image.
© National Instruments Corporation 2-3 IMAQ Vision Builder Tutorial
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3. Navigate to Program Files\National Instruments\IMAQ 

Vision Builder\Examples\Metal  and check the Select All Files 
option. Notice that IMAQ Vision Builder previews the images in the
Preview Image window and displays information about the file type
and image depth.

4. Click OK .

IMAQ Vision Builder loads those image files into the Image Browse
as shown in Figure 2-3. Notice that the Image Browser provides 
information about the selected image, such as image size, locatio
depth, and type.

Figure 2-3.  Image Browser

You can view new images in either thumbnail view (as shown in Figure 2
or in full-size view, which shows a single full-size view of the selected 
image.

Image Location

Image Browser

Browse Buttons

Image
Depth

Image
Type

Image
Size

Delete
Selected Image(s)

Thumbnail/Full-Size
View Toggle
IMAQ Vision Builder Tutorial 2-4 © National Instruments Corporation
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5. Click the Thumbnail/Full-Size View toggle to view the first image in 
full size.

6. Use the browse buttons to view Metal4.tif .

7. To enter processing mode, double click the image. IMAQ Vision 
Builder loads the image into the processing window, as shown in 
Figure 2-4.

Figure 2-4.  Processing an Image

Tip The Reference window displays the original version of the image as you 
manipulate it in the processing window.

Processing WindowReference Window

Zoom
Ratio

Image
Size
© National Instruments Corporation 2-5 IMAQ Vision Builder Tutorial
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8. Select Binary»Threshold. The Threshold parameter window appea
in the lower right corner of the IMAQ Vision Builder window, 
as shown in Figure 2-5.

Figure 2-5.  Thresholding an Image

The Threshold parameter window displays a histogram. A histogra
counts the total number of pixels at each grayscale value and grap
From the graph, you can tell whether the image contains distinct 
regions of a certain gray-level value, and you can select pixel regi
of the image. For example, if the background of an image is black 
you want to remove it, you can select a range closer to the 255 (wh
value. 

9. From the Threshold parameter window, specify settings that work b
for your application. For this threshold, set the Min  and Max values to 
130 and 255 to select all of the particles.

Threshold Parameter Window
IMAQ Vision Builder Tutorial 2-6 © National Instruments Corporation
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Tip Often you will need to manipulate the parameters several times to find the valu
that work best. Rather than entering numbers in the Min  and Max fields, you can 
select the range using the pointers on the histogram. Adjust the pointers until a
of the particles you want to select are red. The black pointer marks the minimu
value, and the white pointer marks the maximum value.

10. Click OK  to apply the manual threshold to the image. The image i
converted to a binary image where all of the selected pixels in the
threshold range are set to 255 (white) and all other pixels are set 
0 (black).

Refer to Figure 2-6, which displays the image after the threshold has b
applied. 

Figure 2-6.  Thresholded Image

Script
Window

Script
Tools

Tools
Palette
© National Instruments Corporation 2-7 IMAQ Vision Builder Tutorial
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The thresholding step is recorded in the Script window. The script reco
the processing operation and all of its parameters. If you need to run t
same operation on other images, you can save the script and use it ag

11. Select Script»Save Script and name the script threshold.scr . 

If you find another image that you need to threshold similarly, run th
script on a different image using the following steps:

a. Load the image.

b. Select Script»Open Script to open threshold.scr .

c. Click the Run Script button in the script window.

Try experimenting with different options and images. For example
you can perform a particle analysis to find the area that each objec
this image occupies. If you need help with any specific image 
processing operation, click the Help button in the parameter window.

12. Select File»Exit to close IMAQ Vision Builder.

Acquiring Images in IMAQ Vision Builder
If you have National Instruments IMAQ hardware and NI-IMAQ installe
you can acquire live images in IMAQ Vision Builder.

Tip If you do not have IMAQ hardware and NI-IMAQ 2.0 or later, IMAQ Vision 
Builder simulates the acquisition process by displaying a sequence of images. 
can stop the sequence at any frame, capture the image, and send the image to
Image Browser for processing.

IMAQ Vision Builder offers three types of acquisitions: snap, grab, and
sequence. A snap acquires and displays a single image. A grab acquires 
and displays a continuous sequence, which is useful when you need t
focus your camera. A sequence acquires images according to settings th
you specify and sends the images to the Image Browser.

1. Launch IMAQ Vision Builder from the Start menu 
(Start»Programs»National Instruments IMAQ Vision 
Builder»IMAQ Vision Builder ).

2. Press the Acquire button in the toolbar. IMAQ Vision Builder displays
the Acquisition Interface window and acquisition property pages, a
shown in Figure 2-7.

The Interface window displays all IMAQ hardware and channels 
available for your computer. Figure 2-7 shows that two IMAQ 
hardware devices are available—the IMAQ PCI-1408 and the 
IMAQ PCI-1424.
IMAQ Vision Builder Tutorial 2-8 © National Instruments Corporation
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Figure 2-7.  Acquiring Images in IMAQ Vision Builder

The property pages above the Interface window list properties 
available for the selected device. In Figure 2-7, the IMAQ PCI-1408
selected. Because the 1408 can acquire StillColor if you have a co
camera, you can set the following properties for StillColor acquisiti

• StillColor Mode —Selects the acquisition mode.

– Disabled disables StillColor and enables monochrome mod
Disable StillColor if you have a monochrome camera.

– RGB enables color mode with Tri-CCD cameras. This mod
uses channels 1, 2, and 3, but you need to select a camer
only for channel 1.

– Composite enables color mode for PAL or NTSC cameras

• Image Representation—Selects the image representation.

– RGB in 16-, 24-, 32-, 48-bit format.

– Red, green or blue plane in 8-bit format.

Acquisition Property Pages

Store Acquired Image in Browser

IMAQ Hardware and Channels
© National Instruments Corporation 2-9 IMAQ Vision Builder Tutorial
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– Luminance, Hue, Saturation or Intensity in 8- or 16-bit 
format.

– HSL (Hue, Saturation, Luminance) in 32-bit format.

– HSI (Hue, Saturation, Intensity) in 32-bit format.

Note Your computer must have a National Instruments IMAQ board and NI-IMAQ 2.0
or later installed before you can acquire live images in IMAQ Vision Builder.

Snapping an Image (Single Acquisition)
1. Open the Acquisition window.

2. Click the Acquire Single Image button to acquire a single image with
the IMAQ device and display it. This operation is also known as a 
snap.

3. Press the Store Acquired Image in Browser button to send the image
to the Image Browser.

4. Process the image as you would any other image in IMAQ Vision 
Builder. See Chapter 3, Analyzing the Structure of a Metal Using Blob
Analysis, and Chapter 4, Using Gauging for Part Inspection for 
examples of processing images in IMAQ Vision Builder.

Grabbing an Image (Continuous Acquisition)
1. Open the Acquisition window.

2. Click the Live Acquisition button to acquire and display images in 
continuous mode at the maximum rate. This operation is also kno
as a grab.

Note If your computer does not have an IMAQ board, IMAQ Vision Builder simulates
the live acquisition process. You can interact with the simulation module as yo
would with a live acquisition.

3. Click the Live Acquisition button again to stop the acquisition and 
display the last acquired image.

Tip You can acquire a region of interest within the full-sized image. Draw a region o
interest in your image while grabbing it, and the image reduces to that area. Y
can refine the acquired area again by selecting another region of interest or retu
to the full-sized image by clicking on the image.
IMAQ Vision Builder Tutorial 2-10 © National Instruments Corporation
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4. Press the Store Acquired Image in Browser button to send the image
to the Image Browser.

5. Process the image as you would any other image in IMAQ Vision 
Builder. See Chapter 3, Analyzing the Structure of a Metal Using Blob
Analysis, and Chapter 4, Using Gauging for Part Inspection for 
examples of processing images in IMAQ Vision Builder.

Acquiring a Sequence of Images
1. Open the Acquisition window.

2. Click the Sequence Acquisition button to acquire a sequence of live
images.

3. Click the Sequence tab to view the Sequence property page.

4. Set the properties for the Sequence property page.

• Number of Frames—Number of frames you want to acquire.

• Skip Count—Number of frames you want to skip between 
acquisitions.

• Line—Physical trigger line.

• Action—Triggering action.

– Disabled disables triggering.

– Trigger start of acquisition

– Trigger each image

• Timeout—Time in ms within which the trigger must occur.

Images acquired are automatically sent to the Image Browser.

5. Process the image as you would any other image in IMAQ Vision 
Builder. See Chapter 3, Analyzing the Structure of a Metal Using Blob
Analysis, and Chapter 4, Using Gauging for Part Inspection for 
examples of processing images in IMAQ Vision Builder.
© National Instruments Corporation 2-11 IMAQ Vision Builder Tutorial
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Analyzing the Structure of a 
Metal Using Blob Analysis

This chapter describes blob analysis and provides step-by-step direct
for completing a blob analysis tutorial in IMAQ Vision Builder.

What Is Blob Analysis?
Blob analysis consists of a series of processing operations and analys
functions to produce some information about the blobs in an image. A b
(Binary Large OBject) is defined as a connected region or grouping of 
pixels in an image in which all pixels have the same intensity level. In 
binary image, the background is zero, and every non-zero pixel is part
binary object.

You perform a blob analysis to find statistical information—such as the s
of the blobs or the number, location, and presence of blob regions. With
information, you can detect flaws on silicon wafers, detect soldering 
defects on electronic boards, or locate objects in motion control 
applications when there is significant variance in part shape or orienta

Tutorial
In this tutorial, you find the area of circular particles in a metal. As you
perform this analysis, IMAQ Vision Builder records all of the processin
operations and parameters in a script. You will run that script on other
images to test your blob analysis script.

To find the total area of circular particles, you will perform the following
image processing steps:

• Filter the image to sharpen edges and ease the separation of the 
particles from the background.

• Threshold the image to isolate pixels that interest you (the particle
and remove all other pixels (the background).

• Fill holes that appear in the particles after thresholding.
n Builder Tutorial
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• Remove all objects touching the border so that you remove partia
particles.

• Use a particle filter to find all circular blobs and remove non-circula
blobs.

• Perform a particle analysis to find the total area occupied by circu
blobs.

Loading Images into IMAQ Vision Builder
Perform the following steps to load an image:

1. Launch IMAQ Vision Builder from the Start menu 
(Start»Programs»National Instruments IMAQ Vision 
Builder»IMAQ Vision Builder ).

2. To load images, select File»Open Image.

3. Navigate to Program Files\National Instruments\IMAQ 

Vision Builder\Examples\Metal  and check the Select All Files 
option. Notice that IMAQ Vision Builder previews the images in the
Preview Image window and displays information about the file form
and size and pixel depth.

Tip The Preview Image window displays all selected images in a sequence. To view
images at a different rate, adjust the slide to the right of the Preview Image 
window.

4. Click OK .

IMAQ Vision Builder loads the image files, which represent 
microscopic views of pieces of metal, into the Image Browser. Fro
this collection of images in the Image Browser, you can select the
image that you want to process. 

5. Double click the first image, Metal1.tif . The image is loaded into 
the processing window.

Preparing an Image for Blob Analysis
Before you can separate circular particles from non-circular particles, 
need to prepare the image. To isolate particles of interest, verify that 
individual particles are distinct from other particles (that is, there is a g
between particles) and that the borders of those particles are sharp.
IMAQ Vision Builder Tutorial 3-2 © National Instruments Corporation
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Examining the Image
Examine the image in the processing window. The image is slightly 
blurred. Also, the edges of particles are not sharp. Although you can s
these problems from just looking at this image, you might need to use aline 
profile in other cases. A line profile returns the grayscale values along a
that you draw with the line tool from the Tools palette.

1. Select Image»Line Profile. The parameter window appears and the
line tool from the Tools Palette is automatically selected and active

2. Draw a short segment across a particle, as shown in Figure 3-1.

Figure 3-1.  Using a Line Profile to Examine Edges

3

21
© National Instruments Corporation 3-3 IMAQ Vision Builder Tutorial



Chapter 3 Analyzing the Structure of a Metal Using Blob Analysis

ticles. 
lope, 
 

 
the 

ed 
 

ake 
ical 

e so 
ding 
the 

les, 

e the 
ine 
In Figure 3-1, the areas labeled 1 and 2 represent the edges of the par
Notice that the edges of both particles have a slope. The greater the s
the more variation you will have when you threshold the image. As you
change the threshold level, you might change the shape or size of the
particle. You can use the Highlight Details filter to define the edges of 
particles and reduce the slope.

The area labeled 3 is a fluctuation in pixel values, which might be caus
by brighter and darker pixels in the center of the particles or it could be
edges of a hole in the particle. Later, you will threshold the image to m
all pixels in the objects the same pixel value and perform a morpholog
operation on the image to fill any holes left in the object.

3. Click Return.

Filtering the Image
Filters can smooth, sharpen, transform, and remove noise from an imag
that you can extract the information you need. To sharpen edges, inclu
the edges of any holes inside a particle, and create contrast between 
particles and the background, follow these steps:

1. Select Gray Scale»Filters.

2. Select Convolution–Highlight Details from the Filters list. This 
function looks for sharp transitions and highlights edge pixels 
according to the kernel to make gaps more prominent.

3. Click Apply  to add this step to the script.

4. Click Close.

Examining the Results of the Filtering
To confirm that the filtering helped sharpen edges and separate partic
perform another line profile using the following steps:

1. Select Image»Line Profile.

2. Click and drag to draw a short segment across a particle to examin
line profile of a particle and its border, as shown in Figure 3-2. The l
profile indicates more defined edges.
IMAQ Vision Builder Tutorial 3-4 © National Instruments Corporation
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Figure 3-2.  Using a Line Profile to Examine Particle Edges

3. Click Return.

Separating Particles from the Background with Thresholding
Thresholding isolates pixels so that you can keep those that interest you
remove remaining pixels. Thresholding also converts the image from 
grayscale to binary. 

The Threshold parameter window displays a histogram. A histogram 
counts the total number of pixels in each grayscale value and graphs 
From the graph, you can tell whether the image contains distinct region
a certain gray-level value, and you can select pixel regions of the imag

Follow these steps to select a range of brighter pixels to analyze.

1. Select Binary»Threshold.

2. Select Manual Threshold from the Threshold list.

3. Select a range of 130 to 255.
© National Instruments Corporation 3-5 IMAQ Vision Builder Tutorial
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Notice that the particles of interest (circular and non-circular) are 
highlighted in red. When you apply this threshold, everything 
highlighted in red is set to white (255) and all other pixels are set t
0 (black).

Tip You can adjust the pointers until all of the particles of interest are red. The blac
pointer marks the minimum value, and the white pointer marks the maximum 
value.

4. Click OK to add this step to the script. Figure 3-3 shows the 
thresholded image. The pixels that you want to process are white.
Unselected pixels are set to black.

The image is now a binary image, which is an image composed o
black and white pixels with values of 0 and 255. The particles are n
referred to as blobs.

Figure 3-3.  Separating Particles from the Background with Thresholding
IMAQ Vision Builder Tutorial 3-6 © National Instruments Corporation
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Modifying Blobs with Morphological Functions
Morphological functions affect the shape of blobs. Each blob or region
the binary image is affected on an individual basis. Morphological 
operations prepare blobs in the image for quantitative analysis such a
finding the area, perimeter, or orientation. Use the following steps to ap
two morphological functions to the image. The first fills holes in the 
particles and the second removes objects that touch the border of the im

1. Select Binary»Adv. Morphology.

2. Select Fill holes from the Morphology–Advanced function list.

3. Click Apply  to add this step to the script.

4. Select Remove border objects to remove any objects that touch the
border of the image, as shown in Figure 3-4.

Figure 3-4.  Modifying Blobs with Morphological Functions

5. Click Apply  and Close to add this step to the script and close the 
Advanced Morphology window.
© National Instruments Corporation 3-7 IMAQ Vision Builder Tutorial
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Isolating Circular Blobs
Use the following steps to define a particle filter that isolates and keeps
circular blobs and removes the non-circular blobs from the image.

1. Select Binary»Particle Filter .

2. Select Heywood circularity factor  from the list of particle filters. 
This function calculates the ratio of the perimeter of the blob to the
area of the particle. The more circular the blob, the closer the ratio 

3. To find more circular and less oblong blobs, enter a minimum value
0 and a maximum value of 1.06 for the parameter range.

4. Select the Keep Objects option to keep the circular blobs (and remov
the blobs that do not fit in this range).

5. Click OK  to add this step to the script. The image now contains on
the circular blobs, as shown in Figure 3-5.

Figure 3-5.  Isolating Circular Blobs
IMAQ Vision Builder Tutorial 3-8 © National Instruments Corporation
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Analyzing Circular Blobs
Now that you have isolated the circular blobs, follow these steps to find
area occupied by them:

1. Select Binary»Particle Analysis. A results table is displayed with all
of the measurement results.

IMAQ Vision Builder assign numerical labels to each blob. The firs
row of the results table lists the numerical label associated with ea
blob.

2. Click the Show Labels button to view the labels.

Tip When you click on a blob, the measurement results for that blob are highlighte
in blue. When you click on the results for a blob, the blob is highlighted in yellow
in the processing view.

3. To show only the area measurement, click the Choose Measurements 
button.

4. Click None to deselect all of the measurements.

5. Double click Area (unit) .

6. Click OK .

7. Click Apply  to record the particle analysis in the script.

8. Click Close.

You now have all of the information you need to analyze the structure 
the metal. Remember to include the analysis as part of your LabVIEW
LabWindows/CVI, or Visual Basic solution. You also can use Microsof
Excel to analyze the data generated by IMAQ Vision Builder.

Tip To send the data to Microsoft Excel, click the Send Data to Excel button in the 
Particle Analysis results window.
© National Instruments Corporation 3-9 IMAQ Vision Builder Tutorial
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Testing the Blob Analysis Script
The script that you created as you processed this image is a custom 
algorithm. To test this algorithm, run it on another image in the collecti
using the following steps:

1. Click the Image Browser button in the Standard toolbar.

2. Double click the third image, Metal3.tif .

Tip Rather than returning to the Image Browser, you can navigate through the imag
in the Image Browser from the Reference window. Click the next and back butto
until you see the image you want to process and then click the Make Image Active 
button to move that image into the Processing window.

3. Click the Run Script button. 

Figure 3-6 shows the original image, Metal3.tif , on the left and the 
image after the blob analysis processing on the right. Notice that t
circular blobs are removed from the image during processing beca
they are touching each other. To separate particles from each other
can adjust the thresholding step.

Figure 3-6.  Comparing the Original Image to the Processed Image

4. Click Cancel in the Particle Analysis window to close the results tab

Original Image (Metal3.tif)

Overlapping
Circular Blobs

Image after Processing
IMAQ Vision Builder Tutorial 3-10 © National Instruments Corporation
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5. Double click the Threshold step in the script window to open the 
threshold parameters. Figure 3-7 shows Metal3.tif  at the 
thresholding step of the script. 

Figure 3-7.  Testing the Blob Analysis Script

6. Adjust the minimum threshold value until the blobs are clearly 
separated. A minimum value of 150 works well.

7. Click Replace.

8. Click the Run Script button to rerun the script. Notice that the circula
blobs now appear in the final processed image.

9. Click Cancel to close the Particle Analysis window.
© National Instruments Corporation 3-11 IMAQ Vision Builder Tutorial
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Saving the Blob Analysis Script
Now that you have written a blob analysis algorithm and tested it on 
another image, you can save the script to use on similar images. You 
can perform batch processing with this script. See the Analyzing a 
Collection of Images with Batch Processing section in Chapter 4, Using 
Gauging for Part Inspection, for an example of batch processing in IMAQ
Vision Builder.

1. Select Script»Save Script.

2. Save the script as blob analysis.scr .

Implementing the Algorithm in LabVIEW
You have prototyped, tested, and refined an IMAQ Vision processing 
algorithm. Now you can use that script to implement the algorithm in 
development environments such as LabVIEW, LabWindows/CVI, and
Visual Basic using the IMAQ Vision library. Follow these steps to 
implement the blob analysis algorithm in LabVIEW:

1. Select Script»Builder File . The Builder Information window lists all 
of the processing steps and the parameters for each.

2. Click the Save button.

3. Save the file as blob analysis.txt .

4. Use File»Exit to close IMAQ Vision Builder.

5. Open the file in a text editor or word processor and print the file.

6. Launch LabVIEW and use the step descriptions to build the blob 
analysis block diagram with IMAQ Vision VIs. The block diagram 
should look similar to Figure 3-8.
IMAQ Vision Builder Tutorial 3-12 © National Instruments Corporation
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Figure 3-8.  Blob Analysis Block Diagram

Tip The IMAQ Particle Filter VI is installed with IMAQ Vision Builder. You can find it 
in the Program Files\National Instruments\IMAQ Vision Builder\VIs  
folder.
© National Instruments Corporation 3-13 IMAQ Vision Builder Tutorial
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Using Gauging 
for Part Inspection

This chapter describes gauging and provides step-by-step directions f
completing a part inspection tutorial in IMAQ Vision Builder.

What Is Gauging?
Components such as connectors, switches, and relays are small and 
manufactured in high quantity. Human inspection of these components
tedious and time consuming. Vision systems can quickly and consiste
measure certain features on a component and generate a report with 
results. From the results, you can determine whether a part meets its 
specifications.

Gauging consists of making critical distance measurements—such as
lengths, diameters, angles, and counts—to determine if the product is
manufactured correctly. If the gauged distance or count does not fall wi
tolerance limits, the component or part does not meet specifications a
should be rejected. Gauging inspection is used often in mechanical 
assembly verification, electronic packaging inspection, container 
inspection, glass vile inspection, and electronic connector inspection.

Tutorial
In this tutorial, you analyze an image of a jumper to see if the jumper m
its physical specifications. A jumper is a plastic plug that fits over a pair
protruding pins to close an electrical circuit.

Your goal is to measure distances between features on the jumper an
determine if those measurements fall within a tolerance range. Figure
illustrates the measurements and the acceptable values for those 
measurements.
n Builder Tutorial
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Figure 4-1.  Jumper Specifications

As you perform this analysis, IMAQ Vision Builder records all of the 
processing operations and parameters in a script. You will run that scrip
other jumper images to determine which are good and which are defec

Loading Images into IMAQ Vision Builder
Perform the following steps to load an image:

1. Launch IMAQ Vision Builder from the Start menu 
(Start»Programs»National Instruments IMAQ Vision 
Builder»IMAQ Vision Builder ).

2. To load images, select File»Open Image.

Distance 1
203–205 pixels

Distance 6
98–100 pixels

Angle 5
310–311˚

Distance 7
104–106  pixels

Distance 2
35–36 pixels

Distance 4
14–15 pixels

Distance 3
26–29 pixels

Hole
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4-2. 
3. Navigate to Program Files\National Instruments\IMAQ 

Vision Builder\Examples\Jumper  and check the Select All 
Files option. Notice that IMAQ Vision Builder previews the images i
the Preview Image window and displays information about the file
format and size and pixel depth.

Tip The Preview Image window displays all selected images in a sequence. To vie
the images at a different rate, adjust the slide to the right of the Preview Image
window.

4. Click OK  to load the image files into IMAQ Vision Builder. From this
collection of images in the Image Browser, you can select the ima
that you want to process. 

5. Double click the first image, Jumper1.bmp . The image is loaded into 
the processing window.

Finding Edges in the Image
Before you can compute the measurements, you need to detect edge
which you can base the measurements. The Edge Detector finds edg
along a line that you draw with the line tool from the Tools palette.

1. Select Gray Scale»Edge Detector.

2. Select the Simple Edge Tool. The Simple Edge Tool is effective on 
images with sharp contrast between the background and objects.

3. Select All Edges so that IMAQ Vision Builder finds and labels every
edge along the line you draw.

4. Select Absolute Value. Absolute Value indicates that you want to us
pixel values to specify the threshold level. Relative Value indicates 
that you are specifying the threshold level as a percentage.

5. Set Threshold Level to 128. The threshold level specifies the 
difference in pixel values that you expect to constitute an edge in 
image. Absolute detection considers a threshold level of 128 or gre
as an edge.

6. Click and drag to draw a horizontal line across the middle of the 
jumper to find the edges that define Distance 1, as shown in Figure
IMAQ Vision Builder labels the edges 1 and 2. 

Note You can obtain the same results by selecting Relative Value with a Threshold 
Level of 50%.
© National Instruments Corporation 4-3 IMAQ Vision Builder Tutorial
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Figure 4-2.  Finding the Edges for Distance 1

Look at the line profile. The sharp transitions in the line profile indica
edges. Notice that the number of edges found is displayed under 
line profile.

7. Click Apply  to add this edge detection step to the script.

8. To find edges for the other measurements, click and drag to draw
lines as indicated in the Figures 4-3 to 4-6 and click Apply  after each 
to add them to the script.

Tip To draw a straight line, press and hold the <Shift> key as you draw the line.

Figure 4-3.  Finding the Edges for Distances 2 and 3

Figure 4-4.  Finding the Edges for Distance 4
IMAQ Vision Builder Tutorial 4-4 © National Instruments Corporation
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Figure 4-5.  Finding the Edges for Angle 5 and Distances 6 and 7

Figure 4-6.  Finding the Edges for Angle 5

9. Click Close to close the Edge Detection window.

Storing the Original Image
To calculate Distances 6 and 7, you need to isolate the hole and find i
center point. As you isolate the hole, you will alter the image. Because 
need the original image to find the measurements, follow these steps 
save a copy of the original image in an image buffer.

1. Select Image»Image Buffer.

2. Select Push Image to indicate that you want to copy the image to th
image buffer.

3. Click Apply  to add this step to the script. Notice that the image is 
copied to the buffer only after you click Apply.

4. Click Close to close the Image Buffer window.
© National Instruments Corporation 4-5 IMAQ Vision Builder Tutorial
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Finding the Center Point in the Hole
To find the center point in the hole, you need to isolate the hole and th
perform a circle detection.

Isolating the Hole
Follow these steps to isolate the hole:

1. Select Binary»Threshold. A threshold selects pixels based on their
gray-level value and turns them white. All unselected pixels are turn
black.

2. Select Auto Threshold: Clustering. Clustering applies an automatic
thresholding algorithm. For this image, the thresholding range 
computed by the algorithm is between 135 and 255. This threshol
range selects the objects and turns them white, converting them t
blobs.

3. Click OK  to add the threshold to the script and close the Threshol
window.

The image now consists of two white blobs. Follow these steps to iden
individual blobs with color:

4. Select Binary»Adv. Morphology.

5. Select Label objects. When you label objects, a different color is 
assigned to each blob. In this case, you see a green blob and a red

Note You do not need to add the Label objects step to the script because it is not a 
necessary step in the processing algorithm. It was included here to show you h
to color label objects in an image, which is especially useful for images containin
many objects that are not clearly separated.

To isolate the hole, which is the green blob, you need to remove the
blob. Because the red blob touches the border of the image and th
green blob does not, you can use a function to remove all objects 
touch the border.

6. Select Remove border objects from the Morphology list to remove 
the red blob.

7. Click Apply  to add this step to the script.

8. Click Close to close the Morphology window.
IMAQ Vision Builder Tutorial 4-6 © National Instruments Corporation
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Performing a Circle Detection
The circle detection function finds the center of circular particles in an
image. If a particle is not circular, this function might not find the exact
center. However, in this example, you do not need to find the exact ce
of the object. Instead, you are trying to find the center of a symmetrica
object along the horizontal axis. Follow these steps to use circle detec
to find the center of the hole:

1. Select Binary»Circle Detection. IMAQ Vision Builder finds the 
center of the hole and displays its coordinates in the results table,
shown in Figure 4-7.

Figure 4-7.  Finding the Center of an Object with Circle Detection

2. Click Apply  to add this step to the script.

3. Click Close to close the Circle Detection window.
© National Instruments Corporation 4-7 IMAQ Vision Builder Tutorial
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Restoring the Original Image
Perform the following steps to restore the original image so that you see
location of the edges on the original image:

1. Select Image»Image Buffer.

2. Select your image from the Image Buffer list.

3. Select Pop Image.

4. Click Apply. The original image is restored in the processing windo

5. Click Close to close the Image Buffer window.

Making the Measurements
Now that you have found all of the necessary edges and the center po
the hole, you can calculate the measurements with the Caliper functio
The Caliper function is a tool that uses points on the image to calculat
measurements, such as distances, angles, the center of a segment, o
area, depending on the number of points you have selected on the im
These points are results of earlier processing steps, such as edge dete

Follow these steps to make the measurements:

1. Select Gray Scale»Caliper.

2. Click on points 1 and 2 to find the first measurement—Distance 1, 
which specifies the width of the entire image.

Tip If you have trouble finding the points, click the Zoom In tool in the Tools palette 
to magnify the image. Magnification factors are displayed in the lower, left corne
of the processing window. 1/1 specifies 100% magnification (default). 2/1 specif
a slightly magnified view, and 1/2 specifies a slightly demagnified view.

3. Click Distance as the type of measurement.

4. Click the Measure button to compute the distance and add the distan
measurement to the results table, as shown in Figure 4-8.
IMAQ Vision Builder Tutorial 4-8 © National Instruments Corporation
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Figure 4-8.  Using the Caliper Function to Find Distance 1

5. Using the data in the following table, repeat Steps 2–4 to find the 
remaining measurements:

Tip Instead of clicking on the points in the image, you can double click on the poin
in the Points listbox to select them. When a point is selected, IMAQ Vision Builde
places a checkmark next to it.

To Make This 
Measurement

Select 
these Points

Type of 
Measurement

Distance 2 3,4 Distance

Distance 3 8,9 Distance

Distance 4 11,12 Distance

Angle 5 14,17,15,18 Angle
© National Instruments Corporation 4-9 IMAQ Vision Builder Tutorial



Chapter 4 Using Gauging for Part Inspection

le.

 the 
Figure 4-9 shows a magnified view of the image with all of the caliper 
measurements selected on the image and displayed in the results tab

Figure 4-9.  Using the Caliper Tool to Collect Measurements

6. Click Add to add these caliper measurements to the script and close
Caliper window.

7. Select File»Save Script and save the script as jumpers.scr .

Distance 6 13,19 Distance

Distance 7 19,16 Distance

To Make This 
Measurement

Select 
these Points

Type of 
Measurement
IMAQ Vision Builder Tutorial 4-10 © National Instruments Corporation
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Analyzing a Collection of Images with Batch Processing
Perform the following steps to run the script as a batch process on the
jumper images and generate a text file containing all of the measurem
data:

1. Select Script»Batch Processing.

2. Select Browser from Image Source to process the images stored in 
Image Browser.

The listbox contains all of the steps in the script. You can select any ste
the script and choose options, such as saving that step’s results to file
displaying results, or opening the parameter window to adjust the sett
on each iteration. For this example, save the caliper results to a file.

3. Select Caliper in the list box.

4. Select Save Results.

5. Click the Setup button and set the following options:

a. Select One file for all results.

b. Press the Browse button, navigate to the directory where you wan
the file saved, and click Select Cur Dir.

c. Name the file jumpers.txt .

6. Click OK  to close the Setup options.

7. Click Run to start the batch process.

As batch processing runs, a progress window appears on the left 
of the IMAQ Vision Builder window. The progress window displays
the current process (acquiring an image or processing an image),
number of times the process has been completed, the starting time
an estimation of the time remaining. If you ever need to stop a bat
process, click the Cancel button.

8. When the batch processing completes, click OK .

9. Click Return to exit the Batch Processing window.

The jumper images have been processed and the caliper results store
text file.

Analyzing the Results
As you implement this algorithm in your development environment usi
the Builder file, remember to include your analysis. For this example, y
can use Excel to quickly analyze the results.
© National Instruments Corporation 4-11 IMAQ Vision Builder Tutorial
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Note To complete this part of the tutorial, you must have Excel version 97 or later 
installed on your computer.

1. Launch Microsoft Excel.

2. Open jumpers.txt  from within Excel to view the results.

The results are labeled and listed in the order in which they appear in 
Image Browser. In this case, images are listed from Jumper1.bmp  to 
Jumper6.bmp . The Jumper1.bmp  results appear as follows. 

Table 4-1 lists the acceptable ranges for the jumper measurements an
actual values you might see for the jumper images. Notice that Jumper1  is 
the only one that meets the specifications.

Note The bold values indicate which measurements caused the jumpers to fail.

Program Files\National Instruments\ 
IMAQ Vision Builder\Images\ 
Jumpers\Jumper1.bmp

10/23/98 3:17:16 PM

Distance (1, 2) Dist = 204.79

Distance (3, 4) Dist = 35.19

Distance (8, 9) Dist = 28.81

Distance (11, 12) Dist = 14.52

Angle (14, 17, 15, 18) Angle = 311.8º

Distance (13, 19) Dist = 99.44

Distance (19, 16) Dist = 104.52

Table 4-1.  Jumper Measurement Results

Measure Ranges Jumper1 Jumper2 Jumper3 Jumper4 Jumper5 Jumper6

 1 203–205 204.79 204.79 204.79 204.79 211.79 203.79

 2 35–36 35.19 35.19 42.23 35.19 35.19 35.19

 3 26–29 28.81 26.81 28.81 28.81 28.81 19.81

 4 14–15 14.52 8.52 14.52 14.52 14.52 14.52

 5 310–313 311.8 311.8 311.8 301.8 311.8 311.8

 6 98–100 99.44 99.44 99.44 98.44 99.44 107.44

 7 104–106 104.52 104.52 104.52 104.52 111.52 95.52
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Customer Communication

For your convenience, this appendix contains forms to help you gather the information necessa
to help us solve your technical problems and a form you can use to comment on the product 
documentation. When you contact us, we need the information on the Technical Support Form
the configuration form, if your manual contains one, about your system configuration to answer
questions as quickly as possible.

National Instruments has technical assistance through electronic, fax, and telephone systems to
provide the information you need. Our electronic services include a bulletin board service, an FT
a fax-on-demand system, and e-mail support. If you have a hardware or software problem, first 
electronic support systems. If the information available on these systems does not answer you
questions, we offer fax and telephone support through our technical support centers, which are
by applications engineers. 

Electronic Services

Bulletin Board Support
National Instruments has BBS and FTP sites dedicated for 24-hour support with a collection of
and documents to answer most common customer questions. From these sites, you can also d
the latest instrument drivers, updates, and example programs. For recorded instructions on how
the bulletin board and FTP services and for BBS automated information, call 512 795 6990. Yo
access these services at:

United States: 512 794 5422
Up to 14,400 baud, 8 data bits, 1 stop bit, no parity

United Kingdom:  01635 551422
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

France:  01 48 65 15 59
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

FTP Support
To access our FTP site, log on to our Internet host, ftp.natinst.com , as anonymous  and use 
your Internet address, such as joesmith@anywhere.com , as your password. The support files and
documents are located in the /support  directories.
n Builder Tutorial
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Fax-on-Demand Support
Fax-on-Demand is a 24-hour information retrieval system containing a library of documents on a
range of technical information. You can access Fax-on-Demand from a touch-tone telephone a
512 418 1111.

E-Mail Support (Currently USA Only)
You can submit technical support questions to the applications engineering team through e-mai
Internet address listed below. Remember to include your name, address, and phone number so
contact you with solutions and suggestions. 

support@natinst.com

Telephone and Fax Support
National Instruments has branch offices all over the world. Use the list below to find the technic
support number for your country. If there is no National Instruments office in your country, cont
the source from which you purchased your software to obtain support.

Country Telephone Fax
Australia 03 9879 5166 03 9879 6277
Austria 0662 45 79 90 0 0662 45 79 90 19
Belgium 02 757 00 20 02 757 03 11
Brazil 011 288 3336 011 288 8528
Canada (Ontario) 905 785 0085 905 785 0086
Canada (Québec) 514 694 8521 514 694 4399
Denmark 45 76 26 00 45 76 26 02
Finland 09 725 725 11 09 725 725 55
France 01 48 14 24 24 01 48 14 24 14
Germany 089 741 31 30 089 714 60 35
Hong Kong 2645 3186 2686 8505
Israel 03 6120092 03 6120095
Italy 02 413091 02 41309215
Japan 03 5472 2970 03 5472 2977
Korea 02 596 7456 02 596 7455
Mexico 5 520 2635 5 520 3282
Netherlands 0348 433466 0348 430673
Norway 32 84 84 00 32 84 86 00
Singapore 2265886 2265887
Spain 91 640 0085 91 640 0533
Sweden 08 730 49 70 08 730 43 70
Switzerland 056 200 51 51 056 200 51 55
Taiwan 02 377 1200 02 737 4644
United Kingdom 01635 523545 01635 523154
United States 512 795 8248 512 794 5678
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Technical Support Form
Photocopy this form and update it each time you make changes to your software or hardware, a
the completed copy of this form as a reference for your current configuration. Completing this f
accurately before contacting National Instruments for technical support helps our applications 
engineers answer your questions more efficiently.

If you are using any National Instruments hardware or software products related to this problem
include the configuration forms from their user manuals. Include additional pages if necessary.

Name ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

Fax ( ___ ) ________________Phone ( ___ ) ______________________________________

Computer brand____________ Model ___________________Processor _____________________

Operating system (include version number) ________________________________________

Clock speed ______MHz   RAM _____MB Display adapter ________________________

Mouse ___yes   ___no     Other adapters installed ___________________________________

Hard disk capacity _____MB Brand______________________________________________

Instruments used _____________________________________________________________

___________________________________________________________________________

National Instruments hardware product model _____________ Revision  ____________________

Configuration _______________________________________________________________

National Instruments software product ___________________  Version  _____________________

Configuration _______________________________________________________________

The problem is: ______________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

List any error messages: _______________________________________________________

___________________________________________________________________________

___________________________________________________________________________

The following steps reproduce the problem: _______________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________
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IMAQ Hardware and Software Configuration Form
Record the settings and revisions of your hardware and software on the line to the right of eac
Complete a new copy of this form each time you revise your software or hardware configuration
use this form as a reference for your current configuration. Completing this form accurately bef
contacting National Instruments for technical support helps our applications engineers answer
questions more efficiently.

National Instruments Products
IMAQ hardware _____________________________________________________________

Interrupt level of hardware _____________________________________________________

DMA channels of hardware ____________________________________________________

Base I/O address of hardware __________________________________________________

Programming choice _________________________________________________________

IMAQ Vision Builder and NI-IMAQ _______________________________________________

Other boards in system ________________________________________________________

Base I/O address of other boards _______________________________________________

DMA channels of other boards _________________________________________________

Interrupt level of other boards __________________________________________________

Other Products
Computer make and model ____________________________________________________

Microprocessor ______________________________________________________________

Clock frequency or speed ______________________________________________________

Type of video board installed ___________________________________________________

Operating system version ______________________________________________________

Operating system mode _______________________________________________________

Programming language _______________________________________________________

Programming language version _________________________________________________

Other boards in system ________________________________________________________

Base I/O address of other boards _______________________________________________

DMA channels of other boards _________________________________________________

Interrupt level of other boards __________________________________________________
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Documentation Comment Form
National Instruments encourages you to comment on the documentation supplied with our pro
This information helps us provide quality products to meet your needs.

Title: IMAQ™ Vision Builder Tutorial

Edition Date: January 1999

Part Number: 322228A-01

Please comment on the completeness, clarity, and organization of the manual.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

If you find errors in the manual, please record the page numbers and describe the errors.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

Thank you for your help.

Name _____________________________________________________________________

Title ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

E-Mail Address ______________________________________________________________

Phone ( ___ ) __________________________  Fax ( ___ ) ___________________________

Mail to: Technical Publications Fax to: Technical Publications
National Instruments Corporation National Instruments Corporation
6504 Bridge Point Parkway 512 794 5678
Austin, Texas 78730-5039
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Prefix Meaning Value

p- pico- 10–12

n- nano- 10–9

µ- micro- 10– 6

m- milli- 10–3

k- kilo- 103

M- mega- 106

G- giga- 109

t- tera- 1012

Numbers

1D One-dimensional.

2D Two-dimensional.

3D Three-dimensional.

3D view Displays the light intensity of an image in a three-dimensional coordin
system, where the spatial coordinates of the image form two dimensio
and the light intensity forms the third dimension.

A

AIPD National Instruments internal image format used for saving calibration
information associated with an image and for saving complex images.

alpha channel Channel used to code extra information, such as Gamma correction,
an image.

area threshold Detects objects based on their size.

arithmetic operators The image operations multiply, divide, add, subtract, and remainder.
© National Instruments Corporation G-1 IMAQ Vision Builder Tutorial
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auto-median function A function that uses dual combinations of opening and closing opera
to smooth the boundaries of objects.

B

binary image An image containing objects usually represented with a pixel intensit
of 1 (or 255) and the background of 0.

binary morphology Functions that perform morphological operations on a binary image.

blob Binary Large OBject. A connected region or grouping of pixels in an ima
in which all pixels have the same intensity level.

blob analysis A series of processing operations and analysis functions that produce
information about the blobs in an image.

BMP Image format commonly used for 8-bit images on PCs. Also called bitmap.

border function Removes objects (or particles) in a binary image that touch the imag
border.

Builder file IMAQ Vision Builder script file. Builder files are ASCII text files that list
the processing functions and relevant parameters for an image proces
algorithm that you created in IMAQ Vision Builder. 

C

caliper A function that calculates distances, angles, circular fits, and the cent
mass based on positions given by edge detection, particle analysis, 
centroid, and search functions.

circle function Detects circular objects in a binary image.

closing A dilation followed by an erosion. A closing fills small holes in objects a
smooths the boundaries of objects.

color images Images containing color information, usually encoded in the RGB for

color lookup table 
(CLUT)

Table for converting the value of a pixel in an image into a red, green, 
blue (RGB) intensity.
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complex images Save information obtained from the FFT of an image. The complex 
numbers which compose the FFT plane are encoded in 64-bit floating-p
values: 32 bits for the real part and 32 bits for the imaginary part. 

connectivity Defines which of the surrounding pixels of a given pixel constitute its 
neighborhood.

connectivity-4 Only pixels adjacent in the horizontal and vertical directions are consid
neighbors.

connectivity-8 All adjacent pixels are considered as neighbors.

convex function Computes the convex regions of objects in a binary image.

convolution See linear filter.

convolution kernel Simple 3 × 3, 5 × 5, or 7 × 7 matrices (or templates) used to represe
filter in the filtering process. The contents of these kernels are a discre
two-dimensional representation of the impulse response of the filter th
they represent.

D

Danielsson function Similar to the distance functions, but with more accurate results.

definition The number of values a pixel can take on, which is the number of color
shades that you can see in the image.

density function For each gray level in a linear histogram, it gives the number of pixels
the image that have the same gray level. 

device Plug-in data acquisition board that can contain multiple channels and
conversion devices.

differentiation filter Extracts the contours (edge detection) in gray level.

dilation Increases the size of an object along its boundary and removes tiny ho
the object.

distance calibration Determination of the physical dimensions of a pixel by defining the 
physical dimensions of a line in the image.
© National Instruments Corporation G-3 IMAQ Vision Builder Tutorial
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distance function Assigns to each pixel in an object a gray-level value equal to its shor
Euclidean distance from the border of the object.

driver Software that controls a specific hardware device, such as a data acqui
board.

E

edge Defined by a sharp change (transition) in the pixel intensities in an im
or along an array of pixels.

edge contrast The difference between the average pixel intensity before and the av
pixel intensity after the edge.

edge hysteresis The difference in threshold level between a rising and a falling edge

edge steepness The number of pixels that corresponds to the slope or transition are
edge.

equalize function See histogram equalization.

erosion Reduces the size of an object along its boundary and eliminates isola
points in the image. 

exponential and 
gamma corrections

Expand the high gray-level information in an image while suppressing l
gray-level information.

exponential function Decreases the brightness and increases the contrast in bright region
image, and decreases contrast in dark regions.

F

FFT Fast Fourier Transform. A method used to compute the Fourier transf
of an image.

Fourier spectrum The magnitude information of the Fourier transform of an image.

Fourier transform Transforms an image from the spatial domain to the frequency doma

frequency filters Counterparts of spatial filters in the frequency domain. For images, 
frequency information is in the form of spatial frequency. 
IMAQ Vision Builder Tutorial G-4 © National Instruments Corporation
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Gaussian filter A filter similar to the smoothing filter, but using a Gaussian kernel in t
filter operation. The blurring in a Gaussian filter is more gentle than a 
smoothing filter.

grab Acquisition technique that acquires and displays a continuous sequen
images using an IMAQ device. Use this acquisition technique when yo
need to focus your camera.

gradient convolution 
filter

See gradient filter.

gradient filter Extracts the contours (edge detection) in gray-level values. Gradient fi
include the Prewitt and Sobel filters.

gray level The brightness of a point (pixel) in an image.

gray-level dilation Increases the brightness of pixels in an image that are surrounded by
pixels with a higher intensity.

gray-level erosion Reduces the brightness of pixels in an image that are surrounded by
pixels with a lower intensity.

gray-level images Images with monochrome information.

gray-level morphology Functions that perform morphological operations on a gray-level ima

H

highpass attenuation Inverse of lowpass attenuation.

highpass FFT filter Removes or attenuates low frequencies present in the FFT domain o
image.

highpass filter Emphasizes the intensity variations in an image, detects edges (or o
boundaries), and enhances fine details in an image.

highpass frequency 
filter

Attenuates or removes (truncates) low frequencies present in the frequ
domain of the image. A highpass frequency filter suppresses informat
related to slow variations of light intensities in the spatial image.

highpass truncation Inverse of lowpass truncations.
© National Instruments Corporation G-5 IMAQ Vision Builder Tutorial
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histogram Indicates the quantitative distribution of the pixels of an image per 
gray-level value.

histogram equalization Transforms the gray-level values of the pixels of an image to occupy
entire range (0 to 255 in an 8-bit image) of the histogram, increasing t
contrast of the image.

hole filling function Fills all holes in objects that are present in a binary image.

HSL Color encoding scheme in Hue, Saturation, and Lightness.

HSV Color encoding scheme in Hue, Saturation, and Value.

I

image Light intensity as a function of the spatial coordinates f (x, y) where x and y 
denote spatial coordinates and the value f at any point (x, y) is the light 
intensity at that point.

Image Browser IMAQ Vision Builder feature that displays all of the images currently 
loaded. Through the Image Browser, you can select an image that you 
to process by double clicking it.

image buffer Memory location used to store images.

image file A file containing image information and data.

image palette The gradation of colors used to display an image on screen, usually d
by a color lookup table.

image processing Encompasses various processes and analysis functions which you c
apply to an image.

image source Original input image.

image visualization The presentation (display) of an image (image data) to the user.

inner gradient Finds the inner boundary of objects.

inspection functions Detects specific features in an image. The features detected include 
peaks, and rotational shifts.

intensity range Defines the range of gray-level values in an object of an image.
IMAQ Vision Builder Tutorial G-6 © National Instruments Corporation
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intensity threshold Characterizes an object based on the range of gray-level values in th
object. If the intensity range of the object falls within the user specified
range, it is considered an object; otherwise it is considered part of the
background.

interpolation Is the technique used to find values in between known values when 
resampling an image or array of pixels.

K

kernel Structure that represents a pixel and its relationship to its neighbors. T
relationship is specified by weighted coefficients of each neighbor.

L

labeling The process by which each object in a binary image is assigned a un
value. This process is useful for identifying the number of objects in th
image and giving each object a unique identity. 

LabVIEW Laboratory Virtual Instrument Engineering Workbench. Program 
development environment application based on the programming langu
G used commonly for test and measurement applications.

Laplacian filter Extracts the contours of objects in the image by highlighting the varia
of light intensity surrounding a pixel.

line profile Represents the gray-level distribution along a line of pixels in an imag

linear filter A special algorithm that calculates the value of a pixel based on its ow
pixel value as well as the pixel values of its neighbors. The sum of this
calculation is divided by the sum of the elements in the matrix to obtai
new pixel value.

logarithmic and inverse 
gamma corrections

Expand low gray-level information in an image while compressing 
information from the high gray-level ranges.

logarithmic function Increases the brightness and contrast in dark regions of an image, an
decreases the contrast in bright regions of the image.

logic operators The image operations AND, NAND, OR, XOR, NOR, difference, mas
mean, max, and min.
© National Instruments Corporation G-7 IMAQ Vision Builder Tutorial



Glossary

 
alue 

of an 

to 

age. 
ons 

mage 
thers 

g 

se 

 
 

lookup table Table containing values used to transform the gray-level values of an
image. For each gray-level value in the image, the corresponding new v
is obtained from the lookup table.

lowpass attenuation Applies a linear attenuation to the frequencies in an image, with no 
attenuation at the lowest frequency and full attenuation at the highest 
frequency.

lowpass FFT filter Removes or attenuates high frequencies present in the FFT domain 
image.

lowpass filter Attenuates intensity variations in an image. You can use these filters 
smooth an image by eliminating fine details and blurring edges.

lowpass frequency 
filter

Attenuates high frequencies present in the frequency domain of the im
A lowpass frequency filter suppresses information related to fast variati
of light intensities in the spatial image.

lowpass truncation Removes all frequency information above a certain frequency.

L-skeleton function Uses an L-shaped structuring element in the Skeleton function.

M

mask Isolates parts of an image for further processing.

mask image An image containing a value of 1 and values of 0. Pixels in the source i
with a corresponding mask image value of 1 are processed, while the o
are left unchanged.

median filter A low pass filter that assigns to each pixel the median value of its 
neighbors. This filter effectively removes isolated pixels without blurrin
the contours of objects.

morphological
transformations

Extract and alter the structure of objects in an image. You can use the
transformations for expanding (dilating) or reducing (eroding) objects, 
filling holes, closing inclusions, or smoothing borders. They mainly are
used to delineate objects and prepare them for quantitative inspection
analysis.

M-skeleton Uses an M-shaped structuring element in the skeleton function.
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neighborhood 
operations

Operations on a point in an image that take into consideration the value
the pixels neighboring that point.

nonlinear filter Replaces each pixel value with a nonlinear function of its surrounding
pixels.

nonlinear gradient filter A highpass edge-extraction filter that favors vertical edges.

nonlinear Prewitt filter A highpass edge-extraction filter that favors horizontal and vertical ed
in an image.

nonlinear Sobel filter A highpass edge-extraction filter that favors horizontal and vertical ed
in an image.

Nth order filter Filters an image using a nonlinear filter. This filter orders (or classifies)
pixel values surrounding the pixel being processed. The pixel being 
processed is set to the Nth pixel value, where N is the order of the filter.

number of planes 
(in an image)

The number of arrays of pixels that compose the image. A gray-level o
pseudo-color image is composed of one plane, while an RGB image is
composed of three planes (one for the red component, one for the blue
one for the green).

O

opening An erosion followed by a dilation. An opening removes small objects 
smoothes boundaries of objects in the image.

operators Allow masking, combination, and comparison of images. You can use
arithmetic and logic operators in IMAQ Vision.

outer gradient Finds the outer boundary of objects.
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palette The gradation of colors used to display an image on screen, usually de
by a color lookup table.

Parameter window Displays parameters that you can set for an image processing functi
Each IMAQ Vision function available through the menus has a parame
window where you set the parameters for that function. 

picture element An element of a digital image. Also called pixel.

pixel Picture element.

pixel calibration Directly calibrating the physical dimensions of a pixel in an image.

pixel depth The number of bits (n) used to code the intensity of a pixel. For a given n, 
a pixel can take 2n different values. For example, if n equals 8-bits, a pixel 
can take 256 different values ranging from 0 to 255. If n equals 16 bits, a 
pixel can take 65,536 different values ranging from 0 to 65,535 or –32,
to 32,767. 

Power 1/Y function Similar to a logarithmic function but with a weaker effect.

Power Y function See exponential function.

Prewitt filter Extracts the contours (edge detection) in gray-level values using a 3 ×
filter kernel.

probability function Defines the probability that a pixel in an image has a certain gray-leve
value.

Processing window IMAQ Vision Builder feature that updates the image as you change 
parameters. The Processing window is located on the right side of the
IMAQ Vision Builder window.

proper-closing A finite combination of successive closing and opening operations tha
can use to fill small holes and smooth the boundaries of objects.

proper-opening A finite combination of successive opening and closing operations tha
can use to remove small particles and smooth the boundaries of objec

Q

quantitative analysis Obtaining various measurements of objects in an image.
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Reference window IMAQ Vision Builder feature that displays the original version of the im
(image source) as you manipulate it in the processing window. The 
Reference window appears in the upper left corner of the IMAQ Vision
Builder window.

region of interest An area of the image that is graphically selected from a window displa
the image. This area can be used focus further processing. Also calledROI.

resolution The number of rows and columns of pixels. An image composed of m rows 
and n columns has a resolution of . This image has n pixels along its 
horizontal axis and m pixels along its vertical axis.

Reverse function Inverts the pixel values in an image, producing a photometric negativ
the image.

RGB Color image encoding using red, green, and blue colors.

RGB chunky Color encoding scheme using red, green, and blue (RGB) color inform
where each pixel in the color image is encoded using 32 bits: 8 bits for 
8 bits for green, 8 bits for blue, and 8 bits for the alpha value (unused)

Roberts filter Extracts the contours (edge detection) in gray level, favoring diagona
edges.

ROI Region of interest.

ROI tools Collection of tools from the Tools palette that enable you to select a re
of interest from an image. These tools let you select a point or line; 
polygon, rectangle, and oval regions; and freehand lines and areas.

S

script List of image processing and analysis functions and the parameters for
of those functions. IMAQ Vision Builder records each function and 
relevant parameters as you prototype your image processing applicati

Script window The window in which IMAQ Vision Builder displays a script. From the 
scripting window, you can edit, remove, or add steps and run scripts. T
Script window appears in the lower left corner of the IMAQ Vision Builde
window.

m n×
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segmentation function Fully partitions a labeled binary image into non-overlapping segmen
with each segment containing a unique object.

separation function Separates objects that touch each other by narrow isthmuses.

sequence Acquisition technique that acquires images according to settings tha
specify in the acquisition property pages.

shape matching Finds objects in an image whose shape matches the shape of the o
specified by a template. The matching process is invariant to rotation a
can be set to be invariant to the scale of the objects.

Sigma filter A highpass filter that outlines edges.

skeleton function Applies a succession of thinning operations to an object until its widt
becomes one pixel.

skiz function Obtains lines in an image that separate each object from the others a
equidistant from the objects that they separate.

smoothing filter Blurs an image by attenuating variations of light intensity in the 
neighborhood of a pixel.

snap Acquisition techniques that acquires and displays a single image.

Sobel filter Extracts the contours (edge detection) in gray-level values using a 
3 × 3 filter kernel.

spatial calibration Assigning physical dimensions to the area of a pixel in an image.

spatial filters Alter the intensity of a pixel with respect to variations in intensities of 
neighboring pixels. You can use these filters for edge detection, image
enhancement, noise reduction, smoothing, and so forth.

spatial resolution The number of pixels in an image, in terms of the number of rows an
columns in the image.

Square function See exponential function.

Square Root function See logarithmic function.
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structuring element A binary mask used in most morphological operations. A structuring
element is used to determine which neighboring pixels contribute in th
operation.

sub-pixel analysis Used to find the location of the edge coordinates in terms of fractions
pixel.

T

template Pattern or shape that you are trying to match in an image using the 
search-shape matching function or the search-correlate function. A 
template can be a region selected from an image or it can be an entire
image.

thickening Alters the shape of objects by adding parts to the object that match th
pattern specified in the structuring element.

thinning Alters the shape of objects by eliminating parts of the object that matc
the pattern specified in the structuring element.

threshold Separates objects from the background by assigning all pixels with 
intensities within a specified range to the object and the rest of the pix
to the background. In the resulting binary image, objects are represen
with a pixel intensity of 255 and the background is set to 0.

threshold interval Two parameters, the lower threshold gray-level value and the upper 
threshold gray-level value.

TIFF Image format commonly used for encoding 8-bit and 16-bit images an
color images on both Macintosh and PC platforms.

Tools palette Collection of tools that enable you to select regions of interest, zoom in
out, and change the image palette.
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Numerics
3D View function, 1-4

A
absolute value (threshold), 4-3
acquiring images

grab (continuous image), 2-10
opening the Interface window, 2-8
property pages, 2-9
region of interest, 2-10
sequence, 2-11
snap (single image), 2-10
in StillColor, 2-9

Acquisition window, 1-3
analyzing blobs, 3-9

B
batch processing, 1-3, 4-11
blob, 3-1
blob analysis

definition, 3-1
filtering, 3-4
implementing in LabVIEW, 3-12 to 3-13
introduction, 3-1
LabVIEW block diagram, 3-13
morphology, 3-7
opening images, 3-2
particle analysis, 3-9
particle filter, 3-8
preparing images for processing, 3-2 to 3-5
saving the script, 3-12
testing the script, 3-10 to 3-11
thresholding, 3-5 to 3-6

Browser
See Image Browser.

Builder file, 1-3, 3-12, 4-11
bulletin board support, A-1

C
Caliper function, 1-5, 4-8 to 4-10
Choose Measurements button, 3-9
circle detection, 4-7
Circle Detection function, 1-5
closing IMAQ Vision Builder, 1-2
Clustering function (threshold), 4-6
color images, 2-3
complex images, 2-3
customer communication, xi, A-1 to A-7

D
definition, 2-2
documentation

conventions used in this manual, x
organization of this manual, ix
related documentation, x, 1-5

drawing straight lines, 4-4

E
Edge Detector, 1-4, 4-3
electronic services, A-1 to A-2
e-mail support, A-2
Excel, using with IMAQ Vision 

Builder, 3-9, 4-12
exiting IMAQ Vision Builder, 1-2

F
fax support, A-2
features of IMAQ Vision Builder, 1-3
Fill holes function, 3-7
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filtering images, 1-4, 3-4
finding edges, 4-3 to 4-5
finding the center of a particle, 4-6 to 4-7
FTP support, A-1
full-size view (Image Browser), 2-4

G
gauging

analyzing results, 4-11 to 4-12
batch processing, 4-11
circle detection, 4-7
definition, 4-1
finding edges, 4-3 to 4-5
finding the center of a particle, 4-6 to 4-7
introduction, 4-1 to 4-2
making measurements, 4-8 to 4-10
morphology, 4-6
restoring the original image, 4-8
storing the original image, 4-5
thresholding, 4-6

getting help, 1-5 to 1-6
getting started in IMAQ Vision Builder, 

2-3 to 2-8
grab, 2-8
grabbing an image, 2-10
gray-level images, 2-3

H
help

IMAQ Vision Builder scripts, 1-6
IMAQ Vision documentation, 1-5
National Instruments Web site, 1-6
online help, 1-5

Heywood Circularity Factor particle filter, 3-8
histogram, 1-4, 2-6 to 2-7, 3-5

I
image analysis functions, 1-4
Image Browser

accessing from the toolbar, 3-10
definition, 1-3
full-size view, 2-4
important elements (figure), 2-4
thumbnail view, 2-4

image buffer, 4-5, 4-8
image processing functions, 1-4
images

color, 2-3
complex, 2-3
definition, 2-1, 2-2
gray-level, 2-3
number of planes, 2-2
opening in IMAQ Vision 

Builder, 2-3 to 2-4
pixel depth, 2-2
properties, 2-1
resolution, 2-1
types, 2-3

IMAQ hardware, 1-1, 2-8
IMAQ Particle Filter VI, 3-13
IMAQ Vision Builder

acquiring images, 2-8 to 2-11
environment, 1-3
using with Excel, 3-9
exiting, 1-2
features, 1-3
getting started, 2-3 to 2-8
image analysis functions, 1-4
image processing functions, 1-4
installing, 1-2
using with LabVIEW, 3-9
using with LabWindows/CVI, 3-9
launching, 1-2
machine vision functions, 1-4
online help, 1-5
IMAQ Vision Builder Tutorial I-2 © National Instruments Corporation



Index
sending data to Excel, 4-12
system requirements, 1-1
using with LabVIEW, 3-12
using with LabWindows/CVI, 3-12
using with Visual Basic, 3-12, 3-9

IMAQ Vision documentation, 1-5
implementing scripts, 3-12
installing IMAQ Vision Builder, 1-2
Interface window (acquisition), 1-3, 2-8, 2-9
isolating blobs, 3-8

L
Label objects function, 4-6
LabVIEW, 3-9, 3-12
LabWindows/CVI, 3-9, 3-12
launching IMAQ Vision Builder, 1-2
line profile, 1-4, 3-3, 4-4

M
machine vision functions, 1-4
magnifying an image, 4-8
manual

See documentation.
morphology, 1-4, 3-7

N
National Instruments Web site, 1-6
NI-IMAQ, 1-1, 2-8
number of planes, 2-2

O
online help, 1-5
opening images, 2-3 to 2-4, 3-2, 4-2 to 4-3

P
Parameter window, 1-3
part inspection, 4-1 to 4-12
particle analysis, 1-4, 3-9
particle filter, 1-4, 3-8
pixel (definition), 2-1
pixel depth, 2-2
processing mode, 2-5
Processing window, 1-3, 2-5

R
Reference window

definition, 1-4
purpose, 2-5
using to browse images, 3-10

relative value (threshold), 4-3
Remove border objects function, 3-7, 4-6
resolution, 2-1
restoring an image from an image buffer, 4-8
Run Script button, 2-8, 3-10, 3-11

S
scripting

batch processing, 4-11
description, 1-3
using example scripts, 1-6
implementing Builder files, 3-12
modifying scripts, 3-11
opening scripts, 2-8
Run Script button, 2-8, 3-10, 3-11
saving scripts, 2-8, 3-12
Script window, 1-3, 2-8
testing scripts, 3-10

search-correlate, 1-4
Select All Files option, 3-2, 4-3
Send Data to Excel button, 3-9
separating particles from background, 3-5
sequence, 2-8
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sequence acquisition, 2-11
Sequence property page, 2-11
shape matching, 1-5
Show Labels option, 3-9
Simple Edge tool, 4-3
simulation module, 2-10
snap, 2-8
snapping an image, 2-10
StillColor acquisition, 2-9
storing an image, 4-5
system requirements, 1-1

T
technical support, A-1 to A-2
telephone support, A-2
testing scripts, 3-10
Three-Dimensional View function, 1-4
thresholding

clustering threshold, 4-6
definition, 1-4
manual threshold, 2-6 to 2-7, 3-5 to 3-6
modifying threshold parameters, 

3-10 to 3-11
threshold levels, 4-3

thumbnail view (Image Browser), 2-4
Tools Palette, 1-4
tutorials

blob analysis, 3-1 to 3-13
gauging, 4-1 to 4-12

V
VI, IMAQ Particle Filter, 3-13
Visual Basic, 3-9, 3-12

W
windows

Acquisition, 1-3
Parameter, 1-3
Processing, 1-3, 2-5
Reference, 1-4, 2-5, 3-10
Script, 1-3, 2-8

Z
Zoom In tool, 4-8
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