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Conventions

The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also emphasizes lines of code 
that are different from the other examples.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.
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1
Introduction to Lookout

This chapter explains how to install and run Lookout and describes the 
basics of the Lookout environment. 

Hardware and Software Requirements
Lookout requires the following:

• Pentium class or equivalent PC running at 90 MHz or faster

• At least 32 MB RAM

• 65 MB free disk space, plus possibly 100 MB or more, depending 
on how much historical data you intend to log to the Citadel database; 
you should also have about 50 MB of disk space for file swapping on 
Windows 2000/NT/XP computers

• Windows 2000, Windows NT version 4 or later, Windows XP, or 
Windows Me/98; National Instruments strongly recommends using 
Windows 2000/NT/XP for optimum stability

• If you plan to install the Historical Data Viewer along with Lookout, 
and you are running Windows NT, you must have service pack 6 or 
later installed

• Monitor display setting of at least 800 × 600 pixels

• Network card and TCP/IP networking installed on the computers 
you want to connect, if you intend to take advantage of Lookout 
networking

Note Performance of Lookout depends on the number, size, and complexity of processes 
you are running. While the minimum requirements are fine for some processes, you should 
plan on using more powerful computer configurations for complex and data intensive 
applications.

• You must be properly set up on a network with TCP/IP protocols 
installed if you want to use the networking capabilities of Lookout. 
You must be able to ping any computer on your network that you 
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intend to have as a part of your Lookout network. To test this, access 
a command prompt and enter the following command:

Ping compname

where compname is the name of the computer you want to ping.

If TCP/IP is functioning properly on your computer, you should 
receive a response that looks something like the following example:

Pinging compname [123.45.67.89] with 32 bytes of data:

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

If TCP/IP is not working properly on your computer, consult your 
system administrator. Refer to Chapter 5, Networking and Running 
an Application, for more information on networking and network 
configuration with Lookout.

Tip If your computer does not have a command prompt available in the Windows Start 
menu or in Start»Programs, select Start»Run and enter command.com in the Run dialog 
box. This opens a command prompt you can use for the ping command.

Installing Lookout
This section describes how to install Lookout. For more information about 
upgrading from earlier versions of Lookout, refer to the release notes for 
this version of Lookout.

1. Shut down all applications that may currently be using ODBC such as 
spreadsheets, word processors, database programs, MS Query, and 
similar applications.

2. Insert the Lookout CD into your CD drive.

3. The Lookout CD-ROM has autorun capability. If for some reason the 
autorun fails to start the CD installation routine, select Start»Run 
and enter N:\Lookout\setup.exe where N represents your 
CD-ROM drive. (To install the free client version, enter 
N:\Free_Client\setup.exe. To install the Lookout Player, 
enter N:\LookoutPlayer\lk51_web.exe.) Then click OK.
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Choosing a custom installation provides you with certain installation 
options, including the following:

• Lookout allows you to choose whether to install its help. Use 
Browse to enter the name of an alternate directory or click Next 
to accept the recommended directory name.

• During installation, Lookout can install its ODBC driver. Make 
sure you select the Citadel ODBC option if you want to be able 
to access Lookout’s Citadel database.

• When installing Lookout on a Windows 2000/NT/XP system, you 
are presented with a list of options on what you may install. Make 
sure you install the optional NT keyboard driver under 
Windows NT if you want to be able to block unauthorized users 
from using certain keyboard commands such as <Alt-Tab> to 
switch out of Lookout.

4. Follow the remaining instructions to complete the Lookout 
installation.

Registering Lookout
If this is your first installation of Lookout on the computer you are using, 
or if you have any lost or corrupted your registration information, then the 
first time you launch Lookout, it prompts you for registration information.
Be sure to register your Lookout Package to receive your permanent unlock 
code. As an unregistered package, Lookout is limited to 50 I/O points and 
one client connection, and runs for only 30 days.

When you register Lookout, you unlock it for permanent use at your 
appropriate I/O count. If you do not register Lookout by the end of the 
30 day period, it lapses to a demo system. You must complete the 
registration form and send it to National Instruments in order to register 
Lookout. When we receive your registration form, National Instruments 
generates a keycode to unlock Lookout and faxes or mails it to you. You 
also can get your keycode through the Internet at ni.com/keycode. If you 
have not registered your copy of Lookout, you are guided through the 
registration. If you have not yet created your personal profile, you must do 
so before you can register Lookout. 

Lookout requires a hardware key in some countries. Contact 
National Instruments if you are not sure whether your system requires 
a hardware key. If you were supplied a key with Lookout, be sure to plug 
it into the parallel port on your computer before activating Lookout. 



Chapter 1 Introduction to Lookout

Lookout Operator’s Manual 1-4 ni.com

Starting Lookout for the First Time
1. Launch Lookout by selecting Start»Programs»National 

Instruments Lookout.

A dialog box appears asking you to register Lookout. If you are ready 
to register Lookout, click Enter new keycode. The registration dialog 
box appears.

2. Enter your name in the Name field.

3. Enter the Organization name exactly as it appears with the keycode 
information sent in response to your registration, including 
punctuation marks. This text is used in combination with the keycode, 
so it must be exact.

(If you have not yet received your keycode from National Instruments, 
you can enter your registration data later. Select OK and Lookout will 
inform you that you have not registered your package yet. Select OK 
again until Lookout launches.) 

4. Enter the Serial Number of your package. (This can be found on your 
registration form.)

5. Enter your 12-character Keycode. The keycode is not case sensitive 
and you can leave the hyphens out if desired. Notice that there are no 
spaces near the hyphens.
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6. Click OK.

If you enter the proper information correctly, Lookout appears on your 
screen with no process running. If you are certain that you typed the 
information correctly and Lookout does not accept it, contact National 
Instruments for assistance.

Changing I/O Count Registration
If you want to change the number of Lookout I/O points you are using, 
or make other changes in system capabilities or client connections, first 
contact National Instruments to obtain a new Lookout keycode. Then select 
Options»System»Change Registration Info and enter the new keycode.

Adding Client Connections
You are limited in the number of client connections you are allowed to 
maintain in Lookout. You can add or remove client licenses from any copy 
of Lookout. For example, if you have a copy of Lookout running a server 
process with two clients connected and need to increase the number of 
client connections to three, you need only get a license for one more client 
connection, and enter that new license code. 

Note If you are logged on to a Windows 2000/NT/XP computer as Guest or Restricted 
User, certain Lookout tasks will not work correctly, because they require writing to the 
registry or WINNT folder. These tasks include creating a user account, adding a client 
license, and registering a Logos computer.

1. To add or change client connection information in Lookout, select 
Options»System from the menu, and click the Change Client 
License button. Click the Add button. The following dialog box 
appears.
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2. Enter your Organization name as you reported it in your registration 
request. Enter the Serial Number and the License Code you received. 
Click OK.

If your registration attempt fails, check to make sure you entered all of the 
information correctly. Contact National Instruments if correcting these 
entries does not fix the problem.

A newly installed version of Lookout will run with one client connection 
for 30 days before reverting to demo program mode.
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Lookout Environment
Figure 1-1 shows a Lookout screen.

Figure 1-1.  Lookout Environment

Depending on the security access level of the user logged in to Lookout, 
certain menus and tools may be unavailable. Refer to the Lookout Help for 
more information about Lookout Menu Commands.

1 Menu Bar
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Menu Bar
The menu bar displays the currently available menu commands, which 
change depending on whether Lookout is in run mode, edit mode, or is open 
without any processes running. These commands may or may not be 
available to the operator, depending on his or her security level.

Status Bar
When Lookout is in run mode, the status bar is gray. The time and date are 
displayed on the left end of the bar. The account name of the currently 
logged on operator comes next. The company name as entered during 
registration appears in the middle, and the alarm status is on the right end 
of the status bar. The control panel navigation arrows, which scroll through 
various control panels, may or may not be visible, depending on your 
system options settings.

Lookout Workspace
The workspace is the area in which you view and operate control panels. 
The visible workspace on your screen is only a window into the Lookout 
virtual workspace. If control panels or their associated icons are partially 
or completely outside the visible workspace, Lookout automatically 
displays horizontal and vertical scroll bars.

Control Panels
Control panels provide the display area for any switches, knobs, bar graphs, 
digital displays, trend graphs, and other components that you want to use to 
monitor and control your operations. 

You can move the panels around the screen by grabbing the title bar of a 
panel with the mouse cursor and dragging it to a new location. There is 
no limit on the number of control panels you can create or the number of 
objects displayed on any one panel.

There are three types of control panels: normal, pop-up, and pop-up with 
no icon. A normal control panel can be maximized, normal size, or 
minimized within the Lookout workspace. Control panels can also 
“pop up” when an event occurs, such as when a push button is pressed or 
when an alarm is activated. When a pop-up control panel is displayed, it 
remains on top of all other panels until you minimize it.
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Alarms Window
You can choose how the Alarms Window is displayed by selecting 
Alarms»Display Options. In Figure 1-1, the Alarms Window is set to 
display at the bottom of the workspace.

Operator Input and Navigation
Operators may navigate using a mouse, trackball, touchscreen, or 
keyboard. When the cursor moves over a controllable object, the cursor 
turns into a hand, indicating you now have control of the object. 
Controllable objects include such things as Switches, Pots, and 
Pushbuttons.

When using a keyboard, the arrow keys move the cursor around the screen. 
The <Tab> key jumps the cursor from one controllable object to another, 
and the <Space> bar acts as the left mouse button, so you can click a 
controllable object without actually using a mouse.

Virtual Keypad
When you are in run mode, you can click a digital Pot control and bring up 
a virtual keypad to enter numeric values, either with a mouse or a 
touchscreen.

Virtual Keyboard
Lookout also has a virtual keyboard you can use with a touchscreen or a 
mouse.

To enable the virtual keyboard, select Options»System and then check 
Left Mouse Click or Right Mouse Click in the Virtual Keyboard 
Pops Up section of the dialog box.
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When this feature is enabled, clicking in a data entry field or touching 
the field on a touchscreen displays the virtual keyboard, as shown in the 
following illustration.

Setting System Options
You can configure certain system options in Lookout that determine the 
way your version of Lookout operates. Select Options»System from 
the menu bar. The System Options dialog box appears as shown in the 
following figure. Some default settings may be different for your computer.

Note Only users logged on with security levels of 9 or greater can access the System 
Options dialog box.
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• If security level is below (0-9)—You can set local limits on how 
Lookout runs when users with different security levels are logged on. 
Use these selection boxes to set these limits. Refer to Chapter 4, 
Security, for full details on the security features of Lookout.

• Log alarms to—If you have a printer directly connected to your 
computer, you can direct that all alarms be printed when they occur. 
Set this field to the communications port to which your printer is 
connected. Refer to Chapter 3, Alarms and Events, for information on 
the alarm and event logging features of Lookout. 

• Virtual Keyboard Pops Up On—Lookout features a virtual keyboard 
that you can access by clicking a control that accepts a text or numeric 
input. You can set whether a right-click or a left-click pops up this 
keyboard.

• Show panel navigation arrows in status bar—Select this checkbox 
if you want to use panel navigation arrows. These arrows, which 
appear in the right side of the status bar, activate control panels in the 
order in which you last accessed them. This feature is most convenient 
when you have a large number of control panels in a process and need 
to cycle through a subset of them several times in a short period 
of time.
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• Computer Name—This field shows the network name of the 
computer you are working on. If this field is blank, and you intend to 
use the networking capability of Lookout, you need to check your 
network settings to make sure your computer is properly named for 
network operations.

• Citadel Database—These fields set the default destination for 
historical data logged by Lookout. All processes running under a 
single instance of Lookout will use this data path to log data to Citadel, 
unless this setting was overwritten when the process was created.

You set the Default Path and the Default Computer separately. Use 
the complete path for the Default Path setting, and the fully qualified 
computer name for the Default Computer setting.

• Change Registration Info and Change Client License—Click these 
buttons to enter new registration or license information.



© National Instruments Corporation 2-1 Lookout Operator’s Manual

2
Serial COM Port Communication

This chapter describes how Lookout regulates serial port usage so that 
objects gain access to serial ports in an orderly and timely fashion.

Defining Serial COM Port Settings
Complete the following steps to configure serial port settings for 
hardwired, radio, and dial-up communications.

Note You must define serial port communication settings on every copy of Lookout. 
If you have more than one instance of Lookout running on the same computer, each 
instance must use a different serial port. 

Because multiple Lookout instances cannot share the same serial port, if it is necessary 
for two processes to access the same serial port, they need to be run in the same Lookout 
instance. If you are designing a system with multiple server process files, and those server 
files all access the same serial port on a single computer, they need to be run in the same 
Lookout instance.

1. In Lookout, select Options»Serial Ports. The Serial Port Settings 
dialog box appears. 
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2. In the Serial port field, select the communication port you are 
defining. Microsoft Windows supports up to 64 serial ports; however, 
most computers support only two serial ports without additional 
hardware. 

3. Define the serial port configuration for the appropriate communication 
port. The rest of this chapter contains complete descriptions of the 
configuration options.

4. Click Accept to save the configuration for the serial port.

5. Click Quit to exit.

Setting Receive Gap
The Receive gap setting is available for all serial connection types. 
This number specifies the number of empty bytes (or amount of time) a 
driver receives from a controller before the driver recognizes the end of a 
message frame and asks for another message. Normally you should leave 
this at the default setting of 20. However, if you are experiencing garbled 
communication alarms, you might try increasing this number to as high as 
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100 to allow more time before Lookout decides it has received a complete 
message. 

Selecting the Serial Connection

Hardwired Serial Connection
Hardwired serial connections require no hardware handshaking for line 
control. Use this setting for all serial communication types except dial-up 
telephone and remote radio transceivers. You should also use this setting 
when directly connecting Lookout to the master repeater on a radio system 
or through a leased-line modem. Because a master repeater is a full-duplex 
device that does not require keying and unkeying of the frequency, it acts 
much like a physically hardwired network. Other hardwired connection 
types include RS-232, RS-422, RS-485, and leased telephone lines.

Dial-Up Serial Communication
Use the Dial-up serial connection when you use a modem in conjunction 
with a switched telephone line (not leased line). You can customize the 
dial-up settings for your particular modem and phone line.

The default Dialing prefix settings are based on the Hayes Corporation 
AT command set, which is an industry standard for data modems. Table 2-1 
explains the Lookout default settings. For additional commands, refer to 
your modem operation documentation. 

 

When you use an external dial-up modem with Lookout, the DTR line in 
your cable between the modem and the computer must be wired straight 
through. This line is pin 20 on a 25-pin RS-232 connector and pin 4 on 

Table 2-1.  Dialing Prefix

Prefix Description

AT Attention code that must precede all commands

Xn Result code and dialing options: X4 waits for dial tone 
before dialing, and recognizes busy signal

Mn Speaker on or off: M for speaker always off

Vn Verbal or numeric result codes: V for numeric result codes

En Local echo mode: E for no echo

D Dial phone number with modifiers: P for pulse; T for tone



Chapter 2 Serial COM Port Communication

Lookout Operator’s Manual 2-4 ni.com

a 9-pin connector. Lookout uses the DTR line to command the modem to 
disconnect (hang up) and return to the command mode.

Some factory modems are not configured to respond to the DTR line. After 
Lookout first successfully dials out to a remote modem and finishes the 
polling cycle, it drops the DTR line but the modem remains connected. If 
the modem does not respond after several seconds of Lookout attempting 
to raise and drop the DTR line, Lookout generates an alarm stating that the 
modem is not responding. If you receive this alarm message, your modem 
is not configured to monitor the DTR line.

The Hayes Corporation standard command for configuring the modem to 
hang up and enter command mode upon loss of DTR is &D2. You can use 
a terminal program to make this setting permanent on most modems by 
entering the modem command AT&D2&W to store the setting permanently 
in nonvolatile modem memory. Or you can just add &D2 into the Dialing 
prefix. The default Dialing prefix is ATX4MVEDT, so you might change it 
to AT&D2X4MVEDT.

Retries specifies the number of times Lookout dials the specified phone 
number and attempts to connect to the modem at the other end of the line. 
If Lookout fails to connect after the specified Retries, it generates an alarm 
and moves on to the next phone number in the polling queue (if a queue 
has formed).

Wait for connection specifies the length of time Lookout waits to receive 
a connect signal back from the modem it is calling. The time period begins 
when Lookout first sends the local modem the dialing prefix command. The 
time should be long enough for the local modem to receive a dial tone, dial 
the phone number, allow the remote modem to pick up the line, and send 
back a connect message. If the specified time is too short, your system 
could be operating correctly but never make a connection.

Pause between calls is the length of time Lookout waits after hanging 
up before it sends the local modem the next dialing prefix signal. If the 
specified time is too brief, your system might not hang up the existing call 
but still attempt to call the next number.

Note Your specific modems, radios, and local phone lines might operate faster or slower 
than the default settings. You might need to use a trial-and-error approach to find the best 
settings for your system.

For information about troubleshooting dial-up connections, refer to the 
NI Developer Zone resources at ni.com/zone.
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Radio (RTS/CTS) Serial Connection
RTS/CTS is a local hardware handshaking mechanism between the local 
computer and the local communication device. Use the Radio (RTS/CTS) 
serial connection when you connect the serial port to a device that requires 
RTS/CTS hardware handshaking, such as a radio transceiver that must be 
keyed up during data transmission and unkeyed during data reception. 
Other half-duplex communication media, such as RS-485, might require 
RTS/CTS hardware handshaking. Although the RTS/CTS scheme works 
identically for other RTS/CTS communication schemes, this example 
assumes that you are communicating through radio.

When you select RTS/CTS hardware handshaking, Lookout controls the 
RTS, or request-to-send pin, and monitors the CTS, or clear-to-send pin, 
during data transmission (pins 4 and 5 on a 25-pin RS-232 connector). 
Therefore, you must have at least the RTS pin (pin 4) wired straight 
through on your RS-232 cable. The CTS pin (pin 5) is optional.

Lookout initiates a serial transmission on an RTS/CTS port by first 
asserting RTS to key the radio. Lookout then begins monitoring the state 
of the CTS pin. When the radio transmitter is fully keyed and ready to 
transmit, the radio asserts CTS and Lookout immediately begins data 
transmission. If the radio does not assert CTS within the CTS timeout 
setting (default is 100 ms), Lookout assumes the radio is ready to transmit 
and transmits anyway.

The CTS timeout setting is the maximum amount of time that Lookout 
waits after asserting RTS for CTS before transmitting. Most radios 
typically take between 10 and 80 milliseconds to key up. Consult your radio 
specifications and DIP switch settings to determine the key-up delay on 
your radio.

If your radio can assert CTS when it is ready to transmit, add about 
50 milliseconds to the radio key-up delay specification and use this total 
value for the CTS timeout. If your radio does not assert CTS, you should 
begin by adding about 20 milliseconds to your radio key-up time. Then, 
increase this value in 10 millisecond increments until the remote radio 
begins to correctly receive the first bytes of the message.

Some radios might assert CTS before they are actually ready to transmit. In 
this case, disconnect the CTS line (pin 5 on a 25-pin RS-232 connector) and 
set the CTS timeout to a value high enough to let the radio fully key before 
transmission.
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After it transmits the last byte of data, Lookout continues to assert RTS, 
keeping the radio keyed until the RTS delay off time period expires. You 
should set this value to the default of zero milliseconds so that Lookout 
unkeys the radio as soon as possible to prepare to receive the response.

When unkeyed, most radios generate an audible squelch tail that the remote 
device might decode as unexpected garbage bytes. Some remote devices 
reject the entire message instead of just decoding the valid data and 
ignoring the extra garbage bytes. In this case, keep the radio keyed for 
several milliseconds using the RTS delay off setting. This time period 
delays the squelch tail long enough for the remote device to recognize 
the last data frame as valid before receiving garbage bytes caused by the 
squelch tail.

If you set the RTS delay off setting too high, the remote device begins 
transmitting its response before the local radio is unkeyed, causing a 
communication alarm in Lookout.

Serial Port Hangup
You can configure your serial port to use +++ATH hangup as well as DTR 
hangup. Every serial port you have configured will have a configuration 
section in the lookout.ini file under the port name, such as [COM1]. 
Add the following entry to the file to set your hangup mode: 

DTR_Hangup=N

When N=1 (default), that port uses DTR hangup. When N=0, the port uses 
+++ATH hangup.

Diagnosing Serial COM Port Problems
You can create serial port diagnostic files to help solve serial port 
communication problems. 

1. Select Options»Serial Ports.

2. Check the Enable checkbox. 

3. Enter the File name to which you want Lookout to log 
communications, as shown in the following illustration. If you enter a 
file name only, Lookout creates the file in the Lookout directory. You 
can create a diagnostic file for each serial port you have configured. If 
you use the same file name for each port, all messages are logged to 
the same file.
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4. If you want timestamps for each communication, check the 
Timestamp Enable checkbox and choose a Timestamp Format. 

5. To log all parts of a message in hexadecimal, select the Value in HEX 
checkbox. Otherwise, printable characters print as their character 
representation instead of in hex format. International characters are 
logged as two bytes (printable or non-printable). 

The serial diagnostic file is a text file consisting of requests and replies. 
Any byte that can be represented by a printable character is displayed 
as the character, unless the Value in HEX checkbox was checked. All 
non-printable bytes are represented by their hex codes enclosed in square 
brackets. The following text shows how a typical request and reply might 
appear.

Modbus1 ->

[01][03][00][00][00][02][C4][0B]

Modbus1 <-

[01][03][04][00]A[00][00][AA]'
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In the first line, the Modbus1 object sent out (->) a message, the message 
shown in line two. The third line shows that Modbus1 received (<-) a 
message, the message in line four. 

If timestamps are enabled for each message, you can match messages in 
the diagnostic file with alarms in the Alarms Window. A logged 
communication with timestamps enabled might look like the following:

09/27/2001 15:08:12 - Modbus1 ->

[01][03][00][0A][00][01][A4][08]

The diagnostic file might expose a missing reply from the hardware, as in 
the following example:

Modbus1 ->

[01][03][00][0A][00][01][A4][08]

Modbus1 ->

[01][03][00][0A][00][01][A4][08]

Modbus1 ->

[01][03][00][0A][00][01][A4][08]
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3
Alarms and Events

This chapter describes Lookout alarms and events. 

An event can be anything that happens within the Lookout environment, 
such as adjusting a control, entering or leaving edit mode, or logging in and 
out. An alarm in Lookout denotes an abnormal condition and must be 
acknowledged by the operator.  For the purposes of logging and retrieval, 
events and alarms are combined. 

Selecting Processes to Monitor for Alarms
Before you can monitor alarms or events from processes running on other 
computers, you must add them to the list of processes that your monitoring 
computer is tracking. Complete the following steps to select other 
processes to monitor for alarms.
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1. Select Alarms»Select Processes. The following dialog box appears.
 

2. Navigate to the process you want to monitor in the Available 
Processes list, click the process, and click the Add button. (If you do 
not see the computer that is running the process you want to monitor, 
right-click the Network node, and select Register Computer.)

3. To stop monitoring a process, select the process in the Selected 
Processes list and click the Delete button.

4. Click OK.

Viewing Alarms and Events
You can view recent or active alarms and events in the Alarms Window in 
Lookout. You can also view historical alarm and event information that has 
been logged, using the Historical Data Viewer in MAX (National 
Instruments Measurement and Automation Explorer). 
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Viewing Alarms and Events in the Alarms Window
The Alarms Window lists all active and unacknowledged alarms and/or 
events. Alarms are listed in chronological order with the most recent alarm 
at the top of the list. If there are too many alarms to see at once, you can use 
the scroll bar at the right of the Alarms Window to scroll through the list.

 

If you have your Alarms Window minimized, you can view it by pressing 
<Ctrl-A>, selecting Alarms»Show, or clicking the alarm indicator box on 
the far right side of Lookout status bar, at the bottom of the screen. The 
number of alarms and events currently shown in the Alarms Window is 
displayed in the alarm indicator box. 

To quickly identify alarm status, use the Lookout Alarms Window color 
scheme, as defined in Table 3-1.

 

Because a new line is added to the list every time an alarm activates or event 
occurs, Lookout might list the same item multiple times. 

Table 3-1.  Alarms Window Color Scheme

Color Alarm Status

Red Active

Blue Unacknowledged, Inactive

Red and Black Acknowledged, Active (Alarm information, including 
time, description, priority, and name, appears in black 
and the area appears in red)

Green Event
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You can sort the alarms and events by clicking the column headers in the 
Alarms Window. To view detailed information about a particular alarm 
or event, right-click it and select Properties. The following dialog box 
appears, listing specific information about the alarm or event. 

 

You can scroll through alarms and events using the Previous and Next 
buttons.

Right-clicking in the Alarms Window displays the Alarms menu, which 
includes options you can use to acknowledge alarms and access all other 
alarm properties.
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Setting Alarm Display Options
With the Alarms»Display Options command, you can change the display 
style of the Alarms Window. The Alarm Display Options dialog box 
appears, as shown in the following figure.

 

• Window style—Determines the position of the Alarms Window in the 
Lookout workspace. If you select Floating, it appears as a pop-up style 
control panel that you can resize, move around, and minimize at any 
time. If you use either the Top or Bottom window style, the Window 
height specifies the number of items Lookout can display in the 
Alarms Window. The actual height of the window adjusts 
automatically depending on the selected font and Window height 
setting. If more alarms occur than can be displayed in the window 
at once, a scroll bar appears along the right side of the window.

• Date format—Set the date format using the Date format selection 
box. 
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Filtering Alarms in the Alarms Window
To filter the alarms and events that appear in your Alarms Window, select 
Alarms»Filter Options, or right-click in the Alarms Window and select 
Filter Options. The following dialog box appears.

 

• Priority—To monitor alarms with specific priorities, check this box 
and set the Min and Max criteria.

• User Name—Check this box and enter a user account name, to restrict 
your display to alarms and events generated while that particular user 
is logged on. You can select only one user name at a time, but you can 
use wildcard characters (*, ?, #) to widen the scope. 

Tip The wildcard characters supported are * (substitutes for zero or more characters), 
? (substitutes for any single character), and # (substitutes for any single numeral).

• Object Name—Check this box and enter an object name, including 
the full path, to restrict your display to alarms and events involving that 
particular object. You can only enter one name at a time, but you can 
use wildcard characters (*, ?, #) to widen the scope of those objects 
reported.

• Description—Check this box and type a description to restrict your 
display to alarms and events that meet your criteria. You can filter on 
only one description at a time, but you can use wildcard characters 
(*, ?, #) to widen the scope of the alarms reported. 
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• Area Name—Check this box and enter an area name to restrict your 
display to only alarms in the alarm area you choose. You can enter only 
one alarm area at a time. Click the Browse Areas button to locate and 
select the alarm area you want to use as a filter.

• Show—You can choose to have the Alarms Window show alarms only, 
events only, or both alarms and events.

• Old Alarms—This option allows you to display alarms after they have 
been acknowledged. Number specifies the number of acknowledged 
alarms to show. Any alarms older than Start time are not displayed. 
You can enter Start time using any time format supported in Lookout. 

• Audible Alarms—Check this box to enable a sound alert when an 
alarm takes place. The sound depends on your Windows system setting 
for error sounds.

Note If you use international characters in any filter options other than Description, 
no alarms will match.

Printing Alarms and Events
You can print alarms and events manually, or you can set up your process 
to print them as they happen.

Printing Alarms and Events Manually
You can print alarms and events in Lookout, based on your filtering. 
To print alarms, select Alarms»Print. The following dialog box appears.
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• Print Range—Select the time range you want to print alarms and 
events from with the items in the Print Range section of the dialog 
box. Notice that when you define your own range, you use month, day, 
and year, followed by hour and minute.

• Printouts—Determines the exact alarm information included in your 
printout. Snapshot prints only the status of alarms at the beginning of 
the specified Range but does not indicate what happened during the 
time span. Journal creates a printout of everything that happened 
during the time span from the beginning of the Range. 

• Columns—Specifies which columns you want printed. Specific 
information about each alarm is presented in columnar format, and 
Lookout prints only the information you designate. 

• Print to CSV file—Prints the results to a comma separated file 
(.csv). Enter the file names for your Snapshot and Journal files, 
including a complete path to where you want the files written. If you 
enter a file name only, Lookout will create the file in the Lookout 
directory.
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• Alarm level—Sets the alarm level for the error generated if there is a 
problem printing to a .csv file. You must be in edit mode with Print 
to CSV files selected in order to change this setting.

• Time Format—Sets the format for printing times.

• Filter Options—You can adjust your filter settings by clicking this 
button. The New Alarm Filters dialog box appears with the same 
options available when filtering alarms, plus the following two 
additional Filter Criteria options:

– Ack User Name—Check this box and enter a user account name 
to restrict your display to alarms and events acknowledged by that 
particular user. You can only enter one user name at a time, but 
you can use wildcard characters (*, ?, #) to widen the scope. 

– Ack Comment—Check this box and type a comment to restrict 
your alarms displayed to those with the specified 
acknowledgement comment.

Note If you use international characters in any filter options other than Description, 
no alarms will match.

Printing Alarms and Events as They Happen
You can print alarms as they happen. Complete the following steps to print 
the contents of the Alarms Window using the filter criteria you have 
configured:

1. Select Options»System. The System Options dialog box appears.

2. Specify a printer port in the Log alarms to field of the dialog box. 

3. Click OK.

This method works well for a printer directly connected to your computer 
that has a line-by-line option. Some printers may queue an entire page of 
data before printing. To print alarms directly to a network computer, you 
must capture a port in the network printer driver and link it to your 
networked printer. Refer to your operating system documentation for 
detailed instructions on how to capture a port for a printer driver. 
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Acknowledging and Clearing Alarms
Complete the following steps to acknowledge an alarm or event in the 
Alarms Window.

Note The security level for alarm acknowledgement is set in the System Options dialog 
box, accessed by selecting Options»System. 

1. Select an alarm in the Alarms Window. <Ctrl-click> to select multiple 
alarms; <Shift-click> to select blocks. Right-click in the Alarms 
Window and choose Select All or Acknowledge All to select all 
alarms for acknowledgment. 

2. Right-click in the Alarms Window and choose Acknowledge. 
A dialog box appears for you to enter a comment. 

3. (Optional) Enter a comment, as shown in the following illustration. 
Comments are optional, and you can click OK to finish acknowledging 
alarms without entering a comment. However, you can search 
historical data for alarms, or print out the alarms, based on comments. 
So, using certain standard comments or comments on specific 
circumstances can be beneficial.

 

When an alarm is inactive and has been acknowledged, Lookout removes it 
from the Alarms Window.

Silencing Audible Alarms
To permanently silence alarms, select Alarms»Filter Options and 
uncheck the Audible Alarms checkbox. If the Audible Alarms checkbox 
is checked, you can temporarily silence alarms by selecting Alarms» 
Silence or pressing <Ctrl-S>, but new alarms will produce an audible beep. 
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Data Quality Problems
When a red X appears over a display or control on a panel, there is a data 
quality problem. You can hover over the red X in run mode to see a 
description of the problem in the middle of the status bar. 
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4
Security

This chapter describes Lookout security. 

Creating and Editing User Accounts
You use the User Account Manager to create and edit the properties of 
groups, create or edit the properties of user accounts, assign users to one 
or more groups, and otherwise manage security accounts for Lookout 
applications. Only an Administrator or someone whose account is a 
member of the Administrator group can create, revise, or delete system user 
accounts. Select Options»User Manager to open the User Account 
Manager, and refer to its help.

Note User Account Manager does not support international character sets, so user names, 
group names, and passwords must not include international characters.

Logging On and Off
Server and client run-time versions of Lookout open with the (nobody) user 
account logged in.

Select File»Log Off or press <Ctrl-D> to log off. To log back on, select 
File»Log on, press <Ctrl-L>, or click the account name in the status bar. 

When no one is logged into Lookout, the (nobody) account is automatically 
logged in.

Note If the (nobody) account is logged on, any functions of a process that require a 
security level greater than zero do not receive or report data until someone logs on using 
an account with a high enough security level.

Note If yours is the only account that is a member of the Administrators group, and you 
forget your password, there is no way to access the System»User Manger command, and 
there is no way to modify account settings. Contact National Instruments for assistance. 
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In run mode the name of the user account logged in to Lookout is shown in 
the status bar at the bottom of the screen. 

Control Security
Control security for a Lookout user interface object, such as a Pot or a 
Switch, is stored in the process file and implements security at the operator 
level. This security level is compared to the security level assigned to a user 
account or a group to prevent or enable access.

If the user is allowed access, the mouse cursor changes into a hand when 
positioned over the object and the operator can adjust and control the 
object. If the user is not allowed access, the cursor changes into the 
international symbol for forbidden, and the operator cannot control the 
object.

Control Is Accessible
Control Access Is Denied
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5
Networking and Running 
an Application

This chapter describes how to network and run Lookout applications.

Synchronizing Lookout Computers
To keep your data properly time stamped, you must make sure the times 
on your computers are properly synchronized. The Lookout time 
synchronization service is installed as a service in Windows 2000/NT/XP 
that runs every time you run your computer. Time synchronization runs as 
a background process in Windows Me/98. 

If your primary server is off-line for some reason, a computer scheduled 
to synchronize automatically seeks out the second computer on the 
synchronization server list. At the time of the next synchronization, 
the computer first looks for the primary server before seeking a secondary 
synchronization server. If no computer is set as a primary time server, your 
computer runs on its own clock.

Complete the following steps to configure time synchronization.

1. Select Options»Time Synchronization. The following dialog box 
appears.
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2. Determine the time synchronization order that you want to use. 
If you have some computers running Windows Me/98 and other 
computers running Windows 2000/NT/XP in your network, you 
should list your Windows 2000/NT/XP computers first in the server 
search list. 

3. Set the order that you want in the Time Server Search Order. Any 
computer that is running the time synchronization service can serve 
as a time server or a time client. The primary time server is the first 
computer listed in the Time Server Search Order field. Do not 
include a computer in its own list of time synchronization services.

• To add a computer to the Time Server Search Order field, click 
the Add button. If you know the name of the computer you want 
to add, you can type it into the Computer name field. If you do 
not know the exact name of the computer, you can browse for it in 
the network tree contained in the second field.

• To remove a computer from the Time Server Search Order field, 
highlight the computer name and click the Remove button.

• To change the order in which your computers search for a time 
synchronization server, select the computer name and click the Up 
or Down buttons.

• Use Sleep Time (seconds) to set how long each computer waits 
between each synchronization. You should set the primary time 
synchronization server sleep time to 60 seconds.
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Suppose you have four computers you need to have synchronized. 
If one fails, the others look for the next in line to synchronize to as time 
servers. For computers A, B, C and D, you would use the following 
time server search order in each computer.

As the primary time server, Computer A would have no other servers 
listed. As long as Computer A is running, it in effect synchronizes to 
itself. Computer B should synchronize to Computer A as long as A is 
running. If A is not running, B should synchronize to itself. Computer 
C should synchronize to Computer A if it is running, Computer B if A 
is not running, and to itself if neither A not B is running. This pattern 
should be used for all the computers you want in one synchronized set.

4. Click OK.

5. Implement this same search order for all of the computers on your 
network running Lookout, similar to what is shown in Table 5-1.

Monitoring Windows Services
Lookout requires three background services that run in Windows outside of 
the Lookout application itself to be running on your computer while it is 
running: Lookout CitadelService, Lookout Classifieds, and Lookout 
TimeService. In your Windows NT task manager, these services appear as 
lkcitdl.exe, lkads.exe, and lktsrv.exe. Under Windows NT 
systems, these services run automatically as NT services. 

Lookout installs a National Instruments services manager, denoted by an 
icon located in the system tray of the Windows taskbar, near the computer 
clock. The columns of circles from left to right represent Classifieds, 
TimeService, and CitadelService. A green light indicates the service is 
running. A red light indicates the service is stopped. When you right-click 
this icon, a shortcut menu appears from which you can start or stop any of 
the Windows services.

Table 5-1.  Time Synchronization Order

Computer A Computer B Computer C Computer D

None listed A A A

— — B B

— — — C
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Running Lookout Processes
You can run many processes at one time. You cannot, however, run two 
processes with the same process name on a single computer. 

Selecting Startup Process Files
If your computer runs Lookout 24 hours a day, you may want to ensure that, 
if the computer temporarily loses power, it will automatically reboot and 
begin executing your processes when power returns.

Complete the following steps to select startup processes.

1. Select Options»Startup, and the following dialog box appears.
 

2. To add a file to your list of startup processes, click the Add button. 
A dialog box you can use to browse for a file appears. 

3. Select the file you want to run when Lookout opens and click Open.

You can add as many process files as you want. The files will open in 
the order in which they are entered in the Startup Process Files dialog 
box. However, the number of processes that you can load is limited to 
what you can list using about 2,600 characters total, which includes 
process names and paths. 

To edit a path to a file, highlight the file name and click the Edit button.

4. Click OK when you are done.

5. To make sure Lookout loads and runs when your computer boots or 
reboots, consult your operating system documentation instructions on 
how to set a default startup application. 
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit our extensive library of technical support resources available 
in English, Japanese, and Spanish at ni.com/support. These 
resources are available for most products at no cost to registered 
users and include software drivers and updates, a KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and 
application notes, instrument drivers, discussion forums, 
a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 
measurement and automation professionals by visiting 
ni.com/support. Our online system helps you define your 
question and connects you to the experts by phone, discussion 
forum, or email.

• Training—Visit ni.com/custed for self-paced tutorials, videos, and 
interactive CDs. You also can register for instructor-led, hands-on 
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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Glossary

ACK Acknowledge (an alarm or event).

alarm Software notification of an abnormal condition in a process. 

Citadel The Lookout historical database that stores your data for access later.

client A Lookout process that monitors a Lookout server process. Lookout 
clients should be computer independent so that they can be run from any 
computer on your network. 

.csv files Comma Separated Value file, a format widely accepted by spreadsheet and 
other data handling programs.

CTS Clear to Send. Part of a handshaking protocol for certain devices that 
connect the serial port of a computer. 

database Collection of data stored for later retrieval, display, or analysis. 

dialing prefix Part of the Hayes AT command set for use with modems. 

DTR Data Terminal Ready.

event An event can be anything that happens within the Lookout environment. 
In Lookout, events include such things as adjusting a control value, 
entering or leaving edit mode, opening or closing a control panel, and 
logging in or logging out of the system.

frame In a communication, sequence of bytes sent from a computer to a 
device or vice versa. 

I/O Input/Output.

I/O point Every read-only, write-only, or read-write connection Lookout makes to 
external hardware is counted as an I/O point. Lookout is licensed for use 
with a set number of I/O points. If you exceed the number you are licensed 
to use with your copy of Lookout, a warning message appears on your 
computer screen warning you to shut down one of your processes within 
a specified time before Lookout cuts back on I/O usage.

IP Internet Protocol.
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logging The process of storing data in a computer database file. 

Logos National Instruments proprietary networking.

MAX National Instruments Measurement and Automation Explorer.

ODBC Open DataBase Connectivity, a standard application programming 
interface (API) for accessing a database. You can use ODBC statements to 
access files in a number of different databases, including Access, dBase, 
DB2, and Excel.

ODBC is compatible with the Structured Query Language (SQL) 
Call-Level Interface. ODBC handles SQL requests by converting them 
into requests an ODBC database can use.

ping A utility program in Windows and DOS that checks to see if a computer 
can be reached across a network. Also used to indicate the running of that 
program.

PLC Programmable Logic Controller.

pop-up panel One variety of Lookout control panel that can only be displayed at the size 
set by the process developer, and which cannot be maximized. When open, 
a pop-up panel remains on top of other panels until minimized.

process In Lookout, process refers to a Lookout “program,” used for industrial 
automation, control, monitoring, or reporting.

receive gap A serial communications setting that determines the number of empty 
bytes (or amount of time) a driver receives before recognizing the end 
of a message frame and requesting another message. 

RTS Request to Send, part of a handshaking protocol for certain devices that 
connect the serial port of a computer. 

server A process that provides data (services) to client processes. In Lookout, 
server processes are intended to have direct connections to field hardware. 
Client processes interact with field hardware through server processes.

startup file A Lookout process file (.l4p) you designate to open and run any time 
Lookout is opened.
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TCP/IP Transmission Control Protocol, a method (protocol) for sending data 
between computers. Used with IP, the Internet Protocol. TCP/IP sends 
data as packets, with IP handling the delivery of data and TCP keeping 
track of the individual packets.

trend Historical data showing the change in a value over time. Often used in 
connection with graphing the data for display.
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Index

A
accounts, managing. See user accounts
acknowledging and clearing alarms, 3-10
alarms

data quality problems, 3-11
printing

as alarms and events happen, 3-9
manually, 3-7

selecting processes for monitoring, 3-1
silencing audible alarms, 3-10
viewing

filtering alarms, 3-6
in Alarms Window, 3-3
setting display options, 3-5

Alarms Window
display options, setting, 3-5
filtering alarms, 3-6
overview, 1-9
viewing alarms, 3-3

C
Citadel Database settings, 1-12
client connections, adding, 1-5
communications service. See serial port 

communication
computer name, setting, 1-12
contacting National Instruments, A-1
control panels overview, 1-8
control security, 4-2
conventions used in the manual, iv
CTS timeout setting, 2-5
customer

education, A-1
professional services, A-1
technical support, A-1

D
diagnosing serial port problems, 2-6
diagnostic resources, A-1
Dialing prefix settings, 2-3
dial-up modem settings, 2-3
documentation

conventions used in the manual, iv
online library, A-1

drivers
instrument, A-1
software, A-1

E
events

printing
as they occur, 3-9
manually, 3-7

viewing in Alarms Window, 3-3
example code, A-1

F
filters for alarms, 3-6

international characters (note), 3-7

H
hangup setting, serial port communications, 2-6
hardware

hardware key for Lookout, 1-3
Lookout requirements, 1-1

Hardwired option, serial connections, 2-3
help

professional services, A-1
technical support, A-1
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I
I/O points

changing number of, 1-5
for unregistered Lookout package, 1-3

installing Lookout, 1-2
instrument drivers, A-1
international characters, 2-7, 3-7, 3-9, 4-1

K
keyboard, virtual, 1-9, 1-11
keycode

changing I/O count registration, 1-5
registering Lookout, 1-4

keypad, virtual, 1-9
KnowledgeBase, A-1

L
log alarms setting, 1-11
logging on and off (security), 4-1
Lookout

environment
Alarms Window, 1-9
control panels, 1-8
edit mode (figure), 1-7
menu bar, 1-8
status bar, 1-8
workspace, 1-8

hardware and software requirements, 1-1
installing, 1-2
operator input and navigation, 1-9
registering, 1-3
setting system options, 1-10
starting for first time, 1-4
testing TCP/IP, 1-1
virtual keyboard, 1-9
virtual keypad, 1-9

M
menu bars, overview, 1-8
modem settings for dial-up serial 

communication, 2-3

N
National Instruments

customer education, A-1
professional services, A-1
system integration services, A-1
technical support, A-1
worldwide offices, A-1

networking
monitoring Windows services, 5-3
running Lookout processes

selecting startup process files, 5-4
synchronizing Lookout computers, 5-1

O
objects

control security, 4-2
online technical support, A-1

P
panel navigation arrows, 1-11
Pause between calls (modem) setting, 2-4
phone technical support, A-1
printing alarms and events

as they occur, 3-9
manually, 3-7

processes
monitoring alarms, 3-1
running Lookout processes on networks 

launching Lookout automatically
selecting startup process files, 5-4

professional services, A-1
programming examples, A-1
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R
Radio (RTS-CTS) serial connection, 2-5
Receive gap setting, 2-2
registering Lookout

adding client connections, 1-5
changing I/O count registration, 1-5
changing registration information, 1-12
limitations of unregistered package, 1-3
starting Lookout for first time, 1-4

Retries (modem) setting, 2-4
RTS delay off time period, 2-6
RTS/CTS handshaking settings, 2-5

S
security

control security, 4-2
logging on and off, 4-1
overview, 4-1
system options, setting, 1-10

serial number for Lookout, 1-4
serial port communication

defining settings, 2-1
diagnosing problems, 2-6
dial-up modem settings, 2-3
hangup setting, 2-6
Hardwired connection, 2-3
international characters, 2-7
overview, 2-1
Receive gap setting, 2-2
RTS/CTS serial connection, 2-5
selecting serial connection, 2-3
Serial Port Settings dialog box 

(figure), 2-2
Serial port field, 2-2
silencing audible alarms, 3-10
software

drivers, A-1
requirements, 1-1

starting Lookout for first time, 1-4
status bar for Lookout, 1-8
support, technical, A-1
synchronization

Lookout computers on the network, 5-1
system integration services, A-1
System Options dialog box (figure), 1-11
system options, setting, 1-10

T
TCP/IP, testing, 1-1
technical support, A-1
telephone technical support, A-1
training, customer, A-1
troubleshooting resources, A-1

U
user accounts

international characters (note), 4-1

V
virtual keyboard

overview, 1-9
setting mouse clicks for pop-up 

feature, 1-11
virtual keypad, 1-9

W
Wait for connection (modem) setting, 2-4
Web

professional services, A-1
technical support, A-1

Windows services, monitoring, 5-3
workspace in Lookout, 1-8
worldwide technical support, A-1
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