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Conventions

The following conventions are used in this manual: 

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.
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1
Introduction to the LabVIEW 
DSC Module

This manual gets you started using the LabVIEW Datalogging and 
Supervisory Control (DSC) Module, an add-on to LabVIEW. If you are not 
familiar with LabVIEW, start with the LabVIEW documentation and 
examples. When you are familiar with LabVIEW, complete the activities 
in this manual. 

The DSC Module helps you design and deploy monitoring and data logging 
systems. The DSC Module adds the following features and capabilities to 
LabVIEW:

• Configuration utilities and wizards

• Historical data collection and trending

• Alarm and event reporting and logging

• Security

• Connection to PLC (Programmable Logic Controller) and industrial 
device networks

• OPC (OLE for Process Control) server and client capabilities

• Connection to a wide selection of device servers

• DSC Module Control and indicator palettes

• DSC Module Function palettes

Open and Run a VI
In the following activity, you will become familiar with some basic features 
of the DSC Module by exploring a DSC Module example.

You can complete this activity in approximately 20 minutes.

1. Select File»Open in LabVIEW, and open the HMI Security VI in the 
LabVIEW\examples\lvdsc\Security directory. 
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This example VI shows a conveyor system that can be controlled and 
monitored. 

2. Right-click the front panel to open the Controls palette if it is not 
already displayed. Click the pushpin button, click the Options button, 
and set the Palette View to Advanced. Click the OK button. The DSC 
Module controls and indicators are available in the Advanced palette 
view.

Take a moment to open the DSC palette, shown at left, and browse the 
DSC Module control palettes shown in the following figure.

3. Switch to the block diagram and take a moment to browse the DSC 
function palettes shown in the following figure.

4. Select Tools»DSC Module to view the menu that provides access to 
many DSC Module features. 

5. Make sure the Tag Utilities toolbar is displayed by selecting 
Tools»DSC Module»Show Toolbar. The Tag Utilities toolbar 
provides shortcuts to several DSC Module tools.

6. Return to the front panel and run the VI. The Tag Engine launches.

The Tag Engine runs independently, communicating between devices 
and the DSC Module application. 
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7. Click the Login button on the front panel of the VI to launch the User 
Login dialog box, part of the DSC Module security capabilities. Enter 
Administrator in the Username field. Click the OK button. You do 
not need to enter a password unless you created one for the 
Administrator account. 

As an administrator, you have access to controls and indicators at the 
bottom of this example’s front panel.

8. Set the Set Speed knob to 10. When the conveyor’s Current Speed 
exceeds 8, an alarm is generated. You will see this alarm later.

9. Select Tools»DSC Module»Monitor Tags to launch Tag Monitor. 

The DSC Module’s Tag Monitor allows you to view value, time stamp, 
alarm state, and connection information for selected tags. 

10. Expand the Demo item under your computer in the left pane, and 
double-click the CurrentSpeed, RateofSpeedChange, and SetSpeed 
tags. Those items are added to the top-right pane view, and their 
current values are displayed. In the bottom-right pane you can see the 
alarm generated when the conveyor speed exceeded 8. 

Tags represent a connection to either a real-world I/O (Input/Output) 
point or a variable held in memory. In a DSC Module application, you 
use tags to monitor, log, and retrieve data. The convenience and power 
of tags makes applications easier to create, distribute, and maintain.

11. Close Tag Monitor. Click the No button when prompted to save. 

12. Stop the HMI Security VI and close it. Stop the Tag Engine when 
prompted. 

Summary
For more information about the topics covered in this chapter, refer to the 
LabVIEW Help or the LabVIEW Datalogging and Supervisory Control 
Module Developer Manual.

DSC Module Features
The DSC Module adds utilities, wizards, controls, indicators, functions, 
and VIs to LabVIEW. DSC Module features are available on the Controls 
palette, Functions palette, Tag Utilities toolbar, and Tools»DSC Module 
menu.
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Tags
Tags are important in DSC Module applications. Tags represent a 
connection to either a real-world I/O point or a variable held in memory. 
The DSC Module includes tools for easily connecting to and monitoring 
tags.

Tag Engine
The Tag Engine performs the following tasks:

• Communicates with devices

• Scales and initializes data

• Processes alarms

• Logs alarms and events to the historical database

• Logs historical data

Tag Monitor
Use Tag Monitor to view value, time stamp, alarm state, and connection 
information for selected tags. You also can use it to write values to tags and 
debug communication problems.
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2
Graphical User Interface

This chapter teaches you how to create a graphical user interface using the 
LabVIEW Datalogging and Supervisory Control (DSC) Module.

Build a Graphical User Interface
This activity teaches you how to build a front panel to interface with the 
OPC Demo server.

You can complete this activity in approximately 15 minutes.

Complete the following steps to build the front panel shown in this figure.



Chapter 2 Graphical User Interface

Getting Started with the DSC Module 2-2 ni.com

1. Create a new VI by clicking the New VI button from the LabVIEW 
dialog box, or by selecting File»New VI from the front panel or block 
diagram.

Make sure to display the Tag Utilities toolbar by selecting Tools»DSC 
Module»Show Toolbar.

2. Click the Image Navigator button shown at left on the Tag Utilities 
toolbar to launch the Image Navigator. 

The DSC Module’s Image Navigator provides a collection of more 
than 4,000 industrial automation graphics that you can use on front 
panels. 

3. Select Pumps from the Categories list in the Image Navigator. Select 
the Heavy-duty plastic centrifugal pump from the top row of the 
Symbols box and drag the image from the Image Navigator window 
onto the LabVIEW front panel. 

4. In LabVIEW, navigate to the Numeric palette and place a Knob on the 
front panel. To show the digital display, right-click the knob and select 
Visible Items»Digital Display from the shortcut menu. 

5. Select and place a Gauge on the front panel.

6. Navigate to the Boolean palette, place a Square LED on the front 
panel, and label it MotorRPMLimit. 

7. Select, place, and label three Push Button controls on the front panel. 
Select and place the OK Button on the front panel, and change its text 
to Login. 

8. Navigate to the Decorations controls palette and add decorations to 
the front panel to recreate the front panel shown. 

9. Resize and label the objects so that your front panel resembles the 
illustration shown at the beginning of this section. 

10. When your front panel is similar to the front panel shown, select 
File»Save and save as Compressor.vi in the examples\lvdsc 
folder. 

Connect the Front Panel Controls to Tags
This activity demonstrates how to connect the OPC Demo server I/O points 
to the controls and indicators on the front panel of the Compressor VI 
created in the previous section.

You can complete this activity in approximately 10 minutes.
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Make sure that the Tag Engine is not running. If you can see the Tag Engine 
icon in the Windows taskbar, shown at left, right-click it, and select Stop 
from the shortcut menu. 

1. With the Compressor VI open, click the Start Tag Configuration 
Editor button, shown at left, on the Tag Utilities toolbar to launch the 
Tag Configuration Editor. 

2. Select File»New to create a new .scf file.

The DSC Module Tag Configuration Editor will store tag information 
and Tag Engine parameters in a configuration (.scf) file, which the 
Compressor VI will use. 

3. Save the file as Compressor.scf in the LabVIEW folder. Click the 
Save button. Click the OK button in the SCF Summary dialog box 
that appears. Close the Tag Configuration Editor.

4. Right-click the knob and select HMI Wizard from the shortcut menu. 

The DSC Module’s HMI Wizard allows you to quickly and easily 
create the block diagram code necessary to connect the knob to an I/O 
point. 

5. Click the Create New Tag button, shown at left, in the dialog box to 
select a server item and create a tag to connect to it. 

If you had already created tags for the Compressor.scf file, you 
would be able to select one from the Tag drop-down menu. When and 
how to most effectively create tags depends on the application you are 
developing. 

6. Select National Instruments.OPCDemo»NI OPC Demo Server» 
Simulation»MotorRPMSetPoint, as shown in the following figure. 
Click the OK button.
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A server communicates with and manages I/O such as PLCs and data 
acquisition (DAQ) plug-in devices. 

A server item is a channel, I/O point, or variable in a hardware device.

You connect to these items with tags.

7. Click the OK button. The configuration file is saved. Click the OK 
button.

8. Repeat steps 4 through 7 for the gauge, selecting MotorRPMSensor 
from Simulation this time. You will connect the LED later.

9. Run the VI. The Tag Engine launches.

10. Turn the MotorRPMSetPoint knob and notice that the 
MotorRPMSensor adjusts accordingly.

11. Switch to the block diagram to see the generated code.

12. Stop and close the VI.

13. Right-click the Tag Engine icon, shown at left, and select Stop from 
the shortcut menu to stop the Tag Engine.
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Summary
For more information about the topics covered in this chapter, refer to the 
LabVIEW Help or the LabVIEW Datalogging and Supervisory Control 
Module Developer Manual.

Image Navigator
Use the Image Navigator to add standard or customized industrial graphics 
to DSC Module applications. 

Tag Configuration Editor
Use the Tag Configuration Editor to create tags and set their attributes. 
The Tag Configuration Editor stores tag information and Tag Engine 
parameters in .scf files, which are used by DSC Module applications at 
execution time. 

HMI Wizard
Use the HMI Wizard to quickly and easily create the block diagram code 
necessary to connect front panel objects to tags. You can unlock and 
customize wizard-generated code. Alternatively, you could manually drop 
and wire the DSC Module Tags VIs and Tag Attribute VIs to read tag 
values, write to tags, access tag attributes, and perform other tag operations.

Servers
The DSC Module can connect to any OPC-compliant server and to many 
third-party device servers. You also can connect to National Instruments 
servers, including National Instruments DAQ and FieldPoint servers. 
Use the DSC Module’s Server Browser to see available servers on your 
computer or across the network, view server information, change OPC 
settings, and so on.
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3
Real-Time Trending

This chapter teaches you how to view data values using the LabVIEW 
Datalogging and Supervisory Control (DSC) Module’s Real-Time Trend 
capabilities. 

View Real-Time Data
This activity demonstrates how to view real-time data using a Real-Time 
Trend.

You can complete this activity in approximately 15 minutes.

Create the Real-Time Trend Viewing Panel
Complete the following steps to build the front panel shown in this figure.

1. Select File»New from any open window or click the Create a New VI 
button, shown at left, on the Tag Utilities toolbar.

2. Select and place the Real-Time Trend from the Trends palette on the 
front panel and label it Real-Time Trend.



Chapter 3 Real-Time Trending

Getting Started with the DSC Module 3-2 ni.com

3. Right-click the Real-Time Trend and select HMI Wizard from the 
shortcut menu. 

4. Select MotorRPMSensor from the Tag pull-down list and click Add 
to add it to the Tag List. Repeat for MotorRPMSetPoint. Click the 
OK button.

5. Select and place an OK Button from the Boolean palette on the front 
panel.

6. Right-click the OK button and select Panel Wizard from the shortcut 
menu. Select Close this Panel from the With this control pull-down 
menu. Click the OK button to close the Panel Wizard dialog box. The 
button text changes from OK to Close.

The DSC Module’s Panel Wizard provides a quick way to create 
navigation among multiple windows and front panels in your 
application. 

7. Save this VI as Real Time Trend.vi in the examples\lvdsc 
folder.

Connect the Viewing Panel to the Application
1. Open the Compressor VI if it is not already open. You will connect this 

VI’s Real-Time Trending button.

2. Right-click the Real-Time Trending button and select Panel Wizard 
from the shortcut menu.

3. Select the VI radio button on the Panel tab. Click the Browse button, 
then find and double-click Real Time Trend.vi. Click the OK 
button to close the Panel Wizard dialog box.

Notice that the button text has changed to Real Time Trend. 
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4. Run the Compressor VI. To view the real-time trends on the Real Time 
Trend VI’s panel, click the Real Time Trend button. Move the knob 
on the Compressor VI front panel and notice the change on the trend 
display.

5. Stop and save the Compressor VI and the Real Time Trend VI.

Summary
For more information about the topics covered in this chapter, refer to the 
LabVIEW Help or the LabVIEW Datalogging and Supervisory Control 
Module Developer Manual.

Trends
Use a Real-Time Trend to view live data on the front panel of a DSC 
Module application. To view logged historical data on a front panel, use a 
Historical Trend. For more flexible, powerful trending on a front panel, use 
the NI HyperTrend. 

Panel Wizard
Right-click on a Boolean control and select Panel Wizard from the 
shortcut menu to configure the control to open or close a panel. Using the 
Panel Wizard, you also can configure a control to launch the User Login 
dialog box, Historical Trend Viewer, Historical Data Viewer, Tag Monitor, 
or any VI.
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4
Historical Logging

This chapter teaches you how to log and view data values with the 
LabVIEW Datalogging and Supervisory Control (DSC) Module. 

Configure Data Logging
This activity demonstrates how to specify which items are logged by the 
DSC Module. By default, all data is logged to the Citadel database. If you 
do not want to log the data of a specific tag, you can change its 
configuration.

You can complete this activity in approximately 3 minutes.

1. Open the Compressor VI if it is not already open. Display the Controls 
palette and Tag Utilities toolbar.

2. Click the Start Tag Configuration Editor button, shown at left, on 
the Tag Utilities toolbar to open the Tag Configuration Editor. 

3. Double-click MotorRPMSetPoint.

4. Click the Operations tab and remove the checkmark from the Log 
Data checkbox. Click the OK button.

5. Select File»Save in the Tag Configuration Editor. If the Tag Engine is 
still running, you are prompted to restart it with the changes. Click the 
Yes button. 

6. Close the Tag Configuration Editor, but leave the Tag Engine running.

View Logged Data Using the Historical Data Viewer
This activity demonstrates how to view the data being logged, using the 
Historical Data Viewer in Measurement & Automation Explorer (MAX).

You can complete this activity in approximately 5 minutes.

1. Open the Compressor VI if it is not already open.
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2. Right-click the Historical Data Viewer button and select Panel 
Wizard from the shortcut menu.

3. Select Historical Data Viewer and click the OK button.

4. Run the VI. Adjust the MotorRPMSetPoint control several times, 
waiting a few seconds between each adjustment. This provides logged 
data for you to access.

5. To view the logged data, click the Historical Data Viewer button. 
MAX launches with the Historical Data category visible. 

The DSC Module’s Citadel database efficiently stores historical data, 
alarms, and events. Historical Data Viewer is an easy and powerful 
way to view and manage Citadel data.

6. Expand the Historical Data category and Citadel 5 Universe in the 
left tree view. 

7. In the right pane, navigate to MotorRPMSensor under your computer 
name. Highlight MotorRPMSensor and click the View Data button 
at the top of that pane.

8. Select the Display tab at the bottom of the right pane. 

9. Click the End of Data button, shown at left, to locate the most recently 
logged data.

10. Click the stoplight icon, shown at left, in the top-right corner to switch 
the Historical Data Viewer from historical data to live data mode. To 
see the display change, adjust the MotorRPMSetPoint control on the 
Compressor VI front panel.

11. Close Historical Data Viewer.

12. Stop and save the VI. Notice that the Tag Engine keeps running and 
logging data, as shown by the Tag Engine icon in the Windows system 
tray.

Summary
For more information about the topics covered in this chapter, refer to the 
LabVIEW Help or the LabVIEW Datalogging and Supervisory Control 
Module Developer Manual.

Citadel Historical Database
The DSC Module efficiently stores historical data, alarms, and events. 
Citadel is the DSC Module’s historical database. You can use various DSC 
Module tools or VIs to view and manage Citadel data. 



Chapter 4 Historical Logging

© National Instruments Corporation 4-3 Getting Started with the DSC Module

Historical Data Viewer
Historical Data Viewer launches within MAX. Use Historical Data Viewer 
to view, archive, or delete data logged to Citadel. You can launch it 
manually in LabVIEW by selecting Tools»DSC Module»View Historical 
Data, or you can launch it programmatically using the Call HDV VI on the 
Historical Data palette. 
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5
Alarms

This chapter teaches you how to use the basic alarm capabilities of the 
LabVIEW Datalogging and Supervisory Control (DSC) Module. 

Set and View Alarms
This activity demonstrates how to configure, view, and acknowledge 
alarms using DSC Module utilities. 

You can complete this activity in approximately 5 minutes.

1. Open the Compressor VI if it is not already open. 

2. Click the Start Tag Configuration Editor button, shown at left, on 
the Tag Utilities toolbar to open the Tag Configuration Editor.

3. Double-click MotorRPMSensor and select the Alarms tab. 
Configure the alarm characteristics as shown in the following figure. 
Click the OK button.
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4. Select File»Save in the Tag Configuration Editor. If the Tag Engine 
is still running, you are asked to update the .scf file. Click the Yes 
button to update. Close the Tag Configuration Editor.

5. Create a new VI. 

6. Select and place the Alarm & Event Display from the Alarms & 
Events subpalette onto the front panel and label it Alarms and 
Events.

7. Place an OK Button from the Boolean palette on the front panel.
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8. Right-click the OK button and select Panel Wizard from the shortcut 
menu. Select Close this Panel from the With this control pull-down 
menu. Click the OK button. 

9. Save this VI as Alarms.vi in the examples\lvdsc folder and 
close it.

10. Right-click the Alarms button on the front panel of the Compressor VI 
and select Panel Wizard from the shortcut menu.

11. Select the VI radio button on the Panel tab. Browse to the Alarms.vi 
you created and click the OK button.

12. Run the VI. Turn the MotorRPMSetPoint knob above 8 to cause 
alarms. Click the Alarms button to launch the Alarms VI and view 
alarms.

13. To acknowledge the alarms, right-click any alarm and select 
Acknowledge All from the shortcut menu. Click the OK button. 

14. Stop and close the Alarms VI when you are done.

15. Stop the Compressor VI and save any changes.

Add Alarm Functionality to an Existing VI
This activity demonstrates how to add alarm functionality to an existing VI 
using the HMI Wizard. This activity demonstrates how to turn on the 
MotorRPMLimit LED when MotorRPMSensor is in alarm.

You can complete this activity in approximately 7 minutes.

1. Open the Compressor VI if it is not already open. 

2. Right-click MotorRPMLimit and select HMI Wizard from the 
shortcut menu.

3. Select Tag Alarm State from the Attach Indicator to pull-down 
menu. Select MotorRPMSensor in the Tag pull-down list. Click the 
OK button. 

4. Run the VI. Turn the MotorRPMSetPoint knob. Notice that the LED 
lights up when MotorRPMSensor is in alarm (above 70).

5. Stop and save the VI. 

6. Right-click the Tag Engine icon in the Windows task bar and select 
Stop from the shortcut menu to stop the Tag Engine.
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Summary
For more information about the topics covered in this chapter, refer to the 
LabVIEW Help or the LabVIEW Datalogging and Supervisory Control 
Module Developer Manual.

Alarms and Events
You can use various DSC Module tools to easily configure, view, and 
acknowledge alarms and events. An alarm is a specific type of event related 
to the value of a tag. Events can be tag events, such as a change in alarm 
state, or system events, such as a user login or Tag Engine launch.
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6
Security

This chapter teaches you how to use some of the security features included 
in the LabVIEW Datalogging and Supervisory Control (DSC) Module.

Add Security to Your System
This activity demonstrates how to create user accounts and implement 
security for front panels. A login button limits access to front panel objects 
based on the password-based user accounts.

You can complete this activity in approximately 10 minutes.

1. Open the Compressor VI if it is not already open. 

2. Select Tools»DSC Module»Security»Edit User Accounts. The User 
Account Manager launches.

The DSC Module’s User Account Manager allows you to create user 
and group accounts, assign passwords, set the security level for a user, 
add or remove users in a group, and so on.

Note If you were not previously logged in as Administrator, you are prompted to do so 
now. Click the OK button. Select Administrator from the Accounts pull-down menu and 
click the OK button.

3. Select User»New User Account in the User Account Manager 
window.

4. Create the following two new accounts. Click the OK button after 
entering the following information for each user. Close the User 
Account Manager window when you are done.

User Name Password Security Level

Engineer Eng 7

Operator Oper 5
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5. After creating the accounts, right-click the MotorRPMSetPoint knob 
on the Compressor VI front panel and select Security from the 
shortcut menu to launch the Security Wizard. 

The DSC Module Security Wizard launches the Access Rights dialog 
box so that you can quickly and easily implement security on the 
control. 

6. Click the Add button. Double-click Engineer and Operator. Click the 
OK button.

7. Configure each user’s access using the Access pull-down menu, 
as shown in the following figure. Click the OK button.

8. Right-click the Login button and select Panel Wizard from the 
shortcut menu.

9. Select Login prompt on the Panel tab. Click the OK button.

10. Run the VI. Click the Login button on the front panel and log in as 
Operator. The MotorRPMSetPoint knob is no longer visible because 
the Operator user is not authorized to access it.

Note Security passwords are case sensitive.

11. Click the Login button again and log in as Engineer. Notice that 
the MotorRPMSetPoint knob reappears because the Engineer is 
authorized to adjust it.

12. Stop and save the VI. 
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Summary
For more information about the topics covered in this chapter, refer to the 
LabVIEW Help or the LabVIEW Datalogging and Supervisory Control 
Module Developer Manual.

Security
To implement security for a DSC Module application, first create accounts 
with the User Account Manager. Then use various DSC Module features 
such as the Security Wizard or Security VIs to limit access to different 
aspects of your application as needed.
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7
Networking

This chapter teaches you about networking a LabVIEW Datalogging and 
Supervisory Control (DSC) Module application.

Note To complete these activities, you must have two computers connected by a network 
to act as client and server. Both computers must be running the same version of the DSC 
Module.

Access I/O over the Network
To set up a client-server system, you must register network computers, then 
import tags from the server machine, and view them on the client machine.

Registering the Server Computer on the Client Machine
This activity demonstrates how to register a network computer with the 
DSC Module.

You can complete this activity in approximately 3 minutes.

1. The computer that you have been working on will be your server 
computer. Choose another computer running the same version of the 
DSC Module to be the client computer. 

2. On the client computer, log in as Administrator using the Tools»User 
Name dialog box. 

3. Select Tools»DSC Module»Options, select the Advanced tab, then 
click Registered Computers.

4. If the server computer is not listed, click the Add button, select the 
server computer, and click the Register button. Click the OK button 
to close the Register Computer dialog box. Click the OK button to 
close the remaining dialog boxes.
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Importing Tags to the Client Computer
This activity demonstrates how to access tags over the network. 
Configuring the client involves adding tags from a server computer 
configuration (.scf) file to a .scf file on the client.

You can complete this activity in approximately 10 minutes.

1. On the client computer, launch the Tag Configuration Editor.

2. Select File»New and then File»Import Network Tags.

Note File sharing must be enabled on the server computer to view files from the client 
computer.

3. Click the Browse button in the Data Source field and navigate across 
the network to the server computer and the Compressor.scf file. 

4. Select the tags to import to the client computer .scf file and click the 
Add All button as shown in the following figure. Click the Import 
button.

5. Select File»Save in the Tag Configuration Editor and save the file as 
NetworkTags.scf. Click the OK button in the SCF Summary 
dialog box. Close the Tag Configuration Editor.
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6. Copy the Compressor VI from the server computer onto the client 
computer and run the VI there. Notice the server tag values are 
displayed on the client computer.

Summary
For more information about the topics covered in this chapter, refer to the 
LabVIEW Help or the LabVIEW Datalogging and Supervisory Control 
Module Developer Manual.

Networking
After you have registered a network computer, you can import tags from it 
and log to it using DSC Module functionality. 

Where to Go from Here
The DSC Module includes a comprehensive documentation set designed to 
help you create monitoring and datalogging applications. The LabVIEW 
DSC Module Bookshelf is available by selecting Help»Search the DSC 
Module Bookshelf in LabVIEW. It describes and links to the available 
DSC Module documents. Open and explore the LabVIEW DSC Module 
Bookshelf. 

Note You must have Adobe Acrobat Reader version 5.05 or later with Search and 
Accessibility to use the search functionality in the LabVIEW DSC Module Bookshelf.

The LabVIEW Help contains information about DSC Module VIs and 
features. You can access the LabVIEW Help by selecting Help»VI, 
Function & How-To Help in LabVIEW. For additional guidance 
developing DSC Module applications, you can study the DSC Module 
examples in the examples\lvdsc directory. For additional developer 
resources, training, technical support, and more, refer to ni.com.

http://www.ni.com
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit our extensive library of technical support resources available 
in English, Japanese, and Spanish at ni.com/support. These 
resources are available for most products at no cost to registered 
users and include software drivers and updates, a KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and 
application notes, instrument drivers, discussion forums, 
a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 
measurement and automation professionals by visiting 
ni.com/support. Our online system helps you define your 
question and connects you to the experts by phone, discussion 
forum, or email.

• Training—Visit ni.com/custed for self-paced tutorials, videos, and 
interactive CDs. You also can register for instructor-led, hands-on 
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.

http://www.ni.com
http://www.ni.com
http://www.ni.com/support
http://www.ni.com/support
http://www.ni.com/custed
http://www.ni.com/alliance
http://www.ni.com/niglobal
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