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Control Module Release Notes
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Welcome to the LabVIEW Datalogging and Supervisory Control (DSC) 
Module, the LabVIEW solution for distributed data logging and monitoring 
needs. This document describes installation, known issues, new features, 
upgrade steps, and more for the DSC Module version 7.0. For recent 
information not included in these release notes, refer to the 
dsc_readme.txt file.
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System Requirements
The DSC Module runs on any system with the following minimum 
specifications:

• Windows NT 4.0 or Windows 2000/XP/Me/98. If you are running 
Windows NT, you need service pack 6a and the 6a Security Rollup 
Package, which are included in the July 26, 2001 security update 
available at www.windowsupdate.com.

• 128 MB of RAM, 256 MB recommended.

• 200 MHz or higher processor speed, 500 MHz recommended.

• 800 MB of disk space to install LabVIEW and the DSC Module and 
have swap space available. Increasing your computer resources has a 
significant effect on performance of DSC Module applications. 

• 800 × 600 or better monitor display.

http://www.windowsupdate.com
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Compatibility Issues
This version of the DSC Module requires LabVIEW version 7.0. 

If you are upgrading from a previous version of LabVIEW, your existing 
VIs are automatically converted and compiled when you open them, and 
you are prompted to save. A VI saved in the DSC Module version 7.0 no 
longer loads in an earlier version.

Citadel Database Compatibility
This version of the DSC Module includes Citadel 5, a new version of the 
historical database. The DSC Module version 7.0 logs to and retrieves from 
Citadel 5 databases only. You must convert existing databases to Citadel 5 
if you want to use them with the new DSC Module. Refer to the Convert 
Citadel Databases section for information about converting your 
databases.

NI-DAQ Software Compatibility
If you want to use NI-DAQ with this version of the DSC Module, you can 
use either Traditional NI-DAQ or NI-DAQmx, but not both at the same 
time. If you use Traditional NI-DAQ, you can use DAQ OPC. You cannot 
use NI-DAQmx with OPC. To use NI-DAQmx, you must use the DAQ VIs 
with memory tags. To make this process easy, you can automatically 
generate these memory tags from your NI-DAQmx configuration using the 
Tag Configuration Editor’s Import DAQ Memory Tags feature.

If you have trouble with a Traditional NI-DAQ application after upgrading 
to this version of the DSC Module, make sure the DAQ OPC server is 
installed. Perform a custom installation from the NI-DAQ installation CD 
to install DAQ OPC; the DSC Module installation CD does not include the 
DAQ OPC server.

Installation

Before You Install
• Before you install the DSC Module, you must have already installed 

LabVIEW 7.0. If you reinstall LabVIEW 7.0 after installing the DSC 
Module, you must reinstall the DSC Module.

• Make sure that you meet the system requirements listed in the System 
Requirements section of this document.
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• If you have a previous version of the DSC Module installed, either 
uninstall that older version or plan to install this version into a different 
directory. 

• If you want to preserve custom settings used in your previous version 
of the DSC Module, save all .ini and .cfg files in the LabVIEW 6.x 
directory to a backup location, then copy them to the relevant location 
after installing version 7.0. 

• If you want to preserve custom images you have stored in Image 
Navigator, back up your custom.cat files before upgrading to 
version 7.0 of the DSC Module. 

• If you have Microsoft SQL Server version 6.5 or earlier on your 
computer, you must upgrade to Microsoft SQL Server version 7.0 
or later before installing the DSC Module.

• Under Windows Me/98, you cannot browse OPC server computers 
across the network unless the Remote Registry Service is installed. 
For more information about installing Remote Registry Service, refer 
to the Microsoft Web article about how to install remote administration 
services.

Installing the DSC Module
Complete the following steps to install the DSC Module.

1. Install LabVIEW 7.0 if you have not already done so. Refer to the 
LabVIEW installation instructions for help.

2. Restart your computer. You must restart after installing LabVIEW and 
before installing the DSC Module.

3. Insert the DSC Module CD in your CD-ROM drive.

4. Run the installer. Run x:\setup.exe where x is the letter of your 
CD-ROM drive.

5. Follow the onscreen instructions. 

6. Restart your computer and log on to your computer as an 
administrator. When you reboot, the MSDE setup might take awhile.

7. (Optional) Launch LabVIEW and change the default palette view to 
access the DSC Module palettes: select Tools»Options, select 
Control/Function Palettes in the pull-down menu, and choose the 
Advanced palette view. The DSC Module palette icon is shown at left.

Uninstalling the DSC Module
To uninstall this DSC Module, select Start»Settings»Control Panel»
Add/Remove Programs. Select National Instruments Software and 
choose to remove the NI LabVIEW DSC Module 7.0.



© National Instruments Corporation 5 DSC Module Release Notes

New Features for Version 7.0
The following sections describe changes to existing features and new 
features available in this version of the DSC Module.

Citadel 5 Database
The DSC Module version 7.0 includes Citadel 5, a new version of the 
Citadel historical database. Citadel 5 introduces data access from ADO 
clients and improved ODBC support.

Database Names
Citadel 4 identified databases exclusively by their path; Citadel 5 now uses 
database names. Because of the new Citadel 5 format, the Historical Data 
VIs have been modified, the Tag Configuration Editor uses a new .scf file 
format, the ODBC data source setup has changed, and the Historical Data 
Viewer has been updated.

Conversion to Citadel 5 Format
The DSC Module version 7.0 logs to and retrieves from Citadel 5 databases 
only. You must convert existing databases to Citadel 5 if you want to use 
them with the new DSC Module. Refer to the Convert Citadel Databases 
section for information about converting databases.

Time Zones and Daylight Savings Time Information
As with Citadel 4, times in Citadel 5 are stored in UTC (Coordinated 
Universal Time). In addition to this, the DSC Module Tag Engine and 
Citadel 5 now store the time zone with every point and alarm logged, which 
allows you to determine the local time when the point was logged. This 
addresses problems of both data logged in another time zone and daylight 
savings time (CST and CDT are considered two different time zones in this 
scheme). You can get this information using extra columns in the SQL 
query.

Citadel 5 ODBC Data Source
As with Citadel 4, you must have an ODBC data source for Citadel 5 as 
described in the LabVIEW Help. However, the following changes have been 
made to the National Instruments Citadel ODBC Setup dialog box:

• ODBC setup now asks for a Database URL instead of a database path. 
Database URL is the computer and database name where data for the 
source are stored, for example \\computer_name\my_database. 
Database URL should match the existing local or remote database you 
intend to access.
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• The ... button allows you to browse local and remote databases.

• The Test Connection button allows you to test the connection you are 
setting up.

Expanded Access to Citadel 5 Data
The Citadel 5 ODBC driver is compliant with SQL 92 and ODBC 2.5 
standards. All clients that follow these standards can retrieve data from a 
Citadel 5 database. ADO clients now can use the ODBC driver through the 
Microsoft OLE DB Provider for ODBC Drivers to access the Citadel 5 
database. You can use the MS Query wizard to build queries.

Creating a Data Link for the ODBC Data Source
If you want to access Citadel data from an ADO client, you need a data link 
to ODBC. You might be able to create the data link from within your ADO 
client, though you might be required to create it multiple times. 
Alternatively, complete the following steps to create a data link once that 
can be stored anywhere on your system or network.

1. Create a Citadel 5 ODBC data source, if you have not already done so.

2. Create a new text (.txt) document.

3. Right-click the new text document and rename it to have a .udl 
extension, for example data_link.udl. A warning might appear, 
explaining that changing file extensions could cause files to become 
unusable. Disregard this warning.

4. Right-click the .udl file and select Properties. In the dialog box that 
appears, click the Provider tab and select Microsoft OLE DB 
Provider for ODBC Drivers.

5. Click the Connection tab and select your Citadel 5 ODBC data source 
name.

6. Click the OK button.

Citadel 5 Tables
Citadel 5 tables are different than Citadel 4 tables. For more information 
about Citadel 5 tables, refer to the Update SQL Queries section of this 
document.
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Revised Historical Data VIs
In this version of the DSC Module, several of the VIs on the Historical Data 
palette have been revised as follows:

• New time stamp type—Doubles that were formatted as show date & 
time have been replaced by the LabVIEW time stamp type.

• Read Trace and Read Traces VIs are now polymorphic for output trace 
type and include a new timeout parameter.

• Read Trace and Read Traces VIs now allow interpolation. Previously, 
the interpolate through gaps parameter for read trend VIs, if set to 
TRUE, removed gaps/breaks. The interpolate data subparameter in 
the options parameter now calculates interpolations, which can slow 
down data retrieval. To only remove gaps/breaks in this version, use the 
option parameter’s remove data breaks subparameter instead.

• A maintain trending info option has been added for the Read Trace 
and Read Traces VIs. If this option is set to TRUE, the returned trace 
includes the first data point before start timestamp and the last data 
point after stop timestamp. If the option is set to FALSE, the returned 
trace includes only points between the start and stop time stamp.

• The new Detach Database VI allows you to programmatically remove 
the logical connection between the DSC Module and a Citadel 
database. You might want to detach a database to have the flexibility to 
move or rename database files without causing errors. Also, you 
should detach all local databases before renaming your computer. A 
detached database does not show up in the Citadel 5 Universe tree view 
in Historical Data Viewer.

• The Make Network Path VI and Split Network Database Path VI are 
gone from the palette, since database paths are no longer used.

• The VIs have new icons.

If you have an existing application that uses previous versions of the 
Historical Data VIs, you do not need to replace them unless you want to 
take advantage of the new functionality. However, previous Historical Data 
VIs are renamed automatically to Legacy_old_VI_name.vi when 
detected in version 7.0.

Table 1.  Comparison of Historical Data VIs

Version 6.x VI Version 7.0 VI

— Create Database

— Detach Database

Archive Database Archive Traces

Call HTV Call HDV
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Compact Database Compact Database

Decimate Historical Trend Decimate Trace

Decimate Historical Trends Decimate Traces

Delete Traces Delete Traces

Get Historical Tag List Get Trace List

Get Historical Trend Info Get Trace Info

Get Trace Names Get Trace List

Historical Trend Statistics Get Trace Statistics

Historical Trend to Spreadsheet Write Traces to Spreadsheet

Historical Trend to Spreadsheet File Write Traces to Spreadsheet File

Launch MAX HDV Call HDV

Make Database Network Path —

Read Historical String Trend Read Trace (String)

Read Historical String Trends Read Traces (String)

Read Historical Trend Read Trace

Read Historical Trend Read Trace (Bit Array)

Read Historical Trend Read Trace (Logical)

Read Historical Trend Read Trace (Numeric)

Read Historical Trends Read Traces

Read Historical Trends Read Traces (Bit Array)

Read Historical Trends Read Traces (Logical)

Read Historical Trends Read Traces (Numeric)

Rename Traces Rename Historical Data

Split Network Database Path —

Table 1.  Comparison of Historical Data VIs (Continued)

Version 6.x VI Version 7.0 VI
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Revised Historical Alarm and Event VIs
In the DSC Module version 7.0, several VIs on the Alarm & Events palette 
have been revised as follows:

• The format of returned alarms has changed to provide additional data.

• The A&E Query to Spreadsheet VI now allows either text or HTML 
output format and allows you to define a header, footer, and delimiter.

• The alarm and event queries support more advanced filtering.

• The Make Network Path VI and Split Network Database Path VI are 
gone from the palette, since database paths are no longer used.

• The VIs have new icons.

If you have an existing application that uses previous versions of the 
Alarms & Events VIs, you do not need to replace them unless you want to 
take advantage of the new functionality. HIST Alarm & Event Query and 
HIST Alarm & Event Query To Spreadsheet File will be renamed 
automatically to Legacy_old_VI_name.vi when detected in version 7.0.

The legacy HIST Alarm & Event Query to Spreadsheet File VI no longer 
supports timeout, table or multicolumn listbox, or colors parameters. If 
you wire values to any of these parameters, you get a warning that the 
features are no longer supported. In addition, you still see any errors from 
the query. The new Alarm & Event Query to Spreadsheet File VI also does 
not support these three parameters.

Table 2.  Comparison of Historical Alarm and Event VIs

Version 6.x VI Version 7.0 VI

Acknowledge Alarm Acknowledge Alarm

Archive Alarms and Events Alarm & Event Archive

Get Alarm Summary Status Get Alarm Summary Status

HIST Alarm & Event Query Alarm & Event Query

HIST Alarm & Event Query to 
Spreadsheet File

Alarm & Event Query to 
Spreadsheet File

Make Network Database Path —

Read Alarm Summary Read Alarm Summary

Read Event History Read Event History

Read Tag Alarm Read Tag Alarm

Split Network Database Path —
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Revised Data Set Logger VIs
This version of the DSC Module includes changes to the Data Set Logger 
VIs, as follows:

• database path in is now database URL.

• New time stamp type—Doubles are replaced by the LabVIEW time 
stamp type.

• New timeout parameter.

If you are updating an existing DSC Module application that uses Data Set 
VIs, you must right-click them on the block diagram and choose to replace 
them with the legacy version available in legacy.llb in the 
vi.lib\lvdsc\servers\Data Set Logger directory. The format of 
the legacy VIs is legacy_old_name.vi. These legacy VIs have the new 
functionality but use previous inputs and outputs.

If you are not upgrading an existing application that uses Data Set VIs, use 
the new Data Set VIs.

Other VI and Palette Changes
• The DSC Module controls and VIs are accessible through the new 

DSC Module icon, shown at left.

• In this version of the DSC Module, the Tag control is located on the 
DSC Module controls palette rather than the I/O controls palette. 

• The Tags palette includes a new Tag Name to DataSocket URL 
function.

• The Get Logging Status VI on the System palette has a new logging 
databases parameter.

New Version of Historical Data Viewer
The Historical Data Viewer that comes with this version of the DSC 
Module allows you to view both Citadel 4 and Citadel 5 databases in 
Measurement & Automation Explorer (MAX). It also allows you to 
convert Citadel 4 databases to the new Citadel 5 format. In addition, 
navigation tools have been added for easier viewing of data sets. 

Revised Historical/Event Logging Configuration
Citadel 5 databases are identified by names instead of paths. So now when 
you select Configure»Historical in the Tag Configuration Editor, a Name 
field is included in the dialog box. For Citadel databases that have not been 
converted to the new Citadel 5 format, the DSC Module creates a name for 
the database using its path and underscores.
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You must give each Citadel 5 database a unique name/path pair. For 
example, you can have a database named Db1 on multiple computers, but 
you cannot have two databases named Db1 on the same computer. Database 
name/path pairs are checked for conflicts whenever you configure 
historical or event logging and when the Tag Engine launches.

When you open a .scf file created in a previous version of the DSC 
Module, you are prompted to convert it and its associated databases to the 
new format. For more information about converting databases, refer to the 
Convert Citadel Databases section.

Enhanced HMI Wizard for Historical Trends
When you right-click a Historical Trend and launch the HMI Wizard, 
you now can select tags from either a database or a .scf file, which is 
convenient if you have not yet logged data.

New Version of Image Navigator
The Image Navigator that comes with the DSC Module version 7.0 
contains over 4,000 symbols. It includes many new symbols, new 
categories, improvements to existing graphics, broader support for various 
file types, and feature enhancements such as drag-and-drop.

Tag Monitor Enhancements
Tag Monitor has the following additional features:

• New display columns—Tag Name and Read/Write Attributes.

• New selections available in the Options menu—Type Mismatch 
Checking, XX for Bad Quality, Hex for Raw Data, Set Decimal 
Places, and Select Columns.

New Examples
The DSC Module version 7.0 comes with additional examples to help you 
develop your application more quickly and easily. The new examples 
include common DSC Module tasks. All examples are accessible in the 
NI Example Finder tool by selecting Help»Find Examples.

Most examples specifically designed for use with the DSC Module make 
use of signal generation VIs available only in LabVIEW Advanced 
Analysis Libraries. These libraries are not included in the LabVIEW Base 
Package. Therefore, the example Demo server will not provide data for the 
examples when the DSC Module is installed with the LabVIEW Base 
Package.
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Online Documentation Enhancements
The DSC Module version 7.0 comes with a Bookshelf in PDF format so 
that you can search National Instruments product documents installed on 
your computer. To access the Bookshelf PDF, select Help»Search the 
DSC Module Bookshelf in LabVIEW. You must have Adobe Acrobat 
Reader version 5.05 or later with Search and Accessibility to use the search 
functionality. Refer to the Adobe Systems Incorporated Web site at 
www.adobe.com to download Acrobat Reader.

The LabVIEW Help includes the following updates for this version of the 
DSC Module:

• Merged help—Use the LabVIEW Help to learn about the DSC Module 
features. You can access the LabVIEW Help by selecting Help»VI, 
Function, & How-To Help in LabVIEW.

• VI icon parameter links—When you click an input or output parameter 
in the help, the help topic jumps to the description of the parameter in 
the scrolling region.

• Place VIs from help—Click either the Place on the block diagram 
button or Find on the Functions Palette button in a VI reference topic 
and switch back to LabVIEW to place the VI on the block diagram.

Change in Bad Quality Status
The error status for application-defined quality is now a warning instead of 
an error. For example, a thermocouple out-of-range state from FieldPoint 
is now a warning and not a bad-quality error.

Changes to NI Services
This version of the DSC Module includes a new version of the Citadel 
service, which appears as National Instruments Citadel in Windows 
Services and nicitdl5.exe in the Task Manager. To start and stop this 
or other NI services, use Windows Services available in the Control 
Panel.

Change to Default Source of Time Stamps
By default, time stamps logged to Citadel with this version come from 
the system clock of the computer running the Tag Engine instead of 
from the server. To have time stamps come from the server, change the 
DSCEngine.ini setting Use Server Timestamps to TRUE. 
Because changing this setting could result in larger Citadel databases, 
NI recommends keeping the default value.

http://www.adobe.com
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Upgrading Existing DSC Module Applications to 7.0
After installing version 7.0 of LabVIEW and the DSC Module, follow the 
instructions in this section to ensure a smooth conversion of your existing 
DSC Module applications.

Convert .scf Files
When you use the Tag Configuration Editor to open a .scf file created in 
a previous version of the DSC Module, a conversion wizard launches and 
leads you through the process of converting your .scf file. The wizard also 
gives you the option of converting existing Citadel 3.x or 4 databases that 
are associated with that .scf file. If the Launch Engine VI attempts to 
access a .scf file that has not yet been converted, an error is returned.

The conversion wizard saves a renamed backup of the original .scf file to 
the same location as the new, converted .scf.

Convert Citadel Databases
The DSC Module version 7.0 logs to and retrieves from Citadel 5 databases 
only. You must convert existing databases to Citadel 5 if you want to use 
them with the new DSC Module.

Databases Associated with a .scf File
When you open a .scf file created in a previous version of the DSC 
Module, a conversion wizard launches. After converting the .scf, the 
wizard gives you the option of converting existing Citadel 3.x or 4 
databases that are associated with that .scf file. NI recommends using the 
default conversion options. If you must save the converted database to a 
location other than the default path due to a shortage of hard drive space, 
for example, you might need to make minor changes to your application.

If you attempt to log data from a converted application without first 
converting the database to Citadel 5, the DSC Module creates a new, empty 
Citadel 5 database in the same location as the Citadel 4 database and logs 
data to that new database. To get all the logged data back into one database 
after that happens, you must use the Historical Data Viewer to convert the 
Citadel 4 database and then merge it with the new Citadel 5 database.

Databases Not Associated with a .scf File
If you choose not to convert a Citadel database when the wizard asks you, 
or if you have an existing database that is not associated with a converted 
.scf file, you can convert the database using the Historical Data Viewer 
in MAX. In LabVIEW, select Tools»DSC Module»View Historical Data. 
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In the window that opens, right-click the Historical Data category, select 
Create New from the shortcut menu, then choose the appropriate 
conversion in the dialog box that appears. If you cannot locate the database 
you want to convert, you might need to create a Citadel 4 version of it in 
Historical Data Viewer before choosing to convert it to Citadel 5.

Remote Databases
You cannot convert a database remotely, or over the network. You must 
convert it on the computer where it exists.

Converted Alarms
Alarm priorities logged by version 6.x of the DSC Module ranged from 
0–10, and those values are retained when converted from Citadel 4 to 
Citadel 5 format. Alarm priorities logged to Citadel 5 from version 7.0 
of the DSC Module range from 0–15.

Redirect NI HyperTrend and HTV to Citadel 5 Data
If your application uses the NI HyperTrend control, right-click the control 
on the front panel and select the tags to display so that data is retrieved from 
the converted Citadel 5 database instead of the Citadel 4 database.

If your application uses Historical Trend Viewer (HTV), launch HTV and 
reselect the tags to display so that data is retrieved from the converted 
Citadel 5 database instead of the Citadel 4 database.

Check for Nondefault Conversion Issues
If you chose not to use the default values while converting a Citadel 
database, or if you renamed a database after conversion, verify that any VI 
parameters such as Citadel path in, source Citadel path, database path, 
data directory, network path, and so on, point to the new database 
location or name.

If you renamed or moved a .scf file after conversion and your application 
includes the Call HTV VI, verify that the scf path parameter of that VI 
points to the file correctly.

Create a New ODBC Data Source
For more information about creating an ODBC data source for Citadel 5, 
refer to the Citadel 5 ODBC Data Source section of this document.
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Update SQL Queries
If you have existing SQL queries for retrieving historical data, you must 
convert them for use with Citadel 5. Refer to Tables 3 and 4, which detail 
the difference in Citadel 4 and Citadel 5 queries.

For more information about each Citadel 5 database table, refer to the PDF 
of the LabVIEW Datalogging and Supervisory Control Module Developer 
Manual, dsc_dev.pdf, in the LabVIEW 7.0\manuals folder.

Citadel 5 Transform Functions
Transform functions have changed with Citadel 5, as shown in Table 4.

Table 3.  Changes in Citadel Tables

Citadel 5 ODBC 
Driver

Citadel 4.x 
ODBC 
Driver  Description 

Aliases N/A Aliases table is used to map alias names to actual tag 
names.

RawData Points RawData table is used to retrieve the actual values logged 
for a tag and times they were logged. You can query only 
one tag at a time.

IntData Traces IntData table is used to retrieve interpolated values. You 
can query more than one tag at a time. 

DS_RawData_
dataset_name 

N/A DS_RawData_dataset_name table is used to retrieve the 
actual values logged for a tag, times, and particular data 
set where logged. You can query only one tag at a time. 

DS_IntData_dataset_
name 

N/A DS_IntData_dataset_name table is used to retrieve the 
interpolated values for a particular data set. You can query 
more than one tag at a time.

Table 4.  Changes in Transform Functions

Citadel 5 ODBC driver 
Citadel 4.x ODBC 

Driver Description 

MATH_MIN(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

MIN(tag) Returns the minimum for tag across the 
interval. 

MATH_MAX(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

MAX(tag) Returns the maximum for tag across the 
interval. 
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Standard set functions (MIN, MAX, AVG, COUNT) are supported and you 
can use them on any Citadel 5 table. It is important to distinguish between 
set functions MIN, MAX, AVG, and Citadel 5 transform functions 
MATH_MIN, MATH_MAX, MATH_AVG. Set functions perform 
calculations on query results. Transform functions perform calculations on 
interpolation intervals.

MATH_AVG(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

AVG(tag) Returns the average for tag across the 
interval. 

MATH_STDEV(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

STDEV(tag) Returns the standard deviation for tag 
across the interval. 

MATH_STARTS(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

STARTS(tag) Returns the number of starts (that is, the 
number of transitions from OFF to ON) 
for tag across the interval. For numeric 
points, 0.0 is interpreted as OFF, and all 
other numbers are treated as ON. 

MATH_STOPS(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

STOPS(tag) Returns the number of stops (that is, the 
number of transitions from ON to OFF) 
for tag across the interval. 

MATH_ETM(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

ETM(tag) Returns the amount of time tag was in 
the ON state across the interval.

MATH_QUAL(tag | 
TO_DISCRETE(tag) | 
TO_CONTINUOUS(tag)) 

QUAL(tag) There might be gaps in the historical 
data traces in Citadel because of 
machine shutdown, Tag Engine 
shutdown, or similar occurrences. 
MATH_QUAL returns the ratio of time 
for which valid data exist for tag across 
the interval to the length of the interval 
itself. If valid data exist for only 
one-half of the interval, MATH_QUAL 
returns 0.5. 

TO_DISCRETE(tag) N/A Casts current tag type to discrete (that is, 
the tag is treated as discrete). 

TO_CONTINUOUS(tag) N/A Casts current tag type to continuous 
(that is, the tag is treated as continuous).

Table 4.  Changes in Transform Functions (Continued)

Citadel 5 ODBC driver 
Citadel 4.x ODBC 

Driver Description 
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Tag names are forced into an accepted format by replacing characters 
within the names with the characters in Table 5.

Long Tag Names and Aliases
Database tables and column names can be only up to126 characters long 
and cannot contain some special characters. Some ODBC clients support 
names only up to 62 characters long. The database URL is not included in 
a tag or data set name. The Citadel 5 driver automatically generates alias 
names for tags or data sets whose names are longer than the Maximum 
Column Name Length value specified in the ODBC configuration dialog 
box. Alias names consist of a prefix and original tag or data set name 
substring, so the total length of the alias string is equal to the Maximum 
Column Name Length value. An alias prefix has the format 
~XXXXXXXXXXXXXXXX_ where XXXXXXXXXXXXXXXX is 
64-bit tag or data set ID. 

Reimport FieldPoint Configuration
If you communicate with FieldPoint in your DSC Module application using 
the FieldPoint IAK server, sometimes referred to as the FieldPoint 
LabVIEW DSC Server or the FieldPoint VI-Based Server, complete the 
following steps after upgrading to version 7.0 of the DSC Module.

1. Uninstall FieldPoint Explorer if you are using a version earlier 
than 3.0.1.

2. Download and install a more recent version of FieldPoint Explorer.

• If you install FieldPoint version 3.0.1 or 3.0.2, mass compile the 
FieldPoint IAK server (the contents of the <LABVIEW>\
_servers\FieldPoint folder), and export your configuration 
to the DSC Module by selecting BridgeVIEW»Export to 
BridgeVIEW from FieldPoint Explorer.

• If you install FieldPoint version 4.0, save a backup of the .scf 
file then revise it to use the FieldPoint OPC Server, in one of two 
ways:

– Use the Tag Configuration Wizard to generate a new set of 
tags using the National Instruments.OPCFieldPoint 
server.

Table 5.  Special Access SQL Characters

Special Character Converted Character

period (.) at sign (@)

forward slash (/) backslash (\)
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– Edit the configuration of each FieldPoint tag—on the 
Connection tab, change the Server Name to National 
Instruments.OPCFieldPoint. Add the tag to an I/O 
Group, and select the appropriate Item.

Special Upgrade Notes for BridgeVIEW Users
The following special topics apply when upgrading directly from 
BridgeVIEW to this version of the DSC Module.

Major Interface Changes
Whereas BridgeVIEW was a stand-alone software package, the DSC 
Module is an add-on to LabVIEW. The items on the BridgeVIEW Project 
menu now appear in the LabVIEW Tools»DSC Module menu. DSC 
Module tools are concentrated in this menu. The controls, indicators, VIs, 
and functions that come with the DSC Module are added to the LabVIEW 
controls and functions palettes. The Tag Engine, the next generation of the 
BridgeVIEW engine, is how the DSC Module manages data.

IAK/IAS Servers
NI recommends that instead of the old IAK (IAS) servers, you use the 
National Instruments Lookout Protocol Drivers OPC Server or the OPC 
servers for NI-DAQ, National Instruments FieldPoint, and National 
Instruments Foundation Fieldbus. For more information about converting 
your application so that it does not use IAK (IAS) servers, refer to the NI 
Developer Zone at ni.com/zone.

Importing Tags
Open the Tag Configuration Editor and select File»Import Network Tags. 
In the dialog box that appears, you can browse to a .scf file on any 
computer on your network and import tags from that file into your local 
.scf file.

You also can use this dialog box to import tags from a remote computer 
using BridgeVIEW 2.x networking. This option is provided for 
compatibility with BridgeVIEW 2.x networking, but NI recommends 
converting to the latest National Instruments Logos networking when 
possible.

You also can access this option in the Tag Configuration Editor with 
BridgeVIEW compatibility pre-selected by selecting Configure»
Network»BridgeVIEW 2.x Networking»Import Network 
Configuration.

http://www.ni.com/zone
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If you have enabled BridgeVIEW 2.x networking in your Tag 
Configuration Editor, the Advanced button on the Configure Network 
Access dialog box is enabled. Click this button in the dialog box to 
launch a Network Settings dialog box. These settings apply only to 
BridgeVIEW 2.x networking.

Converting Network Protocol
In the Tag Configuration Editor, select Configure»Network»Convert 
Network Protocol to convert the currently loaded.scf file from 
BridgeVIEW 2.x network tags to DSC Module Logos tags.

The DSC Module makes use of the Logos communications protocol, 
an internal National Instruments technology for rapid and reliable 
transmission of data across your network and between applications running 
on one computer. You will occasionally encounter the term Logos in data 
addressing and browsing activities, and might find the term used in URLs 
for data connections.

Adjusting Security Levels
BridgeVIEW offered up to 255 security levels. The DSC Module offers 
11 levels, ranging from 0 to 10. The DSC Module does not depend on 
security levels, however, and discourages their use. Instead, NI 
recommends that you use access rights to configure access to controls and 
indicators.

Importing Security User Accounts
You can import your BridgeVIEW user accounts into the User Account 
Manager. If it is not already running, open the National Instruments User 
Account Manager by selecting Tools»DSC Module»Security»Edit User 
Accounts. Then select User»Import BridgeVIEW User Accounts. 
A dialog box appears asking you whether the user accounts you want to 
import are from BridgeVIEW 1.0, 1.1 or later, a BridgeVIEW 2.0 binary 
export, or a BridgeVIEW text export file. Select the correct option to 
complete importing your user information.

When the DSC Module’s User Account Manager imports user accounts 
from BridgeVIEW, it maps the security levels as shown in the Tables 6 
and 7.
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Table 6.  BridgeVIEW Default Security Level Conversions

BridgeVIEW Default 
Security Level

User Account Manager 
Security Level

0 0

25 1

50 2

100 4

150 6

200 8

255 10

Table 7.  BridgeVIEW Security Range Conversions

BridgeVIEW Security 
Level Range

User Account Manager 
Security Level

0 0

1–38 1

39–63 2

64–89 3

90–114 4

115–140 5

141–165 6

166–191 7

192–216 8

217–242 9

243–255 10
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Known Issues
For recent known issues not included in these release notes, refer to the 
dsc_readme.txt file. This version of the DSC Module has the following 
known issues.

Installation
cwui.ocx cannot be registered on a Windows XP computer that has 
Crystal Report 8 installed. Complete the following steps to work around the 
problem by granting the user full access to the cwui.ocx type library 
registry key and its subkeys.

1. Open the registry editor and select the cwui.ocx key, 
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\

{D940E4E4-6079-11CE-88CB-0020AF6845F6}.

2. Select Edit»Permissions and select the appropriate user.

3. Click the Advanced button, click the Edit button, make sure all 
permissions are set, and click the OK button.

4. Enable the Replace permission entries option and click the Apply 
button.

5. From a command prompt, run regsvr32 cwui.ocx to manually 
register cwui.ocx.

Data Logging and Retrieval
• Quitting the Tag Engine using the Task Manager can corrupt the 

Citadel database.

• Database names cannot contain certain characters. They must contain 
only characters A–Z, a–z, 0–9, and the underscore character ( _ ).

• Periodically, you might see CPU usage at 100% due to Citadel and 
SQL services, even when there are no clients present.

• Converting a large (2 GB or more) Citadel 4 database to Citadel 5 is 
slow.

• In Historical Data Viewer, A&E Views might not work after a 
destructive database archive.

• When changing an NI HyperTrend y-axis Minimum and Maximum, 
the Apply button does not work; clicking the OK button applies the 
change. When changing an NI HyperTrend x-axis Width, you must 
right-click the NI HyperTrend and select Restore X Axis Width from 
the shortcut menu to apply the change.



DSC Module Release Notes 22 ni.com

• If you already have a data set tag in your current .scf file and you 
create a new Data Set Logger configuration, your tag to the newly 
created data set might not be valid; if you look under Connections you 
might find it not connected to anything. To fix this problem, restart 
LabVIEW.

• If a remote database connection is lost while your client computer is in 
hibernation mode, an NI HyperTrend display on the client computer 
might hang.

• If you try to configure data sets when the Tag Engine is running, you 
can select tags only from the .scf file being used by the Tag Engine.

• If the network connection is lost while performing an archive operation 
to a remote computer, the operation times out and is aborted instead of 
waiting for communication to be reestablished.

• Historical Data Viewer does not display remote alarms unless the 
remote computer is on the same Windows domain.

OPC
• You experience a hang or error when launching NI-DAQ or the 

DAQ OPC server. A work-around solution is described in the 
NI KnowledgeBase on ni.com, Unusual Error Messages Loading, 
Executing, or Debugging Application When Using NI-DAQ 6.x.

• In Server Explorer or Server Browser, browsing to remote OPC servers 
might not work for certain operating systems.

• Even when an OPC server has items off scan, the Tag Engine can 
connect to the items and the .scf file sets initial values for the items.

• The OPC Demo server might not correctly unload when the Tag 
Engine stops. Exit LabVIEW to unload the server.

• In Server Explorer, you might receive error 0x80080005 when trying 
to launch the OPC LabVIEW server.

• The Tag Engine might not shut down as expected after OPC clients are 
disconnected. If the OPC Server goes down, and you try to shut down 
the Tag Engine on the client computer, the Tag Engine might appear to 
hang. However, it is waiting for the timeout period and will shut down 
after the timeout period, which is about three minutes.

• If you get the message Error Connecting Network Registry when 
attempting to browse OPC server computers across the network under 
Windows Me/98 (by selecting Tools»DSC Module»Advanced»
Server Browser»Network OPC Servers), you must install the 
Remote Registry Service. For more information about installing 
Remote Registry Service, refer to the Microsoft Web article about how 
to install remote administration services.

http://www.ni.com


© National Instruments Corporation 23 DSC Module Release Notes

DSC Module VIs, Communication, and Dialog Boxes
• If data is being written to the Tag Engine while an application is 

reading a trend with a large number of samples (100,000 or more) in a 
tight loop, the read might fail.

• When you attempt to start or stop the Tag Engine from the Engine 
Manager window, certain error messages might be placed under the 
Engine Manager window where they cannot be seen.

• With extrapolate to now set to TRUE and interpolate through gaps 
set to FALSE, Read Historical Trend(s) VIs extrapolate the last good 
value to now, even if the tag status has gone bad.

• A Can’t connect to Lookout error occurs if the HMI Wizard is used 
to create a front panel DataSocket item and the VI is set to run when 
opened. To avoid this error, first open LabVIEW then open and run 
the VI.

• The DSC Module might not correctly report bad status for 
disconnected or unavailable FP-1600 modules.

• Tag control values might reset to 0 instead of the LabVIEW default 
value, last value held, or last value logged.

• The Tag Status Handler VI does not support positive user-defined error 
codes. If any user-defined error code has a positive value, the default 
LabVIEW error message is used.

• The polymorphic Read Trace VI might not automatically change type 
when you wire in a certain data type. To select the correct type, 
right-click the VI on the block diagram and choose Select Type from 
the shortcut menu.

Tag Monitor
• In Tag Monitor, denying read privileges causes a Quality of access 

denied for write-only tags. The read/write column values might also 
not be accurate.

More Information and Updates
For information on DSC Module updates and changes in the future, 
visit ni.com/labviewdsc.

To download the newest patches and other updates, visit 
ni.com/downloads.

http://www.ni.com/labviewdsc
http://www.ni.com/downloads
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