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Getting Started with the LabVIEW™ Mobile Module

Version 2009

The LabVIEW Mobile Module extends the LabVIEW graphical development environment to Mobile
devices so you can create applications that run on Windows Mobile and Pocket PC. You can create
portable solutions for a wide spectrum of applications, such as field test systems, remote control and
monitoring systems, and portable data acquisition systems.

This manual contains new features for version 2009, system requirements, installation instructions, and
a tutorial that shows you how to create a LabVIEW project and build, run, deploy, and debug a Mobile

application.
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System Requirements

The Mobile Module has the following requirements:

* A computer with Windows Vista/XP or Windows 2000 with Service Pack 4.0 or later
*  LabVIEW 2009 Base, Full, or Professional Development System

* 2.5 GB available disk space
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A Mobile device running Windows Mobile 5.0, Windows Mobile 6.0, or Pocket PC 2003

Note For more information about additional software requirements and supported devices
for Windows Mobile and Pocket PC, refer to KnowledgeBase 3ANADAKN: LabVIEW Mobile
Module Software Requirements and Supported Devices at ni . com.

Refer to the LabVIEW Release Notes, available by selecting Start»All Programs»National
Instruments»LabVIEW»LabVIEW Manuals and opening LV _Release Notes.pdf, for standard
LabVIEW development system requirements.

Installing the Mobile Module

Complete the following steps to install the Mobile Module.

1.
2.

Log in as an administrator or as a user with administrator privileges.

Install LabVIEW 2009, if not already installed. Refer to the LabVIEW Release Notes for standard
LabVIEW installation instructions.

Install the Mobile Module from the LabVIEW Platform DVD. The Mobile Module includes
Microsoft tools, such as Microsoft ActiveSync on Windows XP/2000 and ARM emulators for
Windows Mobile. Some of these Microsoft tools might interfere with any existing installations of
Visual Studio, Windows Embedded, or Windows CE toolkits.

@ Note (Windows XP/2000) The Mobile Module installs ActiveSync 4.2 if you do not
already have ActiveSync 4.2 or later installed. The Mobile Module works with
ActiveSync 4.2 or later.

Activate the Mobile Module.

You must activate the Mobile Module before you can build VIs into Mobile applications. The
Mobile Module runs in evaluation mode if you do not activate it. In evaluation mode, you can create
VlIs, but any Mobile applications you build run only for five minutes. You have the option of
activating the Mobile Module at the end of the installation. You also can use the NI License Manager,
available by selecting Start»All Programs»National Instruments»NI License Manager, to
activate National Instruments products. Refer to the National Instruments License Manager Help,
available by selecting Help»Contents in the NI License Manager, for more information about
activating NI products.

Restart the computer when the installer completes.

(Windows Vista) You must install Windows Mobile Device Center to use the Mobile Module.
Refer to the Microsoft Web site at www.microsoft.com to download Windows Mobile Device
Center.

Install the additional tools you need. Refer to the Installing Additional Tools section for more
information about additional tools.

Uninstalling the Mobile Module

In addition to uninstalling the Mobile Module, you also must uninstall the following:

(Windows XP/2000) Microsoft ActiveSync
Microsoft Device Emulator version 1.0 — ENU
Microsoft Visual C++ 2005 Redistributable

Installing Additional Tools

You must install additional tools on the target depending on the functionality you need.
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Shared Variable Support

To use front panel data binding and Shared Variable nodes in Mobile applications, you must install the
latest version of shared variable support on the target.

Complete the following steps to install or uninstall support for shared variables on a Mobile target.
1. Connect the device to the host computer using ActiveSync/FTP.
2. Navigate to and run labview\PDA\Utilities\Variables\PocketPC\Setup.exe.

@ Tip You also can right-click the target in the Project Explorer window and select
= Install»Support for Shared Variables from the shortcut menu.

(ARM Emulators) You also must install Virtual PC 2007 on the host computer. Download the appropriate
installer from the Microsoft Download Center at www.microsoft.com/downloads.

PNG Image Support

You must install support for PNG images on the target if the VI contains PNG images on the user
interface.

Complete the following steps to install or uninstall support for PNG images on a Mobile target.
1. Connect the device to the host computer using ActiveSync/FTP.
2. Navigate to and run labview\PDA\Utilities\LVPNG\PocketPC\Setup.exe.

@ Tip You also can right-click the target in the Project Explorer window and select
= Install»Support for PNG Images from the shortcut menu.

NI-VISA Support

You must install NI-VISA on the target to use VISA in Mobile applications. If you did not install
NI-VISA when you installed the Mobile Module, select Start»All Programs»National
Instruments» VISA»Windows Mobile Driver Installation.

@ Tip You also can right-click the target in the Project Explorer window and select
= Install»Support for NI-VISA from the shortcut menu.

WIDCOMM Bluetooth DLLs

You can use the WIDCOMM Bluetooth DLLs on a Mobile device to run applications that use Bluetooth
communication if you do not have the Microsoft Bluetooth driver.

@ Note The Mobile Module supports the WIDCOMM BTW-CE 1.4 or later driver. Do not
install the WIDCOMM Bluetooth DLLs if you are using the Microsoft Bluetooth driver or
you receive an error when you use the Bluetooth VIs and functions. If your device uses the
Broadcom Bluetooth driver, install the LabVIEW WIDCOMM Bluetooth driver by manually
copying LvBtw.d11 from the 1abview\PDA\Utilities\Bluetooth directory to the
Windows directory. Do not run Setup.exe and do not copy BtCoreIf.d1l1l or
BtSdkCE30.d11 if they already exist on the device.

Complete the following steps to install the WIDCOMM Bluetooth DLLs.
1. Connect to ActiveSync on the host computer.
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2. On the host computer, run labview\PDA\Utilities\Bluetooth\Setup.exe to install the
DLLs on the device.

@ Tip  You also can right-click the target in the Project Explorer window and select
€ Install»Support for WIDCOMM Bluetooth from the shortcut menu.

Refer to README . txt, located in the 1abview\PDA\Utilities\Bluetooth directory, for more
information about manually installing the WIDCOMM Bluetooth DLLs.

LabVIEW SMS Client

You must install and run the LabVIEW SMS Client, which is located in
labview\PDA\Utilities\SMS\Setup.exe, on the host computer to receive Short Message Service
(SMS) messages or to use the Request Make Call VI. The LabVIEW SMS Client notifies the Mobile
application if there is an incoming SMS message and stores the incoming message in LVSMSClient.dat,
which is located in the \Program Files\National Instruments\labview\SMS directory on the
target.

Complete the following steps to install or uninstall the LabVIEW SMS Client on a Mobile target.

1. Perform a soft reset on the device. Refer to your device documentation for information about
performing soft resets.

2. Connect the device to the host computer using ActiveSync.
3.  Run setup.exe on the host computer to install or uninstall the required DLLs.

You also can right-click the target in the Project Explorer window and select Install»Support for
SMS Client from the shortcut menu.

NI-DAQmx Base

You can download the latest version of NI-DAQmx Base for use with Mobile devices from the National

Instruments Web site. After you complete the NI-DAQmx Base installation, you must copy the driver

files to the device.

Complete the following steps to install NI-DAQmx Base on the Mobile device.

1. Select StartyPrograms»National Instruments»NI-DAQmx Base» Utilities.

2. Launch the Driver Installation utility that corresponds to the Mobile device.

3. Check the device screen to see if any additional steps are requested, such as replacing an older
driver.

Refer to the NI-DAQmx Base Readme and the NI-DAQmx Base 3.x Getting Started Guide for more
information about NI-DAQmx Base.

Windows Mobile Emulators

Emulators are tools you can use during development to run and test Mobile VIs quickly without having
to download the application to the target.

ARM Emulators
If you are using ARM-based emulators, you must install Virtual PC 2007.

(Windows Vista) If you want to use emulators on host computers that use Windows Vista, you must
download the Microsoft Device Emulator 2.0.

Download Virtual PC 2007 and the Microsoft Device Emulator 2.0 from the Microsoft Download Center
at www.microsoft.com/downloads.
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x86 Emulators

On host computers with Windows XP/2000, the Mobile Module installs ARM targets, including emulators,
for Windows Mobile and Pocket PC. If you need x86 emulator targets, install the following Microsoft
eMbedded Visual Tools:

. Microsoft eMbedded Visual C++ 4.0
. Microsoft eMbedded Visual C++ SP 4 or later
. SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni . com/info and enter the info code pdaevc for
the most recent information about downloading and installing the Microsoft eMbedded Visual Tools.

What's New

Refer to the LabVIEW Upgrade Notes, available by selecting Start»All Programs»National
Instruments»LabVIEW»LabVIEW Manuals and opening LV_Upgrade_ Notes.pdf, for more
information about new features and changes in the LabVIEW development system.

Refer to the Mobile Module book on the Contents tab of the LabVIEW Help, available by selecting
Help»Search the LabVIEW Help in LabVIEW, for more information specific to the Mobile Module
and Mobile applications.

Refer to the LabVIEW Mobile Module Readme, available by selecting Start»All Programs»National
Instruments»LabVIEW»Readme and opening readme Mobile.html, for known issues.

The LabVIEW 2009 Mobile Module includes the following enhancements and features.
Vls and Functions Support and Enhancements

The Mobile Module includes the following support and enhancements:
+  Additional Fixed-Point Support—The following functions now support the fixed-point data type:
—  Divide
—  Reciprocal
—  Square Root
— InRange and Coerce
—  Unflatten From XML
—  Flatten To XML
+  Execution Highlighting Support—The Mobile Module now supports execution highlighting, which

you can use to view an animation of the execution of the block diagram. Execution highlighting is
supported only for instrumented debugging.

* VI Call Configuration Support—Use the VI Call Configuration dialog box to configure when to
load a subVI. Right-click a subVI and select Call Setup from the shortcut menu to display this
dialog box.

Front Panel Controls Support and Enhancements

The Mobile Module includes the following support and enhancements:
*  Graph and Chart Control Enhancements—The graph and chart controls include the following
enhancements:

—  Improved Appearance—Graphs and charts in Mobile applications now have a high-color,
three-dimensional appearance. Graphs and charts also include improved placement and
appearance of scale labels and the plot area.

—  Plot Legend Support—Graphs and charts now support the plot legend, which you can use to
customize how the plot appears in the plot area of a graph or chart.
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—  Cursor Legend Improvements—Graphs and charts in Mobile VIs now use the same cursor
legend as graphs and charts in VIs running on Windows.

—  Scale Legend Improvements—Graphs and charts in Mobile VIs now use the same scale legend
as graphs and charts in VIs running on Windows.

—  Graph Palette Support—Graphs and charts now support the graph palette, which you can use
to move cursors, zoom, and pan the display.

LabVIEW Class Support

You can now use LabVIEW classes in Mobile VIs in the same way you use LabVIEW classes in VIs
running on Windows.

The Mobile Module now supports using the following node and functions with LabVIEW classes:
*  Call Parent Method

*  Preserve Run-Time Class

*  To More Generic Class

*  To More Specific Class

The Mobile Module does not support using LabVIEW classes in the following VIs and functions:
*  Get LV Class Default Value

*  Get LV Class Path

+  Flatten To String

*  Unflatten From String

»  Flatten To XML

*  Unflatten From XML

*  Variant To Flattened String

*  Flattened String To Variant

»  File I/O VIs and functions

You cannot probe a LabVIEW class data type. You can debug and probe values on any static, dynamic,
and accessor VIs of a LabVIEW class.

Tutorial

Use this tutorial to learn how to use the Mobile Project Wizard to create a LabVIEW project and build,
run, and debug a Mobile application.

The VI in this tutorial simulates a sine wave with configurable offset and frequency values and displays
the result in a graph.

Creating the LabVIEW Project

Use LabVIEW projects to group together LabVIEW files and non-LabVIEW files, create build
specifications for building a Mobile VI into an application, and deploy the application to the target. You
must use a project to build a Mobile VI into an application.

Using the Mobile Project Wizard, complete the following steps to create a LabVIEW project, add the
target, and add an existing VI to the project.

1. Launch LabVIEW. In the Getting Started window, select Mobile Project from the Targets
pull-down menu. Click the Go button to launch the Mobile Project Wizard.
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2. Define the project information as shown in Figure 1.

a. Select New Mobile project, import VI from the Project type pull-down menu to create the
LabVIEW project using an existing VI.

@ Tip The blank VI project type creates a project with a new Mobile template VI rather
= than importing an existing VI.

b.  Specify a project name and the location where you want to save the project and the VI in the
Project location text box. Save the project to a location other than the default location so you
do not overwrite the shipping example with your changes. The default project name is
Untitled project.lvproj.For this tutorial, name the project Mobile Tutorial.lvproj
in the Project location text box.

c.  Click the Browse button next to the VI path text box and navigate to labview\examples\
WindowsMobile\tutorial\Mobile Tutorial.vi to select the VI to import. Click the
OK button to add the VI to the project you are creating.

13 Create New Mobile Project

Define project informiation

Project bype
Mew Mobile project, impart VI ™M

Select this option to create a Mobile project and import &
previously created Wl

Project location

CDocuments and SetbingsisgrayiiMy Documents),
LabWIEW DatalMobile Tutorial, lvproj

Y1 path
C!\Program Files\Mational InstrumentsiLabWIEW 8.6)

examplesiwindowsMobileitutorialiMobile Tutorial. vi

| < Back |[ Mext = ] | Finish |[ Cancel ][ Help

Figure 1. Defining the Project Information

3. Click the Next button.

4. Select Windows Mobile 5.0 Pocket PC Emulator from the Device type pull-down menu, as
shown in Figure 2.
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{3 Create New Mobile Project

Select device type

Device bype
windows Mobile 5.0 Pocket PC Emulatar (]

[ < Back ][ Mext = ] | Finish H Cancel ” Help

Figure 2. Selecting the Target

@ Note You might see additional targets for Windows Mobile or Pocket PC if you
configure additional devices through the Microsoft Device Emulator Manager.

5. Click the Next button.

6.  Click the Finish button. Because the Create a build specification checkbox contains a checkmark,
as shown in Figure 3, the Mobile Build Specification Properties dialog box opens. Refer to the
Creating the Build Specification section for more information about creating a build specification.
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13 Create New Mobile Project

Syskem preview
= @ Windows Mobile 5.0 Pocket PC Emulator

Create a buid specification

m]. Mabile Tutorial.vi
_4;_" Dependencies
:‘_ Build Specifications

’ < Back “ Mexk = | ’ Finish ” Cancel ” Help

Figure 3. Previewing the Project

Creating the Build Specification

Build specifications contain the build settings and code generation options to use when you build a
Mobile VI into an application. You can create the build specification when you create a project or wait
until you are ready to build the application. You must create a build specification before you can build
a Mobile VI into an application.

You can have multiple build specifications for the same target. For example, you might want one build
specification that generates debugging information and another build specification that does not generate
this extra information.

5

Note This tutorial creates the build specification through the Mobile Project Wizard. You
also can create a build specification at any time by right-clicking Build Specifications under
the target in the Project Explorer window and selecting New»Mobile Application (EXE)
from the shortcut menu.

Complete the following steps to create a Mobile build specification.
1. Define the settings for the Mobile application, as shown in Figure 4.

a.

b.

Enter Mobile Tutorial in the Build specification name text box. This is the name that
appears under Build Specifications in the Project Explorer window.

(Optional) By default, the name of the application is the same as the top-level VI. If you do
not want to use the top-level VI name for the application name, remove the checkmark from
the Same as top-level VI checkbox and enter a name in the Target filename text box.
Browse to and select the destination directory for the application on the host computer, which
is where LabVIEW saves the . exe, in the Destination directory text box.
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d.  Enter the destination directory for the application on the target in the Remote path for target
application text box.

{# Mobile Tutorial Mobile Build Specification Properties

Categor | Application Information
Application Information

Device Information

Build specification name

Source Files

Source File Settings Maobile Tutarial
Machine Aliases

Generated Files Target filename

MMobile Tukorial exe Same as top-level VI

Destination direckory

CiDocuments and SettingsisgrayiMy DocumentsibuildsiMobile Tutorialifobile
Tutorial

Remote path For targek application

My Documents

[] Generate serial anly [1 Expression Folding
[] Enable debugging

Front panel scale Factor Allocate constants

z First Use i
Screen depth Deallocate constants

=] v Qut of Scope |

[ K ][ Cancel ][ Help

Figure 4. Defining the Application Information

2. (Optional) Click the Help button to open the LabVIEW Help and read a description of each build
setting.

3. Select the Device Information category to view which target and processor this build specification
applies to.

4. Select the Source Files category to select the source files to include when you build the VI into an
application. When you use the Mobile Project Wizard to create a build specification, LabVIEW
automatically uses the VI you import as the top-level VI. When you create build specifications
outside of the wizard, you must manually select the top-level VI and click the blue arrow button
to move the VI to the Top-level VI text box, as shown in Figure 5. Mobile applications can have
only one top-level VI.
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{3 Mobile Tutorial Mobile Build Specification Properties X
Categor | Source Files
Application Information
Device Information Project Files [A
5 Fil
SEE:E: F:.l.szettings =[] Windows Mabile 5.0 Packet PC Emalator Top-level VI
Machine Aliases = E] | |ml Mabile Tutarialvi |
Generated Files
Additional files {*.c, *.cpp, *.lib, *.0bj) [A]
(v]
<] EY
Always included (*,vi) [A]
(] (v]
<] M 2] <] EY
[ (o] 4 ] [ Cancel ] [ Help ]

Figure 5. Selecting the Source Files

5. Select the Generated Files category to view the filenames and paths to the files the Mobile Module

generates when you build the VI into an application.

6. Click the OK button. The build specification you just created appears in the Project Explorer
window under the Mobile target, as shown in Figure 6.
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i3 Project Explorer - Mobile Tutorial.lv... E]@

File Edit WYew Project Operate Tools Window Help

== I TR

Items | Files

= ng, Project: Mobile Tutorial. lvproj
5 B My Computer
: L. 55 Dependencies
: "% Build Specifications
= @ windows Mobile 5.0 Pocket PC Emulator
il Mobile Tutorial vi
: _'E' Dependencies
= "% Build Specifications
L. '[0) Mabile Tutorial

Figure 6. Project Explorer Window

7. Select File»Save Project in the Project Explorer window to save the project. LabVIEW saves
any build specifications with the project.

Building the VI into an Application and Deploying

After you develop the VI on the host computer, you build the VI into an executable application that you
can run on a target. Pick one of the options in the Using the Shortcut Menu section or the Using the Run
Button section of this manual to build, deploy, and run the application.

Click the Run button in the application on the target to start simulating the sine wave.

@ Note ARM emulators for Windows Mobile require a few minutes to load the OS before you
see the application running on the emulator target.

Using the Shortcut Menu
Right-click the build specification in the Project Explorer window and select one of the following
options from the shortcut menu:

*  Deploy—Builds the VI into an application, if necessary, and deploys the application to the target.
This option does not run the application automatically.

*  Run—Builds the VI into an application, if necessary; deploys the application to the target; and
runs the application automatically.

Getting Started with the LabVIEW Mobile Module 12 ni.com



*  Build—Builds the VI into an application. This option does not deploy or run the application
automatically.

Using the Run Button

When you run a VI under the Mobile target in the Project Explorer window, the Run button behaves

differently from when you run a VI under My Computer in the Project Explorer window:

«  If you want to build, deploy, and run—Click the Run button in a VI to build the VI into an
application, deploy the application to the target, and run the application on the target. LabVIEW
prompts you to create a build specification if you do not have an existing build specification for
the VI. If you have multiple build specifications, LabVIEW prompts you to select a build
specification in the Select a Build Specification dialog box. Alternatively, you can specify a default
build specification by right-clicking a build specification in the Project Explorer window and
selecting Set as Default from the shortcut menu. LabVIEW indicates the default build specification
with a green square around the build specification glyph in the Project Explorer window.

+  If you want to build without deploying or running—Press the <Ctrl> key while you click the
Run button in a VI to build the VI into an application without deploying or running the application.
LabVIEW prompts you to create a build specification if you do not have an existing build
specification for the Mobile VI. If you have multiple build specifications, LabVIEW prompts you
to select a build specification in the Select a Build Specification dialog box. Alternatively, you
can specify a default build specification by right-clicking a build specification in the Project
Explorer window and selecting Set as Default from the shortcut menu. LabVIEW indicates the
default build specification with a green square around the build specification glyph in the Project
Explorer window.

Closing the Application
Tap the Exit button in the application on the Mobile target to close the application.

Debugging the Application

You must create a build specification that enables debugging before you can debug a Mobile application.
Enabling debugging generates extra debugging information and can significantly increase the size of
the application.

When LabVIEW on the host computer connects to the Mobile target, the application runs on the target.
The front panel is fully functional on the target. However, the front panel controls have no effect on the
application, and the indicators in the VI on the host computer do not reflect the execution of the application
on the target.

The block diagram acts as a conduit between the application running on the target and the VI running
on the host computer, where you can probe signals, set breakpoints, and step through code as you do in
any other VL.

@ Tip  You can modify an existing build specification by double-clicking the build specification
= in the Project Explorer window or right-clicking the build specification and selecting Properties
from the shortcut menu. This tutorial creates a second build specification for debugging.

Creating a Debugging Build Specification

Complete the following steps to create a debugging build specification.

1. Right-click Build Specifications under the Mobile target and select New»Mobile Application
(EXE) from the shortcut menu to open the Mobile Build Specification Properties dialog box.

2.  Enter (Debug) Mobile Tutorial in the Build specification name text box.
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3. Remove the checkmark from the Same as top-level VI checkbox so you can change the application
name.

Enter (Debug) Mobile Tutorial.exe inthe Target filename text box.

5. Place a checkmark in the Enable debugging checkbox to generate debugging information when
you build the VI into an application, as shown in Figure 7.

b My Application Mobile Build Specification Properties

Categor | Applicaton Information
Application Information

Device Information
EBuild specification name

Source Files

Source File Settings {Debug) Mobile Tutarial
Machine Aliases

Generated Files Target filename

{Debug) Mobile Tutorial exe [ same as top-level ¥1

Destination direckary

C:iDocuments and SettingstsgrayiMy DocumentsibuildsiMobile Tutoriali{Debug)
Mobile Tukorial

Remote path for targek application

My Documents

[ Generate serial only [1 Expression Folding
Enable debugging

Front panel scale Factor Allocate constants

2 First Use |
Screen depth Deallocate constants

g ] ouk of Scope [»e]

[ oK ][ Cancel ][ Help

Figure 7. Creating the Debugging Build Specification
6.  Select Source Files from the Category list and select Mobile Tutorial.vi in the Project Files list.

Click the blue right arrow button to move the VI from the Project Files list to the Top-level VI
text box.
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7. Click the OK button. The build specification you just created appears in the Project Explorer
window, as shown in Figure 8.

& Project Explorer - Mobile Tutorial.lv... g@

File Edit Yiew Project Operate Tools Window Help

=T X[ E5 o | R~

Ttems | Files

= ﬁ_gé, Project: Mobile Tukorial, lvproj
5 B My Computer
_'l:? Dependencies
_ "% Build Specifications
= [E] Windows Mobile 5.0 Pocket PC Emulator
i [ml Mobile Tutarial.vi
_'l:? Dependencies
= 1 Build Specifications
+IE] IMobile Tutorial
... |0 {Debug) Mabile Tutorial

Figure 8. Two Build Specifications in the Project Explorer Window

Adding a Probe to the VI

Probes display information about the data that passes through a wire. As you interact with the application
on the target, you can see the data passing through the wire in the corresponding VI on the host computer.

Complete the following steps to add a probe to the Mobile Tutorial VI.
1. Select Window»Show Block Diagram in the VI to open the block diagram if it is not visible.

@ Tip Double-click the VI in the Project Explorer window to open the VI if the VI is not
= already open.

2. Right-click the wire connecting the Frequency control to the For Loop and select Probe from the
shortcut menu.
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A floating Probe window appears when you create a probe. LabVIEW numbers the Probe windows
automatically and displays the same number in a glyph on the wire you probe, as shown in Figure

Frequency 7]
o=y '

Qffset Sirulaked Signal
[DEL H——IH |— FDEL]

Figure 9. Adding a Probe to the Block Diagram

Deploying and Debugging a Mobile Application

You must use the debugging build specification to deploy the application, which contains debugging
information, to the target before the probe in the VI on the host computer can update the values passing
through the wire.

Complete the following steps to deploy and debug the Mobile application.
1. Right-click the debugging build specification you want to build and deploy and select Debug from
the shortcut menu. Save any VlIs if prompted.

LabVIEW builds the VI into an application, deploys the application to the target, and runs the
application on the target as shown in Figure 10. A new instance of the emulator opens each time
you build and deploy an application.
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Figure 10. Running the Application on the Emulator

2. Click the Run button in the application on the target.

3. Move the Frequency slider in the application running on the target and click the Run button again.
The value in the Probe window on the block diagram updates as you move the slider in the
application on the target.

@ Note Any changes you make on the front panel of the Mobile VI on the host computer
have no effect on the application running on the target.

4.  Click the Exit button in the application on the target to stop the application and end the debugging
session.

Related Documentation

LabVIEW includes extensive online and print documentation for new and experienced LabVIEW users.

The following documents contain information that you might find helpful as you use the Mobile Module:

e LabVIEW Help—Refer to the LabVIEW Help, available by selecting Help»Search the LabVIEW
Help in LabVIEW, for information about LabVIEW programming concepts, step-by-step instructions
for using LabVIEW, and reference information about LabVIEW Vls, functions, palettes, menus,
and tools. Refer to the Mobile Module book on the Contents tab of the LabVIEW Help for
information specific to the Mobile Module and Mobile applications. The LabVIEW Help uses
(Mobile) in the index to indicate Mobile-specific topics.
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e LabVIEW Mobile Module Readme—Refer to the LabVIEW Mobile Module Readme, available
by selecting Start»All Programs»National Instruments»LabVIEW»Readme and opening
readme Mobile.html, for last-minute information and known issues.

*  Mobile Module Examples—Use the Mobile Module examples to learn how to use certain VIs
and functions as well as a starting point for developing your own Mobile VIs and applications.
You can modify an example to fit an application, or you can copy and paste from one or more
examples into a VI that you create. Browse or search the example VIs with the NI Example
Finder by selecting Help»Find Examples.

*  NI-DAQmx Base 3.x Getting Started Guide

*  NI-DAQmx Base Readme

*  Documentation for your device.

. LabVIEW PDFs—In addition to this document, the Getting Started with LabVIEW manual,
LabVIEW Quick Reference Card, LabVIEW Release Notes, and LabVIEW Upgrade Notes are
available as PDFs by selecting Start»All Programs»National
Instruments»LabVIEW»LabVIEW Manuals.

@ Note You must have Adobe Reader 6.0.1 or later installed to view or search the PDF
versions of these manuals. Refer to the Adobe Systems Incorporated Web site at
www . adobe . com to download Adobe Reader. Refer to the National Instruments Product
Manuals Library at ni . com/manuals for updated documentation resources.

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments
Corporation. Refer to the Terms of Use section on ni.com/legal for more information about
National Instruments trademarks. Other product and company names mentioned herein are
trademarks or trade names of their respective companies. For patents covering National
Instruments products/technology, refer to the appropriate location: Help»Patents in your software,
the patents. txt file on your media, or the National Instruments Patent Notice at ni . com/patents.
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