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About This Manual

This manual provides tutorials you can use to get started programming a 
robot with the FIRST Tech Challenge (FTC) software. Use this manual to 
build and program a robot that moves according to commands you send 
from a game controller.

Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names, front panel controls and indicators, dialog boxes, sections of dialog 
boxes, menu names, and palette names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also emphasizes lines of code 
that are different from the other examples.
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Related Documentation
The following documents contain information that you may find helpful as 
you read this manual.

Programming in LabVIEW
If you use LabVIEW to program the robot, refer to the following 
documents:

• Getting Started with the LabVIEW Toolkit for LEGO® 
MINDSTORMS® NXT—Use this manual to learn how to develop 
NXT VIs in the LabVIEW environment. You can use the LabVIEW 
Toolkit for LEGO MINDSTORMS NXT to develop FTC programs. 
Access this manual by navigating to the National Instruments\
LabVIEW 8.5\manuals directory and opening 
NXT_Getting_Started.pdf.

• LabVIEW Help—Use the LabVIEW Help to access information about 
LabVIEW programming concepts, step-by-step instructions for using 
LabVIEW, and reference information about LabVIEW VIs, functions, 
palettes, menus, tools, properties, methods, events, dialog boxes, and 
so on. The LabVIEW Help also lists the LabVIEW documentation 
resources available from National Instruments. Access the LabVIEW 
Help by selecting Help»Search the LabVIEW Help in LabVIEW. 
You also can access reference information about the FTC VIs and 
dialog boxes directly by selecting Help»FIRST Tech Challenge VI 
Reference.

• LabVIEW Quick Reference Card—Use this card as a reference for 
information about documentation resources, keyboard shortcuts, data 
type terminals, and tools for editing, execution, and debugging. Access 
this manual by navigating to the National Instruments\
LabVIEW 8.5\manuals directory and opening 
LV_Quick_Reference.pdf.

Programming in LEGO MINDSTORMS
If you use LEGO MINDSTORMS to program the robot, refer to the 
following documents:

• LEGO® MINDSTORMS® Education NXT User Guide—Use this 
manual to learn about the NXT device, the different motors and 
sensors available with LEGO MINDSTORMS Education NXT, and 
the LEGO MINDSTORMS environment. This printed manual is part 
of the LEGO MINDSTORMS Education NXT kit.
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• Help and Support for LEGO® MINDSTORMS® Education NXT—Use 
the Help and Support for LEGO® MINDSTORMS® Education NXT to 
access information about LEGO MINDSTORMS programming 
concepts and reference information about LEGO MINDSTORMS 
blocks. Access the Help and Support for LEGO® MINDSTORMS® 
Education NXT by selecting Help»Contents and Index in LEGO 
MINDSTORMS.

Third-Party Web Sites
The following third-party Web sites contain information that you may find 
helpful as you use the FTC software.

• FTC Community—Refer to the FTC Community Web site at 
www.usfirst.org/community/ftc for official information about 
the FTC competition, including rules and regulations as well as 
support information.

• Carnegie Mellon University Robotics Academy—Refer to the 
Carnegie Mellon University Robotics Academy Web sites at 
www.education.rec.ri.cmu.edu/content/events/ftc/

labview and www.education.rec.ri.cmu.edu/content/
events/ftc/nxt_g to access FTC training materials about 
programming in LabVIEW and LEGO MINDSTORMS, respectively.

• Center for Engineering Educational Outreach—Refer to the Center 
for Engineering Educational Outreach (CEEO) Web site at 
www.ceeo.tufts.edu to access educational materials and sample 
programs that you can use to interact with an NXT device.

http://www.education.rec.ri.cmu.edu/content/events/ftc/labview
http://www.education.rec.ri.cmu.edu/content/events/ftc/labview
http://www.ceeo.tufts.edu/
http://www.education.rec.ri.cmu.edu/content/events/ftc/nxt_g
http://www.education.rec.ri.cmu.edu/content/events/ftc/nxt_g
http://www.usfirst.org/community/ftc
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1
Overview of the FIRST Tech 
Challenge

The objective of the FIRST Tech Challenge (FTC) competition is to build 
and program a robot to perform certain tasks in Autonomous and 
TeleOperated modes.

Autonomous and TeleOperated Modes
In Autonomous mode, the robot moves without input from game 
controllers. You use either LabVIEW or LEGO MINDSTORMS to 
develop a program and then download that program to the NXT device 
on the robot. When you run the program, the robot moves and behaves 
according to instructions in the program itself.

In TeleOperated mode, the robot moves in response to commands it 
receives from one or two game controllers. As in Autonomous mode, you 
develop a program in LabVIEW or LEGO MINDSTORMS and then 
download that program to the NXT device on the robot. The program must 
contain instructions that allow the robot to receive data from the game 
controllers and respond accordingly. When you run the program, you then 
can use the joysticks and buttons on the game controllers to manipulate the 
behavior of the robot.

If you want the robot to respond to commands it receives from game 
controllers, connect the game controllers to a host computer through a USB 
connection. Use a controller station running on the host computer to receive 
data from the game controllers, convert the data to a form the program 
running on the NXT device can understand, and then send the data through 
either a USB or Bluetooth connection to the NXT device on the robot.

During the actual FTC competition, FIRST provides a field management 
system (FMS) that acts like a controller station and can connect to multiple 
robots at once.
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Enabled and Disabled Status
At certain points in the FTC competition, the program on the NXT device 
must be running, but the robot cannot move. For example, at the beginning 
of the Autonomous part of the competition, you must run the Autonomous 
program on the NXT device, place the robot on the field, and return to the 
team area. The robot cannot start moving until all teams have placed their 
robots on the field and returned to their positions. Similarly, between the 
Autonomous and TeleOperated parts of the competition, the robots must be 
running in TeleOperated mode but cannot move until the judges have 
finished tallying the scores for the Autonomous portion.

During these times, the FMS sets the status of the robots to Disabled. The 
program you run on the NXT device must handle the Disabled status such 
that the robot does not move and does not respond to any commands from 
the game controllers. When the FMS sets the status of the robots to 
Enabled, the program you run on the NXT device must recognize this 
change in status. The program must handle the Enabled status such that 
the robot then starts moving or responding to commands from the game 
controllers.

FTC Software Components
The FTC software includes LabVIEW, LEGO MINDSTORMS Education 
NXT, and the LabVIEW Toolkit for LEGO MINDSTORMS NXT, as well 
as FTC-specific LabVIEW VIs and LEGO MINDSTORMS blocks. You 
can use this software to program a robot in either LabVIEW or LEGO 
MINDSTORMS. The FTC software also includes a controller station, 
accessible by navigating to the National Instruments\
LabVIEW 8.5\examples\FTC Toolkit\FTC Controller Station 
directory or the LEGO Software\LEGO MINDSTORMS Edu NXT\
examples\FTC Toolkit\FTC Controller Station directory and 
opening FTC Controller Station.exe.

In the following chapters, you can build a robot, program the robot with the 
FTC software, manipulate the behavior of the robot with a game controller, 
modify the program, and manipulate the behavior of the robot again.
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2
Building the Robot

Follow the illustrations in this chapter to build a robot using hardware 
available in the FIRST Tech Challenge (FTC) kit.

Note The robot you build in this chapter works with the programs discussed in later 
chapters of this manual. However, the robot and the programs in this manual are only 
examples of the kinds of robots and programs you can develop for the FTC competition. 
You can build a robot of any shape or size and design programs to manipulate the behavior 
of the robot in whichever way you want to accomplish the goals of the FTC competition.

The first illustration in this chapter shows the completed hardware 
assembly of the robot as well as a list of parts. Ensure you have all the 
necessary parts before beginning to build the robot.
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3
Connecting the Motors, 
Batteries, and Game Controllers

The robot you build in Chapter 2, Building the Robot, is not complete 
because it cannot perform any automated tasks. You must connect the 
motors to the NXT device so that the program running on the NXT device 
can move the motors. You also must provide power to the motors. Finally, 
you must connect the game controllers to the host computer on which you 
want to run the FIRST Tech Challenge (FTC) Controller Station.

Connecting the Motors
You need the following hardware parts to connect the motors to the NXT 
device:

• one black 6-wire cable

• one motor controller

• two split gearhead motor connection wires

Complete the following steps to connect the motors to the NXT device.

1. Connect one end of the black 6-wire cable to any of ports 1–4 on the 
NXT device.

2. Connect the other end of the black 6-wire cable to a sensor terminal on 
the motor controller. Because this motor controller is connected 
directly to the NXT device, this motor controller is motor controller 1 
on the port.

3. Connect the base end of a gearhead motor connection wire to the motor 
controller.

4. Connect one of the split ends of the gearhead motor connection wire to 
the gear head of the motor you want to use as the front left motor.

5. Connect the other split end of the gearhead motor connection wire to 
the gear head of the motor you want to use as the rear left motor.

6. Repeat steps 3 through 5 for the front and rear right motors of the 
robot. All four motors now are connected to the NXT device through 
motor controller 1.
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Note Instead of wiring the corresponding front and rear motors together, you also can wire 
the two front motors together and the two rear motors together. If you use this second 
method, however, be sure to program the left motors to move in the reverse direction of the 
right motors.

Providing Power to the Motors
You need the following hardware parts to provide power to the motors:

• one battery pack

• one “Y” quick connect cable

Complete the following steps to provide power to the motors.

1. Connect one end of a “Y” quick connect cable to a battery pack.

2. Connect the other end of the “Y” quick connect cable to a power 
terminal on motor controller 1. Because all four motors are connected 
to motor controller 1, all four motors now can receive power.

Connecting the Game Controllers
When the robot is in TeleOperated mode, the robot responds to commands 
it receives from one or two game controllers. Connect each game controller 
to a host computer using the attached USB plug.

You now can configure the FTC Controller Station to send data from the 
game controllers to the program running on the NXT device. In the 
previous sections of this chapter, you connected the motors to the NXT 
device and provided power to the motors. Therefore, after you configure the 
FTC Controller Station and program the robot appropriately, the robot can 
move according to commands you send from the game controllers.



© National Instruments Corporation 4-1 Getting Started with the FIRST Tech Challenge Software

4
Controlling the Robot with the 
FTC Controller Station

After you build the robot and connect the hardware to the NXT device, you 
can use the FIRST Tech Challenge (FTC) Controller Station to establish 
communication between one or two game controllers and the robot. You 
then can manipulate the behavior of the robot with the game controllers 
during TeleOperated mode.

Refer to Chapter 7, Troubleshooting the Robot, for troubleshooting tips if 
the robot does not work as you expect.

Downloading the Firmware
Before you can use the FTC Controller Station to control the robot, you 
must ensure that the FTC Controller Station can communicate with the 
NXT device. The NXT device must be running the correct firmware to 
communicate with the FTC Controller Station.

Downloading the Firmware from LabVIEW
Complete the following steps to download the correct firmware to the NXT 
device from LabVIEW. Ensure the NXT device is turned on and connected 
to the computer before you download new firmware to the device.

1. Launch LabVIEW.

2. Select Tools»NXT Module»Update NXT Firmware to display the 
Update NXT Firmware dialog box.

3. Click the Browse button next to the Look in text box to display a file 
dialog box.

4. Navigate to the National Instruments\LabVIEW 8.5\vi.lib\
addons\NXTToolkit\Firmware directory and click the Current 
Folder button.

5. In the Available Firmware Files list, select LEGO MINDSTORMS 
NXT Firmware v1.21.
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6. Click the Download button to begin downloading the firmware to the 
NXT device. The Progress section of the Update NXT Firmware 
dialog box displays the progress of the firmware update.

7. When the Update NXT Firmware dialog box displays 
Successfully Downloaded Firmware!, click the Close button to 
close the dialog box.

Downloading the Firmware from LEGO MINDSTORMS
Complete the following steps to download the correct firmware to the NXT 
device from LEGO MINDSTORMS. Ensure the NXT device is turned on 
and connected to the computer before you download new firmware to the 
device.

1. Launch LEGO MINDSTORMS.

2. Select Tools»Update NXT Firmware to display the Update NXT 
Firmware dialog box.

3. Click the Browse button to display the Browse for Folder dialog box.

4. Navigate to the LEGO Software\LEGO MINDSTORMS Edu NXT\
engine\Firmware directory and click the OK button.

5. In the Available Firmware Files list, select LEGO MINDSTORMS 
NXT Firmware v1.21.

6. Click the Download button to begin downloading the firmware to the 
NXT device. The Progress section of the Update NXT Firmware 
dialog box displays the progress of the firmware update.

7. When the Update NXT Firmware dialog box displays 
Successfully Downloaded Firmware!, click the Close button to 
close the dialog box.

Connecting to the FTC Controller Station
After the NXT device has the correct firmware, you must connect the NXT 
device to the FTC Controller Station.

Note Refer to the LEGO® MINDSTORMS® Education NXT User Guide for information 
about using and configuring the NXT device.
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Complete the following steps to connect the NXT device to the FTC 
Controller Station.

1. Navigate to the National Instruments\LabVIEW 8.5\
examples\FTC Toolkit\FTC Controller Station directory or 
the LEGO Software\LEGO MINDSTORMS Edu NXT\examples\FTC 
Toolkit\FTC Controller Station directory and double-click 
FTC Controller Station.exe to launch the FTC Controller 
Station.

2. Click the Run button, shown at left, to begin running the FTC 
Controller Station. Notice that the FTC Controller Station 
automatically assigns any connected game controllers to Controller 1 
and Controller 2.

3. Enter the name of the NXT device in the NXT Name text box.

4. Click the Connect button to connect to the NXT device. The NXT 
Name text box is red when the NXT device is not connected, yellow 
while the FTC Controller Station is connecting to the NXT device, and 
green when the NXT device is successfully connected. When an NXT 
device is connected, the Connect button changes to either Connect 
USB or Connect BT, depending on whether the connection uses USB 
or Bluetooth.

When the NXT device is connected successfully, the FTC Controller 
Station downloads two default programs, FTCTeleOp and Program 
Chooser, to the NXT device.

Selecting the TeleOperated Program
Use the Program Chooser program that the FTC Controller Station 
downloads to the NXT device to specify which program you want to run 
in TeleOperated mode. The Program Chooser program has two options, 
Single and Dual. The Single option indicates that you have only one 
program to run for both the Autonomous and TeleOperated modes. The 
Dual option indicates that you have separate programs to run in each mode.

If you select the Dual option, you must select the program you want to use 
in TeleOperated mode from a list of available programs on the NXT device. 
The Program Chooser program then creates an FTCConfig.txt 
configuration file that specifies the program you selected as the program to 
run in TeleOperated mode. When the mode of the robot changes from 
Autonomous to TeleOperated, the FTC Controller Station stops any 
currently running Autonomous program and starts running the 
TeleOperated program that the configuration file specifies.
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If you select the Single option, the Program Chooser program does not 
create an FTCConfig.txt configuration file. If a configuration file already 
exists on the NXT device, the Program Chooser program deletes this file. 
Because no configuration file exists, the FTC Controller Station does not 
stop the currently running program when the mode of the robot changes 
from Autonomous to TeleOperated.

Complete the following steps to use the Program Chooser program to select 
the program you want to use in TeleOperated mode.

1. On the NXT device, navigate to My Files»Software files»Program 
Chooser and press the orange button.

2. Select Run and press the orange button.

3. Select Dual and press the orange button.

4. Use the left and right arrow buttons to select FTCTeleOp.rxe from 
the list of programs and press the orange button. The Program Chooser 
program creates an FTCConfig.txt configuration file on the NXT 
device that specifies FTCTeleOp as the program to run in TeleOperated 
mode.

5. Press the orange button to end the Program Chooser program.

6. In the FTC Controller Station, click the Update button to detect the 
FTCConfig.txt configuration file on the NXT device. Notice that the 
FTCConfig.txt found on brick? round LED turns green, and 
FTCTeleOp.rxe is listed as the Designated TeleOperated Program.

7. Set the Mode of the NXT device to TeleOperated. Because you 
specified a Designated TeleOperated Program, the FTC Controller 
Station stops any program running in Autonomous mode on the NXT 
device and begins running the Designated TeleOperated Program.

Note Notice that you also can set the Status of the robot from the FTC Controller Station. 
The FTCTeleOp program does not handle the Enabled or Disabled status to change the 
behavior of the robot. However, ensure that the programs you run on the NXT device for 
the FTC competition handle both an Enabled and a Disabled status. When the Status is 
Disabled, the robots must stop moving. Refer to the Enabled and Disabled Status section 
of Chapter 1, Overview of the FIRST Tech Challenge, for more information about the 
Enabled and Disabled status.
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Using the Game Controllers
After you connect the NXT device to the FTC Controller Station and select 
the TeleOperated program you want to use, you can use game controllers 
to manipulate the behavior of the robot.

Complete the following steps to select the game controllers you want to use 
to manipulate the behavior of the robot.

1. Click the Refresh List button for Controller 1. An updated list of 
game controllers connected to the host computer appears in the text 
box above the Refresh List button.

2. From the list of connected game controllers, select the game controller 
you want to correspond to Controller 1. Controller 1 now displays 
any movements or button presses you make on the physical game 
controller. For example, if you press button 2 on the game controller, 
button 2 on Controller 1 appears to be pressed as well. The FTC 
Controller Station sends any game controller data for Controller 1 to 
the FTCTeleOp program running on the NXT device, which 
manipulates the behavior of the robot accordingly.

Note Buttons 9–12 are not shown on Controller 1 or Controller 2 of the FTC Controller 
Station. Buttons 11 and 12 correspond to the left and right joystick buttons, respectively.

3. If you want to use two game controllers to manipulate the behavior of 
the robot, repeat steps 1 and 2 for Controller 2.

4. Move the joysticks on the game controller and observe how the robot 
responds.

5. Click the STOP Program button in the FTC Controller Station to stop 
both the FTC Controller Station and the program running on the NXT 
device.



© National Instruments Corporation 5-1 Getting Started with the FIRST Tech Challenge Software

5
Modifying the Program in 
LabVIEW

The FTCTeleOp program moves the motors of a robot according to 
joystick movements you make on a game controller. You can use 
LabVIEW to modify this program to perform more advanced tasks. For 
example, you can modify the program so that the robot moves at turbo 
speed when you press a button on the game controller.

Complete the following steps to modify the FTCTeleOp program in 
LabVIEW and program a turbo button. Refer to Chapter 6, Modifying the 
Program in LEGO MINDSTORMS, to modify the FTCTeleOp program in 
LEGO MINDSTORMS.

1. Navigate to the National Instruments\LabVIEW 8.5\
examples\FTC Toolkit directory and open FTCTeleOp.vi to 
open the source VI for the FTCTeleOp program.

2. Select Window»Show Block Diagram or press the <Ctrl-E> buttons 
to display the block diagram.

3. Place an FTC Read Buttons VI, located on the FTC Toolkit palette, 
on the block diagram inside the Case structure and under the FTC Read 
Controller VI and the FTC Drive Motors VI.

4. Wire the Buttons output of the FTC Read Controller VI to the Buttons 
input of the FTC Read Buttons VI. The FTC Read Buttons VI returns 
the Boolean values of the buttons on the controller whose data the FTC 
Read Controller VI reads.

5. Place a Case structure, located on the Programming»Structures 
palette, to the right of the FTC Read Buttons VI. Notice the selector 
terminal on the left border of the Case structure. The value you wire to 
this selector terminal determines which case of the Case structure to 
execute.

Note If you do not have enough room to place the Case structure, <Ctrl>-click the white 
space between the FTC Read Controller VI and the FTC Drive Motors VI and drag the 
mouse sideways to add more space between the two VIs.
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6. Wire the Button 1 output of the FTC Read Buttons VI to the selector 
terminal of the Case structure. When button 1 on the game controller 
is pressed, the Button 1 output of the FTC Read Buttons VI returns 
TRUE, and the True case of the Case structure executes. When 
button 1 on the game controller is not pressed, the Button 1 output of 
the FTC Read Buttons VI returns FALSE, and the False case of the 
Case structure executes.

7. Click the increment or decrement arrow of the selector label of the 
Case structure to switch to the False case.

8. Click the numeric constant with value 30 that is connected to the FTC 
Drive Motors VI and drag it inside the False case of the Case structure.

9. Rewire the numeric constant to the Throttle input of the FTC Drive 
Motors VI. When button 1 on the game controller is not pressed, the 
numeric constant in the False case specifies a throttle of 30, and the 
motors of the robot move at 30% speed.

10. Click the increment or decrement arrow of the selector label of the 
Case structure to switch to the True case.

11. Place a numeric constant, located on the Programming»Numeric 
palette, in the True case of the Case structure and set the value of the 
numeric constant to 100.

12. Wire this second numeric constant to the output tunnel on the border 
of the Case structure. When button 1 on the game controller is pressed, 
the numeric constant in the True case specifies a throttle of 100, and 
the motors of the robot move at 100% speed. Thus button 1 of the game 
controller acts like a turbo button for the robot.
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The block diagram of the VI should look similar to the following 
figure.

13. Save this program as FTCTeleOpTurbo.vi in an easily accessible 
location. You can compare this program to the FTCTeleOpTurbo.vi 
in the National Instruments\LabVIEW 8.5\examples\
FTC Toolkit directory.

14. Follow the instructions in Chapter 4, Controlling the Robot with the 
FTC Controller Station, to specify FTCTeleOpTurbo as the program to 
run in TeleOperated mode. You then can move the robot using the 
joysticks on a game controller and use button 1 of the game controller 
as a turbo button.
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6
Modifying the Program in LEGO 
MINDSTORMS

The FTCTeleOp program moves the motors of a robot according to 
joystick movements you make on a game controller. You can use LEGO 
MINDSTORMS to modify this program to perform more advanced tasks. 
For example, you can modify the program so that the robot moves at turbo 
speed when you press a button on the game controller.

Complete the following steps to modify the FTCTeleOp program in LEGO 
MINDSTORMS and program a turbo button. Refer to Chapter 5, 
Modifying the Program in LabVIEW, to modify the FTCTeleOp program 
in LabVIEW.

1. Navigate to the LEGO Software\LEGO MINDSTORMS Edu NXT\
examples\FTC Toolkit directory and open FTCTeleOp.rbt to 
open the source for the FTCTeleOp program.

2. Place an FTC Read Buttons block, located on the Data block palette, 
on the work area between the FTC Read Controller block and the FTC 
Drive Motors block.

3. Wire the Buttons output plug of the FTC Read Controller block to the 
Buttons input plug of the FTC Read Buttons block.

Note If you do not see any data plugs for the FTC Read Buttons block, click the tab at the 
lower left edge of the block to display the data hub.

The FTC Read Buttons block returns the logic values of the buttons on 
the controller whose data the FTC Read Controller block reads.

4. Place a Switch block, located on the Common block palette, to the 
right of the FTC Read Buttons block.

5. In the configuration pane of the Switch block, set the Control property 
to Value. An input data wire plug appears at the bottom left corner of 
the Switch block. The value you wire to this input plug determines 
which case of the Switch block to execute.

6. Also in the configuration pane of the Switch block, remove the 
checkmark from the Flat view checkbox.
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7. Wire the Button 1 output plug of the FTC Read Buttons block to the 
input data wire plug of the Switch block.

When button 1 on the game controller is pressed, the Button 1 output 
plug of the FTC Read Buttons block returns TRUE, and the True case 
of the Switch block executes. When button 1 on the game controller is 
not pressed, the Button 1 output plug of the FTC Read Buttons block 
returns FALSE, and the False case of the Switch block executes.

8. Click the X on top of the Switch block to switch to the False case.

9. Place a Math block, located on the Data block palette, in the False case 
of the Switch block.

10. In the configuration pane of the Math block, set the B property to 30.

11. Wire the Result output plug of the Math block to the Throttle input 
plug of the FTC Drive Motors block. When button 1 on the game 
controller is not pressed, the Math block in the False case specifies 
a throttle of 30, and the motors of the robot move at 30% speed.

12. Click the checkmark on top of the Switch block to switch to the True 
case.

13. Place a Math block in the True case of the Switch block.

14. In the configuration pane of the Math block, set the B property to 100.

15. Wire the Result output plug of this second Math block to the border of 
the Switch block, aligned with the wire connected to the Throttle 
input plug of the FTC Drive Motors block. When button 1 on the game 
controller is pressed, the Math block in the True case specifies a 
throttle of 100, and the motors of the robot move at 100% speed. Thus 
button 1 of the game controller acts like a turbo button for the robot.
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The work area of the program should look similar to the following 
figure.

16. Save the program as FTCTeleOpTurbo.rbt in an easily 
accessible location. You can compare this program to the 
FTCTeleOpTurbo.rbt file in the LEGO Software\LEGO 
MINDSTORMS Edu NXT\examples\FTC Toolkit directory.

17. Follow the instructions in Chapter 4, Controlling the Robot with the 
FTC Controller Station, to specify FTCTeleOpTurbo as the program to 
run in TeleOperated mode. You then can move the robot using the 
joysticks on a game controller and use button 1 of the game controller 
as a turbo button.
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7
Troubleshooting the Robot

In previous chapters, you built a robot whose behavior you can manipulate 
using a game controller. However, at times, the robot might not work as 
you expect. Table 7-1 describes common issues you might encounter when 
working with the robot and solutions to address those issues.
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Table 7-1.  Common Programming Issues

Issue Solution

I cannot connect to the device using 
Bluetooth.

Shut down any programs running on the NXT 
device before you try using Bluetooth to connect to 
the NXT device.

Ensure the NXT device is within range of the 
Bluetooth device. Bluetooth has a limited range of 
approximately fifty feet.

Ensure Bluetooth is on and the Bluetooth icon is 
visible on the NXT device. If Bluetooth is on and 
visible but you cannot connect to the NXT device, 
try power cycling the device. Turn the device off, 
turn the device back on, and then try reconnecting 
to the NXT device using Bluetooth. You also might 
need to remove and reinsert the batteries in the NXT 
device before reconnecting to the device.

I try to run the program on the NXT device, 
but the robot is not responsive.

Ensure you have enough battery power on the NXT 
device. If you are using a rechargeable battery pack, 
ensure the battery pack is fully charged. The battery 
pack takes between five and six hours to charge. 
When charging is complete, the red light on the 
battery charger turns off.

Ensure the NXT device is not in sleep mode. By 
default, the NXT device enters sleep mode after 
10 minutes of inactivity. On the NXT device, you 
can set Sleep to Never to prevent the device from 
shutting down. Select Settings»Sleep and use the 
left and right arrow buttons to select Never. Then 
press the orange button on the NXT device.

Ensure the game controllers are connected to the 
host computer. If you unplug a game controller, you 
must click the Refresh List button in the FIRST 
Tech Challenge (FTC) Controller Station and 
reselect the controller you want to use.
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I am trying to connect to the NXT device 
from the FTC Controller Station, but the 
FTC Controller Station cannot find the NXT 
device.

Connecting to the NXT device from the FTC 
Controller Station for the first time can take up to 
one minute. Subsequent connections take less time.

Ensure you entered the correct name of the NXT 
device in the NXT Name text box in the FTC 
Controller Station. This field is case sensitive.

Ensure the NXT device is not in sleep mode. By 
default, the NXT device enters sleep mode after 
10 minutes of inactivity. On the NXT device, you 
can set Sleep to Never to prevent the device from 
shutting down. Select Settings»Sleep and use the 
left and right arrow buttons to select Never. Then 
press the orange button on the NXT device.

I accidentally unplugged a game controller 
but plugged it back in. Now the FTC 
Controller Station does not recognize the 
game controller.

Click the Refresh List button in the FTC Controller 
Station and reselect the controller you want to use.

Table 7-1.  Common Programming Issues (Continued)

Issue Solution
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