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About This Manual

Use this manual to familiarize yourself with LabVIEW SignalExpress 
interactive measurements and the basic LabVIEW SignalExpress features 
that you use to acquire and analyze signals.

This manual contains exercises that help you begin working with 
LabVIEW SignalExpress. These exercises teach you how to run projects, 
configure steps, work with signals, configure sweep measurements, log 
data, and extend LabVIEW SignalExpress with LabVIEW graphical 
programming.

Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes input and 
output names, parameter names, dialog boxes, sections of dialog boxes, and 
menu names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard. This font is also used for the proper names of disk drives, paths, 
directories, programs, subprograms, subroutines, device names, functions, 
operations, variables, filenames, and extensions.

Related Documentation
Refer to the LabVIEW SignalExpress Help, available by selecting Help»
LabVIEW SignalExpress Help, for more information as you read this 
manual.
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1
Introduction to LabVIEW 
SignalExpress

National Instruments provides innovative solutions for scientists 
and engineers to build automated measurement systems based on 
industry-standard computers and platforms. National Instruments develops 
robust, industry-leading programming environments for automating 
measurement systems, such as LabVIEW for graphical development, 
LabWindows™/CVI™ for ANSI C programming, and Measurement Studio 
for Microsoft Visual Studio programming. You can use these programming 
tools with National Instruments measurement hardware and interfaces to 
traditional instruments to build custom, advanced virtual instrumentation 
systems.

LabVIEW SignalExpress optimizes virtual instrumentation for design 
engineers by offering instant interactive measurements that require no 
programming. You can use LabVIEW SignalExpress interactively to 
acquire, generate, analyze, compare, import, and log signals. You can 
compare design data with measurement data in one step. LabVIEW 
SignalExpress extends the ease of use and performance of virtual 
instrumentation to those who must acquire or analyze signals without 
programming applications. You also can extend the functionality of 
LabVIEW SignalExpress by importing a custom virtual instrument (VI) 
created in the LabVIEW Development System or by converting a 
LabVIEW SignalExpress project to a LabVIEW block diagram so you can 
continue development in LabVIEW. Refer to Chapter 7, Extending 
LabVIEW SignalExpress Projects with LabVIEW, for more information.
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2
Installing LabVIEW 
SignalExpress

You can use the LabVIEW SignalExpress CD to install LabVIEW 
SignalExpress and complete the exercises in this manual.

LabVIEW SignalExpress LE
LabVIEW SignalExpress LE gives you a 30-day trial of the Full version of 
LabVIEW SignalExpress. After that period, you must activate your version 
of LabVIEW SignalExpress LE or purchase the Full version. If you activate 
your version of LabVIEW SignalExpress LE before your 30-day trial of the 
full version is complete, the full features are still available for the remainder 
of your 30-day trial. You can use LabVIEW SignalExpress LE to complete 
simple data acquisition and logging functions.

If you do not register your version of LabVIEW SignalExpress LE after 
30 days, LabVIEW SignalExpress LE runs with the following limitations:

• You can no longer save projects, so you cannot convert projects into 
LabVIEW block diagrams.

• You can run projects for only 10 minutes per session.

Refer to the National Instruments Web site at ni.com/signalexpress to 
purchase the full version of LabVIEW SignalExpress.

Minimum System Requirements
LabVIEW SignalExpress requires a minimum of 256 MB of RAM and a 
Pentium III or later or Celeron 866 MHz or equivalent processor, but 
National Instruments recommends 512 MB of RAM and a Pentium 4/M or 
equivalent processor.

http://www.ni.com/signalexpress
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Installing LabVIEW SignalExpress
Complete the following steps to install LabVIEW SignalExpress on 
Windows Vista/XP/2000/NT.

Note If you want to convert LabVIEW SignalExpress projects to LabVIEW block 
diagrams, you must install LabVIEW 7.1 or later before you install LabVIEW 
SignalExpress.

1. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with the installation program.

2. Log on as an administrator or as a user with administrator privileges.

3. Insert the LabVIEW SignalExpress Development or Evaluation CD 
and follow the instructions that appear on the screen.

By default, LabVIEW SignalExpress installs in the Program Files\
National Instruments\SignalExpress directory.

4. After installation, check the hard disk for viruses and enable any virus 
detection programs you disabled.

The example projects you use with this manual are located in 
SignalExpress\Examples\Tutorial. The solutions for each exercise 
are located in SignalExpress\Examples\Tutorial\Solutions.

If you use LabVIEW SignalExpress with National Instruments data 
acquisition or modular instrumentation hardware, you must install 
NI-DAQmx 8.5 or later, NI-SCOPE 2.7 or later, NI-FGEN 2.2 or later, or 
NI-DMM 2.4.2. LabVIEW SignalExpress includes a National Instruments 
Driver CD that includes these drivers.
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3
Working with Projects

You can use LabVIEW SignalExpress to define measurement procedures 
by adding and configuring steps in an interactive measurement 
environment. A step is a configurable function that acquires, generates, 
analyzes, loads, or stores signals. Most steps process input signals and 
produce output signals. You can configure the operation of a step by 
specifying values in a configuration view. A saved sequence of configured 
steps is a LabVIEW SignalExpress project.

This chapter teaches you how to load and run existing projects and how to 
configure steps in these projects.

Opening a Project
Complete the following steps to load a sample project in LabVIEW 
SignalExpress.

1. Launch LabVIEW SignalExpress.

Notice that LabVIEW SignalExpress is split into three main views: the 
Project View on the left, the Data View in the middle, and the help on 
the right. Within the Data View, you should see the Data View tab, the 
Logging Options tab, and the Project Documentation tab.

2. If LabVIEW SignalExpress does not open in the factory-default 
configuration, select View»Data View to display the Data View.

3. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click the First 
Project.seproj LabVIEW SignalExpress project. 

4. Examine the window that appears, as shown in Figure 3-1 with the 
help hidden, to learn about different components of LabVIEW 
SignalExpress.
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Figure 3-1.  First Project.seproj

The left pane is the Project View, which presents the order of 
operations, or steps, for the project. The right pane is the Data View, 
which displays the signal that the project generates and analyzes.

Running a Project and Displaying Signals
LabVIEW SignalExpress has two execution modes—Run and Run Once. 
When you click the Run button, LabVIEW SignalExpress executes all 
steps in the project continuously until you click the Stop button. The Stop 
button appears in place of the Run button as a project runs. While the steps 
in the project execute, the Data View updates continuously. While the 
project runs, you can change the measurement configurations and view the 

1 Execution control buttons
2 Work Area pull-down menu
3 Step

4 Input
5 Output
6 Project View

7 Logged Data window
8 Data View
9 Record button

5

8

5

1

3

4

2

9

6

7
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results immediately. If you modify the configuration of steps while a 
project runs, LabVIEW SignalExpress gives you direct, immediate 
feedback on the changes you make. When you click the Run Once button, 
LabVIEW SignalExpress executes all steps in the project one time.

Complete the following steps to run the sample project and display signals.

1. Click the Run button, shown at left, to execute all steps in the project 
continuously.

The project loads a signal from a text file and performs two operations 
on the signal—an amplitude and levels measurement and a distortion 
measurement. The Amplitude and Levels step and the Distortion step 
perform these measurements, respectively. When you run a project, 
steps analyze input signals and generate new output signals as a result 
of the analysis. In this project, the Load from ASCII step loads a 
distorted sine wave, the Amplitude and Levels step and the Distortion 
step analyze the sine wave, and both steps return new outputs. In the 
Project View, LabVIEW SignalExpress indicates inputs with red 
arrows and outputs with blue arrows.

The graph in the Data View still contains the loaded signal, which is a 
time-domain signal. Graphs display time-domain, frequency-domain, 
or x-y signals. 

2. Click the exported spectrum output signal of the Distortion step in the 
Project View and drag it to the Data View to display the signal. 

LabVIEW SignalExpress creates a new graph in the Data View. 
LabVIEW SignalExpress does not display the exported spectrum 
signal on the same graph as the time-domain signal because the 
exported spectrum signal is a frequency-domain signal. LabVIEW 
SignalExpress automatically recognizes different types of signals and 
renders them in the appropriate displays.

3. Select Help»LabVIEW SignalExpress Help, click the Search tab, 
and enter "signal types" to refer to the LabVIEW SignalExpress 
Help for more information about signal types. The help provides 
information about using LabVIEW SignalExpress functionality such 
as projects, steps, and signals.

4. Click the dc output of the Amplitude and Levels step and drag it to the 
Data View to display the measurement. 

LabVIEW SignalExpress creates a table to display the scalar 
measurement from the dc output.
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5. Drag the rms output to the table to display the scalar RMS 
measurement.

LabVIEW SignalExpress creates a new row in the table to display the 
second measurement. The project should appear as shown in 
Figure 3-2.

Figure 3-2.  Outputs of First Project.seproj

Configuring a Step
A step is a configurable function that acquires, generates, analyzes, loads, 
or stores signals. Steps process input signals and produce output signals. 
You can configure the operation of a step in SignalExpress by specifying 
values in the Step Setup dialog box, or configuration view, for that step. 
While a project runs, you can modify the configuration of steps to view 
immediate feedback on the changes and adjust the measurements until you 
achieve the results you need.
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Complete the following steps to configure the Distortion step and the 
Amplitude and Levels step.

1. Double-click the Distortion step in the Project View. The Step Setup 
dialog box for the Distortion step appears, as shown in Figure 3-3.

Figure 3-3.  Distortion Step Setup Dialog Box

On the Configuration tab, the settings indicate that the Distortion step 
receives a time-domain waveform signal as an input, performs a power 
spectrum on the signal to convert it to the frequency domain, and 
computes the total harmonic distortion (THD) and fundamental 
frequency of the signal. The step generates three measurements as 
outputs—the spectrum, the THD, and the fundamental frequency of 
the original time-domain waveform input.

2. If the context help does not appear on the right side of the screen, click 
the Show Help button, shown at left, to display complete reference 
information about the step. The upper half of the context help displays 
information about the step, and the lower half of the context help 
displays information about an object when you move the cursor over 
the object.
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3. On the Configuration tab, select Fundamental Tone from the 
Export signals (THD) pull-down menu.

The operation of the step changes from displaying the 
frequency-domain spectrum of the entire input signal to displaying 
only the frequency spectrum of the fundamental tone of the input 
signal. The graphed signals in the top half of the Step Setup dialog box 
update to reflect the change you made.

4. Select Harmonics Only from the Export signals (THD) pull-down 
menu.

The step changes to export only the spectrum of the harmonic signals 
from the input signal. Both the output signal of the Distortion step and 
the graph on the Data View update to reflect the change you made.

5. Click the Amplitude and Levels step in the Project View. 

The Step Setup dialog box changes from displaying the configuration 
of the Distortion step to displaying the configuration of the Amplitude 
and Levels step.
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6. Click the Input/Output tab to display the list of possible inputs and 
outputs for this step, as shown in Figure 3-4.

Figure 3-4.  Amplitude and Levels Step Setup Dialog Box

7. Place checkmarks in the Export +peak value, Export -peak value, 
and Export peak-peak value checkboxes to configure the Amplitude 
and Levels step to return three additional measurements.

Three additional outputs appear in the Project View.

8. Click the Data View tab to display the Data View.

9. Drag the three new outputs from the Project View to the table to 
display the scalar measurements.

10. Click the Stop button, shown at left, to stop the project.

When you click the Stop button, the project stops running after 
completing the current cycle of operations, or the current iteration. 
Click the down arrow on the Stop button and click the Abort button to 
completely stop the project without finishing the current iteration.
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11. Select File»Save Project As and save the project as My First 
Project.seproj in the SignalExpress\Examples\Tutorial 
directory.

12. Select File»Close Project to close the project.

Moving and Deleting Steps
The steps in SignalExpress projects depend on input data, which means 
steps can operate only on signals exported from previous steps in the 
Project View. When you click the Input signal pull-down menu on the 
Input tab of the Step Setup dialog box of a step, the menu displays only 
compatible signals exported from a previous step. When the output of a 
step becomes the input of another step, the steps become dependent on each 
other, and the two steps execute sequentially at the same rate. The first step 
generates an output signal that the second step must receive as an input 
before the step can execute.

You can move a step within a project by dragging it up or down in the 
Project View. You can delete a step by right-clicking it in the Project View 
and selecting Delete from the shortcut menu. However, when you move or 
delete a step, the status of signals in the project changes. For example, if 
you delete a step that generates output signals, the operation of the project 
breaks if any of the deleted output signals are inputs for other steps, and an 
error indicator appears in the Project View. You also can cut, copy, and 
paste steps within a project by pressing the <Ctrl-X>, <Ctrl-C>, and 
<Ctrl-V> keys, respectively, or by right-clicking a step in the Project View 
and selecting Cut, Copy, Paste Before Selected Step, or Paste After 
Selected Step from the shortcut menu.

Handling Errors and Warnings
If an error occurs while a project runs, an error indicator, shown at left, 
appears in the Project View on the step that encountered the error. 
Double-click the step with the error to display an error description across 
the bottom of the Step Setup dialog box. Click the Details button to the 
right of the error description to display the full error description.

SignalExpress logs all errors and warnings in the Event Log while a project 
runs. To display the Event Log, select View»Event Log and click the Event 
Log tab in the Data View area. Refer to the LabVIEW SignalExpress Help for 
more information about errors and warnings by selecting Help»LabVIEW 
SignalExpress Help, clicking the Search tab, and entering errors.



© National Instruments Corporation 4-1 Getting Started with LabVIEW SignalExpress

4
Working with Signals

You can use LabVIEW SignalExpress to generate and analyze signals to 
evaluate designs without programming. This chapter teaches you how to 
work with signals in LabVIEW SignalExpress, including how to plot 
signals on graphs, import signals from a file, interactively align and 
compare two signals, and save signals to a file.

Graphing Signals
Complete the following steps to plot signals in a sample project and 
examine the signals visually using cursors.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click 
Signals.seproj. This project configures the Create Signal step 
to create a square wave signal and the Filter step to perform a lowpass 
Butterworth filter.

2. Drag the step signal output of the Create Signal step to the Data View.

3. Drag the filtered step output of the Filter step to the Data View.

You can plot signals of the same signal type on the same graph. Both 
the step signal and the filtered step signals are time-domain signals, 
so they appear on the same graph. If you want to plot signals of 
different types, drag the signals to the same graph and LabVIEW 
SignalExpress creates a new graph.

4. Click the Add Display button, shown at left, on the toolbar to create a 
new graph.

5. Drag the filtered step output of the Filter step to the new graph.
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6. Right-click the new graph and select Visible Items»Cursors from the 
shortcut menu to display two interactive cursors, as shown in 
Figure 4-1.

Figure 4-1.  Signals.seproj

As you drag the cursors, LabVIEW SignalExpress displays the x and 
y values of the cursors in the cursor table at the bottom of the Data 
View.

7. Select File»Save Project As and save the project as 
My Signals.seproj in the SignalExpress\Examples\
Tutorial directory.
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Importing a Signal from a File
You can import signals from standard file formats such as ASCII comma- 
or tab-delimited files and LabVIEW measurement data files (.lvm). You 
also can import signals from simulated results of EDA tools such as SPICE 
simulators.

Complete the following steps to import a signal from a file.

1. Right-click the Project View and select Load/Save Signals»Analog 
Signals»Load from ASCII from the shortcut menu.

2. Click the browse button, shown at left, in the Step Setup dialog box, 
navigate to the SignalExpress\Examples\Tutorial directory, 
and double-click Step Response.txt. This step parses an ASCII file 
and displays the signals in the file.

In the File preview section, column 1 shows the time stamp data, and 
column 2 shows the actual voltage values of the signal.

3. Click the Import Signals tab to display the available signals in the file.

4. Place a checkmark in the Column 2 checkbox to import that signal, 
and remove the checkmark from the Column 1 checkbox.

The Step Setup dialog box displays a preview of the signal in the 
Imported Signal section.

5. Select Column 1 from the Input X values pull-down menu to set the 
x-axis data of the waveform to the appropriate values.

6. Open the Data View.

7. Right-click the Column 2 output in the Project View and select 
Rename from the shortcut menu.

8. Enter step response and press the <Enter> key to rename the output.

9. Drag the step response output of the Load from ASCII step to the 
lower graph in the Data View.

The filtered step signal resembles the rising edge of the step response 
output, as shown in Figure 4-2.
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Figure 4-2.  Signals of Signals.seproj

10. Select File»Save Project to save the project.

Aligning and Comparing Signals
Although the filtered step signal and the step response output both show 
an overshoot in the rising edge, assessing the similarity between the two 
is difficult because the signals come from different sources and vary in 
amplitude and timing. However, you can use the Interactive Alignment step 
to align and compare two signals, so you can choose which type of 
information you want to export from the operation to use in the project.

Complete the following steps to align two signals in the 
My Signals.seproj project.

1. Right-click the step response output and select Send To»
Processing»Analog Signals»Interactive Alignment from the 
shortcut menu to pass the step response signal from the Load from 
ASCII step to the Interactive Alignment step.



Chapter 4 Working with Signals

© National Instruments Corporation 4-5 Getting Started with LabVIEW SignalExpress

The step selects the two most recent signals from the project to use as 
inputs and displays the signals on the graph of the Step Setup dialog 
box, as shown in Figure 4-3.

Figure 4-3.  Interactive Alignment Step Setup Dialog Box

When you add a step to a project, LabVIEW SignalExpress selects 
input signals based on the signal types the step can accept. For 
example, the Interactive Alignment step can operate only on 
time-domain waveform signals. Therefore, the step selects as inputs 
the last two time-domain signals created in the project. To change the 
input signals for a step, select different signals from the pull-down 
menu of compatible signals in the Input/Output tab of the Step Setup 
dialog box.

2. Click the red signal in the Input Signals graph and drag it to another 
point within the graph.

You can drag, expand, and contract signals on the graph.

3. Try to align the rising edges of the two signals by dragging a signal 
within the graph. Click a signal to set an anchor point and press and 
hold the <Alt> key to stretch the signal around that anchor point in the 
x and y directions.
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On the Alignment tab of the Step Setup dialog box, the step computes 
and displays the x and y gain and offset values you need to achieve 
alignment specifications as you drag the signals.

4. Select Auto - Step from the Mode pull-down menu to align the 
signals. LabVIEW SignalExpress bases this alignment mode on 
built-in algorithms.

The lower graph in the Step Setup dialog box displays the difference 
between the two signals.

5. On the Input/Output tab, place a checkmark in the Export aligned 
signals checkbox to add the signals to the outputs of the step.

6. Select the Data View tab to open the Data View.

7. Click the Add Display button, shown at left, to add a third graph.

8. Drag the aligned reference and aligned test outputs of the Interactive 
Alignment step to the new graph to view the aligned signals.

9. Select File»Save Project to save the project.

Signal Types in LabVIEW SignalExpress
Some steps, such as the Arithmetic step, can operate on multiple signal 
types. For example, you can use the Arithmetic step to operate on 
time-domain or frequency-domain waveforms. The Arithmetic step 
changes behavior based on the type of input signals you select for the 
step. For example, if you add two time-domain signals, LabVIEW 
SignalExpress adds only their amplitudes. However, if you add two 
frequency-domain phase signals, LabVIEW SignalExpress adds the 
appropriate phase shift.

Refer to the LabVIEW SignalExpress Help for more information by 
selecting Help»LabVIEW SignalExpress Help, clicking the Search tab, 
and entering "signal types".

Exporting and Printing Signals
You can use LabVIEW SignalExpress to document signals or continue 
analysis in another software application. This section teaches you how to 
export signals, including sending signals to an ASCII file, sending data to 
Microsoft Excel, printing signals, and using the built-in documentation 
feature to document the LabVIEW SignalExpress project.
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Saving Signals to File
Complete the following steps to save a signal to a file.

1. Click the Add Step button and select Load/Save Signals»Analog 
Signals»Save to ASCII/LVM.

2. Click the Signals tab in the Step Setup dialog box and select filtered 
step from the Input Data pull-down menu.

3. On the File Settings tab, save the file to SignalExpress\
Examples\Tutorial\filtered signal.txt in the Export file 
path control.

4. Select Overwrite from the If file already exists pull-down menu.

5. Select Generic ASCII from the Export file type pull-down menu.

You can use a Load/Save Signals step to save data to a file every time 
the project runs.

6. Click the Close button to close the Step Setup dialog box.

7. Click the Run button to run the project and save the resulting signal to 
the specified ASCII file.

8. Select File»Save Project to save the project.

9. Select File»Close Project to close the project.

Exporting Signals to Microsoft Excel
To export signal data to Microsoft Excel, launch Excel and drag the output 
signal of a step in LabVIEW SignalExpress to an Excel spreadsheet.

Printing Signals
To print an image of a graph, open the Data View and select File»Print»
Print Data View.

Creating Reports in LabVIEW SignalExpress
Select View»Project Documentation to display the Project Documentation 
View. You can describe your project using text and drag and drop step 
outputs into your documentation. When you drag and drop a step output into 
the Project Documentation View, the value in the Project Documentation 
View automatically updates to match the current value of the step output. 

To print your documentation, open the Project Documentation View and 
select File»Print»Print Documentation. To export your documentation to 
HTML, open the Project Documentation View and select File»Export»
Export Documentation to HTML.
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5
Logging Data

You can use LabVIEW SignalExpress to record and analyze 
measurements. You can record any time-domain, double, U32, or Boolean 
step output. You also can analyze and process logged data by playing it 
through analysis steps. 

This chapter teaches you how to record data using the integrated data 
logging features in LabVIEW SignalExpress. You learn how to record a 
specified signal, play back that signal, and analyze the signal using analysis 
steps. You also learn how to use the Recording Options View to log signals 
based on specified start or stop conditions. 

Recording a Signal
You can use the Record button to configure a data logging process. 

Complete the following steps to specify a signal to record and to record the 
signal.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click 
Logging.seproj.

This project uses the Create Signal step to generate a signal based on a 
formula.

2. Click the Record button, shown at left, to open the Logging Signals 
Selection dialog box.

The Logging Signals Selection dialog box displays the signals in the 
project available for recording. You can select one signal or multiple 
signals to record. You also can specify a name and description for 
the log.

3. Place a checkmark in the signal checkbox to record the formula signal 
generated in the Create Signal step.

4. Click the OK button to close the Logging Signals Selection dialog 
box and begin recording the signal. The logging operation continues 
until you click the Stop button.
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5. Click the Stop button, shown at left, to stop logging the signal. 

The logged data appears in the Logged Data window, as shown in 
Figure 5-1.

Figure 5-1.  Logged Data Window

By default, LabVIEW SignalExpress names the logged data according 
to the date and time you recorded the data. LabVIEW SignalExpress 
saves logged data in the .tdms file format in the directory you specify 
in the Options dialog box. 

6. Select Tools»Options and select the Logging option to specify the 
directory for LabVIEW SignalExpress to save the logged data and to 
customize various preferences for logged data.

7. Click the OK button to close the Options dialog box.

8. Select File»Save Project to save the project.

Viewing a Logged Signal
Complete the following steps to view the logged data.

1. If the Data View is not visible, select View»Data View to display the 
Data View. 

2. The Logged Data window displays a list of all logged data in the 
current project. Select the data log you just recorded from the Logged 
Data window and drag it into the Data View. The Data View displays 
the logged data and a preview graph, as shown in Figure 5-2. The 
signal displayed in the Data View may differ from the signal displayed 
in Figure 5-2, depending on how long you record the signal.
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Figure 5-2.  Logging.seproj

The preview graph provides a method for zooming and panning 
through data in the Data View. The preview graph appears by default 
when viewing logged data. When viewing live or non-logged data, 
right-click the Data View and select Visible Items»Preview to display 
the preview graph.

3. Click the Zoom In button next to the preview graph to zoom in on the 
logged signal. The cursors on the preview graph show the subset of 
data currently displayed on the preview graph. Use the scroll bar 
beneath the preview graph to scroll through the data. Click and drag the 
cursors on the preview graph to increase or decrease the subset of data 
you are viewing.

Logging Signals with Predefined Start and Stop 
Conditions

You can configure start and stop conditions that the signals must meet 
before LabVIEW SignalExpress records or stops recording the signals. 
Complete the following steps to log data based on start and stop conditions.

1. If the Recording Options tab is not visible, select View»Recording 
Options to open the Recording Options View.
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2. Select Signal Selection in the Category list in the Recording Options 
View.

3. Place a checkmark next to the signal in the Record column, as shown 
in Figure 5-3.

Figure 5-3.  Signal Selection

The Record button changes to the Record While Running button, 
shown at left. Ensure the Record While Running button is pressed. 
When the Record While Running button is pressed, LabVIEW 
SignalExpress records the selected signal when you click the Run or 
Run Once button.

4. Select Start Conditions in the Category list in the Recording Options 
View. 

5. Click the Add button in the Logging start conditions page to 
customize a start condition for your logging task.

a. Select the Signal option in the Condition source control to 
specify for LabVIEW SignalExpress to begin recording when the 
input signal meets the specified condition.

b. Select signal in the Signal control.
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c. Select Rising slope in the Condition control to begin recording 
the signal based on the value of the edge of the signal on a positive 
slope.

d. Enter 1 in the Value control to begin recording when the signal 
crosses 1 on a rising slope.

6. Select Stop Conditions in the Category list in the Recording Options 
View.

7. Click the Add button in the Logging stop conditions page to 
customize a stop condition for your logging task.

a. Select the Duration option in the Condition source control.

b. Enter 5 in the Duration control to record the signal for 5 seconds 
after the signal meets the start condition.

c. Click the Run button, shown at left. LabVIEW SignalExpress 
begins recording the signal when the signal crosses level 1 on a 
rising slope and continues recording the signal for 5 seconds. 

The Recording indicator on the bottom of the Recording Options 
View will turn on when the signal meets the start condition and 
logging is in progress. The Disk information indicator displays 
the available hard disk space on the computer for the log.

Analyzing Logged Signals
After you log a signal, you can play back the logged data or run the logged 
signal through analysis steps, just as you can with live data. Complete the 
following steps to analyze a logged signal.

1. Navigate to the Work Area pull-down menu on the top left of the 
LabVIEW SignalExpress window, as shown in Figure 5-4. Click the 
down arrow and select Playback to switch to the Playback work area.

Figure 5-4.  Work Area pull-down menu

Use work areas to perform multiple LabVIEW SignalExpress 
operations from within the same project. You can acquire data, process 
signals, record data, and perform measurements on logged data 
without opening a new project. When you save your project, 
LabVIEW SignalExpress saves every work area within the project in 
the same project file.
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The default work area, Monitor/Record, allows you to take 
measurements, analyze live data, and log data. You must be in the 
Playback work area to use logged data as an input for an analysis step. 
For example, you can take a measurement and log the signal in the 
Monitor/Record work area, and then run the logged data through an 
analysis step in the Playback work area.

2. Click the Add Step button, shown at left, and select the Filter step from 
Processing»Analog Signals»Filter. LabVIEW SignalExpress 
automatically selects the first signal you logged as the input to the 
Filter step.

3. Navigate to the Data View. Drag the filtered data output of the Filter 
step into the Data View to view the resulting signal.

4. Click the Run button, shown at left. The Data View displays the 
resulting filtered signal and LabVIEW SignalExpress plays back the 
entire log.

Advanced Playback
You can configure advanced data playback options by using the Playback 
Options View. The Playback Options View displays a preview of the 
logged data and allows you to select a subset of that data to play back or run 
through analysis steps.

1. Select View»Playback Options to open the Playback Options View, 
as shown in Figure 5-5. The Playback Options View allows you to 
preview the logged data, as well as specify a subset of the logged data 
to play back or send to analysis steps. 
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Figure 5-5.  Playback Options View

2. Select signal from the second log you created in the Logged signal 
listbox.

3. Enter 1 in the Start time control to play back or analyze a subset of the 
logged signal beginning 1 second after the start of the log. 

4. Enter 4 in the Stop time control to play back or analyze a subset of the 
logged signal ending four seconds after the start of the log.

5. Switch to the Data View and drag the filtered data output of the Filter 
step into the Data View.

6. Click the Run button, shown at left. LabVIEW SignalExpress filters 
the subset of the signal you specified in the Playback Options View and 
displays the resulting filtered signal in the Data View.

7. Click the Stop button to stop running the project.

Refer to the LabVIEW SignalExpress Help for more information about 
logging data, such as specifying alarm conditions and playback options.
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6
Performing Sweep 
Measurements

You can use LabVIEW SignalExpress to automate measurements to 
characterize and validate designs by creating sweep operations. You can 
use the sweep measurements to gather data from designs over a range of 
conditions to document the performance of the designs. For example, you 
can use sweep operations to vary the frequency of a stimulus signal or vary 
the level of a supply voltage while taking measurements to characterize 
designs.

This chapter teaches you how to set up sweep operations using the Sweep 
step in LabVIEW SignalExpress. You learn how to characterize the 
performance of a filter by sweeping through a range of frequency values 
and measuring the output of the filter. You also learn how to display sweep 
results and perform multidimensional sweeps for more complex 
measurements.

Defining Sweep Ranges and Outputs
You can use the Sweep step in LabVIEW SignalExpress to define 
automated measurements for complex, repeatable sweep operations.

Complete the following steps to define a frequency range in a sample 
project to sweep through a filter.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Sweep.seproj.

2. Click the Run button, shown at left, to run the project.

The project generates a sine wave stimulus signal using the Create 
Signal step, passes it through a bandpass elliptic filter using the Filter 
step, measures the RMS level of the filter output using the Amplitude 
and Levels step, and converts the level to decibels (dB) using the 
Formula step. The Filter step acts as a simulated unit under test, so the 
project uses no hardware. However, you also can sweep physical 
signals generated from a National Instruments arbitrary waveform 
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generator, function generator, dynamic signal analyses, or 
multifunction I/O (MIO) device.

3. Click the Add Step button, shown at left, and select Execution 
Control»Sweep.

4. Click the Add button in the Step Setup dialog box to display the list 
of sweep parameters from each step in the project, as shown in 
Figure 6-1.

Figure 6-1.  Sweep Parameter Selection Dialog Box

5. Select the Frequency parameter under Create Signal and click the 
OK button.

The Sweep step encloses the Create Signal step, which provides the 
signal to sweep.

6. On the Sweep Configuration tab, select Exponential from the Type 
pull-down menu.

7. Enter 1k in the Start Frequency (Hz) field, and enter 40k in the Stop 
Frequency (Hz) field.

8. Enter 150 in the Number of points field.

The Sweep Configuration tab should appear as shown in Figure 6-2.
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Figure 6-2.  Sweep Step Setup Dialog Box

You used the Sweep step to specify a range of values to iterate through 
the Frequency parameter of the Create Signal step. The Create Signal 
step uses the defined frequency range to generate a sine wave at each 
of these frequencies. However, you can use the Sweep step to sweep 
any sweepable parameter value of any sweepable step in a project.

9. Click the Sweep Output tab.

10. Click the Add button to display the list of sweep outputs from each 
step in the project.

11. Select the response amplitude in dB output under Formula and click 
the OK button to plot this measurement against the swept Frequency 
parameter.

The Sweep step creates a loop around all the steps in the Project View 
to include all the steps in the sweep operation.
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Plotting Sweep Results
Complete the following steps to run the sweep measurement.

1. Click the Run Once button, shown at left, to execute the sweep 
measurement.

The stimulus signal output on the graph iterates through the specified 
range of frequencies.

2. Drag the response amplitude in dB vs. Frequency signal from the 
bottom of the Sweep loop to the Data View to display the output of the 
sweep.

LabVIEW SignalExpress creates a new graph. The data from a sweep 
operation is an x-y array that requires a separate graph, as shown in 
Figure 6-3.

Figure 6-3.  Sweep.seproj
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3. Click the Run Once button again to execute the sweep.

The frequency response of the Filter step plots on the new graph while 
the project runs. The graph displays the transfer function of the filter, 
or the amplitude output expressed in decibels versus the frequency.

4. Double-click the Filter step to display the filter specifications in the 
Step Setup dialog box.

The frequency response of the filter in the Filter Magnitude 
Response graph matches the graph in the Data View.

5. Select File»Save Project As and save the project as 
My Sweep.seproj in the SignalExpress\Examples\Tutorial 
directory.

You can use the Sweep step to sweep multiple parameters simultaneously 
by adding additional parameters on the Sweep Configuration tab of the 
Sweep Step Setup dialog box. Sweeping two or more parameters 
simultaneously is called a parallel sweep. For example, if you want to vary 
the amplitude of a stimulus signal, you can run a parallel sweep. You can 
use a parallel sweep to maximize the precision of the acquisition by varying 
the input range of a digitizer or MIO device as you vary the signal level. As 
the signal level increases, you can increase the input range of the 
measurement device to ensure you use the entire resolution for the 
measurement.

Running Multidimensional Sweeps
Use multidimensional, or nested, sweeps to iterate through one range while 
you vary another range. For example, if you want to sweep through 
frequencies of a stimulus signal at different amplitudes, run a nested sweep. 
You can set the amplitude to level 1 and sweep through frequencies, and 
then set the amplitude to level 2 and sweep through frequencies, and so on. 
You can build a nested sweep by right-clicking a Sweep step in a project 
and selecting Add Dimension from the shortcut menu to add another 
sweep loop. 

Complete the following steps to run a sample nested sweep project.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Nested 
Sweep.seproj.

2. Click the Run button, shown at left, to run the project.

Each iteration of the inner sweep loop sweeps the frequency of the 
stimulus signal. The outer sweep loop varies the low and high cutoff 
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frequencies of the Filter step. Each iteration appears in real time on the 
upper graph, and then appears on the lower graph to display all the 
sweeps at each cutoff frequency setting, as shown in Figure 6-4.

Figure 6-4.  Nested Sweep.seproj

3. Click the Stop button, shown at left, to stop the project.
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7
Extending LabVIEW 
SignalExpress Projects with 
LabVIEW

You can use LabVIEW SignalExpress to define automated measurements 
by using built-in steps for acquiring, generating, analyzing, or logging 
signals. You can extend the functionality of LabVIEW SignalExpress 
projects by using LabVIEW in the following ways:

• Build a VI in LabVIEW and import this VI into LabVIEW 
SignalExpress to provide custom step functionality and expand the 
number of steps available in LabVIEW SignalExpress.

• Convert a LabVIEW SignalExpress project to a LabVIEW block 
diagram to continue development in LabVIEW.

You must have LabVIEW 7.1 or later to complete the exercises in this 
chapter.

Importing LabVIEW VIs into LabVIEW SignalExpress as 
Steps

Use the Run LabVIEW VI step in LabVIEW SignalExpress to call custom 
LabVIEW VIs. You can call a LabVIEW VI from LabVIEW 
SignalExpress to do the following:

• Control GPIB instruments

• Control National Instruments hardware that LabVIEW SignalExpress 
does not support

• Read or write data to more file formats

• Display operator instructions in a pop-up dialog box

• Define a measurement algorithm
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Complete the following steps to import a VI from LabVIEW with the Run 
LabVIEW VI Step.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click User 
Step.seproj.

This project uses the Create Signal step to generate a signal.

2. Click the Add Step button and select Run LabVIEW VI»Run 
LabVIEW 8.2 VI. 

The VI you run in this exercise was saved in LabVIEW 8.2. You must 
use the version of the Run LabVIEW VI step that matches the version 
of LabVIEW you saved your VI in.

3. Click the browse button on the Step Setup dialog box and select 
Limiter-LV82.vi in the LabVIEW SignalExpress\Examples\
Tutorial directory. The Limiter-LV82 VI accepts a time-domain 
waveform as an input, clips the signal above and below values that you 
specify in the Step Setup dialog box, and returns the clipped 
waveform as an output signal.

When you import a LabVIEW VI, LabVIEW SignalExpress maps the 
inputs of the VI as parameters and the outputs of the VI as output 
signals in LabVIEW SignalExpress.

You can define whether the inputs for VIs become input signals or 
parameters. An input signal appears in the Project View as an input to 
a step, which means you can pass signals as inputs to a VI. A parameter 
is a value you can configure on the Step Setup dialog box of a step. 
You also can sweep parameters dynamically using the Sweep step. In 
this project, the VI has an input signal, Time waveform in, and scalar 
parameters, Upper limit and Lower limit.

Verify that the Step Setup dialog box appears as shown in Figure 7-1.
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Figure 7-1.  Limiter VI Step Setup Dialog Box

4. Click the Run button, shown at left, to run the project. 

5. Drag the Clipped waveform out output signal from the Limiter.vi step 
to the Data View.

6. Double-click the Limiter.vi step to display the Step Setup dialog box.

7. Select the Configure VI tab to display the VI. 

8. Enter new values in the Upper limit and Lower limit fields. For 
example, enter 100 in the Upper limit field.

9. Click the Apply button to apply the changes.

10. Click the Close button to close the VI and click the Close button to 
close the Step Setup dialog box.

The Clipped waveform out signal changes on the Data View to reflect 
the changes you made.

Refer to the LabVIEW SignalExpress Help for more information about 
using LabVIEW VIs in LabVIEW SignalExpress and building VIs that 
work well in LabVIEW SignalExpress.
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Converting LabVIEW SignalExpress Projects to 
LabVIEW Block Diagrams

LabVIEW SignalExpress can convert LabVIEW SignalExpress projects 
into LabVIEW block diagrams.

Note To convert an LabVIEW SignalExpress project to a LabVIEW VI, you must have 
the LabVIEW 7.1 Full Development System or greater installed.

Complete the following steps to convert a LabVIEW SignalExpress project 
to a LabVIEW block diagram.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial\Solutions and double-click My First 
Project.seproj.

2. Select Tools»Generate Code»LabVIEW Diagram.

3. Specify a filename and location for the new LabVIEW VI and click the 
OK button.

The resulting LabVIEW block diagram reflects the execution of the 
project in LabVIEW SignalExpress. The LabVIEW block diagram 
consists of LabVIEW Express VIs wired together. Each Express VI 
correlates to a step in the LabVIEW SignalExpress project. You can 
double-click an Express VI to display the same Step Setup dialog box 
as in LabVIEW SignalExpress. You also can right-click an Express VI 
and select Open Front Panel from the shortcut menu to convert the 
Express VI into a LabVIEW subVI. You can view the block diagram 
to see how the LabVIEW block diagram executes and modify the 
functionality of the VI. When you convert an Express VI into a subVI, 
you cannot convert the subVI back into an Express VI.

Note When you convert a LabVIEW SignalExpress project with logging, LabVIEW 
SignalExpress generates a LabVIEW block diagram with one Express VI. You cannot 
convert the generated Express VI into a subVI.
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8
Where to Go from Here

Refer to the following resources for more information about LabVIEW 
SignalExpress.

LabVIEW SignalExpress Sample Projects
LabVIEW SignalExpress provides a variety of sample projects that 
demonstrate more capabilities of LabVIEW SignalExpress. These projects 
are located in the SignalExpress\Examples directory. Review these 
examples to learn more about the features of LabVIEW SignalExpress or 
to start with a project that closely resembles your needs.

Using Hardware with LabVIEW SignalExpress
This manual does not describe how to control hardware from LabVIEW 
SignalExpress because LabVIEW SignalExpress supports a variety of 
National Instruments hardware for acquiring and generating signals. You 
can generate or acquire and log analog signals in SignalExpress using 
National Instruments MIO devices, dynamic signal acquisition devices, 
high-speed digitizers, or arbitrary waveform generator and function 
generator devices. You also can synchronize multiple devices in a system 
by sharing clocks and trigger signals between devices. Refer to the 
LabVIEW SignalExpress Help by selecting Help»LabVIEW 
SignalExpress Help for more information about using hardware with 
LabVIEW SignalExpress.

Web Resources
Refer to the National Instruments Web site at ni.com/signalexpress 
for resources such as example projects, technical documents, and 
LabVIEW VIs written for use in LabVIEW SignalExpress.

http://www.ni.com/signalexpress
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit the award-winning National Instruments Web site for 
software drivers and updates, a searchable KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, thousands 
of example programs, tutorials, application notes, instrument 
drivers, and so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Developer Exchange at 
ni.com/exchange. National Instruments Application Engineers 
make sure every question receives an answer.

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp04
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp07
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp08
http://digital.ni.com/productpages/nialliance.nsf/main?readform
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp10
http://ni.com
http://ni.com
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