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About This Manual

Use this manual to familiarize yourself with LabVIEW SignalExpress
interactive measurements and the basic LabVIEW SignalExpress features
that you use to acquire and analyze signals.

This manual contains exercises that help you begin working with
LabVIEW SignalExpress. These exercises teach you how to run projects,
configure steps, work with signals, configure sweep measurements, log
data, and extend LabVIEW SignalExpress with LabVIEW graphical
programming.

Conventions

The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

@ This icon denotes a note, which alerts you to important information.
@ This icon denote a tip, which alerts you to advisory information.
bold Bold text denotes items that you must select or click in the software, such

as menu items and dialog box options. Bold text also denotes input and
output names, parameter names, dialog boxes, sections of dialog boxes, and
menu names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the
keyboard. This font is also used for the proper names of disk drives, paths,
directories, programs, subprograms, subroutines, device names, functions,
operations, variables, filenames, and extensions.

© National Instruments Corporation vii Getting Started with LabVIEW SignalExpress



About This Manual

Related Documentation

Refer to the LabVIEW SignalExpress Help, available by selecting Help»
LabVIEW SignalExpress Help, for more information as you read this
manual.
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Getting Started with
LabVIEW SignalExpress

National Instruments provides innovative solutions for scientists

and engineers to build automated measurement systems based on
industry-standard computers and platforms. National Instruments develops
robust, industry-leading programming environments for automating
measurement systems, such as LabVIEW for graphical development,
LabWindows™/CVI™ for ANSI C programming, and Measurement Studio
for Microsoft Visual Studio programming. You can use these programming
tools with National Instruments measurement hardware and interfaces to
traditional instruments to build custom, advanced virtual instrumentation
systems.

LabVIEW SignalExpress optimizes virtual instrumentation for design
engineers by offering instant interactive measurements that require no
programming. You can use LabVIEW SignalExpress interactively to
acquire, generate, analyze, compare, import, and log signals. You can
compare design data with measurement data in one step. LabVIEW
SignalExpress extends the ease of use and performance of virtual
instrumentation to those who must acquire or analyze signals without
programming applications. You also can extend the functionality of
LabVIEW SignalExpress by importing a custom virtual instrument (VI)
created in the LabVIEW Development System or by converting a
LabVIEW SignalExpress project to a LabVIEW block diagram so you can
continue development in LabVIEW. Refer to Chapter 6, Extending
LabVIEW SignalExpress Projects with LabVIEW, for more information
about advanced functionality in LabVIEW SignalExpress.

This chapter provides information about LabVIEW SignalExpress system
requirements, installation instructions, version availability, and available
licensing options.

© National Instruments Corporation 1-1 Getting Started with LabVIEW SignalExpress



Chapter 1 Getting Started with LabVIEW SignalExpress

Installing LabVIEW SignalExpress

Before you begin the exercises in this manual, you must install
LabVIEW SignalExpress. The LabVIEW SignalExpress setup program
installs the software in about 10 minutes.

Minimum System Requirements

To run LabVIEW SignalExpress, National Instruments recommends that
your system meet the following requirements:

e 512 MB of memory

*  Pentium 4 processor or equivalent (Pentium III or Celeron 600 MHz
minimum)

Installation Instructions

Complete the following steps to install LabVIEW SignalExpress on
Windows 2000/XP/Vista.

@ Note If you installed LabVIEW SignalExpress from the LabVIEW 8.6 Platform DVD,
you do not need to reinstall using the media described in this section. Refer to the LabVIEW
Release Notes for DVD installation instructions.

1. Exit all programs before you run the LabVIEW SignalExpress installer.
Applications that run in the background, such as virus scanning utilities,
might cause the installer to take longer than average to complete.

2. Log on as an administrator or as a user with administrator privileges.

Insert the LabVIEW SignalExpress installation media and follow the
instructions that appear on the screen.

@ Note Unless you specify another location during installation, the LabVIEW
SignalExpress installation program copies files to the <Program Files>\National
Instruments\SignalExpress directory.

4. After installation, check the hard disk for viruses and enable any virus
detection programs you disabled.

The example projects you use with this manual are located in the <Program
Files>\National Instruments\SignalExpress\Examples\
Tutorial directory. The solutions for each exercise are located in the
<Program Files>\National Instruments\SignalExpress\
Examples\Tutorial\Solutions directory.

Getting Started with LabVIEW SignalExpress 1-2 ni.com



Chapter 1 Getting Started with LabVIEW SignalExpress

LabVIEW SignalExpress Version Availability

LabVIEW SignalExpress is available in both a full and limited (LE)
version. Refer to the following table for a list of features available in each
version.

Table 1-1. Differences in LabVIEW SignalExpress Full and LE Versions

Full LE

Instrument Support

N
|

Over 300 common standalone instruments

Visualization and Documentation

Customizable graphing

Interactive cursors

Save signals to file

Print and export graphs

NN NN S

Drag and drop data into Microsoft Excel, Word,
and WordPad

NN N NS

Operator mode with limited user-editing

Signal Processing

Software filters

Scalar and waveform math

Analog and digital conversion

Interactive signal comparisons

AN N NN
|

Load simulation data from PSPICE, Multisim,
and other SPICE packages

Time and Frequency Measurements

Amplitude and level

Timing and transition

NN S
|

Power spectrum
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Table 1-1. Differences in LabVIEW SignalExpress Full and LE Versions (Continued)

Full

LE

Frequency response

Distortion measurements

Tone extraction

v
v
v

Data Logging

Limited data logging (one log per project)

Unlimited data logging

Logging alarms and events

Logging with start or stop conditions

AN NN

Measurement Automation

Parameter sweeping

Limit testing

Software triggering

Sequencing

AN NN

Remote Data Access

Read/Write shared variables

\

Getting Started with LabVIEW SignalExpress
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Chapter 1 Getting Started with LabVIEW SignalExpress

LabVIEW SignalExpress Licensing Options

This section assists you in understanding the licensing policies for
LabVIEW SignalExpress. This document does not replace the National
Instruments Software License Agreement. Use this document only as a
reference.

LabVIEW SignalExpress LE

The limited, unlicensed LE version of LabVIEW SignalExpress gives you
access to all features in Table 1-1 for 30 days. After that period,
LabVIEW SignalExpress runs in unlicensed mode. If you do not activate a
valid license within 30 days and you create a project that contains licensed
steps, the following occurs:

»  Each time you drop a step that is licensed, a dialog box prompts you to
activate the software.

*  You cannot save a project.

*  Projects close after 10 minutes.

Refer to the National Instruments Web site at ni . com/signalexpress to
purchase LabVIEW SignalExpress Full version.

LabVIEW Signal Express Full Version

The full version of LabVIEW SignalExpress provides you with the full
functionality shown in Table 1-1. You can activate the full version of
LabVIEW SignalExpress using the National Instruments License Manager,
the LabVIEW SignalExpress installer, or the National Instruments Web
site at ni.com/activate.

© National Instruments Corporation 1-5 Getting Started with LabVIEW SignalExpress



Working with Projects

You can use LabVIEW SignalExpress to define measurement procedures
by adding and configuring steps in an interactive measurement
environment. A step is a configurable function that acquires, generates,
analyzes, loads, or stores signals. The Add Step menu and the Add Step
palette show the steps available in LabVIEW SignalExpress.

Most steps process input signals and produce output signals. You can
configure the operation of a step by specifying values on the Step Setup tab
for the step. A saved sequence of configured steps is a LabVIEW
SignalExpress project.

This chapter teaches you how to load and run existing projects and how to
configure steps in these projects.

Opening a Project

Complete the following steps to load a sample project in LabVIEW
SignalExpress.

1. Launch LabVIEW SignalExpress.

Notice that LabVIEW SignalExpress is split into views that display
various types of information. The primary view appears in the middle
of the application window and contains tabs. If LabVIEW
SignalExpress opens in the default configuration, the Data View tab,
the Recording Options tab, and the Project Documentation tab
appear in the primary view.

The primary view is surrounded by supplementary views. In the
default configuration, the Project View appears on the left, and the
context help appears on the right.

@ Note If LabVIEW SignalExpress detects a supported hardware device, the Channel View
appears across the bottom of the LabVIEW SignalExpress application window.

2. If LabVIEW SignalExpress does not open in the default configuration,
select View»Reset Layout to reset the application to the default
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Chapter 2 Working with Projects

configuration. You can use the View menu to display tabs and views or
reset the layout at any time.

Select Help»Open Example, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click First
Project.seproj to open the example project.

Examine the window that appears, as shown in Figure 2-1 with the
context help closed, to learn about different components of LabVIEW
SignalExpress.

® ®

- C:\Prograng Files\.. \first Project.seproj - LabVIEW SignalExpress [M][=)<]
File  Edit Met"loo\s AJgEtsp Operate Dataview Window Help
€ AddStep 43 Run ~| Recard 500
i3 Project ~ 2 X | [& pataview =
® P ——)
5

G|
Load from ASCI

®
o

|» 28 exported time signal

b ® '8 Distorted Sinewave.
[ Amplitude and Lavels o

Db 0 Distor distorted sinewave

H B Distor.distorted sinewave

1.4

bt

v

v

Voltage ()

DEE
1 Run button 4 Input 7 Logged Data window
2 Work Area pull-down menu 5 Output 8 Primary view with Data View tab visible
3 Step 6 Project View 9 Record button

Figure 2-1. First Project.seproj

The LabVIEW SignalExpress environment consists of views that
display various types of information. The primary view appears in the
middle of the application window and contains tabs, such as the Data
View tab. Supplementary views surround the primary view and appear
with individual title bars. For example, the Project View is a
supplementary view.
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Chapter 2 Working with Projects

Running a Project and Displaying Signals

£% Fun ~

LabVIEW SignalExpress has multiple execution or run modes. You can
run projects once, continuously, for a number of iterations you specify, or
for an amount of time you specify. When you run a project once, LabVIEW
SignalExpress executes all the steps in the project one time. When you run
a project continuously, LabVIEW SignalExpress executes all the steps in
the project continuously. Click the down arrow on the Run button, shown
at left, and select Configure Run from the pull-down menu to configure
the run mode for a project.

Displays on the Data View tab update continuously while a project runs.
When a project is running, you can change measurement configuration settings
by changing settings on the Step Setup tab and view the results immediately.
Projects you run continuously run until you click the Stop button, shown at left.
The Stop button appears in place of the Run button as a project runs.

Complete the following steps to run the sample project and display signals.

1. Click the Run button. If the Run Information dialog box appears,
click the Run button in the dialog box to execute all the steps in the
project continuously.

The project loads a signal from a text file and performs two operations
on the signal—an amplitude and levels measurement and a distortion
measurement. The Amplitude and Levels step and the Distortion step
perform these measurements, respectively. When you run a project,
steps analyze input signals and generate new output signals as a result
of the analysis. In this project, the Load from ASCII step loads a
distorted sine wave, the Amplitude and Levels step and the Distortion
step analyze the sine wave, and both steps return new outputs. In the
Project View, LabVIEW SignalExpress indicates inputs with red
arrows and outputs with blue arrows.

The graph display on the Data View tab still contains the loaded
signal, which is a time-domain signal. Graphs display time-domain,
frequency-domain, or XY signals.

2. Drag the exported spectrum output signal of the Distortion step from
the Project View to the Data View tab to display the signal.

LabVIEW SignalExpress creates a new graph display on the Data
View tab. LabVIEW SignalExpress does not display the exported
spectrum signal on the same display as the time-domain signal
because the exported spectrum signal is a frequency-domain signal.
LabVIEW SignalExpress automatically recognizes different types of
signals and renders them in the appropriate displays.

© National Instruments Corporation 2-3 Getting Started with LabVIEW SignalExpress



Chapter 2

Working with Projects

Tip Refer to the LabVIEW SignalExpress Help for more information about signal types
by selecting Help»LabVIEW SignalExpress Help, clicking the Search tab, and entering
"signal types". The help provides information about using LabVIEW SignalExpress
functionality such as projects, steps, and signals.

3. Drag the dc output of the Amplitude and Levels step to the Data View
tab.

LabVIEW SignalExpress creates both a graph and a Legend table to
display the scalar measurement from the dc output. The Legend table
displays the value of each output and the color LabVIEW
SignalExpress uses to plot the output on the adjoining graph.

4. Drag the rms output of the Amplitude and Levels step to the Legend
table to display the scalar RMS measurement.

LabVIEW SignalExpress creates a new row in the table to display the
second measurement. The project appears as shown in Figure 2-2.

“& C:\Program Files\...\First Project.seproj * - LabVIEW SignalExpress [Z]@
file Edit Yiew TIools AddStep Operate DataView Window Help

€ Add Step Stop - | @ Record S0

5 Project > X% Data View x

V| fm AddDisplay S Properties...
Display 1

i [ Monitor | Record

ol
@ Load from ASCII

|» @ [ Distorted Sinewave.tt

Amplitucle and Levels

M |8 Distor. distoted sinewave W
|» 0 de

b EE s

@ Distortion

¥ |5 Distor. distoted sinewave W
|25 exported time signal
|+ A, exported spectrum

o S00u im 1.5m Zm 2.5m 3m 3.5m 4m 4.5m Sm
Theration

Display 2

3
3

fund. frequency
THD (%)

mplitude (dE rms ref 1.0E+0 EU)

nEm

ok ozsk sk 3%k
Tirne (s)

Display 3

Awg, tm: 26.487ms 1.2-

fo
3 Logs 800m -

Legend

Ea)

rms (V)

-10.0602m
1.00382

{73 snapshots

&00m -

400m -

Woltage ()

200m =

0-

20 = A T
29 100 150 200 250 300 350 400 450 500540

BDE® Time: ()
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Chapter 2 Working with Projects

Configuring a Step

A step is a configurable function that acquires, generates, analyzes, loads,
or stores signals. Steps process input signals and produce output signals.
You can configure the operation of a step in LabVIEW SignalExpress by
specifying values on the Step Setup tab for the step. While a project runs,
you can modify the configuration of steps and see immediate feedback on
the Data View tab, and you can adjust measurements until you achieve the
results you need.

Complete the following steps to configure the Distortion step and the
Amplitude and Levels step.

1. Double-click the Distortion step in the Project View. LabVIEW
SignalExpress displays the Step Setup tab for the Distortion step, as
shown in Figure 2-3.

Exported Signal

7 -

o 1-
h=
2 -
£ 0
=
I -] -
2oy 1 1 1 1 1
0 1 2m 3 i S
Time {53
Exported Power Spectrum Aukoscale magnitude
50—
g o
<
5 -50 -
5 -100-
=
-150 -y 1 1 1 1 I I I I I 1
o Sk 10k 15k 20k 25k 30k 35k 40k 45k, S0k

Frequency (Hz)

Inputfoutput | Corfiguration | advanced

Measurement Setup Measurement Resulks
Distortion bypes Highest harm. Fund. frequency  THD (%)
Harrmonics only B4 19 3002001 3k 0.3616
Export signals {THDY) : SIMAD (dE) THD + Moise (%)
Input Signal || ] i}

Figure 2-3. Distortion Step Setup Tab

On the Configuration page of the Step Setup tab, the Export signals
(THD) field indicates that the Distortion step exports the input signal,
and the Exported Signal graph displays a preview of the signal. The
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Working with Projects

Exported Power Spectrum graph indicates that the step performs a
power spectrum on the input signal to convert it to the frequency
domain, and the Measurement Results field displays the fundamental
frequency and total harmonic distortion (THD) of the signal. The step
generates the exported signal and three measurements as outputs—the
spectrum, the THD, and the fundamental frequency of the original
time-domain waveform input.

If the context help does not appear on the right side of the screen, select
Help»Context Help to display complete reference information about
the step.

The upper section of the context help displays information about the
step, and the lower section of the context help displays information
about specific parameters of the step when you move the cursor over a
parameter. Move the cursor over the THD (%) parameter to display
information about the parameter.

On the Configuration page, select Fundamental Tone from the
Export signals (THD) pull-down menu.

The Exported Power Spectrum graph changes from displaying the
frequency-domain spectrum of the entire input signal to displaying
only the frequency spectrum of the fundamental tone of the input
signal. Both the output signal of the Distortion step and the graph
display of the exported spectrum output on the Data View tab update
to reflect the change you made.

Select Harmonics only from the Export signals (THD) pull-down
menu.

The Exported Power Spectrum graph on the Step Setup tab and the
graph of the output on the Data View tab both change to display only
the spectrum of the harmonic signals from the input signal.

Click the Amplitude and Levels step in the Project View.

The Step Setup tab changes from displaying the configuration of the
Distortion step to displaying the configuration of the Amplitude and
Levels step.
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Chapter 2 Working with Projects

6. Select the Input/Output page to display the list of possible inputs and
outputs for this step, as shown in Figure 2-4.

Input Signal

RN 1 1 1 1 I
1] im 2m 3 < S
Time {53 Autoscale amplitude

InputfOutput | Configuration

Export DC value

Export RMS value

E}?, Di...distorted sinewave W [] Export +peak value
[] Export: -peak value

Input signal;

[] Export peak-peak value

Figure 2-4. Amplitude and Levels Step Setup Tab

7. Place checkmarks in the Export +peak value, Export -peak value,
and Export peak-peak value checkboxes to configure the Amplitude
and Levels step to return three additional measurements.

Three additional outputs appear in the Project View.
Switch to the Data View tab.

Drag the three new outputs from the Project View to the Legend table
of scalar measurements. The new outputs appear on the adjoining
graph.

E Note If you have been running the project for a while, you might need to stop and restart
the project to see all the scalar signals on the graph. LabVIEW SignalExpress accumulates
points of data for signals that you add to a graph, and new signals you add do not have as
many data points to display on the graph.
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10. Click the Stop button to stop the project.

When you click the Stop button, the project stops running after
completing the current cycle of operations, or the current iteration.
Click the down arrow on the Stop button and select Abort from the
pull-down menu to completely stop the project without finishing the
current iteration.

11. Select File»Save Project As and save the project as My First
Project.seproj in the SignalExpress\Examples\Tutorial
directory.

12. Select File»Close Project to close the project.

Ordering, Moving, and Deleting Steps

Most steps in LabVIEW SignalExpress projects require input data. Steps
can operate only on signals exported from previous steps in the Project
View, so the order in which steps appear in the Project View can effect
project functionality.

For steps that have an Input or Input/Output page on the Step Setup tab,
the Input signal pull-down menu on that page displays only compatible
signals exported from a previous step. When the output of a step becomes
the input of another step, the steps become dependent on each other, and the
two steps execute sequentially at the same rate. The first step generates an
output signal that the second step must receive as an input before the second
step can execute.

You can move a step within a project by dragging it up or down in the
Project View. You can delete a step by right-clicking it in the Project View
and selecting Delete from the shortcut menu. When you move or delete a
step, the status of signals in the project changes. For example, if you delete
a step that generates output signals, the operation of the project breaks if
any of the deleted output signals are inputs for other steps, and an error
indicator appears in the Project View. You also can cut, copy, and paste
steps within a project by pressing the <Ctrl-X>, <Ctrl-C>, and <Ctrl-V>
keys, respectively, or by right-clicking a step in the Project View and
selecting Cut, Copy, Paste Before Selected Step, or Paste After Selected
Step from the shortcut menu.
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Handling Errors and Warnings

If an error occurs while a project runs, an error indicator, shown at left,

|§| appears in the Project View on the step that encountered the error.
Double-click the step with the error to display an error description across
the bottom of the Step Setup tab. Click the Details button to the right of
the error description to display the full error description.

LabVIEW SignalExpress logs all errors and warnings on the Event Log tab
while a project runs. To display the Event Log tab, select View»Event
Log. Refer to the LabVIEW SignalExpress Help for more information
about errors and warnings by selecting Help»LabVIEW SignalExpress
Help, clicking the Search tab, and entering errors.
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Graphing Signals

You can use LabVIEW SignalExpress to generate and analyze signals
without programming. This chapter teaches you how to work with signals
in LabVIEW SignalExpress, including how to plot signals on graphs,
import signals from a file, interactively align and compare two signals, and
save signals to a file.

h Add Display

© National Instruments Corporation

Complete the following steps to plot signals in a sample project and
examine the signals visually using cursors.

1.

Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click
Signals.seproj. This project configures the Create Analog Signal
step to create a square wave signal and the Filter step to perform a
lowpass Butterworth filter.

Drag the step signal output of the Create Analog Signal step to the
Data View tab.

Drag the filtered step output of the Filter step to the Data View tab.

Both the step signal and the filtered step signals are time-domain
signals, so they appear on the same graph display. If you try to plot
signals of different types by dragging the signals to the same display,
LabVIEW SignalExpress creates a new display.

Click the Add Display button, shown at left, to create a new display.
Drag the filtered step output of the Filter step to the new display.

3-1 Getting Started with LabVIEW SignalExpress



Working with Signals

6. Right-click the new display and select Visible Items»Cursors from
the shortcut menu to display two interactive cursors, as shown in
Figure 3-1.
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Figure 3-1. Signals.seproj

As you drag the cursors, LabVIEW SignalExpress displays the x- and
y-values of the cursors in the cursor table at the bottom of the Data
View tab.

7. Select File»Save Project As and save the project as
My Signals.seproj in the SignalExpress\Examples\
Tutorial directory.
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Importing a Signal from a File

You can import signals from standard file formats such as ASCII comma-
or tab-delimited files and LabVIEW measurement data files (. 1vm). You
also can import signals from simulated results of electronic design
automation tools such as SPICE simulators.

Complete the following steps to import a signal from a file.

1.

Right-click in the Project View and select Load/Save Signals»Analog
Signals»Load from ASCII from the shortcut menu to add the Load
from ASCII step to the Project View. The Step Setup tab for the Load
from ASCII step appears. This step parses an ASCII file and displays
the signals in the file.

@ Note You can add steps to a project from the Add Step menu, the Add Step palette, or the
shortcut menu that appears when you right-click in the Project View.

2.

10.
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On the Step Setup tab, click the browse button, shown at left, navigate
to the SignalExpress\Examples\Tutorial directory, and
double-click Step Response. txt.

In the File preview section, column 1 shows the time stamp data, and
column 2 shows the actual voltage values of the signal.

Switch to the Import Signals page of the Step Setup tab to display the
available signals in the file.

Place a checkmark in the Column 2 checkbox to import that signal,
and remove the checkmark from the Column 1 checkbox.

The Step Setup tab displays a preview of the signal on the Imported
Signal graph.

Select Column 1 (Column 1) from the Input X values pull-down
menu to set the x-axis data of the waveform to the appropriate values.

Switch to the Data View tab.

In the Project View, expand the Step Response.txt output of the Load
from ASCII step.

Right-click the Column 2 output and select Rename from the shortcut
menu.

Enter step response and press the <Enter> key to rename the output.

Drag the new step response output of the Load from ASCII step to the
lower display on the Data View tab.
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The filtered step signal resembles the rising edge of the step response
output, as shown in Figure 3-2.
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Figure 3-2. Signals of Signals.seproj

11. Select File»Save Project to save the project.

Aligning and Comparing Signals

Although the filtered step signal and the step response output both show
an overshoot in the rising edge, assessing the similarity between the two
is difficult because the signals come from different sources and vary in
amplitude and timing. However, you can use the Interactive Alignment step
to align and compare two signals, so you can choose which type of
information you want to export from the operation to use in the project.

Complete the following steps to align two signals in the
My Signals.seproj project.

1. Expand the Step Response.txt output, right-click the step response
output and select Send To»Processing»Analog Signals»
Interactive Alignment from the shortcut menu to pass the step
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response signal from the Load from ASCII step to the Interactive
Alignment step.

The step selects the two most recent signals from the project to use as

inputs and displays the signals on the graphs on the Step Setup tab, as
shown in Figure 3-3.
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Figure 3-3. Interactive Alignment Step Setup Tab

When you add a step to a project, LabVIEW SignalExpress selects
input signals based on the signal types the step can accept. For
example, the Interactive Alignment step can operate only on
time-domain waveform signals. Therefore, the step selects as inputs
the last two time-domain signals created in the project.

@ Note To change the input signals for a step, select different signals from the pull-down
menu of compatible signals on the Input or Input/Output page of the Step Setup tab, or

click the down arrow that appears next to the step input name on the step in the Project
View.
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2. Click the red signal in the Input Signals graph and drag it to another
point within the graph. The Comparison Result Signal graph updates
to show the new calculated difference between the signals.

You can drag, expand, and contract signals on the graph.

3. Try to align the rising edges of the two signals by dragging a signal
within the graph. Click a signal to set an anchor point and press and
hold the <Alt> key while dragging the signal to stretch the signal
around that anchor point along the x- and y-axes.

On the Alignment page of the Step Setup tab, the step computes and
displays the x- and y-gain and offset values you need to achieve the
alignment specifications as you drag the signals.

4. Select Auto - Step from the Mode pull-down menu to align the
signals. LabVIEW SignalExpress computes the alignment using
built-in algorithms.

The Comparison Result Signal graph on the Step Setup tab displays
the difference between the two signals.

5.  On the Input/Output page, place a checkmark in the Export aligned
signals checkbox to add the signals to the outputs of the step.

6. Switch to the Data View tab.
Click the Add Display button to add a third display.

Drag the aligned reference and aligned test outputs of the Interactive
Alignment step to the new graph to view the aligned signals.

9. Select File»Save Project to save the project.

Signal Types in LabVIEW SignalExpress

Some steps, such as the Arithmetic step, can operate on multiple signal
types. For example, you can use the Arithmetic step to operate on
time-domain or frequency-domain waveforms. The Arithmetic step
changes behavior based on the type of input signals you select for the
step. For example, if you add two time-domain signals, LabVIEW
SignalExpress adds only their amplitudes. However, if you add two
frequency-domain phase signals, LabVIEW SignalExpress adds the
appropriate phase shift.

Refer to the LabVIEW SignalExpress Help for more information about
signal types by selecting Help»LabVIEW SignalExpress Help, clicking
the Search tab, and entering "signal types".
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Exporting and Printing Signals

You can use LabVIEW SignalExpress to document signals or continue
analysis in another software application. This section teaches you how to
export signals, including sending signals to an ASCII file, sending data to
Microsoft Excel, printing signals, and using the built-in project
documentation feature to document the LabVIEW SignalExpress project.

Saving Signals to File

Complete the following steps to save a signal from My Signals.seproj
to a file.

1.
€ Add Step

10.
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Click the Add Step button, shown at left, to display the Add Step
palette.

Select Load/Save Signals»Save to ASCII/LVM to add the Save to
ASCII/LVM step to the Project View. The Step Setup tab for the Save
to ASCII/LVM step appears.

Click the Signals page on the Step Setup tab and select filtered step
from the Input Data pull-down menu.

On the File Settings page, specify where to save the text file you are
creating. Click the Browse button next to the Export file path field
and navigate to the SignalExpress\Examples\Tutorial
directory, and enter filtered signal.txt as the filename.

Select Overwrite from the If file already exists pull-down menu.

Select Generic ASCII (.txt) from the Export file type pull-down
menu.

You can use a Load/Save Signals step to save data to a file every time
the project runs.

Click the down arrow on the Run button and select Run Once to run
the project and save the resulting signal to the specified ASCII file.

Select File»Save Project to save the project.
Select File»Close Project to close the project.

Browse to the filtered signal.txt and open the file in a text
editor to see the values of the signal. In LabVIEW SignalExpress, you
can use the Load from ASCII step to import the signal back into a
project.
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Exporting Signals to Microsoft Excel

Printing Signals

To export signal data to Microsoft Excel, launch Excel and drag the output
signal of a step in LabVIEW SignalExpress to an Excel spreadsheet. You

also can right-click a display on the Data View tab and select Export To»
Microsoft Excel to export all the data on the display.

To print an image of a graph, display the Data View tab and select File»
Print»Print Data View.

Creating Reports in LabVIEW SignalExpress

Select View»Project Documentation to display the Project
Documentation tab. You can use this tab to describe a project using text and
images such as graphs. You can drag a step output from the Project View to
the Project Documentation tab to display a graph of the output signal. If the
project is running, the graph on the Project Documentation tab
automatically updates to match the current value of the step output.

To print the documentation, display the Project Documentation tab
and select File»Print»Print Documentation or click the Print
Documentation button. To export the documentation to HTML, display
the Project Documentation tab and select File»Export»Export
Documentation to HTML.
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You can use LabVIEW SignalExpress to record and analyze
measurements. You can record any time-domain, double, 32-bit unsigned
integer, or Boolean step output. You also can analyze and process logged
data by playing it through analysis steps.

This chapter teaches you how to record data using the integrated data
logging features in LabVIEW SignalExpress. You learn how to record a
specified signal, play back that signal, and analyze the signal using analysis
steps. You also learn how to use the Recording Options tab to log signals
based on specified start or stop conditions.

Recording a Signal

& Record

You can use the Record button to configure a data logging process.

Complete the following steps to specify a signal to record and to record the
signal.

1. Select File»xOpen Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click
Logging.seproj.

This project uses the Create Analog Signal step to generate a signal
based on a formula.

2. Click the Record button, shown at left, to open the Logging Signals
Selection dialog box.

The Logging Signals Selection dialog box displays the signals in the
project available for recording. You can select one signal or multiple
signals to record. You also can specify a name and description for
the log.

3. Place a checkmark in the signal checkbox to record the formula signal
generated in the Create Analog Signal step.

4. Click the OK button to close the Logging Signals Selection dialog
box and begin recording the signal. The logging operation continues
until you click the Stop button.

© National Instruments Corporation 4-1 Getting Started with LabVIEW SignalExpress



Chapter 4 Logging Data

FER

Click the Stop button, shown at left, to stop logging the signal. If you
have not logged a signal before, the First Log Complete dialog box
appears. Click the OK button to close the dialog box.

The logged data appears in the Logged Data window at the bottom of
the Project View, as shown in Figure 4-1.

= Logs
¥ 4/15/2008 : 3:08:19 PM
ﬁ Snapshots

Figure 4-1. Logged Data Window

By default, LabVIEW SignalExpress names the logged data according
to the date and time you recorded the data. LabVIEW SignalExpress
saves logged data in the . tdms file format in the directory you specify
in the Options dialog box.

Select Tools»Options and select the Logging option to specify the
directory for LabVIEW SignalExpress to save the logged data and to
customize various preferences for logged data.

Click the OK button to close the Options dialog box.

Select File»Save Project As and save the project as
My Logging.seproj in the SignalExpress\Examples\
Tutorial directory.

Viewing a Logged Signal

Complete the following steps to view the logged data.

1.

If the Data View tab is not visible, select View»Data View to display
the Data View tab.

The Logged Data window displays a list of all logged data in the
current project. Select the data log you just recorded from the Logged
Data window and drag it to the Data View tab. The Data View tab
displays the logged data and a Preview Graph, as shown in Figure 4-2.
The signal displayed on the Data View tab might differ from the signal
displayed in Figure 4-2, depending on how long you recorded the
signal.
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Figure 4-2. Logging.seproj

The Preview Graph provides a method for zooming and panning
through data on the Data View tab. The Preview Graph appears by
default when you view logged data. When viewing live or non-logged
data, right-click a display on the Data View tab and select Visible
Items»Preview from the shortcut menu to display the Preview Graph.

Click the Zoom In button next to the Preview Graph to zoom in on the
logged signal. The cursors on the Preview Graph show the subset of
data currently displayed on the Data View tab. Use the scroll bar
beneath the Preview Graph to scroll through the data. Click and drag
the cursors on the Preview Graph to increase or decrease the subset of
data you are viewing.
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Logging Signals with Predefined Start and Stop
Conditions

You can configure start and stop conditions that signals must meet before
LabVIEW SignalExpress records or stops recording the signals. Complete
the following steps to log data based on start and stop conditions.

1. If the Recording Options tab is not visible, select View»Recording
Options to open the Recording Options tab.

2. Select Signal Selection from the Category list on the Recording
Options tab.

3. Place a checkmark next to the signal in the Record column, as shown
in Figure 4-3.

Category | signal selection
Signal Selection
Log Summary Channel Record
Start Conditions
signal
Stop Conditions ke sig [v]
Alarms
Events
Recording status
recording SRS

Disk infarmation [
(used:S1 GE - free: 109 GEB)

Current estimated log size:

Rerording tima left:

Current log started on:

Figure 4-3. Signal Selection

The Record button changes to the Record While Running button,
¥} Record While Running shown at left. Ensure the Record While Running button is pressed.
When the Record While Running button is pressed, LabVIEW
SignalExpress records the selected signal when you click the Run
button.

4. Select Start Conditions from the Category list on the Recording
Options tab.
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Click the Add button under the Start condition list to customize a
start condition for the logging task.

a. Inthe Condition type pull-down menu, verify that Signal trigger
is selected to specify that LabVIEW SignalExpress begins
recording when the input signal meets the specified condition.

b. In the Signal pull-down menu, verify that signal is selected.

c. Inthe Trigger type pull-down menu, verify that Rising slope is
selected to specify to begin recording the signal based on the value
of the edge of the signal on a positive slope.

d. Enter 1 in the Trigger value field to begin recording when the
signal crosses 1 on a rising slope.

Select Stop Conditions from the Category list on the Recording
Options tab.

Click the Add button under the Stop condition list to customize a stop
condition for the logging task.

a. In the Condition type pull-down menu, verify that Duration is
selected to specify that LabVIEW SignalExpress stops recording
after a specified amount of time passes.

b. In the Duration control, verify that 5 appears to specify to record
the signal for 5 seconds after the signal meets the start condition.

Click the Run button, shown at left. LabVIEW SignalExpress begins
recording the signal when the signal crosses level 1 on a rising slope
and continues recording the signal for 5 seconds.

The following indicators in the Recording status section of the
Recording Options tab update while the project runs:

*  Recording displays ON when the signal meets the start condition
and logging is in progress.

* Disk information displays the available hard disk space on the
computer for the log.

*  Current estimated log size displays the size of the log file on
disk.

*  Recording time left displays the amount of time you can continue
recording the log before running out of disk space.

e  Current log started on displays the start time of the current log.

The Start Conditions, Stop Conditions, Alarms, and Events pages
of the Recording Options tab also include indicators that display the
status of start and stop conditions, alarms, and events that you
configure.
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Analyzing Logged Signals

After you log a signal, you can play back the logged data or run the logged
signal through analysis steps, just as you can with live data. Complete the
following steps to analyze a logged signal.

1. Locate the Work Area pull-down menu above the Project View, as
shown in Figure 4-4. Click the down arrow and select Playback to
switch to the Playback work area.

@] | Monitar [ Record

Figure 4-4. Work Area pull-down menu

Use work areas to perform multiple LabVIEW SignalExpress
operations from within the same project. You can acquire data, process
signals, record data, and perform measurements on logged data
without opening a new project. When you save a project, LabVIEW
SignalExpress saves every work area within the project in the same
project file.

The default work area, Monitor/Record, allows you to take
measurements, analyze live data, and log data. The Playback work area
allows you to use logged data that you record in the Monitor/Record
work area as an input for an analysis step.

2. Click the Add Step button, shown at left, and select the Filter step from
Processing»Analog Signals»Filter. LabVIEW SignalExpress
automatically selects the first signal you logged as the input to the
Filter step.

@) Add Step

3. Switch to the Data View tab, and drag the filtered data output of the
Filter step to the Data View tab to view the resulting signal.

4. Click the Run button. The Data View tab displays the resulting
filtered signal and LabVIEW SignalExpress plays back the entire log.

Advanced Playback

You can use the Playback Options tab to configure advanced data
playback options. The Playback Options tab displays a preview of the
logged data and allows you to select a subset of that data to play back or run
through analysis steps.

1. Select View»Playback Options to display the Playback Options tab,
as shown in Figure 4-5.
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Figure 4-5. Playback Options View

2. In the Logged signal listbox, select signal from the second log you
created.

3. Enter 1 in the Start time (s) field to play back or analyze a subset of
the logged signal beginning 1 second after the start of the log.

4. Enter 4 in the Stop time (s) field to play back or analyze a subset of
the logged signal ending four seconds after the start of the log. If the
log is not at least 4 seconds long, enter an appropriate value in the Stop
time (s) field.

5. Inthe Logged signal listbox, right-click the signal from the second log

and select Activate from the shortcut menu to make that signal the
active log.

@ Note You also can right-click a log in the Logged Data window and select Make Active
Log from the shortcut menu to make that log the active log.

6. Switch to the Data View tab. The graph display on the Data View tab
automatically updated to display the signal from the second log when
you made that signal the active signal.

7. Click the Run button, shown at left. LabVIEW SignalExpress filters
the subset of the signal you specified on the Playback Options tab and
displays the resulting filtered signal on the Data View tab.

1% Run -

Refer to the LabVIEW SignalExpress Help for more information about
logging data, such as specifying alarm conditions, events, and playback
options.
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You can use LabVIEW SignalExpress to automate measurements to
characterize and validate designs by creating sweep operations. A design
can be anything you create and want to characterize and validate with
LabVIEW SignalExpress. You can use the sweep measurements to gather
data from designs over a range of conditions to document the performance
of the designs. For example, you can use sweep operations to vary the
frequency of a stimulus signal or vary the level of a supply voltage while
taking measurements to characterize designs.

This chapter teaches you how to set up sweep operations using the Sweep
step in LabVIEW SignalExpress. You learn how to characterize the
performance of a filter by sweeping through a range of frequency values
and measuring the output of the filter. You also learn how to display sweep
results and perform multidimensional sweeps for more complex
measurements.

Defining Sweep Ranges and Outputs

£% Run -~

You can use the Sweep step in LabVIEW SignalExpress to define
automated measurements for complex, repeatable sweep operations.

Complete the following steps to define a frequency range in a sample
project to sweep through a filter.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Sweep. seproj.

2. Click the Run button, shown at left, to run the project continuously.

The project generates a sine wave stimulus signal using the Create
Analog Signal step, passes it through a bandpass elliptic filter using the
Filter step, measures the RMS level of the filter output using the
Amplitude and Levels step, and converts the level to decibels (dB)
using the Formula step. The Filter step acts as a simulated unit under
test, so the project uses no hardware. However, you also can sweep
physical signals generated from a National Instruments arbitrary
waveform generator, function generator, dynamic signal analyzer, or
multifunction I/O (MIO) device.
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€ add Step
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Click the Stop button to stop the project.

Click the Add Step button, shown at left, and select Execution
Control»Sweep to add the Sweep step to the Project View.

On the Step Setup tab, click the Add button to display the list of
sweepable parameters from each step in the project, as shown in
Figure 5-1.

i3 Sweep Parameter Selection

Available Sweepable Parameters

= Create Analog Signal: stimulus signal (sinewala |
amplitude Il
Block size (samples)
Frequency (Hz)
Offset (V)
Phase (deg.)
Sample rate (3/s)

= Filter: response signal
Lowy Cut-Off
Crrder

I OK l [ Cancel ]

Figure 5-1. Sweep Parameter Selection Dialog Box

Select the Frequency (Hz) parameter under Create Analog Signal
and click the OK button.

The Sweep step encloses the Create Analog Signal step, which
provides the signal to sweep.

On the Sweep Configuration page of the Step Setup tab, select
Exponential from the Type pull-down menu.

Enter 1k in the Start: Frequency (Hz) field, and enter 40k in the
Stop: Frequency (Hz) field.

Enter 150 in the Number of points field.
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The Sweep Configuration page appears as shown in Figure 5-2.

Sweep Configuration

Sweep Outpuk

Sweepable parameters:

Parameter Mame Skep Name Affected Output Alias A
Frequency (Hz) Create Analog Signal  stimulus signal {sinewa
~

Configuration

Type
Exponential |

Sween Poinks

40k

Start: Frequency (Hz)

1k S 10k -

Values

Stop: Freguency (Hz)
40k, 2

Mumber of poinks e

-~ lk I 1 1 1 1 1 1 1 1

150 5 1 20 40 &0 80 100 120 140 180
Ikeration

10.
11.

12.
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Figure 5-2. Sweep Step Setup Tab

You use the Sweep step to specify a range of values to iterate through
the Frequency (Hz) parameter of the Create Analog Signal step. The
Create Analog Signal step uses the defined frequency range to
generate a sine wave at each of these frequencies. You can use the
Sweep step to iterate through any sweepable parameter value of any
sweepable step in a project.

Switch to the Sweep Output page.

Click the Add button to display the list of sweepable outputs from each
step in the project.

Select the response amplitude in dB output under Formula and click
the OK button to plot this measurement against the swept Frequency
(Hz) parameter.

The Sweep step creates a loop around all the steps in the Project View
to include all the steps in the sweep operation.
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Running Sweep Measurements

Complete the following steps to run the sweep measurement.

1. Switch to the Data View tab, click the down arrow on the Run button,
and select Run Once to execute the sweep measurement.

The white stimulus signal output on the graph display iterates through
the specified range of frequencies.

2. Drag the response amplitude in dB vs. Frequency signal from the
bottom of the Sweep loop to the Data View tab to display the output
of the sweep.

LabVIEW SignalExpress creates a new graph display. The data from a
sweep operation is an XY array that requires a separate display, as
shown in Figure 5-3.

“& C:\Program Files\...\Sweep.seproj * - LabVIEW SignalExpress Q@

Flle Edt Wiew Tools AddStep Operate DataView Window Help
@ Addstep €3 Run 7| @ Record 50

1 Project + # X | [ Data View | 83 Step Setup X
i Monitor | Record V|| | fim Add Display g Properties..

Display 1

-

Sweep &00m -

£00m~

[-) Craie Anaiog Signal
Sinewave 400m

[» P8 stimulus signal [sinewave)

I- A Filter
Simulated Unit-Under-Test

W B8 stimuius signal sine...

200m -

0-

Voltage (¥)

-200m -

i
[ '8 response signal ~400r -
-600m -~
Amplitude and Levels
JHE] 8 e Fivs ofhe Fes _a00m-
M [ response signal -
sy I I I T I I U I I I
I 51 s ofresponse 0 1m zm 3m 4m sm &m m Bm 9m 10m
—_— BB Time {s)
] Farmula
Convet to dB lsplety
M ims of response: -
I» B2 esporse anpitude n &6 s
g ——————
5 Etes
=2
£
] s
3 Logs &
g |
{3 Snapshots 2
g ===
o ===
1k 10k 100k
BHE Frequency (Hz)

Figure 5-3. Sweep.seproj
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3. Select the Run Once option again to execute the sweep.

The frequency response of the Filter step plots on the new graph
display while the project runs. The graph shows the transfer function
of the filter, or the amplitude output expressed in decibels versus the
frequency.

@ Note By default, LabVIEW SignalExpress does not clear displays on the Data View tab
between iterations of a sweep. Because the frequency response of the Filter step is the same
for each iteration, the graph that displays the signal does not appear to update when you
run the project. You can use the Data page of the Options dialog box to specify whether
LabVIEW SignalExpress clears displays between iterations of a sweep. Select Tools»
Options to display the Options dialog box.

4. Double-click the Filter step to display the filter specifications on the
Step Setup tab.

The frequency response of the filter in the Filter Magnitude
Response (dB) graph matches the graph in the Data View.

5. Select File»Save Project As and save the project as
My Sweep.seproj in the SignalExpress\Examples\Tutorial
directory.

You can use the Sweep step to sweep multiple parameters simultaneously
by adding additional parameters on the Sweep Configuration page of the
Sweep Step Setup tab. Sweeping two or more parameters simultaneously
is called a parallel sweep. For example, if you want to vary the amplitude
of a stimulus signal, you can run a parallel sweep to maximize the precision
of the acquisition by varying the input range of a digitizer or MIO device
as you vary the signal level. As the signal level increases, you can increase
the input range of the measurement device to ensure you use the entire
resolution for the measurement.

Running Multidimensional Sweeps

Use multidimensional, or nested, sweeps to iterate through one range while
you vary another range. For example, if you want to sweep through
frequencies of a stimulus signal at different amplitudes, run a nested sweep.
You can set the amplitude to level 1 and sweep through frequencies, then
set the amplitude to level 2 and sweep through frequencies, and so on. You
can build a nested sweep by right-clicking a Sweep step in a project and
selecting Add nested sweep from the shortcut menu to add another sweep
loop.
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Complete the following steps to run a sample nested sweep project.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Nested
Sweep .seproj.

2. Click the Run button to run the project.

Each iteration of the inner sweep loop sweeps the frequency of the
stimulus signal. The outer sweep loop varies the low and high cutoff
frequencies of the Filter step. Each iteration appears in real time on the
upper graph display, and then appears on the lower display to show all
the sweeps at each cutoff frequency setting, as shown in Figure 5-4.

&7 C:\Program Files\...\Mested Sweep.seproj * - LabVIEW SignalExpress E]@
File Edit Wiew Took AddStep Operate DataView Window Help

@ Addstep 43 Run | @ Record 56

{3 Praject > i X Data View x

V\ T Add Gisplay g Properties...
Disolay 1

i \ Monitor { Recard

M Sweep
Outer Loop feut-off hequencies)
M Sweep
Inner Loop [signal freq.)
@ Create Analog Signal
Sweeping Sine Tone

[ stimulus signal [roise)

[ . Filter
Simulated UnitUnder-T st

M B8 stimulus signel (noiss) -
|8 respanse signal

[
£
=
|
=
b=
£
i3
& -
g
-
L

Amplituce and Levels
Get the RMS of the Response

¥ |8 respore signal -
[» [ ims of response
— B ) Frequency (Hz)
Convert to B Display 2
MG s of response -
| [ response amplitude in dB

v B response amplitude in d vs. .

I @ B2 response ampliude in dB vs. Fr..

Idle

response amplitude in &

3 Logs
13l snapshots

Frequency (Hz)

Figure 5-4. Nested Sweep.seproj

3. Click the Stop button, shown at left, to stop the project.
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Extending LabVIEW SignalExpress
Projects with LabVIEW

You can use LabVIEW SignalExpress to define automated measurements
by using built-in steps for acquiring, generating, analyzing, or logging
signals. You can extend the functionality of LabVIEW SignalExpress
projects using LabVIEW in the following ways:

Build a VI in LabVIEW and import the VI into LabVIEW
SignalExpress to provide custom step functionality and expand the
number of steps available in LabVIEW SignalExpress.

Convert a LabVIEW SignalExpress project to a LabVIEW block
diagram to continue development in LabVIEW.

You must have LabVIEW 7.1 or later to complete the exercises in this
chapter.

Importing LabVIEW Vs into LabVIEW SignalExpress

as Steps

Use the Run LabVIEW VI step in LabVIEW SignalExpress to call custom
LabVIEW VIs. You can call a LabVIEW VI from LabVIEW
SignalExpress to do the following:

© National Instruments Corporation

Control GPIB instruments

Control National Instruments hardware that LabVIEW SignalExpress
does not support

Read or write data to more file formats
Display operator instructions in a pop-up dialog box

Define a measurement algorithm
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€ Add Step

Complete the following steps to import a VI from LabVIEW with the Run
LabVIEW VI Step.

1.

Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click User
Step.seproj.

This project uses the Create Analog Signal step to generate a signal.

Click the Add Step button, shown at left, and select Run LabVIEW
VI»Run LabVIEW 8.6 VI.

The VI you run in this exercise was saved in LabVIEW 8.6. You must
use the version of the Run LabVIEW VI step that matches the version
of LabVIEW in which you saved the VI.

On the Step Setup tab, click the browse button in the Select VI section
and select Limiter-Lv86.vi in the LabVIEW SignalExpress\
Examples\Tutorial directory. The Limiter-LV86 VI accepts a
time-domain waveform as an input, clips the signal above and below
values that you specify on the Step Setup tab, and returns the clipped
waveform as an output signal.

When you import a LabVIEW VI, LabVIEW SignalExpress maps the
inputs of the VI as parameters and the outputs of the VI as output
signals in LabVIEW SignalExpress.

You can define whether the inputs for VIs become input signals or
parameters. An input signal appears in the Project View as an input to
a step, which means you can pass signals as inputs to a VI. A parameter
is a value you can configure on the Step Setup tab of a step. You also
can sweep parameters dynamically using the Sweep step. In this
project, the VI has an input signal, Time waveform in, and scalar
parameters, Upper limit and Lower limit.
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Verify that the Step Setup tab appears as shown in Figure 8-1.

Setkings | Configure I I Execution Conkral |

Select vT
CH\Program FilesiMational InstrumentsSignalExpress\Examplest TutorialLimiter, v

[ Run this step automatically Refresh VI

Control name:

Tirne wavefarm in ’
Input signal;

~
Connect Input. .. FE sine wave A
Disconnect Input

~
Cubputs: Strict bype of oukput data
Clipped waveform out A | Time Waveform, Real »

Figure 6-1. Limiter VI Step Setup Tab

S Aun - 4. Click the Run button, shown at left, to run the project.

Switch to the Data View tab and drag the Clipped waveform out
output signal from the Run LabVIEW 8.6 VI step to the Data View
tab.

6. Double-click the Run LabVIEW 8.6 VI step to display the Step Setup
tab.

7. Select the Configure VI page to display the VI.

Enter new values in the Upper limit and Lower limit fields. For
example, enter 100 in the Upper limit field.

9. Switch to the Data View tab. The Clipped waveform out signal
changes to reflect the changes you made.

10. Click the Stop button, shown at left, to stop the project.

11. Select File»Save As and save the project as My User Step.seproj.

12. Select File»Close Project to close the project.
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Refer to the LabVIEW SignalExpress Help for more information about
using LabVIEW VIs in LabVIEW SignalExpress and building VIs that
work well in LabVIEW SignalExpress.

Converting LabVIEW SignalExpress Projects to
LabVIEW Block Diagrams

LabVIEW SignalExpress can convert LabVIEW SignalExpress projects
into LabVIEW block diagrams.

@ Note To convert a LabVIEW SignalExpress project to a LabVIEW VI, you must have the
LabVIEW 7.1 Full Development System or later installed.

Complete the following steps to convert a LabVIEW SignalExpress project
to a LabVIEW block diagram.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial\Solutions and double-click My First
Project.seproj.

2. Select Tools»Generate Code»LabVIEW Diagram.

Specify a filename and location for the new LabVIEW VI and click the
OK button. LabVIEW SignalExpress generates the new VI and opens
the VI in the last version of LabVIEW you opened on the machine.

The resulting LabVIEW block diagram reflects the execution of the
project in LabVIEW SignalExpress. The LabVIEW block diagram
consists of LabVIEW Express VIs wired together. Each Express VI
correlates to a step in the LabVIEW SignalExpress project. You can
double-click an Express VI to display a configuration dialog box that
is identical to the Step Setup tab in LabVIEW SignalExpress. You also
can right-click an Express VI and select Open Front Panel from the
shortcut menu to convert the Express VI into a LabVIEW subVI. You
can view the block diagram to see how the LabVIEW block diagram
executes and modify the functionality of the VI. When you convert an
Express VI into a subVI, you cannot convert the subVI back into an
Express VI

@ Note When you convert a LabVIEW SignalExpress project with logging, LabVIEW

SignalExpress generates a LabVIEW block diagram with one Express VI. You cannot
convert the generated Express VI into a subVL
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Where to Go from Here

Refer to the following resources for more information about LabVIEW
SignalExpress.

LabVIEW SignalExpress Sample Projects

LabVIEW SignalExpress provides a variety of sample projects that
demonstrate more capabilities of LabVIEW SignalExpress. These projects
are located in the SignalExpress\Examples directory. Review these
examples to learn more about the features of LabVIEW SignalExpress or
to start with a project that closely resembles your needs.

Using Hardware with LabVIEW SignalExpress

LabVIEW SignalExpress supports a variety of National Instruments
hardware for acquiring and generating signals. You can generate or acquire
and log analog signals in LabVIEW SignalExpress using National
Instruments MIO devices, dynamic signal acquisition devices, high-speed
digitizers, or arbitrary waveform generator and function generator devices.
You also can synchronize multiple devices in a system by sharing clocks
and trigger signals between devices. Refer to the LabVIEW SignalExpress
Help by selecting Help»LabVIEW SignalExpress Help for more
information about using hardware with LabVIEW SignalExpress.

Web Resources

Refer to the National Instruments Web site at ni . com/signalexpress
for resources such as example projects, technical documents, and
LabVIEW VIs written for use in LabVIEW SignalExpress.

© National Instruments Corporation 7-1 Getting Started with LabVIEW SignalExpress


http://www.ni.com/signalexpress

Technical Support and
Professional Services

Visit the following sections of the award-winning National Instruments
Web site at ni . com for technical support and professional services:

© National Instruments Corporation

Support—Technical support resources at ni . com/support include
the following:

Self-Help Technical Resources—For answers and solutions,
visit ni . com/support for software drivers and updates, a
searchable KnowledgeBase, product manuals, step-by-step
troubleshooting wizards, thousands of example programs,
tutorials, application notes, instrument drivers, and so on.
Registered users also receive access to the NI Discussion Forums
atni.com/forums. NI Applications Engineers make sure every
question submitted online receives an answer.

Standard Service Program Membership—This program
entitles members to direct access to NI Applications Engineers
via phone and email for one-to-one technical support as well as
exclusive access to on demand training modules via the Services
Resource Center. NI offers complementary membership for a full
year after purchase, after which you may renew to continue your
benefits.

For information about other technical support options in your
area, visit ni .com/services, or contact your local office at
ni.com/contact.

Training and Certification—Visit ni.com/training for
self-paced training, eLearning virtual classrooms, interactive CDs,
and Certification program information. You also can register for
instructor-led, hands-on courses at locations around the world.

System Integration—If you have time constraints, limited in-house
technical resources, or other project challenges, National Instruments
Alliance Partner members can help. To learn more, call your local
NI office or visit ni.com/alliance.
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Appendix A Technical Support and Professional Services

If you searched ni . com and could not find the answers you need, contact
your local office or NI corporate headquarters. Phone numbers for our
worldwide offices are listed at the front of this manual. You also can visit
the Worldwide Offices section of ni . com/niglobal to access the branch
office Web sites, which provide up-to-date contact information, support
phone numbers, email addresses, and current events.
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RAISONNABLEMENT, NECESSAIRES A LA PROTECTION CONTRE LES DEFAILLANCES DE SYSTEME, Y COMPRIS
NOTAMMENT EN PREVOYANT DES MECANISMES DE SAUVEGARDE OU DE MISE HORS TENSION. LE SYSTEME
INFORMATIQUE DE CHAQUE UTILISATEUR FINAL ETANT ADAPTE A SES BESOINS SPECIFIQUES ET DIFFERENT DES
PLATES-FORMES DE TEST DE NATIONAL INSTRUMENTS ET UN UTILISATEUR OU UN CONCEPTEUR D’APPLICATION
POUVANT UTILISER LES PRODUITS NATIONAL INSTRUMENTS EN COMBINAISON AVEC D’AUTRES PRODUITS D’UNE
FACON NON PREVUE OU NON TESTEE PAR NATIONAL INSTRUMENTS, L’UTILISATEUR OU LE CONCEPTEUR
D’APPLICATION EST SEUL RESPONSABLE DE LA VERIFICATION ET DE LA VALIDATION DE L’ADEQUATION ET DE LA
COMPATIBILITE DES PRODUITS NATIONAL INSTRUMENTS DES LORS QUE DES PRODUITS NATIONAL INSTRUMENTS SONT
INTEGRES DANS UN SYSTEME OU UNE APPLICATION, Y COMPRIS NOTAMMENT, DE L’ ADEQUATION DE LA CONCEPTION,
DU FONCTIONNEMENT ET DU NIVEAU DE SECURITE DUDIT SYSTEME OU APPLICATION.



Sommaire

A propos de ce manuel

COMNVEITIONS .oeeieeiivieeeeeiieeeeeeeeiteeeeeeetteeeeeeesaeeeeeeesaaeeessessaeeeseeesseseeessesrsesesansraeesessanaes vii
DOCUMENTAION ASSOCIEE ...veeeeeieereeieeieiieeeeeeeeiteeeeeeeiaeeeeeeestareeeeeesaeeeeeeenisreeeeseesraeesessanes viii

Chapitre 1
Initiation a LabVIEW SignalExpress

Installation de LabVIEW SignalEXpPress ........oceeveeriiriiienieniienienieeniiesieeieeseveenieesaees 1-2
Configuration systeme minimale TEQUISE .........cevvverviereerrreeniieenieenieesieerieenanes 1-2
INSTAIIALION ...ttt sttt s s 1-2

Versions de LabVIEW SignalExpress diSponibles..........coccvevvieerieniiinieenieniieeniieneennne. 1-3

Options relatives aux licences de LabVIEW SignalEXpress ........cocceeveveenieeneerieeneennne. 1-5
LabVIEW SignalEXpress LE.......ccccooviiriiiiiinieniieieseeeeenie et 1-5
Version complete de LabVIEW SignalEXpPress .......ccceeceevveenieeneencieeneeneennne. 1-5

Chapitre 2
Travailler avec des projets

OUVETtUTE A UN PrOJEL....ccuviiieiiiieiieiieiete ettt ettt et e s snens 2-1
Exécution d’un projet et affichage de SiZnauX...........cccceveeverieniininicnieicncceeeeeeene 2-3
Configuration d UNE ELAPE .......c..cocueeuieieriieieiiiiee ettt e 2-5
Organisation, déplacement et sSUppression d’étapes .........ccceeveceerueeceeneereenenieeneennennens 2-9
Gestion des erreurs et des miSes €N Garde.........c..cecveveeieriieeenieieneneeneeeere e eneeanes 2-10

Chapitre 3
Manipulation de signaux

Représentation de signaux dans des graphes ..........ccoceveevereerieneeieneneene e 3-1
Importation d’un signal & partir d’un fichier ...........coceiiriniiiinie e 33
Alignement et cOMparaison de SIZNAUX .......cecveruereerrerrientirienteeeeneeeeesteeeeseeeeesreeseesaens 3-4
Types de signaux dans LabVIEW SignalEXPress.........ccecceveerierieeiereeiienencenie e 3-7
Exportation et impression de SIZNAUX .......cc.eerveruerierteeienteeienteeteneeeee e eeeseeeeeseeenaesaeas 3-7
Enregistrement de signaux dans un fichier............ccccoeeeiiriiniinincnienceeee 3-7
Exportation de signaux dans Microsoft Excel...........ccccoeiviiniinininiencenenen. 3-8
IMPression de SIZNAUX .....cceerueeriertieientieie sttt eete sttt eeseeeee e eeesaeas 3-8
Création de rapports dans LabVIEW SignalEXpress........c.coccevevvererenvenennennee 3-9

© National Instruments Corporation v Initiation & LabVIEW SignalExpress



Sommaire

Chapitre 4
Enregistrement des données

Enregistrement d’un SiZNal.........ccoceeiiiriiiiiiiiiiinienieesteee e
Affichage d’un signal enregistré dans un journal...........ccoceevieriieeniiiniennienieeneeneeee
Enregistrement de signaux avec des conditions de démarrage et d’arrét

PIEAGTINIES vttt ettt ettt ettt e st e e s bt e st e sbeesaees
Analyse des SIZNauX ENTEZISIIES .......eevierieiriierierieerte et eee ettt ste e it s e esbee s
REIECtUre AVANCEE ........eeiiiieiiiiieieeiceeee ettt s

Chapitre 5
Reéalisation de mesures de bhalayage

Définition de sorties et de gammes de balayage .......ccccceceevvevieneneeniinieneneeneneeeneeen
Exécution de mesures balay€es ..........coevveririeriinieniiieieneeseeeceetee e
Exécution de balayages multidimensionnels..........c.cceoereevierienienieniinieneneeneneeneaeen

Chapitre 6
Extension des projets LabVIEW SignalExpress avec LabVIEW

Importation de VIs LabVIEW dans LabVIEW SignalExpress sous

FOTME A’ ELAPES ...veeveieeiiieiie ettt ettt ettt et e st e st esbaesabeenaee
Conversion de projets LabVIEW SignalExpress en diagrammes

LabVIEW ...ttt ettt ettt s

Chapitre 7
Et maintenant ?

Projets d’exemple LabVIEW SignalEXpress.......c.ccocceveeieiinieniiniiciinieeeeeneeneeeneen
Utilisation du matériel avec LabVIEW SignalEXpress ........ccccccoeeeeceinievicneenencncnennen.
RESSOUICES WED.....c.iiiiiiiiieiicec et st

Annexe A
Support technique et services

Initiation & LabVIEW SignalExpress vi

ni.com



A propos de ce manuel

Utilisez ce manuel pour vous familiariser avec les mesures interactives dans
LabVIEW SignalExpress et les fonctionnalités de base de LabVIEW
SignalExpress que vous utilisez pour acquérir et analyser des signaux.

Ce manuel contient des exercices qui vous aident a prendre en main
LabVIEW SignalExpress. Ces exercices vous apprennent comment
exécuter des projets, configurer des étapes, manipuler des signaux,
configurer des mesures de balayage, enregistrer des données et étendre les
possibilités de LabVIEW SignalExpress avec 1’environnement de
programmation graphique LabVIEW.

Conventions

Les conventions suivantes apparaissent dans ce manuel :

» Le symbole » vous guide a travers les éléments de menu imbriqués et les
options de boite de dialogue pour une action finale. Ainsi, la séquence
Fichier»Mise en page»Options indique qu’il vous faut dérouler le menu
Fichier, sélectionner 1’élément Mise en page et sélectionner Options dans
la derniere boite de dialogue.

@ Cette icOne représente une remarque qui vous donne des informations
importantes.
@ Cette icOne représente une astuce qui vous donne des recommandations.
=
gras Du texte en caracteres gras représente un élément que vous devez

sélectionner ou sur lequel vous devez cliquer dans le logiciel, comme les
éléments de menu ou les options de boite de dialogue. Du texte gras indique
également des noms d’entrées et de sorties, des noms de parametres, des
boites de dialogue, des sections de boite de dialogue et des noms de menus.

Le texte en italique Signale les variables, la mise en valeur, une référence croisée ou une
introduction a un concept-clé. Il indique également du texte que vous devez
remplacer par un mot ou une valeur.

monospace Du texte dans cette police indique du texte ou des caractéres qui doivent
&tre entrés avec le clavier. Cette police est également utilisée pour les noms
des disques durs, des chemins, des répertoires, des programmes, des
sous-programmes, des noms des périphériques, des fonctions, des
opérations, des variables et des noms de fichiers et d’extensions.

© National Instruments Corporation vii Initiation a LabVIEW SignalExpress



A propos de ce manuel

Documentation associée

Reportez-vous a I’Aide LabVIEW Signal Express, disponible en
sélectionnant Aide»Aide LabVIEW Signal Express, pour obtenir des
informations complémentaires.
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Initiation a LabVIEW
SignalExpress

National Instruments offre des solutions innovatrices aux scientifiques et
aux ingénieurs pour construire des systeémes de mesure automatisés basés
sur les plates-formes et les ordinateurs conformes aux normes de
I’industrie. National Instruments développe des environnements de
programmation robustes, a la pointe de la technologie, comme LabVIEW
pour le développement graphique, LabWindows™/CVI™ pour la
programmation en C ANSI et Measurement Studio pour la programmation
avec Microsoft Visual Studio. Vous pouvez utiliser ces outils de
programmation avec le matériel de mesure de National Instruments et des
interfaces pour instruments traditionnels afin de construire des systemes
d’instrumentation virtuelle avancés.

LabVIEW SignalExpress optimise 1’instrumentation virtuelle pour les
ingénieurs concepteurs en offrant des mesures interactives instantanées qui
ne requierent aucune programmation. Vous pouvez utiliser LabVIEW
SignalExpress de maniere interactive pour acquérir, générer, analyser,
comparer, importer et enregistrer des signaux. Vous pouvez comparer des
données de conception avec des données de mesure en une étape.
LabVIEW SignalExpress apporte la simplicité d’utilisation et les
performances de I’instrumentation virtuelle aux personnes qui doivent
acquérir ou analyser des signaux sans programmer des applications. Vous
pouvez aussi étendre les fonctionnalités de LabVIEW SignalExpress en
important un VI (instrument virtuel) personnalisé créé dans
I’environnement de développement graphique LabVIEW ou en
convertissant un projet LabVIEW SignalExpress en un diagramme
LabVIEW ce qui vous permet de poursuivre le développement dans
I’environnement LabVIEW. Reportez-vous au chapitre 6, Extension des
projets LabVIEW SignalExpress avec LabVIEW, pour obtenir des
informations complémentaires sur les fonctionnalités avancées de
LabVIEW SignalExpress.

Ce chapitre offre des informations sur la configuration systéme requise, les

instructions d’installation, les versions et les options de licences
disponibles pour LabVIEW SignalExpress.
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Chapitre 1 Initiation a LabVIEW SignalExpress

Installation de LabVIEW SignalExpress

Avant de commencer les exercices de ce manuel, vous devez installer
LabVIEW SignalExpress. Le programme d’installation de LabVIEW
SignalExpress installe le logiciel en 10 minutes environ.

Configuration systeme minimale requise

National Instruments recommande la configuration suivante afin
d’optimiser les performances d’exécution de LabVIEW SignalExpress :

e 512 Mo de mémoire

*  Un processeur Pentium 4 ou équivalent (Pentium IIT ou Celeron
600 MHz minimum)

Installation

Effectuez les étapes suivantes pour installer LabVIEW SignalExpress sous
Windows 2000/XP/Vista.

@ Remarque Si vous installez LabVIEW SignalExpress a partir du DVD de la plate-forme
LabVIEW 8.6, vous n’avez pas besoin d’effectuer de réinstallation en utilisant le média
comme cela est décrit dans cette section. Reportez-vous aux Notes d’information
LabVIEW pour consulter des instructions sur I’installation au moyen du DVD.

1. Quittez tous les programmes avant d’exécuter 1’installeur de
LabVIEW SignalExpress. Il se peut que des applications qui
s’exécutent en arriere-plan, comme des utilitaires de détection de
virus, ralentissent le processus d’installation.

2. Ouvrez une session en tant qu’administrateur ou en tant qu’utilisateur
jouissant de privileges d’administrateur.

3. Insérez le média d’installation de LabVIEW SignalExpress et suivez
les instructions qui s’affichent a I’écran.

@ Remarque Le programme d’installation de LabVIEW SignalExpress copie les fichiers
dans le répertoire <Program Files>\National Instruments\SignalExpress a
moins que vous ne spécifiiez un autre emplacement.

4. Une fois I'installation terminée, vérifiez que le disque dur ne contient

pas de virus et activez les programmes de détection de virus que vous
aviez éventuellement désactivés.
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Chapitre 1 Initiation a LabVIEW SignalExpress

Les projets d’exemple que vous utilisez avec ce manuel sont situés dans le
répertoire <Program Files>\National Instruments\
SignalExpress\Examples\Tutorial. Les solutions des exercices se
trouvent dans le répertoire <Program Files>\National
Instruments\SignalExpress\Examples\Tutorial\Solutions.

Versions de LabVIEW SignalExpress disponibles

LabVIEW SignalExpress est disponible dans les versions compleéte et
limitée (LE). Reportez-vous au tableau suivant pour consulter une liste des
fonctionnalités disponibles dans chaque version.

Tableau 1-1. Différences entre les versions compléte et LE de LabVIEW SignalExpress

Complete LE

Support d’instruments

Plus de 300 instruments autonomes communs v —

Visualisation et documentation

Tracage personnalisable

Curseurs interactifs

Enregistrer des signaux dans un fichier

Imprimer et exporter des graphes

WordPad

Glisser - Déposer de données dans Microsoft Excel, Word et

SIS NSNS
SIS NSNS

Mode opérateur avec édition par 1’utilisateur limitée

<
|

Traitement du signal

Filtres logiciels

Mathématiques sur scalaires et waveforms

Conversion analogique et numérique

Comparaison interactive de signaux

Chargement de données de simulation a partir de PSPICE,
Multisim et d’autres logiciels SPICE

AN RN RN NN
|
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Tableau 1-1. Différences entre les versions compléte et LE de LabVIEW SignalExpress (suite)

Complete

LE

Mesures de temps et fréquence

Amplitude et niveaux

Cadencement et transition

Spectre de puissance

Réponse en fréquence

Mesures de distorsion

Extraction de ton

NSNS TSNTNS

Fichier journal

Enregistrement limité des données (un journal par projet)

Enregistrement illimité des données

Alarmes et événements d’enregistrement

Enregistrement avec conditions de démarrage et d’arrét

SIS S

Automatisation des mesures

Balayage de parametres

Test de limite

Déclenchement logiciel

Mise en séquence

SIS S

Acces distant a des données

Lecture/Ecriture de variables partagées
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Chapitre 1 Initiation a LabVIEW SignalExpress

Options relatives aux licences de LabVIEW
SignalExpress

Cette section a pour but d’expliquer les polices relatives aux licences de
LabVIEW SignalExpress. Ce document ne remplace pas le Contrat de
licence logiciel National Instruments. Utilisez ce document seulement
comme référence.

LabVIEW SignalExpress LE

La version limitée (LE), sans licence de LabVIEW SignalExpress vous
donne acces a toutes les fonctionnalités qui figurent dans le tableau 1-1
pendant 30 jours. Passée cette période, LabVIEW SignalExpress s’exécute
en mode sans licence. Si vous n’activez pas une licence valide dans la
période de 30 jours et que vous créez un projet qui contient des étapes sous
licence, voici ce qui se passe :

*  Chaque fois que vous ajoutez une étape sous licence, une boite de
dialogue vous demande d’activer le logiciel.

*  Vous ne pouvez pas enregistrer des projets.

»  Les projets se ferment apres 10 minutes.

Reportez-vous au site Web de National Instruments & ni . com/
signalexpress pour acheter la version complete de LabVIEW
SignalExpress.

Version compléte de LabVIEW SignalExpress

La version complete de LabVIEW SignalExpress vous offre toutes les
fonctionnalités qui figurent dans le tableau 1-1. Vous pouvez activer la
version complete de LabVIEW SignalExpress en utilisant le Gestionnaire
de licences National Instruments, I’installeur de LabVIEW SignalExpress
ou le site Web de National Instruments en vous rendant sur ni . com/
activate.
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Travailler avec des projets

Vous pouvez utiliser LabVIEW SignalExpress pour définir des procédures
de mesure en ajoutant et en configurant des étapes dans un environnement
de mesure interactif. Une étape est une fonction configurable qui acquiert,
génere, analyse, charge ou enregistre des signaux. Le menu Ajouter une
étape ct la palette A jouter une étape affichent les étapes disponibles dans
LabVIEW SignalExpress.

La plupart des étapes traitent des signaux en entrée et produisent des
signaux en sortie. Vous pouvez configurer le fonctionnement d’une étape
en spécifiant des valeurs dans 1’onglet Configuration de 1’étape propre a
I’étape. Une séquence enregistrée d’étapes configurées constitue un projet
LabVIEW SignalExpress.

Ce chapitre vous apprend a charger et a exécuter des projets existants et a
configurer des étapes dans ces projets.

Ouverture d’un projet

Effectuez les étapes suivantes pour charger un projet d’exemple dans
LabVIEW SignalExpress.

1. Lancez LabVIEW SignalExpress.

Notez que LabVIEW SignalExpress est divisé en affichages qui
présentent différents types d’informations. L’ affichage principal
apparait au milieu de la fenétre d’application et contient des onglets.
Si LabVIEW SignalExpress s’ouvre avec la configuration par défaut,
les onglets Affichage des données, Options d’enregistrement et
Documentation du projet apparaissent dans I’affichage principal.

L’ affichage principal est entouré d’affichages supplémentaires. Dans
la configuration par défaut, 1a Vue du projet apparait a gauche et ’aide
contextuelle a droite.

Remarque Si LabVIEW SignalExpress détecte un périphérique matériel supporté,
I’ Affichage des voies apparait en bas de la fenétre d’application de LabVIEW
SignalExpress.
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Travailler avec des projets

Si LabVIEW SignalExpress ne s’ouvre pas dans la configuration par
défaut, sélectionnez Affichage»Réinitialiser la mise en page pour
réinitialiser la configuration par défaut de 1’application. Vous pouvez
utiliser le menu Affichage pour afficher des onglets et des affichages
ou réinitialiser la mise en page a tout moment.

Sélectionnez Aide»Ouvrir un exemple, naviguez vers le répertoire
SignalExpress\Examples\Tutorial et double-cliquez sur le
projet d’exemple First Project.seproj pour I’ouvrir.

Observez la fenétre qui apparait, montrée avec 1’aide contextuelle
fermée dans la figure 2-1, pour vous familiariser avec les différents
composants de LabVIEW SignalExpress.

1

©)

oject.sepin] - Lab¥IEW SignalExpress

& C:\Program Files\...\First Pry
Fichier Edtion Affichage

) Ajouter une étape £ Exécuter

ils Nnuterune¥ue Exécution  Affichage des données  Fenftre  Aide

~| @ Enregstrer 50

5 Proiet

Survellance/Enregistrement i Ao

v B x .mr hage des données

affichage g Proprités...

. Chalgel un fichier Al

[+ ® 5 Distorted Sinewave bt

I Amplitude et niveaux

¥ [ Distor. distorted sinewave
| 2 cc
b 0 velf

M B0 Distor. distorted sinemave
|» 5 signal temporel exporté

[» B specte sxpants

|» =0 fréquence ford.

|» =0 DHT (%)

SCl

-

-

jon (¥)

Inacti

53 Journaux

3l Instantanés

2,5m

1 Bouton Exécuter 5 Sortie 8 Affichage principal avec 'onglet
2 Menu déroulant Zone de travail 6 Vue du projet Affichage des données visible
3 Etape 7 Fenétre Données enregistrées 9 Bouton Enregistrer

4 Entrée
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Chapitre 2 Travailler avec des projets

L’environnement LabVIEW SignalExpress est composé d’affichages
qui présentent différents types d’informations. L’ affichage principal
apparait au milieu de la fenétre d’application et contient des onglets
comme I’onglet Affichage des données. Des affichages
supplémentaires entourent 1’affichage principal et apparaissent avec
des barres de titres individuelles. Par exemple, la Vue du projet est un
affichage supplémentaire.

Exécution d’un projet et affichage de signaux

LabVIEW SignalExpress a plusieurs modes d’exécution. Vous pouvez
exécuter des projets une fois, en continu ou pendant un nombre d’itérations
ou une durée que vous spécifiez. Quand vous exécutez un projet une fois,
LabVIEW SignalExpress exécute toutes les étapes du projet une fois.
Quand vous exécutez un projet en continu, LabVIEW SignalExpress
exécute toutes les étapes du projet en continu. Cliquez sur la fleche vers le
4£% Exécuter - bas du bouton Exécuter, montré a gauche, et sélectionnez Configurer
I’exécution a partir du menu déroulant pour configurer le mode
d’exécution d’un projet.

Les affichages de I’onglet Affichage des données se mettent a jour

continuellement pendant qu’un projet s’exécute. Quand un projet

s’exécute, vous pouvez changer les parametres de configuration de la

mesure en changeant les parametres sur I’onglet Configuration de I’étape

et voir les résultats immédiatement. Les projets qui s’exécutent en continu

Arréter - s’exécutent jusqu’a ce que le bouton Arréter, montré a gauche, soit
actionné. Le bouton Arréter apparait a la place du bouton Exécuter
lorsqu’un projet s’exécute.

Effectuez les étapes suivantes pour exécuter le projet d’exemple et afficher
des signaux.

1. Cliquez sur le bouton Exécuter. Si la boite de dialogue Informations
sur ’exécution apparait, cliquez sur le bouton Exécuter dans cette
boite de dialogue pour exécuter toutes les étapes du projet en continu.

Le projet charge un signal a partir d’un fichier texte et effectue deux
opérations sur le signal : une mesure de I’amplitude et des niveaux et
une mesure de distorsion. L’étape Amplitude et niveaux et I’étape
Distorsion effectuent ces mesures, respectivement. Lorsque vous
exécutez un projet, les étapes analysent des signaux en entrée et
génerent de nouveaux signaux en sortie comme résultat de I’analyse.
Dans ce projet, 1’étape Charger un fichier ASCII charge un signal
sinusoidal déformé, I’étape Amplitude et niveaux et 1’étape Distorsion
analysent le signal sinusoidal et les deux étapes renvoient de nouvelles
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sorties. Dans la Vue du projet, LabVIEW SignalExpress indique les
entrées avec des fleches rouges et les sorties avec des fleches bleues.

L’affichage graphe dans 1’onglet Affichage des données contient
toujours le signal chargé, qui est un signal du domaine temporel. Les
graphes affichent des signaux XY, du domaine fréquentiel ou du
domaine temporel.

Faites glisser le signal en sortie spectre exporté de 1’étape Distorsion
de la Vue du projet vers I’ Affichage des données pour afficher le
signal.

LabVIEW SignalExpress crée un nouvel affichage graphe dans

I’ Affichage des données. LabVIEW SignalExpress n’affiche pas le
signal spectre exporté sur le méme graphe que le signal du domaine
temporel car le signal spectre exporté est un signal du domaine
fréquentiel. LabVIEW SignalExpress reconnait automatiquement les
différents types de signaux et les affiche en fonction de leur type.

Astuce Reportez-vous a I’Aide LabVIEW SignalExpress pour obtenir des informations
complémentaires sur des types de signaux en sélectionnant Aide»Aide LabVIEW
SignalExpress, en cliquant sur I’onglet Rechercher et en entrant " types de signaux".
L’aide offre des informations sur I'utilisation des fonctionnalités de LabVIEW
SignalExpress telles que les projets, les étapes et les signaux.

Faites glisser la sortie cc de I’étape Amplitude et niveaux vers I’onglet
Affichage des données.

LabVIEW SignalExpress crée a la fois un graphe et une table Légende
pour afficher la mesure scalaire de la sortie cc. La table Légende
affiche la valeur de chaque sortie et la couleur que LabVIEW
SignalExpress utilise pour tracer la sortie sur le graphe attenant.

Faites glisser la sortie Veff de 1’étape Amplitude et niveaux vers la
table Légende pour afficher la mesure scalaire efficace.

LabVIEW SignalExpress crée une nouvelle ligne dans la table pour
afficher la deuxieme mesure. Le projet apparait tel que le montre la
figure 2-2.
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&7 C:\Program Files\...\First Project.seproj * - Lab¥IEW SignalExpress E]@
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Figure 2-2. Sorties de First Project.seproj

Configuration d’une étape

Une étape est une fonction configurable qui acquiert, génere, analyse,
charge ou enregistre des signaux. Les étapes traitent des signaux en entrée
et produisent des signaux en sortie. Vous pouvez configurer le
fonctionnement d’une étape dans LabVIEW SignalExpress en spécifiant
des valeurs dans 1’onglet Configuration de I’étape de 1’étape. Pendant
qu’un projet s’exécute, vous pouvez modifier la configuration des étapes et
afficher immédiatement le retour d’informations sur I’onglet Affichage
des données. Ainsi, vous pouvez ajuster les mesures jusqu’a ce que vous
obteniez les résultats escomptés.
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Travailler avec des projets

Effectuez les étapes suivantes pour configurer I’étape Distorsion et 1’étape
Amplitude et niveaux.

1. Double-cliquez sur I’étape Distorsion dans la Vue du projet. LabVIEW
SignalExpress affiche ’onglet Configuration de I’étape pour 1’étape
Distorsion, comme le montre la figure 2-3.

Signal exporté

=
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Entrée/Sortie | Configuration | Avancé

Configuration des mesures Résultats de la mesure
Types de distorsion Harm. supérieure Fréguence fond, DHT (%)
Harmoniques uniquement | s 19 e 3,0020013k 0,3616
Signaux 4 exporter (DHT) SIMAD (dE) DHT + Bruit (%)
Signal en entrée E3 i} i}

Figure 2-3. Onglet Configuration de I'étape Distorsion

Sur la page Configuration de 1’onglet Configuration de I’étape, le
champ Signaux a exporter (DHT) indique que I’étape Distorsion
exporte le signal en entrée, et le graphe Signal exporté affiche un
apercu du signal. Le graphe Spectre de puissance exporté indique
que I’étape applique un spectre de puissance sur le signal en entrée
pour le convertir en signal du domaine fréquentiel, et le champ
Résultats de la mesure affiche la fréquence fondamentale et la
distorsion harmonique totale (DHT) du signal. L’ étape génere le signal
exporté et trois mesures sous forme de sorties : le spectre, la DHT et la
fréquence fondamentale de I’entrée du signal du domaine temporel
d’origine.
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Chapitre 2 Travailler avec des projets

Si I’aide contextuelle n’apparait pas a droite de 1’écran, sélectionnez
Aide»Aide contextuelle pour afficher des informations de référence
completes sur I’étape.

La partie supérieure de I’aide contextuelle affiche des informations sur
I’étape, et la partie inférieure de 1’aide contextuelle affiche des
informations sur des parametres spécifiques lorsque le curseur passe
dessus. Déplacez le curseur sur le parametre DHT (%) pour afficher
des informations sur le parametre.

Sur la page Configuration, sélectionnez Ton fondamental dans le
menu déroulant Signaux a exporter (DHT).

Le graphe Spectre de puissance exporté passe de 1’affichage du
spectre du domaine fréquentiel du signal en entrée complet a
I’affichage du spectre de fréquence du ton fondamental du signal en
entrée uniquement. Le signal en sortie de 1’étape Distorsion et
I’affichage graphe de la sortie spectre exporté sur I’onglet Affichage
des données des données se mettent a jour pour refléter la
modification que vous avez apportée.

Sélectionnez Harmoniques uniquement dans le menu déroulant
Signaux a exporter (DHT).

Le graphe Spectre de puissance exporté de 1’onglet Configuration
de I’étape et le graphe de la sortie sur I’onglet Affichage des données
changent tous les deux pour afficher uniquement le spectre des signaux
harmoniques du signal en entrée.

Cliquez sur I’étape Amplitude et niveaux dans la Vue du projet.

L’onglet Configuration de I’étape qui affichait la configuration de
I’étape Distorsion, affiche désormais la configuration de 1’étape
Amplitude et niveaux.
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6. Sélectionnez la page Entrée/Sortie pour afficher la liste des entrées et
des sorties possibles pour cette étape, comme le montre la figure 2-4.

Signal en entrée

1,5-
=
500m -
o
=)
=
|8 0
=
<L
-500m -
-1-
-1,5- 1 1
o im 2m
EntréefSortis | Configuration

Signal en entrée

EXZ Di...distarted sinewave ¥

3m 4m Sm
Echelle automatique de I'amplitude

Exporter la valeur CC
Exporter la valeur efficace
[] Exporter la valeur max,

[] Exporter la waleur min,

[] Exporter la valeur de pic 4 pic

Figure 2-4. Onglet Configuration de I'’étape Amplitude et niveaux

7. Cochez les cases Exporter la valeur max., Exporter la valeur min.
et Exporter la valeur de pic a pic pour configurer I’étape Amplitude
et niveaux pour renvoyer trois mesures supplémentaires.

Trois sorties supplémentaires apparaissent dans la Vue du projet.

Passez a I’onglet Affichage des données.

9. Faites glisser les trois nouvelles sorties de la Vue du projet vers la table
Légende de mesures scalaires. Les nouvelles sorties apparaissent sur
le graphe attenant.

Remarque Si le projet s’exécute depuis quelques minutes, il se peut que vous deviez

Iarréter et le redémarrer pour voir tous les signaux scalaires sur le graphe. LabVIEW
SignalExpress accumule des points de données pour des signaux que vous ajoutez a un
graphe et de nouveaux signaux que vous ajoutez n’ont pas autant de points de données a
afficher sur le graphe.

Initiation & LabVIEW SignalExpress
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Chapitre 2 Travailler avec des projets

10. Cliquez sur le bouton Arréter pour arréter le projet.

Lorsque vous cliquez sur le bouton Arréter, le projet arréte de
s’exécuter apres avoir terminé le cycle de fonctionnement actuel ou
I’itération actuelle. Cliquez sur la fleche vers le bas a droite du bouton
Arréter et sélectionnez Abandonner dans le menu déroulant pour
arréter completement le projet sans terminer 1’itération en cours.

11. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le
projet sous Mon premier projet.seproj dans le répertoire
SignalExpress\Examples\Tutorial.

12. Sélectionnez Fichier»Fermer le projet pour fermer le projet.

Organisation, deplacement et suppression d’étapes

La plupart des étapes dans des projets LabVIEW SignalExpress requierent
des données en entrée. Certaines étapes ne peuvent fonctionner que si elles
recoivent des signaux d’étapes les précédant dans la Vue du projet. L’ ordre
dans lequel les étapes apparaissent dans la Vue du projet peut donc affecter
le fonctionnement d’un projet.

Pour les étapes qui ont une page Entrée ou Entrée/Sortie sur I’onglet
Configuration de I’étape, le menu déroulant Signal en entrée de cette
page n’affiche que des signaux compatibles exportés par une étape
précédente. Lorsque la sortie d’une étape devient I’entrée d’une autre étape,
les deux étapes deviennent dépendantes 1’'une de 1’autre et s’exécutent de
maniere séquentielle, a la méme fréquence. La premiere étape génere un
signal en sortie que la deuxieme étape doit recevoir comme entrée avant de
pouvoir s’exécuter.

Vous pouvez déplacer une étape dans un projet en la faisant glisser vers le
haut ou vers le bas dans la Vue du projet. Vous pouvez supprimer une étape
en faisant un clic droit dessus dans la Vue du projet et en sélectionnant
Supprimer dans le menu local. Lorsque vous déplacez ou supprimez une
étape, 1’état des signaux du projet change. Par exemple, si vous supprimez
une étape qui génere des signaux en sortie, le fonctionnement du projet est
brisé si I’un des signaux en sortie supprimés est I’entrée d’une autre étape
et un indicateur d’erreur apparait dans la Vue du projet. Vous pouvez aussi
couper, copier et coller des étapes dans un projet en appuyant
respectivement sur les touches <Ctrl-X>, <Ctrl-C> et <Ctrl-V>, ou en
cliquant avec le bouton droit sur la Vue du projet et en sélectionnant
Couper, Copier, Coller avant I’étape sélectionnée ou Coller apres
I’étape sélectionnée dans le menu local.
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Gestion des erreurs et des mises en garde

d’erreur, montré a gauche, apparait dans la Vue du projet sur I’étape dans
laquelle I’erreur s’est produite. Double-cliquez sur I’étape ou I’erreur s’est
produite pour afficher sa description au bas de 1’onglet Configuration de
I’étape. Cliquez sur le bouton Détails a droite de la description de I’erreur
pour afficher la description complete.

|§| Si une erreur se produit pendant qu’un projet s’exécute, un indicateur

LabVIEW SignalExpress enregistre toutes les erreurs et les mises en garde
dans I’onglet Journal d’événements pendant I’exécution d’un projet. Pour
afficher I’onglet Journal d’événements, sélectionnez Affichage»Journal
d’événements. Reportez-vous a I’Aide LabVIEW SignalExpress pour
obtenir des informations complémentaires sur les erreurs et les mises en
garde en sélectionnant Aide»Aide LabVIEW SignalExpress, en cliquant
sur I’onglet Rechercher et en entrant erreurs.
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Vous pouvez utiliser LabVIEW SignalExpress pour générer et analyser des
signaux afin d’évaluer des projets de conception sans programmation. Ce
chapitre vous apprend a travailler avec des signaux dans LabVIEW
SignalExpress, en vous indiquant notamment comment tracer des signaux
sur des graphes, importer des signaux d’un fichier, aligner et comparer
deux signaux de maniere interactive et enregistrer des signaux dans un
fichier.

Représentation de signaux dans des graphes

Effectuez les étapes suivantes pour tracer des signaux dans un projet
d’exemple et examiner visuellement les signaux a I’aide de curseurs.

1.

h Ajouter un affichage

© National Instruments Corporation

Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire
SignalExpress\Examples\Tutorial et double-cliquez sur
Signals.seproj. Ce projet configure I’étape Créer un signal
analogique pour qu’elle permette de créer un signal carré et I’étape
Filtre pour réaliser un filtre Butterworth passe-bas.

Faites glisser la sortie step signal de I’étape Créer un signal analogique
vers 1’onglet Affichage des données.

Faites glisser la sortie filtered step de 1’étape Filtre vers I’onglet
Affichage des données.

Comme les signaux step signal et filtered step sont tous deux des
signaux temporels, ils apparaissent sur le méme affichage graphe. Si
vous essayez d’afficher des signaux de types différents en les faisant
glisser sur le méme affichage, LabVIEW SignalExpress crée un nouvel
affichage.

Cliquez sur le bouton Ajouter un affichage, montré a gauche, pour
créer un nouvel affichage.

Faites glisser la sortie filtered step de 1’étape Filtre vers le nouvel
affichage.
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6. Faites un clic droit sur le nouvel affichage et sélectionnez Eléments
visibles»Curseurs dans le menu local pour afficher deux curseurs
interactifs, comme le montre la figure 3-1.
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Figure 3-1. Signals.seproj

Quand vous déplacez les curseurs, LabVIEW SignalExpress affiche
les valeurs x et y des curseurs dans le tableau de curseurs au bas de
I’onglet Affichage des données.

7. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le
projet sous Mes signaux.seproj dans le répertoire
SignalExpress\Examples\Tutorial.
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Chapitre 3 Manipulation de signaux

Importation d’un signal a partir d’un fichier

Vous pouvez importer des signaux de formats de fichier standard comme
des fichiers ASCII délimités par des virgules ou des tabulations et des
fichiers de données de mesures LabVIEW (. 1vm). Vous pouvez aussi
importer des signaux a partir de résultats simulés d’outils EDA

(de conception électronique assistée par ordinateur) comme des
simulateurs SPICE.

Suivez les étapes ci-apres pour importer un signal a partir d’un fichier.

1.

Cliquez avec le bouton droit sur la Vue du projet et sélectionnez
Charger/Enregistrer des signaux»Signaux analogiques»Charger
un fichier ASCII dans le menu local pour ajouter 1’étape Charger un
fichier ASCII a la Vue du projet. L’onglet Configuration de I’étape
de I’étape Charger un fichier ASCII apparait. Cette étape analyse un
fichier ASCII et affiche les signaux dans le fichier.

@ Remarque Vous pouvez ajouter des étapes a un projet a partir du menu A jouter une étape,
de la palette Ajouter une étape ou a partir du menu local qui apparait quand vous cliquez
avec le bouton droit sur la Vue du projet.

2.

© National Instruments Corporation

SurI’onglet Configuration de I’étape, cliquez sur le bouton Parcourir,
montré a gauche puis naviguez vers le répertoire SignalExpress\
Examples\Tutorial et double-cliquez sur le fichier Step
Response. txt.

Dans la section Apercu du fichier, la colonne 1 affiche les
informations d’horodatage et la colonne 2 indique les valeurs de
tension réelles du signal.

Passez a la page Signaux a importer de I’onglet Configuration de
I’étape pour afficher les signaux disponibles dans le fichier.

Cochez I’option Colonne 2 pour importer ce signal et désélectionnez
I’option Colonne 1.

L’onglet Configuration de I’étape affiche un apercu du signal sur le
graphe Signal importé.

Sélectionnez Colonne 1 dans le menu déroulant Valeurs X en entrée
pour définir les données de 1’axe des x du signal aux valeurs
appropriées.

Passez a I’onglet Affichage des données.

Dans la Vue du projet, développez la sortie Step Response.txt de
I’étape Charger un fichier ASCII.
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8. Faites un clic droit sur la sortie Colonne 2 dans la Vue du projet et
sélectionnez Renommer dans le menu local.

9. Entrez réponse indicielle etappuyez sur la touche <Entrée> pour
renommer la sortie.

10. Faites glisser la nouvelle sortie réponse indicielle de 1’étape Charger
un fichier ASCII vers I’affichage inférieur sur 1’onglet Affichage des
données.

Le signal filtered step ressemble au front montant de la sortie réponse
indicielle, comme le montre la figure 3-2.
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Figure 3-2. Signaux de Signals.seproj

11. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.

Alignement et comparaison de signaux

Bien que le signal filtered step et la sortie réponse indicielle montrent tous
les deux un overshoot sur le front montant, il est difficile d’évaluer leur
similarité car ces signaux proviennent de sources différentes et ont une
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amplitude et un cadencement différents. Toutefois, vous pouvez utiliser
I’étape Alignement interactif pour aligner et comparer deux signaux, de
sorte que vous puissiez choisir quel type d’informations vous voulez
exporter de I’opération pour pouvoir les utiliser dans le projet.

Suivez les étapes ci-apres pour aligner deux signaux dans le projet Mes
signaux.seproj.

1. Développez la sortie Step Response.txt, cliquez avec le bouton droit
sur la sortie réponse indicielle et sélectionnez Envoyer vers»
Traitement»Signaux analogiques»Alignement interactif dans le
menu local pour transmettre le signal réponse indicielle de 1’étape
Charger un fichier ASCII a I’étape Alignement interactif.

L’étape sélectionne les deux signaux les plus récents dans le projet a
utiliser comme entrées et affiche les signaux sur les graphes de I’onglet
Configuration de I’étape, comme le montre la figure 3-3.
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1
= /
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Figure 3-3. Onglet de configuration de I’étape Alignement interactif

Lorsque vous ajoutez une étape a un projet, LabVIEW SignalExpress
sélectionne les signaux en entrée en fonction des types de signaux que
I’étape accepte. Par exemple, I’étape Alignement interactif ne peut €tre
utilisée que sur des signaux du domaine temporel. Par conséquent,
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I’étape sélectionne comme entrées les deux signaux du domaine
temporel créés dans le projet.

@ Remarque Pour changer les signaux en entrée d une étape, sélectionnez différents signaux
dans le menu déroulant des signaux compatibles sur la page Entrée ou Entrée/Sortie de
I’onglet Configuration de I’étape ou cliquez sur la fléche vers le bas qui apparait a c6té
du nom de I’entrée de 1’étape dans Vue du projet.

2.

Initiation & LabVIEW SignalExpress

Cliquez sur le signal rouge dans le graphe Signaux en entrée et
faites-le glisser vers un autre point du graphe. Le graphe Signal
résultant de la comparaison se met a jour pour afficher la nouvelle
différence calculée entre les signaux.

Vous pouvez faire glisser, étendre et réduire des signaux sur le graphe.

Essayez d’aligner les fronts montants de deux signaux en faisant
glisser un signal dans le graphe. Cliquez sur un signal pour définir un
point d’ancrage et maintenez la touche <Alt> enfoncée tout en faisant
glisser le signal pour 1’étendre autour de ce point d’ancrage dans le
sens des x et des y.

Sur la page Alignement de I’onglet Configuration de I’étape, I’ étape
calcule et affiche le gain des x et des y et les valeurs d’offset dont vous
avez besoin pour atteindre les spécifications d’alignement lorsque
vous faites glisser les signaux.

Sélectionnez Auto - Créneau dans le menu déroulant Mode pour
aligner les signaux. LabVIEW SignalExpress calcule 1’alignement en
utilisant des algorithmes intégrés.

Le graphe Signal résultant de la comparaison sur I’onglet
Configuration de I’étape affiche la différence entre les deux signaux.

Sur la page Entrée/Sortie, cochez 1’option Exporter les signaux
alignés pour ajouter les signaux aux sorties de 1’étape.

Passez a I’onglet Affichage des données.

Cliquez sur le bouton A jouter un affichage pour ajouter un troisiéme
affichage.

Faites glisser les sorties référence alignée et test aligné de I’étape
Alignement interactif dans le nouveau graphe pour afficher les signaux
alignés.

Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.
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Types de signaux dans LabVIEW SignalExpress

Certaines étapes, comme 1’étape Arithmétique, peuvent fonctionner avec
plusieurs types de signaux. Par exemple, vous pouvez utiliser 1’étape
Arithmétique pour manipuler des signaux des domaines fréquentiel et
temporel. L’étape Arithmétique adapte son comportement en fonction du
type de signaux en entrée que vous sélectionnez pour cette étape. Par
exemple, si vous ajoutez deux signaux du domaine temporel, LabVIEW
SignalExpress ajoute uniquement leur amplitude. Toutefois, si vous
ajoutez deux signaux de phase du domaine fréquentiel, LabVIEW
SignalExpress ajoute le seuil de décalage approprié.

Reportez-vous a I’Aide LabVIEW SignalExpress pour obtenir des
informations complémentaires sur des types de signaux en sélectionnant
Aide»Aide LabVIEW SignalExpress, en cliquant sur I’onglet
Rechercher et en entrant "types de signaux".

Exportation et impression de signaux

Vous pouvez utiliser LabVIEW SignalExpress pour documenter des
signaux ou continuer des analyses dans d’autres applications logicielles.
Cette section vous apprend comment exporter des signaux, notamment en
les envoyant dans un fichier ASCII, en envoyant les données dans
Microsoft Excel, en imprimant des signaux et en utilisant la fonctionnalité
de documentation intégrée pour documenter le projet LabVIEW
SignalExpress.

Enregistrement de signaux dans un fichier

Effectuez les étapes suivantes pour enregistrer un signal du projet Mes
signaux.seproj dans un fichier.

1. Cliquez sur le bouton Ajouter une étape, montré a gauche, pour
afficher la palette Ajouter une étape.

€ Ajouter une &tape

2. Sélectionnez Charger/Enregistrer des signaux»Signaux
analogiques»Enregistrer au format ASCII//LVM pour ajouter
I’étape Enregistrer au format ASCII//LVM a la Vue du projet. L’ onglet
Configuration de I’étape de 1’étape Enregistrer au format
ASCII//LVM apparait.

3. Cliquez sur la page Signaux de I’onglet Configuration de 1’étape et
sélectionnez filtered step dans le menu déroulant Données en entrée.
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10.

Sur la page Parametres du fichier, spécifiez ou enregistrer le fichier
texte que vous créez. Cliquez sur le bouton Parcourir a c6té du champ
Chemin du fichier a exporter, naviguez vers le répertoire
SignalExpress\Examples\Tutorial etentrez signal
filtré.txt comme nom de fichier.

Sélectionnez Remplacer dans le menu déroulant Si le fichier existe.

Sélectionnez ASCII générique (.txt) dans le menu déroulant Type du
fichier a exporter.

Vous pouvez utiliser I’étape Charger/Enregistrer les signaux pour
enregistrer des données dans un fichier chaque fois que le projet
s’exécute.

Cliquez sur la fleche vers le bas du bouton Exécuter et sélectionnez
Exécuter une fois pour exécuter le projet et enregistrer le signal
résultant dans le fichier ASCII spécifié.

Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.
Sélectionnez Fichier»Fermer le projet pour fermer le projet.

Naviguez vers le fichier signal filtré.txt et ouvrez-le dans un
éditeur de texte pour voir les valeurs du signal. Dans LabVIEW
SignalExpress, vous pouvez utiliser I’étape Charger un fichier ASCII
pour réimporter le signal dans un projet.

Exportation de signaux dans Microsoft Excel

Pour exporter des données de signaux dans Microsoft Excel, lancez Excel
et faites glisser le signal en sortie d’une étape de LabVIEW SignalExpress
dans un fichier tableur Excel. Vous pouvez aussi cliquer avec le bouton
droit sur un affichage de 1’onglet Affichage des données et sélectionner
Exporter vers»Microsoft Excel pour exporter toutes les données de
I’affichage.

Impression de signaux

Pour imprimer une image d’un graphe, ouvrez 1’onglet Affichage des
données et sélectionnez Fichier»Imprimer»Imprimer : Affichage des
données.

Initiation & LabVIEW SignalExpress
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Chapitre 3 Manipulation de signaux

Création de rapports dans LabVIEW SignalExpress

Sélectionnez Affichage»Documentation du projet pour afficher I’onglet
Documentation du projet. Vous pouvez utiliser cet onglet pour décrire un
projet en utilisant du texte et des images comme des graphes. Vous pouvez
faire glisser une sortie d’étape de la Vue du projet vers 1’onglet
Documentation du projet pour afficher un graphe du signal en sortie. Si
le projet est en cours d’exécution, le graphe sur I’onglet Documentation
du projet se met automatiquement a jour pour représenter la valeur
actuelle de la sortie de 1’étape.

Pour imprimer la documentation, affichez I’onglet Documentation du
projet et sélectionnez Fichier»Imprimer»Imprimer la documentation
ou cliquez sur le bouton Imprimer la documentation. Pour exporter la
documentation au format HTML, affichez 1’onglet Documentation du
projet et sélectionnez Fichier»Exporter»Exporter la documentation en
HTML.
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Enregistrement des donnees

Vous pouvez utiliser LabVIEW SignalExpress pour enregistrer dans un
fichier journal, enregistrer et analyser vos mesures. Vous pouvez
enregistrer n’importe quelle sortie d’étape du domaine temporel, double, de
type entier non signé 32 bits ou booléen. Vous pouvez aussi analyser et
traiter les données ainsi enregistrées en les relisant avec les étapes
d’analyse.

Ce chapitre vous apprend a enregistrer des données en utilisant les
fonctionnalités d’enregistrement de données intégrées a LabVIEW
SignalExpress. Vous apprendrez a enregistrer un signal spécifié, a relire ce
signal et a I’analyser en utilisant des étapes d’analyse. Vous allez également
apprendre a utiliser I’onglet Options d’enregistrement pour enregistrer
des signaux en fonction de conditions de démarrage et d’arrét spécifiées.

Enregistrement d’un signal

0 Enregistrer

Vous pouvez utiliser le bouton Enregistrer pour configurer un processus
d’enregistrement de données.

Effectuez les étapes suivantes pour spécifier le signal & enregistrer et
I’enregistrer.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire
SignalExpress\Examples\Tutorial et double-cliquez sur
Logging.seproj.

Ce projet utilise I’étape Créer un signal analogique pour générer un
signal sur la base d’une formule.

Cliquez sur le bouton Enregistrer, illustré a gauche, pour ouvrir la
boite de dialogue Sélection des signaux a enregistrer.

La boite de dialogue Sélection des signaux a enregistrer affiche les
signaux dans le projet disponible pour I’enregistrement. Vous pouvez
sélectionner un ou plusieurs signaux a enregistrer. Vous pouvez aussi
spécifier un nom et une description pour I’enregistrement.

3. Cochez la case signal pour enregistrer le signal de la formule généré
par I’étape Créer un signal analogique.
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Chapitre 4 Enregistrement des données

4. Cliquez sur le bouton OK pour fermer la boite de dialogue Sélection

Arréter -

Initiation & LabVIEW SignalExpress

des signaux a enregistrer et commencer I’enregistrement du signal.
L’enregistrement se poursuit jusqu’a ce que vous cliquiez sur le bouton
Arréter.

Cliquez sur le bouton Arréter, montré a gauche, pour arréter le projet.
Si c’est la premiere fois que vous enregistrez un signal, la boite de
dialogue Premier journal terminé apparait. Cliquez sur le bouton OK
pour fermer la boite de dialogue.

Les données enregistrées apparaissent dans la fenétre Données
enregistrées au bas de la Vue du projet, comme le montre la figure 4-1.

= ﬁ: Journausx
+-g 118/ 04,/2008 : 11:56:22
ﬁ Instantanés

Figure 4-1. Fenétre Données enregistrées

Par défaut, LabVIEW SignalExpress nomme les données enregistrées
d’apres la date et ’heure de leur enregistrement. LabVIEW
SignalExpress enregistre des données au format de fichier . tdms dans
le répertoire que vous spécifiez dans la boite de dialogue Options.

Sélectionnez Outils»Options puis sélectionnez 1’option
Enregistrement pour spécifier le répertoire dans lequel LabVIEW
SignalExpress enregistre les données et pour personnaliser différentes
préférences pour les données enregistrées.

Cliquez sur le bouton OK pour fermer la boite de dialogue Options.

Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le
projet sous Mon enregistrement.seproj dans le répertoire
SignalExpress\Examples\Tutorial.
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Chapitre 4 Enregistrement des données

Affichage d’un signal enregistré dans un journal

Effectuez les étapes suivantes pour afficher les données enregistrées dans
un fichier journal.

1.

Si I’onglet Affichage des données n’est pas visible, sélectionnez
Affichage»Affichage des données pour afficher 1’onglet Affichage
des données.

La fenétre Données enregistrées présente la liste de toutes les données
enregistrées dans le projet actuel. Sélectionnez le journal de données
que vous venez d’enregistrer dans la fenétre Données enregistrées et
faites-le glisser dans 1’onglet Affichage des données. L onglet
Affichage des données affiche les données enregistrées et un graphe
d’apercu, comme le montre la figure 4-2. Il se peut que le signal qui
apparait sur 1’onglet Affichage des données différe du signal montré
sur la figure 4-2 en fonction de la durée de votre enregistrement.

- C:WProgram Files\...\Mon enregistrement.seproj - Lab¥IEW SignalExpress E]@

Fichier Edtion Affichage Outls Ajouter une étape Exécution  Affichage des données  Fendre Aide

Q) Ajouter une étape £ Exécuter +| @ Enregistrer 59

{1 Projet

> X (&) Affichage des données |} options denregistrement || '] Documertation du projet X

] |t Ajouter un affichage g Fropristés...

@U | Surveillance/Erregistrament

¥[8 signal

Créer un signal analogique

Tension ()

NV

Inactif

=63 Journau
= < 18/04/2008 : 11:56:22
signal
{2 Instantanés

“"-"\”'J"/’ F\("'.“.
| ‘[ \} i \

o v I
Le 15 L b ¥ 4 -

B Temps ()

1 Données enregistrées

2 Graphe d’apergu
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Figure 4-2. Logging.seproj
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Le graphe d’apercu offre la possibilité de zoomer sur les données et de
les faire défiler horizontalement dans I’onglet Affichage des données.
Le graphe d’apergu apparait par défaut lorsque vous affichez des
données enregistrées. Lorsque vous affichez des données en direct ou
non enregistrées, cliquez avec le bouton droit sur un affichage de
I’onglet Affichage des données et sélectionnez Eléments visibles»
Apercu dans le menu local pour afficher le graphe d’apercu.

Cliquez sur le bouton Zoom avant a c6té du graphe d’apergu pour
effectuer un zoom avant sur le signal enregistré. Les curseurs sur le
graphe d’aper¢u montrent le sous-ensemble de données actuellement
affiché sur I’onglet Affichage des données. Utilisez la barre de
défilement en dessous du graphe d’apercu pour faire défiler les
données. Cliquez sur le curseur et faites-le glisser sur le graphe
d’aperc¢u pour agrandir ou réduire le sous-ensemble des données
affichées.

Enregistrement de signaux avec des conditions de
demarrage et d’arrét prédéfinies

Vous pouvez configurer des conditions de démarrage et d’arrét que les
signaux doivent respecter avant que LabVIEW SignalExpress les
enregistre ou arréte de les enregistrer. Effectuez les étapes suivantes pour
enregistrer les données en fonction de conditions de démarrage et d’arrét.

1.

Initiation & LabVIEW SignalExpress

Si ’onglet Options d’enregistrement n’est pas visible, sélectionnez
Affichage»Options d’enregistrement pour ouvrir I’onglet Options
d’enregistrement.

Sélectionnez Sélection des signaux dans la liste de Catégorie de
I’onglet Options d’enregistrement.
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Chapitre 4 Enregistrement des données

3. Cochez la case du signal dans la colonne Enregistrer, comme le
montre la figure 4-3.
Catégarie Sélection des signaus
Sélection des signaux -
Résumé du journal Mom de |a woie Enregistrer
Conditions de démarrage fﬁ? signal

Conditions o' arrét
Alarmes
Evénements

Etat de l'enregistrement:

Enregistrement _
Infos sur le disque [l
{utilise : & Go - libre : 22 Go)
Taille estimée du journal :

Temps d'enreg. restant :

Journal en cours démarré & ¢

‘fas Enregistrer pendant l'exécution

© National Instruments Corporation

Figure 4-3. Sélection des signaux

Le bouton Enregistrer devient le bouton Enregistrer pendant
I’exécution, montré a gauche. Assurez-vous que le bouton
Enregistrer pendant I’exécution est enclenché. Quand le bouton
Enregistrer pendant I’exécution est enclenché, LabVIEW
SignalExpress enregistre le signal sélectionné quand vous cliquez sur
le bouton Exécuter.

Sélectionnez Conditions de démarrage dans la liste Catégorie de
I’onglet Options d’enregistrement.

Cliquez sur le bouton Ajouter situé sous la Liste des conditions de
démarrage pour personnaliser une condition de démarrage pour une
tache d’enregistrement.

a. Dans le menu déroulant Type de condition, assurez-vous que
Déclenchement du signal est sélectionné pour spécifier que
LabVIEW SignalExpress commence 1’enregistrement quand le
signal en entrée remplit la condition spécifiée.

b. Dans le menu déroulant Signal, assurez-vous que signal est
sélectionné.
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£3 Exécuter -
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c. Dans le menu déroulant Type de déclenchement, vérifiez que
I’option Pente montante est sélectionnée pour spécifier le début
de I’enregistrement du signal en fonction de la valeur du front du
signal sur la pente positive.

d. Entrez 1 dans le champ Valeur de déclenchement pour
commencer I’enregistrement quand le signal passe 1 sur une pente
montante.

Sélectionnez Conditions d’arrét dans la liste Catégorie de 1’onglet
Options d’enregistrement.

Cliquez sur le bouton A jouter situé sous la Liste des conditions
d’arrét pour personnaliser la condition d’arrét d’une tache
d’enregistrement.

a. Dans le menu déroulant Type de condition, vérifiez que 1’option
Durée est sélectionnée pour spécifier que LabVIEW
SignalExpress arréte I’enregistrement apres un laps de temps
défini.

b. Dans la commande Durée, assurez-vous que 5 apparait pour
indiquer d’enregistrer le signal pendant 5 secondes a partir du
moment ou le signal remplit la condition de démarrage.

Cliquez sur le bouton Exécuter, montré a gauche. LabVIEW
SignalExpress commence a enregistrer le signal quand celui-ci atteint
le niveau 1 sur une pente montante et continue a I’enregistrer pendant
5 secondes.

Les indicateurs suivants dans la section Etat de ’enregistrement de
I’onglet Options d’enregistrement se met a jour pendant que le projet
s’exécute.

*  Enregistrement affiche activé quand le signal remplit la
condition de démarrage et que I’enregistrement est en cours.

* Infos sur le disque affiche 1’espace disque disponible sur
I’ ordinateur pour le journal.

e Taille estimée du journal affiche la taille du fichier journal sur le
disque.

¢ Temps d’enreg. restant affiche pendant combien de temps vous
pouvez continuer 1’enregistrement du journal avant d’étre a cours
d’espace sur le disque.

¢ Journal en cours démarré a affiche le temps de départ du journal
actuel.
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Les pages Conditions de démarrage, Conditions d’arrét, Alarmes
et Evénements de I’onglet Options d’enregistrement comprennent
aussi des indicateurs qui affichent I’état des conditions de démarrage,
des conditions d’arrét, des alarmes et des événements que vous
configurez.

Analyse des signaux enregistrés

Une fois que vous avez enregistré un signal, vous pouvez repasser les
données enregistrées ou exécuter le signal enregistré via les étapes
d’analyse, comme vous pouvez le faire avec les données en direct.
Effectuez les étapes suivantes pour analyser un signal enregistré.

1.

0 Ajouter une ékape

© National Instruments Corporation

Repérez le menu déroulant Zone de travail au-dessus de la Vue du
projet, comme le montre la figure 4-4. Cliquez sur la fleche vers le bas
et sélectionnez Relecture pour passer a la zone de travail de Relecture.

@H surveilance/Enregistrernent V|

Figure 4-4. Menu déroulant Zone de travail

Utilisez des zones de travail pour effectuer plusieurs étapes LabVIEW
SignalExpress a partir du méme projet. Vous pouvez acquérir des
données, traiter des signaux, enregistrer les données dans un fichier
journal et effectuer des mesures sur les données enregistrées sans
devoir ouvrir un nouveau projet. Lorsque vous enregistrez un projet,
LabVIEW SignalExpress enregistre toutes les zones de travail qui s’y
trouvent dans le méme fichier de projet.

La zone de travail par défaut, Surveillance/Enregistrement, vous
permet de prendre des mesures, d’analyser des données en direct et
d’enregistrer des données. La zone de travail Relecture vous permet
d’utiliser des données enregistrées dans la zone de travail
Surveillance/Enregistrement comme entrée d’une étape d’analyse.

Cliquez sur le bouton Ajouter une étape, montré a gauche, et
sélectionnez I’étape Filtre en sélectionnant Traitement»Signaux
analogiques»Filtre. LabVIEW SignalExpress sélectionne
automatiquement le premier signal que vous avez enregistré comme
entrée de I’étape Filtre.

Passez a I’onglet Affichage des données, faites glisser la sortie
filtered data de I’étape Filtre vers I’ Affichage des données pour
afficher le signal résultant.
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Enregistrement des données

4. Cliquez sur le bouton Exécuter. L’onglet Affichage des données
affiche le signal filtré résultant et LabVIEW SignalExpress relit tout le
journal.

Relecture avancée

Vous pouvez utiliser I’onglet Options de relecture pour configurer des
options de relecture des données avancées. L’onglet Options de relecture
affiche un apercu des données enregistrées et vous permet de sélectionner
un sous-ensemble de ces données a relire ou a exécuter via des étapes
d’analyse.

1. Sélectionnez Affichage»Options de relecture pour afficher I’onglet
Options de relecture, comme le montre la figure 4-5.

Signal enreqistré
El g Eg o~ Temps de débutifin de la relecture

= LI ] e

signal 2

signal

Amplitude

Temps de début (s) Temps de fin (5) Faormat de temps
10,0000 | Z,8600 . Relatif au temps de départ du journal A

Zonfiguration du bloc de relecture

Mombre d'échantillons Nombre dibérations Apercu de relecture
1000 £ 286
Chevauchement {%) Fréguence d'échantillonnage
o A 100,000k

Wlitération 1 [llicération Z [llitération 3

[#]lanarer la dernigre itération
si elle est partielle

[CLire seulement des intervalles entisrs

Figure 4-5. Fenétre Options de relecture

2. Dans la liste déroulante Signal enregistré, sélectionnez signal dans le
deuxiéme journal que vous avez créé.

3. Entrez 1 dans le champ Temps de début (s) pour relire ou analyser un
sous-ensemble du signal enregistré qui commence une seconde apres
le début du journal.

4. Entrez 4 dans le champ Temps de fin (s) pour relire ou analyser un
sous-ensemble du signal enregistré qui commence quatre secondes
apres le début du journal. Si la durée du journal est inférieure a 4
secondes, entrez la valeur appropriée dans le champ Temps de fin (s).
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5. Dans laliste déroulante Signal enregistré, cliquez avec le bouton droit
sur le signal du deuxieme journal et sélectionnez Activer dans le menu
local pour définir le signal comme journal actif.

@ Remarque Vous pouvez aussi cliquer avec le bouton droit sur un journal dans la fenétre
Données enregistrées et sélectionner Rendre le journal actif dans le menu local pour
définir ce journal comme le journal actif.

6. Passez a I’onglet Affichage des données. L’ affichage graphe sur
I’onglet Affichage des données fait automatiquement apparaitre le
deuxieéme journal quand vous définissez ce signal comme le signal
actif.

7. Cliquez sur le bouton Exécuter, montré a gauche. LabVIEW
SignalExpress filtre le sous-ensemble du signal que vous avez spécifié
dans I’onglet Options de relecture et affiche le signal filtré résultant
dans I’onglet Affichage des données.

£% Exécuter -

Reportez-vous a I’Aide LabVIEW SignalExpress pour obtenir des
informations complémentaires sur I’enregistrement de données, comme la
spécification de conditions d’alarme, d’événements et les options de
relecture.
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Réalisation de mesures de

halayage

Vous pouvez utiliser LabVIEW SignalExpress pour automatiser les
mesures afin de caractériser et valider des systémes en créant des
opérations de balayage. Un systéeme peut étre quelque chose que vous créez
que vous voulez caractériser et valider avec LabVIEW SignalExpress. Vous
pouvez utiliser les mesures de balayage pour rassembler des données de
systémes en fonction d’une gamme de conditions pour documenter leurs
performances. Par exemple, vous pouvez utiliser des opérations de
balayage pour faire varier la fréquence d’un signal d’impulsion ou le niveau
d’une tension d’alimentation tout en prenant des mesures pour définir les
caractéristiques des systeémes.

Ce chapitre vous apprend comment configurer des opérations de balayage
en utilisant I’étape Balayage dans LabVIEW SignalExpress. Vous allez
apprendre comment définir les caractéristiques des performances d’un
filtre en balayant une gamme des valeurs de fréquence et en mesurant la
sortie du filtre. Vous allez aussi apprendre a afficher les résultats du
balayage et effectuer des balayages multidimensionnels pour effectuer des
mesures plus complexes.

Définition de sorties et de gammes de balayage

£3 Exécuter -

Vous pouvez utiliser I’étape Balayage dans LabVIEW SignalExpress pour
définir des mesures automatisées dans le cadre d’opérations de balayage
complexes et susceptibles d’étre répétées.

Effectuez les étapes suivantes pour définir une gamme de fréquence a
balayer dans un projet d’exemple utilisant un filtre.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire
SignalExpress\Examples\Tutorial et double-cliquez sur
Sweep.seproj.

2. Cliquez sur le bouton Exécuter, montré a gauche, pour exécuter le
projet en continu.
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a Ajouker une étape
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Le projet géneére un signal d’impulsion sinusoidal a I’étape Créer un
signal analogique, ce signal passe ensuite dans un filtre passe-bande
elliptique a I’étape Filtre, mesure le niveau Veff de la sortie du filtre a
I’étape Amplitude et niveaux et convertit le niveau en décibels (dB) a
I’étape Formule. L’ étape Filtre agit comme une unité simulée en cours
de test, le projet n’utilise donc pas de matériel. Toutefois, vous pouvez
aussi balayer des signaux physiques générés a partir d’un générateur
de fonctions, de I’analyseur de signaux dynamiques, d’un périphérique
d’E/S multifonction (MIO) ou d’un générateur de signaux arbitraires
National Instruments.

Cliquez sur le bouton Arréter pour arréter le projet.

Cliquez sur le bouton Ajouter une étape, montré a gauche, et
sélectionnez Controle d’exécution»Balayage pour ajouter 1’étape
Balayage a la Vue du projet.

Sur I’onglet Configuration de I’étape, cliquez sur le bouton Ajouter
pour afficher la liste des parameétres balayables a partir de chaque étape
du projet, comme le montre la figure 5-1.

Selection du parametre de balayage

Paramétres pouvant Etre balayés

= Créer un signal analogique: stimulus signal {s | A
armplitude '
Mombre d'échantillons
Fréquence {Hz)
OffFsek (V)
Phase (ded.)
Fréq, d'échantilonnage (Efs)
= Filtre: response signal
Coupure basse
Crdre

I oK l [ Annuler ]

Figure 5-1. Boite de dialogue Sélection du parametre de balayage

Sélectionnez le parametre Fréquence (Hz) sous Créer un signal
analogique et cliquez sur le bouton OK.

L’ étape Balayage comprend I’étape Créer un signal analogique qui
fournit le signal a balayer.

Sur la page Configuration du balayage de 1’onglet Configuration de
I’étape, sélectionnez Exponentiel dans le menu déroulant Type.

Entrez 1k dans le champ Départ : Fréquence (Hz), et entrez 40k dans
le champ Arrét : Fréquence (Hz).
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9. Entrez 150 dans le champ Nombre de points.

La page Configuration du balayage apparait comme le montre la
figure 5-2.

Configuration du balayage Sortie du balayage

Parameétres pouvant Stre balayés :
Mom du parametre Mom de ['étape Sortie affectée Alias |

Fréquence (Hz) Créer un signal analogic stimulus signal (sineway

Configuration Points du balayage
Type 40k -
Exponentiel w

Départ : Fréguence {Hz)

1k 2 10k -

‘aleurs

Arrét ; Fréquence (Hz)
40k, 2

Morbre de points 1k
o 1 ] 1 ] ] | 1 ] ]
150 £ 1 20 40 &0 &0 100 120 140 160
Itération

Figure 5-2. Onglet Configuration de I'étape Balayage

Vous utilisez I’ étape Balayage pour spécifier une gamme de valeurs sur
laquelle effectuer des itérations dans le parameétre Fréquence (Hz) de
1’étape Créer un signal analogique. L’étape Créer un signal analogique
utilise la gamme de fréquence définie pour générer un signal
sinusoidal a chacune de ces fréquences. Vous pouvez utiliser 1’étape
Balayage pour effectuer des itérations sur toute valeur d’un parametre
susceptible d’étre balayé de n’importe quelle étape d’un projet
elle-méme susceptible d’étre balayée.

10. Passez a la page Sortie du balayage.

11. Cliquez sur le bouton Ajouter pour afficher la liste des sorties pouvant
&tre balayées pour chaque étape du projet.

© National Instruments Corporation 5-3 Initiation a LabVIEW SignalExpress



Chapitre 5 Réalisation de mesures de balayage

12. Sélectionnez la sortie response amplitude in dB sous Formule et

cliquez sur le bouton OK pour tracer cette mesure par rapport au
paramétre Fréquence (Hz) balayé.

L’ étape Balayage crée une boucle autour de toutes les étapes de la Vue
du projet pour inclure toutes les étapes dans I’opération de balayage.

Exécution de mesures balayées

Effectuez les étapes suivantes pour exécuter la mesure de balayage.

1.

Initiation & LabVIEW SignalExpress

Passez a I’onglet Affichage des données, cliquez sur la fléche vers le
bas du bouton Exécuter et sélectionnez Exécuter une fois pour
exécuter la mesure balayée.

La sortie blanche stimulus signal sur 1’affichage graphe itere dans la
gamme de fréquences spécifiée.

Faites glisser le signal response amplitude in dB vs. Fréquence du
bas de la boucle de balayage vers 1’ Affichage des données pour
afficher la sortie du balayage.
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LabVIEW SignalExpress crée un nouvel affichage graphe. Les
données d’une opération de balayage sont représentées dans un tableau
XY qui requiert un affichage séparé, comme le montre la figure 5-3.

‘& C:\Program Filest...\Sweep.seproj * - LabVIEW SignalExpress B [=15%]

Fichier Edion Affichage Cutls  Ajouter une étape Exécution  Affichage des données  Fenftre Aide

@ Aouter une étape 3 Exécuter - | @ Enregistrer 59

53 Proiet v X Affichage des données | 82 Configuration de lstape x
i@ [ surveilbncefErregstrement: ]| i aiouter un sffichags G Propristes...
Affichage 1
200m -
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Figure 5-3. Sweep.seproj

3. Sélectionnez I’option Exécuter une fois pour exécuter a nouveau le
balayage.

La réponse en fréquence de I’étape Filtre est tracée sur le nouvel
affichage graphe pendant que le projet s’exécute. Le graphe montre la
fonction de transfert du filtre, ou la sortie d’amplitude exprimée en
décibels par rapport a la fréquence.
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Chapitre 5

5

Réalisation de mesures de balayage

Remarque Par défaut, LabVIEW SignalExpress ne réinitialise pas les affichages sur
I’onglet Affichage des données entre les itérations d’un balayage. Dans la mesure ou la
réponse en fréquence de I’étape Filtre est la méme a chaque itération, le graphe qui affiche
le signal ne semble pas se mettre a jour quand vous exécutez le projet. Vous pouvez utiliser
la page Données de la boite de dialogue Options pour indiquer si LabVIEW SignalExpress
supprime le résultat du balayage sur les affichages entre des itérations d’un balayage.
Sélectionnez Outils»Options pour afficher la boite de dialogue Options.

4. Double-cliquez sur 1’étape Filtre pour afficher les spécifications du
filtre dans 1’onglet Configuration de I’étape.

La réponse en fréquence du filtre dans le graphe Réponse en
amplitude du filtre (dB) correspond au graphe de 1’ Affichage des
données.

5. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le
projet sous Mon balayage.seproj dans le répertoire
SignalExpress\Examples\Tutorial.

Vous pouvez utiliser I’étape Balayage pour balayer plusieurs parametres
simultanément en ajoutant des parametres supplémentaires sur la page
Configuration du balayage de 1’onglet Configuration de I’étape de
I’étape Balayage. Le balayage simultané de plusieurs parametres est appelé
balayage parallele. Par exemple, si vous voulez varier I’amplitude d’un
signal de stimulus, vous pouvez exécuter un balayage en parallele pour
optimiser la précision de 1’acquisition en variant la gamme en entrée d’un
numériseur ou d’un périphérique MIO tout en variant le niveau du signal.
A mesure que le niveau du signal augmente, vous pouvez augmenter la
gamme d’entrée du périphérique de mesure pour vous assurer que vous
utilisez toute la résolution pour la mesure.

Exécution de balayages multidimensionnels

Utilisez des balayages multidimensionnels ou imbriqués pour effectuer des
itérations sur une gamme tout en faisant varier une autre gamme. Par
exemple, si vous voulez effectuer des itérations sur des fréquences d’un
signal d’impulsion & différentes amplitudes, exécutez un balayage
imbriqué. Vous pouvez définir I’amplitude au niveau 1 et effectuer des
itérations sur des fréquences, puis définir I’amplitude au niveau 2 et
effectuer des itérations sur des fréquences, et ainsi de suite. Vous pouvez
construire un balayage imbriqué en cliquant avec le bouton droit sur I’étape
Balayage dans un projet en sélectionnant Ajouter un balayage imbriqué
dans le menu local pour ajouter une autre boucle de balayage.
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Chapitre 5 Réalisation de mesures de balayage

Effectuez les étapes suivantes pour exécuter un projet d’exemple de
balayage imbriqué.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire
SignalExpress\Examples\Tutorial et double-cliquez sur
Nested Sweep.seproj.

2. Cliquez sur le bouton Exécuter pour exécuter le projet.

Chaque itération de la boucle de balayage interne balaie la fréquence
du signal d’impulsion. La boucle de balayage externe fait varier les
fréquences de coupure basse et haute de 1’étape Filtre. Chaque itération
apparait en temps réel sur I’affichage graphe supérieur, puis apparait
sur I’affichage graphe inférieur pour montrer tous les balayages a
chaque configuration de la fréquence de coupure, comme le montre la
figure 5-4.

“& C:\Program Files\...\Nested Sweep.seproj * - LabVIEW SignalExpress E]@

Fichier Edition Affichage Outls  Ajouter une étape  Exécution  Affichage des données  Fengtre Aide
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Figure 5-4. Nested Sweep.seproj

Arréter -

et

Cliquez sur le bouton Arréter, montré a gauche, pour arréter le projet.
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Extension des projets LabVIEW
SignalExpress avec LabVIEW

Vous pouvez utiliser LabVIEW SignalExpress pour définir des mesures
automatisées en utilisant les étapes intégrées pour acquérir, générer ou
analyser des signaux. Vous pouvez étendre la fonctionnalité des projets
LabVIEW SignalExpress en utilisant LabVIEW des fagons suivantes :

Construisez un VI dans LabVIEW et importez-le dans LabVIEW
SignalExpress pour fournir une fonctionnalité d’étape personnalisée et
étendre le nombre d’étapes disponibles dans LabVIEW SignalExpress.

Convertissez un projet LabVIEW SignalExpress en un diagramme
LabVIEW pour poursuivre le développement dans LabVIEW.

Vous devez avoir LabVIEW 7.1 ou une version ultérieure pour effectuer les
exercices de ce chapitre.

Importation de Vis LabVIEW dans LabVIEW
SignalExpress sous forme d’étapes

Utilisez I’étape Exécuter un VI LabVIEW dans LabVIEW SignalExpress
pour appeler des VIs LabVIEW personnalisés. Vous pouvez appeler un
VI LabVIEW a partir de LabVIEW SignalExpress pour qu’il :

© National Instruments Corporation

Contrdle des instruments GPIB

Contrdle du matériel National Instruments non supporté par LabVIEW
SignalExpress

Lise ou écrive des données dans davantage de formats de fichier

Affiche des instructions destinées a I’opérateur dans une boite de
dialogue locale

Définisse un algorithme de mesure
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Chapitre 6 Extension des projets LabVIEW SignalExpress avec LabVIEW

a Ajouter une étape

Effectuez les étapes suivantes pour importer un VI LabVIEW avec 1’étape
Exécuter un VI LabVIEW.

1.

Initiation & LabVIEW SignalExpress

Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire
SignalExpress\Examples\Tutorial etdouble-cliquez sur User
Step.seproj.

Ce projet utilise I’étape Créer un signal analogique pour générer un
signal.

Cliquez sur le bouton Ajouter une étape, montré a gauche, et
sélectionnez Exécuter un VI LabVIEW»Exécuter un VI
LabVIEW 8.6.

Le VI que vous exécutez dans cet exercice a été enregistré avec
LabVIEW 8.6. Vous devez utiliser la version de I’étape Exécuter un VI
LabVIEW qui correspond a la version de LabVIEW dans laquelle vous
avez enregistré le VL.

Sur I’onglet Configuration de I’étape, cliquez sur le bouton Parcourir
dans la section Sélectionnez un VI et sélectionnez
Limiter-Lv86.vi dans le répertoire LabVIEW SignalExpress\
Examples\Tutorial. Le VI Limiter-LV86 accepte un signal du
domaine temporel comme entrée, écréte le signal au-dessus et en
dessous des valeurs que vous spécifiez dans la boite de dialogue
Configuration de I’étape, et renvoie le signal écrété en sortie.

Lorsque vous importez un VI LabVIEW, LabVIEW SignalExpress
mappe les entrées du VI comme parametres et les sorties du VI comme
signaux en sortie dans LabVIEW SignalExpress.

Vous pouvez définir si les entrées des VIs deviennent des signaux en
entrée ou des parametres. Un signal en entrée apparait dans la Vue du
projet comme une entrée d’une étape, ce qui signifie que vous pouvez
transmettre des signaux a un VI sous la forme d’entrées. Un parameétre
est une valeur que vous pouvez configurer dans I’onglet
Configuration de I’étape d’une étape. Vous pouvez aussi balayer des
parametres de maniere dynamique en utilisant I’étape Balayage. Dans
ce projet, le VI posséde un signal en entrée Signal temporel en entrée
et les parametres scalaires Limite supérieure et Limite inférieure.
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Chapitre 6 Extension des projets LabVIEW SignalExpress avec LabVIEW

Assurez-vous que 1’onglet Configuration de I’étape apparait comme
dans la figure 8-1.

Paramétres | Configurer le YT | Contrdle d'exécution

Sélectionnez le I
Z;\Program Files\Mational InstrumentsiSignalExpress\Examples) Tutorial\Limiter-LYa2 . vi

[CJExécuter automatiquement cette étape Rafraichir le Y1

Mom de la commande

Time wavefarm in ) q
Signal en entrée

A
Connecker une entrée, . E‘l?. .
sine wave v
Décannecter l'entrée

v
Sorties Type strick des données en sortie
Clipped waveform out A | Waveform temporele, réel w

£% Exécuter =
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Figure 6-1. Onglet de configuration de I’étape VI Limiter

Cliquez sur le bouton Exécuter, montré a gauche, pour exécuter le
projet.
Passez a I’onglet Affichage des données et faites glisser le signal en

sortie Clipped waveform out de I’étape Exécuter un VI LabVIEW 8.6
vers I’onglet Affichage des données.

Double-cliquez sur I’étape Exécuter un VI LabVIEW 8.6 pour afficher
I’onglet Configuration de 1’étape.

Sélectionnez la page Configurer le VI pour afficher le VI.

Entrez de nouvelles valeurs dans les champs Limite supérieure et
Limite inférieure. Par exemple, entrez 100 dans le champ Limite
supérieure.

Passez a I’onglet Affichage des données. Le signal Clipped
waveform out change pour refléter les modifications effectuées.

ArrEker - 10. Cliquez sur le bouton Arréter, montré a gauche, pour arréter le projet.
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Chapitre 6 Extension des projets LabVIEW SignalExpress avec LabVIEW

11.

Sélectionnez Fichier»Enregistrer sous et enregistrez le projet sous

Mon étape utilisateur.seproj.

12. Sélectionnez Fichier»Fermer le projet pour fermer le projet.

Reportez-vous a I’Aide LabVIEW SignalExpress pour obtenir davantage
d’informations sur ’utilisation de VIs LabVIEW dans LabVIEW
SignalExpress et sur la construction de VIs qui fonctionnent sous
LabVIEW SignalExpress.

Conversion de projets LabVIEW SignalExpress en
diagrammes LabVIEW

LabVIEW SignalExpress peut convertir des projets LabVIEW
SignalExpress en diagrammes LabVIEW.

@ Remarque Pour convertir un projet LabVIEW SignalExpress en VI LabVIEW, le systeme
de développement complet de LabVIEW 7.1 ou une version ultérieure doit étre installée.

Effectuez les étapes suivantes pour convertir un projet LabVIEW
SignalExpress en diagramme LabVIEW.

1.

Initiation & LabVIEW SignalExpress

Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire
SignalExpress\Examples\Tutorial\Solutions et
double-cliquez sur Mon premier projet.seproj.

Sélectionnez Outils»Générer le code»Diagramme LabVIEW.

Spécifiez un nom de fichier et un emplacement pour le VI LabVIEW
et cliquez sur le bouton OK. LabVIEW SignalExpress génere le
nouveau VI et I’ouvre dans la derniere version de LabVIEW ouverte
sur votre machine.

Le diagramme LabVIEW résultant reflete 1’exécution du projet dans
LabVIEW SignalExpress. Le diagramme LabVIEW comprend des
VIs Express LabVIEW cablés entre eux. Chaque VI Express
correspond a une étape dans le projet LabVIEW SignalExpress. Vous
pouvez double-cliquer sur un VI Express pour afficher une boite de
dialogue de configuration identique a I’onglet Configuration de
I’étape dans LabVIEW SignalExpress. Vous pouvez également
effectuer un clic droit sur un VI Express et sélectionner Ouvrir la
face-avant dans le menu local pour convertir le VI Express en un
sous-VI LabVIEW. Vous pouvez afficher le diagramme LabVIEW
pour voir comment il s’exécute et modifier la fonctionnalité du VI.
Lorsque vous convertissez un VI Express en sous-VI, vous ne pouvez
plus convertir le sous-VI en VI Express.
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Chapitre 6 Extension des projets LabVIEW SignalExpress avec LabVIEW

@ Remarque Lorsque vous convertissez un projet LabVIEW SignalExpress comportant un
enregistrement dans un fichier journal, LabVIEW SignalExpress génere un diagramme
LabVIEW avec un VI Express. Vous ne pouvez pas convertir le VI Express généré en un
sous-VIL.
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Et maintenant ?

Reportez-vous aux ressources suivantes pour obtenir de plus amples
informations sur LabVIEW SignalExpress.

Projets d’exemple LabVIEW SignalExpress

LabVIEW SignalExpress offre une variété de projets d’exemple qui
démontrent davantage de possibilités de LabVIEW SignalExpress. Ces
projets sont situés dans le répertoire SignalExpress\Examples. Passez
ces exemples en revue pour en savoir plus sur les fonctionnalités de
LabVIEW SignalExpress ou pour démarrer avec un projet qui s’approche
de vos exigences.

Utilisation du mateériel avec LabVIEW SignalExpress

LabVIEW SignalExpress supporte de nombreux périphériques National
Instruments d’acquisition et de génération de signaux. Vous pouvez
générer ou acquérir des signaux analogiques dans LabVIEW SignalExpress
en utilisant des numériseurs haute vitesse, des périphériques d’acquisition
de signaux dynamiques, des générateurs de waveform arbitraires et des
générateurs de fonctions ou des périphériques MIO National Instruments.
Vous pouvez aussi synchroniser plusieurs périphériques dans un systeéme
en partageant des signaux d’horloge et de déclenchement entre des
périphériques. Reportez-vous a 1’Aide LabVIEW SignalExpress en
sélectionnant Aide»Aide LabVIEW SignalExpress pour obtenir des
informations complémentaires sur 1’utilisation de périphériques avec
LabVIEW SignalExpress.

Ressources Weh

Reportez-vous au site Web de National Instruments sur ni.com/france/
signalexpress pour obtenir des ressources telles que des projets
d’exemple, de la documentation technique et des VIs LabVIEW écrits pour
&tre utilisés dans LabVIEW SignalExpress.
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Support technique et services

Visitez les sections suivantes du site Web primé de National Instruments
sur ni.com pour obtenir une assistance technique et des services
professionnels :

*  Support — Les ressources de support technique en ligne sur
ni.com/support comprennent notamment :

Ressources d’auto-assistance technique — Visitez
ni.com/support pour obtenir des réponses et des solutions,
vous procurer des drivers et des mises a jour de logiciels, faire des
recherches dans la Base de connaissances, accéder aux manuels
sur les produits et aux assistants de dépannage pas a pas, ou
obtenir des milliers d’exemples de programmes, des tutoriels, des
notes d’application, des drivers d’instruments et bien plus encore.
Les utilisateurs enregistrés bénéficient également de I’acces a NI
Discussion Forums, sur ni . com/ forums. Pour accéder au forum
francais, cliquez sur le menu déroulant “Select Community” et
sélectionnez “Francais”. Les ingénieurs d’applications de NI se
font fort de répondre a toutes les questions qui leur sont adressées.

Abonnement SSP (Standard Service Program) — Ce
programme confére a ses membres un acces direct par téléphone
et e-mail aux ingénieurs d’applications de NI et leur permet
d’obtenir un support technique individuel, ainsi qu’un acces
privilégié aux modules de formation a la demande par le biais du
Services Resource Center. NI offre un abonnement gratuit d’un
an a partir de la date d’achat. Au bout d’un an, vous pouvez
renouveler votre abonnement pour continuer a profiter de ces
avantages.

Pour obtenir des informations sur d’autres options de support
technique dans votre région, visitez ni .com/services ou
contactez votre filiale locale en utilisant les coordonnées qui
se trouvent sur ni.com/contact.

*  Formations et certifications — Visitez ni.com/france et cliquez
sur Formations et Certifications sur le volet de gauche pour obtenir des
informations détaillées sur les programmes proposés. Vous pouvez
également vous inscrire a des cours de formation dispensés par des
instructeurs un peu partout dans le monde.
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Annexe A Support technique et services

* Intégrateurs — Si vous devez concilier délais serrés, ressources
techniques limitées et toute autre contrainte, nous vous invitons a faire
appel aux intégrateurs du Programme National Instruments Alliance
Partner. Pour en savoir plus, appelez votre filiale locale ou visitez le
site ni.com/alliance.

Si vous n’avez pas trouvé la réponse a vos questions sur ni . com, contactez
votre filiale locale ou le siege social de NI. Les numéros de téléphone des
filiales figurent au début de ce manuel. Vous pouvez également visiter la
page des filiales internationales sur ni.com/niglobal afin d’accéder au
site Web local de votre filiale, qui contient les informations les plus & jour
pour contacter le support technique par téléphone, fax ou e-mail, ainsi que
les dates des événements a venir.

Initiation & LabVIEW SignalExpress A-2 ni.com



LabVIEW" SignalExpress’

Erste Schritte mit LabVIEW SignalExpress

Juni 2008 ¢ NATIONAL
3738730-0113 ’ INSTRUMENTS



Deutschsprachige Niederlassungen

National Instruments National Instruments National Instruments

Germany GmbH Ges.m.b.H. Switzerland

Konrad-Celtis-Strafie 79 Plainbachstrafle 12 Sonnenbergstrafie 53

81369 Miinchen 5101 Salzburg-Bergheim CH-5408 Ennetbaden

Tel.: +49 89 7413130 Tel.: +43 662 457990-0 Tel.: +41 56 2005151, +41 21 3205151 (Lausanne)
Fax: +49 89 7146035 Fax: +43 662 457990-19 Fax: +41 56 2005155

Lokaler technischer Support

Deutschland: ni.germany@ni.com www.ni.com/germany

Osterreich: ni.austria@ni.com www.ni.com/austria

Schweiz: ni.switzerland@ni.com www.ni.com/switzerland

Technischer Support und Produktinformation weltweit

ni.com

National Instruments Corporate Firmenhauptsitz
11500 North Mopac Expressway  Austin, Texas 78759-3504 USA Tel: 001 512 683 0100

Internationale Niederlassungen

Australien 1800 300 800, Belgien 32 (0) 2 757 0020, Brasilien 55 11 3262 3599, China 86 21 5050 9800,
Dénemark 45 45 76 26 00, Finnland 358 (0) 9 725 72511, Frankreich 01 57 66 24 24,

GroBbritannien 44 0 1635 523545, Indien 91 80 41190000, Israel 972 3 6393737, Italien 39 02 41309277,
Japan 0120-527196, Kanada 800 433 3488, Korea 82 02 3451 3400, Libanon 961 (0) 1 33 28 28,

Malaysia 1800 887710, Mexiko 01 800 010 0793, Neuseeland 0800 553 322, Niederlande 31 (0) 348 433 466,
Norwegen 47 (0) 66 90 76 60, Polen 48 223 390150, Portugal 351 210 311 210, Russland 7 495 783 6851,
Schweden 46 (0) 8 587 895 00, Singapur 1800 226 5886, Slowenien 386 3 425 42 00, Spanien 34 91 640 0085,
Siidafrika 27 0 11 805 8197, Taiwan 886 02 2377 2222, Thailand 662 278 6777,

Tschechische Republik 420 224 235 774, Tiirkei 90 212 279 3031

Weitere Informationen finden Sie im Anhang unter Technische Unterstiitzung und professioneller Service. Fiir
Kommentare und Anregungen zu unserer Dokumentation geben Sie bitte auf unserer Website ni . com/info den
Infocode feedback ein.

© 2004-2008 National Instruments Corporation. Alle Rechte vorbehalten.



Wichtige Informationen

Garantie

National Instruments gewéhrleistet, dass die Datentriger, auf denen National Instruments Software tibermittelt wird, wihrend eines Zeitraums
von 90 Tagen ab Lieferung, nachgewiesen durch Empfangsbestitigung oder sonstige Unterlagen, nicht aufgrund von Material- und
Verarbeitungsfehlern Programmanweisungen nicht ausfiihren. Datentriger, die Programmanweisungen nicht ausfiihren, werden nach Wahl
von National Instruments entweder repariert oder ersetzt, sofern National Instruments wihrend der Garantiezeit iiber derartige Mingel
informiert wird.

Damit Gegenstinde zur Ausfithrung von Garantieleistungen angenommen werden, miissen Sie sich eine Warenriicksendenummer
(RMA-Nummer) vom Hersteller geben lassen und diese auf der Packung deutlich sichtbar angeben. Die Kosten der Riicksendung von
Ersatzteilen, die von der Garantie erfasst sind, an Sie iibernimmt National Instruments.

National Instruments geht davon aus, dass die Informationen in dieser Unterlage zutreffend sind. Die Unterlage ist sorgfiltig auf technische
Richtigkeit tiberpriift worden. Fiir den Fall, dass dennoch technische oder Schreibfehler vorhanden sein sollten, behilt sich National
Instruments das Recht vor, dies in spiteren Ausgaben ohne vorherige Ankiindigung zu berichtigen. Bitte wenden Sie sich an National
Instruments, falls Sie einen Fehler vermuten. National Instruments haftet in keinem Fall fiir Schiden, die sich aus oder im Zusammenhang mit
dieser Unterlage oder den darin enthaltenen Informationen ergeben.

SOWEIT HIER NICHT AUSDRUCKLICH VORGESEHEN, SCHLIESST NATIONAL INSTRUMENTS JEDE GEWAHRLEISTUNG, SEI
SIE AUSDRUCKLICH ODER STILLSCHWEIGEND, AUS. DIESER AUSSCHLUSS GILT INSBESONDERE FUR EINE ETWAIGE
KONKLUDENTE GEWAHRLEISTUNG, DASS DIE PRODUKTE VON DURCHSCHNITTLICHER QUALITAT UND FUR DEN
NORMALEN GEBRAUCH ODER FUR EINEN BESTIMMTEN ZWECK GEEIGNET SIND. EINE SCHADENERSATZPFLICHT FUR
SCHULDHAFTES VERHALTEN SEITENS NATIONAL INSTRUMENTS IST AUF DEN VOM KUNDEN GEZAHLTEN KAUFPREIS
BEGRENZT. NATIONAL INSTRUMENTS HAFTET NICHT FUR SCHADEN, DIE SICH AUS DEM VERLUST VON DATEN,
ENTGANGENEM GEWINN ODER NUTZUNGSMOGLICHKEITEN ERGEBEN UND AUCH NICHT FUR ZUFALLIGE ODER
FOLGESCHADEN, SELBST WENN NATIONAL INSTRUMENTS AUF DIE MOGLICHKEIT SOLCHER SCHADEN HINGEWIESEN
WURDE. Diese Haftungsbegrenzung gilt unabhéngig vom Rechtsgrund der Haftung. Anspriiche gegeniiber National Instruments miissen
innerhalb eines Jahres nach Schadenseintritt gerichtlich geltend gemacht werden. Die Firma National Instruments haftet nicht fiir
Verspitungsschiden, die nicht in ihrem Verantwortungsbereich liegen. Diese Garantie erstreckt sich nicht auf Schéden, Fehler, Fehlfunktionen
oder Servicemingel, die auf der Nichtbefolgung von Anweisungen von National Instruments fiir die Installation, den Betrieb oder die Wartung,
auf Veridnderungen des Produktes, Missbrauch oder Fehlgebrauch des Produktes, auf einer Unterbrechung der Energieversorgung, Feuer,
Wasserschidden, Unfille, Handlungen Dritter oder anderen Geschehnissen, die nicht im Verantwortungsbereich von National Instruments
liegen, beruhen.

Urheberrechte

Gemil den Bestimmungen des Urheberrechts darf diese Publikation ohne vorherige schriftliche Zustimmung der Firma National Instruments
Corporation weder vollstindig noch teilweise vervielfiltigt oder verbreitet werden, gleich in welcher Form, ob elektronisch oder mechanisch.
Das Verbot erfasst u.a. das Fotokopieren, das Aufzeichnen, das Speichern von Informationen in Retrieval Systemen sowie das Anfertigen von
Ubersetzungen gleich welcher Art.

National Instruments achtet das geistige Eigentum anderer und fordert seine Nutzer auf, dies ebenso zu tun. Die Software von National
Instruments ist urheberrechtlich und durch andere Rechtsvorschriften zum Schutz geistigen Eigentums geschiitzt. Wenn Sie NI Software
nutzen, um Software oder andere Materialien, die im Eigentum Dritter stehen, zu vervielfiltigen, diirfen Sie NI Software nur insoweit nutzen,
als Sie die betreffenden Materialien nach den jeweils anwendbaren Lizenzbestimmungen oder Rechtsvorschriften vervielfiltigen diirfen.

Marken

National Instruments, NI, ni.com und LabVIEW sind Marken der Firma National Instruments Corporation. Nihere Informationen zu den
Marken von National Instruments finden Sie im Abschnitt Terms of Use unter ni .com/legal.

Sonstige hierin erwihnte Produkt- und Firmenbezeichnungen sind Marken oder Handelsnamen der jeweiligen Unternehmen.

Mitglieder des National Instruments Alliance Partner Programms sind eigenstindige und von National Instruments unabhingige Unternehmen;
zwischen ihnen und National Instruments besteht keine gesellschaftsrechtliche Verbindung und auch kein Auftragsverhiltnis.

Patente

Nihere Informationen iiber den Patenteschutz von Produkten von National Instruments finden Sie unter Hilfe»Patente in Threr Software, in der
Datei patents. txt auf Ihrem Datentridger oder unter ni.com/patents.

WARNUNG ZUR NUTZUNG VON NATIONAL INSTRUMENTS PRODUKTEN
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SICHERHEITSNIVEAU ENTWICKELT, DAS FUR EINE VERWENDUNG BEI ODER IN ZUSAMMENHANG MIT CHIRURGISCHEN
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FUHREN KANN.

(2) BE1 JEDER ANWENDUNG, EINSCHLIESSLICH DER OBEN GENANNTEN, KANN DIE ZUVERLASSIGKEIT DER FUNKTION
DER SOFTWAREPRODUKTE DURCH ENTGEGENWIRKENDE FAKTOREN, EINSCHLIESSLICH Z.B.
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ANWENDUNGSENTWICKLERS (ENTGEGENWIRKENDE FAKTOREN WIE DIESE WERDEN NACHSTEHEND
ZUSAMMENFASSEND “SYSTEMFEHLER” GENANNT) BEEINTRACHTIGT WERDEN. JEDE ANWENDUNG, BEI DER EIN
SYSTEMFEHLER EIN RISIKO FUR SACHWERTE ODER PERSONEN DARSTELLT (EINSCHLIESSLICH DER GEFAHR
KORPERLICHER SCHADEN UND TOD), SOLLTE AUFGRUND DER GEFAHR VON SYSTEMFEHLERN NICHT LEDIGLICH AUF
EINE FORM VON ELEKTRONISCHEM SYSTEM GESTUTZT WERDEN. UM SCHADEN UND, U.U. TODLICHE, VERLETZUNGEN
ZU VERMEIDEN, SOLLTE DER NUTZER ODER ANWENDUNGSENTWICKLER ANGEMESSENE SICHERHEITSMASSNAHMEN
ERGREIFEN, UM SYSTEMFEHLERN VORZUBEUGEN. HIERZU GEHOREN UNTER ANDEREM SICHERUNGS- ODER
ABSCHALTMECHANISMEN. DA JEDES ENDNUTZERSYSTEM DEN KUNDENBEDURFENISSEN ANGEPASST IST UND SICH VON
DEM TESTUMFELD UNTERSCHEIDET, UND DA EIN NUTZER ODER ANWENDUNGSENTWICKLER SOFTWAREPRODUKTE
VON NATIONAL INSTRUMENTS IN VERBINDUNG MIT ANDEREN PRODUKTEN IN EINER VON NATIONAL INSTRUMENTS
NICHT GETESTETEN ODER VORHERGESEHENEN FORM EINSETZEN KANN, TRAGT DER NUTZER BZW. DER
ANWENDUNGSENTWICKLER DIE LETZTENDLICHE VERANTWORTUNG FUR DIE UBERPRUFUNG UND AUSWERTUNG DER
EIGNUNG VON NATIONAL INSTRUMENTS PRODUKTEN, WENN PRODUKTE VON NATIONAL INSTRUMENTS IN EIN SYSTEM
ODER EINE ANWENDUNG INTEGRIERT WERDEN. DIES ERFORDERT U.A. DIE ENTSPRECHENDE ENTWICKLUNG UND
VERWENDUNG SOWIE EINHALTUNG EINER ENTSPRECHENDEN SICHERHEITSSTUFE BEI EINEM SOLCHEN SYSTEM ODER
EINER SOLCHEN ANWENDUNG.
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Zu diesem Handbuch

In diesem Handbuch erhalten Sie eine Einfiihrung in die interaktive
Messung mit LabVIEW SignalExpress und die Grundfunktionen des
Programms zum Erfassen und Analysieren von Signalen.

Die im Buch enthaltenen Ubungen sollen Thnen den Einstieg in LabVIEW
SignalExpress erleichtern. Sie lernen damit die Konfiguration von Schrit-
ten, das Ausfiihren von Projekten, die Arbeit mit Signalen, das wiederholte
Messen mit variablen Parametern, das Protokollieren von Daten sowie die
Erweiterung von LabVIEW SignalExpress durch die grafische Program-
mierumgebung LabVIEW.

Symbole und Darstellungen

»

fett

kursiv

monospace

In diesem Handbuch werden die folgenden Symbole und Darstellungen
verwendet:

Das Symbol » kennzeichnet die Reihenfolge, in der Meniipunkte und Dia-
logfeldoptionen anzuklicken sind. So wird zum Beispiel mit der Abfolge
Datei»Seite einrichten»Optionen angezeigt, dass zunéchst das Menii
Datei zu 6ffnen ist, daraus der Meniipunkt Seite einrichten auszuwihlen
und anschlieBend die Seite Optionen anzuklicken ist.

Dieses Zeichen steht fiir einen Hinweis auf wichtige Informationen.
Dieses Symbol steht fiir einen Tipp.

In fettgedruckter Schrift sind Elemente dargestellt, die ausgewéhlt oder
angeklickt werden miissen, wie Meniipunkte oder Optionen in Dialogfel-
dern. Bei fettgedrucktem Text kann es sich auch um die Namen von Ein-
und Ausgingen, Parameternamen, Dialogfelder, Bereiche in Dialogfeldern
und Meniinamen handeln.

Variablen, Hervorhebungen, Querverweise und erstmals genannte Fachaus-
driicke sind durch Kursivschrift gekennzeichnet. Ebenfalls kursiv sind
Textstellen gedruckt, an denen Worter oder Werte einzusetzen sind.

In Monospace-Schrift (nicht proportionaler Schrift) ist Text dargestellt, der
tiber die Tastatur einzugeben ist. Diese Darstellungsweise wird ebenfalls
fiir Laufwerke, Pfade, Verzeichnisse, Programme, Unterprogramme, Sub-
routinen, Gerdtenamen, Funktionen, Operationen, Variablen sowie
Dateinamen und -erweiterungen verwendet.

© National Instruments Corporation vii Erste Schritte mit LabVIEW SignalExpress



Zu diesem Handbuch

Literaturhinweise

Wenn Sie beim Lesen dieses Handbuchs weitere Fragen haben, werden
diese moglicherweise in der Hilfe zu LabVIEW SignalExpress unter
Hilfe»LabVIEW SignalExpress Hilfe beantwortet.
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Erste Schritte mit LabVIEW
SignalExpress

Mit den innovativen Produkten von National Instruments haben Wissen-
schaftler und Ingenieure die Moglichkeit, mit der Industrienorm ent-
sprechenden Computern und Plattformen automatisierte Messsysteme zu
erstellen. Dazu bietet National Instruments technologisch fiihrende Pro-
grammierumgebungen wie die grafische Entwicklungsumgebung
LabVIEW, die ANSI-C-Programmierumgebung LabWindows™/CVI™
oder Measurement Studio zur Programmierung in Microsoft Visual Studio
an. Diese Programmierumgebungen arbeiten sowohl herkommlichen
Messgeriten als auch mit virtuellen Messgeréten, die mittels der Messkar-
ten von National Instruments auf dem Computer emuliert werden, so dass
Sie reale und virtuelle Messgerite zu technisch anspruchvollen Systemen
kombinieren kénnen.

Mit LabVIEW SignalExpress konnen Sie interaktiv virtuelle Messsysteme
erstellen und ohne jegliche Programmierung sofort mit der Messung begin-
nen. Signale werden interaktiv erfasst, erzeugt, analysiert, verglichen,
importiert und gespeichert. So konnen Sie zum Beispiel vorgegebene Werte
in einem Schritt mit Messwerten vergleichen. LabVIEW SignalExpress
macht damit die Einfachheit und die Moglichkeiten virtueller Messanlagen
auch solchen Nutzern zugénglich, die Signale ohne Programmierung von
Anwendungen messen und analysieren mochten. Die Programmfunktionen
konnen auch ausgebaut werden, indem Sie ein eigenes VI (virtuelles Instru-
ment) aus der LabVIEW-Entwicklungsumgebung importieren oder ein
LabVIEW-SignalExpress-Projekt in ein LabVIEW-Blockdiagramm
umwandeln, so dass Sie in LabVIEW weiter am Projekt arbeiten konnen.
Weitere Informationen zu fortgeschrittenen Funktionen in LabVIEW
SignalExpress finden Sie in Kapitel 6, Erweitern von LabVIEW-Signal Ex-
press- Projekten durch LabVIEW.

Dieses Kapitel enthdlt Angaben zu den Systemanforderungen, zur Installa-
tion, zu verfiigbaren Versionen und zu Optionen zur Lizenzierung fiir
LabVIEW SignalExpress.
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Kapitel 1 Erste Schritte mit LabVIEW SignalExpress

Installieren von LabVIEW SignalExpress

Bevor Sie mit den Ubungen dieses Handbuchs beginnen, muss LabVIEW
SignalExpress installiert werden. Die Installation das Programms dauert
etwa 10 Minuten.

Systemanforderungen

Fiir die Ausfithrung von LabVIEW SignalExpress wird folgende System-
konfiguration empfohlen:

e 512 MB Arbeitsspeicher

*  Pentium 4 oder gleichwertiger Prozessor (mindestens Pentium III oder
Celeron mit 600 MHz)

Installationshinweise

Gehen Sie zur Installation von LabVIEW SignalExpress unter
Windows 2000/XP/Vista wie folgt vor:

@ Hinweis Wenn Sie LabVIEW SignalExpress bereits von der DVD mit LabVIEW 8.6
installiert haben, miissen Sie das Programm nicht wie nachfolgend beschrieben neu instal-
lieren. Installationshinweise finden Sie in den LabVIEW-Versionshinweisen.

1. SchlieBen Sie alle Programme, bevor Sie das Installationsprogramm
starten. Im Hintergrund laufende Programme, zum Beispiel Antiviren-
programme, verlangern unter Umstinden die Installation.

2.  Melden Sie sich als Administrator oder Anwender mit Administrator-
rechten an.

3. Legen Sie die Installations-CD fiir LabVIEW SignalExpress ein und
folgen Sie den Anweisungen.

@ Hinweis Wenn Sie keinen anderen Speicherort angeben, kopiert das Installationspro-
gramm von LabVIEW SignalExpress die Dateien in das Verzeichnis <Programme>\
National Instruments\SignalExpress.

4. Untersuchen Sie die Festplatte nach Abschluss der Installation auf
Viren und aktivieren Sie die automatische Virenerkennung wieder.

Die in den folgenden Ubungen verwendeten Beispielprojekte befinden
sich im Verzeichnis <Programme>\National Instruments\
SignalExpress\Examples\Tutorial. Die Losungen zu den
einzelnen Ubungen sind im Verzeichnis <Programme>\
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Erste Schritte mit LabVIEW SignalExpress

National Instruments\SignalExpress\Examples\Tutorial\

Solutions gespeichert.

Verfiighare Versionen von LabVIEW SignalExpress

LabVIEW SignalExpress ist als Full Edition und Limited Edition (LE)
erhiltlich. In der folgenden Tabelle sehen Sie die Programmfunktionen der

beiden Versionen im Vergleich.

Tabelle 1-1. Unterschiede zwischen LabVIEW SignalExpress Full und LE

Full LE

Geriteunterstiitzung

Uber 300 giingige Gerite

N
|

Visualisierung und Dokumentation

Benutzerdefinierte grafische Darstellung

Interaktive Cursor

Speichern von Signalen in Dateien

Drucken und Exportieren von Graphen

Verschieben von Daten iiber Drag-and-Drop in
Microsoft Excel, Word und WordPad

AN N NN

Bedienmodus mit eingeschrinkter Benutzerbearbeitung

NONN N NS

Signalverarbeitung

Softwarefilter

Berechnungen an Skalaren und Signalverldufen

Analoge und digitale Umrechnung

Interaktive Signalvergleiche

Laden von Simulationsdaten von PSPICE, Multisim und
anderen SPICE-Programmen

AN N NN
|

Zeit- und Frequenzmessungen

Amplitude und Pegel

Timing und Ubergang

NS
|
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Kapitel 1 Erste Schritte mit LabVIEW SignalExpress

Tabelle 1-1. Unterschiede zwischen LabVIEW SignalExpress Full und LE (Fortsetzung)

Full LE

Leistungsspektrum v —

Frequenzgang v —

Verzerrungsmessungen v —
v

Grundfrequenz ermitteln

Datenprotokollierung

Eingeschrinkte Datenprotokollierung (ein Protokoll pro
Projekt)

Unbeschrinkte Datenprotokollierung

Alarm- und Ereignisprotokollierung

Datenprotokollierung mit Start- oder Stoppbedingungen

SISNE S

Automatische Messungen

Sweep-Parameter

Grenzwerttest

Software-Triggerung

Ablaufsteuerung

AN NN

Zugriff auf Netzwerkdaten

Lesen/Schreiben von Umgebungsvariablen

N
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Kapitel 1 Erste Schritte mit LabVIEW SignalExpress

Optionen zur Lizenzierung fiir LabVIEW SignalExpress

Im folgenden Abschnitt werden die Lizenzbestimmungen fiir LabVIEW
SignalExpress erldutert. Dieses Dokument ersetzt nicht die Softwarelizenz-
vereinbarung von National Instruments. Es dient lediglich als kurzer
Uberblick.

LabVIEW SignalExpress LE

Die eingeschrinkte, nicht lizenzierte LE-Version von LabVIEW SignalEx-
press gewéhrt Thnen Zugriff auf alle Programmfunktionen der Tabelle 1-1
fiir 30 Tage. Danach wechselt LabVIEW SignalExpress in den nicht lizen-
zierten Modus. Wenn Sie innerhalb von 30 Tagen keine giiltige Lizenz

aktivieren, werden Projekte mit lizenzierten Schritten wie folgt behandelt:

*  Bei jedem Ablegen eines lizenzierten Schritts wird ein Dialogfeld mit
der Aufforderung angezeigt, die Software zu aktivieren.

*  Projekte konnen nicht gespeichert werden.

*  Projekte werden nach 10 Minuten geschlossen.

Aufni.com/signalexpress konnen Sie die Vollversion von LabVIEW
SignalExpress erwerben.

LabVIEW Signal Express - Vollversion

Die Vollversion von LabVIEW SignalExpress bietet uneingeschrinkten
Zugriff auf alle in der Tabelle 1-1 aufgefiihrten Funktionen. Das Programm
kann mit dem Lizenzmanager von National Instruments, dem Installations-
programm von LabVIEW SignalExpress oder auf der Website ni . com/
activate aktiviert werden.
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Arbeit mit Projekten

Mit LabVIEW SignalExpress werden Messungen in Form einer Reihe von
Schritten ausgefiihrt, die Sie interaktiv auswéhlen und konfigurieren. Ein
Schritt ist eine Funktion mit individuellen Einstellungen, mit der Daten
erfasst, analysiert, geladen oder gespeichert werden konnen. Das Menii
Schritt hinzufiigen und die Palette Schritt hinzufiigen enthalten die in
LabVIEW SignalExpress verfiigbaren Schritte.

Die meisten Schritte verarbeiten Eingangssignale und erzeugen Ausgangs-
signale. Durch die Angabe von Werten auf der Registerkarte
Schritteinstellungen konnen Sie die einzelnen Schritte konfigurieren.
Eine gespeicherte Schrittfolge ergibt ein Projekt.

In diesem Kapitel lernen Sie, wie Projekte geladen und ausgefiihrt und
Schritte in den Projekten konfiguriert werden.

Offnen von Projekten

Zum Laden eines Beispielprojekts in LabVIEW SignalExpress gehen Sie
wie folgt vor:

1. Starten Sie LabVIEW SignalExpress.

Beachten Sie, dass LabVIEW SignalExpress in verschiedene Ansich-
ten aufgeteilt ist, in denen verschiedene Arten von Informationen
angezeigt werden. Die Hauptansicht wird in der Mitte des Programm-
fensters angezeigt und enthilt Registerkarten. Wenn das Programm in
der Standardkonfiguration getffnet wird, enthilt die Hauptansicht die
Registerkarten Datenansicht, Aufnahmeoptionen und Projekt-
dokumentation.

Neben der Hauptansicht sehen Sie verschiedene Zusatzansichten.
Bei der Standardkonfiguration wird die Projektansicht links und die
Kontexthilfe rechts angezeigt.

@ Hinweis Wenn LabVIEW SignalExpress unterstiitzte Hardware erkennt, erfolgt die
Anzeige der Kanalansicht im unteren Bereich des Programmfensters.
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Kapitel 2 Arbeit mit Projekten

2. Wenn LabVIEW SignalExpress nicht in der Standardkonfiguration
geoffnet wird, wihlen Sie Ansicht»Original-Layout wiederherstel-
len, um zur Standardkonfiguration zuriickzukehren. Uber das Menii
Ansicht kann die Anzeige von Registerkarten und Ansichten jederzeit
angepasst werden.

3. Wihlen Sie Hilfe»Beispiel 6ffnen, wechseln Sie zum Verzeichnis
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf
First Project.seproj.

4. Sehen Sie sich in Ruhe den Aufbau von LabVIEW SignalExpress an
(siehe Abbildung 2-1; die Kontexthilfe ist hier ausgeblendet).

®

© C:\Program Files\.l.\Firsl ijecllsepmj - LabVIEW StenalExpress B=)X]
Datei Bearbeiten Ansi Werkzeuge itt hinzufagen Dalirr\:ht Fenster  Hife

@ schrithinaufigen €% Ausfhren ~ = Einmal ausfiiven @) Aufnahme = 7 | 2 andocken | % Hife sinblenden
@ [ Mornitor-jaufnahmemodus ~] il

E Aus ASCI-Datei laden

[» @ '8 Distorted Singwave tat

Amplitude und Pegel

1B [ Distorted Sinewave.to - distoried sinewave
|» @0 DL
[» 0 RMS

?J@T

°

Warzarung

Il [ Distorted Sinewave -
|» @ [ Expottiertes Zeitsignal

[» @ [ Expotiettes Spekinm

Ampltude

Lesraut

3 Protokolle
{53 Momentaufnahmen ol
1 Schaltflache “Ausfiihren” 4 Eingangssignal 7 Fenster “Protokolldaten”
Pulldown-Meni zur Auswahl des 5 Ausgangssignal 8 Hauptansicht mit angezeigter Datenansicht
Arbeitsbereichs 6 Projektansicht 9 Schaltflache “Aufnahme”

3 Schritt

Abbhildung 2-1. First Project.seproj

Die Programmoberfliche von LabVIEW SignalExpress besteht aus
Ansichten fiir unterschiedliche Arten von Angaben. Die Hauptansicht
wird in der Mitte des Programmfensters angezeigt und enthélt
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Registerkarten wie die Datenansicht. Um die Hauptansicht herum
gibt es Zusatzansichten mit eigenen Titelleisten. Die Projektansicht ist
beispielsweise eine der Zusatzansichten.

Ausfiihren eines Projekts und Anzeigen von Signalen

£3 Ausfihren

In LabVIEW SignalExpress gibt es verschiedene Ausfiihrungsmodi. Pro-
jekte konnen entweder einmal oder kontinuierlich durchlaufen, eine
bestimmte Anzahl von Iterationen absolvieren oder eine bestimmte Zeit
lang ausgefiihrt werden. Beim einmaligen Durchlauf fiihrt LabVIEW
SignalExpress alle Schritte im Projekt einmal aus. Beim kontinuierlichen
Durchlauf fiihrt LabVIEW SignalExpress alle Schritte im Projekt fortlau-
fend aus. Klicken Sie auf den Pfeil der Schaltfliche Ausfiihren (siche Abb.
links) und wihlen Sie Ausfiihrung konfigurieren, um den Ausfiihrungs-
modus fiir ein Projekt festzulegen.

Die Anzeige der Datenansicht wird wihrend der Ausfiihrung kontinuier-
lich aktualisiert. Uber die Registerkarte Schritteinstellungen konnen Sie
Messkonfigurationen wihrend der Ausfithrung dndern. Die resultierenden
Daten werden dann sofort angezeigt. Projekte mit fortlaufender Ausfiih-
rung werden iiber die Schaltfliche Stopp (siehe Abb. links) angehalten.
Die Stopp-Schaltfliche erscheint anstelle der Ausfiihren-Schaltfléche,
wenn das Projekt l4uft.

Zum Starten des Beispielprojekts in SignalExpress und zum Anzeigen von
Signalen gehen Sie wie folgt vor:

1. Klicken Sie auf die Schaltfliche Ausfiihren. Wenn das Dialogfeld
Angaben zur Ausfithrung angezeigt wird, klicken Sie auf Ausfiih-
ren, um alle Schritte im Projekt kontinuierlich auszufiihren.

Daraufhin wird ein Signal aus einer Textdatei geladen und es werden
zwei Arten von Messungen vorgenommen: eine Amplituden- und
Pegelmessung sowie eine Verzerrungsmessung. Diese Messungen
werden jeweils von den Schritten “Amplitude und Pegel” und “Verzer-
rung” vorgenommen. Bei der Ausfiihrung eines Projekts analysieren
die Schritte die Eingangssignale und erzeugen als Ergebnis der Ana-
lyse neue Ausgangssignale. In diesem Projekt wird mit dem Schritt
“Aus ASCII-Datei laden” eine verzerrte Sinuskurve geladen, die dann
mit den Schritten “Amplitude und Pegel” und “Verzerrung” ausgewer-
tet wird. Beide Schritte erzeugen eine neue Kurve. Die Eingangs-
groBen werden in der Projektansicht durch rote Pfeile und die Aus-
gangsgrofen durch blaue Pfeile gekennzeichnet.
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Im Graphen in der Datenansicht wird immer noch das geladene Zeit-
bereichssignal angezeigt. Graphen konnen Zeitbereichs-, Frequenz-
bereichs- und XY-Signale darstellen.

Ziehen Sie das Ausgangssignal Exportiertes Spektrum des Schritts
“Verzerrung” von der Projektansicht in die Datenansicht.

LabVIEW SignalExpress erzeugt darauthin in der Datenansicht einen
neuen Graphen. LabVIEW SignalExpress zeigt das Signal Exportier-
tes Spektrum nicht im selben Graphen wie das Zeitbereichssignal an,
da es sich bei Exportiertes Spektrum um ein Frequenzbereichssignal
handelt. LabVIEW SignalExpress erkennt Signaltypen automatisch
und zeigt sie entsprechend an.

Tipp Weitere Informationen zu Signaltypen finden Sie in der Hilfe zu LabVIEW
SignalExpress, indem Sie Hilfe»LabVIEW SignalExpress Hilfe auswihlen, auf die
Registerkarte Suchen klicken und das Stichwort Signaltypen eingeben. In der Hilfe
erfahren Sie mehr zu den einzelnen Komponenten von LabVIEW SignalExpress, wie
Projekten, Schritten oder Signalen.

Ziehen Sie den Ausgang DC des Schritts “Amplitude und Pegel” in die
Datenansicht.

LabVIEW SignalExpress erzeugt darauthin einen Graphen und eine
Legende, um die Messergebnisse des Ausgangs DC darzustellen. Die
Tabelle Legende zeigt den Wert jeder Ausgabe und die Farbe, in der
LabVIEW SignalExpress den dazugehdrigen Plot im benachbarten
Graphen darstellt.

Ziehen Sie den Ausgang RMS des Schritts “Amplitude und Pegel” in
die Tabelle Legende, um die Werte der RMS-Messung anzuzeigen.
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LabVIEW SignalExpress fiigt der Tabelle daraufthin eine Zeile fiir das
zweite Messergebnis hinzu. Das Projekt sollte wie in Abbildung 2-2
aussehen.

& C:\Programme\...\First Project.seproj * - Lab¥IEW SignalExpress [3@
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Abbildung 2-2. AusgangsgréBen von First Project.seproj

Konfigurieren von Schritten

Ein Schritt ist eine konfigurierbare Funktion, mit der Daten erfasst, analy-
siert, geladen oder gespeichert werden konnen. Jeder Schritt verarbeitet
Signale und gibt Signale aus. Durch die Angabe von Werten auf der Regi-
sterkarte Schritteinstellungen konnen Sie die einzelnen Schritte konfigu-
rieren. Sie konnen auch bei laufenden Projekten Anderungen an den Ein-
stellungen vornehmen, so dass Sie IThre Messungen genau anpassen
konnen, bis die gewiinschten Ergebnisse in der Datenansicht dargestellt
werden.
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Zur Konfiguration der Schritte “Verzerrung” und “Amplitude und Pegel”
gehen Sie wie folgt vor:

1. Kilicken Sie den Schritt “Verzerrung” in der Projektansicht doppelt an.
LabVIEW SignalExpress zeigt die Registerkarte Schritteinstellungen
fiir den Schritt “Verzerrung” wie in Abbildung 2-3 an.

Exportiertes Signal
2

Amplitude
P O e
1 1 1 1

o im 2m 3 i S

50—

Zeit {s)
Ausgegebenes Leistungsspektrum amplitude autom, skalieren

0-
_50_
-100 -

Betrag (dE)

-150- 1 [ [ [ i [ i [ i
1] = 10k 15k 20k 25k 30k 35k 40k 45k S0k
Frequenz (Hz)

Eingabefausgabe | Konfiguration | Fortgeschritten

Messeinstelungen Messergebnisse
Werzerrungsarten Héchste Harmonische | Grundfrequenz Klirrfakkor (=)
ur Harmenische | 19 3 3,0020013k 0,3616
Signale exportieren (Klirrf akbor) SIMAD (dB) Klirrfakkor+Rauschen
Eingangssignal ™ il il

Abbildung 2-3. Registerkarte “Schritteinstellungen” fiir den Schritt “Verzerrung”

Auf der Seite Konfiguration der Registerkarte Schritteinstellungen
zeigt das Feld Signale exportieren (Klirrfaktor) an, dass mit dem
Schritt “Verzerrung” das Eingangssignal exportiert wird. Der Graph
Exportiertes Signal zeigt eine Vorschau des Signals an. Ausgegebe-
nes Leistungsspektrum weist darauf hin, dass der Schritt ein
Leistungsspektrum des Signals erstellt, um es in ein Frequenzspektrum
umzuwandeln. Der Bereich Messergebnisse zeigt die Grundfrequenz
und den Klirrfaktor des Signals an. Der Schritt erzeugt das exportierte
Signal und drei Messergebnisse: das Spektrum, den Klirrfaktor und die
Grundfrequenz des urspriinglichen Eingangssignals.
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Wenn die Kontexthilfe nicht auf der rechten Bildschirmhilfte ange-
zeigt wird, klicken Sie auf Hilfe»Kontexthilfe. Darauthin sollten alle
in der Hilfe enthaltenen Informationen zu einem Schritt angezeigt
werden.

In der oberen Hilfte der Kontexthilfe werden Informationen zum
Schritt selbst angezeigt und in der unteren Hilfte sehen Sie Angaben
zu einem bestimmten Parameter des Schritts, wenn Sie den Cursor
darauf fithren. Bewegen Sie den Cursor zum Parameter Klirr-
faktor (%), um Informationen dazu anzuzeigen.

Wihlen Sie auf der Registerkarte Konfiguration aus dem Pulldown-
Menii Signale exportieren (Klirrfaktor) die Option Grundschwin-
gung aus.

Der Graph Ausgegebenes Leistungsspektrum zeigt nun nicht mehr
das Frequenzbereichsspektrum des gesamten Signals, sondern nur
noch der Grundschwingung an. Das vom Schritt “Verzerrung” ausge-
gebene Signal und der Graph des Ausgangs Exportiertes Spektrum
in der Datenansicht werden entsprechend angepasst.

Wihlen Sie aus dem Pulldown-Menii Signale exportieren (Klirrfak-
tor) die Option Nur Harmonische aus.

Der Graph Ausgegebenes Leistungsspektrum auf der Registerkarte
Schritteinstellungen und der Graph des Ausgangs auf der Register-
karte Datenansicht zeigen nun das Spektrum der Harmonischen des
Eingangssignals an.

Klicken Sie in der Projektansicht den Schritt “Amplitude und Pegel”
an.

Das Dialogfeld Schritteinstellungen zeigt nun die Einstellungen zum
Schritt “Amplituden und Pegel” an.
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6. Waibhlen Sie die Registerkarte Eingabe/Ausgabe, so dass eine Liste der
moglichen Ein- und Ausgabesignale fiir diesen Schritt angezeigt wird
(vgl. Abbildung 2-4).

Eingangssignal

1,5- —
SDDn::
-500m -
=il =
-1,5- 0 H | ] I
4m Sm

1] im 2m 3m
Zeit Amplitude auto-skalieren

Amplitude
=
1

Eingabe /Ausgabe Konfiguration

: : DC-Wert ausgeben
el g Effektivmert ausgeben
m Distorted Sinewave. txt ¥ [ Pasitiven Spitzenwert ausgeben
|:| Meqgativen Spitzenwert ausgeben
|:| Spitze-Spitze-Wert ausgeben

Abbildung 2-4. Registerkarte “Schritteinstellungen” des Schritts
“Amplituden und Pegel”

7. Aktivieren Sie die Optionen Positiven Spitzenwert ausgeben, Nega-
tiven Spitzenwert ausgeben und Spitze-Spitze-Wert ausgeben, so
dass diese drei Werte ermittelt werden.

In der Projektansicht erscheinen nun drei zusitzliche Ausgénge.
8.  Wechseln Sie zur Datenansicht.

9. Ziehen Sie die drei neuen Ausginge von der Projektansicht in die
Tabelle Legende. Die neuen Ausgaben werden dann im benachbarten
Graphen angezeigt.

@ Hinweis Wenn das Projekt bereits fiir lingere Zeit lduft, sollten Sie es eventuell anhalten
und neu starten, um alle skalaren Signale im Graphen anzuzeigen. Signale in Graphen
werden kumulativ aufgebaut. Neu hinzugefiigte Signale enthalten daher entsprechend
weniger Werte.

Erste Schritte mit LabVIEW SignalExpress 2-8 ni.com



Kapitel 2 Arbeit mit Projekten

10. Klicken Sie auf die Schaltfliche Stopp, um das Projekt anzuhalten.

Beim Anklicken der Stopp-Schaltfliche beendet das Projekt noch den
letzten Durchlauf und hilt dann an. Wenn Sie auf den Pfeil der
Stopp-Schaltfliche klicken und Abbrechen wihlen, wird das Projekt
mit sofortiger Wirkung gestoppt, ohne die noch ausstehenden Arbeits-
schritte abzuwarten.

11. Klicken Sie auf Datei»Speichern unter und speichern Sie das Projekt
unter dem Namen My First Project.seproj im Verzeichnis
SignalExpress\Examples\Tutorial.

12. SchlieBen Sie das Projekt iiber Datei»Projekt schlieen.

Sortieren, Verschieben und Loschen von Schritten

Die meisten Schritte in Projekten von LabVIEW SignalExpress erfordern
Eingangsdaten. Schritte konnen nur mit Signalen arbeiten, die von vorhe-
rigen Schritten in der Projektansicht ausgegeben wurden. Daher kann die
Reihenfolge der Schritte in der Projektansicht die Funktionsfiahigkeit von
Projekten beeinflussen.

Fiir Schritte mit einer Seite Eingabe oder Eingabe/Ausgabe auf der Regi-
sterkarte Schritteinstellungen werden im Menii Eingangssignal nur vom
vorherigen Schritt ausgegebene Signale angezeigt, die kompatibel sind.
Sobald das Ausgabesignal eines Schritts am Eingang des nichsten anliegt,
werden die Schritte voneinander abhingig und nacheinander mit der glei-
chen Rate ausgefiihrt. Der zweite Schritt kann erst beginnen, wenn durch
den ersten Schritt ein Signal erzeugt wurde.

Sie konnen die Schritte in der Projektansicht nach oben oder unten ziehen.
Zum Loschen eines Schritts klicken Sie ihn in der Projektansicht mit der
rechten Maustaste an und wihlen Sie aus dem Kontextmenii die Option
Loschen aus. Allerdings 4ndert sich beim Verschieben oder Loschen eines
Schritts der Status des Signals. Beim Loschen eines Schritts, auf dessen
Ausgangssignal ein anderer Schritt angewiesen ist, funktioniert das Projekt
beispielsweise nicht mehr und in der Projektansicht erscheint eine entspre-
chende Fehlermeldung. Sie konnen Schritte innerhalb eines Projekts auch
ausschneiden, kopieren oder einfiigen, indem Sie die Tastenkombinationen
<Strg + X>, <Strg + C> und <Strg + V> driicken oder einen Schritt in der
Projektansicht anklicken und die Option Ausschneiden, Kopieren, Vor
markiertem Schritt einfiigen oder Nach markiertem Schritt einfiigen
auswihlen.
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Umgang mit Fehlern und Warnungen

[T

Bei einem Fehler wihrend eines laufenden Projekts wird durch eine Feh-
leranzeige (vgl. Abbildung links) in der Projektansicht der Schritt
angezeigt, bei dem der Fehler aufgetreten ist. Wenn Sie den fehlerhaften
Schritt doppelt anklicken, erscheint am unteren Rand der Registerkarte
Schritteinstellungen eine Kurzbeschreibung des Fehlers. Die vollstidndige
Beschreibung wird beim Anklicken der Schaltfliche Details neben der
Fehlermeldung angezeigt.

LabVIEW SignalExpress protokolliert alle Fehler und Warnungen wih-
rend der Ausfiihrung eines Projekts auf der Registerkarte Ereignis-
protokoll. Wihlen Sie zur Anzeige der Registerkarte Ereignisprotokoll
die Option Ansicht»Ereignisprotokoll. Weitere Informationen zu Fehlern
und Warnungen finden Sie in der Hilfe zu LabVIEW SignalExpress, indem
Sie Hilfe»LabVIEW-SignalExpress-Hilfe auswihlen, auf die Register-
karte Suchen klicken und das Stichwort Fehler eingeben.
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In LabVIEW SignalExpress konnen Signale ohne Programmierung gene-
riert und analysiert werden. In diesem Kapitel erfahren Sie, wie in
LabVIEW SignalExpress mit Signalen gearbeitet wird. Sie lernen, wie
Signale grafisch dargestellt, aus Dateien importiert, interaktiv ausgerichtet,
verglichen und in Dateien gespeichert werden.

Graphisches Darstellen von Signalen

h Meue Anzeige

Gehen Sie zum Darstellen der Signale in einem Beispielprojekt und zum
visuellen Untersuchen der Signale anhand von Cursorn wie folgt vor:

1. Klicken Sie auf Datei»Projekt 6ffnen, wechseln Sie zum Verzeichnis
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf
Signals.seproj. In diesem Projekt wird der Schritt “Analoges
Signal erstellen” so konfiguriert, dass er ein Rechtecksignal ausgibt,
und der Schritt “Filter” wird auf einen Butterworth-Tiefpass
eingestellt.

2. Ziehen Sie den Ausgang step signal des Schritts “Analoges Signal
erstellen” in die Datenansicht.

3. Ziehen Sie den Ausgang filtered step des Schritts “Filter” in die
Datenansicht.

Da das step signal und das Signal filtered step Zeitbereichssignale
sind, erscheinen sie im selben Graphen. Wenn Sie zwei Signale unter-
schiedlichen Typs in denselben Graphen ziehen, erstellt LabVIEW
SignalExpress automatisch eine neue Anzeige.

4. Klicken Sie auf die Schaltfliche Anzeige hinzufiigen (vgl. Abbildung
links), damit eine neue Anzeige erzeugt wird.

5. Ziehen Sie den Ausgang filtered step des Schritts “Filter” in die neue
Anzeige.
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6. Klicken Sie die neue Anzeige mit der rechten Maustaste an und und
wihlen Sie aus dem Kontextmenii die Option Sichtbare Objekte»
Cursor aus, so dass zwei interaktive Cursor eingeblendet werden (vgl.
Abbildung 3-1).

& C:\Programme\...\Signals.seproj * - LabVIEW SignalExpress E]@
Datei EBsarbeiten Ansicht ‘Werkzeuge  Schritt hinzufiigen Bedienen Datenansicht Fenster  Hilfe

@) schritt hinzufigen €% Ausfithren | @ Aufnahme 55

E3 Projekt ~ ¥ % | {5 patenansicht %
@ ‘ Anzsigen | Aufnehmen V‘ % Heus Anzeige B Eigenschaften...
Anzeige 1

2,2-

b' Analoges Signal erstellen
Step Signal 1

[» 28 step signal

I- i Filter
Step Signal 1

M % step signal -
1b |5 filtered step

i i i
2m 2,5m 3,5m 3,99m

BEm Zeit ()
Anzeige 2
z,2-

Inaktiv

53 Protokolle
{73 Momentaufnahmen

Spannung {Y)

i |
2m 2,5m

o S0t 4
B®Mm Zeit {s)
filtered step «1: Im vl Dx: Zm 1j0xc: 500
filtered step %21 3m v2: 1,99999 Dy: 1,99999 DyjDx: 999,995

Abbildung 3-1. Signals.seproj

Wenn Sie an den Cursorn ziehen, zeigt LabVIEW SignalExpress in der
Cursor-Tabelle unten in der Datenansicht die x- und y-Werte der
Cursor an.

7. Klicken Sie auf Datei»Speichern unter und speichern Sie das Projekt
unter dem Namen My Signals.seproj im Verzeichnis
SignalExpress\Examples\Tutorial.

Importieren von Signalen aus Dateien

Signale konnen aus Standarddateiformaten wie ASCII (durch Kommata
oder Tabulatoren gegliedert) oder LabVIEW-Dateien fiir Messwerte

(* . 1vm-Dateien) importiert werden. Ebenso konnen simulierte Signale von
Programmen zur Entwurfsautomatisierung (wie SPICE) einbezogen
werden.
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Zum Importieren eines Signals aus einer Datei gehen Sie wie folgt vor:

1.

Klicken Sie mit der rechten Maustaste in die Projektansicht und
wihlen Sie Signale laden/speichern»Analoge Signale»Aus
ASCII-Datei laden aus dem Kontextmenii, um der Projektansicht den
Schritt “Aus ASCII-Datei laden” hinzuzufiigen. Daraufhin wird die
Registerkarte Schritteinstelungen fiir den Schritt angezeigt. Der
Schritt liest die Signale in der ASCII-Datei und stellt sie grafisch dar.

@ Hinweis Schritte konnen iiber das Menii Schritt hinzufiigen, die Palette Schritt hinzu-
fiigen oder das Kontextmenii der Projektansicht erstellt werden.

2.

© National Instruments Corporation

Klicken Sie auf der Registerkarte Schritteinstellungen auf die
Schaltfldche “Durchsuchen” (vgl. Abbildung links). Wechseln Sie
anschlieBend zum Verzeichnis SignalExpress\Examples\
Tutorial und klicken Sie die Datei Step Response. txt doppelt an.

In der Spalte 1 der Dateivorschau werden die Zeitwerte und in
Spalte 2 die tatsdchlichen Spannungswerte des Signals angezeigt.

Wechseln Sie auf der Registerkarte Schritteinstellungen zur Seite
Signale importieren, um die Signale der Datei anzuzeigen.

Aktivieren Sie die Option Spalte 2, um das entsprechende Signal zu
importieren, und deaktivieren Sie Spalte 1.

Auf der Registerkarte Schritteinstellungen wird nun unter Impor-
tiertes Signal eine Vorschau des Signals angezeigt.

Wihlen Sie aus dem Pulldown-Menii x-Eingangswerte die Option
Spalte 1 aus, um die Werte auf der x-Achse entsprechend einzustellen.

Wechseln Sie zur Datenansicht.

Erweitern Sie in der Projektansicht den Ausgang Step Response.txt
des Schritts “Aus ASCII-Datei laden”.

Klicken Sie mit der rechten Maustaste auf den Ausgang Spalte 2 und
wiihlen Sie aus dem Kontextmenii die Option Umbenennen.

Geben Sie step response ein und driicken Sie <Enter>, um den
neuen Namen zu iibernehmen.
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Arbeit mit Signalen

10. Ziehen Sie den neuen Ausgang step response des Schritts “Aus
ASCII-Datei laden” in die untere Anzeige der Datenansicht.

Das Signal filtered step dhnelt der steigenden Flanke von step
response (vgl. Abbildung 3-2).

£
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Abbildung 3-2. Signals of Signals.seproj

11. Speichern Sie das Projekt iiber Datei»Projekt speichern.

Ausrichten und Vergleichen von Signalen

Obwohl sowohl am Signal filtered step als auch am Signal step response
ein Uberschwingen an der steigenden Flanke zu verzeichnen ist, lisst sich
die Ahnlichkeit zwischen beiden nur schwer abschitzen, da die Si gnale aus
unterschiedlichen Quellen stammen und in Amplitude und Zeit nicht iden-
tisch sind. Sie konnen die Signale jedoch mit dem Schritt “Interaktive
Ausrichtung” aneinander ausrichten und auswéhlen, welche Angaben fiir
das Projekt eine Rolle spielen sollen.
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Zum Ausrichten zweier Signale im Projekt My Signals.seproj gehen
Sie wie folgt vor:

1.

Erweitern Sie den Ausgang Step Response.txt, klicken Sie mit der
rechten Maustaste auf den den Ausgang step response und wihlen Sie
Senden an»Verarbeitung»Analoge Signale»Interaktive Ausrich-
tung aus dem Kontextmenii, um das Signal step response vom Schritt
“Aus ASCII-Datei laden” in den Schritt “Interaktive Ausrichtung” zu
iibertragen.

Darauthin werden die zwei neuesten Signale des Projekts als Ein-
gangssignale ausgewdhlt und im Graphen auf der Registerkarte
Schritteinstellungen dargestellt (vgl. Abbildung 3-3).
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Abbildung 3-3. Schritteinstellungen fiir “Interaktive Ausrichtung”

Beim Hinzufiigen von Schritten zu einem Projekt wéhlt LabVIEW
SignalExpress die Eingangssignale je nach Signaltypen, mit denen der
Schritt arbeitet. Der Schritt “Interaktive Ausrichtung” funktioniert bei-
spielsweise nur mit Signalverldufen im Zeitbereich. Daher werden fiir
den Schritt die zwei letzten Zeitbereichssignale ausgewihlt, die im
Projekt erstellt wurden.
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@ Hinweis Um die Eingangssignale eines Schritts zu dndern, wihlen Sie aus dem
Pulldown-Menii auf der Seite Eingabe oder Eingabe/Ausgabe der Registerkarte
Schritteinstellungen ein anderes Signal aus oder klicken Sie auf den Pfeil neben den
Schritteingangsnamen in der Projektansicht.

2.

Klicken Sie im Graphen Eingangssignale das rote Signal an und
ziehen Sie es an eine andere Stelle im Graphen. Darauthin wird der
Graph Signal nach Vergleich aktualisiert und der berechnete Unter-
schied zwischen beiden Signalen angezeigt.

Sie konnen das Signal verschieben, aufziehen und stauchen.

Versuchen Sie, die steigenden Flanken der beiden Signale in eine Linie
zu bringen, indem Sie das Signal im Graphen verschieben. Klicken Sie
ein Signal an, um einen Ankerpunkt zu setzen, und ziehen Sie bei
gedriickter <Alt>-Taste am Signal, um es auf der x- oder y-Achse um
den Ankerpunkt zu dehnen.

Auf der Seite Ausrichtung der Registerkarte Schritteinstellungen
werden automatisch die Verstiarkung (der Faktor) und der Offset (Sum-
mand) fiir den x- und y-Wert angezeigt.

Wihlen Sie aus dem Pulldown-Menii Modus die Option Autom.
Schritt aus, um die Signale in eine Linie zu bringen. LabVIEW
SignalExpress berechnet die Ausrichtung mithilfe integrierter
Algorithmen.

Der Graph Signal nach Vergleich auf der Registerkarte Schrittein-
stellungen zeigt den Unterschied zwischen den beiden Signalen an.

Aktivieren Sie auf der Seite Eingabe/Ausgabe die Option Ausgerich-
tete Signale ausgeben, um die Signale als Ausgangsgrofen des
Schritts hinzuzufiigen.

Wechseln Sie zur Datenansicht.

Klicken Sie auf die Schaltfliche Neue Anzeige, um eine dritte
Anzeige hinzuzufiigen.

Ziehen Sie die Ausgangssignale Bezugssignal ausgerichtet und Test-
signal ausgerichtet des Schritts “Interaktive Ausrichtung” in den
neuen Graphen, um die ausgerichteten Signale anzuzeigen.

Speichern Sie das Projekt tiber Datei»Projekt speichern.
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Signaltypen in LabVIEW SignalExpress

Einige Schritte, zum Beispiel der Schritt “Arithmetik”, arbeiten mit ver-
schiedenen Signaltypen. Sie konnen mit dem Schritt “Arithmetik”
Berechnungen an Zeit- und Frequenzbereichssignalen vornehmen. Je nach
ausgewihltem Eingangssignal passt sich der Schritt entsprechend an.
Wenn Sie zum Beispiel zwei Zeitbereichssignale addieren, werden nur die
Amplituden addiert. Bei zwei Frequenzbereichssignalen addiert LabVIEW
SignalExpress dagegen die entsprechende Phasenverschiebung.

Weitere Informationen zu Signaltypen finden Sie in der Hilfe zu LabVIEW
SignalExpress, indem Sie Hilfe»LabVIEW SignalExpress Hilfe auswih-
len, auf die Registerkarte Suchen klicken und das Stichwort Signaltypen
eingeben.

Exportieren und Drucken von Signalen

Mithilfe von LabVIEW SignalExpress konnen Sie Signale beschreiben und
in anderen Programmen weiter analysieren. In diesem Abschnitt lernen Sie,
wie Signale exportiert (z. B. in eine ASCII-Datei), an Microsoft Excel
tibertragen, gedruckt oder mit der Dokumentationsfunktion von LabVIEW
SignalExpress beschrieben werden.

Speichern von Signalen in Dateien

€ Schritt hinzufiigen

Zum Speichern eines Signals aus dem Projekt My Signals.seproj in
einer Datei gehen Sie wie folgt vor:

1. Zur Anzeige der Palette Schritt hinzufiigen klicken Sie die Schaltfli-
che Schritt hinzufiigen an (vgl. Abbildung links).

2. Waibhlen Sie Signale laden/speichern»Als ASCII/LVM speichern,
um diesen Schritt der Projektansicht hinzuzufiigen. Daraufhin wird die
Registerkarte Schritteinstellungen fiir den Schritt “Als ASCII/LVM
speichern” angezeigt.

3. Kilicken Sie auf der Registerkarte Schritteinstellungen auf die Seite
Signale und wihlen Sie aus dem Pulldown-Menii Eingangsdaten die
Option filtered step aus.

4. Geben Sie auf der Seite Datei-Einstellungen an, wo die erstellte Text-
datei gespeichert werden soll. Klicken Sie neben dem Feld Pfad zur
Exportdatei auf die Schaltfliche Durchsuchen, wechseln Sie zum
Verzeichnis SignalExpress\Examples\Tutorial und geben Sie
filtered signal.txt als Dateinamen an.

© National Instruments Corporation 3-7 Erste Schritte mit LabVIEW SignalExpress



Kapitel 3 Arbeit mit Signalen

5. Wihlen Sie aus dem Pulldown-Menii Bei vorhandener Datei die
Option Uberschreiben aus.

6. Wihlen Sie aus dem Pulldown-Menii Typ der Exportdatei die Option
Allgemeine ASCII-Datei (*.txt) aus.

Mit dem Schritt “Signale laden/speichern” konnen Sie bei jeder Aus-
fiihrung des Projekts Daten in Dateien speichern.

7. Klicken Sie auf den Pfeil der Schaltfliche Ausfiihren und wihlen Sie
Einmal ausfiihren, um das Projekt zu starten und das erzeugte Signal
in der angegebenen ASCII-Datei zu speichern.

Speichern Sie das Projekt iiber Datei»Projekt speichern.
9. SchlieBen Sie das Projekt iiber Datei»Projekt schliefSen.

10. Offnen Sie die Datei filtered signal.txt in einem Texteditor,
um die Werte des Signals anzuzeigen. Mithilfe des Schritts “Aus
ASCII-Datei laden” konnen die Signale wieder in ein Projekt in
LabVIEW SignalExpress importiert werden.

Exportieren von Signalen nach Microsoft Excel

Um Signaldaten nach Microsoft Excel zu exportieren, starten Sie Excel und
ziehen Sie das Ausgabesignal eines Schritts in LabVIEW SignalExpress in
eine Excel-Tabelle. Sie konnen auch mit der rechten Maustaste in die
Datenansicht klicken und die Option Exportieren in»Microsoft Excel
wihlen, um alle Daten der Anzeige zu importieren.

Drucken von Signalen

Zum Drucken eines Graphen 6ffnen Sie die Datenansicht und wihlen Sie
die Option Datei»Drucken»Datenansicht drucken.

Erstellen von Protokollen in LabVIEW SignalExpress

Uber Ansicht»Projektdokumentation wird die Registerkarte Projektdo-
kumentation geoffnet. Hier konnen Sie ein Projekt mithilfe von Text und
Abbildungen wie Graphen beschreiben. Wenn Sie ein Signal von der Pro-
jektansicht in die Registerkarte Projektdokumentation ziehen, wird es
darin grafisch dargestellt. Wird das Projekt noch ausgefiihrt, wird auch der
Graph in der Projektdokumentation automatisch aktualisiert.

Zum Drucken der Dokumentation wechseln Sie zur Registerkarte Projekt-
dokumentation und wihlen Sie Datei»Drucken»Dokumentation
drucken oder klicken Sie auf die Schaltfliche Dokumentation drucken.
Zum Umwandeln der Dokumentation in das HTML-Format wechseln Sie
zur Registerkarte Projektdokumentation und wihlen Sie Datei»
Exportieren»Dokumentation als HTML-Datei speichern.
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Mit LabVIEW SignalExpress konnen Sie Messergebnisse aufzeichnen und
auswerten. Sie konnen alle Arten von Zeitbereichssignalen bzw. Werten

mit doppelter Genauigkeit sowie im vorzeichenlosen 32-Bit- und im boo-
leschen Format protokollieren. Auflerdem konnen Sie protokollierte Werte
analysieren und verarbeiten, indem Sie Analyseschritte darauf anwenden.

In diesem Kapitel lernen Sie, wie Werte mit den entsprechenden Funktio-
nen in LabVIEW SignalExpress protokolliert werden. Sie erfahren, wie ein
angegebenes Signal aufgenommen, wiedergegeben und mit den Analyse-
schritten ausgewertet wird. AuSerdem wird beschrieben, wie mit der
Registerkarte Aufnahmeoptionen Signale nach bestimmten Start- oder
Stoppbedingungen protokolliert werden.

Aufnehmen eines Signals

& 2sufnabme

Mit der Schaltfliche Aufnehmen wird die Protokollierung konfiguriert.

Zum Auswihlen und Aufnehmen eines Signals gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt 6ffnen, wechseln Sie zum Verzeichnis
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf
Logging.seproj.

In diesem Projekt wird mit dem Schritt “Analoges Signal erstellen” ein
Signal anhand einer Formel erstellt.

2. Klicken Sie auf die Schaltfliche Aufnahme (vgl. Abbildung links),
um das Dialogfeld Signalauswahl fiir Protokollierung zu 6ffnen.
Das Dialogfeld Signalauswabhl fiir Protokollierung zeigt alle Signale
im Projekt an, die aufgenommen werden konnen. Sie konnen ein

Signal oder mehrere Signale auswéhlen. AuBerdem kann das Protokoll
hier benannt und beschrieben werden.

3. Aktivieren Sie die Option signal, um das berechnete Signal des
Schritts “Analoges Signal erstellen” aufzunehmen.

4. Klicken Sie auf die Schaltfliche OK, um das Dialogfeld Signalaus-
wabhl fiir Protokollierung zu schlieffen und die Aufnahme zu
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.

beginnen. Die Aufnahme lduft bis zum Anklicken der Schaltflache
Stopp.

Klicken Sie auf die Schaltfliche Stopp (vgl. Abbildung links), um die
Aufnahme anzuhalten. Wenn zuvor noch kein Signal aufgenommen
wurde, wird das Dialogfeld Erstes Protokoll vollstindig angezeigt.
Klicken Sie auf OK.

Die aufgezeichneten Daten werden im Fenster Protokolldaten im
unteren Bereich der Projektansicht angezeigt (vgl. Abbildung 4-1).

=53 Protokolle
+-y 25.04.2008 12:19:35
l__\-_a Momentaufnahmen

Abbildung 4-1. Fenster “Protokolldaten”

Per Voreinstellung kennzeichnet LabVIEW SignalExpress die Werte
mit dem Datum und der Zeit, zu der sie aufgezeichnet wurden.

LabVIEW SignalExpress speichert protokollierte Werte in einer Datei
im * . tdms-Format in dem unter Optionen angegebenen Verzeichnis.

Zur Auswabhl eines Verzeichnisses fiir protokollierte Werte wihlen Sie
Werkzeuge»Optionen und klicken Sie auf Protokollierung. Hier
finden Sie auch alle anderen Einstellungen zur Protokollierung.

Klicken Sie anschliefend zum Verlassen des Dialogfelds Optionen
auf OK.

Klicken Sie auf Datei»Projekt speichern unter und speichern Sie das
Projekt unter dem Namen My Logging . seproj im Verzeichnis
SignalExpress\Examples\Tutorial.

Anzeigen aufgezeichneter Signale

Zum Anzeigen der aufgezeichneten Werte gehen Sie wie folgt vor:

1.

Wenn die Datenansicht ausgeblendet ist, wihlen Sie Ansicht»
Datenansicht.

Unter Protokolldaten wird eine Liste aller aufgezeichneten Werte des
Projekts angezeigt. Markieren Sie das Protokoll, das Sie gerade im
Fenster Protokolldaten erstellt haben, und ziehen Sie es in die Daten-
ansicht. In der Datenansicht werden die Protokolldaten und eine
Vorschau angezeigt (vgl. Abbildung 4-2). Das Signal in der Datenan-
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sicht kann sich je nach Lange der Aufzeichnung vom Signal in
Abbildung 4-2 unterscheiden.

€

Datei Bearbeiten Ansicht ‘Werkzeuge  Schritt hinzufiigen  Bedienen  Dateransicht Fenster Hife
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Abhildung 4-2. Logging.seproj

In der Vorschau kénnen Sie in die Datenansicht hineinzoomen oder
sich darin durch Hin- und Herziehen der Maus verschiedene
Abschnitte ansehen. Die Vorschau wird bei der Anzeige aufgezeichne-
ter Werte immer als erstes geoffnet. Fiir aktuelle oder andere nicht
aufgezeichnete Werte konnen Sie die Vorschau 6ffnen, indem Sie die
Datenansicht mit der rechten Maustaste anklicken und Sichtbare
Objekte» Vorschau auswihlen.

Zum VergroBern der aufgezeichneten Werte klicken Sie auf die Schalt-
fliche Heranzoomen neben der Vorschau. Die Cursor in der Vorschau
deuten auf die Werte, die gerade in der Datenansicht angezeigt wer-
den. Mit der Bildlaufleiste unter der Vorschau konnen Sie durch die
Werte scrollen. Durch Anklicken und Ziehen der Cursor konnen Sie
mehr oder weniger Werte anzeigen.
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Protokollieren von Signalen mit festgelegten Start- und
Stoppbedingungen

Mit Hilfe von Start- und Stoppbedingungen konnen Sie einen Zeitraum
festlegen, wihrend dessen LabVIEW SignalExpress Signale aufzeichnen
soll. Gehen Sie dazu wie folgt vor:

1.  Wenn die Registerkarte Aufnahmeoptionen ausgeblendet ist, wihlen
Sie Ansicht»Aufnahmeoptionen.

2. Wihlen Sie auf der Registerkarte Aufnahmeoptionen aus der Liste
Kategorie die Option Signalauswahl aus.

3. Setzen Sie dann neben dem Signal in der Spalte Aufnahme ein Hak-
chen (vgl. Abbildung 4-3).

Kategorie Signalauswahl
Signalauswahl
Zusammenfassung Kanalname Aufnahme
Starthedingungen sianal
Stoppbedingungen L\z ® 4
Alarme
Ereignisse
Protokalierungsstatus

aufnahme EHEIN

Festplattenangaben [
(beleat: 4 GB - Frei: 36 GB)

Geschatzte ProtokollgriBe:
Werbleibende Zeit:

Akfuelles Protakoll begann:

Abbildung 4-3. Signalauswahl

Die Schaltfliche Aufnahme wandelt sich darauthin in Aufnahme
wihrend Ausfithrung um (vgl. Abbildung links). Die Schaltfldche
Aufnahme wihrend Ausfithrung muss angeklickt sein. Wenn Auf-
nahme wihrend Ausfithrung gedriickt ist, zeichnet LabVIEW
SignalExpress das ausgewdhlte Signal nach Anklicken von Ausfiih-
ren auf.

‘f,s Aufnahme wahrend Ausfihrung
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Wihlen Sie auf der Registerkarte Aufnahmeoptionen aus der Liste
Kategorie die Option Startbedingungen aus.

Klicken Sie auf die Schaltfliche Hinzufiigen unter der Liste der
Startbedingungen, um eine Bedingung fiir die Protokollierung
festzulegen.

a. Stellen Sie sicher, dass im Pulldown-Menii Bedingungsart die
Option Signal-Trigger ausgewdhlt ist. So wird festgelegt, dass
LabVIEW SignalExpress die Aufnahme beginnt, wenn das Ein-
gangssignal die angegebene Bedingung erfiillt.

b. Im Pulldown-Menii Signal muss signal ausgewaihlt sein.

c. Unter Trigger-Typ muss Pos. Steigung ausgewihlt sein. Mit der
Aufnahme soll also begonnen werden, wenn das Signal die ange-
gebene Flanke bei positiver Steigung erreicht.

d. Geben Sie 1 unter Trigger-Wert ein. Die Protokollierung beginnt
dann beim Wert 1 einer steigenden Flanke.

Wihlen Sie auf der Registerkarte Aufnahmeoptionen aus der Liste
Kategorie die Option Stoppbedingungen aus.

Klicken Sie auf die Schaltfliche Hinzufiigen unter der Liste der
Stoppbedingungen, um eine Bedingung fiir die Protokollierung
festzulegen.

a. Stellen Sie sicher, dass im Pulldown-Menii Bedingungsart die
Option Dauer ausgewéhlt ist, um anzugeben, dass die Aufnahme
nach Ablauf einer bestimmten Zeit angehalten werden soll.

b. Geben Sie als Dauer den Wert 5 ein. Das Signal wird dann nach
Erfiillen der Startbedingung fiinf Sekunden lang aufgezeichnet.

Klicken Sie auf die Schaltfliche Ausfiihren (vgl. Abbildung links).
LabVIEW SignalExpress beginnt dann beim Ubersteigen von Pegel 1
an einer steigenden Flanke mit der Prokollierung und zeichnet das
Signal fiinf Sekunden lang auf.

Folgende Anzeigen werden im Bereich Protokollierungsstatus der
Registerkarte Aufnahmeoptionen wihrend der Ausfiihrung des Pro-
jekts aktualisiert:

* Aufnahme lautet EIN, wenn das Signal die Startbedingung erfiillt
und die Protokollierung lauft.

* Festplattenangaben zeigt an, wie viel Festplattenspeicher fiir die
Protokollierung noch frei ist.

*  Geschiitzte ProtokollgroBe zeigt die GroBe der Protokolldatei
an.
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*  Verbleibende Zeit zeigt die Zeit an, die fiir die Protokollierung
noch zur Verfiigung steht, bis die Festplatte voll ist.

¢ Aktuelles Protokoll begann zeigt die Startzeit des aktuellen Pro-
tokolls an.

Die Seiten Startbedingungen, Stoppbedingungen, Alarme und
Ereignisse der Registerkarte Aufnahmeoptionen enthalten auch
Anzeigen fiir den Status von Start- und Stoppbedingungen, Alarmen
und Ereignissen.

Analysieren aufgezeichneter Signale

Nach dem Aufzeichnen eines Signals konnen Sie dieses wieder abspielen
und mit Analyseschritten auswerten. Zum Analysieren eines aufgezeichne-
ten Signals gehen Sie wie folgt vor:

1. Suchen Sie das Pulldown-Menii Arbeitsbereich iiber der Projektan-
sicht (vgl. Abbildung 4-4). Klicken Sie auf den Pfeil und wéhlen Sie
Wiedergabe aus, um in den Wiedergabebereich zu wechseln.

@J | Anzeigen | Aufnehmen w |

Abbildung 4-4. Pulldown-Menii zur Auswahl des Arbeitshereichs

In Arbeitsbereichen konnen Sie im selben Projekt mehrere Arbeits-
schritte von LabVIEW SignalExpress ausfiihren. So konnen Sie z. B.
Daten erfassen, Signale verarbeiten, Daten aufzeichnen und Messun-
gen an den aufgezeichneten Daten vornehmen, ohne dazu ein neues
Projekt 6ffnen zu miissen. Beim Speichern eines Projekts speichert
LabVIEW SignalExpress alle Arbeitsbereiche zum Projekt in dersel-
ben Datei.

Im voreingestellten Arbeitsbereich, “Anzeigen/Aufnehmen”, konnen
Sie Messungen an Signalen durchfiihren, die Signale auswerten und
aufzeichnen. Im Wiedergabebereich kénnen im Arbeitsbereich
“Anzeigen/Aufnehmen” aufgenommene Daten als Eingangswerte fiir
eine Analyse verwendet werden.

2. Klicken Sie auf die Schaltfliche Schritt hinzufiigen (vgl. Abbildung
links) und wihlen Sie Verarbeitung»Analoge Signale»Filter.
LabVIEW SignalExpress legt an den Eingang des Schritts “Filter”
automatisch das erste aufgezeichnete Signal an.

o achritk hinzufiagen
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Wechseln Sie zur Datenansicht und ziehen Sie das Ausgangssignal
gefilterte Daten des Schritts “Filter” in die Datenansicht, um das
resultierende Signal anzuzeigen.

Klicken Sie auf die Schaltfliche Ausfiihren. In der Datenansicht
wird nun das gefilterte Signal angezeigt und LabVIEW SignalExpress
spielt die gesamte Aufzeichnung ab.

Erweiterte Wiedergabe

Auf der Registerkarte Wiedergabeoptionen konnen Sie fortgeschrittene
Optionen fiir die Datenwiedergabe konfigurieren. Die Registerkarte Wie-
dergabeoptionen zeigt eine Vorschau der aufgezeichneten Daten an und
Sie konnen daraus einen Abschnitt auswihlen, der mit den Analyseschrit-
ten ausgewertet werden soll.

1.

Wihlen Sie Ansicht»Wiedergabeoptionen, um zur Registerkarte
Wiedergabeoptionen zu wechseln (vgl. Abbildung 4-5).

Protokolliertes Signal

signal

signal

E = Start/Stopp Wiedergabezeit

El ] e

Amplitude

Startzeit (s) Stoppzeit (5} ZeitFormat
0,0000 1% 52500 % Relativ 2um Protokallbeginn e

Einstellungen zum Wiedergabeblock

Blackarifie (Samples) Anzahl an Iterationen Worschau
1000 = 528
.
Uberschneidung (%) Sample-Rate
o — 100,000k

W tteration 1 [l teration 2 llTteration 3

Letzte Iteration ignorieren,
Falls unwollskandig

[IMur ganze Intervalle wiedergeben
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Abbildung 4-5. Ansicht “Wiedergabeoptionen”
Wihlen Sie im Feld Protokolliertes Signal das signal der letzten Auf-
nahme aus.

Geben Sie als Startzeit (s) den Wert 1 ein. So werden alle Daten abge-
spielt oder ausgewertet, die eine Sekunde nach Beginn der
Aufzeichnung aufgenommen wurden.

Geben Sie als Stoppzeit (s) den Wert 4 ein. Damit werden alle Daten
bis zum Ablauf von vier Sekunden nach Aufzeichnungsbeginn abge-
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spielt oder ausgewertet. Wenn das Protokoll kiirzer als vier Sekunden
ist, passen Sie die Stoppzeit (s) entsprechend an.

5. Klicken Sie im Feld Protokolliertes Signal mit der rechten Maustaste
auf signal (zweite Aufnahme) und wihlen Sie Aktivieren aus dem
Kontextmenii, um das Signal als aktives Protokoll festzulegen.

@ Hinweis Sie konnen auch ein Protokoll im Fenster Protokolldaten mit der rechten
Maustaste anklicken und Protokoll aktiv schalten aus dem Kontextmenii wihlen.

6. Wechseln Sie zur Datenansicht. Der Graph in der Datenansicht wird
automatisch aktualisiert, so dass nach der Aktivierung des zweiten
Protokolls das darin aufgezeichnete Signal angezeigt wird.

7. Klicken Sie auf die Schaltfliche Ausfiihren (vgl. Abbildung links).
£ Ausfihren LabVIEW SignalExpress filtert nun den Bereich des Signals, den Sie
in den Wiedergabeoptionen angegeben haben. Das gefilterte Signal
wird in der Datenansicht angezeigt.

In der Hilfe zu LabVIEW SignalExpress sind weitere Optionen zur Auf-
zeichnung und Wiedergabe von Daten, z. B. anhand von Alarmbedin-
gungen, beschrieben.
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Festlegen des

Mit LabVIEW SignalExpress konnen Sie Messungen mit dem so genann-
ten Sweep-Modus automatisieren, um Produktentwiirfe zu testen und zu
tiberpriifen, ob diese realen Bedingungen standhalten. In LabVIEW Signal-
Express konnen Sie beliebige Produktentwiirfe validieren. Anhand von
Sweep-Messungen konnen Sie Daten zu Produktentwiirfen tiber einen
Bereich von Konditionen hinweg gewinnen, um die Funktion der Entwiirfe
zu dokumentieren. So konnen Sie zum Beispiel die Frequenz eines ange-
legten Signals wobbeln oder eine Versorgungsspannung variieren, um
Produktentwiirfe auszutesten.

In diesem Kapitel lernen Sie, wie mit dem Sweep-Schritt in LabVIEW
SignalExpress Messungen mit variierenden Parametern vorgenommen
werden. Sie erfahren u. a., wie die Reaktion eines Filters auf eine Reihe ver-
schiedener Frequenzen gemessen wird. Es wird beschrieben, wie die
Ergebnisse der Sweep-Messung angezeigt und parallele Sweeps fiir kom-
plexe Messungen vorgenommen werden.

Messbereichs und der Ausgangsgrofien

£3 Ausfidhren

In LabVIEW SignalExpress konnen Sie Messungen durch komplexe, sich
wiederholende Messungen mit variierenden Parametern automatisieren.

Zum Festlegen eines Frequenzbereichs, mit dem ein Filter in einem Bei-
spielprojekt gewobbelt werden soll, gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt 6ffnen, wechseln Sie zum Verzeichnis
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf
Sweep.seproj.

2. Klicken Sie auf die Schaltfliche Ausfiihren (vgl. Abbildung links),
um die kontinuierliche Ausfiihrung des Projekts zu starten.

Mit dem Schritt “Analoges Signal erstellen” wird ein Sinussignal
generiert, das den Schritt “Filter” (als elliptischen Bandpassfilter kon-
figuriert) durchlduft. AnschlieBend wird mit dem Schritt “Amplitude
und Pegel” der Effektivpegel des Filters gemessen und mithilfe des
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Schritts “Formel” in Dezibel umgerechnet. Der Filterschritt soll den
Priifling simulieren, so dass das Projekt keine Hardware benétigt. Sie
konnen aber auch ein tatsdchliches Signal von einem Arbitrir- oder
Funktionsgenerator, einer Multifunktionskarte von National Instru-
ments oder das Ergebnis einer Analyse dynamischer Signale
verwenden.

Klicken Sie auf die Schaltfldche Stopp, um das Projekt anzuhalten.

4. Kilicken Sie auf die Schaltfldche Schritt hinzufiigen (vgl. Abbildung
links) und wéhlen Sie Ausfiihrungssteuerung»Sweep, um der Pro-
jektansicht den Schritt “Sweep”” hinzuzufiigen.

€ Schritt hinzufiigen

5. Klicken Sie auf der Registerkarte Schritteinstellungen auf die Schalt-
fliche Hinzufiigen. Daraufthin wird zu jedem Schritt im Projekt eine
Liste variierbarer Parameter angezeigt (vgl. Abbildung 5-1).

13 Auswahl der variierbaren Parameter

Watiierbare Parammeter

= Analoges Signal erstellen: stimulus signal {sin | A
armplitude B
Blockgrafhe (Samples)

Frequenz {Hz)
OffFsek (V)

Phase (Grad)
Sample-Rate (5)s)

= Filter: response signal
Untere Grenze

Cirdnninn ()

I oK l[ abbrechen ]

Abbildung 5-1. Auswahlfeld der variierbaren Messparameter

6. Wibhlen Sie unter Analoges Signal erstellen die Option Frequenz
(Hz) aus und klicken Sie auf OK.

Der Schritt “Sweep” umfasst den Schritt “Analoges Signal erstellen”,
der das Signal fiir die Messung mit variierenden Parametern stellt.

7. Wihlen Sie auf der Seite Sweep-Konfiguration der Registerkarte
Schritteinstellungen aus dem Pulldown-Menii Typ die Option Expo-
nentiell aus.

8. Geben Sie 1k fiir Start: Frequenz (Hz) und 40k fiir Stopp: Fre-
quenz (Hz) ein.

9. Geben Sie unter Werteanzahl den Wert 150 ein.
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Die Seite Sweep-Konfiguration sollte Abbildung 5-2 entsprechen.

Sweep-Konfiguration Sweep-Ausgang

Yariierbare Parameter:

Parametername: Schritt Betroffener Ausgang  Alias |»
Frequenz (Hz) Analoges Signal erstelle stimulus signal {sinewany
w

Konfiguration

Typ
Exponentisl

Sweep-\Werke

40k -
v

Start: Freguenz (Hz)

1k 10k

Fs
L3

Werte

Stopp: Frequenz (Hz)
40k, 2

»

WWerteanzahl

.::.-=-
150

1 1 1 1 1 I 1 1
20 40 &0 &0 100 120 140 160
Iteration

4

10.
11.

12.
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Abbildung 5-2. Registerkarte “Schritteinstellungen” fiir den Schritt “Sweep”

Mit dem Schritt “Sweep” konnen Sie fiir den Parameter Frequenz
(Hz) des Schritts “Analoges Signal erstellen” einen Bereich von
Werten festlegen, die nacheinander durchlaufen werden sollen. Der
Schritt “Analoges Signal erstellen” erzeugt dann anhand dieses
Bereichs bei jeder der Frequenzen eine Sinusschwingung. Der
Sweep-Schritt ist aber nicht auf das Wobbeln von Frequenzen
beschrinkt, sondern funktioniert auch mit anderen Schritten, sofern
deren Parameter variierbar sind.

Wechseln Sie zur Seite Sweep-Ausgabe.

Klicken Sie auf die Schaltfliche Hinzufiigen, um zu jedem Schritt
eine Liste variierbarer Parameter anzuzeigen.

Wihlen Sie den Ausgang response amplitude in dB unter Formel
und klicken Sie auf OK, um die Messung dem gewobbelten Parameter
Frequenz (Hz) gegeniiberzustellen.

Mit dem Sweep-Schritt wird um alle anderen Schritte in der Projektan-
sicht eine Schleife gelegt, in der diese wiederholt werden.
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Messungen mit variierenden Grofien

Beginnen Sie die Messung mit variierenden Parametern wie folgt:

1. Wechseln Sie zur Datenansicht und klicken Sie auf den Pfeil der
Schaltfliche Ausfithren. Wihlen Sie dann die Option Einmal
ausfiihren.

Der Ausgang stimulus signal des Graphen geht nun die Frequenzen
im angegebenen Bereich nacheinander durch.

2. Ziehen Sie das Signal response amplitude in dB vs. Frequency am
unteren Rand der Sweep-Schleife in die Datenansicht, damit das
Ergebnis der Messung angezeigt wird.

LabVIEW SignalExpress erzeugt darauthin einen neuen Graphen. Die
Messung mit variierenden Parametern ergibt ein x-y-Array, fiir das ein
gesonderter Graph bendtigt wird (vgl. Abbildung 5-3).
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{23 Projekt -~ 2 X Datenansicht | 93 Schritteinstelungen x
@ Anzeigen | Aufnehmen ~| | %m neue anzeige G Eigenschaften. .
Anzeige 1
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Abbildung 5-3. Sweep.seproj

3. Wihlen Sie erneut die Option Einmal ausfiihren.

Der Frequenzgang des Filters wird auf dem neuen Graphen dargestellt.
Der Graph zeigt die Ubertragungsfunktion des Filters an, also die
Amplitude in dB gegeniiber der Frequenz.
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@ Hinweis Per Voreinstellung werden Anzeigen in der Datenansicht zwischen den Iteratio-
nen eines Sweeps nicht geloscht. Da der Frequenzgang des Filterschritts fiir jede Iteration
gleich ist, scheint es, als wiirde der Graph mit dem Signal wihrend der Ausfiihrung des
Projekts nicht aktualisiert werden. Auf der Seite Daten des Dialogfelds Optionen kénnen
Sie festlegen, ob die Anzeigen zwischen den Iterationen eines Sweeps geloscht werden sol-
len. Wihlen Sie dazu Werkzeuge»Optionen, um das Dialogfeld Optionen anzuzeigen.

4. Kilicken Sie den Schritt “Filter” doppelt an, so dass auf der Register-
karte Schritteinstellungen die Filterspezifikationen angezeigt
werden.

Der unter Amplitudengang des Filters (dB) dargestellte Frequenz-
gang entspricht dem Graphen in der Datenansicht.

5. Klicken Sie auf Datei»Projekt speichern unter und speichern Sie das
Projekt unter dem Namen My Sweep.seproj im Verzeichnis
SignalExpress\Examples\Tutorial.

Sie konnen auch mehrere Parameter gleichzeitig variieren, indem Sie auf
der Seite Sweep-Konfiguration der Registerkarte Schritteinstellungen
des Schritts “Sweep” weitere Parameter auswéhlen. Ein Sweep mit mehre-
ren variierenden Parametern wird paralleler Sweep genannt. Wenn Sie zum
Beispiel ein Signal mit wechselnder Amplitude anlegen mochten, erzielen
Sie die hochste Messgenauigkeit, indem Sie den Eingangsbereich des
A/D-Wandlers oder der MIO-Karte mit dem Signalpegel variieren lassen.
Durch stetiges Anpassen des Eingangsbereichs des Messgerits an den
Signalpegel konnen Sie die ganze Auflosung des Geriits fiir die Messung
nutzen.

Geschachtelte Messungen mit variierenden Parametern

Ebenso konnen zwei Sweeps ineinander verschachtelt werden. So kdnnen
Sie zum Beispiel bei verschiedenen Amplituden durch die Frequenzen
eines Signals wobbeln. Sie konnen beispielsweise die Amplitude auf den
Pegel 1 setzen und alle Frequenzen durchlaufen, dann die Amplitude auf 2
setzen und alle Frequenzen durchlaufen usw. Um eine geschachtelte Mes-
sung mit variierenden Parametern durchzufiihren, klicken Sie einen
Sweep-Schritt in einem Projekt mit der rechten Maustaste an und wihlen
Sie Multi-Sweep hinzufiigen, um eine weitere Sweep-Schleife
einzufiigen.
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Kapitel 5 Messungen mit variierenden GréBen

Zum Offnen eines Beispielprojekts, in dem geschachtelte Messungen mit
variierenden Parametern demonstriert werden, gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt 6ffnen, wechseln Sie zum Verzeichnis
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf
Nested Sweep.seproj.

2. Klicken Sie zum Starten des Projekts auf die Schaltfliche Ausfiihren.

Jedes Mal, wenn die innere Sweep-Schleife durchléduft, wird die
Frequenz des anliegenden Signals gewobbelt. Mit der dufleren
Sweep-Schleife werden die obere und untere Grenzfrequenz des
Schritts “Filter” verdndert. Jede Iteration wird verzogerungsfrei im
oberen Graphen dargestellt. Im unteren Graphen erscheinen dazu die
Messergebnisse bei jeder Anderung der Grenzfrequenz (vgl.
Abbildung 5-4).
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Abbildung 5-4. Nested Sweep.seproj

3. Klicken Sie auf die Schaltfliche Stopp (vgl. Abbildung links), um das

Projekt zu beenden.
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Erweitern von
LabVIEW-SignalExpress-
Projekten durch LabVIEW

Mit den Schritten zur Erfassung, Erzeugung, Analyse oder Aufzeichung
von Daten konnen Sie mit LabVIEW SignalExpress automatisierte Mes-
sungen vornehmen. LabVIEW SignalExpress kann auf folgende Arten
durch LabVIEW erweitert werden:

Erstellen eines VIs in LabVIEW und Importieren des VIs in LabVIEW
SignalExpress als neuen Schritt. So konnen Sie die Funktionen von
LabVIEW SignalExpress beliebig erweitern.

Umwandeln eines LabVIEW-SignalExpress-Projekts in ein
LabVIEW-Blockdiagramm, um den Schritt in LabVIEW weiter
auszubauen.

Fiir die Ubungen in diesem Kapitel benotigen Sie eine LabVIEW-Version
ab7.1.

Importieren von Vis in LabVIEW SignalExpress als neue

Schritte

Mit dem Schritt “LabVIEW-VI ausfiihren” konnen Sie beliebige
LabVIEW-VIs von LabVIEW SignalExpress aus aufrufen. Dadurch sind
folgende Funktionen moglich:

© National Instruments Corporation

Steuern von GPIB-Instrumenten

Arbeit mit Hardware von National Instruments, die
LabVIEW SignalExpress nicht unterstiitzt

Arbeit mit zusitzlichen Dateiformaten
Einblenden von Bedienungsanleitungen in Popup-Dialogfeldern

Festlegen von Messalgorithmen
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Kapitel 6 Erweitern von LabVIEW-SignalExpress- Projekten durch LabVIEW

0 Schritk hinzuflioen

Gehen Sie zum Importieren eines LabVIEW-VIs mit dem Schritt
“LabVIEW-VI ausfiihren” wie folgt vor:

1.

Klicken Sie auf Datei»Projekt 6ffnen, wechseln Sie zum Verzeichnis
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf
User Step.seproj.

In diesem Projekt wird mit dem Schritt “Analoges Signal erstellen” ein
Signal erstellt.

Klicken Sie auf die Schaltfliche Schritt hinzufiigen und wihlen Sie
LabVIEW-VI ausfiihren» VI ausfiihren - LabVIEW 8.6.

Das in dieser Ubung verwendete VI wurde in LabVIEW 8.6 gespei-
chert. Sie miissen immer die Version des Schritts “LabVIEW-VI
ausfiihren” aufrufen, in der das VI gespeichert wurde.

Klicken Sie auf der Seite Einstellungen im Bereich VI auswihlen auf
die Suchschaltfldche und 6ffnen Sie das VI Limiter-Lv86.vi im
Verzeichnis LabVIEW SignalExpress\Examples\Tutorial.Das
VI “Limiter-LV86” schneidet ein Zeitbereichssignal an den in den
Schritteinstellungen festgelegten Werten ab.

Beim Importieren eines LabVIEW-VIs in LabVIEW SignalExpress
werden die Einginge des VIs als Schrittparameter und die Ausgénge
des VIs als Ausgidnge des Schritts interpretiert.

Bei den VI-Eingiingen konnen Sie festlegen, ob diese Eingangssignale
oder Parameter darstellen sollen. Ein Eingangssignal erscheint in der
Projektansicht als Eingang eines Schritts, so dass Sie dem VI von
auBen Signale zufiihren konnen. Parameter sind alle Schritteinstel-
lungen im Dialogfeld zu einem Schritt. Mit dem Sweep-Schritt
konnen Sie auch bestimmte Parameter dynamisch verdndern. Im vor-
liegenden Projekt liegt am VI ein Zeitbereichssignal an und es hat die
Parameter Upper limit und Lower limit (beides Skalarwerte).
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Das Dialogfeld Schritteinstellungen sollte wie in Abbildung 6-1
aussehen.

Einstellunasn | W1 korfiguriersn | Ausfiibrungssteusrung |

W1 auswahlen
C\Programme’fational InstrumentsiSignalExpress|Examplest Tutoriali Limiter-LV&6. vi

[Jmiesen Schritt automatisch ausfohren YI neu laden

Mame des Elements:

Time waveform in . X
Eingangssignal:

[ An Eingang anschliefien. .. ] E\.‘é sine wave -

[ fan Eingang trennen ]

W
Ausgange: Strikker Ausgabedatentyp
Clipped waveFarm out || | Zeitbereichssignal, resll £

Abbildung 6-1. Registerkarte “Schritteinstellungen” fiir Limiter-VI

4. Klicken Sie auf die Schaltfliche Ausfiihren (vgl. Abbildung links),
um das Projekt zu starten.

£ Ausfithren

5. Wechseln Sie zur Datenansicht und ziehen Sie das Signal Clipped
waveform out des Schritts “VI ausfiihren - LabVIEW 8.6” in die
Datenansicht.

6. Klicken Sie doppelt auf den Schritt “VI ausfiihren - LabVIEW 8.6,
um die Registerkarte Schritteinstellungen anzuzeigen.

7. Klicken Sie zur Anzeige des VIs auf die Seite VI konfigurieren.

Andern Sie die Werte fiir Upper limit und Lower limit. Geben Sie
beispielsweise in Upper limit den Wert 100 ein.

9. Wechseln Sie zur Datenansicht. Das Signal Clipped waveform out
wird nun in der Datenansicht den Anderungen entsprechend angezeigt.

10. Klicken Sie auf die Schaltfliche Stopp (vgl. Abbildung links), um das

Projekt zu beenden.
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11. Wihlen Sie Datei»Projekt speichern unter und geben Sie dem

Projekt den Namen My User Step.seproj.

12. Schliefen Sie das Projekt iiber Datei»Projekt schliefen.

Informationen zum Verwenden von VIs in LabVIEW SignalExpress sowie
zum Entwickeln von VIs, die gut fiir LabVIEW SignalExpress geeignet
sind, finden Sie in der Hilfe zu LabVIEW SignalExpress.

Umwandeln von LabVIEW-SignalExpress-Projekten in
LabVIEW-Blockdiagramme

LabVIEW-SignalExpress-Projekte konnen in LabVIEW-Blockdiagramme
umgewandelt werden.

@ Hinweis Zur Umwandlung eines LabVIEW-SignalExpress-Projekts in ein LabVIEW-VI
wird das LabVIEW Full Development System ab 7.1 benétigt.

Zum Umwandeln eines LabVIEW-SignalExpress-Projekts in ein
LabVIEW-Blockdiagramm gehen Sie wie folgt vor:

1.

Klicken Sie auf Datei»Projekt 6ffnen, wechseln Sie zum Verzeichnis
SignalExpress\Examples\Tutorial\Solutions und klicken
Sie doppelt auf My First Project.seproj.

Wihlen Sie Werkzeuge»Programmcode erzeugen»LabVIEW-
Blockdiagramm.

Geben Sie einen Namen und Speicherort fiir das neue VI an und
klicken Sie auf OK. LabVIEW SignalExpress erzeugt das neue VI und
offnet es in der zuletzt auf Threm Rechner gedffneten Version von
LabVIEW.

Das erzeugte LabVIEW-Blockdiagramm spiegelt den Projektablauf in
LabVIEW SignalExpress wider. Es besteht aus mehreren LabVIEW-
Express-VIs, die miteinander verbunden sind. Jedes Express-VI ent-
spricht einem Schritt im LabVIEW-SignalExpress-Projekt. Bei einem
Doppelklick auf ein Express-VI werden die gleichen Schritteinstel-
lungen wie in LabVIEW SignalExpress angezeigt. Sie konnen die
Express-VIs auch mit der rechten Maustaste anklicken und Frontpa-
nel 6ffnen auswihlen, um das Express-VI in ein LabVIEW-SubVI
umzuwandeln. Im Blockdiagramm kdnnen Sie die Ausfiihrung des VIs
sehen und das VI dndern. Die Umwandlung eines Express-VIs in ein
SubVTI ist nicht umkehrbar.

@ Hinweis Beim Umwandeln eines LabVIEW-SignalExpress-Projekts mit Datenprotokol-
lierung enthilt das erzeugte Blockdiagramm nur ein Express-VI und dieses lésst sich nicht
in ein SubVI umwandeln.
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Weitere Informationen

Weitere Informationen zu LabVIEW SignalExpress erhalten Sie durch:

LabVIEW-SignalExpress-Beispielprojekte

Zu LabVIEW SignalExpress gibt eine Vielzahl von Beispielprojekten, die
die Funktionen von LabVIEW SignalExpress veranschaulichen. Die Pro-
jekte befinden sich im Verzeichnis SignalExpress\Examples. Mithilfe
der Beispiele konnen Sie sich mit den Funktionen des Programms niher
vertraut machen oder ein passendes Beispiel als Grundlage fiir ein eigenes
Projekt verwenden.

Verwenden von Hardware mit LabVIEW SignalExpress

LabVIEW SignalExpress unterstiitzt zahlreiche Gerite von National
Instruments zur Erfassung und Erzeugung von Signalen. LabVIEW
SignalExpress arbeitet mit MIO-Karten, Karten zur Analyse dynamischer
Signale, Hochgeschwindigkeits-A/D-Wandlern sowie Arbitrir- und Funk-
tionsgeneratoren von National Instruments. Sie konnen auch mehrere
Gerite in einem System synchronisieren, indem Sie fiir alle Geréte densel-
ben Takt oder Trigger verwenden. Weitere Einzelheiten zur Verwendung
von Hardware mit LabVIEW SignalExpress finden Sie in der Hilfe zu
LabVIEW SignalExpress, die sich unter Hilfe»xLabVIEW SignalExpress
Hilfe befindet.

Online-Informationsquellen

Auf der Website ni . com/signalexpress finden Sie Beispielprojekte,
technische Beschreibungen und LabVIEW-VIs fiir das Programm.
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Technische Unterstiitzung und
professioneller Service

Auf der Website ni . com/germany finden Sie umfassende Informationen
tiber die folgenden professionellen Serviceleistungen und den technischen
Support von National Instruments:

e Support—Auf ni.com/support/d finden Sie folgende Informa-
tionsquellen und Tools:

Technische Ressourcen—Diese Website bietet Thnen Soforthilfe
bei Fragen und Problemen. Auflerdem finden Sie hier Treiber,
Updates, eine umfassende Wissensdatenbank (KnowledgeBase),
Bedienungsanleitungen, Anleitungen zur Problemlésung,
Tausende Beispielprogramme, autodidaktische Kurse und Appli-
cation Notes. Registrierte Nutzer konnen sich auch an den
Diskussionsforen auf ni . com/forums (englisch) beteiligen.
Jede im Forum eingereichte Frage wird garantiert beantwortet.

Standard Service Program—Teilnehmer dieses Programms
konnen sich telefonisch oder per E-Mail direkt mit unseren Appli-
kationsingenieuren in Verbindung setzen und jederzeit die
Schulungseinheiten im Services Resource Center nutzen. Beim
Erwerb eines Produkts von National Instruments sind Sie auto-
matisch ein Jahr lang zur Teilnahme am Standard Service Program
berechtigt. Danach ist die Mitgliedschaft kostenpflichtig.

Welche Art der technischen Unterstiitzung es in Ihrer Nihe gibt,
erfahren Sie unter ni . com/services/d oder bei einer unserer
Niederlassungen (ni.com/contact).

¢ Training und Zertifizierung—Auf ni . com/training/d finden
Sie Lehrmaterial und Informationen zur Zertifizierung. Hier konnen
Sie sich auch fiir eine der weltweit angebotenen Software-Schulungen
anmelden.

*  Systemintegration—Wenn Sie aus Zeit- oder Personalmangel oder
aus anderen Griinden bei einem Projekt in Verzug geraten, konnen
Thnen die Mitglieder des NI-Alliance-Programms weiterhelfen. Fiir
Informationen zu diesem Programm setzen Sie sich entweder tele-
fonisch mit einer Niederlassung von National Instruments in Threr
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Anhang A Technische Unterstiitzung und professioneller Service

Nihe in Verbindung, besuchen Sie die Website ni.com/alliance
(englisch) oder klicken Sie auf ni . com/germany im Menii links auf
den Link “Alliance Program”.

Sollten Sie nach dem Besuch unserer Website ni . com noch Fragen
haben, wenden Sie sich bitte an eine Niederlassung von National Instru-
ments in Threr Ndhe. Die Telefonnummern aller Niederlassungen finden
Sie am Anfang dieses Handbuchs. Auf die Websites der einzelnen Nieder-
lassungen, auf denen Sie immer die aktuellen Kontaktinformationen,
Telefonnummern des technischen Supports, E-Mail-Adressen sowie
aktuelle Ereignisse und Veranstaltungen finden, gelangen Sie iiber
ni.com/niglobal.
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