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About This Manual

Use this manual to familiarize yourself with SignalExpress interactive 
measurements and the basic SignalExpress features that you use to acquire 
and analyze signals.

This manual contains exercises that help you begin working with 
SignalExpress. These exercises teach you how to run projects, configure 
steps, work with signals, configure sweep measurements, log data, and 
extend SignalExpress with LabVIEW graphical programming.

Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence Options»Settings»General directs you to 
pull down the Options menu, select the Settings item, and select General 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names, input and output names, views, dialog boxes, sections of dialog 
boxes, and menu names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard. This font is also used for the proper names of disk drives, paths, 
directories, programs, subprograms, subroutines, device names, functions, 
operations, variables, filenames, and extensions.

Related Documentation
Refer to the SignalExpress Help, available by selecting Help»
SignalExpress Help, for more information as you read this manual.
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1
Getting Started with 
SignalExpress

National Instruments provides innovative solutions for scientists 
and engineers to build automated measurement systems based on 
industry-standard computers and platforms. National Instruments develops 
robust, industry-leading programming environments for automating 
measurement systems, such as LabVIEW for graphical development, 
LabWindows™/CVI™ for ANSI C programming, and Measurement Studio 
for Microsoft Visual Studio programming. You can use these programming 
tools with National Instruments measurement hardware and interfaces to 
traditional instruments to build custom, advanced virtual instrumentation 
systems.

SignalExpress optimizes virtual instrumentation for design engineers by 
offering instant interactive measurements that require no programming. 
You can use SignalExpress interactively to acquire, generate, analyze, 
compare, import, and log signals. You can compare design data with 
measurement data in one step. SignalExpress extends the ease of use and 
performance of virtual instrumentation to those who must acquire or 
analyze signals without programming applications. You also can extend the 
functionality of SignalExpress by importing a custom virtual instrument 
(VI) created in the LabVIEW Development System or by converting a 
SignalExpress project to a LabVIEW block diagram so you can continue 
development in LabVIEW. Refer to Chapter 6, Extending SignalExpress 
Projects with LabVIEW, for more information about advanced 
functionality in SignalExpress.

This chapter provides information about SignalExpress version availability 
and available licensing options.
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SignalExpress Version Availability
SignalExpress is available in both a full and limited (LE) version. Refer to 
the following table for a list of features available in 
each version. 

Table 1-1.  Differences in SignalExpress Limited Edition (LE) and Full Edition

LE Full

Instrument Support

Over 300 common standalone instruments Acquire/Generate Signals steps 
installed by NI Device Drivers

IVI DMM Acquire

IVI FGEN Arbitrary Waveform

IVI FGEN Standard Function

IVI Power Supply

IVI Scope Acquire

Acquire/Generate Signals steps 
installed by NI Device Drivers

IVI DMM Acquire

IVI FGEN Arbitrary Waveform

IVI FGEN Standard Function

IVI Power Supply

IVI Scope Acquire

Visualization and Documentation

Customizable graphing Data View Data View

Interactive cursors Cursors Cursors

Drag and drop data into Microsoft Excel, 
Word, and WordPad

Drag and drop Drag and drop

Print and export graphs — Project Documentation tab

Operator mode with limited user-editing — Operator mode

Signal Creation

Analog signal creation Create Analog Signal Create Analog Signal

Digital signal creation Create Digital Signal Create Digital Signal

Signal Processing

Software filters — Filter

Scalar and waveform math — Arithmetic

Formula

Scaling and Conversion

Time Averaging

Window
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Signal Processing (Continued)

Analog and digital conversion — Convert Analog to Digital

Convert Digital to Analog

Interactive signal comparisons — Interactive Alignment

Load simulation data from PSPICE, 
Multisim, and other SPICE packages

— Load from SPICE

Time and Frequency Measurements

Amplitude and level — Amplitude and Levels

Timing and transition — Timing and Transition

Power spectrum — Power Spectrum

Frequency response — Frequency Response

Distortion measurements — Distortion

Tone extraction — Tone Extraction

Data Logging

Save signals to file Load/Save Signals steps 
installed by NI Device Drivers

Export to text and Microsoft 
Excel files

Load/Save Signals steps 
installed by NI Device Drivers

Export to text and Microsoft 
Excel files

Save to ASCII/LVM

Export TDMS log files to 
Microsoft Excel

Data logging (Creating TDMS Files) Record button*

Playback

Record button

Playback

Record While Running button

Recording Options tab

Unlimited logs per project

Logging alarms and events — Alarms

Events

Logging with start or stop conditions — Start conditions

Stop conditions

Table 1-1.  Differences in SignalExpress Limited Edition (LE) and Full Edition (Continued)

LE Full
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Measurement Automation

Parameter sweeping — Sweep

Limit testing — Limit Test

Software triggering — Trigger

Sequencing — Sequence

Remote Data Access

Read/Write shared variables — Read Shared Variables

Write to shared variables

LabVIEW Interaction

LabVIEW code generation Generate a LabVIEW VI from 
a project

Generate a LabVIEW VI from 
a project

LabVIEW Express VIs Acquire/Generate Signals 
Express VIs installed by 
NI Device Drivers

Create Signals Express VIs

IVI DMM Acquire

IVI FGEN Arbitrary Waveform

IVI FGEN Standard Waveform

IVI Power Supply

IVI Scope Acquire

Acquire/Generate Signals 
Express VIs installed by 
NI Device Drivers

Create Signals Express VIs

IVI DMM Acquire

IVI FGEN Arbitrary Waveform

IVI FGEN Standard Waveform

IVI Power Supply

IVI Scope Acquire

Load/Save Signals Express VIs

Processing Express VIs

Analysis Express VIs

Run LabVIEW VIs in SignalExpress — Run LabVIEW VI steps

* Recording is limited to one log per project

Table 1-1.  Differences in SignalExpress Limited Edition (LE) and Full Edition (Continued)

LE Full
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SignalExpress Licensing Options
This section assists you in understanding the licensing policies for 
SignalExpress. This document does not replace the National Instruments 
Software License Agreement. Use this document only as a reference.

Evaluation Mode
The evaluation mode of SignalExpress gives you access to the 
SignalExpress Full Edition and the features in Table 1-1 for 7 days. After 
that period, you must either register the free, unlicensed LE version or 
activate the SignalExpress Full Edition. If you do not register or activate 
SignalExpress, you cannot launch the product after the 7 day evaluation 
period expires.

Note If you install SignalExpress on a machine that has LabVIEW 8.0 or later installed, 
the trial of the SignalExpress Full Edition begins the first time you launch either LabVIEW 
or SignalExpress.

SignalExpress Full Edition
The full edition of SignalExpress provides you with the full functionality 
shown in Table 1-1. You can activate the full edition of SignalExpress 
using the National Instruments License Manager, the SignalExpress 
installer, or the National Instruments website at ni.com/activate.

Refer to the National Instruments website at ni.com/signalexpress to 
purchase SignalExpress Full Edition.

SignalExpress LE
You can register the free limited edition, SignalExpress LE, at any time 
during or after the 7 day evaluation period. After the 7 day evaluation 
period expires, registered versions of SignalExpress LE allow you to 
evaluate licensed features with the following restrictions:

• Each time you drop a step that is licensed, a dialog box prompts you to 
activate the software. 

• You cannot save a project.

• Projects close after 10 minutes.

http://www.ni.com/signalexpress
http://www.ni.com/activate
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Activating SignalExpress LE
Complete the following steps to activate SignalExpress LE from the 
application.

1. Launch SignalExpress. 

2. In the National Instruments License Dialog window that appears, 
click the Register Limited Edition button. 

3. Follow the prompts to activate SignalExpress LE. 

Note You also can activate SignalExpress LE from the NI License Manager using the 
serial number listed in the SignalExpress Readme.
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2
Working with Projects

You can use SignalExpress to define measurement procedures by adding 
and configuring steps in an interactive measurement environment. A step is 
a configurable function that acquires, generates, analyzes, loads, or stores 
signals. The Add Step menu and the Add Step palette show the steps 
available in SignalExpress. 

Most steps process input signals and produce output signals. You can 
configure the operation of a step by specifying values on the Step Setup tab 
for the step. A saved sequence of configured steps is a SignalExpress 
project.

This chapter teaches you how to load and run existing projects and how to 
configure steps in these projects.

Opening a Project
Complete the following steps to load a sample project in SignalExpress.

1. Launch SignalExpress. Select Empty SignalExpress Project from the 
Getting Started window.

Notice that SignalExpress is split into views that display various types 
of information. The primary view appears in the middle of the 
application window and contains tabs. If SignalExpress opens in the 
default configuration, the Data View tab, the Recording Options tab, 
and the Project Documentation tab appear in the primary view. 

The primary view is surrounded by supplementary views. In the 
default configuration, the Project View appears on the left, and the 
context help appears on the right.

Note If SignalExpress detects a supported hardware device, the Channel View appears 
across the bottom of the SignalExpress application window.
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2. If SignalExpress does not open in the default configuration, select 
View»Layout»Reset Project to NI Default Layout to reset the 
application to the default configuration. You can use the View menu to 
display tabs and views or reset the layout at any time.

3. Select Help»Open Example to open the SignalExpress\
Examples directory. Navigate to the Tutorial directory and 
double-click First Project.seproj to open the example project. 

4. Examine the window that appears, as shown in Figure 2-1, to learn 
about different components of SignalExpress. 

Figure 2-1.  First Project.seproj

1 Run button
2 Record button
3 Primary view with Data View tab visible
4 Work Area pull-down menu
5 Project View

6 Step
7 Input
8 Output
9 Logged Data window
10 Context Help

8

6

7

4

2 31

55

5

10

9
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Running a Project and Displaying Signals
SignalExpress has multiple execution or run modes. You can run projects 
once, continuously, for a number of iterations you specify, or for an amount 
of time you specify. When you run a project once, SignalExpress executes 
all the steps that appear in the Project View one time. When you run a 
project continuously, SignalExpress executes all the steps in the project 
continuously. Click the down arrow on the Run button, shown at left, and 
select Configure Run from the pull-down menu to configure the run mode 
for a project.

Displays on the Data View tab update continuously while a project runs. 
When a project is running, you can change measurement configuration settings 
by changing settings on the Step Setup tab and view the results immediately. 
Projects you run continuously run until you click the Stop button, shown at left. 
The Stop button appears in place of the Run button as a project runs. 

Complete the following steps to run the sample project and display signals.

1. Click the Run button. If the Run Information dialog box appears, 
click the Run button in the dialog box to execute all the steps in the 
project continuously.

The project loads a signal from a text file and performs two operations 
on the signal—an amplitude and levels measurement and a distortion 
measurement. The Amplitude and Levels step and the Distortion step 
perform these measurements, respectively. When you run a project, 
steps analyze input signals and generate new output signals as a result 
of the analysis. In this project, the Load from ASCII step loads a 
distorted sine wave, the Amplitude and Levels step and the Distortion 
step analyze the sine wave, and both steps return new outputs. In the 
Project View, SignalExpress indicates inputs with red arrows and 
outputs with blue arrows.

The graph display on the Data View tab still contains the loaded 
signal, which is a time-domain signal. Graphs display time-domain, 
frequency-domain, or XY signals. 

2. Drag the exported spectrum output signal of the Distortion step, 
shown at left, from the Project View to the Data View tab to display 
the signal. 

SignalExpress creates a new graph display on the Data View tab. 
SignalExpress does not display the exported spectrum signal on the 
same display as the time-domain signal because the exported 
spectrum signal is a frequency-domain signal. SignalExpress 
automatically recognizes different types of signals and renders them in 
the appropriate displays.
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Tip Refer to the SignalExpress Help for more information about signal types by selecting 
Help»SignalExpress Help, clicking the Index tab, and entering signal types. The help 
provides information about using SignalExpress functionality such as projects, steps, and 
signals.

3. Drag the dc output of the Amplitude and Levels step to the Data 
View tab. 

SignalExpress creates a Chart display with both a graph and a Legend 
table to display the scalar measurement from the dc output. The 
Legend table displays the value of each output and the color 
SignalExpress uses to plot the output on the adjoining graph.

4. Drag the rms output of the Amplitude and Levels step to the Chart 
display to display the scalar RMS measurement.

SignalExpress creates a new row in the table to display the second 
measurement. The project appears as shown in Figure 2-2.

Figure 2-2.  Outputs of First Project.seproj
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Configuring a Step
A step is a configurable function that acquires, generates, analyzes, loads, 
or stores signals. Steps process input signals and produce output signals. 
You can configure the operation of a step in SignalExpress by specifying 
values on the Step Setup tab for the step. While a project runs, you can 
modify the configuration of steps and see immediate feedback on the Data 
View tab, and you can adjust measurements until you achieve the results 
you need.

Complete the following steps to configure the Distortion step and the 
Amplitude and Levels step.

1. Double-click the Distortion step in the Project View. SignalExpress 
displays the Step Setup tab for the Distortion step, as shown in 
Figure 2-3.

Figure 2-3.  Distortion Step Setup Tab
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On the Configuration page of the Step Setup tab, the Export signals 
(THD) field indicates that the Distortion step exports the input signal, 
and the Exported Signal graph displays a preview of the signal. The 
Exported Power Spectrum graph indicates that the step performs a 
power spectrum on the input signal to convert it to the frequency 
domain, and the Measurement Results field displays the fundamental 
frequency and total harmonic distortion (THD) of the signal. The step 
generates the exported signal and three measurements as outputs—the 
spectrum, the THD, and the fundamental frequency of the original 
time-domain waveform input.

2. If the context help does not appear on the right side of the screen, select 
Help»Context Help to display complete reference information about 
the step. 

The upper section of the context help displays information about the 
step, and the lower section of the context help displays information 
about specific parameters of the step when you move the cursor over a 
parameter. Move the cursor over the THD (%) parameter to display 
information about the parameter.

3. On the Configuration page, select Fundamental Tone from the 
Export signals (THD) pull-down menu.

The Exported Power Spectrum graph changes from displaying the 
frequency-domain spectrum of the entire input signal to displaying 
only the frequency spectrum of the fundamental tone of the input 
signal. Both the output signal of the Distortion step and the graph 
display of the exported spectrum output on the Data View tab update 
to reflect the change you made.

4. Select Harmonics only from the Export signals (THD) pull-down 
menu.

The Exported Power Spectrum graph on the Step Setup tab and the 
graph of the output on the Data View tab both change to display only 
the spectrum of the harmonic signals from the input signal.

5. Click the Amplitude and Levels step in the Project View. 

The Step Setup tab changes from displaying the configuration of the 
Distortion step to displaying the configuration of the Amplitude and 
Levels step.
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6. Select the Input/Output page to display the list of possible inputs and 
outputs for this step, as shown in Figure 2-4.

Figure 2-4.  Amplitude and Levels Step Setup Tab

7. Place checkmarks in the Export +peak value, Export -peak value, 
and Export peak-peak value checkboxes to configure the Amplitude 
and Levels step to return three additional measurements.

Three additional outputs appear in the Project View.

8. Switch to the Data View tab.

9. Drag the three new outputs from the Project View to the Chart display 
of scalar measurements. The new outputs appear on the graph and in 
the Legend table.

Note If you have been running the project for a while, you might need to stop and restart 
the project to see all the scalar signals on the graph. SignalExpress accumulates points of 
data for signals that you add to a graph, and new signals you add do not have as many data 
points to display on the graph. 
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10. Click the Stop button to stop the project.

When you click the Stop button, the project stops running after 
completing the current cycle of operations, or the current iteration. 
Click the down arrow on the Stop button and select Abort from the 
pull-down menu to completely stop the project without finishing the 
current iteration.

11. Select File»Save Project As and save the project as My First 
Project.seproj in the C:\Program Files\National 
Instruments\SignalExpress\Examples\Tutorial directory.

12. Select File»Close Project to close the project.

Ordering, Moving, and Deleting Steps
Most steps in SignalExpress projects require input data. Steps can operate 
only on signals exported from previous steps in the Project View, so the 
order in which steps appear in the Project View can effect project 
functionality. 

For steps that have an Input or Input/Output page on the Step Setup tab, 
the Input signal pull-down menu on that page displays only compatible 
signals exported from a previous step. When the output of a step becomes 
the input of another step, the steps become dependent on each other, and the 
two steps execute sequentially at the same rate. The first step generates an 
output signal that the second step must receive as an input before the second 
step can execute.

You can move a step within a project by dragging it up or down in the 
Project View. You can delete a step by right-clicking it in the Project View 
and selecting Delete from the context menu. When you move or delete a 
step, the status of signals in the project changes. For example, if you delete 
a step that generates output signals, the operation of the project breaks if 
any of the deleted output signals are inputs for other steps, and an error 
indicator appears in the Project View. You also can cut, copy, and paste 
steps within a project by pressing the <Ctrl-X>, <Ctrl-C>, and <Ctrl-V> 
keys, respectively, or by right-clicking a step in the Project View and 
selecting Cut, Copy, Paste Before Selected Step, or Paste After Selected 
Step from the context menu.
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Handling Errors and Warnings
If an error occurs while a project runs, an error indicator, shown at left, 
appears in the Project View on the step that encountered the error. 
Double-click the step with the error to display an error description across 
the bottom of the Step Setup tab. Click the Details button to the right of 
the error description to display the full error description.

SignalExpress logs all errors and warnings on the Event Log tab while a 
project runs. To display the Event Log tab, select View»Event Log. Refer 
to the SignalExpress Help for more information about errors and warnings 
by selecting Help»SignalExpress Help, clicking the Index tab, and 
entering errors.
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3
Working with Signals

You can use SignalExpress to generate and analyze signals without 
programming. This chapter teaches you how to work with signals in 
SignalExpress, including how to plot signals on graphs, import signals 
from a file, interactively align and compare two signals, and save signals to 
a file.

Graphing Signals
Complete the following steps to plot signals in a sample project and 
examine the signals visually using cursors.

1. Select Help»Open Example, to open the SignalExpress\
Examples directory. Navigate to the Tutorial directory and 
double-click Signals.seproj. This project configures the Create 
Analog Signal step to create a square wave signal and the Filter step to 
perform a lowpass Butterworth filter.

2. Drag the step signal output of the Create Analog Signal step to the 
Data View tab.

3. Drag the filtered step output of the Filter step to the Data View tab.

Both the step signal and the filtered step signals are time-domain 
signals, so they appear on the same graph display. If you try to plot 
signals of different types by dragging the signals to the same display, 
SignalExpress creates a new display.

4. Click the Add Display button, shown at left, to create a new display.

Note You can remove individual displays by clicking the X at the top right corner of the 
display.

5. Drag the filtered step output of the Filter step to the new display.
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6. Right-click the new display and select Visible Items»Cursors from 
the context menu to display two interactive cursors, as shown in 
Figure 3-1.

Figure 3-1.  Signals.seproj

As you drag the cursors, SignalExpress displays the x- and y-values of 
the cursors in the cursor table at the bottom of the Data View tab.

7. Select File»Save Project As and save the project as 
My Signals.seproj in the C:\Program Files\National 
Instruments\SignalExpress\Examples\Tutorial directory.
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Importing a Signal from a File
You can import signals from standard file formats such as ASCII comma- 
or tab-delimited files and LabVIEW measurement data files (.lvm). You 
also can import signals from simulated results of electronic design 
automation tools such as SPICE simulators.

Complete the following steps to import a signal from a file.

1. Right-click in the Project View and select Load/Save Signals»
Analog Signals»Load from ASCII from the context menu to add the 
Load from ASCII step to the Project View. The Step Setup tab for the 
Load from ASCII step appears. This step parses an ASCII file and 
displays the signals in the file.

Note You can add steps to a project from the Add Step menu, the Add Step palette, or the 
context menu that appears when you right-click in the Project View.

2. Confirm that . (dot) is selected in the Decimal separator pull-down 
menu to read the values in the example file correctly. 

3. On the Step Setup tab, click the browse button, shown at left, 
navigate to the C:\Program Files\National Instruments\
SignalExpress\Examples\Tutorial directory, and double-click 
Step Response.txt.

In the File preview section, column 1 shows the time stamp data, and 
column 2 shows the actual voltage values of the signal.

4. Switch to the Import Signals page of the Step Setup tab to display the 
available signals in the file.

5. Confirm that a checkmark appears in the Column 2 checkbox to 
import that signal.

The Step Setup tab displays a preview of the signal on the Imported 
Signal graph.

6. Confirm that Column 1 (Column 1) appears in the Input X values 
pull-down menu to set the x-axis data of the waveform to the 
appropriate values.

7. Switch to the Data View tab.

8. In the Project View, expand the Step Response.txt output of the Load 
from ASCII step.

9. Right-click the Column 2 output and select Rename from the context 
menu.
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10. Enter step response and press the <Enter> key to rename the output.

11. Drag the new step response output of the Load from ASCII step to the 
lower display on the Data View tab.

The lower graph display appears to show almost no signals.  This is 
because the Create Analog Signal step produces signals with a current 
timestamp while the step response output has a zero timestamp.  
Right-click the lower graph display and select Time Stamp»Ignore to 
see both the filtered step signal and the step response output.

The filtered step signal resembles the rising edge of the step response 
output, as shown in Figure 3-2.

Figure 3-2.  Signals of Signals.seproj

12. Select File»Save Project to save the project.
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Aligning and Comparing Signals
Although the filtered step signal and the step response output both show 
an overshoot in the rising edge, assessing the similarity between the two 
is difficult because the signals come from different sources and vary in 
amplitude and timing. However, you can use the Interactive Alignment step 
to align and compare two signals, so you can choose which type of 
information you want to export from the operation to use in the project.

Complete the following steps to align two signals in the 
My Signals.seproj project.

1. Expand the Step Response.txt output, right-click the step response 
output and select Send To»Processing»Analog Signals»Interactive 
Alignment from the context menu to pass the step response signal 
from the Load from ASCII step to the Interactive Alignment step. 
Place a checkmark in the Ignore x0 checkbox on the Alignment tab to 
ignore timestamp mismatches.

The step selects the two most recent signals from the project to use as 
inputs and displays the signals on the graphs on the Step Setup tab, 
as shown in Figure 3-3.

Figure 3-3.  Interactive Alignment Step Setup Tab
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When you add a step to a project, SignalExpress selects input signals 
based on the signal types the step can accept. For example, the 
Interactive Alignment step can operate only on time-domain waveform 
signals. Therefore, the step selects as inputs the last two time-domain 
signals created in the project. 

Note To change the input signals for a step, select different signals from the pull-down 
menu of compatible signals on the Input or Input/Output page of the Step Setup tab, or 
click the down arrow that appears next to the step input name on the step in the Project 
View.

2. Click the red signal in the Input Signals graph and drag it to another 
point within the graph. The Comparison Result Signal graph updates 
to show the new calculated difference between the signals.

You can drag, expand, and contract signals on the graph.

3. Try to align the rising edges of the two signals by dragging a signal 
within the graph. Click a signal to set an anchor point and press and 
hold the <Alt> key while dragging the signal to stretch the signal 
around that anchor point along the x- and y-axes.

On the Alignment page of the Step Setup tab, the step computes and 
displays the x- and y-gain and offset values you need to achieve the 
alignment specifications as you drag the signals.

4. Select Auto - Step from the Mode pull-down menu to align the 
signals. SignalExpress computes the alignment using built-in 
algorithms.

The Comparison Result Signal graph on the Step Setup tab displays 
the difference between the two signals.

5. On the Input/Output page, place a checkmark in the Export aligned 
signals checkbox to add the signals to the outputs of the step.

6. Switch to the Data View tab.

7. Click the Add Display button to add a third display.

8. Drag the aligned reference and aligned test outputs of the Interactive 
Alignment step to the new graph to view the aligned signals.

9. Select File»Save Project to save the project.
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Signal Types in SignalExpress
Some steps, such as the Arithmetic step, can operate on multiple signal 
types. For example, you can use the Arithmetic step to operate on 
time-domain or frequency-domain waveforms. The Arithmetic step 
changes behavior based on the type of input signals you select for the 
step. For example, if you add two time-domain signals, SignalExpress adds 
only their amplitudes. However, if you add two frequency-domain phase 
signals, SignalExpress adds the appropriate phase shift.

Refer to the SignalExpress Help for more information about signal types by 
selecting Help»SignalExpress Help, clicking the Index tab, and entering 
signal types.

Exporting and Printing Signals
You can use SignalExpress to document signals or continue analysis in 
another software application. This section teaches you how to export 
signals, including sending signals to an ASCII file, sending data to 
Microsoft Excel, printing signals, and using the built-in project 
documentation feature to document the SignalExpress project.

Saving Signals to File
Complete the following steps to save a signal from My Signals.seproj 
to a file.

1. Click the Add Step button, shown at left, to display the Add Step 
palette.

2. Select Load/Save Signals»Analog Signals»Save to ASCII/LVM to 
add the Save to ASCII/LVM step to the Project View. The Step Setup 
tab for the Save to ASCII/LVM step appears.

3. Click the Signals page on the Step Setup tab and select filtered step 
from the Input Data pull-down menu.

4. On the File Settings page, specify where to save the text file you are 
creating by clicking the Browse button next to the Export file path 
field and navigating to the C:\Program Files\National 
Instruments\SignalExpress\Examples\Tutorial directory. 
Enter filtered signal.txt as the filename.

5. Select Overwrite from the If file already exists pull-down menu.

6. Select Generic ASCII (.txt) from the Export file type pull-down 
menu.
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You can use a Load/Save Signals step to save data to a file every time 
the project runs.

7. Click the down arrow on the Run button and select Run Once to run 
the project and save the resulting signal to the specified ASCII file.

8. Select File»Save Project to save the project.

9. Select File»Close Project to close the project.

10. Browse to the filtered signal.txt and open the file in a text 
editor to see the values of the signal. In SignalExpress, you can use the 
Load from ASCII step to import the signal back into a project.

Exporting Signals to Microsoft Excel
To export signal data to Microsoft Excel, launch Excel and drag the output 
signal of a step in SignalExpress to an Excel spreadsheet. You also can 
right-click a display on the Data View tab and select Export To»
Microsoft Excel to export all the data on the display.

Creating Reports in SignalExpress
Select View»Project Documentation to display the Project 
Documentation tab. You can use this tab to describe a project using text and 
images such as graphs. You can drag a step output from the Project View 
to the Project Documentation tab to display a graph of the output signal. 
If the project is running, the graph on the Project Documentation tab 
automatically updates to match the current value of the step output. 

To print the documentation, display the Project Documentation tab 
and select File»Print»Print Documentation or click the Print 
Documentation button. To export the documentation to HTML, display 
the Project Documentation tab and select File»Export»Export 
Documentation to HTML.
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4
Logging Data

You can use SignalExpress to record and analyze measurements. You can 
record any time-domain, double, 32-bit unsigned integer, Boolean, or 
digital step output. You also can analyze and process logged data by 
playing it through analysis steps. 

This chapter teaches you how to record data using the integrated data 
logging features in SignalExpress. You learn how to record a specified 
signal, play back that signal, and analyze the signal using analysis steps. 
You also learn how to use the Recording Options tab to log signals based 
on specified start or stop conditions. 

Recording a Signal
You can use the Record button to configure a data logging process. 

Complete the following steps to specify a signal to record and to record the 
signal.

1. Select Help»Open Example, navigate to the Tutorial directory, and 
double-click Logging.seproj.

This project uses the Create Analog Signal step to generate a signal 
based on a formula.

2. Click the Record button, shown at left, to display the Logging Signals 
Selection dialog box.

The Logging Signals Selection dialog box displays the signals in the 
project available for recording. You can select one signal or multiple 
signals to record. You also can specify a name and description for 
the log.

3. Place a checkmark in the signal checkbox to record the formula signal 
generated in the Create Analog Signal step.

4. Click the OK button to close the Logging Signals Selection dialog 
box and begin recording the signal. The logging operation continues 
until you click the Stop button.
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5. Click the Stop button, shown at left, to stop logging the signal. If you 
have not logged a signal before, the First Log Complete dialog box 
appears. Click the OK button to close the dialog box.

The logged data appears in the Logged Data window at the bottom of 
the Project View, as shown in Figure 4-1.

Figure 4-1.  Logged Data Window

By default, SignalExpress names the logged data according to the date 
and time you recorded the data. SignalExpress saves logged data in the 
.tdms file format in the directory you specify in the Options dialog 
box. 

6. Select Tools»Options and select the Logging option to specify the 
directory for SignalExpress to save the logged data and to customize 
various preferences for logged data.

7. Click the OK button to close the Options dialog box.

8. Select File»Save Project As and save the project as 
My Logging.seproj in the C:\Program Files\National 
Instruments\SignalExpress\Examples\Tutorial directory.

Viewing a Logged Signal
Complete the following steps to view the logged data.

1. If the Data View tab is not visible, select View»Data View to display 
the Data View tab. 

2. The Logged Data window displays a list of all logged data in the 
current project. Select the data log you just recorded from the Logged 
Data window and drag it to the Data View tab. The Data View tab 
displays the logged data and a Preview Graph, as shown in Figure 4-2 
with the context help closed. The signal displayed on the Data View 
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tab might differ from the signal displayed in Figure 4-2, depending on 
how long you recorded the signal.

Figure 4-2.  Logging.seproj

The Preview Graph provides a method for zooming and panning 
through data on the Data View tab. The Preview Graph appears by 
default when you view logged data. When viewing live or non-logged 
data, right-click a display on the Data View tab and select Visible 
Items»Preview from the context menu to display the Preview Graph.

Click the Zoom In button next to the Preview Graph to zoom in on the 
logged signal. The cursors on the Preview Graph show the subset of 
data currently displayed on the Data View tab. Use the scroll bar 
beneath the Preview Graph to scroll through the data. Click and drag 
the cursors on the Preview Graph to increase or decrease the subset of 
data you are viewing.

1 Logged Data 2 Preview Graph

1

2
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Logging Signals with Predefined Start and Stop 
Conditions

You can configure start and stop conditions that signals must meet before 
SignalExpress records or stops recording the signals. Complete the 
following steps to log data based on start and stop conditions.

1. If the Recording Options tab is not visible, select View»Recording 
Options to open the Recording Options tab.

2. Select Signal Selection from the Category list on the Recording 
Options tab.

3. Place a checkmark next to the signal in the Record column, as shown 
in Figure 4-3.

Figure 4-3.  Signal Selection

The Record button changes to the Record While Running button, 
shown at left. Ensure the Record While Running button is pressed. 
When the Record While Running button is pressed, SignalExpress 
records the selected signal when you click the Run button.

4. Select Start Conditions from the Category list on the Recording 
Options tab. 
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5. Click the Add button under the Start condition list to customize a 
start condition for the logging task.

a. In the Condition type pull-down menu, verify that Signal trigger 
is selected to specify that SignalExpress begins recording when 
the input signal meets the specified condition.

b. In the Signal pull-down menu, verify that signal is selected.

c. In the Trigger type pull-down menu, verify that Rising slope is 
selected to specify to begin recording the signal based on the value 
of the edge of the signal on a positive slope.

d. Enter 1 in the Trigger value field to begin recording when the 
signal crosses 1 on a rising slope.

6. Select Stop Conditions from the Category list on the Recording 
Options tab.

7. Click the Add button under the Stop condition list to customize a stop 
condition for the logging task.

a. In the Condition type pull-down menu, verify that Duration is 
selected to specify that SignalExpress stops recording after a 
specified amount of time passes.

b. In the Duration (s) control, verify that 5 appears to specify to stop 
recording 5 seconds after the signal begins.

8. Click the Run button, shown at left. SignalExpress begins recording 
the signal when the signal crosses level 1 on a rising slope and 
continues recording the signal for 5 seconds. 

The following indicators in the Recording status section of the 
Recording Options tab update while the project runs:

• Recording displays ON when the signal meets the start condition 
and logging is in progress. 

• Disk information displays the available hard disk space on the 
computer for the log. 

• Current estimated log size displays the size of the log file on 
disk.

• Recording time available displays the amount of time you can 
continue recording the log before running out of disk space.

• Current log started on displays the start time of the current log.

The Start Conditions, Stop Conditions, Alarms, and Events pages 
of the Recording Options tab also include indicators that display the 
status of start and stop conditions, alarms, and events that you 
configure.
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Analyzing Logged Signals
After you log a signal, you can play back the logged data or run the logged 
signal through analysis steps, just as you can with live data. Complete the 
following steps to analyze a logged signal.

1. Locate the Work Area pull-down menu above the Project View, 
as shown in Figure 4-4. Click the down arrow and select Playback 
to switch to the Playback work area.

Figure 4-4.  Work Area pull-down menu

Use work areas to perform multiple SignalExpress operations from 
within the same project. You can acquire data, process signals, record 
data, and perform measurements on logged data without opening a 
new project. When you save a project, SignalExpress saves every work 
area within the project in the same project file.

The default work area, Monitor/Record, allows you to take 
measurements, analyze live data, and log data. The Playback work area 
allows you to use logged data that you record in the Monitor/Record 
work area as an input for an analysis step.

2. Click the Add Step button, shown at left, and select the Filter step from 
Processing»Analog Signals»Filter. SignalExpress automatically 
selects the first signal you logged as the input to the Filter step.

3. Switch to the Data View tab, and drag the filtered data output of the 
Filter step to the Data View tab to view the resulting signal.

4. Click the Run button. The Data View tab displays the resulting 
filtered signal and SignalExpress plays back the entire log.
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Advanced Playback
You can use the Playback Options tab to configure advanced data 
playback options. The Playback Options tab displays a preview of the 
logged data and allows you to select a subset of that data to play back or run 
through analysis steps.

1. Select View»Playback Options to display the Playback Options tab, 
as shown in Figure 4-5. 

Figure 4-5.  Playback Options Tab

2. In the Logged signal listbox, select signal from the second log you 
created.

3. Enter 1 in the Start time (s) field to play back or analyze a subset of 
the logged signal beginning 1 second after the start of the log. 

4. Enter 4 in the Stop time (s) field to play back or analyze a subset of 
the logged signal ending four seconds after the start of the log. If the 
log is not at least 4 seconds long, enter an appropriate value in the Stop 
time (s) field. 

5. In the Logged signal listbox, right-click the signal from the second log 
and select Activate from the context menu to make that signal the 
active log.

Note You also can right-click a log in the Logged Data window and select Make Active 
Log from the context menu to make that log the active log.
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6. Switch to the Data View tab. The graph display on the Data View tab 
automatically updated to display the signal from the second log when 
you made that signal the active signal. 

7. Click the Run button, shown at left. SignalExpress filters the subset of 
the signal you specified on the Playback Options tab and displays the 
resulting filtered signal on the Data View tab.

8. Select File»Close Project to close the project. The Save Project 
Changes? dialog box appears. Select Discard project changes and 
delete new logs on disk option. You can also select Save project and 
logs option and Discard project changes and keep logs on disk 
option.

Refer to the SignalExpress Help, available by selecting Help»
SignalExpress Help, for more information about logging data, such as 
specifying alarm conditions, events, and playback options.
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5
Performing Sweep Measurements

You can use SignalExpress to automate measurements to characterize and 
validate designs by creating sweep operations. A design can be anything 
you create and want to characterize and validate with SignalExpress. You 
can use the sweep measurements to gather data from designs over a range 
of conditions to document the performance of the designs. For example, 
you can use sweep operations to vary the frequency of a stimulus signal or 
vary the level of a supply voltage while taking measurements to 
characterize designs.

This chapter teaches you how to set up sweep operations using the Sweep 
step in SignalExpress. You learn how to characterize the performance of a 
filter by sweeping through a range of frequency values and measuring the 
output of the filter. You also learn how to display sweep results and perform 
multidimensional sweeps for more complex measurements.

Defining Sweep Ranges and Outputs
You can use the Sweep step in SignalExpress to define automated 
measurements for complex, repeatable sweep operations.

Complete the following steps to define a frequency range in a sample 
project to sweep through a filter.

1. Select Help»Open Example, navigate to the Tutorial directory, and 
double-click Sweep.seproj.

2. Click the Run button, shown at left, to run the project continuously.

The project generates a sine wave stimulus signal using the Create 
Analog Signal step, passes it through a bandpass elliptic filter using the 
Filter step, measures the RMS level of the filter output using the 
Amplitude and Levels step, and converts the level to decibels (dB) 
using the Formula step. The Filter step acts as a simulated unit under 
test, so the project uses no hardware. However, you also can sweep 
physical signals generated from a National Instruments arbitrary 
waveform generator, function generator, dynamic signal analyzer, 
or multifunction I/O (MIO) device.

3. Click the Stop button to stop the project.
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4. Click the Add Step button, shown at left, and select Execution 
Control»Sweep to add the Sweep step to the Project View.

5. On the Step Setup tab, click the Add button to display the list of 
sweepable parameters from each step in the project, as shown in 
Figure 5-1.

Figure 5-1.  Sweep Parameter Selection Dialog Box

6. Select the Frequency (Hz) parameter under Create Analog Signal 
and click the OK button.

The Sweep step encloses the Create Analog Signal step, which 
provides the signal to sweep.

7. On the Sweep Configuration page of the Step Setup tab, select 
Exponential from the Type pull-down menu.

8. Enter 1k in the Start: Frequency (Hz) field, and enter 40k in the 
Stop: Frequency (Hz) field.
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9. Enter 150 in the Number of points field.

The Sweep Configuration page appears as shown in Figure 5-2.

Figure 5-2.  Sweep Step Setup Tab

You use the Sweep step to specify a range of values to iterate through 
the Frequency (Hz) parameter of the Create Analog Signal step. 
The Create Analog Signal step uses the defined frequency range to 
generate a sine wave at each of these frequencies. You can use the 
Sweep step to iterate through any sweepable parameter value of any 
sweepable step in a project.

10. Switch to the Sweep Output page.

11. Click the Add button to display the list of sweepable outputs from each 
step in the project.

12. Select the response amplitude in dB output under Formula and 
click the OK button to plot this measurement against the swept 
Frequency (Hz) parameter.

The Sweep step creates a loop around all the steps in the Project View 
to include all the steps in the sweep operation.
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Running Sweep Measurements
Complete the following steps to run the sweep measurement.

1. Switch to the Data View tab, click the down arrow on the Run button, 
and select Run Once to execute the sweep measurement.

The white stimulus signal output on the graph display iterates through 
the specified range of frequencies.

2. Drag the response amplitude in dB vs. Frequency signal from the 
bottom of the Sweep loop to the Data View tab to display the output 
of the sweep.

SignalExpress creates a new graph display. The data from 
a sweep operation is an XY array that requires a separate display, 
as shown in Figure 5-3.

Figure 5-3.  Sweep.seproj
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3. Select the Run Once option again to execute the sweep.

The frequency response of the Filter step plots on the new graph 
display while the project runs. The graph shows the transfer function 
of the filter, or the amplitude output expressed in decibels versus the 
frequency.

Note By default, SignalExpress does not clear displays on the Data View tab between 
iterations of a sweep. Because the frequency response of the Filter step is the same for each 
iteration, the graph that displays the signal does not appear to update when you run the 
project. You can use the Data page of the Options dialog box to specify whether 
SignalExpress clears displays between iterations of a sweep. Select Tools»Options to 
display the Options dialog box.

4. Double-click the Filter step to display the filter specifications on the 
Step Setup tab.

The frequency response of the filter in the Filter Magnitude 
Response (dB) graph matches the graph on the Data View tab.

5. Select File»Save Project As and save the project as 
My Sweep.seproj in the C:\Progam Files\National 
Instruments\SignalExpress\Examples\Tutorial directory.

You can use the Sweep step to sweep multiple parameters simultaneously 
by adding additional parameters on the Sweep Configuration page of the 
Sweep Step Setup tab. Sweeping two or more parameters simultaneously 
is called a parallel sweep. For example, if you want to vary the amplitude 
of a stimulus signal, you can run a parallel sweep to maximize the precision 
of the acquisition by varying the input range of a digitizer or MIO device 
as you vary the signal level. As the signal level increases, you can increase 
the input range of the measurement device to ensure you use the entire 
resolution for the measurement.

Running Multidimensional Sweeps
Use multidimensional, or nested, sweeps to iterate through one range while 
you vary another range. For example, if you want to sweep through 
frequencies of a stimulus signal at different amplitudes, run a nested sweep. 
You can set the amplitude to level 1 and sweep through frequencies, then 
set the amplitude to level 2 and sweep through frequencies, and so on. You 
can build a nested sweep by right-clicking a Sweep step in a project and 
selecting Add nested sweep from the context menu to add another sweep 
loop. 



Chapter 5 Performing Sweep Measurements

Getting Started with SignalExpress 5-6 ni.com

Complete the following steps to run a sample nested sweep project.

1. Select Help»Open Example, navigate to the Tutorial directory, and 
double-click Nested Sweep.seproj.

2. Click the Run button to run the project.

Each iteration of the inner sweep loop sweeps the frequency of the 
stimulus signal. The outer sweep loop varies the low and high cutoff 
frequencies of the Filter step. Each iteration appears in real time on the 
upper graph display, and then appears on the lower display to show all 
the sweeps at each cutoff frequency setting, as shown in Figure 5-4.

Figure 5-4.  Nested Sweep.seproj

3. Click the Stop button, shown at left, to stop the project.
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6
Extending SignalExpress Projects 
with LabVIEW

You can use SignalExpress to define automated measurements by using 
built-in steps for acquiring, generating, analyzing, or logging signals. You 
can extend the functionality of SignalExpress projects using LabVIEW in 
the following ways:

• Build a VI in LabVIEW and import the VI into SignalExpress to 
provide custom step functionality and expand the number of steps 
available in SignalExpress.

• Convert a SignalExpress project to a LabVIEW VI to continue 
development in LabVIEW.

Importing LabVIEW VIs into SignalExpress as Steps
Use the Run LabVIEW VI steps in SignalExpress to call custom 
LabVIEW VIs. 

Note You do not need to install the LabVIEW Development System to use a Run 
LabVIEW VI step. The Run LabVIEW VI steps do not support VIs developed in 64-bit 
versions of LabVIEW.

You can call a LabVIEW VI from SignalExpress to do the following:

• Control GPIB instruments

• Control National Instruments hardware that SignalExpress does not 
support

• Read or write data to more file formats

• Display operator instructions in a pop-up dialog box

• Define a measurement algorithm
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Complete the following steps to import a VI from LabVIEW with the Run 
LabVIEW VI step.

1. Select Help»Open Example, navigate to the Tutorial directory, and 
double-click User Step.seproj.

This project uses the Create Analog Signal step to generate a signal.

2. Click the Add Step button, shown at left, and select Run LabVIEW 
VI»Run LabVIEW 2011 VI. 

Note The VI you run in this exercise was saved in LabVIEW 2011. You must use the 
version of the Run LabVIEW VI step that matches the version of LabVIEW in which you 
saved the VI.

3. On the Step Setup tab, click the browse button in the Select VI section 
and select Limiter-LV2011.vi in the C:\Program Files\
National Instruments\SignalExpress\Examples\

Tutorial directory. The Limiter-LV2011 VI accepts a time-domain 
waveform as an input, clips the signal above and below values that you 
specify on the Step Setup tab, and returns the clipped waveform as an 
output signal.

When you import a LabVIEW VI, SignalExpress maps the inputs of 
the VI as parameters and the outputs of the VI as output signals in 
SignalExpress.

You can define whether the inputs for VIs become input signals or 
parameters. An input signal appears in the Project View as an input to 
a step, which means you can pass signals as inputs to a VI. A parameter 
is a value you can configure on the Step Setup tab of a step. You also 
can sweep parameters dynamically using the Sweep step. In this 
project, the VI has an input signal, Time waveform in, and scalar 
parameters, Upper limit and Lower limit.
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Verify that the Step Setup tab appears as shown in Figure 6-1.

Figure 6-1.  Limiter VI Step Setup Tab

4. Click the Run button, shown at left, to run the project. 

5. Switch to the Data View tab and drag the Clipped waveform out 
output signal from the Run LabVIEW 2011 VI step to the Data View 
tab.

6. Double-click the Run LabVIEW 2011 VI step to display the Step 
Setup tab.

7. Select the Configure VI page to display the VI. 

8. Enter new values in the Upper limit and Lower limit fields. For 
example, enter 100 in the Upper limit field.

9. Switch to the Data View tab. The Clipped waveform out signal 
changes to reflect the changes you made.

10. Click the Stop button, shown at left, to stop the project.

11. Select File»Save As and save the project as My User Step.seproj.

12. Select File»Close Project to close the project.
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Refer to the SignalExpress Help for more information about using 
LabVIEW VIs in SignalExpress and building VIs that work well in 
SignalExpress.

Converting SignalExpress Projects to LabVIEW VIs
SignalExpress can convert SignalExpress projects into LabVIEW VIs.

Note To convert a SignalExpress project to a LabVIEW VI, you must have the LabVIEW 
8.2 Full Development System or later installed.

Complete the following steps to convert a SignalExpress project to a 
LabVIEW VI.

1. Select Help»Open Example, navigate to the Tutorial\Solutions 
directory and double-click My First Project.seproj.

2. Select Tools»Generate Code»LabVIEW Diagram.

3. Specify a filename and location for the new LabVIEW VI and click the 
OK button. SignalExpress generates the new VI and opens the VI in 
the last version of LabVIEW you opened on the machine.

The resulting LabVIEW VI reflects the execution of the project in 
SignalExpress. The block diagram consists of LabVIEW Express VIs 
wired together. Each Express VI correlates to a step in the 
SignalExpress project. You can double-click an Express VI to display 
a configuration dialog box that is identical to the Step Setup tab in 
SignalExpress. You also can right-click an Express VI and select Open 
Front Panel from the context menu to convert the Express VI into a 
LabVIEW subVI. You can view the block diagram to see how the 
LabVIEW block diagram executes and modify the functionality of the 
VI. When you convert an Express VI into a subVI, you cannot convert 
the subVI back into an Express VI.

Note When you convert a SignalExpress project with logging, SignalExpress generates a 
LabVIEW block diagram with one Express VI. You cannot convert the generated Express 
VI into a subVI.
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7
Where to Go from Here

Refer to the following resources for more information about SignalExpress.

SignalExpress Sample Projects
SignalExpress provides a variety of sample projects that demonstrate 
more capabilities of SignalExpress. These projects are located in the 
C:\Program Files\National Instruments\

SignalExpress\Examples directory. Review these examples to learn 
more about the features of SignalExpress or to start with a project that 
closely resembles your needs.

Using Hardware with SignalExpress
SignalExpress supports a variety of National Instruments hardware for 
acquiring and generating signals. You can generate or acquire and log 
analog signals in SignalExpress using National Instruments MIO devices, 
dynamic signal acquisition devices, high-speed digitizers, or arbitrary 
waveform generator and function generator devices. You also can 
synchronize multiple devices in a system by sharing clocks and trigger 
signals between devices. Refer to the SignalExpress Help by selecting 
Help»SignalExpress Help for more information about using hardware 
with SignalExpress.

Web Resources
Refer to the National Instruments website at ni.com/signalexpress for 
resources such as example projects, technical documents, and LabVIEW 
VIs written for use in SignalExpress.

http://www.ni.com/signalexpress
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A
Technical Support and 
Professional Services

Log in to your National Instruments ni.com User Profile to get 
personalized access to your services. Visit the following sections of 
ni.com for technical support and professional services:

• Support—Technical support at ni.com/support includes the 
following resources:

– Self-Help Technical Resources—For answers and solutions, 
visit ni.com/support for software drivers and updates, a 
searchable KnowledgeBase, product manuals, step-by-step 
troubleshooting wizards, thousands of example programs, 
tutorials, application notes, instrument drivers, and so on. 
Registered users also receive access to the NI Discussion Forums 
at ni.com/forums. NI Applications Engineers make sure every 
question submitted online receives an answer.

– Standard Service Program Membership—This program 
entitles members to direct access to NI Applications Engineers 
via phone and email for one-to-one technical support as well as 
exclusive access to eLearning training modules at ni.com/
elearning. All customers automatically receive a one-year 
membership in the Standard Service Program (SSP) with the 
purchase of most software products and bundles including 
NI Developer Suite. NI also offers flexible extended contract 
options that guarantee your SSP benefits are available without 
interruption for as long as you need them. Visit ni.com/ssp for 
more information.

For information about other technical support options in your 
area, visit ni.com/services, or contact your local office at 
ni.com/contact. 

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp04
http://www.ni.com/forums
http://www.ni.com/services
http://www.ni.com/contact
http://www.ni.com
http://www.ni.com/elearning
http://www.ni.com/elearning
http://www.ni.com/ssp
http://www.ni.com
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp04
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• Training and Certification—Visit ni.com/training for training 
and certification program information. You can also register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.

You also can visit the Worldwide Offices section of ni.com/niglobal 
to access the branch office websites, which provide up-to-date contact 
information, support phone numbers, email addresses, and current events.

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp08
http://www.ni.com/alliance
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