
RELEASE AND UPGRADE NOTES

LabVIEW  Datalogging and 
Supervisory Control Module
Version 2010

This document describes the system requirements and the process of 
installing the LabVIEW 2010 Datalogging and Supervisory Control (DSC) 
Module and the DSC Module Run-Time System. This document also 
describes the new features available with version 2010 and compatibility 
and upgrade issues you might encounter when you use version 2010.
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System Requirements
To use the DSC Module, the computer must meet the following minimum 
system requirements:

• 800 MB free disk space.

• 512 MB of RAM. National Instruments recommends 1 GB of RAM.

• LabVIEW 2010 Base, Full, or Professional Development System. 
Refer to the LabVIEW Release Notes for information about the 
LabVIEW development system.

• Internet Explorer 6 Service Pack 1 or later.

Supported Operating Systems
The DSC Module supports the following operating systems:

• Windows 7 (32-bit and 64-bit)

• Windows Vista (32-bit and 64-bit)

• Windows XP Service Pack 2 or later

• Windows Server 2003 R2 (32-bit)

• Windows Server 2008 R2 (64-bit)

The DSC Module does not support Windows NT/Me/2000/98/95 or the 
Windows Server non-R2 editions.

Note Support for Windows Server 2003 R2 may require disabling physical address 
extensions (PAE). To learn how this might affect your use of Windows Server 2003 and 
what actions you might have to take, visit ni.com/info and enter the Info Code 
PAESupport.

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=PAESupport
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Installing the DSC Module
This section includes information about installing the DSC Module on a 
development computer.

Complete the following steps to install the DSC Module.

1. Log in to the computer as an administrator or as a user with 
administrative privileges.

2. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with installation.

3. Insert the LabVIEW Platform DVD Disc 1.

Tip You also can double-click setup.exe from the media to launch the installer.

4. Follow the instructions for installing software.

5. When the Product List page appears, select Datalogging and 
Supervisory Control Module in the Industrial Monitoring folder. 

6. Select Install to minimize user interaction. Selecting Custom install 
opens additional dialog boxes that require your input.

7. Follow the instructions to finish installing and activating the 
DSC Module.

8. After installation, enable any virus detection programs you disabled.

9. Refer to the Where to Go from Here section of this document for more 
information about getting started with and using the DSC Module.

Note By default, the NI Keyboard Filter Driver is not installed. The NI Keyboard Filter 
Driver activates special security features, including the ability to restrict users from 
switching between applications by pressing the <Alt-Tab> keys. This driver does not work 
on laptop computers or on computers with hibernation enabled.

Activating the DSC Module
The DSC Module relies on licensing activation. You have a temporary 
license for a 30-day evaluation period. When the evaluation period expires, 
you must activate a valid DSC Module license to continue using the 
DSC Module.

You can use the NI License Manager, available by selecting Start»
All Programs»National Instruments»NI License Manager, to activate 
National Instruments products. Refer to the National Instruments License 
Manager Help, available by selecting Help»Contents in the NI License 
Manager, for information about activating NI products.

Refer to ni.com/support if you encounter errors during installation.

http://www.ni.com/support
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LabVIEW 2010 DSC Module Features and Changes
The following sections describe the new features in the DSC Module.

Logging Data to Relational Databases
You can log shared variable data, alarms, and events to the following 
supported relational databases: Microsoft Access, MySQL, Oracle, 
PostgreSQL, and SQL Server. Logging data to a supported relational 
database enables you to work with shared variables, alarms, and events in 
a database other than the Citadel database. You must be familiar working 
with the supported relational database before logging data to that database.

Use the Relational Database page on the DSC Settings: Database page 
of the Project Library Properties dialog box to enable logging to a 
supported relational database. Use the Table Management dialog box to 
specify the table name for each data type that logs to the database. The DSC 
Module supports logging the following data types to a supported relational 
database: numeric, Boolean, and string. Each data type logs to a separate 
table. LabVIEW also logs alarms and events to a separate table. You can 
customize the table name for each data type that LabVIEW logs by process. 
For example, you can specify that data of the same data type from different 
processes logs to the same table or to different tables.

DSC Module Web Services
LabVIEW Web services allow Web browsers and HTTP-capable clients to 
interact with LabVIEW applications. You use URLs and HTTP methods to 
transmit data to the Web service. The DSC Module includes built-in Web 
services that expose DSC Module VIs functionality. The DSC Module 
includes the following Web services:

• Alarms & Events Web service—Web service for sending and 
receiving alarm and event information. Use the name nialarm when 
referring to this Web service in a URL.

• Citadel Web service—Web service for querying historical data in the 
Citadel database. Use the name nicitadel when referring to this 
Web service in a URL.

DSC Module Support for Touch Panel Devices Running Windows XP 
Embedded

You can use the DSC Module to create human-machine interface (HMI) 
applications for Touch Panel devices running Windows XP Embedded. 
You use a LabVIEW project to define a Touch Panel target for which you 
can build, deploy, and run a Touch Panel application on a Touch Panel 
device. You can create a project by using the Touch Panel Project Wizard.
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Enhancements to Navigation Controls
The Navigation Controls Manager dialog box includes the Align and 
Customize pages. Use the Align page to align navigation controls and front 
panel windows of VIs in the project library. Use the Customize page to 
select a control file to use as a navigation control. When you select the 
control file, LabVIEW creates an XControl to use as the navigation control. 
You also can replace a navigation control with an existing XControl by 
right-clicking the navigation control from the front panel, selecting 
Replace from the shortcut menu, and selecting the XControl to use.

You can set the string text on the Previous Button, Next Button, and 
Jump Button programmatically by using the Button Text property. 
Right-click a navigation control from the front panel, select Create»
Property Node, and select the Button Text property from the shortcut 
menu. LabVIEW creates the Property Node on the block diagram. 
The Property Node links implicitly to the navigation control.

Enhancements to the NI Distributed System Manager
Use the NI Distributed System Manager to create and monitor shared 
variables, processes, and I/O servers. You also can use the System Manager 
to manage security and aliases. In LabVIEW, select Tools»Distributed 
System Manager to launch the System Manager.

LabVIEW includes the following enhancement to the System Manager:

• Synchronizing time for networked computers—Use the Shared 
Variable Engine Time Server Configuration dialog box, available 
by selecting View»Configure Time Servers, to synchronize the time 
of computers on the network with a central time server.

Enhancements to the Historical Data Viewer
The Historical Data Viewer in the Measurement & Automation Explorer 
(MAX) contains the Import Settings and Export Settings buttons in the 
Trace Properties view and Display view of the trace view. Use the 
Import Settings button to import display configuration settings from a 
file to a trace view. Use the Export Settings button to export display 
configuration settings to a file from a trace view. The display configuration 
settings import from and export to an XML file.
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New VIs
The DSC Module includes the following new VIs:

Write Filters VIs for Touch Panel Devices
Write filters protect data from unwanted modifications by redirecting write 
operations to another location or overlay. Use enhanced write filters (EWF) 
to protect volumes and redirect writes to a disk location on another volume 
or to the RAM. Use file-based write filters (FBWF) to protect files and 
folders in a volume and redirect writes to the memory cache. Write filters 
are available for Touch Panel devices running Windows XP Embedded. 
The Functions palette includes the new Touch Panel palette. The 
Touch Panel palette includes the new Write Filters palette.

The Write Filters palette includes the new Enhanced Write Filter (EWF) 
palette with the following new VIs:

• EWF Checkpoint

• EWF Clear Command

• EWF Commit Volume

• EWF Enable HORM

• EWF Get Config Information

• EWF Protect Volume

• EWF Restore

The Write Filters palette includes the new File-Based Write Filter (FBWF) 
palette with the following new VIs:

• FBWF Add Exclusion

• FBWF Cache Configure

• FBWF Commit All

• FBWF Commit File

• FBWF Enable

• FBWF Get Cache Usage Information

• FBWF Get Config Information

• FBWF Protect Volume

• FBWF Remove Exclusion

• FBWF Restore File

Refer to the MSDN Web site at http://msdn.microsoft.com to learn 
more about write filters.

http://msdn.microsoft.com/
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EPICS VIs
The Data Communication palette includes the new EPICS palette with 
the following new VIs:

• Create EPICS Server

• Create PV

• Delete PV

• Deploy EPICS Server

• Get PV Attributes

• List PVs

• Undeploy EPICS Server

Other New VIs
The Tags palette includes the following new VI:

• Get Computer List

The Database Management palette includes the following new VI:

• Get Database List

Changed VIs
The DSC Module includes the following changed VIs:

• Configure Initial Value—The data type (deprecated) input replaces 
the data type input. This VI automatically detects the data type of the 
shared variable you specify in the variable reference in input.

• Configure Logging—The data type (deprecated) input replaces the 
data type input. This VI automatically detects the data type of the 
shared variable you specify in the variable reference in input.

• Configure Scaling—The data type (deprecated) input replaces the 
data type input. This VI automatically detects the data type of the 
shared variable you specify in the variable reference in input.

• Data Set Internal ID String to ID Cluster—The internal ID raw 
data input replaces the internal_ID raw data input.

• Open Trace—Use the lifespan in days input to specify the numbers 
of days that LabVIEW stores a trace in the Citadel database.

• Read Events—Use the shared variables input to specify a list of 
shared variables for which you want to read event information.

• Write Traces to Spreadsheet—Use the formatValue variable, 
which you can apply to the row format input, to specify the export 
format of a numeric variable.

• Write Traces to Spreadsheet File—Use the formatValue variable, 
which you can apply to the row format input, to specify the export 
format of a numeric variable.
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New Properties
The DSC Module includes the following new SharedVariableIO 
properties:

• Initial Value:Int8 

• Initial Value:Int16 

• Initial Value:Int32 

• Initial Value:Int64 

• Initial Value:Single 

• Initial Value:UInt8 

• Initial Value:UInt16 

• Initial Value:UInt32 

• Initial Value:UInt64

Refer to the Property and Method Reference»SharedVariableIO book 
on the Contents tab of the LabVIEW Help for more information about 
SharedVariableIO properties.

Upgrade and Compatibility Issues
Refer to the following section for upgrade and compatibility issues specific 
to different versions of the DSC Module.

Upgrading from the DSC Module 8.2
If you open a VI saved in the DSC Module 8.2 or earlier, the VI might be 
broken if the VI contains an indicator, constant, or control created from the 
shared variable value change notification output of the following VIs.

• Cancel Value Change Notifications

• Enable Value Change Notifications

• Request Value Change Notifications

To fix the broken VI, delete the indicator, constant, or control. Then create 
a new indicator, constant, or control from the shared variable value 
change notification output and wire it to the appropriate parameter.
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Upgrading from the DSC Module 7.x 
If you are upgrading from the DSC Module 7.x or earlier, refer to 
the Upgrading from the LabVIEW DSC Module 7.x section of the 
LabVIEW 8.2 Datalogging and Supervisory Control Module Release and 
Upgrade Notes for important upgrade information. Refer to the National 
Instruments Web site at ni.com/info and enter the Info Code dsc820 to 
access the LabVIEW 8.2 Datalogging and Supervisory Control Module 
Release and Upgrade Notes.

DSC Module Run-Time System
To run applications built with LabVIEW, the DSC Module, and the 
LabVIEW Application Builder on a computer without the DSC Module 
installed, you must install the DSC Module Run-Time System on that 
computer. The DSC Module Run-Time System contains components that 
enable the DSC Module features in the built applications. Refer to the 
National Instruments Web site at ni.com/info and enter the Info Code 
dscrts for information about the DSC Module Run-Time System.

To use the DSC Module Run-Time System, the computer must meet the 
following minimum system requirements:

• Depending on the components you choose to install, the computer 
must have the following amount of free disk space:

– 1.0 GB free disk space if you install all components of the 
DSC Module Run-Time System except the Shared Variable 
Logging Support component

– 1.3 GB free disk space if you install all components of the 
DSC Module Run-Time System 

• 512 MB of RAM.

The DSC Module Run-Time System supports the same operating systems 
as the DSC Module. Refer to the Supported Operating Systems section 
of this document for information about operating systems that the 
DSC Module Run-Time System supports.

Installing the DSC Module Run-Time System
Complete the following steps to install the DSC Module Run-Time System.

1. Log in to the computer as an administrator or as a user with 
administrative privileges.

2. Install the DSC Module Run-Time System from the LabVIEW 2010 
DSC Module Run-Time System installation media.

3. Follow the instructions that appear on the screen.

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=dsc820
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=dscrts
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Note If you install the DSC Module Run-Time System on a Touch Panel computer, 
National Instruments recommends that you do not install the Shared Variable Logging 
Support component unless you need to log data to the Touch Panel computer. Logging 
data consumes resources, such as memory and disk space, that you may want to reserve for 
other uses. If you do not install the Shared Variable Logging Support component, you 
still can use the Touch Panel computer to view logged data on other computers.

4. Restart the computer.

Configuring the Microsoft SQL Server
The DSC Module requires the Microsoft SQL Server 2005 Express Edition 
(SQL Express). This component is installed by default when you install the 
DSC Module. During the installation process, the DSC Module installer 
creates an instance of SQL Express named CITADEL. To prevent 
unauthorized access to SQL Express, the installer also generates a 
password for the default SQL Express administrator sa. The default 
password is the computer ID. 

Complete the following steps to find the computer ID using the NI License 
Manager.

1. Launch the NI License Manager by selecting Start»All Programs»
National Instruments»NI License Manager.

2. Click the Display Computer Information button on the toolbar.

The DSC Module installer enables a mixed security mode on existing SQL 
Servers. If the target computer does not have an SQL Server installed, the 
DSC Module installer installs SQL Express in the mixed security mode.

Use the following command line prompt to change the default password for 
the sa user:

Sqlcmd -S"localhost\CITADEL" -U"sa" -P"COMPUTER_ID" 
-Q"sp_password 'COMPUTER_ID', 'NEW_PASSWORD', 'sa'"

If the mixed security mode is not acceptable, change both the SQL Express 
and Citadel login modes. You must set the registry DWORD values 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\

MSSQLServer\LoginMode and 
HKEY_LOCAL_MACHINE\SOFTWARE\National Instruments\

Citadel\5.0\IntegratedSecurity to 1.
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National Instruments recommends that you change the login mode 
immediately after you install the DSC Module. Otherwise, you must relink 
all existing Citadel databases. Restart the SQL Express and Citadel services 
in order for changes to take effect. If you use integrated NT security, you 
might need to configure the server machine and all clients explicitly.

Note The DSC Module 8.2 uses Microsoft SQL Server 2000 Desktop Engine (MSDE 
2000), not SQL Express. If you are upgrading from the DSC Module 8.2, any existing 
databases continue to use MSDE 2000 for alarm logging, but new databases you create use 
SQL Express. If you detach an existing database from the DSC Module and then reattach 
the database, the DSC Module migrates the database to SQL Express.

You might want to uninstall MSDE 2000 after installing the DSC 
Module 2010. Complete the following steps to uninstall MSDE 2000.

1. Stop all running processes in the NI Distributed System Manager.

2. Open Measurement & Automation Explorer (MAX) and select 
My System»Historical Data»Citadel 5 Universe from the 
Configuration tree.

3. On the Databases page, detach all databases from the local computer.

4. Open the Windows Control Panel and uninstall MSDE 2000.

5. Restart the computer.

6. Open MAX and reattach all databases.

Where to Go from Here
National Instruments provides many resources to help you succeed with 
your NI products. Use the following resources as you start exploring the 
DSC Module.

Getting Started
Refer to the Getting Started with the LabVIEW Datalogging and 
Supervisory Control Module manual in the labview\manuals directory 
for exercises you can complete to familiarize yourself with the 
DSC Module.

DSC Module Examples
Use the NI Example Finder, available by selecting Help»Find Examples 
from LabVIEW, to browse or search for the DSC Module example VIs. 
You also can access the example VIs from the labview\examples\
lvdsc directory.
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Related Documentation
Refer to the LabVIEW Help for information about LabVIEW and the 
DSC Module, and refer to the Context Help window for information about 
using VIs and functions.

• LabVIEW Help—Available by selecting Help»LabVIEW Help in 
LabVIEW. Browse the DSC Module book on the Contents tab for an 
overview of the DSC Module. 

• Context Help window—Available by selecting Help»Show Context 
Help in LabVIEW.

NI Web Site
Visit ni.com/dsc for the latest NI Developer Zone articles, examples, and 
support information for the DSC Module.

Refer to ni.com/info and enter the Info Code dsctrn to access online 
training for the DSC Module.

Known Issues
You can access the software and documentation known issues list online. 
Refer to the National Instruments Web site at ni.com/info and enter the 
Info Code LVDSC2010KI for an up-to-date list of known issues in the DSC 
Module and the DSC Module Run-Time System.

http://www.ni.com/dsc
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=dsctrn
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=LVDSC2010KI
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