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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.
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1
Introduction to NI Circuit Design 
Suite

Some of the features described in this book may not be available in your 
edition of NI Circuit Design Suite. Refer to the release notes for a list of the 
features in your edition. 

NI Circuit Design Suite Product Line
National Instruments Circuit Design Suite is a suite of EDA (Electronics 
Design Automation) tools that assists you in carrying out the major steps in 
the circuit design flow. 

Multisim is the schematic capture and simulation program designed for 
schematic entry, simulation, and feeding to downstage steps, such as PCB 
layout. Multisim also includes mixed analog/digital simulation capability, 
and microcontroller co-simulation. 

Ultiboard, fed from Multisim, is used to design printed circuit boards, 
perform certain basic mechanical CAD operations, and prepare them for 
manufacturing. Ultiboard also provides automated parts placement and 
layout. 

The Tutorials
This book contains the following step-by-step tutorials: 

• Multisim Tutorial—Introduces you to Multisim and its many 
functions. 

• Ultiboard Tutorial—Shows you how to place the components and 
traces for the circuit described in the Multisim Tutorial chapter. You 
will also learn how to autoplace parts and then autoroute them. 

• Multisim MCU Tutorial—Leads you through the process of simulating 
and debugging a circuit that contains a microcontroller. 

For more detailed information on the features discussed in these chapters, 
refer to the Multisim User Manual or the Ultiboard User Manual. 
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2
Multisim Tutorial

This chapter contains a tutorial that introduces you to Multisim and its 
many functions. 

Some of the features described in this chapter may not be available in your 
edition of Multisim. Refer to the release notes for a list of the features in 
your edition. 

Introduction to the Multisim Interface
Multisim is the schematic capture and simulation application of National 
Instruments Circuit Design Suite, a suite of EDA (Electronics Design 
Automation) tools that assists you in carrying out the major steps in the 
circuit design flow. Multisim is designed for schematic entry, simulation, 
and feeding to downstage steps, such as PCB layout. 
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Multisim’s user interface consists of the following basic elements:

The Menu Bar is where you find commands for all functions. 

The Design Toolbox lets you navigate through the different types of files 
in a project (schematics, PCBs, reports), view a schematic’s hierarchy and 
show or hide different layers. 

The Component toolbar contains buttons that let you select components 
from the Multisim databases for placement in your schematic. 

1 Menu Bar
2 Design Toolbox
3 Component Toolbar
4 Standard Toolbar

5 View Toolbar
6 Simulation Toolbar
7 Main Toolbar

8 In Use List
9 Instruments Toolbar
10 Scroll Left/Right

11 Circuit Window
12 Spreadsheet View
13 Active Tab
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The Standard toolbar contains buttons for commonly-performed functions 
such as Save, Print, Cut, and Paste. 

The View toolbar contains buttons for modifying the way the screen is 
displayed.

The Simulation toolbar contains buttons for starting, stopping, and other 
simulation functions. 

The Main toolbar contains buttons for common Multisim functions.

The In Use List contains a list of all components used in the design. 

The Instruments toolbar contains buttons for each instrument. 

The Circuit Window (or workspace) is where you build your circuit 
designs. 

The Spreadsheet View allows fast advanced viewing and editing of 
parameters including component details such as footprints, RefDes, 
attributes and design constraints. Users can change parameters for some or 
all components in one step and perform a number of other functions. 

Overview
This tutorial leads you through the circuit design flow, from schematic 
capture, through simulation and analysis. After following the steps outlined 
on the following pages, you will have designed a circuit that samples a 
small analog signal, amplifies it and then counts the occurrences of the 
signal on a simple digital counter. 

Helpful tips are indicated by the presence of an icon in the left column, 
as in: 

Tip You can access the online help at any time by pressing F1 on your keyboard, or by 
clicking on the Help button in a dialog box. 

When you get to the wiring section of this tutorial, you can carry on with 
the circuit you created in the component placement section. 

Alternatively, you can open Getting Started 1.ms10, found at 
...\samples\Getting Started\. This file has all of the components 
properly placed. 
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When you arrive at the simulation section, you can carry on with the circuit 
you wired, or open Getting Started 2.ms10, which has all of the 
components properly wired. 

Schematic Capture
In this section, you will place and wire the components in the circuit shown 
below.

 



Chapter 2 Multisim Tutorial

© National Instruments Corporation 2-5 Getting Started with NI Circuit Design Suite

Opening and Saving the File
Complete the following step to launch Multisim:

1. Select Start»All Programs»National Instruments»Circuit Design 
Suite 10.1»Multisim 10.1. A blank file opens on the workspace called 
Circuit1. 

Complete the following steps to save the file with a new name: 

1. Select File»Save As to display a standard Windows Save dialog.

2. Navigate to the location where you wish the file to reside, enter 
MyGettingStarted as the filename, and click the Save button.

Tip To guard against accidental loss of data, set up a timed auto-backup of the file in the 
Save tab of the Preferences dialog box. 

Complete the following step to open an existing file:

1. Select File»Open, navigate to the location where the file resides, 
highlight the file, and click on the Open button. 

Tip To view files from earlier versions of Multisim, select the desired version in the Files 
of Type drop-down in the Open dialog. 

Placing the Components
Complete the following steps to start placing components:

1. Open MyGettingStarted.ms10 as described above. 

2. Select Place»Component to display the Select a Component 
browser, navigate to the 7-segment LED display as shown below 
and click OK. The component appears as a “ghost” on the cursor. 

Tip Once you have selected the desired Group and Family, start typing the 
component’s name in the browser’s Component field. As you type, the string appears 
in the Searching field at the bottom of the browser. In the example below, type 
seven_seg_decimal_com_a_blue. Matches are displayed as you type.
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3. Move the cursor to the bottom-right of the workspace and left-click to 
place the component. Note that the Reference Designator for this 
component is “U1.” 

4. Place the remaining components in the Digital Counter area as shown 
below.
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Note When placing resistors, inductors, or capacitors (RLC components), the Select a 
Component browser has slightly different fields than for other components. When placing 
any of these components, you can choose any combination of: the component’s value 
(for example, the resistance value); type (for example, carbon film); tolerance; footprint 
and manufacturer. If you are placing a component that will be ultimately exported to PCB 
layout, and become part of a Bill of Materials, you must be careful that the combination 
of values that you select in the Select a Component dialog box are available in a 
real-world, purchaseable component. 

Tip When placing RLC components, type the value of the device that you want to place 
in the field at the top of the Component list. The value does not need to appear in the list to 
be placed on the schematic. 

Tip While placing the 200 Ω resistor, rotate it to a vertical orientation by pressing Ctrl-R 
on your keyboard. 

Tip Reference Designators (for example, U1, U2) are assigned in the order the 
components are placed. If you place components in a different order than in the original 
circuit, the numbering will differ. This will not affect the operation of the circuit in any way. 
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5. Place the parts in the Counter Control section. After placement, 
right-click on each of the SPDT switches and select Flip Horizontal.

 

Tip The SPDT switches are in the Basic Group; Switch Family.

Tip When a part is on the workspace and you want to place the same part again, highlight 
it and select Edit»Copy, then Edit»Paste. You can also select it from the In Use List and 
click to place it on the workspace. 

6. Place the parts in the Analog Amplifier section as shown below, 
rotating as needed.

 

After you place the AC voltage signal source, double-click on it. 
Change the Voltage (Pk) to 0.2 V and click OK to close the dialog.
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7. Place the parts in the Bypass Capacitors section as shown below.
 

8. Place the header and associated parts as shown below.
 

Tip J3 is in the Basic Group; Connectors Family

Tip Once you have wired a circuit, you can drop two-pinned components like resistors 
directly onto a wire. The connection is automatically made by Multisim. 

Wiring the Circuit
All components have pins that you use to wire them to other components 
or instruments. As soon as your cursor is over a pin, Multisim knows you 
want to wire and the pointer changes to a crosshair. 

Tip You can wire the circuit that you placed on the workspace or you can use 
Getting Started 1.ms10 from the Getting Started folder (found inside the 
samples folder). 
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Complete the following steps to wire the circuit: 

1. Click on a pin on a component to start the connection (your pointer 
turns into a crosshair) and move the mouse. A wire appears, attached 
to your cursor. 

2. Click on a pin on the second component to finish the connection. 
Multisim automatically places the wire, which conveniently snaps to 
an appropriate configuration, as shown below. This feature saves a 
great deal of time when wiring large circuits.

 

3. You can also control the flow of the wire by clicking on points as you 
move the mouse. Each click “fixes” the wire to that point. 
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4. Finish wiring the Digital Counter section as shown below. 
 

Tip Use Bus Vector Connect to wire multi-pinned devices like U3 and R4 together in a 
bus. Refer to the Multisim User Manual for details. 

Tip Virtual Wiring—To avoid clutter, you could use virtual connections between the 
Counter Control and Digital Counter sections. When two nets have the same net name, they 
are virtually connected. 
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5. Finish wiring the circuit as shown below.
 

Simulation
Simulating your circuits with Multisim catches errors early in the design 
flow, saving time and money. 

Virtual Instrumentation
In this section, you will simulate the circuit with the virtual oscilloscope. 

Tip You can also use Getting Started 2.ms10 from the Getting Started folder 
(found inside the samples folder). 

1. J1, J2 and R2 are interactive components. 

Set up the interactive keys for J1, J2 and R2 by double-clicking on 
each. In the Key field, enter "E" for J1, "L" for J2, and "A" for R2. 

Press "E" to enable the counter, or just click on the widened switch arm 
that appears when you hover the cursor over J1. 

2. Select Simulate»Instruments»Oscilloscope to place the oscilloscope 
on the workspace. Wire the instrument as shown in step 4. 
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Tip To easily differentiate between traces on the oscilloscope, right-click on the wire 
connected to the scope’s “B” input and select Segment Color from the pop-up. Select a 
color that differs from the wire connected to the “A” input, for example blue. (Simulation 
cannot be running when changing wire color or performing any other editing function.)

3. Double-click on the scope’s icon to show the instrument face. Select 
Simulate»Run. The output of the opamp appears on the scope. 

4. Adjust the Timebase to 2mS/Div and Channel A’s Scale to 
500mV/Div. You will see the following displayed on the scope.

 

As the circuit simulates, the 7-segment display counts up and the LED 
flashes at the end of each count cycle. 

5. Press E on your keyboard while the simulation is running to enable or 
disable the counter. Enable is Active Low. 

Press L to load zeros into the counter. Load is Active Low. 

Press Shift-A to observe the effect of changing the potentiometer’s 
setting. Repeat, pressing A. 

Tip Instead of pressing the above-mentioned keys, you can directly manipulate the 
interactive components on the schematic with your mouse. 
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Analysis
In this section, you will use AC Analysis to verify the frequency response 
of the amplifier. 

Complete the following steps to perform an AC Analysis at the output of 
the opamp: 

1. Double-click on the wire that is attached to pin 6 of the opamp, and 
change the net name to analog_out in the Net dialog box. 

2. Select Simulate»Analyses»AC Analysis and click on the Output tab.
 

3. Highlight V(analog_out) in the left column and click Add. 
V(analog_out) moves to the right column. 



Chapter 2 Multisim Tutorial

© National Instruments Corporation 2-15 Getting Started with NI Circuit Design Suite

4. Click Simulate. The results of the analysis appear in the Grapher.
 

The Grapher
The Grapher is a multi-purpose display tool that lets you view, adjust, save 
and export graphs and charts. It is used to display the results of all Multisim 
analyses in graphs and charts and a graph of traces for some instruments 
(for example, the results of the oscilloscope). 

Complete the following steps to view results of a simulation on the 
Grapher: 

1. Run the simulation as described earlier. 

2. Select View»Grapher.
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The Postprocessor
The Postprocessor lets you manipulate the output from analyses 
performed on a circuit and plot the results on a graph or chart. Types of 
mathematical operations that can be performed on analysis results include 
arithmetic, trigonometric, exponential, logarithmic, complex, vector and 
logic. 

Reports
Multisim allows you to generate a number of reports: Bill of Materials 
(BOM), Component Detail Report, Netlist Report, Schematic 
Statistics, Spare Gates and the Cross Reference Report. This section uses 
the BOM as an example for the tutorial circuit. 
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Bill of Materials
A bill of materials lists the components used in your design and therefore 
provides a summary of the components needed to manufacture the circuit 
board. Information provided includes: 

• Quantity of each component needed.

• Description, including the type of part (example: resistor) and value 
(example: 5.1 kohm). 

• Reference Designator of each component. 

• Package or footprint of each component. 

Complete the following step to create a BOM (bill of materials) for your 
circuit: 

1. Click the Reports menu and choose Bill of Materials from the menu 
that appears. 

The report appears, looking similar to this:
 

To print the Bill of Materials, click the Print button. A standard Windows 
print screen appears, allowing you to choose the printer, number of copies, 
and so on. 



Chapter 2 Multisim Tutorial

Getting Started with NI Circuit Design Suite 2-18 ni.com

To save the Bill of Materials to a file, click the Save button. A standard 
Windows file save dialog box appears, allowing you to specify the path and 
file name. 

Because the Bill of Materials is primarily intended to assist in procurement 
and manufacturing, it includes only “real” parts—it excludes parts that are 
not real or able to be purchased, such as sources or virtual components. 
Components without assigned footprints do not appear in the Bill of 
Materials. 

To see a list of components in your circuit that are not “real” components, 
click the Virtual button. A separate window appears, showing these 
components only. 

Detailed information on this and other reports can be found in the Multisim 
User Manual. 
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3
Ultiboard Tutorial

The tutorial in this chapter places the parts and traces for the circuit 
described in the Multisim Tutorial chapter. 

Tip For instructions on exporting a design from Multisim to Ultiboard, refer to the 
Multisim User Manual, the Ultiboard User Manual, or the help files. 

Introduction to the Ultiboard Interface
Ultiboard is the PCB layout application of National Instruments Circuit 
Design Suite, a suite of EDA (Electronics Design Automation) tools that 
assists you in carrying out the major steps in the circuit design flow. 
Ultiboard is used to lay out and route printed circuit boards, perform certain 
basic mechanical CAD operations, and prepare them for manufacturing. 
It also provides automated parts placement and layout. 

Ultiboard’s user interface is made up of several elements. 
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The Menu Bar is where you find commands for all functions. 

The Standard toolbar contains buttons for commonly-performed functions 
such as Save, Print, Cut, and Paste. 

As you add more parts and traces to a board, it can become difficult to select 
only those which you want to use. The Select toolbar contains buttons used 
to control selections. 

The Draw Settings toolbar lets you select the layer, thickness and unit of 
measure of a line or object that is being drawn. It also contains buttons for 
functions that control the appearance of lines and shapes drawn on a layer. 

1 Menu Bar
2 Standard Toolbar
3 Select Toolbar
4 Draw Settings Toolbar

5 View Toolbar
6 Main Toolbar
7 Autoroute Toolbar

8 Status Bar
9 Workspace
10 Spreadsheet View

11 Design Toolbox
12 3D Preview
13 Birds Eye View
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The View toolbar contains buttons for modifying the way the screen is 
displayed.

The Main toolbar contains buttons for common board design functions.

The Autoroute toolbar contains autorouting and part placement functions. 

The Status Bar displays useful and important information. 

The Workspace is where you build your design. 

The Spreadsheet View allows fast advanced viewing and editing of 
parameters including part details such as shapes, Reference Designators, 
attributes and design constraints. 

The Design Toolbox lets you show, hide, or dim elements of your design.

The 3D Preview shows you a three-dimensional preview of the board. 

The Birds Eye View shows you the design at a glance and lets you easily 
navigate around the workspace. 

Opening the Tutorial
Complete the following steps to open the tutorial file: 

1. Select Start»All Programs»National Instruments»Circuit Design 
Suite 10.1»Ultiboard 10.1 to launch Ultiboard.

2. Select File»Open. 

3. Select File»Open Samples and double-click on the Getting 
Started folder to open it. 

4. Select Getting Started.ewprj and click Open. The project file is 
loaded into Ultiboard. 
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5. To select a design (for example, GS1) either click on its tab, or click on 
its name in the Projects tab of the Design Toolbox. 

Creating a Board Outline
You can create a board outline in one of the following ways:

• draw a board outline using the drawing tools 

• import a DXF file

• use the Board Wizard.

Complete the following steps to experiment with the Board Wizard:

1. Double-click on Board Outline in the Layers tab.

2. Click on the existing board outline in the GS1 design and press Delete. 

3. Choose Tools»Board Wizard. 
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4. Enable the Change the layer technology option to make the other 
options available. 

5. Choose Multi-layers constructed with double sided boards and 
single layer stack-ups, and click Next. 
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6. The next dialog box is where you define the Lamination Settings for 
the board. (For this tutorial you will not change settings.)

 

7. Click Next. 

In the Shape of Board dialog box:

• Make sure the Reference Point is set to Left-Bottom for 
Alignment.

• Make sure the Rectangular option is selected.

• Set the Width to 3000 and the Height to 2000 (a more suitable 
size for the parts in this design).

• Set the Clearance to 5.00000. This is the distance from the edge 
of the board that is to be kept free of any other elements.

8. Click Finish. The board outline is placed on your design.

Note For complete details on the Board Wizard, refer to the Ultiboard User Manual. 
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Complete the following steps to move the board outline:

1. Double-click on Board Outline in the Layers tab.

2. Click anywhere on the board outline in the workspace and drag the 
board to a location just below the row of parts.

Complete the following steps to change the reference point:

1. Select Design»Set Reference Point. The reference point is attached to 
your cursor.

2. Move the cursor the the lower-left corner of the board outline and click 
to place it.

 

Placing Parts
You can place parts on your GS1 design file in several different ways: 

• Select one or more parts from outside the board outline and drag them 
into place.

• Use the Parts tab in the Spreadsheet View to locate parts and place 
them.

• Select parts from the database.
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Tip You can use the Place»Unplace Parts command to quickly remove all non-locked 
parts from the PCB and experiment with a different placement technique. 

Dragging Parts from Outside the Board Outline
By default, parts are placed outside the board outline when you open a 
netlist from Multisim or another schematic capture program. Before you 
begin, double-click the Copper Top layer in the Design Toolbox to make 
it the active layer. 

Complete the following steps to drag U1 from outside the board outline: 

1. Find U1 in the collection of parts outside the board outline. To make 
this easier, zoom in (press F8) until you can see U1. 

Tip You can also search for a part with the Edit»Find command. While this command 
works much like a Find function in other applications, it also allows you to search for a part 
by name, number, shape, value, or by all variables. Refer to the Ultiboard User Manual for 
details. 

2. Click on U1 (the 7-segment display) and drag it to the location shown 
in the figure below.

Note For information on Force Vectors and Ratsnests, shown in the figure below, refer to 
the Ultiboard User Manual. 
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U1 remains selected. This is an important point for Ultiboard that 
holds throughout the application—you need to explicitly end any 
particular action. In this case, simply clicking somewhere else 
de-selects the part. Right-clicking also ends the current action. 

3. Go to the Parts tab in the Spreadsheet View and scroll to U1. You will 
notice that the green light beside the part is slightly brighter—this 
indicates that the part has been placed. 

Dragging Parts from the Parts Tab
Complete the following steps to drag parts from the Parts tab: 

1. In the Parts tab, scroll down until you see J3.
 

1 Force Vector 2 Ratsnest
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2. Click on J3 and drag it from the Parts tab onto the workspace. J3 is 
attached to your mouse pointer. 

3. Drop J3 on the left edge of the board, roughly in the middle. As before, 
in the Parts tab J3’s green light is slightly brighter, indicating that the 
part has been placed.

For even more rapid placement of parts, in the Parts tab select an unplaced 
part (its green light is dim) and click the Start Placing the Unpositioned 
Parts button. Ultiboard systematically goes through the list of parts in the 
Parts tab, selecting each one and attaching it to your mouse pointer so you 
can place it, then selects the next one on the list. 

Placing the Tutorial Parts
Using any method or combination of methods, make your layout look like 
the illustration below. You can also simply open the next design file in the 
project, GS2, which has already been set up this way. 

Your design should look like this: 
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Placing Parts from the Database
In addition to placing parts imported as part of your design file, you can 
place parts directly from the database. The following uses this method to 
place the mounting holes. 

Complete the following steps to place parts from the database:

1. Choose Place»From database. The Get a part from the database 
dialog box opens. 

2. In the Database panel, expand the Through Hole Technology Parts 
category and navigate to the Holes category. The parts appear in the 
Available Parts panel. 

3. In the Available Parts panel, select the Hole35 part. The part displays 
in the Preview panel. 

 

4. Click OK. The Get a part from the database dialog box disappears, 
and you are prompted to enter the RefDes and Value. 

5. Enter the hole’s reference designator (H1) and value (HOLE) and click 
OK. 

6. Move the pointer over the board. The part is attached to the pointer.
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7. When the hole is in position in the top-left corner, click to drop it on 
the board. 

8. The Enter Reference Designation for Part dialog box reappears, 
with the reference designator automatically incremented to H2. 

9. Enter the value (HOLE) and click OK to place the next mounting hole 
in the top right corner, and repeat to place H3 in the bottom right 
corner, and H4 in the bottom left corner. 

10. Click Cancel to stop, and click Cancel again to close the Get a part 
from the database dialog box. 

 

Moving Parts
You can use the same methods for moving parts as you do for placing them. 
To select a part already on the board, simply click on it. To specify the X/Y 
coordinates to which the selected part is to move, press the * key on the 
numeric keypad. Alternatively, in the Parts tab, select a placed part 
(indicated by a bright green light beside it) and drag it to a new location. 
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Tip The part’s label is a separate element from its shape. When selecting a part on the 
board, be sure to select the whole part, not just the label. Try using the Selection Filters to 
assist with this. Refer to the Ultiboard User Manual for more information. 

Tip Once a part is selected, you can also move it around on the board by pressing the 
arrow keys on your keyboard. 

You can also select a group of parts and move them together. To do this, you 
can do one of the following: 

• Hold down the Shift key and click on more than one part.

• Drag a box around several parts. 

All the selected parts will move together when you drag the cursor.

Tip These are temporary groups—once you select another part, the group connection is 
lost. To make a group that remains until you remove it, you can use the Group Editor. For 
details, refer to the Ultiboard User Manual. 

Another option for moving parts is to use the Edit»Align commands to 
align the edges of selected parts or to space them relative to each other. 

Use the Edit»Align commands to align the mounting holes you just placed: 

1. Select H1 and hold down the Shift key to select H2. 

2. Choose Edit»Align»Align Top. If H2 was not originally placed 
exactly in line with H1, you will see it move. 

3. Click on an empty space on the board, then select H2 and H3. 

4. Choose Edit»Align»Align Right. 

5. Continue in this manner to align the bottoms of H3 and H4, and the left 
sides of H1 and H4. 

Placing Traces
You have the following options for placing traces: 

• Manual trace

• Follow-me trace

• Connection machine trace

A manual trace is placed exactly as you specify, even running through 
a component or trace if that is the path you set out. A follow-me trace 
automatically draws a legal trace between the pins you select with your 
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mouse movements—you can move from pin to pin, leaving a legal trace. A 
connection machine trace automatically joins two pins by the most efficient 
route, though you have the option of changing it.

As you place a trace, and before you click to fix it in place, you can always 
remove a segment by backing up over it. Each time you click while placing 
a manual trace, or each time a follow-me trace or connection machine trace 
changes direction, a separate segment of that trace is created. When 
performing operations on traces, be sure to select either the appropriate 
segment or, if you wish, the whole trace.

Placing a Manual Trace
You can continue with the design you have been working on, or open GS3. 
Be sure you are on the Copper Top layer before beginning—Copper Top 
should be highlighted in red in the Layers tab of the Design Toolbox. 

Tip If necessary, press F7 to show the whole design. 

Complete the following steps to place a trace manually: 

1. Choose Place»Line. 

Tip The Line command is used to create a line on any layer. The results differ depending 
on the layer selected. For example, if the selected layer is silkscreen, you will create a line 
on the silkscreen layer of the PCB. If the selected layer is a copper layer, then the “line” is 
actually a trace. 
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2. Locate J3, toward the left-hand part of the board. Find the start pin 
shown below:

 

Tip If you have trouble locating the part, use the Find function of the Parts tab. Select the 
part in the Parts tab, then click the Find and select the part button. The part is shown in 
the workspace. If necessary, zoom in further using F8. 

3. Click on the pin specified in the above step. Ultiboard highlights all the 
pins that are part of the same net as the pin you clicked on with an X. 
(The color of the highlighting can be changed in the Colors tab of the 
Preferences dialog box.) This is how you know where to connect to 
pins to match the connectivity from your schematic. 

1 Part J3 2 Start Pin
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4. Move the cursor in any direction. A green line (the trace) is attached to 
the selected pin. Each time you click you anchor the trace segment, 
as shown in the figure below (2). 

5. Click on the destination pin. 
 

6. Right-click to stop placing traces. 

1  Pins in the Same Net  

1 Trace
2 Click to anchor trace

3 Destination Pin
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Placing a Follow-me Trace
Complete the following steps to place a follow-me trace: 

1. Choose Place»Follow-me. 

2. Click on the top pin of J3. 

3. Click on the second pin from the bottom in the left column of U4. 

4. Ultiboard draws the connection for you. 

Tip You do not need to click exactly on a pin—you can also start by clicking on a ratsnest 
line. 

Placing a Connection Machine Trace
Complete the following steps to place a Connection Machine trace:

1. Choose Place»Connection Machine. 

2. Click on the segment of the ratsnest indicated below.
 

1 Click Ratsnest  
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3. Move your cursor—Ultiboard suggests various trace placement 
options routed around obstacles. 

4. When you see the route you want, click to fix the trace. You don’t have 
to click on the ratsnest or the destination pin. 

 

5. Right-click to end trace placement. 

Auto Part Placement
As well as placing parts as described earlier in this chapter, you can use 
Ultiboard’s advanced automatic part placement functionality. 

Tip Before autoplacing parts, pre-place and lock any parts that you do not wish to be 
moved during the autoplacement process. (The mounting holes, and U1, J1, J2, J3, and 
LED 1 in GS5 have been pre-placed and locked.) For details on locking parts, refer to the 
Ultiboard User Manual. 

1 Trace Segments Appear Between Pins  
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Complete the following steps to autoplace the parts in Getting 
Started.ewprj: 

1. Open the GS5 design in Ultiboard. 

2. Select Autoroute»Start Autoplacement. The parts are placed on the 
circuit board.

 

Autorouting Traces
You can place traces in Ultiboard using the methods described earlier in 
this chapter, or automatically route the traces as described below. 

Complete the following steps to autoroute the traces in Getting 
Started.ewprj: 

1. Open the GS3 design in Ultiboard. 

2. Select Autoroute»Start/Resume Autorouter. The workspace goes to 
Autorouter Mode and trace autorouting begins. 

As autorouting proceeds, you will see traces being placed on the board. 
When autorouting is complete, Autorouter Mode closes and you are 
returned to the workspace.

3. Optionally, select Autoroute»Start Optimization to optimize the 
placement of the traces. 
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The autorouter can be stopped at any time and you can make manual 
changes as desired. When you restart the autorouter, it will continue with 
the changes you made. Remember to lock any traces that you have placed 
manually and do not wish to be moved by the autorouter. 

Tip Use the Routing Options dialog box to modify autoplacement and autorouting 
options. Refer to the Ultiboard User Manual for details. 

Preparing for Manufacturing/Assembly
Ultiboard can produce many different output formats to support your 
production and manufacturing needs. This section explains the functions 
performed to output your board for production and documentation 
purposes. 

Cleaning up the Board
Before sending the board for manufacturing, you should clean up any open 
trace ends (trace segments that do not have any terminating connections in 
the design) and unused vias that have been left on the board. 

To delete open trace ends, make sure the GS4 design is open and choose 
Edit»Copper Delete»Open Trace Ends. This deletes all open trace ends 
in the design. 
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To delete any unused vias, make sure the design is open and choose 
Design»Clean Unused Vias to delete all vias that do not have any trace 
segments or copper areas connected to them. 

Adding Comments
Comments can be used to show engineering change orders, to facilitate 
collaborative work among team members, or to allow background 
information to be attached to a design. 

You can “pin” a comment to the workspace, or directly to a part. When a 
part with an attached comment is moved, the comment also moves. 

For details, refer to the Ultiboard User Manual. 

Exporting a File
Exporting a file refers to producing an output from Ultiboard in a format 
that can be understood by the board manufacturer. An exported file 
contains complete information describing how a finished board is to be 
manufactured. Files that can be exported include Gerber RS-274X and 
RS-274D files. 

For complete details, refer to the Ultiboard User Manual. 
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Viewing Designs in 3D
Ultiboard lets you see what the board looks like in three dimensions at any 
time during the design. For complete details, refer to the Ultiboard User 
Manual. 

 

Tip You can use the Internal View to look between the layers of a multi-layer PCB. For 
details, refer to the Ultiboard User Manual. 
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4
Multisim MCU Tutorial

The tutorial in this chapter leads you through the process of simulating and 
debugging a circuit that contains a microcontroller. 

Overview
The files used for this tutorial install with your NI Circuit Design Suite 
software at ...\samples\Getting Started. 

This tutorial uses Getting Started MCU.ms10, which accesses the 
contents of folder LCDWorkspace as required. 

The LCD Graphical Display circuit example demonstrates the use of a PIC 
microcontroller to control a graphical LCD display component in Multisim 
based on a combination of the Toshiba T6963C controller and an external 
display RAM. To control the LCD display, the microcontroller sends 
signals to the LCD through the LCD’s data and control lines. A software 
program written for the microcontroller determines the logic behind setting 
the lines on its pins to high or low to send commands and data to the LCD 
display. 
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About the Tutorial
The data lines of LCD U2 are connected to pins RB0–RB7 on 
microcontroller U1. The control lines of the LCD are connected to RA0–
RA2 on the microcontroller. The MCU U1 communicates with the LCD U2 
via these wires. Data is sent to U2 in parallel and signals on the control lines 
determine the timing and type of data being sent (i.e., address or data). 

The LCD Graphical Display can operate in three modes: text mode, 
graphical mode and a combination text and graphical mode. This example 
demonstrates the controlling of the LCD Graphical Display in a 
combination text and graphical mode. The software that the MCU runs is 
contained in an MCU workspace that displays in the Design Toolbox as 
LCDWorkspace. The workspace contains one project project1 that 
consists of a single source code file main.asm.
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Complete the following to view the file:

1. Double-click on main.asm in the Design Toolbox. A tab appears in 
the schematic capture workspace called main.asm that displays the 
assembly program.

 

To display the line numbers, select MCU»Show Line Numbers. 

Complete the following to run this circuit: 

1. Select Simulate»Run. If you did not build your program beforehand, 
a dialog box displays stating that the configuration is out of date and 
asks if you would like to build it. Click Yes. The results of the build 
display in the Results tab of the Spreadsheet View. If there are no 
errors or warnings, the program built successfully. (The sample 
program should not contain any errors.) 

The program displays the line “Graphical LCD T6963C for Multisim” 
characters in text mode; the LCD then switches to graphical mode and 
draws an inverted “V” dot-by-dot on top of the text. 

Once the lines are drawn, the text scrolls right and then left. This is 
achieved by moving the start address of the text buffer of the LCD 
display. This also demonstrates that there are two buffers in the LCD, 
one for storing graphics and another for storing text. Other features of 
the LCD such as text flashing and erasing of characters are also 
demonstrated. 

The LCD display program continues to cycle through each of these 
effects. 

To stop the simulation, select Simulate»Stop. 
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Understanding the Assembly Program

Constants and Data
To make the program easier to understand, the LCD display commands and 
temporary buffers for storing addresses and data in the MCU are predefined 
in constants at the start of the program:

 

The text to be displayed on the LCD display is stored in data tables for some 
microcontrollers, but there is no PIC assembly instruction that allows you 
to directly address a data value in the program memory space. Instead, you 
can load literal values into the W register so you can write a routine that 
returns a value in your string based on an index. The RETLW instruction 
loads a constant value into the W register and executes a RETURN in one 
instruction. 

The TXPRT routine retrieves the text data to be displayed on the LCD 
display. The character codes for the LCD display are defined in the T6963C 
controller reference manual (for example, 0x27 is the code for the letter 
“G,” 0x52 for “r,” and so on): 
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Initialization
The initialization code begins at the START label as shown in the excerpt 
below. The pins in the microcontroller are set up as output pins, and the 
values are reset. The LCD display component is initialized by the 
microcontroller and set to graphical and text mode. The home addresses for 
the internal graphical and text buffers in the LCD display component are 
set to 0x0000 and 0x2941 respectively, which determines where on the 
display the LCD starts to display the buffer data. Finally, the control signals 
are set up for the proper read/write operation on the LCD display. 
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Drawing Text and Graphics
The rest of the program sends commands to the LCD graphical display via 
the control lines through MCU pins RA0 to RA2 and data through the data 
lines: 

 

For example, the above excerpt from the main loop in the program sends 
the characters defined in the TXPRT subroutine to be displayed in text mode 
on the graphical LCD. 

The following sets the LCD to auto write mode: 

MOVLW CMD_AWRON

MOVWF CMD_BUFFER

CALL CMD
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At this point, the program starts counting, and executes through the loop 
LOOP_READ_DATA2 35 times. This loop calls TXPRT to retrieve the text 
data and load it into the W register. It then calls to the subroutine ADT, 
which calls SEND_DATA, which writes the values in the W register to 
port B, to be sent to the data lines of the LCD display. Once the data is sent, 
the proper value on port A of the microcontroller is sent to the control pins 
of the LCD display to let it know that the data is ready to be read. The 
subroutines all return at the end to the instruction just after the call to them 
and the same thing happens until all 35 characters have been transmitted. 
The final three instructions in the excerpt turn off the auto write mode in the 
LCD display after exiting the loop: 

MOVLW CMD_AWROFF

MOVWF CMD_BUFFER

CALL CMD

The next few instructions draw the horizontal and sloped lines in graphical 
mode:

;6 draw wave once

MOVF ADDR_L, 0

BTFSC STATUS, Z

CALL DRAW_WAVE

Working with the MCU Debugging Features
This section provides a step-by-step walkthrough of Multisim’s MCU 
debugging features. It is important to follow the steps exactly as scripted, 
otherwise, the descriptions will no longer apply. Once you understand the 
breakpoint and single stepping features you can explore the possibilities of 
advanced MCU debugging. 

Debug View Overview
To write a program for a microcontroller either in C or assembly, you create 
source code files (.asm, .inc, .c, .h) as part of the MCU workspace, 
which can in turn be edited in the source code view. 

Complete the following step to access the source code view: 

1. Double-click on the file item (for example, main.asm) shown in the 
MCU workspace hierarchy in the Design Toolbox. 

During simulation, additional debugging information displays to help you 
understand what is happening inside the MCU. For example, you can 
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switch between viewing events happening in the high level source and at 
the assembly instruction level which also displays the actual opcodes for 
each instruction that are being executed by the MCU. 

The source code view is not capable of displaying all this extra information. 
Instead, each MCU component in the circuit design has its own 
Debug View that displays debugging information. 

Complete the following steps to access the Debug View:

1. Select MCU»MCU PIC 16F84A U1»Build. 

Note The Debug View is available only after you have successfully built your code, 
so the preceding step is only necessary once. 

2. Select MCU»MCU PIC 16F84A U1»Debug View.

Or

Use the right-click context menu on an item in the MCU workspace of 
the Design Toolbox. 

 

Another tab opens in the schematic capture workspace called 
Debug(<reference designator of MCU>), in this case Debug(U1). 



Chapter 4 Multisim MCU Tutorial

© National Instruments Corporation 4-9 Getting Started with NI Circuit Design Suite

 

Use the drop-down list at the top of the Debug View to select between the 
disassembly instructions generated internally by Multisim or the listing file 
generated by the assembler or compiler (the format of the listing file is 
dependent on the tool that you choose to build your code). 

In the LCD graphical display example, the code was written in assembly 
and built by the Microchip assembly tools. The Microchip assembler 
generates a listing file (.lst) that contains all of the opcodes generated for 
each assembly instruction. The debug listing view displays information 
from this listing file. Multisim generates the disassembly format using its 
internal disassembler to disassemble the opcode instructions into assembly 
instructions. 

This format is not necessary for this example since the debug listing 
contains all of the information needed. In cases where an MCU project 
loads only the machine code (.hex) file, the disassembly view shows the 
disassembled opcode instructions so that you can see what’s happening in 
the MCU. Since no listing file for MCU projects of this type is available, 
the disassembly view is very useful. 

Adding a Breakpoint
You can add breakpoints in the source code view when simulation has 
stopped, as well as during simulation. You can add breakpoints to a 
microcontroller project in two ways. 

1  Drop-down List  
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One way is to add them in the source code view. In this example, the 
main.asm tab in the schematic capture workspace is the only source code 
view available. 

Note If your MCU design contains more than one file, there will be a source code view 
for each of your source code files. 

You can also set a breakpoint in the Debug View window. You can set 
breakpoints in the disassembly view or the debug listing view, but for this 
example, you will only use the debug listing view.

 

Complete the following steps to add a breakpoint in the source code view: 

1. Open the Debug View for U1. 

2. Double-click on main.asm in the Design Toolbox. 

3. Scroll to the line just below the START label: BCF STATUS, RP0. 

4. Double-click on the first (grey) column on the left side of the 
main.asm window next to the line BCF STATUS, RP0. A red circle 
appears at that location indicating that a breakpoint has been set at that 
line. 

5. Select Simulate»Run. The simulation automatically pauses at the 
breakpoint that you have just set. The Debug View automatically 
jumps into focus with a yellow arrow showing where the MCU 
program execution is paused. 

1  Grey Column  
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Complete the following to remove the breakpoint: 

1. Double-click on the breakpoint in the Debug View or the main.asm 
source code view. 

Or

Select MCU»Remove all breakpoints to remove all breakpoints. 

Note You can add and remove breakpoints in the Debug View in the same manner as the 
source code view. 

Break and Step
1. Select MCU»Remove all breakpoints to remove all breakpoints. 

2. Go to the circuit design view (the Getting Started MCU tab) and 
select Simulate»Run. The words “Graphical LCD T6963CC for 
Multisim” start to display on the graphical LCD component. 

3. Select Simulate»Pause. 

4. Go to the Debug View for U1 and notice that the line of code in the 
debug listing view where the MCU has stopped its execution is 
indicated by a yellow arrow in the left-most column. 
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5. Select MCU»MCU PIC16F84A U1»Memory View to view the 
current state of the memory inside the microcontroller U1. Notice that 
the value of the program counter PC in the IROM section is one higher 
than the address value of the line the yellow arrow is pointing to. In the 
example in the above figure, the address in the Debug View is 192 and 
the PC value in the Memory View is 193. 

Note If the MCU has not finished executing the current command when you pause the 
simulation, the value in the program counter will be the same as the address value. 

You can also look at the other sections of the Memory View to see the 
values inside the other parts of memory in the microcontroller. 

6. Click the Step into button in the Simulation tool bar. 

7. The current instruction is executed and the simulation pauses at the 
next instruction.

8. Select Simulate»Stop. 
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Break and Step Out
1. Place a breakpoint in the SEND_DATA subroutine at MOVWF PORTB. 

2. Select Simulate»Run. The simulation pauses at the breakpoint. 

3. Click the Step out button in the Simulation toolbar to step out of the 
SEND_DATA subroutine. 

4. The simulation executes all of the remaining instructions in the 
SEND_DATA subroutine and pauses at the first instruction after the call 
to the SEND_DATA subroutine. 

Break and Step Into
1. Select MCU»Remove all breakpoints. 

2. Place a breakpoint at the call to SEND_DATA where you had just 
stepped out of just above the yellow arrow. 

3. Select Simulate»Run. The simulation pauses at breakpoint that you 
just placed. 

4. Click the Step Into button on the Simulation toolbar. The simulation 
pauses inside the SEND_DATA subroutine. 

Break and Step Over
1. Select Simulate»Run. The simulation pauses at the same breakpoint 

that you set previously at the call to the subroutine SEND_DATA. 

2. Click the Step Over button on the Simulation toolbar. The entire 
SEND_DATA subroutine is executed and the simulation pauses at the 
instruction after the CALL SEND_DATA instruction. 

Run to Cursor
1. Select MCU»Remove all breakpoints. 

2. Click on a line inside the SEND_DATA subroutine since we know that 
this subroutine will be called again to send data to the LCD display.

3. Click the Run to Cursor button in the Simulation toolbar. The 
simulation runs until the MCU hits the instruction that you clicked on 
inside the SEND_DATA subroutine. It then pauses and places the yellow 
arrow next to that line. 
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A
Technical Support and 
Professional Services

Visit the following sections of the award-winning National Instruments 
Web site at ni.com for technical support and professional services:

• Support—Technical support resources at ni.com/support include 
the following:

– Self-Help Technical Resources—For answers and solutions, 
visit ni.com/support for software drivers and updates, a 
searchable KnowledgeBase, product manuals, step-by-step 
troubleshooting wizards, thousands of example programs, 
tutorials, application notes, instrument drivers, and so on. 
Registered users also receive access to the NI Discussion Forums 
at ni.com/forums. NI Applications Engineers make sure every 
question submitted online receives an answer.

– Standard Service Program Membership—This program 
entitles members to direct access to NI Applications Engineers 
via phone and email for one-to-one technical support as well as 
exclusive access to on demand training modules via the Services 
Resource Center. NI offers complementary membership for a full 
year after purchase, after which you may renew to continue your 
benefits. 

For information about other technical support options in your 
area, visit ni.com/services, or contact your local office at 
ni.com/contact. 

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.
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If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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Symbole und Darstellungen

In diesem Handbuch werden die folgenden Symbole und Darstellungen 
verwendet:

» Das Symbol » kennzeichnet die Reihenfolge, in der Menüpunkte und 
Dialogfeldoptionen anzuklicken sind. So wird zum Beispiel mit der 
Abfolge Datei»Seite einrichten»Optionen angezeigt, dass zunächst das 
Menü Datei zu öffnen ist, hieraus die Option Seiteneinstellungen und 
daraus der Befehl Optionen auszuwählen ist.

Dieses Symbol steht für Ratschläge.

Dieses Zeichen steht für einen Hinweis auf wichtige Informationen.

fett In fettgedruckter Schrift sind Elemente dargestellt, die ausgewählt oder 
angeklickt werden müsen, wie Menüpunkte oder Optionen in 
Dialogfeldern. Parameternamen sind ebenfalls fettgedruckt.

kursiv Variablen, Hervorhebungen, Querverweise und erstmals genannte 
Fachausdrücke sind durch Kursivschrift gekennzeichnet. Ebenfalls kursiv 
sind Textstellen gedruckt, an denen Wörter bzw. Werte einzusetzen sind.

monospace In Monospace-Schrift (nicht proportionaler Schrift) sind 
Programmauszüge, Syntaxbeispiele und Zeichen, die über die Tastatur 
einzugeben sind, dargestellt. Diese Darstellungsweise wird ebenfalls für 
Laufwerke, Pfade, Verzeichnisse, Programme, Unterprogramme, 
Subroutinen, Gerätenamen, Funktionen, Operationen, Variablen sowie 
Dateinamen und -erweiterungen verwendet.
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1
Einführung in die NI Circuit 
Design Suite

Einige der in diesem Handbuch beschriebenen Funktionen sind möglicher-
weise nicht in Ihrer Version der NI Circuit Design Suite verfügbar. 
Einzelheiten zum Funktionsumfang Ihrer Ausgabe finden Sie in den 
Versionshinweisen. 

NI Circuit Design Suite Produktlinie
Die Circuit Design Suite von National Instruments ist ein EDA-Software-
paket (EDA – Electronics Design Automation), mit dessen Hilfe Ihnen die 
wichtigsten Schritte zur Planung und Erstellung von Schaltungen erleich-
tert werden. 

Multisim ist ein Programm zur Erstellung und Simulation von Schaltplä-
nen. Es eignet sich zur Schaltplaneingabe, zum Durchführen von 
Simulationen und zur Weitergabe der Daten an den nächsten Arbeitsgang, 
zum Beispiel die Leiterplattenentflechtung. Mit Multisim können analoge 
und digitale Simulationen durchgeführt werden. 

Ultiboard erzeugt anhand der Daten von Multisim gedruckte Schaltungen, 
führt einfache mechanische CAD-Operationen durch (z. B. Platzierung der 
Bauteile auf den Leiterplatten) und bereitet die Leiterplatten für die Pro-
duktion vor. Ultiboard sorgt außerdem für die automatische 
Bauteilplatzierung und das Layout.
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Lerneinheiten (Tutorial)
Dieses Handbuch enthält folgende Schritt-für-Schritt-Tutorials:

• Einführung in Multisim—Stellt Ihnen Multisim und seine Funktionen 
vor.

• Einführung in Ultiboard—Zeigt Ihnen, wie Sie die Bauelemente und 
Leiterbahnen für die im Multisim-Tutorial-Kapitel beschriebenen 
Schaltungen richtig platzieren. Außerdem lernen Sie, wie Bauele-
mente automatisch eingefügt und die dazugehörigen Leiterbahnen 
automatisch verlegt werden.

• Einführung in Multisim MCU—Führt Sie durch die Simulation und 
Fehlersuche in einer Schaltung mit Mikrocontroller.

Weiterführende Informationen zu den in diesen Kapiteln beschriebenen 
Funktionen finden Sie im Multisim- oder im Ultiboard-Benutzerhandbuch.
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Einführung in Multisim

Im vorliegenden Kapitel erhalten Sie eine kurze Einführung in Multisim 
und seine Funktionen.

Einige der beschriebenen Funktionen sind möglicherweise in Ihrer Aus-
gabe von Multisim nicht enthalten. Einzelheiten zum Funktionsumfang 
Ihrer Ausgabe finden Sie in den Versionshinweisen.

Multisim-Benutzeroberfläche
Bei Multisim, einem Programm zur Erfassung und Simulation von Schalt-
plänen der National Instruments Circuit Design Suite, handelt es sich um 
ein EDA-Programm (EDA – Electronics Design Automation), mit dessen 
Hilfe die wichtigsten Schritte zur Planung und Erstellung von Schaltungen 
durchgeführt werden können. Multisim ist ein Programm zur Schaltplan-
eingabe, zum Durchführen von Simulationen und zur Weitergabe der 
Daten an den nächsten Arbeitsgang, zum Beispiel die Leiterplatten-
entflechtung.
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Die Benutzeroberfläche von Multisim ist folgendermaßen aufgebaut:

Die Menüleiste enthält die Befehle für sämtliche Funktionen. 

Die Entwurf-Toolbox ermöglicht die Suche nach den verschiedenen 
Dateien eines Projekts (z. B. Schaltplandateien, Leiterplattenlayoutdateien 
oder Berichten), die Anzeige einer Schaltplanhierarchie und das Ein- und 
Ausblenden verschiedener Lagen. 

1 Menüleiste
2 Entwurf-Toolbox
3 Bauelemente-

Symbolleiste
4 Standard-Symbolleiste

5 Ansicht-Symbolleiste
6 Simulations-

Symbolleiste
7 Haupt-Symbolleiste

8 Liste verwendeter 
Bauelemente

9 Instrumenten-
Symbolleiste

10 Text rollen links/rechts
11 Schaltungsfenster
12 Tabellen-Ansicht
13 Aktive Registerkarte
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Die Bauelemente-Symbolleiste enthält Schaltflächen zur Auswahl von 
Bauelementen aus den Multisim-Bauelementedatenbanken zum Platzieren 
in Schaltungen. 

Die Standard-Symbolleiste enthält Schaltflächen für die meistverwende-
ten Funktionen wie Speichern, Drucken, Ausschneiden oder Einfügen. 

Die Ansicht-Symbolleiste enthält Schaltflächen zur Veränderung der 
Bildschirmanzeige.

Die Simulations-Symbolleiste enthält Schaltfächen zum Start, Stopp und 
andere Simulationsfunktionen.

Die Haupt-Symbolleiste enthält Schaltflächen für allgemeine 
Multisim-Funktionen.

Die Liste verwendeter Bauelemente enthält eine Liste aller im Entwurf 
verwendeter Bauelemente.

Die Instrumenten-Symbolleiste enthält Schaltflächen für jedes 
Instrument. 

Im Schaltungsfenster (das auch als “Arbeitsbereich” bezeichnet wird) 
wird der Schaltplan gezeichnet. 

Die Tabellen-Ansicht ermöglicht die Anzeige von Parametern und Bau-
elementeinformationen wie Platzbedarfsinformationen, Referenz-
bezeichnungen, Attribute und Entwurfsregeln. Sie können die Parameter-
werte für einige oder alle Bauelemente in einem einzigen Schritt ändern 
und weitere Funktionen verwenden. 



Kapitel 2 Einführung in Multisim

Erste Schritte mit NI Circuit Design Suite 2-4 ni.com

Überblick
In diesem Dokument werden alle Aspekte der Erstellung einer technischen 
Schaltung vom Erstellen eines Schaltplans über die Simulation der Schal-
tung bis hin zur Analyse der Ergebnisse beleuchtet. Nach dem Abarbeiten 
der beschriebenen Schritte erstellen Sie eine Schaltung, mit der ein analo-
ges Kleinsignal erfasst und verstärkt wird und dessen Auftreten mit einem 
einfachen digitalen Zähler ermittelt wird. 

Nützliche Tipps sind links durch ein Symbol gekennzeichnet, z. B.: 

Tipp Sie können jederzeit die Hilfe aufrufen, indem Sie auf der Tastatur <F1> drücken 
oder in einem Dialogfeld die Schaltfläche Hilfe anklicken. 

Sobald Sie den Abschnitt zum Verbinden der Bauelemente erreicht haben, 
können Sie mit der Schaltung fortfahren, die Sie im Abschnitt “Bauele-
mente platzieren” erstellt haben. 

Alternativ können Sie die Datei Getting Started 1.ms10 im 
Verzeichnis ...\Dokumente und Einstellungen\All Users\
Gemeinsame Dokumente\National Instruments\Circuit 

Design Suite 10.1\samples\Getting Started\ öffnen. In dieser 
Datei sind sämtliche Bauelemente richtig platziert. 

Nach Erreichen der Simulation können Sie entweder an der vorhandenen 
Schaltung weiterarbeiten oder die Datei Getting Started 2.ms10 ver-
wenden, in der alle Bauteile bereits richtig verbunden sind. 
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Schaltungsentwicklung
In diesem Abschnitt fügen Sie die Bauelemente für die unten abgebildete 
Schaltung ein und verbinden sie miteinander.

 

Öffnen und Speichern der Datei
Um Multisim zu starten, führen Sie die folgenden Schritte aus:

1. Wählen Sie Start»Programme»National Instruments»Circuit 
Design Suite 10.1»Multisim 10.1. Es öffnet sich eine leere Datei im 
Arbeitsbereich namens Schaltung1. 
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So speichern Sie die Datei unter einem anderen Namen: 

1. Wählen Sie Datei»Speichern unter. Es öffnet sich das Windows-Dia-
logfeld zum Speichern von Dateien.

2. Wählen Sie einen Speicherort für die Datei aus. Geben Sie anschlie-
ßend als Dateinamen MeineErstenSchritte ein und klicken Sie auf 
die Schaltfläche Speichern.

Tipp Um versehentlichem Datenverlust vorzubeugen, sollten Sie über die Registerkarte 
Speichern des Dialogfelds Voreinstellungen regelmäßig Sicherheitskopien erstellen. 

Um eine vorhandene Datei zu öffnen, führen Sie die folgenden Schritte aus:

1. Wählen Sie Datei»Datei öffnen, wählen Sie eine Datei aus und 
klicken Sie auf die Schaltfläche Öffnen. 

Tipp Zum Öffnen von Dateien aus älteren Multisim-Versionen wählen Sie im Dialogfeld 
Datei öffnen unter Dateityp die entsprechende Version aus. 

Einfügen der Bauelemente
Um Bauelemente einzufügen, führen Sie die folgenden Schritte aus:

1. Öffnen Sie MeineErstenSchritte.ms10 wie oben beschrieben. 

2. Klicken Sie auf Platzieren»Bauelement, um zum Fenster Bauele-
ment wählen zu gelangen. Wählen Sie hier die in der folgenden 
Abbildung dargestellte 7-Segment-LED-Anzeige aus und klicken Sie 
auf OK. Das Bauelement erscheint daraufhin umrisshaft unter dem 
Cursor. 

Tipp Nach Auswahl der Gruppe und Familie des Bauelements können Sie unter Bauele-
ment den Namen des Bauteils eingeben. Ihre Eingabe wird im Feld Suche am unteren 
Rand des Fensters angezeigt. Geben Sie für das obige Beispiel 
seven_seg_decimal_com_a_blue ein. Übereinstimmungen werden bereits bei der 
Eingabe angezeigt.
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3. Bewegen Sie den Cursor in die rechte untere Ecke der Arbeitsfläche 
und klicken Sie mit der linken Maustaste, um das Bauelement einzu-
fügen. Die Kennung für dieses Bauelement lautet “U1”. 

4. Fügen Sie die restlichen Bauelemente wie dargestellt in den Bereich 
für den Zähler ein.
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Hinweis Beim Einfügen von Widerständen, Induktoren oder Kondensatoren (RLC-Bau-
elementen) enthält das Dialogfeld Bauelement wählen geringfügig andere Optionen als 
sonst. Beim Einfügen dieser Bauelemente können Sie jede denkbare Kombination aus fol-
genden Parametern wählen: Wert des Bauelements (z. B. Widerstandswert), Typ (z. B. 
Kohleschicht), Toleranz, Footprint und Hersteller. Beim Einfügen eines Bauelements, das 
als PCB-Layout exportiert werden soll und Teil der Stückliste sein wird, müssen Sie 
darauf achten, dass die im Dialogfeld Bauelement wählen angegebene Kombination von 
Werten auch wirklich verfügbar ist. 

Tipp Beim Einfügen von RLC-Bauelementen ist der Wert des Bauteils ganz oben in die 
Liste der Bauelemente einzutragen. Der Wert muss aber nicht in der Liste enthalten sein, 
damit das Bauteil in die Schaltung eingefügt werden kann. 

Tipp Um den 200-Ω-Widerstand senkrecht anzuordnen, drücken Sie beim Einfügen des 
Widerstands die Tastenkombination <Strg + R>. 

Tipp Die Bauelemente werden in der Reihenfolge mit Referenzbezeichnern versehen, in 
der sie eingefügt werden (z. B. U1, U2, U3). Wenn Sie also die Bauelemente in einer ande-
ren Reihenfolge als in der Abbildung einfügen, ändert sich auch die Nummerierung 
entsprechend. Dies hat jedoch keinerlei Einfluss auf die Funktion der Schaltung. 
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5. Fügen Sie die Bauelemente für die Steuerung des Zählers ein. Klicken 
Sie nach dem Einfügen mit der rechten Maustaste auf jeden SPDT-
Schalter und wählen Sie Horizontal kippen.

 

Tipp Die SPDT-Schalter befinden sich in der Gruppe “Basic” und der Familie “Switch”.

Tipp Wenn das benötigte Bauteil schon auf dem Schaltplan vorhanden ist, markieren Sie 
es, wählen Sie Bearbeiten»Kopieren und dann Bearbeiten»Einfügen. Sie können es 
außerdem aus der Verwendungsliste auswählen und durch einen Klick in den Arbeitsbe-
reich einfügen. 

6. Fügen Sie die Bauteile für den Analogverstärker wie dargestellt ein 
und drehen Sie sie bei Bedarf.
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Nachdem Sie die Wechselspannungsquelle eingefügt haben, führen 
Sie einen Doppelklick darauf aus. Ändern Sie den Effektivwert der 
Spannung (RMS) auf 0.2 V und klicken Sie auf OK.

7. Fügen Sie die Bauteile für die Überbrückungskondensatoren wie dar-
gestellt ein.

 

8. Fügen Sie den Kollektor und die dazugehörigen Bauelemente ein (vgl. 
die Abbildung unten).

 

Tipp J3 befindet sich in der Gruppe “Basic” und der Familie “Connectors”.

Tipp Nach dem Verdrahten einer Schaltung können Sie Bauteile mit zwei Anschlüssen – 
z. B. Widerstände – einfach auf einer Verbindung ablegen. Multisim fügt das Bauteil dann 
automatisch in den Stromkreis ein. 
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Verbinden der Bauelemente
Alle Bauelemente haben Anschlussstifte, über die sie mit anderen Bauele-
menten oder Geräten verbunden werden können. Sobald sich der Cursor 
über einem Anschlussstift befindet, erkennt Multisim die gewünschte Ver-
bindung und der Cursor verwandelt sich in ein Fadenkreuz. 

Tipp Sie können nun entweder die Bauelemente zu einer Schaltung verbinden oder die 
Datei Getting Started 1.ms10 verwenden. Diese befindet sich im Unterordner Get-
ting Started des Ordners samples. 

Um Bauelemente zu verbinden, führen Sie die folgenden Schritte aus: 

1. Klicken Sie den Ausgangspunkt für die Verbindung an (der Cursor ver-
wandelt sich daraufhin in ein Fadenkreuz) und bewegen Sie die Maus. 
Daraufhin erscheint unter dem Cursor eine Linie, die eine Leiterbahn 
symbolisieren soll. 

2. Klicken Sie auf den Anschlussstift des zweiten Bauteils, an dem die 
Verbindung enden soll. Multisim erstellt die Verbindungen automa-
tisch und fügt die Leiterbahn automatisch an der richtigen Stelle und 
in der richtigen Konfiguration ein, wie unten dargestellt. Diese Funk-
tion spart insbesondere beim Verbinden großer Schaltungen viel Zeit.

 

3. Die Lage der Leiterbahn kann durch Mausklicks bestimmt werden. Bei 
jedem Klick wird die Leiterbahn an der entsprechenden Stelle fixiert. 
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4. Verbinden Sie die restlichen Bauteile für den Zählerbaustein entspre-
chend der Darstellung. 

 

Tipp Verbinden Sie Elemente mit mehreren Anschlussstiften, wie U3 und R4, in einer 
Busleitung mit Hilfe von Bus-Vektorverbindungen. Einzelheiten dazu entnehmen Sie 
bitte dem Multisim-Benutzerhandbuch. 

Tipp Virtuelle Verdrahtung — Damit die Verbindung nicht zu unübersichtlich wird, 
können Sie zwischen den Abschnitten “Counter Control” und “Digital Counter” virtuelle 
Verbindungen herstellen. Wenn zwei Netze den gleichen Netznamen enthalten, sind sie 
virtuell miteinander verbunden. 
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5. Verdrahten Sie den Rest der Schaltung entsprechend der Abbildung 
(siehe unten).

 

Simulation
Durch Simulation Ihrer Schaltungen mit Multisim lassen sich schon früh 
Schaltungsfehler erkennen, wodurch Zeit und Geld gespart wird. 

Virtuelle Messinstrumente
In diesem Abschnitt wird Ihre Schaltung mit Hilfe eines virtuellen Oszillo-
graphen simuliert. 

Tipp Um Zeit zu sparen, können Sie aber auch die Datei Getting Started 2.ms10 aus 
dem Ordner Getting Started verwenden, der sich unter samples befindet. 

1. J1, J2 und R2 sind interaktive Bauelemente. 

Um die Bedientasten für J1, J2 und R2 festzulegen, klicken Sie die 
Bauelemente doppelt an. Geben Sie auf der Registerkarte “Wert” in 
das Feld Taste für Schalter für J1 “E” ein, für J2 “L” und für R2 “A”. 

Betätigen Sie <E>, um den Zähler zu aktivieren, oder klicken Sie auf 
die verbreiterte Linie, die erscheint, wenn sich der Cursor über J1 
befindet. 
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2. Um einen Oszillographen einzufügen, wählen Sie Simulieren»
Instrumente»Oszillograph. Verbinden Sie das Gerät wie im Schritt 4 
dargestellt mit der restlichen Schaltung. 

Tipp Um einfach zwischen den Kurven auf dem Oszillographen zu unterscheiden, klicken 
Sie die Leitung, die zum Eingang B des Geräts führt, mit der rechten Maustaste an und 
wählen Sie aus dem Kontextmenü die Option Segment einfärben aus. Wählen Sie eine 
andere Farbe als die der Leitung an Eingang A aus, z. B. Blau. (Beim Bearbeiten der Schal-
tung, z. B. beim Ändern der Leitungsfarbe, darf die Simulation nicht laufen).

3. Klicken Sie das Symbol für den Oszillographen doppelt an, um die 
Vorderseite des Geräts mit der Anzeige und den Bedienknöpfen einzu-
blenden. Wählen Sie Simulieren»Start. Im Oszillographen wird nun 
das Ausgangssignal des Operationsverstärkers angezeigt. 

4. Stellen Sie die Skalierung der Zeitbasis auf 2 ms pro Skalenteil und die 
Empfindlichkeit von Kanal A auf 500 mV pro Skalenteil ein. Der 
Oszillograph zeigt die Kurven dann folgendermaßen an:
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Während der Simulation der Schaltung zählt die 7-Segment-Anzeige 
aufwärts. Wenn der Zähler einmal durchgezählt hat, leuchtet eine LED 
auf. 

5. Drücken Sie während der Simulation die Taste <E>, um den Zähler zu 
aktivieren oder zu deaktivieren. Das Starten ist low-aktiv. 

Mit L wird der Zähler auf Null gestellt. Das Zurückstellen ist ebenfalls 
low-aktiv. 

Drücken Sie <Shift + A> und beobachten Sie, was beim Drehen am 
Potentiometer geschieht. Wiederholen Sie das Ganze, aber drücken Sie 
diesmal nur <A>. 

Tipp Statt mit den genannten Tasten können Sie die Bauelemente auch mit der Maus 
bedienen. 
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Analyse
In diesem Abschnitt führen Sie an Ihrer Schaltung eine AC-Analyse durch, 
um den Frequenzgang des Verstärkers zu überprüfen. 

So führen Sie eine AC-Analyse am Ausgang des Operationsverstärkers 
durch: 

1. Klicken Sie die Leiterbahn doppelt an, die zum Anschlussstift 6 des 
Operationsverstärkers führt, und ändern Sie den Netznamen im Dia-
logfeld Netz ggf. auf analog_out. 

2. Wählen Sie Simulieren»Analysen»AC-Analyse und klicken Sie auf 
die Registerkarte Ausgabe.

 

3. Markieren Sie V(analog_out) in der linken Spalte und klicken Sie 
auf Hinzufügen. Der Eintrag V(analog_out) wird daraufhin in die 
rechte Spalte verschoben. 
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4. Klicken Sie auf Simulation. Die Ergebnisse der Analyse werden in der 
Graphanzeige angezeigt.

 

Die Graphanzeige
In der Graphanzeige können Sie Diagramme und Tabellen anzeigen las-
sen, modifizieren, speichern und exportieren. In diesem Fenster werden die 
Ergebnisse aller Multisim-Analysen in Graphen und Diagrammen oder 
Kurvengraphen dargestellt (wie bei einem Oszillographen). 

Zur Anzeige der Simulationsergebnisse in der Graphanzeige: 

1. Starten Sie die Simulation wie oben beschrieben. 

2. Wählen Sie Ansicht»Graphanzeige.
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Der Postprozessor
Im Postprozessor können Sie die Ergebnisse einer Schaltungsanalyse 
bearbeiten oder in Form eines Diagramms oder Graphen darstellen. Auf die 
Ergebnisse können arithmetische, trigonometrische, logarithmische, kom-
plexe, logische sowie Exponential- und Vektorfunktionen angewandt 
werden. 

Berichte
In Multisim können unterschiedliche Arten von Berichten erzeugt werden: 
Stücklisten (BOMs), Einzelheiten zu Bauelementen, Netzlisten, Schalt-
planstatistiken, Auflistungen nicht verbundener Gatter oder 
Querverweise. In diesem Abschnitt soll für den Beispielschaltplan eine 
Stückliste erstellt werden. 
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Stückliste
Eine Stückliste ist eine Aufstellung der Bauelemente, die für eine 
bestimmte Schaltung und die Herstellung der zugehörigen Leiterplatte ver-
wendet werden. Sie enthält folgende Angaben: 

• Die Stückzahl jedes erforderlichen Bauelements.

• Eine Beschreibung, in der der Bauteiltyp (z. B. Widerstand) und die 
Größe des Bauteils (z. B. 5,1 k) enthalten ist. 

• Die Kennung jedes Bauelements. 

• Das Gehäuse oder den Platzbedarf jedes Bauelements. 

Zum Erstellen einer Stückliste für Ihre Schaltung: 

1. Wählen Sie aus dem Menü Berichte die Option Stückliste aus. 

Nun wird die Stückliste geöffnet, die in etwa wie folgt aussieht:
 

Um die Stückliste auszudrucken, klicken Sie auf die Schaltfläche 
Drucken. Daraufhin öffnet sich das Windows-Druckdialogfeld, in dem Sie 
den gewünschten Drucker, die Anzahl der Kopien usw. auswählen können. 
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Klicken Sie zum Speichern der Stückliste auf die Schaltfläche Speichern. 
Daraufhin öffnet sich das Windows-Dialogfeld zum Speichern von 
Dateien, in dem Sie den Pfad und den Dateinamen angeben können. 

Da die Stückliste hauptsächlich zur Unterstützung bei der Beschaffung und 
Herstellung gedacht ist, enthält sie lediglich reale Bauteile, also z. B. keine 
Quellen oder virtuellen Bauelemente. Bauelemente ohne zugewiesene 
Footprints erscheinen nicht in der Stückliste. 

Wenn Sie eine Liste der Bauelemente in Ihrer Schaltung sehen wollen, bei 
denen es sich nicht um reale Bauelemente handelt, müssen Sie auf die 
Schaltfläche Virtuelle Bauelemente anzeigen klicken. Daraufhin wird ein 
weiteres Fenster geöffnet, in dem nur diese Bauelemente angezeigt werden. 

Genaue Angaben zu Stücklisten und anderen Berichtarten finden Sie im 
Benutzerhandbuch zu Multisim. 
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3
Einführung in Ultiboard

In diesem Kapitel wird die praktische Erstellung von Platinen anhand der 
im Multisim-Kapitel beschriebenen Schaltpläne erläutert. 

Tipp Das Importieren von Multisim-Schaltplänen ist im Benutzerhandbuch zu Multisim, 
dem Benutzerhandbuch zu Ultiboard und in den Hilfedateien beschrieben. 

Ultiboard-Benutzeroberfläche
Ultiboard ist ein Programm zur Leiterplattenentflechtung und Bestandteil 
der Circuit Design Suite von National Instruments. Bei der NI Circuit 
Design Suite handelt es sich um ein EDA-Softwarepaket (EDA – Electro-
nics Design Automation), mit dessen Hilfe Ihnen die wichtigsten Schritte 
zur Planung und Erstellung von Schaltungen erleichtert werden. Ultiboard 
erzeugt anhand der Daten von Multisim gedruckte Schaltungen, führt ein-
fache mechanische CAD-Arbeitsschritte durch (z. B. Platzierung der 
Bauteile auf den Leiterplatten) und bereitet die Leiterplatten für die Pro-
duktion vor. Ultiboard sorgt außerdem für die automatische 
Bauteilplatzierung und die Leiterplattenentflechtung (Layout). 

Die Benutzeroberfläche von Ultiboard besteht aus verschiedenen 
Elementen.



Kapitel 3 Einführung in Ultiboard

Erste Schritte mit NI Circuit Design Suite 3-2 ni.com

 

Die Menüleiste enthält die Befehle für sämtliche Funktionen. 

Die Standard-Symbolleiste enthält Schaltflächen für die meistverwende-
ten Funktionen wie Speichern, Drucken, Ausschneiden oder Einfügen. 

Je mehr Elemente und Leiterbahnen Sie einer Leiterplatte hinzufügen, 
desto schwieriger wird unter Umständen das Markieren einzelner Schal-
tungsteile. Die Symbolleiste Auswahl enthält Schaltflächen, die Ihnen das 
Markieren von Objekten erleichtern sollen. 

1 Menüleiste
2 Standard-Symbolleiste
3 Auswahl-Symbolleiste
4 Symbolleiste für 

Zeicheneinstellungen

5 Ansicht-Symbolleiste
6 Haupt-Symbolleiste
7 Autoroute-Symbolleiste

8 Statusleiste
9 Arbeitsbereich
10 Tabellen-Ansicht

11 Entwurf-Toolbox
12 3D-Vorschau
13 Vogelperspektive
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Die Symbolleiste Zeichnungseinstellungen ermöglicht Ihnen die Aus-
wahl der Lage, Dicke und Messgröße gezeichneter Linien bzw. Objekte. 
Außerdem bietet sie Schaltflächen für Funktionen, mit denen die Darstel-
lung von Linien und Formen auf einer Lage verändert werden kann. 

Die Ansicht-Symbolleiste enthält Schaltflächen zur Veränderung der 
Bildschirmanzeige.

Die Haupt-Symbolleiste enthält Schaltflächen für allgemeine 
Leiterplattenfunktionen.

Die Autoroute-Symbolleiste enthält Funktionen zum Autorouting und zur 
Bauelementplatzierung. 

Die Statusleiste bietet hilfreiche und wichtige Informationen an. 

Die Schaltung entwickeln Sie im Arbeitsbereich. 

Die Tabellen-Ansicht ermöglicht die Anzeige von Parametern und Bau-
elementeinformationen wie Platzbedarf (Form), Referenzbezeichnungen, 
Attribute und Entwurfsregeln. 

Die Entwurf-Toolbox ermöglicht es, Elemente ein- und auszublenden 
oder abzudunkeln.

Die 3D-Vorschau zeigt Ihnen eine dreidimensionale Vorschau der 
Leiterplatte. 

Die Vogelperspektive zeigt Ihnen den Entwurf auf einen Blick und ermög-
licht Ihnen ein einfaches Navigieren im Arbeitsbereich. 

Öffnen der Einführung
Um eine Übungsdatei zu öffnen, führen Sie die folgenden Schritte aus: 

1. Wählen Sie Start»Programme»National Instruments»Circuit 
Design Suite 10.1»Ultiboard 10.1, um Ultiboard zu starten.

2. Wählen Sie Datei»Beispieldateien öffnen und klicken Sie den Ordner 
Getting Started doppelt an. 

3. Wählen Sie Getting Started.ewprj und klicken Sie auf Öffnen. 
Die Projektdatei wird in Ultiboard geladen. 
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4. Zum Auswählen eines Schaltplans (z. B. GS1) klicken Sie entweder 
auf die dazugehörige Registerkarte oder wählen Sie auf der Register-
karte Projekte der Entwurf-Toolbox den Namen des Schaltplans aus. 

Auswahl der Platinenkontur
Zum Festlegen der Außenkontur der Platine gibt es folgende 
Möglichkeiten:

• Durch Ziehen eines Umrisses mit den Zeichenwerkzeugen 

• Durch Importieren einer DXF-Datei

• Durch Nutzung des Leiterplatten-Wizards.
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Um mit dem Leiterplatten-Wizard zu arbeiten, führen Sie die folgenden 
Schritte aus:

1. Klicken Sie auf der Registerkarte Lagen doppelt auf Board Outline.

2. Klicken Sie auf den vorhandenen Leiterplattenumriss im GS1-Entwurf 
und dann auf <Entf>. 

3. Wählen Sie Extras»Leiterplatten-Wizard. 
 

4. Aktivieren Sie die Option Lagentechnologie ändern, um zu den ande-
ren Optionen zu gelangen. 

5. Wählen Sie Mehrere Lagen mit doppelseitigen Leiterplatten und 
Einzellagenstapeln und klicken Sie auf Weiter. 
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6. Das nachfolgende Dialogfeld ermöglicht es Ihnen, Überschichtungs-
einstellungen für die Platine vorzunehmen. (Bei dieser Übung wird 
jedoch keine der Einstellungen verändert.)

 

7. Klicken Sie auf Weiter. 

Im Dialogfeld Form der Leiterplatte:

• muss der Referenzpunkt zur Ausrichtung auf Links - unten 
gesetzt sein.

• muss die Option Rechteckig aktiviert sein.

• muss die Breite auf 3000 und die Höhe auf 2000 eingestellt 
werden (diese Größe ist für die Bauelemente in diesem Schaltplan 
besser geeignet).

• muss der Freiraum 5,00000 lauten. Dieser Wert gibt die Breite 
des Platinenrands an, auf dem sich keine Bauelemente befinden 
dürfen.

8. Klicken Sie auf Fertig stellen. Der Leiterplattenumriss wird Ihrem 
Entwurf hinzugefügt.

Hinweis Weitere Einzelheiten zum Leiterplatten-Wizard erhalten Sie im Benutzerhand-
buch zu Ultiboard. 
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Um den Leiterplattenumriss zu verschieben, führen Sie die folgenden 
Schritte aus:

1. Klicken Sie auf der Registerkarte Lagen doppelt auf Board Outline.

2. Klicken Sie dann an eine beliebige Stelle im Leiterplattenumriss und 
ziehen Sie die Leiterplatte direkt unter die Bauelemente.

Um den Bezugspunkt zu ändern, führen Sie die folgenden Schritte aus:

1. Wählen Sie Entwurf»Referenzpunkt festlegen. Damit wird der 
Bezugspunkt dem Cursor unterlegt.

2. Bewegen Sie den Cursor in die linke untere Ecke des Leiterplattenum-
risses und führen Sie einen Mausklick aus.

 



Kapitel 3 Einführung in Ultiboard

Erste Schritte mit NI Circuit Design Suite 3-8 ni.com

Platzieren von Bauelementen
Zum Platzieren der Bauteile in der Datei GS1 auf die Platine gibt es ver-
schiedene Möglichkeiten: 

• Wählen Sie Bauelemente aus dem Bereich außerhalb des Leiterplat-
tenumrisses aus und ziehen Sie sie an die gewünschte Stelle.

• Suchen Sie die Bauelemente auf der Registerkarte Bauteile in der 
Tabellen-Ansicht und fügen Sie sie von dort aus ein.

• Wählen Sie Bauteile aus der Datenbank aus.

Tipp Mit Platzieren»Platzieren der Bauteile aufheben können Sie alle nicht fixierten 
Bauelemente von der gedruckten Platine entfernen und sie noch einmal anders einfügen. 

Ziehen von Bauelementen aus dem Bereich außerhalb des 
Leiterplattenumrisses

Beim Öffnen einer Netzliste aus Multisim oder eines anderen Programms 
zur Erstellung von Schaltplänen werden die Bauelemente normalerweise 
außerhalb des Leiterplattenumrisses angeordnet. Klicken Sie vor dem 
Beginn der Arbeit in der Entwurf-Toolbox doppelt auf Oberste Kupfer-
lage. Dadurch wird diese Lage als aktive Lage ausgewählt. 

Um U1 aus dem Bereich außerhalb des Leiterplattenumrisses zu verschie-
ben, führen Sie die folgenden Schritte aus: 

1. Suchen Sie in den Bauelementen außerhalb des Leiterplattenumrisses 
nach U1. Zoomen Sie dazu den Bereich mit <F8> heran, bis Sie U1 
erkennen können. 

Tipp Mit Hilfe der Funktion Bearbeiten»Suchen können Sie nach einem Bauelement 
suchen. Diese Funktion arbeitet im Großen und Ganzen wie die Suchfunktion anderer 
Anwendungen. Zusätzlich können Sie ein Bauelement jedoch auch nach Namen, Nummer, 
Form und Wert oder nach all diesen Parametern ausfindig machen. Einzelheiten dazu 
finden Sie im Benutzerhandbuch zu Ultiboard. 
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2. Klicken Sie auf U1 (die 7-Segment-Anzeige) und ziehen Sie sie an die 
in der unteren Abbildung gezeigte Position.

Hinweis Weitere Informationen zu den hier dargestellten Kraftvektoren und Luftlinien im 
Layout finden Sie im Ultiboard-Benutzerhandbuch. 

 

U1 bleibt so lange ausgewählt, bis Sie die Markierung aufheben. In 
Ultiboard müssen Sie jeden Vorgang explizit beenden. In diesem Fall 
wird die Auswahl des Bauelements durch einen einfachen Klick an 
eine andere Stelle aufgehoben. Auch durch einen Klick mit der rechten 
Maustaste kann der aktuelle Vorgang beendet werden. 

3. Klicken Sie auf die Registerkarte Bauteile in der Tabellen-Ansicht 
und scrollen Sie zu U1. Sie werden feststellen, dass die grüne LED 
neben dem Bauelement etwas heller ist. Das weist darauf hin, dass das 
Bauelement bereits auf die Platine platziert wurde.

1 Kraftvektor 2 Luftlinien
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Ziehen von Bauelementen von der Bauteile-Registerkarte
Um Bauelemente von der Registerkarte Bauteile zu verschieben, führen 
Sie die folgenden Schritte aus: 

1. Scrollen Sie in der Bauteile-Registerkarte bis zu J3.
 

2. Klicken Sie auf J3 und ziehen Sie das Element von der Registerkarte 
Bauteile in den Arbeitsbereich. J3 ist nun dem Mauszeiger unterlegt. 

3. Legen Sie J3 links am Rand etwa mittig auf der Leiterplatte ab. Wie 
bereits zuvor beobachtet, leuchtet nun auch die grüne LED von J3 auf 
der Registerkarte Bauteile etwas heller und zeigt damit an, dass das 
Bauelement auf die Platine platziert wurde.

Noch schneller lassen sich Platinen bestücken, indem Sie auf der Register-
karte Bauteile ein noch nicht eingefügtes Bauelement (angezeigt durch 
eine schwach leuchtende LED) auswählen und auf die Schaltfläche Start 
Platzierung der nicht positionierten Bauteile klicken. Ultiboard geht nun 
systematisch durch die Liste auf der Registerkarte Bauteile, wählt jedes 
Bauelement aus und unterlegt es dem Mauszeiger, so dass Sie es an der 
gewünschten Stelle absetzen können. Anschließend wird automatisch das 
nächste Bauelement aus der Liste ausgewählt. 
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Einfügen der Bauelemente dieser Einführung
Die Platine sollte am Schluss der Übung so bestückt sein wie in der Abbil-
dung unten. Die genaue Vorgehensweise bleibt Ihnen überlassen. Sie 
können aber auch die Datei GS2 in Ihrem Projekt öffnen, die bereits ent-
sprechend vorbereitet wurde. 

Ihr Entwurf sollte wie folgt aussehen: 
 

Einfügen von Bauelementen aus der Datenbank
Statt Bauelemente und andere Komponenten aus einer Datei zu importie-
ren, können Sie sie auch direkt aus der Datenbank auf die Platine einfügen. 
Im Folgenden wird auf diese Weise eine Montagebohrung vorgenommen. 

Um die Komponente aus der Datenbank einzufügen, führen Sie die folgen-
den Schritte aus:

1. Wählen Sie Platzieren»Aus Datenbank. Es erscheint das Dialogfeld 
Bauelement aus Datenbank abrufen. 

2. Erweitern Sie unter Datenbank in der Ultiboard-Hauptdatenbank die 
Kategorie Through Hole Technology Parts und wechseln Sie zur 
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Kategorie Holes. Daraufhin werden unter Verfügbare Bauelemente 
alle Bohrlochtypen angezeigt. 

3. Klicken Sie unter Verfügbare Bauelemente auf HOLE35. Die Kom-
ponente wird daraufhin in der Vorschau angezeigt. 

 

4. Klicken Sie auf OK. Das Dialogfeld Bauelement aus Datenbank 
abrufen wird ausgeblendet und Sie werden dazu aufgefordert, eine 
Referenzbezeichnung (REFDES) und einen Wert (VALUE) 
einzugeben. 

5. Geben Sie als Referenzbezeichnung des Bohrlochs “H1” und als Wert 
“HOLE” an und klicken Sie auf OK. 

6. Bewegen Sie den Mauszeiger über die Leiterplatte. Die Komponente 
ist nun dem Mauszeiger unterlegt.

7. Sobald sich das Loch im Bereich der oberen linken Ecke befindet, 
legen Sie es durch einen Mausklick auf der Leiterplatte ab. 

8. Es erscheint erneut das Dialogfeld Referenzbezeichnung für Bauteil 
eingeben. Die Referenzbezeichnung wird automatisch auf H2 erhöht. 

9. Geben Sie als Wert “HOLE” ein und klicken Sie auf OK, um die näch-
ste Bohrung in der rechten oberen Ecke zu platzieren. Fahren Sie so 
mit H3 in der rechten unteren Ecke und H4 in der linken unteren Ecke 
fort.
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10. Klicken Sie zum Beenden des Vorgangs auf Abbrechen und schließen 
Sie das Dialogfeld Bauteil aus Datenbank abrufen, indem Sie noch-
mals auf Abbrechen klicken. 

 

Bauelemente verschieben
Die verschiedenen Vorgehensweisen zum Einfügen von Bauelementen 
gelten ebenso für das Verschieben. Um ein Bauelement auszuwählen, das 
sich bereits auf der Leiterplatte befindet, müssen Sie nur darauf klicken. 
Zum Festlegen der Koordinaten, an die das Bauteil verschoben werden soll, 
drücken Sie auf dem Ziffernblock der Tastatur die <*>-Taste. Stattdessen 
können Sie auch auf der Registerkarte Bauteile ein Bauelement auf der 
Platine auswählen (durch eine hell leuchtende grüne LED gekennzeichnet) 
und es an eine andere Stelle ziehen. 

Tipp Die Beschriftung von Bauelementen gehört nicht zum Footprint. Beim Markieren 
eines Bauelements auf der Leiterplatte müssen Sie daher aufpassen, dass Sie das gesamte 
Bauelement markieren und nicht nur die Beschriftung. Um diesen Vorgang zu erleichten, 
können Sie den Auswahlfilter zu Hilfe nehmen. Einzelheiten dazu finden Sie im Benut-
zerhandbuch zu Ultiboard. 
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Tipp Zum Verschieben eines Bauelements markieren Sie es und drücken Sie die 
Pfeiltasten auf der Tastatur. 

Sie können aber auch mehrere Bauelemente markieren und gemeinsam 
verschieben. Dazu gibt es folgende Möglichkeiten: 

• Drücken Sie die <Shift>-Taste und klicken Sie mehrere Bauelemente 
an.

• Ziehen Sie um mehrere Bauelemente einen Rahmen auf. 

Alle markierten Bauelemente werden beim Bewegen des Cursors gemein-
sam verschoben.

Tipp Gruppen gelten nur vorübergehend. Sobald Sie ein anderes Bauelement auswählen, 
geht die Gruppierung verloren. Um eine Gruppe von Bauelementen dauerhaft (bis zum 
Entfernen) zusammenzuhalten, ist der Gruppeneditor zu verwenden. Weitere Informatio-
nen finden Sie im Benutzerhandbuch zu Ultiboard. 

Durch Bearbeiten»Ausrichten können markierte Bauelemente so ver-
schoben werden, dass ihre Ränder in einer Linie sind oder die Bauelemente 
einen bestimmten Abstand voneinander haben. 

So platzieren Sie das eingefügte Bohrloch durch Bearbeiten»Ausrichten 
an die richtige Stelle: 

1. Wählen Sie H1 und halten Sie für H2 die <Shift>-Taste gedrückt. 

2. Wählen Sie Bearbeiten»Ausrichten»Oben ausrichten. Wenn H2 
nicht in Linie mit H2 eingefügt wurde, wird es nun entsprechend 
verschoben. 

3. Klicken Sie auf einen freien Bereich auf der Leiterplatte und markieren 
Sie H2 und H3. 

4. Wählen Sie Bearbeiten»Ausrichten»Rechts ausrichten. 

5. Fahren Sie auf diese Weise mit dem Ausrichten der Unterkanten von 
H3 und H4 sowie der linken Kanten von H1 und H4 fort. 

Verlegen von Leiterbahnen
Zum Verlegen von Leiterbahnen stehen Ihnen die folgenden Optionen zur 
Verfügung: 

• Manuell eingefügte Leiterbahn

• Follow-me-Leiterbahn

• Vollautomatische Leiterbahn.
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Eine manuell eingefügte Leiterbahn wird genau so verlegt, wie Sie es vor-
geben, auch wenn sie durch ein Bauelement oder eine andere Leiterbahn 
verläuft. Eine Follow-me-Leiterbahn stellt selbständig zulässige Verbin-
dungen zwischen den mit der Maus angewählten Anschlussstiften her. Sie 
können sich also von Anschlussstift zu Anschlussstift bewegen und so eine 
zulässige Leiterbahn anlegen. Beim vollautomatischen Einfügen von Lei-
terbahnen werden zwei Anschlussstifte auf dem kürzestmöglichen Weg 
miteinander verbunden, wobei der Verlauf der Leiterbahn später gändert 
werden kann.

Bevor Sie mit der Maus klicken, um eine Leiterbahn an einer bestimmten 
Stelle zu fixieren, können Sie jederzeit ein Stück der Leiterbahn entfernen, 
indem Sie den Cursor zurückbewegen. Jedes Mal, wenn Sie eine Leiter-
bahn durch Klicken manuell verlegen oder wenn eine Follow-me-Leiter-
bahn oder vollautomatisch verlegte Leiterbahn die Richtung ändert, wird 
ein neues Segment erzeugt. Dieser Umstand ist bei Änderungen zu 
berücksichtigen.

Manuelles Verlegen von Leiterbahnen
Sie können entweder mit der bisher verwendeten Datei fortfahren oder GS3 
öffnen. Achten Sie darauf, dass die Oberste Kupferlage ausgewählt ist, 
bevor Sie beginnen. Die Oberste Kupferlage sollte auf der Registerkarte 
Lagen der Entwurf-Toolbox rot hervorgehoben sein. 

Tipp Drücken Sie bei Bedarf zum Einblenden des gesamten Plans die Taste <F7>. 

Um eine Leiterbahn manuell anzuordnen, führen Sie die folgenden Schritte 
aus: 

1. Wählen Sie Platzieren»Linie. 

Tipp Mit diesem Menüpunkt wird eine Linie auf einer beliebigen Lage erzeugt. Die Art 
der Linie ist je nach ausgewählter Lage unterschiedlich. Wenn die ausgewählte Lage zum 
Beispiel die Siebdrucklage ist, wird damit auf der gedruckten Leiterplatte eine Linie 
erzeugt. Bei einer Kupferlage wird mit dieser Option eine leitende Verbindung hergestellt. 
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2. Suchen Sie links auf der Leiterplatte nach J3. Finden Sie heraus, wo 
sich der unten gezeigte Start-Anschlussstift befindet:

 

Tipp Bei Schwierigkeiten mit dem Auffinden des Bauelements nutzen Sie die Suchfunk-
tion auf der Registerkarte Bauteile. Wählen Sie ein Bauelement auf der Registerkarte 
Bauteile aus und klicken Sie dann die Schaltfläche Bauteil suchen und auswählen an. 
Das Bauelement wird im Arbeitsbereich angezeigt. Bei Bedarf können Sie mit <F8> näher 
heranzoomen. 

3. Klicken Sie auf den Anschlussstift, der im Schritt oben festgelegt 
wurde. Ultiboard hebt daraufhin sämtliche Anschlussstifte hervor, die 
zum selben Netz gehören. Die Hervorhebungsfarbe kann auf der Regi-
sterkarte Farben des Dialogfelds Voreinstellungen (Optionen»
Allgemeine Einstellungen) verändert werden. So wissen Sie, welche 
Anschlussstifte Ihrem Schaltplan entsprechend zu verbinden sind. 

1 Bauteil J3 2 Start-Anschlussstift
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4. Bewegen Sie den Cursor in eine beliebige Richtung. Eine grüne Linie 
(die Leiterbahn) wird nun an den ausgewählten Anschlussstift ange-
hängt. Mit jedem Klick fixieren Sie ein Leiterbahnensegment, wie in 
der unten stehenden Abbildung (2) gezeigt. 

5. Klicken Sie auf den Endanschlussstift. 
 

6. Mit einem Rechtsklick wird das Verlegen von Leiterbahnen beendet. 

1  Anschlussstifte desselben Netzes  

1 Leiterbahn
2 Fixieren der Leiterbahn durch Mausklick

3 Endanschlussstift
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Verlegen von Follow-me-Leiterbahnen
Um eine Follow-me-Leiterbahn einzufügen, führen Sie folgende Schritte 
aus: 

1. Wählen Sie Platzieren»Follow-me. 

2. Klicken Sie auf den oberen Anschlussstift von J3. 

3. Klicken Sie in der linken Spalte von U4 auf den zweiten Anschlussstift 
von unten. 

4. Ultiboard stellt automatisch eine Verbindung zwischen beiden her. 

Tipp Statt auf einen Anschlussstift können Sie auch auf die Luftlinie zwischen den Bau-
elementen klicken. 

Vollautomatisches Verlegen von Leiterbahnen
Um eine Vollautomatische Leiterbahn einzufügen, führen Sie die folgen-
den Schritte aus:

1. Wählen Sie Platzieren»Vollautomatisch. 

2. Klicken Sie die unten dargestellte Luftlinie an.
 

1 Luftlinie anklicken  
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3. Beim Bewegen Ihres Cursors schlägt Ultiboard automatisch verschie-
dene Leiterbahnverläufe um Hindernisse herum vor. 

4. Wenn Sie sich für eine Leiterbahnführung entschieden haben, fixieren 
Sie die Leiterbahn durch einen Klick. Sie müssen dazu nicht auf die 
Luftlinie oder den Endanschlussstift klicken. 

 

5. Mit der rechten Maustaste beenden Sie die Leiterbahnplatzierung. 

1 Es erscheinen Leiterbahnsegmente zwischen Anschlussstiften
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Automatische Bauteilplatzierung
Neben den bisher beschriebenen Möglichkeiten zum Bestücken von Plati-
nen bietet Ultiboard auch eine vollautomatische Bauteilplatzierungs-
funktion für fortgeschrittene Benutzer. 

Tipp Vor dem automatischen Bestücken der Platine müssen Sie alle Bauelemente, die 
vom automatischen Einfügen nicht betroffen sein sollen, per Hand einfügen und an der 
gewünschten Stelle fixieren. (Die Montagebohrungen und U1, J1, J2, J3, und LED 1 in GS5 
wurden beispielsweise bereits fixiert). Weitere Informationen zum Fixieren von Bauteilen 
finden Sie im Benutzerhandbuch zu Ultiboard. 

Zum automatischen Einfügen der Bauelemente in Getting 
Started.ewprj: 

1. Öffnen Sie den Entwurf GS5 in Ultiboard. 

2. Wählen Sie Automatische Leiterbahnführung»Start automatische 
Platzierung. Die Leiterplatte wird nun mit den Bauteilen bestückt.
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Automatische Leiterbahnführung
Leiterbahnen können in Ultiboard entweder nach den beschriebenen Ver-
fahren oder automatisch verlegt werden. Die automatische Leiterbahn-
führung wird nachfolgend erklärt. 

Zum automatischen Verbinden der Leiterbahnen in Getting 
Started.ewprj: 

1. Öffnen Sie den Entwurf GS3 in Ultiboard. 

2. Wählen Sie Automatische Leiterbahnführung»Start/Wiederauf-
nahme automatische Leiterbahnführung. Der Arbeitsbereich 
wechselt in den Modus zur automatischen Leiterbahnführung. 

Daraufhin können Sie sehen, wie die Leiterbahnen auf der Platine ver-
legt werden. Nach Abschluss des Vorgangs wird der Modus zur 
automatischen Leiterbahnführung beendet und der bisherige 
Arbeitsbereich wieder geöffnet.

3. Bei Bedarf können Sie den Verlauf der Leiterbahnen optimieren, 
indem Sie Automatische Leiterbahnführung»Start Optimierung 
auswählen. 

 

Sie können die automatische Leiterbahnführung jederzeit anhalten und 
manuelle Änderungen vornehmen. Bei erneutem Start der automatischen 
Leiterbahnführung fährt die Funktion an der letzten Stelle fort. Alle manu-
ell verlegten Leiterbahnen müssen fixiert werden, damit sie nicht durch die 
Automatik verschoben werden. 



Kapitel 3 Einführung in Ultiboard

Erste Schritte mit NI Circuit Design Suite 3-22 ni.com

Tipp Die Einstellungen zum automatischen Bestücken mit Bauelementen und zur auto-
matischen Leiterbahnführung befinden sich in den Leiterbahnführungsoptionen. 
Einzelheiten dazu finden Sie im Benutzerhandbuch zu Ultiboard. 

Vorbereitung für Herstellung und Bestückung
Ultiboard bietet eine Vielzahl verschiedener Ausgabeformate für die Pro-
duktion und Fertigung der Platinen. In diesem Abschnitt werden das 
Fertigen der Platine und Dokumentieren des gefertigten Produkts 
beschrieben. 

Aufräumen der Leiterplatte (Clean-Up)
Bevor Sie die Leiterplatte in die Fertigung schicken, sollten Sie alle offenen 
Leiterbahnenden und nicht genutzten Lötaugen von der Leiterplatte 
beseitigen. 

Dies soll nun anhand des GS4-Entwurf geübt werden. Öffnen Sie den Ent-
wurf und wählen Sie Bearbeiten»Löschen Kupferfläche»Leiterbahn-
enden ohne Anschluss. Dadurch werden alle nach einer Seite offenen Lei-
terbahnen aus dem Entwurf gelöscht. 

Um alle Lötaugen ohne Anschluss an Leiterbahnsegmente oder Kupferflä-
chen zu löschen, klicken Sie bei geöffnetem Schaltplan auf Entwurf»Noch 
nicht verwendete Durchkontaktierungen löschen.

Hinzufügen von Kommentaren
Mit Hilfe von Kommentaren können Sie Änderungsvorgaben oder 
bestimmte Hintergrundinformationen an die Ingenieursabteilung 
übermitteln. 

Sie können einen Kommentar direkt in einen Arbeitsbereich einfügen oder 
an ein Bauelement anheften. Wenn Sie das betreffende Bauelement ver-
schieben, so verschiebt sich der Kommentar ebenfalls. 

Weitere Informationen finden Sie im Benutzerhandbuch zu Ultiboard. 
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Exportieren von Dateien
Beim Erstellen einer Ultiboard-Exportdatei werden alle Angaben zu einer 
Platine in einem Format zusammengefasst, das durch den Hersteller der 
Leiterplatte gelesen werden kann. Eine exportierte Datei enthält vollstän-
dige Informationen darüber, wie eine Leiterplatte anzufertigen ist. Zu den 
exportierbaren Dateien gehören Gerber-RS-274X- und RS-274D-Dateien. 

Weitere Informationen finden Sie im Benutzerhandbuch zu Ultiboard. 

3D-Ansicht von Entwürfen
In Ultiboard kann jederzeit eine dreidimensionale Voransicht Ihrer Leiter-
platte eingeblendet werden. Weitere Informationen finden Sie im 
Benutzerhandbuch zu Ultiboard. 

 

Tipp Die Interne Ansicht ermöglicht Ihnen einen Blick zwischen die Lagen einer mehr-
lagigen Platine. Weitere Informationen finden Sie im Benutzerhandbuch zu Ultiboard. 
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4
Einführung in Multisim MCU

In diesem Kapitel lernen Sie, wie eine Schaltung mit Mikrocontroller simu-
liert und darin nach Fehlern gesucht wird. 

Überblick
Die für diese Einführung verwendeten Dateien werden zusammen mit der 
NI Circuit Design Suite unter ...\Dokumente und Einstellun-
gen\All Users\Gemeinsame Dokumente\National 

Instruments\Circuit Design Suite 10.1\samples\Getting 

Started\ installiert. 

Für diese Anleitung nutzen Sie die Datei Getting Started MCU.ms10, 
die bei Bedarf auf den Inhalt des Ordners LCDWorkspace zugreift. 

Im Multisim-Schaltungsbeispiel für eine LCD-Grafikanzeige wird der Ein-
satz eines PIC-Mikrocontrollers zur Steuerung der Anzeige anhand eines 
Toshiba-T6963C-Controllers und einem externen RAMs demonstriert. Zur 
Steuerung der Anzeige übermittelt der Mikrocontroller Signale über die 
Daten- und Steuerleitungen des Geräts. Ein für den Mikrocontroller 
geschriebenes Softwareprogramm bestimmt die Logikpegel für die Leitun-
gen an den Anschlussstiften (High oder Low) zur Übermittlung von 
Befehlen und Daten an die Anzeige. 
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Über diese Anleitung
Die Datenleitungen von LCD U2 sind mit den Anschlussstiften RB0 bis 
RB7 des Mikrocontrollers U1 verbunden. Die Steuerleitungen der 
LCD-Anzeige sind mit den Anschlüssen RA0 bis RA2 des Mikrocontrol-
lers verbunden. Die MCU U1 kommuniziert mit dem LCD U2 über diese 
Verbindungen. Die Daten werden parallel an U2 übermittelt, wobei die 
Signale auf den Steuerleitungen das Timing und den Typ der gesendeten 
Daten (d. h. Adresse oder Daten) bestimmen. 

Die LCD-Grafikanzeige kann in drei verschiedenen Modi arbeiten: im 
Textmodus, Grafikmodus oder einem kombinierter Modus aus Text und 
Grafik. Im Beispiel befindet sich die Anzeige im kombinierten Modus. Die 
Software zur Ausführung der MCU befindet sich in einem MCU-Arbeits-
bereich, der in der Entwurf-Toolbox als LCDWorkspace angezeigt wird. 
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Der Arbeitsbereich enthält ein Projekt namens project1, das nur aus der 
Quellcodedatei main.asm besteht.

Um die Datei zu betrachten, führen Sie die folgenden Schritte aus:

1. Klicken Sie in der Entwurf-Toolbox doppelt auf main.asm. Im 
Arbeitsbereich zur Schaltungserfassung erscheint eine Registerkarte 
namens main.asm, auf der das Assembly-Programm angezeigt wird.

 

Zum Einblenden der Zeilennummern wählen Sie MCU»Zeilennummern 
anzeigen. 

Um die Schaltungssimulation zu starten, führen Sie die folgenden Schritte 
aus: 

1. Wählen Sie Simulieren»Start. Wenn Sie noch keine Programmdatei 
erzeugt haben, erscheint ein Dialogfeld mit dem Hinweis, dass die 
Konfiguration nicht mehr aktuell ist. Sie werden daher aufgefordert, 
eine neue Programmdatei zu erstellen. Klicken Sie auf Ja. Die Ergeb-
nisse der Erstellung werden in der Tabellen-Ansicht auf der 
Registerkarte Ergebnisse angezeigt. Wenn keine Fehler oder Warnun-
gen zu sehen sind, wurde die Programmdatei erfolgreich erzeugt. (Das 
Beispielprogramm sollte keine Fehler enthalten.) 

Das Programm zeigt die Zeile “Graphical LCD T6963C for Multisim” 
im Textmodus an; das LCD schaltet dann in den Grafikmodus um und 
stellt Punkt für Punkt über dem Text ein umgedrehtes “V” dar. 

Nach der Anzeige der Linien scrollt der Text nach rechts und links. 
Dazu wird einfach die Startadresse des Textpuffers der LCD-Anzeige 
verschoben. Die LCD-Anzeige enthält zwei Pufferspeicher, und zwar 
einen zum Speichern von Grafiken und einen zum Speichern von Tex-
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ten. Weitere Funktionen der LCD-Anzeige, wie Blinken des Textes 
und Löschen von Zeichen, werden ebenfalls demonstriert. 

Das Programm zur Steuerung der LCD-Anzeige stellt jeden dieser 
Effekte nacheinander dar. 

Um die Simulation anzuhalten, wählen Sie Simulieren»Stopp. 

Die Funktion des Assembly-Programms

Konstanten und Daten
Um das Programm verständlicher zu gestalten, werden zu Beginn die 
Befehle zur Steuerung der Anzeige und die temporären Puffer für Adressen 
und Daten in der MCU als Konstanten definiert.

 

Der anzuzeigende Text wird bei einigen Mikrocontrollern in Form einer 
Tabelle gespeichert. Es gibt aber keinen Assembly-Befehl, um direkt auf 
einen Datenwert im Speicherbereich des Programms zuzugreifen. Stattdes-
sen besteht die Möglichkeit, Werte in unkodierter Form in das W-Register 
zu laden, so dass Sie eine Routine schreiben können, die je nach Kennzahl 
einen anderen String ausgibt. Die RETLW-Anweisung lädt einen konstanten 
Wert in das W-Register und führt einen RETURN durch (beides in einem 
Befehl). 
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Die TXPRT-Routine fragt den auf der LCD-Anzeige darzustellenden Text 
ab. Die Zeichencodes der LCD-Anzeige sind im Handbuch zum 
T6963C-Controller festgehalten (z. B. steht 0x27 für den Buchstaben “G” 
und 0x52 für “r”): 
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Initialisierung
Der Initialisierungscode beginnt bei START, wie im Programmabschnitt 
unten dargestellt. Die Anschlussstifte im Mikrocontroller werden als Aus-
gangskontakte konfiguriert und die Werte zurückgesetzt. Die 
LCD-Anzeige wird durch den Mikrocontroller initialisiert und auf Grafik- 
und Textmodus gestellt. Die Rücksprungadresse wird für den Grafikpuffer 
auf 0x0000 und den Textpuffer auf 0x2941 eingestellt. Dadurch wird fest-
gelegt, an welcher Stelle im LCD die Anzeige die Daten beginnen soll. 
Schließlich werden die Steuersignale noch für den geeigneten 
Schreib-/Lesezugriff auf der LCD-Anzeige eingestellt. 
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Zeichnen von Text und Grafiken
Der Rest des Programmcodes dient dazu, Befehle über die Steuerleitungen 
und die MCU-Anschlussstifte (RA0 bis RA2) an die LCD-Anzeige und die 
Daten über die Datenleitungen zu senden: 

 

Zum Beispiel werden mit dem oben dargestellten Programmabschnitt die 
mit der TXPRT-Subroutine angegebenen Zeichen aus der Hauptschleife an 
die im Textmodus befindliche LCD-Anzeige übertragen. 

Mit den folgenden Befehlen wird die LCD-Anzeige in den Auto-Schreib-
modus umgeschaltet: 

MOVLW CMD_AWRON

MOVWF CMD_BUFFER

CALL CMD
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An diesem Punkt beginnt das Programm zu zählen und führt die Schleife 
LOOP_READ_DATA2 35 Mal aus. Durch TXPRT ruft die Schleife den Text ab 
und lädt ihn in das W-Register. Dann ruft sie die Subroutine ADT auf, 
welche wiederum SEND_DATA aufruft. Dadurch werden die Werte im 
W-Register an den Port B gesendet, so dass sie an die Datenleitungen der 
LCD-Anzeige übermittelt werden können. Nach dem Senden der Daten 
wird der passende Wert von Port A des Mikrocontrollers an die Steueran-
schlussstifte der LCD-Anzeige übertragen, um zu signalisieren, dass die 
Daten gelesen werden können. Nach Ausführung jeder Subroutine kehrt 
das Programm wieder an das Ende des letzten Befehls zurück, der vor dem 
Aufruf der Subroutine ausgeführt wurde. Das passiert so lange, bis alle 35 
Zeichen übermittelt wurden. Mit den letzten drei Anweisungen wird nach 
Verlassen der Schleife der Auto-Schreibmodus der LCD-Anzeige 
ausgeschaltet: 

MOVLW CMD_AWROFF

MOVWF CMD_BUFFER

CALL CMD

Mit den folgenden Anweisungen wird die horizontale und die schräge Linie 
im Grafikmodus gezeichnet:

;6 draw wave once

MOVF ADDR_L, 0

BTFSC STATUS, Z

CALL DRAW_WAVE

Arbeiten mit den MCU-Fehlersuchfunktionen
Dieser Abschnitt enthält eine Schritt-für-Schritt-Beschreibung der Fehler-
suchfunktion des Multisim-MCU-Moduls. Es ist wichtig, dass die Schritte 
genau in der angegebenen Reihenfolge ausgeführt werden. Sobald Sie die 
Haltepunktfunktion und die Einzelschrittverfahren verstanden haben, 
können Sie sich mit den Möglichkeiten der erweiterten MCU-Fehlersuche 
befassen. 

Übersicht zur Fehlersuche
Um ein Programm für einen Mikrocontroller entweder in C oder Assembler 
zu schreiben, erstellen Sie zunächst Quellcodedateien (also eine *.asm, 
*.inc, *.c und *.h -Datei) als Teil des MCU-Arbeitsbereichs. Diese 
Dateien können dann in der Quellcodeansicht bearbeitet werden. 
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Um zur Quellcodeansicht zu gelangen: 

1. Klicken Sie die Datei (z. B. main.asm) in der Entwurf-Toolbox in 
der Hierarchie der MCU-Arbeitsbereiche doppelt an. 

Während der Simulation sollen Ihnen die angezeigten zusätzlichen Fehler-
suchinformationen dabei helfen, zu verstehen, was innerhalb der MCU 
geschieht. Sie können beispielsweise zwischen dem High-Level-
Quellcode und den Assembly-Anweisungen umschalten, wo außerdem der 
tatsächliche Opcode für jede ausgeführte Anweisung angezeigt wird. 

In der Quellcodeansicht können all diese Zusatzinformationen nicht ange-
zeigt werden. Stattdessen hat jedes MCU-Bauelement im Schaltplan eine 
eigene Debug-Auflistung, in der Angaben zu Fehlern angezeigt werden. 

Um zur Debug-Auflistung zu gelangen:

1. Wählen Sie MCU»MCU PIC 16F84A U1»Erstellen. 

Hinweis Die Fehlersuchansicht ist nur dann verfügbar, wenn Sie Ihren Code erfolgreich 
erstellt haben, so dass der vorangehende Schritt nur einmal notwendig ist. 

2. Wählen Sie  MCU»MCU PIC 16F84A U1»Debug-Ansicht.

oder:

Klicken Sie im MCU-Arbeitsbereich der Entwurf-Toolbox einen Ein-
trag mit der rechten Maustaste an und wählen Sie den entsprechenden 
Menüpunkt aus. 
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Es öffnet sich eine weitere Registerkarte im Arbeitsbereich der Schal-
tungserfassung namens Debug(MCU-Referenzbezeichner), in diesem 
Fall Debug(U1). 

 

In der Dropdown-Liste im oberen Bereich der Debug-Auflistung (vgl. 
Abbildung) können Sie zwischen den intern von Multisim erzeugten Disas-
sembly-Anweisungen und der vom Assembler oder Compiler erzeugten 
Auflistungsdatei umschalten. (Das Format der Auflistungsdatei richtet sich 
nach dem Tool, mit dem Sie die Programmdatei erzeugt haben). 

Im Beispiel der LCD-Grafikanzeige wurde der Programmcode in Assem-
bler geschrieben und mithilfe der Mikrochip-Assembly-Tools in eine 
Programmdatei umgewandelt. Der Mikrochip-Assembler erzeugt eine 
Auflistungsdatei (*.lst) mit allen Opcodes, die für jede Assembly-
Anweisung erzeugt wurden. In der Fehlerlistenansicht werden Informatio-
nen aus dieser Auflistungsdatei angezeigt. Multisim wandelt die 
Opcode-Anweisungen mithilfe eines internen Disassemblers in Assem-
bler-Anweisungen um. 

Für dieses Beispiel ist das Disassembler-Format jedoch nicht notwendig, 
da die Fehlerliste bereits alle erforderlichen Informationen enthält. In den 
Fällen, wo ein MCU-Projekt nur die *.hex-Datei mit dem Maschinencode 
lädt, zeigt die Disassembly-Ansicht die aufgeschlüsselten Opcode-Anwei-
sungen, so dass erkennbar wird, was innerhalb der MCU vor sich geht. Die 

1  Drop-down-Liste  
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Disassembly-Ansicht ist sehr nützlich, da für MCU-Projekte dieses Typs 
keine Auflistungsdatei verfügbar ist. 

Hinzufügen von Haltepunkten
Sie können der Quellcodeansicht sowohl bei angehaltener als auch bei lau-
fender Simulation Haltepunkte hinzufügen. Haltepunkte können einem 
Mikrocontrollerprojekt auf zwei Arten erzeugt werden. 

Eine Möglichkeit besteht darin, sie zur Quellcodeansicht hinzuzufügen. In 
diesem Beispiel ist die Registerkarte main.asm im Arbeitsbereich der 
Schaltungserfassung die einzig verfügbare Quellcodeansicht. 

Hinweis Wenn sich Ihr MCU-Entwurf aus mehreren Dateien zusammensetzt, ist für jede 
der Quellcodedateien eine Quellcodeansicht verfügbar. 

Sie können aber auch einen Haltepunkt in der Debug-Auflistung angeben. 
Sie können Haltepunkte in der Disassembly-Ansicht oder der Fehlerlisten-
ansicht einfügen. In diesem Beispiel benötigen Sie jedoch lediglich die 
Fehlerliste.

 

Um einen Haltepunkt in der Quellcodeansicht hinzuzufügen: 

1. Öffnen Sie Debug-Auflistung für U1. 

2. Klicken Sie in der Entwurf-Toolbox doppelt auf main.asm. 

1  Graue Spalte  
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3. Scrollen Sie bis zur Zeile direkt unterhalb der START-Beschriftung: 
BCF STATUS, RP0. 

4. Klicken Sie im main.asm-Fenster die erste (graue) Spalte links neben 
BCF STATUS, RP0 doppelt an. Es erscheint ein roter Punkt an dieser 
Stelle, der signalisiert, dass an dieser Zeile ein Haltepunkt gesetzt 
wurde. 

5. Wählen Sie Simulieren»Start. Die Simulation wird automatisch an 
der Stelle unterbrochen, wo Sie den Haltepunkt gesetzt haben. Die 
Debug-Auflistung springt nun automatisch in den Vordergrund und 
ein gelber Pfeil weist an die Stelle, wo die Programmausführung unter-
brochen wurde. 

Um den Haltepunkt zu entfernen, führen Sie die folgenden Schritte aus: 

1. Klicken Sie den Haltepunkt in der Debug-Auflistung oder der 
main.asm-Quellcodeansicht doppelt an. 

oder:

Wählen Sie MCU»Entferne alle Haltepunkte, um alle Haltepunkte 
zu entfernen. 

Hinweis Haltepunkte in der Debug-Auflistung werden genauso hinzugefügt und entfernt 
wie in der Quellcodeansicht. 

Unterbrechen und in/aus Funktion hinein-/herausspringen
1. Wählen Sie MCU»Entferne alle Haltepunkte, um alle Haltepunkte 

zu entfernen. 

2. Wechseln Sie zur Schaltplan-Entwurfsansicht (die Registerkarte Get-
ting Started MCU) und wählen Sie Simulieren»Start. Auf der 
LCD-Anzeige wird nun der Text “Graphical LCD T6963C for Mul-
tisim” angezeigt. 

3. Wählen Sie Simulieren»Pausieren. 

4. Rufen Sie die Debug-Auflistung für U1 auf. Wie Sie sehen, ist die 
Programmzeile in der Fehlerliste an der Stelle, wo die Ausführung 
angehalten hat, links durch einen gelben Pfeil gekennzeichnet. 
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5. Wählen Sie MCU»MCU PIC16F84A U1»Speicheransicht, um den 
aktuellen Status des Speichers im Mikrocontroller U1 anzuzeigen. 
Beachten Sie, dass der Wert des Programmzählers PC des IROM-
Abschnitts um eins höher liegt als der Adresswert der Zeile, auf die der 
gelbe Pfeil zeigt. (Im Beispiel in der Abbildung oben hat die Adresse 
in der Debug-Auflistung den Wert 192 und der PC-Wert in der Spei-
cheransicht lautet 193). 

Hinweis Wenn der aktuelle Befehl bei Unterbrechung der Simulation noch nicht vollstän-
dig ausgeführt wurde, bleibt der Wert im Programmzähler der gleiche wie der Adresswert. 

Die anderen Abschnitte der Speicheransicht enthalten Werte in ande-
ren Teilen des Mikrocontroller-Speichers. 

6. Klicken Sie in der Werkzeugleiste Simulation auf die Schaltfläche 
Einzelschritt in den Funktionsaufruf hinein. 
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7. Die aktuelle Anweisung wird ausgeführt und die Simulation bei der 
nächsten Anweisung unterbrochen.

8. Wählen Sie Simulieren»Stopp. 

Unterbrechen und aus Funktion herausspringen
1. Fügen Sie in die SEND_DATA-Subroutine unter MOVWF PORTB einen 

Haltepunkt ein. 

2. Wählen Sie Simulieren»Start. Die Simulation wird am Haltepunkt 
unterbrochen. 

3. Klicken Sie die Schaltfläche Aus Funktion herausspringen in der 
Werkzeugleiste Simulation, um die SEND_DATA-Subroutine zu 
verlassen. 

4. Es werden alle verbleibenden Anweisungen in der SEND_DATA-Sub-
routine ausgeführt und bei der ersten Anweisung nach SEND_DATA 
wird die Simulation unterbrochen. 

Unterbrechen und in Funktion hineinspringen
1. Wählen Sie MCU»Entferne alle Haltepunkte. 

2. Setzen Sie vor den Aufruf von SEND_DATA einen Haltpunkt – also 
dort, wo Sie soeben über dem gelben Pfeil herausgesprungen sind. 

3. Wählen Sie Simulieren»Ausführen. Die Simulation wird dort unter-
brochen, wo Sie soeben den Haltepunkt gesetzt haben. 

4. Klicken Sie in der Werkzeugleiste Simulation auf die Schaltfläche 
In Funktion hineinspringen. Die Simulation wird daraufhin in der 
SEND_DATA-Subroutine unterbrochen. 

Unterbrechen und Funktionsaufruf überspringen
1. Wählen Sie Simulieren»Start. Die Simulation wird am selben Halte-

punkt unterbrochen wie zuvor beim Aufruf der Subroutine 
SEND_DATA. 

2. Klicken Sie in der Werkzeugleiste Simulation auf die Schaltfläche 
Funktionsaufruf überspringen. Die Subroutine SEND_DATA wird 
nun vollständig ausgeführt und die Simulation wird an der ersten 
Anweisung nach CALL_SEND_DATA unterbrochen. 



Kapitel 4 Einführung in Multisim MCU

© National Instruments Corporation 4-15 Erste Schritte mit NI Circuit Design Suite

Zum Cursor
1. Wählen Sie MCU»Entferne alle Haltepunkte. 

2. Klicken Sie auf eine Zeile in der SEND_DATA-Subroutine, denn diese 
Subroutine wird bekanntermaßen nochmals aufgerufen, um Daten an 
die LCD-Anzeige zu übermitteln.

3. Klicken Sie in der Werkzeugleiste Simulation auf die Schaltfläche 
Zum Cursor. Die Simulation wird bis zur Anweisung ausgeführt, die 
Sie in der SEND_DATA-Subroutine angeklickt haben. Dann folgt eine 
Ausführungspause und neben die Zeile wird ein gelber Pfeil gesetzt. 
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A
Technische Unterstützung und 
professioneller Service

Auf der Website ni.com/germany finden Sie umfassende Informationen 
über die folgenden professionellen Serviceleistungen und den technischen 
Support von National Instruments:

• Support—Auf ni.com/support/d finden Sie folgende Informa-
tionsquellen und Tools:

– Technische Ressourcen—Diese Website bietet Ihnen Soforthilfe 
bei Fragen und Problemen. Außerdem finden Sie hier Treiber, 
Updates, eine umfassende Wissensdatenbank (KnowledgeBase), 
Bedienungsanleitungen, Anleitungen zur Problemlösung, 
Tausende Beispielprogramme, autodidaktische Kurse und Appli-
cation Notes. Registrierte Nutzer können sich auch an den 
Diskussionsforen auf ni.com/forums (englisch) beteiligen. 
Jede im Forum eingereichte Frage wird garantiert beantwortet.

– Standard Service Program—Teilnehmer dieses Programms 
können sich telefonisch oder per E-Mail direkt mit unseren Appli-
kationsingenieuren in Verbindung setzen und jederzeit die 
Schulungseinheiten im Services Resource Center nutzen. Beim 
Erwerb eines Produkts von National Instruments sind Sie auto-
matisch ein Jahr lang zur Teilnahme am Standard Service Program 
berechtigt. Danach ist die Mitgliedschaft kostenpflichtig. 

Welche Art der technischen Unterstützung es in Ihrer Nähe gibt, 
erfahren Sie unter ni.com/services/d oder bei einer unserer 
Niederlassungen (ni.com/contact). 

• Training und Zertifizierung—Auf ni.com/training/d finden 
Sie Lehrmaterial und Informationen zur Zertifizierung. Hier können 
Sie sich auch für eine der weltweit angebotenen Software-Schulungen 
anmelden.

• Systemintegration—Wenn Sie aus Zeit- oder Personalmangel oder 
aus anderen Gründen bei einem Projekt in Verzug geraten, können 
Ihnen die Mitglieder des NI-Alliance-Programms weiterhelfen. Für 
Informationen zu diesem Programm setzen Sie sich entweder tele-
fonisch mit einer Niederlassung von National Instruments in Ihrer 
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Nähe in Verbindung, besuchen Sie die Website ni.com/alliance 
(englisch) oder klicken Sie auf ni.com/germany im Menü links auf 
den Link “Alliance Program”.

Sollten Sie nach dem Besuch unserer Website ni.com noch Fragen 
haben, wenden Sie sich bitte an eine Niederlassung von National Instru-
ments in Ihrer Nähe. Die Telefonnummern aller Niederlassungen finden 
Sie am Anfang dieses Handbuchs. Auf die Websites der einzelnen Nieder-
lassungen, auf denen Sie immer die aktuellen Kontaktinformationen, 
Telefonnummern des technischen Supports, E-Mail-Adressen sowie 
aktuelle Ereignisse und Veranstaltungen finden, gelangen Sie über 
ni.com/niglobal.
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Stichwortverzeichnis

Zahlen
3D-Entwürfe in Ultiboard, 3-23

A
Analyse, 2-16
Assembly-Programm, 4-4
Automatische Leiterbahnführung, 3-21
Automatisches Einfügen, 3-20

B
Bauelemente mit zwei Anschlüssen

direkt in eine Verbindung einfügen, 2-10
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必ずお読みください

保証

NIのソフトウェア製品が記録されている媒体は、素材および製造技術上の欠陥によるプログラミング上の問題に対して、受領書
などの書面によって示される出荷日から90日間保証致します。NIは、保証期間中にこのような欠陥の通知を受け取った場合、
弊社の裁量により、プログラミングの指示どおりに実行できないソフトウェア媒体を修理、交換致します。NIは、ソフトウェア
の操作が中断されないこと、および欠陥のないことを保証致しません。

お客様は、保証の対象となる製品をNIに返却する前に、返品確認 (RMA: Return Material Authorization)番号をNIから取得
し、パッケージ外に明記する必要があります。NIは、保証が及んでいる部品をお客様に返却する輸送費を負担いたします。

本書の内容については万全を期しており、技術的内容に関するチェックも入念に行っております。技術的な誤りまたは誤植が
あった場合、NIは、本書を所有するお客様への事前の通告なく、本書の次の版を改訂する権利を有します。誤りと思われる個所
がありましたら、NIへご連絡ください。NIは、本書およびその内容により、またはそれに関連して発生した損害に対して、一
切責任を負いません。

NIは、ここに記載された以外、明示または黙示の保証は致しません。特に、商品性または特定用途への適合性に関する保証は致
しません。NI側の過失または不注意により発生した損害に対するお客様の賠償請求権は、お客様が製品に支払われた金額を上限
とします。NIは、データの消失、利益の損失、製品の使用による損失、付随的または間接的損害に対して、その損害が発生する
可能性を通知されていた場合でも、一切の責任を負いません。NIの限定保証は、訴訟方式、契約上の責任または不法行為に対す
る責任を問わず、過失責任を含め、適用されます。NIに対する訴訟は、訴訟原因の発生から1年以内に提起する必要があります。
NIは、NIの合理的に管理可能な範囲を超えた原因により発生した履行遅延に関しては一切の責任を負いません。所有者がインス
トール、操作、保守に関するNIの指示書に従わなかったため、所有者による製品の改造、乱用、誤用、または不注意な行動、さ
らに停電、サージ、火災、洪水、事故、第三者の行為、その他の合理的に管理可能な範囲を超えた事象により発生した損害、欠
陥、動作不良またはサービスの問題については、本書に定める保証の対象となりません。

著作権
著作権法に基づき、National Instruments Corporation（米国ナショナルインスツルメンツ社）の書面による事前の許可なく、
本書のすべてまたは一部を写真複写、記録、情報検索システムへの保存、および翻訳を含め、電子的または機械的ないかなる形
式によっても複製または転載することを禁止します。

National Instrumentsは他者の知的財産を尊重しており、お客様も同様の方針に従われますようお願いいたします。NIソフト
ウェアは著作権法その他知的財産権に関する法律により保護されています。NIソフトウェアを用いて他者に帰属するソフトウェ
アその他のマテリアルを複製することは、適用あるライセンスの条件その他の法的規制に従ってそのマテリアルを複製できる場
合に限り可能であるものとします。

BSIM3 and BSIM4 are developed by the Device Research Group of the Department of Electrical Engineering and 
Computer Science, University of California, Berkeley and copyrighted by the University of California. 

The ASM51 cross assembler bundled with Multisim MCU is a copyrighted product of MetaLink Corp. 
(www.metaice.com). 

MPASM™ macro assembler and related documentation and literature is reproduced and distributed by 
Electronics Workbench under license from Microchip Technology Inc.  All rights reserved by Microchip Technology 
Inc.  MICROCHIP SOFTWARE OR FIRMWARE AND LITERATURE IS PROVIDED “AS IS,” WITHOUT WARRANTY OF ANY KIND, 
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL MICROCHIP BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY ARISING OUT OF OR IN CONNECTION WITH THE SOFTWARE OR FIRMWARE OR THE USE 
OF OTHER DEALINGS IN THE SOFTWARE OR FIRMWARE.

Anti-Grain Geometry - Version 2.4

Copyright (C) 2002–2004 Maxim Shemanarev (McSeem)

Permission to copy, use, modify, sell and distribute this software is granted provided this copyright notice appears 
in all copies. This software is provided "as is" without express or implied warranty, and with no claim as to its 
suitability for any purpose.

Anti-Grain Geometry - Version 2.4 

Copyright (C) 2002–2005 Maxim Shemanarev (McSeem) 

1. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the 
following conditions are met:

2. Redistributions of source code must retain the above copyright notice, this list of conditions and the following 
disclaimer.



3. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following 
disclaimer in the documentation and/or other materials provided with the distribution. 

The name of the author may not be used to endorse or promote products derived from this software without 
specific prior written permission. 

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT 
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE 
GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON 
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGE.

商標
National Instruments、NI、ni.com、および LabVIEWはNational Instruments Corporation（米国ナショナルインスツル
メンツ社）の商標です。National Instrumentsの商標の詳細については、ni.com/legalの「Terms of Use」セクションを参
照してください。

Ultiboard is a registered trademark and Multisim and Electronics Workbench are trademarks of Electronics 
Workbench. 

Portions of this product obtained under license from Bartels Systems GmbH. 

本文書中に記載されたその他の製品名および企業名は、それぞれの企業の商標または商号です。

ナショナルインスツルメンツ・アライアンスパートナー・プログラムのメンバーはナショナルインスツルメンツより独立して
いる事業体であり、ナショナルインスツルメンツと何ら代理店、パートナーシップまたはジョイント・ベンチャーの関係にあ
りません。

特許
National Instrumentsの製品を保護する特許については、ソフトウェアに含まれている特許情報（ヘルプ→特許情報）、CDに
含まれているpatents.txtファイル、またはni.com/patentsのうち、該当するリソースから参照してください。

Some portions of this product are protected under United States Patent No. 6,560,572. 

National Instruments Corporation製品を使用する際の警告
(1) National Instruments Corporation（以下「NI」という）の製品は、外科移植またはそれに関連する使用に適した機器の
備わった製品として、または動作不良により人体に深刻な障害を及ぼすおそれのある生命維持装置の重要な機器として設計さ
れておらず、その信頼性があるかどうかの試験も実行されていません。

(2) 上記を含むさまざまな用途において、不適切な要因によってソフトウェア製品の操作の信頼性が損なわれるおそれがありま
す。これには、電力供給の変動、コンピュータハードウェアの誤作動、コンピュータのオペレーティングシステムソフトウェ
アの適合性、アプリケーション開発に使用したコンパイラや開発用ソフトウェアの適合性、インストール時の間違い、ソフト
ウェアとハードウェアの互換性の問題、電子監視・制御機器の誤作動または故障、システム（ハードウェアおよび /またはソフ
トウェア）の一時的な障害、予期せぬ使用または誤用、ユーザまたはアプリケーション設計者の側のミスなどがありますが、
これに限定されません（以下、このような不適切な要因を総称して「システム故障」という）。システム故障が財産または人体
に危害を及ぼす可能性（身体の損傷および死亡の危険を含む）のある用途の場合は、システム故障の危険があるため、1つの形
式のシステムにのみ依存すべきではありません。損害、損傷または死亡といった事態を避けるため、ユーザまたはアプリケー
ション設計者は、適正で慎重なシステム故障防止策を取る必要があります。これには、システムのバックアップまたは停止が
含まれますが、これに限定されません。各エンドユーザのシステムはカスタマイズされ、NIのテスト用プラットフォームとは
異なるため、そしてユーザまたはアプリケーション設計者が、NIの評価したことのない、または予期していない方法で、NI製
品を他の製品と組み合わせて使用する可能性があるため、NI製品をシステムまたはアプリケーションに統合する場合は、ユー
ザまたはアプリケーション設計者が、NI製品の適合性を検証、確認する責任を負うものとします。これには、このようなシス
テムまたはアプリケーションの適切な設計、プロセス、安全レベルが含まれますが、これに限定されません。



表記規則

本書では以下の表記規則を使用します。

→ 矢印（→）は、ネスト化されているメニュー項目やダイアログボックスの

オプションをたどっていくと目的の操作項目を選択できることを示しま

す。 たとえば、ファイル→ページ設定→オプションとなっている場合は、

ファイルメニューをプルダウンして、ページ設定項目を選択し、最後のダ

イアログボックスからオプションを選択します。

このアイコンは、ユーザへのアドバイスを表しています。

このアイコンは、注意すべき重要な情報があることを示しています。

太字 太字のテキストは、メニュー項目やダイアログボックスのオプションな

ど、ソフトウェアで選択またはクリックする必要がある項目を表します。 
また、パラメータ名を示します。

斜体 斜体のテキストは、変数、強調、相互参照、または重要な概念の説明を示

します。 また、ユーザが入力する必要がある語または値のプレースホルダ

も示します。

monospace このフォントのテキストは、キーボードから入力する必要があるテキスト

や文字、コードの一部、プログラムサンプル、構文例を表します。 また、

ディスクドライブ、パス、ディレクトリ、プログラム、サブプログラム、

サブルーチンなどの名称、デバイス名、関数、操作、変数、ファイル名お

よび拡張子の引用にも使用されます。
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NI Circuit Design Suite の
概要

本書で説明する一部の機能は、ご使用の NI Circuit Design Suite のバー

ジョンによって使用できない場合があります。 ご使用のバージョンの機能

の一覧については、リリースノートを参照してください。 

NI Circuit Design Suite の製品ライン

ナショナルインスツルメンツの Circuit Design Suite は、EDA
（Electronics Design Automation）ツールのパッケージソフトで、

回路設計フローにおける主なステップを支援します。 

Multisim は、回路図の入力、シミュレーション、および PCB レイアウト

のようなダウンステージステップへのフィード用に設計された回路図キャ

プチャおよびシミュレーションプログラムです。 Multisim には、混合アナ

ログ / デジタルシミュレーション機能、およびマイクロコントローラコシ

ミュレーションも含まれています。 

Multisim からフィードされる Ultiboard は、プリント回路基板の設計、

特定の基本的な機械的 CAD 操作の実行、そして製造の準備に使用しま

す。 また、Ultiboard は自動部品配置およびレイアウトを提供します。 

チュートリアル

本書には、以下の段階的なチュートリアルが含まれています。 

• 「Multisim チュートリアル」 — Multisim およびその多くの機能を紹介

します。 

• 「Ultiboard チュートリアル」 — Multisim チュートリアルの章で説明

する回路のコンポーネント、そしてトレースを配置する方法を説明し

ます。 また、部品を自動配置し、自動で経路設定する方法について取

得します。 

• 「Multisim MCU チュートリアル」 — マイクロコントローラが含まれ

る回路のシミュレーションおよびデバッグのプロセスを説明します。 

これらの章で説明される機能の詳細については、『Multisim User Guide』
または『Ultiboard User Guide』を参照してください 
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2
Multisim チュートリアル

この章には、Multisim およびその多くの機能を紹介するチュートリアル

が含まれています。 

この章で説明する機能の一部は、ご使用の Multisim のバージョンによっ

て使用できない場合もあります。 ご使用のバージョンの機能の一覧につい

ては、リリースノートを参照してください。 

Multisim インタフェースの概要

Multisim は、ナショナルインスツルメンツ Circuit Design Suite の回路

図キャプチャおよびシミュレーションアプリケーションで、EDA
（Electronics Design Automation）ツールのパッケージソフトで、回路

設計フローにおける主なステップを支援します。 Multisim は、回路図の入

力、シミュレーション、および PCB レイアウトのようなダウンステージ

ステップへのフィード用に設計されています。 
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Multisim のユーザインタフェースは、以下の基本的な要素から構成され

ています。

メニューバーにすべての関数のコマンドがあります。 

設計ツールボックスでは、異なるタイプのファイルをプロジェクト（回路

図、PCB、レポート）で参照、回路図の階層を表示、そして異なるレイ

ヤーを表示または非表示することができます。 

1 メニューバー

2 設計ツールボックス

3 コンポーネントツールバー

4 標準ツールバー

5 表示ツールバー

6 シミュレーションツールバー

7 メインツールバー

8 使用中リスト

9 計測器ツールバー

10 左右のスクロール

11 回路ウィンドウ

12 スプレッドシートビュー

13 アクティブタブ
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コンポーネントツールバーには、Multisim のデータベースから回路図に

配置するコンポーネントを選択するためのボタンがあります。 

標準ツールバーには、保存、印刷、切り取り、および貼り付けなどのよく

実行する操作用のボタンが含まれています。 

表示ツールバーには、画面の表示方法を変更するためのボタンがありま

す。

シミュレーションツールバーには、開始、停止、およびその他のシミュ

レーション機能のボタンがあります。 

メインツールバーには、よく使用する Multisim の機能のボタンがありま

す。

使用中リストには、設計で使用されるすべてのコンポーネントのリストが

含まれています。 

計測器ツールバーには、各計測器のボタンがあります。 

回路ウィンドウ（またはワークスペース）は、回路設計を行う場所です。 

スプレッドシートビューでは、フットプリント、参照番号、属性、および

設計制約など、コンポーネントの詳細を含むパラメータの迅速で詳細な表

示および編集が可能です。 すべてまたは一部のコンポーネントのパラメー

タを、ワンステップで変更し、さまざまな機能を実行することができま

す。 

概要

このチュートリアルでは、回路図キャプチャ、シミュレーション、解析と

いった回路設計フローについて説明します。 次のページで説明する手順に

従った後に、小規模のアナログ信号をサンプリングする回路を設計してテ

ストし、サンプル信号を増幅して簡単なデジタルカウンタで信号発生回数

をカウントします。 

役に立つヒントが、以下のような左の列のアイコンによって示されます。 

ヒント キーボードで「F1」を押す、またはダイアログボックスのヘルプボタンをク

リックすることで、オンラインヘルプにいつでもアクセスすることができます。 

このチュートリアルの配線セクションでは、コンポーネント配置セクショ

ンで作成した回路をそのまま使用することができます。 
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または、...¥samples¥Getting Started¥にある Getting 

Started 1.ms10を使用することもできます。 このファイルでは、すべて

のコンポーネントが正しく配置されています。 

シミュレーションセクションでは、配線した回路を使用するか、Getting 

Started 2.ms10を開きます（コンポーネントがすべて正しく配線され

ています）。 

回路図キャプチャ

このセクションでは、以下の図のように回路にコンポーネントを配置し

て、配線します。
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ファイルを開いて保存する
以下の手順に従い、Multisim を起動します。

1. スタート→すべてのプログラム→ National Instruments →

Circuit Design Suite 10.1 → Multisim 10.1 を選択します。 「回路 1」
という空のファイルがワークスペースで開きます。 

新しい名前でファイルを保存するには、以下の手順に従います。 

1. ファイル→保存を選択して Windows 標準の保存ダイアログを表示

します。

2. ファイルを保存する場所へ移動し、MyGettingStartedというファ

イル名を入力して保存ボタンをクリックします。

ヒント データを間違って削除することを回避するために、環境設定ダイアログボック

スの保存タブで自動バックアップ作成を設定することができます。 

既存のファイルを開くには、以下の手順に従います。

1. ファイル→開くボタンをクリックして、ファイルのある場所へ行き、

ファイルをハイライトして開くをクリックします。 

ヒント Multisim の旧バージョンで保存されたファイルを開くには、開くダイアログ

ボックスのファイルタイプドロップダウンリストから該当するバージョンを選

択します。 

コンポーネントを配置する
以下の手順に従い、コンポーネントを配置します。

1. 上記の説明に従って MyGettingStarted.ms10を開きます。 

2. 配置→コンポーネントを選択してコンポーネントを選択ブラウザを開

き、以下の図に示される 7 セグメント LED の表示を選択し、OK を

クリックします。 コンポーネントの「ゴースト」画像がカーソル上に

表示されます。 

ヒント 適切なグループとファミリを選択したら、ブラウザのコンポーネントフィール

ドにコンポーネント名を入力します。 入力する際、ブラウザの下にある

検索中フィールドに文字列が表示されます。 この例では、

「seven_seg_decimal_com_a_blue」と入力します。 入力内容に応じて、

一致するコンポーネント名が表示されます。
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3. カーソルをワークスペースの右下へ移動し、左クリックしてコンポー

ネントを配置します。 このコンポーネントの参照番号は「U1」となり

ます。 
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4. 残りのコンポーネントを上の図のように「Digital Counter」領域に

配置します。
 

メモ 抵抗器、インダクタ、キャパシタ（RLC コンポーネント）を配置する場合、

コンポーネントを選択ブラウザには他のコンポーネントとは若干異なるフィール

ドがあります。 これらのコンポーネントを配置する際、コンポーネント値（例 : 
抵抗値）、タイプ（例 : 炭素膜）、許容差、フットプリント、および製造元の任意

の組み合わせを選択することができます。 PCB レイアウトに最終的にエクスポー

トされ、材料表の一部になるコンポーネントを配置する場合は、コンポーネント

を選択ダイアログボックスで選択する値の組み合わせが実際に購入可能なコン

ポーネントであることに注意する必要があります。 

ヒント RLC コンポーネントを配置する場合、コンポーネントリストの上にあるフィー

ルドに配置するデバイス値を入力します。 値は、回路図に配置されるリストに表

示する必要はありません。 

ヒント 200 Ωの抵抗器を配置する場合は、キーボードで「Ctrl-R」を押して、縦になる

よう回転させます。 

ヒント 各コンポーネントの参照番号（例 : U1、U2 など）は、配置した順番に割り当て

られます。 従って、コンポーネントを配置する順番によっては、上の図と参照番

号が異なる場合があります。 これは、回路の動作には影響しません。 
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5. 「Counter Control」領域に部品を配置します。 配置が完了したら、

各 SPDT スイッチを右クリックして左右反転を選択します。
 

ヒント SPDT スイッチは、Basic グループの Switch ファミリにあります。

ヒント すでにワークスペースに配置した部品と同じ部品を再度配置するには、配置済

みの部品をハイライト表示して編集→コピーを選択し、編集→貼り付けを選択

します。 また、使用中リストから選択して、クリックしてワークスペースに配置

することもできます。 

6. 下の図のように「Analog Amplifier」領域に部品を配置します。部

品は必要に応じて回転させます。
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AC 電圧信号ソースを配置したら、その上でダブルクリックします。 
電圧（Pk）を 0.2 V に変更し、OK をクリックしてダイアログボック

スを閉じます。

7. 下の図のように「Bypass Capacitors」領域に部品を配置します。
 

8. 下の図に示されるように、ヘッダと関連部品を配置します。
 

ヒント J3 は、Basic グループの Connectors ファミリにあります。

ヒント 回路の配線が完了したら、抵抗器などの 2 ピンコンポーネントを直接ワイヤに

ドロップすることができます。 接続は Multisim によって自動的に接続されます。 

回路を配線する
すべてのコンポーネントには、他のコンポーネントまたは計測器に配線す

るためのピンがあります。 カーソルをピンの上に配置するとクロスヘアに

変化し、Multisim で配線を開始できるようになります。 

ヒント ワークスペースに配置した回路を配線する、または Getting Startedフォル

ダ（samplesフォルダ内）から Getting Started 1.ms10を使用することも

できます。 
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以下の手順に従い、回路を配線します。 

1. コンポーネントのピンをクリックして接続を開始し（ポイントがクロ

スヘアに変化します）、マウスを移動させます。 カーソルの動きに合

わせてワイヤが表示されます。 

2. 2 番目のコンポーネントのピンをクリックして接続を完了します。 
Multisim は、以下に示されるように、適切な構成に簡単にするス

ナップするワイヤを自動的に配置します。 この機能により、大規模な

回路を配線する場合に大幅に時間を節約することができます。
 

3. 配線中にマウスをクリックして、ワイヤの位置を指定することもでき

ます。 マウスをクリックするたびに、ワイヤがそのポイントに固定さ

れます。 
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4. 下の図に示されるように「Digital Counter」領域のコンポーネント

を配線します。 
 

ヒント U3 や R4 などのマルチピンデバイスをバスで接続するには、バスベクトル接続

を使用します。詳細については、『Multisim User Manual』を参照してくださ

い。 

ヒント 仮想配線 —「Counter Control」領域と「Digital Counter」領域の間の接続で

は、仮想接続を使用して配線を簡潔にすることができます。 同じネット名の 2 つ

の回路は、仮想接続することができます。 
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5. 下の図のように配線を完了します。
 

シミュレーション

回路を Multisim でシミュレートすると、設計フローの早い段階でエラー

を検出することができ、時間とコストを削減することができます。 

仮想計測器
このセクションでは、仮想オシロスコープを持つ回路をシミュレートしま

す。 

ヒント Getting Startedフォルダ（samplesフォルダ内）から Getting 

Started 2.ms10を使用することもできます。 

1. J1、J2、R2 は対話式コンポーネントです。 
各コンポーネントをダブルクリックして、J1、J2、および R2 の対話

キーを設定します。 J1、J2、R2 のキーフィールドにそれぞれ「E」、
「L」、「A」と入力します。 
「E」を押してカウンタを有効にするか、カーソルを「J1」の上に移

動すると表示される拡張スイッチアームをクリックします。 



第 2 章 Multisim チュートリアル

© National Instruments Corporation 2-13 NI Circuit Design Suite スタートアップガイド

2. シミュレート→計測器→オシロスコープを選択して、ワークスペース

にオシロスコープを配置します。 手順 4 で示されるように計測器を配

線します。 

ヒント オシロスコープのトレースを簡単に区別するには、スコープの「B」入力に配線

されているワイヤを右クリックし、ポップアップメニューからセグメントカ

ラーを選択します。 たとえば青など、「A」入力に接続されているワイヤと異な

る色を選択します。 （シミュレーションは、ワイヤの色を変更、または他の編集

機能を実行する場合に実行することはできません）。

3. スコープのアイコンをダブルクリックして計測器の前面を表示しま

す。 シミュレート→実行を選択します。 演算増幅器の出力がスコープ

に表示されます。 

4. タイムベースを 2mS/Div に変更して、チャンネル A のスケールを

500mV/Div に設定します。以下がスコープに表示されます。
 

回路のシミュレーション実行中に、7 セグメントのカウンタの数値が

増加し、各カウントサイクルの終りに LED が点滅します。 

5. シミュレーション実行中にキーボードで「E」キーを押して、カウン

タを有効 / 無効に切り替えます。 有効はアクティブ LOW です。 
「L」キーを押してカウンタにゼロをロードします。 ロードはアクティ

ブ LOW です。 
「Shift-A」キーを押して、ポテンショメータの設定を変更した結果を

確認します。 「A」キーを押して繰り返します。 
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ヒント 上記のキーを押す代わりに、マウスで回路図上の対話式コンポーネントを直接

操作することができます。 

解析
このセクションでは、AC 解析を用いて増幅器の周波数応答を検証しま

す。 

演算増幅器の出力で AC 解析を実行するには、以下の手順に従います。 

1. 演算増幅器のピン 6 に接続されているワイヤの上でダブルクリック

し、ネットダイアログボックスで回路名を「analog_out」に変更し

ます。 

2. シミュレート→解析→ AC 解析を選択して、出力タブをクリックし

ます。
 

3. 左の列の V(analog_out)をハイライトし、追加をクリックします。 
V(analog_out)が右の列に移動します。 
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4. シミュレートをクリックします。 解析結果がグラファに表示されま

す。
 

グラファ
グラファは、グラフや表を表示、調整、保存、エクスポートするための多

目的表示ツールです。 Multisim によるすべての解析結果のグラフや表、ま

たその他の計測器のデータのグラフが表示するために使用します（例 : オ
シロスコープの結果）。 

グラファ上のシミュレーションの結果を表示するには、以下の手順に従い

ます。 

1. 上記の説明に従って、シミュレーションを実行します。 

2. 表示→グラファを選択します。
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後処理
後処理では、回路で実行された解析の出力を編集し、結果をグラフまたは

チャートにプロットすることができます。 解析結果で実行できる数学演算

の種類は、算術演算、三角関数、指数関数、対数関数、複素演算、ベクト

ル演算、および論理演算です。 

レポート

Multisim は、材料表（BOM）、コンポーネント詳細レポート、ネットリ

ストレポート、回路図統計、スペアゲート、および相互参照などの多くの

レポートを生成します。 このセクションでは、チュートリアルの回路の例

として BOM を使用します。 

材料表
材料表は、設計で使用されたコンポーネントの一覧を示すことにより、回

路基板の製造に必要なコンポーネントの概要を提供します。 提供される情

報には、以下が含まれます。 

• 必要な各コンポーネントの数量

• 詳細 : 部品のタイプ（例 : 抵抗器）および値（例 : 5.1 kΩ) を含む。 
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• 各コンポーネントの参照番号。 

• 各コンポーネントのパッケージまたはフットプリント。 

回路の BOM（材料表）を作成するには、以下の手順に従います。 

1. レポートメニューをクリックして、表示されるメニューから材料表を
選択します。 

以下のようなレポートが表示されます。
 

材料表を印刷するには、印刷ボタンをクリックします。 標準の Windows
の印刷画面が表示され、プリンタ、コピー数などを選択できます。 

材料表をファイルに保存するには、保存ボタンをクリックします。 標準的
な Windows のファイル保存ダイアログボックスが表示され、パスと
ファイル名を指定することができます。 

材料表は主に調達および製造の支援が目的であるため、実際の部品のみが
含まれており、ソースまたは仮想コンポーネントなどの実物ではない、購
入不可能な部品は除外されます。 フットプリントに割り当てられていない
コンポーネントは、材料表に表示されていません。 

回路の実コンポーネントではないコンポーネントの一覧を表示するには、
仮想ボタンをクリックします。 別のウィンドウにこれらのコンポーネント
のみを表示します。 

この詳細情報および他のレポートについては、『Multisim User Manual』
を参照してください。 
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3
Ultiboard チュートリアル

この章のチュートリアルでは、Multisim チュートリアルの章で説明する

回路の部品およびトレースを配置する方法を説明します。 

ヒント Multisim から Ultiboard に設計をエクスポートする方法については、『Multisim 
User Manual』、『Ultiboard User Manual』、またはヘルプファイルを参照して

ください。 

Ultiboard インタフェースの概要

Ultiboard は、ナショナルインスツルメンツ Circuit Design Suite の

PCB レイアウトアプリケーションで、EDA（Electronics Design 
Automation）ツールのパッケージソフトで、回路設計フローにおける主

なステップを支援します。 Ultiboard は、プリント回路基板のレイアウト

および経路設定、特定の基本的な機械的 CAD 操作の実行、そして製造の

準備に使用します。 また、Ultiboard は自動部品配置およびレイアウトを

提供します。 

Ultiboard のユーザインタフェースは、複数の要素から成り立ちます。 
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メニューバーにすべての関数のコマンドがあります。 

標準ツールバーには、保存、印刷、切り取り、および貼り付けなどのよく

実行する操作用のボタンが含まれています。 

より多くの部品およびトレースをボードに追加すると、使用するボードの

みを使用するものだけを選択するのが難しくなります。 選択ツールバーに

は、選択の制御に使用するボタンが含まれています。 

1 メニューバー

2 標準ツールバー

3 選択ツールバー

4 描画設定ツールバー

5 表示ツールバー

6 メインツールバー

7 自動経路設定ツールバー

8 ステータスバー

9 ワークスペース

10 スプレッドシートビュー

11 設計ツールボックス

12 3D プレビュー

13 全体図ビュー
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描画設定ツールバーでは、描画するラインまたはオブジェクトの厚さおよ

び測定単位、そしてレイヤーを選択することができます。 このツールバー

にはまた、ラインの外観、そしてレイヤーに描画する形状を制御する機能

のボタンが含まれています。 

表示ツールバーには、画面の表示方法を変更するためのボタンがありま

す。

メインツールバーには、よく使用するボード設計機能のボタンがありま

す。

自動経路設定ツールバーには、自動経路設定および部品配置機能がありま

す。 

ステータスバーは、役立つ重要情報を表示します。 

ワークスペースでは、設計を行います。 

スプレッドシートビューでは、フットプリント、形状、基準番号、属性、

および設計制約など、部品の詳細を含むパラメータの迅速で詳細な表示お

よび編集が可能です。 

設計ツールボックスでは、設計の要素を表示、非表示、または淡色表示す

ることができます。

3D プレビューでは、ボードの 3 次元プレビューを表示することができま

す。 

全体図ビューは設計の全体図を表示し、ワークスペースでの操作を簡単に

します。 

チュートリアルを開く

チュートリアルファイルを開くには、以下の手順に従います。 

1. スタート→すべてのプログラム→ National Instruments → Circuit 
Design Suite 10.1 → Ultiboard 10.1 を選択して、Ultiboard を起動

します。

2. ファイル→開くを選択します。 

3. ファイル→サンプルを開くを選択し、Getting Startedフォルダを

ダブルクリックして開きます。 

4. Getting Started.ewprjを選択して、開くをクリックします。 プロ

ジェクトファイルが Ultiboard にロードされます。 
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5. 設計（例 : GS1）を選択するには、そのタブをクリックするか、設計

ツールボックスのプロジェクトタブ内の名前をクリックします。 

ボードアウトラインを作成する

ボードアウトラインは、以下のいずれかの手順で作成できます。

• 描画ツールを使用してボードアウトラインを描画 

• DXF ファイルをインポート

• ボードウィザードを使用

以下の手順に従い、ボードウィザードを使用します。

1. レイヤータブのボードアウトラインをダブルクリックします。

2. GS1設計で既存のボードアウトラインをクリックして、「削除」を押

します。 

3. ツール→ボードウィザードを選択します。 
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4. レイヤーテクノロジを変更オプションを有効にして、他のオプション

が利用できるようにします。 

5. 両面ボード（レイヤーペア）とシングルレイヤースタックアップで構

築されたマルチレイヤーを選択して、次へをクリックします。 
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6. 次のダイアログボックスで、ボードのラミネート設定を定義します。 
（このチュートリアルでは設定は変更しません）。

 

7. 次へをクリックします。 
ボードの形状ダイアログボックスでは、以下に注意してください。

• 基準ポイントがアライメントで左下に設定されている。

• 長方形オプションが選択されている。

• 幅を 3000、高さを 2000 に設定されている（この設計で最適な

部品のサイズ）。

• 間隔が 5.00000 に設定されている。 他の要素から離されるボード

の端からの距離です。

8. 終了をクリックします。 ボードアウトラインは設計に配置されます。

メモ ボードウィザードの詳細については、『Ultiboard User Manual』を参照してく

ださい。 
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以下の手順に従い、ボードアウトラインを移動します。

1. レイヤータブのボードアウトラインをダブルクリックします。

2. ワークスペースのボードラインをクリックして、ボードを部品の行の

すぐ下にドラッグします。

以下の手順に従い、基準ポイントを変更します。

1. 設計→基準ポイントを設定を選択します。 カーソルの動きに合わせて

基準ポイントが表示されます。

2. カーソルをボードラインの左下へ移動し、クリックして配置します。
 

部品を配置する

GS1設計ファイルにさまざまな方法で部品を配置することができます。 

• ボードアウトラインの外側から 1 つまたは複数の部品を選択して所

定の位置へドラックする

• スプレッドシート表示の部品タブを使用して部品を検索して配置する

• データベースから部品を選択する

ヒント 配置→部品配置を取り消しコマンドを使用して、ロックされていないすべての

部品を PCB から素早く削除して、異なる配置方法を試すことができます。 
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ボードアウトラインの外側から部品をドラッグする
デフォルトでは、Multisim または他の回路図キャプチャプログラムから

ネットリストを開くと、コンポーネントはボードアウトラインの外側に配

置されています。 始める前に、設計ツールボックスで銅（上）レイヤーを

ダブルクリックして、アクティブレイヤーにします。 

以下の手順に従い、U1 をボードアウトラインの外側にドラッグします。 

1. ボードアウトラインの外側の部品のコレクションの中から U1 を検索

します。 U1 が見えるまでズームイン（「F8」を押す）とより簡単に検

索できます。 

ヒント また、編集→検索コマンドで部品を検索することもできます。 このコマンドは他

のアプリケーションの検索機能のような役割を果たし、名前、番号、形状、値、

またはすべての変数から検索することができます。 詳細については、『Ultiboard 
User Manual』を参照してください。 

2. U1（7 セグメント表示）をクリックして、下記の図に表示される位

置にドラッグします。

メモ 「フォースベクトル」および「ラッツネスト」の詳細については、『Ultiboard 
User Manual』を参照してください。 
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U1 は選択されたままです。 これは、アプリケーションにおける

Ultiboard の重要な点であり、すべての操作を明示的に終了する必要

があります。 この場合、他の場所をクリックして部品を選択解除しま

す。 また、右クリックすると現在の操作が終了します。 

3. スプレッドシート表示の部品タブへ移動し、U1 が表示されるまでス

クロールします。 部品の隣の緑のライトがやや明るくなっていること

に注意してください。これは、部品が配置されたことを示していま

す。 

部品タブから部品をドラッグする
以下の手順に従い、部品を部品タブからドラッグします。 

1. 部品タブで J3 が表示されるまでスクロールします。
 

1 フォースベクトル 2 ラッツネスト
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2. J3 をクリックして、部品タブからワークスペースにドラッグします。 
ポインタの動きに合わせて J3 が表示されます。 

3. J3 をボードの左側のエッジの、やや中央にドロップします。 上記の

ように、部品タブの J3 の緑色のライトはやや明るくなり、部品が配

置されたことを示しています。

より早く部品を配置するには、部品タブで身配置の部品（緑のライトは淡

色表示）を選択して、未配置部品の配置を開始ボタンをクリックします。 
Ultiboard は、各部品を選択してマウスのポインタに貼り付けて配置でき

るようにしてから、リストから次の部品を選択する方法で、部品タブの部

品のリストを体系的に確認します。 

チュートリアルの部品を配置する
任意の方法、また任意の方法の組み合わせで、以下の図のようなレイアウ

トを作成してください。 すでにこのように設計されている、プロジェクト

にある次の設計ファイル、GS2を使用することもできます。 

設計は以下のようになります。 
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データベースから部品を配置する
設計ファイルにインポートされた部品を配置する以外に、データベースか

ら直接部品を配置することができます。 以下では、この方法を使用して取

り付け穴を配置します。 

以下の手順に従い、データベースから部品を配置します。

1. 配置→データベースからを選択します。 データベースから部品を取得

ダイアログボックスが表示されます。 

2. データベースパネルで、スルーホールテクノロジカテゴリを展開し、

穴カテゴリを参照します。 利用可能な部品パネルに部品が表示されま

す。 

3. 利用可能な部品パネルで、Hole35 を選択します。 プレビューパネル

に部品が表示されます。 
 

4. OK をクリックします。 データベースから部品を取得ダイアログボッ

クスが消え、RefDes および Value を入力するダイアログボックス

が表示されます。 

5. 穴の参照番号（H1）および値（HOLE）を入力して、OK をクリック

します。 

6. ボード上にポインタを移動します。 部品はポインタの動きに合わせて

表示されます。
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7. 左上隅の位置に穴を移動したら、クリックしてボードにドロップしま

す。 

8. 参照番号が自動的に H2 に増分された部品の参照番号を入力ダイアロ

グボックスが再び表示されます。 

9. 値（HOLE）を入力して OK をクリックし、次の取り付け穴を右上隅

に配置し、同じ作業を繰り返して H3 を右下隅に配置し、H4 を左下

隅に配置します。 

10. キャンセルをクリックして停止し、キャンセルをもう一度クリックし

てデータベースから部品を取得ダイアログボックスを閉じます。 
 

部品を移動する
配置する方法と同じ方法で部品を移動することができます。 クリックする

だけで、ボード上にすでにある部品を選択できます。 選択した部品の移動

先の X/Y 座標を指定するには、数値キーパッドの「*」キーを押します。 
また、部品タブで配置した部品（隣に緑色のライトで示される）を選択

し、新しい場所にドラッグします。 
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ヒント 部品のラベルは、形状とは別の要素です。 ボードで部品を選択する場合は、ラベ

ルだけでなく部品全体を選択し、 選択フィルタの使用を試みてください。 詳細に

ついては、『Ultiboard User Manual』を参照してください。 

ヒント 部品を選択するには、キーボードの矢印キーを押して、ボード上で移動するこ

ともできます。 

また、部品のグループを選択して、同時に移動することもできます。 これ

を行うには、以下のうちの 1 つを実行してください。 

• 「Shift」キーを押したまま、複数の部品をクリックする

• いくつかの部品の周りにボックスをドラッグする 

選択されたすべての部品は、カーソルをドラッグすると移動します。

ヒント これらは一時的なグループで、他の部品を選択するとグループ接続は解除され

ます。 グループが削除するまで残るようにするには、グループエディタを使用し

ます。 詳細については、『Ultiboard User Manual』を参照してください。 

部品を移動するもう 1 つの方法は、編集→整列コマンドを使用して、選

択した部品の端を揃えるか、部品間のスペースを相対的にします。 

編集→整列コマンドを使用して、配置した取り付け穴を揃えます。 

1. H1 を選択して、「Shift」キーを押したまま H2 を選択します。 

2. 編集→整列→上端揃えを選択します。 H2 が H1 に沿って配置されて

いなかった場合は、移動します。 

3. ボード上の空白をクリックして、H2 と H3 を選択します。 

4. 編集→整列→右端揃えを選択します。 

5. H3 と H4、H1 と H4 の下端、H1 と H4 の左端が揃うまでこの作業を

続けます。 
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トレースを配置する

トレースの配置には以下のオプションがあります。 

• 手動トレース

• 誘導型トレース

• 接続マシントレース

手動トレースは、設定したパス通りに、コンポーネントまたはトレースを

介する場合も指定した通りに配置されます。 誘導型トレースは、マウス操

作で選択したピン間に有効なトレースを自動的に描画します。ピンからピ

ンに移動して、有効なトレースを残すこともできます。 接続マシントレー

スは、最も効率の良い経路で 2 つのピンを自動的に接合します。オプ

ションで経路を変更することもできます。

トレースを配置すると、クリックして最適な位置に配置する前に、バック

アップすることによってセグメントを削除することができます。 手動ト

レースを配置中にクリック、もしくは誘導型トレースまたは接続マシント

レースで方向を変更するたびに、トレースの個別のセグメントが作成され

ます。 トレースで操作をする場合、最適なセグメントを選択するか、希望

する場合はトレース全体を選択します。

手動トレースを配置する
今まで作業してきた設計を継続して使用するか、GS3を使用します。 開始

する前に銅（上）レイヤー上にいることを確認してください。銅（上）が

設計ツールボックスのレイヤータブで赤でハイライトされます。 

ヒント 必要な場合は、「F7」を押して設計全体を表示します。 

以下の手順に従い、トレースを手動で配置します。 

1. 配置→ラインを選択します。 

ヒント ラインコマンドは任意のレイヤー上にラインを作成するために使用します。 結果

は、選択するレイヤーによって異なります。 たとえば、選択したレイヤーがシル

クスクリーンの場合、PCB のシルクスクリーンレイヤー上にラインを作成しま

す。 選択したレイヤーが銅の場合、「ライン」が実際のトレースになります。
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2. ボードの左側にある J3 を検索します。 下記に示される開始ピンを検

索します。
 

ヒント 部品を検索できない場合は、部品タブの検索機能を使用します。 部品タブで部品

を選択して、部品を検索して選択ボタンをクリックします。 部品は、ワークス

ペースに表示されます。 必要な場合は、「F8」を使用してさらにズームインしま

す。 

3. 上記のステップで指定されたピンをクリックします。 Ultiboard は、

X をクリックしたピンと同じネットの一部であるすべてのピンをハイ

ライトします。（ハイライトに使用される色は、環境設定ダイアログ

ボックスのカラータブで変更できます）。 この方法で、回路図の接続

に一致する方法でピンを接続する場所を理解します。 

1 部品 J3 2 開始ピン
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4. カーソルを動かします。 緑のライン（トレース）は選択されたピンに

固定されます。 クリックするたびに、以下の図（2）のようにトレー

スセグメントが固定されます。 

5. 配線先のピンをクリックします。 
 

6. 右クリックして、トレースの配置を終了します。 

1  同じネットのピン  

1 トレース

2 クリックしてトレースを固定
3 配線先のピン
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誘導型トレースを配置する
以下の手順に従い、誘導型トレースを配置します。 

1. 配置→誘導型を選択します。 

2. J3 の上ピンをクリックします。 

3. U4 の右列にある 2 番目のピンをクリックします。 

4. Ultiboard が自動的に接続を描画します。 

ヒント ピンをクリックする必要はありません。ラッツネストラインをクリックして開

始することもできます。 

接続マシントレースを配置する
以下の手順に従い、接続マシントレースを配置します。

1. 配置→接続マシンを選択します。 

2. 下記に示されるラッツネストのセグメントをクリックします。
 

3. カーソルを動かします。Ultiboard は、障害物の周りに経路設計され

るさまざまなトレース配置オプションを推奨します。 

1 ラッツネストをクリック  
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4. 設定したい経路がある場合、クリックしてトレースを修正します。 
ラッツネストまたは配線先のピンをクリックする必要はありません。 

 

5. 右クリックしてトレース配置を終了します。 

自動部品配置

この章で説明された部品の配置以外に、Ultiboard の上級自動部品配置機

能を使用することができます。 

ヒント 部品を自動配置する前に、自動配置プロセス中に移動しない部品すべてをあら

かじめ配置してロックします。 （GS5の取り付け穴および U1、J1、J2、J3、
LED1 はあらかじめ配置されロックされています）。 部品をロックする方法の詳細

については、『Ultiboard User Manual』を参照してください。 

1 ピンの間に表示されるトレースセグメント  
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Getting Started.ewprjで部品を自動配置するには、以下の手順に従

います。 

1. Ultiboard で GS5設計を開きます。 

2. 自動経路設定→自動配置を開始を選択します。 部品が回路基板に配置

されます。
 

トレースを自動経路設定する

この章ですでに説明した方法、または以下で説明する自動的に経路決定す

る方法で、Ultiboard にトレースを配置することができます。 

Getting Started.ewprjでトレースを自動設定するには、以下の手順

に従います。 

1. Ultiboard で GS3設計を開きます。 

2. 自動経路設定→自動ルータを開始 / 再開を選択します。 ワークスペー

スは自動経路設定モードになり、トレースの自動経路設定が開始され

ます。 
自動経路設定が開始されると、トレースがボードに配置されます。 自
動経路設定が完了すると、自動経路設定モードが閉じ、ワークスペー

スに戻ります。

3. オプションで、自動経路設定→最適化を開始を選択して、トレースの

配置を最適化することができます。 
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自動ルータは、いつでも終了することができ、手動で変更できます。 自動

ルータを再開すると、変更を反映して継続します。 手動で配置したトレー

ス、および自動ルータによって移動しないトレースをロックしてくださ

い。 

ヒント 経路設定オプションダイアログボックスを使用して、自動配置および自動経路

設定オプションを修正します。 詳細については、『Ultiboard User Manual』を

参照してください。 

製造 / アセンブリの準備をする

Ultiboard は、多くの異なる出力フォーマットが生成可能で、生産および

製造のニーズに対応します。 このセクションでは、生産およびドキュメン

ト化のために、ボード出力で実行する機能について説明します。 

ボードをクリーンアップする
ボードを製造する前に、開いているトーレス終端（設計上、終端接続を持

たないトレースセグメント）、ボードに残っている未使用のビアを削除す

る必要があります。 

開いているトレース終端を削除するには、GS4設計が開いていることを確

認して、編集→銅を削除→開いたトーレス終端を選択します。 この方法で

は、設計中のすべての開いているトレースが削除されます。 
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未使用のビアを削除するには、設計が開いていることを確認し、設計→未

使用ビアをクリーンを選択して、トレースセグメントまたは接続されてい

る銅領域を持たないすべてのビアを削除します。 

コメントを追加する
コメントは、設計の変更順位を表示することができ、チームメンバー間の

共同作業を容易にしたり、背景情報を設計に追加することができます。 

コメントをワークスペースや部品に固定することができます。 コメントの

付いた部品が移動されると、コメントも一緒に移動します。 

詳細については、『Ultiboard User Manual』を参照してください。 

ファイルをエクスポートする
ファイルのエクスポートは、Ultiboard からボードの製造元が理解できる

フォーマットで出力を生成することを示します。 エクスポートされたファ

イルには、完成ボードの製造方法の詳細情報が含まれています。 エクス

ポートできるファイルには、Gerber RS-274X および RS-274D ファイル

が含まれます。 

詳細については、『Ultiboard User Manual』を参照してください。 
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設計を 3D で表示する

Ultiboard では、設計中にいつでも 3 次元でボードを表示できます。 詳細

については、『Ultiboard User Manual』を参照してください。 
 

ヒント 内部ビューを使用して、マルチレイヤー PCB のレイヤー間を表示することがで

きます。 詳細については、『Ultiboard User Manual』を参照してください。 
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4
Multisim MCU チュートリアル

この章のチュートリアルでは、マイクロコントローラが含まれる回路シ

ミュレーションおよびデバッグのプロセスを説明します。 

概要

このチュートリアルで使用されるファイルは、NI Circuit Design Suite ソ

フトウェアと一緒に ...¥samples¥Getting Startedにインストールさ

れます。 

このチュートリアルでは、Getting Started MCU.ms10を使用し、

LCDWorkspaceのフォルダへのアクセスが必要です。 

液晶グラフィックディスプレイ（LCD）回路の例は、Toshiba T6963C コ

ントローラおよび外部表示 RAM の組み合わせに基づく、Multisim にお

けるグラフィック LCD を制御するための PIC マイクロコントローラの使

用について説明します。 LCD を制御する際、マイクロコントローラは

LCD のデータおよび制御ラインを介して LCD に信号を送信します。 マイ

クロコントローラ用に書かれたソフトウェアプログラムが、LCD にコマ

ンドおよびデータを送信するためのピン上のラインの設定が、HIGH また

は LOW に設定される論理を決定します。 
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チュートリアルについて

LCD U2 のデータラインは、マイクロコントローラ U1 のピン RB0 ～ RB7
に接続されています。 LCD の制御ラインは、マイクロコントローラの

RA0 ～ RA2 に接続されます。 MCU U1 は、これらのワイヤを通じて

LCD U2 と通信します。 データが並行して U2 に送信され、制御ラインの

信号が送信されるデータのタイミングとタイプを決定します（例 : アドレ

スまたはデータ）。 

LCD は、テキストモード、グラフィックモード、およびテキスト / グラ

フィックの混合モードの、3 モードで操作することができます。 この例

は、テキスト / グラフィック混合モードでの LCD の制御です。 MCU が実

行するソフトウェアは、LCDWorkspaceという名前で設計ツールボック

スを表示する MCU ワークスペースに含まれています。 ワークスペースに
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は、シングルソースコードファイル main.asmから構成される 1 つのプ

ロジェクト project1が含まれています。

以下の手順に従って、ファイルを表示します。

1. 設計ツールボックスで main.asmをダブルクリックします。 アセンブ

リプログラムを表示する回路図キャプチャワークスペースに

main.asmという名前のタブが表示されます。
 

ライン番号を表示するには、MCU →ライン番号を表示を選択します。 

以下の手順に従って、この回路を実行します。 

1. シミュレート→実行を選択します。 あからじめプログラムをプログラ

ムを作成していない場合は、ダイアログボックスに構成が古いことが

示され、作成するかどうかの確認メッセージが表示されます。 はいを

クリックします。 構築の結果がスプレッドシート表示の結果タブに表

示されます。 エラーまたは警告がない場合は、プログラムは正常に作

成されます。 （サンプルプログラムにはエラーは含まれていません。） 
プログラムはテキストモードで「Graphical LCD T6963C for 
Multisim」の文字を表示し、LCD がグラフィックモードに切り替わ

り、反転した「V」がドット単位でテキスト上に描画されます。 
ラインが描画されると、テキストは右、そして左ににスクロールされ

ます。 これは、LCD のテキストバッファの開始アドレスを移動するこ

とによって実行できます。 また、LCD にはバッファが 2 つあり、1 つ

はグラフィックの格納、もう 1 つはテキストの格納用であることも

示しています。 テキスト点滅および文字消去などの LCD のその他の

機能も示されています。 

LCD プログラムは、これらの各作用を継続して繰り返します。 

シミュレーションを停止するには、シミュレート→停止を選択します。 
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アセンブリプログラムを理解する

定数およびデータ
プログラムをより簡単に理解するために、LCD コマンドおよびアドレス

を格納する一時バッファを表示し、MCU 内のデータはプログラムの開始

時に定数であらかじめ定義されています。
 

LCD に表示されるテキストは一部のマイクロコントローラのデータ表に

格納されますが、プログラムメモリスペースでデータ値を直接処理するこ

とを可能にする PIC アセンブリ命令はありません。 代わりに、初期値を

W レジスタにロードして、指標に基づいた文字列に値を返すルーチンを

書き込むことができます。 RETLW命令は定数値を W レジスタにロードし、

1 回の命令で RETURNを実行します。 

TXPRTルーチンは、LCD に表示するテキストデータを取得します。 LCD
の文字モードは、T6963C コントローラのリファレンスマニュアルに定義

されています（例 : 0x27は “G”、0x52は “r” のコードなど）。 
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初期化
初期コードは、以下の引用に示される通り、STARTラベルから開始しま

す。 マイクロコントローラのピンは出力ピンとして設定され、値はリセッ

トされます。 LCD コンポーネントは、マイクロコントローラによって初

期化され、グラフィック / テキストモードに設定されます。 LCD コン

ポーネントの内部のグラフィックとテキストバッファのホームアドレス

は、LCD がディスプレイ上でバッファデータの表示を開始する場所を指

定する 0x0000および 0x2941にそれぞれ設定されます。 最後に、制御信

号が LCD 上の適切な読み取り / 書き込む操作用に設定されます。 
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テキストおよびグラフィックを描画する
残りのプログラムは、LCD に MCU ピン RA0 ～ RA2 の制御ラインを介

してコマンド、そしてデータラインを介してデータを送信します。 
 

たとえば、プログラム内のメインループからの上記の引用は、LCD にテ

キストモードで表示される TXPRTサブルーチンで定義された文字を送信

します。 

以下は LCD を自動書き込みモードに設定します。 
MOVLW CMD_AWRON

MOVWF CMD_BUFFER

CALL CMD
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この時点でプログラムはカウントを開始し、ループ LOOP_READ_DATA2

を 35 回実行します。 このループは、TXPRTを呼び出し、テキストデータ

を取得して W レジスタをロードします。 そして、LCD のデータラインに

送信される値ををポート B の W レジスタに値を書き込む SEND_DATAを

呼び出すサブルーチン ADTを呼び出します。 データが送信されると、マイ

クロコントローラのポート A 上の適切な値が LCD の制御ピンに送信さ

れ、データの読み取り準備ができたことを知らせます。 サブルーチンはす

べて命令の終了時の呼び出し直後に返され、35 文字がすべて転送される

まで同じ動作が繰り返されます。 引用の最後の 3 つの命令が、ループを出

た後に LCD の自動書き込みモードを OFF にします。 
MOVL WCMD_AWROFF

MOVWF CMD_BUFFER

CALL CMD

以下の命令は、グラフィックモードで水平および直線ラインを描画しま

す。

;6 draw wave once

MOVF ADDR_L, 0

BTFSC STATUS, Z

CALL DRAW_WAVE

MCU デバッグ機能を使用する

このセクションでは、段階的に Multisim MCU モジュールのデバッグ機

能について説明します。 以下の説明どおりに作業を行わない場合、これら

の説明が該当しなくなります。 ブレークポイントとシングルステップ機能

を理解したら、上級 MCU デバッグを取得します。 

デバッグ表示の概要
C またはアセンブリのいずれかでマイクロコントローラのプログラムを

書くには、ソースコードビューで編集可能なソースコードファイル

（.asm、.inc、.c、.h）を MCU ワークスペースの一部として作成しま

す。 

ソースコードビューにアクセスするには、以下の手順に従います。 

1. 設計ツールボックスの MCU ワークスペース階層に表示されるファイ

ル項目（例 : main.asm）をダブルクリックします。 



第 4 章 Multisim MCU チュートリアル

NI Circuit Design Suite スタートアップガイド 4-8 ni.com/jp

シミュレーション中に表示される追加デバッグ情報は、MCU 内で起こっ

ている状況を理解する上で役立ちます。 たとえば、MCU が実行する各命

令の実際の操作コードも表示するアセンブリ命令レベル、そしてハイレベ

ルソースで発生するイベントを切り替えることができます。 

ソースコードビューは、この追加情報すべてを表示することができませ

ん。 代わりに、回路設計の MCU コンポーネントはデバッグ情報を表示す

るためのデバッグ表示を各自持っています。 

デバッグ表示にアクセスするには、以下の手順に従います。

1. MCU → MCU PIC 16F84A U1 →構築を選択します。 

メモ デバッグ表示はコードの構築が完了すると利用でき、上記の手順は一回のみ実

行します。 

2. MCU → MCU PIC 16F84A U1 →デバック表示を選択します。

または

設計ツールボックスの MCU ワークスペースにある項目上の右クリッ

クコンテクストメニューを使用します。 
 

デバッグ (<MCU の参照番号 >)、この場合デバッグ (U1) という回路

図キャプチャワークスペースで別のタブが開きます。 
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デバッグ表示の上部にあるドロップダウンリストを使用して、Multisim
が内部生成する逆アセンブリ命令、もしくはアセンブラまたはコンパイラ

が生成するリスティングファイルを選択します。リスティングファイルの

フォーマットはコード構築に使用したツールによって異なります。 

LCD の例では、コードはアセンブリに書き込まれ、Microchip アセンブ

リツールによって構築されます。 Microchip アセンブラは、各アセンブ

リ命令のすべての操作コードを含むリスティングファイル（.lst）を生

成します。 デバッグリスティングビューは、このリスティングファイルか

らの情報を表示します。 Multisim は、内部逆アセンブラを使用して逆アセ

ンブリフォーマットを生成し、操作コード命令をアセンブリ命令に逆アセ

ンブルします。 

デバッグリスティングに必要な情報がすべて含まれているため、この

フォーマットはこの例では必要ありません。 MCU プロジェクトにマシン

コード（.hex）ファイルのみがロードされる場合、逆アセンブリ表示に

は逆アセンブリ操作コード命令が表示され、MCU で何が起こっているか

を見ることができます。 このような種類の MCU プロジェクトのリスティ

ングファイルがないため、逆アセンブリ表示が役に立ちます。 

1  ドロップダウンリスト  
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ブレークポイントを追加する
シミュレーションが停止した場合、そしてシミュレーション中に、ソース

コードビューにブレークポイントを追加することができます。 2 通りの方

法でマイクロコントローラプロジェクトにブレークポイントを追加するこ

とができます。 

1 つ目は、ソースコードビューで追加する方法です。 この例では、回路図

キャプチャワークスペースの main.asmタブのみが利用可能なソース

コードビューです。 

メモ MCU 設計に複数のファイルが含まれている場合は、各ソースコードファイルに

対してソースコードビューがあります。 

また、デバッグ表示ウィンドウでブレークポイントを設定することもでき

ます。 逆アセンブリ表示またはデバッグリスティングビューでブレークポ

イントを設定することができますが、この例ではデバッグリスティング

ビューのみを使用します。
 

ソースコードビューでブレークポイントを追加するには、以下の手順に従

います。 

1. U1 のデバッグ表示を開きます。 

2. 設計ツールボックスで main.asmをダブルクリックします。 

3. STARTラベルのすぐ下にあるライン BCF STATUS, RP0までスクロー

ルします。 

1  灰色の列  
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4. ライン BCF STATUS, RP0の隣の main.asmウィンドウの左側にある

1 番目の（灰色）列をダブルクリックします。 その場所でブレークポ

イントがラインに設定されたことを示す赤い丸が表示されます。 

5. シミュレート→実行を選択します。 シミュレーションは、設定したブ

レークポイントで自動的に一時停止します。 デバッグ表示は、MCU
プログラムの実行の一時停止を示す黄色の矢印の焦点に自動的に移動

します。 

以下の手順に従って、ブレークポイントを削除します。 

1. デバッグ表示または main.asmソースコードビューでブレークポイ

ントをダブルクリックします。 
または

MCU →すべてのブレークポイントを削除を選択して、すべてのブ

レークポイントを削除します。 

メモ デバッグ表示で、ソースコードビューと同じ方法でブレークポイントを追加ま

たは削除できます。 

切断してステップ
1. MCU →すべてのブレークポイントを削除を選択して、すべてのブ

レークポイントを削除します。 

2. 回路設計表示（Getting Started MCU タブ）でシミュレート→実行

を選択します。 「“Graphical LCD T6963CC for Multisim”」という

文字が LCD コンポーネントに表示され始めます。 

3. シミュレート→一時停止を選択します。 

4. U1 のデバッグ表示へ移動し、一番左側の列の黄色の矢印で示される、

MCU が実行を停止した場所にあるデバッグリスティングビューの

コードラインに注目します。 
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5. MCU → MCU PIC16F84A U1 →メモリ表示を選択して、マイクロコ

ントローラ U1 の内部のメモリの現在の状態を表示します。 IROM セ

クションのプログラムカウンタ PCの値が、黄色の矢印が示すライン

のアドレス値よりも 1 大きいことに注意します。 上記の図の例では、

デバッグ表示のアドレスは 192 で、メモリ表示の PC 値は 193 です。 

メモ シミュレーションを一時停止したときに MCU が現在のコマンドを完了してい

な場合は、プログラムカウンタ値はアドレス値と同じです。 

メモリ表示の他のセクションで、マイクロコントローラのメモリの他

の部品内の値を表示することができます。 

6. シミュレーションツールバーの中に入るボタンをクリックします。 

7. 現在の命令が実行され、シミュレーションは次の命令で一時停止しま

す。

8. シミュレート→停止を選択します。 
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切断して外に出る
1. MOVWF PORTBの SEND_DATAサブルーチンにブレークポイントを配

置します。 

2. シミュレート→実行を選択します。 シミュレーションがブレークポイ

ントで一時停止されます。 

3. シミュレーションツールバーの外に出るボタンをクリックして、

SEND_DATAサブルーチンの外に出ます。 

4. シミュレーションは、SEND_DATAサブルーチン内で残りのすべての

命令を実行し、SEND_DATAサブルーチンへの呼び出し後の最初の命

令で一時停止します。 

切断して中に入る
1. MCU →すべてのブレークポイントを削除を選択します。 

2. 黄色の矢印のすぐ上で外に出た場所、SEND_DATAへの呼び出し時に

ブレークポイントを配置します。 

3. シミュレート→実行を選択します。 シミュレーションは配置したばか

りのブレークポイントで一時停止します。 

4. シミュレーションツールバーの中に入るボタンをクリックします。 シ
ミュレーションが SEND_DATAサブルーチン内で一時停止します。 

切断して飛び越える
1. シミュレート→実行を選択します。 シミュレーションは、サブルーチ

ン SEND_DATAへの呼び出し時に、上記で設定したブレークポイント

と同じポイントで一時停止します。 

2. シミュレーションツールバーの飛び越えるボタンをクリックします。 
SEND_DATAサブルーチン全体が実行され、現在の命令が実行されて

から、シミュレーションは CALL SEND_DATA命令の次の命令で一時

停止します。 

カーソルに実行
1. MCU →すべてのブレークポイントを削除を選択します。 

2. このサブルーチンが、再度 LCD にデータを送信するために呼び出さ

れることが確認されているので、SEND_DATAサブルーチンの内側の

ラインをクリックします。

3. シミュレーションツールバーのカーソルに実行ボタンをクリックしま

す。 シミュレーションは、SEND_DATAサブルーチン内でクリックし

た命令に MCU が到達するまで実行されます。 そして、一時停止し、

ラインの隣に黄色の矢印を配置します。 



© National Instruments Corporation A-1 NI Circuit Design Suite スタートアップガイド

A
技術サポートおよびプロフェッ
ショナルサービス

技術サポートおよびその他のサービスについては、NI のウェブサイト

（ni.com/jp）の下記のセクションを参照してください。

• サポート―技術サポート（ni.com/jp/support）には以下のリソー

スがあります。

– セルフヘルプリソース―質問に対する回答やソリューションが必
要な場合は、ナショナルインスツルメンツのウェブサイト
（ni.com/jp/support）でソフトウェアドライバとアップデー
ト、検索可能な技術サポートデータベース、製品マニュアル、
トラブルシューティングウィザード、種類豊富なサンプルプログ
ラム、チュートリアル、アプリケーションノート、計測器ドライ
バなどをご利用いただけます。 ユーザ登録されたお客様は、

NI ディスカッションフォーラム（ni.com/jp/dforum）にアク
セスすることもできます。 オンラインでのご質問には、ナショナ
ルインスツルメンツのアプリケーションエンジニアが必ず回答い
たします。

– 標準サポート・保守プログラム（SSP）―NI のアプリケーション
エンジニアによる電話または E メールでの個別サポート、サー
ビスリソースセンターからのオンデマンドトレーニングモジュー
ルのダウンロードが可能となるプログラムです。 このプログラム
には製品ご購入時にご加入いただき、その後 1 年ごとに契約更
新してサービスを継続することができます。 
その他の技術サポートオプションについては、ni.com/jp/
servicesをご覧いただくか、ni.com/contactからお問い合
わせください。 

• トレーニングと認定―自習形式のコースキットやインストラクタによ

る実践コースなどのトレーニングおよび認定プログラムについては、

ni.com/jp/trainingを 参照してください。

• システムインテグレーション―時間の制約がある場合や社内の技術リ

ソースが不足している場合、またはプロジェクトで簡単に解消しない

問題がある場合などは、ナショナルインスツルメンツのアライアンス

パートナーによるサービスをご利用いただけます。 詳しくは、NI 営業

所にお電話いただくか、ni.com/jp/allianceをご覧ください。

NI のウェブサイト（ni.com/jp）を検索しても問題が解決しない場合は、

NI の国内営業所または米国本社までお問い合わせください。 海外支社の電

話番号は、このマニュアルの冒頭に記載されています。 また、NI ウェブサ
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イトの Worldwide Offices セクション（ni.com/niglobal（英語））か

ら海外支社のウェブサイトにアクセスすることもできます。 各支社のサイ

トでは、お問い合わせ先、サポート電話番号、メールアドレス、現行のイ

ベント等に関する最新情報を提供しています。
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