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P2 Workflow Using Avid Xpress Pro HD
This paper will describe a typical workflow using Panasonic P2 media with Avid Xpress Pro HD.  You must have Avid Xpress 
5.1 or later updates. We will list minimum hardware and software requirements, acquisition techniques, archiving in the 
field, importing to Avid Express Pro, editing, output of product and final archiving.

Minimum computer Requirements
To run Avid Xpress Pro HD, here are the minimum Computer Requirements (as stated by Avid at www.avid.com).  Avid 
Xpress Pro HD will run on a PC or Mac.

Windows/PC System
Windows XP Professional with Service Pack 2
QuickTime 7.1 or later; Windows Media Player 10 (9.5 codecs)  
1 GB system memory minimum, 2 GB recommended for HD or high-stream count SD projects
One of the following processors: (minimum speed listed)
•	 Xeon 2.4 Ghz (single or dual core)
•	I ntel Core 2 Duo 2.13 Ghz
•	I ntel Core Duo 1.67 Ghz
•	 Pentium 4 1.8 Ghz
•	 Pentium M 1.8 Ghz (mobile)
•	 Pentium D  1.7 Ghz (mobile)
www.avid.com/products/xpresspro/specs.asp lists specific graphic cards that have been tested by Avid.

Mac System 
Mac OS X 10.4.6, 10.4.7, or 10.4.8 (Earlier versions of Mac OS X are not supported)
Mac OS X 10.4.8 requires Avid Xpress Pro version 5.6.3 or later 
PowerMac G5 and PowerBook models only.
System memory (same requirements for software-only, with Avid Mojo or with Avid Mojo SDI)
1 GB system minimum, 2 GB recommended for HD 
A graphics adapter supported by Apple – 128MB (or higher) memory on graphics card
Apple native FireWire, included with all qualified systems 
QuickTime 7.1 or later

System, software and recording format used for this paper:
Panasonic CF-51 Toughbook laptop computer:
•	I ntel Core Duo 1.67 GHz
•	 60 GB hard drive
•	DVD -CD-RW Drive
•	Q uick Time 7.1
•	 Microsoft Windows XP Version 2002
•	 Avid Express Pro HD 5.5

Acquisition in the field
Shooting with P2 Media opens up great flexibility in your workflow.  You’ll enjoy all the workflow and reliability benefits 
of solid-state acquistion, but like any production, the benefits are greater when you advance plan you’re archiving and 
distribution requirements.  You can acquire footage directly on P2 cards, or on a Firestore FS-100.  If you acquire on a P2 
card, you can edit directly from the card.  You can transfer the information on the cards to the P2 Store and you can then 
edit directly from the P2 Store.   Or you can transfer the information from the P2 card to a hard drive and edit from the hard 
drive.
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KEY POINT.  P2 Cards are temporary storage

Do not think of P2 media as a tape replacement.  It is only a temporary 
storage media for your camera master.  You will want to get your footage 
off of a P2 and onto some field archival system immediately, so that you 
can reuse your P2 cards.  This is one of the major advantages of P2 
cards, they are reusable!  With the correct workflow, you can produce 
almost any project with a minimum of just three P2 cards.  And remember 
you can instantly review any shot in the field and delete bad takes, 
freezing up space on the P2 card.

Alternate Workflow Options
If you are recording a long form production (concert, play, wedding, corporate talking head) that requires you to continually 
record for over a long continuous time, there are a couple of alternative workflows available to you. 

Record on a Firestore fs-100 Hard Drive

This portable hard drive connects directly to your camera and based on your recording 
format can capture record times of 100 minutes or more.  However, remember this is a 
camera capture and like the P2 cards, you should archive this material asap, to another 
hard drive or other media. 

Key Point.  Make sure you install FS-100 Version 3.0 Upgrade.   This upgrade 
provides DVCPROHD Quicktime support and Native 720p MXF support. Contact www.
focusinfo.com for details on this upgrade.

Record directly to a laptop  
This option will allow greater record times (based on the hard drive of your computer, or an external hard drive).  The 
downside is that you have to have a laptop in the field connected via Firewire to your camera.  Obviously this will not work in 
locations where there is a lot of camera movement, but for locked down long shots, this is an attractive option.  In addition, 
you can actually capture directly to your Avid Xpress Pro HD (so that you are instantly ready to edit in the field).  

Connect camera via firewire.
Open Avid Xpress Pro HD.
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Open Capture Tool.

 

Click on Tools > Capture.  If configured correctly you will see the camera output in your composer window.  If not configured 
correctly, click on the deck pull down menu and click on check decks.

Key Point.  Make sure that your camera is set to the same resolution and frame rate as your Avid 
Project.

Select Audio and Video Tracks.
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Click on capture button.

 
Creating clones of your data on an internal and/or external hard drive
You can also copy your data directly from a P2 card (either Firewire out of a camera, in a PCMCIA slot or via the AJ-PCD20 
Media reader) to your hard drive.  
Mount the P2 cards.
Copy not Move.  
Copy all the files on the P2 card to the following folder on your hard drive: drive:\Avid MediaFiles\ MXF\1.  Note; use the 
Copy function not Move.

Key Point.  Regardless of how you acquire footage, it’s vital that you archive it before erasing 
your P2 cards.  Whether archiving to digital tape, or optical disc, or hard disk, make sure that you copy the entire 
contents of the card (CONTENTS folder and LASTCLIP.TXT file) to an archival media before formatting or erasing the cards.  

 

Q u i c k T i m e ™  a n d  a
 d e c o m p r e s s o r

a r e  n e e d e d  t o  s e e  t h i s  p i c t u r e .

See the “Archiving” section at the end of this paper for more details.
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Acquisition in the studio 
Acquiring footage in the studio is similar to acquiring in the field, except of course you have much more control.  All of the 
steps described above in Acquisition in the field apply, although in a studio it might most desirable to record directly to a 
laptop via Avid Xpress Pro HD then the only limitation on record time is the size of your external hard drive.

Preparing for the edit on Avid Xpress Pro HD
Getting content recorded originally on P2 cards into Avid Xpress Pro HD is very easy and you have a number of options.

Editing directly from a P2 card
One of the best features of using P2 cards with your Avid Xpress Pro HD is that there is no need to capture, digitize or import.  
You can edit directly from your P2 card!  Unquestionably, this is the fastest workflow path to editing, but remember you are 
tying up your P2 cards when you go this route.  

Insert the P2 card.
If your laptop has a PCMCIA card slot, you just insert your P2 card into the slot.
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Open Avid Xpress Pro HD.  
Set your project parameters in terms of resolution and frame rate. 

Use Media Tool.  
Click on Tools  > Media Tool. 
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Select the media drive that your P2 card is in.  Select current project . 

The media on that P2 card will appear in your Media tool.  

You can grab a clip and drag it to the composer window.  Notice as you scroll in the composer window, the light flashes 
on the P2 card.  This indicates that you are indeed editing directly off of the P2 card.  Editing from this point is identical to 
editing any other media in Avid.
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Consolidate your files. 
You can also consolidate your files onto your hard drive in your computer, so that you can free up your P2 cards.  

Consolidating makes copies of the media files or portions of media files of selected clips, subclips or sequences.  Consolidating 
copies these files onto a hard drive that you select.  This frees up the P2 cards and allows you to edit from your hard drive.  
Select the media files and then click bin.  On the drop down menu select Consolidate/Transcode. The Consolidate/Transcode 
dialog box will open.  Here you select Consolidate and designate the target hard drive.  Select your options and then click 
consolidate.  Your media files will then be copied to your designated hard drive.  Editing this material from the hard drive is 
now identical to editing all other types of media in Avid.

Editing from Panasonic Aj-PCD20P Memory Card Reader
Connect the AJ-PCD20 to your computer.  
Choose Firewire or USB.  

Insert your P2 cards.  
The reader has five slots.  It does not matter which order or how many slots 
you use. 

Open Avid Xpress Pro HD.  
As you start Avid Xpress Pro HD, you will notice that it will scan and index all the active P2 cards that are inserted into the 
AJ-PCD20.  Each slot is seen as a separate drive, with it’s appropriate drive letter.  
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Mount all dRIves.

Use Media Tool.  
Click on Tools > Media Tool and 
you will see each drive letter that 
represents each card slot in the 
reader.  

Select the drives (P2 
cards) 
Click on the drive(s) you want and 
then select current project.  
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The media on that drive will appear in your Media tool.  

You can grab a clip and drag it to the composer window.  Notice as you scroll in the composer window, the light flashes on 
the corresponding card slot on the Memory Card Reader.  This indicates that you are indeed editing directly off of the P2 
card.

Consolidate your files. 
This is identical to consolidating as described above in the section on editing directly from a P2 Card.

Editing from Firestore fs-100
You can connect the FS-100 to either a PC or Mac.  This paper 
will discuss connection to a PC.  For more details on a Mac 
connection, see the FS-100 manual. If footage was acquired 
on the FireStore FS-100, you will first have to run the FS-100 
“Organize P2” command before attempting to import footage 
into the computer.  Then set the FS-100 into direct drive mode, 
and attach the FS-100 via an IEEE 1394 interface cable; make 
sure to plug the cable into the FS-100’s COMPUTER I/O port, 
not its DV I/O port.

Open the FS-100 drive folder
Create a new folder OMFI MediaFiles.  Select 
File>New>Folder
Drag all OMF and AIF Files into the new folder.
Open Avid Xpress Pro HD.
Open or create a new project.
Use Media Tool.  Select Tools>Media Tool
Click on FS-100 drive, press ok.
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Create a New Bin.  
Click on File> New Bin, or open one of your existing bins. 

Highlight all items in the Media Tools Window.  
Click Edit>Select All 

Drag to bin.  
When all your clips are in your bin, you can now edit in the timeline.

Key Point.  Dismounting FS-100
Remember you must dismount the FS-100 drive from your computer prior to powering down your system.
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Editing from clones of your data on an internal and/or external hard drive
Naturally, you can edit from hard drives.  There are various methods to get your footage onto the hard drive. You could have 
recorded directly to the hard drive or you could have input your files from a P2 Store. Whichever method, now that it is time 
to edit, simply connect your hard drive to your Avid Xpress Pro HD.

KEY POINT - Make sure that you are at the root level of your drive and that you have copies all the folders 
and files from the original data.

Open Avid Xpress Pro HD.
Mount all drives.
Click on File > Mount All 

Open Media Tool.  Click on Tools > Media Tool.  
Identifiy the eXternal drive. Click current project. 
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Copy or drag clips into bin.  
The clips will appear in the Media Tool, either copy or drag selected clips to your bin and start editing.

Output
After editing, it is time to output your data.  Once again, you have a number of options based on what your requirements 
for a specific project demand.   You can output the following DVCPROHD projects; 720p/23.976. 720p/59.94, 1080i/50, and 
1080i/59.94 via Firewire to an external deck or other device. You can also output DVDCPROHD to a SD DV Device.

Select the sequence you wish to output
Render all effects
Select Special >Device>IEEE 1394
Select Clip > Digital Cut
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Perform the Digital Cut.

Archive (storing your data)  
After your project is completed it is important to archive your assets.  Besides backing up your Avid Xpress Pro HD files, you 
will also want to archive your P2 footage.   

Key Point.  When archiving, you want to store all the originally-recorded data, in its original form.  
Don’t just archive certain portions or certain files, but back up the entire contents of the card.  Additionally, it is vital to keep 
and preserve the directory structure and archive the entire CONTENTS directory and the “LASTCLIP.TXT” file, if any.  Once 
again you have some options.  

DLT Tape Storage
Since P2 media is not tape based, but rather IT information, perhaps the most time tested storage for IT technology is with 
a DLT (Digital Linear Tape) storage system.  One example of a good tape drive that works well in the P2 workflow is the 
Quantum SDLT 600A. The interface to control this device is fttp. 

Blu-Ray Disc
This emerging technology offers up to 50 GB storage, and is very attractive for archival storage.

DVD
P2 information can be archived on regular DVD ROM discs.  Another common archival process is to use optical discs, such 
as recordable data DVDs.  A 4GB P2 card can be archived onto a regular 4.7GB DVD-R or DVD+R; an 8GB P2 card can be 
archived onto a dual-layer DVD-R.  16GB and larger cards may be able to be archived onto data Blu-Ray or dual-layer HD-
DVD discs.  To archive onto a data DVD-R you’ll need a DVD burner as well as a DVD burning application (such as Nero AG’s 
“Nero”, or Roxio “Toast”) which supports making data DVDs.  Note: you do not want to create a playable video DVD, you 
want to create a data DVD.  Then, using your DVD burning application, create a data DVD image that consists of one card’s 
CONTENTS and LASTCLIP.TXT and burn one DVD per card.
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Hard Disc Storage
Hard drive storage is now quite affordable and allows for short term storage, although this is not recommended for archival 
storage.	

Conclusion
Panasonic P2 media offers you great flexibility in your acquisition, archiving and editing workflow.  Working with P2 data 
and editing within Avid Xpress Pro HD is quite straightforward and allows for the fastest workflow. For more information 
consult: www.panasonic.com/business/provideo/home.asp, www.focusinfo.com and www.avid.com.

Written by:   Bernie Mitchell, President, Silver Platter Productions, Inc.


