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Setup

Specifications

Power supply: 6 -> 14vdc, center positive
Fuse: 3A Max, 5x20mm glass fuse
Solenoid: 5v or Vin

Stepper motor: Vin, 5mm shaft, bipolar

Hardware Setup

The system contains the follow external board connections;

e Five push-buttons

e Adjustable potentiometer

e Two E-stops, one active, one passive.
e 4-bit LCD

e Single pulse encoder

e Two solenoid relays, active low

e Stepper motor driver

e Fuse connector

e Power

The hardware parts list, PCB files and program, can be downloaded from the Git repository;

https://github.com/Heych88/Arduino-cutter



4-bit LCD

Stepper motor
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The wiring of the hardware, for most common operations, is as follows;



Cut

: Alternate
= connection

Vin  GND

Up Down Stop/Stat Select

Motor rotation direction

Upon installation of a stepper motor, the two winding pairs must be located. It is recommended
to use a multimeter to measure the resistance between the wires. One winding pair must then
be connected into the output connector group pairing of Outl and Out2 and the second
winding pair connected to Out3 and Out4.

Once connected, the motor will spin in a direction. If the motor is required to spin in the
reverse direction, swap the group pairings with each other. l.e. Outl swap with Out3, Out2
swap with Out4.



Solenoid power selection

The solenoids can be supplied with either 5v or Vin. Both solenoids must power from the same
supply and must both be either 5v or Vin.

The voltage can be changed by swapping the jumper on header JP1. See board for voltage
configuration details.

For 5v solenoids, place the jumper on pins 1 and 2. For Vin solenoids, put the jumper on pins 2
and 3.




Software Setup
Menu Selection

The controller contains 11 adjustable menu selections. Six for adjusting production runs and five for
system specific hardware setup.

To enter the system menu, press the up button.
To navigate the system menu, press either the up or down buttons.

To select a menu, press the SEL button, and a flashing cursor will appear on the screen.

Production Run Settings

Adjust quantity
Adjusts the desired production quantity to be produced with the desired product specifications,
as outlined in other sections.

1. Navigate tothe "Set quantity" menu using the UP or DOWN buttons.
Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the desired quantity using the UP or DOWN buttons.

4. Press the SEL button to set the desired quantity and return to the home screen.

Adjust length
Adjusts the total desired product length.

I St len
- oMM

1. Navigate tothe "Set length" menu using the UP or DOWN buttons.
Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the desired length using the UP or DOWN buttons.

4. Press the SEL button to set the desired length and return to the home screen.



Reset production counts
Resets the number of the already produced product.

1. Navigate tothe "Clear Qty" menu using the UP or DOWN buttons.

2. Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Press the UP button until the display changes to "Yes".

4. Press the SEL button to rest the produced quantity and return to the home screen.

Adjust motor speed menu
Adjusts the motors running speed. This menu is only used for display purposes only.

1. Navigate tothe "Set Speed" menu using the UP or DOWN buttons.
2. Adjust the speed using the SPEED DIAL until at the desired speed.
3. Navigate to the home menu with the DOWN button.

Adjust pierce distance
Adjusts the distance from the end of the desired length to add a pierce.

If the number of pierces is two, a pierce is performed at the desired distance from the start of
piece and the desired distance from the final length of the part.

If the number of pierces is one, a pierce is only performed at the desired distance from the start
of piece.

The pierce distance is calculated from the product edges and the centre of the piercing die.




1. Navigate tothe "Set pierce dist" menu using the UP or DOWN buttons.

2. Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the desired length using the UP or DOWN buttons.

4. Press the SEL button to set the desired distance and return to the home screen.

Adjust pierce quantity
Resets the number of piercings in each product piece.

1. Navigatetothe "Set pierce gty" menu using the UP or DOWN buttons.

2. Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the desired quantity using the UP or DOWN buttons.

4. Press the SEL button to set the quantity and return to the home screen.

Hardware Setup

Adjust pierce solenoid delay
Adjusts the time delay for activating and deactivating the solenoid used for piercing in
milliseconds.

The total solenoid time is double the delay time set, as the delay time set is the full time that
the solenoid is activated (set Low) and the identical time to release and retract the solenoid (set
High) back to its deactivated state.

1. Navigatetothe "Set pierce delay" menu using the UP or DOWN buttons.

2. Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the desired delay using the UP or DOWN buttons.

4. Press the SEL button to set the required delay time and return to the home screen.



Adjust cut solenoid delay
Adjusts the time delay for activating and deactivating the solenoid used for cutting in
milliseconds.

The total solenoid time is double the delay time set, as the delay time set is the entire time that
the solenoid is activated (set Low) and the identical time to release and retract the solenoid (set
High) back to its deactivated state.

1. Navigatetothe "Set cut delay" menu using the UP or DOWN buttons.

2. Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the desired delay using the UP or DOWN buttons.

4. Press the SEL button to set the required delay time and return to the home screen.

Adjust stepper motor counts per rotation
Changes the number of steps for one full stepper motor revolution.

This is specific to each motor. Check the datasheet of the motor for more information.

If a geared system is used, the gear ratio must be factored into consideration here. l.e. a motor
step count of 200 with a motor to wheel gear ration of 10:1, set the step count to 2000.

1. Navigate tothe "Set steps/rev" menu using the UP or DOWN buttons.

2. Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the steps using the UP or DOWN buttons.

4. Press the SEL button to set the required steps and return to the home screen.



Adjust drive wheel diameter
Adjusts the diameter of the drive wheel that is driven by the drive motor.

1. Navigate tothe "Set diameter" menu using the UP or DOWN buttons.

2. Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the diameter using the UP or DOWN buttons.

4. Press the SEL button to set the diameter and return to the home screen.

Adjust solenoid offset
Adjusts the distance between the pierce and cut solenoids in mm.

The pierce solenoid is MUST be placed before the cutting solenoid, in the direction of travel.

1. Navigatetothe "Pier sol offset" menu using the UP or DOWN buttons.
Press the SEL button, and a flashing cursor will appear. If the flashing cursor doesn’t
appear, press the SEL button until it does.

3. Adjust the offset distance between the cutting blade and the centre of the piercing die
using the UP or DOWN buttons.

4. Press the SEL button to set the required steps and return to the home screen.
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Programming with Arduino IDE

The brains behind the program is an Arduino Leonard.

A new Leonardo can be programmed using the Arduino IDE which can be downloaded for free from the
Arduino site;

https://www.arduino.cc/en/Main/Software

Install the software as required by your operating system. l.e. For windows download and run the .exe
file.

Programming the EEPROM

If you are installing a brand-new Arduino Leonardo board, the EEPROM must be flashed first. If it is the
existing system board, this step can be skipped.

The code can be downloaded from the Git repository;

https://github.com/Heych88/Arduino-cutter

1. Runthe Arduino IDE
2. Click File > Open

File | Edit Sketch Teols Help

MNew Ctrl+M
Open... Ctrl=0Q
Open Recent »
Sketchbook >

3. Navigate to the programs code location and select the eeprom_write.ino file by navigating to
<Saved path>/src/eeprom_write/eeprom_write.ino

11


https://www.arduino.cc/en/Main/Software

43| Open an Arduino sketch... x
P

Look in: l eeprom_wiite - | (€] 5 el FFF g
| Mame h Date moadified Type
-@lceprn-m_write.inn- 13-Dec-17 3:01 AM  Arduino fi
Quick access
Desktop
™
Libraries
This PC
‘-i £ >
Metwork
Chject name: eepmm_wite ino V| I Open I
Objects of type: | All Fes () | Cancel
Click open

Set the board type under Tools > Board, select Arduino Leonardo.

«ch Tools Help

. Auto Format CtrlsT
Archive Sketch

L Fix Encoding & Reload
Senal Monitor Ctrl+Shift=M
Senal Plotter Ctrl+Shift«L

WiFi101 Firmware Updater r o

Board: "Arduino Leonardo" ! Boards Manager...
Port 9. Arduino AVR Boards
Get Board Info Arduino Yun
Ardui :
Programmer: "AVRISP mkil" ; R
Arduino Duemilanove or Diecimila
Burn Bootloader
IEPRN. R Arduine Nano
Arduino/Genuino Mega or Mega 2560
CDELATADCR, 0 Arduino Mega ADK
IRCE_DELAY RADDR 2 :
¢_DESIRED ADDR 4 '® Arduino Leonardo
[_LENGTH ADDR © Arduino Leonarde ETH
IRCE LENGTH ADDR & PUSPIT 7 S .

Connect the Arduino board to the computer using the micro USB port. It is recommended to
remove all other external power supplies before and during USB connection to the PC.

Assign the correct computer port that the Arduino is connected too, under Tools > Port > COMx
(Arduino Leonard).
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ich Tools Help

I Auto Format Crrl+T
Archive Sketch
fite Fix Encoding & Reload
Serial Maonitor Cirl+ Shift+M
Serial Plotter Cirl+5Shift+L

WiFi101 Firmware Updater

Board: "Arduino Lecnardo” »
Port: "COMT (Arduino Leonardo)” H Senal ports
Get Board Info oM

Programmer: "AVRISP midl” ||| COMT (Arduino Leonardo)

Riirm Rantlmader

Note: The COM port used above may vary between machines.
8. On the main screen, click the Verify icon, tick icon. This will compile the program.

9. If no errors have occurred, click on the Upload icon, arrow icon.

10. Once uploaded the program will run automatically, and when complete, the program will turn
on Pin 13 LED.

11. If Pin13 LED, onboard LED ‘L, is on. You have successfully loaded the EEPROM onto the device.
You can now move onto the main program load sequence.
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Programming the system program

If you are installing a brand-new Arduino Leonardo board, the EEPROM must be flashed first. See above
for details.

The code can be downloaded from the Git repository;

https://github.com/Heych88/Arduino-cutter

1. Runthe Arduino IDE
2. Click File > Open

File | Edit Sketch Teols Help

Mew Ctrl+M
Open... Ctrl+=Q
Open Recent »
Sketchbook >

3. Navigate to the programs code location and select any .ino file by navigating to <Saved
path>/src/xxx.ino

& Open an Arduine sketch... *
Lockin: | | s v @ E
* Mame ’ Date modified Type
) eeprom_write 13-Dec-17 101 AM  File folder
Lhicckaccesas @'_ﬂ_eapmm.mn 13-Dec-17T 12205 PM  Arduino fi
- @'_‘I_:Etu pifo 0B-Dec-17 &13PM  Arduing fi
@'_Lsu lenaid.ino 08-Dec-17 &22PM  Arduing fi
Desktop &5 _3_dicplayine 13-Dec-17 %38 AM  Arduing fi
: £ _4 motoring 13-Dec-17 1227PM  Arduino fi
™ @'_S_huttun.lnn 13-Dec-17T 1520 PM  Arduing fi
Libraries E'_E-_imerrupt.]nn 0B-Dec-17 10:58 AM  Arduing fi
@_B_rn aining 13-Dec-17 1L08 PM Arduing fi
[! ﬁ'src.lnn 13-Dec-17 358 AM Arduimo fi
This PC
¢ . .
MNetwork
Object name: __eeprom ino b | I Cpen |
Ohjecte of type: Al Files ("7 t Cancal
4. Click open

5. Set the board type under Tools > Board, select Arduino Leonardo.




10.

«ch Tools Help

I Auto Format Ctrl+ T
Archive Sketch
- Fix Encoding & Reload
Senal Menitor Ctrl+Shift=M
Senal Plotter Ctrl+Shift=L

WiFi101 Firmware Updater o8

Board: "Arduino Leonardo” I Boards Manager...
Port i‘ Arduino AVR Boards
Get Board Info Arduino Yun

Arduino/Genuino Uno

2

Programmer: "AVRISP mkil"

Burn Bootloader
IEPRON.B> Arduine Nano

Arduinc Duemilanove or Diecimila

Arduino/Genuino Mega or Mega 2560
[_DELAY_ADDR 0

5 Arduino Mega ADK
IRCE_DELAY ADDR 2

¢_DESIRED ADDR 4 '® Arduino Leonsrdo
[_LENGTE ADDR & Arduino Lecnardo ETH
IRCE LENGTH ADIR & PRSP Y- S .

Connect the Arduino board to the computer using the micro USB port. It is recommended to

remove all other external power supplies before and during USB connection to the PC.

Assign the correct computer port that the Arduino is connected too, under Tools > Port > COMx

(Arduino Leonard).

ich  Tools Help

I Auto Format Ctrle T
Archive Sketch

nte

Fix Encading &t Reload
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L

" WiFi101 Firmware Updater

211 Beard: "Arduino Lecnardo” >
Port: "COMT (Arduino Leonardo)” H Senal ports
Get Board Info COomM1

Drogrammer: “AVRISE midl® :. st ol emerio)

Riirm Rnatlmadar

Note: The COM port used above may vary between machines.
On the main screen, click the Verify icon, tick icon. This will compile the program.

If no errors have occurred, click on the Upload icon, arrow icon.

Once uploaded, the board can be unplugged from the PC, and the system power can be plugged
in again. Upon powerup, the system will operate as usual.
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