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Introduction 

The Deko Training Manual is the primary text for the Pinnacle Systems Deko training program: 

Deko is a full-color video character generator from Pinnacle Systems, Inc. Based on the Windows 
operating system; Deko offers unprecedented performance in broadcast quality.  

How to Use This Manual 
This manual is designed as an in-depth tutorial of the Deko system. Lessons are structured in a 
logical flow taking you from basic concepts to more advanced features and functions. Most lessons 
include self-paced exercises that allow you to practice the skills needed for mastery of the Deko 
system. A companion CD contains samples and the source material you will need to perform the 
exercises.  

Note: All Deko references in this manual apply to FXDeko. While most of this material is directly 
applicable to other version of Deko hardware and software, features and menus vary between different 
systems. Your Deko system may not include options described in this manual.  
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How to Contact Pinnacle Systems 
Pinnacle Systems, Inc. 
280 N. Bernardo Avenue 
Mountain View, CA 94043 

What to Do Before You Call: 
Whenever you contact Pinnacle Systems for technical support, please have the following information 
available: 

• Product name and software version number 

• Product serial number (in the Help menu, choose About) 

• Precise description of problem and attempted solutions 

• Exact wording of any error messages 

Pinnacle Systems Technical Support by Phone: 
Customer Service (U.S.):  (650) 930-2990 
Customer Service Fax (U.S.)  (650) 930-1601 
Customer Service (Europe)  +44 1895 442-003 
Customer Service Fax (Europe)+44 1895 442 009 

Information and Technical Support on the Internet: 
For the latest information on Deko upgrades, visit our website at: www.pinnaclesys.com. 

Our e-mail address for technical support is: 
In the U.S.: broadcast-support@pinnaclesys.com 
In the U.K.: broadcast-support-uk@pinnaclesys.com 
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Lesson 1: Verify and Configure Your Deko 

Verifying Your Deko 
If you have PostDeko, you should have in front of you a keyboard, mouse and a VGA monitor. The 
Deko family of character generators have video outputs, so you should have a keyboard, mouse, VGA 
monitor and video monitor.  

You do not have video output with PostDeko. Throughout the rest of this tutorial, you will need to 
look at the Program window of the Deko software whenever a lesson tells you to check your video 
output. 

Identify Your Keyboard 
You might have either the standard or the FastAction Keyboard, which makes it easier to harness the 
power of Deko. Some shortcut keys change when you have FastAction. In this tutorial, we will mark 
shortcuts with SK for Standard keyboard, or FAK for FastAction keyboard. Shortcuts that apply to 
both will not be marked. 

 

The Deko FastAction Keyboard. 
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Close 
Maximize 

Toggle  

Minimize 

Start Up Your Deko Software 
On the menu monitor, you should now be looking at the Windows NT Desktop�or maybe the 
nearly identical Windows 95/98/2000 Desktop if you have PostDeko.  

If the task bar is visible, set it to Auto Hide. To do this, go to Start > Settings > Taskbar & Start 
Menu. Then, in the dialog box that appears, check the Auto hide box and click OK. 

 

If you do not see the Desktop, it may be because some 
other program is running. Close or minimize each 

program until you see the Desktop. 

By now you are looking at the Desktop and are ready 
to start the Deko program. Depending on which 
flavor of Deko you have, you will find the appropriate 
Deko entry in the Start Menu. Find the correct entry, 
highlight the program and click on it once. 
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How to Create a Shortcut  
The easiest way to launch Deko is from a shortcut on the desktop. A shortcut is a link to the actual 
file giving ready access to the program file. Your desktop should already have a Deko shortcut 
available. If not, to create a shortcut: 

 
1. If the Windows Desktop is not visible, minimize  

all programs. 

2. Right-click on the My Computer icon and select 
Explore. 

3. When the Explore window appears, double-click on (C:) Drive, Double click on the Deko 
program directory, then double-click on the Bin directory. 

Program 
Shortcut 

3. Right-click on 
application file. 
Drag to desktop 

1. Double-click 
Deko folder 

2. Double-click 
the Bin subfolder 
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4. Right-click on the Deko program icon and drag it to the 
desktop.  

5. Release the right mouse button. A menu will be revealed. 
Select Create Shortcut(s) Here. The Deko icon will be placed 
on the desktop. 

6. Double-click the newly made shortcut icon to launch Deko. 

Launching Deko from the Start Menu 
When other applications are running, the 
Windows Desktop may not be visible. An 
alternative way of accessing the shortcut is from 
the Start menu. To place a copy of the shortcut in 

the Start menu, drag the Deko shortcut from the Desktop to 
the Start menu button and release. A copy of the Shortcut 
will appear in the Start menu. Now you can start Deko by 
clicking on the Start button and selecting the Deko icon in 
the menu.  

You may wish to place additional programs you use often in 
the Start menu for easy access. 
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Can�t Find Deko in the Programs List? 
1. Click the Start > Find > Files or Folders.  

 
2. Type in the name of the desired application in the Named: field. Such as:  

FXDeko.exe
FXDekoII.exe
PostDeko.exe

3. Click on the Find Now button. 

4. Once the search has finished, look in the list at the bottom of the window. You should see a 
description of your filename along with a path that indicates its location.  

5. Double-click on the icon of the found file to open your application. 
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Verify Hardware Settings 
All Deko systems except PostDeko provide for video input and output to support live feed of 
character generator output for video production. Depending on your model of Deko, these settings 
may vary. On the FX Deko, these settings are made in two locations. 

Verify Video Standard 
The first setting to verify is the video operating standard. All versions of Deko 
can operate in either NTSC or PAL standards.  

• To set the video standard, minimize the Deko interface to reveal the 
Windows NT Desktop. Right click on the Desktop and select 
Properties from the Shortcut menu. 

 

• Select the Pinnacle tab from the dialog box. Click on the Setup button in Configuration and 
verify the video Standard. In the U.S., the standard is NTSC. In most of Europe, Australia, 
Africa, the Middle East and Latin America, the standard is PAL. 
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Check Input / Output Settings 
The Input/Output settings are found under the Options > Hardware Setting > Analog I/O 
Adjustments menu. This menu reveals a four-tab dialog box used to set the video Input/Output feeds 
to the Deko.  

IO Status Tab 
The IO Status tab verifies the current setting of the system. Check to see that the settings match the 
I/Os you are using in your system.  

Note: if the Output settings are incorrect, your video monitor will display the output of your 
graphics incorrectly. Click on the corresponding tabs to make any needed adjustments. 
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Input/Output Adjustment Tabs 
The Input and Output adjustment tabs provide for both selection of video format and adjustment of 
the signal. The Formats are Composite, YUV (Component) and RGB. Choose the format that 
matches your video standard.  

 

Note: Do not move the Video adjustment sliders unless you are technically qualified to do so.  

FastAction Keyboard Isn�t Working Properly? 
If you cannot clear the LED display on the FastAction keyboard or perform typical keystrokes such as 
using the Read key to open a document, your keyboard may not be enabled properly. First, check to 
see that Num Lock is set on the keyboard. If this does not correct the problem, do the following: 

1. Go to Options > Preferences.  

2. In the Preferences dialog box select the Common tab. 

3. To the right you will see settings for the FastAction keyboard. Click Enhanced Keypad, 
FastAction Function and FastAction Lights keys to place an �X� in each box. 
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4. Click on the OK. This will activate the keyboard. 

 

Versions before 3.0 
If the boxes are grayed out, this means the drivers may not be installed. If you have the drivers, they 
may not work of you upgraded Windows NT Service Pack 6. To find your software version, go to 
Help > About Deko.  

To fix this problem, re-install the FastAction Keyboard drivers. Begin as if you were installing the 
entire Deko program. 

1. Run Setup.exe from your Deko installation disk.  

2. Keep the destination directory the same as where you installed Deko.  

3. Choose Custom installation. 

4. When you reach the window pictured below, deselect all components by clicking directly over 
each check mark except for the FastAction Keyboard. Make sure FastAction Keyboard has a 
check.  
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5. Click Next to complete the installation process. 

6. Restart the computer. Click the Start button and choose Shut Down. 

7. Select Restart the computer? in the Shut Down window and click on Yes. 
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Desktop Layout 
The first time the Deko program opens; you will see the Graphic Compose Layout screen. All 
creation and playback of Deko graphics are done using the mouse and keyboard to interact with the 
various controls and windows on the Deko desktop.  

 

The appearance of the desktop depends on the current layout as selected from the Window Menu. 
Deko offers a variety of standard layouts for creating, editing and playing back graphics and macros. 
You can also set up and save custom layouts that better accommodate the way you work. 

Set Preferences 
Go to Options > Preferences.  

• Select the Cursor tab and click the Moving cursor sets font and 
look box. Check the Show text cursor box is checked so that your 
cursor is visible in the Program window.  

• For Text Cursor Style, check I-beam. Your window should look 
like the one below.  

Note: The lessons in this text reference the I-beam cursor. You may have 
greater familiarity with the Box cursor as used in some other CG 
applications. If so, select Box cursor as your preference. 

• In the Options menu, deselect Save Settings on Exit. 
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• Select the Common tab.  

• Click on the Layout window.  

• Click on the Shortcut menu in Starting layout and select Style Edit.  

• If you are using a FastAction keyboard (FAK), make sure the Enhanced Keypad and 
FastAction Function Keys are selected. If both selections are grayed out, this may indicate 
that the drivers need to be installed. 
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• Check Automatically play macros when opened. 

• Check Automatically play associated effects. 

• Click OK.  

Color Used Where Graphic is Transparent  
The Common tab provides you with a setting to change the background of the Preview and Program 
window when you are working with transparent backgrounds. The normal default for this setting is 
dark gray. With this setting it is often difficult to determine whether you are looking at a keyed 
transparent background or a black background. Choosing a dark color such as dark green for your 
setting helps you to determine what is transparent in the background. To change this setting: 

1. Click on the button under Color used where graphic is transparent. A color 
picker is revealed.  

2. Click on one of the basic colors or use the color picker panel for a custom 
color. The color chosen will display in the Color Solid box. 

3. When you have selected a 
satisfactory color click 
OK. The color will be 
deposited on the button 
under Color used where 
graphic is transparent. 
This color will be used as 
the background color of 
the Preview and Program 
windows.  

4. Click OK to accept the 
change. 

Note: the color will not 
be displayed on your 
video output. 
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Choose Style Edit Layout (Alt+F11) 
Deko provides eight preset layouts as tools for developing and playing graphics. For the first part of 
the lesson we will be using the Style Edit layout. This is the preferred of the preset layouts for 
graphic creation. Later, you may choose to create a custom layout to suit your individual work style. 

Most Deko commands have keyboard shortcuts. In addition, the FastAction Keyboard has special 
function keys to improve the productivity of your work session. Begin to learn the shortcuts and you 
will dramatically improve your speed and productivity using Deko software. 

Go to Windows > Select Layout > Style Edit. The shortcut for Style Edit layout on both the SK and 
the FAK is Alt+F11. On the FAK, press Ctrl + Program to choose your preference for standard 
layout (as set in the Starting layout section of Options > Preferences > Common tab). This could be 
the Style Edit layout, one of the other layout preferences, or your own custom layout.  

Save Preferences (Alt + O >S) 
Go to Options > Save Settings Now. This saves Preference menu settings and preset macro settings. 
Any time you re-open the Deko program, these settings will still exist and the Preset Style window 
will open with these styles. 

Special Note: Using Undo 
From time to time, you may find yourself wishing you hadn�t done whatever you just did. Yes, it 
could happen to you. No need to panic. Deko gives you the prerogative to change your mind and 
your mistakes using Undo. 

To Undo the Previous Action(s): 
Go to Edit > Undo (Ctrl + Z) for each action you wish to undo. The Edit menu tells you what will 
be undone. 

To Redo Undone Actions: 
Go to Edit > Redo (Ctrl + Y) for each action you wish to redo. The Edit menu tells you what will be 
redone, that is, putting it back the way it was immediately before you used the Undo function. 

To Enable or Disable Undo: 
In the Edit menu, check or un-check Undo enabled. 

The default setting is Undo enabled. Undo uses several megabytes of space on your hard drive and 
may slow some Deko operations. Disabling Undo frees space on your hard drive and may speed up 
Deko�s performance. However, you cannot Undo actions performed while Undo is disabled, even if 
you immediately re-enable it.  
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Opening Files 
The Open Files dialog provides the tools for you to open files in the Deko interface. The following 
tools will assist your selection: 

• Directory Path field � provides the path from the root Drive directory to your file directory. 
Starting from the Root Drive directory, double clicking on each folder in the path will open 
the final directory in the path where your files are located. This path will be placed in your 
Paths file of preferences. The above example would show d:\deko\tutorial

• File Selection List menu � provides a list of all available files for you to open in a selected 
directory. 

• List File of Type menu � acts as a filter showing only selected file 
types in the File Selection menu. This can be useful when many 
file types are stored in a directory. Deko defaults to the Deko 
(*.dko) file type represented by the active window when File Open 
was selected. You can select a different file type if desired. In the 
program window, other graphic files can be open including .bmp, 
.tga, and .jpg files. To see these files, click on the arrow of the 
List Files of Type box and click on the desired file type. 

 

Directory Path 
box for the file 

selected 

Drive Selection 
List box 

Network Drive 
button 

File Selection 
list box 

File Type list 
menu 

File Option 
information 
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• Drives Selection menu � use this to select a different available drive. 

• Network Drive button � if your Deko is connected to a network, files can be opened from 
servers or other Deko systems on the network. Click on this button to open the dialog to map 
the network path. 

• Options button � provides file information on the selected file. 

Note: Use Clear + Read keys (FAK) or F9 (SK) to open access the File Open dialog without using the 
mouse. 

Saving Files 
When you wish to save an opened file, the preferred method is to choose File > Save As. Deko 
automatically increments a number on the file name to create a new file with a new name. This 
allows you to retrieve the original should you wish to go back. The keyboard shortcut is F12 on the 
SK (Standard Keyboard) or the Save File button on the FAK (FastAction Keyboard). To overwrite the 
original file, go to File > Save or press Alt+F12 (Alt + Save File on FAK). 

Verify System Output 
1. Go to Style Edit layout. (ALT+F11). 

2. Click in the Program window to �set focus� and type some characters. 

3. Look to the video monitor to verify system output. If no text is displayed, do one of the 
following: 

• Check for power and proper channel selection on the video monitor. 

• Check the connection from Deko chassis to the video monitor for improper video cabling 
(Refer to your Deko Quick Install Guide for information on connections). 

• Check for a video reference source; Deko requires this for output. Go to Options > Hardware 
Settings > Analog IO adjustments. Under Reference Status, look for �Line Locked� or �Color 
Locked� to verify a reference source.  

Note: Use the Hardware Settings menu for technical troubleshooting. Do not change any setting 
without consulting the appropriate technical personnel within your facility. 

Exiting Deko 
To exit Deko, choose File > Exit (Alt+F4) or click on the close box on the Deko Interface. 
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Exercise: Enter Text Into Bio Page. Play to Air With an Effect. 
This sample exercise is designed to familiarize you with various components of a Deko graphic, as 
well as entering, saving and recalling text. See the sample below. 

 
1. Click in the Program window to set focus and open the sample file 

D:\Deko\Tutorial\training_bio.dko. 

2. On the keyboard, toggle the Insert key to enable Overwrite (OVR) mode. Look to the status 
bar at the bottom of the screen to see that OVR is displayed. 

3. Press the Tab key to jump from layer to layer in the graphic. Enter personal information for the 
following layers: name, hometown, occupation and hobbies. 

4. Press the Save File key and enter �99� as the filename (message address). Save your file to the 
Tutorial folder. 

5. Press the Clear Program key to clear out the air channel. Do the same for the Preview channel. 

6. On a FastAction keyboard (FAK): Enter �99� from the numpad, then select the Read Preview 
key.  

 On a Standard keyboard (SK): go to View > Preview. Select the Read key (F9) and open 
�99.dko�. 

7. Take notice of the FAK�s blinking Play key and the mouse icon � (indicating unavailable). 
Deko is currently paused awaiting the play of an effect. 

8. Press the Play key (FAK) or Alt + Enter (SK) to resume the effect. Look at the video monitor to 
see your work. 
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Shortcuts Keys 
Close the Deko program  Alt + F4 
Save Settings Now   Alt + O > S 
Save File As    F12 
Save File    Alt + F12 
Style Edit Layout   Alt + F11 
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Lesson 2: Navigating the Deko Interface 

The Deko Interface  
When you open the Deko program, the window will display the starting layout you set to configure 
on the Common tab of the Preferences dialog box. If you configured your system in Lesson 1, the 
window should open to the Style Edit layout. This is the preferred layout for graphic creation. In this 
section we will review some important concepts for quickly navigating the Deko Interface. We will 
also introduce the four main layouts for work within Deko. Finally we will show you how to create 
and save your own custom layout. 

When you are working in Deko, the look of the screen will change depending on the layout you are 
using. All layouts share some things in common. For example, each window will open with a menu 
bar at the top of the layout. These menus provide you with the tools necessary for running the Deko 
software and are key to mastering the program. The menus will change depending on the layout 
selected and the window activated for each function.  

If you position the mouse pointer to a menu selection and click on a 
Menu item, a Shortcut menu will reveal more selections, click on a 
selection to open a dialog box or activate a function. 

Navigating the Menus with the Keyboard 
As you are learning the software, you will need to refer to the menus 
frequently to learn where commands are located. As you learn the 
interface, you will use the keyboard shortcuts and rely less on the mouse.  

Using the Alt Toggle 
Pressing the Alt key will toggle menu selection. When you press the Alt 
key, the selection over File will depress. Press the left arrow key to select the 
item to the right. Press the down arrow to open the Shortcut menu. Continue 
pressing the down arrow to select a menu item. 
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Using Alt Key Select to Open Menus 
Notice that the first letter for each menu selection is underlined. 
If you hold the Alt key down and press the underlined letter, that 
menu will be revealed. For instance, press Alt + V to reveal the 
view menu. 

Notice that each menu item has an underlined character. While 
the window is open, if you press this character, you will activate 
this menu function. Press Alt + V then N to reveal the Motion 
window (without a layout change). Press Alt + V then S to reveal 
the Style window. 

In this text we will note any menu selections as with this example 
Alt +V > S, which translates to the Alt key plus the V key 
then the S key. 

Shortcut Keys 
Also notice in this menu that some selections have a keyboard 
shortcut. For example, Sequence has F11 noted after it. Function 
key 11, is a keyboard shortcut for the Sequence Edit layout on a 
Standard keyboard. You should begin to memorize the shortcut 
keys you use regularly. They will save you a tremendous amount 
of time. Learn to use the mouse as little as possible. 

The View Menu 
The View menu, pictured above, provides access to all of the tools 
available to the Deko interface. The eight items checked in the 
menu comprise the elements of the Style layout view. The 
remaining items are additional dialogs we will explain later. 
Selecting an item will toggle it on or off view. Each standard interface layout uses a different 
combination of these views. Later in this lesson, you will learn how to create your own custom layout 
using the tools of your choice.  

Remember use Alt + V > (ID letter) to select a view rather than the mouse. If an item has a keyboard 
shortcut, learn the shortcut. 
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The Window Menu 

 
The Window menu provides access to the machine layouts you will be working with. There are seven 
standard layouts available to work in. In addition, FXDeko/FXDeko II and some other models allow 
you to save custom layouts that will appear in this menu. To access these layouts with the Alt key, 
press Alt + W > L > (ID letter for Layout). For example, Typeface edit can be accessed with  
Alt + W > L > T. 

Notice that the first five layouts have shortcut keys. You should learn these shortcut keys, and use 
them to access the different Layouts. You will be switching layouts frequently in the operation of the 
machine and you need to be able to do this quickly. 

Four Important Layouts 
The four most important layouts for working within Deko are: 

• Style Edit (Alt + F11) 

• Effects Playback (Shift + F11) 

• Sequence Playback (SK: F11, FAK: Seq Edit) 

• Motion Compose (Shift + Ctrl + M) 
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Style Edit Layout (Alt + F11) 
 

 
The Style Edit layout is the preferred view for graphic creation and is probably the most important 
layout for you to learn. The Style Edit opens with the Program window in the center. Five windows 
surround the Program window: Style window, Current Style window, Preset Style window, Shader 
window and Tools window.  

The Style Edit layout will be covered in detail in Lesson 4 � Type and Modify Text. 

Sequence Edit (F11) 
 

 
The Sequence Edit layout is used to create a playback sequence of graphics. The Sequence Edit view 
opens with three windows, the Preview window (top left), Program window (top right) and Sequence 
window (bottom). 
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Effect Playback (Shift + F11) 

 
The Effect Playback window looks similar to the Sequence layout. The Effect playback window 
replaces the Sequence window on the bottom. Use this layout to setup and playback single effects (as 
opposed to creating a playback sequence of multiple graphics). You can also use this layout to create 
an embedded effect, which can be stored with a graphic and played when the graphic is opened in the 
preview channel. 

Both of these layouts will be covered detail in Lesson 9 � Creating Sequences and Effects. 

Motion Compose (Shift + Ctrl + M) 

 
The Timeline Motion Compose window enables you to create a wide variety of complex on-screen 
moves and 3D effects. These effects can be applied to any and all elements in the graphic providing 
for very sophisticated and exiting on-screen moves. 
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In Lesson 10 you will work through a tutorial to produce a complex graphic move with the timeline. 
You will also learn how the timeline can be used to create sophisticated moves on multiple elements 
(layers) of a graphic. 

Custom Layouts 
The Deko interface can be customized to meet your individual requirements. To customize the 
interface, rearrange the windows as necessary. Open any windows you wish to include from the view 
menu. Close any windows you do not wish to include. Below is an example of a custom layout. 
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To save your custom layout: 

1. Go to Windows > Save Layout As. 

2. Type the layout name in the Save Layout dialog box and 
click Save. 

 

3. The layout is now available as a selection in the Windows > Select Layout menu. 

 
Note: Not all versions of Deko allow you to save custom layout views. 
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Lesson 3: Setting up and Managing File Directories 

Opening Windows NT Explorer 
Windows provides a number of ways to manage files. One of the more useful tools is Windows 
Explorer. Explorer works basically the same on Windows 95, 98 or Windows NT, so no mater what 
version of Deko you are using, you will find Explorer an essential tool to manage your files. 

Opening Windows Explorer 
1. Click on the Start button. 

2. Move the mouse pointer up to Programs to 
highlight it. A second menu will appear. 

3. Click on Windows NT Explorer. 

Desktop 
Many long-term users do not know about this 
shortcut to open Explorer. 

4. Right-click on the My Computer Icon on 
the Desktop 

5. Click on Explore from the popup menu.  
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Showing File Details 
 
When Explorer opens, check to see you are in the 
Details View.  

To choose the Details view, go to View > Details. 

 

Browsing Through Drives and Folders 

 
Explorer has two sections. The left pane, or Network Tree, shows the drives and folders available to 
the system. The right pane shows the contents of the highlighted drive or folder. In the above 
picture, the C drive is highlighted in the left pane, so its content shows in the right pane.  
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Notice the minus (�) sign next to the C drive and the plus (+) sign next to some of the folders in the 
network tree. A minus sign indicates that the folders (directories) residing in that drive or folder are 
displayed below it and slightly to the right in the network tree. A plus sign indicates that that drive 
or folder has additional folders, which are not in view. Clicking on a sign or double clicking on a 
folder will toggle between showing and hiding the directory contents. 

Look at the Icons in the left pane. Your system will have the 
same Icons. 

Indicates a local hard drive, on your computer. Your 
Deko should have a C and D drive. Drive letters begin 
with A: (always a floppy drive) and continue to include 
all local and network drives. The hand under the drive 
icon indicates this is a shared drive. 

Indicates a CD-Drive 

Indicates a network drive, which is a drive or directory 
located on another computer and connected over a 
network. 

My Computer displays all drive resources located locally 
on your computer. 

Desktop indicates all resources and Shortcuts mapped to your desktop space. You can 
customize this space. 

Network Neighborhood provides access to all network connections available on your 
computer. 

The Control Panel folder gives you shortcut access to your computer�s Control Panels 
directory. This folder contains a number of useful utilities to modify the settings on your 
computer. For instance, the Date/Time utility allows you to set the clock and calendar for 
your computer. This Clock Setting is used when you create a CG clock in Deko. 

If your C drive is highlighted, click on the Up One Level button on the Tool bar. This will 
place you at the My Computer level. 

Note: If you are at a file level, clicking 
on the Up One Level button will take 
you to the next folder up or to the drive 
level if there are no folders. At the drive 
level, it will take you to My Computer, 
From My Computer; you will go to the 
Desktop. 
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Network Neighborhood 

 
Network Neighborhood displays the available network connections for your system. In the above 
example, the Network Connection Elarson-98 is open displaying its directory contents. The Folder 
Texture located in the D directory is highlighted with its contents in the right window. Network 
connections can be navigated in the same way as drive connections. 

Note: Not all network connections or directories will be available to you without proper 
authorization or a password. If the Enter Network Password dialog box appears, enter your login 
name in the Connect As: field and your password in the Password field. See your network 
administrator for help accessing the files you need. 
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Managing Files and Folders 

Copying Files Between Drives or Folders 
1. Go to the drive and folder that have the original files you want to copy. 

2. Select the file you want to copy. To select more than one file, hold down the Ctrl key and click 
on each of the files you want. 

3. Click the right mouse button (right-click) on one of the highlighted files. A menu will appear. 

4. Click on Copy. You won�t see anything happen but the files are now copied to the Clipboard, a 
temporary storage area on your computer. 

 
Note: If Copy is grayed out on the menu, your mouse pointer was not on top of one of the 
highlighted files. Repeat steps 2 and 3 and try again. 
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5. Navigate to the drive on which you wish to paste the copied file(s).  

6. Scroll to the folder into which you want to paste the file(s), 

7. Right-click on the folder where you want to paste the file(s). A menu will appear 

8. Click on 
Paste. 

 
Note: If the files have the 
same names as the files already 
in this folder, you will see a 
message appear as to the right. 
Click Yes to allow the copy to 
continue, or no to disallow it. 
If you click Yes to All, 
copying will occur for all files 
with the same name. Be 
careful when selecting this 
command. You may overwrite 
a file you did not wish to lose. 
There is no undo for this 
command. 
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Moving Files Between Drives 
Use the Cut/Paste commands to move files between drives. 

1. Go to the drive that has the 
files you want to move. 

2. Select the files. 

3. Right-click on one of the 
highlighted files. A menu will 
appear. 

4. Click on Cut. You will still be 
able to see the files but the file 
icons will be grayed out. 

5. Go to the drive to which you 
wish to move the files. 

6. Right-click the folder where 
you wish to place the files in 
and click on Paste. The files 
will be moved to the new 
location. 

Note: Macintosh users often drag 
and drop files between folders. This 
is a dangerous practice in Windows 
as it can break directory links 
causing files to be lost to the 
program�s search path. Do not drag 
and drop files between folders. 
Instead, select the files and copy 
them, then paste them to a new 
folder.  
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Deleting Folders and Files 
When you want to permanently delete folders or files from your system you use the Delete command. 
The Cut command will not remove files until you move them into another folder. The Delete 
command will normally send items to the Recycle Bin, which is the last item in the Network Tree. 
Items placed in the Recycle Bin can be recovered and placed back on your system for use. If the 
recycle bin is emptied, items are no longer available for recovery. 

1. Right-click on the folder or 
file(s) you want to delete. A 
popup menu will appear.  

2. Click on Delete. One of two 
messages will appear. 

 
• If the following message appears, click yes and the folder or file(s) will be placed in the 

Recycle Bin. Files placed in the recycle bin can be recovered.  

 
• If this message appears, click yes to permanently remove the folder or file(s) from the drive or 

system.  
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Note: The second message will appear whenever you are deleting files from a networked drive or an 
external drive such as a zip disk or a floppy. Files deleted from external drives or sources cannot be 
recovered. 

Rescuing a Deleted Folder or File 
If you deleted a folder and sent it to the Recycle Bin, you can easily recover it. Windows provides a 
number of ways to do this. Three ways are outlined here: 

• Click on the Undo button in the Toolbar 

• Click on the Edit menu and select Undo Delete. 

 

• Drag the Network Tree 
Scroll bar to the bottom and 
right-click on Recycle Bin.  

1. Click Open on the menu. 

2. Select the file(s) you wish to 
restore. 

3. Right-click on one of the 
highlighted files and click 
Restore on the popup menu. 
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Creating New Folders 
Folders can be nested inside other folders. This way you can easily organize your data. At the end of 
this lesson you will complete an exercise creating new folders and sub-folders to store your graphics 
in. Creating folders is an important skill you will use to organize your graphic material. 

1. Click on the Drive or folder you wish to place 
your new folder in. In this case click on the C 
drive. 

2. Go to File > New. A popup menu will appear. 

3. Click on Folder. A second folder labeled New 
Folder will appear at the bottom of the list of 
folders in the right window. New Folder will 
have a box around it and will be highlighted. 

 

4. Type a name for the new folder. 
In this example it is Deko 
Graphics. 

5. Press the Enter key to complete 
the process. 

Notice that your new folder appears 
in the correct order in the Network 
Tree. It still appears at the bottom of 
the right contents pane. When you 
click to another folder and then open 
it again it will appear in the 
alphabetical order. 
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Renaming Folders and files 
You may wish to change the name of a file or folder. A file must be closed before you can rename it. 
If it is still opened, you will get an Access Denied message. 

1. Right-click on the 
folder or file you 
want to rename. A 
menu will appear. 

2. Click on Rename. A 
box will appear 
around the name and 
the name will be 
highlighted. 

3. Type a new name. 

Note: If you chose to show 
the file extension, be sure to 
type the file extension in 
the new name or Windows 
will not recognize the file. 
File extensions are typically 
a three-letter code preceded 
by a period such as .dko for Deko graphic file type. 

4. Press Enter to complete the naming process. 
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Windows Components 
Programs open within the Windows interface as Windows, which can be opened, closed, resized or 
repositioned on the Desktop. Explorer, like other programs opens within a window. Windows will 
have some or all of the following components to allow you to work with them. 

 
• Title Bar � gives the Title of the program, documents or dialog box. When it is bright and 

highlighted it is active. When it is grayed out, another window is active. Click anywhere in 
the window to make it active. Click and hold the left mouse button on the title bar to drag 
the window to a new location on the desktop. 

• Menu Bar � provides tools to work within the program or dialog box. 

• Minimize, Maximize/Restore/Close buttons � Use to minimize, maximize, restore or close a 
window. We will discuss this in the next section below. 

• Scroll Bars � Drag these with the mouse (click and hold the left-mouse button and drag the 
mouse) to reveal contents of the window that are not visible. If the scroll bars disappear, the 
full content of the window is displayed. 

• Resize Triangle � Position the mouse pointer over this small triangle in the lower right 
corner of the window and drag to resize it. 

Title Bar 

Scroll Bars 

Resize 
Triangle

Minimize, 
Maximize/Restore 

Close Buttons 
Menu Bar 
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Changing the Size of a Window 
1. Click on the Maximize       button to make a window fill your screen. Notice that after the 

window is maximized, the Restore button         appears in place of the Maximize button.  

2. Click on the Restore button to restore the window to its previous size. 

3. Click on the Minimize        button. The window will disappear into the taskbar at the bottom 
of your screen. It is now running in the background, which means the program is still open and 
will immediately reappear when you click its button on the taskbar. 

 
 

Switching Between Open Programs or Windows 
If you move the mouse to the bottom of the Desktop, the Taskbar will reveal. Click on the program 
you desire, and the Desktop will switch to the program selected. 

Alt Tab Key 
You can quickly gain access to each program without revealing the Taskbar by holding down the Alt 
key and pressing the Tab key. When you press and hold the keys, the following menu appears 
showing each program running on the task bar. Each time you press the tab key, you toggle between 
programs. If multiple programs are running, hold down the Alt key and press the Tab key until the 
blue square highlights the program you want. Then release both keys and the program will switch. 
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Deko File Types 
Deko uses a variety of file types to save various kinds of data. Each file type is identified by a three-
letter extension. 

• .aut � Automation file, opened or saved from the Automation or Database window. 

• .dko � Graphic file, opened or saved from the Program or Preview window. 

• .efx � Effect file, opened or saved from the Effects window. 

• .fac � Custom typeface, opened or saved from the Custom Typeface window. 

• .mcr � Macro file, opened or saved from the Macro editor. 

• .pst � Preset Style file, opened or saved from the Preset Style window. 

• .mot � Motion files, opened or saved from the Timeline Motion editor. 

• .seq � Sequence file, opened or saved from the Sequence editor. 

• .shd � Shader files, opened or saved from the Shader window. 

• .sty � Style files, opened or saved from the Style window. 

Setting Directories and Paths in Deko 
Deko saves and opens different file types from a directory you specify in the Preferences menu. This 
simplifies file management during operation. We recommend you set up your directory structure for 
saving files before you begin a project. The next exercise will show you how to do this. You can 
always change the directory you wish to save a file to or open a file from. 

The paths tab (Options > Preferences) allows you to assign preferred directories to save various files 
used by the system. The directories are assigned a path from a root directory or drive, with the paths 
noted on the Paths tab of Preferences.  

You can set these paths to 
preferred directories for the Deko 
to use upon program startup. You 
can change these preferred 
directories at any time while 
operating the system, either by 
navigating to a new directory from 
the File > Open menu, or from the 
File > Change Directory menu if 
you are currently viewing an active 
browser window. You can also 
change paths by typing new ones 
directly in the appropriate fields. 
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Exercise � Create New Folders and Subfolders 
In this exercise you will create one new folder on the C drive and four subfolders placed within the 
folder. Use this as an example to consider how you might set up your directories on your own Deko 
system. 

Create New Folder 
1. Click on the C drive in the Directory Tree to highlight it. 

2. Go to File > New > Folder. A folder named New Folder will appear at 
the bottom of the right pane. 

 
3. Click in the highlighted 

Name box and type �News�. 
The news folder will appear in 
the Directory Tree.  

 
4. In the Directory Tree (left window pane), click on the News folder to highlight it. Go to File > 

New > Folder. A new folder will appear in the right window pane.  

5. Click in the Name box and type �5am�. 

6. Repeat step 4 and create the following additional subfolders: �noon, 6pm�. When you are 
finished the subdirectories should look as follows. 





  

Deko Training 

4-1

Lesson 4: Type and Modify Text 

At the end of this lesson, you will be able to use your Deko to type text, change the size and color of 
characters, and add style details. 

Before You Start 
The Window menu provides several options for arranging the current layout of windows and tools on 
your Deko desktop. Most of these layouts include a Program window, which is where you will type 
text. 

The Program window shows the current on-air graphic. The contents of this window match Deko�s 
video output, with the addition of a cursor, safe-title lines and other markers. A Preview window 
shows the same elements (cursor, safe-title lines and markers) as a Program window but may not have 
an associated video output. 

Creating Graphics 
The main function of Deko is the creation and display of graphic files. All graphics are created in a 
Program or Preview window. A Deko graphic can include text and background elements. Once 
created, a graphic may be saved on disk in a graphic file. 

A graphic consists of one or more layers and a background. Each layer can be text or a geometric 
shape � a rectangle or an ellipse. 

Each character of text is rendered in a particular style, which specifies its font and look. Each 
geometric shape is also rendered in a particular look. 

Deko provides a variety of tools for typing, justifying, positioning, sizing and otherwise editing text 
and shapes.  
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The Deko Interface 
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Current Style 
Window 
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Elements of the Deko Interface 
Pictured left is the Style Edit layout, the preferred layout for graphic creation. The elements of the 
layout are the most common tools you will use in creating graphics. Additional tools available to this 
layout and others will be discussed later. 

Menu Bar 
The Menu bar appears in all layouts. The menu selections will vary slightly depending on which 
window is active at the time 

Text Bar 
The Text bar is also available in all layouts. The Text bar allows users to choose and size text as well 
as access and activate the various shaders. You will use them in designing the styles of your text and 
graphic objects. There are also tools for text formatting and text justification. The right side tools are 
used for recording macros. This subject will be covered later in more detail. 

Program Window 
The Program window is the primary graphic creation window. Graphics created in the Program 
window are simultaneously displayed on the video output of the Deko unit. The Program window 
displays with the graphic cursor position, safe area, carriage returns and tab stops. A Preview window 
is also available for graphic creation. The Preview window is identical to the Program window except 
its output may not made available to air depending on how many channels are in the system. 

Style Window 
The Style window is used to define the Style attributes of Text and Graphic elements. The Style 
window provides an interface to change Graphic, Font, Look and Layer attributes. Pressing the 
associated button at the top of the window accesses each attribute control. The attributes are: 

• Font � provides font formatting attributes such as size, width, kerning and leading. 

• Look � allows the addition of detail elements such as face, edge, shadow, underline and frame. 

• Layer � sets layer attributes such as word wrap, scaling and layer justification. 

• Graphic � allows you to link effects files and clips (if you have the ClipDeko option) with 
associated graphics. 

Shader Window 
The Shader window is used in conjunction with the Style window to modify the look of the various 
details. There are six shaders available for adjusting the look of a font or graphic element. They are: 

• Face Shader 

• Edge Shader 

• Shadow Shader 
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• Underline Shader 

• Frame Shader 

• Background Shader 

Clicking on the appropriate Shader button on the Text bar can access each Shader. 

Note: If the current selection does not have a particular detail, clicking on a Text bar Shader button 
will add one. If the current selection already has that detail, clicking on the Shader button will delete 
it. 

The Shader window provides a choice from five fill sources for each Shader element. 

• Color � a solid color fill. 

• Ramp � a color gradient fill. 

• Texture � a graphic file that can be used as a texture fill. 

• Keyhole � a key cutout for external fill. 

• CAP � an option to allow fill from sequential animation files. 

Tools Window 
The Tools window provides a palette of tools used in the creation of graphics. Tools allow you to 
create text layers and graphic elements as well as move and alter their shapes. Many of the tools have 
shortcut keys that you should memorize to speed your productivity. 

Current Style Window 
The Current Style window provides a sample of the current style selection or the style at the current 
cursor position (when Moving cursor sets font and look is selected in Options > Preferences > Cursor 
tab). In the default mode, the style is presented with an upper and a lower case �Aa�. 

Preset Style Window 
The Preset Style window provides a swatch of eight styles that can be quickly used in graphics. Users 
can assign their own preset styles to palettes and save these as .pst extension files. More than one 
Preset Style window may be opened on the screen at the same time. 

Status Bar 
The Status bar provides useful information about the graphic in current view including cursor screen 
position, layer selected, layer position, insert/overwrite mode status, and file size. 

Command Bar 
The Command bar, which you can select to view on your screen, is used to play macro files. This 
component will be covered in greater detail later. 
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Window Focus in the Deko Interface 
The Deko interface provides multiple layouts for the different tasks you may be performing. Each 
layout consists of a number of windows providing the tools for the task at hand. For a window to be 
active, its title bar will be highlighted and in color. Inactive windows have title bars that are grayed 
out.  

 
To activate a window, position the mouse to a point anywhere within the window and click. You can 
also change the window focus by pressing Ctrl + Tab or Shift + Ctrl + Tab. 

Certain windows have hot keys to activate them. Press F5 to activate the Program window and 
Alt+F5 to activate the Preview window. The FAK has dedicated Program and Preview keys as well as 
keys to activate the other tools on the screen. 

Active Window 
Inactive Window 
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Exercise � Type and Alter Text 
1. Go to Window > Select layout > Style Edit, or press Alt+F11. This opens all the tools and 

windows necessary for text creation.  

Note: you should begin to use keyboard shortcuts rather than the mouse to perform operations 
whenever possible. 

 

2. Select the Program window by pressing the Program key (FAK)  
or F5 (SK). Deko highlights the title bar of the Program window to 
show you that the window is active. 

3. Click on the Layer button in the Style window and verify that Word 
wrap is checked.  

4. Click on the Title bar of the Preset Style window to set focus. 

5. With focus set on the Preset Style window, press the Clear + Read 
keys (FAK) or F9 (SK) to bring up the Open File dialog. Select the 
file tutorial.pst and click Open. 

6. From the Options menu, select Save Settings Now. You will be using this setting for exercises 
in the next two lessons. 

7. Select Preset Style 1 in the Preset Style window. 

8. Set focus to the Program window and type your text. Type The quick brown fox
jumped over the lazy dog. If your system has video output, verify that you see the 
same output on the video monitor. 
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9. Select the �g� in dog by placing your I-beam to the left of the �g� and pressing Shift + right 
arrow.  

• Locate the up/down arrows next to the size field on the Text bar. 

• Click either arrow to change the size of the selected character. If you hold an arrow button 
down the font size numbers will automatically advance. You must release the arrow to see the 
character in the new size. 

 
10. Double-click the word lazy to select it. Triple-click to select the entire row. Try it.  

11. Click on Style 6 from the Preset Style window. If you have a FAK, use the Preset Style buttons 
to select the style.  

Size field. 
Use up 
arrow to 
increase. 

Text bar 

Preset 
Style 

window

Click once 
to select 

look 

Selected 
word in 

new style
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You should see the selected word change immediately to the look of Preset Style 6. 

Congratulations! You have successfully set up your screen in the proper layout for text creation, 
entered text in the Program window, resized text, and given text a new style. 

Navigating the Cursor and Selecting Text 
As we saw in the previous example, selected text can be resized and have new styles applied to it. 
Understanding the mechanics of this process is essential to working productively with Deko. The 
system provides easy methods with either the mouse or the keyboard to quickly navigate the cursor 
and select text. 

Home and End Key Behavior 
Go to Options > Preferences and click on the Cursor tab. The lower 
right quadrant of the tab provides an option to determine how your 
keyboard Home and End key will behave. The behavior is as follows: 

Character Generator 
• Home moves the cursor to the beginning of a text field. 

• End moves the cursor to the end of a text field. 

• Ctrl + Home moves the cursor to the beginning of a line. 

• Ctrl + End moves the cursor to the end of a line. 

Windows 
• Home moves the cursor to the beginning of a line. 

• End moves the cursor to the end of a line. 

• Ctrl + Home moves the cursor to the beginning of a text field. 

• Ctrl + End moves the cursor to the end of a text field. 

Choose the one that works better for you. If you have no preference, choose Character generator.  

Note: for the rest of this document, we will refer to Home and End key behavior using the Character 
generator standard. If your machine is set to Windows, make adjustments accordingly. 

Cursor Selection 
Deko provides two cursors, the I-Beam cursor and the Box cursor. The I-beam is placed to the left of 
a character to be selected with the shift + right arrow key. The Box cursor places a box around the 
character to be selected with the shift + right arrow key. It is important to distinguish the difference 
between a box cursor around a character and a character that has been selected shown in the third 
example below. 
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Setting the Text Cursor 

To set the cursor, go to Options > Preferences and in the dialog box select the Cursor tab. Choose 
your preference. For the remainder of this document we will use the I-beam 
cursor. If you are more comfortable with the box cursor, choose it. 

Moving the Cursor 
You can reposition the cursor by positioning the mouse and clicking at the 
place where you want it. This will place the cursor at current mouse position. 
Use the keyboard arrow keys to move the cursor a character or row at a time.  

• Left or right arrow keys move the cursor a space at a time.  

• Up or down arrow keys move the cursor a row at a time.  

• Ctrl + Left/Right arrow moves the cursor a word at a time. 

Selecting Characters 
You can select characters with either the mouse or the keyboard. To 
perform character selection: 

• Press the Shift key and move the arrow keys. 

• Drag the mouse.  

This operation places a bounding box around the selection. If the bounding box contains characters 
or words not selected, the characters selected will be noted with a row of dotted lines (otherwise 
known as measles) across the face of the selected text. 

Correct selection 
of character 

I-Beam cursor-  
no characters 

selected 

Box cursor-   
no characters 

selected
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More Selections 
To select a word, position the cursor over the word and double-click. 

To select a row, position the cursor anywhere on the line and triple-click. 

To select all the text in a Layer, do one of the following: 

• Press Ctrl + Shift + A (recommended). 

• From the top left of the text, drag the cursor across and down to the lower left quadrant of 
the text. 

• Press the Insert key to select Overwrite and press the Tab key. 

• Go to Edit > Select Field (Alt + E > I). 

To select multiple Blocks of Text, which can be useful if you wish to isolate parts of a field only 
selecting certain characters or words, do one of the following: 

• Hold the Ctrl key down as you drag. Release 
the mouse button and Ctrl key as you 
position for the next selection. Then repeat 
the process. The example right shows three 
characters selected. 

• Go to Edit > Select More. Move the cursor with the arrow keys to position for selection. Hold 
down the shift key and use the arrow keys to make a selection (recommended). 

To select all text characters in the Current Style: 

1. Position the cursor next to a character of the 
style in question so that the style shows in the 
Current Style window.  

2. Go to Edit > Select Style (Alt + E > Y) or  
(Shift + Ctrl + S). 

To select all text from all Layers in a Graphic, do one of the following: 

• Choose Select All from Edit menu. 

• Press Ctrl+A. 

To De-select text, do one of the following: 

• Click anywhere in the text field. 

• Press any arrow key. 
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Selected Text versus Current Style 
It is important to understand the difference between selected characters and the Current Style. If you 
select some characters and then change the size value, Deko will scale the selected text. If you change 
size when no characters are selected, this changes the Current Style. So be aware that you must select 
characters before making changes to their text properties. Otherwise, you are setting the properties of 
the next character to be typed. 

Note: Changing selected text may not permanently change the text field attributes unless the new 
line position is selected (indicated by a triangle marker). When you desire to change the text in a 
field, use Ctrl + Shift + A to guarantee all of the text is selected. 

Modifying Selections 
Text is selected so it can be modified. Modifications can include resizing or repositioning text, 
changing the font or changing the look of a font. When we change the look of a selection, we are 
changing its style. A style is defined as a font plus the font�s look.  

Styles 
The font is specified by its name, size and kerning characteristics. Its style is defined as the elements 
that give the font shape and color. Style elements are described as details. Each detail has a look that 
is defined by the Shader settings. Detail elements include: 

• Face � the fill elements of a font. 

• Edge � outline of any other detail. 

• Shadow � drop or deep shadow of a detail. 

• Underline � of a given detail (including frame). 

• Frame � of the detail. 

Styles can be saved individually from the Style window, or they can be added to a Preset Style 
window and saved in groups of eight. The current style determined by style selection or cursor 
position is visible in the Current Style window. 

Steps in Creating a Style 
1. Select a font. 

2. Set Font parameters including Size, Leading, Kerning, Rotation and Skew from the Text bar or 
in the Font dialog of the Style window. 

3. Add Details from the Look dialog in the Style window or by clicking the appropriate detail on 
the Text bar. 

4. Adjust Detail settings in the Shader window. 
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Selecting or Changing Typefaces 
To change a font (typeface): 

1. Select the text (Ctrl + Shift + A). 

2. On the Text bar, click on the arrow and scroll to the desired 
font and click on it. This will change the current font setting. 

To change a font size: 

3. Select the text (Ctrl + Shift + A). 

4. To change the font size, click on the arrows of the size box to 
increment the size, or type a value into the size box and press 
enter on the keyboard. 

Style Window 
To change a font or font size using the Style window: 

5. Click on the font button in the Style window to bring up the font parameter dialog box. 

6. Use the Typeface list menu in this dialog box or click on the Browse button 
in the window to reveal the Typeface Browser.  

This browser reveals a window with samples of available typefaces. Scroll to a desired typeface 
and double click on it. The window opens as a single column of typeface icons. You can resize 
this window to any size up to screen maximum to show more fonts. 

Keyboard 
The FAK has a dedicated key for the Typeface Browser. On the SK, type Ctrl + L to open the 
browser, then select File/Browse Typefaces (Alt + F > F). 
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Changing a Typeface 

 

Adding Details 
Deko allows you to control the look of your font by adding details. Details define the overall look of 
the font, such as face, edge and shadow attributes. Deko allows you to determine how many of these 
details you wish to add to a font and gives you great flexibility in assigning priority and attributes to 
these details. 

To add a detail to your text: 

1. Select the text you wish to modify. 

2. In the Style window, click the Look button. Choose Add 
and then select the detail from the reveal window. 

Typeface 
Drop-down 

list 

Selected text 
to change 

Current 
Style 

window 

Typeface 
Browser  
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Modifying Look Details 
Each detail has a list of attributes that can be altered. To change a detail attribute, 
click on the detail in the Look view of the Style window. The attributes for that 
detail are displayed at the bottom of the window. In addition, clicking on a detail 
will select that detail element in the Shader window. Modifying a detail involves 
setting attributes in both the Style and the Shader windows. 

Detail Attributes 
All details have Hide, Shader and Blur attributes. Edge, Shadow, Underline and Frame details have 
other specific attributes. 

Face Attributes (Common to All Details) 

• Hide � click to hide detail from view. This is useful when 
setting up a look with multiple details, to distinguish one from 
another. 

• Shader � shows a sample swatch of the current Shader Setting for 
face. 

• Blur � sets a blur adjustment on the selected detail from 0 (no 
blur) to 100. 

Edge Attributes 

• Shape � defines the shape of the blur edges, either round or 
square. 

• Type � there are four types of fill: 

� Outer � borders the outer edge of the previous detail. 

� Inner � borders the inner edge of the previous detail. 

� Border � fills the outer and inner edge of the previous detail. 

� Filled � fills a solid edge placed behind the previous detail. 

• Size � the width of the edge from 0 (no edge) to 100. 

Outer 

 

Inner Border Filled 
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Shadow Attributes 

• Angle � sets the angle of the shadow in degrees. 

• Type � there are two types of shadows: 

� Drop � creates a single shadow of the detail being shadowed. 

� Deep � creates a thick shadow that appears to be extruded. 

• Distance � controls the distance of the shadow from the shadowed detail(s). 

Underline Attributes 

• Shape � like edge, controls the shape of the underline edges, either 
square or round. 

• Height � controls the height of the underline. The default value is 
100. 

• Width � provides an option to make the underline wider than the 
actual text. A value of zero matches the width of the text. 

• V offset � specifies a vertical offset from the underline�s normal 
position. Negative values move the underline down, and positive 
values move it up. 

• Spaces � when checked, underlines the spaces between words. 

Frame Attributes 

• Shape � produces a rectangle with either square or rounded 
corners. 

• Height � specifies the height of the frame. 

• Width � specifies the width of the frame. 

• H offset � offsets the frame horizontally relative to the detail being 
framed. 

• V offset � offsets the frame vertically relative to the detail being 
framed. 

• Descenders � when checked, lowers the bottom of the frame to 
accommodate lower case descender characters like g, j and y. 

• Spaces � when checked, underlines the spaces between words. 

Drop Deep 
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Priority Controls 

Each Detail has a priority attribute control to determine how it will be laid out in 
relation to other details. By clicking the more button, you will reveal the priority 
controls. 

• Priority � determines whether the detail appears in front of or behind 
other details. By default, Deko assigns a priority to each detail so that 
they render from front to back, in the order they appear in the Details 
list. Use Priority to change the rendering order. Priority ranges from 0 
(closest to viewer) to 1000 (farthest from viewer). Priority also controls 
the rendering order of overlapping details from different styles. 

• From previous detail � specifies which other details in the look provide 
the shape on which this detail is based: 

� Face � produces a detail based only on the face detail. 

� Previous � produces a detail based on the To next detail setting of the item immediately 
above the current detail in the list. 

� Frame � produces a detail based on the first frame above the current detail in the list. 

� Underline � produces a detail based on the first underline above the current detail in the 
list. 

• To next detail � determines what this detail will send to the detail immediately below it in 
the list: 

� Previous � sends whatever was sent to the current detail from the detail above it. 

� This � sends the current detail. 

� Merged � sends the combination of the current detail and whatever was sent to the 
current detail from the detail above it. 
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Shader Controls 
To apply color to text or graphics, Deko uses a Shader.  

Each detail in a look (face, edge, frame, shadow or underline) has its own shader. The shader 
determines how color is applied to the detail. 

Each detail can be filled with colors from five different shader options: 

• A color shader produces a detail with a single, solid color. 

• A ramp shader produces a detail with a four-color ramp and an optional highlight. 

• A texture shader produces a detail with a bitmap texture. 

• A keyhole shader produces a key cutout that can be replaced with video from an external key 
source. 

• A CAP shader (option) allows the inclusion of sequential animation files as a fill source 

Note: CAP shader can only be used with a rectangle or circle or as fill of a single letter, not as 
fill of a text field. 

Any detail can have any kind of shader. For instance, a face can have a color shader, an edge a ramp 
shader, and a shadow a texture shader, all within a single look. 

Multiple occurrences of the same type of detail within a look do not have to have the same type of 
shader. For example, a look with three edges can have a different shader for each edge. 

You can use the same type of shader on multiple details within a graphic. In addition, each graphic�s 
background has its own shader. Using the background shader, you can make a solid, ramped or 
textured background for any graphic.  

Shaders are specified in the Shader window (F7). Any shader can be stored as a preset shader. The 
preset shaders can be saved in an .shd file for future use. 

Activating a Shader 
To activate a shader for the current look�s first face, edge, shadow, underline or frame, click the 
appropriate detail shader button on the text bar. 

 

Note: If you click the shader button for a detail that is not in the Details list, Deko automatically 
adds the detail. 

You can activate the shader for a detail in the current style also by activating the Style window and 
clicking on any detail in the Details list box. 

       face          edge      shadow    underline    frame
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Background Shader 
To activate the background shader, click the background-shader button (Ctrl+F7) on 
the text bar.  

Shader Controls  

 

The Shader window allows you to quickly adjust colors or other parameters for a given detail. 
Pictured above is a Face Shader with the current shader type set to Color. The following tools are 
provided to set a color: 

• Shader Type buttons � chooses the type of detail fill from among the five choices. 

• Current Detail Color � shows current color of selected detail. 

• Color Space Selector � chooses the current color space. The choice will affect the view of the 
color picker palettes. The choices are: 

• RGB � Red, Green, Blue color space. 

Shader Type 

Current Detail 
Color  

Unselected 
Components 

Selected 
Component 

Selected 
Component Bar 

Eye Dropper 

Current Color 
Pick 

Shader Detail 

Illegal Color 
Indicator 

Color Space 
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• HSV � Hue, Saturation, Value color space. 

• Selected Component � sets the component to be adjusted in the Selected Components bar. 

• Unselected Component  � the large color palate display square displays the two remaining 
unselected components in a horizontal/vertical grid. In other words, if (as above) Value is the 
Selected Component, the square shows Hue along the vertical axis and Saturation along the 
horizontal axis. If Opacity is the Selected Component, Deko displays a gray scale in this 
square. 

• Current Color � shows the current color selected in the color picker. The color is indicated in 
the picker by a crosshair marker at its position. 

• Illegal Color Indicator � if a color chosen is out of the legal range of NTSC colors, the illegal 
color indicator will turn red. Clicking on the indicator will move the color to the nearest 
legal color. 

• Eye Dropper Tool � allows the selection of a color from anywhere on the desktop. To capture 
a color, hold the mouse button down and drag it over the desired color, then release it. The 
color will be deposited in the current color selection. 

To Change the Color of a Selected Detail 
1. Choose the selected component to adjust the color picker window 

(HSV and Value are a good starting point). 

2. Click in the palette window to choose the desired color. Note the 
color in the current color selection. 

3. Right-click the Color button to transfer the color to 
the detail. 

Preset Shaders 

 
The 18 Preset Shader buttons appear at the bottom of the Shader window. You can use these shader 
buttons to save your favorite shader settings. Any type of shader may be assigned to any preset. You 
can save the Preset Shaders to disk for later retrieval. 

• To use a Preset Shader, left-click the desired shader and its settings will be deposited in the 
current shader settings.  

• To save a current shader setting to Preset Shaders, right click on any of the 18 Preset Shader 
buttons and the current setting will be deposited on that button. 

Left-click to 
use a preset 

shader 

Right-click to 
save current 
shader as a 

preset 
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• To save current Preset Shader settings, click on the Shader window and choose Save As from 
the File menu or press F12 (SK) or Save File (FAK). Enter the name for the file and press 
Enter.  

Note: Deko will automatically add the extension .shd to the file. 

Ramp Shader  
The Ramp Shader allows you to create color gradients with or without highlight details. The four 
buttons represent the individual color quadrants of the gradient. In addition, a check box with a fifth 
color box is added to create a highlight detail across the gradient. Color selection for each of these 
boxes works the same as with the Color Shader. 

Once colors are applied to the gradient, click on Options to select the 
way your gradient is applied to text. The following options are 
available: 

• Group � determines how the ramp will be applied. 

� letter � applies the ramp to each letter. 

� word � applies the ramp to each word. 

� row � applies the ramp to each row of text. 

� page � applies the ramp to the entire page of text. 

• Opacity � controls the overall transparency of the ramp on top 
of any transparency controls applied to individual colors in the 
ramp. 

• Ramp Options  

� H Scale � the width of the ramp relative to the group. For 
setting less than 100 percent, only part of the ramp is 
applied. 

• V Scale � the height of the ramp relative to the group. For 
setting less than 100 percent, only part of the ramp is applied. 

Choose colors for 
gradient buttons 

by selecting 
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• Hilite Options 
� Size � of the ramp in percentage relative to height of the ramp. 

� Angle � expressed in degrees (-360 to 360); an angle of 0 produces a horizontal line. 

� H Offset � specifies the horizontal position of the highlight relative to the ramp. 
Negative numbers move it to the left, positive values to the right. 

� V Offset � specifies vertical the position of the highlight relative to the ramp. Negative 
values move it down; positive values move it up. 

Texture Shader 
The Texture shader allows you to apply a graphic file as a detail fill. 
Textures can be .dko files as well as a variety of popular graphic files 
including .jpg, .tga, .bmp and .tif files. Any graphic can act as a 
fill.  

When the File name box is checked (default) Deko links the graphic file 
as a texture, but does not actually save or render the file to the graphic. 
This allows you to change textures at a later time. 

Texture Shader Options 
• File Name Check Box � if this box is unchecked, Deko copies 

the bitmap from the original texture file and saves it as part of 
the graphic. The word unnamed appears in the File Name text 
box to indicate the texture is being stored with the graphic.  

Note: choosing this option will increase the size of the graphic 
and will preclude modifications to the texture when editing 
the original source files. 

• Group � specifies how the ramp should be applied: 

� letter � applies the same texture to each letter. 

� word � applies the same texture to each word. 

� row � applies the same texture to each row of text. 

� page � applies the texture to the entire page of text. 

• Opacity � controls the texture�s opacity, from zero (transparent) to 100 (opaque). 

• Auto Scale � scales texture based on the group setting. Works in conjunction with specific 
horizontal and vertical scaling. 

• Replace � tags the texture for replacement with a user-specified texture. 

• H offset � offsets the texture relative to its horizontal alignment. 

• V offset � offsets the texture relative to its vertical alignment. 
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• H Alignment   

• left � aligns the left edge of the texture with the left edge of the group. 

• center � aligns the center of the texture with the center of the group. 

• right � aligns the right edge of the texture with the center of the group. 

• V Alignment   
� top � aligns the top of the texture with the top of the group. 

� middle � aligns the middle of the texture with the middle of the group. 

� baseline � aligns the middle of the texture with the baseline of the group. 

� bottom � aligns the bottom of the texture with the bottom of the group. 

Keyhole Shader 
Clicking the Keyhole Shader button allows you to apply a key cutout to a detail. By applying an 
external fill source (from your switcher or other source) you can fill a detail element with live video.  

To Apply a Keyhole: 
1. Select a detail�s Shader. 

2. Click on the Keyhole button. When the button is selected, the Current Style 
window will display the detail with a keyhole fill pattern indicating the key. The Detail Shader 
button on the text bar will display it as well. The text detail will appear as a dull gray color in 
the Program window. In your output monitor, the detail will display Deko�s current input 
source. If there is none, a noisy green will display. 

Keyhole 
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Text Face 
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The CAP Shader (Option) 
The CAP Shader allows you to apply prebuilt animation sequences to a 
detail. Animation sequences are built from a sequence of cels that are 
made up of individual graphic files, often .tga files.  

Note: For animation sequences, each file (cel) within the animation 
should be named with successive cel numbers, such as globe001.tga, 
globe002.tga, globe003.tga… 

Typically, the CAP shader is applied to rectangles to allow animations 
to be incorporated into graphics. A Deko graphic can support more than 
one animation, but performance may degrade if there are large 
animations or lots of details in one graphic. To apply an animation file 
to a graphic: 

1. Enter the File Name or click Open to browse to the file location. 
Enter the name of the first file in the sequence. 

2. Specify Number of Frames � the number of cels (files) to play. 
Deko defaults to a number based on the assumption that the 
animation ends when it encounters a file name that breaks the 
sequence of numbers. 

3. Indicate Play direction by checking forward or backward. 

4. To play the animation in a continuous loop, click Continuous. 

5. To change the direction of the animation each time it plays click Oscillate. 

6. Enter the frame rate at which you wish the animation to play back. 

Note: Playing an animation file involves using the Motion editor. CAP 
Shaders will be covered in Lesson 17. 

The Graphic Browser 
The Graphic Browser, like the Typeface Browser provides a window with 
sample picons of available graphics in a given directory. The window opens 
as a single column of graphic Picons; you can resize this window to any size 
up to screen maximum to show more graphics. The graphic browser can be 
accessed the following ways: 

• Press Ctrl + L (SK) or Browse Graphics (FAK)  

• Goto View > Browser. 

• Click on the Browse button in any Shader when Texture is selected. 

Pressing Page Up or Page Down keys will advance or reverse one page of 
picons at a time within the browser. To advance to a particular graphic 
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type the first letter of the graphic title. The browser will advance to the first graphic with that letter. 
Scroll forward to find your graphic. 

Viewing Import Files in the Graphic Browser 
The Graphic browser defaults to viewing 
.dko files. To view non-native Deko files: 

1. Set focus to the Graphic Browser 

2. Go to File > Change Directory. The 
Change Directory dialog box appears. 

3. Choose the file type you wish to list 
from the List Files of Type drop-down 
menu. 

4. Click OK. The Browser will view files 
of the specified type. 

 

Note: Do not choose All Files, or picons of all file types in the directory will be created (including 
text and other Deko file types) which could make a graphic search very difficult 

Copying, Cutting, and Pasting  
Once you have defining the look of a given detail, you can copy or cut the parameters of that detail 
and paste them to text elements. The keyboard shortcuts for copy, cut and paste are the same as for 
all Windows programs: 

• Ctrl + C � Copy 

• Ctrl + X � Cut 

• Ctrl + V � Paste 

The keyboard shortcuts are the quickest way to perform this 
operation. As an alternate, you can use the Edit menu selections 
for Cut, Copy and Paste, or use the Tool 
Buttons:  

 
Copy Cut Paste 
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Copying, Cutting, and Pasting Looks 
When a Style window is active, Cut, Copy and Paste acts on Details. Use this when you want to 
Copy and Paste details from one Style to another. 

To Copy and Paste a Look: 
1. Select text whose look you wish to copy. 

2. Go to Edit > Copy > Look. 

3. Select the Text or position the cursor where you will apply the new look. 

4. Go to Edit > Paste Look or type Ctrl + V. 

To Cut or Copy and Paste a Detail: 
1. Select the text element that contains the style you wish to copy. 

2. Activate the Style window. 

3. Choose Look at the top of the window and select the detail you wish to copy from the Details 
list.  

4. Type Ctrl + C (copy) or Ctrl + X (cut) to copy or cut. Cut removes the detail. Copy leaves the 
detail intact but copies it to the clipboard so it can be pasted to another element.  

5. Select the text element you wish to paste details to. 

6. Click on the detail in the Details list where you wish to insert the copied detail. 

7. Type Ctrl + V to paste the detail. 

Styles 
Styles are the combination of a font plus a look. As you have just found out, setting up a style can be 
a time-consuming operation. Deko allows you to save your work as individual styles that can be 
recalled as desired. Styles can also be combined on Preset Style windows that combine eight styles 
together. These are accessible simply by clicking on a style button or pressing the Style buttons one 
through eight on the FastAction Keyboard. 

Once you have selected and adjusted your font and have defined its look with the Style and Shader 
windows, you can save your completed fonts for future access. 

To Save a Style: 
1. Make sure the style is visible in the Current Style window. 

2. Click on the Style window. 
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3. Select Save As from the Edit menu or press F12 (SK), Save File (FAK). Enter the name of the 
style and press Enter. 

Note: Recommended practice is to save styles to a preset palette, .pst file rather than be saved as an 
individual style. 

Preset Style Windows 
Preset Style windows allow you to conveniently save up to eight styles at a time, and you can save as 
many Preset Style windows as you like. Each is saved with a .pst extension.  

 

To Assign a Style to a Preset Style Window: 

1. If the Preset style window is not in view, go to View > Preset Styles. 

2. In the graphic window, click on the desired style so it is visible in the Current Style window. 

3. Right-click on a Preset style button. 

You can also pick up multiple styles from a graphic window and assign them all to preset style 
buttons. To do this, activate a graphic window. Then choose Pick Presets from the Text menu. Deko 
assigns each style in the graphic to a Preset Style. 

To save a Preset Style window: 

4. Click on the window to activate it and go to File > Save As or press F12 (SK), Save File (FAK). 

5. Enter the name of the style and press Enter. 

To open a Preset Style window: 

6. Click on the preset style window and go to File > Open (SK: F9, FAK: Clear + Read).  

7. Navigate to the drive or folder holding the .pst file you are looking for. Click on it and click 
OK or press enter. 
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Saving a Pre-Rendered Style 
Pre-rendered styles occupy more disk space than a normal style file.  

Pre-rendered styles are indicated at the bottom of the Style/Font window by a check next to Pre-
rendered Style, and in the Preset Style window by an (r) in front of the typeface name. 

To save a style as a pre-rendered style: 

1. Activate the Style window (F6). 

2. Go to > Render and Save Style.  

3. When the Render and Save dialog box appears, 
navigate to the drive and directory you wish to store 
the file in. 

4. Type a file name in the File Name field, then click 
OK or press Enter. 

Note: FX Deko software and hardware has substantially improved in performance, and current 
releases show no difference in performance between normal style files and pre-rendered styles. 
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Exercise � Modify Text 
1. Select Font in the Style window.  

2. Click the Typeface drop-down menu and choose a font by name.  

 

To Add an Underline to Your Text: 
1. Select the text you wish to underline.  

2. In the Style window, click the Look button.  

3. Choose Add, then underline. 
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To Change the Color of Your Text: 
1. Select the text you wish to change. 

2. Select Look in the Style window, choose Face from the Details list, and then click the Shader 
button. 

3. In the Shader window on the right side of your desktop, a Color button indicates the current 
color of your text.  

 
4. Position the cursor in the lower color palette area of the window and (left) click the desired 

color to pick it up. Notice that nothing changes because you have not yet applied this color to 
the color button above.  

5. Right-click the Color button to drop in the new color. You will see the selected text change 
immediately to the chosen color. 

 

Note: left-click picks a color while right-click applies the selected color. 
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Shortcut Keys 

General Desktop Controls 
Switching programs Alt + Tab 
Changing active window Ctrl + Tab 
Selecting Program window F5; FAK: Program 
Selecting Preview window Alt + F5; FAK: Preview 
Select Style Edit window Alt + F11 
Open Text Browser window Ctrl + L; FAK: Typeface 

Browser 
Select Style Look window FAK: Look 
Select Style Font window FAK: Font 

Moving Cursor 
Left or right one character Left/right arrow keys 
Up or down one row Up/down arrow keys 
Left or right one word Ctrl + left/right arrow keys 
Move to beginning of field Home 
Move to end of field End 
Move to end of row Ctrl + End 
Move to beginning of row Ctrl + Home 

Selecting Characters 
Select word Double-click mouse 
Select row Triple-click mouse 
Select to end of field Shift + End 
Select to beginning of field Shift + Home 
Select all text in layer Ctrl + Shift + A 
Select all text in graphic Ctrl + A 
Select multiple blocks of text Ctrl Drag 
Select style Shift + Ctrl + S 

Cutting, Copying and Pasting Details, Styles, Graphic Elements 
Cut element Ctrl + X 
Copy element Ctrl + C 
Paste element Ctrl + V 
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Lesson 5:  Working with Layers and Tabs 

Deko allows you to define an area where text will be entered along with the style that will be applied 
to that text. This area is referred to as a text layer. Layers are important to the operation of Deko and 
your knowledge of them will expand in the following lessons. Text layers are equivalent to, but more 
flexible than the tab layers in other CGs. 

All Deko graphics are made up of a combination of a background and one or more layers. Layers can 
contain text, ellipse shapes, or rectangles. When a new graphic is created, it opens with a default 
background (usually black), which is determined in your Preference settings, and a default text layer, 
which occupies the safe title area of the screen. 

Creating Additional Layers 
The Tool window provides three tools that can be used to create additional layers. Layers can be: 

• Text layers � created with the Text layer tool. 

• Rectangle layers � created with the Rectangle layer tool. 

• Ellipse layers � created with the Ellipse layer tool. 

Creating a Text Layer 
1. From the Tools window click on the Text layer tool. 

2. Position the cursor placing it in the upper left corner of where you want the 
new text layer to go. Notice that the cursor over the Program window changes. 
You should see a pointer with an I-beam denoting that this is a Text layer.  

3. Click and drag the cursor down to the right until you have a rectangular outline the size of your 
desired text layer, then release the mouse button. You should now have two layers in your 
graphic, the default layer, and a second text layer representing the smaller rectangle. 

Note: The process of creating a shape layer (rectangle or ellipse) is basically the same. Select the 
appropriate tool. Position the cursor and drag till the desired shape is produced. We will discuss 
shape layers a little later. 

Moving and Resizing a Text Layer 
To change the size and position of a text layer you use the Move tool. To select the Move tool, do one 
of the following: 

• Click on the Move tool in the Tool window. 

• Press Ctrl + M (SK) or Move (FAK). 
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To Move a Text Layer 
1. Move the mouse so the cursor is over the edge of the text layer. 

2. Left-click to select it (SK) or Page Up or Down (FAK). The text layer outline will turn black, 
and eight small gray squares will appear on the outline, one on each corner, and one in the 
middle of each line. These handles are used to resize the layer. 

3. To move the layer, place the cursor on one of the black lines, but not near one of the squares. 
Click and hold the left mouse button down. A crosshair pattern cursor appears. Drag the layer 
to the new location. 

Note: You can also move the layer by selecting it and using Alt + Arrow Keys. Up/Down or 
Left/Right. Ctrl + Spacebar will toggle between Coarse (10 pixels) and Fine (1 pixel) movements. 

To Change the Size of a Text Layer 
1. Position the mouse so the cursor is next to one of the handles and click. Then do one of the 

following: 

• Place the cursor near one of the centered box handles will allow you to adjust the width or 
height of the layer. The cursor will change to an up/down arrow or a left/right arrow. 

 
• Placing the cursor near one of the boxes on the corners will allow you to resize both height 

and width together in a diagonal movement. The cursor will change to a diagonal arrow 
pointer. 

2. Click and drag to resize the layer. 
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Layers vs. Fields  
The Deko interface often uses the term Layers. Some users refer to a layer as the physical boundaries 
of an object in the graphic. Others refer to a field as the content inside of a layer. Actually the terms 
are synonymous and interchangeable.  

To Enter Text 
To enter text, simply begin to type. When you begin to type an I-beam (or box cursor) appears at the 
beginning of the layer and moves as you type your text. 

Note: If there are multiple layers in the graphic press the Tab key to select the layer to which you 
wish to enter text. Each time you press the Tab key you will advance to the next layer in text context.  

To select a text layer for moving or resizing, press Page Up or Page Down to toggle through the 
layers for selection. 

Note: Pressing Page Up or Page Down will toggle through all of the layers in a graphic (including 
shape layers). Pressing the Tab key (or Shift + Tab) will toggle only through text layers. Using the 
Tab key can save time selecting a layer if there are several shape layers in a graphic. When a layer 
contains Tabs, the Tab key will not jump to a new layer (it will jump to the next tab in the layer). To 
select another layer, you must press Page Up or Page Down. 
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Exercise � Entering Text and Adjusting Layer Attributes 
1. With the Text layer tool selected, create a new text layer in the lower-third position. 

2. Select a style from the Preset Style window and set the font size at 60 points. 

3. Click on the Style window, then click the Layer button. This will reveal the Layer attribute 
settings.  

4. Make sure Word wrap is not selected. 

5. Set focus to the Program window. 

6. Enter text and type a name that moves beyond the boundaries of 
the layer. 

 
7. Click on the Word Wrap checkbox. Notice that the second word in  

the layer moves below the layer boundaries. 
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Word Wrap Preferences 
It is often preferable to leave the Word wrap setting off and only turn it on when you need word 
wrap for specific graphics. To change the Word wrap setting: 

1. Go to Options > Preferences and choose the Advanced tab. 

2. Uncheck the Word wrap box and click OK. 

 

Auto-scaling 
The Auto-scaling feature allows you to have layers automatically size or scale text to fit. This is 
especially useful in templates for graphics such as lower thirds where names can vary in length but 
must fit within a given screen area. The Auto-scaling feature has three settings: 

• None � no auto-scaling. 

• Scale to fit box � scales text vertically and horizontally to fit 
within the layer boundaries. 

• Shrink to fit box � shrinks text on the horizontal to fit within 
the layer boundaries. 
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Exercise Continued � Adjusting Auto-scaling 
1. Uncheck Work wrap. 

2. Click Shrink to fit box in the Auto-scaling section. Notice that the text shrinks horizontally to 
fit within the layer boundaries. 

3. Now Click the Scale to fit box. Notice the different shape to the text. With Scale to fit box, the 
text sizes to fit both horizontally and vertically. 

The Move Tool � Moving a Layer vs. Moving Text 
In previous examples, we used the Move tool to change the size and/or position of the layer. As we 
demonstrated in the example, changing the size or shape of the layer did not alter the size or shape of 
the text unless an auto-scale selection was chosen. The Move tool can also be used to alter text within 
a layer; however within the layer the tool acts somewhat differently. 

Moving Selected Text 
When text is selected within a layer, a selection bounding outline borders the selection with eight 
small selection handles surrounding the selection.  

1. Place the cursor near the outline so that the crosshair cursor appears.  

2. Click and drag the text to a new position. The position of the selected text will change in 
relation to other text elements within the text layer. 

3. Place the cursor near one of the eight selection 
handles so that the cursor becomes a scale tool. 
Notice that the text scaling changes. Also notice the 

size and width indicators in the Font tab/Style 
window change. 
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Moving Text with the Keyboard 
You can also move selected text with the keyboard, press Alt + Arrow keys to move in four potential 
directions. Ctrl + Spacebar toggles between Fine (1 pixel/line) and Course (10 pixels/lines) 
movement. This works when moving layers and objects as well. 

Note: Moving text within a layer is not the recommended practice. Moving one word within a layer 
of many may be confusing. We suggest that you make the word it�s own layer so as not to affect the 
position of other words. To do this select the word and type Alt + T>F. 

Scale, Rotate, Skew, Kern and Justify Controls 
Deko provides tools to enable easy scaling, rotating and skewing text. With the Justify controls, text 
positioning on the screen is easily adjusted. As with the Move tool, there are keyboard equivalents for 
all of these adjustments. These actions take on slightly different characteristics when applied to an 
entire layer vs. to selected text within the layer. Let�s examine each of these attributes.  

Scaling Text and Layers 
To change the size and position of selected text within the layer use the Scale tool. To select the Scale 
tool do one of the following: 

• Click on the Scale Tool in the Tool window  

• Press Ctrl + W (SK) or Scale button (FAK) 

When text is selected within the layer, and the Scale tool is selected, the mouse works exactly as it 
does with the Move tool selected. 

• When the cursor is placed next to a bounding outline, the crosshair cursor appears. Dragging 
the mouse will move the text. Try it. 

• When placing the mouse near one of the selection handles, the pointer becomes a scaling tool 
and dragging the text will scale it. Notice that the text size and width attributes change in 
the Style window. 

• Hold down the Alt key and press the arrow keys. Notice the text does not move but rather 
changes in size. Also notice the scaling attributes change in the Font/Style window.  

Type Ctrl + Spacebar to change the settings between Course and Fine when making the 
adjustments. Press and hold Ctrl down when you drag to preserve aspect ratio. 
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To Scale a Layer 
1. Click on the Scale tool in the Tool window or type Ctrl+W (FAK: Scale). 

2. Select the layer. 

3. Position the pointer over a handle on any side or corner of the layer so that the pointer becomes 
a scaling tool. 

 
4. Drag to scale the layer. Notice that when you scale a layer, the size 

and width indicators for the font do not change within the Style 
window.  

Press and hold Ctrl when you drag a corner to retain the Layer 
aspect ratio. 

5. Click on the Layer window and click the More button. 

6. Scale the text and observe the transform section in the window. Notice the H and V Scale 
changes and the H and V Origin changes. 

To scale a layer with the keyboard, select the layer and then press Alt + the arrow keys. 

Note: It is important to remember that scaling selected text within the layer will change the font size 
attributes, while changing the scaling of a layer itself will leave font attributes unchanged but will 
change the Scale attributes of the layer itself. This is because Scaling a layer is a post process; that is, 
the layer attributes are applied to the layer after text attributes are applied.  Where this becomes 
important is when you wish to note attribute changes for additional graphics or restore attributes to 
their original values. 

Rotate and Skew 
The Rotate tool allows you to both rotate and skew selected text or layers. Rotate and skew apply 
differently to selected text and selected layers. With selected text, the adjustment is applied to Text 
attributes, while with selected layers, the adjustment is applied to Layer attributes. 
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To Rotate Selected Text 
1. Click on the Rotate tool button         or type Ctrl + R (FAK: Rot/Skew) 

2. Position the pointer near the bounding outline of the selected text so the pointer becomes a 
rotation tool.  

3. Drag to rotate the text. In the Style window under Font, notice the change in the rotation 
setting. Notice also that the text leaves the boundaries of the layer outline. 

To Skew Selected Text 
1. Click on the Rotate button or type Ctrl + R. 

2. Position the pointer over the top-right-corner handle of the selected text so the pointer becomes 
a skew tool. 

3.  Drag to skew the text. Again, notice in the Style window the change in the skew setting. 

Note: You can change Rotate and Skew settings for selected text by 
entering numerical values in the Rotation and Skew fields in the Style 
window. 

Rotate and Skew a Layer 
If a layer is selected, it can be rotated and or skewed using the Rotate/Skew tool as with selected text. 
The procedure is the same but the object rotated is a layer with all of its contents. As with Scale, 
changing Rotate or Skew parameters to a layer will apply attributes to the layer rather than to the 
text. 
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Justifying Text and Layers 
Deko provides tools for simplifying the justification of text. Three tools on the toolbar provide reveal 
menus for justifying text. Keyboard shortcuts are available as well.  

Text can be justified within layer boundaries or you can justify a layer relative to safe title marker 
boundaries, indicated by a red-dotted line in the graphic window. 

Justifying Text Within a Layer 
1. Select a Layer and press the Home key to enter the text layer.  

2. Without selecting any characters within the layer, click on one of the justify tools to reveal the 
menu and click on the appropriate button. 

Note: You can justify text using the keyboard by holding down Ctrl and pressing the numbers on the 
keypad. The positions are represented as follows. 

7 8 9 
top left top center top right 

4 5 6 
middle left middle center middle right 

1 2 3 
bottom left bottom center bottom right 

 0  
 justification off  

Note: Selecting all of the text within a layer before justifying will force the layer boundaries to fit the 
borders of the text and then justify to the safe title boundary. If you select only some of the text in 
the layer, a separate layer will be created for that text when it is justified. 

Justify Grid 

Justify 
Horizontal 

Justify 
Vertical 
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Special Settings 
• Full Horizontal Justification � forces all of the rows with exception of the last rows or any 

hard returns flush with the left and right sides of the text. 

 
• Full Vertical Justification � spreads the text so the top and bottom lines are flush with the 

top and bottoms of the layer box. 
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• Spread Justification � makes all lines of selected text flush with both the left and right sides 
of the layer boundaries. 

 

Justifying Layers 
When a text or shape layer is selected, the layer is justified to the boundaries of the safe title area. To 
justify a layer, select it and apply the appropriate justification tool. Tool bars and keyboard shortcuts 
work the same for layers.  

Pressing the down 
arrow produces a layer 
set to center lower third 
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Character Spacing (Kerning) and Row Spacing (Leading) 
The Kerning/Leading tool allows you to make incremental changes in character or row spacing. The 
same tool is used for both. Both actions can be performed from the mouse or the keyboard. 

To activate the Kerning/Leading tool type Ctrl + K (FAK: Kern/Lead) or click on the tool. 

Kerning Text 
To kern from the keyboard: 

1. Select the text to be kerned. 

2. Hold down Alt and press either the right arrow to widen space between characters or the left 
arrow to reduce character spacing. 

Type Ctrl + Spacebar to toggle between fine and course control. 

To kern with the mouse: 

3. Move the pointer handle to either side of selected text so that the pointer becomes a kerning 
tool.  

4. Drag the handle either to the right to widen spacing between text or to the left to narrow the 
space between text. 

 

Leading Rows 
To change the row spacing of selected text with the keyboard, hold down Alt and press the up arrow 
to increase space and the down arrow to decrease space. 

Use Ctrl + Spacebar to toggle between fine and course control. 

To change Leading using a mouse: 

1. Move the mouse pointer to a handle above or below selected text, so the 
pointer becomes a leading tool.  

2. Drag the handle downward to increase the space between rows, or upward to reduce row 
spacing. 
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Note: Numerical kerning and leading values can be entered for selected text or to current style 
setting if no text is selected by entering a value in the Kerning or Leading fields in the Style window. 
Positive values increase the space between characters or rows and negative numbers decrease it. 

 

To change leading, select 
Kerning/Leading tool and 

position on one of the 
boxes so the leading tool 

shows. Then drag the 
mouse up or down. 
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Exercise � Creating a Lower Third Template with a Keyed Background 

Before you start 
A graphic consists of one or more layers and a background. The use of a background, the bottom 
graphic element over which all layers and their contents appear, is introduced in this exercise. Deko 
allows you to import a wide variety of file formats and use any file as a background. 

For keyed backgrounds like the lower third in this exercise, Deko can import a variety of file types. 
However, .tga and .tif work best since they are the commonly used formats that store a key 
signal.  

Note: Lesson 6 will introduce importing graphics and define and discuss the use of key signals  
(alpha channels). 

Step-by-Step: Lower Third with Logo 
Clear the Program window: Press Clear Program (FAK) or Alt+F8 (SK)  

You will be creating a three-part lower third � a background image, plus two text layers. The two 
layers will be used for a two-line lower third to hold a name and job title. 

Load up the Sample Background Image 
1. Set focus to the Program window. 

2. Press Clear Read (FAK) or F9 (SK) to reveal the File Open dialog. Your directory path should 
read D:\Deko\Tutorial.  

3. Change the file format from *.dko (Deko) to *.tga (Targa) in the List Files of Type box in the 
bottom left of the Open dialog box. 
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4. Double-click title.tga in the File Name list to open it. Deko automatically loads 
title.tga as a background into the Program window. This image was created on a paint 
system and saved as a Targa file. It includes a logo and textured lower third bars with semi-
transparency. 

Create a Text Layer for the Name 
1. From the Tools menu, select the add-text-layer tool.  

2. Position the tool on the upper left corner of the background�s upper blue rectangle and drag it 
to the bottom right corner to create a text layer that matches the blue rectangle.  

 
3. If you need to make any adjustments to the layer, make sure that the Move tool is selected so 

that you do not accidentally scale the text and the layer. 

Open the Tutorial Preset Style 
1. Click on the Preset Style window. 

2. From the File menu select Open (F9). The directory path should read D:\Deko\Tutorial. If it 
does not, change the directory path by double-clicking the D:\ directory and scroll down to the 
Deko folder.  

3. Double-click the Deko folder to find the Tutorial sub-folder.  

4. Click on the file titled tutorial.pst. Then press OK. 

Note: double-clicking on the file tutorial.pst will open it as well. 

C:\ Directory 

Deko 
folder 

Tutorial  
sub-folder 
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This will open a new Preset Style window. We will use the styles in this window to complete the 
exercise. 

Set Auto-Scaling Properties and Choose a Style 
1. In the Style window, click the Layer button.  

2. Turn off Word wrap and choose Shrink to fit box in the Auto-scaling 
section of the window. This enables your text to conform to the 
boundaries of this layer, as it commonly does in lower third titles.  

3. Then choose style 7 in your tutorial.pst window, but don�t type yet.  

Create a Text Layer for Job Title 
1. Select the Text Layer tool and create a second text layer. This layer goes below the previous 

layer and directly on top of the lower gray rectangle. 

 
2. Choose style 8 from the Preset Style window for this layer. Don�t type yet. Set the layer for 

Shrink to fit box and turn Word wrap off.  
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Delete the Default Text Layer 
1. Set focus to the Program window. 

2. Use Page Up to move among your layers to select the Default layer. This layer is based on the 
size of the safe-title area. 

 
3. Once the default layer is selected, tap the Delete key. This will make it easier to work with the 

graphic.  

Save This File to the Hard Drive 
1. With the Program window selected, go to the File menu and choose Save Graphic As (SK: F12, 

FAK: Save File).  

2. In the Directories list, double-click the Deko Tutorial folder to open it.  

3. In the File Name field type template. Under the List Files of Type drop-down box, verify 
Deko (.dko) as File Type. Then select OK to save. 

What you have just created and saved is the positioning and the font chosen for that position, along 
with the background image. This is commonly referred to as a template.  

Default Layer 

Name Layer 

Title Layer 
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Exercise � Creating Graphics from a Template 
A template graphic contains text layers ready to be filled. The template can also contain a 
background image. The file saved to disk in the previous exercise was a template graphic. 

The only difference between a ready-to-air graphic and a template graphic is whether or not the text 
has been filled in. There is no difference in how you save the files. In this exercise you will create five 
lower thirds from the template you just created. 

Fill in a Name and Job Title 
1. The first lower third needed is Frank Capelli, Firefighter. Press the Insert key to 

toggle Insert/Overwrite to OVR.  

2. Select the name layer, and then type in the name.  

3. Tab to the second layer, and type in the job title. Notice that the current style box changed 
when you moved to the second layer. If this did not happen, then you might not have the 
correct user preference set for Moving cursor sets font and look.  

 

Use Save As to Store the Lower Third on Disk 
1. From the File window go to Save Graphic As (SK: F12, FAK: Save File).  

2. To preserve the original template file, template.dko, save the file a different file name. Use 
title1. Once you have created a name, Deko will automatically increment the number at the 
end. Deko will suggest that your next title be title2, etc.  
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Fill in the Second Lower Third 

 
1. This one is John Murdouch, Eyewitness. Remember to put the name and title into their 

own layers. With OVR turned on, you can just Tab and type. 

2. Again, Save Graphic As lets you preserve your template file by making a new file on disk. Use 
the default title2.dko. 
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Fill in the Third Title and Save 
1. This third CG page is J. Christian Bollwage, City of Elizabeth Mayor. 

Notice that the Deko has automatically put both layers into a smaller font size, to fit it into the 
available space.  

2. If the text rises within the layer when it first starts shrinking, you will need to center the text 
within the layer, using Ctrl + Number key 4.  

3. Save this graphic. 

4. Repeat the same steps for these remaining lower-third titles. 

5. Jeanette Hanlein, Proprietor and Harold Lambeau, Deputy Sheriff. If 
done correctly, your Save Graphic As window will look like this on the fifth save: 
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The Layer Browser 
The previous exercise produced a graphic with a background and two 
distinct layers. Deko graphics are often composed of many layers. Creating 
separate layers can make it easier to manage and modify the graphic, and is 
also an important element in creating effects, as we will see later. 
Managing layers is made easier with the Layer Browser. To view the Layer 
Browser, select View/Layer Browser on the Menu bar (Ctrl + Shift + B).  

 

The Layer Browser shows all layers in sequence, with the highest priority layer (top) represented by 
the first layer in the browser, and lower priority layers numbered in sequence below. A layer in the 
browser can be selected simply by clicking on it.  

Note: As the layer browser can tax system memory, it is recommended practice to keep it closed 
when playing graphics on air. 

A thumbnail 
positioned and 
numbered in 

order, from 1 to 
last, represents 

each layer. 
View/Lock 
indicators 

Change 
View/Lock 

buttons 

View/Hide Layer Lock/Unlock Layer Normal/Zoom Layer 
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Reordering Layers 
Layer priority determines how a layer is viewed on the screen. The top layers will appear in front of 
layers of lower priority. Layer priority can be easily changed: 

• Click on a layer thumbnail in the browser and drag it to a different position. 

• Click on a layer in the graphic or the browser and type: 

• Ctrl + (+) to move the layer up one position. 

• Ctrl + (-) to move the layer down one position. 

• Alt + (+) to move the layer to the top position. 

• Alt + (-) to move the layer to the bottom position. 

Reordering Layers Based on Screen Position 
From the Layer menu, select Re-order Layers. A priority first from left to right, then from top to 
bottom determines the layer order. This is designed for fast and easy update of live template pages. 

Viewing Layers 
Next to each layer is a View status indicators. The indicator will either show an eye open or shut. 
When the eye is open, the layer is visible in the Program window; when the eye is shut, the layer is 
not visible. To change the view status of a layer: 

1. Select the layer in Layer Browser by clicking on it.  

2. Click on either View button at the top of the browser window (eye open or closed) to change 
the status. 

Locking Layers 
Below the View status indicator on each layer is a Lock status indicator. When a layer is locked, it 
cannot be moved or altered. To lock or unlock a layer: 

1. Click on the layer to select it. 

2. Click on either the Lock or Unlock button at the top of the browser. 

Normal/Zoom Layers 
In the normal view, layers appear in proportion to their actual size in the graphic. For small layers, 
this makes it difficult to distinguish one layer from another in the layer browser. The zoom button 
magnifies the layer element in the browser making it easier to identify the layer in the browser.  

Selecting Multiple Layers 
It is often necessary to select more than one layer to work with. Individual layers can be selected by 
pressing the Page Up or Page Down keys when the Program window is active, or by clicking on the 
layers in the Layer Browser.  
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To select more than one layer at a time, do one of the following: 

• In the Layer Browser, hold the Ctrl key down and click on 
desired layer thumbnails. Each will be highlighted; 

• Select Edit > Select More menu and click on each desired layer 
in the graphic (use Page Up/Page Down to select the layers 
consecutively). 

• Within the graphic, hold the Ctrl key down and click on each 
desired layer. 

Note: When you select multiple layers within the graphic a plus sign 
will appear next to the cursor pointer. Also note that while you have 
selected multiple layers, the only indication that these layers have been 
selected will appear in the Layer Browser, with each selected layer 
highlighted. 

 

Naming Layers 
Often it is advantageous to name layers. If related layers are given related names, the layers can be 
easily grouped using the wildcard symbol *. 

Example: Lower Third 
low3 top text 
low3 bottom text 
low3 top banner 
low3 bottom banner 
low3 bug 

 

Example: Leaderboard layout, layer names as follow 
Column 1a Column 2a Column 3a 
Column 1b Column 2b Column 3b 
Column 1c Column 2c Column 3c, etc. 
 

The advantage of using such a naming scheme is that it allows us to quickly group related layers 
when building effects and motions. For example, we could identify all the layers in Column 1 by 
notating Column 1* or all the layers in row one by notating Column *a. In lesson 10, you will learn 

Ctrl click to select multiple 
layers. Each selected is 

highlighted in blue. 
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how to apply layer names to the Timeline Motion Compose window to easily produce exiting effects 
on grouped layers. 

To name a layer: 

1. Click on the desired layer in the Layer browser. 

2. Click in the Number layer below the Layer Picon or right-click on the 
Picon. A Shortcut menu appears.  

3. Click on Edit Name. The name layer for the layer changes to allow you 
to edit name layer. 

4. Enter the new name in the layer.  

5. Click anywhere in the screen to accept the name change.  

6. Repeat this process for each layer to be named. 

Modifying Layers 

Cutting and Pasting Layers 
Layers can be cut, copied or pasted within the graphic or to other graphics. To perform any of these 
operations, select the desired layer(s) and use the keyboard shortcuts: 

• Cut � Ctrl + X 

• Copy � Ctrl + C 

• Paste � Ctrl + V 

Appending A Graphic to Another Graphic 
An entire graphic (with all of its layers) can be appended to another graphic file combining layers 
from the first graphic with that of the second.  

To append one graphic with another: 

1. Open the first graphic file. 

2. Go to File > Append Layers (Alt+F9). 

3. In the opened dialog box, navigate to the drive and directory containing the second graphic file. 

4. Choose the file from the File Name menu or type it in the File Name field and click OK. 

Note: the first file will be appended to the second file with the second files graphic layers behind 
those of the first. The second graphic�s background is discarded for the first. 
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Converting Layers to Background 
Sometimes it is desirable to lock down all layers permanently to a background.  

To do this, go to Choose Layers > Layers to Background. 

Note: Deko copies the layers and combines them with the background. The original layers remain 
until you clear them out with Edit > Clear Layers or F8. 

Combining Text Across Many Layers 
It is also possible to combine the contents of two or more text layers 
into a single layer.  

To do this: 

1. Select the text within the layers you wish to combine. Hold Ctrl 
and drag the mouse to select the desired text within each layer. 

2. Go to Layer > Text to Field. 
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Exercise � Making a Full Screen Slate 
In this lesson, you will create a slate � a CG page suitable for presenting bullet points to support an 
interview or an investigative report. 

The background for a slate can be a uniform color, a ramped color, or a graphic file. Typically, the 
bullet points on a slate are brought up one by one, either from the Deko, or from a still store. If the 
images are brought up from a still store, you have no choice but to save them as multiple graphics, 
one for each added bullet point. However, if the images are brought up from a Deko, then you can 
save a single copy and use a layer-based transition to bring it on screen. We will cover layer-based 
transitions in a later lesson that will show you how to create and save motion files with the Motion 
editor. 

Bullet points in the body of a slate are typically emphasized with a graphical element, such as a dot, 
square, sphere or arrow. Deko provides you with two different ways to put such an element up on 
screen: graphical layers and custom typefaces. In this exercise you will use graphical layers to create 
the bullet points. In the next lesson, we will cover creating and using Custom Typefaces. 

Step-by-Step 

Create a Text Layer for the Title Line of the Graphic, and assign a style 
1. Delete the default layer and make a text layer near the top third of the screen within the 

margins of the safe area.  

2. Specify Shrink to fit box and click off Word wrap.  

3. Assign Preset Style 4 from the Preset Style window, but don�t type in the layer. 

Create a Single Text Layer for Bullet Points, Assigning a Style 
1. Create a single text layer for the main points you will be bulleting leaving some room to the left 

of the layer for the graphic bullet on each point.  

Title layer 

Body layer 

Leave room for graphic 
bullets to be inserted
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2. Again, specify Shrink to fit box and leave Word wrap off.  

3. Select Preset Style 1 and scale down the size of the characters to 30. Do this before typing into 
the layer. 

Fill in Some Text on Your Layers Before Setting a Background 
1. Select the Title layer and type in a short title. 

2. Select the Body layer and type in several lines of text to illustrate your body. Keep the bullet 
points within one line and enter an extra return in between lines to space the text out. Enter 
five bullet points. 

 

Convert Body Text Layer into Multiple Layers 
A bulleted slate works best if each bullet point is a separate layer. It is 
often easier to type in all the bullets in to one layer and convert them 
into multiple layers. 

1. Select all of the text in the body text layer (Shift + Ctrl + A). 

2. Once all the text is selected go to Text > Text to Multiple Fields. 
This will take the single selected text layer and break it into five 
distinct text layers each a separate layer in the graphic. 

Note: avoid dragging the layers with the mouse to adjust layer spacing. 
This can produce unsatisfactory results. 
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Add the First Bullet Point 
 
1. From the Tools window, select the ellipse tool. Your cursor 

will change to indicate that it can draw a circle or ellipse. 

2. Position the cursor to the left of the first text layer in your bullet list 

3. Press and hold the Ctrl key (this will give you a perfect circle). Drag the cursor 
down and let go when you reach the desired size. Reposition the circle for better placement if 
necessary.  

4. With the circle still selected, choose a style from the Preset Style window or create your own 
style, preset 3 works well.  

Copy the Bullet to the Second Bullet Point 
1. With the circle selected, press Ctrl + C (to copy), then Ctrl + V (to paste). 

You�ve created a copy of the first circle but cannot see it because it was placed directly on top 
of the original. The only indication that you�ve successfully copied and pasted a second element 
is that the layer count on the status bar down at the bottom of your desktop updated with the 
addition of another layer. It should now read Layer 2 of 8. 

 
2. Again, with the circle selected press Ctrl + M. This is the shortcut for selecting the Move tool.  
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3. Hold down the Alt key and press the arrow down key until the second circle (bullet) is 
positioned next to the second point. Press Ctrl + Spacebar to toggle between Course and Fine 
movements so you can align the bullet to the point. 

 
4. Repeat Step 8 three more times until you have a total of 5 bullets. 

 

Name the Layers 
1. Open the Layer browser and select the layer for the first bullet point. When you have 

highlighted the layer in the browser, selection points will surround the selected 
bullet points. 

2. Right-click on the Layer browser picon to reveal the Shortcut menu and 
click on Edit layer name. 

3. In the Name layer, type Col 1a. 

4. Click anywhere on the screen to accept the 
change. 

5. Select the next and remaining bullet points to change their names as follows: Col 1b,  
Col 1c, Col 1d, Col 1e. 
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6. Select the first text layer associated with the first bullet point and change its name layer to  
Col 2a. 

7. Select the next text layer and the remaining layers and change their names as follows:  
Col 2b, Col 2c, Col 2d, Col 2e. 

8. Change the name of the Graphic Title Layer Why I Deserve a Raise to Title. 

Bring up a One-Color Background 
1. To turn on the background, go to the text bar at the top of the desktop and click once on the 

Background on/off button, which resembles a TV screen (FAK: F3) 

 
2. Then click once on the background color button directly to the right. This activates the 

Background Shader window. 

3. Click on the color button in the Background Shader. Pick a color 
from the palette below. Right-click on the active color box to 
place the selected color in it. The background of the graphic will 
now change to your selected color. 

Change the Background to a Ramp. 
1. From the Shader window, choose Ramp. You will see a four-

cornered gradient to which you can apply separate colors plus a 
highlight.  

2. Again, pick your colors from the palette below and right-click 
on each quadrant to drop in the selected colors in. 

Background on/off button 

Background color button 
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3. Check Hilite box. Set Value to 90 and right click this new color value to the active Hilite Color 
box. 

 
4. Click on Options. This will reveal a settings window to setup the 

highlight. Enter the following values: 

• Size 60 

• Angle 30 

• H Offset -70 

• V Offset 0 

1. Set Ramp values by 
entering colors in the four 

boxes 

2. Check the Hilite 
box 

3. Set value to 90 

4. Right-click on 
Hilite box to deposit 

new color 
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This will create an offset highlight to your graphic that should look something like this. 

 

Change to a Texture File 
1. Click on the Texture button to reveal the Texture dialog box in 

the Shader window. 

2. Click the checkbox next to File name, and then click the Open 
button below the File Name box. 
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3. In the Scroll menu below File Name, scroll to the file bulletsbgd.dko and click on it. Click 
OK. The file will be loaded into the background of the graphic. Alternately, you can click on 
the Browse button to open the Graphic browser and double-click on the graphic of your choice 
to load it into the background. 

Save this File to Disk 
1. Press F12 (SK) or Save File (FAK) to save the file to disk. 

 
2. Enter the name slate into the Name field of the Save As dialog and click OK. The file will be 

saved as slate.dko. 

 
Your graphic should look something like this when complete. 
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Check Tab Stop on 
Markers tab of 

Preferences dialog 
to show tabs in text 

fields 

Use the keyboard shortcut  
Alt + T then type T for Tab 

Set and the underlined letter 
of your choice of tab. 

Left, Center, Right, Decimal 

Alt + T then C to clear a tab 
Alt + T then A to clear all tabs 

Setting Tab Stops 
Deko provides tab stop settings that can be applied to any layer. If a layer has tab 
stops applied, the bottom margin of the text layer will show indicators for tab 
positions. As you tab to a tab stop, a tab indicator will show in that position. Tab 
indicators will only show if they are set to show 
in the Preference menu. To verify this, go 
to Options > Preferences and click on the 
Markers tab. Check the Tab stops check 
box to show them in a layer. 

Set Tabs 
1. Position the cursor in the text layer where you wish to 

insert the tab stop. 

2. Choose Tab Set from the Text menu (or Tab Set key on 
FAK) and select the type of tab from the drop-down menu. 
The choices are: 

• Left 

• Right 

• Center 

• Decimal 
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3. When you press the Tab key to advance the cursor to a tab stop, a tab marker is displayed to the 
left of the first character at that tab stop. 

 
Note: Tab stops are saved as a text layer parameter within the layer. When you create a new layer, the 
tab stop settings of the last active layer will be copied to the new layer. When you clear the graphic 
window, all tabs will disappear with the contents of that graphic. 

Note: Make sure Word wrap is not selected in layers that will contain Tab stops.  

Finding a Tab Stop 
• Tab stops for a column are located to the right of the last character typed in the previous 

column.  

• For the first column, your tab stop can be located by hitting the home key.  

• To confirm you are positioned on a tab, look to the bottom left of the status bar for the word 
�Tab�. 

Moving a Tab Stop 
1. Position the cursor to the left of the Tab Stop. 

2. Select the Move tool (Ctrl + M). 

3. Hold Alt and use the right or left arrow keys to move the tab stop. 

4. Type Ctrl + Spacebar to toggle between Coarse and Fine movement. 

Tab Markers 

Tab Stop indicators 
at the bottom of the 

text field 

       Left         Center       Right        Decimal 

Note character 
position relative to 

the Tab Stop 
indicators at the 

bottom of the field 
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Exercise: Working with Tabs 
This sample exercise highlights the benefits of setting Tab stops inside of a text layer. For instance, 
Tabs are recommended when names and statistics for many players are displayed in a columnar order. 
If a player advances and moves ahead of his opponents, a Leaderboard provides fast and flexible access 
to change this order. Rows of information can be exchanged up or down, rapidly. And there is no 
restriction to style formatting. Any changes to style and position can also happen quickly. See the 
sample below. 

 

To Exchange Rows of Content 
1. Click in the Program window to set focus and open the sample file 

D:\Deko\Tutorial\training_leaderboard.dko. 

2. Toggle the Insert key to enable Overwrite (OVR) mode. Look to the status bar at the bottom of 
the screen for OVR.  

Note: Pressing the Insert key toggles between Overwrite (OVR) and Insert (INS) modes. The 
OVR mode must be set when updating Tab content. Typing in INS mode will re-arrange the 
Tab stops. 

3. Press the Tab key and overwrite the existing content with new text. Get a feel for the speed of 
typing. 

4. Set the cursor anywhere within a row of content you wish to exchange up. (Shift + ALT + up 
arrow) will exchange up the list, one row at a time. (Shift + ALT + down arrow) will exchange 
down the list, one row at a time. 
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To Select All Text at a Tab 
1. Set the cursor anywhere within the desired Tab column.  

2. Press Shift + Alt + T to select all the Tab�s text.  

3. Use this function for changing the font or look of text within a single Tab column. Once 
selected, left-click on any one of the eight Preset Styles. 

To Locate and Modify Tab Position 
To locate the Tab Stop in the first (left-most) Tab column, press the Home key. Look to the status 
bar for the word Tab. 

To Locate the Tab Stop in any other Tab Column 
1. Set the cursor to the right of the last character typed in the previous Tab column. Look to the 

status bar for the word Tab. 

2. Set the cursor at a Tab Stop. 

3. Enable the Move Tool (Ctrl + M). Hold the Alt key down and use the right or left arrows to 
reposition the Tab column. 
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Shortcut Keys 

File Management  
Open File F9; FAK: Read 
Save File As F12; FAK: Save File 
Save File Alt + F12; FAK: Alt + Save File 
Open Graphic Browser Ctrl + L; FAK: Browse 

Graphics 
 

Selecting Tools 
Move tool Ctrl + M; FAK: Move 
Scale tool Ctrl + W; FAK: Scale 
Rotate/Skew tool Ctrl + R; FAK: Rot/Skew 
Kearning/Leading tool Ctrl + K; FAK: Kearn/Lead 
Course/Fine movement Ctrl + Spacebar 

Layer Controls 
Bring to Front Alt + (+) 
Send to Back Alt + (-) 
Bring Forward one layer Ctrl + (+) 
Send Back one layer Alt + (-) 
Justify layers or text Ctrl + Numeric Keypad 
Clear Text from layer Ctrl + Shift + T 
Clear Layers F8 
Clear All Alt + F8; FAK: Clear Program 
Move text cursor among layers Tab 
Select next/previous layer Page Up/Page Down 
Insert or Overwrite text Insert (toggle) 
View Layer Browser Ctrl + Shift + L 
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Lesson 6: Working With File Imports 

Deko Graphics 
As we learned in Lesson 4, Deko graphics are made up of one or more layers and a background. 
Layers can consist of text or shapes. Backgrounds consist of solid colors, ramp shaders or textures. 
With Deko, you can create shapes consisting of rectangles or ellipses. As you have already learned, 
you can also create complex looks that can be applied to fonts (font plus look equal style) and shapes.  

If you wish to incorporate photographs or continuous tone graphic elements such as team logos or 
station IDs, you must import these elements into Deko from another application. Deko allows you to 
import graphic elements from a wide variety of sources. Typically, these elements would be created 
in application such as Adobe Photoshop, and saved into a file format that can be read by Deko. 

Deko can use these imported files to supply the background to a graphic, or to supply texture fills to 
any font or shape with a Texture Shader. In Lesson 7, you will also learn how to import graphics to 
create a Custom Typeface, which allows you treat graphic elements as characters in a typeface. This is 
an ideal way of handling graphics consisting of frequently used logos or IDs. 

Computer Graphics  
While Deko graphics in their native state are saved as .dko files, the Deko application supports a 
wide variety of widely used graphic formats. 

There are two broad classes of still graphics: bitmapped graphics and vector graphics.  

Bitmapped Graphics 
Bitmapped graphics are made up of individual bits of picture information or pixels (picture 
elements). The graphic consists of a computer map of these bits that is re-created pixel for pixel when 
displayed or printed. Paint applications such as Photoshop create bitmapped graphics. A bitmap is an 
array of pixels (picture elements) mapped in an X Y grid. The dimensions of a bitmap frame for 
television are 720 pixels x 486 pixels (NTSC) or 720 pixels x 586 pixels (PAL). Each pixel is assigned 
enough bits of information to represent the RGB color values for that element. In digital television 
each pixel receives 8 bits of information for each color (Red Green and Blue) for a total of 24 bits per 
pixel. That works out to 8,398,080 bits of information for one video graphic frame. 

Vector Graphics 
Vector Graphics are made up of geometrical formulas to represent image content rather than an array 
of bits (bitmap). Vector graphics are more flexible than bit maps because they can be resized and 
stretched. Vector graphics do not need as many bits to store information for graphic creation than a 
bitmap because shapes are determined by a formula rather than a bit for bit reproduction. Deko is a 
vector graphic application. It treats imported bitmaps as geometric objects within the graphic. 
Imported graphics fill the background or fill shapes as applied textures. 
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Alpha Channels (Key Channels) 
An important aspect of Graphic files used with Deko is the inclusion of an alpha channel, also called 
a key channel. In addition carrying the RGB values Graphics can contain additional information 
carried in an alpha channel. This alpha channel carries gray-scale information that can be used to 
mask or hide part of the graphic.  

As we can see below, example A shows a graphic image. Example B shows the alpha (mask) channel. 
When the mask is combined with the photo as in example C, the muted color area will be cut from 
the image when it is displayed within Deko as shown in D. 

 
A Paint application such as Photoshop is required to create an alpha channel.  

Note: other terms for alpha channel include: hicon, picon, key and alpha mask. 

Example A 

Example D 

Example C 

Example B 
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File Formats 
There are many file formats used in computer graphic applications today. As we said earlier, Deko 
saves graphics as .dko files. Photoshop saves files as a .psd extension in their native form. However, 
Photoshop can accept a wide variety of formats and save them as native .psd or convert them into 
other formats. Deko can accept many graphic formats. If you need to carry an Alpha channel with the 
graphic, you must save your graphic as a .tga (Targa) or .tif (TIFF) file format. 

Targa® Files 
.tga � The TGA (Targa®) format is designed for systems using the Truevision video board and is 
commonly supported by MS-DOS color applications. The Targa format supports 32-bit RGB files 
with a single alpha channel, and indexed-color, grayscale, and 16-bit and 24-bit RGB files without 
alpha channels. When saving an RGB image in this format, you can choose a pixel depth.  

TIFF Files  
.tif � Tag Image File Format (TIFF) is the most versatile scheme for storing photo-realistic bit-
mapped data and the most reliable for ensuring that image and tonal values are faithfully imported 
by the importing application. TIFF files are supported across Macintosh, Windows and other 
imaging platforms. TIFF is a flexible bitmap image format supported by virtually all paint, image-
editing, and page-layout applications. Also, virtually all desktop scanners can produce TIFF images. 
In addition to other formats for print applications, the TIFF format supports RGB and grayscale files 
with alpha channels, and Bitmap files without alpha channels. TIFF also supports LZW (lossless) 
compression. 

Other File Formats 
Deko can read other formats besides TIFF and Targa files. Not all formats can carry alpha channels. 
Deko cannot read the alpha channels of other file formats (except Pinnacle .g files). If have a file 
saved in an other format and need to use an existing alpha channel or create a new one, bring the 
image into a paint program and save the file with the alpha channel as a TIFF or Targa file.  

Below are some other popular file formats: 

.bmp � (BitMaP) is the standard Windows image format on DOS and Windows-compatible 
computers. Bitmapped graphics are large in comparison to gifs or jpegs due to the fact that they 
contain a map of every pixel on the screen and they are not compressed. The BMP format supports 
RGB, indexed-color, grayscale, and Bitmap color modes but not support alpha channels. 

.gif � Graphics Interchange Format (GIF) is the file format commonly used to display indexed-
color graphics and images in documents over the World Wide Web and other online services. GIF is 
an LZW-compressed (see compression below) format designed to minimize file size and electronic 
transfer time. The maximum compression available with a GIF depends on image content. Graphic 
images with limited flat colors will compress well�sometimes even down to one tenth of the 
original file size�while a complex, non-repetitive image will fare worse, perhaps only saving 20% or 
so. GIF files are limited to a palette of 256 colors or less. The GIF format does not support alpha 
channels. 
 
Note: Deko cannot read .gif files. Translate them first to a compatible format. 
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.g � Pinnacle.g files are used as the native file format for Lightning still stores and Thunder clip 
servers. The .g format is a good choice for import if your facility has integrated Deko with these 
products. .g files are already formatted to NTSC or PAL resolution. They also carry an alpha channel 
readable by Deko. 

.jpg � Joint Photographic Experts Group (JPEG). JPEG is a lossy compression method. In other 
words, to save space it just throws away parts of an image. Lossy compression methods can generate 
artifacts�unwanted effects such as false color and blockiness�if not used carefully. JPEG 
compression provides the best results with continuous-tone images, such as photographs. A JPEG 
image is automatically decompressed when opened. A higher level of compression results in lower 
image quality, and a lower level of compression results in better image quality. In most cases, the 
Maximum quality option produces a result indistinguishable from the original. The JPEG format 
supports RGB, and grayscale color modes, and does not support alpha channels.  

.pct � PICT format (Macintosh Picture) � supports a mixture of bitmapped and vector oriented 
data that is encoded in the Mac�s native QuickDraw language. This is the most generic file format 
for the Macintosh, widely used among graphics and page-layout applications as an intermediary file 
format for transferring files between applications. The PICT format supports RGB files with a single 
alpha channel, and indexed-color, grayscale, and bitmap files without alpha channels. The PICT 
format is especially effective at compressing images with large areas of solid color. This compression 
can be dramatic for alpha channels with their large areas of white and black.  

Note: Deko will not see alpha channels saved in the .pct format. 

.png � Portable Network Graphics (PNG), developed as a patent-free alternative to GIF, the PNG 
format is used for lossless compression and display of images on the World Wide Web. Unlike GIF, 
PNG supports 24-bit images and produces background transparency without jagged edges. The 
PNG format supports grayscale and RGB color modes with a single alpha channel, and bitmap and 
indexed-color modes without alpha channels.  

Note: Deko will not see alpha channels saved in the .png format. 

.pcx � a graphics file format for programs running on PCs, its supported by most scanners, and 
desktop publishing programs. The PCX format supports RGB, indexed-color, grayscale, and Bitmap 
color modes, and does not support alpha channels. Images can be saved with 1, 4, 8, or 24 bits per 
pixel (bit depth). 

.wmf � Windows Metafile Format, a graphics file format used to store vector and bitmap data in 
memory and on hard drives for later playback to an output device. Though native to Microsoft 
Windows, several non-Windows applications support this format as a means exchanging data with 
Windows applications. WMF supports up to 24-bit images  
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File Compression 
Many image file formats use compression techniques to reduce the storage space required by bitmap 
image data. Compression techniques are distinguished by whether they remove detail and color from 
the image. Lossless techniques compress image data without removing detail; lossy techniques 
compress images by removing detail. The following are commonly used compression techniques: 

• Run Length Encoding (RLE) is a lossless compression technique supported by the Photoshop 
and TIFF file formats and some common Windows file formats. 

• Lempel-Zif-Welch (LZW) is a lossless compression technique supported by TIFF, PDF, GIF, 
and PostScript language file formats. This technique is most useful in compressing images 
that contain large areas of single color, such as screenshots or simple paint images. 

• Joint Photographic Experts Group (JPEG) is a lossy compression technique supported by 
JPEG, PDF, and PostScript language file formats. JPEG compression provides the best 
results with continuous-tone images, such as photographs. 

• CCITT encoding is a family of lossless compression techniques for black-and-white images 
that is supported by the PDF and PostScript language file formats. (CCITT is an abbreviation 
for the French spelling of International Telegraph and Telecommunications Consultive 
Committee.) 

• ZIP encoding is a lossless compression technique supported by the PDF file format. Like 
LZW, ZIP compression is most effective for images that contain large areas of single color. 

Aspect Ratio and Graphic Size 

Square vs. Rectangular Pixels 
All Windows- and Macintosh-based computer systems use square pixels to create bitmapped images. 
A common frame sized used in multimedia applications has a screen area of 640 x 480 pixels. This  
4 x 3 aspect ratio (the ratio of screen width to screen height) mirrors the aspect ratio of a television 
system at very close to the same resolution.  

Both PAL and NTSC television systems use rectangular pixels. In NTSC the aspect ratio is 4 x 3 as 
well, however, this aspect ratio has a pixel dimension of 720 x 486 pixels. 

If you create a graphic sized at 640 x 480 (Example 
1) on a computer graphics system, and display it on a 
video output. The image will not fill the screen 
correctly and will be geometrically distorted because 
the square pixels from the computer output will be 
squeezed into rectangular shapes making objects 
appear slightly thinner and taller than they actually 
are. This is especially noticeable with symmetrical 
shapes such as circles and squares. 

Example 1 
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If you create an image on a computer program 
with an image size of 720 x 486 (Example 2), 
and bring display it on a video output, the image 
will fill the screen but will still be geometrically 
distorted because the square pixels from the 
computer output will be squeezed into 
rectangular shapes. 

Deko has the ability to resize imported graphics, 
so creating an image of the correct aspect ratio on 
the computer is most important. You can make 
an image saved at 640 x 480 look right. However 
to gain the best looking output we recommend 
the following practice. 

Recommended Practice 

4 x 3 Images 
When making 4 x 3 images with Photoshop or 
other square pixel paint program, make your 
image size 720 x 540. This is a 4 x 3 aspect ratio 
in square pixels. Just before you are ready to 
export your file to Deko, resize the image to 720 
x 486 and save the image as a .tga file or a 
.tif file. Use 486 because our video buffers are 
exactly 486 lines tall. The resized image will 
appear geometrically distorted on your computer 
monitor. However when you import the image to 
Deko it will display correctly. 

Note: Before you resize the image make sure you 
save a copy of the image at 720 x 540 so you can 
work in a geometrically correct image if you need 
to edit the file.  

16 x 9 Images 
When making 16x9 images, work in 864 pixels by 486 lines, and then scale down to 720 x 486 
before saving the .tga file.  By using the 864 pixel-count, you have an image that is in the 16 x 9 
aspect ratio, and you are scaling down before saving. Do not use a 720 x 405 image because you 
would have to scale up when changing to video resolution, thus reducing image quality.  

Resized Box will appear distorted with 
objects shorter and wider than normal 

Example 2 



Working With File Imports   

 Deko Training 

6-7

Bringing Images Into Deko 
When you wish to import an image into 
Deko, use the File Open dialog box, and 
select the file format from the List Files 
of Type menu. 

If you are unsure of the aspect ratio 
settings, click on the options button. 
This reveals the File Open Options 
dialog box.  

The top section of this dialog box 
provides Image size information 
represented in Horizontal and Vertical 
Pixels.  

The Bottom How to format: section 
gives you four choices on how to bring 
the image into Deko. The Choices are: 

• Scale to full screen � 
(recommended) use this choice if 
the original image is already 
scaled to the correct aspect ratio. 
640 x 480 or 720 x 540 will scale 
correctly at this setting. If you 
followed the recommended 
practice the image will look 
correct as well.  

• Square pixels, preserve height � 
This setting will preserve the 
vertical dimension setting of the 
image and stretch or shrink the 
horizontal dimension to fill the 
frame.  

• Square pixels preserve width � 
This setting will preserve the 
horizontal dimension setting and 
stretch or shrink the vertical 
dimension to fill the frame. 

• No scaling � Use this setting if you do not want any resizing of the image. If you followed 
the described recommended practice just discussed, this setting will work as well.  
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Exercise � Creating an OTS Graphic 
Very often, the Over-The-Shoulder (OTS) graphic both with and without text is stored either in a 
paint system or in a still store device. If these systems are networked to the Deko, the graphic file can 
be loaded up as a background, altered, and then stored back out to the remote hard drive.  

In this exercise you will open an OTS background with a rectangle left blank for a graphic insertion. 
You will then insert the graphic and add a caption. Finally you will save the completed graphic as a 
Targa file so it can be used with an external still store. 

Open Background 
1. Select the Style edit layout (Alt+F11) 

2. Activate the Program window. If a graphic already exists, clear the window. 

3. Press F9 (SK) or Clear + 
Read (FAK) to open the 
Open File dialog box. 

4. Select Targa (*.tga) 
from List of File types. 

5. Select the file ots.tga and 
click open.  

The background image will 
open in the program 
window. Notice the black 
rectangle in the upper left 
corner of the graphic. This 
is where we will put our 
graphic. 

 

Notice black rectangle. 
This is where we will 
insert our graphic. 
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Insert Graphic 
1. Delete the default text layer. 

2. Select Preset Style 8. 

3. Select the Move tool, and then select the Rectangle Shape tool. 

4. Draw a rectangle to outline the 
shape of the black rectangle. 

5. On the Style window, click the 
Look button and make sure the 
Look is defined by a face detail 
only. 

 

6. On the Face Shader window, click 
Texture.  

7. Click Open. When the Select texture file dialog box appears, select 
budget.tga from the list, and click Open. 

Note: You should be in the Deko/Tutorial directory with 
Targa (*.tga) chosen in List Files of Type. 
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8. Click OK. 

9. On the Face Shader window set Group to page.  

10. Notice the sample in the texture window that shows a small visual of your 
imported graphic. The graphic has been pre-sized to fit within the OTS window. Your  
background should now look like this. 

 

Define a Text Layer and Add a Caption 
1. Select the Text Layer tool. 

2. Draw a text layer under the graphic 
rectangle. 

3. Select a preset style from the Preset Style 
palette or define a new style. 

4. Select Layer from the Text window and check 
Shrink to fit box in the Auto-scaling section. 
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Type the title Budget Talks into the text layer. 
 

Save Graphic as a Targa File for Export 
1. Press Save File (FAK) or F12 (SK). The Save Graphic As dialog box opens. 

2. Check to make sure Targa (*.tga) is selected in List Files of Type. 

3. Type budgettalks for a title and click OK. The graphic will be saved as a Targa file that can 
be exported to still stores and other devices. 
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Exercise � Creating a Lower-third with a �Sticky� Texture 
In lesson 5 we created a series of lower-third graphics with a background. Sometimes it is desirable to 
reposition this background in the frame. We refer to this effect as a sticky texture. In this exercise 
you will use the elements from the lower-third lesson to create a sticky texture lower third. 

1. Set focus on the Program window and open
title1.dko. 

2. Click on the Background Shader button to turn the 
background off. The text layers will appear without the 
background. 

 
3. Select the Rectangle Shape tool and draw a rectangle over 

the lower third of the graphic. 

 
4. Click on the Look button in the Style window and delete any 

details other than face. 

5. Set focus on the Face Shader. Click on the Texture button and 
open title.tga. The lower-third background should appear in the 
rectangle window in front of your two text layers. 

6. Set focus on the Program window and select the rectangle texture 
layer.  

7. Press Ctrl+ (-) twice to move the texture behind your text 
layers. 

8. In the Face Shader window under Group, choose letter. 
When letter is selected, your 
background graphic should disappear 
in the window.  
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9. Click on the up arrow in the window next to V Offset to allow the 
vertical offset numbers to advance. Release the keys periodically to 
see if you can see the graphic begin to appear in the window. 
Advance the numbers to about 34. Adjust to fine tune the position 
of the background correctly under the text layer. 

10. The background is now a texture in the rectangle layer that can be 
positioned like any other object in the graphic. Select all of the layers 
(Shift + Ctrl + L). 

11. Select the Move tool and reposition the layers in the graphic (Alt+ 
Up Arrow key). The background element will move with the text 
layers.  
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Chyron Import 
The Chyron Import option gives you the ability to read Chyron Infinit family files and work with 
them in the Deko environment. The members of the Infinite family include Maxine, Max, Winfinit, 
and Infinit. These files come in two flavors: 

Message 
Message directories contain message and RGBA (RGB plus Alpha Channel) files that Deko can read 
into a Program or Preview window. These files usually refer to fonts, which you can associate with 
True Type fonts for viewing and editing within Deko. 

Machine 
Machine directories contain logo font files that Deko can convert into Deko custom typeface (.fac) 
files. 

To Open the Chyron Import Window: 
1. Insert the Chyron disk into the appropriate drive and close the drive door. 

2. Activate a Program or Preview window. 

 
3. Go to View  > Chyron import. 

To Import a Chyron Message File: 
1. Open the Chyron Import window. 

2. Navigate to the drive and directory that contain the message file. 

3. Double-click the file name to open the file in the active Program window. 

Note: Once you have imported a Chyron message file, you can save it as a Deko (.dko) file. The 
sample file, Chyron2.dko, is a Chyron message file with logo fonts that was saved as a .dko file. 

Double-Click to 
open a file. 
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To Map a Chyron Bitmap Font onto a TrueType Font: 
1. Open the Chyron Import window. 

2. Navigate to the drive and directory that contain the message file.  

3. Click the file name to open its Font Mapping list in the window. 

 
4. Double-click an item in the Font Mapping list to open the list of available TrueType fonts. 

 
5. Select a TrueType font, and then click Accept to add the font to the 

mapping file for the current Deko session. 
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To Save the Current Font Mapping File for Future Deko Sessions: 
1. In the Chyron Import window, click Details. The Chyron Import Details dialog box appears. 

 
2. Click Save. The Save As dialog box appears. 

 
3. Enter a name for the mapping file in the File name: field, and then click Save. The Save As 

dialog box disappears. 

4. Click OK in the Chyron Import Details dialog box or press Enter. Deko saves the font mapping 
file as a text (.txt) file. 



Working With File Imports   

 Deko Training 

6-17

To Open a Font Mapping File: 
1. In the Chyron Import window, click Details. The Chyron Import Details dialog box appears. 

 
2. In the Chyron Import Details dialog box, click Open, and then navigate to the mapping file. 

 
3. In the Open dialog box, double-click the file name, or select it and click Open. 

4. Click OK in the Chyron Import Details dialog box or press Enter. 
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To Convert a Chyron Logo Font into a Custom Typeface: 
1. Open the Chyron Import window. 

2. Navigate to the drive and directory that contain the machine file.  
Note that the file description appears. 

 
3. Double-click the file name to open and import the file into a Custom Typeface window. 

 

4. Go to File > Save Custom Typeface As. 

5. Navigate to the drive and directory where you will store the file. 

6. Type a new file name in the File Name field, then click OK or press Enter. 

Note: the sample file, 28SharkElements.fac, is a custom typeface converted from a Chyron logo 
font. 
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Lesson 7: Creating and Using Custom Typefaces 

Custom Typefaces 
Custom Typefaces allow you to save graphic IDs, logos and other graphic content to a typeface font 
for quick access and recovery. Creating a custom typeface is an easy process. Once a typeface is 
created, you can access the typeface elements as you would a regular typeface or font.  

Creating Custom Typefaces 
1. Go to View > Custom Typeface. The Custom Typeface window appears.  

2. Activate the Program window and open the first graphic 
you wish to import as a character. You can do this quickly 
from the graphic browser by double clicking on the 
selected graphic. 

3. Activate the Custom Typeface Window and click on the 
character to which you wish to import the graphic. 

4. Go to File > Import Character. The graphic will appear on 
the selected character. 

Click on the 
character you 

wish to add the 
graphic to 
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5. Repeat steps 2 through 4 until all desired graphics are imported. 

6. Activate the Custom typeface window. Press Save File (FAK) or F12 (SK) and type in the name 
of the custom typeface. 

Alternate Method 
1. Go to View > Custom Typeface. 

2. Click on the character into which you wish to import the graphic. 

3. Go to File > Import Character From File. The Import graphic into the selected character to 
dialog box appears. 

4. Browse to the file directory and select the desired file, then click OK. 

5. Repeat Steps 2 through 4 until all graphics are selected. 

6. Activate the Custom Typeface window. Press Save File on the FAK and type the name of the 
custom typeface. 
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Exercise � Build a Weather Graphic 
Assembling a weather graphic typically requires the import of symbols (or logos) that were designed 
on some other application. The method by which these symbols are imported can vary. Traditionally, 
files are transferred from one device to another via floppy or Zip. Deko can accommodate both. A 
faster approach is to transfer via network connection.  

The following will step you through logo import, using a Custom Typeface and assembling a typical 
weather graphic. See the finished sample below. 

 

Import Weather Logos 
1. Select the Style Edit layout. 

2. Go to View > Custom Typeface. The Custom 
Typeface window will open 

3. Set focus to the Program window. Open (Clear 
+ Read) the sample graphic 
wx_partlycloudy.tif. To do this you will 
need to set List Files of Type to TIFF. 

4. Set focus to the Custom Typeface window and 
click on character A. 

Logo layer 

�Day�  
Text layer 

�Forecast� 
Text layer 

�Temperature� 
Text layer 
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5. Go to File > Import Character (Alt + F > I).  
The logo should display in the A position. 

 
6. Set focus on the Program window and open the sample graphic wx_chanceshowers.tif.  

7. Set focus to the Custom Typeface window and click on character B. 

8. Go to File > Import Character (Alt + F > I).  
The logo should display in the B position. 

9. Repeat steps 6-8 assigning three more graphics to 
the following key positions: 

A. Open the sample graphic wx_tstorms.tif. Assign to the C position. 

B. Open the sample graphic wx_windyrainy.tif. Assign to the D position. 

C. Open the sample graphic wx_snowfall.tif. Assign to the E position. 

 
10. Save the Custom Typeface as weather.fac. Be sure to save in the D:\Deko\Tutorial folder. 
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Using a Custom Typeface 
When a Custom Typeface is created and saved, using the Custom Typeface is similar to using a 
standard typeface. You can apply the same detail attributes to your logos as you do to your text. To 
simplify this exercise, we have already assigned an identical copy of the custom typeface you just 
created to a Preset Style window. This window has the other fonts you will use in the exercise as well. 

1. Set focus to the Preset Style window. Open the Preset Style training_weather.pst. 

 
2. Set focus on the Program window and clear the window of any existing graphics. 

3. Delete the default text layer. 

4. From the Tools window, select the Add Text Layer tool. Draw a layer box in the center of the 
Program window (approximately 2 in. x 2 in.). 

5. Select Preset Style 4. 

6. Set focus back to the Program window and type 
Shift + A. If the logo appears to sit high in the 
layer, type Ctrl + numpad 2 to bottom justify. 

7. Save this graphic as 1600.dko. 

Assembling the Weather Graphic 
Your weather graphic will consist of 3 text layers, 1 
logo layer and a background. The logo layer has 
already been created in the previous section. 

1. Enable the Background Shader and click on the 
Texture button in the Shader window. 
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2. Click the Open button and navigate to D:\Deko\Tutorial\bgd_training_weather.dko. The 
background elements for the graphic will appear. If you need to position the logo relative to the 
example below, select the move tool and do this now. 

 
3. Draw a text layer for Day below �ACCU-WEATHER� and select Preset Style 1 (Bank Gothic). 

4. Center justify text inside the layer (Ctrl+5) and type in all CAPS �TOMMORROW.� 

 
5. Draw a text layer for the Forecast and choose Preset Style 2 (Futura Condensed).  

6. Center justify text inside the layer (Ctrl+5) and type �Cool, Partly Cloudy�. 



Creating and Using Custom Typefaces 7-7  

 Deko Training 

7. In the box below the Forecast layer draw a text layer for Temperature. Choose Preset Style 3 
(Futura Condensed size 140). 

8. Center justify text inside the layer and type �45�. 

 

Inserting Useful Symbols 
Depending on the current typeface character set there may be many symbols available to the user that 
do not have a quick key. The Degree (°) symbol is one of these. 

• To insert the Degree symbol by typing the key code, hold down the 
Alt key and, from the number pad, type 0176. Release keys to 
display the symbol. 

• To insert the symbol with a mouse, select 
View > International. The International 
character window appears.  

• Position the cursor after the �45.�  

• With the mouse, click on the degree  �°� 
symbol in the International character 
window. 
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If a faster approach is required, a custom TrueType font can be created with the degree symbol 
mapped to a user-defined key. Special software programs, such as Macromedia Fontographer, are 
designed for such tasks.  

When you have added the degree symbol, your finished graphic should look like this. 

 
9. Press Alt + Save File (FAK) or Alt+F12 (SK) to save the graphic.  

Keyboard Shortcuts for Useful Symbols 
 

Symbol Keystrokes 

© Alt+0169 

® Alt+0174 

° Alt+0176 

� Alt+0153 

¼ Alt+0188 

½ Alt+0189 

¾ Alt+0190 
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Lesson 8: Baseline Editing � Typing on a Curve 

Deko provides many tools for text formatting including: moving, scaling, rotation, skewing, kerning 
and leading. For precise placement of text to match details of a specific image, such as an imported 
logo, the tool best used is called Baseline Edit. 

Baseline Edit Window 
To activate the Baseline Edit window, do one of the following: 

• From the Layer menu, choose Edit Baseline to activate the Baseline Edit window. 

• If the Baseline Edit window is open but not active, check Baseline Edit in the Window 
menu. 

Drawing Baseline Segments 
To draw a curved baseline: 

1. Select the layer whose baseline you wish to modify. 

2. Activate the Baseline Edit window. 

3. Do one of the following: 

• In the Baseline menu, check Draw Curve. 

• Click the curve drawing tool button in the Tools window. 

• Position the drawing tool where you will begin the curve and drag the mouse to draw the 
curve. 

To draw a line-segment baseline: 

4. Select the layer whose baseline you wish to modify. 

5. Activate the Baseline Edit window. 

6. Do one of the following: 

• In the Baseline menu, check Draw Curve. 

• Click the drawing tool button in the Tools window. 

7. Click to begin the line, then move the line tool to the desired end point and click again. Repeat 
this step as desired to draw multiple line segments. 

8. To break the line, move the cursor out of the Baseline Edit window. 
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Rectangle or Ellipse 
To use a rectangle or ellipse as a baseline: 

1. Select the layer whose baseline you wish to modify. 

2. Activate the Baseline Edit window. 

3. Click the rectangle or ellipse button in the Tools window, and then drag the cursor in the 
Baseline Edit window to define the rectangle or ellipse. 

4. Release the mouse button, then drag points as desired to edit the baseline. 

Note: Hold Ctrl as you drag the cursor to maintain a square or round baseline. 

Apply Baseline 
To apply a baseline: 

1. Once you have drawn or edited the baseline as desired. 

2. Do one of the following: 

• To apply the baseline and remain in Baseline Edit mode, choose Apply Baseline (Enter) from 
the Baseline menu. 

• To apply the baseline and close the Baseline Edit window, choose Accept Baseline  
(Alt + Enter) from the Baseline menu. 

Editing Baselines 

Delete or Insert a Point 
To delete or insert a point on a baseline: 

1. If not already in the Baseline Edit mode, choose Edit Baseline from the Layer menu. 

2. In the Baseline menu, check Edit Curve. 

3. Do one of the following: 

• Click the point you wish to delete, and then choose Delete Selected Point (Delete) from the 
Baseline menu. 

• Choose Insert Point (Insert) from the Baseline menu, and then click on the curve where you 
wish to insert the point. 

Reverse Direction 
To reverse the direction of the baseline: 

1. If not already in the Baseline Edit mode, choose Edit Baseline from the Layer menu. 
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2. In the Baseline menu, choose Reverse Baseline. 

Change Type of Point 
To change the type of a point on the baseline: 

1. In the Baseline menu, check Edit Curve. 

2. Click the point to select it. 

3. In the Baseline menu, do one of the following: 

• Check Move To, for a point that begins a new section of the baseline. 

• Check Line To, for a point connected to the previous point by a straight line. 

• Check Bezier, for a point connected to the previous point by a Bezier curve. 

Bezier curves 
To adjust the continuity between two Bezier curves: 

1. In the Baseline menu, check Edit Curve. 

2. Click the point shared by the two curves. 

3. In the Baseline menu, do one of the following: 

• Check Cusp for no continuity. The control points on either side of the shared point move 
independently. 

• Check Smooth for C1 continuity. 

• Check Symmetric for C2 continuity. 

Cancel Changes 
To cancel changes to a baseline, do one of the following: 

• To cancel all changes and exit the Baseline Edit window, choose Cancel from the Baseline 
menu. 

• If Undo is enabled, you can choose Undo (Ctrl + Z) from the Edit menu, for each change you 
wish to undo. 
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Exercise � Baseline Editing 
1. Click in the Preset Style window to set focus and open the sample file 

D:\Deko\Tutorial\training_baseline.pst.  

2. Click in the Program window to set focus and open the sample file 
D:\Deko\Tutorial\training_baseline.dko. A sample logo will appear along with a 
default text layer.  

3. Left-click in the first Preset Style button to activate that style. 

4. Go to Layer > Baseline Edit. The graphic 
window will become a Baseline Edit 
window, as indicated in the title bar.  

 
The text layer tool will become a drawing tool. 

5. Click the Ellipse tool, and then move the cursor to the Baseline Edit window and position in 
the very center of the logo. 

6. Hold down the Ctrl key, then click and drag your mouse downward. Release the mouse button 
when your baseline circle begins to enter the blue of the logo. If the circle is a little off-center, 
select the Move tool and adjust the circle in the center of the logo. 
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7. Press Alt + Enter to accept the baseline or go to Baseline > 
Accept. The baseline will change showing the text cursor. 
In this mode you can enter text. 

 
8. Enter the text WWLP MASS. Drag points as desired to edit the baseline. 
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Editing a Baseline 
1. Select Edit Baseline from the Layer menu (Alt + L > B). 

2. Click on the Rotation tool in the Tools window. 

3. Position the mouse pointer in the graphic, then click and drag the mouse up or down. Notice 
that the baseline rotates around the graphic. 

 
4. Press the Enter key.  This will apply the change to the text position, but remain in Baseline 

Edit mode. Try this a few more times. 

5. Press Alt + Enter to accept the baseline and disable Baseline Edit mode. 

6. Enter the Edit Baseline mode again (Alt + L > B). 

7. Now select the Selection Tool in the Tools window.  

8. Position the mouse on the graphic. The pointer 
changes to a hand icon. 

9. Place the hand icon near one of the points and drag 
the mouse to reposition the point. Notice how the 
baseline shape changes. 
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Note: You can move the position of any point on the curve with the selection tool except the starting 
point of the baseline. To move the baseline start point, select the move tool and drag the baseline to a 
new position. Then edit the other points. 

10. Position the hand near one of the 
handles protruding from a point. Click 
and drag the handle. Notice that as you 
drag the handle the spline of the curve 
changes. You can edit any point to 
create complex curves. 

11. Press the Insert key and position the 
mouse pointer near the curve. Notice 
that the mouse pointer includes a plus 
sign.  

 

 
12. Click to insert a point. 

13. When you are finished editing the baseline, press Alt + Enter to accept changes and leave 
Baseline Edit mode. 
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Lesson 9: Creating Sequences and Effects  

This lesson will introduce you to the concept of sequence playback and effect creation. We will 
introduce you to the Sequence layout and show you how to build a sequence with effects. We will 
also introduce the Effects layout and show you the advantage of using embedded effects with your 
graphics. At the end of this lesson you will be able to do the following: 

• Build a sequence with effects. 

• Build a roll page with speed changes and a pause. 

• Build a crawl with speed changes and a pause. 

• Build a multi-layer crawl. 

• Create an embedded effect that will automatically play when a graphic is opened in the 
preview window. 

The Sequence Layout (SK: F11, FAK: Seq Edit) 
A Sequence ties graphics and effects together in the form of a play-list. Sequences are best used for 
rundowns, weather pages, credits or other items that are consistently used repeatedly in the same 
order. If you wish to play effects maintaining random access to any graphic in a directory, the Effects 
layout allows you to build and play single effects. That layout will be covered later in this lesson. 
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The Sequence layout is made up of the Preview window on the left, the Program window on the 
right and the Sequence window at the bottom center of the screen. 

The Sequence Window 

 
The Sequence window opens with a view of 6 event rows you can resize the window to show more 
events per view). There are 10 data fields in each event for the user to control playback of graphics.  

To Create a Sequence 
1. Open the Sequence layout (SK: F11, FAK: Seq Edit). 

2. Activate the Sequence window. 

3. If there are events in the Sequence window and you wish to clear them, go to Sequence > Clear 
Sequence. 

4. Use the Tab or arrow keys to move to the data fields and enter necessary information for each 
field. Shift + Tab will move in a backward direction. 

5. When you have finished setting up the first event, continue entering events until your sequence 
is complete. 

6. Making sure the Sequence window is active, save the sequence using Save File on the FAK or 
F12 on the SK. 
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Data Fields 

Control Field 
The Control field determines how events will sequence one after another. Click on the 
down arrow in the Control window for an event to reveal a menu, then choose the 
desired control the controls are: 

• (blank field) � no control. The event starts playing as soon as the previous event 
is finished playing. 

• pause � waits for a GPI trigger, right mouse click, or Play Sequence (Alt + 
Enter) or Play key on the FAK to continue playing. 

• hold � displays the first frame of the effect, then waits for a trigger as described above before 
continuing. 

• delay � pauses the number of fields specified in the Time field before continuing. 

• stop � stops the sequence, returning control to the user. To resume playback, press the Play 
key or pres Alt + Enter. 

• tcode � starts the event playback based on input and output times using a time code reader. 
If Deko does not detect time code, it will trigger time code events based on the system clock. 

• skip � skips to the next event. Use this if you wish to insert a comment in an event number 

• loop � repeats subsequent event a specified number of times, until an end is encountered. 

• end � specifies the end of the loop. 

• goto � skip to event number in Time field. 

Time C 
The control variable field used with the delay, 
loop and goto control selections. 

Effect Field 
Click on the arrow in the field box to choose your 
desired effect. Several effects in the menu have a 
reveal arrow that shows more choices. The example 
to the right shows the second column reveal menu 
shows more choices in the third column. The best 
way to learn effects is to begin to play with them 
to see what happens. In this lesson we will build a 
crawl and a roll effect within a sequence. You will 
also have some time to play. 
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Two points worth noting: 

• The menu item motion provides access to 
motions in your current directory to sequence 
playback. We will cover timeline motions in 
Lesson 10.  

• Choosing an effect from the DVE effects 
selection (an option on more advanced 
Dekos), will activate the options button on 
the Sequence window. If you click Options, 
the DVE Effect Editor dialog box appears. 
This dialog box allows you great control over 
the playback of your effect. 

Rate Field 
Enter a value here to determine the rate at which the effect is performed. This rate 
is determined by the values specified in the Units field. 

Units Field 
Click on the pull-down menu to determine the rate unit. When you click on an 
effect, the most common unit of measurement is chosen as a default with a nominal 
rate specified for that unit. You can change either. 

In Time/Out Time 
You can choose a time code value for effects to trigger. If no time code is detected by the system, the 
computer system clock will be read. This normally displays time of day. 

Playback Controls 
The sequence window displays three buttons for Stop, Pause and Play of Sequences. 
Recommended practice is to use the buttons provided on the FAK. 

Editing Sequences 

Insert 
To insert an Event between other existing Events: 

1. Place the cursor where you would like the new Event to be placed. 

2. Go to the Sequence menu. 

3. Choose Insert event (Alt + Insert). 

Delete 
To delete the current event, choose Delete Event (Alt + Delete) from the Sequence menu. 

To delete a group of events, select the group of events to be deleted. Press Delete. 
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Exercise � Create and Run a Sequence 
For this lesson, you will sequence the five title files created in Lesson 5, or use the sample files, 
lesson6a.dko through lesson6e.dko, provided in the Tutorial directory. 

Change Layout to Sequence Playback (SK: F11) (FAK: Seq Edit) 

Specify the First Event 
1. Click the down arrow next to the Effect field in Event 1 and choose clear. 

2. Click the down arrow next to the Control field of Event 2, then choose Pause. Pause causes the 
Sequencer to wait for Play or a GPI trigger before playing the event.  

Preview 
window 

Program 
window 

Sequence 
window 
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Specify the Next Five Lower Third Titles 
1. Click on the down arrow next to the Effect field and choose Motion. From the window that is 

revealed choose the motion file lower_third.mot.  

2. In the Graphics Browser, select the first of the five lower third files you created in Lesson 5. 

3. Double-click on the file to insert it into the sequencer. Notice that the cursor advances to the 
next event in the sequence. 

4. Select the next lower third and insert it, Repeat this process to fill in the next three events. 

5. Save the sequence to the hard drive (SK: F12, FAK: Save File). Enter number 200 in the File 
name field and click OK. 

6. Make the rate 2 sec. for even 2 and after. 

Play the Sequence 
1. Press the Home key to position your cursor in Event 1 and make it the current event. Deko 

always plays a sequence beginning with the current event. Near the top right you will see 
controls for Stop, Pause and Play. You can use these controls to play, but we 
recommend pressing the Play, Stop and Pause keys on your FAK.  

2. Press the Play key. This first event will play from Preview to Program. It will then pause, since 
you have set this as a control in each event. You will see the Pause button turn yellow. The Play 
key on the keyboard will blink green.  

3. Press Play again. The sequence will stop when it gets to an empty event or when you press the 
Stop button. 
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Exercise � Create and Run a Credit Roll 

Before You Start 
Though some shows now cut from page to page of credits, the credit roll remains a staple of TV 
production. Deko makes it easy to create and run credits. All the text is typed into a single file, just 
as it was when you did a lower third or a slate. The only difference is that you must tell the Deko 
that you want this to be a roll file. 

Running the roll file is equally easy. You specify the speed of the roll in a sequence event, and run 
that event. 

Unfortunately, moving video text up or down has a technical problem, inherent with all character 
generators, because interlace artifacts, give the text in rolls a jagged appearance. Deko provides you 
with a built-in solution that always gives you the smoothest roll possible. 

Step-by-Step: Create and Run a Credit Roll 
1. Enter the Style Edit layout to compose your roll graphic (Alt+F11). 

2. Clear the program window (SK: Alt + F8, FAK: Clear Program), and 
select the style you wish to use for the roll. You can, of course, use as 
many different styles as you want, though usually rolls are all one 
typeface, in several sizes.  

3. Select the Program window and go to Text > Vertical Scrolling. A check 
mark will appear indicating that it is enabled. 

 
A vertical scroll appears on the Program window, to allow you to move 
through the roll file. 

 

Vertical 
Scroll bar 
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4. Type in the roll text. Put in about ten lines of text separated by blank lines. If you can�t think 
of anything else, use this example: 

Writer
(Insert your name here) 
 
Producer
(Insert your name here) 
 
Camera
(Insert your name…)
 
(4 or 5 more lines)

Note: If you want your credits to roll off the screen when complete, enter several carriage returns 
after the last line of text. This will increase the vertical length of the roll page and provide a blank 
screen on air when the credit roll finishes. 

5. Save the file to the hard drive. (SK: F12, FAK: Save File) 

6. Bring up the Sequence layout. (SK: F11, FAK: Seq Edit)  

If there is already an open Sequence window, clear it. Activate the window, then go to 
Sequence > Clear Sequence. 

7. Fill in the fields for event 1.  

• Effect � roll  

• File Name � the file you saved 

• Rate � 2 seconds 

• Units � seconds 

 
8. Play the roll. Use Play on the FAK or Alt + Enter on the SK. 

Note: You can use the + and - keys on the Num Pad to change speed during playback of a roll or 
crawl. 
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Setup for Page for Smooth Rolling 
1. Select the Sequence window. Go to Sequence > Smooth Roll Playback Adjustments > Only Full 

Vertical Resolution Rates. 

 
2. From the Options window choose Save Settings Now to preserve this one-time setting 

(Alt + O > S). 

3. Change the rate of time in the Sequencer from 2 seconds to 5 seconds and then press Play. The 
Smooth Roll Playback Warning will appear. 
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The values you see in the window depend on the number of lines in your roll, and the font size 
and leading. Generally, you will want to adjust the line spacing rather than the overall time. 

4. Once you decide whether you�d like to adjust duration or line spacing, choose OK. If you 
adjusted line spacing, a �Save As� window will appear asking that you save these changes either 
over the original file or to a new file. Insert the File Name into the highlighted field and choose 
OK. If you saved as a new file, the updated name will appear in your sequence. 

5. Go to the Sequencer and change your rate of time to 7 seconds. The Smooth Roll Playback 
Adjustment dialog box appears again. 

6. Specify your change in either duration or line spacing. Choose OK and re-save the existing 
graphic over the original if you chose to change the line spacing.  

7. Play the sequence. 

Import a Text Document 
Since Deko supports standard ASCII text, it can import text files (such as credits) from other 
applications. You will use a sample text document provided in the Tutorial folder and place the 
contents of this document into the Deko program. We will use the default layer provided. Your text 
will be imported and placed into this layer according to the Current Style.  

1. Clear out the Program window.  

2. Set up for vertical scrolling as instructed in this lesson.  

3. Be sure to also set the window for Word wrap (it should have a check-mark next to it in the 
Text pull-down menu). 

4. Set the desired style and size that you would like for your text. 

5. Open the file titled credits.txt from the Tutorial folder. Changing directory paths and File 
types should be familiar to you by now.  

6. Your text will be placed according to the specifications you have set for justification, style, and 
size.  

7. If you would like to specify justification, make sure Num Lock is on and use the numeric 
keypad for these shortcut key combinations: 

• Ctrl + 7 = top, left 

• Ctrl + 8 = top, center 

• Ctrl + 9 = top, right 

8. Save this file as a native .dko (Deko) file in the same folder as your other files.  

9. Set up your sequence to play these credits, as you did in steps 5 and 6 of this lesson. 
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Exercise � Create and Run a Crawl 

Before You Start 
A crawl is almost identical to a roll. In both cases, there are two special steps: mark the file as 
scrolling and transition it on with the roll or crawl. Unlike rolls, crawls always have smooth motion. 
The limitation with rolls is due to the interlaced nature of video, which only effects vertical motion. 

Deko crawls can be in any typeface or mixture of typefaces. The vertical position of the crawl can be 
easily adjusted. You can even have up to four different crawl lines, each going at a different speed. 

Step-by-Step: Create and Run a Crawl 
1. Switch the menu layout to Style Edit and click on the Program window to give it focus, then 

clear the program window. 

2. Go to Text > Horizontal Scrolling. (Alt + T > H). A horizontal scroll 
bar appears at the bottom of the Program window. This control allows 
you to move back and forward in the crawl file. 

 
3. Type in your text. Enter whatever text you like, in whatever style or mixture of styles you like. 

It is important to enter all the text on a single line � do not press the Enter key. If you need 
inspiration, you can use the following text: 

State lottery officials announced today that today’s $20 Million jackpot was
won by (your name here). In an unprecedented announcement, officials stated
that not only today’s jackpot, but also future jackpots would all be awarded to
(name). Ticket sales are expected to decline in response to today’s news.

Horizontal 
Scroll Bar 
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Notice how you can scroll back and forth through the text. The appearance of the scroll bar 
changes, to give you an idea the file length. 

 
4. Save the file.  

5. Switch menu layout to sequence. If necessary, choose Clear sequence from the Sequence menu to 
clear out the current sequence.  

6. Pick crawl as the transition, and either type in or Browse for the file name you just saved. 

 
7. Set the crawl rate. The default rate of 1 second per page is a little fast, set it to between one-

quarter and one-half pages per second. 

8. Select the text layer on the screen and use the Justify controls Ctrl + Number pad to set the 
crawl to a lower-third position. 

9. Press Alt + Save File (FAK) or Alt+F12 (SK) to save the graphic. 

Note: you can press Ctrl+S to save the file with either keyboard. 

Re-position of 
Scroll bar 
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10. Set the crawl to play continuously. Go to the Control field in Event 2 and specify, �go to�. In 
the Time field directly to the right, specify the number 1. This will direct the sequence back up 
to Event 1. 

11. Play the crawl. 

Note: You can use the + and � keys on the Num Pad to change speed during playback of a roll or 
crawl. 

Embed Speed Changes in Your Crawl 
1. Open your graphic in the Style Edit layout. 

2. Scroll the graphic to the position you would like to see the speed change to occur and position 
the cursor. 

3. From the text menu, select Insert 
Speed. 

4. Select Pause or a speed from the drop-
down menu. You can specify speed 
changes in 1/10 page increments up to 
1 page per second. Deko inserts a marker to show where the embedded change is. 

Note: You can apply speed changes and pauses to both roll and 
crawl graphics. Embedded speed changes only work if you 
specify Pages per Second as your unit of rate to your crawl or roll 
effect. Do not use the + and - keys to change speed during 
playback of a roll or crawl with embedded changes. 

Embedded Speed Changes 
To edit your Embedded speed changes: 

1. Select the marker you wish to edit. 

2. Select Edit Speed from the text menu and 
choose the changed speed from the pull-
down menu to the right. 

Creating a Multi-Line Crawl 
This works much like a single-line crawl except carriage returns separate each row of text. Don�t 
create separate layers of text.  

1. Clear out the Program window and set for Horizontal Scrolling. The cursor will default to the 
upper left corner of the window. 

2. Pick a style and type First Row. 

Speed 
Marker 
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3. Press Enter twice. 

4. Change styles of you like. Type Second Row. 

5. Press Enter twice. 

6. Again, you can change styles. Type Third Row.  

7. Save this file as multicrawl.dko in the Tutorial folder. 

 
Set up the Sequencer with multicrawl.dko as the File Name, specify crawl as the Effect and 
change the Rate of time to 2 seconds. Since this is a multiple row crawl, the Rate of time is applied 
to the first row only. 

To set timing for the other rows: 

8. Click in Event 1. 

9. Select the Options button in the Sequencer to display a Crawl options dialog box. 

10. Specify 3 seconds for Second Row and 4 seconds for Third Row. 

 

11. Ignore the Fourth row. 

Enter 
carriage 
returns 

after each 
row. 
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12. Press OK and play the sequence. You should see three rows of text crawl at independent speeds. 
To create a more interesting effect with this feature, experiment with row length and size. 

The Effect Layout 
The Effects window allows you to play effects maintaining random access to any graphic in a 
directory. The Effects layout allows you to build and play single effects. Use this layout when your 
playout of graphics is not an orderly sequence. You can also use the effects layout to save effects that 
can be embedded within a graphic file. Embedded effects will playback whenever a graphic is opened 
up in the preview window. 

 
The Effects layout looks similar to the Sequence layout with a Preview window (left) Program 
window (right) and Effect window (bottom). 
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The Effect Window 
The effect window is also similar in function to the sequence window. Rather than have sequential 
events with data fields, the Effect window shows data field for one effect. 

To create a single effect and play to the current graphic: 

1. Open the Effect layout (Shift+F11). 

2. Activate the Effect window. 

3. Enter the necessary information in the Effect window data fields. 

• Channel � the channel for playback output (you can leave this blank). 

• Effect � the menus are identical to those shown in the sequence window. 

• Layers � the graphic element, e.g. layers, background, row, etc., on which to perform the 
effect. Options depend on the specific effect. If this is left blank the effect applies to the 
entire graphic. 

• Rate � set this rate as you would set rate in the sequence window described above. 

• Units � set the unit of measurement for rate. 

• Hold � when check, loads the graphic in and waits for a trigger to play the effect. 

4. If you wish to save the effect as an .efx file, press Save File or F12 and enter a file name then 
click OK. 

5. Press the play key or Alt + Enter to play the effect. 

6. Making sure the Sequence window is active, save the sequence using Save File on the FAK or 
F12 on the SK. 
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Check this box if you 
wish to have embedded 
effects to playback on 
graphics. 

Embed Effects 
To embed an effect into a graphic: 

1. Open a graphic in the Preview window. 

2. Select Style from the View menu (F6). 

3. Click the Graphic button on the Style window. 

4. Click the Select button and navigate to the effect (.efx) file. 

5. Save the graphic. 

6. To play the graphic simply open it in  
the Preview window. Deko automatically  
plays the associated effect. If read in the  
Program window, the graphic will cut to  
air without an effect. 

Note: This will not occur unless your Preferences  
are set correctly. Open Options>Preferences and  
click on the common tab. Check Automatically  
play associated effects.  

If the Effect Playback window is open when you  
open the graphic, Deko automatically focuses on  
the Effect Playback window after the effect plays. 

Note: Press Ctrl + Play to play 
the effect again. 
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Shortcuts 
 

Sequence Layout  SK: F11; FAK: Seq Edit 
Effects Layout Shift + F11  
Play Effect/Sequence SK: Alt + Enter; FAK: Play 
Stop Sequence Esc  
Save window contents SK: Alt + F12; FAK: Alt + Save 

File 
�Save as� window contents SK: F12; FAK: Save File 
Enable Horizontal Scrolling Alt +T > H 
Enable Vertical Scrolling Alt + T > V 



 10-1 

 Deko Training  

Lesson 10: Understanding Timeline Motions 

In this lesson we will introduce the components of the Timeline window and you will create a basic 
Motion using FXDeko�s Timeline Motion editor. We will also define the important concept of 
Content Independence. 

Before You Start 
The Timeline Motion editor, shown below, is an option for FXDeko v2.0 or higher. 

Using the Timeline Motion editor, you can create text animations, called Motions, which are not 
based on specific graphics. The Motion window contains a series of one or more Actions that is saved 
in a Motion (.mot) file. You can then specify that Motion file within a sequence, just as you would 
any other effect. 

 

The Timeline Motion editor enables the creation of on-screen moves, variable flight paths, dynamic 
re-sizing, X-Y-Z rotation and more. Choose from several 3D DVE effects to apply to any character, 
word, row, layer, background or full screen. Scrub through (preview) the Motion during its creation 
for real time feedback. 

Motion 
Actions
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Step-by-Step: Preview a Sample Timeline Motion 
�What�s so great about Timeline Motions?� Follow the steps below to preview a sample Motion that 
you will recreate from scratch in the next section: Step-by-Step: Build a Timeline Motion.  

Open and Play a Sample Sequence File 
1. Select the Sequence Layout (SK: F11. FAK: Sequence). 

2. Click once in the Sequence window to set focus.  

3. Press Clear Read (FAK) or F9 SK to reveal the Open Dialog. The path should read 
D:\Deko\Tutorial. Double-click on the file named 100.seq to open into the Sequence 
window. 

4. Press the play button in your Sequence window or play key on your Fast Action keyboard to run 
the sample Motion. 

Timeline Motions add a wealth of creativity for post and on-air applications. Automated elections, 
stock reports and live news are just a few of many areas in which Deko can improve the quality and 
efficiency of production. 

 



Understanding Timeline Motions 10-3  

 Deko Training 

Step-by-Step: Build a Timeline Motion 
The following steps will guide you through defining and building a Motion using the Timeline 
Motion editor found in FXDeko. If you get into trouble, please look at the Help section that follows. 

Choose Motion Compose Layout (Ctrl + Shift + M) 
1. Go to Window > Select Layout > Motion Compose (Shift + Ctrl + M).  

 
2. Your desktop will now reflect the image below. You should see a  

Preview window, Program window and Timeline Motion window. 
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To best explain the Timeline Motion editor we will use the analogy of a dance. As we step along, we 
will make references that should help you better understand the components of the Timeline 
interface.  

 
There are 5 sections of this interface that we will define one by one and refer to throughout this 
lesson using the IDs and descriptions above.  

(a) Action List 
This list is a summary of your performance. Consider each Action a dancer who�s Choreography can 
be individually specified. Right-click to add and delete Actions to the list as desired. Every Action 
has an associated Effect, defined in section (b). 

(b) Effect / Object 
An Effect is specified for every Action created in section (a). DVE Effects are selected at the top. They 
include Page Turns, Ripples and other editable 3D Effects. To edit and optionally save parameters of 
an Effect, click on the Edit button. 

Your chosen Effect will perform based on your definition of an Object. Objects can be characters, 
words, rows, layers, all layers together, background or the entire graphic. Select a Layer number 
below, in which to find the specified Object. 

Your Actions will perform in either Preview or Program. Check one to enable them. 

Motion 
Actions 

Timeline 
Toolbar  

Position 
Selector 

  Timing 
Bars 

In and Out 
Handles 

Scrub Bar 

Scrub Handle

(a) 
Action  

List 

(b) 
Effect/ 
Object 

(c) 
Parameter 

(d) 
Timeline Graph 

(e) 
Timing 
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(c) Parameter 
As every dancer has its own choreography, here you will specify Parameters of movement for every 
Action (dancer). This movement can be as basic or complex as you like.  

The more Parameters are specified, the more complex the movement. To enable a Parameter, place a 
check in the box beside it.  

(d) Timeline Graph 
Edit your Parameters by degree of position, scale, rotation, kern, skew and opacity. Adjust for curved, 
linear, cusp, smooth and symmetrical movement using the Continuity Tools found in the Timeline 
Toolbar.  

Click and drag the Scrub Handle across the Timeline Graph to preview the entire Motion. The 
Position Selector displays a list of position choices and is used only with the Position Parameter. 
Position choices and view of the Graph depend upon the Parameter currently selected. 

(e) Timing 
For every Action (dancer) created in section (a), a corresponding Timing Bar will appear. Grab 
handles at either end to adjust for In or Out Timing of Actions. 

When you define an Object in section (b) to be a character, word or row, a Sub-Bar will appear just 
below and is tied to the Timing Bar above it for that Action. Click and drag the round Offset control 
to adjust Timing delay.  

Exercise continued 
Continue the following steps to create a simple Timeline Motion. If you�ve already run the sample 
sequence, jump to step 3. 

Open a Sample File into the Preview Window (SK: F9, FAK: Read) 
1. Click once in the Preview window to set focus.  

2. Press Clear Read (FAK) or F9 (SK).  

3. The directory path should read D:\Deko\Tutorial. If it does not, change the directory path 
by double-clicking the C directory and scroll down to the Deko folder. Then double-click the 
Deko folder to find the Tutorial sub-folder.  

4. Click once on the file named 200.dko but do not press OK yet. 
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5. Take a look in the bottom of the Open dialog box. You will see an area titled File info that 
displays important details of your graphic. This contains a comment logged by the user while 
saving the file. See Further Exploration for these steps. 

 
6. Press OK to open a sample graphic in the Preview window and notice that the content of the 

graphic reflects the comment stored in the File Info area. 

Open a Sample Motion file 
1. If there is a graphic in the Program window, set focus to Program and clear the graphic so you 

have a blank screen (SK: F8 twice, FAK: Clear Program). 

  
2. Go to Edit > Clear All. 

3. Set focus to the Motion window and open the file named 200.mot. You should see only one 
Action in the Actions list.  
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4. This Action indicates that the Effect is a Screen move; the Object is defined as the entire 
Graphic, and will perform in the Preview channel. These are specified in the Effect section, 
where is can be modified. 

Create and Scrub a Basic Motion  
1. In the Parameter list, click once to place a check in the box next to Y Position to enable. In the 

Timeline Graph, position your mouse on the Scrub Handle. Click, hold and drag your mouse to 
the right across the Graph. This is called scrubbing.  

 
2. You should take notice of three things: 

• Your graphic will push down from the top, off-screen. 

• You will see a similar Scrub Bar appear in the Timing section. This acts as a guide for setting 
In and Out points to your Actions. 

• You can scrub forward or backward (right or left) and your output will reflect your Motion in 
real time! 

Create a More Complex Motion  
1. In the Effect section, click on the arrow under Effect and select Page Turn.  

2. In the Parameter list, click to enable Z Rotate. The default degree of Rotation is 360°. 

3. To change Rotation, click and hold on the small, red Bezier Point in the Graph, then drag 
down to 180°. 

4. For more accurate control, double-click in the Numerical Setting box on the Timeline Toolbar. 
Enter 180. Scrub the effect to preview. 

 

Scrub 
Handle 

Bezier Point

Scrub Bar 
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5. In the Effect section, click on the arrow under Object and change from Graphic to Background. 
Your Parameters and Effect will now apply to the Background only! Scrub to preview and 
notice that the text in Layer 1 now remains in place. All other Objects will stay put until an 
Effect is applied to a new Action. 

 
6. To add a new Action for your text layer, right-click on the first one and select Insert. You can 

also right-click to Delete Actions. 

 
7. The default Effect for the new Action is the same as before. Click on 

Object and select Layer.  

8. FXDeko can build an unlimited number of layers. Assign Layer 1 in the 
Layer Number field.  

9. From the Parameter section, enable Y Position. Click on the Position Selector in the Timeline 
Graph and select �Bottom to Home�.  

 
10. Enable X Position and set the position for �Right to Home�. 

11. Enable Z Rotate. Scrub to preview. 

Note: Home Position 
We have given FXDeko the intelligence to identify the result of a finished graphic and make this 
equivalent to the end keyframe in a Motion, saving both time and effort for the operator. The graphic 
itself becomes an integral part of a Motion. We call this the Home position.  

Position 
Selector
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All off-screen objects begin their motion path in the same position. Notice below that every character 
is overlapped. This motion requires little effort since all you will need to do is plot the direction from 
which you want your object to appear. 

 
If the content is changed for any reason, off-screen position remains the same and Deko will 
automatically work out the parameters of the graphic and individual flight paths for every object. 
Home position defines the result of the Motion. 

See the Further Exploration section of this lesson to run a sample Motion that best defines this 
concept. 

Your 200.mot Motion should now contain two different Actions: a Background Page Turn and a 
Layer Screen move. However, each Action performs at the same time. Follow the next steps to set 
separate In and Out times for each Action. 

Adjust Timing  
When you inserted a new Action in step 6, you may have noticed the addition of second Timing Bar. 
This appeared because every Action has its own, independent Timing control. Again, think of it as 
Choreography for a dance and each dancer has separate In and Out times during a performance. 

Off-screen, 
Start position 

Character 
Flight Path 

Home 
Position 
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To adjust Timing: 

 
1. Look for a light gray highlight to appear behind the Timing Bar and the corresponding Action. 

This indicates correct selection.  

2. Select the first (top) Timing Bar.  

3. Click, hold and drag the Out Point to the left. 

4. By default, a playback rate in seconds will display during selection of any In or Out point. To 
change the Playback Rate or Units, select the arrow next to either box Timeline Toolbar. 

 
5. Position Out Time for the first (top) Timing Bar at 1:10 Seconds.  

6. Click, hold and drag the In Point for the second (bottom) Timing Bar and position IN Time at 
1 Second. These will overlap slightly. 

7. Scrub to preview. 

Create a Character-Based Motion 
1. In Effect, click on the arrow under Object and change from Layer to Character. 

2. You�ve now changed the way the Motion defines an Object. Your Parameters and Effect will 
now apply to the characters of Layer 1 individually but at the same time!  

3. Scrub to preview and notice that each character has the same Start position off-screen.  

4. You should also notice the addition of a Sub-Bar below the Timing Bar. This appears anytime 
an Object is defined as either: Character, Word or Row. 

 

IN Time OUT Time

Playback 
Rate 

Units of 
Playback 
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The Sub-Bar provides finer timing control of your Object�s movement and is tied directly to 
the Timing Bar above it.  

5. Click, hold and drag the round Offset control just a pinch to the right. This will increase (to the 
right) or decrease (to the left) the delay between each character. Scrub to preview. 

6. When the Offset Control is positioned on the left directly over the Simultaneous Tab, there is 
no delay in placement between each Object.  

7. As the Offset Control is moved to its right, more delay will appear in between the placement of 
each Object. 

8. The Sequential Tab places each Object, one directly after the other.  

9. The Sync Button synchronizes timing on multiple actions that look to the same object (layer).  

10. The Pause Button will hold that Action. A GPI or manual trigger will resume the Motion. 

11. Position the Scrub Bar toward the end of the Timeline.  

12. Set focus to the Preview window and select the words Tonight on.  

13. Overwrite the text with Tonight’s Lineup on. Your text will automatically word wrap 
and shrink to fit full because we have applied these parameters to the text layer (make sure 
Word wrap and Shrink to fit are selected in the Layer section of the Style dialog box). 

14. Notice in the output that your Motion maintains its flight path, regardless of the content! 
Motion paths are specified in Objects. Whether an Object contains one letter, one word or one 
layer of several words, the path is never tied strictly to the content. We call this Content 
Independence.  

Timing 
Sub-Bar 

Pause 
Button 

Offset 
Control 

Simultaneous 
Tab 

Sync 
Button 

Sequential 
Tab 
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Content Independence 
The objective of Deko�s Motion editor is to provide a mechanism by which to fly objects around the 
screen. In doing so, we recognize that a CG has specific needs just as any word processor, where 
relationships are formed between letters, words, sentences and paragraphs. This concept is also built 
into Deko, having created a motion environment that allows these relationships to be maintained. 
Deko allows an object to be defined equally as: 

The letter: T 

The word: Tonight 

The row:  Tonight on Channel 22. 

Either way, we have created a system whereby is does not matter. Based on what you specify in the 
Motion editor, Deko automatically works out the definition of an Object without user intervention, 
saving both production time and cost. This is also ideal when interfaced to an automation system or 
external databases where content is not known at the time Motions are built! 

Play the Motion 
1. So far, you�ve been scrubbing through your Motion manually using the Scrub Bar. To preview 

your Motion in real time, click the Play button on the Timeline Toolbar.  

 
2. Press the Swap key to take the graphic back to Preview. 

When you use the Play button to playback a Motion, Deko plays the entire Motion at the 
playback rate specified on the Timeline Toolbar. However, this rate is ignored when the 
Motion file is specified within a sequence. The sequencer�s rate of time for that event takes 
priority.  

You have now successfully created a basic Motion. Save this file. For a more complex approach, 
follow the next steps to enhance the existing Motion. 

Stop/Pause/Play 
Playback 

Rate GPI Trigger 
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Create a Point-to-Point Motion 
For the sake of identifying the next steps, we will call this keyframing. Though keyframing is a term 
mostly used on a DVE, Deko can produce a similar effect whereby different points of position are 
inserted as part of an Action for your Object.  

Rather than Actions performing off-screen to on-screen, or on-screen to off-screen, Deko allows you 
to create Point-to-Point Actions within the screen and as part of a single Motion. Consider that your 
existing Action for the text layer already has two Points (keyframes):  

• Start point (Bottom) 

• End Point (Home) 

We will add another. Let�s begin by editing our first Point (the direction from which our Object 
appears off-screen).  

1. Select the second Action assigned to Layer 1.  

2. Click in the box beside X Position to disable that Parameter.  

3. Click on Y Position to highlight the Parameter, but do not disable it. A check should remain. 

4. From the Position Selector box in the Graph, select Top to Home. This defines the first and last 
Points. By now, you should notice that the display in the Timeline Graph will change to reflect 
the values of the selected Parameter. 

5. Drag your Scrub Bar to about 2 seconds into the entire Motion. It should line up in the center 
of the second, corresponding Timing Bar (not the Sub-bar). 

 

Lineup 
Scrub Bar Insert  

Bezier 
Point #2 

Bezier 
Handles 

Point #1 

Point #3 
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6. Click once on the Insert point icon in the Timeline Toolbar. Your mouse pointer will display a 
�+� sign. 

 
7. Position your mouse in the Graph where the blue Scrub Bar and yellow, diagonal Timeline 

intersect. Click once to insert a red Bezier Point with two, purple handles at opposite ends. This 
becomes Point 2. 

8. The red Bezier point acts as a keyframe for repositioning. You can also assign a level of 
continuity by choosing one of five Continuity Tools in the Timeline Toolbar (see above). Deko 
defines continuity as a degree of smoothness from Point to Point. To assign continuity to Point 
2, the Point must be selected (indicated in red).  

9. Click on the Cusp Tool in the Timeline Toolbar. This sets the level of continuity for Point 2 to 
be Abrupt instead of Smooth.   

10. Click on the bottom, purple Bezier handle of Point 2 and drag upward so it creates an arch.  

11. Click on the top, purple Bezier handle and drag upward and to the right so it creates a V with 
both handles. 

Move to/Line/Curve 
Line Tools 

Cusp/Smooth/Symmetrical 
Continuity Tools 

Point #1

Purple Bezier handles control the 
amount of continuity expressed Point-
to-Point during movement of an Object. 

Point #2
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Next 
Point

Previous 
Point 

Point 2 

Point 2 Right 
Bezier 
Handle 

Point 3 
Bezier 
Handle 

12. The motion we are creating is an abrupt bounce of our Object 
during its flight path. To make this more effective, select Point 2 
either manually with your mouse or for more accurate selection 
click on the Next Point Icon in the Timeline Toolbar. 

13. Click, hold and drag Point 2 downward and below the Home 
position line. The Home line will lift upward to display a greater 
area below it.  

14. Release Point 2 when about ¼ of the Graph 
displays beyond the Home line. Select the 
right Bezier handle of Point 2 and drag 
upward. Select the only Bezier handle of Point 
3 and drag upward. This creates an arch and 
provides a taller bounce to your effect. 

15. Just for fun, enable both the X and Y Scale 
Parameters. In the Background Action change 
Effect from Page Turn to Tiles and play your 
Motion! Then save it. 

Note: Though we have just created a Point-to-Point 
Motion for Position, this is only one of many 
Parameters. For greater creativity you should 
experiment and apply these steps to other Parameters.  

Create a Transition Action 
The Motion that we have just created applies to the contents of Preview graphic only and does not 
consider a graphic that may exist in the Program window. Let�s now consider Program and create a 
transition between Preview and Program graphics. 

1. Select the Program window and open the file 100.dko.  

2. Right-click in the Action List and insert a new Action.  

3. In the Effect panel, change the Object to Graphic and select for Program at the bottom.  

4. Enable Opacity and X and Y Scale Parameters.  

5. Shorten the timing duration to 1 second. 

6. Scrub to preview. You should see the Program graphic shrink and dissolve center screen.  

7. For a better effect, select X Scale and position the second point to 2 instead of 0. This will scale 
that parameter to twice it�s size instead of shrinking to zero.  
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8. Do the same for Y Scale but follow the tip below. Then Scrub to preview and save the Motion. 

 

Tip: Copy and Paste Function 
Values of a Point can be copied and pasted for use within the same Parameter. Rather than creating 
details of a point from scratch, click on X Scale and Copy (Ctrl + C); then click on Y Scale and Paste 
(Ctrl + V). This will apply those same values. 

Congratulations on successfully building your Motion. Your results should match the sample 
sequence 100.seq. Continue on to explore more advanced techniques. 

Edit a DVE Effect 
The Timeline interface offers a large list of DVE Effects to apply to an Action. From this list, you can 
customize and edit the Parameters of a chosen Effect.  

1. Click once on the top, Background Action. In Effect, change from Tiles to Page Turn and click 
on the Edit button to open the DVE Effect Editor shown below. 

 
2. There are many Parameters that can be edited and saved into a Template. Select Number of

Waves.  

Edit 
Slider 
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3. Click, hold and drag the Edit slider to the right. Set the value for 5 waves and click OK.  

4. Scrub to preview the new Effect. 

Create an Absolute Motion Path 
In the start of this lesson we mentioned the Timeline�s ability to begin and end Motions in any 
arbitrary position determined by the user.  

1. Open and play the sample sequence 300.seq. This provides a good example of Absolute 
Motion.  

2. After you have viewed the sample, clear your Program window and open 400.dko in Preview.  

3. Select the Motion window and open 200.mot.  

4. Change the Effect from Graphic to Layer and enable X Position.  

5. The default for X Position is Left to Home.  

6. Click on the Position Selector in the Graph and select Absolute.  

7. Notice that the Timeline changes to portray Absolute left, center and right coordinates.  

8. Scrub to preview.  

9. You should see your text layer fly in from off screen/left, through the center and off 
screen/right. Our objective is to create an on-screen flight path. 

 
10. Position the scrub bar at the very front (left) of the Timeline.  

11. Click on the left Point Abs lf and drag down to just above the Centerline.  

Note: 
Offscreen 
Position 

 
Off screen (start 
or end) position 
for any Object in 
flight is exactly 
one full-screen in 
any direction. 

 

Absolute Paths Absolute Paths 



10-18 Understanding Timeline Motions 

 Deko Training 

12. Click on the right Point Abs Rt and drag up to just below the Centerline.  

13. View your output as a guide for placement. Scrub to preview. 

 
14. Enable Y Position and select the Absolute path.  

15. Use the Copy function on the X Position and Paste to the Y Position (see the Tip in step 11).  

16. Enable Z Rotate then Scrub to preview. 

Left Point

Right 
Point 
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Help 
Why Does My Program Output Disappear When I Scrub a Motion? 
When you click and drag the Scrub Handle, you enable what is called Scrub mode. This puts the user 
into a place where the Program output is ignored for the sake of previewing the creation of a motion 
effect.  

In the instance where the user does not have a graphic in 
the Program window, then nothing is affected. But in the 
case where there is a graphic in the Program window, but 
there is no accommodating Program Action, then the 
Program channel is ignored. 

To disable Scrub Mode, click once on the Scrub Handle 
Icon in the Timeline Toolbar. Your program graphic will 
reappear in the output monitor. 

I played My Motion From the Timeline Toolbar. Where is My Preview Graphic? 
When you play your Motion, remember that Preview graphics will now appear in Program. Press the 
Swap key (SK: F3, FAK: Swap) to transfer back from Program to Preview. The Program graphic (if 
there was one) will disappear. 

Scrub Handle 
Icon 

Play button 
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Exercise: Build a Slate Motion 
The previous steps helped you to build various motion 
paths. In this exercise you will build a more advanced 
motion for the slate.dko graphic (right), already 
created (Lesson 5, page 34). Every layer has also been 
named (Lesson 5, page 30). 

We will incorporate the following techniques that will 
make the most efficient Motion playback: 

• Layer-naming  

• Wild Card for Grouping  

• Inserting Points 

• Copy and Paste 

• Pausing 

1. Go to Motion layout. (Shift + Ctrl + M) 

2. Set focus to the Preview window and open the file slate.dko, 
created in Lesson 5. 

3. Click on the Clear Motion tool to start with a fresh Motion 
window.  

4. Click on the (bottom) Preview Action.  

5. In the Effect section, specify the Object to be the Background.  

6. In the Parameter section, click in the box to 
the Left of X Position to enable that parameter.  

7. In the Timeline Graph section, click on the 
down arrow in the Position Selector and 
choose Right to Home. 

8. Above the Timeline Graph, specify 5 
Seconds as the total Rate of Time for this 
Motion. 
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9. In the Timing section, click and hold on the Out point (triangle) for the bottom Timing bar. 
Drag left until it displays an Out time of 1;0s (1 second, 0 frames). 

 
10. Click on the New Action tool to insert a new 

Action in the Action list.  

11. By default, the Object will specify a 
Background. Change this to Layer.  

12. We will use this Action for the layer named 
Title. Click on the down arrow under Layer 
name or number. A drop down list of layer 
names will display. Select Title. 

Note: Benefits of Layer Naming  
Specifying a layer name avoids a dependence on layer priority and saves 
time for the operator.  

For example: If an Action specifies layer number and a new layer, such as a 
logo, is added to the intended graphic, the layer priority will be changed 
and the Action will now affect a different layer. This will require the 
operator to open the intended graphic and re-order the layers. 

Layer naming is the most efficient way to build a Motion, and naming layers smartly will allow you 
to group multiple layers. 

1. Enable the parameters X Position and X Rotate.  

2. With the parameter X Rotate highlighted, click and hold on the red 
point next to 360°. Drag in a downward direction and release at 180°.  
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3. In the Timing section, click and hold on the In point for the third Timing bar. Drag right until 
it displays an In time of 1;0s (1 sec, 0 frames).  

Click and drag the Out point left until it displays an Out time of 2:10s (2 sec, 10 frames). 
Click, hold and drag the Scrub bar to preview. 

Add Actions for Bullet Layers 
1. Insert a New Action.  

2. Specify the Object as Layer and in Layer name or number, select 
Col 1a. 

3. In the Parameter section, enable X Position. 

4. In the Timing section, move the In point for the 
fourth Timing bar to 2;10.  

Note: Be sure that the third and fourth Timing bars do not overlap. 

 
5. We will use layer naming as a method for grouping multiple layers. 

In this example, we will group all layers that begin with �Col 1�. 
To do this, under Layer name or number, replace the �a� with an 
asterisk (*).  

Drag the Scrub bar to preview. This is called a wild card. 

In Point 

Out Point 
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Note: Notice the addition of a sub-bar 
below the timing bar. This provides more 
control over grouped Objects and only 
appears when an Object is specified as 
Row, Word or Character or used as a Wild 
Card. We will use the round control in the 
sub-bar to create a sequential delay 
between the placement of each bullet. 

6. Click, hold and drag the round control slightly to the right. Scrub the Motion to see the delay. 
Then click on the center gray square in the sub-bar to place the round control. 

 
7. Scrub to preview a sequential placement of each bullet in the �Col 1*� group.  

8. Since the Action for Column 2 will be almost identical to Column 1, we can copy 
and paste this Action for the text in Column 2. Click on the fourth Action. Press 
Ctrl + C, then Ctrl + V.  

A duplicate action is created and a fifth Action and Timing bar will display. 

 
9. Under Layer name or number, replace the �1� 

with a �2�.  

10. Enable the Opacity parameter, and then enable 
both X Scale and Y Scale. Scrub to preview. 
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11. As an advanced technique, we will add a Point to the Scale parameter timeline 
to create a dynamic re-size of the text. Click on the word X Scale to display the 
graph for that parameter. Be careful not to disable it. 

12. Just above the Effect selection click on the Insert Point tool.  

13. Position your mouse in the Graph and click in the very middle of the yellow timeline. A red 
point will display. (Fig. A) Click on the red point and drag up to just above the 1.00 line.  
(Fig. B) 

 
14. In the Parameter section, click on the word X Scale. Press Ctrl + C to copy the values of that 

parameter. Click on the word Y Scale. Press Ctrl + V to paste the values. A red point will 
display. 

15. Play the Motion to preview real-time playback.  

16. Finally, we will place a pause for the 
manual reveal of each bullet point. Click on 
the pause icon below the fourth Timing 
sub-bar to enable a pause between the 
placement of each Object. The pause icon 
will turn blue to indicate that it is active.  

17. Play the Motion. The Play key will trigger 
after each pause. Save the motion as 
slate.mot. 

Figure A Figure B 
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Further Exploration 
How Can I Increase the Degree of Rotation Beyond 360°? 
Although the Timeline Graph displays default Rotation values from �360° (counter clockwise) to 
+360° (clockwise), you are not limited to this setting. To apply Rotation beyond +360°:  

1. Click and hold on the small, red Bezier point in the Graph.  

2. Drag your mouse in an upward direction. Your Graph will display the added values or enter the 
desired value manually in the Numerical Setting box. 

3. Use this same approach in the downward direction to apply Rotation counter clockwise. 

 

What Happens When I define an Object as a Word or Row? 
When an Object in the Effect section specifies a character, word or row, a Sub-bar will appear just 
below the Timing bar for that Action. This gives you the ability to apply a delay between each 
Object during its flight path. Experiment by selecting each and scrubbing through the Timeline to 
give you a better feel for the difference between each. 

Run a Motion that Defines �Home Position�  
1. Select Motion Compose Layout.  

2. Set focus to the Preview window and open 200.dko.  

3. Set focus to the Timeline Motion Editor and open procedural.mot.  

4. Click and hold on the scrub bar arrow and then drag to the right to preview the effect. 

5. Edit to the content by adding or deleting text, and then scrub the motion again. Notice that 
the effect remains the same regardless of the number of characters input. 

Clockwise (Drag 
Up) 

Counter 
Clockwise (Drag 

Down)

Numerical 
Setting 
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Shortcut Keys 
 

Motion Compose layout Shift + Ctrl + M 
Clear Program window SK: F8 twice; FAK: Clear Program 
Swap SK: F3; FAK: Swap 
Save File As SK: F12; FAK: Save File 
Save File SK: ALT + F12; FAK: ALT + Save File 
Open Macro window SK: F2; FAK: Macro Edit 
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Lesson 11: Using Macros 

A command is an instruction to FXDeko to perform a specific function. 

The FXDeko user interface (menus, shortcut keys, etc.) implicitly executes commands. Every time 
you press a key or select a menu item, you invoke a command that directs FXDeko to perform a 
function. 

If you know the command name for the function you wish to perform, you can invoke the command 
explicitly by entering its name on the Command Bar. 

 
 
For example, the command to clear the current graphic is clear graphic. Try it. Press F4 to 
select the Command Bar, type clear graphic, then press Enter. 

Some commands have user-defined parameters. The Prompt button on the Command Bar opens a 
Command Prompt dialog box where you can specify parameter values. The Defaults button in the 
resets a command�s parameters to their default values. 

Every command recognized by FXDeko is listed and described in detail in the accompanying 
FXDeko Command Reference. 

A macro is a sequence of FXDeko commands. You can name and store a macro by saving it in a file. 
You can invoke a macro in the same way you can invoke a command, by typing the macro name on 
the Command Bar and pressing Enter. 

Once you learn FXDeko�s macro language, you will be able to write and edit macros directly in the 
Macro window. For now, you can follow the simple instructions in this section to quickly begin 
creating macros using FXDeko�s Macro Recorder. 

Using the Macro Recorder 

Recording a Macro 

Macro Play 
Macro Record 
On/Off Toggle 

Macro Stop 
Playback 

Macro Pause 
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To Record a Macro: 
1. To turn the macro recorder on, do one of the following: 

• Click the record button at the far right end of the text bar.  

• Go to Macro > Record Macro (Ctrl + F2). 

On the text bar, the button lights up red to indicate that the macro recorder is on.  

2. Use the keyboard and/or mouse to perform the sequence of actions that will constitute the 
macro. 

3. To turn the recorder off, do one of the following: 

• Click off the record button on the text bar. 

• Go to Macro > Record Macro (Ctrl + F2). 

• Press F2 to turn the recorder off and activate the Macro window. 

To view the macro you just recorded, do one of the following: 

• Go to Window > Select Layout > Macro Edit. 

• Go to View > Macro (F2).  

Playing a Macro 
To play the active macro, do one of the following: 

• Click the play button near the right end of the text bar.  

• Choose Play Macro (Alt + F2) from the Macro menu.  

On the text bar, the play button lights up green to indicate that a macro is playing.  

Note: the name of the macro that is currently playing appears on the status bar. If no Macro window 
or Sequence window is active, FXDeko plays the macro in the most recently activated Macro 
window. 
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Exercise � Recording a Macro 
To see how this works please perform the following steps: 

1. Click the macro record button and notice that it highlights in pink. 

2. Click on Preset 1 in the Preset Style window with your mouse or press Style 1 (FAK). 

3. Press F5 or Program (FAK) on your keyboard to select the graphic window, and then type the 
word Deko. 

4. Double click on this word to select it. 

5. Click in turn on presets 2 to 8 in the Deko Preset Style window or press Style 2 to 8 (FAK). 

6. Click on the record macro button again to turn off the record function. 

7. Press the Macro Edit key or go to View > Macro. The macro you just recorded will be 
displayed. 

 
8. Press F5 then F8 or Clear Program (FAK) to select the graphic window and erase it. 

9. Click on the green macro play button to perform the macro and you will then see the word 
Deko appear in Style 8.  

You may have expected it to appear first in Style 1 then cycle through to Style 8. The reason 
that it does not appear to do that is that the macro performs all of the actions very quickly. 

10. To slow down the macro, select the macro window (as in step 7). 

11. Click with your mouse at the end of select word and then press the Enter key to insert a 
carriage return. 
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12. Type render. This is a useful command when you want the machine to wait until it displays a 
graphic before moving on to the next step. 

 
13. Click at the end of select_style_preset 2 and then press the Enter key to insert a 

carriage return, type render. Repeat for other rows as shown below. 

 
14. Click on the green macro play button and watch as the display now changes from style 1 

through 8 with a short delay. 

 

Click at end of �select_style_preset 2� 
and enter a carriage return.  

Type Render.  

Repeat this for the other rows. 

Click here (step 12)  
Enter a carriage return and type the 

word render 
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Replacing Commands 
The command render is not the only command that you can use to force the machine to wait until 
it updates. You can also use the wait command and specify how long you wish the machine to wait. 
The syntax to use is wait 1 for 1 second or wait 0 12 for a 12 frame delay. There is a very easy 
way to replace commands in macros and this is to use the replace function. To see how this works 
please perform the following steps: 

1. Press Macro Edit to view your macro. 

2. Place the cursor at the top line. 

3. Go to Edit > Replace. 

4. Type render in the Find what: window, and wait 1 in the Replace with: window (see the 
figure below) then click on Replace All. 

5. Close the replace window. 

6. Click on the green macro play button. The delay will now be 1 second between events. 

 

Loops and Variables 
The above program can be made shorter by using a loop and a variable instead of typing the same 
information several times. For example, you can type select_style_preset and render or 
wait just once but use them however many times they are required.  You can find more 
information on variables in the on-line help menu but basically there are 2 types: 

• System-defined � A system variable is prefixed by the @ symbol and examples are @time and 
@date which are the PC time and date respectively. 

• User-defined. � User-defined variables are prefixed with the $ symbol and can be any name 
that you require (without gaps) but the first character after the $ symbol must NOT be a 
number. 

To modify the macro that you have just created to use a loop and variables do the following: 
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1. You should see the display as in the figure above. 

2. Modify the macro to appear as below. 

 
In the above example, you will see the user-defined variable ($num) and the loop command. The 
comments appear after hash symbol (#) to show what each line of the macro does. These are not 
necessary for the program to work but are included for future reference. 

Click on the green macro play button to perform the macro. 

Note: $num was used to indicate a number in the above example; it is good practice to use a name 
that describes what the variable does. For example, $name if you want to enter a name, $loc or 
$location for entering a location. 
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Assigning Macros to the Preset Macro Key 
For repetitive tasks, you can create a macro and assign it to the Preset Macro key. To access functions 
assigned to this key, hold down the Preset Macro key and press the assigned key for the Macro. 

1. If this is a new macro, record your macro with the macro recorder. 

3. Press the Macro Edit key (SK: F2, FAK: Macro Edit), to open the 
Macro Window. You will see several lines of K language that define your actions in code. 

4. Save the macro (SK: F12, FAK: Save File). 

5. Press the Preset Macro key in the bottom, left on the FAK. This will open a window where you 
can enter up to 26 macros as character assignments. 

 
6. Scroll to the desired key assignment and 

click on the key. 

7. Press the Select File button. The Select 
Preset Macro dialog box appears. 

8. Navigate to the desired Macro file. Select 
the file and click OK. 

9. The Macro will appear assigned to the 
desired key.  
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10. Click close to accept the assignment. 

11. To run the Preset Macro, press the Preset Macro key + the assigned key. 
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Exercise: Build a Serve Indicator Macro 
1. Open the sample graphic D:\Deko\Tutorial\225.dko. A lower third scoreboard for a 

tennis match will display. See the sample below. 

2. To the left of the player names, locate the yellow ellipse shape layers. Continue on to build a 
macro that will hide or reveal these layers to act as serve indicators. 

 
3. From Style Edit layout, click on the Macro record button in the top, right of the Deko interface 

to enable the Macro recorder. The button will turn pink to indicate record. If you are asked if 
you wish to clear the Macro window before recording, select yes.  

4. Go to Layer > More Layers.  

5. From the More Layers window, scroll down and select Layer 14. 
Click OK. 

6. In the Style Edit window, click on the Layer button. 

7. Click the More button at the bottom of the window, then click 
on Hide. Layer 14 will be hidden. 

 
8. Click on the pink Record button to stop the Macro recorder.  
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 Figure A

9. Press the Macro Edit key to open the Macro window to view the recorded commands. These 
commands make up the serve_up macro.  

We will need 2 more macros: serve_down and serve_none. 

10. Within the Macro window, select and delete all commands except what is displayed in Figure A. 

11. In an effort to be efficient, this macro should also contain 
commands to show Layer 13. Select and copy (Ctrl + C) the 2 
command rows. 

12. Move the cursor below the last line and paste (Ctrl + V).  

13. Highlight the 14 in the second layer 14 and change it to 13. 

14. Highlight 0 in the second layer_edit show=0 and
change it to 1. 

15. Save this macro as serve_up.mcr. Your macro should look like 
Figure B. 

 
16. Edit this macro show Layer 14 and hide Layer 13. Save this as serve_down.mcr. Your 

macro should look like the following: 

 

 

Figure B
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17. Modify this macro to hide Layer 14 and Layer 13. Save this as serve_none.mcr. Your macro 
should look like the following: 

 

Run Macro on FAK 
To run this Macro on a FastAction keyboard: 

1. Press the Preset Macro key to open a dialog window. 

2. Scroll down and select the Z location, then press the Select File button. 

3. Navigate to D:\Deko\Tutorial\macros, and select the macro file named 
serve_up.mcr. 

4. Scroll up to the X location, and then press the Select File button. 

5. Navigate to D:\Deko\Tutorial\macros, and select the macro file named 
serve_down.mcr. 

6. Scroll up to the C location, and then press the Select File button. 

7. Navigate to D:\Deko\Tutorial\macros, and select the macro file named 
serve_none.mcr.

8. Go to the Options menu and select Save Settings Now, to maintain the Preset assignments after 
re-launch of the Deko program. 

9. Press Preset Macro, then the appropriate character to run the macros. 

Run Macro on SK 
To run this Macro on a Standard keyboard: 

1. Press the Cmd key (F4) to enter your cursor in the command line. 

2. Type serve_up then press the Enter key. The macro will play. 

3. Type serve_down then press the Enter key. The macro will play. 
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4. Type serve_none then press the Enter key. The macro will play. 

5. You will not need to re-type any of the macros above. Press F4, then the up or down arrow to 
gain access to recently played macros. 

Exercise: Review and Run a Directory Select Macro 
The directory macro: dir_select is already created and stored in the D:\Deko\Tutorial folder. 
This macro enables the user to change through several directory paths quickly and efficiently.  

This exercise works in conjunction with a previous exercise found on page 15 of Lesson Three: 
Setting up and Managing File Directories. If you have not completed that exercise, go back and refer 
to those pages before continuing on.  

1. Press the Macro Edit key (FAK) to open the Macro window. 

2. Open the macro D:\Deko\Tutorial\dir_select.mcr. The following Macro will 
display: 

 
There are three sections of this Macro, separated by a blank row: 

• In the first section, a choice list of directory paths is provided. These choices are user-defined 
and can be accessed rapidly in the form of a drop down list. 

• The second section contains commands that will perform based on the chosen directory. The 
commands will set all directory paths chosen by the user for each of the five Deko File Type 
categories: Graphics, Macros, Styles, Motions and Custom Typefaces. 

• After the directory choice is selected and all directory paths have properly changed, a 
confirmation of the selected directory will appear in the bottom, left of the Deko status bar. 

A.  
Directory Choices  
(user-defined) 

B.  
Directory Change  
Through 5 File Type 
categories 

C.  
Confirmation of directory 
change in status bar 
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Exercise � �my_settings� Macro 
This Macro will record all software and hardware settings and preferences as defined by the user into 
the Macro Edit window. A Deko operator, who begins new work on a fresh Deko system, can restore 
all of their preferred settings by running this Macro as a one-time process. Save the Settings once and 
they will restore each time the Deko is powered up. 

We will record 3 commands and save as one Macro file for playback on a new Deko system: 

learn @preference � Records all settings enabled in the Options/Preferences menu, such as: 
Starting Layout, Prompt options, Current Directory, Cursor Style and other options.  

learn @settings � Records all software settings such as Preset Macro assignments, Preset Style 
and Shader options and other options. 

Caution: Running the �learn @hardware� command will affect I/O settings that may have 
already been established by technical staff. Be sure you have proper permissions before 
modifying the hardware settings. 

To Create �my_settings.mcr�: 
1. From Style Edit layout, open the Macro Edit window. (SK: F2, FAK: Macro Edit) 

2. Click on the Macro record button to enable the Macro recorder. The button will turn pink to 
indicate record. If asked if you wish to clear the Macro window before recording, select yes. 

3. In the Command Bar, type the following 3 commands separated by a semicolon: 

learn @settings; learn @preference

(Be sure to include a space between learn and @) 

4. Press Enter to display all the commands that 
make up your settings in the Macro Edit window. 

5. Click on the pink record button to turn the 
recorder off. 

6. Set focus to the Macro Edit window and press  
Ctrl + End to place the cursor at the very end of 
the Macro. 

7. To display a confirmation of the Macro�s success, 
type the following: 

message My Settings Complete
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8. Save the Macro as “my_settings.mcr”.

To Run �my_settings.mcr�: 
1. From the Command bar, type the following: 

my_settings

 
2. Press Enter and look to the bottom, left on the status bar. Your message should display in the 

lower left corner of the Status bar. 
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Lesson 12: Creating Clocks and Timers 

Clocks and countdowns are a common element of graphics. In earlier versions of Deko, building 
clocks required the use of macros. Beginning with version 4.1 of the Deko software, building a clock 
or timer is greatly simplified.  

This lesson will introduce the new clock feature in version 4.1 software. Building a clock is a two-
step process. First the clock parameters are formatted. Multiple clock styles can be created. Next, you 
create a graphic layer and assign the clock you created to the layer. Let�s review the first step. 

Creating Clocks 
The new clock feature is found in the Style menu. In version 4.1 software, 
the Layer view of the Style menu has changed. The Auto-Update panel 
provides selection buttons to choose your Auto-update source, and Clock 
is added as a choice. When the Clock button is clicked an ID box appears 
to allow you to assign different clocks to different layers or graphics.  

Press the View Clocks button to reveal 
the Clock List dialog box. 

Clock List 
The Clock List shows the current clocks available and provides 
buttons for creating new clocks, as well as modifying or deleting 
existing clocks.  

 

Add a Clock 
1. Go to View > Style Menu. (FAK Font or Look) 

2. Set focus to the Style window and click on the 
Layer button to select the Layer view. 

3. Select the Clock button from the Auto Update 
section. 

4. Click on View clocks to show the List.  

5. Click the Add button. The Configure Clock dialog 
box will open. 

6. Enter Data in the appropriate fields and Click OK 
to add the clock to the clock list. 
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Add Clock Data Fields 
• Clock Type � click on pull-down arrow and choose from three choices: Time of day; 

Countdown, or Countup. 

• Format � set timing format for Time of day � HH:MM:SS; HH:MM � or 
Countdown/Countup � HH:MM:SS, HH:MM, MMM:SS, SSS. 

• Time Offset � will set an offset for the time output, from your system clock time (useful for 
time zone shifts). 

• Hour Format  � 12 Hour or 24 Hour display. 

• Append AM/PM � Adds an AM or PM to 12 hour output 

• Keep leading zeros � will keep the zero in place for times, such as 01:25PM. 

• Separators � Choose colons, semicolons or commas. 

• Tenths display � Countdown/Countup timers only.  

Insert a Clock in a Graphic 
1. Create a layer in your graphic for the clock or timer. 

2. Assign a preset style to the layer. 

3. Go to View > Style Menu. (FAK Font or Look) 

4. Click on the Layer button to select the Layer view. 

5. Select the Clock button from the Auto Update section. 

6. Click on View Clocks to show the Clock List.  

7. Click on the up or down arrows 
from the ID window to select the 
correct clock ID. The clock will 
appear in the data field. 

 

 
 

Note: When choosing Countdown/Countup timers, you must click 
the Start button in the Clock List to begin the count. Click Reset to reset the timer. 

Note: For some fonts, digits can shift left and right as the clock advances. To 
avoid this, choose monospace or digits rather than proportional spacing. This 
setting is found in the Font section of the Style window. 
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Exercise � Create a Clock 

Create a Clock 
1. Choose the Style Edit view.  

2. On the Style window click the Layer button to reveal the Layer view. 

3. Click the Clock button in the Auto Update panel. 

4. Click View Clocks. The Clock List window appears. 

5. Click Add Clocks. The Add Clocks dialog box 
appears. 

6. Make the following settings in the data fields: 

• Set Clock Type to Time of Day. 

• Set Format to HH:MM. 

• Check Append AM/PM. 

7. Click OK. The new clock will be added to the 
Clock List. 

Add Clock to Your Graphic 
1. Create a new Text Layer. 

2. Choose a style from your Preset Style palette. 

3. Choose the Layer view on the Style window and Click Shrink to Fit box in Auto-scaling section. 

4. Under the Auto Update section, click on Clock. 

5. Set ID to the Clock ID from your Clock List. The new clock will appear in your Text Layer 
formatted to your settings. 
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Preview       Program A       Program B 

Lesson 13: Channel Configuration 

Single/Dual Channel Operation 
All graphics can be created in either the Preview or Program window. This makes no difference to 
the graphic. The Program window shows the current �on-air� graphic and matches Deko�s video 
output. The Preview window shows a graphic that is not yet �on-air�. Preview is most used to 
demonstrate what is about to become an �on-air� graphic. 

Depending on the configuration of your Deko system, you can view up to two Program outputs plus 
a Preview output. 

To Specify Single Program Plus a Preview Output: 
In the Channel menu do one of the following: 

• Click Program/Preview 

• Click Keying and Routing. In the dialog box, select 
Program/Preview 

To Specify Dual Program Output: 
Your system must be configured with 2 Program output cards. 

In the Channel menu do one of the following: 

• Click Dual Program 

• Click Keying and Routing. In the dialog box, select Dual Program 

In Dual Program mode, you can view a Preview window plus Program A 
and Program B windows. To view Program B, go to the View menu and 
select Program B. 

There is no dedicated layout to view 
all of these windows at once. 
However, Deko smartly allows you 
to open each window and create 
your own layout. See the sample 
below. 
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The FastAction Keyboard provides dedicated keys for operating in Dual Program mode. Pgm A and 
Pgm B keys set focus to the desired Program window. 

The Sequence window also provides a selection for playing an effect to either Program A 
or Program B. In the Sequencer, click the down arrow in the Channel field and choose the 
desired function. 

 

Using Deko�s Built-In Keyer 
With Deko�s built-in keyer, you can key text and graphics over a live input of video. And you can 
frame grab this input. Or, use Deko�s linear key output to key text and graphics downstream 
through a switcher.  

Keying and Routing 
1. Connect an input video signal to Deko, and optionally a key signal. 

2. In the Options menu, click Hardware settings. Click Input selection and select the appropriate 
input signal. 

3. From the Channel menu, choose Keying and Routing. 

You will see a selection 
list for both Channel 1 
and 2.  

Selections from this list 
will vary based on the 
current Channel Usage, 
selected at the bottom of 
this window. 

 
 
 
To turn off Deko�s built-in keyer: 

• Choose Deko only. 

To turn on Deko�s built-in keyer: 

• Choose Deko + Input 1 or 2 
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To view a Clip: 

• Choose Deko + Clip - Keys mixed. 

4. Choose the type of key:  

• Choose Keys mixed to view key signals for both the selected Video input and the Deko 
graphic. 

• For example: A DDR feeds Input 1 with an animated logo. Deko provides a text crawl across 
the bottom lower third, then sends this downstream for keying through the switcher. 

• Choose Full key to avoid viewing an unwanted key signal from the selected video input. 

• For example: This would be typically selected when frame grabbing from a camera feed. 

Frame Grabbing 
Note: The internal keyer does not need to be on to perform a Frame Grab. 

Connect an input video signal to Deko, and optionally a key signal. Do one of the following: 

• In the Channel menu, choose Frame Grab 

• In the Keying and routing menu, choose Frame Grab 

To Grab with Key: 
In the Keying and routing menu, enable Grab with key. 

To Suppress Motion Jitter: 
Go to Channel menu, choose Motion suppress, then select Motion suppress now. You can optionally 
choose to suppress all Motion jitter while grabbing, and other options handling fields and scan-lines.





 14-1 

 Deko Training  

K. Browse Graphics, 
Browse Typefaces 

L. Preset 
Styles 

M. Function
Keys 

N. Dual Channel 
Selection 

O. Transform 
Tools 

P. Clear Channels 

L. Undo 
Redo 

J. Macro 
Record & 

Cmd 

G. Preset 
Macro 

F. Transform 
And Text 

Formatting 
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E. Playback D. Smart 
Read 
Keys 
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H. Tab 
Set 

Q. Delete File 
Save File 

B. Numeric 
Keypad for 

fast Graphic 
Recall

C. Read 
Key 

A. Graphics 
Counter 

Lesson 14: FastAction Keyboard 

The FastAction Keyboard (FAK) enables common tasks to perform with a single keystroke. It is 
designed for use in real-time on-air environments, where speed is critical. 

Though the Deko User Manual provides a detailed description of all FAK functions � this Lesson 
contains a Quick-Start Chart, condensed descriptions to help get you started and steps to enable your 
FastAction keyboard. 

 
 
 

FAK Quick-Start Chart 

 

 
 

A. Graphics Counter � Use the graphics counter (alphanumeric display) to view the numeric 
location of a file as it is being typed. Press the Read key (C.) to recall the file to the currently 
selected window. The counter will advance to display the next sequential file. Press the Prev 
(-) and Next (+) keys on the numeric keypad to cycle through all files (alpha and numeric) in 
the current directory.  

B. The Numeric Keypad � Press the Num Lock key to enable. A yellow light will illuminate. 
This provides fast access to reading files. You can quickly call up graphics with numerical file 
names by typing the filename on the numeric keypad. Press the Read key (C.) to open to the 
currently selected window. 
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C. Read � Type the numeric location or press the Prev (-) or Next (+) keys to display a file in 
the graphics counter. Press the Read key to open that file to the currently selected window. 
Pressing Clear, then Read will display the Open dialog box. You can navigate, then double-
click on a filename to open into the currently selected window. 

D. Smart Read keys � (Read Preview and Read Program) automatically opens the entered 
filename to the either the Preview or Program channel without changing focus of the current 
window. This allows random access to either channel with a single keystroke. 

E. Playback and Macro Edit keys � Playback controls for sequences and single effects include 
Stop and Play. Pause is executed by pressing the Play key while an effect is in progress. 

Press the Macro Edit key to open the Macro Edit window in any layout. A combination of 
commands can be typed or recorded to this window, then saved as a *.mcr file. Macros are 
designed to automate repetitive tasks and speed production. 

F. Text Formatting Tools � Include: Page Up/Down keys to select layers, Home/End keys to 
insert cursor inside layer, and the Insert key to toggle INS and OVR modes of typing text. 

Layers and text can be manipulated on screen with Transform Tools. Controls for 
transforming can be accessed by holding the Alt key down and pressing the directional 
arrows. 

G. Preset Macro key � You can store macros to a character assignment and execute them by 
pressing the Preset Macro key and the desired character. 

H. Tab Set � position your cursor, and press the Tab set key to insert a Tab stop in the following 
formats: Left, Center, Right and Decimal. 

I. Undo/Redo keys � You may wish to Undo or Redo a particular action. Pressing the Undo 
key will backtrack keystrokes and mouse-clicks until you have reached a desired state. The 
Undo function must be enabled in the Edit menu. 

J. Macro Record & Cmd key � Press the Learn key at this location to turn on Macro Record. 
This will record all keystrokes and mouse � clicks to the Macro Edit window. Open this 
window to view the commands.  

Press the Cmd key and type the Macro filename to play a Macro. 

K. Browse Graphics/Typefaces � Press the Browse Graphics key to open a window of thumbnail 
images displaying all graphic files for the current directory. Press the Browse Typeface key to 
display thumbnail images for all fonts loaded on the system. 

L. Preset Style keys � Select text, then press any one of eight Preset Style keys to load the look 
and font displayed in same position of the Preset Styles window, located at the bottom of the 
Style Edit layout.  
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M. Function keys � Deko�s 12 Function keys are enhanced with quick access to commonly used 
text functions. These include font selection, treatment, size and spell-check. 

N. Dual Channel Selection � For multi-channel (2 program and 1preview) systems, press the 
Pgm A or Pgm B keys for quick dual-channel selection. 

O. Transform Tools � Use these tools to manipulate layers and text on screen. They include 
Move, Scale, Rotate/Skew, Kern/Lead. Hold down the Alt key down and press the directional 
arrows to control transforming. 

P. Clear Preview and Program � Clear Preview and Program channels with a single keystroke. 
This will revert the graphic to a default state containing one default text layer. 

Q. Delete Files and Save Files � Delete files and save files rapidly by entering the numeric 
location. Press the Delete or Save key twice to execute that function. The graphic counter 
will advance to the next sequential location. 
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Exercise: Fastest Way to Get Random Graphics to Air 
1. Press Num Lock to enable the numeric keypad. A yellow light will illuminate. 

2. Press the Effect key to change layout displaying the Preview and Program channels 

3. Press Clear Preview and Clear Program. 

4. Look to the graphics counter on the FAK. If a file location is displayed press the Clear key. 

5. Type: 100. 

6. Press the Read Preview key. The next file 101.dko will display in the counter. 

7. Press the Read Program key. The next file 102.dko will display in the counter. 

8. Set focus to Preview. 

9. Press the Next (+) key to jump over 102.dko and advance to 103.dko. 

10. Press the Read Preview key. 

Repeat these steps with other graphics to familiarize with this section of the keyboard. This is your 
best and most efficient tool for on-air operation. 

Exercise: Fastest Way to Get Sequential Graphics to Air 
1. Press Clear Preview and Clear Program. 

2. Type: 100.

3. Press the Read Preview key. 

4. Press the Read Next (*) key. Then again. 

Note: you will see sequential files read into the Preview channel then swap to the Program channel, 
all in a single keystroke. 

Enable / Disable Function Keys 
To enable/disable FastAction function keys (F1 - F12): 

1. Go to Options > Preferences > Common. 

2. Under Keyboard click FastAction Function Keys. 

3. Click OK or press Enter. 



FastAction Keyboard 14-5  

 Deko Training 

Note: When the FastAction Function Key box is checked, the F1-F12 keys access the functions 
engraved on the keycaps, which mirror Deko text bar functions. When the box is unchecked, the 
keys function as on a standard Deko keyboard. 

Enable FAK Numeric Keypad 
To enable the FastAction numeric keypad: 

1. Go to Options > Preferences > Common. 

2. Under Keyboard click Enhanced. 

3. Click OK or press Enter. 

Note: Once enabled, the numeric keypad provides FastAction access to reading files. To quickly 
recall graphics with numerical filenames, type the filename on the keypad and press Read. The 
display shows the filename as it is being typed, and advances to the sequential file when you press 
Read. 

The keyboard will display an alphanumeric filename, but only numeric filenames can be entered on 
the numeric keypad. To read in any filename, press Clear to clear the display, then press Read. In the 
Open dialog box, type or double-click on the filename.  
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Lesson 15: SportsWare and Pops 

The SportsWare option includes two powerful features to enhance fast-track character generation: 
Pops and Macro Autoplay. Macros were discussed in Lesson 11. In this lesson we will learn how to 
create and apply Pops. 

About Pops 
The Pops feature allows you to create and �pop� a text selection onto an open graphic. These text 
selections are saved as text files or as special graphic files, which you can use like any other graphic 
file. You can even specify pop files, including text (.txt) files, in sequences. 

There are three ways to pop text onto the CG page:  

Text Pop 
A Text Pop pops in text only (from a .txt file) at the cursor position. Text is rendered in the current 
style. For example, during a baseball game, you can pop stats into a lower third. 

Style Pop 
A Style Pop pops in text and font at the cursor position. This works like a text pop, except it renders 
text in the stored style associated with the pop rather than the current style. 

Place Pop 
a Place Pop pops in text and style appear on a specific position of the graphic, regardless of where the 
cursor is. You can, for instance, pop �Final Results� in the center of an on-air election graphic, even 
if the cursor is at the top of the page. 
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Creating a Text Pop 
To create a text pop: 

1. Open a word processing program. 

2. Type the text. 

 
3. Navigate to the drive and directory where you will store the file and save the file as a text (.txt) 

file. 
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Creating a Style Pop 
To create a style pop: 

1. Activate a Program or Preview window. 

2. Choose a preset style or create a new style for the text. 

3. Type the text. 

4. Select the text, not the layer. 

5. Navigate to the drive and 
directory where you will store 
the file, and type a name in 
the File name text box. 

6. Click the Save Selection button. 

Creating a Place Pop 
To create a place pop: 

1. Activate a Program or 
Preview window. 

2. Create a layer for the text or 
use the default layer. 

3. Choose a preset style or 
create a new style for the 
text. 

4. Type the text. 

5. Select the layer, NOT the 
text. 

6. Navigate to the drive and directory where you will store the file, and type a name in the File 
name text box. 

7. Choose Save Selection. 

Style Pop  
Select Text not Layer 

Place Pop  
Select Layer not text 
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Note: When you use Save Selection to save a graphic, the Graphic browser indicates next to the 
graphic file name that the graphic is a pop file. Likewise, the File Info section of the File Open dialog 
box will tell you if a file is a pop file. 

Using Pops 

To Pop Text Onto a Graphic Using a Text Pop or Style Pop: 
1. Open the graphic file and position the cursor or select the layer where you will pop in the text. 

2. Press Clear Read (FAK) or F9 (SK) to open the file.  

3. In the dialog box, navigate to the drive and directory containing the text pop (.txt) or style pop 
(.dko) file. 

4. Choose the file from the File Name list box or type it in the File Name text box, then click OK 
or press Enter. 

Note: Deko pops the text into the current or selected layer of the graphic, then automatically selects 
the next layer behind it. It does not create a new layer for the pop. 

To Place Pop Text onto a Graphic: 
1. Open the graphic file onto which you will pop the text. 

2. Press Clear Read (FAK) or F9 (SK) to open the file.  

3. In the dialog box, navigate to the drive and directory containing the place pop (.dko) file. 

4. Choose the file from the File Name list box or type it in the File Name text box, then click OK 
or press Enter. 

Note: Deko creates a new layer for the place pop in front of the current or selected layer, then 
automatically activates the layer behind the previously current or selected layer. 

Graphic Browser and File 
info: section of File open 

dialog indicate �pop� graphic. 
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Exercise � Creating and Using Pops 

Creating a Text Pop 
1. Go to Start > Programs > Accessories > Notepad.  

The application Notepad will open. 

2. Type Jimmy Keys in the open window. 

3. Go to File > Save. The Save As dialog box will appear. 

4. Navigate Save in box to D:\Deko\Tutorial. 

5. Type 021 in the File name box and click Save. 

 
6. Highlight the text in the window and type  

Terry Matthews. 

7. Go to File > Save As and save the file as 051. 

8. Repeat this process and save the following names as 
these files: 

Name Save File As 
Alan Mills 075.txt

Eric Davis 024.txt

Brady Anderson 009.txt
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Creating a Style Pop 
1. In Deko, clear the Program window.  

2. Click on the Preset Style window and open training_pops.pst. 

3. Select the Layer in the program window, and then Select Preset Style 2. 

4. Type the following five names with numbers: 

 
5. Select the first row within the layer but DO NOT select the end of row marker. 

 
 

6. Press Save File (FAK) or F12 (SK).  

7. When the Save Graphic As dialog 
appears, enter 521 in File name and 
click on Save Selection. This will save 
the selection as a Style Pop. 
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8. Select the next row (remember not to select the end of row marker). 

9. Press the Save File key and enter 551 in File name, then press Save Selection. 

10. Repeat steps 8 and 9 and save the next three rows as follows. 

Name Save File As 
75 Alan Mills 575.dko

24 Eric Davis 524.dko

9 Brady Anderson 509.dko

 

Creating a Place Pop 
1. Clear the Program window.  

2. Delete the default text layer and draw a text layer about 1 inch high from the bottom-right of 
the safe area indicators. 

 
3. Select Preset Style 4. 

4. Type Live. 

5. Center justify the text (Ctrl+5). 

 
6. Select the layer, and press the Save File key.  

7. Under File Name, enter 700.dko and click on the Save Selection button. 
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Using Text Pops 
1. Open the graphic file 1501.dko. The graphic is a background with a lower-third template made 

up of one layer. 

2. Select the layer, which is waiting for a player name. 

3. Do one of the following: 

• On the number pad enter 021 and press the Read Key (FAK). 

• Press F9. Set List Files of Type to .txt and enter 021 in the File Name box (SK).  

The Pop Jimmy Key will appear in the Text Layer formatted to the style of the layer. 

 
4. Press Read (FAK) or F9 (SK) and enter 051 on the number pad. The Name Layer will change to 

Terry Matthews. 

5. Repeat this for the other three Text Pops: 075.txt, 024.txt, 009.txt.  



SportsWare - Pops 15-9  

 Deko Training 

Using Style Pops 
1. With the layer still selected, read 521.dko. Notice that the style has changed within the layer 

to the style of the saved Pop. 

 
2. Repeat this for the other four Style Pops: 551.dko, 575.dko, 524.dko, 509.dko.  

Using Place Pops 
1. Open the file training_stocks.dko. 

2. Read 700.dko. Notice that the Place Pop appears in the lower right corner of the graphic. 
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Lesson 16: Automation 

What is Automation? 
Automation allows you to control your Deko Character Generator from another computer program. 
Usually that program is running on a different computer, and sending commands to the Deko 
through a serial line or a network connection. But since Deko runs on a standard, Windows NT 
platform, the controlling program can also be run on the same computer as the Deko. 

Traditionally, CG automation interfaces have been used by newsroom automation systems, such as 
Newstar, Basys, etc.. For example, using these systems journalists and producers type in the names of 
people who appear in a news story. Those names along with the name or ID number of a template are 
then sent over to the CG, for display during that news item. 

The template is a file created by the CG operator, which picks the layout and style of the text. The 
newsroom automation program that sends commands to the CG fills in the content. 

With Deko, you can move beyond newsroom automation, and create simple custom interfaces for 
data entry and update. The benefits are really quite amazing�a custom interface running on the 
Deko serves as pre-packaged access to the power of the machine. This allows a relatively untrained 
person to create quite sophisticated effects. The simplified interface also helps prevent errors, by 
restricting the novice operator�s options. The experienced operator can always �reach behind� to the 
full power and flexibility of the Deko. 

Pinnacle has created several examples of what can be accomplished with automation. The �Sports 
Score Update� provides fields for the names of two teams, and the name of the CG template in which 
to display the score. The user can then hit �add� buttons to update the scoreboard displayed by the 
Deko.  This application is especially well suited for fast-scoring sports like basketball.  

How Does Deko Automation Work? 

Push vs. Pull Technology 

Deko 

Newsroom System 

Newsroom pushes content to Deko 
templates. Deko sends * to acknowledge 
receipt of data. 

Sports Integration System 
(IDS / Walter Bohlin Systems) 

Content is sent to Deko template. Sports 
systems sends confirmation to Deko of 
sent data (R command). 

Replace Deko layer Usage 
Push Data 

Query Deko layer Usage 

Pull Data 

Deko layers set to 
replace. Doors are 
open awaiting data 

Deko layers set to query. 
Deko sends a request for 
data ( X command ). 
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Enable Automation 
You only need to perform these steps once.  After that, your machine will come up with Automation 
enabled. 

1. Within Deko, go to View > Automation.  The dialog box will open at the bottom of the screen. 

 

2. In the Port text field, type in the Communications port that Deko will be using, most often 
COM1 or COM2. 

3. Under Type Select �I.I.I.� for Intelligent Interface. 

4. Under ID, if you have only one Deko put �1�.  

5. In the Default Doc field, select either �Program� or �Preview�, to decide which screen receives 
your data. 

6. Lastly, check Automation Enabled. A successful connection will show a message such as �Server 
created through \\ . \COM1�. 

 

7. Close the Automation dialog box. 
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Creating a Template File 
This section describes the process of creating a template file, which will later be filled in by the 
automation interface, as sketched out in the next section. 

1. Within Deko, design the look of your .dko file, selecting the fonts and colors. You may design 
using just one layer, and putting example text on the screen. 

2. After you have designed and created your look, you are ready to select the text fields. Each text 
block that needs to be updated through automation must be put into its own layer. Repeat the 
following steps for each text field: 

3. Highlight the text. 

4. Go to Text > Text to Field. This puts the highlighted text to its own independent layer. 

5. Go to Layer > Layer Properties. 

6. There are two screens for this window.  Select More to view page two of this window. Under 
Text Initialization set Usage to �Replace�. This allows the layer to be updated through the 
Automation Interface. 

7. We recommend that you select Shrink to Fit, and uncheck Word Wrap. This is also where you 
select the centering alignments for your layers. 

In later versions of Deko software, you may need to reassign the layer order of the layers that are set 
to �Replace� starting with the first layer to be updated as layer one. To reassign layers, select each 
layer and then use �Ctrl+� or �Ctrl��. Layer One will receive the first set of data from the 
Automation Interface, layer two will get the second, and so on� 

In newer versions of Deko software, you can set an ID for interfaced layers (query or replace). This ID 
represents a priority order in which layers will be filled with external data. To assign an ID, select 
each layer. In the Style window, click on the ID arrow under Auto-Update. 
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Using the Template 
With a successful connection made between the Deko and the external control program, you will 
begin to see data in the Automation Window.   

When a command is sent that the Deko understands, it responds with an asterisk ( * ). 

For example, a Newsroom Automation system sends:  

W\100\900\layer one text\layer two text\\<0D> <0A>

Deko responds: 

*

In this example: 
 W = Write to layer 
 100 = Name of the file where the transmitted text will be stored 
 900 = Template 
 Layer one text = transmitted text for the first layer set to �Replace� 
 Layer two text = text for the second layer set to �Replace� 
 \\ = Command terminator 
 <OD> = Carriage Return  
 <OA> = Line Feed 
 

In response to this command, the Deko will create a file called 100.aut, which contains the two 
lines of text that were sent by this command, along with the name of the .dko file serves as the 
template � in this case, 900.dko. 

When, at a later time, the file 100.aut is read, it will cause the Template file 900.dko to be read, 
and its fields will be filled with the data in 100.aut. 
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Lesson 17: Other Options 

Deko provides a number of options which expand the capabilities of your system. In this lesson, we 
will examine four options designed to enhance the Deko system: 

• Database Connection 

• Cap Shaders 

• Still Deko 

• Clip Deko 

Database Connection 
The Automation option now includes a dynamic feature that enables Deko to read and display 
information from a database. This means you can set up a layer to query a database and display the 
value of a field within that database. 

A database query differs from Deko�s existing query feature, which sends inquiries to a newsroom 
automation system. Database queries send inquiries to database files, which may be stored on a local 
system drive or accessed by a LAN or WAN. 

To use the database connection feature, you must have the ODBC driver installed to support the 
database source. The ODBC driver is automatically installed during installation and setup of your 
database software package. You must also specify a data source name (DSN).  

View ODBC Drivers 
To view installed ODBC drivers: 

1. Go to Start > Settings > Control Panel. 

2. Double-click the ODBC icon to open the ODBC Data Source Administrator dialog box. 

3. Click the ODBC Drivers tab. 

Specify a DSN 
See also the Test Drive section on page 16-4. 

To specify a DSN: 

1. Go to Start > Settings > Control Panel. 

2. Double-click the ODBC icon to open the ODBC Data Source Administrator dialog box. 

3. Click one of the following: 

• User DSN � To create a data source that is visible only to you and can only be used on the 
current machine. 
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• System DSN � To create a data source that is visible to all users on the current machine. 

• File DSN � To create a data source which allows you to connect to a data provider and which 
can be shared by multiple users who have the correct driver installed. 

4. Click the Add button, select the driver for which you want to set up a data source, then click 
Finish. 

5. Type in a Data Source Name. 

6. Click the Select button, navigate to the database file, and then click OK. Click OK two more 
times to close the dialog box. 

Query Database 
To set up a layer to query a database: 

1. Select the layer. 

2. Go to View > Database to open the Database window. 

3. In the window, choose a Database Name, then check the Connect box. 

4. Choose a Table In Database. 

5. Specify a record within that table, by selecting a Field Name and entering a Field Value for that 
field. 

6. In Display Field, choose the field whose data to display in the layer. 

7. Enter a value in the Frequency box to specify how many seconds to wait between requests to the 
data source for updates. If Frequency is set to zero, the automation interface will issue the 
request only once. 

8. Click Create Query. 
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Database Window Options 
• Database Name � A database name defined in the ODBC Data Source Administrator. 

• Connect � Connects Deko to the specified database. 

• Table In Database � A table within the database. 

• Field Name � The field used to identify a data record within the database. 

• Field Value � A value of the specified Field Name field. This can be �hard-coded� as a 
specific value, or you can enter the variable, $Where_ColVal, then use the Command Bar to 
update the value of the variable. See the topic, To use a variable Field Value, later in this 
section. 

• Display Field � The field whose value to display in the layer. 

• Create Query � Associates this database query with the current layer. 

• Read Query �Reads query associated with the current layer into the Database window. Select 
a layer that has been previously set up for database query, then use this button to display 
options already specified for that layer in the Database window. 

To Set a Global Field Value: 
1. From the Command bar, type global $FieldValue 

2. Play command. 

To Use a Global Field Value: 
1. Set layers Field Value to: $FieldValue 

2. From the Command bar, type $FieldValue = “pcle” 

3. Play the command. All values should update. 

Note: the FieldValue �pcle� refers to the value for Pinnacle Systems Inc. found in the Tutorial demo 
Stocks database. 
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Test Drive 
Before you begin, you must have Microsoft Access installed in your Deko PC. It might also be a good 
idea to open the sample database, Sample.mdb, in Access and look at the two tables, 
Elections and QVC, to get a general idea of their contents and structure. 

This exercise requires the use of these Deko Sample Files: 
Race.dko

Race2.dko

Sample.mdb (this file must be copied to your hard drive) 

To register the Database: 

1. Click Start at the bottom of your desktop, choose Settings, then double-click Control Panel. 

 
2. Double-click the ODBC icon to open the ODBC Data Source Administrator dialog 

box.  

You should be looking at User DSN options. If not, click the  
User DSN tab at the top of the dialog box. 

 
3. Click the Add button. 
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4. Select Microsoft Access Driver, then click the Finish button. 

 
5. In the Data Source Name text box, type Sample. Usually, you can use any name you want, 

but for this test drive you must use Sample. 

 
6. Click the Select button, navigate to the Sample.mdb file, and then click OK.  
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Notice that the pathname for Sample.mdb appears in the Setup dialog box. 

 
7. Click OK again and notice that Sample appears in the User DSN list. 

 
8. Click OK once more to finish the process and close the dialog box. That�s it! You don�t have to 

do this again until you want to add ODBC access for another database. 
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Query the Database 
Set up a layer to query the database. We will set up a layer in the Race.dko template to display the 
name of the first candidate in race 3. 

1. Open the graphic, Race.dko. 

On WriteDeko, this file requires the Unlimited Layers option.  Instead, you can use the file 
Race2.dko, which only has five layers. 

 
2. Select layer 2, the one that says �Mark Sanders�. 

3. From the View menu, select Database to open the Database window, then fill in window 
options as Sample as the Database Name. 

• Choose Sample as the Database Name 

• Check the Connect box. 

• Choose Elections as the Table in Database. 

• In the Field Name box, enter ID. 

• Enter 3 as the Field Value. 

• In the Display Field box, choose Candidate1.  

4. Click the Create Query button. 
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Voila! Candidate 1 in race 3 is�Teicia Joffe. 

 
5. Select Layer 8, the one that displays Teicia�s total votes. 

 
6. In the Database window, click the Read Query button. 

7. Change the Field Value from 1 to 3. 

8. Click the Create Query button. The display now tells us 
Teicia has 12,000 total votes. 
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Set Up Automatic Query Updates 
By default, update frequency is set to zero and the automation interface issues a query only once. 
Let�s set up Race.dko to automatically update Teicia�s total vote count every ten seconds, so that 
we will have an accurate total as the votes keep rolling in. 

1. Make sure layer 8 is still selected, the one that 
displays Teicia�s total votes. 

2. In the Database window, change Frequency to 10. 

3. Now, keep Deko running while you open the 
Sample.mdb database in Access and go to the 
Elections table.  

4. Change the value of Total Votes1 in row 3 to 
12,003. Save the change to disk by closing the 
table. Within ten seconds you will see the Deko 
display change to reflect the new total. 

 

 

 

 

Note: You can tell when Deko is updating a query even if the Display Field value isn�t changing. 
The status line displays a �rendering� message during each update. 



  Other Options 

Deko Training 

17-10

Set Up the Graphic to Update Fields Based on a Global Variable 
You may have noticed that when you changed the Field Values for Candidate1 and Total Votes1 
from 1 to 3, then clicked Create Query, none of the data in other layers changed. Those layers still 
displayed information from race 1. Most likely, you would want to display all of the results of race 3 
all at once. Can you do that without changing the Field Value for each layer individually every time? 
Yes, if you go through the one-time process of entering a global variable as the Field Value for each 
layer. 

1. Go to View > Command Bar. 

 
2. Click the command text box and type $Where_ColVal=3, then click Play. 

3. For each layer in Race.dko: 

• Select the layer. 

• Click Read Query at the bottom of the Database window. 

• Now click the Field Value drop-down list box and choose 
$Where_ColVal. 

• At the bottom of the Database window, change the 
Frequency to 10. 

• Click the Create Query button. Notice that within 10 
seconds the field display changes to reflect values in race 3. 
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4. On the Command Bar change the command to $Where_ColVal=4 and click Play. Within 10 
seconds you should see all the field values change again. 
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CAP Shaders (Cel Animation Player) 
A CAP (cel animation player) shader produces a detail with an animation. You can use a CAP shader 
to apply a cel animation to a detail, just as you can use other types of shaders to apply ramps, colors, 
or textures. A CAP shader differs from other types of shaders in that you cannot apply a cel animation 
to a background.  

A typical way to use the CAP shader is to create a rectangle and choose CAP for the rectangle�s face 
shader. Make the rectangle large enough or it will clip the edges of the animation. It is also 
important to make the rectangle small enough without clipping so you maintain the maximum 
efficiency.  

By specifying a CAP shader, Deko will recall a series of image frames. On the Deko2000, the series 
of frames will automatically loop, producing the animation. On the FXDeko, the series of frames are 
loaded and the first one displays as a static graphic on the detail. FXDeko only plays the cel 
animation in the context of a motion. See Playing a Cel Animation. 

You can have more than one CAP shader in a graphic. Performance may degrade as Deko encounters 
large animations or a lot of details in a graphic. 

Applying a Cel Animation 
To apply a cel animation to a detail: 

1. Create a Shape field. (a rectangle or ellipse).  

2. In the Style window click on the Look Tab. Make sure there is a 
Face detail. 

3. Open the Face detail�s shader. 

4. At the top of the Shader window, choose CAP. 

5. Click on Open to select a file. The Select Cap file dialog box will 
open. 
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6. Navigate to the directory containing the sequential animation file and locate the first file in the 
sequence.  

7. To verify file open parameters click on the Options button. 

 
8. Choose No scaling or Square pixels, preserve height from the How to format section. Use 

Square pixels, preserve height if the animation has not been resized for Television (see Lesson 6). 

9. Click OK. Then Click OK to close Select CAP file dialog box. 

10. In the Face Shader Frames: field, enter the total number of frames 
in the Animation sequence. 

11. Choose CAP Options: 

• Forward/Backward � specifies which direction the animation 
will play. 

• Oscillate � reverses direction of the animation each time it 
plays. 

• Continuous � plays cel animation through any pause in the 
motion. Automatically puts a pause at the end of the motion so 
the animation continues when the motion ends. 

• Rate � the rate of animation playback in frames per second. 
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Setting Up the Animation File to Play 
1. Open the graphic that includes the CAP shader in the Preview window. 

2. Activate the Motion window. If necessary, go to Motion > Clear Motion 
to restore default settings to the Motion window. 

3. Click the second default motion descriptor to select it from the script list on the left hand side 
of the Motion window. 

 
4. Click the arrow next to the Object dropdown menu and select Layer from the drop-down menu. 

5. Enter the layer number of the layer that contains the CAP shader in the Layer number text box. 

6. Uncheck opacity from the effects parameter list. 

7. To view the cel animation, play the motion or, if you have the Timeline option, scrub through 
the timeline. 

Keep Animation Playing 
To keep a cel animation playing once a motion ends, in the Shader window, under CAP shader 
options, select Continuous. Deko automatically puts a pause at the end of the motion so that the 
animation continues when the motion ends. 

CAP Performance Guidelines 
A rough limit for the size of an individual frame (image) for a CAP shader that plays in real time is 
approximately 1/9 of the screen size in NTSC (if this is the only motion being played).  That means 
that, since NTSC is 720 x 486 = 350,000 pixels, the file size of an individual frame should be no 
more than about 39,000 pixels (x 4 bytes per pixel = 156 kilobytes, uncompressed). 
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The StillDeko Option 
The StillDeko option brings Deko graphic file management to a new level of efficiency and ease of 
use, through Lightning integration. This is the most powerful, efficient and useful Still 
Store/Character Generator integration available today. 

To see whether StillDeko is enabled, go to Options > Enabled Options. A checkmark next to 
StillDeko indicates that it is enabled. If StillDeko is not enabled, contact your Pinnacle Systems 
dealer. 

Lightning and Thunder 
Lightning is a high performance, network based, image storage and management system, used in on-
air broadcast and production. Thunder works similarly, and has the added capability to store and 
manage clips as well as still images. StillDeko uses Thunder Browse software to integrate Thunder 
and/or Lightning with Deko, for the most powerful graphics management available. Once you install 
the Thunder Browse software, you can open and edit a Lightning image in Deko, associate a Thunder 
clip with a Deko graphic, and store Deko files in a Lightning database on your Deko�s hard drive or a 
networked Lightning system. 

Install Thunder Browse Software on Deko 
1. Connect the Thunder dongle to the parallel port on the back of your Deko. If you have any 

other dongle already connected, connect the Thunder dongle onto the back of the dongle 
already there. 

2. Insert the Thunder CD in your Deko�s CD drive. 

3. In the bottom left corner of desktop, go to Start > Run. 

4. Click the Browse button and navigate to the Setup.exe file on the Thunder CD, then click OK. 

5. Follow the on-screen prompts to complete the installation. The installer will ask you to choose 
Thunder or Thunder Browse. Choose Thunder Browse. 

6. Once the installation is complete, go to Start > Shut Down > Restart. 

7. Once the computer has restarted, go to Start > Programs > Thunder Browse. 

8. Thunder Browse prompts you to enter the Options Enable password. Refer to the Important 
Notice, included with your Deko documentation, for the password. Enter the password, which 
is case sensitive, and click OK. 
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Connect to An Existing Remote Database 
To access databases on another system in your network, you must first connect to that system. After 
you follow this one-time connection process, the other system will always appear in the Thunder 
Browser Tree. 

If your Deko is not networked, check with your network administrator. 

1. Open Thunder Browse.  

2. Go to File > Open. 

3. In the Look in field at the top of the Open dialog box, choose Network Neighborhood. 

 

 
4. Double-click the remote system name, the exported drive (usually D), the Lightning directory, 

and then the database (.pff) file you wish to open. 
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Set Up a Database on Your Deko 
You must first setup file sharing for the drive where the database will reside. After that, you can 
create a new database, and open it. 

File Sharing 
To set up file sharing on the hard drive: 

1. Go to Start > Programs > Windows Explorer. 

2. Right-click the drive where you will store Lightning databases (probably C or D), then choose 
Sharing. The Properties dialog box appears with the Sharing tab selected. 

3. Under the Sharing tab, click the New Share button. 

 

4. Type the drive designation letter (such as C) in the Share Name text box, then click OK, then 
click OK again on the Properties dialog box. The selected drive is now shared. 
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Create and Open a Database 
To create and open a database: 

1. Open Thunder Browse. 

2. In the File menu, click Advanced, then Create New Database. 

3. Select Lightning as the Database Type. 

Note: Thunder and Lightning databases are different. Thunder and Thunder Browse can access both 
Thunder and Lightning databases. Lightning can access only Lightning databases. If you are creating 
a database on your Deko system we recommend that you select Lightning as the Database Type. This 
way, any Lightning or Thunder machine can open your database. 

 

4. Enter a Database Name. 

5. Enter a Database Path, unique to the new database, that contains the full path name of the 
directory where the new database will reside. 

6. Choose 525 for NTSC (the default setting) or 625 for PAL. 

7. Thunder automatically enters other field 
values for you. Click the Create button. 

8. Go to File > Open, and navigate to the new  
database (.pff) file. Then click the Open  
button. 
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Set Default Database 
To set a default database: 

1. Open the database, as described above, so that it shows up in your Thunder Network Tree. You 
can select any database as the default database. It can be a database on your hard drive, or 
anywhere on the network. 

2. In the Thunder Network Tree, navigate to the database, then right-click the database name. 

 
3. In the drop-down menu, click Set Default Database. 

Access Stills and Clips 
To open a still image from Deko: 

1. In Deko, click anywhere on the Program or Preview window. 

2. From the File menu, choose Open From Lightning.  

3. In the Open From Lightning dialog box, double-click anywhere on the image data line. 

Data lines TIP: You can re-sort images 
alphanumerically by StillNum, 
Date, Title, Category, User, or 
Memo, by clicking the 
appropriate sort button. 
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To browse for images: 

Hold Alt and press the Tab key to find Thunder, then release Alt to open Thunder Browse. 

 
Thunder Browse has a variety of View menu options, to display exactly the information you want. 
Refer to the Thunder documentation and Online Help for more details. 

 

Still Images 
You can open a still image from the Thunder Browse into the Deko in several different ways: 

• Right click on the still, and choose Title from the drop-down menu. 

• Left click the still, then press function key F9 on the keyboard. 

• Use the numeric keypad to type the number of the still, then press F9. 

Any of these three operations will switch you over to the Deko application, with the image you 
picked loaded into the Preview or Program window�whichever was active when you left the 
application. 

If Deko is already open, you can drag and drop an image from Thunder Browse to the Deko Preview 
or Program window, where you can then edit the image like any other Deko graphic. 

Once you edit and save a graphic in Deko, Thunder marks the upper right corner of 
the thumbnail image of the graphic with the Deko logo.  
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Clips 
Thunder Browse marks thumbnail images of clips with a small film clip in the upper right corner. 
You can associate a clip from the Thunder Browse with a Deko graphic. When you then use the 
graphic in a sequence, Deko plays the clip simultaneously with the effect associated with the graphic. 

To associate a clip with a Deko graphic: 

1. In Deko, open the graphic in a Program or Preview window. The window must be active. 

2. Drag and drop the clip from the Thunder Browser onto the graphic. 

Store Images 
To save a Deko graphic in a Lightning database: 

1. Open the graphic in an active Program or Preview window. 

 
2. From the Deko File menu, choose Save To Lightning. 

3. In the Save To Lightning dialog box, you can edit any of the file details, which default to the 
details of the last saved image. StillDeko automatically picks an available, empty number for 
you. We recommend against changing the number, to avoid overwriting an existing still. 
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4. Click OK. The image is stored in the Lightning database, and will show up in the Browse 
window if you press Alt + Tab to switch to the Thunder Browse application. 

Note: You can also drag and drop images from Windows Explorer into the Thunder Browser. 
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Link clip to 
graphic 

Break Link to 
graphic 

Open the Clip 
Editor 

Record a 
Clip 

ClipDeko 
The ClipDeko option enables you to record Digital video, then playback, loop, trim, and browse 
these clips. Animated backgrounds can now be played all from one box, without the need for a 
separate disk recorder. you can also associate any clip to any Deko graphic. 

ClipDeko hardware supports DV25 and MPEG-2 compression formats, providing over 3 hours of 
DV25 storage. Clips can also be imported in the form of AVI files from standard applications such as 
Adobe AfterEffects and 3D Studio Max. 

• The Clip Browser offers thumbnail images 
for fast searching as well as clip association 
control for linking your clips to specific 
graphics. 

 

 

 

 

 

• The Clip Editor allows you to import, 
record, preview, play and, loop your clips, 
as well as assign key clips to fill clips, and 
align a fill clip with its associated key. 
This menu also contains a thumbnail 
browser of all clips imported in the database. 

Thumbnail 
Browser 

Associated Key 
icon 

Loaded Clip In /Out 
Trim options 

Assign key 

Scrub and 
Playback  
controls 

Link clip to 
graphic 

Clip record, 
load, import 

Settings config 
menu 



  Other Options 

Deko Training 

17-24

To Turn On ClipDeko: 
• In the Channel menu, choose ClipDeko. 

To Enable ClipDeko: 
• In the Channel menu, click Keying and Routing. 

• In the Keying and Routing dialog box, under the appropriate channel, 
select Deko + Clip. 

 

To Open the Clip Browser: 
1. Turn on ClipDeko. 

2. In the View menu, click Clip Browser. 

To Open the Clip Editor: 
Do one of the following: 

• In the Clip Browser, click the Edit Clip tool. 

• Go to View > Clip Edit. 

Note: The Clip Editor also contains a clip browser. 

Recording and Importing Clips 
The first time you record a clip, it is important to verify the compression protocol before recording. 

To Verify the Compression Protocol: 
1. Open the Clip Editor and click the Settings button. 

2. In the dialog box, click the 
Capture tab. 

3. Verify that the compression 
protocol is set to DV25. 
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To Record a New Clip from Input Video: 
1. Connect a live video source to the system�s SDI Video input. 

2. In the Clip Editor, click the Record button. 

3. In the Create Clip dialog box, type a clip name and select a folder where the clip will be stored. 

4. Specify clip length � up to 10 minutes. 

5. Click the Record button to start recording input video. 

6. Once the recording is complete, click Play to play back the new clip. As it plays, verify that it 
appears properly on the system video output. 

To Import a Clip to the Browser Database: 
1. Open the Clip Editor, then click the Import 

button. 

2. In the Import Clip dialog box, navigate to the 
directory that contains the clip (.avi file) you wish 
to import. 

3. Select the file name, then click the Open button. 

Using Clips with Key 
Using clips with key requires that you have two separate 
clips, one for the fill, and one for the key. The fill clips can be imported or recorded as described in 
an earlier section. You can use a copy of the same .avi file for both the fill clip and the key clip, but 
you must record or import that file twice.  

To Import a Fill Clip and Its Associated Key: 
1. Import the fill clip as described above. 

2. Double-click the fill clip thumbnail to load it as the current clip. 

3. Import the key clip as described above, but be sure to choose �Use as key in currently loaded 
clip� in the Import Clip dialog box before you click Open. 
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To Assign a Key Clip to a Fill Clip: 
 
 
1. In the Clip Browser, double-click the fill clip thumbnail to 

load it as the current clip. 

2. In the Clip Browser, click the key clip thumbnail to select 
it. 

3. In the Clip Editor, click the Assign Key button. Deko 
displays a key icon in the corner of the fill clip�s thumbnail 
image. 

 
 

To Remove the Key Assignment from the Current Clip: 
• In the Clip Editor, click the Delete Key button. 

 

To Align a Key Clip with a Fill Clip: 
1. In the Channel menu, click Keying and Routing, then verify that Deko Under Video is 

selected. 

2. Create a solid color background that contrasts with the clip color and black. 

3. Open a fill clip that has been assigned a key clip. 

4. In the Clip Editor, select Scrub Key. 

5. Use the thumbwheel or the double arrow keys to align the key clip with the fill clip. 

6. Click Set Offset. 

Key clip 
thumbnail 

Fill clip 
thumbnail 
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Playing Clips 
The first time you play a clip, it is important to specify 
the genlock source. 

To Specify the Genlock Source: 
1. Open the Clip Editor and click the Settings button. 

2. Click the Playback tab in the dialog box. 

3. Under Genlock Source, choose Reference Input 
(signal present). 

 

To Preview a Clip: 
Open the browser and select the clip. Deko displays the clip in the clip viewer, a box in the lower left 
corner of the editor. 

Note: The name of the current clip file and the name of the .avi files for the fill and for the key 
appear below the clip viewer. The format (DV25, YUV, or RGB) of the .avi file appears next to 
the file name. If no clip is selected, the clip viewer is grayed out. 

To Set a Start Point and End Point for Playback: 
1. Open the browser and select the clip. 

2. Open the Clip Editor, and use the slider, thumbwheel, or frame-by-frame buttons to find the 
frame where you would like playback to begin. 

3. Click the In button. 

4. Repeat step 2 to set the display on the desired Out point frame, then click the Out button. 

Note: You also can specify In and Out points as well as Duration of playback by entering numerical 
values next to these buttons. 
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To Play a Clip from the In Point to the Out Point: 
• Check Play In to Out.  

Note: When Play In to Out is not checked, Deko will play the clip from beginning to end, 
ignoring the In and Out points. Once you specify an In point and/or an Out point, and check 
Play In to Out, Deko begins at the In point and ends at the Out point whenever you scrub 
through the clip. When no In or Out point is specified, you can scrub through the whole  clip. 

To Find the Nearest Point (In, Out, Beginning, or End) in the Clip: 
1. In the Clip Edit box, do one of the following: 

2. Use the double left arrows to jump to the nearest point backward in the clip (Out, In, or 
beginning). 

 
3. Use the double right arrows to jump to the nearest point forward in the clip (Out, In, or end). 

 

To Play a Clip: 
Do one of the following: 

• From the Clip menu, select Play. 

• In the Clip Editor, click the Play button under the thumbwheel. 

To Synchronize Clip Playback with Effect Playback: 
1. Open the Clip. 

2. In the Clip Editor, click Synchronize with Effect. 

Note: When you associate the clip with a graphic, ClipDeko will begin clip playback 
simultaneously with any effect played on that graphic. 

To Stop Clip Playback: 
Do one of the following: 

• From the Clip menu, select Stop. 

• In the Clip Editor, click the Pause button under the thumbwheel. 

• Clear the Program graphic. 
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To Loop from In to Out: 
1. In the Clip Editor, click the loop button under the thumbwheel. 

2. Specify number of times to loop in the box next to the Loop button. 

3. Play the clip. 

Using the Clip Browser 
Clips are organized alphabetically by clip name in the browser. You can type a letter to jump forward 
or backward through the browser alphabetically. 

To Associate a Clip with a Graphic: 
1. Open the graphic. 

2. Open the Clip Browser and scroll through thumbnail images to find the clip. Click the clip to 
select it. 

3. Do one of the following: 

4. Drag and drop the clip from the browser onto the graphic. 

5. Click the Link tool at the top of the browser, then select the graphic file name from the list of 
available (open) graphics. 

You can use the Undo Link tool at the top of the browser to break a link between a clip and a 
graphic. 

 
Note: When you associate a clip with a graphic, ClipDeko will play the clip whenever you open 
the graphic in the Program window, swap the graphic to the Program window, or play and 
effect on the graphic. 

To Rename a Clip: 
Do one of the following: 

• In the browser, click the clip name to highlight it, then click it again. 

• Click the clip to select it, then right-click and select Edit Clip Name. 

• Type a new clip name, then press Enter. 

To Delete a Clip from the Browser Database: 
1. Open the browser and click the clip to select it. 

2. Open the Clip Editor and click Delete. Deko displays a message box asking if you want to 
delete the .avi file, too. Click Yes or No. 
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Keyboard Extenders 

Overview 
Describes a variety of keyboard extenders, and covers issues of hot switching among multiple control 
points. 

This document will refer to the SVGA, keyboard and mouse at the operator station as the GUI.  
Technically, this is a misuse of the term, but it saves typing. 

Extender Choices 
• All systems extend keyboard, mouse and SVGA, unless otherwise indicated. 

• All systems consist of a transmitter, near the chassis, and a receiver at the GUI. 

• The transmitter is generally powered from the keyboard cable, while the receiver always has a 
wall wart power supply. 

This document lumps together extenders and multi-point access. Our experience is that with the 
FastAction Keyboard (FAK), having multiple receivers and switching among them best achieve 
multi-point access. The automatic switches tend to result in double characters being sent to the 
display of the FAK. 

See pages A-3 and A-4 for details on hot switching among receivers. 

In systems without FAK, multi-point access works fine.  



A-2 Appendix 

 Deko Training 

Brands and Models 

BlackBox 
http://www.blackbox.com/catalog/09switches/424.PDF 
Servswitch Cat5 KVM Extender 

Uses Cat5 cable. Works fine. Up to 1000 feet. 
Dual station version also available. Standard dual station caveats apply. 
Cost $765. 

Cybex 
http://www.cybex.com/ 
PC-Extender Plus 

Uses 25 wire cable, which is awkward to run long distances, and horribly expensive, 
especially the plenum-rated version. Works well, though SVGA can get a little dim or noisy. 

PC-Extender SNAP 1 

Uses Cat5 cable, and supports runs up to 300 feet. Works well. 
Cost $600. 

LongView400 (LV400) 

An enhanced version of SNAP 1, at the same price; Uses Cat5 cable, supports runs up to 500 
feet, and also includes support for COM port, audio, multi-media quality video.  Works fine. 
Cost $600. 

Hall Research 
http://www.hallresearch.com/hall/model97.htm 
Model 97 Dual station interface 

Works fine. Can be used as an extender, up to 250 feet away. 
When used as dual station, the standard caveats apply 
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FastAction Keyboard Hot Switching 
Our experience is that you can easily hot swap from one location to another, while in the Deko 
application. The experiments were conducted with the LV400, but should work the same for all 
extenders. 

Simply switch, at the transmitter, from a cable leading to receiver A, to a cable leading to receiver B.  
If using a Cat5 extender, a jumper block could be setup, such as is used for networking. This allows 
any GUI to be used with any chassis. 

For temporary setups, such as a sporting event, the GUI of one of the on-air operators can be 
switched to the spare machine by changing the wire over from one transmitter to another. 

Vital Details 
After switching to a new GUI, you must �wake up� the new FastAction Keyboard (FAK).  The best 
way to do this is disconnect the keyboard cable from the rear of the FAK, wait a couple of seconds, 
and then reconnect it. If this is not done, the keyboard will not function. 

In addition, to get accurate display lights on the caps lock and num lock keys, you must press each 
one twice. Otherwise, the lights stay off, even if they should be on. 

On one system, we found it necessary to disconnect and reconnect the mouse from the receiver, after 
hot swapping. Until this was done, the mouse cursor was locked in position. Our guess is that the 
hot-swap procedure puts noise on the mouse line. 

Keyboard Mixing 
You can also hot swap between a FAK and a standard 101 keyboard. There are some details to watch 
out for. 

The driver for the FAK is loaded at Windows NT boot time. Therefore, our recommendation is that 
you have the FAK connected (through the extender) at boot time. Otherwise, you will not be able to 
use all the FAK features until NT is re-booted. 

If you boot up NT with a 101 keyboard and then switch to a FAK, all the FAK functions will work 
except for the function keys and numeric keypad. To check whether the FAK driver is loaded, go to 
Options > Preferences and pick the Common tab. 
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If the FAK driver is not loaded, the choices in the Keyboard section will be grayed out, as shown. 

 

 
On the other hand, if you switch to the 101 keyboard with the FAK driver loaded, the numeric 
keypad and function keys will behave like a FAK. If you don�t want this behavior, you can turn off 
those features. To do this, go to Options > Preferences. Under the Common tab, un-check the boxes 
labeled Enhanced Keypad and FastAction Function Keys. 
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File Associations for Sports Production 
Deko offers many tools to speed and simplify graphic creation. One tool in particular that can reduce 
pre-build efforts in Sports and Event production is File Association. 

File Association is defined as any file containing a reference to any other file. For example: A Graphic 
file (.dko) can embed an Effect file (.efx) � or the background of a Graphic file (.dko) can reference 
another Graphic file (.dko).  

Benefit of a File Association 
By referencing a single graphic across many other graphics, what is typically a lengthy process to edit 
the appearance of a large volume of graphics is reduced to one step � edit the single referenced 
graphic!  

Two Components of a File Association 
1. An air graphic will typically contain one or more Deko objects refer to an associated graphic. 

The object can be the background or several shape layers in a Deko graphic who�s Shader is 
specified as a Texture. 

2. An associated graphic is not typically called to air, but rather contains all the team-specific 
elements � such as banners, logos, frames and team names � used in various team graphics. 

 

Building the Graphics 
Ideally, the seasonal pre-build for a sporting event will produce a single associated graphic for each 
team. The air graphics will make a reference to two associated graphics: team_home.dko and 
team_visitor.dko. On game day, it all comes together when the playing teams, for example: 
team_GB and team_NY, are saved as team_home.dko and team_visitor.dko.  

Air Graphic  
saved as 900.dko 

Associated Graphic 
saved as �team_GbGreen.dko� 
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Every air graphic will automatically update with the current team �look�, 
without user intervention! To insure the success of this process, there are several 
rules to comply with. 

Rules for Making File Associations 
• When using shaper layers as the Deko object for file association, the 

Texture Group should be letter-based in the Group list of the Shader 
window. This creates what we  refer to as a �sticky� texture, so the user 
may define any size and position in the air graphic.  
For example: A single full-screen headshot is the associated graphic. This 
can be used in any random air graphic, such as a lower-third banner, 
full-screen page or over the shoulder bio. 

 
�team_GBgreen.dko� �teamMNgold.dko� �teamNYblue.dko� �teamSFred.dko� 

 
• Team elements used in associated graphics should never 

vary in size or screen position from team to team. 

• Graphics intended to be an associated graphic should not 
make references to other files. Avoid these �deep file 
associations� by collapsing layered graphics into 
backgrounds. From the Layer menu, select Layers to 
Background. 

• Team elements should be arranged into as few graphics (for 
file association) as possible. Storing all team elements in a 
single graphic is ideal. 

�teamNYblue.dko� 
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• When saving graphics, click on the Option button in the dialog window. Be sure to deselect 
�Save with rendered bitmap for faster recall� and be sure to select �Never� under �Save 
character glyphs�. 
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Optional Exercise: Make Bio Graphic with a File Association 
1. Set focus to the Preset Style window, and open training_fileassociation.pst. 

2. From the Tools window, click on the Add Rectangle tool. 

3. Pick Preset Style #1 and draw a rectangle in the bottom right corner of the Program window. 
Fig. A 

 
4. Choose the Add Rectangle tool and draw a rectangle just above and over-lapping the first. 

Release when the bottom edge of the layer sits just above safe-title. Pick Preset Style #2. Fig. B 

5. From the Shader window, click on Texture, then open the file team_home.dko. 

6. From the Group list, select Letter. This creates a �sticky� texture for random on-screen 
placement. 

7. In the H Offset field, click and release on the up arrow until you reach 30. Notice the texture 
moving as you edit the Horizontal position.  

8. In the V Offset field, click and release on the down arrow until you reach �2. The graphic 
should resemble Fig. C below.  

Figure A Figure B 

Figure C Figure D 
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Note: These values may vary slightly based on the on-screen position of the rectangle. 

9. Next we will add a headshot. Choose the Add Rectangle tool and draw 
a rectangle over top of and about the same size as the red frame. Pick 
Preset Style #2. 

10. From the Shader window, click on Texture, then open the file 
head_agassi.tif. 

11. From the Group list, select Letter.  

12. Set H Scale and V Scale to 50 for both. 

13. Reset H Offset and V Offset to 0 for both.  

14. From the Tools window, click on the Add Text Layer tool. Pick Preset Style # 3 and draw 4 
layers for the player name, position, age and hometown. 

15. Your graphic should resemble Fig. D above. Save as 0801.dko. Be sure you have followed all 
the File Association Rules listed above. 
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Optional Exercise � Update and Recall Team Graphics for Game Day 
1. Open the graphic team_NYblue.dko, and save this as team_home.dko. 

2. Read the air graphic titled 0801.dko. This will display the team look and team title of the 
current home team. 

Samples for Review 

Home Visitor Type of Graphic 

800 900 Air Graphic / Lower Third 
801 901 Air Graphic / Bio Page 
team_home team_visitor Associated Graphic 

 

Team Elements Graphics 
 

team_Gbgreen

team_SFred

team_NYblue

team_MNgold
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Deko Unshaper Card Information 
Deko�s graphics are composited over external video by a linear keyer. The compositing can be done 
internally, using Deko�s integrated downstream keyer or externally, typically through a switcher.  
Deko�s internal keyer always composites anti-aliased graphics properly, smoothly blending the 
graphic into the background with no disturbing artifacts. External keying can also be done cleanly.  
However, an improperly configured system can lead to unsatisfactory results, including black fringes 
and saw-tooth patterns surrounding the graphic. An improperly configured system will also cause the 
fill to look like it is disappearing too quickly during a dissolve. 

An external switcher requires two signals to properly composite an anti-aliased graphic: the key 
signal and the video fill. The key signal is also known as the alpha channel. In addition to cutting a 
hole for the graphic, it carries the anti-aliasing and transparency information. The video fill contains 
the actual RGB content of the graphic. The keyer uses the key signal to control the blending 
between the video fill and the background video. 

Keyers use one of two algorithms for blending the video fill with the background video. A shaped 
keyer, also known as a narrow or half-blending keyer, expects the input video fill to be anti-aliased 
over a black background prior to processing. An unshaped keyer, uses the linear key signal to control 
a dissolve between the two video signals. 

The following diagram illustrates both the fill and key for one scan line of an anti-aliased white 
letter: 

 

Unshaped fill Shaped fill

Unshaped key Shaped key
 

Note: The key signal is the same for both unshaped and shaped video. Unshaped fill is always full 
value when the key is non-zero.  Shaped fill is always less than or equal to the level of the key. The 
shaped fill of a white character is identical to its key signal. 
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Without getting too technical, an unshaped keyer does a crossfade between the fill and background 
signal. It applies the mathematical formula to do the keying: F*K+B(1-K) where F = Fill, B = 
Background, and K=Key. 

A shaped keyer applies the formula: F+B(1-K) 

The standard Deko produces shaped video. Shaped video has many technical advantages: less 
processing is required for multi-layered compositing, it looks good on a monitor, and it avoids nasty 
filtering problems during D-to-A conversion and encoding. If your keyer does not handle shaped 
keying, the Deko Unshaper module is required. 

The following table shows some of the terms used to refer to the two keying algorithms, along with 
the equipment manufacturers who use them: 

Algorithms Manufacturer 
Shaped Unshaped Deko Products, Tektronix/GVG 
Additive Multiplicative  
Narrow Wide  
Half-Blended Full-Blended Matrox 
Aston Mode Non-Aston Mode BVS 
Attenuated Fill Non-Attenuated Fill  
One Legged Two Legged  
Add Linear BTS 
Matte Linear Abekas 
Clean Linear Sony 
Cyber Key On Cyber Key Off VGV 

 

The following switchers require an unshaped input: 

Manufacturer Model 
GVG 110, 200, 300 
Ross All 
Echolab All 
BVS All 
VGV DX60, DX120, D2500, DX300, DX320 

 

The following switchers accept a shaped input: 

Manufacturer Model 
GVG All digital switchers 
VGV CV60, CV120, CV132, CV332 
Sony All digital switchers  
BTS All digital switchers  
Abekas All 
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There is a simple test to check which mode your keyer is in. Put up a box on your Deko, using the 
drawing tools. Fill the box with a ramp, where the left side is 100% white, 100% opaque, and the 
right side is 100% white, 0% opaque. If you view the video (or key for that matter) output of the 
Deko on a waveform monitor, you will see a straight line from 100 IRE down to black. If you key 
this over a black signal, and view the output of the keyer, it should look the same if it is configured 
properly. If you see a curved line, it means the keyer is expecting an unshaped signal.  

The optional Unshaper enables Deko to produce unshaped video. The Unshaper�s proprietary fill-
widening circuitry enables unshaped keying of the highest quality. The unshaping can be turned on 
and off under software control, allowing Deko to be used with any external linear keyer. 
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GPI Connection 
GPI (General Purpose Interface) is a method by which electronic pulses from one device, such as an 
edit controller, are used to trigger functions on another device, such as FXDeko.  

To connect a GPI trigger, connect the triggering device to COM port 1. 

To enable GPI triggering: 

1. Connect the triggering device, then restart FXDeko. 

2. Activate the Sequence window (F11). 

3. Go to Sequence > GPI Settings. 

4. In the GPI Trigger Settings dialog box, check GPI Enabled, enter the COM port name (such as 
COM1), and then choose OK. 

DCD

DTR

GND

RTS

DE9S

GPI
OUT

J1

SW1

1

2

R1
47K

R2

510

1

1

2

2

CR1

CR2

GREEN

RED

1

2

3

4

5

6

7

8

9



Appendix A-15  

 Deko Training 

Controlling a Thunder Server from FXDeko 

Before you begin 

Controlling Multiple Channels 
For each channel you wish to control remotely, both the Thunder and FXDeko procedures must be 
repeated. For example, if you wish to control two channels of Thunder from the FXDeko, you will 
need to have two entries in Thunder�s Protocol Setup Window, and two clip servers set up on the 
FXDeko. 

A Word about Media ID Numbers 
Controlling Thunder from a remote location requires the operator to know the media ID number for 
the desired clip. This is a separate number from the clip�s database number (the number appearing 
below the picon in the Thunder database).  

The Media ID number is formatted as the workspace number, an underscore, and the clip�s original 
database number. In most situations, the workspace number will be 0. Workspaces are a function of 
the Security Administration option, and Thunder systems without this option always use the default 
workspace, which is 0.  

The original database number is the database number assigned to the clip when it was first created. If 
the clip was moved from one database to another, it may have been renumbered. Somebody else may 
have also renumbered the clip. It is in cases like these that the Media ID number will be dissimilar 
from the clip�s database number. 

The Clip Command and Its Syntax 
Controlling a clip server from FXDeko is done with the Command bar.  

Thunder understands three clip commands: 

• Clip load <Clip Server ID> <Media ID>

• Clip play <Clip Server ID>

• Clip stop <Clip Server ID>

Clip load <Clip Server ID> <Media ID> 
The Clip Server ID is the ID number assigned to Thunder in FXDeko�s Clip Server Configuration 
window.  

The Media ID number is the Media ID number for the desired clip to play from Thunder�s default 
database. This is not the still number. In most cases the Media ID number will be 0, and underscore, 
and the clip number. 

Example: Thunder�s clip server ID number in the FXDeko Clip Server Configuration window is 0, 
and the correct Media ID number for the clip1 is 0_1: 

Type the command: clip load 0 0_1 
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Clip play <Clip Server ID>

The Clip Server ID is the ID number assigned to Thunder in FXDeko�s Clip Server Configuration 
window. For this command to work, there must be a cued clip (the picon appears just under the mini 
monitor on the desired channel in the Thunder application). This is done using the clip load 
command. 

Example: Thunder�s Clip Server ID number in the FXDeko Clip Server Configuration window is 0, 
and the clip load command was executed successfully:  

In the FXDeko Command bar, type the command: clip play 0 

Clip stop <Clip Server ID>

The Clip Server ID is the ID number assigned to Thunder in FXDeko�s Clip Server Configuration 
window. This command stops the clip currently being played out of the selected Thunder channel. 

Example: Thunder�s Clip Server ID number in the FXDeko Clip Server Configuration window is 0, 
and the clip load and play commands were executed successfully: 

In the FXDeko Command bar, type the command: clip stop 0 

Thunder Configuration 
1. Thunder must have a default database. Right-

click on the desired database and choose Set 
Default Database from the context menu. 

2. Configure the desired channel for automation. 
Go to File > Preferences > Protocol Setup.  

3. In the Protocol dialog box, select 
ThunderNet. The Channel box determines 
which channel you wish to control. 
ThunderNet protocol is an Ethernet protocol, so the Port box will be disabled. It should show 
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COM1.  

4. Press the Restart button next to the protocol you have just set up, then press the OK button. 

Note: If you wish to change the Default Database, you must restart the Protocol. To do this, 
select a new Default Database as described above. Select Preferences/Protocol to bring up the 
Protocol Setup dialog box. Click Restart on the assigned channel(s). 

5. Make sure the automation protocol has permission to control the desired channel. Choose File 
menu, Preferences, then Channel Configuration.  

6. In the Channel Configuration window, Notice the second column of checkboxes. These 
checkboxes permit and deny access to the listed channels from the context chosen in the box at 
the top of the column. ThunderNet will appear listed as IO COM1 Context.  

Make sure the desired channel to control has its checkbox checked when IO COM1 Context is 
selected at the top of the column.  

 
Note: the IO COM1 Context reference assumes that the Port box in the Protocol Setup 
window for the ThunderNet protocol shows COM1. If another COM port was selected in 
that box before it was disabled, that COM port number will appear in the second column of 
checkboxes. 

IO COM1 Context 

Hardware Channel 1 
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FXDeko Configuration 
1. Go to Options > Configure Clip Servers. 

2. Enter a unique number in the Server ID box.  

3. If there are no clip servers already configured, the first number to be entered is 0. If there is 
already a clipserver #0 (for example, if you have ClipDeko you should already have a clip server 
#0), you may enter 1 here.  

Note: The remainder of this procedure will assume the Clip Server ID number is 0. If you 
entered a different number here, use this number instead of 0. 

4. Enter a name in the Name box. This name is arbitrary. However, to avoid confusion, we 
recommend the name �Thunder�. The input box allows you to indicate which FXDeko input is 
connected to the server if desired.  

5. In the Protocol box, choose Thund Protocol. Press the Insert button, the clipserver will appear 
in the list and the properties button should become active. 

6. Press the Properties button. The server ID is the number given in the Configure Clip Servers 
window in the Server ID box.  

7. Select the appropriate Video Type (NTSC or PAL).  

8. Make sure the Network Com checkbox is checked.  

9. Set the Codec box to show which Thunder channel you want to control.  

10. Enter the Thunder system�s network name into the Server box. 

1.Enter Server ID 

2. Name Server 
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11. Press the Test button.  

If all is well, the message �Thunder Network Initialized OK, Device=Thunder� will appear.  

If not, refer to the Troubleshooting section below. 

Testing the Configuration 
1. First, identify an existing clip in the Thunder default database. Select a valid clip (the picon 

will show a green filmstrip in the upper right 
corner).  

2. Right-click on the picon, and select Properties 
from the context menu.  

3. In the Properties dialog, choose the Clip tab. 
Take note of the media ID number. 

4. In the FXDeko�s Command bar, type the following command:  
clip load <server-id> <media ID>  
For example, if Thunder�s clip server ID in the FXDeko Clip Server configuration window was 
0, and the media Id of the desired clip is 0_1, the command to type into the Command bar is: 
clip load 0 0_1.  

Note: There will be no returned message on the FXDeko. Watch the appropriate mini-monitor 
in the Thunder application, this command should cue the desired clip and the picon will 
appear just under the mini monitor. 

Select Video 
Type 

Select Hardware 
Channel 

Enter Server 
Name 

Check Network 
COM 

Click Test 
button 
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5. Following the example set in step 2, type the next command to play the clip: clip play 0. The 

cued clip should now play out through the channel. There will still be no response apparent on 
the FXDeko. 

Troubleshooting 
Pressing the TEST button in the FXDeko Clip Server Configuration Parameters window returned an 
error.  

1. Make sure both systems are communicating correctly on the network and are using a common 
network protocol. 

2. Sometimes the error may be due to a permissions issue. Use the Windows NT Explorer on the 
FXDeko, select Network Neighborhood, and pick the Thunder system by its network name.  

If there is a permissions issue, Explorer will ask for a Name and password. Enter a valid 
username and password that Thunder would accept on its own login screen. Once you can 
successfully browse the Thunder system using Windows NT Explorer, the Test button should 
now work until the next time FXDeko is rebooted. To correct this issue on a permanent basis, 
see your network administrator. 

The Test button returned an OK, but when the clip load command is entered, nothing happens. 

3. The Deko will not provide a response when the commands are entered. Check visually to see if 
Thunder played the clip. 

4. On the Thunder system open the Thunder Network Protocol application (click on the Protocol 
button on the Windows Start bar. 
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5. Inside this window you will see numerous messages as the 
two systems communicate. Look for an error message, you 
should see either �Clip not found� or �Clip did not load.� 
See below: 

Clip not found error message: Check to make sure you are 
referring to the correct Media ID. See A word about Media 
ID numbers on page A-9. Right-click on the clip you 
intended to load and select Properties from the context 
menu. In the Properties dialog box, select the Clip tab. 
The clip�s correct Media ID number appears here. 

Clip did not load error message: Make sure the automation protocol has permission to control 
the desired channel of Thunder. In the Channel Configuration window (go to File > Preferences 
> Channel Configuration), the second column is where the protocol appears. The heading of 
this column is a selection box. Select IO COM1 Context in this box, and make sure the 
intended channel to control has a checkbox under this column. 
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How to contact Pinnacle Broadcast Support: 

Broadcast Support Americas and Canada 
Phone: (650) 930-2990  
Fax:  (650) 930-1601 
Hours 6am � 6pm (M-F) Pacific Time 
Email  broadcast-support@pinnaclesys.com 
Web Support www.pinnaclesys.com/support 

Broadcast Support Europe 
Phone: (44) (0) 1895 442-003  
Fax:  (44) (0) 1895 442-275 
Hours 9 am � 5 pm (M-F)  
Email  broadcast-support-uk@pinnaclesys.com 
Web Support www.pinnaclesys.com/support 

Broadcast Support South Asia 
Phone: (65) 284-2336  
Fax:  (65) 285-9486 
Hours 9 am � 6 pm (M-F)  
Email  pacrim-support@pinnaclesys.com 
Web Support www.pinnaclesys.com/asia 
Supports Regions: Taiwan, India, Pakistan, Bangladesh, Sri Lanka, 

Australia, New Zealand 

Broadcast Support Beijing 
Phone: (86) 10 6641 0053 or (86) 10 6641 0063  
Fax:  (86) 10 6641 0073 
Hours 9 am � 6 pm (M-F) Beijing Time 
Email  broadcast-support@pinnaclesys.com 
Web Support www.pinnaclesys.com/asia 
Supports Regions: China, Hong Kong, Korea 

Pinnacle Systems Corporate Website:  http://www.pinnaclesys.com 

Pinnacle Systems Mailing Address: 

Pinnacle Systems, Inc. 
Attn: Broadcast Support  
280 N. Bernardo Avenue 
Mountain View, CA  94043-5238 
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Glossary 

A to D (Analog to Digital) � A conversion process that changes an analog signal into a digital signal. 
It is achieved by sampling the signal at intervals and then quantifying each sample to give them 
values suitable for use in a digital system. 

active window � The window with a highlighted (usually blue) title bar. A window must be active 
for you to perform tasks in it. To open and activate a window, choose the window type from the View 
menu. To activate a window that is already open, select it from the list at the bottom of the Window 
menu, or click anywhere on the window. 

aliasing � Inaccurate rendering of an image due to a low, digital-sampling rate. Aliasing appears as 
jaggies, or jagged edges on graphics and especially text. Aliasing is corrected by special software and 
techniques (anti-aliasing) that smooth out the jagged edges by anticipating and displaying the 
interim pixels. In analog CCD systems, a form of distortion that is associated with the process of 
signal sampling, resulting in stair-step edges on diagonal lines within the image. 

analog � A signal that is a likeness of or analogous to a physical process and is continuously variable. 
Analog electronic signals, the basis for conventional video and audio recording and imaging 
processes, are distinguished from digital signals, which represent discrete numerical samples of 
information�the basis for computer imaging processes. 

Analog/Digital Converter (A/D) � An electronic circuit that changes continuously variable analog 
signals into discrete numerical digital signals (bits). The common abbreviation is A/D. 

Analog-to-Digital Conversion (A/D) � The process of converting an analog signal into a digital bit 
stream. Includes the steps of sampling and quantizing.  

animation � Single images displayed in rapid sequence producing the illusion of motion. 

anti-aliasing � Aliasing causes jagged edges in images displayed on a computer screen in low 
resolution. Anti-aliasing software smoothes the stair-step effect by anticipating and displaying the 
interim pixels. In analog CCD systems, anti-aliasing is accomplished by the removal of unwanted 
high-frequency components through the means of a high-frequency-cut optical filter placed before 
the imager.  

artifacts � Unpleasant visual problems within the signal such as noise, chroma displacement, etc. 

ASCII � An abbreviation for American Standard Code for Information Interchange. An ASCII file is a 
text file that is in a standard computer readable format understandable to any PC platform. 

aspect ratio � The ratio of height over width of an image. A standard video monitor has an aspect 
ratio of four units of width (horizontal) to three units of height (vertical). This is expressed as a 4:3 
aspect ratio. Images will become distorted if forced into a different aspect ratio during enlargement, 
reductions, or transfers. The aspect ratio for HDTV is 16:9. 
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axis � A line that is fixed, along which distances are measured or to which positions are referenced.  

background � The backmost part of a graphic. It is a full-screen rectangle located behind the last 
layer, furthest from the viewer. The background can be turned on and off. When off, it is transparent 
� live video �shows through� the background when you use a keyer. When the background is on, the 
background shader determines its color. Like all FXDeko shaders, the background can be a solid 
color, a ramp or a texture.  

bandwidth � In terms of signal frequency, the range between the lowest and the highest frequencies 
used to transmit a signal from one site to another. Bandwidth is a measure of an analog signal and is 
measured in cycles per second. Contemporary units are Hertz (one cycle equals one Hertz).  

(1) In video systems, bandwidth is specified as the highest frequency value because all video systems 
must transmit frequencies down to 30 Hz or lower. The greater the bandwidth, the more 
information is carried and the higher the potential resolution of images. In television, bandwidth 
is usually expressed in MHz.  

(2) With digital codec specifications, bandwidth is represented by the number of bits of information 
that can be transmitted per second or bps. High-bandwidth codecs can have bandwidths between 
768 Kbps (thousand bits per second) and 45 Mbps (million bits per second). Low-bandwidth 
codecs range between 56 Kbps and 384 Kbps. 

baud � Commonly used unit of transmission speed to describe the rate at which binary data is 
communicated. One baud is approximately equal to one bit per second. Common baud rates are 300, 
1200, and 2400 bps (bits per second). 

Bernoulli Devices � A medium-high-capacity, disk-storage medium used for digital data storage. 
Bernoulli disks use a floppy piece of magnetic material housed in a rigid cassette. The disks have a 
storage capacity of about 20 MB and a data-access performance equivalent to hard drives. 

binary � A numbering system that uses only two values, one and zero. It is used extensively by 
modern electronic equipment that responds to being in a state of either ON or OFF. The foundation 
of information processing in all digital systems. 

bit � Short for binary digit: the smallest unit of digital information with a value of 0 or 1. A bit is 
the smallest element of a digital word. (See binary and word). 

bitmap � A set of numerical values specifying the colors of the pixels in a graphic image. A 
representation of images or graphic information made up of individual bits of picture information or 
pixels (picture elements). Bitmaps are computer maps of these bits that can be re-created pixel for 
pixel when displayed or printed. 

bitmapped graphics � A form of graphics that is made up of individual bits of picture information or 
pixels (picture elements). The graphic consists of a computer map of these bits that is re-created pixel 
for pixel when displayed or printed. 
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black � Video signal set to a pre-determined level (7.5 IRE units) so that no picture information 
appears and the screen is black. Also referred to as pedestal or setup, the level at which this signal is 
set determines overall picture contrast and quality. 

black level � In an NTSC composite signal, 7.5 IRE units is the lowest point in the signal that 
luminance components are permitted. Luminance information falling below this point is cut off and 
lost. 

breakup � A momentary image distortion caused by the loss of sync. 

broadcast system � A system that allows public access to electronically transmitted information. 
Typically, the Federal Communications Commission (FCC) regulates a commercial television or radio 
station. 

bus � A row of switches on a production switcher for entering or cutting to program material. There 
are several busses or rows on each switcher. Each bus contains the same input sources but sends 
selected signals to a different stage of the switcher. The program/background bus selects which signal 
will go out on air; the preset or preview bus sets what the next source will be when an auto transition 
is performed; the key bus determines what will serve as the key source and/or the key fill. 

byte �The number of bits used to represent a character. Typically, in personal computers, 8 bits 
equals one byte, e.g. 00001111. (See Binary). 

CAP shader � (Cel Animation Player) Deko shader used to apply a cel animation to a detail, such as a 
face or an edge. You can then play the animation within a motion. 

CD-ROM (Compact Disc�Read Only Memory) � A 4.75-inch laser encoded optical memory storage 
medium with the same constant linear velocity (CLV) spiral format as compact audio discs and some 
videodiscs. CD-ROMs can hold about 650 megabytes of data. CD-ROMs differ from regular 
prerecorded compact audio discs in the amount of additional error-correction information encoded. 
CD-ROMS primarily are used for large data and graphic files but can play back standard audio 
Compact Discs as well.  

CD-ROM drive or player � A device that retrieves data from a CD-ROM disc. Differs from a 
standard compact audio disc player by incorporating additional error correction circuitry. Some 
models lack the necessary D/A converter to play music from standard compact discs. 

cel animation � A series of graphic files. Each file consists of one frame of the animation and may be 
of any graphic type that Deko can import (.tga, .bmp, .dib, .rle, .pcd, .pcx, .psd, .wmf, .jpg, .g, .dko, 
.or .tif). Files should be successively numbered, such as globe001.tga, globe002.tga, globe003.tga, 
etc. You can play a cel animation within a Deko motion by applying the animation to a detail using 
a CAP (Cel Animation Player) shader. 

character set � A set of 256 characters in a TrueType or PostScript font. A font may contain more 
than 256 characters, but Windows NT can access only 256 at a time. By choosing a character set, 
you are choosing which 256 characters you wish to use. Not all character sets are supported by every 
font. See Using an International Character Set. 
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chroma � See chrominance.  

chroma key � Inserting one image over a background of a second image. Allows you to eliminate 
predetermined objects from one scene and put what is left within a second scene by cutting a hole in 
a background and filling the hole with an image or text. Chroma key uses color rather than 
luminance to trigger the key. 

chrominance � The signals, used in image reproduction systems that represent the color components 
of the image. A black-and-white image has a chrominance value of zero.  

clipboard � The Windows NT temporary holding area for text or other data that has been cut or 
copied from an FXDeko graphic, macro, style or sequence. When you cut or copy a selection, it 
replaces any previous contents of the clipboard. When you paste, you are pasting the contents of the 
clipboard. You can paste multiple times without re-cutting or re-copying. The contents of the 
clipboard remain the same until you cut or copy something different. 

Since most Windows NT applications support the clipboard, it is possible to cut and copy a selection 
from one Windows NT application�a word processor or a spreadsheet program, for example�and 
paste it into another Windows NT application. 

coaxial cable (COAX) � A one-conductor, one-ground cable which can carry a wide range of 
frequencies up to 1,000 feet with little or no signal loss. Coax is primary means of equipment 
interconnection for video devices.  

color bars � An electronically generated signal consisting of red, blue, green, yellow, cyan, and 
magenta, plus gray, black, and white set to standards established by the Society of Motion Picture 
and Television Engineers. Color Bars are used as a reference at the head end of a videotape recording. 
The playback machine is set up using color bars to ensure accurate color saturation and balance 
during playback. 

command � An instruction, optionally modified by parameters, to perform a specific function on the 
Deko. 

command bar � Allows direct entry of Deko commands and macros. Press F4 to call up the command 
bar, type the name of a command or macro, then press Enter or click Play. Use the Prompt button on 
the command bar to open the Command Prompt dialog box where you can specify command 
parameters. A Defaults button in the dialog box resets parameters to their default values. Click Close 
to close the command bar. 

component video � A video signal that has not been encoded and retains the original color 
information as separate elements. Component is technically superior to encoded composite video. It 
entails the transfer of three-color video signals that describe a color image. The most common 
component systems are RGB and Y/R-Y/B-Y. Y stands for luminance or brightness, the sum of R, 
G, and B. By subtracting Y from (R-Y) and from Blue (B-Y), two color difference signals are 
produced which when transmitted with the Y signal can be used to recreate the original RGB color 
information.  
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composite sync � A signal containing all the timing pulses that are needed to lock the electron beam 
of the picture monitor in step, both horizontally and vertically, with the electron beam of the 
imaging device.  

composite video � The most common type of video signal, in which the color (chrominance) and 
brightness (luminance) information is combined onto a single signal path. Composite signals are used 
in television broadcast and most video recording applications. Some image degradation results from 
combining the signals. 

compression � Techniques used to reduce the size of digital signals so that they are easier to process, 
transmit, and store. Video and audio compression allows the conversion of analog signals to digital 
and reduces the number of bytes required to store those digital signals. Video, in particular, can be 
moved to and manipulated more efficiently when compression techniques are employed. There are 
several methods of compression for both audio and video available but no standard has been set as 
yet. For more information on both still image and motion image compression standards. (See JPEG 
and MPEG). 

compression � The action taken by a video codec in reducing the data rate required for the 
transmission of television signals between sites. 

contrast � How much brighter the white areas of an image are from the black areas.  

contrast ratio � The ratio of the scale between the brightness of the brightest possible area in an 
image to the darkest possible area.  

control point � The point at either end of a Bezier curve or a line segment. In FXDeko, you can move 
control points to change the curvature or length of a baseline segment. 

convergence � Proper alignment of the vertical and horizontal lines to ensure that red, blue, and 
green signals are correctly registered to produce a proper color image on video displays. Convergence 
circuits are found on color monitors and projectors.  

crosstalk � Interference of one channel of electrical information with another adjacent channel. This 
could be from one stereo channel to another (e.g.. left to right, right to left) or chroma and luma 
information in a video system. 

cue � To ready a source for playback or to locate the starting point of a tape. 

current event � The event you are editing or playing back. FXDeko indicates the current event by 
highlighting its event number. 

current style � Style based on current Font and Look settings in the Style window. FXDeko displays 
the current style in the Current Style window. Any text you type in a graphic appears in the current 
style. When text is selected, the current style becomes the style of the first character of selected text. 
When a layer is selected, the current style becomes the style of the layer. 
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custom typeface � A typeface made in FXDeko for typing graphical (logo) characters. You create a 
custom typeface by importing graphics and assigning each graphic to a key. Custom Typeface 
characters can be typed, positioned, scaled, and even given looks like normal TrueType characters. 

cut � A visual technique where the picture changes instantaneously from one scene to an entirely 
different one. 

D to A (Digital to Analog) � A conversion process that takes a digital signal and converts it into an 
analog signal usually by a process of filtering. 

D/A � Abbreviation for Digital-to-Analog converter.  

D-1 � Component Digital Video: employs the component Y, R-Y, B-Y recording system in a digital 
recording process. 

D-2 � Composite Digital Video: employs the composite (full bandwidth, direct color) recording 
system in a digital recording process. 

DAC (Digital-to-Analog Converter) � Also called a D to A converter. A device that converts digital 
signals to analog signals that traditional analog circuits, such as VCRs, audio amplifiers, video 
monitors can handle. In a digital video system, the DAC converts digital video to an analog video 
signal. In a CD drive, it converts the digital information to analog audio that can be used by 
amplifiers and speakers. 

data rate � The speed of a data-transfer process, normally expressed in bits per second or bytes per 
second. The data rate of CD-ROM is 150,000 bytes per second, while the data rate for a typical 
Magnetic Hard Disk is 1.5 MB per second. 

definition � Synonymous with sharpness, detail, quality, or resolution of a video signal.  

desktop � The Windows NT term for everything appearing on your computer�s color monitor such 
as windows, icons, cursors, buttons, etc.  

desktop video � Video post-production using personal computers at the desktop rather than a 
traditional post-production environment. Desktop video may include video storyboarding, editing, 
and/or special effects generation using personal computer equipment rather than dedicated post-
production hardware. 

detail � One element of a Deko look. It controls how a font is rendered. There are five kinds of 
details: face, edge, shadow, underline and frame. 

digital � A method of representing information using a sequence of ones and zeros for storage and 
interpretation by a computer. In digital transmission, analog signals which are originally in a 
continuous form are converted to discrete signals of zeros or ones to be transmitted to a receive site, 
interpreted, and used to reconstruct the original analog signal. 
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digitization � The process of changing an electronic analog signal into a discrete binary form. The 
process is divided into the steps of sampling the analog signal at set moments in time, quantizing 
each sample (assigning it a numerical value), and translating the sample into a discrete binary 
number. The advantages of digitization include reliable high-speed signal transmission, quality 
duplication, and easy manipulation and processing. A copy of a digital signal is virtually identical to 
the original. The primary disadvantage of digital signals is their large size resulting in high-storage 
requirements. Digital compression techniques are helping to overcome this disadvantage.  

disc � A generic name for an optically recorded medium as opposed to �disk� which refers to 
magnetically recorded material. 

disk � A magnetic storage device for computers such as a floppy or a hard disk. 

display � A CRT (Cathode-Ray Tube): a device used to view electronic images; the process of 
presenting that image.  

dissolve � As one scene is fading out, another scene is simultaneously coming in. At the middle of 
the dissolve, both scenes are on the screen with the same 50% exposure. In single camera taping 
techniques, the dissolves are added in postproduction. 

double-click � To tap the left mouse button twice in rapid succession without moving the cursor. 

downstream key � A term that is applied to the final output of the switcher where a key can be 
created. The downstream key function is used by broadcasters to key their logo over the final 
program feed, and by producers who wish to further modify their signal by taking advantage of the 
downstream keyer. 

drag � Holding the left mouse button down and moving the mouse in the desired direction. 
Operation is used to select elements in a window. 

driver (device driver) � A software program that translates commands between the computer 
operating system and a peripheral device such as a CD-ROM drive, videodisc player, computer 
printer, or other device. 

DVE (Digital Video Effects) � Used to manipulate video images: fly-in, squeeze room, rotate spin. 
DVE effects have been exclusively in the high-end video production domain until recently when low-
cost extension boards have become available to accomplish these effects on the Macintosh and other 
PCs. 

event � One element of a sequence or motion. In a sequence, an event describes the playback of a 
single graphic file using an effect. In a motion, an event describes the movement on or off air of some 
element of a graphic. 

eyedropper � A button used to pick colors from anywhere on the desktop. It is located in the 
Shader window, on the color picker.  
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fade � The gradual increase or decrease in the video level of the picture. In other words, the picture 
emerges from black, or recedes into black. 

field (1) � A video term signifying one half of one television frame. In NTSC television broadcast, 
each frame (image) is made up of 525 lines. Two 262.5 horizontal line fields equal one frame. Each 
field represents either the even or the odd lines of a complete frame. A scanning system that uses 
even/odd field pairs is defined as interlace scanning. A field equals one-half of a complete television 
scanning cycle (1/60 of a second NTSC; 1/50 of a second PAL/SECAM). When interlaced, two fields 
combine to make one video frame with a scanning cycle of 1/30 of a second at a scanning rate of 1/30 
of a second in NTSC. 

field (2) � Computer term: The basic categories of information stored in the records in a file�for 
example, a file of bibliographic information might have Author, Title, and Date fields. Field is also 
used to describe portions of a sector that contain particular information, such as a sync field. 

field frequency � The number of fields per second. NTSC field frequency is 60 per second; PAL 
frequency is 50 per second.  

field rate � The number of fields per second.  

frame � One complete TV picture consisting of two interlaced scanned fields. The American and 
Japanese standard for TV, NTSC, scans a new TV frame consisting of 525 raster lines 30 times per 
second. One TV frame is a 1/30 second synchronized to the U.S. AC power frequency of 60 Hz. 

frame buffer � An area of computer memory that produces an output picture, which can be viewed on 
a monitor. A frame buffer consists of an array of pixels, short for picture elements. Each pixel is 
assigned separate amounts of red, green, blue and transparency, from 0 to 255. The number of rows 
and columns of pixels determines the resolution of the frame buffer. In NTSC, FXDeko�s frame 
buffer has 720 pixels in each of 486 rows. In PAL, it has 720 pixels in each of 576 rows. 

frame grabber � Similar to digitizers, but this term generally refers to those that can capture a frame 
in 1/30th of a second. A real-time frame grabber can digitize and display full-motion video. 

freeze frame (1) � The action taken or the device used to pull out a single field or a full frame from a 
sequence in full motion. 

freeze frame (2) � To hold a single frame or picture for a period of time. 

gain � A term used for amplification of an electronic signal. Also stands for amplitude or volume. In 
projection systems, the ability of a screen to amplify incident light. In cameras, the ability to amplify 
the input signal to obtain pictures in low-light conditions. 



Glossary G-9  

 Deko Training 

genlock � Circuitry that synchronizes the television signal source of two or more devices. All video 
signals contain synchronization pulses that are used to reconstruct the picture on the CRT. When 
several signals are used together through a common device such as a switcher, they all must be 
operating on the same sync. A master sync generator provides genlock to signal generating devices 
(cameras, VTRs, switchers, etc.) so that they can operate in sync.  

glyph � The word glyph comes from the Greek glyphe, meaning a pictograph or other symbolic 
character or sign. In FXDeko, glyphs are actual renderings of characters, in a particular style (font 
and look). FXDeko normally renders characters as you type them. For a style with a large font or 
complicated look, you can increase the speed of typing by pre-rendering the style. 

GPI (General Purpose Interface ) � A pulse or contact (switch) closure signal sent from an editor to 
trigger audio tape recorders, digital video effects devices, and graphics generators to activate for an 
edit or effect. Some external devices do not have the ability to be directly controlled by the editor. In 
this case GPI signal is used as a means of telling these devices when to execute a command. The 
choice of command itself, however, must be set up on the external device and cannot be controlled by 
the editor. 

graphic � One video page of text and/or background art, created and displayed using FXDeko. A 
graphic is created in either the Program or Preview window. A graphic can be saved on disk as a 
graphic file. 

Graphic Browser window � Also referred to as the Browser, shows thumbnails of all the graphics in 
the current directory. Depending on how it is invoked, this window shows graphics that will be read 
into Preview or Program, put into a sequence, or used as texture shaders. 

You can size and position the browser anywhere, to see as many thumbnails as you like. Type the 
first one or two letters of a graphic�s name to jump to the thumbnail of that graphic. Double-click 
the thumbnail to use the graphic.  

graphics (1) � Computer term: Text or pictorial artwork created on the computer with software and 
stored on a hard disk for use in computer-based presentations, desktop publishing, or video 
applications.  

graphics (2) � Video term: Text and Graphics created primarily by specialized electronic character 
generators and graphics systems and used in videotape applications. Personal computers equipped 
with special video output cards are capable of producing graphics for video production. 

gray scale � An even range of gray tones between black and white.  

GUI (Graphic User Interface) � A computer operating system that relies on menus, icons, and a 
pointing device (mouse) for user interaction. The foundation for the Macintosh� personal computer 
and IBM PCs operating with Microsoft Windows� 3.0. 

High Definition Television (HDTV) � A high-quality television system that has a wider aspect ratio 
(16:9) and increased number of scanning lines (1080) providing video images of a cinematic quality. 
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history � A drop-down list of commands that have been executed since the last time FXDeko was 
rebooted. 

horizontal resolution � In a television scanning system, the specification of resolution in the 
horizontal direction, meaning the ability of the system to reproduce closely spaced alternating black-
and-white vertical lines of detail across the screen. The number of alternating black -and-white lines 
is divided by the aspect ratio (usually 4:3) to make comparison between horizontal and vertical 
resolution easier. This number is usually expressed as TV lines per picture height.  

hue � The shade of a color. (See Wavelength). 

interface � An electronic device that allows dissimilar components in a system to communicate. The 
connection between two devices, such as a computer and a peripheral, for example.  

interlace � The pattern of two separate field scans when they join to form a complete video frame. As 
the video picture is transmitted, the first field picks up even-numbered scan lines, the second picks 
up odd-numbered ones. The two lace together to form a single, complete frame. (See Field and 
Frame). 

JPEG (Joint Photographic Experts Group) � An industry group brought together to establish a 
standard for digital image compression. Also used to denote the draft standard algorithm the group 
has developed for digital image compression. An approved standard has yet to be developed. The 
JPEG draft standard is being used by various software developers and is the basis for Apple�s software 
compression scheme, QuickTime�. 

kerning � The spacing between the characters within a word. The higher the kerning amount, the 
more space between characters. A negative kerning amount tightens the spacing between characters. 

key � A combination of two images where one image covers a portion, or cuts a hole in the picture, of 
the other as in a title. A key signal has three components: a key source, a key fill, and a background 
image. The key source cuts a hole in the background video, and the fill signal fills in that hole. Titles 
are usually keyed in. 

key signal � A black-and-white video signal that, when used with a keyer, tells the keyer how to 
combine two video signals. FXDeko outputs both a full-color video output and a black-and-white 
key signal. Let�s say you�re keying FXDeko graphics over live video from a camera. You feed the 
video and key outputs from FXDeko to a keyer (which could be FXDeko�s own internal keyer), and 
also the camera output. Where the key signal is white, the keyer inserts FXDeko�s output (the fill 
signal). Where the key signal is black, the keyer inserts the camera output (the key signal). Where 
the key signal is gray�somewhere between black and white�the keyer mixes the FXDeko and 
camera outputs. 

keyhole shader � A shader that cuts through all elements behind a detail to show keyed video on the 
detail. 
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Kilobyte (KB) � One thousand bytes or characters of digital information, consisting of from six to 
eight bits. In reality, one kilobyte equals 1024 bytes of information. 

layer � A layer is one element of a FXDeko graphic. A layer is either a text layer, a rectangle layer or 
an ellipse layer. A graphic can have any number of layers. Layers are rendered from front to back. 

layer browser � Shows a thumbnail image of each layer in the current graphic, and displays the 
layer�s name and order. Type the first one or two letters of the layer name to jump to that layer�s 
thumbnail. You can click a thumbnail to select a layer, or reorder layers by dragging and dropping 
them within the browser. 

layout � The arrangement of windows and toolbars on the desktop. FXDeko provides several pre-
configured layouts for composing, editing and playing back graphics and macros. 

leading � The spacing between rows of text. The higher the leading amount, the more space there is 
between rows. Leading rhymes with wedding. 

linear � A motion video or film sequence designed to be played from beginning to end without stops 
or branching. Linear usually refers to traditional video or films that are meant to be watched by the 
viewer passively from beginning to end without interaction.  

linear key signal � A key signal that varies from black to white, including intermediate gray shades. 
This is in contrast (no pun intended) to a hard key signal, which has areas of either black or white 
but no gray. A linear key signal is required for keyed graphics to look properly anti-aliased over 
background video. Your switcher must be capable of handling linear key. 

linear video � Any video program which plays from start to finish with no variation in sequence or 
pace of information presented. 

live � Television that is transmitted as the event occurs. 

look � Deko parameters that control everything about the way a text character looks�colors, edges, 
shadows, etc. A look is made up of a list of details. 

looping � A video device (switcher, monitor, etc.) that allows video inputs to pass through outputs to 
other devices without terminating. By looping the signal through a device, one signal can drive 
several devices. 

luminance � Amplitude (brightness) of the gray scale portion of the television signal. The Y signal. 
The range of brightness from black through gray to white in a video picture.  

macro � A series of FXDeko commands that can be saved in a macro file and played back on demand. 
You can use the macro recorder to record a macro, or you can edit a macro as a text file. 

macro recorder � Used to play macros and to record actions to create macros. 
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mapping � The ability to take a two-dimensional graphics file of texture: wood grain, chrome, etc. 
and project it on an object, thus, wrapping the object with the chosen texture. 

maximize button � Appears on the right side of a windows title bar. Clicking this button enlarges 
the window to its maximum size. 

media � Materials or technical means of communication, using films, art, video, voice, music, 
computer programming, etc. 

Megabyte (MB) � A unit of measurement equal to 1024 kilobytes (KB) or 1,048,576 bytes. Data 
files: especially sound, graphics, and digital video files are measured in MB. 

menu bar � Appears near the top of FXDeko�s application window, under the title bar. Clicking on 
any entry brings up a pull-down menu of commands. Click on a command to perform it. Commands 
followed by an ellipsis (...) bring up an additional window for more information to be entered. 
 
  

MHz � Abbreviation for megahertz, or millions of cycles per second. The bandwidth of the video 
signal is 4.2 MHz. A normal U.S. television transmission channel is 6 MHz. 

minimize button � Appears on the right side of a title bar. Clicking this button 
reduces the window to its smallest size, usually an icon at the bottom of the 
screen. For example, clicking the minimize button in FXDeko�s title bar reduces 
FXDeko to its application icon. To restore FXDeko, double-click the icon. 

mixing � Combining two or more audio or video sources. 

modem � A device used to accept digital signals and add them onto, or modulate them on, analog 
signals for transmission between sites. Modem is an abbreviation for MOdulator/DEModulator. A 
modem acts not only to convert digital signals to be transmitted in analog form, but likewise to 
demodulate the signals. 

monitor � In video, a television with composite video inputs. A computer monitor usually accepts 
RGB rather than composite input. To watch or listen to, or the device through which monitoring 
takes place. 

monochrome � Black and white.  

motion � Describes the movement on or off air of elements, or sprites, of a graphic. Each line in a 
motion script specifies one or more sprites. A motion script can be saved in a motion (.mot) file, 
which you can then specify as an effect in a sequence. 
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mouse pointer � The mouse pointer is used for pointing to objects on the desktop and 
clicking or dragging them. 

MPEG (Motion Picture Experts Group) � The standards committee meeting to set standards for the 
compression of motion video images. Like JPEG, it is both a group and an algorithm. The algorithm, 
for compressing moving images, is being developed and is not yet available for use. 

navigate � A term used to use a mouse or keyboard to control the elements of a Graphic Interface. To 
navigate around a dialog box, use Tab and Shift + Tab to move between fields, or click on the desired 
field. The up and down arrow keys scroll through the items in a list. Double-click a directory to 
select it. Double-click a file name to open the file.  

network � An interconnected and coordinated system of geographically dispersed communication 
devices (terminals) so that signal transmission to or among any of the devices is practical and reliable. 

noise � A change in the characteristics of an electronic signal (amplitude, frequency, or phase) that is 
not directly related to the information being communicated. All electronic circuits are subject to 
noise. 

non-composite video signal � A video signal containing picture and blanking information, but no 
sync signals. Non-composite video signals are used as input and output signals for some video 
equipment.  

NTSC (National Television System Committee) � The group that established the color TV 
transmission system in the United States. Used to refer to the North American broadcast scanning 
standard for television of 525 lines per frame at a rate of 30 frames per second. Established by the 
American National Technical System Committee, NTSC is used as a general term to describe the 
color and standards of American broadcasting. Other color standards such as PAL and SECAM are 
used by different countries and are not compatible with NTSC. 

Object-oriented graphics � A picture or other graphic where each object, rather than being made up 
of separate dots (as in a bit-mapped graphic), is treated as a unit. 

OEM (Original Equipment Manufacturer) � A manufacturer that sells equipment slightly redesigned 
to several vendors. Each vendor then puts its name on that equipment and sells it as its private brand.  

PAL (Phase Alternating Line) � A video standard used in Western Europe, Latin America, Great 
Britain, South Africa, and Australia; PAL uses 625 scan lines with a 25-frame/50-field per second 
rate. PAL is not compatible with NTSC.  

patch bay � A junction panel of connector jacks (patch points) that serve as a convenient location for 
making all system connections. It consists of two rows of connector jacks, which are wired, with 
various signals from the rear of external equipment. 

pedestal � See black. 
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phase � The timing of an electronic signal. Two signals that occur simultaneously are in phase, if 
they occur at different times, they are out of phase.  

Phase Alternating Line (PAL) � The broadcast television standard in Europe as well as other 
locations, calling for 625 lines per frame transmitted at 25 frames per second. North American 
standards call for 525 lines per frame transmitted at 30 frames per second. 

picons � Picture Icons: On screen visual objects that represent media elements. 

PICT � A standard format for encoding computer graphics and images (term is an abbreviation of 
picture).  

PICT 2 or PICT II � An update of the PICT adding color support and formatting instructions 
carried as comments in the image file. 

pin location � A character�s pin location determines how it will be placed relative to the baseline of 
the current row. The Y value indicates the baseline of the character, and the X value indicates the left 
edge of the character. 

pixel (picture element) � (1) The smallest unit of picture information on imagers, scanners, printers, 
displays, images, or graphic files. (2) The basic picture element of a computer screen or graphics-
sensing array, such as a CCD, the smallest dot a computer can create. (3) The individual picture 
elements on a picture tube or display device. 

preset shader � A shader that has been stored in one of the 18-shader presets at the bottom of the 
Shader window. All 18 preset shaders may be saved in a shader presets file. 

preset style � A style that has been saved in one of the eight preset style buttons in the Preset Style 
window. Each button displays sample text in the preset style. To change what sample text is 
displayed, click Sample in the Typeface Browser and type in new sample text. By default, sample text 
on the buttons shows fonts in their actual sizes. You can have the buttons display all fonts in 
standard sizes by choosing Preferences from the Options menu, clicking the Advanced tab, and un-
checking the Show actual font size in Presets box. 

Preview window � The window that shows a graphic that is not yet on-air. When playing back a 
sequence, this window shows the next graphic in the sequence.  

Program window � The window that shows the current on-air graphic. The contents of this window 
match FXDeko�s video output, with the addition of a cursor, safe-title lines and other markers. 
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quantizing � The numerical value assigned to a digital sample. In digital imaging, the level of 
quantizing determines how realistically digital images will be reproduced. The more quantizing 
levels for each sample, the truer the digital representation will be to the original analog source. 

RAM � Abbreviation for random-access memory, a memory providing access time that is 
independent of location. 

random access � Also referred to as instant access, a term used to define the capability of a videodisc 
to access specific frames regardless of location on the disc. 

raster � The pattern of the moving electron scanning beam in a CRT, usually moving left to right 
and repeating over the image from top to bottom as a series of horizontal scan lines. In an NTSC 
system, the raster scan of one TV frame consists of 525 individual scanned lines made up of two 
interlaced fields of 262.5 lines each. The scanning pattern creates a new frame every 30th of a second. 

real estate � The space available on a videodisc or tape. 

real time � The actual time in which a program or event takes place. 

reference black level (pedestal) � Part of the video signal that provides a reference level for total 
picture brightness.  

render � To draw an image as it actually appears in schematic or blueprint form. 

resolution � FXDeko specifies resolution in screen units, which are user-definable in 
Options/Preferences/Advanced/Resolution. The default value for screen units is 486 in NTSC and 
576 in PAL. 

resolution � The maximum definition a particular system is capable of reproducing. Resolution is 
measured in the number of discrete observable lines that can be reproduced on a system. The higher 
the resolution a system is capable of producing, the sharper the picture will appear. In TV, resolution 
is measured in vertical and horizontal lines or the total number of observable black to white line 
transitions observable in the picture. Horizontal resolution is limited by the bandwidth of the 
television circuit, while vertical resolution is limited by the total number of TV scan lines. A high-
resolution video camera or monitor can display 700 horizontal lines of resolution and 486 vertical 
lines or 700 x 486 resolution. 

Amount of detail in the video image is measured along both the horizontal and vertical axes. In 
digital systems, resolution is the number of pixels on a display surface. Computer CRT resolutions 
are usually given as the number of pixels per scan line and the number of scan lines, e.g. 640 x 480. 
Video resolution is measured in terms of lines of detail per horizontal scan line (horizontal resolution) 
and total number of scan lines (vertical resolution). 

The clarity or graininess of a video or computer image as measured by lines or pixels; the smallest 
resolvable detail in the image. The perceivable detail, or the ability of an image reproducing system 
to reproduce fine detail.  
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restore button � Appears on the right side of a windows title bar. Clicking 
this button restores the window to its size before it was minimized or 
maximized. 

RGB (Red, Green, Blue) � The primary colors of light, which are mixed to produce a video image. In 
video, RGB refers to a system in which the three primary colors are kept isolated and delivered from 
the source to the display device over separate wires. This system results in high-quality pictures. The 
RGB system is used by some broadcast video equipment and computers.  

RGB encoder � Device for converting composite video to RGB video.  

right-click � Operation that involves pressing the right-mouse button. The right-click operation 
reveals hidden menus or dialogs in an NT interface. 

ROM (Read-Only Memory) � The information on a CD-ROM disc cannot be altered or new 
information added by the user. 

routing � Directing a signal through various audio and/or video components. 

routing switchers � Hard-wired, automated patch bays that allow system connections to be made 
simply by pushing a button. 

safe title area � The area of the screen considered safe for graphics. Anything outside this area may be 
clipped by an over scanning monitor. The safe title area is only a reference; it does not prevent typing 
outside its boundaries. You can specify the top, bottom, right and left boundaries of the safe title 
area. Values represent a percentage of the distance from the specified edge of the screen to the 
opposite edge. With Deko, the default text layer is set to the dimensions of the safe title area. 

safe-area � The central display on a video screen. A loss of 10-15% of the edges of the image is to be 
expected because of over scanning on video monitors. Designers should plan to stay in the �safe-area� 
when creating graphics for video. Also known as Safe-Title Area. 

sampling � The act of frequently �looking� at a signal during the analog to digital conversion 
process to evaluate how the signal has changed. The process of dividing something continuous into 
discrete sections. The resulting samples of the signal are used to form the digital representation of 
the signal.  

saturation � The intensity of a particular hue.  

scaling � Changing the size of something.  

scan converter � A digital signal processor that converts the high scan rate output of the computer 
display card to a high-quality broadcast video signal rate. Scan converters differ from encoding boards 
and boxes in that they usually can take a variety of scan rates from many computer systems, and they 
are usually in the higher price range: US$8000 to US$12,000. 
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scan line �A complete horizontal row of pixels on the display surface of a CRT. 

screen units � The units FXDeko uses for the height of a typeface and for the location of text and 
shapes in a graphic. Screen units are user-definable, in Options > Preferences > Advanced > 
Resolution. Once you set the number of vertical units, the number of horizontal units is 
automatically set to 4:3 of that amount. For convenience, the default value for screen units is 486 in 
NTSC and 576 in PAL, which equals the number of visible scan lines in each video standard.  

SCSI (Small Computer Systems Interface) � An intelligent controller standard used to connect 
peripherals like CD-ROM drives and printers to microcomputers. 

sequence � A list of events that controls the playback of a series of FXDeko graphic files. 

serial communications � Multi-pin digital communication lines allowing several communications to 
occur sequentially along each conductor enabling the connected devices to talk and to receive at the 
same time.  

set width � A character�s set width determines how much horizontal space the character occupies 
when typed. A character�s set width plus its pin location equals the pin location of the character to 
its right. 

setup � See black. 

shader � Controls the color�solid, texture, ramp, or  keyhole�of a detail or a background. 

sprite graphics � A small graphic picture that can be moved around the screen independently to 
produce animation. 

status bar � The line of information, at the bottom of the screen, which shows FXDeko�s current 
status. 

 

string � A set of characters, such as a word or sentence. A string that includes spaces or non-
alphanumeric characters must be defined within quotation marks, such as �Hello there�. 
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style � A style consists of a font and a look. A font is a typeface of specified size, shape and 
orientation. A look controls how FXDeko renders a font character. Each look is comprised of a list of 
details. Each detail is a face, edge, frame, shadow, or underline, and has its own set of attributes that 
dictate its color, size, shape, etc. 

superimpose � To overlap the image from one source over the image from anther source. Also: Super. 

Sync (Synchronize) � The drive pulses�both vertical and horizontal�that maintain the vertical and 
horizontal scanning process of the video picture signal in all video equipment through processing and 
recording to display. 

sync generator � A pulse generator that produces video sync signals. A master sync generator would 
be used to provide sync signals (genlock) to integrate the functioning of several pieces of video 
equipment in relation to each other and the video signal. 

text bar � The toolbar at the top of the FXDeko desktop, under the menu bar, which controls many 
common text functions. 

 

text box � Text boxes are Windows NT controls in which you type or otherwise enter information. 

 

text cursor � Shows where in a text field the next typed character will be inserted. The text cursor is 
shaped like an I-beam or a rectangle, depending how you have your cursor preference set. 

                
I - beam cursor         Box cursor 

text field � One layer of text in a FXDeko graphic. A text field is defined by its text field box, which 
controls word wrapping and justification. A text field has a default style (font and look). Characters 
in a text field may extend beyond the text field box. The box is used for alignment, not clipping. 

texture shader � Used to apply a pattern to a detail. The pattern is actually a bitmap that is cut from 
another graphic file and pasted onto the detail. 

time code � A code using time as its measuring and location system. Recently standardized by the 
SMPTE, time code utilizes hours, minutes, seconds, and frames. It is a binary electronic signal if 
recorded on the tape and is analogous to the edge numbers in film. 
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title bar � The bar at the top of any Windows NT application window, including FXDeko�s. This 
bar is highlighted whenever an application is active. 

tool tips � Those little yellow pop-up windows that appear if you hold the selection cursor over a 
toolbar button for a brief moment. They explain what each button does. You can turn tool tips on 
and off from the Help menu. 

turnkey � Generally used to refer to a fully integrated system installed and ready for use; implies all 
phases of creating such systems, as well as all necessary communication links to use them. 

UNIX� � An operating system developed by AT&T and used by the LMS� applications controller. 
Widely acclaimed in the computer industry, UNIX is recognized for its powerful multi-user and 
multi-tasking capabilities. 

VCR � Video Cassette Recorder. 

vertical resolution � For television signals, the specification of resolution in the vertical direction. 
The ability to reproduce closely spaced horizontal lines. The maximum number of alternating white-
and-black horizontal lines that can be counted from the top of the picture to the bottom, or the 
amount of detail that can be perceived in the vertical direction. Vertical resolution is only roughly 
equivalent to the number of horizontal scanning lines in a picture. 

video signal � A waveform carrying video information.  

voice-over � A spoken message delivered off-camera. This is the opposite of Lip Sync recording, 
which is done live as the actors are being photographed. An off-screen narration would be considered 
a voice-over. 

VTR � Video Tape Recorder. 

wipe � An optical effect where the picture appears to have been �wiped� from the screen, i.e., left to 
right, or top to bottom. 

workstation � A high-end computer system having many of the characteristics of a personal 
computer; intended for use by engineers or imaging professionals. 

WYSIWYG � An acronym for, What you see is what you get. Refers to computer systems that give 
you an on-screen image of the final printed or recorded product, rather than substituting symbols or 
codes. 

Y signal � The luminance or brightness aspect of a video signal. 

Y, R-Y, B-Y � The three components of a component video signal including the Y (luminance) 
signal and the R-Y, B-Y color difference signals (chrominance). The component output of the D-1, 
Betacam®, and MII formats. 
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