
DynaLog File Viewer
Reference Guide

Millennium 52-leaf MLC
Millennium 80-leaf MLC
Millennium 120-leaf MLC
HD120 MLC
MARK-Series 52-leaf MLC
MARK-Series 80-leaf MLC
Saturne 80-leaf MLC
BrainLAB m3

13485 100013698-06 July  2013



Document ID 100013698, Revision 06

Abstract DynaLog File Viewer Reference Guide provides reference information and
procedures for using the DynaLog File Viewer, version 8.X.
This publication is the English-language original.

Manufacturer Varian Medical Systems, Inc.
3100 Hansen Way
Palo Alto, CA 94304-1038
United States

European
Authorized
Representative

Varian Medical Systems UK Ltd.
Oncology House
Gatwick Road, Crawley
West Sussex RH10 9RG
United Kingdom

Notice Information in this user guide is subject to change without notice and does not
represent a commitment on the part of Varian. Varian is not liable for errors
contained in this user guide or for incidental or consequential damages in
connection with furnishing or use of this material.
This document contains proprietary information protected by copyright. No part
of this document may be reproduced, translated, or transmitted without the
express written permission of Varian Medical Systems, Inc.

FDA 21 CFR 820
Quality System
Regulations
(CGMPs)

Varian Medical Systems, Oncology Systems products are designed and
manufactured in accordance with the requirements specified within this federal
regulation.

ISO 13485 Varian Medical Systems, Oncology Systems products are designed and
manufactured in accordance with the requirements specified within the ISO 13485
quality standard.

CE Varian Medical Systems, Oncology Systems products meet the requirements of
Council Directive MDD 93/42/EEC.

EU REACH SVHC
Disclosure

The link to the current EU REACH SVHC disclosure statement can be found at 
http://www.varian.com/us/corporate/legal/reach.html

HIPAA Varian’s products and services are specifically designed to include features that
help our customers comply with the Health Insurance Portability and
Accountability Act of 1996 (HIPAA). The software application uses a secure login
process, requiring a user name and password, that supports role-based access.
Users are assigned to groups, each with certain access rights, which may include
the ability to edit and add data or may limit access to data. When a user adds or
modifies data within the database, a record is made that includes which data
were changed, the user ID, and the date and time the changes were made. This
establishes an audit trail that can be examined by authorized system
administrators.

WHO ICD-O codes and terms used by permission of WHO, from:
■ International Classification of Diseases for Oncology, (ICD-O) 3rd edition,

Geneva, World Health Organization, 2000.
ICD-10 codes and terms used by permission of WHO, from:
■ International Statistical Classification of Diseases and Related Health

Problems, Tenth Revision (ICD-10). Vols 1–3, Geneva, World Health
Organization, 1992.

2 DynaLog File Viewer Reference Guide

http://www.varian.com/us/corporate/legal/reach.html


CAUTION: US Federal law restricts this device to sale by or on the order of a physician.

Trademarks Clinac® linear accelerator, Exact® arm, Exact® couch, On-Board Imager® kV imaging
system, ARIA® oncology information system, Eclipse™ integrated treatment planning,
Millennium™ MLC, PortalVision™ MV imaging system, PortalVision™ aS1000 MV imager,
PortalVision™ aS500 MV imager, PortalVision™ aS500–II MV imager, and RPM™

respiratory gating system, Silhouette Edition®, UNIQUE™, EDW™, HD120 MLC™ are
trademarks of Varian Medical Systems, Inc.
Microsoft® is a registered trademark of Microsoft Corporation.
All other trademarks or registered trademarks are the property of their respective owners.

Copyright © 2002, 2003, 2006, 2007, 2010, 2013 Varian Medical Systems, Inc.
All rights reserved. Produced in the United States of America.

3



Contents

CHAPTER 1    INTRODUCTION .............................................................................................................. 6
Introduction ....................................................................................................................................................... 6
Visual Cues ......................................................................................................................................................... 6
Contacting Varian Customer Support ......................................................................................................... 7
DynaLog File ....................................................................................................................................................... 8
DynaLog File Size ...............................................................................................................................................9
DynaLog File Viewer Description ..................................................................................................................9

CHAPTER 2    GENERATING DYNALOG FILES ....................................................................................11
Generate DynaLog Files .................................................................................................................................. 11

Generate and Save DynaLog Files for a MARK-Series MLC .............................................................11
Generate and Save DynaLog Files for a Millennium MLC .............................................................. 12

CHAPTER 3    DYNALOG FILE VIEWER PROCEDURES .....................................................................14
Start DynaLog File Viewer ............................................................................................................................. 14
Set the DynaLog File Interpretation ........................................................................................................... 14
Open DynaLog Files ......................................................................................................................................... 15

Millennium DynaLog Files ..................................................................................................................... 16
Classic DynaLog Files ...............................................................................................................................18

Save DynaLog Analysis Results .................................................................................................................... 21
View DynaLog Data in Graphical Formats ................................................................................................23

Error Histogram ........................................................................................................................................23
Error RMS ...................................................................................................................................................26
Beam On Plot ............................................................................................................................................ 28
Beam Hold Off Plot ................................................................................................................................. 28

Arrange DynaLog File Graphical Formats .................................................................................................30
Display File Information ................................................................................................................................30
Print DynaLog File Reports ............................................................................................................................ 31
Close DynaLog Files ......................................................................................................................................... 31
Obtain DynaLog File Viewer Version Number ......................................................................................... 32
Exit DynaLog File Viewer ...............................................................................................................................32

CHAPTER 4    INTERPRET DYNALOG ANALYSIS RESULTS .............................................................33
DynaLog File Viewer Analysis of Step-and-Shoot Treatments ............................................................ 33
Relation Between Dynamic Tolerance and RMS Error ...........................................................................34

APPENDIX A    DYNALOG FILE CONTENTS .......................................................................................41
File Naming Convention ................................................................................................................................41
File Header ........................................................................................................................................................ 41
File Content ...................................................................................................................................................... 42

4 DynaLog File Viewer Reference Guide



APPENDIX B    COMPRESSING DYNALOG FILES ............................................................................ 44
Compress DynaLog Files ............................................................................................................................... 44
Install Zip and Unzip ...................................................................................................................................... 44
Zip DynaLog Files ............................................................................................................................................ 44
Unzip DynaLog Files ....................................................................................................................................... 45

INDEX ........................................................................................................................................................46

Contents 5



Chapter 1    Introduction

Introduction
This reference guide describes DynaLog files and how to use DynaLog File Viewer,
version 8.X (DFV), a program that analyzes data in DynaLog files and displays the
data in graphical formats.

DynaLog File Viewer Reference Guide is written for physicists who want to statistically
evaluate leaf positions and the beam state of the Clinac during a dynamic treatment
using a MARK-Series MLC or a Millennium MLC (this includes the HD120 MLC).

This guide uses the term MARK-Series to indicate all pre-Millennium MLCs
including MLC, Standard MLC, CR-MLC, and MARK-Series MLC.

Before you begin using DynaLog File Viewer, you should be familiar with the
Microsoft Windows operating environment and have basic knowledge of the MLC
software.

Visual Cues
This publication uses the following visual cues to help you find information:

WARNING: A warning describes actions or conditions that can result in serious injury or
death.

CAUTION: A caution describes hazardous actions or conditions that can result in minor or
moderate injury.

NOTICE: A notice describes actions or conditions that can result in damage to equipment
or loss of data.

Note: A note describes information that may pertain to only some conditions, readers, or sites.
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Tip: A tip describes useful but optional information such as a shortcut, reminder, or suggestion,
to help get optimal performance from the equipment or software.

Contacting Varian Customer Support
Varian Customer Support is available on the internet, by e-mail, and by telephone.
Support services are available without charge during the initial warranty period.

The my.varian.com website provides contact information, product documentation,
and other resources for all Varian products.

Get Online Customer Support
You can browse the my.varian.com site without having a Varian account or logging
in. However, you must have a Varian account to get online customer support and to
access product information for products at your institution or clinic.

1. Go to http://my.varian.com.
2. Click Contact Us at the top of the window to display customer support and

training options, and international e-mail addresses and telephone numbers.
3. Choose an option:

■ If you do not already have an account, click Create New Account and follow
the instructions. Establishing an account may take a few days.

■ If you have an account, go to the next step.
4. Enter your user name and password.
5. Browse the information and then click the link that corresponds to what you

want to do:
■ Fill out and submit a support request.
■ Find documents. Online documents in PDF format include customer technical

bulletins (CTBs,) manuals, and customer release notes (CRNs).
■ Send an e-mail to Varian support. You can browse for international e-mail

addresses and telephone numbers by geographic area, and for oncology-
specific contacts such as for brachytherapy.

■ Find parts and services by geographical area.

E-Mailing Varian
Send e-mail inquiries through the my.varian.com website.

Alternatively, you can use a support e-mail address that corresponds to your location
or interest:

Chapter 1    7

http://my.varian.com


Location E-mail Address

North America support-americas@varian.com

Latin America soporte.al@varian.com

Europe support-emea@varian.com

Australia and New Zealand support-anz@varian.com

China support-china@varian.com

Japan support-japan@varian.com

South East Asia support-sea@varian.com

Brachytherapy Systems brachyhelp@varian.com

Ordering Documents by Phone
You can order documents by phone by calling Varian Medical Systems support.

Location Telephone Number

North America + 1 888 827 4265 (Press 2 for parts)

Global Call your local Varian office.

DynaLog File
A DynaLog file is a record of the actual dose fraction (dose dynamic) or gantry angle
(arc dynamic) versus actual MLC leaf positions from either a dynamic treatment or a
segmental treatment, encoded in UTF-8 format. A dynamic treatment is a treatment
during which the MLC leaves, collimator, or gantry move while the beam is on and
both the dose rate and the speed of the leaves are continually adjusted by the control
system.

The DynaLog data is taken every 50 ms by the MLC controller. The recording
continues until the dynamic treatment is completed or terminated. Starting with
MLC version 8.0, DynaLog file information is collected for the entire treatment, and
no time limit is imposed. Autosave is only accomplished if automatic DynaLog
logging was started prior to treatment.

The MLC controller stores the DynaLog data in a temporary memory buffer. Each
time you load a new dynamic treatment, the MLC controller overwrites the DynaLog
data from the previous treatment. As a result, the DynaLog data for the finished
treatment is no longer retrievable. To prevent losing data from your dynamic
treatment, save the DynaLog files after each field or turn on the autosave feature of
DynaLog files.

8 DynaLog File Viewer Reference Guide



DynaLog File Size
The DynaLog file size is dependent upon the elapsed treatment time. Thus, the
longer the dynamic treatment lasts, the larger the DynaLog file size.

File size might become a consideration on the MARK-Series MLC, where the file
needs to be transferred from the controller using floppy disks or flash drive.

If the file becomes too large, you can use a file-compression utility to reduce its size
so that it fits on the floppy disk. One popular compression tool is PKZIP, available
from the PKWARE web site at http://www.pkware.com. Another alternative is the
public domain compression tool Zip from the Info-ZIP Group, which you can find in
the ZipTool directory on the DFV installation CD-ROM. For more information about
using this utility, see Compress DynaLog Files on page 44.

DynaLog File Viewer Description
DynaLog File Viewer is a utility program that allows you to view data from DynaLog
files in graphical formats. A standard text editor such as WordPad or Notepad
cannot be used to view DynaLog files. DynaLog File Viewer takes the data from the
DynaLog files and converts the data into tables and plots. DynaLog files are viewed
by using one of the following formats:

■ Error Histogram—shows information for all leaf position deviations. DynaLog
File Viewer creates a histogram with a tally of the number of leaf position
deviations within each bin. This plot is broken into 0.05 cm bins spanning a total
range from 0–1.00 cm. The plot has a zero deviation bin for deviations less than
0.005 cm and an above maximum bin for deviations greater than 1.00 cm. The error
histogram bin boundaries represent position deviations at the isocenter plane.

■ Error RMS—shows the calculated root mean square (RMS) value for leaf
deviations. DynaLog File Viewer calculates RMS values for leaf position
deviations of individual leaves using the following formula:
 

Lea fError RM S

LeafPlanPost LeafActualPost
2

t 1=

n

∑
n---------------------------------------------------------------------------------------------------=
-(  )

 

where:

■ t = data sample index
■ n = total number of samples
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Note: DynaLog files contain all leaf positions, but a leaf is included in the RMS calculations
only if it or the opposing leaf moves during the treatment.

■ Beam Hold Off plot—shows when and how often the beam hold-off is asserted
during the dynamic treatment. This plot can be used as a tool to ensure that the
system is operating correctly.

■ Beam On plot—shows when and how often the beam is on during the dynamic
treatment.

For examples of each of the data tables and plots, as well as instructions on how to
use DynaLog File Viewer, see Chapter 3.
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Chapter 2    Generating DynaLog Files

Generate DynaLog Files
The MARK-Series MLC and Millennium MLC controllers operate in different
software environments; therefore, the procedure for generating DynaLog files for
each type of controller is different. This chapter provides step-by-step instructions for
generating DynaLog files for the MARK-Series MLC and the Millennium MLC.

Generate and Save DynaLog Files for a MARK-Series MLC
To generate DynaLog files for a MARK-Series MLC, perform the following steps:

1. Close the patient file on the MLC workstation.
2. Type F on the MLC controller keyboard.

The MLC controller prompts you to type a letter that represents the disk drive
where you want to save the DynaLog files for both carriages.

3. To save the DynaLog files, perform one of the following:
■ Type A to save the DynaLog files onto a floppy disk.

■ Type letter of the flash drive location to save the DynaLog files onto a flash
drive.

■ Type C to save the DynaLog files to the hard disk drive.

Note: DynaLog files saved to the hard disk drive are stored in the MLC controller directory
and are not accessible while the MLC controller is in use. To access the files, exit the MLC
controller.

Once you have specified the drive where the DynaLog files are to be saved, the MLC
controller writes dynaloga.001 for carriage A and dynalogb.001 for carriage B
to the designated drive. The MLC controller automatically increases the file extension
number (for example, .002, .003, .004 and so forth), each time new DynaLog files
are generated.

If the DynaLog files are saved to a hard disk drive, to copy them onto a floppy disk
or flash drive, type one of the following commands at the MS-DOS prompt:
■ copy dynaloga.### X:dynaloga.###
■ copy dynalogb.### X:dynalogb.###
where ### is the appropriate three-digit extension and X is the appropriate floppy
disk or flash drive location.
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Generate and Save DynaLog Files for a Millennium MLC
The Millennium MLC controller operates in a VxWorks® environment. Serial
communication, using HyperTerminal, needs to be set up to communicate with the
MLC controller, and an Ethernet connection is required to transfer DynaLog files to
the workstation.

Note: DynaLog files may contain patient Personal Health Information (PHI).

Use one of the following methods to generate DynaLog files for the Millennium
MLC:
■ Enter a command to save the DynaLog files for only the dynamic treatment just

completed.
or

■ Enter a command to make the MLC controller automatically save the DynaLog
files after the completion of each dynamic treatment. There are two possible ways
to automatically save DynaLog files:
■ Enter a command at HyperTerminal that turns on the autosave only for the

current session.
■ Modify the appropriate startup.* file to turn on autosave permanently.

Note: The Millennium MLC controller automatically names the file when generating new
DynaLog files. The name is based on the patient’s information and time of treatment.
However, the MLC workstation replaces following characters in the DynaLog file name with
an underscore _:
■ < (less than)
■ > (greater than)
■ : (colon)
■ " (double quote)
■ / (forward slash)
■ \ (backslash)
■ | (vertical bar or pipe)
■ ? (question mark)
■ * (asterisk)

To enable the system to generate and save DynaLogs automatically, in the
HyperTerminal at the VxWorks prompt, type the command: diagAutoDynalogs 1
To turn off this feature, type the command: diagAutoDynalogs 0
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When this feature is enabled, as soon as a dynamic MLC treatment finishes, the
controller writes those treatment DynaLog files to the DynaLogs folder subdirectory
within the default FTP root directory on the MLC workstation. For example:

\Oncology\MLC\Controller\exec\DynaLogs\
Unlike manually-generated DynaLog files, the controller assigns unique file names to
the automatically generated DynaLog files. The Revision B MLC controller names the
files using the following convention:

CYYYYMMDDHHNNSS_<Patient ID>.dlg
where the values are as follows:

C A or B for the MLC carriage (leaf bank)

YYYY 4-digit year

MM 2-digit month

DD 2-digit day of the month

HH 24-hour clock time stamp

NN minutes time stamp

SS seconds time stamp

<Patient ID> The Patient ID
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Chapter 3    DynaLog File Viewer Procedures

Start DynaLog File Viewer
DynaLog File Viewer opens, saves, and displays the DynaLog files in data tables and
plots.

To start DynaLog File Viewer:
■ Double-click the DynaLog File Viewer icon on the desktop.

or
■ From the Windows Start menu, select Programs > MLC Utilities > DynaLog File

Viewer.

The first time DynaLog File Viewer is opened, the Configuration dialog box opens,
allowing you to choose which MLC calculations are to be used, and what file format
is to be used from the list of available formats (see Set the DynaLog File
Interpretation on page 14).

After the first time, when the program opens, the Open dialog box for the current
configuration opens (see Millennium DynaLog Files on page 16 and Classic
DynaLog Files on page 18).

Set the DynaLog File Interpretation
The MLC type you specify determines the types of files you can open and how the
data is interpreted by which MLC type you specify:
■ When you start DynaLog File Viewer for the first time, you are prompted to select

an MLC type.
■ You can also change the MLC type at any time by selecting MLC Type from the

Config menu.

The Pick MLC Type dialog box opens so that you can select the MLC type.
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The five choices represent the eight supported MLC configurations. Each
configuration uses different correction factors and calculation sets:
■ Millennium MLC (120, 80, & 52)

■ Millennium 120-leaf MLC
■ Millennium 80-leaf MLC
■ Millennium 52-leaf MLC

■ HD 120 MLC
■ Mark MLC (80 & 52)

■ MARK-Series 80-leaf MLC
■ MARK-Series 52-leaf MLC

■ m3 without Varian MLC (Novalis)
■ m3 with Varian MLC

Note: The same data yields different results when different configuration settings are selected.
Therefore, you should ensure that you select the configuration that is used to collect your data.

You can open either Millennium DynaLog files or Classic files. For more information,
see Millennium DynaLog Files on page 16 and Classic DynaLog Files on page 18.

Open DynaLog Files
From the File menu, DynaLog File Viewer can open either Millennium DynaLog files
or Classic files.
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Note: You can only open Millennium DynaLog files if you have the MLC type set to
Millennium MLC (see Set the DynaLog File Interpretation on page 14).

Millennium DynaLog Files
When you start the Dynalog File Viewer program, the Open Dynalog File for
Carriage A window Figure 1 opens.

Figure 1 Open DynaLog File for Carriage A Window

At other times, you can display this window from the File menu.
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To open a Millennium DynaLog file, perform the following steps:

1. From the File menu, select Open Dynalog Files.

The Open Dynalog File for Carriage A window appears (see Figure 1 Open
DynaLog File for Carriage A Window on page 16). If the desired file is not
available, use the folder navigation buttons in the window to navigate to the
directory containing the desired file.

2. Select the file for carriage A (for example,
A20050721094800_294262481.dlg).

3. Click Open.

The program opens the files for Carriage A and Carriage B. The file name for
Carriage B is automatically assumed to be the same as that for Carriage A, with a
B prefix instead of an A.

Note: To open a file, both the A and B files must be present in the same folder.

The program automatically generates the data tables and plots for both the error
RMS and the error histogram data and displays them in the main window.
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Classic DynaLog Files
Classic DynaLog Files are generated by Mark-series MLC models. To open a Classic
DynaLog file, perform the following steps:

1. From the File menu, select Open Classic Dynalog Files.

The Open Classic Dynalog File for Carriage A window appears.
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If the desired file is not available, use the folder navigation buttons in the
window to navigate to the directory containing the desired file.

2. Select the file for carriage A (for example, DYNALOGA.015).
3. Click Open.

The program opens the files for Carriage A and Carriage B. The file name for
Carriage B is automatically assumed to be the same as that for Carriage A, with
the last letter of the file name being B instead of A.

Note: To open a file, both the A and B files must be present in the same folder.

The program automatically generates the data tables and plots for both the error
RMS and the error histogram data and displays them in the main window.
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Save DynaLog Analysis Results
To save the error histogram data table, perform the following steps:

1. From the File menu, select Save Error Histogram.

The Save Histogram Data window appears.

2. Accept the default file name or type a new file name for the error histogram data
table in the File name text box.

3. Click Save.
The error histogram data file is an ASCII text file that contains the same data as
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the Error Histogram Data window, described in Error Histogram on page 23.

To save the error RMS data, perform the following steps:

1. From the File menu, select Save Error RMS.

The Save RMS Data window appears.

2. Accept the default file name or type a new file name for the error RMS data table
in the File name text box.

3. Click Save.

The program saves the error RMS file and closes the window.
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The error RMS data file is an ASCII text file that contains the same data as the Error
RMS Data window, described in Error RMS on page 26.

View DynaLog Data in Graphical Formats
To view the tables and plots for the DynaLog data:
■ From the View menu, select the desired data tables and plots.

 

 

When selecting either Error Histogram or Error RMS from the View menu, DFV
displays both the data table and the plot in the main window. For clarity, this
reference guide shows the data tables and plots in individual figures.

Error Histogram
To view the error histogram data:
■ From the View menu, select Error Histogram.
■ From the Window menu, select either Error Histogram Data or Error Histogram

Plot.
DynaLog File Viewer opens both the Error Histogram Data (Figure 2 on
page 24) and the Error Histogram Plot windows (Figure 4 on page 26).

The Error Histogram Data table has five columns.
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1 2 3 4 5

1. Bin number
2. Range of leaf deviation for that bin at the

isocenter plane
3. Number of samples in that bin

4. Percentage of the total sample count in
that bin

5. Summation of the percentage in that bin

Figure 2 Error Histogram Data Window

The last column contains the cumulative sum of the percentages in the fourth
column. If the sum of the percentages reaches 95% within the first 8 rows, then the
Percent and Percent Sum columns of the row that crosses the 95% threshold, and all
the previous rows, are shaded green.

If the sum of the percentages does not reach 95% in the first 8 rows, then the first 8
rows are shaded green, and the subsequent rows are shaded red up to the row that
reaches the 95% mark.

If there is a non-zero # of Counts value for bin 22, then that value is shaded yellow
(see Figure 3).
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Figure 3 Error Histogram Data with Shading for Bin 22

The specifications that determine pass or fail (red or green) are set to match the
current Varian specification, and cannot be altered by the user.

The Error Histogram Plot provides a graphical representation of the Error Histogram
Data values.
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1

2

1. Y-axis represents sample count
2. X-axis represents bin number

Figure 4 Error Histogram Plot Window

Error RMS
To view the error RMS data:
■ Select Error RMS from the View menu.

DFV displays both the Error RMS Data (Figure 5) and the Error RMS Plot
(Figure 6) windows.

The first row of the Error RMS Data table shows the average RMS error for the
moving leaves on carriage A and carriage B. The second row shows the maximum
RMS error for the leaves on carriage A and carriage B. The green shading indicates
the larger maximum of the two. If the maximum value is greater than the acceptance
specification, then the value is shaded red instead of green.

The remaining rows represent the RMS error for each individual leaf. All error values
are in units of centimeters at the treatment plane. Leaf pairs that do not move during
the course of the treatment are not included in the RMS calculations.
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1 2 3

1. Leaf number

2. RMS error for carriage A

3. RMS error for carriage B

Figure 5 Error RMS Data Window

1

2

1. Y-axis represents RMS error

2. X-axis represents leaf number

Figure 6 Error RMS Plot Window

Chapter 3    DynaLog File Viewer Procedures 27



Beam On Plot
■ To view the Beam On Plot, select Beam On Plot from the View menu.

The Beam On Plot window appears.

1

2

1. Y-axis represents beam on
2. X-axis represents time

Figure 7 Beam On Plot

Figure 7 shows the state of the beam during the dynamic treatment as a function of
time. The X-axis represents time; the Y-axis has a 0 or 1 value. A 1 represents the state
in which the beam is on, and 0 represents the state in which the beam is off.

Beam Hold Off Plot
■ To view the Beam Hold Off Plot, select Beam Hold Off Plot from the View menu.

The Beam Hold Off Plot window appears.
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1

2

1. Y-axis represents beam hold-off
2. X-axis represents time

Figure 8 Beam Hold Off Plot for Dynamic Treatment

Figure 8 shows the state of the beam hold-off during the dynamic treatment as a
function of time. The Y-axis can have a value of 0 or 1. A 1 represents the state in
which the beam hold-off is on (X-ray off), and 0 represents the state in which the
beam hold-off is off (X-ray on). The X-axis represents time.

1. Y-axis represents beam hold-off
2. X-axis represents time

Figure 9 Beam Hold Off Plot for LFIMRT
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Figure 9 shows the state of the beam hold-off during the LFIMRT treatment as a
function of time. The Y-axis can have a value of 0 or 2. A 2 represents the state in
which the beam hold-off is on (X-ray off), and 0 represents the state in which the
beam hold-off is off (X-ray on). The X-axis represents time.

Arrange DynaLog File Graphical Formats
When several data tables and plots are open, you can specify which data table or plot
appears in the front by clicking on the window or by using the Window menu.

To bring the data table or plot to the front:
■ Click in the window of the desired DynaLog file information.

or
■ From the Window menu, select the desired DynaLog file information.

The Window menu displays only the open data tables and plots. Data tables and
plots are numbered in the order in which they were opened.

Note: In order to bring a specific data table or plot to the front, the data table or plot must be
active and must appear in the main DynaLog File Viewer window.

Display File Information
To display information about the current data files:
■ Select the File Info option from the View menu.

The File Info data box opens and shows the File Info data.
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Print DynaLog File Reports
To print DynaLog file reports:

1. Select Print Reports from the File menu.
2. In the standard Windows print dialog box, select the desired printer.
3. Click OK.

The Print Reports option prints a single report with file information, plus the data
tables and charts from the windows that are open. This can include:
■ Error Histogram Plot
■ Error Histogram Data
■ Error RMS Plot
■ Error RMS Data
■ Beam On Plot
■ Beam Hold Off Plot

Close DynaLog Files
To close the DynaLog file tables and plots:
■ Click the close button (X) in the upper right corner of the window.
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Obtain DynaLog File Viewer Version Number
To display the DynaLog File Viewer version number:
■ Select About from the Help menu.

Exit DynaLog File Viewer
To exit DynaLog File Viewer:
■ Select Exit from the File menu.
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Chapter 4    Interpret DynaLog Analysis Results

DynaLog File Viewer Analysis of Step-and-Shoot
Treatments

In order to understand the statistical analyses performed by DynaLog File Viewer for
step-and-shoot treatments, it is important to understand some details about how the
leaves are instructed to move throughout the treatment, and how this information is
recorded in the DynaLog files.

Varian dynamic MLC treatments are driven by MLC plan files, also known as dva
files. MLC plan files are the instructions for the positioning of all MLC leaves
throughout the treatment, and consist of a progressive sequence of dose fractions;
associated with each dose fraction is an intended position for each leaf. Step-and-
shoot treatments contain alternating step and shoot segments: the step segment
instructs the leaves to move with no dose increase; the shoot segment instructs the
dose fraction to increase with no leaf movement.

In each 50-ms control cycle, the Clinac reports the current dose fraction along with
the actual position of each leaf. The MLC controller determines if the actual dose
fraction has reached the next dose fraction listed in the MLC plan file. If so, the next
dose fraction, along with a new set of leaf positions, is read from the MLC plan file;
these positions then become the new expected leaf positions. At this transition point,
the leaves are in the leaf positions associated with the former dose fraction—the old
positions—but the MLC controller now expects them to be at the new positions. Often
for the step-and-shoot technique, these position changes are large—on the order of
millimeters or even centimeters—and they exceed the dynamic leaf tolerance. In this
case, a beam hold-off is asserted.

At this instant in time, the following occurs:

■ Leaf position deviations are equal to the distance between the current actual leaf
positions (which were the old expected positions) and the newly calculated
expected leaf positions.

■ Beam hold-off has been asserted.
■ Beam hold-off instruction has not yet been delivered to the Clinac, and so the

beam is still on.

The DynaLog file record for this instance records the following:

■ Beam hold-off = 1 (Yes) or = 2 (during LFIMRT carriage group transitions)
■ Beam on = 1 (Yes)
■ Actual leaf positions equal to the old positions
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■ Expected leaf positions equal to the new positions

Note: Even if the dynamic leaf tolerance is not exceeded, these transition values are still
relatively large.

The DynaLog File Viewer includes all DynaLog file data points with beam on = 1 in
its calculations, so these transition points are always included. As a result at each
transition point, leaf deviation values equal to the intended incremental movement of
the leaf—relatively large values—are included in the statistical calculations.

It is important to understand that during normal operation of the MLC, these
transition-point deviations are always included in the statistical results calculated by
the DynaLog File Viewer.

Relation Between Dynamic Tolerance and RMS Error
DynaLog data depend on the dynamic plan and the treatment setup.

Typically, DynaLog data include the following characteristics:
■ Distinguishable correlation exists between the histogram distribution and the

RMS error values for leaf position deviations. When the RMS error values are
large, the histogram bin counts reflect this fact. For example, more tallies may be
in bin ranges trending toward 1.0 cm. On the other hand, when the RMS error
values are smaller, more tallies may be in bin ranges trending toward 0.0 cm.

Active leaves are those leaves that move during the delivery of the dynamic field.

Note: The number of RMS samples is derived from the summation of bin tallies and the
number of active leaves, according to the following equation:

Number of RMS Samples  =  
Summation of Bin Samples

Number of Active Leaves

■ Smaller dynamic tolerance values result in lower RMS error values, whereas
larger dynamic tolerance values result in higher RMS error values.

■ Smaller dynamic tolerance values result in more frequent beam hold-offs.

Figure 10 on page 35 through Figure 18 on page 40 show results of the Error
Histogram Values, Error RMS Values, and Beam Hold Off Plot windows of DynaLog
files from treatments delivered using various total doses and dose rates.
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Figure 10 shows the Error Histogram Data window. The inset window shows
quantitative leaf histogram data values split into bins, the number of tallies per bin,
and the percentage of occurrences in each bin. The large window displays a graphical
representation of the same data. This IMRT plan was delivered using 180 MU at a
dose rate of 300 MU/min.

Figure 10 Error Histogram Data and Plot at 180 MU and 300 MU/min

Figure 11 shows a plot of leaf RMS error values for the same treatment as used for 
Figure 10.
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Figure 11 Error RMS Values Plot at 180 MU and 300 MU/Min

Figure 12 shows the Beam Hold Off plot for the same treatment. In this case, there
were no beam hold-offs.

Figure 12 Beam Hold Off Plot at 180 MU and 300 MU/Min

Figure 13 shows the same display as shown in Figure 10 on page 35, except that the
treatment represented in Figure 13 was delivered using a dose rate of 600 MU/min
rather than 300 MU/min. The higher dose rate requires the leaves to move faster to
maintain the desired dose versus position prescribed in the MLC plan file. Note the
higher percentage of counts in the 0.005 cm–0.05 cm bin (72.69%) compared to the
same bin shown in Figure 10 (59.31%).
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Figure 13 Error Histogram Data and Plot at 180 MU and 600 MU/Min

Figure 14 shows the plot of leaf RMS error values for the same treatment as used for 
Figure 13. Notice that the general shape of the curve is similar to Figure 11 on
page 36, but the individual peak values have increased compared to the individual
peak values in Figure 11.

Figure 14 Error RMS Values Plot at 180 MU and 600 MU/Min
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Figure 15 shows the Beam Hold Off plot for the treatment delivered using 180 MU at
600 MU/min. This plan results in more beam hold-offs compared to Figure 12 on
page 36, because the beam needed to be paused while the leaves moved into the
positions as prescribed in the MLC plan file.

Figure 15 Beam Hold Off Plot at 180 MU and 600 MU/Min

Figure 16 corresponds to Figure 10 on page 35 except that Figure 16 was generated
with a total dose of 45 MU rather than 180 MU. The lower total dose requires the
leaves to move at a faster speed to maintain the desired dose versus position
prescribed in the MLC plan file. Note the slightly higher percentage of counts in the
0.005 cm–0.05 cm bin (63.35%) compared with the same bin shown in Figure 10
(59.31%).
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Figure 16 Error Histogram Data and Plot at 45 MU and 300 MU/Min

Figure 17 corresponds to Figure 11 on page 36 except that, while the general shape of
the curve remains quite similar to the curve in Figure 11, the individual peak values
have increased from over 0.036 cm in Figure 11 to a little over 0.11 cm in Figure 17.

Figure 17 Error RMS Values Plot at 45 MU and 300 MU/Min
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Figure 18 corresponds to Figure 12 on page 36 and Figure 15 on page 38 except that
the total dose and/or dose rate was reduced. Notice the larger number of beam hold-
offs in this plot compared to the beam hold-offs in Figure 15. This is what is expected
when the treatment conditions are changed so that the time allowed for the leaf
movements is reduced from 0.30 minutes at 600 MU/min and 180 MU total dose to
0.15 minutes at 300 MU/min and 45 MU total dose.

Figure 18 Beam Hold Off Plot at 45 MU and 300 MU/Min
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Appendix A    DynaLog File Contents

File Naming Convention
The MLC controller names the files using the following convention:

CYYYYMMDDHHNNSS_<Patient ID>.dlg
where:

C A or B for the MLC carriage (leaf bank)

YYYY 4-digit year

MM 2-digit month

DD 2-digit day of the month

HH 24-hour clock time stamp

NN minutes time stamp

SS seconds time stamp

<Patient ID> The Patient ID

Note: The Millennium MLC controller automatically names the file when generating new
DynaLog files. The name is based on the patient’s information and time of treatment.
However, the MLC workstation replaces following characters in the DynaLog file name with
an underscore _:
■ < (less than)
■ > (greater than)
■ : (colon)
■ " (double quote)
■ / (forward slash)
■ \ (backslash)
■ | (vertical bar or pipe)
■ ? (question mark)
■ * (asterisk)

File Header
The file header consists of 6 lines with the following meanings:
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Line Format Description

1 B Letter indicating version

2 <Lastname>,<Firstname>,<ID> Patient information, up to 25 characters

3 <PlanUID>,<Beam Number>

or

<Plan filename>

Treat 6.5 or greater

or

Standalonea

4 <long> Tolerance

5 <long> Number of leaves in MLC

6 <long> Clinac Scale

0 = Varian scale

1 = IEC scale (IEC 60601-2-1 only)

Note: The IEC 61217 scale is not
available for DynaLog files.

a. The logic for determining the third line is as follows: If the Field Serial number is zero and
the PlanUID is non-zero, it is assumed to be Treat 6.5 or greater. If both the Field Serial
number and the PlanUID are zero, the filename is used. If the filename is an empty string, a
blank line is written.

File Content
Each line of the DynaLog file contains the following:

Column Format Description

1 <long> Current dose fraction or current gantry rotation

Note: For RapidArc and conformal arc plans, dose fraction information is displayed only if
you remove the # character preceding the diagUseRapidArcDynalogFormat command in
the MLC controller startup script. In all other cases, gantry rotation in tenths of a degree is
displayed if you retain the # character preceding the diagUseRapidArcDynalogFormat com‐
mand.

2 <long> Previous segment number (starting with zero)

3 <long> Beam hold-off state

2 = LFIMRT carriage group transitions

1 = MLC beam hold-off signal asserted

0 = MLC beam hold-off signal not asserted
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Column Format Description

4 <long> Beam on state

1 = Clinac beam is on

0 = beam is off

5 <long> Previous segment dose index or previous segment gantry
angle

6 <long> Next segment dose index or next segment gantry angle

7 <long> Gantry rotation in 10th of a degree

8 <long> Collimator rotation in 10th of a degree

9 <long> Upper Y1 jaw position in mm in the isoplane

10 <long> Upper Y2 jaw position in mm in the isoplane

11 <long> Lower X1 jaw position in mm in the isoplane

12 <long> Lower X2 jaw position in mm in the isoplane

13 <long> Carriage expected position in 100th of a mm

14 <long> Carriage actual position in 100th of a mm

The remaining columns contain the following values for each leaf in the carriage. (nLeaf = 0,
1, 2, and so on)

4*nLeaf + 15 <long> Expected position

4*nLeaf + 16 <long> Actual position

4*nLeaf + 17 <long> Previous field position

4*nLeaf + 18 <long> Next field position

Note:
■ All dose fractions range from 0 to 25000.
■ All gantry and collimator angles are recorded in tenths of degrees, Varian scale.
■ All jaws are recorded in millimeters in the isoplane.
■ All carriage and leaf positions are recorded in hundredths of millimeters, in the leaf

(physical) plane. Zero is at the centerline. Positive means retracted. Negative means
extended across the centerline.
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Appendix B    Compressing DynaLog Files

Compress DynaLog Files
Zip is a file compression utility that reduces a file size. Zip typically compresses
DynaLog files to approximately 10% of their original size. UnZip is the counterpart
to Zip—it decompresses zipped files. Zip and UnZip are public domain programs
from the Info-ZIP Group. Info-ZIP software (Zip, UnZip and related utilities) is
freeware and can be obtained as either source code or executables from the Internet.

This appendix provides instructions on how to use the Zip and UnZip utilities to
compress and restore DynaLog files. For more detailed instructions on the use of
these programs, including descriptions of features that are not described here, refer
to the complete program documentation, included in zip files in the ZipTool
\Distrib directory of the DFV installation CD-ROM.

Note: These procedures apply only for a MARK‐Series MLC controller. Because Millennium
MLC DynaLog files do not need to be transferred to floppy disks or flash drives, this process
does not apply to Millennium MLC controllers.

Install Zip and Unzip
The files Zip.exe and UnZip.exe are located in the ZipTool directory on the DFV
installation CD-ROM.

To install the Zip and Unzip files, perform the following steps:

1. Copy UnZip.exe to C:\ on the computer on which the DynaLog files are to be
analyzed.

2. Copy Zip.exe to C:\ on the MLC controller computer. (If the controller does
not have a CD-ROM drive, transfer this file using a floppy disk or flash drive.)

Zip DynaLog Files
Note: Zipping DynaLog files can only be done when the MARK‐Series MLC controller
computer is not running the MARK‐Series MLC controller software.
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To zip DynaLog files directly to a floppy disk or flash drive on a MARK-Series MLC
controller computer, perform the following steps:

1. If the MARK-Series MLC controller software is running, exit that program by
typing E.

2. Insert the floppy disk or flash drive into the appropriate drive.
3. Change the current directory to the directory containing the desired DynaLog

files to compress.
4. At the DOS prompt, type the zip command using the following syntax:

C:\zip <zipfilename> <file list>
C:\zip a:dlogs dynloga.001
compresses dynloga.001 to a file named dlogs.zip on the A: drive.

C:\zip a:dlog1 dynloga.001 dynlogb.001
compresses dynloga.001 and dynlogb.001 to a file named dlog1.zip on
the A: drive.

The normal DOS wildcard characters apply.

C:\zip dlogall dynlog?.*
compresses all files matching this wildcard template to a file named
dlogall.zip in the current directory. Depending on the number and size of the
original DynaLog files in this example, if dlogall.zip fits onto a floppy disk or
flash drive, it can be copied to the floppy disk or flash drive using one of the
normal DOS commands.

Unzip DynaLog Files
Once the zip files are copied to the destination computer containing UnZip.exe, the
DynaLog files from the zip files can be retrieved. UnZip is a DOS program, so these
steps must be executed in a command prompt window.

To retrieve the DynaLog files from the zip files, perform the following steps:

1. Change the current directory to the directory containing the desired zip files to
decompress.

2. At the DOS prompt, type the unzip command using the following syntax:
C:\unzip <zipfilename>
The .zip extension to the zip file name is optional. UnZip extracts all the files
that had been compressed into the specified zip file, restoring each to the current
directory with its original file name.
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