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             TMS320C5535 eZdsp Quick Start Guide

1.0  SYSTEM REQUIREMENTS

To operate the Spectrum Digital XDS100 JTAG Emulator with your system it needs to meet
the following requirements:

• 2 GB of free hard disk space 
• Microsoft WindowsTM XP/Vista/Win 7
• Min 1 GB ram, 2 GB recommended
• Min 1.5 GHz., dual core recommended
• Color Display
• Internet access
• USB port
• DVD reader

2.0  WHAT’S  INCLUDED

The TMS320C5535 eZdsp kit includes:
• TMS320C5535 eZdspTM

• USB cable
• Micro SD card
• Microphone/Earphone
• TMS320C5535 eZdsp DVD with Code Composer Studio (CCS)
• This Quick Start Guide

C5535 eZdsp DVD Quick Start GuideUSB Cable
Micro SD
   Card

Microphone/
 Earphone
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Audio Demonstration Setup
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3.0  Getting Started

Welcome to the C5000TM C5535 eZdsp Quick Start Guide. The C5535 eZdsp is the
development platform for the C553x family. The goal of the Quick Start Guide is to verify
the operation of your eZdsp kit and guide you through the included demo and installation
of Code Composer Studio. 

To run the included audio demonstration continue with the next section, section 4.

To install the Code Composer Studio from the DVD go to section 5.

4.0  C5535 eZdsp Audio Demonstration

To run the C5535 eZdsp audio demonstration execute the following setup instructions:

1. Insert the micro SD card into the SD card slot (connector J6) on the bottom of the
    C5535 eZdsp board.
2. Plug the included audio headphones/microphone into the C5535 eZdsp board. 
    Make sure to match the “STEREO IN” on the eZdsp board (connector J3) to the figure
    above of the microphone on the headphone/microphone set. Please note the
    microphone plug may be pink in color and have a stamped image of a microphone on
    it to help determine the correct plug. 
3. Also make sure to match the “STEREO OUT” on the eZdsp (connector J4) board to
    the figure above of the headphones on the other headphone/microphone set. Please
    note the headphone plug may be green in color and have a stamped image of a
    headphone on it to help determine the correct plug.
4. Make sure the C5535 eZdsp is NOT plugged into the PC via the J2 connector.
5. Plug the included USB cable (USB Type-A to USB Mini-B) into the C5535 USB
    connector (J1) on the C5535 eZdsp. Then plug the other end of the USB cable into a
    USB port on your PC/laptop.
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6. Put on the headphones. Now you can test out the playback function.
a. Open the media player on your PC/laptop
b. Select a music file located on the provided DVD: 

                   <DVD Drive>\DemoAudio\DemoAudio.mp3
c. Play the music file. Note: Make sure the volume settings on your PC/laptop are
   set for your earphones and the volume is turned up. You should be able to hear
   music through the headphones.
d. You can use the push buttons (SW1, SW2) on the C5535 eZdsp to control the
   volume. Press SW1: volume up. Press SW2: volume down. Press
   SW1 and SW2 together: mute/unmute.

7. Testing the record function
a. Open the Sound Recorder on your PC/laptop.
b. Record your voice by clicking the record button and speaking into the
    microphone. You can playback your voice recording and hear it on the
    headphones.

8. Enjoy your C5535 eZdsp as a USB headset

Demo specific documentation can be found in the DemoAudio directory and at the URL:

     http://processors.wiki.ti.com/index.php/C5000_Connected_Audio_Framework

For more information on how to get started, please visit www.ti.com/c5000audio.

Also please visit www.ti.com/cheapdsp to learn more about the C5535 including
documentation, software training, and more.
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5.0  C5535 eZdsp Code Composer Studio Installation

Note: Install ALL software prior to connecting to the C5535 eZdsp J2 connector !
Note: The user MUST be logged onto windows with “Administrative Rights” and any

anti-virus software must be disabled during installations. Please contact your
system administrator if help is needed in this area.

1. Insert the Code Composer Studio (CCS) v4 DVD into the computer’s DVD drive.
    Launch the install via the “Run” icon on the “Start” button.The setup file name is
         <DVD Drive>\setup_ccs_4.2.4.00033.exe. The user prompts will step the user
    through the rest of the CCS installation. This installation may take several minutes.
    The installation will place a CCS icon on your desktop.
2. At this time plug the C5535 eZdsp J2 connector into a USB port (directly or via
    a USB extension cable) on your laptop or PC. Windows will recognize the new
    hardware connection and complete the hardware installation automatically.
3. Launch CCS v4 from the shortcut icon on the desktop.
4. A prompt will appear asking for a workspace location. Each time CCS starts up the
    main workspace is the main working folder for CCS. The default location will be 
    (on Windows XP) “C:\Documents and Settings\<user name>\My
    Documents\workspace”. To have CCS automatically default to the specified
    workspace location, select the “Use this as the default and do not ask again” option.
5. Create a user license. After launching CCS, the user may be prompted to create a
    user license to activate the CCS software. Select the “Activate a License” option. Then
    click “Use Free Limited License”. This will re-direct you to the Texas Instruments
    website to complete the License creation process. Alternatively, the “Activate a
    License” step may be bypassed temporarily and completed at a later date by clicking
    “Evaluate Code Composer Studio for 30 days”.
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6.0  CCS Configuration Instructions

1. Launch CCS v4 from the shortcut on the desktop. (This was created when CCS v4
    was installed).
2. The CCS v4 window will appear. Click the “Target” menu, then select “New Target
    Configuration File”.
3. The “New Target Configuration” window will appear. Enter a file name that describes
    the emulator connection and/or Texas Instruments device being used and click
    “Finish”. For example: “C5535_eZdsp”.
4. The “Basic” configuration setup window will open in the CCS v4. Select “Texas
    Instruments XDS100v2 USB Emulator” from the “Connection” menu. Type “5535” in
    the “Device” field and select “eZdsp5535”, from the list.

License Screen
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5. Click the “Save” button to save the configuration.
6. Click the “View” menu and select “Target Configurations” to expose the
    configuration(s) that have been built or imported. A new tab labeled “Target
    Configurations” will become available in the CCS window.
7. Expand the “User Defined” folder. Right-click on the new configuration that has been
    created and click “Launch Selected Configuration”.
8. Click “View->Debug” then click “Target->Connect Target”. CCS will attempt to connect
    to the C5535 eZdsp and run the GEL file. Once the connection is successful and the
    GEL file has finished, the console window will print a message stating
    “Target Connection Complete”.

Configuration Screen
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7.0  Running the C5535 eZdsp LED Blink Demonstration

1.   The C5535 eZdsp must be connected in CCS before proceeding. If the board is not
      connected, please refer to section 4.0 of this guide.
2.   Click “File->Import”.
3.   When the new window appears, expand “CCS” and select “Existing CCS/CCE
      Eclipse Project”. Click “Next”.
4.   Select “Select Root Directory” and click the “Browse” button. Browse to directory
      path “<Install_Dir>\ccsv4\emulation\boards\ezdsp5535_v1\tests\led”. 
      The default <Install_Dir> is “C:\Program Files\Texas Instruments”
5.   Highlight the “LED” folder and click “OK”. Then click “finish”
6.   Click “View->C/C++Projects”. A new tab will appear in the CCS v4 window and there
      should be a LED project visible.
7.   Click “Project->Build Active Project”.
8.   When the build is complete, a message will print in the Console Window.
9.   Click “Target->Debug Active Project”
10. Click “Target->Run”. The C5535 eZdsp LEDs should now blink.

8.0  SUPPORT RESOURCES

1. For additional information regarding the TMS320C5535 family of DSPs please refer
    to the following page on the TI web site:

                  http://tiexpressdsp.com/index.php/C5000
2. If you have problems or need additional information regarding the embedded
    emulation please refer to the XDS100 USB wiki on the TI web site. The URL for this
    site is:              http://tiexpressdsp.com/index.php?title=XDS100
3. Code Composer Studio support is available via a forum at:
                           http://community.ti.com/forums/138.aspx
4. More information about other Spectrum Digital emulators can be found at: 
                                        www.spectrumdigital.com
5. Additional development support is available via the online community: 
                                        www.ti.com/ezdsp5000
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                                     EVALUATION BOARD/KIT IMPORTANT NOTICE

Spectrum Digital, Inc. (SDI) provides the enclosed product(s) under the following conditions:

This evaluation board/kit is intended for use for ENGINEERING DEVELOPMENT,
DEMONSTRATION, OR EVALUATION PURPOSES ONLY and is not considered by SDI to be a
finished end-product fit for general consumer use. Persons handling the product(s) must have
electronics training and observe good engineering practice standards. As such, the goods being
provided are not intended to be complete in terms of required design-, marketing-, and/or
manufacturing-related protective considerations, including product safety and environmental
measures typically found in end products that incorporate such semiconductor components or
circuit boards. This evaluation board/kit does not fall within the scope of the European Union
directives regarding electromagnetic compatibility, restricted substances (RoHS), recycling
(WEEE), FCC, CE or UL, and therefore may not meet the technical requirements of these 
directives or other related directives.

Should this evaluation board/kit not meet the specifications indicated in the User’s Guide, the
board/kit may be returned within 30 days from the date of delivery for a full refund. THE
FOREGOING WARRANTY IS THE EXCLUSIVE WARRANTY MADE BY SELLER TO BUYER
AND IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESSED, IMPLIED, OR STATUTORY,
INCLUDING ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR
PURPOSE.

The user assumes all responsibility and liability for proper and safe handling of the goods.
Further, the user indemnifies SDI from all claims arising from the handling or use of the goods.
Due to the open construction of the product, it is the user’s responsibility to take any and all
appropriate precautions with regard to electrostatic discharge.

EXCEPT TO THE EXTENT OF THE INDEMNITY SET FORTH ABOVE, NEITHER PARTY
SHALL BE LIABLE TO THE OTHER FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES.

SDI currently deals with a variety of customers for products, and therefore our arrangement with
the user is not exclusive.



                                                                                514586-0001A

SDI assumes no liability for applications assistance, customer product design, software
performance, or infringement of patents or services described herein.

Please read the User’s Guide and, specifically, the Warnings and Restrictions notice in the
User’s Guide prior to handling the product. This notice contains important safety information
about temperatures and voltages. For additional information on SDI’s environmental and/or
safety programs, please contact the SDI application engineer or visit www.spectrumdigital.com. 

No license is granted under any patent right or other intellectual property right of SDI covering or
relating to any machine, process, or combination in which such SDI products or services might be 
or are used.

Mailing Address: Spectrum Digital, Inc.
P.O. Box 1559
Sugar Land, TX. 77487-1559

“eZdsp” is a trademark of Spectrum Digital, Inc.

FCC Warning

This evaluation board/kit is intended for use for ENGINEERING DEVELOPMENT,
DEMONSTRATION, OR EVALUATION PURPOSES ONLY and is not considered by SDI to be a
finished end-product fit for general consumer use. It generates, uses, and can radiate radio
frequency energy and has not been tested for compliance with the limits of computing devices
pursuant to part 15 of FCC rules, which are designed to provide reasonable protection against
radio frequency interference. Operation of this equipment in other environments may cause
interference with radio communications, in which case the user at his own expense will be
required to take whatever measures may be required to correct this interference.
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