
The Ecometrica Mapping Platform admin tool allows you 

to easily build cloud-based web-mapping applications.  

 

Each application can be set up in a number of different 

ways, depending on how you want your community of 

users to interact with the data. 

 

This user guide provides detailed instructions for 

managing general application settings, uploading 

different data types and setting up query results 

extracted from your spatial data using ready-to-use 

widgets including bar charts, tables and time-series 

graphs.  

 

The appendices included give important additional 

information, such as how to format vector and raster 

data for upload to the platform. 
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1. PLATFORM ADMINISTRATION OVERVIEW 
 

The Administrative interface of the Ecometrica Mapping platform can be accessed by certain 

users to create and manage applications. You can access the Admin by adding /admin to the 

end of any application URL and logging in or by selecting ‘Admin’ from the drop-down menu in 

the top right corner of the application interface. If you working within an EO Lab and are setting 

up the first application for your EO Lab, you can log into the admin using 

‘admin.{yourEOlabname}.ourecosystem.com/admin’.  

 
The Admin Dashboard displays the name of the application you are logged into and includes 
links to the settings for this site and the Admin User Manual. 
 

Global Settings 

 
The options under ‘Global settings’ can be used to create, edit and manage all applications and 
their content on the EO Lab. 

 

❖ Applications and Users displays a list of all applications currently on the platform. General 
settings for all applications can be managed and adjusted, and new users can be added 
here. 

 

❖ Global Areas lists all the areas of interest drawn or uploaded to your EO Lab. 

 

Application Areas are grouped into Application Area Groups – these areas are assigned to 

individual applications and are visible to all users of that application.  

 

User Areas are linked to individual user accounts and can be viewed and queried by that user on 

any application they have access to. User areas are listed in ‘My Areas’ under ‘Area Groups’ on 

the map interface when a user is logged in. 

 

❖ System can be used to check that the ‘Workers’ (which allow uploads) are online, and that 

the tiling servers used to create display layers are configured correctly. ‘Tasks’ can be used to 

check the status of both shapefile and GeoTIFF uploads to the platform. 

Application Admin 

 
The options under ‘Application Admin’ can be used to upload new datasets, display layers and 
areas of interest to the application you are logged into. Application Admin is also used to create 
new queries and results.  
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❖ Areas lists the Application Area Groups and Application Areas for the application you are 

logged into. New Application Area Groups can be created here, and Application Areas can be 

uploaded as shapefiles and CSV into those groups.  

 

❖ Datasets and Display Layers lists both Dataset Groups and Display Groups on the 
application you are logged into. New Datasets and Display Layers can be uploaded into 
these groups as GeoTIFFs.  

 

Datasets are 1-band GeoTIFFs which contain the spatial values your users can extract 
information from, for example average carbon or land-use types. The results and graphs 
are generated for an area of interest from these layers. 

 
Layer legends, that specify the colours and names for classified category raster datasets 
for charts in the results, are also created here.  

 
Display Layers, the coloured maps of spatial data that can be viewed under ‘Display 
Groups’, are uploaded separately to datasets. 3-band RGB GeoTIFFs in WGS 1984 Web 
Mercator Auxiliary Sphere (EPSG 3857) are used to create display layers, which are then 
tiled to allow for zooming in online. 

 

a) Queries and Reports allows you to set up Tabs, Questions and Widgets to create the query 

results for the application you are logged into. 

 

2.  SETTING UP A NEW APPLICATION 
  

This section describes the workflow for setting up a new mapping application: 
 

 

 
Basic work flow for creating a new application 

 
To create a new application, Select 'Applications and Users' > ‘Add application’ 
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Using the listed ‘Application Options’ tabs, you can create your application settings and select 
from existing datasets to include: 
 
 
Domain 
 

 

a) Enter a domain name relevant to the purpose of your app and your data – this is the url 

used to access the application and should not include upper-case letters or spaces.  

All applications within your EO Lab should have the extension ‘.{yourEOlabname 

}.ourecosystem.com’ for example ‘forestry.{ yourEOlabname}.ourecosystem.com’. 

 

b) Enter a display name - this will be the application title, displayed in the browser tab on the 
map interface. This name will also appear in downloaded PDF reports from the application. 
Both the domain and display name can be changed at any stage; however, be cautious about 
changing the domain name of an app that is used by others.  
 

c) You can enter additional URLs to redirect to your application using the 'Add another Alias' 
option 

 

Layers 

 
Under 'Layers' you can select existing Dataset Groups and Display Layers to be used on your 
application. If none exist, you can create new datasets and layers under 'Application Admin' at a 
later stage. 
 

a) Select the existing Dataset Groups to include in your new application: 
 

• Dataset Groups are groups of raster GeoTIFF files that cover a similar extent and 
theme, for example 'Global NDVI Resolution 17' 

• Datasets are individual raster files uploaded as GeoTIFFs into Dataset Groups.  

• Datasets are used to generate your query results and charts on the results page 
 
b) Any associated Display Layers will automatically be moved to your application as soon as 

you move a Dataset Group across. However, you will still need to create ‘Display Groups’ to 
make these visible on the map interface. 
 

Application Settings 

 
a) Under ‘Application Settings’ you can choose whether the site is to be publicly available by 

ticking the ‘Is public’ box. No log in is required for public applications, and visitors to the 
application will be taken directly to the map interface. Do not check the ‘Is public’ if the site 
access should be secure and only available to invited users with login details. 
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b) Deselecting the ‘Custom Polygon Drawing’ option means that users cannot draw personal 

areas on the interface. This option is selected as default so that all users can draw and query 
polygons on the interface. 

 
c) When selected, the ‘Show warnings for small areas’ will display a warning message in the 

query results for very small areas that have been created manually. This is to warn users that 
they have created an area smaller than the pixel size of the dataset, and results may 
therefore be inaccurate.  

 
d) Check the ‘Cache site areas’ if you would like the caching for the display of the areas on your 

app to start immediately when the app is opened. This means you may have to wait before 
you can view your areas when you first open the app, but when an Area Group is turned on 
(after the caching is complete) the areas will display right away - rather than spending time 
loading at this stage. Checking this option is recommended if you have a lot of areas on your 
app, or if your area boundaries are quite complex. 

 
e) Check the ‘Allow users to self-register as viewers’ box if you want to allow visitors to the 

application to register for a user account with Viewer permissions. If this option is enabled, 
any visitors to the application will be directed to the log in screen and will have the option to 
create a new account. 

 
 

 
 
 
 
 
 
 
 
 
f) Using the ‘Default Map Style’ drop-down menu, you can select the map style which will 

automatically display as the base map for the application interface. 
 
g) In the ‘Introduction’ text box, type the text you would like included in the introduction 

window that appears when first loading the application. This can be added in plain text, or 
in html if you click the ‘Source’ button in the top left corner of the text box. If left blank, no 
introduction window will appear on loading. If a logo is added (see section ‘n’) it will show in 
this introduction section along with your text. 

 
h) In the ‘Description’ box, add the text that you want to appear in the ‘About’ section in the 

drop-down menu in the top right corner of the interface. This can be written in plain text or 
in html using the ‘Source’ option. If a logo is added (see section ‘l’) it will show in this 
‘About’ section as well. 
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i) Under ‘Invite message’ you can add additional text that will be inserted in the invitation 

email.  
 

j) Check the ‘Invite Application Description’ box if you would like the text from the 
‘Description’ box added to your invitation email. 

 
k) Choose the colour for displaying areas of interest on the map interface using the ‘Polygon 

outline colour’ picker tool, as well as the transparency of the polygons: 

 
 

 
 
 
 
 
 
 
 
 
 

l) Adjust the opacity/transparency of the fill for your areas of interest by changing the 
‘Polygon Opacity’. Set a value between 0 (completely transparent) and 1 (completely 
opaque).  

 
m) Under ‘Logo’, you can upload a PNG or JPEG file of an organisation or company logo.  The 

logo will be displayed in the introduction/about section. Note that there must also be text in 
the introduction box (see section ‘h’) for the introduction window to appear on the front 
end. 

 
n) The ‘Bounding Box’ is the extent of the map seen when you first load the application. Enter 

coordinates here in degrees or use the “Allow saving default bonds” in the App Preferences 
on the interface to set up the Bounding Box for your app. 
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Users 

 
a) Under ‘Users’ you can directly add new or existing users to this application. Users can also 

be invited by an Application Administrator or Administrator directly from the map interface 
using the ‘Invitation' icon in the drop-down menu. Applications with ‘Self-Register Viewers’ 
enabled allow users to register themselves through the login page. 

 
 

Superusers, Application Administrators and Administrators can define the access 

level for each person invited to the application: 

 

❖  Viewers are able to draw, save and query their own areas of interest, as well as 

query site areas and view map layers 

 

❖  Collaborators, in addition to Viewer permissions, can edit all area descriptions 

directly from the interface. 

 

❖  Administrators can do all of the above and also invite, block and set permissions for 

other users to the application. 

 

❖ Application Administrators have the same capabilities as an Administrator, but they 

are also able to log into the admin to create new applications. They are only able to 

view and edit applications that they have 'application administrator' status for. 

Application administrators are able to upload data and create queries, but they can 

only delete data that they have created and can only view queries on their 

applications.  

 

❖ Superusers have overall control of the application, or, if working within an EO Lab, 

Superusers have overall control of all the applications and users on that EO Lab. They 

are able to add, edit or remove any layer, area file or query that is available on the 

application or EO Lab, and can access the list of users across all the applications on 

the EO Lab. Superuser permission can only be given by another superuser. 

 

Navigation Links 

 

Additional ‘Navigation Links’ can be added as link icons in the drop-down menu in the top 
right corner. These can include text and attachments such as documents, or can be links that 
open directly to another URL by selecting the ‘Link’ option. Navigation links are essentially 
customisable menu items that you can add to the drop-down menu on the interface. 
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3.  ADDING NEW DATASETS, DISPLAY LAYERS AND 

AREAS TO YOUR APPLICATION 
 

Dataset Groups 

 
Raster datasets must be uploaded to a Dataset Group. Dataset Groups can be used to organise 
your raster datasets according to certain themes or extents. If a suitable Dataset Group already 
exists, you can upload your raster dataset to an existing Dataset Group, or you can create a new 
Dataset Group. 
 
To create a new Dataset Group, go to ‘Data and Display Layers’ > ‘Dataset Groups ‘> ‘Add 
Dataset Group’ 
 
a) Add in a name for your Dataset group (this can be in Camel Case with or without spaces)  
b) Select ‘Is Public’, which means it is available for use 
c) Choose the site(s) it should be available on. You can select more than one by holding 

‘Control’ when selecting. 
d) Save your changes 

A Dataset Group should not become too full, as it may take longer to upload new data layers or 
affect query times.  

Datasets 

 
Datasets are 1-band Geotiffs which contain the spatial values used in your query results, charts 
and graphs, for example average carbon or land-use types. Raster datasets can be uploaded in 
any projection; however, equal-area projections are required if you are planning to query your 
raster data, and the pixels must be square. The default projection for the platform is GCS WGS 



10 

 

1984 (EPSG 4326). All datasets used within one result set should be uploaded in the same 
projection and resolution for accurate query results. 
 

Datasets should be uploaded as Geotiffs and should be signed or unsigned 16-bit or 32-bit float 
- avoid 2-bit, 4-bit and 8-bit data as they are not always read properly by gdal. No 
accompanying .tfw files that contain projection information are required for the upload. 

See detailed instructions on how to prepare a raster dataset for upload to the platform in Ap-
pendix 1 of this manual as there are several important attributes to check to ensure the files 
upload and are read correctly: 

• Make sure you know what the NoData value in your file is (such as -9999) and that there 
is only ONE value that indicates NoData 

• Avoid using ArcGIS’s default value for floating point. You can use the Export > Raster to 
different format option in ArcCatalog (for batch setting of nodata values for floating 
points, see the FAQ & troubleshooting document). 

• Avoid using 0 (zero) as a NoData value for quantitative data layers because zero is likely 
to represent a valid pixel value 

• Check that the file extents are appropriate for your projection – for example, if your 
raster is in GCS WGS 1984 (EPSG 4326) the maximum extent of the file can only be -90 to 
90 degrees latitude and -180 to 180 longitude.  

• Compress larger .tif files to speed up uploads and save database space 

A ‘Worker’ must be online to upload raster datasets. You can check if a worker is online under 
‘System’> ‘Workers’. If they are all offline you will need to contact the support team before 
uploading. The progress of your upload can be checked under ‘System’>’Tasks’. When the 
upload indicates ‘success’, the file has successfully uploaded. 

Once the raster dataset is in the correct format, you can upload the file to a cloud service, such 
as Dropbox (make sure you use the direct download URL link). Do not zip the file, make the URL 
public and copy the URL. You can also upload your dataset directly from your desktop using the 
“Desktop File Import” button. 
 
New Datasets can be uploaded under ‘Data and Display Layers’ > ‘Datasets ‘> ‘Add Dataset’ 
 
a) Add in a Layer name for your dataset  - this MUST be less than 50 characters long, be in 

small case letters and without spaces, for example ‘carbon_brazil_2020_gcs‘.  
This name cannot be changed later. 

b) Select the Dataset Group to upload your file to. 
c) ‘Data Timestamp’ is only needed for timeseries uploads and can be left as the default (9999-

12-31 23:59:59.999999 if no date is associated with this dataset or for single file uploads). 
a) A description can be added for the dataset– this is optional and will not be displayed on the 

interface. 
d) The ‘Dataset Type’ should be set to ‘Qualitative’ for rasters with classes/ categories or 

‘Quantitative’ for quantitative data. 
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e) For datasets in GCS WGS 1984 (EPSG 4326) choose the resolution level (between 1 and 28) 
for the dataset. 

• The platform resamples raster datasets in GCS WGS 1984 to a grid with up to 28 
resolutions, see Table 1 on the following page for the exact pixel size for each 
resolution level. 

• For datasets in GCS WGS 1984 you will need to select the resolution level from the 
dropdown menu. For any other projection, the native pixel size will be read from the 
file and any resolutions set in the dropdown menu will be overridden.  

f) Choose the Resampling method to resample your raster dataset. ‘Nearest neighbour’ is used 
as the default for both quantitative and qualitative data. 

g) A ‘Legend’ will need to be added for qualitative raster datasets with categories but can be 
created later 

h) ‘Is Public’ should be enabled so that the dataset is accessible for use 
i) To upload your file, enter the URL in the ‘Import file URL’ field, or use the Desktop File 

Import option. 
j) To upload a dataset that is not projected in GCS WGS 1984 (EPSG 4326), check the ‘Keep 

native projection’ box. Checking this box will override the ‘resolution’ value and the pixel 
size will be read from the file.  
 

 
 
k) A description of the file and upload details such as the resampling method can be added in 

the ‘Comment’ field. 
l) A ‘NoData value’ can be included for the file or the field can be left blanked if the NoData 

value has been set within the file already 
m) Under ‘Import (Advanced)’: 

• ‘Warp to Grid’ should be selected so that the raster dataset is resampled to match 
the platform grid.  

• ‘Build Overviews’ is only needed for cross-querying layers with different resolutions 
and can be left disabled  

• Raster band should be set as 1, as only single band rasters should be uploaded as 
datasets 

n) Date and attributes can be added to individual dataset adding a key for 'date' and 

'display_name. 'date' defines the order that the raster datasets are plotted for time series 

results, and should be in the format MM/DD/YYYY (i.e. 1st of May 2017 would be 

05/01/2017). The key 'display_name' is the name that will be displayed on the interface as 

table headings or data points on a graph, for example 'May 2010' or 'NDVI 2010'. 
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• For time series and table widgets, any datasets included in a time series or table 
must have name and date 'attributes' added so that they can be plotted in the 
correct order on the interface. 

 

 
*Please note if you include a ‘display_name’ or display_date’ attribute it will display on your bar 

charts and tables for quantitative layers 

 

o) Click ‘Save’ to upload your file 
 

When selecting a resolution for a raster dataset in GCS WGS 1984 (EPSG 4326), choose the 
closest platform resolution level that is finer than that dataset. For example, for data with a 
resolution of 1km x 1km, set the dataset to resolution 16 (see Table 1). The data will be 
resampled to 611.5m at the equator. 
 
Choose the resolution level closest to the original data, as the maximum size for a user-drawn 
query is 1 million pixels - so the finer the data resolution, the smaller user-drawn areas must be.   
 
For example, for datasets with a resolution of 250m, the data is resampled to 152.8m. User 
drawn polygons will run for areas up to 2 334 784 ha (152.8m x 152.8m x 1 000 000 pixels). For 
data with 1km resolution, the data is resampled to 611.5 - user drawn areas will run for 
polygons up to 37 380 996 ha. 
 
The resolution information above can be ignored for rasters that are in their native projection 
(rasters that have not been projected into GCS WGS 1984). The pixel size for these native 
projections, is read from the file. Once your native projection dataset has been uploaded, the 
pixel size will be returned in the metadata for your dataset. The corresponding platform 
resolution will also be returned, but no resampling will have taken place and this value can be 
ignored. This value may, however, be useful for determining the max zoom level for any 
associated display layers (see page 15-16). 
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Table 1: Ecometrica Mapping Platform Resolution Table 

Resolution 
Level 

Cell size at the 
equator (m) 

Cell size (Arc Seconds) 
[div by 3600 to get 

degrees] 

Cell size (Degrees) 
[mul by 3600 to get 

arc seconds] 

Max Zoom Level 
(for Display 

Layers) 

1 20037581 648000 180.0 6 

2 10018790 324000 90.0 6 

3 5009395 162000 45.0 6 

4 2504698 81000 22.5 6 

5 1252349 40500 11.25 6 

6 626174.4 20250 5.625 6 

7 313087.2 10125 2.8125 6 

8 156543.6 5062.5 1.40625 6 

9 78271.8 2531.25 0.703125 6 

10 39135.9 1265.625 0.351563 6 

11 19567.95 632.8125 0.175781 6 

12 9783.975 316.4063 0.087891 6 

13 4891.987 158.2031 0.043945 6 

14 2445.994 79.10156 0.021973 10 

15 1222.997 39.55078 0.010986 10 

16 611.4984 19.77539 0.005493 12 

17 305.7492 9.887695 0.002747 13 

18 152.8746 4.943848 0.001373 14 

19 76.4373 2.471924 0.000687 14 

20 38.21865 1.235962 0.000343 15 

21 19.10933 0.617981 0.000172 16 

22 9.554663 0.30899 0.000086 17 

23 4.777331 0.154495 0.000043 17 

24 2.388666 0.077248 0.000021 17 

25 1.194333 0.038624 0.000011 18 

26 0.597166 0.019312 0.000005 18 

27 0.298583 0.009656 0.000003 18 

28 0.149292 0.004828 0.000001 18 
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You can check the status of your dataset upload under 'System' > 'Tasks'. Below are the more 
common reasons why uploads fail: 

• File extent larger than -90 to 90 degrees latitude and -180 to 180 longitude for 
datasets in GCS WGS 1984 (EPSG 4326). 

• If no tasks are listed at all, make sure at least one 'Worker' is online under 'System' 
 
The ‘Dataset Upload History’ at the bottom of the each dataset page shows the time and date 
of the upload as well as the file name and any details entered into the comment field when 
uploaded. This can be used to check the correct file and version is used within the query results. 
 

Display Groups 

 
Display layers are the coloured maps of spatial data that can be viewed under ‘Display Groups’ 
on the interface.  Existing display layers that were selected when creating the application under 
‘Application Options’ > ‘Layers’ can be added to the map interface by creating a Display Layer 
Group and choosing the display layers to add to the group from the drop-down menu.  
 
New Display Layer Groups can be created under ‘Data and Display Layers’ > ‘Display Groups ‘> 
‘Add Display group’ 
 
a) Add a name for your Display Group  
b) Select the application the display layers will be enabled for. 
c) From the drop-down lists, select the existing display layers to add to the group  
d) Save your changes 

 

Layer Legends 

 
Layer legends are needed to specify the colours and text to display in tables, pie charts, bar 
charts and time series graphs for classified category layers (qualitative datasets).  
 

 

 
a) Click ‘Layer Legends’ under ‘Data and Display Layers’ and ‘Add layer legend’. 
b) Create a name for the legend. 
c) You can upload a legend colour file (ArcGIS .clr file or QGIS .txt – see the next page for more 

information on these supported file formats) or you can enter legend information manually. 
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If you are uploading legend colours from a file, all information previously saved in the 
legend will be overwritten. If you need to make changes to ‘Uploaded legend colours’ (aside 
from changes to the Index or Label), you can either: 

• edit the original legend colour file and reupload 

• create a new legend colour file and upload it to the mapping platform 

• delete unwanted entries in the ‘Uploaded legend colours’ table and create new ones 
in the ‘Manually selected colours’ table 

‘Manually selected colours’ can be added and edited at any time using hex colour code or 
the colour picker tool. If you are using hex colour code to manually select colours and your 
colours do not change or display as expected, make sure you are entering a valid hex colour 
code. Because black (#000000) is a place holder value for blank legend entries, it cannot be 
saved as a ‘Manually selected colour’ – however, near black colours (like #000001) can be 
saved instead. 
 

 
 
d) The ‘index’ value specifies the order in which legend items occur in widgets. When 

uploading a legend from a file, index values will be automatically assigned. When entering 
legend colours manually, simply order them 1, 2, 3, 4 etc. – keeping in mind that index 
values must be unique across ‘Uploaded legend colours’ and ‘Manually selected colours’. 

e) The ‘value’ is the pixel value in the raster dataset which the colour represents. 
f) The ‘label’ is a description of the pixel value or class. The text will be displayed in tables for 

each category/class, and when using 'label_length' in the pie chart widget. In order to save 
your legend layer, a label must be provided for each legend entry. 

 

Layer legend graphics for qualitative datasets are automatically generated from the legend 
layer. The Dataset type (in the dataset layer metadata) must be set to Qualitative for a legend 
graphic to be generated automatically. These graphics are displayed in the bottom-left of the 
platform interface when a display layer is selected and the legend button is pressed: 
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For layers that contain many different legend entries, legend colour files can be uploaded to the 
Ecometrica mapping platform as either a ArcGIS .clr file or a QGIS .txt file.  
 

Legend Colour 
File Format 

Creation Instructions  Generated Fields 

ArcGIS .clr file 
(space separated) 

Once the symbology is set for your 
display raster:  
Click on the Symbology tab in the 
layer’s Properties, select Unique 
Values, click the Colormap button 
and click Export a Colormap. 

value red green blue 
 

 

QGIS .txt file 
(comma 
separated) 

Once the symbology is set for your 
display raster:  
Click on the Style tab in the layer’s 
Properties and click on the save icon 
(‘Export color map to file’). Labels, if 
included, will also be stored in the 
resulting .txt file. 

value, red, green, blue, 
alpha*, label* 
 
*these values are not required 
by the platform, but will 
automatically upload if 
included in the file 
 
 
 
 

 

 
For quantitative layers, a legend is not needed for query results. However, if desired, a legend 
graphic (.PNG) can be uploaded to the platform using the “Image path” option. The Dataset 
Type (in the dataset layer metadata) must be set to the quantitative for a .PNG legend graphic 
to display on the interface. For the best results, upload an image with a transparent background 
colour and white text. For details on how to create a legend graphic to be displayed with a 
quantitative display layer, see the section on How to create a layer legend graphics/images 
under Appendix 1. 
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You can clone an existing legend using the “Save as New” option. Change the name of the 
legend you would like to clone, and click “Save as New” to copy all the legend colours and 
entries that were saved in the original legend, as well as the attached legend image if present. 
 

 
 
You can then edit your newly cloned legend by adding/deleting entries in the “Manually 
selected colours” section. 

Display Layers  

 
Display layers are separate from the data layers that are used in queries and have to be created 
separately as 3-band RGB GeoTiffs. Display layers are uploaded in the WGS 1984 Web Mercator 
Auxiliary Sphere: EPSG 3857 projection and can be uploaded in their original resolution without 
needing to be resampled, although it is preferable to create a display layer with approximately 
the same resolution as the data layer it represents. 
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Not all data layers have to be displayed on the map interface. Those that you want to display on 
the map interface should be uploaded separately and are tiled to allow for zooming in online.  

You can use the Data > Export Data > Use Renderer > Force RGB tool in ArcGIS to convert a 1-
band classified raster to a 3-band RGB file. In QGIS, use the Raster > Conversions > PCT to RGB 
tool. Areas that should be transparent on the display layer should be set to one colour- usually 
magenta (RGB 255,0,255) is used as transparent.  

Upload the 3-band .tif file to a cloud service, such as Dropbox (make sure you use the direct 
download link). Do not zip the file, make the URL public and copy the URL. You can also upload 
your display layer directly from your desktop using the Desktop File Import button. 
 
See details instructions on how to prepare a display layer for upload to the platform in Appendix 
1 of this manual. 
 
New display layers can be uploaded under ‘Data and Display Layers’ > ‘Display layers ‘> ‘Add 
Display layers’ 
 
a) Add the name for the display layer – this will be the name displayed on the interface and 

can be in Camel Case with spaces. 
b) Select ‘Active’ is enable the display layer to be used. 
c) Select ‘MBTilesD’ as the tile server. 
d) Projection for all display layers should be set to ‘EPSG 3857 aka Web Mercator’. 
e) A description can be added for your display layer – this will be displayed on the interface, 

when pressing the ‘Info’ button at the bottom of the screen. 
f) Select the dataset the display layer is linked to. A dataset can only be attached to one 

display layer.  
g) Under ‘Import file URL’ paste the URL for your display layer, or use the Desktop File Import 

option. 
h) Leave the transparent colour as 255, 0, 255 that has been saved as the background colour in 

your raster or change it to the NoData colour in your file. 
i) Choose the max zoom level for your display layer. See Table 2 below for the max zoom level 

to choose depending on the resolution of your data.  
j) Click ‘Save and continue’ to upload your file. 

 
As display layers must be tiled at each zoom level to enable zooming in and out on the interface, 
display layers may take a few hours to create once uploaded depending on the size of the file.  
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Table 2: Choosing the Max Zoom Level in the display layer import section 

Resolution 
Level 

Cell size at the 
equator (m) 

Cell size (Arc Seconds) 
[div by 3600 to get 

degrees] 

Cell size (Degrees) 
[mul by 3600 to get 

arc seconds] 

Max Zoom Level 
(for Display 

Layers) 

1 20037581 648000 180.0 6 

2 10018790 324000 90.0 6 

3 5009395 162000 45.0 6 

4 2504698 81000 22.5 6 

5 1252349 40500 11.25 6 

6 626174.4 20250 5.625 6 

7 313087.2 10125 2.8125 6 

8 156543.6 5062.5 1.40625 6 

9 78271.8 2531.25 0.703125 6 

10 39135.9 1265.625 0.351563 6 

11 19567.95 632.8125 0.175781 6 

12 9783.975 316.4063 0.087891 6 

13 4891.987 158.2031 0.043945 6 

14 2445.994 79.10156 0.021973 10 

15 1222.997 39.55078 0.010986 10 

16 611.4984 19.77539 0.005493 12 

17 305.7492 9.887695 0.002747 13 

18 152.8746 4.943848 0.001373 14 

19 76.4373 2.471924 0.000687 14 

20 38.21865 1.235962 0.000343 15 

21 19.10933 0.617981 0.000172 16 

22 9.554663 0.30899 0.000086 17 

23 4.777331 0.154495 0.000043 17 

24 2.388666 0.077248 0.000021 17 

25 1.194333 0.038624 0.000011 18 

26 0.597166 0.019312 0.000005 18 

27 0.298583 0.009656 0.000003 18 

28 0.149292 0.004828 0.000001 18 
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Selecting the correct zoom level for your display layer is important as it sets the number of 
times the user can zoom in before the pixels look blurry. The following screenshots show 
zoomed in pixels with lower and higher max zoom levels set on upload. The max zoom level on 
the left has not been set high enough and the pixels become blurry as you zoom in, while the 
image on the right shows a display layer with the max zoom level set high enough for the pixel 
resolution of the dataset. 
 

 
 

Display Series 

 
Multiple display layers can be added to a Display Series to be presented as a time series on the 
interface. Upload your display layers following the steps described in the previous section. New 
Display Series can be created under ‘Application Admin’ > ‘Display Series’ > ‘Add display series’. 

 

a) Add the name for the display series – this will be the name shown on the interface and can 
include upper-case letters and spaces. 

b) Select the order the display series will be presented on the interface (i.e. the position of the 
display series within the ‘Display Groups’ drop-down menu). 

c) Add some description for the series. This will be displayed on the interface when the display 
series is switched on. 

d) A legend for the display series can be added either by selecting an already existing legend 
from the drop-down menu, or by creating a new legend using the “Add another layer 
legend” option (see the Layer Legends section page 14 for more details on legends) 

e) Select the display layers to be included in the display series using the drop-down menu. The 
Layer order section sets the order display layers will appear in the time series. 

f) Press Save and Continue 
 
Display Series are also displayed in the Display Groups page (‘Application Admin’ > ‘Display 
Groups’) and have a green mark to specify they are time series. They are displayed in the same 
menu as single display layers in the interface, and their order within this menu can be changed 
along with adding/deleting display layers from the time series, by clicking on the display series 
name and editing the related section. Alternatively, they can be edited directly in the Display 
Series section. 
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Application Areas and Groups   

 
Areas of Interest can be polygons drawn by users on the map interface or uploaded as 

shapefiles of points, polygons and multipolygons. Points can also be imported from CSV files 

which must include latitude and longitude columns. Shapefiles should be compressed (all files 

zipped together) and uploaded in GCS WGS 1984 (EPSG 4326) into an Application Area Group, 

even if your raster datasets are in another projection. The platform will reproject your areas of 

interest on the fly when querying a dataset that was uploaded in an equal-area projection.   

 

Shapefiles should be polygons, without any gaps or silvers. Ensure that polygons are 2D 

(without M or Z values). The area names and descriptions can be imported directly from the 

shapefile attribute table if it has fields called ‘name’ and ‘descriptio’. (Note that you should use 

‘description’ without the ‘n’ because ArcGIS cannot handle such long field names).  

 

For detailed instructions on how to prepare a shapefile for upload to the platform see Appendix 
1 of this manual. It is very important to simplify your areas, as polygons with many vertices 
will slow down query results and displaying them on the map interface. 
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Once the shapefile is in the correct format, compress all the parts of the shapefile into a zipped 
file and upload the file to a cloud service, such as Dropbox. Make the URL public and copy the 
URL. 
 
If using DropBox, make sure you use the direct link URL by replacing the 'www.dropbox.com' in 
the file URL with 'dl.dropboxusercontent.com'.  
 
So https://www.dropbox.com/s/jlqfyh74i03wzsy/ANP_Estatales_Chp_wgs1984.zip?dl=0     
 
becomes  
 
https://dl.dropboxusercontent.com/s/jlqfyh74i03wzsy/ANP_Estatales_Chp_wgs1984.zip?dl=0 
 
Shapefiles must be uploaded into an Application Area Group or User Area Group. 
 
A new Application Area Group can be created under ‘Areas’ > ‘Application Area Groups ‘> ‘Add 
Application Area Group’ 
 

 

b) Add a name for your Application Area Group – this will appear on the interface as the 
heading for a group of areas and can be changed later.  Note that this heading will not be 
displayed on the interface until a shapefile has been uploaded to it.   

 
 
 
 
 
 
c) Select the application the Application Area Group will be enabled for. 
d) Choose the order that the group will be displayed in relation to other area groups. Groups 

with the same order value will be ordered alphabetically. 
e) Add a description to your group – this is optional and will not be displayed on the interface.  
f) When you save your area group, an ‘Import areas from file’ field will be displayed. Click 

‘Show’ to display all the options for uploading a shapefile or CSV. 
 

 

 

 

 

 

 

 

 

 

 

 

http://www.dropbox.com/
http://dl.dropboxusercontent.com/
https://www.dropbox.com/s/jlqfyh74i03wzsy/ANP_Estatales_Chp_wgs1984.zip?dl=0
https://dl.dropboxusercontent.com/s/jlqfyh74i03wzsy/ANP_Estatales_Chp_wgs1984.zip?dl=0
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g) If you select Zipped shapefile from the import file type, you can paste the URL for your 
shapefile into the ‘File URL’ field, or import your shapefile locally. 
 
 
 
 
 
 
 
 
 
 

 
h) If you select CSV file from the import file type, you can paste the URL for your CSV file or up-

load it locally. 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
If only latitude and longitude columns are included in the CSV files, then the rows will be up-
loaded as Points. If a column “area” is included, the rows will be imported as polygons of ap-
proximatively the given area. Areas must be specified in ha. Alternatively, you can specify either 
a radius or an area for each point in the CSV file under the CSV Import Options. If you specify a 
radius or an area in this section, then this will overwrite the area column in the CSV file. Finally 
you can choose to tick the ‘Ignore errors’ option. If ticked, the rows in the CSV file with missing 
or incorrectly formatted coordinates/areas will be ignored and the valid rows will be uploaded. 
The File Import History (at the bottom of the Application Area Group page) will contain a record 
of the rows that did not upload and an explanation of the errors found. If you leave the ‘Ignore 
errors’ unchecked, then the CSV import will fail if it contains rows with missing or incorrectly 
formatted columns. 
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i) Select ‘import attribute features if you want the attribute table details labelled under ‘name’ 
and description’ imported as well. Both the area names and area descriptions can be 
changed by clicking into the area under ‘Areas’.  

j) Indicate whether the group is to be publicly available (which makes the areas visible on the 
interface) by ticking the ‘public’ box. Specify the layer number (0..n-1) to import from the 
shapefile. This is normally the first layer (0).  

k) Once you have clicked save, you should be able to view the individual polygons as areas on 
the interface as well as under ‘Areas’ in the admin under ‘Application Areas’. You can check 
the status of the upload at ‘System’ > ‘Tasks’ to make sure the file uploaded correctly.  

 
Note that there might be several pages of areas, and you can view them page by page or use 
the search options above the list of areas. Area attributes, descriptions and geometry can be 
viewed when you click into an area under ‘Application Area’. The ‘geometry’ field will show the 
polygon vertices uploaded from the shapefile.  
 

 
 
User Areas, which are attached to a user account rather than an application can be uploaded 
into ‘User Area Groups’ using the same process. User Area Group can be created under ‘Global 
Settings’ > ‘User Area Groups’ > ‘Add User Area Group’ 
 

Duplicating Areas and Area Groups 

 
You can make a copy an individual Application Area or a whole Application Area Group in order 
to use them on a different application. 
 
Use the dropdown menu next to ‘Choose Action:’ below the search fields and select ‘Clone se-
lected area group’ or ‘Clone selected area’: 
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When you click ‘Go’, a clone of the group or area will be created with the "Copy of” in front of 
the original name. The cloned application group or area will be assigned to the same application 
as the original group or area. An option will be available to edit the cloned application group or 
area once cloned, or you can locate it using the search options. 
 
To move the cloned area or group to another application, go into the 'Global Areas' menu. Find 

your 'Copy of' application area or group using the search option. Click into it and select the 

application you would like to move the areas to using the drop-down next to ‘Application’. You 

can then rename the area or group of areas as required. 

 

4. SETTING UP QUERY RESULTS 
 

The area results extract information from your raster datasets and can be used to answer 
specific questions, such as how land use has changed over time or what is the total biomass 
within an area. Note that raster datasets that are not in an equal-area projection may return 
unexpected results, and if you are planning on combining several raster layers in a query, the 
raster layers should be in the same projection and resolution. 
 
To set up queries and operations to run on drawn or pre-defined polygons for any of your 
uploaded datasets, ‘Tabs’ ‘Questions’ and ‘Question Widgets’ need to be created.  
 
‘Tabs’ are the main headings for each query result, for example ‘Total Biomass’, ‘Land Cover 
Type’ or ‘Vegetation Type’ or ‘Average NDVI’. 
 
‘Questions’ are the types of operations to be run on each layer. For example, to get the average 
biomass and error for a group of carbon layers, you would create a slug (name) for the question 
e.g. get_avg_agb_bgb_c_error and specify which layers the operation will be carried out on. 
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Under ‘Questions’, you will need to create a Query (or use an existing one). Queries are the 
coded operations written in python-like script e.g. to sum, average or group values for each 
pixel included in the drawn or uploaded polygons.  
 
‘Widgets’ are then created to define how the question results are displayed, for example as a 
title, numeral (total), pie chart, table or bar chart. Finally, ‘Question columns’ are created to 
define the unit to include with each result, for example t,  tC, t/ha or m. 
 

Create Tabs 
 

Tabs are the headings the question results are groups under. Note that each tab will use a 
different ‘query’, with its one question, code and widgets: 

 
 
 

 
 
 
 
 
To create a new Tab, select ‘Queries and Reports’ > ‘Tabs’ > ‘Add Tab’ 
 

a) Select the application for the tab you are creating 
b) Name the tab as the heading you would like displayed on the interface, and then add the 

'Order' (1 or 2 or 3 etc) that you want this tab to appear in the results in relation to other 
tabs  

c) When the checkbox labelled ‘Public’ is unticked, the corresponding tab in the interface will 
only show for superusers (“Staff Only” will be indicated in brackets). When you tick the 
checkbox, the result will start appearing for all users. It is best to leave this box unticked 
until the complete result has been finalised and tested. When you make a new tab, or a 
copy of a tab, it will default to being visible by superusers only. 

 

Create Questions 
 

Questions can be duplicated or cloned within an application or across different applications 
from existing questions. 
 
In the list of Questions in admin; select the question you want to duplicate and in the drop-
down menu just above the list of questions, choose the action called ‘Make Question Clone’.  
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Click the ‘Go’ button, and a copy of the selected question (including the tab, layers, widgets and 
widget parameters) will be created. The cloned question will be named 'Copy of ' the original 
question and it will be added to bottom of the results page. The duplicated question is 
automatically not ‘public’, so only superusers can see these results. Once you have finished 
modifying it, you can tick the ‘Make public’ option under its tab.  
 
To move the copied question to another site, you can click into the new tab and select the 
application to move it to. It will then no longer be visible from the original site, and the page in 
the admin will return a 404 page-not-found error. You can click back to return to the previous 
page. 
 

To create a completely new question, select ‘Queries and Reports’ > ‘Questions’ > ‘Add Ques-
tion’ 
 
a)   Enter a name (‘slug’) without spaces, for example ‘get_avg_ndvi_anomalies’ 
b) Select the ‘Tab’ the question result will display under. 
c) ‘Code’ is the query language code of calculations to be run on the dataset. Simple codes can 

be copied and pasted from other queries. See the separate guide on the query language 
structure and writing queries under the ‘Help’ section of the admin.  
 

d) Select the ‘Spreadsheet export columns’ – these are the results you want include in the 
downloadable excel spreadsheet. When no columns are specified, all the columns in the 
query code will be included.  
 

 
 
For time series results, if you would like the date included next to each result in the 
spreadsheet then you should add ‘layer’ both in the 'Spreadsheet export column' as a 
‘Question Column’: 
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e) Select the format of the downloadable spreadsheet: 
➢ If the question contains totals widgets, select 'List Total Widgets'.  
➢ If the question contains table widgets, select 'Tables as shown in Interface'.  
➢ If the question does not contain total or table widgets, for example if for a time-series 

graph, (or they don’t need to be included in the download): 

• At “Spreadsheet format”, select “Raw Data Export Spreadsheet” or 

• At “Spreadsheet export columns”, add a comma-separated list of the columns 
you want to export, in the order you want them to appear (e.g. category, area, 
average, total, coverage). 

* If you want to leave out a Totals Tab in a worksheet, select the “Raw Data Export 
Spreadsheet” format and leave the “Spreadsheet export columns” blank. 

f) Select the ‘layer’ or ‘layers’ that the query should run on. The ‘layer’ is the dataset on which 
the query will be executed. For example, your ‘query’ could be grouping the sum of carbon 
stocks by a risk category (so that the result will show how much carbon stock is under 
different risk categories), but the layer on which you execute this is not the ‘risk’ dataset, 
but the ‘carbon’ layer. 

g) Next the ‘widgets’ and ‘question columns’ need to be created. Save your question before 
you create widgets so that the widget can be linked to your new question. 

 

Question columns 
 

‘Question columns’ are used to define the column headings and units for the values within pie 
charts, tables, columns, etc. For example, if ‘average_carbon’ is specified in the query code, the 
units for average carbon should be included in the ‘question columns’: 
 

a) Click on ‘add question column’ 

b) Enter the ‘key’ which identifies the value from the query  
c) Enter the ‘value’ which labels the results for this column, for example on the y-axis for charts  

and as headings for tables. 
d) The units are optional and will be added behind individual values  
 
For example, if the query includes ‘average_carbon’ this will be used as the ‘key, while the units 
and display name would be included as: 
 

Key: total_carbon  Value: Total Carbon Stock 2001 to 2011  Unit: tC 
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The chart would then be displayed as: 
 

 
 
 

Create Widgets 
 

Widgets are the type of format your results will be displayed in - for example titles, bar charts, 
pie charts, graphs or tables. Certain parameters need to be filled in for widgets and these 
depend on the annotations that were defined in the queries. This is best explained using an 
example as described below.  

  

a) Click on ‘Create New Widget’ - this will redirect you to the ‘Question Widgets’ page 
b) Select the ‘question’ that the widget will be used for  
c) Choose the type of output (a full list of widget types is included below this section) 
d) Select the order the widget should display in relation to other widgets 
e) Choose a title for the widget, for example ‘Vegetation Type’. This can also be left blank. 
f) Select the ‘width of widget’ - this specifies the width the widget will be displayed on the 

results page. For example, widgets can be displayed over the full page width, or two table 
category widgets can be displayed together using the ‘half’ width option, for example to 
compare results for different years or sensors: 
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. 

 

g) Choose the widget parameters under ‘Question widget parameters’. Depending on the type 
of widget selected, a number of different parameter options and explanations for each will 
be shown above the question widget parameters fields: 
 

 
 

These parameters should be included under question widget parameters, for example: 
 

• 'size', which is 'small' or 'large', which pretty much just determines the height. 
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• 'column', which column to show data from (output value is query ie “true_average”) 

• ‘default_colour’, which specifies the graph/chart colour in hexadecimals 
 

*Note for time series and table widgets, any datasets included in a time series or table 
must have name and date 'attributes' added so that they can be plotted in the correct 
order on the interface. 
 
Date attributes can be added to individual dataset by clicking each and adding a key for 

'date' and 'display_name. 'Date' defines the order that the raster datasets are plotted, 

should be in the format 1/5/2010 (1st of May 2010). 'display_name’ is the name that will be 

displayed on the interface as table headings or data points on a graph, for example 'May 

2010' or 'NDVI 2010'. 

 

 
 

These attributes can also be added when uploading the dataset. 

 

Query and Widget Examples 

 
A catalogue of different query types available and examples of how they display on the interface 

can be viewed using the demonstration applications available on your EO Lab such as 'country-

demo.{yourEOlabname}.ourecosystem.com'. 

 

Example of query codes to use for different query types can also be found in the ‘Query 

Language Guide’ in the Help section of the admin interface. 

 

These queries can be cloned, moved to other applications and modified to use with different 

datasets and widget parameters.  
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This section shows examples of the different queries and widget types available on the 

platform, and the question and widgets parameters required for each of them.  

 

1. Title Widgets display a large title for result in bold text: 

 

 

 

Question widget parameters can be used to format the text style for titles, such as 'small-title 
bold', 'green-text'. 

 

The full list of available parameters with explanations for each widget type is displayed above 

the 'Question Widget Parameters' field once you have selected your widget type. 

 

2. Notes/Text Widgets can also be used to display information or explanation below or above 

results for a query: 

 

 
 

The text should be included in html with 'text' used as the question widget column 'key' field 

shown below: 
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Below are examples html text formats to use to add images or links to text widgets: 
 
<img src="http://dl.dropboxusercontent.com/Drought/precsoigraph.PNG"> 
 
Example of adding links to points, text widgets or descriptions: 
 
<b>This graph shows precipitation & Southern Oscillation Index (SOI) values over the whole of 
the Murray-Darling Basin between 2001 and 2011. <br/> Precipitation in the MDB is not 
distributed evenly, the highest rainfall is often in the southeast and lowest in the west area. 
Please refer to the full report on Drought in the Murray-Darling Basin under the Science page 
links. Meteorological data were sourced from the <a href="http://www.bom.gov.au" 
target="_blank">Bureau of Meteorology of Australia</a>, which provides daily and monthly 
data for precipitation and temperature.<b> 
 
 

3. Break widgets are used to start subsequent widgets on a new line, and can be used if a 

previous widget fills half the page, but the next is still wanted on a new line 

 

4. Total Widgets display a numerical value within a border, and can be used to display any 

mathematical result derived from your raster dataset (for example sum, average, minimum 

or maximum). 

 

 
 

http://dl.dropboxusercontent.com/Drought/precsoigraph.PNG
http://www.bom.gov.au/
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For this query, 'AGB_total' and AGB_avg' (above ground biomass) are the 'columns' - the values 

to be calculated from the raster datasets). These columns are defined within the query code, in 

this case to sum or average the values of all the pixels that fall within the queried polygon. 

These values are then multiplied by 0.5 to calculate the carbon stock and density: 
 

 
 

The layers for the query to run on are the Saatchi & Baccini Pantropical carbon maps: 

 
 

Four total widgets were created to display these values in bounding boxes: 
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The Question columns specify what the columns should be called on the interface and what unit 

to use for each: 

 

 
 
The question widget parameters define which 'column' (value from dataset) it should display 

(average or total), which layer it should get the result from and that a globe and leaf icon should 

be displayed with the result: 

 

 
 

The full list of available icons for total widgets can be found here. 

 

5. Pie & Bar Chart widgets can be used to display categories within a qualitative dataset, or to 

compare results from multiple datasets.  

 

To classify a qualitative dataset, a 'Layer Legend ' must be set up and saved so that the 

correct colours and names will be used for the different classes: 

 

https://admin.ourecosystem.com/s/fonts/photon/index.html
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6. Layer + Category Bar Chart widgets show multiple qualitative layers classified by categories 

so that they can be compared to each over (for example for different time periods). The bar 

charts can also be 'stacked' by values or as a percentage by including the 'stacking' 

parameters for the widgets: 
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7. Time Series widgets can be used to display results for a series of quantitative dataset over 

time as graphs or bar charts, such as NDVI values or land cover changes over time. 

 
Multiple dataset series can be plotted in a graph. There are also a number of question 

widget parameter keys to customise a time series chart: 

 

• 'negative_colour' allows you to specify a different colour for negative values within a 

time series 

• 'secondary' adds a second axis if you want to show two columns  

• 'error_column' and 'error_layers' lets you add uncertainties as error bars for your 

time series values  

 

To create the above graph, all the datasets should be added to the question using the drop-

down selector. The below parameters should be included for the question widget parameters 

for a time series widget, including a comma-separated list of the datasets, which 'column' (or 

value from the data) you are plotting and a colour for negative values:  
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To plot multiple time series datasets on one graph, you should list each series as 'layers', 

'layers_1', 'layers_2' etc in the question widget parameters. Corresponding error or uncertainty 

layers to create error bars can be added as 'error_layers', 'error_layers_1', 'error_layers_2' 

 

Error bars can also be calculated using another value or 'column' from the primary dataset, such 

as standard deviation using the keys 'error_column', 'error_ column _1', 'error_ column _2' 

 

Each dataset will be plotted in a different colour automatically, but you can specify the colours 

as well using ' default_colour', 'default_colour_1'. A legend for time series datasets can be 

added, and the displayed name for each series should be specified using 'layers_name', 

'layers_1_name', ' layers_2_name' 
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8. Category Table widgets classifies qualitative data in classes with a table, for example land 

cover classes or forest loss per year. Similar to the pie and bar charts, a layer legend must be 

created to define the colours and names for each category: 

 

 
 

Category layers can also be cross-queried with quantitative layers. For example, the 

below query shows the amount of carbon according to Saatchi et al’s 2011 pantropical carbon 

map in each land cover type using the ESA CCI land cover 2010 dataset: 
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For category table queries, the 'classification' layer can be specified within the query code. The 

quantitative datasets/s to be grouped within these classes is included as a 'requested_layer', 

and the operation will run on every layer listed in the query. Note that when cross-querying 

layers, all datasets must be in the same projection and resolution. 

 

9. Category Pairing Table widgets can be used if you have multiple qualitative/classified 

datasets that you want to display in one table: 

 

 
 

Specify the value you want to compare between the datasets as the 'column' for example 'area'. 

Use the 'layer_pairs' parameter to tell the platform to either classify each qualitative map by 

itself: 

 

layer_pairs                    (qual_2001, qual_2001),(qual_2002, qual_2002) 

 

Or to cross-query each with a quantitative dataset of the same projection and resolution, for 

example a carbon map when you want to show how carbon values have changed between 2 

landcover maps: 

 

layer_pairs                    (quant _2001, qual_2001),( quant _2002, qual_2002)           or 

layer_pairs                    (quant_2001, qual_2001),( quant_2001, qual_2002) 
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10. Multiple Layers widgets can be used to organise results and values from multiple 

quantitative datasets of the same projection and resolution into a table: 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

For a series of related datasets, use a similar naming structure when you upload them, for 

example: 

 

ndvi_modis_201401, ndvi_modis_201404, ndvi_modis_201406, ndvi_modis_201408 
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Use the 'column_pattern' parameter to tell the platform which series of layers.columns to use, 

for example: 

ndvi_modis_(partial).layer,  

ndvi_modis_(partial).true_average,  

ndvi_modis_(partial).minimum,  

ndvi_modis_(partial).maximum 

 

Each column (ie. true_average, minimum) is placed in a new column in the table. 

In the series of datasets, '(partial)' is use like a wild card so you don't have to list each layer - 

'partial_columns' is used to list the part of the dataset name replaced in the order you want 

them listed: 

201401, 201404, 201406, 201408 

 

'table_titles' is used for each column heading and should be in the order you would like them 

displayed: 

Year, Average, Minimum, Maximum 
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APPENDIX 1: Instructions for preprocessing & correct 

formats for data uploads 
 

SHAPEFILES 
 

Areas of interest are uploaded as shapefiles (.shp) 

 

1. Make sure it contains the .prj projection file and that it is the “EPSG:4326” projection 

(i.e. GCS_WGS_1984). The file name should indicate the projection and contents (ie 

ghana_GCS.shp).  

 

2. Ensure the polygons do not contain any gaps or overlap (slivers) between or within pol-

ygons. Sometimes gaps/overlaps can be difficult to identify as they occur on the bound-

ary between 2 polygons - creating a topology within a feature dataset can help to re-

move gaps and slivers; alternatively, the Editor tools can be used to manually correct 

topology errors. 

 

3. Make sure the shapefile is 2D (without M or Z values). This can be checked under the 

shapefile properties and will be shown under ‘Coordinates have Z values: No/Yes’. M or 

Z values can be removed by using the copy features tool to create a new shapefile: 

a. Select the output shapefile  

b. Click the Environments button at the bottom of the tool dialog box. 

c. Expand the General Settings. 

d. For the parameter, Output has Z Values, change the value to Disabled. 

e. For the parameter, Output has M Values, change the value to Disabled. 

f. Click OK in the Environments dialog box. 

g. Click OK to execute the geoprocessing tool. 

 

4. Check how many vertices are in your polygons - processing speed on the platform in-

creases if you “simplify” polygon shapefiles.  

a. Experiment to find the minimum amount of vertices that still accurately repre-

sent the shape of your polygons. For example, it is quite possible to simplify a 

polygon with 6000 vertices to 2000 vertices without losing important infor-

mation.  

(This is very easy to do in QGIS: Vector>Geometry tools>Simplify Geometries - be 

careful not to ruin the topology of your polygons though by creating small gaps 

and silvers) 
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5. If you include a column in the attribute table of the shapefile called “name”, this will au-

tomatically become the AOI name when uploaded. This text can be edited for each AOI 

after upload, but for shapefiles with many polygons adding a name field can save a lot 

time. You can also add additional text, upload images, tables or links for each AOI once 

uploaded. 

6. If you include a column in the attribute table of the shapefile called “description” (the 

shapefile character limitation in ArcGIS will only let you create a “descriptio”, this still 

works), this will automatically become the AOI description on the interface (also edita-

ble after upload): 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Finally, all of the shapefile parts (.shp; .prj; .shx; .sbn; .sbx etc) should be sent to a single 

compressed folder using zip software (Winzip/Peazip/7zip).  The compressed folder can 

then be uploaded to a shared Dropbox account, emailed (depending on the size) or 

transferred via a file transfer service such as WeTransfer. 

How to simplify a polygon vector layer if it has too many vertices 

 
In QGIS: 

1. Open vector file in QGIS 
2. In the menu on top, click Vector -> Geometry Tools -> Simplify Geometry 
3. Choose an appropriate tolerance (high values = fewer vertices). 
4. Run and test your file 

 
In QGIS, simplifying polygons can sometimes cause small gaps or extra tiny polygons between 
existing polygons. Make sure to use a tolerance that doesn't ruin the topology of your shapefile.  
 
ArcGIS has a 'topology edit tool' that is the easiest way to simplify polygons without causing 
topology errors: 
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1. Start editing  
2. under 'More editing tools, make sure 'Topology' is selected in the topology toolbar 
3. Select 'Topology Edit tool'  
4. Select the polygons to simplify  
5. Use 'Generalise edge to simplify without creating gaps between polygons - you'll need 

to  select a tolerance based on the units your polygon is in.  
 

                

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

RASTERS 

 

1. Raster datasets can be uploaded in any projection; however, to ensure that your results 

are accurate, equal-area projections and square pixels are strongly recommended. The 

default projection for the platform is GCS WGS 1984 (EPSG 4326). 

2. Make sure your raster file is saved in either 16 bit integer or 32 bit float format 

○ If a time series of rasters is used, make sure all are either integer or floating 

point as the Ecometrica Mapping Platform cuts off the last 2 decimals 

3. Make sure that you have assigned only 1 value as the NoData value. 

○ It is best to use something easy such as -9999 rather than using ArcGIS’s default 

value which can be quite complicated. Avoid using 0 (zero) as the NoData value 
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because zero is likely to represent a valid pixel value. 

4. Ensure that the raster layer has only one field of information. 

○ Delete raster attribute table or count field if needed 

5. Check that the file extents are appropriate for your projection – for example, for rasters 

projected in GCS WGS 1984 (EPSG 4326) the maximum extent of the file can only be -90 

to 90 degrees latitude and -180 to 180 longitude. 

6. The file format should be Geotiff (we will only upload the .tif file, so make sure there are 

no accompanying .tfw files that contain projection information). 

○ You can test whether the .tif file will work on its own (without associated files) 

by saving only the .tiff file in a separate folder and opening it in a newly opened 

GIS project. Check that the coordinates make sense when the file is opened. 

7. Ensure the raster layer is in the required resolution - if you are planning on combining 

several raster layers in a query, then the raster layers should be in the same projection 

and resolution. 

○ The platform handles 28 resolution levels as set out in the Ecometrica Mapping 

Platform resolutions Table 1 on the following page. For datasets in GCS WGS 

1984 (EPSG 4326) you will need to select the resolution level (between 1 and 28) 

for the dataset.  For datasets in any other projection, the following information 

can be ignored as the resolution will be automatically read from the file and no 

resampling will occur. 

○ Raster data is uploaded to the closest resolution level that has smaller pixels 

than the original data. Nearest neighbour or average is normally used as the 

resampling method when uploading data, however cubic convolution and biline-

ar resampling methods can also be used. 

○ You can now upload the file to Dropbox or any other cloud storage service. Make 

sure the web URL for your file is publicly accessible. Upload the raster under Ras-

ter Layers > Add Raster Layer > Import file URL  

○ Do not ZIP the geotiff before you upload it to the cloud service. 
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Table 1: Ecometrica Mapping Platform Resolution Table 

Resolution 
Level 

Cell size at the 
equator (m) 

Cell size (Arc Seconds) 
[div by 3600 to get 

degrees] 

Cell size (Degrees) 
[mul by 3600 to get 

arc seconds] 

Max Zoom Level 
(for Display 

Layers) 

1 20037581 648000 180.0 6 

2 10018790 324000 90.0 6 

3 5009395 162000 45.0 6 

4 2504698 81000 22.5 6 

5 1252349 40500 11.25 6 

6 626174.4 20250 5.625 6 

7 313087.2 10125 2.8125 6 

8 156543.6 5062.5 1.40625 6 

9 78271.8 2531.25 0.703125 6 

10 39135.9 1265.625 0.351563 6 

11 19567.95 632.8125 0.175781 6 

12 9783.975 316.4063 0.087891 6 

13 4891.987 158.2031 0.043945 6 

14 2445.994 79.10156 0.021973 10 

15 1222.997 39.55078 0.010986 10 

16 611.4984 19.77539 0.005493 12 

17 305.7492 9.887695 0.002747 13 

18 152.8746 4.943848 0.001373 14 

19 76.4373 2.471924 0.000687 14 

20 38.21865 1.235962 0.000343 15 

21 19.10933 0.617981 0.000172 16 

22 9.554663 0.30899 0.000086 17 

23 4.777331 0.154495 0.000043 17 

24 2.388666 0.077248 0.000021 17 

25 1.194333 0.038624 0.000011 18 

26 0.597166 0.019312 0.000005 18 

27 0.298583 0.009656 0.000003 18 

28 0.149292 0.004828 0.000001 18 
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DISPLAY LAYERS 

 
Maps to be displayed on the map interface visually need to be created as 3-band RGB rasters 

should be in EPSG:3857 -- WGS84 Web Mercator (Auxiliary Sphere) projection. The steps below 

describe how to create a “display layer” for the platform in ArcGIS and then in QGIS: 

 

1. Resample the raster layer to the appropriate resolution if needed 

○ The resolution should preferably be the same or at least closely resemble the up-

loaded data layer. 

 

2. Make sure the layer is re-projected to EPSG:3857 -- WGS84 Web Mercator (Auxiliary 

Sphere) 

 

3. Convert 1-band classified rasters to RGBs: 

○ Open the file in ArcGIS. 

○ Set the symbology to the display colours/categories. 

○ Set the ‘Display noData as’ to 255,0,255. (Magenta 255,0,255 was chosen as the 

colour to set as transparent for nodata as few classifications use it, however if 

the colour is included in the file, it should be set to the next closest colour ie. 

255,1,255). 

 

4. You can export a layer file (.lyr) if the display colours are likely to be used again. 

 

5. Under the table of contents, right-click the layer > Data > Export Data 

 

6. Select Use Renderer > Force RGB  to convert a 1-band raster to an RGB image. Make 

sure to leave the nodata value blank if the nodata class was changed to a class value. 

LZW compression may also be necessary as the exported 3-band rasters are usually very 

large. 
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7. Check the output colours. 

○ Note that ArcGIS always automatically applies a histogram & gamma stretch. 

Make sure to remove the stretching under the ‘Symbology’ tab. The unstretched 

file is how it will look on the map interface. 

○ Double-check that the background of the RGB correctly displays 255,0,255. 

 

8. You will need to run the ‘Calculate Statistics’ tool in ArcCatalog or under the ‘Da-

ta management’ toolbox for the RGB layer so that gdal can read the file when uploading 

to the mapping platform. Make sure you calculate the statistics within the same session. 

 

In QGIS: 

1. Make sure the layer is re-projected to EPSG:3857 -- WGS84 Web Mercator (Aux-

iliary Sphere) 

 

2. In the 'Style' tab under 'Layer properties', select 'Render Type' as 'Single Pseudo-

color'. Set the colour for each of your raster values, or classify quantitative rasters using 

the colour ramp drop-down: 
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o In QGIS, if your nodata value is set correctly in your file as NoData, it will au-

tomatically be transparent (even if you add it as a separate value in your col-

our scheme). 

o If you convert to an RGB with nodata set as transparent without a colour as-

signed to the value, your nodata values will come out as a black frame in 

your RGB.  

o To view or change the colour of your nodata values, make sure to assign the 

nodata value a colour in your style settings (preferably 255, 0, 255). Go into 

the 'Transparency' tab under 'Layer Properties' and uncheck the 'No data 

value' field: 

 
 

3. To convert your coloured map into a 3-band RGB .tif, right-click on the layer and 

select 'Save As' 
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o Select 'Rendered Image', make sure the project is '3857- Pseudo Mercator', 

choose a location and name, and then click 'OK'. 

o Most recent versions of QGIS will create an additional transparency band 

when converting to a rendered image - so in QGIS you will have created a 4-

band RGBA instead of a 3-band RGB. 

 

4. To remove the 4th band you can use the Raster > Conversion > Translate tool: 

 

 
 

o In the gdal code area, click the edit button and use the below script to extract 

bands 1, 2 & 3 and apply LZW compression:  

 

 gdal_translate -co COMPRESS=LZW -of GTiff -b 1 -b 2 -b 3 input.tif output.tif  
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o If you don't remove the 4th band created when using QGIS, you will get the 

below upload failure message (shown under 'System' > 'Tasks') on the plat-

form: 

Result: CannotImportDisplayException(ValueError('Dataset 

/home/oe/tmp/tmpuAxJk2.tif is not a RGB image. /home/oe/tmp/tmpuAxJk2.tif',),) 

 

 

 
 

Note: When using ArcGIS, if the statistics for the display layer are not calculated (in the same 

map session), the layer incorrectly displays as a black or white frame on the platform. While this 

is usually only an issue with ArcGIS, you can calculate the statistics for the display layer in QGIS 

using the following steps: 

o Right-click on the layer and select ‘Properties’. Next, click on ‘Style’, expand the 

‘Load min/max values’ menu, select the ‘Min/Max’ button, change the accuracy to 

‘Actual (slower)’ and press ‘Load.  

o When you look in the ‘Metadata’ tab, under ‘Properties’ it should now show 

statistics for Band 1, 2 and 3. 
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DISPLAY LAYER LEGEND GRAPHICS 

 
Layer legend graphics for qualitative datasets are automatically generated from the legend lay-

er (see the Legend section of this manual). Map layer legends are displayed in the top-left cor-

ner of the interface when a display layer is selected: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

However, you can manually upload legend graphics for quantitative datasets.  

 

1. Legend graphics should have a maximum width of 4.3cm and height of approximately 

0.3cm (or approximately 400 pixels x 130 pixels). Smaller legends tend to display better 

on the web interface. The text above or below the colour ramps can be added separate-

ly using a program such as Microsoft Word or PowerPoint, or OpenOffice Impress. 

 

2.  For the best results, the background colour should be transparent. 

 

3. The graphics can be created by copying a legend in ArcGIS or QGIS and saving it as a 

.PNG to keep the background transparent. 
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In ArcGIS:  

• Go to the ‘Layout View’. Insert a legend and adjust the labels, colours or stretch as 

required.  

• Select the legend by clicking on it, right-click and copy it. Paste the legend in a word 

or presentation document (like Microsoft Office PowerPoint).  

• Crop, rotate or re-shape your legend graphic as needed. You can add text labels as a 

text box as well (white text works best).  

• Select your legend graphic (and text box if you have made one) and right-click to se-

lect ‘Save as Picture’. Save as a .PNG file. 

 

 

 

In QGIS: 

• Go to Project > New Print Composer. Under Layout, select Add Shape > Add Rectan-

gle and draw a rectangle. Adjust the height and width to a maximum of 35 x 10 mm 

under the Item Properties tab/panel. Smaller legends tend to display better on the 

platform.  

• Set the page itself to 100% transparency. This is done through the Composition 

tab/panel under Page Settings > Page Background. (Panels can be changed under 

View > Panels.) 

• Change the Style in the Item Properties tab/panel by switching the Symbol Layer 

Type to Gradient Fill. Select Color ramp and choose the colour ramp that was ap-
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plied to your display. 

 

        

 

 

 

 

 

 

 

 

 

 

• Under the Item Properties tab/panel edit the Rotation so that the rectangle lies hori-

zontally. 

• Add labels by selecting Layout > Add label. Change the colour of the text to white 

and adjust font size as needed. 

• Under Composer > Export as Image, and crop or re-size as needed in an image edit-

ing or word document. Right-click the image and select Save as Picture to save your 

legend graphic as a .PNG file. 
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APPENDIX 2: Testing Platform Results 
 
The steps below describe how to extract raster values for polygon areas using ArcGIS and QGIS 
in order to compare results generated from offline GIS software with the mapping platform re-
sults and ensure that datasets have been properly uploaded. Because of the way ArcGIS’ Zonal 
Statistics tool works, querying a raster with complex polygon shapes in ArcGIS may produce re-
sults that differ from platform results – the following steps aim to explain these differences, and 
provide a method for accurately comparing results across mapping tools. 
 
In ArcGIS: 

1. Load your raster dataset and area file, ensuring that they are in same projection. 

2. Run ‘Zonal Statistics as Table’ tool. 

• This tool applies a vector-to-raster conversion internally in order to extract 

results from a raster dataset: http://pro.arcgis.com/en/pro-app/tool-

reference/spatial-analyst/zonal-statistics.htm   

• ArcGIS statistics produced using this method are therefore representative of 

a rasterized version of your polygon area files; to replicate ArcGIS results on 

the Ecometrica Mapping Platform, rasterized polygons can be uploaded. 

 

3. Rasterize your polygons. 

• In order to compare results produced by ArcGIS and your online results, ras-

terized versions of your area files will need to be uploaded to the platform. 

http://pro.arcgis.com/en/pro-app/tool-reference/spatial-analyst/zonal-statistics.htm
http://pro.arcgis.com/en/pro-app/tool-reference/spatial-analyst/zonal-statistics.htm
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• Use the ‘Feature to Raster’ conversion tool. Under ‘Output cell size’ select 

the same size than the raster you are querying. 

• Note: if Zonal Statistics were to be run on these rasterized polygons, the re-

sults from Step 2 should be the same. 

4. Upload the rasterized polygons to your application on the platform using the instruc-

tions starting on page 17 and set up query results using the instructions starting on page 21. 

The platform and ArcGIS should match.  

 
In QGIS: 

1. Load your raster dataset and area file, ensuring that they are in the same projection. 

2. Run the ‘Zonal Statistics’ plugin. 

• The plugin will generate output columns in the vector file (area file) with a 

user-defined prefix.  

• This tool operates in the same manner as the mapping platform (based on a 

GDAL library) and should produce results that are directly comparable to the 

online results. There is no need to rasterize any vector layers as with ArcGIS. 

 
 
 
 
 
 



59 

 

APPENDIX 3: Ecometrica Platform – Terms of Use (June 

2016) 

This document explains to you the basis on which you may make use of the Ecometrica Plat-
form. Please read these terms of use carefully before you start to use the Ecometrica Platform. 
By using the Ecometrica Platform, you indicate that you accept these terms of use and that you 
agree to abide by them. If you do not agree to these terms of use, please refrain from using the 
Ecometrica Platform. We may revise these terms of use from time to time. Such variation will 
be notified to you.  

 

Information about Ecometrica 

The Ecometrica Platform is operated by us, Ecometrica Limited, registered in Scotland as a lim-
ited company under company number SC339323 and having its registered office at Orchard 
Brae House, 30 Queensferry Road, Edinburgh EH4 2HS.  

Accessing the Ecometrica Platform 

Access to the Ecometrica Platform is restricted to registered users. You must keep your user 
identification code, password or any security information safe and not disclose them to anyone. 
We have the right to disable any user identification code or password at any time, if you have 
failed, or we reasonably suspect you have failed, to comply with any of the provisions of these 
terms of use.  
 
You are responsible for making all arrangements necessary for you to have access the Ecomet-
rica Platform. You are also responsible for ensuring that all persons who access the Ecometrica 
Platform through your internet connection are permitted to do so, are aware of these terms 
and to ensure that they comply with them.  

 

Intellectual property rights 

We are the owner, or licensee, of all intellectual property rights in the Ecometrica Platform, and 
in the material published on it. Those works are protected by database rights, copyright laws 
and treaties around the world. All such rights are reserved.  
 
You shall not, except as may be allowed by any applicable law which is incapable of exclusion:  

• attempt to copy, modify, duplicate, create derivative works from, frame, mirror, repub-
lish, download, display, transmit, or distribute all or any portion of the Ecometrica Plat-
form in any form or media or by any means; or 

• attempt to reverse compile, disassemble, reverse engineer or otherwise reduce to hu-
man-perceivable form all or any part of the Ecometrica Platform; or 

• access all or any part of the Ecometrica Platform in order to build a product or service 
which competes with the Ecometrica Platform; or 

• use the Ecometrica Platform to provide services to third parties except as expressly 
permitted in a written agreement between us; or 
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• license, sell, rent, lease, transfer, assign, distribute, display, disclose, or otherwise com-
mercially exploit, or otherwise make the Ecometrica Platform available to any third par-
ty without our written consent; or 

• knowingly introduce viruses, trojans, worms, logic bombs or other material which is ma-
licious or technologically harmful; or  

• attempt to gain unauthorised access to the Ecometrica Platform, the server on which 
the Ecometrica Platform is stored or any server, computer or database connected to the 
Ecometrica Platform. You must not attack the Ecometrica Platform via a denial-of-
service attack or a distributed denial-of service attack. 
 

Reliance on the Platform 

We make commercially reasonable efforts to ensure that the information contained or made 
available on the Ecometrica Platform is complete and accurate at the time it is produced. 
However, we make no warranties, representations or undertakings about the content of the 
information contained on the Ecometrica Platform or the results generated using the 
Ecometrica Platform (including, without limitation, any as to the completeness or fitness for 
any particular purpose of such content). In addition, we have no responsibility for any 
information or materials that may be included on the Ecometrica Platform from you or other 
third parties.  
 
Our liability 

To the extent permitted by law and except where expressly stated in this document, we hereby 
expressly excludes all conditions, warranties and other terms whether express or implied by 
statute, common law or otherwise.  
 
We shall not in any circumstances be liable whether in contract, tort (including for negligence 
and breach of statutory duty howsoever arising), misrepresentation (whether innocent or 
negligent), restitution or otherwise, for any loss (whether direct or indirect) of data, profits, 
business, business opportunities, revenue, turnover, reputation or goodwill or any other 
indirect or consequential loss.  
 
Our total aggregate liability in contract, tort (including negligence and breach of statutory duty 
howsoever arising), misrepresentation (whether innocent or negligent), restitution or 
otherwise, arising in connection with your use of the Ecometrica Platform and under these 
terms of use shall in all circumstances be limited to fifty thousand pounds Sterling (£50,000).  
 
Information about you and your visits to the Platform 

You acknowledge that by making the Ecometrica Platform available to you, we may process 
some of your personal data (e.g. your name, contact details and email address). By using the 
Ecometrica Platform, creating an account you hereby consent for us to:  

a. process your personal data for the purpose of these terms and making the Ecometrica 
Platform available to you; 
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b. transfer your personal data to destinations outside the European Economic Area (EEA) 
which may have lower standards of data protection than those applicable in the EEA; 
and 

c. retain your personal data for as long as is necessary for the purpose of these terms and 
making the Ecometrica Platform available. 

We shall have the right to disclose your identity to any third party who is claiming that any 
material posted or uploaded by you to the Ecometrica Platform constitutes a violation of their 
intellectual property rights, or of their right to privacy.  
 
We may report any such breach to the relevant law enforcement authorities and we will co-
operate with those authorities by disclosing your identity to them. In the event of such a 
breach, your right to use the Ecometrica Platform will cease immediately.  

 

Uploading material to The Ecometrica Platform 

When using the Ecometrica Platform, you must not distribute or transmit any material that:  
• is unlawful, harmful, threatening, defamatory, obscene, infringing, harassing or racially 

or ethnically offensive; 
• facilitates illegal activity, depicts sexually explicit images or promotes unlawful violence; 
• is discriminatory based on race, gender, colour, religious belief, sexual orientation, disa-

bility, or any other illegal activity; or 
• causes damage or injury to any person or property. 

 
We will not be responsible, or liable to any third party, for the content or accuracy of any 
materials posted by you or any other user of the Ecometrica Platform.  
 
We will have the right to remove any material or posting you make on the Ecometrica Platform 
if, in our opinion, such material does not comply with the standards set out above.  
 
We will not be liable for any loss or damage caused by a distributed denial-of-service attack, 
viruses or other technologically harmful material that may infect your computer equipment, 
computer programs, data or other proprietary material due to your use of the Ecometrica 
Platform or to your downloading of any material posted on it, or on any website linked to it. 
  
Links from the Ecometrica Platform 

Where the Ecometrica Platform contains links to other sites and resources provided by third 
parties, these links are provided for your information only. We have no control over the 
contents of those sites or resources, and accepts no responsibility for them or for any loss or 
damage that may arise from your use of them.  
 

Term and termination 

We may terminate your access to the Ecometrica Platform immediately by written notice to 
you if you commit, or we have reasonable grounds for suspecting that you have committed, a 
material or persistent breach of these terms which you fail to remedy (if remediable) within 14 
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days after the service of written notice requiring you to do so. Upon termination for any 
reason:  

a. all rights granted to you under these terms shall cease; 
b. you must cease all activities authorised by these terms, including accessing the Ecomet-

rica Platform;  
c. we may destroy or otherwise dispose of any data in our possession unless we receive, 

no later than ten (10) days after termination, a written request for the delivery to You of 
the then most recent back-up of data. We will use reasonable commercial endeavours 
to deliver the back-up to you within thirty (30) days of receipt of such a written request, 
provided that you have, at that time, paid all fees and charges outstanding at and result-
ing from termination (whether or not due at the date of termination). You shall pay all 
reasonable expenses incurred by us in returning or disposing of the data; and 

d. the accrued rights of the parties as at termination, or the continuation after termination 
of any provision expressly stated to survive or implicitly surviving termination, shall not 
be affected or prejudiced. 

Jurisdiction and applicable law 

The English courts will have exclusive jurisdiction over any claim arising from, or related to, a 
visit to the Ecometrica Platform although we retain the right to bring proceedings against you 
for breach of these conditions in your country of residence or any other relevant country.  
 
These terms of use and any dispute or claim arising out of or in connection with them or their 
subject matter or formation (including non-contractual disputes or claims) shall be governed by 
and construed in accordance with the laws of England. 


