
Laser Cut Keyguard Instructions 
 

 
 

This guide describes a workflow to assist a maker to design a custom lasercut keyguard for an 

Augmentative and Alternate Communication (AAC) device. 

 

An AAC device is used to help someone communicate. AAC devices may be comprised of a 

variety of different tablets, (tablet cases) and apps. The AAC apps may also provide options to 

customize the number, size and layout. 

  

A keyguard is a thin plate that sits over top of an AAC device. The keyguard can help a user use 

the AAC device more easily and more effectively. The openings in the keyguard can help 

provide focus, tactile feedback, and the ability to rest the user’s hand on the device without 

activating a button, reducing fatigue.  
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Overview 
The overall process involves measuring the users device, designing the layout of the Keyguard, 

preparing the vector file for Laser cutting, Laser cutting the Keyguard, and mounting the 

Keyguard. 

 

Equipment 
Creating a custom lasercut keyguard requires the following items: 

 Computer with vector graphics software. 

o Inkscape 

o (Optional) Autodesk Fusion 360 

 Measuring Tools 

o Ruler 

o Measuring Tape 

 Keyguard Material 

o Cardstock or cardboard to test fit 

o 1/8 in. or 1/16 in. acrylic 

 Mounting 

o Suction tape 

 

These instructions will refer to steps in Inkscape, but alternative vector graphic software such as 

Adobe Illustrator or Corel Draw may also be used. 

1. Gathering Device Information 

The first step is to gather information about how the user uses their device and then get the 

physical size of the device and app to create an appropriate keyguard. 

Usage 

Does the user want access to the on-screen buttons for editing, menu, iPad home button, etc., 

or is the keyguard to block access? 

 

What size and shape of openings are required? 

 

Should any additional information be marked on the keyguard? 
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Device Measurements 

If the user’s device and AAC application is available, measurements can be made directly. 

  

In some cases, the user may submit a photo of the device with some measurements that can be 

used to scale and determine the measurements. 

 

Capturing A Reference Image 

To accurately measure the position of the various buttons, it can be helpful to capture a 

reference image. To ensure the final keyguard properly fits the device and the openings match 

the buttons, it is critical that the reference image can be scaled properly. 

  

To capture a reference image, accurately measure the cut a piece of paper to a length that 

spans the longest edge of the device. Accurately measure the length of the piece of paper and 

write it on the paper. It is important to know the distance of the screen opening to the closest 

milimeter or 1/16 inch.  

 

Take an image of the device with the app running and the piece of paper. Try to position the 

camera so the device is not skewed. 

 

 

 
 

If possible, capture a screenshot of the image as well. See the appendix for instruction on how 

to capture a screenshot of the app. 
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Using The Reference Image 

In order to use a device photo to design the keyguard layout, the image needs to be rotated and 

scaled. 

  

Import Reference Image  

1. Open Inkscape. 

2. Select File > Import 

3. Select the reference image. Press Open. 

4. Press OK to use the default import options.  

 

 

Rotation 

Rotate the photo so that the tops and sides are aligned with the horizontal and vertical axes. 

 

Tip: Use the measuring tool (ruler icon on toolbar, or ‘M’ on the keyboard) to measure the angle 

of part of the image that should be horizontal. 

 

  

Scaling 

Scale the image so that the size of the image on the computer matches the size of the device.  

 

Use the measuring tool to measure the known distance in the reference photo. Change the units 

to match the known measurement. 

 

Calculate the required scaling factor by dividing the distance measured from the photo by the 

true distance measured on the device, then multiplying by 100. 

For example, if the distance measured from the photo is 25 inches and the true distance is 5 

inches, the scaling factor is: 

 

5/25 * 100 = 20% 

 

1. Click Object > Transform 

2. Click on the Scale tab. 

3. Make sure the ‘Scale Proportionally’ is checked. 

4. Enter the scale factor calculated above. 

5. Click Apply to scale the image. 

  

2. Keyguard Layout 
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Design Considerations 

  

Message Window Size Settings 

Many AAC applications have a message window near the top of the screen. This message 

window may be adjustable to allow the user to set the number of lines and the text size. 

Changing the message window size affects the size of the buttons below. Increasing the 

number of lines or text size of the message window will cause the cause the buttons below 

to reduce in height. 

 

Camera Access 

Don’t cover the camera. 

 

Symmetry 

In some cases, it can be helpful to make the keyguard symmetric about a vertical axis so 

that the device can be rotated.  

 

Material Thickness 

Thicker keyguards may help reduce the number of accidental touches. 

  

Robustness 

Round the corners of the keyguard to remove the sharp edges.  

 

Try to avoid skinny section, especially near the edges, that may cause the keyguard to 

crack or break. 

 

Mounting 

How will the keyguard be mounted to the device?   

 

Keyguard Design 

Using the reference image as a reference, add rectangles and circles to match the outline and 

the openings for the keyguard. 

 

TIP: Use rectangles and circles and set the dimensions using the top bar.  

Marking  

Adding some laser etched marking can make the keyguard easier to use for the user, caregiver, 

or therapist, by helping identity for which app, device and/or user the keyguard belongs. 

 

One way to add text that is fast to etch as lines with the laser cutter is to use the Hershey Text 

plugin in Inkscape: 
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1. Extensions > Render > Hershey Text 

2. In the Hershey Text dialog box: 

a. Type in desired text 

b. Select Action: Typeset that text 

c. Select Font Face: Sans-1 stroke 

3. Click Apply. 

4. Adjust the size and position of the text as desired. 

  

This will create a single-stroke vector path that can be quickly etched using the laser cutter. 

 

Use these steps to add “makersmakingchange.com” near an edge of the keyguard. In order to 

be legible, the text should be ⅛ inch (3 - 4 mm) in height. This will allow the user to locate the 

plans for a replacement or request a modification to their keyguard and provide an opportunity 

for other potential keyguard users to request their own keyguard. 

 

Customization / Personalization 

Add any additional information requested by the user to the keyguard. This may include, for 

example: 

 Name 

 Organization 

 Phone number 

 App / App setting 

 Etc 

 

Try to position the text in a location so that it will not obscure the screen. The space on either 

side of the camera or Home button is usually a good choice. 

 

Laser Cutter File Preparation 

Once the geometry of the keyguard has been finalized, the next step is to prepare the design for 

laser cutting. These instructions may vary depending on the laser cutter and laser cutter 

software. 

  

Operation Stroke Fill Width 

Cut Line Red (R:255,G:0,B:0) None 0.01mm 

Engrave Line Blue (R:0,G:0,B:255) None 0.01mm 
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Engrave Area None Black (R:0,G:0,B:0) 0 

  

Cut lines are meant to cut through the entire depth of the material. The outside outline and all of 

the button openings should be set as Cut Lines. 

 

Engrave lines will engrave a line a limited depth. Single-line text markings should be set as 

Engrave Lines. 

 

Engrave Area will engrave a closed area. This can be useful for adding closed shapes, but 

takes longer to do on the laser cutter. 

 

Save the design file using the following naming convention: 

  {FirstName}{LastInitial}{Number}_{Revision}.svg 

 

Save a copy as a PDF for laser cutting using the same naming convention: 

 {FirstName}{LastInitial}{Number}_{Revision}.pdf 

 

For example, the initial design for John Smith’s first keyguard should be saved as: 

JohnS01_1.svg  

AND 

 JohnS01_1.pdf 

 

Data Transfer 

Transfer both the SVG and PDF file to a USB flash drive. 

3. Test-cut  
This is a recommended but optional step. 

 

Before cutting the keyguard out of plastic, it is helpful to test the fit to see how well the 

design matches up on the device and how well the openings match up to the buttons on the 

application. To quickly and inexpensively test the fit, we can laser cut the keyguard out of 

cardstock or cardboard. 

 

Laser Test Cut 

Bring the USB stick with the PDF design file to the laser cutter.  
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Assessing Fit 

The keyguard should sit flat on the touchscreen. A little wiggle room is better than too tight. 

The openings should match up with the buttons 

Refinements 

If necessary, adjust the size and spacing so the keyguard fits the device and matches the 

buttons properly.  

4. Final Cut  

Final Design Checks 

□ If possible, have you cut a design to test the fit? 

□ Are the corners rounded? 

□ Is the keyguard marked with makersmakingchange.com ? 

□ Is the keyguard marked with any requests from the user (name, app, etc)? 

Laser Cutting  

Bring the USB flash drive with the final design files to the laser cutter so the keyguard can be 

cut out of acrylic.  

5. Finishing 

There are a few final steps to make the keyguard ready for use. 

Smoothing 

Check to make sure there are no sharp edges on the keyguard outline or any of the openings. A 

sharp knife or small file can be used to smooth over any sharp edges. 

Mounting 

There are a few different methods for mounting a keyguard on to an AAC device including: 

● suctions cups 

● velcro 

● suction tape 

● magnets 

● under the case 
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Suction tape (or "suction cup tape") bonds to smooth, flat, clean surfaces just like a suction cup. 

Though not actually suction cups, the surface of this tape has thousands of microscopic craters 

that work by creating many partial vacuums between the tape and the target surface. 

 

The tape is not pressure sensitive, can re-bond repeatedly, and leaves no residue on the target 

surface. To remove, you simply pull the tape off or twist it to break the bond. 

 

1. Cut some narrow strips of suction tape. 

2. Attach the strips of suction tape to the edges of the keyguard. 
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Appendix 

iPad Screenshot Scaling 

To capture a screenshot on an iPad device, load the app and hold the device in the desired 

orientation. While holding down the On/Off button, press the Home button. The screen will flash 

to indicate a screenshot has been captured.  

 

The screenshot image will be 1024 pixels wide and 768 pixels high regardless of the actual size 

of the screen on the device. In order to scale it properly, use the conversion factor in the table 

below. 

 

iPad Type Screen Width 
(mm) 

Screen Height  
(mm) 

Conversion  
(px to mm) 

iPad 198.1 149 0.193 

iPad2 198.1 149 0.193 

iPad 3rd generation 198.1 149 0.193 

iPad 4th generation 198.1 149 0.193 

iPad 5th generation 196.47 147.39 0.192 

iPad Pro 9.7-inch 203.11 153.71 0.198 

iPad Pro 10.5-inch 213.5 160.13 0.208 

iPad Pro 12.9-inch 1st Generation 262.27 196.61 0.256 

iPad Pro 12.9-inch 2nd Generation 262.27 196.61 0.256 

iPad mini 161.2 121.3 0.157 

iPad mini 2 161.2 121.3 0.157 

iPad mini 3 161.2 121.3 0.157 

iPad mini 4 161.24 121.31 0.157 

iPad Air 198.1 149 0.193 

iPad Air 2 203.11 153.71 0.198 

Source: http://volksswitch.org/index.php/volks-devices/fully-customizable-3d-printable-aac-

keyguard-for-tablets/using-app-screenshots-to-determine-the-app-layout/ 
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Fusion 360 Workflow 

Autodesk Fusion 360 is a cloud-based, computer-assisted design program with a free license 

for hobbyists and enthusiasts. Fusion 360 requires a 64 bit system and either Windows or MAC 

OS. To access the hobbyist license, you’ll need to sign up for an account and download the free 

trial: https://www.autodesk.com/products/fusion-360/overview 

  

Fusion 360 has a few features that make it a useful tool for designing custom laser cut 

keyguards. 

 

Insert Canvas 

1. Under the insert menu, select Insert Canvas 

2. Choose the top plane 

3. Select the image 

4. Rotate the image to align the edges with the grid. You may need to manually enter a 

small value (e.g. 1, 0.1 degrees) into the box. 

   

Scale the Image 

1. In the Browser bar, click the triangle beside the Canvasses Folder to show its contents 

2. Right click on the canvas image you added in the previous step and select ‘Calibrate 

Image’ 

3. Use the mouse to select a first and a second point on the image with a known distance 

between them, and then enter the distance value in to the dialog box. Try to be as 

accurate as possible when entering the points so the reference image is scaled properly. 

 

Design Keyguard Layout 

1. Create a new sketch on the same plane as the canvas. 

2. Create the outline of the keyguard using the rectangle tool. 

3. Create the keyguard button openings using rectangles or circles according to the users 

preference. 

4. When finished, close the sketch. 

 

Tip #1: Use construction lines to help align the openings. 

 

Tip #2: To make the design symmetric, add a construction line in the middle and use the 

Sketch>Mirror tool to copy openings to the other side. You can also use Symmetry constraints 

to enforce symmetry. 

 

Extrude Keyguard Sketch 

1. Click Create > Extrude 

2. Select the keyguard profile sketch. 

3. Set the extrusion distance to 1/16 inch or 1/8 inch 

 

Export sketch 
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1. Right click on the sketch 

2. Click ‘Save as DXF’ 

 

Import sketch into Inkscape 

1. Import the dxf file. 

2. In some cases the design may be upside down. You may need to rotate the design 180 

degrees.  

3. Add any marking or text. 

4. Change the line color and stroke according to the laser cut file preparation instructions. 

Additional Resources 

 

Suction Tape 

http://www.keyguardat.com/suction-tape/ 

 

3D Printed Keyguard Workflow 

http://volksswitch.org/index.php/volks-devices/fully-customizable-3d-printable-aac-keyguard-for-

tablets/ 
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