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ABSTRACT

Abstract should a movie trailer, not a plot summary of your thesis. It
should describe the problem (statement), research objective, and research approach.

Emphasize on original contributions.
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ABSTRAK

Abstract in Malay is the hardest, even to me. Using Google Translate is
definitely a no-no. Check all special terms on Dewan Bahasa and Pustaka website.

http://prpm.dbp.gov.my/


http://prpm.dbp.gov.my/
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CHAPTER 1

INTRODUCTION

In general, every thesis must have a solidly defined problem that motivated the

research

° Why the problem is important

° What others have done

° Describe the (novel) contribution and findings

° Document the experiments that validate the contribution
° Draw conclusions.

Each thesis is unique and depends on the writer and the editor (your SV). The following

example a good starting point:

. Abstract: A short (few paragraphs) summary of the the dissertation. Describe

the problem and the research approach. Emphasize the original contributions.

° Chl1 Introduction: An overview of the problem; why it is important; problem
definition; a summary of extant work and a statement of your hypothesis or

specific question to be explored. Make it readable by anyone.

° Ch 2 Literature Review: Critical review of extant works. Research gaps to be

exploited. Make the definitions precise, concise, and unambiguous.

° Ch 3 Methodology: Research design, central concept of your work, methods

and procedure, variables.



Ch 4 Validation work: Describe experiment details that provide evidence in

support of your thesis.

Ch 5 Results and analysis: Describe the results of experiments that provide

evidence in support of your thesis. Usually experiments or simulations
- Could be proof-of-concept
- To show better efficiency

Ch 6 Conclusion: Summarize what was learned and how it can be applied.

Mention the possibilities for future research.



CHAPTER 2

INSTALLATION

Download and install Lyx Bundle ftp://ftp.lyx.org/pub/lyx/
bin/2.2.3/LyX-223-Bundle-2.exe

- Miktex
- LyX

Download UTM thesis template https://github.com/utmthesis/

utmthesis
Testing the template. Open utmthesis.layout using a text editor
- Check line 13
* Make sure Format 60
Generating pdf
- Open thesis-template-numbering.lyx
- File > Export > PDF (pdflatex)

- A PDF should be generated


ftp://ftp.lyx.org/pub/lyx/bin/2.2.3/LyX-223-Bundle-2.exe
ftp://ftp.lyx.org/pub/lyx/bin/2.2.3/LyX-223-Bundle-2.exe
https://github.com/utmthesis/utmthesis
https://github.com/utmthesis/utmthesis

CHAPTER 3

WRITING FLOW

° Vital information

\title{The Thesis Title}

\titletwo{Second Line (Optional)}

\titlethree{Third Line (Optional)}

\author{The Author}

\degree{Master of Engineering}
\specialization{Computer and Microelectronic System}
\intakeyear{2016}

\titledate{June 2018}

\award{2}

1. Bachelor Degree Project Report

2. Master’s Project Report (By course work)
3. Master’s Dissertation (By course work and research)
4. Master’s Thesis (By research)
5. Doctor of Philosophy Thesis
6. Engineering Doctorate Thesis
7. First Stage Proposal
\superone{M.Y. Supervisor}
. Preamble pages
- Acknowledgement
- Dedication

- Abstract




- Abstrak

* Please check with the Dewan Bahasa website http://prpm.

dbp.gov.my/ for special terms.
- Abbreviations
- Symbols
° Main Matters: Parts, Chapters, and Sections
- Chapter
- Section
- Subsection
- Subsubsection

- Try not to go beyond this! We receive many questions on this.


http://prpm.dbp.gov.my/
http://prpm.dbp.gov.my/

4.1

4.2

CHAPTER 4

LYX FEATURES

LyX Basic Features

Cut/Paste/Copy — Like MS Word.

WYSIWYM, not WYSWYG
- The hardest things for new users: How LyX handles whitespace.
- Protected Break, which you get by typing Ct r1+Return

- Protected Space, which you get by typing Ctr1+Space

LyX Environments

Document classes are another major part of the WYSIWYM philosophy.

- It tells LyX how to typeset the document, so you do not need to know

how.
- UTMthesis class is a book-type derived class.

Different parts of a document have different purposes; we call these parts

environments.

- Certain types of documents have special environments (an abstract and

a title for journal, but not letter)

- An environment may require a certain font style, font size, indenting,

line spacing, and more.



- The Environment choice box is located on the left end of the toolbar

and looks like this: sandard ] .

° Paragraph alignment
- The default in most cases is justified alignment.
. Using Different Character Styles
- Noun style (toolbar button A%)
- Emphasized style (toolbar button A )
- Don’t overuse character styles!
° Lists and sublists
- Enumerate
- Itemized
- List (not native to I5TEX)
- Description

° Footnotes

- Footnotes can be added using the toolbar button or the menu

Insert> Footnote.

4.3 Cross-Referencing and Bibliography

° The use of label and cross-reference.

Dynamic numbering of
* <reference>: prints the float number, this is the default.

* (<reference>): prints the float number within two parentheses,

e.g. for Equation.
* <page>: prints the page number.

* on page <page>: prints the text "on page" and the page number.



* <reference> on page <page>: prints the float number, the text

"on page", and the page number.

* Formatted reference: prints a self defined cross-reference

format (haven’t explored yet).

° Use it to refer to figures, tables, equations, chapters etc.

4.4  Bibliographies

° Use BiBTEX



@book{bl,

Author = {Leslie Lamport},

Title = {BEIgX: A Document Preparation System},
Publisher = {Addison-Wesley Professionall,

Year = {1994},

}

@electronic{wl,

title = {BIEX Wikibook},
year = {2013},

month = {November},

URL = {http://en.wikibooks.org/wiki/BIsX},

}

@article{abanades2006screening,

title={Screening of water-splitting thermochemical cycles
potentially attractive for hydrogen production by concentrated
solar energyl,

author={Abanades, St{\’e}phane and Charvin, Patrice and Flamant,
Gilles and Neveu, Pierre},

journal={Energy},

volume={31},

number={14},

pages={2805--2822},

year={2006},

publisher={Elsevier}

}

@inproceedings{Markatos2002,

author = {Markatos, E.P.},

title = {Speeding up TCP/IP: faster processors are not enough},
booktitle = {21st IEEE International Performance, Computing, and
Communications Conference},

year = {2002},

pages = {341--345},

address = {Phoenix, AZ, USA},

month = {April},

}




° Where to get?
- Mendeley (citations manager)
- Google Scholar
- Publishers
- Require manual edit
o BibTgX style
- For numbering, use utmthesis—-numbering.bst
- For author-date, use utmthesis—authordate.bst

° When citing, click on @ such as Markatos (2002).
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CHAPTER 5

TYPESETTING MATHS

° In order to create a formula, just click the toolbar button Z or use the menu

Insert>Math > Inline Formula

Also for Display Formula and Numbered Formula.

For multiline equations, use Eqnarray

. Examples of Math Mode Features

Exponents and Subscripts — e.g., x*2y, you will get 2% and type a_1 to

get ai.
a
Fractions — by typing \frac or using the icon b in the Math Panel.

Roots — using the Math Panel button\/ﬁ or the commands \sqrt or

\root.
Operators with Limits — Sum (>°) and integral ( f ) operators

Math Symbols — includes Greek, Operators , Relations, Arrows.
Also AMS additional symbols.

Altering Spacing — using protected space.
Brackets and Delimiters — Auto-sizing delimiter via icon [D]

Arrays and Multi-line Equations — Matrices are entered using the

0000

[
[l
|m[m]
[

Math Panel matrix button =85,

oooo

Cases — Insert> Math > Cases Environment or the command \cases.



CHAPTER 6

FLOATS

° A float doesn’t have a fixed location.

- It can “float” forward or backward to wherever it fits best to get a high

quality layout.
- Caption as part of a float.

- Can create subfigure with double Insert>Float>Figure and again,

insert > Float > Figure
° Float Placement
- Here if possible: try to place the float at the position where it is inserted
- Top of page: try to place the float at the top of the current page
- Bottom of page: try to place the float at the bottom of the current page
- Page of floats: try to place the float at an own page
. Graphics and Images

- Place the cursor and click on the toolbar icon £ or select Insertr

Graphics from the menu.

- You can copy and paste as well (just like MS Word) but will result in
bipmap image. Not good enough.

- Use scalable images such as SVG, EPS, PDF.

° Tables
B

- Insert a table using either the toolbar button =¥ or the menu Insertr>
Table



7.1

CHAPTER 7

BEST PRACTICES

Criteria of a good project report

Content: Spend more time and effort writing about the strengths of your work,
and making clear, confident statements wherever possible to emphasize your

best results.

Clear: Clarity is king. Make your expression clear. The examiner can
disagree with you, but they should never misunderstand you. Always check

for ambiguous the statements.
Concise: Have you written your proposal in a succinct and focused way?
Coherent: Does your chapters and sections link together well?

Style: Read some of your supervisor’s work, so you can get a sense of their
style. Keep the style simple and avoid dense, dry, monotonous text blocks.
Thesis writing is not a creative writing, although you need to be creative and

be aware of the rhythm of your writing.

Honest: An ethical writer always acknowledges the contributions of others
and the source of his/her ideas. Others ideas, data, and conclusions are usually

borrowed and used as the foundation of one’s own contribution.
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7.2 Some Tips and Best practices

Terms and phrases to avoid

Mostly adverbs, they are very often overly used. Use strong words instead.

Avoid judgmental words such as “bad”, “good”. Use “incorrect/correct” to

refer to factual correctness or errors.

Use precise words or phrases to assess quality (e.g., “method A requires less

computation than method B”).

% ¢ 29 ¢ 99 C¢

° Avoid all qualitative judgments such as “true”, “pure”, “good”, “perfect”, “an

ideal solution”

9% Ces

° Avoid vague phrases such as “as the basis of” , “different” vs. “various”, “in

99 ¢

light of”, “lots of”, “obviously”, “clearly” etc.

See more at https://www.cs.purdue.edu/homes/dec/essay.

dissertation.html

Voices and tenses

° Voice: Use active constructions. For example, say “the operating system starts

the device” instead of “the device is started by the operating system”.

° Tense: Write in the present tense. For example, say “The system writes a page
to the disk and then uses the frame...” instead of “The system will use the frame

after it wrote the page to disk...”

° Define Negation Early: Example: say “no data block waits on the output

queue” instead of “a data block awaiting output is not on the queue.”


https://www.cs.purdue.edu/homes/dec/essay.dissertation.html
https://www.cs.purdue.edu/homes/dec/essay.dissertation.html
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Grammar and logic

Be careful that the subject of each sentence really does what the verb says it

does.

“RPC requires programs to transmit large packets” is not the same
as “RPC requires a mechanism that allows programs to transmit large

packets”.

“There is a compiler that translates the N languages by..” means a
single compiler exists that handles all the languages, while the sentence
“For each of the N languages, there is a compiler that translates...”

means that there may be 1 compiler, 2 compilers, or N compilers.

Focus on results

Stick to the plain facts

Avoid

“After working eight hours in the lab that night, we realized...”.

“If that cat had not crawled through the hole in the floor, we might
not have discovered the power supply error indicator on the network

bridge”

Never attribute such events to mystical causes or imply that strange

forces may have affected your results.

Avoid self-assessment

Avoid self-assessment (both praise and criticism)

“The method outlined in Section 2 represents a major breakthrough in

the design of distributed systems because...”

“Although the technique in the next section is not earthshaking,...”
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- “This novel architecture ...”

References to extant works

Always cites papers, not authors.

Avoid the phrase “the authors claim that X”. If you agree on X correct, simply

state X followed by a reference.

If one absolutely must reference a paper instead of a result, say “the paper states

that...” or “reference [1] presents evidence that...”.

Concept vs. instance

A reader can become confused when a concept and an instance of it are blurred.
- An algorithm vs. a particular program that implements it
- A programming language vs. a compiler

- A general abstraction vs. its particular implementation in a computer

system

- A data structure vs. a particular instance of it in memory.

Drawing only warranted conclusions

Draw conclusions that the evidence supports.

If programs run much slower on computer A than on computer B, one cannot
conclude that the processor in A is slower than the processor in B unless one has
ruled out all differences in the computers’ operating systems, input or output

devices, memory size, memory cache, or internal bus bandwidth.
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. Refrain from doing judgment unless one has the results from a controlled
experiment (e.g., running a set of several programs many times, each when

the computer is otherwise idle).

° Even if the cause of some phenomenon seems obvious, one cannot draw a

conclusion without solid, supporting evidence.

Science and what’s not

° In a scientific thesis, one never draws conclusions about the economic viability

or commercial success of an idea/method.

- Avoid statements such as “over four hundred vendors make products

using technique Y.

° Politics And Science: A scientist avoids all political and ideological influence

when assessing ideas.

One must assess the idea independent of the source.



CHAPTER 8

ADVANCED TOPICS

Ask Mr Google.
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APPENDIX A

MATHEMATICAL PROOFS



APPENDIX B

PSEUDO-CODES



APPENDIX C

TIME-SERIES RESULTS
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