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About This Guide 
Welcome to the Magento User Guide, which provides an overview of the Magento Enterprise Edition (EE) 

eCommerce platform developed by Magento, Inc. This guide is intended for web storeowners and first-time 

users of Magento. It provides a quick guide through the most important steps for getting your web store up 

and running and ready for selling online. The options described in this user guide enable you to generate a 

feature-rich and attractive eCommerce interface without the need for advanced technical expertise. 

This guide first introduces Magento and its key concepts. The following three chapters discuss basic system 

configuration and introduce the daily experience that a customer can have in a Magento web store and the 

daily management tasks that a storeowner would perform.  

Parts I through VI of this manual walk you through the process of setting up your Magento web store; 

customizing its behavior to your requirements; entering products; managing orders, invoices and shipments; 

and using various marketing features. Parts VII through X describe advanced features of Magento EE. 

Support and Contact Information 
We at Magento are dedicated to providing our customers with the best possible service. We would love to 

hear from you.  

For feedback on this book and all other inquiries, please use our contact form at: 

http://www.magentocommerce.com/company/contact-us/ 

For information about Magento support resources, see “Getting Help,” page 451. 

Conventions Used in This Guide 
The following style conventions are used in this document: 

Note: This is a note. 

 

Tip: This is a tip providing useful suggestions and information. 

http://www.magentocommerce.com/company/contact-us/
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PART I: GETTING STARTED 

1 Introducing Magento 
This chapter introduces Magento, its basic components, and the workflow for using it. 

1.1 What Is Magento? 

Magento is a feature-rich eCommerce platform, built on open-source technology, that provides 

online merchants with unprecedented flexibility and control over the look, content, and 

functionality of their eCommerce store. Magento’s intuitive administration interface features 

powerful marketing, search engine optimization, and catalog management tools to give merchants 

the power to create sites that are tailored to their unique business needs. Designed to be completely 

scalable, Magento offers companies a stable, secure, customizable eCommerce solution. 

1.2 Magento Frontend and Backend 

The following sections provide an overview of the two visible interfaces of Magento: the frontend 

and the backend. 
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Frontend (The Web Store Front) 

The frontend is the public view of your web store with which your customers can interact through a 

standard web browser. It presents your products, product categories, and promotions, and provides 

your customers with ordering, payment, and purchase tracking features. 

An example is shown in Figure 1. 

 

Figure 1. Magento Frontend 
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Backend (The Back Office) 

The backend is the password-protected view of the back office features that enable a web store 

administrator to set up the products and purchasing options and to manage orders and all other 

store functions. You can navigate the Admin Panel using the menu on the top of the page (Magento 

top menu). A view of the backend is shown in Figure 2. 

 

Figure 2. Magento Backend 

1.3 Magento Concepts 

To use Magento effectively, you should be familiar with the following terms and concepts. For a 

complete list of Magento terms and definitions, see “Glossary,” page 453. 

Attribute: A characteristic of a product. For example, an attribute of a digital camera could be 

“resolution,” and the value of this attribute for a particular digital camera could be “10 megapixels.” 

Customers can filter a list of products by values of one or more attributes. 

Attribute Group: A logical grouping of attributes within an attribute set. 
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Attribute Set: A collection of attributes, customized to fit a certain type of product. For example, if 

you sell several different kinds of T-shirts on your website, you can create the T-shirts attribute set, 

which will include the simple attributes commonly shared by all of your T-shirts. This may include 

color, size, gender, and brand. 

Bundle product: This product is composed of components that are presented in different ways and 

are made from existing products. A good example of a bundle is a complete computer. For this 

computer, you can configure how much RAM or what kind of monitor is included with this 

computer in your store. 

Category: A user-defined product classification. A category can have any number of levels of 

subcategories. 

Configurable product: This product enables your customers to select the variant that they want by 

choosing options. For example, you can sell T-shirts in two colors and three sizes. You would have 

to create six variants as individual products (each with its own SKU) and then add these six to a 

configurable product where customers can choose the size and color, and then add it to their cart.  

Credit memo: A credit memo is a statement of credits; for example, a credit for returned 

merchandise generates a credit memo. According to your store policy, you can apply the credit to 

future orders or refund the customer’s payment method. 

Cross-sell: Cross-sell products appear next to the shopping cart. When a customer navigates to the 

shopping cart page, these products are displayed as cross-sells to the items already in the shopping 

cart. They are similar to impulse buys, like magazines and candy at the cash registers in grocery 

stores. 

Downloadable product: A product, such as a media file, that the customer downloads from the store 

after purchase. These downloadable files can reside on your server or be provided as URLs to any 

other server. 

Grouped product: This option enables you to display several similar products on a single page. For 

example, if you are selling chefs’ knives and you have the same knife in four sizes, you can make a 

grouped product to display all four of these sizes. Customers can select the size(s) that they want 

and add them to the cart from this page.  

Invoice: An invoice in Magento represents a confirmation of payment. More than one invoice can 

be associated with a single order. If the products in an order are shipped in multiple shipments, then 

an invoice is generated for each shipment for the products in that shipment. 

Order: An order is a request for goods. 

Order status: The order status indicates where it is in the order cycle. In Magento, the system order 

status values are the following: 

 Pending - Pending orders are brand new orders that have not been processed. Typically, 

these orders need to be invoiced and shipped. 

 On Hold - The user cannot proceed to order processing if the order is in this state. This is 

convenient if, for example, some data must be verified.  
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 Pending PayPal (possible for PayPal orders only) - Pending PayPal orders are brand new 

orders that have not been cleared by PayPal. When using PayPal as a payment method, 

customers are redirected to the PayPal website. If they have not paid for the order, orders 

will be marked as Pending PayPal. It is not recommended to process these orders without 

referencing PayPal first to see if payment has been made.  

 Payment Review - As long as an external payment gateway is verifying the payment 

information from a sales order, the order is assigned the Payment Review status both in the 

payment system and in Magento.  

 Processing - Processing means that the order has been either invoiced or shipped, but not 

both.  

 Suspected Fraud (possible for PayPal orders only) – The order transaction did not pass one 

or more of the PayPal fraud filters and the system receives the response from PayPal that the 

transaction is under review by Fraud Service 

 Complete - Orders marked as complete have fully been invoiced and have shipped.  

 Canceled - The order can be of this status if the customer calls your web store and asks to 

cancel an order if the order has not been paid for. 

The store administrator can create custom order statuses, assign them to order states and set default 

status values for order states. 

Product type: Magento classifies products as one of several predefined product types: Simple 

Product, Virtual Product, Downloadable Product, Grouped Product, Configurable Product, Bundle 

Product, Gift Card Product. 

Related product: Related products are offered to the customer for purchase in addition to the item 

that the customer is viewing. 

Scope: Scope describes the extent of your store hierarchy to which a given setting is effective. A 

setting can have a scope of Global (all websites, stores, and store views), Website (the selected 

website and all stores and store views under it), Store (the selected store and all store views under 

it), and Store View (the selected store view). Some settings that are set at a higher level can be 

overridden at a lower level. 

Search Engine Optimization (SEO): The set of techniques and strategies that ensure that your site is 

listed prominently in search engine results, thereby increasing the likelihood that customers will find 

your site. 

Simple product: This is the most basic product type. It is suitable for all kinds of physical (shipped) 

products. 

Shipment: A shipment is a record of the products in an order that have been shipped. More than one 

shipment can be associated with a single order. 

Shopping cart: The set of products that a customer has selected to purchase, but has not yet 

purchased. 

Store: The second level of your store hierarchy. A website can have multiple stores (each, 

potentially, with its own root category), and a store can have multiple store views. 
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Store View: The lowest level of your store hierarchy. Typically, a store view is created for each 

locale or language. All store views under a given store share the same catalog. Customers use a 

drop-down menu on the frontend to switch from one store view to another. 

Tax rule: A combination of a product tax class, customer tax class, and tax rate. This rule defines 

which tax calculation is applied. 

Up-sell: An up-sell item is one that is offered to the customer as an alternative to the product the 

customer is viewing. These products may be more expensive, of higher quality, or more popular, or 

produce a higher profit margin. 

Virtual Product: This is a product that does not require shipping or inventory. It is generally used for 

warranties or services. 

Website: The highest level of your store hierarchy. You can have multiple websites, and each 

website can have a different domain name. Websites can be set up to share customer data, or to not 

share data. Typically, each website has different lines of products and may have different customer 

bases. 

1.4 Installing Magento 

Installation of Magento Enterprise Edition is typically performed by a company’s IT 

department or by an outside consultant. For information about installing or upgrading 

Magento EE, see the “Upgrading Magento Enterprise” document that you receive when you 

purchase the Enterprise Edition software. 
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2 Introducing the Frontend 
In order to familiarize you with the features of the frontend, this chapter describes the basic browsing and 

purchasing features provided for your customers by a web store created using Magento. This knowledge will 

help you make better decisions when setting up your store. 

2.1 Overview 

The frontend provides the view of your web store that is publicly available to customers using the 

Internet. The frontend shows your product catalog and provides your customers with ordering, 

payment, and tracking features.  

You can access the Magento EE demo web stores by navigating to http://enterprise-

demo.magentocommerce.com. The Single Store Demo is a sample Magento store that uses 

Magento’s default theme and sample data. This sample store is referenced frequently this user guide. 

You can access your own store by browsing to the address that you defined for it during installation. 

The illustration in Figure 3 shows the first page of a default Magento store with sample data. 

 

Figure 3. Magento Store Frontend 

http://enterprise-demo.magentocommerce.com/
http://enterprise-demo.magentocommerce.com/
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2.2 Finding the Right Products  

The Magento frontend is also referred to in this guide as your web store. It provides a variety of 

options for browsing through the products offered and then drilling down to view detailed 

information about each product. Magento enables you to define the default appearance of how 

multiple products are presented, such as whether they are shown as a list or grid (table), their sort 

order, and the filter that is used. 

Categories 

The products in the web store are grouped into categories, which are displayed in a bar near the top 

of the web store page. Each product can be assigned to one or more categories. 

Categories can have multiple levels of subcategories. A customer can navigate to a subcategory 

using a category’s drop-down menu. Figure 4 shows the five categories on the Magento demo store 

and the subcategories under Electronics: Cell Phones, Cameras and Computers: 

 

Figure 4. Categories and Subcategories 

A category or a subcategory can each have a product list or show a landing page that features some 

products. Figure 5 shows a category that has products: 
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Figure 5. Category Page with Products 

Filtering the Display of Products 

Typically, the first step of a customer when browsing through the web store may be to select the 

category or subcategory of the products of interest. The customer can then filter the products in that 

category according to the various attributes of these products.  

The SHOP BY area on the left side of the frontend page provides a variety of product attributes that 

can be used to access the products in that category. The attributes in a category appear in groups, 

each with its own title. In the frontend page shown above, the groups that appear are PRICE (which 

shows ranges of prices), COLOR, MANUFACTURER and SHOE TYPE. Next to each attribute is the 

number of products that have that attribute.  

For example: The Apparel category has three green products, as shown in Figure 6. 

 

Figure 6. Category Product Counts 
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After a customer clicks on the Green attribute, all the green products are displayed in the web store 

for browsing and the SHOP BY area indicates that the products in this category have been filtered 

by the Color: Green attribute, as shown in Figure 7. 
 

 

Figure 7. Filter Indication 

To clear the filter and thus redisplay all the products in the currently selected category, click the 

Clear icon ( ) next to the filter, or click the Clear All Items option. 

Note: The third product is shown because it contains two variants inside: a green and a 
red version. 

Popular Tags 

Another option that Magento provides to help customers find the right product is called Popular 

Tags. Popular Tags provide another property that can be assigned to products that customers can 

select in order to view the products to which this tag has been assigned (see Figure 8).  
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Figure 8. Popular Tags 

Popular tags can be assigned by customers in the product page (see Figure 9) and can be approved 

and edited from the backend, if required. 

 

Figure 9. Adding a Tag to a Product 

Searching 

The top right of your web store page provides a search field in which a customer can type all or part 

of the name of a product, or its attributes, in order to find it, as shown in Figure 10. 

 

 

Figure 10. Search Tool 

Comparing Products 

Magento enables customers to compare two or more selected products, as follows: 

1. A customer first clicks the Add to Compare link provided for each product that he/she wants to 
compare, as shown in Figure 11. 

Search Field 
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Figure 11. Add to Compare Link 

2. After selecting all the products to be compared, the customer then clicks the Compare Items 
button in the COMPARE PRODUCTS area, as shown in Figure 12. 

 

Figure 12. Compare Products Area 

The Compare Products page is then displayed in a pop-up window, as shown in Figure 13. 
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Figure 13. Compare Products Page 

Note: A row also appears for each comparable attribute defined for these products, 
such as Color. See “Managing Product Attributes,” page 72, for more information 
about defining attributes. 

Sorting Products 

A customer can sort the products that are displayed by selecting the relevant option in the Sort by 

drop-down menu, as shown in Figure 14. 
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Figure 14. Sort By Drop-down menu 

Grid/List View 

By selecting the Grid or List links at the top of the page, a customer can choose to view products 

displayed in a grid (table), as shown in Figure 14, or as a list, as shown in Figure 15.  
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Figure 15. List View 

Recently Viewed 

The RECENTLY VIEWED PRODUCTS area (see Figure 16) lists the products that were recently 

viewed by the customer, whether they were purchased or not, and enables the customer to easily 

link back to them. 

 

Figure 16. Recently Viewed Products Area 

2.3 Promotional Information 

Magento provides a variety of aspects of product presentation that you can control and that enable 

you to promote and up-sell products to your customers.  
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Product List Banners 

You can define the banner that appears at the top of each category landing page with a static block 

(see Figure 17). This feature adds a graphical element to your category pages that can be used for 

special promotions, or to highlight certain products. Banners can be defined per category. More 

information about how to create and add static blocks on your site can be found in “Managing CMS 

Pages,” page 145. 

 

 

Figure 17. Product List Banner 

Promotional Pages 

Another way to feature products and promotions in your web store is a customized category landing 

page, which is a static HTML page that may be displayed while the user is browsing a category, 

instead of showing a list of products. See Figure 18. 

 

Figure 18. Promotional Page 
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Up-sell Products  

Up-sell products are items that your customer could buy instead of the product that is being viewed. 

These products may be more expensive, of higher quality, or more popular, or produce a higher 

profit margin. 

The example in Figure 19 presents a more expensive keyboard and other products as up-sells to the 

less expensive keyboard. 

 

Figure 19. Up-sell Products 
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Related Products 

Related products are meant to be purchased in addition to the item the customer is viewing. Related 

products are shown in the right column of your web store in a separate block. The example in 

Figure 20 shows various mobile phones promoted as related products.  

 

Figure 20. Related Products 

Cross-sell Products 

Cross-sell products appear next to the shopping cart. When a customer navigates to the shopping 

cart page (whether automatically after adding a product or otherwise), these products are displayed 

as cross-sells to the items already in the shopping cart. They are similar to impulse buys, like 

magazines and candy at the cash registers in grocery stores. See Figure 21. 

 

Figure 21. Cross-sell Item 
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Product Pages 

The backend enables you to define the type of information and functionality that is provided in a 

product’s page. Figure 22 shows a typical product page. 

 

Figure 22. Product Page 

Most of the features provided to present a product in your web store are self-explanatory. The 

following describes a few of these features: 

 Image: The customer can use the slider to zoom in and out of the image, click on it to 

enlarge it, or pan it to see different parts of it. 
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 Description: The top of the page shows a short description in the Quick Overview area, and 

farther down you can see a more detailed Product Description area. Also, Additional 

Information details are provided about the product in the form of a table. 

 Product Tags: Shows the tags assigned to this product. Customers can navigate to other 

products by clicking on one of these tags. You can also define whether customers can add 

tags.  

 Reviews: Your customers can rate and review your products. The store administrator can 

approve or remove reviews. 

 Product Options: Magento provides a variety of controls that enable you to configure the 

product options that appear for a customer to select, such as check boxes, drop-down 

menus, and so on. For example, customers are able to select the size of a shoe, as shown in 

Figure 23. 

 

Figure 23. Product Options 

2.4 Web Store Page Header and Footer 

Every web store has a header that appears at the top of each page and a footer that appears at the 

bottom of each page. These features enable you to control the look and feel of your web store and 

provide the customer with various functions, as described in this section. 
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The Header 

The default header of each of your web store pages shows your web store logo and banner. An 

example is shown in Figure 24. 

 

Figure 24. Web Store Header 

This header also provides a variety of functions on the right, as follows:  

 My Account: Enables registered customers to access their order history, track their 

shipments, download products, and change address information. 

 My Wish List: Enables customers to define a list of items that they may want to purchase in 

the future. They can also share their wish list with their friends. 

 My Cart: Enables customers to see the products that they have selected to purchase. 

 Checkout: Enables customers to start the checkout process in order to specify payment, 

billing, and shipping information. 

 Log In: Enables customers to identify themselves. 

 Log Out: Enables customers to log out of their accounts. 

The Footer 

The bottom of each of your web store pages includes a footer (see Figure 25). 

 

Figure 25. Web Store Footer 

This footer generally provides links to various informational and functional pages in the site, such as 

Contact Us and the Site Map. 

Categories 

Store Logo 

Search 

Various 
Functions 
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2.5 Purchasing Functionality  

Wishlist 

The Wishlist feature enables customers to pick out products which they are interested in, 

but not ready to order yet. Products can be moved from the Wishlist to the shopping cart 

with one click. Customers can also share the Wishlist with their friends right from the 

Wishlist section of the My Account page. The Wishlist feature is available for registered 

customers only. 

My Cart 

To add a product to your shopping cart, click on the Add to Cart button for that product, as shown 

in Figure 26. 

 

Figure 26. Add to Cart Button 

The My Cart area shown in Figure 26 displays a brief list of the products in your shopping cart. The 

Recently Added items(s) area shows a list of the last three items added to your shopping cart. 
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Clearing My Cart 

A customer who wants to remove all items from the shopping cart can do so by clicking the 

Clear Shipping Cart button on the Shopping Cart page (see Figure 27). 

 

Figure 27. Clearing the Shopping Cart 

Checking Out 

The My Cart area also provides a Checkout button (see Figure 28) that takes a customer to the first 

step of the one-page checkout process (see Figure 29). 

 

Figure 28. My Cart Area 

 

Figure 29. Checking Out 

Most of the functionality of the checkout process is available by default. In addition, the backend 

provides a variety of options to customize the customer checkout process, such as various payment 

and shipping methods that can be offered to your customers. 
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A customer can make a one-time purchase as a guest or register and create an account. Customers 

that have created an account can later track the status of their orders.  

Tip: Magento also provides multi-shipping functionality that enables customers to ship 
items to more than one address at the same time. This is a very useful feature for 
sending gifts, for example. This feature can be configured under System > 
Configuration > SALES > Shipping Settings > Options. 

Tip: Customers can also register and create an account by using the My Account or Log 
In link on the top right of each page. 

Figure 30 shows an example of checking out as a guest by selecting the Checkout as Guest option 

in the step above. 

Click Continue to see the next step in which the customer can enter the billing and identification 

information. 

 

Figure 30. Checkout as Guest 

Click Continue to specify the Shipping Address, select the Shipping Method, and select the Payment 

Method. 

The last step of the checkout process enables the customer to review the entire order, as shown in 

Figure 31. 
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Figure 31. Order Review 

Note: The right column shows the summary of information entered during the previous 
checkout steps and enables you to change any of the information that is incorrect. 

Customers then confirm the order and receive an order number, or they can change their minds and 

edit their carts using the Edit Your Cart link. If they proceed with the order and the payment is 

processed successfully, then a “Thank You” page is displayed, as shown in Figure 32. 

 

Figure 32. “Thank You” Page 

A confirmation email can be sent to the customer. An example is shown in Figure 33. The 

confirmation email can be configured by under System > Configuration > Sales Emails. 
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Figure 33. Confirmation Email 

2.6 Managing Customer Relations 

Customer Emails 

Magento can send a variety of automatically generated customer emails (such as when a customer 

places an order or opens an account) and enables you to customize them as you require. For more 

information about customizing the emails sent from the store to customers, see “Customizing 

Transactional Emails,” page 156. 

Ratings and Reviews 

Rating and review functionality is provided by Magento to enable customers and web store owners 

to give their opinions, feedback, and comments about products. They appear in the frontend, as 

shown in Figure 34. 
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Figure 34. Ratings and Reviews 

The number of stars indicates the satisfaction rating. You can click on the Review(s) link to display 

the actual textual reviews provided by customers. For more details, see “Managing Ratings and 

Reviews”, page 324. 

Community Polls 

Each web store can provide a Community Poll, as shown in Figure 35. For more details, see 

“Managing Polls,” page 329. 

 

Figure 35. Community Poll 
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3 Introducing the Backend 
In order to familiarize you with the features of the backend, this chapter describes, at a high level, the 

ongoing management tasks that you can perform in the backend while running your Magento web store on a 

day-to-day basis.  

See “Accessing the Backend,” page 37, for details on logging in to your store’s backend. 

See “Setting Up Your Catalog,” page 53, for a full description of how to set up your catalog. Each of the 

subsequent chapters features a description of the other aspects of customizing your backend. 

3.1 Understanding Scope 

Magento enables you to organize your operations into multiple websites, stores, and store 

views. (See “Store Hierarchy,” page 39, for descriptions of these terms.) Many of the 

configuration pages in the backend enable you to select the website, store, or store view 

that you want your configuration changes to apply to. Selecting the website, store, or store 

view is known as selecting the scope of your changes. 

To select the scope for configuration changes, use the Current Configuration Scope drop-

down menu in the upper left corner of the configuration page, as shown in Figure 36. 

 

Figure 36. Selecting Configuration Scope 

If you select Default Config, the option choices you make are applied as default values for all 

websites, stores, and store views. 

On the configuration pages, you will see scope indicators to the right of each option. These indicate 

the lowest level of the hierarchy at which you can set the value of these options. For example, the 

value of the Default Display Currency option may be set at the default (global) level, but can be 

overridden at the store view level, as indicated by the “[STORE VIEW]” indicator for that option (see 

Figure 37). 
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Figure 37. Scope Indicators 

3.2 Managing Administrator Messages 

When you log in to the backend, any new messages are displayed in a pop-up box. Typically, these 

messages are notifications of new Magento or extension releases. You can manage these messages 

much like you would manage your email. 

To display all the messages in your inbox: 

Click the Go to messages inbox on the top right of the page. The Messages Inbox page is displayed, 

which provides standard message handling features (see Figure 38). 

 

Figure 38. Messages Inbox Page 

You can mark selected messages as Read so that they do not appear again when you log in. You can 

also Remove marked messages so that they are permanently deleted. 
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3.3 Supervising Web Store Activities 

The Dashboard (Figure 39) is the first page to be displayed by default after you log in. It can also be 

accessed by clicking Dashboard on the Admin Panel top menu.  

 

Figure 39. Dashboard 

This page shows you basic information and statistics for managing your web store. The following 

describes the options in this page. 

Chart 

Orders tab: The Orders tab in the center of the page shows a graph that indicates the quantity of 

orders being processed in your web store for each point on the time scale within the specified 

range. The range is selected in the Select Range drop-down menu at the top of the chart. 

Underneath you can see the revenue, tax and shipping amounts of your orders and the total quantity 

of the orders. Only orders for which at least one invoice, shipment, or credit memo has been 

created or which have been created from external gateways (for example, PayPal Express) are 

included in the reports. 

Amounts tab: The Amounts tab in the center of the page shows a graph indicating the revenue for 

each point on the time scale within the specified range. The range is selected in the Select Range 

drop-down menu at the top of the chart. 

Revenue, Tax, Shipping, and Quantity: These statistics are calculated as follows: 

 Revenue = Total Invoiced Amount - Tax Invoiced Amount - Shipping Invoiced Amount - 

(Total Refunded Amount - Tax Refunded Amount - Shipping Refunded Amount) 

 Tax = Tax Invoiced Amount - Tax Refunded Amount 

 Shipping = Shipping Invoiced Amount - Shipping Refunded Amount 
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Note: Charts can be enabled or disabled under System > Configuration > ADVANCED 
> Admin > Dashboard. 

Left Information Panel 

The panel on the left shows you the total amount of orders handled in your Magento web store, the 

average amount of each order, information about your last five orders, and the last five and top five 

search terms. 

Bottom Information Tabs 

The bottom of the Dashboard (Figure 40) provides additional information about your web store, as 

follows: 

 

Figure 40. Additional Dashboard Information 

 Bestsellers Tab - Shows a list of the best-selling products in your web store, their price, and 

the quantity ordered.  

 Most Viewed Products Tab - Shows a list of the most recently viewed products and the 

number of times they were viewed. 

 New Customers - Shows a list of the most recently registered customers. 

 Customers - Shows a list of your top customers, meaning the customers that have ordered 

the most items from your web store in the last year. 

3.4 Managing Orders 

This section first describes how to view and manage orders, as well as how to create orders from the 

backend. 
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Viewing the Orders in Your Web Store 

To view the orders in your web store: 

In the Admin Panel, select Sales > Orders to display the Orders page, as shown in Figure 41. 

 

Figure 41. Orders Page 

This page displays a list of the orders placed in your web store.  

The following describes some of the options for managing orders in this page: 

 Quantity of Orders Displayed: The top part of the page enables you to control how many 

orders are displayed in the page, as shown in Figure 42. 

 

Figure 42. Order Display Controls 

 Selecting Orders: The area under the order display controls enables you to select/unselect 

all the orders in your web store or to select/unselect all the orders currently visible, meaning 

those that are currently displayed in this page. See Figure 43. 

 

Figure 43. Order Selection Controls 

Note: You can also select individual orders by selecting the check box on the left of 
each order.  

 Filtering Orders: The area under the order selection controls enables you to filter the orders 

that are displayed by specifying values in one or more of the fields and then clicking Search. 

To display all orders, click Reset Filter. See Figure 44. 

 

Figure 44. Filtering Controls 

Note: The list displays only those orders that meet all the criteria that you specified. 

 Sorting orders: Click on the header of a column to sort the orders by the value of that 

column. Each click toggles between an ascending sort and a descending sort. 

Filtering 

Sorting 
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 Order actions: The Actions drop-down menu provides a list of actions that may be 

performed on the selected orders. The actions that can be performed include the following: 

 

o Cancel: Sets the order status to Canceled and disables any further processing. 

o Hold: Puts the order on hold. The order is not affected in any way, but no further 

action may be performed unless you release it from Hold status. 

o Unhold: Releases the order from Hold status.  

o Printing options: These options enable you to print various documents related to 

the order. 

 Viewing an order: To view and/or edit an existing order, click row for the desired order or 

click the View option in the order’s row in the Action column. The Order View page opens, 

showing details about the order. 

Viewing an Order’s Details 

Magento provides a large variety of information for each order. This section provides a quick review 

of some of the information provided for an existing order. The navigation bar at the top of the Order 

View page enables you to access the various sections: Information, Invoices, Credit Memos, 

Shipments, Comments History, and Transactions. 

Information Page 

This page provides an overview of the most important information about the order, such as the 

current status of the order, the products ordered, customer information, billing, shipping, and 

payment information. See Figure 45. 
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Figure 45. Order Information Page 

Note: The SKU (Stock Keeping Unit) specifies the product code that is used to keep 
track of the actual inventory. SKUs are defined during product creation. For details 
about managing your product catalog, see “Setting Up Your Catalog,” page 53. 

The Comments History area of this page provides information about the lifecycle of the order. Every 

time that an invoice, shipment, or credit memo document is created, a record with each document’s 

identification is added on this tab. Also, here you can find out whether the customer was notified 

about the creation of each order document. For each partial refund, the system provides the order 

amount to be returned to the customer. You can change the order status in the Status drop-down 

menu.  

To add a comment to the order:  

1. Specify the comment text in the Comment text box. 

2. If you want to send the comment to the customer by email, select the Notify Customer by Email 
check box. 

3. If you want to make the comment visible in the order view on the frontend, select the Visible on 
Frontend check-box to specify that the customer is sent a copy of the comments that you add in 
the Comment box. 

4. Click Submit Comment.  
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All comments are stored on the Comments History page. To open it, click the Comments History tab 

on the left. 

Invoices Page 

An invoice represents a confirmation of payment. The Invoices page enables you to view the list of 

invoices generated for an order.  

You can generate an invoice individually or together with a shipment. If the products in an order are 

shipped in multiple shipments, then an invoice is generated for each shipment for the products in 

that shipment.  

Credit Memos 

The Credit Memos page displays a list of the refunds given for products in this order. You can click 

on a credit memo in the list to display the refund details. 

Shipments Page 

A shipment is a record of the products in an order that have been shipped. As with invoices, 

multiple shipments can be created per order. 

The Shipment page displays a list of the shipments sent for products in this order. You can click on a 

shipment in the list to display the shipment details.  

On the Shipment page, you can also add tracking numbers that were received from shipping service 

providers. The tracking number enables customers to learn the status of the shipments in their orders 

using the My Account option that appears in the header of the frontend. For the supported shipping 

service providers you can create and print shipping labels form the Shipment page. 

Comment History Page 

The Comment History page enables you to view a list of comments that have been added to the 

order record over the course of its life cycle. It is a good practice to add comments at every stage of 

the order, especially if problems come up. 

Transactions Page 

The Transactions page enables you to view a list of transactions that are associated with this order. 

Creating New Orders 

You may want to create an order using the backend, for example when an order is received over the 

phone. 



Introducing the Backend 

36 

Tip: Typically, orders are placed by customers in the frontend. In addition, you can 
create orders in the backend. This enables you to take orders by phone, mail or fax 
and then enter them into your web store to be managed and tracked. This feature is 
useful for call center operators to take orders directly from your customers. The 
ordering process in the backend is not much different from the one your customers 
experience. The backend provides all the same functions that your customers have 
when creating an order from your web store, including the ability to move products 
between the shopping cart and wishlist. It also enables you to give customers 
special prices and discounts. 

To create a new order from the backend: 

1. Select Sales > Orders.  

2. Click the Create New Order button on the top right. 

A full description of this procedure is provided in “Managing Orders,” page 317.  

3.5 Managing Ratings and Reviews 

Rating and review functionality is provided by Magento to enable customers and web store owners 

to submit their opinions, feedback, and comments about products. Product reviews and ratings can 

also be added using the backend. To access the ratings and reviews management features, select 

Catalog > Reviews and Ratings. 

For more information about ratings and reviews, see “Managing Customer-Generated Content,” 

page 324. 

3.6 Generating Reports 

Magento provides a variety of reports that you can access at any time. These reports are available 

under the Reports menu at the top of the Admin Panel. 

Some of the most important reports are described in “Reports,” page 334. 
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4 Basic Configuration 
This chapter describes how to configure the basic information for your web store. The other aspects of your 

web store to be configured are described in the subsequent chapters of this guide. 

4.1 Accessing the Backend 

All of the basic configuration tasks are performed in the Magento backend. The following describes 

how to access and log in to the Magento backend.  

Tip: Immediately after you install Magento, you can easily open the backend by 
clicking the Go to Backend button on the last page of the Magento Installation 
Wizard. We recommend that you bookmark the backend page for easy access. 

To access the Magento backend administration environment: 

1. Use a standard web browser to navigate to the backend by entering the URL that you specified 
in the Magento Installation Wizard with the addition of the suffix /admin (or the one that you 
specified during installation). For example, if you specified mywebstore.com as the base URL, 
then use http://www.mywebstore.com/admin to access your backend. 

Note: The Magento EE Demo Store backend can be accessed at: 
http://enterprise-admin.magentocommerce.com/index.php/admin/ 

The Log in to Admin Panel page is displayed, as shown in Figure 46. 

 

Figure 46. Backend Login Page 

2. Log in using the user name and password that you created during the installation process.  

Note: The backend of the Magento Demo Store can be accessed using the User Name: 
admin and Password: 123123 

3. Click the Login button to display the administration panel, as shown in Figure 47. 

http://enterprise-admin.magentocommerce.com/index.php/admin/
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Figure 47. Magento Backend 

4. After you log in, the Magento messages that you have not yet read are displayed, such as the 
one shown in Figure 48. 

 

Figure 48. Incoming Message Notice 

Additionally, information about other messages is shown in a bar just under the menu (see 

Figure 49). See “Managing Administrator Messages,” page 29, for more information about 

managing these messages. 

 

Figure 49. Message Bar 
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4.2 Store Hierarchy 

Among the first things you will want to do is plan your store hierarchy, that is, the 

arrangement of websites, stores, and store views. When Magento is installed, a “Main 

Website,” a default store, and a default store view are created. You will want to create 

additional websites, stores, and store views, depending on the breadth of the items you are 

selling and the composition of your target markets. 

To be able to create these entities, you need to create at least one root category first. See 

“Managing Categories,” page 62, for more information about creating root categories. For 

now, determine how you want your store hierarchy set up. 

Websites 

Suppose you want to sell machine shop equipment online, and your spouse wants to sell handmade 

baskets. It is unlikely that you would sell both of these product lines in a single store, but in a single 

Magento installation, you can do both by setting up separate websites. Each website can have its 

own domain name. The websites can be set up to share customer data, or not to share any data. 

Stores 

For your handmade baskets website, you might want to set up two stores, one specializing in wicker 

and one for other materials. You can set up two root categories (one for wicker items and one for 

other items) and assign one to each store. (See “Managing Categories,” page 62, for more 

information about setting up root categories). Several stores of one website can have different 

independent domain names as well, but it should be configured on the store view level of each 

store. 

Store Views 

Your market research indicates that about half of your potential customer base speaks English, and 

the other half speaks Spanish. Within each store, you can create separate store views, one for 

English and one for Spanish. The store views share the same catalog, but each is presented in its 

respective language. Customers use a drop-down menu on the frontend to switch from one store 

view to another. 

4.3 Store Pages General Configuration 

This section describes how to configure general aspects of your frontend pages. These 

configurations are performed in the Configuration area of the Admin Panel. 
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To access the Configuration section, select System > Configuration. The tabs in the left 

column provide access to configuration options for different aspects of your Magento 

instance. The Current Configuration Scope drop-down menu in the upper left corner of the 

page enables you to select the hierarchy level (website, store, store view) to which the 

configuration will be applied. To apply configuration settings at the global level (that is, for 

all your websites, stores, and store views), leave Default Config selected. 

To open the options for configuring your store pages design click the Design tab in the left 

column. The Design page opens with a number of field sets. See Figure 50. 

 

Figure 50. Design Configuration Page 

HTML Head Field Set 

The settings in the HTML Head field set on the Design tab are used to define general information 

about your store’s pages. These settings may not be visible to your customers, but they are important 

for things such as traffic analytics and search engine optimization. 

To define general page features: 

1. Click the HTML Head heading to expand the field set as shown in Figure 51. 
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Figure 51. HTML Head Field Set 

Note: The words in square brackets (for example, [STORE VIEW]) indicate the scope of 
the associated option. 

2. Click the Browse button and select an icon file (on your local computer) to use as a “favicon.” 
This small icon appears in the address bar of your customers’ browsers. 

3. In the Default Title field, specify the page title to be displayed in browsers for those pages that 
do not have their own title. This information is also used to improve search engine visibility and 
performance.  
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4. In the Title Prefix and Title Suffix fields, specify a prefix and a suffix to be appended to the pages 
of your web store that have their own title, such as a prefix of My Web Store. 

5. In the Default Description and Default Keywords fields specify words that describe your web 
store to be used by search engines when page-specific information is not provided. Keywords 
must be separated by commas. 

6. Optional. Select Display Demo Store Notice to display a notice at the top of every page that 
indicates that this is a demo store and that no transactions will be processed. This option is 
useful while you are setting up your store prior to opening for business. 

7. Click the Save Config button on the top right of the page. 

Header Field Set 

The options on the Header field set define the look of the top of each page in your store. 

To define the header of each web store page: 

1. Click the Header tab to expand the section as shown in Figure 52. 

 

Figure 52. Header Field Set 

2. In the Logo Image Src field, specify the logo graphic file to appear on the top left of each page 
of your web store, as shown in Figure 53 for the Magento Demo Store. Make sure that you 
name your logo something other than logo.gif, so it does not get overwritten in future upgrades. 

 

 

Figure 53. Page Header Section 

Note: You will need to upload the image file using an FTP client to the 
skin/frontend/default/default/images/ directory or to your own skin folder in your 
Magento installation. 

3. In the Logo Image Alt field, specify the alternative text to be displayed when your customers 
hover their mouse cursors over the logo image in your web store. 

4. In the Welcome Text field, specify the welcome message to be displayed on the top right of 
your web store for customers that are not logged in, as shown in Figure 53. 

5. Click Save Config to save your changes. 

Logo Image Welcome Message 
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Footer Field Set 

The options in the Footer field set define what is displayed at the bottom of each web page in your 

store. 

To define the footer of your web store pages: 

1. Select the Footer option to expand the page to display the footer options, as shown in Figure 54. 

 

Figure 54. Footer Field Set 

2. In the Copyright field, specify your web store’s copyright information. 

3. In the Miscellaneous HTML field, specify the custom HTML code to be added to the end of the 
page code that is generated by Magento. This area is usually used for adding tracking scripts 
that track your customers’ activity on the site. 

4. Click Save Config to save your changes. 

4.4 Store Contacts Configuration 

This section describes how to configure store email addresses that are used for internal and external 

email communications and the Contact Us feature. 

Web Store Emails  

The Store Email Address page of the system configuration enables you to specify email addresses 

and contact names to be used when sending email to customers upon registration and at all steps of 

the order lifecycle. These email address are also used for sending error reports to the store 

administrator. 
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To define web store email addresses: 

1. In the Admin panel, select System > Configuration > GENERAL > Store Email Address. Here you 
can configure the various email addresses used for sending emails from your web store to your 
customers. See Figure 55. 

 

Figure 55. Store Email Addresses Page 

2. In the Current Configuration Scope drop-down menu in the left upper left corner, select the 
scope for which you want these configurations to apply. All fields on this page can have 
different values for each store view. 

3. In each Sender Name field, specify the name of the sender or department from which the emails 
are sent. 

4. In the Sender Email field specify the email address used for sending the emails. 

5. Click Save Config to save your changes. 

Note: See “Customizing Transactional Emails,” page 156, for more information about 
emails. 

Contacts 

These options define the email to which customers send requests when using the Contact Us option 

at the bottom of the pages of your web store. 

To define your web store contact information: 

1. In the Admin Panel, select System > Configuration > GENERAL > Contacts to display the 
Contacts page, as shown in Figure 56. 
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Figure 56. Contacts Page 

2. In the Current Configuration Scope drop-down menu in the left upper left corner, select the 
scope for which you want these configurations to apply.  

3. In the Enable Contact Us drop-down menu, select Yes to enable customers to contact you by 
email with the Contact Us link, or select No to disable this communication method. 

4. In the Send Emails To field, specify the email that is used for receiving feedback when a 
customer uses the Contact Us option in the store. 

5. In the Email Sender drop-down menu, select the email address from which feedback messages 
are sent. 

6. In the Email Template drop-down menu, select the template to be used for the Contact Us form 
displayed on the frontend. You can create custom email templates. For more information, see 
“Customizing Transactional Emails,” page 156. 

7. Click Save Config to save your changes. 

Sales Emails 

You can configure Magento to send emails that confirm an order, invoice, shipment, or credit memo 

to both registered customers and store guests. 

To configure sales emails sent to customers: 

1. In the Admin Panel, select System > Configuration > SALES > Sales Emails. 

2. In the Current Configuration Scope drop-down menu in the left upper left corner, select the 
scope for which you want these configurations to apply. 

3. Click the Order heading to expand the Order field set, as shown in Figure 57. 
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Figure 57. Sales Emails Page 

4. In the Order field set, configure the following options: 

 In the Enabled drop-down menu, select Yes to enable new order confirmation emails to be 

sent. 

 In the New Order Confirmation Email Sender drop-down menu, select the email address to 

be used for sending the new order confirmation. 

 In the New Order Confirmation Template drop-down menu, select the template to be used 

for the for the order confirmation emails sent to registered customers. 

 In the New Order Confirmation Template for Guest drop down menu, select the template to 

be used for the for the order confirmation emails sent to guest customers. 

 In the Send Order Email Copy To field, specify the email address to which a copy of the 

new order confirmation email is sent. This feature helps you to keep track of the new orders 

that come in. 

5. Configure the options on the other field sets on this page. 

6. Click Save Config to save your changes. 

4.5 Shipping Settings 

This section describes how to specify shipping options, such as the origin used for shipping rate 

calculations and whether to enable the multiple shipping destinations feature. 
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Configuring shipping settings and shipping methods enables you to provide customers a selection of 

shipping methods with shipping rates during checkout. Magento includes extensive integration with 

major shipping carriers; for USPS, DHL, FedEx, and UPS, you can create shipment orders and print 

shipping labels right from the Magento Admin Panel. See “Shipping,” page 165, for details about 

shipping system integration. 

To define general shipping options: 

1. In the Admin Panel, select System > Configuration > SALES > Shipping Settings. 

2. In the Current Configuration Scope drop-down menu in the left upper left corner, select the 
scope for which you want these configurations to apply. 

3. Click the Origin and Options tabs to expand the page to display the shipping options, as shown 
in Figure 58. 

 

Figure 58. Shipping Settings Page 

4. Configure the options to match your store. 

5. Click Save Config to save your changes. 

See “General Shipping Settings,” page 165, for details about configuring shipping methods. 

4.6 Cookie Restriction Mode 

Magento can notify store customers about cookies that are being used by your store. The feature is 

called Cookie Restriction Mode. It is aimed at helping store owners to comply with the European 

Union Privacy and Electronic Communications Directive and its amendment. According to these 

regulations, websites cannot use cookies until a user consents.  
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Enabling and Configuring Cookie Restriction Mode 

To enable the cookie restriction mode: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration > GENERAL > Web. 

3. In the Current Configuration Scope in the upper-left corner of the page select the desired 
website. 

4. Expand the Session Cookie Management field set.  

5. In the Cookie Restriction Mode field select Yes. 

6. To save the changes click the Save Config button. 

Important Note (for Magento Enterprise Edition only): Enabling the cookie restriction 
mode enables the notification of customers about cookies being used by a store. To 
actually stop using cookies which are related to customer private information, such 
as cookies storing the customer ID or recently compared products list, you need to 
disable the Full Page Cache (FPC) functionality. FPC can be disabled under System 
> Cache Management. For more information about full page cache, see “Full-Page 
Caching,” page 373. 

Cookie Restriction Mode: Implementation Details 

After the cookie restriction mode is enabled, a message is displayed on the top of each page in the 

store front. The message informs customers that the website requires cookies to provide all of its 

features and requests users to confirm that they are informed and consent. See Figure 59. 
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Figure 59. Cookie Restriction Warning Message  

The message contains a link to the Privacy Policy page, which provides a list of cookies being 

collected and explains on how they are used. The default content of this page can be changed 

under CMS > Pages > Manage Content > Privacy Policy. 

After a customer clicks Allow, the message disappears.  

If a customer does not click Allow, the message persists, but the store functionality is available as 

usual. However, Google Analytics cookies are not stored in this case, even if the Google Analytics 

functionality is enabled.  

Cookies Used in Magento 

The following table lists cookies, which are always stored by Magento on the customer’s side. 

Cookie Name Cookie Description 

USER_ALLOWED_SAVE_COOKIE Indicates whether a customer is allowed to use cookies 

external_no_cache A flag which indicates whether caching is disabled 

persistent_shopping_cart Session key 

Stf If links to a product were sent to friends, this cookie stores the timestamps 

in the '$timeStamp1, $timestamp2, ..., $timestampN' format. 
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Cookie Name Cookie Description 

pollN A poll ID to indicate that the poll has been already voted. 

frontend Session ID 

guest-view Allows guests to edit their orders. 

 

The following table contains a list of cookies, which Magento additionally stores on the customer’s 

side if the Full Page Cache functionality is enabled.  

Cookie Name Cookie Description 

CUSTOMER Hashed value of a customer ID in the 'customer_$customerId' format 

CUSTOMER_INFO Hashed value of a customer group ID in the 

'customer_group_$customerGroupId' format 

NEWMESSAGE Indicates whether a new message has been received  

CART Hashed value of a quote ID in the '$quoteId' format 

COMPARE List of product IDs added by customer to compare list in the '$productId 

1, $productId 2, ..., productId N' format 

POLL ID of a recently voted poll 

RECENTLYCOMPARED A customer's list of recently compared product IDs in the '$productId 1, 

$productId 2, ..., productId N' format 

WISHLIST Hashed list of products added to Wishlist in the '$productId 1_$productId 

2_..._productId N' format 

WISHLIST_CNT Hashed number of items in the customer's Wishlist in the 

'wishlist_item_count_$productCount' format 

CUSTOMER_AUTH Indicates whether a customer is logged in. A hashed value of 

'customer_logged_in_0|1' 

CATEGORY_INFO Stores the category info on the page. This allows displaying pages more 

quickly. 

LAST_CATEGORY Recently visited category ID in the '$categoryID' format 

VIEWED_PRODUCT_IDS Recently viewed product IDs in '$productId 1, $productId 2, ..., 

productId N' format 

currency Code of the currency selected by a customer ('USD', 'UAH', 'GBP', etc.) 

store Store view code 

NO_CACHE Indicates whether it is allowed to use cache 

LAST_PRODUCT Last viewed product ID 
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If the Google Analytics module is enabled and using cookies is allowed by a customer, Magento 

stores the following Google Analytics cookies: 

 _utma 

 _utmb_ 

 _utmc 

 _utmz. 

For a description of the Google Analytics cookies, refer to the official Google documentation. 

 

 





 

 53 

 

PART II: PRODUCTS AND PRODUCT CATALOGS 

5 Setting Up Your Catalog 
This chapter describes how to create a catalog for your Magento web store. “Product Categories and Product 

Attributes,” page 62, describes how to add products and define their attributes.  

5.1 Overview 

The best workflow for creating your products is as follows: 

Step 1

Step 2

Step 3

Step 4

Step 5

 

page 54 

page 63 

page 73 

page 76 

page 80 

The following describes the process depicted above:  

 Step 1: “Setting Up Catalog Defaults,” page 54. This step describes how to set basic catalog 

default configurations that define its behavior.  

 Step 2: “Creating Categories,” page 63. The next step is to create the categories that will 

contain your products. Each product can be assigned to one or more categories. 

A Magento store with Sample Data provides three such categories: Furniture, Electronics, 

and Apparel. Categories can have multiple levels of subcategories. A customer can click on 

a category to see a drop-down menu of subcategories, such as Cell Phones, Cameras, and 

Computers, as shown in Figure 60. 

Creating Categories 

Creating Attributes 

Creating Attribute Sets 

Creating a New Product 

Setting Up Catalog Defaults 
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Figure 60. Categories and Subcategories 

 Step 3: Creating Attributes, page 73. Next, you can create the attributes that represent a 

product’s characteristics. Attributes are a powerful Magento concept to make finding and 

comparing products easier. 

 Step 4: Creating Attribute Sets, page 76. Attribute sets are logical groups of attributes that 

simplify the process of assigning attributes to a product. They do not appear in the frontend. 

o Creating a New Attribute Group, page 78. Part of the process of creating an 

attribute set is to create attribute groups. These groups determine how attributes 

appear in the backend when defining a product. 

 Step 5: Creating a New Product, page 80. This step shows how to fill in product information 

in order to maximize conversion and how to assign Categories to help customers navigate 

to the products of interest to them. Attribute sets and attributes are assigned to products to 

describe them, provide multiple options and help the customer search through the product 

list.  

5.2 Setting Up Catalog Defaults 

The first step to creating your catalog is to configure the catalog system default settings. In many 

cases, these settings can be overridden at lower levels (such as in individual categories and 

products).  

To configure catalog defaults: 

In the Admin Panel, select System > Configuration > CATALOG > Catalog. In the Current 

Configuration Scope drop-down menu, select the scope of this configuration. The following 

describes some of the more important sections in the page. 

Frontend 

This section determines how your products are shown on the frontend catalog pages. See Figure 61. 
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Figure 61. Catalog Frontend Configuration 

 List Mode 

o Grid Only: The products are displayed only in a grid structure. 

o List Only: The products are displayed only in a list. 

o Grid (Default)/List: The products are displayed in a grid structure by default, but 

your customers are able to switch to list. 

o List (Default)/Grid: The products are displayed in a list structure by default, but your 

customers are able to switch to grid.  

 Products per Page: For each display type (List and Grid), do the following: 

o Specify, in a comma-separated list, what the options are for the number of products 

to display on a product page. These options will be listed in a drop-down menu on 

the frontend. 

o Specify how many products are displayed on a page by default.  

 Allow All Products per Page: Select whether the customers are allowed to display all 

products on a single category page. 

 Product Listing Sort By: The products are sorted, by default, by the selected attribute. The 

Best Value products are featured products as determined by the store administrator; for 

more information, see “Creating Categories,” page 63. The customer can select from the 

other options on a per-page basis. 

You can configure attributes to be used for sorting using the Used for Sorting in Product 

Listing setting of an attribute. For details, see “Managing Product Attributes,” page 72. 
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 Use Flat Catalog Category: Selecting Yes “flattens” multiple category database tables into a 

single table for increased performance on the frontend. Magento recommends selecting Yes 

for any size catalog. 

 Use Flat Catalog Product: Selecting Yes “flattens” multiple product database tables into a 

single table for increased performance on the frontend. Magento recommends selecting Yes 

if your catalog contains more than 1,000 SKUs. 

 Allow Dynamic Media URLs in Products and Categories: Selecting No can improve 

performance. 

Sitemap 

This section determines how your site map is displayed to customers. 

 Use Tree Like Category Sitemap: Selecting Yes displays the site map as a tree, showing all 

categories and subcategories as branches. Selecting No displays the categories and 

subcategories in a single column. 

 Minimum Lines per Page: Determines the number of lines on each page when the site map 

is distributed among several pages. 

Product Reviews 

This section enables unregistered guests in your store to write product reviews.  

Product Alerts 

You can enable your customers to subscribe to two types of customer alerts by email: price change 

alerts and in-stock alerts. For each alert type, choose whether to enable users to subscribe to it, and 

select the email template to use. Also, select a sender display name, which applies to both alert 

types (see Figure 62). For more information on how to configure email templates and email sender 

addresses, see “Customizing Transactional Emails,” page 156. 

 

 

Figure 62. Product Alerts Configuration 

The price change alert creates a Sign up for price alert link in every product page. Clicking this link 

subscribes your customers to this alert for that particular product so that they receive an email each 

time the product price is changed. This includes adding or changing Special Prices in addition to the 

regular Price field.  
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The in-stock alert creates a link called Sign up to get notified when this product is back in stock in 

every Out of Stock product. Clicking this link subscribes your customer to this alert so that they 

receive an email when the product status changes to In Stock.  

For each product, there is a tab listing all the customers subscribed to either of these alerts.  

Product Alerts Run Settings 

These settings enable you to select how often Magento checks for changes that require alerts to be 

sent. Additionally, you can select the recipient, sender, and template for emails that are sent if the 

sending of alerts fails. 

 Frequency: Choose how often product alerts are sent out: Daily, Weekly, or Monthly. 

 Start Time: Choose what time of day the product alert process starts. This time should be 

after any price or inventory updates are performed. 

 Error Email Recipient: Identify the email address of the person (normally a store 

administrator) who should receive an email notification when there is an error in the 

product alert process. 

 Error Email Sender: Select the role that the email will be “from.” 

 Error Email Template: Select the email template to use for product alert error notifications. 

For more information, see “Customizing Transactional Emails,” page 156. 

Product Image Placeholders 

This section enables you to specify an image for each of the sizes that are used instead of the 

product image, if it is missing. 

Recently Viewed/Compared Products 

This feature is described in detail in “Recently Viewed,” page 15. The configuration section enables 

you to specify how many products are shown by default in each list. See Figure 63. 

 

Figure 63. Recently Viewed/Compared Products Settings 

Price 

The Price section contains only the Catalog Price Scope drop-down menu, in which you can select 

the scope of the base currency (Global or Website). 
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Layered Navigation 

The Layered Navigation section enables you to choose whether the price ranges that are displayed 

in the layered navigation tool are calculated automatically or manually. If you select Manual, the 

Default Price Navigation Step field becomes visible, enabling you to specify the default size of the 

price ranges. 

Category Top Navigation 

The Category Top Navigation section enables you to define how many levels of subcategories are 

displayed by clicking on a category in the top navigation bar on the frontend. Setting this value to 0 

(zero) enables all levels to be displayed. If you have a large number of subcategory levels, this can 

potentially make it difficult for the user to navigate. 

Search Engine Optimizations 

In order to make your site more search engine friendly, configure the following parameters, as 

shown in Figure 64:  

 

Figure 64. Search Engine Optimization Settings 

 Auto generated Site Map: Enable this feature to display a Site Map link in the footer of the 

frontend pages. This enables a customer to view an automatically generated site map 

including a list of all of your existing categories. In addition to the auto-generated site map, 

Magento enables integration with Google Sitemap. More information is provided on the 

following pages. 

 Popular Search Terms: Enable this feature to display a Search Terms link in the footer of the 

frontend pages. This enables customers to link to a list of all search terms. This is an SEO 

feature because each of these search terms counts as a link to your site and is explored by 

search engines to discover content on your site. 
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 Product URL Suffix and Category URL Suffix: These options determine which suffix is 

displayed on each product and category page. Typically this value will be .html or .htm. 

When you change this value (and click Save Config), you must perform a cache refresh by 

selecting System > Cache Management and clicking Flush Magento Cache. 

 Use Categories Path for Product URLs: This option determines how the URL is composed. 

Select Yes to specify that the URL links for products include the associated category and a 

separate link is generated for each associated category. Select No to specify that the URL 

rewrites include only the product name and that there is only one link for each product, 

regardless of how many categories the product is associated with. 

 Create Permanent Redirect for old URLs if URL key changed: Selecting Yes automatically 

creates a redirect for the old URL that points to the new URL if a page is moved. Doing so 

eliminates the “404 Not Found” error message that customers see if a page they had 

bookmarked is moved. 

 Page Title Separator: Specify a character to replace the space character ( ) with when the 

system uses the page title to construct the page’s URL. Typically you would use an 

underscore (_) or hyphen (-). 

 Use Canonical Link Meta Tag For Categories and Use Canonical Link Meta Tag For 

Products: Select whether to add a tag to each category or product page that points to a 

“preferred” URL for search engines to index when encountering pages that contain the same 

content (but which may be sorted differently, for instance). 

Catalog Search 

The options in this section define how the catalog search feature behaves. 

 Minimal Query Length: Defines the minimum number of characters that the customer must 

specify in the Search field on the frontend. 

 Maximum Query Length: Defines the maximum number of characters that the customer 

may specify in the Search field.  

 Maximum Query Words Count: Define the maximum number of terms that can be specified 

in the Search field. This limit applies to the “Like" search type only.   

 Search Type: Define the type of search that is performed: 

o Like: Includes only results that are close in spelling to the specified search terms. 

o Fulltext: Includes only results that exactly match the specified search terms. 

o Combine (Like and Fulltext): Includes both exact matches and close matches.  

 Apply Layered Navigation if Search Results are Less Than: Defines the maximum number of 

results for which layered navigation can be applied. If the number of results is more than 

this number, then the results are presented as a simple list. If you specify 0, then layered 

navigation is always applied. Limiting the number of results can increase performance. 

Downloadable Products Options 

This section controls the settings for products of Downloadable type. The most important settings 

are the following, as shown in Figure 65: 
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Figure 65. Downloadable Products Options 

 Order Item Status to Enable Downloads: Controls whether customers can access their 

downloadable product links immediately after the order is placed or only after the invoice is 

created for the order.  

 Default Maximum Number of Downloads: Controls how many times a downloadable 

product may be downloaded by the customer after it has been purchased. 

 Shareable: Setting this option to Yes enables non-registered customers (guest customers) to 

access their downloads. This is the only option for customers to access their products if you 

want to offer guest checkout or quick checkout methods, such as PayPal Express or Google 

Checkout. This setting can be overridden at the product level. 

 Default Sample Title and Default Link Title: These settings control what is displayed 

throughout the store when referring to samples and downloadable products (links). 

 Open Links in New Window: Controls whether the download page opens in a new 

window. 

 Use Content-Disposition: Controls whether the content is opened in a browser window or 

downloaded. 

 Disable Guest Checkout if Cart Contains Downloadable Items: This setting disables the 

Guest Checkout option only if there are downloadable items in a cart, and leaves it enabled 

if a customer is purchasing other products. If you set this option to Yes, be sure to set the 

Shareable option to Yes as well. 

Date and Time Custom Options 

The options in this section control how dates and times are displayed in your store. 

 Use JavaScript Calendar: Enables your store to present a JavaScript-powered calendar date 

picker in any field that requires the customer to select a date. When this option is set to No, 

then drop-down menus are provided to select the date and time. 

 Date Fields Order and Time Format: Select the order in which the day, month, and year 

values are presented in the format xx/yy/zz., and select a 12-hour (a.m./p.m.) or 24-hour 

time format. These fields are important for store views that are targeted for specific countries 

that use date and time formats that are different from your local custom. 
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 Year Range: Indicate the range of years that is available for selection in either the JavaScript 

calendar or calendar drop-down menus. Use a four-digit year format. 
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6 Product Categories and Product Attributes 

6.1 Managing Categories 

This section describes how to display, create, and edit categories and subcategories. 

The products in the web store are grouped into categories. Categories enable you to give your store 

structure and form. In Magento, each store you create is assigned to a unique category. Any other 

category that you want to use in your store must be created as a subcategory. All categories are 

technically considered subcategories because you are placing them under the root category. See 

Figure 66. 

 

Figure 66. Example Category Structure 

The way category names are displayed on the frontend depends on the layout. If the default theme 

is used for the web store, categories are shown in a bar near the top of the store web page. 

Each product can be assigned to one or more categories, as described in “Finding the Right 

Products,” page 8. 
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Displaying Categories 

To display a list of all defined categories: 

Select Catalog > Manage Categories. The categories are listed in a tree view on the left, as shown in 

Figure 67.  

 

Figure 67. Category List 

 If you have loaded Sample Data, these sample categories (Furniture, Electronics and Apparel) will 

appear in the category tree. Disabled categories are listed in gray text. 

Creating Categories 

This section describes the most important steps in creating a category. 

To create a new category: 

 To create a new root category, make sure that Choose Store View in the upper-left corner of 

the page is set to Default Config, and click Add Root Category. 

 To create a subcategory, select the parent category (it can be either a root category or a 

category) in the list and click Add Subcategory. 

Four tabs of information are provided to describe this category: General Information, Display 

Settings, Custom Design, and Category Products. Click each tab and specify the requested 

information, as described below. 

Category 
List 
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Note: Required  fields appear with a red asterisk (*). 

General Information Tab 

Most of the fields in this page are self-explanatory. In this tab, you are asked to provide a category 

name, description, images (used to represent your category) as well as meta keywords and 

description for better search engine positioning. See Figure 68. 

 

Figure 68. Create a New Category – General Information 

1. Specify a name for this category in the Name field. 

2. Set the Is Active field to Yes to specify that this category appears in the store. 
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3. In the URL key field you can specify a relative URL path which can be specified in place of the 
standard Target Path. It is “search engine friendly” because it can use the name of the category 
instead of the ID number. If you leave this field blank, Magento will automatically generate a 
URL with the name of the category upon creation of the category. If you specify a value here 
manually, you cannot use spaces in this field. The URL key field is not displayed for root 
categories. 

4. For Thumbnail Image, use the Browse button to select and upload a thumbnail image to 
represent the category. 

5. Specify a description in the Description text box. This description is presented on the frontend. 

Note: You can use HTML tags in this text box. Alternatively, click the WYSIWYG Editor 
button to open a full-function HTML editor. The “What You See Is What You Get” 
(WYSIWYG) Editor includes a spelling checker, for which you need to download 
and install a plug-in for your browser. 

6. The Image field is used for a category image. Click the Browse button next to the field to select 
the file. This image will appear in the frontend for each category’s page between the category 
name and the content.  

7. In the Page Title field, specify the title of the page, which will be displayed on the browser tab 
header when the customer opens this category page. 

8. In the Meta Keywords and Meta Description text boxes, specify the keywords and description 
for search engines to use for this category when indexing your site. 

9. Select Yes for Include in Navigation Menu so that the category will appear in the navigation 
menu on the frontend. 

10. Click Save Category to save your changes. 

Display Settings Tab 

The Display Settings tab enables you to specify how this category is presented to the customer. See 

Figure 69. 

 

Figure 69. Create a New Category – Display Settings 
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1. In the Display Mode field, select one of the following options to specify how you would like 
your category page to appear: 

 Static block only 

 Static block and product list below it 

 Product list only  

2. In the CMS Block field, select the static block that you would like to be shown for this category 
(if selected in the Display Mode field). This block must first be created in the CMS section; for 
more information, see “Managing CMS Pages,” page 145.  

 In the Is Anchor field, select Yes to specify that this category page is an anchor. Anchors are 

used for the layered navigation in Magento, as described in “Layered Navigation,” page 68. 

o If you set the category to be an anchor for Layered Navigation, then your web store 

displays the subcategories of this category in the SHOP BY panel on the left. This 

area also shows a linked list of the filterable attributes of the products in this 

category and its subcategories.  

o Figure 70 shows the SHOP BY panel for the Apparel category, which is set as an 

anchor.  

 

Figure 70. Anchored Category 

3. For Available Product Listing Sort By, specify the attributes by which the customer can sort the 
list of products in this category. By default, all available attributes can be used for sorting; clear 
the Use All Available Attributes check box to modify the list. 

4. For Default Product Listing Sort By, select the attribute by which the product list is sorted by 
default. This is set in the catalog configuration (see “Setting Up Catalog Defaults,” page 54), but 
you can clear the Use Config Settings check box to select a default sorting attribute for this 
particular category. 

5. For Layered Navigation Price Step, specify the size of the price range to be used when 
calculating the price “buckets” for the Layered Navigation. This is set in the catalog 
configuration, but you can clear the Use Config Settings check box to specify a price range size 
for this particular category. 

Custom Design Tab 

The Custom Design tab contains additional settings to control the theme and layout updates that are used for 

this category page.  Depending on the settings they can also affect child pages as well. All of these settings 

are optional. For more information about custom designs and page layouts, see ”Design and Content,” page 

141. 
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1. For Use Parent Category Settings, choose Yes to “inherit” the settings of this subcategory from its 
parent category. Doing so ensures a consistent look within a category family, and disables all 
other settings on this page. This setting is not available for root categories. 

2. For Apply to Products, select Yes to apply the category page settings to the product pages of the 
products in this category. 

3. Select a custom design from the Custom Design drop-down menu. Magento comes with several 
custom designs already defined, and you can modify these custom designs or create your own. 
For more information, see “Managing CMS Pages,” page 145. 

4. For the Active From and Active To fields, select the start and end dates for this custom design to 
be applied to this category. If you do not select a start date, the custom design is applied 
immediately. If you do not select an end date, the custom design is applied to this category until 
you manually deactivate it. 

5. For Page Layout, select a layout from the drop-down menu: 

 No layout updates: Uses the default settings that come with the Magento installation 

 Empty: Displays the category page without any objects, except for the content (products or 

static blocks only), category name, and view options (number to display per page, view as 

grid or list, and sort be options) 

 1 column: Displays the contents, category name and view options, as well as the header, 

footer, search field, and navigation bar 

 Column on the left: Adds the left column to the 1 column display, which by default 

includes the currency selection and layered navigation 

 Column on the right: Adds the right column to the 1 column display, which by default 

includes the shopping cart view, Wishlist, compared products list, polls, and newsletter 

sign-up 

 3 columns: Displays both the left and the right columns 

6. The Custom Layout Update is essentially a static block, with a few differences. Rather than 
HTML, the structure must be in XML format. The Update will appear at the bottom of the page, 
below the products, whereas a static block will appear above the products (if the static block is 
set to display with products). The custom layout update will appear on the page only during the 
dates specified in the Active From and Active To date range. 

7. Click Save Category to save your changes. 

Catalog Products Tab 

This tab enables you to specify the products that belong to this category. See Figure 71. 
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Note: You can also assign a product to a category when editing a product’s record. For 
more information, see “Managing Products,” page 80. 

 

Figure 71. Creating a New Category – Products  

1. If needed, use the filter fields at the top of the table to filter the list of products. Click Reset Filter 
to clear all filter settings. 

2. Select the check box in the left column for each product that belongs in this category. 
Remember that a product can be assigned to more than one category. 

3. In the Position column, specify a whole number that indicates the order in which the product is 
listed when the products are sorted by Best Value. The product with a Position value of 1 is 
listed first, 2 is listed second, and so on. If more than one product has the same value for 
Position, the product with the lowest (that is, closest to 1) ID number is listed first. 

4. Click Save Category to save your changes. You may need to refresh the page to display the 
category in the tree. 

Editing Categories 

To edit a Category: 

Click on a category in the tree, edit its information and click Save Category. 

Layered Navigation 

What Is Layered Navigation? 

Of course, you want the customers browsing through your site to find the products that interest them 

in the fastest possible way. Otherwise, your sales opportunities are lost. When a customer is 

confronted with a category containing 60 products spread across multiple pages, most customers 

simply leave the site when they cannot find what they need on the first page. Magento enables you 

to provide customers with the option to find the products that they want by making a selection from 

a variety of filters, such as price, manufacturer, or any other aspect of the products, as shown in 

Figure 72. Layered navigation information is shown on category listing pages while searching for 

products. Show your customers what they want and you will raise conversions!  

The example in Figure 72 shows an enabled layered navigation filter by PRICE range and COLOR. 
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Figure 72. Layered Navigation 

Default Layered Navigation 

In Magento, two properties appear as navigation filters by default: PRICE and CATEGORY.  

 PRICE: Price ranges are selected logically in order to provide another filter for navigation. 

The ranges themselves are determined by the prices of products contained within 

them. There are never more than ten price ranges displayed at a time and products are 

distributed accordingly.  

 CATEGORY: If you define a category as an Anchor Category (see “Display Settings Tab,” 

page 65), its subcategories are displayed as layered navigation options. Figure 72 shows that 

the first filter is CATEGORY and it features two options: Shirts and Shoes. In this example, 

Shirts and Shoes are subcategories of the category that is represented by this layered 

navigation block.  

Defining Layered Navigation Filters 

The additional filters in Figure 72 are Manufacturer and Shoe Type. These are product attributes that 

have been selected as filterable. This is defined in the Use in Layered Navigation field under 

Catalog > Attributes, as described in “Creating Attributes,” page 73. 

There are two types of filterable attributes: 

 Filterable (with results): Links appear only for values where the number of results (the 

number in parentheses next to each value) is greater than zero.  

 Filterable (no results): Links appear for all values, regardless of the number of results.  



Product Categories and Product Attributes 

70 

In order for an attribute to appear as a layered navigation filter, the Catalog Input Type for 

Storeowner must be Dropdown, Multiple Select or Price. This controls the number of possible filter 

options and makes them consistent. 

Price Layered Navigation 

The Price Layered Navigation algorithm enables you to create price ranges so that products are 

evenly distributed among ranges. You can also split each range iteratively. 

The enhanced configuration controls for the Price Layered Navigation feature were introduced in 

Magento EE version 1.12. 

Configuring the Price Layered Navigation Algorithm 

The algorithm for calculating the price layered navigation is configured in the Magento Admin Panel 

under System > CATALOG > Catalog > Layered Navigation.  

To set and configure the new price layered navigation algorithm: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration > CATALOG > Catalog. 

3. In the Current Configuration Scope in the upper left corner of the page, select the desired store 
view. 

4. Expand the Layered Navigation field set. In the Display Product Count field, decide whether the 
number of products which fall into a price range will be displayed. 

5. In the Price Navigation Step Calculation field select Automatic (equalize product counts). 
Additional options appear. 

Note: The Automatic (equalize price ranges) option of the Price Navigation Step 
Calculation field is similar to the Automatic option which was available in previous 
versions of Magento. If you select the Automatic (equalize price ranges) option, the 
previously existing price layered navigation algorithm will be used. 

6. In the Display Price Interval as One Price field, decide what will be the system behavior if all 
products which fall into a certain price range have the same price. Select Yes if you want to 
display a single price (not the range finite values). 

7. In the Interval Division Limit field, specify the threshold for a number of products within a price 
range after which the range cannot be further split. The default value is 9. 

8. To save the changes click Save Config. 

Price Layered Navigation Algorithm: Customer Experience 

The price layered navigation algorithm provides the optimal distribution of products among price 

ranges. In addition, the feature provides iterative splitting of price ranges.  
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Previously, if a customer selected to view products from a certain price range, there was no further 

subdivision to smaller price ranges on the resulting catalog page. For example, if a store customer 

clicked the $0.00-$99 range, the price filter on the page with a list of products contained the 

selected range only. See Figure 73. 

 

Figure 73. Price Layered Navigation Without Iterative Splitting 

With the iterative splitting feature, after a customer chooses to view the $0.00-$99 range, the price 

filter on the page with a list of products can contain several sub-ranges. See Figure 74. 

 

Figure 74. Price Layered Navigation With Iterative Splitting 
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Note: A price range is not further split after the number of products which fall into this 
range reaches the threshold set in the Interval Division Limit field under System > 
Configuration > CATALOG > Catalog > Layered Navigation.  

6.2 Managing Product Attributes 

What Is an Attribute in Magento? 

An attribute represents a property of a product, such as its name, image, SKU, color, manufacturer, 

and so on. Attributes enable you to add new product properties without having to write a single line 

of code or to add any columns to your database. Understanding attributes is crucial for making your 

store easy to use for customers. 

You assign attributes to your products in order to enable your customers and search engines to find 

them more easily. Your Magento web store automatically displays products according to their 

attributes, for easy accessibility by your customers, in the SHOP BY layered navigation panel on the 

left of your web store. See Figure 75. 

 

Figure 75. Category Page with Layered Navigation 

Attributes also determine which products are displayed when a customer performs a search for a 

keyword. 

System attributes define the properties that are required by the store to function properly. These 

attributes cannot be deleted. 
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You can add as many additional attributes as desired. In the Magento backend you can define 

attributes in sets. Attribute sets ease the definition process so that similar products can be created 

with the same attributes. Attribute sets enable you to assign multiple attributes to a product at one 

time by assigning an entire attribute set to a product.  

If a store sells televisions, shoes, books, and power tools, then four attribute sets could be defined: 

one specific to televisions, one for shoes, and so on. When a new power tool product is added to 

your catalog, you can simply select the “Power Tool” attribute set to add the relevant attributes to 

this product.  

You should first define attributes, then define attribute sets and assign the relevant attributes to the 

attribute sets, as described in this section.  

Creating Attributes 

Attributes must be defined before defining attribute sets and products. 

Note: Only attribute sets can be assigned to a product, not individual attributes. 

To define attributes: 

1. Select Catalog > Attributes > Manage Attributes. A list of existing attributes is displayed, as 
shown in Figure 76.  

 

Figure 76. Manage Attributes Page 

2. Click Add New Attribute to display the New Product Attribute page (Figure 77) in which you 
can define a new attribute. 



Product Categories and Product Attributes 

74 

 

Figure 77. New Product Attribute Page 

3. In the Attribute Code field, specify a unique identifier for this attribute. Do not use spaces. This 
code does not appear on the frontend. 

4. In the Scope field select the scope to which this attribute applies. 

5. The Catalog Input Type for Store Owner setting controls how a store administrator specifies 
values for attributes. For descriptive textual attributes, you can use the Text Field or Text Area 
types; for list prices you use the Price type. Note that not all types can be used for layered 
navigation. 

6. If this attribute has a default value, specify it in the Default Value field. 

7. If the value of the attribute must be unique for each product (for example, a SKU number), 
select Yes for Unique Value. 

8. If the value of the attribute cannot be blank for any product, select Yes for Values Required. 
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9. In the Input Validation for Store Owner field, select the type of validation that should be 
enforced on values of this attribute. For example, if the values of this attribute will be email 
addresses, select Email to cause the system to check each entered value of this attribute against 
the rules for valid email addresses. 

10. If this attribute will apply only to certain Magento product types, select Selected Product Types 
for Apply To. In the list that appears, select one or more product types for this attribute (use 
Ctrl+click to select multiple items). 

11. For Use in Quick Search and Use in Advanced Search, select Yes to enable the quick search 
and advanced search tools to search this attribute’s values. 

12. For Comparable on Front-end, select Yes to have this attribute appear in the Compare window 
when products are compared. 

13. The Use in Layered Navigation field defines whether the attribute is used in layered navigation. 
The following options are available: 

  Filterable (with results): Only those attribute values that correspond to the existing products 

in your frontend catalog will be used in the layered navigation. 

 Filterable (no results): All values of the attribute that you have created on the Manage 

Label/Options tab will be listed. 

 No: Not used in layered navigation. 

Note that only attributes with the Dropdown, Multiple Select, or Price input type can be used in 

layered navigation. 

14. The Use for Promo Rule Conditions, field defines whether the attribute can be used in defining 
conditions for catalog and shopping cart price rules. 

15. The Position parameter determines the position of the attribute in the layered navigation block 
with respect to other filterable attributes. 

16. In the Visible on Product View Pages on Frontend field, select Yes to specify that this attribute 
appears in the Additional Information part of a product’s page in the web store, as shown in 
Figure 78. 

 

Figure 78. Attributes on the Additional Information Panel 

17. For Allow HTML Tags on Frontend, select Yes to enable HTML tags that are specified in this 
attribute’s values to be honored on the frontend. 

18. For Used in Product Listing, select Yes to list values of this attribute in the product listing. 
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19. For Used for Sorting in Product Listing, select Yes to enable the product list to be sorted by 
values of this attribute. 

20. Click Manage Label/Options at the top left of the page to display the Manage Label/Options 
page, as shown in Figure 79. 

 

Figure 79. Manage Label/Options Page 

21. In the Mange Titles box, specify a display name for this attribute for each store view. If you 
specify a value only in the Admin field, that value will be used in all cases. 

22. For attributes with an input type of Dropdown or Multiple Select, you can enter values that can 
be specified for the attribute. To add a value, click the Add Options button. You can specify a 
different label for the value for each store view and set the default value by selecting the Is 
Default option button. For the Dropdown input type, you can select the Is Default option button 
only for one attribute value. For the Multiple Select input type, you can select multiple values 
by selecting the Is Default check box next to the desired attribute values. See Figure 80. 

 

Figure 80. Attribute Value Specifications 

23. Click Save Attribute. 

6.3 Creating Attribute Sets  

An attribute set is a collection of attributes, customized to fit certain types of products. All attribute 

sets must contain all of Magento’s system attributes, but you can customize them to include different 

combinations of simple attributes. Only attribute sets (not individual attributes) can be assigned to a 

product. If you want to add a small number of attributes, you can add them to the Default set, but if 

you want to add attributes that will be applied only to a subset of products, it is advisable to create 

an attribute set for each set of attributes that you want to assign to products. An attribute set can 

inherit attributes from another attribute set. This feature saves you from redefining sets of attributes 

that apply to many different products.  
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To create a new attribute set: 

1. In the Admin Panel, select Catalog > Attributes > Manage Attribute Sets. A list of existing 
attribute sets is displayed, as shown in Figure 81. 

 

Figure 81. Manage Attribute Sets Page 

Note: Figure 81 shows the attribute sets that are provided in Magento’s Sample Data. 

Note: The Default attribute set is composed mostly of system attributes. This attribute 
set is typically inherited by all other attribute sets. 

2. Click the Add New Set button to display the Add New Attribute Set page (Figure 82). 

 

Figure 82. Add New Attribute Set Page 

3. In the Name field, specify the name of this attribute set. This name is used only in the backend. 

4. In the Based On field, select another attribute set from which this attribute set is to inherit. This 
enables you to reuse the attributes that are already defined in a set to build other attribute sets. 
The simple option is to leave the Default option that appears in this field. 

Click Save Attribute Set to display the Edit Attribute Set page (Figure 83). 
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Figure 83. Edit Attribute Set 

Note: System attributes are indicated by an icon with an orange dot.  

The top left of the page shows the name of the attribute set that you are defining. 

The center of the page shows a hierarchical tree representing groups of attributes. An attribute 

group is a logical grouping of attributes within an attribute set. See “Creating a New Attribute 

Group” below for a description of how to define attribute groups. 

The right side of the page shows a list of attributes defined in other attribute sets and not 

assigned to this attribute set. 

5. Assign attributes to this attribute set by dragging them from the Unassigned Attributes area on 
the right into a group in the tree in the Groups area. 

Creating a New Attribute Group 

The center of the Edit Attribute Set page shows a hierarchical tree representing groups of attributes.  

Attribute groups can be thought of as folders that contain attributes. Each group corresponds to a 

different tab on the product page in the backend. Magento comes with seven attribute groups by 

default: General, Prices, Meta Information, Images, Recurring Profiles, Design, and Gift Options. 

They contain the various system attributes. System attributes cannot be removed from an attribute 

set; however, they can be moved to other attribute groups. Therefore, you can remove an attribute 

group as long as there are no system attributes within it. The order of both the attribute groups and 

the attributes can be changed by selecting and dragging them. This affects the order of tabs and 

attributes on the product page in the backend, respectively. You can also create a new attribute 

group, to which you can move system attributes, or associate simple attributes. See Figure 84. 
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Figure 84. Attribute Groups 

To create a new attribute group: 

1. Click Add New in the Groups area to display a pop-up window asking for the group name. 

2. Specify the name of the new group and click OK. 

3. Click and drag attributes from the Unassigned Attributes area into the newly created group to 
assign them to this group. 

4. You can also click and drag attributes that are already assigned to move them between groups. 
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7 Managing Products 
This section describes how to define and edit products.  

Tip: You should first define attributes and an attribute set, as described in “Managing 
Product Attributes,” page 72, before you define products that have those attributes. 

7.1 Product Types 

Magento offers a variety of product types that enable significant flexibility when defining products. 

The following lists the available product types and their typical usage: 

 Simple Product: This is the most basic product type. It is suitable for all kinds of physical 

(shipped) products.  

 Grouped: This option enables you to display several similar products on a single page. For 

example, if you are selling chefs’ knives and you have the same knife in four sizes, you can 

make a grouped product to display all four of these sizes. Customers can select the size(s) 

that they want and the quantity they need, and add them to the cart from this page.  

 Configurable: This product type enables your customers to select the variant that they want 

by choosing options. For example, you can sell T-shirts in two colors and three sizes. You 

would have to create six variants as individual products (each with its own SKU) and then 

add these six to a configurable product where customers can choose the size and color, and 

then add it to their cart. A very similar functionality is possible by using Custom Options for 

Simple products. The difference between a configurable product and a product including 

custom options is that inventory is not checked or updated for individual options during the 

purchase of the latter and there is no possibility to go directly to a product with a given set 

of options. This also makes it hard for a search engine to find the product option. 

  Virtual Product: This is a product that does not require shipping or inventory. It is generally 

used for warranties or services. 

 Downloadable Product: This is a digitally downloadable product that sells one or more files 

of a product and provides samples of those files. These downloadable files can reside on 

your server or be provided as URLs to any other server. 

 Bundle: This product is composed of components that are presented in different ways and 

are made from existing products. A good example of a bundle is a complete computer. For 

this computer, you can configure how much RAM or what kind of monitor is included with 

this computer in your store. 

 Gift Card: This product is a physical or virtual gift card that can be used in your store. For 

more information, see “Gift Cards,” page 384. 

7.2 Creating a New Product 

The following steps are the same for all product types. Subsequent sections describe the differences 

between each of the product types. 
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To create a new product: 

1. In the Admin Panel, select Catalog > Manage Products to display the Manage Products page, as 
shown in Figure 85. 

 

Figure 85. Manage Products Page 

Note: Figure 85 shows the products defined in the Sample Data provided with 
Magento. If you downloaded Sample Data, then you may want to leave the 
products in for you to refer to as examples and delete them later. 

2. Click Add Product on the top right of the page to display the New Product page (Figure 86). 

 

Figure 86. New Product Page 

Product Wizard, First Page 

The New Product page is the first page of a product definition wizard that walks you through the 

process of defining a product.  

1. In the Attribute Set field, select the attribute set that contains the attributes that best describe this 
product. See “Managing Product Attributes,” page 72, for a description of how to define 
attributes. 

2. In the Product Type field, choose the type of product you want to create.  

3. Click Continue to display the General tab, as shown in Figure 87. (This tab may look different 
depending on the product type that you choose.).  
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Figure 87. General Tab 

General Tab 

Fill in all the mandatory fields, which are indicated by a red asterisk (*).  

 Name: The product name as it appears in the frontend.  

 SKU: The product’s store keeping unit (SKU). Magento uses SKU as a unique identifier for 

this product. SKU is global, meaning if you update the SKU for a product in one web store, 

it is updated in all other web stores as well.  

 Weight: The product’s weight. This value is usually used for shipping calculations. Specify 

only the number. Shipping service providers will interpret it according to the measurement 

units they use. 

 Status: Select Enabled to make this product available on the frontend. 

 Tax Class: The tax class of the product. See “Product Tax Class,” page 160, for more 

information.  

 Visibility: Determines whether the product is displayed in the catalog pages and/or search 

results. The following options are available: 

o Not Visible Individually: The product will not be displayed individually in the 

frontend; however, it can be a component of a composite, configurable, bundle, or 

grouped product. 

o Catalog: The product will displayed on pages of categories it is associated with, but 

it will not appear in search results. 

o Search: The product will be displayed when your customers search for it either 

using the quick or Advanced Search tools, but will not be displayed on the related 

category page. 

o Catalog, Search: The product will be available on category view pages with which 

it is associated and on the search results page. 

The following describes the other fields in this page: 
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 URL key:  The search engine-friendly URL identifier is the name used for this product in the 

product’s URL. You cannot use spaces in this field. If the URL key is left blank, one is 

automatically generated by Magento.  

 Manufacturer: Select the name of the manufacturer from the drop-down menu. 

 Color: Select the color of the product, if applicable. 

 Set Product as New from/to Date: The date range in which this product can be promoted as 

a new product in various locations throughout your site. 

 Country of Manufacture: Select the country in which the product was manufactured. 

 In feed: Determines whether this product is included in your store’s product RSS feed. 

Note: Additional fields may appear on this (and other pages) if you add attributes to the 
Default attribute set or base the product on another attribute set. 

Note: The Create New Attribute button opens a pop-up window that enables you to 
specify an attribute to be added to the selected attribute set. However, we 
recommend defining the attribute structure first. 

Prices Tab 

Click the Prices tab in the Product Information panel on the left to display the Prices tab, as shown 

in Figure 88. 

 

Figure 88. Prices Tab 

Fill in all the mandatory fields, which are indicated by a red asterisk (*). 

This tab enables you to specify the Price, Cost and Special Price information for this product. You 

can also add Tier Pricing, as described in “Tier Pricing,” page 291. 

 The Special Price field is used for discounting or promotions, as described in “Special 

Prices,” page 287. 
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 The Cost field is only used in the backend. It can be used for generating margin and profit 

reports. 

 The Apply Map, Display Actual Price, and Manufacturer’s Suggested Retail Price fields are 

used for implementing the Minimum Advertised Price feature for this product. For more 

information, see “Minimum Advertised Price,” page 293. 

Meta Information Tab 

Click Meta Info on the left to display the Meta Information tab, as shown in Figure 89. 

 

Figure 89. Meta Information Tab 

Specify information that enables search engines to more easily find and index this product.  

Images Tab 

Customers generally like to see what they are buying before they make a purchase. The Images tab 

enables you to upload pictures of your product. 

1. Click the Images tab on the left to display the Images tab, as shown in Figure 90.  

 

Figure 90. Images Tab 

2. Specify the image to be displayed in the web store to represent this product. Use the Browse 
button to select the image file from your local file system. 
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Tip: You can select more than one file in this window to upload multiple images at 
once. 

3. After you have specified the image files of this product, click the Upload Files button. The 
Images tab shows uploaded the image files, as shown in Figure 91. 

 

Figure 91. Images Tab with Images Uploaded 

4. Select the appropriate options for each of the images, as follows: 

 Label: Alternate text for the image tag 

 Sort Order: The order in which the images are displayed in the Slideshow and MORE 

VIEWS gallery  

 Thumbnail: Used in shopping cart and related items 

 Small Image: Used in the Category listing, Wishlist, and so on 

 Base Image: Large product image (zoomed in) 

 Exclude: Excludes the image from the Slideshow and MORE VIEWS gallery 

 Remove: Deletes the image from the collection; if the Remove check box is selected, the 

image will be removed after you save the product 

Description Tab 

Click Description on the left to open the Description tab, which enables you to create 

descriptions for the product (see Figure 92). 
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Figure 92. Description Tab 

Both of the fields on this tab are mandatory. For both fields, you can use the WYSIWIG editor to 

format your descriptions. 

 Description: The information that you specify in the Description field is shown in the 

product’s page under the title Product Description.  

 Short Description: The information that you enter in the Short Description field appears on 

the product’s page under the title Quick Overview. This information is also shown when 

products are displayed in a list. 

Design Tab 

The Design tab contains additional settings to control the appearance of this product’s product page, 

as shown in Figure 93. 
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Figure 93. Design Tab 

All of these settings are optional. For more information about custom designs and page layouts, see “Design 

and Content,” page 141. 

1. Select a custom design from the Custom Design drop-down menu. Magento comes with several 
custom designs already defined, and you can modify these custom designs or create your own. 

2. For the Active From and Active To fields, select the start and end dates for this custom design to 
be applied to this product. If you do not select a start date, the custom design is applied 
immediately. If you do not select an end date, the custom design is applied to this product until 
you manually deactivate it. 

3. The Custom Layout Update is essentially a static block, with a few differences. Rather than 
HTML, the structure must be in XML format. The Update will appear at the bottom of the page, 
below the products, whereas a static block will appear above the products (if the static block is 
set to display with products). The Custom Layout Update will appear on the page only during 
the dates specified in the Active date range. 

4. For Page Layout, select a layout from the drop-down menu. 

 No layout updates: Uses the default settings that come with the Magento installation 

 Empty: Displays the category page without any objects, except for the content (products or 

static blocks only), category name, and view options (number to display per page, view as 

grid or list, and sort-by options) 

 1 column: Displays the contents, category name and view options, as well as the header, 

footer, search field, and navigation bar 

 Column on the left: Adds the left column to the 1 column display, which by default 

includes the currency selection and layered navigation 

 Column on the right: Adds the right column to the 1 column display, which by default 

includes the shopping cart view, Wishlist, compared products list, polls, and newsletter 

signup 

 3 columns: Displays both the left and the right columns 

5. For Display Product Options In, select a location for the product options to appear in the layout. 
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Recurring Profile Tab 

By default, the Recurring Profile tab only appears for simple and virtual products. However you can 

configure it to become available for other product types, by changing the Apply To option of the 

Enable Recurring Profile attribute. A recurring profile enables you to set and configure recurring 

payments on a product. These are most often used for subscriptions or products with installment 

payment plans. When a product like this is purchased from your store, the customer is redirected to 

a third-party payment system where a “recurring payment agreement” with the store is authorized 

by the customer. Currently, creating recurring profiles is available only for the PayPal Express 

Checkout payment method. 

To enable a recurring profile for this product, select Yes for Enable Recurring Profile. Additional 

options become visible, as shown in Figure 94. 

 

Figure 94. Recurring Profile Tab 
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Most of the options on this tab are self-explanatory. For additional details on how recurring profiles 

work, see the http://www.magentocommerce.com/knowledge-base/entry/working-with-recurring-

profiles/ article in the Magento Knowledge Base. 

Note: Creating a recurring profile for a product does not create subsequent orders in the 
Magento Admin Panel. 

Gift Options Tab 

The Gift Options tab contains one option. The Allow Gift Message option determines whether 

customers are able to add a gift message to this particular product during checkout.  

The default value of this setting is controlled by a Sales configuration setting (System > 

Configuration > Sales >Gift Options). To change this option, clear the Use Config Settings 

check box. 

Inventory Tab 

The Inventory tab enables you to control various aspects of inventory management for this product. 

Many of the settings on this tab are controlled by the Inventory configuration settings (System > 

Configuration > Inventory). To override these configuration settings for this product, clear the 

appropriate Use Config Settings check box. 

1. Select the Inventory option in the left panel to display the Inventory tab, as shown in Figure 95. 

 

Figure 95. Inventory Tab 

2. In the Manage Stock field, select Yes to specify that all inventory options are available for this 
single product, or select No to specify that you do not want to manage product inventory (in 
this case, the product is permanently available in the store to your customers).  

3. In the Qty field, specify how many items of this product you have in stock. 

http://www.magentocommerce.com/knowledge-base/entry/working-with-recurring-profiles/
http://www.magentocommerce.com/knowledge-base/entry/working-with-recurring-profiles/
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4. In the Qty for Item’s Status to become Out of Stock field specifies that if stock quantity falls 
below this level, then the product becomes Out of Stock. 

5. The Minimum /Maximum Qty Allowed in Shopping Cart fields enable you to limit availability 
to products that have great prices to retail customers, so that they are not sold to wholesale 
customers. 

6. In the Qty Uses Decimals field, select Yes to specify that customers can enter decimal quantities 
for this product, as opposed to integers. This is suitable for a product sold by the weight, volume 
or length. For example: 2.35 pounds of concrete or 3.75 feet of carpeting. 

7. The Backorders field enables your customers to place an order for a product that has an in-stock 
quantity of less than 0. This option also enables you to notify your customers that even though 
there are no items of a product currently available, they can still place an order. You can do this 
by selecting the Allow Qty Below 0 option and the Notify Customer option. You can also 
enable this option without notifying customers by only selecting the Allow Qty below 0 option. 

8. The Enable Qty Increments field enables you to choose whether this product is sold in 
quantities other than 1 (for example wine that is sold in multiples of 6 bottles). If you select Yes 
for this option, the Qty Increments field becomes visible, enabling you to specify the quantity 
increment for this product. 

9. In the Stock Availability field, select the In Stock option if this product is in stock, or select Out 
of Stock otherwise. 

Websites Tab 

The Websites tab enables you to choose which websites, stores, and store views this product is 

available on. Use the check boxes to make your selections. To set up websites, stores, and store 

views, see “Setting Up Your Store Hierarchy,” page 139. 

1. Select the Websites option in the left panel to display the Websites tab, as shown in Figure 96. 

 

Figure 96. Websites Tab 

2. If your store has more than one website, store or store view, you must assign the product to the 
appropriate website in order to make it available in this website.  

Note: Sample Data contains three store views. If you want to create a product in the 
Sample Data environment, you must select the Main Website option when creating 
a product. 

Categories Tab 

The Categories tab enables you to assign this product to one or more categories. 

1. Select the Categories option in the left panel to display the Categories tab, as shown in Figure 
97. 
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Figure 97. Categories Tab 

2. Specify the categories to which this product belongs by selecting the appropriate check boxes. 

Note: You can assign a product to more than one category. 

Note: You can also assign products to a category while editing the category. 

Related Products, Cross-sell, and Up-sell Tabs  

Each of these pages is similar and enables you to configure relationships between products. The 

interface in Figure 98 appears in each of these pages: 

 

Figure 98. Product Relationship Interface 

 To display all the products in the list, click the Reset Filter button. 

 Select the relevant check boxes to assign products. You can use any of the filters available 

to make it easier to search for the products that you want. 

For more information about these pages, see “Up-selling, Related Products, and Cross-selling,” page 

269. 

Product Alerts Tab 

This page is only available when alerts are enabled (System > Configuration > Catalog). See Figure 

99. 
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Figure 99. Product Alerts Tab 

This page displays a list of the customers who have subscribed to each type of alert for this product, 

and the dates on which they were notified about changes. 

Product Reviews Tab 

This tab provides a list of reviews posted by customers about a product that is being edited (the tab 

is not available for new product records for which there are no reviews). You can use the Edit button 

that appears in each review row to approve, edit or remove the review. See Figure 100. 

Note: The Pending Reviews RSS link enables you to receive notifications of all pending 
reviews and enables you to first approve them before they are shown on the site. 

 

Figure 100. Product Reviews Tab 

Product Tags Tab 

This tab displays the tags that customers have assigned to a product, and how many times each tag 

was used. This tab is not available in new product records for which no tags have been assigned. 

See Figure 101. 
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Figure 101. Product Tags Tab 

Note: You can click on a tag row to edit it or approve, reject, disable, or delete it. 

Customers Tagged Product Tab 

This page enables you to see which customers have tagged specific products. See Figure 102. 

 

Figure 102. Customers Tagged Product Tab 

Note: You can click on a tag row to edit it or approve, reject, disable, or delete it. 

Custom Group Configuration Pages 

Additional configuration pages may appear depending upon the groups that you have created using 

the Attribute Sets tool. See “Creating Attribute Sets,” page 76 for more information about attribute 

sets. An example custom group T-Shirts attribute is shown in Figure 103. 

 

Figure 103. Custom Attribute 
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Fill in the attributes that appear in this page according to the definitions that are specified in the 

attribute set. Some of these attributes may be mandatory and each may be one of a variety of types 

according to the definitions of the attribute set. 

Custom Options Tab 

This page enables you to easily create product variants or products that can accept customer input, 

such as custom imprints or gifts. See “Creating Variations of a Product,” page 105, for more 

information on this topic. 

Product Type Dependent Configuration Pages 

Depending upon the product type, additional configuration tabs may be available. The following 

provides a quick review of these types of pages. 

Downloadable Products: Downloadable Information Tab 

The Downloadable Information tab enables you to specify options for a downloadable 

product. See Figure 104. 

 

Figure 104. Downloadable Information Tab 

This page contains two sections: 

 The Samples section enables you to display a sample of the downloadable product on the 

product’s information page. For example, this can be a short sample of a music file, a few 

pages of an eBook, or a trial version of a software application. You can provide as many 

samples as you require by clicking the Add New Row button and filling out the fields. You 

can add files using either of two methods: 

o Select the File option, click the Browse button (...) and then click the Upload Files 

button. This will upload the file from your local computer to the server.  
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o Select the URL option, specify the link to a file that is already on a server in a 

different location, and click the Upload Files button.  

Samples that you put in the Samples section appear in the store as shown in Figure 105. 

 

Figure 105. Downloadable Product Sample 

 The Links section contains the actual products that can be purchased, along with possible 

samples for them. 

o The Links can be purchased separately option controls whether each of the 

downloadable products can be purchased by itself or not. This feature enables, for 

example, the tracks of a music CD product to be purchased separately. If you set 

this option to Yes, then you must specify the price for each of the downloadable 

items. 

o Each of the items also has two options that control its behavior. The Max. 

Downloads option controls how many times after purchase a product can be 

downloaded by the customer. The Shareable option controls whether after each 

purchase of the product, the downloadable item is available for download without 

logging in, or if it requires logging in. If the Shareable option is set to Yes, then 

customers can click links in the Order Confirmation email that they receive in 

order to get the product. However, this setting also enables anyone who gets this 

link to download the product. Setting this option to Yes is the only way to enable 

Guest customers to check out (or to enable a comparable quick checkout method, 

such as PayPal Express or Google Checkout) to download the product. There are 

configuration settings that must be selected to match your store. 

The uploading process is similar to the uploading of the samples, as described above, with the 

exception of providing an option to tie in sample files for each downloadable product. This feature 

can be used to provide customers with a short sample of each track of a music CD, for example.  
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Figure 106 shows a product in a store with three links and samples for each of them, for which the 

setting Links can be purchased separately was set to Yes. 

 

Figure 106. Downloadable Product Links and Samples 

Bundle Product: Bundle Items Tab  

An example of a bundled product is the Build Your Own Computer offering found in the demo 

store, as shown in Figure 107. 
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Figure 107. Bundle Product 

In Bundled product types, there are differences in the General and Prices pages, as follows:  

 SKU Fixed or Dynamic (General tab): Specifies whether the entire product is assigned an 

SKU based on its components, or the SKU is fixed for the bundle.  
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 Weight Fixed or Dynamic (General tab): Specifies whether the entire product’s weight is 

based on the weight of its individual components, or the weight is fixed for the entire 

bundle. 

 Price Fixed or Dynamic (Price tab): Specifies whether the price of the product us based on 

the price of its individual component, or the price is fixed for the entire bundle. 

 Price View (Price tab): Specifies whether the product’s price is shown as a range, from the 

least expensive component to the most expensive (Price Range), or only the least expensive 

price is shown (As Low As).  

The Bundle Items tab contains the following settings: 

 Ship Bundle Items: Specifies whether individual components are shipped separately, or the 

entire product is shipped.  

 Bundle Items: Bundled Items appear in the store as a list of available options. You can add a 

new option using the Add New Option button. For each option you can configure its title, 

input type (single and multiple selection fields are available), whether the field is mandatory 

(for example: it can be True for a computer processor and False for an additional battery of 

a laptop computer), and its position on the page. See Figure 108. 

 

Figure 108. Bundle Items Tab 
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After you add options, you can specify individual values for each option. Click the Add Selection 

button to open a selection area, as shown in Figure 109. 

 

Figure 109. Adding Products to a Bundle 

You can select any product that you want using the check boxes. Click the Add Selected Product(s) 

to Option button to confirm the assignment. For each selection, you can then define the following 

options: 

 Default Qty: Specifies the default quantity shown in the product view page 

 User Defined Qty: When set to Yes, this option enables customers to enter a quantity for a 

given selection 

 Position: Specifies the order in which the selection appears 

 Default: Specifies the predefined value 

Grouped Product: Associated Products Tab 

A grouped product enables you to purchase each of the items separately. 

In the store, a grouped product appears as shown in Figure 110. 
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Figure 110. Grouped Product 

When creating a Grouped Product, the Associated Products page enables you to specify which 

products are included in a group, as well as the default quantity for each and their position (order) 

on the page. See Figure 111. 

 

Figure 111. Associated Products in a Grouped Product 

Note: There is no global price for grouped products. Their price is controlled only by 
the individual elements that you purchase. 

Configurable Product: Associated Products Tab 

Configurable products must be associated with simple products using attributes that a customer can 

select from a configurable product page. This means that when a shirt is offered in three sizes, then 

three simple products must be assigned to the configurable product, one for each size. 

The configurable product appears in the store with a section that provides customers with options, 

such as the Size option shown in Figure 112. 
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Figure 112. Configurable Product 

This is the most complex configuration page and it is described below it in three stages.  

Select Configurable Attributes 

This section enables you to select the product attributes that can be configured. The only attributes 

that are available on this tab are those that have a scope of Global, an input type of Dropdown, and 

the Use to create configurable product option set to Yes. See Figure 113. 

 

Figure 113. Select Configurable Attributes 

Use the check boxes to select one or more desired attributes, and then click Continue. 
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Create Simple Associated Product 

This section enables you to create simple products along with the configurable product. See Figure 

114. 

 

Figure 114. Create Simple Associated Product 

Click the Create Empty button to open a pop-up window with a regular product creation page, but 

which has a preselected product type, Simple Product, and an attribute set that is the same as the 

configurable product. 

The Copy from Configurable button works in a very similar manner to the above, but it pre-fills 

many of the fields with information from the selected configurable product, as shown in Figure 115. 

 

Figure 115. Quick Simple Product Creation 

This area enables you to quickly create simple products without filling in all the information. Fill in 

the required fields and click the Quick Create button to create this product. The Auto generate 

option enables Magento to select the Name and SKU based on the attributes. 

Super Product Attributes Configuration 

This section enables you to specify the attribute name that appears in the store for selection and the 

price for each of the options. Two price options are provided: Fixed or Percentage. See Figure 116. 

 

Figure 116. Super Product Attributes Configuration 
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The price for configurable products is a combination of the price from the Prices tab, as described in 

“Prices Tab,” page 83, and the values entered in this area. This means that if the configurable 

product’s price is $20 and the price for the Medium option is: Percentage and 10, then this variation 

of the product costs $22. The price of the associated products is not used for calculation. See Figure 

117. 

 

Figure 117. Selecting Associated Products 

Completing the Product Wizard 

Click the Save or Save and Continue Editing button in the top right corner of the page. If you choose 

the latter, after saving the product you are redirected back to its page. 

To edit an existing product: 

1. From the Catalog menu, select the Manage Products option to display a list of products, as 
shown in Figure 118. 

 

Figure 118. Product List 

2. Click the Edit link on the right side of the row of the relevant product. 
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7.3 Mass-Changing Products 

Magento provides various features that enable changes to be made on multiple products or their 

properties. On the product list, mark products using the selection check boxes. Then select one of 

the actions from the Actions drop-down menu and click the Submit button: 

 Delete: Deletes the selected products from the store. 

 Change Status: Disables or enables multiple products at once. 

 Update Attributes: Updates the attributes of multiple products. When you click the Submit 

button, a new page opens containing a list of all attributes for all selected products. Select 

the Change check box for any attribute that you want to change, then specify the new 

attribute values. Click Save to confirm the changes. 

Note: You can use the Duplicate Product feature to create separate products without 
having to enter every value each time. To use it, click the Duplicate button on the 
product page of an existing product. 
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8 Creating Variations of a Product 
This chapter describes how to create variations of a product by adding input controls (input options) 

to a product’s page. An example of the variation of a product is the same product with different 

colors or sizes. In this case you must add a customized field to enable the customer to select the 

required color or size. 

Tip: If you want to track the quantity that is sold of each variant of the product, you 
must create a separate product for each variant of the product and group them in 
the product of type Configurable, and not use the variations options described here. 

To create variations of a product: 

1. From the Catalog menu, select the Manage Products option to display a list of products.  

2. Click the Add Product button to create a new product or click the Edit link to the right of the 
relevant product to open the edit page.  

3. Select the Custom Options tab. 

4. Click the Add New Options button on the top right of this page to display the controls shown in 
Figure 119. 

 

Figure 119. Creating Custom Options 

5. In the Title field, specify a name for this new property, such as the name Size. 

6. In the Input Type field, select the type of input that can be given in this field, such as text or 
drop-down menu, as shown above.  

7. In the Is Required field, select Yes to indicate that this is a mandatory field, meaning that a 
customer must select an option in this field in order to purchase this specific product.  

8. If there is more than one option, then specify the order in which this option appears in the Sort 
Order field. A value of 1 indicates that it appears first. 

9. Click the Add New Row button to display the row shown in Figure 120, in which you can 
define the new variation of this product. For example, the product in a certain size and its 
corresponding price. 
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Figure 120. Creating a Product Variation 

10. In the Title field, specify the name of this variation of the product, such as Size XL. 

11. All the prices in these rows are relative to the price of this product as defined in the Prices page 
of the product wizard described on page 83. In the Price Type field, select one of the following 
options: 

 Fixed: To specify that the price of this variation of the product differs from the price of the 

base product by a fixed monetary amount, such as $1. 

 Percentage: To specify that the price of this variation of the product differs from the price of 

the base product by a percentage, such as 10%. 

12. In the Price field, specify the difference between the price of this variation of the product and 
the price of the base product. Specify a fixed amount or a percentage according to the value 
that you entered in the Price Type field. You can also enter negative values. 

13. In the SKU field, specify the SKU for this variation of the product. 

14. If there is more than one variation, then specify the order in which this option appears in the 
Sort Order field. A value of 1 indicates that it appears first.  

15. Click the Save button. This example product is shown in the web store, as shown in Figure 121. 
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Figure 121. Product Variation in the Frontend 

In this example, you can see that the price is $13.50. However, if the Green color is selected, 

then the price is $18.75, as shown in Figure 122. 

 

Figure 122. Price Change for Product Variation 
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Note: If this product is added to the customer’s shopping cart, then the variation 
information appears there, as shown below: 
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9 Composite Products Handling 
This chapter describes the handling of composite products for store customers and administrators in 

Magento Enterprise Edition. In this guide the term “composite product” refers to products, of any product 

type, that should be configured before being added to the Shopping Cart. It includes built-in product types: 

configurable, bundle, grouped products, downloadable products, gift card, any product type with custom 

options, and any other product type that has some options to configure and was created by a third-party 

developer working in the Magento environment. The term “configuring a composite product” refers to 

making the configuration, setting custom options, and specifying the quantities of associated simple 

products.  

A composite product can be added to the Wishlist without configuration, though it must be configured 

before being added to the Shopping Cart. The configuration is stored in the system, if the product was once 

configured, and can be changed at any step before the order is submitted. 

Customers can change the configuration of the products in multiple locations in the store (product page, 

Wishlist, and Shopping Cart), and the configuration will be saved if the customer moves the product from 

section to section (for example, adding the product to the Wishlist from the product page or adding it to the 

Shopping Cart from the Wishlist). The same goes for the quantities of the products. 

In the Admin Panel, you can easily add and reconfigure composite products when creating orders, as well as 

view and change the configuration of the products in the customer's Wishlist and Shopping Cart. 

9.1 Composite Products Handling for Store Customers 

Products in the Wishlist 

If a product that was configured (including setting custom options) on the product page, or 

reconfigured in the Shopping Cart is added to the Wishlist, the configuration is preserved. The same 

goes for the quantity of the product and the price. 

On the My Wishlist page the configuration, whether it was made in the Wishlist or before the 

product was added, can be viewed by clicking View Details. Under the product image, the price 

quote for a non-configured product is shown as it was before, so the customer can see the original 

price, and change the configuration if necessary. If the product was configured before it was added 

to the Wishlist, the final price for the product according to chosen options is displayed under the 

product original price. See Figure 123. 
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Figure 123.  A Configured Product in the Wishlist 

To change the configuration of the composite product from the My Wishlist page, a customer clicks 

the Edit link under the ADD TO CART button of the product. See Figure 123. 

Clicking the Edit link opens the product page, where all product options are already selected and 

quantity is set, if they were configured before. The customer can then change the product 

configuration and/or quantity, and update the product in the Wishlist by clicking the Update 

Wishlist button, or add the product to the Shopping Cart.  

A composite product, which was added to the Wishlist multiple times with different sets of options, 

appears in the Wishlist as separate products. 

When a customer clicks the Edit link for a bundle product in the Wishlist or in the Shopping Cart, 

the system redirects the customer to the page that originally opens after the Customize and Add to 

Cart button is clicked on the product page, not the very first product page view for the bundle 

product. This means the product options are shown to a customer immediately, without having to 

click the Customize and Add to Cart button to access product configuration.  

Note: Grouped products are stored in the Wishlist not as a set of individual simple 
products, but as a single grouped product, with simple products displayed beneath 
the grouped product as product options. This is contrary to the Order and Shopping 
Cart, where only individual simple products are displayed in this case. 

Products in the Shopping Cart 

When the store customer adds a configured product to the Shopping Cart from the Wishlist, the 

configuration and the quantity are preserved. 
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If a composite product, that has not been previously configured, is added to the Shopping Cart from 

the Wishlist, the customer is redirected to the product page where product configuration is 

performed. The customer can then update the Wishlist, or add the configured product to the 

Shopping Cart. When there are several products in the Wishlist that require configuration, an error 

message appears when the customer tries to add them to the Shopping Cart. The message informs 

the customer which products should be configured. The customer then must configure the products, 

using the Edit link in the Wishlist, and add them to the Shopping Cart one by one.  

To change the configuration and quantity of the product on the Shopping Cart page, a customer can 

use the Edit link located to the right of the product image. See Figure 124. 

 

Figure 124. Composite Product in the Shopping Cart 

Clicking the Edit link on the Shopping Cart page opens the product page, where all product options 

are already selected and quantity is set, if they were specified previously. The customer can then 

change the product configuration and/or quantity and return to the updated Shopping Cart by 

clicking the Update Cart button. 

For simple products, clicking the Edit link in the Shopping Cart redirects customer to the product 

page with the quantity specified as it was specified in the Shopping Cart. The customer can then 

change the quantity and update the product in the cart.  

Reconfiguring the product is available as well from the mini Shopping Cart, which is displayed 

when a customer clicks MY CART in the upper-right corner of the store page. The user can change 

the product configuration using the Edit Item link. See Figure 125. 

 

Figure 125. A Composite Product in the Mini Shopping Cart 
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Note: In the Shopping Cart, mini Shopping Cart, and Wishlist, if the customer clicks the 
product name or image, the product page opens as if browsed to it from the 
category or using the direct link. No product options, if any, are specified and no 
quantity is set. 

When a customer selects product options (if any), sets the quantity for a product, and chooses to 

add it to the Shopping Cart or the Wishlist, the product is added according to the options and/or 

quantity specified on the product page. If product configuration is identical to the configuration of 

an item already in cart, the quantity of identical items is increased by the quantity the customer 

specifies on the product page. 

Products that are added to the Shopping Cart from the Wishlist are validated by the system for 

availability and quantity increments. If products are not in stock or can be purchased in specific 

quantities only, an error message appears at the top of the page.  

9.2 Composite Products in the Admin Panel  

In Magento Enterprise Edition, all types of products can be added to orders in the Admin Panel. 

Composite products can be configured during the order creation. The configurations, made by the 

customer, are preserved for composite products, which are added to the order from the customer's 

Shopping Cart, Wishlist, or last ordered items.  

You can also change the configuration of the products in the customer's Wishlist and Shopping Cart. 

Composite Products in Orders Created from the Admin Panel 

According to the Magento logic, a composite product needs to be configured before it can be added 

to the order.  

To open the order management section in the Admin Panel, navigate to Sales > Orders.  

When the order is created from the Admin Panel, products for the order can be selected from the 

general list of products or moved from the Shopping Cart, Wishlist, Last Ordered Items, Products In 

Comparison, Recently Compared Products, or Recently Viewed Products side blocks. See Figure 

126. 



 Composite Products Handling 

 113 

 

Figure 126. Creating the Order from the Admin Panel 

In the general list of products, which opens when you click Add Products, a Configure link is 

displayed for each product; however, it is always unavailable for products that cannot be 

configured. See Figure 127. 

 

Figure 127. Configuring Composite Products in the Admin Order 
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When you click the link, the Configure Product pop-up window appears, where you can make the 

configuration and specify the quantity of the associated products. If you do not click the Configure 

link for the composite product, but simply select the Select check box, the Configure Product pop-

up window appears automatically. See Figure 128. 

 

Figure 128. The Configure Product Window for Configuring a Composite Product in 

the Admin Panel 

When you click OK, the configuration and quantity for the product are saved, the Select check box 

for this product becomes selected, and the quantity is displayed in the Qty To Add field. When you 

click the Add Selected Product(s) to Order button, having selected the products you need to add to 

the order, and having made the necessary configurations, the products are added to the order with 

the configuration and quantity you have specified. The price for the composite product in the Items 

Ordered list is displayed according to the product configuration. 

Note: When a grouped product is added to the order from the general list of products, 
illustrated in Figure 127, quantities of the associated individual products can be set 
only in the pop-up window, which opens on clicking the Configure link or 
selecting the Select check box, as described earlier. The Qty to Add field for a 
grouped product is unavailable, as in the order. A grouped product is not displayed 
as one product, but the associated simple products are displayed instead; this is 
contrary to the Wishlist, where a grouped product is displayed as one product, both 
in the Admin Panel and the frontend. 

For the grouped products, in the Shopping Cart/Last Ordered Items list/Wishlist side blocks, a 

special “Configure and Add to Order” icon appears. It looks like a green gear (see Figure 129). 

When you click the icon, the Configure Product pop-up window appears, where you can perform 

the configuration. When you click OK, the simple products associated with this grouped product are 

added to the order. For all other product types, the usual check box is present, enabling you to add 

them to the order. Selecting this check box and clicking the Update Changes button adds the 

selected products to order, where they can be configured (or reconfigured).  
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Composite products in the Products in the Comparison List, Recently Compared Products, and 

Recently Viewed Products side blocks do not have configurations made by customers, and cannot 

be configured from these locations. When they are added to the order, a message appears, notifying 

you that the products require configuration. The only exceptions are grouped products, which 

cannot be added to the order if the quantities for the associated simple products are not specified.  

 

Figure 129. Changing Product Configuration in the Admin Order 

When composite products were added with no configurations, or if you need to change the 

configuration of the product(s) already added to the order, there is a Configure button for every 

composite product in the Items Ordered list. It is always unavailable for products that do not require 

configuring. When you click Configure, a pop-up window opens, where you can make product 

configuration changes. The system applies changes only when you finally click Update Items and 

Qty's. See Figure 129. 

Note: The Custom Options link previously present for each item line is no longer 
available, because both product options of composite products and custom options 
are specified using the Configure button. 

Managing Composite Products in Shopping Carts and the Wishlists 
in the Admin Panel 

In Magento Enterprise Edition, you can see and change the configuration of composite products in 

the customer's Shopping Cart and Wishlist in the Admin Panel.  

To open the customer's information in the Admin Panel, navigate to Customers > Manage 

Customers, and select the customer from the list. The customer page opens. Click the Shopping Cart 

or Wishlist tab under Customer Information in the left column to see the products that the customer 

has added to the Shopping Cart or Wishlist. Now, for each composite product in these sections, the 

configuration is displayed under the product name and there is a Configure link in the Action 

column. It is unavailable for products that do not require configuration. See Figure 130. 
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Figure 130. Composite Products in the Shopping Cart in the Admin Panel 

Clicking the Configure link opens a pop-up window, where you can change the configuration 

and/or quantity of the product. If configured products are moved to the Shopping Cart or the 

Wishlist in the Admin Panel from the order, the Shopping Cart, or the Wishlist, all configurations are 

preserved.  

To manage the customer’s Shopping Cart from this location you can use the Manage Shopping Cart 

button on the top of the page. The Shopping Cart for <customer> in <store view> page opens. For 

the products in the Shopping Cart, the configuration made by customer is preserved. It can be 

changed by the store administrator using the Configure button, similarly to changing the 

configuration in the order, described earlier. See Figure 131.  

 

Figure 131. Composite Products in the Shopping Cart in the Admin Panel 
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You can configure composite products, before adding them to the Shopping Cart, using the Configure link in 

any section on this page (Products, Wishlist, Products in Comparison List, Recently Compared Products, 

Recently Viewed Products, or Last ordered items). See Figure 131. 
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10 Enhanced Catalog Search 
The success of any web store greatly depends getting customers to the right products quickly. Magento 

Enterprise Edition provides several search features which can significantly improve search results and 

relevancy for your visitors and customers. Primary among these features is the ability to use Apache’s Solr 

search engine and enhanced search recommendations and related terms. 

Chapter Quick Reference 

The table below lists some of the most common tasks for using Solr catalog search and where to go in the 

Admin Panel to perform them. The sections that follow provide step-by-step instructions on each. 

TASK ADMIN MENU 

To enable Solr System > Configuration > Catalog tab 

Catalog Search panel 

To configure quick search with Solr to 

use attribute weights 

Catalog > Attributes > Manage Attributes tab 

Frontend Properties tab 

To enable search suggestions using 

Solr 

System > Configuration > Catalog tab Catalog Search 

panel 

To enable catalog navigation using 

Solr 

System > Configuration > Catalog tab 

Catalog Search panel 

To enable and configure search 

recommendations 

System > Configuration > Catalog tab 

Catalog Search panel 

To set up related search terms Catalog > Search Terms 

 

10.1 Catalog Search with Solr 

Solr is a powerful search engine that supports stemming, plurals, replacements, layered navigation 

and more. Solr is not bundled with Magento and must be installed separately by your hosting firm or 

system administrator, but it is fast and enterprise ready and available for all Unix systems.  

The Solr search feature in Magento Enterprise Edition enables you to choose between using the 

default Magento MySQL-based search or using an external Solr server for product searches on the 

frontend. When you enable and configure Solr, both the quick search and advanced search will be 

redirected to the Solr server and Magento will present results in exactly the same way as it would 

with the default MySQL-based search. 

Solr search engine module provides Magento users with the following advantages: 

 Improved search performance  

 Improved search results relevancy 

 Support for spelling/synonyms/stop words  

 Improved layered navigation performance 

Solr is especially recommended for sites with heavy traffic and search loads. Products are added to 

the search engine index as each product is saved in the Admin Panel so the index is kept up to date 

without any need for manual intervention. 
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Installing Solr 

The Solr search engine must be installed separately from Magento. Please consult with your system 

administrator or hosting firm to get it installed. While Magento is unable to provide support for 

configuring Solr server we can provide Solr configuration and schema files to help your hosting firm 

or system administrator with initial server configuration. Please contact the support team for 

assistance. 

During the installation process, you specify the host name, port, and the password to connect to the 

server where Solr search engine is installed. Keep track of this information, which you will need 

when you configure Magento to use Solr. 

Note that Solr provides a number of base files which need to be filled in for every language that will 

be used in the system. The files are as follows: 

 protwords.txt – Protected words. Use a protected word file to protect against the 

stemmer reducing two unrelated words to the same base word. 

 spellings.txt – Definitions of misspelled words 

 stopwords.txt – Words that stop the search (have no meaning for search) 

 synonym.txt – Synonyms for every language 

Out-of-the-box Solr supports search functionality for 20 languages. Depending on the language of 

the store that is opened in the frontend, Solr will call the fields of that specific language. 

Configuring Your Magento Store to Use Solr 

Magento quick search performed by the Solr search engine provides the following options: 

 Search results according to the specified weight of an attribute 

 Search terms suggestions based on the corrected customer’s misspelling 

 Search results including the Layered Navigation block 

To enable Solr: 

A number of parameters must be set up in the Magento Admin Panel in order to establish the 

connection to Solr search engine, which can be installed either on the same or on a different server 

from Magento.  

1. Choose System > Configuration. Select the Catalog tab on the left. 

2. In the Catalog Search panel, enable Solr by setting the following values: 

 Search Engine: Determines whether the default MySqlFulltext search engine or Solr is used 

for product search on your websites. The search engine used and its configuration settings 

are global for all websites on the Magento installation. You can set the following values: 

o MySqlFulltext: The default Magento-native search 

o Solr: Enables Magento to use the Solr search engine (installed separately) 

 If Solr is selected, the following fields will appear: 
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o Solr Server Hostname: Specify the host name of the Solr Enterprise Search server to 

connect to 

o Solr Server Port: Specify the port number of the Solr server to connect to 

o Solr Server Password: The Solr server password you set when you installed Solr 

o Solr Server Timeout: The connection to Solr search engine should be established 

within the number of seconds specified in the Solr Server Timeout field; if it is not, 

the MySQL search engine is used instead of Solr 

o Solr Server path: Specify the path to Solr located on the server specified in the Solr 

Server Hostname field; the Solr server path should be specified with no starting and 

ending slashes 

3. Click the [✔Save Config] button to save your settings 

To configure quick search for Solr:  

With the Solr search engine enabled, all of the product attributes that are enabled for quick search 

now have an additional Search Weight parameter. This parameter denotes the priority a specific 

attribute has in the Solr search. If Solr is enabled, it is also used for Advanced Search, but the search 

weight is not used there in generating search results. 

When a customer enters a term in the search field on your web store, one of the parameters that the 

Solr search engine takes into account in generating results is the attribute search weight. Attributes 

whose search weight is greater will be searched and returned first by Solr.  

For example, if there are two attributes in the system, “color” with a search weight of 1 and 

“description” with a search weight of 3. When a customer searches for the word “red,” Solr will 

return a list of products whose color attribute is red and will not include in the list the products 

whose description contains the word “red.” This result happens because the search weight of the 

“color” attribute is higher than that of the “description” attribute. 

1. To set your attribute weights, choose Catalog > Attribute > Manage Attributes. 

2. In the Frontend Properties panel, you can set the following values: 

 Search Engine: Solr must have previously been enabled; see the “To enable Solr” 

instructions above. 

 Use in Quick Search: Determines if an attribute’s values will be used when returning search 

results: 

o Yes: This attribute can be used in generating quick search results; if set to Yes and if 

Solr is enabled, the search weight field below appears. 

o No: Attribute cannot be used in generating quick search results. 

 Search Weight: The search weight of product attributes can range from 1 to 5, with 

1=greatest weight; 5=least weight. Greater search weights have higher priority in returning 

results. If no value is specified, all attributes have a search weight of 1. 

3. Click the [✔Save Attribute] button to save your settings. 
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To enable search suggestion for Solr: 

In Magento, customers’ misspellings in the search query text are corrected and customers are 

provided with Solr-recommended search suggestions. 

When a customer makes a spelling mistake in the search term, the system displays the “Did you 

mean: suggestion_link” message on the search results page and, depending on the search suggestion 

configuration, more than one suggestion can be displayed to the customer. 

1. Choose System > Configuration. Select the Catalog tab on the left. 

2. In the Catalog Search panel, enable Solr by setting the following values: 

 Search Engine: Solr must have previously been enabled. See the “To enable Solr” 

instructions above. 

 Enable Search Suggestions: Determines if search suggestions will be provided by Solr in 

response to common misspellings: 

o Yes: Makes the search suggestions functionality available to customers. Enabling 

search suggestions can slow down search performance (depending on your 

hardware, configuration and search volume). If search performance becomes slow, 

disable this option. 

o No: Search suggestions will not be provided with search results. 

 Search  Suggestions Count: Specify the number of suggestions that will be provided to the 

customer on running search in the frontend. The suggested terms are those that most closely 

correspond to the term being searched. By default, this field is set to display two 

suggestions. 

 Show Results Count for Each Suggestion: Set to Yes to display the number of search results 

for each search suggestion. (Depending on the store theme, this number is usually shown in 

brackets next to the suggestion.) 

3. Click the [✔Save Config] button to save your settings. 

To enable catalog navigation using Solr: 

All of the attributes set to be used in layered navigation are added to Solr index. As a result, Solr can 

also be used to generate the layered navigation. In order to add these attributes to Solr search 

results, the store administrator needs enable Solr for catalog navigation.  

1. Choose System > Configuration. Select the Catalog tab on the left. 

2. In the Catalog Search panel, enable Solr by setting the following values: 

 Search Engine: Solr must have previously been enabled. See the “To enable Solr” 

instructions above. 

 Enable Solr Engine for Catalog Navigation: Determines if Solr will be used for generating the 

layered navigation: 

o Yes: Uses Solr instead of the MySQL Fulltext search to generate the layered 

navigation. 

o No: Magento-native catalog and layered navigation is used. 
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3. Click the [✔Save Config] button to save your settings. 

10.2 Related-Terms Search Recommendations 

With search recommendations enabled and set up, the store administrator is able to more easily 

specify search synonyms for customers’ search terms. This feature greatly expands the search results 

that are available to customers. Search recommendation functionality is independent of the search 

engine selected and is available for both MySql Fulltext and Solr search. 

The store administrator can specify the search recommendations list for a specific search term and 

the search engine provides the standard search results and also proposes the list of related terms 

with the search results. 

For better performance, Magento also splits the searched word combination into separate words and 

automatically provides search recommendations for each of them, if these are available in the 

system. For example, if a visitor searches for the phrase “hp laptop,” the search system splits the 

phrase into two words, “hp” and “laptop,” and provides five search recommendations for the first 

term and twelve for the second one. 

To enable related terms search recommendations:   

When search recommendation are enabled, when a visitor searches for a term that has search 

recommendations set up for it, the visitor’s search results are provided as well as related search 

terms (the search recommendations) with a count of the number of results for each. Clicking any of 

the recommended terms takes the visitor to the search results page for the selected search term.  

Search recommendations functionality is independent of the search engine selected and is available 

for both MySql Fulltext and Solr search. 

1. Choose System > Configuration. Select the Catalog tab on the left. 

2. In the Catalog Search panel, enable search recommendations by setting the following values: 

 Enable Search Recommendations: Determines if search recommendations are provided on 

the frontend for synonyms and other related searches: 

o Yes: Uses Solr instead of the MySQL Fulltext search to generate the layered 

navigation. 

o No: Magento-native catalog and layered navigation is used. 

 Search Recommendations Count: Specify the number of words that will be provided to the 

customer as recommended terms related to customer’s search. By default, no more than five 

recommended terms are shown to customers. 

 Show Results Count for Each Recommendation: If Yes, the number of products found for the 

proposed search recommendation is shown in the brackets next to it. 

3. Click the [✔Save Config] button to save your settings. 
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To relate search terms:   

1. To add related search variants to a search term, choose System > Configuration. 
The resulting Searches grid provides the list of all terms that have been searched by customers 
on the website. These include the misspelled and incorrectly entered words. Magento also 
counts the number of each term being searched by customers which helps identify the most 
frequently searched terms and add synonyms or search recommendations for them. 

2. Click on any of the search terms in the list. 

3. On the resulting Edit Search page, to see all previously searched terms click the [Reset Filter] 
button located in the upper right of the Related Searches gird. Filter the list as desired to find 
specific related searches. 

4. Select the check boxes for all search queries to be added as search recommendations for this 
search term. 

5. Click the [✔Save Search] button to save your settings. 

Tip: Search queries created through the Admin Panel will not affect the search results 
count. In order to generate the count, the query must be run from the frontend. 
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11 Importing and Exporting Product and 
Customer Data 
Unless you have a small product catalog, the prospect of creating each product manually, 

one by one, is daunting. Magento has a solution: Import your product data from a comma-

separated values (CSV) spreadsheet file. You can also export your product data to a CSV 

file. 

If you have customer data in a database or spreadsheet, you can import that data into 

Magento as well. 

11.1 Working with CSV Files 

In order to import a CSV file into Magento, it must have certain characteristics. Specifically, each 

column heading must exactly match the Attribute Code for the attribute in that column.  

Tip: To ensure that a CSV file’s column headings are understood by Magento, first 
export a product CSV file (see “Exporting Product and Customer Data,” page 127). 
You can then edit this file (by adding or updating rows) and then re-import it. 

For the Category column, specify product category in textual form based on a category’s path, with 

a slash (/) between each category level; for example, Furniture/Living Room. Do not include the 

Root Category in the path. 

11.2 Importing Customer and Product Data 

Importing is available for all product types, except bundle, gift card, and downloadable products. 

You can import customer data, product data, and product images. 

To import customer or product data to Magento: 

1. Log in to the Magento Admin Panel. 

2. In the top menu, select System > Import/Export > Import to open the Import page, as shown in 
Figure 132. 

 

Figure 132. Import Page 

3. In the Import Settings field set, specify the following: 
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 In the Entity Type drop-down menu, select either Products or Customers. 

 In the Import Behavior drop-down menu, select the way complex data will be handled if 

imported records already exist in the database. Complex data for products includes 

categories, websites, custom options, tier prices, related products, up-sells, cross-sells, and 

associated products data. Complex data for customers includes addresses. The following 

options for handling the complex data are available: 

o Append Complex Data: The new complex data will be added to the existing 

complex data for the existing entries in the database. 

o Replace Existing Complex Data: The existing complex data for the already existing 

entities will be replaced. 

o Delete Entities: If entities that are being imported already exist in the database, they 

will be deleted from the database. 

 In the Select File to Import field specify the import CSV file.  

4. Click the Check Data button in the upper-right corner of the page. The system validates the file. 
If the file is valid, the corresponding message and the Import button appear. If some of the rows 
in the imported file are not valid and cannot be imported, the corresponding information is 
included to the message, but you can proceed with importing. The invalid rows will be skipped. 

5. For more information about the valid CSV file structure, see “Catalog Products CSV File 
Structure,” page 128, and “Customers CSV File Structure,” page 129. 

6. If needed, make corrections to the CSV file. 

7. Click the Import button to import the data into the database. 

File Validation 

File validation includes the following: 

1. All attribute values are checked for conformance with the required data type (decimal, integer, 
varchar, text, datetime). 

2. The complex data, service data (see “Catalog Products CSV File Structure,” page 128, and 
“Customers CSV File Structure,” page 129 for details), and attributes whose values must be from 
a defined set(such as a drop-down or multiple select input type), are checked to ensure their 
values exist in the defined sets. 

3. For new entities, the presence of the required attributes values in the file is checked. For existing 
entities, the presence of the required attributes values is not checked, but if a required value is 
specified, it is validated by the attribute type. 

Note: The “Required” option of the attributes is set in the Magento Admin Panel. To 
access the attribute management section, select Catalog > Attributes > Manage 
Attributes.  

Importing Product Images 

Product images can be bulk imported into Magento as well. This feature saves you the trouble of 

uploading individual image files to your store. 
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To import product images: 

1. Place the image files that you need to import in the subfolders in the %path_to_your 
Magento_instance%/media/import folder. Subfolders for the files should be created 
according to the following logic: Name the first folder using the first symbol of the file name, 
and then create a subfolder and name it using the second symbol of the file name. For example: 
for importing filename.jpg the path to the file will be the following: 
%path_to_your_Magento_instance%/media/import/f/i/filename.jpg 

Set the RE0777 permissions for the folders, and at least 0666 permissions for the image files. 

2. In the import CSV file, specify the relative path to the image file (For example, 
/f/i/filename.jpg). The following columns correspond to product images: 

o image 

o small_image 

o media_image 

3. Perform the import in the same manner as you would import product data.  

Important Note: Names of the image files you need to import should contain only 
lowercase symbols. 

The rules and restrictions for importing include the following: 

For entities that are new and do not exist in the database: 

 The entities are added with the attribute values specified in the CSV file. 

 If there is no value, or there is a non-valid value, for a required attribute with no default 

value set, then the entity (the corresponding row or rows) cannot be imported. 

 If there is no value, or there is a non-valid value, for a required attribute with the default 

value set, then the entity (the corresponding row or rows) is imported, and the default value 

is set for the attribute. 

 If the complex data is not valid, then the entity (the corresponding row or rows) cannot be 

imported. 

For entities that already exist in the database: 

 For attributes that are not complex data, the values from the import file, including the empty 

values for the non-required attributes, replace the existing values. 

 If there is no value, or there is a non-valid value, for a required attribute, then the existing 

value is not replaced. 

 If the complex data for the entity is invalid, the entity (the corresponding row or rows) 

cannot be imported, except the case, when Delete Entities was selected in the Import 

Behavior drop-down menu. 

 The way complex data is handled depends on the settings in the Import Behavior drop-

down menu: 
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o For both new and existing entities, if an attribute, specified in the import file, exists 

in the system, and its values are taken from the defined set of values, but the value, 

specified in the import file does not exist in the defined set, the row is imported and 

the default value, if it is defined, is set for this attribute. Otherwise the 

corresponding row cannot be imported. 

o If an attribute name is specified in the import file but has not been defined in the 

system, it is not created in the system, and its values are not imported. 

The file is invalid and cannot be imported if: 

o All rows in the file are invalid 

o A non-existing service data or complex data name is specified in the import file 

(that is, there is a column with a “_<non-existing name>” heading) 

11.3 Exporting Product and Customer Data 

Exporting is available for all product types except gift card products. 

To export customer or product data: 

1. Log in to the Magento Admin Panel. 

2. In the Magento top menu, select System > Import/Export > Export. The Export page opens. 

3. In the Export Settings field set specify the following: 

 In the Entity Type drop-down menu, select either Customers or Products. The Entity 

Attributes field set appears.  

 In the Export File Format drop-down menu, select the format of the file for the exported 

data. Currently only the CSV format is available. 

4. In the Entity Attributes field set you can include or exclude data to be exported according to the 
entity attribute values. The following export restrictions can be set: 

 You can filter the data to be exported by attributes values. To include the records with 

certain attribute values, set the required values of the attributes in the Filter column. 

 To exclude products or customers with certain attribute values, you need to set the values of 

the attributes for which the entities will be excluded, and select the corresponding check 

boxes in the Skip column. See Figure 133. 
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Figure 133. Exporting Customers Meeting Certain Conditions  

5. Click the Continue button in the lower-right corner of the page. You will be asked to specify the 
location for the file, or it will be saved in the default location depending on your browser 
settings. 

The CSV file that is generated can be used for importing data to Magento. 

11.4 Catalog Products CSV File Structure 

The imported or exported catalog products CSV file contains information about products and 

relations between them. The table has the following structure: 

1. The first row of the table contains the names of the columns, there are two types of the names:  

 _<name> - The names of the service columns and complex data columns. Service columns 

contain entity properties, which are not attributes. For example, columns with website or 

product type information are service columns. The underscore as first character is used to 

distinguish these columns from the attribute column names.  

 <attribute name> – the names of the columns with values of both system-created 

attributes and attributes created by the store administrator. 

2. Other rows contain attributes values, service data, and complex data. If a row contains the 
value in the SKU column, then this row the rows below it describe the product. Each new SKU 
value begins the description of the next product.  
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3. In the import procedure, if a row that contains the SKU value is invalid, then this row, and all 
other rows with data for that product cannot be imported. 

The minimal valid table contains only the SKU column. It can be used to delete entries from the 

database. 

There is no limit to the number of the columns in the table. Columns that do not contain data will 

be ignored. 

11.5 Customers CSV File Structure 

The imported or exported customers CSV file contains the table with information about customers. 

The table has the following structure: 

1. The first row of the table contains the names of the attribute columns (which are the same as 
attribute codes). There are two types of column names:  

 _<name> - The names of the service columns, and complex data columns. Service columns 

contain entity properties, which are not attributes. For example, columns with website or 

store information are service columns. The underscore as first character is used to 

distinguish these columns from the other attributes names.  

The “_address_default_billing” and the “_address_default_shipping” columns are the default 

billing and shipping addresses flags. If the address in the row is the default billing and/or 

shipping address of the client, the “_address_default_billing” and/or 

“_address_default_shipping” columns in this row will have the “1” value. 

 <attribute name> – The names of the columns with values of both system-created 

attributes, and attributes created by the store administrator. 

2. Other rows contain attribute values, service data, and complex data. Each row with non-empty 
values in the “email” and “_website” columns starts the description of the subsequent customer. 
Each row can represent customer data with or without address data, or the address data only. In 
case a row contains only the address data, values in the columns, related to the customer 
profile, will be ignored and may be empty.  

To add or replace more than one address for a customer, in the import file add a row for each new 

address with empty customer data and the new or updated address data below the customer data 

row. 

When the file is validated before the import starts, all customer address data values are validated, if 

at least one address-related column contains a non-empty value. Therefore, if you do not need to 

add or replace address data for a customer, delete values in all address columns for this customer. 
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12 Scheduled Import and Export 
Magento Enterprise Edition enables you to perform import and export jobs on a user-defined schedule. 

Scheduled imports and exports can be run on a daily, weekly or monthly basis; import and export files can 

be located and placed on the local Magento servers or remote FTP servers. Scheduling import and export 

jobs is implemented using the cron job scheduler. 

This feature was introduced in Version 1.11 of Magento Enterprise Edition. 

12.1 Terminology 

The following terms are used in reference to this feature: 

 Scheduled import: Imports that are created using the Scheduled Import/Export feature. 

 Scheduled export: Exports that are created using the Scheduled Import/Export feature. 

12.2 Scheduled Import/Export – a Quick View 

Using the Scheduled Import/Export feature does not require additional configuration. 

To access the scheduled import/export management tools, select System > Import/Export > 

Scheduled Import/Export. Figure 134 shows the Scheduled Import/Export page.  

 

Figure 134. Scheduled Import/Export Managing Page 

To create a new scheduled import or export job, click the Add Scheduled Import or Add Scheduled 

Export button. After being saved, a new scheduled import or export is added to the list on the 

Scheduled Import/Export page. 

After each scheduled import and export operation, a copy of the import or export file is placed in 

the var/log/import_export/%Y%/%m%/%d%/ directory on the Magento local server. You can 

configure cleaning it under System > Configuration > ADVANCED > System, on the Scheduled 

Import/Export File History Cleaning field set. 
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The details of each import/export operation are not written to a log, but if an error occurs, you will 

receive an Import or Export Failed email, which contains the error description. 

After each import job, a re-index operation is performed automatically. 

12.3 Scheduled Import and Export Configuration 

The Scheduled Import/Export functionality is implemented by the Enterprise_ImportExport module. 

The module is enabled by default. In the Magento Admin Panel, modules are managed in System > 

Configuration > Advanced. 

No additional settings are required to start using the Scheduled Import/Export functionality.  

12.4 Scheduled Import 

The Scheduled Import feature is similar to the manual Import feature (available under System > 

Import/Export > Import) with respect to the available import file format and types of import entities: 

 The import file should be in .CSV format; 

 You can import product and customer data. 

The advantage of the Scheduled Import is that you can import a data file multiple times 

automatically, after specifying the import parameters, and schedule only once. 

The details of each import operation are not written to a log, but in case of failure you will receive 

an Import Failed email, which contains the error description. 

The result of the last scheduled import job is displayed in the Last Outcome column on the 

Scheduled Import/Export page. 

After each import operation, a copy of the import file is placed in the 

var/log/import_export/%Y%/%m%/%d%/ directory on the server where Magento is deployed. The 

timestamp, the marker of the imported entity (products or customers), and the type of the operation 

(in this case, import) are added to the import file name. For information about cleaning the file 

history, see “Cleaning the Scheduled Import/Export File History,” page 137. 

After each scheduled import job, a re-index operation is performed automatically. On the frontend, 

changes in the descriptions and other text information are reflected after the updated data goes to 

the database, and the changes in prices are reflected only after the re-index operation.  

To create a scheduled import: 

1. Select System > Import/Export, and click Scheduled Import/Export. The Scheduled Import/Export 
page opens.  

2. Click the Add Scheduled Import button in the upper right corner of the page. The New 
Scheduled Import page opens. 

3. In the Import Settings field set, specify the following: 



Scheduled Import and Export 

132 

Option Description 

Name The name of the import. Helps you to distinguish it if many different 

scheduled imports are created.  

Description Optional. You can enter an additional description. 

Entity Type Defines what data will be imported. Select Products or Customers. 

Import Behavior Defines how complex data will be handled if entities, which are 

being imported, already exist in the database. Complex data for 

products include categories, websites, custom options, tier prices, 

related products, up-sells, cross-sells, and associated products data. 

Complex data for customers include addresses. The following 

variants of handling the complex data are available: 

 Append Complex Data - The new complex data will be added 

to the existing complex data for the already existing entries in 

the database. This is the default value. 

 Replace Existing Complex Data - The existing complex data for 

the already-existing entities will be replaced. 

 Delete Entities - If entities which are being imported already 

exist in the database, they will be deleted from the database. 

Start Time Set the start hour, minutes, and seconds of the import. 

Frequency Define how often the import will be run. Select between Daily, 

Weekly, and Monthly. 

On Error Define the system behavior in case errors are found during file 

validation. Select between the following options: 

 Stop Import - The file is not imported if any errors are found 

during validation. This is the default value. 

 Continue Processing - In case errors are found during 

validation, but importing is possible, the file is imported. 

Status The import is enabled by default. You can suspend it by setting the 

Status to Disabled.  

On the Import File Information field set, specify the following 

Option Description 

Server Type You can import from a file located on the same server where 

Magento is deployed (select Local Server) or from the remote FTP 

server (select Remote FTP). If you select Remote FTP, additional 

options for credentials and file transfer settings appear. 

File Directory Specify the directory where the import file is located. If Server Type 

is set to Local Server, specify the path relative to the Magento 

installation directory. For example, var/import. 
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Option Description 

File Name Specify the name of the import file. 

FTP Host[:Port]  

(present if Server Type 

is set to Remote FTP) 

Specify the FTP host domain name or IP address of the FTP server 

where the import file directory is located. 

User Name 

(present if Server Type 

is set to Remote FTP) 

Specify the user name for accessing the remote FTP server. 

Password 

(present if Server Type 

is set to Remote FTP) 

Specify the password for accessing the remote FTP server. 

File Mode 

(present if Server Type 

is set to Remote FTP) 

Defines the file mode, in which the file will be transferred from the 

remote FTP. Select Binary or ASCII. 

Passive Mode 

(present if Server Type 

is set to Remote FTP) 

Defines whether the file will be transferred from the remote FTP in 

passive mode. Select Yes or No. 

On the Import Failed Emails field set specify the following 

Option Description 

Failed Email Receiver Specify the email address to which an email notification (failed 

import email) is sent if the import fails. 

Failed Email Sender Specify the email address that is used as the sender for the import 

failed email. 

Failed Email Template Select a template for the import failed email. By default, only the 

Import Failed (Default Template from Locale option is available. 

Custom templates can be created under System > Transactional 

Emails. 

Send Failed Email Copy 

To 

The email address to which a copy of import failed email is sent. 

Send Failed Email Copy 

Method 

Select the copy sending method for the import failed email. 

Note: You can set General Contact, Sales Representative, and other store email 
addresses under System > Configuration > Store Email Addresses. 

4. To save the new scheduled import, click Save in the right upper corner of the page. The new 
scheduled import job is added to the list on the Scheduled Import/Export page. From this page it 
can be run immediately for testing and edited. 
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When you create a scheduled import, the import file is not validated immediately; the validation is 

performed each time before the import job is executed.  

12.5 Scheduled Export 

The Scheduled Export feature is similar to the manual Export feature (available under System > 

Import/Export > Export) with respect to the available export file format and types of entities that can 

be exported: 

 You can export to .CSV format; 

 You can export product and customer data. 

The advantage of the Scheduled Export is that you can export data multiple times automatically, 

after specifying the export parameters, and schedule only once. 

The details of each export are not written to a log, but in case of failure you will receive an Export 

Failed email, which contains the error description. 

The result of the last export job is displayed in the Last Outcome column on the Scheduled 

Import/Export page. 

After each export, the export file is placed in the user-defined location, and a copy of the file is 

placed in the var/log/import_export/%Y/%m/%d/ directory on the server where Magento is 

deployed. The timestamp and the marker of the exported entity (products or customers) and type of 

the operation (in this case, export) are added to the export file name. For information about cleaning 

the file history, see “Cleaning the Scheduled Import/Export File History,” page 137.  

To create a scheduled export: 

1.  Select System > Import/Export, and click Scheduled Import/Export. The Scheduled 
Import/Export page opens.  

2. Click the Add Scheduled Export button in the upper right corner of the page. The New 
Scheduled Export page opens. 

3. In the Export Settings field set, specify the following: 

Option Description 

Name The name of the export. Helps you to distinguish it if many different 

scheduled exports are created.  

Description Optional. You can enter an additional description. 

Entity Type In the Entity Type drop-down menu, select what data you want to 

export. Select Products or Customers. after you select the entity; the 

Entity Attributes field set appears, where you can include or exclude 

data to be exported according to the entity attribute values. 

File Format Select the format of the export file. Currently only the .CSV option is 

available. 
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Option Description 

Start Time Set the start hour, minutes, and seconds of the export. 

Frequency Define how often the export job will be executed. Select between Daily, 

Weekly and Monthly. 

Status A new scheduled export is enabled by default. You can suspend it by 

setting Status to Disabled.  

In the Export File Information field set, specify the following 

Option Description 

Server Type You can place the export file on the same server where Magento is 

deployed (select Local Server) or on the remote FTP server (select 

Remote FTP). If you select Remote FTP, additional options for 

credentials and file transfer settings appear. 

File Directory Specify the directory where the export file is placed. In case Server Type 

is set to Local Server, specify the relative to Magento installation path. 

For example, var/export. 

FTP Host[:Port] 

(present if Server 

Type is set to 

Remote FTP) 

Specify the FTP host domain name or IP address of the FTP server where 

the export file directory is located. 

User Name 

(present if Server 

Type is set to 

Remote FTP) 

Specify the user name for accessing the remote FTP server. 

Password 

(present if Server 

Type is set to 

Remote FTP) 

Specify the password for accessing the remote FTP server. 

File Mode 

(present if Server 

Type is set to 

Remote FTP) 

Defines the file mode in which the file will be transferred to the remote 

FTP. Select Binary or ASCII. 

Passive Mode 

(present if Server 

Type is set to 

Remote FTP) 

Defines whether the file will be transferred to the remote FTP in passive 

mode. Select Yes or No. 

In the Export Failed Emails field set, specify the following: 



Scheduled Import and Export 

136 

Option Description 

Failed Email 

Receiver 

Specify the email address to which an email notification (export failed 

email) is sent if the export fails. 

Failed Email Sender Specify the email address that is used as export failed email sender. 

Failed Email 

Template 

Select a template for the failed export email. By default, only the Export 

Failed (Default Template from Locale) option is available. 

Custom templates can be created under System > Transactional Emails. 

Send Failed Email 

Copy To 

The email address to which a copy of the failed export email is sent. 

Send Failed Email 

Copy Method 

Specify the copy sending method for the export failed email. 

In the Entity Attribute field set there a list of all available attributes for the selected entity. Here 

you can include or exclude data to be exported according to the entity attribute values.  

The following export restrictions can be set: 

 You can filter the data to be exported by attributes values. To include the records with 

certain attribute values, set the required values of the attributes in the Filter column. 

 To exclude products or customers with certain attribute values, you need to set the values of 

the attributes for which the entities will be excluded, and select the corresponding check 

boxes in the Skip column. 

4. To save the new scheduled export, click Save in the right upper corner. The new scheduled 
export job is added to the list on the Scheduled Import/Export page. From this page it can be run 
immediately, for testing, and edited. 

12.6 Managing Existing Scheduled Import and Export Jobs 

You can view and manage all existing scheduled imports/exports on the Scheduled Import/Export 

page. To open it, select System > Import/Export > Scheduled Import/Export.  

All existing scheduled import/export jobs are displayed in the list. In the Last Outcome column the 

result of the last job is displayed. If the import or export has not been run yet, it has the value 

Pending in the Last Outcome column.  

To run the scheduled import/export immediately: 

In the Action column select Run. 

To edit the scheduled import/export: 

In the Action column select Edit, or click the import/export job in list.  

You can delete and change the status for multiple scheduled imports/exports at one time. 
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To delete scheduled imports/exports: 

1. Choose the scheduled import/export jobs by selecting the corresponding check boxes in the first 
column. 

2. In the Actions drop-down menu select Delete. 

3. Click the Submit button next to Actions. The confirmation dialog box appears. 

4. Confirm the deletion by clicking OK. 

To change status of scheduled imports/exports: 

1. Choose the scheduled imports/exports by selecting the corresponding check boxes in the first 
column. 

2. In the Actions drop-down menu select Change Status. The Status drop-down menu appears. 

3. In the Status drop-down menu select Enabled or Disabled. 

4. Click the Submit button next to Actions.  

12.7 Cleaning the Scheduled Import/Export File History 

After each scheduled import and export operation copies of import and export files are placed in the 

var/log/import_export/%Y/%m/%d/ directory. These files are called history files. 

To set the old import/export files cleaning: 

1. Select System, and click Configuration. The configuration is done on the global level, so make 
sure that the Current Configuration Scope in the upper-left corner of the page is set to Default 
Config. 

2. Under ADVANCED in the left column click System. 

3. In the Scheduled Import/Export File History Cleaning field set, specify the following options: 

Option Description 

Save Files, Days Specify for how long import/export history files are stored. 

Enable File History 

Cleaning 

Select Yes if you want to activate the automatic deletion of old 

import/exports files. By default, it is set to No. 

Start Time Specify the time when the files deletion starts. 

Frequency Specify how often the cron checks if there are history files that should 

be deleted. Select between Daily, Weekly, and Monthly. 

Error Email Recipient Specify the email address to which the error email is sent if the file 

cleaning process fails. 

Error Email Sender Select the email address from which the error email is sent 
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Option Description 

Error Email Template Select the template for the error email. By default, only the File 

History Cleaning Failed (Default Template from Locale) option is 

available. 

Custom templates can be created under System > Transactional 

Emails. 

4. To save the file history cleaning settings, click the Save Config button in the upper-right corner 
of the page. 
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PART III: PREPARING TO SELL 

13 Setting Up Your Store Hierarchy 
If you have planned your store hierarchy (see “Store Hierarchy,” page 39) and set up the appropriate root 

categories (see “Creating Categories,” page 63), you are ready to set up your store hierarchy. 

To set up your store hierarchy: 

1. In the Admin Panel, select System > Manage Stores to open the Manage Stores page, as shown 
in Figure 135. 

 

Figure 135. Manage Stores Page 

2. To create a new website: 

a. Click Create Website to open the New Website page. 

b. In the Name field, specify a name for this website. Typically this will be the site’s domain 

name (for example, somecompany.com). 

c. In the Code field, specify a code name that the Apache Web server will use to point to the 

domain name (for example, somecompany_com). 

d. (Optional) In the Sort Order field, specify an integer number to determine where this 

website is listed in scope-selection drop-down menus in the backend. A specification of 1 

places this website at the top of the list, 2 places it second, and so on. 

e. Click Save Website. 

3. To create a new store: 

a. From the Manage Stores page, click Create Store to open the New Store page. 

b. In the Website drop-down menu, select the website that will be the parent of this store. 

c. In the Name field, specify a name for this store. 

d. In the Root category drop-down menu, select the root category for this store. A root 

category can be assigned to more than one store, or to stores in different websites. 

e. Click Save Store. 

4. To create a new store view: 

a. From the Manage Stores page, click Create Store View to open the New Store View page. 

b. In the Store drop-down menu, select the store that is associated with this store view. 

c. In the Name field, specify a name for this store view, for example, French. 



Setting Up Your Store Hierarchy 

140 

d. In the Code field, specify a code for this store view, for example, somecompany.fr. 

e. In the Status drop-down menu, select whether this store view is Enabled or Disabled. 

f. (Optional) In the Sort Order field, specify an integer number to determine where this store 

view is listed under its associated store in scope-selection drop-down menus in the 

backend. A specification of 1 places this website at the top of the list, 2 places it second, 

and so on. 

g. Click Save Store View. 

Note: If you are associating a separate domain with each website, some modifications 
must be made to the web server configuration files. For details, see the following 
Magento Knowledge Base article: http://www.magentocommerce.com/
knowledge-base/entry/tutorial-multi-site-multi-domain-setup 

http://www.magentocommerce.com/knowledge-base/entry/tutorial-multi-site-multi-domain-setup
http://www.magentocommerce.com/knowledge-base/entry/tutorial-multi-site-multi-domain-setup
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14 Design and Content 
This chapter describes how to customize the look-and-feel of your web store by applying easy to use options 

that are provided in the Magento backend.  

14.1 Overview 

Magento provides a variety of simple-to-use design options that enable you to apply your own 

customized look-and-feel to your Magento web store with basic HTML knowledge. 

Tip: See http://www.magentocommerce.com/design_guide for a description of how 
interfaces, themes, skins, layouts and blocks are used and to gain access to 
resources that will assist in their implementation. 

14.2 Terminology 

Following are some of the terms you should be familiar with when customizing the design 

of your store: 

Block: A Magento feature that modularizes page elements for easier management. 

Content block: Block that produces content, such as the content of a category list, mini cart, 

or product list. See also Structural block. 

Content Management System (CMS): A Magento feature that stores pages or parts of pages 

that you can use in your store. 

Layout: File that maps content blocks to structural blocks. More than one content block can 

be mapped to a single structural block. 

Skin file: File that define the visual functional specifications of page elements, such as text, 

graphics, and the logic behind buttons and other controls. 

Structural block: Block created for the sole purpose of assigning visual structure to a store 

page; for example, header, footer, left column, main column. 

Template: A collection of XML and other files that define the block structure and logic for 

visual presentation. 

Theme: a collection of templates and skin files that control the visual elements of your 

store. These visual elements are applied to all pages in your store, giving your store a 

consistent look and feel throughout. 

14.3 Changing the Web Store’s Theme 

When you first install Magento, the design elements of your store are based on the Default Theme. 

You can modify this theme, add themes created by others, or create new themes from scratch. 

http://www.magentocommerce.com/design_guide
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Tip: To design your own theme, see the Designer’s Guide to Magento at 
http://www.magentocommerce.com/design_guide 

To add and activate a theme in your store: 

1. Go to the Magento Connect site (http://www.magentocommerce.com/‌‌magento-connect). This 
site contains hundreds of extensions, which are add-ons to Magento software that can extend or 
enhance the look or functionality of your store. New ones are added often. 

2. Click on the Core link to select one of the free extensions provided by Magento. The extensions 
are listed in the center of the page, as shown in Figure 136. 

 

Figure 136. Magento Connect 

http://www.magentocommerce.com/design_guide
http://www.magentocommerce.com/magento-connect
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3. This example demonstrates the implementation of the Modern Theme. Scroll down the list of 
extensions and select the Modern Theme. 

4. Install the theme as you would any other Magento extension. See “Extending Magento,” page 
344, for more information. 

5. You can now activate this theme so that the web store appears with a new layout. Select 
System > Configuration > Design and expand the Themes section. The Design page is 
displayed, as shown in Figure 137. 

 

Figure 137. Design Page 

Tip: The Add Exception option enables you to define special themes displayed for users 
using specific browsers. An example is showing an iPhone optimized theme for 
users using this device to browse the store. 

6. In the Default field, specify the name of the theme. In this example it is called Modern. 

7. Click the Save Config button on the top right of the page. The header, footer, menu bar, and 
background of the frontend now look different according to the new theme.  

8. If your home page appears incorrect, it may be because the layout that you selected is suited to 
two columns when your home page has one column or vice versa. For the Modern theme, the 
following change must be applied so that that the frontend home page appears properly. From 
the top menu bar in the Admin Panel, select CMS > Pages to display the Manage Pages page, as 
shown in Figure 138. 
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Figure 138. Manage Pages Page 

This page shows two Home Page rows:  

 One row has the value 2 columns with right bar in its Layout column and its Status column 

shows Enabled. 

 The other row has the value 1 column in its Layout column and its Status column shows 

Disabled. 

9. Click on the first and second rows of the home page. The page shown in Figure 139 is displayed 
for each of them. 

 

Figure 139. Edit Page  

 Change the Enabled status of the page with 2 columns with right bar layout to Disabled.  

 Change the Disabled status of the page with 1 column layout to Enabled. The homepage of 

the frontend now appears similar to the page shown in Figure 140. 
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Figure 140. Frontend Home Page with New Theme 

14.4 Managing CMS Pages 

Content Management System (CMS) pages are static pages such as your Homepage, About Us and 

Customer Service pages that provide information about the web store and are managed through the 

Backend panel. CMS Pages are full pages that are available via their own URL addresses. Static 

Blocks are sections of code or graphics that can be referenced inside CMS pages as well as Category 

landing pages. They are page elements that can be reused and referenced throughout your site. 

The following example shows how to create a new page in Magento and then how to create a link 

to it from your store footer. 

To add a CMS page: 

1. Select CMS > Pages to display the list of currently defined CMS pages as shown in Figure 138. 

2. Click the Add New Page button on the top right of the page to display the New Page page, as 
shown in Figure 141. 
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Figure 141. New Page  

3. In the Page Title field, specify the words to appear in the browser’s title bar. 

4. In the URL Key field, specify the unique identifier to be used in the URL. It must contain all 
lower case letters and no spaces. The following example uses our_history. 

5. Leave the default value in the Store View field.  

6. In the Status field, select Enabled. 

7. Click Content in the left navigation bar. Use the WYSIWIG editor to define the content for this 
page. 

8. Click Design in the left navigation bar to open the design options, as shown in Figure 142. 
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Figure 142. Custom Design Options 

9. Click the Layout field and then select one of the following options: 

 Empty: Shows the content of an empty page with no header, footer or side bars.  

 1 Column: Displays all the content entered in a single central column with a header and 

footer.  

 2 Columns with left/right bar: Displays all the content entered on the page with a header, 

footer and left/right bar.  

 3 columns: Displays both the left and right columns from the design package with the 

content shown between. 

10. Click Save Page. You can now open a browser and browse to this Landing page. The URL is 
taken from the value that you specified for URL Key, as described above. For example: 
/our_history is added to the web store’s URL. 
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11. The following steps show how to add a link to this page from the frontend’s footer. Select 
CMS > Static Blocks option to display the list of existing Static Blocks. 

12. Click on the Footer Links row to display the definition of the frontend’s footer (see Figure 143).  

 

Figure 143. Editing a Static Block 

13. In the Content field, use the WYSIWYG editor to add a link to the new page. You can do this by 
pressing ENTER after one of the existing links, typing the link text, selecting this text, and 

clicking the Link icon (  ). Use the Insert/Edit Link dialog box to specify the link attributes, as 
shown in Figure 144. 



 Design and Content 

 149 

 

Figure 144. Insert/Edit Link Dialog Box 

The footer of the frontend now appears as shown in Figure 145. 

 

Figure 145. Updated Footer Block 

14.5 WYSIWYG Editor 

The Magento WYSIWYG (What You See Is What You Get) editor for CMS pages, shown in Figure 

143, was embedded in Magento from TinyMCE. More information about this editor can be found at 

http://tinymce.moxiecode.com/. 

With the Show/Hide Editor button, you can toggle between the WYSIWIG mode, where the style 

and page elements are controlled using the toolbar of buttons, and the standard HTML mode, where 

these elements are controlled using HTML tags. Content already in the page will also be converted 

automatically to match the mode. Styled content in WYSIWYG mode will reveal the tags in HTML 

mode, and vice versa. 

 WYSIWYG mode: This mode includes numerous editing features. A few of them are 

described here: 

o Insert Widget: This button enables you to insert a Widget into the CMS page. A 

dialog box enables you to create the Widget to insert. You will be able to choose 

from any of the previously mentioned Widget Types. The options in the dialog box 

include the all of the options you would see in the Widget Options tab when 

creating a Widget through CMS > Widgets, as well as the Template drop-down 

menu from the Frontend Properties tab. 

http://tinymce.moxiecode.com/
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o Insert/edit Image: This button enables you to insert an image into the CMS page. A 

dialog box enables you to configure the image. Enter the image path, or (in a 

second dialog box) browse and select the image to insert from your server 

directory. If browsing, you can upload images from your computer to the directory 

in this window, and then select them to use in the CMS page. In the original dialog 

box, you can also set other information regarding the image, including description, 

title, styling, and mouse-over effects. 

o Insert/edit embedded media: This button enables you to insert various types of 

media into the CMS page. A dialog box enables you to configure the media. Select 

the media type (Flash, QuickTime, Shockwave, Windows Media, or Real Media), 

and enter the media path, or (in a second dialog box) browse and select the media 

to insert from your server directory. If browsing, you can upload media from your 

computer to the directory in this window, and then select them to use in the CMS 

page. In the original dialog box, you can also set other information regarding the 

media, including dimensions and styling. 

 HTML mode: In HTML mode, you can insert Widgets and images. The only difference is 

that for inserting images, you see the server directory dialog box only, and you will not be 

able to set the description, styling, and so on. These must be set using HTML tags. 

14.6 Widgets 

Widgets are configurable and reusable page blocks that allow you to display dynamic (or static) 

content in the frontend. For example if you wanted to display all best sellers for a specific category 

on the top part of the category page you can use a widget rather than custom coding that capability. 

To create a new Widget: 

1. Navigate to CMS > Widgets and click Add New Widget Instance. 

2. You will need to select the type and theme to use to for this Widget, which cannot be changed 
after it has been created. The Widget type will determine which configuration options display in 
the Widget Options tab in the next step. 

3. After clicking Continue, configure the Widget with the following options: 
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 Frontend Properties: For the most part, all Widgets types have the same options in the 

Frontend Properties tab. You can set the name, Store View(s), and sort order. The sort order 

is only relevant when two or more widgets both display in the same section of the same 

page. This placement is determined in the Layout Updates section. Click Add Layout 

Update to create a rule defining where this Widget will display. You can add multiple 

Layout Updates. In the Display On drop-down menu, select on which type of page this 

Widget will display. You can choose from category pages, product pages, or other specific 

pages. If you choose a type of category or product, you can then choose specific categories 

or products, respectively. If you choose a specified page, you must then choose the page (or 

select a format of page to use, i.e. all pages with a left column). Then, in the Block 

Reference drop-down menu, select the location on this page where the Widget will be 

placed. All Widget types can be placed in the left, center, or right column, but some can 

also be placed in the header or footer. Lastly, choose the Template. Some Widget types only 

have one template, and therefore there is no ability to select. Link Widget types and product 

listing Widget types will have multiple template options to choose from. 

 Widget Options: The options in this tab depend on which type you initially selected. 

o Banner Rotator: This Widget enables you to display one or more previously created 

Banners. Banners are a new Magento feature which will be discussed in more 

depth below. From the Banners to Display drop-down menu, you can select if the 

Banners are all related to a Shopping Cart or Catalog Price Rule, in which case they 

will only display if the rule is active and applied. You will be able to associate a 

Banner with a price rule when creating the Banner. Depending on your selection 

from that drop-down menu, you will be able to choose which specific Banners to 

use. If you selected Specified Banners, then you will be able to choose each Banner 

individually from the grid below. If you chose Banners associated to a Shopping 

Cart or Catalog Price Rule, then you will need to select the Banner Type from a 

drop-down menu. Banner Type is set on the Banner level, and will help you ensure 

that the Banners will fit the Block Reference that you chose in the previous tab. 

From the Rotation Mode drop-down menu, you can select how to display the 

Banners if you have chosen more than one for this Widget. You can display them 

all at once or rotate them. If you rotate them, you can also choose if they will rotate 

randomly, in a series (they will rotate in order based on position), or shuffled (they 

will all display once in a random order, and then start over). 

o CMS Hierarchy Node Link: This Widget enables you to link to a CMS Node or 

page. Choose the Node or page by selecting it from the Hierarchy tree. Only pages 

which are part of the Hierarchy can be linked to using this Widget type. CMS 

Hierarchy is a new Magento feature, and will be discussed in more depth below. In 

addition to choosing the Node or page to link to, you can also customize the text of 

the link. 

o CMS Page Link: This Widget enables you to link to any existing CMS page. Choose 

the page by selecting it from the grid. You can also customize the text of the link. 

o CMS Static Block: This Widget enables you to insert an existing Static Block. 

Choose the Static Block by selected it from the grid. 
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o Catalog Category Link: This Widget enables you to link to a category. Choose the 

category by selecting it from the category tree. You can also customize the text of 

the link. 

o Catalog Events Carousel: This Widget enables you to insert the Events Carousel. 

You can customize the number of Events to display at once in the Carousel, the 

number of Events to scroll each time the scroll arrows are clicked, and the width of 

the Carousel, so that it will fit into the Block Reference that you chose in the 

previous tab. 

 Catalog New Products List: This Widget enables you to insert the new products block. 

Products will display in this block if the Set Product as New From/To Date range, 

configured on a per product level, includes the current date. You can customize the number 

of products to display at once, as well as the cache lifetime. 

 Catalog Product Link: This Widget enables you to link to a product. Choose the product by 

selected in from the grid. The category tree allows you to filter the product results in the 

grid. You can also customize the text of the link. 

 Recently Compared Products: This Widget enables you to insert the recently compared 

block. You can customize the number of products to display at once. 

 Recently Viewed Products: This Widget enables you to insert the recently viewed block. 

You can customize the number of products to display at once. 

14.7 Banners 

Banners are another feature in Magento which enable you to display blocks of information on the 

frontend. These blocks can contain static content and Widgets. They can also be configured to 

display only to certain types of customers, or when certain price rules are applied. 

1. To create a new Banner, navigate to CMS > Banners. After clicking Add Banner, configure the 
Banner with the following options: 

 Banner Properties 

o Banner Name: This is for internal purposes. 

o Active: Only active Banners will be able to be displayed in the frontend. 

o Applies To: Select the Banner Type(s) from this drop-down menu. A Banner can be 

associated to multiple Banner Types. As previously discussed in the Widgets 

section, Banner Types are an internal tool to help you keep track of the page area 

for which a Banner is intended. This feature is needed because you may design the 

Banner dimensions to fit a specific space. When creating a Banner Rotator Widget, 

you can select the Banners to use based on Banner Type. Possible Banner Types 

include the header, footer, left column, right column, and main content area. 
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o Customer Segments: Customer Segments are a rule-based tool for dynamically 

segmenting customers by attributes such as purchase history, items in shopping cart 

and much more. You can associate a Banner to a Customer Segment to personalize 

your marketing and merchandising of products. To do so, select Specified from the 

drop-down menu, and highlight the desired Customer Segment(s). For more 

information, see “Rich Merchandising Suite (RMS),” page 377. 

 Content: Enter your static HTML content in the text area. You can also insert Widgets and 

images into the content area. When you click Insert Widget, a pop-up window will allow 

you to create the Widget to insert. You will be able to choose from any of the previously 

mentioned Widget Types, except for Banner Rotator. The options in the pop-up window 

include all of the options you would see in the Widget Options tab when creating a Widget 

through CMS > Widgets, as well as the Template drop-down menu from the Frontend 

Properties tab. When you click Insert Image, a pop-up window will allow you select the 

image to insert from your media directory. You can also upload images from your computer 

to the directory in this window, and then select them to use in the Banner. If you are using 

multiple Store Views, you can create different content for each. 

 Related Promotions: This tab includes one grid containing all your existing Shopping Cart 

Price Rules, and one grid containing all your existing Catalog Price Rules. Select the check 

box next to a Price Rule to associate it. You can associate this Banner to multiple Shopping 

Cart and Catalog Price Rules simultaneously. If the Banner is associated to any price rules, it 

will only appear when that rule is applied (the price rule is active and the conditions in the 

rule have been met). You can also associate a Banner to a Price Rule via the Price Rule 

page. For both Shopping Cart and Catalog Price Rules, there is now a Related Banners tab 

in the Price Rule page. This tab includes a grid containing all existing Banners, which can 

be associated by selecting the check box next to the Banner. 

14.8 Versioning 

Magento’s versioning system for CMS pages enables you to create multiple versions of a page, track 

the revision history of each version and restore, and separate the ability to create and publish based 

on permissions.  

 Enabling Versions: When creating a new CMS page in Magento, you will be presented with 

the option to enable Versioning for that particular CMS page. To enable it, select Yes from 

the Under Version Control drop-down menu. If No is selected, only one version will be 

saved, and there will be no ability to restore revisions. 

 Editing Versions: After saving the page initially, the options presented will change. In the 

Page Information tab, the Currently Published Revision will display a link to the version that 

was just created. Even if the CMS page itself is not published yet (the Status is Disabled), the 

Currently Published Revision will display, and this will represent the Version and Revision 

that will appear as soon as the page becomes published. To access the content section and 

make further edits, select the Versions tab. Initially, there will only be one Version listed 

here. When you select that version, you will be redirected to a new page displaying the 

version options and the list of revisions for that version. 
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o Version Label: This is the name of your Version. It is for internal purposes, to help 

you differentiate between the content of the various Versions. When you want to 

create multiple Versions of the same page (for example, a seasonal Version and a 

regular Version), make sure to label your Versions appropriately. 

o Access Level: This sets the permissions for accessing this version. Private means 

that only the creator of this version will be able to access it. Protected means that 

only users with Publish Revision permissions (in System > Permissions > Roles) will 

be able to access it. Public means all users with CMS Pages permissions will be 

able to access it. 

o Owner: By default, this will be the user who created the page. The owner can be 

changed, which will affect access to the page if the access level is set to Private.  

 Underneath these options is a grid listing all revisions to this version. Clicking on a revision 

here will enable you to edit the content, design, and metadata. Each time an edit is made to 

any revision and saved, a new revision will be created. Alternatively, you can Save in New 

Version, which will create a new Version (in which this will be the first Revision) instead of 

saving this as a new Revision to the current Version. 

 Publishing Versions: In order to publish a page, you must select the desired Revision of the 

desired Version, and click Publish. If you are currently making edits to this Revision, the 

Publish button will instead read Save and Publish, which will simultaneously create a new 

Revision and publish the page. This published Version and Revision will now appear under 

the Currently Published Revision link in the Page Information tab (you may need to click 

Back once or twice to arrive here). Make sure that the Status is set to Published for the page 

to be visible on the frontend. 

14.9 Hierarchy 

The CMS Hierarchy feature is a categorization tool for CMS pages, enabling users with no technical 

knowledge to create complex content pages and sections of content such as Articles, a Knowledge 

Base, and more. The advantage to categorizing your CMS pages is that you will then be able to 

display automatically generated menus and/or pagination, to enable your customers to browse 

through the pages easily.  

1. To access the CMS Hierarchy, navigate to CMS > Pages > Manage Hierarchy.  
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Note: In Magento EE 1.11 and earlier, the Hierarchy can be managed per Store View 
only. In Magento EE 1.12 and later, hierarchies can be managed on both, website 
and store view levels . 

 Adding Nodes and pages - On the left side of the page will be the hierarchy tree. You can 

add nodes and pages to this tree. Nodes are used solely as folders to group child nodes 

and/or pages. Nodes cannot be viewed on the frontend. If customers visit a Node on the 

frontend, they will automatically be redirected to the first page under that node. Pages can 

be viewed on the frontend, but they can also be used as folders to group child nodes or 

pages. To add a node to the tree, click Add Node on the right of the tree. The node will be 

added to whatever folder (whether Node or page) is currently highlighted. To add a page or 

pages to the tree, select them from the grid below, and click Add Selected Page(s) to Tree. 

The page(s) will be added to whatever folder is currently highlighted. A page can only be 

added to a folder once, so it will become inactive in the grid below when that folder is 

highlighted. However, pages can be added to multiple folders.  

In Magento EE 1.12 and later, you can perform mass actions on hierarchies. To copy or 

delete a hierarchy, click the Manage Hierarchies on the left, select one or more hierarchies, 

and click Copy Hierarchy To or Delete Hierarchy From. Clicking Copy Hierarchy To copies 

the currently displayed hierarchy tree to the selected websites/store views. 

 Node and page options: When a node or page is highlighted, you will be able to edit the 

option on the right of the tree. 

o Properties: Here you can edit the title and URL key. They can only be edited for 

Nodes, because the title and URL key for pages are set in CMS > Pages > Manage 

Content. You can also preview the frontend. When previewing nodes, you will be 

redirected to the first page under that node. 

o Render Metadata in HTML Head: This section will only appear for top level nodes 

and pages. It is used for SEO purposes to define the structure of the hierarchy 

o Pagination Options for Nested Pages:  This section will appear only if child nodes 

or pages have been created under the currently highlighted node or page. They will 

control the pagination for the immediate child nodes or pages only (that is, 

pagination options for a top level node or page will control first-level child nodes 

and pages; pagination options for a first-level child node or page will control 

second-level child nodes and pages; and so on). If pagination is enabled, then links 

to the previous and upcoming pages will appear above and below the page content 

on the frontend. They will link to the other “sibling” pages. You can also control 

the number of page links to display at once. 

o Page Navigation Menu Options: If the navigation menu is enabled, then a menu 

similar to the category tree will appear on the frontend, above the page content. 

For each node, you can control the number of parent and child levels to display in 

the menu, as well as the list options for the menu (such as numbered list, bulleted 

list, and so on). 
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o Main Navigation Menu Options (available in Magento Enterprise 1.12 and later): 

For nodes and pages of the first (root) level, the section contains the Show in 

Navigation Menu field, where you can decide if the node will be included in the 

category menu in the frontend. If you select Yes, the node, with all child pages and 

nodes, will be displayed in the category menu. For nested pages and child nodes, 

the section contains the Exclude from Navigation Menu field, where you can 

choose to exclude the page or child node from the category menu, even if the 

parent root node is displayed there. 

Hierarchy can also be managed on the CMS pages themselves. To do so, select a page and click the 

Hierarchy tab in the left column. The hierarchy tree will be displayed, with a check box next to 

each node and page. You can associate this CMS page to multiple nodes or pages. 

14.10 Customizing Transactional Emails 

Transactional emails are all emails sent from a Magento store. Magento offers flexible, easy-to-use 

functionality to enable you to customize these emails and translate them into multiple languages to 

best use them for communication with your customers. 

This section describes how to modify the emails that are sent from the web store, for example, when 

an account is created or an order is placed. 

To customize a transactional email template: 

1. Select System > Transactional emails to display a list of the custom email templates created in 
this web store.  

Note: This page shows only customized emails. If this page is empty, it means that 
Magento will only send standard default emails. 

2. Click the Add New Template button to display the New Email Template page. See Figure 146. 
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Figure 146. New Email Template Page 

3. In the Template field, select the name of one of the transactional emails that you want to 
customize, such as New account.  

4. In the Locale field, select the language. 

5. Click Load Template. 

6. In the Template Name field, specify a name for the customized email template. 

7. If desired, modify the Template Subject field. 

8. In the Template Content area, use the WYSIWIG editor to modify the content. You must change 
the contact phone number and email address as well as the logo image reference at the top of 
the page to reflect your own store information in all active templates.  

9. Click the Save Template button. 

10. Now that your customized email template is ready and available, the next step is to inform 
Magento that it should use this template to send email to customers instead of the default 
template. This is controlled in various configuration sections depending on the type of email.  

In our example of customizing a New Account email, select System > Configuration > 

Customers > Customer Configuration. Then expand the Create New Account Options section 

and select your newly customized transactional email in the Default Welcome Email field. 
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15 Taxes 
Magento provides a variety of options for defining taxes that can be accessed by selecting the Sales menu 

and then the Tax option. Tax classes are used to define “tax rules.” Tax rules are defined as a combination of 

a Product Class, a Customer Class and a Tax Zone and Rate, as described below.  

Each type of customer can be assigned a customer class when you define them, and each product is 

assigned a tax class. For a description of how to define a customer, see “Managing Customers,” page 315. 

For a description of how to define a product, see “Creating a New Product,” page 80. 

Magento analyzes the shopping cart of each customer and calculates the appropriate tax according to the 

class of the customer, the class of the products in the shopping cart, and the region (as defined by the 

customer’s shipping address, billing address or shipping origin). 

Magento also supports the calculation of Value-Added Tax (VAT) for business-to-business transactions in the 

European Union. For more information, see “VAT ID Validation,” page 476. 

15.1 General Taxation Settings 

To configure general taxation settings:  

1. From the System menu, select the Configuration option.  

2. From the SALES section in the panel on the left, select Tax. 

3. Expand the Tax Classes section, and in the Tax Class for Shipping field, specify the tax class 
charged on the shipping amount, as shown in Figure 147. With Sample Data populated, we 
have added three examples of tax classes for Shipping. If your store changes additional tax on 
shipping expenses then you should designate the product tax class that will apply to shipping.  

 

Figure 147. Tax Class for Shipping 

4. Expand the Calculation Settings section, as shown in Figure 148. 

http://www.magentocommerce.com/knowledge-base/entry/what-are-tax-rules-and-how-do-i-use-them
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Figure 148. Tax Calculation Settings 

5. In the Tax Calculation Method Based On field, select whether the tax is based on the price of 
each unit, or on the “row total” (that is, the total for a line item in the order, accounting for any 
discounts). 

6. In the Tax Calculation Based On field, select whether the tax is calculated based on the 
customer’s shipping address, billing address, or your store’s shipping origin. 

7. In the Catalog Prices field, specify whether the catalog prices of items include tax or exclude 
tax.  

8. In the Shipping Prices field, select whether the shipping amounts include tax or exclude tax.  

9. In the Apply Customer Tax field, select whether tax is applied to the original or discounted 
price. 

10. In the Apply Discount on Prices field, select whether any discounts applied include the tax or 
exclude it. 

11. In the Apply Tax On field, select whether tax is applied to custom prices or to original prices. 

12. Expand the Default Tax Origin Calculation section to specify which country is used by Magento 
as the default for tax calculation, as shown in Figure 149. 

 

Figure 149. Default Tax Origin Calculation 

Note: If you set the Display Product Prices field to Including Tax in the Display section 
described below, then the tax is only displayed if there is a tax rule that matches 
the tax origin or if Magento detects that the customer address matches the tax rule 
(which happens after a customer creates an account, logs in, or uses the Tax and 
Shipping estimation tool in the cart). 

13. Expand the Price Display Settings tab to select whether display prices for products and shipping 
include tax or exclude tax. 
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14. Expand the Display section to select how taxes and prices are shown for products and in a 
shopping cart according to the requirements (legal and otherwise) of your store, as shown in 
Figure 150. 

 

Figure 150. Shopping Cart Tax Display Settings 

15. Expand the Orders, Invoices, Credit Memos Display Settings tab to select how prices and taxes 
are displayed in orders, invoices, and credit memos. 

16. Expand the Fixed Product Taxes tab to specify the behavior of fixed per product taxes, such as 
the European DEEE/WEEE (Waste Electrical and Electronic Equipment) tax, according to the 
requirements for your store and products. 

Note: To assign a fixed tax to a product, create an attribute with the Catalog Input Type 
for Store Owner set to Fixed Product Tax, and assign this attribute to the attribute 
set for the product. 

15.2 Product Tax Class 

You create product tax classes and assign products to them depending on the type of product. For 

example, food might not be taxed (or might be taxed at a different rate). 

To define a product tax class:  

1. Select Sales > Tax > Product Tax Class to display the Product Tax Classes page (Figure 151), 
which shows a list of the previously defined product tax classes.  

 

Figure 151. Product Tax Classes Page 

2. Click the Add New button to display the New Class page, as shown in Figure 152. 

 

Figure 152. New Product Tax Class Page 
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3. In the Class Name field, specify a name for this tax class. 

Note: You can apply a tax class to a product by editing the product and choosing the 
appropriate option on the Prices tab. 

4. Click Save Class.  

15.3 Customer Tax Class 

You create customer tax classes and assign customers to them depending on the type of customer. 

For example, in some jurisdictions, wholesale transactions are not taxed but retail transactions are. 

To define a customer tax class: 

1. Select Sales > Tax > Customer Tax Classes to display a list of the previously defined customer 
tax classes. 

2. Click the Add New button to display the New Class page, as shown in Figure 153. 

 

Figure 153. New Customer Tax Class Page 

3. In the Class Name field, specify a name for this tax class. 

Note: You can link a customer tax class to a customer group by editing the customer 
group. You can then assign this customer group when creating or editing a 
customer. 

4. Click the Save Class button.  

15.4 Tax Zones and Rates 

Tax rates are generally applicable to transactions that take place in specific geographical areas. The 

Tax Zones and Rates feature enables you to specify the tax rate for each geographical area for which 

you collect and remit taxes. Because you give each tax zone and rate specification a unique 

identifier, you can have multiple tax rates for a given geographic area (for example, for places that 

do not tax food or medicine but tax other products). 

To define tax zones and rates:  

1. Select Sales > Tax > Manage Tax Zones and Rates option to display a list of the previously 
defined tax zones and rates. 
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Figure 154. Manage Tax Rates Page 

2. Click Add New Tax Rate to display the Add New Tax Rate page, as shown in Figure 155. 

 

Figure 155. Add New Tax Rate Page 

3. In the Tax Identifier field, specify a unique name for this tax. Do not use spaces. This identifier 
is not shown in the frontend if the Tax Titles section is filled in, as described below.  

4. Select the location by using the Country and State drop-down menus. 

5. For Zip/Post is Range, select whether the Zip or postal code specification needs to be expressed 
as a range of codes or an individual code. 

 If you select No, specify the Zip or postal code in the Zip/Post Code field. You can use the * 

wildcard character in this field; for example, 90* means all Zip codes form 90000 through 

90999. 

 If you select Yes, specify the starting and ending Zip or postal codes in the Range From and 

Range To fields. 

6. In the Rate field, specify the percentage of tax. 

7. In the Tax Titles section, specify a name of this tax for each store view. 

8. Click the Save Rate button. 

15.5 Tax Management Rules 

Tax management rules put all the taxation elements together: product tax classes, customer tax 

classes, and tax zones and rates. 
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To define Tax Management Rules: 

1. To define how taxes are charged, select Sales > Tax > Manage Tax Rules to display a list of the 
previously defined tax rules, as shown in Figure 156. 

 

Figure 156. Manage Tax Rules Page 

Each tax rule is composed of a customer tax class, a product tax class, and a tax rate. 

2. To define a new tax rule, click Add New Tax Rule to display the Edit Rule page, as shown in 
Figure 157. 

 

Figure 157. Edit Rule Page 

3. Select a Customer Tax Class, Product Tax Class and Tax Rate for this rule. This rule defines that 
the tax rate you select is applied to the customers in the selected customer tax class and the 
products in the selected product tax class. 

4. In the Tax Priority field, specify the priority of this tax, when more than one tax applies. If two 
tax rules with the same priority apply then the taxes are added together. If two taxes with a 
different priority apply then the taxes are compounded.  

5. The Sort Order field enables you to specify the order in which tax rules are displayed on the 
Manage Tax Rules page. 

6. Click Save Rule or Save and Continue Edit to save your changes. 
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Tip: When numerous taxes must be defined, you can ease the process by importing 
them from a spreadsheet. Select Sales > Tax > Import/Export Tax Rates. 
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16 Shipping 
A variety of shipping methods are available for selection in Magento. This section describes a few of 

these shipping rate options for your web store.  

16.1 General Shipping Settings 

To configure general shipping settings:  

1. Select System > Configuration > Shipping Settings. 

2. Expand the Origin section and specify the address used for shipping calculations. Typically, this 
is the warehouse address from which products are shipped, as shown in Figure 158. 

 

Figure 158. Shipping Origin Settings 

3. Expand the Options section, as shown in Figure 159. 

 

Figure 159. Shipping Options Settings 

4. In this section, enable or disable shipping to multiple addresses. Shipping to multiple addresses 
is very useful for stores that sell gifts. It enables customers to send various parts of an order to 
different destinations. 

5. Click Save Config to save your changes. 

16.2 Flat Shipping Rates 

A flat shipping rate refers to a fixed predefined cost for shipping which can be applied per item or 

per shipment, according to your preferences. 

To define flat shipping rates: 

1. Select System > Configuration > Shipping Method.  
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2. Expand the Flat Rate section to define a fixed predefined amount for shipping, as shown in 
Figure 160. 

 

Figure 160. Flat Rate Shipping Settings 

Tip: Magento also provides the option to specify table rates by expanding the Table 
Rates section. This feature enables you to define shipping rates by weight, 
destination, price, the number of items and various combinations of these 
categories. The table rates are entered by importing a CSV file. See 
http://www.magentocommerce.com/knowledge-base/entry/how-do-i-set-up-table-
rate-shipping for more information. 

3. In the Enabled field, select Yes. The flat rate method then appears as an option in the shopping 
cart and on the shipping page during the checkout. 

4. The contents of Title and Method name fields appear in the frontend as shown in Figure 161. 

http://www.magentocommerce.com/knowledge-base/entry/how-do-i-set-up-table-rate-shipping
http://www.magentocommerce.com/knowledge-base/entry/how-do-i-set-up-table-rate-shipping
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Figure 161. Flat Rate Shipping Method and Title 

Note: Some Shipping Methods, such as UPS, provide a variety of shipping methods to 
choose from. 

5. In the Type field, specify the entity to which the shipping fee applies, such as Per Item. In this 
case, the shipping fee is dependent on the number of items shipped. If you set the rate to be per 
item, it is multiplied by the total quantity of items in the shopping cart. If you have two of the 
same item or two different items, then the rate is the same. You can also select Per Order in this 
field. 

6. In the Ship to applicable countries field, you can select the Specific Countries option to enable 
access to the field under it in which you can select specific countries, so that the appropriate 
(and different) shipping rates are applied to the relevant countries, as shown in Figure 162. 

 

Figure 162. Specific Countries Selection 

Tip: Hold down the Ctrl key while clicking options to select multiple countries. 

7. In the Sort Order field, specify the position of this shipping method in relation to the other 
shipping methods offered to the customer. 

16.3 Online Rates 

Apart from static options such as flat rates and table rates, Magento also offers dynamic retrieval of 

rates from various shipping providers. 
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Note: Most shipping providers require that you open an account with them. Consult 
your shipping provider for details on how to obtain API credentials. 

To enable and configure these shipping methods, expand the appropriate tabs (UPS, USPS, FedEx, 

or DHL) and configure the settings. The configuration of this method is similar to the configuration 

of a Flat Rate, as described above. The exact options depend on the service provider; contact the 

provider for more information. 

For example, UPS rates can appear in your web store as shown in Figure 163. 

 

Figure 163. UPS Shipping Options 

16.4 Offering Free Shipping 

Tip: Free shipping per product can be defined as a shopping cart price rule. See 
“Catalog and Shopping Cart Price Rules,” page 274, for more information. This 
option enables you to set up free shipping that is valid only when a customer 
provides the appropriate discount code. 

To define free shipping:  

1. Select System > Configuration > Shipping Methods. 

2. Expand the Free Shipping section to enable free shipping with optional minimum order amount, 
as shown in Figure 164. 
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Figure 164. Free Shipping Settings 

3. In the Enabled field select Yes to enable the method.  

4. In the Minimum order amount field specify the amount for an order over which shipping is 
provided free of charge.  

5. In the Ship to applicable countries field, you can select the Specific Countries option to enable 
access to the field under it in which you can select specific countries, so that free shipping is 
only applied to the relevant countries or you can select the All Allowed Countries to specify that 
free shipping is available for users from all countries. 

16.5 Acquiring Additional Shipping Modules 

Numerous other shipping modules are provided at http://www.magentocommerce.com/magento-

connect and new ones are uploaded often. More information on installing shipping extensions is 

provided in “Extending Magento,” page 344. 

http://www.magentocommerce.com/magento-connect
http://www.magentocommerce.com/magento-connect
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17 Shipping Integration with Label Printing 
Support 

This chapter describes how you can create shipments with major shipping service providers and print 

shipping labels directly in the Magento Admin Panel. 

This feature was introduced in Version 1.11 of Magento Enterprise Edition. 

17.1 Terminology List 

The following terminology is used in reference to this feature: 

 International shipments: Shipments where the sender and recipient are in different 

countries; international borders are crossed. 

 Domestic shipments: Shipments where the sender and recipient are in the same country; no 

international borders are crossed. 

17.2 Shipping Integration – General Concept 

Magento Enterprise Edition includes a higher level of integration with several major shipping 

carriers, which includes creating shipping labels, creating shipment orders in the shipping carrier 

systems, and automatic tracking number entry in the Magento Admin Panel.  

The shipping labels feature is supported for the following shipping service carriers:  

 UPS 

 USPS 

 FedEx 

 DHL 

Shipping labels can be created in the Magento Admin Panel from the shipments pages, and from the 

Return Merchandise Authorization (RMA) managing pages. For details about RMA implementation, 

see Return Merchandise Authorization,” page 178. 

When you choose to create a shipping label, Magento prompts you to specify the information about 

packages you want to use (type, size, etc.) and its contents (which products go to which packages). 

When you finish, Magento connects to the shipping carrier web-services, creates an order in its 

system, and receives the shipping label for the shipment. The tracking number(s) are also received 

and added in the Admin Panel. 
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Note: An individual shipment order for each package is created, as a result multiple 
shipping labels can be received for one shipment in Magento. 

17.3 Configuring Store Address and Shipping Method 
Settings 

The following configuration fields (at the product level, in the shipping settings, and in the shipping 

methods settings) support the shipping integration and label printing functionality: 

 On the product level 

Option Description 

Country of Manufacture Mandatory for USPS and FedEx international shipments. 

 In the shipping settings under System > Configuration > Shipping Settings > Origin 

Option Description 

Street Address The street address of the place from which your shipments will be sent (that 

is, the location of your company or warehouse). 

Mandatory for shipping label creation. 

Street Address Line 2  Specify any possible address details here, like floor, entrance and so on. We 

strongly recommend that you use this field. 

 In the shipping methods settings under System > Configuration > Shipping Methods > USPS 

Option Description 

Secure Gateway URL You do not need to configure this field, it is pre-populated by Magento. 

Password A password for enabling shipment order creation in the shipping carrier 

system using web-services. You must acquire this password from the 

shipping carrier. 

Length, Width, Height, 

Girth 

The default dimensions of the package. These fields appear if you select 

Large option in the Size field. 

 In the shipping methods settings under System > Configuration > Shipping Methods > FedEx 

Option Description 

Meter Number, Key, 

Password 

These credentials are required for enabling shipment order creation in the 

shipping carrier system using web-services. You must acquire this 

information from the shipping carrier 

Also, ensure that you have specified the store information under System > Configuration > 

General > Store Information. If these options are not set, Magento will not proceed with shipping 

label creation, and an error message will be displayed. 

We also strongly recommend that you configure all shipping method settings under System > 

Configuration > Shipping Methods for each shipping carrier that you want to use for shipping label 

creation. 
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17.4 Creating and Printing Shipping Labels  

You can decide to create a shipping label while creating the shipment in the Magento Admin Panel, 

or later, when the shipment already exists. 

To create a shipping label at the shipment creation stage: 

1. Select Sales, and click Orders. 

2. Open your order for editing. 

3. Click the Ship button in the upper right corner of the order view. The New Shipment page 
opens. 

4. Configure the shipment, select the Create Shipping Label check box above the Submit Shipment 
button, and click Submit Shipment. The Create Packages pop-up window appears. 

5. In the Create Packages pop-up window, add the packages, distribute all shipped products 
among the packages, and click OK (for details, see “Creating Packages in the Create Packages 
Pop-Up Window,” page 173). This is a required step for creating a shipping label. If you click 
Cancel, the shipping label will not be created and the Create Shipping Label check box will be 
cleared.  

6. Magento connects to the shipping carrier, creates the order in its system, and receives a 
shipping label and tracking number for each package. If a shipping label is successfully created, 
the new shipment is saved and the shipping label is available for printing. A tracking number is 
displayed in the Shipping and Tracking Information section. If the shipping label cannot be 
created due to problems with connection or any other reason, the shipment is not created. 

To create a shipping label for an existing shipment: 

1. Open a shipment for editing. 

2. Click the Create Shipping Label button in the Shipping and Tracking Information section. The 
Create Packages pop-up window appears. 

3. In the Create Packages pop-up add packages, distribute all shipped products between packages 
and click OK (for details, see “Creating Packages in the Create Packages Pop-Up Window,” 
page 173). 

Note: This is a required step for creating the shipping label. If you click Cancel, the 
shipping label is not created. 

4. Magento connects to the shipping carrier, creates the order in its system, and receives a 
shipping label and a tracking number. If a shipping label for this shipment already existed in the 
system, it is replaced with a new one. Existing tracking numbers are not replaced. The new 
received tracking numbers are added to the existing ones. 

The information about created packages and their contents is saved in the system. To view the 

information, click the Show Packages button located next to the Print Shipping Label button.  

If you create shipping labels multiple times, the Show Packages window reflects the most recent 

package configuration. 
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To print a shipping label: 

1. Open the shipment for editing. 

2. Click the Print Shipping Label button in the Shipping and Tracking Information block of the 
shipment view. See Figure 165. 

 

Figure 165. Shipping Labels Related Controls on the Shipment Page 

Shipping labels are stored in PDF format. When you click the Print Shipping Label button, the PDF 

file is downloaded. If your browser settings allow it, you can open the file at once, and print the 

shipping labels. Each shipping label is placed on a separate page in the PDF file. 

In addition to the usual information each shipping carrier adds to a shipping label, it will contain the 

Magento order number, number of the package, and the total quantity of packages for the Magento 

shipment. For all shipping labels created from Magento for DHL, FedEx, and UPS shipments, the 

“Type of Goods” field of a shipping label will have the value “Merchandise.” For USPS, it will 

contain the value that is specified in the Contents field in the Create Packages pop-up window. 

Note: If the Print Shipping Label button is not displayed, it means the shipping label has 
not been created for this shipment yet. You need to click the Create Shipping Label 
button first. If Magento succeeds in receiving the shipping label from the shipping 
service carrier, then the Print Shipping Label button will be displayed.  

Creating Packages in the Create Packages Pop-Up Window 

This section describes the Create Packages pop-up window, how packages are created, and how 

products are distributed between packages. 

The Create Packages pop-up window appears if you choose to create a shipping label. You can start 

configuring the first package at once. 



Shipping Integration with Label Printing Support 

174 

To configure a package: 

1. Specify the following: 

Option Description 

Type The type of a package. Select one of the predefined values. Available package 

types are different for each shipping carrier, and also depend on the shipping 

method selected during order creation. To see the complete list of shipping 

methods and their supported packages implemented in Magento, see “Shipping 

Methods and Package Types Available in Magento,” page 472. 

When the Create Packages pop-up window opens, the default package for the 

shipping carrier set in system configuration is selected in the Type field.  

If you select a package, which is not designed by a shipping carrier, you will 

need to specify the dimensions of the package. 

This field is unavailable for USPS domestic shipments, because specifying 

package types is not necessary for these shipments. 

Total Weight The total weight of a package. The field is pre-populated with the total weight of 

products in a package, after you add them, but can be edited manually. The 

measurement units can be specified using the drop-down menu next to the field; 

select between pounds and kilograms. 

Length The length of a package, integer and floating point numbers. The field is enabled 

if the custom package type is used. The measurement units can be specified 

using the drop-down menu next to the Height field; select between inches and 

centimeters. 

Width The width of a package, integer and floating point numbers. The field is enabled 

if the custom package type is used. The measurement units can be specified 

using the drop-down menu next to the Height field; select between inches and 

centimeters. 

Height The height of a package, integer and floating point numbers. The field is enabled 

if the custom package type is used. The measurement units can be specified 

using the drop-down menu next to the Height field; select between inches and 

centimeters. 

Signature Confirmation Defines delivery confirmation. Possible values: 

 Not Required – no delivery confirmation letter is sent to you. 

 No Signature – a delivery confirmation letter without a recipient’s signature 

is sent to you. 

 Signature Required – the shipping carrier obtains the recipient’s signature 

and provides you with its printed copy. 

 Adult Required – the shipping carrier obtains the adult recipient’s signature 

and provides you with its printed copy. 

 Direct (FedEx only) – FedEx obtains a signature from someone at the 

delivery address and reattempts delivery if no one is available to sign for 

the package.  
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Option Description 

 Indirect (FedEx only) – FedEx obtains a signature in one of three ways: (1) 

from someone at the delivery address; (2) from a neighbor, building 

manager or other person at a neighboring address; or (3) the recipient can 

leave a signed FedEx Door Tag authorizing release of the package without 

anyone present. Available for residential deliveries only. 

The field availability and options may vary slightly for different shipping 

methods. 

For the most up to date information please refer to shipping carrier’s resources. 

Contents 

(available for USPS 

shipments only) 

Description of the package contents. Select from the following: 

 Gift 

 Documents 

 Commercial Sample 

 Returned Goods 

 Merchandise 

 Other 

Explanation 

(available for USPS 

shipments only) 

Detailed description of the package content. 

Note: If you select the non-default value in the Type field or choose to require a 
signature confirmation, the price of a shipment may differ from the one you 
charged to the customer. 

2. To view a list of shipped products and add them to the package, click the Add Products button. 
The grid with the list of the shipped products appears. The Qty column is pre-populated with 
the maximum available quantity to add (for the Package 1 this number is equal to the total 
shipped quantity of the product).  

3. Specify the products and quantities. To add the products to the package, click the Add Selected 
Product(s) to Package button in the header of the grid. The products are added to the package. 

To add a new package, click the Add Package button in the window header. 

You can add several packages, and edit them simultaneously.  

To delete a package, click the Delete Package button. 

Changing Product Quantities in an Existing Package 

After the products are added to the package, their quantity cannot be edited directly. To increase the 

quantity of the product in the package, click the Add Selection button, and specify the additional 

quantity. This number will be added to the previous quantity of the product in the package. To 

decrease the quantity, delete the product from the package, click Add Selection, and specify the 

new, smaller value. 
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After you distribute all products, the total number of the packages you are going to use is equal to 

the number of the last package in the list. 

The OK button is disabled until all shipped items are distributed between packages and all 

necessary information is specified. After you finish creating packages and distributing the products, 

click OK. Magento starts the shipping label generation process.  

If you click Cancel, your packages are not saved and shipping label creation is canceled. 

Printing Shipping Labels for Multiple Orders  

Printing shipping labels is available as mass action on the Orders and the Shipments pages. 

To print shipping labels for the shipments of multiple orders: 

1. Select Sales, and click Orders. The Orders page opens. 

2. Using the check boxes in the left column, select the desired orders. 

3. In the Actions drop-down menu, select Print Shipping Labels. 

4. Click the Submit button.  

Shipping labels will be printed for all shipments that are related to the selected orders, for which 

shipping labels have already been created. 

Similarly, the Print Shipping Labels mass action is available on the Shipments page (see Figure 166). 

To open the Shipments page: 

 On the Magento top menu navigate to Sales > Shipments. 

 

Figure 166. "Print Shipping Labels" Mass Action 

Tracking Numbers 

Together with shipping labels, Magento receives the tracking numbers related to the 

shipment. The tracking numbers are inserted in the Shipping and Tracking Information 

section. When you create shipping labels multiple times, previous tracking numbers are not 

deleted.  



 Shipping Integration with Label Printing Support 

 177 

Note: The logic for tracking numbers is different when shipping labels are created for 
merchandise returns from RMA managing pages: old tracking numbers are replaced 
with new ones in this case. 

17.5 Shipping Integration Implementation Features 

Shipping integration in Magento has the following constraints: 

 DHL: Due to carrier limitations, shipping labels can be created for U.S. originating 

shipments only. 

 FedEx: For non-U.S. stores, creating labels is possible for international shipments only. 

(FedEx does not allow domestic shipments originating outside the U.S.)  

 UPS: Creating labels is currently possible for U.S. originating shipments only (specific 

credentials are required for non-U.S. stores). 
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18 Return Merchandise Authorization (RMA) 
This chapter describes how merchandise returns can be processed in Magento Enterprise Edition using the 

Return Merchandise Authorization (RMA) feature. 

This feature was introduced in Version 1.11 of Magento Enterprise Edition. 

18.1 RMA – General Concept 

The general workflow of RMA processing is the following: 

1. A store customer places an RMA request. Both logged in and non-logged in customers can 
create requests. You can create a request in the Admin Panel as well. 

2. You consider the request. You can authorize (preapprove) it partially, or completely, or cancel. 
If you authorize the return and agree to pay for the return shipment, you can create the 
shipment order with one of the supported shipping carriers, right from the Admin Panel.  

3. The customer sends back the merchandise. 

4. You approve the return partially or completely, or cancel it. 

With the RMA feature, you can process returns for the following product types: 

 Simple  

 Grouped 

 Configurable 

 Bundle 

Virtual products, downloadable products, and gift cards cannot be processed. 

You can choose to disable the RMA functionality for all products on the frontend, or configure only 

certain products to be unavailable for returns.  

Note: To ensure that RMA functionality works correctly, in Magento Enterprise Edition, 
starting from version 1.11, it is strongly recommended that you not create refunds, 
without creating and completing the corresponding RMA request. Otherwise, 
available quantities of the products may be counted incorrectly. 

18.2 Configuring the RMA Feature 

Unless the whole RMA module is disabled, creating RMA requests is always available in the Admin 

Panel. Allowing store customers to use the RMA functionality is optional and can be configured.  

To enable and configure the RMA functionality: 

1. Select System and click Configuration. 

2. In the Current Configuration Scope drop-down menu in the upper-left corner of the page, select 
the desired website. 
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3. Under SALES in the left column, click Sales. 

4. In the RMA Settings field set, the following options are available: 

Option Description 

Enable RMA on Frontend Defines whether store customers can create and view RMA 

requests. The default value is No. 

Can be configured for each store view. Applied to both new 

and existing orders. 

Enable RMA on Product Level Defines the default value for the Enable RMA field on 

product pages. Can be set for each store view. 

Use Store Address Select which address and contact name is used for return 

merchandise shipments. If you select Yes, the address set 

under the System > Configuration > SALES > Shipping 

Settings > Origin is used.  

If you select No, the address fields below become 

available, and you can specify an alternate address. 

Regardless of the value selected, the store name and the 

store contact telephone, necessary for shipping label 

creation, are taken from the configuration settings under 

System > Configuration > General > Store Information. 

Contact Name (available if Use Store 

Address is set to No) 

The name of the store contact person. 

Street Address (available if Use Store 

Address is set to No) 

Specify the street address for a store address, which is used 

for returned merchandise shipments. 

City (available if Use Store Address is 

set to No) 

Specify the city for a store address, which is used for 

returned merchandise shipments. 

State/Province (available if Use Store 

Address is set to No) 

Specify the state/region for a store address, which is used 

for returned merchandise shipments. 

ZIP/Postal Code Specify the ZIP/postal code for a store address, which is 

used for returned merchandise shipments. 

Country Specify the country for a store address, which is used for 

returned merchandise shipments. 

5. To save the configuration, click the Save Config button in the upper-right corner of the page. 

Note: If all items in the order are configured to be not available for return, the RMA 
request cannot be created for this order on the frontend, nor in the Admin Panel. 

18.3 Configuring RMA at the Product Level 

Availability for RMA for separate items can be configured using the Enable RMA system attribute. 

This system attribute is available for simple, grouped, configurable, and bundle products.  
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The Enable RMA attribute is available on the General tab of the product view. By default, it is set to 

Use Config and configuration settings are applied. If you set it to No, the product will not appear in 

the list of items available for return, in both frontend and backend returns.  

Changes of the Enable RMA attribute value are applied to the products in the already existing orders 

as well.  

18.4 Configuring RMA Emails 

You can configure Magento to send email notifications to a customer at different stages of RMA 

processing. 

To enable and configure RMA email notifications: 

1. Select System, and click Configuration. 

2. Under SALES in the left column click Sales Emails.  

3. Expand the RMA field set. The fields on the RMA field set configure the emails sent to the 
customers upon RMAs creation. The following options are available: 

Option Description 

Enabled Select Yes to send email notifications upon RMA creation 

(RMA email).  

If you set Enabled to No, you can still choose to send the 

notification, when creating an RMA request in the Admin 

Panel. 

RMA Email Sender Specify the email address that is used as the RMA email 

sender. 

RMA Email Template Select a template for the RMA email. 

Custom templates can be created under System > 

Transactional Emails. 

RMA Email Template for Guest Select a template for the RMA email in case the return was 

created by a non-logged in customer. 

Custom templates can be created under System > 

Transactional Emails. 

Send RMA Email Copy To The email address to which a copy of RMA email is sent. 

Send RMA Email Copy Method Specify the copy sending method for the RMA email. Select 

between Bcc and Separate Email. 
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Note: If you select the Use Website check box near the option, the settings made on the 
website level (that is, in the Current Configuration Scope your website is selected) 
are used.  

4. The RMA Authorization, RMA Admin Comments and RMA Customer Comments field sets 
contain similar options for other RMA email notifications. The RMA Authorization field set 
configures the email notifications that are sent to customers after RMA requests are authorized 
by the store administrator. 

The RMA Admin Comments and RMA Customer Comments field sets configure the email 

notifications sent to the customer when comments are added to the RMA requests by customers 

and the store administrator, respectively. 

5. To save the configuration, click the Save Config button in the upper-right corner of the page. 

18.5 Enabling Shipping Methods for Return Shipments 

Magento Enterprise Edition includes a higher level of integration with UPS, USPS, DHL, and FedEx. 

This integration can be used for return products shipments as well. If you decide to authorize a 

return, you can create a shipment order in a shipping carrier system and print a shipping label from 

the RMA management section of the Magento Admin Panel.  

To enable shipping methods to be used for RMA: 

1. Select System > Configuration. 

2. In the Current Configuration Scope drop-down menu in the upper-left corner of the page select 
the desired website. 

3. In the left column under SALES click Shipping Methods. 

4. In the field set for the desired shipping carrier (UPS, USPS, FedEx, DHL), in the Enabled for 
RMA field select Yes. 

5. To save the configuration, click the Save Config button in the upper-right corner of the page. 

Using the shipping integration functionality requires store address and shipping methods settings to 

be carefully configured. See “Shipping Integration with Label Printing Support,” page 170 for 

information about shipping integration settings. 

For details about creating shipping orders and shipping labels for RMA shipments, see “Return 

Shipments,” page 191. 
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Note: RMA shipping expenses are not included in the Shipping reports. 

18.6 Creating and Managing RMA Item Attributes 

The RMA item attributes are properties of the return items. There are four system attributes related to 

RMAs: Resolution, Item Condition, Reason to Return and Other. These fields are filled in by a 

customer when an RMA request is created, and can be later edited by a backend user. If you want 

customers to specify other information, you can create other item attributes. You can also change 

the existing options for the system attributes. See Figure 167. 

 

Figure 167. Items Attribute Fields on the New Return Page on the Frontend 

To manage the RMA item attributes, select Sales > RMA > RMA Item Attributes.  

You can create, edit and delete RMA item attributes. Working with RMA item attributes is similar to 

working with attributes of products. 

18.7 Placing an RMA Request on the Frontend 

RMA requests can be created only for shipped orders (at least one shipment created). Both account-

holding and guest customers can place RMA requests.  
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Account-Holding Customer Placing an RMA Request on the 
Frontend 

To place an RMA request, an authorized (logged in) account-holding store customer does the 

following: 

1. Select My Account > My Orders. 

2. Locate the order containing the items to be returned. 

3. Click the View Order link. 

4. Click the Return link in the upper-right corner of the order view. See Figure 168. 

 

Figure 168. Return Link for Account-Holding Store Customers 

The New Return for Order page opens. The field block for the first product to return is 

displayed.  

5. By default, for each return product a customer must fill the following fields. (The fields 
correspond to the RMA attributes, which can be managed in the Admin Panel. For details, see 
“Creating and Managing RMA Item Attributes,” page 182.) 

 Quantity to Return: The quantity of the product items that a customer wants to return. For 

complex products this field does not appear. The customer specifies the quantity to return 

for each simple product in the Item field.  

 Reason to Return: By default, the following values are available: Wrong Color, Wrong Size, 

Out of Order, and Other. If Other is selected, the additional text field appears for specifying 

the reason. 

 Desired Resolution: The way the customer wants to resolve the situation. By default, the 

following values are available: Exchange, Refund, Store Credit. 

 Item Condition: By default, the following values are available: Unopened, Opened, and 

Damaged. 
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To add more products to the return request the customer should use the Add Item to Return link 

in the bottom of the page. 

6. When the customer is finished supplying the information about all products to be returned, the 
customer saves the request by using the Save button.  

After the return request is saved, it can be viewed on the My Returns tab of the customer’s 

account page. The request cannot be edited, but comments can be added to the saved 

return requests. 

Upon creation, a return request is in Pending status. When the request status changes, it is 

reflected in the customer’s account on the frontend as well. 

Guest Customer Placing an RMA Request on the Frontend 

To create a return request, a guest customer must do the following: 

1. Click the Orders and Returns link in the store page footer.  

2. Fill the following fields (redundant information about the order is required for purposes of 
security): 

 Order ID 

 Billing Last Name (as it is specified in the order billing address) 

 Find Order By: The possible values are Email Address and ZIP Code 

 Email Address/Billing ZIP Code: Depends on the selection in the Find Order By field 

3. Click Continue. The New Return for Order page opens.  

4. Fill in the fields and save the request on the New Return page (see step 5 in “Account-Holding 
Customer Placing an RMA Request on the Frontend,” page 183). 

Creating an RMA Request Using the Orders and Returns Widget 

Magento Enterprise Edition includes an Orders and Returns widget. A widget of this type enables 

guest customers to access their orders one step quicker, compared to using the Orders and Returns 

link in the page footer. 

Figure 169 illustrates an example of the Orders and Returns widget on the frontend: 
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Figure 169. Orders and Returns Widget 

Note: If you add a widget of this type, the returns will be available for guest customers, 
even if the RMA functionality is set to be unavailable on the frontend. 

To access the widget management functionality, on the Magento top menu navigate to CMS > 

Widgets.  

18.8 Placing an RMA Request on the Backend 

In the Admin Panel, you can create RMA requests from three locations:  

 RMA managing section  

 Order management section, from the order view page 

 Customer management  section, from the customer’s page 

Creating an RMA Request from the RMA Management Section 

To access the RMA management section navigate to Sales > RMA > Manage RMA. See Figure 170. 
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Figure 170. Creating a New RMA Request from the RMA Managing Section 

When you click the New RMA Request button, the Create New RMA page opens.  

Creating an RMA Request from the Order View Page 

To open the order view of a particular order, navigate to Sales > Orders, and click the desired order. 

See Figure 171. 

 

Figure 171. Creating RMA Request from the Order View Page 

When you click the Create RMA button, the Create New RMA page opens. 

Creating an RMA Request from a Customer Page 

To access the customer page, navigate to Customers > Manage Customers, and click the desired 

customer.  
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Figure 172. Creating an RMA Request from the Customer Page 

On the Order tab of the customer page, the Return link is available only for shipped orders. When 

you click the link, the Create New RMA page opens. 

Setting Up and Saving a New RMA Request 

The first step in creating an RMA request from the Admin Panel is specifying the order from which 

items need to be returned. If you selected to create an RMA request from the Customer view page or 

Order view page, this step is omitted. 

To set up and save a new RMA request on the Create New RMA page: 

1. On the General Information tab you can type the contact email address of the customer, add 
comments and see the shipping cost estimation using the Get shipping methods and rates link in 
the Shipping Method section.  
If you want the customer to receive an email notification about the RMA creation, select the 
Email RMA Confirmation check box in the lower-right corner of the page. 

2. On the RMA Items tab you can add products to the request (at least one product must be 
specified to save the RMA request).  
To add a product to the RMA request:  

a. Click the Add Product button.  

b. Select the product(s), click the Add Selected Products to RMA button; 

c. Specify the RMA attributes values. 

Note: To manage the RMA attributes, select Sales > RMA > Manage RMA Items 
Attributes. 

3. To save the RMA request click the Submit RMA button in the upper-right corner of the page. 
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18.9 Managing RMA Requests 

According to the RMA logic in Magento, you can change the status values of items in the RMA 

request, and the status of the request changes correspondingly. This section contains a detailed 

description of the RMA management process. 

Existing RMA requests can be managed from three locations in the Admin Panel: 

 The Manage RMA page (select Sales > RMA > Manage RMA) 

 The order view page (select Sales > Orders >your order > RMA tab) 

 The customer page (select Customers > Manage Customers >your customer > RMA tab) 

The provided workflow for an RMA request can be divided into several stages, as illustrated in 

Figure 173 (next page). 
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Figure 173. RMA Process 
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To manage an RMA: 

1. An RMA request is placed. Now you need to decide whether you agree to proceed with RMA 
process. You have the following options: 

Action Do this RMA request status 

Reject the return On the RMA page, click the Close button.  Closed 

Preapprove the return  1. On the RMA page click the RMA Items 

tab.  

2. For the rejected items, set Status to 

Denied. 

3. For the preapproved items, specify the 

quantity of the product, you have 

preapproved in the Authorized Qty field, 

and set their Status to Authorized.  

4. Click the Save button.  

 

Partially Authorized  

(if there are some items in Denied 

or Pending Status) 

Or 

Authorized  

(if all items are authorized). In this 

case the options for creating the 

shipping label for the back 

shipment appear on the General 

Information tab. When you create 

a shipping label, the customer can 

print it from the RMA view page 

on the frontend. 

 

Now the customer is expected to send the return items back to you. If you agree to pay for the 

shipment, you can create a shipping label from the RMA page. See “Return Shipments,” page 

191, for details. 

2. You receive the returned items. On the RMA Items tab of the RMA page, specify the quantity 
you have received for each product, change its Status to Return Received, and click Save or 
Save and Continue. The new status of the RMA request depends on the correlation between the 
authorized and received quantities: 

 If Returned Qty is equal to Authorized Qty for all authorized products, the RMA request 

status becomes Return Received.  

 If, for some authorized products, Returned Qty is less than Authorized Qty, the return 

request status becomes Return Partially Received. 

Now you can decide how the return can be resolved. At this point, you have the following 

options: 

Action Do this RMA request status  

Reject the return On the RMA page, click the Close button.  Closed 

Approve the return  1. On the RMA page click the RMA Items 

tab.  

2. For the rejected items, set Status to 

Denied. 

3. For the approved items, specify the 

quantity of the product, you have 

Processed and Closed  

(if all items are either in Approved 

or Denied status) 

or 

Partially Approved  

(if at least one product return was 
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Action Do this RMA request status  

approved in the Approved Qty field, 

select the way the return will be resolved 

in the Resolution field, and set their 

Status to Approved.  

You may need to select different 

resolution options for one product. For 

example, you authorized the return of 10 

chairs. When they arrived, you saw that 

they are really damaged and you 

approve the return. But you have only 2 

chairs left in stock, so you can exchange 

only 2 chairs, and refund the rest. In this 

case, you can add more lines for the 

product, using Split Line link in the 

Action column, and then in each row set 

different Approved Qty and Resolution. 

4. Click the Save button.  

Approved, but still there are items 

with Authorized status) 

or 

Partially Rejected  

(if all returned products were 

rejected, but there are still 

products for which Returned Qty 

is less than Authorized Qty) 

 

 

3. Managing the return resolutions (refund or exchange) is out of the RMA functionality scope, and 
can be managed in other sections of the Admin Panel. Depending on the resolutions you have 
selected for the approved RMA items, you may need to do the following: 

Resolution Your actions in the Admin Panel 

Exchange  You can create a credit memo for the original order (having selected to 

refund to store credit and excluded the shipping costs from the refund), 

and create a new one for the exchange items. 

Alternatively, if the products you send in exchange are identical to those 

that were originally ordered, you can simply send the exchange 

products to the customer, outside of Magento. But in this case the 

shipment cost will not be included in the Shipment report in Magento. 

Refund Create a credit memo for the refunded items in the original order. You 

need to decide whether the shipping charges for the original order will 

be refunded. 

You can refund the original payment method or refund to store credit.  

18.10 Return Shipments 

When the RMA request reaches the Authorized status, the options for creating a shipping label for 

the back shipment appear on the General Information tab. See Figure 174. 
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Figure 174. Creating Shipping Labels for Return Shipment 

Creating a Shipment Order and Shipping Labels for RMA from the 
Magento Admin Panel 

When you choose to create a shipping label, Magento connects to the shipping carrier web services, 

creates a shipment order at the shipping carrier side, and receives the shipping label and the 

tracking number. In the shipment order, the customer shipping address (taken from the original 

order) is used as sender address; the store address is used as receiver address. The store address is 

taken from the RMA configuration (System > Configuration > SALES > Sales > RMA Settings). 

To create a shipping label: 

1. Click the Create Shipping Label button. The Packages pop-up window appears. 

2. Select the packages and distribute shipped items between packages. The information about 
packages (type, size) and its contents (which products go to which packages) is required in 
order to generate a shipping label. For details about creating packages, see “Creating Packages 
in the Create Packages Pop-Up Window,” page 173. 

3. After you create the packages and click OK, Magento connects to the shipping carrier’s web 
services, creates a separate shipping order in the carrier’s system for each package, and receives 
the shipping labels and the tracking numbers.  
If you click Cancel on the Packages window, a shipping label is not created. 

Shipping labels for one shipment can be created multiple times. When you create a new shipping 

label, the old shipping label and tracking numbers are deleted and replaced with new ones. 

Once you create a shipping label for the return shipment, the customer can print it from the RMA 

view page on the frontend. 

To view a shipping label: 

Click the Print Shipping Label button to download and view the PDF file for the shipping label.  

To view packages configuration: 

Click the Show Packages button next to the Print Shipping Label button. 
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Adding the RMA Shipping Information on the Frontend  

If the return shipment is managed by the store customer, he or she can add the tracking number (or 

numbers) of the shipment to the RMA request. A tracking number that is added on the frontend is 

visible in the Admin Panel as well. 

18.11 Viewing RMA Requests on the Frontend 

All changes made in the RMA request by the store administrator are reflected in the RMA request 

view on the frontend (except the comments, which can be hidden, if the store administrator chooses 

not to show them).  

Account-holding (logged-in) customers can view their RMA requests on the My Returns tab of the 

My Account page. Placed RMA requests are displayed here. See Figure 175. 

 

Figure 175. My Returns Section on the Frontend  

Guest customers can view their RMA requests using the Orders and Returns link in the store page 

footer or the Orders and Returns widget. 

On the RMA request view page customers can leave comments. 
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19 Store Credit 
This chapter introduces Store Credit functionality, which essentially is a balance associated with a customer 

account. Store Credit can be used by customers for paying in the store, and can be used by administrators 

for refunding money to customers. Additionally, Gift Card balances can be transferred to Store Credit, saving 

customers from having to manually enter the Gift Card code on subsequent purchases. 

This feature is available in Magento Enterprise Edition. 

19.1 Configuration of Store Credit 

There are some configuration settings that must be completed relating to Store Credit. In order to do 

so, navigate to System > Configuration, click the Customer Configuration tab in the left column, and 

select the Store Credit Options section. The following settings are available: 

 Enable Store Credit Functionality: Determines if the Store Credit module is enabled. 

Disabling it will remove the Store Credit tab from the My Account section in the frontend, 

as well as in the Manage Customers page in the backend. 

 Show Store Credit History to Customers: Determines if the balance history of a customer's 

Store Credit is visible to the customer in their My Account page. 

 Store Credit Update Email Sender: Determines the sender of the email that customers 

receive when their Store Credit balance is updated. 

 Store Credit Update Email Template: Determines the template of the email that customers 

receive when their Store Credit balance is updated. 

When you have completed these settings, click Save Config in the top right of the page. 

19.2 Managing Store Credit 

The store administrator can view and edit a customer's Store Credit balance at any time. To do so, 

navigate to Customers > Manage Customers, select a customer from the customer grid, and click the 

Store Credit tab in the left column. The first section on this page shows the current balance. If 

customer accounts are shared on the Global level, this section will be a grid listing the customer's 

balance in each website. 

The second section enables you to update the balance of the customer. The Update Balance field is 

where the change in balance should be entered. The amount here can be positive or negative, and 

will add to or subtract from the existing balance, respectively. If customer accounts are shared on 

the Global level, there will be a drop-down menu in which you choose the website for which the 

balance will be updated. Additionally, there is a check box that enables you to send the Store Credit 

Update email to the customer, notifying them of the balance change. Selecting this option unlocks 

the Store View drop-down menu, which determines from which store view the email will be sent. 
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The third section displays the balance history, including a timestamp, a description of the action, 

and the balance change. Additionally, for some actions there is additional information available, 

such as the order number on which store credit was applied. This section is in the form of a grid, 

enabling you to filter the records. 

Refunding to Store Credit 

While creating a Credit Memo, you have the ability to refund the amount to a customer's store 

credit. On the New Credit Memo page, there is a field in which you can enter the amount of the 

refund that will be applied to the customer’s store credit. This feature enables you to apply either the 

full or a partial amount of the refund to store credit. 

Paying with Store Credit 

In order to pay with Store Credit, a customer must be logged in during checkout. In the Payment 

Information step of the checkout process, a Use Store Credit check box will appear above the 

enabled payment methods. The available balance will be displayed in parentheses. If the available 

balance is greater than the order grand total, the enabled payment methods will disappear upon 

selecting the check box. In the Order Review step of the checkout process, the amount of store 

credit applied to the order will appear among the order totals, subtracting from the grand total, 

similar to Gift Cards. 

The customer’s store credit balance will be deducted only when the order is placed. 

Orders paid with store credit cannot be refunded. Credit memos will not be available. To refund 

such an order, cancel it and manually increase the balance of the customer’s account appropriately. 

If an order is partially paid with store credit, the amount paid with store credit cannot be refunded. 

Again, this amount should manually be added to the customer’s account. 

Store Credit in My Account 

A customer's My Account section includes a Store Credit tab. This page displays the current 

balance, as well as the balance history (if enabled in the Configuration page). In addition to this, 

customers can apply a Gift Card account balance toward their store credit. There is a link in the 

Store Credit tab which redirects to the Gift Card tab (if the Gift Card is Virtual or Combined, the 

email sent to the recipient will also contain a link to the Gift Card tab). The customer can enter the 

Gift Card Code in the field, and click Redeem Gift Card to transfer the balance. In order for the 

balance to be transferrable, the Gift Card Account must be set to Redeemable.
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PART IV: PAYMENT 

20 General Magento Payment Concepts 
Magento offers a wide range of built-in interfaces to popular payment services and gateways that enable the 

collection of money from your customers. This chapter describes some of the general concepts that are 

associated with payment methods. 

In addition to the built-in payment methods, many more can be added by downloading Magento payment 

module extensions, provided at http://www.magentocommerce.com/magento-connect. More information on 

installing payment module extensions is provided in “Extending Magento,” page 344. 

20.1 Definitions 

The following terminology is useful to know when setting up payment methods: 

 Payment method: A way for the customer to pay for the merchandise in your store. Payment 

methods can be internal, such as check, money order, or stored credit card, or external, 

such as PayPal or Authorize.Net. 

 Payment gateway: A third-party service provider that processes transactions for external 

payment methods. 

 Payment Bridge: A Magento software product that enables merchants to meet PCI security 

requirements. Certain external payment methods can be used with or without Payment 

Bridge, and some external payment methods require Payment Bridge. 

20.2 Using External Payment Methods 

The advantages of using external payment methods include faster processing, enhanced 

security, and less overhead for the store owner. The more external payment methods you 

offer to your customers, the more likely they will be able to find one they can use. There is 

a cost, however; each external payment method has service fees that you must pay. Terms 

and conditions vary from method to method. Some methods can be used by customers only 

in certain countries or using certain currencies. 

Some external payment methods can be used only with Magento Payment Bridge. For more 

information, see “Magento Payment Bridge,” page 463. 

http://www.magentocommerce.com/magento-connect
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20.3 Using Internal Payment Methods 

Magento’s internal payment methods (including checks, money orders, purchase orders, 

and saved credit cards) typically rely on physical mail or manual processing. They are 

generally used for smaller-volume merchants who do not need the automation afforded by 

external payment methods. 

20.4 Payment Bridge 

Magento Payment Bridge is a PA-DSS certified secure payment application that helps merchants in 

meeting PCI compliance. It is installed separately from Magento. Magento Payment Bridge is 

provided with a subscription to Magento Enterprise Edition. Magento Payment Bridge is a perfect 

way to keep all customer-to-merchant information interchange working via a separate PA-DSS 

compliant application, eliminating the need to make your Magento installation itself PA-DSS 

compliant. This enables you to make updates with new marketing, merchandising and content 

management features to the core Magento eCommerce application without having to go through 

PCI compliance reassessment of the entire Magento eCommerce platform. 

For more information about the payment methods that are supported by Payment Bridge, 

and how to enable and configure Payment Bridge, see “Magento Payment Bridge,” page 

463. 
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21 PayPal Payment Methods 
PayPal is one of the most popular ways to accept online payments. It enables you to accept credit cards and 

PayPal accounts. The following PayPal payments methods are integrated with Magento: 

 PayPal Payments Advanced (Includes Express Checkout)  

 PayPal Payments Pro (Includes Express Checkout)   

 PayPal Payments Standard  

 PayPal Payflow Pro (Includes Express Checkout)    

 PayPal Payflow Link (Includes Express Checkout)  

 PayPal Express Checkout  

 PayPal Payments Pro Payflow Edition (Includes Express Checkout) (UK only) 

 PayPal Payments Pro Hosted Solution (Includes Express Checkout) 

Important Note: According to the implemented logic, all PayPal payment methods 
except PayPal Express Checkout are mutually exclusive. This means that you 
cannot configure and enable two or more methods simultaneously, except that 
Express Checkout may be enabled with other PayPal payment methods. 
PayPal Payments Standard may not be enabled simultaneously with any other 
method, including Express Checkout.  

The PayPal payment methods that are integrated with Magento require that the merchant have a PayPal 

business account and/or a PayPal Payflow account. The type of PayPal account which is required is 

specified in each method’s description. Regarding store customers who have a buyer account at PayPal, 

both the Express Checkout and the Express Checkout for Payflow Pro payment methods need your customers 

to also have buyer accounts at PayPal for paying for their purchases. The PayPal Payments Standard 

payment method can work either directly or through a buyer account. This depends on the PayPal Account 

Optional parameter being enabled in the Premier or Business account of a merchant. 

The PayPal payment methods that are available in Magento, and the method names, are different depending 

on merchant location. You can find country-specific lists of available PayPal methods in “Country-Specific 

Lists of PayPal Methods Integrated with Magento,” page 470. Two PayPal payment methods that can be used 

all over the world are Express Checkout and PayPal Payments Standard. 

21.1 Setting Merchant Location 

Setting the merchant location is a necessary step in configuring PayPal payment methods.  

To set the merchant location country: 

1. Log in to the Magento admin panel. 

2. Navigate to System > Configuration > SALES > Payment Methods. 

3. In Current Configuration Scope in the upper-left corner of the page select your website or leave 
Default Config. 
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4. Under Merchant Location in the Merchant Country field, select your country (see Figure 176). 

5. To save changes, click Save Config. 

 

Figure 176. Setting Merchant Location for PayPal Payment Methods 

Regarding the customers who have buyer accounts at PayPal, both the Express Checkout and the 

Express Checkout for Payflow Pro payment methods require your customers to also have buyer 

accounts at PayPal for paying their purchases. The Website Payments Standard payment method 

can work either directly or through a buyer account. This depends on the PayPal Account Optional 

parameter being enabled in the Premier or Business account of a merchant. By default, this 

parameter is enabled and the web store customers can choose whether to simply enter their credit 

card information and the billing and shipping addresses and pay the order amount, or to create a 

buyer account with PayPal and then pay the order amount. With this parameter turned off, the 

customer will need to create a buyer account with PayPal prior to paying the order amount. 

Using the Website Payments Pro, Website Payments Pro Payflow Edition, Payflow Pro Gateway, or 

Payflow Link payment methods requires that the customer enter credit card information during the 

shopping cart checkout. 

21.2 PayPal Payments Advanced 

The PayPal Payments Advanced payment method is available for merchants in the United States 

only. 

General Concept 

The PayPal Payments Advanced payment method passes the information about the card, entered by 

a customer, directly to PayPal; it is never stored in your Magento system. A merchant needs to have 

a PayPal business account to be able to use this payment method. A customer does not need to 

have a PayPal buyer account to use this method. PayPal Payments Advanced also includes PayPal 

Express Checkout. 

The PayPal Advanced payment method is not available for orders created from the Admin Panel. 

Configuring PayPal Payments Advanced 

To use the PayPal Advanced method, you should have a PayPal Payments Advanced account on 

PayPal. You need to have a separate account for each website. 

Configuring the PayPal Advanced method for each website is a two-step procedure for each 

website: 
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1. Set the options in the Magento Admin Panel. 

2. Set the required options of the PayPal Payments Advanced account on the PayPal Manager 
website. 

Setting PayPal Payments Advanced Options in the Magento Admin 
Panel 

To configure the PayPal Advanced payment method in the Magento Admin Panel: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration. 

3. Select the desired website from the Current Configuration Scope drop-down menu in the upper-
left corner of the page. 

4. Under SALES in the left column, click Payment Methods. In the Merchant Location section, 
choose United States in the Merchant Country field. If any other country is selected, the PayPal 
Payments Advanced settings are not displayed. 

5. In the PayPal All-in-One Payment Solutions section, click the Configure button next to PayPal 
Payments Advanced, to expand the corresponding settings.  

6. In the Required PayPal Settings field set, configure the following:  

 In the Partner, User, Vendor and Password fields, specify your PayPal Payments Advanced 

account credentials. 

 Test Mode: The test mode helps testing the integration of Magento with the PayPal payment 

system. Transactions that are submitted while the account is in the test mode are not 

actually submitted to the credit card and electronic check processing networks, and credit 

card or bank accounts are not actually charged. Therefore, these transactions do not have 

valid transaction IDs. When you finish testing the integration project, the test mode must be 

turned off. 

 Use Proxy: Decide whether the proxy server is used for establishing the connection between 

Magento and the PayPal payment system. If you select Yes, two additional fields for 

specifying the proxy host and port are displayed. 

 If you want to enable PayPal Express Checkout, configure the settings in the Express 

Checkout section.  

Note: PayPal Express Checkout can be also configured individually under System > 
Configuration > SALES > Payment Methods > Express Checkout. If Express 
Checkout is configured within another PayPal solution, such as Payments 
Advanced or Payments Pro, individual Express Checkout settings are not available. 

7. In the Basic Settings – PayPal Payments Advanced section, configure the following settings:  

 Title: In the Title field, specify the name of the payment method that will be displayed to 

customers in the Payment Information section of the one-page checkout. This parameter can 

be set up for each store view. 
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 Sort Order: When deciding to use a number of payment methods, in the Sort Order field 

determine the sequence number of this method in the list of available methods in the 

Payment Information section of the one-page checkout. 

Note: The payment methods for which the sort order is not set are displayed first. 

 Payment Action: Choose what type of transaction is conducted when the order is placed, 

and the entities that will be created in the backend as a result. The following options are 

available: 

o Authorization: The payment is authorized and only an order is created in the 

backend of your store. 

o Sale: The payment is captured on the PayPal side, and as a result an order and an 

invoice are created in the backend of your store. 

 Payment Applicable From: Choose the countries from which customers can use this 

payment method. Choose between the following options:  

o All Allowed Countries: Customers from the default countries list can use this 

payment method. 

o Specific Countries: Only customers whose billing address includes one of the 

countries selected in the Countries Payment Applicable From field can use this 

payment method. The field works as a filter, so that this payment method will be 

listed for only those customers whose billing address is in one of these selected 

countries. 

 Debug Mode: In the Debug Mode field, specify whether communications with the payment 

system are written into the log file. The log file for PayPal Payments Advanced is 

payments_payflow_advanced.log.  

 Enable SSL verification: Decide whether you want to enable host authenticity verification. 

 CVV Entry is Editable: Choose whether the field for entering CVV number will be displayed. 

 Require CVV Entry: Choose whether CVV field will be mandatory. The setting appears only 

if CVV Entry is Editable is set to Yes. 

 Send Email Confirmation: Choose whether PayPal email confirmation will be sent to 

customers. 

 URL method for Cancel URL and Return URL: The setting refers to the Cancel and Return 

URL displayed on the PayPal-hosted form.  

8. The PayPal Billing Agreement Settings, Settlement Report Settings and Frontend Experience 
Settings, and Basic Settings – PayPal Express Checkout sections are related to configuring the 
PayPal Express Checkout method, which is included with the PayPal Payments Advanced 
payment method. PayPal Express Checkout can be also configured individually. See “PayPal 
Express Checkout,” page 214, for more information. 

9. Click Save Config in the upper-right corner of the page to save the settings. 
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Setting the PayPal Payments Advanced Account Options on the 
PayPal Manager Website 

To make the necessary settings for the PayPal Advanced account: 

1. Log in to https://manager.paypal.com/  

2. Navigate to Service Settings > Hosted Checkout Pages. Options should be configured in the Set 
Up and Customize sections. 

3. Configure the options according to the recommendations displayed in the PayPal Payments 
Advanced field set in the Magento Admin Panel. 

PayPal Payments Advanced Method: Customer Experience 

A store customer selects the PayPal Payments Advanced payment method on the Payment 

Information checkout step and clicks Continue. The Order Review step appears, where the PAY 

NOW button is available instead of the usual PLACE ORDER button. After the customer clicks PAY 

NOW, the PayPal-hosted form opens in the customer’s browser. The customer specifies the card 

information and clicks Verify Card. If the transaction is successful, the customer is redirected to the 

order confirmation page. 

Note: The form also contains the Pay with PayPal button; clicking it redirects a 
customer to the PayPal site, where the customer can complete the payment using 
PayPal Express Checkout. 

If the transaction fails on any reason, an error message appears on the checkout page and the 

customer is directed to repeat the checkout process. These situations are handled on the PayPal 

side. 

Order Processing with the PayPal Advanced Payment Method 

Processing of orders that are paid using the PayPal Payments Advanced payment method is the 

same as regular processing of orders that are paid with PayPal. An invoice, shipment, and credit 

memo (online/offline refund) can be created. Multiple online refunds are not available for the 

PayPal Payments Advanced payment method. 

When PayPal Advanced is used, an order is created in the Admin Panel when a customer clicks 

PLACE ORDER on the Order Review step of the one-page checkout. The order status upon creation 

depends on the response the system receives from PayPal, and can be one of the following: 

 Processing: The transaction was successful 

 Pending Payment: The system did not receive any response from PayPal 

 Canceled: The transaction was not successful for some reason 

 Suspected Fraud: The transaction did not pass some of the PayPal fraud filters; the system 

receives the response from PayPal that the transaction is under review by Fraud Service 

https://manager.paypal.com/
https://manager.paypal.com/
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21.3 PayPal Payments Pro (Includes Express Checkout) 

With the PayPal Payments Pro payment method, customers do not need to have an account 
with PayPal and they are not redirected to the PayPal website at all. Credit cards that 
customers enter are processed directly on your website with the Website Payments Pro 
method, which is also known as the PayPal direct method of payment. The method also 
includes PayPal Express Checkout, which cannot be disabled when PayPal Payments Pro is 
enabled. 

The PayPal Payments Pro payment method can work via the Magento Payment Bridge or 
without it. 

The Website Payments Pro method of payment is available only to merchants in the United 
States, the United Kingdom, and Canada. When enabled, the method is available during 
order creation in the frontend and the backend. A merchant needs to have a PayPal 
business account to be able to use this payment method. 

Note: By default, direct payments are not enabled in the PayPal merchant account, and 
therefore the Website Payments Pro payment method will not work in your 
Magento installation. You need to apply to the PayPal Merchant Technical Support 
at http://www.paypal.com/mts  for direct payments to be enabled. 

Configuring PayPal Payments Pro 

To enable and configure the Website Payments Pro payment method: 

1. In the admin panel, navigate to System > Configuration > SALES >Payment Methods. In the 
Current Configuration Scope field, select the website for which the payment method is to be 
enabled and then make sure that the Merchant Country field is specified correctly. 

2. Under PayPal All-in-one Payment Solutions, click the Configure link for PayPal Payments Pro. 
The options are distributed under several sections: Required PayPal Settings, Basic Settings –
PayPal Payments Pro, and Basic Settings PayPal Express Checkout. 

3. Configure the following options under Required PayPal Settings: 

 If the Payment Bridge web application is set up for your Magento installation, enable the 

Use Via Payment Bridge parameter so that payments placed using the PayPal Payments Pro 

method of payment are processed with PayPal through a secure PA-DSS compliant payment 

application. If you choose to use Payment Bridge, the PayPal Payflow Pro method should be 

enabled and configured in the Payment Bridge application. In the Magento Admin Panel 

you need to configure only settings grouped under Required PayPal Settings. See “Magento 

Payment Bridge,” page 463, for details about Payment Bridge 

 Populate the Email Associated with PayPal Merchant Account, API Username, API 

Password, and API Signature fields with your PayPal merchant account information. 

http://www.paypal.com/mts
http://www.paypal.com/mts
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 You can choose to activate the test mode for the PayPal payment system merchant account 

in the Sandbox Mode field. The test mode helps testing the integration of Magento with the 

PayPal payment system. Transactions that are submitted while the account is in the test 

mode are not actually submitted to the credit card and electronic check processing 

networks, and credit card or bank accounts are not actually charged. Therefore, they do not 

have a valid transaction ID. After you have finished testing the integration project, the test 

mode must be turned off. 

 In the API Uses Proxy field, decide whether a proxy server is used for establishing the 

connection between Magento and the PayPal payment system. If you select Yes, two 

additional fields for specifying the proxy host and port become available. 

 Finally, choose to enable the PayPal Payments Pro method including Express Checkout in 

the Enable this Solution field. 

4. Configure the following options under Basic Settings – PayPal Payments Pro: 

 In the Title field, set the payment method title available for customers in the frontend. This 

title is store-view specific. 

 When deciding to use a number of payment methods, in the Sort Order field determine the 

order this method will be displayed in the Payment Information section of the shopping cart 

Checkout page in the frontend. 

 In the Payment Action field, choose the way payments will be authorized in the PayPal 

payment system and the entities that will be created in the backend as a result of the 

payment procedure. The following options are available:  

o Authorization: Payments are only authorized in the PayPal payment system and 

only an order is created in the backend of your store. You need to log on to the 

merchant account on the PayPal website and capture the transaction. 

o Sale: A payment is authorized and captured in the PayPal payment system and as a 

result a corresponding transaction is created in the PayPal merchant account and 

an order and an invoice are created in the backend of your web store. 

 Under Credit Card Settings, in the Allowed Credit Card Types field, select the allowed types 

of credit cards that can be used for performing payments through the PayPal payment 

system. In the Payment Information section of the Checkout page in the frontend, the 

customer can choose among the credit card types specified in this list. 

 Choose the countries whose residents can use this method of payment in the Payment 

Applicable From field. Choose between the following options:  

o All Allowed Countries: Customers from the default countries list can use this 

payment method.  
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Note: The default list of countries is defined in the Allow Countries field located under 
System > Configuration > GENERAL > General > Countries Options 

o Specific Countries: Only customers whose billing address includes one of the 

countries listed in the Countries Payment Applicable From field that becomes 

available can use this payment method. The field essentially works as a filter, so 

that this payment method will be listed only for those customers whose billing 

address is one of these selected countries. 

 In the Debug Mode field, specify whether communications with the payment system are 

written into the log file. The credit card related information is not written to the log file in 

order to prevent credit card fraud. 

 In the Enable SSL verification field, decide whether you want to enable host authenticity 

verification. 

 In the Transfer Cart Line Items drop-down menu, select whether information about each 

individual line item in the order is sent to the payment processor (Yes), or only the order 

total (No). 

 In the Require CVV Entry field, choose whether a credit card verification number must be 

specified by the customer when entering credit card information during the products 

checkout. The Card Security Code (CSC) provides an additional security measure to prevent 

card misuse within online transactions. (The Card Security Code is also known as the Card 

Verification Value.) 

 Under 3D Secure, in the 3D Secure Card Validation field, choose whether credit cards will 

be verified through the Centinel 3D Secure system. If the parameter is enabled, the 

following two fields become available.  

Note: The 3D Secure functionality used for credit card verification must first be set up 
under System > Configuration > SALES > Payment Services > 3D Secure Credit 
Card Verification. In this case, credit card validation will be performed by the 
external Centinel® system when the PayPal Website Payments Pro payment 
method is selected. For details on PayPal Billing Agreement and its settings, see 
“Billing Agreements,” page 223. 

o In the Severe 3D Secure Card Validation field, choose whether severe validation 

will be applied to credit cards by the Centinel system.  

Note: Severe credit card validation removes the chargeback liability on the merchant. 

o In the Centinel Custom API URL field, specify the URL provided by Centinel which 

will establish the connection with the Centinel system for credit card validation. 

 For details on PayPal Settlement Report and its settings see “Generating a PayPal Settlement 

Report,” page 227. 

5. Under Frontend Experience Settings, configure the following options: 

 In the PayPal Product logo field, select the PayPal logo which will be displayed on the 

home and catalog pages of your store. 
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 Use the options grouped under the PayPal Merchant Pages Style heading to configure the 

store-related fragment of the PayPal page displayed to customers who choose to pay using 

PayPal Express Checkout. To see the hint for an option, click the question mark icon next to 

the field. 

6. Under Basic Settings PayPal Express Checkout, configure the options of the PayPal Express 
Checkout Payment method. The options available for Express Checkout here are similar to the 
standalone Express Checkout options. For more information, see “PayPal Express Checkout,” 
page 214.  

7. To save the configuration, click Save Config. 

Working with PayPal Payments Pro 

After customers add products to their shopping carts, they can proceed to checkout by clicking the Proceed 

to Checkout button. Then, they need to specify the billing and shipping addresses and the shipping method. 

In the Payment Information section of the Checkout page, they select the PayPal Direct Payment method 

option button and then specify the type of credit card, its number, expiration date, and card verification 

number. 

If the payment action selected in the backend configuration is Authorize, only a sales order of the Processing 

status is created in Magento. In this case, the amount of money to be authorized is pending approval on the 

payment gateway. With the PayPal Payments Pro payment method, you can process the payment online 

both in the Magento backend and from the PayPal merchant account. 

Note: When checking out products from the shopping cart to multiple addresses 
simultaneously, customers can choose to pay the orders with the Website Payments 
Pro payment method. 

On the customer’s request, the store administrator can also create an order from the backend and place it 

through the Website Payments Pro method of payment.  

Note: An order can be voided online at any time until the order amount is fully 
invoiced. If required, the order can be online partially invoiced for a specified 
quantity of products. For each partial invoice submitted through the PayPal 
payment system, a separate transaction record with a unique ID and of the Capture 
transaction type will become available on the Transaction tab, and a separate 
invoice document will be created on the Invoices tab. The payment transaction of 
the type Authorization will be closed only after the full order amount is captured. 

When capturing the payment transaction, PayPal transfers the order amount from the buyer's balance, bank 

account or credit card to the merchant's account. If for any reason the customer returns the purchased 

products and claims a refund, like with order amount capturing and invoice creation, you can create an 

online refund either in the Magento backend or in the PayPal merchant account. 
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Note: Make sure that instant payment notifications are enabled in your PayPal 
merchant account; an invoice will be created in Magento only after an instant 
payment notification message is delivered to Magento from PayPal. Based on these 
notifications, you can receive detailed payment information on each transaction 
from PayPal after you click the Fetch button on the Transaction page of an order. 

If the payment method has been set to Sale, both a sales order and an invoice are created in Magento under 

Sales > Orders. 

21.4 PayPal (Website) Payments Standard 

This section describes how to set up the PayPal (Website) Payments Standard method.  

Note: In the Magento admin panel, for U.S. merchants this method is called PayPal 
Payments Standard; for merchants from other countries it is PayPal Website 
Payments Standard. 

To set up payment by PayPal Website Payments Standard: 

1. Your first step is to create a PayPal merchant account. Check with PayPal (www.paypal.com) 
for detailed instructions. 

2. In the Magento backend, select System > Configuration > Payment Methods to display the 
Payment Methods page, as shown in Figure 177. 

 

Figure 177. Payment Methods Page 

3. In the Merchant Location section, select the country and specify the email address that is 
associated with your PayPal merchant account. 

4. In the PayPal All-in-One Payment Solutions section, click the Configure button next to PayPal 
(Website) Payments Standard, to expand the corresponding settings shown in Figure 178.  

http://www.paypal.com/
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Figure 178. PayPal Website Payments Standard Settings 

5. In the Required PayPal Settings section, specify an email address that was used when registering 
a merchant account with PayPal and choose to enable the solution (payment method). See 
Figure 179. 

 

Figure 179. Required PayPal Settings for PayPal Payments Standard 

6. In the Basic Settings – PayPal Payments Standard section, perform the following configurations: 

 In the Title field, specify a title to be shown to your customers. 

 In the Sort Order field, specify an integer number to indicate where this payment method 

should appear on the list of available payments on the frontend. A value of 1 places this 

payment at the top of the list, a value of 2 places it second, and so on. 

 In the Payment Action field, select one of the following options: 

o Authorization: Blocks or holds funds in the PayPal account until these funds have 

been transferred to your account. This usually occurs when you process the Order. 

o Sale: Specifies that funds are transferred to your account immediately. 

7. Click Advanced Settings to see and configure other available options: 

 In the Payment Applicable From field, leave the All allowed countries selection or select 

Selected Countries to select from a list of countries. 

 In the Sandbox Mode drop-down menu, select whether this payment method is in sandbox 

mode. Sandbox mode is used when you are setting up and testing the payment method; no 

actual payments are processed. 

 In the Transfer Cart Line Items drop-down menu, select whether information about each 

individual line item in the order is sent to the payment processor (Yes), or only the order 

total (No). 
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 In the Debug Mode drop-down menu, specify whether communications with the payment 

system are written into the log file. Data (except for credit card numbers) is stored in the 

system log file. 

 In the Enable SSL Verification drop-down choose whether you want to enable SSL 

verification.  

8. Click Save Config to save the configuration. 

21.5 PayPal Website Payments Pro Payflow Edition 
(Includes Express Checkout)  

The Website Payments Pro Payflow Edition payment method is available only to merchants in the 

United Kingdom. Store owners must have a Payflow Pro merchant account at PayPal to set up the 

connection between Magento and the payment system and to provide this payment method to 

customers. To establish the connection, the account information provided during the merchant 

account registration must be entered in the Magento backend. 

The Website Payments Pro Payflow Edition payment method sends transactions for processing to 

PayPal through the Payflow Pro gateway. This payment method provides web store owners with the 

following options: 

 Express checkout of shopping cart: Customers having a buyer account can choose to pay 

with the Express Checkout (Payflow Edition) payment method and be redirected to the 

PayPal website. They can check out the shopping cart quickly using the saved billing and 

shipping address and credit card information.  

Note: When Website Payments Pro Payflow Edition is enabled in Magento, the Express 
Checkout for Payflow Pro payment method is automatically enabled and it uses the 
Website Payments Pro Payflow Edition credentials for connecting to PayPal. With 
the Express Checkout Payflow Edition payment method, Magento customers will 
choose whether to log on to their existing PayPal buyer accounts, simply enter the 
billing address and credit card information without registering at PayPal, or both 
(register with PayPal and place a payment transaction there). 

Note: Express Checkout for Payflow Pro cannot be used standalone; it uses credentials 
of the Website Payments Pro Payflow Edition payment method. 

 Direct payment: Store owners can accept credit card payments directly on their websites. 

Customers using the Website Payments Pro Payflow Edition payment method do not need to 

have a buyer account with PayPal and they are not redirected to PayPal; credit card 

information is entered during the shopping cart checkout in the web store. After the order is 

placed, the PayPal payment system processes credit card payments from the shopping cart 

through the Payflow Pro gateway. 
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Configuring Website Payments Pro Payflow Edition 

To enable direct payments through the Payflow Pro gateway: 

1. Navigate to System > Configuration > SALES > Payment Methods and then select the website 
for which the payment method is to be enabled.  

2. Make sure that United Kingdom is specified in the Merchant Country field under Merchant 
Location. 

3. Under PayPal All-in One Payment Solutions, click the Configure link for Website Payments Pro 
Payflow Edition (Includes Express Checkout). The options are distributed under several sections: 
Required Settings, Basic Settings – PayPal Website Payments Pro Payflow Edition, Basic Settings 
– PayPal Express Checkout. 

4. Configure the following options under Required Settings: 

 If the Payment Bridge web application is set up for your Magento installation, enable the 

Use Via Payment Bridge parameter so that payments placed using the PayPal Payments Pro 

method of payment are processed with PayPal through a secure PA-DSS compliant payment 

application. If you choose to use Payment Bridge, the PayPal Payflow Pro method should be 

enabled and configured in the Payment Bridge application. In the Magento Admin Panel 

you need to configure only settings grouped under Required PayPal Setting. See “Magento 

Payment Bridge,” page 463, for details about Payment Bridge 

 Optionally populate the Email Associated with PayPal Merchant Account field. 

 In the Partner, User, Vendor, and Password fields, specify the credentials of the Payflow Pro 

merchant account. 

 Choose whether to activate the test mode for the PayPal payment system merchant account 

in the Test Mode field. The test mode helps testing the integration of Magento with the 

PayPal payment system. Transactions that are submitted while the account is in the test 

mode are not actually submitted to the credit card and electronic check processing 

networks, and credit card or bank accounts are not actually charged. Therefore, they do not 

have a valid transaction ID. Once you have finished testing the integration project, the test 

mode must be turned off. 

 In the API Uses Proxy field, decide whether a proxy server is used for establishing the 

connection between Magento and the PayPal payment system. When selecting Yes, two 

additional fields for specifying the proxy host and port become available. A third party 

server can be used to relay the traffic, if there is no direct access to the PayPal server. 

 In the Enable this Solution select Yes to enable the solution. 

5. Under Basic Settings – PayPal Website Payments Pro Payflow Edition, configure the following 
options: 

 In the Title field, for each store view set the payment method title available for customers in 

the frontend. 

 When deciding to use a number of payment methods, in the Sort Order field determine the 

order that this method will be displayed in the Payment Information section of the shopping 

cart Checkout page in the frontend. 
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 In the Payment Action field, choose the way payments will be authorized in the PayPal 

payment system and the entities that will be created in the backend as a result of the 

payment procedure. The following options are available:  

o Authorization: Payments are only authorized in the PayPal payment system and 

only an order is created in the backend of your web store. You need to log on to 

the merchant account on the PayPal website and capture the transaction. 

o Sale: A payment is authorized and captured in the PayPal payment system and as a 

result a corresponding transaction is created in the PayPal merchant account and 

an order and an invoice are created in the backend of your web store. 

 Under Credit Card Settings, in the Allowed Credit Card Types field, select the allowed types 

of credit cards that can be used when paying with the Website Payments Pro Payflow 

Edition method of payment. In the frontend, the customer can choose among the credit card 

types specified in this list. These will be provided in the Payment Information section of the 

Checkout page. 

 Choose customers of which countries can use this method of payment in the Payment 

Applicable From field. Choose between the following options: 

o All Allowed Countries: Customers from the default countries list can use this 

payment method.  

Note: The default list of countries is defined in the Allow Countries field located under 
System > Configuration > GENERAL > General > Countries Options. 

o Specific Countries: Only customers whose billing address includes one of the 

countries listed in the Countries Payment Applicable From field that becomes 

available can use this payment method. The field works as a filter, so that this 

payment method will only be listed for those customers whose billing address is 

one of these selected countries. 

 In the Debug Mode field, specify whether communications with the payment system are 

written into the log file. The credit card related information is not written to the log file in 

order to prevent credit card fraud. 

 In the Enable SSL verification field, decide whether you want to enable host authenticity 

verification. 

 In the Require CVV Entry field, choose whether a credit card verification number must be 

specified by the customer when he or she enters credit card information during the 

shopping cart checkout. The Card Security Code (CSC) provides an additional security 

measure to prevent card misuse within online transactions. (The Card Security Code is also 

known as the Card Verification Value.) 

 Under 3D Secure, set the 3D Secure Card Validation field to Yes to specify that credit cards 

will be verified through the Centinel 3D Secure system. If the parameter is enabled, the 

following two fields become available.  



 PayPal Payment Methods 

 213 

Note: The 3D Secure functionality used for credit card verification must first be set up 
under System > Configuration > SALES > Payment Services > 3D Secure Credit 
Card Verification. In this case, credit card validation will be performed by the 3D 
Secure service provided by CardinalCommerce when customers choose to pay 
with the Payflow Pro Gateway payment method during the checkout.  

o In the Severe 3D Secure Card Validation field, choose whether severe validation 

will be applied to credit cards through the 3D Secure service. Severe credit card 

validation removes the charge back liability on the merchant. 

o In the Centinel API URL field, specify the URL provided by Centinel which will 

establish the connection with the Centinel system for credit card validation. 

 The Settlement Report Settings, Frontend Experience Settings and Basic Settings – PayPal 

Express Checkout sections are related to configuring the PayPal Express Checkout method. 

This edition of the PayPal Express Checkout has fewer options than standalone Express 

Checkout. However, the existing options coincide with the similar options of the Express 

Checkout. See “PayPal Express Checkout,” page 214, for details about these options. 

 In the Transfer Cart Line Items field, choose whether shopping cart items, their prices, 

quantities, and subtotal amounts, are transferred separately line by line or they are 

transferred as one whole with their price total value. If the parameter is enabled, the 

Transfer Shipping Options field becomes available. 

Working with Website Payments Pro Payflow Edition 

In the frontend, after customers add products to their shopping carts, they check out by clicking the 

Proceed to Checkout button. After they specify the billing and shipping addresses and choose the 

shipping method, in the Payment Information section of the Checkout page, they select the option 

button for the PayPal Direct Payment Payflow Edition payment method, and enter the type of credit 

card, its number, expiration date, and card verification number in the fields which become 

available. Then, the customer places the sales order. 

The Checkout with PayPal button is also available in the shopping cart. If the customer chooses to 

check out with the Express Checkout payment method, she or he will be redirected to the PayPal 

website where the payment is confirmed. After that the customer is redirected back to the Magento 

Review Order page where he or she specifies the shipping method and places the order. 

Note The PayPal Express Checkout Payflow Edition payment method can also be 
selected in the Payment Information section of the shopping cart Checkout page. 

If the Authorize payment action was selected in the Website Payments Pro Payflow Edition payment 

method configuration, a sales order of the status Processing is created in Magento, and a transaction 

of the Authorization type is added on the Transactions tab. The transaction can be captured both in 

the Magento backend and in the PayPal merchant account. The latter option is possible because the 

Payflow Pro account is linked to the PayPal account of the merchant. 

In Magento, you need to create an invoice and in the Invoice Totals block select the Capture Online 

option in the Amount field. As a result, one more payment transaction of the Capture type is added 

on the Transactions tab and an invoice document becomes available on the Invoices tab. 
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In the PayPal merchant account, you can select the necessary transaction on the account Overview 

page and then click the Capture button for it. On the Capture Funds page, enter the capture amount 

and then proceed to payment. Confirm the payment by clicking the Capture Funds button. An 

invoice is created in Magento as soon as PayPal verifies the payment and sends an instant payment 

notification to Magento. Make sure that Instant Payment Notifications (IPNs) are enabled for your 

PayPal merchant account. 

If the Sale payment action was selected for the payment method configuration, a sales order of the 

status Processing and an invoice of the status Paid will be created. 

The payment transaction information can be reviewed in the merchant account. All authorization, 

capture, and refund transactions created through the Website Payments Pro Payflow Edition method 

of payment can be reviewed in the PayPal manager at https://manager.paypal.com/ . 

21.6 PayPal Express Checkout 

Express Checkout is a PayPal solution for streamlining the checkout process. This payment method 

is applied in all countries from the PayPal Worldwide reference list. Unlike all other payment 

methods that Magento provides, the Express Checkout payment method allows the customer to 

check out at the beginning of a usual checkout flow. With the Express Checkout payment method 

enabled, the Check out with PayPal button becomes available on the product view page, in the 

shopping cart, and in the mini shopping cart. Clicking the button provides the ability to review the 

shopping cart price information on the PayPal website. To use this method of payment, the 

customer needs to log on to her or his buyer account at PayPal. The payment system uses the 

customer’s billing and shipping information taken from the customer’s PayPal buyer account. The 

customer can then continue and be redirected again to the Magento Review Order page. After the 

customer places the order in Magento, the payment information is submitted to PayPal and the 

payment transaction is settled there. 

If the customer uses the one-page checkout flow and selects the Express Checkout payment method 

in the Payment Information section of the Checkout page, he or she is redirected to the PayPal from 

the Payment Review page, before the sales order is submitted. However, the Express Checkout 

method of payment is unavailable if the customer chooses to check out the products from the 

shopping cart to multiple addresses. And, in the Magento backend, the store administrator cannot 

place an order through the Express Checkout method of payment as it is unavailable from here as 

well. 

Except for the configuration details, there are some aspects of PayPal Express Checkout that you 

should be aware of when setting it up:  

 Saving the customer’s billing address 

 Order transactions 

 Billing Agreements 

 Settlement Reports 

https://manager.paypal.com/
https://manager.paypal.com/
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Configuring PayPal Express Checkout 

To enable the PayPal Express Checkout payment method: 

1. Log in to the Magento admin panel.  

2. Navigate to System > Configuration > SALES > Payment Methods and select the website for 
which the payment method is to be enabled. 

3. Under PayPal Express Checkout, click the Configure link for PayPal Express Checkout. The 
options are grouped under two main headings Required PayPal Settings and Basic Settings – 
PayPal Express Checkout. 

Note: After you have enabled and configured Express Checkout in the scope of an All-
in-one solution, such as Payments Pro or Payments Advanced, configuring the 
standalone PayPal Express Checkout becomes unavailable. 

4. Under Required PayPal Settings configure the following options: 

 Populate the Email Associated with PayPal Merchant Account field.  

 In the API Authentication Methods drop-down menu, choose between API Signature and 

API Certificate. 

 In the API Username, API Password, and API Signature fields, specify the API username, 

password, and signature provided by the PayPal payment system.  

Note: You can get your PayPal API credentials at the PayPal website. Click the Get 
Credentials from PayPal button to open the PayPal website page. You need to log 
in to your account and click the API Credentials link to get the credentials. 

 You can activate the test mode for the PayPal payment system merchant account in the 

Sandbox Mode field. The test mode helps testing the integration of Magento with the PayPal 

payment system. Transactions that are submitted while the account is in test mode are not 

actually submitted to the credit card and electronic check processing networks, and credit 

card or bank accounts are not actually charged. Therefore, they do not have a valid 

transaction ID. After testing the integration is finished, the test mode must be turned off.  

 To test the work of Magento and PayPal in sandbox mode, click the Sandbox Credentials 

button, log in to your sandbox test account, and click the API Credentials link to acquire the 

necessary information.  

 In the API Uses Proxy field, indicate whether a proxy server is used for establishing the 

connection between Magento and the PayPal payment system. If you select Yes, two 

additional fields for specifying the proxy host and port become available.  

 In the Enable this Solution select Yes to enable the payment method. 

5. Under the Basic Settings – PayPal Express Checkout configure the following options: 

 In the Title field, specify the name of the payment method that will be displayed to 

customers in the Payment Information section of the shopping cart Checkout page. This 

parameter can be set up for each store view. 
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 When deciding to use a number of payment methods, in the Sort Order field determine the 

order in which this payment method will be displayed in the Payment Information section 

of the shopping cart Checkout page in the frontend. 

 In the Payment Action field, choose the way payments will be authorized in the PayPal 

payment system and the entities that will be created in the Magento backend as a result of 

the payment procedure. The following options are available:  

o Authorization: After the customer places an order in the web store, PayPal 

authorizes the order amount in the customer's PayPal balance. Customers cannot 

use the authorized amount from their buyer account because it is reserved by 

PayPal until the merchant captures it. The store administrator can capture online 

the authorized order amounts from the buyer accounts both in the Magento 

backend and in the PayPal merchant account. With the Authorization payment 

action selected in the Magento configuration, only an order is created in the 

backend of your web store after the customer places an order through Express 

Checkout. Merchants select this payment action when, for example, the products 

from an order are shipped before capturing the payment or if there is a need not to 

accept payments immediately. 

o Sale: The order amount is authorized by PayPal and the funds are captured from 

the buyer account and are transferred to the merchant account at PayPal. 

Merchants select this payment action if they are sure that the transaction and the 

shipment of products from orders can be immediately fulfilled. With the Sale 

payment action, when the customer places an order through Express Checkout, a 

corresponding transaction is created in the PayPal merchant account and both an 

order and an invoice are created in the backend of your web store. 

o Order: The amount of the order is neither captured nor authorized in the 

customer’s balance, bank account, or credit card at PayPal. The Order payment 

action represents an agreement between the PayPal payment system and the 

merchant which enables the latter to capture one or more amounts up to the 

“ordered” total from the customer's buyer account, over a maximum of 29 days. It 

means that after the funds are “ordered,” the merchant can capture them anytime 

during the following 29 days. Capturing of the order amount can be done only 

from the Magento backend, by creating one or multiple invoices. 

 In the Shortcut on Shopping Cart field, choose whether the customer can use the express 

checkout button on the shopping cart page and in the mini shopping cart. Clicking the 

button redirects the customer to the PayPal website where the shopping cart price 

information can be reviewed.  

 In the Shortcut on Product View field, choose whether the express checkout button is 

available on the product view page. 

 In the Payment Applicable From field, choose the countries whose residents can use this 

method of payment. Choose between the following options:  

o All Allowed Countries: Customers from the default countries list can use this 

payment method.  
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Note: The default list of countries is defined in the Allow Countries field located under 
System > Configuration > GENERAL > General > Countries Options. 

o Specific Countries: Only customers whose billing address includes one of the 

countries listed in the Countries Payment Applicable From field that becomes 

available can use this payment method. The field works as a filter, so that this 

payment method will only be listed for those customers whose billing address is 

one of these selected countries. 

 In the Debug Mode field, specify whether communications with the payment system are 

written into the log file. 

Note: The credit card related information is not written to the log file in order to prevent 
credit card fraud. 

 In the Enable SSL verification field decide whether you want to enable host authenticity 

verification. 

 In the Transfer Cart Line Items field, choose whether shopping cart items, their prices, 

quantities, and subtotal amounts, are transferred separately line by line or are transferred as 

one whole with their price total value. If the parameter is enabled, the Transfer Shipping 

Options field becomes available. 

 Enable the Transfer Shipping Options field to allow the customer change the shipping 

address and the shipping rate on the PayPal website.  

Note: In live mode, the parameter works via the HTTPS protocol only. 
If this parameter is enabled, the Change link becomes available in the Ship to 
section of the PayPal Review your information page. Clicking the link provides the 
list of all shipping addresses associated with the customer. Also, the payment total 
area provides the list of all available shipping rates. 
The parameter does not work if more than ten shipping rate options are available. 

 Choose whether a dynamic or a static PayPal Acceptance Mark image will be displayed 

next to the payment method in the Payment Information section of the shopping cart 

Checkout page. Choose between the following options in the Shortcut Buttons Flavor field:  

o Dynamic: The appearance of dynamic images is dynamically changed by PayPal. 

When signing up for a PayPal campaign, the appearance of the image dynamically 

changes during the campaign based on the parameter information that you add to 

the image URL. 

o Static: The static images cannot be changed dynamically. When participating in a 

PayPal campaign, the image code must be manually updated to change the image 

displayed and restore the default image when the campaign is over.  
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Note: For better image management, we recommend that you replace static images in 
your system with dynamic ones. 

 If the Enable PayPal Guest Checkout field is set to Yes, Magento customers who are not 

registered with PayPal can perform the payment without registering with PayPal. After a 

guest customer clicks the Check out with PayPal button and is redirected to the PayPal 

website, he or she may continue checking out as a guest by clicking the corresponding 

Don't have a PayPal account? link located near the Log in to PayPal section. In this case, 

the customer needs to specify credit card information and a billing address. After PayPal 

validates the credit card information, the customer can proceed to review the payment 

information and perform the actual payment. If the field is set to No, the customer needs to 

register with PayPal prior to proceeding to the payment. 

 Specify whether the customer can sign a billing agreement with your web store in the 

PayPal payment system when there are no active billing agreements available in the 

customer account. Choose between the following options in the Billing Agreement Signup 

field:  

o Auto: The customer can either sign a billing agreement during the Express 

Checkout flow or use another method of payment. 

o Ask Customer: The customer can decide whether to sign a billing agreement during 

the Express Checkout flow. 

o Never: The customer cannot sign a billing agreement during the Express Checkout 

flow.  

Note: The store owner needs to apply to the PayPal Merchant Technical Support for 
enabling the billing agreements feature. The Billing Agreement Signup parameter 
must be enabled only after PayPal confirms that billing agreements are enabled for 
your merchant account. 

 Optionally configure options under PayPal Billing Agreement Settings. See “Billing 

Agreements,” page 223, for details. 

 Optionally configure options under Settlement Report Settings. See “Generating a PayPal 

Settlement Report,” page 227, for details. 

 Under Frontend Experience Settings configure the following options: 

o In the PayPal Product logo field select the PayPal logo which will be displayed on 

the home and catalog pages of your store. 

o Use the options grouped under PayPal Merchant Pages Style heading to configure 

customize the store-related fragment of the PayPal page displayed to customers 

who choose to pay using PayPal Express Checkout. To see the hint for an option 

click the question mark icon next to the field. 

6. Click the Save Config button to save the current settings. 
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Saving the Customer’s Billing Address  

Prior to version 1.11 of Magento Enterprise Edition, the PayPal Express Checkout payment method 

did not allow saving the complete billing address for the order in Magento. Starting with version 

1.11, this restriction was removed and a complete billing address can be saved in a Magento order 

when the PayPal Express Checkout payment method is used by a customer. The billing address can 

be received from PayPal, and can be edited by the customer. 

If you want to receive the billing address of a customer from PayPal for customers using the PayPal 

Express Checkout payment method, you need to take the following steps: 

1. Enable the corresponding functionality is enabled in your PayPal merchant account. Contact 
PayPal technical support for details. 

2. In the Magento Admin Panel, under System > Configuration > SALES > Payment Methods > 
PayPal Express Checkout, in the Require Customer’s Billing Address field select Yes, and save 
the configuration. If you want to request the customers billing address only for orders which 
contain downloadable and/or virtual products, in the Require Customer’s Billing Address field 
select For Virtual Quotes Only. 

When customers choose to pay using PayPal Express Checkout, they are redirected to PayPal. 

Having logged in to PayPal and reviewed the payment information, they are redirected back to the 

store, to the Order Review page, where they choose the shipping method, edit the billing and 

shipping addresses, and place the order.  

Note: If a billing address cannot be received from PayPal because of your configuration 
or due to any other reasons, the billing address fields on the Order Review page are 
prepopulated with the shipping address values. A customer can edit them if 
necessary.  

Figure 180 illustrates the Order Review store page when a customer uses the PayPal Express 

Checkout payment method. 
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Figure 180. Order Review Page with PayPal Express Checkout Payment Method 

If a customer leaves the billing and shipping addresses without changes, the PLACE ORDER button 

is enabled when the customer selects the shipping method in the Shipping Method field. 

If the customer edits the billing or shipping address, the PLACE ORDER button is disabled. The 

customer needs to click the UPDATE ORDER DATA button first. The system will update the 

information, including the available shipping methods, and the PLACE ORDER button will be 

enabled. 

After the customer clicks PLACE ORDER, the order is created in Magento, and PayPal performs the 

related transaction(s). The complete billing and shipping addresses are saved in the order record in 

Magento.  
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Order Transactions in PayPal Express Checkout 

Magento includes the option of using the Order payment action for the PayPal Express Checkout 

payment method. When a store customer submits an order, having paid using the PayPal Express 

Checkout payment method, for which the Order payment action is set, the funds on the customer’s 

card are authorized. If the authorization times out before you capture all payment, the authorization 

is voided, and a new authorization and capture are conducted when you create an invoice. Only 

the amount equal to the invoice total is authorized and captured. The maximum number of these 

authorizations for one order, and the periods for which the first authorization and the order in 

general stay valid, depend on your PayPal merchant account settings. These parameters need to be 

specified in the Magento Admin Panel as well. Capturing can be done only from the Magento 

Admin Panel, by creating one or more invoices. 

Situations in which using the Order transaction may be appropriate include the following: 

 Back orders, in which available items are sent immediately, and the remaining part of the 

order is sent when available; this may include more than two shipments 

 Split orders, in which ordered items are sent in more than one shipment, perhaps to 

different addresses, and you want to collect a payment for each shipment 

 Drop shipments, which are shipments from other vendors for which you accept the 

payment 

Using the Order payment action does not influence the checkout process for store customers. 

Configuring the Payment Action for the PayPal Express Checkout 

To change the payment action settings for the PayPal Express Checkout payment 
method: 

1. In the Magento Admin Panel, select System > Configuration > SALES > Payment Methods. 
Configuration can be done either on the global or website level, so in the Current Configuration 
Scope drop-down menu located in the upper left part of the page, leave Default Config or select 
the desired website. 

2. In the PayPal Express Checkout field set, in the Payment Action drop-down menu, select Order. 

3. Configure these additional settings, which correspond to settings in your PayPal merchant 
account: 

 Authorization Honor Period (days): Defines how long the primary authorization stays valid. 

The value should be equal to the corresponding value in your PayPal merchant account. 

The default value in your PayPal merchant account is 3. To increase this number you need 

to contact PayPal. The authorization becomes invalid at 11:49 p.m., U.S. Pacific Time, of 

the last day. 

 Order Valid Period (days): Defines how long the order remains valid. When the order 

becomes invalid, you can no longer create invoices for it. Specify the value equal to the 

Order Valid Period value in your PayPal merchant account. The default value in your 

PayPal merchant account is 29. To change this number, you need to contact PayPal. 
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 Number of Child Authorizations: Defines the maximum number of authorizations for one 

order. That is, the maximum number of the online partial invoices you can create for one 

order. 

The number in this field should be equal to the corresponding setting in your PayPal 

merchant account. The default number of child authorizations in your PayPal account is 1. 

To increase this number, you need to contact PayPal. 

4. Click Save Config in the upper-right corner of the page to save the new configuration. 

Managing Orders Paid Using PayPal Express Checkout with Payment Action 
Set to Order 

When the store customer submits the order, having paid using the PayPal Express Checkout 

payment method, for which the Order payment action is set, the order (with Processing status) is 

created in the Admin Panel. Two transactions are created for this order: one with type Order and 

one with type Authorization. See Figure 181. 

 

Figure 181. Order Transaction for PayPal Express Checkout 

The funds on the customer’s account are put on hold, and you can capture the payment only from 

the Magento Admin Panel. To capture, you need to create an online invoice. When you choose to 

create an online invoice, Magento determines whether the number of days passed from the first 

authorization exceeds the Order Valid Period value. If more days have passed, you cannot create an 

online invoice for this order. 

If the order is valid, Magento determines whether the first authorization is valid, comparing the 

number of days passed with the Authorization Honor Period value. If the authorization is valid, the 

necessary sum is captured; the rest is left on hold, and the number of captures is not limited. If the 

authorization is not valid anymore, it is voided. A new authorization and capture are created, but 

for the invoice total (not the order total). From this moment, each time you create an online invoice 

for this order, a new authorization and capture will be conducted only for invoice totals. 

Also, Magento will determine whether the number of the conducted captures is equal to the 

Number of Child Authorizations value each time. If the number specified there is already reached, 

creating online invoices for the order will not be possible. 

If you click the Void button on the order view page, the Order transaction is voided. After this, no 

online invoice can be created for the order. 
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Note: PayPal provides an option of capturing an amount larger than was ordered. 
However, this option is not supported in Magento. 

Billing Agreements 

The Billing Agreement functionality enables customers to sign an agreement with the payment 

system and eases the process of checkout because customers do not need to specify payment 

information again and again. During the shopping cart checkout, the customer can simply choose a 

billing agreement as a payment method and based on its number; the payment system will charge 

the customer's account. 

Billing Agreements Overview 

With the Billing Agreements functionality, individual customers purchasing products from a web 

store on regular basis can place sales orders through an external payment system without specifying 

their credit card information again and again; they can simply grant the authorization to the 

payment system once. With Billing Agreements, customers do not need to enter credit card 

information in Magento and they are not redirected to the external payment system, although the 

actual payment is performed there. 

After the customer signs a billing agreement with the store on the PayPal side, PayPal provides the 

store and the customer with the reference ID for the signed billing agreement. The reference ID is a 

unique number assigned to a billing agreement by the payment system. During subsequent 

purchases, the customer selects the billing agreement as the payment method and uses the billing 

agreement reference ID. No other payment information is required for placing an order. The 

payment system verifies billing agreement information and whether the payment can be fulfilled by 

the reference ID specified by the customer. After the payment system performs the payment 

transaction, the reference ID is returned to the Magento system and an order is placed. 

Note: Currently Magento Enterprise Edition supports using only the PayPal Express 
Checkout payment method for the Billing Agreement functionality. Before enabling 
billing agreements, you need to contact the PayPal Merchant Technical Services for 
enabling the billing agreements (reference transactions) for your PayPal merchant 
account. 

After a billing agreement is signed with PayPal, the store owner can charge the customer’s PayPal 

account directly. 

After the Billing Agreement functionality is enabled in the Magento backend configuration (System > 

Configuration > SALES > Payment Methods> PayPal Express Checkout > Advanced Settings > 

PayPal Billing Agreement Settings or in the scope of configuring PayPal Express Checkout for All-in-

one PayPal solutions, like PayPal Payments Advanced), billing agreements can be created in the 

following two ways: 

 Creating a billing agreement from the customer account in the frontend: The customer uses 

the Billing Agreement wizard which redirects him or her to the PayPal website, where a 

billing agreement is signed.  
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Note: A billing agreement can be created from a customer account only if the Allow in 
Billing Agreement Wizard parameter is enabled in the Magento backend. 

 Submitting a billing agreement with an order: After choosing the corresponding payment 

method, the customer is redirected to the PayPal website, where a billing agreement is 

signed. 

Configuring Billing Agreements 

To enable and configure PayPal Express Checkout Billing Agreements: 

Note: The Billing Agreements payment method can also be enabled from the PayPal 
All-in-One solution. 

1. In the Admin Panel, navigate to System > Configuration > SALES > Payment Methods. 

2. Locate and expand PayPal Express Checkout > Advanced Settings > PayPal Billing Agreement 
Settings. 

3. Set the Enabled field to Yes. 

Note:  The PayPal Billing Agreement payment method becomes available after the 
customer creates any billing agreements in her or his customer account. 

4. In the Title field, specify the name of the billing agreement payment method that will be 
available to customers on the Billing Agreements tab of the customer account and in the 
Payment Information section of the shopping cart Checkout page. 

5. If more than one payment method is enabled, in the Sort Order field specify the order of the 
Bank Transfer payment method to appear in the Payment Information section both in the 
frontend and in the backend. 

6. In the Payment Action field, choose the way payments will be authorized in the PayPal 
payment system and the entities that will be created in the backend as a result of the payment 
transaction. The following options are available:  

 Authorization: Payments are only authorized on the PayPal side and only an order is 

created in the backend of your store. You will need to log on to the merchant account on 

the PayPal website and capture the transaction. 

 Sale: A payment is authorized and captured on the PayPal side and as a result an order and 

an invoice are created in the backend of your store. 

7. The Payment from Applicable Countries parameter enables you to select which customers can 
use this payment method. All Allowed Countries means that all customers from the default 
countries list can use this payment method. If you have not already configured the default list, it 
can be done by navigating to System > Configuration > GENERAL > General > Countries 
Options and selecting each country you want to add from the Allow Countries list. If you want 
to further reduce the number of countries from which your customers will be allowed to use this 
payment method, select Specific Countries. This means that only customers whose billing 
address includes one of the countries listed in the Payment from Specific Countries list below 
can use this payment method. 
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8. In the Debug Mode field, specify whether communications with the payment system are written 
into the log file. 

Note: To prevent fraud, the credit card information is not written to the log file. 

9. In the Transfer Cart Line Items field, choose whether shopping cart lines (product names, their 
price, quantities, and row total amounts) are transferred separately line by line, or transferred as 
one whole with the total price value. 

10. The customer is able to create billing agreements from the customer account if the Allow in 
Billing Agreements Wizard option is enabled in the configuration. The Billing Agreements tab in 
the customer account provides the wizard which redirects the customer to the PayPal website 
where a billing agreement is signed. 

In the Express Checkout settings, you should also specify what options for signing a billing 

agreement your customers will have during the shopping cart checkout. Choose from the following 

options in the Billing Agreement Signup field: 

 Auto: The customer will not be notified that he or she will have to sign a billing agreement 

with the store when redirected to her or his PayPal customer account. After reading the 

agreement, the customer may choose whether to sign a billing agreement or to return to 

your store and check out with another payment method. 

 Ask Customer: When selecting the PayPal Express Checkout payment method during the 

shopping cart checkout, the customer will have the choice of either checking out through 

the normal PayPal process, or by checking out the order through PayPal and signing a 

billing agreement on the PayPal side. 

 Never: The customer will not be able to sign a billing agreement when submitting a sales 

order through the PayPal Express Checkout payment method. However, the customer will 

still be able to create a billing agreement from the customer's account and later use these 

during the checkout process. 

Creating a Billing Agreement from a Customer Account 

A customer can create a billing agreement by signing in to her or his customer account on your 

website, selecting the billing agreement payment method, and starting the Billing Agreement wizard 

located on the Billing Agreements tab. When a billing agreement is created, it is submitted to the 

PayPal payment system and is recorded to the customer account with its reference information. The 

number of billing agreements that a customer can create in the customer account is not limited and 

depends only on the customer’s needs. The customer can also cancel some or all of the billing 

agreements on the Billing Agreement page of the customer account. 
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Note: Billing agreements available in the customer account can be either Active or 
Canceled. Canceled billing agreements cannot be reactivated. . 

When checking out products from the shopping cart, a customer who has already signed a billing 

agreement with PayPal can choose the PayPal Billing Agreement payment method in the Payment 

Information section of the checkout page and select the necessary billing agreement reference ID 

from the list. When the customer clicks the Place Order button, the billing agreement reference ID 

and sales order payment details are transferred to the PayPal payment system. After the payment 

system confirms the payment, a sales order is created in Magento. 

Note: If the payment action selected for the PayPal Billing Agreement payment method 
in the backend configuration is Sale, as soon as the customer places an order, the 
PayPal payment system transfers the order amount from the customer’s account to 
the merchant’s one and both a sales order and an invoice are created in Magento. 
With the Authorization payment action selected, only a sales order is created. 

Creating a Billing Agreement with an Order 

If the customer purchasing items from the web store does not yet have a billing agreement with 

PayPal, she or he can choose the PayPal Express Checkout method of payment, select the Sign a 

billing agreement to streamline further purchases with PayPal check box, and be redirected to the 

PayPal payment system where the customer payment information is available and the billing 

agreement can be signed. After a billing agreement with the store is signed, the customer is 

redirected back to the Magento frontend, where an order is placed. A corresponding record appears 

in the billing agreements list.  

Additionally, the customer who has no billing agreements in the customer account can also sign a 

billing agreement from the mini shopping cart or from a product view page by clicking the Check 

out with PayPal button, that is, by using the PayPal Express Checkout payment method. This opens 

a dialog box that gives the customer the option to sign a billing agreement with the PayPal payment 

system. If the customer cancels creating a billing agreement, the order is created through the normal 

PayPal payment process. 

Note: If the customer has one or more billing agreements, the customer can still create 
a new billing agreement from the customer's account, but will not be able to sign a 
new billing agreement using the PayPal Express Checkout payment method. 

When the customer signs a billing agreement during the order checkout, PayPal creates a payment 

transaction through the PayPal Express Checkout payment method selected by the customer (that is, 

a sales order is created in Magento), and a billing agreement reference ID which is sent to the 

customer and the store. The currently created order is not related to the billing agreement that is 

signed. Related billing agreement-order records are created in Magento the next time that the 

customer selects this billing agreement as a payment method and places an order. 
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Managing Billing Agreements 

The store administrator can take a number of actions to manage customer’s billing agreements both 

in the Customer and Sales areas. 

 Sales Management Area: The list of all billing agreements for all customers is available 

under Sales > Billing Agreements. Here, the store administrator can filter the records by the 

customer or billing agreement information including billing agreement reference ID, status, 

and creation date. A specific record provides general information about the selected billing 

agreement and about all sales orders that relate to it. 

The store administrator can view, cancel, or delete a customer’s billing agreements in the 

Sales Management area. Billing agreements can be canceled or deleted by clicking the 

corresponding buttons located in the upper right part of the Billing Agreement page. An 

already canceled billing agreement can only be deleted by the store administrator. 

 Customer Management Area: Billing agreements created by a single customer can be seen 

on the Billing Agreements tab of the customer account page in the backend (Customers > 

Manage Customers). From here, the store administrator can open a required billing 

agreement to view its general information and sales orders relating to it, cancel a billing 

agreement, or delete it. 

Creating a Sales Order with a Billing Agreement 

On a customer’s request, the store administrator can create a sales order and after filling in all 

required information for order currency, items, billing and shipping addresses, she or he needs to 

select the PayPal Billing Agreement payment method and specify the reference number for a 

specific billing agreement. When the order is submitted, the billing agreement reference ID is 

transferred to the PayPal payment system and, if the payment is authorized, an order is created in 

Magento. 

Generating a PayPal Settlement Report 

The PayPal Settlement report provides the store administrator with the information about each 

transaction that affects the settlement of funds. 

Note: Prior to generating settlement reports, the store administrator needs to contact the 
PayPal Merchant Technical Services for creating an SFTP user account, enabling 
settlement reports generation, and enabling SFTP at PayPal business account. 

After configuring and enabling settlement reports in the PayPal merchant account, Magento will 

start generating reports during the following 24 hours. 

To configure PayPal Settlement Reports: 

1. In the admin panel, click System > Configuration. 

2. Under SALES, click Payment Methods and then locate and expand PayPal Express Checkout > 
Advanced Settings > Settlement Report Settings (or in the Express Checkout settings within the 
All-in-one PayPal solution). 
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3. Under SFTP Credentials, specify the login and the password to connect to the PayPal SFTP 
server which will be used for transferring settlement transaction data. The login and the 
password are provided by the PayPal SFTP server administrator. 

4. In the Sandbox Mode field, choose whether you will be using a sandbox for testing settlement 
transaction reports or live environment. If you choose No, two additional fields for specifying 
the location of reports on the server become available. 

5. In the Custom Endpoint Hostname or IP-Address field, specify the hostname or the IP address of 
the server where the reports are stored. The field defaults to the endpoint hostname 
reports.paypal.com. The port number must be separated with a colon from the hostname 
(for example, test.example.com:5224). 

6. In the Custom Path field, specify the path to the folder where settlement reports are stored on 
the PayPal side. The field defaults to /ppreports/outgoing. 

7. PayPal settlement reports are automatically fetched from the PayPal payment system if this is set 
up in the Enable Automatic Fetching field located under Scheduled Fetching. When the field is 
set to Yes, two additional fields for setting up the frequency of fetching settlement reports from 
PayPal appear. 

8. In the Schedule field, choose whether settlement reports will be fetched from PayPal daily, or 
every 3, 7, 10, 14, 30, or 40 days. Specify the time of day when settlement reports will be 
fetched in the Time of Day fields.  

Note: The Schedule and Time of Day parameters are global (set up for all websites). 

Tip: Keep in mind that after settlement reports are delivered to the SFTP server, they are 
only available for 40 days there; after this period of time, the reports are archived. 
You can access archived reports only by special request to PayPal Account 
Management. 

9. Click the Save Config button to save the PayPal settlement reports configuration. 

Viewing a PayPal Settlement Report 

The list of reports that have been fetched from PayPal is available in the backend under Reports > 

Sales > PayPal Settlement Reports. 

Each report contains the following information: 

 Report Date: The date when the settlement report was generated. 

 Merchant Account: The encrypted merchant account number generated by PayPal. 

 Transaction ID: The identification of a transaction of the money moving event. Transaction 

ID is generated by PayPal and cannot be changed by the merchant. 

 Invoice ID: The identification of an invoice generated within Magento. The field can be 

populated with either an invoice ID sent with the capture request or with the value of the 

invoice ID (if any) from the authorizing transaction. 

 PayPal Reference ID: The identification of a related, pre-existing transaction or event. 

 Event Code: The code assigned to the transaction according to the event that has initiated it. 

Among these can be website payments standard payment, express or direct checkout API, 

preapproved payment, subscription payment, and so on. 
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 Initiation Date: The date and time the transaction was initiated. 

 Completion Date: The date and time the transaction was completed. 

 Gross Amount: The amount of the payment between the two parties and before fees. 

 Fee Amount: The amount of fee associated with the settlement. All transaction fees are 

included in this amount. Fees are never amortized across several transactions. 

The store administrator can fetch the most recent settlement reports by clicking the Fetch Updates 

button located in the upper right part of the page. After clicking it, a dialog box appears, stating that 

the system will connect to the PayPal SFTP server to fetch the reports. When all recent reports are 

added to the list, the Infolog message appears, stating the number of reports fetched. 

Opening a report for a required transaction, the store administrator can view the following 

additional information: 

 PayPal Reference ID Type: One of the following reference codes:  

o Order ID 

o Transaction ID 

o Subscription ID 

 Preapproved Payment ID 

 Custom: The text entered by the merchant on the transaction in PayPal 

 Transaction Debit or Credit: The direction of money movement of gross amount 

 Fee Debit or Credit: The direction of money movement for fee 

21.7 PayPal Payflow Pro (Includes Express Checkout) 

PayPal Payflow Pro General Concept 

The Payflow Pro gateway, formerly known as Verisign, is a payment method available for customers 

of the USA, Canada, Australia, and New Zealand. Similar to other PayPal payment methods that are 

provided in Magento, Payflow Pro Gateway requires that the store owner have a merchant account 

at PayPal. Payflow Pro gateway links the merchant account at PayPal and the merchant's website 

and acts both as a gateway and a merchant account. With the Payflow Pro Gateway payment 

method, payments are processed directly on the merchant websites and customers are not 

redirected to PayPal. Unlike other PayPal payment methods, the pricing for using the Payflow Pro 

Gateway method of payment is fixed no matter how many transactions are submitted. That is, 

merchants pay a fixed monthly fee plus a fixed fee for each transaction regardless of their number. 

Payflow Pro Gateway does not require that web store customers have buyer accounts at PayPal; but 

depending on the merchant country, customers may use their PayPal buyer accounts for paying 

through the gateway. 
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The Payflow Pro Gateway payment method implies that customers specify their credit card 

information during the shopping cart checkout, without leaving the store checkout page and without 

PayPal hosted forms. Additionally, payments are accepted through the Payflow Pro Gateway at the 

time when an order is placed. 

Configuring Payflow Pro Gateway 

To enable and configure the Payflow Pro payment method: 

1. In the admin panel, navigate to System > Configuration > SALES > Payment Methods and then 
select the website for which the payment method is to be enabled. 

2. Make sure that your merchant location is specified correctly in the Merchant Country field 
under Merchant Location. 

3. Under PayPal Payment Gateways, click the Configure link for PayPal Payflow Pro (Includes 
Express Checkout). Options are grouped under three main headings: Required PayPal Settings, 
Basic Settings – PayPal Payflow Pro, and Basic Settings – PayPal Express Checkout. See Figure 
182. 

 

Figure 182. Choosing to Configure PayPal Payflow Pro 

4. Under Required PayPal Settings, configure the following options: 

 If the Payment Bridge web application is set up for your Magento installation, enable the 

Use Via Payment Bridge parameter so that payments placed using this payment method are 

processed with PayPal through a secure PA-DSS compliant payment application. If you 

choose to use Payment Bridge, the PayPal Payflow Pro method should be enabled and 

configured in the Payment Bridge application. In the Magento Admin Panel you need to 

configure only settings grouped under Required PayPal Settings. See “Magento Payment 

Bridge,” page 463, for details about Payment Bridge. 

 Filling the Email Associated with PayPal Merchant Account field is optional.  

 In the Partner, User, Vendor, and Password fields, enter the credentials of your Payflow Pro 

merchant account. 
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 Choose whether to activate the test mode for the PayPal payment system merchant account 

in the Test Mode field. The test mode helps testing the integration of Magento with the 

PayPal payment system. Transactions that are submitted while the account is in the test 

mode are not actually submitted to the credit card and electronic check processing 

networks, and credit card or bank accounts are not actually charged. Therefore, they do not 

have a valid transaction ID. Once you have finished testing the integration project, the test 

mode must be turned off. 

 In the Use Proxy field, decide whether a proxy server is used for establishing the connection 

between Magento and the PayPal payment system. When selecting Yes, two additional 

fields for specifying the proxy host and port become available. A third party server can be 

used to relay the traffic, if there is no direct access to the PayPal server. 

 In the Enable this Solution select Yes to enable the PayPal Payments Pro and Express 

Checkout payment methods. 

5. Under Basic Settings – PayPal Payflow Pro configure the following options: 

 In the Title field, specify the name of the payment method that will be displayed to 

customers in the Payment Information section of the shopping cart Checkout page. This 

parameter can be set up for each store view. 

 When deciding to use a number of payment methods, in the Sort Order field determine the 

order this method will be displayed in the Payment Information section of the shopping cart 

Checkout page in the frontend. 

 In the Payment Action field, choose the way payments will be authorized in the PayPal 

payment system and the entities that will be created in the backend as a result of the 

payment procedure. The following options are available:  

o Authorization: Payments are only authorized in the PayPal payment system and 

only an order is created in the backend of your store. You need to log on to the 

merchant account on the PayPal website and capture the transaction. 

o Sale: A payment is authorized and captured in the PayPal payment system and as a 

result a corresponding transaction is created in the PayPal merchant account and 

an order and an invoice are created in the backend of your web store. 

 Under Credit Card Settings, in the Allowed Credit Card Types field, select the allowed types 

of credit cards that can be used when paying with the PayPal Payments Pro Payflow method 

of payment. In the frontend, the customer can choose among the credit card types specified 

in this list. These will be provided in the Payment Information section of the Checkout page. 

 Choose customers of which countries can use this method of payment in the Payment 

Applicable From field. Choose between the following options:  

o All Allowed Countries: Customers from the default countries list can use this 

payment method.  
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Note: The default list of countries is defined in the Allow Countries field located under 
System > Configuration > GENERAL > General > Countries Options. 

o Specific Countries: Only customers whose billing address includes one of the 

countries listed in the Countries Payment Applicable From field that becomes 

available can use this payment method. The field works as a filter, so that this 

payment method will only be listed for those customers whose billing address is 

one of these selected countries. 

 In the Debug Mode field, specify whether communications with the payment system are 

written into the log file. The credit card related information is not written to the log file in 

order to prevent credit card fraud. 

 In the Enable SSL verification field decide whether you want to enable host authenticity 

verification. 

 In the Require CVV Entry field, choose whether a credit card verification number must be 

specified by the customer when he or she enters credit card information during the 

shopping cart checkout. The Card Security Code (CSC) provides an additional security 

measure to prevent card misuse within online transactions. (The Card Security Code is also 

known as the Card Verification Value.) 

 Under 3D Secure, set the 3D Secure Card Validation field to Yes to specify that credit cards 

will be verified through the Centinel 3D Secure system. If the parameter is enabled, the 

following two fields become available.  

Note: The 3D Secure functionality used for credit card verification must first be set up 
under System > Configuration > SALES > Payment Services > 3D Secure Credit 
Card Verification. In this case, credit card validation will be performed by the 3D 
Secure service provided by CardinalCommerce when customers choose to pay 
with the Payflow Pro Gateway payment method during the checkout.  

o In the Severe 3D Secure Card Validation field, choose whether severe validation 

will be applied to credit cards through the 3D Secure service. Severe credit card 

validation removes the chargeback liability on merchant. 

o In the Centinel API URL field, enter the URL provided by Centinel which will 

establish the connection with the Centinel system for credit card validation. 

 For details on PayPal Settlement Report and its settings see “Generating a PayPal Settlement 

Report,” page 227. 

6. Under Basic Settings PayPal Express Checkout configure the options of the PayPal Express 
Checkout Payflow Edition payment method. This edition of the PayPal Express Checkout has 
fewer options than standalone Express Checkout. But the existing options coincide with the 
similar options of the Express Checkout. See “PayPal Express Checkout,” page 214, for more 
information.  

7. To save the configuration click Save Config. 
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Working with Payflow Pro Gateway 

After customers add products to their shopping carts and proceed to the checkout, they specify their 

billing and/or shipping addresses and the shipping method. Then, in the Payment Information 

section of the Checkout page, they can select the Payflow Pro payment method, enter the type of 

credit card, its number, expiration date, and the card verification number. Customers are not 

redirected to the PayPal website when they choose to pay with Payflow Pro Gateway. Depending 

on the payment action selected in the configuration of the payment method, either a sales order or a 

sales order and an invoice are created under Sales > Orders. 

Orders paid with Payflow Pro Gateway can be processed online only from Magento. Here, you can 

submit an online invoice and as a result a corresponding transaction and an invoice will be created. 

Regarding order amount refunds, you can also submit them online from the created invoice. 

Note: Partial invoices are not available when using the Payflow Pro Gateway payment 
method. The Qty to Invoice field is unavailable for editing. The partial refund is 
unavailable as well. 

You can view all Payflow Pro Gateway transactions in the PayPal manager at 

https://manager.paypal.com/ . 

21.8 The PayFlow Link Payment Method 

Magento Enterprise Edition includes the option of using the PayFlow Link payment method for 

PayPal. PayFlow Link is available for merchants in the United States and Canada only; this method 

requires a Payflow merchant account. 

This method passes the information about the card, entered by the customer, directly to PayPal; it is 

never stored in Magento system. A customer does not need to have a PayPal account to use this 

method. 

The PayFlow Link payment method is not available for orders created from the Admin Panel. 

Note: You can find more information about the PayFlow Link by PayPal here: 
https://www.paypal.com/cgi-bin/webscr?cmd=_payflow-link-overview-
outside&bn_r=m 

Configuring the PayFlow Link Payment Method  

To use the PayFlow Link feature, you should have a separate PayFlow Link account for each 

website. 

Configuring the PayFlow Link method for each website is a two-step procedure: 

1. Set the options in the Magento Admin Panel. 

2. Set the required options of the PayFlow Link account on the PayPal Manager website. 

https://manager.paypal.com/
https://www.paypal.com/cgi-bin/webscr?cmd=_payflow-link-overview-outside&bn_r=m
https://www.paypal.com/cgi-bin/webscr?cmd=_payflow-link-overview-outside&bn_r=m
https://manager.paypal.com/
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Setting the PayFlow Link Payment Method Options in the Magento Admin 
Panel 

To configure the PayFlow Link method in the Magento Admin Panel: 

1. In the admin panel, click System > Configuration. 

2. Select the desired website from the Current Configuration Scope drop-down menu in the upper-
left corner of the page. 

3. Under SALES in the left column, click Payment Methods. In the Merchant Country field select 
United States or Canada. If any other country is selected, the PayFlow Link settings are not 
displayed. 

4. Under PayPal Payment Gateways, click Configure next to the PayPal Payflow Link (Includes 
Express Checkout) label. Options are grouped under three main headings: Required PayPal 
Settings, Basic Settings – PayPal Payflow Link, and Basic Settings – PayPal Express Checkout. 

5. Under Required PayPal Settings > PayFlow Link, configure the following options: 

 In the Partner, Vendor, User and Password fields, specify your Payflow Link account 

credentials.  

 Test Mode: The test mode helps testing the integration of Magento with the PayPal payment 

system. Transactions that are submitted while the account is in the test mode are not 

actually submitted to the credit card and electronic check processing networks, and credit 

card or bank accounts are not actually charged. Therefore, they do not have a valid 

transaction ID. When you are finished testing the integration project, the test mode must be 

turned off. 

 Use Proxy: Decide whether the proxy server is used for establishing the connection 

between Magento and the PayPal payment system. If you select Yes, two additional fields 

for specifying the proxy host and port are displayed. 

6. In the Enable Payflow Link drop-down menu, select Yes to enable the payment method. 

7. Under Required PayPal Settings > Express Checkout, configure the options of the Express 
Checkout. The Express Checkout included to the Payflow Link method can be enabled only if 
the Payflow Link method is enabled. For description of the Express Checkout settings, see 
“PayPal Express Checkout,” page 214. 

8. Under Basic Settings – PayPal Payflow Link, configure the following Payflow Link options: 

 Title: In the Title field, specify the name of the payment method that will be displayed to the 

customer in the Payment Information section of the one-page checkout. This parameter can 

be set up for each store view. 

Note: We recommend that you use the PayPal value in the Title field for each store 
view. 

 Sort order: When deciding to use a number of payment methods, in the Sort Order field 

determine the order this method will be displayed in the Payment Information section of the 

one-page checkout.  
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Note: The payment methods for which the sort order is not set are displayed first. 

 Payment Action: Choose what type of transaction is conducted when the order is placed, 

and the entities that will be created in the backend as a result. The following options are 

available: 

o Authorization: The payment is authorized and only an order is created in the 

backend of your store. 

o Sale: The payment is captured on the PayPal side, and as a result an order and an 

invoice are created in the backend of your store. 

 Payment Applicable From: Choose the countries whose residents can use this payment 

method. Choose between the following options: 

o All Allowed Countries: Customers from the default countries list can use this 

payment method. 

o Specific Countries: Only customers whose billing address includes one of the 

countries selected in the Countries Payment Applicable From field can use this 

payment method. The field works as a filter, so that this payment method will be 

listed for only those customers whose billing address is in one of these selected 

countries. 

 Debug Mode: In the Debug Mode field, specify whether communications with the payment 

system are written into the log file. The log file for PayFlow Link payments is 

payment_payflow_link.log. 

 CVV Entry is Editable: Choose whether the field for entering CVV number will be displayed. 

 Require CVV Entry: Choose whether CVV field will be mandatory. The setting appears only 

if CVV Entry is Editable is set to Yes. 

 Send Email Confirmation: Choose whether PayPal email confirmation will be sent to 

customers. 

 URL method for Cancel URL and Return URL: The setting refers to the Cancel and Return 

URL displayed on the PayPal-hosted form.  

9. The PayPal Billing Agreement Settings, Settlement Report Settings and Frontend Experience 
Settings and Basic Settings – PayPal Express Checkout sections are related to configuring the 
PayPal Express Checkout method, which is included with the PayPal Payflow Link payment 
methods. 

10. Click Save Config in the upper-right corner of the page to save the settings. 

Setting the PayFlow Link Account Options on the PayPal Manager Website 

To make the necessary settings for the PayFlow Link account, you should log in to 

https://manager.paypal.com/ and select Service Settings > Hosted Checkout Pages > Set Up. You 

can find the information for setting the required options in the Magento Admin Panel. It is displayed 

in the Required PayPal Settings > Payflow Link section of the PayPal Payflow link configuration. 

 

https://manager.paypal.com/
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PayFlow Link Payment Method: Customer Experience 

The store customer selects the PayFlow Link payment method on the Payment Information checkout 

step and clicks Continue. The Order Review step appears, where the PAY NOW button is available 

instead of the usual PLACE ORDER button. After the customer clicks PAY NOW, the PayPal-hosted 

form, where the credit card information can be entered, loads in the checkout page. The customer 

specifies the card information and clicks Pay Now. See Figure 183. If the transaction is successful, 

the customer is redirected to the order confirmation page.  

 

Figure 183. PayFlow Link in the Frontend (PayPal-hosted Form) 

The form also contains the Cancel Payment link. Clicking it redirects the customer to the Payment 

Information step of the checkout, where the payment method is selected. 

If the transaction fails on any reason, an error message appears on the checkout page and the 

customer is directed to repeat the checkout process. These situations are handled on the PayPal 

side. 

Order Processing When the PayFlow Link Payment Method Is Used 

When a customer clicks the PAY NOW button on the last checkout step, the order is created in the 

Admin Panel with a Pending Payment status. After the customer enters the card information and 

clicks Pay Now in the form, uploaded from PayPal, the status of the order changes, depending on 

the response the system receives from PayPal:  

 Processing: The transaction was successful 

 Pending Payment: The system did not receive any response from PayPal 

 Canceled: The transaction was not successful for some reason 

 Suspected Fraud: The transaction did not pass some of the PayPal fraud filters and the 

system receives the response from PayPal that the transaction is under review by Fraud 

Service 
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Note: You can manage your fraud filters at https://manager.paypal.com/ 

If the customer clicks the Cancel Payment link in the form, the order status changes to Canceled. 

The new order is created when a customer proceeds with the checkout. 

In general, processing of orders that are paid using the PayFlow Link payment method is the same as 

regular processing of orders that are paid with PayPal. An invoice, shipment, and credit memo 

(online/offline refund) can be created. Multiple online refunds are not available for the PayFlow Link 

payment method. 

21.9 PayPal Payments Pro Hosted Solution (Includes 
Express Checkout)  

In Magento Enterprise Edition, the PayPal Payments Pro Hosted Solution payment method is 

available for merchants from EU and APAC regions. The method’s naming is different for different 

merchant countries: 

 Japan: Website Payments Plus  

 France: Integral Evolution  

 Italy: PayPal Pro  

 Spain: Pasarela integral  

 Others: Payments Pro Hosted Solution  

This method passes information about the credit card directly to PayPal without the customer being 

redirected to the PayPal website. The card information is never stored in Magento system, which 

can be preferable for customers for higher security. A customer does not need to have a PayPal 

account to use this method, but the store owner must have a Website Payments Pro account on 

PayPal. 

The Website Payments Pro Hosted Solution payment method is available only in orders created 

from the frontend. 

Configuring the Website Payments Pro Hosted Solution Payment 
Method in the Magento Admin Panel 

To configure the Website Payments Pro Hosted Solution payment method: 

1. In the admin panel, click System > Configuration. 

2. Select the desired website from the Current Configuration Scope drop-down menu in the upper-
left corner of the page. 

3. Under SALES in the left column, click Payment Method. In the Merchant Country field, select 
the country that receives money, according to your PayPal account details.. 

https://manager.paypal.com/
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4. Under PayPal Payment Solutions, click the Configure link for PayPal Payments Pro Hosted 
Solution (includes Express Checkout). The options are grouped under three main headings: 
Required PayPal Settings, Basic Settings – PayPal Website Payments Pro Hosted Solution, and 
Basic Settings – PayPal Express Checkout. 

5. Under Required PayPal Settings, configure the following options: 

 Populate the Email Associated with PayPal Merchant Account field.  

 In the API Authentication Methods drop-down menu, choose between API Signature and 

API Certificate. 

 In the API Username, API Password, and API Signature fields, specify the API username, 

password, and signature provided by the PayPal payment system.  

Note: You can get your PayPal API credentials at the PayPal website. Click the Get 
Credentials from PayPal button to open the PayPal website page. You need to log 
in to your account and click the API Credentials link to get the credentials. 

 You can activate the test mode for the PayPal payment system merchant account in the 

Sandbox Mode field. The test mode helps testing the integration of Magento with the PayPal 

payment system. Transactions that are submitted while the account is in test mode are not 

actually submitted to the credit card and electronic check processing networks, and credit 

card or bank accounts are not actually charged. Therefore, they do not have a valid 

transaction ID. After testing the integration is finished, the test mode must be turned off.  

 To test Magento and PayPal in sandbox mode, click the Sandbox Credentials button, log in 

to your sandbox test account, and click the API Credentials link to acquire the necessary 

information.  

 In the API Uses Proxy field, indicate whether a proxy server is used for establishing the 

connection between Magento and the PayPal payment system. If you select Yes, two 

additional fields for specifying the proxy host and port become available.  

 In the Enable this Solution select Yes to enable the payment method. 

6. Under Basic Settings – PayPal Website Payments Pro Hosted Solution configure the following 
options: 

 In the Title field, specify the name of the payment method that will be displayed to the 

customer in the Payment Information section of the one-page checkout. This parameter can 

be set up for each store view. 

 When deciding to use a number of payment methods, in the Sort Order field determine the 

order this method will be displayed in the Payment Information section of the of the one-

page checkout.  

 Payment Action: Choose what type of transaction is conducted when the order is placed, 

and the entities that will be created in the backend as a result. The following options are 

available: 

o Authorization: The payment is authorized and only an order is created in the 

backend of your store. 

o Sale: The payment is captured at PayPal's side, and as a result an order and an 

invoice are created in the backend of your store. 
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 In the Display Express Checkout in the Payment Information step decide whether Express 

Checkout will be displayed in the list of available payment methods during one-page 

checkout. 

 Choose the countries from which customers can use this method of payment in the Payment 

Applicable From field. Choose between the following options:  

o  All Allowed Countries: Customers from the default countries list can use this 

payment method. 

Note: The default list of countries is defined in the Allow Countries field located under 
System > Configuration > GENERAL > General > Countries Options.  

o Specific Countries: Only customers whose billing address includes one of the 

countries listed in the Countries Payment Applicable From field can use this 

payment method. The field works as a filter, so that this payment method will only 

be listed for those customers whose billing address is one of these selected 

countries.  

 In the Debug Mode field, specify whether communications with the payment system are 

written into the log file. The log files are stored in the magento/var/log folder. 

 In the Enable SSL verification field decide whether you want to enable host authenticity 

verification. 

7. The PayPal Billing Agreement Settings, Settlement Report Settings, Frontend Experience Settings 
and Basic Settings – PayPal Express Checkout sections are related to configuring the PayPal 
Express Checkout method. The existing options coincide with the similar options of the Express 
Checkout. See “PayPal Express Checkout,” page 214, for more information. 

8. Click Save Config in the upper-right corner of the page to save the settings. 

The Website Payments Pro Hosted Solution Payment Method: 
Customer Experience 

Using the Website Payments Pro Hosted Solution payment method is similar to using the PayFlow 

Link payment method, which is described in “The PayFlow Link Payment Method,” page 233. The 

only difference is that the PayPal-hosted form for entering the card information, which appears for 

the Website Payments Pro Hosted Solution payment method, does not contain the Cancel Payment 

link redirecting the customer to the Payment Information step of the checkout, where another 

payment method can be selected. 

Handling Orders Paid with the Website Payments Pro Hosted 
Solution Payment Method 

When the customer clicks the Pay Now button at the Order Review checkout step using the Website 

Payments Pro Hosted Solution payment method, the order with Pending status is created in the 

Admin. After the customer submits the form by clicking the Pay Now button in the PayPal-hosted 

form, the system receives the notification from the payment gateway using the Instant Payment 

Notification protocol (IPN). The status of the order is changed according to the notification received.  
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In general, processing of the order, that are paid using the Website Payments Pro Hosted Solution 

payment method is the same as regular order processing in Magento. An invoice, shipment, and 

credit memo (online/offline refund) can be created. Multiple online invoices and multiple online 

refunds are available for the Website Payments Pro Hosted Solution payment method as well. 

21.10 PayPal Fraud Management Filter Support in Magento 

Magento Enterprise Edition includes support for PayPal fraud management filters (FMFs), available 

for owners of Website Payments Pro PayPal accounts. 

PayPal FMFs are intended to make it easier for merchants to detect and respond to fraudulent 

transactions. FMFs can be configured to flag, hold for review, or deny riskier payments. Magento 

order status values are changed according to these settings. It works for orders that are paid using 

the Express Checkout or Website Payments Pro payment methods. This section describes the 

processing of suspected fraudulent orders for different filter action settings. 

Note: You can manage your fraud filters at https://manager.paypal.com/. 

“Review” Filter Action  

If for a certain PayPal FMF you set the filter action to “Review,” in the Magento Admin Panel the 

suspected order receives the status ”Payment Review” when the order is placed. 

You can review the order and approve, or cancel the payment in the Magento Admin Panel, or on 

the PayPal side. See Figure 184. 

 

Figure 184. An Order That Needs Review, According to the FMF Settings 

To accept the payment in the Magento Admin Panel, click the Accept Payment button in the upper-

right corner of the page. The order status changes to “Processing,” the corresponding information is 

added in the Comments History section of the order view, and the transaction gets the “Completed 

Payment” status on the PayPal side. 

https://manager.paypal.com/
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To deny the payment in the Magento Admin Panel, click the Deny Payment button in the upper-

right corner of the page. The order status changes to “Canceled,” the transaction is reverted, and 

funds are released on the customer’s account. The corresponding information is added in the 

Comments History section of the order view. 

When you click the Accept Payment or the Deny Payment buttons, no new transactions for the 

order are created. 

If you change the status of the transaction on the PayPal site, you must click the Get Payment 

Update button in the upper-right corner of the Order page in the Magento Admin Panel to apply the 

changes. If you click Accept Payment or Deny Payment, the changes made at the PayPal site are 

applied. 

“Deny” Filter Action  

If for a certain PayPal FMF you set the filter action to “Deny,” the suspected order cannot be placed 

by the customer, because the corresponding transaction is rejected by PayPal. 

“Flag” Filter Action  

If for a certain PayPal FMF you set the filter action to “Flag”, the suspected order gets the status 

”Processing” when it is placed. 

The corresponding transaction is marked with a “flag” in the list of the merchant account 

transactions. 
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22 Authorize.Net Payments 
This chapter describes the integration with the Authorize.Net payment gateway that is available in Magento 

Enterprise Edition. 

22.1 Balance Response, Partial Authorization 
Transactions, and Authorization Reversals  

Because MasterCard and Discover modified their rules for processing debit, prepaid, and gift cards, 

the Authorize.Net payment gateway now requires its merchants to add the following functionality to 

their eCommerce applications to comply with new requirements: 

 Balance response transactions 

 Partial authorization transactions 

 Authorization reversals 

eCommerce merchants are currently required to provide support for authorization reversals only. 

Though no longer required, partial authorizations and balance responses are considered best 

practices, and Authorize.Net still strongly recommends that eCommerce merchants provide support 

for all three requirements. Magento Enterprise Edition includes all three options. 

These features are implemented in the Authorize.Net payment method. The following types of debit, 

prepaid, and gift cards are supported: 

 MasterCard  

 Discover  

 Diners Club  

 JCB  

 Visa  

 American Express (supporting only partial authorization and balance response transactions)  

Balance response transactions, partial authorizations, and authorization reversals are provided for 

all merchants, even from countries other than the United States.  

Magento triggers the new functionality during the order creation, when it receives the appropriate 

response from the Authorize.Net payment gateway. The gateway receives approval or rejection for 

using the new features from the bank it communicates with, while processing payments.  

Balance Response 

If the customer chooses the Authorize.Net payment method and uses one of the supported debit, 

prepaid, or a gift cards, the information about the balance and the amount put on hold or captured 

for this card is available for viewing. You can view these balances in the Payment Method block of 

the order view (My Account > My Orders), in the Remaining Balance and Processed Amount fields. 

The following information is displayed for a card (see Figure 185): 
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 Credit Card Type  

 Credit Card Number (only the last four digits of the card number are stored and displayed in 

Magento) 

 Processed Amount  

 Remaining Balance (if available)  

 

Figure 185. Customer's Card Information in the Order View 

The same information is also shown in the Payment Method section of emails that are sent to the 

customer upon creating an order, its invoice, shipment notice, and credit memo. If the customer 

uses more than one credit card for paying the order (that is partial authorization takes place), the 

information is included for each card that is used in the payment. For detailed information about 

partial authorization, see “Partial Authorization,” page 244. 

Similarly, the balance and the amount put on hold or are shown in the Payment Information block 

of the order view in the Admin Panel (see Figure 186). 
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Figure 186. Credit Card Information in the Order View in the Admin Panel 

Note: In some cases the balance information is not available (that is, the card issuer 
may not return the remaining balance on customer's card). This typically occurs 
when the customer's card is a credit card. In this case, the Remaining Balance field 
does not appear in the back-end or in the front-end.  

Partial Authorization 

The partial authorization functionality enables your store to accept multiple cards as payment for a 

single order. It can be useful if the customer tries to pay for a purchase with a card, but it turns out 

that the amount available on the card is not enough to complete the payment. Magento enables the 

customer to use up to five cards for one order. 

The partial authorization feature is optional. You can enable or disable it at the global or at the 

website level. 

To set the partial authorization: 

1. On the Magento top menu, click System > Configuration. 

2. In the Current Configuration Scope drop-down menu in the upper left part of the page, leave the 
Default Config or select the desired website. 

3. In the left column under SALES click the Payment Methods tab. In the Authorize.Net field set, 
you can enable or disable the partial authorization functionality using the Allow Partial 
Authorization drop-down menu. 
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Partial Authorization: Customer Experience 

During the one-page checkout process, the customer selects the Authorize.Net payment method, 

types the card information, and proceeds to the Order Review checkout step. After the customer 

clicks PLACE ORDER, the request is sent to Authorize.Net. If the payment gateway responds that the 

amount available on the card is not enough to cover the order total, a dialog box with the following 

message appears: 

The amount on your credit card is insufficient to complete your purchase. 

The available amount has been put on hold. To complete your purchase, 

click Continue and specify additional credit card number. To cancel the 

purchase and release the amount on hold, click Cancel. 

After the customer chooses to continue, the Payment Information checkout step reappears and the 

customer is prompted to specify another credit card. The information about the previously used 

credit cards is displayed as well (see Figure 187). 

If the customer clicks Cancel in the Payment Information checkout step, all authorizations are 

reversed. The customer may then choose another payment method to complete the purchase. If the 

customer simply closes the browser window, authorizations remain active until they expire. The 

terms of authorizations depend on the banks that issued the credit cards. 

Note: The order in the Admin Panel is created only after the total amount of the order is 
covered. 
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Figure 187. Partial Authorization Triggered During Checkout 

When the customer reaches the limit of five cards allowed to be used for one order, the following 

message appears in the Order Review checkout step: 

You have reached the maximum number of credit cards that can be used 

for the payment. 

When the customer clicks the OK button, the Payment Information checkout step reappears, where 

the following message is displayed: 

"You have reached the maximum number of credit cards that can be used 

for one payment. The available amounts on all used cards were insufficient 

to complete payment. The payment has been canceled and amounts on 

hold have been released. 

The system sends a request to Authorize.Net to void all authorizations of this payment. The 

customer may now choose other payment method or try to use other credit cards. 
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During partial authorization the bank may reject the transaction for some reason, for example if the 

daily card limit is exceeded for the credit card. In this case Authorize.Net sends the appropriate 

response to Magento and the following message is displayed: 

Your credit card has been declined. Click Continue to specify another 

credit card to complete your purchase. Click Cancel to release the amount 

on hold and select another payment method. 

If the customer decides to reverse the payment and clicks Cancel, the payment will be reversed and 

a request will be sent to Authorize.Net to release the amounts on hold from the previously entered 

cards. The customer may then select another payment method. If the customer chooses to continue, 

the Payment Information checkout step reappears, and the customer is prompted to enter another 

credit card. 

To revert all authorizations made during the partial authorization process and release all amounts, 

while the order is not placed yet, the customer can use the Cancel button in the Payment 

Information checkout step. 

If the customer starts partial authorization having performed payment with at least one credit card, 

and then changes any information on any checkout step, the partial authorization cannot proceed 

correctly An error message appears after the customer clicks PLACE ORDER, all authorizations are 

released automatically, and the customer is redirected to the Payment Information checkout step. 

Partial Authorization in Orders Created from the Admin Panel 

The partial authorization feature can be used in orders, created from the Admin Panel, either when 

you create a new order or use the reorder feature (the Reorder button on the order view page). 

When you choose the Authorize.Net payment method in the order, enter the card information, and 

click the Submit Order button, the request is sent to Authorize.Net. If the amount on the card is not 

enough to cover the order, the available funds are put on hold and the partial authorization is 

triggered. The corresponding message appears on the Create New Order page. If you choose to 

continue, the system displays the information about the previously used credit cards and prompts 

you to enter another credit card. If you click Cancel, then all authorizations are reversed.  

If you simply close the browser window during the partial authorization, then authorizations will 

remain active until they expire. The term of authorization depends on the bank that issued the credit 

card. 

You can cancel the order by clicking the Cancel button in the upper right corner of the page, if 

payment is not yet complete. In this case Magento sends a request to Authorize.Net to void the 

authorizations for all cards carried out during the partial authorization. This releases the amounts on 

hold on the entered cards. If the payment gateway is not able to void the authorizations on some 

transactions, the system only cancels the order.  

If you change any order information, after the partial authorization was triggered, it cannot 

proceed correctly. An error message appears if you enter another card and click Submit 

Order, and all authorizations are released automatically. 
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Partial Authorization Refund 

When processing a refund on an order that was paid for with partial authorizations, Magento 

refunds the captured amounts to the cards they originated from. This process is performed by the 

system and you do not have to do anything. 

When you initiate an online invoice or online refund, and some of the authorizations fail, the 

system proceeds with the rest of authorizations. The online invoice or refund document is not 

created in this case. When all authorizations have been processed, the system displays a message 

with information on all processed authorizations (both successful and failed) in the order header. 

The same information is added to the order comments. 

A recommendation to proceed with failed authorizations manually on the Authorize.Net is issued to 

the store administrator. The store administrator can view a notification message stating that she or 

he can create only offline invoice or offline refund in Magento. 

In the case of a partial refund, the amounts are refunded to the cards they originated from, in the 

order they were authorized. That is, the amounts captured from the first card are refunded to this 

card first. It is possible that for the last card in the partial refund process, the amount reversed is less 

than was captured during the partial authorization. In this case the transaction for this card remains 

open and can be closed in the next partial refund. 

Only the last four digits of the credit card number are stored in Magento. Authorize.Net allows 

merchant systems to submit the refund using the last four digits of the credit card number during 

120 days after the payment. That is why, if more than 120 days passed from the date of the 

payment, you cannot process an online refund for an order that was paid with the Authorize.Net 

payment method. 

Because American Express does not support authorization reversals, it is impossible to create an 

online refund for these cards. In this case you can create an offline refund, and settle the situation by 

releasing the customer's funds outside the Magento system. 

22.2 The Direct Post Payment Method for Authorize.Net  

Magento incorporates the Direct Post Method for payments using the Authorize.Net gateway. The 

Direct Post method uses the Server Integration Method and the Advanced Integration Method. 

Note: In older versions of Magento the Advanced Integration Method is used. 

When payments are made using the Direct Post Method, the Authorize.Net gateway handles all 

steps in the transaction process (payment data collection, data submission, and response to the 

customer) while the customer is not redirected anywhere from the web store.  

You can learn more about the Direct Post Method here: http://developer.authorize.net/api/dpm/  

http://developer.authorize.net/api/dpm/
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Enable and Configure the Authorize.Net Direct Post  

To enable and configure the Authorize.Net Direct Post payment method: 

1. Navigate to System > Configuration > SALES > Payment Methods > Authorize.Net Direct Post. 
Configuration can be done on either the global or website level, so in the Current Configuration 
Scope drop-down menu, located in the upper left part of the page, leave the Default Config or 
select the desired website. The following settings are available: 

 Enabled: Enable or disable the Authorize.Net Direct Post payment method. 

 Payment Action: In the Payment Action field, choose the way payments will be authorized 

in the Authorize.Net payment system and the entities that will be created after the 

successful transaction in the backend as a result of the payment procedure. The following 

options are available:  

o Authorize Only: Funds on the customer's card are only authorized at the side of the 

Authorize.Net system and only an order is created in the backend of your store. 

You can later create an invoice and conduct the capturing. 

o Authorize and Capture: Funds on the customer's card are authorized and captured 

at Authorize.Net side, and as a result an order and an invoice are created in the 

backend of your store. 

 Title: In the Title field, specify the name of the payment method that will be displayed to the 

customer in the Payment Information section of the one-page checkout. This parameter can 

be set up for each store view. 

 API Login ID and Transaction Key: Specify your Authorize.Net credentials.  

 Merchant MD5: Specify your MD5 Hash Value. 

Note: The MD5 Hash feature enables Magento to verify that transaction responses are 
securely received from Authorize.Net. The MD5 Hash value is used by the 
payment gateway to encrypt responses for transactions, submitted for your account. 
You can set your MD5 Hash Value in your Authorize.Net account settings at the 
Authorize.Net website (select Account > Settings > Security Settings > MD5-Hash.) 

 New Order Status: Select the order status of all new orders that are created using this 

payment method. 

 Test Mode: Select Yes if you want to test the payment method. In this case a notification is 

sent to Authorize.Net that orders should be sent to their test site. When you finish testing the 

integration project, the test mode must be turned off by selecting No in the Test Mode field.  

 Gateway URL: This is the URL to which the order information will be sent. By default, it is 

populated with https://secure.authorize.net/gateway/transact.dll.  

https://secure.authorize.net/#_blank
https://secure.authorize.net/gateway/transact.dll
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Note: If you have a special test URL from Authorize.Net, you can select No in the Test 
Mode list and specify the testing link in the Gateway URL field. However, the URL 
of the live site must be reentered before you take your site live. 

 Accepted Currency: Specify the currency of the transactions. It should be one of the 

currencies that are allowed by the payment gateway and it does not have to correspond to 

the currency in which the prices are displayed on the store pages. 

 Debug: Specify whether communications with the payment system are written into the log 

file. 

Note: Only the four last digits of the customer’s card are written to the log file, in order 
to prevent card fraud. 

 Email Customer: Specify whether you want Authorize.Net to send emails to your customers 

on the completion of the checkout. This does not influence the order confirmation email 

and other transactional emails sent from Magento, only the emails sent from your 

Authorize.Net account.  

 Merchant's Email: Specify the email address associated with your account, if you want 

Authorize.Net to send you email notifications of orders placed using this payment method. 

If it is left blank, no emails will be sent to you by Authorize.Net. 

 Credit Card Types: Select the options that will appear in the Credit Card Type drop-down 

menu in the frontend.  

 Credit Card Verification: Select whether customers will be required to specify the Credit 

Card Verification number during checkout. 

 Payment from Applicable Countries: Choose the countries whose residents can use this 

method of payment. Choose between the following options: 

o All Allowed Countries: Customers from the default countries list can use this 

payment method. 

o Specific Countries: Only customers whose billing address includes one of the 

countries selected in the Payment from Specific Countries field below, can use this 

payment method. The field works as a filter, so that this payment method will only 

be visible for those customers whose billing addresses are in one of these selected 

countries. 

 Minimum/Maximum Order Total: These fields also work as filters. This payment method 

will only be visible for those customers whose order total is above the minimum (if a 

minimum value is specified) and below the maximum (if a maximum value is specified).  

 Sort order: When deciding to multiple payment methods, in the Sort Order field determine 

the order this method will be displayed in the Payment Information section of the one-page 

checkout in the frontend. 

2. Click Save Config in the upper-right corner of the page. 
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Authorize.Net Direct Post in Orders Created from the Admin Panel 

The Authorize.Net Direct Post payment method can be used in the orders created from the Admin 

Panel as well (Sales > Orders > Create New Order). If the method is enabled, you can select it in the 

Payment Method section. After you click the corresponding option button, the fields for the card 

information appear. If the transaction fails, an error message appears and you can then select 

another payment method or try Authorize.Net Direct Post with another card. 

Order Handling 

Handling the orders, paid using the Authorize.Net Direct Post payment method, is quite similar to 

the general Magento order workflow. An invoice, shipment, and credit memo can be created.  

Authorize.Net Direct Post: Customer Experience 

If you enable this method, the customer can select it in the Payment Information section of the one-

page checkout. After the customer clicks the corresponding option button and clicks Continue, the 

Order Review section of the checkout appears, where the fields to enter the card information are 

presented. The customer then needs to enter the card information and click the PLACE ORDER 

button. See Figure 188. 

If the transaction is successful, the customer is redirected to the order confirmation page. If the 

transaction fails on some reason, an error message is displayed in a dialog box and the customer 

may then select another payment method or try Authorize.Net Direct Post with another card. 
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Figure 188. Checkout Using Authorize.Net Direct Post 

22.3 3D Secure Authentication for Authorize.Net 
Payments 

Magento Enterprise Edition includes the option to use 3D Secure authentication for payments 

carried out via the Authorize.Net payment. Cardinal Centinel® is used as the service provider. 

3D Secure Authentication General Concept 

During the checkout, the customer is prompted to specify the secret code assigned to the 

card, which enables the card issuing bank to confirm the cardholder’s identity. The bank 

also provides additional data elements to confirm the cardholder’s identity. The service 

provider arranges communication with banks and payment systems. 
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Note: To find more information about the 3D Secure protocol you can also search by 
“Verified by Visa”, “MasterCard SecureCode”, and “J/Secure”.  

To be able to use the 3D Secure authentication for Authorize.Net payments in Magento, you need 

to take two steps:  

1. Configure general 3D Secure settings. 

2. Enable 3D Secure in the Authorize.Net payment method section. 

3D Secure authentication can be used in both frontend and backend orders. 

Configuring 3D Secure  

To configure general 3D Secure settings in the Admin Panel you do the following: 

1. Navigate to System > Configuration > SALES > Payment Services. Configuring can be done on 
either the global or website level, so leave Default Config, or select the desired website in the 
Current Configuration Scope drop-down menu in the upper-left corner of the page.  

2. Under 3D Secure Credit Card Validation the following settings are available: 

 Processor Id: Specify the merchant processor identification code. This value is assigned to 

you by Centinel. 

 Merchant Id: Specify the merchant identification code. This value is also assigned to you by 

Centinel. 

 Password: Specify the password to connect to the Centinel system. 

 Test Mode: Choose whether the connection with the Centinel system is tested prior to start 

the real life 3D Secure validation of payment transactions. 

3. Click Save Config in the upper-right corner of the page. 

Configuring 3D Secure Use for Authorize.Net 

3D Secure authentication is implemented for the Authorize.Net payment method. To enable and 

configure 3D Secure for Authorize.Net, do the following: 

1. Navigate to System > Configuration > SALES > Payment Methods. Configuring can be done on 
either the global or website level, so leave Default Config, or select the desired website in the 
Current Configuration Scope drop-down menu in the upper-left corner of the page. 

2. Under 3D Secure in the Authorize.Net field set, select Yes in the 3D Secure Card Validation 
field. Additional settings appear: 

 In the Severe 3D Secure Card Validation field, choose whether severe validation will be 

applied to credit cards by the Centinel system.  

 In the Centinel Custom API URL field, specify the URL, which will establish the connection 

with the Centinel system for credit card validation. The URL is provided by Centinel. 

3. Click Save Config in the upper-right corner of the page. 
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3D Secure for Authorize.Net: Customer Experience 

During the one-page checkout process, the customer selects the Authorize.Net payment method, 

specifies the card information, and clicks Continue. The Order Review checkout step opens and 

includes a form that is hosted by the bank that issued the card. The customer needs to enter the 

secret code, log in to the account, or confirm his or her identity in some other way, depending on 

the bank’s requirements. See Figure 189. 

 

Figure 189. 3D Secure Authentication Form for the Customer 

After submitting the form, the customer is redirected to the Order Review checkout step. The 

customer clicks PLACE ORDER, and proceeds to the order confirmation page if the authentication is 

successful. If the authentication fails on some reason, an error message is displayed in a dialog box 

and the customer may then select another payment method or try Authorize.Net again. 

3D Secure for Authorize.Net in Orders Created from the Admin 
Panel 

When during the admin order creation you select the Credit Card (Authorize.Net) payment method, 

the fields for entering the card information and the Start/Reset Validation button appear (see Figure 

190). 
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Figure 190. 3D Secure Authentication in the Admin Orders 

When you enter the card information and click the Start/Reset Validation button, a form appears 

that is hosted by the bank that issued the card. You need to enter the secret code, log in to the 

account, or confirm the identity in some other way. If the validation is successful, the corresponding 

message is displayed under 3D Secure Card Validation and you can proceed with creating the 

order. 
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23 Internal Payment Methods 
This chapter describes some of the internal payment methods that are available in Magento. 

To define internal payment methods: 

In the Admin Panel, select System > Configuration > Payment Methods to display the Payment 

Methods page, as shown in Figure 191. 

 

Figure 191. Internal Payment Methods (Circled) 

A few internal payment options are described in this chapter. Configuration of the other internal 

payment methods is similar. 

23.1 Saved Credit Cards 

This option enables you to take credit cards and to process them offline. This method is 

useful when you have a card terminal in a brick and mortar store or have access to a virtual 

terminal. This payment method is enabled by default in the Sample Data. 
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Tip: When using the Credit Cards payment method it is highly recommended to 
configure an SSL certificate for your web store. 

Important Note: Saving customer card data is discouraged unless absolutely necessary. 
Even though the data is encrypted it still poses a security risk to hold this 
information. The Saved Credit Cards payment method is not PCI compliant. 

To set up the Saved Credit Cards payment method: 

1. Select System > Configuration > Payment Methods to display the Payment Methods page. 

2. In the Current Configuration Scope drop-down menu, select the scope for these configuration 
selections. 

3. Expand the Saved CC section to define credit cards, as shown in Figure 192. 

 

Figure 192. Saved Credit Card Configuration Options 

4. Make your configuration selections. Most of these options are self-explanatory. The options that 
may need some explanation are as follows: 
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 Request Card Security Code: Determines whether the payment method interface on the 

frontend requires the customer to supply the security code on the back of the card. If your 

credit card terminal requires the security code, set this option to Yes. 

 3D Secure Card Validation: Determines whether credit card validation is carried out using 

the 3D Secure system. You must be a 3D Secure system subscriber, and you must first set up 

the general 3D Secure configuration options in  

System > Configuration > Payment Services. 

5. Click Save Config to save your changes. 

This option appears in the web store as shown in Figure 193. 

 

Figure 193. Saved Credit Card Payment Method (Frontend) 

Customers who place an order in your web store and use the Saved Credit Card payment method 

see their card details as shown in Figure 194. 

 

Figure 194. Credit Card Information (Frontend) 
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Tip: You can use the following test credit card number to test the payment methods in 
your web store: 
Visa 4111111111111111 
MasterCard 5555555555554444 
American Express 378282246310005 
Use any expiration date in the future, and for the CVV/CVC/verification code, use 
123 or 000. 

23.2 Checks and Money Orders 

This payment method enables you to accept paper checks and money orders as payment. The order 

remains in Pending status until the payment is received (or clears your bank, if you prefer). 

This payment method is enabled by default in the Sample Data. Expand the Check/Money Order 

section to define how checks and money orders are accepted in your web store, as shown in Figure 

195. 

 

Figure 195. Check/Money Order Configuration Options 

In the Make Check payable to field, specify the name of the entity to which the checks must be 

made out. 
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This option appears in the web store as shown in Figure 196. 

 

Figure 196. Check/Money Order Payment Method (Frontend) 

23.3 Purchase Orders 

Customers who are representatives of other companies can use the Magento Purchase Order 

payment method to buy products and assign a corresponding purchase order number generated in 

their accounting system to the sales order generated in Magento. 

For example, your web store customer represents the company that sells computers. They need to 

buy some monitors from your shop. In their accounting system, the customer creates a purchase 

order which is assigned a unique purchase order number. When the customer places an order in 

Magento, she or he can select the Purchase Order payment method and specify the purchase order 

number from their accounting system. All order-related documents, including the order 

confirmation email, invoice, shipment, and credit memo, will have the purchase order number on 

them. The company accounting department can now reference the purchase order number entered 

on the Magento sales order so that they know what the order was created for, whether it was 

authorized, and so on. 

When the customer receives your invoice, they process the payment in their Accounts Payable 

system. You will typically want to check the customer’s creditworthiness before allowing them to 

use the Purchase Order payment method in your store. See Figure 197. 
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Figure 197. Configuring the Purchase Order Payment Method 

To enable and use the Purchase Order payment method: 

1. In the admin panel, navigate to System > Configuration > SALES > Payment Methods and then 
expand the Purchase Order field set. 

2. Set the Enabled field to Yes to make this field available to your customers. 

3. In the Title field, specify the name of the payment method as it will appear in the Payment 
Information section in both the frontend and in the backend. 

4. The Payment from Applicable Countries parameter enables you to select which customers can 
use this payment method. All Allowed Countries means that all customers from the default 
countries list can use this payment method. If you have not already configured the default list, it 
can be done by navigating to System > Configuration > GENERAL > General > Countries 
Options and selecting each country you want to add from the Allow Countries list. If you want 
to further reduce the number of countries from which your customers will be allowed to use this 
payment method, select Specific Countries. This means that only customers whose billing 
address includes one of the countries listed in the Payment from Specific Countries list below 
can use this payment method. 

5. In the Minimum Order Total field, you can specify that the payment method will be available 
only if the shopping cart total amount is greater than the minimum order total amount specified 
in this field. 
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6. In the Maximum Order Total field, you can specify that the payment method will be available 
as long as the shopping cart total amount is less than the maximum order total amount specified 
in this field. 

7. If more than one payment method is enabled, use the Sort Order field to specify the order in 
which the Purchase Order payment method appears in the Payment Information section in both 
the frontend and in the backend. 

When the customer selects this payment method, the Purchase Order Number field becomes 

available where he or she must specify the number of the corresponding order from their accounting 

system and then place the order in Magento. The same thing happens when the store administrator 

creates an order in the Magento backend; after selecting the Purchase Order payment method in the 

Payment Method section, the Purchase Order Number field must be filled out. 

23.4 Zero Subtotal Checkout 

If a customer places an order and the subtotal is equal to zero, you can offer them this payment 

method, whereby they will not be required to enter any payment information. Unlike the other 

payment methods for which you can set order amount filters, this method contains an intrinsic order 

amount filter, so that the method will appear only if the subtotal is equal to zero. This payment 

method is only available when an order is created in the backend. See Figure 198. 

The Zero Subtotal Checkout payment method can be used in cases such as these: 

 The product that the customer adds to the shopping cart is of the Downloadable or the 

Virtual product type and its price equals zero. 

 The price of a simple product is zero and the Free Shipping method is available. 

 A coupon code which covers the full price of products and shipping is applied in the 

shopping cart.  

Note: The payment method will be available if taxes are configured so that they are 
applied to the products in the shopping cart after the discount is applied. 

 A gift card is applied to the shopping cart and it fully covers the order amount including 

shipping.  
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Note: During the checkout of an order covered by a gift card, the customer will still 
have to select the No Information Required payment method in the Payment 
Information section of the Checkout page. 

 

Figure 198. Configuring the Zero Subtotal Checkout Payment Method 

To configure the Zero Subtotal Checkout payment method: 

1. In the admin panel, navigate to System > Configuration > SALES > Payment Methods and then 
expand the Zero Subtotal Checkout field set. 

2. In the Title field, specify the name of the payment method as it will appear in the Payment 
Information section in both the frontend and in the backend. 

3. Set the Enabled field to Yes to make the payment method available to customers. 

4. In the New Order Status field, select the order status of all new orders created using this 
payment method. The recommended status is Pending, as this is intended to apply to orders 
which have not had any actions performed on them; however, you can change this to the 
Processing status. 

5. In the Automatically Invoice All Items field, choose whether all products in an order with a zero 
subtotal amount will be automatically invoiced by the system. However, the status of the order 
specified in the New Order Status field will not be taken into account as an order with the 
products of the Downloadable and Virtual product types with zero price do not require 
shipment, and as soon as the products in the order are invoiced, its status changes to Complete. 
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6. The Payment from Applicable Countries parameter enables you to select which customers can 
use this payment method. All Allowed Countries means that all customers from the default 
countries list can use this payment method. If you have not already configured the default list, it 
can be done by navigating to System > Configuration > GENERAL > General > Countries 
Options and selecting each country you want to add from the Allow Countries list. If you want 
to further reduce the number of countries from which your customers will be allowed to use this 
payment method, select Specific Countries. This means that only customers whose billing 
address includes one of the countries listed in the Payment from Specific Countries list below 
can use this payment method. 

7. If more than one payment method is enabled, use the Sort Order field to specify the order in 
which the Purchase Order payment method appears in the Payment Information section in both 
the frontend and in the backend. 

The totals area of a shopping cart that contains only products of the Virtual or the Downloadable 

product types with the zero price displays zero subtotals. Because the products of these types 

cannot be shipped, no shipping information will be specified and the Payment Information section 

of the Checkout page will contain the message that no payment information is required.  

23.5 Bank Transfer 

This payment method can be enabled if you provide customers with the ability to pay for an order 

amount with a wire transfer directly to your bank account. See Figure 199. 
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Figure 199. Configuring the Bank Transfer Payment Method 

To set up the Bank Transfer Payment method: 

1. Navigate to System > Configuration > SALES > Payment Methods. 

2. Locate and expand the Bank Transfer Payment field set. 

3. Set the Enabled parameter to Yes to enable this method. 

4. In the Title field, enter the name of the payment method to be displayed in the Payment 
Information section both in the frontend and in the backend. 

5. Set the New Order Status parameter to Pending. 
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6. The Payment from Applicable Countries parameter enables you to select which customers can 
use this payment method. All Allowed Countries means that all customers from the default 
countries list can use this payment method. If you have not already configured the default list, it 
can be done by navigating to System > Configuration > GENERAL > General > Countries 
Options and selecting each country you want to add from the Allow Countries list. If you want 
to further reduce the number of countries from which your customers will be allowed to use this 
payment method, select Specific Countries. This means that only customers whose billing 
address includes one of the countries listed in the Payment from Specific Countries list below 
can use this payment method. 

7. In the Instructions field, specify the bank account information you need to enable your 
customers to transfer money through this payment method. 

8. In the Minimum Order Total field, you can specify that the payment method is available only if 
the shopping cart total amount is greater than the minimum order total amount specified in this 
field. 

9. In the Maximum Order Total field, you can specify that the payment method is available as long 
as the shopping cart total amount is less than the maximum order total amount specified in this 
field. 

10. If more than one payment method is enabled, in the Sort Order field specify the order of the 
Bank Transfer payment method to appear in the Payment Information section both in the 
frontend and in the backend. 

11. Click Save Config. 

23.6 Cash on Delivery 

Cash on Delivery (COD) is a payment method which can be set up to enable the customers to pay 

their order amount with cash when the merchandise is delivered.  The customer pays the order 

amount to the shipping carrier, which sends a check to you. See Figure 200. 

Shipping carriers typically charge an extra fee for the COD service. You should account for this fee 

in your shipping and handling charges. 
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Figure 200. Configuring the Cash on Delivery Payment Method 

To set up the Cash on Delivery payment method: 

1. Navigate to System > Configuration > SALES > Payment Methods. 

2. Locate and expand the Cash On Delivery Payment field set. 

3. Enable the payment method by selecting Yes in the Enabled field. 

4. In the Title field, enter the name of the payment method to be displayed in the Payment 
Information section both in the frontend and in the backend. 

5. Set the New Order Status parameter to Pending. 
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6. The Payment from Applicable Countries parameter enables you to select which customers can 
use this payment method. All Allowed Countries means that all customers from the default 
countries list can use this payment method. If you have not already configured the default list, it 
can be done by navigating to System > Configuration > GENERAL > General > Countries 
Options and selecting each country you want to add from the Allow Countries list. If you want 
to further reduce the number of countries from which your customers will be allowed to use this 
payment method, select Specific Countries. This means that only customers whose billing 
address includes one of the countries listed in the Payment from Specific Countries list below 
can use this payment method. 

7. In the Instructions field, enter any specific instructions for customers to follow with regards to 
the cash on delivery payment. 

8. In the Minimum Order Total field, you can specify that the payment method is available only if 
the shopping cart total amount is greater than the minimum order total amount specified in this 
field. 

9. In the Maximum Order Total field, you can specify that the payment method is available as long 
as the shopping cart total amount is less than the maximum order total amount specified in this 
field. 

10. If more than one payment method is enabled, in the Sort Order field specify the order of the 
Cash on Delivery payment method to appear in the Payment Information section both in the 
frontend and in the backend. 

11. Click Save Config. 
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PART V: MARKETING 

24 Up-selling, Related Products, and Cross-
selling 

Three types of product promotion selling options are provided in Magento: Up-sell products, Related 

products, and Cross-sell products.  

 Up-sell Products: When a customer views a product, the Up-sells for this product are items 

that your customer could buy instead of the product that is being viewed. These products 

may be of a better quality, more expensive, or more popular, or produce a higher margin. 

These products appear on the Product Information page.  

 Related Products: Related products appear in the Product Information page in the right 

column. Related products are meant to be purchased in addition to the item the customer is 

viewing.  

 Cross-sell Products: Products that are promoted in the shopping cart page right before 

checkout. When a customer navigates to the shopping cart (whether automatically after 

adding a product or otherwise), these products are offered as suggestions in addition to the 

products already in the shopping cart. They are similar to impulse buys, like magazines and 

candy at the cash registers in grocery stores.  
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24.1 Up-sells 

The up-sell products appear in the Product Information page under the Product Description, as 

shown in Figure 201. This example presents a more expensive keyboard and other products as up-

sells to the less expensive keyboard. 

 

Figure 201. Up-sell Products 

To add Up-sells to a product: 

1. In the Admin Panel select Catalog > Manage Products to display a list of products, as shown in 
Figure 202.  
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Figure 202. Manage Products Page 

2. Click the Edit link which appears on the right side of the row of the product for which you want 
to define Up-sells. The page shown in Figure 203 is displayed: 

 

Figure 203.  Edit Product Page 

3. Select the Up-sells tab in the panel on the left. See Figure 204. 
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Figure 204. Products Selected as Up-sell Products 

Tip: By default the list shows only products that were already selected as up-sells. If 
there are none or you want to add other products, click the Reset Filter button to 
display a list of all the products. 

4. Use the check box in each row or the products that you want to appear as up-sells to this 
product.  

5. Click the Save button. 

24.2 Related Products 

Related Products are shown in the right column of your web store in a separate block. The example 

in Figure 205 shows a mouse product that was added as a Related Product for a keyboard purchase. 

 

Figure 205. Related Item 

To add Related Products to a product: 

1. In the Admin Panel, select Catalog > Manage Products to display a list of products. 

2. Click the Edit link that appears on the right side of the row of the product for which you want to 
define Related Products. 
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3. Select the Related Products tab in the panel on the left to display the Product Listing page.  

Tip: By default the list shows only products that were already selected as Related 
Products. If there are none or you want to add other products, click the Reset Filter 
button to display a list of all the products. 

4. Use the check box in each row of the products that you want to appear as Related Products to 
this product.  

5. Click the Save button. 

24.3 Cross-sells  

Cross-sell products are shown in a block below the shopping cart products, as shown in Figure 206. 

 

Figure 206. Cross-sell Item 

Cross-sell products are displayed after a product has already been added to the shopping cart. By 

default, three products are randomly selected by Magento from the products that have been defined 

as Cross-sell products of all the products in the shopping cart.  

To add Cross-sell products to a product: 

1. In the Admin Panel, select Catalog > Manage Products to display a list of products. 

2. Click the Edit link that appears on the right side of the row of the product for which you want to 
define Related Products. 

3. Select the Cross Sells tab in the panel on the left to display the Product Listing page.  

Tip: By default the list shows only products already selected as cross-sells. If there are 
none, or you want to add other products, click the Reset Filter button to display a 
list of all the products. 

4. Use the check box in each row of the products that you want to appear as Cross-sells for this 
product.  

5. Click the Save button. 
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25 Catalog and Shopping Cart Price Rules 
There are two types of price rules in Magento: Catalog Price Rules and Shopping Cart Price Rules. Catalog 

Price Rules are applied to products before they are added to the shopping cart. Shopping Cart Price Rules 

are applied to products in the shopping cart.  

25.1 Catalog Price Rules  

Catalog Price Rules are applied to products before they are added to a shopping cart. They can be 

used to create sales and discounts that do not require that a discount code be supplied by the 

customer. The process of defining a Catalog Price Rule consists of three stages: 

 Defining the Catalog Price Rule Information, page 274, defines general 

information about the rule. 

 Defining the Catalog Price Rule Conditions, page 276, defines the 

conditions that trigger the rule. 

 Defining the Catalog Price Rule Actions, page 278, defines the actions that 

are executed when the conditions of this rule are met. 

Defining the Catalog Price Rule Information 

To create a Catalog Price Rule:  

1. From the Admin Panel, select Promotions > Catalog Price Rules > Add New Rule button to 
display the page shown in Figure 207. 
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Figure 207. Adding a New Catalog Price Rule 

2. In the Rule Name and the Description fields, specify a unique name and a description for this 
Catalog Price Rule.  

3. In the Status field, select Active. 

4. In the Websites field, select the website to which this rule applies. 

5. In the Customer Groups field, select one or more customer groups to which this rule applies.  

6. In the From Date and To Date fields, set a date range for the rule to take effect. If you leave the 
date range empty, then the rule is enabled as soon as it is created.  
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Advanced Tip: You can use the Priority field (1 is the highest priority) when there are 
multiple rules. This determines which rule takes effect when more than one Catalog 
Price Rule applies. 

Defining the Catalog Price Rule Conditions 

After you have set up the general information for the price rule, you must create the conditions that 

specify when the rule is triggered.  

The following example shows how to discount every T-shirt that is over $20 by 10% by defining a 

rule that has two conditions.  

To define Catalog Price Rule Conditions: 

1. Select the Conditions option in the panel on the left to display the page shown in Figure 208. 

 

Figure 208. Specifying Rule Conditions 

2. The first rule appears by default: If ALL these Conditions are TRUE. It specifies whether the rules 
that you define must all be met or if any of them can be met (AND or OR) in order to trigger the 
rule’s action. In our example, we wanted the discount to take effect when the product is a T-
shirt and when the T-shirt costs over $20. Therefore, leave the word ALL in the page above. 

3. Click on the  icon to display a selection field and select the SKU option under Product 
Attributes from the drop-down menu. The page changes as shown in Figure 209. 

 

Figure 209. Adding a SKU Condition 

4. Click on the is link to display the comparison operator drop-down menu shown in Figure 210. 

 

Figure 210. Comparison Operator Drop-down Menu 

5. Select the is one of comparison operator. 
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6. Click on the three dots to the right of the words is one of to display the value field, as shown in 
Figure 211. 

 

Figure 211. Value Field 

7. Click on the Chooser icon  to display a list of products from which you can select, as shown 
in Figure 212. 

 

Figure 212. Item Selection 

The page above shows the list of products filtered to show only those that have the word Shirt in 

their name.  

8. Select the check boxes of the products (T-shirts in this example) to which this rule is to apply.  

9. Save this selection of products by clicking the Apply icon . 

10. Now this rule specifies that it applies to T-shirts. You must now add the Condition that the 

product must cost over $20 in order for the rule to apply. To do so, click on the  icon to 
display a selection field and select the Price option under Product Attributes from the drop-
down menu.  

11. Click on the is link and select equals or greater than from the comparison operator drop-down 
menu.  

12. Enter the value 20.00 in the value field on the right to create the second Condition, as shown in 
Figure 213. 
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Figure 213. Two Conditions Specified 

Defining the Catalog Price Rule Actions 

Now that the conditions have been defined that trigger this rule, we must define the actions to be 

taken when the conditions are met. The following defines that the price is discounted by 10%. 

To define Catalog Price Rule Actions: 

1. Select the Actions option in the panel on the left to display the page shown in Figure 214. 

 

Figure 214. Specifying Actions 

2. The Apply drop-down menu enables you to define whether the discount that is specified in the 
Discount amount field is a percentage or a fixed amount of the price of this product. It also 
enables you to define whether the discount amount is subtracted from the original price (By) or 
whether the Discount amount field actually defines the final price (To). For our example, in the 
Apply field, select By Percentage of the original price. 

3. In the Discount Amount field, specify the value 10.00. This specification defines a final price 
that is a 10% reduction of the original price.  

Note: Mistakenly selecting the To Percentage of the original price option would give a 
final price that is equal to 10% of the original price, meaning a 90% reduction. 

4. Select the Save Rule button to create the rule. 

5. You must also select either the Save and Apply or the Apply Rules button to immediately apply 
this discount to the selected products.  
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Note: As you add new rules, the system must recalculate the prices and the priorities of 
the rules. Generally, system rules are automatically processed and applied each 
night. In order to apply a new rule immediately, you must select one of the Apply 
buttons. 

25.2 Shopping Cart Price Rules 

Shopping Cart Price Rules, as the name implies, are applied when a customer reaches the shopping 

cart. They can be applied either with or without the customer entering a coupon code, and include 

features not found in traditional coupon tools. This example defines a simple 10% discount coupon 

to be used for clogs when the shopping cart subtotal is over $100.  

The process of defining a Cart Price Rule consists of three stages: 

 Defining the Cart Price Rule Information, page 279, defines general information about this 

rule. 

 Defining the Cart Price Rule Conditions, page 281, defines the conditions that trigger the 

rule. 

 Defining the Cart Price Rule Actions, page 281, defines the actions that are executed when 

the conditions of this rule are met. 

Defining the Cart Price Rule Information 

To create a Cart Price Rule:  

1. In the Admin Panel, select Promotions > Cart Price Rules > Add New Rule button to display the 
page shown in Figure 215. 
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Figure 215. Adding a New Shopping Cart Price Rule 

2. In the Rule Name field and the Description field, specify a unique name and a description for 
this Shopping Cart Price Rule.  

3. In the Status field, select Active. 

4. In the Website field, select the website to which this coupon applies. 

5. To specify that this rule only applies when a coupon code is used, select Specific Coupon in the 
Coupon drop-down menu, and specify the code of the coupon that the customer must specify 
in the web store. 

6. To specify that each customer can use this coupon only once, specify 1 in the Uses Per 
Customer field. 

Tip: If you want to create a limited offer, the coupon can be limited to be used a certain 
number of times by selecting Specific Coupon in the Coupon drop-down menu and 
specifying that number the Uses per coupon field. 

7. In the From Date and To Date fields, set a date range for the rule to take effect. If you leave the 
date range empty, then the rule is enabled as soon as it is created.  
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Advanced Tip: You can use the Priority field (1 is the highest priority) when there are 
multiple rules. It determines which rule takes effect first when more than one Cart 
Price Rule applies. 

8. By default, an announcement of this shopping cart price rule is included in your store’s RSS 
feed. To suppress this announcement, select No in the Public in RSS Feed drop-down menu. 

Defining the Cart Price Rule Conditions 

After you have set up the general information for the price rule, you create the Conditions that 

specify when the rule is triggered. The following example shows how to create a rule that has one 

condition, which checks when the shopping cart subtotal is over $100. 

To define Catalog Price Rule Conditions: 

Select the Conditions option in the panel on the left and define a rule with the single condition 

“Subtotal equals or greater than 100,” as shown in Figure 216. 

 

Figure 216. Shopping Cart Price Rule Condition 

Defining the Cart Price Rule Actions 

Now that the condition has been defined that triggers this rule, you must define the actions to be 

taken. The following defines that 10% is reduced from the product’s original price. 

To define Cart Price Rule Actions: 

1. Select the Actions option in the panel on the left to display the page shown in Figure 217. 

 

Figure 217. Specifying Shopping Cart Price Rule Actions 

2. The Action tab has two important sections. The first one controls the discount. In the Apply 
field, select Percent of product price discount.  
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3. In the Discount amount field, specify 10 to indicate that 10% is reduced from the product’s 
original price. 

Tip: Other options, not related to this example, are available, such as: Fixed amount 
discount, Fixed amount discount for whole shopping cart, and Buy X get Y free. 

4. In the Maximum Qty Discount is Applied to field, specify the maximum quantity of products to 
which this discount can be applied. If you enter 5 in this field, then the first five products of this 
type purchased in the same shopping cart get the 10% discount and the sixth product of the 
same type does not get the discount. 

5. In the Discount Qty Step (Buy X) field, specify how often the discount is applied. This field is 
not relevant to our example, so leave this field empty. If you enter 8 here, then a 10% discount 
is applied to all the products after the eighth product is added to the shopping cart. If more than 
eight items are added to the shopping cart, the ninth through 15th products do not get the 
discount until the 16th product is added to the shopping cart, at which point the discount is 
10% for all 16 products. This discount continues for every factor of eight. 

6. In the Free Shipping field, specify whether to combine the coupon amount with a free shipping 
offer, for only the products for which the coupon is valid or for the entire Order, when one of 
these products is in the shopping cart. This field is not relevant to our example, so leave the No 
value in this field.  

7. After defining the coupon as described above, select the products for which the coupon is valid. 
In our example, the coupon discount applies to clogs. Define a condition that applies to the 
SKU of clogs, as shown in Figure 218. 

 

Figure 218. Specifying Products to Apply the Discount To 

8. Click the Save Rule button.  

25.3 Example: Defining a Buy 2 Get 1 Free Promotion 

This section describes how to create another discount coupon with a Buy 2 get 1 free promotion. In 

this example, the web store is trying to push a digital camera as a family deal. This is a Shopping 

Cart Price rule. 
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To define a Buy 2 get 1 free promotion: 

1. Define the Coupon Information, as described in “Shopping Cart Price Rules,” page 279, but 
leave the Coupon drop-down menu selected to No Coupon. This selection specifies that the 
discount takes effect as soon as a customer adds the products to the shopping cart. See Figure 
219. 

 

Figure 219. Buy X get Y Free Promotion 

2. Do not define any conditions, because this rule is always applied to the Digital Camera. The 
deal is created for the Argus QC-2185 Quick Click 5MP Digital Camera available in the 
Magento Sample Data.  

3. Click the Actions tab in the left navigation bar. In the Apply field, select the Buy X get Y free 
option. 

4. In the Discount Amount field, specify 1. This is the number of units that are offered free. 

5. In the Discount Qty Step field, specify 2. This is the number of units that must be purchased in 
order to receive the free unit. 

6. In the bottom section, set up the condition to specify the SKU of the item that is featured in this 
promotion 

7. Click the Save Rule button.  

You can now send out your marketing message telling customers that if they buy 3 Argus QC-

2185 Quick Click 5MP Digital Cameras one of them will be free.  

Tip: It is good practice to test the effect of these rules yourself before trying them out on 
the public. Either use a discount code that only you know or assign your test 
customer to a testing customer group and limit the cart rules to only that customer 
group. 

25.4 Auto-Generating Coupon Codes 

For shopping cart price rules, you can auto-generate batches of coupon codes and track their usage. 
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Auto-Generating Coupon Codes Quick Reference 

Batches of discount coupon codes can be generated and managed on the Manage Coupon Codes 

tab of the Shopping Cart Price Rule page (Promotions > Shopping Cart Price Rules > %your rule%). 

To make the tab appear, in the Coupon field select Specific Coupon, select the Use Auto 

Generation check box, and click Save and Continue Edit. See Figure 220. 

 

Figure 220. Enabling the Auto-generation of Coupon Codes 

The default settings for the format of auto-generated coupon codes are configured under System > 

Configuration > Promotions > Auto Generated Specific Coupon Codes. 

 For detailed description of the auto-generation of coupon codes, see “Auto-Generating, Exporting, 

and Managing Coupon Codes,” page 285. 

Configuring Coupon Codes Auto-Generation Settings 

You can set the default requirements for the coupon code format under System > Configuration > 

Promotions > Auto Generated Specific Coupon Codes. The following settings are available for 

configuring: 

 Code Length: Defines a coupon code length excluding prefix, suffix and separators. 

 Code Format: Defines a coupon code format. The options are: Alphanumeric (a 

combination of letters and numbers), Alphabetical (letters only), Numeric (numbers only). 
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 Code Prefix: Defines a value that will be appended to the beginning of all the coupon 

codes. If you do not want to use a prefix, leave this field blank. 

 Code Suffix: Defines a value that will be appended to the end of all codes. If you do not 

want to use a suffix, leave this field blank. 

 Dash Every X Characters: Defines the interval at which a dash (-) will be inserted in all 

coupon codes. If you do not want to use a dash, leave this field blank. 

Note: Coupons whose codes differ only by dash character(s) are considered to be 
different coupons. 

These settings can be overridden each time you need to generate a batch of coupons on the 

Shopping Cart Price Rule page. 

Auto-Generating, Exporting, and Managing Coupon Codes 

To generate and export a batch of coupon codes:  

1. Log in to the Magento Admin Panel. 

2. Navigate to Promotions > Shopping Cart Price Rules. 

3. Select an existing rule or create a new one. 

4. In the Coupon field select Specific Coupon. 

5. Select the Use Auto Generation check box. Perform other rule configurations, if necessary. 

Important Note: Shopping cart price rules with auto-generated coupon codes cannot be 
used in automated email reminders. If the shopping cart price rule for which you 
set Specific Coupon in the Coupon field has been used in an automated email 
reminder rule, it will be automatically unassigned after saving the rule. 

6. Click Save and Continue Editing. The Manage Coupon Codes tab appears. See Figure 221. 

7. On the Manage Coupon Codes tab, specify the quantity of codes to be generated in the Coupon 
Qty field, correct the code format settings (if necessary) and click Generate. The generated 
coupon codes appear in the grid. For each coupon, you can see whether it has been used and 
how many times. To delete the coupon codes, select the check boxes in the first column, select 
Delete from the Actions drop-down menu, and click Submit. 

8. To export the codes, filter the list of codes so that only the desired codes are displayed, choose 
the file extension in the Export to field, click Export, and save the file.  
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Figure 221. Generating and Managing Coupon Codes 

Tracking the Usage of Coupon Codes 

Information about how often each coupon was used is displayed in the grid on the Manage Coupon 

Codes tab of the Shopping Cart Price Rule page. See Figure 221 above for illustration of the grid. 

You can also create detailed report about coupon usage in orders. 

To create a report about the usage of coupons generated for a specific shopping cart 
price rule: 

1. Navigate to Reports > Sales > Coupons. The Coupons Usage Report page opens. 

2. In the Show Report For field select the scope, configure report filters. In the Shopping Cart Price 
Rule field select Specified and select the desired rule(s). 

3. Click Show Report in the upper right corner of the page.  
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26 Special Prices and Product Group Price 
Special Prices and Product Group Prices give you additional flexibility in creating and managing price 

promotions. 

26.1 Special Prices 

Special prices enable you to define a discounted price for a product for a specified period of time.  

To define Special Price: 

1. In the Admin Panel, select Catalog > Manage Products to display the list of products. 

2. Click the Edit link on the right side of the relevant product’s row. 

3. Click the Prices tab in the left navigation panel. See Figure 222. 

 

Figure 222. Prices Options 

4. In the Special Price field, enter the special price.  

5. Optionally, set Special Price From / To Date. If you leave these fields blank, the special price is 
applied immediately and applies until removed on the same page. 

6. Click Save. 

The special price is shown on the frontend as shown in Figure 223. 
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Figure 223. Special Price – Frontend 

26.2 Product Group Price 

The Product Group Price feature enables you to set different product prices for different customer 

groups on the product level. The functionality is aimed at improving the admin user experience with 

setting promotional prices for customer groups.  

Terminology 
 Regular price: The value of the price system product attribute (which by default corresponds 

to the Price field on the Prices tab of the Product Information page available under 

Catalog > Manage Products > %desired product%). 

 Promotional price: A product price that is defined by any of the following system product 

attributes: special_price, group_price, or tier_price; or the resulting price after a catalog 

price rule is applied.  

Note: The group_price attribute is a system product attribute which was added for 
storing the group price value.  

Setting a Group Price for a Product 

To set a group price for a catalog product: 

1. Log in to the Magento Admin Panel. 

2. Navigate to Catalog > Manage Products > %desired product%. The Product Information page 
opens. 

3. On the Prices tab in the Group Price field click Add Group Price. 

4. Select the target customer group and specify the price for the selected group. The Website 
column defines the scope of the Group Price field. 
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Note: For bundle products, the group price is specified as a discount percentage. If 
bundle items have their own group prices set for the same customer group, then the 
discount specified for the whole bundle product is applied to these group prices. 

5. To save your changes, click Save or Save and Continue Edit.  

Group Price Implementation Details  

A group price can be specified for the following product types: 

 Simple 

 Configurable 

 Virtual 

 Bundle 

 Downloadable 

The list of product types for which a group price can be specified is defined in the settings of the 

group_price product attribute. The settings are available under Catalog > Attributes > Manage 

Attributes > group_price. The list of product types, for which the attribute is used, can be configured 

in the Apply To field. 

Note: For the Grouped and Gift Card product types, the Group Price functionality will 
not be applied even if these product types are selected in the Apply To field of the 
group_price attribute. In this case, for Grouped products, the Group Price field will 
not even be displayed on the Product Information page in the Admin Panel. For 
Gift Card products, the Group Price field will be displayed, but its value will not be 
considered by the system. 

Displaying the group price in the frontend fits the general logic of price displaying in Magento. If, 

besides the regular price, a product has promotional price(s), the lowest price value is displayed in 

the frontend. If a product custom option has price set as a percentage, than the lowest promotional 

price will be used as base for the calculation. The same logic is applied when the associated 

products (the options) of a configurable product have prices set as a percentage. 

The following table illustrates how the minimum promotional price logic is implemented. The table 

provides several examples, but it is not an exhaustive list of possible combinations.  

Backend Price Settings  Price Displayed in the Frontend 

Price = $4 

Special Price = $5 

Tier Price = $3 

For customers from the tier price group(s): 

$ 4  

As low as: $3 

For customers from other groups: 

$4 

Price = $5 

Special Price = $3 

Tier Price = $4 

For all customers: 

Regular Price: $5 

Special Price: $3 



Special Prices and Product Group Price 

290 

Backend Price Settings  Price Displayed in the Frontend 

Price = $5 

Special Price = $3 

Tier Price = $4 

Price after a catalog price rule applied = $2 

For customers from the catalog price rule group: 

Regular Price: $5 

Special Price: $2 

For customers from other groups: 

Regular Price: $5 

Special Price: $3 

 

Price = $5 

Special Price = $4 

Group Price = $3 

For customers from the price group: 

Regular Price: $5 

Special Price: $3  

For customers from other groups: 

Regular Price: $5 

Special Price: $4 

Important Note: When a group price is set for a product, then the catalog price rules for 
the corresponding customer groups are applied to the group price, not to the 
regular price. 
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27 Tier Pricing 
Tier Pricing is a promotional tool that enables a web store owner to price products differently when higher 

quantities are purchased. This is an effective way to move more merchandise and appeal to customers who 

buy more than one product at a time. When a customer adds a certain quantity of a product to their 

shopping cart, the price is automatically changed to reflect the discount. 

To define Tier Pricing: 

1. In the Admin Panel, select Catalog > Manage Products to display the list of products. 

2. Click the Edit link on the right side of the relevant product’s row. 

3. Click the Prices tab in the left navigation panel. See Figure 224. 

4. Add tiers by clicking the Add Tier button. You can create as many tiers as you need. 

 

Figure 224. Specifying Price Tiers 

5. Click Save. 

Tip: To apply a tier to multiple groups, but not all groups, create multiple tiers, each 
with the same Qty and Price information and select a different customer group in 
each. 

The prices on the frontend take precedence from the highest to the lowest quantity. Therefore, if you 

have a tier for the quantity 5 and one for the quantity 10 and a customer adds 5, 6, 7, 8 or 9 items to 

the shopping cart, then the customer gets the discounted price that you specified for the quantity 5 

tier. As soon as the customer adds the 10th item, the discounted price specified for the quantity 10 

tier supersedes the quantity 5 tier and that discounted price (of 10) applies instead.  
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After saving the product, it shows the Tier Pricing block on the frontend. See Figure 225. 

 

Figure 225. Tier Pricing Block- Frontend 

On the product listing pages, the best available deal is displayed below the regular price, as shown 

in Figure 226. 

 

Figure 226. “As Low As” Indication 
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28 Minimum Advertised Price (MAP) 
This chapter describes how a Minimum Advertised Price (MAP) policy can be applied in Magento. 

28.1 Minimum Advertised Price – General Concept 

If you have a minimum advertised price in the agreement with a manufacturer, you can still sell the 

merchandise at lower price, though this price will be hidden. It will not be visible to customers on 

the product page and will not be indexed by search engines. As a result, a price below the 

minimum advertised will not appear in any catalog of products collected from multiple web stores. 

The “crossed-out” price, which can be displayed on catalog and product pages, will be the 

manufacturer’s suggested retail price (MSRP). For storing the MSRP value, a new system attribute 

was added to the default attribute set. 

An individual setting enables you to specify how the actual price is shown to customers: on clicking 

the Check for price link on a catalog or product page, when a product is added to the shopping cart, 

or before the order confirmation. 

The MAP functionality can be applied to all product types except gift card products, and bundle 

products with dynamic pricing. 

The MAP functionality only influences the way products prices are displayed on the frontend.  

The following terminology is used in reference to this feature: 

 Actual Price: The price that is specified in the Price of Special Price field on the product 

view page. 

 Manufacturer’s Suggested Retail Price (MSRP): The retail price as suggested by the 

manufacturer. The Actual Price is typically lower than MSRP. 

28.2 Minimum Advertised Price – a Quick View 

MAP can be enabled and configured under System > Configuration > Sales > Minimum Advertised 

Price. See Figure 227. 
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Figure 227. MAP Global Settings 

After MAP is enabled, the configuration on the product level becomes available with the Apply 

MAP, Display Actual Price, and Manufacturer’s Suggested Retail Price fields. See Figure 228. 

 

Figure 228. MAP Settings on Product Level 

When MAP is applied globally, all prices on the frontend are hidden; the Click for price links appear 

instead. If you specify the Manufacturer’s Suggested Retail Price (MSRP), it will appear crossed-out. 

See Figure 229. 
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Figure 229. MAP Applied for the “Cuddle bear toy” and “Teddy bear toy” Products  

The way the actual price is displayed depends on the Display Actual Price setting. The following 

options are available: 

 On Gesture (default value): Clicking the Click for price link opens a pop-up window, 

containing the actual price and the information message. The actual price is shown on the 

last steps of the ordering process as well. See Figure 230. 

 

Figure 230. Display Actual Price Set to “On Gesture” 
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 In Cart: Clicking the Click for price link in a catalog redirects to the product page, where 

instead of the price or next to the crossed-out MSRP the following message is displayed: “To 

see product price, add this item to your cart. You can always remove it later.” The What’s 

this link is also included, which points to further explanations. The actual price of the 

product is displayed after it is added to the shopping cart. See Figure 231. 

 

Figure 231. Display Actual Price Set to “In Cart” 

 Before Order Confirmation: Clicking the Click for price link in a catalog redirects to the 

product page, where the following message is displayed instead of the price or next to the 

crossed-out MSRP: “See price before order confirmation.” The What’s this link points to 

further explanations. The actual price and totals are displayed on the Order Review step of 

the one-page checkout, or on the order review pages of the Google checkout or PayPal 

checkout. See Figure 232. 
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Figure 232. Display Actual Price Set to “In Cart” 

For products that allow configuration on the frontend, and whose prices depend on the variant 

selected (the variants themselves can actually be either custom options or simple products with their 

own SKUs and stock management), the following logic is implemented if MAP is applied: 

 MAP is applied to the main price; prices of the options, bundle items, and associated 

products (which add or subtract from the main price) are displayed normally. 

 If a product does not have a main price, and its price is derived from the associated 

products’ prices (such as in a grouped product), the MAP settings of the associated products 

are applied. Note that the MAP feature is not supported for bundled products with dynamic 

pricing. 

Regarding other price settings, the MAP application logic is the following: 

 If tier pricing is set, the tier price is displayed according to the Display Actual Price setting. 

 If a special price is set, it is considered to be the actual price for MAP. 

In the order management and customer management tools, as well as in the reports sections of the 

Admin Panel, only the actual price appears.  

28.3 Setting Up MAP 

MAP functionality can be configured at both the global and product levels.  

On the global level, you can enable/disable the functionality, apply it to all products, define how 

the actual price is displayed, and edit the text of the MAP related messages and information tips on 

the frontend.  

When MAP is enabled globally, product-level MAP settings become available. For a product you 

can choose to apply MAP, specify the MSRP, and define how the actual price is displayed.  
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Product-level MAP settings override the global ones. 

28.4 Setting up MAP on the Global Level 

By default the MAP functionality is disabled globally. 

To enable and configure MAP: 

1. In the Magento Admin Panel, select System, and click Configuration. 

2. In the Current Configuration Scope in the upper left corner of the page, select the desired 
website. 

3. In the left column under SALES, click Sales. 

4. On the Minimum Advertised Price field set configure the following settings: 

Option Description Scope 

Enable MAP Select Yes to enable the MAP. Website 

Apply MAP (Default 

Value) 

Applies MAP to all catalog products. 

If set to Yes, all prices in the catalog on the frontend are 

substituted with the Click for price links. On product 

pages, the prices are either substituted with the Click for 

price links or with the information about how to see 

prices, depending on the Display Actual Price setting.  

Website 

Display Actual Price Defines how the actual price is displayed on the frontend. 

Select from the following: 

 On Gesture - Clicking the Click for price link 

opens a pop-up window, containing the actual 

price. On all other stages of the ordering process 

(in the shopping cart, on the order review) the 

actual price is displayed normally. 

 In Cart - Clicking the Click for price link in a 

catalog redirects to the product page. On the 

product page, the price is replaced with the 

following message: “To see price, add this item 

to your cart. You can always remove it later". 

The What’s this link points to an information tip. 

The text of the information tip can be edited in 

the Default "What's This" Text Message field.  

The actual price is shown when customer adds 

the product to the shopping cart. It is also shown 

during the checkout as usual. 

 Before Order Confirmation - Clicking the Click 

for price link in a catalog redirects to the product 

page. On the product page the price is replaced 

with the following message: “See price before 

Website 
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Option Description Scope 

order confirmation." The What’s this link points 

to the information tip.  

The actual price is displayed on the Order 

Review step of the one page checkout or on the 

order review pages of the Google checkout or 

PayPal checkout. In the shopping cart, neither 

the prices nor the subtotals are displayed. 

When there is at least one item in the shopping 

cart with Display Actual Price set to Before 

Order Confirmation, the order total is not shown 

in the cart. Instead, the message “Order total will 

be displayed before you submit the order” is 

shown. 

The option selected defines how product prices are 

displayed in Wishlists and comparison lists as well 

Default Pop-up Text 

Message 

The text field for editing the information message 

displayed if the Display Actual Price field is set to On 

Gesture. 

Store 

view 

Default "What's This" 

Text Message 

The text field for editing the text of the What’s this 

information tip. 

Store 

view 

5. To save the configuration, click the Save Config button in the upper-right corner of the page. 

28.5 Setting Up MAP on the Product Level 

MAP settings on the product level become available once the MAP functionality is enabled.  

For gift cards and bundle products with dynamic pricing, the MAP settings are not available. 

To configure MAP settings on a product level: 

1. Select Catalog and click Manage Products. 

2. Open the product for editing. 

3. On the Prices tab, the following MAP settings are available: 

Option Description 

Apply MAP Defines whether MAP is applied to the product.  

Display Actual 

Price 

Defines how the actual price of the product is displayed on the frontend. 

The value here overrides the corresponding global setting.  

Manufacturer’s 

Suggested Retail 

Price 

The price at which a manufacturer "suggests" to sell the product. If 

specified, it appears crossed-out on the catalog and product pages on the 

frontend. 
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4. To save the settings click Save or Save and Continue. 

Note: If a product added to the shopping cart has MSRP specified, it will not be 
displayed crossed-out in the mini shopping cart or in the shopping cart side block. 

28.6 How MAP Is Applied for Different Product Types 

The following describes how MAP is applied for different product types. 

Product type MAP implementation 

Simple, Virtual The actual price is not shown on the catalog and product pages; it is 

displayed according to the Display Actual Price setting. The custom 

options prices are displayed normally. 

Grouped Prices of the associated simple products are not shown on the catalog 

and product pages; they are displayed according to their Display 

Actual Price setting. 

Configurable The actual price is not shown on the catalog and product pages; it is 

displayed according to the Display Actual Price setting. The prices of 

the options are displayed normally. 

Bundle with fixed 

price 

The actual price is not shown in the catalog; it is displayed according 

to the Display Actual Price setting. The prices of the bundle items are 

displayed normally. 

Downloadable The actual price is not shown on the catalog and product pages; it is 

displayed according to the Display Actual Price setting. The prices of 

the links are displayed normally. 

28.7 How MAP Is Applied for Different Price Settings 

The following describes how MAP is applied for different price settings. 

Price setting MAP implementation 

Tier Price If tier pricing is set, the tier pricing message is not displayed in the 

catalog. On the product page a notification is displayed that indicates 

that the price can be lower when ordering more than a certain 

quantity, but the discount is displayed in percentages only. For 

associated products of a grouped product, the discounts are not 

displayed on the product page. 

The tier price is shown according to the Display Actual Price setting. 

Special Price If the Special price is specified, the special price is displayed according 

to the Display Actual Price setting. 
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29 Newsletters  
Magento provides a Newsletter feature, which enables store administrators to send newsletters to customers 

who have registered to receive them. 

The first step in creating newsletters is to configure the newsletter settings for your site.  

To configure newsletter settings on your site: 

1. In the Admin Panel, select System > Configuration to display the configuration page. 

2. In the CUSTOMERS area in the left navigation panel, select the Newsletter option and expand 
the Subscription Options area to display the page shown in Figure 233. 

 

Figure 233. Newsletter Subscription Options 

3. In the Need to Confirm field, select Yes to specify that each customer that registers for a 
newsletter will receive an email asking them to confirm their registration. This technique is 
called double opt-in, meaning that customers confirm that they want to receive a newsletter 
twice. This method reduces the number of customers that consider your newsletter as spam.  

29.1 Newsletter Templates 

Before sending a newsletter, create a newsletter template. You can create and save as many of these 

as required for any situation, whether it be an annual holiday newsletter or weekly product updates.  

To create a new newsletter template: 

1. In the Admin Panel, select Newsletter > Newsletter Templates to display a page listing the 
previously defined newsletter templates. You can edit an existing template or create a new one. 

2. To add a new template, click the Add New Template button to display the New Newsletter 
Template page, as shown in Figure 234. 
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Figure 234. New Newsletter Template Page 

3. In the Template Name field, specify a unique and indicative name for this template. This value 
is not visible for customers.  

4. In the Template Subject field, specify the subject of the email to be sent to your customers. 

5. In the Sender Name and Sender Email fields, specify the name and email of the sender of the 
email to be sent to your customers. 

6. In the Template Content field, use the WYSIWIG editor to compose the body of the email. Note 
that this field is pre-filled with tags showing an unsubscribe link in the email. We recommend 
that you do not remove this link so that all emails that are sent enable your customers to 
unsubscribe from the newsletter. 

7. Click Preview Template, to display the content with the formatting as it will be viewed by your 
subscribers. 

8. After you have finished editing the template, click the Save Template button to save it. 
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Tip: After you have saved a template, a Save As button appears when you edit this 
template. The Save As button enables you to duplicate the template, so that you 
can make changes and save the template as a new template without affecting the 
original template. This can save you time because you will not need to re-enter all 
the template information in order to create a new template. If you already have an 
existing template that is similar to the new template, simply edit the fields that you 
require, and then use the Save As button to create a new template. 

29.2 Newsletter Queues 

A newsletter that has many recipients must be sent in stages. The process of sending the newsletter 

is managed by a queue. After you start this queue, Magento sends the emails in packs. 

To send your newsletter using a queue: 

1. In the Admin Panel, select Newsletter > Newsletter Templates to display a list of newsletter 
templates. 

2. In the Action drop-down menu for the relevant template, select the Queue Newsletter option. 

3. In the Queue Date Start field, specify when the newsletter will start being sent. 

4. In the Subscribers From field, select one or more store views whose customers this newsletter 
will be sent to. 

5. Review the template and parameters and then click the Save Newsletter button to schedule 
sending the newsletter. 

Tip: To ensure delivery of your newsletters, it is recommended that you integrate your 
Magento installation with a third-party newsletter provider. These services are 
“whitelisted” by email service providers. Look for newsletter providers in the 
Magento Connect website. 

29.3 Newsletter Reports 

Three newsletter reports are provided in the Newsletter menu:  

 Newsletter Queue: Shows the newsletter queues that have been defined and indicates their 

progress in sending emails. 

 Newsletter Subscribers: Shows a list of customers that have subscribed to your newsletter. It 

also enables you to unsubscribe these customers manually. 

 Newsletter Problem Reports: Shows a list of errors that have occurred while sending the 

email. This Report enables you to remove the incorrect emails from the subscribers list. 
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30 Facebook Open Graph Extension 2.0 for 
Magento 
The Facebook Open Graph 2.0 extension enables you to add custom social networking buttons to 

your store. The extension uses the new Facebook Open Graph 2.0 protocol.  

30.1 Compatibility 

The Facebook Open Graph 2.0 extension is compatible with Magento Enterprise Edition and 

Professional Edition 1.8 and later, and Magento Community Edition 1.3 and later. 

30.2 Downloading and Installing 

The Facebook Open Graph 2.0 extension is free of charge; you can download it from Magento 

Connect, the official marketplace for Magento extensions. 

30.3 Installing 

You can install the extension using the Magento Connect Manager. To access it in the Magento 

Admin Panel navigate to System > Magento Connect > Magento Connect Manager.  

30.4 Setting Up 

To make new social networking buttons appear in your store, after installing the extension you need 

to take two basic steps: 

1. Create an application on the Facebook Developers site  

2. Configure Magento 

In the following subsections these procedures are described in detail. 

Creating an Application on the Facebook Developers Site 

The current implementation of the Facebook Open Graph 2.0 extension requires an application to 

be created manually on the Facebook Developers site. 

To create an application: 

1. Navigate to https://developers.facebook.com/ 

2. Click Apps in the top menu. 

http://www.magentocommerce.com/magento-connect
http://www.magentocommerce.com/magento-connect
https://developers.facebook.com/
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3. Click Create New Application and perform all of the steps of the app creation wizard. Using the 
app by the Facebook Open Graph 2.0 extension implies  the following restrictions and 
requirements: 

 Please note that the App Namespace value, which you set on the first step of the app 

creation, will be used in Magento configuration.  

In the left column select Settings > Basic. Under the Select how your app integrates with 

Facebook heading select Website. In the Site URL field enter your store address. See Figure 

235. 

Important Note: Your website and store should have one domain name. 

 

Figure 235. Website Settings on Facebook Developers 

 For Action Types in the Advanced settings in the Graph API URL field enter own, want or 

other action you want to be associated with a social networking button on your product 

pages. This title is for internal use. See Figure 236. 
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Figure 236. Object Type Settings in the Facebook Developers Application 

Note: You cannot set the “dislike” action as it is not supported by Facebook Open 
Graph 2.0. 

 The Object Type you create should have the following Object Properties: 

o URL (page URL) 

o Title (product title) 

o Image (image URL) 

o Description (product description) 

o Price 

By default, a new Object Type has only the first four properties. To add the Price property, use the 

Add Another Property button on the Object Type page. See Figure 237. 
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Figure 237. Adding Properties to an Object Type 

Configuring Magento 

To configure the Facebook Open Graph 2.0 extension settings in Magento Admin Panel: 

1. Navigate to System > Configuration > SOCIAL > Facebook. If you don’t see the SOCIAL 
heading in the left column, you may have not installed the extension. 

2. In the Current Configuration Scope drop-down menu in the upper left corner of the page select 
your website. 

3. Under Facebook Config set the following: 

 Enable Facebook on Frontend: Select Yes if you want social buttons to appear on the 

frontend. 

 App Namespace: Enter the App Namespace value of your application. You can find it in the 

Basic Settings section of your app on the Facebook Developers site. See Figure 238. 

 

Figure 238. App Namespace Value 

 App ID and App Secret: Specify the App ID and App Secret values of your application. You 

can find it in the Basic Settings section of your app on the Facebook Developers site. See 

Figure 239.  
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Figure 239. App ID and AP Secret Values 

 Object Type – Enter the Open Graph Type value of your Object Type. To find it on the 

Facebook Developers site, open the settings of your application, navigate to Open Graph > 

Dashboard, click your object type, and expand the Advanced settings. On the page header 

the system will display the Apps > %Your Facebook Application Name% > Open Graph > 

Object Type: %Object name%. See Figure 240. 

 

Figure 240. Open Graph Type Setting 

 Actions Settings (can be different for each store view: To add and configure a social 

networking button, click Add Action Button. For each button, specify the following: 

o In the Action column, specify the internal button action title, for example, own or 

want. This value should correspond to the value you have specified in the Graph 

API URL field on the Facebook Developers site. The Graph API URL field is 

available in the Advanced section of the Action Type settings. See Figure 236. 
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o In the Button Title column, specify the name of the social networking button as you 

want it to appear in the frontend. 

o In the Enable FriendBox column decide if you want to display in the frontend the 

related Facebook block, which contains the count and the pictures of friends.  

o In the Count in FriendBox column, set the maximum number of friends that can be 

displayed in the related Facebook block. By default, it is set to 3. If you set zero 

value (0) or leave the field empty, then the default value is applied. 

4. To save the configuration, click Save Config in the upper right corner of the page. 

Now the social networking buttons you have created and the corresponding Facebook blocks will 

appear on the product pages of your web store. In the following section of this guide you can find 

the detailed description and illustrations of how these buttons look and work. 

30.5 Facebook Open Graph 2.0 Extension: Customer 
Experience 

When the Facebook Open Graph 2.0 extension is successfully installed and all configuration is 

done, the social networking buttons will be displayed on each product page in the frontend, along 

with the Facebook blocks providing the information about other Facebook users and friends who 

clicked your social networking buttons for the product (if set to be displayed). Information provided 

in the blocks depends on the customer who is logged in to Facebook and whether his or her friends 

have performed some actions with your app (that is clicked your social buttons). The following 

situations are possible (in this example, the Want and I own this social networking buttons were 

added): 
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1. Customer is not logged in to Facebook. See Figure 241. 

 

Figure 241. Product Page: Customer Not Logged In to Facebook 
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2. Customer is logged in to Facebook, but none of the customer’s friends wants or owns the 
product. See Figure 242. 

 

Figure 242. Product Page: Customer Logged In to Facebook; No Friends Want or Own 

the Product 
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3. Customer is logged in to Facebook, but he or she has not performed any action with the app 
yet. See Figure 243. 

 

Figure 243. Product Page: Customer Logged In to Facebook; Has Not Performed 

Action with the App 
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4. Customer is logged to Facebook, and his or her friends have already performed some action 
with the app. See Figure 244. 

 

Figure 244. Product Page: Customer Logged In to Facebook; Friends Have Already 

Performed Action with the App 
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PART VI: STORE MANAGEMENT 

31 Managing Orders and Customers 
This chapter describes how to manage customer records and how to add orders from the backend. 

31.1 Managing Customers 

Viewing and Editing Customers 

To view existing customers:  

1. In the Admin Panel, select Customers > Manage Customers to display the Manage Customers 
page, as shown in Figure 245. The Manage Customers page contains a list of all the customers 
that opened accounts in your web store or were added using the Add New Customer feature.  

 

Figure 245. Manage Customers Page 

2. Click the Edit link on the right side of a customer’s row to display the customer information 
page, as shown in Figure 246. 

 

Figure 246. Customer Information Page 

The tabs in the left panel provide a variety of types of information about the customer and for 

handling the relationship with a customer, such as: when the customer last logged in and out, 

addresses, ordering statistics, recent orders, current shopping cart contents, their last reviews, the 

newsletter to which they subscribed and so on. 
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Adding a Customer 

Customers typically register themselves in your web store using the My Account link in the header 

of each page. In addition, you can use the following procedure to add a customer using the 

backend. 

To add a new customer: 

1. In the Admin Panel, select Customers > Manage Customers. 

2. Click the Add New Customer button to display the New Customer page, as shown in Figure 
247. 

 

Figure 247. New Customer Page 

This page enables you to define basic identifying information about the customer and his/her 

various addresses. Many aspects of the information retained about a customer in Magento can 

be accessed by editing the customer’s information, as described in “Viewing and Editing 

Customers,” page 314.  

3. The fields on this page are self-explanatory. Specify the customer’s information and then click 
the Save Customer button.  

Managing Customer Groups 

The customer group to which the customer belongs determines which discounts are given to this 

customer, as defined in the Catalog Price Rules and Shopping Cart Price Rules (described in 

“Catalog and Shopping Cart Price Rules,” page 274), and the tax rule that is applied to that 

customer. 
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To create and edit customer groups: 

1. In the Admin Panel, select Customers > Customer Groups to open the Customer Groups page, 
as shown in Figure 248. 

 

Figure 248. Customer Groups Page 

2. Do one of the following: 

 To create a new customer group, click Add New Customer Group. 

 To edit an existing customer group, click the row for the desired group. 

The customer group editing page opens, as shown in Figure 249. 

 

Figure 249. New Customer Group Page 

3. Specify a unique name for this customer group (or modify the existing name). 

4. Select a tax class to associate with this group. 

5. Click Save Customer Group. 

Checking Online Customers 

You can check which customers are currently online and view their activity. 

To view online customers: 

In the Admin Panel, select Customers > Online Customers to display the Online Customers page, as 

shown in Figure 250. 

 

Figure 250. Online Customers Page 
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Customer Reports 

A variety of customer reports can be generated by selecting Reports > Customers in the Admin 

Panel. 

The following describes the available customer reports: 

 New Accounts: Shows the customers that have opened accounts in your web store during 

the period that you specify. 

 Customer by orders total: Lists customers in descending order of money spent in your web 

store. 

 Customer by number of orders: Lists customers in descending order of number of orders 

placed in your web store. 

Importing and Exporting Customer Information 

For information about importing and exporting customer information, see “Importing and Exporting 

Product and Customer Data,” page 124. 

31.2 Managing Orders 

The section “Managing Orders, page 31, introduces the procedures for handling the day-to-day 

order management tasks in your web store. This section assumes that you are familiar with that 

information. 

See “Viewing the Orders in Your Web Store,” page 32, for a description of how to view and edit the 

Orders in your web store. This section goes into more details about the order life cycle in Magento. 

Orders Terminology 

This section describes some of the terms used for handling orders in Magento. In addition to 

creating orders, there are many features in the Magento backend that are part of the process of 

managing and fulfilling orders, such as creating invoices, shipments, and credit memos, and editing 

and cancelling orders.  

Sales Order 

When an order is created in a Magento web store, either in the frontend or in the backend, a sales 

order record is created to record this transaction. This sales order can be seen in the orders list by 

selecting the Orders option from the Sales menu in the backend.  

This is only a temporary record. Payment has not yet been processed and the order can still be 

canceled.  

Invoice 

An invoice is a record of the receipt of payment for an order.  
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Note: In some cases, payment is automatically received during the creation of an 
Invoice. 

Creating an invoice converts the temporary sales order into a permanent record of an Order, which 

can no longer be canceled. 

Multiple invoices can be created for a single order, each containing as much or as few of the 

purchased products that you specify.  

Shipment 

A shipment is a record of the products in an order that have been shipped. As with invoices, 

multiple shipments can be associated with a single order, until all of the products in the order are 

shipped.  

Credit Memo 

A credit memo is a record of a refund. A product cannot be refunded until it has been paid (which 

means that it has been invoiced). This means that you are not able to create a credit memo before 

an invoice has been created.  

The credit memo serves as a record of a refund, but it is not a record of the actual return of funds to 

the customer.  

Creating New Orders 

This section describes how to create an order using the backend, such as when an order is received 

on the phone. 

To create a new order from the backend: 

1. In the Admin Panel, select Sales > Orders. 

2. Click the Create New Order button on the top right of the page to display the Create New Order 
page, as shown in Figure 251. 

 

Figure 251. Create New Order Page 

3. Select a customer If you have multiple websites, stores, or store views, select the one to which 
this order applies. The Create New Order for <customer> page opens, as shown in Figure 252. 
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Figure 252. Create New Order for <customer> Page 

Note: If the customer does not already exist in your customer records, click Create New 
Customer on the first Create New Order page. You will need to complete all the 
address information. 

4. Click the Add Products button to display the list of products, as shown in Figure 253. 
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Figure 253. Product List for Creating Orders 

5. Use the check boxes to select the products to be purchased, and click the Add Selected 
Product(s) to Order button. 

Tip: If you selected one of the existing customers, then the left column shows a list of 
the products that this customer has in his/her cart, wish list, recently ordered, 
viewed, or compared. To add one those products to the order, select the required 
product and click Update Changes button. 

6. Complete the other mandatory fields of the order. Mandatory fields are marked by an asterisk 
(*). 

7. You can define many options for the order, such as choosing custom prices for products and 
applying discount codes. 

8. After you have completed all the required order information, click the Submit Order button to 
display the order information page. 

9. To confirm payment, click the Invoice button to generate an invoice for your review.  

10. Review the invoice, and if all is well, click the Submit Invoice button at the bottom of the page. 

11. When you are ready to ship the products, click the Ship button to generate a Shipment 
document. 

12. If applicable, you can add a tracking number received from the shipping service by clicking the 
Add Tracking Number button. Adding a tracking number enables customers to view the status 
of their shipment using the shipping carrier’s website. 

13. Review the shipment. You can modify the quantity to be shipped if only part of the order is 
ready.  

The order status changes to Completed after all its products have been shipped.  

14. Click the Email Copy of Shipment option to automatically send an email to notify the customer 
that the products were shipped. 
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15. Click the Submit Shipment button at the bottom of the page.  

16. Click the Back button to return to the orders page, where you can create additional Orders if 
needed. 

Clearing the Shopping Cart 

If, at any time during the ordering process, the customer decides not to move forward with the 

order, you can clear the customer’s shopping cart in either of two ways: 

 Click the Clear Shopping Cart button on the Create New Order page (see Figure 254). 

 

Figure 254. Clearing the Shopping Cart on the Create New Order Page 

 Click the Clear Shopping Cart button on the Shopping Cart page (Customers > Manage 

Customers > %customer% >Manage Shopping Cart); see Figure 255. 

 

Figure 255. Clearing the Shopping Cart on the Shopping Cart Page 

Refunding 

You can create a record of a product refund from an existing order by generating a credit memo.  
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To view the list of refunds made in your web store: 

From the Sales menu, select the Credit Memos option to display the Credit Memos page, as shown 

in Figure 256. 

 

Figure 256. Credit Memos Page 

To refund a product from an existing order: 

Note: You can create credit memos only for orders for which invoices were created. 
Without an invoice, an order is assumed not to be paid so that there is nothing to 
refund. 

1. In the Admin Panel, select Sales > Orders to display a list of the existing orders. 

2. Click the View link on the right side of the row of the desired order to display the order view 
page.  

3. Click the Credit Memo button to generate a credit memo.  

4. Scroll down to the Items to Refund area, and in the Qty to Refund field of each relevant 
product, specify the quantity of products to refund. 

5. To specify that this product was actually returned to the web store, select the Return to Stock 
check box, as shown in Figure 257. 

 

Figure 257. Items to Refund 

6. (Optional) Select the Email Copy of Credit Memo check box, as shown in Figure 258, to 
automatically send an email to the customer that the order has been refunded. You can also 
adjust the refund totals to match your business rules. 
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Figure 258. Refund Totals 

7. Click the Refund button at the bottom of the page. The total of the order from which this 
product was refunded is updated automatically.  

8. Click the Back button to return to the orders page where you can create additional orders, if 
required. 

Note: Refunding an order in Magento does not cause an actual payment refund. You 
must refund the payment on your own. The credit memo is only a record used to 
track the refunds and to provide proper values in the reports. 
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32 Managing Customer-Generated Content 
This chapter describes how to manage customer generated content, such as ratings, reviews, tags, and polls. 

32.1 Managing Ratings and Reviews 

Rating and review functionality is provided by Magento to enable customers and web store owners 

to give their opinions, feedback, and comments about products. Ratings and reviews appear in the 

frontend, as shown in Figure 259. 

 

Figure 259. Ratings and Reviews Links on the Frontend 

The quantity of stars indicates the satisfaction rating. You can click on the Review(s) link to display 

the actual reviews provided by customers or input your own Review, as shown in Figure 260.  

 

Figure 260. Customer Reviews Frontend Interface 

To add a review, the customer clicks on the Add Your Review link on the product information page 

to open the Write Your Own Review page, as shown in Figure 261. 
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Figure 261. Write Your Own Review Page (Frontend) 

Adding a Custom Rating 

By default, the customer can rate the quality, price, and value of a product. You might want to add 

custom ratings, to enable customers to rate such aspects as durability, warranty, and so on. This 

section describes how to create a new customized rating.  

1. In the Admin Panel, select Catalog > Reviews & Ratings > Manage Ratings to display the 
Manage Ratings page, as shown in Figure 262. 

 

Figure 262. Manage Ratings Page 

2. Click the Add New Rating button to display the New Rating page, as shown in Figure 263. 
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Figure 263. New Rating Page 

3. In the Default Value field enter a name for this rating.  

4. Click the Save Rating button. 

Approving Reviews for Public Viewing 

New reviews that are submitted by customers must be approved by the web store administrator in 

the backend before they appear on the frontend.  

To view and approve new reviews:  

1. In the Admin Panel, select Catalog > Reviews & Ratings > Customer Reviews > Pending 
Reviews to display the Pending Reviews page, as shown in Figure 264. 

 

Figure 264. Pending Reviews Page 

2. Click the Edit link on the right side of the relevant review’s row to display the Review Details 
page, as shown in Figure 265. 
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Figure 265. Review Details Page 

3. You can modify the review, if required. 

4. In the Status field, change the Pending status to Approved or Not Approved.  

32.2 Managing Tags 

Tags can be assigned by customers directly in the frontend. A tag describes a specific property of a 

product, such as Cool, Valentine’s gift and so on. Popular Tags serve as a descriptor that customers 

can select in order to view the products to which a specific tag has been assigned. Figure 266 shows 

an example of various tags as they appear in the web store.  

 

Figure 266. Tags Display in the Frontend 
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Adding Tags 

The number of tags that can be added to a product is unlimited and they can later be renamed or 

deleted. To add one or more tags to a product, the customer scrolls down on the product page to 

the Product Tags section, as shown in Figure 267. 

 

Figure 267. Adding Product Tags (Frontend) 

Tags must be separated by spaces, and phrases (two or more words that comprise a single tag) must 

be enclosed in single quotation marks (‘).Figure 267 shows what it looks like when a customer adds 

three tags: 

 rock and roll 

 t-shirt  

 red 

After a customer submits product tags, an administrator has to approve them on the backend so that 

they will appear on the frontend. 

Approving Tags 

Tags must first be approved by the backend administrator before they appear on the front-end. After 

a tag has been approved by the backend administrator, it can be used for other products and does 

not need to be approved again. 

To approve a tag: 

1. In the Admin Panel, select Catalog > Tags > Pending Tags to display the Pending Tags page, as 
shown in Figure 268. 

 

Figure 268. Pending Tags Page 
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This page shows a list of tags that have not yet been approved.  

2. Use the check boxes in the left column to select all of the tags that you want to approve (or all 
of the tags that you want to disable). 

3. In the Action drop-down menu, select Change Status. The Status drop-down menu becomes 
visible. 

4. In the Status drop-down menu, select Approve (or Disable). 

Note: To modify a tag or view details about a tag, such as the product or products it 
was applied to, or the name of the customer who submitted it, click the row for that 
tag. 

Note: If a customer has entered a tag that you do not want to ever see again, simply 
change the status to Disabled. 

32.3 Managing Polls 

Polls provide a powerful marketing tool for finding out the opinion of your customers about your 

products, store, customer service, or anything else.  

It is very simple to create a poll. Figure 269 shows an example of how a poll appears in the 

frontend. 

 

Figure 269. Poll on the Frontend 

A poll occupies only a small amount of space on your store pages and is shown in the right column 

by default. Poll results are immediately displayed to the customer after the customer submits an 

answer, as shown in Figure 270. 

 

Figure 270. Poll Results 
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To create a poll: 

1. In the Admin Panel, select CMS > Polls to open the Poll Manager page, which shows a list of 
existing polls. 

2. Click the Add New Poll button in the top right corner of the page to display the New Poll page, 
as shown in Figure 271. 

 

Figure 271. New Poll Page 

3. In the Poll Question field, enter the question that your customer will be asked. 

4. In the Status field, specify whether the poll is Open or Closed. The status of the poll is Open by 
default, which means that it appears in your store. If you do not want it to appear in your store, 
select the Closed option. 

5. Select one or more stores that you want the poll to appear in. 

6. Click the Poll Answers option in the left panel to display Assigned Answers page. 

7. Click the Add New Answer button to add possible answers to your question that can be 
selected by customers, as shown in Figure 272. 

 

Figure 272. Assigned Answers Page 

8. In the Answer Title field, specify the text of the answer to appear in your store for customers to 
select.  
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9. To influence the poll results in advance, you can add votes to the count in the Votes Count 
field, which is 0 by default. 

10. Repeat steps 7 through 9 for each answer that you want to appear in this poll. 

11. Click the Save Poll button. 

Customers can answer a poll only once and you can view the results in the backend by clicking on 

the row for the poll in the Poll Manager page. If you have multiple polls open, they will cycle 

randomly in the frontend, meaning customer may see a different poll every time they refresh a 

frontend page. 

Editing a Poll 

After a poll has been created, you can edit it by clicking on the roll for the poll in the Poll Manager 

page (CMS > Polls).selecting the Poll Manager option from the CMS menu.  

To close the poll so that it no longer appears in the store, change the Status field to Closed in the 

Poll information section.  

To see the votes that have been tallied for each answer, click the Poll Answers option in the left 

panel to display the number of votes in the Votes Count field, as shown in Figure 273. 

 

Figure 273. Poll Results (Backend) 
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33 Inventory Control: Quantity Increments and 
“Only X Left” 

All editions of Magento have robust inventory control capabilities that enable you to set and manage 

inventory levels and thresholds and auto-decrement inventory as it’s sold from the website. In addition, 

Magento Enterprise Edition has additional capabilities that provide you with even more control. 

One of the advanced inventory control features is the ability to set the allowed quantity increments when 

customers add an item to their carts. This is especially relevant for B2C sites that sell items in multi-packs or 

B2B sites that sell in cases or cartons.  

Another advanced inventory feature is the ability to display a message on the frontend when an item is 

nearly out of stock with an “Only 5 left” type message. This helps add urgency and improve conversion, 

which can be especially helpful for moving those last few items in your inventory. 

In addition Magento Enterprise Edition provides support for setting order minimums on a customer-group 

basis, but this can only be set globally for that customer group at this time. 

These features were introduced in Version 1.8 of Magento Enterprise  

33.1 Enabling and Configuring Advanced Inventory 
Control Options 

To enable and configure additional inventory control options: 

In order to take advantage of these new inventory control features, you first need to enable them in 

the Admin Panel. In addition, you have the option of setting some of the default values for your 

entire store, if that makes sense for your merchandise.  If not, you can set specific thresholds and 

increments on a product-by-product basis. 

1. Choose System > Configuration. Select the Inventory tab on the left. 

2. To enable the “Only X left” feature for a website, in the Stock Options panel set the Only X left 
Threshold value to your desired threshold. If the value is 0, the feature will not be enabled. This 
value can be set differently for each Magento website in your installation but it cannot be set on 
a per-product basis. Whatever you set here will apply to the entire website you have selected in 
the Configuration Scope selector. 

3. To globally enable the Quantity Increments feature, in the Product Stock Options panel set 
Enable Qty Increments to Yes. Enter the desired default increment in the Qty Increments field 
that appears when you change this field to Yes. You can override these values for each product, 
if desired. 

4. To globally enable the minimum purchase quantities for specific customer groups, in the 
Product Stock Options panel click the [+Add Minimum Qty] button. Select the customer group 
from the drop-down menu and enter the quantity minimum desired. This is a global setting and 
cannot be overridden on a per-product basis. 

5. Click the [✔Save Config] button to save your settings. 
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To set quantity increments on a per-product basis: 

1. Choose Catalog > Manage Products.  

2. Select a product to edit and then select the Inventory tab on the left. 

3. In the Inventory panel, enable the Quantity Increments feature for this product by setting Enable 
Qty Increments to Yes. Enter the desired increment in the Qty Increments field that appears 
when you change this field to Yes. 

4. Click the [✔Save] button to save your settings. 
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34 Monitoring and Improving the Web Store 
This chapter describes how to monitor and improve your web store by using reports, search terms, 

synonyms, redirects, and Google Analytics. 

34.1 Reports 

This section describes some of the most important reports in Magento. This section first provides a 

full description of how to generate a Sales Report and a brief description of other important reports. 

Generating Reports 

Magento provides a variety of reports that you can access at any time. To see the reports that you 

can generate in Magento, from the Reports menu, select a type of report and then select a specific 

report of that type. 

Some report pages have filter controls that enable you to narrow the scope of the report, as shown 

in Figure 274. 

 

Figure 274. Report Filter Controls 

 The Show Report For drop-down menu enables you to select the store view or website (or 

all websites) to report on. 

 The Match Period To drop-down menu enables you to select which records to report on, 

based on either the order creation date or the order modified date. 

 The Period drop-down menu enables you to aggregate the report data into rows for each 

day, month, or year within your report From and To dates. 

 Use the From and To calendar controls to determine the start and end dates that will be 

covered by the report. 

 For Order Status, select Any to include all orders, or select Specified to select one or more 

order status values from a list. 

 The Empty Rows drop-down menu enables you to select whether to include date period 

rows that have no data. 
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 The Show Actual Values drop-down menu enables you to select whether to display actual 

(Yes) or projected (No) values. Projected values are based on estimates of amounts to be 

paid. 

When you are finished making filter selections, click Show Report (or Refresh, in some reports) to 

generate the report. To export the report information shown on the screen, select the CSV (Comma 

Separated Values) option or the Excel XML option from the Export to drop-down menu, and click 

Export. 

Refreshing Sales Report Statistics 

To reduce the performance impact of generating sales reports (those that are available under 

Reports > Sales), Magento calculates and stores the required statistics for each report. When you 

generate a report, the report uses the stored statistics, rather than recalculating the statistics each 

time you generate a report. 

The sales report statistics need to be refreshed in order for the reports to use the most recent data. 

Refreshing the sales report statistics is a manual process. 

To refresh the Sales Report statistics: 

1. In the Admin Panel, select Reports > Refresh Statistics to open the Refresh Statistics page, as 
shown in Figure 275. 

 

Figure 275. Refresh Statistics Page 

2. Use the check boxes on the left to select the reports for which you want to have the statistics 
refreshed. 

3. In the Actions drop-down menu, select the scope of the statistics to be refreshed: Refresh 
Lifetime Statistics or Refresh Statistics for the Last Day. 

4. Click Submit. 

Available Reports 

The following describes the reports that are available in Magento. 

Report Path Description 

Total Ordered Reports > Sales > 

Orders 

Shows orders for the specified time period. 

Order Taxes Reports > Sales > Tax Shows taxes charged for orders in the 

specified time period; grouped by tax rate. 
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Report Path Description 

Total Invoiced 

vs. Paid 

Reports > Sales > 

Invoiced 

Shows amounts paid and unpaid for invoiced 

orders in the specified time period. 

Total Shipped Reports > Sales > 

Shipping 

Shows orders shipped in the specified time 

period, grouped by carrier/method; includes 

shipping charge amounts. 

Total Refunded Reports > Sales > 

Refunds 

Shows refunds applied to orders in the 

specified time period. 

Coupons Usage Reports > Sales > 

Coupons 

Shows coupons used for orders in the 

specified time period, grouped by coupon 

code. 

PayPal 

Settlement 

Reports > Sales > 

PayPal Settlement 

Reports 

Shows PayPal settlements for the specified 

time period. Click Fetch Updates to retrieve 

data from PayPal. 

Products in Carts Reports > Shopping 

Cart > Products in carts 

Shows products that are currently in 

shopping carts. 

Abandoned Carts Reports > Shopping 

Cart > Abandoned Carts 

Shows shopping carts that were started but 

then abandoned. 

Tip: This report enables you to contact the 

customers and offer them discounts or 

otherwise turn an abandoned cart into a 

conversion. 

Products 

Bestsellers 

Reports > Products > 

Bestsellers 

Shows the products that were sold in the 

highest quantity in the specified time period. 

Products Ordered Reports > Products > 

Products Ordered 

Shows all products that were ordered in the 

specified time period. 

Most Viewed Reports > Products > 

Most Viewed 

Shows the products that were viewed the 

most times in the specified time period. 

Low Stock Reports > Products > 

Low Stock 

Shows the products whose stock levels are 

low. 

Downloads Reports > Products > 

Downloads 

Shows the number of purchases and 

downloads for each downloadable product. 

New Accounts Reports > Customers > 

New Accounts 

Shows the new accounts that were created 

during the specified time period. 

Customers by 

Orders Total 

Reports > Customers > 

Customers by orders 

total 

Shows the customers listed in descending 

order of total order amount. 

Customers by 

Number of 

Orders 

Reports > Customers > 

Customers by number of 

orders 

Shows the customers listed in descending 

order of number of orders placed. 

Customers 

Reviews 

Reports > Reviews > 

Customers Reviews 

Shows the customers listed in descending 

order of number of reviews contributed. 

Products Reviews Reports > Reviews > 

Products Reviews 

Shows the products listed in descending 

order of number of reviews. 

Customers Tags Reports > Tags > 

Customers 

Shows the customers listed with the number 

of tags each one has created. 

Products Tags Reports > Tags > 

Products 

Shows the number of unique tags and total 

number of tags created for each product. 

Popular Tags Reports > Tags > 

Popular 

Shows the number of times each tag has 

been applied. 

Search Terms Reports > Search Terms Shows the terms that were submitted in the 

search tool.  

Tip: If you see that the Hits field of a 
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Report Path Description 

product shows a high number (meaning that 

customers search for it often), but the 

Results column shows a low number or zero, 

then you should review your product names 

and descriptions to promote products related 

to this keyword. 

 

34.2 Search Synonyms and Redirects 

The following shows you how to fine-tune Magento’s search behavior. Two mains options are 

provided: 

 Search Synonyms: Misspelled search terms may mean missed opportunities for you. If you 

know that a frequently used search term is often misspelled by customers, and thus does not 

display results, you can add additional search terms.  

 Redirects: You can specify that when a customer searches for a certain term that they are re-

directed to a specific page. Direct customers to a specific product page, a specific brand 

landing page, or an informational page. For example, the search term “Returns” can take 

customers directly to the Shipping Policy page.  

The following example demonstrates how to add the misspelled search term “latop” so that the 

results are returned for the correct term, “laptop.” 

To add new search synonym and or redirection: 

1. In the Admin Panel, select Catalog > Search Terms to display the Search page, as shown in 
Figure 276. 

 

Figure 276. Search Page 

2. Click the Add New Search Term button to display the New Search page, as shown in Figure 
277. 
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Figure 277. New Search Page 

3. In the Search Query field, specify the incorrect spelling of the term (“latop” in this example). 

4. In the Synonym For field, specify the correct search term that is defined in your web store 
(“laptop” in this example). 

5. In the Redirect URL field, specify the URL to which the customer is redirected when no results 
are returned for the search term. 

6. Click the Save Search button. 

34.3 Google Analytics 

Google Analytics is a free service provided by Google to help website owners find out more about 

the traffic on their website and about conversions. Magento supports both the following Google 

Analytics options: 

 Page View Tracking: Enables you to see the origin from which your web store visitors linked 

to your store.  

 E-commerce Tracking: Enables you to see which customers make purchases and what they 

buy. 

You can sign up to this service at https://www.google.com/analytics. While signing up, a report is 

displayed showing your new Google Analytics account number in the following format: UA-

XXXXXXX-1. Write this number down, because it is required for configuring Google Analytics in 

Magento.  

To add Google Analytics tracking to Magento: 

1. In the Admin Panel, select System > Configuration > Google API. 

2. Expand the Google Analytics section as shown in Figure 278. 

 

Figure 278. Google Analytics Options 

3. In the Enable field, select Yes. 

https://www.google.com/analytics


 Monitoring and Improving the Web Store 

 339 

4. In the Account number field, specify the Google Analytics account number that you wrote 
down when you signed up for the service. 

Tip: Magento supports native integration with Google Website Optimizer, which is 
another free service from Google that enables you to test different versions of page 
elements and to select the elements that provide the best conversion rates. 



Keeping Your Store Healthy 

340 

35 Keeping Your Store Healthy 
Now that you have your own web store running and are selling products, do not forget to keep it in good 

condition. Make sure that your hosting provider performs regular file and database backups  

This chapter describes what you can do to keep your store healthy by using backups and rollbacks, using a 

staging environment, updating Magento, and extending Magento. 

35.1 Backups and Rollbacks 

Magento enables you to perform different types of backups (backup of database, file system, or both) 

and to perform rollbacks automatically. 

Backup and Rollback Quick Reference 

The main tasks related to creating backups and restoring the system are performed in the Magento 

Admin Panel under System > Tools > Backups. 

Files are compressed using the .gz and .tgz formats. Backup files are stored in the var/backups 

directory in your Magento file system. The content of the /var/cache, /var/log, 

/var/session and /var/report folders is excluded from the backup. 

Creating and Managing Backups 

To create a backup: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Tools > Backups. 

3. Click one of the following buttons, depending on the backup type you need to create: 

 System Backup: Creates a complete backup of the database and the file system. On the next 
step you will have the possibility to choose whether to include the media folder to the 
backup. 

 Database and Media Backup: Creates a backup of the database and the media folder. 

 Database Backup: Creates a backup of the database. 

4. The confirmation dialog box appears. If you agree to put the store into the maintenance mode 
for the time of backup creation, select the corresponding check box. After the backup creation 
is completed, the maintenance mode is turned off automatically. If you are creating a system 
backup, select the Include Media folder to System Backup check box if you want to include the 
media folder. Confirm the backup creation. 

Database backup files are compressed using the .gz format. For the system backups and database 

and media backups, the .tgz format is used. Backup files are stored in the var/backups directory 

in your Magento file system. The files that are stored in the /var/cache, /var/log, 

/var/session and /var/report folders are excluded from the backup. 
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Records about all created backups are listed in a grid on the Backups page. Deleting a record 

deletes the archive file as well. 

Rolling Back the System 

To roll back the whole system or the database: 

1. In the Magento Admin Panel, navigate to System > Tools > Backups. 

2. The Backups page opens, where all previously created backups are listed in a grid. For the 
desired backup, click the Rollback link in the Action column. Note that all changes made since 
the backup creation will be lost after the rollback. 

3. Confirm rolling back, specify your Magento Admin Panel account password, and choose 
whether you want to put your store into the maintenance mode for the time of rolling back. 
When restoring file system or database and media files you can choose to use the FTP 
connection. 

4. After the rollback, you are redirected to the login page to log in to the Admin Panel. 

5. Refresh cache types and rebuild required indexes. This can be done under System > Cache 
Management and System > Index Management, respectively. 

Important note: Use the Rollback functionality with caution. Customers who are in the 
process of checking out when you start the rollback may not be able to complete 
the checkout. 

Limiting Access to the Backup and Rollback Functionality for 
Administrator Users 

Access to the Backups and Rollback functionality management can be restricted by configuring user 

permissions for Backups and Rollback resources of the Admin Panel for an admin role. 

Role permissions are configured under System > Permissions > Roles > %desired role%. See Figure 

279 for illustration of a role permission tree on the Role Information page. 
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Figure 279. Defining Access Permissions to the Backup and Rollback Functionality 

To restrict access to the Backup and/or Rollback resources, leave the corresponding check box 

cleared. If you need to grant access to the Rollback resources, you must grant access to Backup 

resources as well.  

Creating a Backup from the Magento Connect Manager (MCM) 

In the Magento Connect Manager (MCM), you can choose to create a backup before installing an 

extension or upgrading Magento.  

To create a backup before installing an extension from MCM: 

1. Navigate to System > Magento Connect > Magento Connect Manager. 

2. Select the Create Backup check box and select the backup type. See Figure 280. 

3. Proceed with installing extension or updating Magento. The backup will be created 
automatically, and will be listed in the grid under System > Tools > Backups in the Magento 
Admin Panel. 
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Figure 280. Selecting to Create a Backup in Magento Connect Manager 

35.2 Staging Environment  

If you plan to change and develop your web store over time, we recommend that you set up a 

staging environment (also called a testing environment) in which you can test your ideas before 

applying them to the live store. We highly recommend that you also use this environment when 

updating new versions of Magento. 

At its simplest, the staging environment is just like any other Magento installation that is not 

accessible to the public. If you are modifying the files, you can keep them synchronized with the 

live files using any of the various available version control tools. 
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35.3 Extending Magento 

There are hundreds of payment gateways and shipping providers all over the world. Magento out-of-

the-box supports a few of the most popular ones. However, community members are developing 

and publishing new extensions in order to extend Magento with various new features. If you need to 

add functionality to Magento, you should first search for it on Magento Connect, which is our 

marketplace for extensions. You can access Magento Connect at: 

http://www.magentocommerce.com/magento-connect. The Magento Connect home page is 

displayed, as shown in Figure 281. 

 

Figure 281. Magento Connect Home Page 

Various free extensions are provided from this page.  

The following example shows how to install the iDEAL core payment extension that adds a new 

payment method to the store called iDEAL.  

http://www.magentocommerce.com/magento-connect
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Note: There are also commercial extensions available for purchase on their publishers’ 
pages. The installation process for each one may vary. Please consult the extension 
author for installation instructions. 

To install a free extension: 

1. Go to the MagentoConnect page on the MagentoCommerce site at 
http://www.magentocommerce.com/. 

2. Browse through the extensions using the filters provided in the panel on the right. 

3. Go into the details page of the desired extension to display a page similar to Figure 282. 

 

Figure 282. Extension Details Page 

4. Click Get Extension Key to display the following:  

http://www.magentocommerce.com/
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5. Click the link to read the license agreement, then accept the licensing agreement by selecting 
the agreement check box. 

6. An extension key similar to the following is displayed: magento-core/Mage_Ideal. 
This is a special link to an extension that Magento recognizes. Click Select to select it and then 
copy it to the clipboard (Ctrl+C). 

7. In the Admin Panel, select System > Magento Connect > Magento Connect Manager. 

8. Log in using your backend username and password and click Log In. 

9. Paste the extension key in the Install New Extensions section, as shown in Figure 283. 

 

Figure 283. Pasting the Extension Key 

10. Click the Install button and wait until the installation has finished.  

You can now return to the backend and start using the extension that you have just installed! 

Note: After you install a payment module, this new option appears in the System menu 
under Configuration > SALES > Payment Methods. 
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PART VII: ADVANCED SITE MANAGEMENT 

36 Controlling Website Access 
This chapter introduces Magento Enterprise Edition’s functionality for restricting access to your websites—

both on the backend and the frontend.  

For your administrator users, Enterprise Edition enables you to control what they can see in the Admin Panel. 

You can restrict which features and functions are available to an admin user as well as which websites’ or 

stores’ products and data they can see. 

For your customers, Enterprise Edition also enables you to easily control whether your frontend website is 

temporarily closed (for example, for maintenance) or whether your website is open to all visitors or to only 

logged in customers or customers in specific customer groups (for example, for private sales or B2B 

websites). 

36.1 Limiting Administrator Access to the Admin Panel 
(Backend) 

As with all versions of Magento, you can create individual accounts for each user to whom you 

want to allow access to the backend Admin Panel. You can even create roles that define which 

Admin Panel functionality those administrator users will have access to.  Additionally, Magento 

Enterprise Edition enables you to further restrict that admin access to only a specific site or set of 

sites and their associated data. If you have multiple brands or business units with separate stores all 

on the same Magento installation, this feature enables you to provide admin access to each of your 

business units but to still hide and protect their data from one another. 

To limit which websites or stores administrator users can see when they log in to the Admin Panel, 

you create a role with a limited scope and resources. After you have created a restricted role, you 

can assign that role to a specific admin user account. Administrator users assigned to a restricted 

role will be able to see and change data only for websites or stores associated with that role. They 

will also be unable to change global settings or data. 

If an admin user’s access is restricted to a specific set of websites and/or stores, the websites and 

stores for which they are not authorized will not be shown in the scope drop-downs or they will be 

displayed as inactive. Only the sales and other data for allowed websites and stores will be shown. 

To limit admin role access to specific websites or stores: 

1. Choose System > Permissions > Roles. 

2. Click on the [+Add New Role] button to create a new role. 

3. In the Role Info tab, specify the following information: 
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 Role Name (required) - Give the role a descriptive name to help you remember its scope 

and purpose. 

4. Select the Role Resources tab in the left column. 

 In the Role Scopes panel, set the following values: 

o Select Custom from the Role Scopes drop-down menu. 

o In the resulting list, select the websites and/or stores that you want users with that 

role to have access to. 

 In the Role Resources panel, set the following values: 

o Select Custom from the Resource Access drop-down menu. 

o In the resulting list, select the menus and features that you want users with that role 

to have access to. 

 Important Note: Be sure to disable access to at least the Permissions tool here in the 
Role Resources section if you are limiting website/store access for a given role. 
Otherwise, users with this role will be able to modify their own restrictions. 

o If desired, select the Role Users tab and assign existing Admin user accounts to this 

new role.  

5. Click the [✔Save Role] button to save your new role. 

After creating a restricted role, you can create new administrator users at any time (System > 

Permissions > Users) and assign your new restricted role to the administrator users whose access 

you want to limit. 

36.2 Limiting Visitor/Customer Access to the Website 
(Frontend) 

Another Enterprise Edition concept, called website restrictions, provides you with the ability to 

either shut down access to your site completely (for example, if it’s closed for maintenance) or to 

restrict access to only logged-in customers (for example, for B2B websites or for private sales). 

Restricting Customer Access from an Entire Website 

If you wish to temporarily close your website, you can do so easily in Enterprise Edition by setting 

the website restrictions to “website closed.” This will temporarily redirect site visitors to any URL 

under Magento control to a single landing page of your choice. 

To restrict access to an entire website: 

1. Choose System > Configuration. Select the General tab on the left. 

2. In the Website Restrictions panel, you can set the following values: 
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 Access Restriction - Determines whether the website restriction features are enabled. If Yes, 

frontend website access is restricted in the manner set in the fields below. If No, this feature 

in disabled and the following settings have no effect. 

 Restriction Mode - There are three possible modes. 

o Website Closed - All access to the frontend website is restricted and the website is 

essentially “closed.” All frontend URLs are temporarily redirected to the page 

specified as the Landing Page below. This setting can be useful during site 

maintenance or just prior to launch.  

o Private Sales: Login Only - Users can only access the frontend website if they first 

log in. All frontend URLs are temporarily redirected to either the specified landing 

page or to the login form until the user logs in. Users cannot create a new account 

themselves when the site is in this mode.  

o Private Sales: Login and Register - Users can only access the frontend website if 

they first log in. All frontend URLs are temporarily redirected to the login form until 

the user logs in. Users can create a new account themselves when the site is in this 

mode. 

 Startup Page - Determines whether the site displays the login form or a landing page until a 

user logs in. This setting is only applicable in Private Sales mode (if the previous setting is 

either Private Sales: Login Only or Private Sales: Login and Register), because the Website 

Closed option prohibits users from logging in altogether.  

o To login form - Users are redirected to the log in form until they log in.  

o To landing page - Users are redirected to the static page specified below until they 

log in.  

Important note: Be sure to include a link to the login page from the specified landing 
page so that customers can log in to access the full site. 

 Landing Page - Specifies the landing page users see either when the website is closed or 

when you have chosen to start up from a landing page in Private Sales mode. 

 HTTP response - Specify the HTTP response sent out when your website is closed and a 

connection is attempted by bots, crawlers, or spiders.  

o 503 Service unavailable means that the page is not available, and the index will 

not be updated.  

o 200 OK means the landing page returned is the correct page, and the spider might 

assume the landing page is the only page on the site. 

3. Click the [✔Save Config] button to save your settings. 
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Note: The Private Sales website restriction settings can be also used for B2B websites. 
Customers can be created in the backend and required to log in in order to view 
the site. 

Restricting Customer Access on a Category-by-Category Basis 

In order allow specific customer groups to see only certain categories of your website, you first need 

to enable this ability in the Admin Panel. You can set default values that apply to all categories in 

your entire store.  You can also override these settings for individual categories. 

To configure default access permissions and landing pages 

1. Choose System > Configuration. Select the Catalog tab on the left. 

2. In the Category Permissions panel, you can set the following values: 

 Enable - Determines whether or not category access can be restricted.  

o Yes - Frontend website access is restricted in the manner set in the fields below. A 

new tab (Category Permissions ) will appear at the category level in Catalog > 

Manage Categories so that you can override these settings on a category-by-

category basis.  

o No - This feature in disabled and the following settings have no effect. 

 Allow Browsing Category - Determines whether category pages are visible and to which 

customers.  

o Yes, to all – Gives this permission to all customer groups.  

o Yes, to specified customer groups - Gives this permission to certain customer 

groups only.  

o Customer Groups – This multiple select menu will appear, listing all existing 

customer groups, from which you can select the group or groups to give this 

permission.  

o No, redirect to landing page - Denies this permission to all customer groups. 

o Landing Page - Select the landing page that customers will be directed to if they do 

not have permission to browse categories. Customers will be redirected if you have 

selected either Yes, to specified customer groups or No, redirect to landing page 

above. They will also be redirected if you deny access to a customer group on the 

category level, which will be discussed further in the next section. This drop-down 

menu lists all landing pages that have been created in CMS > Manage Pages. 

 Display Product Prices - Determines whether product prices are displayed on the product 

listing pages and product info pages.  

o Yes, to all - Gives this permission to all customer groups. Select Yes, to specified 

customer groups in order to give this permission only to certain customer groups.  

o If this option is selected, a Customer Groups multiple select menu will appear, 

listing all existing customer groups, from which you can select the group or groups 

to give this permission. Select No in order to deny this permission to all customer 

groups. 
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 Allow Adding to Cart - Determines whether customers are able to add products to their 

carts from the product listing pages and product info pages.  

o Select Yes, to all in order to give this permission to all customer groups.  

o Select Yes, to specified customer groups in order to give this permission only to 

certain customer groups. If this option is selected, a Customer Groups multiple 

select menu will appear, listing all existing customer groups, from which you can 

select the group or groups to give this permission.  

o Select No in order to deny this permission to all customer groups. 

 Disallow Catalog Search by - Select the customer group or groups from this multiple select 

menu that will not be allowed to use the Quick Search bar in the header or the Advanced 

Search tool to search for products in your site. 

3. Click the [✔Save Config] button to save your settings. 

To apply category permissions: 

The default category permissions that you set above can be overridden on the category level. To do 

so, navigate to Catalog > Manage Categories, select the desired category from the category tree in 

the left column, and select the Category Permissions tab. This tab will exist only if you have enabled 

this feature in the configuration settings described above. 

Here you have the ability to set permissions for each website and each customer group. First, click 

the New Permission button. Select the desired website and customer group from the corresponding 

drop-downs. If you want to apply this permission for all websites and/or customer groups, select All 

Websites or All Customer Groups, respectively. 

For each type of permission (browsing, product prices, and add to cart) you have the ability to Allow 

or Deny permission. Additionally, you can choose to use the permission of the parent category, Use 

parent. This setting is helpful if you have a child category or set of children categories which will 

always follow the permission settings of the parent. This way, you can change the permission 

settings of the parent category and have the changes automatically apply to the child or children 

categories. 

Each permission (browsing, product prices, and add to cart) will apply to the product listing 

(category) page of the selected category, as well as the product view (product) page of products 

associated to the selected category. However, if a product is associated to another category, which 

has no viewing or selling restrictions, then none of the permissions will apply to the product view 

page. 

To remove a permission, click the red X button. 

When you have completed these settings, click the Save Category button in the top right of the 

page. 
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36.3 CAPTCHA 

CAPTCHA functionality is used to ensure that a human being, rather than another computer, is 

interacting with the site. It can be used in the backend and frontend. CAPTCHA in Magento is visual 

and is fully configurable.  

The CAPTCHA was implemented using a module from Zend Framework.  

CAPTCHA: Quick Reference  

The following table lists the main tasks related to the CAPTCHA functionality, and the places where 

they are performed in the Magento Admin Panel. 

Task Admin Panel Menu Scope 

      Enable and configure the CAPTCHA for 

the backend 

System > Configuration > ADVANCED >Admin > 

CAPTCHA 

Global 

Enable and configure the CAPTCHA for 

the frontend 

System > Configuration > CUSTOMERS >Customer 

Configuration > CAPTCHA 

Website 

Enabling and Configuring CAPTCHA for the Backend 

To enable and configure CAPTCHA for the backend: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration > ADVANCED >Admin > CAPTCHA. Make sure that the 
Current Configuration Scope is set to Default. 

3. Configure the following settings: 

 Enable CAPTCHA in Admin: Enables CAPTCHA for the login pages of the Admin Panel. 

 Font: Defines the font used for CAPTCHA displaying. To add your own font, put the font file 

in the same directory as your Magento instance and specify it in the config.xml file that is 

stored in the app/code/core/Mage/Captcha/etc/ folder. 

 Forms: Defines the form, on which CAPTCHA is displayed. Available options: Admin Login 

and Admin Forgot Password. 

 Displaying Mode: Defines preconditions for displaying CAPTCHA. Available options: 

Always or After number of attempts to login. If the latter is selected, the Number of 

Unsuccessful Attempts to Login text field is displayed. Setting Number of Unsuccessful 

Attempts to Login to 0 (zero) is similar to setting Displaying Mode to Always. The After 

number of attempts to login option does not cover the Forgot Password form. If the 

CAPTCHA functionality is enabled and set to be displayed on this form, then it is always 

displayed on the form. 
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Note: To track the number of unsuccessful login attempts, the attempts to log in under 
one email address from one IP address are counted. The maximum allowed 
number of attempts to log in from one IP address is 1,000. This limitation is applied 
only when the CAPTCHA functionality is enabled. 

 CAPTCHA Timeout (minutes): Defines how long the displayed CAPTCHA is valid. After the 

timeout the user needs to reload the page.  

 Number of Symbols: Defines the number of symbols that are used for creating CAPTCHA. 

Maximum allowed value is 8. You can also specify a range, for example, 5-8; each 

generated CAPTCHA can contain different number of symbols. 

 Symbols Used in CAPTCHA: Defines what symbols are used in CAPTCHA. Only letters (a-z 

and A-Z) and numbers (0-9) are allowed. The default set of symbols suggested in the field 

excludes similar looking symbols like “i”, “l”, “1”. Displaying these symbols in CAPTCHA 

decreases the chances that a user will recognize CAPTCHA correctly. 

 Case Sensitive: Defines whether letters in CAPTCHA are case sensitive. 

4. To save the settings click Save Config. 

Enabling and Configuring CAPTCHA for the Frontend 

To enable and configure CAPTCHA displaying in the frontend: 

1.  Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration > CUSTOMERS > Customer Configuration.  

3. In the Current Configuration Scope drop-down field select the desired website. 

4. Expand the CAPTCHA field set. Configure the following settings: 

 Enable CAPTCHA on Frontend: Enables the CAPTCHA for the website frontend; 

 Font: Defines the font used for CAPTCHA displaying. To add your own font, put the font file 

in the same directory as your Magento instance and specify it in the config.xml stored in the 

app/code/core/Mage/Captcha/etc/ folder. 

 Forms: Defines the forms where CAPTCHA is used. The following options are available: 

Create User, Login, Forgot Password, Checkout as Guest, and Register during Checkout.  

 Displaying Mode: Defines preconditions for displaying CAPTCHA. Available options: 

Always or After number of attempts to login. If the latter is selected, the Number of 

Unsuccessful Attempts to Login text field is displayed. Setting Number of Unsuccessful 

Attempts to Login to 0 (zero) is similar to setting Displaying Mode to Always. The After 

number of attempts to login option does not cover the Forgot Password and Create User 

forms. If the CAPTCHA functionality is enabled and these forms are selected in the Forms 

field, the CAPTCHA is always displayed on these forms. 
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Note: To track the number of unsuccessful attempts to log in, the attempts to log in 
under one email address from one IP-address are counted. The maximum allowed 
number of attempts to log in from one IP-address is 1,000. This limitation is only 
applied when the CAPTCHA functionality is enabled. 

 CAPTCHA Timeout (minutes): Defines for how long the displayed CAPTCHA is valid.  After 

the timeout a user needs to reload the page. 

 Number of Symbols: Defines the number of symbols that are used for creating CAPTCHA. 

Maximum allowed value is 8. You can also specify a range, for example, 5-8. 

 Symbols Used in CAPTCHA: Defines what symbols are used in CAPTCHA. Only letters (a-z 

and A-Z) and numbers (0-9) are allowed. The default set of symbols suggested in the field 

excludes similar looking symbols like “i”, “l”, “1”. Displaying these symbols in CAPTCHA 

decreases the chances that a user will recognize CAPTCHA correctly. 

 Case Sensitive: Defines whether letters in CAPTCHA are case sensitive. 

5. To save the settings click Save Config. 

CAPTCHA: User Experience 

The CAPTCHA in Magento is visual. Figure 284 and Figure 285 illustrate the way 

CAPTCHA is displayed in the frontend and the backend. 

 

Figure 284. CAPTCHA in the Frontend 
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Users can reload the displayed CAPTCHA by clicking the Reload icon in the upper right corner of 

the image. The number of reloads is not limited.  

 

Figure 285. CAPTCHA in the Backend 

Administrator users can reload the displayed CAPTCHA by clicking the Reload icon in the 

upper right corner of the image. The number of reloads is not limited.  
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37 Read and Edit Permissions for Prices and 
Promotions 

This chapter describes a feature that enables you to control administrator user  access to the Product 

Managing and Promotions resources of the Magento Admin Panel. 

This feature was introduced in Version 1.11 of and Magento Enterprise Edition. 

37.1 Read and Edit Permissions – a Quick View 

In the Magento Admin Panel, the access roles are configured under System > Permissions > Roles. 

This functionality concerns access rights for the products management and promotions management 

resources. 

Permissions for Promotions Resources – a Quick View 

The general logic for Promotions permissions is the following: 

 When only Read permission is granted for a certain resources (such as catalog price rules 

and shopping cart rules), the backend user can only view the existing rules. No fields are 

available for editing, and all management buttons are hidden. To grant Read permission 

only, select the resource check box, and clear the Edit check box. See Figure 286. 

 

Figure 286. Only Read Access Rights Are Granted for All Rules-type Resources of the 

Promotions Section 

 When Edit permission is granted for a given resource, the backend user has the complete 

access to that resource. 

Permissions for Product Management – a Quick View 

The general logic for product management permissions is the following: 

 When Read permission is granted for the product status, the backend user cannot change 

the value of the Status product attribute. When creating a new product, the Status field is 

unavailable for editing and is set to Disabled. 

 When the Edit permission is given for the product status, the backend user can change the 

values of the Status product attribute. 
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 When the Read permission is given for the price, the backend user can view, but cannot 

edit, the product price-related fields. When creating a new product, the Price attribute (or 

Amount, in case of a gift card product) is unavailable for editing and set to the default value, 

and creating recurring profiles is unavailable. When adding custom options, or associated 

products for a configurable product, or links for downloadable products, the prices are 

unavailable for editing and are set to zero, the Price Type field is unavailable for editing and 

set to Fixed.  

 When Edit permission is given for the product price, the backend user has full access to all 

price-related fields. 

 When access to product management is granted, but neither Read nor Edit permissions for 

product price are specified, all price-related fields and columns are hidden, and 

management of recurring profiles is unavailable. The backend user can still create new 

products and add custom options, associated products, and links for downloadable 

products. In this case, the price fields and price columns in the grids are hidden and are set 

to the default or zero value. The price and total columns are hidden on the Manage 

Products page, the Category Products tab of the Category view, and the customer’s 

shopping cart view in the Admin Panel. 

The default product price is set under System > Configuration > Catalog > Price > Default Product 

Price. 

37.2 Access Roles and Users 

In the Magento Admin Panel, the access roles are configured under System > Permissions > Roles. 

To open the access management section for a role, open the role for editing, click the Role 

Resources tab, and select Custom in the Resources Access drop-down menu. The resources tree 

appears where you can specify which sections of the Admin Panel are accessible for the role. 

The new functionality concerns the access rights to the Manage Product and Promotions 

subsections. 

37.3 Read and Edit Permissions for Product Management 
Resources 

For the product management section, you can grant the following access rights:  

 Read/Edit permission for the product status 

 Read/Edit permission for the product price 

 Access without options 
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Access rights 
option 

How to assign Restrictions 

Read Product Status 

 

The Status field of the products is 

unavailable for editing. When 

creating a product, the field is 

unavailable for editing and is set to 

Disabled. Performing mass Status 

change on the Products page is 

unavailable. 

Edit Product Status 

 

The Status field of the products is 

available for editing by the backend 

user. 

Read Product Price 

 

 When editing existing products 

or performing mass change of 

attributes values, all fields on the 

Prices tab are displayed, but are 

unavailable for editing. 

 When creating a new product, 

the Price field on the Prices tab 

is unavailable for editing, and is 

set to the default value. All other 

price related fields on this tab 

(Special Price, Special Price 

From/To Date, Tier Price; if 

MAP is enabled, all MAP related 

settings) are not displayed.  

For gift card products, the 

Amount field on the Prices tab is 

unavailable for editing and is set 

equal to the default price value. 

All other amount-related fields 

(Allow Open Amount, Open 

Amount Min Value, Open 

Amount Max Value) are not 

displayed. 

 Management of recurring 

profiles is unavailable. When 

creating a new product, the 

Enable Recurring Profile 

attribute is set to No and is 

unavailable for editing. 

 When adding custom options, or 

associated products for 

configurable products, or links 

for downloadable products, the 

Price field is unavailable for 

editing and is set to zero, and 

the Price Type field is 
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Access rights 
option 

How to assign Restrictions 

unavailable for editing and is set 

to Fixed. 

Edit Product Price 

 

The admin user has the right to 

access and change all price-related 

fields and columns of the product 

management section. 

Access without Read 

or Edit rights 

 

All price related fields and columns 

are hidden. Specifically: 

 On the Prices tab, for both new 

and existing products, the Price, 

Special Price, Tier Price, Cost (if 

applied), Special Price From 

Date, Special Price To Date 

attributes, and all MAP-related 

settings are hidden. For new 

products the Price is set to the 

default value. The same logic 

applies to the Amounts and the 

Allow Open Amount, Open 

Amount Min Value, and Open 

Amount Max Value fields for the 

gift card products. 

 For both new and existing 

products, the Enable Recurring 

Profile field is displayed, but is 

unavailable for editing. For the 

existing products, all other fields 

related to the product profile are 

hidden. For new products the 

Enable Recurring Profile field is 

set to No.  

 On the Related Products, Up-

sells, Cross-sells tabs of the 

product view, the Price column 

in the grids is not displayed. 

 On the Custom Options tab, 

Associated Products tab of the 

product view, the Price and 

Price Type columns in the grids 

are not displayed. When adding 

a new custom option or a new 

associated product for a 

configurable product, the Price 

and Price Type fields are 

hidden. For new entries, the 

Price is set to zero, and the Price 
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Access rights 
option 

How to assign Restrictions 

Type is set to Fixed.  

 On the Downloadable 

Information tab for 

downloadable products, the 

Price column is hidden. For the 

new rows the Price is set to 

zero. 

 On the Manage Products and 

Category Products pages 

(Categories > Manage 

Categories > Category Products 

tab), the Price columns in the 

grids are hidden. 

 In the customer’s shopping cart 

views (accessible from the 

Customer’s page), the Price, 

Total and Subtotal columns are 

hidden. 

Note: In the shopping cart management section under Customers > Manage Customers 
> %your customer% > Manage Shopping Cart, users with no Read or Edit 
permissions for product prices will still be able to see the option prices when 
configuring products. 

Configuring the Default Price 

When a backend user with Read Product Price permissions creates a new product, the product price 

is set to the default value. 

To set the default price: 

1. Select System > Configuration > Catalog. 

2. In the Current Configuration Scope drop-down menu in the upper left corner of the page, leave 
Default Config. 

3. Set the default price in the Default Product Price field on the Price field set. 

Note: If the default price is not set, it is considered equal to zero. As a result, a user 
with Edit access rights for product status and Read access rights for product prices 
can create products which will appear on the frontend with a price of zero. 

Read and Edit Permissions for Promotions Resources 

For the promotions management resources, you can grant the following access rights:  

 Read/Edit permissions for Catalog Price Rules 

 Read/Edit permissions for Shopping Cart Price Rules 
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 Read/Edit permissions for Automated Email Reminder Rules 

The following table describes how different access options for Catalog Price Rules resources are 

applied and assigned. 

Access rights 
option 

How to assign Restrictions 

Read Catalog Price 

Rules 

 
 

The user can view the existing rules, 

but all fields are unavailable for 

editing and the management buttons 

are hidden. Specifically, on the 

Catalog Price Rules page, the Apply 

Rule and Add New Rule buttons are 

hidden; on the Edit Rule page, only 

the Back button is available. 

Edit Catalog Price 

Rules 

 
 

The user has the complete access to 

the subsection, including all fields and 

buttons.  

Assigning and applying Read and Edit permissions for the Shopping Cart Price Rules and Automated 

Email Reminder Rules are similar in all respects to that for the Catalog Price Rules. 
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38 Advanced Security Features 
This chapter introduces Magento Enterprise Edition encoding and security features, which match PCI 

standard requirements. 

38.1 Encryption and Hashing 

Magento Enterprise Edition hashes all data that does not require decryption by using a strong SHA-

256 hashing algorithm instead of the previously used MD5. Legacy passwords will be hashed using 

the new algorithm whenever they are entered by customers, and all new passwords will be hashed 

using the SHA-256 algorithm. 

Magento Enterprise Edition also encrypts all data that does require decryption by using an industry-

standard AES-256 algorithm. This includes credit card data and integration (payment and shipping 

modules) passwords. 

38.2 Changing the Database Key 

Magento Enterprise Edition provides a tool to change the database key that is used for data 

encryption and decryption. This database key was generated when Magento was originally installed 

in your production environment. The key should be changed if the old key is ever compromised, as 

well as on a regular basis to improve security. When the key is changed, all legacy data is re-

encoded using the new key.  

To change the encoding key: 

1. Navigate to System > Manage Encryption Key. 

2. Select whether or not the new encryption key will generate automatically. If not, a New Key 
field will appear in which you can manually enter a new key.  

3. Click the Change Encryption Key button in the top right of the page. 

The encryption key will be changed and all previous data will be encoded with the new key. The 

new encryption key will be displayed for reference. 

Note: Please make a note of the new key and keep it in a safe place. It will be required 
in order to decrypt data if any problems occur with your files. 

38.3 Logging Administrator Actions 

Logging of administrator actions enables you to track of backend activities. For most events, the 

available information includes the action, the name of the user who performed it, whether it was a 

success or failure, and the ID of the object on which the action was performed. Additionally the IP 

and date are always logged.  
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To configure logging: 

By default, all available modules are logged. To configure which modules are logged, navigate to 

System > Configuration, click the Admin tab in the left column, and select the Events Logging 

section. Locate the module you wish to edit and select Yes to enable it or No to disable it. 

Additionally, you can control how long the log entries are stored and how often they are archived. 

To edit these settings, click on the System tab in the left column and select the Event Log Archiving 

section. 

 Save Log, days - Determines how long the log entries are stored in the database before 

being removed. If there are many administrators working on the site, you can change this 

value from the default (60 days) to a lower value to avoid filling the capacity of the 

database. 

 Log Archiving Frequency - Determines how often old events are saved to the archive. 

Possible values are Daily, Weekly or Monthly. 

Note: For log cleaning to work, the Magento cron job has to be set up. More 
information is available here:  http://www.magentocommerce.com/wiki/how_to/ 
how_to_setup_a_cron_job 

Logs Report 

To view the actual log of admin actions, navigate to System > Admin Actions Log > Report. This 

page is in a grid format, enabling you to sort and filter by values such as timestamp, IP address, user 

name, and module. If applicable, the Item_id column will display the ID of an affected item, such as 

customer ID, order ID, or product ID. The log report can be exported to CSV or XML using the 

Export to drop-down menu and Export button. 

Logs Archive 

To access the log archive files, navigate to System > Admin Logging > Archive. This page lists the 

CSV log files stored in var/admin_logs. By default, the file name will contain the current date in the 

format (iso) yyyyMMddHH.csv. File names are hyperlinked to download the appropriate file. 

38.4 Setting Administrator Password Security Levels 

There is a set of options controlling administrator password security. The following settings are 

available by navigating to System > Configuration, clicking the Admin tab in the left column, and 

selecting the Security section: 

 Maximum Login Failures to Lockout Account - Determines the number of consecutive failed 

login attempts that will cause that account to become locked. If you do not want to enable 

the lockout feature, leave this field blank. 

 Lockout Time (minutes) – Determines the duration, in minutes, for which the account will 

be locked after the failed logins. 
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 Password Lifetime (days) - Determines the duration, in days, until Magento will request an 

administrator to change their password. If you do not want to enable the password lifetime 

feature, leave this field blank. 

 Password Change - Determines if the administrator is required to change their password 

after the password expires (option Forced), or if the password change is optional and a 

notification message is displayed (option Recommended). 

Note: During an account lockout, other administrators can unlock the account by 
navigating to System > Permissions > Locked Users. 
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39 Advanced Design and Content Management 
This chapter introduces some of Enterprise Edition’s functionality to support working with your design and 

content. The biggest enhancement over our Community Edition functionality is the ability to create content 

staging websites that allow you to stage and preview content and design changes in your production 

environment without making those changes live. Some of primary uses of content staging include data entry, 

preparing seasonal layout and data changes, and building new CMS content.  

Chapter Quick Reference 

The table below lists some of the most common tasks using EE’s design and content staging enhancements 

and where to go in the Admin Panel to perform them. The sections that follow provide step-by-step 

instructions on each. 

TASK ADMIN MENU 

To configure content staging System > Configuration > General tab 

 

To create a staging website System > Content Staging > Staging Websites 

To merge content from a staging 

website to a live site 

System > Content Staging > Staging Websites 

To roll back a content merge System > Content Staging > Backups  

 

To change the favicon System > Configuration > Design 

 

39.1 Content Staging  

In order to effectively use content staging, it is necessary to understand a little bit about how it 

works in Magento. Content staging websites are created as hidden or beta websites that can be 

accessed via a special, password-protected URL. They can have the same domain as the live store 

or on a separate domain, but they run on the same Magento installation and database as your live 

site. 

In the Admin Panel, staging websites are accessed and used in the same way as normal websites. 

You create, edit, and delete content and products in exactly the same way. Setting the Configuration 

Scope as you work determines which site you’re working on—a staging site or a live site.  

When your changes are done and approved you can merge the staging website with the live website 

and do not have to re-enter data or configuration changes. During merging, all the content assigned 

to the staging website will become assigned to the live website, and all attributes on the staging 

website/store view level will be copied to the matching live website/store view. All mapping and 

content selection details can be controlled by the administrator, so only the content and content 

types you want will be merged. Additionally, during merging, a rollback (backup) can be created. 
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Note: It is important to keep in mind that these websites are content staging websites 
and are not staging websites for code or development work. 

Setting Up Content Staging Websites 

To configure your content staging websites: 

There are some configuration settings that must be completed relating to content staging.  

1. Choose System > Configuration. Select the General tab on the left. 

2. In the Staging Websites panel, configure your staging websites: 

 Automatically create Entry Points for Staging Websites - Determines if the entry points 

(index files) for beta sites are created automatically. If you plan to host your Staging 

Websites on a separate domain, select No. 

 Folder Name for Entry Points - Entry points, if created automatically, will be created as 

subdirectories in this path. This folder must be writeable. 

 Close Website during Merge or Rollback – Determines if access will be restricted to the live 

site while the merge or rollback is being performed.  

o If you select No, the site(s) can be accessed as usual.  

o Take down entire frontend means access to all sites will be restricted, and is the 

recommended option.  

o Take down only relevant websites means access will be restricted only to the site(s) 

involved in the merge or rollback activity. 

 Landing Page – Select the CMS page that will be shown if the site is closed during a merge 

or rollback activity. 

3. Click the [✔Save Config] button to save your settings. 

To create a new content staging website: 

Magento Enterprise Edition allows you to create as many Staging Websites as required. 

1. Choose System > Content Staging > Staging Websites.  
This page contains a grid listing all existing Staging Websites. 

2. Click the [+Add Staging Website] button. 

3. Select one of existing websites as the base in the Source Website drop-down menu and click 
the [Continue] button. 

4. Configure the staging website with the following options: 

 Label - Unique name assigned to the staging environment so that it is easily recognizable. 

 Staging Website Code - Unique website code of the Staging Website. This field will be pre-

populated with and automatically generated code, although you have the ability to modify 

the value.  

 Staging Website Name - Name of the Staging Website. This field will be pre-populated with 

and automatically generated name, although you have the ability to modify the value.  
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 Base URL and Secure Base URL - Base address of the Staging Website. If the website is to be 

hosted on a separate domain or in a non-default location, enter a new value. 

 Frontend Restriction - Controls how the frontend of the Staging Website can be accessed. 

The following options are available: 

o Not accessible - Disables access to the entire staging frontend. 

o Accessible – The staging site is open and can be accessed by anyone that knows 

the URL. 

o Require HTTP Auth – The staging site will show a username and password prompt 

on access, which can be configured below. 

 HTTP Login and HTTP Password - Enter the username and password used for restricting 

frontend access when the Frontend Restriction drop-down menu above is set to Require 

HTTP Auth. 

5. Select Original Website Content to be Copied to Staging Website – This section determines 
which items will be copied to the Staging Website from the source Website. 

6. Select Original Website Store Views to be Copied to Staging Website – This Section determines 
which Store Views will be copied to the Staging Website from the source Website. 

7. Click the [Create] button to save your settings. You will be redirected to the Staging Websites 
grid. 

Now you can start editing content, assign it to the Staging Website, and change attributes on the 

Website or Store View level of the Staging Website. 

You can also edit the staging environment by clicking on the desired Staging Website in the grid. 

While editing, you can change the Label and Frontend Restriction options. You can also view the 

Event History tab, listing all events (creation, merge, or rollback) that were done in this site. 

Note: You can also create Staging Websites based on other Staging Websites. This 
allows more people to work on different parts of the new content. The content can 
be merged to the beta Website, fully tested and reviewed, and finally merged to the 
production (live) Website. 

Merging Content 

After making all the necessary content changes on the Staging Website you can merge or schedule 

merging of the Staging Website to another Website. 

To merge or schedule merging of a Website: 

1. Navigate to System > Content Staging > Staging Websites. 

2. Click on the staging website in the grid that you want to merge. 

3. Click the [Merge] button to open the mapping configuration page. 

4. In the top section, define the mapping of the Websites and Store Views. This controls which 
Staging Website is merged to which live Website, and which staging Store View is merged to 
which live Store View. 
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 Select the To Website, which is the target Website. The To website can be either the Source 

Website, or another Website. 

 Click Add New Store View Map. 

 Select the From and To Store Views. Each From Store View option can only be selected 

once. 

 Repeat adding Store View maps for all Store Views that need to be merged. 

5. Select the Create a backup check box if you want to create a backup of the live site before 
merging.  

6. In the Select Items to be merged section, select all items that you want to merge from the 
staging to the live website. 

7. Click Merge Now or specify a date and time and click Schedule Merge.  

Note: for a scheduled merge to be applied, the Magento cron job has to be running on 
the server. 

Note: You can only create one backup for each website per merge. Backups are created 
in the database and require significant database space. Backups are not updated 
when Magento is updated. If the table structure is changed during an update, there 
will be no way to restore the backup. 

Rolling Back Merges 

If you have selected the Create a backup check box during website merging, a backup of the target 

Website will be created just before the merge. This backup only contains the tables related to the 

content staging merge and is not a backup of the entire site. 

To roll back website content: 

1. Navigate to System > Content Staging > Backups. This page contains a grid listing all existing 
backups. 

2. Click on the backup in the grid that you want to roll back. You will be redirected to the Website 
Backup Information page. This page has three tabs available in the left column: 

 Backup General Info - Displays the basic backup information. Table Prefix is the prefix used 

for backup tables of this website in the database. 

 Rollback History - Displays events associated with this backup. 

 Rollback - Contains the list of items which are available for rollback. 

3. In the Rollback tab choose the items that you want to restore. You can only select the items 
which are available. 

4. Click the Rollback button. After the website is restored, you will be redirected to the backup 
grid. 
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Note: Items are available for rollback only if the table versions of the backup and 
original Website match. If they do not match, the rollback is not possible with 
Magento functionality. It can be carefully performed using manual database 
administration tools, however this is not recommended. The table version might 
change when an upgrade of the Magento system also changes the structure of some 
of the tables. 

Rollback can be used either to restore content if an error is noticed after a merge, or to restore to a 

previous site version when the staging site is used for seasonal or temporary Website changes. 

Working with a Content Staging Website 

Content staging is a very powerful tool, but requires caution to use it effectively. An important thing 

to understand is that the Staging Website it is not a separate beta Website with a separate database. 

It is another Website in the store that is hidden. Thus, creating and deleting content, such as 

products, requires special attention. 

To remove a product from a staging website: 

You cannot and should not “delete” a product from a content staging website. Deletion of the 

product in staging will result in deletion from the live site as well. To remove a product from a 

content staging website, you should simply disable it in that website. 

1. Navigate to Catalog > Manage Products and select the desired product from the grid. 

2. In the Websites tab, uncheck the Staging Website that you wish to de-associate from the 
product. Alternatively, you can change the Choose Store View scope drop-down menu to the 
desired Staging Website, navigate to the General tab, and select Disabled in the Status drop-
down menu. Click Save when you are finished. This will remove the product from the Staging 
Website, but it will still exist in the production site until a merge is performed. 

3. Merge the Staging Website into the production Website by following the steps in the previous 
section of this chapter. 

The product will be unassigned to or disabled in the Staging Website as well as the production 

Website. Now you can safely delete the product, as it is no longer used. 

To create a product on a staging website: 

1. Navigate to Catalog > Manage Products and click Add Product. 

2. Create the product as usual and assign it only to the Staging Website on the Websites tab. Save 
the product. 

3. Merge the Staging Website into the production Website by following the steps in the previous 
section of this chapter. 

Now the product will be available in both the staging and production Websites. 

Similar steps should be taken when working with other types of content. 
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Special care has to be taken when upgrading Magento. Upgrades will modify Staging Websites but 

will not modify the backups, and in many cases (if the upgrade modifies content tables) this can 

render the backup unusable. It is advisable to perform upgrades before working on Staging 

Websites, or after a merge is performed, confirmed and no rollback is expected to be used. 

39.2 Changing the Favicon 

Magento Enterprise Edition enables you to upload a new favicon for a website, store, or store view 

from the Admin Panel. The favicon is a graphic, associated with your store, that appears in the end 

user’s Favorites list and other places in the browser. 

While some browsers support additional file types as favicons, the safest format is an ICO file that is 

16x16 pixels or 32x32 pixels. Many free favicon converter tools are available online to convert your 

PNG, GIF, and JPG files to the ICO format. 

To change the favicon: 

1. Choose System > Configuration. Be sure to select the desired Configuration Scope. 

2. Select the Design tab on the left. In the HTML Head panel, configure your staging websites: 

 Favicon icon - Click the Browse button. In the File Upload dialog box, browse for the 

desired image file on your computer and then click the Open button. 

3. Click the [✔Save Config] button to save your favicon. 

Note: Magento does not convert an image from other file formats to an appropriate one; 
therefore, the store administration needs to perform the file conversion prior to 
uploading an image file. 
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40 Alternate Media Storage: Content Delivery 
Network and Database 

Magento Enterprise Edition enables you to store media files in a database on a database server or in a 

Content Delivery Network (CDN), as opposed to storing them on the file system of the web server. The 

advantage of this feature is that it minimizes the effort required to synchronize media when multiple 

instances of the system that are deployed on different servers need to access the same images, CSS files, and 

other media files. 

This feature was introduced in Version 1.10 of the Magento Enterprise edition. 

Note: CDN as alternate media storage is implemented as a support option only, not as a 
full integration with a specific CDN. You must choose and configure a CDN on 
your own. 

40.1 Using a Database as Alternate Media Storage 

By default, all images, compiled CSS files, and compiled JavaScript files of the Magento instance are 

stored in the file system on the web server. You can choose to store these files in a database on a 

database server. One advantage of this approach is the option of automatic synchronization and 

reverse synchronization between the web server file system and the database. You can use the 

default database to store media or create a new one. To be able to use a newly created database as 

media storage, you must add information about it and its access credentials to the local.xml file.  

To switch to using a database as media storage or change to another database, do the following. 

This configuration is done at the global level. 

1. Navigate to System > Configuration > ADVANCED > Advanced > System > Storage 
Configuration for Media.  

2. In the Media Storage drop-down menu, select Database. The Select Media Database drop-down 
menu and the Synchronize button appear. In the drop-down menu, all the databases that are 
specified in the local.xml file are listed. 

3. In the Select Media Database drop-down menu, select the database you want to use. 

4. Click the Synchronize button to transfer the existing media to the newly selected database. 

Accessing Media from a Database 

When the customer opens the store page, its browser requests the HTML code and the media 

specified in the HTML code from the Magento system. The system searches the requested media in 

the file system and passes it to the browser, if it is found. If the system does not find the media in the 

file system, it requests the media from the database specified in the settings, places the media to the 

file system, and sends it to the customer's web browser.  
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To get the files from the database to the file system on the web server a PHP script is used. When 

the browser requests media from the web server, there are two alternatives of when a PHP script is 

run:  

1. If web server rewrites are enabled in the Magento system and supported by the server, the PHP 
script is run only when the requested media is not found in the web server file system.  

2. If web server rewrites are disabled in the Magento system or not supported by the server, the 
PHP script is run in any case, even when the required media exists in the file system of the web 
server. 

Note: You can configure web server rewrites in System > GENERAL > Web > Search 
Engine Optimization > Use Web Server Rewrites. 

40.2 CDN as Alternate Media Storage 

Storing media files in a CDN is another alternative supported in Magento. There is no full 

integration with a specific CDN, and you are responsible for choosing and configuring a CDN on 

your own. 

After configuring the CDN, you must perform the following changes in the Admin Panel; these 

changes can be made at either the global or website level: 

1. Navigate to System > Configuration > GENERAL > Web. 

2. Change the value of the Base Media URL and Base JavaScript URL fields in the Unsecure and 
Secure field groups. Change the value of the Base Skin URL field if you want skins to be stored 
on the CDN as well.  

Accessing Media from a CDN 

When a CDN is selected as media storage, all paths to media on the web store pages are changed to 

paths to the CDN.  

Retrieving media that is stored in a CDN works as follows: When a customer opens the web store 

page, the browser addresses the CDN with the request to acquire some media files, such as images. 

If the CDN does not yet have these images in its storage, it requests them from the server, and 

provides images to the customer's browser. If the CDN already has the required images in storage, it 

simply serves the requested images to the customer's browser.  

Important Note: When a CDN is used as media storage, JavaScript may not function 
properly if the CDN is not in your subdomain. This is a browser security feature.  
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41 Full-Page Caching 
Full-page provides quicker loading time for frontend pages by caching the entire contents of pages. Magento 

caches category, product and CMS pages. As a general concept, caching improves response time and 

reduces server load.  

Chapter Quick Reference 

The table below lists some of the most common tasks for using EE’s full-page caching and where to go in the 

Admin Panel to perform them. The sections that follow provide step-by-step instructions on each. 

TASK ADMIN MENU 

To configure the page cache System > Configuration > System tab 

Full Page Cache Settings panel 

To configure auto generation of the 

page cache 

System > Configuration > System tab 

Full Page Cache Auto Generation 

To enable/disable the page cache System > Cache Management 

Action: Disable/Enable 

To manually clear the page cache System > Cache Management 

Action: Refresh 

41.1 Implementing Full-Page Caching 

When page caching is enabled, rather than generating each page each time a page is visited—

running block code and retrieving page information from the database—the fully generated page 

can be stored after the first page visit or even pre-generated and stored. The cached content is then 

used to process the same requests from other visitors. After a page is cached, it takes less time to 

open it again in the browser. 

For the purposes of caching, visitors to your website fall into the following categories: 

 Non-sessioned visitors – Visitors who are just browsing a site. 

 Sessioned visitors – Visitors who interact with a store by comparing products or adding 

products to the shopping cart and therefore have a session ID. 

 Customers – Logged-in visitors who have a relation to a customer group which can affect 

prices. 

Most visitors to any website are non-sessioned, so the cache is populated mostly with the content of 

pages visited by such visitors. When non-sessioned visitors browse a store, the system caches the 

content of these pages, which can be served again to other non-sessioned visitors. Cached page 

content generated by a sessioned visitor visiting a category or a product page is only available for 

the same sessioned visitor. 

In the current version of Magento Enterprise Edition, the whole category, product, or CMS page 

content is cached including the static and dynamic blocks after a shopper visits a page for the first 

time. When the content of a dynamic block on a cached page changes, the cached page is 

retrieved, the dynamic block is overwritten, and the changed page is re-cached. 
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To configure full-page caching: 

The Site Administrator has some control over how much site content is cached. These settings 

control the page cache that is generated after a visitor visits a page for the first time. Pages that are 

never visited are not cached. 

1. Choose System > Configuration. Select the System tab on the left. 

2. In the Full Page Cache panel, you can set the following values: 

 Cache Lifetime (minutes) – For versions EEv1.8 and older. Determines the number of 

minutes after which the page cache will be removed. A new page cache will be created the 

next time a visitor visits the page after the previous cache has been removed. 

 Maximum Allowed Page Depth – Determines the number of layered navigation filters, or 

parameters that can be applied in order for a page to be cached. For example, each layered 

navigation filter applied to a page is another parameter. If the page depth is limited to two, 

each filter will be cached, as well as any combination of two filters. However, combinations 

of three or more filters will not be cached. This allows control over the number of cached 

files that will be stored. 

 Enable Cache For Not Default Currencies – Determines whether pages containing 

currencies other than the default currency will be cached.  

o Yes – Enables page caching for all currencies in the store’s allowed currency list (as 

set in System > Configuration > Currency Setup). Each allowed currency represents 

another variant of the same page. When enabled, this option greatly increases the 

cache storage size. 

o No – Only pages for the default currency will be cached. 

3. Click the [✔Save Config] button to save your settings. 

To enable and configure full-page cache auto generation: 

Magento’s page cache is typically visitor generated, meaning that pages are cached after they’re 

visited the first time. When a site first goes live, or after large numbers of content changes, you may 

want to force the cache to re-generate itself fully. 

Magento’s Full Page Cache Auto Generation functionality generates the page cache by crawling the 

website, rather than by waiting for visitors to click to each page. This creates more cached pages 

than does visitor-generated page caching, because pages are cached even if they are not visited. 

Auto-generating the page cache ensures that the initial visitor to a page avoids the longer load time. 

It can be a very resource intensive process, however, and should not be done during high traffic 

times on your site.  

1. Choose System > Configuration. Select the System tab on the left. 

2. In the Full Page Cache Auto Generation panel, you can set the following values: 

 Enable Pages Cache Auto Generation  
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o Yes – Enables this feature. This does not cause the page cache to be auto-

generated, however. To start the auto-generation process, enable it here and then 

go to the Cache Management screen (System > Cache Management) and flush the 

Magento cache there. This action will trigger the auto-generation process. 

o No – The page cache will not be generated by a crawler and will be generated only 

as visitors visit each page on your site. 

 Crawler Thread Number – Determines the number of parallel requests during this process. 

The crawler class that emulates the first visit to a page can work in a multi-thread mode. A 

higher number of threads will reduce the amount of time required to cache all pages; 

however, it will also consume more system resources. Be careful with this option. 

Depending on your hardware and server configuration, it is recommended that you use no 

more than one to five parallel threads. 

 Generate Pages Cache For Not Default Currencies – Determines whether pages containing 

currencies other than the default currency will be cached.  

3. Click the [✔Save Config] button to save your settings. 

Because this feature can be so resource intensive, it is recommended that you enable it only when 

needed, and that you flush the Magento cache to trigger the auto-generation process. Then you can 

disable it until the next time you want to fully regenerate the page cache. 

To enable/disable page caching: 

Full-page caching is enabled by default. You can disable and re-enable it as you need. It’s generally 

a good idea to disable page caching when a site is in development and to re-enable it when the site 

goes live. 

1. To disable and/or re-enable full-page caching, go to System > Cache Management.  

2. Select Page Cache in the Cache Storage Management grid. 

3. Select Enable or Disable from the Action drop-down menu in the top right of the grid. 

To manually clear the page cache: 

After making changes to products or CMS pages and blocks, you may want to clear the page cache 

in order to force the updates to appear. If you’ve enabled page cache auto generation refreshing, 

then the page cache also triggers the auto-generation process.  

1. To refresh the page cache, go to System > Cache Management.  

2. Select Page Cache in the Cache Storage Management grid. 

3. Select Refresh from the Action drop-down menu in the top right of the grid. 
The page cache will be cleared and will begin to be regenerated as shoppers visit pages on the 
website.
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PART VIII: ADVANCED MARKETING AND PROMOTION FEATURES 

42 Rich Merchandising Suite (RMS) 
This chapter introduces Magento Enterprise Edition’s Rich Merchandising Suite (RMS) of features. 

42.1 Targeted Marketing Using Customer Segments 

Customer Segments allow you to dynamically identify customer groups based on specific 

characteristics, from address information, order history, shopping cart contents, and more and to 

dynamically target different content and promotions to those groups.  You can then generate reports 

and export the customers, as well as optimize marketing initiatives based on those segments 

including Shopping Cart Price Rules and Banners. Customer Segment information constantly 

refreshes, so that customers can become associated and de-associated to a Segment as their 

information changes. 

In Magento Enterprise Edition 1.12 and later, Customer Segments can be created for both guest 

customers and logged-in customers.  

To create a new Customer Segment 

1. Navigate to Customers > Customer Segments.  

2. After clicking Add Segment configure the segment with the following options: 

 General Properties tab: 

o Segment Name - This name is for internal purposes. 

o Description – This description is also for internal purposes, and provides an 

optional space to enter more detailed information than can be contained in the 

Segment Name. 

o Assigned to Website - A Customer Segment can only be assigned to one Website, 

because the conditions can use information that is specific to each Website. To use 

the same conditions on multiple Websites, you must create multiple Segments. 

o Status - Select Active to enable this Segment. Price Rules and Banners associated to 

this Segment can be unassociated by selecting Inactive, without having to edit the 

Price Rule or Banners. 

o Apply to (available in Magento Enterprise Edition v1.12 and later) – Defines the 

customer types to which the segment is applied. The selection influences the set of 

conditions available for creating the segment. The option cannot be changed after 

the segment is saved. Possible options: 

o Visitors and Registered Customers – The segment will be applied to 

shoppers who are logged in as well as those who are not logged in. 
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o Registered Customers – The segment will be applied only to shoppers who 

are logged in. 

o Visitors – The segment will be applied to shoppers who are not logged in. 

 

 Conditions tab (available in Magento Enterprise Edition v1.12 and later): This tab becomes 

available after you save the segment. In the Conditions tab, you can define the rules by 

which customers will be associated to this Segment. These rules are defined in a similar 

manner to those of Shopping Cart and Catalog Price Rules, with different options. There are 

5 main characteristics upon which these rules can be based. 

o Customer Address - You can define any of the address fields, such as city or 

country. Any address in a customer’s address book can match these conditions for 

the customer to match. Or, you can specify that only the default billing or shipping 

addresses can be used to match a customer. . Available only for customers who are 

logged in. 

o Customer – Miscellaneous customer information can be defined, including 

Customer Group, name, email, newsletter subscription status, and Store Credit 

balance. . Available only for customers who are logged in. 

o Shopping Cart – Shopping Cart characteristics can be based on either quantity (line 

items or total quantity) or monetary amount (grand total, tax, gift card, etc.) 

currently in the shopping cart. 

o Products - You can define products that are in the shopping cart or wishlist, or that 

have previously been viewed or ordered. You can also set a date range for when 

this occurred. The products are defined using product attributes. There is a new 

setting in the attribute management page called Use for Customer Segment 

Conditions, which must be set to Yes for the attribute to appear in this section. 

o Sales - Order characteristics for past orders can be defined based on the 

billing/shipping address in the order, the total or average amount or quantity of the 

orders, or the total number of orders. You can also set a date range for when this 

occurred, and the order status of the orders that match these conditions. Available 

only for customers who are logged in. 

Note: Conditions that are set for shoppers who are not logged in stop working when 
these shoppers log in. 

 Matched Customers - This tab appears only for previously created Segments. It will be 

discussed in the Reports section below. 
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Reporting Based on Customer Segments 

Reports for Customer Segments can be generated in two locations. You can navigate to Customers > 

Customer Segments, and select an existing Customer Segment from the grid. Then, click on the 

Matched Customers tab. This tab will only exist for previously created Customer Segments, so it will 

not be available when creating a new Segment. The number of customers that currently match the 

conditions of this Segment will be noted in the tab in parentheses. To refresh the Segment data, and 

get the most up-to-date list of matched customers, click Match Customers at the top of the page. The 

list of customers can be exported to CSV or Excel by using the Export to drop-down menu, and 

clicking Export. The second location where a report can be generated is Reports > Customers > 

Customer Segments. Select an existing Customer Segment. The report can be generated using the 

same Export options. In future releases, this report will also enable you to quickly cross-reference 

Customer Segments. 

Promotions Based on Customer Segments 

In order to use these Customer Segments for marketing purposes, you can associate them to 

Shopping Cart Price Rules or Banners. 

 Shopping Cart Price Rules – To associate a Segment to a Shopping Cart Price Rule, navigate 

to Promotions > Shopping Cart Price Rules, click Add New Rule or select an existing 

Shopping Cart Price Rule from the grid, click the Conditions tab, and select Customer 

Segment as a condition in the drop-down menu. You can specify the Segment to use from a 

grid listing all of the existing Segments. 

 Banners – To associate a Segment to a Banner, navigate to CMS > Banners, click Add 

Banner or select an existing Banner from the grid, and select Specified from the Customer 

Segments drop-down menu. This will open a multi-select menu including all existing 

Segments. You can associate multiple Segments to a Banner. 

42.2 Creating Dynamic Product Relationships  

Rule-Based Product Relations offer further targeted merchandising to your customers. You will be 

able to suggest products for customers through automated rule-based selection of products to be 

used for related items, up-sells, and cross-sells.  

To create a new Rule-Based Product Relation: 

1. Choose Catalog > Rule-Based Product Relations.  

2. After clicking Add Rule, configure the Rule-Based Product Relation using the following options: 

 Rule Information 

o Rule Name – This is for internal purposes. 



Rich Merchandising Suite (RMS) 

380 

o Priority – When multiple rules overlap on a product page or the shopping cart, the 

priority will determine the sort order of each group of displayed products. For 

example, if Rule 1 (with priority 1) displays three products, and Rule 2 (with 

priority 2) displays five products, and both rules apply to the same product’s up-

sells list, then the three Rule 1 products will always display before the five Rule 2 

products. However, the sort order of the Rule 1 products relative to one another is 

random. Additionally, if there is a mix of rules and manually added products, the 

manually added products will always display before the rule-based products. 

Products can be manually added by navigating to Catalog > Manage Products, 

clicking Add Product or selecting an existing product from the grid, and selecting 

the Related Products, Up-sells, or Cross-sells tab. From these tabs, you can 

manually select which specific products will be displayed. 

o Status – Select Active for this rule to apply. 

o Apply To – Select whether this rule will apply to a product’s Related Products, Up-

sells, or Cross-sells. 

o From/To Date – You can select a date range in which the rule will automatically 

become enabled and/or disabled. 

o Result Limit – You can set a limit for the number of products that will be displayed. 

The maximum number is 20, but you can set a smaller limit. For example, if you 

are creating an Up-sell rule, and there are 40 products which match the conditions 

in the Products to Display tab, you can set the limit to 10. This will automatically 

choose 10 of those 40 products, which will then rotate through the Up-sells block. 

The advantage to setting a lower limit is that it reduces the processing time. 

 Products to Match - In this tab, set the product conditions to determine which products will 

have this rule applied to it. These conditions are defined in the same manner as Catalog 

Price Rules, whereby the products are defined using product attributes. There is a new 

setting in the attribute management page called Use for Target Rule Conditions, which must 

be set to Yes for the attribute to appear in this section. 

 Products to Display – In this tab, set the product conditions to determine which products 

will be displayed in the Related Products, Up-sells, or Cross-sells blocks. The conditions are 

almost identical to those of the Products to Match tab, with one additional option available. 

You can determine which products to display based on a price relationship with the 

Matched Product. For example, if you want to display Up-sell products which are at least 

twice the price of the Matched Product, you can show only products which are 200% or 

more of the Matched Product price. 
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42.3 Automatically Sending Reminder Emails  
to Customers 

The automated reminder email feature allows you to set your store to automatically send reminder 

emails at time interval you determine to customers who’ve added something to their shopping cart 

or wishlist but have not yet purchased. Emails can be triggered when it’s X days after the shopping 

cart or wishlist was abandoned or you can also add other conditions like total cart value, quantity, 

items in cart, whether the wishlist was shared with anyone or several other conditions. Emails can 

go out simply as reminders to revisit the site or can have a coupon code associated with them. One 

of the most powerful features is that unique coupon codes can automatically be generated for each 

email so that you have complete control over the offers you associate with reminder emails. 

To enable and configure automated email reminders: 

1. Choose System > Configuration. Select the Promotions tab on the left. 

2. In the Automated Email Reminder Rules panel, you can set the following values: 

 Enable Reminder Emails - Enables automated email reminders. If this is set to No, all of the 

following values will be ignored. 

 Frequency - Indicates the frequency with which Magento should check for new customers 

who qualify for the automated email reminders. Choices are Minute Intervals (every X 

minutes), Hourly (every hour), or Daily. 

o Interval or Minute of the Hour should be set if Minute Intervals or Hourly are chosen. 

 Start Time - Time of day of the first check. Specified in 24-hour time based on the system 

time on your server. 

 Maximum Emails per One Run - Enables to you limit the number of emails sent at the same 

time in any scheduled block. 

 Email Send Failure Threshold - The number of times the reminder attempts to send out 

notifications to specific email address and fails. When the value is set to 0, there is no 

threshold, and notifications will keep being sent despite any failures. 

 Reminder Email Sender - Sets which store contact (as previously set in System > 

Configuration > Store Email Addresses tab) will be associated with the email on the From 

line. 

3. Click the Save Config button to save your settings 

To create an email template for your automated email reminders: 

1. Choose System > Transactional Emails. 

2. Click the [+Add New Template] button 

3. The default email template for reminder emails is called “Rule Reminder.”  Just to get started, 

select this email template from the Template drop-down menu and click the [✔Load Template] 
button. The contents of that template will appear in the “Template Information” panel below it. 
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4. You will see that you have the following variables available to you in email reminders. These 
variables are unique to the Rules Reminder email template. The promotion information in these 
variables is determined by the automated email reminder rule you set up and the coupon 
information in these variables is determined by the shopping cart price rule you associate with 
the automated email reminder rule. 

 promotion_name 

 promotion_description 

 coupon.getCode() 

 coupon.getUsageLimit() 

 coupon.getUsagePerCustomer() 

5. See “Customizing Transactional Emails, page 156, for more information on the basics of editing 
transactional emails. When you’re done editing the reminder email template to fit your brand 

and needs, give it a name and click the [✔Save Template] button. 

To create a rule for your automated email reminders: 

Before setting up an automated email reminder rule, make sure you have a shopping cart price rule 

set up that defines the promotion being offered. 

1. Choose Promotions > Automated Email Reminder Rules. 

2. Click the [+Add New Rule] button. 

3. In the Rule Information tab, you can set the following values: 

 Rule Name - Name of automated reminder rule, used internally 

 Description - Description of automated reminder rule, used internally 

 Shopping Cart Price Rule - This is the promotion rule (created in Promotions > Shopping 

Cart Price Rules) that this reminder will advertise. Reminder emails may promote a 

shopping cart price rule with or without coupon. If a shopping cart price rule defines an 

auto-generated coupon, this reminder rule will generate a random, unique coupon code for 

each customer. 

 Assign to Websites - Select which websites should receive automated reminder emails 

based on this rule. 

 Status - Active or inactive. If status is inactive, then all other settings will be ignore and the 

rule will not be triggered. 

 Active From - Starting date for this automated reminder rule. If no date is specified, then the 

rule will be active immediately. 

 Active To - Ending date for this automated reminder rule. If no date is specified the rule will 

remain active indefinitely. 

 Repeat Schedule - Number of days before the rule is triggered again and the reminder email 

sent again if the conditions are still met. To trigger the rule more than once, enter the 

number of days of each check separated by commas. For example, enter “7” to have the 

rule re-triggered again 7 days later; enter “7,14” to have the rule re-triggered 7 days and 

then again 14 days later. 
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4. In the Conditions tab, using the standard Magento interface for promotions, you can set the 
following values: 

 Rules can be based either on Shopping Carts, Wishlists or both. 

 For Wishlists, available trigger conditions include: number of days abandoned, sharing, 

number of items, specific items in Wishlist. 

 For Shopping Carts, available trigger conditions include: number of days abandoned, if a 

specific coupon code has been applied, line items quantity, items quantity, total, if items are 

virtual, and specific items in the shopping cart. 

5. In the Emails and Labels tab, you can set the following values: 

 Assign email templates to each store - Each store in your Magento installation that you have 

access to will be listed here. Select the email reminder template you would like to go out to 

each. Leave the value here as “—Not Selected— “ if you don’t want to send this rule’s 

reminder email to the customers of that store. 

 Rule Title (default for all stores) - Rule title is accessible in email templates as a variable. 

 Rule Description (default for all stores) - Rule description is accessible in email templates as 

a variable. 

 Rule Title (per store view) - Per store view override of the default title value supplied above. 

 Rule Description (per store view) - Per store view override of the default description value 

supplied above. 

6. Click the Save button to save your rule. 

Important Note: For automated email reminders to be sent as configured in the Admin 
panel, the crontab service (for UNIX/BSD/Linux ) or the Scheduled Tasks service 
(for Windows) should be configured to run the necessary script periodically. You 
can find more details at: 
 http://www.magentocommerce.com/wiki/1_-
_installation_and_configuration/how_to_setup_a_cron_job 

http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/how_to_setup_a_cron_job
http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/how_to_setup_a_cron_job
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43 Gift Cards 
This chapter introduces physical and virtual Gift Card products that can be purchased in the site, and Gift 

Card Accounts which hold balance that can be redeemed during checkout. These features are available in 

Magento Enterprise Edition.  

43.1 Configuring Gift Cards  

There are some configuration settings that must be completed relating to Gift Card Accounts.  

To configure gift cards: 

1. Choose System > Configuration and select the Gift Cards tab in the left column.  

2. These will be the default settings for all Gift Card products, and most can be edited on a per 
product level. The following settings are available: 

 Gift Card Notification Email Sender - Select the sender of the email that will be sent when a 

Gift Card Account is created. This only applies to accounts created automatically from the 

purchase of a Gift Card product, and does not apply to accounts created manually by an 

administrator. The configuration of emails sent for accounts created by an administrator will 

be described later in this chapter. 

 Gift Card Notification Email Template - Select the template of the email that will be sent 

when a Gift Card Account is created. 

 Redeemable - Determines whether or not the accounts that will be created for Gift Cards 

will be redeemable (able to be transferred to Store Credit) upon creation.  

 Lifetime (days) - Determines the expiration date for all accounts. The accounts will expire X 

number of days after the Gift Card is purchased. If you do not wish to set a default lifetime, 

leave this field blank. 

 Allow Gift Message - Determines whether the customer purchasing the Gift Card can add a 

message that will be sent to the recipient of the card (via email and/or with the shipment of 

the physical Gift Card). 

 Gift Message Maximum Length - Determines the maximum allowed length of gift messages. 

 Generate Gift Card Account when Order Item is - Determine the point at which an account 

is created for Gift Card products. If you select Ordered, the account will be created when 

the order containing the Gift Card is completed. If you select Invoiced, the account will be 

created when the order containing the Gift Card has been invoiced.  

Gift Card Code Pool 

The Code Pool is a pre-generated set of unique Gift Card codes in a specific format. Codes from the 

Code Pool are used each time a Gift Card Account is created. It is the administrator's responsibility 

to assure there are enough free codes in the code pool for the Gift Cards. Make sure to generate a 

Code Pool before starting to offer Gift Card products. 
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To generate a new Code Pool: 

1. Navigate to System > Configuration and select the Gift Card tab in the left column. 

2. In the Gift Card Account General Setting panel, set the following settings: 

 Code Length - Determines the number of characters that will be used in all Gift Card codes, 

not including the prefix, suffix or separators. 

 Code Format - Choose whether the code will be Alphanumeric (a mix of letters and 

numbers), Alphabetical (letters only), or Numeric (numbers only). 

 Code Prefix - Allows you to add a value that will be appended to the beginning of all codes, 

and is optional. 

 Code Suffix - Allows you to add a value that will be appended to the end of all codes, and 

is also optional. 

 Dash Every X Characters - Allows you to determine the interval at which a dash (-) will be 

inserted in all codes. If you do not want to use a dash, leave this field blank. 

 New Pool Size – Determines the number of unique codes to be generated. 

3. Click Save Config in the top right of the page to save the settings used for code generation. 

4. Click the Generate button to generate the Code Pool. 

Note: If the Code Length is not long enough to allow for generating the requested 
number of codes, an error message will be shown. 

Note: Depending on the settings and number of codes already used, Magento may 
generate fewer codes than requested. 

43.2 Gift Card Accounts 

Gift Card Accounts are entities which hold the balance of Gift Cards, and they can be used for paying in the 

store. A Gift Card Account is created for each Gift Card product purchased. 

To create a new account: 

1. Gift Card Accounts can be managed by navigating to Customers > Gift Card Accounts. This 
page contains a grid listing all existing accounts and gives you the ability to create a new 
account, or edit existing accounts.  

2. Click the Add Gift Card Account button in the top right of the page. 

3. When creating or editing a Gift Card Account, there are multiple tabs. In the Information tab, 
the following options are available: 

 Active - Determines whether or not the balance of the account can be redeemed during 

checkout. Also determines whether or not the balance of the account can be transferred to a 

customer's Store Credit. 

 Redeemable - Determines whether or not the balance of the account can be transferred to a 

customer's Store Credit. 

 Website - Determines the website in which the account can be redeemed. 
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 Balance - Determines the balance of the account. 

 Expiration Date - Determines the date on which the account expires and becomes inactive. 

This is optional, and leaving it blank will mean that the account is not set to expire. 

 In the Send Gift Card tab, the following options are available: 

o Recipient Email - Enter the email address to which an email notification of this Gift 

Card Account will be sent. This field is optional, and no email will be sent if it is 

left blank. 

o Recipient Name - Enter the name of the email recipient. 

4. When you have completed these settings, click the Save button in the top right of the page. If 
you have entered a Recipient Email, click the Save & Send Email button. The Sender and 
Template of the email that will be sent is different from that of the email sent for a Gift Card 
product. To edit the Sender and Template of this email, navigate to System > Configuration, 
click the Gift Card Accounts tab, and select the Email sent from Gift Card Account management 
section. 

After the Gift Card Account is saved, you will be redirected to the Gift Card Account grid page, and 

the newly created account will be listed. To edit any of these settings, click on the row of the 

account you wish you edit. You will be able to edit all of the same settings that you entered when 

creating the account. In addition to this, you will see the account Gift Card Code and Status in the 

Information tab (both of which are not editable), as well as a History tab which displays the balance 

history of the Gift Card Account. 

43.3 Gift Card Products 

Gift Card Products are the actual products that can be purchased in the store. There are three types 

of Gift Card Products: Virtual, Physical and Combined. 

To create a new Gift Card: 

1. Choose Catalog > Manage Products. 

2. Click Add Product in the top right of the page. 

3. Select your desired Attribute Set, select Gift Card from Product Type drop-down menu, and 
click Continue. 

4. Set the Gift Card pricing in the Prices tab. Rather than having a price field like that of a Simple 
Product, Gift Cards have a price configuration feature similar to that of the tier price feature. 
You can add additional prices by clicking the Add Amount button. Each amount added will 
appear in a drop-down menu on the frontend. Instead of using set prices, you also have the 
option of allowing the customer to specify a gift card amount into an open field. To enable this 
option, select Yes in the Allow Open Amount drop-down menu. If using this feature, you can 
set a maximum and/or minimum amount (Open Amount Min Value and Open Amount Max 
Value options) that the customer can enter into the amount field. Additionally, you can use set 
prices and open amounts concurrently. This feature will add an Other Amount option to the 
drop-down menu on the product page, which will generate an open field when selected. 

5. Set the Gift Card options in the Gift Card Information tab. The following options are available: 
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 Card Type - Determines the type of the Gift Card. The possible values are: 

o Virtual – The Gift Card information will be sent by email (the order will require the 

email address of the recipient). No shipping information will be necessary. 

o Physical – The Gift Card will be shipped (the order will require the shipping 

address of the recipient). No email will be sent to the recipient. 

o Combined – The Gift Card will be shipped and sent by email (the order will require 

both the shipping address and email address of the recipient) 

 Redeemable - Determines whether or not the account that will be created for this Gift Card 

will be redeemable (able to be transferred to Store Credit) upon creation. 

 Lifetime (days) - Determines the expiration date for Gift Card Account created for this Gift 

Card. The accounts will expire X number of days after the Gift Card is purchased. If you do 

not wish to set a default lifetime, leave this field blank. 

 Allow Gift Message - Determines whether the customer purchasing the Gift Card can add a 

message that will be sent to the recipient of the card (via email and/or with the shipment of 

the physical Gift Card). 

 Email Template - Select the template of the email that will be sent when the Gift Card 

Account is created. 

6. Fill in the remaining product information (name, SKU, categories, related products, etc.) as you 
would for a Simple Product. 

7. Click Save in the top right of the page. 

Purchasing Gift Cards 

Gift Card products have several features in addition to a typical Simple or Virtual Product. Most 

notably is the price, which is configurable. Depending on the price settings you entered in the 

Prices tab, there will either be a drop-down menu containing set prices, an open field, or a 

combination (in this case, the drop-down menu will contain an Other Amount option, which will 

create an open field when selected). All amounts are in the display currency currently used in that 

store, but the actual amount of the Gift Card is converted to the base currency once added to the 

cart.  

In addition to this is the Sender Name (and Sender Email if the Gift Card is Virtual or Combined) 

and Recipient Name (and Recipient Email if the Gift Card is Virtual or Combined). If the customer is 

logged in when viewing this page, the Sender Name (and Sender Email, if applicable) will be pre-

populated. If you have selected to allow messages, there will also be a Message text area. 

If multiple Gift Cards are purchased in one order, and the Gift Card is Virtual or Combined, then all 

the corresponding Gift Card codes will be sent to the recipient in one email. 

For all Gift Card types, the generated account codes will be shown in the order information page in 

the admin. This will allow you to retrieve the code to place it on the physical gift card, if necessary. 

If an order containing a Gift Card product is canceled or refunded, you will need to manually 

cancel the Gift Card account. You can either delete the account entirely, or simply deactivate it. 
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Paying with Gift Cards 

Gift Card accounts can be redeemed in the shopping cart, similar to the manner in which a coupon 

is applied to an order. There is a block that contains a field for entering the Gift Card code, and a 

button used to apply that account to the items in the cart. Additionally, this block contains a Check 

Gift Card status and balance link. This navigates the customer to a page where they can enter their 

Gift Card code(s) and view the remaining balance. 

Multiple Gift Cards accounts can be applied to a shopping cart. Each time a Gift Card is applied, the 

amount is displayed in the order totals block, subtracting from the grand total. The full balance of 

each Gift Card will be subtracted from the shopping cart total. Multiple Gift Cards will be applied in 

ascending order, meaning the accounts with the smallest remaining balances will be applied first, 

until the customer runs out of cards, or until the grand total becomes zero. If the grand total 

becomes zero, the last account that actually applies to the cart will receive a partial deduction, and 

any cards that have not applied to the cart will not receive a deduction. 

The actual deductions occur only once the order is placed. 

Orders paid with Gift Cards cannot be refunded. Credit Memos will not be available. To refund 

such an order, cancel it and manually increase the balance of the Gift Card, or the customer’s Store 

Credit account, appropriately. If an order is partially paid with Gift Cards, the amount paid with Gift 

Cards cannot be refunded. Again, this amount should manually be added to the Gift Card or 

customer’s account. 

Redeeming Gift Cards 

In addition to using a Gift Card balance during checkout, the balance can be transferred to a 

customer’s Store Credit (if you have enabled this feature). More information about this is available in 

“Store Credit,” page 194. 
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44 Reward Points and Loyalty Programs 
The Magento Reward Points System enables an online merchant to implement unique programs designed to 

enhance user experience and increase customer loyalty. Points are awarded based on a wide range of 

transaction and customer activities, with the ability for the merchant to control point allotment, balance, and 

expiration. Customers can redeem points toward purchases, based on a conversion rate between points and 

currency that is set up by the merchant. 

44.1 Configuring Reward Points 

There are some configuration settings that must be completed relating to Reward Points.  

To configure reward points: 

1. Choose System > Configuration and select the Reward Points tab in the left column.  

2. In the Reward Points section, the following options are available: 

 Enable Reward Points Functionality: Select Yes in order to activate this feature. 

 Enable Reward Points Functionality on Front: If this functionality is enabled, customers will 

be able to earn points through their activities, and redeem them during the checkout 

process. If disabled, only admin users will be able to assign and redeem points on behalf of 

customers. 

 Customers may see Reward Points History: If enabled, customers will be able to see a 

detailed history of each accrual, redemption, and expiration of Reward Points in the My 

Account interface. 

 Min Reward Points Balance to be able to Redeem: Requires customers to achieve a 

minimum point balance before they are able to redeem them on orders. If left blank, there 

will be no minimum limit. 

 Cap Reward Points Balance to: Prevents customers from accruing more than this maximum 

points balance. If left blank, there will be no maximum limit. 

 Reward Points Expire (in days) : Sets a limit in which customers must redeem Reward Points 

before they expire. Each batch of points which are earned during separate activities will 

have a separate expiration, and the expiration limit will display for each batch in the 

Reward Points history in the frontend (if enabled) and admin. If left blank, there will be no 

expiration limit. 

 Reward Points Expiry Calculation: Selecting Static defines the date of expiration at the time 

when the points are earned based on the expiration limit defined above. If the expiration 

limit is changed, the expiration date for existing points will not change. Selecting Dynamic 

does not define a date of expiration. Instead, points will periodically be checked for 

expiration. This allows for the editing of the expiration limit to affect existing points. 

 Landing Page: Defines the CMS page which will be used to display more information to 

customers about Reward Points. A default template for this CMS page is included, and links 

to this CMS page appear at various frontend locations where points can be earned. 
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In the Acquiring Reward Points by Customers section, the amount of Reward Points earned for 

various customer activities is defined. If points are assigned for any of these activities, a message will 

be displayed on the frontend in the corresponding section informing customers about the amount of 

points available for completing the action. Points earned for placing orders or qualifying for 

Shopping Cart Price Rules are not defined in this section, and will be discussed in more detail later 

in this chapter. The following options are available: 

 Registration: Defines the amount of points earned when a customer registers. 

 Newsletter Signup: Defines the amount of points earned when a customer signs up for the 

newsletter. This is not available for guests who sign up for the newsletter. Additionally, if a 

customer unsubscribes, and subscribes again, they will not receive points a second time. 

 Converting Invitation to Customer: Defines the amount of points earned for the inviter when 

an invitation has been accepted by the invitee, resulting in the creation of a new customer 

account. 

 Invitation to Customer Conversion Qty Limit: Limits the number of invitation conversions 

that can be used to earn points per inviter. If left blank, there will be no maximum limit. 

 Converting Invitation to Order: Defines the amount of points earned for the inviter when an 

invitee has accepted the invitation and placed an initial order. 

 Invitation to Order Conversions Qty Limit: Limits the number of order conversions that can 

be used to earn points per inviter. If left blank, there will be no maximum limit. 

 Invitation Conversion to Order Reward: Indicates how often a customer can earn reward 

points when invitees make purchases. 

o First: The customer will receive reward points only for the first invoiced order 

placed by the invitee-customer. Even if more than one invitee registered and placed 

orders, only the amount of the first order will be converted to reward points and 

granted to the customer.  

o Each: The customer will receive reward points for each invoiced order placed by 

the invitee-customer. Reward points will be given according to the reward point 

exchange rates set for the required combination of a website and a customer group.  

 Review Submission: Defines the amount of points earned when a review has been 

submitted and approved by an admin user. 

 Rewarded Reviews Submission Qty Limit: Limits the number of reviews that can be used to 

earn points per customer. If left blank, there will be no maximum limit.  

 New Tag Submission: Defines the amount of points earned when a tag has been submitted 

and approved by an admin user. 

 Rewarded Tag Submission Qty Limit: Limits the number of tags that can be used to earn 

points per customer. If left blank, there will be no maximum limit. 

In the Email Notification Settings section, there are two email notifications related to Reward Points 

which can be managed: balance updates and expiration notifications. The following options are 

available: 
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 Email Sender: Determines the sender of both the balance update and expiration notification 

emails. 

 Subscribe Customers by default: Determines the default subscription status of customers for 

both balance update and expiration notifications emails. 

 Balance Update Email: Determines the template of the email that customers receive when 

there is an update to their points balance. 

 Reward Points Expiry Warning Email: Determines the template of the email that customers 

receive when the expiration warning limit has been reached for a batch of points. 

 Expiry Warning before (days) : Defines the number of days prior to the expiration of point at 

which the expiration notification will be sent. If left blank, or if the warning limit is greater 

than the expiration limit (defined in the section above), no expiration notifications will be 

sent. 

Reward Exchange Rates 

Reward Exchange Rates determine the amount of points that are earned for orders placed based on 

the order amount, as well as the amount of monetary credit available when points are redeemed in 

an order. Different exchange rates can be applied to different websites and different customer 

groups.  

To manage exchange rates: 

1. Choose Customers > Reward Exchange Rates. This page contains a grid listing all existing 
exchange rates.  

2. To create a new exchange rate, click Add New Rate in the top right of the page. If multiple 
exchange rates apply to the same customer due to an overlap of websites and/or customer 
groups, exchange rates will use the following priority: 

a. Specific website and specific customer group 

b. All Websites and specific customer group 

c. Specific website and All Customer Groups 

d. All Websites and All Customer Groups 

 The Direction determines which type of transaction the exchange rate will define.  

 Points to Currency defines the amount of points that can be redeemed for an amount of 

monetary credit towards an order.  

 Enter the amount of points in the first Rate field, and the amount of monetary credit in the 

second Rate field. When converting points to currency, the amount of points cannot be 

divided. For example, if 10 points converts to $2.00, points must be redeemed in groups of 

ten. Therefore, 25 points would redeem for $4.00, with 5 points remaining in the customer’s 

balance. 
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 Currency to Points defines the monetary amount of an order that will earn the customer an 

amount of points. Enter the monetary amount in the first Rate field, and the amount of credit 

in the second Rate field. When converting currency to points, the amount of points again 

cannot be divided, and any currency remainder will be rounded down. For example, if 

$2.00 converts to 10 points, points will be earned in groups of $2.00. Therefore, a $7.00 

order would earn 30 points, and the remaining $1.00 would be rounded down. The 

monetary amount of the order is defined as the amount which the merchant receives, or the 

grand total minus shipping, tax, discounts, store credit, and gift cards. The points will be 

earned the moment when there are no non-invoiced items in the order (all items are either 

paid or canceled). If an admin user does not want to allow customers to earn Reward Points 

for canceled orders, those points can be manually deducted via the Manage Customers 

page. This will be discussed in more detail later in the chapter.  

For either Direction, the monetary amount will equal the base currency of the website. 

44.2 Rewarding and Redeeming Reward Points 

Shopping Cart Price Rules  

Points can be rewarded to customers who apply for Shopping Cart Price Rules. They can be 

rewarded as the only action of the price rule, or in conjunction with a discount. In order to add 

Reward Points to a price rule, navigate to Promotions > Shopping Cart Price Rules and select an 

existing price rule or click Add New Rule. Select the Actions tab in the left column, and enter the 

amount of points in the Add Reward Points field. When the price rule is activated, a message in the 

shopping cart will alert customers about the amount of points they can earn by placing the order. 

Customer Balances 

Reward Points balances can be managed by admin users per customer. To do so, navigate to 

Customers > Manage Customers, select a customer from the grid, and select the Reward Points tab 

in the left column. From this view, the admin user can view and edit (add to or subtract from) the 

customer’s points balance per website, and edit the customer’s email notification status. 

Additionally, this view includes a detailed history of each accrual, redemption, and expiration of 

points, including timestamp, exchange rate, and reason for balance change. 

If enabled on the frontend, customers can also view the details of their points balance. In the My 

Account interface, there is a Reward Points tab. This tab contains information including the balance, 

current exchange rate, maximum and minimum limits, subscription status (with ability to edit), and 

(if enabled) balance history. There is also a link to the Rewards Points landing page. 
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Redeeming Points 

Points can be redeemed by admin users and (if enabled) customers during the checkout process. In 

the Payment Method section, a Use my Reward Points check box will appear above the enabled 

payment methods. The available points and monetary exchange rate will be included. If the 

available balance is greater than the order grand total, no additional payment methods will be 

required. The amount of Reward Points applied to the order will display among the order totals, 

subtracting from the grand total, similar to Store Credit and Gift Cards. If Reward Points are used in 

conjunction with Store Credit and Gift Cards, Reward Points will be deducted first, and Store Credit 

or Gift Cards will only be deducted if the order total is greater than the redeemable amount of 

Reward Points.  

Refunding to Reward Points  

Orders placed with Reward Points can be refunded to the Reward Points balance up to the amount 

redeemed in the order. On the New Credit Memo page, there is a field in which the amount of 

points that will be applied to the customer’s balance can be entered. By default, the value will be 

pre-populated with the full amount of points used in the order. 
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45 Private Sales 
This chapter concludes the discussion of Private Sales functionality, which consists of the following: 

 Invitations: Email messages sent out with a link to create an account in the store. If desired, 

the ability to create an account can be restricted to those who receive an invitation. 

 Events: Sale restrictions based on a start and end date. Adding to cart will only be possible 

between these dates. 

Related to Private Sales functionality are the following features, which are discussed in “Controlling Website 

Access,” page 347: 

 Category Permissions: Feature enabling the administrator to disable browsing, price 

displays, or adding to cart for different categories based on customer groups. 

 Website Restrictions: Feature enabling the administrator to disable access to the website by 

redirecting to a landing page, login page or registration page. 

45.1 Invitations  

There are some configuration settings that must be completed to enable Invitations.  

To enable and configure invitations: 

1. Choose System > Configuration and select the Invitations tab in the left column. 

 Enable Invitations Functionality: Determines whether the Invitations module is enabled. 

 Referred Customer Group: Determines the customer group of the invitee. Same as Inviter 

means invitees will automatically have the same customer group as the customers who 

invited them. System Configuration Default means invitees will automatically have the 

customer group that is selected as the default. This setting can be changed by clicking on 

the Customer Configuration tab in the left column, selecting the Create New Account 

Options section, and editing the Default Group drop-down menu. 

 New Accounts Registration: Determines whether the ability to create a new account is By 

Invitation Only, or Available to All. If you select the former, the new account registration 

section will not appear on the login page, and invitees must follow the link in the Invitation 

email in order to create an account. 

 Allow Customers to Add Custom Message to Invitation Email: Determines whether there 

will be a field in the Invitation form in which the inviter can add a custom message which 

will be sent to the invitee via email. This does not affect the administrator's ability to add a 

message to an Invitation. 

 Max Invitations Allowed to be Sent at One Time: Determines the maximum number of 

invitations that the inviter can send at once. A different invitation is sent out to each email 

address that the inviter includes in the form. This limit will help prevent inviters from 

bottlenecking your server by sending out large numbers of Invitations at once, and reduces 

the ability to use Invitations for spamming. 



 Private Sales 

 395 

 Customer Invitation Email Sender: Determines the sender of the email that invitees receive 

when an Invitation email is sent. 

 Customer Invitation Email Template: Determines the template of the email that invitees 

receive when an Invitation email is sent. 

2. When you have completed these settings, click Save Config in the top right of the page. 

Invitations Frontend 

If enabled, customers can send and view Invitations from My Account. There will be a My 

Invitations tab in the left column. The page shows a list of all past Invitations sent, including the 

email address of the recipient, and the current status (Sent, Accepted, or Canceled). It also includes 

a Send Invitations button, which redirects to the Invitation form. This form contains a field for the 

email address of each recipient (the number of these fields is determined in the configuration above) 

and (if enabled) a message text area. When the Send Invitations button is clicked in the form page, 

the invitation email will be sent to the recipients. If a recipient email belongs to an existing customer 

in the system, the invitation email will not get sent to that email, and no record will be created in 

the admin. Customers can also send invitations using the Send Invitations link in the store header. 

The invitation email includes a link to the customer account registration form on the Magento 

frontend. The customer email field will be auto-populated. 

Invitations Backend 

The admin has the ability to send and view Invitations as well. To do so, navigate to Customers > 

Manage Invitations. This page contains a grid listing all Invitations which have been sent. If one 

Invitation was sent to multiple recipients, a separate record will be created for each recipient. 

To create a new Invitation, click Add Invitations in the top right of the page. Similar to the customer 

Invitation feature, there will be an email and message field. However, there is an unlimited number 

of recipient email addresses that can be entered into the email text area, and there will always be a 

message text area regardless of the configuration setting. In addition to these fields, you can select 

from which Store View the Customer Invitation email will be sent (and where the link in the email 

will redirect), and to which customer group the invitee will belong if they create an account (this 

supersedes the configuration setting). When you have completed the Invitation form, click Save in 

the top right of the page. The Customer Invitation email will be sent and you will be redirected to 

the Invitation grid. 

To view past Invitations, click on a record in the grid. This page will show some basic information 

about the Invitation, such as the timestamp it was sent, the email address of the recipient, the 

current status (Sent, Accepted, or Canceled), the customer group of the invitee, and the link which 

was sent to the invitee. The message, if one was included, will be displayed in a text area, allowing 

you to edit the message, save it by clicking the Save Invitation Message button, and resend the 

Invitation by clicking the Resend button. To cancel the invitation, click the Cancel button. This will 

change the status to Canceled and the link in the email will no longer redirect to the customer 

account registration form. 
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If the invitee has created a customer account, the account details will be listed in this page 

(including a link to the customer account in the admin). If the inviter was a customer (the invitation 

was not sent by an administrator), the account details will be listed in this page as well (including a 

link to the customer account in the admin). 

Lastly, the status history can be viewed by clicking the Status History tab in the left column. This 

will show the timestamp of each status change (Sent, Accepted, or Canceled). 

Invitations Reports 

You can view several reports about Invitations.  

To view invitation reports: 

1. Choose Reports > Invitations. 

2. The following reports are available: 

 General: This report summarizes Invitation information for the designated scope and period 

of time. The scope can be defined in the Show Report for drop-down at the top of the page. 

There will be one line for each Period. A Period can be a Day, Month, or Year, and is 

defined in the Show by drop-down at the top of the page. The number of Periods in the 

report depends on the date range designated at the top of the page. For each Period, you 

can see the total number of Invitations sent, accepted, and canceled, as well as the 

percentage of sent Invitations which have been accepted, and the percentage of sent 

Invitations which have been canceled. 

 Customers: This report summarizes Invitation information by customer for the designated 

scope and period of time. The scope can be defined in the Show Report for drop-down at 

the top of the page. There will be one line for each Period. A Period can be a Day, Month, 

or Year, and is defined in the Show by drop-down at the top of the page. The number of 

Periods in the report depends on the date range designated at the top of the page. For each 

Period, you can see a list of all customers who have sent Invitations, including their ID, 

name, email, and customer group. Additionally, you can see the number of Invitations they 

have sent in that period, and the number of those Invitations which have been accepted. 

 Order Conversion Rate: This report summarizes Invitation and sales information for the 

designated scope and period of time. The scope can be defined in the Show Report for 

drop-down at the top of the page. There will be one line for each Period. A Period can be a 

Day, Month, or Year, and is defined in the Show by drop-down at the top of the page. The 

number of Periods in the report depends on the date range designated at the top of the page. 

For each Period, you can see the number of Invitations which have been sent, the number 

of the those Invitations which have been accepted, the number customers who have 

completed an order after accepting an Invitation, and the percentage of Invitations sent 

which have led to a completed order.  
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45.2 Events  

There are some configuration settings that must be completed relating to Events.  

To enable and configure events: 

1. Choose System > Configuration, click the Catalog tab in the left column. 

2. In the Catalog Events panel, configure events by setting the following values: 

 Enable Catalog Events Functionality: Determines whether the Events module is enabled. 

 Enable Catalog Event Widget: Determines if the Event Widget is displayed in the frontend. 

This is a static block containing information about Events in your site. Sometimes this 

feature is referred to as Lister Block. There is more information about the Event Widget 

below. 

 Number of Events to be Displayed on Category: Determines the number of Events that will 

display in the Event Widget on the category pages. 

 Number of Events to be Displayed on CMS Pages: Determines the number of Events that 

will display in the Event Widget on CMS pages, such as the home page. 

3. When you have completed these settings, click Save Config in the top right of the page. 

Events Backend 

Events can be created and viewed by navigating to Catalog > Categories> Catalog Events. This page 

contains a grid listing all Events that you have created. To create a new Event, click Add Catalog 

Event in the top right of the page. You will need to first select the category for which the Event will 

be created. Click on the desired category from the category tree. Only one event can exist for a 

given category at one time, so any categories that already have an associated Event will be disabled 

in the category tree. When you click on a valid category, you will be redirected to the next page. 

This page contains fields for the start and end date of the event, the image which will be displayed 

in the Event Widget, the sort order in the Event Widget, and check boxes for displaying a 

countdown ticker block on the category page and/or product page (of products associated to the 

given category). This page also displays the category for which you are creating the Event, which 

will link back to the previous step if clicked (so you can select a different category). When you have 

completed the Event settings, click Save in the top right of the page. You will be redirected to the 

Event grid. 

To edit an existing Event, select it from the Event grid. This page is similar to creating a new Event. 

One difference is that the category link will no longer link back to the category tree to allow you to 

select a different category. Instead, it will link to the Catalog > Manage Categories page for that 

category. Another difference is that the Status of the Event will display. This status is solely 

dependent upon the start and end date of the Event. Future Events are Upcoming, current Events are 

Open, and past Events are Closed. 
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In Catalog > Manage Categories, there will be a link to the Events page. This link is a button which 

will only display for existing categories, so it will not display when creating a new category. If the 

category already has an associated Event, the button will say Edit Catalog Event and will link to the 

edit page of the given event. If the category does not yet have an associated Event, the button will 

say Add Catalog Event and will link to the second step of the “create new event” process (with the 

given category pre-populated). 

Events Frontend 

If the Event Widget is enabled, it will display on the home page and on category pages. It will 

display Open Events first, sorted by end date. If two or more Events share the same end date, sorting 

will be based upon the sort order entered in the steps above. Open Events include a countdown 

ticker. After all Open Events, the widget will display Upcoming Events, sorted by start date, then sort 

order. Upcoming Events include the start and end date. 

If the Category Page ticker has been enabled for a given event, the ticker block will display at the 

top of the product listing page. If the Product Page ticker has been enabled, the ticker block will 

display at the top of the product view page (of products associated to the given category). Like the 

Event Widget, the ticker block displays a countdown ticker for open events and the start and end 

date for upcoming events. If an event is closed, the ticker block will indicate this (and includes the 

start and end date, similar to Upcoming events). By default, products in upcoming or closed events 

are not sellable. The Add to Cart button will not display in the product listing page or the product 

view page. To restore the Add to Cart button for a closed event, the event must be deleted. 

However, if a product is associated to another category, which has no selling restrictions, then the 

Add to Cart button will appear in the product view page. Similarly, the ticker block will not display 

in the product view page if that product is associated to another category which has no selling 

restrictions. 

45.3 Category Permissions and Website Restrictions 

Category Permissions can be used in conjunction with invitations and events to create private sales. 

Website Restrictions can be used in conjunction with Invitations and Events to create Private Sales.  

To learn more about these features, see “Controlling Website Access,” page 347. 
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46 Gift Registries 
This chapter introduces Magento Enterprise Edition’s Gift Registry functionality. Enterprise Edition’s gift 

registries enable your registered customers to create a gift registry for a special occasion and to notify friends 

and family of the registry. Friends and family can purchase items from the gift registry and Magento keeps 

track of the items bought and quantities remaining. 

The store administrator can also perform basic operations such as viewing or sharing customers’ gift 

registries, adding items from the customer’s shopping cart to one of the registries created by the customer, 

updating gift registry item quantity, or deleting a customer’s gift registry. In the frontend, after a customer 

creates a gift registry, items can be added to it either from the customer’s shopping cart or from the Wishlist, 

and then the gift registry list can be shared with others. A gift registry recipient can in turn open a gift registry 

by either following the emailed link or searching for it by the gift registry owner’s name, email, or gift 

registry ID. Gift registry recipients who want to purchase a product from the gift registry can add an item 

from the gift registry list directly to their shopping cart. When an order is placed for gift registry items and the 

gift registry is updated to reflect the quantity of items fulfilled. See Figure 287. 

 

 

Figure 287. General Gift Registry Work Flow 
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•Receives email notification 
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•Updates gift registry item counts 

•Notifies gift registry owner 
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Chapter Quick Reference 

The table below lists some of the most common tasks for using EE’s gift registry functionality and where to go 

in the Admin Panel to perform them. The sections that follow provide step-by-step instructions on each. 

TASK ADMIN MENU 

To enable gift registries System > Configuration > Gift Registry tab 

General Options tab 

To configure gift registry notification 

emails 

System > Configuration > Gift Registry tab 

To customize gift registry notification 

emails 

System > Transactional Email 

To customize gift registry types 

available 

Customers > Gift Registry 

To add a gift registry search widget to 

the website 

CMS > Widgets 

To view a customer’s gift registry Customers > Manage Customers 

Gift Registry tab 

To manage items in a customer’s gift 

registry 

Customers > Manage Customers 

Gift Registry tab 

To share a customer’s gift registry Customers > Manage Customers 

Gift Registry tab 

To delete a customer’s gift registry Customers > Manage Customers 

Gift Registry tab 

46.1 Administering Gift Registries 

Before customers can start using the Gift Registry module, the store administrator needs to complete 

some general setup. This section describes the setup to be done in the Magento backend. This 

includes enabling the module itself, setting the gift registry notification process, and creating gift 

registry types and attributes. 

Enabling and Configuring Gift Registries 

To enable gift registries: 

1. Choose System> Configuration. Select the Gift Registry tab on the left. 

2. In the General Options panel, enable gift registries by setting the following values: 

 Enable Gift Registry: Determines if gift registries are available on your Magento stores. 

o Yes: Enables the gift registry functionality for the selected store view and customers 

registered for the selected store view are provided with a Gift Registry tab on their 

account page after the gift registry configuration settings are saved in the backend. 

o No: Gift registries are not available on the frontend website. 
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 Max Recipients Limit: Set the number of recipients that a customer creating a gift registry 

can add to her or his gift registry. A recipient is the person who the gift registry owner shares 

his or her gift registry list with. In the frontend, when a customer creates a gift registry, the 

Add Recipient button is available as long as the number of recipients added does not 

exceed the value specified in the Max Recipients Limit field. 

3. Click the [✔Save Config] button to save your settings. 

After the store administrator enables the module in the backend configuration, a warning message 

appears, stating that one or more cache types are invalidated. The store administrator needs to 

follow the link from the message or click System > Cache Management on the Magento top menu, 

select the check box for the invalidated cache type, and click the Submit button. After the cache is 

refreshed, the Gift Registry submenu appears under the Customers menu in the backend. 

After the Gift Registry functionality is enabled, the Gift Registry tab becomes available for customers 

in the My Account menu on the customer’s page in the frontend. 

When it is required, the Gift Registry functionality can be disabled by setting the Enable Gift 

Registry field to No (System > Configuration > CUSTOMERS > Gift Registry > General Options). 

However, note that the Gift Registry submenu will disappear from the Customers menu in the 

backend only after the cache is again refreshed. 

To configure gift registry email notifications: 

As part of the gift registry functionality, Magento will send email notifications in response to several 

events in the gift registry work flow. Magento sends the following gift registry-related emails: 

 To the gift registry owner upon successful creation of the gift registry. Email contains a link 

to the newly created gift registry that can be shared with friends and family 

 Optionally, if the gift registry owner wishes to send notifications from the store, to the 

friends and family (gift registry recipients) of the gift registry owner. Email contains a link to 

the gift registry. 

 To the gift registry owner when updates are made to the gift registry. Email indicates that 

items have been purchased but does not specify by whom. 

Magento has pre-defined templates for each of these emails that can be modified and customized by 

the store administrator in the same way all other email templates can be in Magento in System > 

Transactional Emails. 

1. Choose System > Configuration. Select the Gift Registry tab on the left. 

2. In the Owner Notification panel, configure the emails that will sent to gift registry owners 
notifying them that their gift registry has been created by setting the following values: 

 Email Template – Select the Gift Registry Owner Notification template to use to notify the 

gift registry owner that the gift registry has been successfully created. Figure 288 shows an 

example of the default template. 
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Figure 288. Default Gift Registry Owner Notification Template 

 Email Sender: Specify an email sender from whom a gift registry owner will be sent an email 

notifying him/her that their new gift registry was created. 

3. In the Gift Registry Sharing panel, configure the emails that will sent to notify gift registry 
recipients that a gift registry has been shared with them by setting the following values: 

 Email Template: Select the Gift Registry Sharing template to use to notify recipients 

specified by the gift registry owner that their gift registry has been shared. After a gift registry 

owner adds gift registry recipients and clicks the Share Gift Registry button on the Share Gift 

Registry page, each recipient from the list receives an email. Figure 289 shows an example 

of the default template: 

 

Figure 289. Default Gift Registry Sharing Template 

 Email Sender: Specify an email sender from whom a gift registry recipient will be sent an 

email notifying him/her that a gift registry has been shared with them.  
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 Max Emails Allowed to be Sent at One Time: Set the maximum number of email 

notification letters to be sent to recipients with whom a gift registry owner can share his or 

her gift registry. 

4. In the Gift Registry Update panel, configure the emails that will sent to notify the gift registry 
owner of changes to the gift registry by setting the following values: 

 Email Template: Select the Gift Registry Update template to use to notify the gift registry 

owner that their gift registry has been updated (when items are purchased). When any of the 

gift registry recipients places an order for an item from the gift registry, the gift registry 

owner receives an update email letter containing the information about the gift registry item 

and its quantity ordered. In this case, the gift registry owner does not know the name of the 

person who has placed an order. Figure 290 shows an example of the default template: 

 

Figure 290. Default Gift Registry Update Template 

 Email Sender: Specify an email sender from whom a gift registry recipient will be sent an 

email notifying him/her that a gift registry has been shared with them.  

5. Click the [✔Save Config] button to save your settings. 

Customizing Gift Registry Types 

After the Gift Registry configuration is complete, the administrator needs to create gift registry types 

and attributes in the backend. Gift registry types denote special events that the gift registry can be 

created for. These can be a wedding, a birthday, an anniversary, a child birth, or any other special 

occasion. By default, Magento provides gift registry types for the following special events: 

 Baby Registry 

 Birthday 

 Wedding 

With the pre-defined gift registry types, Magento provides a number of pre-defined attributes/fields. 

The store administrator can choose to modify or delete some of them or to add a number of new 

attributes and attribute options. A gift registry attribute provides additional information about the gift 

registry owner, the event, its time and place, or any other gift registry-specific information. When 

the customer is creating a new gift registry on the frontend, these attribute fields will be presented to 

him/her to fill in while creating the registry.  
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To create or modify gift registry types: 

1. Choose Customers > Gift Registry. A list of available gift registry types is displayed. 

2. Click the [+Add Gift Registry Type] button to create a new gift registry type, or click on one of 
the currently available gift registry types to edit it. 

3. In the General Information panel, configure the gift registry type by setting the following values: 

 Code: Specify the name for the gift registry type that will be used in the system. This must be 

unique and can contain only letters, numbers and underscores. 

 Label: Specify the name for the gift registry type that will be displayed on the frontend. 

 Sort Order: Assigns to a gift registry type the order in which it will appear on the Create Gift 

Registry page on the frontend. 

 Is Listed: Determines if a gift registry type is available (is listed) on the frontend. 

4. Click the Attributes tab 

5. Click the [+Add Attibute] button to create a new attribute, or click on one of the currently 
available attributes to edit it. 

6. In the Attributes tab, create or modify attributes by setting the following values: 

 Code: Specify the name for the attribute that will be used in the system. This must be unique 

and can contain only letters, numbers and underscores. 

 Input Type: define the type of input allowed for a gift registry attribute. A gift registry 

attribute can have a number of options. For example, for a gift registry type Wedding, the 

administrator can create the gift registry attribute Role and add two attribute options, Bride 

and Groom. When creating a gift registry of a specific gift registry type, in the frontend the 

customer will make a choice from the attribute options depending on the value that the 

store administrator has specified in the Input Type field for a specific gift registry attribute 

option. The store administrator can choose among the following pre-defined custom and 

static input types in this field: 

o Text 

o Select: For “Select” input types, use the [+Add Option] button to create the drop-

down menu of options  

o Date 

o Country 

o Event Date: For Event Date input types, the Is Searchable, Is Listed, and Date 

Format fields appear. The Is Listed field specifies whether there will be a column of 

values of this attribute in the grid of gift registries in the frontend. The Is Searchable 

field specifies whether the gift registry attribute is available in the gift registry 

advanced search. In the frontend, such attribute is displayed under the Type 

Specific Options group. 

o Event Country: For Country or Event Country input types, the Show Region field 

appears. Indicate whether the list of countries or regions related to the country 

selected by the customer will be available for selection in the frontend. 

o Event Location 
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o Role 

 Attribute Group: Select the information group that the attribute will appear in on the 

frontend. On the frontend, when a customer creates a gift registry, related gift registry 

attributes appear under any of the following attribute groups selected by the store 

administrator: 

o Event Information: Groups all gift registry attributes that add the information about 

the gift registry event, its time, place, etc. 

o Gift Registry Properties: Combines all attributes that add information directly about 

the gift registry. 

o Privacy Settings: Lists the attributes that add information about the gift registry event 

privacy. 

o Recipients Information: Groups the attributes that provide information about the 

person who creates a gift registry. 

 

Figure 291. Create Gift Registry Page 

 Label: Specify the attribute name that will be displayed to the customer on the Create Gift 

Registry page in the frontend. 

 Is Required: Choose whether the attribute with custom options, if there are any, is required 

to be specified by the customer in the frontend. The customer will not be able to save a gift 

registry if the attribute set to be a required one is not specified on the Create Gift Registry 

page. 

 Sort Order: Define the order of the gift registry attribute to be displayed to the customer on 

the Create Gift Registry page in the frontend. This parameter is relevant when there is more 

than one attribute created for a gift registry type. 

7. Click the [✔Save] button to save your attribute. 



Gift Registries 

406 

Adding a Gift Registry Search Widget to the Frontend 

Magento users can search for an existing gift registry in a web store. This functionality becomes 

available if the store administrator creates a widget, which adds a Gift Registry Search section in the 

specified place of the web store page.  

In the frontend, the customer searching for a gift registry can select the search type in the Search By 

field. Depending on her or his choice, a number of fields to be filled out appear. These are gift 

registry owner first and last names, email, the type of gift registry, or the gift registry ID. After 

clicking the Search button, the customer is provided with the search results on the Gift Registry 

Search page. If the search returns no results, the customer can try searching again by using the 

search options on the page. 

To add a gift registry search widget to your store: 

1. To create the widget instance, choose CMS > Widgets.  

2. Click the [+Add New Widget Instance] button. 

3. In the Settings panel, create the widget by setting the following values: 

 Type: Select “Gift Registry Search” from the drop down. 

 Design Package/Theme: Select the theme being used by the store you wish this widget to 

show up on. 

4. Click the [✔Continue] button.  

5. In the Frontend Properties panel, enter the remainder of the basic widget info: 

 Widget Instance Title: Name for this widget  

 Sort Order: Order in which widget should appear, relative to other elements in the block in 

which it appears. 

6. In the Layout Updates panel, specify the pages and block in which the gift registry search 
widget should appear by setting the following values: 

 Display On: Indicate the specific pages or the types of pages on which the gift registry 

search widget should appear.  

 Block Reference: Indicate the blocks in your template in which the widget should appear. 

Depending on the template, options my vary, but are typically Left Column and Right 

Column.  

7. Click the Widget Options tab.  

8. In the Widget Options panel, specify the ways in which visitors to your website can search for 
gift registries. 

 Quick Search Form Types include: 

o Recipient Name Search 

o Recipient Email Search 

o Gift Registry ID Search 

9. Click the [✔Save] button to save your widget. 



 Gift Registries 

 407 

10. Refresh the Magento page cache if necessary to see the widget appear on the frontend. 

46.2 Managing Gift Registries 

After the Gift Registry module is enabled and set up and all required gift registry types and attributes 

are created, the store administrator can manage gift registry records by monitoring them, making 

some changes to them, sharing gift registries, or delete them on gift registry owners’ request. 

To view a customer’s gift registry: 

1. Choose Customers > Manage Customers.  

2. Click on the customer whose gift registry you’d like to view. 

3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer. 

4. Click on the desired gift registry. 

To manage items in a customer’s gift registry: 

If desired, you can add items in the customer’s shopping cart to a customer’s gift registry from the 

Admin Panel. You can also change quantities and delete items. 

1. Choose Customers > Manage Customers.  

2. Click on the customer whose gift registry you’d like to view. 

3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer. 

4. Click on the desired gift registry. 

5. To add items from the customer’s shopping cart to their gift registry: 

6. In the Shopping Cart Items section, locate the item to add to the gift registry and check the 
check box.  

7. From the Actions drop-down menu, select “Add to Gift Registry” and click the [Submit] button. 

8. To change quantities in the gift registry: 

9. Enter the new quantity in the Gift Registry Items section and click the [Update Items and Qtys] 
button 

10. To delete an item, set its quantity to “0” or select “Remove Item” from the Actions drop-down 
menu for that item. 

To share a customer’s gift registry: 

If desired, you can add items in the customer’s shopping cart to a customer’s gift registry from the 

Admin Panel. You can also change quantities and delete items. 

1. Choose Customers > Manage Customers.  

2. Click on the customer whose gift registry you’d like to view. 
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3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer. 

4. Click on the desired gift registry. 

5. In the Sharing Information area provide the following information: 

o Emails: Enter the email addresses provided by the gift registry owner. Multiple 

email addresses must be separated with a comma.  

o Send From: Select the store view from which the gift registry recipients will receive 

an email letter with a URL link to the customer’s gift registry. 

o Message: If desired, type a message that a gift registry recipient will see in the 

received email letter 

6. Click the [Share Gift Registry] button.  

Upon sharing a gift registry list, gift registry recipients whose email addresses are specified in the 

Emails field will receive an email notification with a link to customer’s gift registry item list and to 

the store where the recipients can purchase the items from the gift registry list.  

To delete a customer’s gift registry: 

1. Choose Customers > Manage Customers.  

2. Click on the customer whose gift registry you’d like to view. 

3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer. 

4. Click on the desired gift registry. 

Click the [x Delete Registry] button to permanently delete the gift registry. Note that this 

operation cannot be reversed. 
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47 Gift Wrapping 
In Magento Enterprise Edition, store customers can select a gift message and/or gift wrapping for the entire 

order, as well as for separate order items, and a printed card, such as a picture post card, to the order. You 

can process the gift wrapping and printed card, and charge customers for them, as well as add gift messages, 

gift wrapping, and a gift card in orders that are created from the Admin Panel. 

This feature was introduced in Version 1.10 of Magento Enterprise Edition. 

47.1 Enabling and Configuring Gift Options: Global or 
Website Level 

To enable and configure the gift wrapping and gift messages features: 

1. In the Magento top menu, select System > Configuration. 

2. Under SALES in the left column, click Sales. The configuration can be done either at the global 
or website level, so in the Current Configuration Scope drop-down menu leave the Default 
Config or select the desired website.  

3. Expand the Gift Options fields set. Here you can set the following options: 

 Allow Gift Messages on Order Level: Specify whether a gift message can be added for the 

entire order. 

 Allow Gift Messages on Order Items: Specify whether a gift message can be added for an 

individual order item. 

 Allow Gift Wrapping on Order Level: Specify whether gift wrapping can be selected for the 

entire order. 

 Allow Gift Wrapping on Order Items: Specify whether gift wrapping can be selected for an 

individual order item. 

 Allow Gift Receipt: Specify whether a person creating the order can choose to send a gift 

receipt (that is, a shipping document where the prices and totals are not shown) instead of 

the general shipping document. 

 Allow Printed Card: Specify whether a printed card can be added to the order. 

 Default Price for Printed Card - The default price for the card (it is displayed when the card 

is selected during the order creation). 

When the gift wrapping functionality is enabled, the gift wrapping-related settings on the product 

level in the Admin Panel become available.  

Gift Options Settings at the Product Level 

The global gift wrapping and gift messages settings can be overridden at the product level. The 

corresponding settings for a product are accessible on the Gift Options field set of the Product 

Information page, when the product is created or edited. See Figure 292. 
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Note: To access the product management section, Catalog > Manage Products.  

 

Figure 292. Gift Options Settings at the Product Level 

The following settings for gift options are available at the product level: 

 Allow Gift Message: Specify whether a gift message can be added for this product. If the 

Use Config Settings check box is selected, the system configuration settings are applied. 

 Allow Gift Wrapping: Specify whether gift wrapping can be added for this product. If the 

Use Config Settings check box is selected, the system configuration settings are applied. 

 Price for Gift Wrapping: Specify the price for gift wrapping for this product. If the Use 

Config Settings check box is selected the default gift wrapping price is applied.  

Tax Classes for Gift Options 

Because you can charge customers for gift wrapping and printed cards, you can also specify a tax 

class for these items, at either global or website level in System > Configuration > SALES > Tax > 

Tax Classes. Select the applicable tax class in the Tax Class for Gift Option drop-down field. It 

contains all product tax classes that are defined in your Magento system.  

Note: Product tax classes can be created and managed in Sales > Tax > Product Tax 
Classes. 

The way prices for the gift wrapping and the printed card are displayed in different locations can be 

set in System > Configuration > SALES > Tax in the Shopping Card Display Settings and the Orders, 

Invoices, Credit memos Display Settings field sets. The available options are Excluding Tax, 

Including Tax, and Excluding and Including Tax. See Figure 293. 
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Figure 293. Gift Wrapping and Printed Card Prices Display Options 

Managing Gift Wrapping Designs in the Admin Panel 

To access the list of gift wrapping options, select Sales > Gift Wrapping. To edit an existing gift 

wrapping option, click it, or click the corresponding Edit link in the Action column. See Figure 294. 

 

Figure 294. List of Existing Gift Wrapping Options in the Admin Panel 

To add a new gift wrapping option: 

1. Click the Add Gift Wrapping button in the upper-right corner of the Manage Gift Wrapping 
page. The New Gift Wrapping page opens. 

2. Specify the following: 
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 Gift Wrapping Design: The name of the gift wrapping as store customers will see it. It can 

be different for each store view. To specify the name for a particular store view you must 

save the newly created gift wrapping, and then reopen it for editing, or use the Save and 

Continue Edit button.  

 Websites: Select the website where the new gift wrapping will be available. 

 Status: Determines whether the gift wrapping is enabled (that is, available in the list of the 

gift wrapping options in the order creation) or disabled. 

 Price: Specify the price of the gift wrapping option. This setting is overridden by the gift 

wrapping price setting at the product level. 

Note: The base currency is set at the global level in System > Configuration > 
GENERAL > Currency Setup. 

 Image: An image, illustrating the gift wrapping, can be downloaded. The customer can view 

its preview when adding gift wrapping during the order creation. It is an optional field.  

3. Click Save in the upper-right corner of the page. 

To delete a gift wrapping option: 

1. On the Manage Gift Wrapping page in the first column of the grid, select the check box 
corresponding to this gift wrapping. 

2. Choose Delete in the Actions drop-down menu in the heading of the grid. 

3. Click the Submit button.  

Or  

1. Open the gift wrapping option for editing. 

2. Click the Delete button. 

Gift Options: Customer Experience  

If gift messages and/or gift wrapping are enabled, then in the Shipping Method step of the one-page 

checkout the customer is presented with gift options.  

If the customer chooses to add gift options, two groups of check boxes appear: Gift Options for 

Entire Order and Gift Options for Individual Items. Also, the Send Gift Receipt and the Add Printed 

Card check boxes become available below, if the corresponding settings in the Admin Panel are 

configured to allow them. See Figure 295. 
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Figure 295. Adding Gift Options to the Order in the Frontend  

When the customer selects the Gift Options for the Entire Order check box, the Gift Wrapping 

Design drop-down menu and the Gift Message link appear below. The customer can select a gift 

wrapping design and write a gift message for the entire order. After the gift wrapping design is 

selected, its price and an image preview, if available, are displayed.  

Note: Gift wrapping is not available for downloadable and virtual products, so the Gift 
Wrapping Design drop-down menu does not appear for products of these types and 
for orders, which contain only  products of these types. 

When the customer selects the Gift Options for Individual Items check box, the list of product 

names with the Gift Wrapping Design drop-down menus, and the Gift Message links, appear for 

each product. They are similar to these fields for the entire order. See Figure 296. 
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Figure 296. Adding Gift Options for the Entire Order and Separate Order Items 

Note: If you do not create and enable gift wrapping, the Gift Wrapping Design drop-
down menu does not appear. 

If the customer selects the Add Printed Card check box, the card price is displayed below. 

Prices for the selected gift wrapping options and the printed card are represented as individual lines 

in order totals in the Order Review checkout step.  

Gift Options in Orders Created from the Admin Panel 

Gift options are available for orders that are created from the Admin Panel. To access the order 

management section, select Sales > Orders.  

When creating the order, the gift options for each order item can be added using the Gift Options 

link displayed under product name in the Items Ordered block. See Figure 297. 
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Figure 297. Gift Options for Order Items in the New Order in the Backend 

When you click the link, a pop-up window opens, where gift wrapping and/or a gift message can be 

added. If gift wrapping is selected for a product, its price is displayed under the product name. 

Gift options for the entire order are available in the Gift Options block of the Create New Order 

page. See Figure 298. 

 

Figure 298. Gift Options for the Entire Order in the New Order in the Backend 

The gift wrapping and the printed card prices for the order and separate items are represented as 

individual lines in the order totals. 

Note: When a new order is created using the reordering functionality, the gift options of 
the original order are not preserved.  

Gift Wrapping and Gift Card Refund 

When you create a credit memo that is not for the entire order, the refund for the gift wrapping 

and/or the gift card is included to the first credit memo that is created for the order. 

To exclude these costs from the amount to be refunded, the total of these costs should be specified 

in the Adjustment Fee field located above the Grand Total value in the credit memo. See Figure 

299. 
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Figure 299. Adjusting the Refund Total When Creating the Credit Memo 

Gift Wrapping and Gift Message Modules 

The Gift Wrapping module is connected with the Gift Message module. If the Gift Message module 

is disabled, then the Gift Wrapping module is disabled too. This means the Gift Options tab will be 

missing on the product page and the order page, and the Gift Wrapping page will not be available 

in Sales Management. The Add Gift Options check box will not be available on the Shipping 

Method checkout step in the frontend. To access the module management section, navigate to 

System > Configuration > ADVANCED > Advanced. 
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PART IX: ADVANCED CUSTOMER AND ORDER MANAGEMENT 

48 Custom Order Status Values 
In Magento Enterprise Edition you can create custom order status values, assign them to order states, and set 

default statuses for order states.  

Order state is the state of an order in the order processing workflow. The predefined order states in Magento 

are New, Pending Payment, Processing, Complete, Closed, Cancelled, On Hold, and Payment Review. 

Order states are not visible in the user interface, except the order statuses management section. 

Order status is the status of an order in a specific step of the order state processing workflow. The predefined 

order statuses in Magento are: Cancelled, Cancelled Ogone, Closed, Complete, Declined Ogone, Suspected 

Fraud, On Hold, Payment Review, Pending, Pending Amazon Simple Pay, Pending Ogone, Pending 

Payment, Pending PayPal, Processed Ogone Payment, Processing, Processing Ogone Payment, Waiting. 

A default order status for a state is a status that an order receives when it enters the state.  

48.1 Managing Order Status Values 

To access the list of order status values that are defined for your Magento system, in the Magento 

top menu select System > Order Statuses to open the Order Statuses page (see Figure 300). 

 

Figure 300. Order Statuses List 

To create a new order status value: 

1. Click the Create New Status button in the upper right corner of the Order Statuses page. For a 
new order status you specify the following: 

 Status Code: For system internal use. 

 Status Label: The label of the status, as it is shown in the Admin Panel and frontend. 

 Store View Specific Labels: You can specify an alternative status label for each store view 

available in the system.  
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2. Click the Save Status button the upper-right corner of the New Order Status page. 

To assign an order status value or set it as the default for an order state: 

1. Click the Assign Order Status to State button in the upper-right corner of the page. The Assign 
Order Status to State page opens, where you specify following fields: 

 Order Status: Select the order status value that you want to assign. 

 Order State: Select the order state, to which the status value is assigned. 

 Use Order Status As Default: Select this check box if you want the specified status value to 

be the default for the selected state. 

2. To save the assignment, click the Save Status Assignment button in the upper-right corner of the 
Assign Order Status to State page.  

Note: Currently only default custom order status values are applied in the order 
management workflow. The custom status values that are not set as default are 
available only in the comments section in the order view in the Admin Panel. See 
Figure 301. 

 

Figure 301. Non-default Custom Order Status in Comments  

To cancel the assignment of the order status value, click the Unassign link in the Action column for 

the desired order status in the list on the Order Statuses page. 

To edit the existing order status, click the corresponding row in the list of order statuses. The Edit 

Order Status page opens, where the status labels can be changed. 

Order status values cannot be deleted. 
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49 Editing Orders in the Admin Panel 
In Magento Community Edition, when you edit an existing order, the original order is canceled and a new 

one is created. In Magento Enterprise Edition, you have the option to change the billing and shipping 

addresses of the existing order, without creating a new order. See Figure 302. 

This feature was introduced in Version 1.10 of Magento Enterprise Edition. 

 

Figure 302. Edit Links for the Billing/Shipping Address in the Admin Order View 

Note: When using the order editing functionality, changing the billing and shipping 
addresses does not influence the totals calculation.  

To edit the billing or shipping address in an existing order: 

1. In the Magento top menu, select Sales > Orders. 

2. Open the desired order for editing, and click the Edit link in the Billing Address section or the 
Shipping Address section (see Figure 302). A page for editing the address opens. 

3. Make the necessary changes and click the Save Order Address button in the upper right corner 
of the page. 

When making any other changes to an order (by clicking the Edit button in the order view page), the original 

order is canceled and a new one is created. 
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50 Assisted Shopping 
Magento Enterprise Edition’s assisted shopping feature enables merchants and their customer service 

representatives to better manage a customer’s shopping cart from the Admin Panel. Customer Service reps 

can see the contents of a customer’s shopping cart while they are on the phone with that customer and they 

can easily move items from the wishlist or recently viewed items list to the shopping cart—all without 

having to create an order. They can also apply a coupon code to a cart from the backend. 

To use the assisted shopping feature: 

In order to use the assisted shopping feature on the backend, the customer must login or create an 

account so that their cart, wishlist and browsing history will be visible on the backend. To see and 

manage that customer’s cart: 

1. Choose Customers > Manage Customers. 

2. Select a customer to edit from the list and then select the Shopping Cart tab on the left. 

3. Click the [Manage Shopping Cart] to go into the Assisted Shopping mode. 

4. You will be able to see the customer’s shopping cart, apply a coupon code, as well as be able 
to see: all products, customer’s wishlist, customer’s comparison list, recently compared 
products, recently viewed products, and customer’s last ordered products. Any of these 
products can be easily seen and added to the customer’s shopping cart using the [+Add 
Selected Products to the Shopping Cart] button. As soon as they are added to the cart this way, 
the customer should also be able to see those items in his/her cart on the frontend simply by 
refreshing the page. 

5. The customer can then continue browsing, checkout unassisted, or the customer service 

representative can create the order by clicking the [✔Create Order] button and proceeding to 
place the order for the customer. 

Note: The customer service rep can remove items from the cart by setting the quantity 
to 0 and updating the cart. But the customer service rep cannot move items from 
the cart to the wishlist or comparison list, the customer must do that themselves. 
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51 Order Archiving 
In order to speed up the performance on the backend when admin users are using the Admin panel to 

service customers and look up orders, Magento Enterprise Edition order archiving functionality. Order 

archiving allows the merchant to set a time period after which orders and their related sales documents 

(invoices, credit memos, and so on) are moved to an archive table. Archived orders are not deleted and are 

still available in the backend via the Admin Panel, but having the older, less frequently accessed orders 

moved out of the main order tables enables admin users to access the newest orders more quickly. 

This feature was introduced in Version 1.8 of Magento Enterprise Edition. 

To enable order archiving: 

1. Choose System > Configuration. Select the Sales tab on the left. 

2. In the Orders, Invoices, Shipments, Credit Memos Archiving panel, you can set the following 
values: 

 Enable Archiving - Yes enables archiving using the values below. No disables archiving and 

any values below are ignored.  

 Archive Orders Purchased - Age (in days) of orders to be archived. Orders and their related 

documents older than this number of days will be moved to the archive table. 

 Order Statuses to be Archived - Status of orders that can be archived. By default, orders 

flagged as “complete” and “closed” are set to be archive-able. You can expand this list to 

include more order statuses or reduce it to fewer. 

Click the [✔Save Config] button to save your settings 
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52 Customer and Address Attributes 
Magento has many built-in customer data fields to support the order, fulfillment and customer management 

processes. But every business is different and many times additional fields are necessary Magento Enterprise 

Edition includes the ability to create and manage custom customer attributes and custom address attributes 

from the Admin Panel. With the Customer/Address Attribute functionality, the store administrator can create 

custom attributes to be displayed in the following areas of the backend and frontend: 

 Create an Account page where a guest is registering for a customer account 

 Account Information section of the customer’s account in the frontend 

 Address Book section of the customer’s account in the frontend 

 Billing Information section of the Checkout page for the registered customer 

 Billing Information section of the Checkout page available when the guest is registering for a 

store 

 Account Information section in an order being created for a customer in the backend 

 Billing Address section in an order being created for a customer in the backend 

This feature was introduced in version 1.9 of Magento Enterprise Edition. 

Chapter Quick Reference 

The table below lists some of the most common tasks for using EE’s customer and address attributes and 

where to go in the Admin Panel to perform them. The sections that follow provide step-by-step instructions 

on each. 

TASK ADMIN MENU 

Creating custom customer attributes Customers > Attributes > Manage Customer Attributes 

Creating custom address attributes Customers > Attributes > Manage Customer Address 

Attributes 

Changing the order of address fields 

on the frontend 

System > Configuration > Customer Configuration 

Address Template panel 

To create custom customer attributes: 

When creating a customer attribute, the store administrator needs to specify a number of properties 

for it including those for displaying the attribute in the frontend. 

1. Choose Customers > Attributes > Manage Customer Attributes. 
On the resulting Customer Attributes grid you can see all of the system and custom attributes. 
You cannot edit or delete System Attributes. 

2. Click the [+Add New Attribute] button. 
The resulting page is very similar to the Product Attribute editor, which you are probably 
already familiar with. 

3. On the Properties tab, in the Attribute Properties panel, enter the appropriate information for the 
following fields to create your attribute: 
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 Attribute Code: Specify the customer attribute name that will be used by the system. The 

name must be unique and must not contain any special characters, except an underscore, 

or any spaces. 

 Input Type: Specify the way the attribute being created will be presented to the customer in 

the frontend. The following options are available: 

o Text Field: Single line text field. Max and min size can be specified later.  

o Text Area: Multi-line text input area. Max and min size can be specified later. 

o Multiple Line: The number of input lines to be available for the customer in the 

frontend (cannot exceed 20 lines). 

o Date: The system validates the customer’s date attribute input. 

o Dropdown: Dropdown list of options. When selected, the store administrator needs 

to create a number of attribute options on the Manage Label / Options tab. 

o Multiple Select: Multi-selectable list of options. When selected, the store 

administrator needs to create a number of attribute options on the Manage Label / 

Options tab. 

o Yes/No: Binary/yes-no input field. 

o File (attachment) : Allows files to be uploaded by the customer. 

o Image File: Allows images to be uploaded by the customer. 

 Default Value: Specify a value that will be displayed in the attribute field in the frontend as 

a default one.  

 Input Validation: Specify how the customer’s input will be validated by the system when the 

customer enters a value in the attribute field in the frontend. The system verifies that the 

value entered in the attribute field corresponds to the type of attribute created. Input 

validation options available to the store administrator may vary depending on the attribute 

input type selected. 

 Minimum Text Length and Maximum Text Length: Specify the values for the minimum and 

maximum allowed length of text that can be entered by a customer in the attribute field in 

the frontend. These fields appear if the attribute is of Text Field, Text Area, or Multiple Line 

input type. 

 Maximum File Size (bytes): Specify the maximum allowed size of a file to be attached. This 

field appears if the attribute is of File type. 

 File Extensions: List allowed extensions of files to be attached in the field. Separate multiple 

file extensions with a comma. This field appears if the attribute is of File type. 

 Values Required: Specify whether the attribute field should be mandatory on frontend 

forms. The customer will not be able to save his or her account information if the 

mandatory attribute is not filled out. 

 Input/Output Filter: Choose which filter will be applied to the attribute during the input and 

output operations. Filters can only be applied if the attribute is of Text Field, Text Area, or 

Multiple Line input type. The following options are available: 

o None 

o Strip HTML Tags 

o Escape HTML Entities 
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 Use in Customer Segment: If Yes, the custom attribute being created can be used in 

customer segmentation. (Customer segments are used as targets for advertising, promotions, 

and suggestive selling. Customers can match any of created segments based on their 

personal data and purchase history. In Magento, customer segments are created and set up 

under Customers > Customer Segments.) 

4. On the Properties tab, in the Frontend Properties panel, enter the appropriate information for 
the following fields to create your attribute: 

 Show on Frontend: Specify whether the attribute will be available in the frontend. 

 Sort Order: Specify the position at which the attribute will be displayed. All custom 

attributes are displayed after the system attributes, so they are shown at the end of the 

existing form fields. 

 Forms to Use In: Choose the forms on which the custom attribute will be displayed in the 

frontend. Choose among the following options: 

o Customer Checkout Register 

o Customer Registration 

o Customer Account Edit 

o Admin Checkout 

5. On the Manage Label/Options tab, set label to be displayed to the customer in the frontend. 
Specify the value either for a specific store view or a default one for all store views. 
 
If the attribute input type selected on the Properties tab is either Dropdown or Multiple Select, a 
number of options can be added to the attribute on the Manage Label / Options tab. The store 
administrator can perform this by clicking the Add Option button located in the Manage 
Options (values of your attribute) area and specifying a label for each attribute option. This also 
can be done for either all store views or for specific ones. When all required options are added, 
the store administrator can specify which of them will be displayed in the attribute field as a 
default option by selecting the Is Default check box. The order of customer attribute options is 
set in the Position field. 

6. Click the [✔Save Attribute] button to save your attribute. 

To create custom customer address attributes: 

Customer address attributes created by the store administrator are used when the store needs to find 

out any additional address information from the customer. This can be an optional email address, 

Skype account, alternate phone number, county, etc. 

The process for creating a customer attribute and a customer address attribute are almost the same 

except that customer address attributes can be displayed in the frontend only in the following two 

forms: 

 Customer Registration Address 

 Customer Account Address 

For detailed information about how to create an address attribute, refer to the instruction above to 

create custom customer attributes. 
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To change the order of address fields on the frontend: 

Currently, the store administrator can modify address templates which define the look of address 

fields in the customer’s billing or shipping addresses in the frontend. This can be done for the 

following addresses in the system: 

 Customer’s billing and shipping addresses in the customer’s address 

 Shipping and billing addresses from customer’s address book (available during the shopping 

cart checkout) 

 Addresses in invoices, shipments, and refunds (printed in PDF files) 

1. Choose System > Configuration. Select the Customer Configuration tab on the left. 

2. In the Address Template panel, you can edit the following address templates: 

 Text: The template is used for all addresses that are printed.  

 Text One Line: This template defines the order of address entities in the customer’s 

shopping cart address book list. Progress during checkout. 

 HTML: This template defines the order of address fields located under the Customer 

Addresses area in the Admin panel (Customers > Manage Customers) and those located on 

the Add New Address page when a customer creates a new billing or shipping address on 

his or her account page. 

 PDF: The template defines the display of billing and shipping addresses in the printed 

invoices, shipments, and credit memos. 

 JavaScript Template 

 In the templates, you will see the following code blocks:  

o depend code: For processing of inner elements 

o if code: An attribute is defined 

o var code: The code attribute is printed  

 Use the following examples in your address templates: 

o For Text, Text One Line, HTML, and PDF address templates: {{depend address 

attribute code}} a space, a character, or a User Interface label {{/depend}}; {{if 

address attribute code}}{{var address attribute code}} a space, a character, or a User 

Interface label {{/if}} 

o For JavaScript address template: #{address attribute code} or User Interface label 

#{address attribute code} 

Click the [✔Save Config] button to save your template modifications. 



Persistent Shopping Cart 

426 

53 Persistent Shopping Cart 
This chapter describes the Persistent Shopping Cart feature, which enables you to use a persistent cookie in 

Magento. In Magento Community Edition, only a session cookie is used. A persistent cookie is used to give 

access to certain account data after the session cookie expires. 

The Persistent Shopping Cart feature will work as described only for those customers whose browsers allow 

the use of cookies. 

This feature was introduced in Version 1.11 of Magento Enterprise Edition. 

53.1 Persistent Shopping Cart – General Concept 

The persistent cookie feature enables customers to have access to the shopping cart, wishlist, last 

ordered items and other history of interaction with the store, as well as have all customer specific 

settings applied, for a long period of time after the customer logs out or closes the window, or the 

session cookie lifetime runs out. Account-holder (non-guest) access to the checkout and My 

Account sections still require the customer to log in, to apply the session cookie. 

53.2 Persistent Shopping Cart – a Quick View 

By default, using the persistent cookie is disabled. You can enable and configure it under System > 

Configuration > CUSTOMERS > Persistent Shopping Cart. See Figure 303. 

 

Figure 303. Persistent Shopping Cart Configuration Fields 
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The Enable “Remember Me” field defines whether the Remember Me check box is displayed on 

login and registration pages on the frontend. This check box governs whether the persistent cookie 

can be actually applied for a given customer. 

If the feature is enabled, and the Remember Me check box is selected by a customer, the cookies 

are applied in the following order (there are two alternatives, depending on the Clear Persistence on 

Log Out value): 

Clear Persistence 
on Log Out value 

Cookies applied 

Yes When a customer logs in, both cookies (session and persistent) 

are applied. 

When a customer logs out, both cookies are deleted. 

If a customer does not log out, but the session cookie expires, 

the persistent cookie is still used. The customer has access to the 

sections, specified in the Persistent Shopping Cart configuration.  

No When a customer logs in, both cookies are applied. 

When a customer logs out, the session cookie is deleted, but the 

persistent cookie remains. If a customer does not log out, but the 

session cookie expires, the persistent cookie is still used. 

When a persistent cookie is applied, a Not %Jane Smith%? link is displayed in the page header, 

enabling the customer to terminate the persistent session and start working as a guest or log in as a 

different customer. 

Note: If Persist Shopping Cart is set to Yes, the following situation is possible: Customer 
A in the persistent session adds products to the cart, and goes away to make a cup 
of coffee. Customer B takes his place, and does not click the Not %Customer A% 
link. The B is actually working with the A’s shopping cart. If he or she goes to 
checkout and logs in as Customer B, the shopping cart content of the A (modified 
by B or not) is added to the B’s shopping cart. After B submits the order, the 
ordered products will be removed from the A’s shopping cart. 

53.3 Enabling and Configuring the Persistent Shopping 
Cart 

By default, using the Persistent Shopping Cart feature is disabled.  

To enable and configure the Persistent Shopping Cart: 

1. Select System, and click Configuration. 

2. In the Current Configuration Scope drop-down menu in the upper left corner of the page, select 
the desired website. 

3. Under CUSTOMERS in the left column click Persistent Shopping Cart. The following options are 
available: 
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Option Description 

Enable Persistence Defines whether using the persistent cookie is enabled.  

Persistence Lifetime 

(seconds) 

Defines the lifetime of the persistent cookie in seconds. 

Maximum allowed value is 3153600000 seconds (100 years).  

Enable “Remember 

Me” 

Defines whether the Remember Me check box is displayed on 

the login and registration pages on the frontend.  

If Enable Persistence is set to Yes, and Enable “Remember Me” 

is set to No, the persistent cookie is only used for those 

customers who already have it. 

“Remember Me” 

Default Value 

Defines the default state for the Remember me check box on the 

frontend. 

Clear Persistence on 

Log Out 

Defines whether the persistent cookie is deleted when a store 

customer logs out.  

Note: No matter how Clear Persistence on Log Out is 

configured, if a customer does not log out, but the session 

cookie expires, the persistent cookie is still used. 

Persist Shopping Cart Defines whether using the persistent cookie gives access to the 

shopping cart data of the correspondent account. The following 

options are available: 

 No – a customer with only persistent cookie applied will 

have a guest shopping cart. Its content will be added to the 

registered customer’s shopping cart after logging in. If a 

customer clicks the Not %John Smith%? link, the shopping 

cart content is left unchanged, as a customer will simply 

continue working with the same guest shopping cart. 

 Yes – a customer with only persistent cookie applied will 

work with the shopping cart of the corresponding account, 

and will continue working with it after logging in. If a 

customer clicks the Not %John Smith%? link, the shopping 

cart content is left unchanged, as a customer will simply 

continue working with the same account shopping cart. 

When Persist Shopping Cart is set to Yes, the following 

situation is possible: Customer A in persistent session adds 

products to the cart, and goes away to make a cup of 

coffee. Customer B takes his place, does not click the Not 

Customer A link. He or she will be working with A’s 

shopping cart actually. If B goes to checkout and logs in as 

Customer B, the A’s shopping cart content (modified by B 

or not) will be added to B’s shopping cart. After B submits 

the order, the ordered products will be removed from A’s 

shopping cart. 

Persist Wishlist Defines whether using the persistent cookie gives access to the 

wishlist data of the corresponding account. As guest customers 

do not have wishlists, if Persist Wishlist is set to No, a customer 
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Option Description 

with only the persistent cookie applied will need to log in to 

access the wishilist. 

Persist Recently 

Ordered Items 

Defines whether using the persistent cookie gives access to the 

Recently Ordered Items block data of the corresponding 

account. 

Persist Currently 

Compared Products 

Defines whether using the persistent cookie gives access to the 

Currently Compared Products block data of the corresponding 

account. 

Persist Comparison 

History 

Defines whether using the persistent cookie gives access to the 

Comparison History block data of the corresponding account. 

Persist Recently 

Viewed Products 

Defines whether using the persistent cookie gives access to the 

Recently Viewed Products block data of the corresponding 

account. 

Persist Customer 

Group Membership 

and Segmentation 

Defines whether using the persistent cookie enables applying 

customer group rules (tier pricing, catalog price rules, shopping 

cart price rules) and segment rules (related to displaying 

banners) of the corresponding account. 

53.4 Persistent Shopping Cart Implementation 

The Persistent Shopping Cart feature will work as described only for those customers whose 

browsers allow the use of cookies. 

The following table describes store customer access to different parts of the corresponding account 

data and store functionality, depending on the cookies applied. 

Cookie applied Store customer access 

Only session cookie 

applied 

A store customer has full access to all data of the corresponding 

account, no login required for checking out.  

Both session and 

persistent cookie are 

applied. 

Similar to the case where only the session cookie is applied. 

Only persistent 

cookie is applied 

The customer has access to the sections, which are configured to 

be persisted in the Persistent Shopping Cart settings; the Not 

%John Smith% link appears in the pages header next to 

Welcome, John Smith! string. To be able to check out the 

customer is prompted to log in. After the login the session 

cookie is applied. 
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Cookie Application Workflow 

When the Persistent Shopping Cart feature is enabled, the general workflow of applying the 

persistent cookie depends on the values of the Enable Remember Me and Clear Persistence on Log 

Out settings in the Admin Panel, and the store customer decision to select or clear the Remember 

Me check box when logging in or registering. The following variants are possible: 

Settings Effect 

Enable Remember Me = No  

and 

Clear Persistence on Log 

Out = any value 

The Remember me check box is not available on the login 

and registration page. The persistent cookie is not used. 

Enable Remember Me = 

Yes and Clear Persistence 

on Log Out = any value 

and customer does not 

select Remember Me 

The session cookie is applied as usual; the persistent 

cookie is not used. 

Enable Remember Me = 

Yes 

and 

Clear Persistence on Log 

Out = Yes 

and 

Customer selects 

Remember Me 

When a customer logs in, both cookies are applied. 

When a customer logs out, both cookies are deleted. 

If a customer does not log in, but the session cookie 

expires, the persistent cookie is still used.  

Apart from logging out, the persistent cookie is deleted 

when its lifetime runs out or when the customer clicks the 

Not %Jane Smith% link. 

Enable Remember Me = 

Yes and 

Clear Persistence on Log 

Out = No and 

Customer selects 

Remember Me 

When a customer logs in, both cookies are applied. 

When a customer logs out, the session cookie is deleted, 

the persistent session continues.  

The persistent cookie is deleted when its lifetime runs out 

or when the customer clicks the Not %Jane Smith% link. 

Cross-Browser Approach 

There is a separate independent persistent cookie for each browser.  

If a customer opens a store in multiple browsers using store cookies, the changes made in any 

browser are reflected in other browsers after pages are refreshed. 

Persistent Shopping Cart in Magento Community Edition 

The Persistent Shopping Cart feature in Magento Community Edition has the following restriction: 

persistent cookies can give access to shopping cart data only. 
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54 Multiple Wishlists 
Multiple Wishlists functionality enables store customers to create multiple Wishlists with different privacy 

setting for each of them. 

This feature was added in Enterprise Edition v1.12. 

54.1 General Concept 

With the Multiple Wishlists functionality enabled, store customers can perform the following actions 

with their Wishlists: 

 Create multiple Wishlists 

 For each Wishlist, configure whether it is private or public 

 Move items between Wishlists 

 Search for public Wishlists of other customers and purchase items from them 

All of a given customer’s Wishlists are available in the Admin Panel, similar to the way a single 

Wishlist is available. 

54.2 Configuring Multiple Wishlists 

The Multiple Wishlists functionality is disabled by default. 

To enable and configure the Multiple Wishlists functionality: 

1. Log in to the Magento Admin panel. 

2. Navigate to System > Configuration > CUSTOMERS > Wishlist. 

3. In the Current Configuration Scope drop-down menu, select the desired store view. 

4. Expand the General Options field set.  

5. If Enabled is set to No, switch it to Yes. Doing so will enable the regular Wishlist functionality 
and make the Multiple Wishlists-related settings appear. 

6. In the Enable Multiple Wishlists field, select Yes. The Number of Multiple Wishlists field 
appears. 

7. In the Number of Multiple Wishlists field, specify the maximum number of Wishlists each 
customer will be allowed to create. The specified number should exceed 1. The default value is 
5. 

8. To save the settings click Save Config. 
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Important Note: When you disable the Multiple Wishlist functionality, only a single 
(default) Wishlist is available for the store customers, but the multiple wishlists data 
is not deleted, and is available in the Admin Panel. 

54.3 Customer Experience with Multiple Wishlists 

The section describes the options available for store customers when the Multiple Wishlists 

functionality is enabled.  

Note: In Magento, the Wishlist functionality is available for logged-in customers, and 
customers working in a persistent session, when the Persistent Wishlist is enabled. 

Managing Multiple Wishlists 

For store customers, Wishlist management options are available on the My Wishlists tab of the My 

Account page. See Figure 304. 

 

Figure 304. Managing Multiple Wishlists in the Frontend 

The following table lists the main actions related to multiple Wishlists, which a customer 

can perform on the My Wishlists tab and means of performing them: 
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Task How to do it 

Create a new wishlist  On the My Wishlists tab of the My Account page, click the 

Create New Wishlist button. 

 Click Create New Wishlist when selecting a wishlist to 

which an item will be added, moved or copied. Can be 

performed on the My Wishlists tab of the My Account page 

and in all places where the Add to Wishlist link is 

displayed. 

 

Edit the name or privacy properties of an existing 

wishlist 

Click the Edit icon near the wishlist name. 

 

Move/copy an item from one wishlist to another  Select the desired items, click the little arrow next to the 

link and select the target wishlist. 

 To move/copy items to the default wishlist, select the items 

and click the Move to Wishlist or the Copy to Wishlist link 

under the item description. 

 

Move/copy multiple items from one list to 

another 

 Select the desired items, click the down arrow next to the 

COPY TO WISHLIST or MOVE TO WISHLIST button, and 

select the desired wishlist. 

 To move/copy multiple items to the default wishlist, select 

the desired items and click the COPY TO WISHLIST or 

MOVE TO WISHLIST button. 

 

View another wishlist Click the Change link in the table header and select the wishlist you 

want to view. 
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Task How to do it 

Delete a wishlist Click the DELETE WISHLIST button located under the wishlist items 

list.  

 

Note: The default wishlist cannot be 
deleted. 

 

Adding a Product to One of the Multiple Wishlists 

 

When the Multiple Wishlists functionality is enabled, store customers can 

add items to any of the multiple Wishlists, using the down arrow next to 

the Move to Wishlist link.  

 

Clicking the Move to Wishlist link adds products to the default Wishlist. 

 

 

 

Searching for a Wishlist 

All Wishlists that are set to be public can be found using the Wishlist search (a widget of the Widget 

Search type). The widget enables a customer to search by Wishlist owner name or email address. 

When store customers find someone else’s Wishlist, they can view it, order products from this 

Wishlist, or add the products to their own Wishlists.  

When items from a customer’s public Wishlist are purchased by another customer, the items are not 

removed from the original Wishlist. 
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Note: No shipping addresses are associated with wishlists. 

54.4 Managing Multiple Wishlists in the Backend 

In the Admin Panel, all items of all customer Wishlists are always displayed on all pages where 

Wishlist items are usually available (such as the Create New Order and Manage Shopping Cart 

pages), irrespective of whether the Multiple Wishlists functionality is enabled or disabled. Figure 

305 illustrates the Wishlist tab on the Customer Information page.  

 

Figure 305. Customer Information Page with Multiple-Wishlist Items 

On Figure 305, the Wishlist items from two different Wishlists are displayed in the grid, and the 

name of each Wishlist is specified in the Wishlist column. 

Adding a Wishlist Search Widget  

A Search widget of type Wishlist implements the ability to search for public Wishlists in the 

frontend.  

To add a Wishlist Search widget: 

1. In the Admin Panel, navigate to CMS > Widgets. 

2. Click the Add New Widget Instance button. The New Widget Instance page opens. 

3. In the Type drop-down field, select Wishlist Search. In the Design Package/Theme field, select 
the desired design theme and click Continue.  

4. On the Widget Options tab in the Quick Search Form Types field, choose the type of the quick 
search form which will be used. The following options are available: 

 All Forms – Use all listed form types. 

 Wishlist Owner Name Search – Store customers will be able to search for the Wishlists by 

an owner name. 

 Wishlist Owner Email Search - Store customers will be able to search for the Wishlists by an 

owner email address. 

5. Configure other widget properties. 
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6. Save the widget by clicking Save or Save and Continue. The widget becomes available in the 
frontend. 

Multiple Wishlists Reports 

An admin can view and export a report about all Wishlists of store customers under Reports > 

Customers > Customers Wishlists. A customer Wishlists report lists all Wishlist items and contains 

the following information:  

 The date when a product was added 

 The customer name 

 The Wishlist name and status (public or private) 

 The product name and SKU 

 Customer comments 

 Quantity of the product in the Wishlist, quantity currently available in the store, and the 

difference between these two values. 

You can choose to see a report for the whole website or for an individual store view. The scope is 

selected in the Show Report For field. The report can be exported to .csv or Excel .xml format. 
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55 Order by SKU 
Magento Enterprise Edition enables store customers and administrators to add products to shopping 

carts and orders by specifying SKU numbers.  

Important Note: The compound dynamic SKUs of bundle products are not supported. 

This feature was added in Enterprise Edition v1.12. 

55.1 Order by SKU: Quick Reference 

In the Magento Admin Panel, the Order by SKU functionality is always available and does not 

require configuration. Products can be added by SKUs in the following locations: 

 The Create New Order page (Sales > Orders > Create New Order) 

 The Shopping Cart page (Customers > Manage Customers > %customer% > Manage 

Shopping Cart) 

An administrator can specify individual SKU values or load a .csv file with a list of SKUs.  

In the frontend, you can make the Order by SKU functionality available for store customers by 

creating a widget instance of the Order by SKU type and by enabling the Order by SKU tab on the 

My Account page. 

Widgets are created and managed under CMS > Widgets. Displaying the Order by SKU tab can be 

enabled or disabled in the Admin Panel under System > Configuration > SALES >Sales >Order by 

SKU Settings. The Order by SKU tab provides the ability to load a .csv file with a list of SKUs. 

55.2 Configuring the Order by SKU Functionality 

In the Magento Admin Panel the Order by SKU functionality is always available and does not 

require configuration.  

In the frontend, you can make the Order by SKU functionality available for store customers by 

creating a widget instance of the Order by SKU type and by enabling the Order by SKU tab on the 

My Account page. 

The Order by SKU tab contains the fields for entering SKUs and quantities, and controls for loading 

a .csv file with a list of SKUs. A widget of the Order by SKU type contains the fields for SKUs and 

quantities and optionally a link to the Order by SKU tab. 

To create an Order by SKU widget: 

1. Log in to the Magento Admin Panel 

2. Navigate to CMS > Widgets. 

3. Click the Add New Widget Instance button.  
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4. In the Type field select Order by SKU and configure other widget options. The Display a Link to 
Loading a Spreadsheet setting determines whether the widget will contain a link.  

5. To save the widget click Save or Save and Continued Edit. 

To enable the Order by SKU tab of the My Account page: 

1. Log in to the Magento Admin Panel 

2. Navigate to System > Configuration > SALES > Sales  

3. In the Current Configuration Scope select your website. 

4. Expand the Order by SKU Settings field set. 

5. In the Enable Order by SKU in my Account on Frontend select one of the following: 

 Yes, for Everyone – The Order by SKU tab will appear on the My Account page for all 
logged in customers. 

 Yes, for Specified Customer Groups - The field for specifying Customer Group(s) appears 
once you select the option. The Order by SKU tab will be displayed on the My Account 
page for those logged in customers who belong to the Customer Group(s) you specify.  

 No – The Order by SKU tab on the My Account page will not appear. 

6. To save the configuration click Save Config. 

Important Note: The Order by SKU functionality supports ordering by a compound SKU 
value, consisting from the system SKU value and a value of the custom option SKU, 
delimited by the “-” sign. However such a compound value can be processed 
correctly only if both the system SKU and custom option(s) SKU values do not 
contain a "-" sign. 

55.3  Ordering by SKU in the Backend 

In the backend, you can find the Order by SKU functionality in the following locations: 

 The Create New Order page, available under Sales > Orders > Create New Order. Clicking 

the Add Products by SKU button opens the Add to Order by SKU section. See Figure 306. 

 

Figure 306. Adding Items to an Order by SKU 
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 The Shopping Cart page, available under Customers > Manage Customers > %customer% > 

Manage Shopping Cart. To access the ordering by SKU controls, expand the Add to 

Shopping Cart by SKU field set. See Figure 307. 

 

Figure 307. Add to Shopping Cart by SKU Field Set on the Shopping Cart Page in the 

Admin Panel 

To add products by SKU during admin order creation or managing a shopping cart: 

1. Click Add Products by SKU button or expand the Add to Shopping Cart by SKU field set. 

2. Specify SKUs and quantities, or load a spreadsheet, or both. Only the .csv file format is 
supported. See “Loading a Spreadsheet with SKUs: Requirements,” page 442, for details about 
file restrictions. 

3. Choose to add products to cart/order. 

4. If some products cannot be added on any reason (out of stock, require configuring, or some 
other reason), then they are listed in a separate grid under the “Products requiring attention” 
heading. See “Ordering by SKU: Exceptions Handling in the Backend,” page 439, for details 
about processing different product types. 

5. Perform product configurations and update quantities in the “Products requiring attention” grid 
if necessary, and add products to cart/order. 

6. If product addition fails again, the products still will be listed in the grid. You can ignore the 
“Products requiring attention” grid and proceed with creating order or managing the shopping 
cart. If you delete all products, the grid disappears. 

The grid with products which could not be added is stored during the session.  

Ordering by SKU: Exceptions Handling in the Backend 

The following are the situations in which products cannot currently be added to cart/order in the 

backend because of some correctable condition, or cannot be added in at all. In these situations, the 

corresponding SKUs are displayed in the “Products requiring attention” grid: 

 A product is composite (a product of configurable, grouped, bundle, gift card types or a 

product with custom options). These products can be added after configuring them. 

 No product with a specified SKU is found in the catalog. The product cannot be added. 

 A product is assigned to another website. The product cannot be added. 
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 A product is disabled or out of stock (in this case a product cannot be added to a shopping 

cart, but can be added to an order). 

55.4 Ordering by SKU: Customer Experience 

In the frontend, the Order by SKU functionality can be made available in the following locations: 

 In the widget, which can be located on any store page. Its location is configured by an 

administrator. See Figure 308.  

 

Figure 308. Order by SKU Widget 

  On the Order by SKU tab of the Account Information page. It must be enabled by an 

administrator to appear, see Configuring the Order by SKU Functionality section. The tab is 

available for logged-in users only. On the Order by SKU tab, customers can add products 

by individual SKUs or load a .csv file with a list of SKUs. See Figure 309. 

 

Figure 309. Order by SKU Tab in the My Account Page 

After a customer specifies SKUs and quantities, or loads a spreadsheet, the Shopping Cart page 

appears. If products cannot be added to the Shopping Cart on some reason, they are listed in a 

separate grid on the Shopping Cart page. See Figure 310. 
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Figure 310. Products Requiring Attention 

Products from this grid can be added to cart after the customer performs configuration or specifies 

quantities. A customer can ignore the grid with failed products and proceed to checkout for 

products that were successfully added to the Shopping Cart. The grid is stored during the session.  

Ordering by SKU: Exceptions Handling in the Frontend 

After a customer specifies SKUs or loads a spreadsheet with SKUs, and chooses to add them to the 

Shopping Cart, all products that can be ordered and do not require additional configuration are 

added to the Shopping Cart. All other products are displayed in a separate grid under the Products 

Requiring Attention heading. 

The following are the situations in which products cannot currently be added to a Shopping 

Cart because of some correctable condition, or cannot be added at all: 

 A product is composite (a product of configurable, grouped, bundle, gift card types or a 

product with custom options) 

 A product is out of stock or disabled 

 There is not enough quantity in stock and backorders are not allowed 

 No product with a specified SKU is found in the catalog 

 The quantity specified is less than the minimum allowed in the cart for a product 

 The quantity specified is greater than the maximum allowed in the cart for a product 

 A product cannot be added because of category permissions settings 

 A product is assigned to another website 

 A product is configured to be not visible individually 
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 A product cannot be added because of other errors, such as errors in installed extensions or 

customization 

55.5 Loading a Spreadsheet with SKUs: Requirements 

The same requirements are applied to a spreadsheet with SKUs in both the frontend and backend. 

A spreadsheet must have at least two columns and must be stored in a .csv file. The header row 

must contain “sku” and “qty”. If a file contains other columns, they will be ignored, but the file will 

be processed correctly. 

Figure 311 shows an example of valid content of a .csv file for ordering by SKUs. 

sku  qty

book1 2

book2 3

book3 1  

Figure 311. A Valid Spreadsheet for Ordering by SKU 

Files with SKUs are processed according the following rules: 

 A row where the SKU value is empty is ignored. 

 A row where the SKU value is not empty, and the QTY value is empty, invalid, or equal to 

“0,” is processed and the corresponding product is placed in the “Products requiring 

attention” grid.  
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PART X: MAGENTO MOBILE 

56 XML Connect Module: Managing Mobile 
Applications 

XML Connect is a module that enables you to create and manage Magento mobile applications. It also 

enables these applications to load content and communicate with a Magento Enterprise Edition instance on 

the server after being installed on a mobile phone or other mobile device. See Figure 312. 

 

Figure 312. Magento Application on a Mobile Phone 

Magento Enterprise Edition integrate the XML Connect module with the system. You can easily create 

mobile applications for your stores from the Magento Admin Panel. 

To enable or disable the XML Connect module, select System > Configuration > ADVANCED > Advanced 

and select Enable or Disable in the Mage_XmlConnect drop-down menu. 
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According to the Magento Mobile logic, a mobile application is strictly bound to a certain store and certain 

mobile device type. The general workflow for creating and activating a mobile application is the following: 

1. Create a mobile application in the Admin Panel. 

2. Subscribe to one of the Magento support plans and receive the activation key. 

3. Submit your application to Magento. 

4. Magento adds your application to the store, like App Store or Google Play, and supports it for 
the period corresponding to your subscription plan. 

56.1 Creating a New Mobile Application 

To access the mobile applications management section, select Mobile > Manage Apps from the top 

menu.  

To create a new application: 

1. Click the Add App button in the upper-right corner of the Manage Apps page. The New App 
page opens (see Figure 313). 

 

Figure 313. Creating a New Mobile Application, Selecting the Device Type 

2. Select the targeted device type in the Device Type drop-down menu. The available options are 
iPad, iPhone, and Android. Click the Continue button.  

3. At this step, several tabs with settings are available (see Figure 314). 

 

Figure 314. Configuring a New Mobile Application 

 On the General tab, specify the following fields: 
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o App Name: Specify the name of the application. It is an internal name and it is not 

displayed to the application users. 

o Store View: Select the store view the application is created for. 

o Catalog Only App: Decide whether your application shows only the catalog or 

provides the options to buy products or add them to the Wishlist.  

Note: These settings are applied after the general website restrictions, set in the 
System > Configuration > GENERAL > General > Website Restrictions. 

 On the Design tab you can customize the design of your application:  

o In the Images field set you specify your logo, banners, and background image. Up 

to five banners can be loaded; they will be rotating. For each banner you can 

choose the action to be performed on banner click. To set an action for a banner, 

click the link next to the Action label. See Figure 315. 

 

Figure 315.  Setting an Action for a Banner 

You can choose to redirect customers to product page, CMS page, or category 

page. For product and category pages, you will need to type the name of the 

product or category. A CMS page can be selected from a list. 

After you add the images, you can save the application, using the Save or Save and 

Continue Edit buttons in the upper-right corner of the page. 

o In the Color Themes field set you can customize the color schemes. 

o In the Tabs field set you can manage the tabs of your application. 

You can see the changes applied at once: the preview image is displayed in the 

right part of the page. 

 On the Content tab you can add pages, based on the existing CMS pages, which will be 

available for navigation for the application users. To add a new page, click the Add Page 

button. For a new page you need to specify: 

o In the Label field, specify the label for the application page. The label is visible for 

application users. 
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o In the Get Content from CMS Page list, select from which CMS page the content is 

taken. The list contains default CMS pages and custom CMS pages created for the 

selected store view. 

o On the Payment Methods tab, you can configure which payment methods will be 

available for the application users. The following fields are available: 

o Enable Standard Checkout: If you select Yes all payment methods that are 

supported by Magento Enterprise Edition, will be available. 

o Activate PayPal MECL: In this field you can activate the PayPal mobile embedded 

payment method. You can choose to use MECL (Mobile Express Checkout Library) 

alongside standard checkout, or use it as your only checkout method for Magento 

mobile. PayPal MECL requires a PayPal business account. 

 On the Analytics tab you can enable Flurry Analytics, after subscribing to a Magento 

support plan and submitting your application to Magento. You will be able to see the 

statistics both in the Admin Panel and at www.flurry.com. The following fields are 

available: 

o Enable Flurry Analytics - If you select Yes, the Flurry API Code field appears.  

o Flurry API Code - Specify your Flurry API code. You can request it from Magento, 

after submitting your application. 

 Flurry Analytics Site - Contains the link to www.flurry.com, where you can view the 

statistics after it is enabled.  

Note: Enabling the Flurry Analytics is currently possible for iPhone applications only. 
Support for Android and iPad are planned for a future Magento Enterprise Edition 
release. 

 The Submission History tab contains records about the application submissions. You need 

to resubmit the application if you make changes in any submission settings. It refers to the 

settings on the Submit App page, which opens on Save and Submit App button click. These 

settings are described in ”Subscribing to a Magento Support Plan and Submitting the Mobile 

Application ,” page 447. 

 On the Cache Management tab you can set the lifetime of cache on the application side. To 

disable it, leave the Cache Lifetime field empty. 

 On the Social Networking tab you can link your application with your accounts on Twitter, 

Facebook, or LinkedIn via API. 

 On the Push Notification tab you can enable or disable the push notifications service of 

Urban Airship.  

Note: You can find more about the AirMail by Urban Airship at 
http://urbanairship.com/products/airmail/. 

To enable the service, you need to accept Urban Airship's Terms of  Service and 

make the following configurations: 

 In the Enable AirMail Message Push notification list, select Yes. Additional fields for 

configuration appear. 

http://www.flurry.com/
http://www.flurry.com/
http://urbanairship.com/products/airmail/
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 In the Application Key, Application Secret, and Application Master Secret fields, specify 

your Urban Airship account credentials. You can request them from Magento at 

magentomobile@magento.com, after submitting your application to Magento. 

 In the Mailbox title field, specify the title for your mailbox as it will be shown on the More 

Info tab of the application. 

You can manage templates for your AirMail push notifications and messages on the 

AirMail templates page. To access it, select Mobile > Message Templates. 

Managing the message templates and message sending is described later in this 

chapter. 

4. To save the newly created application, click the Save or Save and Continue Edit button in 
upper-right corner of the page. 

56.2 Subscribing to a Magento Support Plan and 
Submitting the Mobile Application  

You can order a subscription for a Magento support plan at 

http://www.magentocommerce.com/product/mobile. When you buy a subscription, you receive the 

activation key for your application from Magento.  

To submit your application to Magento: 

1. Click the necessary application in the list of applications on the Manage Apps page. The 
application opens for editing. 

2. Click the Save and Submit App button in the upper-right corner of the page. In the Submit App 
page, specify the following: 

 In the Activation Key field under Key, specify your activation key from Magento. 

 Information that you specify in the Submission Fields field set will be displayed in the 

applications store, for example App Store. The following fields are available: 

o In the Title field, specify the name of your application. It is shown to the customers, 

so we recommend choosing a 10-12 character recognizable title. 

o In the Description field, specify the description of your store. It appears in the App 

Store. 

o In the Contact Email field, specify the email address to contact for this application 

and submission issues. 

o The Price field is currently unavailable for editing, as only free applications are 

currently allowed in Magento. 

o In the Country field select the countries where the application will be available. 

o In the Copyright field enter your copyright text. It appears in the information 

section of your application. 

mailto:magentomobile@magento.com
http://www.magentocommerce.com/product/mobile
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o In the Keywords fields enter a comma-separated list of  keywords for your 

application. The field may contain 100 characters maximum. These keywords are 

matched to users' searches in the application stores.  

 Under Icons: 

o In the Large iTunes Icon field (or Large Android Market Logo for Android 

applications), browse for the image that will appear as a large icon of your image in 

the applications store. You do not need to gradient or soften edges; this is done 

automatically by Apple. Required size: 512px by 512px.  

o In the Loader Splash Screen field, browse for the image that will appear first on the 

screen, while your application is loading. Required size: 320px by 460px. For 

iPhone applications you can specify a separate image for iPhone retina screens in 

the Loader Splash Screen (iPhone 4 retina) field. Required size: 640px by 920px. 

o In the Custom App Icon field, browse for the image that will be used as your 

application icon, after the user installation of your application. Recommended size: 

57px by 57px at 72 dpi. 

For iPhone applications you can specify a separate image for iPhone retina screens 

in the Custom App Icon (iPhone 4 retina) field. Required size: 114px by 114px. 

o In the Copyright Page Logo field, browse for your logo image, which is displayed 

on the copyright page of your application. Recommended size: 100px by 100px.  

For iPhone applications you can specify a separate image for iPhone retina screens 

in the Copyright Page Logo (iPhone 4 retina) field. Required size: 114px by 114px. 

3. Click the Submit App button in upper-right corner of the page. 

After you submit your application, you can contact the Magento team, for example by email at 

magentomobile@magento.com, to request Urban Airship and/or Flurry credentials, and any other 

information you need. Placing your application in the application store, for example the App Store, 

takes from several hours to several days.  

The history of applications submissions is stored in Magento. To view it, select Mobile > Submission 

History. The App Submission History page opens, where you can see the list of submitted 

applications, submission dates, and activation keys.  

56.3 Push Notifications and AirMail Messages to the 
Application Users 

In the Magento Admin Panel you can create and send AirMail push notification messages, also 

called push notifications, and AirMail messages for your mobile application users. Push 

notifications, which are plain text messages, are shown to the user upon launching the application. 

AirMail messages are rich-media, including HTML, images, video and audio. 

In Magento, message sending is implemented using the cron job scheduler. By default, it checks for 

new messages to be sent every 5 minutes. 

mailto:magentomobile@magento.com
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To send a push notification or AirMail message to application customers you need to take two steps: 

1. Create a template for the message.  

2. Add the message to the queue.  

You select the message type when adding the message to the queue. When you send the AirMail 

message, the push notification is sent as well. For example, you can make it something like “You've 

got a new message from YourStore store.” The push notification appears when the user opens your 

application. The AirMail message is stored in the AirMail application inbox. 

Creating a Message Template 

To access the templates managing feature, select Mobile > Message Templates from the Magento 

top menu. 

To create a new message template: 

1. Click the Add New Template button in the upper-right corner of the page. The New Template 
page opens. 

2. The following fields are available: 

 Application - Select the application for which the message template is intended. 

 Template Name - Specify the template name, maximum 255 characters. 

 Push Title - Specify the text of the push notification messages that will be sent using this 

template, maximum 140 characters.  When you send the AirMail message, the push 

notification is sent as well. 

 Message Title - Specify the title for the AirMail messages, sent using this template, 

maximum 140 characters. 

 Template Content - In this field you can create the content of your AirMail message. To add 

the content you can use the WYSIWIG editor, or hide the editor and write the HTML code 

in the text window. You can hide and show the editor using the Show/Hide Editor button.  

 You can insert variables with the store contact information and widgets to your template.  

To insert a variable, click the corresponding icon in the editor, or click the Insert 

Variable button if the editor is hidden. The list of available variables opens. Click 

the desired variable to insert it.  

To insert a widget, click the corresponding icon in the editor, or click the Insert 

Widget button if the editor is hidden. The Insert Widget pop-up window opens, 

where you need to take several steps to set the widget. When you are finished, 

click the Insert Widget button in the upper-right corner of the window.  

3. Click the Save button in the upper-right corner of the page to save the template. 

Message Queue Management 

While adding the message to the queue, you have the option of specifying what type of message 

you will send, a push notification or an AirMail message. 
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To add messages to the sending queue: 

1. Select Mobile > Message Templates. 

2. For the desired message template in the Action column, select Queue Message. The New 
AirMail Message Queue page opens. 

3. Specify the following: 

 In the Message Type drop-down menu under Message Settings, select the type of the 

message you want to send. It can be Push message or AirMail message. 

Note: For Android applications, only push notifications are available. 

 In the Start Date field, specify the start date and time for sending the message. You can type 

it manually or select from the calendar by clicking the calendar icon. If you leave Start Date 

empty, the message will be sent immediately after you finish configuration and click Queue 

Message. 

 Under Template, specify the following: 

o In the Push Title field, you can edit the text of the push notification message, 

maximum 140 characters. If you intend to send a push notification, and have 

selected Push message in the Message Type drop-down menu, proceed to the step 

4. 

o In the Message Title field, you can edit the title of the AirMail message, maximum 

255 characters. 

o In the Template Content field, you can make changes in your message template. 

For more information about editing the template, see the last step of the procedure 

in “Creating a Message Template,” page 449. 

4. Click the Queue Message button in the upper-right to add the message to the queue. You are 
redirected to the AirMail Messages Queue page, the message is added to list with In Queue 
status. 

To cancel the message sending, select Cancel in the Action column for this message. Canceled 

messages are not deleted and can be previewed.  

To delete the message from the sending queue, select Delete in the Action column for this message.
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APPENDICES 

A Getting Help 
The Magento software offers a variety of options and possibilities, but also has a learning curve. Magento 

provides several resources for getting help discovering Magento and using it daily to attain your eCommerce 

objectives. 

You can start with the Search field at the top of the community site found at 

http://www.magentocommerce.com, which provides results from the Magento forum, knowledge base, wiki, 

groups, and other resources.  

If you are unable to find answers to your questions, try posting your question in the Magento Answers site 

and the Magento forums, where thousands of participants help each other with Magento issues.  

To access Magento Answers: 

Go to http://www.magentocommerce.com/answers/ and log in or using the user name and password 

that you created before downloading Magento. (If you do not have a Magento user name, you can 

register for one from this page.) Follow the onscreen directions to ask your question. 

To access Magento forums: 

Go to http://www.magentocommerce.com/boards and log in using the user name and password that 

you created before downloading Magento. Choose a forum that best matches your question. 

If you found the answer yourself and were unable to find it elsewhere, please share it with others. 

Use the wiki or forums to write and share it. 

There are also several other community features in addition to the forums described above that enable the 

exchange of ideas and help. They are: 

 Groups: Link community members working on or interested in specific subjects, such as 

Designing For Magento and Drop Shippers. 

 Chat: Provides a real time discussion with Magento community members. 

 Wiki: Provides community editable pages for sharing ideas and findings, tutorials and 

information.  

The following lists other resources available to help you use get the most out of Magento: 

Knowledge Base 

The Magento knowledge base is a Wiki that provides instructions published by Magento or 

community members in the form of guides and “how-to” articles. 

At: http://www.magentocommerce.com/knowledge-base  

http://www.magentocommerce.com/
http://www.magentocommerce.com/answers/
http://www.magentocommerce.com/boards
http://www.magentocommerce.com/knowledge-base
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Webinar Archive 

Up-to-date webinars are provided by Magento in which you can learn real-world tips and tricks in 

order to get the most out of your stores and promotions. 

At: http://www.magentocommerce.com/media/webinar-archive 

Screencasts 

Screen casts are presentation videos that can guide you through many of the Magento features. 

At: http://www.magentocommerce.com/media/screencasts 

Designer’s Guide to Magento 

The Designer’s Guide to Magento provides information for designers describing Magento concepts 

and design implementation in Magento. 

At: http://www.magentocommerce.com/design_guide  

Magento Blog  

The Magento Blog contains fresh updates describing new Magento releases, interesting showcases 

and events. 

At: http://www.magentocommerce.com/blog  

Magento on Twitter 

You can keep up with Magento events and announcements by following Magento on Twitter. 

At: http://twitter.com/magento 

Technical Documents and Magento Core API 

These provide developers with information on how to develop Magento.  

At: http://docs.magentocommerce.com/ 

Here you can find information about all Magento classes and functions. 

At: http://www.magentocommerce.com/support/magento_core_api 

Here you can find information and usage examples for calling Magento using an API. This enables 

easier integration of Magento with existing systems. 

http://www.magentocommerce.com/media/webinar-archive
http://www.magentocommerce.com/media/screencasts
http://www.magentocommerce.com/design_guide
http://www.magentocommerce.com/blog
http://twitter.com/magento
http://docs.magentocommerce.com/
http://www.magentocommerce.com/support/magento_core_api
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B Glossary 
The following is a complete list of Magento terms and definitions. 

above the fold The web page content that is immediately visible in 

the browser window; section of a page that is 

displayed without the need to scroll. 

Admin panel Administrative panel; back office; private section of 

store where orders, catalog, content, and 

configurations are managed.  

alt text The text that is displayed in place of an image when 

the user is unable to view the image. 

anchor text The visible text that is anchored to another page or 

page section; the literal text of a hyperlink. 

API Application Program Interface: A software interface 

that lets third-party applications read and write to a 

system using programming language constructs or 

statements. 

attribute A characteristic or property of a product; anything 

that describes a product. Examples of product 

attributes include color, size, weight, and price.  

authorization To give a service permission to perform certain 

actions or to access resources. 

average inventory cost Product price, less coupons or discounts, plus freight 

and applicable taxes. The average is determined by 

adding the beginning cost of inventory each month, 

plus the ending cost of inventory for the last month of 

the period. 

banner Promotional graphics displayed either horizontally on 

the top of a web page or vertically on the left or right 

margins. Website advertisements are often displayed 

as banners. 
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B2B Business to Business: A type of business transaction 

between two business entities that are not the final 

consumers of the goods or services. 

B2C Business to Consumer: Business transactions between 

a business entity and a consumer. 

batch processing To perform a task or make a change to multiple items 

all at once, without manual repetition.  

bounce rate The percentage of visitors to your site that leave 

without viewing any other pages. 

brand A unique identity that defines a particular product or 

group of products.  

breadcrumb A navigation aid that helps the user to keep track of 

their location within your store.  

brick and mortar A retail business with a permanent physical location, 

as opposed to being entirely virtual. 

broken link A hyperlink that fails to send the user to its intended 

web page. 

canonical URL The canonical meta tag redirects search engines to 

the correct URL, when seemingly duplicate content is 

encountered on the server. 

capture The process of converting the authorized amount into 

a billable transaction. Transactions cannot be 

captured until authorized, and authorizations cannot 

be captured until the goods or services have been 

shipped. 

cardholder A person who opens a credit card account and is 

authorized to make purchases. 

category A set of products that share particular characteristics 

or attributes. 
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conversion A marketing term that indicates a goal has been 

reached. If the goal is to sell a product, conversion is 

reached when a visitor to your site becomes a buyer. 

conversion rate The percentage of visitors who are converted into 

buyers.  

checkout process The process of gathering the payment and shipping 

information that is necessary to complete the 

purchase of items in the shopping cart. In the final 

step, the customer reviews and places the order. 

CMS Content Management System: A software system that 

is used to create, edit, and maintain content on a 

website.  

CSV Comma Separated Values: A type of file used to store 

data values which are separated from each other by 

commas.  

CVM  Card Verification Method: A way to verify the identity 

of the customer by confirming a 3-digit or 4-digit 

credit card security code with the payment processor. 

credit memo A document issued by the merchant to a customer to 

write off an outstanding balance because of 

overcharge, rebate, or return of goods. 

CSS Cascading Style Sheets: A style sheet language that 

controls the appearance of HTML documents; a way 

to control the appearance of text, graphics, lists, links, 

and all other elements on a web page. 

domain The address of a website on the web; what the 

customer types in their browser address bar to access 

the store. 

double opt-in The process for subscribing email recipients by 

requiring them to take a secondary step to confirm 

that they want to receive emails. 



Glossary 

456 

dynamic content A web page that displays different content depending 

on the user request. 

keyword A term or phrase used in a search to filter for content 

that is of significant importance to that term or 

phrase. 

FAQ Frequently Asked Questions. 

favicon Short for favorites icon; a 16x16 or 32x32 pixel icon 

associated with a website; is displayed in the browser 

address bar and next to the site name in a bookmark 

list. 

FOB Freight On Board: A shipping term indicating who is 

responsible for paying transportation charges. 

fulfillment The process of managing customer shipments. 

gateway A transaction bridge between a customer and a 

payment processing service that is used to transfer 

money between the customer and the merchant. 

gross margin The difference between the cost and price of a 

product.  

home page The first home page a visitor sees when they access 

your website URL. Considered the most important 

page on your website according to search engine 

indexers. 

HTML HyperText Markup Language: A standard for tagging 

and structuring text, images, videos, and other media 

on a web page. 

invoice A document that provides a detailed description of a 

purchase, including products purchased, quantity, 

price, shipping cost, sales tax, and total. 

JavaScript A scripting language used with HTML to produce 

dynamic effects and interactions on web pages.  
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landing page A page on your site where a visitor arrives after 

clicking a link or advertisement. 

link juice The value and authority transferred from one web 

page to another via hyperlinks (or links). Link juice 

affects a website’s page rank, a factor used to rank a 

search engine results page. 

locale A set of configurations that defines the user’s 

language, country, tax rate, and other settings. 

login The process of signing into an online account. 

markdown The amount subtracted from the original price of a 

product.  

markup A percentage added to the cost of an item to 

determine the retail price. 

merchant account An account with a bank or financial institution that 

makes it possible to accept credit card transactions. 

meta tags Information in a web page that is not displayed on the 

page itself, but is used by search engines to determine 

the page title, description, and page keywords. 

navigation The primary group of web page links that a customer 

uses to navigate around the website; the navigation 

links to the most important categories or pages on an 

online store. 

opt-in The process by which a user consents to receiving 

emails from an online store. 

packing slip A document that is usually included in a shipped 

package that describes the contents. Packing slips do 

not include financial or account information. 

payment gateway A service that charges your customers’ credit cards 

and sends the funds to your merchant account, for 

deposit into your business bank account. 



Glossary 

458 

PCI Payment Card Industry: Refers to debit and credit 

cards and their associated businesses.  

purchase order (PO) A written sales contract between a buyer and seller 

that describes the merchandise or service to be 

purchased from a vendor. 

privacy policy A document that explains the merchant’s policies for 

handling customer information. 

redirect A method used to alert browsers and search engines 

that a page has been moved. 

301 Redirect: Permanent change 

302 Redirect: Temporary change 

relative link A hyperlink that includes only the address of the 

linked page that is relative to the linking page, rather 

than the full URL. 

return policy A document that explains the merchant’s rules 

regarding the return of products by customers. 

robots.txt A file placed on a website that tells search engine 

crawlers which pages not to index. 

RSS feed Really Simple Syndication: A technology that creates 

web content syndication and allows web users to 

subscribe to product feeds, websites, and blogs. 

SaaS Software as a Service: A software delivery model 

where the vendor provides the software and hosting 

environment, and customers pay for the service by 

subscription or per use. 

security certificate Information that is used by the SSL protocol to 

establish a secure connection. 

SEO Search Engine Optimization: The process of 

improving a website’s search engine rankings in order 

to increase valued visitors. 
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settlement Settlement occurs when the acquiring bank and the 

issuer exchange funds and the proceeds are deposited 

into the merchant account. 

shipping carrier A company that transports packages. Common 

carriers include UPS, FedEx, DHL, and USPS. 

shopping cart A grouping of products that the customer wishes to 

purchase at the end of their shopping session. 

Site map A page that provides search engines with an efficient, 

alternate route through your site. 

SKU Stock Keeping Unit: A number or code assigned to a 

product to identify the product, options, price, and 

manufacturer. 

splash page A promotional page with a product or advertisement; 

normally displayed before the home page. 

SSL certificate  A validation and security mechanism that identifies 

the merchant and encrypts credit card and other 

sensitive information. 

static content Content that does not change frequently. See also 

dynamic content. 

static block A fixed content block that can be displayed on 

various content pages in a store. 

theme A package that contains graphics and appearance 

information, and customizes the look and feel of the 

store. 

transactional email A notification email sent to the customer when a 

transaction is processed. 

URL Uniform Resource Locator: The unique address of a 

page on the internet. 

usability Refers to the degree to which a product or service is 

easy to use by its customers. 
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WYSIWYG What You See Is What You Get: An editor that 

displays formatted text as it will appear in its final 

published form. 

XML Extensible Markup Language: A markup format 

derived from SGML that it used to format information 

for publication and distribution.  
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C System Requirements 
Magento must be installed on a web server in a LAMP environment: Linux, Apache, MySQL, and PHP. At 

the base level, Magento requires the following software. 

Operating Environment (LAMP) 

Supported Operating Systems (Unix only) 

 Linux x86, x86-64 

Supported Web Servers: 

 Apache 1.3.x 

 Apache 2.0.x 

 Apache 2.2.x 

MySQL: 

 4.1.20 or newer 

 InnoDB storage engine 

PHP Compatibility: 

 PHP v5.2.13 or later 

 Required extensions: 

o PDO_MySQL 

o simplexml 

o mcrypt 

o hash 

o GD 

o DOM 

o iconv 

o curl 

o SOAP (if Webservices API is to be used) 

 Configuration requirements: 

o Safe_mode off 

o Memory_limit recommended 512MB (minimum 256MB) 

Basic Configuration Requirements 

SSL: 

 If HTTPS is used to work in the admin, SSL certificate should be valid. Self-signed SSL 

certificates are not supported. 
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Mail server: 

 SMTP server or Sendmail-compatible Mail Transfer Agent (MTA) 

Server privileges: 

 Ability to run scheduled jobs (crontab) with PHP 5 

 Ability to override options in .htaccess files 

 We also recommend the use of APC as a bytecode cache for performance improvements. 

You can find it in the PECL archives here: http://pecl.php.net/package/APC. Other bytecode 

cache systems are not supported at this time. 

Requirements for Enterprise v1.8 Encoded only: 

 ionCube loader v3.1.23 or above 

Supported Browsers for Backend Admin 
 Adobe Flash browser plug-in must be installed 

 Mozilla Firefox 3.5 and above 

 Apple Safari 2.x and above (Mac only) 

 Microsoft Internet Explorer 7 and above 

 Google Chrome 7 and above 
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D Magento Payment Bridge 
Magento Payment Bridge is a secure payment application that helps merchants in meeting PCI compliance. 

It is installed separately from Magento Enterprise Edition, making PCI compliance easier. Magento Payment 

Bridge is provided with a subscription to Magento Enterprise Edition. 

All sensitive credit card data that is received from customers during the checkout process is put into the 

token in Magento Payment Bridge and is stored there, encrypted, until the payment system returns the 

successful result of a payment transaction. After the transaction is completed, the payment data within 

Magento Payment Bridge is cleaned from the token, which remains in the database during a specific period 

of time. With Magento Payment Bridge, no sensitive credit card data is passed over or stored in Magento, 

which guarantees the security of customers’ credit card data. 

Enabling Payment Bridge 

Before enabling the Payment Bridge functionality in the Magento backend configuration, your Magento 

Payment Bridge administrator must create a merchant account and configure payment gateways in the 

Magento Payment Bridge payment application. The Magento Payment Bridge administrator provides the 

merchant with the merchant account information required for the authorization by the Payment Bridge. 

Perform the following steps to enable and configure the Payment Bridge functionality in the Magento 

backend: 

1. Log in to the Magento admin panel. 

2. Navigate to System > Configuration. 

3. In the Current Configuration Scope field in the upper-left corner of the page, leave Default 
Config or select your website. It is recommended that you enable and configure Payment Bridge 
on the global level if your business logic allows. 

4. In the left column under SALES, click Payment Methods and expand the Payment Bridge 
field set. 

5. Set the Enabled field to Yes. 

Note: The functionality will be applied only if the Magento Payment Bridge application 
is installed and configured with the merchant account and required payment 
gateways. You need to contact your Magento Payment Bridge administrator to 
perform necessary configurations. 

6. In the Merchant Code field, enter the merchant ID specified by the Magento Payment Bridge 
administrator during the merchant account creation. 
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Note: After the Magento Payment Bridge administrator creates a merchant account, the 
merchant code, merchant key, and data transfer key are provided to the merchant. 

7. The merchant key (either entered by the Magento Payment Bridge administrator, or 
automatically generated by the payment application during the creation of a merchant account) 

must be specified in the Merchant Key field. The merchant key is a unique code that helps 
secure the connection to the Payment Bridge. 

8. In the Gateway Basic URL field, specify the URL to connect to the Payment Bridge payment 
application. 

9. The data transfer key, which is generated during the merchant account creation in Magento 

Payment Bridge, must be specified in the Data Transfer Key field. The data transfer key 
encrypts any data that is transferred between the merchant and the Payment Bridge. 

10. The Magento Unique Identifier field (present only if Current Configuration Scope is set to 
Default Config) is used if you have several instances of Magento using the same Payment Bridge 
merchant account. In this field you can enter the identifier for the current Magento instance. 
Assigning identifiers is essential if your websites that are powered by different Magento 
instances use saved payment methods, such as Authorize.Net CIM. 

11. In the Debug field, specify whether data messages that are sent to the payment system and 
received from it are written into the system log file. See Figure 316. 

 

Figure 316. Enabling Payment Bridge Functionality 

12. To save your changes, click Save Config, and proceed to configure payment methods that will 
work with the Payment Bridge payment application. 

Payment Gateways Supported by Magento Payment Bridge 

The Magento Payment Bridge payment application supports the following payment methods (which 

are integrated with external payment gateways). Some of the methods can work with or without 

Payment Bridge. 

 Integration with PayPal: 
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o Website Payments Pro 

o Website Payments Pro Payflow Edition 

o Payflow Pro Gateway 

 Integration with Authorize.Net (Authorize.Net CIM works only with Payment Bridge) 

 Integration with Braintree (works only with Payment Bridge) 

 Integration with CyberSource (works only with Payment Bridge) 

 Integration with DIBS (works only with Payment Bridge) 

 Integration with eWAY Direct Payments (works only with Payment Bridge) 

 Integration with First Data Global Gateway (works only with Payment Bridge) 

 Integration with Ogone Direct Link (works only with Payment Bridge; 3D Secure available) 

 Integration with Paybox Direct (works only with Payment Bridge) 

 Integration with Payone.de (works only with Payment Bridge; available only if your base 

currency is euros)  

 Integration with PSiGate (works only with Payment Bridge) 

 Integration with Sage Pay Direct (works only with Payment Bridge) 

 Integration with WorldPay (works only with Payment Bridge) 

All methods except PayPal Payflow Pro Gateway require having a merchant account in the 

corresponding payment service provider. 

Most of the listed payment methods are available “out-of-the-box” in Magento Enterprise Edition 

with Magento Secure Payment Bridge installed, enabled, and properly configured.  

The following methods are not included in Magento Enterprise Edition 1.12 with Magento Secure 

Payment Bridge version 1.11.18. These methods are available for download from support accounts 

on magentocommerce.com as an individual patch: 

 Integration with PSiGate  

 Integration with WorldPay 

 Integration with DIBS 

 Integration with Sage Pay 

Payment Services Supported by Magento Payment Bridge 

Magento Payment Bridge supports the following payment services: 

 3D Secure Credit Card Validation by Cardinal Centinel 

  Kount fraud detection service; if enabled, this service is automatically used for all payments 

conducted via Payment Bridge 
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3D Secure Credit Card Validation by Cardinal Centinel 

Cardinal Centinel 3D secure credit card validation can be used for the following payment methods, 

if they are configured to use Payment Bridge: 

 Authorize.Net 

 PayPal Website Payments Pro 

 PayPal Website Payments Pro Payflow Edition 

 PayPal Payflow Pro Gateway 

Note: Sage Pay Direct and Ogone Direct Link payment gateways use their own 3D 
secure credit card validation services, which are configured during the payment 
gateway configuration in the Payment Bridge application. 

Cardinal Centinel 3D secure credit card validation payment service is enabled and configured in the 

Magento Payment Bridge payment application. To use Cardinal Centinel 3D secure credit card 

validation payment service, you must have an account in Cardinal Centinel system.   

Kount Fraud Detection Service 

Kount fraud detection service is enabled and configured in the Magento Payment Bridge payment 

application. When the service is enabled, it is used for all payments conducted via Payment Bridge.  

To use Kount fraud detection service, you need to have an account in the Kount system, The set of 

rules for credit card validation is created in the Kount agent web console. For each transaction, the 

Kount system sends one of the following responses about the transaction status: 

 Approve 

 Review 

 Escalate 

 Decline 

If a Review or Escalate response is received, the transaction is marked with a “Suspected Fraud” 

comment in the Magento Admin Panel. This comment is displayed in the Comments History section 

on the Order View page of the corresponding order, which you can view by navigating to Sales > 

Orders. If Kount declines the transaction, the corresponding order is not created in Magento and the 

transaction is not completed. In all other cases the status of a transaction assigned by Kount does not 

influence the transaction itself; it serves only as an indicator for the merchant. 

Functionality Overview: Payment Methods Working via 
Payment Bridge 

The following table presents the functionality matrix for payment methods which work via Payment 

Bridge. 
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Payment method Partial capture 
online 
(same for offline) 

Full refund online 
from the Invoice 
page 

Partial refund 
online from the 
Invoice page 
(same for offline) 

Partial refund 
offline from the 
Order page 

PayPal Payflow Pro 
Gateway  

no yes no no 

PayPal Website 
Payments Pro 
Payflow Edition  

yes yes yes yes 

PayPal Website 
Payments Pro  

yes yes yes yes 

Authorize.Net  no yes yes yes 

Braintree no yes yes yes 

CyberSource no yes no no 

DIBS no yes yes yes 

eWAY Direct no no no yes 

First Data Global 
Gateway 

no yes no no 

Ogone Direct Link yes yes yes yes 

Paybox Direct no no no yes 

Payone.de no yes no no 

PSiGate no yes yes yes 

Sage Pay Direct yes yes yes yes 

WorldPay no yes yes yes 

 

Full capture (capturing the entire order total) is available both ways, online and offline (except for 

eWAY Direct) for all listed payment methods.  

Online refund from the Order page is not available for any of the methods listed in the table.  

Full offline refund is available for all payment methods. 

Configuring Payments Methods to Use Payment Bridge 

For each payment method that uses Payment Bridge, enabling/disabling and configuring is a two-

step procedure (the order is arbitrary): 

 Enabling/disabling and configuring the method in Payment Bridge (via SSH client). Payment 

gateway credentials are entered during this configuration.  

 Enabling/disabling and configuring the method in the Magento admin panel.  

For details about step 1, refer to Magento Payment Bridge PA-DSS Implementation Guide. 

The following sections describe step 2, enabling and configuring payment methods in 

Magento. 
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Payment Methods Working Only with Payment Bridge 

For all payment methods that work only if Payment Bridge is enabled and configured, the options 

which should be configured in the Magento admin panel are largely the same, though the set of 

available options may differ. Configuring the Braintree payment method is described here and can 

be used as an example for configuring other payment methods. 

To enable and configure the Braintree payment method in the Magento admin panel: 

1. Navigate to System > Configuration.  

2. In the Current Configuration Scope field in the upper-left corner of the page, leave Default 
Config or select the desired website.  

3. In the left column under SALES, click Payment Methods and expand the Braintree field set. 

4. In the Enabled field, select Yes.  

5. In the Title field, specify the name of the payment method that will be displayed to the customer 
in the Payment Information section of the one-page checkout. This parameter can be set up for 
each store view. 

6. In the Payment Action field, choose the way payments will be authorized in the Braintree 
payment system and the entities that will be created after the successful transaction in the 
backend as a result of the payment procedure. The following options are available:  

o Authorization: Funds on the customer’s card are only authorized on the Braintree 

system, and only the order is created in the backend of your store. You can later create 

an invoice and conduct the capturing. 

o Sale: Funds on the customer’s card are authorized and captured on the Braintree side, 

and as a result an order and an invoice are created in the backend of your store. 

7. In the Enable Vault field, choose whether the Vault functionality will be enabled. This 
functionality enables the secure storage of customers’ sensitive payment information on the 
Braintree side. After a credit card profile is saved, Magento/Payment Bridge will store the first 4 
and last 6 digits of the card number. Thus, the tokens will be generated and used to charge the 
customers. Other information, in particular, customers’ addresses, could be stored in the vault 

as well. 

8. In the Sort Order field, decide what will be the position of the method in the list of available 
payment methods displayed to customers during checkout. 

9. To save the configuration, click Save Config. 

Payment Methods for which Payment Bridge Usage Is Optional 

For all payment methods which can work both ways (through Payment Bridge and directly with 

payment gateways), the options which should be configured in the Magento admin panel are largely 

the same, (though the set of available options may differ). Configuration of the Authorize.Net 

payment method is described here and can be used as an example for configuring other payment 

methods.  
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To enable and configure the Authorize.Net payment method to use Payment Bridge in 
the Magento admin panel: 

1. Navigate to System > Configuration. 

2. In the Current Configuration Scope field in the upper-left corner of the page, leave Default 
Config or select the desired website.  

3. In the left column under SALES, click Payment Methods and expand the Authorize.Net field set. 

4. In the Enabled field, select Yes. 

5. In the Use via Payment Bridge field, select Yes.  

6. Configure other options as necessary. 

7. To save your configuration, click Save Config. 

Note: For payment methods that can work with or without Payment Bridge, the set of 
options available for configuring can differ depending on your choice concerning 
Payment Bridge usage. For example, for the Authorize.Net payment method, 3D 
Secure Card Validation is available only if the Payment Bridge is not used; 
Customer Information Manager is only available when Payment Bridge is used.  
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E Country-Specific Lists of PayPal Methods 
Integrated with Magento  

The following PayPal payment methods are available according to merchant location. 

United States 
 PayPal Payments Advanced (Includes Express Checkout)+ 

 PayPal Payments Pro (Includes Express Checkout) 

 PayPal Payments Standard+ 

 PayPal Payflow Pro (Includes Express Checkout)- 

 PayPal Payflow Link (Includes Express Checkout) 

 PayPal Express Checkout  

Canada 
 PayPal Payments Pro (Includes Express Checkout) 

 PayPal Payments Standard 

 PayPal Payflow Pro 

 PayPal Payflow Link (Includes Express Checkout) 

 PayPal Express Checkout  

Australia 
 PayPal Payments Standard 

 PayPal Payflow Pro 

 PayPal Payments Pro Hosted Solution 

 PayPal Express Checkout  

United Kingdom 
 PayPal Express Checkout 

 PayPal Payments Standard 

 PayPal Payments Pro Payflow Edition (Includes Express Checkout) 

 PayPal Payments Pro Hosted Solution 

Japan 
 PayPal Express Checkout  

 PayPal Payments Standard 

 PayPal Website Payments Plus (PayPal Payments Pro Hosted Solution) 
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France 
 PayPal Express Checkout  

 PayPal Payments Standard 

 PayPal Integral Evolution (PayPal Payments Pro Hosted Solution) 

Italy 
 PayPal Express Checkout  

 PayPal Payments Standard 

 PayPal Pro (PayPal Payments Pro Hosted Solution) 

Spain 
 PayPal Express Checkout  

 PayPal Payments Standard 

 PayPal Pasarela integral (PayPal Payments Pro Hosted Solution) 

Hong Kong  
 PayPal Express Checkout 

 PayPal Payments Standard 

 PayPal Payments Pro Hosted Solution 

New Zealand  
 PayPal Express Checkout 

 PayPal Payments Standard 

 PayPal Payflow Pro 

Others 
 PayPal Express Checkout  

 PayPal Payments Standard 
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F Shipping Methods and Package Types 
Available in Magento 

The tables below list the shipping methods that are available for each of the supported shipping carriers and 

package types that are supported by each of the shipping methods. 

There are additional notes and assumptions regarding the information provided: 

 Custom packaging has been added to each shipping method of each shipping carrier. 

 Shipping methods are divided into U.S. and International. Those that are marked as “U.S.” 

are for US domestic shipments only. Those that are marked as "International" can be those 

shipped from the U.S. to other countries, from other countries to the U.S. and within 

countries other than the U.S. FedEx does not offer domestic shipments for countries other 

than the U.S. at this time. USPS offers shipments from the U.S. only (both domestic and 

international). 

 For international shipping methods available package types sometimes depend on the origin 

country (U.S. or other). The currently available package types are filtered according to the 

list of packages acceptable for shipping methods if a shipment originates from the U.S. For 

shipments originating from countries other than the U.S., the full list of package types 

available for the selected shipping method is provided. 

 

Table 1. FedEx: U.S. shipping methods and package types 

Shipping method Package type 

FedEx First Overnight, FedEx Priority Overnight, FedEx 

Standard Overnight, FedEx 2Day 

FedEx Envelope  

 FedEx Pak  

 FedEx Box  

 FedEx Tube 

 Your Packaging 

FedEx Express Saver FedEx Envelope 

 FedEx Pak 

 Your Packaging 

FedEx Ground, FedEx Home Delivery, FedEx SmartPost Your Packaging 
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Table 2. FedEx: International shipping methods and package types 

Shipping method Package type 

FedEx International First  FedEx Envelope  

 FedEx Pak  

 FedEx Box  

 FedEx Tube 

 Your Packaging 

FedEx International Priority FedEx Envelope  

 FedEx Pak  

 FedEx Box  

 FedEx 10 kg Box and FedEx 25 kg Box 

 FedEx Tube 

 Your Packaging 

FedEx International Ground Your Packaging 

FedEx Europe First Priority FedEx Envelope 

 FedEx Pak 

 FedEx 10 kg Box and FedEx 25 kg Box 

 Your Packaging 

 

Table 3. UPS: U.S. shipping methods and package types 

Shipping method Package type 

UPS Next Day Air Early AM, UPS 2nd Day Air, UPS 

Next Day Air, UPS 2nd Day Air AM 

Small Express Box 

 Medium Express Box 

 Large Express Box 
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Shipping method Package type 

 UPS Express Tube 

 UPS Pak 

 UPS Letter 

 Your Packaging 

UPS 3 Day Select, UPS Ground Your Packaging 

 

Table 4. UPS: international shipping methods and package types 

Shipping method Package type 

UPS Worldwide Express, UPS Worldwide Express Plus, 

UPS Worldwide Saver, UPS Worldwide Expedited 

Small Express Box 

 Medium Express Box 

 Large Express Box 

 UPS Express Tube 

 UPS 10kg Box 

 UPS 25kg Box 

 UPS Pak 

 UPS Letter 

 Customer Packaging 

UPS Worldwide Expedited Small Express Box 

 Medium Express Box 

 Large Express Box 

 UPS Express Tube 

 UPS Pak 
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Shipping method Package type 

 Customer Packaging 

 

Table 5. USPS: international shipping methods and package types 

Shipping method Package type 

Express Mail International Flat Rate Envelope, Express 

Mail Flat Rate Envelope Hold For Pickup 

Express Mail® International Flat Rate 

Envelope 

Priority Mail International Large Flat Rate Box Priority Mail International Large Flat 

Rate Box 

Priority Mail International Medium Flat Rate Box Priority Mail International Medium Flat 

Rate Box 

Priority Mail International Small Flat Rate Box Priority Mail International Small Flat 

Rate Box 

Priority Mail International Flat Rate Envelope Priority Mail International Flat Rate 

Envelope 

Global Express Guaranteed (GXG) Large Package/Non-Rectangular 

(Regular and Medium) 

 Variable 

USPS GXG Envelopes, Express Mail International, 

Priority Mail International, First-Class Mail 

International Package 

Large Package/Rectangular (Regular and 

Medium) 

 Large Package/Non-Rectangular 

(Regular and Medium) 

 Variable 

First-Class Mail International Large Envelope Variable 

 

Table 6. DHL: shipping methods and package types 

Shipping method Package type 

Express, Express International Package 

 Letter 
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G VAT ID Validation 
All editions of Magento include a value-added tax (VAT) ID validation feature. The feature is intended for 

B2B merchants from the European Union (EU), where VAT is charged if a merchant and a customer are in 

the same country, and VAT is not charged if a merchant and a customer are in different countries within EU 

and both parties are EU-registered business entities. 

VAT identification number (VAT ID) Validation enables store administrators to create more than one default 

customer group, which will be automatically assigned to each customer during account creation, address 

creation or update, and checkout according to the customer’s VAT ID, and the customer’s and merchant’s 

location countries. This feature enables merchants to create different tax rules for intra-country (domestic) 

and intra-EU sales, and to apply the corresponding VAT amount automatically. 

Note: VAT-related tax rules do not influence other tax rules and do not prevent 
applying other tax rules where applicable. Only one tax rule can be applied at a 
given time. 

Magento performs VAT ID validation using the web-services of the European Commission server: 

http://ec.europa.eu/taxation_customs/vies/.  

VAT ID Validation Quick Reference 

The following table lists the main tasks concerned with the VAT ID Validation feature and the 

locations, where they can be performed in the Admin Panel. 

TASK ADMIN MENU SCOPE 

Create customer groups, which 

can be used as default for the 

VAT ID Validation functionality 

Customers > Customer Groups  

Enable the VAT ID Validation 

functionality 

System > Configuration > CUSTOMERS > 

Customer Configuration > Create New 

Account Options 

Store view 

To Set the default groups for 

customers from your country and 

from other EU countries 

System > Configuration > CUSTOMERS 

>Customer Configuration > Create New 

Account Options 

Store view 

To Set your country and VAT ID  System > Configuration > GENERAL > General 

> Store Information 

Store view 

To Modify Magento list of EU 

countries  

System > Configuration > GENERAL > General 

> Countries Options 

Global 

To Edit the VAT Number customer 

address attribute 

Customers > Attributes > Manage Customer 

Address Attributes  

Global 

To Create tax rates and tax rules for 

domestic, intra-EU and other 

VAT-related customer groups 

Sales > Tax   

For assigning groups to customers, the default customer’s address (billing or shipping) for tax 

calculation is used; the setting is configured under System > Configuration > CUSTOMERS > 

Customer Configuration > Create New Account Options > Tax Calculation Based On).  

http://ec.europa.eu/taxation_customs/vies/
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If the VAT ID Validation feature is enabled, you can still choose not to apply it for a certain 

customer by selecting the correspondent check box on the Customer Information page under 

Customers > Manage Customers.  

Configuring VAT ID Validation 

Configuring the VAT ID Validation includes these steps: 

1. Creating VAT-related customer groups.  

2. Creating tax classes, tax rates and tax rules.  

3. Configuring the VAT ID Validation settings. 

4. Setting your VAT ID and location country. 

5. Modifying the list of EU member countries used by Magento. This step is only necessary if the 
EU gets new members or some countries leave the EU. 

Creating the VAT-Related Customer Groups 

VAT ID Validation functionality automatically assign one of the four default customer groups to 

customers according to VAT ID validation results:  

 Domestic 

 Intra-EU 

 Invalid VAT ID  

 Validation error.  

You can create new customer groups to be used in the VAT ID Validation functionality or use 

existing groups, if they comply with your business logic. Customer groups are created under 

Customers > Customer Groups.  

When configuring the VAT ID Validation functionality, you will need to assign each of the created 

customer groups as a default for customers with appropriate VAT ID validation results. For details 

see the Enabling and Configuring the VAT ID Validation Functionality section further. 

Configuring the VAT-Related Tax Rules 

The VAT ID Validation functionality was implemented to facilitate the VAT applying for EU B2B 

merchants. In Magento, taxes are applied using the tax rules mechanism. Each tax rule is defined be 

three entities: 

 Customer Tax Classes 

 Product Tax Classes 

 Tax Rates. 

To use the VAT ID Validation functionality effectively, you need to create the appropriate tax rules.  
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Important Note: According to the EU taxation policy, the supply of services between 
businesses (B2B services) is in principle taxed at the customer's place of 
establishment 
(http://ec.europa.eu/taxation_customs/taxation/vat/how_vat_works/vat_on_services/
index_en.htm ). So if you sell downloadable or virtual products, which do not 
require shipping, the VAT rate of a customer’s location country should be applied 
for both, intra-union and domestic sales. This means that you additionally need to 
create individual tax rules for a product tax class corresponding to the 
downloadable and virtual product types. 

The following table contains the minimal list of tax rules which must be created to use the VAT ID 

Validation functionality. 

Tax rule # Customer Tax Class Product Tax Class Tax Rate 

1  A class for domestic 

customers 

 A class for customers with 

invalid VAT ID 

 A class for customers, for 

whom VAT ID validation 

failed 

A class for products of all 

types, except bundle and 

virtual 

VAT rate of the 

merchant’s country 

2 A class for intra-union customers A class for products of all 

types, except 

downloadable and virtual 

VAT rates for all EU 

countries, except 

merchant’s country. 

Currently this rate is 0% 

3 (required only if 

you sell products 

of bundle or 

virtual type) 

 A class for domestic 

customers 

 A class for customers with 

invalid VAT ID 

 A class for customers, for 

whom VAT ID validation 

failed 

A class for downloadable 

and virtual product types 

VAT rate of the 

merchant’s country 

4 (required only if 

you sell products 

of bundle or 

virtual type) 

A class for intra-union customers A class for downloadable 

and virtual product types 

VAT rates for all EU 

countries, except 

merchant’s country. 

Currently this rate is 0% 

Note: It is recommended that you apply the merchant’s VAT rate for customers with 
invalid VAT IDs and those for which validation fails. You can create other tax rules 
and apply other tax rates according to your business logic. 

In the Magento Admin Panel, all tax rule related entities, including tax rules, tax rates, product tax 

classes and customer tax classes, are managed under Sales > Tax; tax classes are assigned to 

customer groups under Customers > Customer Groups > %customer group%. 

http://ec.europa.eu/taxation_customs/taxation/vat/how_vat_works/vat_on_services/index_en.htm
http://ec.europa.eu/taxation_customs/taxation/vat/how_vat_works/vat_on_services/index_en.htm
http://ec.europa.eu/taxation_customs/taxation/vat/how_vat_works/vat_on_services/index_en.htm
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Enabling and Configuring the VAT ID Validation Functionality 

To enable VAT ID and set default groups: 

1. Log in to the Magento Admin Panel. 

2. Navigate to System > Configuration > CUSTOMERS > Customer Configuration. 

3. In the Current Configuration Scope field in the upper-left corner leave Default Config or select 
the desired store view. 

4. Expand the Create New Account Options field set.  

5. In the Enable Automatic Assignment to Customer Group field, select Yes. The following fields 
appear: 

 Tax Calculation Based On: Choose whether VAT calculation will be based on customer's 

shipping or billing address. If the customer does not have a shipping address (that is, the 

customer has only now registered and the system does not yet take into account the 

customer's shipping address), the Default Tax Destination Calculation address will be used 

for tax calculation to be displayed to the customer. 

Important Note: If the Tax Calculation Based On is set to Shipping Address, then 
Magento will use billing address for VAT calculation, if a customer only buys 
downloadable and/or virtual products.  

 Group for Valid VAT ID – Domestic: Choose a customer group, which is automatically 

assigned to customers coming from your country and whose VAT ID is valid. See 

“Configuring Additional Settings for the VAT ID Validation Feature,” page480, for details 

about setting your location country. 

 Group for Valid VAT ID - Intra-Union - Choose a customer group, which is automatically 

assigned to customers coming from EU countries other than yours, and whose VAT IDs are 

valid. See “Configuring Additional Settings for the VAT ID Validation Feature,” page 480, 

for details about where your location country is set. 

 Group for Invalid VAT ID: Choose a customer group, which is automatically assigned to 

customers whose VAD ID is invalid. 

 Validation Error Group: Choose a customer group, which is automatically assigned to 

customers for whom the VAT ID validation failed.  

 Validate on Each Transaction: Choose whether VAT ID validation will be performed each 

time during order creation even if a previously saved customer address with validated VAT 

ID is used. The option applies to one-page checkout in the frontend only. If a new customer 

address is used (including guest checkout or if a customer has no address assigned to their 

account), then the validation is performed irrespective of this setting. During order creation 

in the Admin Panel, no automatic validations are performed.  
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 Default Value for Disable Automatic Group Changes Based on VAT ID (available only if 

Default Config is selected in Current Configuration Scope): Choose whether the automatic 

change of customer group based on VAT ID will be enabled or disabled by default. The 

setting can be overridden on the product level. The setting influences the system behavior in 

the following situations: 

i. The VAT ID of the customer’s default address or the whole default address 

changes. 

ii. Customer group change was emulated during the checkout for a registered 

customer who had no previously saved address or for a customer, who 

registered during the checkout. 

If the automatic group change is enabled, then in the first case the customer group 

changes automatically, and in the second case the temporarily emulated customer 

group is assigned to customer.  

If the automatic group change is disabled, the customer group that is assigned 

never changes, unless an administrator changes it manually. 

 Show VAT Number on Frontend: Choose whether the field for entering and storing the VAT 

ID number will be visible in the frontend. 

6. To save the settings, click Save Config. 

If the VAT ID Validation feature is disabled (the Enable Automatic Assignment to Customer Group 

field set to No), then the system behavior is as usual, and the default customer group can be set in 

the Default Group field. 

When the feature is enabled, the system does not automatically validate customer VAT IDs nor does 

it change customer groups. 

Configuring Additional Settings for the VAT ID Validation Feature 

To set your VAT ID and location country: 

1. Navigate to System > Configuration > GENERAL > General. 

2. In the Current Configuration Scope field, select the desired store view. 

3. Expand the Store Information field set.  

4. In the Country field, select your country.  

5. In the VAT Number field, enter your VAT number. You can validate the entered value by 
clicking the Validate VAT Number button. The result of validation will be displayed 
immediately.  
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Note: If your VAT number is valid, then apart from validation result for each customer’s 
VAT ID validation, the validation server will send to Magento the following 
additional information: VAT request identifier and VAT request date. If a customer’s 
VAT validation is performed during checkout, then the VAT request identifier and 
VAT request date are saved in the Comments History section of the Order View 
page under Sales > Orders > (select appropriate order). 

6. To save the settings, click Save Config. 

To modify the list of the countries that are EU members: 

1. Navigate to System > Configuration > GENERAL > General. 

2. In the Current Configuration Scope field, select the desired store view. 

3. Expand the Countries Options field set.  

4. In the European Union Countries field make the necessary changes in the list of countries that 
are EU members. 

5. To save the changes, click Save Config. 

VAT ID Validation Implementation Details: Customer 
Experience 

Assigning Customer Groups Based on VAT ID Value During 
Registration  

If the VAT ID Validation feature is enabled, after registration each customer is proposed to enter the 

VAT ID number. However only those who are registered VAT customers are expected to fill this 

field. 

After a customer specifies the VAT number and other address fields, and chooses to save, the system 

saves the address and sends the VAT ID validation request to the European Commission server. 

According to the results of the validation, one of the default groups is assigned to a customer. This 

group can be changed if a customer or an administrator changes the VAT ID of the default address 

or changes the whole default address. And the group can be temporarily changed (group change 

will be emulated) in some cases during one-page checkout. 

Applying and Assigning Customer Groups During Checkout  

The system behavior concerned with the VAT ID validation and the customer group change during 

the checkout depends on how the Validate on Each Transaction and the Disable Automatic Group 

Change settings are configured. This section describes the implementation of the VAT ID Validation 

functionality for the checkout on the frontend. 
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In case a customer uses Google Express Checkout, PayPal Express Checkout or another external 

checkout method, when the checkout is performed completely on the side of the external payment 

gateway, the Validate on Each Transaction setting cannot be applied. Thus the customer group 

cannot change during checkout.  

The Figure 317 illustrates the flow of VAT ID validation and customer group change during one-

page checkout. 
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Figure 317. One-page Checkout with VAT ID Validation 



VAT ID Validation 

484 

VAT ID Validation Implementation Details: Admin 
Experience 

The VAT Number Customer Address Attribute 

Customer VAT ID value is stored in the vat_id customer address attribute. The default label of this 

attribute is VAT number. Customer address attributes are managed under Customers > Attributes > 

Manage Customer Address Attributes. 

The VAT number field is always present in all shipping and billing customer addresses in the 

backend. It is not mandatory. Displaying the field in the frontend is configured in the Show VAT 

Number in Frontend field under System > Configuration > CUSTOMERS > Customer 

Configuration > Create New Account Options. 

Note: For customers not from the EU countries, consider storing the VAT number (if 
any), in the existing Tax/VAT Number customer attribute to avoid any possibility of 
customer group change (whether persistent or emulation during checkout). It is 
recommended that you rename the Tax/VAT Number customer attribute to avoid 
confusion with the new VAT Number customer address attribute that is used for the 
VAT ID Validation functionality.  

Disabling Automatic Customer Group Change 

When the VAT ID Validation functionality is enabled, the group of a customer can only be changed 

manually in the Admin Panel, no automatic changes of customer group can take place.  

When the VAT ID Validation functionality is enabled, the system will automatically, permanently 

change a customer group in the following situations: 

 The VAT ID of the customer’s default address or the whole default address changes.  

 The customer group change was emulated during the checkout for a registered customer 

who had no previously saved address, or a customer who registered during the checkout. 

The automatic customer group change can be disabled by selecting the Disable automatic group 

change check box on the customer’s page under Customers > Manage Customers > %customer% > 

Account Information. See Figure 318. 
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Figure 318. Disabling Automatic Group Change on Customer Level 

Important Note: The setting does not influence the emulation of the customer group 
change during checkout. 

The default value of the Disable automatic group change check box is set in the Default Value for 

Disable Automatic Group Changes Based on VAT ID field under System > Configuration > 

CUSTOMERS > Customer Configuration > Create New Account Options. The configuration setting 

is made on the global level. The default value applies to new customers and to customers whose 

records are available in the system when the VAT ID Validation functionality is enabled for the first 

time.  

VAT ID Validation in Customer Accounts in the Admin Panel 

When an administrator adds a new default address with a VAT ID to the account of a new or 

existing customer or changes the VAT ID of the existing default address, the system validates the 

VAT ID and assigns the appropriate customer group to the customer. The validation is performed 

after the Save or Save and Continue button is clicked. 

Note: The system behavior is as described when the VAT ID Validation functionality is 
enabled and configured. 

If you want to disable the automatic change of a customer group, select the Disable automatic 

group change check box on the Account Information tab of the Customer Information page. 

VAT ID Validation During Order Creation in the Admin Panel 

This section describes the system behavior when an admin creates a new order in the Admin Panel, 

with the VAT ID Validation functionality enabled and configured.  
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During order creation in the Admin Panel no VAT ID validation is performed automatically. To 

validate the VAT ID of the customer address, an administrator needs to click the Validate VAT 

Number button in the Billing Address or Shipping Address section of the Create New Order page. 

See Figure 319. 

 

Figure 319. Validating Customer VAT ID During Order Creation in the Admin Panel 

After the validation, the administrator receives a notification about the validation results in the form 

of a pop-up message. 

A customer group, which should be assigned to a customer according to the validation results, can 

differ from the customer group that is currently assigned to the customer. In this case the system 

displays a dialog box suggesting that the administrator confirm or reject the group change emulation 

for the customer’s current order. If the administrator confirms, then the group change is emulated for 

the current order and the corresponding VAT rate is applied (if the corresponding tax rule is 

configured in the system). The actual customer group of a customer is not changed. 

If a new customer account is added during the order creation, and an administrator confirms using 

the customer group that corresponds to the VAT ID validation results, then after the order creation 

the customer account is saved in the system and the customer group that was used for order 

creation is assigned to it.  
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	1. In the Admin Panel, select System > Configuration > GENERAL > Contacts to display the Contacts page, as shown in Figure 56.
	2. In the Current Configuration Scope drop-down menu in the left upper left corner, select the scope for which you want these configurations to apply.
	3. In the Enable Contact Us drop-down menu, select Yes to enable customers to contact you by email with the Contact Us link, or select No to disable this communication method.
	4. In the Send Emails To field, specify the email that is used for receiving feedback when a customer uses the Contact Us option in the store.
	5. In the Email Sender drop-down menu, select the email address from which feedback messages are sent.
	6. In the Email Template drop-down menu, select the template to be used for the Contact Us form displayed on the frontend. You can create custom email templates. For more information, see “Customizing Transactional Emails,” page 156.
	7. Click Save Config to save your changes.
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	1. In the Admin Panel, select System > Configuration > SALES > Sales Emails.
	2. In the Current Configuration Scope drop-down menu in the left upper left corner, select the scope for which you want these configurations to apply.
	3. Click the Order heading to expand the Order field set, as shown in Figure 57.
	4. In the Order field set, configure the following options:
	5. Configure the options on the other field sets on this page.
	6. Click Save Config to save your changes.
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	2. In the Current Configuration Scope drop-down menu in the left upper left corner, select the scope for which you want these configurations to apply.
	3. Click the Origin and Options tabs to expand the page to display the shipping options, as shown in Figure 58.
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	5. Click Save Config to save your changes.
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	3. In the Current Configuration Scope in the upper-left corner of the page select the desired website.
	4. Expand the Session Cookie Management field set.
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	6. To save the changes click the Save Config button.
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	o Grid Only: The products are displayed only in a grid structure.
	o List Only: The products are displayed only in a list.
	o Grid (Default)/List: The products are displayed in a grid structure by default, but your customers are able to switch to list.
	o List (Default)/Grid: The products are displayed in a list structure by default, but your customers are able to switch to grid.
	o Specify, in a comma-separated list, what the options are for the number of products to display on a product page. These options will be listed in a drop-down menu on the frontend.
	o Specify how many products are displayed on a page by default.
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	o Like: Includes only results that are close in spelling to the specified search terms.
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	1. Specify a name for this category in the Name field.
	2. Set the Is Active field to Yes to specify that this category appears in the store.
	3. In the URL key field you can specify a relative URL path which can be specified in place of the standard Target Path. It is “search engine friendly” because it can use the name of the category instead of the ID number. If you leave this field blank...
	4. For Thumbnail Image, use the Browse button to select and upload a thumbnail image to represent the category.
	5. Specify a description in the Description text box. This description is presented on the frontend.
	6. The Image field is used for a category image. Click the Browse button next to the field to select the file. This image will appear in the frontend for each category’s page between the category name and the content.
	7. In the Page Title field, specify the title of the page, which will be displayed on the browser tab header when the customer opens this category page.
	8. In the Meta Keywords and Meta Description text boxes, specify the keywords and description for search engines to use for this category when indexing your site.
	9. Select Yes for Include in Navigation Menu so that the category will appear in the navigation menu on the frontend.
	10. Click Save Category to save your changes.
	Display Settings Tab

	1. In the Display Mode field, select one of the following options to specify how you would like your category page to appear:
	2. In the CMS Block field, select the static block that you would like to be shown for this category (if selected in the Display Mode field). This block must first be created in the CMS section; for more information, see “Managing CMS Pages,” page 145.
	o If you set the category to be an anchor for Layered Navigation, then your web store displays the subcategories of this category in the SHOP BY panel on the left. This area also shows a linked list of the filterable attributes of the products in this...
	o Figure 70 shows the SHOP BY panel for the Apparel category, which is set as an anchor.
	3. For Available Product Listing Sort By, specify the attributes by which the customer can sort the list of products in this category. By default, all available attributes can be used for sorting; clear the Use All Available Attributes check box to mo...
	4. For Default Product Listing Sort By, select the attribute by which the product list is sorted by default. This is set in the catalog configuration (see “Setting Up Catalog Defaults,” page 54), but you can clear the Use Config Settings check box to ...
	5. For Layered Navigation Price Step, specify the size of the price range to be used when calculating the price “buckets” for the Layered Navigation. This is set in the catalog configuration, but you can clear the Use Config Settings check box to spec...
	Custom Design Tab

	1. For Use Parent Category Settings, choose Yes to “inherit” the settings of this subcategory from its parent category. Doing so ensures a consistent look within a category family, and disables all other settings on this page. This setting is not avai...
	2. For Apply to Products, select Yes to apply the category page settings to the product pages of the products in this category.
	3. Select a custom design from the Custom Design drop-down menu. Magento comes with several custom designs already defined, and you can modify these custom designs or create your own. For more information, see “Managing CMS Pages,” page 145.
	4. For the Active From and Active To fields, select the start and end dates for this custom design to be applied to this category. If you do not select a start date, the custom design is applied immediately. If you do not select an end date, the custo...
	5. For Page Layout, select a layout from the drop-down menu:
	6. The Custom Layout Update is essentially a static block, with a few differences. Rather than HTML, the structure must be in XML format. The Update will appear at the bottom of the page, below the products, whereas a static block will appear above th...
	7. Click Save Category to save your changes.
	Catalog Products Tab

	1. If needed, use the filter fields at the top of the table to filter the list of products. Click Reset Filter to clear all filter settings.
	2. Select the check box in the left column for each product that belongs in this category. Remember that a product can be assigned to more than one category.
	3. In the Position column, specify a whole number that indicates the order in which the product is listed when the products are sorted by Best Value. The product with a Position value of 1 is listed first, 2 is listed second, and so on. If more than o...
	4. Click Save Category to save your changes. You may need to refresh the page to display the category in the tree.
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	1. Log in to the Magento Admin Panel.
	2. Navigate to System > Configuration > CATALOG > Catalog.
	3. In the Current Configuration Scope in the upper left corner of the page, select the desired store view.
	4. Expand the Layered Navigation field set. In the Display Product Count field, decide whether the number of products which fall into a price range will be displayed.
	5. In the Price Navigation Step Calculation field select Automatic (equalize product counts). Additional options appear.
	6. In the Display Price Interval as One Price field, decide what will be the system behavior if all products which fall into a certain price range have the same price. Select Yes if you want to display a single price (not the range finite values).
	7. In the Interval Division Limit field, specify the threshold for a number of products within a price range after which the range cannot be further split. The default value is 9.
	8. To save the changes click Save Config.
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	6.2 Managing Product Attributes
	What Is an Attribute in Magento?
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	1. Select Catalog > Attributes > Manage Attributes. A list of existing attributes is displayed, as shown in Figure 76.
	2. Click Add New Attribute to display the New Product Attribute page (Figure 77) in which you can define a new attribute.
	3. In the Attribute Code field, specify a unique identifier for this attribute. Do not use spaces. This code does not appear on the frontend.
	4. In the Scope field select the scope to which this attribute applies.
	5. The Catalog Input Type for Store Owner setting controls how a store administrator specifies values for attributes. For descriptive textual attributes, you can use the Text Field or Text Area types; for list prices you use the Price type. Note that ...
	6. If this attribute has a default value, specify it in the Default Value field.
	7. If the value of the attribute must be unique for each product (for example, a SKU number), select Yes for Unique Value.
	8. If the value of the attribute cannot be blank for any product, select Yes for Values Required.
	9. In the Input Validation for Store Owner field, select the type of validation that should be enforced on values of this attribute. For example, if the values of this attribute will be email addresses, select Email to cause the system to check each e...
	10. If this attribute will apply only to certain Magento product types, select Selected Product Types for Apply To. In the list that appears, select one or more product types for this attribute (use Ctrl+click to select multiple items).
	11. For Use in Quick Search and Use in Advanced Search, select Yes to enable the quick search and advanced search tools to search this attribute’s values.
	12. For Comparable on Front-end, select Yes to have this attribute appear in the Compare window when products are compared.
	13. The Use in Layered Navigation field defines whether the attribute is used in layered navigation. The following options are available:
	14. The Use for Promo Rule Conditions, field defines whether the attribute can be used in defining conditions for catalog and shopping cart price rules.
	15. The Position parameter determines the position of the attribute in the layered navigation block with respect to other filterable attributes.
	16. In the Visible on Product View Pages on Frontend field, select Yes to specify that this attribute appears in the Additional Information part of a product’s page in the web store, as shown in Figure 78.
	17. For Allow HTML Tags on Frontend, select Yes to enable HTML tags that are specified in this attribute’s values to be honored on the frontend.
	18. For Used in Product Listing, select Yes to list values of this attribute in the product listing.
	19. For Used for Sorting in Product Listing, select Yes to enable the product list to be sorted by values of this attribute.
	20. Click Manage Label/Options at the top left of the page to display the Manage Label/Options page, as shown in Figure 79.
	21. In the Mange Titles box, specify a display name for this attribute for each store view. If you specify a value only in the Admin field, that value will be used in all cases.
	22. For attributes with an input type of Dropdown or Multiple Select, you can enter values that can be specified for the attribute. To add a value, click the Add Options button. You can specify a different label for the value for each store view and s...
	23. Click Save Attribute.
	6.3 Creating Attribute Sets

	1. In the Admin Panel, select Catalog > Attributes > Manage Attribute Sets. A list of existing attribute sets is displayed, as shown in Figure 81.
	2. Click the Add New Set button to display the Add New Attribute Set page (Figure 82).
	3. In the Name field, specify the name of this attribute set. This name is used only in the backend.
	4. In the Based On field, select another attribute set from which this attribute set is to inherit. This enables you to reuse the attributes that are already defined in a set to build other attribute sets. The simple option is to leave the Default opt...
	5. Assign attributes to this attribute set by dragging them from the Unassigned Attributes area on the right into a group in the tree in the Groups area.
	Creating a New Attribute Group

	1. Click Add New in the Groups area to display a pop-up window asking for the group name.
	2. Specify the name of the new group and click OK.
	3. Click and drag attributes from the Unassigned Attributes area into the newly created group to assign them to this group.
	4. You can also click and drag attributes that are already assigned to move them between groups.
	7 Managing Products
	7.1 Product Types
	7.2 Creating a New Product

	1. In the Admin Panel, select Catalog > Manage Products to display the Manage Products page, as shown in Figure 85.
	2. Click Add Product on the top right of the page to display the New Product page (Figure 86).
	Product Wizard, First Page

	1. In the Attribute Set field, select the attribute set that contains the attributes that best describe this product. See “Managing Product Attributes,” page 72, for a description of how to define attributes.
	2. In the Product Type field, choose the type of product you want to create.
	3. Click Continue to display the General tab, as shown in Figure 87. (This tab may look different depending on the product type that you choose.).
	General Tab

	o Not Visible Individually: The product will not be displayed individually in the frontend; however, it can be a component of a composite, configurable, bundle, or grouped product.
	o Catalog: The product will displayed on pages of categories it is associated with, but it will not appear in search results.
	o Search: The product will be displayed when your customers search for it either using the quick or Advanced Search tools, but will not be displayed on the related category page.
	o Catalog, Search: The product will be available on category view pages with which it is associated and on the search results page.
	Prices Tab
	Meta Information Tab
	Images Tab

	1. Click the Images tab on the left to display the Images tab, as shown in Figure 90.
	2. Specify the image to be displayed in the web store to represent this product. Use the Browse button to select the image file from your local file system.
	3. After you have specified the image files of this product, click the Upload Files button. The Images tab shows uploaded the image files, as shown in Figure 91.
	4. Select the appropriate options for each of the images, as follows:
	Description Tab
	Design Tab

	1. Select a custom design from the Custom Design drop-down menu. Magento comes with several custom designs already defined, and you can modify these custom designs or create your own.
	2. For the Active From and Active To fields, select the start and end dates for this custom design to be applied to this product. If you do not select a start date, the custom design is applied immediately. If you do not select an end date, the custom...
	3. The Custom Layout Update is essentially a static block, with a few differences. Rather than HTML, the structure must be in XML format. The Update will appear at the bottom of the page, below the products, whereas a static block will appear above th...
	4. For Page Layout, select a layout from the drop-down menu.
	5. For Display Product Options In, select a location for the product options to appear in the layout.
	Recurring Profile Tab
	Gift Options Tab
	Inventory Tab

	1. Select the Inventory option in the left panel to display the Inventory tab, as shown in Figure 95.
	2. In the Manage Stock field, select Yes to specify that all inventory options are available for this single product, or select No to specify that you do not want to manage product inventory (in this case, the product is permanently available in the s...
	3. In the Qty field, specify how many items of this product you have in stock.
	4. In the Qty for Item’s Status to become Out of Stock field specifies that if stock quantity falls below this level, then the product becomes Out of Stock.
	5. The Minimum /Maximum Qty Allowed in Shopping Cart fields enable you to limit availability to products that have great prices to retail customers, so that they are not sold to wholesale customers.
	6. In the Qty Uses Decimals field, select Yes to specify that customers can enter decimal quantities for this product, as opposed to integers. This is suitable for a product sold by the weight, volume or length. For example: 2.35 pounds of concrete or...
	7. The Backorders field enables your customers to place an order for a product that has an in-stock quantity of less than 0. This option also enables you to notify your customers that even though there are no items of a product currently available, th...
	8. The Enable Qty Increments field enables you to choose whether this product is sold in quantities other than 1 (for example wine that is sold in multiples of 6 bottles). If you select Yes for this option, the Qty Increments field becomes visible, en...
	9. In the Stock Availability field, select the In Stock option if this product is in stock, or select Out of Stock otherwise.
	Websites Tab

	1. Select the Websites option in the left panel to display the Websites tab, as shown in Figure 96.
	2. If your store has more than one website, store or store view, you must assign the product to the appropriate website in order to make it available in this website.
	Categories Tab

	1. Select the Categories option in the left panel to display the Categories tab, as shown in Figure 97.
	2. Specify the categories to which this product belongs by selecting the appropriate check boxes.
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	Product Alerts Tab
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	o Select the File option, click the Browse button (...) and then click the Upload Files button. This will upload the file from your local computer to the server.
	o Select the URL option, specify the link to a file that is already on a server in a different location, and click the Upload Files button.
	o The Links can be purchased separately option controls whether each of the downloadable products can be purchased by itself or not. This feature enables, for example, the tracks of a music CD product to be purchased separately. If you set this option...
	o Each of the items also has two options that control its behavior. The Max. Downloads option controls how many times after purchase a product can be downloaded by the customer. The Shareable option controls whether after each purchase of the product,...
	Bundle Product: Bundle Items Tab
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	Select Configurable Attributes
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	Completing the Product Wizard

	1. From the Catalog menu, select the Manage Products option to display a list of products, as shown in Figure 118.
	2. Click the Edit link on the right side of the row of the relevant product.
	7.3 Mass-Changing Products

	8 Creating Variations of a Product
	1. From the Catalog menu, select the Manage Products option to display a list of products.
	2. Click the Add Product button to create a new product or click the Edit link to the right of the relevant product to open the edit page.
	3. Select the Custom Options tab.
	4. Click the Add New Options button on the top right of this page to display the controls shown in Figure 119.
	5. In the Title field, specify a name for this new property, such as the name Size.
	6. In the Input Type field, select the type of input that can be given in this field, such as text or drop-down menu, as shown above.
	7. In the Is Required field, select Yes to indicate that this is a mandatory field, meaning that a customer must select an option in this field in order to purchase this specific product.
	8. If there is more than one option, then specify the order in which this option appears in the Sort Order field. A value of 1 indicates that it appears first.
	9. Click the Add New Row button to display the row shown in Figure 120, in which you can define the new variation of this product. For example, the product in a certain size and its corresponding price.
	10. In the Title field, specify the name of this variation of the product, such as Size XL.
	11. All the prices in these rows are relative to the price of this product as defined in the Prices page of the product wizard described on page 83. In the Price Type field, select one of the following options:
	12. In the Price field, specify the difference between the price of this variation of the product and the price of the base product. Specify a fixed amount or a percentage according to the value that you entered in the Price Type field. You can also e...
	13. In the SKU field, specify the SKU for this variation of the product.
	14. If there is more than one variation, then specify the order in which this option appears in the Sort Order field. A value of 1 indicates that it appears first.
	15. Click the Save button. This example product is shown in the web store, as shown in Figure 121.
	9 Composite Products Handling
	9.1 Composite Products Handling for Store Customers
	Products in the Wishlist
	Products in the Shopping Cart

	9.2 Composite Products in the Admin Panel
	Composite Products in Orders Created from the Admin Panel
	Managing Composite Products in Shopping Carts and the Wishlists in the Admin Panel


	10 Enhanced Catalog Search
	Chapter Quick Reference
	10.1 Catalog Search with Solr
	Installing Solr
	Configuring Your Magento Store to Use Solr


	1. Choose System > Configuration. Select the Catalog tab on the left.
	2. In the Catalog Search panel, enable Solr by setting the following values:
	o MySqlFulltext: The default Magento-native search
	o Solr: Enables Magento to use the Solr search engine (installed separately)
	o Solr Server Hostname: Specify the host name of the Solr Enterprise Search server to connect to
	o Solr Server Port: Specify the port number of the Solr server to connect to
	o Solr Server Password: The Solr server password you set when you installed Solr
	o Solr Server Timeout: The connection to Solr search engine should be established within the number of seconds specified in the Solr Server Timeout field; if it is not, the MySQL search engine is used instead of Solr
	o Solr Server path: Specify the path to Solr located on the server specified in the Solr Server Hostname field; the Solr server path should be specified with no starting and ending slashes
	3. Click the [✔Save Config] button to save your settings
	1. To set your attribute weights, choose Catalog > Attribute > Manage Attributes.
	2. In the Frontend Properties panel, you can set the following values:
	o Yes: This attribute can be used in generating quick search results; if set to Yes and if Solr is enabled, the search weight field below appears.
	o No: Attribute cannot be used in generating quick search results.
	3. Click the [✔Save Attribute] button to save your settings.
	1. Choose System > Configuration. Select the Catalog tab on the left.
	2. In the Catalog Search panel, enable Solr by setting the following values:
	o Yes: Makes the search suggestions functionality available to customers. Enabling search suggestions can slow down search performance (depending on your hardware, configuration and search volume). If search performance becomes slow, disable this option.
	o No: Search suggestions will not be provided with search results.
	3. Click the [✔Save Config] button to save your settings.
	1. Choose System > Configuration. Select the Catalog tab on the left.
	2. In the Catalog Search panel, enable Solr by setting the following values:
	o Yes: Uses Solr instead of the MySQL Fulltext search to generate the layered navigation.
	o No: Magento-native catalog and layered navigation is used.
	3. Click the [✔Save Config] button to save your settings.
	10.2 Related-Terms Search Recommendations

	1. Choose System > Configuration. Select the Catalog tab on the left.
	2. In the Catalog Search panel, enable search recommendations by setting the following values:
	o Yes: Uses Solr instead of the MySQL Fulltext search to generate the layered navigation.
	o No: Magento-native catalog and layered navigation is used.
	3. Click the [✔Save Config] button to save your settings.
	1. To add related search variants to a search term, choose System > Configuration. The resulting Searches grid provides the list of all terms that have been searched by customers on the website. These include the misspelled and incorrectly entered wor...
	2. Click on any of the search terms in the list.
	3. On the resulting Edit Search page, to see all previously searched terms click the [Reset Filter] button located in the upper right of the Related Searches gird. Filter the list as desired to find specific related searches.
	4. Select the check boxes for all search queries to be added as search recommendations for this search term.
	5. Click the [✔Save Search] button to save your settings.
	11 Importing and Exporting Product and Customer Data
	11.1 Working with CSV Files
	11.2 Importing Customer and Product Data

	1. Log in to the Magento Admin Panel.
	2. In the top menu, select System > Import/Export > Import to open the Import page, as shown in Figure 132.
	3. In the Import Settings field set, specify the following:
	o Append Complex Data: The new complex data will be added to the existing complex data for the existing entries in the database.
	o Replace Existing Complex Data: The existing complex data for the already existing entities will be replaced.
	o Delete Entities: If entities that are being imported already exist in the database, they will be deleted from the database.
	4. Click the Check Data button in the upper-right corner of the page. The system validates the file. If the file is valid, the corresponding message and the Import button appear. If some of the rows in the imported file are not valid and cannot be imp...
	5. For more information about the valid CSV file structure, see “Catalog Products CSV File Structure,” page 128, and “Customers CSV File Structure,” page 129.
	6. If needed, make corrections to the CSV file.
	7. Click the Import button to import the data into the database.
	File Validation

	1. All attribute values are checked for conformance with the required data type (decimal, integer, varchar, text, datetime).
	2. The complex data, service data (see “Catalog Products CSV File Structure,” page 128, and “Customers CSV File Structure,” page 129 for details), and attributes whose values must be from a defined set(such as a drop-down or multiple select input type...
	3. For new entities, the presence of the required attributes values in the file is checked. For existing entities, the presence of the required attributes values is not checked, but if a required value is specified, it is validated by the attribute type.
	Importing Product Images

	1. Place the image files that you need to import in the subfolders in the %path_to_your Magento_instance%/media/import folder. Subfolders for the files should be created according to the following logic: Name the first folder using the first symbol of...
	Set the RE0777 permissions for the folders, and at least 0666 permissions for the image files.
	2. In the import CSV file, specify the relative path to the image file (For example, /f/i/filename.jpg). The following columns correspond to product images:
	o image
	o small_image
	o media_image
	3. Perform the import in the same manner as you would import product data.
	o For both new and existing entities, if an attribute, specified in the import file, exists in the system, and its values are taken from the defined set of values, but the value, specified in the import file does not exist in the defined set, the row ...
	o If an attribute name is specified in the import file but has not been defined in the system, it is not created in the system, and its values are not imported.
	o All rows in the file are invalid
	o A non-existing service data or complex data name is specified in the import file (that is, there is a column with a “_<non-existing name>” heading)
	11.3 Exporting Product and Customer Data

	1. Log in to the Magento Admin Panel.
	2. In the Magento top menu, select System > Import/Export > Export. The Export page opens.
	3. In the Export Settings field set specify the following:
	4. In the Entity Attributes field set you can include or exclude data to be exported according to the entity attribute values. The following export restrictions can be set:
	5. Click the Continue button in the lower-right corner of the page. You will be asked to specify the location for the file, or it will be saved in the default location depending on your browser settings.
	11.4 Catalog Products CSV File Structure

	1. The first row of the table contains the names of the columns, there are two types of the names:
	2. Other rows contain attributes values, service data, and complex data. If a row contains the value in the SKU column, then this row the rows below it describe the product. Each new SKU value begins the description of the next product.
	3. In the import procedure, if a row that contains the SKU value is invalid, then this row, and all other rows with data for that product cannot be imported.
	11.5 Customers CSV File Structure

	1. The first row of the table contains the names of the attribute columns (which are the same as attribute codes). There are two types of column names:
	2. Other rows contain attribute values, service data, and complex data. Each row with non-empty values in the “email” and “_website” columns starts the description of the subsequent customer. Each row can represent customer data with or without addres...
	12 Scheduled Import and Export
	12.1 Terminology
	12.2 Scheduled Import/Export – a Quick View
	12.3 Scheduled Import and Export Configuration
	12.4 Scheduled Import

	1. Select System > Import/Export, and click Scheduled Import/Export. The Scheduled Import/Export page opens.
	2. Click the Add Scheduled Import button in the upper right corner of the page. The New Scheduled Import page opens.
	3. In the Import Settings field set, specify the following:
	4. To save the new scheduled import, click Save in the right upper corner of the page. The new scheduled import job is added to the list on the Scheduled Import/Export page. From this page it can be run immediately for testing and edited.
	12.5 Scheduled Export

	1.  Select System > Import/Export, and click Scheduled Import/Export. The Scheduled Import/Export page opens.
	2. Click the Add Scheduled Export button in the upper right corner of the page. The New Scheduled Export page opens.
	3. In the Export Settings field set, specify the following:
	4. To save the new scheduled export, click Save in the right upper corner. The new scheduled export job is added to the list on the Scheduled Import/Export page. From this page it can be run immediately, for testing, and edited.
	12.6 Managing Existing Scheduled Import and Export Jobs

	1. Choose the scheduled import/export jobs by selecting the corresponding check boxes in the first column.
	2. In the Actions drop-down menu select Delete.
	3. Click the Submit button next to Actions. The confirmation dialog box appears.
	4. Confirm the deletion by clicking OK.
	1. Choose the scheduled imports/exports by selecting the corresponding check boxes in the first column.
	2. In the Actions drop-down menu select Change Status. The Status drop-down menu appears.
	3. In the Status drop-down menu select Enabled or Disabled.
	4. Click the Submit button next to Actions.
	12.7 Cleaning the Scheduled Import/Export File History

	1. Select System, and click Configuration. The configuration is done on the global level, so make sure that the Current Configuration Scope in the upper-left corner of the page is set to Default Config.
	2. Under ADVANCED in the left column click System.
	3. In the Scheduled Import/Export File History Cleaning field set, specify the following options:
	4. To save the file history cleaning settings, click the Save Config button in the upper-right corner of the page.
	Part III: Preparing to Sell
	13 Setting Up Your Store Hierarchy
	1. In the Admin Panel, select System > Manage Stores to open the Manage Stores page, as shown in Figure 135.
	2. To create a new website:
	3. To create a new store:
	4. To create a new store view:
	14 Design and Content
	14.1 Overview
	14.2 Terminology
	14.3 Changing the Web Store’s Theme

	1. Go to the Magento Connect site (http://www.magentocommerce.com/magento-connect). This site contains hundreds of extensions, which are add-ons to Magento software that can extend or enhance the look or functionality of your store. New ones are add...
	2. Click on the Core link to select one of the free extensions provided by Magento. The extensions are listed in the center of the page, as shown in Figure 136.
	3. This example demonstrates the implementation of the Modern Theme. Scroll down the list of extensions and select the Modern Theme.
	4. Install the theme as you would any other Magento extension. See “Extending Magento,” page 344, for more information.
	5. You can now activate this theme so that the web store appears with a new layout. Select System > Configuration > Design and expand the Themes section. The Design page is displayed, as shown in Figure 137.
	6. In the Default field, specify the name of the theme. In this example it is called Modern.
	7. Click the Save Config button on the top right of the page. The header, footer, menu bar, and background of the frontend now look different according to the new theme.
	8. If your home page appears incorrect, it may be because the layout that you selected is suited to two columns when your home page has one column or vice versa. For the Modern theme, the following change must be applied so that that the frontend home...
	9. Click on the first and second rows of the home page. The page shown in Figure 139 is displayed for each of them.
	14.4 Managing CMS Pages

	1. Select CMS > Pages to display the list of currently defined CMS pages as shown in Figure 138.
	2. Click the Add New Page button on the top right of the page to display the New Page page, as shown in Figure 141.
	3. In the Page Title field, specify the words to appear in the browser’s title bar.
	4. In the URL Key field, specify the unique identifier to be used in the URL. It must contain all lower case letters and no spaces. The following example uses our_history.
	5. Leave the default value in the Store View field.
	6. In the Status field, select Enabled.
	7. Click Content in the left navigation bar. Use the WYSIWIG editor to define the content for this page.
	8. Click Design in the left navigation bar to open the design options, as shown in Figure 142.
	9. Click the Layout field and then select one of the following options:
	10. Click Save Page. You can now open a browser and browse to this Landing page. The URL is taken from the value that you specified for URL Key, as described above. For example: /our_history is added to the web store’s URL.
	11. The following steps show how to add a link to this page from the frontend’s footer. Select CMS > Static Blocks option to display the list of existing Static Blocks.
	12. Click on the Footer Links row to display the definition of the frontend’s footer (see Figure 143).
	13. In the Content field, use the WYSIWYG editor to add a link to the new page. You can do this by pressing ENTER after one of the existing links, typing the link text, selecting this text, and clicking the Link icon (  ). Use the Insert/Edit Link dia...
	14.5 WYSIWYG Editor

	o Insert Widget: This button enables you to insert a Widget into the CMS page. A dialog box enables you to create the Widget to insert. You will be able to choose from any of the previously mentioned Widget Types. The options in the dialog box include...
	o Insert/edit Image: This button enables you to insert an image into the CMS page. A dialog box enables you to configure the image. Enter the image path, or (in a second dialog box) browse and select the image to insert from your server directory. If ...
	o Insert/edit embedded media: This button enables you to insert various types of media into the CMS page. A dialog box enables you to configure the media. Select the media type (Flash, QuickTime, Shockwave, Windows Media, or Real Media), and enter the...
	14.6 Widgets

	1. Navigate to CMS > Widgets and click Add New Widget Instance.
	2. You will need to select the type and theme to use to for this Widget, which cannot be changed after it has been created. The Widget type will determine which configuration options display in the Widget Options tab in the next step.
	3. After clicking Continue, configure the Widget with the following options:
	o Banner Rotator: This Widget enables you to display one or more previously created Banners. Banners are a new Magento feature which will be discussed in more depth below. From the Banners to Display drop-down menu, you can select if the Banners are a...
	o CMS Hierarchy Node Link: This Widget enables you to link to a CMS Node or page. Choose the Node or page by selecting it from the Hierarchy tree. Only pages which are part of the Hierarchy can be linked to using this Widget type. CMS Hierarchy is a n...
	o CMS Page Link: This Widget enables you to link to any existing CMS page. Choose the page by selecting it from the grid. You can also customize the text of the link.
	o CMS Static Block: This Widget enables you to insert an existing Static Block. Choose the Static Block by selected it from the grid.
	o Catalog Category Link: This Widget enables you to link to a category. Choose the category by selecting it from the category tree. You can also customize the text of the link.
	o Catalog Events Carousel: This Widget enables you to insert the Events Carousel. You can customize the number of Events to display at once in the Carousel, the number of Events to scroll each time the scroll arrows are clicked, and the width of the C...
	14.7 Banners

	1. To create a new Banner, navigate to CMS > Banners. After clicking Add Banner, configure the Banner with the following options:
	o Banner Name: This is for internal purposes.
	o Active: Only active Banners will be able to be displayed in the frontend.
	o Applies To: Select the Banner Type(s) from this drop-down menu. A Banner can be associated to multiple Banner Types. As previously discussed in the Widgets section, Banner Types are an internal tool to help you keep track of the page area for which ...
	o Customer Segments: Customer Segments are a rule-based tool for dynamically segmenting customers by attributes such as purchase history, items in shopping cart and much more. You can associate a Banner to a Customer Segment to personalize your market...
	14.8 Versioning

	o Version Label: This is the name of your Version. It is for internal purposes, to help you differentiate between the content of the various Versions. When you want to create multiple Versions of the same page (for example, a seasonal Version and a re...
	o Access Level: This sets the permissions for accessing this version. Private means that only the creator of this version will be able to access it. Protected means that only users with Publish Revision permissions (in System > Permissions > Roles) wi...
	o Owner: By default, this will be the user who created the page. The owner can be changed, which will affect access to the page if the access level is set to Private.
	14.9 Hierarchy

	1. To access the CMS Hierarchy, navigate to CMS > Pages > Manage Hierarchy.
	o Properties: Here you can edit the title and URL key. They can only be edited for Nodes, because the title and URL key for pages are set in CMS > Pages > Manage Content. You can also preview the frontend. When previewing nodes, you will be redirected...
	o Render Metadata in HTML Head: This section will only appear for top level nodes and pages. It is used for SEO purposes to define the structure of the hierarchy
	o Pagination Options for Nested Pages:  This section will appear only if child nodes or pages have been created under the currently highlighted node or page. They will control the pagination for the immediate child nodes or pages only (that is, pagina...
	o Page Navigation Menu Options: If the navigation menu is enabled, then a menu similar to the category tree will appear on the frontend, above the page content. For each node, you can control the number of parent and child levels to display in the men...
	o Main Navigation Menu Options (available in Magento Enterprise 1.12 and later): For nodes and pages of the first (root) level, the section contains the Show in Navigation Menu field, where you can decide if the node will be included in the category m...
	14.10 Customizing Transactional Emails

	1. Select System > Transactional emails to display a list of the custom email templates created in this web store.
	2. Click the Add New Template button to display the New Email Template page. See Figure 146.
	3. In the Template field, select the name of one of the transactional emails that you want to customize, such as New account.
	4. In the Locale field, select the language.
	5. Click Load Template.
	6. In the Template Name field, specify a name for the customized email template.
	7. If desired, modify the Template Subject field.
	8. In the Template Content area, use the WYSIWIG editor to modify the content. You must change the contact phone number and email address as well as the logo image reference at the top of the page to reflect your own store information in all active te...
	9. Click the Save Template button.
	10. Now that your customized email template is ready and available, the next step is to inform Magento that it should use this template to send email to customers instead of the default template. This is controlled in various configuration sections de...
	15 Taxes
	15.1 General Taxation Settings

	1. From the System menu, select the Configuration option.
	2. From the SALES section in the panel on the left, select Tax.
	3. Expand the Tax Classes section, and in the Tax Class for Shipping field, specify the tax class charged on the shipping amount, as shown in Figure 147. With Sample Data populated, we have added three examples of tax classes for Shipping. If your sto...
	4. Expand the Calculation Settings section, as shown in Figure 148.
	5. In the Tax Calculation Method Based On field, select whether the tax is based on the price of each unit, or on the “row total” (that is, the total for a line item in the order, accounting for any discounts).
	6. In the Tax Calculation Based On field, select whether the tax is calculated based on the customer’s shipping address, billing address, or your store’s shipping origin.
	7. In the Catalog Prices field, specify whether the catalog prices of items include tax or exclude tax.
	8. In the Shipping Prices field, select whether the shipping amounts include tax or exclude tax.
	9. In the Apply Customer Tax field, select whether tax is applied to the original or discounted price.
	10. In the Apply Discount on Prices field, select whether any discounts applied include the tax or exclude it.
	11. In the Apply Tax On field, select whether tax is applied to custom prices or to original prices.
	12. Expand the Default Tax Origin Calculation section to specify which country is used by Magento as the default for tax calculation, as shown in Figure 149.
	13. Expand the Price Display Settings tab to select whether display prices for products and shipping include tax or exclude tax.
	14. Expand the Display section to select how taxes and prices are shown for products and in a shopping cart according to the requirements (legal and otherwise) of your store, as shown in Figure 150.
	15. Expand the Orders, Invoices, Credit Memos Display Settings tab to select how prices and taxes are displayed in orders, invoices, and credit memos.
	16. Expand the Fixed Product Taxes tab to specify the behavior of fixed per product taxes, such as the European DEEE/WEEE (Waste Electrical and Electronic Equipment) tax, according to the requirements for your store and products.
	15.2 Product Tax Class

	1. Select Sales > Tax > Product Tax Class to display the Product Tax Classes page (Figure 151), which shows a list of the previously defined product tax classes.
	2. Click the Add New button to display the New Class page, as shown in Figure 152.
	3. In the Class Name field, specify a name for this tax class.
	4. Click Save Class.
	15.3 Customer Tax Class

	1. Select Sales > Tax > Customer Tax Classes to display a list of the previously defined customer tax classes.
	2. Click the Add New button to display the New Class page, as shown in Figure 153.
	3. In the Class Name field, specify a name for this tax class.
	4. Click the Save Class button.
	15.4 Tax Zones and Rates

	1. Select Sales > Tax > Manage Tax Zones and Rates option to display a list of the previously defined tax zones and rates.
	2. Click Add New Tax Rate to display the Add New Tax Rate page, as shown in Figure 155.
	3. In the Tax Identifier field, specify a unique name for this tax. Do not use spaces. This identifier is not shown in the frontend if the Tax Titles section is filled in, as described below.
	4. Select the location by using the Country and State drop-down menus.
	5. For Zip/Post is Range, select whether the Zip or postal code specification needs to be expressed as a range of codes or an individual code.
	6. In the Rate field, specify the percentage of tax.
	7. In the Tax Titles section, specify a name of this tax for each store view.
	8. Click the Save Rate button.
	15.5 Tax Management Rules

	1. To define how taxes are charged, select Sales > Tax > Manage Tax Rules to display a list of the previously defined tax rules, as shown in Figure 156.
	2. To define a new tax rule, click Add New Tax Rule to display the Edit Rule page, as shown in Figure 157.
	3. Select a Customer Tax Class, Product Tax Class and Tax Rate for this rule. This rule defines that the tax rate you select is applied to the customers in the selected customer tax class and the products in the selected product tax class.
	4. In the Tax Priority field, specify the priority of this tax, when more than one tax applies. If two tax rules with the same priority apply then the taxes are added together. If two taxes with a different priority apply then the taxes are compounded.
	5. The Sort Order field enables you to specify the order in which tax rules are displayed on the Manage Tax Rules page.
	6. Click Save Rule or Save and Continue Edit to save your changes.
	16 Shipping
	16.1 General Shipping Settings

	1. Select System > Configuration > Shipping Settings.
	2. Expand the Origin section and specify the address used for shipping calculations. Typically, this is the warehouse address from which products are shipped, as shown in Figure 158.
	3. Expand the Options section, as shown in Figure 159.
	4. In this section, enable or disable shipping to multiple addresses. Shipping to multiple addresses is very useful for stores that sell gifts. It enables customers to send various parts of an order to different destinations.
	5. Click Save Config to save your changes.
	16.2 Flat Shipping Rates

	1. Select System > Configuration > Shipping Method.
	2. Expand the Flat Rate section to define a fixed predefined amount for shipping, as shown in Figure 160.
	3. In the Enabled field, select Yes. The flat rate method then appears as an option in the shopping cart and on the shipping page during the checkout.
	4. The contents of Title and Method name fields appear in the frontend as shown in Figure 161.
	5. In the Type field, specify the entity to which the shipping fee applies, such as Per Item. In this case, the shipping fee is dependent on the number of items shipped. If you set the rate to be per item, it is multiplied by the total quantity of ite...
	6. In the Ship to applicable countries field, you can select the Specific Countries option to enable access to the field under it in which you can select specific countries, so that the appropriate (and different) shipping rates are applied to the rel...
	7. In the Sort Order field, specify the position of this shipping method in relation to the other shipping methods offered to the customer.
	16.3 Online Rates
	16.4 Offering Free Shipping

	1. Select System > Configuration > Shipping Methods.
	2. Expand the Free Shipping section to enable free shipping with optional minimum order amount, as shown in Figure 164.
	3. In the Enabled field select Yes to enable the method.
	4. In the Minimum order amount field specify the amount for an order over which shipping is provided free of charge.
	5. In the Ship to applicable countries field, you can select the Specific Countries option to enable access to the field under it in which you can select specific countries, so that free shipping is only applied to the relevant countries or you can se...
	16.5 Acquiring Additional Shipping Modules

	17 Shipping Integration with Label Printing Support
	17.1 Terminology List
	17.2 Shipping Integration – General Concept
	17.3 Configuring Store Address and Shipping Method Settings
	17.4 Creating and Printing Shipping Labels

	1. Select Sales, and click Orders.
	2. Open your order for editing.
	3. Click the Ship button in the upper right corner of the order view. The New Shipment page opens.
	4. Configure the shipment, select the Create Shipping Label check box above the Submit Shipment button, and click Submit Shipment. The Create Packages pop-up window appears.
	5. In the Create Packages pop-up window, add the packages, distribute all shipped products among the packages, and click OK (for details, see “Creating Packages in the Create Packages Pop-Up Window,” page 173). This is a required step for creating a s...
	6. Magento connects to the shipping carrier, creates the order in its system, and receives a shipping label and tracking number for each package. If a shipping label is successfully created, the new shipment is saved and the shipping label is availabl...
	1. Open a shipment for editing.
	2. Click the Create Shipping Label button in the Shipping and Tracking Information section. The Create Packages pop-up window appears.
	3. In the Create Packages pop-up add packages, distribute all shipped products between packages and click OK (for details, see “Creating Packages in the Create Packages Pop-Up Window,” page 173).
	4. Magento connects to the shipping carrier, creates the order in its system, and receives a shipping label and a tracking number. If a shipping label for this shipment already existed in the system, it is replaced with a new one. Existing tracking nu...
	1. Open the shipment for editing.
	2. Click the Print Shipping Label button in the Shipping and Tracking Information block of the shipment view. See Figure 165.
	Creating Packages in the Create Packages Pop-Up Window

	1. Specify the following:
	2. To view a list of shipped products and add them to the package, click the Add Products button. The grid with the list of the shipped products appears. The Qty column is pre-populated with the maximum available quantity to add (for the Package 1 thi...
	3. Specify the products and quantities. To add the products to the package, click the Add Selected Product(s) to Package button in the header of the grid. The products are added to the package.
	Changing Product Quantities in an Existing Package
	Printing Shipping Labels for Multiple Orders

	1. Select Sales, and click Orders. The Orders page opens.
	2. Using the check boxes in the left column, select the desired orders.
	3. In the Actions drop-down menu, select Print Shipping Labels.
	4. Click the Submit button.
	Tracking Numbers
	17.5 Shipping Integration Implementation Features

	18 Return Merchandise Authorization (RMA)
	18.1 RMA – General Concept

	1. A store customer places an RMA request. Both logged in and non-logged in customers can create requests. You can create a request in the Admin Panel as well.
	2. You consider the request. You can authorize (preapprove) it partially, or completely, or cancel. If you authorize the return and agree to pay for the return shipment, you can create the shipment order with one of the supported shipping carriers, ri...
	3. The customer sends back the merchandise.
	4. You approve the return partially or completely, or cancel it.
	18.2 Configuring the RMA Feature

	1. Select System and click Configuration.
	2. In the Current Configuration Scope drop-down menu in the upper-left corner of the page, select the desired website.
	3. Under SALES in the left column, click Sales.
	4. In the RMA Settings field set, the following options are available:
	5. To save the configuration, click the Save Config button in the upper-right corner of the page.
	18.3 Configuring RMA at the Product Level
	18.4 Configuring RMA Emails

	1. Select System, and click Configuration.
	2. Under SALES in the left column click Sales Emails.
	3. Expand the RMA field set. The fields on the RMA field set configure the emails sent to the customers upon RMAs creation. The following options are available:
	4. The RMA Authorization, RMA Admin Comments and RMA Customer Comments field sets contain similar options for other RMA email notifications. The RMA Authorization field set configures the email notifications that are sent to customers after RMA reques...
	5. To save the configuration, click the Save Config button in the upper-right corner of the page.
	18.5 Enabling Shipping Methods for Return Shipments

	1. Select System > Configuration.
	2. In the Current Configuration Scope drop-down menu in the upper-left corner of the page select the desired website.
	3. In the left column under SALES click Shipping Methods.
	4. In the field set for the desired shipping carrier (UPS, USPS, FedEx, DHL), in the Enabled for RMA field select Yes.
	5. To save the configuration, click the Save Config button in the upper-right corner of the page.
	18.6 Creating and Managing RMA Item Attributes
	18.7 Placing an RMA Request on the Frontend
	Account-Holding Customer Placing an RMA Request on the Frontend


	1. Select My Account > My Orders.
	2. Locate the order containing the items to be returned.
	3. Click the View Order link.
	4. Click the Return link in the upper-right corner of the order view. See Figure 168.
	5. By default, for each return product a customer must fill the following fields. (The fields correspond to the RMA attributes, which can be managed in the Admin Panel. For details, see “Creating and Managing RMA Item Attributes,” page 182.)
	6. When the customer is finished supplying the information about all products to be returned, the customer saves the request by using the Save button.
	Guest Customer Placing an RMA Request on the Frontend

	1. Click the Orders and Returns link in the store page footer.
	2. Fill the following fields (redundant information about the order is required for purposes of security):
	3. Click Continue. The New Return for Order page opens.
	4. Fill in the fields and save the request on the New Return page (see step 5 in “Account-Holding Customer Placing an RMA Request on the Frontend,” page 183).
	Creating an RMA Request Using the Orders and Returns Widget
	18.8 Placing an RMA Request on the Backend
	Creating an RMA Request from the RMA Management Section
	Creating an RMA Request from the Order View Page
	Creating an RMA Request from a Customer Page
	Setting Up and Saving a New RMA Request


	1. On the General Information tab you can type the contact email address of the customer, add comments and see the shipping cost estimation using the Get shipping methods and rates link in the Shipping Method section.  If you want the customer to rece...
	2. On the RMA Items tab you can add products to the request (at least one product must be specified to save the RMA request).  To add a product to the RMA request:
	3. To save the RMA request click the Submit RMA button in the upper-right corner of the page.
	18.9 Managing RMA Requests

	1. An RMA request is placed. Now you need to decide whether you agree to proceed with RMA process. You have the following options:
	2. You receive the returned items. On the RMA Items tab of the RMA page, specify the quantity you have received for each product, change its Status to Return Received, and click Save or Save and Continue. The new status of the RMA request depends on t...
	3. Managing the return resolutions (refund or exchange) is out of the RMA functionality scope, and can be managed in other sections of the Admin Panel. Depending on the resolutions you have selected for the approved RMA items, you may need to do the f...
	18.10 Return Shipments
	Creating a Shipment Order and Shipping Labels for RMA from the Magento Admin Panel


	1. Click the Create Shipping Label button. The Packages pop-up window appears.
	2. Select the packages and distribute shipped items between packages. The information about packages (type, size) and its contents (which products go to which packages) is required in order to generate a shipping label. For details about creating pack...
	3. After you create the packages and click OK, Magento connects to the shipping carrier’s web services, creates a separate shipping order in the carrier’s system for each package, and receives the shipping labels and the tracking numbers.  If you clic...
	Adding the RMA Shipping Information on the Frontend
	18.11 Viewing RMA Requests on the Frontend

	19 Store Credit
	19.1 Configuration of Store Credit
	19.2 Managing Store Credit
	Refunding to Store Credit
	Paying with Store Credit
	Store Credit in My Account


	Part IV: Payment
	20 General Magento Payment Concepts
	20.1 Definitions
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	21 PayPal Payment Methods
	21.1 Setting Merchant Location

	1. Log in to the Magento admin panel.
	2. Navigate to System > Configuration > SALES > Payment Methods.
	3. In Current Configuration Scope in the upper-left corner of the page select your website or leave Default Config.
	4. Under Merchant Location in the Merchant Country field, select your country (see Figure 176).
	5. To save changes, click Save Config.
	21.2 PayPal Payments Advanced
	General Concept
	Configuring PayPal Payments Advanced


	1. Set the options in the Magento Admin Panel.
	2. Set the required options of the PayPal Payments Advanced account on the PayPal Manager website.
	Setting PayPal Payments Advanced Options in the Magento Admin Panel

	1. Log in to the Magento Admin Panel.
	2. Navigate to System > Configuration.
	3. Select the desired website from the Current Configuration Scope drop-down menu in the upper-left corner of the page.
	4. Under SALES in the left column, click Payment Methods. In the Merchant Location section, choose United States in the Merchant Country field. If any other country is selected, the PayPal Payments Advanced settings are not displayed.
	5. In the PayPal All-in-One Payment Solutions section, click the Configure button next to PayPal Payments Advanced, to expand the corresponding settings.
	6. In the Required PayPal Settings field set, configure the following:
	7. In the Basic Settings – PayPal Payments Advanced section, configure the following settings:
	o Authorization: The payment is authorized and only an order is created in the backend of your store.
	o Sale: The payment is captured on the PayPal side, and as a result an order and an invoice are created in the backend of your store.
	o All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries selected in the Countries Payment Applicable From field can use this payment method. The field works as a filter, so that this payment method will be listed for o...
	8. The PayPal Billing Agreement Settings, Settlement Report Settings and Frontend Experience Settings, and Basic Settings – PayPal Express Checkout sections are related to configuring the PayPal Express Checkout method, which is included with the PayP...
	9. Click Save Config in the upper-right corner of the page to save the settings.
	Setting the PayPal Payments Advanced Account Options on the PayPal Manager Website

	1. Log in to https://manager.paypal.com/
	2. Navigate to Service Settings > Hosted Checkout Pages. Options should be configured in the Set Up and Customize sections.
	3. Configure the options according to the recommendations displayed in the PayPal Payments Advanced field set in the Magento Admin Panel.
	PayPal Payments Advanced Method: Customer Experience
	Order Processing with the PayPal Advanced Payment Method
	21.3 PayPal Payments Pro (Includes Express Checkout)
	Configuring PayPal Payments Pro


	1. In the admin panel, navigate to System > Configuration > SALES >Payment Methods. In the Current Configuration Scope field, select the website for which the payment method is to be enabled and then make sure that the Merchant Country field is specif...
	2. Under PayPal All-in-one Payment Solutions, click the Configure link for PayPal Payments Pro. The options are distributed under several sections: Required PayPal Settings, Basic Settings –PayPal Payments Pro, and Basic Settings PayPal Express Checkout.
	3. Configure the following options under Required PayPal Settings:
	4. Configure the following options under Basic Settings – PayPal Payments Pro:
	o Authorization: Payments are only authorized in the PayPal payment system and only an order is created in the backend of your store. You need to log on to the merchant account on the PayPal website and capture the transaction.
	o Sale: A payment is authorized and captured in the PayPal payment system and as a result a corresponding transaction is created in the PayPal merchant account and an order and an invoice are created in the backend of your web store.
	o All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries listed in the Countries Payment Applicable From field that becomes available can use this payment method. The field essentially works as a filter, so that this pa...
	o In the Severe 3D Secure Card Validation field, choose whether severe validation will be applied to credit cards by the Centinel system.
	o In the Centinel Custom API URL field, specify the URL provided by Centinel which will establish the connection with the Centinel system for credit card validation.
	5. Under Frontend Experience Settings, configure the following options:
	6. Under Basic Settings PayPal Express Checkout, configure the options of the PayPal Express Checkout Payment method. The options available for Express Checkout here are similar to the standalone Express Checkout options. For more information, see “Pa...
	7. To save the configuration, click Save Config.
	Working with PayPal Payments Pro
	21.4 PayPal (Website) Payments Standard

	1. Your first step is to create a PayPal merchant account. Check with PayPal (www.paypal.com) for detailed instructions.
	2. In the Magento backend, select System > Configuration > Payment Methods to display the Payment Methods page, as shown in Figure 177.
	3. In the Merchant Location section, select the country and specify the email address that is associated with your PayPal merchant account.
	4. In the PayPal All-in-One Payment Solutions section, click the Configure button next to PayPal (Website) Payments Standard, to expand the corresponding settings shown in Figure 178.
	5. In the Required PayPal Settings section, specify an email address that was used when registering a merchant account with PayPal and choose to enable the solution (payment method). See Figure 179.
	6. In the Basic Settings – PayPal Payments Standard section, perform the following configurations:
	o Authorization: Blocks or holds funds in the PayPal account until these funds have been transferred to your account. This usually occurs when you process the Order.
	o Sale: Specifies that funds are transferred to your account immediately.
	7. Click Advanced Settings to see and configure other available options:
	8. Click Save Config to save the configuration.
	21.5 PayPal Website Payments Pro Payflow Edition (Includes Express Checkout)
	Configuring Website Payments Pro Payflow Edition


	1. Navigate to System > Configuration > SALES > Payment Methods and then select the website for which the payment method is to be enabled.
	2. Make sure that United Kingdom is specified in the Merchant Country field under Merchant Location.
	3. Under PayPal All-in One Payment Solutions, click the Configure link for Website Payments Pro Payflow Edition (Includes Express Checkout). The options are distributed under several sections: Required Settings, Basic Settings – PayPal Website Payment...
	4. Configure the following options under Required Settings:
	5. Under Basic Settings – PayPal Website Payments Pro Payflow Edition, configure the following options:
	o Authorization: Payments are only authorized in the PayPal payment system and only an order is created in the backend of your web store. You need to log on to the merchant account on the PayPal website and capture the transaction.
	o Sale: A payment is authorized and captured in the PayPal payment system and as a result a corresponding transaction is created in the PayPal merchant account and an order and an invoice are created in the backend of your web store.
	o All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries listed in the Countries Payment Applicable From field that becomes available can use this payment method. The field works as a filter, so that this payment method...
	o In the Severe 3D Secure Card Validation field, choose whether severe validation will be applied to credit cards through the 3D Secure service. Severe credit card validation removes the charge back liability on the merchant.
	o In the Centinel API URL field, specify the URL provided by Centinel which will establish the connection with the Centinel system for credit card validation.
	Working with Website Payments Pro Payflow Edition
	21.6 PayPal Express Checkout
	Configuring PayPal Express Checkout


	1. Log in to the Magento admin panel.
	2. Navigate to System > Configuration > SALES > Payment Methods and select the website for which the payment method is to be enabled.
	3. Under PayPal Express Checkout, click the Configure link for PayPal Express Checkout. The options are grouped under two main headings Required PayPal Settings and Basic Settings – PayPal Express Checkout.
	4. Under Required PayPal Settings configure the following options:
	5. Under the Basic Settings – PayPal Express Checkout configure the following options:
	o Authorization: After the customer places an order in the web store, PayPal authorizes the order amount in the customer's PayPal balance. Customers cannot use the authorized amount from their buyer account because it is reserved by PayPal until the m...
	o Sale: The order amount is authorized by PayPal and the funds are captured from the buyer account and are transferred to the merchant account at PayPal. Merchants select this payment action if they are sure that the transaction and the shipment of pr...
	o Order: The amount of the order is neither captured nor authorized in the customer’s balance, bank account, or credit card at PayPal. The Order payment action represents an agreement between the PayPal payment system and the merchant which enables th...
	o All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries listed in the Countries Payment Applicable From field that becomes available can use this payment method. The field works as a filter, so that this payment method...
	o Dynamic: The appearance of dynamic images is dynamically changed by PayPal. When signing up for a PayPal campaign, the appearance of the image dynamically changes during the campaign based on the parameter information that you add to the image URL.
	o Static: The static images cannot be changed dynamically. When participating in a PayPal campaign, the image code must be manually updated to change the image displayed and restore the default image when the campaign is over.
	o Auto: The customer can either sign a billing agreement during the Express Checkout flow or use another method of payment.
	o Ask Customer: The customer can decide whether to sign a billing agreement during the Express Checkout flow.
	o Never: The customer cannot sign a billing agreement during the Express Checkout flow.
	o In the PayPal Product logo field select the PayPal logo which will be displayed on the home and catalog pages of your store.
	o Use the options grouped under PayPal Merchant Pages Style heading to configure customize the store-related fragment of the PayPal page displayed to customers who choose to pay using PayPal Express Checkout. To see the hint for an option click the qu...
	6. Click the Save Config button to save the current settings.
	Saving the Customer’s Billing Address

	1. Enable the corresponding functionality is enabled in your PayPal merchant account. Contact PayPal technical support for details.
	2. In the Magento Admin Panel, under System > Configuration > SALES > Payment Methods > PayPal Express Checkout, in the Require Customer’s Billing Address field select Yes, and save the configuration. If you want to request the customers billing addre...
	Order Transactions in PayPal Express Checkout
	Configuring the Payment Action for the PayPal Express Checkout


	1. In the Magento Admin Panel, select System > Configuration > SALES > Payment Methods. Configuration can be done either on the global or website level, so in the Current Configuration Scope drop-down menu located in the upper left part of the page, l...
	2. In the PayPal Express Checkout field set, in the Payment Action drop-down menu, select Order.
	3. Configure these additional settings, which correspond to settings in your PayPal merchant account:
	4. Click Save Config in the upper-right corner of the page to save the new configuration.
	Managing Orders Paid Using PayPal Express Checkout with Payment Action Set to Order
	Billing Agreements
	Billing Agreements Overview
	Configuring Billing Agreements


	1. In the Admin Panel, navigate to System > Configuration > SALES > Payment Methods.
	2. Locate and expand PayPal Express Checkout > Advanced Settings > PayPal Billing Agreement Settings.
	3. Set the Enabled field to Yes.
	4. In the Title field, specify the name of the billing agreement payment method that will be available to customers on the Billing Agreements tab of the customer account and in the Payment Information section of the shopping cart Checkout page.
	5. If more than one payment method is enabled, in the Sort Order field specify the order of the Bank Transfer payment method to appear in the Payment Information section both in the frontend and in the backend.
	6. In the Payment Action field, choose the way payments will be authorized in the PayPal payment system and the entities that will be created in the backend as a result of the payment transaction. The following options are available:
	7. The Payment from Applicable Countries parameter enables you to select which customers can use this payment method. All Allowed Countries means that all customers from the default countries list can use this payment method. If you have not already c...
	8. In the Debug Mode field, specify whether communications with the payment system are written into the log file.
	9. In the Transfer Cart Line Items field, choose whether shopping cart lines (product names, their price, quantities, and row total amounts) are transferred separately line by line, or transferred as one whole with the total price value.
	10. The customer is able to create billing agreements from the customer account if the Allow in Billing Agreements Wizard option is enabled in the configuration. The Billing Agreements tab in the customer account provides the wizard which redirects th...
	Creating a Billing Agreement from a Customer Account
	Creating a Billing Agreement with an Order
	Managing Billing Agreements
	Creating a Sales Order with a Billing Agreement
	Generating a PayPal Settlement Report

	1. In the admin panel, click System > Configuration.
	2. Under SALES, click Payment Methods and then locate and expand PayPal Express Checkout > Advanced Settings > Settlement Report Settings (or in the Express Checkout settings within the All-in-one PayPal solution).
	3. Under SFTP Credentials, specify the login and the password to connect to the PayPal SFTP server which will be used for transferring settlement transaction data. The login and the password are provided by the PayPal SFTP server administrator.
	4. In the Sandbox Mode field, choose whether you will be using a sandbox for testing settlement transaction reports or live environment. If you choose No, two additional fields for specifying the location of reports on the server become available.
	5. In the Custom Endpoint Hostname or IP-Address field, specify the hostname or the IP address of the server where the reports are stored. The field defaults to the endpoint hostname reports.paypal.com. The port number must be separated with a colon f...
	6. In the Custom Path field, specify the path to the folder where settlement reports are stored on the PayPal side. The field defaults to /ppreports/outgoing.
	7. PayPal settlement reports are automatically fetched from the PayPal payment system if this is set up in the Enable Automatic Fetching field located under Scheduled Fetching. When the field is set to Yes, two additional fields for setting up the fre...
	8. In the Schedule field, choose whether settlement reports will be fetched from PayPal daily, or every 3, 7, 10, 14, 30, or 40 days. Specify the time of day when settlement reports will be fetched in the Time of Day fields.
	9. Click the Save Config button to save the PayPal settlement reports configuration.
	Viewing a PayPal Settlement Report

	o Order ID
	o Transaction ID
	o Subscription ID
	21.7 PayPal Payflow Pro (Includes Express Checkout)
	PayPal Payflow Pro General Concept
	Configuring Payflow Pro Gateway


	1. In the admin panel, navigate to System > Configuration > SALES > Payment Methods and then select the website for which the payment method is to be enabled.
	2. Make sure that your merchant location is specified correctly in the Merchant Country field under Merchant Location.
	3. Under PayPal Payment Gateways, click the Configure link for PayPal Payflow Pro (Includes Express Checkout). Options are grouped under three main headings: Required PayPal Settings, Basic Settings – PayPal Payflow Pro, and Basic Settings – PayPal Ex...
	4. Under Required PayPal Settings, configure the following options:
	5. Under Basic Settings – PayPal Payflow Pro configure the following options:
	o Authorization: Payments are only authorized in the PayPal payment system and only an order is created in the backend of your store. You need to log on to the merchant account on the PayPal website and capture the transaction.
	o Sale: A payment is authorized and captured in the PayPal payment system and as a result a corresponding transaction is created in the PayPal merchant account and an order and an invoice are created in the backend of your web store.
	o All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries listed in the Countries Payment Applicable From field that becomes available can use this payment method. The field works as a filter, so that this payment method...
	o In the Severe 3D Secure Card Validation field, choose whether severe validation will be applied to credit cards through the 3D Secure service. Severe credit card validation removes the chargeback liability on merchant.
	o In the Centinel API URL field, enter the URL provided by Centinel which will establish the connection with the Centinel system for credit card validation.
	6. Under Basic Settings PayPal Express Checkout configure the options of the PayPal Express Checkout Payflow Edition payment method. This edition of the PayPal Express Checkout has fewer options than standalone Express Checkout. But the existing optio...
	7. To save the configuration click Save Config.
	Working with Payflow Pro Gateway
	21.8 The PayFlow Link Payment Method
	Configuring the PayFlow Link Payment Method


	1. Set the options in the Magento Admin Panel.
	2. Set the required options of the PayFlow Link account on the PayPal Manager website.
	Setting the PayFlow Link Payment Method Options in the Magento Admin Panel

	1. In the admin panel, click System > Configuration.
	2. Select the desired website from the Current Configuration Scope drop-down menu in the upper-left corner of the page.
	3. Under SALES in the left column, click Payment Methods. In the Merchant Country field select United States or Canada. If any other country is selected, the PayFlow Link settings are not displayed.
	4. Under PayPal Payment Gateways, click Configure next to the PayPal Payflow Link (Includes Express Checkout) label. Options are grouped under three main headings: Required PayPal Settings, Basic Settings – PayPal Payflow Link, and Basic Settings – Pa...
	5. Under Required PayPal Settings > PayFlow Link, configure the following options:
	6. In the Enable Payflow Link drop-down menu, select Yes to enable the payment method.
	7. Under Required PayPal Settings > Express Checkout, configure the options of the Express Checkout. The Express Checkout included to the Payflow Link method can be enabled only if the Payflow Link method is enabled. For description of the Express Che...
	8. Under Basic Settings – PayPal Payflow Link, configure the following Payflow Link options:
	o Authorization: The payment is authorized and only an order is created in the backend of your store.
	o Sale: The payment is captured on the PayPal side, and as a result an order and an invoice are created in the backend of your store.
	o All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries selected in the Countries Payment Applicable From field can use this payment method. The field works as a filter, so that this payment method will be listed for o...
	9. The PayPal Billing Agreement Settings, Settlement Report Settings and Frontend Experience Settings and Basic Settings – PayPal Express Checkout sections are related to configuring the PayPal Express Checkout method, which is included with the PayPa...
	10. Click Save Config in the upper-right corner of the page to save the settings.
	Setting the PayFlow Link Account Options on the PayPal Manager Website
	PayFlow Link Payment Method: Customer Experience
	Order Processing When the PayFlow Link Payment Method Is Used
	21.9 PayPal Payments Pro Hosted Solution (Includes Express Checkout)
	Configuring the Website Payments Pro Hosted Solution Payment Method in the Magento Admin Panel


	1. In the admin panel, click System > Configuration.
	2. Select the desired website from the Current Configuration Scope drop-down menu in the upper-left corner of the page.
	3. Under SALES in the left column, click Payment Method. In the Merchant Country field, select the country that receives money, according to your PayPal account details..
	4. Under PayPal Payment Solutions, click the Configure link for PayPal Payments Pro Hosted Solution (includes Express Checkout). The options are grouped under three main headings: Required PayPal Settings, Basic Settings – PayPal Website Payments Pro ...
	5. Under Required PayPal Settings, configure the following options:
	6. Under Basic Settings – PayPal Website Payments Pro Hosted Solution configure the following options:
	o Authorization: The payment is authorized and only an order is created in the backend of your store.
	o Sale: The payment is captured at PayPal's side, and as a result an order and an invoice are created in the backend of your store.
	o  All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries listed in the Countries Payment Applicable From field can use this payment method. The field works as a filter, so that this payment method will only be listed fo...
	7. The PayPal Billing Agreement Settings, Settlement Report Settings, Frontend Experience Settings and Basic Settings – PayPal Express Checkout sections are related to configuring the PayPal Express Checkout method. The existing options coincide with ...
	8. Click Save Config in the upper-right corner of the page to save the settings.
	The Website Payments Pro Hosted Solution Payment Method: Customer Experience
	Handling Orders Paid with the Website Payments Pro Hosted Solution Payment Method
	21.10 PayPal Fraud Management Filter Support in Magento
	“Review” Filter Action
	“Deny” Filter Action
	“Flag” Filter Action


	22 Authorize.Net Payments
	22.1 Balance Response, Partial Authorization Transactions, and Authorization Reversals
	Balance Response
	Partial Authorization


	1. On the Magento top menu, click System > Configuration.
	2. In the Current Configuration Scope drop-down menu in the upper left part of the page, leave the Default Config or select the desired website.
	3. In the left column under SALES click the Payment Methods tab. In the Authorize.Net field set, you can enable or disable the partial authorization functionality using the Allow Partial Authorization drop-down menu.
	Partial Authorization: Customer Experience
	Partial Authorization in Orders Created from the Admin Panel
	Partial Authorization Refund
	22.2 The Direct Post Payment Method for Authorize.Net
	Enable and Configure the Authorize.Net Direct Post


	1. Navigate to System > Configuration > SALES > Payment Methods > Authorize.Net Direct Post. Configuration can be done on either the global or website level, so in the Current Configuration Scope drop-down menu, located in the upper left part of the p...
	o Authorize Only: Funds on the customer's card are only authorized at the side of the Authorize.Net system and only an order is created in the backend of your store. You can later create an invoice and conduct the capturing.
	o Authorize and Capture: Funds on the customer's card are authorized and captured at Authorize.Net side, and as a result an order and an invoice are created in the backend of your store.
	o All Allowed Countries: Customers from the default countries list can use this payment method.
	o Specific Countries: Only customers whose billing address includes one of the countries selected in the Payment from Specific Countries field below, can use this payment method. The field works as a filter, so that this payment method will only be vi...
	2. Click Save Config in the upper-right corner of the page.
	Authorize.Net Direct Post in Orders Created from the Admin Panel
	Order Handling
	Authorize.Net Direct Post: Customer Experience
	22.3 3D Secure Authentication for Authorize.Net Payments
	3D Secure Authentication General Concept


	1. Configure general 3D Secure settings.
	2. Enable 3D Secure in the Authorize.Net payment method section.
	Configuring 3D Secure

	1. Navigate to System > Configuration > SALES > Payment Services. Configuring can be done on either the global or website level, so leave Default Config, or select the desired website in the Current Configuration Scope drop-down menu in the upper-left...
	2. Under 3D Secure Credit Card Validation the following settings are available:
	3. Click Save Config in the upper-right corner of the page.
	Configuring 3D Secure Use for Authorize.Net

	1. Navigate to System > Configuration > SALES > Payment Methods. Configuring can be done on either the global or website level, so leave Default Config, or select the desired website in the Current Configuration Scope drop-down menu in the upper-left ...
	2. Under 3D Secure in the Authorize.Net field set, select Yes in the 3D Secure Card Validation field. Additional settings appear:
	3. Click Save Config in the upper-right corner of the page.
	3D Secure for Authorize.Net: Customer Experience
	3D Secure for Authorize.Net in Orders Created from the Admin Panel

	23 Internal Payment Methods
	23.1 Saved Credit Cards

	1. Select System > Configuration > Payment Methods to display the Payment Methods page.
	2. In the Current Configuration Scope drop-down menu, select the scope for these configuration selections.
	3. Expand the Saved CC section to define credit cards, as shown in Figure 192.
	4. Make your configuration selections. Most of these options are self-explanatory. The options that may need some explanation are as follows:
	5. Click Save Config to save your changes.
	23.2 Checks and Money Orders
	23.3 Purchase Orders

	1. In the admin panel, navigate to System > Configuration > SALES > Payment Methods and then expand the Purchase Order field set.
	2. Set the Enabled field to Yes to make this field available to your customers.
	3. In the Title field, specify the name of the payment method as it will appear in the Payment Information section in both the frontend and in the backend.
	4. The Payment from Applicable Countries parameter enables you to select which customers can use this payment method. All Allowed Countries means that all customers from the default countries list can use this payment method. If you have not already c...
	5. In the Minimum Order Total field, you can specify that the payment method will be available only if the shopping cart total amount is greater than the minimum order total amount specified in this field.
	6. In the Maximum Order Total field, you can specify that the payment method will be available as long as the shopping cart total amount is less than the maximum order total amount specified in this field.
	7. If more than one payment method is enabled, use the Sort Order field to specify the order in which the Purchase Order payment method appears in the Payment Information section in both the frontend and in the backend.
	23.4 Zero Subtotal Checkout

	1. In the admin panel, navigate to System > Configuration > SALES > Payment Methods and then expand the Zero Subtotal Checkout field set.
	2. In the Title field, specify the name of the payment method as it will appear in the Payment Information section in both the frontend and in the backend.
	3. Set the Enabled field to Yes to make the payment method available to customers.
	4. In the New Order Status field, select the order status of all new orders created using this payment method. The recommended status is Pending, as this is intended to apply to orders which have not had any actions performed on them; however, you can...
	5. In the Automatically Invoice All Items field, choose whether all products in an order with a zero subtotal amount will be automatically invoiced by the system. However, the status of the order specified in the New Order Status field will not be tak...
	6. The Payment from Applicable Countries parameter enables you to select which customers can use this payment method. All Allowed Countries means that all customers from the default countries list can use this payment method. If you have not already c...
	7. If more than one payment method is enabled, use the Sort Order field to specify the order in which the Purchase Order payment method appears in the Payment Information section in both the frontend and in the backend.
	23.5 Bank Transfer

	1. Navigate to System > Configuration > SALES > Payment Methods.
	2. Locate and expand the Bank Transfer Payment field set.
	3. Set the Enabled parameter to Yes to enable this method.
	4. In the Title field, enter the name of the payment method to be displayed in the Payment Information section both in the frontend and in the backend.
	5. Set the New Order Status parameter to Pending.
	6. The Payment from Applicable Countries parameter enables you to select which customers can use this payment method. All Allowed Countries means that all customers from the default countries list can use this payment method. If you have not already c...
	7. In the Instructions field, specify the bank account information you need to enable your customers to transfer money through this payment method.
	8. In the Minimum Order Total field, you can specify that the payment method is available only if the shopping cart total amount is greater than the minimum order total amount specified in this field.
	9. In the Maximum Order Total field, you can specify that the payment method is available as long as the shopping cart total amount is less than the maximum order total amount specified in this field.
	10. If more than one payment method is enabled, in the Sort Order field specify the order of the Bank Transfer payment method to appear in the Payment Information section both in the frontend and in the backend.
	11. Click Save Config.
	23.6 Cash on Delivery

	1. Navigate to System > Configuration > SALES > Payment Methods.
	2. Locate and expand the Cash On Delivery Payment field set.
	3. Enable the payment method by selecting Yes in the Enabled field.
	4. In the Title field, enter the name of the payment method to be displayed in the Payment Information section both in the frontend and in the backend.
	5. Set the New Order Status parameter to Pending.
	6. The Payment from Applicable Countries parameter enables you to select which customers can use this payment method. All Allowed Countries means that all customers from the default countries list can use this payment method. If you have not already c...
	7. In the Instructions field, enter any specific instructions for customers to follow with regards to the cash on delivery payment.
	8. In the Minimum Order Total field, you can specify that the payment method is available only if the shopping cart total amount is greater than the minimum order total amount specified in this field.
	9. In the Maximum Order Total field, you can specify that the payment method is available as long as the shopping cart total amount is less than the maximum order total amount specified in this field.
	10. If more than one payment method is enabled, in the Sort Order field specify the order of the Cash on Delivery payment method to appear in the Payment Information section both in the frontend and in the backend.
	11. Click Save Config.
	Part V: Marketing
	24 Up-selling, Related Products, and Cross-selling
	24.1 Up-sells

	1. In the Admin Panel select Catalog > Manage Products to display a list of products, as shown in Figure 202.
	2. Click the Edit link which appears on the right side of the row of the product for which you want to define Up-sells. The page shown in Figure 203 is displayed:
	3. Select the Up-sells tab in the panel on the left. See Figure 204.
	4. Use the check box in each row or the products that you want to appear as up-sells to this product.
	5. Click the Save button.
	24.2 Related Products

	1. In the Admin Panel, select Catalog > Manage Products to display a list of products.
	2. Click the Edit link that appears on the right side of the row of the product for which you want to define Related Products.
	3. Select the Related Products tab in the panel on the left to display the Product Listing page.
	4. Use the check box in each row of the products that you want to appear as Related Products to this product.
	5. Click the Save button.
	24.3 Cross-sells

	1. In the Admin Panel, select Catalog > Manage Products to display a list of products.
	2. Click the Edit link that appears on the right side of the row of the product for which you want to define Related Products.
	3. Select the Cross Sells tab in the panel on the left to display the Product Listing page.
	4. Use the check box in each row of the products that you want to appear as Cross-sells for this product.
	5. Click the Save button.
	25 Catalog and Shopping Cart Price Rules
	25.1 Catalog Price Rules
	Defining the Catalog Price Rule Information


	1. From the Admin Panel, select Promotions > Catalog Price Rules > Add New Rule button to display the page shown in Figure 207.
	2. In the Rule Name and the Description fields, specify a unique name and a description for this Catalog Price Rule.
	3. In the Status field, select Active.
	4. In the Websites field, select the website to which this rule applies.
	5. In the Customer Groups field, select one or more customer groups to which this rule applies.
	6. In the From Date and To Date fields, set a date range for the rule to take effect. If you leave the date range empty, then the rule is enabled as soon as it is created.
	Defining the Catalog Price Rule Conditions

	1. Select the Conditions option in the panel on the left to display the page shown in Figure 208.
	2. The first rule appears by default: If ALL these Conditions are TRUE. It specifies whether the rules that you define must all be met or if any of them can be met (AND or OR) in order to trigger the rule’s action. In our example, we wanted the discou...
	3. Click on the  icon to display a selection field and select the SKU option under Product Attributes from the drop-down menu. The page changes as shown in Figure 209.
	4. Click on the is link to display the comparison operator drop-down menu shown in Figure 210.
	5. Select the is one of comparison operator.
	6. Click on the three dots to the right of the words is one of to display the value field, as shown in Figure 211.
	7. Click on the Chooser icon  to display a list of products from which you can select, as shown in Figure 212.
	8. Select the check boxes of the products (T-shirts in this example) to which this rule is to apply.
	9. Save this selection of products by clicking the Apply icon .
	10. Now this rule specifies that it applies to T-shirts. You must now add the Condition that the product must cost over $20 in order for the rule to apply. To do so, click on the  icon to display a selection field and select the Price option under Pro...
	11. Click on the is link and select equals or greater than from the comparison operator drop-down menu.
	12. Enter the value 20.00 in the value field on the right to create the second Condition, as shown in Figure 213.
	Defining the Catalog Price Rule Actions

	1. Select the Actions option in the panel on the left to display the page shown in Figure 214.
	2. The Apply drop-down menu enables you to define whether the discount that is specified in the Discount amount field is a percentage or a fixed amount of the price of this product. It also enables you to define whether the discount amount is subtract...
	3. In the Discount Amount field, specify the value 10.00. This specification defines a final price that is a 10% reduction of the original price.
	4. Select the Save Rule button to create the rule.
	5. You must also select either the Save and Apply or the Apply Rules button to immediately apply this discount to the selected products.
	25.2 Shopping Cart Price Rules
	Defining the Cart Price Rule Information


	1. In the Admin Panel, select Promotions > Cart Price Rules > Add New Rule button to display the page shown in Figure 215.
	2. In the Rule Name field and the Description field, specify a unique name and a description for this Shopping Cart Price Rule.
	3. In the Status field, select Active.
	4. In the Website field, select the website to which this coupon applies.
	5. To specify that this rule only applies when a coupon code is used, select Specific Coupon in the Coupon drop-down menu, and specify the code of the coupon that the customer must specify in the web store.
	6. To specify that each customer can use this coupon only once, specify 1 in the Uses Per Customer field.
	7. In the From Date and To Date fields, set a date range for the rule to take effect. If you leave the date range empty, then the rule is enabled as soon as it is created.
	8. By default, an announcement of this shopping cart price rule is included in your store’s RSS feed. To suppress this announcement, select No in the Public in RSS Feed drop-down menu.
	Defining the Cart Price Rule Conditions
	Defining the Cart Price Rule Actions

	1. Select the Actions option in the panel on the left to display the page shown in Figure 217.
	2. The Action tab has two important sections. The first one controls the discount. In the Apply field, select Percent of product price discount.
	3. In the Discount amount field, specify 10 to indicate that 10% is reduced from the product’s original price.
	4. In the Maximum Qty Discount is Applied to field, specify the maximum quantity of products to which this discount can be applied. If you enter 5 in this field, then the first five products of this type purchased in the same shopping cart get the 10%...
	5. In the Discount Qty Step (Buy X) field, specify how often the discount is applied. This field is not relevant to our example, so leave this field empty. If you enter 8 here, then a 10% discount is applied to all the products after the eighth produc...
	6. In the Free Shipping field, specify whether to combine the coupon amount with a free shipping offer, for only the products for which the coupon is valid or for the entire Order, when one of these products is in the shopping cart. This field is not ...
	7. After defining the coupon as described above, select the products for which the coupon is valid. In our example, the coupon discount applies to clogs. Define a condition that applies to the SKU of clogs, as shown in Figure 218.
	8. Click the Save Rule button.
	25.3 Example: Defining a Buy 2 Get 1 Free Promotion

	1. Define the Coupon Information, as described in “Shopping Cart Price Rules,” page 279, but leave the Coupon drop-down menu selected to No Coupon. This selection specifies that the discount takes effect as soon as a customer adds the products to the ...
	2. Do not define any conditions, because this rule is always applied to the Digital Camera. The deal is created for the Argus QC-2185 Quick Click 5MP Digital Camera available in the Magento Sample Data.
	3. Click the Actions tab in the left navigation bar. In the Apply field, select the Buy X get Y free option.
	4. In the Discount Amount field, specify 1. This is the number of units that are offered free.
	5. In the Discount Qty Step field, specify 2. This is the number of units that must be purchased in order to receive the free unit.
	6. In the bottom section, set up the condition to specify the SKU of the item that is featured in this promotion
	7. Click the Save Rule button.
	25.4 Auto-Generating Coupon Codes
	Auto-Generating Coupon Codes Quick Reference
	Configuring Coupon Codes Auto-Generation Settings
	Auto-Generating, Exporting, and Managing Coupon Codes


	1. Log in to the Magento Admin Panel.
	2. Navigate to Promotions > Shopping Cart Price Rules.
	3. Select an existing rule or create a new one.
	4. In the Coupon field select Specific Coupon.
	5. Select the Use Auto Generation check box. Perform other rule configurations, if necessary.
	6. Click Save and Continue Editing. The Manage Coupon Codes tab appears. See Figure 221.
	7. On the Manage Coupon Codes tab, specify the quantity of codes to be generated in the Coupon Qty field, correct the code format settings (if necessary) and click Generate. The generated coupon codes appear in the grid. For each coupon, you can see w...
	8. To export the codes, filter the list of codes so that only the desired codes are displayed, choose the file extension in the Export to field, click Export, and save the file.
	Tracking the Usage of Coupon Codes

	1. Navigate to Reports > Sales > Coupons. The Coupons Usage Report page opens.
	2. In the Show Report For field select the scope, configure report filters. In the Shopping Cart Price Rule field select Specified and select the desired rule(s).
	3. Click Show Report in the upper right corner of the page.
	26 Special Prices and Product Group Price
	26.1 Special Prices

	1. In the Admin Panel, select Catalog > Manage Products to display the list of products.
	2. Click the Edit link on the right side of the relevant product’s row.
	3. Click the Prices tab in the left navigation panel. See Figure 222.
	4. In the Special Price field, enter the special price.
	5. Optionally, set Special Price From / To Date. If you leave these fields blank, the special price is applied immediately and applies until removed on the same page.
	6. Click Save.
	26.2 Product Group Price
	Terminology
	Setting a Group Price for a Product


	1. Log in to the Magento Admin Panel.
	2. Navigate to Catalog > Manage Products > %desired product%. The Product Information page opens.
	3. On the Prices tab in the Group Price field click Add Group Price.
	4. Select the target customer group and specify the price for the selected group. The Website column defines the scope of the Group Price field.
	5. To save your changes, click Save or Save and Continue Edit.
	Group Price Implementation Details

	27 Tier Pricing
	1. In the Admin Panel, select Catalog > Manage Products to display the list of products.
	2. Click the Edit link on the right side of the relevant product’s row.
	3. Click the Prices tab in the left navigation panel. See Figure 224.
	4. Add tiers by clicking the Add Tier button. You can create as many tiers as you need.
	5. Click Save.
	28 Minimum Advertised Price (MAP)
	28.1 Minimum Advertised Price – General Concept
	28.2 Minimum Advertised Price – a Quick View
	28.3 Setting Up MAP
	28.4 Setting up MAP on the Global Level

	1. In the Magento Admin Panel, select System, and click Configuration.
	2. In the Current Configuration Scope in the upper left corner of the page, select the desired website.
	3. In the left column under SALES, click Sales.
	4. On the Minimum Advertised Price field set configure the following settings:
	5. To save the configuration, click the Save Config button in the upper-right corner of the page.
	28.5 Setting Up MAP on the Product Level

	1. Select Catalog and click Manage Products.
	2. Open the product for editing.
	3. On the Prices tab, the following MAP settings are available:
	4. To save the settings click Save or Save and Continue.
	28.6 How MAP Is Applied for Different Product Types
	28.7 How MAP Is Applied for Different Price Settings

	29 Newsletters
	1. In the Admin Panel, select System > Configuration to display the configuration page.
	2. In the CUSTOMERS area in the left navigation panel, select the Newsletter option and expand the Subscription Options area to display the page shown in Figure 233.
	3. In the Need to Confirm field, select Yes to specify that each customer that registers for a newsletter will receive an email asking them to confirm their registration. This technique is called double opt-in, meaning that customers confirm that they...
	29.1 Newsletter Templates

	1. In the Admin Panel, select Newsletter > Newsletter Templates to display a page listing the previously defined newsletter templates. You can edit an existing template or create a new one.
	2. To add a new template, click the Add New Template button to display the New Newsletter Template page, as shown in Figure 234.
	3. In the Template Name field, specify a unique and indicative name for this template. This value is not visible for customers.
	4. In the Template Subject field, specify the subject of the email to be sent to your customers.
	5. In the Sender Name and Sender Email fields, specify the name and email of the sender of the email to be sent to your customers.
	6. In the Template Content field, use the WYSIWIG editor to compose the body of the email. Note that this field is pre-filled with tags showing an unsubscribe link in the email. We recommend that you do not remove this link so that all emails that are...
	7. Click Preview Template, to display the content with the formatting as it will be viewed by your subscribers.
	8. After you have finished editing the template, click the Save Template button to save it.
	29.2 Newsletter Queues

	1. In the Admin Panel, select Newsletter > Newsletter Templates to display a list of newsletter templates.
	2. In the Action drop-down menu for the relevant template, select the Queue Newsletter option.
	3. In the Queue Date Start field, specify when the newsletter will start being sent.
	4. In the Subscribers From field, select one or more store views whose customers this newsletter will be sent to.
	5. Review the template and parameters and then click the Save Newsletter button to schedule sending the newsletter.
	29.3 Newsletter Reports

	30 Facebook Open Graph Extension 2.0 for Magento
	30.1 Compatibility
	30.2 Downloading and Installing
	30.3 Installing
	30.4 Setting Up

	1. Create an application on the Facebook Developers site
	2. Configure Magento
	Creating an Application on the Facebook Developers Site

	1. Navigate to https://developers.facebook.com/
	2. Click Apps in the top menu.
	3. Click Create New Application and perform all of the steps of the app creation wizard. Using the app by the Facebook Open Graph 2.0 extension implies  the following restrictions and requirements:
	o URL (page URL)
	o Title (product title)
	o Image (image URL)
	o Description (product description)
	o Price
	Configuring Magento

	1. Navigate to System > Configuration > SOCIAL > Facebook. If you don’t see the SOCIAL heading in the left column, you may have not installed the extension.
	2. In the Current Configuration Scope drop-down menu in the upper left corner of the page select your website.
	3. Under Facebook Config set the following:
	o In the Action column, specify the internal button action title, for example, own or want. This value should correspond to the value you have specified in the Graph API URL field on the Facebook Developers site. The Graph API URL field is available i...
	o In the Button Title column, specify the name of the social networking button as you want it to appear in the frontend.
	o In the Enable FriendBox column decide if you want to display in the frontend the related Facebook block, which contains the count and the pictures of friends.
	o In the Count in FriendBox column, set the maximum number of friends that can be displayed in the related Facebook block. By default, it is set to 3. If you set zero value (0) or leave the field empty, then the default value is applied.
	4. To save the configuration, click Save Config in the upper right corner of the page.
	30.5 Facebook Open Graph 2.0 Extension: Customer Experience

	1. Customer is not logged in to Facebook. See Figure 241.
	2. Customer is logged in to Facebook, but none of the customer’s friends wants or owns the product. See Figure 242.
	3. Customer is logged in to Facebook, but he or she has not performed any action with the app yet. See Figure 243.
	4. Customer is logged to Facebook, and his or her friends have already performed some action with the app. See Figure 244.
	Part VI: Store Management
	31 Managing Orders and Customers
	31.1 Managing Customers
	Viewing and Editing Customers


	1. In the Admin Panel, select Customers > Manage Customers to display the Manage Customers page, as shown in Figure 245. The Manage Customers page contains a list of all the customers that opened accounts in your web store or were added using the Add ...
	2. Click the Edit link on the right side of a customer’s row to display the customer information page, as shown in Figure 246.
	Adding a Customer

	1. In the Admin Panel, select Customers > Manage Customers.
	2. Click the Add New Customer button to display the New Customer page, as shown in Figure 247.
	3. The fields on this page are self-explanatory. Specify the customer’s information and then click the Save Customer button.
	Managing Customer Groups

	1. In the Admin Panel, select Customers > Customer Groups to open the Customer Groups page, as shown in Figure 248.
	2. Do one of the following:
	3. Specify a unique name for this customer group (or modify the existing name).
	4. Select a tax class to associate with this group.
	5. Click Save Customer Group.
	Checking Online Customers
	Customer Reports
	Importing and Exporting Customer Information
	31.2 Managing Orders
	Orders Terminology
	Sales Order
	Invoice
	Shipment
	Credit Memo

	Creating New Orders


	1. In the Admin Panel, select Sales > Orders.
	2. Click the Create New Order button on the top right of the page to display the Create New Order page, as shown in Figure 251.
	3. Select a customer If you have multiple websites, stores, or store views, select the one to which this order applies. The Create New Order for <customer> page opens, as shown in Figure 252.
	4. Click the Add Products button to display the list of products, as shown in Figure 253.
	5. Use the check boxes to select the products to be purchased, and click the Add Selected Product(s) to Order button.
	6. Complete the other mandatory fields of the order. Mandatory fields are marked by an asterisk (*).
	7. You can define many options for the order, such as choosing custom prices for products and applying discount codes.
	8. After you have completed all the required order information, click the Submit Order button to display the order information page.
	9. To confirm payment, click the Invoice button to generate an invoice for your review.
	10. Review the invoice, and if all is well, click the Submit Invoice button at the bottom of the page.
	11. When you are ready to ship the products, click the Ship button to generate a Shipment document.
	12. If applicable, you can add a tracking number received from the shipping service by clicking the Add Tracking Number button. Adding a tracking number enables customers to view the status of their shipment using the shipping carrier’s website.
	13. Review the shipment. You can modify the quantity to be shipped if only part of the order is ready.
	14. Click the Email Copy of Shipment option to automatically send an email to notify the customer that the products were shipped.
	15. Click the Submit Shipment button at the bottom of the page.
	16. Click the Back button to return to the orders page, where you can create additional Orders if needed.
	Clearing the Shopping Cart
	Refunding

	1. In the Admin Panel, select Sales > Orders to display a list of the existing orders.
	2. Click the View link on the right side of the row of the desired order to display the order view page.
	3. Click the Credit Memo button to generate a credit memo.
	4. Scroll down to the Items to Refund area, and in the Qty to Refund field of each relevant product, specify the quantity of products to refund.
	5. To specify that this product was actually returned to the web store, select the Return to Stock check box, as shown in Figure 257.
	6. (Optional) Select the Email Copy of Credit Memo check box, as shown in Figure 258, to automatically send an email to the customer that the order has been refunded. You can also adjust the refund totals to match your business rules.
	7. Click the Refund button at the bottom of the page. The total of the order from which this product was refunded is updated automatically.
	8. Click the Back button to return to the orders page where you can create additional orders, if required.
	32 Managing Customer-Generated Content
	32.1 Managing Ratings and Reviews
	Adding a Custom Rating


	1. In the Admin Panel, select Catalog > Reviews & Ratings > Manage Ratings to display the Manage Ratings page, as shown in Figure 262.
	2. Click the Add New Rating button to display the New Rating page, as shown in Figure 263.
	3. In the Default Value field enter a name for this rating.
	4. Click the Save Rating button.
	Approving Reviews for Public Viewing

	1. In the Admin Panel, select Catalog > Reviews & Ratings > Customer Reviews > Pending Reviews to display the Pending Reviews page, as shown in Figure 264.
	2. Click the Edit link on the right side of the relevant review’s row to display the Review Details page, as shown in Figure 265.
	3. You can modify the review, if required.
	4. In the Status field, change the Pending status to Approved or Not Approved.
	32.2 Managing Tags
	Adding Tags
	Approving Tags


	1. In the Admin Panel, select Catalog > Tags > Pending Tags to display the Pending Tags page, as shown in Figure 268.
	2. Use the check boxes in the left column to select all of the tags that you want to approve (or all of the tags that you want to disable).
	3. In the Action drop-down menu, select Change Status. The Status drop-down menu becomes visible.
	4. In the Status drop-down menu, select Approve (or Disable).
	32.3 Managing Polls

	1. In the Admin Panel, select CMS > Polls to open the Poll Manager page, which shows a list of existing polls.
	2. Click the Add New Poll button in the top right corner of the page to display the New Poll page, as shown in Figure 271.
	3. In the Poll Question field, enter the question that your customer will be asked.
	4. In the Status field, specify whether the poll is Open or Closed. The status of the poll is Open by default, which means that it appears in your store. If you do not want it to appear in your store, select the Closed option.
	5. Select one or more stores that you want the poll to appear in.
	6. Click the Poll Answers option in the left panel to display Assigned Answers page.
	7. Click the Add New Answer button to add possible answers to your question that can be selected by customers, as shown in Figure 272.
	8. In the Answer Title field, specify the text of the answer to appear in your store for customers to select.
	9. To influence the poll results in advance, you can add votes to the count in the Votes Count field, which is 0 by default.
	10. Repeat steps 7 through 9 for each answer that you want to appear in this poll.
	11. Click the Save Poll button.
	Editing a Poll

	33 Inventory Control: Quantity Increments and “Only X Left”
	33.1 Enabling and Configuring Advanced Inventory Control Options

	1. Choose System > Configuration. Select the Inventory tab on the left.
	2. To enable the “Only X left” feature for a website, in the Stock Options panel set the Only X left Threshold value to your desired threshold. If the value is 0, the feature will not be enabled. This value can be set differently for each Magento webs...
	3. To globally enable the Quantity Increments feature, in the Product Stock Options panel set Enable Qty Increments to Yes. Enter the desired default increment in the Qty Increments field that appears when you change this field to Yes. You can overrid...
	4. To globally enable the minimum purchase quantities for specific customer groups, in the Product Stock Options panel click the [+Add Minimum Qty] button. Select the customer group from the drop-down menu and enter the quantity minimum desired. This ...
	5. Click the [✔Save Config] button to save your settings.
	1. Choose Catalog > Manage Products.
	2. Select a product to edit and then select the Inventory tab on the left.
	3. In the Inventory panel, enable the Quantity Increments feature for this product by setting Enable Qty Increments to Yes. Enter the desired increment in the Qty Increments field that appears when you change this field to Yes.
	4. Click the [✔Save] button to save your settings.
	34 Monitoring and Improving the Web Store
	34.1 Reports
	Generating Reports
	Refreshing Sales Report Statistics


	1. In the Admin Panel, select Reports > Refresh Statistics to open the Refresh Statistics page, as shown in Figure 275.
	2. Use the check boxes on the left to select the reports for which you want to have the statistics refreshed.
	3. In the Actions drop-down menu, select the scope of the statistics to be refreshed: Refresh Lifetime Statistics or Refresh Statistics for the Last Day.
	4. Click Submit.
	Available Reports
	34.2 Search Synonyms and Redirects

	1. In the Admin Panel, select Catalog > Search Terms to display the Search page, as shown in Figure 276.
	2. Click the Add New Search Term button to display the New Search page, as shown in Figure 277.
	3. In the Search Query field, specify the incorrect spelling of the term (“latop” in this example).
	4. In the Synonym For field, specify the correct search term that is defined in your web store (“laptop” in this example).
	5. In the Redirect URL field, specify the URL to which the customer is redirected when no results are returned for the search term.
	6. Click the Save Search button.
	34.3 Google Analytics

	1. In the Admin Panel, select System > Configuration > Google API.
	2. Expand the Google Analytics section as shown in Figure 278.
	3. In the Enable field, select Yes.
	4. In the Account number field, specify the Google Analytics account number that you wrote down when you signed up for the service.
	35 Keeping Your Store Healthy
	35.1 Backups and Rollbacks
	Backup and Rollback Quick Reference
	Creating and Managing Backups


	1. Log in to the Magento Admin Panel.
	2. Navigate to System > Tools > Backups.
	3. Click one of the following buttons, depending on the backup type you need to create:
	 System Backup: Creates a complete backup of the database and the file system. On the next step you will have the possibility to choose whether to include the media folder to the backup.
	 Database and Media Backup: Creates a backup of the database and the media folder.
	 Database Backup: Creates a backup of the database.
	4. The confirmation dialog box appears. If you agree to put the store into the maintenance mode for the time of backup creation, select the corresponding check box. After the backup creation is completed, the maintenance mode is turned off automatical...
	Rolling Back the System

	1. In the Magento Admin Panel, navigate to System > Tools > Backups.
	2. The Backups page opens, where all previously created backups are listed in a grid. For the desired backup, click the Rollback link in the Action column. Note that all changes made since the backup creation will be lost after the rollback.
	3. Confirm rolling back, specify your Magento Admin Panel account password, and choose whether you want to put your store into the maintenance mode for the time of rolling back. When restoring file system or database and media files you can choose to ...
	4. After the rollback, you are redirected to the login page to log in to the Admin Panel.
	5. Refresh cache types and rebuild required indexes. This can be done under System > Cache Management and System > Index Management, respectively.
	Limiting Access to the Backup and Rollback Functionality for Administrator Users
	Creating a Backup from the Magento Connect Manager (MCM)

	1. Navigate to System > Magento Connect > Magento Connect Manager.
	2. Select the Create Backup check box and select the backup type. See Figure 280.
	3. Proceed with installing extension or updating Magento. The backup will be created automatically, and will be listed in the grid under System > Tools > Backups in the Magento Admin Panel.
	35.2 Staging Environment
	35.3 Extending Magento

	1. Go to the MagentoConnect page on the MagentoCommerce site at http://www.magentocommerce.com/.
	2. Browse through the extensions using the filters provided in the panel on the right.
	3. Go into the details page of the desired extension to display a page similar to Figure 282.
	4. Click Get Extension Key to display the following:
	5. Click the link to read the license agreement, then accept the licensing agreement by selecting the agreement check box.
	6. An extension key similar to the following is displayed: magento-core/Mage_Ideal. This is a special link to an extension that Magento recognizes. Click Select to select it and then copy it to the clipboard (Ctrl+C).
	7. In the Admin Panel, select System > Magento Connect > Magento Connect Manager.
	8. Log in using your backend username and password and click Log In.
	9. Paste the extension key in the Install New Extensions section, as shown in Figure 283.
	10. Click the Install button and wait until the installation has finished.
	Part VII: Advanced Site Management
	36 Controlling Website Access
	36.1 Limiting Administrator Access to the Admin Panel (Backend)

	1. Choose System > Permissions > Roles.
	2. Click on the [+Add New Role] button to create a new role.
	3. In the Role Info tab, specify the following information:
	4. Select the Role Resources tab in the left column.
	o Select Custom from the Role Scopes drop-down menu.
	o In the resulting list, select the websites and/or stores that you want users with that role to have access to.
	o Select Custom from the Resource Access drop-down menu.
	o In the resulting list, select the menus and features that you want users with that role to have access to.
	o If desired, select the Role Users tab and assign existing Admin user accounts to this new role.
	5. Click the [✔Save Role] button to save your new role.
	36.2 Limiting Visitor/Customer Access to the Website (Frontend)
	Restricting Customer Access from an Entire Website


	1. Choose System > Configuration. Select the General tab on the left.
	2. In the Website Restrictions panel, you can set the following values:
	o Website Closed - All access to the frontend website is restricted and the website is essentially “closed.” All frontend URLs are temporarily redirected to the page specified as the Landing Page below. This setting can be useful during site maintenan...
	o Private Sales: Login Only - Users can only access the frontend website if they first log in. All frontend URLs are temporarily redirected to either the specified landing page or to the login form until the user logs in. Users cannot create a new acc...
	o Private Sales: Login and Register - Users can only access the frontend website if they first log in. All frontend URLs are temporarily redirected to the login form until the user logs in. Users can create a new account themselves when the site is in...
	o To login form - Users are redirected to the log in form until they log in.
	o To landing page - Users are redirected to the static page specified below until they log in.
	o 503 Service unavailable means that the page is not available, and the index will not be updated.
	o 200 OK means the landing page returned is the correct page, and the spider might assume the landing page is the only page on the site.
	3. Click the [✔Save Config] button to save your settings.
	Restricting Customer Access on a Category-by-Category Basis

	1. Choose System > Configuration. Select the Catalog tab on the left.
	2. In the Category Permissions panel, you can set the following values:
	o Yes - Frontend website access is restricted in the manner set in the fields below. A new tab (Category Permissions ) will appear at the category level in Catalog > Manage Categories so that you can override these settings on a category-by-category b...
	o No - This feature in disabled and the following settings have no effect.
	o Yes, to all – Gives this permission to all customer groups.
	o Yes, to specified customer groups - Gives this permission to certain customer groups only.
	o Customer Groups – This multiple select menu will appear, listing all existing customer groups, from which you can select the group or groups to give this permission.
	o No, redirect to landing page - Denies this permission to all customer groups.
	o Landing Page - Select the landing page that customers will be directed to if they do not have permission to browse categories. Customers will be redirected if you have selected either Yes, to specified customer groups or No, redirect to landing page...
	o Yes, to all - Gives this permission to all customer groups. Select Yes, to specified customer groups in order to give this permission only to certain customer groups.
	o If this option is selected, a Customer Groups multiple select menu will appear, listing all existing customer groups, from which you can select the group or groups to give this permission. Select No in order to deny this permission to all customer g...
	o Select Yes, to all in order to give this permission to all customer groups.
	o Select Yes, to specified customer groups in order to give this permission only to certain customer groups. If this option is selected, a Customer Groups multiple select menu will appear, listing all existing customer groups, from which you can selec...
	o Select No in order to deny this permission to all customer groups.
	3. Click the [✔Save Config] button to save your settings.
	36.3 CAPTCHA
	CAPTCHA: Quick Reference
	Enabling and Configuring CAPTCHA for the Backend


	1. Log in to the Magento Admin Panel.
	2. Navigate to System > Configuration > ADVANCED >Admin > CAPTCHA. Make sure that the Current Configuration Scope is set to Default.
	3. Configure the following settings:
	4. To save the settings click Save Config.
	Enabling and Configuring CAPTCHA for the Frontend

	1.  Log in to the Magento Admin Panel.
	2. Navigate to System > Configuration > CUSTOMERS > Customer Configuration.
	3. In the Current Configuration Scope drop-down field select the desired website.
	4. Expand the CAPTCHA field set. Configure the following settings:
	5. To save the settings click Save Config.
	CAPTCHA: User Experience

	37 Read and Edit Permissions for Prices and Promotions
	37.1 Read and Edit Permissions – a Quick View
	Permissions for Promotions Resources – a Quick View
	Permissions for Product Management – a Quick View

	37.2 Access Roles and Users
	37.3 Read and Edit Permissions for Product Management Resources
	Configuring the Default Price


	1. Select System > Configuration > Catalog.
	2. In the Current Configuration Scope drop-down menu in the upper left corner of the page, leave Default Config.
	3. Set the default price in the Default Product Price field on the Price field set.
	Read and Edit Permissions for Promotions Resources

	38 Advanced Security Features
	38.1 Encryption and Hashing
	38.2 Changing the Database Key

	1. Navigate to System > Manage Encryption Key.
	2. Select whether or not the new encryption key will generate automatically. If not, a New Key field will appear in which you can manually enter a new key.
	3. Click the Change Encryption Key button in the top right of the page.
	38.3 Logging Administrator Actions
	Logs Report
	Logs Archive

	38.4 Setting Administrator Password Security Levels

	39 Advanced Design and Content Management
	Chapter Quick Reference
	39.1 Content Staging
	Setting Up Content Staging Websites


	1. Choose System > Configuration. Select the General tab on the left.
	2. In the Staging Websites panel, configure your staging websites:
	o If you select No, the site(s) can be accessed as usual.
	o Take down entire frontend means access to all sites will be restricted, and is the recommended option.
	o Take down only relevant websites means access will be restricted only to the site(s) involved in the merge or rollback activity.
	3. Click the [✔Save Config] button to save your settings.
	1. Choose System > Content Staging > Staging Websites.  This page contains a grid listing all existing Staging Websites.
	2. Click the [+Add Staging Website] button.
	3. Select one of existing websites as the base in the Source Website drop-down menu and click the [Continue] button.
	4. Configure the staging website with the following options:
	o Not accessible - Disables access to the entire staging frontend.
	o Accessible – The staging site is open and can be accessed by anyone that knows the URL.
	o Require HTTP Auth – The staging site will show a username and password prompt on access, which can be configured below.
	5. Select Original Website Content to be Copied to Staging Website – This section determines which items will be copied to the Staging Website from the source Website.
	6. Select Original Website Store Views to be Copied to Staging Website – This Section determines which Store Views will be copied to the Staging Website from the source Website.
	7. Click the [Create] button to save your settings. You will be redirected to the Staging Websites grid.
	Merging Content

	1. Navigate to System > Content Staging > Staging Websites.
	2. Click on the staging website in the grid that you want to merge.
	3. Click the [Merge] button to open the mapping configuration page.
	4. In the top section, define the mapping of the Websites and Store Views. This controls which Staging Website is merged to which live Website, and which staging Store View is merged to which live Store View.
	5. Select the Create a backup check box if you want to create a backup of the live site before merging.
	6. In the Select Items to be merged section, select all items that you want to merge from the staging to the live website.
	7. Click Merge Now or specify a date and time and click Schedule Merge.
	Rolling Back Merges

	1. Navigate to System > Content Staging > Backups. This page contains a grid listing all existing backups.
	2. Click on the backup in the grid that you want to roll back. You will be redirected to the Website Backup Information page. This page has three tabs available in the left column:
	3. In the Rollback tab choose the items that you want to restore. You can only select the items which are available.
	4. Click the Rollback button. After the website is restored, you will be redirected to the backup grid.
	Working with a Content Staging Website

	1. Navigate to Catalog > Manage Products and select the desired product from the grid.
	2. In the Websites tab, uncheck the Staging Website that you wish to de-associate from the product. Alternatively, you can change the Choose Store View scope drop-down menu to the desired Staging Website, navigate to the General tab, and select Disabl...
	3. Merge the Staging Website into the production Website by following the steps in the previous section of this chapter.
	1. Navigate to Catalog > Manage Products and click Add Product.
	2. Create the product as usual and assign it only to the Staging Website on the Websites tab. Save the product.
	3. Merge the Staging Website into the production Website by following the steps in the previous section of this chapter.
	39.2 Changing the Favicon

	1. Choose System > Configuration. Be sure to select the desired Configuration Scope.
	2. Select the Design tab on the left. In the HTML Head panel, configure your staging websites:
	3. Click the [✔Save Config] button to save your favicon.
	40 Alternate Media Storage: Content Delivery Network and Database
	40.1 Using a Database as Alternate Media Storage

	1. Navigate to System > Configuration > ADVANCED > Advanced > System > Storage Configuration for Media.
	2. In the Media Storage drop-down menu, select Database. The Select Media Database drop-down menu and the Synchronize button appear. In the drop-down menu, all the databases that are specified in the local.xml file are listed.
	3. In the Select Media Database drop-down menu, select the database you want to use.
	4. Click the Synchronize button to transfer the existing media to the newly selected database.
	Accessing Media from a Database

	1. If web server rewrites are enabled in the Magento system and supported by the server, the PHP script is run only when the requested media is not found in the web server file system.
	2. If web server rewrites are disabled in the Magento system or not supported by the server, the PHP script is run in any case, even when the required media exists in the file system of the web server.
	40.2 CDN as Alternate Media Storage

	1. Navigate to System > Configuration > GENERAL > Web.
	2. Change the value of the Base Media URL and Base JavaScript URL fields in the Unsecure and Secure field groups. Change the value of the Base Skin URL field if you want skins to be stored on the CDN as well.
	Accessing Media from a CDN

	41 Full-Page Caching
	Chapter Quick Reference
	41.1 Implementing Full-Page Caching

	1. Choose System > Configuration. Select the System tab on the left.
	2. In the Full Page Cache panel, you can set the following values:
	o Yes – Enables page caching for all currencies in the store’s allowed currency list (as set in System > Configuration > Currency Setup). Each allowed currency represents another variant of the same page. When enabled, this option greatly increases th...
	o No – Only pages for the default currency will be cached.
	3. Click the [✔Save Config] button to save your settings.
	1. Choose System > Configuration. Select the System tab on the left.
	2. In the Full Page Cache Auto Generation panel, you can set the following values:
	o Yes – Enables this feature. This does not cause the page cache to be auto-generated, however. To start the auto-generation process, enable it here and then go to the Cache Management screen (System > Cache Management) and flush the Magento cache the...
	o No – The page cache will not be generated by a crawler and will be generated only as visitors visit each page on your site.
	3. Click the [✔Save Config] button to save your settings.
	1. To disable and/or re-enable full-page caching, go to System > Cache Management.
	2. Select Page Cache in the Cache Storage Management grid.
	3. Select Enable or Disable from the Action drop-down menu in the top right of the grid.
	1. To refresh the page cache, go to System > Cache Management.
	2. Select Page Cache in the Cache Storage Management grid.
	3. Select Refresh from the Action drop-down menu in the top right of the grid. The page cache will be cleared and will begin to be regenerated as shoppers visit pages on the website.
	Part VIII: Advanced Marketing and Promotion Features
	42 Rich Merchandising Suite (RMS)
	42.1 Targeted Marketing Using Customer Segments

	1. Navigate to Customers > Customer Segments.
	2. After clicking Add Segment configure the segment with the following options:
	o Segment Name - This name is for internal purposes.
	o Description – This description is also for internal purposes, and provides an optional space to enter more detailed information than can be contained in the Segment Name.
	o Assigned to Website - A Customer Segment can only be assigned to one Website, because the conditions can use information that is specific to each Website. To use the same conditions on multiple Websites, you must create multiple Segments.
	o Status - Select Active to enable this Segment. Price Rules and Banners associated to this Segment can be unassociated by selecting Inactive, without having to edit the Price Rule or Banners.
	o Apply to (available in Magento Enterprise Edition v1.12 and later) – Defines the customer types to which the segment is applied. The selection influences the set of conditions available for creating the segment. The option cannot be changed after th...
	o Customer Address - You can define any of the address fields, such as city or country. Any address in a customer’s address book can match these conditions for the customer to match. Or, you can specify that only the default billing or shipping addres...
	o Customer – Miscellaneous customer information can be defined, including Customer Group, name, email, newsletter subscription status, and Store Credit balance. . Available only for customers who are logged in.
	o Shopping Cart – Shopping Cart characteristics can be based on either quantity (line items or total quantity) or monetary amount (grand total, tax, gift card, etc.) currently in the shopping cart.
	o Products - You can define products that are in the shopping cart or wishlist, or that have previously been viewed or ordered. You can also set a date range for when this occurred. The products are defined using product attributes. There is a new set...
	o Sales - Order characteristics for past orders can be defined based on the billing/shipping address in the order, the total or average amount or quantity of the orders, or the total number of orders. You can also set a date range for when this occurr...
	Reporting Based on Customer Segments
	Promotions Based on Customer Segments
	42.2 Creating Dynamic Product Relationships

	1. Choose Catalog > Rule-Based Product Relations.
	2. After clicking Add Rule, configure the Rule-Based Product Relation using the following options:
	o Rule Name – This is for internal purposes.
	o Priority – When multiple rules overlap on a product page or the shopping cart, the priority will determine the sort order of each group of displayed products. For example, if Rule 1 (with priority 1) displays three products, and Rule 2 (with priorit...
	o Status – Select Active for this rule to apply.
	o Apply To – Select whether this rule will apply to a product’s Related Products, Up-sells, or Cross-sells.
	o From/To Date – You can select a date range in which the rule will automatically become enabled and/or disabled.
	o Result Limit – You can set a limit for the number of products that will be displayed. The maximum number is 20, but you can set a smaller limit. For example, if you are creating an Up-sell rule, and there are 40 products which match the conditions i...
	42.3 Automatically Sending Reminder Emails  to Customers

	1. Choose System > Configuration. Select the Promotions tab on the left.
	2. In the Automated Email Reminder Rules panel, you can set the following values:
	3. Click the Save Config button to save your settings
	1. Choose System > Transactional Emails.
	2. Click the [+Add New Template] button
	3. The default email template for reminder emails is called “Rule Reminder.”  Just to get started, select this email template from the Template drop-down menu and click the [✔Load Template] button. The contents of that template will appear in the “Tem...
	4. You will see that you have the following variables available to you in email reminders. These variables are unique to the Rules Reminder email template. The promotion information in these variables is determined by the automated email reminder rule...
	5. See “Customizing Transactional Emails, page 156, for more information on the basics of editing transactional emails. When you’re done editing the reminder email template to fit your brand and needs, give it a name and click the [✔Save Template] but...
	1. Choose Promotions > Automated Email Reminder Rules.
	2. Click the [+Add New Rule] button.
	3. In the Rule Information tab, you can set the following values:
	4. In the Conditions tab, using the standard Magento interface for promotions, you can set the following values:
	5. In the Emails and Labels tab, you can set the following values:
	6. Click the Save button to save your rule.
	43 Gift Cards
	43.1 Configuring Gift Cards

	1. Choose System > Configuration and select the Gift Cards tab in the left column.
	2. These will be the default settings for all Gift Card products, and most can be edited on a per product level. The following settings are available:
	Gift Card Code Pool

	1. Navigate to System > Configuration and select the Gift Card tab in the left column.
	2. In the Gift Card Account General Setting panel, set the following settings:
	3. Click Save Config in the top right of the page to save the settings used for code generation.
	4. Click the Generate button to generate the Code Pool.
	43.2 Gift Card Accounts

	1. Gift Card Accounts can be managed by navigating to Customers > Gift Card Accounts. This page contains a grid listing all existing accounts and gives you the ability to create a new account, or edit existing accounts.
	2. Click the Add Gift Card Account button in the top right of the page.
	3. When creating or editing a Gift Card Account, there are multiple tabs. In the Information tab, the following options are available:
	o Recipient Email - Enter the email address to which an email notification of this Gift Card Account will be sent. This field is optional, and no email will be sent if it is left blank.
	o Recipient Name - Enter the name of the email recipient.
	4. When you have completed these settings, click the Save button in the top right of the page. If you have entered a Recipient Email, click the Save & Send Email button. The Sender and Template of the email that will be sent is different from that of ...
	43.3 Gift Card Products

	1. Choose Catalog > Manage Products.
	2. Click Add Product in the top right of the page.
	3. Select your desired Attribute Set, select Gift Card from Product Type drop-down menu, and click Continue.
	4. Set the Gift Card pricing in the Prices tab. Rather than having a price field like that of a Simple Product, Gift Cards have a price configuration feature similar to that of the tier price feature. You can add additional prices by clicking the Add ...
	5. Set the Gift Card options in the Gift Card Information tab. The following options are available:
	6. Fill in the remaining product information (name, SKU, categories, related products, etc.) as you would for a Simple Product.
	7. Click Save in the top right of the page.
	Purchasing Gift Cards
	Paying with Gift Cards
	Redeeming Gift Cards

	44 Reward Points and Loyalty Programs
	44.1 Configuring Reward Points

	1. Choose System > Configuration and select the Reward Points tab in the left column.
	2. In the Reward Points section, the following options are available:
	o First: The customer will receive reward points only for the first invoiced order placed by the invitee-customer. Even if more than one invitee registered and placed orders, only the amount of the first order will be converted to reward points and gr...
	o Each: The customer will receive reward points for each invoiced order placed by the invitee-customer. Reward points will be given according to the reward point exchange rates set for the required combination of a website and a customer group.
	Reward Exchange Rates

	1. Choose Customers > Reward Exchange Rates. This page contains a grid listing all existing exchange rates.
	2. To create a new exchange rate, click Add New Rate in the top right of the page. If multiple exchange rates apply to the same customer due to an overlap of websites and/or customer groups, exchange rates will use the following priority:
	44.2 Rewarding and Redeeming Reward Points
	Shopping Cart Price Rules
	Customer Balances
	Redeeming Points
	Refunding to Reward Points


	45 Private Sales
	45.1 Invitations

	1. Choose System > Configuration and select the Invitations tab in the left column.
	2. When you have completed these settings, click Save Config in the top right of the page.
	Invitations Frontend
	Invitations Backend
	Invitations Reports

	1. Choose Reports > Invitations.
	2. The following reports are available:
	45.2 Events

	1. Choose System > Configuration, click the Catalog tab in the left column.
	2. In the Catalog Events panel, configure events by setting the following values:
	3. When you have completed these settings, click Save Config in the top right of the page.
	Events Backend
	Events Frontend
	45.3 Category Permissions and Website Restrictions

	46 Gift Registries
	Chapter Quick Reference
	46.1 Administering Gift Registries
	Enabling and Configuring Gift Registries


	1. Choose System> Configuration. Select the Gift Registry tab on the left.
	2. In the General Options panel, enable gift registries by setting the following values:
	o Yes: Enables the gift registry functionality for the selected store view and customers registered for the selected store view are provided with a Gift Registry tab on their account page after the gift registry configuration settings are saved in the...
	o No: Gift registries are not available on the frontend website.
	3. Click the [✔Save Config] button to save your settings.
	1. Choose System > Configuration. Select the Gift Registry tab on the left.
	2. In the Owner Notification panel, configure the emails that will sent to gift registry owners notifying them that their gift registry has been created by setting the following values:
	3. In the Gift Registry Sharing panel, configure the emails that will sent to notify gift registry recipients that a gift registry has been shared with them by setting the following values:
	4. In the Gift Registry Update panel, configure the emails that will sent to notify the gift registry owner of changes to the gift registry by setting the following values:
	5. Click the [✔Save Config] button to save your settings.
	Customizing Gift Registry Types

	1. Choose Customers > Gift Registry. A list of available gift registry types is displayed.
	2. Click the [+Add Gift Registry Type] button to create a new gift registry type, or click on one of the currently available gift registry types to edit it.
	3. In the General Information panel, configure the gift registry type by setting the following values:
	4. Click the Attributes tab
	5. Click the [+Add Attibute] button to create a new attribute, or click on one of the currently available attributes to edit it.
	6. In the Attributes tab, create or modify attributes by setting the following values:
	o Text
	o Select: For “Select” input types, use the [+Add Option] button to create the drop-down menu of options
	o Date
	o Country
	o Event Date: For Event Date input types, the Is Searchable, Is Listed, and Date Format fields appear. The Is Listed field specifies whether there will be a column of values of this attribute in the grid of gift registries in the frontend. The Is Sear...
	o Event Country: For Country or Event Country input types, the Show Region field appears. Indicate whether the list of countries or regions related to the country selected by the customer will be available for selection in the frontend.
	o Event Location
	o Role
	o Event Information: Groups all gift registry attributes that add the information about the gift registry event, its time, place, etc.
	o Gift Registry Properties: Combines all attributes that add information directly about the gift registry.
	o Privacy Settings: Lists the attributes that add information about the gift registry event privacy.
	o Recipients Information: Groups the attributes that provide information about the person who creates a gift registry.
	7. Click the [✔Save] button to save your attribute.
	Adding a Gift Registry Search Widget to the Frontend

	1. To create the widget instance, choose CMS > Widgets.
	2. Click the [+Add New Widget Instance] button.
	3. In the Settings panel, create the widget by setting the following values:
	4. Click the [✔Continue] button.
	5. In the Frontend Properties panel, enter the remainder of the basic widget info:
	6. In the Layout Updates panel, specify the pages and block in which the gift registry search widget should appear by setting the following values:
	7. Click the Widget Options tab.
	8. In the Widget Options panel, specify the ways in which visitors to your website can search for gift registries.
	o Recipient Name Search
	o Recipient Email Search
	o Gift Registry ID Search
	9. Click the [✔Save] button to save your widget.
	10. Refresh the Magento page cache if necessary to see the widget appear on the frontend.
	46.2 Managing Gift Registries

	1. Choose Customers > Manage Customers.
	2. Click on the customer whose gift registry you’d like to view.
	3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer.
	4. Click on the desired gift registry.
	1. Choose Customers > Manage Customers.
	2. Click on the customer whose gift registry you’d like to view.
	3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer.
	4. Click on the desired gift registry.
	5. To add items from the customer’s shopping cart to their gift registry:
	6. In the Shopping Cart Items section, locate the item to add to the gift registry and check the check box.
	7. From the Actions drop-down menu, select “Add to Gift Registry” and click the [Submit] button.
	8. To change quantities in the gift registry:
	9. Enter the new quantity in the Gift Registry Items section and click the [Update Items and Qtys] button
	10. To delete an item, set its quantity to “0” or select “Remove Item” from the Actions drop-down menu for that item.
	1. Choose Customers > Manage Customers.
	2. Click on the customer whose gift registry you’d like to view.
	3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer.
	4. Click on the desired gift registry.
	5. In the Sharing Information area provide the following information:
	o Emails: Enter the email addresses provided by the gift registry owner. Multiple email addresses must be separated with a comma.
	o Send From: Select the store view from which the gift registry recipients will receive an email letter with a URL link to the customer’s gift registry.
	o Message: If desired, type a message that a gift registry recipient will see in the received email letter
	6. Click the [Share Gift Registry] button.
	1. Choose Customers > Manage Customers.
	2. Click on the customer whose gift registry you’d like to view.
	3. Click on the Gift Registry tab. You will see all of the gift registries created by that customer.
	4. Click on the desired gift registry.
	47 Gift Wrapping
	47.1 Enabling and Configuring Gift Options: Global or Website Level

	1. In the Magento top menu, select System > Configuration.
	2. Under SALES in the left column, click Sales. The configuration can be done either at the global or website level, so in the Current Configuration Scope drop-down menu leave the Default Config or select the desired website.
	3. Expand the Gift Options fields set. Here you can set the following options:
	Gift Options Settings at the Product Level
	Tax Classes for Gift Options
	Managing Gift Wrapping Designs in the Admin Panel

	1. Click the Add Gift Wrapping button in the upper-right corner of the Manage Gift Wrapping page. The New Gift Wrapping page opens.
	2. Specify the following:
	3. Click Save in the upper-right corner of the page.
	1. On the Manage Gift Wrapping page in the first column of the grid, select the check box corresponding to this gift wrapping.
	2. Choose Delete in the Actions drop-down menu in the heading of the grid.
	3. Click the Submit button.
	1. Open the gift wrapping option for editing.
	2. Click the Delete button.
	Gift Options: Customer Experience
	Gift Options in Orders Created from the Admin Panel
	Gift Wrapping and Gift Card Refund
	Gift Wrapping and Gift Message Modules

	Part IX: Advanced Customer and Order Management
	48 Custom Order Status Values
	48.1 Managing Order Status Values

	1. Click the Create New Status button in the upper right corner of the Order Statuses page. For a new order status you specify the following:
	2. Click the Save Status button the upper-right corner of the New Order Status page.
	1. Click the Assign Order Status to State button in the upper-right corner of the page. The Assign Order Status to State page opens, where you specify following fields:
	2. To save the assignment, click the Save Status Assignment button in the upper-right corner of the Assign Order Status to State page.
	49 Editing Orders in the Admin Panel
	1. In the Magento top menu, select Sales > Orders.
	2. Open the desired order for editing, and click the Edit link in the Billing Address section or the Shipping Address section (see Figure 302). A page for editing the address opens.
	3. Make the necessary changes and click the Save Order Address button in the upper right corner of the page.
	50 Assisted Shopping
	1. Choose Customers > Manage Customers.
	2. Select a customer to edit from the list and then select the Shopping Cart tab on the left.
	3. Click the [Manage Shopping Cart] to go into the Assisted Shopping mode.
	4. You will be able to see the customer’s shopping cart, apply a coupon code, as well as be able to see: all products, customer’s wishlist, customer’s comparison list, recently compared products, recently viewed products, and customer’s last ordered p...
	5. The customer can then continue browsing, checkout unassisted, or the customer service representative can create the order by clicking the [✔Create Order] button and proceeding to place the order for the customer.
	51 Order Archiving
	1. Choose System > Configuration. Select the Sales tab on the left.
	2. In the Orders, Invoices, Shipments, Credit Memos Archiving panel, you can set the following values:
	52 Customer and Address Attributes
	Chapter Quick Reference

	1. Choose Customers > Attributes > Manage Customer Attributes. On the resulting Customer Attributes grid you can see all of the system and custom attributes. You cannot edit or delete System Attributes.
	2. Click the [+Add New Attribute] button. The resulting page is very similar to the Product Attribute editor, which you are probably already familiar with.
	3. On the Properties tab, in the Attribute Properties panel, enter the appropriate information for the following fields to create your attribute:
	o Text Field: Single line text field. Max and min size can be specified later.
	o Text Area: Multi-line text input area. Max and min size can be specified later.
	o Multiple Line: The number of input lines to be available for the customer in the frontend (cannot exceed 20 lines).
	o Date: The system validates the customer’s date attribute input.
	o Dropdown: Dropdown list of options. When selected, the store administrator needs to create a number of attribute options on the Manage Label / Options tab.
	o Multiple Select: Multi-selectable list of options. When selected, the store administrator needs to create a number of attribute options on the Manage Label / Options tab.
	o Yes/No: Binary/yes-no input field.
	o File (attachment) : Allows files to be uploaded by the customer.
	o Image File: Allows images to be uploaded by the customer.
	o None
	o Strip HTML Tags
	o Escape HTML Entities
	4. On the Properties tab, in the Frontend Properties panel, enter the appropriate information for the following fields to create your attribute:
	o Customer Checkout Register
	o Customer Registration
	o Customer Account Edit
	o Admin Checkout
	5. On the Manage Label/Options tab, set label to be displayed to the customer in the frontend. Specify the value either for a specific store view or a default one for all store views.  If the attribute input type selected on the Properties tab is eith...
	6. Click the [✔Save Attribute] button to save your attribute.
	1. Choose System > Configuration. Select the Customer Configuration tab on the left.
	2. In the Address Template panel, you can edit the following address templates:
	o depend code: For processing of inner elements
	o if code: An attribute is defined
	o var code: The code attribute is printed
	o For Text, Text One Line, HTML, and PDF address templates: {{depend address attribute code}} a space, a character, or a User Interface label {{/depend}}; {{if address attribute code}}{{var address attribute code}} a space, a character, or a User Inte...
	o For JavaScript address template: #{address attribute code} or User Interface label #{address attribute code}
	53 Persistent Shopping Cart
	53.1 Persistent Shopping Cart – General Concept
	53.2 Persistent Shopping Cart – a Quick View
	53.3 Enabling and Configuring the Persistent Shopping Cart

	1. Select System, and click Configuration.
	2. In the Current Configuration Scope drop-down menu in the upper left corner of the page, select the desired website.
	3. Under CUSTOMERS in the left column click Persistent Shopping Cart. The following options are available:
	53.4 Persistent Shopping Cart Implementation
	Cookie Application Workflow
	Cross-Browser Approach
	Persistent Shopping Cart in Magento Community Edition


	54 Multiple Wishlists
	54.1 General Concept
	54.2 Configuring Multiple Wishlists

	1. Log in to the Magento Admin panel.
	2. Navigate to System > Configuration > CUSTOMERS > Wishlist.
	3. In the Current Configuration Scope drop-down menu, select the desired store view.
	4. Expand the General Options field set.
	5. If Enabled is set to No, switch it to Yes. Doing so will enable the regular Wishlist functionality and make the Multiple Wishlists-related settings appear.
	6. In the Enable Multiple Wishlists field, select Yes. The Number of Multiple Wishlists field appears.
	7. In the Number of Multiple Wishlists field, specify the maximum number of Wishlists each customer will be allowed to create. The specified number should exceed 1. The default value is 5.
	8. To save the settings click Save Config.
	54.3 Customer Experience with Multiple Wishlists
	Managing Multiple Wishlists
	Adding a Product to One of the Multiple Wishlists
	Searching for a Wishlist

	54.4 Managing Multiple Wishlists in the Backend
	Adding a Wishlist Search Widget


	1. In the Admin Panel, navigate to CMS > Widgets.
	2. Click the Add New Widget Instance button. The New Widget Instance page opens.
	3. In the Type drop-down field, select Wishlist Search. In the Design Package/Theme field, select the desired design theme and click Continue.
	4. On the Widget Options tab in the Quick Search Form Types field, choose the type of the quick search form which will be used. The following options are available:
	5. Configure other widget properties.
	6. Save the widget by clicking Save or Save and Continue. The widget becomes available in the frontend.
	Multiple Wishlists Reports

	55 Order by SKU
	55.1 Order by SKU: Quick Reference
	55.2 Configuring the Order by SKU Functionality

	1. Log in to the Magento Admin Panel
	2. Navigate to CMS > Widgets.
	3. Click the Add New Widget Instance button.
	4. In the Type field select Order by SKU and configure other widget options. The Display a Link to Loading a Spreadsheet setting determines whether the widget will contain a link.
	5. To save the widget click Save or Save and Continued Edit.
	1. Log in to the Magento Admin Panel
	2. Navigate to System > Configuration > SALES > Sales
	3. In the Current Configuration Scope select your website.
	4. Expand the Order by SKU Settings field set.
	5. In the Enable Order by SKU in my Account on Frontend select one of the following:
	 Yes, for Everyone – The Order by SKU tab will appear on the My Account page for all logged in customers.
	 Yes, for Specified Customer Groups - The field for specifying Customer Group(s) appears once you select the option. The Order by SKU tab will be displayed on the My Account page for those logged in customers who belong to the Customer Group(s) you s...
	 No – The Order by SKU tab on the My Account page will not appear.
	6. To save the configuration click Save Config.
	55.3  Ordering by SKU in the Backend

	1. Click Add Products by SKU button or expand the Add to Shopping Cart by SKU field set.
	2. Specify SKUs and quantities, or load a spreadsheet, or both. Only the .csv file format is supported. See “Loading a Spreadsheet with SKUs: Requirements,” page 442, for details about file restrictions.
	3. Choose to add products to cart/order.
	4. If some products cannot be added on any reason (out of stock, require configuring, or some other reason), then they are listed in a separate grid under the “Products requiring attention” heading. See “Ordering by SKU: Exceptions Handling in the Bac...
	5. Perform product configurations and update quantities in the “Products requiring attention” grid if necessary, and add products to cart/order.
	6. If product addition fails again, the products still will be listed in the grid. You can ignore the “Products requiring attention” grid and proceed with creating order or managing the shopping cart. If you delete all products, the grid disappears.
	Ordering by SKU: Exceptions Handling in the Backend
	55.4 Ordering by SKU: Customer Experience
	Ordering by SKU: Exceptions Handling in the Frontend

	55.5 Loading a Spreadsheet with SKUs: Requirements

	Part X: Magento Mobile
	56 XML Connect Module: Managing Mobile Applications
	1. Create a mobile application in the Admin Panel.
	2. Subscribe to one of the Magento support plans and receive the activation key.
	3. Submit your application to Magento.
	4. Magento adds your application to the store, like App Store or Google Play, and supports it for the period corresponding to your subscription plan.
	56.1 Creating a New Mobile Application

	1. Click the Add App button in the upper-right corner of the Manage Apps page. The New App page opens (see Figure 313).
	2. Select the targeted device type in the Device Type drop-down menu. The available options are iPad, iPhone, and Android. Click the Continue button.
	3. At this step, several tabs with settings are available (see Figure 314).
	o App Name: Specify the name of the application. It is an internal name and it is not displayed to the application users.
	o Store View: Select the store view the application is created for.
	o Catalog Only App: Decide whether your application shows only the catalog or provides the options to buy products or add them to the Wishlist.
	o In the Images field set you specify your logo, banners, and background image. Up to five banners can be loaded; they will be rotating. For each banner you can choose the action to be performed on banner click. To set an action for a banner, click th...
	You can choose to redirect customers to product page, CMS page, or category page. For product and category pages, you will need to type the name of the product or category. A CMS page can be selected from a list. After you add the images, you can save...
	o In the Color Themes field set you can customize the color schemes.
	o In the Tabs field set you can manage the tabs of your application.
	o In the Label field, specify the label for the application page. The label is visible for application users.
	o In the Get Content from CMS Page list, select from which CMS page the content is taken. The list contains default CMS pages and custom CMS pages created for the selected store view.
	o On the Payment Methods tab, you can configure which payment methods will be available for the application users. The following fields are available:
	o Enable Standard Checkout: If you select Yes all payment methods that are supported by Magento Enterprise Edition, will be available.
	o Activate PayPal MECL: In this field you can activate the PayPal mobile embedded payment method. You can choose to use MECL (Mobile Express Checkout Library) alongside standard checkout, or use it as your only checkout method for Magento mobile. PayP...
	o Enable Flurry Analytics - If you select Yes, the Flurry API Code field appears.
	o Flurry API Code - Specify your Flurry API code. You can request it from Magento, after submitting your application.
	4. To save the newly created application, click the Save or Save and Continue Edit button in upper-right corner of the page.
	56.2 Subscribing to a Magento Support Plan and Submitting the Mobile Application

	1. Click the necessary application in the list of applications on the Manage Apps page. The application opens for editing.
	2. Click the Save and Submit App button in the upper-right corner of the page. In the Submit App page, specify the following:
	o In the Title field, specify the name of your application. It is shown to the customers, so we recommend choosing a 10-12 character recognizable title.
	o In the Description field, specify the description of your store. It appears in the App Store.
	o In the Contact Email field, specify the email address to contact for this application and submission issues.
	o The Price field is currently unavailable for editing, as only free applications are currently allowed in Magento.
	o In the Country field select the countries where the application will be available.
	o In the Copyright field enter your copyright text. It appears in the information section of your application.
	o In the Keywords fields enter a comma-separated list of  keywords for your application. The field may contain 100 characters maximum. These keywords are matched to users' searches in the application stores.
	o In the Large iTunes Icon field (or Large Android Market Logo for Android applications), browse for the image that will appear as a large icon of your image in the applications store. You do not need to gradient or soften edges; this is done automati...
	o In the Loader Splash Screen field, browse for the image that will appear first on the screen, while your application is loading. Required size: 320px by 460px. For iPhone applications you can specify a separate image for iPhone retina screens in the...
	o In the Custom App Icon field, browse for the image that will be used as your application icon, after the user installation of your application. Recommended size: 57px by 57px at 72 dpi. For iPhone applications you can specify a separate image for iP...
	o In the Copyright Page Logo field, browse for your logo image, which is displayed on the copyright page of your application. Recommended size: 100px by 100px.  For iPhone applications you can specify a separate image for iPhone retina screens in the ...
	3. Click the Submit App button in upper-right corner of the page.
	56.3 Push Notifications and AirMail Messages to the Application Users

	1. Create a template for the message.
	2. Add the message to the queue.
	Creating a Message Template

	1. Click the Add New Template button in the upper-right corner of the page. The New Template page opens.
	2. The following fields are available:
	3. Click the Save button in the upper-right corner of the page to save the template.
	Message Queue Management

	1. Select Mobile > Message Templates.
	2. For the desired message template in the Action column, select Queue Message. The New AirMail Message Queue page opens.
	3. Specify the following:
	o In the Push Title field, you can edit the text of the push notification message, maximum 140 characters. If you intend to send a push notification, and have selected Push message in the Message Type drop-down menu, proceed to the step 4.
	o In the Message Title field, you can edit the title of the AirMail message, maximum 255 characters.
	o In the Template Content field, you can make changes in your message template. For more information about editing the template, see the last step of the procedure in “Creating a Message Template,” page 449.
	4. Click the Queue Message button in the upper-right to add the message to the queue. You are redirected to the AirMail Messages Queue page, the message is added to list with In Queue status.
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	o PDO_MySQL
	o simplexml
	o mcrypt
	o hash
	o GD
	o DOM
	o iconv
	o curl
	o SOAP (if Webservices API is to be used)
	o Safe_mode off
	o Memory_limit recommended 512MB (minimum 256MB)
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	D Magento Payment Bridge
	Enabling Payment Bridge

	1. Log in to the Magento admin panel.
	2. Navigate to System > Configuration.
	3. In the Current Configuration Scope field in the upper-left corner of the page, leave Default Config or select your website. It is recommended that you enable and configure Payment Bridge on the global level if your business logic allows.
	4. In the left column under SALES, click Payment Methods and expand the Payment Bridge field set.
	5. Set the Enabled field to Yes.
	6. In the Merchant Code field, enter the merchant ID specified by the Magento Payment Bridge administrator during the merchant account creation.
	7. The merchant key (either entered by the Magento Payment Bridge administrator, or automatically generated by the payment application during the creation of a merchant account) must be specified in the Merchant Key field. The merchant key is a unique...
	8. In the Gateway Basic URL field, specify the URL to connect to the Payment Bridge payment application.
	9. The data transfer key, which is generated during the merchant account creation in Magento Payment Bridge, must be specified in the Data Transfer Key field. The data transfer key encrypts any data that is transferred between the merchant and the Pay...
	10. The Magento Unique Identifier field (present only if Current Configuration Scope is set to Default Config) is used if you have several instances of Magento using the same Payment Bridge merchant account. In this field you can enter the identifier ...
	11. In the Debug field, specify whether data messages that are sent to the payment system and received from it are written into the system log file. See Figure 316.
	12. To save your changes, click Save Config, and proceed to configure payment methods that will work with the Payment Bridge payment application.
	Payment Gateways Supported by Magento Payment Bridge
	Payment Services Supported by Magento Payment Bridge
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	Functionality Overview: Payment Methods Working via Payment Bridge
	Configuring Payments Methods to Use Payment Bridge
	Payment Methods Working Only with Payment Bridge


	1. Navigate to System > Configuration.
	2. In the Current Configuration Scope field in the upper-left corner of the page, leave Default Config or select the desired website.
	3. In the left column under SALES, click Payment Methods and expand the Braintree field set.
	4. In the Enabled field, select Yes.
	5. In the Title field, specify the name of the payment method that will be displayed to the customer in the Payment Information section of the one-page checkout. This parameter can be set up for each store view.
	6. In the Payment Action field, choose the way payments will be authorized in the Braintree payment system and the entities that will be created after the successful transaction in the backend as a result of the payment procedure. The following option...
	7. In the Enable Vault field, choose whether the Vault functionality will be enabled. This functionality enables the secure storage of customers’ sensitive payment information on the Braintree side. After a credit card profile is saved, Magento/Paymen...
	8. In the Sort Order field, decide what will be the position of the method in the list of available payment methods displayed to customers during checkout.
	9. To save the configuration, click Save Config.
	Payment Methods for which Payment Bridge Usage Is Optional

	1. Navigate to System > Configuration.
	2. In the Current Configuration Scope field in the upper-left corner of the page, leave Default Config or select the desired website.
	3. In the left column under SALES, click Payment Methods and expand the Authorize.Net field set.
	4. In the Enabled field, select Yes.
	5. In the Use via Payment Bridge field, select Yes.
	6. Configure other options as necessary.
	7. To save your configuration, click Save Config.
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	F Shipping Methods and Package Types Available in Magento
	G VAT ID Validation
	VAT ID Validation Quick Reference
	Configuring VAT ID Validation

	1. Creating VAT-related customer groups.
	2. Creating tax classes, tax rates and tax rules.
	3. Configuring the VAT ID Validation settings.
	4. Setting your VAT ID and location country.
	5. Modifying the list of EU member countries used by Magento. This step is only necessary if the EU gets new members or some countries leave the EU.
	Creating the VAT-Related Customer Groups
	Configuring the VAT-Related Tax Rules
	Enabling and Configuring the VAT ID Validation Functionality

	1. Log in to the Magento Admin Panel.
	2. Navigate to System > Configuration > CUSTOMERS > Customer Configuration.
	3. In the Current Configuration Scope field in the upper-left corner leave Default Config or select the desired store view.
	4. Expand the Create New Account Options field set.
	5. In the Enable Automatic Assignment to Customer Group field, select Yes. The following fields appear:
	6. To save the settings, click Save Config.
	Configuring Additional Settings for the VAT ID Validation Feature

	1. Navigate to System > Configuration > GENERAL > General.
	2. In the Current Configuration Scope field, select the desired store view.
	3. Expand the Store Information field set.
	4. In the Country field, select your country.
	5. In the VAT Number field, enter your VAT number. You can validate the entered value by clicking the Validate VAT Number button. The result of validation will be displayed immediately.
	6. To save the settings, click Save Config.
	1. Navigate to System > Configuration > GENERAL > General.
	2. In the Current Configuration Scope field, select the desired store view.
	3. Expand the Countries Options field set.
	4. In the European Union Countries field make the necessary changes in the list of countries that are EU members.
	5. To save the changes, click Save Config.
	VAT ID Validation Implementation Details: Customer Experience
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