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1.  General Notes

1.1  Safety Instruction

All regulations concerning laser safety must be followed and all technical data apply only if the 
device is operated according to its purpose.
If the device is connected to a customized power supply, it must be earthed correctly using an 
earthed power socket. Absence of an earthed connection may lead to an electric shock or se-
vere injuries!
The device must only be operated with the casing closed!
The polarimeter must only be operated with the shielded USB cable shipped with the device!

Consider all laser safety instructions recommended by the laser manufacturer! 
Adhere strictly to local laser savety requirements (e.g., BGI832, BGV B2) !

1.2  Parts List

The Schäfter+Kirchhoff polarimeter is shipped with the following components:
1.  Polarization Analyzer SK010PA-xx
2.  Fiber adapter FC-APC
3.  USB cable
4.  CD-ROM with installation software "SKPolarization Analyzer"
5.  This handbook
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2.  Introduction

2.1  Mode of Operation

The Polarization Analyzer SK010PA from Schäfter+Kirchhoff is an integrated polarization analy-
zer with a USB interface for control by a computer.
This polarimeter was developed mainly for the investigation of the polarization properties of 
fiber-coupled radiation and a large variety of adapters are available for attaching many different 
fiber connectors. The polarimeter can also be integrated into a microbench system or even used 
to analyse a light beam in free space directly. An integrated auto-log function enables the recor-
ding of polarization measurements over extended periods of time.
The extinction measurement of fiber-coupled radiation is provided as a dedicated application 
for the correct alignment of the polarization axis of polarization-maintaining fibers. An intuitive 
display directs the user to the correct fiber alignment.
The measurement principle of the polarimeter SK010PA is based on a rotating quarter-wave pla-
te in front of a polarization-sensitive detector. The raw measurements are used to calculate the 
normalized Stokes parameters, which are displayed on a Poincaré sphere.

2.2  System Requirements

For operating the polarimeter the following requirements are demanded to the PC:
A 	Connections
	 For operating the polarimeter, a free USB port (2.0 or 1.1) and operation system Windows 

2000 or better has to be available (there are external driver for former versions of Windows, 
but Schäfter+Kirchhoff discourages from its use).

B 	Graphics board
	 For the 3D display of the Poincaré sphere and the measurement data, DirectX9 is required.

Without hardware assistance by DirectX9, the display is rendered by software. However this 
yields to losses in speed and quality of the display.

C 	Processor
	 700 MHz minimum, for maximum measuring speed a processor with at least 1.5 GHz is re-

commended.
D 	Operating system
	 A current Windows operating system from Microsoft is required, which supports graphics via 

DirectX9 and allows communication via USB. Schäfter+Kirchhoff recommends the use of the 
operating system WindowsXP. 
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3.  Quick Start-Up

3.1  Software Installation

After inserting the CD 'SK010PA Polarization Analyzer' the application 'SETUP.EXE' is started 
automatically. The user is directed through the installation process by dialog boxes, which allow 
for selection of the program folder, where the software shall be saved. Please follow the instruc-
tions of the installation software.
After a successful setup, the program file 'SKPolarization Analyzer' including a program group 
and a link in the system start menu are installed. The program is started by selecting 'SK' -> 
'SKPolarization Analyzer' in the system start menu.

3.2  Installation of Drivers

3.2.1  USB Driver
When the polarimeter is connected for the first time, the operating system of your computer de-
notes that it has found new hardware. The install shield for a USB driver is started automatically. 
Direct the search for the driver to the CD-Rom drive of your computer. The driver will be installed 
automatically.

3.2.2  DirectX
For the 3D display of the Poincaré sphere and of the measurement data, DirectX9 is demanded. 
You can find the installation software for DirectX9 in the newly installed 'SK' program group. 

3.3  Attaching a Fiber Cable

Slopingly attach the connector's ferrule to the fiber adapter in order to avoid damage of its end 
face, see Figure 2 left. Plug the connector considering its key. Press the connector's key to the 
right hand side of the adapter's notch. Fasten the box nut hand-screwed only, see Figure 2 right.

   

Figure 2:  Slopingly attach the connector's ferrule to the fiber adapter in order to avoid damage fits end face. Plug the 
connector considering its key. Press the connector's key to the right hand side of the adapter's notch. Fasten the box nut 

handscrewed only.
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3.4  Using Software SKPolarization Analyzer

3.4.1  Program Start and Wavelength Definition
Start the program by use of the start menu 'SK' -> 'SKPolarization Analyzer'. Automatically you 
will be asked for the wavelength of your laser source, see Figure 3.

Figure 3:  Input dialog for the wavelength at start up of the program.

3.4.2  Measurement Parameters
On startup the polarimeter starts measuring automatically. But before the first measurement is 
executed, the measurement settings have to be checked and changed if necessary. The relevant 
parameter dialog is opened via the menu 'Edit' -> 'Edit Parameters' or by pressing key F4.
For more information about parameter settings see subsection 5.4.1.

3.4.3  Running a Measurement
You can start a continuous measurement manually to display the actual state of polarization of 
your device under test by pressing button 'Run'  or by pressing key F2.
When the polarimeter has been started, measurements are displayed continuously - depending 
on operation mode and on actual settings. The data displayed are ellipticity η and azimuth angle 
φ, and they are illustrated as points on the Poincaré sphere (Figure 4) and as a polarization ellipse.

Figure 4:  Display of the SKPolarization Analyzer program directly after start up

The measurement is stopped by pressing the button 'Stop'  or by key F3. For more information 
on continuous measurement see subsection5.4.2.
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3.4.4  Measurement of Extinction Ratio
In case of measuring the extinction ratio of polarization maintaining fibers (PER measurement 
mode), the number of measuring points have to be defined in the parameter dialog. A detailled 
description of the measurement method can be found in section 5.5.
Before starting the PER measurement, it should be checked, that the signal amplitude (as to be 
seen in window 'Detector Signal', see Figure 5) is not overloaded even at different states of po-
larization. For this stress the fiber and observe the waveform, see subsection 5.5.3.
After these pre-arrangements press button 'PER-Measurement'  or key F11 to start the PER 
measurement. 

Figure 5:  Result of an PER measurement

Now the number of measurement points defined in the parameter dialog is recorded, while you 
have to stress the fiber thermally or mechanically. By stressing the fiber, the individual measure-
ment points should cover a whole circle on the Poincaré sphere, see Figure 5.
After a PER measurement is completed the extinction ratio of the fiber cable attached is calcu-
lated automatically. For the definition of the different values in the result window see section 5.5.
You can terminate the acquisition and directly calculate the extinction ratio any time by pressing 
the button 'Stop'  or by key F3.



M
an

ua
l P

ol
ar

im
et

er
 4

6_
IN

D
6.

in
d

d
 •

 P
ag

e 
9

Kieler Straße 212, D-22525 Hamburg • Phone (+49) 40 85 39 97-0 • Fax (+49) 40 85 39 97-79 • eMail: info@SuKHamburg.de • Web: www.SuKHamburg.de

9

2012 E  

4.  Description of the Polarization Analyzer SK010PA
Different optical connections, possible configurations, connectors, and controls of the polariza-
tion analyzer SK010PA are described in this section.

4.1  Control Elements

1. 	Green LED: 
Continuous light when running.

red LED
green LED

Attenuator 
(iris diaphragm)

Adapter for Mi-
crobench sys-
tem

Adapter for 
fiber connectors

Figure 6:  Control elements on front of polarimeter SK010PA

2. 	Red LED: 
Continuous light:	Power ON 
Off:			  Power OFF 

3. 	Iris diaphragm: 
Mechanical adjustment of optical power. 
left state:  	  open 
right state:	  close

	 The diaphragm can be closed completely. 
Maximum aperture is 4 mm. 

4. 	Adapter for fiber connector:
	 When the polarimeter is not in use, please close the connector with the enclosed cap.
	 Note: The Polarization Analyzer is shipped with mounted fiber adapter. The reference of the 

azimuth angle is calibrated to the microbench.  

5. Adapter for micro bench components: Four rods with Ø 6 mm can be attached, see subsec-
tion 4.2.4.

4.2  Optical Connection Alternatives

4.2.1  Adapters for Fiber Connectors
Fiber cables with connectors can be attached directly to the polarimeter. Adapters are available 
for fiber connectors of type  FC-APC (standard), FC-PC, DIN Avio, and ST.
By default the fiber adapters do not contain any optics, making them unsensitive to different 
wavelengths and polarization changing property of some lenses. But only the center part of the 
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radiation cone reaches the sensor.
If used with very low power input a fiber adapter with a collimating lens should be used to colli-
mate the diverging radiation from the fiber to a collimated beam. By default Its focal length is 6.2 
mm, yielding with a fiber NA = 0.11 to a beam with diameter 1 mm.
Special adapters, e.g. for single ferrules, are available on request.

4.2.2  Attaching a Fiber Cable
Slopingly attach the connector's ferrule to the fiber adapter in order to avoid damage of its end 
face, see Figure 7 left. Plug the connector considering its key. Press the connector's key to the 
right hand side of the adapter's notch. Fasten the box nut hand-screwed only, see Figure 7 right.

   

Figure 7:  Slopingly attach the connector's ferrule to the fiber adapter in order to avoid damage of its end face. Plug the 
connector considering its key. Press the connector's key to the right hand side of the adapter's notch. Fasten the box nut 

hand-screwed only.

4.2.3  Changing the Fiber Adapters
You can change the fiber adapter by loosen the Allen hex screw on the right hand side of the 
adapter, see Figure 8 . When attaching the new adapter take account for the aligning pin.

    

Figure 8:  Changing of the fiber adapter. Use Allen hex key WS 1.5 mm.
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4.2.4  Free Space Beams
The state of polarization of an optical beam can be analyzed. The polarimeter can be attached to 
the micro bench system. The connecting plate holds 4 rods Ø 6 mm, see Figure 9.
Remove the fi ber adapter and attach four rods Ø 6 mm. Each rod is fi xed with 2 pin screws (Allan 
hex key WS 1.5 mm).
Schäfter+Kichhoff offers mounting plates for optical components with different outer diameters.

Figure 9:  Polarization Analyzer SK010PA with adaptation to the micro bench system (left) and with attached fiber collimator 
60FC-Q...-4-M100-13 with integrated quarter-wave plate from Schäfter+Kichhoff, on the right.
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5.  Operating Instruction for the Software SKPolarization 
Analyzer

In this section detailed information for using the polarimeter SK010PA and its software 
SKPolarization Analyzer is given.

5.1  Requirements

1. The software SKPolarization Analyzer has to be installed correctly, see section 3.1. When the 
setup CD has been used there is no need for additional software installation.

2. The polarimeter has to be connected (glowing red LED).

5.2  Running the Software

The program is started via start menu by selecting SKPolarization Analyzer in the start menu 
folder selected during software installation (standard is 'Start' -> 'Program Files' -> 'SK' -> 'SK-
Polarization Analyzer').
Alternatively, you can start the SKPolarization Analyzer.exe directly via Windows-Explorer.

5.3  User Interface

5.3.1  Description of  the different windows
The program SKPolarization Analyzer is a multi-window application. Hence, the different de-
scriptions of the measured state of polarization SOP are displayed in different windows.
As standard, there are four different descriptions for the measured SOP, see Figure 10:
-  Numerical Values
-  Poincaré Sphere
-  Detector Signal
-  Polarization Ellipse
Each window can be closed separately and re-opened via the 'View' menu.
The size of each window can be rescaled individually. By selecting 'Window' -> 'Reset Window 
Positions', sizes and positions of all windows can be rescaled to a default view.
As long as the polarization analyzer is runninge, the program can be used in its entirety. So you 
can perform an extinction measurement while only displaying its numerical value.
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Measured Values

Detector 
Signal

Status Bar

Poincaré Sphere

Tool Bar

Polarization 
Ellipse

Figure 10:  User interface of SKPolarization Analyzer

5.3.2  Window 'Numerical Values'
The continuously measured state of polarization SOP is displayed with the following parameters, 
see Figure 11.

PER  Extinction [dB] 
The extinction ratio PER is the ratio of the powers in the two (linear) principal states of pola-
rization in logarithmic scale.

lin. PER  Extinction [dB] 
The extinction lin. PER is the ratio of linear polarized light to the total amount of light measu-
red in logartihmic scale. For depolarized sources the lin. PER will be lower then PER.

j 	Azimuth Angle [°] 
The azimuth angle j describes the angle of the main polarization axis. In the ellipse view this 
value is the angle of the semi-major axis in [°]. On the Poincaré sphere, this value is equiva-
lent to half the longitude angle or azimuth (in [°]).The azimuth angle is a relative value given 
with respect to a reference value. When the polarimeter is shipped, the reference value is set 
to zero with respect to the micro bench adapter plate.

rel. j relative Azimuth Angle [°] 
The user can change the reference value of the azimuth by software, see subsection 5.4.3. 
The factory setting is then discarded. After redefining the reference, the azimuth angle j is 
displayed with a prefixed 'rel'. To switch to the standard reference value, select 'Edit' -> 'Set 
0-Phase (default)' or press Alt+F4.
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Figure 11:  Numerical display of the continuously measured state of polarization

DOP Degree Of Polarization 
The DOP describes the polarized fraction of radiation. This value ranges between 100 % 
(totally polarized) and 0 % (totally depolarized). Almost all lasers have DOPs close to 100 %. 
Since the Poincaré sphere is normalized to the DOP, its radius is always 1 (100%) and does 
not account for the unpolarized fraction of the radiation.

Intensity [0 ... 100] 
The intensity displayed is the intensity of the incoming radiation. It is not measured directly 
but calculated from the detector signal as the Stokes parameter S0, see appendix D.4.

The relation of these parameters with the Stokes parameter and its depiction on the Poincaré 
sphere is described in appendix D.2.
For interpretation of the values acquired during PER-Measurement, see subsection 5.5.2.

5.3.3  Window 'Poincaré Sphere'
For an interpretation of the Poincaré sphere see appendix D.3.
Navigation in the window with the Poincaré sphere can be done completely by mouse. As stan-
dard setting the plot can be rotated by clicking on the sphere and moving the pointer.
Using the mouse wheel changes zoom factor. It can also be altered by pressing and holding key 
'z' while performing a horizontal move with mouse.
Additionally, by selecting 'View' -> '3D-View Settings' the zoom factor can be adjusted with a 
scroll bar.
In the same dialog the angle of view of the sphere can be adjusted, in order to increase the three-
dimensional effect for the measurement points on the surface of the Poincaré sphere. If the angle 
of view is minimum, the sphere is projected to the two-dimensional screen without any vanishing 
point. This is the best setting for measuring angles on the sphere.
When the angle of view is increased, the sphere is projected to the screen through vanishing 
point projection. Lines and measurement points on the back side of the sphere are scaled down. 
This is suitable for an intuitive three-dimensional effect.
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5.3.4  Window 'Detector Signal'
The detector signal displayed is the optical power measured by the photo detector in the device. 
Stokes parameter and displayed parameters are calculated from this signal. With help of this plot 
you can control the modulation amplitude of the signal and therefore avoid signal clipping, see 
Figure 12. 

Figure 12:  Detector Signal of a linear SOP.

5.3.5  Window 'Polarization Ellipse'
The polarization ellipse is a two-dimensional description for the polarization of light. The two 
radii of the ellipse, a and b, represent the power fractions projected to the two (linear) principle 
states of polarization. The phase information is neglected. The angle of the semi-major axis a is 
the azimuth angle j (see appendix D.2).
You can toggle between a linear display and a logarithmic by selecting 'View' -> 'Logarithmic 
Ellipse Scale' or by pressing Alt + 'L'.
The squared ratio of the two radii a/b in logarithmic scale is the extinction E. This value is repre-
sented additionally by a bar plot ranging from 0 to 50.0 dB.

The color of the bar depends on the actual extinction and is graduated as:
Red		  =	 bad polarization extinction (< 23 dB)
Dark green	 =	 good polarization extinction (23 ...30 dB)
Light green	 =	 very good polarization extinction (> 30 dB)

The polarization ellipse is a suitable help for coupling radiation with low coherence into a polari-
zation maintaining fiber.
You can activate the polarization ellipse by shortcut Alt + 'E'.

Figure 13:  Display of the continuously measured state of polarization by an elliptical plot.
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5.4  Measuring the State of Polarization (SOP)

5.4.1  Initial Settings
You can change or check the settings for all parameters by selecting 'Edit' -> 'Edit Parameters' 
or by key F4. The following parameters have to be checked and, if necessary, changed before 
measuring:
-	 Number of averaging cycles per measurement point (and therefore measuring time).
-	 Number of sampling points in the measured signal for the FFT analysis. 
- 	 Actual laser wavelength
- 	 Number of points for continuous measurement
The number of measurement points for a PER measurement have to be defined additionally, see 
subsection 5.5.3.
All settings are saved when the program is closed and are loaded automatically after restart.

Figure 14:  Dialog for editing measurement and program parameters

5.4.2  Start Continuous Measurement: Run Mode
After defining the initial settings, the polarimeter could be started. For a continuous measure-
ment of the actual SOP click  in the toolbar or press key F2.
Having a successful communication with the polarimeter, the software displays 'USB' in its 
status bar. Otherwise the warning is displayed, that no polarimeter has been found. In this case 
check again if polarimeter is powered on and connected properly to your computer.
When polarimeter has been found, the measured state of polarization is displayed continuously 
- depending on operation mode and on actual settings.  
Calibrating the azimuth reference is optional, see subsection 5.4.3.
You can abort the run mode by clicking  or by pressing key F3.
The polarimeter SK010PA measures states of polarization continuously. The time elapsed bet-
ween individual measurements is given by the rotary speed of 15 rps and yields to 30 measure-
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ments per second. The response time depends on the number of averaging.
Measured values are displayed as points on the Poincaré sphere and as numerical values. An 
elliptical plot is optional, see subsection 5.6.2.
To save or record the individual measurements, there are a log functions, see subsection 5.4.4 
and 5.4.5.

5.4.3  Calibration of Zero Azimuth
The azimuth angle is a relative value given with respect to a reference value. When shipped, the 
reference value of the polarimeter is set to zero with respect to the micro bench adapter plate. 
Normally, there is no need for changing the reference.
However, you can change the reference value by software.
You have to connect a laser source with a defined linear state of polarization (free beam or cou-
pled to a polarization maintaining fiber). The semi-major axis of its polarization ellipse will be the 
new azimuth angle j = 0 °.
Start the polarimeter. The reference can then be changed by clicking symbol  in the toolbar, 
by pressing F6, or by selecting 'Edit' -> 'Calibrate Azimuth'. You have to confirm the change of 
the  reference value by pressing 'OK'. The new reference is activated automatically. The actual 
value of the azimuth of your reference source now should be j = 0 °. You can abort calibrating 
the azimuth angle by pressing 'Cancel'. In this case the previous reference value is retained.
After calibrating the azimuth angle, the polarimeter is back in continuous measurement mode.
During measurement you can toggle between the user-defined reference (relative) and the facto-
ry setting (default) by selecting menu 'Edit' -> 'Set Azimuth (relative)' and 'Edit' -> 'Set Azimuth 
(default)', respectively.
The relative reference angle is saved when the program is closed and it is available for the next 
start. In case the relative/default value is activated when you leave the program, the relative/de-
fault value is active after restart.

Figure 15:  Prompt for software calibration of the azimuth angle reference

5.4.4  Saving Measurements
You can save single measurements of DOP in an ASCII file. The measurement data combined 
with current date, time, temperature, and the comment defined by the user are written, separa-
ted by tab stops, into a pre-assigned file, see Figure 16.
You have to select 'Save Actual Data' or just use shortcut Strg+'S'.
To assign the data file, select 'File' -> 'Set Log File' or just use shortcut Strg + 'L' and edit the file 
name in the prompted dialog.
When saving measurement data without assigning a log file before, the set log file dialog opens 
automatically.
Several calls of the saving function will write the data into the same file but in subsequent num-
bered lines.
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When you close the program, directory and file name are stored.
After restart of the program and without new assigning of the log file, the latest log file is used. 
Separated by an empty line the new sets of data are stored with nummeration starting at 1.

Figure 16:  Example of an automatically generated protocol as ASCI file

5.4.5  Continuous Data Recording
To record individual measurements of the state of polarization over long periods of time, an au-
tomated data logging can be used.
For logging data, the same log file as for data saving is used, see subsection 5.4.4.
The elapsed time between individual data sets is defined by selecting 'File' -> 'Set Log Interval' 
or by short cut Strg + 'T'.
By selecting 'Edit' -> 'Record Logs on/off' or by key F10 the automated data recording is star-
ted. An activated record is shown in the status bar by 'Rec. ON'. 
To stop the automated data recording again, select 'Edit' -> 'Record Logs on/off' or press 'F10'. 
In the status bar 'Rec. OFF' is shown.

5.5  PER Measurement

The operating program SKPolarization Analyzer supports the measurement of the extinction 
ratio for coherent radiation coupled into a polarization maintaining fiber.

5.5.1  Measurement Principle
A polarization maintaining fiber consists of two polarization axes, called slow and fast axis. 
These axes are independent propagation paths for coupled radiation. To couple linearly polarized 
radiation to a polarization maintaining fiber, the plane of polarisation of the radition source has to 
match one of the two axes, standard is to match the slow polarization axis.
When coupling linearly polarized radiation with an angle j ≠ 0 with respect to the slow polariza-
tion axis of the fiber, the radiation is partly guided in the second, named fast polarization axis of 
the fiber.
Since the two paths of propagation are not phase locked, the two fractions of the radiation have 
gained a differential phase at the fiber end, depending on temperature or on bending of the fiber.
In case of radiation with sufficient coherence length, the two fractions of radiation will super-
impose to an arbitrary elliptical SOP, again dependend on temperature or on bending of the fiber.
On the Poincaré sphere, these varying states of polarization are projected on to a circle, its cen-
ter ideally located on the equator, see Figure 17.
The lesser the angle j is, the smaller the radius of the circle will be.
In case of a correct orientation of the fiber's polarization axis, i.e. j = 0, at best the circle reduces 
to a spot on the equator.
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Figure 17:  Larger scaled view of the PER measurement

5.5.2  PER Measurement
When a PER measurement is started, the polarization analyzer accumulates several measure-
ments. During this time the user has to vary the state of the fiber either thermally or mechanically. 
The varying SOPs are recorded and finally a circle on the surface of the Poincaré sphere is fitted 
according to the data.
The result of the fit is displayed as 'Fiber PER Measurement:', see Figure 18:

η:  Ellipticity [°] 
The ellipticity η is defined as the ellipticity of the circle's center. It is a measure for the part of 
the extinction ratio, which is independent from temperature and bending of the fiber. For an 
ideal fiber, η = 0°, even if the polarization axis of the fiber is not aligned properly.

∆η:  Ellipticity radius [°] 
The ellipticity radius ∆η is the radius of the circle in DEG and a value for the varying part of 
the extinction ratio. In case of a correct orientation of the fiber's polarization axis, i.e. j = 0, 
the ellipticity radius ∆η = 0.

Mean E:  average extinction ratio [dB] 
The average extinction ratio is directly calculated from the ellipticity η and so represents the 
part independent from temperature and bending of the fiber radius. E can be very high for an 
ideal fiber, even if the polarization axis of the fiber is not aligned properly.The actual extinc-
tion ratio may be higher or even lower with respect to the circle's center, depending on the 
actual state of polarization.

Min E:  minimum extinction ratio [dB] 
The minimum extinction ratio is defined as the extinction ratio for the actual state of polari-
zation (depending on temperature and on bending of the fiber) on the circle's farthest point 
from the equator. It represents the worst possible polarization state of the current fiber align-
ment.

Min Ext. Ratio V:  minimum extinction ratio 
The minimum extinction ratio V is a linear representation of the logarithmic value Min E.
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average ellipticity in DEG
variation of ellipticity in DEG
center azimuth in DEG
average extinction ratio in dB
minimum extinction ratio in dB
minimm extinction ratio

comment fi eld

Figure 18:  Numerical result of an PER measurement

5.5.3  Performing a PER Measurement
A PER measurement is started by icon  in the tool bar or by key 'F11'.
The number of measurement points defi ned in the parameter dialog, see 5.6.3, are recorded, 
while the fi ber has to be stressed thermic (by use of a blow-dryer) or mechanically, see Figure 19. 
As as result the individual measurement points form a circle on the surface of the Poincaré sphe-
re. For a precise measurement the points have to cover a whole circle on the Poincaré sphere.
The time elapsed for the measurement is displayed in an indication bar, see Figure 20.

Figure 19:  Stressing the fiber thermic with a blow-dryer

Figure 20:  Display for elapsed measuring time as indication bar
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Additionally you have to check the signal amplitude (as to be seen in window 'Detector Signal', 
see Figure 13) not beeing overloaded even at different states of polarization before the start of an 
actual mesurement. Therefore stress the fiber and observe the waveform of the detector signal.
After the data is recorded, the measurement is stopped and a circle is fitted to the data. The 
measurement result is displayed in window 'Numerical values', see Figure 18.
You can finish the acquisition of data points at any time to directly calculate the extinction ration 
by button 'Stop', , or by key F3.
In case if the individual measurements are too noisy or if the data points do not cover an entire 
circle, a corresponding error message is displayed.
In case the data appears to cover more an elliptical than a circular form you may have used a 
wavelength differing from the wavelength defined. A dialog box of warning is shown.

5.5.4  Adjustment of the Fiber's Polarization Axis
With the result of a PER measurement you can optimize the adjustment of the fiber's polarization 
axis to increase the extinction ratio. Therefore rotate the polarization axis of the fiber with respect 
to the linear radiation at the fiber input.
In the description of the Poincaré sphere the actual state of polarization (blue spot) has to come 
close to the center of the circle by rotating the fiber's polarization axes. For a given fiber the cen-
ter position is the best possible and stable state of polarization. 
For measuring the increased extinction ratio you have to redo the PER measurement.
For optimal coupling these steps have to be repeated iteratively.
Starting this iterations, when the circle displayed is still large, changes of the radius could be 
seen very easily. When the circle decreases it becomes more difficult to see improvements.
Hence, the software supports an additional indicating bar, which displays the distance of the 
actual SOP to the circle's center on logarithmic scale, see Figure 21.
As a standard setting this bar is displayed automatically after the first PER measurement is fini-
shed

Figure 21:  Bar indication for adjustment a fiber's polarization axis

Zero percentage in adjustment quality corresponds to the largest distance possible on the sphe-
re. This is achieved for j = 45°. The best adjustment value, 100%, is reached in case the actual 
state of polarization already is in the center of the latest PER measurement circle.
The adjustment quality is displayed on a logarithmic scale. The black line represents the radius 
of the latest PER measurement, so it can be seen immediately whether the extinction ratio is 
increased or not when the alignment of the polarization axis is adjusted.
In case of an increased extinction ratio the bar is colored green, in case the extinction ratio is 
decreased, the bar is colored red.
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5.5.5  Saving a PER Measurement
You can save the result of a PER measurement into an ASCII file, see Figure 22.
Select 'File' -> 'Save PER Results' or just use shortcut  Strg+'E'.
The different values are separated by tab stops, so you can import the data e.g. to Microsoft 
Excel very easily.

Figure 22:  Protocol of an PER measurement

5.6  User Interface

In this section the user interface is described systematically.

5.6.1  Tool Bar
This subsection includes a complete list of all icons and their corresponding short cuts.

Polarization Analyzer Operation
	 Starts a continuous measurement of polarization 				    F2
	 Starts a new PER measurement 							       F11	
	 Stops the running measurement or terminates PER measurement		  F3

Parameter Settings  	
	 Input parameters, opens a dialog box for parameter settings 		  F4	
	 Calibration of azimuth angle reference	 phase 				    F6

Saving
	 Save PER measurement results							       Strg+E
	 Save actual state of polarization to log file					     Strg+S
	 Record logs: start/stop of automated data logging				    F10

Windows
	 Opens window 'Poincaré Sphere' (3D-view)					     Shift+3
	 Opens window 'Measured Values'						      Shift+D
	 Opens window 'Detector Signal'							       Shift+S
	 Opens window 'Polarization Ellipse'						      Shift+E

	 Switch windows 'Poincaré Sphere' and 'Polarization Ellipse'			  Alt+S
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5.6.2  Menus
This subsection shows a complete list of all menu items and their corresponding short cuts.

	     

closes all windows and stops measuring

saves last current measurement in text file 

writes current polarization measurement to log file

creates log file

sets time interval for data logging

saves all setting and closes program

Figure 23:  File menu

	     

opens dialog box for parameter input

sets azimuth angle reference to factory settings (default)

sets azimuth angle reference to user value

writes a new azimuth angle reference (user)

data logging on/off

opens dialog for editing the comment

	

Figure 24:  Edit menu

	     

starts plarimeter for continuous measurement

stops the Polarization Analyzer

start an PER measurement

	

Figure 25:  Polarization Analyzer menu
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rotating sphere by mouse

zooming sphere by mouse

resets sphere to default view

changing zoom and anle of view of Poincaré sphere

deletes current points of PER measurment

switchs between ellipse view and Poincaré sphere

show PER adjustment bar

logarithmic display of polarization ellipse

opens window with Poincaré sphere

opens window with numerical data

opens window with detector signal

opens window with ellipse plot

show/hide tool bar

show/hide status bar

	

Figure 26:  View menu

	     resets all window positions to default positions

	

Figure 27:  Window menu

	     

open this handbook as .pdf document

shows information about the current polarimeter and 
software revision

	

Figure 28:  Help menu
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5.6.3  Dialogs
In this subsection all dialog boxes of the software are listed. The dialog boxes can be called by 
different menu items. All entries are discussed in detail.

5.6.3.1  Parameter Dialog
Wavelength:
Input field for the current wavelength.
It is necessary to specify the correct wave-
length since the measurement is based on a 
wave plate which is wavelength dependent. In 
case of a differing wavelength, the calculated 
ellipticity will be incorrect.
Ask for wavelength:
If selected, a dialog asks for the actual wave-
length at program start.
Measurement Points:
Defines the number of measurement points for 
the PER measurement. The measuring time de-
pends on this number of measurement points.
Show Adjustment Bar after PER-Measure-
ment:
If selected, after each PER measurement the 
adjustment bar will be displayed to assist in 
aligning the polarization axis of a polarization 
maintaining fiber.

Figure 29:  Dialog for editing measurement and program parameters

FFT-Points:
Number of FFT-points per measurement cycle (one revolution of the quarter-wave plate). You can 
select between 16, 32, 64, and 128 points (default 64 points). These Points are shown in window 
'Detector signal'.
Continuous Measurement Points:
Number of blue measurement points in continuous measurement mode.
Enable fading points:
Switch between sudden disappearing and slowly fading continuous measurement points.
Averaging:
Number of averaging per measurement. Reduces noise from measurement points.



M
an

ua
l P

ol
ar

im
et

er
 4

6_
IN

D
6.

in
d

d
 •

 P
ag

e 
26

2012 E  

Kieler Straße 212, D-22525 Hamburg • Phone (+49) 40 85 39 97-0 • Fax (+49) 40 85 39 97-79 • eMail: info@SuKHamburg.de • Web: www.SuKHamburg.de

M
an

ua
l P

ol
ar

im
et

er
 4

6_
IN

D
6.

in
d

d
 •

 P
ag

e 
26

Kieler Straße 212, D-22525 Hamburg • Phone (+49) 40 85 39 97-0 • Fax (+49) 40 85 39 97-79 • eMail: info@SuKHamburg.de • Web: www.SuKHamburg.de

26

2012 E  

5.6.3.2  Comment Dialog

Figure 30:  Input dialog for the comment field

The comment field of the polarimeter software is designated for text with up to 64 characters. 
The text is displayed in the numerical display and is recorded in the log file.
You can open the notes input dialog by shortcut Alt+'N' or by selecting the menu entry 'Edit' -> 
'Notes input'.

5.6.3.3  Wavelength Input Dialog
It is necessary to specify the wavelength in use during operation since all measurements are 
based on a wave plate which is wavelength dependent. For a differing wavelength the calculated 
ellipticity will be incorrect.
Hence, a dialog for defining the measuring wavelength is shown at startup of the program, see 
Figure 31.
For changing the measuring wavelength during runtime you have to use the parameter dialog 
(shortcut 'F4'), see Figure 29.
You can suppress the appearance of the wavelength input dialog on start up by unselecting the 
field 'Ask for wavelength on startup' in the parameter dialog.

Figure 31:  Input dialog for changing the wavelength

5.6.3.4  3D view settings Dialog
While the zoom factor in the 3D measurement display can be changed via mouse wheel and 
mouse move with button "z" pressed, there are some more customization that can be done:
In the 3D view settings dialog the angle of view can be changed, resulting in an exaggerated 
effect of dimensional proportion change.
In this window one can also specify the values ot the different changes made to the 3D view 
on runtime which should be saved for the next time the polarization analyzer is connected. You 
can differentiate between the saving of the zoom factor, rotation of the whole sphere and the 
angle of view.



M
an

ua
l P

ol
ar

im
et

er
 4

6_
IN

D
6.

in
d

d
 •

 P
ag

e 
27

Kieler Straße 212, D-22525 Hamburg • Phone (+49) 40 85 39 97-0 • Fax (+49) 40 85 39 97-79 • eMail: info@SuKHamburg.de • Web: www.SuKHamburg.de

27

2012 E  

Figure 32:  Input dialog for changing the wavelength

 
5.6.3.5  Set Log Interval
For automated data logging the time interval between the individual measurements has to be 
defined. 
As standard this value is set to 10 sec. You can change this value in a dialog box opened by 
selecting 'File' -> 'Set Log Interval' or by shortcut 'Strg' + 'T', see Figure 32.

Figure 33:  Input dialog for defining parameters for data logging

5.6.3.6  About
All information about the polarization analyzer hardware, such as type revision number and serial 
number are shown when the about dialog box is opened. Therefore select 'Help' -> 'About Po-
larization Analyzer' or icon  in the tool bar.

    

Software version

Polarization Analyzer type

Revision and serial number

Wavelength range of Polarization  
Analyzer connected

Version of DLL currently in use

Figure 34:  Dialog showing information about the current polarimeter
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6.  Appendix

The following pages contain the technical data and shipping condition of the Schäfter+Kichhoff 
polarization analyzer SK010PA.
In a theoretical part the polarization nature of light and its representation as Stokes vectors and 
as points on the Poincaré sphere is described in a short form.
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A.  Technical Data
Operating temperature				    10 - 40 °C (non condensing)
Warm-up time					     5 min
Size							       40 x 70 x 82 (B x L x H))

Figure 35:  Dimensions of SK010PA, the adapter is compatible to "micro-bench"  

and "multicube" combination system.

Fiber adapter			  standard		  FC-APC
Aperture			   max.			   4 mm
Wavelength range		  SK010PA UV		 350 -   450 nm
				    SK010PA UVIS	 400 -   700 nm
				    SK010PA VIS	 450 -   800 nm
				    SK010PA NIR	 700 - 1100 nm
				    SK010PA IR		  1100 - 1600 nm
Sampling rate					     30 measurements per sec.
Accuracy η + ∆η					     0.2 °
Accuracy E 						      0.5 dB
Accuracy j						      0.2 °
Accuracy DOP					     5 %
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B.  Shipping Condition

The Schäfter+Kirchhoff polarimeter is shipped with the following components:
1.  Polarization Analyzer SK010PA-xx
2.  Fiber adapter FC-APC
3.  USB cable
4.  CD-ROM with installation software SKPolarization Analyzer
5.  This handbook

Figure 36:  All parts of the Schäfter+Kirchhoff polarization analyzer as shipped
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C.  Equipment

Adapter for fiber connectors 
FC-APC / PC	  
DIN-AVIO PC / APC	  
ST

Different fiber connectors 
and wavelengths

Adapter plate
For attaching beam optical 
components with Ø 19.5 mm 
system mount or with 
Ø 25 mm compatible with mi-
crobench systems

Ø 19.5 	 48MC-MP-19.5 
Ø 25 	 48MC-MP-25    

Rod for mounting to microbench sy-
stem  
48MC-6-75

75 mm

Connector 
Type PC/APC Lens Spectral 

Range Code

FC 4 = APC

A11

400 -   600 nm 01
DIN-AVIO 0 = PC 600 - 1050 nm 02

ST
0 = PC

1050 - 1550 nm 03
F-SMA 1300 - 1750 nm  45

PA  -  FC   -      4      -   A11   -    02

Adapter incl. 4 Rods  
for optics:  

Ø 12 	 PA-48MC-12
Ø 19.5 	 PA-48MC-19.5
Ø 25 	 PA-48MC-25
Ø 32 	 PA-48MC-32

Adapter and inter-ad-
apter incl. 8 rods for 
optics: 

Ø45	 PA-48MC-45
Ø55	 PA-48MC-55

Wavelength ranges	
SK010PA UV	 350 -   450 nm
SK010PA UVIS	 400 -   700 nm
SK010PA VIS	 450 -   800 nm
SK010PA NIR	 700 - 1100 nm
SK010PA IR	 1100 - 1600 nm

incl. adapter for Ø 11 mm optics and  
integrated iris diaphragm 

PA-48MC-11

Adapter for free beam applications

Single Parts

USB 2.0 Cable

Polarization Analyzer SK01PA



M
an

ua
l P

ol
ar

im
et

er
 4

6_
IN

D
6.

in
d

d
 •

 P
ag

e 
32

2012 E  

Kieler Straße 212, D-22525 Hamburg • Phone (+49) 40 85 39 97-0 • Fax (+49) 40 85 39 97-79 • eMail: info@SuKHamburg.de • Web: www.SuKHamburg.de

M
an

ua
l P

ol
ar

im
et

er
 4

6_
IN

D
6.

in
d

d
 •

 P
ag

e 
32

Kieler Straße 212, D-22525 Hamburg • Phone (+49) 40 85 39 97-0 • Fax (+49) 40 85 39 97-79 • eMail: info@SuKHamburg.de • Web: www.SuKHamburg.de

32

2012 E  

D.  Theory of Polarized Light 

D.1  Polarization Nature of Light

Light is a transversal electro-magnetic wave (in isotropic media such as bulk glass or air).
Due to the transversal nature of the wave (and the linearity of Maxwell's equations), there are two 
independent orthogonal oscillating planes. Coherent light, as it is emitted from a laser source, 
generally can be described as a superposition of radiation parts oscillating in the two planes, 
respectively.
You can name some particular states of polarization, SOP, see Figure 36.
If the two parts oscillate in phase, the superimposed radiation is linearly polarized. Its orienta-
tion, the azimuth angle, depends on the ratio of the two amplitudes. If only one part has a non-
zero amplitude, the radiation is polarized horizontally and vertically.
If the two parts oscillate with a phase shift of p/2, the superimposed radiation is called circularly 
polarized. Depending on sign of the phase shift, the radiation is left-handed or right-handed 
circularly polarized.
The most generic state of polarization is the elliptic SOP. Again you can distinguish between left-
handed or right-handed elliptically polarized light.

x

y

x

y

x

y

x

y

x

y

x

y

x

y

x

y

x

y

Figure 37:  Different states of polarization SOP as superposition of two orthogonally polarized linear states. On the left a 
linear state, in the middle circularly polarized state and on the right an elliptically polarized state of polarization is displayed.

D.2  Mathematical Description

The electro-magnetic field can be described (assuming the wave propagates into z- direction of 
a Cartesian coordinate system):

		  Ex(t) = Êx  cos(wt ⋅ δx )									        (1)
		  Ey(t) = Êy  cos(wt ⋅ δy )	

Here Ex(t) and Ey(t) are the time-dependent parts of the wave oscillating in the x-z Plane and y-z 
plane, respectively. Êx and Êy represents the amplitudes and δx and δy their phases, while ω is the 
frequency.
In the x-y plane the vector (Ex(t), Ey(t)) describes an ellipse, see Figure 37.
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This ellipse is defined by two values. The first one is the azimuth angle j with respect to the x-
axis and the ellipticity η, see Figure 37. From (1) azimuth j and ellipticity η are calculated as (δ = 
δx - δy):
		

sin (2η) =
 	 2 Êx ⋅ Êy ⋅ sin(δ)							       (2)

				    								      

				  
  |Êx|² + |Êy|2	

		
tan (2j) =

 	 2 Êx ⋅ Êy ⋅ cos(δ)	
				    							     

				      
|Êx|²  -  |Êy|2

	

ϕ

Figure 38:  Polarization ellipse described as superposition of two orthogonally polarized linear SOPs

The extinction ratio V = (b/a)2 is related to the ellipticity η by

		  V = 1 / cot ² η										         (3)

and the extinction E is the extinction ratio V on a logarithmic scale (in dB):

		  E = -10⋅log( V )									         (4)

D.3  Poincaré Sphere

The Poincaré sphere is a comprehensive description of SOPs. Any SOP of a coherent source is 
mapped one-to-one onto a surface of a sphere with unit radius.
All linear states of polarization are mapped to points laying on the equator. The state of horizon-
tally polarized light is mapped opposite to the state of vertically polarized light, see Figure 38.
An arbitrary linear SOP is described by twice the azimuth angle 2j and η = 0.
Circularly polarized light is mapped to the poles of the sphere, right-handed polarized to the 
north pole and left-handed polarized to the south pole.
Left-handed and right-handed elliptically polarized light are mapped to the northern and sou-
thern hemisphere, respectively. The zenith angle is repre⋅
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Figure 39:  Poincaré sphere

Figure 40:  Ellipticity η and azimuth angle j on the Poincaré sphere
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D.4  Normalized Stokes Parameters

There is another representation of the SOP, which is more correlated to the Poincaré description. 
The normalized Stokes parameters, (

S

1, 

S

2, 

S

3), are in a Cartesian coordinate system the coor-
dinates of the SOP mapped to the Poincaré sphere with its center at the origin, see Figure 39.
Since the radius of the Poincaré sphere is unity, (

S

1, 

S

2, 

S

3) = 1. 
The normalized Stokes parameters are related to ellipticity η and azimuth angle j or to the elec-
tro-magnetic wave (1) by following equations:

		  S

1 = cos 2η ⋅ cos 2η	=       Êx
2 -  Êy

2
                     

Êx² + Êy
2

						      (5)

		

S

2 = cos 2η ⋅ sin 2η 	= 2⋅Êx
 ⋅  Êy ⋅ cos  δ                                      

     Êx² + Êy
2

	

		

S

3 =	  sin 2η 	 = 2⋅Êx
 ⋅  Êy ⋅ sin  δ                                      

     Êx² + Êy
2

	

				      		

D.5  Partly Coherent Light, Degree of Polarization DOP

Light sources other than lasers are partly coherent or incoherent. SOPs of partly coherent light 
is not represented exactly by the Poincaré sphere, since the Poincaré description is normalized.
Partly coherent light is described entirely by the Stokes parameter, (

S

1, 

S

2, 

S

3). 

S

0 represents the 
total optical power, √(

S

1
2, 

S

2
2, 

S

3
2)  represents the optical power of the coherent part.

The normalized Stokes parameter are related to the Stokes parameter by:

	

S

1 = 

S

1 /

S

0, 

S  

2 = 

S

2 /

S

0, 

S

3 = 

S

3 /

S

0 .								       (6)

The degree of polarization DOP describes the coherence of radiation. It is defined as

	 DOP = √(

S

1, 

S

2, 

S

3).										          (7)
		            

S

0 

From the definition you see that DOP ≤ 1. For coherent radiation DOP ≅ 1.
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