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Migrating Label Formats from Legi for Windows 2.X to Legitronic 
Labeling Software 3.5.X 

 

Today’s powerful enterprise grade PC’s come loaded with Microsoft’s Windows XP Professional operating system, or at the 

very least Microsoft Windows 2000 Professional. Legitronic Labeling Software version 3.5 was designed with these multi-

tasking, multi-user professional (as opposed to home versions) operating systems in mind.  
PC’s of the Windows 3x – 9x era are wearing out and being replaced. When this happens, the first thing the user wants to 

know is, “Will my old Legi run on my new PC?” The answer is a resounding, “It depends!” The reasons are many and often 

quite technical but under some circumstances, the old version will work just fine, and sometimes it won’t. We’ve even seen 

installations that function fine for a while, then stop, never to work again. In a nutshell, older 16-bit versions of Legi were 

created to work with older 16-bit operating systems, while the newer versions of Legitronic Labeling Software are 32-bit, 

written for 32-bit operating systems.  

 

This document deals with what you must do if you can’t run the old software anymore.  

 

Versions of That Legi Will Migrate to Version 3.5 

Legi for Windows version 2.2.0 will migrate into Legitronic Labeling Software 3.5. Earlier releases of Legi for Windows will 

usually not migrate forward without causing problems. As a result, it is usually less work and time, to create new formats 

under your new software.  

 
Notice the word migrate in the article’s title. Migrate implies a journey. You can’t just open the old label formats in the new 

software and print them. There is some work involved. You’ll need to install new printer divers and you will have to touch 

each label format and possibly other processes as well. 

 

What You Will Need 

• Windows 2000 Professional or Windows XP Professional - Home editions are not supported 

• A new license key (dongle) - The 16-bit dongle is black; the 32-bit dongle is beige 

• Copies of your old formats - never use originals (once a label is saved as 32-bit you cannot go back to 16-bit) 

• Administrative privileges over the PC on which you’re installing Legi 

• * An ODBC compliant database (MS Access, SQL, etc) and its associated ODBC driver  

* Only if your formats require database interaction
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Before You Install the Legitronic Labeling Software 

1. Log into Windows using an account with administrative privileges. 

2. Log into LegiWin. 

3. Open each label format and review the properties of each Text Field. Legi version 2 had the option to use both Auto 

Wrap AND Dynamic Fit. In newer versions, these options are mutually exclusive. If you find that one of your Text 

Fields has both of these options checked, turn off Auto Wrap and save the label. You will tweak that field later in the new 

version. (Figure 1) 

Figure 1 
 

4. Look for any fields on the label that access a database. These can be fields that use a Supplied Input (Figure 2a) with a 

Table Lookup (Figure 2b), a Tracking Serial Number (Figure 3), or a field with an expression type of Database      

(Figure 4). 

 

Figure 2a        Figure 2b 
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Figure 3         Figure 4 

 

5. Write down the name of any databases or tables and their locations. 

6. Repeat steps 3, 4 and 5 until all labels have been examined. 

7. Return to the LegiWin Main Menu and click Configuration. Then select Printers from the Configuration Menu.     

(Figure 5a, b) 

 

Figure 5a       Figure 5b 

 

Note what printer(s) you have on which port(s). (Figure 6) 

 

Figure 6
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8. Redirect the current printer(s) from the existing port(s) to and direct it to File. (Figure 7) 

 

Figure 7 
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Install Legitronic Labeling Software 

9. Plug your new dongle into the parallel or USB port. 

10. Log into Windows using an account with administrative privileges. 

11. Place the Legitronic Labeling Software CD in the CD ROM drive and let it start. Choose the option to install as a Single 

User Hardware Key. (Figure 8) 

 

Figure 8 
 

12. After Legi is installed, go to the Windows Program Group that the installation created and run Sentinel Installer program. 

(Figure 9a-b) 

 

Figure 9a      Figure 9b 
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Install New Printer Drivers 

13. Log into Windows using an account with administrative privileges. 

14. Open the Printers area of Windows. (Figure 10) 

Figure 10 

 
15. Click the Add a Printer link and follow the Add a Printer Wizard instructions. (Figure 11) 

 

Figure 11 

 

16. Choose the Local Printer option, but UNCHECK the setting that allows Windows to detect Plug and Play devices. 

(Figure 12) 

Figure 12
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17. Direct the printer to the port where it is installed. (Figure 13) 

NOTE: If using a networked printer contact your Network Administrator. 

 

Figure 13 

 

18. Click the Have Disk button when the list of manufacturers and printers on the Install Printer Software window comes up. 

(Figure 14) 

Figure 14 
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19. Click the Browse button on the Install from Disk window. (Figure 15) 

 

Figure 15 

 
20. Browse to C:\Program Files\Weber Marking Systems\Legitronic Labeling Software\Printer Drivers\Windows-NT-2000-

XP\English folder. (Figure 16) 

 

Figure 16 
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21. Double-click on WeberNT.inf. (Figure 17) 

 

Figure 17 

 

22. Click OK on the Install from Disk window. (Figure 18) 

 

Figure 18 
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23. Scroll through the list of printers and highlight the model to install and click Next. (Figure 20) 

NOTE: If asked to replace or keep the existing driver, choose replace. 

 

Figure 20 
 

24. Continue through the Add a Printer Wizard. 

25. Choose No to Default Printer, Share Printer and Print a Test Page. (Figure 21a, b, c) 

 

Figure 21a   Figure 21b    Figure 21c 
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26. Click Finish to complete the Add Printer Wizard. (Figure 22) 

 

Figure 22 

 

27. Choose Continue Anyway to the Windows Certification warning.(Figure 23) 

 

Figure 23 

 

28. Right-click on the newly installed printer. 

29. Choose Properties from the quick-pick menu. (Figure 24) 

 

Figure 24 
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30. Click on the Ports tab.(Figure 25) 

 

Figure 25 

 

31. Uncheck the Enable Bidirectional Support option (near the lower left) UNLESS your printer is USB enabled.        
(Figure 26) 

 

Figure 26
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NOTE: If you need to make changes to your port settings click on the Configure Port button, (Figure 27a, b). Ask your IS 

department if such changes are needed. (The recommended COM1 settings are shown) 

 

  Figure 27a        Figure 27b 

 

32. Click on the Device Settings tab. (Figure 28) 

 

Figure 28
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33. Click on the Properties button for the Setup Label Size option. (Figure 29) 

 

Figure 29 

 
34. Change the label settings from the existing values to 20 inches by 20 inches, (Figure 30a, b) and click OK. 

Figure 30a       Figure 30b 
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35. Click Close to finish setting up your printer. (Figure 31) 

 

Figure 31 



  16 

 

Databases 

If your label uses a database to populate fields and/ or supply input, it will need updating to a 32-bit database. You may use 

any Open Database Compliant (ODBC) database you choose. For this example, we will use Microsoft Access 2003. If you 

are unsure of this process you should contact your IS department. 

 

36. Open MS Access 2003. 

37. Click File ►New►. (Figure 32a, b) 

 

Figure 32a       Figure 32b 

 

38. Choose Blank Database from the New File list. (Figure 33) 

 

Figure 33
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39. Change the default database name to a meaningful name in the File New Database dialog box, (Figure 34a, b) and click 

Create. 

 

Figure 34a       Figure 34b 

 

40. Click File ►Get External Data► Import when the Tables screen opens. (Figure 35a, b) 

 

Figure 35        Figure 35b
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41. Browse to the database files you located in Steps 4 and 5, and choose the Paradox (*.db) option in the File of type box. 

(Figure 36) 

 

Figure 36 

 

42. Highlight the database you want to import and click Import. (Figure 37a) You will see the Paradox database imported 

into your MS Access 2003 database as a table. (Figure 37b) 

 

Figure 37a       Figure 37b
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43. Repeat Steps 41 – 43 until all databases are imported 

44. Right click on the first table you imported in Steps 41 -43, (Figure 38a) and choose Design View from the menu.    

(Figure 38b) 

 

Figure 38a       Figure 38b 

 

45. Change the Data Types to Text for all fields in the table. 

 

Figure 39 

 

46. Repeat the previous step until all fields in all tables are set to Text. 

47. Click Save and close the database. 
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Configuring the ODBC driver and defining a Data Source 

48. Click on Start then on Control Panel then on Administrative Tools then on Data Sources (ODBC). (Figure 40) 

 

 
       Figure 40 

 

49. Select the System DSN tab and click [Add] (Figure 41) 

 

 
Figure 41

Add button 



  21 

50. The next step is creating a Data Source. The Data Source is the key name that you enter to connect to your database to 

the Label format. Select the type of database you are using and click finish. For this example, we will use Microsoft 

Access. Select Microsoft Access Driver and click [Finish]. (Figure 42) 

 

 
Figure 42 

 

51. The next step is to enter a Data Source Name (DSN). The DSN will be the name that will be used in the Legitronic 3.X.X 

ODBC database field that will reference the label format to the assigned database. The DSN is assigned by the operator 

and can be any combination of alpha and numeric characters. (Figure 43) 
Note: The description field is optional and only to be used as a reference.  

 

 
Figure 43 

* Clicking the [Advanced] button allows the Data Source Name to be password protected. This will not be addressed 

in this paper. For further information, call Labeling Systems.

DSN 

 * 

Finish button 

ODBC driver for 

MS Access 

Select button 
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52. Click the [Select] button on the ODBC Microsoft Access Set Up screen. The following screen will appear. Select the 

Access Database to be used for the Label. Then click [OK]. (Figure 44) 

 

 
Figure 44 

 

Note the file path will show under database.  

53. Click [OK].(Figure 45) 

 

 
Figure 45

Access 

Database 

OK Button 

OK Button 
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54. You should now be back at the ODBC Data Source Administrator screen. (Figure 46) 

 

 
Figure 46 

 
 

55. Click [OK] and you are finished configuring the ODBC Data Source 

 

OK Button 
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Opening the Label 

56. Start the Legitronic Labeling Software. ( Start ► All Programs ►Weber Marking Systems ► Legitronic Labeling 

Software ► Legitronic Labeling Software) (Figure 47) 

 

Figure 47 

 

57. Key in the Login Name (weber) and Login Password (legi) and click OK 

58. Click File ► Open Label for Design. (Figure 48) 

 

Figure 48 
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59. Browse to and highlight the label you want to import and click Open. (Figure 49a, b) 

 

Figure 49a       Figure 49b 

 

60. Click OK when the message “You are opening a Legitronic Labeling Software for Windows 2.2.0 label format. If you 

save it, it will be upgraded to 3.5.1” appears. (Figure 50) 

 

Figure 50 

Click the Save Icon when the label opens. (Figure 51) 

 

Figure 51 
 

Your label is now in Legitronic Labeling Software 3.5.1 format. See the next section for other helpful information.  
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Other Considerations 

If the printer that the label format is using is not found, you will see the following: 

 

 

Pull down the printer list and select your printer.  

 

If it is not listed, review the Installing a Printer section of this document. 
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If your label is using a database, you will see the following: 

 

 

Enter the DSN from step 51 exactly as you first entered it and click OK. 
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Enter the DSN name again if prompted to do so. 

 

You may also have to tweak the field spacing and the fonts on the label formats as the newer software and drivers have 

tighter tolerances. 

 

 
 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

If you have any questions about the material covered in this document, 

please call Product Systems at 847.364.8500 ext 773 


