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This document has been specifically prepared by Gaia Resources for training purposes.  Use of this 

document (including copying or other reproductions) cannot be undertaken without express 

permission from Gaia Resources.   

 

All enquiries on the contents of this training should be directed to Gaia Resources, 191 St Georges 

Terrace, Perth, Western Australia, 6000 or via email to enquiries@gaiaresources.com.au 
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A. QGIS user training introduction 

 

QGIS is an open source Geographic Information System (GIS) that allows people to make maps and 

view various forms of geographic information. During the course you will learn tasks to import, 

interrogate, edit, create, visualize, geoprocess and export data. 

 

The training is an introductory course comprising the more common tools used in QGIS. This training 

course has been designed to be completed in one and a half days with provision to extend to two 

days for those that require additional assistance or have brought their own data with them.  It consists 

of short presentations, exercises and questions and is completed in conjunction with prepared 

workspaces and training data. This training material can be referred to and reused at any time in the 

future so ensure the training data is kept with the hard copy manual. 

 

For further training, or assistance in any spatial work you may have, please contact our staff at: 

 

Gaia Resources 

191 St Georges Terrace, 

Perth, WA, 6006 

+61 8 9227 7309 

enquiries@gaiaresources.com.au 

gaiaresources.com.au 

B. Installing your software 

Before you start the training, your QGIS software should be installed on your pc. 

 

You can install your software by: 

 

• Opening the QGIS website in a browser (http://www.qgis.org/en/site/) 

• Click on the "Download Now" button (Version 2.18) 

• Download the Installer for your pc (for Windows, ensure you select the correct bit size.) 
 

If you are not sure which bit size your laptop is, go to "Start > Control Panel > System".  The 

details should be under System type (32 or 64 bit). 

QGIS allows you to download installers for Windows, Mac OS X, Linux, BSD and Android. 

 

Please note that this training has been created based on Windows QGIS version 2.18 Las Palmas 

using the operating system MS Windows 10 and MS Windows 8. If you are using alternative versions 

or operating systems screen shots and workflows may vary. 

 

To complete this training, you will also need access to: 

 

• PDF viewer 

• Microsoft Excel 

Or a software application that can open the files from these programs.  Some sections of the 

training also require: 

 

• Internet connection 

C. Training data 

 

The data to be used within the training today has been supplied by Geoscience Australia. 

This data can be downloaded via their website:  http://www.ga.gov.au/metadata-

gateway/metadata/record/gcat_64314. 
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 © Commonwealth of Australia (Geoscience Australia) 2014.  

 

This product is released under the Creative Commons Attribution 3.0 Australia Licence. 

http://creativecommons.org/licenses/by/3.0/au/deed.en 

D. Folder structure 

 

You will be given access to the QGIS training folders, required for completing this training.  The 

folders are structured as follows: 

 

01_Training_Data 

Where the data for this training is stored.  This includes spatial data, spreadsheets, GPS files 

and image data. 

 

02_Training_Outputs 

 Where you should keep the exported and created outputs from this training. 

 

 
 

Take a bit of time to go through these folders and the types and format of the data you will be 

working with. Also note that all folders in “02_Training_Outputs” are empty awaiting your processed 

data. This is an example of good data management when working with a GIS so keep it in mind as 

you go through the training – for example make sure any data you are creating gets saved to the 

outputs folder and is named correctly as this will impact on subsequent exercises.  

http://creativecommons.org/licenses/by/3.0/au/
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1.0 Exercise 1 – Familiarising yourself with QGIS 

1.1 Launching QGIS 

● Click Windows Start and find QGIS Desktop from your program list.  

*Or alternatively, find QGIS Desktop shortcut icon on your desktop. 

 

You will see there are two types of QGIS application, Desktop and Browser.   

QGIS Browser:  The Browser allows you to review the general details of a dataset (i.e. the  

   parameters, metadata and attributes). 

QGIS Desktop:  The Desktop allows you to review the general details of datasets, but also  

   allows you to manipulate and map multiple datasets.  This is what we will be 

   using for training. 

 

Please note that the terms “Field name” and “Column name” (when referring to attributes) are 

used interchangeably in QGIS (the latter is slowly being phased out). 

1.2 QGIS workspace 

Workspaces are a place-holder for your data. They allow you to visualise, colour, label, filter and 

modify the data held within them. They come with a variety of tools to analyse, process and review 

your data.   

 

● Hover over buttons in the menu and toolbars for an idea of what they can do (The image 

below may not look exactly like your workspace). 

 
 

The different areas of the workspace are as follows; 

 

1) Menu Bar:  Contains workspace properties, settings, tools, plugins and other  

    details pertaining to the workspace. 

 

2) Table of Contents: Shows the list of layers (or datasets) in the workspace. 

 

Menu Bar 

Toolbar 

Map Canvas 

Info Bar 

Table of Contents: Layers 
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3) Toolbars:  Contains tools used for importing, manipulating and exporting data. 

   These can be removed or added as needed, so may not look exactly 

   like what you have on your screen. 

     

4) Info Bar:  Shows cursor coordinates, scale, magnifier, rotation, and   

    coordinate reference system (CRS) information for the workspace. 

 

5) Map Canvas:   Where data will be visually represented.    

 

Note:  The workspace format will vary based on which operating system and installer you 

 used to install QGIS on your system.   

1.3 Setting up and saving your workspace 

● Click "Project > Save as" in the Menu bar. 

● Save the workspace as "Exercise_1" in the folder "02_Training_Outputs\00_Workspaces". 

Note:   When saving a Workspace, if file extensions are set up to display in your File Explorer the 

extension will be shown as .qgs in your directory. 

 

The workspace should now show the title "Exercise_1" above the menu bar. 

Note: Remember to save your workspace frequently throughout the exercises.   

1.4 Adding vector layers 

 

Remember: vector layers can describe anything from lakes to roads to 

property boundaries or fauna habitat.  By overlaying these layers (e.g. points, 

lines and areas) we can ask the GIS important questions such as:  

o How many disease points are there per local government area? 

o How far do I have to drive to get to a landowner’s property?  

o What species are concentrated around certain wetlands in the last 12 

months? 

 

● Click "Add Vector Layer"   in the left hand side toolbar. 

● Under “Source", click "Browse”. 

● In File Explorer (i.e. your folders), click on the drop down list on the bottom right side. This 

gives a list of all available format options QGIS can read. 
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● Select "ESRI Shapefiles (*.shp *SHP)". 

● Open the data "01_Training_Data\01_Shapefiles\Bremer_Bay\i5012_mainlands.shp". 

● Click “Open” again. 

The layer will appear in the table of contents and its visual representation in the map canvas on 

the right. 

 

 
 

If you can't see the layer in the map canvas: 

 

● Ensure that the layer is activated (indicated with a tick to the left of the layer name). 

● Right click the "i5012_mainlands.shp" layer. 

● Click "Zoom to Layer". 

Note:   As QGIS randomly colours the added layers, your data may look different to the above. 

 

● Open File Explorer (Right click "Start", click "File Explorer").  Resize it so you can see both your 

File Explorer and your workspace map canvas. 

● Find the "01_Training_Data\01_Shapefiles\Bremer_Bay" folder. 

● Find the"i5012_roads" dataset (there should be 4 files in total with this name). 

● Select only the "i5012_roads.shp" file. 

● Drag and drop this file to the map canvas. 

● Ensure the layer is activated in the table of contents. 

Note:   Dragging the file to the map canvas can be time efficient, but only the file with the 

 extension ".shp" can be used.  For example, if you try dragging all 4 of the i5012_roadsfiles 

 over to the Map Canvas, you will get an error reading for 3 of those files. 

 

Question time 

 

a) What are the 4 file extensions that make up the shapefile of "i5012_roads"? ____________________ 
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Note:   Shapefiles are the basic building blocks for storing geometric location and attribute  

information of geographical features, which can be represented as points, lines or polygons 

(areas). Shapefiles can comprise up to 15 individual files with the most common being: 

.shp   (feature geometry) 

.dbf    (feature attributes) 

.prj   (feature projection) 

.sbn/ .sbx/ .shx (spatial indexes) 

 

Locate and add the following layers into your workspace.  In the Menu Bar: 

● Click "Layer > Add Layer > Add Vector Layer". 

● Under "Source", click "Browse". 

● In File Explorer, locate folder "01_Training_Data\01_Shapefiles\Bremer_Bay". 

● Select the following files (hint: hold down the Ctrl key while selecting files): 

o i5012_islands.shp 

o i5012_lakes.shp 

o i5012_nativevegetationareas.shp 

o i5012_populatedplaces.shp 

o i5012_reserves.shp 

 

● Click "Open".  

● Click "Open" again. 

● If set to default settings, these layers should already be activated. 

 

1.5 Change the layer order 

The ordering of your data determines how it is presented in the map canvas. 

 

● Click the "i5012_mainlands" layer in the table of contents. 

● Drag it to the top of the layer list in the table of contents and release. 
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You should now only see the outline of the mainland.  This is because the mainland layer is on top, 

so it is covering the layers below it. 

 
 

● Reorder your data per the below: 

o i5012_populatedplaces  

o i5012_reserves     

o i5012_nativevegetationareas  

o i5012_roads    

o i5012_lakes    

o i5012_islands     

o i5012_mainlands  

1.6 Reviewing metadata 

Metadata is the information about the layer. 

Remember: metadata helps us understand where the layer came from, when 

it was created and modified, what methods were used to generate it, who 

created it (and who to talk to for more information). It also describes the 

geographic coverage and any use limitations that the author of the data 

needs you to be aware of.  

 

For our Geoscience Australia data, a PDF document has been included in the data folder under 

"01_Training_Data\01_Shapefiles\Bremer_Bay\00_Metadata". 

● Open "GA_Topo250K_METADATA.pdf". 

● Find “Appendix D: Metadata" (page 52 of the document). 

● Skim read to page 55.  

 

 

Question time 

 

b) What is the Data Currency Beginning Date? ________________________________________________ 
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Note: Metadata can give you a better understanding of how useful it might be for your work, or if 

 it's the most up to date version of that data. It also comes in many different formats such as 

 text or xml files.  

 

● Close the PDF and go back to QGIS 

Metadata can also be stored within the data.  To review the metadata within the layer: 

 

● Right click the"i5012_mainlands" layer in the table of contents. 

● Click "Properties".  This window shows you all the properties for that layer. 

● Click the "Metadata" tab.  

● Review the metadata saved within the layer. 

As the Geoscience Australia data has a separate metadata document, only automated 

information is kept in this metadata area. 

 

● Click "Cancel". 

1.7 Change the layer names 

Changing the name of layers makes them easier to understand, and is required when you use 

legends in maps (this will be covered later on in the training). 

 

● Right click the "i5012_populatedplaces" layers. 

● Click "Rename". 

● Change the name to "Towns". 

● Change the names for all the vector layers to the below: 

o i5012_reserves    Nature Reserves 

o i5012_nativevegetationareas  Native Vegetation 

o i5012_roads    Roads 

o i5012_lakes    Lakes 

o i5012_islands    Islands 

o i5012_mainlands   Mainland 

 

Note:   Changing a layer name only changes its name in the Workspace.  This process will not 

change its name in the data folder (i.e. its shapefile name).  Hovering over the layer in the 

table of contents will show you the layers’ directory location and the original name of the 

layer. 

1.8 Adding rasters 

Remember: raster layers can represent elevation, satellite imagery, 

georeferenced maps, temperature or hydrological modelling. Raster layers 

are grids, where each cell has a value for a common variable like depth to 

groundwater. Apart from the obvious value of a backdrop for a map, when a 

GIS is used to overlay raster layers a number of questions can be answered, 

such as:  

- How much native vegetation and habitat is being cleared each year? 

- How deep do bores need to be to reach an aquifer? 
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Images and rasters can also be added to your workspace if they are geo-referenced (meaning 

their extents are referenced in the spatial world). 

To add a raster: 

● Click the "Add Raster" button on the left hand side toolbar.  

● Add "01_Training_Data\04_Images\GA_topo_mga50". 

● Move it above your other layers in the table of contents. 

● Ensure it’s turned on and review the data. 

Note:   If you still can’t see the layer, click “Project”, “Project Properties”, click the “CRS” tab on the 

left and ensure “Enable ‘on the  fly’ CRS transformation (OTF)” is checked. You will learn 

more about this later.  

 

This raster is of a 250K topographic map of Australia (essentially the vector files you have, but in an 

image format).   

Metadata for this raster can be found on the Geoscience Australia website: 

http://www.ga.gov.au/metadata-gateway/metadata/record/gcat_76945 

1.9 Scale, Zooming and Panning 

 
 

The "Map Navigation" toolbar above provides the tools required for moving around your map 

canvas.   

 

● Hover over each of the buttons to see what they do.   

 

 

Question time 

 

c) What do the following tools do?    

  ________________________________________________ 

  ________________________________________________ 

  ________________________________________________ 
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Now based on the topographic map, use the navigation tools to move around to the following 

areas: 

 

 

● Zoom in to the town site Bremer Bay.   

● Pan down along the coastline until you get to Beaufort Inlet.   

● Pan up to Borden Bremer Bay Road and pan right along it until you reach back to the 

Bremer Bay town site.   

● Zoom out until you can see the Fitzgerald River National Park and adjacent Dillon Bay.  

● Zoom back to your last extent (Zoom Last).   

● Zoom out full to the extents of the map (Zoom full).   

Note: The mouse wheel can also be used to zoom in and out of the map canvas. 

 

For the following exercises we won't be requiring the topographic map, so will deactivate it so it 

doesn't show in the map canvas: 

 

● Deactivate the "GA_topo_mga50" layer in the table of contents (hint: uncheck the box next 

to the name in the table of contents) 

 

1.10 Adding OpenLayers (i.e. Imagery) 

We can add extra functionality to QGIS by using "plugins". Plugins are important components of the 

open source QGIS software, written by QGIS developers and users who wish to extend the core 

product. These plugins are made available for all users through the Plug-in Manager. 

One of these plugins allows you to view online imagery such as Google maps and Open Street 

Maps, two very useful additions to your workspace.   

Bremer Bay  

town site 

Beaufort Inlet 

Borden Bremer  

Bay Road 

Fitzgerald River  

National Park 

Dillon Bay 
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In the Menu Bar: 

● Click on "Plugins > Manage and Install Plugins". 

 

● Under the "Installed" tab, review which plugins you already have (you can review more 

details on the plugin by clicking on it). 

● Search and select a plugin called "OpenLayers Plugin". 

● Sometimes this comes pre-installed so just ensure the tool is checked.

 

● If not click on the “All” tab.  

● Search for the plugin again and select it.  

● Click “Install plugin”. 

● Click "Close". 

The "OpenLayers" plugin allows you to add Google and Bing maps to your table of contents as a 

layer. To access these layers, in the Menu Bar: 

● Click "Web". 

● Hover over "OpenLayers plugin". 

A list of available layers will appear.   

● Hover over “Google Maps” and select “Google Satellite”. (This will add the layer to the 

table of contents). 

● Activate the "Google Satellite" layer and drag to above the "Islands" layer. 

● Loading time is dependent on your internet connection. 

● If the imagery only partially shows, right click on the “Mainland” layer and click “Zoom to 

Layer”.  

You should now be able to see some of your layers on top of the Google Satellite imagery.  As 

Google has its own CRS, your map will be projected 'on the fly' to this CRS. 

● Once you have had a play with the imagery, remove it from your workspace as we will no 

longer need it.  

● Right click on the “Google Satellite”.  

● Click “Remove”. 

● Click “OK”.  
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Note:   Google have legal caveats to how you can use their images for maps and publications.  

Contact the Google Service Team for more information. At present you cannot export a 

map with OpenLayers (sometimes this works but the imagery in miss-aligned).  

 
Note: These plugin layers may need to be re-added or reconfigured every time you open up your 

workspace. 

 

Note: If you receive an error message when loading imagery from OpenLayers to a blank 

workspace, add a vector layer before loading the OpenLayer imagery then right click and 

zoom to that layer. 

 

1.11 The Coordinate Reference System (CRS) 

A Coordinate Reference System (CRS) is an integral part of spatial data because it determines 

where data is located in the spatial world.  It is the framework on which a GIS can compare one set 

of spatial data (e.g. soil landscape zones) to another (e.g. vegetation quadrat locations).  Creating 

or amending data in the wrong CRS can cause it to be corrupted, inaccurate or just plain non-

sensible.  Incorrectly defined CRS systems are one of the main factors that lead to corrupted 

datasets and analysis results. 

 

 

Remember: Spatial data can be represented in Geographic or Projected 

coordinate systems. A Geographic system is based on approximating the earth as a 

sphere, whereas a projected system attempts to project parts of the earth onto a 

flat plane. An analyst should choose to work in different projected coordinate 

systems depending on whether they are calculating areas accurately or calculating 

distances accurately or wanting a visually accurate display. 

 

To show spatial data correctly on a map, it must have coordinates and the correct coordinate 

system defined.  So for the same point location on the ground, the location values (e.g. 

coordinates) are very different when referenced in different CRS’s. 

 

 

  
 

Geographic Coordinate Systems Projected Coordinate Systems 

Latitudes and Longitudes (degrees) Eastings and Northings (metres) 

 

So for the same location, the coordinates in the Geographic Datum of Australia (geographic) and 

the Map Grid of Australia - Zone 50 (projected) would be: 

 

E

N
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GDA94  MGA Zone 50 

Longitude:  118.94332 Easting: 679225 

Latitude: -34.11793 Northing: 6223062 

 

If you have a GDA point and try and map it in a MGA Zone 50 projection, your point will end up in 

an unexpected location. This is because a map that is expecting a 6 digit Easting and 7 digit 

Northing, is getting 3 digit and 2 digit values.  

 

    
 

Mapping a point in GDA94 Mapping Geographic Coordinates  

Longitude:  118.94332 in Eastings and Northings 

Latitude: -34.11793 Easting: 118.94332 

  Northing: -34.11793 

1.11.1 Your data CRS 

To check which CRS your data is in: 

 

● Right click the "Roads" layer. 

● Click "Properties" 

● Click "General". 

This shows you the general information of your dataset.  The CRS information will be listed under 

"Coordinate reference system". 

 

 

Question time 

 

d) What CRS is your "Roads" layer currently set in?  ____________________________ 

 

 

● Click "Cancel" 
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1.11.2 Your workspace CRS 

Your workspace also has a CRS.  To check which CRS you are using in your workspace, in the Menu 

Bar: 

● Click on "Project > Project Properties > CRS". 

● Your CRS will be shown at the bottom under "Selected CRS". 

 

 

Question time 

 

e) What CRS is your workspace currently set in?  ____________________________ 

 

 

At the top of this CRS page, there is a check box named "Enable 'on the fly' CRS transformation 

(OTF)".  Ensure it is activated. 

 

 
 

When activated, it allows you to allocate a CRS for the workspace. This means that any layer in 

your workspace that has a different CRS defined will still overlay correctly (presuming your layers 

are intended to display in the same location in the first place!). 

 

So it is possible to show both geographic coordinate system data and projected data in the same 

workspace, or temporarily change the CRS of the workspace for geoprocessing and measuring.  

 

● Click "Cancel" 

Note: The 'on the fly' option will turn on automatically as soon as you add different CRS defined 

 data into your workspace unless you change this in the settings. 

 

Why is this important? If your environmental analysis and conclusions are based on 

the area of something, like weed control area vs. money spent, or change in plant 

disease affected area over time -then you need your calculations to be accurate. 

In this case, all of the input layers should be in the same CRS – and projected rather 

than geographic. If you are more interested in overlaying layers and interpreting 

things visually, then ‘on-the-fly’ option is much more efficient than converting your 

data layers to the same CRS. 

 

1.11.3 Setting up the CRS for new data 

Also, to ensure that we have control over the CRS of new data you create, we need to format the 

workspace settings.  In the Menu Bar: 

● Click on "Settings > Options" (these are all the settings you can define in your workspace). 

● Click "CRS". 

● Under "Default CRS for new projects" ensure that "Automatically enable 'on the fly' 

reprojection if layers have different CRS" is checked. 

● Under "CRS for new layers" ensure that "Prompt for CRS" is selected.  This will give us the 

option of setting the CRS for any data, instead of the workspace automatically selecting 

one for you. 

● Click "OK". 
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● We may also need to re-set the workspace projection as we have been viewing a Google 

Imagery layer and this often over-rides all other projections and does not revert even after 

removing the layer.  

● See the coordinates in the info bar at the bottom of the workspace.  

 
 

● From what you have learned this does not look like typical latitude/ longitude values 

(geographical) or easting/ northing values (projected) for the area we are working in as 

there is a minus sign in front of the northing coordinate. This projection system is called a 

“Pseudo Mercator” (or “Web Mercator”) and is a standard for web mapping applications.  

● As long as "Enable 'on the fly' CRS transformation (OTF)" is checked in the workspace settings 

all your other loaded layers should overlay correctly with the imagery however once the 

imagery is removed we have to re-set the workspace to the CRS that you were working in. 

● Go to “Project > Project Properties”. 

● Click on the “CRS” tab. 

● Type in the “Filter” text box “GDA94”. 

● Select the top result. 

 
 

● Click “OK”.  

● Your workspace will now show latitude and longitude coordinates in the info bar.  

  
 

Note: Knowing what CRS your data is in is good spatial practice.  As the workspace automatically 

 changes data CRS on the fly, you may not be aware of any CRS issues - which could 

 potentially cause problems later on when calculating or geo-processing data. 

1.12 Using the Info Bar 

The Info Bar at the bottom of your workspace shows you general information and offers some tools 

for your workspace.  This includes: 

 

● the coordinate location of your cursor,  

● the scale of your data in the map canvas, 

● the magnifier tool to zoom in statically, 

● the rotation tool to rotate your map view, and  

● the workspace CRS ID. 
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Note: If the workspace CRS ID is greyed out, it's because the workspace does not have the 

 "Enable 'on the fly' CRS transformation" activated. 

 

Note:  EPSG stands for "European Petroleum Survey Group".  They publish a database of 

 coordinate system information and documents on map projections and datums from 

             around the world. These standards are used internationally throughout the spatial  

 community. 

 

● Hover over each of the Info Bar buttons to see pop-up information on what they show. 

1.12.1 Coordinate location 

● Using your cursor, hover over the Bremer Bay town site location. 

 

 

Question time 

 

f) What is the estimated coordinates of the town site?  ____________________________ 

 

g) Are these in latitudes and longitudes?  Or easting and northings?     ___________________________ 

 

1.12.2 Scale bar 

The scale of a map is the ratio of the map distance to the corresponding distance on the ground. 

Why is this important? In cartography, there are two confusing terms 

related to scale that you may encounter. A ‘large-scale’ map is one 

that has a low scale ratio (e.g. 1:1000) and shows objects on the 

ground as relatively large. That is, compared to a ‘small-scale’ map 

where the scale ratio is high (e.g. 1:1,000,000) and shows objects as 

relatively small. A large-scale map could show your field work around 

a wetland, whereas a small-scale map would show all the wetlands in 

the region. 

 

● Click on the scale arrow to see the range of scale drop down values. 

The scale bar format indicates 1 measurement in the map is X 

measurements on the ground. 

 For example: 1: 1,000,000  

 1 unit in the map canvas is equivalent to 1 million units in reality. 

 

 

Question time 

 

h) What scale value from the drop down list allows you to zoom in the closest to the data in the 

map? ___________________ 

 

i) Are you able to type in your own scale value? (hint: press "Enter" after typing in a value)  

 

Coordinate location Magnifier Rotation Workspace CRS ID Scale bar 
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____________________________________ 

 

1.12.3 Workspace CRS ID 

● Hover over the CRS ID (EPSG) value to see the name of the CRS. 

We are able to change the workspace CRS from this location. 

● Click on the CRS symbol in the Info Bar.  

● Ensure the "Enable 'on the fly' CRS transformation (OTF)" is activated. 

● Find and select the CRS "GDA94 / MGA zone 50" 

 
 

● Click "OK". 

This will change the DISPLAY of all your data in your workspace to "GDA94 / MGA zone 50" (not the 

actual projection of the layers individually but how the layers are displayed in the map canvas). 

 

Projections such as these are used for determining areas and for geoprocessing outputs based on 

measurement, such as buffers (which we will cover later in the training). 

 

The workspace is now in an "on the fly" projection of MGA Zone 50.  Review how the data in the Info 

Bar has changed, namely: 

o The data in your map canvas should now be slightly askew. 

o The coordinates in your info bar should now be showing in easting and northing. 

o The EPSG would have changed to a new CRS ID. 

 

 

Question time 

 

j) What is the EPSG of your workspace now?  ____________________________ 

 

 

1.13 Changing QGIS keyboard shortcuts (optional extra) 

You can set or add your own QGIS keyboard shortcuts via the Menu Bar: 

 

● Click "Settings > Configure shortcuts". 

● Click the Action you would like to update. 

● Click "Change". 

● When "Input" appears, click the action you would like the shortcut to be (i.e. Ctrl + X). 
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● Click “Close”. 

1.14 Additional help 

For additional help and information on QGIS functions and tools, in the Menu Bar: 

 

● Click "Help > Help Contents". 

● Search for your issue. 

1.15 Rendering behaviour options 

QGIS has the option to render data over your various CPU cores which makes your data load 

faster.  Since some of the data layers you work with could be very large and you may find yourself 

adding and removing data layers frequently, it might make sense to set QGIS to render them in 

parallel so as to make the application more efficient. 

To turn on this rendering option, in your Menu Bar: 

● Click "Settings > Options". 

● Under "Rendering", check "Render layers in parallel using many CPU cores". 

● Click "OK". 

Save and close your workspace. 

 

End of Exercise 1.  
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2.0 Exercise 2 - Data structure and review 

In this exercise we will focus on the following topics related to data structure and review: 

 

• Identifying data (vector and raster) 

• The attribute table 

• Selecting data 

• Measuring areas, distances and angles 

• Adding and removing toolbars 

• Data formats 

To ensure consistency, we have created a QGIS workspace for you for this exercise.  To begin, 

open up the Exercise 2 workspace provided. In your training data folder: 

● Locate folder "01_Training_Data\00_Workspaces".   

● Open “Exercise_2_GAIA".Now we need to save it in your working folders.   

● Once the workspace is open, in the top toolbar, click "Save As".   

● Save in the folder "02_Training_Outputs\00_Workspaces" as "Exercise_2.qgs" (remember to 

navigate to your output folder “02_Training_Outputs). 

2.1 Identifying vector data 

Identifying data allows you to review the attributes that have been saved within the dataset for a 

feature. For example, this could be a property boundary, a park, a road, a town site, and so on. 

● Click the "Nature Reserves" layer to activate it. 

● Click the "Identify Features" tool in the top toolbar. 

● In the map canvas, click on the large reserve located on the top right of the data. 

● The polygon should be highlighted a different colour.  An "Identify Results "window will pop 

up listing all the Features and Values associated with that polygon (depending on settings 

the info tool may also pop up in the table of contents). 
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Question time 

 

a) What is the "FEATTYPE" (or feature type) of this reserve? _______________________________________ 

 

 

Note:   You can only access the Identify Features tool once you have selected (activated) a layer.   

 

Note:   You can resize the pop up window by hovering over the right hand border.  When the 

 cursor changes to a double ended arrow, extend the border out further so you are able to 

 see all the details in the value field.   

 

The Identify Tool also tells us that the reserve is: 

o Named "Fitzgerald River National Park". 

o The authority is the "State/Territory National Parks and Wildlife Service or Equivalent" 

o The data was sourced from "Geoscience Australia". 

 

Use the "Identify Features" tool on the other layers to answer the questions below (remember you 

need to select a layer in the table of contents before you can identify it): 

 

 

Question time 

 

b) What is the name of the only town?   ____________________________________ 

 

c) What are the names of two of the islands? ____________________________________ 

 

d) Name a type of road class?   ____________________________________ 

 

 

● Click the “Clear results” icon at the bottom of the “Identify Results” tool. 

 

● Close the "Identify Results" window. 

2.2 Identifying raster data 

We can also identify the values within grid cells of a raster layer: 

 

● Activate the "GA_Topo_mga50" layer so you can see it in the map canvas. 

● Click on the "GA_Topo_mga50" layer to select it. 

● Click the "Identify Features" tool in the top toolbar. 

● In the Map Canvas, click on the large reserve located on the top right of the data. 

 

 

Question time 

 

e) What details come up in the information window?  __________________________________ 

 

f) What do you think these values represent?  __________________________________ 
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Note:   Rasters do not contain attribute tables and usually only contain a value for each grid/ cell. 

This could be an elevation height, or as is commonly the case with imagery, a 

red/green/blue value indicating a colour. Rasters could store values for any variable like pH, 

average wind speed, temperature, soil moisture etc. 

 

Raster layers also have properties, but they differ greatly from vector layers. 

● Right click the "GA_Topo_mga50" layer. 

● Click "Properties" 

● Review the different details under each tab. 

● Click "Cancel". 

Why is this important? The Layer Properties window is the central place to change the way 

data for a layer is displayed in QGIS. In the properties of a vector layer you have a wide 

range of controls to change the symbology, add labels and work with tables. In a raster 

layer properties it is more about the colour ranges applied, statistical display adjustments, 

and settings to make QGIS more efficient in rendering that gridded data. The properties are 

also where you view the layer CRS.  

2.3 Removing layers 

As we will not be using the raster layer in the following exercises, remove it from the table of 

contents. 

● Right click “GA_topo_mga50" in the table of contents. 

● Click "Remove". 

● Click "OK". 

2.4 Reviewing vector attribute tables 

Using the "Identify Features" tool allows you to see the attributes of one item at a time.  The attribute 

table of a layer lets you review multiple features all at once. The attribute table is similar to a 

Microsoft Excel table as it shows features and values in separate rows and fields. Within the attribute 

table you can do things like sort records on a column, perform selections and run summary 

statistics. 
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The different areas of the Attribute table are as follows; 

 

1) Layer name:   The layer the attribute table belongs to. 

 

2) Table details:   Shows how many features are in the table, how many are selected, 

    and how many are filtered.   

 

3) Toolbar:   Contains tools for manipulating the table.  

 

4) Attribute name:  The attribute name, or field name, is the title of the field. 

 

5) Features:   Contains all the information related to one feature in the   

    layer in one row. 

 

6) Row IDs:  The attribute table row id for each feature. 

 

7) Values:   The information found within the cell. 

 

8) Data display format:  Allows user to toggle between different viewing formats:  table format 

    (shown here) or form format. 

2.5 Attribute table view 

To review the attribute table: 

 

● Right click the "Nature Reserves" layer in your table of contents. 

● Click “Open Attribute Table". 

● Click on row ID “6" and review the map canvas. The Fitzgerald River National Park should be 

highlighted (if you can't see the map canvas, resize or move the attribute table until both 

are visible). 

● Use the scroll bar at the bottom of the attribute table to review all the values found within 

this feature. 

Layer name Table details Toolbar Attribute name / field name 

Features 

Row IDs 

Values Data display format 
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● Click the "NAME" field name to order the values alphabetically. 

 
 

● To resize the fields, hover over the edge of the field.  When a double sized arrow appears, 

click and drag the arrow to make the field larger. 

2.6 Attribute form view 

Although this type of table is informative, table formats can be difficult to read and review - 

especially when dealing with very large attributes tables.  QGIS gives the option of viewing 

individual features in a form type format.   

● Click the "Form View" button found at the bottom right of the table.  

 
 

To change the field: 
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● Click on “abc ####” drop down (this name changes depending on last usage), hover over 

“Column Preview” and choose “abcName” from the list. 

● You will now see the form view for the field “Name”. 

● Click on the "FITZGERALD RIVER NATIONAL PARK" value listed to the left. 

 You should now see all the attribute details related to that park appear to the right.   

 

 
 

● Hover over "Column Preview" again from the form set drop down. 

● When the drop down appears, all the available field names will appear.  Selecting one of 

these will show your data via that field type.  

● Click on "FEATREL". This will bring up the attributes listed by the recorded dates. 

● Click back to "Table View"   found at the bottom right of the table. 

● Close the table (click on the cross on the top right corner). 

● In the top toolbar in your workspace, click "Deselect features from All Layers" to unselect the 

national park.  

● Click "Save". 

Note: You can also open the Attribute table from the Attributes Toolbar located in the  

 top toolbar  but remember to activate your desired layer first.  

 
Now review the attribute tables of your layers to find the following information: 

 

 

Question time 
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g) How many lakes are recorded in the "Lakes" layer?  ______________________________ 

 

h) Which "Nature Reserve" has a "FEATREL" value of 2002-03-20? ______________________________ 

 

i) How many "FORMATION" types are in the "Roads" layer?   ______________________________ 

 

j) What is the row ID for the smallest sized area in the Native Vegetation layer?  (Use the  

 

"SHAPE_Area" field)______________________________ 

 

2.7 Selecting data 

The selection tool enables you to specifically select various elements in 

the map. 

● Select the "Nature Reserves" layer in the table of contents. 

● Click "Select Features by Freehand".  

● Click the map canvas and drag your cursor around the reserves found to the left of the 

"South Coast Highway". 

● Now draw a very rough polygon similar to the orange dashed boundary shown in the 

image below (hold down the left mouse button, the area you are selecting will become 

opaque white): 

 

● The nature reserves selected will come up a different colour (default is yellow). 

● Open the "Nature reserves" attribute table. 

● Change the select button to "Show Selected Features" (found in the bottom left corner). 

 
 

The table will now only show the datathat was selected. 

South Coast Highway 
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Question time 

 

k) How many reserves are selected?  ______________________________ 

 

 

 

● To unselect the data, either click "Unselect all" in the attributes table or in the top toolbar in 

the workspace.  

● As there are now no selected features the attribute table will be empty.  To see all the 

attributes again, change the select button back to "Show All Features"   

● In the attribute table, sort by “NAME” and click on row ID "6" to highlight the "CORACKERUP 

NATURE RESERVE". 

 
 

● In the attribute table toolbar, click "Zoom map to the selected rows" .  This will zoom the 

map canvas to the extents of the "Corackerup Nature Reserve". 

● Close the attribute table. 

 

2.8 Measuring areas, distances and angles 

The "Measuring" tool in the top toolbar, allows you to measure lines, areas and angles in your Map 

Canvas.   There are three options: 

o Measure Line   
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o Measure Area   

o Measure Angles   

 

● Click the small arrow to the right of the Measuring tool.   

● Select "Measure Area". 

● Click “New”. 

Roughly click around the perimeter of the "Corackerup Nature Reserve".  This will bring up 

the Measure window which calculates the area as you click around it. 

● Right click to finalise the measurement. 

 

Note:   QGIS will change the measurement based on the size you are measuring. 

 m2: 0 - 3000m2 

 ha:  1 - 100ha  

 km2: 1km2 and greater  

 

Question time 

 

l) What is the estimated total area of the reserve?    ____________________________ 

 

 

Note: Measuring data in this way is only a very rough estimate.  Exact areas based on the shape 

 can be calculated using an expression.  Expressions will be discussed later on in the training. 

 

● Close the measuring window. 

● Zoom your map canvas to the full extent.  

● Deselect any features that may be still selected.  

2.9 Adding and removing Toolbars 

There are also additional toolbars and tools that you can use in your workspace.   

 

● Right click the grey space located at the top of the workspace. 
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● Deactivate the "Layers Panel" and review how the workspace changes. 

● Re-activate the "Layers Panel" toolbar. 

● Ensure the "Label Toolbar" is activated (we will use this later on in the exercises). 

● Activate the "Browser Panel”.  This panel allows you to review and add data from your 

computer (as another alternative to using Windows File Explorer). 

● Use the "Browser Panel" to find your training data on your computer. 

● Locate the folder "01_Training_Data\01_Shapefiles\Bremer_Bay". 

● Double click "i5012_watercourselines.shp". 

● Move the layer under "Lakes" and rename it to "Rivers". 

Note: You are able to move toolbars around the workspace by 

 dragging and dropping dotted panel. 

 

2.10 Save data into a different format 

● Right click the "Roads" layer. 

● Click "Save As". 

● For "Format" select "GPS eXchange Format [GPX]". 

● Save as "Roads" in the folder "02_Training_Outputs\02_Excel" (Browse for it). 

● Click “Save”. 

● Uncheck “Add saved file to map”. 

● Click "OK".   

This file is now in a format that can be uploaded into a GPS. 

2.11 Copy values from an attributes table into an excel spreadsheet 

● Right click the "Nature Reserves" layer. 

● Click "Open Attribute Table". 

● Highlight all the rows in the table by clicking the “Select all” icon   

● On your keyboard, click "Ctrl +C". 
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● Open Microsoft Excel. 

● Click in a cell and click "Ctrl + v" (or right click "Paste"). 

● Save the spreadsheet as "Nature_reserves.xlsx" in the folder "02_Training_Outputs\02_Excel". 

● Close the spreadsheet. 

● Unselect all records and close the attribute table.  

2.12 Adding decorations (optional extra) 

We are also able to add mapping elements to our map canvas (although you will not be able to 

see them when we create our map).  These map canvas elements are called "decorations" and 

are used for assisting navigation around your map. 

2.12.1 Scale Bar Decoration 

In the Menu Bar: 

 

● Click "View > Decorations > Scale Bar". 

● In the "Scale Bar Decoration" window, select the following: 

o Activate “Enable scale bar” 

o Placement: Bottom Left 

● Click "OK”. 

2.12.2 Grid Decorations 

In the Menu Bar: 

 

● Click "View > Decorations > Grid". 

● In the "Grid Decoration" window, select the following: 

o Activate "Enable grid" 

● Click "OK”. 

Save your workspace. 

 

2.13 Extent Overview 

This is a useful way of navigating around the map canvas when digitising at a small scale.  

 

● Right click anywhere on the top toolbar.  

● Check “Overview Panel”. 

● In the table of contents right click on the “Mainlands” layer. 

● Click “Show in overview” (you may need to drag the edge of the overview panel to 

enlarge it).  

● Now zoom into a scale of 1:80,000 and pan around the map. You will see the extent of your 

map canvas display in the overview.  
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● Remove the “Overview Panel” from the table of contents.  

Save and close your workspace.  

 

End of Exercise 2.  
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3.0 Exercise 3 – Symbolising and labelling data 

 

To begin, open up the Exercise 3 workspace provided.   

In your training data folder: 

● Locate folder “01_Training_Data\00_Workspaces".   

● Open “Exercise_3_GAIA" and save to your working folders under 

"02_Training_Outputs\00_Workspaces" as “Exercise_3.qgs". 

3.1 Simple symbology 

Symbology is how the data looks in the map canvas and is a critical component of good map 

making, and often the most time consuming to get it right.   

To change symbology: 

● Double click the "Mainland" layer in the table of contents to bring up the layers properties. 

● Click “Style”.   

 

 

 

 

 

 

● There are various ways to change colours. 

● Click on the second symbology level (this is “Simple fill” by default but can be a number of 

others depending on last used). 

Layer Property 

Table of 

Contents 

 

Symbol type Layer name 

Transparency level of symbol layer 

Symbol layer 

Saved Symbology Styles 

Transparency level of Layer 

Blending mode of Layer 
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● Under "Symbol layer type", click on the "Fill" colour button. 

 

● Click on the “Color ramp” tab. 

 

● Select a light cream colour from the colour selector.   

● Click "OK". 

 

This will give your "Mainlands" data a fill colour of light cream.  We can also change the border 

colour and type as well. Note that there are various options for selecting colours.  

● Under "Symbol layer type", click on the "Outline" colour button. 

 
 

● Click on the “Color Wheel” tab. 

 

● Select a light brown from the colour wheel and click "OK". 
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● Under "Symbol layer type", change the "Outline style" to "Dash Line" 

 

● Click "OK" 

Your "Mainlands" data should now be a light cream, with a light brown dashed border. 

 

We will now change the symbology of the other layers to a more suitable style. 

 

Towns 

● Simple marker fill colour:    Orange 

● Simple marker outline colour:   White 

● Simple marker size:     4mm 

● Simple marker outline width:   1mm 

 

 
 

Lakes 

● Simple fill colour:     Light blue 

● Fill style:      Dense 1 

● Border style:      No Pen 
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Rivers 

● Simple line colour:   Medium blue (Red: 166, Blue: 206,  Green: 227) 

 

 
 

Note: A great way of choosing colours for symbology theming is to use the colour picker: 

 

  
 

 

Native Vegetation 

● Fill:       Saved style "wine” 

● Layer Transparency:   30% 
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Note: If you don't have any saved styles, you can import them into your workspace by going to: 

 "Settings > Style Manager > Share > Import”.  In File Explorer, browse and 

 select the file "01_Training_Data\05_Other\Styles.xml".  Click "Select all" then "Import". 

 Close the window to return back to the workspace. 

 

Nature Reserves 

 

Load a saved style for your layer: 

 

● Double click the "Nature Reserves" layer. 

 

● In the layer properties window, click “Style”. 

 

● In the bottom left of the window, click "Style >Load Style". 

 

 
 

● Browse to the file “Nature_reserves_style.qml" in “01_Training_Data\05_Other". 

 

● Click "Open". 

 

The layer should now be restyled to light grey with diagonal stripes. 

 

● Click "OK". 

 

Note: There are various options to save your preferred styles to use between or within your QGIS 

workspaces.  From the layer properties “Style” tab click “Style> Save Style > QGIS Layer Style 

File” and save a qml file to your working folder for distribution with your shapefile: 

 

  
 

             Alternatively, you can save styles to the symbology library – click “Save” below the layer 

style options and give it a name: 
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You can also copy symbology to layers of the same geometry (i.e. polygon to polygon): 

● Right click the "Mainland" layer in the table of contents. 

● Click "Styles > Copy Style". 

● Right click the “Islands” layer. 

● Click "Styles > Paste Style". 

The Islands should now have the same symbology as the Mainlands layer.  If you try and save styles 

over different geometries, you should receive an error message. 

There is also a useful shortcut to changing the colour of a layer in the Style dropdown: 

 

Note: Colours from your "Select Color" window can also be saved for future use (ideal if you are 

 using the same colour for different layers (i.e. different water body types). 

 

 When you have selected your colour in the style properties, click the arrow button to save it 

 to the workspace: 

 

  
  

 

 

Question time 

 

a) For polygons, what "Fill style" ensures no fill colour is shown in the Map Canvas? 

____________________________ 

b) Is there an option to save the style that you have created? (Review options found in the "Style" 

window) ____________________________ 

c) What are the four options for selecting colours (Hint: one is “Color ramp”)    ___________________ 

 

______________________________ 



QGIS Videos User Training Manual 

Gaia Resources QGIS_Videos_User_Training_Manual_218   42 

 

 

3.2 Categorising symbology 

We also have the ability to colour our data based on field values in the attribute table. 

● Open the "Roads" layer "Properties". 

● Click "Style”. 

● Select the "Categorized" option as the Symbol type. 

● Select "CLASS" as the “Column” value. 

● Change the "Color Ramp" to "YlOrBr". 

● Click the "Classify" button. 

 

A list of all the different types of roads should now be visible.   

 

 
 

The “Value” field indicates the value within your data’s attribute table, whilst the Legend field 

indicates the name that is used in the table of contents/map legends (this will be important when 

we start making our maps further on in the training). 

3.2.1 Reordering symbology layers 

The classification automatically orders the values alphabetically, however this may not be the order 

we need for our data in.  Drag and drop the class values to the following order: 

 

o Principal Road 
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o Second Road 

o Minor Road 

o Track 

o <blank> 

3.2.2 Renaming and removing symbology layers 

We also would like to change the "Track" label to something more descriptive. 

 

● Double click the legend value for "Track". 

● Rename the value to "Unsealed Track" 

 

Note: Changing the name of the label value only changes it within this Workspace only. 

 

We also would like to remove the <blank> value from our classification.  <Blank> values represent 

null values (even if there are no null values in the field the <blank> value will still appear for digitising 

purposes).  As we would like to show only classified roads, we will remove it. 

 

● Click on the <blank> value so it is highlighted. 

 
 

● Click the "Delete" button. 

 

The blank value will now be removed from your classification. 

 

Note: If you need to add missing values, click the "Add" button. 

 

Finally, we need to recolour the roads to give it more logical meaning to the size and width of the 

road. Double click each road’s symbol to change the symbology. 

o Principal Road: 

  Color:  Dark Orange 

  Pen width: 0.5 

  

o Secondary Road: 

   Color:  DarkOrange 

    

o Minor Road: 

   Color:  MediumOrange 

   

o Unsealed Tracks: 

   Color:  Light Brown 

   Pen style: Dash Line 

 

● Click "OK". 

All the changes will now be shown in your table of contents.  The "Roads" layer is partially covered 

by "Native Vegetation" due to the layer ordering in the table of contents. 

 

● Drag the "Roads" layer so it sits above the "Native Vegetation" and “Nature Reserves” Layer. 
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Question time 

d) Another symbol type option is the "Graduated Tool".  Review this tool in one of the layers 

properties.  What do you think it could be used for? 

_________________________________________________________ 

 

 

3.3 Adding labels 

We also have the option of labelling our data with field values found within the data's attribute 

table: 

● Double click the "Roads" layer. 

● Click "Labels". 

● Select “Show labels for this layer” at the top of the window. 

● From the “Label with” drop down choose "NAME". 

● Click "OK". 

Your roads layer should now have labels.  However they are quite sporadic and hard to read. 

We are able to fine tune the symbology with the properties window.  

 

● Double click the "Roads" layer. 

● Click "Labels". 

● Change the following: 

o Text  Font:   Arial 

  Size:   6 

  Color:   A similar orange as the Town point 

    (drag this colour into your custom colours) 

  Type Case:   All uppercase 

 

o Buffer  Activate "Draw text buffer" 

  Transparency: 20% 

   

o Placement Click "Curved"  

  Allowed positions: "On line" (and deactivate "Above Line")  

 

● Click "OK". 

Your roads should now be labelled. Some may be missing, while others are duplicated.   

 

 
 

This is due to the rendering and the automatic placement of the labels.    

 

● Open your "Roads" layer "Properties". 

● Click "Labels". 

● Click "Rendering". 
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● Activate the "Merge connected lines to avoid duplicate labels". 

● Click "OK". 

For the Town layer: 

 

● Add a label to the Bremer Bay town point using the "Name" field and the following 

symbology: 

o Text:  Font: Arial 

   Size: 8 

   Color:  The custom colour orange 

 

o Buffer  Activate "Draw text buffer" 

  Transparency:  20% 

 

o Shadow Activate "Draw drop shadow" 

   Transparency:  50% 

 

When complete, you will note that the label is covering the town point location. To avoid this, an 

offset can be placed on the label for clarity. 

 

● Open the "Towns" layer "Properties" window. 

● Under "Labels", click "Placement". 

● Select "Offset from point". 

● Choose the bottom right quadrant. 

● Under Offset X, Y, add 3 in the left box, and 0 in the right box.   

● Ensure the drop down is set to “Millimeter”. 

● Click "OK". 

This has moved the label 3 points across, enabling the label to be separated clearly from the point. 

 

 
 

Now label the "Nature Reserves" layer with your own format preferences.   

 

The names however, are probably too long for the map.  
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Ideally we would like each word to be shown on a different line. We can do this by wrapping the 

text around a character. 

 

● Open the "Nature Reserves" layer "Properties" window. 

● Under "Labels", click "Formatting". 

● Place a space in "Wrap on character". 

● Change the Alignment to "Centre" (this should cascade and centre the text after each 

space). 

● Click "OK". 

 

 

Investigate the labelling options further to answer the following question: 

 

Question time 

 

e) Do the "Label Placement" options change for a point and a line?   ______________________ 

 

3.4 Adding text annotation 

We also want to add additional text that is not found in our data.   We can do this by using the "Text 

Annotation" tool. 

 

 
 

● In the top toolbar, click the "Text Annotation" tool.  

● Click on your map canvas.  The default text box should appear. 
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Note: These sort of text boxes are good to indicate locations quickly, but they are only saved 

 within the workspace, and cannot be exported into other workspaces (unlike shapefiles). As 

 the point is only a label, it contains no attributes, no location data and no geometry but it  

             does move around with the map extent.  

 

● Double click on the text box to open the "Annotation text" window. 

● Change the following items: 

o Font type: Arial 

o Font colour: Dark grey 

o Text:  Project Camp Site A 

o Map marker: Diamond (recolour to red) 

o Frame width: 0.5 

o Frame color: Dark grey 

 

● By dragging and dropping the text box and the diamond point, resize and place the label 

in the following location: 

 
● Click the “Pan Map” tool (or other navigation tools) to deactivate the annotation tool.    

3.5 Symbology for colour blindness (optional extra) 

Although colour is a great way for beautifying maps - it may not necessarily be used.  Reports may 

be printed off in black and white which may result in loss of distinction between features if they are 

created in similar saturations.    This is also the case for colour blind people who have difficulty in 

distinguishing between reds and greens (around 10% of the male population).  QGIS allows you to 

check your colour schemes easily within the workspace. 

 

● In the Menu Bar, click "View > Preview Mode". 

● Click on each available simulation to see if your symbology needs amending. 

● Click back to "Normal". 

An easy way to create contrast in your symbology is to include pattern as well as colour. 

 

3.6 Advanced symbology for cartographic type outputs (optional extra) 

Additionally, QGIS gives more options regarding creating gradients, selective line colouring, 

inverted feathering and SVG fills for polygons.  This can give your map a more illustrative feel 

without having to export it out into a specialist program. 

 

Gradients 

● In your table of contents, right click the "Lakes" layer. 
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● Click "Properties > Style". 

● Click on "Simple fill" and under "Symbol layer type" select "Gradient fill". 

 

● Select your two colours for the gradient 

● Click "OK" 

As the "Coord mode" is set at "Object", each individual lake has its own gradient.   

To link all gradients together, change "Coord mode" to "Viewport". 

 

Object gradient     Viewport gradient 

Selective Line Colouring 

● In your Table of Contents, double click "Native Vegetation" then "Style". 

● Click on "Simple fill". 

● Change the "Symbol layer type" to "Outline: Simple line". 

● Change the colour to olive green (guess) and the pen width to 5.0 mm. 



QGIS Videos User Training Manual 

Gaia Resources QGIS_Videos_User_Training_Manual_218   49 

● Check the box "Draw line only inside polygon". 

● Set the "Layer transparency" to 60. 

● Click "OK". 

This will colour the inside of the polygon only. 

 

 
 

 

 

 

Inverted Feathering (adds shadows to data) 

● In your Table of Contents, right click "Mainland". 

● Click "Duplicate" (a new layer should appear called "Mainland copy"; make sure it is 

checked). 

● Double click "Mainland copy" then "Style". 

● Change "Single Symbol" to "Inverted polygons" (this turns the data into a mask). 

● Click "Simple fill". 

● Under "Symbol layer type", click "Shapeburst fill". 

● Under "Gradient colors" change the first colour to grey. 

● Under "Shading style" click "Shade to a set distance 5.0mm". 

● Make the "Blur strength" 10. 

● Click "OK". 
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SVG fill 

● In your table of contents, double click "Nature Reserves" then "Style". 

● Click "Simple xxx" (may be “Simple fill”, “Gradient fill” or others depending on your last 

selection). 

● Under "Symbol layer type", change to “SVG fill”. 

● In the SVG Symbols, find a tree SVG and click on it. 

● Change the "Texture width" to 2.0mm 

● Change the colours to medium green. 

● Change the "Layer transparency" to 0. 
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● Click on “Line pattern fill", click the minus button to remove it  

● Click "OK". 

 
 

3.7 Using masks to clip out unnecessary detail 

Masks are used to draw attention to focus areas of a map.  For this example, our area of focus will 

be a provided layer called the "2013 Project Boundary". 

 

● Add the data "2013_Project_Boundary.shp" from your Training data files 

(01_Training_Data\01_Shapefiles\Additional). 

● Drag this layer up to the top of the Table of Contents. 

● Zoom in closer to this layer so you can clearly see it in the map canvas. 

 
 

● In the table of contents, double click the layer "2013_Project_Boundary". 

● Click "Style". 

● Change "Single Symbol" to "Inverted polygons". 

● Click "Simple fill" and change "Symbol layer type" to "Shapeburst fill". 

● In the "Gradient colors" change the first colour to orange. 

● Check the box "Shade to a set distance: 5mm". 

● Change the "Layer transparency" to 40. 

● Click "OK". 

The areas around your boundary should now be faded out. If you want to remove them 

completely, make sure your "Layer transparency" is turned to 0. 
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Note: There is a Masking plugin that can also automate this process.  It also adds functionality 

 around the masking of labels in your map canvas. 

 

Feature Drop Shadow 

 

There are also effects available for shapes. Let’s pretend we want to accentuate the Nature 

Reserve areas as focal points of the map.  

 

● Open the “Nature Reserves” layer “Properties” window.  

● Click on the “Style” tab. 

● Check the “Draw effects” box (bottom left).  

● Click on the effects icon.    

● Check “Drop Shadow” from the list.  

● Click “OK” on the effects window and “OK’ again.  

● Check the changes in the map canvas 

 

● Experiment with other effects such as Inner and Outer Glows, uncheck “Draw effects” in the 

“Styles” tab when you have finished. 

Note: The Feature Drop Shadow will not have the desired effect if you are using a SVG fill. Change 

to simple fill to see the best results. 

 

Symbology Point Displacement and Heatmaps (Optional Extra)  

 

If you are feeling adventurous and want to see some more great cartographic features, 

experiment with the “Point Displacement” and “Heatmap” symbology options. There is a point 
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shapefile to assist with this located in folder “01_Training_Data\01_Shapefiles\Additional” named 

“Random_points.shp”. 

 

Save and close your workspace. 

End of Exercise 3. 

4.0 Exercise 4 - Importing points and amending attributes 

 

To begin, open up the Exercise 4 workspace provided.   

In your training data folder: 

● Locate folder "01_Training_Data\00_Workspaces".   

● Open "Exercise_4_GAIA" and save to your working folders under 

"02_Training_Outputs\00_Workspaces" as “Exercise_4.qgs". 

4.1 Import your own point locations from a spreadsheet 

We have supplied you with a Microsoft Excel sheet for this training.  This can be found under the 

"01_Training_Data\02_Excel"folder. 

● In Microsoft Excel, open the file "Weed_Points.xlsx". (Don't change any of the field values at 

this point. Take a look at the layout of the data). 

● Save a new copy of the file in your "02_Excel" folder in a CSV format.   (This is the format 

used to import locations into QGIS). 

o In Microsoft Excel, click "Save As" 

o Choose the "Save as type" option as "CSV (Comma delimited) (*.csv)"    

  This set up might be slightly different depending on the version and software  

  you are using. 

o Name the file "Weed_Points.csv" and save in the folder 

"02_Training_Outputs\02_Excel" 

o Click "Save". 

o If a message window appears, click "Yes". 

o Close Microsoft Excel (if a message asks if you would like to save your changes, click 

"Don’t Save"). 

● In your QGIS workspace, click on the "Add Delimited Text Layer" on the left side toolbar.  

● In the "Create a Layer from a Delimited Text File", amend the following details: 

● File Name 

o Browse for the CSV file you just created.  

o Click "Open". 

 

● Layer Name 

o Type "Weed points CSV". 

 

● File Format 

o Ensure "CSV (comma separated values)" is activated. 

 

● Record options 

o Ensure "Number of header lines to discard" is 0 (to understand what this 

means enter a value and see what happens to the table preview). 
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o Ensure "First record has field names" is activated (check this on and off and 

see what happens to the table preview). 

 

● Field options 

o Ensure "Trim Fields" is activated (removes unwanted spaces before and after 

values). 

 

● Geometry definition 

o Ensure "Point Coordinates" is activated. 

o X field has the field value "Eastings". 

o Y field has the field value "Northing". 

 

● Double check the CSV settings listed in the bottom window look correct. 

 
 

● Click "OK".   

● You should now be prompted to select the CRS for your CSV layer. Select "GDA94 / MGA 

zone 50". 

● Click "OK". 

Note:   When creating a shapefile from a .csv, remember that there is a 9 character limitation to 

field names. Names with longer characters will be truncated. 

 

● The "Weed Points CSV" layer will now be visible in your table of contents.  Activate it to see 

how it looks in your map canvas. 

● Open the "Weed Points CSV" attribute table to check that all the attributes converted 

across okay.   

4.2 Save CSV points into a shapefile 

Although the points are now visible in the map, we would like to save them in a shapefile format.  A 

shapefile format allows us to edit and amend the data within QGIS: 

● Right click your "Weed Points CSV" layer in the table of contents. 
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● Click "Save As". 

● Change the format to "ESRI Shapefile". 

 

● Save to the "02_Training_Outputs\01_Shapefiles" folder with the details: 

 

o File name:  Weed_points.shp 

o CRS:   GDA94 / MGA zone 50 

 If your CRS is different, change the CRS from "Layer CRS" to "Selected CRS" 

 and browse for "GDA94 / MGA zone 50" 

o Activate "Add saved file to map" 

 

● Click "OK". 

Your "Weed_points" layer should now be visible in the table of contents.   

● Ensure it is activated and located at the top of the layers list. 

● Rename the layer to "Weed Points". 

● As we won't need the CSV file anymore, remove the "Weed Points CSV" layer from your 

table of contents. 

4.3 Selecting and editing attributes 

Now we will symbolise the data: 

 

● Style the layer using categories to show the different species. 

o Use the column "Common_Na".  

o Use the "Spectral" color ramp.   

o Click "Classify" 

o Click "OK" 

 

 

 

Question time 

 

a) What is the potential issue with the classification of data (see Step 4.3 

above)?________________________ 

 

 

4.3.1 Changing Individual field values 

We will need to change the incorrect attribute values in the table to fix up the classification.  This 

ensures all our attributes are standardised - essential for manipulating, filtering and mapping our 

data (we will learn more about these techniques later on in the training). 
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We will need to take the full stop off the "Arum Lily" value, and ensure the correct spelling of the 

"Variegated Thistle". 

 

● Firstly, review your map canvas and find the location of the incorrect values based on your 

colour classification.   

● Right click the "Weed Points" layer. 

● Click "Open Attribute Table". 

● Click on "Toggle Editing Mode"   in the Attribute Table toolbar (This will activate some of 

the buttons that were previously greyed out.) 

Your table of contents will now show your "Weed Points" layer with the editing pencil next to it. 

 

● Click the “Common_Na” field heading to sort the data. 

● Search for "Arum Lily." in your attribute table (hint: there will be two of them). 

● Double click on the value "Arum Lily."  

● When the text turns blue, delete the full stop at the end of the name, so the new value is 

"Arum Lily". 

 

Note:  If your amendments are not showing up in the table after editing the values, refresh the field 

by clicking on the field name twice. 

● Click the "Save Edits" button.  

● Repeat the process and change "Vareegated Thistle" and "Varegated Thistle" to 

"Variegated Thistle". 

● Click off the "Toggle Editing Mode"   in the Attribute Table toolbar and click “Save”. 

● Close the attribute table. 

● Now review your map again. The incorrect values should now be coloured correctly in the 

map, but not the classification to the left under “Layers”.   

● To correct the classification of the "Weed Point" data in your table of contents: 

o Right click the "Weed Point" layer. 

o Click "Properties" 

o Click "Style" 

o Click "Delete all" to remove all the values 
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o Click "Classify" to reclassify your data with the new amendments 

o Click "OK" 

● You will now see only two entries for the two species as there are no spelling errors.  

4.3.2 Deleting rows 

Now we can see the weed locations, we can check the accuracy of their spatial location.  For this 

project, let’s say there is an old weed point that should be removed -located above the 

"Corackerup Nature Reserve".  We are able to do this within the workspace: 

● Click on the “Weed Points” layer to activate it. 

● In the top toolbar, change the "Select Features by Freehand" to "Select Feature(s)".  

● Click on the point just above "Corackerup Nature Reserve" so it changes to a different 

colour (may be difficult to see colour change depending on settings). 

● Right click the "Weed Point" layer. 

● Click "Open Attributes Table". 

● Resize the attribute table so you can see both the map and the attributes. 

 
 

● The selected location should be highlighted in the attribute table. 

● Click on "Toggle Editing Mode"   in the Attribute Table toolbar. 

● In the attribute table toolbar, click "Delete selected features".   In the map, the point will 

now be deleted. 

● Click "Save Edits"  in your attribute table. 

4.3.3 Add a field 

While we are editing the attribute table, we will add a field for additional information. 

● Select "New field" in the toolbar.  
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● Fill out the following details. 

 Name:  Coll_Date 

 Comment: Date sample collected 

 Type:  Date 

● Click "OK". 

● Add another field as follows: 

Name:  Comments 

  Comment: Comments about the survey  

  Type:  Text 

Length: 254 

● Click "OK". 

● Click "Save Edits".  

 

Note:   The different Type options for spatial data are: 

 Whole Number (integer) Length: 10 max   i.e. 1000000000 

 Decimal Number (real) Length: 20 max  Precision: 15 max i.e. 10000.00000 

 Text (string)   Length: 254 characters max  i.e. abc1234!# 

 Date    Date only    i.e.yyyy-mm-dd 

 

Question time 

 

b) What happens when you try and create a longer string than 255characters to the width of 

 a text field?  _____________________________________________________ 

 

4.3.4 Delete a field 

Or alternatively, delete unnecessary fields.  In this case, we want to delete the Projection details as 

it’s already automatically saved as part of the shapefile. 

● Select "Delete field”.  

● Select "Projection" from the list. 

● Click "OK" (the field should now be deleted). 

● Click "Save Edits".  

 

 

Question time 

 

c) What is the shortcut syntax to the "Delete field" tool?  (hint: hover over the tool) 

______________________ 

 

 

  



QGIS Videos User Training Manual 

Gaia Resources QGIS_Videos_User_Training_Manual_218   59 

4.4 Amending fields in the attribute table using the Field Calculator 

Manual data editing works well, but is time consuming if there are numerous features in a dataset.  

However, QGIS allows you to automate multiple field entries using the field calculator. 

 

• Click "Open field calculator".  

 
 

Using the field calculator, we will automatically fill the "Coll_Date" field in our attribute table.  This 

field indicates the collection date of our species: 

 

● Activate the "Update existing field" and below it select the "Coll_Date" field. 

● In the expression box, type '2014-02-02' (including the single quotes – dates must use the 

format of yyyy-mm-dd to be valid). 

If the expression is invalid, an "Expression is invalid" error message will appear. 

If the expression is valid, you should see the date value entered in the “Output preview”. 

 
 

Note: Single quotes are required in expressions to tell QGIS that you are dealing with "Strings", 

“Date” or "Text".  Numbers do not require any quotes. Date fields require the format yyyy-

mm-dd. 

 

● Click "OK". 
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● Click "Save Edits".  

In your attribute table, all records in the "Coll_Date" field should now be automatically updated 

with the value “2014-02-02”. 

 

 

4.4.1 Amend fields in the Field Calculator based on a selection 

If we want to update fields based on a selection, we need to specify this in the expression.  In this 

case, we want to add that Mr Peabody recorded all the Variegated Thistle locations. 

● In the attribute table, highlight all the values of "Variegated Thistle".(Hint: You can highlight 

multiple rows by holding down the Ctrl key and clicking on the Row IDs on the left) 

 

 

Hint: sort the field by clicking on “Common_Na” heading before highlighting. 

● Click "Open field calculator".  

● Ensure "Only update x selected features" is activated. 

● Activate "Update existing field" and choose "Recorder". 

● In the expression box, type 'P. Peabody' (including the single quotes). 

● Check the expression is valid. 

● Click "OK". 

● Click "Ctrl + S" on your keyboard to save your edits. 

The "Recorder" field will now be updated with the new text. 

4.4.2 Select features by using an expression 

Selecting features one by one can be time consuming.  QGIS gives the option of selecting multiple 

features via an expression. 

● Firstly, clear your attribute table selections by clicking the "Unselect all" button (Ctrl + U)  

● Click on the "Select features by using an expression" button .This will bring up the "Select 

by expression" window. 

● Under the search box, click on the small cross to the left of the "Fields and Values" listing.  This 

will show all the fields names currently found in your attribute table. 

 
● Double click on "Species_Na" to bring it up in the expression box. 
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● Under "Expression", click on the "=". The value in the expression box should now have the 

text: 

 
 

● Next to "Load values" on the bottom right, click "all unique".  The unique values of that field 

will appear.   

● Double click 'Silybummarianum' to add it to your expression 

 

● The expression box should now have the text: 

 

(Note the different use of double and single quotes in an expression) 

● Click "Select" then "Close".  

All the rows with the species name "Silybummarianum" should now be selected. Now amend 

the "Comments" field using the Field Calculator: 

 

● Click "Ctrl + i" on your keyboard. 

● Activate "Update existing field" and choose "Comments". 

● Add the text to the expression box: 'Requires further ground truthing'. 

● Check the expression is valid. 

● Click "OK". 



QGIS Videos User Training Manual 

Gaia Resources QGIS_Videos_User_Training_Manual_218   62 

● To unselect all the rows, click "Deselect all".  

● Click "Save Edits".  

 

 

Question time 

 

d) Within the "Field Calculator", what is the symbol for the operator that joins two fields together? 

(similar to the "&" string concatenation symbol in Microsoft Excel.  Hint: hover over the buttons). 

______________________ 

 

 

● You can also add an expression straight in the Attribute Table as a shortcut for simple tasks. 

● From the dropdown list (top left of Attribute Table) select “Coll_Date”. 

● Type ‘2014-03-03’ in the text box next to the sum icon.  

● Click “Update All”. 

 

● The “Coll_Date” field will now be updated.  

● Click off "Toggle Editing Mode"   in the Attribute Table toolbar. 

● Click “Save” and close the attribute table. 

Note: The variety of functions you can use for the field calculator, query and expressions are 

extensive.  A basic list can be found on the QGIS website:  

https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/expression.html 

4.5 Using text field operators in expressions 

 

Operators can be used extensively to manipulate data.  The more common ones for text fields are: 

 

AND, OR, IN, I I, LIKE, NOT 

 

AND selects one type and another type 

 

OR selects one type or another type 

 

IN use IN for list of values 

 

I I  concatenates string data  

 

LIKE selects types based on string structure and wildcards (%)  

 

NOT select everything except a type 
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Now we will practise some more with selecting records based on an expression. 

● Click "Add Vector Layer".   

● Under “Source", click "Browse”. 

● Open the data "01_Training_Data\01_Shapefiles\Additional\Test_Expression.shp". 

● Click “Open” and “Open” again to add the layer to your workspace. 

● Open the “Attribute Table”  

● Click on the "Select features by using an expression" button .    

● Arrange the select by expression tool and the attribute table so you can see both. 

 

 

Now use the select by expression tool to work out answers to questions from e to l. 

For example (and note there is often more than one way to use operators): 

 

Select ID: 1 and ID: 4    "ID" = 1 OR "ID" = 4 

 

Select all sites except Site D   NOT “Location” = ‘Site D’ 

 

Select all sites except Site D   "Location" IN ('Site A', 'Site B', 'Site C') 

  

Select Weeds with a capital A in them: "Name" LIKE '%A%' 

 

Complete the below based on your own expressions, then count how many rows the expression 

selects: 

 

e) Select all the Recorders whose name is "P. Joe" 

f) Select Sites A and Sites B 

g) Select Site B who was recorded by S. Smith 

h) Select sites with an amount more than 1 (you can also use the ">" operator) 

i) Select Weed C and Site C 

j) Select all the Weeds except Weed C 

k) Select all weeds that were recorded by the Smith brothers. 
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l) Select all Site A’s that were recorded in May. 

These basic expressions/queries open up a large amount of functionality in any GIS system so are 

worth remembering. They can also be used to filter features within a map, populate fields in an 

attribute table, and label features by an expression.  

(answers can be found in Section 8.3) 

 

● Close the select by expression tool and attribute table. 

● Remove the “Test_Expression” layer from your workspace as it is no longer required.    

Save and close your workspace. 

 

End of Exercise 4.  
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5.0 Exercise 5 - Creating, modifying and joining data 

To begin, open up the Exercise 5 workspace provided.   

In your training data folder: 

● Locate folder "01_Training_Data\00_Workspaces".   

● Open "Exercise_5_GAIA" and save to your working folders under 

"02_Training_Outputs\00_Workspaces" as “Exercise_5.qgs". 

5.1 Adding features to an existing dataset 

Although we have edited the attributes of the "Weed Points" we now need to add a missing weed 

location to Beaufort Inlet on our map.   

● In your table of contents, right click the "Lakes" layer. 

● Click "Open Attribute Table". 

● Search for "BEAUFORT INLET" and highlight the row. (Hint: sort the "NAME" field 

alphabetically). 

● Close the attribute table. 

● Now zoom to the highlighted inlet on your map using the "Zoom to Selection" tool in the top 

toolbar.  

● Pan your map canvas up until you can see the end of "Millers Point Road". 

 
 

● In the table of contents, select the "Weed Points" layer and turn on editing by selecting the 

“Toggle Editing” button in the top toolbar. 

 
This editing toolbar allows you to add, delete and modify data. 

 

● The pencil will show next to the “Weed Points” layer showing it is in editing mode. 
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● Click the "Add feature" button in the editing toolbar.  For a point layer, this symbol will be 

three little points  .  Clicking this tool will turn your cursor to a small target symbol in the 

map canvas. 

● In the map canvas, click the very end of "Millers Pint Road", near the inlet. 

● The attribute form for that dataset will appear (don’t worry if you can’t see the cross hairs). 

 

● Fill out the attributes for this feature as follows: 

o ID   29 

o Common_Na  Arum Lily 

o Species_Na  Zantedeschia aethiopica 

o Coll_Date  2014-03-03 

o Amount  1 

o Recorder  S. Smith 

 

● Leave the other values blank 

● Click "OK" 

● In the editing toolbar, click "Save Edits".   

The new, appropriately coloured weed location should now be visible in your map canvas. 

 

● Click on "Zoom Full" in your top toolbar to pull back to your map canvas full extents.  

● Click "Deselect Features from All Layers" in the top toolbar to unselect the Inlet.  
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5.2 Adding X and Y coordinates based on an expression 

Although you have a new point, the Eastings and Northing fields are empty as these are not 

automatically created.  To update these accurately, you can add the values using an expression. 

● Right click the "Weed Points" layer and open the attribute table. 

● Highlight the row of your newly created feature. 

● The "Toggle Editing Mode”  should already be turned on. 

● Create the below expression for your "Easting" field ($x can be found in the Function list 

"Geometry"). 

 

● Click "Update Selected". 

● Repeat the process, but for "Northing" and using the expression “$y”. 

 

● Save your changes.  The new coordinates should now be visible in your table. 

● Deselect features from all layers.  

 

Note: If you cannot see your changes after running an expression, try resorting the field to refresh 

it. 

5.3 Modifying existing spatial data 

We also discover that we need to move one of the points as currently it is located on the road.  The 

weed point in question is ID 26. 

●  Ensure the "Weed Points" layer is still selected in the table of contents.  

● Use the "Identify Features" tool to locate the weed point ID: 26.
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● Zoom in closer to the weed location. 

● Once located, close the "Identify Results" window.   

● The "Weed Points" layer should still be in editing mode.  If not, click on "Toggle Editing" in the 

top toolbar.  

● Click the "Move Feature(s)" tool.  

● Click on weed location "ID:26" and drag it north, slightly off the road. 

● Click off the “Toggle Editing” button in the editing toolbar and click "Save”. 

● Zoom out to the full extents of your map canvas.  

5.4 Importing GPS files 

Next we need to create our survey boundaries.  We have been given the boundary extents in GPX 

format, the standard output from Global Positional Systems (GPS). 

● Click "Add Vector layer".  

● Click "Browse" and locate the folder "01_Training_Data\03_GPS". 

● Ensure "GPS eXchange Format [GPX] [OGR] (*.gpx, *.GPX)" is selected as a file type or just 

select “All files (*)”. 

● Select the file "Survey_boundary_extents.gpx".  

● Click "Open". 

● Click "Open" again. 

 

 

Question time 

a)  What are the layer name options in the GPX file? __________________________________ 

 

 

● Select the layer name "waypoints" (it has a geometry type of "Point”). 

● Click "OK". 

● Activate the layer in the table of contents and drag it to the top of the layers. 

So we can see the data more easily, deactivate all the layers in your table of contents except for 

"waypoints" and "Mainland". 
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● Save your workspace. 

5.5 Creating a new shapefile 

We can now use these GPS locations as ground truthing locations enabling us to create site 

boundaries. Before we can do this we need to create a blank shapefile to store the boundaries in.  

● Click "New shapefile" in the left hand side toolbar.  

● Select the Type as "Polygon". 

● Specify the CRS as "GDA94 / MGA zone 50". 

● Under “New field” create the following field: 

o  Name  Site_name 

o Type  Text data 

o Length  50 

o Click “Add to fields list” 

 

Note:   Field names must be less than 10 characters in length or they will be automatically 

truncated. Use underscores instead of spaces and don’t use special characters 

(~`#@%^&*’<>).  

 

● Click “OK”. 

● Save data as "Survey_Boundary.shp" in the folder "02_Training_Outputs\01_Shapefiles". 

● Click "Save".  QGIS will automatically add the shapefile to your table of contents. 

● Activate your new layer in the table of contents. 

● Rename it to "Survey Boundary". 

● Change its style to: 

o  Symbol layer type:   Outline: Simple line 

o Color:   Red 

o Pen width:  1.00 millimeter 
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● Click "OK".  

● You will not see the red outline as we have not started adding any geometry to the new 

shapefile (open the Attribute Table and you will see that it is blank).  

5.6 Using the snapping tool 

Before we get started digitising we want the ability to align our boundary corners exactly to the 

points given to us in the GPX file.  To do this, we need to activate snapping for the "waypoints" 

layer.  In your Menu Bar: 

● Click "Settings > Snapping Options". The "Snapping and Digitizing Options" toolbar should 

appear. 

● Ensure the Layer selection is set to “Advanced” (if you can’t see the same information as 

below, select “All layers” from “Snapping mode” dropdown and then “Advanced” again”.  

 
 

● Change the snapping tolerance of the waypoints to: 

o Mode:  to vertex 

o Tolerance: 15.000000 
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o Units:  pixels 

 

● Make sure “waypoints” is checked. 

● Deselect all the layers except for "Waypoints" (we don't want our data to "snap" to any other 

dataset). 

 

 

Question time 

 

b) Other than vertex, what else can you snap to? ____________________________ 

 

 

● Click “OK” on the snapping options dialog box. 

Note: Although your other layers may be deselected in the table of contents, you are able to still 

snap to them when you are digitizing.  Deselecting them in the "Snapping" toolbar stops this 

from occurring. 

 

Note:   The tolerance for snapping can be set to either pixels or map units.  Pixels are based on your 

current screen pixel size.  Map units are based on the units specified in your workspace (see 

"Project > Project Properties > General").  Setting the tolerance to pixels is useful as you won't 

need to change the tolerance if you are zooming in and out of your map canvas.   

 

Note: Tolerance amounts for snapping are dependent on your data.  Although there is no ideal 

number, the defaults in QGIS are usually sufficient.  However, if you do have issues snapping 

successfully, a larger tolerance may be the solution. 

5.7 Digitizing new shapefile features 

We are now ready to create new features within our blank “Survey_Boundary” layer using the 

loaded GPS locations. 

● Ensure the "Survey Boundary" layer is selected in the table of contents. 

● Activate the "toggle editing" tool and click on the "Add feature" tool.  

● Hover over one of the left most points in the waypoint layer.  You should notice a small pink 

cross appear. This indicates that your cursor has snapped exactly to the location of the 

waypoint.  Click on the waypoint. 

● When you move your cursor away, you should now see a faint dashed line.  This shows that 

you have digitized your first vertex in the "Survey Boundary" layer. 

 

● Continue around to the other 3 points until you complete the shape.  To stop digitising, right 

click. 
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● The attribute table form will appear.  Complete the following details: 

o id:  1 

o Site_name: Site A 

 

● Click "OK". 

Your first site is complete!  Based on the below image, repeat the digitizing steps to finish the other 

sites for your project calling them “Site B”, “Site C” and “Site D” with the sequential “id” numbers. 

 

 

● When complete click "Save Layer Edits".   

● Deactivate "Toggle Editing".    

You now have your survey boundaries stored in a shapefile that were digitised from your GPS 

waypoints. Take a look at the Attribute Table.  

5.8 Joining data from a spreadsheet 

We now have our boundaries, but the attribute data within them is not complete.  For this project 

we have been given data standards for the attributes of our spatial data.   

 

1 

Site A 

2 

Site B 

3 

Site C 
4 

Site D 
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We could add these fields and fill them out via expressions, but this could be time consuming.  

Alternatively, we can add spreadsheet data via a "join". 

"Joins" work by linking a value in both the data and the table.  These values must be identical for 

the link to work. 

 

 

Firstly we need to convert the spreadsheet into CSV so we can import it into QGIS: 

● Open "01_Training_Data\02_Excel\Survey_Boundaries_Details.xlsx" in Microsoft Excel. 

● Click “File”, “Save As”. 

● Choose “CSV (Comma delimited) (*.csv)” from the “Save as type” drop down. 

● Save the csv table to folder "02_Training_Outputs\02_Excel". 

● When a message appears, click "OK" then "Yes". 

● Close Microsoft Excel.  If a message appears asking you to save the CSV file, click "Don’t 

Save". 

● In your QGIS workspace, click "Add Delimited Text file" and open the CSV file you just 

saved. 

o Ensure "CSV (comma separated values) is activated 

o Ensure "Number of header lines to discard" is 0, and "First record has field names" is 

activated 

o Ensure "Trim fields" is activated 

o Ensure that the "Geometry definition" has "No geometry (attribute only table)" 

activated.   

 

● Click "OK".  This will import the CSV file as a table into your table of contents. 

 

Now we need to join this table to our data. 

● Right click the "Survey Boundary" layer (not the csv table) and click "Properties". 

● Click "Joins"  

● Click the "Add" button  

● In the "Add vector join" window, complete the following: 

o Join layer  Survey_Boundaries_Details 

o Join field  Site_name 

o Target field Site_name 
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● This is where it is important that you entered your “Site_name” records accurately.  

● Check “Custom field name prefix”. 

● Delete the text “Survey_Boundaries_Details_” from the text box as we do not want a prefix in 

front of the field name for this example.  

● Click "OK". 

● Click "OK" again.   

● Open the attribute table of the "Survey Boundary" layer.  You should now see the joined 

attributes.   

 

This is only a temporary join in the workspace.  To save these attributes permanently you will need 

to export and save the layer as a new shapefile. 

 

● Close the attribute table. 

● Right click the "Survey Boundary" layer. 

● Click "Save as". 

● Complete the following details: 

o Format  ESRI Shapefile 

o Save as  "Survey_Boundary_Atts.shp" in "02_Training_Outputs\01_Shapefiles" 

o CRS  Layer CRS (double check its "GDA / MGA 50 - if not, you will need to 

   change the CRS to "Selected CRS" and browse for the right CRS) 

o Activate "Add saved file to map" 

 

● Click "OK".  This will add the new layer to your table of contents. 

● Rename the new layer to "Survey Boundary Final". 

● Copy the style from the old "Survey Boundary" layer to the new "Survey Boundary Final". 

● Activate the "Survey Boundary Final" so it is visible in the table of contents. 

● Remove the following layers from your table of contents as they are no longer required: 

o Survey Boundary 

o Survey_Boundary_Details 

o waypoints 

 

Note: You can remove more than one layer at a time by "Ctrl + click" 

 

● Open the attribute table of the "Survey Boundary Final" layer. 

 

 

Question time 
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c) What would happen if your join field attributes do not match?___________________________ 

 

___________________________________________________________ 

 

 

 

● Close the attribute table. 

5.9 Renaming fields 

You may decide to rename the field names after they have already been created. You can do this 

using the Refactor fields tool. 

 

● Go to the “Processing” menu and click “Toolbox”. 

● In the search box type in “Refactor fields”. It should appear below under “Vector table 

tools”. Click into it. 

● Change the Input layer to “Survey Boundary Final” and click “Yes” to reset the field 

mapping. 

● The layer’s attributes should now appear under “Fields mapping”. 

● We want to rename the field “Method”. Double click “Method” under the “Name” column 

and enter the new field name “Sur_Method”. 

● Under “Refactored” we have to save the boundaries to a new layer. 

● Click the three dots and “Save to file” as “Survey_Boundary_Atts_Refactor.shp” in 

"02_Training_Outputs\01_Shapefiles". 

 
● Click “Save”. 

● Make sure “Open output file after running algorithm” is activated. 

● Once the new boundaries are loaded into the map view review the renamed attribute 

field. Close the attributes table. 

● Copy the style of “Survey Boundary Final” and paste it into the “Refactored Boundary”. 

● Remove the old layer “Survey Boundary Final”. 
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● Rename the new layer to “Survey Boundary Final”. 

Note:  You can also use the Refactor fields tool to re-order your fields or clone/delete/create other 

fields. 

 

● Save your workspace. 

5.10 Checking and cleaning data 

● Add the vector data "Survey_Vegetation" from the folder 

"01_Training_Data\01_Shapefiles\Survey_Data". 

We need to make a copy of this layer to your output folder before we start editing. 

● Right click on the “Survey_Vegetation” layer.  

● Click “Save As”. 

● Save the layer as “Survey_Vegetation_Clean.shp” to folder 

“02_Training_Outputs\01_Shapefiles”. 

● Select “Add saved file to map”. 

● Click “OK”.  

● Hover your mouse over the “Survey_Vegetation_Clean” layer to confirm that it is saved in 

your “02_Training_Outputs” folder. 

 

● Activate and drag the layer to the top of the table of contents. 

● Change the symbology of this layer so there is no fill, and a medium green border. 

● Deactivate the other layers so you can only see the "Survey_Vegetation_Clean" layer. 

● Remove the original “Survey_Vegetation” layer from the workspace. 

● Zoom closer into each of the survey boundaries. 

You might be able to see various overlaps and gaps in the data, although most are too small to see 

even if zooming in close. These issues are usually created when snapping is not used and as they 

are usually small, they can be easily overlooked.    

The term "topologically correct" means that the data is clean and structured well (no overlaps/ 

gaps, line segments not joining when they should).    

There are various tools that can help us identify these topological issues. 
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5.10.1 Identifying gaps 

 

In the Menu Bar: 

 

● Click the “Topology Checker” button which should be located on the left toolbar.    

If the button is missing check that the tool is activated in “Plugins > Manage and Install Plugins”. 

 

A side bar will appear to the right of your map canvas.  

 

● Click "Configure"    

● Add the rule "Survey_Vegetation_Clean",  "must not have gaps". 

● Click “Add Rule”. 

 

● Click "OK". 

● Click "Validate All".   

 

● Your map will now be highlighted red with any gaps.   

● Ensure your snapping options are on for vertex for the "Survey_Vegetation_Clean" layer (in 

the “Settings” menu). Change Mode “to vertex” to 15 pixels.  

● Double click on one of the errors listed in the topology checker table.  

● You will zoom into the polygon with the gap in the map canvas.  

● Click "Toggle Editing" and amend the areas that contain errors using the "Node Tool".  

Hint: to start moving vertices click on a red cross so it becomes a square.    

Hint: where there are gaps move the vertices off its original position and snap back in place. 

● Click “Validate All” when you have made some changes to see if you have removed the 

gaps. 
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● Repeat the process for all the other gaps.  

● Once complete, click "Save Layer Edits". 

● Repeat the above process but for the configuration "must not overlap". 

 

● Save the edits once the data is clean. 

● Remove the layer “Survey_Vegetation_Clean” from the workspace. 

Save and close your workspace. 

 

End of Exercise 5.  
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6.0 Exercise 6 - Geo-processing and other handy tools 

 

To begin, open up the Exercise 6 workspace provided.   

In your training data folder: 

● Locate folder "01_Training_Data\00_Workspaces".   

● Open "Exercise_6_GAIA" and save to your working folders under 

"02_Training_Outputs\00_Workspaces" as "Exercise_6.qgs". 

There are various simple geo-processing tools that are used frequently in a GIS.  As most of our data 

today is in vector format, we will be focusing on vector format tools. 

 

It is important that the user is aware of what CRS each dataset is in.  When processing data, issues 

can arise if the datasets being used are in conflicting CRS's.  QGIS cannot always process data 

'onthefly', so the best way to keep your processing clean is to reproject all your data in the same 

CRS. 

 

Note: Always double check your outputs once they are processed to ensure the tool executed 

correctly. 

6.1 Removing 'onthefly' transformations 

We need to ready our workspace for our processing, so will need to remove the 'onthefly' 

transformation so only layers with the same CRS will overlay. In the Menu Bar: 

 

● Click "Project > Project Properties". 

● Under "CRS", deactivate the "Enable 'on the fly' CRS transformation (OTF)". 

● Click "OK". 

● Right click on the “Survey Boundary Final” layer and click “Zoom to Layer” (this also refreshes 

the loaded layers). 

You will now notice that your map canvas only shows a few datasets. This is because your 

workspace CRS is set at GDA94 / MGA Zone 50 (and not converting ‘on the fly’ anymore), so only 

data with that CRS will show in the map canvas – see easting and northing coordinates showing in 

the info bar on the bottom and not latitude and longitude.  
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Now we need to make sure that 'on the fly' transformations are not automatically activated while 

we are geo-processing.   

 

In the Menu Bar: 

 

● Click "Settings > Options". 

● Under "CRS", choose the option "Don't enable 'on the fly' reprojection". 

● Click "OK". 

6.2 Reprojecting data 

We want to find out how much native vegetation is located in our Survey Boundaries, so will need 

to reproject that layer to MGA Zone 50 to match the projection of the Survey Boundaries layer.   

● In the table of contents, right click "Native Vegetation". 

● Click "Save As" 

● In the "Save vector layer as..." complete the following: 

o Format: ESRI Shapefile 

o Save as: Native_Veg_MGA50.shp 

Save under the folder "02_Training_Outputs\01_Shapefiles" 

o CRS:  Select "GDA94 / MGA zone 50" from the dropdown or browse for it 

o Activate "Add saved file to map" 

 

● Click "OK".   

You will now see the “Survey Boundary Final” data on the newly projected “Native_Veg_MGA50” 

layer overlayed in the same location (you have just converted a geographical dataset (lats and 

longs in degrees) to a projection dataset (easting and northings in meters). 

6.3 Clipping data 

Now we can clip the Native Vegetation dataset to the Survey Boundary extents as they are in the 

same CRS. In the Menu Bar: 

● Click "Vector > Geoprocessing Tools > Clip". 

● In the "Clip" window, select the following: 

o Input layer: Native_Veg_MGA50 

o Clip layer:  Survey Boundary Final 

o Output shapefile: Native_Veg_Extents.shp 

Save to file under "02_Training_Outputs\01_Shapefiles" 

o Activate "Open output file after running algorithm" 

 

● Click "Run". 

● Rename "Clipped" to “Native_Veg_Extents”. 

● Remove the "Native_Veg_MGA50" layer from your table of contents. 

Your map canvas should look similar to the below; you should now only see native vegetation 

within your survey boundary extents.  
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6.4 Dissolving data 

We can now dissolve all the Native Veg Extents into one polygon (for easier calculations of areas).  

In the Menu Bar: 

● Click "Vector > Geoprocessing Tools > Dissolve". 

● In the "Dissolve" window, select the following: 

o Input layer: Native_Veg_Extents 

o Activate “Dissolve all (do not use fields)” 

o Output shapefile: Native_Veg_Dissolve.shp 

Save to file under "02_Training_Outputs\01_Shapefiles" 

o Activate "Open output file after running algorithm" 

 

● Click "Run". 

● Rename "Dissolved" to “Native_Veg_Dissolve”. 

● Remove the "Native_Veg_Extents" layer from your table of contents. 

● Activate and drag the "Native_Veg_Dissolve" layer to the top of the table of contents. 

● Open the "Native_Veg_Dissolve" attribute table and review the contents. 

You will notice that all the polygons are saved under one feature.  This is called a multi-part 

polygon feature (as there is one row of information shared by many polygons). 

It's important to note that the attributes in this table were based on the first feature in the original 

"Native Vegetation" layer, so are not accurate for the new multi-part polygon.  For this reason it is 

good practice to delete all unwanted fields.  

● In the "Native_Veg_Dissolve" attribute table, click on "Toggle editing mode".  

● Click “Delete field”.  

● Select all fields and click “OK”. 

All shapefile attributes should have a unique identifier, even if it is a multi-part polygon.  
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● Click “New field”. 

● Complete the following: 

o Name:  ID 

o Type:  Whole number (integer) 

o Length:  10 

 

● Double click in the new record and enter “1”. 

 

6.5  Calculating areas using an expression 

We will now calculate the area of this one multi-part polygon.  As we are using a projection (GDA / 

MGA Zone 50) our map units are in meters, so any calculations will also be in meters. 

● In the "Native_Veg_Dissolve" attribute table, ensure you are still in editing mode. 

● Click the "Open field calculator".  

● Complete the following: 

o Activate "Create a new field" 

o Output field name: Area_Ha 

o Output field type: Decimal number (real) 

o Output field length: 10 (total integers/numbers before and after decimal point) 

o Precision:  4 (total integers/numbers after decimal point) 

 

● Under the search functions, expand out the "Geometry" listing. 

● Double click the value "$area".  This will bring up the value in your expression box. 

 
 

This will calculate the area in squared meters.  We want to calculate our area in hectares so we will 

need to divide this amount by 10,000. 

 

● Complete the expression so it reads as follows (no quotes needed):   $area /10000 
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● Check if the expression is valid. 

● Click "OK" 

A new field will be added to the attribute table with the area in hectares. 

● In your attribute table, click "Save Edits".   

● Deactivate the "Toggle editing mode" button.   

Note: Every time you open an attribute table it opens as a new tab in your Windows 

taskbar, so make sure you close them if they are no longer in use.  

 

 
 

 

 

 

Question time 

 

a) What is the area of the Native Vegetation in your survey boundaries (in hectares)?____________ 

 

 

● Close the attribute table. 

Note: For calculating areas in different measurements, you can use the following expressions: 

 Squaremetres: $area 

 Squarekilometres: $area /1000000 

 Hectares:  $area /10000 

6.6 Calculating points in polygons 

We would also like to see how many weed species are located within these native vegetation 

areas.  In the Menu Bar: 

● Click "Vector > Analysis Tools >Count points in polygon". 

● When the "Count points in polygon" window appears, complete the following: 

o  Polygons:  Native_Veg_Dissolve 

o Points:   Weed Points 

o Count field name: WeedCount 

o Output Shapefile: Native_Veg_Weed_Count.shp 

  Save to file under "02_Training_Outputs\01_Shapefiles" 

o Activate "Open output file after running algorithm" 

 

● Click "Run". 
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● Rename “Count” to “Native_Veg_Weed_Count”. 

● Activate and drag the "Native_Veg_Weed_Count" layer to the top of the table of contents. 

● Open the attribute table and find the newly added field “WeedCount". 

● Check that this output is correct by having a look at the layers. 

 

 

Question time 

 

b) How many weeds are located within the Native Vegetation?  (Hint:  the number will be located 

in the new field  “WeedCount”) _____ 

 

 
● Close the attribute table. 

● Remove both the "Native_Veg_Weed_Count" and the "Native_Veg_Dissolve" layers from 

your table of contents. 

6.7 Filtering a layer 

We also need to create 500 metre buffers around our Variegated Thistle sites. Firstly we need to filter 

out our weed points. 

 

● In the table of contents, right click "Weed Points". 

● Click "Filter". 

● Double click on “Common_Na” in the “Fields” window. 

● Click “=” under “Operators”. 

● Click “All” under the “Values” window to bring up unique values for that field. 

● Double click “Variegated Thistle” 

● In the "Query Builder" window, check that your expression looks like this: 

 "Common_Na" = 'Variegated Thistle' 

 

● Click "OK". 

Only the thistle points should be visible in your map canvas. 

 

 

 

Question time 

 

c) How many thistle points are there in the map?  (hint: review the "Weed Points" attribute table) 

_______________________ 

 

 

6.8 Creating buffers 

Now to create the buffers around the remaining points. In the Menu Bar: 
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● Click "Vector> Geoprocessing Tools > Fixed distance buffer" and complete the following: 

o Input layer:  Weed Points 

o Distance:  500 (again this is based on the CRS so indicates metres) 

o Output shapefile: Buffer_Thistle_500m.shp 

Save to file under "02_Training_Outputs\01_Shapefiles" 

o Activate "Open output file after running algorithm" 

● Click "Run”. 

● Activate and drag the layer so it's under the "Weed Points" layer in the table of contents. 

● Zoom in closer to one of the weed locations.   

● Use the measuring tool to ensure the buffer is a total 1000m wide. 

● Rename the layer "Buffer 500m". 

6.9 Installing a plugin 

You have now been emailed some additional weed location coordinates to add to the “Weed 

Points” layer.  As there are only two locations it will be quicker to add them within the workspace 

rather than setting up another join from a spreadsheet. 

 

To enable us to enter specific coordinates directly to the map canvas we will need to install a 

plugin: 

 

● Click on the “Plugins” menu and open “Manage and Install Plugins”. 

● Search for “Numerical Digitize”(this might already be installed). 

● Click “Install plugin”. 

● Close the plugin manager. 

● Right click on the “Weed_Points” layer.  

● Click “Zoom to Layer”. 

We still have a filter on the layer, so we will turn this off before continuing. To do so: 

 

● Right click on “Weed Points”. 

● Click “Filter”. 

● Click "Clear" to completely remove the expression.  Click “OK”. 

● You will notice all weed points are now displaying. 

● Click on any other layer then back on the “Weed_Points” layer to reactivate it. 

● Now click on “Toggle Editing” mode.   

● Click on the newly installed plugin “Numerical Digitize”.    (this should be located next to 

the editing tools in the top tool bar). 
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(if it's not showing, you might have to restart QGIS - remember to save your work!) 

● In the popup table, add the following locations: 

o X1 Coordinate: 682374 

o Y1 Coordinate: 6194730 

o X2 Coordinate: 683752 

o Y2 Coordinate  6192893 

● Click “in the CRS of the Layer”. 

● Click “OK”. 

● Enter “ID” = 30 and 31 in the popup attributes table consecutively.  

These two weed locations will now be added to the map canvas within the survey boundary 

“Site C”. Notice they are coloured blue as they are now NULL values in the attribute table – 

review the symbology for the layer.  

 
 

● Open the “Attribute Table” for “Weed Points”.   

These two weed locations are also added as new blank records within the attribute table. 

 

● Double click on the cells and add the following values: 

 
 

● If easier you can copy and paste from one cell to another using “Ctrl c” and “Ctrl v”. 

Remember for many new records you could either do a join or use the field calculator.  

● Click off “Toggle Editing”.   

● Click “Save”.  

The new point locations and associated attributes are now permanently saved to the 

“Weed_points.shp” shapefile located in your “02_Training_Outputs/01_Shapefiles” folder. 

 

● Close the attribute table.  

6.10 Advanced labelling options (optional extra) 

Now we have finished geo-processing we can turn on ‘on the fly’ CRS transformation. 
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● Go to “Project > Project Properties” and check “Enable ‘on the fly’ CRS transformation 

(OTF)”.  

● Click “OK”.  

● Click Refresh if necessary.  

● You should now see all layers overlaying one another.  

Although automated labelling is quick and fast, we might want our labels labelled more carefully 

for clarity and consistency.  To give you an example, turn on the labels for the "Weed Points" using 

the field "Common_Na" (hint: you can do this under the layers properties). 

 

Although most of them are labelled clearly some areas where the points are closely located the 

labels become overlapped and hard to read. 

QGIS gives you the option of defining your own locations for the labels (as well as other items such 

as size, colour, font and rotation). 

To manually modify your own labels, we first need to set up fields in our layer to store our own 

definitions to the labels.   

For this example we will modify our "Weed Points" layer".  In the Menu Bar: 

● Right click the "Weed Points" layer and open its attribute table. 

● Create the following new fields (in an editing session): 

o Name:    X 

o Type:    Decimal number (real) 

o Length:   20 

o Precision:  4 

 

o Name:    Y 

o Type:    Decimal number (real) 

o Length:   20 

o Precision:  4 

 

o Name:    Colour 

o Type:    Text (string) 

o Length:   20 

 

o Name:    Font 

o Type:    Text (string) 

o Length:   20 

 

● Click "Save". 

● Open the properties of the "Weed Points" layer then "Labels". 

● Activate the label by selecting “Show labels for this layer”, then Label with “Common_Na". 
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We can now define each label amendment with the new fields we have created above.  We 

do this by using the "Data defined override".   

 

● Under "Text> Font", click on the "Data defined override" box and select the "Font" field type 

string. 

 
 

Defining your data this way will turn the "Data defined override" yellow.   

Complete the same process for "Color" using your new data field called "Colour". 

 

To give the ability to move your label around in the map canvas, we do the same but under 

"Placement > Data defined" 

 

Complete the same process for your "X" and "Y" fields. 

 

 
 

● Click "OK" to save your changes. 

Now we can start modifying our labels.  Back at the start of the training, we asked you to turn on 

the toolbar "Label".  This is the toolbar that will allow you to move and modify your labels in your 

map canvas.  
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If you can't see this toolbar, repeat the steps found in Chapter 2.9. To activate this toolbar, ensure 

your "Weed Points" layer is in edit mode. . 

To begin with, we will start moving those labels that are overlapping. 

 

● In the "Label" toolbar, click "Move Label".  

● Click and hold on the label you want to move (the selected label will be highlighted). 

 

● Drag and drop the label until it is in a more preferable position. 

● Do this for any other overlapping labels. 

 
 

● Save your changes. 

We can also change the colour and size of individual labels: 

● In the "Label" toolbar, click "Change Label".  

● Click on a label to bring up the "Label properties" window. 

● Change the font type and the colour. 

● Click "OK" 

● End the editing session and save your changes. 

The label should have now changed colour and font and the changes stored in the attribute table 

– review the changes in the attribute table.  

Note:  Saving the style of your data also saves your derived labelling of the layer as well. 

 

As we won't require these labels for the next exercise, you can turn them off in the properties. 

 

Save your workspace 

 

End of Exercise 6. 
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7.0 Exercise 7 - Making maps 

 

To begin, open up the Exercise 7 workspace provided.   

In your training data folder: 

● Locate folder "01_Training_Data\00_Workspaces".   

● Open "Exercise_7_GAIA" and save to your working folders under 

"02_Training_Outputs\00_Workspaces" as "Exercise_7.qgs". 

7.1 Activating 'on the fly' transformations 

As we have completed our geo-processing, we can change the 'on the fly' transformation settings 

so layers with different CRS overlay for our mapping. In the Menu Bar: 

 

● Click "Settings > Options". 

● Under "CRS", select the option "Automatically enable 'on the fly' reprojection if layers have 

different CRS". 

● Click "OK". 

In the Menu Bar: 

 

● Click "Project >Project Properties". 

● Under "CRS" ensure "Enable 'on the fly' CRS transformation (OTF)" is activated. 

● Click "OK". 

Your data should all be overlaying one another in your map canvas, if not click “Refresh”  

 

Let’s create a map! 

7.2 Creating a composer 

In the Menu Bar: 

● Click "Project > New Print Composer" or use the shortcut "Ctrl + P". 

 

● Enter the title as "Bremer Bay Overview". 
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● Click "OK". 

This will create a new composer.  Where workspaces deal with data, composers deal with creating 

maps drawing from the data in the workspace. 

 
 

The main areas of the composer are: 

 

1) Composer Toolbar:  The tools used for creating and manipulating your map 

2) Map area:   Where the elements of the map are compiled 

3) General map options:  The general settings of the map 

 

● Enlarge the composer by clicking the "Maximize" button on the top right of the window. 

 
 

 

● Click the "Zoom Full" button.  in the top toolbar of your composer to enlarge the map 

area. 
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● Click "Save project".  

7.3 Setting up the data for the map 

● Go back to your workspace (you can toggle between the workspace and map composer 

by clicking the QGIS tabs on the Taskbar at the bottom of your screen). 

 

 

In your workspace ensure the following layers are activated and sorted as per the below in the 

table of contents (how your data looks in the workspace is how it will look in your composer). 

o Weed points 

o Buffer 500m 

o Survey Boundary Final 

o Nature Reserves 

o Roads 

o Native Vegetation 

o Lakes 

o Rivers 

o Islands 

o Mainland 

 

● Uncheck the layer “Town”.   

 

7.4 Setting up the map composition 

Return to your composer. In the Menu Bar: 

 

● Click and activate "View>Show Grid". 

● Click and activate "View > Snap to Grid". 

This creates a snapping grid.  When adding elements, they will "snap" to these points allowing items 

to be aligned.  Their size though needs to be a little smaller. 

 

To the right of your map area: 

 

● Click "Composition".  

o Under "Guides and Grid", change "Grid spacing" to 5.50mm. 

 

This makes your snapping grids a little smaller giving a bit more flexibility for where you can align 

your map elements to. 
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7.4.1 Adding map elements 

Below are the map elements we will be adding to our map.   

Note: The types of elements you include in your map are reliant on what the map will be used for, 

where it will be used, and who the target audience is. 

 

7.4.2 Adding a map canvas 

● In the left (or sometimes top) toolbar, click "Add new map".  

● Click and drag the element to the extents indicated in the image below. 

To resize the element, hover over the corner until a double ended arrow appears.  Click 

on the arrow and drag the corner to where you want it to go. 

Snap the corners to your snapping grid. 

 

 

Your data from your QGIS workspace will automatically fill the extents of the canvas. 

However, it might not be showing in the right location.   
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7.4.3 Modify the location of your data in the map canvas 

 

● Ensure the map canvas is selected (this is indicated by white boxes on the corners). 

● To the right of the map canvas, click on "Item properties". These are the properties for 

the map as that is the element selected. 

 

o Under "Extents", click on the "Set to map canvas extent" button.   

 

 
 

If it's still not in the right place, you will need to do some manual adjusting.   

 

● Ensure the map is selected. 

● In the toolbar, click the "Move item content" button  

● Drag the data around the frame and use the mouse wheel to zoom in and out until the 

data looks like the below. 

● For finer scale adjustments you can enter values under “Item properties”, “Main 

properties” and “Scale”. 

 

● Once completed, click the "Select / Move" tool.  This allows you to move elements in 

your composer i.e. if you want to move the map itself around the map canvas 

instead of the map content.  
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Note: If the data in the map canvas is fuzzy or not drawing correctly, it may be cached.  Under 

'Item properties > Main Properties" ensure "Cache" is selected and click the "Update 

preview" button. 

 The map canvas will show the data you can currently see in the workspace.  If you want to 

add or change the data in the composer, you will need to do it in the workspace first, then 

update the cache in the composer to see the changes take effect. 

7.4.4 Stylising the map canvas 

To give your map canvas a border: 

 

● Ensure your map canvas is selected. 

● In "Item properties" to the right of the map canvas: 

o Activate "Frame" and change the "Thickness" to 0.25  

  

 
 

 We can also colour the background, which in this case, indicates the ocean: 

 

o Ensure "Background" is activated and change the colour to:  Red: 211, Green: 238, Blue: 228 
 

 

7.4.5 Adding a grid 

Grids show us coordinate locations on the map canvas as a reference point. 

 

● Ensure your map canvas is selected. 

● In "Item properties" to the right of the map canvas: 

o Click on "Grids". 
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o Click “Add a new grid”  

o Grid type: Cross 

o Interval: X 10000 

   Y 10000 

o Cross width 1 

o Activate "Draw coordinates" 

o Left:  Vertical ascending 

o Right:  Vertical descending 

o Font:  Size: 6 

o Coordinate precision: 0 

● Click "Save project".   

7.4.6 Adding text and labels 

We also want to add a title to our map. 

● Click "Add new label".  

● Click on the map area near the top right. 

● Under 'Item Properties': 

o  In  "Main Properties,  

o Modify the title from "QGIS" to "Location of Weeds in Bremer Bay" 

o Change the font style to "Bold" 

o Change the font size to 12 

● Click on the text box, and resize until you can see the text in full. 

● Drag and resize the text box accordingly. 

 

7.4.7 Adding logos 

We would also like to add a logo to the map. 

● Click on "Add image".   

● Click and draw a square on the map canvas in the bottom right hand corner. 

● Under 'Item Properties': 

o  In "Main Properties, click “Image source”. 
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o In the Browser, find and select the file 

"01_Training_Data\04_Images\Gaia_logo.png". 

o Click "Open". 

● Drag and resize the image box accordingly. 

 
 

Note: To fine tune the location of elements, you can use the arrow keys on your keyboard. 

7.4.8 Adding a scale bar 

Scale bars give reference to the size and scale of the data in your map canvas. 

● Click "Add new scalebar".   

● Click on the map canvas just above the logo. 

● Under 'Item Properties', amend the scale bar to the following: 

o Segments: Segments  left: 0  

     right: 5 

   Fixed width: 2000 units 

   Height:  2mm 

o Display: Line width:   0.30 mm 

o Fonts and colors:    Font:  Size:   10  

● Drag the scale bar accordingly. 

7.4.9 Adding an arrow 

Arrows on maps usually indicate where north is.  QGIS has an arrow element in its toolbar, 

but it's plain and blocky.  There are however alternatives: 

● Click "Add image". 

● Click and draw a small square on the map canvas above the scale bar. 

● Under “Item Properties”: 

o  Under "Search directories" there are some default symbols already loaded for you to 

use (previews might take a few seconds to load). 

o Search for this arrow and click on it.   

It should show the image automatically in your "Image" element. 

o In "Position and size", change the width and height to 8. 
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● Drag it to just above your scale bar. 

 

Note:  Users can customise and create their own shapes for use in the composer.  Files must be in 

SVG format. 

 

Note: Arrows in maps indicate north.  However, arrows in QGIS are only shown as an image and 

are not linked to the CRS in any way.  As most projections will show north at the top of the 

map canvas, we can presume this orientation of the arrow is correct.  However, some 

custom projections may not - so using the arrow in the composer should be used with care. 

7.4.10 Adding a legend 

A legend gives more information on the data shown in the map canvas.   

● Click on "Add new legend".  

● Click on the map canvas just below the title text. 

The legend will automatically list the data found in your workspace table of contents. 

 

● Under 'Item Properties': 

o Under "Fonts": 

o Change the "Item Font" to size 10. 

o Change the "Subgroup Font" to size 10, bold. 

o Under "Symbol": 

o Change the symbol width to 5.00mm. 
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o Change the symbol height to 3.00mm. 

o Click "Save project".  

● Drag your legend so it sits just below the title. 

 

Note:    If you have finished editing an element you can lock and unlock it from accidental edits by 

clicking “Lock Selected Items” /”Unlock All Items”  from the top toolbar.  

 

7.5 Amending the legend and map canvas 

On closer review of the map we have created, our weed points in the legend has a blank 

category we want removed, and you have decided you want to show the Bremer Bay 

town location.  

 
To amend this, we need to return to our workspace to update the data in the table of 

contents. 

 

● Switch to your workspace. 

● Double click "Weed Points" in your table of contents to bring up the properties. 

● Click on "Style". 

● Select the blank value in your categories. 

 

● Click "Delete". 

● Click "OK". 

The blank category is now removed from your workspace. 

 

● Check the “Town” layer to display it again and move it to the top of the table of 

contents. 

 

Switch back to the composer. 

  

The legend should have automatically updated with your changes. If not under “Item 

properties”, “Legend items” ensure “Auto update” is checked or click “Update all”.  

 

If you need to refresh the map canvas: 
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● Click on the map canvas to select it. 

● Under "Item properties", “Main properties” ensure "Cache" is selected and click "Update 

preview".   

Note: Using “Update All” loses any changes you may have previously made under "Legend items". 

You can update specific items in the legend by clicking the "Update item" button. 

 

No we decide to edit the legend manually (this will not change layers in the workspace).  

● Ensure the legend element is selected.   

o Under "Item properties", in the "Legend items", ensure "Auto update" is unchecked.   

● Under 'Item Properties': 

o  In "Main Properties”, delete the title "Legend". 

o In "Legend items", using the legend toolbar, amend the following: 

 

o Change the label from "Survey Boundary Final" to "Survey Boundary".  

o Remove "Islands" from the list.   

o Move the “Roads” legend item so it sits above “Nature Reserves”.   

o Move the “Survey Boundary” to the top of the legend.  

The legend will now be updated.   

● Click "Save project".   

7.6 Map exporting options 

There are various options when exporting your map. 

 Export as Image:  General image outputs such as .png, .jpg, .bmp, .tiff etc. 

 Export as SVG:A vector format that can be used in illustration software. 

 Export as PDF: Map will be exported as a raster PDF. 

 

However, we will be exporting to JPEG: 

● In the toolbar, click "Export as image".  

● Locate your folder "02_Training_Outputs\03_Image". 

o File name: Bremer_Bay_Overview  

o Save as type: JPG format (*.jpg *.JPG) 

● Click "Save". 

● Leave the export options as default and click “Save” again.  
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Find where the file was saved on your local drive, open and review your map. 

Note:  If you do close your composer you can reopen it by going to "Project > Print Composers > 

Bremer Bay Overview", or open the Composer Manager by clicking “Project > Composer 

Manager”.  

7.7 Creating an atlas 

A QGIS atlas is used to automatically produce multiple maps based on polygon extents.  Before this 

can be used you need to set up your map for automatic processing.  For this exercise, we will be 

producing maps based on the Survey Boundary extents. 

● Open your map composer "Bremer Bay Overview". 

Firstly, we need to set up the map canvas elements so it is ready to be controlled by the atlas. In 

the map composer: 

 

● Select the scale bar element. 

As our Survey Boundary extents are smaller, we will need to adjust the scale bar accordingly. 

● Set the map scale bar as follows: 

Units: 

o Label for units:   m 

o Map units per bar unit:   10.00 

Segments: 

o Right:   2 

o Fixed width:  1000.00 units 

The scale bar won’t look right at the moment but it will when the atlas zooms in to each 

individual survey boundary area. 

 

Now we need to set up the atlas. 

 

● Click on the map canvas element.  

● Click on "Atlas generation". 

 

● Activate "Generate an atlas". 

● Set the following: 

Configuration: 

o Coverage layer: Survey Boundary Final 

Output: 

o Click on the expression button.   

o Output filename expression:  'BremerBay_'||"Site_name". 

o Check the “Output preview” at the bottom of the dialogue box. 

o Click “OK”. 

Configuration: 

o Sort by:   Site_name 
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● Select “Item properties” and activate “Controlled by atlas”. 

● Set “Margin around feature” to 10%.   

Before we create the map atlas we will add an automatically updated label that indicates 

which boundary we are looking at. 

● Click "Add new label" and click just under the title in your composer.   

 

● Click "Item Properties" and under main properties, delete the text "QGIS" 

● Click the "Insert an expression" button. 

 

● In the insert expression, click "Fields and values >Site_name" (this should bring up "Site_name" 

in your Expression box). 

 

● Click "OK".  The expression should now be seen in the Main properties box. 

 

● Resize, drag and drop the text box under the title label. 

 

Click "Save project".   
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Before we export it is useful to check the map atlas preview tool to ensure the extent and map 

elements (like the scale bar) look as we expect for each map extent.  

 

● Click “Preview Atlas” on the top tool bar.  

● Click “Next Feature” to toggle through each map extent. Now is a 

good time to tweak the layout or map element settings if required.  

Time to export to a map atlas!  

 

● To print the maps click "Export Atlas as Images" (note – it looks a lot like the “Export as 

image” button so hover over it with the mouse to make sure you get the right one). 

 

● Select “Export Atlas as images”. 

● Search for the folder directory "02_Training_Outputs\03_Image". 

● Click "Choose". 

● Leave the export options as default and click “Save”.  

● Give it a moment and then find this folder on your computer.  You should now see four 

maps titled "BremerBay_Site A" to “BremerBay_Site D". 

Open the map images - note that the scale bar will change size and the site name will change with 

each survey area. 

You can also export all maps to a single pdf file.  

• Go back to the map composer. 

• Make sure the map element is selected. 

• Click on the “Atlas generation” tab.  

• Check “Single file export when possible” under “Output”. 

• Click “Export Atlas as pdf”. 

• Give the file a name and click “Save”.  

• Navigate to your export folder and open the pdf file.    

Save your workspace and close. 

End of Exercise 7. 

 

Completion of the training - well done!  
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8.0 Appendix 

8.1 Acronyms used in this document 

 

CRS  Coordinate Reference System 

 

CSV  Comma separated values, or 

  Character separated values 

 

ID  Identifier 

 

EPSG  European Petroleum Survey Group 

 

ESRI  Environmental Sciences Research Institute 

 

GA  Geoscience Australia 

 

GDA94  Geocentric Datum of Australia1994 

 

GIS  Geographic Information Science, or 

  Geographic Information Systems  

 

GPS  Global Positioning System 

 

GPX  Global Positioning System eXchange Format 

 

JPEG  Joint Photographic Experts Group 

 

MGA  Map Grid of Australia 

 

OGR  OGR Simple Features Library 

 

PDF  Portable Document Format 

 

QGIS  Quantum Geographic Information System 

 

SHP  Shapefile 

 

XLSX  Excel 2007 format 
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8.2 Locating free data sources 

In Australia, many Government Department have free data that anyone can download.   A good 

overview of available datasets can be found here: 

 

http://australia.gov.au/topics/it-and-communications/data.   

 

Otherwise, the more popular data portals are: 

 

WA Government Data: 

 

Provides a range of different data from the majority of Government Departments. 

 

https://data.wa.gov.au/ 

 

Geoscience Australia: 

 

Provides a range of different data, mainly at a national scale.   

 

https://www.ga.gov.au/search 

 

Department of Mines and Petroleum: 

 

For all things mining in Western Australia.  Tenements, mine sites, geology. 

 

https://dasc.dmp.wa.gov.au/dasc/ 

 

Bureau of Meteorology: 

 

Various weather datasets for recent and average conditions for state and federal. 

 

http://www.bom.gov.au/climate/maps/ 

 

Satellite Data: 

 

Various satellite data can be freely available.  Usually these are low resolution, but good for 

national scale mapping. 

 

https://lpdaac.usgs.gov/data_access 
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8.3 Answers to questions 

 

Exercise 1 

a) What are the 4 file extensions that make up the shapefile of "i5012_roads"? .dbf, .prj, .shp, .shx 

b) What is the Data Currency Beginning Date? 9/05/06 

c) What do the following tools do?  Pan map, Zoom full, Refresh 

d) What CRS is your "Roads" data currently set in? GDA94 

e) What CRS is your workspace currently set in? GDA94 

f) What is the estimated coordinates of the town site?119.3784, -34.3909   

g) Are these in latitudes and longitudes?  Or easting and nothings? Latitudes and Longitudes 

h) What scale value allows you to zoom in the closest to the data in the map? 1:500 

i) Are you able to type in your own scale value? Yes 

j) What is the EPSG of your workspace now?  EPSG: 28350 

 

Exercise 2 

a) What is the "FEATTYPE" (or feature type) of this reserve? Nature Conservation Reserve 

b) What is the name of the only town?  Bremer Bay  

c) What are the names of two of the islands? Cheyne Island, Doubtful Island, Glasse Island, Haul 

Off Rock. Horatio Island, Red Island, Roe Rocks, Smooth Rocks, Sparkling Island.  

d) Name a type of road class?  Principal Road, Minor Road, Secondary Road, Track  

e) What details come up in the information window? Band 1: 148  , Band 2: 158 ,  Band 3: 103 

f) What do you think these values represent? Colours  

g) How many lakes are recorded in the "Lakes" layer?53 

h) Which "Nature Reserve" has a "Featrel" value of 2002-03-20? Hassell National Park 

i) How many "Formation" types are in the "Roads" layer?  2: Sealed and Unsealed 

j) What is the row ID for the smallest sized area in the Native Vegetation layer?  (Order the 

"SHAPE_Area" field)   4 

k) How many reserves are selected? 3 

l) What is the estimated total area of the reserve? 45.99km2 

 

Exercise 3 

a) For polygons, what "Fill style" ensures no fill colour is shown in the Map Canvas?   No Brush 

b) Is there an option to save the style that you have created? (Review options found in the "Style" 

window) Yes 

c) What are the four options for selecting colours (Hint: one is “Color wheel”)? Color ramp, 

Color swatches and Color picker.  

d) Another symbol type option is the "Graduated Tool".  Review this tool.  What do you think it 

could be used for? Symbolizes numerical fields that show graduating values (such as 

temperature or areas) 

e) Do the "Label Placement" options change for a point and a line?   Yes 
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Exercise 4 

a) What is the potential issue with the classification of data (see Step 4.3)?  Spelling mistakes make 

it look like there is more than two species in the table. 

b) What happens when you try and create a longer string than 255characters to the  width of a 

text field?  You can't type in the value 

c) What is the shortcut syntax to the "Delete field" tool?  Ctrl + L 

d) Within the "Field Calculator", what is the operator symbol for string concatenation?  II 

e) Select all the Recorders whose name is "P. Joe"  

  "Recorder" = 'P. Joe'  

  Total 4 rows 

 

f) Select Sites A and Sites B   

  "Location" IN ('Site A', 'Site B') 

  "Location" = 'Site A' OR "Location" = 'Site B' 

  Total 5 rows 

 

g) Select Site who was recorded by S. Smith 

  "Location" = 'Site B' AND "Recorder" = 'S. Smith' 

  Total 1 row 

 

h) Select sites with an amount more than 1 (you can also use the ">" operator) 

  "Amount" > 1 

  NOT "Amount" = 1 

  Total 7 rows 

 

i) Select Weed C and Site C 

  "Name" = 'Weed C' AND "Location" = 'Site C' 

  Total 1 row 

 

j) Select all the Weeds except Weed C 

  NOT "Name" = 'Weed C' 

  Total 6 rows 

 

k) Select all weeds that were recorded by the Smith brothers. 

  "Recorder" LIKE '%Smith%' 

  "Recorder" = 'K. Smith' OR "Recorder" = 'S. Smith' 

  Total 5 rows 

 

l) Select all Site A's that were recorded in May 

  "Location" = 'Site A' AND "Date" LIKE '%05%' 

  Total 1 row 

 

Exercise 5 

a) What are the layer name options in the GPX file? waypoints,  routes, tracks, route_points, 

track_points 

b) Other than vertex, what else can you snap to?    to segment, to segment and vertex 

c) What would happen if the join field attributes do not match? Records for a ‘no match’ will not 

have populated the attribute table.  
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Exercise 6 

a) What is the area of the Native Veg in your survey boundaries (in hectares)?  4157.7364 

b) How many weeds are located within the Native Vegetation?  2 

c) How many thistle points are there in the map?  7   


