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Introduction 

This tutorial leads you through the steps necessary to make a simple two-sided PCB using 

EAGLE. This guide is operational: it shows in detail what you do and how to do it. Before you 

start the tutorial take 5 minutes to go through the Cadsoft EAGLE Guided tour, to get an 

overview. It will pay you to work through all of this guide, following the steps yourself, 

before attempting your first unguided PCB. 

A short note about the EAGLE on-line help documentation. This is pretty good but based on 

the command-line interface to EAGLE. It is easier when learning to use the drag-and-drop 

GUI, which we follow in this tutorial. 

This guide assumes that you are designing a two-sided PCB with plated-through holes (PTH), 

the normal case, and supported by the freeware version of EAGLE providing your board is no 

larger than 100mmX80mm. If you want to download the freeware EAGLE to your own PC 

this is easy. Look for the latest freeware version for your operating system & language (e.g. 

eagle-win-5.2.exe for windows XP and English). The download site is here - follow the 

program link to download the latest installation executable. When you first run the 

application, after installation, click the "run as freeware" button. 

EAGLE can also be used to design multi-layer and single-sided PCBs, non-PTH PCBs, etc. It 

can also be easily adapted to produce boards with coarser features, suitable for low quality 

optical processes and manual manufacture. See the EAGLE Configuration Guide for more 

details of use with different technologies after you have followed this guide. 

In order to design a PCB, you need to complete the following steps: 

1. Create a schematic sheet & add components 

2. Add nets to the schematic (connect components) 

3. Check schematic (Electrical Rule Check or ERC) 

4. Create a board outline 

5. Position components on the board 

6. Route tracks between the components 

7. Check board (Design Rule Check or DRC) 

8. Pour copper to fill empty spaces on the board 

9. (optional) Add text legends to PCB layout 

10. Perform Final Checks 

In EAGLE the schematic design takes most of the time. The PCB layout itself, steps 4-9, uses 

the excellent built-in auto-router, and can be quick if layout is good, or impossible if layout is 

bad. If you take time to reposition the components carefully you will reduce the average 

length of tracks, and get better high-frequency performance from the board, as well as 

ensuring that even dense layouts can auto-route fully. 

http://www.cadsoft.de/Tour/tour00.htm
http://www.cadsoft.de/download.htm
https://intranet.ee.ic.ac.uk/t.clarke/EAGLE/Eagle_configuration.htm
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Basics 

You will be making a schematic (myname.sch) file which contains your circuit diagram & a 

PCB board layout (myname.brd) file. Each file has its own editor window. At any time you 

will change just one of these but the two are linked, so that the connections & components on 

the schematic always exist on the board. For example if you try to delete components on the 

board you will be asked to make the change on the schematic first. 

EAGLE has an excellent undo command (Edit->Undo or Ctrl-Z) which allows you to undo 

any command. So don't worry about doing the wrong thing - easy when mouse clicks extend 

connections - just undo as necessary when things go wrong. If the screen looks wrong at any 

stage, use View->Redraw (F2) to refresh the display. 

EAGLE is very forgiving - any part of the circuit can be modified at any time, providing the 

auto-router is run again to sort out track changes. 

This tutorial will take you through the design and layout of a simple circuit using EAGLE. 

Before Starting 

You will want (or if using EAGLE on a networked workstation need) to change the default 

project directory. Start the EAGLE control panel. Options->Directories gives a list of 

directories. Change the projects directory if necessary to something convenient that you can 

write, e.g. on the EEE system H:/EAGLEProjects. All new projects will be created inside 

this directory, and the EAGLE project navigator in the control panel uses this as a root. For 

more advanced use you may wish to change the other directories also. The directory changes 

made are saved under "My Documents" as eaglerc.usr, so normally need to be made only 

once. 

Step 1: Schematic Creation 

Make a project for your PCB design 

Start the EAGLE Control Panel application. Create a new project: 

File->New->Project. 

Rename the project if you wish as follows: the control panel window indicates whether a 

project is open with a green circle next to the project name. Click this if necessary to close the 

project. Then  

Right-click->Rename  

on the project's name. After having renamed the project you can reopen it. 

Right-click on the Project name ->New->Schematic. The schematic window will open. Inside 

the schematic window: 

File->Save as (choose a suitable name for your schematic sheet. NB - the freeware version of 

EAGLE allows only one sheet per design). For the first half of this tutorial you will be 

working with the schematic window, and can minimise the control panel window. 

Open component libraries 

By default all the standard EAGLE libraries are open which makes it inconvenient to select 

your components from the EEE library. Download the design project library from the web and 

save it somewhere, for example (on the departmental system) to: 

h:\eagle\lbr\ee2parts.lbr 

https://intranet.ee.ic.ac.uk/t.clarke/EAGLE/ee2parts.zip
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In the schematic command window (long thin box at top) type the following commands to 

change the open libraries: 

USE -*           <this closes all the standard libraries> 

USE h:\eagle\lbr\ee2parts.lbr  <this opens your project library> 

or 

USE < this displays an open file dialog box to find and open your library> 

If you want to use components from the standard libraries they can all be reopened again with 

"USE *". However the ee2parts components have hole sizes suitable for easy hand soldering 

and should be used preferentially - they contain all the components needed for the design 

project.  

Add components to your schematic 

Edit->Add-> Select component. 

Each open library in the ADD window contains a list of components (click + if not visible). 

Some components have multiple packages (click on + to select the correct package). The 

component schematic symbol and package layout appear in the two windows to the right of 

the library window. Each component has a description you can check to see what it is. When 

you have identified the correct component and package (component & package will be visible 

in the two windows) click OK to start the ADD procedure (NB DONT click Drop in this box, 

if you do this you will lose the current component and need to re-open the library with USE to 

retrieve it). The ADD window will vanish and a schematic outline will track the cursor when 

it is over the main schematic sheet window. Left-click to place each component. Right-click 

before placing to rotate the component. Any number of the selected component can be added. 

To stop the ADD procedure select Edit->Stop Command. 

Any number of components can be added to your schematic in any order. As described above 

you can position and even rotate components as they are added to the schematic. However 

components can also be moved after adding, with the Edit->Move command, or rotated with 

the Edit->Rotate command. Note that these menu commands can also be selected using the 

buttons on the left side of the schematic sheet window. (See also Edit->Smash in Step 3a).  

NB - you are allowed to flip/mirror schematic symbols, Edit->Mirror, e.g. op-amps to make 

+/- inputs the other way round. 

For this tutorial you will use one op-amp from one TL072 dual op-amp ICs, three capacitors 

(C) and 4 resistors (R), all from the ee2parts library. Most components result in a single 

schematic symbol, and correspond to a physical component on the board itself. However the 

op-amp is a special case. A single op-amp symbol is only half of a dual op-amp component. If 

you add multiple op-amp symbols (repeated left-clicks) you will notice that they are named 

IC1a, IC1b, IC2a, IC2b etc indicating which op-amp symbols are part of a single physical 

component. Make sure that you use add both parts (a and b) of each dual op-amp package to 

the schematic (two left-clicks in a single add operation). If one part remains unused you can 

then wire this up so that it has well-defined inputs and does not oscillate.  

After adding components your schematic should look something like Figure 1. Note the 

"spare" op-amp positioned away from the other components. 
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Figure 1 - schematic, with components 

All the operations selected from menus can also be accessed via buttons (hover mouse over 

button icons to see what each do). Most useful are the zoom buttons (top middle), and the 

Move
 

 button, Delete button , Stop button . When a command is active its button, 

and the stop button, will be highlighted. In this case right-clicking on a schematic object will 

invoke the command. A short description of the command is displayed on the bottom window 

edge. 

Add a frame to your schematic 

To make the schematic look neater add a frame (Draw->Frame) clicking on the corners of the 

frame. If you get this wrong just undo and start again. You may need to change the position of 

the frame when you draw a big schematic. It can be deleted and redrawn at any time. 

Operating on groups of components 

You can operate on many components at once - for example to move them - with the Edit-

>Group command. Edit->Group followed by either left-click and drag to select rectangle, or 

left-click any number of times to draw a polygonal boundary followed by right-click. Now the 

grouped components will be highlighted in red. If the group is wrong just repeat the operation 

till you have the correct group. Then Edit->Move and right-click will select the group for 

moving, left-click will terminate the move.  

Practice this by moving your components to a position equi-distant from all frame edges. 

Once you have defined a group it will persist until a new drawing is loaded or another group is 

defined. Other commands work on groups of components in the same way - using the group 

option under the right-click menu instead of left-click. 

Step 2: Add nets to schematic 

Use the Draw->Net command to connect components. DO NOT use Draw->Wire. 

Draw->Net 

Left-mouse click on end of source pin or wire, left-mouse click when a change of direction in 

the wire is required, left-mouse click on the destination. A connection will be made and 
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highlighted green with connected wires indicated by a bobble. Note that single right-angle 

bends will be made automatically, and that right-mouse click during the net command will 

cycle between different possible wire directions. 

EAGLE has an excellent unlimited UNDO facility (Edit->Undo). Use this when nets go 

wrong. If they go very wrong use Edit->Delete (followed by right-clicks on unwanted objects) 

to remove unwanted nets and start again. 

Step 2a Add supply connectors to the schematic 

Supply connectors are a special type of component which does not exist physically on the 

PCB. You can use them to make the schematic neater by naming supplies, and using 

connectors instead of nets to join together supply connections which are not adjacent. All 

supply connectors with the same name connect together. Some useful connectors can be found 

in the ee2parts library. Supply connectors have one more very clever use. Some ICs have 

supply pins which do not show on the schematic symbol. These will be automatically 

connected to a net with the correct supply connector (which has the same name as the pin). If 

you do not have a supply connector with the correct name it will result in an ERC error (see 

next step). Obviously it is an error not to connect the supply pins for op-amps that you use.  

Sometimes you will want to connect together distant subnets which are NOT a supply. You 

can't use a supply connector for this since op-amp outputs joined to supply connectors is an 

error. Choose a suitable alphanumeric name (e.g. sigout). Use Edit->Name and left-click on 

each of the nets to be connected – giving them the same name will connect them together. 

IMPORTANT: to make this connection visible on the schematic use Draw->Label to add a 

label (which will display the net name) to each subnet so joined. Try labelling the op-amp 

inverting output “OUT” to see how this works and then undo the operations (Edit->Undo or 

Ctrl-Z will work through any number of commands). 

Step 2b add I/O pads and testpoints to the layout 

To get signals on and off the PCB you need either connector components or connecting wires. 

The best way to join wires to a prototype PCB is via terminal pads which have circuit pins 

soldered - wires can then be soldered to the pins. Add the PAD-TERMINAL component from 

the EEE library to allow wires for the V+, V- and GND supplies. Throughout your circuit you 

will have internal nets which you need to measure when testing. Add testpoints (PAD-

TESTPOINT component) to these nets. Testpoints will appear on the schematic as small pads 

similar to terminal pads - you do not however need to solder circuit pins onto testpoints.  

 

 Figure 2. A schematic with nets and supply connectors added. 
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Schematic best practice layout 

Figure 2 shows how your circuit should look with nets and supply connectors added. Note 

how an additional GND connector simplifies connections to the unused op-amp. Note how the 

schematic is laid out carefully. Signals run left to right, connections to supplies run top to 

bottom. Supply rails themselves (where supply connectors are not used) run horizontally. 

Resistors are positioned horizontally or vertically to indicate DC voltage - more positive DC 

voltages are indicated by component ends being higher. Connections are made with the 

minimum number of bends and crossings. These rules can have exceptions, but if you follow 

them it is much easier to read the schematic. 

Op-amps and digital ICs with separate supplies 

Some ICs have symbols without supply connections, they automatically connect to specific 

named supply connectors.  

NB - note that there will only be one set  of supply connections per package, so in a dual op-

amp one op-amp symbol will never have supply connections. It is therefore not possible to run 

the two op-amps in one package off different supplies. 

TIP. If you have an IC package whose supply must be connected to a different net in 

the circuit from its name V+, and where the supply connections are not visible on any 

of the symbols - use the Edit->Invoke command as follows to expose the supply 

connections. Click on the symbol. In the box click on the request terminals you want to 

be added to the schematic. Now position the new terminals suitably on the schematic 

using a left mouse click to finish adding the terminals. Note that op-amp supplies will 

fit neatly on top of one of the op-amp symbols – but this is not true for other ICs. 

Step 3: Electrical Rule Check 

When you think you have connected everything you must do an ERC which will identify 

disconnected pins, nets which are next to each other but not connected, etc. 

Tools->ERC 

 

Figure 3 

The error messages indicate what is wrong. The error check is quite intelligent and knows 

about power supplies, inputs, outputs, etc. Click on a message to highlight the corresponding 
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error on the schematic. You can see in Figure 3 that the first error, (highlighted) is where a 

horizontal net (N$4) crosses the end of the pins of C1 and GND components.  

ERC messages indicate either errors - must be mended - or warnings - will not stop board 

layout but nevertheless indicate a problem. You should normally eliminate all warnings.  

One common source of ERC error is when wires which you want to connect look as though 

they connect are in fact not joined. Where a wire joins the middle of another there must be a 

green circle (Draw->Junction) to indicate connection. Sometimes two nets are adjacent and 

appear joined but in fact are not. The View->Show tool ( ) is invaluable here. If you click 

on any part of a net it will highlight all connected wires and component endpoints. You can 

then easily check what is missing.  When you encounter such an error simply delete (Edit-

>Delete) line segments around the problem and rewire again (Draw->Net). 

Another common error is the opposite, a net runs across the endpoint of a component without 

joining, as in Figure 4a, (the first two errors from Figure 3 are of this form).  

                                                  

    (a)            (b) 

        Figure 4 

You must reposition the component (R4) or net so that the pin and net are separate as in 4b.  

Before you make the board your schematic must pass ERC. POWER warnings which 

relate to IC supply pins connecting to the wrong net are sometimes unavoidable. For 

example, in our example circuit the op-amp V+ is expected to connect to V+ but we have 

done this via an RC decoupling network - common practice to isolate AC supply noise. 

You must examine each POWER error carefully to check that the supply is in fact 

connected as you wish. Since supply errors are common and the most difficult to correct 

on PCBs this check is important. 

Figure 3 illustrates some POWER errors, and also some “no value” errors. In this case 

we are laying out the PCB before precise R and C values have been calculated, so these 

errors will remain uncorrected. However the no value PADs should be corrected using 

Edit->Value. 

Finally all ERC errors have been corrected except some understood POWER and “no 

value” warning errors. Where an error is understood it can be approved to prevent 

future display - DO THIS ONLY IF ABSOLUTELY CERTAIN THE ERROR IS OK. 

Step 3a - Finishing the Schematic 

Now you have got a schematic which passes its ERC and can be used to generate a PCB. You 

will still wish to change it to make it easier to read. 

Adding a Document Field 

Add a document field component (docfield from the ee2parts library) to your schematic in 

the right bottom corner to provide automatic info about date etc. To set the 

>DRAWING_AUTHOR field use command Edit->Global attributes->New and add 

name=DRAWING_AUTHOR, value= <your text>. View->Redraw (F2) will update the 

displayed text as in Figure 5. 
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Figure 5 

Entering Component values 

Resistors and Capacitors should have values displayed on the schematic (and parts list) as well 

as names. Use Edit->Value to set values. Sometimes you will need to use a non-standard 

name for a component, in which case Edit->Name will allow you to change the default names 

(do not do this unless you have to). 

Changing the position of names & values 

Component names & values will often clutter up the schematic and get in the way of other 

components. Also if you have rotated the component the names & values will be rotated. You 

can move & rotate names and values relative to the symbol itself with the Edit->Smash 

command. After a symbol has been "smashed" you will be able to use Edit->Move (or left-

click->move) to move (or rotate, right-click) individual parts of the symbol. Selection of a 

group (Edit->Group) followed by smash (Edit->Smash, right-click->Smash Group) can be 

used to smash all components. 

The Layout grid 

EAGLE uses a layout grid to make it easy to align components. You should always use the 

default layout grids when positioning components (View->Grid changes this, but should never 

be needed). You can get finer control over where items are placed by using the finer 

alternative default grid accessed by pressing the Alt key while moving a component. 

(1) This is useful when you are repositioning component names and values. To get the finer 

grid, press Alt during a move operation, and the mouse will move items with 10X greater 

resolution. 

(2) This can be also used to reposition correctly connected components with a fine resolution, 

but be warned that it makes connection of the repositioned components much more difficult, 

since any new nets must be aligned with the component end-points using the 10X finer grid 

also - they will fail to connect using normal grid. Rule of thumb - don’t do this! 

(3) You may find a higher zoom factor (View->Zoom in) useful when doing fine positioning. 

Printing a Parts List 

You can print a parts list for a schematic (including resistor and capacitor values) with File-

>Export->Partslist.  
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Printing the Schematic 

You can export an image of the schematic (.png) at a specified resolution to a file using File-

>Export->Image. This can then be printed. Alternatively you can print the schematic with 

File->Print. The page limit option allows you to specify that a larger schematic (eg A3) is 

automatically shrunk down to only one page. 

Steps 4-7. Board Creation & Layout 

Step 4: Create the board 

Open the schematic created previously, which should now be correct and pass its ERC check 

(see Step 3 above for warnings which can be ignored - all other warnings and errors must be 

corrected). 

File->Switch to Board 

Since the schematic does not yet have a board attached you will be asked whether you want to 

create one from the schematic: say yes. 

The board (Figure 6) consists of all your components, with connections shown as a rats-nest, 

and a rectangular wire outline (default 100mmX80mm) which represents the board area. 

Change the user interface so that the board background is displayed in white or light yellow: 

Option->User interface->layout->tick white or coloured (see Figure 10) 

 

Figure 6: initial rats-nest of schematic components outside the PCB outline, with white 

background. Note the cross indicating (0,0). 

Change the board size 

You can do this any time, but it is easier before you have populated the board outline.  The 

wire rectangle defines where the board will be cut. To change the board size Edit->Move and 

left-click near the middle of the top or right side of the rectangle to pick it up. Re-position 

making sure the board stays rectangular, and left-click again to terminate. Don’t ever 

reposition the bottom or left sides, which should intersect very near the “origin” cross. 

Continue as necessary until the board is the correct size, making sure it stays rectangular. On 

the Freeware EAGLE you will not be able to make the board bigger than the standard size, 

which is 100X80mm. For the EE2 project you must move both top & right edges inwards to 

reduce the board size to precisely equal that given you in the instructions, leaving bottom & 

left edges unchanged. If you make a mistake you can always delete the .brd file and recreate it 

from the schematic. 
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Once you have created a board EAGLE will remember the connection between the board and 

the schematic, and keep them consistent. Make sure that if you ever load one you allow 

EAGLE to load the other (which it will normally ask to do automatically). This means that 

consistency will be preserved whatever changes you make. (EAGLE calls this "forwards & 

backwards annotation"). 

If your board gets totally messed up, or inconsistent with the schematic, it is easy to start 

again. Delete the board file (*.brd) and follow the instructions in this section for creating a 

new board from the schematic. You will have to reposition all your components. 

Use EEE custom DRC and autoroute parameters. 

In order for board manufacture to allow easy soldering we need to make pads bigger by 

changing the default DRC rules. You need do this only once for a given board. First download 

ee_rules_dp.dru & ee_autoroute.ctl from web pages. 

Tools->DRC->FILE tab->Load->choose downloaded eerules_dp.dru file.->apply->select 

Tools->auto->general tab->Load->choose downloaded ee_autoroute.ctl file->select 

Step 5: Position the components inside the board outline 

Move the components one by one inside the rectangular board outline (Edit->Move) and 

position them where you want. Note that you must move components into the allowed 

100*80mm area and cannot rearrange them outside the allowed area - this is a restriction 

imposed by freeware EAGLE. It is a good idea first to print out the schematic so you know 

what is connected to what and can easily position components in a logical order. Do not worry 

if you get things wrong, you can reposition at a later stage. Note that you can also rotate 

components (Edit->Rotate). NB - you are allowed to flip/mirror PCB components. DONT DO 

THIS - it will require the component to be mounted on the wrong side of the board! 

 

(a)      (b) 

Figure 7 

(a) Rat's-nest connected components positioned on board layout - in this case it is easy 

to optimise layout by rotating & repositioning components to untangle the rat's-nest.  

Note the black board outline & cross on lower left which marks the (0,0) origin. 

(b) Auto-routed tracks (blue = bottom layer, red = top layer) 

dru/ee_rules_dp.dru
ctl/ee_autoroute.ctl
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When all components are on the board in the correct positions, start the auto-router. 

Step 6: Route the tracks 

Tools->Auto... 

This has many options, but the EEE defaults (which you loaded via ee_autoroute.ctl) 

normally work fine so click OK. The rats-nest connections will be changed into routed PCB 

tracks as in Figure 7b. You know the routing is complete because of the message in the bottom 

edge of the window (Figure 8). Anything less than 100% indicates some connections not 

routed. 

 

Figure 8 

NOTE – dense circuits may get less than 100% routing. In Step 8 when you add poured 

copper connected to V- this will simplify routing and may cure problems – so do not 

despair at this stage. Layout optimisation should be done AFTER step 8, when the final 

tracking is known. 

If you now change the position of any component or add or delete components the routing will 

need to be adjusted. The easiest way to do this is to rip up all connections to get back to "rats-

nest" wires and auto-route again, using a command in the command box (immediately above 

layout): 

RIPUP; 

Reply yes when asked whether you want to rip-up all tracks. All tracks will vanish to be 

replaced by another "rats-nest". 

Step 7: Design Rule Check 

Tools->DRC 

This command will bring up a window showing the currently loaded set of design rules – for 

the EE2 design project this should be ee_rules_dp latest version, which you loaded in step 4. 

To change to a new set of rules (in a .dru file), click Load, select the new file, click Open, to 

view the new rules, then click Apply to use them with the board. 

Click Check and this will run the design rules and say whether there are any errors. If there 

are errors Tools->Errors will display them. You must correct all DRU errors. 

Step 8: Pour Copper 

PCBs should normally have all area not used for tracks covered with copper "ground plane" to 

reduce high-frequency noise. This does not interfere with the normal tracks, in fact it can be 

used to reduce the tracks required. Normally, all "poured copper" is connected to a single 
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circuit supply connector. EAGLE is clever enough to route connections on this supply using 

the poured copper, thus reducing the number of tracks.  

An added bonus is that the poured copper connections are much lower impedance than is 

possible using tracks. 

We will first add poured copper to the tutorial board in the simplest possible way. We use one 

side only and connect the poured copper to the power supply connector GND. 

EAGLE uses polygons drawn on top or bottom of the board to mark the boundary of an area 

within which copper will be automatically poured. 

To draw a polygon  for the V- supply type “Polygon GND” in board wndow command box: 

 

Select from the top toolbar drop-down box the layer (top or bottom) on which you want to 

place the polygon from the top toolbar. (All other options can be unchanged). 

 

Then left-click for each corner of the polygon, and right-click for the last corner. Figure 9a 

shows a polygon round the whole board. 

         

(a)   Figure 9    (b) 

After drawing the polygon you should rip-up all tracks, and recalculate the rat's-nest wires: 

RIPUP;                           (rips up all tracks) 

Tools->Rats-nest            (recalculates the rat's-nest wires, which may have changed) 
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and auto-route again. The auto-router will now try to connect all filled copper areas to the 

appropriate supply. Figure 9b shows that the number of tracks is now significantly smaller, 

with one side copper making the GND connections. (In more complex designs there will also 

be tracks on this side - here it was not necessary). 

Do the DRC check again after pouring copper. 

If you need to change the layout or even the schematic after this final step you can still  

RIPUP the tracks. To remove the poured copper use Edit->Ratsnest, and auto-route again: 

1. RIPUP;  

2. Tools->Ratsnest 

3. Tools->Auto... 

(This can be done in one go using the command line: ripup; ratsnest; auto; ) 

Tips: Your polygon can be drawn as near to the edge of the board as you like. Leave some 

area around the edge of your board empty of components: at least 2mm. This will be filled 

with copper and make a ring connecting together all the different filled areas easily. If you end 

with very large unfilled areas your board layout is too dense, change it to allow room for 

poured copper. Medium-sized unfilled areas do not matter. 

Viewing poured copper 

After Tools->Auto both tracks and poured copper will be displayed. This can make it difficult 

to see tracks. Save the board, exit, and reload it. After the reload you will see tracks, and 

polygon boundaries, but no poured copper. The layout is identical, and can be sent for 

manufacture in this form (without another Tools->Auto command) but will be easier to view. 

To see the poured copper, execute another Tools->Auto command. Figure 10 shows part of a 

layout with poured copper visible on both sides. Note that top + bottom copper is coloured 

dark brown, top only is red, bottom only is blue, and that colours can be changed using 

Options->User interface. 

    

(a) white layout background   (b) coloured layout background 

Figure 10 

Usage of Poured Copper 

You should draw identical large polygons on both sides of the board. Repeat the polygon 

operation, selecting the other side in the top bar layer box. Normally both polygons should be 

filled with the same supply but in some cases you could use different supplies for top and 

bottom copper - on dense layouts the problem with this is that there are too many tracks and 

each supply layer on its own does not fully connect - whereas two identical supply layers will 

connect fully. 
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EAGLE allows any number of non-overlapping polygons to be drawn on either side, and each 

polygon connected to its own supply (or they could all be the same). Overlapping polygons on 

the same side must be connected to the same supply. 

More on Poured Copper 

Poured copper will automatically join with pins on its own supply net. These pins will connect 

copper on the two sides if both sides are same supply. HOLE-VIA components can be added 

to join together both sides at other places. They must be connected on the schematic to the net 

(V-,GND,etc) that is used for the poured copper, & may then be positioned as required on the 

layout. This will allow the copper fill to reach areas on the board only filled on one side. 

Step 9: Final Touches 

Any part of your design schematic or board can be modified at any time, with new auto-

routing managing the new layout. 

Component names 

On the PCB layout “silk screen” (usually a white painted legend on top side) components will 

be identified by their layer 25 names (IC1, R2, etc). The name text may be difficult to read, or 

lie underneath the component or pads and so be hidden after soldering. This can be cured as 

on the schematic using smash to separate name and component followed by move, rotate as 

necessary. Note that component values (if you have layer 27 visible) are not put on silk-screen 

and so do not matter. You should therefore normally switch the tvalues 27 layer off (View-

>Display/hide layers->click on 27 till it is not displayed black). 

Text 

Add a caption to the board, and your names! This can be done using the TEXT command 

Draw->Text 

Enter the text you want, then click OK. The toolbar in 11 will appear and your text will follow 

the cursor ready for insertion using a left-click: 

 

Figure 11 

Change the layer, angle, size, ratio, and font till they match those on the toolbar in Figure 11. 

You can increase size from this, but not decrease it (to be precise, size*ratio > 0.01 is required 

by some board manufacturers). You can check the results by moving the cursor over the PCB 

layout. 

When all is correct place the text on the PCB layout using left-click. 

Use the tPlace layer (no 21) for lettering if your board will be manufactured with silk-screen, 

and for the EE2 project. Lettering can overlap copper tracks in this case. If your board will 

have no silk-screen you can put your text on the top (1) or bottom (16) copper layers. In this 

case be careful to place the text somewhere well away from components and tracks.  

Note that proportional (non-vector) fonts must be vectorised at the CAM stage and therefore 

change slightly on output. This can mean that a font which does not touch tracks on the board 

in EAGLE will touch them on the output board.  Use of vector fonts avoids this problem. 
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Remember to do another DRC check after this step if you are adding text to copper - just in 

case something goes wrong. 

 

 

 

Step 10 Final Checks before Manufacture (EE2 project – 

NOT EE2Lab PCB Touch switch) 

YOU MUST check these before submitting your final brd and sch files. 

 Check current board layout is saved 

 Check no ERC warnings or errors (except lack of value for R,C and supply nets with 

wrong name – and these must be checked on schematic). 

 Check DRC rules loaded are correct for manufacturer (eerules_dp.dru v3.40 2008). 

 Check board size is rectangular and has precisely the specified X,Y dimensions using 

run->statistic_brd. Boards with incorrect dimensions will be rejected 

 Check auto command gives 100% routing without polygons falling apart (message 

at bottom of window after auto command) 

 Check there are no DRC errors 

 Check component names (layer 25) are all visible, on board, not overlapping pads, and 

if possible not hidden under components. Note that component values (layer 27) are 

not printed on silk screen. (Board will be OK if you do not do this but less easy to 

build) 

 Check that no object (track or pad) lies within 2mm of the board edge 

 Check you have included, easily visible, a layer 21 caption giving your lab group 

Your .brd file now contains all the information necessary to manufacture the PCB, however 

make sure you keep safe both this and the schematic – you will be able to print schematics, 

layouts, component value lists etc for use in debugging. 
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Appendix A. Routing Problems 

Some layouts can be very difficult to auto-route, especially when  SMT packages are used 

with dense connections. 

      
   (a) - tracks                (b) ratsnest 

Good layout for a difficult circuit with 100% auto-route 

 

       
(a) tracks     (b) ratsnest 

Bad layout for same circuit with 97% auto-route 

 

Strategies to obtain 100% routing 

 

1. Reposition components for shorter tracks 

2. Reduce autoroute grid pitch (0.5mm is used for above board to allow efficient routing 

of 1mm pitch SMT pads). 

3. Reduce track width/spacing and pad size in DRC rules. This will always help, but 

makes the board more difficult to hand-solder. DRC rules must be compatible with 

manufacturer specifications. 

4. Add manually positioned vias to encourage correct routing of difficult tracks, or of 

supply layer, if “polygons falling apart” message is observed. Hole-via components 

must be connected to correct net on schematic and positioned as required on layout. 



 17 

Appendix B. Command Shortcuts & Further Information 

For convenience you can use alternative ways to run commands: 

1) All commands have a text version which can be typed in the command window. 

2) Menu commands have equivalent action buttons on the LHS of the schematic & PCB 

windows. Hover the mouse over each of these to find out what they do. 

3) The short-cut function keys (see Options->Assign) can be used instead of menu commands. 

4) Left-click on an object provides a context-sensitive list of commands including properties. 

Object properties can be modified to change aspects of the object (e.g. layer etc).  Deletion etc 

can be selected via left-click: 

Left-click->delete is a short-cut for Edit->delete, left-click. 

EAGLE has a very large number of special-purpose add-ons (ULPs) written in its own 

programming language. See the EAGLE web-site for further information and a wider 

selection than is in the EAGLE download. These can be run from the EAGLE control panel 

File->Run->select ulp. Useful ones: 

renumber_sch.ulp  

Changes all component numbers in a schematic (or schematic & board) to 

remove gaps. NB - if you have a board make sure the board & schematic 

are loaded when you run this - otherwise they will become inconsistent. 

statistic_brd.ulp Display info about board size, number of holes, etc 

traceres.ulp Display calculated resistance of each track on the layout 

For use of EAGLE on EE in-house boards, or for more information about EAGLE routing and 

customisation, see the configuration guide. 

Further documentation on EAGLE can be found in the excellent Tutorial or the 

comprehensive Manual. If you need to design your own library components you should 

consult the manual for walkthroughs. 

EEE department web documentation on EAGLE: www2.ee.ic.ac.uk/t.clarke/EAGLE. 

http://www.cadsoft.de/cgi-bin/download.pl?page=/home/cadsoft/html_public/download.htm.en&dir=eagle/userfiles/ulp
http://www2.ee.ic.ac.uk/t.clarke/EAGLE/EAGLE_configuration.htm
file:///C:\www\eagle\tutorial_eng.pdf
https://intranet.ee.ic.ac.uk/t.clarke/EAGLE/manual_eng.pdf
https://intranet.ee.ic.ac.uk/t.clarke/EAGLE

