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Game Map Generator
Extension panel for Photoshop® CS6
Plugin for Photoshop® CC-2014 / CC-2015 +

Many thanks that you decided to buy the Game Map Generator (GMG).

Build your own map or background for your game! By using the Game 
Map Generator it is as easy and fast as never before to create maps 
and backgrounds for many different game genres like e.g. Role-Play-
ing Games or MMORPG, Tower Defense and other Real-Time Strategy.

With only one click you can create any possible map size for which 
every isometric icon and character animation is suitable! It all makes 
this little app very versatile and applicable in multiple ways. Perfect 
for game developers with little Photoshop knowledge, but also essen-
tial for professional game developers as a big time saver. 

As default textures there are 3 different surfaces available: grass, de-
sert and ice/snow. In additi on 4 grid versions can be shown if necessary.

With the additional Isometric Transform Tool every 2D shape can be 
transformed to the correct isometric perspective. That is very useful 
especially if the basic shape for a GMG Element is not already set in 
the correct perspective (the basic shape is used to create the Game 
Map Genarator Elements, like water bodies, streets and so on). Also 
for icon designers the Isometric Transform Tool is a great assistant.

The heart of the plugin are the 23 detailed GMG Elements: different 
kind of water bodies, paths, streets, ditches, canyons, plateaus, lava 
ravines through grass, snow/ice and desert. These can be built out of 
any shape – no matter if pixel, vector, Smart Object or text layer.

The procedure is very simple: create a basic shape and then click on 
the desired GMG Element. The basic shape can be created with one 
of the five brushes from the panel. Simply click on ADD LAYER and 
start drawing. The Game Map Generator will create a detailed GMG 
Element of it, that can be edited afterwards.
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Every Game Map has its own surface texture requirements. With the 
18 high quality textures and the 7 different brushes almost every 
surface can be built in a fast and professional way. Simply click on the 
desired texture and start texturing. Every texture has its own pre-
setting of brushes, that can, of course, be edited to fit your personal 
requirements.

For basic design there are 60 isometric high quality icons available. 
But also every other icon can be used. If the plugin is used with Photo-
shop CC-2014 / 2015, there is an Icon Library Function additionally 
available. With it you can load your own icons (PSD or PNG) directly 
into the plugin. So it is very easy to retrieve every icon and to scale 
it with the useful scale function.

Features Overview

•	 Creates isometric game maps and backgrounds
•	 Unlimited map size
•	 Unlimited professional results
•	 23 one-click GMG Elements possible from every shape
•	 7 pre-built brushes and 18 high quality textures
•	 Special effect brushes
•	 Random textures functions
•	 Global light function

Extras

•	 60+ isometric basic icons
•	 Icon Library Function (only from Photoshop CC-2014)
•	 Isometric Transform Tool
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Panel Overview

Map
Simply insert the desired map size and here it goes! The app creates 
a map with grass surface and isometric grid. The default surface can 
easily be changed to desert or snow/ice. The isometric grid can be 
changed or hidden as required. With the global light function you 
can set the light incidence for the whole document. All settings are 
editable at any time.

With the Isometric Transform Tool all basic shapes (for creating the 
GMG Elements), all text layers and every other simple shapes can be 
transformed into an isometric perspective. 

Insert map size

Set global light

Change the main 
ground texture

Hide or change the 
isometric grid

Transform shapes into 
isometric orientations

Main navigation
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Elements
To create a GMG Element (i.e. Game Map Generator Element), a basic 
shape has to be created first. This can be a pixel shape, a vector shape, 
a Smart Object or a text layer.

To create a pixel shape, first click ADD LAYER. An empty layer will be 
made and a brush pre-selected. You can start drawing immediately 
by using the Game Map Generator brushes or one of your own. If 
you are done, click on the desired GMG Element. (Make sure that the 
basic shape is selected.) The original basic shape remains unchanged 
and is now found in the “original_shape” folder in the just made  
GMG Element. So it can still be edited or used again for another 
GMG Element.

Add a new shape layer

Change the pre-selected brush

Select a GMG Element
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Texturing
To create a texture layer, just click on one of the 18 textures. The 
app will create a texture layer in the folder “surface_texture_group”. 
The surface that should be textured can be edited by painting on the 
mask. Therefore the mask must always be selected – not only the layer!
(Please watch the tutorial video “Working with masks” link p.21) 
Every texture is allocated to one of the pre-set brushes, but of course 
you can also use your own brushes instead. 

With the special brushes it is very easy to conjure up little flowers, 
tendrils or grass. A whole carpet of flowers, mushrooms or clover 
with only one click can be made with one of the three random textures. 
All areas that should not be textured can be covered by using a mask.

7 pre-set brushes

Select the main ground texture

3 special brushes

Random textures
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Icons
In the tab “Icons” you can find all the 60+ basic icons. It is also pos-
sible to load your own icons into the panel. You can upload PNG files 
or PSD files with only one layer:

1. Select the icon folder
2. Thumbnails are generated automatically
3. The icons can be loaded

At the first load of an own icons folder a “thumbnail” folder will be 
generated. If the folder should be filled with new icons, first the 
“thumbnails” folder has to be deleted manually to upload all icons 
into the panel.

Icon size slider

Load your own icons

Did you also buy our isometric 
icon sets? Then just select the 
folder “psds_single” in the set 
to load the editable icons into 
the panel.
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Install the Panel in  
Photoshop CC-2014 / 2015 +
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Install the panel – Photoshop CC-2014 / 2015 +

IMPORTANT: 
Do not modify the content of the Game-Map-Generator folder!
If you modify the content of the folder, the plugin will no longer 
work. Then you have to download it again.

1. Open Photoshop, go to File > Scripts > Browse... 
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2. Browse to the unzipped 01_installation > CC-2014+ folder 
and select the Game-Map-Generator-installer.jsx

3. Follow the instruction
4. Restart Photoshop
5. Browse to Window > Extensions > Game Map Generator
Done!

 

Uninstalling
1. Click the HELP Button in the panel and scroll to 5.
2. Click the Uninstall Button and follow the instruction
3. Restart Photoshop

Done!

Uninstalling


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Alternative 
manual installation
Photoshop CC-2014 / 2015 +
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Alternative manual installation 
Photoshop CC-2014/2015

Windows
Navigate to your download folder > 01_installation and copy the 
folder “Game-Map-Generator”  to the appropriate directory:

Windows 64: 
C:\Program Files (x86)\Common Files\Adobe\CEP\extensions\
Windows 32: 
C:\Program Files\Common Files\Adobe\CEP\extensions\

If the Adobe\CEP\extensions folder does not exist, you can create it.

Restart Photoshop. You will find the extension in the Photoshop menu: 
Window > Extensions > Game Map Generator

OSX
Launch Terminal and run this command to open the install folder 
(or open the folder by yourself):

open /Library/Application\Support/Adobe/CEP/extensions/

Navigate to your download folder > 01_installation and copy the  
folder “Game Map Generator” into the extensions folder.

Restart Photoshop. You will find the extension in the Photoshop menu: 
Window > Extensions > Game Map Generator

Ensure that you do not modify the Game Map Generator folder.  
Doing so will cause a “The Game Map Generator extension could  
not be loaded because it was not properly signed” error when you  
try to launch it.



© 2016 All Rights Reserved Orange_Box | www.the-orange-box.com                      Game Map Generator | 14

Uninstalling the manual installation

1. Navigate to the extensions folder to the appropriate directory:

WINDOWS
Windows 64: C:\Program Files (x86)\Common Files\Adobe\CEP\extensions\
Windows 32: C:\Program Files\Common Files\Adobe\CEP\extensions\

OSX
/Library/Application\ Support/Adobe/CEP/extensions/ 

2. Delete the “Game Map Generator” folder.
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Install the Panel in  
Photoshop CS6
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Install the panel – Photoshop CS6

To install the Game Map Generator you will need a copy 
of Adobe Photoshop CS6 and the latest version of Adobe Extension 
Manager ( https://www.adobe.com/exchange/em_updates/ ) 
installed on your computer.

1. If Photoshop is open, please close it.
2. Open the Adobe Extension Manager CS6

Note: Some Windows users may have to run Adobe Extension Mana-
ger as an administrator in order to install the extension. To do this, 
right click the Adobe Extension Manager icon and select “Run as ad-
ministrator.”
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3. Click the install button and browse to the extension 
Game_Map_Generator_CS6.zxp

4. Follow the instructions and install the panel. 
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Don´t worry about this alert message, just click “install”.

5. When the extention appears in the list, open Photoshop.





© 2016 All Rights Reserved Orange_Box | www.the-orange-box.com                      Game Map Generator | 19



6. You will find the panel under 
Windows > Extensions > Game Map Generator!

7. (CS6 only) Click the “Install” button in the panel - DONE!

Windows > Extensions > Game Map Generator!
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Advices

To install the panel you will need Photoshop CS6 / CC and the latest 
Adobe Extension Manager:
https://www.adobe.com/exchange/em_updates/ 

Some Windows users may have to run Adobe Extension Manager as 
an administrator in order to install the extension. To do this, right 
click the Adobe Extension Manager icon and select “Run as  
administrator.”

Important (Photoshop CS6 only)

If you are using more than one panel from Orange Box it may come to a conflict 
with the error message “Expected a reference to an existing File/Folder”. This is not 
an error in the panel but a path problem in Photoshop.

Our suggestion:
Only open the favored panel after starting Photoshop. Do you want to use another 
one, save your work, close the open panel and restart Photoshop. Now you can 
open another panel.

Up to now we have no solution for this conflict. As soon as we resolve the problem, 
we will provide an update.
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Tutorial Video Link List

Teaser: https://youtu.be/xQd9JqGE4-c
Demo - Features and workflow: https://youtu.be/eQ-S5RDZkhQ

For CC-2014 / 2015 +
1.	 Install: https://youtu.be/skewvCqJq_A
2.	 Uninstall https://youtu.be/lU0xX8LfKy0
3.	 Generate a basic map: https://youtu.be/dk4K6eJz_jw
4.	 Generate a GMG Element: https://youtu.be/GKGhoQw9LjQ
5.	 Texturize the map: https://youtu.be/n7JPJ01JUGI
6.	 Place the basic icons: https://youtu.be/Z0BcpsWnxEw
7.	 Load icons into the panel: https://youtu.be/ntLgBcZoUwU

For CS6
1.	 Install: https://youtu.be/Bi32_gR-OGA
2.	 Uninstall https://youtu.be/--CRF5_O4eQ
3.	 Generate a basic map: https://youtu.be/QYiGXiXflLg
4.	 Generate a GMG Element: https://youtu.be/AFR1BLzsngg
5.	 Texturize the map: https://youtu.be/6_MI3lYvGSs
6.	 Place the basic icons: https://youtu.be/jt-AGgtWUaU

Resources

Tutorials
Working with masks: https://youtu.be/QgmTl2Hbdsc

Used Free Fonts
Luckiest Guy: https://www.google.com/fonts/specimen/Luckiest+Guy
Runic: http://www.fonts2u.com/runic-regular

!
More 3D-Map-Generator Infos,  
Tutorials and Stuff:
www.3d-map-generator.com
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Support and troubleshooting

Of course we will support you with the installation and usage of the 
Game Map Generator. Just write us an e-mail by using the contact 
form on our envato profile page.

http://graphicriver.net/user/Orange_Box

But before you send your message, 
please read the instructions and watch 
the tutorials. It’s much faster than 
waiting for a reply. We spend a lot of 
time to describe all steps very well.

 
Didn’t you find the answer?

Then please log in to your envato account and use the e-mail form at 
your profile page to contact us.

If you are reporting an issue:

• give us as much information as possible (Photoshop Version,   
OS version)

• tell us what exactly you have done
• screenshots are helpful
• videos are very helpful


