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1 Getting Started With MacGourmet Deluxe

This chapter introduces you to MacGourmet Deluxe
Welcome to MacGourmet! In this chapter, you will be introduced to the basics of 
MacGourmet a recipe, wine and cooking note organizer.

Running MacGourmet for the First Time
When you start MacGourmet for the first time you will be asked a few questions to get 
you started:

Widescreen: More suitable for MacBooks and newer wider display screens, displays 
your data using 3 side-by-side columns.

3-pane: Used to display your data in the same way that your Mail application does.
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Summary Views: Single column views that allow you to quickly see and change infor-
mation, all in a compact space.

Multiple Columns: Display your information using a column for each value.

Large and Small Icons: Set the size of the icons in the source list on the left-hand side 
of your recipe box.

Creating your MacGourmet library

The next prompt will ask you where youʼd like to store your library. Press the “Use 
Documents” button to keep your library in your Documents folder. Press the “Specify 
Location” button to specify a different folder for your library.

Wherever you decide to create your database, all of your information will be stored in a 
file named MacGourmet3Database. Donʼt forget to back this library file up from time to 
time.

This database file cannot be moved (without changing the location in 
Advanced preferences) or renamed, and if this happens, MacGourmet 
will think that it needs to create a new database when you launch it after 
doing either of these things. 

If this happens, you can restore your information by just moving your 
MacGourmet3Database file back to the original location or by changing 

the name back to what it was originally.
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Loading the sample recipes and notes

If you want to add some sample recipes, press the “Yes, Please” button to add them to 
your initial library. If youʼd rather start with an empty library, just press the “No Thanks” 
button.

Installing MacGourmet Plug-ins
MacGourmet Deluxe plug-ins come packaged in double-clickable files that will launch 
MacGourmet Deluxe, if itʼs not already running, and install any new functionality con-
tained in them automatically for you.

There are many plug-ins available for MacGourmet Deluxe, free extras like, tools and 
importers for both recipe file formats and web sites.

MacGourmet Package File: Just double-
click to install its contents.

To uninstall a plug-in, you only need to double-click on the package file again, and 
choose the “Uninstall” option when an existing version of the plug-in is detected.
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MacGourmet Feature Overview

Your recipe box has 3 main lists for storing your items, “Recipes,” “Notes” and “Wine 
Notes.” Each of these lists holds the master copy of each respective item type in your 
database. You can easily put items in lists that you create, but they really just refer back 
to the master copy. 

For instance, if you create three of your own lists and then drag a recipe from your 
“Recipes” list to each of these three lists, you will see four copies of your recipe in dif-
ferent locations. There will, however, only be one REAL copy. The other three recipes 
that you see in the lists you created are really just pointers back to the master copy. This 
means that modifying that recipe anywhere will change all the instances of that recipe, 
no matter where you put it. 

If you delete an item in one of your lists, it is removed from your list. It is not removed 
from your database however, unless you explicitly delete it, or you delete it from one of 
your master lists.
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Recipes

Your “Recipes” list shows you all of the recipes in your database. This list can only con-
tain recipes. If you delete a recipe from this list, it will get deleted from your database.

Notes

Your “Notes” list like your “Recipes” list, shows you all of your notes. Deleting and copy-
ing notes from this list works like deleting and copying recipes from your “Recipes” list.

Shopping Lists

This list shows you all of your current shopping lists. Unlike recipes, wine and cooking 
notes, shopping lists can only exist in this list. When you create a shopping list from one 
or many recipes, it will get added to this list. Deleting a shopping list from this list will de-
lete it from your database. You can add a new shopping list by dragging one or more 
recipes to this list, in addition to the normal ways of creating new items. For more infor-
mation on shopping lists, please see section 10.

Wine Notes

Your “Wine Notes” like your “Recipes” list, shows you all of your wine notes. Deleting 
and copying notes from this list works like deleting and copying recipes from your “My 
Recipes” list.

Clippings

The Clippings list contains selections of text “clipped” from web sites, using the “Make 
MacGourmet Text Clipping” menu item in the Services menu, by dragging text from 
other applications to this list, and by pasting text into this list. Clippings can be double-
clicked and imported using the Recipe Import Assistant.

Featured

Featured lists are lists of recipes, etc., that are published on the MacGourmet website 
and displayed within MacGourmet. This list is retrieved from the web, and includes lots 
of recipe packages put together for MacGourmet users. Importing them is as simple as 
finding the packages or recipes that you want to try and dragging the package or recipe 
image to a list in your Recipe Box, or by clicking on the image for a package or recipe. 
This content will be updated regularly and will offer users a quick and easy way to add 
great recipes to their collections.
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Find Results

The results of searches you do using the Find menu appear in this list.

Last Import

Your "Last Import" list displays the items that were added to your database the last time 
you imported something. Every time you do an import, the current list items are re-
placed with any newly imported items. Don't worry though, because even though the 
items were removed from your "Last Import" list, you will still be able to find them in your 
appropriate "My" list and anywhere you might have copied them.

Smart Lists

Smart Lists allow you to create lists of items that match find criteria you specify. Once 
created, they can be configured to keep themselves up-to-date as you make changes to 
your database, like imports, rating changes, etc.

To create a new Recipe Smart List:
1. Click on the view that holds all of your lists.

2. Right-click or Ctrl-click on the list and choose New > Smart Recipe List from the 
menu.

3. Alternatively, choose File > New > Smart Recipe List.

User Lists

(Lists and Sub-lists Created By You)

User lists, unlike your master lists, can contain sub-lists, and any kind of item. Also, un-
like your master lists, deleting an item from a user list doesn't remove it from your data-
base. It only removes it from its user list. Unless you delete an item from a master list, it 
can be added to and deleted from any user list, and moved and copied to any location 
that you would like. Removing an item from its master list however, will also remove it 
from any list that contains it. This means that if you remove a recipe from your “My 
Recipes” master list, it will also be removed from all of your user lists that contain it.

To create a new User List:
1. Click on the left-hand view that holds all of your lists, so that it has the focus.

2. Press the “+” button at the bottom left of your recipe box.
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To create a sub-list in a list:
1. Select the list you want to add the new sub-list to.

2. Right-click or Ctrl-click on the list and choose New > List from the menu.

3. Alternatively, choose File > New > List or ⇧⌘G (shift-⌘-G).

Recipe Box Widescreen and Normal Display Modes
Your recipe box is able to display your information in two different modes, widescreen 
and normal. Widescreen mode stacks your columns side-by-side and can better take 
advantage of more recent Apple widescreen displays. You can see this in the image that 
begins this chapter. The normal, or “Mail” mode uses a display similar to that used by 
Appleʼs Mail application. 
The mode used can be set 
in Preferences.

In addition to these 
modes, the column that 
displays the items in the 
main selected list can also 
be shown using either the 
normal multi-column “list”, 
or using a “summary” ver-
sion of the list, which are 
more suited to widescreen 
mode. When displayed us-
ing summaries, the items 
in the list will be displayed 
in a single column, with 
taller rows that contain a 
summary of information for 
the selected item, including 
its image, etc. 

You can quickly flag, rate, scale and mark recipes as prepared by clicking on the re-
spective icons in the summary views. 

To toggle between list and summary lists, select the item list and choose View > Use 
Columns or View > Use Summaries (depending on that the current selection is).

Finally, you can also display the icons in the source list on the left in two ways: with 
large icons, or using smaller icons. To change this setting, select something in the 
source list and choose View > Use Small Icons or View > Use Big Icons.
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Customizing Your Table Columns
The table columns of each type of recipe box list is customizable. This lets you show 
only the columns you are interested in. It also allows you to display them in the order 
you desire.

To access the list of columns to display:
Hold the right mouse button down (or press the ctrl key on your keyboard and hold 
down the mouse button) and click on any table column. When you do this, a menu with 
all of the available columns is displayed, with a check mark next to all of the columns 
that are set to display. If you want to hide a column, just select a checked column name 
from the list, the checkbox next to the item will no longer appear, and the column will be 
hidden in your recipe box. To show column, select an unchecked column from the list to 
add a checkbox, and the column will be then displayed.

You can also choose View > View Options... 
when the list is selected to display the Op-
tions window:

Note: this can only be used when using 
columns, not when using summaries.

To rearrange your columns:
Click on a column header and drag it to a new position.

Note that there are different columns for different list types. For instance, selecting a list 
that only displays recipes will have recipe-related columns available, selecting a wine 
note will have wine-note related, etc. User lists, because they can contain any type of 
item, will only display columns that are common to all of the items it can contain.

Creating and Editing
You can edit and view recipes and notes simply by double-clicking on an item in a list to 
open its editor. Double-clicking on a recipe, for example, will open the recipe editor. The 
editor for an item allows you to view and change any of the itemʼs information, including 
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adding notes and 
pictures.

Creating an item 
is done by select-
ing the appropri-
ate menu item 
from the File > 
New submenu. 
You can also use 
the “New” toolbar 
item, which will 
create a new item 
for the selected 
list. If you are in 
one of your user 
lists, which can 
contain different kinds of items, you will be prompted for the type of item to create.

You can display editors as both dialog windows and sheets, which are attached to the 
main window. To specify the editing style youʼd like to use, change the “Display editors 
as sheets” option in Preferences.
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The Chef View - Your Kitchen Cooking Helper
If you have your laptop or computer in the kitchen with you while you cook, you can dis-
play any recipes you are working on in a Chef View. Chef Views are windows containing 
a view of your recipe that is optimized for use while cooking. The text is large enough so 
that you can read the ingredients and directions from a distance. This view also displays 
only what you need to see while cooking, the list of ingredients and the directions. This 
means no extra fluff like the pictures, ads and web navigation that you get when display-
ing a recipe on a web site in a web browser.

MacGourmetʼs chef view will speak the text of the selected recipe or ingredient if en-
abled, and it will also respond to voice or Apple remote commands.

Viewing More than One List at a Time
Not content with just viewing and organizing your recipes and notes in your recipe box? 
No problem. MacGourmet allows you to open lists in their own windows, with their own 
item views, for extra flexibility. This allows you to see one of your lists in its own “recipe 
box” like window, without a view on the left side. In addition, updating or adding anything 
to a list when viewed in its own window will also cause the update to happen in your 
main recipe box, keeping everything synchronized for you. 
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To view a list in its own window, select a list and either press the “View List” toolbar item, 
or choose “View List” 
from the File menu.

Changing the 
Look of Recipes 
and Notes
MacGourmet doesn't 
give you just one set of 
fonts and colors for dis-
playing recipes and 
notes. Go to the General 
Preferences tab and se-
lect the look you want 
with a recipe selected in 
your recipe box to see 
the layout change

Viewing Larger Versions of Your Images
While the image for a selected item may be small, to make it easier to display more in-
formation, you can see a larger size of any image, if there is one, by clicking on the im-
age in your recipe box.

Viewing More than One Item at a Time
Displaying read-only versions of more than one item at a time can be done by choosing 
File > Display Item for each item.
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Scaling Your Recipes
MacGourmet allows you to arbitrarily change the number of servings, by scaling the 
original servings amount. To scale the servings of a recipe, you first need to have en-
tered a servings amount. Then, you can scale your recipe in one of two ways: If you are 
using the Summary views, you can just click on the  icon to display the scaling win-
dow. To change the number of servings, you just enter a new amount and press “Scale”. 
You can reset your recipe to the original servings amount by pressing the “Reset” 
button.

Another way to scale your a selected 
recipe is to select it and choose:

Edit > Recipe > Scale Servings

This is display the scaling window, 
seen below. Changing the servings 
works the same way as using the pop 
up scaler, described previously, does.

Scaling your recipes doesnʼt actually 
change the original, it just creates a 
scaled “view” of the original recipe. 
You can always go back to the original 
servings amount by displaying one of 
the scaling windows and pressing the 
“Reset” button.
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Recipe Box Toolbar Icons

New - Add a new item

Delete - Delete the selected item or items

Get Info - Display the editor for the item

New Shopping List - Create a new shopping list using the selected recipes

Chef View - Display the chefʼs view for the selected items

Print - Print the selected items

Export - Export the selected items

Import - Import items into your library

Lists Editor - Edit categories, courses. equipment, cuisines, etc.

Send Email - Email the selected items

View List - Display the selected list in a separate window

Nutrition Database - Display the database main window

Weekly Planner - Display the Mealplan weekly planner window 

Cookbook Builder - Display the Cookbook builder window)
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2 Creating and Editing Recipes

This section describes creating and editing your recipes.

Creating New Recipes
To create a new recipe, choose File > New > Recipe (⌘-N). This creates a new empty 
recipe in the currently selected list, provided it is editable and can contain recipes.

Editing Your Recipes
You can edit and view recipes simply by double-clicking on one in one of your lists or by 
selecting something in your recipe box and choosing File > Get Info.

The Info Tab

Keywords - for 
entering free-
form text to as-
sociate with the 
recipe.

Yield - for en-
tering the prod-
uct of the rec-
ipe, such as 24 
cookies. Differ-
ent from serv-
ings, which are 
used for nutri-
tional calcula-
tion and which 
can only be a 
number.

Servings - 
stores the ac-
tual number of 
servings the 
recipe makes.
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Categories table - allows you to set categories for the recipe used for searching 
and organizing your recipes. Fields marked with a  are user created categories. 
Fields marked with a  are system categories and categories marked with a  are 
locked and canʼt be deleted.

The Ingredients Tab

Quantity - 
The quantity 
needed for an 
ingredient.

Measurement 
- The meas-
urement of the 
ingredient.

Description - 
What the in-
gredient actu-
ally is.

Directions - 
Instructions 
associated 
with the in-
gredient, like 
“chopped” or 
“diced”

Is Main - 
Whether or not an ingredient is a main recipe ingredient. Marking an ingredient a 
“main” ingredient makes it easier to search.

Measurement System - The measurement system used by the ingredients: U.S. 
Standard or metric.

Commands

New - Add a new ingredient row
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Delete - Delete the selected ingredient row or rows

Add Group - Add a new ingredient group to the list. Drag and drop ingredient 
rows into a group to organize your list.

Add Recipe as Ingredient - Add a recipe as an ingredient to the list.
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The Directions Tab
Entering Steps 
and Step Details

Each step for a 
direction can 
have the text of a 
step, a label, and 
image and a way 
to highlight it in 
the directions list. 
To edit the val-
ues, you just 
need to select a 
direction and  edit 
the values in the 
“Step Detail” sec-
tion of the editor. 
Your changes are 
entered immedi-
ately and saved 
when you move 
to another step or 
recipe or when 
you close the edi-
tor.
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The Preparation Tab

Preparation 
Times

1. Type - The 
type of time, 
like “Start to 
Finish” or 
“Prep”

2. Amount - The 
amount and 
units, for in-
stance 25 
Minutes, or 1 
Hour 30 Min-
utes.

Equipment

Any special 
equipment that is 
required by the 
recipe. Check any 
that are needed. Fields marked with a  are equipment youʼve added. Fields marked 
with a  are equipment included by default.
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The Notes Tab

Introduction/
Summary

Enter a summary 
here. This can be 
an introduction to 
the recipe, why 
itʼs great, a little 
story associated 
with it, etc.

Recipe Notes

Any notes helpful 
when making the 
recipe. To edit the 
values, you just 
need to select a 
note and  edit the 
values in the 
“Note Details” section of the editor. Your changes are entered immediately and saved 
when you move to another note or recipe or when you close the editor.

Available Note Tags

Chef

Cooking

Pairing

Prep

Serving

Private - Personal notes that arenʼt exported
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The Picture Tab
1. Image Well - 

The area that 
displays the 
primary image 
for the recipe. 
You can drag 
and drop an 
image to this 
area to 
change the 
picture, or se-
lect it and 
choose Edit > 
Paste.

2. The Crop Box 
- Dragging 
this box 
around and 
pressing the 
“Crop” button 
allows you to 
save only part 
of the image 
as the primary 
image for the 
recipe.

3. Clear - Clears the current picture, making it so that the recipe no longer has a pic-
ture.

4. Crop - Uses the area surrounded by the “Crop box” to specify a smaller, more fo-
cused version of an image as the primary image.

5. Reset - Resets a cropped image to the original version.

6. Open - Allows an image for the recipe to be opened from your computerʼs disk drive.

7. Size slider - Changes the size of the crop box.
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The Nutrition Tab

The nutrition Notes 
tab allows you to 
record already-
calculated nutri-
tional information 
for the recipe.

The Calculated tab enables 
you to calculate nutritional 
data for your recipes. For 
more information, please see 
section 12, Nutritional Analy-
sis.
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3 Creating and Editing Wine Notes

This section describes creating and editing your wine notes.

Creating New Wine Notes
To create a new wine note, choose File > New > Wine Note (⇧-⌘-W). This will create a 
new empty wine note in the currently selected list, provided it is editable and can con-
tain wine notes.

Editing Your Wine Notes
You can edit and view notes simply by double-clicking on one in a list or by selecting 
something in your recipe box and choosing File > Get Info.

The Info Tab

Style - The 
wine style, like 
light, medium, 
full-bodied, 
etc.

Type - The 
wine type, 
such as Red: 
Cabernet 
Sauvignon.

Keywords - 
Enter any 
keywords or 
text that youʼd 
like associ-
ated with a 
wine note.
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The Tasting Notes Tab

Rating - A rating 
of how much 
you enjoyed the 
wine.

Tasting Notes - 
Any notes or 
thoughts that 
you had about 
the wine after 
tasting it.
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The Winemakerʼs Notes Tab

Winemaker 
Notes - Notes 
from the wi-
nemaker 
about their 
product.

Winemaker 
URL - The 
web address 
of the wine-
maker.
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The Label Tab

Image Well - 
Displays the 
primary image 
for the recipe. 
You can drag 
and drop an 
image to this 
area to 
change the 
picture, or se-
lect it and 
choose Edit > 
Paste.

Crop Box - 
Dragging this 
box around 
and pressing 
the “Crop” 
button allows 
you to save 
only part of 
the image as 
the primary image for the recipe.

Clear - Clears the current picture, making it so that the recipe no longer has a pic-
ture.

Crop - Uses the area surrounded by the “Crop box” to specify a smaller, more fo-
cused version of an image as the primary image.

Reset - Resets a cropped image to the original version.

Open - Allows an image for the recipe to be opened from your computerʼs disk drive.

Size slider - Changes the size of the crop box.
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The Cellar Info Tab

Purchase 
Location - 
Displays the 
place you 
bought the 
wine. 

Purchase 
Date - dis-
plays the date 
you pur-
chased the 
wine.

Maturation 
Date - dis-
plays the date 
the wine 
should be 
“ready”.

Date Opened 
- records the 
date you 
opened the 
bottle.

Number On Hand - displays the number of bottles in your collection.

Price - records the price you paid for the bottle.
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4 Creating and Editing Cooking Notes

Creating and editing your cooking notes.

Creating New Cooking Notes
To create a new cooking note, choose File > New > Cooking Note (⇧-⌘-N). This will 
create a new empty cooking note in the currently selected list, provided it is editable and  
can contain cooking notes.

Editing Your Notes
You can edit and view notes simply by double-clicking on one in a list or by selecting 
something in your recipe box and choosing File > Get Info.

The Info Tab

Title - dis-
plays the 
name of the 
note. 

Source - re-
cords where 
you found the 
recipe. 

Keywords - 
an area for 
free-form text 
entry which 
will associate 
with the recipe 
and facilitate 
easier 
searches.

Note Text - 
records any 
info or cooking 
tips, or tricks.
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The Picture Tab

Image Well - 
Displays the 
primary image 
for the recipe. 
You can drag 
and drop an 
image to this 
area to change 
the picture, or 
select it and 
choose Edit > 
Paste.

Crop Box - 
Dragging this 
box around and 
pressing the 
“Crop” button 
allows you to 
save only part 
of the image as 
the primary im-
age for the recipe.

Clear - Clears the current picture, making it so that the recipe no longer has a pic-
ture.

Crop - Uses the area surrounded by the “Crop box” to specify a smaller, more fo-
cused version of an image as the primary image.

Reset - Resets a cropped image to the original version.

Open - Allows an image for the recipe to be opened from your computerʼs disk drive.

Size slider - Changes the size of the crop box.
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5 Finding Things in MacGourmet

Finding recipes and notes in your MacGourmet database.
There are a variety of ways to find things in MacGourmet. You can quickly filter on cer-
tain fields, or all fields in your recipe box using the Search Field. You can search for 
recipes, wine notes and cooking notes using the basic search functionality. You can  
create Smart Lists that search for items based on criteria you specify: lists that keep 
themselves updated as you add and delete items. You can search for recipes based on 
ingredients you have and ingredients you do not have. Finally, you can do "Potluck" 
searches that return random selections from your recipe collection. This is great if you 
can't decide what to make!

The Search Field
The search field is found 
on the toolbar of your 
recipe box and your list 
views. It allows you to 
pick a field to search on 
and quickly filter the se-
lected list based on 
whatever you type into 
this field.

Finding Recipes, Wine Notes and Cooking Notes
Basic search allows you to search for recipes, wine notes and cooking notes using the 
fields that correspond to each of those items. For instance, you can search for recipes 
using name, keywords, source, etc. You can search for wine notes using vintage, the 
region or comments in a winemaker's note. When you search, your  results are dis-
played in the “Find Results” list in your recipe box. Your find results will be saved for 
your current MacGourmet session, but quitting the application and restarting it later will 
clear the “Find Results” list, so that it does not get too cluttered with old searches.
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L
Tip: You can move the cursor to the search field by press-
ing ⌥⌘F (option-⌘-F).

Finding Recipes Using “Cupboard Find”
Cupboard Find is an easy and quick way to find recipes based on ingredients you have 
and ingredients you do not have. For instance, the screenshot below shows a recipe 
search that calls for chicken and potatoes, but not garlic, because you donʼt have any 
garlic. When your search is complete, your results are displayed in the Find Results list 
of your recipe box.

To display the Cupboard Find window:
Choose Edit > Find > Cupboard Find... (You can also press ⌘-F).

Creating and Using Smart Lists
Let MacGourmet create recipe and note lists for you automatically with Smart Lists. 
Simply specify your criteria — like recipes you have prepared or recipes with a rating 
greater than 3 — and MacGourmet will do the rest. MacGourmet finds the items that 
match the things you specify and creates a list that updates itself automatically.

If you were to create a Smart List for recipes, using the values shown below, a new list 
would be created for you that displayed recipes that you have prepared with a rating 
that is greater than 3. As you marked more recipes as prepared, and rated others, this 
list would be updated to reflect these changes, provided you had the "Live updating" 
box checked. Checking the “Limit to” check box would allow the Smart list to show only 
20 of the recipes in the database that matched your list settings instead of all of them.
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L
Note: Because Smart Lists are updated each time something in the 
database changes, adding more and more lists can slow response 
times in large databases. Large databases will respond most quickly 
when there are fewer lists that need updating.

To create a new smart recipe list:
1. Click on the view that holds all of your lists.

2. Choose File > New > Smart Recipe List. You can also right-click (or ctrl-click for one 
button mouse users) on the view that holds all of your lists and choose New > Smart 
Recipe List in the menu that pops up.

3. A new list will be added, which you can rename by double clicking on it. To edit a list, 
select it and choose Edit > Modify Smart List. You can also select it and right-click 
(or ctrl-click for one button mouse users) on it to display a menu, from which you can 
then choose “Modify Smart List.”

Doing a Potluck Find
Can't decide on what to make? Not a problem. Potluck Find is a fun way to search for 5 
random recipes from your collection. To do a new Potluck Find:

Choose Edit > Find > Potluck Find.

Potluck Find can be used as often as you want, returning a new, different list of recipes 
each time you use it.

Finding Recipes, Wine Notes and Cooking Notes
Search for each item type by selecting the appropriate command from the Find menu.
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To find recipes:
Choose Edit > Find > Find Recipes..., or press ⌃⌘R (ctrl-⌘-R).

To find wine notes:
Choose Edit > Find > Find Wine Notes..., or press ⌃⌘W (ctrl-⌘-W).

To find cooking notes:
Choose Edit > Find > Find Cooking Notes..., or press ⌃⌘R (ctrl-⌘-N).

When you use any of these commands, a Find window appropriate for the type of item 
you are searching for will be displayed, so that only the information appropriate to the 
type of item will be available for your search.

You can also search your library for potential duplicate recipes. Find Duplicates looks 
at the directions of each of your recipes and compares them to those of all of your other 
recipes to see if there are any that might be the same. The ones that look like duplicates 
are returned in a Find result, and added to the Find Results list in your recipe box.

To find duplicate recipes:
Choose Edit > Find > Find Duplicates

Creating Smart Lists from Find Results
You can easily turn your find results into smart lists:

1. Select the Find result in the list

2. Choose File > New > Smart List From Find, to turn it into a Smart List.

This will create a new Smart List that uses the criteria in the selected Find result.

39



6 Importing and Exporting

Importing and exporting your information.
MacGourmet provides a variety of ways to get information into and out of your recipe 
box.

L
Note: If you do not see the “Make MacGourmet Text Clipping” menu 
item in the Services menu, try copying MacGourmet to the system Ap-
plications folder. Also, try logging out, and rebooting if that still doesnʼt 
work. In rare cases you might have to reboot twice.

If youʼre using Mac OS X 10.6 (Snow Leopard) please see Appendix B 
for information on configuring Services.

Using the MacGourmet Clipping Service
Getting recipes 
into MacGourmet 
is as easy as 
1-2-3:

1. Go to your fa-
vorite recipe 
web site in 
your web 
browser and 
select the text 
of a recipe. 
Hint: Itʼs often 
easier to clip 
from a “Print” 
version of a 
recipe, which 
will usually 
display a rec-
ipe without 
ads and web 
site naviga-
tion.
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2. With the text of the recipe selected, and your browser the front-most application, se-
lect "Clip Recipe" from the Safari Services menu, or press ⇧⌘M (shift-⌘-M). 

Doing this adds a 
text clipping of the 
recipe to the Clip-
pings list in your 
Recipe Box.

L
Note: Not all web browsers support the Services menu. Apple's 
Safari, Camino, and Opera, and the latest versions of Firefox all 
support the Services menu, but older versions of Firefox, iCab, 
Microsoft's Internet Explorer, and Googleʼs Chrome currently do 
not.
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3. Double click 
your new clip-
ping to bring up 
the Recipe Im-
port Assistant. 
Copy or drag 
the text from 
the left text 
area into the 
appropriate 
fields and text 
areas on the 
right. Make any 
corrections or 
modifications 
you desire. Text 
can also be 
copied to import 
fields by select-
ing text in the 
area one the left hand side of the assistant and choosing the desired target from the 
popup menu below the top text area, and pressing the Set button. Alternatively, each 
menu item has an associated keyboard shortcut.
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Before committing your new recipe, you can see what it will look like when it's imported 
in the import 
preview.

Other ways to 
make clippings
In addition to us-
ing the Services 
menu item to 
create and add 
clippings to your 
recipe box, you 
can also create 
clippings by ei-
ther dragging and 
dropping text 
from another ap-
plication to the 
Clippings list, or 
by copying text 
from another ap-
plication, select-
ing the clippings list in MacGourmet and choosing Edit > Paste. Once youʼve made a 
clipping, you can import it using the Assistant, the same as you would a web clipping, 
which is described above.

Using the MacGourmet Recipe Web Page Import Service
MacGourmet makes it super easy to import recipes from certain, supported web sites 
including allrecipes.com, epicurious.com, foodnetwork.com, williams-sonoma.com and 
food.yahoo.com.

1. Go to the recipe page on your favorite, supported web site. Note that you have to go 
to one of their standard recipe pages for the importers to work. Recipes on featured 
pages, special pages, etc. are not usually supported by the importer.

2. Select the entire URL in the address bar of your web browser.

3. Choose Safari > Services > Import Recipe From Web Page, or press ⇧⌘O

4. After a moment, a Recipe Import Assistant window (described above) appears with 
all of the recipe information already filled in. Verify the information is correct, make 
any desired changes, and press the Save button. Note: Occasionally, because of the 
many variations of information, the information is not retrieved in its entirety. When 
this happens, you can still make a web clipping and import the recipe that way.
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Note: MacGourmet site 
plugins use web page 
“scraping” to get recipe 
information. Recipe web 
sites tend to change their 
code often, and this some-
times breaks the web 
page import service for 
that site. If this happens, 
first, check to make sure 
that you are using the lat-
est version of MacGour-
met Deluxe. If you are, 
sending the URL to sup-
port helps us track any 
changes to the site.

While waiting for a fix, you can still import a recipe using the recipe clipping service.

L
MacGourmet imports files saved in the following formats:

MasterCook Text, MasterCook MXP, MasterCook MX2, Master-
Cook Mac, Meal-Master, Cookʼn text, RecipeML, and Yum XML

Using File Import and Export
You can choose to import existing files in various formats, described below:
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Importing Recipes:
The image below shows a MasterCook import file selected.

While you should 
make sure that you 
select the correct file 
format for your import, 
MacGourmet will ver-
ify that the file you se-
lected matches the 
selected format be-
fore your import 
starts.

To import Yum XML 
files:

1. Choose File > Ex-
port All Recipes > 
As XML Text...

2. Save the file to your 
hard drive.

3. Using MacGourmet, choose File > Import...

4. Choose the XML file you created, and select Yum XML for the format of the file to 
import.

To import Cookʼn text files:

1. Export from Cookʼn using their text-based format.

2. Using MacGourmet, choose File > Import...

3. Choose the text file you created, and select Cookʼn for the format of the file to im-
port.

To import Recipe ML, MasterCook MXP, MasterCook MX2,  and Meal-Master files:

1. To export from a PC based application: select the recipes and export them using one 
of the text-based formats that matches one of the available importers.

2. Using MacGourmet, choose File > Import...
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3. Choose the file you want to import and choose the appropriate file format, Reci-
peML, MasterCook MXP, MasterCook MX2 or Meal-Master.

L
Hint: To import recipe collections from MasterCook 4.06 for Mac-
intosh you need to take the collections files and convert them to 
MasterCook export files

To import MasterCook Mac files:

1. You need to open a collection, say "15-minute Meals" 

2. Go to the index, and select all of the recipes, or just the recipes that you want to ex-
port.

3. Select the "Export Selected Recipe(s)" menu item from the Recipe menu, and 
choose the "Mac Format" menu item in the save dialog.

This will create a file that is in the correct format for import into MacGourmet, a Master-
Cook Mac file. After saving the file as a "Mac Format" file, you can then import that file 
into MacGourmet.

You can also drag and drop an import file into your Recipe Box! Just select an import file 
in the Finder and drag it into one of your lists, or onto one of your lists. That's all there is 
to it.

Once imported, your new items can be found in both your appropriate "My" list, and in 
your "Last Import" list.

Importing from other Mac Applications
In addition to importing from some of the older PC-based apps, MacGourmet can also 
import from many Mac recipe applications. Doing this just requires the installation of an 
optional plug-in, which you can do using the Plug-in Manager. For details please see 
Appendix C. Instructions for using each plug-in will be displayed when the importer is 
selected in the manager, once itʼs been installed.

Exporting Recipes and Notes
Exporting items is as easy as importing them. You can export recipes in a variety of 
formats, described below:

MacGourmet Export Files
The MacGourmet file export types include three different ways to export both text and 
binary versions of recipes, wine notes and notes.
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When you choose to export MacGourmet files, any embedded images will be saved in a 
format that is smaller and faster to import later. The MacGourmet Text format is useful 
when putting your export files on a web site or sending them through email. In the text 
version of the format, any embedded images are converted to text, making them easier 
to share across different mail and web servers, but also making them larger. Both for-
mats are compatible with MacGourmet 2 and MacGourmet 3.

If you want to create smaller export files optimized for MacGourmet 3, just choose the 
MacGourmet 3 file export format.

iPod Notes (for older non-iOS iPods)

1. Choose the list or set of recipes in your recipe box that youʼd like to export to your 
iPod.

2. Choose File > Export... and choose iPod Note as the format.

3. Choose the location to save your recipes. A folder containing your recipes will be 
created in this location. Note: if you want to group your recipes in sublists on your 
iPod, create and choose to export a list in your recipe box that has sublists.

4. Connect your iPod to your Mac, making sure that “Enable disk use” in Settings is 
checked when you inspect your iPod in iTunes.

5. Drag the folder that was created when you exported to the Notes folder on your 
iPod, then disconnect it.

6. You should now be able to browse your recipes as iPod notes.
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Text and Rich Text

1. Choose the list or set of recipes in your recipe box that youʼd like to export.

2. Choose File > Export... and choose either Text File or RTF File as the format.

MasterCook, MasterCook Mac and Meal-Master

1. Choose the list or set of recipes in your recipe box that youʼd like to export.

2. Choose File > Export... and choose MasterCook MXP, MasterCook MX2, Master-
Cook Mac or Meal-Master as the format.

Note that you can only export recipes when a format other than one of the MacGourmet 
formats is selected. Wine and general notes will be ignored.

Creating text versions of your recipes and notes
Additionally, you can select one or more items and choose Edit > Copy. Doing this will 
place text versions of the selected items into the Mac OS X Pasteboard, letting you then 
paste the text into other applications like Mail, TextEdit, Entourage, etc.

Exporting the names of items in a list
To export the names of all of the items in one of your recipe box lists, select the list, and 
choose Edit > Copy. This will add a text-based list of all of the item names in the list to 
your pasteboard, which you can then  paste into any application youʼd like.
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7 Publishing Your Recipes and Notes to the Web

Publishing to the web.
MacGourmet allows you to publish 
your recipes, wine notes and gen-
eral notes to the web, or to your 
local file system. This allows you to 
easily share what you've created, 
entered, etc. with others. Create 
and modify web site publications 
by going to the Publish panel in 
Preferences, and selecting the 
Sites tab.

Publishing Your Recipes 
to Your Apple .Mac Ac-
count
MacGourmet allows you to easily 
publish recipes, wine notes and 
notes to your Apple .Mac account. 
To create a new publication: 

Click the Add button. 

A sheet appears.
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Title - This field 
lets you specify 
the name of the 
publication. This 
name is used 
both for the publi-
cation's entry in 
the Publish 
menu, and as the 
title displayed on 
the index page of 
your publication.

Summary - This 
field allows you to 
specify a brief 
summary for your 
recipe and notes 
sites.

Server Type - 
This pop up 
menu lets you 
pick which type of 
server to write 
your data to. Cur-
rently Appleʼs 
MobileMe, 
WebDAV, and 
Local disk are of-
fered.

Server - This text 
field specifies the address of the server to connect to. For MobileMe this value is fixed.

Website URL -  This field is used to specify the base URL for your recipe site. This URL 
is the specification of how the user will get to your web site. You can change this to any-
thing you want, but it will also get updated automatically for you as well, using informa-
tion inserted into other fields. For MobileMe you will usually want to use the default 
value.

Publish Folder - This text field specifies the location on the server or file system where 
your files should be written. Note that when using MobileMe, that the location Apple 
specifies is "Web/Sites/YourSiteName" so while you can specify anything you want, the 
suggested location starts with "Sites" followed by the name of a folder that will contain 
your site.
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Create export files for published items - Checkbox that allows you to create 
MacGourmet export files as part of your publication, so that importing your recipes by 
other users can be as simple as just dragging the image of an export file from a web 
page into MacGourmet.

Finally, the Template and Style pop up menus allow you to pick one of the included 
MacGourmet themes for your publication.

After creating the specification for your 
publication, publish it by choosing File > 
Publish.

The Publish menu contains your publica-
tions, listed by their titles. Selecting a 
publication from the menu will create all 
of the files necessary for your site, in the 
location you specified. Once the publica-
tion is complete, access it using the URL 
displayed in the field labeled "This site's 
address is:" when your publication is se-
lected in the Publish preferences table.
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8 The Lists Editor

Modifying and searching categories, equipment, ingredients, and 
more.
The Lists Editor allows you to view 
and edit most of the information in 
your database. 

The lists editor has 4 sections, reci-
pes, wine notes, cooking notes, and 
shopping lists. Each section has a 
popup menu that displays fields that 
can be browsed and edited. When a 
field in the popup is selected, the 
middle area of the browser changes 
to display all of the information as-
sociated with the selected field. 

Fields marked with a  are user 
created and can be changed, or de-
leted.

Fields marked with a  are system 
created values that can be changed 
or deleted.

Fields marked with a  are locked 
and canʼt be changed. 

To change a value, double-click on 
it in the table, change the value and 
press Return to finish.

You are also able to see what items 
use each value in the middle table by selecting something. This updates the “Used By” 
table at the bottom of the library browser with any items that use the selected value. To 
go to the item in your recipe box, double-click on the item in the “Used By” table.

Note: some lists, like categories, you can directly modify, and some, like Ingredient De-
scriptions, are built from the information you entered into your database. Because of 
this, items in a list like “Ingredient Descriptions” can only be “deleted” by removing the 
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values from any items that are using them. If you change one of these values in the 
middle table, all of the items that use the value will be updated with the new value. 
When nothing uses a value, it is removed from the list.

L
NOTE: The Library Browser is a VERY powerful tool and caution 
should be exercised when using it to modify your information. 
Make sure you check your changes before pressing “Yes” when 
you are asked to confirm your change.
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9 Making Relationships Between Items

Linking your recipes and notes.

Making Links Using the Relationship Manager
MacGourmet features a tool called the "Relationship Manager" that allows you to make 
links between recipes and notes. This allows you to remember recipes that went well 
together, wines that went well with recipes, and notes that are useful when preparing 
certain recipes. 

To make relationships:
1. Select an item in your Recipe Box and bring up the Relationship Manager, from the 

Tools menu. Notice that the item shown at the top of the Relationship Manager is the 
name of the currently selected item. To keep the selection from changing as you se-
lect items in your recipe box, press the “Lock” checkbox.

2. Next, find an item in one of your recipe box lists that you want to link to the currently 
selected item.

3. Once you find it, drag it to the Relationship Manager table. Note that selecting a new 
item changes the selected item in the Relationship Manager unless youʼve checked 
the lock checkbox. Note: it is possible to drag an item without selecting it by quickly 
clicking and dragging the item, in one motion.

4. Drop the item. A new relationship between the selected manager item and the 
dropped item is created. This relationship is in both directions, which means, if you 
make a relationship between a “Roasted Lemon Chicken” recipe and a “How to roast 
a chicken” cooking note, that relationship appears when viewing either item in your 
recipe box.

You can always add more relationships. Delete any relationships by selecting the rela-
tionship in the "Related Items" table of the Relationship Manager when a recipe or note 
is selected, and pressing the Delete key.

Double-clicking an item in the relationship manager selects that item in your recipe box.

54



10 Creating and Using Shopping Lists

Creating, using and exporting shopping lists.

Creating a Shopping List
MacGourmet allows you easily to create shopping lists.

To create a new shopping list:
1. Select one or more recipes.

2. Next select “Shopping List From Selection” from the File > New menu. You can also 
select “Shopping List From Selection” from the “New” contextual menu by right click-
ing or command clicking on a selected recipe.

Additionally, create a new, blank shopping list by selecting the “Shopping List...” item 
from the File > New menu when you have your “My Shopping Lists” list selected in your 
recipe box.

Alternatively, create a new shopping list by selecting one or more recipes and dragging 
and dropping the selection on the “My Shopping Lists” list on the left side of your recipe 
box.

Combining Shopping Lists
Two shopping lists can be merged by dragging one shopping list and dropping it onto 
another one. When shopping lists are merged, the ingredients in the list are combined.

Editing Your Shopping Lists
Like recipes and wine notes, you can edit and view shopping lists simply by double-
clicking on one in a list. Double-clicking on a shopping list will open the shopping list 
editor which allows you to specify the name, and the items for a shopping list. The editor 
allows you to also specify fields like aisle and store for each item on your list. The editor 
also allows you do add non-recipe items to your list.

To edit values in the editor table, just double-click on the column of the row youʼd like to 
change. To add or remove a row, just press the appropriate button located above the 
table. The button marked with a “+” will add a new row, the button marked with the “-” 

55



will delete the cur-
rent selected rows.

Shopping List 
Columns
To hide and show 
columns, just right-
click (or control-
click) on the table 
column headers and 
check or uncheck 
the columns. You 
can also select the 
shopping list item 
table and choose 
View > View Op-
tions... to change the 
columns that are 
shown or hidden.

Most of the shopping 
list columns are self-
explanatory, how, the column marked with a $ character will display a coupon icon when 
displayed for any row that is checked. This is useful when shopping for marking items 
on your list that you have coupons for.

Maintaining the Shopping List Favorites & History List
Every shopping list displays a master Favorites list, shown above in the bottom section 
of the shopping list editor window. The favorites list is a place to keep often used items, 
such as pantry staples, so that they can be quickly added to any shopping list. To add 
one or more favorite items to a shopping list, just drag and drop the rows from the favor-
ites list to the shopping list. The favorites list can also be used to store pantry quantities, 
if desired as well.

Items in the favorites list are also used to set the aisles, stores and categories for items 
whenever a new shopping list is created. For instance, if the favorites list has a row for 
“all-purpose flour” and a shopping list gets created that uses this ingredient, the values 
for the “all-purpose flour” favorite item are used to fill in the data for this item in the new 
shopping list.

Alternatively, if there are no favorites found, existing shopping lists are searched for this 
information and the items in a new shopping list are filled in using the values from exist-
ing shopping lists, so itʼs also possible to keep a “master” shopping list that is used to fill 
in information automatically.
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Add

Delete

Exclude - Exclude the selected item from current and future shopping lists. 
Useful for removing staples like salt, pepper, etc. from your lists.

Find - Search a predefined list of items for things to add to your lists.

Add to Favorites - Add the selected item to your list of favorites.

Exporting a Shopping List to Your PDA or to a Text File
MacGourmet lets you easily export your shopping lists to PDAs and to text files. To ex-
port a shopping list, select it in your recipe box. Next choose Export... from the File 
menu. Finally choose a name, location and format for your exported shopping list. 
MacGourmet currently supports HandyShopper and SplashShopper, and plain text ex-
port formats.
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11 Printing Your Recipes and Notes

This chapter describes how to print from MacGourmet.
MacGourmet offers you many printing options. You can print one item, or many items. 
You can print one item per page, or many to a page. 

To print, select one or 
many items in your recipe 
box and press the Print 
toolbar item, or select 
Print... from the File menu. 
The Print window displays 
The Print window allows 
you to choose the printing 
template and gives you an 
approximate preview of 
your recipes or items when 
printed.

Note: this view is only ap-
proximate. To really see 
what your print out looks 
like, press the “Print” but-
ton at the bottom of the 
Print window, which dis-
plays the Print Settings 
sheet, and press the “Pre-
view” button at the bottom-left of the sheet.

L
Note: You can only print one type of item at a time. This means that if 
you are in your recipe list, you can select as many recipes as you want 
and print them. However, if you are in a user list, you can only select 
multiple items of the same type.

To print each of your selected recipes on a separate page, check the “Print one item per 
page” check box. 

To change the print margins, press the “Set Margins” button. A sheet appears that al-
lows you to set the top, bottom, left and right margins.

Increase the size of the text by moving the “Font Size” slider to the right; moving it to the 
left reduces the font size.
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12 Nutritional Analysis

Analyzing Nutrition

About MacGourmet Nutritional Information
Nutrition Analyses Based on USDA Database
MacGourmet is proud to use the abbreviated USDA National Nutrient Database for rec-
ipe nutrition analysis. Today, the National Nutrient Data Bank is a repository of informa-
tion for more than 130 nutrients and for over 7,000 foods. It is made available in their 
principle database--the USDA National Nutrient Database for Standard Reference (SR). 

U.S. Department of Agriculture, Agricultural Research Service. 2006. USDA Nutrient Database for Stan-
dard Reference, Release 19. Nutrient Data Laboratory Home Page, http://www.ars.usda.gov/nutrientdata 
Note: Release numbers change as new versions are released.

Use MacGourmet Information with Care
The nutrition values that are calculated by MacGourmet are based on individual recipe 
ingredients. If a nutrient value is not available at this time, you will not find a mapping for 
the nutrient name. While Advenio takes the utmost care in providing you with the most 
accurate nutritional values possible, please note that this information is an estimate and 
is not intended for medical nutrition therapy. If you are following a strict diet for medical 
or dietary reasons, it is important that you, first, consult your physician or registered die-
titian before planning your meals based on MacGourmet nutritional analysis, and, sec-
ond, remain under appropriate medical supervision while using the nutrition information 
calculated by MacGourmet.

Overview
The MacGourmet:Nutrition plug-in consists of a main window, which provides access of 
the nutrition database and nutrient items, and a floating heads up display (HUD) window 
that displays a summary of the calculated nutritional information for a recipe.
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The Nutrition Database
Once the plug-in is installed, the 
main nutritional database window 
can be accessed from either the 
Nutrition menu, or the recipe box 
toolbar. The main window allows 
you to browse all of the nutri-
tional items in the database as 
well as providing a source for the 
mappings between nutritional da-
tabase items and your ingredi-
ents.

The main window consists of 3 
areas, the main list or nutritional 
items, the nutritional data for the 
selected item and the mappings 
from the selected item to ingredi-
ent names.

To find information on a nutri-
tional item in the database, type 
part of the nutrient name into the 
search field. As you type, results 
matching your search will be dis-
played. Remove food groups from 
your search by right-clicking, or control-clicking on the nutritional item table and un-
checking the category in the menu.

Once you find the nutritional item you are looking for, selecting it will display the nutrient 
values for the item in the nutritional information table. The data in this table shows the 
nutritional information for the item for every 100 grams.

Selecting the item will also show you the ingredients in your recipe library that currently 
map to the item. For instance, in the image above, ingredients with a description of ei-
ther “chopped nuts” or “nuts” will use the selected nutritional item in the nutritional calcu-
lations for a recipe.

The Mappings Table
The mappings table is the component of the recipe editor that links your recipe ingredi-
ents to their nutritional data items in the database (see Calculating Nutritional Data for a 
Recipe, below). In order to correctly calculate nutritional data, each ingredient must be 
mapped to an appropriate item in the nutritional database. Ingredients that have been 
mapped are marked with a  and will show the name of the nutritional item it maps to. 
Unmapped ingredients are marked with a . Unless a mapping is provided, these in-
gredients will not be used in the nutritional calculations for the recipe. To see the item in 
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the database that the ingredient maps to, you just need to click on the  button next to 
the nutritional item name.

The Nutritional Data per Serving Heads-up-display
Found in the toolbar of the main nutri-
tional database window is a button to 
open the nutritional data per serving 
HUD window. You can also access 
this window from the Nutrition menu. 
This floating window allows you to 
browse a summary of the calculated 
data, per serving, for the recipe that is 
selected in your recipe box. If no data 
has been calculated, the values will 
be marked with a “--” where the calcu-
lated values would be displayed.

The Calculation Details Window
When the nutritional data for a re
cipe is generated, information on 
the analysis is stored with the data, 
and can be viewed using the Calcu-
lation Details window, which can be 
opened either from the database 
window toolbar or the Nutrition 
menu. In this component you will 
find the basics of how the calcula-
tion for each ingredient was done, 
any errors in the calculations, and 
any ingredients that were skipped 
when calculating the data, along 
with information on why a calculation failed or wasnʼt included in the final results. Ingre-
dients used successfully in the nutritional analysis are marked with a  in the table. In-
gredients that were not used because of errors, or because there were no mappings, 
are listed with a . Clicking on each ingredient will show you the associated analysis 
information or error. You can also find warnings displayed in this window as well. Warn-
ings are logged when a calculation is done but the data is possibly incorrect based on 
the resolution or mapping provided. When there are warnings, Nutrition has made a 
guess at the resolution, so these calculations should be verified for their accuracy.
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Calculating Nutritional Data for a Recipe
To calculate the nutritional values for a recipe, you have to select the Calculated sub-
section in the Recipe editor Nutrition tab.

This component shows each ingredient, and itʼs equivalent nutrition database nutrient 
value. MacGourmet calculates nutritional values based on the ingredients that make up 
your recipes. To figure out the nutritional values for each ingredient, MacGourmet uses 
the concept of associating the ingredient name used in your recipe, and an equivalent 
nutritional database item, called a mapping. MacGourmet comes with many mappings 
predefined, and youʼll see these marked with a  in the “Nutrition Food Item” column 
when you view one of your recipes. Values marked with a  have not been mapped 
yet, because a mapping between the ingredient description and a nutritional item wasnʼt 
found.

To correctly calculate the 
nutritional information, as 
many ingredients as pos-
sible must be mapped to 
nutritional items. To cre-
ate a new mapping, you 
just need to find the nutri-
tional item in the data-
base that is the closest 
match the ingredient, and 
drag and drop the item 
from the nutritional data-
base to the ingredient 
row that needs a map-
ping. Once you do this, 
the correct nutritional val-
ues will available to cal-
culate the nutritional in-
formation for the ingredi-
ent.
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The Weight Resolver: Providing Needed Additional Information
Sometimes, after mapping an ingredient, you need to provide more information to calcu-
late nutritional values.

An example of this is 
an ingredient of “1 
egg.” While this value 
is mapped to “Egg, 
whole, raw, fresh” in 
the nutritional data-
base, when you press 
the “Calculate” button, 
you will be asked to 
specify the size of the 
egg you are using, such 
as medium, large, or ex-
tra large. Once you pro-
vide this additional in-
formation, the correct 
values will be deter-
mined for the mapping. 
If you press cancel at 
any point, the calcula-
tion for the recipe will be 
canceled as well.

How do you decide what 
value to choose? You 
want to choose the item from the list that most resembles your ingredient. For instance, 
if your ingredient has a measurement of 3 tablespoons, youʼd want to choose the “1 ta-
blespoon” choice. If tablespoon wasnʼt an option “1 teaspoon” would also work (3 tea-
spoons in a tablespoon). If your ingredient is measured in something like slices, and you 
only have an option like “1 cup” you might have to figure out and change your ingredient 
so that it resolves correctly, by figuring out how many slices would be in a cup and 
changing your ingredient measurement. Finally, if you just want to skip this ingredient, 
choose “DO NOT RESOLVE” and it will be ignored when calculating the data.

When Mappings Are Not Found
While most ingredients will have mappings, occasionally youʼll find that the nutritional 
database doesnʼt have a good match. When this happens, the nutritional information for 
the recipe has to be calculated without the ingredient. The USDA does update the data-
base often, though, so at some point all of the ingredients could be available for your 
calculations. Youʼll be able to get this updated information simply by downloading and 
reinstalling a new version of the Nutrition plug-in, when itʼs available.
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Recalculating Your Nutritional Information

While you can recalculate your 
nutritional information any time 
you desire, sometimes you will 
have to recalculate your infor-
mation because of changes in 
ingredients, servings or map-
pings. When this happens, the 
table labeled “Calculated Nutri-
tional Information per Serving” 
will be marked with an alert 
message stating that the data 
displayed needs to be recalculated. When you press the Calculate button, the old val-
ues will be replaced with the new ones and the alert will be cleared.

Tips on Getting the Best Calculations
MacGourmet:Nutrition relies heavily on the USDA database of nutritional items to do 
calculations. To do this without having to force the use of someone elseʼs “standardized” 
ingredients in your recipes, it allows ingredients in recipes to be simply mapped to their 
equivalents in the nutrition database using a simple drag and drop process. This is easy 
enough but there are ways to make this easier.

For example:

You might have various ways of referring to boneless and skinless chicken breasts in 
your recipes:

• skinless chicken breasts

• chicken breasts, skinless

• boneless, skinless chicken breasts

• boneless and skinless chicken beasts

All of these would ultimately map to “Chicken, broilers or fryers, breast, meat only, raw”  
but each variation would have to be mapped by hand before a calculation could be done 
properly. Any new variations would also have to be mapped. However, if all of the vari-
ants were replaced with “boneless, skinless chicken breasts” and that description was 
used in most recipes, work would be saved. This isnʼt always possible of course, but the 
more standardized your information, the less work youʼll have when you do a calcula-
tion.
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Another point worth mentioning: your choice of mappings can effect the accuracy of 
your calculations. Sometimes a mapping that seems to make sense, wonʼt when the 
calculation is done. Youʼll see this when you press the Calculate button and the Weight 
Resolver is displayed. This is normal, because as described previously, if you have “1 
egg” in your recipe, the calculation needs to know the size of the egg you are using. The 
problem occurs, however, when none of the resolver options seem to be appropriate. 

For example:

A recipe calls for “1 can chili, no beans” which you map to “HORMEL chili, No beans, 
canned entree” in the nutrition database. When you go to calculate your information 
however, you are given the following options: 1 cup, 1 package yields, 1 serving. None 
of these resolutions are totally appropriate. Why? Well “1 can” cannot be converted to 1 
cup, because there is no way to know from that description how many cups are in a 
can. The same thing applies to the other resolutions. In this case, itʼs a good idea to 
look for something more appropriate for your mapping. If nothing appropriate seems to 
be found, you should consider changing the ingredient to say “2 cups chili, about 1 can” 
because a weight for “1 cup” is one of the available options. If you do either of these, 
youʼll be able to resolve the weight and calculate the correct values for the ingredient. 

Typically, if your ingredients have measurements like “1 can” or “1 package,” itʼs better 
for calculating nutrition if you change the ingredient measurement to include the 
amount, in cups, tablespoons, etc., adding the package or can value as an ingredient 
direction instead.

Another example: 

Your recipe calls for something like “1 salmon filet, about 1 1/2 pounds.” Your results will 
be better if you change the ingredient to be “1 1/2 pounds salmon, one filet” instead, be-
cause there is no straightforward way to map “1 salmon filet” to the nutritional database 
weight of “1/2 filet.” Why? Well 1/2 filet in the nutritional database is 159g. So to get an 
accurate calculation, the “filet” needs to be entered using that number, so youʼd have to 
figure out how the filet in the recipe properly equates to the database weight, and adjust 
accordingly. If you do the conversion to “1 1/2 pounds” everything is taken care of for 
you.

Comparing MacGourmet: Nutrition Data to Data With a Recipe
A word on MacGourmet:Nutrition calculations vs. information you might already have for 
a recipe: While they should be in the same ballpark, the odds of them being nearly the 
same are slim, unless they were calculated in the same exact manner. Some calcula-
tions you have will be estimates, like the MacGourmet:Nutrition values. Some will be 
more accurate, because they were calculated in a lab. Itʼs difficult to make a direct com-
parison between both sets of data unless you know exactly how the recipe data was 
calculated. Just something to keep in mind.

The values can also differ greatly based on the exact ingredients they used in their cal-
culations, and what you use in your mappings. For instance, some of your mappings 
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may be approximate matches rather than exact matches. This can cause final values to 
be different. Not using the right mappings, or not choosing the best resolutions can also 
cause the final values to be different, sometimes by a significant amount. For example, 
if you have an ingredient of “5 cm Ginger root,” youʼll find that none of the resolutions 
match this measurement. If possible, figure out this amount in the units of the easiest 
resolution you see, i.e. what 5 cm of ginger root might be in slices, cups, teaspoons or 
grams.

The rules of thumb for good calculations are essentially these: Start with a recipe that is 
as clean and consistent as possible. Then, when mapping, make sure you choose the 
best mappings possible. Finally, try and make sure that your ingredients resolve in the 
best way you can. When in doubt about the numbers, check the Calculation Details 
window to see just how the data was generated. This information can give you insight 
into ways to improve your mappings and resolutions. If you follow these rules, youʼll get 
data that is as accurate as estimated nutritional data can be.
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Adding Your Own Nutritional Items
Sometimes youʼll find that the USDA hasnʼt defined values or weights for an ingredient 
that your recipe uses. You might, however, have the nutritional information from the 
package available to you. In these instances, you can add new items to your database 
for these ingredients, and then make mappings to them just like you make mappings to 
the default USDA items that come with Nutrition.

Adding a New Nutritional Item
To add a new item, choose Nutrition > Add Item or press the “New Item” button in the 
toolbar. This will open a window that allows you to add information commonly found on 
product packages in the “Nutrition Facts” box for your item.

After filling in the name for your item and choosing the group it belongs too, you must fill 
in the “Serving Size” and “Weight” fields for your item. Itʼs best to enter the size in as 
clear a manner as possible. For instance, as “1 cup” or “1 tablespoon.”

At times you might have to do 
your own conversion for your 
item to work properly. An ex-
ample of this is when you want 
to enter the information for “1 
can cream of chicken soup.” 
The USDA doesnʼt offer a 
weight for 1 can, so youʼd have 
to enter your own item, unless 
youʼre willing to convert your 
ingredient into cups. Unfortu-
nately, when you look at the 
can you find it lists the amount 
for 1 cup in milliliters, not in 
grams, and your item weight 
has to be entered in grams. To 
solve this problem, you can 
find, by doing a search in the 
nutrition database, that the 
USDA does provide a meas-
urement for the soup you are 
using of 124g for each 1/2 cup. 
The soup can lists that there 
are 2.5 1/2 cup servings in 
each can, so you can then fill in “1 can” for your Serving Size, and 310g for your Weight 
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(124g x 2.5 = 310g). Now, if you map your soup ingredient to your nutritional item, you 
can do your calculation correctly when your ingredient is in cans.

Youʼll find items youʼve added in the list, marked with the 
 icon. To show just your added items, right-mouse-

click or control-mouse click on the table, and choose 
“Show Only My Items” from the menu that pops up.

L
Note: To prevent conflicts with ingredients that use USDA items and 
ingredients that use your own, itʼs sometimes a good idea to make your 
ingredient description more specific for your own items. For instance, 
instead of just having an ingredient of “1 can cream of chicken soup” 
which might already be mapped to the USDA item, you can leave 
“cream of chicken soup” mapped to the USDA item, and then enter 
something along the lines of “Campbellʼs Condensed Cream of Chicken 
Soup” for your ingredient, and then map that to your nutritional item.

Deleting Your Nutritional Items
To delete a nutritional item that youʼve added to the database, you just need to select it, 
and choose Nutrition > Delete Item or press the “Delete Item” button in the toolbar. Note 
that you can only delete items youʼve added, which are marked with .
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USDA Food Groups

Baby Foods

Baked Products

Beef Products

Beverages

Breakfast Cereals

Cereal Grains and Pasta

Dairy and Egg Products

Ethnic Foods

Fast Foods

Fats and Oils

Finfish and Shellfish Products

Fruits and Fruit Juices

Lamb, Veal and Game Products

Legumes and Legume Products

Meals, Entrees and Side dishes
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Nut and Seed Products

Pork Products

Poultry Products

Sausages and Luncheon Meats

Snacks

Soups, Sauces and Gravies

Spices and Herbs

Sweets

Vegetables and Vegetable Products

L
Note: You can show and hide food groups from your searches and from 
the browser by right-clicking, or control-clicking on the nutritional item 
table and un-checking or checking the group in the menu.
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13 Meal Planning

Planning Your Meals with the Weekly Planner
Mealplan is based 
around a weekly plan-
ner which is shown in 
the picture below. The 
planner shows you a 
week at a time, and 
lets you plan meals for 
each week, using 
meals and the recipes 
you want to prepare.

You can move from 
week to week by 
pressing the “Previous 
Week” and “Next 
Week” buttons in the 
toolbar, or by choosing 
Mealplan > Previous 
Week and Mealplan > 
Next Week. You can 
always return to the 
current week by press-
ing the “Current Week” 
toolbar button, or 
choosing Mealplan > 
Current Week.

If you want to jump to 
a specific week, press 
the “Choose Week” toolbar button and click on any day within the week that you want to 
jump to.

Adding Meals and Recipes to your Planner
You can easily add meals and recipes to your planner by using either copy and paste, or 
drag and drop. You can add recipes to a day, or to meals within a day.
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To add a meal to a planner day, either select a day and choose a meal from the 
Mealplan > Add menu, or drag and drop a meal from the meals list to the desired day.

The meals list displays the pre-defined meals available for the planner, and it also lets 
you add and delete your own meals. The built-in meals cannot be deleted or changed, 
but additional meals can be added. To add a meal just press the “+” button at the bottom 
of the list. To delete a meal select a meal and choose the “-” button.

The default times (the times used whenever you create an instance of a meal in the 
planner) for meals can be set in the meals list by clicking on the clock icon and choosing 
a time. Times are used primarily when you send your data to iCal. When your planner is 
synced, meals that have times will be placed at those times in your calendar. Recipes 
that arenʼt part of meals will be placed at noon.

L
Note: When you delete a meal from the meals list, it will be removed 
permanently and any recipes that are in these meals in the planner will 
be removed from the meal and then added directly to the days that in-
cluded the meals.

Adding recipes to your planner is simple: copy one or more recipes from any MacGour-
met recipe box list and select a meal or day, and then choose Edit > Paste, or just drag 
and drop one or more recipes from a recipe box list to a meal or day in your planner.

Once in your planner, meals and recipes can ordered however desired, just drag and 
drop the items from one place in the planner to another. Recipes can be moved from 
one meal to another or from one day to another in the same way.

L
Note: Itʼs a good idea for recipes to have a designated course. Courses 
are used to organize sections of your menus, and when you send your 
data to iCal.

Adding Notes to your Weekly Planner
Mealplan also features notes that can be added to any day or meal. Planner notes allow 
items other than recipes to be added, for the purposes of including those things that you 
donʼt necessary have or donʼt need recipes for.
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Printing your Weekly Planner
Mealplan lets you print your planner, a week at a time. To print a copy of your planner 
for a week, select that week in the planner, and choose:

Mealplan > Print Week

This will print your week, 
organized by the meals for 
each day. Recipes for a 
day that arenʼt part of a 
meal are added to the bot-
tom of your printed sched-
ule.

The order of the meals in 
your planner is determined 
based on the default times 
for the meals, which can be 
set in the meals drawer, by 
clicking on the clock icon of 
a meal row.

Creating Shopping Lists
Shopping lists can be created for any week in your planner, by choosing:

Mealplan > Make Shopping List

When this is done, a new shopping list, created using all of the recipes for the current 
week, is added to the list of shopping lists in the  MacGourmet recipe box window.
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Creating and Printing Menus
Mealplan provides a way to make menus for the meals in your planner by allowing a 
menu to be attached to each meal. To do this, select a meal in the planner and choose:

Mealplan > Attach Menu

This will attach a menu 
and allow the header and 
sub-header lines to be set 
for a menu, along with the 
format for the date to use 
when printing it. To see 
what a menu looks like, 
select a meal with an at-
tached menu and choose:
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Mealplan > Print Menu

to display the print preview win-
dow. There, you can see what a 
menu will look like when printed, 
and you can choose from various 
available styles.

The order of the courses in a 
menu is determined by the order 
of the recipes in the meal, and 
their courses. So recipes for an 
appetizer course should come 
first in the meal, and should have 
their course set to “Appetizer” in 
MacGourmet. When making 
menus, itʼs important that recipes 
have their courses set appropri-
ately.
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Sending your Planner to iCal
While Mealplan doesnʼt have its own monthly calendar view, because itʼs based around 
the concept of a weekly planner, a month-based view of Mealplan data can be viewed in 
iCal by sending the planner data to iCal.

Using Mealplan with iCal
To send your plan to iCal, just choose:

Mealplan > Send Planner to iCal

The rest will be taken care of automatically: a new calendar named “Mealplan” will be 
created, and it will be populated with your planner data.

L
Note: Sending your planner to iCal is a one way operation. Each time 
you send the planner to iCal, the data in iCal gets replaced, so any 
changes made to your Mealplan calendar in iCal will be lost.

It a good idea to have appropriate times for meals set, and for all recipes to be in meals 
when planner data is sent to iCal. When a planner is synced, meals that have times will 
be placed at those times in your calendar. Recipes that arenʼt in meals will be placed at 
noon.

Setting Mealplan Preferences
Mealplan adds a tab to MacGourmet preferences that lets you set the following options:

Weekly Planner
Week starts on: Specifies the day of the week to start your planner on, currently Sunday 
or Monday.

Printed Planner
Include Saturday and Sunday: Include the weekend days when printing your planner

Include date in planner day titles: Include the of the month and the month number in the 
day headers.

Print Vertically
Print a “Stacked” vertical version of the planner, as opposed to the default horizontal 
planner.

Include Recipes When Printing
Print out all of the recipes in your week when this option is checked.
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14 Creating Cookbooks

This chapter describes the optional cookbook feature of 
MacGourmet
MacGourmet allows you to add an optional plug-in that gives you the ability to easily 
create PDF cookbooks. To purchase this plug-in, please visit the MacGourmet online 
store (macgourmet.com/store)

Building Your Cookbook
Cookbook creation takes place in the Builder window. The builder window contains your 
library of cookbooks, each one capable of containing one or more chapters with recipes 
and text and image pages.

Recipes are added to cookbooks by either dragging and dropping, or copying and past-
ing them from the MacGourmet recipe box window. Once in a cookbook, they can be 
arranged by dragging them from one position to another, making it easy to list recipes in 
a chapter in the exact order desired.
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To create a new cookbook
1. Open the Builder win-
dow and choose Cook-
book > New > Cookbook

Cookbooks have many op-
tions available. The op-
tional book cover can have 
a title, subtitle, edition, 
footer and an full size im-
age. These settings can be 
changed on the Cover tab 
of the cookbook editor.

Cookbooks can also op-
tionally have a table of 
contents, an index, or 
author and preface infor-
mation. Additionally, recipe 
images can be included or hidden. These options can all be found on the Detail tab.

Finally, cookbooks can be created with custom page and margin sizes. This allows a 
8.5” x 11” cookbook to be created for printing on a home printer, or a 9” x 7” cookbook 
for a book print-on-demand service.

Chapters
Chapters contain recipes, and can also contain full-page image pages. To add recipes 
to a chapter, either drag and drop them from the MacGourmet recipe box, or copy them 
from the recipe box and paste them into a chapter. Once items are added to a chapter, 
they can be rearranged simply by dragging and dropping them from one location to an-
other.

Chapters themselves can also be reordered by dragging them from one location in a 
cookbook to another.

Chapters can have titles as well as a brief optional summary. They can also include text 
useful for chapter introductions, or stories about the recipes listed.

To create a new chapter:
Select a cookbook in the Builder window and choose Cookbook > New > Chapter, or 
press the Add Chapter toolbar button

Text Pages
Text pages allow text to be placed at various locations in a cookbook. For instance, a 
text page could be added to a chapter, to separate one section of recipes from another. 
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One could also be added to the end of a cookbook, or to the beginning to provide a fam-
ily history or notes about the book.

To create a new Text Page
Select a cookbook or a chapter, and choose Cookbook > New > Text Page, or press the 
Add Text Page toolbar button

Image Pages
Image pages allow high resolution, full-page-sized images to be added to a cookbook or 
chapter. Image pages are different from the images that are included in your recipes. 
Smaller recipe images will be added to the chapters inline if the recipes have images, 
but image pages allow for any image to be added to a cookbook. This is perfect for full-
sized recipe images, but it also useful as a way of adding personal, family images to a 
cookbook as well.

L
Note: images should be high-resolution and should be in the same ratio 
as your page size. If an image is too small it will be scaled to fit the 
whole page. If an image is too big, it will be cropped to fit within the 
page dimensions.

To create a new Image Page:
Select a cookbook or a chapter, and choose Cookbook > New > Image Page, or press 
the Add Image Page toolbar button.

Blank Pages
Blank pages are just that: pages with no text or images on them. Blank pages can be 
added between chapters, or to the end of a cookbook, as a way of reserving space for 
notes, or personal handwritten messages. They are also useful to add “space” at the 
beginning of a cookbook. Some book styles actually include an intentionally blank page 
at the beginning.

To create a new Blank Page:
Select a cookbook, or a chapter, and choose Cookbook > New > Blank Page, or press 
the Add Blank Page toolbar button.

Text Blurbs
Text Blurbs are blocks of text that can appear between your recipes. These are a great 
way to preface a recipe, or to add comments about a recipe that is coming after it.

To create a new Blurb:
Select a cookbook, or a chapter, and choose Cookbook > New > Text Blurb, or press 
the Add Blurb toolbar button.
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Creating a PDF Cookbook
The cookbook Builder allows you to create high-resolution PDF files with your recipes. 
These PDFs are suitable for printing or can be shared as digital files.

To create a PDF file of your cookbook:
Select one of your cookbooks in the Builder window and choose Cookbook > Create 
PDF

In the window displayed, choose the theme for the cookbook that youʼd like to create, 
and then check the “Show in Preview” button if you want your new cookbook to be dis-
played in the Preview application when the cookbook is completed.

Publishing and Printing Your Cookbook
There are many services that provide self publishing and printing of PDF cookbooks. 
Most allow uploads of PDF files without covers, and then provide a way to add a book 
cover and choose from a variety of bindings for the finished output.

To create a cookbook without a cover, simply uncheck the “Has book cover” box on the 
cookbook editor Cover tab. If a text title page is desired, check the “Has title page” box 
on the Detail tab.

Once you have created your cookbook, you can then upload it to one of many print-on-
demand self publishing services that will let you print one or more copies. Table 14-1 
lists some recommended sites.

Lulu www.lulu.com

CreateSpace www.createspace.com

CafePress www.cafepress.com

Table 14-1

Some of these sites will also allow you to sell your cookbook creation online, which 
could be a great way to share your recipes.

Tips for Creating Your Cookbook
The “engine” that creates your cookbook is limited in that it wonʼt always know what will 
work best for your output.
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Occasionally the page breaks might not be optimal and your recipes may be divided 
over pages in a way that is not satisfying. When this happens, it might be worth consid-
ering modifying a recipe to condense the text, or to make it cleaner, so that the recipe is 
either shorter, or breaks in a more appealing manner.

Some recipe collections might also work better with certain themes. Trying another 
theme might produce a better cookbook with your content. It is also possible to try an-
other style as well. For instance, it might work better for your creation to have recipes 
start an new page after each one, rather than being listed one right after the next.
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Appendix A

Backing Up Your MacGourmet Library
Having a good backup plan is critical. Many people contact us for their serial number 
because their hard drives died and theyʼve lost everything. Files can be accidentally de-
leted, or corrupted, so itʼs always a good idea to make copies of your information from 
time to time.

There are two components of MacGourmet that should be backed up:

Locating the MacGourmet3Database.mgdatabase file:
This is the file you created the first time you ran MacGourmet. If you chose to put it in 
Documents, and you regularly back up that folder using something like Time Machine, 
your information will get saved. If you put it somewhere else, make sure this location is 
added to your backup plan.

Locating the MacGourmet Application Support folder:
This folder is located inside your user folder inside of Library/Application Support/

This folder stores things youʼve added to MacGourmet, like themes, plug-ins, etc.

The application file itself will always be available from our servers, so you can back that 
up, but itʼs not critical.

Normally, running Time Machine should keep these files backed up, but you should ver-
ify that they are being included.
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Changing the Location of Your MacGourmet Library
By default, your library is found in the location you specify the first time you run 
MacGourmet. To change this location, open Preferences and navigate to the Advanced 
tab. Next press the “Change...” button and select the folder that you would like to use to 
store your MacGourmet3Database.mgdatabase file. Make sure that this folder is read/
write for any user that will be using MacGourmet. Note that this location is the folder that 
will CONTAIN the database file.

To reset the location to the default, press the “Reset” button.

Note that you need to quit and restart MacGourmet for this change to take effect.

Changing your database location at launch
You can select an existing library other than your default library at application launch 
time by holding down the option key while the application is starting up. This will display 
an open dialog that lets you choose an existing MacGourmet3Database file to load. This 
feature allows you to have multiple recipe libraries if you desire.

Note: When starting MacGourmet without holding down the option key, it will go back to 
loading the default library specified in Advanced preferences.
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Appendix B

Configuring the Services menu in Mac OS X 10.6(Snow Leopard)

If you are using Mac OS X 10.6 (Snow Leopard), support for Mac OS X Services 
changed and they are totally configurable now. You do have to explicitly add your 
MacGourmet Services menu items to your Services menu though, they are no longer 
there by default. To do this:

Open the Services Preferences from the Services menu in any app, in this case, Safari:

Then, look for the MacGourmet menu 
items, "Import Recipe From Web Page" 
and "Clip Recipe" and check the boxes 
next to them:

 
Close Preferences, and that should 
be it, the MacGourmet Services 
are enabled.
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Appendix C

Managing MacGourmet Plug-ins With the Plug-in Manager

The Plug-in Manager is a tool for adding and removing plug-in functionality.

The Plug-in Manager lets 
you view, enable and dis-
able built-in and added 
plug-ins. To open it choose:

Tools > Plug-in Manager

Built-in Plug-ins 
This list includes built-in 
plug-ins that come with the 
product. You can enable 
and disable these, but you 
canʼt remove them like op-
tional plug-ins.

Adding, Removing and 
Disabling Optional 
Plug-ins
This list includes plug-ins 
youʼve installed. To install a 
plug-in, just press the Install 
button next to the name in 
the list. Once installed, you 
can enable it or disable it by 
checking or unchecking the Enabled column.

Installing one or more optional plug-ins requires an application restart.

Plug-in Types
Web Site Importer

File Import/Export

Tools - Tools like Mealplan, Cookbook, or Nutrition.

C
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