
HOW TO USE ENSIGHT WITH WORKBENCH
Use EnSight with Workbench

INTRODUCTION
EnSight can be run as a stand-alone application, or as a component from within ANSYS Workbench. This document 
describes the use of EnSight from within the WorkBench environment. It covers activating the EnSight WorkBench 
Extension, linking EnSight to WorkBench solutions and using EnSight to open the WorkBench solution. This 
document assumes that Ansys Workbench has been installed on your Windows or Linux machine and that you wish 
to use EnSight within this framework. It does not attempt to teach WorkBench, nor EnSight usage.

Quick Startup

Simple Example EnSight Session within ANSYS Workbench

Detailed view of the EnSight ANSYS Workbench Interface

File locations within WorkBench

EnSight Differences within ANSYS WorkBench

EnSight Limitations within ANSYS WorkBench

Advanced Usage: Design Point Session Using EnSight

QUICK STARTUP

 Launch WorkBench
To launch ANSYS Workbench on Windows, click the Start menu, then select 

All Programs > ANSYS 19.0 > Workbench 19.0.

To launch ANSYS Workbench on Linux, open a command line interface, type the path to “runwb2” (for

example, “/ansys_inc/v190/Framework/bin/Linux64/runwb2”), then press Enter.

The ANSYS Workbench interface has a Toolbox list on the left side to make it easy to choose the tool set that will 
enable you to solve particular types of problems. Tools are chosen from the Toolbox list and dragged onto the Project 
Schematic in order to use them. Tools are then linked together in a workflow to accomplish tasks. Supporting features 
such as Properties and Messages provide orienting information. These features and the status indicators in the 
system cells guide you through the completion of your workflow. In order to see EnSight in the Toolbox, the EnSight 
WorkBench extension must be activated. 

Activating EnSight as a WorkBench Extension
If the EnSight extension is not in the list of Component Systems in the Toolbox Workspace, choose, from the 
WorkBench top menu, Extensions>Manage Extensions...   which will pop up the Extensions Manager dialog 
(see below). Toggle on the EnSight Extension, and then right click on EnSight and choose Load as Default 
(as shown below). This will load the EnSight application extension when you start up WorkBench in the future.
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Linking EnSight to WorkBench solutions
To link the EnSight Extension to a solution result, drag the EnSight extension from the Component Systems list onto 
the Project Schematic. A red, square landing pad will appear in the WorkBench Project Schematic space to give you 
guidance.

Now drag the Solution onto the Results under EnSight to link the Solver Solution to EnSight’s Results. Once the link 
is created, right click on the EnSight Results and choose Update.
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Using EnSight to open WorkBench solution(s)
The EnSight Results will show a check box when they are properly updated. Now double-click on the EnSight Results 
or Right-click > Edit... which will startup EnSight and load the Solution data for interactive use.
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SIMPLE EXAMPLE ENSIGHT SESSION WITHIN ANSYS WORKBENCH

This walkthrough loads a simple, sample ANSYS Workbench analysis (creating the analysis is beyond the scope of 
this document) and then adds the ANSYS EnSight extension and attaches the mechanical and fluid analysis 
workflow to EnSight and then opens the solutions using EnSight.

This example uses the EnSight FLUENT Direct Reader to load the Fluent fluid flow analysis and the EnSight 
ANSYS Reader to load the Ansys Mechanical analysis results, in order to demonstrate, step by step, an EnSight 
WorkBench workflow using multiple, simultaneous, heterogeneous solutions. 

1. Now, Launch WorkBench, then open a project containing both fluid and structural solutions.

2. If you have not already done this, Activating EnSight as a WorkBench Extension must be done here so that you 
can see EnSight in the Toolbox. Then, restart WorkBench.

3. Upon restarting WorkBench, you should see the EnSight extension under the Component Systems pulldown in 
the Toolbox Workspace on the left side.
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4. Load the WorkBench project using File>Open. Now drag the EnSight extension from the Component Systems 
list onto the Project Schematic. A red, square landing pad will appear in the WorkBench Project Schematic space to 
give you guidance.

5. Now an EnSight system is established in your Project Schematic and ready to be linked up.
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6. Now drag the Fluid Flow Solution on to the Results under EnSight to link the Solver output to EnSight’s input.

7. Now, EnSight is linked to the solution. Right click on the green arrows in the EnSight Results to update the link. 
Important: Any time your result has the double arrows, then it needs to be updated. A check box means your 
results are current. Updating EnSight Results prepares the data to be loaded.
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8. The EnSight results will show a check box when they are properly updated. Now double-click on the EnSight 
Results or Right-click > Edit... which will startup EnSight and load the Solver Solution for interactive use.

9. The EnSight session will start up with only the Fluent solution loaded as shown below. Note that only the Fluent 
results were linked up to EnSight, so only the Fluent results are loaded. This portion of the manual assumes that you 
know how to use EnSight from here. If not, from the top menu of EnSight, Help> Getting Started Manual. 
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10. Within EnSight’s menu, File>Quit to exit EnSight. Now, back in the WorkBench environment, in the Project 
Schematic area, let’s also add the structural solution to the EnSight process. Drag the structural solution onto the 
EnSight results section as shown below.

11. Note that you now have two links into the EnSight results section, as shown below but EnSight’s Results show the 
double arrow indicating they need to be updated.

Double arrows
indicate that this
needs updating
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12. Now, with the new link, again, notice that there is no longer a check box on the EnSight results. We need to 
update the EnSight results. On the EnSight Results, Right-click > Update.

13. Now let’s open EnSight and load the Fluid Solution and the Structural Solution. Right-click > Edit or 
double-click on the EnSight Results section as shown below to start up EnSight and load the solution data:
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14. EnSight now opens with both Fluid and Structural solution results (see Load Multiple Datasets (Cases)).

15. Now, set the EnSight properties in the WorkBench Properties View to enable the Beta feature in EnSight to see 
Units (units are labels only, more details are discussed later in the Properties View). To adjust EnSight properties, 
select the EnSight Results (click on the EnSight Results) and in the top menu, View>Properties. Toggle on 
Advanced EnSight Features; now adjust the EnSight Advanced properties (shown below) as described. Close the 
properties view by right-clicking on the Title Bar, and choosing Close. If EnSight is running, quit EnSight and then 
double click on the EnSight Results to reload the Solution with EnSight using the Beta features that you have toggled 
on.
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1. Select EnSight 
   Results

2. From the top menu,
    View>Properies

3. Toggle on Advanced 
EnSight Features to expose 
other toggles. Toggle on 
Enable Beta Features.
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16. Color by variables from each of the two solutions simultaneously. This is the view below (with units shown in the 
legend titles), that you will see if you have enabled Beta features. If you don’t see units in the legend bar, go back to 
step 15 and then make sure you have quit and restarted EnSight after you enable the Beta features.

17. Quit EnSight when you are done with your simultaneous postprocessing of the two solutions.

18. Consider saving your updated Workbench project, and then exit Workbench.

Important

Saving a WorkBench project enables you to re-open the project on the machine that originally created it. To make the 
project available on another machine, you need to use File > Archive to create a project archive. To open the 
project on a different machine, run File > Restore Archive on that machine.
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DETAILED VIEW OF THE ENSIGHT ANSYS WORKBENCH INTERFACE

The previous section stepped through a sample analysis and provided a broad overview of using EnSight within the 
WorkBench workflow. What follows is a more detailed look at the WorkBench GUI as it relates to EnSight. Some of 
the content is repeated for the advanced WorkBench user who skips the sample analysis and wants to dive into the 
details.

Reminder, if the EnSight extension is not shown in the list of Component Systems in the Toolbox Workspace then 
it must be loaded as a WorkBench extension as follows. Choose, from the WorkBench menu, Extensions>Manage 
Extensions...   which will pop up the Extensions Manager dialog. Toggle on the EnSight Extension, and then 
right click on EnSight and choose Load as Default. Now, quit WorkBench. Restart WorkBench and verify that 
EnSight appears in the Toolbox under the Component Systems pulldown.
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After choosing to Load as Default, the EnSight as a WorkBench extension, and then restarting WorkBench, you 
should now see EnSight in the Component Systems pulldown in the Toolbox Workspace as follows:

Now let’s look at the WorkBench GUI in more detail. Shown below are the components of WorkBench. WorkBench 
has a top-level Menu Bar, and a lower Status Bar and one or more Project Tabs. Each Project Tab has a Toolbar, with 
a number of Workspace Views, some of which are shown below: the Toolbox Workspace, Properties View, Files 
View and the Project Schematic Workspace. The Project Schematic is where Systems from the ToolBox are 
assembled together into a Workflow. Some of this will be discussed in this section as it pertains to EnSight.

 

Menu Bar            Workspace Tab(s)   Project Schematic  Toolbar    Properties

Status Bar      Toolbox            Files View     System
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Views
You control which views are displayed by choosing View from the top menu and choosing the view you want to 
display. Note that the Toolbox and the Project Schematic are displayed by default. For the following View, first select 
a cell, then choose one of the following other views from the top level View Menu, and the workspace corresponding 
to the selected cell will appear: Toolbox Customization, Files View,  Properties View, Messages View, Progress 
View, Sidebar Help View.  If you minimize a view (on the Title Bar, Right-click>Minimize), it appears as a tab 
in the View Bar and the check box is cleared from the View menu. For more details on workspaces and tabs, see 
Tabs within Workbench in the Workbench User's Guide and Views within Tabs in the Workbench User's Guide. Now, 
let’s look at several Workspaces and Views.

1. Select the EnSight 
Results, 

2. From the top menu 
bar, View>Files 

3. Pops up the 
dockable/undockable 
Files Workspace. 
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Toolbox Workspace
The list on the left is the Toolbox; by default viewing is toggled on for the Toolbox. The Toolbox contains four 
pulldowns containing systems available to you: Analysis Systems, Component Systems, Custom Systems, and 
Design Exploration, which are discussed below.

1. Analysis Systems
The Analysis Systems pulldown contains applications that transform input and solve particular types of problems, 
often resulting in transformed output. These systems can be thought of as of the kind of solution that is desired 
packaged with the Solver. For example Eigenvalue Buckling system is a modeling, a meshing, a modal 
frequency buckling analysis and a visualization process packaged with Ansys Mechanical. Similarly, the Fluid 
Flow (Fluent) system contains tools for creating the geometry, performing the meshing, setting up the solver, 
using the solver to derive the solution, and viewing the fluid flow results. 

2. Component Systems
The Component Systems pulldown contains extensions that are loaded into WorkBench that also solve particular 
types of problems similar to the Analysis Systems. In particular, you will see the EnSight Extension under this 
pulldown. EnSight is available to input solution results and to interactively Analyze, Visualize and Communicate these 
solution results and create postprocessing output such as tables, movies, images, or data files.
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3. Custom Systems
The Custom Systems pulldown contains customized applications that combine multiple analysis systems. For 
example, the FSI: Fluid Flow (Fluent) > Static Structural system combines ANSYS Fluent and the Mechanical 
application to perform a Fluid Structure Interaction (FSI) analysis.

4. Design Exploration
The Design Exploration pulldown contains systems that enable you to see how changes to parameters affect the 
performance of the system.

Note: Which systems are shown in the Toolbox depends on the licenses that exist on your system. You can 
hide systems by enabling View > Toolbox Customization and clearing the check box beside the name of the 
system you want to hide. To begin using a system, drag it into the Project Schematic area.

Project Schematic Workspace
The Project Schematic enables you to manage the process of your work flow; by default viewing of the Project 
Schematic is on. It keeps track of your files and shows the actions available as you work on a project. At each step 
you can select the operations that process or modify the case you are solving. 

When you move a system from the Component Systems toolbox to the Project Schematic, you will see a system 
similar to the following:

Each white cell represents a step in solving a problem. Right-click the cell to see what options are available for you to 
complete a step. For example, you would select Edit in the example above on an EnSight Results cell to launch 
EnSight and load solution data, or Properties to open the EnSight Properties table to enable optional EnSight 
capabilities.

System Type
Cell State
System Name

System
Coordinates

Load Results using EnSight

Toggle on 
Advanced 
EnSight 
Features to 
expose other 
options.
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Toolbox Customization
View>Toolbox Customization will view the Tool Customization Workspace in a tabular form, as shown below. 
This allows you to customize the Physics, Solver Type and Analysis Type of the particular application or extension 
according to your workflow needs as shown below. Right-click>Minimize on the Toolbox Customization title 
bar, to reduce the workspace table down to a tab below the Toolbox list. Right-Click>Close to close the Toolbox 
Customization workspace.
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Files View
The Files view (View>Files) shows the files that are in the selected cell of a given System. The project files are 
updated constantly, and any “save” operation from a component will save all files associated with the project. 

ANSYS Workbench associates data with system cells. This data may be stored in different ways, including as part of 
the ANSYS Workbench project file or as separate files.When files are generated, they appear in the Files view. This 
view can be used to identify which files are associated with each cell. 

On the title bar, Right-click>Minimize or Right-click>Close to minimize this file Workspace to a tab or to 
close it, respectively.

Important
Although the Files View reveals the data files that make up a project, you should not attempt to manipulate these files 
directly, as project data management will proceed unaware of your changes and with unpredictable results.
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Properties View
The Properties view is a table whose entries describe the status of a system. These entries vary between system 
cells and are affected by the status of the cell. Some entries in the Properties area are changeable; others are for 
information only. To display the Properties for a particular cell, right-click the cell and select Properties, or click on the 
cell to select it, and in the top menu, View>Properties. Note, once the Properties view is open, simply selecting 
another cell in the Project Schematic will display its properties. Right click on the Toolbar and choose Close to close 
the window, or minimize to reduce it to a tab.

EnSight Example
For example to adjust EnSight properties, select the EnSight Results (click on the EnSight Results) and in the top 
menu, View>Properties. Toggle on the Advanced EnSight Features toggle to see the available properties 
and their settings. The Use Software Rendering toggle is available in the rare instance that EnSight is unable to 
adjust its rendering mode due to graphics incompatibilities; toggle this on to force EnSight to use internal software 
rendering in order to manually bypass hardware or software graphics card rendering problems. The Enable Beta 
Features toggle exposes two features under development: units labeling (for details, see EnSight Limitations within 
ANSYS WorkBench) and the Nexus report interface. 

Messages View
The Messages view shows the messages to the user. For example, click on the EnSight Results in the Project 
Schematic to select it, and in the top menu, View>Messages. 

On the title bar, Right-click>Close to Close the Message view workspace.

1. Select EnSight 
   Results

2. From the top menu,
    View>Properies

Toggle 

3. Toggle on Advanced 
EnSight Features to 
expose other toggles.
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Progress View
The Progress view shows the progress to the user. For example, click on the EnSight Results in the Project 
Schematic to select it, and in the top menu, View>Progress. 

On the title bar, Right-click>Close to Close the Message view workspace.

Sidebar Help View
In the top menu, View>Sidebar Help. Click on this link.

In addition to having a visual layout that guides you through completing your project, you can also access Sidebar 
Help by pressing F1 while the mouse focus is anywhere on ANSYS Workbench. Sidebar Help is a dynamically 
generated set of links to information appropriate for helping you with questions you have about any of the tools and 
systems you currently have open.

Shortcuts (Context Menu Options)
You can access commonly used commands by right-clicking in most areas of ANSYS Workbench. These commands 
are described in Context Menus in the Workbench User's Guide.
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FILE LOCATIONS WITHIN WORKBENCH

EnSight has default locations for file operations within the ANSYS Workbench environment. To view a file within your 
OS, simply select the Results cell of interest, View>Files to see the Files View, and then Right-click>Open 
Containing Folder . Warning: Do not move WorkBench files around!

ENSIGHT DIFFERENCES WITHIN ANSYS WORKBENCH

Note that EnSight behaves somewhat differently in a WorkBench session than when run stand-alone. Many of these 
changes are largely cosmetic, but that can be confusing initially.

• The default part colors are different. EnSight in WorkBench utilizes a more muted color palette with an improved 
default lighting configuration.

• The mouse button graphics view manipulations have been modified to align better with the other Ansys application 
defaults.  Specifically, the middle mouse is used to manipulate the view (with control and shift modifiers), the left 
mouse is used to select entities and the right mouse is used to bring up context sensitive menus.

• All interactive operations in an EnSight WorkBench session are saved in an EnSight context file automatically. 
When you reopen EnSight, this context file will be used to restore the session to its last saved state. Whenever 
EnSight is closed, the context file is updated. You will not be prompted to save the EnSight state when exiting 
EnSight when it is launched from WorkBench.

• The default license manager for EnSight, when run from within an Ansys installation (including via WorkBench) is 
the Ansys license manager. EnSight will use a SLiM license if an appropriate license cannot be obtained from the 
Ansys license manager.

ENSIGHT LIMITATIONS WITHIN ANSYS WORKBENCH

There are several EnSight limitations within the WorkBench environment. 

• When launched from WorkBench, EnSight always opens using an EnSight Standard license; you cannot do parallel 
processing from within Workbench. 

• Workbench cannot effectively use the EnSight native, Case Gold data format due to Workbench limitations in the 
handling of large numbers of files.

• Care must be taken when using EnSight Python and command language files from within WorkBench. The 
WorkBench interface relies on specific ordering of cases in the EnSight session and any Python or command 
language operations that modify case attributes (e.g. names, etc) will conflict with WorkBench conventions. 

• EnSight cannot be run in script-driven, batch mode using Workbench. WorkBench will evaluate design points in 
batch mode if an EnSight session is not open, but there is no mechanism to run a specific script in batch mode.

• Currently in EnSight units are labels only. EnSight-standalone displays units by default. In contrast, EnSight within 
the WorkBench environment does not display units by default. Display of units is a EnSight WorkBench Property 
controlled by the Enable Beta Features toggle, which is off within the WorkBench environment by default. This is 
because EnSight lacks a mechanism to convert common variables to common unit systems prior to display. Thus, it 
is possible when using EnSight through WorkBench to view “temperature” related variables (with different names) 
from different data sources (e.g. Fluent and Mechanical) in different units (e.g. K, C). The individual variables will be 
properly labeled with ‘K’ and ‘C’ denoting that the variables are in different unit systems.   It was decided to limit the 
units exposure as a beta feature until this shortcoming is addressed.

• When using design point parameter in the current release, WorkBench is not automatically made aware of any 
EnSight constants that are created/activated. The list of design point parameters is updated when the EnSight task 
‘Enable Design Point Parameters’ property changes state. Thus, if you have a running EnSight session and use the 
calculator to create a new constant that you wish to appear in the current WorkBench design point variables, one 
may need to uncheck and recheck the “Enable Design Point Parameters” property.

• The current EnSight session state is explicitly linked to the collection of solutions marked as inputs into the EnSight 
Results task in WorkBench. If one changes the inputs (e.g. adds an additional solution or removes one), the state of 
the EnSight session will be reset to the default (the EnSight context file will be reset). It is strongly recommended 
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that users configure all of the inputs to the EnSight Results task before setting up the visualization in EnSIght that 
they would like to be retained.
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ADVANCED USAGE: DESIGN POINT SESSION USING ENSIGHT

This example will take you step by step through a WorkBench Design Points EnSight example session. You might, for 
example, use Design Points if you wanted to optimize a design based on some figures of merit. This section assumes 
you have successfully worked through the previous simple, example session: Simple Example EnSight Session 
within ANSYS Workbench so some intermediate steps will be skipped in the interest of brevity. 

1. Load a WorkBench dataset, drag the EnSight system from the WorkBench Toolbox onto the Project Schematic and 
link the Solver Solution to the EnSight Results cell. Right click the EnSight Results and choose Update if your 
EnSight Results cell has arrows rather than a check mark. If the update takes a while, in order to see the progress, 
from the WorkBench top menu, View>Progress. You should see the following.
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2. Now double-click EnSight Results to start up an interactive EnSight session. Do something and calculate a Case 
Constant that you wish to use as a design value. In this EnSight example, we have created a new part, a radial clip 
and calculated the Spatial Mean of the Velocity vector magnitude.

 3. Now we want to import the EnSight Case Constant into WorkBench as a Design Point. On the EnSight Results 
Right-click>Properties.
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4. In the resulting dialog, Toggle on, the Enable Design Point Parameters.

5. Now you will notice that you need to update the EnSight Results: Right-click>Update. From the top menu, 
View>Progress to see the progress of the update, if it takes a while.
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6. Once the EnSight Results are updated, now, on the Parameter Set, Right-click>Edit 

8. Now you will see that you are in the Parameter Set tab rather than the Project Tab. The Outline of All Parameters 
table below. Now do a View>Table and see the Table of Design points shown below. Notice the constant calculated 
in EnSight on the Radial Clip Plane part in EnSight, SpaMeanVelMag has been imported into WorkBench as a Design 
Point.

EnSight variable shows up
in the Parameters, and as a
WorkBench Design Point 

Note you are in the Parameter Set View
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8. In the Table of Design Points, Toggle on one of the Retain toggles for DP2. Now right click on the row and choose 
Set as Current. This will make DP 2 as the current Design Point. Now to update to Design Point 2 as the input, to 
solve the flow and to use EnSight to Calculate the Spatial Mean of the Velocity Magnitude on the Radial Clip, Right-
click> Update Selected Design Points. 

 

9. Now take a closer look at your updated Table of Design Points. Two of the SpaMeanVmag EnSight Constants / 
WorkBench Design Points (see P7 Results in Column H below) are have been calculated. You now can see that 
Design point 0 has a higher average velocity at the EnSight Radial clip part.

Choose View>Progress to see what is happening
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10. Notice the cells in the Table of Design Points that are White. These are editable. The columns that are gray are 
the Design Point output from the Solver or from EnSight; they are not editable. They are the input values for the 
Solver. Edit the diameter of DP2, part in1 and change it to 2. Notice that the corresponding Design Points now need 
updating. Right-click>Update Selected Design Points on row 5. Now the solver re-runs with the new 
value for the in1 diameter, and then the solution data is fed to EnSight to create a radial clip and calculate the 
average velocity magnitude.

9. When the update of DP2 is finished, click on the EnSight Window and notice the increased diameter of part in1, the 
input part..
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10. Now, update all design points. Note that EnSight does not launch multiple EnSight processes. It works through 
each of the design points one by one using one EnSight process and one EnSight license. This may take a while 
depending on your number of design points: View>Progress.

11. Now look at your Table of Design Points. It is fully populated. Now you can decide which Spatial Mean of the 
Velocity magnitude satisfies your criteria and answer your hypothetical design problem: DP1 has the maximum value. 

12. Exit WorkBench.
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SEE ALSO

Sample interactive demonstration sessions using EnSight: 

Simple Demonstration
Flow Visualization Example: Unstructured Mesh
Structural Mechanics Example

EnSight Further Reading

EnSight Overview
Print/Save an Image
Save/Restore Context
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