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Install and Set Up HP Web Jetadmin

When you install HP Web Jetadmin, you only need to install it on one hardware platform that meets the 
recommended minimum requirements (System Requirements on page 1) and is centrally accessible on the 
network. You may then access the software from any supported Windows desktop on the network and manage 
all supported network-connected peripherals.

HP Web Jetadmin offers several installation options. If you have installed a previous version of HP Web Jetadmin, 
you can choose to upgrade the previous version or install a new copy. Upgrading an older version preserves your 
settings for discovery options and groups and is most likely the best choice if you have already been using 
HP Web Jetadmin.

Every release of HP Web Jetadmin contains new features and improvements to existing features. In an 
environment where a previous release of HP Web Jetadmin is integrated into critical business operations, 
HP recommends that you fully test and qualify a new release before implementing that release into full 
production.

Read all of the support materials before you implement HP Web Jetadmin. For current information about 
HP Web Jetadmin, see the Late Breaking News for HP Web Jetadmin 10.4 and the HP Web Jetadmin 10.4 
Supported Devices Readme. These documents are available from the HP Web Jetadmin support page (click the 
flag icon on the bottom of the page, and then select your country/region).

System Requirements
HP Web Jetadmin includes network device communication protocols and internal components that manage 
application and device data. These components extend the capabilities of HP Web Jetadmin and improve usage 
and performance in device lists, columns, and filtering functions.

HP Web Jetadmin is supported on platforms that have Microsoft Windows and .NET Framework high-priority 
updates. During each development cycle, HP regularly tests HP Web Jetadmin on platforms that have the 
current Microsoft updates. HP investigates all post-release software issues that customers report. For more 
information about the current software issues, see the Late Breaking News for HP Web Jetadmin 10.4. This 
document is available from the HP Web Jetadmin support page (in English).

HP Web Jetadmin requires the Windows HTTP SSL service. HP Web Jetadmin uses SSL to communicate with 
newer HP devices through port 8050.

HP Web Jetadmin Server Application

Supported operating systems

● Microsoft Windows Server 2016

● Microsoft Windows Server 2012 R2

● Microsoft Windows Server 2012

● Microsoft Windows Server 2008 R2 SP1

● Microsoft Windows 10 (64-bit edition only)
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● Microsoft Window 8.1 (64-bit edition only)

● Microsoft Window 8 (64-bit edition only)

● Microsoft Windows 7 SP1 (64-bit edition only)

For more information about a specific Microsoft operating system, go to www.microsoft.com.

Notes

● HP no longer supports or tests HP Web Jetadmin installations on Microsoft operating systems that were 
released prior to the operating systems that are supported for the current release.

● Beginning with HP Web Jetadmin 10.3 SR6, Microsoft .NET Framework 4.5 or later is required in addition 
to .NET Framework 3.5 SP1 because HP Web Jetadmin supports Transport Layer Security (TLS) 1.1 and 1.2. 
Some of the operating systems that are supported for the current release already ship with .NET 
Framework 4.5 or later.

If the HP Web Jetadmin installer does not detect .NET Framework 3.5 SP1 and .NET Framework 4.5 or later, 
the installer provides the appropriate installation instructions and Microsoft URL to download .NET 
Framework.

● The operating systems that are supported for the current release include Windows Installer 4.5. If Windows 
Installer 4.5 is not already installed, the HP Web Jetadmin installer provides the appropriate Microsoft URL 
to download Windows Installer 4.5.

● Local administrator access is required to install or upgrade HP Web Jetadmin.

● Production HP Web Jetadmin installations are restricted to dedicated hosts. Running HP Web Jetadmin on 
systems that are also mail servers, DNS servers, domain controllers, and so on is not supported.

HP Web Jetadmin Client Application

Supported operating systems

● Microsoft Windows Server 2016

● Microsoft Windows Server 2012 R2

● Microsoft Windows Server 2012

● Microsoft Windows Server 2008 R2 SP1

● Microsoft Windows 10

● Microsoft Windows 8.1

● Microsoft Windows 8

● Microsoft Windows 7 SP1

For more information about a specific Microsoft operating system, go to www.microsoft.com.

Notes

● Beginning with HP Web Jetadmin 10.3 SR6, Microsoft .NET Framework 4.5 or later is required in addition 
to .NET Framework 3.5 SP1 because HP Web Jetadmin supports Transport Layer Security (TLS) 1.1 and 1.2. 
Some of the operating systems that are supported for the current release already ship with .NET 
Framework 4.5 or later.
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If the HP Web Jetadmin installer does not detect .NET Framework 3.5 SP1 and .NET Framework 4.5 or later, 
the installer provides the appropriate installation instructions and Microsoft URL to download .NET 
Framework.

Virtual Machine (Optional Platform)

Recommended requirements

HP recommends the following virtualization solutions:

● VMware ESX

● Microsoft Hyper-V

Notes

● For a VMware server, the virtual machine network must be set to bridged to facilitate HP Web Jetadmin 
communications.

● It is very important to configure VMware so that its guest or virtual systems have enough resources to 
support HP Web Jetadmin and Microsoft SQL Server. To ensure that the appropriate resources are 
provisioned, see the support documentation for the version of VMware you are using.

Server Hardware

Recommended requirements

HP recommends the following hardware configuration for the server:

● 4 or more processor cores

● 2.8 GHz or higher processor speed

● 4 GB or more of RAM

● 4 GB of available storage

Minimum requirements

Although you can use the following hardware configuration for the server, HP does not recommend that you use 
it for production installations. HP does not test HP Web Jetadmin on this hardware configuration and, therefore, 
cannot guarantee the results.

● 2 processor cores

● 2.33 GHz processor speed

● 5 GB of RAM (2 GB is required for the HP Web Jetadmin Service, and 2 GB is the default SQL memory 
reservation)

HP Web Jetadmin uses a value of 3,072 MB to qualify a system as having 3 GB of RAM.

● 4 GB of available storage
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Notes

● Recent software improvements have increased resource capacity requirements. HP strongly recommends 
the 64-bit editions of Windows and 4 GB or more of RAM for production HP Web Jetadmin installations.

● Storage requirements vary depending on the implementation, database, and migration from previous 
versions.

● NTFS is the only supported file system.

● If the HP Web Jetadmin installer determines that less than 1 GB of RAM is installed, the installer displays a 
message stating that 3 GB of RAM is required.

Client Hardware

Recommended requirements

HP recommends the following hardware configuration for the client:

● PC with 2.4 GHz processor

● 64-bit system with 4 GB of RAM

● Client display with a minimum resolution of 1024 x 768

● Optimized for Normal font size

● Default DPI only

Minimum requirements

Although you can use the following hardware configuration for the client, HP does not recommend that you use 
it for production installations. HP does not test HP Web Jetadmin on this hardware configuration and, therefore, 
cannot guarantee the results.

● PC with 1.8 GHz processor

● 32-bit or 64-bit system with 2 GB of RAM

● Client display with a minimum resolution of 1024 x 768

● Optimized for Normal font size

● Default DPI only

Database

For new installations of HP Web Jetadmin 10.3 SR8 or later, the installation package contains and automatically 
installs the database for Microsoft SQL Server 2012 Express SP2 (product version 11.0.5058.0). Existing 
installations of HP Web Jetadmin prior to 10.3 SR8 and installations that have been upgraded to 10.3 SR8 or 
later use the database for Microsoft SQL Server 2008 Express (product version 10.00.2531.00).

NOTE: HP has successfully tested HP Web Jetadmin with Microsoft SQL Server 2014.

TIP: For more information about configuring HP Web Jetadmin to use a separate Microsoft SQL instance, see 
the Using Microsoft SQL Server with HP Web Jetadmin white paper. This white paper is available from the 
HP Web Jetadmin support page (in English).
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Network

The HP Web Jetadmin installer requires one active IPv4 connection. If an active IPv4 connection is not available, 
the installer fails.

For firmware upgrades with HP Web Jetadmin, a minimum bandwidth of 1 MB/s is required. If there are multiple 
devices upgrading at the same time, then the minimum bandwidth of 1 MB/s will be equal to the number of 
concurrent firmware upgrades. For example, four simultaneous upgrades requires at least 4 MB/s.

Installations and Upgrades

Local administrator access is required to install or upgrade HP Web Jetadmin.

Client Application

The HP Web Jetadmin client application requires the following:

● Internet Explorer 8, 9, 10, or 11

● Display with a minimum resolution of 1024 x 768

Notes

● Internet Explorer is required to start the HP Web Jetadmin client application. For more information about 
Internet Explorer requirements and limitations, see the support documentation for the Windows operating 
system that you are using.

● Administrator access is not required to run the HP Web Jetadmin client application.

● A maximum of 15 concurrent client sessions are allowed.

Supported Devices

HP Web Jetadmin supports HP devices and third-party devices that are connected through HP Jetdirect print 
servers. HP Web Jetadmin also supports third-party devices that are standard printer MIB compliant and are 
connected to the network. For third-party devices, HP Web Jetadmin provides basic capabilities as well as more 
robust capabilities if the devices are used with HP-certified plug-ins for HP Web Jetadmin.

IMPORTANT: If the following devices use a Universal Plug-in (UPI), WS-Discovery must be enabled on the 
devices:

● HP LaserJet Pro

● HP Officejet Pro

● HP FutureSmart with a firmware version earlier than 3.2.3

If WS-Discovery is disabled on HP LaserJet Pro and HP Officejet Pro devices, HP Web Jetadmin uses the correct 
UPI and displays a status of Device Communication Error for the devices after a device discovery or full refresh is 
performed.

If WS-Discovery is disabled on HP FutureSmart devices with a firmware version earlier than 3.2.3, 
HP Web Jetadmin uses a generic device model instead of the correct UPI after a device discovery or full refresh is 
performed.
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Host Access

For the application host, local administrator access is required to install or upgrade HP Web Jetadmin.

For the client host, local user access is required to access the HP Web Jetadmin client application and 
administrator access is required to install Microsoft .NET Framework.

Client/Server Security

Microsoft domain or locally managed Windows users and passwords are required.

Notes

● HP tests HP Web Jetadmin in Microsoft Active Directory domains.

● Users must be a member of an HP Web Jetadmin server administrator group or designated as one of the 
following in the HP Web Jetadmin User settings:

– Windows local security group

– Active Directory security group

– Local individual user account

– Active Directory domain user account

Install HP Web Jetadmin
To install HP Web Jetadmin, perform the following steps:

1. Go to www.hp.com/go/webjetadmin, and then download the HP Web Jetadmin software.

2. Double-click the EXE file.

3. Follow the instructions in the wizard.

4. If the installation stops with a warning that a reboot is required, reboot the host on which the 
HP Web Jetadmin installer is running. Then relaunch the installer to continue the installation.

5. When the installation is complete, click the Finish button.

IMPORTANT: If the HP Web Jetadmin installer does not install Microsoft SQL Server Express Edition, the most 
common reason for the failure is that Windows updates, such as service packs or hotfixes, were installed on the 
machine and the machine was not restarted after the updates completed. Restart the machine, and then install 
HP Web Jetadmin again.

Install HP Web Jetadmin from the Command Line
You can install HP Web Jetadmin from a command line, through a script, or through an automated process. The 
following is the command syntax:

<filename>.exe [/L"<LanguageID>"] [/S /v/qn] </V"[Property1=Value1] 
[Property2=Value2] [...]">
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Command-line parameters

● <filename>.exe
Specifies the name of the EXE file that you downloaded from www.hp.com/go/webjetadmin.

● /L"<LanguageID>"
Specifies the ID of the language the installer uses (Optional). If the language dialog is enabled and you 
specify a valid language ID, the installer automatically suppresses the language dialog. If you specify an 
invalid language ID or a language ID that the installer does not support, the installer ignores this parameter.

The following are the language IDs. The default is the local system language.

Language Language ID

Chinese (Simplified) 2052

Chinese (Traditional) 1028

English (Worldwide) 1033

French (European) 1036

German 1031

Italian 1040

Japanese 1041

Korean 1042

Portuguese (Brazilian) 1046

Russian 1049

Spanish (Mid-Atlantic) 1034

● /S /v/qn
Performs a silent installation (Optional).

To perform a silent installation, the following properties are required:

– WJA_EULA
– ENABLE_ANONYMIZED_DATA_COLLECTION

● /V"[Property1=Value1] [Property2=Value2] [...]"
Specifies a list of properties the installer uses (Required). The following are the properties and values.

Property and Value Description

WJA_EULA=ACCEPT | REJECT Specifies whether you accept or reject the HP Web Jetadmin End User License 
Agreement (EULA).

This property is required for silent installations.

ENABLE_ANONYMIZED_DATA_COLLEC
TION=TRUE | FALSE

Specifies whether the Data Collection feature is enabled or disabled. This feature 
collects data about your printers and implementation of HP Web Jetadmin and 
anonymizes the data. HP Web Jetadmin uses an Internet connection to transmit the 
anonymized data to HP. HP uses the anonymized data to improve products and 
services.

This property is required for silent installations.
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Property and Value Description

IMPORTANT: HP is committed to protecting your privacy and the integrity of your 
computer. You can enable and disable this feature at any time. Your name, address, 
email address, and other sensitive data are not sent to HP.

WJA_BACKUP_CONFIRM=YES | NO Specifies whether a backup of HP Web Jetadmin was performed prior to the 
installation.

This property is required for upgrade installations.

WJA_SUPPLY_GROUP_REMOVAL_CONF
IRM=YES | NO

Specifies whether the existing Supplies Groups are removed. In HP Web Jetadmin 
10.2, the Supplies Groups functionality was removed as a product feature. Regular 
device groups will not be removed or altered during the installation.

This property is required when upgrading from all versions of HP Web Jetadmin 10.1 
and earlier.

YES—Confirms that you understand and agree that all Supplies Groups functionality 
as well as existing groups will be removed during the installation.

NO—Causes the installation to terminate and end without the software being 
installed.

WJA_COLUMN_CONFIRM=YES | NO Specifies whether the column data is upgraded, which might affect filters, groups 
with filters, and device list exporting.

This property is required for silent upgrade installations prior to HP Web Jetadmin 
10.2 SR 5.

WJA_SKIP_DB_INSTALL=1 | 0 Specifies whether the database installation is skipped. To skip the database 
installation, specify 1.

This property is required only if you want the installer to skip the database 
installation.

INSTALLDIR=\"<Path>\" Specifies the HP Web Jetadmin installation path. The following is the default path:

C:\Program Files\HP Inc\Web Jetadmin 10\

This property is optional for silent installations.

The path must be enclosed with \". In addition, the properties specified for the /V 
option must be enclosed with quotes. The following is an example of the correct 
syntax:

/V"WJA_EULA=ACCEPT INSTALLDIR=\"C:\Program Files\HP Inc
\Web Jetadmin 10\""

CAUTION: If the path contains spaces and is not enclosed with \", the installer 
fails.

DATABASEDIR=\"<Path>\" Specifies the database installation path. The following is the default path:

C:\Program Files\Microsoft SQL Server\

This property is optional for silent installations.

If the directory name contains spaces, you must use the Windows short-path 
notation. To find the short-path notation, issue the following command:

Dir *. /x

The path must be enclosed with \". In addition, the properties specified for the /V 
option must be enclosed with quotes.

The following are examples of the correct syntax:

– /V"WJA_EULA=ACCEPT DATABASEDIR=\"C:\SQLServer\""
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Property and Value Description

– /V"WJA_EULA=ACCEPT DATABASEDIR=\"C:
\Program~1\SQLServer\""

CAUTION: If the path contains spaces and is not enclosed with \", the installer 
fails.

Examples of the command-line syntax

The following examples assume that the name of the installation file is WjaSetup-x64.exe.

● To perform a basic silent installation, enter the following command:

WjaSetup-x64.exe /S /v/qn /V"WJA_EULA=ACCEPT 
ENABLE_ANONYMIZED_DATA_COLLECTION=TRUE"

● To start the installer in Spanish, enter the following command:

WjaSetup-x64.exe /L"1034"
● To perform a silent installation with HP Web Jetadmin installed on C:\WJA, enter the following command:

WjaSetup-x64.exe /S /v/qn /V"WJA_EULA=ACCEPT 
ENABLE_ANONYMIZED_DATA_COLLECTION=TRUE INSTALLDIR=\"C:\WJA\""

● To perform a silent installation with HP Web Jetadmin installed on C:\WJA and the database installed on C:
\WJADB, enter the following command:

WjaSetup-x64.exe /S /v/qn /V"WJA_EULA=ACCEPT 
ENABLE_ANONYMIZED_DATA_COLLECTION=TRUE INSTALLDIR=\"C:\WJA\" 
DATABASEDIR=\"C:\WJADB\""

● To perform a silent upgrade, enter the following command:

WjaSetup-x64.exe /S /v/qn /V"WJA_EULA=ACCEPT 
ENABLE_ANONYMIZED_DATA_COLLECTION=TRUE INSTALLDIR=\"C:\WJA\" 
DATABASEDIR=\"C:\WJADB\" WJA_BACKUP_CONFIRM=YES 
WJA_SUPPLY_GROUP_REMOVAL_CONFIRM=YES WJA_COLUMN_CONFIRM=YES"

Install HP Web Jetadmin in Blocking Mode
You can run a silent installation in blocking mode from the command line. The following is the command syntax:

start /wait <ProgramAndArguments>
The following examples assume that the name of the installation file is WjaSetup-x64.exe.

● start /wait WjaSetup-x64.exe /S /v/qn /V"WJA_EULA=ACCEPT INSTALLDIR=
\"C:\wja\" DATABASEDIR=\"C:\wjadb\""

● start /wait "C:\temp\WjaSetup-x64.exe /S /v/qn /V"WJA_EULA=ACCEPT 
ENABLE_ANONYMIZED_DATA_COLLECTION=TRUE INSTALLDIR=\"C:\wja\" 
DATABASEDIR=\"C:\wjadb\"""
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Post-installation Tasks
The HP Web Jetadmin server will start automatically as a Microsoft Service. The HP Web Jetadmin server cannot 
accept HP Web Jetadmin client connections until the HP Web Jetadmin server has fully loaded all services into 
memory. Dependent upon your HP Web Jetadmin server available system resources, it may take 1-2 minutes for 
all services to completely load after initial server installation or server reboot.

The first time you launch HP Web Jetadmin after installation, a pop-up dialog is displayed stating that no devices 
have been discovered. You can opt to launch discovery settings at this point.

Once the installation is complete, HP Web Jetadmin can be launched from a supported browser by entering the 
hostname or IP address of the computer on which it is installed, followed by the port number and path. Typical 
default port numbers for Web services have a value of 80. Since HP Web Jetadmin may be running 
simultaneously with another Web service on the same computer, HP Web Jetadmin uses a port number of 8000. 
If desired, the port value may be altered.

Here is an example of the URL used to activate HP Web Jetadmin on a supported Windows desktop:

http://myhost:8000

Recommended Initial Configuration Steps

After HP Web Jetadmin is installed, some of the initial steps that you should take to begin managing devices and 
the print environment include configuring the options that are shared throughout HP Web Jetadmin, running a 
discovery, and configuring various other features.

Shared configuration options include the database, network (for example, SNMP and HTTPS), discovery, server 
maintenance, and credentials. To configure these options, go to Tools > Options > Shared, and then navigate to 
the appropriate category. For more information about a specific option, see the online Help for that option.

Finding devices on the network might be as simple as enabling HP Web Jetadmin to passively listen for devices 
on the network. Finding devices might be as complex as working with the IT team to map the entire IP network, 
and then running an IP Range discovery to compile a complete inventory of network-connected devices. You can 
also use many of the same settings and techniques to discover PC-connected devices. Before you plan and 
implement a device discovery strategy, carefully review the information about discoveries in the 
HP Web Jetadmin documentation and white papers.

You should configure features such as Roles, Users, Alerts, and Device Groups before you begin using 
HP Web Jetadmin. For more information about a specific feature, see the appropriate section in the 
HP Web Jetadmin documentation and the HP Web Jetadmin white papers.

The HP Web Jetadmin documentation and white papers are available from the HP Web Jetadmin support page 
(click the flag icon on the bottom of the page, and then select your country/region).

Configure the HP Web Jetadmin Service to Restart Automatically

It is recommended to configure HP Web Jetadmin to restart automatically whenever the HP Web Jetadmin 
service fails. If, for example, the database is inaccessible, the HP Web Jetadmin service will be stopped and then 
automatically restarted. The HP Web Jetadmin service will wait for the database to become accessible and then 
the HP Web Jetadmin service becomes live.

HP Web Jetadmin installs an additional service named HPWSProAdapter. The HPWSProAdapter service facilitates 
communication with certain HP device models and must be left running. You must also perform the steps in this 
section for the HPWSProAdapter service.
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To configure the HP Web Jetadmin service to restart automatically, follow these steps.

1. Access the Windows Control Panel and select Administrative Tools.

2. Select Services and then select HPWJA Service.

3. Right-click and select Properties from the menu.

4. Click the Recovery tab. For the First failure, Second failure, and Subsequent failures, select Restart the 
service.

5. Click OK.

Ports
HP Web Jetadmin listens continuously on several ports and opens other ports for specific functionality. The 
following table lists the ports that HP Web Jetadmin uses.

NOTE: HP Web Jetadmin uses Internet Control Message Protocol (ICMP) in the discovery process. 
HP Web Jetadmin sends an ICMP echo request to determine if the IP is active.

Port number Type
Inbound (I) or 
Outbound (O)1 Description

69 UDP I TFTP Incoming Port: HP Web Jetadmin uses this port as a staging area for 
firmware images during HP Jetdirect firmware updates. Through SNMP, 
HP Web Jetadmin triggers HP Jetdirect to retrieve firmware through this port.

80 TCP O HP Web Jetadmin uses this port to qualify the link to the HP Embedded Web 
Server on the device and to retrieve the firmware images from the web.

161 UDP O SNMP: HP Web Jetadmin and other management applications use SNMP to 
communicate with and manage devices. HP Web Jetadmin uses this port on 
the printer to issue Set and Get commands to the SNMP agent.

427 UDP I SLP Listen: HP Jetdirect-connected devices use Service Location Protocol 
(SLP) to advertise their existence. When the passive SLP discovery feature is 
enabled on HP Web Jetadmin, devices send multicast packets to this port on 
the HP Web Jetadmin server.

443 TCP O HTTPS: The HP Web Jetadmin service and HPWSProAdapter service send 
device configurations and queries to this port over HTTPS.

HPWSProAdapter uses this port to communicate with devices that do not 
support Web Services and are configured to redirect all of the network traffic 
to HTTPS.

843 TCP O HP Web Jetadmin uses this port to configure some settings, such as fax and 
digital sending, on some HP MFP device models.

1433 UDP O Microsoft SQL Server: By default, HP Web Jetadmin installs the SQL Server 
database on the same host. Optionally, you can configure HP Web Jetadmin 
to communicate with a SQL Server database on a different host. 
HP Web Jetadmin uses this port to facilitate communication with a remote 
SQL Server database.

2493 UDP I/O Build Monitor: This is an HP Web Jetadmin server port that is kept open. Other 
HP Web Jetadmin servers use this port to discover running instances of 
HP Web Jetadmin.

37022 UDP O WS Discovery: HP Web Jetadmin uses this port to perform a Web Services 
discovery on newer HP devices.
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Port number Type
Inbound (I) or 
Outbound (O)1 Description

39102, 3911 TCP O WS Discovery: HP Web Jetadmin uses this port to retrieve details about the 
device Web Services during a discovery. HP Web Jetadmin uses these details 
to establish the WS communication paths that it needs to manage devices.

HP Web Jetadmin uses port 3910 to retrieve print requests and uses port 
3911 to retrieve the printer status.

4088 TCP I Remoting: HP Web Jetadmin uses this port as the primary communication 
channel between a started HP Web Jetadmin client and its corresponding 
HP Web Jetadmin server.

4089 TCP I Client Event Notification: HP Web Jetadmin uses this port to communicate 
change events from the HP Web Jetadmin server to the client. These events 
trigger the client to pull updates from the server through the Remoting 
interface. In previous releases of HP Web Jetadmin, Windows assigned this 
port.

76272 TCP O Web Services (HTTPS): HP Web Jetadmin uses this port to communicate with 
HP FutureSmart devices and older laser devices for some operations, such as 
OXPd.

For devices that do not support Web Services, the HPWSProAdapter Service 
acts as a gateway between HP Web Jetadmin and the devices. The 
HPWSProAdapter Service receives Web Services requests from 
HP Web Jetadmin, and then sends the translated requests to the devices over 
port 8080 (an unsecure connection, an HP Embedded Web Server password is 
not configured on the devices) or port 443 (a secure connection, an 
HP Embedded Web Server password is configured on the devices).

8000 UDP O HP Web Jetadmin Discovery Listen: HP Web Jetadmin uses this port on 
remote IP hosts to detect earlier versions of the HP Web Jetadmin software.

8000 TCP I Web Server: HP Web Jetadmin provides an HTTP listener for the initial client 
launch and online Help content.

8050 TCP I Device Eventing Callback (HTTPS): Newer HP devices use a WS eventing 
protocol for management communications.

8080 TCP O HPWSProAdapter: HPWSProAdapter uses this port to communicate with 
devices that do not support Web Services and are not configured to redirect 
all of the network traffic to HTTPS. HP Web Jetadmin sends device 
configurations and queries to this port.

8140 TCP I OXPm Web Services (HTTP): This is the communication port for HP Open 
Extensibility Platform (management operations).

8143 TCP I OXPm Web Services (HTTPS): This is a secure communication port for 
HP Open Extensibility Platform (management operations).

8443 TCP I Secure Web Server (HTTPS): HP Web Jetadmin provides a secure HTTPS 
listener for the initial client launch, Help content, and device file transfer 
operations.

9100 TCP O Printer Firmware Upgrade and Test File Operation: HP Web Jetadmin uses this 
printer port to transfer printer firmware files, test job files, and PJL 
configuration files.

27892 UDP I Traps Listener: HP Web Jetadmin uses this port for SNMP-based alerts and for 
By User Data Collections.

27893 UDP I WS Hello Listener: HP Web Jetadmin monitors this port for incoming WS Hello 
packets from the HP WS Pro Proxy Agent software that is installed on hosts in 
the enterprise. When HP Web Jetadmin detects a packet, it follows up to 
determine whether there are any printers to discover on the sending host. For 
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Port number Type
Inbound (I) or 
Outbound (O)1 Description

more information, see the HP Web Jetadmin 10.4 Proxy Agents Readme. This 
document is available from the HP Web Jetadmin support page (in English).

59113 TCP O Microsoft SQL Server: By default, HP Web Jetadmin installs the SQL Server 
database on the same host. Optionally, you can configure HP Web Jetadmin 
to communicate with a SQL Server database on a different host. 
HP Web Jetadmin uses this port to facilitate communication with a remote 
SQL Server database.

1 The I/O column represents the communication direction with respect to the HP Web Jetadmin server host. HP Web Jetadmin uses 
random source ports when communicating with ports on remote IP addresses.

2 HP Web Jetadmin uses ports 7627, 3702, and 3910 internally to communicate with devices. To ensure proper communication, these 
ports must be kept open for communication directly with the device and with the internal HPWSProAdapter service.

When using WMI discovery (discovering PC-connected printers without an HP proxy installed on the PC), several 
ports have to be opened for the WMI communication (DCOM ports, WMI ports, and WMI connection applications 
(UnsecApp or WMI_OUT)). For more information, see: https://msdn.microsoft.com/en-us/library/aa822854.aspx

Open the ports in the Windows firewall by using a batch file

HP Web Jetadmin opens the ports listed in the table to communicate with devices. However, the firewall that you 
are using might block the connection and prevent HP Web Jetadmin from communicating with the network.

Instead of adding firewall rules for these ports one at a time, you can create a batch file that opens all of the 
ports that HP Web Jetadmin requires for the Windows firewall at one time. For instructions, see the Create a 
Batch File to Open HP Web Jetadmin Required Ports in the Windows Firewall white paper. This white paper is 
available from the HP Web Jetadmin support page.

Implement SSL
By default, the HP Web Jetadmin HTTP service runs without certificates. If you add a certificate, the HTTP server 
runs in HTTPS mode and Secure Sockets Layer (SSL) communication is enforced. In HTTPS mode, the user and 
the HTTP server are authenticated to one another and the traffic between them is encrypted. This adds an extra 
layer of security to the Smart Client download and other HTTP transactions.

HP Web Jetadmin does not self-generate certificates. You must obtain a certificate from a certificate authority 
(CA). CAs can exist inside or outside of an organization. Many companies have their own CAs. The 
HP Web Jetadmin Signing Request feature generates a file that you can send to the CA. When the CA sends you a 
certificate, use the Install Certificate feature to enable HTTPS.

IMPORTANT: For new server certificates, you must install 2048-bit certificates. Any previously installed 1024-
bit server certificates continue to function correctly.

Enable Secure Sockets Layer (SSL)

HP Web Jetadmin administrators enable SSL by adding a certificate to the HP Web Jetadmin application. This 
certificate forces the browser to use the more secure HTTPS protocol when a user accesses the client logon 
page. The administrator must enable SSL from the console or host that runs the application by using the 
procedure in Configure HTTPS (Server Certificates or SSL) on page 14. When a remote administrator accesses 
Tools > Options > Shared > Network > HTTPS, a message appears stating that certificates can only be installed 
from an HP Web Jetadmin client that runs on the console or server that hosts HP Web Jetadmin.
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In some environments, SSL is required when an HTTP interface or service is used for communication. In these 
cases, SSL can be enabled and enforced by HP Web Jetadmin. SSL provides a high level of assurance regarding 
the authentication and encryption of HTTP communication. That is, a user who requests access to the 
HP Web Jetadmin Smart Client download can be reasonably assured that the system hosting HP Web Jetadmin 
is authentic and the communication between the two systems is encrypted so that it cannot be easily read by 
eavesdroppers.

The SSL protocol uses certificates to accommodate both authentication and encryption. HP Web Jetadmin can 
generate a signing request that can be used by a certificate authority (CA) to generate a certificate. Using Tools > 
Options > Shared > Network > HTTPS, the user can generate a Signing Request.

Once the request has been fulfilled by the CA, the certificate is ready to be installed on HP Web Jetadmin. 
Remember, you must be at the application console to use Tools > Options > Shared > Network > HTTPS. Use 
Install Certificate to browse and upload the certificate file.

Once the certificate is installed, the HTTP service enforces SSL. Any browser contact with HP Web Jetadmin 
should indicate HTTPS on the URL when a certificate is installed. Using Remove Certificate uninstalls the 
certificate and SSL is no longer enforced.

Important Points to Remember When Implementing SSL

Client communication with SSL enforced requires one or more of the following considerations.

● For new server certificates, you must install 2048-bit certificates. Any previously installed 1024-bit server 
certificates continue to function correctly.

● When SSL has been implemented on HP Web Jetadmin with an internal certificate authority (CA), the CA’s 
authorizing certificate must be installed in the client browser. If this certificate is not installed in the client 
browser the HP Web Jetadmin Smart Client page will fail to load up in SSL mode.

● Proxy servers tend to use the standard SSL port 443. If the HP Web Jetadmin Smart Client page is being 
called through a proxy server, a redirect error may occur. This is due to the URL being redirected to 443 
rather than 8443 which is the port used by the HP Web Jetadmin SSL. The workaround for this is to place 
the HP Web Jetadmin fully qualified domain name (FQDN) into the browsers exceptions list under Tools > 
Internet Options > Connections > LAN Settings > Advanced. This causes the browser to pull HTTP and 
HTTPS content directly from the HP Web Jetadmin server.

TIP: HP Web Jetadmin HTTP and HTTPS port numbers can be customized to something other than 8000 
and 8443.

● When you have implemented SSL on HP Web Jetadmin, a redirect occurs when the browser URL uses port 
8000. Here is an example:

The known URL prior to SSL implementation is http://servername.domain.xxx:8000.

After SSL implementation, HP Web Jetadmin will redirect this to a new URL: https://
servername.domain.xxx:8443.

The URLs shown here use FQDN. In most cases the certificate issued and installed in the HP Web Jetadmin 
SSL implementation will contain an FQDN for the host on which HP Web Jetadmin is installed. If a non FQDN 
is used in the browser, certificate failure will occur. As a general rule, form the HP Web Jetadmin URL with 
FQDN when HP Web Jetadmin is implemented with SSL.

To configure HTTPS, access Tools > Options > Shared > Network > HTTPS.
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Configure HTTPS (Server Certificates or SSL)

1. To configure HTTPS, access Tools > Options > Shared > Network > HTTPS.

2. To associate a certificate with the HP Web Jetadmin server and enable HTTPS, select Install Certificate.

IMPORTANT: When using the HP Web Jetadmin client to install a certificate on a Vista host with UAC 
enabled, you must launch the client from the installer (just after install is finished and from the checkbox 
that enables client launch) or from an IE that was Run as Administrator.

-or-

To remove the installed certificate from the server and disable HTTPS, select Remove Certificate.

-or-

To generate a certificate request that can be sent to a signing authority to generate a certificate that can be 
installed to enable HTTPS, select Signing Request.

IMPORTANT: For new server certificates, you must install 2048-bit certificates. Any previously installed 
1024-bit server certificates continue to function correctly.

3. To save these settings and continue setting other options, click Apply. Then click the next option to 
configure in the left menu bar. To save these settings and close this window, click OK.

Use a Separate Instance of Microsoft SQL Server
By default, HP Web Jetadmin installs and uses a database that runs under Microsoft SQL Server Express. An 
existing installation of HP Web Jetadmin can be configured to use the full version of SQL Server instead of SQL 
Server Express. However, HP does not support or test HP Web Jetadmin installations with SQL Server databases 
other than the version listed in Database on page 4 and, therefore, cannot guarantee the results.

For more information about configuring HP Web Jetadmin to use a separate Microsoft SQL instance, see the 
Using Microsoft SQL Server with HP Web Jetadmin white paper. This white paper is available from the 
HP Web Jetadmin support page (in English).

Deploy the Smart Client
HP Web Jetadmin uses the Microsoft ClickOnce Smart Client technology. This technology runs a Microsoft .NET 
Framework application by automatically downloading and starting the application through a web browser. The 
Smart Client application runs as a local .NET Framework application on the host and uses .NET Remoting to 
communicate with the HP Web Jetadmin service. The following describes the interaction between the 
HP Web Jetadmin server and the Smart Client application:

● The Smart Client application uses HTTP or HTTPS to initially contact the HP Web Jetadmin server. The 
default HTTP port is 8000. The default HTTPS port is 8443. For instructions on changing the default ports, 
see Change the Default HTTP or HTTPS Port for the HP Web Jetadmin Smart Client Application 
on page 16.

● The HP Web Jetadmin server transfers approximately 2 MB of files for the Smart Client application to the 
client.

● The Smart Client application runs on the client as the user who is logged in to the computer, executes 
commands that download approximately 50 MB of HP Web Jetadmin client files, and starts the graphical 
user interface for the HP Web Jetadmin client application. The web browser is now inactive.
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After the Smart Client application starts, the web browser is no longer required. Although HP Web Jetadmin 
also uses the web browser to deliver online Help and proactive Product Update notifications, the 
HP Web Jetadmin client application runs locally on the computer.

● The HP Web Jetadmin server downloads all of the relevant information to the client. When new information 
is available, the HP Web Jetadmin server contacts the client and downloads the new information.

The HP Web Jetadmin installer builds a shortcut on the installation host to http://<ip_address>:8000/, where 
<ip_address> is the host where HP Web Jetadmin is installed. Use this URL to access HP Web Jetadmin remotely 
from anywhere on the company's intranet or WAN.

To start the Smart Client session, only a web browser is required. Administrator rights are not required to run 
Smart Client applications. However, .NET Framework must be installed. Local administrator rights might be 
required to install .NET Framework.

In most cases, the Smart Client session starts automatically. However, the local security settings on the 
workstation might prevent the application from starting automatically. For more information about manually 
starting the Smart Client, see Start an HP Web Jetadmin Client Session on page 17. For more information 
about changing the local security settings, see the Microsoft documentation.

Change the Default HTTP or HTTPS Port for the HP Web Jetadmin Smart Client 
Application

Use the following steps to change the default HTTP or HTTPS port that is used to start the HP Web Jetadmin 
Smart Client application:

1. Use Notepad or a similar text editor to open the HP.Imaging.Wjp.Core.WebServer.config.xml file. This 
configuration file is available in the following directory:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\HP Inc\HPWebJetadmin\WjaService\config

2. Update the <value> attribute for the HTTP or HTTPS port in the following entries:

<property name="HttpsPort">
  <type>HP.Imaging.Wjp.Sdk.Core.Framework.ConfigurationItemString
  </type>
  <value>8443</value>
</property>
<property name="HttpPort">
  <type>HP.Imaging.Wjp.Sdk.Core.Framework.ConfigurationItemString
  </type>
  <value>8000</value>
</property>

3. Close and save the file.

Run the Smart Client Application in a Workgroup

Use the following steps to change the Microsoft security settings:

TIP: For more information about the security policy settings, see the Microsoft documentation.

1. On the HP Web Jetadmin server, go to Start > Control Panel > System and Security > Administrative Tools, 
and then double-click Local Security Policy.

2. In the left navigation pane, expand Local Policies, and then select Security Options.

16 Install and Set Up HP Web Jetadmin ENWW



3. In the right pane, double-click Network access: Sharing and security model for local accounts.

4. From the list, select the Classic - local users authenticate as themselves option.

5. Click the OK button.

Start an HP Web Jetadmin Client Session

After the HP Web Jetadmin installation is complete, use one of the following methods to start an 
HP Web Jetadmin client session:

● On the host where HP Web Jetadmin is installed, go to Start > All Programs > HP Web Jetadmin 10, and 
then select HP Web Jetadmin.

● In Internet Explorer, browse to the following URL on the host where HP Web Jetadmin is installed:

http://<ip_address>:8000

● From the command line, issue the following command:

rundll32 dfshim.dll, ShOpenVerbApplication http://<ip_address>:
8000/wja/wja.application?InternalErrorDetails=true
To start the HP Web Jetadmin client session in a specific language, use the following URLs. If the 
corresponding Windows language pack is installed, the HP Web Jetadmin client session displays in that 
language. If the corresponding Windows language pack is not installed, the HP Web Jetadmin client session 
displays in a mixture of English and the specified language.

Language URL

Chinese (Simplified) http://<ip_address>:8000/wja/wja.application?lang=zh-cn

Chinese (Traditional) http://<ip_address>:8000/wja/wja.application?lang=zh-tw

English (Worldwide) http://<ip_address>:8000/wja/wja.application?lang=en-us

French (European) http://<ip_address>:8000/wja/wja.application?lang=fr-fr

German http://<ip_address>:8000/wja/wja.application?lang=de-de

Italian http://<ip_address>:8000/wja/wja.application?lang=it-it

Japanese http://<ip_address>:8000/wja/wja.application?lang=ja-jp

Korean http://<ip_address>:8000/wja/wja.application?lang=ko-kr

Portuguese (Brazilian) http://<ip_address>:8000/wja/wja.application?lang=pt-pt

Russian http://<ip_address>:8000/wja/wja.application?lang=ru-ru

Spanish (Mid-Atlantic) http://<ip_address>:8000/wja/wja.application?lang=es-es

In some cases, you might need to add the URL for HP Web Jetadmin to the trusted security zone in the Web 
browser.

Configure HP Web Jetadmin to Bind to a Specific NIC

HP Web Jetadmin can run on a multi-homed server or on a server that has multiple network interfaces. In many 
cases, a multi-homed server is connected to more than one network and has multiple IP addresses. A multi-
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homed server with multiple IP addresses can cause problems because HP Web Jetadmin tends to use only one 
address for various reasons.

HP Web Jetadmin is a collection of features that administrators can use to manage devices. Each of these 
features might require communications on the network or convey the IP address through which communications 
should take place to other features either on or off the HP Web Jetadmin server. These features facilitate 
learning the HP Web Jetadmin server IP address when the HPWJA service starts. These features do so in 
isolation and might not select the correct IP address. The following sections describe situations where features 
might not detect and select the correct IP address and provide a workaround that forces HP Web Jetadmin to 
select the correct IP address.

HP Web Jetadmin Client Connection

The HP Web Jetadmin client startup is initiated from Internet Explorer using HTTP. Immediately after the startup 
sequence, the HP Web Jetadmin client sends an HTTP message to the client host. The HTTP message points to a 
Microsoft .NET Framework remote connection. The client host then initiates a relatively secure connection to the 
HP Web Jetadmin server based on the HTTP message.

If HP Web Jetadmin is installed on a multihomed server and the HP Web Jetadmin (HPWJA) service selects an 
incorrect IP address, the .NET Framework remote connection fails because the system that hosts the client 
cannot communicate by using the IP address provided. Use the following steps to force the HPWJA service to use 
the correct IP address:

1. Stop the HPWJA service by using Windows Service Manager.

CAUTION: Be careful when stopping the HPWJA service. Critical tasks might be running and clients might 
be logged in to HP Web Jetadmin. To view the running tasks, go to Application Management > Overview > 
Application Management - Active Tasks. To view the clients that are logged in, go to Application 
Management > Overview > Client Management - Active Clients.

2. Use Notepad or a similar editor to open the System.Remoting.config file. This configuration file is available 
in the following directory:

C:\Program Files\HP Inc\Web Jetadmin 10\config\WjaService

IMPORTANT: Make sure that Notepad is running with sufficient privileges to update and save the file.

3. Find the following code in the System.Remoting.config file:

<application>
  <channels>
   <channel ref="tcp" port="4088" name="CMRemotingChannel"
     rejectRemoteRequests="false"
     tokenImpersonationLevel="Impersonation" secure="true"
     protectionLevel="EncryptAndSign" impersonate="false">

4. Add the machineName="xxx.xxx.xxx.xxx" entry, changing the value to the IP address of the 
HP Web Jetadmin server that facilitates client communication. The following is an example of the edited 
code:

<application>
  <channels>
   <channel ref="tcp" port="4088" name="CMRemotingChannel"
     rejectRemoteRequests="false"
     tokenImpersonationLevel="Impersonation" secure="true"
     protectionLevel="EncryptAndSign" impersonate="false"
     machineName="xxx.xxx.xxx.xxx">
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CAUTION: Make sure that the new entry and value are entered exactly as shown here. Use the quotes 
that the editor generates. Do not copy and paste this text because incorrect characters, such as quotes, 
cause the HPWJA service to fail at startup. Observe all of the rules for editing XML. If the file is incorrectly 
formatted, the HP Web Jetadmin XML parser fails.

5. Close and save the file.

6. Start the HPWJA service by using Windows Service Manager.

HP Web Jetadmin Alerts and SNMP Traps Registration

In rare cases, HP Web Jetadmin detects and uses an incorrect IP address for SNMP traps registration at the 
device. When HP Web Jetadmin alert subscriptions are created, HP Web Jetadmin registers its IP address in the 
SNMP traps destination table on the HP device. This registration causes the device to send a notification in the 
form of SNMP trap packets back to the HP Web Jetadmin server. HP Web Jetadmin uses these notifications to 
trigger alerts for device conditions such as toner out or paper jam.

If an HP Web Jetadmin instance on a multi-homed server populates the SNMP traps destination table with the 
incorrect IP address, follow these steps to force HP Web Jetadmin to select and use the correct IP address:

1. Stop the HPWJA service by using Windows Service Manager.

CAUTION: Be careful when stopping the HPWJA service. There might be critical tasks running. To view the 
running tasks in HP Web Jetadmin, go to Application Management > Overview > Application Management - 
Active Tasks. To view the client logins in HP Web Jetadmin, go to Application Management > Overview > 
Client Management - Active Clients.

2. Open Notepad or a similar text editor that has the appropriate create and edit permissions.

3. Enter the following text:

<ipmc:configuration
xmlns:ipmc="www.hp.com/schemas/imaging/ipmc/config/2004/02/24">
  <property name="LocalIPV4Address">
   <type>HP.Imaging.Wjp.Sdk.Core.Framework.ConfigurationItemString
   </type>
   <value>xxx.xxx.xxx.xxx</value>
  </property>
</ipmc:configuration>

CAUTION: Make sure that the new field and values are entered exactly as shown here. Use the quote 
marks that the editor generates. Do not copy and paste from this document because incorrect characters 
cause the HPWJA service to fail at startup. Observe all the rules regarding XML editing. If the files are 
incorrectly formatted, the HP Web Jetadmin XML parser fails.

4. Change the <value>xxx.xxx.xxx.xxx</value> entry to the correct HP Web Jetadmin server IP 
address through which the device can communicate.

5. Select File > Save As.

6. On the Save as window, navigate to the following directory on the HP Web Jetadmin server host:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\HP Inc\HPWebJetadmin\WjaService\config

7. In the File name text box, enter 
HP.Imaging.Wjp.Alerts.Library.AlertsHelpers.config.xml.

8. From the Save as type drop-down list, select All Files (*.*).
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9. Click Save.

10. Start the HPWJA service by using Windows Service Manager.

HP Web Jetadmin now uses the IP address specified during SNMP traps registration. You must update any SNMP 
traps registrations created prior to this procedure by using the HP Web Jetadmin Configuration feature or by 
creating additional alerts subscriptions.

HP Web Jetadmin Web Service

The HP Web Jetadmin web or HTTP service uses the server IP addresses for various reasons, including 
communicating with other processes, nodes, services, and the IP address of the actual HTTP server. In rare 
cases, HP Web Jetadmin detects the incorrect IP address on multi-homed systems. A configuration file that 
includes the HP Web Jetadmin IP address is built during the first HPWJA service startup. Follow these steps to 
correct the IP address value in the configuration file:

1. Stop the HPWJA service by using Windows Service Manager.

CAUTION: Be careful when stopping the HPWJA service. There might be critical tasks running. To view the 
running tasks in HP Web Jetadmin, go to Application Management > Overview > Application Management - 
Active Tasks. To view the client logins in HP Web Jetadmin, go to Application Management > Overview > 
Client Management - Active Clients.

2. Open Notepad or a similar text editor that has the appropriate create and edit permissions.

3. Select File > Open.

4. On the Open window, navigate to the following directory:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\HP Inc\HPWebJetadmin\WjaService\config

5. Open the HP.Imaging.Wjp.Core.WebServer.config.xml file.

6. Find the following portion of the file:

<property name="HostIPv4Address">
  <type>HP.Imaging.Wjp.Sdk.Core.Framework.ConfigurationItemString
  </type>
  <value>xxx.xxx.xxx.xxx</value>
</property>

7. Change the <value>xxx.xxx.xxx.xxx</value> entry to the correct server IP address.

8. Select File > Save.

9. Start the HPWJA service by using Windows Service Control Manager.

HP Web Jetadmin now uses the specified IP address with reference to the HTTP or web services.

Configure the Port for Event Notifications

HP Web Jetadmin directs clients to a TCP connection to receive event notifications. After the client establishes 
the TCP connection, HP Web Jetadmin sends event notifications that prompt the client to update itself via the 
standard Microsoft .NET Remoting channel on port 4088. The HP Web Jetadmin server communicates the port 
number that is established for event notifications to the client when the client first establishes a connection to 
the HP Web Jetadmin server. The port number that HP Web Jetadmin communicates to the client is somewhat 
random, which might cause a problem if a firewall is configured on the HP Web Jetadmin server.
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If a firewall is configured on the HP Web Jetadmin server, the event notification port must be set to static and the 
firewall must be configured to accept connections through this port. If a firewall is configured on the client, the 
firewall on the client does not have to be configured to launch the client.

Use the following steps to configure a static port for event notifications:

CAUTION: Be careful when restarting the HP Web Jetadmin service. Critical tasks might be running and clients 
might be logged in to HP Web Jetadmin. To view the running tasks, go to Application Management > Overview > 
Application Management - Active Tasks. To view the clients that are logged in, go to Application Management > 
Overview > Client Management - Active Clients.

1. Use Notepad or a similar editor to create a file that contains the following XML section:

<ipmc:configuration
xmlns:ipmc="www.hp.com/schemas/imaging/ipmc/config/2004/02/24">
  <property name="ClientEventRouter.ServerPort">
   <type>HP.Imaging.Wjp.Sdk.Core.Framework.ConfigurationItemString
   </type>
   <value>8099</value>
  </property>
</ipmc:configuration>
The port number specified for the <value> attribute can be any unused port.

2. From the File menu, select Save.

3. On the Save As window, navigate to the following directory on the HP Web Jetadmin server:

C:\Windows\ServiceProfiles\NetworkService\AppData\Local\HP Inc\HPWebJetadmin\WjaService\config

4. In the File name box, enter Global.config.xml, and then click the Save button.

5. Restart the HP Web Jetadmin service (HPWJAService). For instructions, see Restart the HP Web Jetadmin 
Service Manually on page 21.

6. Use any firewall application or a similar application to open the port.

Configure the Firewall Software

You must configure the firewall on the HP Web Jetadmin server host to allow client traffic and other traffic to 
pass through the correct ports. The firewall monitors HP Web Jetadmin for the ports that it uses and allows 
traffic.

In some firewall applications, such as Microsoft Firewall, you can specify a program or executable file as a 
firewall exception. In these cases, you can define the following file as an exception:

C:\Program Files\HP Inc\Web Jetadmin 10\bin\HPWJAService.exe

The firewall on the client system does not require any special consideration because the client application does 
not listen to a specific port.

Restart the HP Web Jetadmin Service Manually
It may be necessary to stop and restart the HP Web Jetadmin service. An example of this would be when a 
network is switched from hard-wired to wireless. Once the network is switched, HP Web Jetadmin must be 
restarted in order for the application to realize the change.

ENWW Restart the HP Web Jetadmin Service Manually 21



CAUTION: Restarting HP Web Jetadmin services may interrupt background tasks and user sessions. Always 
check the application before restarting.

To script the stop of all HP Web Jetadmin services, use these command strings in this order:

● Net stop HPWSProAdapter

● Net stop HPWJAService

● Net stop mssql$HPWJA

To script the start of all HP Web Jetadmin services, use these command strings in this order:

● Net start mssql$HPWJA

● Net start HPWJAService

● Net start HPWSProAdapter

1. Uninstall HP Web Jetadmin.

2. Use Windows Service Manager to set the older HP Web Jetadmin service (listed as HP Web Jetadmin in the 
Services MMC) to activate and to also start the service.

Back Up and Restore HP Web Jetadmin
Scripts for backing up and restoring HP Web Jetadmin are available. These scripts provide examples of the 
recommended method for backing up and restoring the HP Web Jetadmin settings and data, including the 
Microsoft SQL Server database. The WJABackupRestoreInstructions_<language_code>.txt file provides 
instructions for running the scripts. The scripts and instructions are available in the following directory:

C:\Program Files\HP Inc\Web Jetadmin 10\WJABackupRestore

Upgrade HP Web Jetadmin
The current HP Web Jetadmin installation must be backed up before an upgrade is started. The 
WJABackupRestoreInstructions_<language_code>.txt file provides instructions for backing up HP Web Jetadmin. 
This file is located in the following directory on the HP Web Jetadmin server:

C:\Program Files\HP Inc\Web Jetadmin 10\WJABackupRestore

In HP Web Jetadmin, go to Help > About, and then write down the current version as 10.4. nnnnn, where nnnnn 
is the build number. This version of the installer is required to perform a recovery.

Before you begin an upgrade, go to Application Management > Overview > Application Management – Active 
Tasks, and then check for any paused or pending tasks. You must stop or resolve these tasks before you run the 
installer.

To upgrade HP Web Jetadmin, obtain the HP Web Jetadmin installation executable from www.hp.com/go/
webjetadmin. Then run the executable on the system that hosts HP Web Jetadmin.
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Import Feature Packs
Feature Packs provide support for dynamically adding new configuration options and new device images to 
HP Web Jetadmin. Feature Packs are imported and applied on an existing installation of HP Web Jetadmin. This 
means that you can gain access to the new functionality without installing and qualifying a new version of the 
full HP Web Jetadmin application. HP Web Jetadmin Administrator rights are required to apply Feature Packs.

Feature Packs are cumulative. A new Feature Pack includes the new functionality that is being released and all of 
the functionality that was released in previous Feature Packs.

Each Feature Pack has a minimum version of HP Web Jetadmin that must be installed before the Feature Pack 
can be imported and applied. If you import a Feature Pack on a version of HP Web Jetadmin that is earlier than 
the minimum required version, HP Web Jetadmin displays a message that specifies the minimum required 
version.

Feature Packs are available from www.hp.com/go/webjetadmin as signed HP Binary (HPb) files. After you 
download an HPb file, you must import the HPb file into the existing installation of HP Web Jetadmin, and then 
apply the HPb file. You must restart the HP Web Jetadmin service before the new functionality is available in 
HP Web Jetadmin.

CAUTION: After a Feature Pack is applied, it cannot be removed from HP Web Jetadmin. HP recommends that 
you back up HP Web Jetadmin before you apply a Feature Pack.

When a Feature Pack is initially released, the software and online Help for the new features are available only in 
English. The localized software and online Help for the new features will be provided at a later time, either in a 
new Feature Pack or a new version of HP Web Jetadmin.

Import and apply a Feature Pack

CAUTION: After a Feature Pack is applied, it cannot be removed from HP Web Jetadmin. HP recommends that 
you back up HP Web Jetadmin before you apply a Feature Pack.

1. Go to www.hp.com/go/webjetadmin, and then download the HP Web Jetadmin Feature Pack file.

2. Go to Tools > Feature Packs.

3. Click the Import button.

4. On the Open window, browse to and select the HPb file, and then click the Open button.

5. On the Success window, click the OK button. The HPb file is listed on the Feature Packs window with a 
status of Imported (Apply Pending).

-or-

If a Feature Pack has already been imported, but has not been applied yet, HP Web Jetadmin displays the 
Warning window.

To overwrite the existing Feature Pack, click the Yes button.

To cancel the import process, click the No button.

6. Select the Feature Pack from the list, and then click the Apply button.

The status of the selected Feature Pack must be Imported.

7. On the Confirm Feature Pack apply window, click the OK button.

8. On the Success window, click the OK button. The Feature Pack is listed on the Feature Packs window with a 
status of Applied (Service Restart Required).

9. Restart the HP Web Jetadmin service (HPWJAService).
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CAUTION: Restarting the HP Web Jetadmin service can interrupt critical processes. Before you restart the 
HP Web Jetadmin service, use the HP Web Jetadmin Broadcast Message feature to notify the active users, 
and then make sure that all of the users are logged off and that there are no active tasks running on the 
HP Web Jetadmin server.

Delete an imported Feature Pack

1. Go to Tools > Feature Packs.

2. Select the Feature Pack from the list, and then click the Delete button.

The status of the selected Feature Pack must be Imported.

3. On the Delete Feature Pack window, click the OK button.

4. On the Success window, click the OK button.

Display the Release Notes for a Feature Pack

The Release Notes for Feature Packs are provided only in English.

1. Go to Tools > Feature Packs.

2. Select the Feature Pack from the list, and then click the Details button. The Release Notes are displayed in 
Notepad.

Enable FIPS on the HP Web Jetadmin Server
Federal Information Processing Standard (FIPS) can be enabled only after you upgrade to HP Web Jetadmin 10.4 
or later. This topic provides instructions for upgrading HP Web Jetadmin, making the required changes to the 
settings in HP Web Jetadmin, and then enabling FIPS. These instructions must be followed in the order provided.

The MD5 and DES protocols are blocked after FIPS is enabled. Communication over SNMPv1/SNMPv2 is still 
possible after FIPS is enabled.

Upgrade to HP Web Jetadmin 10.4 or later

1. On the HP Web Jetadmin server, go to www.hp.com/go/webjetadmin, and then download the 
HP Web Jetadmin software.

2. Double-click the EXE file.

3. Follow the instructions in the wizard.

4. If the installation stops with a warning that a reboot is required, reboot the HP Web Jetadmin server. 
Launch the installer again to continue the installation.

5. When the installation is complete, click the Finish button.

Make the required changes to the settings in HP Web Jetadmin and on the devices

If you omit the following steps, HP Web Jetadmin might not be able to communicate with the devices after FIPS 
is enabled. HP Web Jetadmin displays a status of Device Communication Error for these devices.

1. If HP Web Jetadmin has already discovered devices by using an SNMPv3 credential that specifies the MD5 
and DES protocols, SNMP communication with those devices will not work after FIPS is enabled. The 
SNMPv3 credential for these devices must be changed to the SHA-1 and AES-128 protocols. However, you 
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cannot use HP Web Jetadmin to determine if the SNMPv3 credential for the devices uses the MD5 and DES 
protocols.

Use the following steps to update the SNMPv3 credential on all of the devices that use SNMPv3:

a. In the Device Management navigation pane, right-click Configuration, and then select Create 
configuration template. The Create Device Configuration Template wizard starts.

b. On the Select Template Models page, select the device models to configure, and then click the right 
arrow button.

c. Select the network cards to configure, and then click the right arrow button.

d. Click the Next button.

e. On the Specify template options page, enter a name for the template in the Name box (up to 48 
characters).

f. In the Device settings navigation pane, go to Security > SNMP Version Access Control.

g. Select the Modify SNMPv3 option.

h. In the Current SNMPv3 Credential section, enter the user name, authentication protocol, 
authentication passphrase, privacy protocol, and privacy passphrase that are currently configured for 
SNMPv3. The current SNMPv3 credentials are required.

i. In the New SNMPv3 Credential section, select SHA-1 from the Authentication Protocol list, and select 
AES-128 from the Privacy Protocol list.

j. If required, enter the new values for the user name, authentication passphrase, and privacy 
passphrase.

CAUTION: To change the authentication and privacy passphrases, the current passphrases must be 
specified in the device configuration template even if global SNMPv3 credentials are stored in 
HP Web Jetadmin. If the current passphrases are not specified, the configuration fails.

k. Click the Next button.

l. On the Confirm page, verify that the information is correct, and then click the Create Template button.

m. On the Results page, click the Done button.

n. In the Device Management navigation pane, right-click Configuration, and then select Apply 
configuration template. The Apply Device Configuration Template wizard starts.

o. Select the device configuration template that you just created from the list, and then click the Next 
button.

p. On the Select devices page, select the devices to configure from the Available devices list, and then 
click the > button.

q. Click the Next button.

r. On the Confirm page, verify that the information is correct, and then click the Apply Template button.

s. On the Results page, click the Done button.

2. Use the following steps to delete the SNMPv3 global credentials that use the MD5 and DES protocols:

a. Go to Tools > Options > Shared > Credentials > Device > SNMPv3.

b. Select the SNMPv3 credential that uses the MD5 and DES protocols from the list, and then click the 
Remove button.
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c. On the Confirm Delete window, click the Yes button.

d. Repeat steps b through c for each SNMPv3 credential that uses the MD5 and DES protocols.

3. Run a discovery to rediscover all of the SNMPv3-configured devices.

4. Trap forwarding that is configured to use SNMPv3 credentials with the MD5 and DES protocols does not 
work after FIPS is enabled. Use one of the following procedures to update the alert subscriptions that are 
configured to forward SNMP traps to a server using SNMPv3 credentials with the SHA-1 and AES-128 
protocols.

NOTE: Alert subscriptions that are configured to only write alerts to the alert history log or to send email 
notifications when alerts occur do not need to be updated.

Update the alert subscriptions that were created by using an alert subscription template that is configured 
to forward SNMP traps

a. In the Device Management navigation pane, go to Alerts > All Subscriptions.

b. At the top of the All Subscriptions pane, click the Expand all button to display the details for each alert 
subscription.

c. To identify the alert subscription templates that must be updated, look for alerts that have SNMPv3 
Trap Forwarding in the Notification Type column and have Linked in the Linked to Template column. 
The name of the alert subscription template is shown in the Subscription Name column.

d. In the Device Management navigation pane, go to Alerts > Templates.

e. In the Alerts - Subscription Templates pane, select the alert subscription template from the list, and 
then click the Edit button. The Edit Subscription Template wizard starts.

f. Click the Next button until the Specify notification settings page appears.

g. In the SNMPv3 credential section, select SHA-1 from the Authentication protocol list, and select 
AES-128 from the Privacy protocol list.

h. If required, enter the new values for the user name, authentication passphrase, and privacy 
passphrase.

i. Click the Next button until the Confirm page appears.

j. On the Confirm page, verify that the information is correct, and then click the Save Template button.

k. On the Results page, click the Done button.

All of the alert subscriptions that are linked to this alert subscription template are automatically 
updated with the new SNMPv3 credentials.

l. Repeat steps c through k for each of the alert subscription templates.

Update the alert subscriptions that were created without using an alert subscription template and are 
configured to forward SNMP traps

a. In the Device Management navigation pane, go to Alerts > All Subscriptions.

b. In the All Subscriptions pane, select the alert subscription from the list, and then click the Edit 
Subscription button. The Edit Subscription wizard starts.

c. Click the Next button until the Specify notification settings page appears.

d. In the SNMPv3 credential section, select SHA-1 from the Authentication protocol list, and select 
AES-128 from the Privacy protocol list.
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e. If required, enter the new values for the user name, authentication passphrase, and privacy 
passphrase.

f. Click the Next button until the Confirm page appears.

g. On the Confirm page, verify that the information is correct, and then click the Edit Subscription button.

h. On the Results page, click the Done button.

i. Repeat steps b through h for each alert subscription that was created without using an alert 
subscription template.

-or-

If any future changes are made to the alert subscriptions, all of the alert subscriptions must be changed. To 
prevent this in the future, HP recommends that you use the following steps to create new alert 
subscriptions that are linked to alert subscription templates:

a. In the Device Management navigation pane, go to Alerts > All Subscriptions.

b. In the All Subscriptions pane, select the alert subscription from the list, and then click the Unsubscribe 
button. The Delete Alert Subscriptions wizard starts.

c. On the Confirm page, click the Unsubscribe button.

d. On the Results page, click the Done button.

e. In the Device Management navigation pane, go to Alerts > Templates.

f. In the Alerts - Subscription Templates pane, select the alert subscription template from the list, and 
then click the Apply button. The Apply Alert Subscription Template wizard starts.

NOTE: If an alert subscription template is not available, create an alert subscription template that 
meets your specific needs.

g. On the Select devices page, select the devices from the Available devices list, and then click the > 
button.

h. Click the Next button.

i. To link the selected alert subscription template to this alert subscription, select the Link template to 
subscription option. Changes that are made to the selected alert subscription template are 
automatically applied to the devices that are associated with this alert subscription.

-or-

To create an alert subscription that is not linked to the selected alert subscription template, select the 
Do NOT link template to subscription option, and then enter a name for this alert subscription in the 
Subscription name box. Changes that are made to the alert subscription template are not applied to 
the devices that were previously configured with this alert subscription template.

j. Click the Next button.

k. On the Confirm page, verify that the information is correct, and then click the Apply Template button.

l. On the Results page, click the Done button.

m. Repeat steps b through l for each of the alert subscriptions that were created without using an alert 
subscription template.

5. On the client machines where the HP Web Jetadmin client is launched, use the following steps to enable 
the TLS protocol:
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a. Open an Internet Explorer browser.

b. Go to Tools > Internet options, and then click the Advanced tab.

c. Scroll down to the Security section, and then select the checkboxes for one or more of the TLS 
versions (TLS 1.0, TLS 1.1, and TLS 1.2).

6. Use the following steps to verify that the devices are configured to communicate with the TLS protocol:

a. Select the device from any device list.

b. On the Config tab, go to Network > Mgmt Protocol.

c. Verify that any version of TLS (TLS 1.0, TLS 1.1, and TLS 1.2) is enabled.

d. Repeat steps a through c for each device.

7. Use the following steps to enable FIPS-140 mode on the devices. Enabling FIPS-140 mode affects only the 
following device configuration options:

● SNMP Version Access Control configuration option: The SHA-1 authentication protocol and AES-128 
privacy protocol must be configured.

● Mgmt Protocol configuration option: The TLS 1.0, TLS 1.1, or TLS 1.2 protocol must be enabled.

TIP: The following steps are not required. However, you can use these steps to troubleshoot any FIPS-
related problems.

a. Select the device from any device list.

b. On the Config tab, go to Security > FIPS-140 Mode.

c. Select the Enabled option.

d. Click the Apply button.

e. Repeat steps a through d for each device.

If any of the following device configuration options are configured on a device, enabling FIPS-140 mode 
fails for that device:

● SNMP Version Access Control configuration option: The MD5 authentication and DES privacy protocols 
must not be specified.

● IPsec/Firewall Policy configuration option: The DES-CBC-MD5 algorithm must not be specified for the 
Kerberos setting.

● Upload Jetdirect Certificate configuration option: Certificates must not be signed by using MD5 or 
earlier (MD2 or MD4).

● Upload CA Certificate configuration option: Certificates must not be signed by using MD5 or earlier 
(MD2 or MD4).

● Mgmt Protocol configuration option: The SSL 3.0 or earlier protocol must not be enabled.

HP Web Jetadmin does not report the exact reason for the failure. However, if you enable FIPS-140 mode 
by using the device HP Embedded Web Server (EWS), the EWS does report the exact reason for the failure. 
The FIPS-140 mode setting is available in the EWS from the Networking tab > Security link > Settings page.

Enable FIPS on the HP Web Jetadmin server

1. Stop the following services. These services must be stopped in the specified order.
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a. HPWSProAdapter

b. HPWJAService

c. mssql$HPWJA

2. Use the following steps to enable FIPS on the HP Web Jetadmin server as a local security policy:

TIP: For more information about the System cryptography setting, see the “System cryptography: Use 
FIPS compliant algorithms for encryption, hashing, and signing" security setting effects in Windows XP and in 
later versions of Windows document. This document is available from the Microsoft support page.

a. Go to Control Panel > Administrative Tools > Local Security Policy > Local Policies > Security Options.

b. Right-click System cryptography: Use FIPS compliant algorithms for encryption, hashing and signing, 
and then select Properties.

c. On the Local Security Setting tab, select the Enabled option, and then click the OK button.

3. Start the following services. These services must be started in the specified order.

a. mssql$HPWJA

b. HPWJAService

c. HPWSProAdapter

4. Use the following steps to verify that HP Web Jetadmin can communicate with all of the devices:

a. In the All Devices list, look for any devices that have Device Communication Error in the Status 
column.

b. Verify that you can configure a device by using HP Web Jetadmin.

c. In the All Devices list, right-click a device, and then select Refresh Selection (Full). Verify that the 
refresh completed.

If there are any devices that have a status of Device Communication Error or you cannot complete step b or 
c, access the device EWS, and then verify the following settings:

● Click the Networking tab, and then click the Network Settings link. If SNMPv3 is enabled, verify that 
the authentication protocol is SHA x and the privacy protocol is AES.

● Click the Security tab, and then click the Certificate Management link. Select a certificate, and then 
click the View Details button. Verify that the self-signed certificate uses a signature algorithm other 
than MD5. Repeat this step for each self-signed certificate.

Uninstall HP Web Jetadmin
When you uninstall HP Web Jetadmin, the Microsoft SQL Server Express Edition instance of the HP Web Jetadmin 
database is also removed. You can restore the HP Web Jetadmin database if you ran the appropriate backup 
procedures and stored the backup files in a secure location.

To uninstall HP Web Jetadmin, perform the following steps:

1. Go to Start > Control Panel > Uninstall a program.

2. Right-click HP Web Jetadmin 10.4, and then select Change. The HP Web Jetadmin 10.4 - InstallShield 
Wizard starts.

3. Click the Next button.
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4. Select the Remove option, and then click the Next button.

5. Follow the instructions in the wizard.

6. Review the MSI <xxxxx>.LOG file, where <xxxxx> is a randomly generated string. The log file is available in 
the following directory:

C:\Users\<username>\AppData\Local\Temp

TIP: You can uninstall HP Web Jetadmin from the command line. For instructions, see the Uninstall 
HP Web Jetadmin from the Command Line white paper. This white paper is available from the HP Web Jetadmin 
support page (in English).

Manage Licenses
There are some features for HP Web Jetadmin that require a license. After you obtain the license for a feature, 
you must install the license to enable the functionality.

To manage the licenses, perform the following steps:

1. Go to Start > All Programs > HP Web Jetadmin 10, and then select HP Web Jetadmin License Manager.

2. To install a license, perform the following steps:

a. Click the Add button.

b. On the Enter License window, enter the license key, and then click the Apply button.

3. To delete a license, select the license from the list, and then click the Remove button.

4. To refresh the list of licenses, click the Refresh button.

5. Click the Exit button.

6. Restart the HP Web Jetadmin service (HPWJA Service).
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A End-User License Agreement

When you download, register, and install HP Web Jetadmin, you must read the End-User License Agreement 
(EULA) and acknowledge that you agree to the terms.

After HP Web Jetadmin is installed, the EULA is available from the online Help. To view the EULA, go to Help > 
About, and then click the View the End-User License Agreement link.
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