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Summary of Updates 

This section provides the update history of this manual and introduces the contents of 
subsequent updates. 

Update History 

This manual is updated for a major product version to maintain consistency with system 
hardware or software versions and to incorporate customer suggestions. 

Manual Version Notes 
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About This Manual 

Release Notes 

The product version that corresponds to the manual is WCDMA NodeB V100R006. 

Organization 

The manual describes routine maintenance of WCDMA NodeB. 

There are fourteen chapters and one appendix in the manual. 

Chapter 1 About This Manual describes general information about this manual.  

Chapter 2 Overview describes the local maintenance terminal (LMT) system and its 
elements. 

Chapter 3 Installing LMT Application describes the installation of LMT software.  

Chapter 4 Getting Started with LMT describes how to log into the NodeB through the 
LMT.  

Chapter 5 Alarm Management describes how to manage the alarms on the NodeB 
though the LMT.  

Chapter 6 Managing Files describes how to upload and browse files.  

Chapter 7 Managing NodeB and Boards describes operations on the NodeB and the 
boards on the NodeB O&M system.  

Chapter 8 Tracing NodeB Iub Interface Signaling describes how to create tracing 
tasks and how to browse traced messages.  

Chapter 9 Monitoring NodeB Performance and State in Real Time describes how 
to monitor the NodeB performance and state in real time.  

Chapter 10 Monitoring External Environment of NodeB describes how to monitor 
the NodeB external environment. 

Chapter 11 141 Test describes the NodeB RF performance tests. 

Chapter 12 Managing NodeB Clock describes routine maintenance of the clock 
management system.  
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Chapter 13 Managing NodeB Cells describes operations of the NodeB cell 
management system.  

Chapter 14 NodeB Software Update and Data Configuration File Transfer 
describes the NodeB software upgrade and data configuration file transfer. 

Appendix A Acronyms and Abbreviations lists all acronyms and abbreviations in 
this manual with their full names. 

Intended Audience 

The manual is intended for the following readers:  

 Maintenance engineers and technicians 

Conventions 

This document uses the following conventions:  

I. General conventions 

Convention Description 

Arial Normal paragraphs are in Arial. 

Arial Narrow Warnings, cautions, notes and tips are in Arial Narrow. 

 

II. Symbols 

Eye-catching symbols are also used in this document to highlight the points worthy of 
special attention during the operation. They are defined as follows: 

  Caution, Warning, Danger: Means reader be extremely careful during the 

operation. 

  Note, Comment, Tip, Knowhow, Thought: Means a complementary description. 
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Chapter 1  About This Manual  

1.1  Purpose of This Manual 

This manual describes 

 Installation of the NodeB local maintenance terminal (LMT) 
 Functions and interfaces of each element in LMT  
 Operation guide to NodeB routine operation and maintenance 

The NodeB routine maintenance is mainly conducted through the iManager M2000 
server. For O&M guide to the M2000 server, see iManager M2000 Mobile Element 
Management System Operation Manual. 

1.2  Intended Audience 

This manual is intended for those who operate and maintain the NodeB on the LMT 
system. They must have basic operation skills of MS Windows operating system and 
understandings of the NodeB.  

1.3  Architecture of This Manual  

There are 14 chapters and an appendix in this manual.  

 Chapter 1: describes general information about this manual.  
 Chapter 2: describes the local maintenance terminal (LMT) system and its 

elements. 
 Chapter 3: describes the installation of LMT software.  
 Chapter 4: describes how to log into the NodeB through the LMT.  
 Chapter 5: describes how to manage the alarms on the NodeB though the LMT.  
 Chapter 6: describes how to upload and browse files.  
 Chapter 7: describes operations on the NodeB and the boards on the NodeB O&M 

system.  
 Chapter 8: describes how to create tracing tasks and how to browse traced 

messages.  
 Chapter 9: describes how to monitor the NodeB performance and state in real 

time.  
 Chapter 10: describes how to monitor the NodeB external environment. 
 Chapter 11: describes the NodeB RF performance tests. 
 Chapter 12: describes routine maintenance of the clock management system.  
 Chapter 13: describes operations of the NodeB cell management system.  
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 Chapter 14: describes the NodeB software upgrade and data configuration file 
transfer.  
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Chapter 2  Overview 

2.1  About This Chapter 

This chapter describes the local maintenance terminal (LMT) system and its elements, 
including: 

 Functions 
 Configuration requirements 
 Compositions 
 Main interfaces 

2.2  Introduction to LMT 

2.2.1  Functions of LMT 

The LMT of the NodeB series provides graphic user interface (GUI) for 

 NodeB test 
 Local maintenance 
 Troubleshooting 

2.2.2  LMT Configuration Requirements  

The computer used to install the LMT software must meet the following requirements: 

 Software  
 Hardware 
 Communications 

I. Hardware Configuration Requirements  

Table 2-1 shows the hardware configuration requirements to be met for the computer 
used to install the LMT software.  

Table 2-1  Hardware configuration list 

Item Quantity Recommended 
configuration 

Minimum 
configuration 

CPU 1 2.4 G 400 M 

RAM 1 512 M 64 M 
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Recommended Minimum Item Quantity configuration configuration 

Hard disk 1 40 G 1 G (the minimum 
available space) 

Display adapter 
resolution -- 1024 x 768 800 x 600 

CD drive 1 -- -- 

Network adapter 1 10&100 M 10&100 M 

Others 1 x 3 Modem, sound card 
and sound box -- 

 

II. Software Configuration Requirements  

Table 2-2 shows the software configuration requirements to be met for the computer 
used to install the LMT software.  

Table 2-2  Software configuration list 

Item Standard configuration 

Operating system Windows 2000 Professional (SP4) or above of English 

Default language of 
operating system Western Europe and United States 

Web browser Microsoft Internet Explorer 5.5 or above 

 

  Note:  

It is recommended that the LMT software be installed in a standard operating system. 
Otherwise, they might not be compatible. 

 

III. Communications Requirements  

The computer supports the TCP/IP protocol.  

2.3  LMT System Composition  

2.3.1  Overview  

The LMT communicates with the NodeB through LAN or WAN. You can maintain a 
NodeB through the LMT computer. 
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The NodeB LMT consists of 

 NodeB O&M system 
 NodeB alarm management system 
 TraceViewer 

2.3.2  NodeB O&M System 

I. Functions 

The O&M system provides MML client and GUI access to maintain NodeB, including: 

 Operating MML client: runs a single command on the platform of the MML Client. 
 Tracing management: manages the tracing messages of Iub interface.  
 Software management: downloads and backs up configuration files, and upgrades 

software. 
 Realtime state monitoring: including CPU/DSP occupancy, board or cell service 

resource query, RTWP measurement, and clock test. 
 Test management: supports 141 tests. 
 Equipment maintenance: controls board reset and block/unblock, and helps 

retrieve board data. 
 Clock maintenance: provides routine maintenance for the NodeB timing. 
 Cell management: retrieves and modifies NodeB cells data, and blocks or 

unblocks NodeB cells. 

II. Interface  

The interface of the NodeB O&M system consists of: 

 System menu  
 Toolbar  
 Navigation tree pane  
 Object pane  
 Output pane  
 Status bar  
 MML client  

Figure 2-1 shows the NodeB O&M System window. 
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Figure 2-1 NodeB O&M System window 

Table 2-3 describes the fields of the NodeB O&M System window. 

Table 2-3  Filed description of O&M System window 

No. Field  Description 

1 Menu bar 

The menu bar includes System, Service, View, Window and 
Help menus. 

The System and Service menus provide access to logging 
into the operating system. 

The View, Window and Help menus are similar to those in 
other commonly used application programs.  

2 Toolbar 

The toolbar provides shortcut icons including: 

 Re-login 
 Exit 
 Lock System 
 Office Management 
 Show/Hide other window 
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No. Field  Description 

3 
Navigatio
n tree 
pane 

There are three tabs at the bottom of the pane, including: 

 Maintenance Navigator: The navigator provides 
important routine operations through a GUI interface. 

 MML Navigator: The navigator provides all MML 
commands. 

 Search. In this tab, you can retrieve MML commands by 
command name or by command word. The system lists all 
the commands matching your input automatically to make 
the retrieval faster. 

4 Object 
pane 

This pane provides details about the object. You can maintain 
the NodeB through this pane. 

If you select Maintenance Navigator in the navigation tree 
pane, the pane contains an upper curve graph and a lower list 
of description. 

If you select MML Navigator, the pane contains the MML 
Client. 

5 Output 
pane 

The pane records detailed information of current operations 
and system feedback. At the bottom of the pane, there are four 
tabs as follows: 

 Maintenance Output: It displays results of operations and 
auto reported information. 

 Debug Output: It displays the contents in Maintenance 
Output in binary. 

 Test Output: It displays the result of 141 test. 
 Alarm output: It displays alarms reported by the NodeB. 

6 Status 
bar 

The bar is at the bottom of the interface. It displays  

 Connected office 
 IP address of the office 
 Connection status 

 

III. Online Help  

The NodeB O&M system provides two kinds of online help: 

 NodeB O&M system help 
 MML help 

Table 2-4 shows the main contents and starting modes of these helps.  
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Table 2-4 Online helps of NodeB O&M system  

Name  Main contents Starting mode 

NodeB O&M 
system help 

It provides the following 
information about the NodeB 
O&M system:  

 Field meaning of the dialog 
box 

 Description of and operation 
guide to each O&M function

 Detailed information about 
the board 

There are three starting modes 
in the NodeB O&M window,  

 Press F1 or select Help -> 
Help topics to display the 
NodeB O&M System Help 
window.  

 Click  to display the 
help information. 

 Click Help in a dialog box to 
show the help information. 

MML help  

It provides the following 
information about each MML 
command:  

 Function  
 Note 
 Parameter 
 Example 

1) Execute a command in the 
MML client of the NodeB 
O&M system. 

2) The Help window displays 
information about this 
command. 

 

  Note:  

This manual does not present detailed description of the MML commands involved. For 
more information about the MML commands, see MML Command Help. 

 

2.3.3  NodeB Alarm Management System 

I. Functions 

The NodeB alarm management system serves as a major tool for routine alarm 
management. With this system, you can:  

 Browse alarm information, including fault alarm information and event alarm 
information. 

 Query alarm information, including active alarms, alarm log, alarm configuration, 
and alarm details.  

 Maintain alarm information by modifying or restoring alarm configuration. 
 Set attributes of fault alarm notification, including sound duration, fixed-line phone 

number and mobile phone number. 
 Print and save alarm records, including browsed and reported alarm records. 

For details, see Chapter 5 “Alarm Management”.  
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II. Interface  

The interface of the NodeB alarm management system consists of  

 System menu 
 Toolbar 
 Fault alarm browse window 
 Event alarm browse window 
 Status bar  

Figure 2-2 shows the BTS3812E Alarm Management System window. 

 

Figure 2-2  BTS3812E Alarm Management System window 

Table 2-5 describes the elements of the BTS3812E Alarm Management System 
window. 

Table 2-5  Elements of BTS3812E Alarm Management System window 

No. Field  Description 

1 Menu bar The menu bar provides access to most operations of the 
system.  
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No. Field  Description 

2 Toolbar 

The toolbar provides shortcut icons for common 
operations, including 

 Relogin 
 Office Management 
 Toggle Lock System 
 Display Color Setting 
 Fault Alarm Browse 
 Event Alarm Browse 
 Query Alarm Log  

3 Fault alarm 
browse window The window displays the current fault alarm.  

4 Event alarm 
browse window The window displays the current event alarm. 

5 Status bar 

The bar is at the bottom of the interface.  

It displays 

 IP address of the connected office 
 Connection status 
 Messages between the system and the NodeB 

 

III. Online Help  

Table 2-6 shows the main contents and starting modes of the NodeB Alarm 
Management System Help.  

Table 2-6 Online help of NodeB alarm management system  

Name  Main contents Starting mode 

NodeB alarm 
management 
system help 

It provides the following 
information about the 
NodeB alarm 
management system: 

 Field meaning of the 
dialog box  

 Description of and 
operation guide to 
each alarm 
management function 

In the NodeB alarm management 
system window,  

 Press F1 or select Help -> Help 
topics to display the NodeB Alarm 
Management System Help.  

 Click  to display the NodeB 
Alarm Management System Help. 

 Click Help in a dialog box to display 
the help information.  
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2.3.4  TraceViewer 

I. Function  

The TraceViewer simulates the online environment and opens saved message files in 
the offline environment. It facilitates the browse of traced messages. 

For details, see Chapter 8 “Viewing Traced Messages Offline”.  

II. Interface  

Figure 2-3 shows the BTS3812E TraceViewer window. 

 

Figure 2-3  BTS3812E TraceViewer window  

Table 2-7 describes elements of the BTS3812E TraceViewer window.  

Table 2-7  Elements of BTS3812E TraceViewer window  

No. Field  Description 

1  Menu bar Providing most of the functions of the TraceViewer.  

2  Toolbar Providing the Open shortcut icon. 
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3  Message 
browse pane Displaying messages by tracing the Iub interface.  

4  Status bar 

Located at the bottom of the window, displaying 

 Connected office 
 IP address of the office 
 Network status 

 

III. Online Help  

Table 2-8 shows the main contents and starting mode of the NodeB TraceViewer 
Help.  

Table 2-8  Online help of the NodeB TraceViewer  

Name  Main contents Starting mode 

NodeB 
TraceViewer 
help  

It describes the usage of 
each message browse 
function of the NodeB 
TraceViewer. 

In the TraceViewer window,  

 Press F1 or select Help -> Help 
topics to display the NodeB 
TraceViewer Help.  

  Click Help in a dialog box to 
display the help info-rmation.  
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Chapter 3  Installing LMT Application 

3.1  About This Chapter 

This chapter describes  

 Software installation preparation 
 Installation process 
 Confirmation after installation. 

3.2  Installation Introduction 

3.2.1  Preparing for Installation 

Prepare as follows before installing the LMT software:  

 Obtain the installation disk and instruction provided by Huawei. 
 Obtain valid serial number of the LMT software. 
 Log into the MS Windows 2000 or MS Windows XP operating system with the 

administrator authority. 

3.2.2  Impact on System  

Installing the LMT software shall have the following impact on the system:  

 Creating a shortcut on the desktop 
 Creating a program group of Start -> Program -> Huawei Local Maintenance 

Terminal. The Huawei Local Maintenance Terminal menu includes 
sub-menus of  

 NodeB Operation & Maintenance System 
 Uninstall NodeB Operation & Maintenance System 

 Copying NodeB LMT V1.5 to the selected directory of NodeBV100R005ENG 

3.3  Installing LMT Software  

Follow the steps below to install the NodeB LMT software. 
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  Note:  

To install the LMT software, there are three modes:  
 Initial installation of LMT software 
 Modify installation of LMT software 
 Repair installation of LMT software 

This manual adopts the initial installation mode to introduce the LMT software 
installation.  

 

I. Starting Installation Program 

Follow the steps below to start the installation program: 

1) Insert the installation disk into the disk drive. 
2) The installation program automatically runs. 

Or you may follow the steps below: 

1) Copy the installation software package into the hard disk. 
2) Open the file folder of disk1. 
3) Double-click Setup.exe. 

Then the installation program is started.  

II. Choosing Setup Language  

Follow the steps below to choose the setup language: 

1) Start the installation program.  
The Choose Setup Language dialog box opens up as shown in Figure 3-1.  

 

Figure 3-1 Choose Setup Language dialog box  

2) Choose English in the list box and click OK.  
3) Click Next in the Welcome dialog box after the installation program initialization 

completed. 

Figure 3-2 shows the Welcome dialog box.   
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Figure 3-2  Welcome dialog box 

  Note:  

 Click Cancel to display the quit installation interface. You may choose whether to 
quit or continue the installation.  

 Back is not available in the first installation step. In later steps, Back is available to 
go back to the previous step.  

 

III. Confirming License Agreement  

To accept this agreement after reading it, click Yes. Otherwise, click No to quit the 
installation program.  

Figure 3-3 shows the License Agreement dialog box.  
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Figure 3-3 License Agreement dialog box 

IV. LMT Software Installation Guide 

Read the installation guide in the Information dialog box carefully and click Next.  

Figure 3-4 shows the Information dialog box.  
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Figure 3-4  Information dialog box  

V. Verifying Serial Number  

Enter the customer information and valid serial number in the Customer Information 
dialog box, and then click Next.  

Figure 3-5 shows the Customer Information dialog box.  
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Figure 3-5  Customer Information dialog box 

  Note:  

 The serial number is provided with the installation disk and contained in the 
Serial. txt file of the software package.  

 Next is available only after you enter the user name, company name and serial 
number.  

 Enter the valid serial number. Note that the serial number is case sensitive.  
 If the serial number is invalid for three times, the installation program shall 

automatically quit from the present installation program.  

 

VI. Choosing Destination Location  

Click Browse to select the folder where Setup will install files. Or click Next to install 
files under C:\HWLMT by default.  

Figure 3-6 shows the Choose Destination Location dialog box.  
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Figure 3-6  Choose Destination Location dialog box  

VII.  Selecting Setup Type  

Figure 3-7 shows the Setup Type dialog box.  
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Figure 3-7 Setup Type dialog box  

There are three setup types:  

 Typical: The program installs all the components to maintain all the NodeB 
models and versions supported by the LMT software. Most users are 
recommended to install the software with this type.  

 Compact: The program installs part of the components only to maintain the latest 
version of the NodeB supported by the LMT software of that model.  

 Custom: the program installs the selected components. It is recommended for 
advanced users.  

Select the needed setup type and then click Next. It is recommended for most users 
to select Typical.  

If you select Custom,  

1) Click Next.  
2) Tick the needed components in Select Components dialog box as shown in 

Figure 3-8. 
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Figure 3-8 Select Components dialog box 

3) Click Next in the Select Components dialog box.  

VIII. Selecting Program Folder  

Figure 3-9 shows the Select Program Folder dialog box.  
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Figure 3-9 Select Program Folder dialog box 

You can rename the program folder or use the default name. It is recommended that 
you use the default program folder name and click Next.  

IX. Copying Files  

Figure 3-10 shows the Start Copying Files dialog box.  
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Figure 3-10 Start Copying Files dialog box  

Confirm all the information. Then Click Next to create a folder C:\HWLMT and copy 
files into it.  

When copying files, a progress indicator indicates the setup progress, file types and 
file setup path as shown in Figure 3-11. 
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Figure 3-11 Setup Status dialog box  

X. Finishing Installation  

Figure 3-12 shows the Installation Completed dialog box.  
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Figure 3-12 Installation Completed dialog box 

Follow the steps below to finish the installation of the LMT software, update the 
system setup, open the readme.txt, and start O&M system for login interface:  

1) Tick Start readme.txt and Start Operation_Maintenance System. 
2) Click Finish.  

If you click Finish without ticking Start readme.txt and Start 
Operation_Maintenance System, you can finish the LMT software installation and 
update the system setup.  

 

  Note: 

If the system finds locked files or files under share during the installation, an 
InstallShield Wizard Complete dialog box shall prompt you to restart the computer, 
as shown in Figure 3-13. If so, choose Yes, I want to restart my computer now. and 
click Finish.  
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Figure 3-13 InstallShield Wizard Complete dialog box 

3.4  Verifying Installation  

After the LMT software installation, the program copies the WCDMA NodeB LMT 
programs into the file folder under the selected path. If you use the default installation 
directory, the entire file package of LMT software is copied to C:\Hwlmt.  

Figure 3-14 shows the directory architecture of the LMT software.  

 

Figure 3-14 Directory architecture of the LMT software 
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Table 3-1 describes the directory at different levels.  

Table 3-1 Description of the directory at different levels 

Directory  Description  

Bin Storing public files, such as *.dll files which assist operation 
control. 

BBU3806V100R
005C01B030… 

 

BTS3812AV100
R005C01B065… 

 

BTS3812EV100
R006C01B013… 

Storing files related to this NodeB version. Each folder has the 
same architecture including the following sub-folders:  

bin: storing execution files related to this version  

wh_mes: storing interface tracing resolution files related to this 
version 

data: storing data files related to this version 

Map: storing .map files related to this version for the purpose to 
find problems in case of exceptional conditions  

OnLineHelp: storing online help files related to version  

Data Storing data files unrelated to this version 

Map Storing *.map files to locate problems in case of exceptional 
conditions  

OnLineHelp Storing online help files unrelated to this version 

 

  Note:  

When you use the LMT software, the system creates new file folders under NodeB 
V100R005:  

 Output: default folder for file output  
 Trace: to save traced files 
 Log: to save LMTFrame.log files and LMTFTool.log files 
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Chapter 4  Getting Started with LMT 

4.1  About This Chapter 

This chapter describes how to login to the NodeB through the LMT, including 

 Starting LMT 
 Configuring LMT 
 Managing Office 
 Locking LMT 
 Executing MML Commands 
 Exiting LMT 

4.2  Starting LMT 

4.2.1  Overview 

Before starting the LMT, complete the following operations: 

 Set IP address of the LMT computer  
 Connect the LMT computer to the NodeB  

4.2.2  Setting IP Address for LMT Computer 

I. Introduction 

  Caution:  

Make sure the IP address of the LMT compter does not confict with another IP 
address of a computer within the same local area network.  

 

You have two ways to maintain the NodeB on the LMT:  

 Local maintenance  
 Remote maintenance  

When you conduct the local maintenance, set the IP address for the LMT computer as 
follows:  
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 For the macro NodeB, IP addresses of the LMT computer and the NMPT 
network port need to be in the same network segment.  

 For the DBS3800, IP addresses of the LMT computer and the BBU need to be in 
the same network segment. 

II. Prerequisite  

The LMT computer has configured the TCP/IP protocol.   

III. Procedure 

  Note: 

Microsoft® Windows 2000 (SP4) is the product of Microsoft. For details, refer to the 
technical documents of Microsoft® Windows 2000 (SP4). 
All the Microsoft-related corporate names, trademarks and technical documents are 
properties of Microsoft Corporation. 

 

Follow the steps below to set the IP address of the LMT computer with the MS 
Windows 2000 (SP4) operating system as an example:  

1) Choose Start -> Settings -> Control Panel.   
The Network and Dial-up Connection window opens up.  

2) Right-click the icon of Local Area Connection.  
The Local Area Connection Status dialog box opens up.   

3) Select Properties on the shortcut menu.  
The Local Area Connection Properties dialog box opens up.  

4) Select Internet Protocol (TCP/IP).  
5) Click Properties.  

The Internet Protocol (TCP/IP) Properties dialog box open up. 
6) Select Use the following IP address. 
7) Enter the correct IP address, subnet mask and default gateway.  

 

  Note:  

 In near end O&M mode, the default IP address of all debugging Ethernet ports of 
the NodeB for local maintenance is 17.21.2.15. 

 The subnet mask is 255.255.0.0.  
 If there is no gateway, you can keep the field Default Gateway blank or enter the 

IP address of the LMT. If there is a gateway, enter the IP address of the gateway. 

 

8) Click OK. 
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The setting is completed.  

4.2.3  Connecting LMT Computer to NodeB  

I. Introduction  

There are two ways to maintain the NodeB through the LMT. Correspondingly, there 
are two ways to connect the LMT computer to the NodeB.  

II. Prerequisite 

None.  

III. Procedure  

Under the local maintenance mode: 

 For the macro NodeB, connect the Ethernet port of the LMT computer to that of 
the NodeB NMPT through crossover network cables, as shown in Figure 4-1. Or 
you can connect the LMT computer to the NodeB NMPT through a HUB by using 
straight-thru cables.  

 For the DBS3800, connect the Ethernet port of the LMT computer to the upper 
ETH port of the BBU front plate with crossover network cables, as shown in 
Figure 4-2. Or you can connect the LMT computer to the BBU through a HUB by 
using straight-thru cables.  

(2)

(3)

(1)

 
(1) NMPT (2) Network cable (3) LMT computer 

Figure 4-1 Connecting LMT computer and NMPT under local maintenance mode  
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(1) BBU3806 (2) Crossover cable  (3) LMT computer 

Figure 4-2 Connecting LMT computer and BBU3806 under local maintenance mode 

Under the remote maintenance mode:  

 You can connect the Ethernet port of the LMT computer to that of the back 
administration module (BAM) on the RNC directly.  

 You can connect the Ethernet port of the LMT computer to that of the RNC BAM 
through a gateway. 

 No matter how the LMT computer and the NodeB are connected, you can check 
the connection with a ping command.  

4.2.4  Logging into NodeB Through LMT 

I. Introduction 

You may operate and maintain a NodeB by starting the LMT and logging into the 
NodeB.  

II. Prerequisite 

Physical connection between the LMT computer and the NodeB is good under the 
local maintenance mode.  

III. Porcedure  

Follow the steps below to login to the NodeB through the LMT:  

1) Choose Start -> Program -> Huawei Local Maintenance Terminal -> NodeB 
V100R005 -> NodeB Operation & Maintenance System.  
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If the NodeB O&M system has started, select System -> Login, or click the 

shortcut icon  to display the Login dialog box as shown in Figure 4-3. 

 

Figure 4-3 Login dialog box 

Table 4-1 describes the fields in the Login dialog box.  

Table 4-1 Field description of Login dialog box 

Field  Description  

User name It is the name used to log into NodeB. It is case sensitive and 
cannot be omitted. The default name is admin. 

Password  
It is used to log in to NodeB. It starts with letter, and is case 
sensitive. It is a string of up to 16 characters and contains only 
letters and numbers.  

Office  
It is the name of the NodeB to which the O&M system is connected. 

 Click Office Management to edit the office information. For 
details, see 4.4   “Managing Office”.  

IP address  This is the IP address of NodeB to which the LMT system is 
connected. It is unique to the office name. 

 

  Note:  

If there is no office in the Office Management dialog box as shown in Figure 4-5, set 
the parameters in the dialog box with reference to 4.4   "Managing Office". 
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2) Set parameters in the Office Management dialog box. 
3) Set the user information and IP address in the Login dialog box.  
4) Click OK. 

Then you log into the NodeB.  

4.2.5  Logging into NodeB Through M2000 Server  

I. Introduction  

You may conduct centralized maintenance to NodeBs by logging into the M2000 
server.  

II. Prerequisites  

None. 

III. Procedure 

Follow the steps below to log into the NodeB through the M2000 server:  

1) Choose Start -> Program -> Huawei Local Maintenance Terminal -> NodeB 
V100R005 -> NodeB Operation & Maintenance System.  
If the NodeB O&M system has started, select System -> Login, or click the 

shortcut icon  to display the Login dialog box as shown in Figure 4-3.  
2) Set IP address, user name, and password in the Login dialog box. 

This enables you to log into the M2000 server.  
3) Click OK. 

The NodeB List dialog box opens up.  
4) Select the NodeB to be maintained in the dialog box.  
5) Click OK and enter your user name and password. 

Then you log into the NodeB.  

4.3  Configuring LMT 

4.3.1  Configuring LMT Attributes 

I. Introduction 

Configurations of the LMT attributes include:  

 Setting the office 
 Setting the time-out time of MML commands 
 Setting the system lock time  
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 Executing batch commands  

II. Prerequisites 

None.  

III. Procedure 

Table 4-2 shows configurations of the LMT attributes.  

Table 4-2 Configurations of the LMT attributes 

LMT attribute Menu Remarks  

Office management  System -> Office 
Management  

See 4.4   “Managing 
Office”.  

Setting time-out time 
of MML commands 

System -> System 
Configuration  

See 4.6.3   "Executing 
Batch MML Commands"

Setting system lock 
time  

System -> System 
Configuration See 4.5   "Locking LMT" 

Executing batch 
MML  commands  

System -> Execute Batch 
Commands 

See 4.6.3   "Executing 
Batch MML Commands"

 

4.3.2  Changing Login Password  

I. Introduction  

Changing the login password refers to changing the password for logging into the 
NodeB. You can log into the NodeB only when you provide the correct password.  

II. Prerequisite 

None.  
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III. Procedure  

  Caution:  

 New password takes effects for new users to log into the NodeB. If you have 
logged in to the NodeB, it does not affect your current state.  

 The M2000 server user and the NodeB O&M user have the authority to change the 
login password. The NodeB alarm management user has no authority to change 
the login password.  

 

Follow the steps below to modify the login password:  

1) Choose System -> Change Password.  
The Change Password dialog box opens up, as shown in Figure 4-4.  

 

Figure 4-4 Change Password dialog box 

2) Enter the old and new passwords in the dialog box. 
3) Click OK. 

Then the password is changed. 

4.4  Managing Office 

I. Introduction 

Managing office refers to setting IP address of the M2000 server or NodeB that the 
LMT connects.  

Generally, one office uses one name to identify different IP addresses. A NodeB O&M 
system may have different office information to connect to a specified M2000 server 
or NodeB.  
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II. Prerequisites 

None. 

III. Procedure 

Follow the steps below to manage the office:  

1) Choose System -> Office Management, or click the shortcut icon .  
The Office Management dialog box opens up, as shown in Figure 4-5. 

 

Figure 4-5 Office Management dialog box 

Table 4-3 describes the fields in the Office Management dialog box.  

Table 4-3  Field description of the Office Management dialog box 

Filed  Description  

Office  
It is the name of M2000 server or the NodeB to which the NodeB 
O&M system connects. It is a string of up to 80 characters or 40 
Chinese characters defined by you.  

IP address  It is the M2000/NodeB IP address. It is unique to the “office”.  

Add  You can add other M2000 server or NodeB office information by 
clicking Add to display the Office Information dialog box. 

Delete  You can delete an office by selecting that office and click Delete.  

Modify  You can modify office information by selecting an office and clicking 
Modify.  

 

2) Set the office information in the dialog box.  
3) Click OK.  

The setting is completed.  
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4.5  Locking LMT  

I. Introduction  

The NodeB O&M system provides lock function to ensure its safe operation. You can 
set system lock when you do not use the system so as to prevent illegal operation 
from others. Once the system is locked, you need to enter the correct password 
before further operation.  

The NodeB O&M system has two lock modes:  

 Lock by schedule  
 Lock Now 

  Note:  

The lock function locks the interface of the NodeB O&M system only. It is similar to the 
screen saver of the MS Windows operating system.  

 

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to conduct Lock Now of the NodeB O&M system:  

1) In the NodeB O&M system, to lock the system interface immediately, there are 
three ways:  

 Choose System -> System Lock 
 Press the shortcut key F12 

 Click the shortcut icon .  

Then the Please Input Your Password dialog box opens up after the system is 
locked. 

2) Enter your password and click OK to remove the lock.  

Follow the steps below to conduct Lock by schedule of the NodeB O&M system:  

3) Choose System -> System Configuration.  
The System Configuration dialog box opens up as shown in Figure 4-6.  
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Figure 4-6 System Configuration dialog box 

Table 4-4 describes the fields in the System Configuration dialog box.  

Table 4-4 Field description of System Configuration dialog box  

Field  Description  

Command 
timeout  

It is the name used to set command time-out time. The value 
range is from 10 seconds to 600 seconds and the default value is 
65 seconds. The command fails to execute when it exceeds the 
time-out limitation.  

Set lock time  

It is the name used to set the system lock time. The value range is 
from 0 to 100 minutes and the default value is 5 minutes. 0 is not 
to lock the time. After you set the system lock time and have no 
operation within that period, the system auto locks till you type in 
the correct password.  

FTP Server  

The FTP server is used to transfer the software package and data 
files to the NodeB.  

You can set the user name and password of the FTP server built 
in the LMT computer. The system has initial default values for 
use. You need not to change them.  

The user name and password are both a string of up to 16 
characters including letters, numbers and underlines.  

 

4) Set the lock time in Set lock time of the dialog box.  
5) Click OK. 

The setting is completed.  
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4.6  Executing MML Commands  

4.6.1  Introduction to MML Commands  

I. Functions of MML Commands  

The NodeB MML command helps to maintain the entire NodeB. The functions are:  

 System management 
 Equipment maintenance  
 Iub Interface management 
 Local cell management 
 Alarm management 

II. MML Command Format  

All MML commands are in the format of Command: Parameter Name=Value;. 

The command is mandatory while the parameter name and value are not. 

 An example of an MML command with a command and parameters: SET 
ALMSHLD: AID=10015, SHLDFLG=UNSHIELDED; 

 An example of an MML command with a command only: LST VER:; 

III. MML Command Parameter  

The MML client distinguishes parameters of different attributes by different colors. For 
details, see Table 4-5.  

Table 4-5 Colors for different parameter attributes 

Color of 
parameter 

name  
Meaning Details  

Red Mandatory You must set the red parameters. Otherwise, the 
system returns failure. 

For commands starting with LST and DSP, if you fail to 
set an optional parameter, the system returns all the 
data. 

For commands starting with ADD, if you fail to set an 
optional parameter, the system takes its default value if 
any or takes it as null. 

Black Optional 

For commands starting with MOD and SET, if you fail to 
set an optional parameter, the parameter value 
remains unchanged. 
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IV. MML Command Types  

The MML command format is Action + Object. For details, see Table 4-6.  

Table 4-6 MML command types  

Action Meaning 

ACT To activate 

ADD To add 

BKP To back up 

BLK To block 

DLD To download 

DSP To display dynamic information 

SET To set 

LST To list static data  

MOD To modify 

RMV To remove 

RST To reset 

STR To start 

STP To stop  

UBL To unblock 

ULD To upload  

 

4.6.2  Executing a Single MML Command  

I. Introduction  

Troubleshooting requires executing a single MML command. 

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to execute a single MML command:  

1) Click MML Command Navigation Tree in the navigation tree pane.  
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2) Select an MML command and double click on it to start the MML Client. The 
command is shown in the Command Input box and the parameter input area is 
displayed. 

  

  Note: 

If you start the MML Client by selecting View -> Command Window on the menu of 

the O&M system, or by clicking the shortcut icon , there is no MML command in 
the Command Input field. You need to enter a command manually, and then click 

 to display the parameter input area. 

 

3) Set the parameters.  

 

  Note:  

For deails, see the Online Help page.  

 

4) Click the icon  to execute the command. View the results in Common 

Maintenance page.  

4.6.3  Executing Batch MML Commands  

I. Introduction  

Executing batch MML commands refers to compiling a series of commands into a 
batch file and then run the file to perform a function or an operation.  

There are two modes to execute batch MML commands: 

 Execute batch MML commands by schedule  
 Execute batch MML commands now  

II. Prerequisites  

 Batch MML command files have already been created. 

The batch file (also referred to as the data script file) is a plain text file (*.txt). It stores 
a group of commands that can perform a common function or a specific task in a *.txt 
file. Therefore, you can simply run the file instead of entering the commands one by 
one. 
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There are three ways to create batch MML command files:  

 Create a *.txt file and write the commands into the file. Be sure to write one 
command in a line. 

 Copy the information in History Command drop-down box in the output pane 
and save it in a blank *.txt file.  

 Choose System -> Save Command -> Start Save Input Command… to save 
the used commands.  

III. Procedure  

Follow the steps below to execute the batch MML command by schedule:  

1) Choose System -> Execute Batch Commands, or press Ctrl+R.  
The Execute Batch Commands dialog box opens up, as shown in Figure 4-7. 

  

Figure 4-7 Execute Batch Commands dialog box 

Table 4-7 describes the fields of the Execute Batch Commands dialog box.  
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Table 4-7 Field description of the Execute Batch Commands dialog box  

Field  Description  

Select Batch 
Command 
File  

To specify the batch file to run 

The default file directory is Bin under the installation directory. Note 
that the file must be a *.txt file edited by following correct MML 
command syntax with one MML command in a line.  

Set Execution 
Mode  

To select the execution mode Execute now or Execute by 
schedule for batch processing 

If you select Execute by schedule, you will have to set the 
specified Date and Time.  

If you select Execute now, you may also select User interface. 

File Executed 
by Schedule  

It lists the information of all the files and their Scheduled Time set in 
the Execute by schedule mode.  

Add  
You can click Add to add a batch file to the File Executed by 
Schedule list, after selecting the batch file and setting the time to 
run it. 

Delete  You can select a scheduled task from the File Executed by 
Schedule list and click Delete to delete it. 

 

2) Select Execute by schedule under Set Execution Mode. 
3) Set the execution date and time in Date and Time under the Execute by 

schedule mode.  
4) Click Browse to select the batch file. 
5) Click Add to add the batch file into the File Executed by Schedule list. 
6) Repeat steps 3) to 5) to add all the needed batch files into the list. 
7) Click OK. 

The setting is completed and the Maintenance Output tab in the window displays the 
results.  

Follow the steps below to execute the batch MML commands now:  

1) Choose System -> Execute Batch Commands, or press Ctrl+R.  
The Execute Batch Commands dialog box opens up, as shown in Figure 4-7.  

2) Click Browse to select the batch file. 
3) Select Execute now and User interfere under Set Execution Mode. 
4) Click OK. 

The Execute now dialog box opens up, as shown in Figure 4-8. 
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Figure 4-8 Execute now dialog box 

Table 4-8 describes the fields of the Execute now dialog box.  

Table 4-8 Field description of the Execute now dialog box  

Field  Description  

Run All  

The system runs in turn all the commands in the batch command file.

Method: Select Run All and then click Run. 

Note: During the process, the icon  points to the command being 
executed. 

Step Run 

The system runs one command in the batch command file at a time. 

Method: Select Step Run and then click Run. 

Note: During the process, the icon  points to the command being 
executed. You can click Stop to stop the running. 

Breakpoint 
Run 

The system runs the commands in the batch command file in turn until 
a breakpoint.  

Method: Select Breakpoint Run. Click on a command and click 
Breakpoint to set a breakpoint. Click Run to start running from the 
beginning. Click Stop to stop running during the process. 

The icon  points to the command being executed.  

The icon points to the specified breakpoint. 
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Run Range 
To specify a range in the batch file to run 

Method: Select Run Range, enter the start row and end row, and then 
click Run. 

 

  Note:  

If you select Execute now without selecting User interfere and click OK, the system 
will run the file immediately without displaying the Execute now dialog box. The 
process is the same as Execute by schedule. 

 

5) Set the information as needed and execute the command.  

The Maintenance Output tab in the window displays the results. 

 

  Note:  

 When running the batch file, you cannot modify the MML commands in the file. 
 When running the batch file, the Maintenance Output tab does not display results. 

When execution of batch MML commands is stopped, Maintenance Output tab 
and History Command drop-down box are empty. 

 

4.7  Exiting LMT 

I. Introduction  

If you exit the LMT, you will disconnect the LMT to the NodeB and M2000 server (if 
you log into the NodeB through the M2000 server), and close the Node O&M system.  

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to exit the LMT system:  

1) Choose System -> Exit, or click the shortcut icon . 

The Sure to exit the system? dialog box opens up.  
2) Click OK. 
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Then you exit the LMT.  
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Chapter 5  Alarm Management 

5.1  About This Chapter 

This chapter describes how to manage the alarms on the NodeB though the LMT. 

5.2  Overview 

5.2.1  Alarm Types  

I. Fault Alarm and Event Alarm 

Alarms can be classified into fault alarms and event alarms by nature. 

 Fault alarm: refers to the alarm generated in case of hardware equipment fault or 
major function failure. When the fault is removed, the system reports a cleared 
alarm. One cleared alarm corresponds to one fault alarm. The severity of a fault 
alarm is higher than that of an event alarm in most cases.  

 Event alarm: refers to the accidental alarm indicating that the system is in alarm 
state for a while. There is no cleared alarm for the event alarm. Some event 
alarms are generated periodically. 

II. Active Alarm and Recovery Alarm 

When there are alarms, the alarms can be classified into active alarms and recovery 
alarms according to the alarm state. 

 If an alarm has recovered, the alarm is in a “recovery” state and is called 
“recovery alarm”. 

 If an alarm has not recovered, the alarm is in an “active” state and is call “active 
alarm”.  

For example, when a fault occurs in the interior hardware of a tower mounted amplifier 
(TMA), the system will report a TMA fault alarm.  

 Before the fault in the interior hardware of the TMA is cleared, the alarm is an 
active alarm. 

 After the fault in the interior hardware of the TMA is cleared, the alarm is a 
recovery alarm. 
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  Note: 

A recovery alarm indicates the alarm has recovered. The alarm records are still stored 
in the alarm log and can be queried. See 5.4.4   “Querying Alarm Log”.  

5.2.2  Alarm Log 

The alarm log keeps all the alarm records. You can obtain NodeB alarm information or 
collect alarm statistics by querying the alarm log.  

5.2.3  Alarm Severity 

The alarm severity shows the level of urgency and severity of an alarm. 

The alarm severities of fault alarms and event alarms in descending order are as 
follows: 

 Critical alarm  
 Major alarm  
 Minor alarm  
 Warning  

Table 5-1 describes definitions and handling of alarms at different severities.  

Table 5-1 Definitions and handling of alarms at different severities 

Alarm 
severity  Definition  Handling  

Critical 
alarm 

The critical alarm has an impact on the service 
provided by the system and needs timely 
handling even when it occurs in after-work time. 
For example, a device or resource is not 
available.  

It requires timely 
handling. 
Otherwise, the 
system may 
collapse.  

Major 
alarm  

The major alarm affects the quality of service 
(QoS) and needs resolving within work time to 
avoid impact on some major functions. For 
example, the QoS of a device or resource is 
impaired and needs recovery.  

It requires timely 
handling. 
Otherwise, some 
major functions may 
be affected.  

Minor 
alarm  

The minor alarm does not affect QoS. It needs 
handling at a proper time against potential faults. 

The purpose of this 
alarm is to remind 
maintenance 
technicians of alarm 
reasons and 
eliminate potential 
faults.  

Warning The warning shows a potential error that may 
affect service and needs handling in some cases. 

It requires 
understanding of 
the system running 
state.  
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5.2.4  Alarms Classified by Network Management  

Alarms can also be classified by network management as follows: 

 Power system: Alarms of the power system (for example, DC 48 V) 
 Environment system: Alarms of equipment room environment (for example, 

temperature, humidity and door control) 
 Signaling system: Alarms of channel associated signaling and SS7 
 Trunk system: Alarms of trunk circuit and trunk board 
 Hardware system: Alarms of board parts (for example clock and CPU) 
 Software system: Alarms of software 
 Running system: Alarms of system running 
 Communication system: Alarms of communication system 
 QoS: Alarms of QoS 
 Processing error: Other alarms 

5.3  Configuring Alarm System Attributes 

5.3.1  Overview 

Configurations of alarm system attributes consist of: 

 Configuring Attributes of Alarm Query Window 
 Setting Fault Alarm Blinking Prompt  
 Setting Sound Duration for Fault Alarm 
 Setting Dial Notify for Fault Alarms 
 Setting SMS Notify for Fault Alarms 
 Sorting Alarms 

5.3.2  Configuring Attributes of Alarm Query Window  

I. Introduction 

Configuring attributes of the alarm query window consists of:  

 Alarm colors 
 Column width 
 Showing/Hiding tip 
 Clearing current alarm records 
 Dynamic addition  
 Querying active alarm when login successfully 
 Refreshing the window  
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II. Prerequisite  

None.  

III. Procedure  

Alarm query 
window attribute Menu Remarks 

Displaying color 
setting  

System -> Display Color 
Setting… 

This function is applicable to 
all the alarm browse windows. 

Displaying column 
width  

System -> Display 
Column Setting…  

This function is applicable to 
all active alarm browse 
windows.  

Showing/hiding tip System -> Tip 

Tip function: When the cursor 
moves to an alarm in a browse 
window, a Tip showing the 
alarm information is displayed. 
The information is the same as 
that in Browse Alarm 
Information widow. However, 
the use of tips facilitates 
browsing.  

This function is applicable to 
all the alarm browse windows. 

Clearing current 
alarm records  

Right click in an alarm 
browse window and 
select Clear all the 
alarms from the 
window.  

This function is applicable to 
Fault Alarm Browse and 
Event Alarm Browse 
windows only.  

Dynamic addition  

Right click in an alarm 
browse window and 
select Dynamic Addition 
from the shortcut menu.  

This function is applicable to 
the Fault Alarm Browse, 
Event Alarm Browse and 
Alarm log query result 
windows.  

Querying active alarm 
when login 
successfully  

System -> System 
Configuration  

This function applies to Fault 
Alarm Browse window only.  

Refreshing the 
window  

Right click in an alarm 
browse window and 
select Refresh Window 
from the shortcut menu. 

 For Event Alarm Browse 
window, refreshing means 
clearing the window.  

 For windows of Fault 
Alarm Browse, Alarm Log 
Query Result and Active 
alarm query result, 
refreshing means querying 
alarms by original 
conditions.  
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5.3.3  Setting Fault Alarm Blinking Prompt 

I. Introduction 

When you log into the NodeB alarm management system, an icon  displays in the 

status area of the LMT taskbar.  

The blinking prompt function means when the system reports a fault alarm, the tray 

blinks alternately between  and .  

 

  Note:  

 This function is applicable to fault alarms only.  
 When an alarm is reported, the icon blinks. When the alarm is cleared, the icon 

does not stop blinking automatically. You need to stop it manually. 
 When you disable the blinking prompt when the icon is blinking, the icon stops 

blinking.  

 

II. Prerequisite  

None. 

III. Procedure 

In the NodeB alarm management system, select Management -> Fault Alarm 
Prompt to enable or disable this function. If there is a symbol √ in front of the menu, 
the function is enabled. Otherwise, this function is disabled. The default setting is 
"enabled".  

 If you enable this function, the icon blinks when the system reports a fault alarm. 
Double click the icon to stop blinking and to maximize the window of the alarm 
management system. This facilitates you to handle the fault alarm.  

 If you disable this function, the icon does not change when the system reports a 
fault alarm.  
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5.3.4  Setting Sound Duration for Fault Alarms 

I. Introduction 

If the alarm sound function is enabled, the system prompts you with sound of different 
duration when there are fault alarms at different severity levels.  

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to set the sound duration for fault alarms in the NodeB alarm 
management system:  

1) Select Management -> Fault Alarm Sound to display the Fault Alarm Sound 
dialog box as shown in Figure 5-1. 

 

Figure 5-1 Fault Alarm Sound dialog box 

Table 5-2 describes the fields in the Fault Alarm Sound dialog box 

Table 5-2 Description of fields in Fault Alarm Sound dialog box 

Field  Description  

Critical Alarm  
It is used to set the sound duration for critical alarms. Selecting 
Critical Alarm means starting the fault alarm sound at this severity 
level.  

Major Alarm  
It is used to set the sound duration for major alarms. Selecting 
Major Alarm means starting the fault alarm sound at this severity 
level.  

Minor Alarm  
It is used to set the sound duration for minor alarms. Selecting 
Minor Alarm means starting the fault alarm sound at this severity 
level 

Warning  It is used to set the sound duration for warning. Selecting Warning 
means starting the fault alarm sound at this severity level 
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2) Set sound duration for fault alarms and decide whether to start the alarm sound 
at each severity level in the dialog box.  

3) Click OK to complete the settings.  

5.3.5  Setting Dial Notify for Fault Alarms 

I. Introduction 

The function of setting dial notify for fault alarms indicates that the system notifies you 
in case of fault alarms with the pre-set fixed-line phone number or the mobile phone 
number.  

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to set dial and SMS notify for fault alarms in the NodeB alarm 
management system: 

1) Select Management -> Fault Alarm Notify to display the Fault Alarm Notify 
dialog box as shown in Figure 5-2. 

 

Figure 5-2 Fault Alarm Notify dialog box 
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Table 5-3 describes the fields in the Fault Alarm Notify dialog box  

Table 5-3 Field description of Fault Alarm Notify dialog box 

Field  Description  

Show  After checking an alarm severity level, alarm records at that level 
automatically shown in the left list.  

Notify Type  

You can select alarms in the left list by pressing Shift or Ctrl and then 
select Dial Notify and/or SMS Notify. These settings enable you to 
receive notification of the selected alarms through the preset 
fixed-line phone number and/or the mobile phone number.  

The SMS notify includes 

 alarm ID 
 alarm severity 
 alarm rising time 

Start  

You can start the alarm notification type by selecting Dial Notify 
and/or SMS Notify.  

If you select alarm report of a notify type, the system starts reporting 
the selected alarms through the preset phone number and/or SMS.  

Setting You can set the fixed-line phone and/or mobile phone numbers in the 
Set Notification Mode dialog box by clicking Setting.  

 

2) Select an alarm severity in the dialog box to display alarm records at that level in 
the left list.  

3) Select alarms to be set in the left list.  
4) Select Dial Notify under Notify Type. 
5) Select Dial Notify under Start. 
6) Click Setting to display the Set Notify Type dialog box as shown in Figure 5-3.  

 

Figure 5-3 Set Notify Type dialog box 
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Table 5-4 describes the fields in the Set Notify Type dialog box  

Table 5-4 Field description of Set Notify Type dialog box  

Field  Description  

Notify Type  You can choose the notify type from Dial Notify or SMS Notify.  

Notify Tool  

 If the notify type is Dial Notify, Modem is enabled.  
 If the notify type is SMS Notify, Mobile is enabled.  
 Note that the system automatically sets Notify Tool according to 

the notify type setting.  

Serial Port 
No.  

You can select the Modem port number connected with the NodeB 
alarm management system for alarm notification.  

Phone No.  
 If the notify type is SMS Notify, enter a mobile phone number. 
 If the notify type is Dial Notify, enter a fixed-line phone number 

or a mobile phone number.  

Cleared Time 
Delay(s) 

A fault alarm will be notified if the time between the occurrences of 
the fault alarm and its corresponding cleared alarm is over Cleared 
Time Delay.  

Interval Two 
SMS (s)  

The system reports fault alarms one by one at intervals of Interval 
Two SMS. An alarm is reported for one time only.  

 

7) Select Dial Notify in the Notify Type drop box.  
8) Set the following parameters in the Set Notify Type dialog box 

 Serial port No. 
 Phone No. 
 Cleared time delay(s)  
 Interval two SMS(s)   

9) Click OK to close Set Notify Type dialog box.  
10) Click OK to close Fault Alarm Notify dialog box.  

5.3.6  Setting SMS Notify for Fault Alarms  

I. Introduction 

The function of setting SMS notify for fault alarms indicates that the system notifies 
you in case of fault alarms with the pre-set mobile phone number.  

II. Prerequisite 

None.  
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III. Procedure 

Follow the steps below to set the SMS notify for fault alarms in the NodeB alarm 
management system:  

1) Select Management -> Fault Alarm Notify to display the Fault Alarm Notify 
dialog box as shown in Figure 5-2.  

2) Select an alarm severity in the dialog box to display alarm records at that level in 
the left list.  

3) Select alarms to be set in the left list.  
4) Click SMS Notify under Notify Type. 
5) Click SMS Notify under Start. 
6) Click Setting to display the Set Notify Type dialog box as shown in Figure 5-3.  
7) Select SMS Notify in the Notify Type drop box.  
8) Set the following parameters in the Set Notify Type dialog box 

 Serial port No. 
 Phone No. 
 Cleared time delay(s)  
 Interval two SMS (s)  

9) Click OK to close Set Notify Type dialog box.  
10) Click OK to close Fault Alarm Notify dialog box.  

5.3.7  Sorting Alarms  

I. Introduction 

Alarm records can be sorted by any column. If an alarm is reported after sorting, it is 
added to the list end. 

 

  Note:  

Alarm records can be sorted only by one column each time.  

 

II. Prerequisite  

None.  

III. Procedure  

To sort alarm records in an alarm browse window by a column, click the caption of the 
column.  
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5.4  Monitoring NodeB Alarms 

5.4.1  Overview  

Monitoring the NodeB alarms includes 

 Browsing alarms 
 Querying active alarms 
 Querying alarm log 
 Querying alarm details  
 Realtime print alarms 

5.4.2  Browsing Alarms   

I. Introduction 

The NodeB alarm management system dynamically displays the latest records of 
fault alarms and event alarms in the Fault Alarm Browse and Event Alarm Browse 
windows. You can view the alarm records to know the current operation of the NodeB. 

This function includes: 

 Browsing fault alarms 
 Browsing event alarms 

II. Prerequisite 

None. 

III. Procedure  

Follow the steps below to browse current fault alarms: 

1) Start the NodeB alarm management system.  Then the Fault Alarm Browse 
window opens up as shown in Figure 5-4. If the Fault Alarm Browse window is 

closed, select Browse -> Fault Alarm Browse or click the shortcut icon  to 

open it again.  
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Figure 5-4 Fault Alarm Browse window 

Table 5-5 describes the fields in the Fault Alarm Browse window  

Table 5-5 Field description of Fault Alarm Browse window  

Field  Description  

Alarm serial No. It is a number given to an alarm by the raised time.  

Cleared state It shows whether the alarm is cleared.  

Alarm name It is preset in the NodeB.  

Alarm raised 
time/cleared time  

It shows the time when the alarm is generated. If the 
alarm is cleared, it also shows the time when it is cleared. 

Alarm severity It is preset in the NodeB and changes with the fault code 
dynamically.  

Location info 

It refers to the fault code of the alarm and the fault location 
in the NodeB. Details include:  

 The cabinet number 
 The subrack number  
 The slot number  
 The link number  

Alarm source 
It shows the net element from which the alarm is reported. 
For the NodeB alarm management system, the alarm 
source is the NodeB itself.  

Alarm ID 

Event type 

Alarm type 

These items are preset in the NodeB.  

 

2) Browse the active fault alarms with. The system adds new fault alarms to the list 
end in real time. 
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  Note:  

 Select System -> System Setting to display the System Setting dialog box. If 
Query active alarm when login successfully in the dialog box is not ticked, the 
fault alarms reported before login are not displayed in the Fault Alarm Browse 
window. The window only displays the fault alarms reported after login.  

 If Query active alarm when login successfully in the dialog box is ticked, all the 
active fault alarms are displayed in the Fault Alarm Browse window and new fault 
alarms are added to the list end in real time.  

 

Follow the steps below to browse the current event alarms:  

3) Start the NodeB alarm management system.  Then the Event Alarm Browse 
window opens up as shown in Figure 5-5. If the Event Alarm Browse window is 

closed, select Browse -> Event Alarm Browse or click the shortcut icon  
to open it again.  

 

Figure 5-5 Event Alarm Browse window 

Table 5-6 describes the fields in the Event Alarm Browse window.  

Table 5-6 Field description of Event Alarm Browse window 

Field  Description  

Alarm serial No. It is a number given to an alarm by the raised time.  

Alarm name It is preset in the NodeB.  

Alarm raised 
time   It shows the time when the alarm is generated.   
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Alarm severity It is preset in the NodeB and changes with the fault code 
dynamically.  

Location info 

It refers to the fault code of the alarm and the fault location in the 
NodeB. Details include:  

 The cabinet number 
 The subrack number  
 The slot number  
 The link number 

Alarm source 
It shows the net element from which the alarm is reported. For the 
NodeB alarm management system, the alarm source is the 
NodeB itself.  

Alarm ID 

Event type 

Alarm type 

These items are preset in the NodeB.  

 

4) Browse the active event alarms. The system adds new event alarms to the list 
end in real time.  

5.4.3  Querying Active Alarms  

I. Introduction 

Querying active alarms refers to querying current uncleared fault alarms of the NodeB 
according to specified conditions.  

 

  Note:  

All the active alarms will disappear after resetting the NodeB. In that case, those 
alarms can only be queried by querying alarm log.  

 

II. Prerequisite  

None.  

III. Procedure 

Follow the steps below to query active alarms:  

1) In the NodeB alarm management system, select Query -> Query Active Alarm. 
The Query Active Alarm dialog box opens up as shown in Figure 5-6.  

Huawei Technologies Proprietary 

5-14 



NodeB LMT User Guide Chapter 5  Alarm Management
 

 

Figure 5-6 Query Active Alarm dialog box 

Table 5-7 describes the fields in the Query Active Alarm dialog box.  

Table 5-7 Field description of Query Active Alarm dialog box  

Field  Description  

Serial No.  
To specify a serial No. range 

Default value: all serial Nos.  

Return Numbers 

To specify the number of records 

Default value: 64 

Maximum value: 1000  

Module No.  Unavailable  

Slot No.  To specify a slot  

Cabinet No.  To specify a cabinet  

Subrack No.  To specify a subrack  

Board Location  Unavailable  

 

2) Set the query conditions in the dialog box.  
3) Click OK to display the Active Alarm Query Result window for the query result.  
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  Note:  

You can query active alarms by the MML command of LST ALMAF. 

 

5.4.4  Querying Alarm Log 

I. Introduction 

Querying the alarm log refers to querying the alarm log records by query conditions. 
The aim is to get knowledge to the NodeB alarms or collect alarm statistics.  

 

  Note:  

When an alarm is generated, NodeB record the alarm in the alarm log. The alarm log 
keeps the information of all the fault and event alarms.   

 

II. Prerequisite  

None.  

III. Procedure 

Follow the steps below to query  

1) In the NodeB alarm management system, select Query -> Query Alarm Log or 

click the shortcut icon  to display the Query Alarm Log dialog box, as 

shown in Figure 5-7.  
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Figure 5-7 Query Alarm Log dialog box 

You can set general conditions for alarm query in Common option tab page. The 
conditions may include  

 Alarm type 
 Alarm severity  
 Date/Time  

Table 5-8 describes the fields in the tab page.  

Table 5-8 Field description of Common option tab page  

Field  Description  

Alarm Type  
To specify alarm types 

Default value: Fault alarm not Cleared 

Alarm Severity  
To specify alarm severities 

Default value: critical, major, minor, warning 
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Field  Description  

Date/Time 

To specify a time range to query alarms within that period  

 If you specify start time without start date, the system takes 
the seventh day before the current day as the start date. 

 If you specify end time without end date, the system takes 
the current date as the end date. 

 If you specify start date without start time, the system takes 
0:0:0 as the start time. 

 If you specify end date without end time, the system takes 
23:59:59 as the end time. 

Return Numbers  

To specify the number of records to returned 

Default value: 64 

Maximum value: 1000 

 

You can set detailed conditions for alarm query in the Detailed option tab page as 
shown in Figure 5-8. The conditions may include:  

 Serial number 
 Alarm ID  
 Event type  

 

Figure 5-8 Detailed option tab page 
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Table 5-9 Field description of Detailed option tab page 

Field  Description  

Serial No.  
To specify a serial No. range 

Default value: all serial Nos. 

Alarm ID  
To specify an alarm ID range 

Default value: all alarm IDs 

Module No.  Unavailable  

Event Type  
To specify event types 

Default value: all types 

 

You can set location conditions for alarm query in the Physical option tab page as 
shown in Figure 5-9. The conditions may include:  

 Subrack No.  
 Slot No.  
 Board location  

 

Figure 5-9 Physical option tab page 

Table 5-10 describes the fields in the Physical option tab page.  
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Table 5-10 Field description of Physical option tab page  

Field  Description  

Subrack No. To specify a subrack 

Slot No.  To specify a slot 

Board Location  Unavailable  

Cabinet No.  To specify a cabinet 

Board Type  To specify a board type  

 

2) Set query conditions in the dialog box.  
3) Click OK. The Query Alarm Log window for the query result opens up.  

5.4.5  Querying Alarm Details  

I. Introduction 

Querying the alarm details refers to querying the details of an alarm, including:  

 Alarm serial No. 
 Alarm name  
 Alarm raised time  
 Alarm severity  
 Location information  
 Alarm source  

II. Prerequisite  

None.  

III. Procedure 

Follow the steps below to query the detailed alarms:  

1) Double click an alarm record in the alarm browse window.  
2) The Alarm Details dialog box opens up as shown in Figure 5-10. 
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Figure 5-10 Alarm Details dialog box 

5.4.6  Realtime Printing Alarms  

I. Introduction 

Realtime printing alarms indicate that the system automatically prints the reported 
alarm records according to the conditions.  

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to set the realtime print conditions in the NodeB alarm 
management system:  

1) Select System -> Realtime Print Setup. The Realtime Print Setup dialog box 
opens up as shown as Figure 5-11.  
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Figure 5-11 Realtime Print Setup dialog box 

Table 5-11 describes the fields in the Realtime Print Setup dialog box.  

Table 5-11  Field description of Realtime Print Setup dialog box  

Field  Description  

Alarm severity  To select a severity of alarms to print 

Alarm type  To select a report type of alarms to print 

Event alarm  To select an event type of alarms to print 

Print to File  

If you tick this box, you need to specify a file path. In this case, 
the system prints the selected alarm records to a file. 

If you do not tick it, the system prints the selected alarm records 
in real time. 

 

2) Set the conditions for saving alarm records in the dialog box.  
3) Tick Print to File to display the Save as… dialog box.  
4) Select an existing file or enter a file name to create a new file in the dialog box.  
5) Click Save as…. You are presented with the Realtime Print Setup dialog box.  
6) Click OK in the dialog box.  

The system starts to print the reported alarm records.  
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5.5  Handling NodeB Alarms  

5.5.1  Overview  

Handling NodeB alarms refers to querying NodeB alarm handling suggestions and 
shielded alarms.  

5.5.2  Querying Alarm Handling Suggestions 

I. Introduction 

Querying alarm handling suggestions refers to querying alarm handling suggestions 
for the relevant alarms, including:  

 Alarm meaning 
 Impacting on system 
 System actions 
 Alarm handling  

II. Prerequisite 

None.  

III. Procedure 

There are two ways to query alarm handling suggestions.  

Method One:  

1) Select an alarm record in an alarm browse window.  
2) Right click on that alarm to display the shortcut menu.  
3) Select More in the menu to display the online help.  

Method Two:  

4) Double click an alarm record in an alarm browse window. The Alarm Details 
dialog box opens up as shown in Figure 5-10. 

5) Click More to display the online help.  

5.5.3  Shielded Alarms 

I. Introduction 

A shielded alarm indicates that the NodeB neither saves this alarm nor reports it to the 
alarm management system. In that case, you can not query the shielded alarm.  

Huawei Technologies Proprietary 

5-23 



NodeB LMT User Guide Chapter 5  Alarm Management
 

An unshielded alarm indicates that the NodeB saves this alarm and reports it to the 
NodeB management system. In that case, you can query the unshielded alarm.  

 

  Note:  

If you set shielding conditions, those conditions take effect when next alarm occurs. 
Those uncleared alarms shall remain what they are.  

 

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to modify alarm configurations in the NodeB alarm 
management system:  

1) Select Management -> Alarm Configuration. The Query Alarm 
Configuration dialog box opens up, as shown in Figure 5-12.  

 

Figure 5-12 Query Alarm Configuration dialog box  

Table 5-12 describes the fields in the Query Alarm Configuration dialog box.  
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Table 5-12 Field description of Query Alarm Configuration dialog box  

Field  Description  

Alarm ID To specify an alarm ID range  

Alarm Severity  
To specify one or multiple alarm severities 

Default value: all severities  

Mask Flag  

Options: Shielded, Unshielded and All 

Default value: All 

If an alarm is shielded, the NodeB neither saves it nor 
reports it to the NodeB alarm management system. In this 
case, you can not query this alarm.  

If an alarm is not shielded, the NodeB saves the alarm and 
reports it to the alarm management system. In this case, you 
can query this alarm. 

Report to Alarm Box  Unavailable   

Modification Flag  

Value: Modified, Unmodified, All 

Default value: All 

If the alarm severity, report-to-alarm-box flag, and mask flag 
of an alarm are modified, its modification flag is Modified. 

For the NodeB, the alarm severity and report-to-alarm-box 
flag can not be modified. Therefore, if the mask flag of an 
alarm is modified, its modification flag is Modified. 

Return Numbers  

To specify the number of records returned 

Default value: 64 

Maximum value: 1000 

 

2) Set query conditions in the dialog box.  
3) Click OK to display the Alarm Configuration Query Result window for the 

query result.  
4) Select an alarm record to be modified in the window. You can select one record 

only each time. Then click Modify to display the Modify Alarm Configuration 
dialog box as shown in Figure 5-13.  
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Figure 5-13 Modify Alarm Configuration dialog box 

Table 5-13 describes the fields in the Modify Alarm Configuration dialog box.  

Table 5-13 Field description of Modify Alarm Configuration dialog box 

Field  Description  

Alarm Severity  Unavailable   

Shield Flag  Options: Shielded and Unshielded  

To Alarm Box Flag  Unavailable   

 

5) Modify Shield Flag in the dialog box.  
6) Click OK to complete the modification.  

 

  Note:  

Execute the MML command of SET ALMSHLD to modify the shield flag.  
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Chapter 6  Managing Files 

6.1  About This Chapter 

This chapter describes how to manage the files, including 

 Overview of File Management 
 Uploading Files 
 Browsing Files 

6.2  Overview of File Management 

6.2.1  File Types 

Table 6-1 describes types of the NodeB LMT files.  

Table 6-1 File types of NodeB LMT 

File type Function   Format  Remarks  

Operation 
Log  

To record the NodeB 
operation and 
maintenance information 

In *.txt 
format 

The operation log can be 
uploaded to the FTP 
server. 

Equipment 
Archives 

To record information of 
the boards on a NodeB, 
such as the manufacturing 
information and running 
duration of the boards 

In *.xml 
format 

The equipment archives 
can be uploaded to the FTP 
server. 

Main 
Board Log 
Files  

To record all the logs on 
the NMPT 

In binary 
format  

The main board log file can 
be uploaded to the FTP 
server. 

Board Log 
Files  

To record logs on other 
boards 

In binary 
format  

 The board log files can 
be uploaded to the FTP 
server. 

 Board log files may vary 
because some boards 
have no slave CPUs 
while some other 
boards have no DSPs.  

RTWP 
Routine 
Test Log  

To record and store 
related RTWP information 
in the routine test log after 
the RTWP routine test is 
started 

In binary 
format  

The RTWP routine test log 
can be uploaded to the FTP 
server. 
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6.2.2  Browsing Files 

There are two ways to obtain and browse the files as follows:  

 Browse files by logging into the FTP server after uploading the files to the server  
 Browse the operation log through the M2000 server  

6.3  Uploading Files 

6.3.1  Uploading Operation Log 

I. Introduction 

Uploading the operation log refers to uploading the operation log to the FTP server. 

This enables you to save and view the operation log.  

II. Prerequisites 

The prerequisites to upload the operation log are as follows:  

 The FTP server works well and connects to the NodeB well within the same 
intranet.  

 There is no firewall between the FTP server and the NodeB.  
 The user name and password for the specified FTP Server are correct. Ensure 

that you have the authority to read (when downloading) and write (when uploading) 
data in the specified directory.  

III. Procedure 

Follow the steps below to upload the operation log:  

1) Choose Maintenance Navigator -> Software Management. Then double-click 
the Other File Transfer subnode.  
The Other File Transfer dialog box opens up, as shown in Figure 6-1.  
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Figure 6-1 Other File Transfer dialog box 

Table 6-2 describes the fields in the Other File Transfer dialog box.  

Table 6-2 Field description of Other File Transfer dialog box  

Field  Description  

Transfer Type  
If you select Upload (NodeB to FTP Server), you may upload 
data files from the NodeB to the FTP Server. This enables you to 
view, modify and save the file. 

File Description  

The files include  

 Operation log  
 Equipment archives  
 Main Board Log Files  
 Board Log Files  
 RTWP Routine Test Log File 
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Field  Description  

Destination File 
or Directory  

 The directory or file in the FTP server in which data files are 
saved 

 You may specify the directory or the name of a data file.  

 If you select Upload (NodeB to FTP Server), it refers to the 
destination file or directory.   

 If you select Download (FTP Server to NodeB), it refers to 
the source file.  

FTP Setting  

 To set the FTP server that saves data files to be uploaded or 
downloaded 

 The FTP server in use shall be listed in the FTP Setting box. 
 To set parameters for the FTP server, click Modify.  

Upload Mode  
 To decide whether to use the compressed mode 
 This mode is available only when you select Upload (NodeB 

to FTP Server).  

 

2) Click Modify.  
The FTP Settings dialog box opens up, as shown in Figure 6-2.  

 

Figure 6-2 FTP Settings dialog box 

Table 6-3 describes the fields of the FTP Settings dialog box.  

Table 6-3 Field description of FTP Settings dialog box  

Field  Description  

Use Built-in 
FTP Server  

 The FTP server built in the LMT  
 The built-in FTP server is started by default.  
 To stop the FTP server, select System -> Stop FTP Server. 
 To start the FTP server, select System -> Start FTP Server.  
 Select System -> System Configuration. You can set the user 

name and password for the built-in FTP server in the System 
Configuration dialog box.  
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Field  Description  

IP Address 

 To set the IP address for the computer where this 
FTP server is located 

 The FTP server can be the one started from the 
local computer installed with LMT or from another 
computer.  

User Name  To set the user name for logging into the FTP server

Use 
Specified 
FTP Server  

Password   To set the password for logging into the FTP server

 

3) Set parameters in the dialog box.  
4) Click OK.  

The FTP Settings dialog box is closed. You are presented with the Other File 
Transfer dialog box.  

5) Choose Upload (NodeB to FTP Server) in Transfer Type.  
6) Choose Operation Log in File Description.  
7) Complete other settings in the dialog box.  
8) Click Start. 

The system starts to upload the operation log.  

 

  Note:  

Execute the MML command of ULD FILE to upload operation log.  

 

6.3.2  Uploading Equipment Archives  

I. Introduction  

Uploading equipment archives refers to uploading the equipment archives to the FTP 
server.  

This enables you to view and save the equipment archives. 

II. Prerequisites  

 The MML command of EXP DEVFILE must be executed to generate equipment 
archives.  

 Other prerequisites are the same to those for uploading the operation log. See 
6.3.1  "Uploading Operation Log". 
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III. Procedure 

Follow the steps below to upload the equipment archives:  

1) Choose Maintenance Navigator -> Software Management. Then double-click 
the Other File Transfer subnode.  
The Other File Transfer dialog box opens up, as shown in Figure 6-1.  

2) Click Modify.  
The FTP Settings dialog box opens up, as shown in Figure 6-2.  

3) Set parameters in the dialog box. 
4) Click OK.  

The FTP Settings dialog box is closed. You are presented with the Other File 
Transfer dialog box.  

5) Choose Upload (NodeB to FTP Server) in Transfer Type.  
6) Choose Equipment Archives in File Description.  
7) Complete other settings in the dialog box.  
8) Click Start. 

The system starts to upload the equipment archives.  

 

  Note:  

Execute the MML command of ULD DEVFILE to upload the equipment archives.  

 

6.3.3  Uploading Main Board Log Files  

I. Introduction  

Uploading the main board log files refers to uploading the main board log files to the 
FTP server.  

This enables you to view and save the files.  

II. Prerequisites  

 The prerequisites are the same to those for uploading the operation log. See 6.3.1  
 "Uploading Operation Log". 

III. Procedure 

Follow the steps below to upload the main board log files:  
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1) Choose Maintenance Navigator -> Software Management. Then double-click 
the Other File Transfer subnode.  
The Other File Transfer dialog box opens up, as shown in Figure 6-1.  

2) Click Modify.  
The FTP Settings dialog box opens up, as shown in Figure 6-2.  

3) Set parameters in the dialog box. 
4) Click OK.  

The FTP Settings dialog box is closed. You are presented with the Other File 
Transfer dialog box.  

5) Select Upload (NodeB to FTP Server) in Transfer Type.  
6) Select Main Board Log Files in File Description.  
7) Complete other settings in the dialog box.  
8) Click Start. 

The system starts to upload the main board log files.  

 

  Note:  

Execute the MML command of ULD FILE to upload the main board log files.  

 

6.3.4  Uploading Board Log Files  

I. Introduction  

Uploading the board log files refers to uploading the board log files to the FTP server. 

This enables you to view and save the board log files.   

II. Prerequisites 

 The prerequisites are the same to those for uploading the operation log. See 6.3.1  
 "Uploading Operation Log". 

III. Procedure  

Follow the steps below to upload the board log files:  

1) Choose Maintenance Navigator -> Software Management. Then double-click 
the Other File Transfer subnode.  
The Other File Transfer dialog box opens up, as shown in Figure 6-1.  

2) Click Modify.  
The FTP Settings dialog box opens up, as shown in Figure 6-2.  

3) Set parameters in the dialog box. 
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4) Click OK.  
The FTP Settings dialog box is closed. You are presented with the Other File 
Transfer dialog box.  

5) Select Upload (NodeB to FTP Server) in Transfer Type.  
6) Select Board Log Files in File Description.  
7) Complete other settings in the dialog box.  
8) Click Start.  

The system starts to upload the board log files.  

  Note:  

Execute the MML command of ULD FILE to upload the board log files.  

 

6.3.5  Uploading RTWP Routine Test Log  

I. Introduction  

Uploading the RTWP routine test log refers to uploading the RTWP routine test log to 
the FTP server.  

This enables you to view and save the RTWP routine test log.  

II. Prerequisites 

 The prerequisites are the same to those for uploading the operation log. See 6.3.1  
 "Uploading Operation Log". 

III. Procedure 

Follow the steps below to upload the board log files:  

1) Choose Maintenance Navigator -> Software Management. Then double-click 
the Other File Transfer subnode.  
The Other File Transfer dialog box opens up, as shown in Figure 6-1.  

2) Click Modify.  
The FTP Settings dialog box opens up, as shown in Figure 6-2.  

3) Set parameters in the dialog box. 
4) Click OK.  

The FTP Settings dialog box is closed. You are presented with the Other File 
Transfer dialog box.  

5) Select Upload (NodeB to FTP Server) in Transfer Type.  
6) Select RTWP Routine Test Log in File Description.  
7) Complete other settings in the dialog box.  
8) Click Start. 
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The system starts to upload the RTWP routine test log.  

6.4  Browsing Files  

6.4.1  Browsing Files on FTP Server 

I. Introduction  

Browsing files refers to browsing the uploaded files by logging into the FTP server.  

II. Prerequisite 

The files have been uploaded to the FTP server.  

III. Procedure 

Follow the steps below to browse the uploaded files on the FTP server:   

1) Upload the files to the FTP server. 
For details, see 6.3   "Uploading Files".  

2) Browse the uploaded files by logging into the FTP server. 

6.4.2  Browsing Operation Log on M2000 Server  

I. Introduction  

You can query the NodeB operation log on the M2000 server  

II. Prerequisite  

You have authority to query the NodeB operation log.  

III. Procedure 

For details, see iManager M2000 Mobile Element Management System Operation 
Manual. 
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Chapter 7  Managing NodeB and Boards 

7.1  About This Chapter 

This chapter describes how to manage the NodeB and the boards on the NodeB O&M 
system, including 

 Basic Equipment Panel Operation 
 NodeB-level Operation 
 Board-level Operation 

The NodeB O&M system provides an equipment panel for users to make the 
operations more visual and convenient. All the operations conducted through the 
equipment panel can also be realized by MML commands.  

7.2  Basic Equipment Panel Operation 

7.2.1  Introduction to Equipment Panel 

The NodeB provides multiple maintenance means. Besides the MML command, the 
NodeB O&M system provides a GUI equipment panel. This makes the equipment 
maintenance more visual and convenient.  

7.2.2  Functions of Equipment Panel  

Select a board and then right-click on it to display a shortcut menu on the equipment 
panel. You can perform the following operations by selecting different menus: 

 Querying board status 
 Querying board version  
 Resetting board  

 

 Note:  

For detailed operations on boards, see section 7.4   "Board-level Operation".  
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7.2.3  Interface of Equipment Panel 

Figure 7-1 shows the interfaces of equipment panel. The panel automatically refreshes 
to query the board status in real time.  

 

Figure 7-1 Interface of equipment panel 

II. Board Indicators  

In Figure 7-1, there is an indicator on each board, indicating the present board status.  

Figure 7-2 illustrates the meaning of board indicators.  
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Figure 7-2 Meaning of board indicators 

III. Fault Bar  

The fault bar is used to display active alarms on the board in real time.  

For example, the fault bar message 0-0-3-NULP-Fault indicates the NULP board in 
slot No. 3, subrack No. 0 and cabinet No. 0 is faulty.  

Symbol || is used to divide two alarms from each other. When all the alarms are 
displayed, the fault bar starts rolling to display the alarms from the beginning.  

7.2.4  Starting Equipment Panel 

I. Introduction 

The LMT provides a GUI equipment panel. This makes the equipment management 
more visual and convenient.  

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to start the equipment panel:  

1) Choose Maintenance Navigator -> Rack Node.  
2) Double-click Master Cabinet subnode.  

The system displays the equipment panel of the cabinet in the right pane.  
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7.2.5  Showing or Hiding Board Indicators 

I. Introduction  

You can make preliminary decision of the board status by observing the color of each 
board indicator.  

II. Prerequisite 

None.  

III. Procedure  

To show or hide the indicators as shown in Figure 7-2, follow either way below: 

 Click  on the upper right of the equipment panel,  

 Press Ctrl + L.  

7.2.6  Showing or Hiding Fault Bar  

I. Introduction  

The fault bar displays active alarms in real time.  

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to show or hide the fault bar:  

1) To display the fault bar, click  on the upper right of the equipment panel, or press 
Ctrl+F.  

 

 Note:  

The system displays the fault bar by default.  
There are three ways to close the fault bar as follows:  
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 Click  on the upper right of the equipment panel  
 Press Ctrl + F  
 Close it directly  

 

2) To start the equipment panel, see 7.2.4   "Starting Equipment Panel". If there is an 
active alarm on the device, it is displayed by rolling the fault bar.  

7.3  NodeB-level Operation 

7.3.1  Overview  

Operations on the NodeB include:  

 Querying NodeB Running Version 
 Querying NodeB Software Version 
 Modifying NodeB Time 
 Modifying NodeB Password 
 Resetting NodeB 

7.3.2  Querying NodeB Running Version 

I. Introduction  

You can query the information of the NodeB running version.  

II. Prerequisite  

None.  

III. Procedure  

Follow the steps below to query the NodeB running version:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select the active NMPT of the master cabinet on the panel.  

 

  Note: 

For the DBS3800, select MBBU on the panel. 
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3) Right-click on the NMPT and select List NodeB Running Version on the shortcut 
menu.  
The system displays the Query Result pane as shown in Figure 7-3, listing the 
NodeB version information.  

 

Figure 7-3 Query Result pane 

  Note:  

You can also query the NodeB running version by the MML command of LST VER. 

 

7.3.3  Querying NodeB Software Version 

I. Introduction  

You can check whether the NodeB is upgraded by querying the NodeB software 
version.  

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to query the NodeB software version:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select the active NMPT of the master cabinet on the panel.  
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  Note: 

For the DBS3800, select the MBBU on the panel. 

 

3) Right-click on the NMPT and select List NodeB Software Version on the shortcut 
menu.  
The system displays the Query Result pane as shown in Figure 7-4 and Figure 
7-5, listing the NodeB software version information and NodeB BOOTROM 
version information.  

 

Figure 7-4 NodeB Software Version Information pane 

 

Figure 7-5 NodeB BOOTROM Version Information pane 

  Note:  

You can also query the NodeB running software version by the MML command of LST 
SOFTWARE.  
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7.3.4  Modifying NodeB Time  

I. Introduction  

 Caution:  

The NodeB time is very important for alarm logs, operation logs and services records. 
Modify the NodeB time with caution.  

You can maintain NodeBs of different versions through the same LMT. But at the same 
time, you can maintain only one NodeB on that LMT. The NodeB and the LMT must be 
synchronized to avoid time inconsistency in alarm logs and operation logs. 

II. Prerequisite 

None.  

III. Procedure  

If the time difference between LMT and NodeB is greater than five minutes, the system 
displays a Time Synchronization Check dialog box, listing the LMT time and NodeB 
time and prompting whether to synchronize the LMT time with the NodeB time.  

 If the NodeB time is precise, click Modify to synchronize the LMT time with the 
NodeB time.  

 If the NodeB time is not precise, click Cancel and log into the NodeB to modify the 
NodeB time by the MML command of MOD TM.  

 

  Note:  

 You may query the NodeB time by the MML command of DSP TM before the 
modification to decide whether to modify the time. 

 You may query the NodeB time by the MML command of DSP TM after the 
modification to check whether the modification is valid. 

 If the SNTP function is enabled, the NodeB time shall be synchronized with the 
SNTP server time periodically. Even if NodeB time is modified, it will still be 
synchronized in next synchronization. If the SNTP function is not enabled, the 
modified NodeB time will remain valid. 

 Relevant MML commands: SET SNTPCLTPARA (to set SNTP client parameters) 
and LST SNTPCLTPARA (to list SNTP client parameters).  
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7.3.5  Modifying NodeB Password  

I. Introduction  

This function is to modify the password for logging into the NodeB. You can log into the 
NodeB only when you enter the correct password. 

II. Prerequisite  

None.  

III. Procedure  

  Caution:  

 The setting takes effect upon completion for users who log into the NodeB after the 
modification. However, the new password does not affect your normal operation if 
you have logged into the NodeB before the modification.  

 Users who have authority to modify the NodeB password have to be either an 
M2000 server user or an O&M system user. Alarm management users have no 
authority to modify the NodeB password.  

 

Follow the steps below to modify the NodeB password:  

1) In the NodeB O&M system, select System -> Change Password to display the 
Change Password dialog box as shown in Figure 7-6.  

 

Figure 7-6 Change Password dialog box  

2) Enter the old and new passwords.  
3) Click OK to complete the password modification.  
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7.3.6  Resetting NodeB  

I. Introduction  

  Caution:  

Resetting the NodeB shall interrupt services on the NodeB.   

 

You need to reset the NodeB upon a NodeB failure or after the configuration update.  

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to reset the NodeB:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select the active NMPT of the master cabinet on the panel. 

 

  Note: 

For the DBS3800, select the MBBU on the panel. 

 

3) Right-click on the NMPT and select Reset Board on the shortcut menu.  
4) Click Yes in the dialog box to reset the board.  

The system displays the result and automatically refreshes the status of board 
indicators in accordance with the result. 

 

  Note:  

You can also reset the NodeB by the MML command of RST SYS. 
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7.4  Board-level Operation 

7.4.1  Overview  

Operations of board management vary from different types of boards. Table 7-1 
describes the actions related to boards.  

Table 7-1 Actions related to boards  

NodeB type Board  Action  

Reset board (Except MAFU)  

Display board status 

Query active alarms 
All boards 

Display board version 

HDLP (NDLP)/HULP 
(NULP)/HBBI/MTRU/ 
MAFU 

Block/Unblock board 

List NodeB software version (Valid for 
active NMPT only) 

List NodeB running version (Valid for 
active NMPT only) 

NMPT 
Display current clock status 

For details, see section 
12.3.3 "Displaying Current Clock 
Status".  

Display E1/T1 status  

Display E1/T1 work mode 

Display Iub optical port status (Valid for 
NAOI only)  

Macro 
NodeB  

NAOI/NDTI 

Display Iub optical port work mode 
(valid for NAOI only)  

Reset board 

Display board status 

Query active alarms 

Display board version 

All NodeBs   

Block/Unblock board  

List NodeB software version 

List NodeB running version 

DBS3800 

MBBU 

Display current clock status 
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NodeB type Board  Action  

Display E1/T1 status    

Display E1/T1 work mode 

 

7.4.2  Querying Board Status 

I. Introduction  

You can display the running status of a board to monitor the running status of a NodeB. 
Table 7-2 describes the detailed board status.  

Table 7-2 Board status description  

Type  Board status  Description  

Active/Standby status  
 It indicates the board is active or standby.  
 For a macro NodeB, it applies to the NMPT only.  

Active The board is active. 

Standby The board is standby. 

None Not applicable 

Availability status Physical availability of the board 

 Normal The board works normally. 

 Faulty There is an alarm on the board. 

 Uninstall The board is configured but not inserted. 

 Not 
configured The board is inserted but not configured. 

 Not consistent The configured board is not consistent with the inserted 
board in type. 

Operation status Whether the board supports services establishment 

 Usable The board supports services establishment. 

 Unusable The board does not support services establishment. 

Admin status 

 Whether the board needs to support service 
establishment 

 For a macro NodeB, this status is only applicable to the 
HULP/NULP, HDLP/NDLP, HBBI, MTRU and MAFU. 

 For all the other boards, this status shall be set to Null.

Usable The board needs to support services establishment  

Unusable The board does not need to support services 
establishment  
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Type  Board status  Description  

None The board is not manageable. 

 

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to query the board status:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select a board on the equipment panel.  
3) Right-click and select Display Board Status on the shortcut menu.  

The system displays a dialog box, showing the running status of that board.  

 

  Note:  

Follow either way below to query the board status:  
 Execute the MML command of DSP BRD 
 Check the board indicators 

For details, see sections 7.2.3  II.  "Board Indicators" and 7.2.5   "Showing or Hiding 
Board Indicators". 

 

7.4.3  Querying Active Alarms on Board 

I. Introduction  

Listing active alarms enables you to locate and remove the fault on a board in time.  

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to list active alarms:  
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1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select a board on the panel.  
3) Right-click on the board and select Query Active Alarms on the shortcut menu. 

The system displays a dialog box, showing the uncleared fault alarms of that 
board.  

 

  Note:  

You can also query the active alarms of a specified board by the MML command of LST 
ALMAF. 

 

7.4.4  Querying Board Version 

I. Introduction  

You can check whether the board versions are consistent with the NodeB version by 
querying the running versions of all the boards, including  

 CPU number  
 Board software version  
 Board hardware version  
 Board BOOTROM version 

II. Prerequisite 

None. 

III. Procedure  

Follow the steps below to query the board version:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select a board on the panel.  
3) Right-click on the board and select Display Board Version on the shortcut menu. 

The system displays a dialog box showing the version information of that board.  
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  Note:  

You can also query the version information of a specified board by the MML command 
of DSP BRDVER.  

 

7.4.5  Querying E1/T1 Status  

I. Introduction  

You can check the status of all E1/T1 links of an NDTI/NAOI. 

The result shows the current status of all E1/T1 links of the board.  

 For NAOI, the links are E1/T1 links 0 to 3.  
 For NDTI, the links are E1/T1 links 0 to 7. 

 

  Note:  

For the DBS3800, you can check the status of E1/T1 links by checking the MBBU on 
the equipment panel.  

 

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to query the status of E1/T1 links:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select an NDTI/NAOI on the equipment panel.  

 

  Note:  

For the DBS3800, select the MBBU on the equipment panel.  

 

3) Right-click on the board and select Display E1/T1 State on the shortcut menu. 
The system displays the Display E1/T1 State dialog box as shown in Figure 7-7.  
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Figure 7-7 Display E1/T1 State dialog box  

4) Set parameter for Port No. in the dialog box and click OK. 

The system displays a Query Result dialog box as shown in Figure 7-8, listing the 
query result.  

 

Figure 7-8 Query Result dialog box  

  Note:  

You can also query the status of E1/T1 links by the MML command of DSP E1T1. 

 

7.4.6  Querying E1/T1 Work Mode 

I. Introduction  

You can query the work mode of the E1/T1 links of an NDTI/NAOI. 

The result shows the work mode of all E1/T1 links of the board.  

 For NAOI, the links are E1/T1 links 0 to 3.  
 For NDTI, the links are E1/T1 links 0 to 7. 
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  Note:  

For the DBS3800, you can check the work mode of E1/T1 links through the MBBU on 
the equipment panel. 

 

II. Prerequisite 

None.  

III. Procedure  

Follow the steps below to query the E1/T1 work mode:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select an NDTI/NAOI on the equipment panel.  

 

  Note:  

For the DBS3800, select MBBU on the equipment panel.  

 

3) Right-click on the board and select Display E1/T1 Work Mode on the shortcut 
menu.  
The system displays the Display E1/T1 Work Mode dialog box as shown in 
Figure 7-9.  

 

Figure 7-9 Display E1/T1 Work Mode dialog box  

4) Set parameter for Port No. in the dialog box and click OK. 

The system displays a Query Result dialog box as shown in Figure 7-10, listing the 
query result.  
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Figure 7-10 Query Result dialog box 

  Note:  

You can query the E1/T1 work mode only when the NAOI/NDTI works well or in alarm 
status.  

 

  Note:  

You can also query the E1/T1 work mode of a specified board by the MML command of 
DSP E1T1WORKMODE. 

 

7.4.7  Querying STM-1 Status  

I. Introduction 

You can query the STM-1 status of an NAOI. The result shows the current status of Iub 
optical interface links 0 and 1 of the NAOI. 

 

  Note:  

This command is valid for macro NodeBs only.  

 

II. Prerequisite 

None.  
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III. Procedure  

Follow the steps below to query the STM-1 status:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select an NAOI on the equipment panel.  
3) Right-click on the NAOI and select Display STM-1 State on the shortcut menu. 

The system displays the Display STM-1 State dialog box.  
4) Set the parameter for STM1 No. in the dialog box and click OK.  

The system displays a dialog box listing the query result.  

 

  Note:  

You can query the Iub optical interface status only when the NAOI/NDTI works well or in 
alarm status.  

 

  Note:  

You can also query the Iub optical interface status of a specified board by the MML 
command of DSP STM1. 

 

7.4.8  Querying STM-1 Work Mode  

I. Introduction  

You can query the STM-1 work mode of an NAOI. The result shows the work mode of 
Iub optical interface links 0 and 1 of the NAOI. 

 

  Note:  

This command is valid for macro NodeBs only.  

 

II. Prerequisite 

None.  
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III. Procedure  

Follow the steps below to query the Iub optical interface work mode:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select an NAOI on the equipment panel.  
3) Right-click on the board and select Display STM-1 Work Mode on the shortcut 

menu.  
The system displays the Display STM-1 Work Mode dialog box.  

4) Set the parameter for STM1 No. in the dialog box and click OK.  

The system displays a dialog box listing the query result.  

 

  Note:  

You can query the STM-1 work mode only when the NAOI/NDTI works well or in alarm 
status.  

 

  Note:  

You can also query the STM-1 work mode of a designated board by the MML command 
of DSP STM1WORKMODE. 

 

7.4.9  Blocking/Unblocking Board  

I. Introduction  

You may block or unblock an HULP/NULP, HDLP/NDLP, HBBI, MTRU, MTRU or MAFU 
on a macro NodeB to locate faults without interrupting the system services. 

If a board is blocked, the board is available but cannot process services. Services on 
that board shall be cleared and those accessed afterwards shall be shifted to other 
boards. 

II. Prerequsite 

None.  
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III. Procedure  

Follow the steps below to block a board: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select a board on the equipment panel.  
3) Right-click on the board and select Block Board on the shortcut menu. The 

system displays a dialog box.  
4) Click Yes in the dialog box.  

The system displays the result and refreshes the board indicator.  

 

   Note: 

 You can block an HULP/NULP, HDLP/NDLP, HBBI, MTRU, MTRU or MAFU only 
when it is in normal or faulty state.  

 You can unblock a board only when it is blocked. 
 You can block or unblock the above boards repeatedly. 
 The procedure of unblocking a board is similar to that of blocking a board. You can 

unblock a board by right-clicking on a blocked board and then selecting Unblock 
Board.  

 

   Note: 

 You can also block a board by the MML command of BLK BRD. 
 You can also unblock a board by the MML command of UBL BRD. 

 

7.4.10  Resetting Board 

I. Introduction  

  Caution:  

Resetting a board may interrupt the services on the board.  

 

You can reset a board when it is faulty. The operation initializes and recovers the board. 
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II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to reset the board:  

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master 
Cabinet subnode.  
The system displays the equipment panel of the cabinet in the right pane.  

2) Select a board on the equipment panel.  
3) Right-click on the board and select Reset Board on the shortcut menu. The 

system displays a dialog box.  
4) Click Yes in the dialog box.  

The system displays the result and refreshes the board indicator.  

 

  Note:  

You can also reset a board by the MML command of RST BRD. 

 

7.4.11  Adding/Removing Board 

I. Introduction  

  Caution:  

The operation modifies the data configuration file of the NodeB.  

 

You can add or remove a board. This action changes the NodeB capacity. 

  Note:  

This command is valid for a macro NodeB only . 

 

II. Prerequisite 

None.  
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III. Procedure  

You can add or remove a board by an MML command:  

 Add a board by the MML command of ADD BRD. 
 Remove a board by the MML command of RMV BRD.  
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Chapter 8  Tracing NodeB Iub Interface Signaling 

8.1  About This Chapter 

This chapter describes the Iub interface signaling tracing as follows: 

 Overview 
 Creating NodeB Iub Interface Tracing Task 
 Browsing NodeB Traced Message 

8.2  Overview 

8.2.1  Principle of Tracing NodeB Iub Interface Signaling  

The tracing management is used to conduct routine equipment maintenance. The 
tracing to Iub interfaces and signaling links helps you verify the data and locate the 
faults. 

For example, after the equipment data configuration, you can check the signaling links 
by establishing tracing tasks. If the signaling links are abnormal, you can make 
preliminary fault location.  

Table 8-1 shows the procedure of Iub interface signaling tracing. 

Table 8-1 Procedure of Iub interface signaling tracing 

Step Action  Description  Reference 

1 Create a tracing 
task  

To start the Iub interface 
tracing 

See 8.3   "Creating 
NodeB Iub Interface 
Tracing Task" 

2 Browse traced 
messages online

To display reported traced 
messages by opening a 
message browse window 
after creating a tracing task 

See 8.4.1   "Browsing 
NodeB Traced 
Message" 

3 Save traced 
messages 

To save important traced 
messages as required 

See 8.4.3   "Saving 
NodeB Traced 
Messages " and 8.4.4   
"Saving NodeB Traced 
Messages " 

4 Stop tracing task To stop the tracing task -- 
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5 Browse traced 
messages offline

To browse the saved traced 
messages offline 

See 8.4.5   "Browsing 
NodeB Traced 
Messages" 

 

8.2.2  Introduction to NodeB Iub Interface Tracing 

The NodeB message tracing refers to the NodeB Iub interface tracing.  

The Iub interface is a standard open interface between the NodeB and the RNC in the 
WCDMA system. The Iub interface is used to transmit messages of the user plane, 
signaling plane and specific O&M. 

There are two tracing directions: 

 OUT: from NodeB to RNC (for a macro NodeB, from NMPT to Iub interface 
boards) 

 IN: from RNC to NodeB (for a macro NodeB, from Iub interface boards to NMPT) 

8.3  Creating NodeB Iub Interface Tracing Task 

I. Task Introduction 

Creating an Iub interface tracing task refers to starting the Iub interface tracing. This 
can trace all the Iub interface messages. 

After creating a tracing task, the system automatically sends two messages 
respectively to the master CPU and slave CPU of each available Iub interface board. 
The aim is to trace messages that the system sends and receives. The maximum 
message number that the system can send is 4 (number of boards) x 2 (the active and 
slave CPUs on the board) x 2 (two directions: send and receive) = 16. 

 

  Note: 

 Only one Iub interface tracing task can be created in the NodeB O&M system each 
time, and one message display window can be created for this tracing task. 

 The prompt for busy system and failure in starting a standard interface tracing task 
may lie in the overloaded CPU. It is recommended to start the tracing task 30 
seconds later when the CPU overloading is cleared.  

 

II. Prerequisite 

None.  
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III. Procedure 

Follow the steps below to create a tracing task: 

1) Choose Maintenance Navigator -> Tracing Management. Then double-click 
Standard Interface Tracing subnode.  
A prompt dialog box opens up. 

 

  Note: 

You may clear the check box of Show tips at startup next time in the dialog box. This 
dialog box does not appear when you start a tracing task next time. 

 

2) Click Continue in the dialog box.  
The Standard Interface Tracing dialog box opens up as shown in Figure 8-1.  

Figure 8-1 shows the Standard Interface Tracing dialog box. 

 

Figure 8-1 Standard Interface Tracing dialog box 

3) Click Advanced….  
The Advanced dialog box opens up as shown in Figure 8-2. 
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Figure 8-2 Advanced dialog box 

Table 8-1 describes the fields of the Advanced dialog box. 

Table 8-2 Field description of Advanced dialog box  

Field Description  

Auto Save 

Select Auto Save. The system saves reported messages in the 
Trace directory of the running version by default. You may 
modify the saving directory.  

Each reported message is to be saved in the message file. 

Maximum 
messages per 
window  

To set the maximum number of messages displayed in the 
message browse window 

Range: 100 to 5000  

Default value: 1000 

Flow control type 

Stop Show Message: If the message flow is too large, the 
system stops displaying messages on the interface.  

Stop Trace Task: If the message flow is too large, the system 
stops the tracing task.  

Message colour 

To set the display colors of messages in two directions  

 IN: from RNC to NodeB 
 OUT: from NodeB to RNC 

Both directions have 16 optional colors. 

 

4) Set parameters in the Advanced dialog box. 
5) Click OK.  

You are presented with the Standard Interface Tracing window as shown in 
Figure 8-3.  
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Figure 8-3 shows the Standard Interface Tracing window. 

 

Figure 8-3 Standard Interface Tracing window 

Table 8-3 describes the fields of the Standard Interface Tracing window.  

Table 8-3  Fields in the Standard Interface Tracing window 

Field  Description 

Message 
Sequence No. Sequence number of the message by arrival time 

Time Message arrival time in the format of YYYY-MM-DD HH:MM:SS 

Millisecond Traced message reporting interval: 100 ms 

Message 
Direction 

RNC->NodeB: from RNC to NodeB  

NodeB->RNC: from NodeB to RNC 

Message Type 
NBAP messages starting with NBAP_ 

ALCAP messages starting with ALL2_ 

Message 
Content 

The system translates the message contents displayed in binary 
into message codes according to the message type. 
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8.4  Browsing NodeB Traced Message  

8.4.1  Browsing NodeB Traced Message Online  

I. Introduction  

When you create a tracing task, the system starts a message browse window and 
displays the reported traced messages. The message browse window displays the 
traced messages in columns and adds messages in sequential order in real time. 

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to browse traced messages: 

1) Create a tracing task.  
For details, see 8.3   “Creating NodeB Iub Interface Tracing Task”.  

2) Double-click a message in the Standard Interface Tracing window. 
The message explanation window opens up as shown in Figure 8-4.  

Figure 8-4 lists details in the message explanation window.  
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Figure 8-4 Message explanation window 

The upper part of the window shows the explanation of the message and the lower part 
shows the source code.  

3) Click the Close button on the upper right corner of the window.  
The Standard Interface Tracing window and the message explanation 
window are closed. 

 

  Note: 

 To clear all message records in the window, right-click in the Standard Interface 
Tracing window, and select Clear All on the shortcut menu. The system clears all 
the message records from the list and displays the traced messages reported 
afterwards from the first line. 

 If you double-click another message with the message explanation window open, 
the system does not generate a new message explanation window but refreshes the 
explanations. The system explains only one message each time.  

 If you double-click multiple messages selected, the system explains the one clicked 
only.  

 For more detailed message explanations, see relevant interface protocol.  

 

Huawei Technologies Proprietary 

8-7 



NodeB LMT User Guide Chapter 8  Tracing NodeB Iub Interface Signaling
 

8.4.2  Setting Browsing Properties of NodeB Traced Message  

I. Introduction 

The following functions enable you to browse messages in the Standard Interface 
Tracing window:  

 Setting traced message color: When you create a tracing task, the system 
displays the traced results in different colors according to their transmission 
directions. IN is the color for messages from RNC to NodeB while OUT is the color 
for messages from NodeB to RNC. You can modify the value of IN and OUT. 

 Setting message window scroll: It is used to set whether to scroll the window.  
 Setting message filter: For the unimportant but frequently reported messages, you 

may choose to filter them. 

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to set traced message display: 

1) Right-click in the Standard Interface Tracing window. 
2) Select relevant menus on the shortcut menu. 

Table 8-4 shows how to set the browsing properties of the NodeB traced message.  

Table 8-4 Description of setting browsing properties of NodeB traced message 

Property Shortcut menu Description 

Traced message 
color setting 

Modify Color 
Settings 

You can also set the message color 
when creating an Iub interface tracing 
task. See 8.3   “Creating NodeB Iub 
Interface Tracing Task”. 

Message window 
scroll setting Automatic Scroll -- 

Message Filter 
setting Filter -- 
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8.4.3  Saving NodeB Traced Messages Automatically 

I. Introduction 

 Saving traced messages automatically indicates the system saves the reported 
messages in the format of *.tmf into the Trace directory of the running NodeB. You 
can select another new path. 

 When a message file does not satisfy the save condition, a new message file is 
generated. All message files related to the task are associated through the Index 
value. When a file is created, index value will ascend until the task is terminated. 

The message file name takes the following format: office direction name_Interface 
type_YYYY-MM-DD_HH-MM-SS[_Index].tmf, where, 

 YYYY-MM-DD_HH-MM-SS shows the task creation time.  
 YYYY, MM, DD, HH, MM and SS stands for year, month, day, hour, minute and 

second respectively. 
 Index indicates multiple traced message files created in an interface tracing task. 

The index value ascends from 1. 

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to save the reported interface traced messages automatically: 

1) Open the Standard Interface Tracing dialog box as shown in Figure 8-1. 
2) Click Advanced. 
3) Select Auto Save in the Advanced dialog box as shown in Figure 8-2. 

8.4.4  Saving NodeB Traced Messages Manually  

I. Introduction 

You can choose to save selected or all traced messages. 

II. Prerequistie 

None.  

III. Procedure 

Follow the steps below to save the selected traced messages manually: 

1) Right-click in the Standard Interface Tracing window. 
2) Select Stop Task on the shortcut menu. 
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3) Select the traced messages to be saved. Shortcut keys of Ctrl and Shift are 
applicable. 

4) Right-click on the messages and select Save Selected Record on the 
shortcut menu. 

5) Specify a path and name for the file.  
6) Click Save. 

Follow the steps below to save all the traced messages manually: 

1) Right-click in the Standard Interface Tracing window. 
2) Select Save All Records on the shortcut menu. 
3) Specify a path and name for the file.  
4) Click Save.  

8.4.5  Browsing NodeB Traced Messages Offline  

I. Introduction 

You can browse message files (*.tmf) offline with the TraceViewer.  

II. Prerequisite 

There are message files automatically saved by the system and manually saved by 
you.   

III. Procedure 

Follow the steps below to view traced messages offline: 

1) Select Service -> TraceViewer in the NodeB O&M system, or click the 

shortcut icon . 
2) Select the relevant NodeB version in the Select Version dialog box as shown 

in Figure 8-5. 
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Figure 8-5 Select Version dialog box 

3) Click OK and start the TraceViewer. 
4) Select the message file to be browsed in the Open dialog box. 
5) Click OK.  

The TraceViewer window is displayed.  
6) Double-click a message record in the window.  

You are presented with the explanations of it.  

 

  Note: 

You can carry out the following actions with the NodeB TraceViewer: 
 To save the selected messages to a message file, right-click on the message 

records and then select Save Selected Record on the shortcut menu.  
 Click different buttons on the title bar. Then the messages shall be sequenced 

according to message number, time, direction or type. 
 To filter the messages, right-click the mouse and then select Filter or Filter on 

Column on the shortcut menu. See section 8.4.6   "Filtering NodeB Traced 
Messages ".  

 

7) Select File -> Exit.  
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The message browse window is closed.  

8.4.6  Filtering NodeB Traced Messages  

I. Introduction 

The filtering traced messages function enables you to filter out unwanted messages. 
There are two ways for filtering messages:  

 Filtering messages with customized conditions: you can filter out unwanted 
messages according to one or more conditions by defining the filter.  

 Filtering messages on column: You can filter out unwanted messages according to 
the property of a column. 

II. Prerequisite 

None.  

III. Procedure 

Follow the steps below to define filters: 

1) Select Operate -> Filter… after opening a message tracing file, or right-click 
in an open message tracing file and then select Filter on the shortcut menu. 

2) Click New… in the Filter dialog box as shown in Figure 8-6. 

 

Figure 8-6 Filter dialog box 
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3) Set one or more filtering conditions in the Filter Define dialog box as shown in 
Figure 8-7. 

 

Figure 8-7 Filter Define dialog box 

4) Click OK.  
You are presented with the Filter dialog box. 

5) Select the defined filter and then click Apply. 

 

  Note: 

To perform invert filtering, select Reverse Filter in the Filter dialog box  

 

Follow the steps below to filter messages on column: 

1) Open a message file and then select a column of message records to be 
filtered. 

2) Right-click on the column.  
3) Select Filter on Column on the shortcut menu. 
4) Choose a message property in the drop-down list of the Column Filter dialog 

box. 
5) Click OK.  

You may cancel the message filtering as follows: 

 Choose Operate -> Cancel Filter, or   
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 Right-click in the TraceViewer window and then select Cancel Filter on the 
shortcut menu. 

The system displays all messages in the message file.  
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Notice


The information in this manual is subject to change without notice. Every effort has been made in the preparation of this manual to ensure accuracy of the contents, but all statements, information, and recommendations in this manual do not constitute the warranty of any kind, express or implied.


Summary of Updates


This section provides the update history of this manual and introduces the contents of subsequent updates.


Update History


This manual is updated for a major product version to maintain consistency with system hardware or software versions and to incorporate customer suggestions.

		Manual Version

		Notes



		T2-031640-20051230-C-1.60

		Initial field trial release





About This Manual


Release Notes

The product version that corresponds to the manual is WCDMA NodeB V100R006.

Organization

The manual describes routine maintenance of WCDMA NodeB.


There are fourteen chapters and one appendix in the manual.

Chapter 1 About This Manual describes general information about this manual. 

Chapter 2 Overview describes the local maintenance terminal (LMT) system and its elements.

Chapter 3 Installing LMT Application describes the installation of LMT software. 

Chapter 4 Getting Started with LMT describes how to log into the NodeB through the LMT. 

Chapter 5 Alarm Management describes how to manage the alarms on the NodeB though the LMT. 

Chapter 6 Managing Files describes how to upload and browse files. 

Chapter 7 Managing NodeB and Boards describes operations on the NodeB and the boards on the NodeB O&M system. 


Chapter 8 Tracing NodeB Iub Interface Signaling describes how to create tracing tasks and how to browse traced messages. 

Chapter 9 Monitoring NodeB Performance and State in Real Time describes how to monitor the NodeB performance and state in real time. 

Chapter 10 Monitoring External Environment of NodeB describes how to monitor the NodeB external environment.


Chapter 11 141 Test describes the NodeB RF performance tests.

Chapter 12 Managing NodeB Clock describes routine maintenance of the clock management system. 

Chapter 13 Managing NodeB Cells describes operations of the NodeB cell management system. 

Chapter 14 NodeB Software Update and Data Configuration File Transfer describes the NodeB software upgrade and data configuration file transfer.

Appendix A Acronyms and Abbreviations lists all acronyms and abbreviations in this manual with their full names.

Intended Audience

The manual is intended for the following readers: 

· Maintenance engineers and technicians


Conventions

This document uses the following conventions: 


I.  General conventions

		Convention

		Description



		Arial

		Normal paragraphs are in Arial.



		Arial Narrow

		Warnings, cautions, notes and tips are in Arial Narrow.





II.  Symbols

Eye-catching symbols are also used in this document to highlight the points worthy of special attention during the operation. They are defined as follows:

[image: image4.wmf]  Caution, Warning, Danger: Means reader be extremely careful during the operation.

(  Note, Comment, Tip, Knowhow, Thought: Means a complementary description.[image: image5.wmf]
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Chapter 1   About This Manual 

1.1   Purpose of This Manual

This manual describes

· Installation of the NodeB local maintenance terminal (LMT)

· Functions and interfaces of each element in LMT 

· Operation guide to NodeB routine operation and maintenance

The NodeB routine maintenance is mainly conducted through the iManager M2000 server. For O&M guide to the M2000 server, see iManager M2000 Mobile Element Management System Operation Manual.

1.2   Intended Audience

This manual is intended for those who operate and maintain the NodeB on the LMT system. They must have basic operation skills of MS Windows operating system and understandings of the NodeB. 

1.3   Architecture of This Manual 

There are 14 chapters and an appendix in this manual. 

· Chapter 1: describes general information about this manual. 


· Chapter 2: describes the local maintenance terminal (LMT) system and its elements.

· Chapter 3: describes the installation of LMT software. 

· Chapter 4: describes how to log into the NodeB through the LMT. 

· Chapter 5: describes how to manage the alarms on the NodeB though the LMT. 

· Chapter 6: describes how to upload and browse files. 

· Chapter 7: describes operations on the NodeB and the boards on the NodeB O&M system. 

· Chapter 8: describes how to create tracing tasks and how to browse traced messages. 

· Chapter 9: describes how to monitor the NodeB performance and state in real time. 

· Chapter 10: describes how to monitor the NodeB external environment.

· Chapter 11: describes the NodeB RF performance tests.

· Chapter 12: describes routine maintenance of the clock management system. 


· Chapter 13: describes operations of the NodeB cell management system. 


· Chapter 14: describes the NodeB software upgrade and data configuration file transfer. 
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Chapter 2   Overview

2.1   About This Chapter

This chapter describes the local maintenance terminal (LMT) system and its elements, including:

· Functions

· Configuration requirements


· Compositions


· Main interfaces


2.2   Introduction to LMT

2.2.2   Functions of LMT


The LMT of the NodeB series provides graphic user interface (GUI) for

· NodeB test

· Local maintenance

· Troubleshooting


2.2.3   LMT Configuration Requirements 

The computer used to install the LMT software must meet the following requirements:

· Software 


· Hardware


· Communications

I.  Hardware Configuration Requirements 

Table 2-1 shows the hardware configuration requirements to be met for the computer used to install the LMT software. 

Table 2-1  Hardware configuration list

		Item

		Quantity

		Recommended configuration

		Minimum configuration



		CPU

		1

		2.4 G

		400 M



		RAM

		1

		512 M

		64 M



		Hard disk

		1

		40 G

		1 G (the minimum available space)



		Display adapter resolution

		--

		1024 x 768

		800 x 600



		CD drive

		1

		--

		--



		Network adapter

		1

		10&100 M

		10&100 M



		Others

		1 x 3

		Modem, sound card and sound box

		--





II.  Software Configuration Requirements 

Table 2-2 shows the software configuration requirements to be met for the computer used to install the LMT software. 

Table 2-2  Software configuration list

		Item

		Standard configuration



		Operating system

		Windows 2000 Professional (SP4) or above of English



		Default language of operating system

		Western Europe and United States



		Web browser

		Microsoft Internet Explorer 5.5 or above





(  Note: 

It is recommended that the LMT software be installed in a standard operating system. Otherwise, they might not be compatible.

III.  Communications Requirements 

The computer supports the TCP/IP protocol. 

2.3   LMT System Composition 

2.3.2   Overview 

The LMT communicates with the NodeB through LAN or WAN. You can maintain a NodeB through the LMT computer.

The NodeB LMT consists of

· NodeB O&M system


· NodeB alarm management system


· TraceViewer

2.3.3   NodeB O&M System

I.  Functions

The O&M system provides MML client and GUI access to maintain NodeB, including:

· Operating MML client: runs a single command on the platform of the MML Client.

· Tracing management: manages the tracing messages of Iub interface. 

· Software management: downloads and backs up configuration files, and upgrades software.

· Realtime state monitoring: including CPU/DSP occupancy, board or cell service resource query, RTWP measurement, and clock test.

· Test management: supports 141 tests.

· Equipment maintenance: controls board reset and block/unblock, and helps retrieve board data.

· Clock maintenance: provides routine maintenance for the NodeB timing.


· Cell management: retrieves and modifies NodeB cells data, and blocks or unblocks NodeB cells.

II.  Interface 

The interface of the NodeB O&M system consists of:


· System menu 

· Toolbar 


· Navigation tree pane 


· Object pane 


· Output pane 


· Status bar 


· MML client 


Figure 2-1 shows the NodeB O&M System window.

[image: image1.png]

Figure 2-2 NodeB O&M System window

Table 2-3 describes the fields of the NodeB O&M System window.

Table 2-3  Filed description of O&M System window

		No.

		Field 

		Description



		1

		Menu bar

		The menu bar includes System, Service, View, Window and Help menus.


The System and Service menus provide access to logging into the operating system.


The View, Window and Help menus are similar to those in other commonly used application programs. 



		2

		Toolbar

		The toolbar provides shortcut icons including:


· Re-login


· Exit


· Lock System


· Office Management


· Show/Hide other window



		3

		Navigation tree pane

		There are three tabs at the bottom of the pane, including:


· Maintenance Navigator: The navigator provides important routine operations through a GUI interface.


· MML Navigator: The navigator provides all MML commands.

· Search. In this tab, you can retrieve MML commands by command name or by command word. The system lists all the commands matching your input automatically to make the retrieval faster.



		4

		Object pane

		This pane provides details about the object. You can maintain the NodeB through this pane.


If you select Maintenance Navigator in the navigation tree pane, the pane contains an upper curve graph and a lower list of description.

If you select MML Navigator, the pane contains the MML Client.



		5

		Output pane

		The pane records detailed information of current operations and system feedback. At the bottom of the pane, there are four tabs as follows:


· Maintenance Output: It displays results of operations and auto reported information.


· Debug Output: It displays the contents in Maintenance Output in binary.


· Test Output: It displays the result of 141 test.


· Alarm output: It displays alarms reported by the NodeB.



		6

		Status bar

		The bar is at the bottom of the interface. It displays 

· Connected office

· IP address of the office

· Connection status





III.  Online Help 

The NodeB O&M system provides two kinds of online help:

· NodeB O&M system help


· MML help


Table 2-4 shows the main contents and starting modes of these helps. 


Table 2-4 Online helps of NodeB O&M system 

		Name 

		Main contents

		Starting mode



		NodeB O&M system help

		It provides the following information about the NodeB O&M system: 

· Field meaning of the dialog box


· Description of and operation guide to each O&M function

· Detailed information about the board

		There are three starting modes in the NodeB O&M window, 

· Press F1 or select Help -> Help topics to display the NodeB O&M System Help window. 


· Click [image: image2.png] to display the help information.

· Click Help in a dialog box to show the help information.



		MML help 

		It provides the following information about each MML command: 

· Function 

· Note

· Parameter


· Example

		1) Execute a command in the MML client of the NodeB O&M system.

2) The Help window displays information about this command.





(  Note: 

This manual does not present detailed description of the MML commands involved. For more information about the MML commands, see MML Command Help.

2.3.4   NodeB Alarm Management System

I.  Functions

The NodeB alarm management system serves as a major tool for routine alarm management. With this system, you can: 


· Browse alarm information, including fault alarm information and event alarm information.


· Query alarm information, including active alarms, alarm log, alarm configuration, and alarm details. 


· Maintain alarm information by modifying or restoring alarm configuration.


· Set attributes of fault alarm notification, including sound duration, fixed-line phone number and mobile phone number.


· Print and save alarm records, including browsed and reported alarm records.


For details, see Chapter 5 “Alarm Management”. 

II.  Interface 

The interface of the NodeB alarm management system consists of 

· System menu


· Toolbar


· Fault alarm browse window

· Event alarm browse window

· Status bar 


Figure 2-2 shows the BTS3812E Alarm Management System window.

[image: image3.png]

Figure 2-3  BTS3812E Alarm Management System window

Table 2-5 describes the elements of the BTS3812E Alarm Management System window.

Table 2-5  Elements of BTS3812E Alarm Management System window

		No.

		Field 

		Description



		1

		Menu bar

		The menu bar provides access to most operations of the system. 



		2

		Toolbar

		The toolbar provides shortcut icons for common operations, including

· Relogin


· Office Management


· Toggle Lock System


· Display Color Setting

· Fault Alarm Browse


· Event Alarm Browse


· Query Alarm Log 



		3

		Fault alarm browse window

		The window displays the current fault alarm. 



		4

		Event alarm browse window

		The window displays the current event alarm.



		5

		Status bar

		The bar is at the bottom of the interface. 

It displays

· IP address of the connected office

· Connection status

· Messages between the system and the NodeB





III.  Online Help 

Table 2-6 shows the main contents and starting modes of the NodeB Alarm Management System Help. 

Table 2-6 Online help of NodeB alarm management system 

		Name 

		Main contents

		Starting mode



		NodeB alarm management system help

		It provides the following information about the NodeB alarm management system:

· Field meaning of the dialog box 

· Description of and operation guide to each alarm management function 

		In the NodeB alarm management system window, 


· Press F1 or select Help -> Help topics to display the NodeB Alarm Management System Help. 


· Click [image: image4.png] to display the NodeB Alarm Management System Help. 

· Click Help in a dialog box to display the help information. 





2.3.5   TraceViewer

I.  Function 

The TraceViewer simulates the online environment and opens saved message files in the offline environment. It facilitates the browse of traced messages.

For details, see Chapter 8 “Viewing Traced Messages Offline”. 

II.  Interface 

Figure 2-3 shows the BTS3812E TraceViewer window.

[image: image5.png]

Figure 2-4  BTS3812E TraceViewer window 

Table 2-7 describes elements of the BTS3812E TraceViewer window. 


Table 2-7  Elements of BTS3812E TraceViewer window 

		No.

		Field 

		Description



		1 

		Menu bar

		Providing most of the functions of the TraceViewer. 



		2 

		Toolbar

		Providing the Open shortcut icon.



		3 

		Message browse pane

		Displaying messages by tracing the Iub interface. 



		4 

		Status bar

		Located at the bottom of the window, displaying

· Connected office

· IP address of the office

· Network status





III.  Online Help 

Table 2-8 shows the main contents and starting mode of the NodeB TraceViewer Help. 


Table 2-8  Online help of the NodeB TraceViewer 

		Name 

		Main contents

		Starting mode



		NodeB TraceViewer help 

		It describes the usage of each message browse function of the NodeB TraceViewer.

		In the TraceViewer window, 


· Press F1 or select Help -> Help topics to display the NodeB TraceViewer Help. 

·  Click Help in a dialog box to display the help info-rmation. 
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Chapter 3   Installing LMT Application


3.1   About This Chapter


This chapter describes 


· Software installation preparation


· Installation process


· Confirmation after installation.

3.2   Installation Introduction


3.2.1   Preparing for Installation


Prepare as follows before installing the LMT software: 


· Obtain the installation disk and instruction provided by Huawei.


· Obtain valid serial number of the LMT software.


· Log into the MS Windows 2000 or MS Windows XP operating system with the administrator authority.


3.2.2   Impact on System 


Installing the LMT software shall have the following impact on the system: 


· Creating a shortcut on the desktop


· Creating a program group of Start -> Program -> Huawei Local Maintenance Terminal. The Huawei Local Maintenance Terminal menu includes sub-menus of 


· NodeB Operation & Maintenance System

· Uninstall NodeB Operation & Maintenance System

· Copying NodeB LMT V1.5 to the selected directory of NodeBV100R005ENG

3.3   Installing LMT Software 


Follow the steps below to install the NodeB LMT software.


(  Note: 


To install the LMT software, there are three modes: 

· Initial installation of LMT software


· Modify installation of LMT software


· Repair installation of LMT software


This manual adopts the initial installation mode to introduce the LMT software installation. 


I.  Starting Installation Program

Follow the steps below to start the installation program:


1) Insert the installation disk into the disk drive.


2) The installation program automatically runs.


Or you may follow the steps below:


3) Copy the installation software package into the hard disk.


4) Open the file folder of disk1.


5) Double-click Setup.exe.


Then the installation program is started. 


II.  Choosing Setup Language 


Follow the steps below to choose the setup language:


1) Start the installation program. 
The Choose Setup Language dialog box opens up as shown in Figure 3-1. 


[image: image1.png]

Figure 3-1 Choose Setup Language dialog box 


2) Choose English in the list box and click OK. 


3) Click Next in the Welcome dialog box after the installation program initialization completed.


Figure 3-2 shows the Welcome dialog box.  

[image: image2.png]

Figure 3-2  Welcome dialog box


(  Note: 


· Click Cancel to display the quit installation interface. You may choose whether to quit or continue the installation. 


· Back is not available in the first installation step. In later steps, Back is available to go back to the previous step. 

III.  Confirming License Agreement 


To accept this agreement after reading it, click Yes. Otherwise, click No to quit the installation program. 

Figure 3-3 shows the License Agreement dialog box. 


[image: image3.png]

Figure 3-3 License Agreement dialog box


IV.  LMT Software Installation Guide


Read the installation guide in the Information dialog box carefully and click Next. 

Figure 3-4 shows the Information dialog box. 


[image: image4.png]

Figure 3-4  Information dialog box 


V.  Verifying Serial Number 


Enter the customer information and valid serial number in the Customer Information dialog box, and then click Next. 


Figure 3-5 shows the Customer Information dialog box. 


[image: image5.png]

Figure 3-5  Customer Information dialog box


(  Note: 


· The serial number is provided with the installation disk and contained in the Serial. txt file of the software package. 


· Next is available only after you enter the user name, company name and serial number. 


· Enter the valid serial number. Note that the serial number is case sensitive. 


· If the serial number is invalid for three times, the installation program shall automatically quit from the present installation program. 


VI.  Choosing Destination Location 


Click Browse to select the folder where Setup will install files. Or click Next to install files under C:\HWLMT by default. 


Figure 3-6 shows the Choose Destination Location dialog box. 


[image: image6.png]

Figure 3-6  Choose Destination Location dialog box 

VII.   Selecting Setup Type 


Figure 3-7 shows the Setup Type dialog box. 


[image: image7.png]

Figure 3-7 Setup Type dialog box 

There are three setup types: 


· Typical: The program installs all the components to maintain all the NodeB models and versions supported by the LMT software. Most users are recommended to install the software with this type. 


· Compact: The program installs part of the components only to maintain the latest version of the NodeB supported by the LMT software of that model. 


· Custom: the program installs the selected components. It is recommended for advanced users. 

Select the needed setup type and then click Next. It is recommended for most users to select Typical. 


If you select Custom, 


2) Click Next. 


3) Tick the needed components in Select Components dialog box as shown in Figure 3-8.

[image: image8.png]

Figure 3-8 Select Components dialog box


4) Click Next in the Select Components dialog box. 

VIII.  Selecting Program Folder 


Figure 3-9 shows the Select Program Folder dialog box. 


[image: image9.png]

Figure 3-9 Select Program Folder dialog box


You can rename the program folder or use the default name. It is recommended that you use the default program folder name and click Next. 


IX.  Copying Files 


Figure 3-10 shows the Start Copying Files dialog box. 


[image: image10.png]

Figure 3-10 Start Copying Files dialog box 


Confirm all the information. Then Click Next to create a folder C:\HWLMT and copy files into it. 


When copying files, a progress indicator indicates the setup progress, file types and file setup path as shown in Figure 3-11.


[image: image11.png]

Figure 3-11 Setup Status dialog box 


X.  Finishing Installation 


Figure 3-12 shows the Installation Completed dialog box. 


[image: image12.png]

Figure 3-12 Installation Completed dialog box


Follow the steps below to finish the installation of the LMT software, update the system setup, open the readme.txt, and start O&M system for login interface: 


2) Tick Start readme.txt and Start Operation_Maintenance System.

3) Click Finish. 


If you click Finish without ticking Start readme.txt and Start Operation_Maintenance System, you can finish the LMT software installation and update the system setup. 


(  Note:


If the system finds locked files or files under share during the installation, an InstallShield Wizard Complete dialog box shall prompt you to restart the computer, as shown in Figure 3-13. If so, choose Yes, I want to restart my computer now. and click Finish. 

[image: image13.png]

Figure 3-13 InstallShield Wizard Complete dialog box


3.4   Verifying Installation 


After the LMT software installation, the program copies the WCDMA NodeB LMT programs into the file folder under the selected path. If you use the default installation directory, the entire file package of LMT software is copied to C:\Hwlmt. 


Figure 3-14 shows the directory architecture of the LMT software. 


[image: image14.png]

Figure 3-14 Directory architecture of the LMT software


Table 3-1 describes the directory at different levels. 


Table 3-1 Description of the directory at different levels

		Directory 

		Description 



		Bin

		Storing public files, such as *.dll files which assist operation control.



		BBU3806V100R005C01B030…

BTS3812AV100R005C01B065…

BTS3812EV100R006C01B013…

		Storing files related to this NodeB version. Each folder has the same architecture including the following sub-folders: 


bin: storing execution files related to this version 


wh_mes: storing interface tracing resolution files related to this version


data: storing data files related to this version


Map: storing .map files related to this version for the purpose to find problems in case of exceptional conditions 


OnLineHelp: storing online help files related to version 



		Data

		Storing data files unrelated to this version



		Map

		Storing *.map files to locate problems in case of exceptional conditions 



		OnLineHelp

		Storing online help files unrelated to this version





(  Note: 


When you use the LMT software, the system creates new file folders under NodeB V100R005: 


· Output: default folder for file output 


· Trace: to save traced files


· Log: to save LMTFrame.log files and LMTFTool.log files
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Chapter 4   Getting Started with LMT


4.1   About This Chapter


This chapter describes how to login to the NodeB through the LMT, including


· Starting LMT

· Configuring LMT

· Managing Office

· Locking LMT

· Executing MML Commands

· Exiting LMT

4.2   Starting LMT


4.2.1   Overview

Before starting the LMT, complete the following operations:


· Set IP address of the LMT computer 


· Connect the LMT computer to the NodeB 


4.2.2   Setting IP Address for LMT Computer


I.  Introduction


[image: image1.wmf]  Caution: 

Make sure the IP address of the LMT compter does not confict with another IP address of a computer within the same local area network. 

You have two ways to maintain the NodeB on the LMT: 


· Local maintenance 


· Remote maintenance 


When you conduct the local maintenance, set the IP address for the LMT computer as follows: 


· For the macro NodeB, IP addresses of the LMT computer and the NMPT network port need to be in the same network segment. 


· For the DBS3800, IP addresses of the LMT computer and the BBU need to be in the same network segment.


II.  Prerequisite 


The LMT computer has configured the TCP/IP protocol.  

III.  Procedure

(  Note:

Microsoft® Windows 2000 (SP4) is the product of Microsoft. For details, refer to the technical documents of Microsoft® Windows 2000 (SP4).

All the Microsoft-related corporate names, trademarks and technical documents are properties of Microsoft Corporation.

Follow the steps below to set the IP address of the LMT computer with the MS Windows 2000 (SP4) operating system as an example: 


1) Choose Start -> Settings -> Control Panel.  
The Network and Dial-up Connection window opens up. 

2) Right-click the icon of Local Area Connection. 
The Local Area Connection Status dialog box opens up.  


3) Select Properties on the shortcut menu. 
The Local Area Connection Properties dialog box opens up. 


4) Select Internet Protocol (TCP/IP). 


5) Click Properties. 
The Internet Protocol (TCP/IP) Properties dialog box open up.


6) Select Use the following IP address.

7) Enter the correct IP address, subnet mask and default gateway. 


(  Note: 

· In near end O&M mode, the default IP address of all debugging Ethernet ports of the NodeB for local maintenance is 17.21.2.15.

· The subnet mask is 255.255.0.0. 


· If there is no gateway, you can keep the field Default Gateway blank or enter the IP address of the LMT. If there is a gateway, enter the IP address of the gateway.

8) Click OK.


The setting is completed. 

4.2.3   Connecting LMT Computer to NodeB 


I.  Introduction 


There are two ways to maintain the NodeB through the LMT. Correspondingly, there are two ways to connect the LMT computer to the NodeB. 

II.  Prerequisite

None. 

III.  Procedure 


Under the local maintenance mode:


· For the macro NodeB, connect the Ethernet port of the LMT computer to that of the NodeB NMPT through crossover network cables, as shown in Figure 4-1. Or you can connect the LMT computer to the NodeB NMPT through a HUB by using straight-thru cables. 


· For the DBS3800, connect the Ethernet port of the LMT computer to the upper ETH port of the BBU front plate with crossover network cables, as shown in Figure 4-2. Or you can connect the LMT computer to the BBU through a HUB by using straight-thru cables. 


[image: image2.wmf](2)
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		(1) NMPT

		(2) Network cable 

		(3) LMT computer 





Figure 4-1 Connecting LMT computer and NMPT under local maintenance mode 


[image: image3.jpg]

		(1) BBU3806

		(2) Crossover cable 

		(3) LMT computer 





Figure 4-2 Connecting LMT computer and BBU3806 under local maintenance mode

Under the remote maintenance mode: 


· You can connect the Ethernet port of the LMT computer to that of the back administration module (BAM) on the RNC directly. 


· You can connect the Ethernet port of the LMT computer to that of the RNC BAM through a gateway.


· No matter how the LMT computer and the NodeB are connected, you can check the connection with a ping command. 


4.2.4   Logging into NodeB Through LMT


I.  Introduction

You may operate and maintain a NodeB by starting the LMT and logging into the NodeB. 


II.  Prerequisite


Physical connection between the LMT computer and the NodeB is good under the local maintenance mode. 


III.  Porcedure 


Follow the steps below to login to the NodeB through the LMT: 

1) Choose Start -> Program -> Huawei Local Maintenance Terminal -> NodeB V100R005 -> NodeB Operation & Maintenance System. 
If the NodeB O&M system has started, select System -> Login, or click the shortcut icon [image: image4.png] to display the Login dialog box as shown in Figure 4-3.

[image: image5.png]

Figure 4-3 Login dialog box


Table 4-1 describes the fields in the Login dialog box. 


Table 4-1 Field description of Login dialog box

		Field 

		Description 



		User name

		It is the name used to log into NodeB. It is case sensitive and cannot be omitted. The default name is admin.



		Password 

		It is used to log in to NodeB. It starts with letter, and is case sensitive. It is a string of up to 16 characters and contains only letters and numbers. 



		Office 

		It is the name of the NodeB to which the O&M system is connected. 

 Click Office Management to edit the office information. For details, see 4.4   “Managing Office”. 



		IP address 

		This is the IP address of NodeB to which the LMT system is connected. It is unique to the office name.





(  Note: 


If there is no office in the Office Management dialog box as shown in Figure 4-5, set the parameters in the dialog box with reference to 4.4   "Managing Office".

2) Set parameters in the Office Management dialog box.


3) Set the user information and IP address in the Login dialog box. 


4) Click OK.


Then you log into the NodeB. 


4.2.5   Logging into NodeB Through M2000 Server 


I.  Introduction 


You may conduct centralized maintenance to NodeBs by logging into the M2000 server. 

II.  Prerequisites 


None.

III.  Procedure


Follow the steps below to log into the NodeB through the M2000 server: 

1) Choose Start -> Program -> Huawei Local Maintenance Terminal -> NodeB V100R005 -> NodeB Operation & Maintenance System. 
If the NodeB O&M system has started, select System -> Login, or click the shortcut icon [image: image6.png] to display the Login dialog box as shown in Figure 4-3. 

2) Set IP address, user name, and password in the Login dialog box.
This enables you to log into the M2000 server. 


3) Click OK.
The NodeB List dialog box opens up. 


4) Select the NodeB to be maintained in the dialog box. 


5) Click OK and enter your user name and password.


Then you log into the NodeB. 

4.3   Configuring LMT


4.3.1   Configuring LMT Attributes


I.  Introduction


Configurations of the LMT attributes include: 


· Setting the office


· Setting the time-out time of MML commands


· Setting the system lock time 


· Executing batch commands 

II.  Prerequisites


None. 

III.  Procedure


Table 4-2 shows configurations of the LMT attributes. 

Table 4-2 Configurations of the LMT attributes


		LMT attribute

		Menu

		Remarks 



		Office management 

		System -> Office Management 

		See 4.4   “Managing Office”. 



		Setting time-out time of MML commands

		System -> System Configuration 

		See 4.6.3   "Executing Batch MML Commands"



		Setting system lock time 

		System -> System Configuration

		See 4.5   "Locking LMT"



		Executing batch MML  commands 

		System -> Execute Batch Commands

		See 4.6.3   "Executing Batch MML Commands"





4.3.2   Changing Login Password 


I.  Introduction 


Changing the login password refers to changing the password for logging into the NodeB. You can log into the NodeB only when you provide the correct password. 

II.  Prerequisite


None. 

III.  Procedure 


[image: image7.wmf]  Caution: 


· New password takes effects for new users to log into the NodeB. If you have logged in to the NodeB, it does not affect your current state. 


· The M2000 server user and the NodeB O&M user have the authority to change the login password. The NodeB alarm management user has no authority to change the login password. 

Follow the steps below to modify the login password: 

1) Choose System -> Change Password. 
The Change Password dialog box opens up, as shown in Figure 4-4. 


[image: image8.png]

Figure 4-4 Change Password dialog box


2) Enter the old and new passwords in the dialog box.


3) Click OK.


Then the password is changed.

4.4   Managing Office


I.  Introduction


Managing office refers to setting IP address of the M2000 server or NodeB that the LMT connects. 


Generally, one office uses one name to identify different IP addresses. A NodeB O&M system may have different office information to connect to a specified M2000 server or NodeB. 


II.  Prerequisites


None.

III.  Procedure


Follow the steps below to manage the office: 

1) Choose System -> Office Management, or click the shortcut icon [image: image9.png]. 
The Office Management dialog box opens up, as shown in Figure 4-5.

[image: image10.png]

Figure 4-5 Office Management dialog box


Table 4-3 describes the fields in the Office Management dialog box. 


Table 4-3  Field description of the Office Management dialog box


		Filed 

		Description 



		Office 

		It is the name of M2000 server or the NodeB to which the NodeB O&M system connects. It is a string of up to 80 characters or 40 Chinese characters defined by you. 



		IP address 

		It is the M2000/NodeB IP address. It is unique to the “office”. 



		Add 

		You can add other M2000 server or NodeB office information by clicking Add to display the Office Information dialog box.



		Delete 

		You can delete an office by selecting that office and click Delete. 



		Modify 

		You can modify office information by selecting an office and clicking Modify. 





2) Set the office information in the dialog box. 


3) Click OK. 

The setting is completed. 


4.5   Locking LMT 


I.  Introduction 


The NodeB O&M system provides lock function to ensure its safe operation. You can set system lock when you do not use the system so as to prevent illegal operation from others. Once the system is locked, you need to enter the correct password before further operation. 

The NodeB O&M system has two lock modes: 


· Lock by schedule 


· Lock Now


(  Note: 


The lock function locks the interface of the NodeB O&M system only. It is similar to the screen saver of the MS Windows operating system. 

II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to conduct Lock Now of the NodeB O&M system: 


1) In the NodeB O&M system, to lock the system interface immediately, there are three ways: 


· Choose System -> System Lock

· Press the shortcut key F12

· Click the shortcut icon [image: image11.png]. 


Then the Please Input Your Password dialog box opens up after the system is locked.


2) Enter your password and click OK to remove the lock. 


Follow the steps below to conduct Lock by schedule of the NodeB O&M system: 


3) Choose System -> System Configuration. 
The System Configuration dialog box opens up as shown in Figure 4-6. 


[image: image12.png]

Figure 4-6 System Configuration dialog box


Table 4-4 describes the fields in the System Configuration dialog box. 


Table 4-4 Field description of System Configuration dialog box 

		Field 

		Description 



		Command timeout 

		It is the name used to set command time-out time. The value range is from 10 seconds to 600 seconds and the default value is 65 seconds. The command fails to execute when it exceeds the time-out limitation. 



		Set lock time 

		It is the name used to set the system lock time. The value range is from 0 to 100 minutes and the default value is 5 minutes. 0 is not to lock the time. After you set the system lock time and have no operation within that period, the system auto locks till you type in the correct password. 



		FTP Server 

		The FTP server is used to transfer the software package and data files to the NodeB. 


You can set the user name and password of the FTP server built in the LMT computer. The system has initial default values for use. You need not to change them. 


The user name and password are both a string of up to 16 characters including letters, numbers and underlines. 





4) Set the lock time in Set lock time of the dialog box. 


5) Click OK.


The setting is completed. 


4.6   Executing MML Commands 


4.6.1   Introduction to MML Commands 


I.  Functions of MML Commands 


The NodeB MML command helps to maintain the entire NodeB. The functions are: 

· System management

· Equipment maintenance 


· Iub Interface management

· Local cell management

· Alarm management


II.  MML Command Format 


All MML commands are in the format of Command: Parameter Name=Value;.

The command is mandatory while the parameter name and value are not.


· An example of an MML command with a command and parameters: SET ALMSHLD: AID=10015, SHLDFLG=UNSHIELDED;

· An example of an MML command with a command only: LST VER:;

III.  MML Command Parameter 


The MML client distinguishes parameters of different attributes by different colors. For details, see Table 4-5. 

Table 4-5 Colors for different parameter attributes

		Color of parameter name 

		Meaning 

		Details 



		Red

		Mandatory

		You must set the red parameters. Otherwise, the system returns failure.



		Black

		Optional

		For commands starting with LST and DSP, if you fail to set an optional parameter, the system returns all the data.



		

		

		For commands starting with ADD, if you fail to set an optional parameter, the system takes its default value if any or takes it as null.



		

		

		For commands starting with MOD and SET, if you fail to set an optional parameter, the parameter value remains unchanged.





IV.  MML Command Types 


The MML command format is Action + Object. For details, see Table 4-6. 

Table 4-6 MML command types 

		Action

		Meaning



		ACT

		To activate



		ADD

		To add



		BKP

		To back up



		BLK

		To block



		DLD

		To download



		DSP

		To display dynamic information



		SET

		To set



		LST

		To list static data 



		MOD

		To modify



		RMV

		To remove



		RST

		To reset



		STR

		To start



		STP

		To stop 



		UBL

		To unblock



		ULD

		To upload 





4.6.2   Executing a Single MML Command 


I.  Introduction 


Troubleshooting requires executing a single MML command.

II.  Prerequisite

None. 

III.  Procedure 


Follow the steps below to execute a single MML command: 

1) Click MML Command Navigation Tree in the navigation tree pane. 


2) Select an MML command and double click on it to start the MML Client. The command is shown in the Command Input box and the parameter input area is displayed.

(  Note:


If you start the MML Client by selecting View -> Command Window on the menu of the O&M system, or by clicking the shortcut icon [image: image13.png], there is no MML command in the Command Input field. You need to enter a command manually, and then click [image: image14.bmp] to display the parameter input area.


3) Set the parameters. 

(  Note: 


For deails, see the Online Help page. 


4) Click the icon [image: image15.bmp] to execute the command. View the results in Common Maintenance page. 

4.6.3   Executing Batch MML Commands 


I.  Introduction 


Executing batch MML commands refers to compiling a series of commands into a batch file and then run the file to perform a function or an operation. 


There are two modes to execute batch MML commands:


· Execute batch MML commands by schedule 


· Execute batch MML commands now 


II.  Prerequisites 

· Batch MML command files have already been created.


The batch file (also referred to as the data script file) is a plain text file (*.txt). It stores a group of commands that can perform a common function or a specific task in a *.txt file. Therefore, you can simply run the file instead of entering the commands one by one.

There are three ways to create batch MML command files: 


· Create a *.txt file and write the commands into the file. Be sure to write one command in a line.


· Copy the information in History Command drop-down box in the output pane and save it in a blank *.txt file. 


· Choose System -> Save Command -> Start Save Input Command… to save the used commands. 

III.  Procedure 

Follow the steps below to execute the batch MML command by schedule: 


1) Choose System -> Execute Batch Commands, or press Ctrl+R. 
The Execute Batch Commands dialog box opens up, as shown in Figure 4-7.


 [image: image16.png]

Figure 4-7 Execute Batch Commands dialog box


Table 4-7 describes the fields of the Execute Batch Commands dialog box. 

Table 4-7 Field description of the Execute Batch Commands dialog box 

		Field 

		Description 



		Select Batch Command File 

		To specify the batch file to run


The default file directory is Bin under the installation directory. Note that the file must be a *.txt file edited by following correct MML command syntax with one MML command in a line. 



		Set Execution Mode 

		To select the execution mode Execute now or Execute by schedule for batch processing


If you select Execute by schedule, you will have to set the specified Date and Time. 

If you select Execute now, you may also select User interface.



		File Executed by Schedule 

		It lists the information of all the files and their Scheduled Time set in the Execute by schedule mode. 



		Add 

		You can click Add to add a batch file to the File Executed by Schedule list, after selecting the batch file and setting the time to run it.



		Delete 

		You can select a scheduled task from the File Executed by Schedule list and click Delete to delete it.





2) Select Execute by schedule under Set Execution Mode.

3) Set the execution date and time in Date and Time under the Execute by schedule mode. 

4) Click Browse to select the batch file.

5) Click Add to add the batch file into the File Executed by Schedule list.


6) Repeat steps 3) to 5) to add all the needed batch files into the list.

7) Click OK.


The setting is completed and the Maintenance Output tab in the window displays the results. 


Follow the steps below to execute the batch MML commands now: 


8) Choose System -> Execute Batch Commands, or press Ctrl+R. 
The Execute Batch Commands dialog box opens up, as shown in Figure 4-7. 

9) Click Browse to select the batch file.

10) Select Execute now and User interfere under Set Execution Mode.

11) Click OK.
The Execute now dialog box opens up, as shown in Figure 4-8.

[image: image17.png]

Figure 4-8 Execute now dialog box

Table 4-8 describes the fields of the Execute now dialog box. 

Table 4-8 Field description of the Execute now dialog box 

		Field 

		Description 



		Run All 

		The system runs in turn all the commands in the batch command file.


Method: Select Run All and then click Run.


Note: During the process, the icon [image: image18.png] points to the command being executed.



		Step Run

		The system runs one command in the batch command file at a time. 


Method: Select Step Run and then click Run.


Note: During the process, the icon [image: image19.png] points to the command being executed. You can click Stop to stop the running.



		Breakpoint Run

		The system runs the commands in the batch command file in turn until a breakpoint. 

Method: Select Breakpoint Run. Click on a command and click Breakpoint to set a breakpoint. Click Run to start running from the beginning. Click Stop to stop running during the process.

The icon [image: image20.png] points to the command being executed. 

The icon [image: image21.png]points to the specified breakpoint.



		Run Range

		To specify a range in the batch file to run


Method: Select Run Range, enter the start row and end row, and then click Run.





(  Note: 

If you select Execute now without selecting User interfere and click OK, the system will run the file immediately without displaying the Execute now dialog box. The process is the same as Execute by schedule.

12) Set the information as needed and execute the command. 


The Maintenance Output tab in the window displays the results.

(  Note: 

· When running the batch file, you cannot modify the MML commands in the file.


· When running the batch file, the Maintenance Output tab does not display results. When execution of batch MML commands is stopped, Maintenance Output tab and History Command drop-down box are empty.


4.7   Exiting LMT


I.  Introduction 


If you exit the LMT, you will disconnect the LMT to the NodeB and M2000 server (if you log into the NodeB through the M2000 server), and close the Node O&M system. 

II.  Prerequisite


None. 

III.  Procedure 


Follow the steps below to exit the LMT system: 

1) Choose System -> Exit, or click the shortcut icon [image: image22.png].
The Sure to exit the system? dialog box opens up. 


2) Click OK.


Then you exit the LMT. 

[image: image23.png]
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Chapter 5   Alarm Management

5.1   About This Chapter


This chapter describes how to manage the alarms on the NodeB though the LMT.


5.2   Overview


5.2.1   Alarm Types 


I.  Fault Alarm and Event Alarm


Alarms can be classified into fault alarms and event alarms by nature.

· Fault alarm: refers to the alarm generated in case of hardware equipment fault or major function failure. When the fault is removed, the system reports a cleared alarm. One cleared alarm corresponds to one fault alarm. The severity of a fault alarm is higher than that of an event alarm in most cases. 

· Event alarm: refers to the accidental alarm indicating that the system is in alarm state for a while. There is no cleared alarm for the event alarm. Some event alarms are generated periodically.

II.  Active Alarm and Recovery Alarm


When there are alarms, the alarms can be classified into active alarms and recovery alarms according to the alarm state.


· If an alarm has recovered, the alarm is in a “recovery” state and is called “recovery alarm”.

· If an alarm has not recovered, the alarm is in an “active” state and is call “active alarm”. 

For example, when a fault occurs in the interior hardware of a tower mounted amplifier (TMA), the system will report a TMA fault alarm. 


· Before the fault in the interior hardware of the TMA is cleared, the alarm is an active alarm.

· After the fault in the interior hardware of the TMA is cleared, the alarm is a recovery alarm.


(  Note:

A recovery alarm indicates the alarm has recovered. The alarm records are still stored in the alarm log and can be queried. See 5.4.4   “Querying Alarm Log”. 

5.2.2   Alarm Log


The alarm log keeps all the alarm records. You can obtain NodeB alarm information or collect alarm statistics by querying the alarm log. 

5.2.3   Alarm Severity


The alarm severity shows the level of urgency and severity of an alarm.


The alarm severities of fault alarms and event alarms in descending order are as follows:


· Critical alarm 

· Major alarm 

· Minor alarm 

· Warning 

Table 5-1 describes definitions and handling of alarms at different severities. 


Table 5-1 Definitions and handling of alarms at different severities


		Alarm severity 

		Definition 

		Handling 



		Critical alarm

		The critical alarm has an impact on the service provided by the system and needs timely handling even when it occurs in after-work time.  For example, a device or resource is not available. 

		It requires timely handling. Otherwise, the system may collapse. 



		Major alarm 

		The major alarm affects the quality of service (QoS) and needs resolving within work time to avoid impact on some major functions. For example, the QoS of a device or resource is impaired and needs recovery. 

		It requires timely handling. Otherwise, some major functions may be affected. 



		Minor alarm 

		The minor alarm does not affect QoS. It needs handling at a proper time against potential faults. 

		The purpose of this alarm is to remind maintenance technicians of alarm reasons and eliminate potential faults. 



		Warning 

		The warning shows a potential error that may affect service and needs handling in some cases. 

		It requires understanding of the system running state. 





5.2.4   Alarms Classified by Network Management 


Alarms can also be classified by network management as follows:


· Power system: Alarms of the power system (for example, DC 48 V)


· Environment system: Alarms of equipment room environment (for example, temperature, humidity and door control)


· Signaling system: Alarms of channel associated signaling and SS7


· Trunk system: Alarms of trunk circuit and trunk board


· Hardware system: Alarms of board parts (for example clock and CPU)


· Software system: Alarms of software


· Running system: Alarms of system running


· Communication system: Alarms of communication system


· QoS: Alarms of QoS


· Processing error: Other alarms

5.3   Configuring Alarm System Attributes


5.3.1   Overview


Configurations of alarm system attributes consist of:


· Configuring Attributes of Alarm Query Window

· Setting Fault Alarm Blinking Prompt 


· Setting Sound Duration for Fault Alarm

· Setting Dial Notify for Fault Alarms

· Setting SMS Notify for Fault Alarms

· Sorting Alarms

5.3.2   Configuring Attributes of Alarm Query Window 


I.  Introduction


Configuring attributes of the alarm query window consists of: 


· Alarm colors

· Column width

· Showing/Hiding tip

· Clearing current alarm records

· Dynamic addition 


· Querying active alarm when login successfully


· Refreshing the window 


II.  Prerequisite 


None. 

III.  Procedure 


		Alarm query window attribute

		Menu

		Remarks



		Displaying color setting 

		System -> Display Color Setting…

		This function is applicable to all the alarm browse windows. 



		Displaying column width 

		System -> Display Column Setting… 

		This function is applicable to all active alarm browse windows. 



		Showing/hiding tip

		System -> Tip

		Tip function: When the cursor moves to an alarm in a browse window, a Tip showing the alarm information is displayed. The information is the same as that in Browse Alarm Information widow. However, the use of tips facilitates browsing. 


This function is applicable to all the alarm browse windows. 



		Clearing current alarm records 

		Right click in an alarm browse window and select Clear all the alarms from the window. 

		This function is applicable to Fault Alarm Browse and Event Alarm Browse windows only. 



		Dynamic addition 

		Right click in an alarm browse window and select Dynamic Addition from the shortcut menu. 

		This function is applicable to the Fault Alarm Browse, Event Alarm Browse and Alarm log query result windows. 



		Querying active alarm when login successfully 

		System -> System Configuration 

		This function applies to Fault Alarm Browse window only. 



		Refreshing the window 

		Right click in an alarm browse window and select Refresh Window from the shortcut menu.

		· For Event Alarm Browse window, refreshing means clearing the window. 


· For windows of Fault Alarm Browse, Alarm Log Query Result and Active alarm query result, refreshing means querying alarms by original conditions. 





5.3.3   Setting Fault Alarm Blinking Prompt


I.  Introduction


When you log into the NodeB alarm management system, an icon [image: image1.png] displays in the status area of the LMT taskbar. 


The blinking prompt function means when the system reports a fault alarm, the tray blinks alternately between [image: image2.png] and [image: image3.png]. 


(  Note: 


· This function is applicable to fault alarms only. 

· When an alarm is reported, the icon blinks. When the alarm is cleared, the icon does not stop blinking automatically. You need to stop it manually.


· When you disable the blinking prompt when the icon is blinking, the icon stops blinking. 

II.  Prerequisite 


None.

III.  Procedure


In the NodeB alarm management system, select Management -> Fault Alarm Prompt to enable or disable this function. If there is a symbol √ in front of the menu, the function is enabled. Otherwise, this function is disabled. The default setting is "enabled". 


· If you enable this function, the icon blinks when the system reports a fault alarm. Double click the icon to stop blinking and to maximize the window of the alarm management system. This facilitates you to handle the fault alarm. 

· If you disable this function, the icon does not change when the system reports a fault alarm. 

5.3.4   Setting Sound Duration for Fault Alarms


I.  Introduction


If the alarm sound function is enabled, the system prompts you with sound of different duration when there are fault alarms at different severity levels. 


II.  Prerequisite


None. 

III.  Procedure


Follow the steps below to set the sound duration for fault alarms in the NodeB alarm management system: 

1) Select Management -> Fault Alarm Sound to display the Fault Alarm Sound dialog box as shown in Figure 5-1.

[image: image4.png]

Figure 5-2 Fault Alarm Sound dialog box


Table 5-2 describes the fields in the Fault Alarm Sound dialog box

Table 5-2 Description of fields in Fault Alarm Sound dialog box


		Field 

		Description 



		Critical Alarm 

		It is used to set the sound duration for critical alarms. Selecting Critical Alarm means starting the fault alarm sound at this severity level. 



		Major Alarm 

		It is used to set the sound duration for major alarms. Selecting Major Alarm means starting the fault alarm sound at this severity level. 



		Minor Alarm 

		It is used to set the sound duration for minor alarms. Selecting Minor Alarm means starting the fault alarm sound at this severity level



		Warning 

		It is used to set the sound duration for warning. Selecting Warning means starting the fault alarm sound at this severity level





2) Set sound duration for fault alarms and decide whether to start the alarm sound at each severity level in the dialog box. 

3) Click OK to complete the settings. 


5.3.5   Setting Dial Notify for Fault Alarms


I.  Introduction


The function of setting dial notify for fault alarms indicates that the system notifies you in case of fault alarms with the pre-set fixed-line phone number or the mobile phone number. 


II.  Prerequisite


None. 

III.  Procedure


Follow the steps below to set dial and SMS notify for fault alarms in the NodeB alarm management system:

1) Select Management -> Fault Alarm Notify to display the Fault Alarm Notify dialog box as shown in Figure 5-2.


[image: image5.png]

Figure 5-3 Fault Alarm Notify dialog box


Table 5-3 describes the fields in the Fault Alarm Notify dialog box 

Table 5-3 Field description of Fault Alarm Notify dialog box

		Field 

		Description 



		Show 

		After checking an alarm severity level, alarm records at that level automatically shown in the left list. 



		Notify Type 

		You can select alarms in the left list by pressing Shift or Ctrl and then select Dial Notify and/or SMS Notify. These settings enable you to receive notification of the selected alarms through the preset fixed-line phone number and/or the mobile phone number. 


The SMS notify includes


· alarm ID

· alarm severity

· alarm rising time



		Start 

		You can start the alarm notification type by selecting Dial Notify and/or SMS Notify. 


If you select alarm report of a notify type, the system starts reporting the selected alarms through the preset phone number and/or SMS. 



		Setting

		You can set the fixed-line phone and/or mobile phone numbers in the Set Notification Mode dialog box by clicking Setting. 





2) Select an alarm severity in the dialog box to display alarm records at that level in the left list. 

3) Select alarms to be set in the left list. 

4) Select Dial Notify under Notify Type.

5) Select Dial Notify under Start.

6) Click Setting to display the Set Notify Type dialog box as shown in Figure 5-3. 

[image: image6.png]

Figure 5-4 Set Notify Type dialog box

Table 5-4 describes the fields in the Set Notify Type dialog box 

Table 5-4 Field description of Set Notify Type dialog box 

		Field 

		Description 



		Notify Type 

		You can choose the notify type from Dial Notify or SMS Notify. 



		Notify Tool 

		· If the notify type is Dial Notify, Modem is enabled. 


· If the notify type is SMS Notify, Mobile is enabled. 


· Note that the system automatically sets Notify Tool according to the notify type setting. 



		Serial Port No. 

		You can select the Modem port number connected with the NodeB alarm management system for alarm notification. 



		Phone No. 

		· If the notify type is SMS Notify, enter a mobile phone number.


· If the notify type is Dial Notify, enter a fixed-line phone number or a mobile phone number. 



		Cleared Time Delay(s)

		A fault alarm will be notified if the time between the occurrences of the fault alarm and its corresponding cleared alarm is over Cleared Time Delay. 



		Interval Two SMS (s) 

		The system reports fault alarms one by one at intervals of Interval Two SMS. An alarm is reported for one time only. 





7) Select Dial Notify in the Notify Type drop box. 

8) Set the following parameters in the Set Notify Type dialog box

· Serial port No.

· Phone No.


· Cleared time delay(s) 


· Interval two SMS(s)  


9) Click OK to close Set Notify Type dialog box. 

10) Click OK to close Fault Alarm Notify dialog box. 


5.3.6   Setting SMS Notify for Fault Alarms 


I.  Introduction


The function of setting SMS notify for fault alarms indicates that the system notifies you in case of fault alarms with the pre-set mobile phone number. 

II.  Prerequisite


None. 

III.  Procedure


Follow the steps below to set the SMS notify for fault alarms in the NodeB alarm management system: 

1) Select Management -> Fault Alarm Notify to display the Fault Alarm Notify dialog box as shown in Figure 5-2. 


2) Select an alarm severity in the dialog box to display alarm records at that level in the left list. 

3) Select alarms to be set in the left list. 

4) Click SMS Notify under Notify Type.

5) Click SMS Notify under Start.

6) Click Setting to display the Set Notify Type dialog box as shown in Figure 5-3. 

7) Select SMS Notify in the Notify Type drop box. 

8) Set the following parameters in the Set Notify Type dialog box

· Serial port No.


· Phone No.


· Cleared time delay(s) 


· Interval two SMS (s) 


9) Click OK to close Set Notify Type dialog box. 

10) Click OK to close Fault Alarm Notify dialog box. 


5.3.7   Sorting Alarms 


I.  Introduction


Alarm records can be sorted by any column. If an alarm is reported after sorting, it is added to the list end.

(  Note: 


Alarm records can be sorted only by one column each time. 

II.  Prerequisite 


None. 

III.  Procedure 


To sort alarm records in an alarm browse window by a column, click the caption of the column. 

5.4   Monitoring NodeB Alarms


5.4.1   Overview 


Monitoring the NodeB alarms includes


· Browsing alarms

· Querying active alarms

· Querying alarm log

· Querying alarm details 

· Realtime print alarms

5.4.2   Browsing Alarms  


I.  Introduction


The NodeB alarm management system dynamically displays the latest records of fault alarms and event alarms in the Fault Alarm Browse and Event Alarm Browse windows. You can view the alarm records to know the current operation of the NodeB.


This function includes:

· Browsing fault alarms

· Browsing event alarms

II.  Prerequisite


None.

III.  Procedure 


Follow the steps below to browse current fault alarms:

1) Start the NodeB alarm management system.  Then the Fault Alarm Browse window opens up as shown in Figure 5-4. If the Fault Alarm Browse window is closed, select Browse -> Fault Alarm Browse or click the shortcut icon [image: image7.png] to open it again. 


[image: image8.png]

Figure 5-5 Fault Alarm Browse window


Table 5-5 describes the fields in the Fault Alarm Browse window 


Table 5-5 Field description of Fault Alarm Browse window 


		Field 

		Description 



		Alarm serial No.

		It is a number given to an alarm by the raised time. 



		Cleared state

		It shows whether the alarm is cleared. 



		Alarm name

		It is preset in the NodeB. 



		Alarm raised time/cleared time 

		It shows the time when the alarm is generated. If the alarm is cleared, it also shows the time when it is cleared. 



		Alarm severity

		It is preset in the NodeB and changes with the fault code dynamically. 



		Location info

		It refers to the fault code of the alarm and the fault location in the NodeB. Details include: 


· The cabinet number

· The subrack number 

· The slot number 

· The link number 



		Alarm source

		It shows the net element from which the alarm is reported. For the NodeB alarm management system, the alarm source is the NodeB itself. 



		Alarm ID

		These items are preset in the NodeB. 



		Event type

		



		Alarm type

		





2) Browse the active fault alarms with. The system adds new fault alarms to the list end in real time.

(  Note: 


· Select System -> System Setting to display the System Setting dialog box. If Query active alarm when login successfully in the dialog box is not ticked, the fault alarms reported before login are not displayed in the Fault Alarm Browse window. The window only displays the fault alarms reported after login. 


· If Query active alarm when login successfully in the dialog box is ticked, all the active fault alarms are displayed in the Fault Alarm Browse window and new fault alarms are added to the list end in real time. 

Follow the steps below to browse the current event alarms: 


3) Start the NodeB alarm management system.  Then the Event Alarm Browse window opens up as shown in Figure 5-5. If the Event Alarm Browse window is closed, select Browse -> Event Alarm Browse or click the shortcut icon [image: image9.png] to open it again. 


[image: image10.png]

Figure 5-6 Event Alarm Browse window


Table 5-6 describes the fields in the Event Alarm Browse window. 


Table 5-6 Field description of Event Alarm Browse window


		Field 

		Description 



		Alarm serial No.

		It is a number given to an alarm by the raised time. 



		Alarm name

		It is preset in the NodeB. 



		Alarm raised time  

		It shows the time when the alarm is generated.  



		Alarm severity

		It is preset in the NodeB and changes with the fault code dynamically. 



		Location info

		It refers to the fault code of the alarm and the fault location in the NodeB. Details include: 


· The cabinet number

· The subrack number 

· The slot number 

· The link number



		Alarm source

		It shows the net element from which the alarm is reported. For the NodeB alarm management system, the alarm source is the NodeB itself. 



		Alarm ID

		These items are preset in the NodeB. 



		Event type

		



		Alarm type

		





4) Browse the active event alarms. The system adds new event alarms to the list end in real time. 


5.4.3   Querying Active Alarms 


I.  Introduction


Querying active alarms refers to querying current uncleared fault alarms of the NodeB according to specified conditions. 


(  Note: 


All the active alarms will disappear after resetting the NodeB. In that case, those alarms can only be queried by querying alarm log. 

II.  Prerequisite 


None. 

III.  Procedure


Follow the steps below to query active alarms: 

1) In the NodeB alarm management system, select Query -> Query Active Alarm. The Query Active Alarm dialog box opens up as shown in Figure 5-6. 


[image: image11.png]

Figure 5-7 Query Active Alarm dialog box


Table 5-7 describes the fields in the Query Active Alarm dialog box. 

Table 5-7 Field description of Query Active Alarm dialog box 


		Field 

		Description 



		Serial No. 

		To specify a serial No. range


Default value: all serial Nos. 



		Return Numbers

		To specify the number of records


Default value: 64


Maximum value: 1000 



		Module No. 

		Unavailable 



		Slot No. 

		To specify a slot 



		Cabinet No. 

		To specify a cabinet 



		Subrack No. 

		To specify a subrack 



		Board Location 

		Unavailable 





2) Set the query conditions in the dialog box. 

3) Click OK to display the Active Alarm Query Result window for the query result. 

(  Note: 


You can query active alarms by the MML command of LST ALMAF.

5.4.4   Querying Alarm Log

I.  Introduction


Querying the alarm log refers to querying the alarm log records by query conditions. The aim is to get knowledge to the NodeB alarms or collect alarm statistics. 


(  Note: 


When an alarm is generated, NodeB record the alarm in the alarm log. The alarm log keeps the information of all the fault and event alarms.  

II.  Prerequisite 


None. 

III.  Procedure


Follow the steps below to query 

1) In the NodeB alarm management system, select Query -> Query Alarm Log or click the shortcut icon [image: image12.png] to display the Query Alarm Log dialog box, as shown in Figure 5-7. 

[image: image13.png]

Figure 5-8 Query Alarm Log dialog box


You can set general conditions for alarm query in Common option tab page. The conditions may include 


· Alarm type

· Alarm severity 

· Date/Time 


Table 5-8 describes the fields in the tab page. 


Table 5-8 Field description of Common option tab page 

		Field 

		Description 



		Alarm Type 

		To specify alarm types


Default value: Fault alarm not Cleared



		Alarm Severity 

		To specify alarm severities


Default value: critical, major, minor, warning



		Date/Time

		To specify a time range to query alarms within that period 

· If you specify start time without start date, the system takes the seventh day before the current day as the start date.


· If you specify end time without end date, the system takes the current date as the end date.


· If you specify start date without start time, the system takes 0:0:0 as the start time.


· If you specify end date without end time, the system takes 23:59:59 as the end time.



		Return Numbers 

		To specify the number of records to returned


Default value: 64


Maximum value: 1000





You can set detailed conditions for alarm query in the Detailed option tab page as shown in Figure 5-8. The conditions may include: 


· Serial number

· Alarm ID 

· Event type 


[image: image14.png]

Figure 5-9 Detailed option tab page

Table 5-9 Field description of Detailed option tab page

		Field 

		Description 



		Serial No. 

		To specify a serial No. range


Default value: all serial Nos.



		Alarm ID 

		To specify an alarm ID range


Default value: all alarm IDs



		Module No. 

		Unavailable 



		Event Type 

		To specify event types


Default value: all types





You can set location conditions for alarm query in the Physical option tab page as shown in Figure 5-9. The conditions may include: 


· Subrack No. 

· Slot No. 

· Board location 


[image: image15.png]

Figure 5-10 Physical option tab page

Table 5-10 describes the fields in the Physical option tab page. 


Table 5-10 Field description of Physical option tab page 


		Field 

		Description 



		Subrack No.

		To specify a subrack



		Slot No. 

		To specify a slot



		Board Location 

		Unavailable 



		Cabinet No. 

		To specify a cabinet



		Board Type 

		To specify a board type 





2) Set query conditions in the dialog box. 

3) Click OK. The Query Alarm Log window for the query result opens up. 

5.4.5   Querying Alarm Details 


I.  Introduction


Querying the alarm details refers to querying the details of an alarm, including: 


· Alarm serial No.

· Alarm name 

· Alarm raised time 

· Alarm severity 

· Location information 

· Alarm source 

II.  Prerequisite 


None. 

III.  Procedure


Follow the steps below to query the detailed alarms: 


1) Double click an alarm record in the alarm browse window. 

2) The Alarm Details dialog box opens up as shown in Figure 5-10.

[image: image16.png]

Figure 5-11 Alarm Details dialog box

5.4.6   Realtime Printing Alarms 


I.  Introduction


Realtime printing alarms indicate that the system automatically prints the reported alarm records according to the conditions. 


II.  Prerequisite


None. 

III.  Procedure


Follow the steps below to set the realtime print conditions in the NodeB alarm management system: 

1) Select System -> Realtime Print Setup. The Realtime Print Setup dialog box opens up as shown as Figure 5-11. 


[image: image17.png]

Figure 5-12 Realtime Print Setup dialog box


Table 5-11 describes the fields in the Realtime Print Setup dialog box. 


Table 5-11  Field description of Realtime Print Setup dialog box 

		Field 

		Description 



		Alarm severity 

		To select a severity of alarms to print



		Alarm type 

		To select a report type of alarms to print



		Event alarm 

		To select an event type of alarms to print



		Print to File 

		If you tick this box, you need to specify a file path. In this case, the system prints the selected alarm records to a file.


If you do not tick it, the system prints the selected alarm records in real time.





2) Set the conditions for saving alarm records in the dialog box. 


3) Tick Print to File to display the Save as… dialog box. 

4) Select an existing file or enter a file name to create a new file in the dialog box. 

5) Click Save as…. You are presented with the Realtime Print Setup dialog box. 

6) Click OK in the dialog box. 

The system starts to print the reported alarm records. 

5.5   Handling NodeB Alarms 

5.5.1   Overview 


Handling NodeB alarms refers to querying NodeB alarm handling suggestions and shielded alarms. 


5.5.2   Querying Alarm Handling Suggestions


I.  Introduction


Querying alarm handling suggestions refers to querying alarm handling suggestions for the relevant alarms, including: 


· Alarm meaning

· Impacting on system

· System actions

· Alarm handling 

II.  Prerequisite


None. 

III.  Procedure


There are two ways to query alarm handling suggestions. 


Method One: 


1) Select an alarm record in an alarm browse window. 

2) Right click on that alarm to display the shortcut menu. 

3) Select More in the menu to display the online help. 


Method Two: 


4) Double click an alarm record in an alarm browse window. The Alarm Details dialog box opens up as shown in Figure 5-10.

5) Click More to display the online help. 


5.5.3   Shielded Alarms


I.  Introduction


A shielded alarm indicates that the NodeB neither saves this alarm nor reports it to the alarm management system. In that case, you can not query the shielded alarm. 


An unshielded alarm indicates that the NodeB saves this alarm and reports it to the NodeB management system. In that case, you can query the unshielded alarm. 


(  Note: 


If you set shielding conditions, those conditions take effect when next alarm occurs. Those uncleared alarms shall remain what they are. 


II.  Prerequisite


None. 

III.  Procedure


Follow the steps below to modify alarm configurations in the NodeB alarm management system: 

1) Select Management -> Alarm Configuration. The Query Alarm Configuration dialog box opens up, as shown in Figure 5-12. 
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Figure 5-13 Query Alarm Configuration dialog box 


Table 5-12 describes the fields in the Query Alarm Configuration dialog box. 

Table 5-12 Field description of Query Alarm Configuration dialog box 

		Field 

		Description 



		Alarm ID

		To specify an alarm ID range 



		Alarm Severity 

		To specify one or multiple alarm severities


Default value: all severities 



		Mask Flag 

		Options: Shielded, Unshielded and All

Default value: All

If an alarm is shielded, the NodeB neither saves it nor reports it to the NodeB alarm management system. In this case, you can not query this alarm. 


If an alarm is not shielded, the NodeB saves the alarm and reports it to the alarm management system. In this case, you can query this alarm.



		Report to Alarm Box 

		Unavailable  



		Modification Flag 

		Value: Modified, Unmodified, All

Default value: All

If the alarm severity, report-to-alarm-box flag, and mask flag of an alarm are modified, its modification flag is Modified.


For the NodeB, the alarm severity and report-to-alarm-box flag can not be modified. Therefore, if the mask flag of an alarm is modified, its modification flag is Modified.



		Return Numbers 

		To specify the number of records returned


Default value: 64


Maximum value: 1000





2) Set query conditions in the dialog box. 

3) Click OK to display the Alarm Configuration Query Result window for the query result. 

4) Select an alarm record to be modified in the window. You can select one record only each time. Then click Modify to display the Modify Alarm Configuration dialog box as shown in Figure 5-13. 

[image: image19.png]

Figure 5-14 Modify Alarm Configuration dialog box


Table 5-13 describes the fields in the Modify Alarm Configuration dialog box. 

Table 5-13 Field description of Modify Alarm Configuration dialog box

		Field 

		Description 



		Alarm Severity 

		Unavailable  



		Shield Flag 

		Options: Shielded and Unshielded 



		To Alarm Box Flag 

		Unavailable  





5) Modify Shield Flag in the dialog box. 

6) Click OK to complete the modification. 

(  Note: 


Execute the MML command of SET ALMSHLD to modify the shield flag. 
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Chapter 6   Managing Files

6.1   About This Chapter

This chapter describes how to manage the files, including


· Overview of File Management

· Uploading Files

· Browsing Files

6.2   Overview of File Management

6.2.1   File Types

Table 6-1 describes types of the NodeB LMT files. 


Table 6-1 File types of NodeB LMT

		File type

		Function  

		Format 

		Remarks 



		Operation Log 

		To record the NodeB operation and maintenance information

		In *.txt format

		The operation log can be uploaded to the FTP server.



		Equipment Archives

		To record information of the boards on a NodeB, such as the manufacturing information and running duration of the boards

		In *.xml format

		The equipment archives can be uploaded to the FTP server.



		Main Board Log Files 

		To record all the logs on the NMPT

		In binary format 

		The main board log file can be uploaded to the FTP server.



		Board Log Files 

		To record logs on other boards

		In binary format 

		· The board log files can be uploaded to the FTP server.

· Board log files may vary because some boards have no slave CPUs while some other boards have no DSPs. 



		RTWP Routine Test Log 

		To record and store related RTWP information in the routine test log after the RTWP routine test is started

		In binary format 

		The RTWP routine test log can be uploaded to the FTP server.





6.2.2   Browsing Files

There are two ways to obtain and browse the files as follows: 


· Browse files by logging into the FTP server after uploading the files to the server 

· Browse the operation log through the M2000 server 

6.3   Uploading Files

6.3.1   Uploading Operation Log

I.  Introduction

Uploading the operation log refers to uploading the operation log to the FTP server.

This enables you to save and view the operation log. 

II.  Prerequisites

The prerequisites to upload the operation log are as follows: 


· The FTP server works well and connects to the NodeB well within the same intranet. 

· There is no firewall between the FTP server and the NodeB. 

· The user name and password for the specified FTP Server are correct. Ensure that you have the authority to read (when downloading) and write (when uploading) data in the specified directory. 

III.  Procedure

Follow the steps below to upload the operation log: 


1) Choose Maintenance Navigator -> Software Management. Then double-click the Other File Transfer subnode. 
The Other File Transfer dialog box opens up, as shown in Figure 6-1. 

[image: image1.png]

Figure 6-2 Other File Transfer dialog box

Table 6-2 describes the fields in the Other File Transfer dialog box. 

Table 6-2 Field description of Other File Transfer dialog box 

		Field 

		Description 



		Transfer Type 

		If you select Upload (NodeB to FTP Server), you may upload data files from the NodeB to the FTP Server. This enables you to view, modify and save the file.



		File Description 

		The files include 


· Operation log 

· Equipment archives 

· Main Board Log Files 

· Board Log Files 

· RTWP Routine Test Log File



		Destination File or Directory 

		· The directory or file in the FTP server in which data files are saved

 You may specify the directory or the name of a data file. 


· If you select Upload (NodeB to FTP Server), it refers to the destination file or directory.  


· If you select Download (FTP Server to NodeB), it refers to the source file. 



		FTP Setting 

		· To set the FTP server that saves data files to be uploaded or downloaded

· The FTP server in use shall be listed in the FTP Setting box. 


· To set parameters for the FTP server, click Modify. 



		Upload Mode 

		· To decide whether to use the compressed mode


· This mode is available only when you select Upload (NodeB to FTP Server). 





2) Click Modify. 
The FTP Settings dialog box opens up, as shown in Figure 6-2. 

[image: image2.png]

Figure 6-3 FTP Settings dialog box

Table 6-3 describes the fields of the FTP Settings dialog box. 

Table 6-3 Field description of FTP Settings dialog box 

		Field 

		Description 



		Use Built-in FTP Server 

		· The FTP server built in the LMT 

· The built-in FTP server is started by default. 

· To stop the FTP server, select System -> Stop FTP Server.

· To start the FTP server, select System -> Start FTP Server. 

· Select System -> System Configuration. You can set the user name and password for the built-in FTP server in the System Configuration dialog box. 



		Use Specified FTP Server 

		IP Address 

		· To set the IP address for the computer where this FTP server is located

· The FTP server can be the one started from the local computer installed with LMT or from another computer. 



		

		User Name 

		· To set the user name for logging into the FTP server



		

		Password 

		· To set the password for logging into the FTP server





3) Set parameters in the dialog box. 

4) Click OK. 
The FTP Settings dialog box is closed. You are presented with the Other File Transfer dialog box. 

5) Choose Upload (NodeB to FTP Server) in Transfer Type. 

6) Choose Operation Log in File Description. 

7) Complete other settings in the dialog box. 

8) Click Start.

The system starts to upload the operation log. 

(  Note: 

Execute the MML command of ULD FILE to upload operation log. 

6.3.2   Uploading Equipment Archives 

I.  Introduction 

Uploading equipment archives refers to uploading the equipment archives to the FTP server. 

This enables you to view and save the equipment archives.


II.  Prerequisites 

· The MML command of EXP DEVFILE must be executed to generate equipment archives. 


· Other prerequisites are the same to those for uploading the operation log. See 6.3.1  "Uploading Operation Log".

III.  Procedure

Follow the steps below to upload the equipment archives: 

1) Choose Maintenance Navigator -> Software Management. Then double-click the Other File Transfer subnode. 
The Other File Transfer dialog box opens up, as shown in Figure 6-1. 

2) Click Modify. 
The FTP Settings dialog box opens up, as shown in Figure 6-2. 

3) Set parameters in the dialog box.

4) Click OK. 
The FTP Settings dialog box is closed. You are presented with the Other File Transfer dialog box. 

5) Choose Upload (NodeB to FTP Server) in Transfer Type. 

6) Choose Equipment Archives in File Description. 

7) Complete other settings in the dialog box. 

8) Click Start.


The system starts to upload the equipment archives. 

(  Note: 

Execute the MML command of ULD DEVFILE to upload the equipment archives. 


6.3.3   Uploading Main Board Log Files 

I.  Introduction 

Uploading the main board log files refers to uploading the main board log files to the FTP server. 


This enables you to view and save the files. 

II.  Prerequisites 

· The prerequisites are the same to those for uploading the operation log. See 6.3.1   "Uploading Operation Log".

III.  Procedure

Follow the steps below to upload the main board log files: 

1) Choose Maintenance Navigator -> Software Management. Then double-click the Other File Transfer subnode. 
The Other File Transfer dialog box opens up, as shown in Figure 6-1. 

2) Click Modify. 
The FTP Settings dialog box opens up, as shown in Figure 6-2. 

3) Set parameters in the dialog box.

4) Click OK. 
The FTP Settings dialog box is closed. You are presented with the Other File Transfer dialog box. 

5) Select Upload (NodeB to FTP Server) in Transfer Type. 

6) Select Main Board Log Files in File Description. 

7) Complete other settings in the dialog box. 

8) Click Start.


The system starts to upload the main board log files. 

(  Note: 

Execute the MML command of ULD FILE to upload the main board log files. 


6.3.4   Uploading Board Log Files 

I.  Introduction 

Uploading the board log files refers to uploading the board log files to the FTP server.


This enables you to view and save the board log files.  

II.  Prerequisites

· The prerequisites are the same to those for uploading the operation log. See 6.3.1   "Uploading Operation Log".

III.  Procedure 

Follow the steps below to upload the board log files: 


1) Choose Maintenance Navigator -> Software Management. Then double-click the Other File Transfer subnode. 
The Other File Transfer dialog box opens up, as shown in Figure 6-1. 

2) Click Modify. 
The FTP Settings dialog box opens up, as shown in Figure 6-2. 

3) Set parameters in the dialog box.

4) Click OK. 
The FTP Settings dialog box is closed. You are presented with the Other File Transfer dialog box. 

5) Select Upload (NodeB to FTP Server) in Transfer Type. 

6) Select Board Log Files in File Description. 

7) Complete other settings in the dialog box. 

8) Click Start. 

The system starts to upload the board log files. 

(  Note: 

Execute the MML command of ULD FILE to upload the board log files. 

6.3.5   Uploading RTWP Routine Test Log 

I.  Introduction 

Uploading the RTWP routine test log refers to uploading the RTWP routine test log to the FTP server. 


This enables you to view and save the RTWP routine test log. 

II.  Prerequisites

· The prerequisites are the same to those for uploading the operation log. See 6.3.1   "Uploading Operation Log".

III.  Procedure

Follow the steps below to upload the board log files: 


1) Choose Maintenance Navigator -> Software Management. Then double-click the Other File Transfer subnode. 
The Other File Transfer dialog box opens up, as shown in Figure 6-1. 

2) Click Modify. 
The FTP Settings dialog box opens up, as shown in Figure 6-2. 

3) Set parameters in the dialog box.

4) Click OK. 
The FTP Settings dialog box is closed. You are presented with the Other File Transfer dialog box. 

5) Select Upload (NodeB to FTP Server) in Transfer Type. 

6) Select RTWP Routine Test Log in File Description. 

7) Complete other settings in the dialog box. 

8) Click Start.


The system starts to upload the RTWP routine test log. 

6.4   Browsing Files 

6.4.1   Browsing Files on FTP Server

I.  Introduction 

Browsing files refers to browsing the uploaded files by logging into the FTP server. 

II.  Prerequisite

The files have been uploaded to the FTP server. 

III.  Procedure

Follow the steps below to browse the uploaded files on the FTP server:  

1) Upload the files to the FTP server.
For details, see 6.3   "Uploading Files". 

2) Browse the uploaded files by logging into the FTP server.

6.4.2   Browsing Operation Log on M2000 Server 

I.  Introduction 

You can query the NodeB operation log on the M2000 server 

II.  Prerequisite 

You have authority to query the NodeB operation log. 

III.  Procedure

For details, see iManager M2000 Mobile Element Management System Operation Manual.
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Chapter 7   Managing NodeB and Boards

7.1   About This Chapter


This chapter describes how to manage the NodeB and the boards on the NodeB O&M system, including

· Basic Equipment Panel Operation

· NodeB-level Operation

· Board-level Operation

The NodeB O&M system provides an equipment panel for users to make the operations more visual and convenient. All the operations conducted through the equipment panel can also be realized by MML commands. 

7.2   Basic Equipment Panel Operation

7.2.1   Introduction to Equipment Panel

The NodeB provides multiple maintenance means. Besides the MML command, the NodeB O&M system provides a GUI equipment panel. This makes the equipment maintenance more visual and convenient. 

7.2.2   Functions of Equipment Panel 

Select a board and then right-click on it to display a shortcut menu on the equipment panel. You can perform the following operations by selecting different menus:

· Querying board status


· Querying board version 


· Resetting board 

( Note: 


For detailed operations on boards, see section 7.4   "Board-level Operation". 

7.2.3   Interface of Equipment Panel

Figure 7-1 shows the interfaces of equipment panel. The panel automatically refreshes to query the board status in real time. 

[image: image1.png]

Figure 7-1 Interface of equipment panel

II.  Board Indicators 

In Figure 7-1, there is an indicator on each board, indicating the present board status. 

Figure 7-2 illustrates the meaning of board indicators. 

[image: image2.png]

Figure 7-2 Meaning of board indicators

III.  Fault Bar 

The fault bar is used to display active alarms on the board in real time. 

For example, the fault bar message 0-0-3-NULP-Fault indicates the NULP board in slot No. 3, subrack No. 0 and cabinet No. 0 is faulty. 

Symbol || is used to divide two alarms from each other. When all the alarms are displayed, the fault bar starts rolling to display the alarms from the beginning. 

7.2.4   Starting Equipment Panel

I.  Introduction

The LMT provides a GUI equipment panel. This makes the equipment management more visual and convenient. 

II.  Prerequisite

None. 

III.  Procedure

Follow the steps below to start the equipment panel: 

1) Choose Maintenance Navigator -> Rack Node. 

2) Double-click Master Cabinet subnode. 

The system displays the equipment panel of the cabinet in the right pane. 

7.2.5   Showing or Hiding Board Indicators

I.  Introduction 

You can make preliminary decision of the board status by observing the color of each board indicator. 

II.  Prerequisite

None. 

III.  Procedure 

To show or hide the indicators as shown in Figure 7-2, follow either way below:


· Click [image: image3.bmp] on the upper right of the equipment panel, 

· Press Ctrl + L. 

7.2.6   Showing or Hiding Fault Bar 

I.  Introduction 

The fault bar displays active alarms in real time. 

II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to show or hide the fault bar: 


1) To display the fault bar, click [image: image4.png] on the upper right of the equipment panel, or press Ctrl+F. 

( Note: 

The system displays the fault bar by default. 


There are three ways to close the fault bar as follows: 

· Click [image: image5.png] on the upper right of the equipment panel 

· Press Ctrl + F 

· Close it directly 

2) To start the equipment panel, see 7.2.4   "Starting Equipment Panel". If there is an active alarm on the device, it is displayed by rolling the fault bar. 

7.3   NodeB-level Operation

7.3.1   Overview 

Operations on the NodeB include: 

· Querying NodeB Running Version

· Querying NodeB Software Version

· Modifying NodeB Time

· Modifying NodeB Password

· Resetting NodeB

7.3.2   Querying NodeB Running Version

I.  Introduction 

You can query the information of the NodeB running version. 

II.  Prerequisite 

None. 

III.  Procedure 

Follow the steps below to query the NodeB running version: 


1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select the active NMPT of the master cabinet on the panel. 

(  Note:


For the DBS3800, select MBBU on the panel.

3) Right-click on the NMPT and select List NodeB Running Version on the shortcut menu. 
The system displays the Query Result pane as shown in Figure 7-3, listing the NodeB version information. 

[image: image6.png]

Figure 7-3 Query Result pane

(  Note: 

You can also query the NodeB running version by the MML command of LST VER.


7.3.3   Querying NodeB Software Version

I.  Introduction 

You can check whether the NodeB is upgraded by querying the NodeB software version. 

II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to query the NodeB software version: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select the active NMPT of the master cabinet on the panel. 

(  Note:


For the DBS3800, select the MBBU on the panel.

3) Right-click on the NMPT and select List NodeB Software Version on the shortcut menu. 
The system displays the Query Result pane as shown in Figure 7-4 and Figure 7-5, listing the NodeB software version information and NodeB BOOTROM version information. 

[image: image7.png]

Figure 7-4 NodeB Software Version Information pane

[image: image8.png]

Figure 7-5 NodeB BOOTROM Version Information pane

(  Note: 

You can also query the NodeB running software version by the MML command of LST SOFTWARE. 


7.3.4   Modifying NodeB Time 

I.  Introduction 

[image: image9.wmf] Caution: 

The NodeB time is very important for alarm logs, operation logs and services records. Modify the NodeB time with caution. 

You can maintain NodeBs of different versions through the same LMT. But at the same time, you can maintain only one NodeB on that LMT. The NodeB and the LMT must be synchronized to avoid time inconsistency in alarm logs and operation logs.

II.  Prerequisite

None. 

III.  Procedure 

If the time difference between LMT and NodeB is greater than five minutes, the system displays a Time Synchronization Check dialog box, listing the LMT time and NodeB time and prompting whether to synchronize the LMT time with the NodeB time. 


· If the NodeB time is precise, click Modify to synchronize the LMT time with the NodeB time. 


· If the NodeB time is not precise, click Cancel and log into the NodeB to modify the NodeB time by the MML command of MOD TM. 

(  Note: 

· You may query the NodeB time by the MML command of DSP TM before the modification to decide whether to modify the time.


· You may query the NodeB time by the MML command of DSP TM after the modification to check whether the modification is valid.

· If the SNTP function is enabled, the NodeB time shall be synchronized with the SNTP server time periodically. Even if NodeB time is modified, it will still be synchronized in next synchronization. If the SNTP function is not enabled, the modified NodeB time will remain valid.


· Relevant MML commands: SET SNTPCLTPARA (to set SNTP client parameters) and LST SNTPCLTPARA (to list SNTP client parameters). 

7.3.5   Modifying NodeB Password 

I.  Introduction 

This function is to modify the password for logging into the NodeB. You can log into the NodeB only when you enter the correct password.

II.  Prerequisite 

None. 

III.  Procedure 

[image: image10.wmf]  Caution: 

· The setting takes effect upon completion for users who log into the NodeB after the modification. However, the new password does not affect your normal operation if you have logged into the NodeB before the modification. 

· Users who have authority to modify the NodeB password have to be either an M2000 server user or an O&M system user. Alarm management users have no authority to modify the NodeB password. 

Follow the steps below to modify the NodeB password: 


1) In the NodeB O&M system, select System -> Change Password to display the Change Password dialog box as shown in Figure 7-6. 

[image: image11.png]

Figure 7-6 Change Password dialog box 

2) Enter the old and new passwords. 

3) Click OK to complete the password modification. 

7.3.6   Resetting NodeB 

I.  Introduction 

[image: image12.wmf]  Caution: 


Resetting the NodeB shall interrupt services on the NodeB.  


You need to reset the NodeB upon a NodeB failure or after the configuration update. 

II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to reset the NodeB: 


1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select the active NMPT of the master cabinet on the panel.

(  Note:


For the DBS3800, select the MBBU on the panel.

3) Right-click on the NMPT and select Reset Board on the shortcut menu. 

4) Click Yes in the dialog box to reset the board. 
The system displays the result and automatically refreshes the status of board indicators in accordance with the result.

(  Note: 

You can also reset the NodeB by the MML command of RST SYS.


7.4   Board-level Operation

7.4.1   Overview 

Operations of board management vary from different types of boards. Table 7-1 describes the actions related to boards. 

Table 7-1 Actions related to boards 

		NodeB type

		Board 

		Action 



		Macro NodeB 

		All boards

		Reset board (Except MAFU) 



		

		

		Display board status



		

		

		Query active alarms



		

		

		Display board version



		

		HDLP (NDLP)/HULP (NULP)/HBBI/MTRU/ MAFU

		Block/Unblock board



		

		NMPT

		List NodeB software version (Valid for active NMPT only)



		

		

		List NodeB running version (Valid for active NMPT only)



		

		

		Display current clock status

For details, see section 12.3.3 "Displaying Current Clock Status". 



		

		NAOI/NDTI

		Display E1/T1 status 



		

		

		Display E1/T1 work mode



		

		

		Display Iub optical port status (Valid for NAOI only) 



		

		

		Display Iub optical port work mode (valid for NAOI only) 



		DBS3800

		All NodeBs  

		Reset board



		

		

		Display board status



		

		

		Query active alarms



		

		

		Display board version



		

		

		Block/Unblock board 



		

		MBBU

		List NodeB software version



		

		

		List NodeB running version



		

		

		Display current clock status



		

		

		Display E1/T1 status 



		

		

		Display E1/T1 work mode





7.4.2   Querying Board Status

I.  Introduction 

You can display the running status of a board to monitor the running status of a NodeB. Table 7-2 describes the detailed board status. 

Table 7-2 Board status description 

		Type 

		Board status 

		Description 



		Active/Standby status 

		· It indicates the board is active or standby. 

· For a macro NodeB, it applies to the NMPT only. 



		

		Active

		The board is active.



		

		Standby

		The board is standby.



		

		None

		Not applicable



		Availability status

		Physical availability of the board



		

		Normal

		The board works normally.



		

		Faulty

		There is an alarm on the board.



		

		Uninstall

		The board is configured but not inserted.



		

		Not configured

		The board is inserted but not configured.



		

		Not consistent

		The configured board is not consistent with the inserted board in type.



		Operation status

		Whether the board supports services establishment



		

		Usable

		The board supports services establishment.



		

		Unusable

		The board does not support services establishment.



		Admin status

		· Whether the board needs to support service establishment

· For a macro NodeB, this status is only applicable to the HULP/NULP, HDLP/NDLP, HBBI, MTRU and MAFU.

· For all the other boards, this status shall be set to Null.



		

		Usable

		The board needs to support services establishment 



		

		Unusable

		The board does not need to support services establishment 



		

		None

		The board is not manageable.





II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to query the board status: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select a board on the equipment panel. 

3) Right-click and select Display Board Status on the shortcut menu. 
The system displays a dialog box, showing the running status of that board. 

(  Note: 

Follow either way below to query the board status: 

· Execute the MML command of DSP BRD

· Check the board indicators

For details, see sections 7.2.3  II.  "Board Indicators" and 7.2.5   "Showing or Hiding Board Indicators".

7.4.3   Querying Active Alarms on Board

I.  Introduction 

Listing active alarms enables you to locate and remove the fault on a board in time. 

II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to list active alarms: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select a board on the panel. 

3) Right-click on the board and select Query Active Alarms on the shortcut menu. The system displays a dialog box, showing the uncleared fault alarms of that board. 

(  Note: 

You can also query the active alarms of a specified board by the MML command of LST ALMAF.


7.4.4   Querying Board Version

I.  Introduction 

You can check whether the board versions are consistent with the NodeB version by querying the running versions of all the boards, including 


· CPU number 


· Board software version 

· Board hardware version 

· Board BOOTROM version

II.  Prerequisite

None.

III.  Procedure 

Follow the steps below to query the board version: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select a board on the panel. 

3) Right-click on the board and select Display Board Version on the shortcut menu.

The system displays a dialog box showing the version information of that board. 

(  Note: 

You can also query the version information of a specified board by the MML command of DSP BRDVER. 


7.4.5   Querying E1/T1 Status 

I.  Introduction 


You can check the status of all E1/T1 links of an NDTI/NAOI.

The result shows the current status of all E1/T1 links of the board. 

· For NAOI, the links are E1/T1 links 0 to 3. 

· For NDTI, the links are E1/T1 links 0 to 7.

(  Note: 

For the DBS3800, you can check the status of E1/T1 links by checking the MBBU on the equipment panel. 

II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to query the status of E1/T1 links: 


1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select an NDTI/NAOI on the equipment panel. 


(  Note: 

For the DBS3800, select the MBBU on the equipment panel. 


3) Right-click on the board and select Display E1/T1 State on the shortcut menu.
The system displays the Display E1/T1 State dialog box as shown in Figure 7-7. 

[image: image13.png]

Figure 7-7 Display E1/T1 State dialog box 


4) Set parameter for Port No. in the dialog box and click OK.

The system displays a Query Result dialog box as shown in Figure 7-8, listing the query result. 

[image: image14.png]

Figure 7-8 Query Result dialog box 

(  Note: 

You can also query the status of E1/T1 links by the MML command of DSP E1T1.

7.4.6   Querying E1/T1 Work Mode

I.  Introduction 

You can query the work mode of the E1/T1 links of an NDTI/NAOI.

The result shows the work mode of all E1/T1 links of the board. 

· For NAOI, the links are E1/T1 links 0 to 3. 

· For NDTI, the links are E1/T1 links 0 to 7.

(  Note: 

For the DBS3800, you can check the work mode of E1/T1 links through the MBBU on the equipment panel.


II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to query the E1/T1 work mode: 


1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select an NDTI/NAOI on the equipment panel. 


(  Note: 

For the DBS3800, select MBBU on the equipment panel. 


3) Right-click on the board and select Display E1/T1 Work Mode on the shortcut menu. 
The system displays the Display E1/T1 Work Mode dialog box as shown in Figure 7-9. 

[image: image15.png]

Figure 7-9 Display E1/T1 Work Mode dialog box 


4) Set parameter for Port No. in the dialog box and click OK.

The system displays a Query Result dialog box as shown in Figure 7-10, listing the query result. 

[image: image16.png]

Figure 7-10 Query Result dialog box

(  Note: 

You can query the E1/T1 work mode only when the NAOI/NDTI works well or in alarm status. 

(  Note: 

You can also query the E1/T1 work mode of a specified board by the MML command of DSP E1T1WORKMODE.


7.4.7   Querying STM-1 Status 

I.  Introduction

You can query the STM-1 status of an NAOI. The result shows the current status of Iub optical interface links 0 and 1 of the NAOI.

(  Note: 

This command is valid for macro NodeBs only. 


II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to query the STM-1 status: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select an NAOI on the equipment panel. 


3) Right-click on the NAOI and select Display STM-1 State on the shortcut menu. The system displays the Display STM-1 State dialog box. 


4) Set the parameter for STM1 No. in the dialog box and click OK. 

The system displays a dialog box listing the query result. 

(  Note: 


You can query the Iub optical interface status only when the NAOI/NDTI works well or in alarm status. 


(  Note: 


You can also query the Iub optical interface status of a specified board by the MML command of DSP STM1.

7.4.8   Querying STM-1 Work Mode 

I.  Introduction 

You can query the STM-1 work mode of an NAOI. The result shows the work mode of Iub optical interface links 0 and 1 of the NAOI.

(  Note: 

This command is valid for macro NodeBs only. 


II.  Prerequisite

None. 

III.  Procedure 

Follow the steps below to query the Iub optical interface work mode: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select an NAOI on the equipment panel. 


3) Right-click on the board and select Display STM-1 Work Mode on the shortcut menu. 
The system displays the Display STM-1 Work Mode dialog box. 


4) Set the parameter for STM1 No. in the dialog box and click OK. 

The system displays a dialog box listing the query result. 


(  Note: 


You can query the STM-1 work mode only when the NAOI/NDTI works well or in alarm status. 


(  Note: 


You can also query the STM-1 work mode of a designated board by the MML command of DSP STM1WORKMODE.


7.4.9   Blocking/Unblocking Board 

I.  Introduction 

You may block or unblock an HULP/NULP, HDLP/NDLP, HBBI, MTRU, MTRU or MAFU on a macro NodeB to locate faults without interrupting the system services.

If a board is blocked, the board is available but cannot process services. Services on that board shall be cleared and those accessed afterwards shall be shifted to other boards.

II.  Prerequsite

None. 

III.  Procedure 

Follow the steps below to block a board:


1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select a board on the equipment panel. 


3) Right-click on the board and select Block Board on the shortcut menu. The system displays a dialog box. 

4) Click Yes in the dialog box. 

The system displays the result and refreshes the board indicator. 

(   Note:


· You can block an HULP/NULP, HDLP/NDLP, HBBI, MTRU, MTRU or MAFU only when it is in normal or faulty state. 

· You can unblock a board only when it is blocked.

· You can block or unblock the above boards repeatedly.

· The procedure of unblocking a board is similar to that of blocking a board. You can unblock a board by right-clicking on a blocked board and then selecting Unblock Board. 

(   Note:


· You can also block a board by the MML command of BLK BRD.

· You can also unblock a board by the MML command of UBL BRD.

7.4.10   Resetting Board

I.  Introduction 

[image: image17.wmf]  Caution: 


Resetting a board may interrupt the services on the board. 


You can reset a board when it is faulty. The operation initializes and recovers the board.

II.  Prerequisite

None. 

III.  Procedure

Follow the steps below to reset the board: 

1) Choose Maintenance Navigator -> Rack Node. Then double-click Master Cabinet subnode. 
The system displays the equipment panel of the cabinet in the right pane. 

2) Select a board on the equipment panel. 


3) Right-click on the board and select Reset Board on the shortcut menu. The system displays a dialog box. 

4) Click Yes in the dialog box. 

The system displays the result and refreshes the board indicator. 

(  Note: 

You can also reset a board by the MML command of RST BRD.


7.4.11   Adding/Removing Board

I.  Introduction 

[image: image18.wmf]  Caution: 


The operation modifies the data configuration file of the NodeB. 

You can add or remove a board. This action changes the NodeB capacity.

(  Note: 

This command is valid for a macro NodeB only .

II.  Prerequisite

None. 

III.  Procedure 

You can add or remove a board by an MML command: 

· Add a board by the MML command of ADD BRD.

· Remove a board by the MML command of RMV BRD. 

Huawei Technologies Proprietary

i




		NodeB LMT User Guide

		Table of Contents







Table of Contents


8-1Chapter 8 Tracing NodeB Iub Interface Signaling



8-18.1 About This Chapter



8-18.2 Overview



8-18.2.1 Principle of Tracing NodeB Iub Interface Signaling



8-28.2.2 Introduction to NodeB Iub Interface Tracing



8-28.3 Creating NodeB Iub Interface Tracing Task



8-68.4 Browsing NodeB Traced Message



8-68.4.1 Browsing NodeB Traced Message Online



8-78.4.2 Setting Browsing Properties of NodeB Traced Message



8-88.4.3 Saving NodeB Traced Messages Automatically



8-98.4.4 Saving NodeB Traced Messages Manually



8-98.4.5 Browsing NodeB Traced Messages Offline



8-118.4.6 Filtering NodeB Traced Messages







Chapter 8   Tracing NodeB Iub Interface Signaling

8.1   About This Chapter

This chapter describes the Iub interface signaling tracing as follows:

· Overview

· Creating NodeB Iub Interface Tracing Task

· Browsing NodeB Traced Message

8.2   Overview

8.2.1   Principle of Tracing NodeB Iub Interface Signaling 

The tracing management is used to conduct routine equipment maintenance. The tracing to Iub interfaces and signaling links helps you verify the data and locate the faults.

For example, after the equipment data configuration, you can check the signaling links by establishing tracing tasks. If the signaling links are abnormal, you can make preliminary fault location. 

Table 8-1 shows the procedure of Iub interface signaling tracing.

Table 8-1 Procedure of Iub interface signaling tracing

		Step

		Action 

		Description 

		Reference



		1

		Create a tracing task 

		To start the Iub interface tracing

		See 8.3   "Creating NodeB Iub Interface Tracing Task"



		2

		Browse traced messages online

		To display reported traced messages by opening a message browse window after creating a tracing task

		See 8.4.1   "Browsing NodeB Traced Message"



		3

		Save traced messages

		To save important traced messages as required

		See 8.4.3   "Saving NodeB Traced Messages " and 8.4.4   "Saving NodeB Traced Messages "



		4

		Stop tracing task 

		To stop the tracing task

		--



		5

		Browse traced messages offline

		To browse the saved traced messages offline

		See 8.4.5   "Browsing NodeB Traced Messages"





8.2.2   Introduction to NodeB Iub Interface Tracing

The NodeB message tracing refers to the NodeB Iub interface tracing. 

The Iub interface is a standard open interface between the NodeB and the RNC in the WCDMA system. The Iub interface is used to transmit messages of the user plane, signaling plane and specific O&M.

There are two tracing directions:


· OUT: from NodeB to RNC (for a macro NodeB, from NMPT to Iub interface boards)

· IN: from RNC to NodeB (for a macro NodeB, from Iub interface boards to NMPT)

8.3   Creating NodeB Iub Interface Tracing Task

I.  Task Introduction

Creating an Iub interface tracing task refers to starting the Iub interface tracing. This can trace all the Iub interface messages.

After creating a tracing task, the system automatically sends two messages respectively to the master CPU and slave CPU of each available Iub interface board. The aim is to trace messages that the system sends and receives. The maximum message number that the system can send is 4 (number of boards) x 2 (the active and slave CPUs on the board) x 2 (two directions: send and receive) = 16.

(  Note:

· Only one Iub interface tracing task can be created in the NodeB O&M system each time, and one message display window can be created for this tracing task.

· The prompt for busy system and failure in starting a standard interface tracing task may lie in the overloaded CPU. It is recommended to start the tracing task 30 seconds later when the CPU overloading is cleared. 

II.  Prerequisite

None. 

III.  Procedure

Follow the steps below to create a tracing task:

1) Choose Maintenance Navigator -> Tracing Management. Then double-click Standard Interface Tracing subnode. 
A prompt dialog box opens up.

(  Note:

You may clear the check box of Show tips at startup next time in the dialog box. This dialog box does not appear when you start a tracing task next time.

2) Click Continue in the dialog box. 
The Standard Interface Tracing dialog box opens up as shown in Figure 8-1. 

Figure 8-1 shows the Standard Interface Tracing dialog box.

[image: image1.png]

Figure 8-2 Standard Interface Tracing dialog box

3) Click Advanced…. 
The Advanced dialog box opens up as shown in Figure 8-2.

[image: image2.png]

Figure 8-3 Advanced dialog box

Table 8-1 describes the fields of the Advanced dialog box.

Table 8-2 Field description of Advanced dialog box 

		Field

		Description 



		Auto Save

		Select Auto Save. The system saves reported messages in the Trace directory of the running version by default. You may modify the saving directory. 

Each reported message is to be saved in the message file.



		Maximum messages per window 

		To set the maximum number of messages displayed in the message browse window

Range: 100 to 5000 

Default value: 1000



		Flow control type

		Stop Show Message: If the message flow is too large, the system stops displaying messages on the interface. 

Stop Trace Task: If the message flow is too large, the system stops the tracing task. 



		Message colour

		To set the display colors of messages in two directions 

· IN: from RNC to NodeB

· OUT: from NodeB to RNC

Both directions have 16 optional colors.





4) Set parameters in the Advanced dialog box.

5) Click OK. 
You are presented with the Standard Interface Tracing window as shown in Figure 8-3. 

Figure 8-3 shows the Standard Interface Tracing window.

[image: image3.png]

Figure 8-4 Standard Interface Tracing window

Table 8-3 describes the fields of the Standard Interface Tracing window. 

Table 8-3  Fields in the Standard Interface Tracing window

		Field 

		Description



		Message Sequence No.

		Sequence number of the message by arrival time



		Time

		Message arrival time in the format of YYYY-MM-DD HH:MM:SS



		Millisecond

		Traced message reporting interval: 100 ms



		Message Direction

		RNC->NodeB: from RNC to NodeB 

NodeB->RNC: from NodeB to RNC



		Message Type

		NBAP messages starting with NBAP_


ALCAP messages starting with ALL2_



		Message Content

		The system translates the message contents displayed in binary into message codes according to the message type.





8.4   Browsing NodeB Traced Message 

8.4.1   Browsing NodeB Traced Message Online 

I.  Introduction 

When you create a tracing task, the system starts a message browse window and displays the reported traced messages. The message browse window displays the traced messages in columns and adds messages in sequential order in real time.

II.  Prerequisite

None. 

III.  Procedure

Follow the steps below to browse traced messages:


1) Create a tracing task. 
For details, see 8.3   “Creating NodeB Iub Interface Tracing Task”. 

2) Double-click a message in the Standard Interface Tracing window.
The message explanation window opens up as shown in Figure 8-4. 

Figure 8-4 lists details in the message explanation window. 

[image: image4.png]

Figure 8-5 Message explanation window

The upper part of the window shows the explanation of the message and the lower part shows the source code. 

3) Click the Close button on the upper right corner of the window. 
The Standard Interface Tracing window and the message explanation window are closed.

(  Note:

· To clear all message records in the window, right-click in the Standard Interface Tracing window, and select Clear All on the shortcut menu. The system clears all the message records from the list and displays the traced messages reported afterwards from the first line.

· If you double-click another message with the message explanation window open, the system does not generate a new message explanation window but refreshes the explanations. The system explains only one message each time. 

· If you double-click multiple messages selected, the system explains the one clicked only. 

· For more detailed message explanations, see relevant interface protocol. 

8.4.2   Setting Browsing Properties of NodeB Traced Message 

I.  Introduction

The following functions enable you to browse messages in the Standard Interface Tracing window: 

· Setting traced message color: When you create a tracing task, the system displays the traced results in different colors according to their transmission directions. IN is the color for messages from RNC to NodeB while OUT is the color for messages from NodeB to RNC. You can modify the value of IN and OUT.

· Setting message window scroll: It is used to set whether to scroll the window. 

· Setting message filter: For the unimportant but frequently reported messages, you may choose to filter them.

II.  Prerequisite

None. 

III.  Procedure

Follow the steps below to set traced message display:

1) Right-click in the Standard Interface Tracing window.


2) Select relevant menus on the shortcut menu.

Table 8-4 shows how to set the browsing properties of the NodeB traced message. 

Table 8-4 Description of setting browsing properties of NodeB traced message

		Property

		Shortcut menu

		Description



		Traced message color setting

		Modify Color Settings

		You can also set the message color when creating an Iub interface tracing task. See 8.3   “Creating NodeB Iub Interface Tracing Task”.



		Message window scroll setting

		Automatic Scroll

		--



		Message Filter setting

		Filter

		--





8.4.3   Saving NodeB Traced Messages Automatically

I.  Introduction

· Saving traced messages automatically indicates the system saves the reported messages in the format of *.tmf into the Trace directory of the running NodeB. You can select another new path.

· When a message file does not satisfy the save condition, a new message file is generated. All message files related to the task are associated through the Index value. When a file is created, index value will ascend until the task is terminated.

The message file name takes the following format: office direction name_Interface type_YYYY-MM-DD_HH-MM-SS[_Index].tmf, where,

· YYYY-MM-DD_HH-MM-SS shows the task creation time. 

· YYYY, MM, DD, HH, MM and SS stands for year, month, day, hour, minute and second respectively.

· Index indicates multiple traced message files created in an interface tracing task. The index value ascends from 1.

II.  Prerequisite

None. 

III.  Procedure

Follow the steps below to save the reported interface traced messages automatically:


1) Open the Standard Interface Tracing dialog box as shown in Figure 8-1.

2) Click Advanced.


3) Select Auto Save in the Advanced dialog box as shown in Figure 8-2.


8.4.4   Saving NodeB Traced Messages Manually 

I.  Introduction

You can choose to save selected or all traced messages.

II.  Prerequistie


None. 

III.  Procedure

Follow the steps below to save the selected traced messages manually:


1) Right-click in the Standard Interface Tracing window.

2) Select Stop Task on the shortcut menu.


3) Select the traced messages to be saved. Shortcut keys of Ctrl and Shift are applicable.

4) Right-click on the messages and select Save Selected Record on the shortcut menu.


5) Specify a path and name for the file. 

6) Click Save.

Follow the steps below to save all the traced messages manually:


7) Right-click in the Standard Interface Tracing window.


8) Select Save All Records on the shortcut menu.


9) Specify a path and name for the file. 

10) Click Save. 

8.4.5   Browsing NodeB Traced Messages Offline 

I.  Introduction

You can browse message files (*.tmf) offline with the TraceViewer. 

II.  Prerequisite

There are message files automatically saved by the system and manually saved by you.  

III.  Procedure

Follow the steps below to view traced messages offline:


1) Select Service -> TraceViewer in the NodeB O&M system, or click the shortcut icon [image: image5.png].

2) Select the relevant NodeB version in the Select Version dialog box as shown in Figure 8-5.

[image: image6.png]

Figure 8-6 Select Version dialog box

3) Click OK and start the TraceViewer.

4) Select the message file to be browsed in the Open dialog box.

5) Click OK. 
The TraceViewer window is displayed. 

6) Double-click a message record in the window. 
You are presented with the explanations of it. 

(  Note:

You can carry out the following actions with the NodeB TraceViewer:

· To save the selected messages to a message file, right-click on the message records and then select Save Selected Record on the shortcut menu. 

· Click different buttons on the title bar. Then the messages shall be sequenced according to message number, time, direction or type.

· To filter the messages, right-click the mouse and then select Filter or Filter on Column on the shortcut menu. See section 8.4.6   "Filtering NodeB Traced Messages ". 

7) Select File -> Exit. 

The message browse window is closed. 

8.4.6   Filtering NodeB Traced Messages 

I.  Introduction

The filtering traced messages function enables you to filter out unwanted messages. There are two ways for filtering messages: 

· Filtering messages with customized conditions: you can filter out unwanted messages according to one or more conditions by defining the filter. 

· Filtering messages on column: You can filter out unwanted messages according to the property of a column.

II.  Prerequisite

None. 

III.  Procedure

Follow the steps below to define filters:

1) Select Operate -> Filter… after opening a message tracing file, or right-click in an open message tracing file and then select Filter on the shortcut menu.

2) Click New… in the Filter dialog box as shown in Figure 8-6.

[image: image7.png]

Figure 8-7 Filter dialog box

3) Set one or more filtering conditions in the Filter Define dialog box as shown in Figure 8-7.

[image: image8.png]

Figure 8-8 Filter Define dialog box

4) Click OK. 
You are presented with the Filter dialog box.

5) Select the defined filter and then click Apply.


(  Note:

To perform invert filtering, select Reverse Filter in the Filter dialog box 

Follow the steps below to filter messages on column:

6) Open a message file and then select a column of message records to be filtered.

7) Right-click on the column. 


8) Select Filter on Column on the shortcut menu.

9) Choose a message property in the drop-down list of the Column Filter dialog box.


10) Click OK. 

You may cancel the message filtering as follows:


· Choose Operate -> Cancel Filter, or  

· Right-click in the TraceViewer window and then select Cancel Filter on the shortcut menu.

The system displays all messages in the message file. 
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