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Document Change Record
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released as Revision A.
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Letter Date Description of Change

B 12/2006 Replaced Audio Devices applet information with Bluetooth 
Audio applet information. Updated 802.11 information to 
include “A” functionality. Added information about 
Microsoft WordPad and Media Player.
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Before You Begin
Before You Begin
This section provides you with safety information, technical support 
information, and sources for additional product information.

Safety Information
Your safety is extremely important. Read and follow all warnings and 
cautions in this document before handling and operating Intermec 
equipment. You can be seriously injured, and equipment and data can be 
damaged if you do not follow the safety warnings and cautions.

This section explains how to identify and understand dangers, warnings, 
cautions, and notes that are in this document.

A warning alerts you of an operating procedure, practice, condition, or 
statement that must be strictly observed to avoid death or serious injury 
to the persons working on the equipment.

A caution alerts you to an operating procedure, practice, condition, or 
statement that must be strictly observed to prevent equipment damage 
or destruction, or corruption or loss of data.

Note: Notes either provide extra information about a topic or contain 
special instructions for handling a particular condition or set of 
circumstances.

Global Services and Support

Warranty Information
To understand the warranty for your Intermec product, visit the Intermec 
web site at www.intermec.com and click Service & Support. The Intermec 
Global Sales & Service page appears. From the Service & Support menu, 
move your pointer over Support, and then click Warranty.

Disclaimer of warranties: The sample code included in this document is 
presented for reference only. The code does not necessarily represent 
complete, tested programs. The code is provided “as is with all faults.” All 
warranties are expressly disclaimed, including the implied warranties of 
merchantability and fitness for a particular purpose.

Web Support
Visit the Intermec web site at www.intermec.com to download our current 
manuals (in PDF). To order printed versions of the Intermec manuals, 
contact your local Intermec representative or distributor.

Visit the Intermec technical knowledge base (Knowledge Central) at 
intermec.custhelp.com to review technical information or to request 
technical support for your Intermec product.
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Telephone Support
These services are available from Intermec Technologies Corporation.

Service Description

In the U.S.A. and Canada, 
call 1-800-755-5505 and 
choose this option

Order Intermec 
products

• Place an order.
• Ask about an existing order.

1 and then choose 2

Order Intermec media Order printer labels and ribbons. 1 and then choose 1
Order spare parts Order spare parts 1 or 2 and then choose 4
Technical Support Talk to technical support about 

your Intermec product.
2 and then choose 2

Service • Get a return authorization 
number for authorized service 
center repair.

• Request an on-site repair 
technician.

2 and then choose 1

Service contracts • Ask about an existing 
contract.

• Renew a contract.
• Inquire about repair billing or 

other service invoicing 
questions.

1 or 2 and then choose 3

Outside the U.S.A. and Canada, contact your local Intermec representative. 
To search for your local representative, from the Intermec web site, click 
Contact.

Who Should Read This Manual
This document is written for the person who is responsible for installing, 
configuring, and maintaining the CK60.

This document provides you with information about the features of the 
CK60, and how to install, configure, operate, maintain, and troubleshoot.

Before you work with the CK60, you should be familiar with your network 
and general networking terms, such as IP address.

Related Documents
This contains a list of related Intermec documents and their part numbers.

Document Title Part Number

CK60 Mobile Computer Quick Start Guide 962-054-115

Intermec Computer Command Reference Manual 073529

TE 2000 Terminal Emulation Programmer’s Guide 977-055-008
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The Intermec web site at www.intermec.com contains our documents (as 
PDF files) that you can download for free.

To download documents

1 Visit the Intermec web site at www.intermec.com.

2 Click Service & Support > Manuals.

3 In the Select a Product field, choose the product whose documentation 
you want to download.

To order printed versions of the Intermec manuals, contact your local 
Intermec representative or distributor.
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1Using the Computer

This chapter introduces the CK60 Mobile Computer, developed by 
Intermec Technologies Corporation to enhance wireless connectivity needs 
and contains hardware and software configuration information to assist you 
in making the most out of your CK60.
Note: Desktop and applet icons are shown to the left. Any place that Start 
is mentioned, tap the following Windows icon in the bottom, left corner of 
your CK60 desktop. 
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Chapter 1 — Using the Computer
Introducing the CK60 Mobile Computer
The Intermec CK60 Mobile Computer is an ergonomically designed 
handheld computer built on the Microsoftr Windowsr CE operating 
system. It is a lightweight, easy-to-use, reliable computer that runs client/
server applications, terminal emulation applications, as well as browser-
based applications. 

Enter

Battery status

MicrophoneMicrophone

Scan button

Intermec Ready-To-Work 
Good read light

Indicator

Front Speaker
 

Scan button

Keyboard function

Power button

The CK60 is available with the following:

• Ethernet

• 802.11a/b/g radio

• Bluetooth - *Bluetooth is a trademark owned by Bluetooth SIG, Inc., USA

• 64MB or 128MB RAM/64MB Flash Memory

• Disk on Chip (128MB)

• 2D Area Imager

• EV10 Imager

Use this manual to understand how to use the features and options 
available on the CK60.
CK60s with an IEEE 802.11a/b/g radio installed are Wi-Fir certified for 
interoperability with other 802.11a/b/g wireless LAN devices.
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Learning Software Build Versions
The Persistent Storage Manager (PSM) is an area of storage which is 
embedded in a section of the system’s FLASH memory. This storage area is 
not erased when a cold-boot is performed. It may, however, be erased 
during the reflashing process. In addition to storing applications and data 
files, you do have the option to store a persistent registry to the PSM 
region.
To check to see if your CK60 has the latest PSM build or the latest 
operating system build, double-tap the Internet Explorer icon from the 
desktop, then see the information under CK60 Version Information. 

 

Resetting Your Computer
When the CK60 completely stops responding, an application is locked up 
and does not respond, when you upgrade the firmware, or when you reflash 
the CK60, it may be necessary to perform a reset.

Preferred Reset Method
The recommended method in recovering the CK60 is to press and hold the 
power switch on the front of the CK60 for about 10 seconds. This 
performs a graceful system shutdown and no data is lost in the process.

Secondary Reset Method
If performing the preferred reset method does not restore system operation, 
it may be necessary to press the reset button inside the battery 
compartment of the CK60. This method does not guarantee that cached 
disk data will be saved, and as such, transactional data may be lost during 
the reset. All other data is preserved.

To press the reset button

1 Press the power switch to suspend the CK60.

2 Remove the battery pack from the back of the CK60.
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3 With a stylus, press the reset button in the battery cavity in the back.

4 Press and hold the power switch as you put the battery back in the unit. 

Clean Boot Process
If performing either reset method fails to restore system operation, it may 
be necessary to perform a clean-boot. This is a boot method which formats 
the object store to clean data and registry information from the CK60 
system and restores them to their factory-default state.
Note: This will erase the memory in the CK60, including all applications 
and data files found in the object store (user store). See “Packaging 
Applications for the Computer” on page 74 for more information.

 

To perform a clean-boot

1 Press the power switch to suspend the CK60.

2 Remove the battery pack from the back of the CK60.

3 With a stylus, press the reset button in the battery cavity in the back.

4 Press and hold the power switch as you put the battery back in the unit.

5 Continue to hold the power switch until a Warning message appears on 
the display, release the power switch, then read the message.

6 To continue with the clean-boot, press the right side button. 

To cancel the clean-boot, press the left side button.

Scanning Bar Codes
Do not look directly into the window area or at a reflection of the laser 
beam while the laser is scanning. Long-term exposure to the laser beam 
can damage your vision.

Use the scanner to scan and enter bar code data. The type of scanner you 
are using and the type of bar code you are decoding determines the way you 
scan the bar code. The CK60 supports the scanning of 2D images. Plus, if 
you are using an integrated handle or a tethered scanner, the way you scan 
bar codes is different. 

Do not use force or a sharp object when pressing the reset button. 
You may damage the reset button.

Press this reset button with your stylus.
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When you unpack the CK60, the Code39, UPC/EAN, and PDF417 (with 
imager) bar code symbologies are enabled.

If you are using bar code labels that are encoded in a different symbology, 
you need to enable the symbology on the computer. Use the Intermec 
Settings applet to enable and disable symbologies for your scanner. For help 
on using the Intermec Settings applet, see “Using the Intermec Settings 
Applet” on page 10.

Scanning with the 2D Area Imager
The CK60 has the 2D area imager, which provides the ability to scan 2D 
bar code symbologies and supports omni-directional (360°) scanning where 
you can position the CK60 in any orientation to scan a bar code label. 
Using the 2D area imager is similar to taking a digital pictures.

1 Press the power button to turn on the CK60.

2 Point the scanner window at the bar code label and hold the CK60 
steady a few inches from the label.

3 Press the Scan button on the keypad or pull the trigger on a handle and 
center the red aiming beam over the bar code label.

The aiming beam is smaller when the imager is closer to the bar code and 
larger when it is further away. 

When the CK60 successfully reads a bar code label, you hear a high beep 
and the green Good Read indicator turns on briefly.

4 Release the Scan button.

If you have problems scanning a bar code with the 2D imager, try following 
some of these tips to improve the performance of your imager:

• Set Lighting mode to Illum LED Priority.

• Keep your hand as steady as possible while scanning a label.
• Make sure that Aimer LED Duration is set to zero.

• Position the imager as close to the bar code as possible while still being 
able to capture the entire bar code.

• Enable only the bar codes that you need to use every day.

Use Intermec Settings to configure these imager commands. For help using 
Intermec Settings, see “Using the Intermec Settings Applet” on page 10. 
For more information on the commands and their parameters, see the 
Intermec Computer Command Reference Manual (P/N 073529) via the 
Intermec web site. See “Before You Begin” for information how to 
download this .chm file.
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Supported Devices
The CK60 should connect the following scanner models: 1551, 1553, 
1555; ScanPlus 1800SR, 1800ST, 1800VT; Scan Image 1470; SF51; and 
SF61. There are a number of different scan engines covered by these 
models, including RFID and XLR scan engines. Model 1555 and Scan 
Image 1470 are supported as input devices only; configuration of these 
models are accomplished by scanning labels. 

Using the Ambient Light Sensor
The ambient light sensor automatically turns off the display lighting as 
surrounding light increases to conserve your CK60 battery power. As 
configured from the factory, the ambient light sensor is disabled.

To enable the ambient light sensor and change its settings

4 Make your selections, then tap OK to exit this applet. 

Using the Battery
The CK60 uses a 17.3 Watt-hour, 7.2V, replaceable Lithium-Ion (Li-ion) 
battery. Fully charge the battery before using the CK60. When changing 
the battery, a backup battery (super capacitor) maintains your state, 
memory, and real-time clock for at least 10 minutes.
The battery used in this device may present a fire or chemical burn 
hazard if it is mistreated. Do not disassemble it, heat it above 100°C 
(212°F) or incinerate it.

If you fail to replace the battery immediately, you may lose important 
state or applications.

1 Tap Start > Settings > Control Panel. 

2 Double-tap the Backlight icon.

3 Tap the right arrow to scroll to and tap the Both Power tab. 

This restores the backlight setting once CK60 powers on

This turns off the ambient light sensor.
This disables the backlight in normal environments.
This disables the backlight in bright environments.
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Dispose of used batteries promptly. Keep away from children. Contact 
your Intermec representative for replacement batteries.

Several factors determine the life of your battery such as extreme 
temperatures, input devices, and your usage. For example, if you use a 
tethered scanner every day, you need to replace your battery more often 
than someone who uses an internal scanner.
Note: The CK60 has an internal backup super capacitor which retains data 
for an average of ten minutes after the battery is removed. It also shuts 
down the CK60 if the battery suddenly goes away (removed from the 
computer). Depending upon the processes running, it may not have 
adequate power for a graceful shut down. If so, the CK60 performs a cold-
boot the next time power is applied.

In short, put the CK60 into a suspend (sleep) mode before you remove 
the battery.

You can configure the battery power fail level so that after the system shuts 
down in a low battery condition, there is still sufficient charge to allow the 
unit to remain configured, keep proper time, and maintain DRAM 
(Dynamic Random Access Memory) for at least ten minutes at room 
temperature if the main battery remains in the handheld computer, using 
the Power applet (see page 8). The state and time are lost if:

• The battery discharges beyond this level.

• The battery is removed when the computer is not in suspend mode.

Charging and Installing the Battery
Make sure you fully charge the battery before you install it in your CK60; 
and that you take at least 20 minutes to initially charge the backup battery 
using a charging dock before the backup system is fully functional.

To charge the battery
• Either insert the battery into the quad battery charger, 

• or place the CK60 with battery installed in a single dock, a single dock 
with modem, or a multidock. 

The battery charge time is four hours or less on any of these docks if the 
temperature is within the battery charging range.

You could also use a power adapter to keep the CK60 on full power.

For maximum efficiency, store your CK60 on external power with which to 
charge your batteries.

For more information on these accessories, see “Accessories for the 
Computer” on page 19.

To install the battery, insert the tabs on the bottom of the charged battery 
into the CK60 and snap the battery into place.

Below are things you can do to maximize the life of your battery.
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Maximizing Battery Life

When You Want To: Do This to Save Battery Power:

Operate the CK60 and the Low 
Battery status icon appears or the 
Battery light comes on.

Stop using the CK60 for five 
minutes or longer.

Store the CK60 for more than a 
day.

Checking the Battery Status
The battery status LED above your CK60 keypad, as shown in the 
following illustration, indicates the status of your battery. See the following 
table to understand the meanings of the lights emitted from the LED. 

Battery status LED

Battery Status LED

LED Color Description

Steady Green Battery is more than 95% charged and computer is on a charger.
Blinking Red Battery is low.
Steady Red Main battery is on charge.
Steady Amber The battery is either out of the computer or the pack temperature is 

too hot or too cold to charge.

You can also use the Power applet to view the status of this battery. Tap 
Start > Settings > Control Panel. Double-tap the Power icon, then tap the 
Power tab. Tap OK to exit this applet. 

1 Press the power switch to turn off the CK60.
2 Remove the battery and insert another fully 

charged battery as quickly as possible or you may 
lose state. Or, insert the CK60 into a powered 
quad battery charger.

1 Make sure the low battery icon is not on the 
screen and that the Battery light is not turned on.

2 Press the power switch to turn off the CK60.
1 Save your state and end your computer session.
2 Press the power switch to turn off the CK60.
3 Insert a fully charged battery.
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Adjusting the Beeper
For information about setting volume levels for screen taps, ActiveSync 
alert noises, etc., tap Start > Help.

To enable the beeper

To disable the beeper

1 Tap Start > Settings > Control Panel, then double-tap the Volume 
& Sounds icon.

2 Check for which features the CK60 should enable sounds, then tap 
OK to close. 

1 Tap Start > Settings > Control Panel, then double-tap the Volume 
& Sounds icon.

2 Clear the options to disable their sounds, then tap OK to close. 
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Using the Intermec Settings Applet
Use the Intermec Settings applet to gather, view, and update device 
configuration settings. Information about the settings you can configure 
with the Intermec Settings applet is in the Intermec Computer Command 
Reference Manual available online at www.intermec.com.

See the Data Collection Resource Kit in the Intermec Developer Library 
(IDL) for information about data collection functions. The IDL is available 
as a download from the Intermec web site at www.intermec.com/idl. 
Contact your Intermec representative for more information.

To access the Intermec Settings applet 

Using the Keypad
Your CK60 has one of the following keypad overlay options: a 32-key large 
numeric keypad or a 58-key full alphanumeric keypad.

32-Key Large Numeric Keypad
This keypad is for applications that enter mainly numeric data (0-9). It also 
lets you enter special characters by pressing color-coded key sequences.

8

5

7 9

4 6

321

0
.

-

Esc Enter

1 Tap Start > Settings > Control Panel. 

2 Double-tap the Intermec Settings icon to access the applet. 
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58-Key Full Alphanumeric Keypad
This keypad is for applications that enter mainly numeric data (0-9) and 
that may need to enter the entire alphabet. This keypad also provides shift 
function keys (F1-F24) and special characters, symbols, and functions by 
pressing color-coded key sequences. 

Using the Color-Coded Keys
Each keypad available for the CK60 provides color-coded keys to let you 
access additional characters, symbols, and functions printed on the keypad 
overlay. Once you understand how to use the color-coded keys and key 
sequences, you will know how to access all of the additional features printed 
on the keypad overlay. There are two color-coded modifier keys on the 
CK60: the orange B key and the green C key.

You press and release the first key, then press and release the second key to 
access the color-coded character or function printed above a key. Note that 
there are several hidden characters (such as < or >) on each CK60 keypad 
that require using the color-coded keys to access them.

Capitalizing All Characters
To type all alphanumeric characters as uppercase letters, you can enable the 
Caps Lock feature on the CK60 keypad. To enable Caps Lock, on the 58-
key keypad, press the B key, then the Space key. Press the same key 
sequence to disable the Caps Lock.

Using the Power Key
When you press the power button to turn off the CK60, you actually put 
the CK60 in Suspend mode. In Suspend mode, the CK60 continues to 
supply power to all memory, but turns off power to most hardware. This 
power-saving feature is to prolong battery life.

When you press the power button to turn the CK60 back on, your 
computer resumes where it was when you turned it off. If the Battery light 
flashes and the CK60 does not resume after pressing the power button, 
your battery may be too low to supply power. Replace the battery.
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Turning on the Keypad Backlight
To adjust the keypad backlight for work in low-light settings:

4 Make your selection, then tap OK. 

Using the Screen
The CK60 has a 3.8" diagonal, 240x320 pixel (QVGA) transflective  
TFT-LCD 64K color display. The screens support Unicode characters, 
user-programmable fonts, and bitmap graphics. The Start screen has two 
distinct areas: the desktop and the taskbar. The desktop displays shortcuts 
to some of the applications installed on the CK60. The taskbar displays the 
Start menu, the time, the onscreen keyboard icon, and the desktop icon. 

Desktop

Taskbar

1 Tap Start > Settings > Control Panel. 

2 Double-tap the Backlight icon. 

3 Tap the right arrow, then tap the Keyboard tab. 
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Your CK60 has a stylus for selecting items and entering information. Use 
the stylus in place of a mouse.
Things You Can Do with a Stylus

Action How to Do the Action

Tap Touch the screen once with the stylus to select options, close 
applications, or launch menus from the taskbar.

Double-tap Touch the screen twice with the stylus to launch applications.
Drag Hold the stylus on the screen and drag across to select text and 

images.
Tap and hold Tap and hold the stylus on an icon to see a list of actions 

available for the item. On the pop-up menu that appears, tap 
the action to perform.

Using Software Tools
The following Intermec software tools are available as free downloads:

SmartSystems Foundation Console (www.intermec.com/SmartSystems)
This tool includes a management console that provides a default method to 
configure and manage Intermec devices “out-of-the-box,” without the 
purchase of additional software licenses. This is for anyone who must 
configure and deploy multiple devices or manage multiple licenses.

SmartSystems Platform Bundles (SSPB)
The SmartSystems Platform Bundle (SSPB) is a bundle of software that 
contains the Data Collection Engine (DCE), SmartSystems, Funk 
Supplicant, Intermec Settings, and Intermec Developer Library (IDL) 
runtime.

The SSPB is stored in the “\Flash File Store” folder off the root of your 
CK60 and automatically installed on the device when it is initially started 
up. Updated bundles are available as software downloads from the Intermec 
web site at www.intermec.com/SmartSystems. Click Downloads on the 
left to access the latest.

Intermec Resource Kits (www.intermec.com/IDL)
Resource Kits provide tools that build applications using the features of 
Intermec devices. Resource kits include: Bluetooth, Communications, Data 
Collection, Device Settings, Mobile Gadgets, Printing, and RFID.

This is for anyone who develops software for the CK60.
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Using the Speakers
The high-volume speaker on the back of the CK60 is capable of variable 
volume levels. This speaker is capable of reproducing voice and WAV files, 
and is used primarily to convey status tones. There is a separate volume 
control in the Intermec Settings and Volume & Sounds applets. 
Information on these applets is on the next page.

High-volume speaker on center, back

Do not place the speaker next to your ear when the speaker volume is 
set to “Loud” (maximum), or you may damage your hearing.

The front speaker is a full-voice range speaker of cell-phone quality with a 
separate volume control. See below for information on this volume control.

Front Speaker
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To adjust the volume using the Volume & Sounds applet

To adjust the volume using the Intermec Settings applet

1 Tap Start > Settings > Control Panel. 

2 Double-tap the Volume & Sounds icon. 

3 Tap the Volume tab, drag the slider bar to the right to the “Soft” 
position, then tap OK to exit this applet. 

To disable the speaker, tap the Soft button to drag the slider all the way 
to the left. 

1 Tap Start > Settings > Control Panel. 

2 Double-tap the Intermec Settings icon.

3 Tap (+) to expand Device Settings > Beeper > Volume. 

4 Tap any of the options other than “Off” to enable and adjust. 

To disable the speaker, tap the Off option. 
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Using the Status Indicators
The status indicators on the CK60 turn on to indicate the battery status or 
a successful bar code decode. The battery indicators and screen icon work 
to alert you to your battery status. If the battery indicator (to the right of 
the Scan button) comes on, check the toolbar to see what icon appears. The 
battery may be critically low and need replacing. The green Good Read 
indicator above the display appears when you have decoded a bar code 
successfully.

Using the Secure Digital Card
Note: MultiMediaCards (MMCs) and CompactFlash (CF) storage cards 
are not supported in the CK60.

Use a SanDisk Secure Digital card to increase file storage and install 
software. Its card slot is on the top of the CK60 just above the scanner 
window. Do the following to insert a card in the CK60:
You can corrupt your Secure Digital card if you do not follow these 
installation and removal procedures exactly. Before installing a Secure 
Digital card, inspect the gasket on the door for any damage or wear, 
and replace the door if any damage or wear is found

1 Press the power switch to turn off the CK60.

2 Remove the two screws on the Secure Digital card slot door and remove 
the door (see the following illustration). Be sure to torque the screws to 
this door to 1.5 in-lbs. 

3 Gently insert the Secure Digital card into the CK60 with the printed 
side facing the keypad and screen side of the CK60.

4 Push the card into the slot until it latches in place and the steel card 
retainer covers the end of the Secure Digital card.

5 (Optional) Replace the door, insert the door catch into the slot above the 
steel card retainer, replace the two screws, then press the power button to 
turn on the CK60. 

6 To remove the card, push in on the Secure Digital card until you hear it 
unlatch. The card should eject far enough that you can easily remove it 
from the CK60. If the card does not eject easily, turn the door upside 
down, then use the catch to pull out the Secure Digital card.

Screw Screw
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Physical and Environmental Specifications
Use this section to locate technical information about the CK60 and its 
available features and options.

Physical Dimensions
Length: 22.2 cm (8.75") 
Width: 9.0 cm (3.55") 
Height: 5.3/3.6 cm (2.08"/1.4") at top/keypad 
Weight: 704 g (24.8 oz)

Hardware
Microprocessor: Intel XScale PXA272 520MHz 
Memory: 64 or 128 MB 
Flash ROM: 64 MB 
Persistent Storage: 128 MB, provides onboard non-volatile  

storage of applications and data 
Removable Storage: SDIO Card Slot, user-accessible 
Keypad: 32-key with large numeric keys or  

58-key with full alphanumeric keys;  
both with LED backlighting

Operating System
Microsoft Windows CE 5.0

Software
Development Environments:Embedded Visual C++ 4.0,  

.NET Compact Framework v2.0  
(VB. NET, C#) 

IDL: Integrates with leading development  
environments; supports device-specific  
features and bar code scanning 

Browser support: Internet Explorer 6-compatible

Bar Code Scanning
Options of Integrated 2D Area Imager or 1D & PDF417 Linear Imager 
Supports all popular 1D and 2D symbologies including Australian Post, 
British Post, Codabar, Codablock A, Codablock F, Code 11, Code 2 of 5, 
Code 39, Code 93, Code 93i, Code 128, Datamatrix, Dutch Post, ISBT 
128, Interleaved 2 of 5, Macro 2 of 5, Matrix 2 of 5, Maxicode, Micro 
PDF417, MSI, PDF417, Planet, Plessey, Postnet, QR Code, RSS 14, RSS 
Expanded, RSS Limited, Telepen, TLC39, UCC-EAN Composite Code, 
UPC/EAN

Standard Communications
USB Host and Client, Ethernet 10/100 Base-T, Bluetooth Class 1, V2.0 + 
EDR, RS232 Serial, IrDA 1.1
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Wireless LAN
Standards Compliant: IEEE 802.11g (2.4 GHz - OFDM) 

IEEE 802.11b (2.4 GHz - DSSS) 
IEEE 802.11a (5.0 GHz - OFDM) 

Data Rates: Up to 54 Mbps for 802.11g 
Up to 11 Mbps for 802.11b 
Up to 54 Mbps for 802.11a 

Radio Power Output: 50 m W 
Security: WEP, WPA, 802.11i, 802.1x  

(EAP-TLS, TTLS, LEAP, PEAP) 
Certifications: Wi-Fi, WPA2, Cisco Compatible Extensions 

V2

Device Management
SmartSystems™ Support: Centralized remote support capability;  

configures, updates, and maintains single  
devices or entire populations;  
real-time or batch, wired or wireless.  
Based on Wavelink Avalanche™ with  
Intermec value added utilities.

Power Specifications
Operating: Removable, rechargeable Li-ion battery pack; 

AB11 7.2 V, 2400 mAh (17.3 Watt-hours);  
battery life is application-dependent; 
recharging cycle is 4 hours or less

Backup: Super capacitor supplies 10 minutes bridge  
time while replacing the main battery

Electrical Specifications
External Charge Power: 11 to 28 VDC @ 1.5 A max. (18 W max.)

Environment
Operating temperature: -20° to 50°C (-4° to 122°F) 
Storage temperature: -30° to 70°C (-22° to 158°F) 
Humidity: 5% to 95% noncondensing 
Electrostatic Discharge: +8kV Contact Discharge; +15kV Discharge 
Rain and Dust Resistance: IP64 compliant 
Drop Survival: Multiple 6 ft (1.8 m) drops to steel or concrete

Screen Specifications
Transflective TFT; QVGA Color with touch panel; 240x320 pixels;  
9.7 cm (3.8 in) diagonal active area; 5-level LED backlight control with 
high and low settings

Regulatory Approvals
UL and cUL Listed, UL 60950 and UL 1604 and CSA 22.2 No. 157, FCC 
Part 15, TUV, CE mark
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Accessories for the Computer
You can use these accessories (sold and ordered separately) with the CK60. 
To order accessories, contact your local Intermec representative.

AC4 Quad Battery Charger
Use the Quad Battery Charger to charge up to four batteries without 
having to remove them from the CK60. You can insert up to four CK60s 
with batteries installed making it easy to remember to charge your batteries 
overnight. The charger also provides power to your CK60s while 
communicating via Ethernet.

AD3 Ethernet Multidock
Use the AD3 Ethernet Multidock to hold up to four CK60s with a 
batteries installed. The multidock charges the batteries, provides power to 
the CK60s, provides one Ethernet connector, and provides a serial port for 
each inserted CK60.

AD5 Single Dock
Use the AD5 Single Dock to hold a CK60 with its battery installed. The 
single dock charges the battery, provides power to the CK60, provides an 
Ethernet connector, provides a USB port, provides an ActiveSync USB 
port, and provides a serial port for the inserted CK60.

AD6 Single Dock with Modem
Use the AD6 Single Dock with Modem to hold a CK60 with its battery 
installed. The single dock charges the battery, provides power to the CK60, 
provides an ActiveSync USB port, provides a standard USB port, and 
provides a telephone line connector for the inserted CK60.

CK60 Holster and Belt
Use the holster and belt to carry your CK60while not using it. The holster 
and belt support either right- or left-handed use and you can use it to carry 
a CK60 with or without a handle. You can only use this with a CK60 that 
has either the 1D linear imager or the 2D imager.

CK60 Handstrap
The removable and adjustable handstrap make it easy for you to hold and 
use the CK60 without tiring your hand.

CK60 Power Adapter, AA6 USB Adapter, and Snap-On Adapters
Provides power to all of the docks and chargers.
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2Windows CE

This chapter introduces Microsoftr Windowsr CE 5.0. While using your 
CK60 Mobile Computer, keep this key point in mind:

• Tap Start on the task bar, located at the bottom, left corner of the screen, 
to quickly move to programs, files, and settings. Use the task bar at the 
bottom of the screen to perform tasks in programs. The task bar includes 
menus, buttons, and the onscreen keyboard.

Note: Desktop and applet icons are shown to the left. Any place that Start 
is mentioned, tap the following Windows icon in the bottom, left corner of 
your CK60 desktop. 
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Software Builds
See “Learning Software Build Versions” on page 3 to determine which 
Intermec build of Windows CE is on your unit.

Where to Find Information
This chapter describes your CK60 hardware, provides an overview of the 
programs on your CK60, and explains how to connect your CK60 to a 
desktop, a network, or the Internet. For instructions on setting up your 
CK60 and installing ActiveSync, see the Quick Start Guide. The following 
is a guide to more information to assist you use your CK60.

For information on: See this source:

Programs on your handheld computer. This chapter.
Connecting to and synchronizing with a PC. The Quick Start Guide or ActiveSync Help on your PC.
Last-minute updates, detailed technical information. Read Me files in the Microsoft ActiveSync folder on the PC.
Up-to-date information on Windows CE device. msdn.microsoft.com/embedded/downloads/ce/default.aspx

Windows CE and many of the technologies supported by the CK60 are not 
from Intermec. Many of the utilities and features on a Windows CE device 
come directly from Microsoft without any modification from Intermec. 
There may be certain Microsoft-specific issues that Intermec would not be 
able to support, so contact our front-line support personnel to determine 
the best source of assistance.

Use these URLs for additional information about Microsoft Windows CE:

• msdn.microsoft.com/support

• support.microsoft.com

• www.microsoft.com/technet/community/newsgroups/security/
default.mspx (a free support option)

Basic Skills
Learning to use your CK60 is easy. This section describes the basic 
concepts of using and customizing your CK60.
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Desktop Screen
When you turn on your CK60 for the first time each day, you see the 
Desktop screen. 

Tap to list open windows

Tap to activate the input panel
Double-tap to change time format

Tap to scroll to other programs

Tap to open an associated program

Tap to bring up the Start menu

To customize what is displayed on the Desktop screen, including the 
background image, tap Start > Settings > Control Panel, then double-tap 
the Display icon.

Status icons display information such as low batteries or when the CK60 is 
connected to a PC or to the Internet. You can tap an icon to open the 
associated setting or program.

Programs
You can switch from one program to another by selecting it from the Start 
menu. To access some programs, tap Start > Programs, and then the 
program name.

Start Menu and Task Bar
The Start Menu is at the bottom of the screen above the task bar. It displays 
the active program, and allows you to switch to programs and close screens. 

Tap to see more programs
Tap to see websites
Tap to see text files and other documents
Tap to configure your unit

Tap to learn more about an application

The task bar at the bottom of the screen includes the Start flag, the Input 
Panel icon, and the system tray with the current time and notification. 

Input Panel iconStart flag
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Notifications
Your device can notify you in any of the following notification types:

• A message box appears on the screen.

• A sound, which you can specify, is played.

• A light flashes on your CK60.

Entering Information
You can enter information on your CK60 in several ways, depending on 
the type of device you have and the program you are using:

Typing Using the input panel, enter typed text into the CK60. Do this by tapping 
keys on the onscreen keyboard or by using handwriting recognition software.

Writing Using the stylus, write directly on the screen.
Drawing Using the stylus, draw directly on the screen.

Use the input panel to enter information in any program on your CK60. 
You can either type using the onscreen keyboard or write using Transcriber 
(described on page 25). The characters appear as typed text.

To show the input panel, tap the Input Panel icon, then tap Keyboard. To 
hide the input panel, tap the Keyboard icon, then tap Hide Input Panel. 

Input Panel icon

Select an input method

Large Keys Versus Small Keys on “Soft” Keyboard
The default setting for the onscreen or “soft” keyboard is with small keys. If 
you want to use larger keys, tap Start > Settings > Control Panel, then 
double-tap the Input Panel icon. Tap Options for the Soft Keyboard 
Options, then select Large keys. Tap OK, then OK again to close. Below 
are the “soft” keyboards. 

with large keys

with small keys
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Typing With the Onscreen Keyboard
Tap the stylus input icon, then tap Keyboard. On the soft keyboard that is 
displayed, tap the keys with your stylus.

• To type lowercase letters, tap the keys with the stylus.

• To type a single uppercase letter or symbol, tap the Shift key. To tap 
multiple uppercase letters or symbols, tap the CAP key. Note that the 
CAP key only appears when the keyboard is set to small keys.

• To convert a letter to uppercase, tap and hold the stylus on the letter and 
drag up.

• To add a space, drag the stylus to the right across at least two keys.

• To backspace, drag the stylus to the left across at least two keys.

• To insert a carriage return, tap and hold the stylus on the keyboard and 
drag down.

Using Transcriber
With Transcriber, you can write on the screen with the stylus just as you 
would on paper. You can write a sentence or more of information, then 
pause and let Transcriber change written characters to typed characters.
For specific instructions on using Transcriber, double-tap the Transcriber 
shortcut on the desktop screen or tap the Transcriber option in the Input 
Panel menu, then tap Help. Tap OK to close the Transcriber Intro box. 

To enable the Transcriber, tap the Input Panel icon on the task bar, select 
Transcriber, tap OK to close the Transcriber Intro, select an option, then 
write anywhere on the screen for the input to appear in the active window. 
Tap the Input Panel icon, then select Hide Input Panel, to disable. 

Input Panel icon

Selecting Typed Text
If you want to edit or format typed text, you must select it first by dragging 
the stylus across the text.

You can cut, copy, and paste text by tapping and holding the selected words 
and then tapping an editing command on the pop-up menu, or by tapping 
the command on the Edit menu.
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Finding and Organizing Information
Use the Windows Explorer to find and organize files on your CK60. Tap 
Start > Programs > Windows Explorer. 

Double-tap a folder to open it.

Customizing Your Computer
You can customize your CK60 by adjusting settings and installing 
additional software.

Adjusting Settings
You can adjust settings to suit the way you work. To see available options, 
tap Start > Settings > Control Panel, then double-tap any of the applets. 
You might want to adjust the following:
Date/Time 
To change the time or calendar.

Display 
To customize the look of the desktop.

Owner 
To enter your contact information.

Password 
To limit access to your CK60.

Power 
To maximize battery life.
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Adding or Removing Programs
Programs added to your CK60 at the factory are stored in ROM (Read 
Only Memory). You cannot remove this software, and you cannot 
accidentally lose ROM contents.

You can install any program created for your CK60, as long as your CK60 
has enough memory. The most popular place to find software for your 
CK60 is on the Windows CE .NET web site (msdn.microsoft.com/
embedded/downloads/ce/default.aspx).

Adding Programs Using Microsoft ActiveSync
Install software developed for the CK60 onto your PC before installing the 
same software onto your CK60. Once installation is complete, tap Start > 
Programs, then the program icon to switch to it.

2 Download the program to your PC (or insert the CD or disk that 
contains the program into your PC). You may see a single *.EXE or 
*.ZIP file, a SETUP.EXE file, or several files for different CK60 types 
and processors. Be sure to select the program designed for the Windows 
CE and your CK60 processor type.

3 Read any installation instructions, Read Me files, or documentation that 
comes with the program. Many programs provide instructions.

4 Connect the CK60 and PC, then double-click the *.EXE file.

• If the file is an installer, the installation wizard begins. Follow the 
directions on the screen. Once the software is installed, the installer 
automatically transfers the software to your CK60.

• If the file is not an installer, a message states the program is valid but is 
for a different computer. Move this file to your CK60 using Microsoft 
ActiveSync Explore to copy the program file to the “My 
Computer\Program Files” folder on your CK60.

1 Determine your CK60 and processor type so that you know which 
version of the software to install. Tap Start > Settings > Control Panel, 
then double-tap the System icon. Note the processor information on the 
General tab beneath the Computer heading. 
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Adding a Program Directly from the Internet
Install the appropriate software for your CK60 on your PC before installing 
it on your CK60. Once installation is complete, tap Start > Programs, then 
the program icon to switch to it.

2 Download the program to your CK60 straight from the Internet using 
Internet Explorer. You may see a single *.EXE or *.ZIP file, a 
SETUP.EXE file, or several versions of files for different CK60 types and 
processors. Be sure to select the program designed for the Windows CE 
and your CK60 processor type.

3 Read any installation instructions, Read Me files, or documentation that 
comes with the program. Many programs provide instructions.

4 Tap the file, such as *.EXE file to start the installation wizard. Follow the 
directions on the screen.

Adding a Program to the Start Menu
You can either use Windows Explorer on the CK60 to move the program 
to the “\My Computer\Windows\Start Menu” folder, or use Microsoft 
ActiveSync on the PC to create a shortcut to the program and place the 
shortcut in the “\My Computer\Windows\Start Menu” folder.

Using Windows Explorer on the Computer
Tap Start > Programs > Windows Explorer, locate the program, tap and 
hold the program, then tap Cut on the pop-up menu. Open the “\My 
Computer\Windows\Start Menu” folder, tap and hold a blank area of the 
window, then select Paste to have the program appear on the Start menu.

Using Microsoft ActiveSync on the PC
Use the Explore feature in Microsoft ActiveSync to explore your CK60 files 
and locate programs. Right-click the program, click Create Shortcut, then 
move the shortcut to the “\My Computer\Windows\Start Menu” folder for 
it to appear on the Start menu. See ActiveSync Help for more information.

Removing Programs

1 Determine your CK60 and processor type so that you know which 
version of the software to install. Tap Start > Settings > Control Panel, 
then double-tap the System icon. Note the processor information on the 
General tab beneath the Computer heading.

Tap Start > Settings > Control Panel, then double-tap the Remove 
Programs icon. If the program does not appear in the list of installed 
programs, use Windows Explorer on your CK60 to locate the program, tap 
and hold the program, and then tap Delete on the pop-up menu.
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Microsoft ActiveSync
Tap Start > Settings > Control Panel, then double-tap the PC Connection 
icon. Tap Change Connection, select the connection type from the list. 

Visit the following Microsoft web site for the latest in updates, technical 
information, and samples: 

msdn.microsoft.com/embedded/downloads/ce/default.aspx

With Microsoft ActiveSync, you can back up and restore your CK60 data, 
and copy files between your CK60 and your PC. 

Install Microsoft ActiveSync on the desktop of your PC from the following 
URL. For more information, on installing Microsoft ActiveSync, see your 
Quick Start card. ActiveSync is already installed on your CK60. 

msdn.microsoft.com/downloads/

After installation is complete, the ActiveSync Setup Wizard helps you 
connect your CK60 to your PC or set up a partnership so you can browse 
for or move data between your CK60 and your PC.
Note: While ActiveSync does synchronize files between your PC and your 
CK60, the Windows CE operating system does not include Calendar, 
Contacts, Tasks, Inbox, Channels, and Pocket Access applications.

Microsoft WordPad
WordPad works with Microsoft Word on your desktop to access copies of 
your documents. You can create new documents on your CK60, or you can 
copy documents from your desktop to your CK60. Synchronize documents 
between your PC and CK60 to have up-to-date content in both locations.
To access WordPad, either double-tap the Microsoft WordPad icon on 
your desktop, or select Start > Programs > Microsoft WordPad. For more 
information on using Microsoft WordPad, select Start > Help > 
WordPad.

Creating a Document
Use WordPad to create documents, such as letters or meeting minutes. To 
create a new file, tap File > New, then select either a blank document or a 
template, depending on what you have selected in the Tools > Options 
dialog box. Select an input mode from the View menu.

You can open only one document at a time; when you open a second 
document, you have to save the first. Documents you create or edit are 
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usually saved as WordPad (.WPD), but you can also save documents in 
other formats such as Word (.DOC) or Rich Text Format (.RTF).

Windows Explorer contains a list of files stored on your CK60. Double-tap 
a file to open it. To delete, make copies of, and rename files, tap and hold a 
file in the list, then, select the action on the pop-up menu. 

Tap any of the headers to change the order of the list

Double-tap to open a document

Press and hold a document to see its pop-up menu

You can change the zoom magnification by tapping View > Zoom, then 
select the percentage you want. Select a higher percentage to enter text and 
a lower one to see more of your document.

If you are opening a Word document created on a desktop, you may select 
View > Wrap to Window so that you can see the entire document.

To check spelling, select text, then tap Tools > Spell Check. To use your 
new document as a template, move the document to the Templates folder.

Typing Mode
Enter typed text into the document using the keypad. For information on 
entering typed text, see “Entering Information” on page 24.

To format existing text and to edit text, first select the text. You can select 
text as you do in a Word document, using your stylus instead of the mouse 
to drag through the text you want to select. You can search a document to 
find text by tapping Edit > Find. 

Tap to return to the document

Tap to hide or show the keypad
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Writing Mode
With Transcriber enabled, use your stylus to write directly on the screen. 
The zoom magnification is greater than in typing mode to allow you to 
write more easily. For more information on writing and selecting writing, 
see “Entering Information” on page 24. 

Transcriber enabled

Synchronizing WordPad Documents
You can synchronize WordPad documents with Word documents on your 
desktop. Select the Files information type for synchronization in 
ActiveSync to have the My Documents folder for the CK60 is created on 
your desktop, then place all the files to synchronize in this folder. You 
cannot synchronize password-protected files.

All WordPad files stored in My Documents, subfolders are synchronized 
with the desktop. ActiveSync converts documents during synchronization.  
For information on synchronization or file conversion, see ActiveSync Help 
on the desktop.
Note: When you delete a file on either your desktop or your CK60, the file 
is deleted in the other location when you synchronize.
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Internet Explorer
Use Microsoft Internet Explorer to view web sites. To do this, create the 
connection first via an ISP or network (“Remote Access (Modems)” on 
page 86), then you can also download files and programs from the Internet
To switch to Internet Explorer on your CK60, double-tap the Internet 
Explorer icon on your desktop. 

Viewing Mobile Favorites and Channels
Tap Favorites from the tool menu to display your list of favorites, then tap 
the page you want to view. 

Tap to add or delete a folder or a link

Tap the favorite you want to view

Browsing the Internet
1 Set up a connection to your ISP or corporate network using information 

as described in “Remote Access (Modems)” on page 86.

2 To connect and start browsing, do one of the following:

• Tap Favorites from the toolbar, and then tap the favorite to view.

• In the Address bar that appears at the top of the screen, enter the web 
address you want to visit using the input panel, then tap the [Enter] 
key on the panel to go to that web site. 

Type the web address here
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• Tap the drop-down arrow to select from previously entered addresses. 

Media Player
To switch to this application, tap Start > Programs > Media Player, or 
double-tap the Media Player icon on the desktop. For more information 
about using Windows Media, tap Start > Help, then select a topic.

 

Use Windows Media Player on your desktop to copy digital audio and 
video files to your CK60. You can play Windows Media and MP3 files on 
your Windows Mobile.

Indicates the progress of the current track

Tap to adjust the volume

Tap to skip to the next songTap to play the previous song

Tap to play or pause

Tap to download from the Internet

Note: To add a favorite link while using the CK60, go to the page you 
want to add, then select Favorites > Add to Favorites.

Tap for a list of addresses
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3Configuring the Computer

Use this chapter to understand how to install applications onto your CK60 
Mobile Computer and how to configure the CK60 to communicate in 
your network. 
Note: Desktop and applet icons are shown to the left. Any place that Start 
is mentioned, tap the following Windows icon in the bottom, left corner of 
your CK60 desktop. 
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Developing Applications for the Computer
CK60s run applications programmed in Microsoft Embedded Visual C++. 
Use this section to understand what you need to:

• Develop a new application for the CK60.

• Convert an application from an older computer to a CK60 application.

To develop applications for your CK60, use the Resource Kits in the 
Intermec Developer Library (IDL). Download the IDL from the Intermec 
web site at www.intermec.com/idl. Contact your Intermec representative 
for more information.

You need the following hardware and software components to use the 
Resource Kits:

• Pentium PC, 400 MHz or higher

• Windows 2000 (Service Pack 2 or later) or Windows XP (Home, 
Professional, or Server)

• For native C++ development, Microsoft eMbedded Visual C++ version 
4.0

• For Windows CE 5.0, eVC 4.0 SP4 is required 
• 128 MB RAM (196 MB recommended)

• 360 MB hard drive space for minimum installation (720 MB for 
complete)

• CD-ROM drive compatible with multimedia PC specification

• VGA or higher-resolution monitor (Super VGA recommended)

• Microsoft Mouse or compatible pointing device

Converting Older Computer Applications to CK60 Applications
If you have an existing application that you would like to run on the CK60, 
you can use the Migration Resource Kit to convert that application. The kit 
has a set of libraries and tools to convert your existing “C” applications into 
C++ applications for use on the CK60.

As you migrate from another computer to a CK60, you need to consider 
when converting other computer applications to run on the CK60, most 
APIs should work without changes, with the exception that arrow and tab 
keys may be reversed from other computers. Keyboard remapping is 
available on the CK60 should you need to map these keys like that of the 
other computer.

You need the following hardware and software components to use the 
Migration Resource Kit:

• a PC with at least 1MB of free disk space running Microsoft Windows 
2000 or Windows XP
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• Microsoft eMbedded Visual C++ version 4.0 with Service Pack 2

• Intermec Resource Kits and development tools

• Migration Resource Kit, which contains these files and utilities:

• Functions library

• Header files

• Example files

The Migration Resource Kit is part of the IDL, which is available as a 
download from the Intermec web site at www.intermec.com. Contact 
your Intermec representative for more information.

Packaging Applications for the Computer
Use any of these methods to package applications for installation:

• You could package an application as a cabinet (.cab) file. Recommended

• For simple applications, the application itself may be the file to deliver.

• It could be a directory structure that contains the application, supporting 
files like ActiveX controls, DLLs, images, sound files, and data files.

Consider any of the following when choosing a location into which to store 
your application:

• In the basic CK60, there are two built-in storage options: the Object 
Store and the Flash File Store. The Object Store is a Disk on Chip 
(DOC) Flash that looks like a disk. The Flash File Store is an area of 
storage which is embedded in a section of the system FLASH memory. 
This storage area is not erased during a cold-boot. It may, however, be 
erased during the reflashing process.

• If the optional Secure Digital (SD) storage card is in the system, then 
consider this card the primary location to place applications installation 
files. The “\SD Card” folder represents the SD card.

• Use the small non-volatile Flash File Store region to hold .cab files that 
rebuild the system at cold-boot or install applications from a .cab file into 
the Flash File Store so they are “ready-to-run” when a cold-boot is 
performed. Since the FLASH in the system has a limited number of 
write cycles, do not use the Flash File Store for excessive writing 
purposes; however, reading is okay.

Cab files (short form of “cabinet” files) are compressed folders as defined by 
Microsoft. A “cabinet” file is a single file, usually suffixed with .cab, that 
stores compressed files in a file library. A compressed file can be spread over 
several cabinet files. During installation, the setup application 
decompresses the files stored in a cabinet and copies them to the user’s 
system. Intermec recommends using .cab files to install your applications. 
The CK60 uses standard Windows CE .cab files and does install  
third-party .cab files.
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For the CK60, .cab files register DLLs, create shortcuts, modify registry 
entries, and run custom setup programs. Tap a .cab file to extract that file 
or place the .cab file on one of the approved storage devices in the 
“\CabFiles” folder, then perform a warm-boot on the CK60. There are two 
methods available to extract a .cab file:

• Tap a .cab file to extract it. With this method, the .cab file is 
automatically deleted when the extraction process is successful, unless the 
.cab file is set with the read-only attribute.

• Use the AutoCab method to extract all files when a cold-boot is 
performed on the CK60. This method is available in the Software Tools 
User’s Manual via the IDL, which is downloadable from the Intermec 
web site at www.intermec.com/idl. Contact your Intermec 
representative for information.

Installing Applications on the Computer
Consider any of these options to get the package to the preferred location 
on your CK60: 

• Microsoft ActiveSync (below)

• Secure Digital storage cards (page 39)

• SmartSystems™ Console (page 40)

Using Microsoft ActiveSync
You can use Microsoft ActiveSync to establish a connection between your 
PC and the CK60. Microsoft ActiveSync transfers files, synchronizes files, 
performs remote debugging, and other device management activities.

See Chapter 2 “Windows CE” for information about the Microsoft 
ActiveSync application as provided by Microsoft Corporation.

This can be a serial, a USB, or an 802.11b/g Microsoft ActiveSync 
connection. Files can be copied using Windows Explorer on a PC or a 
laptop computer. This is usually good when updating a few CK60s.

These instructions assume that Microsoft ActiveSync was installed onto 
your PC and is up and running. If not, go to Chapter 2 “Windows CE” 
for an URL from which to download the latest application.

1 Connect the CK60 to a PC using a USB or serial cable. You may have to 
detach, then reattach the cable to “wake” the connection.

2 Wait for a “Connected” message to appear in the Microsoft ActiveSync 
application to signal a connection to the CK60. If necessary, select File > 
Get Connected to initiate a connection or detach, then reattach the USB 
or serial cable.
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5 Within the “Mobile Device” folder, go to the folder where you want the 
files located on the CK60, do a right-click for a pop-up menu, then 
select Paste.

6 When all of the files are pasted, perform a warm-boot on the CK60. 
When the computer reboots, wait for the LED on the top left of your 
keypad to stop blinking. Tap Start > Programs > Windows Explorer to 
locate the newly copied executable files, then tap these files to activate 
their utilities.

Using a Secure Digital Card
If you have a Secure Digital card for your CK60, this is the best place for 
you to install applications.

1 If you are using a Secure Digital card reader, suspend the CK60, remove 
its Secure Digital card, and place it in the reader. For help, see “Using 
the Secure Digital Card” on page 16.

2 Copy your application file to the Secure Digital card. If you are using 
Microsoft ActiveSync to copy the files to the Secure Digital card, place 
the application in the “\SD Card” folder on the CK60.

3 If using a Secure Digital card reader, insert the Secure Digital card back 
into the CK60.

4 Navigate to the “\SD Card” folder and run your application. After your 
application is installed, you can run it from the Programs menu.

3 Click Explore to access the “Mobile Device” folder on your unit.

4 From your PC, select Start > Windows Explorer, then browse the 
“C:\Intermec\CK60 Mgmt Tools\CabFiles” path for any .cab files 
needed for your CK60. Select the appropriate file, right-click the file for 
a pop-up menu, then select Copy.
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Using the SmartSystems Console
Use the SmartSystems Console to drag-and-drop Intermec applications 
onto your CK60s. The CK60 ships with the SmartSystems client loaded on 
it. The console is part of SmartSystems Foundation and is available from 
the Intermec web site. To download SmartSystems Foundation, go to 
www.intermec.com/idl and open the Device Management page.
To use SmartSystems Console to install an application

1 Download your application file from the Intermec web site and unzip it 
on your desktop.

2 From the SmartSystems Console, drag-and-drop the application onto 
each CK60 discovered in your network.

For information on using the SmartSystems Console, see the online help.

Launching Your Application Automatically
Note: This describes the system component startup for Intermec provided 
components only. It does not describe the bootstrap loader process. It only 
describes the component installation process provided by Windows CE. It 
is assumed that you understand the Microsoft CE startup procedures and 
are familiar with how Microsoft components start up.

You can configure the various media used in the Windows CE system with 
a folder name and can change the media in the registry of the system. Many 
of the startup components rely on folder names to locate information files, 
applications, or other related data.

The registry keys used by FolderCopy and other startup components to 
retrieve the folder names are as follows:

Flash File Store 
[HKLM\Drivers\BuiltIn\FlshDrv] 
“FolderName”=“Flash File Store”

SD Card 
[HKLM\System\StorageManager\Profiles\SDMemory] 
“Folder”=“SD Card”

Disk On Chip 
[HKLM\System\StorageManager\Profiles\TRUEFFS_DOC] 
“Folder”=“DiskOnChip”

During normal system startup, there are Intermec-specific and non-
Intermec components that require an orderly start to properly function. 
These non-Intermec components may also need to start themselves so the 
CE device can function properly. Since there are possible configurations 
that come from using one or more optional built-in peripheral devices, the 
platform components on the next page are required to manage startup.

Note: On standard CK60 builds, this is mapped to Object Store and does 
not appear as an actual device to which you can navigate. If any are mapped 
as Object Store, they are not addressable via the defined folders.
40 CK60 Mobile Computer with Windows CE User’s Manual

http://www.intermec.com/idl
http://www.intermec.com/idl


Chapter 3 —  Configuring the Computer
PreShell
PreShell.exe is launched prior to the Microsoft Shell and must execute a 
SignalStartup call before the Microsoft Shell launches.

PreShell searches the “\Flash File Store\SYSTEM” folder for an executable 
of the same name. If one exists, that application is launched. This 
application can do what is desired prior to launching the Microsoft Shell. 
This feature allows end customers to make their own application the shell 
of the system. If desired, do not exit the custom shell nor call SignalStarted.

PostShell
PostShell.exe can launch an application after the Microsoft Shell has 
launched. There are utility applications that exist that can take advantage of 
“hooking” the startup for maintenance, for example.

PostShell searches the “\Flash File Store\SYSTEM” directory for an 
executable of the same name. If one exists, that application is launched 
instead. This application can do what a customer desires and is launched 
after the Microsoft Shell starts initialization. The Microsoft Shell does not 
require complete initialization before this application begins and that may 
cause some application or system issues. These issues are expected and are 
considered normal for those developing PostShell applications. The 
application must test if the APIs it requires are available.

RunAutoRun
System components are installed and configured during the power up 
process from a single starting point. RunAutoRun.exe, built into the 
operating system image and located in the “\Windows\Startup” folder, 
checks for AutoExec.exe in a “\SYSTEM” folder on a mounted volume in 
this order:

• Secure Digital

• Object Store - may be non-volatile storage or RAM

• Disk On Chip - may map as Object Store

• Flash File Store - may map as Object Store. This is the default location 
for the AutoExec program in Intermec systems. Intermec system 
applications are started from this folder. The ordering of mounted 
volumes overrides this feature.

The folder names used for the mounted volumes above are retrieved from 
the registry to maintain coherence with the naming of the mounted 
volumes on the platform. These folder names are not hard-coded. If 
AutoExec is present in the “\SYSTEM” folder on any of these media, it 
executes the program only on the first media in which it is found.

AutoExec is reserved for Intermec use to configure Intermec-specific 
applications. It launches the CAB installer, AutoCab.exe, to install platform 
.cab files to the system, such as Intermec Data Collection.
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When the AutoCab.exe process completes, RunAutoRun then checks for 
the existence of AutoRun.exe and executes this program from the first 
media found. This order is the same as what is used by AutoExec.

AutoRun is reserved for customer use to configure application launch 
sequences. It launches the CAB installer, AutoCab, as well as customer 
programs added to the autouser.dat file and is described on the next page.

runautorun 

autoexec autorun 

autocopy autoreg foldercopy customer 
applications 

autocab autocab 

AutoExec
AutoExec.exe automates operations such as pausing, launching processes, 
or signaling, and is configured through the AutoExec data file 
(AuotExec.dat). This script file must be in the same folder as the program. 
Note: Intermec considers the usage of the AutoExec data file as “Intermec 
Private.” AutoExec installs Intermec applications such as Data Collection, 
Security Supplicants, Intermec Management, applets, and shortcuts from 
components found in the Flash File System. Do not modify the AutoExec 
data file. Instead, use the AutoRun program to add software components.

Usage: 
AutoExec [-%[W]] [-E=["X"]] [-F=["Y"]] [-LOG=] [-W=[Z]]

The return code from the process uses the standard error codes defined in 
WinError.h. Keywords that AutoExec supports are:

-% Passes an ID to use in a call to SignalStarted. This argument is useful only during system startup that relies on 
a SignalStarted to call. W is an integer value.

-E Passes a signal event name to use when autoexec completes. X is a string value.
-F Overrides the data file to use. This must be a fully qualified name. Default is “autoexec.dat” in the same 

location as the AutoExec.exe program. Y is a string value.
-LOG Sets value logs activity to AutoExec.txt (in same location as the AutoExec.exe program). Default is disabled.
-W Pauses the autoexec process by calling sleep for the number of seconds specified by Z. Z is an integer value.

QUIET Enables user notification when an error occurs.
LOGGING Enables logging to a trace file.
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Examples of keyword usage are as follows:
; Allow message pop up if an error occurs. 
QUIET 0

; Log any debug output to a trace file. 
LOGGING 1

; Perform a SetEvent on the event name "autoexec_started". 
SIGNAL "autoexec_started"

; Include this child data file, childexec.dat. 
CALL "\childexec.dat"

; Use autocopy to copy the audio control panel from flash file store to the 
windows directory. Wait for up to 60 seconds for it to exit. 
EXEC "\Flash File Store\SYSTEM\autocopy.exe" -S"\Flash File 
Store\System\CPLAudio.cpl" -D"\Windows\CPLAudio.cpl"

; Change the default EXEC wait time to 90 seconds. 
EXECWAIT 90

; Suspend processing any commands for 10 seconds. 
WAIT 10

; Suspend processing any commands until event called MyEventName is signaled. 
WAITFOR "MyEventName"

AutoRun
AutoRun.exe automates operations such as launching other processes and is 
configured through the AutoRun data file (AutoRun.dat). This script file 
must be in the same directory as the program itself.

AutoRun supports the following script commands in AutoUser.dat and 
AutoRun.dat.
Note: If you need to add steps at boot time, add them to AutoUser.dat, not 
to AutoRun.dat. AutoRun.dat is provided by Intermec and is subject to 
change. AutoUser.dat is the designated place for the end user to add steps 
to the boot time process.

SIGNAL Enables the specified named event and is immediately signaled. Useful for notifying other components 
of the current status.

CALL Opens another .DAT file to process. After the called file is completed, this file is resumed.
RUN Runs a program with a SW_SHOWNORMAL attribute. Autoexec does not wait for the child process to 

exit.
LOAD Runs a program with a SW_HIDE attribute. Autoexec waits for 60 seconds for the child process to exit 

or EXECWAIT seconds if set.
EXEC Runs the specified program. AutoExec waits 60 seconds for the child process to exit or EXECWAIT 

seconds if set.
EXECWAIT Changes the default EXEC wait time from 60 seconds to the number of seconds specified. There is a 

maximum 10-minute limit imposed.
WAIT Forces a sleep for the specified number of seconds to occur.
WAITFOR Forces a sleep until the named event is signaled.
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EXEC Launches a specified program, waits for it to complete (up to 10 minutes).
CALL Processes a specified file of commands and returns.
CHAIN Processes a specified file of commands and does not return.
RUN Loads a specified program and executes it.
LOAD Loads a specified program and executes it.

AutoRun handles quoted file names for the first parameter which specifies 
path names or file names that contain white space. Note only one set of 
quotes per command is supported. AutoRun.dat entry examples:

RUN “Flash File Store\Apps\some.exe” arg1, arg2, arg3
CALL “Flash File Store\SYSTEM\usercmds.dat”

AutoCopy
AutoCopy.exe copies or moves files from one location to another. It has no 
user interface and is configured through command line arguments. It has 
support for these parameters, in no particular order:

Usage: 
AutoCopy [-D["W"]] [-L["X"]] [-M[D]] [-Q[Y]] [-S["Z"]] 

The return code from the process uses the standard error codes defined in 
WinError.h.

Example:
; use AutoCopy to copy the control panel from flash file store to windows.  
autocopy.exe -S"\Flash File Store\System\Audio.cpl" -D"\Windows\Audio.cpl"

; use AutoCopy to move the control panel from flash file store to windows.  
autocopy.exe -M1 -S"\Flash File Store\System\Audio.cpl" -D"\Windows\Audio.cpl"

AutoReg
AutoReg.exe adds registry information to the Windows CE registry. It has 
no user interface and is configured through command line arguments. 

-D Indicates the destination file name and must be fully qualified. W is a string value.
-L Indicates a fully qualified file name for logging to enable. Default is disabled. X is a string value.
-M Moves file to a destination rather than copies the file. Default value is disabled. D is an integer value. D=1 

indicates enabled, 0 is disabled.
-Q Indicates if a message box should appear when an error occurs. Default is disabled. Y is an integer value.
-S Indicates a source file name and must be fully qualified. Z is a string value.
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Usage: 
AutoReg [-D] [-HKey] [-Q] “filename”

The process return code uses the standard error codes defined in 
WinError.h.

Example:
; use AutoReg to install this registry information. 
autoreg.exe "\Flash File Store\install.reg"

; use AutoReg to install this registry information. Delete the file afterwards. 
autoreg.exe -D "\Flash File Store\install.reg"

; use AutoReg to extract registry information to a file.  
autoreg.exe -HHKEY_LOCAL_MACHINE\Software\Intermec\Version "\version.reg"

The format of the input file, in this example, is the standard registry format 
which should ease the creation of the input file since there are many 
publicly available utilities to generate a registry file besides Notepad. One 
example of a tool is the Microsoft Remote Registry Editor.

AutoCab
AutoCab.Exe extracts files, registry settings, and shortcuts from Windows 
CE cabinet (.cab) files. The Windows CE startup sequence invokes 
AutoCab as a part of AutoExec and AutoRun. During the Windows CE 
startup sequence, AutoCab processes all .cab files in the “\CabFiles” 
directory relative to the current location of Autocab, unless the location is 
overridden by command line arguments. AutoCab can run as a stand-alone 
program to install a .cab file or a directory of .cab files.

AutoCab only installs the .cab file if it was not installed before by AutoCab. 
To track the installation of a .cab file, AutoCab marks the .cab file with the 
System attribute. This attribute is ignored if the device is performing a 
cold-boot on a non-persistent file system.

AutoCab preserves the .cab file after installation if the ReadOnly attribute 
is set. If not set, the .cab file is deleted automatically after installation.

Usage:
AutoCab [-ChkRst=][-File=][-Force][-Log=][-Move=][-Quiet=][-Show=][-Signal=]

-D Deletes the registry file after successfully loading it. This allows for systems that have hives implemented.
-H Saves the registry path, and all child entries, to the specific .REG registry file.
-Q Indicates whether a message box should appear when a fatal error occurs.
filename Fully qualified file name to read from or write to, encased in double quotes to support spaces in paths or 

file names. See examples on the next page.
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Command line switches are described below.

-ChkRst= Set to 1 to configure AutoCab to check for the Reset flag after all .cab files are installed. This file is created 
by .cab files that want a warm reset after installation. Default is 0 (do not check for flag).

-File= Specifies the .cab files to extract. Note that the specified files need not end with the .cab extension.
-Force Forces the specified .cab files to extract regardless of whether it was previously extracted.
-Log= Set to 1 to create a log file in the same folder that AutoCab is running. Useful for debugging .cab 

installation. Default is 0 (disabled).
-Move= Set to 1 to force source .cab file deletion, even when read-only bit set on file. Default is 0 (disabled).
-Quiet= Set to 0 to allow AutoCab to display user message box on errors. Useful for debugging .cab installation. 

Default is 1 (keep quiet).
-Show= Set to 0 to prevent showing any installation progress interfaces. Also prevents user from canceling 

installation. Set to 1 to show normal installation. Set to 2 to show Intermec installation progress interface 
(user can see what is installing but cannot cancel it). Default is 1 (show normal).

-Signal= Set to string name of signal to use at the completion of .cab installation before a reboot occurs (if 
enabled). AutoCab uses WaitForSingleObject on this name. Default is disabled.

If <PathName> references a single .cab file, that file is processed. If 
<PathName> references a directory, all the .cab files in that directory is 
processed. If <PathName> is a wild card pattern, all files matching that 
pattern is processed, If <PathName> is omitted, InstallCab processes all the 
.cab files in directory “\CabFiles.”

Example:
; Install all .cab files in the \Flash File Store\XYZ directory, regardless. 
AutoCab -FILE="\Flash File Store\XYZ\*.cab" -FORCE

; Install only one .cab file, use Intermec .cab installation display 
AutoCab -FILE=”\myCab\app.cab” =show=2

Customizing How Applications Load on the Computer
If you have several processes that you need running in a specific order as the 
CK60 turns on, you can use the AutoRun system to customize the way 
applications load. For compatibility with other Intermec computers, you 
can place a copy of AutoRun.exe in the same folder as your AutoRun.dat 
file but it is not required.

To create and install the AutoRun.dat file on your CK60

1 On the CK60, create a folder called “SYSTEM.”

2 On your desktop, open the Notepad application.
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3 Write commands for AutoRun.dat with these script commands:

4 Save this Notepad file as AutoRun.dat.

5 Copy the AutoRun.dat file to the “\SYSTEM” folder on your CK60.

During every boot, the system scans for AutoRun.dat in the “\SYSTEM” 
folder.

Here is a sample AutoRun.dat file that runs a dialer application and 
connects to a VPN:
EXEC “\Program Files\My Dialer\Dialer.exe” 348-2600 
EXEC “\Program Files\My VPN\Connect.exe” MyDomain

Configuring CK60 Parameters
You can configure many parameters on the CK60, such as bar code 
symbologies or the network settings using the Intermec Settings applet. 

You can control some characteristics with configuration parameters. The 
values you set for these parameters determine how the CK60 operates.

Configuring with the Setup Assistant
When first setting up the CK60, use the Setup Assistant to set or enable 
basic network parameters and connect your CK60 to the network. The 
Setup Assistant helps set the date and time (including time zone), SSID 
(Network name), DHCP server or IP address, subnet mask, and default 
router, primary and secondary DNS or WINS addresses, and device name.

To set other parameters, use another configuration method, such as with 
the Intermec Settings applet described in the next section. You can initiate 
the Setup Assistant manually. After the Setup Assistant is done, the CK60 
should communicate with the network and add an icon in the taskbar.

Script Command Description

EXEC Launches a specified program and waits up to 10 minutes for it to complete.
CALL Processes a specified file of commands, returns. When you use the CALL command, the execution 

of the current file pauses while a new file that follows the same set of commands executes. Once 
the new file completes executing, AutoRun.exe continues processing the current file.

CHAIN Processes a specified file of commands and does not return. This command calls another file that 
follows the same set of commands and stops processing the current file.

RUN Loads a specified program and executes it. Specifies the show window attribute so that the user 
interface is visible when the application launches.

LOAD Loads a specified program and executes it. Specifies the hide window attribute so the user interface 
is hidden initially.
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Configuring the Computer With Intermec Settings
Use the Intermec Settings applet to configure the CK60 and view system 
information. You can access the Intermec Settings applet while running any 
application. 

To access the Intermec Settings applet:

For detailed information on most of the commands available in the 
Intermec Settings applet, see the Intermec Computer Command Reference 
Manual (P/N 073529) from the Intermec web site. Go to “Related 
Documents” on page x for information how to download this .chm file.

Synchronizing the Computer System Time with a Time Server
The time on all CK60s must be synchronized with a network time server to 
ensure real-time communications and updates. Network time servers 
acquire Coordinated Universal Time (UTC) from an outside source such as 
the U.S. Naval Observatory (USNO). Simple Network Time Protocol 
(SNTP) is used to synchronize with a network time server.

The default reference time server is the USNO (tock.usno.navy.mil). To 
synchronize the CK60 time with this time server, have a valid connection 
to the Internet. You can also synchronize the CK60 system time with a 
corporate network server within your firewall that is SNTP-capable.

Configuring the Computer through the Network
You can change the configuration parameters of the CK60 by sending 
commands through a host computer or through the network. If you are 
using a network, you can configure one or more CK60s at a time. You can 
remotely configure the wireless or Ethernet CK60 by sending a command 
from an application on the host computer. Note that you cannot set all 
parameters through the network. You can only set those commands that have a 
syntax in the Intermec Computer Command Reference Manual.

1 From the CK60 desktop, select Start > Settings > Control Panel.

2 Double-tap the Intermec Settings icon. 
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Note: You can continue running an application on the CK60 while 
configuring it from the host computer.

Configuring the Computer in a TCP/IP Direct Connect Network
You can use the host computer to configure a wireless or Ethernet CK60 in 
your TCP/IP network. To send and receive configuration data, write a host 
application that can communicate with the CK60 directly through an 
access point or through the Ethernet network. Use the TMF protocol to 
send and receive transactions between the host application and the CK60.

To set up the host computer, verify you can communicate with the CK60. 
To set up the application, prepare and write a host application that can 
communicate with the Intermec Application Server and send or receive 
transactions to and from the CK60 in this format:

TMF field commands

where:

TMF field 2-byte field containing one of these values:
• CG - Configuration Get request sent from the host application.
• Cg - Configuration Get response sent from the CK60 to the host computer.
• CS - Configuration Set request sent from the host application.
• Cs - Configuration Set response sent from the CK60 to the host computer.

commands Reader and configuration commands to set on the CK60 or current values to retrieve from the CK60. To 
save configuration changes in flash memory, send .+1 reader command as last command. For list of all 
commands, see Intermec Computer Command Reference Manual.

Example
In the host application, you want to get the current values of two 
configuration commands from the CK60. Send the CG$+NABV transaction 
from the host application
Note: The transaction header is not shown in this example. You do not 
need a transaction header for a host application in a TCP/IP network, but 
you do for a UDP Plus network.

where:

CG TMF Configuration Get request.
$+ Change Configuration reader command.
BV Beeper Volume configuration command.

The CK60 returns the following transaction to the host application:
CgS+BV4

where:

Cg TMF Configuration Get response.
$+ Change Configuration reader command.
BV4 Beeper Volume command set to 4 (very high beeper volume)
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Configuring the Computer in a UDP Plus Network
You can use the host computer to configure a CK60 in your wireless or 
Ethernet network. To send and receive configuration data or files, you need 
to write a host application that can communicate with an Intermec 
Application Server (formerly Gateway or DCS 30X).

For help, see the appropriate Gateway or DCS 30X User’s Manual. Use the 
Terminal Message Format (TMF) protocol to send and receive transactions 
between the host application and the CK60.

To set up the Intermec Application Server, configure a peer-to-peer 
destination name for the host application. Create a transaction ID, 
$NGCFGRSP, to route to this destination name. The Intermec 
Application Server uses the transaction ID to route responses from the 
CK60 back to the host application. $NGCFGRSP is a special transaction 
ID the server uses to forward configuration response data from a CK60.

All configuration responses are routed with the $NGCFGRSP transaction 
ID. The Intermec Application Server cannot track multiple applications 
sending reader or configuration commands. If you have two host 
applications sending reader or configuration commands, they must both be 
configured to receive the $NGCFGRSP transactions, and therefore both 
receive all responses from all CK60s.

To set up the host computer, verify that the host computer can 
communicate with the Intermec Application Server.

To set up the application, prepare and write a host application that can 
communicate with the Intermec Application Server and send transactions 
to and receive transactions from the CK60 in this format. For an example of 
the host application transaction, see page 49.

transaction header TMF field commands

where:

transaction 
header

96-byte field with message number, date, time, source application ID, destinations application ID, 
transaction ID, and other information. Set system message (SYS$MSG) flag to E in transaction header.

TMF field 2-byte field containing one of these values:
• CG - Configuration Get request sent from the host application.
• Cg - Configuration Get response sent from the CK60 to the host computer.
• CS - Configuration Set request sent from the host application.
• Cs - Configuration Set response sent from the CK60 to the host computer.

commands Reader and configuration commands to set on the CK60 or current values to retrieve from the CK60. To 
save configuration changes in flash memory, send .+1 reader command as last command. See Intermec 
Computer Command Reference Manual for list of supported commands.

Reprogramming the Keypad
This addresses basic keypad remapping changes for the CK60, to redefine 
basic virtual key values generated by the CK60 keypad. Other, more 
advanced options such as multi-keys and named events are not covered 
here. For more advanced options, contact your Intermec representative.
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Implementation
The CK60 keypad virtual key mappings are controlled by registry entries 
read each time the keypad driver loads. You can “remap” the keypad after it 
has loaded by modifying the registry entries and then sending a signal to 
the keypad driver to re-read the registry mappings. The keypad driver uses 
the scan code values returned by the keypad device as an index into these 
registry entries to determine the virtual key value sent to the system.

Registry Entries
There are three main “shift plane” registry entries which map the keypad 
device scancodes to the windows virtual key values. Each registry entry is an 
array of 128 WORDs (2 byte unsigned int, little endian). Since scan codes 
generated by the keypad device can range in value from 0x00 to 0x7f, the 
driver uses the generated scan code value as an index into one of the shift 
plane entries to determine the virtual key value sent up to the system.

The shift plane registry entry used is determined by the current state of the 
Orange and Green keys. If the Orange key is held down, then the “Orange 
shift plane” array is used. If the Green key is held down, then the “Green 
shift plane” array is used. If neither Orange nor Green key is held down, 
then the “Normal, unshifted plane” array is used. 

The name of the three registry entries that define the Normal, Orange, and 
Green shift planes are:
HKLM\HARDWARE\DEVICEMAP\KEYBD\xxxx\Vkey (Normal) 
HKLM\HARDWARE\DEVICEMAP\KEYBD\xxxx\VkeyGold (Orange) 
HKLM\HARDWARE\DEVICEMAP\KEYBD\xxxx\VkeyAlpha (Green)

Where xxxx is a four-digit keypad ID which identifies the type of keypad 
on your CK60. 

These are the registry entries (which are arrays of 128 WORDs) you need 
to modify to remap your keypad.

Programming the Keypad
Do the following to change a single key on the CK60 keypad. You can 
change more than one key, if desired.

1 Identify your keypad 
Read the four bytes of text stored in the registry entry. For this example, 
this value is referred to as <KPID>.

HKEY_LOCAL_MACHINE\Drivers\BuiltIn\KEYPAD\ActiveConfig

2 Read the shift plane mapping 
Read each of these key values into a WORD array of size 128. Note that 
not all keypads have entries for VkeyGold and VkeyAlpha.

HKLM\HARDWARE\DEVICEMAP\KEYBD\<KPID>\Vkey (Normal) 
HKLM\HARDWARE\DEVICEMAP\KEYBD\<KPID>\VkeyGold (Orange) 
HKLM\HARDWARE\DEVICEMAP\KEYBD\<KPID>\VkeyAlpha (Green)
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3 Modify the shift plane mapping 
Write the desired virtual key value to the scan code offset of the desired 
shift plane.

You can use the scan code diagrams on the next page to find the scan 
code for the keys to remap. Note that scan code 00h is the left scan trigger, 
scan code 10h is the right scan trigger, and all values are hexadecimal.

4 Save the modified shift plane mappings 
Write the registry values back.

5 Signal the keypad to reload 
Open the “ITC_KEYBOARD_CHANGE” named event and call 
SetEvent() to signal the keypad to reload.

Alphanumeric Scan Codes

Orange key Green key

Numeric Scan Codes

Orange key Green key
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Configuring the SF51 Cordless Scanner
The following information pertains to configuring the SF51 Cordless 
Scanner to work with your CK60. These instructions assume you have 
EasySet version 5.4 or later installed on your desktop or laptop. EasySet is 
available at no charge from the Intermec web site at www.intermec.com.

Imager Settings
Depending on what is selected as the scanner model, image settings, decode 
security, scanner settings, and virtual wedge are configured from the 
Intermec Settings applet. See the Intermec Computer Command Reference 
Manual, available from the Intermec web site for information.

Enabling Bluetooth
On the CK60, use the Intermec Settings applet to enable Bluetooth 
communications before you configure the SF51.

4 Select On to enable Bluetooth. 

5 Tap Yes to refresh the power and save the settings. 

6 Tap File > Save Settings, then File > Exit to close the applet.

1 Select Start > Settings > Control Panel. 

2 Double-tap the Intermec Settings icon.

3 Tap (+) to expand Communications > Bluetooth > Power. 
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The following table contains the Bluetooth options in the Intermec 
Settings applet and their descriptions:

Bluetooth Features in Intermec Settings Applet

Option Description

Discoverable Check this to ensure your CK60 is discoverable to other Bluetooth devices. The default is for the 
CK60 to be undiscoverable as it does not offer any incoming services out of the box.

Connectable Check this to allow other Bluetooth devices to connect to your CK60. The default is for the CK60 to 
be unconnectable as it does not offer any incoming services out of the box.

Class of Device This sets how a CK60 appears to other devices during a device search. The default is “0x920100” 
which specifies that the CK60 is capable of services of information, object transfer, and networking.

IBT IBT = Intermec Bluetooth 
Version number of the library of Bluetooth functionality that ships on the device and is documented 
in the Intermec Developer Library.

Radio Universally unique and cannot be changed - read-only.
Device Address Universally unique and cannot be changed - read-only.

Creating an SF51 Connection Label
To initiate a connection from the SF51, use EasySet to create an SF51 
connection label with the CK60 Bluetooth address. The device address is 
listed in the Intermec Settings applet on your CK60.

To create an SF51 connection label
1 On your desktop or laptop, double-click the EasySet icon if you have 

not already done so.

2 In the commands window, double-click Data transmission settings > 
Bluetooth parameters > connect/disconnect > compose BT address. 
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3 Enter the Bluetooth address assigned to your CK60 (shown in your 
Intermec Settings applet), then click OK to close.  

4 The connection label for the SF51 appears to the right in EasySet, 
similar to the following. Scan the label once, then confirm the blue 
Intermec Ready-to-Work™ indicator on the SF51 starts blinking, which 
means it is trying to connect. 

5 Enter the PIN number when prompted, such as “0000.”

6 When connected, the blue Intermec Ready-to-Work indicator assumes a 
steady blue.

Viewing SF51 Scanner Information from Your Computer
Note in the CK60, the Intermec Settings applet can display up to seven 
separate SF51 connections. The following illustration shows such 
connections under the Data Collection option.

To view SF51 scanner information

3 Tap Data Collection, then tap (+) to expand the SF51 Scanner 
connections to view MAC addresses, firmware version numbers, and 
whether each scanner is connected to the CK60.

1 From the CK60 desktop, select Start > Settings > Control Panel.

2 Double-tap the Intermec Settings icon. 
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4 When you clear (uncheck) Enable scanner port, the SF51 is 
disconnected from the CK60. Check Enable scanner port again to 
reconnect.

5 Select File > Save Settings to put these settings into effect.

If you want to rename these connections to descriptions more suitable for 
your situation, press the stylus on each SF51 Scanner connection for a pop-
up menu, then select Rename. Enter the new description, then press Enter 
to save your entry.

When the SF51 is connected, configuration changes take effect 
immediately. When the SF51 is not connected, configuration changes take 
effect once the SF51 is reconnected.

Configuring Bluetooth Communications for Wireless Scanners
You can send and receive information to devices wirelessly using the 
Bluetooth radio. The Bluetooth technology uses short-range radio links and 
allows for communications over a 10 m (32.8 ft) range.

Enabling Bluetooth
On the CK60, use the Intermec Settings applet to enable Bluetooth 
communications before you configure the wireless scanner. See “Enabling 
Bluetooth” on page 53 to enable Bluetooth.

To allow incoming connections from wireless scanners

1 In the Intermec Settings applet, tap (+) to expand Communications > 
Bluetooth > Power.

2 Tap (+) to expand Discoverable, then select Enable.

3 Tap (+) to expand Connectable, then select Enable.

4 Select File > Save Settings, then File > Exit to close the applet. 

Note: To avoid incoming connections, disable both the Discoverable and 
the Connectable options.
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Connecting to the Wireless Scanners
With the Bluetooth Scanner Wizard, you can connect up to seven scanners 
using device search, manual entry, Quick Connect bar code scan, or choose 
from previously used devices.

To connect to a wireless scanner

4 Tap Add Device, select one of the options provided on the screen, then 
tap Next to continue: 

• Search (next page)

• Manual (page 59)

• Quick Connect (Incoming) (page 60)

1 From the CK60, select Start > Programs > Windows Explorer. 

2 Browse to the “\Program Files\Intermec\Network\Bluetooth” folder.

3 Double-tap the BluetoothScannerWizard icon. 
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Search
You can set your scanner via a Bluetooth Device Discovery, which takes 
about half a minute to locate all Bluetooth scanners in your range. Select 
Search, then tap Next to discover such scanners.

To find the Bluetooth scanners using Search

1 Momentarily, Bluetooth scanners discovered within range appear. If 
your preferred scanner is in the list, select to highlight the scanner, then 
tap Next. 

2 If you do not see your preferred scanner, make sure this scanner is 
powered on and set to “discoverable” or “visible,” then tap Search. Tap 
Back to return to the first screen without making changes. 

3 If prompted for an authentication request, enter the passcode such as 
“0000,” then tap OK. The passcode is provided by the manufacturer of 
your Bluetooth audio device. You can usually find your passcode in the 
user manual that came with the Bluetooth device. 

4 Tap Finish to save your discovery and close the wizard.
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Manual
Use this feature to enter the remote device address, if you know the 
Bluetooth Device Address of the scanner you want to use.

To avoid device discovery and perform a manual setup

1 Select Manual, then tap Next to go to the Manual Set screen. 

2 Type the address of your scanner in the field, then tap Next. 

Tap Back to return to the first screen without making changes. 

3 When you set your scanner manually, your device does not receive the 
scanner name. Therefore, “-unknown-” is displayed unless you enter the 
correct value in to the registry in some other way.
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Quick Connect (Incoming)
This feature allows you to take your scanner and attach it to the CK60 by 
scanning a bar code provided by the wizard. 

To do a quick connection

1 Select Quick Connect (Incoming).

2 Tap Next to go to the QuickConnect screen. 

3 Scan the bar code with your scanner, then tap Finish to close the wizard.

Tap Back to return to the first screen without making changes. 

Disconnecting a Wireless Scanner
Should you need to remove a scanner from communications with your 
CK60, do the following:
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To disconnect a wireless scanner

1 Tap Remove Scanner from the initial wizard screen. 

2 Select to highlight a scanner from the list of DCE Devices.

3 Tap Disconnect to stop communications.

4 Tap Back to return to the initial wizard screen or Finish to close the 
wizard. 

Using Configuration Parameters
A configuration parameter changes the way the CK60 operates, such as 
configuring a parameter to have the CK60 emit a very loud beep in a noisy 
environment. Use either of these methods to execute configuration 
parameters:

Scan EasySet bar code labels:
You can use EasySet from Intermec Technologies Corporation to print 
configuration labels. Scan the labels to change the imager configuration and 
data transfer settings. For information, see its online help.

Send Reader Commands through the Network or from an Application
You can configure parameters by sending reader commands through the 
network or from an application. See the Intermec Computer Command 
Reference Manual for more information.
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Use this chapter to upgrade the operating system, run diagnostics, solve 
problems you may encounter, and perform routine maintenance on your 
CK60 Mobile Computer:
Note: Desktop and applet icons are shown to the left. Any place that Start 
is mentioned, tap the following Windows icon in the bottom, left corner of 
your CK60 desktop. 
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Upgrading the Operating System on your Computer
You can use the Intermec Recovery Tools CD to reinstall or upgrade the 
operating system software on the CK60. Contact your Intermec 
representative for more information about this CD.

Use the SmartSystems™ Foundation 2.0 application from Intermec to 
perform upgrades on your CK60, versions 2.0 or later. Contact your 
Intermec representative for more information about the SmartSystems 
Foundation software.

When you upgrade the operating system, you erase the current 
configuration and replace it with the new default configuration. You will 
need to reset the network parameters on the CK60 to reestablish 
communications with other devices in the network. In other words, if you 
upgrade the operating system and the default registry from the operating 
system has changed, the registry is rolled back to the new default.

When you upgrade your CK60, you are updating the operating system 
(OS) and the Persistent Storage Manager (PSM) files.

The PSM files are stored on the DiskOnChip, and deliver Intermec value-
added functionality such as data collection, unit configuration and 
diagnostics, and Intermec’s wireless security suite. As new features are 
added to these components, you can upgrade your PSM files without 
needing to upgrade the operating system image. Similarly, features added to 
the operating system image do not affect the functionality of the PSM, and 
you can choose to upgrade only the operating system image.

There are two ways to upgrade the CK60:

• You can use a Secure Digital card to upgrade the CK60. For help, see 
“Using a Secure Digital Card to Upgrade the Computer” on page 65.

• You can use the SmartSystems Console to upgrade the CK60. For help, 
see “Using the SmartSystems Console to Upgrade the Computer” on 
page 67.

You need to download the latest upgrade files from the Intermec web site to 
your desktop PC, and then determine if you will be upgrading both 
operating system and PSM files, just the operating system, or just the PSM 
files.

To download the latest upgrade files

1 Start your web browser and go to the Intermec web site at 
www.intermec.com.

2 Go to Service & Support > Downloads.

3 Select Computers: CK60 Mobile Computer from the drop-down list. 
A list of available downloads appears.

4 Choose which download you need. Make sure the download you select is 
for the CK60.
64 CK60 Mobile Computer with Windows CE User’s Manual

http://www.intermec.com


Chapter 4 —  Maintaining the Computer
5 Look at the description (or the ReadMe file) to determine if this 
download will upgrade both the operating system and PSM files, just the 
operating system, or just the PSM. You will need this information later.

6 Click the link and download the .zip file to your PC.

7 If you are using a Secure Digital card to upgrade the CK60, see below.

If you are using the SmartSystems Console to upgrade the CK60, see 
“Using the SmartSystems Console to Upgrade the Computer” on 
page 67.

Using a Secure Digital Card to Upgrade the Computer
To use a Secure Digital card to upgrade the CK60, you need a Secure 
Digital card reader and a Secure Digital card formatted as FAT16
Note: The CK60 currently supports SanDisk Secure Digital cards only. 
Intermec cannot guarantee that other Secure Digital cards will work with 
the CK60.

• For both the operating system and PSM files, see below.
• For just the operating system, see “Upgrading the Operating System” 

on page 66.
• For just the PSM files, see “Upgrading the Persistent Storage Manager 

Files” on page 66.

Upgrading Both Operating System and PSM Files Simultaneously
You may download files that upgrade both the operating system and PSM 
files simultaneously.

1 Extract the upgrade files to a Secure Digital card. Make sure you select 
the option to use folder names when extracting the files.

2 Remove the battery pack from the CK60 and place the CK60 in a dock 
connected to external power. For help, see “Charging and Installing 
the Battery” on page 7.

3 Insert the Secure Digital card in the CK60. For help, see “Using the 
Secure Digital Card” on page 16.

4 Using a stylus, press the Reset button inside the battery cavity. 

5 When the Bootloader Menu appears, remove the Security Digital card, 
then press the Reset button again.

Note: The upgrade will fail if the CK60 is not connected to external 
power. For help, see the accessories list in “Accessories for the Com-
puter” on page 19.

Do not use force or a sharp object when pressing the Reset button, or 
you may damage the button.
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When the CK60 finishes rebooting, you may use it. You have reset the 
CK60 to its default configuration. You need to set the date and time and to 
set its network communications parameters to reestablish communications 
with the other devices in the wireless network.

Upgrading the Operating System
You may download files that upgrade only the operating system.

1 Extract the upgrade files to a Secure Digital card. Make sure you select 
the option to use folder names when extracting the files. You should see 
the NK.boot and EBOOT.bin files.

2 Remove the battery pack from the CK60 and place the CK60 in a dock 
connected to external power. For help, see “Charging and Installing 
the Battery” on page 7.

3 Insert the Secure Digital card in the CK60. For help, see “Using the 
Secure Digital Card” on page 16.

4 Using a stylus, press the Reset button inside the battery cavity.

5 On the CK60, select Update Bootloader + OS, then press Enter. 
Messages about the download status appear at the bottom of the screen. 
The “Need Reboot” message appears and Cold Boot is selected.

6 Press Enter. The CK60 performs a cold boot and the Refreshing File 
System status box appears. If the Confirm File Replace dialog box 
appears, tap Yes To All. The CK60 finishes rebooting, and your 
operating system is updated.

When the CK60 finishes booting, you may use it. You have reset the CK60 
to its default configuration. You need to set the date and time and to set its 
network communications parameters to reestablish communications with 
the other devices in the wireless network.

Upgrading the Persistent Storage Manager Files
You may download files that upgrade only the PSM files.

1 Extract the upgrade files to a Secure Digital card. Make sure you select 
the option to use folder names when extracting the files. You should see 
the “2577” and “DOCImage” folders.

2 Remove the battery pack from the CK60 and place the CK60 in a dock 
connected to external power. For help, see “Charging and Installing 
the Battery” on page 7.

Note: The upgrade will fail if the CK60 is not connected to external 
power. For help, see the accessories list in “Accessories for the Com-
puter” on page 19.

Do not use force or a sharp object when pressing the Reset button, or 
you may damage the button.
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3 Insert the Secure Digital card in the CK60. For help, see “Using the 
Secure Digital Card” on page 16.

4 Using a stylus, press the Reset button inside the battery cavity.

5 A prompt appears to state the PSM is updating. When this process is 
complete, the CK60 performs a cold boot again and installs the files. 

After the CK60 performs a cold boot, the Refreshing the File System 
dialog box appears. Your CK60 is loaded with the new PSM files.

6 Remove the Security Digital card, insert the battery, then install the 
battery door. You may use the CK60.

Using the SmartSystems Console to Upgrade the Computer
Use the SmartSystems Console to upgrade the operating system on your 
CK60. The console is part of SmartSystems Foundation and is available 
from the Intermec web site via the IDL. Before you can upgrade your 
computer, you need:

• the SmartSystems Foundation. To download SmartSystems Foundation, 
go to www.intermec.com/idl and open the Device Management page.

• the device upgrade .exe file, which is available from the Intermec web site 
at www.intermec.com. Go to Service & Support > Downloads.

To upgrade a CK60 using the SmartSystems Console

1 Install SmartSystems Foundation on your PC and open the console.

2 Make sure the console and the CK60s are on the same subnet.

3 Make sure your CK60s are either in a communications dock, or that 
power management is disabled.

4 Download the device upgrade .exe file to your desktop PC.

5 Double-click the .exe file on your desktop PC. An InstallShield 
application starts and walks you through the process of extracting the 
upgrade files in the default location.

6 From the SmartSystems Console, locate the device upgrade to install.

7 Drag-and-drop the device upgrade onto each CK60 icon. 

Note: The upgrade will fail if the CK60 is not connected to external 
power. For help, see the accessories list in “Accessories for the Com-
puter” on page 19.

Do not use force or a sharp object when pressing the Reset button, or 
you may damage the button.

Note: Do not change the default location where InstallShield extracts 
files. The SmartSystems Console requires files be located in the default 
directory.
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Once the upgrade is done downloading, your CK60 replaces the operating 
system, then automatically performs a cold boot. 
The SmartSystems Console shows the CK60 as offline (via a red stop sign) 
until the CK60 reboots and reconnects to the system.

Troubleshooting Your Computer
• Problems While Operating the Computer (page 68)
• Problems While Configuring the Computer (page 69)
• Problems While Configuring 802.1x Security (page 69)
• Problems with Wireless Connectivity (page 70)
• Problems Transmitting Data through the Serial Port (page 70)
• Problems While Scanning Bar Codes (page 71)
Before sending the CK60 in for service, save its data and configuration. 
Intermec is responsible only for the keypad and hardware features to match 
the original configuration when doing repairs or replacements.

Problems While Operating the Computer 

Problem Solution

You press the power button to turn on the CK60 and 
nothing happens.

The Battery status LED is on.

The CK60 appears locked up and you cannot enter data.

• Make sure the backlight is on by pressing E.
• Make sure you have a charged battery installed correctly. 

For help, see “Using the Battery” on page 6.
• The battery may be discharged. Replace the battery with 

a spare charged battery, or charge the battery.
• Perform a warm-boot.
• If the battery status LED is a steady green, the battery is 

more than 95% charged and unit is on a charger.
• If the battery status LED is blinking red, then the 

battery is low. The speed of the blinking increases as the 
battery power gets increasingly lower.

• If the battery status LED is a steady red, the main 
battery is on charge.

• If the battery status LED is a steady amber for more than 
12 hours, then replace the battery pack.

• Press the power button to turn off the CK60, then press 
the power button again to turn on the CK60.

• Press and hold the power button for ten seconds to 
warm-boot the CK60.

• Perform a clean-boot on the CK60. See “Resetting 
Your Computer” on page 3.

• Try reloading the firmware. See “Upgrading the 
Operating System on your Computer” on page 64.

• If the CK60 does not boot or reset, contact your local 
Intermec representative for help.
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Problems While Configuring the Computer 

Problem Solution

You scan a configuration command, such as Beeper 
Volume, and you hear three low beeps.

If you are working in the Intermec Settings applet, you 
cannot scan configuration commands. Exit the applet to 
scan configuration commands.

You scan or enter an option for the Scanner Model 
configuration command and you hear three low beeps.

You may have scanned or entered a Scanner Model 
command that does not apply to the type of scanner that 
you have installed. Try scanning or entering the Scanner 
Model command again and select an option for the type of 
device you are using.

You cannot type a character on the keypad or you can only 
type uppercase or lowercase letters.

You may have locked a modifier key on the keypad. Check 
the CK60 toolbar to see if it contains an icon with a locked 
symbol. Press the necessary key sequence to unlock the key. 
See “Using the Keypad” on page 10.

Problems While Configuring 802.1x Security
If you have trouble configuring the computer for 802.1x security, check 
these problems and possible solutions.

Problem Solution

The CK60 indicates that it is authenticated, but it does not 
communicate with the host.

Ensure CK60 IP address, host IP address, subnet mask, 
default router are configured for network. Do not perform a 
cold-boot as this resets the time and date. Update time and 
date for Certificate of Authority.

The CK60 does not appear to be authenticating and a 
network connection icon does not appear on the toolbar.

CK60 may not be communicating with access point. 
Ensure CK60 network name matches access point network 
name (SSID). Default name is “INTERMEC.”
802.1x security network may not be active. Ensure the 
server software is properly loaded and configured on server 
PC. For help, see server software documentation.

A network connection icon appears in the toolbar, but then 
disappears.

The CK60 may not be communicating with the intended 
access point. Ensure the CK60 network name matches the 
access point network name. Default network name is 
“INTERMEC.”
Access point may not be communicating with server. 
Ensure the access point is turned on, properly configured, 
and has 802.1x security enabled.

The CK60 indicates that it is not authenticated. • Users Name and Password parameters on CK60 match 
the user name and password on authentication server. 
You may need to reenter the password on both the 
CK60 and the authentication server.

• On your authentication server, the user and group are 
allowed and the group policy is allowed to log into the 
server. For help, see the documentation that shipped 
with your authentication server software.

• IP address and secret key for access point must match 
the IP address and secret key on authentication server. 
You may need to reenter the IP address and secret key on 
both your access point and authentication server.

• Authentication server software is running on server PC
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Problems Transmitting Data through the Serial Port
If you are having problems sending or receiving data through the integrated 
serial port on the CK60, check these possible problems:

• Make sure the CK60 is connected to the PC, host computer, or RS-232 
serial device using the appropriate cable adapter and null modem cable.

• If the CK60 is in a communications dock, make sure the 
communications dock is connected to the serial device using the 
appropriate cable.

You are setting up multiple access points in a network, with 
different SSIDs, and the connection fails.

The CK60 does not save WEP key values when changing 
the SSID. Reenter the WEP key value after changing the 
SSID, select Apply Network Settings from the 802.11 
Radio menu. You should now be able to connect to the 
different access points.

You receive a message saying “The server certificate has 
expired or your system date is incorrect” after you perform a 
cold-boot on the CK60.

Date and time are not saved when a cold-boot is performed. 
Reenter the date and time, then select Apply Network 
Settings from the 802.11 Radio menu.

Problems with Wireless Connectivity 

Problem Solution

When you turn on the CK60 after it was suspended for a 
while (10-15 minutes or longer), it can no longer send or 
receive messages over the network.

Host may have deactivated or lost current terminal 
emulation session. In a TCP/IP direct connect network, 
turn off the “KeepAlive” message from host to maintain the 
TCP session while a CK60 is suspended.

The No Network Connection icon appears on the toolbar. 
The CK60 is not communicating with the access point.

The CK60 is not connected to access point. Ensure access 
point is turned on and operating. Move closer to access 
point to reestablish communications. Ensure CK60 is 
configured correctly for network. CK60 radio parameters 
must match all access point values (page 83). 
If you have an 802.11b radio and its radio initialization 
process failed, reset the CK60 (see page 4).
If No Network Connection icon still appears, you may 
have a defective radio card. For help, contact your local 
Intermec representative.

The CK60 is connected to the Intermec Application Server 
or host computer and you move to a new site to collect 
data. The Network Connection icon was visible, but now 
replaced with the No Network Connection icon.

Move closer to an access point or to a different location to 
reestablish communications until the Network Connection 
icon appears. Any data you collected while out of range is 
transmitted over the network.

The Network Connection icon is in the toolbar, but you 
cannot establish a terminal emulation session with the host 
computer.

There may be a problem with the host computer, with the 
connection between the Intermec Application Server and 
the host computer, or with the connection between the 
access point and the host computer. Check with network 
administrator to make sure the host is running and allowing 
users to login to the system.

The Network Connection icon is in the toolbar, but the 
host computer is not receiving any data from the CK60.

In a UDP Plus network, there may be a problem with the 
connection between the Intermec Application Server and 
the host computer. Check with network administrator or 
see the user’s manual for the Intermec Application Server.
In a TCP/IP network, there may be a problem with the 
connection between the access point and the host 
computer. Check with network administrator or use your 
access point user’s manual.

Problem Solution
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For more information on using the serial port, see “Configuring Serial 
Communications” on page 83.

Problems While Scanning Bar Codes 

Problem Solution

You cannot see a red beam of light from the scanner when 
you press the Scan button and aim the scanner at a bar code 
label.

Move within two feet of a wall to test the effective scan of 
the scanner. For help scanning bar codes, see page 4.

When you release the Scan button or handle trigger, the 
Good Read light does not turn off.

The Good Read light will remain on if you configure the 
CK60 to use continuous/edge triggering. If you configure 
the CK60 for level triggering and the Good Read light 
remains on, there may be a problem. Press the Scan button 
or pull the trigger again without scanning a bar code label. 
If the light is still on, contact your local Intermec 
representative.

The input device attached to the CK60 does not work well 
or read bar code labels very quickly.

Set the Scanner Model command to the specific attached 
input device. Check enabled bar code symbologies and 
enable only the symbologies being used.

The scanner will not read the bar code label. Aim the scanner beam to cross entire bar code label in one 
pass. Vary the scanning angle.
Check the quality of the bar code label, Scan a bar code 
label that you know will scan. Compare the two bar code 
labels to see if the bar code quality is too low. You may need 
to replace the label that you cannot scan.
Ensure the bar code symbology is enabled. Use the 
Intermec Settings applet to check the symbologies. Expand 
Data Collection > Symbologies beneath devices listed 
(scanner, virtual wedge) to check and enable symbologies, 
then scan the bar code label again.
Ensure the CK60 application is expecting input from a bar 
code. You may need to type this information instead.

The scanner does not read the bar code labels quickly, or 
the scanning beam seems to be faint or obscured.

The scanner window may be dirty. Clean the window with 
a solution of ammonia and water. Wipe dry. Do not allow 
abrasive material to touch the window.

You scan a valid bar code label to enter data for your 
application. The data decoded by the scan module does not 
match the data encoded in the bar code label.

The CK60 may have decoded the bar code label in a 
symbology other than the label’s actual symbology. Try 
scanning the bar code label again. Make sure you scan the 
entire label.

You receive a message reading “Scanner Communication 
Failure” when trying to connect a 1551E or 1553 decoded 
scanner.

Make sure that you:

The 1551E/1553 scanner was working, but after changing 
the port setting you cannot change the configuration.

1551E or 1553 scanner port must use the correct RS-232 
settings to allow configuration in the Intermec Settings 
applet. Disable, then enable the scanner port state.

Configuration settings in the Intermec Settings applet do 
not match the settings on your 1551E or 1553 Scanner.

Disable, then enable the scanner port state to synchronize 
the CK60 settings with the scanner.

• You may be too far away from the bar code label. Try 
moving closer to the bar code label and scan it again.

• You may be scanning the bar code label “straight on.” 
Change the scanning angle and try again.

• are using the correct cable.
• the scanner cable is attached correctly. When attaching 

to the port, a single power up beep should emit.
• enable the port state using the Intermec Settings applet.
• try upgrading the scanner firmware.
• select ASCII as the scanner model.
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Cleaning the Scanner Window and CK60 Screen
To keep the CK60 in good working order, you may need to clean both the 
scanner window and the CK60 screen.

Clean the scanner window and CK60 screen as often as needed for the 
environment in which you are using the CK60. To clean the CK60, use a 
solution of ammonia and water.
There are no user-serviceable parts inside the CK60. Opening the unit 
will void the warranty and may cause damage to the internal compo-
nents.

To clean the CK60

1 Press the power button to turn off the CK60. 

2 Dip a clean towel or rag in the ammonia solution and wring out the 
excess.

3 Wipe off the scanner window and screen. Do not allow any abrasive 
material to touch these surfaces.

4 Wipe dry.
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The CK60 Mobile Computer automatically installs the appropriate 
software for radio use when the computer is turned on. It provides wireless 
connectivity via the Wireless Local Area Network (WLAN) using a radio 
option that provides up to 54 Mbps.
Note: Desktop and applet icons are shown to the left. Any place that Start 
is mentioned, tap the following Windows icon in the bottom, left corner of 
your CK60 desktop. 
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Personal Area Networks
"Bluetooth" is the name given to a technology standard using short-range 
radio links, intended to replace cables connecting portable and fixed 
electronic devices. The standard defines a uniform structure for a range of 
devices to communicate with each other with minimal user effort. Its key 
features are robustness, low complexity, low power, and low cost. The 
technology offers wireless access to LANs, the mobile phone network, and 
the internet for a host of home appliances and mobile computer interfaces.

Wireless Printing can also be done with Microsoft APIs, including 
Bluetooth extensions for Winsock, and Bluetooth virtual COM ports. 
Information about other Bluetooth software is in the Bluetooth Resource 
Kit and the Bluetooth Resource Kit User's Guide via the Intermec Developer 
Library (IDL), which is available as a download from the Intermec web via 
www.intermec.com/idl. See your Intermec representative for information.

Using the Intermec Settings Applet
The Intermec Settings applet displays the device name, the device address, 
enables or disables Bluetooth communications, and sets discoverable and 
connectable settings. This also provides a versions screen for various 
Bluetooth items in the system.

To enable Bluetooth communications before configuring radio communications

1 See “Enabling Bluetooth” on page 53 to enable Bluetooth.

2 Tap (+) to expand the Discoverable and Connectable options.

3 Tap File > Save Settings, then File > Exit to close the applet.

Using the Wireless Printing Applet
The Wireless Printing applet separates the task of wireless printing from 
other Bluetooth management items not relevant to this task.

Wireless Printing has a concept of the “current wireless printer.” This 
printer is the one to which the CK60 makes a connection when the wireless 
printing COM port is opened. If there is no current wireless printer, there 
is no wireless printing COM port. Registration and deregistration of this 
COM port is controlled by the Bluetooth COM port control. Use the 
Wireless Printing applet to handle the COM port registration. Customer 
software or other test applications can also use this applet to manage the 
COM port registration and deregistration.

The current wireless printer is stored in the registry and is registered and 
deregistered on Bluetooth stack load/unload. If the current wireless printer 
changes, the existing wireless printing COM port is deregistered, and the 
new one is registered instead. The registered COM port is stored in the 
registry as the “WPort.”
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For information on using Bluetooth communications, see the Bluetooth 
Resource Kit in the IDL, which is available as a download from the 
Intermec web site at www.intermec.com/idl. Contact your Intermec 
representative for more information.

To use the Wireless Printing applet

• Use a Bluetooth device search to locate the remote device (page 75)

• Manually enter the remote Bluetooth Device Address (page 76)

• Use the Bluetooth Device Manager to set a different printer (page 76)

In all situations, after a printer selection was made and you return to the 
Current Wireless Printer screen, tap Test Print to have the selected 
printer print a short message to verify that it was selected as the current 
printer.

Searching for Bluetooth Devices
You can set your wireless printer via a Bluetooth Device Search, which 
takes about half a minute to locate all Bluetooth devices in your range. 

To do a Bluetooth device search

1 Tap Search to find devices. Momentarily, Bluetooth devices found 
within range appear. 

2 If your preferred printer is in the list, select to highlight the printer, then 
tap OK. 

3 If you do not see your preferred device, make sure this device is powered 
on and set to discovery, then tap Search again. 

1 Select Start > Settings > Control Panel. 

2 Double-tap the Wireless Printing icon.

3 Use any of the following methods to select the wireless printer:
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4 Click Cancel to return to the first screen without making changes. 

Entering the Remote Bluetooth Device Address
Use this method if you know the Bluetooth Device Address of the printer 
you want to use.

To avoid a device search and perform a manual setup

1 Tap Manual. 

2 Type the address of your device in the field.

3 Click OK. 

4 Tap Cancel to return to the first screen without making changes. 

When you set your printer manually, your device does not receive the 
printer name. Therefore, “-unknown-” is displayed under Device Name 
unless you enter the correct value in to the registry in some other way.

Setting a Different Printer
Use this feature to move from the selected printer to another printer that 
was previously found.
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To set a different printer

1 Tap Set Different Printer to go to the list of previously found printers. 

2 Select to highlight the printer of choice.

3 Tap OK. 

4 Tap Cancel to return to the first screen without making changes. 

Connecting to the Network Via Bluetooth DUN
Note: While these instructions apply to many Bluetooth devices, these 
instructions use the Nokia 3650 for example purposes.

Before you connect to the network, make sure Bluetooth is enabled on your 
CK60 so you can find and connect to remote devices. Bluetooth is required 
for the SF51 Cordless Scanner. See “Enabling Bluetooth” on page 53 to 
enable Bluetooth.

Also make sure Bluetooth is enabled on your mobile phone. For example, 
with the Nokia 3650, go to its menu, select Connectivity > Bluetooth, 
then set My phone’s visibility to “Shown to all.”

First, establish a Bluetooth connection between the CK60 and your mobile 
phone, then establish a dial-up networking session with your wireless 
network.
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Once connected, you should be able to browse Internet websites and use 
other online resources from your CK60.

To establish a Bluetooth connection between your CK60 and your mobile phone

1 Tap Start > Settings > Network and Dial-up Connections, then 
double-tap Make New Connection. 

2 Enter a name for the connection, such as “Nokia,” tap Dial-Up 
Connection, then tap Next to continue. 

3 Select “Bluetooth” from the Select a modem drop-down list, then tap 
Bluetooth to access the Add Bluetooth Modem dialog.

4 Tap Search Device to find and link to a Bluetooth modem or to a 
Bluetooth-enabled mobile phone. 
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5 When prompted, enter the passkey, PIN, or applicable value in the 
Authentication Request dialog. See the user manual of your Bluetooth 
device for its default value. 

6 Select your device from the list of found devices, then tap Bond. 

7 On successful bonding, notification appears at the bottom of the dialog, 
such as “0060573ee7ba channel 1 is running on BSP1:” 

8 Tap Exit to complete the search and bonding of your device, tap Next, 
enter the phone number for your connection, then tap Finish. 
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To establish a dial-up networking session with your wireless network

Connecting to Bluetooth Audio Devices
The Bluetooth audio user interface is a part of the Bluetooth Audio applet. 
You can use this applet to find, activate, and connect to Bluetooth audio 
devices, such as Bluetooth headsets. You can control the audio volume and 
microphone amplification for the connected Bluetooth audio device (if the 
connected device has these capabilities).

To access the Bluetooth Audio applet

Searching for Bluetooth Headsets
To find a Bluetooth headset with either a “headset” or a “hands-free” 
profile, tap Search for devices. Audio devices that are found are added to 
the list with an icon to identify either profile.

When a device is found, you are prompted to enter a passcode, such as 
“0000,” then tap Authenticate to finish pairing with your audio device. 

1 Double-tap your connection icon.

2 Enter your dial-up networking account information in the User Name 
and Password fields.

3 Tap Connect to establish a connection. 

1 From the CK60 desktop, select Start > Settings > Control Panel.

2 Double-tap the Bluetooth Audio icon. 
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The passcode is provided by the manufacturer of your Bluetooth audio 
device. You can usually find your passcode in the user manual that is 
provided with your audio device.

Once the pairing is successfully completed, the Bluetooth audio device 
appears in the list of found devices. You can double-tap any of the devices 
for a pop-up menu to set it as a default, make a connection, refresh the 
connection, or delete the device from the list.
Note: You can only select one Bluetooth audio device as the default device. 
You must set a device to default before you can connect to that device.

 

Each device has two icons to the left, one to reflect its connection status, 
the other to reflect its default status. This table lists their meanings:
Bluetooth Audio Device Status Icons

Icon Description

Your CK60 and your Bluetooth audio device are not connected. Note the red diag-
onal bar.
Your CK60 and your Bluetooth audio device are connected.

Your Bluetooth audio device is not set as the default.

Your Bluetooth audio device is set as the default. Note the red check mark.
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Connecting to a Bluetooth Headset
If several Bluetooth audio devices are found, you can only connect to one. 
Before connecting to that audio device, you must set it as the default.

To connect to an audio device

1 Double-tap a device for its pop-up menu.

2 Select to check Set as default if it is not already checked.

On successful device activation, the device icon changes to include a red 
check mark. You can set another device as the default without having to 
clear the red check mark on the original.

Select Refresh to retrieve missing information from a device. Select 
Delete to remove a device from the list. 

3 If the activated device has a “hands-free” profile, press a button on the 
device to establish an audio connection between the CK60 and the 
activated device. See the user manual for the Bluetooth device for 
information on what button to press.

4 To establish an audio connection to the activated device with either a 
“headset” or “hands-free” profile, double-tap the audio device, then 
select Connect from the pop-up menu. 

A check mark is added to this option in the pop-up menu. To disconnect 
from the audio device, repeat this step to clear the check mark. 

5 When connection is established, the “connected/disconnected” status 
changes to that of a “connected” status and the Audio Device Settings 
are enabled to adjust settings of the connected Bluetooth audio device.

Tap the Microphone slider bar 
to adjust the amplification

Tap the Volume slider bar 
to adjust the volume 
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Local Area Networks
Note: The 802.11a radio is an extra cost option not supported on all 
CK60s. Contact your Intermec representative for more information.

The CK60 is a versatile handheld computer that you can add to your wired 
or wireless data collection network. You can connect your CK60 to your 
network using any of these communications: serial, 802.11a/b/g radio, 
Ethernet, or Bluetootht radio.

Configuring Serial Communications
The CK60 has a serial port to transfer data to and receive data from another 
device via RS-232 communications. You can also insert the CK60 into a 
communications dock to transmit data to and receive data from a host 
computer or PC using RS-232 communications. The serial cable and the 
communications dock are sold separately. For more information on 
accessories, see page 19.

To use serial communications with your CK60, connect the CK60 to the 
serial port of another device by:

• connecting the CK60 Serial Port to the serial port of the other device 
using the 26-pin to DB9-pin serial cable adapter and a female-to-female 
null modem RS-232 cable;

• connecting the dock to the serial port of the other device using a DB9-
pin to DB9-pin serial adapter cable, then insert the CK60 into the dock; 
or

• connecting a USB cable between the USB connector in the back of the 
dock and your desktop computer.

Configuring 802.11a/b/g Radio Communications
Make sure all components with antennas are at least 30 cm (1 ft) apart 
when power is applied. Failure to comply could result in equipment 
damage.

The wireless CK60 has an internal 802.11a/b/g radio to transfer data using 
wireless communications. This manual assumes you have already set up 
your wireless communications network including your access points. If you 
are using a UDP Plus network, you also need to have your Intermec 
Application Server communicating with a host computer.

The CK60 supports TCP/IP and UDP Plus network protocols

Configuring the Network Parameters for a TCP/IP Network
In a TCP/IP network, the CK60 communicates with a host computer 
directly using TCP/IP. The access point acts as a bridge to allow 
communications between the wired network and the wireless network.
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To configure the network parameters for a TCP/IP network

1 Configure the network name (SSID), host IP address, IP settings (if not 
using DHCP), and network port parameters on each CK60.

2 Configure security. For help, see “Configuring Security” on page 93.

Configuring the Network Parameters for a UDP Plus Network
In a UDP Plus network, the CK60 communications with a host computer 
through the Intermec Application Server.

The Intermec Application Server translates UDP Plus packets on the 
wireless network into TCP/IP packets on the wired network and vice versa. 
The access point acts as a bridge to allow communications between the 
wired network and the wireless network.

To configure the network parameters for a UDP Plus network

1 Configure the network name (SSID), controller IP address, IP settings 
(if not using DHCP), and network port parameters on each CK60.

2 Configure security. For help, see “Configuring Security” on page 93.

The easiest way to configure the network parameters on the CK60 is to use 
the Intermec Settings applet. For help, see “Using the Intermec Settings 
Applet” on page 10.

Controlling the 802.11 Radio Usage

To determine which band your CK60 is supporting

1 Tap Start > Settings > Control Panel, then double-tap the BandEnable 
icon. 

2 To change the band to enable, select the desired band.

3 Tap ok. 

4 Perform a warm-boot for the new setting to take effect.

Your CK60 may be capable of using both bands or just the B/G band. The 
BandEnable applet can enable or mask usage of any band the CK60 is 
capable of using. The band setting defaults to enable all available bands. At 
least one band must be enabled.

The CK60 is able to support 802.11 radio usage of either the A-band 
(5GHz) or the B/G-band (2.4GHz). 
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To read the current enabled operating bands
• Call DeviceIoControl using 

IOCTL_NDISUIO_QUERY_OID_VALUE with the 
OID_GET_BAND parameter. This returns the enabled bands masked 
by what the CK60 supports.

Note: If “Registry Restore” is enabled, you must flush the registry before 
cold-booting or the change will be lost.

Configuring Ethernet Communications
You can use the CK60 directly in an Ethernet network if you have ordered 
the Ethernet option on your CK60 and you insert it into a dock. The 
communications dock as an Ethernet connector makes it possible for the 
CK60 to communicate with your Ethernet network.

To use the CK60 in an Ethernet network

1 Configure the Network Name (SSID), Host IP Address, IP Settings (if 
not using DHCP), and Network Port parameters on each CK60. 

2 If required for your network, set the Primary and Secondary DNS Server 
and Primary and Secondary WINS Server parameters on each CK60.

AutoIP/DHCP
Automatic Private IP Addressing (AutoIP) is enabled by default in 
Windows CE. To remain compatible with other versions of Windows CE, 
enable this setting. You can configure the registry settings in the following 
to set the required AutoIP/DHCP behavior: 

HKEY_LOCAL_MACHINE\Comm\PRISMNDS1\TcpIp

Other registry keys that modify the behavior of AutoIP are as follows. You 
can find the appropriate settings and behavior of each of the AutoInterval, 
AutoIP, AutoMask, AutoSeed, and AutoSubnet keys in Microsoft Help.

When a TCP/IP client cannot find a DHCP server, it generates an AutoIP 
address from the 169.254.xxx.xxx block. The client then tries to check for a 
DHCP server every 15 seconds and if a DHCP server is found, the client 
drops the AutoIP address and uses the address from the DHCP server.

To disable AutoIP, set the AutoCfg registry entry to “0.” If a DHCP server 
cannot be found, instead of using AutoIP, the system will display the 
“Unable to obtain a server assigned IP address” message.
Note: If you try to disable AutoIP using a CAB file to set the registry value 
for AutoIP, set the EnableDHCP value to “1” to keep DHCP enabled.

Note: Use DhcpRetryDialogue and DhcpMaxRetry registry settings to 
extend attempts that a DHCP client makes to get a DHCP address.
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Note: Change the AutoInterval registry key value to make the client retry 
more often to obtain a DHCP address.

Wide Area Networks
The CK60 does not support wide area networks.

Remote Access (Modems)
You can set up connections to the Internet and corporate network at work 
to do such activities as browsing the Internet, sending and receiving e-mail, 
and synchronizing information using Microsoft ActiveSync.

Connections can be made using a wired or wireless network. Once 
connected, you can view web pages by using Internet Explorer. The 
communication software for creating an ISP connection is already installed 
on your CK60. Your service provider may provide the software needed to 
install other services, such as paging and fax services.

Connecting to an Internet Service Provider
To use your ISP connection to view web pages, get the ISP dial-up access 
telephone number, user name, and password from your ISP.
To view additional information for any screen in the wizard or while 
changing settings, tap Help in the upper-right corner.

1 Tap Start > Settings > Network and Dial-up Connections, then double-
tap Make New Connection. 
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2 Enter a name for the connection, such as “My Connection,” tap Next. 

3 In Select a modem, select “Hayes Compatible on COM1,” tap Next. 

4 Enter the phone number, then tap Finish. 

5 Double-tap the new My Connection icon, then enter the user name, 
password, and domain (if provided by an ISP or your network 
administrator).
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6 Tap Dial Properties, then specify your current location from the drop-
down list. Specify your current phone type. If your phone type is pulse 
dialing, select Pulse dialing. If your type is tone dialing (as most phone 
lines are), then select Tone dialing. Tap OK to close the Dialing 
Properties page. These settings apply to all connections. 

7 To start the connection, start visiting web sites by using Internet 
Explorer. See “Internet Explorer” on page 32 for information.

Direct Connection
A direct connection securely connects to servers via the Internet. Ask your 
network administrator for the user name, password, domain name, TCP/IP 
settings, and host name or IP address of the server.
To view additional information for any screen in the wizard or while 
changing settings, tap Help in the upper-right corner.

1 Tap Start > Settings > Network and Dial-up Connections, then double-
tap Make New Connection. 
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2 Enter a name for the connection, such as “Direct Connection.” Select 
Direct Connection, then tap Next to continue. 

3 Select a device through which a connection is made from the Select a 
device drop-down list, tap Configure to adjust the port settings, tap OK 
to return to the Device screen, then tap Finish. 

To disconnect, either detach your device when connected via cable or 
cradle, or switch off the connection when connected via a wireless network.

iConnect
The default network adapter or radio is dependent on what radios are 
installed in your CK60. With the iConnect menu, using the Enable 
feature, you can specify “802.11b,” “Ethernet,” or “No Networking” to 
load onto your CK60 when a cold-boot is performed. 

If you had specified a network prior to when a warm-boot is performed on 
the CK60, the iConnect application restores your network interfaces to 
what they were before the warm-boot was performed.

See the Developer’s Support area of the Intermec web site for the latest 
information on network adapters for your unit.

4 Insert the necessary equipment into the device, then double-tap the new 
Direct Connection icon to connect to the host, then use a program to 
automatically begin connecting.
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To access the iConnect menu

1 Tap the iConnect icon in your toolbar for the following menu: 

2 Select Dismiss from the iConnect menu to end the session without 
exiting the application. 

3 Select Exit iConnect to exit the application. 

Ethernet Communications
If your system does not contain an 802.11a/b/g radio, then Ethernet 
networking using DHCP is selected as the default.
When you select Enable > Ethernet from the iConnect menu, the Ethernet 
icon (shown to the left) appears in the toolbar as circled in the illustration. 

Note: To access the iConnect application after you have exited it, select 
Start > Run, enter “iconnect.exe” in the Open field, then tap OK. The 
iConnect icon then reappears in the toolbar. 

iConnect icon
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To view information about the Ethernet communications
• Select Tools > Ethernet IP Settings from the iConnect menu for the 

following: 

To view the status of the Ethernet communications
• Select Status > Ethernet from the iConnect menu for the following. Tap 

Try Again to check the status after you make changes to the connection. 

No Networking
When you select Enable > No Networking from the iConnect menu, 
neither icon appears in the toolbar.

Wireless Communications
When you select Enable > Wireless from the iConnect menu, the Wireless 
icon (shown to the left) appears in the toolbar. 
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To configure wireless 802.11b communications on the CK60
• Select Tools > Wireless Settings from the iConnect menu to access the 

Profile Wizard for the 802.11a/b/g radio module.
Note: You can configure wireless 802.11b communications using the 
Wireless Network applet. Tap Start > Settings > Control Panel, then 
double-tap the Wireless Network icon to access the Profile Wizard. Go to 
“Configuring Microsoft Security” on page 100 for information.

To view information about the Wireless 802.11b communications, 
• Select Tools > Wireless IP Settings from the iConnect menu for the 

following: 

To view the status of the Wireless communications 

• Select Status > Wireless from the iConnect menu to view the status. Tap 
Try Again to check the status after you make changes to the connection. 

Pinging Your Gateway or DHCP Server
Use the Ping Test feature to test your CK60 connection against your 
network.

To ping your gateway or DHCP Server

1 Select Tools > Ping Test from the iConnect menu.

2 To ping your gateway or DHCP server, select Ping my gateway or 
DHCP server, then select which to ping from the top drop-down list. 

3 To ping a specific host, select Ping the host address below, then enter its 
IP address in the field beneath. 
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4 After you make your selection, tap Ping! and wait for results. 

Configuring Security
Use the next sections to understand how to configure each type of security 
on your wireless CK60.

Loading Certificates
If you choose to use Transport Layer Security (TLS) with WPA or 802.1x 
security, you need to have a unique client certificate on the CK60 and a 
trusted root certificate authority (CA) certificate. If you choose to use 
PEAP, you need to load a root CA certificate. You can use a third-party CA 
to issue unique client certificates and a root certificate.

To load certificates

4 To remove a certificate, press and hold a certificate, then select Delete. 

Wireless Networks
Your wireless adapter (network interface card) connects to wireless 
networks of two types: infrastructure networks and ad-hoc networks.

• Infrastructure networks get you onto your corporate network and the 
Internet. With the 802.11b/g infrastructure mode, the CK60 establishes 
a wireless connection to an AP, linking you to the rest of the network.

1 If your CA is on your WLAN, select Start > Settings > Control Panel.

2 Double-tap the Certificates icon.

3 Tap View to see certificate details.
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• Ad-hoc networks are private networks shared between two or more 
clients, even with no access point.

Each wireless network is assigned a name (or Service Set Identifier - SSID) 
to allow multiple networks to exist in the same area without infringement.

Intermec recommends using security measures with wireless networks to 
prevent unauthorized access to your network and to ensure your privacy of 
transmitted data. Authentication (cryptographically protected) by both the 
network and the user, transmitted data, and encryption are required 
elements for secure networks. Schemes are available to implement the 
features.

Encryption 

AES  
(Advanced 
Encryption 
Standard)

A block cipher, a type of symmetric key cipher that uses groups of bits of a fixed length - called blocks. 
A symmetric key cipher is a cipher using the same key for both encryption and decryption.
As implemented for wireless, this is also known as CCMP, which implements AES as TKIP and WEP 
are implementations of RC4.

CKIP (Cisco 
Key Integrity 
Protocol)

This is Cisco's version of the TKIP protocol, compatible with Cisco Aironet products.

TKIP (Temporal 
Key Integrity 
Protocol)

This protocol is part of the IEEE 802.11i encryption standard for wireless LANs, which provides per-
packet key mixing, a message integrity check and a re-keying mechanism, thus overcoming most of 
the weak points of WEP. This encryption is more difficult to crack than the standard WEP. Weak 
points of WEP include: No Initiation Vector (IV) reuse protection, weak keys, no protection against 
message replay, no detection of message tampering, and no key updates.

WEP (Wired 
Equivalent 
Privacy) 
encryption

With preconfigured WEP, both the client CK60 and access point are assigned the same key, which 
can encrypt all data between the two devices. WEP keys also authenticate the CK60 to the access 
point - unless the CK60 can prove it knows the WEP key, it is not allowed onto the network. WEP 
keys are only needed if they are expected by your clients. There are two types available: 64-bit (5-
character strings, 12345) (default) and 128-bit (13-character strings, 1234567890123). Enter these as 
either ASCII (12345) or Hex (0x3132333435).

Key Management Protocols

WPA (Wi-Fi 
Protected Access)

This is an enhanced version of WEP that does not rely on a static, shared key. It encompasses a 
number of security enhancements over WEP, including improved data encryption via TKIP and 
802.11b/g authentication with EAP. WiFi Alliance security standard is designed to work with existing 
802.11 products and to offer forward compatibility with 802.11i.

WPA2 (Wi-Fi 
Protected Access)

Second generation of WPA security. Like WPA, WPA2 provides enterprise and home Wi-Fi users 
with a high level of assurance that their data remains protected and that only authorized users can 
access their wireless networks. WPA2 is based on the final IEEE 802.11i amendment to the 802.11 
standard ratified in June 2004. WPA2 uses the Advanced Encryption Standard (AES) for data 
encryption and is eligible for FIPS (Federal Information Processing Standards) 140-2 compliance. 

Authentication 

EAP (Extensible 
Authentication 
Protocol)

802.11b/g uses this protocol to perform authentication. This is not necessarily an authentication 
mechanism, but is a common framework for transporting actual authentication protocols. Intermec 
provides a number of EAP protocols for you to choose the best for your network.

EAP-FAST 
(Flexible 
Authentication 
via Secure 
Tunneling)

A publicly accessible IEEE 802.1X EAP type developed by Cisco Systems. It is available as an IETF 
informational draft. An 802.1X EAP type that does not require digital certificates, supports a variety 
of user and password database types, supports password expiration and change, and is flexible, easy to 
deploy, and easy to manage.
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The CK60 provides three types of security for your wireless network: Wi-Fi 
Protected Access 2 (WPA2/802.11i), WPA, and WEP. 802.1x should be 
referred to as an authentication method used for WPA and WPA2. Another 
authentication method for WPA and WPA2 would be the Pre-Shared Key 
(PSK).

Choosing Between Microsoft and Funk Security
Before you can implement a security solution on the CK60, you need to 
choose between Microsoft and Funk security:

• By default, Funk security is enabled. It provides everything you get with 
Microsoft security plus the addition of Cisco Compatible Extensions 
features. It also provides additional authentication types like EAP-TTLS, 
LEAP, and EAP-FAST.

• Microsoft security, with its Microsoft Zero Config feature, is also 
available. To switch to Microsoft security, go to “Configuring 
Microsoft Security” on page 100 to start.

Note: Your security choice does not depend on your authentication server. 
For example, you can choose Funk security if you use Microsoft Active 
Directory® to issue certificates.

Configuring Funk Security
You can define up to four profiles for your Funk Odyssey security. 
Different profiles let your CK60 communicate in different networks 
without having to change all of your security settings. For example, you can 
set up one profile for the manufacturing floor and one for the warehouse.

LEAP 
(Lightweight 
Extensible 
Authentication 
Protocol)

Also known as Cisco-Wireless EAP, provides username/password based authentication between a 
wireless client and a RADIUS server. In the 802.1x framework, traffic cannot pass through a wireless 
network access point until it successfully authenticates itself.

EAP-PEAP 
(Protected 
Extensible 
Authentication 
Protocol)

Performs secure authentication against Windows domains and directory services. It is comparable to 
EAP-TTLS both in its method of operation and its security, though not as flexible. This does not 
support the range of inside-the-tunnel authentication methods supported by EAP-TTLS. Microsoft 
and Cisco both support this protocol.

EAP-TLS 
(Transport Layer 
Security)

Based on the TLS (Transport Layer Security) protocol widely used to secure web sites. This requires 
both the user and authentication server have certificates for mutual authentication. While cryptically 
strong, this requires corporations that deploy this to maintain a certificate infrastructure for all their 
users.

EAP-TTLS 
(Tunneled 
Transport Layer 
Security)

This protocol provides authentication like EAP-TLS (see page 95) but does not require certificates for 
every user. Instead, authentication servers are issued certificates. User authentication is done using a 
password or other credentials that are transported in a securely encrypted “tunnel” established using 
server certificates.
EAP-TTLS works by creating a secure, encrypted tunnel through which you present your credentials 
to the authentication server. Thus, inside EAP-TTLS there is another inner authentication protocol that 
you must configure via Additional TTLS Settings.

Authentication (continued)
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To configure Funk Security

3 Select an active profile, then configure its security settings. 

Using WPA Security
Wi-Fi Protected Access (WPA) is a strongly enhanced, interoperable Wi-Fi 
security that addresses many of the vulnerabilities of Wired Equivalent 
Privacy (WEP). Instead of WEP, WPA uses Temporal Key Integrity 
Protocol (TKIP) for its data encryption method. Currently, WPA satisfies 
IEEE 802.11i standards.

WPA runs in Enterprise (802.1x) mode or PSK mode:

• In Enterprise mode, WPA provides user authentication using 802.1x and 
the Extensible Authentication Protocol (EAP). That is, an authentication 
server (such as a RADIUS server) must authenticate each device before 
the device can communicate with the wireless network.

• In PSK mode, WPA provides user authentication using a shared key 
between the authenticator and the CK60. WPA-PSK is a good solution 
for small offices or home offices that do not want to use an 
authentication server.

To use WPA security, you need an access point with an 802.11b/g radio 
that supports WPA.

1 Select Start > Settings > Control Panel, then double-tap the Intermec 
Settings icon.

2 Tap (+) to expand Communications > 802.11 Radio > Funk Security.
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Configuring WPA Security With Funk Security 
Use this procedure to set WPA security with Funk security. 

1 Make sure you have configured the communications and radio 
parameters on your CK60 and that Funk is your security choice.

2 Open Intermec Settings. Tap (+) to expand Communications > 802.11 
Radio > Funk Security > Profile X with “X” being “1” through “4.”

3 For Association, select “WPA” and press Enter.

4 For 8021x, select “PEAP,” “TLS,” “TTLS,” “LEAP,” or “EAP-FAST” 
and press Enter.

If you select “TTLS” or “PEAP:”

a Select User Name, type your user name, then press Enter.

b Select User Password, type a user password, then press Enter.

c For Validate Server Certificate, select “Yes,” then press Enter. Note 
that you must have the date on the CK60 set correctly when you enable 
Validate Server Certificate.

d You must enter a User Name and Subject Name. You can also enter a 
Server 1 Common name or Server 2 Common name if you want to 
increase your level of security.

If you select “TLS:”

a Load a user and root certificate on your CK60. For help, see “Load-
ing Certificates” on page 93.

b For Validate Server Certificate, select “Yes,” then press Enter. Note 
that you must have the date on the CK60 set correctly when you enable 
Validate Server Certificate.

c You must enter a User Name and Subject Name. You can also enter a 
Server 1 Common name or Server 2 Common name if you want to 
increase your level of security.

If you select “LEAP” or “EAP-FAST:”

a Select User Name, type your user name, then press Enter.

b Select User Password, type a user password, then press Enter.
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Configuring WPA-PSK Security With Funk Security 
Use this procedure to set WPA-PSK security on your CK60 with Funk 
security. 

1 Make sure you have configured the communications and radio 
parameters on your CK60 and that Funk is your security choice.

2 Open Intermec Settings. Tap (+) to expand Communications > 802.11 
Radio > Funk Security > Profile X with “X” being “1” through “4.”

3 For Association, select “WPA” and press Enter.

4 For 8021x, select “None” and press Enter.

5 For Pre-Shared Key, enter the pre-shared key or the passphrase.

The pre-shared key must be a value of 32 hex pairs preceded by 0x for a 
total of 66 characters. The value must match the key value on the access 
point. The passphrase must be from 8 to 63 chtomaracters. After you 
enter a passphrase, the CK60 internally converts it to a pre-shared key. 
This value must match the passphrase on the authenticator.

Using 802.1x Authentication
802.1x authentication provides centralized user authentication using an 
authentication server, authenticators (access points), and supplicants. These 
components communicate using an EAP authentication type, such as TLS 
(Transport Layer Security) or PEAP (Protected Extensible Authentication 
Protocol). 802.1x security provides data encryption using dynamic WEP 
key management. To use 802.1x security, you need:

• An access point with an 802.11b/g radio.

• A CK60 with an 802.11b/g radio and the 802.1x/WPA security option.
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Configuring 802.1x Security With Funk Security 
This sets 802.1x security on your CK60 with Funk security. 

1 Make sure you have configured the communications and radio 
parameters on your CK60 and that Funk is your security choice.

2 Open Intermec Settings. Tap (+) to expand Communications > 802.11 
Radio > Funk Security > Profile X with “X” being “1” through “4.”

3 For Association, select “Open” and press Enter. When working with 
Cisco Aironet access points, you can select “Network-EAP.”

4 For Encryption, select “WEP” and press Enter.

5 For 8021x, select “PEAP,” “TLS,” “TTLS,” “LEAP,” or “EAP-FAST” 
and press Enter.

If you select “TTLS” or “PEAP:”

a Select User Name, type your user name, then press Enter.

b Select User Password, type a user password, then press Enter.

c For Validate Server Certificate, select “Yes,” then press Enter. Note 
that you must have the date on the CK60 set correctly when you enable 
Validate Server Certificate.

d Enter a User Name and Subject Name. You can also enter a Server 1 
Common name or Server 2 Common name to increase security.

If you select “TLS:”

a Load a user and root certificate on your CK60 (page 93).

b For Validate Server Certificate, select “Yes,” then press Enter. Note 
that you must have the date on the CK60 set correctly when you enable 
Validate Server Certificate.

c You must enter a User Name and Subject Name. You can also enter a 
Server 1 Common name or Server 2 Common name if you want to 
increase your level of security.

If you select “LEAP” or “EAP-FAST:” 
Select User Name, then type your user name. press Enter, select User 
Password, type a user password, then press Enter.
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Using Static WEP Security
The CK60 uses the Wired Equivalent Privacy (WEP) protocol to add 
security to your wireless network based on the 802.11b/g standard. To use 
WEP security, you need an access point with an 802.11b/g radio.

Configuring Static WEP Security With Funk Security 
Use this procedure to set Static WEP security with Funk security. 

1 Make sure you have configured the communications and radio 
parameters on your CK60 and that Funk is your security choice.

2 Open Intermec Settings. Tap (+) to expand Communications > 802.11 
Radio > Funk Security > Profile X with “X” being “1” through “4.”.

3 For Association, select “Open” and press Enter. 

4 For Encryption, select “WEP” and press Enter.

5 For 8021x, select “None” and press Enter.

7 For Transmit key, select which WEP key to use for encryption of 
transmitted data.

8 Define a value for each key, up to four. Enter an ASCII key or a hex key 
either 5 or 13 bytes long based on the radio capability. Set a 5-byte value 
for 64-bit WEP or a 13-byte value for 128-bit WEP. Precede hex keys 
with 0x and make sure the keys use 5 or 13 hex pairs.

Configuring Microsoft Security
The default security setting is Funk. If you want to use Microsoft security, 
you need to select it as your security choice.

To select Microsoft Security

1 Select Start > Settings > Control Panel. 

2 Double-tap the Intermec Settings icon. 

3 Tap (+) to expand Communications > 802.11 Radio > Security 
Choice.
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4 Select “Microsoft Security” from the drop-down list, then press Enter. 

5 Tap Yes or press Esc to clear the alert box.

6 Tap File > Save Settings to save your settings.

7 Perform a clean-boot on the CK60. See “Resetting Your Computer” 
on page 3 for more information.
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SmartSystems™ Foundation
Use the SmartSystems Foundation (www.intermec.com/SmartSystems) to 
configure and manage your network. You can also contact your Intermec 
representative for support.

This tool, available as a free download from Intermec, includes a 
management console that provides a default method to configure and 
manage Intermec devices “out-of-the-box,” without the purchase of 
additional software licenses. This is for anyone who must configure and 
deploy multiple devices or manage multiple licenses.

Use the Intermec Settings applet to do device configuration settings within 
the SmartSystems Foundation. Information about the Intermec Settings 
applet is in the Intermec Computer Command Reference Manual (P/N 
073529) available online at www.intermec.com.

Information about the SmartSystems Foundation is available as an online 
help within the SmartSystems Console application. Select SmartSystems > 
Help in the console to access the manual.

To view your SmartSystems information
1 Tap Start > Settings > Control Panel. 

2 Double-tap the Intermec Settings icon.

3 Tap (+) to expand the SmartSystems Information option. 
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Intermec Recovery Tools, 64
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Intermec Settings applet, 74
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configuring parameters, 47, 48
Funk security, 95
imager commands, 5
imager settings, 53
viewing SF51 scanner information, 55

Intermec settings applet
smartsystems, 10, 102
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browsing the Internet, 32
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CE, 3, 32
PSM, 3, 32
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ISP

connecting to via Windows CE, 86
Internet Explorer, 32
Windows CE, 86
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Microsoft security, 95
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Windows Media Player, 33

N
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packaging applications, 37
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Operating the CK60
troubleshooting, 68
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iConnect, 90
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WPA security
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