TOUGH Quick Start

USB Driver

Before the program is burned, users please download the corresponding CP210X driver package according to the
operating system you are using, click the button below. After decompressing the compressed package, select the
installation package corresponding to the operating system value for installation.

6 For Mac OS, make sure System preferences -> Security & Privacy -> General before installing, and allow the apps
to be installed from the App Store and identified developers

Security & Privacy

General FileVault ~ Firewall  Privacy

A login password has been set for this user | Change Password...

v Require password | immediately T after sleep or screen saver begins

Show a message when the screen is locked
v Disable automatic login

v Use your Apple Watch to unlock apps and your Mac

Allow apps downloaded from:
App Store
® App Store and identified developers

§é Click the lock to prevent further changes Advanced...

e Download CP2104 driver

.. Windows10 MacOS & Linux


http://192.168.1.3:3000/#/zh_CN/arduino/arduino_core2_development?id=tough-quick-start
http://192.168.1.3:3000/#/zh_CN/arduino/arduino_core2_development?id=usb-driver
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/drivers/CP210x_VCP_Windows.zip
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/drivers/CP210x_VCP_MacOS.zip
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/drivers/CP210x_VCP_Linux.zip

= | CP210x ¥CP_Windows

. g » computer > (E9 > dosndata > MSStack Arduine » CP210x VCP_Windows

Microsoft ¥S Code In ™

MyDrivers b 2014/4/12 5:56

nodejs B 2014/4/12 5:56

OneKeyDownloads &1 CP210XVCPInstaller_Win7 wS40.24.exe  2009/10/25 16:59 5.364 KB
PanDownload v2.03 M CP210xVCPInstaller xbd v6.7.00.exe 201474712 5:56 1,026 KB
ppT S CP21OKVCPInstaller 336 v6.7 00exe  2014/4/12 556 201 Kg
PLTTY: 2 dpinstol 2014/4/12 5:56 12K8
5] Readme.bdt 2017/11/27 2046 1K8
[5] ReleaseNotes.ox 2014/4/12 5:56 11Ke
[5] SLAB_License Agreement VCP Windo... 2014/4/12 556 9 KB
Typora 4 slabucp.cat 2014/4/12 5:56 12 KB
UlFlow_doc £ slabuepdnf 2014/4/12 556 5K8
Units

python_text

System Volume Infort

WeChat
WinRAR
WxWork

downdate
flash_download too
MSBurner
M5B urner-fer-windc
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Arduino-IDE

Click here to visit Arduino's official website,Select the installation package for your own operating system to
download.

STORE SOFTWARE EDU PRO RESOURCES COMMUNITY HELP

Download the Arduino IDE

Windows Installer, for Windows XP and up
Windows zIP file for non admin install

ARDUINO 1.8.12 Windows app Requires Win 81 or 10
The open-source Arduino Software (IDE) makes it easy to
write code and upload it to the board. It runs on
Windows, Mac OS X, and Linux. The environment is
written in Java and based on Processing and other open-
source software.

This software can be used with any Arduino board. Linux 32 bits
Refer to the Getting Started page for Installation Linux 64 bits

instructions. Linux ARM 32 bits
Linux ARM 64 bits

Mac OS X 10.8 Mountain Lion or newer

Release Notes
Source Code
Checksums (sha512)

M5Stack Boards Manager

1.0pen up Arduino IDE, navigateto File -> Peferences -> Settings


http://192.168.1.3:3000/#/zh_CN/arduino/arduino_core2_development?id=arduino-ide
https://www.arduino.cc/en/Main/Software
http://192.168.1.3:3000/#/zh_CN/arduino/arduino_core2_development?id=m5stack-boards-manager

&9 sketch maylda | Arduino 1.2.9 - O *
Eile Edit Sketch Tools Help

Mew Ctrl+M

Open... Crl+ 0

Open Recent >

Sketchbook »

Eemtles ’p code here, to run once:
Close Crl+w

Sawve Ctrl+5

Save As... Ctrl+Shift+5

Page Setup  Ctrl+Shift+P
Print Ctrl+P

code here, to run repeatedly:
Preferences Ctrl+Comma

Quit Ctrl+Q

. None an COM144

2.Copy the following M5Stack Boards Manager url to Additional Boards Manager URLs:

https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/arduino/package_mb5stack_index.json

,

sketch_aug28a | Arduino 1.8.13

sketch_aug28a

18void setupQ {
2 // put your setup code here, to run once:

3

4}

B Preferences

6Evoid loop() {

7 // put your main code here, to run repeat FYeK ) Additional Boards Manager URLs

8

9} Sketchbook |
JUsers/van https://m5stack.oss-ci aliyuncs.com/resource/arduino/package_m5stack_index.json ]
Editor langua )

Editor font sJ‘
Interface scal
Theme:

Show verbos(

Compiler war

v Display |
« Verify cg Click for a list of unofficial boards support URLs

Check f oK Cancel
v_Use acces..

dditional Boards Manager URLs: https://dl.espressif.com/dI/package_esp32_index.json,http://download.dfro ]

More preferences can be edited directly in the file
/Users /vany/Library/Arduinol5/preferences.txt
(edit only when Arduino is not running)

oK Cancel

3.Navigateto Tools -> Board: -> Boards Manager...


https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/arduino/package_m5stack_index.json

Auto Format sketch_aug28b | Arduino 1.8.13
Archive Sketch
Fix Encoding & Reload

sketch_aug28b Manage Libraries...

16joid setup() { Serial Monitor

2 // put your setup code her SRR

3

4 3 WiFi101 / WiFiNINA Firmware Updater
5

6Evoid loopQ) { ESP32 Sketch Data Upload

7 // put your main code hereSNeECIEICNOEES

g 3 Board: "M5Stack-Core2" Boards Manager... N
Upload Speed: "921600"
CPU Frequency: "240MHz (WiFi/BT)"
Partition Scheme: "Default (2 x 6.5 MB app, 3.6 MB SPIFFS)"
Core Debug Level: "None"
PSRAM: "Enabled"
Port
Get Board Info

Ameba ARM (32-bits) Boards

Arduino AVR Boards

CubeCell

M5Stack Arduino

Seeed SAMD (32-bits ARM Cortex-M0+ and Cortex-M4) Boards
TinkerNode NB-loT

Programmer
Burn Bootloader

4.Search M5Stack inthe pop-up window, find it and click Install

& ® Boards Manager
Type All M5Stack
M5Stack
by M5Stack official version 1.0.4 INSTALLED
Boards included in this package:
M5Core, FIRE, Core2, M5StickC, M5Atom.
More Info | Remove |
Close

5.select Tools -> Board: -> M5Stack-Tough

6. Visit Github (https://github.com/m5stack/M5Tough), download the M5Tough library, and placeitin the



https://github.com/m5stack/M5Tough

Arduino library file path C:\Users\UserName\Documents\Arduino\libraries

Bluetooth serial port function

Open the Arduino IDE and open the example program File -> Examples -> BluetoothSerial -

> SerialToSerialBT . Connect the device to the computer and select the corresponding port to burn. After
completion, the device will automatically run Bluetooth, and the device name is ESP32test . At this time, use the
Bluetooth serial port sending tool on the PC to realize the transparent transmission of Bluetooth serial data.

€® coms - 0o X g

Send

[ets Jun § 20I¢ 00:22:57

rst:0xl (POWERON_RESET),boot:0x13 (SPI_FAST FLASH BOOT) N
configsip: 188777542, SPIWP:0xees

clk_drv:0x00,q dev:0x00,d dev:0x00, cs0_drv:0x00,hd drv:0x00,wp_drv:0x00
mode:DI0, clock diw:l

load:0x3£££0018, len:zd

load:0x3f££001c, len: 1044

load:0x40075000, len: 2596

load:0x40020400, len: 5816

entry 0x40080gac 13
The device started in master mode, make sure remote BT device is on! H
ets Jun OFESIOSEESCY

ratitt (POWEYYSEUMOOY, bft0x13 (SPI_FAST FLASH BOOT)

confZ % 188777542, SPIWP:Oxee

clk_drv:0x00) }49%50x00,d_drv:0x00,cs0_drv:0x00,hd drv:0x00,wp_drv:0x00

mode:DI0, cikitdiwv:l

load:0x3f££0018, lenzd

load:0x3f££001c, len: 1044

load: 0x40%0% bE44Y a8 596

load:0x40050400, lenz 55816

entry 0x400806a%H'The device started in master mode, make sure remote BT device is on!
[The device started, now you can pair it with bluetooth!

HELLOet.Rin ¢ &%$00%2&%%]

194: 0xLB%=] EROYSUMOQ) , bt%: 0xLeBiA%_FA*Tel0MH %%Q)

1 ip:tEYTSOi SY]P:OS

clESw: 950, gESw: 450, dESw: 050150 SP40%0 ¢ d.Tathtt d.UxtO:DI0ctk VEI1C!fd: SSEfnfeetin: AC 45 0% L%
©5 - - -

The device started, now you can pair it with bluetooth!

TIE evite scarfged, now you can pair it with bluetooth!

Hello M55tack

< >

[ dutozersll []Shoes timestamp Hewline ~ | 115200 haud ~ Clear output



http://192.168.1.3:3000/#/zh_CN/arduino/arduino_core2_development?id=bluetooth-serial-port-function

= Terminal

23:37:22.181 Connection lost
23:37:51.493 Connecting to ESP32test ...
23:37:52.561 Connected

23:38:04.355 Hello M5Stack

M1 M2 M3 M4

Hello M5Stack

#include

#if !defined(CONFIG BT ENABLED) defined(CONFIG_BLUEDROID ENABLED)

#error Bluetooth is not enabled! Please run "make menuconfig™ to and enable it
#endif

BluetoothSerial SerialBT;

void setup() {
Serial.begin(
SerialBT.begin(

Serial.println(

void loop() {
(Serial.available()) {

SerialBT.write(Serial.read());

(SerialBT.available()) {
Serial.write(SerialBT.read());

1
delay(20);

WiFi scanning function



http://192.168.1.3:3000/#/zh_CN/arduino/arduino_core2_development?id=wifi-scanning-function

Open the Arduino IDE and open the example program File -> Examples -> WiFi -> WiFiScan . Connectthe
device to the computer and select the corresponding port to burn. After completion, the device will automatically
run the WiFi scan, and the current WiFi scan result can be obtained through the serial port monitor that comes with
the Arduino.

o

File Edit Sketch Tools Help

&% comas

y{100)
scan start
Serial.println("Serup d443can dons
} 17 networks found

1l: cam {-47)*
void loop() 2: M5-2.4G (-50)%*
{ 3: WirelessNet (-55)%
Serial.println("scan stq?: M5-2.4G (-60)*
5: M5-2.4G (-62)*

: ChinaNet-yeTW (-€5)%
: TE-LINK 6666BA (-69)*
: DIRECT-9d-HP M277 Laserdet (-71)%*

// WiFi.scanMet

= WiFi. WOL

.println("scan do

[T N

F (b 0 { : 905 {-72)%
Serial.pr e 0: boluojun (-72)%*
} else I 1l: TP-LINK CS2_666 (-78)*

12: CF5Z1 (-84)*

: fuxiwenhua (-8&)¥
: KM-Webk (-87)

: EM-Guest (-88

: CFSZ1 (-80)*

: ¥M-free (-91)*

Serial.

Serial.
Serial.
Serial.
Serial.
Serial.
Serial.
Serial.

1
1

Serial.println{™"):

ait a bit b
v {5000) ;7 Autoscroll D Show timestamp Hewline ~ | (115200 baud Clear output

#include

void setup()

{
Serial.begin(

WiFi.mode(WIFI STA);
WiFi.disconnect();

delay(100);

Serial.println(

void loop()

{

Serial.println(




int n = WiFi.scanNetworks();
Serial.println( );
(n ) {
Serial.println(
{
Serial.print(n);
Serial.println(

(int i

Serial.print(i

(

505
Serial.print(WiFi.SSID(i));

(

(

Serial.print

%

Serial.print(WiFi.RSSI(i));

Serial.print(")");

Serial.printin((WiFi.encryptionType(i) WIFI_AUTH_OPEN)

Serial.print

delay(10);

}
Serial.println("");




FCC Statement:

Any Changes or modifications not expressly approved by the party responsible for
compliance could void the user’s authority to operate the equipment.

This device complies with part 15 of the FCC Rules. Operation is subject to the
following two conditions: (1) This device may not cause harmful interference, and
(2) This device must accept any interference received, including interference that
may cause undesired operation.

FCC Radiation Exposure Statement:

This equipment complies with FCC radiation exposure limits set forth for an
uncontrolled environment .This equipment should be installed and operated with
minimum distance 20cm between the radiator& your body.

Note: This equipment has been tested and found to comply with the limits for a
Class B digital device, pursuant to part 15 of the FCC Rules. These limits are
designed to provide reasonable protection against harmful interference in a
residential installation. This equipment generates uses and can radiate radio
frequency energy and, if not installed and used in accordance with the instructions,
may cause harmful interference to radio communications. However,there is no
guarantee that interference will not occur in a particular installation. If this
equipment does cause harmful interference to radio or television reception, which
can be determined by turning the equipment off and on, the user is encouraged to
try to correct the interference by one or more of the following measures:

—Reorient or relocate the receiving antenna.

—Increase the separation between the equipment and receiver.

—Connect the equipment into an outlet on a circuit different from that to which the
receiver is connected.

—Consult the dealer or an experienced radio/TV technician for help.





