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1. OUTLINE
StickC PLUS is ESP32 board which based on ESP32-PICO-V3 module, with one LED 

and one button The board is made of PC+ABC. 

1.1 Hardware Composition 
The hardware of M5StickC PLUS: ESP32-PICO-V3 module, TFT screen, IMU, IR 

transmitter, Red LED, Button, GROVE interface, TypeC-to-USB interface, Power 
Management chip and battery. 

StickT Add infrared camera. 

   The product is connected to the computer, developed and used in 
the Desktop environment, and will contact people physically.



ESP32-PICO-V3 is a System-in-Package (SiP) module that is based on ESP32, 
providing complete Wi-Fi and Bluetooth functionalities. The module integrates a 4-MB 
SPI flash. ESP32-PICO-V3 integrates all peripheral components seamlessly, including a 
crystal oscillator, flash, filter capacitors and RF matching links in one single package. 

TFT Screen is a 1.14-inch color screen driven by Sitronix's ST7789 with a resolution of 
135 x 240. Operating voltage range is 2.5~3.3V 

IMU The MPU-6886 is a 6-axis MotionTracking device that combines a 3-axis 
gyroscope and a 3-axis accelerometer in a small 3 mm x 3 mm x 0.75 mm 24-pin LGA 
package. 

M5StickC Lite equips ESP32 with everything needed for programming, everything 
needed for operation and development 



2. PIN DESCRIPTION

2.1. USB INTERFACE 
M5CAMREA Configuration Type-C type USB interface, support USB2.0 
standard communication protocol. 

2.2. GROVE INTERFACE 
4p disposed pitch of 2.0mm M5CAMREA GROVE interfaces, internal wiring and 
GND, 5V, GPIO32, GPIO33 connected. 



3. FUNCTIONAL DESCRIPTION
This chapter describes the ESP32-PICO-V3 various modules and functions. 

3.1. CPU AND MEMORY 

ESP32-PICO-V3 contains two low-power Xtensa® 32-bit LX6 MCU. On-chip memory
comprising: 

 448-KB of ROM, and the program starts for the kernel function calls 
 For a 520 KB instruction and data storage chip SRAM (including flash memory 8 

KB RTC) 
 RTC flash memory of 8 KB SRAM, when the RTC can be started in Deep-sleep 

mode, and for storing data accessed by the main CPU 
 RTC slow memory, of 8 KB SRAM, can be accessed by the coprocessor in Deep- 

sleep mode 
 Of 1 kbit of eFuse, which is a 256 bit system-specific (MAC address and a chip 

set); the remaining 768 bit reserved for user program, these Flash program 
include encryption and chip ID 

3.2. STORAGE DESCRIPTION 

3.2.1. External Flash and SRAM 

ESP32 support multiple external QSPI flash and static random access memory 
(SRAM), having a hardware-based AES encryption to protect the user programs and 
data. 

 ESP32 access external QSPI Flash and SRAM by caching. Up to 16 MB external 
Flash code space is mapped into the CPU, supports 8-bit, 16-bit and 32-bit 
access, and can execute code. 

 Up to 8 MB external Flash and SRAM mapped to the CPU data space, support 
for 8-bit, 16-bit and 32-bit access. Flash supports only read operations, SRAM 
supports read and write operations. 

ESP32-PICO-V3 4 MB of integrated SPI Flash, the code can be mapped into CPU 
space, support for 8-bit, 16-bit and 32-bit access, and can execute code. Pin GPIO6 
ESP32 of, GPIO7, GPIO8, GPIO9, GPIO10 and GPIO11 for connecting module 
integrated SPI Flash, not recommended for other functions. 



3.3. CRYSTAL 
• ESP32-PICO-V3 integrates a 40 MHz crystal oscillator.

3.4. RTC MANAGEMENT AND LOW POWER 
CONSUMPTION 

ESP32 uses advanced power management techniques may be switched between 

different power saving modes. (See Table 5). 

• Power saving mode 

- Active Mode: RF chip is operating. Chip may receive and transmit a sounding
signal. 

- Modem-sleep mode: CPU can run, the clock may be configured. Wi-Fi / 
Bluetooth baseband and RF 

- Light-sleep mode: CPU suspended. RTC and memory and peripherals ULP 
coprocessor operation. Any wake-up event (MAC, host, RTC timer or external 
interrupt) will wake up the chip. 

- Deep-sleep mode: only the RTC memory and peripherals in a working state. Wi- 
Fi and Bluetooth connectivity data stored in the RTC. ULP coprocessor can work. 

- Hibernation Mode: 8 MHz oscillator and a built-in coprocessor ULP are 
disabled. RTC memory to restore the power supply is cut off. Only one RTC clock 
timer located on the slow clock and some RTC GPIO at work. RTC RTC clock or 
timer can wake up from the GPIO Hibernation mode. 

• Deep-sleep mode 

- related sleep mode: power save mode switching between Active, Modem-sleep,
Light-sleep mode. CPU, Wi-Fi, Bluetooth, and radio preset time interval to be
awakened, to ensure connection Wi-Fi / Bluetooth.

- Ultra Low-power sensor monitoring methods: the main system is Deep-sleep
mode, ULP coprocessor is periodically opened or closed to measure sensor data.
The sensor measures data, ULP coprocessor decide whether to wake up the main
system.

Functions in different power consumption modes: TABLE 5 





Arduino IDE Development

USB Driver

Before the program is burned, M5Core host (including BASIC / GRAY / M5GO / FIRE / FACES) users please download the corresponding

CP210X driver package according to the operating system you are using, click the button below. After decompressing the compressed

package, select the installation package corresponding to the operating system value for installation.

Note: M5StickC / M5StickT / ATOM Matrix / ATOM Lite support can be used without driver, users can skip this driver installation step.

*Download CP2104 driver

Arduino-IDE

For Mac OS, make sure System preferences -> Security & Privacy -> General before installing, and allow the apps to be

installed from the App Store and identified developers

M5Stack Docs Product List Platform|API Cases FAQ Language 



Boards Manager

1.Open up Arduino IDE, navigate to File -> Peferences -> Settings

2.Copy the following ESP32 Boards Manager url to Additional Boards Manager URLs:

https://dl.espressif.com/dl/package_esp32_index.json

M5Stack Docs Product List Platform|API Cases FAQ Language 



3.Navigate to Tools -> Board: -> Boards Manager...

4.Search ESP32  in the pop-up window, find it and click Install

M5Stack Docs Product List Platform|API Cases FAQ Language 



5.select Tools -> Board: -> ESP32

For M5Core and M5Stick

For M5StickC

For Atom Matrix/ Atom Lite

The ATOM series has not yet updated the board options. You can choose M5StickC or ESP32 Pico KIT as the board configuration. (Note:

When ESP32-Pico is selected as the board configuration, please use 115200 for the baud rate)

M5Stack Docs Product List Platform|API Cases FAQ Language 



M5Stack Library

Different hardware devices, with different case libraries, please choose to download according to the device you use..Open Arduino IDE,

then Select Sketch -> Include Library -> Manage Libraries...

For M5Core and M5Stick

Search M5Stack  , find it and click Install

M5Stack Docs Product List Platform|API Cases FAQ Language 



For M5Stick-C

For Atom Matrix/Atom Lite

Search M5StickC  , find it and click Install

Search M5Atom  find it and click Install ,to use LED,you may need to install FastLED library

M5Stack Docs Product List Platform|API Cases FAQ Language 



M5Stack Docs Product List Platform|API Cases FAQ Language 



UIFlow Quick Start 

This tutorial applies to M5StickC and M5StickC PLUS 

Burning tool 

Please click the button below to download the corresponding M5Burner firmware 

burning tool according to your operating system. Unzip and open the application. 

Windows10 MacOS 

Linux 

WIFI TEST

http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=uiflow-quick-start
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=burning-tool
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/software/M5Burner_MacOS.zip
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/software/M5Burner_Linux.zip


Firmware burning 

1.Double-click to open the Burner burning tool, select the corresponding device type

in the left menu, select the firmware version you need, and click the download button 

to download. 

2.Then connect the M5 device to the computer through the Type-C cable, select the

corresponding COM port, the baud rate can use the default configuration in M5Burner, 

in addition, you can also fill in the WIFI that the device will be connected to during the 

firmware burning stage information. After configuration, click "Burn" to start burning. 

http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=firmware-burning


3.When the burning log prompts Burn Successfully , it means that the firmware has

been burned. 

When first burning or the firmware program runs abnormally, you can click 

"Erase" to erase the flash memory. In the subsequent firmware update, there is 

no need to erase again, otherwise the saved Wi-Fi information will be deleted 

and the API Key will be refreshed. 

Configure WIFI 

UIFlow provides both offline and web version of the programmer. When using the web 

version, we need to configure a WiFi connection for the device. The following describes 

two ways to configure WiFi connection for the device (Burn configuration and AP 

hotspot configuration). 

Burn configuration WiFi(recommend) 

UIFlow-1.5.4 and versions above can write WiFi information directly through 

M5Burner. 

http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=configure-wifi
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=burn-configuration-wifirecommend


AP hotspot configuration WiFi 

1. Press and hold the power button on the left to turn on the machine. If WiFi is not

configured, the system will automatically enter the network configuration mode

when it is turned on for the first time. Suppose you want to re-enter the network

configuration mode after running other programs, you can refer to the operation

below. After the UIFlow Logo appears at startup, quickly click the Home button

(center M5 button) to enter the configuration page. Press the button on the right

side of the fuselage to switch the option to Setting, and press the Home button to

confirm. Press the right button to switch the option to WiFi Setting, press the Home

button to confirm, and start the configuration.

2. After successfully connecting to the hotspot with your mobile phone, open the

mobile phone browser to scan the QR code on the screen or directly access

192.168.4.1, enter the page to fill in your personal WIFI information, and click

Configure to record your WiFi information. The device will restart automatically after

successfully configuring and enter programming mode.

Note: Special characters such as "space" are not allowed in the 

configured WiFi information. 

Network Programming Mode and API KEY 

Enter network programming mode 

http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=ap-hotspot-configuration-wifi
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=network-programming-mode-and-api-key
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=enter-network-programming-mode


Network programming mode is a docking mode between M5 device and UIFlow 

web programming platform. The screen will show the current network connection 

status of the device. When the indicator is green, it means that you can receive 

program push at any time. Under default situation, after the first successful WiFi 

network configuration, the device will automatically restart and enter the network 

programming mode. If you do not know how to re-enter the programming mode 

after running other applications, you can refer to the following operations. 

restarting, press button A in the main menu interface to select the programming mode 

and wait till the right indicator of the network indicator to turn green in the 

programming mode page. Access UIFlow programming page by visiting 

flow.m5stack.com on a computer browser. 

API KEY Pairing 

API KEY is the communication credential for M5 devices when using UIFlow web 

programming. By configuring the corresponding API KEY on the UIFlow side, the 

program can be pushed for the specific device. The user needs to visit 

flow.m5stack.com in the computer web browser to enter the UIFlow programming page. 

Click the setting button in the menu bar at the upper right corner of the page, enter the 

API Key on the corresponding device, select the hardware used, click OK to save and 

wait till it prompts successfully connecting. 

Light up LED 

Complete the above steps, then you can start programming with UIFlow. 

The following will show you a simple program to drive M5StickC to light 

http://flow.m5stack.com/
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=api-key-pairing
http://flow.m5stack.com/
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=light-up-led


up the LED indicator. (1. Drag the LED to light up the program block. 2. Splice to the 

Setup initialization program. 3 Click the Run button in the upper right corner) 

UIFlow Desktop IDE 

UIFlow Desktop IDE is an offline version of UIFlow programmer which does not require 

network connection, and can provide you with responsive program push experience. 

Please click the corresponding version of UIFlow-Desktop-IDE to download according 

to your operating system . 

Windows10 MacOS 

Linux 

USB programming mode 

Unzip the downloaded UIFlow Desktop IDE archive and double-click to run the 

application. 

http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=uiflow-desktop-ide
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/software/UIFlow-Desktop-IDE_MacOS.zip
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/software/UIFlow-Desktop-IDE_Linux.zip
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=usb-programming-mode


After the app starts, it will automatically detect whether your computer has a USB 

driver (CP210X), click Install, and follow the prompts to finish installation. 

(M5StickC does not require a CP210X driver, so users can choose to install or skip) 

After the driver installation is complete, it will automatically enter the UIFlow Desktop 

IDE and automatically pop up the configuration box. At this time, connect the M5 

device to the computer through the Tpye-C data cable. 

Using UIFlow Desktop IDE requires M5 device with UIFlow firmware and enter ** 

USB programming mode **. 



Click the power button on the left side of the device to restart, after entering the 

menu, quickly click the right button to select USB mode. 

Select the corresponding port, and the programming device, click OK to connect. 

BLE UART 

Function Description 

Establish Bluetooth connection and enable Bluetooth passthrough service. 

http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=ble-uart
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=function-description


Init ble uart name Initialize settings, configure Bluetooth device name. 

BLE UART Writre Send data using BLE UART. 

BLE UART remain cache Check the number of bytes of BLE UART data. 

BLE UART read all Read all data in BLE UART cache. 

BLE UART read characters Read n data in BLE UART cache. 

Instructions 

Establish Bluetooth passthrough connection and send on / off control LED. 

Related Links 

M5StickC IoT Getting Started Tutorial 

UIFlow Block introduction 

http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=instructions
http://localhost:3000/#/en/quick_start/m5stickc_plus/m5stickc_plus_quick_start_with_uiflow?id=related-links
https://m5stack.oss-cn-shenzhen.aliyuncs.com/resource/docs/M5StickC_Guide.pdf
http://localhost:3000/#/zh_CN/uiflow/uiflow_home_page


FCC Statement  
Any Changes or modifications not expressly approved by the party responsible for compliance 
could void the user’s authority to operate the equipment.    
This device complies with part 15 of the FCC Rules. Operation is subject to the following two 
conditions:  
(1) This device may not cause harmful interference, and   
(2) This device must accept any interference received, including interference that may cause 
undesired operation.    

Note : This equipment has been tested and found to comply with the limits for a Class B digital 
device, pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable 
protection against harmful interference in a residential installation. This equipment 
generates,uses and can radiate radio frequency energy and, if not installed and used in 
accordance with the instructions, may cause harmful interference to radio communications. 
However, there is no guarantee that interference will not occur in a particular installation. If this 
equipment does cause harmful interference to radio or television reception, which can be 
determined by turning the equipment off and on, the user is encouraged to try to correct the 
interference by one or more of the following measures:  
—Reorient or relocate the receiving antenna.  
—Increase the separation between the equipment and receiver.  
—Connect the equipment into an outlet on a circuit different from that to which the receiver is 
connected.  
—Consult the dealer or an experienced radio/TV technician for help. 

RF Exposure Statement：

This equipment complies with FCC radiation exposure limits set forth for an uncontrolled 
environment .  

This transmitter must not be co-located or operating in conjunction with any other antenna 
or transmitter.
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