
IBM InfoSphere Information Server Manager
Version 11 Release 3

User's Guide

SC19-4317-00

���





IBM InfoSphere Information Server Manager
Version 11 Release 3

User's Guide

SC19-4317-00

���



Note
Before using this information and the product that it supports, read the information in “Notices and trademarks” on page
51.

© Copyright IBM Corporation 2008, 2014.
US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.



Contents

Chapter 1. Overview of InfoSphere
Information Server Manager . . . . . . 1
System life cycle . . . . . . . . . . . . . 1
Architecture for development, test, and production . 2
Implementing the deployment life cycle . . . . . 2

Chapter 2. Getting started in InfoSphere
Information Server Manager . . . . . . 5
Starting the InfoSphere Information Server Manager
and adding a domain . . . . . . . . . . . 5
Working in the metadata repository . . . . . . 6

Viewing asset properties . . . . . . . . . 6
Viewing job or shared container designs . . . . 6
Searching in the InfoSphere Information Server
Manager . . . . . . . . . . . . . . . 6
Advanced searching in the InfoSphere Information
Server Manager . . . . . . . . . . . . 7
Deleting assets. . . . . . . . . . . . . 7

Tutorial: Deploying assets with the InfoSphere
Information Server Manager . . . . . . . . . 8

Introduction . . . . . . . . . . . . . 8
Module 1: Setting up the tutorial . . . . . . 9
Module 2: Creating and Deploying a package . . 10
Tutorial summary . . . . . . . . . . . 14

Tutorial: Controlling asset source with the
InfoSphere Information Server Manager . . . . . 15

Introduction . . . . . . . . . . . . . 15
Module 1: Setting up the tutorial . . . . . . 16
Module 2: Implementing source control . . . . 17
Tutorial summary . . . . . . . . . . . 20

Chapter 3. Overview of deployment . . 21
Deployment packages . . . . . . . . . . . 22
Basic deployment scenario . . . . . . . . . 22
Deployment workflow. . . . . . . . . . . 22
Deployable assets . . . . . . . . . . . . 23
Defining the deployment package . . . . . . . 23

Deleting package definitions. . . . . . . . 24
Moving package definitions . . . . . . . . 25
Copying package definitions. . . . . . . . 25
Renaming package definitions . . . . . . . 25

Setting the build and deploy paths . . . . . . 25
Building deployment packages and viewing build
histories . . . . . . . . . . . . . . . 26
Deploying packages . . . . . . . . . . . 27

Deploying packages: Single system model . . . 27

Deploying packages: Multiple system, single user
model . . . . . . . . . . . . . . . 28
Deploying packages: Multiple system, multiple
user model . . . . . . . . . . . . . 29

Chapter 4. Importing and exporting
assets . . . . . . . . . . . . . . . 31
Exporting assets . . . . . . . . . . . . . 31
Importing assets . . . . . . . . . . . . . 31
Viewing the log . . . . . . . . . . . . . 32

Chapter 5. Source control of
InfoSphere DataStage and QualityStage
assets . . . . . . . . . . . . . . . 33
Installing Rational ClearCase . . . . . . . . 34
Installing Rational Team Concert . . . . . . . 35
Basic source-control scenario for jobs and associated
assets . . . . . . . . . . . . . . . . 35
Navigating assets and their annotations . . . . . 37
Configuring source control for the InfoSphere
Information Server Manager . . . . . . . . . 37

Creating source control projects. . . . . . . 38
Sharing source control projects . . . . . . . 38

Importing source control projects to your workspace 39
Providing source control for assets . . . . . . 40

Submitting assets to a source control system . . 40
Updating assets in source control . . . . . . 40
Restoring assets from the source control system 41
Locking and unlocking artifacts . . . . . . 42
Clearing a source control workspace . . . . . 42

Appendix A. Product accessibility . . . 43

Appendix B. Contacting IBM . . . . . 45

Appendix C. Accessing the product
documentation . . . . . . . . . . . 47

Appendix D. Providing feedback on the
product documentation . . . . . . . 49

Notices and trademarks . . . . . . . 51

Index . . . . . . . . . . . . . . . 57

© Copyright IBM Corp. 2008, 2014 iii



iv User's Guide



Chapter 1. Overview of InfoSphere Information Server
Manager

You can use the IBM® InfoSphere® Information Server Manager (the deployment
tool) to move, deploy, and control your IBM InfoSphere DataStage® and
QualityStage® assets.

The InfoSphere Information Server Manager is a deployment tool that helps you
manage your jobs and related assets. In a typical environment, you implement
your data transformation solutions across several systems, and control the
promotion of assets between these systems. At its simplest, your environment
might contain development, test, and production systems. The deployment tool is
installed on a Windows computer, and you can connect to all of your systems from
the same Manager.

You can use the deployment tool for the following tasks:
v Viewing your InfoSphere DataStage and QualityStage assets on different

metadata repositories
v Creating packages of assets that you can build and deploy on an iterative basis
v Performing simple exports and imports of assets
v Submitting assets to a source control system

You can also manage your InfoSphere DataStage and QualityStage jobs and related
assets by using the istool commands.

System life cycle
You can use the IBM InfoSphere Information Server Manager to help you
implement a system life cycle for your IBM InfoSphere DataStage and QualityStage
applications and associated assets.

Collections of related InfoSphere DataStage and QualityStage assets, such as jobs
and shared containers, are referred to as an application. As for all software
applications, InfoSphere DataStage and QualityStage applications must be
developed and maintained under a life cycle methodology to ensure quality.

The basic life cycle methodology for InfoSphere DataStage and QualityStage
applications is concerned with the development, test, release, and maintenance of
the applications. This life cycle has a minimum of these phases:
1. Development and maintenance
2. Testing
3. Production

You can implement a system life cycle based on this model, but incorporating more
phases, for example:
1. Development and maintenance
2. Integration testing
3. Quality assurance
4. User acceptance testing
5. Production

© Copyright IBM Corp. 2008, 2014 1



Architecture for development, test, and production
You can place your development, test, and production systems to implement a life
cycle for your IBM InfoSphere DataStage applications.

The best practice is to have a separate physical environment for each phase in the
life cycle. The development, test, and production systems have separate physical
environments.

You can also implement a mixed system, with the development and test systems
sharing a single physical environment, and the production system in a separate
physical environment.

Do not share the development, test, and production systems in a common physical
environment.

The physical environment for each phase in the life cycle can be a loosely coupled
cluster (massively parallel processing environment (MPP), grid, cluster) rather than
a single computer.

Each phase has one or more projects to hold the assets. Move the assets between
different phases by transferring between these projects using the source control
system.

Implementing the deployment life cycle
You can define a process to implement a life cycle for your IBM InfoSphere
DataStage applications.

About this task

The process defines the responsibilities or roles of the various personnel that are
involved in the life cycle. The description of the process does not cover any formal
paperwork that an organization might require. The description focuses on the
process of moving assets through the life cycle.

Procedure
1. Developer: Develop and maintain new assets such as jobs, custom operators,

routines, and sequences in a development project. Thoroughly unit test the
assets. Fix failing tests and make enhancements. Be sure to update the job
description, which is where the change log is kept for an asset.

2. Developer: Send the individual assets to the source code system. Include an
appropriate comment that describes the change when you submit to the
source control system. An asset is serialized as an archive file, known as an
artifact. The name of the artifact is based on the asset name.
v It provides the lowest level of granularity.
v It avoids storing the same asset more than once in the source control

system.
v It prevents any unintentional overlaying of assets when you retrieve the

assets from the source control system.
3. Developer or Administrator: Define and build deployment packages to create

a snapshot of assets with executables. You can rebuild a deployment package
at any time to incorporate the latest versions of the assets, and then deploy
the package to a target system.
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4. Developer or Administrator: Submit the baseline package files to source code
system.

5. Integration Tester: Deploy the packages of controlled assets and executables
into the alpha test environment.

6. Integration Tester: Run the integration tests in the alpha environment and
evaluate the results. If the tests fail, go back to step 1. If the tests succeed,
continue to the next step.

7. Integration Tester: Label the package files for promotion to beta test. Notify
the Quality Assurance Tester that the assets are ready for beta test.

8. Quality Assurance Tester: Retrieve the package files for the beta test from the
source code system and deploy them to the beta test project.

9. Quality Assurance Tester: Run the QA tests and evaluate the results. If the
tests fail, go back to the step 1. If the tests succeed, continue to the next step.

10. Quality Assurance Tester: Label the package files as ready for production.
Notify the Production Manager that the assets are ready for release.

11. Production Manager: Ensure that a system backup is made of target
production project. The backup provides a means to recover from problems
introduced by the changed code. Retrieve the package files that are labeled for
production and deploy them into the production environment. The assets are
now deployed in the production environment.

Chapter 1. Overview of InfoSphere Information Server Manager 3
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Chapter 2. Getting started in InfoSphere Information Server
Manager

Before you can move assets or submit them to the source control system, you must
connect to the metadata repository that contains the assets and locate them.

You can connect to several different metadata repositories from the same
InfoSphere Information Server Manager. You can browse the repository view to
locate the various assets that you want to work with in these repositories. You can
use search facilities to locate particular assets. You can also open a job to look at its
design (although you cannot open individual stages or change job or stage
properties).

Starting the InfoSphere Information Server Manager and adding a
domain

When you start the IBM InfoSphere Information Server Manager, your first task is
to add a domain.

About this task

You can then use the domain to connect to the Services Tier that the IBM
InfoSphere DataStage and QualityStage from which you want to deploy assets
connects to.

Procedure
1. In the Start menu, select Start > All Programs > IBM InfoSphere Information

Server > Information Server Manager.
2. In the repository tree, right-click and select Add Domain. The Add Domain

dialog opens.
3. In the Add Domain dialog, specify the domain, user, password, and whether

the password is saved.
By default, the Save Password setting is cleared. You can change the default
password setting by changing the Save Password option in the Preferences
dialog.
Changing the Save Password setting in the Preferences applies to all
subsequent invocations of the Add Domain dialog. Changing the Save
Password setting in the Add Domain dialog applies only to the specified
domain. If the Save Password setting was previously enabled, then the
password is remembered.

4. After the connection information has been established, expand the list of
available projects and package definitions on the domain and select a project.

5. If you need to reconnect to a disconnected domain, right-click on it and select
Connect. Alternatively, you can double-click the disconnected domain in the
repository tree. If a valid password has been previously saved for that domain,
InfoSphere Information Server Manager connects without prompting. If there is
no previously saved password, the Edit Domain window opens and you are
prompted to enter a password.
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Working in the metadata repository
The IBM InfoSphere Information Server Manager displays a view of the metadata
repository in a tree structure.

Each domain that you add represents a connection to a metadata repository. You
expand the domain to view a node for each of the InfoSphere Information Server
engines that share the metadata repository. You expand each engine to view the
InfoSphere DataStage and QualityStage projects that belong to that engine. Expand
the projects to view the folders that contain the assets that you want to work with.

The repository view also displays deployment packages. You can expand the
Packages to view the package definitions that were created on that domain and
stored in that metadata repository.

The repository tree is the starting point for deployment and source control tasks.
You can also work on the assets themselves from the repository tree.

Viewing asset properties
View the properties of any asset in the Repository view.

About this task

The properties give details of asset name, location, and creation and modification
dates.

Procedure
1. Right-click on the item in the Repository view.
2. Select Show Properties.

What to do next

You can also view properties from the Search Results window, Package Editor
window, Source Control view, Export Editor window, or Import Editor window.

Viewing job or shared container designs
View a job or shared container design in the Repository view.

About this task

You can view the design of a job or a shared container. You cannot make changes,
or view the properties of individual stages within the job or shared container. You
can also view designs in the Search Results window, the Package Editor window,
the Export Editor window, or the Source Control view.

Procedure
1. Double-click the job or shared container, or right-click it and select Open.
2. Use the icons on the editing toolbar at the top-right corner of the window to

zoom in, zoom out, or restore the image to its actual size.

Searching in the InfoSphere Information Server Manager
The IBM InfoSphere Information Server Manager has a search box in the
upper-right corner of the application window.
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About this task

You can use the search box to perform simple searches of the metadata repository
associated with the domain that you are currently viewing. You can also search the
help topics for the InfoSphere Information Server Manager.

Procedure
1. Type the search string in the search box. You can type partial strings, for

example searching for REP might return results for asset names DEPREP.IPO,
FRPREP.ICO, and so on.

2. Select Metadata Repository or Help Search from the drop-down menu to the
right of the search box.

3. Click the search icon to perform the search and display results in the Search
window.

4. If the search returns more results than can be displayed in the Search window,
click Show more in the Search window title bar to scroll through the results.

Advanced searching in the InfoSphere Information Server
Manager

You can perform advanced searches of the metadata repository. You can specify
search criteria to perform a more specific search.

Procedure
1. Open a search window by doing one of the following steps:

v Click the search icon next to the search box in the title bar.
v Select Search from the pop-up menu on the Repository view.

2. Construct your advanced search by selecting search criteria from the

drop-down lists. Use the plus and minus buttons to add or remove
search criteria. If you do not specify a specific metadata repository to search,
the repository associated with the domain that you are currently viewing is
searched.

3. Click the search button to perform the search and display results in the Search
window.

4. If the search returns more results than can be displayed in the Search window,
click Show more in the Search window title bar to scroll through the results.

5. If you have previously performed advanced searches in this window, use the
arrow buttons in the Search window title bar to navigate through different sets
of search results.

Deleting assets
You can delete jobs from the metadata repository by using the IBM InfoSphere
Information Server Manager.

About this task

You can delete jobs from the metadata repository by using the InfoSphere
Information Server Manager. You cannot delete other types of asset because there
might be dependencies on them.

You can delete jobs from the Repository view and the Search Results window.
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Procedure
1. Select the job that you want to delete.
2. Right click and select Delete.

Tutorial: Deploying assets with the InfoSphere Information Server
Manager

This tutorial teaches you the basic skills that you need to use the IBM InfoSphere
Information Server Manager to create and deploy a package.

Introduction
This tutorial walks you through the creation and deployment of a package.

The aim of the tutorial is to get you familiar with deployment in the IBM
InfoSphere Information Server Manager. The tutorial guides you through the cycle
of defining a package, building it, and deploying it. The tutorial then guides you
through building and deploying the package again after some of the assets that it
contains are changed.

The setup process involves importing some sample assets into an IBM InfoSphere
DataStage and QualityStage project, and you include these assets in your
deployment package.

Learning objectives

As you work through the tutorial, you learn how to do the following tasks:
v Connect to the metadata repository of InfoSphere Information Server and import

the tutorial data to a DataStage and QualityStage project.
v Create a package and add assets to it.
v Build the package.
v Deploy the package to a target project.
v Rebuild the package after some changes were made to the assets it contains.
v Redeploy the package to the target project.

If you have access to a second InfoSphere Information Server instance, you can do
an additional task and deploy the package to this second instance.

Time required

This tutorial takes approximately 60 minutes to finish. If you explore other
concepts that are related to this tutorial, it might take longer to complete.

Audience

New users of the InfoSphere Information Server Manager who are familiar with
InfoSphere DataStage and QualityStage.

System requirements

The tutorial requires the following hardware and software:
v InfoSphere Information Server Manager installed on a Windows platform.
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v IBM InfoSphere DataStage clients installed on a Windows computer (can be the
same computer where you have the InfoSphere Information Server Manager
installed).

v Connection to a computer that hosts the services tier for InfoSphere Information
Server.

v Optionally, connection to a second computer that hosts the services tier for
another installation of InfoSphere Information Server.

Prerequisites

Complete the following tasks before starting the tutorial:
v Obtain DataStage developer privileges from the InfoSphere DataStage

administrator.
v Confirm that the InfoSphere DataStage administrator created two projects for

you to work in. They first project is named Develop, and the second project is
named Test.

v Set up the tutorial data as described in the first lesson.

Module 1: Setting up the tutorial
This module explains how to set up the data needed for this tutorial.

Learning objectives

As you work through the module, you learn how to do the following tasks:
v Connect to the metadata repository of InfoSphere Information Server and import

the tutorial data to a DataStage and QualityStage project.

Lesson 1.1: Copying tutorial data
Before you begin the tutorial, you must copy the data that you intend to use to a
folder and import it.

To set up the tutorial:
1. Open the installation media on the client computer where you installed IBM

InfoSphere DataStage.
2. Create a folder on your client computer and name it dep_exercise.
3. From the installation media, copy the \TutorialData\DataStage\

dep_exercise.isx file to the dep_exercise folder.

Lesson 1.2: Starting the InfoSphere Information Server Manager
and adding a domain
The first step is to start the IBM InfoSphere Information Server Manager and
connect to a metadata repository.

The domain is used to connect to the metadata repository holding the DataStage
and QualityStage assets that you want to package and deploy.

To start the InfoSphere Information Server Manager and connect to a metadata
repository:
1. Click Start > Programs > IBM InfoSphere Information Server > IBM

InfoSphere Information Server Manager.
2. In the Repository view of the Information Server Manager application window,

right-click and click Add Domain.
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3. Specify the application server, user, password, and whether the password is
saved.

4. Click OK to connect to the domain and to the metadata repository.

The InfoSphere Information Server Manager is now ready for you to import the
tutorial data.

Lesson checkpoint:

In this lesson, you started the IInfoSphere Information Server Manager.

You learned the following tasks:
v How to start the InfoSphere Information Server Manager
v How to add a domain and use it to connect to a metadata repository

Lesson 1.3: Importing the tutorial data
Before you can start the package and deploy module, you must import the assets
to be packaged.

When you package and deploy with of the IBM InfoSphere Information Server
Manager, you define a package that can easily be updated whenever assets change.
You store the package on the computer that hosts the services tier for the
InfoSphere Information Server. You can also use a simple export mechanism to
write assets to an archive file. The archive file is stored on the Windows computer
where the InfoSphere Information Server Manager is installed. This tutorial
imports the tutorial data from an archive file that is named dep_exercise.isx.

To import the tutorial data:
1. In the Repository navigation tree, right-click the domain that contains the

project to which you want to import the assets and click Import.
2. Browse for the dep_exercise.isx file that you copied in an earlier lesson. Click

Open and view details of the assets that the archive file contains.
3. Click Import to open the Import window.
4. Select Test as the target project.
5. Click OK to import the assets to the Test project.

The InfoSphere Information Server Manager is now ready for you to start work.

Lesson checkpoint:

In this lesson, you imported the tutorial data.

You learned the following task:
v How to import assets from an archive file

Module 2: Creating and Deploying a package
This module teaches you how to create and deploy a package.

Learning objectives

As you work through the tutorial, you learn how to do the following tasks:
v Create a package and add assets to it.
v Build the package.
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v Deploy the package to a target project.
v Rebuild the package after some changes were made to the assets it contains.
v Redeploy the package to the target project.

If you have access to a second InfoSphere Information Server instance, you can do
an additional task and deploy the package to this second instance.

Lesson 2.1: Creating deployment packages
You define a package that contains the assets that you want to deploy.

You create a deployment package and specify which assets you want to include in
your package. You can choose to include dependent assets in the package, to
export design assets only, job executables only, or both design assets and job
executables.

To create the deployment package:
1. Open the Package window by selecting a domain to which you are connected

in the Repository tree and doing one of the following tasks:
v Click File > New > Package from the main menu.
v Right-click, and click New > Package from the pop-up menu.

2. Select the following assets from the repository tree and drag them to the
Package window:
v dep_assets/job1
v dep_assets/job2
v dep_assets/seqjob
v dep_assets/shcont1
v dep_assets/shcont2
In this tutorial, you copy assets from a single IBM InfoSphere DataStage and
QualityStage project to add to your package. You can also add assets from
multiple projects to your package. If you have multiple InfoSphere Information
Server engines that use the services tier to which you are connected, you can
add assets from projects that are associated with different engines.

3. In the Selected Items tab, expand the view of selected folders to see the assets
that are included in the package.

4. View the dependent items for the job1 job by right-clicking on job1 in the
Package window and selecting View Dependent Items.

5. View the package creation options by clicking the Options tab on the Package
window. Select the following options:
v Include executables

v Include designs

v Include dependent items

6. Enter the following text into the Package description field: Deployment package
containing assets from the deployment tutorial

7. Save your package. Name the package dep_exercise_pack. The package is
saved as an asset in the metadata repository. You can view the package in the
packages section of the repository tree.
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Lesson checkpoint:

In this lesson, you created a deployment package.

You learned the following tasks:
v How to define assets to be included in a deployment package
v How to set the options for the package and provide a description
v How to save the package to the metadata repository

Lesson 2.2: Building deployment packages
After you define a package and save it in the metadata repository, you build the
package to create a package file. You can then use the package file to deploy the
packaged assets.

When you define a package, you identify the assets that you want the package to
contain. When you build the package, copies of the assets are added to the
package file. So, the assets are included in the deployment package as they are at
the time of the build, not at the time the package was defined.

To build the deployment package:
1. Click Build in the Package window.
2. Specify the label exercise_build1 and add the comment very first build.
3. Click OK to build the package.
4. When the build is finished, click the History tab. You can see the details of the

build that you just did.

Lesson checkpoint:

In this lesson, you built a deployment package.

You learned the following tasks:
v How to build a deployment package
v How to specify a build label and add a comment to that build

Lesson 2.3: Deploying packages to a different project
You deploy the package to move the assets to another project in the same metadata
repository.

You can use the IBM InfoSphere Information Server Manager to move assets
between projects in the same metadata repository in a controlled and reproducible
manner.

To deploy the package to another project:
1. Click Deploy in the Package window.
2. Select the Test project from the Project name list.
3. Select exercise_build1 in the Build label list.
4. Click OK to deploy the package.
5. When the deploy operation is finished, click OK in the Deploy Results window.
6. Click the History tab in the Package window, and note that the Deployed on

Server field now contains the details of the project that you deployed the
package to.
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Lesson checkpoint:

In this lesson, you deployed a package to a different project.

You learned the following tasks:
v How to deploy a package to a different project
v How to view deployment details in the history of the package

Lesson 2.4: Changing assets and redeploying packages
After an asset in your project changes, you can rebuild the package that contains
that asset and redeploy the package.

To build the deployment package:
1. Open an IBM InfoSphere DataStage and QualityStage Designer client and

attach to the Develop project.
2. Open the Job1 job, add an annotation, and then save the job and exit the

Designer client.
3. In the IBM InfoSphere Information Server Manager, ensure that the Package

window is showing the dep_exercise_pack package.
4. Click Build.
5. Specify the label exercise_build2 and add the comment updated build.
6. Click OK to rebuild the package.
7. When the build is finished, click the History tab. Right-click on

exercise_build2 and select Compare with Previous Build.
8. In the lower half of the Package window, compare the left pane with the right

pane. In the right pane you can see Job1 displayed in green, because Job1 is
the asset that changed between your first build and your second build.

9. Click Deploy in the Package window title bar.
10. Do the following steps:

a. Select the Test project from the Project name list.
b. Select exercise_build2 from the Build label list.
c. Select the Replace existing items option.

11. Click OK to deploy the package to the target project.
12. Refresh the Test project in the Repository view.
13. Double-click the job named Job1, and verify that it now contains the

annotation that you added to the job in the Develop project.

Lesson checkpoint:

In this lesson, you rebuilt a deployment package, where the assets it contained
changed, and deployed it to the target project again.

You learned the following tasks:
v How to rebuild a deployment package
v How to compare different builds of a package
v How to redeploy the package to the target project
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Lesson 2.5: Deploying packages to a different instance of
InfoSphere Information Server
In real-world environments, your development, test, and production projects are
located on different systems. This tutorial walks you through deploying your
package to a project on a separate IBM InfoSphere Information Server instance.

You can connect to several different InfoSphere Information Server systems from a
single InfoSphere Information Server Manager. You add a domain in the
InfoSphere Information Server Manager to connect to each system. You can then
expand the domain in the repository tree and view the InfoSphere Information
Server engines and associated projects, assets, and packages.

In this tutorial, you save the package as a file to a directory on your local
Windows computer. You then deploy the assets from this file to the target
metadata repository. This technique is called the deploy-from-file method. An
alternative method transfers the package file to a defined deployment directory on
the target system and deploys the assets from there. This technique is called the
deploy-from-domain method.

To deploy your package to a different InfoSphere Information Server instance:
1. In the Package window for your package, click Send.
2. In the Save As window, select a directory on your local Windows computer to

save the package file to, and click Save.
3. Add a domain and connect to the target InfoSphere Information Server

instance.
4. Select the new domain in the repository tree, right-click and click Deploy

Package From > File.
5. Browse to the directory where you saved your package file, select the package

file, and click Open.
6. In the new Package window that opens, click Deploy and select the target

project from the Project name list and a build from the Build label list.
7. Click OK to deploy the assets to the target project.

Lesson checkpoint:

In this lesson, you deployed assets to a project on a different InfoSphere
Information Server system.

You learned the following tasks:
v How to save a deployment package to a directory on the local Windows

computer.
v How to deploy the assets in that package to a project on a different InfoSphere

Information Server instance.

Tutorial summary
From the lessons in this tutorial, you learned about deployment in the IBM
InfoSphere Information Server Manager.

Lessons learned

By completing this tutorial, you learned how to:
v Connect to the metadata repository of InfoSphere Information Server and import

the tutorial data to a DataStage and QualityStage project.
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v Create a package and add assets to it.
v Build the package.
v Deploy the package to a target project.
v Rebuild the package after some changes were made to the assets it contains.
v Redeploy the package to the target project.

Tutorial: Controlling asset source with the InfoSphere Information
Server Manager

This tutorial teaches you the basic skills that you need to use the IBM InfoSphere
Information Server Manager to help you implement source control for your
InfoSphere DataStage and QualityStage assets.

Introduction
This tutorial walks you through using the IBM InfoSphere Information Server
Manager to help you implement source control for your IBM InfoSphere DataStage
and QualityStage assets.

This tutorial assumes that you use the CVS source control system. If you use a
different source control system you can adapt the tutorial. Differences between
different source control systems are in the Team menu, and your source control
system commands that are in the Team menu. It is not an aim of the tutorial to
teach you basic source control methodology.

Learning objectives

As you work through the tutorial, you learn how to do the following tasks:
v Connect to the metadata repository of InfoSphere Information Server and import

the tutorial data to an InfoSphere DataStage and QualityStage project.
v Configure your InfoSphere Information Server Manager by importing a

previously defined source control project so that the deployment tool can
connect to your source control system.

v Submit an asset to the source control system
v Resubmit an updated asset to the source control system.
v Restore your updated asset in the metadata repository with the original version

from the source control system.

Time required

This tutorial takes approximately 60 minutes to finish. If you explore other
concepts that are related to this tutorial, it might take longer to complete.

Audience

New users of IBM InfoSphere Information Server Manager who are familiar with
InfoSphere DataStage and QualityStage and with the CVS source control system.

System requirements

The tutorial requires the following hardware and software:
v InfoSphere Information Server Manager that is installed on a Windows platform.
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v IBM InfoSphere DataStage and QualityStage clients on a Windows computer
(which can be the same computer where you have InfoSphere Information
Server Manager installed).

v Connection to a computer that hosts the services tier for InfoSphere Information
Server.

v Connection to a CVS source control system.

Prerequisites

Complete the following tasks before starting the tutorial:
v Obtain DataStage developer privileges from the InfoSphere DataStage

administrator.
v Confirm that the administrator created a source control project for you to work

in.
v Obtain connection details for your source control system.
v Set up the tutorial data as described in the first lesson.

Module 1: Setting up the tutorial
This module explains how to set up the data needed for this tutorial.

Learning objectives

As you work through the module, you learn how to do the following tasks:
v Connect to the metadata repository of an InfoSphere Information Server system

and import the tutorial data to an InfoSphere DataStage and QualityStage
project.

Lesson 1.1: Copying tutorial data
Before you begin the tutorial, you must copy the data to be used to a folder and
import it.

To set up the tutorial:
1. Open the installation media on the client computer where you installed IBM

InfoSphere DataStage.
2. Create a folder on your client computer and name it dep_exercise.
3. From the installation media, copy the \TutorialData\DataStage\

dep_exercise.isx file to the dep_exercise folder.

Lesson 1.2: Starting the InfoSphere Information Server Manager
and adding a domain
The first step is to start the IBM InfoSphere Information Server Manager and
connect to a metadata repository.

The domain is used to connect to the metadata repository holding the IBM
InfoSphere DataStage and QualityStage assets that you want to submit to the
source control system.

To start the InfoSphere Information ServerManager and connect to a metadata
repository:
1. Select Start > Programs > IBM InfoSphere Information Server > IBM

InfoSphere Information Server Manager.
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2. In the Repository view of the InfoSphere Information Server Manager
application window, right-click, and click Add Domain. The Add Domain
window opens.

3. Specify the application server, user, password, and whether the password is
saved.

4. Click OK to connect to the domain and to the metadata repository.

The InfoSphere Information Server Manager is now ready for you to import the
tutorial data.

Lesson checkpoint:

In this lesson, you started the InfoSphere Information Server Manager.

You learned the following tasks:
v How to start the InfoSphere Information Server Manager
v How to add a domain and use it to connect to a metadata repository

Lesson 1.3: Importing the tutorial data
Before you can start the source control module, you must import the assets that
you will package.

To import the tutorial data:
1. In the Repository navigation tree, right-click the domain that contains the

project to which you want to import the assets and click Import.
2. Browse for the dep_exercise.isx file that you copied in an earlier lesson. Click

Open and view details of the assets that the archive file contains.
3. Click Import to open the Import window.
4. Select Test as the target project.
5. Click OK to import the assets to the Test project.

The InfoSphere Information Server Manager is now ready for you to start work.

Lesson checkpoint:

In this lesson, you imported the tutorial data.

You learned the following task:
v How to import assets from an archive file

Module 2: Implementing source control
This module teaches you how to use the IBM InfoSphere Information Server
Manager to implement source control for your IBM InfoSphere DataStage and
QualityStage assets.

Learning objectives

As you work through the module, you learn how to do the following tasks:
v Configure your InfoSphere Information Server Manager by importing a

previously defined source control project so that the Manager can connect to
your source control system.

v Submit an asset to the source control system
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v Update the asset in InfoSphere DataStage and QualityStage and resubmit the
asset to the source control system.

v Replace your updated asset with the original version from the source control
system.

Lesson 2.1: Importing the source control project from CVS
Before you can save assets to the source control system, you must import the
source control project.

The IBM InfoSphere Information Server Manager uses a source control project to
share assets with your IBM InfoSphere DataStage projects. To configure the
InfoSphere Information Server Manager, an administrator must create the source
control project and share the project under the source code control system. Sharing
the project submits it to the source code control repository.

To import the source control project from CVS into your InfoSphere Information
Server Manager workspace:
1. Select Window > Show View > Source Control Workspace.
2. Right-click and click Import.
3. Select Projects from CVS and click Next.
4. Specify details about the CVS repository that you want to connect to and click

Next.
5. Select the Use existing repository location option, select the source control

repository location from the list (if more than one location is offered, ask your
administrator which one to select), and click Next.

6. Select the Use an existing module option and select the project to import from
the list (the project has the same name as the domain that you are connected
to), then click Next.

7. Select the Check out as a project in the workspace option.
8. Click Finish to import the project into your workspace.

Lesson checkpoint:

In this lesson, you imported a source control project into your workspace. You are
now ready to start working with the source control system.

Lesson 2.2: Submitting jobs to the source control system
This lesson shows you how to submit some example jobs to the source control
system.

When you design IBM InfoSphere DataStage jobs and move them through a
product life cycle, it is a good practice to submit designs to a source control
system, so you can control master copies and track changes. In this lesson, you
submit one of the jobs in the IBM InfoSphere Information Server Manager tutorial
data.

To submit a job:
1. Connect to the domain for the metadata repository where the example jobs are.
2. In the Repository view select the job1 job
3. Right-click the selected job, and click Send to Source Control Workspace. This

action creates an archive version of the asset, known as an artifact, and writes
that artifact to the source control project.
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4. Right-click the selected job again, and click Team > Commit to commit the
artifact to the source control system. If you are not already connected to the
CVS repository, a window prompts you for authentication before you can check
in the artifact.

5. In the Commit Files window, provide a comment and click Finish.

The job1 icon is annotated to show that the job is in CVS.

Lesson checkpoint:

You submitted a job to CVS.

You learned the following:
v How to send a job to the source control workspace
v How to commit the job in CVS
v How the job icon changes to illustrate that it is in CVS

Lesson 2.3: Updating jobs in the source control system
This lesson shows you how to update the job that you previously submitted to the
source control system.

By default, executable files are sent to source control when you use the Send to
Source Control Workspace command. If you do not want to include executable
files in your source control, you must disable this option in the Source Control
section of your client preferences.

If you update an asset that was previously submitted to the source control system,
then you must update that asset in the source control system too. In this lesson
you make a minor change to job1, and then resubmit it to CVS.

To upgrade the job:
1. Open job1 in the Designer client, add an annotation to the job, and then save

the job.
2. Connect to the domain for the metadata repository where the example jobs are.
3. In the Repository view, select job1.
4. Right-click, and click Send to Source Control Workspace. This action sends an

updated archive file of the asset to the source control workspace.
5. Right-click again, and click Team > Commit to commit the artifact to the CVS

source control system. If you are not already connected to the CVS repository, a
window prompts you for authentication before you can commit the artifact.

6. In the Commit Files window, provide a comment and click Finish.

The version number next to the job icon is incremented.

Lesson checkpoint:

You have submitted a job to CVS control.

You learned the following:
v How to send a job to the source control workspace
v How to commit the job in CVS
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Lesson 2.4: Restoring jobs from the source control system
This lesson shows you how to restore the job to the metadata repository that you
previously submitted to the source control system.

You might want to restore an asset from the equivalent artifact in the source
control system. For example, if your metadata repository is damaged. Alternatively
you might want to restore an asset from an earlier version in the source control
system or from a different branch in the source control system.

To restore the job from CVS:
1. Open the job1 job in the Designer client, delete the annotation that you added

in the previous lesson, and then save and close the job.
2. In the InfoSphere Information Server Manager, connect to the domain for the

metadata repository where you want to restore the job to.
3. In the Repository view, select job1.
4. Right-click the select job, and click Replace with to select whether you want to

replace the asset with the equivalent artifact or with an artifact from an
alternative branch or version. For this tutorial, select Replace with > Latest
from HEAD to restore the equivalent artifact. The Replace with action copies
the selected artifact to the source control project.

5. Right-click the job again, and click Replace from Source Control Workspace to
import the artifact from the source control workspace as an asset to the
metadata repository.

6. Open job1 in the Designer client again, and note that the annotation is restored.
If the annotation does not appear to be restored, restart the Designer client to
see that the annotation is been restored.

Lesson checkpoint:

You restored a job from CVS to the metadata repository.

You learned how you can replace an asset in your metadata repository from the
source control system.

Tutorial summary
From the lessons in this tutorial, you learned about using the IBM InfoSphere
Information Server Manager to help you implement source control for your IBM
InfoSphere DataStage and QualityStage assets.

Lessons learned

By completing this tutorial, you learned how to:
v Connect to the metadata repository of InfoSphere Information Server and import

the tutorial data to an InfoSphere DataStage and QualityStage project.
v Configure your InfoSphere Information Server Manager by importing a

previously defined source control project so that the deployment tool can
connect to your source control system.

v Submit an asset to the source control system
v Resubmit an updated asset to the source control system.
v Restore your updated asset in the metadata repository with the original version

from the source control system.
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Chapter 3. Overview of deployment

Use the IBM InfoSphere Information Server Manager to deploy IBM InfoSphere
DataStage and QualityStage assets between projects on the same engine tier, or
engine tiers on different InfoSphere Information Server instances.

InfoSphere Information Server Manager supports a model of separate systems that
are used to develop, test, and run InfoSphere DataStage and QualityStage jobs. The
tool facilitates this model by providing a secure, managed, and trackable method
of moving assets between the different systems.

Deployment is an iterative process. You specify the assets that you want to deploy
by defining a package. When you are ready to deploy, you build the package to
produce a package file. If necessary, you copy the package file to the target
deployment environment. You then deploy the package to move the assets to the
target system. When the assets on the source system change, there is no need to
redefine the package; all you need to do is rebuild, recopy, and redeploy the
package.

When you define the deployment package, you can select assets from multiple
InfoSphere Information Server engines and projects which share the same metadata
repository. You can also select specific assets or folders to add all items contained
in the folder.

Package
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Package
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Project P

Information
Server

Information
Server
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Phase 2:
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Figure 1. Package phases in the InfoSphere Information Server Manager
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Deployment packages
To move assets between different projects or different systems, you first define a
package that contains the assets that you want to move. The package is itself
stored in the same metadata repository as the assets it contains.

After you have defined a package, you build it. The build process creates a
package file which contains the assets and which can be used to deploy the assets.
Whenever the assets change on the source system, you can rebuild the package.

You specify labels for the builds, and can supply comments to help track the
information.

The various builds of the package are maintained, so that you can revert to an
earlier version of the assets by deploying an earlier build of the package.

Basic deployment scenario
This topic provides an example deployment scenario involving IBM InfoSphere
DataStage and QualityStage assets.

In a basic deployment scenario, a set of InfoSphere DataStage and QualityStage
assets is moved from a development environment to a test or production
environment. The assets make up some or all of an application, but are not
necessarily dependent on each other. The assets that make up the set might be
developed by different users, possibly in different InfoSphere DataStage and
QualityStage projects.

The set of assets is deployed as a unit to a single target system and a single
DataStage and QualityStage project. However, the set of assets can be deployed
many times to many systems or projects as it moves through its life cycle. The
target system or systems might not allow the compilation of jobs so options are
available to package execution-ready assets.

Deployment workflow
The workflow for deploying assets by using the IBM InfoSphere Information
Server Manager might involve more than one user.

In tightly controlled environments with limited access to the target and source
systems, a developer performs definition and build steps to write the package to
the file system. A production manager (or any user with access to the required
target project and the build package) then applies the package to a project on the
target system.

Deployed assets are typically read-only in every environment except development.
If an error is discovered in a test or production environment that requires a change
to an asset, or if an improved implementation of a specific asset (such as a
InfoSphere QualityStage ruleset) is created, then the change is made in the
development environment and applied to an existing package by rebuilding the
package. The updated package can be deployed into an existing project, replacing
the corresponding assets.

There might be a requirement to revert to an earlier version of a deployment. In
this case a previous build of the package is deployed, replacing the corresponding
assets.
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The following diagram shows the workflow of a created package:

Deployable assets
You can deploy most types of IBM InfoSphere DataStage and QualityStage assets
with IBM InfoSphere Information Server Manager.

You can add the following types of assets to your deployment packages:
v Data elements
v Data connections
v IMS databases
v IMS viewsets
v Jobs (mainframe, parallel, sequence, and server)
v Machine profiles
v Routines (mainframe, parallel, and server)
v Shared containers (parallel and server)
v Table definitions
v Transforms
v Custom folders (external files in the InfoSphere DataStage and QualityStage

project directory)
v QualityStage rule sets
v QualityStage match specifications
v Parallel custom stages, build stages, and wrapper stages
v Parameter sets

You can also deploy job executables, which might be required where your target
domain can only run jobs and not compile them. These executables only work if
certain conditions are met (the runtime environment must be compatible).

Defining the deployment package
You must define the deployment package before you build or deploy the package.
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Figure 2. Deployment package workflow
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About this task

The package definition is like a contents list for the package. You specify the assets
that you want the package to contain in the package definition, which is itself
stored as an asset in the metadata repository. You can open the package definition
at any time to add or remove assets. When you later build the package, the IBM
InfoSphere Information Server Manager assembles the assets that you specified in
the package definition into a package file. You can then deploy the assets to the
target location from the package file.

Procedure
1. Open the Package window by selecting a domain to which you are connected

in the repository tree and doing one of the following tasks:
v Select File > New > Package from the main menu.
v Select New > Package from the pop-up menu.

2. To add items to the package definition, drag the items from the repository tree
to the Selected Items tab of the Package window. Alternatively, you can
right-click on the items in the Repository view or Search window, click Copy,
then right-click in the Selected Items tab of the Deployment Package window,
and click Paste.

3. In the Selected Items tab, expand the view of selected folders to see the assets
that are included in the package.

4. To view dependent items for a single item or multiple items, right-click that
asset and click View Dependent Items.

5. To include additional files from a project file system into the package definition,
right-click in the Selected Items tab, then click Add External Folder. You can
place any files that you want to include with your package in a folder in the
project folder, and then select that folder. You could, for example, use this
feature to package some simple test data for your jobs.

6. To view the package creation options, click the Options tab on the Deployment
Package window. You can use the options to write a package description, and
include job designs, executables, or dependent items in the package.

7. When you define the package contents and options, click Save and specify a
name for the package. The package appears as an asset in the packages section
of the repository tree. You can then open the package and modify it by adding
or deleting assets.

8. You can create folders in the packages section of the repository tree to help
organize your packages. To create a folder:
a. Select the Packages node in the repository tree.
b. Right-click and click New > Folder

c. In the New Folder window, specify a name for the folder and click OK.

Results

After you have created a package definition as an asset in the metadata repository,
you can perform standard operations on the package definition, such as deleting,
moving, copying, or renaming it.

Deleting package definitions
You can delete a package definition or a package folder from the repository tree.
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Procedure
1. Right-click the package definition or the folder in the repository tree.
2. Click Delete.

Moving package definitions
You can move a package definition between folders in the repository tree.

Procedure
1. Right-click the package definition in the repository tree.
2. Click Move.
3. In the Move items window, select the destination folder and click OK.

Copying package definitions
You can copy a package definition and paste it under the packages node, or in a
folder in the packages node. Use this feature as a way of replicating an existing
package definition.

Procedure
1. Right-click the package definition that you want to copy.
2. Click Copy.
3. Right-click on the packages node, or on the target folder, and click Paste.
4. Rename the package definition as required.

Renaming package definitions
You can rename a package definition in the repository tree.

Procedure
1. Right-click the package definition that you want to rename.
2. Click Rename.
3. In the Rename window, type the new name and click OK.

Setting the build and deploy paths
Set the build path to specify the location where the package file is created when a
package is successfully built. If you are deploying a package from one system to
another, set the deploy path on the target system to specify the location where you
copy the package file. In a clustering environment, set the build and deploy paths
to shared directories that are accessible from every cluster node.

Procedure
1. Connect to the domains where you want to build and deploy packages.
2. Click File > Preferences

3. Click Packages in the navigation tree.
4. Select your domain from the Domain list.
5. Enter the Build path.
6. If you are planning to deploy a package from a source system to this system,

enter the Deploy path.
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Building deployment packages and viewing build histories
Before you can deploy a package, you must build it. You can use the build history
to track the state of a package.

About this task

After you have defined a package, you can build it to produce a package that is
ready for deployment. You can rebuild existing packages and redeploy them when
the items that they contain are changed. Use the build history to track the state of
a package.

If you rebuild an existing package, you can choose to replace the entire package or
just update the items in the package that have changed since the last build.

If you choose to replace the existing package, the package is completely rebuilt and
its prior build history is deleted.

Items are pulled into the build in their state at the time of the build, not in their
state at the time the package was defined.

Procedure
1. Click Build in the Package window. The Build Package window opens, where

you specify a label and comment for the build.
2. If you want to completely replace an existing package, select the Replace

existing package option.
3. Click OK to build the package.
4. When the build is finished, click the History tab. The History view displays a

list of package builds that were either created on the domain, or deployed to
the domain.

5. To compare the contents of a build with its previous build, right-click on the
build name and select Compare with Previous Build.

6. To compare the contents of two different builds, highlight both build names,
right-click, and select Compare Selected Builds. Differences between the two
builds are shown in the bottom part of the window. The left-side view shows
the older version, and the right-side view shows the newer version of the build.
On the right-side view, items in green indicate that these new items were
added in the latest build. Items shown in blue indicate that these items were
modified.
On the left-side view, items in red indicate that these items were deleted from
the newer version of the build.
These colors settings are the default. You can customize the colors in the
Preferences menu by selecting Package, then History Comparison Colors in the
navigation view.
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Note: In the status bar of the IBM InfoSphere Information Server Manager
screen is the number of changes found within the chosen builds.

Deploying packages
After you have defined and built a package that contains IBM InfoSphere
DataStage and QualityStage assets, you can deploy that package by using the
deployment tool.

You can deploy packages to different projects on the same InfoSphere DataStage
and QualityStage system, or you can deploy to different InfoSphere DataStage and
QualityStage systems.

Where you are implementing a life cycle procedure, you can use the IBM
InfoSphere Information Server Manager to deploy packages to development, test,
and production systems. In this scenario, you might require that different users
package the assets on the source system, and deploy them to the target system.

Deploying packages: Single system model
In this model, a single user creates the package and deploys it to a different project
on the same IBM InfoSphere DataStage and QualityStage system. You can deploy
any package in the Repository view to the target project if the package has been
built, and if you have the authority to import into the target project.

Figure 3. Deployment package comparison view
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Procedure
1. At the top of the Package window, click Deploy.
2. In the Deploy Package window, specify the target project and the particular

build that you want to deploy to that project. If more than one build exists, you
see a drop-down list of the builds available for deployment.

3. If required, select the Replace existing items option to overwrite items in the
target project.

4. After verifying your settings, click OK, and the package is deployed to the
target project.
When the deployment is complete, a Deploy Results window opens, displaying
the status of the deployment. In this window, you can view the deployment
details, copy the details to a clipboard, or click OK to proceed.

Deploying packages: Multiple system, single user model
In this model, a user creates the package from assets on one IBM InfoSphere
DataStage and QualityStage system, and then deploys the package to a separate
DataStage and QualityStage system.

Figure 4. Deploy Package window
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About this task

This model is typically used where a life cycle is implemented between
development, test, and production systems, but access to each system is not
restricted and a single user can connect to all the domains representing these
systems.

There are two stages in this package and deploy model: one to create and build the
package on the source system, and one to deploy the package directly to the target
system.

To create and build the package on the source system:
1. Connect to the domain that represents the source DataStage and QualityStage

system.
2. Create a package from assets on the source DataStage and QualityStage system,

and build the package.
3. In the Package window, click Send in the top right corner.
4. In the Save As dialog, browse to a location to save the package file to. If

possible, browse to the deployment directory on the target server, and save the
file to that location. (A deployment directory for each domain that you added
to IBM InfoSphere Information Server Manager is specified in the Preferences
window. The deployment directory is on the computer that hosts the services
tier corresponding to that domain, which can be a Windows, UNIX, or Linux
platform.)

To deploy a package to a separate target DataStage and QualityStage system:
1. If you could not send the package file directly to the target system deploy

directory, copy the file now.
2. Connect to the domain that represents the target DataStage and QualityStage

system.
3. In the Repository view, right-click the domain representing the target system

and click Deploy Package From > Domain. The Open Package from File dialog
opens, where you select a package file to deploy. The Package window then
opens for the package that you selected.

4. Click Deploy to open the Deploy Package dialog. Select the target project and
the build that you want to deploy and click OK. The package contents are
deployed to the target project.

5. To view the package build and deployment history, click the History tab.

Deploying packages: Multiple system, multiple user model
In this model, a user creates the package from assets on one IBM InfoSphere
DataStage and QualityStage system, while another user deploys the package to a
separate DataStage and QualityStage system.

About this task

There are two stages in this package and deploy model: one to create and build the
package on the source system, and one to copy the package file to the target
system and deploy it.

To create and build the package on the source system:
1. Connect to the domain that represents the source DataStage and QualityStage

system.
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2. Create a package from assets on the source DataStage and QualityStage system,
and build the package.

3. In the Package window, click Send in the top right corner.
4. In the Save As dialog, browse to a location to save the package file to.

To deploy a package to a separate target DataStage and QualityStage system:
1. Copy the package file to a directory on the target system.
2. Connect to the domain that represents the target DataStage and QualityStage

system.
3. In the Repository view, right-click the domain representing the target system

and select Deploy Package From > File. Browse for the package file to deploy
and click Open to open selected package file in the Package window.

4. Click Deploy to open the Deploy Package dialog. Select the target project and
the build that you want to deploy and click OK. The package contents are
deployed to the target project.

5. To view the package build and deployment history, click the History tab.
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Chapter 4. Importing and exporting assets

You can use the IBM InfoSphere Information Server Manager to export or import
IBM InfoSphere DataStage and QualityStage assets.

You can move assets between projects without having to perform a full
deployment. This movement is useful in cases where there is a subset of project
assets that must be populated in a secondary environment. Importing and
exporting assets in this way is like creating a .dsx file from the InfoSphere
DataStage and QualityStage Designer client.

Exporting assets
You can use the IBM InfoSphere Information Server Manager to export assets to an
archive file.

About this task

Use the InfoSphere Information Server Manager to export assets to an archive file.
The archive file is stored on the Microsoft Windows computer on which the
InfoSphere Information Server Manager is running. You can then import the assets
in the archive file to any project that you can connect to by using the InfoSphere
Information Server Manager.

Important: If you use InfoSphere Information Server Manager to export a job
design (.isx file), export the design time information and the runtime information
separately.

If you export the design time information and the runtime information together in
the .isx file, you cannot import these components separately. You must import the
full contents of the .isx file.

Additionally, if you import the .isx file into a project where the runtime
information already exists, the existing runtime information is lost.

Procedure
1. Connect to the domain that represents the InfoSphere DataStage and

QualityStage system containing the assets you want to export.
2. Right-click the project or any assets in that project that you want to export, and

then select Export to open the Export Archive window. You can drag additional
assets into the Export Archive window.

3. If required, click the Options tab and specify that executables, designs, and
dependent items are to be included in the export.

4. When your list is complete, click Export.
5. In the Export dialog, specify the target location for the archive file.
6. Click Save.

Importing assets
You can use the IBM InfoSphere Information Server Manager to import assets to a
specific project.
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About this task

You can import all the assets from an archive file to which the assets have
previously been exported.

When you import assets, the folder structure matches the hierarchy of the assets in
the metadata repository view. You can select the parent folder where the imported
folder structure is created, but you cannot create your own folder structure.

Important: If you use InfoSphere Information Server Manager to export a job
design (.isx file), export the design time information and the runtime information
separately.

If you export the design time information and the runtime information together in
the .isx file, you cannot import these components separately. You must import the
full contents of the .isx file.

Additionally, if you import the .isx file into a project where the runtime
information already exists, the existing runtime information is lost.

Procedure
1. Right-click the domain that contains the project to which you want to import

the assets and click Import.
2. Browse for a file to import in the Select file to import dialog. Click Open to

open the Import Archive window and view details of the assets that the archive
file contains.

3. Click Import to open the Import dialog.
4. Select the target project and set the option to replace any existing items.
5. Click OK to import the assets to the specified target project.

Viewing the log
View the logs from IBM InfoSphere Information Server Manager from the log view
in the InfoSphere Information Server.

The Web-based log view that tracks InfoSphere Information Server activity shows
complete manager log entries, including timestamps and any related messages.

To view the import and export logs:
1. In the InfoSphere Information Server Web console, click the Administration

tab.
2. In the Administration tab, go to Log management.
3. Click Log views. You then have the option to view import, export, and

deployment logs.
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Chapter 5. Source control of InfoSphere DataStage and
QualityStage assets

You can use the IBM InfoSphere Information Server Manager deployment tool to
manage your IBM InfoSphere DataStage and QualityStage jobs and associated
assets in your source control system.

The deployment tool gives you direct access to these source control systems:
Concurrent Versions System (CVS), IBM Rational ClearCase®, and IBM Rational
Team Concert™.

In a typical DataStage and QualityStage development environment, multiple
developers connect to the same InfoSphere Information Server system, and so to
the same metadata repository. Each developer works on their own Windows
computer that has the InfoSphere DataStage and QualityStage clients installed. If
developers want to submit the assets they develop to the source control system,
they can install the deployment tool on the same computer as these clients.

The deployment tool uses an Eclipse workspace, referred to as the source control
workspace, as a local transfer area for assets being submitted to the source control
system.

Submitting an asset from the metadata repository to your source control system is
a two-step process:
1. You send the asset to the source control workspace. The deployment tool

creates an archive file from the asset, then writes the archive file to the source
control workspace.

2. You send the artifact to the source control system. The deployment tool submits
the asset archive, known as an artifact, to the source control repository.

Restoring an asset in the metadata repository from the version in the source
control repository is a two-step process:
1. You replace the artifact in the source control workspace. The deployment tool

retrieves the asset archive, known as an artifact, from the source control
repository.

2. You replace the asset in the metadata repository. The deployment tool imports
the artifact from the source control project as an asset in the metadata
repository.

The conceptual relationship between the metadata repository, the deployment tool,
and the source control repository is illustrated in the following figure:
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Installing Rational ClearCase
Install IBM Rational® ClearCase into the IBM InfoSphere Information Server
Manager to be used as your source control system.

About this task

The Rational ClearCase Remote Client for Eclipse enables you to use Rational
ClearCase as a team services provider when working in the Eclipse workbench
environment. For more information about Rational ClearCase Remote Client for
Eclipse, see About the Rational ClearCase Remote Client for Eclipse.

Install Rational ClearCase Remote Client for Eclipse on the Windows computer of
every developer who wants to submit the assets they develop to the source control
system.

Procedure
1. Start the InfoSphere Information Server Manager.
2. Click Help > Install New Software.
3. Enter the Web address of your ClearCase Web Server, and press Enter. For

example, http://computername/ccrc/update, where computername is your
ClearCase Web Server. Wait for a few seconds while the list of features to
install is refreshed.

Figure 5. Relationship between metadata repository, InfoSphere Information Server Manager, and source control
repository
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4. Expand Rational ClearCase Remote Client, and ensure that Rational
ClearCase Remote Client for Eclipse is the only selected feature. Click Next.

5. Read and accept the license agreement. Click Next.
6. Click Finish to download the Rational ClearCase Remote Client for Eclipse

feature.
7. Click Install to install the Rational ClearCase Remote Client for Eclipse feature.
8. Click Yes to restart the InfoSphere Information Server Manager.

Installing Rational Team Concert
Install IBMRational Team Concert into the IBM InfoSphere Information Server
Manager to be used as your source control system.

About this task

The Rational Team Concert Client for Eclipse enables you to use Rational Team
Concert as a team services provider when working in the Eclipse workbench
environment. For more information about Rational Team Concert Client for Eclipse,
see Rational Team Concert.

Install Rational Team Concert Client for Eclipse on the Windows computer of every
developer who wants to submit the assets they develop to the source control
system.

Procedure
1. Download the Rational Team Concert Client 3.0.x p2 Install Repository from the

Rational Team Concert website.
2. Extract the compressed file to an empty directory.
3. Start the InfoSphere Information Server Manager.
4. Click Help > Install New Software.
5. Add the directory you extracted the compressed file into as a repository.

a. Click Add.
b. Click Local.
c. Select the directory you extracted the compressed file into, and click OK.
d. Click OK.

6. Select the Rational Team Concert Client Feature, and click Next.
7. Read and accept the license agreement. Click Finish to install the Rational

Team Concert Client for Eclipse.
8. Click Restart Now to restart the InfoSphere Information Server Manager.

Basic source-control scenario for jobs and associated assets
This basic source-control scenario illustrates how you use the IBM InfoSphere
Information Server Manager for source control of your IBM InfoSphere DataStage
and QualityStage assets.

In this scenario, you submit an InfoSphere DataStage job to the IBM Rational
ClearCase source control system. Later, you want to change the job design, and so
you change the design in the Designer client, and check the changed job back in.
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Typically, you deal with more complex source control scenarios. This scenario
illustrates the basic workflow of using the InfoSphere Information Server Manager
for source control.

By default, executable files are included inside the archives that are sent to source
control when you use the Send to Source Control Workspace command in this
scenario. If you do not want to include executable files in your artifacts for source
control, you must disable this option in the Source Control section of your client
preferences.

The following steps describe the basic scenario:
1. The InfoSphere Information Server Manager gives you a view of your IBM

InfoSphere DataStage project in the metadata repository. Browse the metadata
repository to locate the job that you want to submit to the source control
system.

2. In the InfoSphere Information Server Manager, select the job in the Repository
tab, and select Send to Source Control Workspace. A file that contains the job
is created in the source control project, ready to submit to Rational ClearCase.
The file is a compressed archive file.

3. Rational ClearCase detects a new file in the source control project and opens
the Add Resources to Source Control window. Click Apply in this window to
add your job to Rational ClearCase. The icon representing this job in the
InfoSphere Information Server Manager Repository tab changes to show that
the job is now under source control.

4. You decide to change the job design.
5. In the Designer client, open your job, make the required changes, and save the

job.
6. In the InfoSphere Information Server Manager, select the job in the Repository

tab. Click Send to Source Control Workspace to update the archive file that
contains your job in the source control project. Rational ClearCase detects the
updated file which is checked-out automatically.

7. Select Team > Check In to check the archive file that contains your job back
into Rational ClearCase.
The Eclipse Team menu gives you direct access to the Rational ClearCase menu
items from within the InfoSphere Information Server Manager.

The scenario is similar for whatever source control system that you use, although
there might be some minor operational differences.

If you have selected the Auto check-in local changes preference in IBM Rational
Team Concert, clicking Send to Source Control Workspace also updates your
Rational Team Concert repository. Click Team > Deliver to make your changes
available to other rational Team Concert users.

CVS does not have the concept of checking assets in and out, but rather you
commit assets to CVS. Also, CVS does not automatically detect when an artifact is
added to the source control project.

This scenario illustrates some important considerations about using the InfoSphere
Information Server Manager for source control:
v You submit a file containing the assets that you want to control to the source

control system, not the assets themselves.
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v There is no lock that is put on the assets in the metadata repository. The assets
can be edited outside of the control of the source control system. You must put
your own process in place to prevent assets becoming out of step with their
controlled version.

v You can use the source control system directly from within the InfoSphere
Information Server Manager. You access menus and windows that belong to the
source control system by using Team menus.

Navigating assets and their annotations
The IBM InfoSphere Information Server Manager provides a view of assets in the
metadata repository, and a view of artifacts in the source control workspace. The
assets and artifacts are shown with annotations to show their source control status.

Procedure
1. Open the Repository tab in the InfoSphere Information Server Manager by

selecting Home from the home menu .
2. From the domain connection at the top of the tree, you can view the InfoSphere

Information Server engine tiers that connect to the services tier that is
represented by the domain.

3. Under each engine tier, see the InfoSphere projects that exist on that engine tier.
4. Open each project to view the folders and assets that the project contains. The

assets that are submitted to the source control system are marked with
annotations.

5. Open the Workspace tab for the source control by clicking Window > Show
View > Source Control Workspace. The Workspace tab shows the artifacts after
the assets are sent to the source control project. The artifact annotation shows
whether an artifact has been submitted to the source control system.

6. Optional: Open views and perspectives that are associated with your source
control system from within the InfoSphere Information Server Manager. Source
control views and perspectives are available from the Window menu, and from

the home menu when the Workspace tab is open.

Configuring source control for the InfoSphere Information Server
Manager

An administrator must perform some configuration tasks before you can use IBM
InfoSphere Information Server Manager to submit IBM InfoSphere DataStage and
QualityStage assets to a source control system. To enable source control, you must
configure the InfoSphere Information Server Manager.

Before you begin

You must be an Administrator on the computer where the InfoSphere Information
Server Manager is installed.

If a user without administrator privileges wants to use the InfoSphere Information
Server Manager to submit assets to the source control system, then the user must
import the source control project that is created and shared by the administrator
into their InfoSphere Information Server Manager workspace.
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About this task

The configuration tasks are the same regardless of which source control system
you use to control assets. The InfoSphere Information Server Manager uses a
source control project to share assets with your source control system. This project
is different from IBM InfoSphere DataStage and QualityStage projects.

Procedure
1. Connect to an IBM InfoSphere Information Server domain.
2. Create a source control project that has the same name as that domain.
3. Share the source control project under your chosen source code control system.
4. When you share the project, the project itself is submitted to the source control

repository.

Creating source control projects
You must create a source control project and share it in the source control system.

Before you begin

Before you can create and share a source control project, you must first connect to
the required domain. The domain gives you access to the metadata repository that
contains the IBM InfoSphere DataStage and QualityStage assets that you want to
control.

You must have the Suite Administrator role to create a source control project.

About this task

The source control project is the staging area between the InfoSphere Information
Server Manager and the source control system. When you create the source control
project, you create a link between the metadata repository and the source control
system.

When you have assets in different metadata repositories on different domains, you
create a separate source control project for each domain.

Procedure
1. In the Repository view of the InfoSphere Information Server Manager, select the

domain that you want to create a source control project for.
2. Right-click the selected domain, and click Integrate Source Control from the

pop-up menu.
3. Select Share project under source control after successful project creation to

automatically launch the share project procedure after the source control project
is created.

4. Click OK to create the source control project.

Sharing source control projects
After you create a source control project, you must share it on your source control
system.

Before you begin

You must first create a source control project.
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Procedure
1. To open the Share Project window, if you did not select Share project under

source control after successful project creation, do the following steps:
a. In the Repository tab of the InfoSphere Information Server Manager, select

the domain that you want to share a source control project for.
b. Right-click the selected domain, and click Team > Share Project from the

pop-up menu.
2. Follow the prompts to share the project. The exact steps that you do are specific

to the source control system.

Importing source control projects to your workspace
Before you can submit assets to source code control, you must import the source
control project into your own source control workspace in IBM InfoSphere
Information Server Manager.

Before you begin

An administrator must have created a source control project and shared it under
source control.

About this task

The source control project in your source control workspace is used as a local
transfer area for assets being submitted to the source control system.

Procedure
1. Click Window > Show View > Source Control Workspace.
2. To import the source control project from CVS into your source control

workspace, right-click in the Source Control view and click Import.
3. To import the source control project from IBM Rational ClearCase into your

source control workspace:
a. Click Window > Open Perspective > Other > ClearCase.
b. Navigate to the source control project in the ClearCase Navigator window.
c. Right-click on the project and click Import > Import Project into

Workspace.
4. To import the source control project from IBM Rational Team Concert into your

source control workspace:
a. Right-click in the Pending Changes view, and click Create a new repository

workspace.
b. Select the stream that contains the source control project, and click Next.
c. Enter a name and description for the repository workspace, and click Next.
d. Select Use current repository, and click Next.
e. Set the Read Access Premission, and click Next.
f. Clear the Load repository workspace after creation option, and click Finish.

The repository workspace is created.
g. On the Team Artifacts view, right-click the new repository workspace and

click Load.
h. Select Find and load Eclipse projects, and click Next.
i. Select the source control project, select the sandbox, and click Finish. The

repository workspace is loaded into the source control workspace.
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Providing source control for assets
You can use the CVS or IBM Rational ClearCase source control systems for source
control of your IBM InfoSphere DataStage and QualityStage design assets.

Before you begin

When several developers work with the same InfoSphere DataStage and
QualityStage system and submit assets to the source control system, you must
synchronize your source control project to ensure that it is up-to-date with the
source control repository.

About this task

You use the InfoSphere Information Server Manager for source control of design
assets.

Submitting assets to a source control system
You can use the IBM InfoSphere Information Server Manager to submit your IBM
InfoSphere DataStage and QualityStage assets to a source control system.

Before you begin

By default, executable files are included inside the archives that are sent to source
control when you use the Send to Source Control Workspace command. If you do
not want to include executable files in your artifacts for source control, you must
disable this option in the Source Control section of your client preferences.

Procedure
1. In the Repository view, select the asset that you want to submit to source

control.
2. Right-click the asset, and click Send to Source Control Workspace. This action

creates an archive version of the asset, known as an artifact, and writes that
artifact to the source control project.

3. Right-click the asset again, and click the Team command to commit the artifact
to the source control system. (The exact command depends on the type of the
source control system.)

Updating assets in source control
When you update an IBM InfoSphere DataStage and QualityStage asset, you must
also upgrade the version in the source control system. You can update an asset in
the source control system by using the Repository view.

Before you begin

By default, executable files are included inside the archives that are sent to source
control when you use the Send to Source Control Workspace command. If you do
not want to include executable files in your artifacts for source control, you must
disable this option in the Source Control section of your client preferences.

Procedure
1. Select the asset that you updated in IBM InfoSphere DataStage.
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2. If you are using the Repository view, right-click the asset, and click Send to
Source Control Workspace. This action sends an updated archive file of the
asset to the source control project.

3. If you are using the Source Control Workplace view, right-click the asset, and
click Replace From Metadata Repository. This action sends an updated archive
file of the asset to the source control project.

4. Right-click the asset again, and click Team to send the artifact created from the
asset to the source control system. The exact command depends on the type of
source control system.

Restoring assets from the source control system
You might need to restore an asset from the source control system to overwrite the
version in the metadata repository.

About this task

You might want to restore an asset from the equivalent artifact in the source
control system (if, for example, your metadata repository is damaged).
Alternatively you might want to restore an asset from an earlier version in the
source control system or from a different branch in the source control system.

Restored assets are placed in a folder structure that matches the hierarchy of the
assets in the metadata repository view.

Procedure
1. Select the asset that you want to restore.
2. If you are using the Repository view, right-click the asset, and click Replace

with to select whether you want to replace the asset with the equivalent artifact
or with an artifact from an alternative branch or version. If you choose to
replace from another branch or version, an additional window opens to enable
you to specify details. The Replace with action copies the selected artifact to
the source control project.

3. If you are using the Source Control Workplace view, right-click the asset, and
click Replace with to select whether you want to replace the asset with the
equivalent artifact or with an artifact from an alternative branch or version. The
Replace with action copies the selected artifact to the source control project.

4. If you are using IBM Rational Team Concert, there are two other ways to
restore an asset.
v Restoring an asset on the History view:

a. Right-click the asset, and click Team > Show History.
b. Right-click the change set to be restored, and click Load.

v Reversing a change set on the History view:
a. Right-click the asset, and click Team > Show History.
b. Optionally, right-click the change set to be restored, and click Open In

Change Explorer to verify the contents of the change set.
c. In the History view, right-click the change set to be restored, and click

Reverse. A patch, known as a reverse change set is added to the Pending
Changes view.

d. Right-click the reverse change set, and click Merge into Workspace.

5. Right-click the asset again, and click Replace from Source Control Workspace
to import the artifact from the source control project as an asset in the metadata
repository.
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Locking and unlocking artifacts
If you are using IBM Rational Team Connect, you can lock and unlock artifacts.

Procedure
1. Open the Repository view.
2. To lock an artifact, right-click the artifact and click Team > Lock. The artifact is

locked in the Rational Team Concert repository.
3. To unlock an artifact, right-click the artifact and click Team > Unock. The

artifact is unlocked in the Rational Team Concert repository.

Clearing a source control workspace
If you are using IBMRational Team Connect, you can clear your source control
workspace.

Procedure
1. Open the Pending Changes view.
2. Right-click the repository workspace and click Unload. The source control

workspace is cleared, and the Repository view no longer shows any source
control icons.
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Appendix A. Product accessibility

You can get information about the accessibility status of IBM products.

The IBM InfoSphere Information Server product modules and user interfaces are
not fully accessible.

For information about the accessibility status of IBM products, see the IBM product
accessibility information at http://www.ibm.com/able/product_accessibility/
index.html.

Accessible documentation

Accessible documentation for InfoSphere Information Server products is provided
in IBM Knowledge Center. IBM Knowledge Center presents the documentation in
XHTML 1.0 format, which is viewable in most web browsers. Because IBM
Knowledge Center uses XHTML, you can set display preferences in your browser.
This also allows you to use screen readers and other assistive technologies to
access the documentation.

The documentation that is in IBM Knowledge Center is also provided in PDF files,
which are not fully accessible.

IBM and accessibility

See the IBM Human Ability and Accessibility Center for more information about
the commitment that IBM has to accessibility.
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Appendix B. Contacting IBM

You can contact IBM for customer support, software services, product information,
and general information. You also can provide feedback to IBM about products
and documentation.

The following table lists resources for customer support, software services, training,
and product and solutions information.

Table 1. IBM resources

Resource Description and location

IBM Support Portal You can customize support information by
choosing the products and the topics that
interest you at www.ibm.com/support/
entry/portal/Software/
Information_Management/
InfoSphere_Information_Server

Software services You can find information about software, IT,
and business consulting services, on the
solutions site at www.ibm.com/
businesssolutions/

My IBM You can manage links to IBM Web sites and
information that meet your specific technical
support needs by creating an account on the
My IBM site at www.ibm.com/account/

Training and certification You can learn about technical training and
education services designed for individuals,
companies, and public organizations to
acquire, maintain, and optimize their IT
skills at http://www.ibm.com/training

IBM representatives You can contact an IBM representative to
learn about solutions at
www.ibm.com/connect/ibm/us/en/
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Appendix C. Accessing the product documentation

Documentation is provided in a variety of formats: in the online IBM Knowledge
Center, in an optional locally installed information center, and as PDF books. You
can access the online or locally installed help directly from the product client
interfaces.

IBM Knowledge Center is the best place to find the most up-to-date information
for InfoSphere Information Server. IBM Knowledge Center contains help for most
of the product interfaces, as well as complete documentation for all the product
modules in the suite. You can open IBM Knowledge Center from the installed
product or from a web browser.

Accessing IBM Knowledge Center

There are various ways to access the online documentation:
v Click the Help link in the upper right of the client interface.
v Press the F1 key. The F1 key typically opens the topic that describes the current

context of the client interface.

Note: The F1 key does not work in web clients.
v Type the address in a web browser, for example, when you are not logged in to

the product.
Enter the following address to access all versions of InfoSphere Information
Server documentation:
http://www.ibm.com/support/knowledgecenter/SSZJPZ/

If you want to access a particular topic, specify the version number with the
product identifier, the documentation plug-in name, and the topic path in the
URL. For example, the URL for the 11.3 version of this topic is as follows. (The
⇒ symbol indicates a line continuation):
http://www.ibm.com/support/knowledgecenter/SSZJPZ_11.3.0/⇒
com.ibm.swg.im.iis.common.doc/common/accessingiidoc.html

Tip:

The knowledge center has a short URL as well:
http://ibm.biz/knowctr

To specify a short URL to a specific product page, version, or topic, use a hash
character (#) between the short URL and the product identifier. For example, the
short URL to all the InfoSphere Information Server documentation is the
following URL:
http://ibm.biz/knowctr#SSZJPZ/

And, the short URL to the topic above to create a slightly shorter URL is the
following URL (The ⇒ symbol indicates a line continuation):
http://ibm.biz/knowctr#SSZJPZ_11.3.0/com.ibm.swg.im.iis.common.doc/⇒
common/accessingiidoc.html
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Changing help links to refer to locally installed documentation

IBM Knowledge Center contains the most up-to-date version of the documentation.
However, you can install a local version of the documentation as an information
center and configure your help links to point to it. A local information center is
useful if your enterprise does not provide access to the internet.

Use the installation instructions that come with the information center installation
package to install it on the computer of your choice. After you install and start the
information center, you can use the iisAdmin command on the services tier
computer to change the documentation location that the product F1 and help links
refer to. (The ⇒ symbol indicates a line continuation):

Windows
IS_install_path\ASBServer\bin\iisAdmin.bat -set -key ⇒
com.ibm.iis.infocenter.url -value http://<host>:<port>/help/topic/

AIX® Linux
IS_install_path/ASBServer/bin/iisAdmin.sh -set -key ⇒
com.ibm.iis.infocenter.url -value http://<host>:<port>/help/topic/

Where <host> is the name of the computer where the information center is
installed and <port> is the port number for the information center. The default port
number is 8888. For example, on a computer named server1.example.com that uses
the default port, the URL value would be http://server1.example.com:8888/help/
topic/.

Obtaining PDF and hardcopy documentation
v The PDF file books are available online and can be accessed from this support

document: https://www.ibm.com/support/docview.wss?uid=swg27008803
&wv=1.

v You can also order IBM publications in hardcopy format online or through your
local IBM representative. To order publications online, go to the IBM
Publications Center at http://www.ibm.com/e-business/linkweb/publications/
servlet/pbi.wss.
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Appendix D. Providing feedback on the product
documentation

You can provide helpful feedback regarding IBM documentation.

Your feedback helps IBM to provide quality information. You can use any of the
following methods to provide comments:
v To provide a comment about a topic in IBM Knowledge Center that is hosted on

the IBM website, sign in and add a comment by clicking Add Comment button
at the bottom of the topic. Comments submitted this way are viewable by the
public.

v To send a comment about the topic in IBM Knowledge Center to IBM that is not
viewable by anyone else, sign in and click the Feedback link at the bottom of
IBM Knowledge Center.

v Send your comments by using the online readers' comment form at
www.ibm.com/software/awdtools/rcf/.

v Send your comments by e-mail to comments@us.ibm.com. Include the name of
the product, the version number of the product, and the name and part number
of the information (if applicable). If you are commenting on specific text, include
the location of the text (for example, a title, a table number, or a page number).
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Notices and trademarks

This information was developed for products and services offered in the U.S.A.
This material may be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

Notices

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003 U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:
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This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp.
Sample Programs. © Copyright IBM Corp. _enter the year or years_. All rights
reserved.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Privacy policy considerations

IBM Software products, including software as a service solutions, (“Software
Offerings”) may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user or for other purposes. In many cases no personally identifiable
information is collected by the Software Offerings. Some of our Software Offerings
can help enable you to collect personally identifiable information. If this Software
Offering uses cookies to collect personally identifiable information, specific
information about this offering’s use of cookies is set forth below.

Depending upon the configurations deployed, this Software Offering may use
session or persistent cookies. If a product or component is not listed, that product
or component does not use cookies.

Table 2. Use of cookies by InfoSphere Information Server products and components

Product module
Component or
feature

Type of cookie
that is used Collect this data Purpose of data

Disabling the
cookies

Any (part of
InfoSphere
Information
Server
installation)

InfoSphere
Information
Server web
console

v Session

v Persistent

User name v Session
management

v Authentication

Cannot be
disabled

Any (part of
InfoSphere
Information
Server
installation)

InfoSphere
Metadata Asset
Manager

v Session

v Persistent

No personally
identifiable
information

v Session
management

v Authentication

v Enhanced user
usability

v Single sign-on
configuration

Cannot be
disabled
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Table 2. Use of cookies by InfoSphere Information Server products and components (continued)

Product module
Component or
feature

Type of cookie
that is used Collect this data Purpose of data

Disabling the
cookies

InfoSphere
DataStage

Big Data File
stage

v Session

v Persistent

v User name

v Digital
signature

v Session ID

v Session
management

v Authentication

v Single sign-on
configuration

Cannot be
disabled

InfoSphere
DataStage

XML stage Session Internal
identifiers

v Session
management

v Authentication

Cannot be
disabled

InfoSphere
DataStage

IBM InfoSphere
DataStage and
QualityStage
Operations
Console

Session No personally
identifiable
information

v Session
management

v Authentication

Cannot be
disabled

InfoSphere Data
Click

InfoSphere
Information
Server web
console

v Session

v Persistent

User name v Session
management

v Authentication

Cannot be
disabled

InfoSphere Data
Quality Console

Session No personally
identifiable
information

v Session
management

v Authentication

v Single sign-on
configuration

Cannot be
disabled

InfoSphere
QualityStage
Standardization
Rules Designer

InfoSphere
Information
Server web
console

v Session

v Persistent

User name v Session
management

v Authentication

Cannot be
disabled

InfoSphere
Information
Governance
Catalog

v Session

v Persistent

v User name

v Internal
identifiers

v State of the tree

v Session
management

v Authentication

v Single sign-on
configuration

Cannot be
disabled

InfoSphere
Information
Analyzer

Data Rules stage
in the InfoSphere
DataStage and
QualityStage
Designer client

Session Session ID Session
management

Cannot be
disabled

If the configurations deployed for this Software Offering provide you as customer
the ability to collect personally identifiable information from end users via cookies
and other technologies, you should seek your own legal advice about any laws
applicable to such data collection, including any requirements for notice and
consent.

For more information about the use of various technologies, including cookies, for
these purposes, see IBM’s Privacy Policy at http://www.ibm.com/privacy and
IBM’s Online Privacy Statement at http://www.ibm.com/privacy/details the
section entitled “Cookies, Web Beacons and Other Technologies” and the “IBM
Software Products and Software-as-a-Service Privacy Statement” at
http://www.ibm.com/software/info/product-privacy.
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Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at www.ibm.com/legal/
copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:

Adobe is a registered trademark of Adobe Systems Incorporated in the United
States, and/or other countries.

Intel and Itanium are trademarks or registered trademarks of Intel Corporation or
its subsidiaries in the United States and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.

Microsoft, Windows and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

The United States Postal Service owns the following trademarks: CASS, CASS
Certified, DPV, LACSLink, ZIP, ZIP + 4, ZIP Code, Post Office, Postal Service, USPS
and United States Postal Service. IBM Corporation is a non-exclusive DPV and
LACSLink licensee of the United States Postal Service.

Other company, product or service names may be trademarks or service marks of
others.
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