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Purpose

The purpose of this document is to provide detailed usage of the core Utilities. Utilities
are building blocks of functionality that, in some cases, provide a wrapper on top of the
TIBCO® Data Virtualization APl and in other cases simply encapsulate a capability
deemed to be repeatable and useful.

This document covers the following topics:
e Advanced Services (AS) Assets Utilities Overview - Describes the history and use
of the AS Assets Utilities distribution.
e Extending and/or Contributing to the AS Assets Utilities distribution.

Audience

This document is intended to provide guidance for the following users:
e Developers

References

Product references are shown below. Any references to CIS or DV refer to the current
TIBCO® Data Virtualization.

e TIBCO® Data Virtualization was formerly known as
o Cisco Data Virtualization (DV)

o Composite Information Server (CIS)
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What are the AS Assets Utilities?

The AS Assets Utilities, or simply "The Ultilities", were started as an internal project to collect the
ever-increasing number of simple SQL Scripts and custom Java procedures (CJPs) that ended up
being reusable at multiple customer sites. Rather than reinvent the wheel at each customer, it
was proposed that these simple procedures should be gathered and made available to all
customers free of charge as an open source offering.

The Utilities are made up of a number of procedures that perform relatively simple tasks, such as
string, date/time, and XML manipulation; interactions with the CIS repository or CIS host
filesystem; and helpers for working with another AS Asset known as "PDTool".

These procedures are not intended to be full custom solutions (though many end up being used
in such solutions) but are simple timesavers that make the life of a CIS developer easier.

Recommended Development Tools

CIS itself can (and should) be used for developing the SQL Script procedures. Any robust Java
IDE can be used to develop the CJPs, however up to this point, the CJP's have been developed
using Eclipse. The CJP artifacts in the open source repository (GitHub) are therefore geared
towards an Eclipse project.

Git is used as the version control system for the Utilities open source project. For those new to
Git, a visit to https://help.github.com/articles/set-up-qgit will provide an overview of Git and
instructions on downloading and setting up the basic Git tools.
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How Can | Download a Copy of the Utilities GitHub Repository?

The GitHub master repository for the Utilities is located at
https://github.com/TIBCOSoftware/ASAssets Utilities.

Repository Folder Structure

The folder structure of the GitHub repository contains CIS source, custom Java source,
documentation source, and distribution resources.

DocumentationSource

This folder contains the source versions of the user's guide and developer's guide (this document)
in Microsoft Word format. When a release version of a document is ready for distribution, it should
be saved in PDF format and placed in the Release folder.

DVSource
This folder contains the source code for the Utilities DV resources.

DVSource/cis_objects

This folder contains the exported CIS resources in the version control export format. Instead of a
single .CAR file, the resources are exported in a folder tree structure that matches the container
structure in CIS. A .CMF file named for the resource with a resource type suffix contains the
resource's source code, model, ownership information, annotation, permissions, etc. A container
will have a corresponding .CMF file contained inside it.

DVSource/scripts

This folder will contain (still in development) a number of Windows batch files and Linux shell
scripts that can be used to import the resources in the cis_objects folder into a CIS instance and
export resources from a CIS instance into the cis_objects folder structure.

JavaSource

This folder contains the source code for the Utilities DV resources. It contains an Eclipse project
that can be used to build individual CJP data source jars or all of them in one build. Each CJP
collection has a child folder here.

JavaSource/lib
This folder contains library jar files used to build the CJP jars. Open source libraries have
corresponding LICENSE .txt files. CIS libraries are named with a "cs" prefix.

Release
This folder contains the current release of the Utilities and corresponding documentation.

Release/archive
This folder contains past releases of the Utilities and corresponding documentation.
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Checking Out the AS Utilities DV Source Code

TBD. For now, the best way to make sure a new or updated SQL Script gets into the next release
is to send the script (plus documentation and examples!) in a CAR file to Mike Tinius.

Configure Eclipse Variables
There are two variables that need to be created. One is for Eclipse and one is for Ant.

Create DV HOME for Eclipse.

In Eclipse, select Window > Preferences > Java > Build Path > Classpath Variables > New

Enter Name: DV_HOME

Path: Browse to your data virtualization home folder

& New Variable Entry

Name: | DV_HOME

Path: | C:/MySW/CIST.0.5

OK

@ Preferences

type filter text

General
Ant
Help
Install/Update
v Java
Appearance
v Build Path
Classpath Variables
User Libraries
Code Style
Compiler
Debug
Editor
Installed JREs
JUnit
Properties Files Editor
Maven
Mylyn
Plug-in Development
Run/Debug
Team
Validation
XML

)

Classpath Variables

A classpath variable can be added to a project's class path. It can be used to define the location of a JAR file
that isn't part of the workspace. Non modifiable classpath variables are set internally (for example, JRE_LIB,

JRE_SRC, and JRE_SRCROOT depend on the JRE setting).
Defined classpath variables:

(= DV_HOME - C:\MySW\CIS7.0.5
(= ECLIPSE_HOME (non modifiable) - C:\MySW\eclipseGit

lﬁJRE_SRCROOT (non modifiable, deprecated) - (empty)

(= M2_REPO (non modifiable) - C:\Users\mtinius\.m2\repository

(s JRE_LIB (non modifiable, deprecated) - C:\Program Files\Java\jdk1.8.0_152\jre\lib\rt jar
(56 JRE_SRC (non modifiable, deprecated) - C:\Program Files\Java\jdk1.8.0_152\src.zip

(2 JUNIT_HOME (non modifiable, deprecated) - C:\MySW\eclipseGit\plugins\org.junit_4.
(=& JUNIT_SRC_HOME (non modifiable, deprecated) - C:\MySWheclipseGit\plugins\org.jut

| New... I

Edit...

Remove

OK

Cancel




Create DV _HOME for Ant.

In Eclipse, select Window > Preferences > Ant > Runtime > Properties > Add Property

Enter Name: DV_HOME

Path: Locate your data virtualization home folder and type it or copy and paste it.

& Edit User Property

Name: | DV_HOME

Value: | C:\MySWACIS7.0.5

Variables...

Cancel

& Preferences [m] X
type filter text Runtime =4 v v
> General Settings used when running Ant buildfiles:
v Ant ) — -
> Editor % Classpath ¥ Tasks <> Types <0” Properties
Runtime Global properties:
> Help v i Add P
> Install/Update Name Value Contributor roperty...
> Java <@ DV__HOME C:\MySW\CIS_7.0.S _ . Edit Property...
> Maven @ eclipse.home C:\MySWheclipseGit org.eclipse.ant.core
> Mylyn <0” eclipse.pdebuild.h... /C:/MySW/eclipseGit/plugin...  org.eclipse.pde.build Remove
> Plug-in Development <0’ eclipse.pdebuild.s... /C:/MySW/eclipseGit/plugin...  org.eclipse.pde.build
v Run/Debug <0”eclipse.pdebuild.t... /C:/MySW/eclipseGit/plugin...  org.eclipse.pde.build
Console @ eclipse.running true org.eclipse.ant.core
External Tools
» Launching
Perspectives
String Substitution
View Management Global property files:
> Team 5
Validation G
> XML Add Bxternal...
Remove
Restore Defaults Apply
@ OK Cancel




Checking Out the AS Utilities Project

CJPs for the AS Utilities are currently developed in Eclipse. These instructions are based on the
Luna distribution of Eclipse (if not using this release then the following steps may need to be
modified. For instance, Luna includes the Git client, whereas earlier releases of Eclipse do not.) If
installing Eclipse for the first time, the "Eclipse Standard" (or "Eclipse IDE for Java Developers", if
space is tight) should be used.

Clone the AS Utilities Git repository to your local machine
For the next steps, start Eclipse and make sure to apply any updates (Help -> Check for
Updates).

1. Open the Git perspective using the "Open Perspective" panel in the upper right of the
Eclipse screen:

(S
k Access :
it 572 =A

2. Choose the Git perspective:

s S
@ Open Perspective o>

Bacvs Repository Exploring a
(35 Database Debug
({3 Database Development
%5 Debug
|2k Git
@;’Java
S\JJava Browsing
7 Java EE (default) =
TgJJava Type Hierarchy
%’JavaScript

& JPA

') Planning
<J=Plug-in Development
EHRemote System Explorer
{5 Resource
£9Team Synchronizing
G& Web

[ ok J[ cance |

3. Inthe "Git Repositories" panel, click the "Clone a Git repository" link. Alternatively, go to
the "File" menu and select "New"->"Other..." Choose "Git"->"Git Repository" from the
resulting dialog.

4. In the resulting dialog, paste the Git repository URL
https://github.com/TIBCOSoftware/ASAssets_Ultilities.git into the "URI" field. The
"Host" and "Repository Path" fields should auto-populate. Enter your Git user name and
password and click "Next >".
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& Clone Git Repository

Source Git Repository

Enter the location of the source repository.

Location
URI: “[ https:/github.com/TIBCOSoftware/ASAssets_Utilities.gi] | 'Local File...|
Host: I github.com I

Repository path: | /TIBCOSoftware/ASAssets_Utilities.git

Connection

Protocol: l https v l

Authentication
User: I mtinius |
Password: | ssscssce |

[ Store in Secure Store

@ < Back Next > Finish

Cancel

5. The "Branch Selection" screen should show one branch called "master". This should
already be selected so click "Next >".

% Clone Git Repository

Branch Selection

Select branches to clone from remote repository. Remote tracking branches will be

created to track updates for these branches in the remote repository.

O X

GIT
=

Branches of https://github.com/TIBCOSoftware/ASAssets_Utilities.git:
type filter text

[ 25 master

Select Al

@ [ <Back | Net> Finish

Cancel




6. Choose the location where the downloaded source code should be stored. Click "Finish".

& Clone Git Repository m} X
Local Destination GIT
Configure the local storage location for ASAssets_Utilities. ;“ ‘ 4
Destination
Directory: C:\MyFiles\git\ASAssets_GIT_Repo\ASAssets_Utilities I
Initial branch: | master v

[] Clone submedules

Configuration

Remote name: | origin

Projects
[JImport all existing Eclipse projects after clone finishes
Working sets

[[] Add project to working sets

Working set Select...

@ < Back Next > Finish Cancel

7. A progress dialog will appear indicating how far along the clone process is. Once done,
the ASAssets_Ultilities clone should then appear in your Git Repositories list.

& Cloning from https://github.com/TIBCOSoftware/ASAssets_Utili... [m} X

'0' Cloning from https://github.com/TIBCOSoftware/ASAssets_Utilities.git

Receiving objects:  25% (1198/4790)

[] Always run in background

Run in Background Cancel Details >>

8. You may get an error stating that your secure store password has not been set. This can
be safely ignored but it's probably a good idea to go into the Eclipse preferences and set a
password for your secure storage.

L hl
E.] Problem Occurred E‘E‘g

A Writing to secure store failed

 No password provided.

Show Error Log OK l [ Details > > ]




Create a General project from the Git repository to control check-in
1. Open the Java perspective clicking the "Java" perspective button in the upper right of the
Eclipse screen.

2. Right-click in the "Package Explorer" panel on the left side of Eclipse. Select "Import ..."

3. Drill into "Git" and select "Projects from Git". Click "Next >".

r N
& tmport [ [ ]
Select . \A
Import one or more projects from a Git Repository. [ 5 I

Select an import source:

type filter text

> [ General -
= Cvs
> (= BB
4 [ Git
%5, Projects from Git
s (= Install
(= Java EE
> (= Maven
(= Plug-in Development
(= Remote Systems
> (= Run/Debug
(= Tasks
> = Team
= Web

5. Weh cenvices

m

@ < Back Next > Finish

S

4. In the next panel choose "Existing local repository". Click "Next >".

- N
E Import Projects from Git LM
Select Repository Source
lUI IJ
Select a location of Git Repositories ',
-
type filter text
|] Existing local repository
# Clone URI
® T e [




5. Choose the "ASAssets_Utilities" repository. Click "Next >".

& Import Projects from Git [m] X
Select a Git Repository

You can also clone a repository or add local repositories to the list :—‘:A
type filter text Add...

[] ASAssets_CacheManagement
[] ASAssets_KPI
[] ASAssets_Utilities

@ < Back Next > Finish Cancel

6. Select "Import existing Eclipse projects" as the root folder to import. Click "Next >".

& Import Projects from Git [m] X
Select a wizard to use for importing projects GIT
Depending on the wizard, you may select a directory to determine the wizard's scope :_‘:n o

Wizard for project import

(@ Import existing Eclipse projects

O Import using the New Project wizard
O Import as general project

v [= Working Tree - C:\MyfFiles\git\ASAssets_GIT_Repo\ASAssets_Utilities
> = git
» (= DocumentationSource
> (= DVSource
> (= JavaSource
> [~ Release
[2 .gitignore
|X] .project
|Z LICENSE
|=] README.md

@ Next > Finish Cancel

7. Select only the “ASAssets_Utilities” project and click "Finish".



© Import Projects from Git m] X
Import Projects
por el . GIT|
Import projects from a Git repository = I 4
Projects:
type filter text to filter unselected projects Select All
M1 ASAssets_Utilities (C:\MyFiles\git\ASAssets_GIT_Repo\ASAssets_Utilities) Deselect All
[J = ASAssets_Utilities (C:\MyFiles\git\ASAssets_GIT_Repo\ASAssets_Utilities\JavaSource)
Search for nested projects
Working sets
[ Add project to working sets
Select...
@ Next > Finish Cancel

8. The imported project:

v Iz ASAssets_Utilities [ASAssets_Utilities master]
=y DocumentationSource
(= DVSource
(= JavaSource
(= Release
3 LICENSE
3 README.md

Create a Java project from the Git repository JavaSource folder

1. Open the Java perspective clicking the "Java" perspective button in the upper right of the
Eclipse screen.

2. Select File > New > Java Project
a. Enter ASAssets_Utilities_JavaSource
b. Unselect “Use default location”

c. Browse to the Git repository location and select ASAssets_Utilities/JavaSource



@ New Java Project O X Browse For Folder X
Create a Java Project Choose a directory for the project contents:
Enter a location for the project.
v git ~
i — v ASAssets_GIT_Repo
Project name: | ASAssets_Utilities_JavaSource | > ASAssets_CacheManagement
[J Use default location ’ ASAssets_KP.I' .
v ASAssets_Utilities
Location: | | ‘ Browse... ‘ > git
JRE DocumentationSource
> DVSource
(®) Use an execution environment JRE: CDC-1.1/Foundation-1.1 v > JavaSource
ou: ject ific JRE: jdk1.8.0_152 ’ Release
se a project specific JRE: . v
id=asls [t > || AShssets KP| Archive
(O Use default JRE (currently 'jdk1.8.0_152") Configure JREs... > PDTool_Customer_Patches
> PDTool_Test_Installers
Project layout > | | PDToolGitTest
(O Use project folder as root for sources and class files > VCSClients
@ Creat te folders f d class fil Configure default. Notepad-- Diffs
reate separate folders for sources and class files
5 S > PDTo0l7.0.0
; > PDToolRegression
Working sets )
> PDToolStudio7.0.0_SVN
[JAdd project to working sets > || PDToolStudio7.0.0_TFS
Working sets: v Select... PrivilegeScripts
RestClient 2
(@ The default compiler compliance level for the current workspace is 1.7. The new Folder: | JavaSource I
project will use a project specific compiler compliance level of 1.4,
Make New Folder | [« ]| canel |
@ <Back Next > Finish | Cancel

d. Click “Finish”

S New Java Project [m] X
Create a Java Project
Create a Java project in the workspace or in an external location.

Project name: [ ASAssets_Utilities_JavaSource |

[[] Use default location

Location: l C:\MyFiles\git\ASAssets_GIT_Repo\ASAssets_Utilities\JavaSource | I Browse... I
JRE
Use an execution environment JRE: CDC-1.1/Foundation-1.1 v
Use a project specific JRE: jdk1.8.0_152 N

Use default JRE (currently 'jdk1.8.0_152") Configure JREs...

Project layout

Use project folder as root for sources and class files

Create separate folders for sources and class files Configure default...

Working sets
[J Add project to working sets

Working sets:

v Select...

@ The wizard will automatically configure the JRE and the project layout based on the existing
source.

@ < Back Next > ‘ [ Finish Cancel
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Build the AS Utilities jar files

Building the jar files for the CJP data sources is very straightforward. Each CJP folder contains a
"build.xml" file that can be used to build jar files individually. Alternatively, the "build.xml" file in the
project's root folder can be used to build all the jar files in one build. When one or more jar files
are built, they will appear in the "dist" folder in the project's root folder.

Debugging AS Utilities CJP (Java) Source Code
These steps discuss how you can debug the AS Utilities Java code using a remote CIS instance
to attach to.

1. Stop the CIS monitor from Control Panel:
2. Open a command line window to start CIS manually in debug mode
a. C:\CIS7.0.5\bin>composite_server.bat debug

3. Open your Eclipse workspace for ASAssets_Utitlities_JavaSource

i

a. Open the Debug Configurations and create a “Remote Java Application’
configuration for the ASAssets Utilities Java Project

b. Set the parameters as shown below for Host and Port.

c. Use this when debugging and setting breakpoints.

% Debug Configurations

Create, manage, and run configurations

Attach to a Java virtual machine accepting debug connections

X | B>~

Name: ASAssets_Utilities_JavaSource

type filter text &4 Connect . &~ Source| = Common

@ Eclipse Application
#5 Java Applet
31 Java Application

Project:
ASAssets_Utilities_JavaSource

Ju JUnit Connection Type:

Ju JUnit Plug-in Test Standard (Socket Attach)
m2 Maven Build

4 0SGi Eramework Connection Properties:
4 [T Remote Java Application Host: localhost
Z, ASAssets_Utilities_JavaSource Port: 8000

[¥] Allow termination of remote VM
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