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1

Introduction

JavaScript is a platform-independent scripting language that you can use to control many features and
automate many tasks in Adobe® applications. Scripting is easier to learn and use than many other kinds of
programming, and provides a convenient way of automating repetitive tasks or extending applications to
provide additional tools for other users.

» If you are new to scripting, see Adobe Creative Suite: Introduction to Scripting, which introduces basic
scripting concepts and describes different scripting languages that are available, including JavaScript.
JavaScript and other scripting languages are object-oriented, and this book also describes the basic
concepts of object-oriented programming and document object models.

» Each application that supports JavaScript also provides an application-specific Scripting Guide that
introduces the object model for that application, and reference material for the objects. This
document provides information about the JavaScript features, tools, and objects that are common to
all Adobe applications that support JavaScript.

» This document does not teach JavaScript. If you are familiar with scripting or programming in general,
but unfamiliar with JavaScript, see publicly available Web resources and documents, such as:

> The public JavaScript standards organization web site: www.ecma-international.org

D> JavaScript: The Definitive Guide, David Flanagan, O'Reily Media Inc, 2002. ISBN 0-596-00048-0
D> JavaScript Bible, Danny Goodman, Hungry Minds Inc, 2001. ISBN 0-7645-4718-6

D> Adobe Scripting, Chandler McWilliams, Wiley Publishing, Inc., 2003. ISBN 0-7645-2455-0

NoTEe: Check for updated versions of this document at Adobe Developer Center,
http://www.adobe.com/devnet/scripting.

Adobe provides an extended implementation of JavaScript, called ExtendScript, that is used by many
Adobe applications that provide a scripting interface. In addition to implementing the JavaScript
language according to the ECMA JavaScript specification, ExtendScript provides certain additional
features and utilities.

This document describes JavaScript modules, tools, utilities, and features that are available to all
JavaScript-enabled Adobe applications.

NoTE: Some modules, and features of some modules, are optional. Check the product documentation for
each application for details of which modules and features are implemented.

The Adobe ExtendScript SDK, which contains this document, also contains a set of code samples that
demonstrate how to use features of ScriptUl, interapplication communication, and external
communication. This book refers to these samples by name for illustration of concepts and techniques.

You can download the SDK from Adobe Developer Center, http://www.adobe.com/devnet/scripting/.



http://www.adobe.com/devnet/scripting/
http://www.adobe.com/devnet/scripting/
http://www.ecma-international.org
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The samples are located under the ExtendScript SDK root directory:

SDKroot/Samples/javascript/ sample scripts
SDKroot/Samples//javascript/resources/ resources, such asimage or flash files

For help in developing, debugging, and testing scripts, Adobe provides the ExtendScript Toolkit, an
interactive development and testing environment for ExtendScript, which is installed with all
JavaScript-enabled applications. For complete details, see Chapter 2, “The ExtendScript Toolkit.”

ExtendScript also provides global objects that support development and debugging:
» A global debugging object, the Dollar ($) object.

» A reporting utility for ExtendScript elements, the ExtendScript reflection interface.

For complete details, see Chapter 8, “ExtendScript Tools and Features.”

Adobe ExtendScript defines File and Folder classes that simplify cross-platform file-system access. These
classes are available to all applications that support a JavaScript interface.

For complete details, see Chapter 3, “File System Access.”

Adobe provides the ScriptUl module, which works with the ExtendScript JavaScript interpreter to provide
JavaScript scripts with the ability to create and interact with user interface elements. It provides an object
model for windows and user-interface control elements within an Adobe application. For complete details,
see Chapter 4, “User-Interface Tools.”

In addition, ExtendScript provides:

» Global functions for localization of display strings; see “Localizing ExtendScript strings” on page 224

» Global functions for displaying short messages in dialog boxes; see “User notification dialogs” on
page 227.

1

» Anobject type for specifying measurement values together with their units; see “Specifying
measurement values” on page 230.

ExtendScript provides a common scripting environment for all Adobe JavaScript-enabled applications,
and allows interapplication communication through scripts.

Different levels of communication are provided through the cross-DOM and the messaging framework.

» Cross-DOM functions are a limited set of basic functions common across all message-enabled
applications, which allow your script to, for example, open or print files in other applications, simply by
calling the open or print function for that application.
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>

In addition to the basic set of common functions, some applications provide more extensive sets of
exported JavaScript functions to other applications.

The interapplication messaging framework is an application programming interface (API) that allows
extensive control over communication between applications. The APl allows you to send messages to
other applications and receive results, and to receive messages sent by other applications and return
results. Typically the data passed between applications are JavaScript scripts. However, the messaging
framework is extensible. It allows you to define different types of data to send between applications,
and to specify how they are handled.

For complete details, see Chapter 5, “Interapplication Communication with Scripts.”

ExtendScript offers tools for communicating with other computers or the internet using standard
protocols. The Socket object supports low-level TCP connections.

For complete details, see Chapter 6, “External Communication Tools.”

You can extend the JavaScript DOM for an application by writing a C or C++ shared library, compiling it for
the platform you are using, and loading it into JavaScript as an Externalobject instance. A shared library
is implemented by a DLL in Windows, a bundle or framework in Mac OS, or a SharedObject in UNIX.

For complete details, see Chapter 7, “Integrating External Libraries.”

ExtendScript provides these utilities and features:

>

JavaScript language enhancements:

D> Tools for combining scripts, such as a #include directive. See “Preprocessor directives” on
page 233.

D> Support for extending or overriding math and logical operator behavior on a class-by-class basis.
See “Operator overloading” on page 235.

For complete details, see Chapter 8, “ExtendScript Tools and Features.”

JavaScript compilation, through the ExtendScript Toolkit. See Chapter 2, “The ExtendScript Toolkit.

XML integration: ExtendScript defines the xML object, which allows you to process XML with your
JavaScript scripts. For complete details, see Chapter 9, “Integrating XML into JavaScript.”

Scripting support for XMP metadata manipulation: XMPScript provides a JavaScript API for the Adobe
XMP Toolkit. For complete details, see Chapter 10, “Scripting Access to XMP Metadata.”
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On startup, all Adobe JavaScript-enabled applications execute JSX files that they find in their startup
directories; some of these are installed by applications, and some can be installed by scripters. The policies
of different applications vary as to the locations, write access, and loading order.

In addition, individual applications may look for application-specific scripts in particular directories, which
may be configurable. Some applications allow access to scripts from menus; all of them allow you to load
and run scripts using the ExtendScript Toolkit.

For details of how to load and run scripts for any individual application, see the JavaScript Scripting Guide
for that application.

A scriptin a startup directory might be executed on startup by multiple applications. If you place a script in
such a directory, it must contain code to check whether it is being run by the intended application. You can
do this using the appName static property of the BridgeTalk class. For example:

if ( BridgeTalk.appName == "bridge" ) {
//continue executing script
}

If a script that is run by one application will communicate with another application or add functionality
that depends on another application, it must first check whether that application/version is installed. You
can do this using the BridgeTalk.getSpecifier () static function. For example:

if ( BridgeTalk.appName == "bridge-2.0" ) ({
// Check to see that Photoshop is installed.
if ( BridgeTalk.getSpecifier ("photoshop",10)) {
// Add the Photoshop automate menu to the Adobe Bridge UI.
}

}

For details of interapplication communication, see Chapter 5, “Interapplication Communication with
Scripts.”

Scripting shares a global environment, so any script executed at startup can define variables and functions
that are available to all scripts. In all cases, variables and functions, once defined by running a script that
contains them, persist in subsequent scripts during a given application session. Once the application is
quit, all such globally defined variables and functions are cleared. Scripters should be careful about giving
variables in scripts unique names, so that a script does not inadvertently reassign global variables
intended to persist throughout a session.



The ExtendScript Toolkit

The ExtendScript Toolkit provides an interactive development and testing environment for ExtendScriptin
all JavaScript-enabled Adobe applications. It includes a full-featured, syntax-highlighting text editor with
Unicode capabilities and multiple undo/redo support. The Toolkit is the default editor for ExtendScript
files, which use the extension . jsx.

The Toolkit includes a JavaScript debugger that allows you to:

» Single-step through JavaScript scripts (JS or JSX files) inside an application.
» Inspect all data for a running script.

» Setand execute breakpoints.

When you double click a JSX file in the platform’s windowing environment, the script runs in the Toolkit,
unless it specifies a particular target application using the #target directive. For more information, see
“Selecting a debugging target” on page 27 and “Preprocessor directives” on page 233.

Tip: When you have completed editing and debugging your JavaScript script, you can choose to save it as
a binary file (with the extension JSXBIN), using File > Export as Binary. The script loader recognizes both
source code and compiled code. Any application can execute a compiled script. If an application
recognizes the execution of compiled JavaScript, it lists JSXBIN files along with JSX files in any list of
available scripts.”

The ExtendScript Toolkit initially appears with a default workspace arrangement, containing a default
configuration of tabbed panels and Script Editor document windows contained in a parent frame. The
arrangement is highly configurable, through the Window menu, the context menus of individual panels
and panel groups, or directly using drag and drop.

Document Panels
windows

13
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You can, for example, adjust the relative sizes of the panels by dragging the separators up or down, or right
or left, and can rearrange the groupings. To move a tabbed panel, drag the tab into another pane.

If you drag a tab so that the entire destination group is highlighted, it becomes another stacked panel in
that group. If you drag a tab to the top or bottom of a group (so that only the top or bottom bar of the
destination group is highlighted), that group splits to show the panels in a tiled format.

» You can dock the entire panel group to different edges of the Toolkit window.
» You can collapse the entire panel group, then expose individual panels.
» You can open and close, or collapse and expand individual panels, regardless of the dock state.

» You can undock individual tabs or the entire control panel, making them floating panels. Floating
panels can be docked to each other, or can be independent.

There are predefined configurations, called workspaces, suitable for various uses, and you can save your
favorite configurations as workspaces. See “Workspaces” on page 16.

Panel groups have a context menu, which you invoke with a right click in the tab or on the background of
the title bar. These menus have panel-control commands, including Close Panel and Close Group to hide
the individual panel or entire group.

Right click in top bar for panel-group menu

Panel-specific flyout menu

» You can also show or hide specific panels by toggling them on or off in the Window menu. Use the
Window menu to show a hidden panel, or to bring a floating panel to the front.

» Use Window > Hide panels to close all of the panels.

Some panels also have a flyout menu, specific to that panel, which you access through the menu icon in
the upper right corner. The JavaScript Console has a right-click menu that allows you to copy and paste
text.

The individual panels are discussed in detail in the following sections.
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When you open scripts or text files, each file appears in its own Script Editor document window. By default,
the document windows are docked; that is, shown as tabbed panes in the main window. However, like the
panels, you can drag any document window out of the frame to make it an independent floating window.

If you are displaying more than one document, and you have undocked one or more of them, you can
choose to show the document windows in tiled or cascade style—that is, side by side in the main window,
or overlapping in the main window. To do this, choose Window > Tile Documents or Window > Cascade.

You can edit or run scripts in multiple document windows simultaneously. The current document window
is highlighted and has the input focus. You can select another document window by clicking in it, or you
can switch between them with the commands Window > Next document and Window > Previous
document. The default keyboard shortcuts for these commands are F6 and SHIFT-F6; you can change these
using the Keyboard Shortcuts page in the Preferences dialog (Edit > Preferences).

NoOTE: Because you can run scripts in the same application simultaneously, you should be careful not to
interrupt the processing of one script with another. For example, if one script opens a modal dialog in
Photoshop, and you run another script that targets Photoshop while the dialog is still open, the second
script is likely to generate an error.

A button in the upper right corner of the document window allows you to split that window.

Split document button Second view of document

When the window is split, the second window is another view of exactly the same source. Any changes
you make in the text, breakpoints that you add, and so on, appear simultaneously in both windows. The
copy is, by default, positioned to the right of the original, docked window, as shown. However, if you use
CTRL-click to split the window, the second appears below the original.

For more information about the document windows and the Script Editor, see “The Script Editor” on
page 18.
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The Toolkit saves the current layout when you exit, and restores it at the next startup. It saves and restores
the open documents, the current positions within the documents, any breakpoints that have been set, and
other preferences that have been set in the Preferences dialog.

>

The Startup page in the Preferences dialog (Edit > Preferences) offers a choice of whether to open a
blank document window, no document window, or display a previously opened document on startup.

The Tookit defines a number of workspace configurations that are suitable for specific usage types. To
choose a predefined or user-defined workspace, use the workspace menu that drops down from the
upper right corner of the Toolkit. When you choose a workspace, its name appears here. You can also
add and remove workspaces from this menu.

\

Current workspace name appears in this space

You can save any configuration as a named workspace, using the Create new Workspace menu
command, or the Add button on the Workspaces page in the Preferences dialog (Edit > Preferences).

You can remove workspaces you have defined, either individually using the menu or the Workspaces
page in the Preferences dialog, or all at once using the Default button at the bottom of the Workspace

page.

The Keyboard Shortcuts page in the Preferences dialog (Edit > Preferences) allows you to set or
modify keyboard shortcuts for all menu commands. There is a warning if you assign a key combination
that is already in use. If you assign the combination to a new command, it is removed from the
previous command.

You can restore all preferences to their default values by holding the SHIFT key down while the Toolkit
loads.

Some dialog windows offer the option “Don’t show again” If you select this option, the Toolkit remembers
the choices made in this dialog, and next time it would appear, makes the same choices without showing
the dialog.

>

To make these dialogs display again, click Reset Dialogs on the User Interface page in the Preferences
dialog (Edit > Preferences).
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You can open multiple scripts (or text files, including programs in other languages). You can find and open
scripts in a number of ways:

» Use File > Open to bring up the platform-specific file browser.
Choose from recently opened files using File > Recent files.
Create a new script using File > New JavaScript.

Drop files from the Explorer or the Finder onto the Toolkit to open them in a document window.

vV v v Vv

For JavaScript scripts in trusted locations (the user-script folders of installed Adobe applications), a
double-click on the file runs it in the target application or in the Toolkit. For script files in other
locations, you must confirm that you want to run the script.

P Search for scripts containing particular text using Edit > Find and Replace. You can search in a
particular document window, among all scripts open in document windows, or among scripts
associated with an application, or kept in favorite locations. See “Searching in text” on page 24.

» Use the Scripts panel to display and open scripts made available by loaded Adobe applications, or
those kept in favorite locations.

The Scripts panel offers a list of debuggable scripts, which can be JS or JSX files or (for some applications)
HTML files that contain embedded scripts.

You can display a list of scripts made available by a particular target application. Select the target
application in the leftmost drop-down list; the available JavaScript engines for that application become
available in the right-hand list.

When you select a target application, the Toolkit offers to open that application if it is not running, then
displays the scripts which that application makes public. Select a script in this panel to load it and display
its contents in a new document window, where you can modify it, save it, or run it within the target
application.

When you choose the target Favorites, the right-hand list shows the default favorite script location, and
any other favorite locations that have been defined. You can create your own list of favorite script locations
using the flyout menu.

flyout menu
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The favorite script locations that you define are also available to the Find and Replace dialog; see
“Searching in text” on page 24.

You can also examine and set favorite locations using the Favorites page of the Preferences dialog (Edit >
Preferences). Use the Add, Modify, and Remove buttons to edit the list of folders.

Adobe Scripts folder

On first launch, the Toolkit creates a folder named adobe Scripts in the user's Documents folder. The
Default favorite in the Scripts panel displays the contents of this folder.

When double-clicking a JSX file, the Toolkit normally acts as an invisible security filter. Before actually
launching the file, a security dialog asks if it is OK to execute the script. The Toolkit treats the user's
Documents/Adobe Scripts folder, however, as a trusted location; when you double-click a JSX file in that
folder, the Toolkit does not display the security alert.

The Script Editor is a full-featured source code editor for JavaScript. You can open any number of Script
Editor document windows; each displays one Unicode source code document.

The Script Editor offers many useful and powerful text editing and navigation features. Some are intended
specifically for use with JavaScript, while others are useful for all kinds of text editing. Features include:

» Navigation aids and options applicable to any kind of text, and specific code navigation for JavaScript;
see “Navigation aids” on page 19.

» General editing and coding support such as undo-redo, and specific JavaScript coding support such
as syntax checking; see “Coding aids” on page 22.
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>
>

A full-featured text search tool that can search in multiple files; see “Searching in text” on page 24.

Syntax marking (color and font styles for specific syntactic structures) for JavaScript and for many
other computer languages. The marking styles are configurable; see “Syntax marking” on page 26.

You can configure the Script Editor to display text with various features that help you track the structure of
your code, or that help you move around in the file. It also offers mouse and keyboard shortcuts for specific
types of cursor movement and text selection.

View options

The Script Editor offers a number of viewing options that aid in code navigation, including the following:

>
>

Automatic line numbering. View > Line Numbers toggles numbering on and off.

A collapsible tree view of code, where you can open or close logical units of the structure, such as
comments or function definitions. View > Code Collapse toggles the tree view on and off.

A line-wrapping mode, where there is no horizontal scroll bar, and lines are wrapped at word breaks.
View > Word Wrap toggles line-wrapping on and off.

Syntax marking, which uses color and font styles to highlight specific syntactic structures. View >
Syntax Highlighting allows you to turn syntax marking off, or set it to mark a particular language,

JavaScript or many other computer languages. The marking styles are configurable; see “Syntax
marking” on page 26.

You can set the default values for any of these states using the Documents page of the Preferences dialog
(Edit > Preferences).

Function finders

The Functions panel, and the flyout menu at the top right of the document window, both offer lists of
functions defined in the current document. When you select a function in either list, the document jumps
directly to that function definition in the code.
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Bookmarks

The Edit > Bookmarks menu allows you to set and clear navigation points in your text. The F2 function
key is the default shortcut key for the bookmark commands:

» Toggle the bookmark for the current line using CTRL-F2.

» Move the cursor to the next bookmark with F2, or to the previous one with SHIFT-F2. The bookmarks
wrap, so that the first follows the last.

» Use SHIFT-CTRL-F2 to clear all bookmarks in the current text.
When you navigate to a bookmark in a collapsed section of code, that section automatically opens.

Bookmarks are marked with a blue, right-pointing arrow at the left of the line (to the right of the line
number if it is shown). This is the same place where a breakpoint is marked with a dot (see “Setting
breakpoints” on page 31). If you have both a breakpoint and a bookmark set in the same line, the blue

arrow is superimposed on the breakpoint dot.
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line numbers ——

bookmark

collapsible
code sections

bookmarkand
breakpoint

Mouse navigation and selection

You can use the mouse or special keyboard shortcuts to move the insertion point or to select text in the
document window. Click the left mouse button in the document window to move the position caret.

To select text with the mouse, click in unselected text, then drag over the text to be selected. If you drag
above or below the currently displayed text, the text scrolls, continuing to select while scrolling. You can
also double-click to select a word, or triple-click to select a line.

To initiate a drag-and-drop of selected text, click in the block of selected text, then drag to the destination.
You can drag text from one document window to another. You can also drag text out of the Toolkit into
another application that accepts dragged text, and drag text from another application into a Toolkit
document window.

You can drop files from the Explorer or the Finder onto the Toolkit to open them in a document window.

Keyboard navigation and selection

The Keyboard Shortcuts page in the Preferences dialog (Edit > Preferences) allows you to set or modify
keyboard shortcuts for all menu commands.

In addition to the keyboard shortcuts specified for menu commands, and the usual keyboard input, the
document window accepts these special movement keys. You can also select text by using a movement
key while pressing SHIFT.

ENTER Insert a Line Feed character
Backspace Delete character to the left
DELETE Delete character to the right

Left arrow Move insertion point left one character
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Right arrow

Up arrow

Down arrow

Page up

Page down

CTRL + Up arrow
CTRL + Down arrow
CTRL + Page up
CTRL + page down
CTRL + Left arrow
CTRL + right arrow
Home

END

CTRL + HOME

CTRL + END

Move insertion point right one character

Move insertion point up one line; stay in column if possible
Move insertion point down one line; stay in column if possible
Move insertion point one page up

Move insertion point one page down

Scroll up one line without moving the insertion point
Scroll down one line without moving the insertion point
Scroll one page up without moving the insertion point
Scroll one page down without moving the insertion point
Move insertion point one word to the left

Move insertion point one word to the right

Move insertion point to start of line

Move insertion point to end of line

Move insertion point to start of text

Move insertion point to end of text

The Script Editor supports extended keyboard input via IME (Windows) or TMS (Mac OS). This is especially
important for Far Eastern characters.

The Script Editor offers a number of visual and editing features that help you navigate in and maintain the
syntactic structure of your JavaScript code, including the following.

Code completion

When you position the cursor in a document and begin typing, the Toolkit offers completion choices from
among keywords, global functions, functions that are defined in the current document, and functions
defined in the object-model dictionary that is currently selected from the flyout menu.
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You can use the flyout menu at the upper right corner of the document window to choose an
object-model dictionary to use for completion. Available dictionaries depend on which applications are
loaded. See “Inspecting object models” on page 36.

flyout menu

Select object
model dictionary
for completion

Brace matching

The Edit menu offers two kinds of brace-matching selection, that operate when the cursor is placed
immediate after an opening brace character, orimmediately before a closing brace:

> Edit > Select to Brace: Moves the cursor to the matching bracing, but does not select any text. The
default keyboard shortcut is CTRL O (zero).

» Edit > Select Including Brace: Selects all text between the braces. The default keyboard shortcut is
SHIFT CTRL O (zero).

Brace characters include parentheses, curly braces, and square brackets.

Block indentation

When Word Wrap is off, you can automatically indent or outdent entire blocks of text. To indent a block of
text, select some or all of the text on the line or lines, and press TAB. (Be careful; if Word Wrap is on, this
deletes the selected text.) To outdent, press SHIFT TAB.

Comment and uncomment commands

Use Edit > Comment or Uncomment Selection to temporarily remove parts of a JavaScript program from
the path of execution. This command is a toggle. When you first issue the command, it places the special
comment sequence //~ at the front of any line that is wholly or partially selected. When you next issue the
command with such a line selected, it removes that comment marker.

The command affects only the comment markers it places in the text; it ignores any comment markers that
were already in the selected lines. This allows you to temporarily remove and replace blocks of text that
include both code and comments.

Version comments

A special comment format is reserved for a code versioning statement, which is used internally by Adobe
scripts, but is available to all scripters. Use Edit > Insert Version Tag to insert a comment containing the
file name and current date-time, in this format:
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/**
* @@@BUILDINFO@@@ SnpCreateDialog.jsx !Version! Tue Dec 05 2006 08:03:38 GMT-0800
*/

You are responsible for manually updating the 1version! portion with your own version information.

Undo and redo

Choose Undo or Redo from the Edit menu or from the document window’s right-click context menu to
revoke and reinstate multiple editing changes sequentially. The change history is kept from when afile is
created or loaded, and maintained through file-save operations.

Syntax checking

Before running the new script or saving the text as a script file, use Edit > Check Syntax to check whether
the text contains JavaScript syntax errors. The default keyboard shortcut is F7.

P If the script is syntactically correct, the status line shows “No syntax errors.”

» If the Toolkit finds a syntax error, such as a missing quote, it highlights the affected text, plays a sound,
and shows the error message in the status line so you can fix the error.

Multiline statements

The Script Editor supports triple-quote syntax to allow strings to span several source code lines. When
entering a very long string, you can:

» Enteritall ononeline:

var myString = "This very long string might wrap onto a second line visually, but you
typed no CR character when entering it."

» Enter on multiple lines, using a backslash (\) continuation character at the end of each line:

var myString = "This string spans \
two lines."

» Use triple quotes around the entire string on multiple lines:

var myString = """This "quoted" word is inside the
multiline string enclosed by triple quotes."""

The triple-quote option allows the string to contain embedded quotes.

The Toolkit offers a search utility through the Edit > Find and Replace command. This command brings
up the Find and Replace panel. If the panel is not docked, you can hide it by pressing Esc.

The Find and Replace panel allows you to search through multiple documents for text that matches a
specific search string or regular expression. You can choose to search in:

» The current document, or the current selection in the current document

» All open documents
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» All scripts made public by the current target application

» Folders that you have defined as favorite locations; see “The Scripts panel and favorite script locations”
on page 17.

The results of a search are listed in the Find Results tab; by default, this is stacked with the Find and Replace
panel, but you can drag it to another stack, or display it as an independent floating panel.

Double-click a result line in the Find Results panel to jump directly to the document and line where the
text was found.

Using regular-expression syntax

The Toolkit supports a limited set of Regular Expression syntax for the Find and Replace dialog:

Matches any character
( Marks the start of a region for capturing a match.
) Marks the end of a capturing region.
\< Matches the start of a word using the editor's current definition of words.

\> Matches the end of a word using the editor's current definition of words.
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\x Escapes a character x that would otherwise have a special meaning. For example, \[ is
interpreted as a left bracket, rather than the start of a character set.

[...1 A set of characters; for example, [abc] means any of the characters a, b or c. You can also use
ranges, for example [a-z] for any lower case character.

[*...] The complement of the characters in a set. For example, [AA-Za-z] means any character
except an alphabetic character.

Matches the start of a line (unless used inside a set).

$ Matches the end of a line.
* Matches 0 or more times. For example, Sa*m matches Sm, Sam, Saam, Saaam etc.
+ Matches 1 or more times. For example, Sa+m matches Sam, Saam, Saaam and so on.

In a replace operation, you can use the captured regions of a match in the replacement expression by
using the placeholders \ 1 through \ 9, where \ 1 refers to the first captured region, \ 2 to the second, and so
on.

For example, if the search string is Fred\ ([1-9]\) xxx and the replace string is sam\1YvY, when applied to
Fred2xxx the search generates sam2yvy.

The Script Editor offers language-based syntax highlighting to aid in editing code. Although the
debugging features (including syntax checking) are only available for JavaScript, you can choose to edit
other kinds of code, and the syntax is highlighted according to the language. The style of syntax marking is
automatically set to match the file extension, or you can choose the language from the View > Syntax
Highlighting menu.

The style of highlighting is configurable, using the Fonts and Colors page of the Preferences dialog.
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Select language for syntax
highlighting in Script Editor

Customize highlighting
styles in Preferences dialog

You can debug the code in the currently active document window. Select one of the debugging
commands to either run or to single-step through the program.

When you run code from the document window, it runs in the current target application’s selected
JavaScript engine. The Toolkit itself runs an independent JavaScript engine, so you can quickly edit and
run a script without connecting to a target application.

The Toolkit can debug multiple applications at one time. If you have more than one Adobe application
installed, use the drop-down list at the upper left of a document window to select the target application
for that window. All installed applications that support JavaScript are shown in this list. If you try to run a
script in an application that is not running, the Toolkit prompts for permission to run it.

Some applications use multiple JavaScript engines; all available engines in the selected target application
are shown in a drop-down list to the right of the application list, with an icon that shows the current
debugging status of that engine. A target application can have more than one JavaScript engine, and
more than one engine can be active, although only one is current. An active engine is one that is currently
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executing code, is halted at a breakpoint, or, having executed all scripts, is waiting to receive events. An
icon by each engine name indicates whether it is running, halted, or waiting for input:

B  running
EH halted

waiting

The current engine is the one whose data and state is displayed in the Toolkit’s panes. If an application has
only one engine, its engine becomes current when you select the application as the target. If there is more
than one engine available in the target application, you can select an engine in the list to make it current.

When you open the Toolkit, the Toolkit itself is the default target application. When you select another
target, if the target application that you select is not running, the Toolkit prompts for permission and
launches the application. Similarly, if you run a script that specifies a target application that is not running
(using the #target directive), the Toolkit prompts for permission to launch it. If the application is running
but not selected as the current target, the Toolkit prompts you to switch to it.

If you select an application that cannot be debugged in the Toolkit, an error dialog reports that the Toolkit
cannot connect to the selected application.

The ExtendScript Toolkit is the default editor for JSX files. If you double-click a JSX file in a file browser, the
Toolkit looks for a #target directive in the file and launches that application to run the script; however, it
first checks for syntax errors in the script. If any are found, the Toolkit displays the error in a message box
and quits silently, rather than launching the target application. For example:

The JavaScript console is a command shell and output window for the currently selected JavaScript
engine. It connects you to the global namespace of that engine.
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The console is a JavaScript listener, that expects input text to be JavaScript code.

You can use the console to evaluate expressions or call functions. Enter any JavaScript statement and
execute it by pressing ENTER. The statement executes within the stack scope of the line highlighted in the
Call Stack panel, and the result appears in the next line.

» You can use the up- and down-arrow keys to scroll through previous entries, or place the cursor with
the mouse. Pressing ENTER executes the line that contains the cursor, or all selected lines.

» The right-click context menu provides the same editing commands as that of the document window.
You can copy, cut, and paste text, and undo and redo previous actions.

» You can select text with the mouse, and use the normal copy and paste shortcuts.
» The flyout menu allows you to clear the current content.

Commands entered in the console execute with a timeout of one second. If a command takes longer than
one second to execute, the Toolkit generates a timeout error and terminates the attempt.

The console is the standard output location for JavaScript execution. If any script generates a syntax error,
the error is displayed here along with the file name and the line number. The Toolkit displays errors here
during its own startup phase.

The debugging commands are available from the Debug menu, from the document window'’s right-click
context menu, through keyboard shortcuts, and from the toolbar buttons. Use these menu commands
and buttons to control the execution of code when the JavaScript Debugger is active.

Run F5 (Windows) Starts or resumes execution of a script.

Do Continue Ctrl R (Mac OS)
Disabled when script is executing.

Break Ctrl F5 (Windows)  Halts the currently executing script temporarily and reactivates
il Cmd . (Mac OS) the JavaScript Debugger.

Enabled when a script is executing.

Stop Shift F5 (Windows) Stops execution of the script and generates a runtime error.
= Ctrl K (Mac O5)
Enabled when a script is executing.
Step F10 (Windows) Halts after executing a single JavaScript line in the script. If the
> Over Ctrl S (Mac OS) statement calls a JavaScript function, executes the function in
its entirety before stopping (do not step into the function).
v StepInto F11 (Windows) Halts after executing a single JavaScript line statement in the
Ctrl T (Mac OS) script or after executing a single statement in any JavaScript
function that the script calls.
A Step Out ShiftF11 When paused within the body of a JavaScript function, resumes
(Windows) script execution until the function returns.

Ctrl U (Mac OS)
When paused outside the body of a function, resumes script

execution until the script terminates.




CHAPTER 2: The ExtendScript Toolkit Debugging in the Toolkit 30

When the execution of a script halts because the script reached a breakpoint, or when the script reaches
the next line when stepping line by line, the document window displays the current script with the current
line highlighted in yellow.

current line

If the script encounters a runtime error, the Toolkit halts the execution of the script, displays the current
script with the current line highlighted in orange, and displays the error message in the status line. Use the
Data Browser to get further details of the current data assignments.

error line————

error message—

Scripts often use a try/catch clause to execute code that may cause a runtime error, in order to catch the
error programmatically rather than have the script terminate. You can choose to allow regular processing
of such errors using the catch clause, rather than breaking into the debugger. To set this behavior, choose
Debug > Don’t Break On Guarded Exceptions. Some runtime errors, such as out 0f Memory, always
cause the termination of the script, regardless of this setting.
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When debugging a script, it is often helpful to make it stop at certain lines so that you can inspect the state
of the environment, whether function calls are nested properly, or whether all variables contain the
expected data.

» To stop execution of a script at a given ling, click to the left of the line number to set a breakpoint. A
red dot indicates the breakpoint.

» Click a second time to temporarily disable the breakpoint; the icon changes color.
» Click a third time to delete the breakpoint. The icon is removed.

Some breakpoints need to be conditional. For example, if you set a breakpoint in a loop that is executed
several thousand times, you would not want to have the program stop each time through the loop, but
only on each 1000th iteration.

You can attach a condition to a breakpoint, in the form of a JavaScript expression. Every time execution
reaches the breakpoint, it runs the JavaScript expression. If the expression evaluates to a nonzero number
or true, execution stops.

To set a conditional breakpoint in a loop, for example, the conditional expression could be "i >= 1000",
which means that the program execution halts if the value of the iteration variable i is equal to or greater
than 1000.

Tip: It is often useful to check the boundary conditions for loops; to do this, you can set the condition for a
breakpoint within a loop to trigger on the first and last iterations.

You can set breakpoints on lines that do not contain any code, such as comment lines. When the Toolkit
runs the program, it automatically moves such a breakpoint down to the next line that actually contains
code.

The Breakpoints panel

The Breakpoints panel displays all breakpoints set in the current document window. You can use the
panel’s flyout menu to add, change, or remove a breakpoint.

You can edit a breakpoint by double-clicking it, or by selecting it and choosing Add or Modify from the
panel menu. A dialog allows you to change the line number, the breakpoint’s enabled state, and the
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condition statement. You can also specify a hit count, which allows you to skip the breakpoint some
number of times before entering the debugger. The default is 1, which breaks at the first execution.

When execution reaches this breakpoint after the specified number of hits, the debugger evaluates this
condition. If it does not evaluate to true, the breakpoint is ignored and execution continues. This allows
you to break only when certain conditions are met, such as a variable having a particular value.

Breakpoint icons

Each breakpoint is indicated by an icon to the left of the line number in the document window, and an

icon and line number in the Breakpoints panel. Different icons are used in the document window and in
the Breakpoints panel.
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Unconditional breakpoint. Execution stops here.

Unconditional breakpoint, disabled. Execution does not stop.

Conditional breakpoint. Execution stops if the attached JavaScript expression evaluates
to true.
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Conditional breakpoint, disabled. Execution does not stop.




CHAPTER 2: The ExtendScript Toolkit Debugging in the Toolkit 33

If you let your mouse pointer rest over a variable or function in a document window, the result of
evaluating that variable or function is displayed as a help tip. When you are not debugging the program,
this is helpful only if the variables and functions are already known to the JavaScript engine. During
debugging, however, this is an extremely useful way to display the current value of a variable, along with
its current data type.

The Data Browser panel is your window into the JavaScript engine. It displays all live data defined in the
current context, as a list of variables with their current values. If execution has stopped at a breakpoint, it
shows variables that have been defined using var in the current function, and the function arguments. To
show variables defined in the global or calling scope, use the Call Stack to change the context (see “The.
call stack” on page 34).

You can use the Data Browser to examine and set variable values.
» Click a variable name to show its current value in the edit field at the top of the panel.
» To change the value, enter a new value and press ENTER. If a variable is Read only, the edit field is

disabled.

flyout
menu

Examine or modify
selected variable’s value

\

Object opened to
show properties

The flyout menu for this panel lets you control the amount of data displayed:
» Undefined Variables toggles the display of variables whose value is undefined (as opposed to null).

» Functions toggles the display of all functions that are attached to objects. Most often, the interesting
data in an object are its callable methods.

> Core JavaScript Elements toggles the display of all data that is part of the JavaScript language
standard, such as the Array constructor or the Math object.

» Prototype Elements toggles the display of the JavaScript object prototype chain.

Each variable has a small icon that indicates the data type. An invalid object (that is, a reference to an
object that has been deleted) shows the object icon crossed out in red. An undefined value has no icon.
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You can inspect the contents of an object by clicking its icon. The list expands to show the object’s
properties (and methods, if Functions display is enabled), and the triangle points down to indicate that

the object is open.

The Call Stack panel is active while debugging a program. When an executing program stops because of a
breakpoint or runtime error, the panel displays the sequence of function calls that led to the current
execution point. The Call Stack panel shows the names of the active functions, along with the actual

arguments passed in to that function.

For example, this panel shows a break occurring at a breakpoint in a function RGBColorPicker ():

The function containing the breakpoint is highlighted in the Call Stack panel. The line containing the

breakpoint is highlighted in the Document Window.

You can click any function in the call hierarchy to inspect it. In the document window, the line containing
the function call that led to that point of execution is marked with a green background. In the example,
when you select the run () function in the call stack, the Document Window highlights the line in that

function where the ReBColorPicker () function was called.
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Switching between the functions in the call hierarchy allows you to trace how the current function was
called. The Console and Data Browser panels coordinate with the Call Stack panel. When you select a
function in the Call Stack:

» The Console panel switches its scope to the execution context of that function, so you can inspect and
modify its local variables. These would otherwise be inaccessible to the running JavaScript program
from within a called function.

» The Data Browser panel displays all data defined in the selected context.

The Profiling tool helps you to optimize program execution. When you turn profiling on, the JavaScript
engine collects information about a program while it is running. It counts how often the program
executed a line or function, or how long it took to execute a line or function. You can choose exactly which
profiling data to display.

Because profiling significantly slows execution time, the Profile menu offers these profiling options.

off Profiling turned off. This is the default.

Functions The profiler counts each function call. At the end of execution, displays the total to
the left of the line number where the function header is defined.

Lines The profiler counts each time each line is executed. At the end of execution,
displays the total to the left of the line number.

Consumes more execution time, but delivers more detailed information.

Add Timing Info Instead of counting the functions or lines, records the time taken to execute each
function or line. At the end of execution, displays the total number of
microseconds spent in the function or ling, to the left of the line number.

This is the most time-consuming form of profiling.

No Profiler Data When selected, do not display profiler data.
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Show Hit Count When selected, display hit counts.
Show Timing When selected, display timing data.

Erase Profiler Data Clear all profiling data.

Save Data As Save profiling data as comma-separated values in a CSV file that can be loaded
into a spreadsheet program such as Excel.

When execution halts (at termination, at a breakpoint, or due to a runtime error), the Toolkit displays this
information in the Document Window, line by line. The profiling data is color coded:

» Green indicates the lowest number of hits, or the fastest execution time.

» Orange or yellow indicates a trouble spot, such as a line that has been executed many times, or which
line took the most time to execute.

This example shows number-of-hits information:

This example displays timing information for the program, in microseconds. The timing might not be

accurate down to the microsecond; it depends on the resolution and accuracy of the hardware timers built
into your computer.

The ExtendScript Toolkit offers the ability to inspect the object model of any loaded dictionary, using the
Object Model Viewer that you invoke from the Help menu.
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The Object Model Viewer (OMV) comes up as a separate, floating window. The OMV allows you to browse

through the object hierarchy and inspect the type and description of each property, and the description
and parameters for each method.

The drop-down menu in the Browser section at the top left allows you to choose from any loaded
dictionary of objects. A dictionary provides access to the object model for one application or subsystem.

» The Core JavaScript Classes dictionary includes Adobe tools and utilities such as File and Folder.

» The ScriptUI Classes dictionary shows the interface elements defined in the ScriptUl JavaScript
module.
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» Each Adobe application defines a dictionary for that application’s Document Object Model (DOM). The
dictionary for a particular application may not be available until you launch that application, or until
you select it as a target in the Toolkit.

To inspect an object model, select the appropriate dictionary from the Browser menu. The classes defined
in that model appear in the Classes panel. Select a class to populate the Types panel with the available

element types (Constructor, Class, Instance, Event). Select the type to populate the Properties and
Methods panel with elements of that type.

Each time you select a class or element, its description appears on the right; descriptions are stacked,
remaining in view until you close them. You can close each description individually, using the mouse-over
menu that appears in the lower right of the description itself, or you can close all open descriptions using
the Close All button at the top left of the OMV window.

e Clearall
descriptions

Mouse-over

The mouse-over menu also allows you to bookmark an element for easy access, or copy text from the

description. Live links in the descriptions take you to related objects and elements, and you can search for
text in names or descriptions.



File System Access

Adobe ExtendScript defines classes that simplify cross-platform file-system access. These classes are
available to all applications that support a JavaScript interface.

» The first part of this chapter, Using File and Folder objects, describes how to use these classes and
provides details of pathname syntax.

» “File object” on page 47 and “Folder object” on page 56 provide reference details of the objects,
properties, methods, and creation parameters. You can also choose the Core JavaScript Classes
dictionary from the Help menu in the ExtendScript Toolkit to inspect the objects in the Object Model
Viewer.

Because path name syntax is very different on Windows, Mac OS, and UNIX®, Adobe ExendScript defines
the rFile and Folder objects to provide platform-independent access to the underlying file system. A
File object represents a disk file, a Folder object represents a directory or folder.

» The Folder object supports file system functionality such as traversing the hierarchy; creating,
renaming or removing files; or resolving file aliases.

» The File object supports input/output functions to read or write files.

There are several ways to distinguish between a File and a Folder object. For example:
if (f instanceof File)

if (typeof f.open == "undefined") ...// Folders do not open

File and Folder objects can be used anywhere that a path name is required, such as in properties and
arguments for files and folders.

NoTE: When you create two File objects that refer to the same disk file, they are treated as distinct
objects. If you open one of them for /O, the operating system may inhibit access from the other object,
because the disk file already is open.

When creating a File or Folder object, you can specify a platform-specific path name, or an absolute or
relative path in a platform-independent format known as universal resource identifier (URI) notation. The
path stored in the object is always an absolute, full path name that points to a fixed location on the disk.

P Usethe tostring method to obtain the name of the file or folder as string containing an absolute
path name in URI notation.

> Use the £sName property to obtain the platform-specific file name.

39
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Absolute and relative path names

An absolute path name in URI notation describes the full path from a root directory down to a specific file
or folder. It starts with one or two slashes (/), and a slash separates path elements. For example, the
following describes an absolute location for the file myFile.jsx:

/dirl/dir2/mydir/myFile.jsx

A relative path name in URI notation is appended to the path of the current directory, as stored in the
globally available current property of the Folder class. It starts with a folder or file name, or with one of
the special names dot (.) for the current directory, or dot dot (. .) for the parent of the current directory. A
slash (/) separates path elements. For example, the following paths describe various relative locations for
the file myFile.jsx:

myFile.jsx In the current directory.

./myFile.jsx

../myFile.jsx In the parent of the current directory.
../../myFile.jsx In the grandparent of the current directory.

../dirl/myFile.jsx In diri, which is parallel to the current directory.

Relative path names are independent of different volume names on different machines and operating
systems, and therefore make your code considerably more portable. You can, for example, use an absolute
path for a single operation, to set the current directory in the Folder. current property, and use relative
paths for all other operations. You would then need only a single code change to update to a new platform
or file location.

Character interpretation in paths

There are some platform differences in how pathnames are interpreted:
» On Windows and Mac OS, path names are not case sensitive. In UNIX, paths are case sensitive.

» On Windows, both the slash (/) and the backslash (\) are valid path element separators. Backslash is
the escape character, so you must use a double backslash (\\) to indicate the character.

» On Mac OS, both the slash (/) and the colon (:) are valid path element separators.

If a path name starts with two slashes (or backslashes on Windows), the first element refers to a remote
server. For example, / /myhost /mydir/myfile refers to the path /mydir/myfile on the server myhost.

URI notation allows special characters in pathnames, but they must specified with an escape character (%)
followed by a hexadecimal character code. Special characters are those which are not alphanumeric and
not one of the characters:

/-— ot~k ()

A space, for example, is encoded as %20, so the file name "my filer is specified as "my%20file™ Similarly,
the character 4 is encoded as $E4, so the file name "Braun is specified as "BrsE4un™.

This encoding scheme is compatible with the global JavaScript functions encodeURI and decodeURI.
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The home directory

A path name can start with a tilde (~) to indicate the user’s home directory. It corresponds to the platform’s
HOME environment variable.

UNIX and Mac OS assign the HOME environment variable according to the user login. On Mac OS, the
default home directory is /Users/username. In UNIX, it is typically /home /username or /users/username.
ExtendScript assigns the home directory value directly from the platform value.

On Windows, the HOME environment variable is optional. If it is assigned, its value must be a Windows path
name or a path name referring to a remote server (such as \ \myhost\mydir). If the HOME environment
variable is undefined, the ExtendScript default is the user’s home directory, usually the ¢: \Documents and
Settings\username folder.

NoOTE: A script can access many of the folders that are specified with platform-specific variables through
static, globally available Folder class properties; for instance, appData contains the folder that stores
application data for all users.

Volume and drive names

A volume or drive name can be the first part of an absolute path in URI notation. The values are interpreted
according to the platform.

Mac OS volumes

When Mac OS X starts, the startup volume is the root directory of the file system. All other volumes,
including remote volumes, are part of the /volumes directory. The File and Folder objects use these
rules to interpret the first element of a path name:

» If the name is the name of the startup volume, discard it.
» If the name is a volume name, prepend /volumes.
» Otherwise, leave the path as is.

Mac OS 9 is not supported as an operating system, but the use of the colon as a path separator is still
supported and corresponds to URI and to Mac OS X paths as shown in the following table. These examples
assume that the startup volume is Macosx, and that there is a mounted volume Remote.

URI path name Mac OS 9 path name Mac OS X path name
/MacOSX/dir/file MacOSX:dir:file /dir/file
/Remote/dir/file Remote:dir:file /Volumes/Remote/dir/file
/root/dir/file Root:dir:file /root/dir/file
~/dir/file /Users/jdoe/dir/file

Windows drives

On Windows, volume names correspond to drive letters. The URI path /c/temp/£ile normally translates
to the Windows path c:\temp\file.

If a drive exists with a name matching the first part of the path, that part is always interpreted as that drive.
Itis possible for there to be a folder in the root that has the same name as the drive; imagine, for example,
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a folder c:\c on Windows. A path starting with /c always addresses the drive C:, so in this case, to access
the folder by name, you must use both the drive name and the folder name, for example /c/c for c:\c.

If the current drive contains a root folder with the same name as another drive letter, that name is
considered to be a folder. That is, if there is a folder : \c, and if the current drive is D:, the URI path
/c/temp/£ile translates to the Windows path D: \c\temp\£file. In this case, to access drive C, you would
have to use the Windows path name conventions.

To access a remote volume, use a uniform naming convention (UNC) path name of the form
//servername/sharename. These path names are portable, because both Max OS X and UNIX ignore
multiple slash characters. Note that on Windows, UNC names do not work for local volumes.

These examples assume that the current drive is D:

URI path name Windows path name

/c/dir/file c:\dir\file

/remote/dir/file D:\remote\dir\file

/root/dir/file D:\root\dir\file

~/dir/file C:\Documents and Settings\jdoe\dir\file
Aliases

When you access an alias, the operation is transparently forwarded to the real file. The only operations that
affect the alias are calls to rename and remove, and setting properties readonly and hidden. Whena rile
object represents an alias, the alias property of the object returns true, and the resolve method returns
the File or Folder object for the target of the alias.

On Windows, all file system aliases (called shortcuts) are actual files whose names end with the extension
. 1nk. Never use this extension directly; the File and Folder objects work without it.

For example, suppose there is a shortcut to the file /folder1/some. txt in the folder /folder2. The full
Windows file name of the shortcut file is \folder2\some. txt . 1nk.

To access the shortcut from a File object, specify the path /folder2/some. txt. Calling that File object’s
open method opens the linked file (in /folder1). Calling the File object’s rename method renames the
shortcut file itself (leaving the . 1nk extension intact).

However, Windows permits a file and its shortcut to reside in the same folder. In this case, the File object
always accesses the original file. You cannot create a File object to access the shortcut whenit is in the
same folder as its linked file.

A script can create a file alias by creating a File object for a file that does not yet exist on disk, and using its
createAlias method to specify the target of the alias.

Portability issues

If your application will run on multiple platforms, use relative path names, or try to originate path names
from the home directory. If that is not possible, work with Mac OS X and UNIX aliases, and store your files
on a machine that is remote to your Windows machine so that you can use UNC names.
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As an example, suppose you use the UNIX machine myserver for data storage. If you set up an alias share
in the root directory of myserver, and if you set up a Windows-accessible share at share pointing to the
same data location, the path name //myserver/share/file would work for all three platforms.

When doing file I/0, Adobe applications convert 8-bit character encoding to Unicode. By default, this
conversion process assumes that the system encoding is used (code page 1252 on Windows or Mac
Roman on Mac OS). The encoding property of a File object returns the current encoding. You can set the
encoding property to the name of the desired encoding. The File object looks for the corresponding
encoder in the operating system to use for subsequent I/0. The name is one of the standard Internet
names that are used to describe the encoding of HTML files, such as Asc11, x-sJIs, or 130-8859-1.Fora
complete list, see File- and Folder-supported encoding names.

A special encoder, BINARY, is provided for binary I/0. This encoder simply extends every 8-bit character it
finds to a Unicode character between 0 and 255. When using this encoder to write binary files, the encoder
writes the lower 8 bits of the Unicode character. For example, to write the Unicode character 1000, which is
0x3ES8, the encoder actually writes the character 232 (OxES8).

The data of some of the common file formats (UCS-2, UCS-4, UTF-8, UTF-16) starts with a special byte order
mark (BOM) character (\urEFF). The File.open method reads a few bytes of a file looking for this
character. If it is found, the corresponding encoding is set automatically and the character is skipped. If
there is no BOM character at the beginning of the file, open () reads the first 2 KB of the file and checks
whether the data might be valid UTF-8 encoded data, and if so, sets the encoding to UTF-8.

To write 16-bit Unicode files in UTF-16 format, use the encoding UCS-2. This encoding uses whatever
byte-order format the host platform supports.

When using UTF-8 encoding or 16-bit Unicode, always write the BOM character "\urerr" as the first
character of the file.

Each object has an error property. If accessing a property or calling a method causes an error, this
property contains a message describing the type of the error. On success, the property contains the empty
string. You can set the property, but setting it only causes the error message to be cleared. If a file is open,
assigning an arbitrary value to the property also resets its error flag.

For a complete list of supported error messages, see “File access error messages” on page 44.




CHAPTER 3: File System Access

File access error messages

The following messages can be returned in the error property.

44

File or folder does not exist
File or folder already exists
I/0 device is not open

Read past EOF

Conversion error

Partial multibyte character found
Permission denied

Cannot change directory
Cannot create

Cannot rename

Cannot delete

I/0 error

Cannot set size

Cannot open

Cannot close

Read error

Write error

Cannot seek

Cannot execute

The file or folder does not exist, but the parent folder exists.

The file or folder already exists.

An 1/0 operation was attempted on a file that was closed.
Attempt to read beyond the end of a file.

The content of the file cannot be converted to Unicode.
The character encoding of the file data has errors.

The OS did not allow the attempted operation.

Cannot change the current folder.

Cannot create a folder.

Cannot rename a file or folder.

Cannot delete a file or folder.

Unspecified I/0 error.

Setting the file size failed.

Opening of a file failed.

Closing a file failed.

Reading from a file failed.

Writing to a file failed.

Seek failure.

Unable to execute the specified file.




CHAPTER 3: File System Access File- and Folder-supported encoding names 45

The following list of names is a basic set of encoding names supported by the rFile object. Some of the
character encoders are built in, while the operating system is queried for most of the other encoders.
Depending on the language packs installed, some of the encodings may not be available. Names that refer
to the same encoding are listed in one line. Underlines are replaced with dashes before matching an
encoding name.

The File object processes an extended Unicode character with a value greater that 65535 as a Unicode
surrogate pair (two characters in the range between 0xD700-0xDFFF).

Built-in encodings are:

US-ASCII, ASCII,IS0646-US,I SO-646.IRV:1991, ISO-IR-6,
ANSI-X3.4-1968,CP367,IBM367,US,I1IS0646.1991-IRV
UCS-2,UCs2, ISO-10646-UCS-2

UCS2LE,UCS-2LE, IS0-10646-UCS-2LE

UCS2BE,UCS-2BE, ISO-10646-UCS-2BE

UCS-4,UCS4, ISO-10646-UCS-4

UCS4LE,UCS-4LE, IS0O-10646-UCS-4LE

UCS4BE,UCS-4BE, IS0O-10646-UCS-4BE
UTF-8,UTF8,UNICODE-1-1-UTF-8,UNICODE-2-0-UTF-8,X-UNICODE-2-0-UTF-8
UTF1l6,UTF-16,1S0-10646-UTF-16

UTF16LE,UTF-16LE, ISO-10646-UTF-16LE

UTF16BE,UTF-16BE, ISO-10646-UTF-16BE
CP1252,WINDOWS-1252,MS-ANSI
ISO-8859-1,1IS0-8859-1,IS0-8859-1:1987,IS0-IR-100,LATIN1
MACINTOSH, X-MAC-ROMAN

BINARY

The ASCIl encoder raises errors for characters greater than 127, and the BINARY encoder simply converts
between bytes and Unicode characters by using the lower 8 bits. The latter encoder is convenient for
reading and writing binary data.

In Windows, all encodings use code pages, which are assigned numeric values. The usual Western
character set that Windows uses, for example, is the code page 1252. You can select Windows code pages
by prepending the number of the code page with “CP” or “WINDOWS": for example, “CP1252" for the code
page 1252.The File object has many other built-in encoding names that match predefined code page
numbers. If a code page is not present, the encoding cannot be selected.

In Mac OS, you can select encoders by name rather than by code page number. The File object queries
Mac OS directly for an encoder. As far as Mac OS character sets are identical with Windows code pages,
Mac OS also knows the Windows code page numbers.

In UNIX, the number of available encoders depends on the installation of the iconv library.
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Common encoding hames
The following encoding names are implemented both in Windows and in Mac OS:

UTF-7,UTF7,UNICODE-1-1-UTF-7,X-UNICODE-2-0-UTF-7
IS0-8859-2,1I50-8859-2,1I50-8859-2:1987,ISO-IR-101,LATIN2
ISO-8859-3,1IS0-8859-3,1IS0-8859-3:1988,IS0-IR-109,LATIN3
ISO-8859-4,I50-8859-4,1I50-8859-4:1988,IS0O-IR-110,LATIN4,BALTIC
ISO-8859-5,I50-8859-5,1I50-8859-5:1988,IS0-IR-144,CYRILLIC
ISO-8859-6,1I50-8859-6,150-8859-6:1987,ISO-IR-127,ECMA-114,ASMO-708,ARABIC
I50-8859-7,150-8859-7,150-8859-7:1987,IS0O-IR-126,ECMA-118,ELOT-928,GREEKS8, GREEK
ISO-8859-8,1IS0-8859-8,I5S0-8859-8:1988,IS0O-IR-138,HEBREW
ISO-8859-9,IS0-8859-9,IS0-8859-9:1989,IS0-IR-148, LATINS, TURKISH
ISO-8859-10,IS0-8859-10,IS0-8859-10:1992,IS0O-IR-157,LATING
ISO-8859-13,I80-8859-13,IS0O-IR-179,LATIN7Y
ISO-8859-14,1IS0-8859-14,1IS0-8859-14,IS0-8859-14:1998,IS0O-IR-199,LATINS
ISO-8859-15,1IS0-8859-15,1IS0-8859-15:1998,IS0O-IR-203
ISO-8859-16,1IS0-885,1S0-885,MS-EE

CP850, WINDOWS-850, IBM850

CP866, WINDOWS-866, IBM866
CP932,WINDOWS-932,8JIS,SHIFT-JIS,X-SJIS,X-MS-SJIS,MS-SJIS,MS-KANJI
CP936,WINDOWS-936,GBK, WINDOWS-936,GB2312,GB-2312-80,ISO-IR-58, CHINESE
CP949,WINDOWS-949,UHC,KSC-5601,KS-C-5601-1987,KS-C-5601-1989,ISO-IR-149, KOREAN
CP950, WINDOWS-950,BIG5,BIG-5,BIG-FIVE,BIGFIVE,CN-BIG5,X-X-BIG5
CP1251,WINDOWS-1251,MS-CYRL

CP1252,WINDOWS-1252,MS-ANSI

CP1253,WINDOWS-1253,MS-GREEK

CP1254 ,WINDOWS-1254,MS-TURK

CP1255,WINDOWS-1255, MS-HEBR

CP1256,WINDOWS-1256,MS-ARAB

CP1257,WINDOWS-1257, WINBALTRIM

CP1258, WINDOWS-1258

CP1361,WINDOWS-1361, JOHAB

EUC-JP, EUCJP, X-EUC-JP

EUC-KR, EUCKR, X-EUC-KR

HZ,HZ-GB-2312

X-MAC-JAPANESE

X-MAC-GREEK

X-MAC-CYRILLIC

X-MAC-LATIN

X-MAC-ICELANDIC

X-MAC-TURKISH

Additional Windows encoding names

CP437,IBM850, WINDOWS-437
CP709,WINDOWS-709,ASMO-449,BCONV4
EBCDIC

KOI-8R

KOI-8U

IS0-2022-JP

IS0-2022-KR
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Additional Mac OS encoding names
These names are alias names for encodings that Mac OS might know.

TIS-620,TIS620,TIS620-0,TIS620.2529-1,TIS620.2533-0,TIS620.2533-1,IS0-IR-166
CP874,WINDOWS-874

JP,JIS-C6220-1969-RO,IS0646-JP,ISO-IR-14
JIS-X0201,JI8X0201-1976,X0201
JIS-X0208,JIS-X0208-1983,JI5-X0208-1990,JIS0208,X0208,ISO-IR-87
JIS-X0212,JIS-X0212.1990-0,JI8-X0212-1990,X0212,ISO-IR-159
CN,GB-1988-80,1I50646-CN, ISO-IR-57

ISO-IR-16,CN-GB-ISOIR165
KSC-5601,KS-C-5601-1987,KS-C-5601-1989,ISO-IR-149
EUC-CN, EUCCN, GB2312,CN-GB

EUC-TW, EUCTW, X-EUC-TW

UNIX encodings

In UNIX, the File object looks for the presence of the iconv library, and uses whatever encoding it finds
there. If you need a special encoding in UNIX, make sure that there is an iconv encoding module installed
that converts between UTF-16 (the internal format that the File object uses) and the desired encoding.

Represents a file in the local file system in a platform-independent manner. All properties and methods
resolve file system aliases automatically and act on the original file unless otherwise noted.

To create a File object, use the File function or the new operator. The constructor accepts full or partial
path names, and returns the new object. The CRLF sequence for the file is preset to the system default, and
the encoding is preset to the default system encoding.

File ([path]); //can return a Folder object
new File ([path]); //always returns a File object

path Optional. The absolute or relative path to the file associated with this object, specified in
platform-specific or URI format; see “Specifying paths” on page 39. The value stored in the
object is the absolute path.

The path need not refer to an existing file. If not supplied, a temporary name is generated.
If the path refers to an existing folder:
» TheFile function returns a Folder object instead of a File object.

» The new operator returns a File object for a nonexisting file with the same name.
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This property is available as a static property of the File class. It is not necessary to create an instance to
access it.

fs String  The name of the file system. Read only. One of windows, Macintosh, Or Unix.

These functions are available as static methods of the File class. It is not necessary to create an instance to
call them.

decode ()
File.decode (uri)

uri String. The encoded string to decode. All special characters must be encoded in
UTF-8 and stored as escaped characters starting with the percent sign followed by
two hexadecimal digits. For example, the string "my%20file" is decoded as "my
file"

Special characters are those with a numeric value greater than 127, except the
following:

/- ekt ()

Decodes the specified string as required by RFC 2396.

Returns the decoded string.

encode ()
File.encode (name)

name String. The string to encode.

Encodes the specified string as required by RFC 2396. All special characters are encoded in UTF-8
and stored as escaped characters starting with the percent sign followed by two hexadecimal digits.
For example, the string "my file" is encoded as "my%20file"

Special characters are those with a numeric value greater than 127, except the following:
/- b~ ()

Returns the encoded string.

isEncodingAvailable()
File.isEncodingAvailable (name)

name String. The encoding name. Typical values are “ASCII,” “binary,” or “UTF-8." See “File-
and Folder-supported encoding names” on page 45.

Checks whether a given encoding is available.

Returns true if your system supports the specified encoding, false otherwise.
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openDialog ()

File.openDialog ([prompt, filter, multiSelect])

prompt

filter

multiSelect

Optional. A string containing the prompt text, if the dialog allows a prompt.

Optional. A filter that limits the types of files displayed in the dialog.

» In Windows, a filter expression, such as "JavaScript:*.3jsx;All files:*.*"

» In Mac OS, afilter function that takes a File instance and returns true if the file
should be included in the display, false if it should not.

Optional. Boolean. When true, the user can select multiple files and the return
value is an array. Default is false.

Opens the built-in platform-specific file-browsing dialog in which a user can select an existing file or
multiple files, and creates new File objects to represent the selected files.

If the user clicks OK, returns a File object for the selected file, or an array of objects if multiple files
are selected. If the user cancels, returns nul1l.

saveDialog ()

File.saveDialog (prompt[, preset])

prompt

filter

A string containing the prompt text, if the dialog allows a prompt.

Optional, in Windows only. A filter that limits the types of files displayed in the
dialog. A filter expression, such as "JavaScript:*.jsx;All files:*.*n"

Not used in Mac OS.

Opens the built-in platform-specific file-browsing dialog in which a user can select an existing file
location to which to save information, and creates a new File object to represent the selected file

location.

If the user clicks OK, returns a File object for the selected file location. If the user cancels, returns

null.

These properties are available for File objects.

absoluteURI
alias

created

creator

displayName

String
Boolean

Date

String

String

The full path name for the referenced file in URI notation. Read only.
When true, the object refers to a file system alias or shortcut. Read only.

The creation date of the referenced file, or nu11 if the object does not
refer to a file on disk. Read only.

In Mac OS, the file creator as a four-character string. In Windows or UNIX,
value is "2222". Read only.

The localized name of the referenced file, without the path. Read only.
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encoding

eof

error

exists

fsName

fullName

hidden

length

lineFeed

localizedName

modified

name

parent

path

readonly

String

Boolean

String

Boolean

String

String

Boolean

Number

String

String

Date

String

Folder

String

Boolean

Gets or sets the encoding for subsequent read/write operations. One of
the encoding constants listed in “File- and Folder-supported encoding
names” on page 45. If the value is not recognized, uses the system
default encoding.

A special encoder, BINARY, is used to read binary files. It stores each byte
of the file as one Unicode character regardless of any encoding. When
writing, the lower byte of each Unicode character is treated as a single
byte to write.

When true, a read attempt caused the current position to be at the end of
the file, or the file is not open. Read only.

A message describing the last file system error; see “File access error
messages” on page 44. Typically set by the file system, but a script can set
it. Setting this value clears any error message and resets the error bit for
opened files. Contains the empty string if there is no error.

When true, this object refers to a file or file-system alias that actually
exists in the file system. Read only.

The platform-specific full path name for the referenced file. Read only.
The full path name for the referenced file in URI notation. Read only.

When true, the file is not shown in the platform-specific file browser.
Read/write. If the object references a file-system alias or shortcut, the flag
is altered on the alias, not on the original file.

The size of the file in bytes. Can be set only for a file that is not open, in
which case it truncates or pads the file with 0-bytes to the new length.

How line feed characters are written in the file system. One of:

Windows — Windows style
Macintosh — Mac OS style
unix — UNIX style

A localized version of the file name portion of the absolute URI for the
referenced file, without the path specification. Read only.

The date of the referenced file’s last modification, or nul1 if the object
does not refer to a file on disk. Read only.

The file name portion of the absolute URI for the referenced file, without
the path specification. Read only.

The Folder object for the folder that contains this file. Read only.

The path portion of the absolute URI for the referenced file, without the
file name. Read only.

When true, prevents the file from being altered or deleted. If the
referenced file is a file-system alias or shortcut, the flag is altered on the
alias, not on the original file.
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relativeURI String The path name for the referenced file in URI notation, relative to the
current folder. Read only.

type String The file type as a four-character string.
» In Mac OS, the Mac OS file type.

» InWindows, "appl" for .EXE files, "shib" for .DLL files and "TEXT"
for any other file.

If the file does not exist, the value is "2222". Read only.

These functions are available for File objects.

changePath ()
fileObj.changePath (path)

path A string containing the new path, absolute or relative to the current folder.
Changes the path specification of the referenced file.

Returns true on success.

close()
fileObj.close ()

Closes this open file.

Returns true on success, false if there are 1/0 errors.

copy ()
fileObj.copy (target)

target A string with the URI path to the target location, or a File object that references the
target location.

Copies this object’s referenced file to the specified target location. Resolves any aliases to find the
source file. If a file exists at the target location, it is overwritten.

Returns true if the copy was successful, false otherwise.

createAlias ()
fileObj.createAlias (pathl])

path A string containing the path of the target file.

Makes this file a file-system alias or shortcut to the specified file. The referenced file for this object
must not yet exist on disk.

Returns true if the operation was successful, false otherwise.
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execute ()

fileObj.execute

0

Opens this file using the appropriate application, as if it had been double-clicked in a file browser.
You can use this method to run scripts, launch applications, and so on.

Returns true immediately if the application launch was successful.

getRelativeURI ()

fileObj.getRelativeURI ([basePath])

basePath

Optional. A string containing the base path for the relative URI. Default is the current
folder.

Retrieves the URI for this file, relative to the specified base path, in URI notation. If no base path is
supplied, the URI is relative to the path of the current folder.

Returns a string containing the relative URI.

open ()

fileObj.open (model, typel [, creator])

mode

type

creator

A string indicating the read/write mode. One of:

» r:(read) Opens for reading. If the file does not exist or cannot be found, the call
fails.

» w: (write) Opens a file for writing. If the file exists, its contents are destroyed. If
the file does not exist, creates a new, empty file.

P> e:(edit) Opens an existing file for reading and writing.

» a:(append) Opens the file in Append mode, and moves the current position to
the end of the file.

Optional. In Mac OS, the type of a newly created file, a 4-character string. Ignored in
Windows and UNIX.

Optional. In Mac OS, the creator of a newly created file, a 4-character string. Ignored
in Windows and UNIX.

Opens the referenced file for subsequent read/write operations. The method resolves any aliases to

find the file.

Returns true if the file has been opened successfully, false otherwise.

The method attempts to detect the encoding of the open file. It reads a few bytes at the current
location and tries to detect the Byte Order Mark character oxFFFE. If found, the current position is
advanced behind the detected character and the encoding property is set to one of the strings
UCS-2BE, UCS-2LE, UCS4-BE, UCS-4LE, or UTF- 8. If the marker character is not found, it checks for
zero bytes at the current location and makes an assumption about one of the above formats (except
UTF-8). If everything fails, the encoding property is set to the system encoding.

NoTE: Be careful about opening a file more than once. The operating system usually permits you to
do so, but if you start writing to the file using two different File objects, you can destroy your data.



CHAPTER 3: File System Access File object 53

openDlg ()
fileObj.OpenDlg ([prompt] [, filter] [,multiSelect])

prompt Optional. A string containing the prompt text, if the dialog allows a prompt.
filter Optional. A filter that limits the types of files displayed in the dialog.
» In Windows, a filter expression, such as "JavaScript:*.jsx;All files:*. *"

» In Mac OS, afilter function that takes a File instance and returns true if the file
should be included in the display, false if it should not.

multiSelect Optional. Boolean. When true, the user can select multiple files and the return value
is an array. Default is false.

Opens the built-in platform-specific file-browsing dialog, in which the user can select an existing file
or files, and creates new File objects to represent the selected files. Differs from the class method

openDialog () inthatit presets the current folder to this File object’s parent folder and the current
file to this object’s associated file.

If the user clicks OK, returns a File or Folder object for the selected file or folder, or an array of
objects. If the user cancels, returns nu11.

read()
fileObj.read ([chars])

chars Optional. An integer specifying the number of characters to read. By default, reads
from the current position to the end of the file. If the file is encoded, multiple bytes
might be read to create single Unicode characters.

Reads the contents of the file starting at the current position.

Returns a string that contains up to the specified number of characters.

readch ()
fileObj.readch ()

Reads a single text character from the file at the current position. Line feeds are recognized as Cr, LF,
CRLF, or LFCR pairs. If the file is encoded, multiple bytes might be read to create single Unicode
characters.

Returns a string that contains the character.

readln ()
fileObj.readln ()

Reads a single line of text from the file at the current position, and returns it in a string. Line feeds
are recognized as CR, LF, CRLF, or LFCR pairs. If the file is encoded, multiple bytes might be read to
create single Unicode characters.

Returns a string that contains the text.
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remove ()
fileObj.remove ()

Deletes the file associated with this object from disk, immediately, without moving it to the system
trash. Does not resolve aliases; instead, deletes the referenced alias or shortcut file itself.

NoTE: Cannot be undone. It is recommended that you prompt the user for permission before
deleting.

Returns true if the file is deleted successfully.

rename ()
fileObj.rename (newhName)

newName The new file name, with no path.

Renames the associated file. Does not resolve aliases, but renames the referenced alias or shortcut
file itself.

Returns true on success.

resolve()
fileObj.resolve ()

If this object references an alias or shortcut, this method resolves that alias and returns a new rFile
object that references the file-system element to which the alias resolves.

Returns the new File object, or null if this object does not reference an alias, or if the alias cannot
be resolved.

saveDlg ()
fileObj.saveDlg ([prompt] [, preset])

prompt Optional. A string containing the prompt text, if the dialog allows a prompt.

preset Optional, in Windows only. A filter that limits the types of files displayed in the
dialog. A filter expression, such as "JavaScript:*.jsx;All files:*.*"

Not used in Mac OS.

Opens the built-in platform-specific file-browsing dialog, in which the user can select an existing file
location to which to save information, and creates a new File object to represent the selected file.

Differs from the class method saveDialog () in that it presets the current folder to this File object’s
parent folder and the file to this object’s associated file.

If the user clicks OK, returns a File object for the selected file. If the user cancels, returns nul1.
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seek ()
fileObj.seek (pos[, mode])

pos The new current position in the file as an offset in bytes from the start, current
position, or end, depending on the mode.

mode Optional. The seek mode, one of:

» 0:Seek to absolute position, where pos=0 is the first byte of the file. This is the
default.

» 1:Seekrelative to the current position.
» 2:Seek backward from the end of the file.

Seeks to the specified position in the file. The new position cannot be less than 0 or greater than the
current file size.

Returns true if the position was changed.

tell()
fileObj.tell ()

Retrieves the current position as a byte offset from the start of the file.

Returns a number, the position index.

write()
fileObj.write (text[, text...l...)

text One or more strings to write, which are concatenated to form a single string.

Writes the specified text to the file at the current position. For encoded files, writing a single
Unicode character may write multiple bytes.

NoTE: Be careful not to write to a file that is open in another application or object, as this can
overwrite existing data.

Returns true on success.

writeln ()
fileObj.writeln (text[, text...]l...)

text One or more strings to write, which are concatenated to form a single string.

Writes the specified text to the file at the current position, and appends a Line Feed sequence in the
style specified by the 1inefeed property.For encoded files, writing a single Unicode character may
write multiple bytes.

NorTE: Be careful not to write to a file that is open in another application or object, as this can
overwrite existing data.

Returns true on success.
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Represents a file-system folder or directory in a platform-independent manner. All properties and
methods resolve file system aliases automatically and act on the original file unless otherwise noted.

To create a Folder object, use the Folder function or the new operator. The constructor accepts full or
partial path names, and returns the new object.

Folder (I[pathl); //can return a File object
new Folder ([pathl); //always returns a Folder object

path Optional. The absolute or relative path to the folder associated with this object, specified in URI
format; see “Specifying paths” on page 39. The value stored in the object is the absolute path.

The path need not refer to an existing folder. If not supplied, a temporary name is generated.
If the path refers to an existing file:
» The Folder function returns a File object instead of a Folder object.

» The new operator returns a Folder object for a nonexisting folder with the same name.

These properties are available as static properties of the Folder class. It is not necessary to create an
instance to access them.

appData Folder A Folder object forthe folder that contains application data for all users. Read
only.

» In Windows, the value of sappDATAS (by default, ¢: \Documents and
Settings\All Users\Application Data)

» InMacOS, /Library/Application Support

appPackage String  In Mac OS, the Folder object for the folder that contains the bundle of the
running application. Read only.

commonFiles  Folder A Folder object for the folder that contains files common to all programs.
Read only.

» In Windows, the value of $commonProgramFiless (by default,
C:\Program Files\Common Files)

» InMacOS,/Library/Application Support

current Folder A Folder object for the current folder. Assign either a Folder objector a
string containing the new path name to set the current folder.
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desktop

fs

myDocuments

startup

system

temp

trash

userData

Folder

String
Folder

Folder

Folder

Folder
Folder

Folder

A Folder object for the folder that contains the user’s desktop. Read only.

» InWindows, C:\Documents and Settings\username\Desktop

» InMacOS, ~/Desktop

The name of the file system. Read only. One of windows, Macintosh, Or Unix.
A Folder object for the user’s default document folder. Read only.

» InWindows, C:\Documents and Settings\username\My Documents
» InMacOS, ~/Documents

A Folder object for the folder containing the executable image of the running
application. Read only.

A Folder object for the folder containing the operating system files. Read
only.

» In Windows, the value of swindir% (by default, c: \Windows)

» InMacOS, /system

A Folder object for the default folder for temporary files. Read only.

» InMacOS, a Folder object for the folder containing deleted items.

» InWindows, where the Recycle Bin is a database rather than a folder, value
isnull.

Read only.

A Folder object for the folder that contains application data for the current
user. Read only.

» In Windows, the value of sUSERDATA% (by default, C: \Documents and
Settings\username\Application Data)

» InMacOS, ~/Library/Application Support




CHAPTER 3: File System Access Folder object 58

These functions are available as a static methods of the Folder class. It is not necessary to create an
instance in order to call them.

decode ()
Folder.decode (uri)

uri String. The encoded string to decode. All special characters must be encoded in UTF-8
and stored as escaped characters starting with the percent sign followed by two
hexadecimal digits. For example, the string "my%20file" is decoded as "my file".

Special characters are those with a numeric value greater than 127, except the following:
/- o b=x ()
Decodes the specified string as required by RFC 2396.

Returns the decoded string.

encode ()
Folder.encode (name)

name String. The string to encode.

Encodes the specified string as required by RFC 2396. All special characters are encoded in UTF-8
and stored as escaped characters starting with the percent sign followed by two hexadecimal digits.
For example, the string "my file" is encoded as "my%20file™.

Special characters are those with a numeric value greater than 127, except the following:
/- _ b~ x o ()

Returns the encoded string.

isEncodingAvailable()
Folder.isEncodingAvailable (name)

name String. The encoding name. Typical values are “ASCIl," “binary,” or “UTF-8." See “File- and
Folder-supported encoding names” on page 45.

Checks whether a given encoding is available.

Returns true if your system supports the specified encoding, false otherwise.

selectDialog()
Folder.selectDialog ([prompt])

prompt  Optional. A string containing the prompt text, if the dialog allows a prompt.

Opens the built-in platform-specific file-browsing dialog, and creates a new File or Folder object
for the selected file or folder. Differs from the object method selectDlg () in that it does not
preselect a folder.

If the user clicks OK, returns a File or Folder object for the selected file or folder. If the user
cancels, returns null.
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absoluteURI
alias

created

displayName

error

exists

fsName

fullName

localizedName

modified

name

parent

path

relativeURI

String
Boolean

Date

String
String

Boolean

String

String
String

Date

String

Folder

String

String

The full path name for the referenced folder in URI notation. Read only.
When true, the object refers to a file system alias or shortcut. Read only.

The creation date of the referenced folder, or nul1 if the object does not
refer to a folder on disk. Read only.

The localized name of the referenced folder, without the path. Read only.

A message describing the most recent file system error; see “File access
error messages” on page 44. Typically set by the file system, but a script
can set it. Setting this value clears any error message and resets the error
bit for opened files. Contains the empty string if there is no error.

When true, this object refers to a folder that currently exists in the file
system. Read only.

The platform-specific name of the referenced folder as a full path name.
Read only.

The full path name for the referenced folder in URI notation. Read only.

A localized version of the folder name portion of the absolute URI for the
referenced file, without the path specification. Read only.

The date of the referenced folder’s last modification, or nu11 if the object
does not refer to a folder on disk. Read only.

The folder name portion of the absolute URI for the referenced file,
without the path specification. Read only.

The Folder object for the folder that contains this folder, or nu11 if this
object refers to the root folder of a volume. Read only.

The path portion of the absolute URI for the referenced folder, without the
folder name. Read only.

The path name for the referenced folder in URI notation, relative to the
current folder. Read only.

These functions are available for Folder objects.

changePath ()

folderObj.changePath (path)

path

A string containing the new path, absolute or relative to the current parent folder.

Changes the path specification of the referenced folder.

Returns true on success.
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create()
folderObj.create ()

Creates a folder at the location given by this object’s path property.

Returns true if the folder was created successfully.

execute ()
folderObj.execute ()

Opens this folder in the platform-specific file browser (as if it had been double-clicked in the file
browser).

Returns true immediately if the folder was opened successfully.

getFiles ()
folderObj.getFiles ([mask])

mask Optional. A search mask for file names. A string that can contain question mark (?) and
asterisk (*) wild cards. Default is "+, which matches all file names.

Can also be the name of a function that takes a File or Folder object as its argument.
Itis called for each file or folder found in the search; if it returns true, the object is added
to the return array.

NoOTE: In Windows, all aliases end with the extension . 1nk; ExtendScript strips this from
the file name when found, in order to preserve compatibility with other operating
systems. You can search for all aliases by supplying the search mask "* . 1nk", but note
that such code is not portable.

Retrieves the contents of this folder, filtered by the supplied mask.

Returns an array of File and Folder objects, or null if this object’s referenced folder does not exist.

getRelativeURI ()
folderObj.getRelativeURI ([basePath])

basebPath Optional. A string containing the base path for the relative URI. Default is the current
folder.

Retrieves the path for this folder relative to the specified base path or the current folder, in URI
notation.

Returns a string containing the relative URI.

remove ()
folderObj.remove ()

Deletes the empty folder associated with this object from disk, immediately, without moving it to
the system trash. Folders must be empty before they can be deleted. Does not resolve aliases;
instead, deletes the referenced alias or shortcut file itself.

NotE: Cannot be undone. It is recommended that you prompt the user for permission before
deleting.

Returns true if the folder is deleted successfully.
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rename ()
folderObj.rename (newName)

newName  The new folder name, with no path.

Renames the associated folder. Does not resolve aliases; instead, renames the referenced alias or
shortcut file itself.

Returns true on success.

resolve ()
folderObj.resolve ()

If this object references an alias or shortcut, this method resolves that alias

Returns a new Folder object that references the file-system element to which the alias resolves, or
null if this object does not reference an alias, or if the alias cannot be resolved.

selectDlg()
folderObj.selectDlg (prompt)

prompt A string containing the prompt text, if the dialog allows a prompt.

Opens the built-in platform-specific file-browsing dialog, and creates a new File or Folder object
for the selected file or folder. Differs from the class method selectbialog () in that it preselects
this folder.

If the user clicks OK, returns a File or Folder object for the selected file or folder. If the user
cancels, returns null.



User-Interface Tools

Adobe provides the ScriptUl component, which works with the ExtendScript JavaScript interpreter to
provide JavaScript scripts with the ability to create and interact with user interface elements. It provides an
object model for windows and user-interface control elements within an Adobe application.

» The first part of this chapter describes the features and programming model, with details of how you
can use JavaScript to build a user interface with ScriptUl objects.

» “ScriptUl object reference” on page 105 provides reference details of the objects, properties, methods,
and creation parameters. You can also choose the ScriptUI Classes dictionary from the Help menu in
the ExtendScript Toolkit to inspect the objects in the Object Model Viewer.

The sample code distributed with the Adobe ExtendScript SDK includes cod