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IaaS Integration for HP Server Automation

IaaS Integration for HP Server Automation provides information about integrating HP Server Automation
with VMware vRealize ™ Automation.

This documentation provides information on how you can use an HP Server Automation boot image or an
HP Server Automation template to provision virtual machines by cloning.

Intended Audience
This information is intended for system administrators, tenant administrators, fabric administrators, and
business group managers of vRealize Automation. This content is written for experienced Windows or
Linux system administrators who are familiar with virtualization technology and the basic concepts
described in Foundations and Concepts.

VMware Technical Publications Glossary
VMware Technical Publications provides a glossary of terms that might be unfamiliar to you. For
definitions of terms as they are used in VMware technical documentation, go to 
http://www.vmware.com/support/pubs.
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Updated Information

This IaaS Integration for HP Server Automation is updated with each release of the product or when
necessary.

This table provides the update history of the IaaS Integration for HP Server Automation.

Revision Description

001844-01 Miscellaneous minor changes.

001844-00 Initial release.
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HP Server Automation Overview 1
You can you can provision virtual machines by using an HP Server Automation boot image or by
provisioning by cloning and using an HP Server Automation template when you
integrateHP Server Automation with vRealize Automation.

You can optionally identify the HP Server Automation policies to make available in vRealize Automation.
Machine requestors can select from among these policies to install software on the requested machine,
or you can specify HP Server Automation policies in the blueprint to be applied to every machine that is
provisioned from that blueprint.

Integration Requirements Overview
The following is a high-level overview of the requirements for integrating HP Server Automation with
vRealize Automation:

n A system administrator installs Microsoft PowerShell on the installation host prior to installing the
agent.

The required version of Microsoft PowerShell depends on the operating system of the installation host
and might have been installed with that operating system. See Microsoft Help and Support.

n A system administrator installs the HP Server Automation snap-in on at least one host for
vRealize Automation external provisioning integration (EPI) installation. See Chapter 2 Install the HP
Server Automation PowerShell Snap-In.

n A system administrator sets the PowerShell execution policy to RemoteSigned. See Set the
PowerShell Execution Policy to RemoteSigned.

n A system administrator installs at least one EPI agent. See Chapter 3 Install an EPI Agent for HP
Server Automation.

n A system administrator sets up the selected integration method. See Chapter 5 Integrating HP Server
Automation.

n A system administrator enables software installation from HP Server Automation. See Chapter 6
Enable vRealize Automation Software Installation from HP Server Automation.

n A tenant administrator or a business group manager creates a blueprint that enables the deployment
of software jobs. See Chapter 7 Creating Blueprints for HP Server Automation.
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n A tenant administrator or a business group manager publishes the blueprint. See Chapter 9 Publish a
Blueprint.
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Install the
HP Server Automation
PowerShell Snap-In 2
The HP Server Automation snap-in must be installed on at least one host for vRealize Automation
external provisioning integration (EPI) installation prior to installing the EPI agent.

Prerequisites

n Obtain the HP Server Automation Snap-in software from the HP Server Automation installation
media.

n Log in to the vRealize Automation console as a system administrator.

Procedure

1 Click Start, right-click Command Prompt, and click Run as administrator.

2 Change to the directory that contains the PowerShell snap-in.

3 Type msiexec /i OPSWpowershell-37.0.0.5-0.msi.

4 Complete the installation by accepting all defaults.

5 Select Start > All Programs > Windows Power- Shell 1.0 > Windows PowerShell.

6 Type Add-PSSnapin 'OpswareSasPs'.

7 Type Exit.

Set the PowerShell Execution Policy to RemoteSigned
You must set the PowerShell Execution Policy from Restricted to RemoteSigned or Unrestricted to allow
local PowerShell scripts to run.

n For more information about PowerShell Execution Policy, type help about_signing or
help Set-ExecutionPolicy at the PowerShell command prompt.

Prerequisites

n Log in as a Windows administrator.

n Chapter 2 Install the HP Server Automation PowerShell Snap-In.

Procedure

1 Select Start > All Programs > Windows PowerShell version > Windows PowerShell.
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2 Type Set-ExecutionPolicy RemoteSigned to set the policy to RemoteSigned.

3 Type Set-ExecutionPolicy Unrestricted to set the policy to Unrestricted.

4 Type Get-ExecutionPolicy to verify the current settings for the execution policy.

5 Type Exit.

IaaS Integration for HP Server Automation
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Install an EPI Agent for
HP Server Automation 3
A system administrator must install at least one vRealize Automation EPI agent to manage interaction
with HP Server Automation. The agent can be installed anywhere, including the vRealize Automation
server or the HP Server Automation server, as long as the agent can communicate with both servers.

Prerequisites

n Verify that the HP Server Automation PowerShell Snap-in is installed on the same host as your EPI
agent. If the EPI agent is installed before the snap-in, then the agent service must be restarted after
the snap-in is installed. See Chapter 2 Install the HP Server Automation PowerShell Snap-In.

n The agent must be installed on Windows Server 2008 SP1, Windows Server 2008 SP2 (32 or 64-bit),
Windows Server 2008 R2 system, or Windows 2012 with .NET 4.5.

n The credentials of the agent must have administrative access to all HP Server Automation hosts with
which the agent will interact.

n Install the IaaS components, including the Manager Service and Website.

n See Installing vRealize Automation 7.0 for complete information about installing vRealize Automation
agents.

n Log in to the vRealize Automation console as a system administrator.

Procedure

1 Select Custom Install and Proxy Agent on the Installation Type page.

2 Accept the root install location or click Change and select an installation path.

3 Click Next.

4 Log in with administrator privileges for the Windows services on the installation machine.

The service must run on the same installation machine.

5 Click Next.

6 Select EPIPowerShell from the Agent type list.
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7 Enter an identifier for this agent in the Agent name text box.

Maintain a record of the agent name, credentials, endpoint name, and platform instance for each
agent. You need this information to configure endpoints and to add hosts in the future.

Important   Do not duplicate agent names unless you are installing redundant, identically configured
agents for high availability.

Option Description

Redundant agent install Install redundant agents on different servers, but name and configure them
identically to provide high-availability.

Single agent install Select a unique name for this agent.
 

8 Configure a connection to the Manager Service component.

Option Description

If you are using a load balancer Enter the fully qualified domain name and port number of the load balancer for the
Manager Service component. For example,
manager-load-balancer.eng.mycompany.com:443. IP addresses are not
recognized.

With no load balancer Enter the fully qualified domain name and port number of the machine where you
installed the Manager Service component. For example,
manager_service.mycompany.com:443. IP addresses are not recognized.

 
The default port is 443.

9 Configure a connection to the Manager Website component.

Option Description

If you are using a load balancer Enter the fully qualified domain name and port number of the load balancer for the
Manager Website component. For example,
website-load-balancer.eng.mycompany.com:443. IP addresses are not
recognized.

With no load balancer Enter the fully qualified domain name and port number of the machine where you
installed the Manager Website component. For example,
website_component.mycompany.com:443. IP addresses are not recognized.

 
The default port is 443.

10 Click Test to verify connectivity to each host.

11 Click Opsware in EPI Type.

12 Type the fully qualified domain name of the managed server in the EPI Server text box.

Optionally, you can leave this blank to let the agent interact with multiple hosts.

The HP Server Automation server with which the agent interacts when provisioning a machine by
using HP Server Automation depends on the value of the required custom property,
EPI.Server.Name, in the blueprint.

IaaS Integration for HP Server Automation
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Therefore, if you install a dedicated EPI agent by specifying an HP Server Automation server name
during installation, only machines whose EPI.Server.Name property exactly matches the server
name configured for the agent can be provisioned by that server.

If you install a general EPI agent by not specifying an HP Server Automation server name during
installation, a machine can be provisioned by any server specified in the blueprint EPI.Server.Name
property, that is assuming the agent can contact that server.

Note   If no matching agent can be found, or there are no agents with unspecified server values,
Opsware provisioning will wait until a suitable agent is found.

13 Click Add.

14 Click Next.

15 Click Install to begin the installation.

After several minutes a success message appears.

16 Click Next.

17 Click Finish.

What to do next

Determine the type of integration method to use. See Chapter 5 Integrating HP Server Automation.

IaaS Integration for HP Server Automation
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Extend the Default Software
Installation Timeout 4
When you install the software for the integration product, the software might take longer to install than the
default 30-minute timeout. You can increase the default timeout to a value that allows the installation to
finish.

Procedure

1 Navigate to the Manager Service installation directory. Typically, this is %System-Drive%\Program
Files x86\VMware\vCAC\Server.

2 Create a backup of the ManagerService.exe.config file.

3 Open the ManagerService.exe.config file and locate the
workflowTimeoutConfigurationSection element and increase the value of the DefaultTimeout
attribute from 30 minutes to your desired limit.

4 Click Save and close the file.

5 Select Start > Administrative Tools > Services, and restart the vRealize Automation service.
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Integrating
HP Server Automation 5
The steps required to integrate HP Server Automation with vRealize Automation depend on which
provisioning method you want to use and whether you want to enable software installation from
HP Server Automation.

When provisioning virtual machines, you can select from the following integration methods:

n Provision by using a system from which HP Server Automation deploys images that is available on
the network.

n Provision by cloning by using a template that is prepared for HP Server Automation.

You can optionally identify the HP Server Automation policies to make available in vRealize Automation.
Machine requestors can select from among these policies to install software on the requested machine,
or you can specify HP Server Automation policies in the blueprint to be applied to every machine that is
provisioned from that blueprint.

This chapter includes the following topics:

n Enable Provisioning from HP Server Automation Boot Images

n Preparing an HP Server Automation Template for Cloning

Enable Provisioning from HP Server Automation Boot
Images
A system administrator can use an HP Server Automation boot image to enable vRealize Automation to
provision machines by using that instance of HP Server Automation.

Prerequisites

n A system from which HP Server Automation deploys images is available on the network.

n An EPI agent installed. See Chapter 3 Install an EPI Agent for HP Server Automation.

n Log in to the vRealize Automation console as a system administrator.

Procedure

1 On the EPI/Opsware Agent host, select Start > Administrative Tools > Services, and stop the
vRealize Automation EPI/Opsware Agent.
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2 On the EPI agent installation host, which may be the same as the Manager Service host, change to
the EPI agent installation directory, typically %SystemDrive%\Program Files (x86)\VMware\vCAC
Agents\agent_name.

3 Edit the agent configuration file, VRMAgent.exe.config, in the EPI agent installation directory.

a Locate the following line.

<DynamicOps.Vrm.Agent.EpiPowerShell

registerScript="CitrixProvisioningRegister.ps1"

unregisterScript="CitrixProvisioningUnregister.ps1"/>

b Change the line to match the following line.

<DynamicOps.Vrm.Agent.EpiPowerShell

registerScript="CreateMachine.ps1"

unregisterScript="DisposeVM.ps1"/>

4 Create an HP SA password file in the Scripts folder.

The credentials you provide for this file must have administrator access to all instances of HP SA with
which the agent will interact.

a Select Start > All Programs > Windows Power- Shell 1.0 > Windows PowerShell.

b Change to the Scripts directory.

c Type \CreatePasswordFile.ps1 username.

d Type the password when prompted.

e Type Exit.

5 On the vRealize Automation EPI/Opsware Agent host, select Start > Administrative Tools >
Services, and then start or restart the vRealize Automation EPI/Opsware Agent service.

Preparing an HP Server Automation Template for Cloning
You can use an HP Server Automation template to integrate with vRealize Automation.

To create the HP Server Automation template, you must create a reference machine and add
customization specifications to it.

For Windows, see Prepare a Reference Machine for Windows.

For Linux, see Prepare a Reference Machine for Linux.

Prepare a Reference Machine for Linux
You must prepare a reference machine and convert it to a template for cloning to add software installation
by HP Server Automation to provisioning by cloning.

IaaS Integration for HP Server Automation

VMware, Inc.  15



Procedure

1 Add the HP Server Automation agent installation package to the cloning template.

2 Copy the HP Server Automation agent installer to the reference machine.

3 Create a script to run the installer and install the HP Server Automation agent.

4 Copy the script to the reference machine.

5 Add the customization required to invoke the agent after provisioning, so that the agent is installed on
each cloned machine.

Note   Do not install HP Server Automation on the reference machine. The agent must be installed by
using the customization specification or postinstall script following cloning.

What to do next

n Optionally, identify the HP Server Automation policies to make available in vRealize Automation. See 
Chapter 6 Enable vRealize Automation Software Installation from HP Server Automation

n Create a blueprint for the type of HP Server Automation integration you want to enable. See 
Chapter 7 Creating Blueprints for HP Server Automation.

Prepare a Reference Machine for Windows
You must prepare a reference machine and convert it to a template for cloning before you can add
software installation by HP Server Automation to provisioning by cloning.

Procedure

1 Add the HP Server Automation agent installation package to the cloning template.

2 Copy the HP Server Automation agent installer to the C:\ directory of the reference machine.

3 Add the customization required to invoke the agent after provisioning, by adding following line to the
Run Once section of the customization specification.

C:\opswareagentinstaller --opsw_gw_addr opswareipaddress:3001 -s --force_sw_reg 

--force_full_hw_reg

This customization also installs the agent on each cloned machine.

4 Replace opswareagentinstaller with the name of the HP Server Automation agent installer
executable.

IaaS Integration for HP Server Automation
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5 Replace opswareipaddress with the IP address of the server that is hosting the
HP Server Automation instance that installs the software.

For example:

C:\ opsware-agent-37.0.0.2.61-win32-6.0.exe --opsw_gw_addr 10.20.100.52:3001 -s --force_sw_reg --

force_full_hw_reg

What to do next

n Optionally, identify the HP Server Automation policies to make available in vRealize Automation. See 
Chapter 6 Enable vRealize Automation Software Installation from HP Server Automation.

n Create a blueprint for the type of HP Server Automation integration you want to enable. See 
Chapter 7 Creating Blueprints for HP Server Automation.

IaaS Integration for HP Server Automation
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Enable vRealize Automation
Software Installation from
HP Server Automation 6
A system administrator can optionally identify the HP Server Automation policies to make available in
vRealize Automation. Machine requestors can select from among these policies to install software on the
requested machine, or HP Server Automation policies can be specified in the blueprint to be applied to
every machine that is provisioned from that blueprint.

Prerequisites

n An EPI agent installed. See Chapter 3 Install an EPI Agent for HP Server Automation.

n Log in to the vRealize Automation console as a system administrator.

Procedure

1 Open your blueprint in a text editor.

2 Include the custom property in your blueprint

Vrm.Software.IdNNNN=software_policy_name

3 Replace software_policy_name with the name of the policy.

For example where you want to install HP Server Automation Windows ISM Tool, HP Server
Automation Linux ISM Tool, or both, the blueprint might contain the following custom property/value
pairs:

Vrm.Software.Id1000=Windows ISMtool

Vrm.Software.Id1001=RedHatLinux ISMtool

4 Save your changes and close the blueprint file.
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Creating Blueprints for
HP Server Automation 7
The type of blueprint you create depends on how you want to enable HP Server Automation integration.

You need to create a blueprint that includes all of the information required for machine provisioning and
the information required for HP Server Automation integration for either of the following integration
methods:

n Provisioning by using a system from which HP Server Automation deploys images.

n Provisioning by cloning from a template that is prepared for HP Server Automation.

You can optionally identify the HP Server Automation policies to make available in vRealize Automation.
Machine requestors can select from among these policies to install software on the requested machine,
or you can specify HP Server Automation policies in the blueprint to be applied to every machine that is
provisioned from that blueprint.

This chapter includes the following topics:

n Create a Virtual Blueprint for Creating from an HP Server Automation Boot Image

n Create a Blueprint for Cloning from an HP Server Automation Template

Create a Virtual Blueprint for Creating from an
HP Server Automation Boot Image
A tenant administrator or business group manager creates a blueprint for using an HP Server Automation
boot image to deploy HP Server Automation software jobs on machines provisioned from it.

Prerequisites

n Log in to the vRealize Automation console as a tenant administrator or business group manager.

n Obtain the following information from your fabric administrator:
n The name of the HP Server Automation server to be used as the value for the EPI.Server.Name

custom property.

n The name of the HP Server Automation image to be used as the value for the
Opsware.BootImage.Name custom property.
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n Optionally, information about the custom properties and values to be applied to all machines
provisioned from the blueprint. See Chapter 8 Custom Properties for HP Server Automation
Integration.

Note   A fabric administrator can create a property group by using the property set
HPSABuildMachineProperties, which allows HP Server Automation integration in provisioning
by using a boot image, or HPSASoftwareProperties, which allows HP Server Automation
integration in software deployment. These property groups makes it easier for tenant
administrators and business group managers to include this information in their blueprints.

n For information on creating a virtual blueprint, see IaaS Configuration for Virtual Platforms.

Procedure

1 Select Design > Blueprints.

2 In the Actions column, click the down arrow and click Edit.

3 Click the Properties tab.

4 (Optional) Select one or more property groups.

Property groups contain multiple custom properties.

5 (Optional) Add any custom properties to your machine component.

a Click New Property.

b Enter the custom property in the Name text box.

c (Optional) Select the Encrypted check box to encrypt the custom property in the database.

d Enter the value of the custom property in the Value text box.

e (Optional) Select the Prompt user check box to require the user to provide a value when they
request a machine.

If you choose to prompt users for a value, any value you provide for the custom property is
presented to them as the default. If you do not provide a default, users cannot continue with the
machine request until they provide a value for the custom property.

f Click the Save icon ( ).

6 Click the Build Information tab.

7 Select Create and the ExternalProvisioningWorkflow workflow.

8 Click OK.

Your blueprint is saved.

What to do next

Publish your blueprint to make it available as a catalog item. See Chapter 9 Publish a Blueprint.

IaaS Integration for HP Server Automation
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Create a Blueprint for Cloning from an
HP Server Automation Template
A tenant administrator or business group manager creates a blueprint that enables the deployment of
HP Server Automation software jobs on machines provisioned from it.

Prerequisites

n Log in to the vRealize Automation console as a tenant administrator or business group manager.

n Obtain the following information from your fabric administrator:

n An HP Server Automation template. See Preparing an HP Server Automation Template for
Cloning.

n The clone blueprint that you want to integrate with HP Server Automation.

n Optionally, information about the custom properties and values to be applied to all machines
provisioned from the blueprint. See Chapter 8 Custom Properties for HP Server Automation
Integration.

Note   A fabric administrator can create a property group by using the property set
HPSABuildMachineProperties, which allows HP Server Automation integration in provisioning
by using a boot image, or HPSASoftwareProperties, which allows HP Server Automation
integration in software deployment. These property groups makes it easier for tenant
administrators and business group managers to include this information in their blueprints.

n If a policy is to be applied to all machines provisioned from the blueprint, you must include the
custom property Vrm.Software.IdNNNN where NNNN is a number from 1000 to 1999, and the
value is set to the name of the policy, for example Windows_ISMtool.

n The name of the customization specification to be added to the blueprint. See Preparing an HP
Server Automation Template for Cloning.

n For information on how to create a blueprint for cloning by using the template and customization
specification provided to you by your fabric administrator, see IaaS Configuration for Virtual Platforms.

Procedure

1 Select Design > Blueprints.

2 Locate the clone blueprint that you want to integrate with HP Server Automation.

3 In the Actions column, click the down arrow and click Edit.

4 Click the Properties tab.

5 (Optional) Select one or more property groups.

Property groups contain multiple custom properties.

IaaS Integration for HP Server Automation
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6 (Optional) Add any custom properties to your machine component.

a Click New Property.

b Enter the custom property in the Name text box.

c (Optional) Select the Encrypted check box to encrypt the custom property in the database.

d Enter the value of the custom property in the Value text box.

e (Optional) Select the Prompt user check box to require the user to provide a value when they
request a machine.

If you choose to prompt users for a value, any value you provide for the custom property is
presented to them as the default. If you do not provide a default, users cannot continue with the
machine request until they provide a value for the custom property.

f Click the Save icon ( ).

7 Click OK.

Your blueprint is saved.

What to do next

Publish your blueprint to make it available as a catalog item. See Chapter 9 Publish a Blueprint.

IaaS Integration for HP Server Automation
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Custom Properties for HP
Server Automation Integration 8
vRealize Automation includes custom properties that you can use to provide additional controls for HP
Server Automation integration. Some custom properties are required for HP Server Automation
integration. Other custom properties are optional.

Required Custom Properties for HP Server Automation
Integration
Certain custom properties are required for a blueprint to work with HP Server Automation.

Table 8‑1.  Required Custom Properties for HP Server Automation Integration

Property Definition

VMware.VirtualCenter.OperatingSystem Specifies the vCenter Server guest operating system version
(VirtualMachineGuestOsIdentifier) with which
vCenter Server creates the machine. This operating system
version must match the operating system version to be installed
on the provisioned machine. Administrators can create property
groups using one of several property sets, for example,
VMware[OS_Version]Properties, that are predefined to
include the correct VMware.VirtualCenter.OperatingSystem
values. This property is for virtual provisioning.

VirtualMachine.EPI.Type Specifies the type of external provisioning infrastructure.

EPI.Server.Name Specifies the name of the external provisioning infrastructure
server, for example, the name of the server hosting BMC
BladeLogic. If at least one general BMC EPI agent was installed
without specifying a BMC BladeLogic Configuration Manager
host, this value directs the request to the desired server.

Opsware.Software.Install Set to True to allow HP Server Automation to install software.

Opsware.Server.Name Specifies the fully qualified name of the HP Server Automation
server.

Opsware.Server.Username Specifies the user name provided when a password file in the
agent directory was created, for example opswareadmin. This
user name requires administrative access to the HP Server
Automation instance.

Opsware.BootImage.Name Specifies the boot image value as defined in HP Server
Automation for the 32-bit WinPE image, for example winpe32.
The property is not required when provisioning by cloning.
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Table 8‑1.  Required Custom Properties for HP Server Automation Integration (Continued)

Property Definition

Opsware.Customer.Name Specifies a customer name value as defined in HP Server
Automation, for example MyCompanyName.

Opsware.Facility.Name Specifies a facility name value as defined in HP Server
Automation, for example Cambridge.

Opsware.Machine.Password Specifies the default local administrator password for an
operating system sequence WIM image such as
Opsware.OSSequence.Name as defined in HP Server
Automation, for example P@ssword1.

Opsware.OSSequence.Name Specifies the operating system sequence name value as defined
in HP Server Automation, for example Windows 2008 WIM.

Opsware.Realm.Name Specifies the realm name value as defined in HP Server
Automation, for example Production.

Opsware.Register.Timeout Specifies the time, in seconds, to wait for creation of a
provisioning job to complete.

VirtualMachine.CDROM.Attach Set to False to provision the machine without a CD-ROM device.
The default is True.

Linux.ExternalScript.Name Specifies the name of an optional customization script, for
example config.sh, that the Linux guest agent runs after the
operating system is installed. This property is available for Linux
machines cloned from templates on which the Linux agent is
installed.

Linux.ExternalScript.LocationType Specifies the location type of the customization script named in
the Linux.ExternalScript.Name property. This can be either
local or nfs.

Linux.ExternalScript.Path Specifies the local path to the Linux customization script or the
export path to the Linux customization on the NFS server. The
value must begin with a forward slash and not include the file
name, for example /scripts/linux/config.sh.

Optional Custom Properties for HP Server Automation
Integration
Certain custom properties are optional for a blueprint to work with HP Server Automation.

Table 8‑2.  Optional Custom Properties for HP Server Automation Integration

Property Definition

Opsware.ProvFail.Notify (Optional) Specifies the notification email address for HP Server
Automation to use in the event of provisioning failure, for
example provisionfail@lab.local.

Opsware.ProvFail.Notify (Optional) Specifies the HP Server Automation user to whom
ownership is assigned if provisioning fails.

IaaS Integration for HP Server Automation
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Table 8‑2.  Optional Custom Properties for HP Server Automation Integration (Continued)

Property Definition

Opsware.ProvSuccess.Notify (Optional) Specifies the notification email address for HP Server
Automation to use if provisioning is successful.

Opsware.ProvSuccess.Owner (Optional) Specifies the HP Server Automation user to whom
ownership is assigned if provisioning is successful.

Custom Properties That Make HP Server Automation
Software Jobs Available
Depending on how your fabric administrator configures HP Server Automation jobs for
vRealize Automation integration, you might have a choice between making all software jobs available to
machine requesters to select, or you can specify jobs to apply to all machines provisioned from your
blueprint.

Table 8‑3.  Custom Properties to Make Software Jobs Available

Property Definition

LoadSoftware Set to True to enable software install options.

Vrm.Software.Id (Optional) Specifies an HP Server Automation policy to be
applied to all machines provisioned from the blueprint. NNNN is
a number from 1000 to 1999. The first property must start with
1000 and increment in numerical order for each additional
property.

IaaS Integration for HP Server Automation
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Publish a Blueprint 9
You can publish a blueprint for use in machine provisioning and optionally for reuse in another blueprint.
To use the blueprint for requesting machine provisioning, you must entitle the blueprint after publishing it.
Blueprints that are consumed as components in other blueprints do not required entitlement.

Prerequisites

n n Log in to the vRealize Automation console as an infrastructure architect.

n Create a blueprint. See Checklist for Creating vRealize Automation Blueprints.

Procedure

1 Click the Design tab.

2 Click Blueprints.

3 Point to the blueprint to publish and click Publish.

4 Click OK.

The blueprint is published as a catalog item but you must first entitle it to make it available to users in the
service catalog.

What to do next

Add the blueprint to the catalog service and entitle users to request the catalog item for machine
provisioning as defined in the blueprint.
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