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Build and Debug Environment Setup — IAR

This document illustrates how to build Realtek low power Wi-Fi software under IAR SDK
environmen t.
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1. Introduction

This document illustrates how to build Realtek low power Wi-Fi software under IAR SDK
environment.

2.How to get IAR

IAR provides an IDE environment for code building, downloading, and debugging. Please check
“IAR Embedded Workbench” on http://www.iar.com/, and trail version is available.

3. Ameba-Z Hardware Configuration

Hardware block diagram is shown in Figure 3-1 Hardware block diagram. The block USB UART is
used to supply power and catch logs, UART baud is 115200. SWD means J-Link SWD interface,
when it is connected to J-Link Adapter correctly, you can download images to Ameba-Z from IAR
flash downloader. Reset button is used to reset Ameba-Z to run firmware after IAR completes
downloading.

Reset button

DAP update
mode button

1
LERL 1}

Ly
W

=l

= - e 3 UART LOG: pRahmmarty |
y T hlle Al PA29&PA30
P N ¢ o - — =S Download image
DAP reset Al : " —

button

Figure 3-1 Hardware block diagram
The Dupont Line diagram between J-Link Adapter and Ameba-Z SWD is as follows:
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Figure 3-2 J-Link SWD connection
Please notice that DAP chip is not welding on the Ameba-Z demo board and so DAP function is not
enabled which means MBED u disk copy is disabled.
Physical connection as shown below:

Figure 3-3 Physical connection

4.How to build and download code

Please make sure USB UART is connected to PC with USB line and SWD is connect to J-Link Adapter
with Dupont Line before download code.

4.1 AR build

Step 1: Open IAR Workbench
Step 2: To open project, click File > Open = Workspace
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roject Tools Window Help
3 5 anp
New e Y rerdh BURS|L L
Open » File... Ctrl+0O ) - x
=
a a a -
Save Workspace Header/Source File Ctrl+Shift+H o P / o P / o P / 3 e
ool [ Tor( [l T ol & PRI (i oA
Floselerspece St bbb it
LR AR AR AR ARARRRRRRRRNRY
Save Ctrl+8
Save As
Save All
Page Setup...
Print. Ctrl+P
Recent Files »
Recent Workspaces 3
Exit
ETTING STARTED USER GUIDES EXAMPLE PROJECTS INTEGRATED
Guidelines for setting up Complete product Example applications SOLUTIONS
your project. dding documentation in FDF thst demenstiate Informaticn and
files, cempiling, linking, format gives you sil the hardwsre peripherals for example projects for
end debugging it. user and reference specific devices and integrated RTOS and
infermation you need. evalustion boards. middleware solutions.
TUTORIALS SUPPORT RELEASE NOTES My Pages
Tutorials to make you For questions about how All about the lstest Here you can download
femiliar with the IDE 1o use your |AR product, festures, new device product updates,
snd the festures of the reporting a problem, or support, and program manage licenses and
IAR C-SPY debugger finding support comections. contact information, and
resources. chedk your SUA status
I vy -
| n 3
I Open a Workspace NUM B |

Step 3: Select Project.eww in project\realtek_amebaz_va0_example\EWARM-RELEASE

Click Project = Options, General Options->Target->Processor Variant->Core, make sure you have
chosen Cortex-Md4f. If your IAR not support this core, Please choose Cortex-M4 and Floating point
settings->FPU is set to “VFPv4 single precision”.

r nl
& Project - IAR Embedded Workbench IDE | = 85 = |
File Edit View Project Tools Window Help
. = ; P < nop
M IR Ay RO D @ P @ oY
‘Workspace x - X
Diebug -
Files FISH
=fa]Project - Debug A
Capp
[Jcmsis
[Jconsole
ik
[T netwark
Cos
[ peripheral General Options
Cluser Static Analysis
e Runtime Checking
g uOt:jlttF;eu? CfC++ Compiler Target |Dutput I Library Configuration | Library Options I m I s
Aszembler
Output Converter Processor wariant
Custom Build
Build Actons © Core
Linker —
I Debugger ) Device |None default Hone | |E|
Simulator
Angel
I CMS5IS DAP Endian mode Floating point settings
GDB Server @ Little Fru [WPM =ingle precisi v]
IAR ROM-monitar I Big
I-jet/TTAGjet . il [18 -|
J-Llnk;lfIJ-Trace © BES
T Stellaris [JAdvanced SIND (HEOK)
Macraigor
PE micra
RDI
STINK
I Third-Party Driver
Froject
TLADS l Ok I ’ Cancel
Ready

Step 4: To build project, click Project = Rebuild All
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Then you will get boot_all.bin and image2_all_otal.bin in

project\realtek_amebaz_va0_example\EWARM-RELEASE \Debug\Exe.

,
J& Project - IAR Embedded Workbench IDE

(=

Ele Edit View [Project| CMSIS-DAP Tools Window Help

DU

Workspace

Diebug

Files
B Project - [
H#E Cdcmsis
H#E [dconsole
A lib

& (] network
HHEJos

= (1 peripher
= (1 polarss!
— CISDRAM
= CJuser
1 (1 Cutput

I Froject

Add Files...

Add Group...

Import File List...

Add Project Connection...
Edit Configurations...

Remowve

Create Mew Project...
Add Existing Project...

YvYennEe epd

Clean and make the

Options... Alt+F7
Version Control System »
Make F7
Compile Ctrl+F7
Rebuild All

Clean

Batch build... F8
Stop Build Ctrl+Break
Download and Debug Ctrl+D
Debug without Downloading

Make & Restart Debugger Ctrl+R
Restart Debugger Ctrl+Shift+R
Download »
SFR Setup

Open Device Description File
Save List of Registers...

]

> X

Step 5: To build image2_all_ota2.bin for OTA, click Project->Options->Build Actions->Build Actions
Configuration->Pre-build command line, change the secondary parameter “1” to “2” shown as

follows, then Click OK and make project “Rebuild All”.
Then you will get image2_all_ota2.bin in project\realtek_amebaz_va0_example\EWARM-RELEASE

\Debug\Exe.
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Categony:

General Options
Static Analysis

Runtime Checking
| C/C++ Compiler Enild Action=s Configuration |

"

Assembler . .
Output Converter Pre-build command line:

Custom Bukd Aty\commonprebuild vbs"| “$FROT_DIRS 0x05050000° [ |

Build Actions Post-tmild command line:
|

Linker CSCEIPT  “$PROJT_DIEEY. % . % . ‘componenthsocirealtekhST: D
Debugger
Simulator
Angel
CMSIS DAP
GDB Server
IAR. ROM-monitar
IHjet/ITAGet
JLinkf3-Trace
T1 stellaris
Macraigor
PE micra
RDI
STAIMK
Third-Party Driver

TIXDS [ Ok ][ Cancel ]

By the way, the mbed APlIs include C files and Header files used by Ameba-Z is located in
component\soc\realtek\8711b\mbed\. It will also be merged to component\common\mbed\ in
next version. Now if you use Ameba-1, please choose files from component\common\mbed\ and if
you use Ameba-Z, please choose files from component\soc\realtek\8711b\mbed\.

r n R R h
& Project - IAR Embedded Workbench IDE [' = g
File Edit View Project Tools Window Help
T Y YR AYS O P ab BURS DD
Workspace * | main.c | main() -« X
[Debug - = =
Files £ B - # gbrief Main program. 0
E * fparam None
& 0s - * @retval Nones
H= (] peripharal L
ﬂEg_--_ void main(void)
= [£1 analogin_api.c (= T
dma_api.c uint32_t *p = (uint32_t*)0x10005010;
efuse_apic
[E1 flash_api.c *p = 32;
in_api.c printf ("\np=3d\n”, *p);
gpio_ap
gpia_irg_apic
2c_apic E = if { rtl_cryptoEngine init{) !'= 0 ) {
L= 2s_apic DiagPrintf ("crypto engine init failed\r\n"); |_
& [ nic_apic i 4
:: p!nmap.c /* Initialize log uart and at command service */
RINMAap_E0mman.c //consale init():
:: pDI’t_a[:;I.C - ReRegisterPlatformlogUart();
o] pwmout_api.c —
re_api.c . /* pre-processor of application example */
serial_api.c pre_example_entry(): | 4
sleepc
I spi_api.c /* wlan intialization */
SyS_ﬁpi [ [ #if defined(CONFIG_WIFI_NORMAL) ss& defined (CONFIG_NETWORK)
timer_api.c wlan_network();
us_ticker.c  #endif
[Clus_ticker_apic <
/* Execute application example #/
f IF'r0|ec:t afr = ol 3
| = e
= | nr -
f _g- 4 m 3 =
& Build Debuglog
Ready
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4.2 IAR download

The Ameba-Z demo board only supports JLINK SWD download and debug.

Please note that if you want use IAR download image to debug, please set the secondary
parameter of prebuild.bat to “1” and build.

Step 1: Please check J-link debugger is setting correct. Click
Project->Options->Debugger->Setup->Driver, and choose “J-Link/J-Trace”. Then click Debugger->

J-Link/J-Trace->Connection->Interface and choose “SWD”.
r% Project - LAR Embedded Workbench IDE

-

= B X

File Edit VIEW_— Options for node "Project” ﬁ |
D e
Workspace 1
Debuy ; -
[Debug || catsgoy e
Files General Options
o TR | |t
Runtime Checking
i+
g :fnis C/C++ Compiler Setup |Do'wnload I Images I Extra Options I Multicore I Plugins|
Assembler
.
gﬁ?nsole Output Converter Driver [¥]Bun to
: Custom Build | J-Link/J-Trace = | main
[Onetwork P
Build Actions 3
D os Linker etup macros
Dperipherf Use macro filels)
[Quser Simulator $PROT_DIESY. % . % . heomponenthzocirealtelth8T11b4mi E]
Jutilities angel
[ 0utput CMSI5 DAP E]
ff;:;::onimr Device description file
I4et/ITAGjet Override default
J-ink/1-Trace FPROT_DIESY. % % . ‘componenthsocirealtelh8T11bhmi E]
TI Stellaris
- Macraigor
Praject PE micro
x — RDI
Messages STLINK
- Third-Farty Driver
Linking TS
& Waming[Lpl [ (] J ’ Cancel
"zi section

Ay warming[Lp 0T8T,
Perfarming Post-Build Action

Total number Df Errors: D

[ PO [ RPN .2

data section image? validate rodata in startup.o symbaols: [RAM IMGE _WALID PA'I_I'EN]")

=
al | .

Errors 0, Warnings 57 |
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& Project - IAR Embedded Workbench IDE

(=[@] = ]

File Edit View |

=
Options for node "Project” -

2]

nE—a= -

Workspace
Debug

Categon,:

Files
=fi]Project - Cf
A CJapp
= (1 cmsis
H# (] consale
= Clib

& C netwaork
HeEdos

& [ peripher
= CJuser
& [ utilities
i (7 Cutput

I Project

x

Messages
Linking

Warning[Lall

General Options
Static Analysis
Runtime Checking
CfC++ Compiler
Assembler
Output Converter
Custom Build
Build Actions
Linker
Debugger
Simulator
Angel
CMSIS DAP
GDB Server
TAR. ROM-monitor
I-jet/ITAGIet
TI Stellaris
Macraigor
PE micro
RDI
STINK
Third-Farty Driver
TIXDS

Factory Settings

Connection |Brealpoints

Communi cation

() ICR/TF:
IF address:

Interface

) ITAG

D Log communi cation

FPROT_DIES vespycomm. Log

Device O ¥ Serial

IF address
aaa. bbb, cee. ddd Serial

JTAF scan chain
JTAG =can chain with multiple tar
TAF mamber: (O
Scan chain contains non—AEM dewice

Preceeding a

"zi section .

ak ] [ Cancel

Warning[Lp

Toa_l...

Total number of errors: 0

P Ry S

N ol

data section .image?2 validate rodata in startup.o symbols: [Fak_IMGZ2_WALID_PATTEMN]"M
Ferforming Post-Build Action

I

Errors 0, Warnings 57

h

Step 2: To download code, click Project->Download->Download active application.
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File Edit View |Project| Tools Window Help
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lo| o]

- - —

dnﬁuﬁw

[ [iebug

Files
=l [Project -
2 [app

HH Cdcmsis
| [Oconsole
= ik
= [ netwark
FE[Oos
= (1 peripher
= CJuser
&= (1 utilities
8 (1 Output

I Froject

x
Messages
Linking

Ay warming[L
"zi section

I Ay warming[L

data sectio

Perfarming

Total nurmk

L]

Build

Add Files...

Add Group...

Import File List...

Add Project Connection...
Edit Configurations...

Remove

Create New Project...
Add Existing Project...

Options... Alt+F7
Version Control System

Make F7
Compile Ctrl+F7
Rebuild all

Clean

Batch build... F8
C-STAT Static Analysis

Stop Build Ctrl+Break
Download and Debug

Debug without Downloading

Make 8t Restart Debugger Ctrl+R
Restart Debugger Ctrl+Shift+R
Download

SFR Setup

Open Device Description File

3

3

- X

example "rw data section .imageZ.entry.da

mple "rw data section image.entry.data in
Gz2_WALID_PATTEN]")

Download active application Ctrl+D
Download file...

Erase memory

After firmwaré denIbad, click Reset button to reboot the system.

4.3 IAR debug

AR LYY T IEE

To debug or trace code step by step, click Project > Download and Debug or press one of the two

buttons 2 & in the IAR menu.
Upper left corner of the toolbar shows step by step tracking tools.
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& Project - IAR Embedded Workbench IDE — g I:Iﬂu
File Edit View Project Debug Disassembly J-lLink Tools Window Help
Dedd@ s tp@dlo o YT e e P BB [ENES o
|§‘5v| NEFEEEEIE]
D
TS E - x T >
[Debug - Goto -
Files ErooER Disassembly i
B (JProject-D... v
Hz Clapp Oxi04: 0Omb
I = Cdemsis Oxl06: O=f
= (1 console Oxlla: 0O=b
| FE Tl Oxl0c: O=f
= (O netwark Oxl110: 0O=f
Fmlos Oxll4: Oxf
H= C1 peripheral 0x118: 0O=f
= CJuser Ozlle: 0=k
= 7 utilities Oxlle: O=f
L@ (7 Qutput 02122 Oxf
O=zl26: 0O=f
Ozlza: 0O=0
OzlZc: O=f -
| Proect <[ D
Messages File Line *
A Warning[Lp006]: placement includes a mix of wiitable sections (example "rw data section DvworkyP. Nimage2.icf 136
imagel.entry.data in startup.o symbols: [glmage2EntryFunl]") and nor-writable sections
(example "ro data section imagel validate.rodata in startup.o symbols:
[RAM_IMG2_VALID_PATTEM]"
I Ferforming PostBuild Action
Total number of errors: 0 o
Total number of warnings: 57 i
x

Errors 0, Warnings 57

How to set Break point is shown as follows:

(.
& Project - AR Embedded Workbench IDE Elﬁg
Ele Edit Wiew | Project | CMSIS-DAP Jools Window Help —
D | Add Files... Yy euFperdbh nusdslr o
Add Group... = | | L1 main) + x
Debug Import File List... - : " - 1 =
IpEn e #JI.nc‘.ludE “FreeRTes.h set debugger i
Files Add Project Connection. .. (o] #include "task.h' —
. N N #include "diag.h"
Bl Project - [ Edit Configurations v #include "main.hj
[Jemsis -
[Jconsole smave extern void #flan_netowrk (veid);
[Tlib Create New Proj j4 console_init (void);
[T network: o i E
CJos Add Existing Project... . Main program.
}-m £ peripher - None
[ polarss] Options... Al None
[0 SDRAM e v
5 wser Wersion Control System 3 @ o014 main (void)
7 Output Make 74 { m
. console_init():
Compile Crl+F7 //For 1NIC project, disable by default
Rebuild All #if CONFIG_INIC_EN
Clean inic interface_init();
#endif
Batch build... F&
I 3 i . #if defined (CONFIG_WIFI_NORMAL) s& defin
Project top Buil trl+Breal
x Download and Debug Ctrl+D i
Messages Deb thout Download
Building co e noading | «__This optidn is currently not supported in this version! !!
Updating Make & Restart Debugger Ctrl+
Restart Debugger Ctrl+5Shift+R.
Configurati Download v
SFR Setup
o] Device Description Fil 3
Waa [0 DevcaDetoioniie T— »
] Save List of Registers...
Download the application and start the debugger Errors 0, Warnings 0 NU

—
By the way, ROM code and Boot loader code is provided by means of the symbol list tables,
rom_symbol_v01_iar.icf and bootloader_symbol.icf. You can find it in
project\realtek_amebaz_va0_example\EWARM-RELEASE. So if you are tracking to the function
which is running in the ROM or boot loader area, the source code can’t be located.
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. % beootloader_symbol.icf (DAWork)... val_example\EWARM-RELEASE) - GVIM

RTL8710BN
a7

(R HRER(E)

TRmMm &)
AadRE| » @

EIMEB)

EOW)  =EH)
B REREH SIIA THIO? 2

define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define
define

exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported

symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol

f* Bootloader symbol 1list =/

BDOT_FLASH_InitDe
BDOT_FLASH_Phasec
BDOT_FLASH_GetOpt
BDOT_FLASH_Calibr
BDOT_FLASH_GetUen
BDOT_FLASH_Imaged

0TA_Valid = 8x8889
0TA_Change = B8x88
0TA_Force1Check =
0TA_Select = 6x68

IMAGE1$%Base = Bx
RamStartTable = 8
RAM_IMG1_VUALID_PA
BOOT_RAM_Image1p5%
BOOT_RAM_MYWakeFrom
BOOT_RAM_Imagel =
BOOT_System_Init1
BOOT_System_Init2

SOCPS_SPSPin_Pull_RAH =

SOCPS_PAD_CHD_RAM
SOCPS_SleepPG_RAM
SOCPS_FlashPin_Pu
SO0CPS_DeepSleep_R

bugFlg =
alibration =
ion = @xA80000e1;
ation =
dor = 8x880881467;
= BxB8BABA233;
aa5c1;

Aaa5e9 ;

0x 8808867 b ;

Aada6c3 ;

10882001 ;
x10808082881;

TTEH =
= Bx188820e1;
PG = Bx18802187;

Bx1800821ed;
= Bx18882259;
= 8x18808226bh;

= Bx10002359;
= 0x10002389;
11Up_RAH =
AM = Bx100023d7;

<le\EWARM-RELEASE“bootloader_symbol.icf" 37L, 2116C

Bx0300800821 ;
808000037 ;

Bx080008F7;

Bx10080820619;

Bx100082341 ;

Bx108023ad;

1,1

m

it

Tiim

% rom_symbol_w01_iar.icf (D:\Work..val_example\EWARM-RELEASE) - GVIM1

|c: =] .--?3--1

TP REE TED EHS) S1EE)
8 @ & |

EOW) | #e(H)
BRREBSEBA[(THEQ[? A

exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported
exported

symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol
symbol

_ wvectors_table =
Reset_Handler = @
HHMI_Handler = 8x1
HardFault_Handler
MemManage_Handler
BusFault_Handler

UsageFault_Handle
USprintf = B8x2081;
DiagPrintf = Bxid
DiagSPrintf = B8x5
DiagSnPrintf = Bx
pruDiagPrintf = @
pruDiagSPrintf =

UARTIMG_Write = @
UARTIMG_Download

_memcmp = Bx991;
_memcpy = Bx%9ch;
_memset = Bxa7d;
DumpForOneBytes =
CmdRomHelp = Bxcé
CmdDumpWord = Bxc
CmdWritellord = Bx
CmdFlash = Bxdd1;
CmdEfuse = Bx12c1

Bx0;
®181;
1% ;

= Bx119;
= Bx12d;
= Bx131;
F = Bx135;

d;

a9 ;

C3as;
®7ed;
B8x821;
®B55;

= Bx981;

Bxzae?;
93
cd;
d7d;

<LEASE\rom_symbol_ve1_iar.icf" [unix] 1424L, 71558C

2l

Tl

2017-12-26

12



Ji4 REALTEK RTL8710BN

5.Image tool download

Please reference AN0112 Realtek Ameba-Z Image Tool user manual.doc.pdf for details.

Assuming that the Image Tool on PC is Server, which sends images files to Ameba-Z (Client) through
UART. Client or Server, whichever starts first will be ok.

Steps on Ameba-Z

Step 1: For QFN32, pins marked with “1”on the figure should be connected by jumper cap.

For QFN48 & QFN68, pins marked with “2”shouldbe connected by jumper cap.

Step 2: Push the Image Download Button and keep it pressed.

Step 3: Power on the board or press the Reset Button. Now Ameba-Z goes into UART DOWNLOAD
mode.

Step 4: Finally release the Image Download Button. Now the client is ready for receiving data.

| LOGUART: GPIOA_16 & GPIOA_17

Reset Button

nmnr o

Image
Download
Button

| LOGUART: GPIOA_29 & GPIOA_30 |

Figure 5-1 AmebaZ DEV
Steps on image tool
Step 1: Select serial port. The default baud rate is 1.5Mbps.
Step 2: Select transmission baud rate
Step 3: Open serial port
Step 4: Check the images to be transferred
Step 5: Select and load images files by browsing which are generated by IAR project.
Step 6: Input image addresses. The address which starts with 0x08 is for flash, and 0x10 for RAM.
Step 7: Push Download button to start. Now the server is ready to send data.

2017-12-26 13
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Dowrdoad | Generate

Serial

Com: CoM1Z Bandrate: 1500000

Flash Erase

Addr: Q08000000

Boot: sbughvl19114_debugiboot_all. bin Erowse addrl Chex):  O0x03000000
Swstem: [ Browse Addr? Chex):
OTAL: I14_debughimage?_all_otal. bin Browse Added Chex):  Ox0S00E0OO
oTAz: ] Browse AddrS (hex):
User: [ Browse Addef Chex)
RDF: 0o Browse AddrT (hex):

image_all bin Erowze Oz08000000

HTAL image: L

COM12 15 open successfully!

Vart downlead server has started ..
Boot image is being sent. ..

Boot image has been sent successfully!
OTAl image is being sent. ..

O0Thl image has been sent successfully!
811 images are sent successfully!
COMIZ 1= closed successfully!

@ I:l Single Image Mode

Figure 5-2 Image Download Tabpage
When the client and server are both ready, data transmission begins.
The progress bar will show the transmit progress of each image. You can also get the message of
operation successful or errors occur from log window.

6. How to use peripheral sample code

There are several peripheral example code under folder “project\realtek_amebaz_va0_example
\example_sources \”, you can copy & paste the example’s “inc” and “src” to project folder.

Ex. To use i2c example code, you can copy “src” and “inc” from “project\
realtek_amebaz_va0O_example\example_sources\i2c\”.

2017-12-26 14
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project
realtek_ameba__.a) exemp'e_cap
EVWARM-RELEASE

example_sources
gpio
gpio_irg
i2¢
pwm
spi
uart

COPY

uart_irq
wlan

addr

wlan |

Ameba API follows MBED API. User can check MBED website for peripheral API.

7.Warning

7.1 Federal Communication Commission Interference Statement

Federal Communication Commission Interference Statement

This equipment has been tested and found to comply with the limits for a Class B digital device,
pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection
against harmful interference in a residential installation. This equipment generates, uses and can
radiate radio frequency energy and, if not installed and used in accordance with the instructions,
may cause harmful interference to radio communications. However, there is no guarantee that
interference will not occur in a particular installation. If this equipment does cause harmful
interference to radio or television reception, which can be determined by turning the equipment
off and on, the user is encouraged to try to correct the interference by one of the following
measures:

@ Reorient or relocate the receiving antenna.

@ Increase the separation between the equipment and receiver.

@ Connect the equipment into an outlet on a circuit different from that to which the receiver is
connected.

@ Consult the dealer or an experienced radio/TV technician for help.

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two
conditions: (1) This device may not cause harmful interference, and (2) this device must accept any
interference received, including interference that may cause undesired operation.

FCC Caution: Any changes or modifications not expressly approved by the party responsible for
compliance could void the user's authority to operate this equipment.
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IMPORTANT NOTE:

FCC Radiation Exposure Statement:

This equipment complies with FCC radiation exposure limits set forth for an uncontrolled
environment. This equipment should be installed and operated with minimum distance 20cm
between the radiator & your body.

IEEE 802.11b or 802.11g operation of this product in the U.S.A. is firmware-limited to channels 1
through 13.

This module is intended for OEM integrator. The OEM integrator is responsible for the compliance
to all the rules that apply to the product into which this certified RF module is integrated.
Additional testing and certification may be necessary when multiple modules are used.

20cm minimum distance has to be able to be maintained between the antenna and the users for
the host this module is integrated into. Under such configuration, the FCC radiation exposure limits
set forth for an population/uncontrolled environment can be satisfied.

USERS MANUAL OF THE END PRODUCT:

In the users manual of the end product, the end user has to be informed to keep at least 20cm
separation with the antenna while this end product is installed and operated. The end user has to
be informed that the FCC radio-frequency exposure guidelines for an uncontrolled environment
can be satisfied. The end user has to also be informed that any changes or modifications not
expressly approved by the manufacturer could void the user's authority to operate this equipment.
If the size of the end product is smaller than 8x10cm, then additional FCC part 15.19 statement is
required to be available in the users manual: This device complies with Part 15 of FCC rules.
Operation is subject to the following two conditions: (1) this device may not cause harmful
interference and (2) this device must accept any interference received, including interference that
may cause undesired operation.

LABEL OF THE END PRODUCT:

The final end product must be labeled in a visible area with the following " Contains TX FCC ID:
TX2-RTL8710BN ". If the labelling area is larger than the palm of the hand, then the following
FCC part 15.19 statement has to also be available on the label: This device complies with
Part 15 of FCC rules. Operation is subject to the following two conditions: (1) this device
may not cause harmful interference and (2) this device must accept any interference
received, including interference that may cause undesired operation.

Antenna list:

Ant.[Brand |Model Name (P/N) Antenna Type |Connector|Gain (dBi)
1 REALTEK |Ameba-AM0001 Printed Antenna|N/A 2.9

2 |[JOYMAX | TWF-614XMPXX-500 Dipole Antenna |I-PEX 3.0

3 LYNwave |ALA110-222050-300010|PIFA Antenna I-PEX 3.5

Note: The EUT has three type antennas.
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