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Overview 

The Librarian Utility breaks down into the following sections: 

 

 A
T

 

Music Collection 
is where you choose the album, songs, artist, genre, year, radio 

station, or playlist for which you want to create an icon.   
 
Action Buttons 

lso available through 
ools option of main 

menu. 
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Action Buttons 

The action buttons on the Librarian Utility are as follows: 

 

 

 

 

 

 

 

 

Sending Changes from the Librarian Utility to the TerraPlayer Radio 

When you close the Librarian Utility at the end of a session, it will automatically send 
any changes made to the TerraPlayer Base, where they are picked up by the TerraPlayer 
Radio.  The changes will not show until they have been picked up by the TerraPlayer 
Radio. 

 

 

Available Images 
is where you 

choose the image 
to link as an icon. 

 
Left is a navigator 

showing the 
folders. 

 
Image Name lists 
the image files in 

the folder. 
 

The Image 
Preview Pane 

displays the 
selected image. 

Unlink Images   

Link Images   

List Albums   

List Artists   

List Genres   

List Years   List Radio Stations   

List Playlists   

Library Stats   

Search for Artwork   

Exit   
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The Easy Way  

Creating an Album Icon from a .jpg File 

1.  Scan the album cover and create an image file 

Using an external image scanner (not included), scan the album or CD cover.  The 
graphic should be saved as a .jpg file using the album title as a filename with the 
following format: 

Album.jpg 

For example: 

 
Coffee Break.jpg 

The graphic file should be copied into the album folder with the rest of the audio tracks.  
The album folder should have the same name, for example: 

Format                                    Example 

   

2. Start Librarian  

When the program starts, it 
automatically loads all 
available files and images.   

If an album folder contains a 
.jpg with the same name, 
that .jpg will automatically 
be associated as the icon for 
all audio files in that album 
folder.   

Song collections and 
associated images can be 
viewed in the Librarian 
Utility. 
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Advanced Librarian Utility 

The Music Library  

The Music Library contains information about all the audio files on your PC, and on all 
networked PCs.  This database also stores the location of the actual audio files, so the 
system knows where to go to transmit a track to a TerraPlayer receiver.  The database 
does not store the audio files themselves—just the song information and location. 

 
This database is built and maintained automatically.  The Base Transceiver searches the 
PC(s) for all audio files, then builds the library.  The Librarian utility then gets what it 
needs from the Base Transceiver to build it’s own music library.   

 
Music 
Library 

Access the Music Library Database from the main menu of the Librarian window by 
selecting File ►Library Database, or by clicking on the Music Library Stats button. 

The Music Library Database window contains the following: 

 

 
 
 
 

 

 

Song.mp3 
-Filepath 

Music Info 
Album Icon 
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Default JPG directory.   If you store
directory, you need to define the filep
Database Name.  Displays the filepa
Images on File.   Displays the total n
Image Database Size.   Displays the 
Error Log Count.  Lists the number 
TerraDigital Support may require thes
Radio Memory Available.  Lists the
for storing metadata on radio stations
Count/Images table.  Lists the numb
playlists, and radio stations in the data
associated with each.   
  Music Library 
-Filepath to 
Song.mp3 
-Music Info  
-Album Icon
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 all of your image files in a single 
ath for that location here.  
th and name of the physical database. 
umber of image files in the database. 
total size of the database. 
of error logs.  Click the ? button to view.  
e logs in troubleshooting. 

 amount of database memory available 
. 
er of songs, albums, genres, years, 
base. Lists the number of image files 
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Custom Icons 

The JPG Directory 

When you want to associate a custom graphic with an audio file (or a genre, artist, album, 
year, or playlist), you will first need to create a folder called ‘JPG’.  The JPG folder can 
be located anywhere, but it is easiest to maintain if you keep it in the same folder as your 
music collection.  The JPG folder is where you should store custom graphics. 

1.  Create a JPG folder 

Using the Windows Explorer, create a folder called ‘JPG’.  
You may want to keep it under the main folder of your 
music collection, for example: 

 

2.  Access the Music Library Database  

 
Music 
Licrary 

Access the Music Library from the main menu of the Librarian Utility by selecting File 
►Library Database, or by clicking on the Music Library Stats button. 

3.  In the ‘Default JPG Directory’, enter the name of the JPG folder 

           
If you know the filepath to the JPG, you can 
manually type it in the Default JPG Directory 
field.  

To browse, first click on the Default JPG 
Directory field to activate the field.  Then click 
on the ‘…’ button next to the field to open a 
browse navigator.  Navigate through the hard 
drive and select the JPG folder. 

Once done, click OK. 

 

 

4.  Close the Music Library Database when finished 

After the folder has been assigned as the JPG directory, it will appear in the Default JPG 
Directory field, as shown below.  When finished, click Exit. 
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Create a custom icon 

You can create icons to represent different categories: artists, albums, radio stations, 
playlists, or years.  Each one of these has a default icon: 

Artist Album Genre Radio Playlist Year 

      
For most albums, the default icon will be replaced by a copy of the real album cover 
downloaded over the Internet from an online data source when converting a CD with the 
Ripper Utility, or updating Music Information with the MusicInfo Wizard. 

However, album icons, like genre, artist, song, radio, playlist, and year icons, can also be 
replaced with a custom graphic of your own selection or design. 

1.  Create a .jpg 

The Librarian Utility will automatically scale the graphic for display on the touchscreen 
before it stores the graphic in the Music Library, but you should try and keep the shape of 
the graphic roughly square.  For example, if you wanted to create a graphic for use as an 
icon for a playlist, it might look something like this: 

 
CoolestPlaylist.jpg 

You should save the file with a descriptive name, such as ‘CoolestPlaylsit.jpg’ for our 
example.  The file should be stored in the Default JPG Directory.  

2.  Select a View and the Level, and select the desired item 

Depending on the item with which you’d like to associate an icon, select the 
corresponding view from the Action buttons: 

 
 

Or you can select on of these from the View option of the main menu. 

 Refer to View Options on page 76 for more information. 

4.  Locate and select the image file 

In order to search your entire PC or network for all .jpg image files and load them into 
the database, click on the Find button.  Any graphics files the Librarian Utility finds will 
be added to the Music Library.   

To access a specific folder, navigate to that folder using the Available Images navigator 
on the lower right.   

A list of image files will appear in the Image Name field.   

Album  Artist Genre Year Radio Station Playlists 
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5.  Link the image file to the  

Once you have selected the image file and the album, artist, genre, or year with which 
you wish to associate an icon for, click the Link Artwork button: 

 
The selected image will be associated as an icon for subsequent display on the 
TerraPlayer. 

Change Icon Associations 

If a song or album is already associated with an icon, but you’d like to associate it with 
another, you can select the album/tracks in the Music Collection field, select the new 
image in the Available Images field, then drag and drop.   

If you want all the tracks within a given album to be associated with a new icon, select all 
of the tracks and drag and drop them on the Image Preview Pane.  If you want to 
associate individual tracks with unique individual images, you can click on the Image 
Preview Pane, then drag and drop it onto each individual track, or vice versa 

 

Click the Find button 

 
 to load all shared image 

files, or… 
 

Use the navigator to 
locate a specific folder. 

 
Select the image file in 
the Image Names field. 
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View Options 

The information in the Librarian Utility can be viewed in different modes according to 
the types of icons you’d like to create: 

Album View 

 
Default.  Displays information sorted alphabetically by album title.  Can be used to 
search by album, or to assign image files to albums or songs. 
Activate by clicking the Album view button.   
Also activated from the main menu by selecting View ►Album-Song. 

Artist View 

 
Displays information sorted alphabetically by artist name. Can be used to search by 
artist, or to assign image files to artists, albums, and songs. 
Activate by clicking the Artist view button. 
Also activated from the main menu by selecting View ►Artist-Album-Song. 

Genre View 

 
Displays information sorted alphabetically by genre.  Can be used to search by 
genre, or to assign image files to genres, artists, albums, and songs. 
Activate by clicking the Genre view button. 
Also activated from the main menu by selecting View ►Genre-Album-Song. 

Year View 

 
Displays information sorted numerically by release year of album.  Can be used to 
assign image files as icons for specific years.  Activate by clicking the Year view 
button.   
Also activated from the main menu by selecting View ►Year-Album-Song. 

Radio View 

 
Displays all radio stations that have been configured.  Can be used to assign image 
files as icons for specific radio stations.     
Also accessed from the main menu by selecting View ►Radio Stations. 

Playlist View 

 
Displays all playlist files.  Can be used to assign image files as icons for playlists. 
Also accessed from the main menu by selecting View ►Playlists. 

No Art Filter 

You can switch the display of image files in the Librarian Utility on and off.  Select the 
following from the main menu: View ►No Art Filter. 

Refresh Current View 

You can refresh the current view in the window by making the following selections from 
the main menu: View ►Refresh Current View. 
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Adding Images 

There are several ways of adding new image files to the Available Images field. 

Add Available Images 

Selecting Tools ►Add to Available Images from the main menu will bring up a navigator 
allowing you to add any specific folder to Available Images. 

Auto-Find Images 

 
Find 

Artwork 

Perform a search for all image files in file shared folders by clicking the Find Artwork 
button, or by selecting Tools ►Auto-Find Images from the main menu.  Either will add all 
image files found in file shared folders to the Available Images field. 

Update Music Information for Selected Songs 

You can also edit Music Information directly in the Music Library Database using the 
Librarian Utility.  For example, you can select an album or several tracks from an album, 
then select Tools ►Update Music Information for Selected Songs from the main menu, and the 
Librarian Utility will search an online data source to download any available information 
over the Internet. 

This affects only the Music Information in the Music Library Database.  In order to work 
with Music Information stored with the audio files, you must use the MusicInfo Utility. 
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Buy CDs Now 

At the TerraPlayer touchscreen, you can indicate if you would like to buy a CD by 
pressing the Buy Now button on the Music Information screen for that album.  When you 
press Buy Now, the TerraPlayer will keep track of that album in a list of CDs you would 
like to purchase. 

 
To view these albums, select Actions ►Buy CDs Now from the main menu of the 
Librarian Utility.  The Librarian utility will query the Amazon website for any releases of 
this album that it might have for sale.   

 
You can select a release by date by clicking on the checkbox beside the Album name.  If 
you still want to buy the album, click the BUY NOW button.  When you click BUY 
NOW, this item will be added to your Amazon shopping cart, and you can then close the 
transaction to place the order next time you visit Amazon. 

 

 

 

Tap Buy Now to 
add to a list of 

albums you’d like 
to buy. 
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Setting Up AM/FM Radio Station Display Names with Local Call Letters (TR-100 only) 

The Display Name of a radio station is the text that is displayed in the TerraTouch OS.  
You can set up the Display Names with call letters (for example: WKRP, WJNK) for 
AM/FM radio stations (BT-100 only) for a given geographic location.  When you do this, 
radio station icons in the TerraPlayer will list the call letters as well as the frequency for 
each radio station.    

Before (no call letters) 

 

After (with call letters) 

 

Access AM/FM Radio Maintenance 

To access the AM/FM Radio Maintenance window, select the following from the main 
menu of the Librarian Utility:  
File ►AM/FM Radio Maintenance 

Assigning radio station call letters 

Assign radio station call letters to the frequencies as follows:  

 

1.  Access AM/FM Radio Stations 

From the main menu of the Librarian Utility, select the following: File ►AM/FM Radio 
Maintenance.  The Librarian Utility will then query the TerraPlayer Radio, via the 
associated Base Transceiver, and will list the frequencies that have been auto-detected by 
the TerraPlayer Radio.  The first time you access the list of auto-detected frequencies, the 
call letters for those frequencies will not appear – we will assign those next.   

2.  Search for the call letters of your state 

In the Display Stations by State fields, select the state in which you live from the pop-up menu, 
then click the Find Station button.  This will bring up a list of the radio stations in your state.   

Note: If you select another state it will call up the stations for that state, and the call letters will 
not correspond to the stations in your area.    

 
Access AM/FM Radio 

Stations 
The TerraPlayer 

automatically detects the 
frequencies you receive 

and lists them here. 

 
Select stations 

 After Find Stations for 
your state, the radio 

station call letters will 
appear here.   

Search y
l

Pick your
Find

Display 
Name with 

radio station 
call letters. 
 
our state call 
etters 
 state and click 
 Stations.  
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3.  Select stations 

Choose the call letters for your area by double-clicking on each.  As you do, the station 
information will appear in the list on the left, and will be stored in the Music Library 
Database, from where the TerraPlayer Radio will retrieve the information.  

 
Helpful 

Hint 

Overlapping radio stations in some places may have different call letters 
for the same frequency.  If you are in a location where radio station 
frequencies overlap, please make sure that you have the correct call letters 
for the radio station in your area. 

   

Manually editing Display Name or Format 

You also have the option of manually editing the Display Name or format information for 
an AM/FM radio station.  This feature will be useful if you live in an area on the border 
of two broadcast zones, and a radio station from another geographic location overrides 
one on the same frequency in your own location.   

 If you notice that one radio station overrides the broadcast of another, you can change 
the call letters by double-clicking on the field for that frequency in the Display Name 
column, and manually typing in the new call letters.  Or, you can type anything else 
you’d like in the field, and the text will be displayed in the TerraTouch OS once those 
changes have been transmitted to the TerraPlayer Radio. 

 
 

 

Double-click on 
a field in the 

Display Name 
or Format 
columns to 

manually edit the 
text. 
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Radio Alerts  from the TerraPlayer Remote Control 
If you have indicated that an audio file is broken or the Music Information is corrupt, you 
can find those audio files listed in the Radio Alerts window of the Librarian Utility.  
From here, you can look at which audio files are listed, and decide which ones you want 
to fix.   

1.  Access Alerts from Radio 

From the main menu, select the following: File ►Check Alerts from Radio.   

The Librarian Utility will check with the Base Transceiver to see which have been listed.  
This will bring up the Radio Alerts window, which shows the name and filepath of each 
flagged file in the Music File column, and the message in the Alert column: 

 
The messages in the list correspond to the buttons on the TerraPlayer Remote as follows:   

Button Action Radio Alerts Message 
BRO KENBRO KEN

 

BROKEN.  Flags a track on the PC if the 
audio file is broken.   

BAD  AUDIO 

FLA GFLA G

 

FLAG.  Flags a track if the Music 
Information is corrupt. 

INVALID MUSIC DATA 

2.  Replace broken audio files   

Files marked ‘BAD AUDIO’.  If a file was converted from your CD collection, you can 
use TerraPlayer Ripper to reconvert the audio file from the original audio CD.  

 For information on converting audio CDs into digital audio files, refer to Chapter 7: 
The Ripper Utility on page 84 . 

Files marked ‘INVALID MUSIC DATA’.  You can use the Music Info Utility to fix 
Music Information. 

 For information on editing Music Information, refer to Chapter 9: 
The MusicInfo on page 98 . 

3.  Select fixed audio files and click the Remove Checked button 

To the left of each listing in the Music File column, click the checkbox of each file you 
have replaced or repaired, then click Remove Checked.  This will remove audio files 
from the list.  
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Chapter 7: 

The Ripper Utility 

You already have a vast collection of CDs that you would like to play through the 
TerraPlayer? No problem—the Ripper Utility can convert, or ‘rip’, audio CDs into audio 
files.  And there are a range of options available to accommodate both novice users and 
power users. 

Internet Connection and the Ripper Utility 

It is recommended that you log in and maintain a live Internet connection during a 
session with the Ripper Utility, so it can download Music Information from a data source 
on the web. 

Accessing the Ripper Utility 

 

The Ripper Utility can be accessed by clicking on the Ripper button of 
the TerraLaunch window. 

 

Overview 

The Ripper Utility breaks down into the following sections: 

 

Select Source  
is where you choose the 

CDs.   
 

CD-Rom field and 
Refresh CD button 

accesses drive. 
 

With internet connection, 
album information is 
automatically filled. 

 
You can select individual 

tracks in the song list. 

Select 
Destination is 

where you 
choose the 
folder to put 
your audio 

files.   

i

Choose 
Action  

s where you 
choose how 

you rip. 
LLC 
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The Easy Way 

Ripping a Collection of Audio CDs in Batch Mode 

For the novice user, or for anyone wanting to convert a large number of audio CDs at one 
time, there is Batch Mode.  In Batch Mode, the Ripper Utility reads the CD, 
automatically downloads Music Information from an online data source over the Internet, 
and creates digital audio files.  Then, it spits out the CD when done and asks you for 
another one.  You can check in on the computer once in awhile to throw in a new CD, 
then go around doing other things. 

Place 
CD-R

A prom
while 

Music 

Then T
automa

M

Se
s
 

the CD in the 
OM drive… 

 
pt will appear 
downloading 
Information… 

 
erraPlayer will 
tically rip the 
CD. 
  ©2003 TerraDigital Systems, LL
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1.  Select the music folder  

In the Select Destination field, select the shared folder for your audio collection.  This is
where the converted files will be stored. 

2.  Select Batch Mode 

Click on the Batch Mode button.  The Ripper Utility will prompt you to place a CD in 
the drive. 

3.  Place the CD in the CD-ROM drive 

Insert the audio CD in the CD-ROM drive.  If you are logged on to the Internet, the 
Ripper Utility will automatically fill out Music Information.  The “Powered by 
Gracenote” prompt will appear while this is happening.   

As each track is ripped, a progress bar will appear over the song title.  By default, the 
converted tracks will be saved in a filepath along the following format: 

…\Artist Name\Album Title 

For example:  

 
Once it’s done, the Ripper Utility will prompt you for another CD—it makes it easy to 
convert your entire collection. 
Click 
Batch 
ode…
lect the 
hared 
folder  
C 
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Advanced Ripper Utility 

For the power user, there are Advanced Options.  Advanced options include: manual 
Music Information editing, read/write buffer options, jitter correction, encoder options, 
and proxy server parameters if you are running on a network with an Internet connection 
through a proxy server. 

Ripping a CD – Entering Music Information Manually 

Sometimes, the Music Information for an album or track might not be available from the 
online data source.  This may be the case for very new or very rare albums, and you may 
need to enter the Music Information manually.   

1.  S

2.  S

3.  

 Se  
ed
Inf  

de  

 

lect CD,
it Music 
ormation
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elect the CD and enter information 

Insert the audio CD to be ripped into the CD-ROM drive, then select the drive in the
Rom field.  If the album is not in the online data source, you will be prompted to dec
if you want to submit the information yourself.  If you want the Music Information y
enter for the CD to be uploaded to the online data source, click Yes.  If not, click No

Type the name of the album in the Album field.  Enter the year the album was releas
the Year field.  Select or deselect the tracks you wish to convert by clicking the 
checkboxes by each track. 

You can add the name, artist, and genre by double-clicking on a track to open the Ed
Track window.  Use the << and >> buttons to scroll through each track. 

If you want to convert only a single track, deselect the check boxes next to the other 
tracks.  To listen to a track before ripping it, highlight the track then click the  butto
the bottom of the track list.   

elect the folder where the converted files will go 

In the Step 2: Select Destination area, use the cursor and/or scroll bars to locate and
highlight the shared folder for storing the ripped audio files.  If you want to store the
a new folder, you can create one by clicking the Advanced… button in the Step 3: 
Choose Action area. 

Rip the CD 

In the Step 3: Choose Action area, click the Rip Selected button.  The Ripper Utilit
will being converting the songs on the CD into the default MP3 format, and a progre
bar will appear next to each selection to indicate the status of each file as it is being 
ripped.  It’s that easy.  There are other options available, as well: 

 Pick Image… Refer to Pick Image… on page 87 for information. 

 Advanced… Refer to Advanced Ripper Options on page 87 for information.   

Ri
Select 
stination
folder 
 

 

p the CD
 LLC 

 CD 
ide 
ou 
. 

e in 

it 

n at 

 
m in 

y 
ss 
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Pick Image… 

Pick Image allows you to manually associate an image file with a ripped D.  The image is 
then available for display as an icon on the TerraPlayer Radio touchscreen.   

When you click the Pick Image… button a Select window will appear, and you can 
navigate to the folder containing the image file (.jpg format) that will be then be 
associated with the album.     

Advanced Ripper Options 

Using Advanced Options, you can fully customize and control a variety of ripping 
parameters to suit your needs.  A detailed description of each of the advanced options is 
covered in the rest of this section.    

Click on the Advanced… button, and the Advanced Options window appears. 

General Options 

The ‘Ripper Options’ screen opens up on the ‘General’ tab.  The options below are 
available on this tab.   

 

Overwrite existing file without prompting 

If this option is selected and there is a file with the same filepath and filename, then the 
Ripper Utility will overwrite that existing file without prompting for permission.   

Default: On. 

File and Directory Naming Options 

There are fields for defining the filename convention files will be written under, and the 
filepath where they will be written. 

First, you need to define the folders where the ripped files will be stored.  You can define 
a path up to three folders deep.  The folder structure you choose may define how you 
wish to store your audio files.   

In order for this option to work, each folder level must also have a corresponding name in 
the conversion options.   For example, if you select …\Track Genre\Album Artist\Album 
Name\Track Name as the directory structure, you will need to define each of those when 
you select your source, as shown here: 



m

Album Name,  
Song Title,  

Artist Name,  
and Genre  

ust all be defined 
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If none of these have been defined, the folders will not be created.  Or if one of them has 
been left out, it will create a folder at that level, but the folder will be unnamed. 

The default folder naming convention is: 

…\Album Artist\Album Name 

For example: 

…\Zoot Brute\Final Vinyl 

But if you wanted to redefine the path to add a genre folder, you would select ‘Album 
Genre’ in the first field, then move ‘Album Artist’ and ‘Album Name’ into the fields to 
the right.  So the following selections: 

 
Would result in a path like the following example: 

…\Rock\Zoot Brute\Final Vinyl 

You also need to define the naming convention used for the audio files.  The filename 
can be defined by up to six elements, broken up by a separator.  By default, the ripper 
defines a filename using two elements and a separator: Track Number and Track Name 
are the elements, and a hyphen is the separator.  For example: 

…\01 – Ever Ending Story.mp3 

Say you want to include the Artist Name and Album Name in the filename.  You would 
select those options in the respective fields of the ‘Custom File Name and Separator 
Selection’ fields.  So the following selections:   

 
would name the file along the lines of the following example: 

…\01 – Zoot Brute – Final Vinyl – Ever Ending Story.mp3 



6/25/2003  ©2003 TerraDigital Systems, LLC 
112 

 DRAFT 

Reader Options 

When you select the ‘Reader’ tab, you can change the performance parameters of the CD 
reader while it is reading the audio CD for converting files.  The options below are 
available. 

 

Read Mode 

The quality the CD will read with is defined by the Read Mode. 

 High Performance.  This mode reads at the fastest speed possible.  This mode 
works only with systems that have Adaptec ASPI drivers installed, and will not 
appear as on option in system without them.  ASPI can be downloaded from the 
Adaptec website (www.adaptec.com). 

 Compatible.  Compatible will use the CD-ROM driver native to your system.    

Read/Write Buffer Size 

You can redefine the size of the buffer to adjust the Ripper Utility’s performance. 

Move the slider to the right to increase the buffer, or to the left to decrease.  Click on the 
Default button to reset the buffer size.   
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High Performance Options – Jitter Correction 

Jitter occurs when a CD-ROM drive cannot find a 
specific frame, or sector, while it is reading.  This 
results in pops or breaks in the audio.  Jitter 
correction is a way of improving audio through 
overlapping or multiple reading of the same frames 
to help ensure a high-quality conversion. 
On an audio CD, the tracks are written and read in 
spirals, much like on vinyl.  Unlike vinyl, these 
spirals are not one single, continuous groove – they 
are individual frames (sectors) in sequential order.  
Each successive frame is marked with a time-code 
to maintain a sort of ‘continuous groove’.   They are 
read in blocks. 

 

For example, a drive set to read blocks of 15 frames from the CD above would read them 
in the order below: 

 
Since each frame is read only once, a lagging processor may lose data and jitter errors 
may occur.  Jitter correction adds overlapping frames within each read block, ensuring a 
continuous data stream.  For example, a correction of 5 frames would tell the drive to 
read in the following order: 

 
Overlapping frames help maintain the ‘continuous groove’ as the CD drive and computer 
exchange audio data.  Jitter correction can be activated or deactivated in the Ripper 
Utility by setting High Performance Options: 

 

Jitter Correction… tells the drive when to use correction: 

• None.  No jitter correction. 
• Always.  Always use jitter correction 
• On Error.  Only use jitter correction when errors 

occur. 
Jitter Frames… sets the number of overlapping frames. 

Compatible Mode Options – Jitter Correction 

Jitter/Error Correction activates/deactivates jitter correction or sets specific modes. 

 

None… disables jitter correction. 
Always… uses settings in High Performance Options – 
Jitter Correction fields.   
Double Precision...  is optimized for use in converting old 
and used CDs. 
Paranoid… is optimized for use in converting scratched 
and unreadable CDs. 
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Encoder options 

When you select the ‘Encoder’ tab, you can change the format and write parameters the 
Ripper Utility uses in creating the file.  The options below are available.   

 

Encoder 

The Encoder field defines the format the audio tracks will be converted to.  Available 
options are .mp3 and .wma.   

MP3 

If you select .mp3 as the convert format, you can define the settings of the file using the 
following parameters. 

Bit rate is the setting if you wish to use a Constant Bit Rate (CBR).   
Values: None, 32 to 350 kBps. 

Sound Quality and Bitrate 
Bitrate Bandwidth Sound quality similar to 
32 kbps 7.5 kHz AM radio 
96 kbps 11 kHz FM radio 

128 kbps 16 kHz CD 
160-180 kbps 

(VBR) 
20 kHz Virtually transparent 

256 kbps  22 kHz Studio 
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VBR Methods are different means of varying the bit rate at which you will rip a CD.  
Variable Bit Rate (VBR) is a type of data compression where complex sounds are 
encoded at a higher rate, while simple sounds are at a lower rate.  The Ripper Utility will 
adjust the bit rate according to the complexity of the sound.  You can either try the 
different options below to find which method produces the compression/sound quality 
most to your liking, or use the default setting. 

 None.   

 Default.    

 Old.   

 New.    

 MTRH.    

 ABR.   

VBR.  None, 8 to 350 kBps. 

Channels.  Defines whether the track will be written in two-channel stereo, or one 
channel mono. 

Quality Slider.  If you don’t want to bother with the settings above, you can adjust the 
sound quality/compression using the Quality slider to determine whether a file will be 
converted at the fastest rate with low quality, or at the slowest rate with high quality. 

Windows Media Audio 

If you select ‘.wma’ as the audio file format for ripping, you can define the settings of the 
file using the Windows Media Audio field:  
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Music Lookup options 

When the TerraPlayer displays Music Information (ID3 tags, metadata) – album titles, 
artists, song titles, and even album covers – it pulls the information over the internet from 
an online database by a Music Lookup Service provider. 

 

Music Lookup Service 

The Music Lookup Service field uses radio buttons to indicate how and where the Ripper 
Utility will search for music information.   

 Deferred/No Lookup.  This option deactivates metadata lookup. 

 Gracenote.  Indicates that Gracenote services will be used.  If you select this 
option, you will need to register using the Register button in the ‘Gracenote’ 
section. 

Gracenote 

If you decide to use Gracenote services for music information, you will need to register 
with them using the ‘Update Gracenote Registration’ wizard.  To learn more about 
Gracenote, visit their website (www.gracenote.com). 
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Proxy options 

If you are on a network with a proxy server, you will need to set up the following in order 
to access online data sources over the Internet:  

 
 Use Proxy for Music Lookup Services.  Check this to activate communication 

through a prosy server. 

 Proxy Name or IP.  Enter the HOSTNAME or IP Address of the proxy server. 

 Port.  The port number of the internet proxy server on the LAN.  Should be 
provided by your system administrator. 

 User Name.  If the proxy server requires a user name for access, enter your 
username here. 

 Password.  If the proxy server requires a password for access, enter your 
password here. 
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Chapter 8: 

The MusicInfo Utility and Wizard 

Music Information is detail about a song that you get from the album cover: album name, 
artist name, song title, etc.  This information is added to the audio files and stored in the 
Music Library to make it available for display on the TerraPlayer touchscreen.  And so, 
you can still find the song details in the TerraTouch OS on the touchscreen, without 
keeping the CD or album covers around. 

Since Music information is data about an audio file, and an audio file is basically a song 
converted into a data format, it is sometimes called ‘metadata’—in other words, data 
about data.  This metadata is stored with the audio file in the form of an ID3 tag.  An ID3 
tag is a standard format for attaching metadata to an audio file.   

The MusicInfo Wizard scans your audio file collection pulls Music Information in bulk 
from a data source on the Internet, and writes the ID3 tags for each audio file.  So it does 
the work for you automatically. 

However, there may be CDs in your collection for which no Music Information is 
available.  So, sometimes you will need to add that information yourself.  The MusicInfo 
Utility can be used to manually enter or change Music Information stored in an ID3 tag 
on per song or album basis. 

Music Information 

The Music Library stores the following music information for each track: 
Music Information (ID3 Tag) 

Data Field Definition 
File Name of audio file. 
Artist Recording artist. 
Album Name of the album which the track is from. 
Track Position of the track on the album, or song number. 
Song Song title. 
Genre Genre of track. 
Year Original release date of track. 
Duration Length of the track. 

 

Internet Connection and the MusicInfo Utility and Wizard 

It is recommended that you log in and maintain a live Internet connection during a 
session with the MusicInfo Utility, so it can be used to update Music Information 
downloaded from a data source on the web.  In addition, the Wizard requires an Internet 
connection in order to download album covers for your existing files. 
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The Easy Way 

The Easy Way—Updating Music Information with the MusicInfo Wizard  

The MusicInfo Wizard automatically reads all of your audio files and compares them 
against an online data source over the Internet, updating your audio files with the most 
up-to-date information available.   

Depending on the size of your digital audio collection and the speed of your Internet 
connection, this process will take some time.  Estimated times for changes are given in 
the following table: 

 Download Save Changes 

Approximate time per 1,000 
digital audio files 

30-40 minutes 
(T1 connection) 

10-25 minutes 
(longer times for 

converting ID3 v1 tags 
to v2) 

 

Important! Before starting the MusicInfo Wizard, it is recommended that you backup 
your digital audio collection.  

 

 
Helpful 

Hint 

To get only album cover icons: If your digital audio collection already has 
Music Information (ID3 tags) that you are happy with, you can run the 
MusicInfo Wizard in a way to get only the album covers.  To do this, run 
through the MusicInfo Wizard, but at the last step, click on the Cancel 
button.  The wizard will have downloaded the album cover icons, but will 
not save the Music Information.   

1.  Start the MusicInfo Wizard 

 

The MusicInfo Wizard can be accessed by clicking on the Wizard button 
of the TerraLaunch window. 

2.  Select the desired folders then click Next > 
The wizard will prompt you to select the drive or folders containing the audio files you 
wish to update.  By default, it searches all drives.  Select the drive or folder, then click on 
the Next > button. 



 

3.  Select the desired audio files then click Next > 
The wizard will prompt you to select the audio files you wish to update.  By default, all 
audio files are selected.  Unselect audio files you don’t wish to update.  You can expand 
the window to see all the Music Information columns.  Select the drive or folder, then 
click on the Next > button.  

4.  Select the updated audio files to save, then click Next > 
The wizard will prompt you with a list containing which files have been cleaned.  Select 
the ones you wish to save.  By default, it selects all.  Select the drive or folder, then click 
on the Next > button.  

A progress bar will appear on the bottom of the window to tell you how much further the 
MusicInfo Wizard has to go.  Depending on the speed of your Internet connection and the 
size of your audio file collection, this may take some time. 
Select or deselect 
multiple audio files 

by clicking and 
holding the mouse 

button, then 
dragging across the 

checkboxes.  
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When finished, the MusicInfo Wizard will exit to the TerraLaunch window. 
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Advanced MusicInfo  Utility 

If you need to write your own music information, you can use MusicInfo.  

Accessing the MusicInfo Utility 

The MusicInfo Utility can be accessed by clicking on the MusicInfo button of the 
TerraLaunch window: 

 

Overview 

 The MusicInfo window is broken down into the following: 

  
 

 

 

Action Buttons 

The action buttons on the MusicInfo Utility are as follows: 

 

 

 

 

 

Action Buttons  
 

Also available through File 
and Tools options of main 
menu, or by right-clicking 

on a track. 
 

From menu, you can also 
Play and Stop a track for 

previewing. 

Current tags 
 Lists track 
information 

(ID3 tag 
metadata) for 
each track. 

Read Selected 

Save Selected   

Update Selected   

Stop  

Help   

Navigator  
Use the navigator to 

locate your audio files.
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Modifying Music Information for an Album 

Using the MusicInfo Utility, creating or modifying track information is a breeze: 

 
 

1.  Select the folder with the audio files 

Using the navigator on the left, search out and highlight the folder with the album. 

2.  Edit Music Information for all tracks 

Make sure all tracks are selected.  Double-click on any entry to edit. 

3.  Save the changed Music Information 

From the main menu, select File ►Save to save the changes. 

 
Select the folder with 

your audio files.    

 
Edit Music Information 

for all tracks  
 

   Genre 
Click on the arrow 

button to open a list of 
available genres and 

subgenres. 



6/2

Updating Music Information for Individual Tracks 

Using the MusicInfo Utility, you can also clean selected or individual tracks: 

 

Select t
your 

Sele

Click o
button
 
he folder with 
audio files.    
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1.  Select the folder with the audio files 

Using the navigator on the left, search out and highlight the folder with the album. 

2.  Select the track(s) 

In the # column, select the track(s) you want to update.   

3.  Update the Music Information 

Click on the Clean button, and the MusicInfo Utility will update Music Information for 
the selected track(s). 

 

 
ct Track(s)    

 
n the Clean 
 to update. 
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Chapter 9: 

The Playlist Utility 

The Playlist Utility lets you create ahead of time lists of music you would like to play 
later on.  Say you are planning a party and you want to DJ the music, but you don’t want 
to stand by the stereo all night because you want to socialize.  You can have it both ways 
by using the TerraPlayer Utility Suite’s Playlist Utility to organize of all the tunes you 
want to play before the party begins.  Once you’ve created a playlist, it can be readily 
accessed through the Playlist Mode on the TerraPlayer. 

Accessing the Playlist Utility 

 

The Playlist Utility can be accessed by clicking on the Playlist button of 
the TerraLaunch window. 

Overview 

 The Playlist Utility window is broken down into the following: 

Als
A

ma
clic

Current 
Playlist Area 
is where you 

add and 
reorder tracks 
to the playlist. 
Tracks can be 

i
ac

you
a

Action Buttons  
o available through the 
ctions option of the 
in menu. Or by right-

king on a track in the # 
column. 
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Action Buttons 

The action buttons on the Playlist Utility are as follows: 

 

 

 

 

 

 

reordered by 
drag-and-drop.

Navigator 
s a directory tree for 
cessing the folders on 
r computer or network 
nd selecting tracks.   

Create a New Playlist  

Open a Saved Playlist  

Save the Current Playlist  

Add a Track   

Remove a Track   

Shuffle the Tracks   

Remove Duplicates from Playlist  

Print the Current Playlist   

Help   



6

The Easy Way 

Creating a Playlist 

Create a new playlist as follows: 

 
 

Select th
the A

Drag an
p

Repeat

 
Save when finished 

by clicking: 

 

Click th

Select F
the m
 
e file and click 
dd button 

 
 

or… 
 

d drop it in the 
laylist. 

 
 for all tracks. 
 
e New button 

 
 

or… 
ile ►New from 
ain menu. 
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1.  Create a new playlist 

From the main menu of the Playlist Editor window, select File ►New.  Or, click the Create 
a New Playlist button: 

 
A blank playlist will appear in the current playlist area. 

2.  Select and add audio files 

Find and select the desired track(s) in the navigator.  Click the Add button, or drag and 
drop the file in the playlist.  Repeat this for each file.    

3.  Save the playlist 

From the main menu, click on File ►Save, or click on the save button in the toolbar.  The 
Base Transceiver will automatically find the playlist, and make it available for play at the 
TerraPlayer Radio. 
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Advanced Playlist  Utility  

View Options 

You can select which Music Information will be displayed, and the column width of that 
information from the View options menu.  The View options menu is available from one 
of two places:  

 

 

 

Music Information 

You can choose to display the Music Information by checking or unchecking the option 
in the View menu. 

 
 Refer to Music Information on page 98 for more information. 

Automatically Size Columns 

Selecting Automatically Size Columns will size columns as wide as possible to show all 
text, regardless of window size. 

Automatically Expand Columns 

Selecting Automatically Expand Columns will fit columns to the window size. 

 

View options are available from the 
View in the main menu, or by right-

clicking on the File column. 
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Chapter 10: 

The Configuration Wizard 

In order to find and play audio files on the PC, the TerraPlayer requires that you 
configure the folders containing those audio files for file sharing.  The Configuration 
Wizard can do this for you automatically. 

 Refer to Shared Music Folders on page 13 for more information. 

Accessing the Configuration Wizard 

 

The Configuration Wizard can be accessed by clicking on the 
Configuration button of the TerraLaunch window. 

The Configuration Wizard 

 

1.  Click the Next button 

 

2.  Choose a Base Transceiver (Ethernet installation with multiple Bases only) 
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3. Choose the hard drive to search for music 

 

 
 

4.  Choose the folders containing audio files that you wish to share 

 

 
 

5.  Click the Finish button 

 

 



6/25/2003  ©2003 TerraDigital Systems, LLC 
129 

 DRAFT 

Appendix A: 

Troubleshooting 

There are no album covers 

Since digital audio files do not come packaged with album covers, they must be 
downloaded from on online data source, then ‘associated’, or connected, with the digital 
audio files before they will appear on the TerraTouch OS. 

Things to look for 
Have you run the MusicInfo Wizard while connected to the Internet? 
The MusicInfo Wizard will scan your digital audio files.  Then with the help of an active Internet 
connection it will download both Music Information and album covers.  It will download album covers 
in the form of .jpg files and store them in the same directory as a given audio file.  It will 
automatically ‘associate’ the audio and .jpg files and add them to the Music Library.   
If you perform this while the TerraPlayer is on, you should reboot the Base Transceiver and the 
TerraPlayer Radio. 
Have you run the Librarian Utility? 
If you already have album cover .jpgs for the audio files, make sure first that they installed in the 
same directory as the file, and are named using the album name.  Then, if you run the Librarian 
Utility, it will read and associate the album cover .jpg file with the digital audio file. 
If you perform this while the TerraPlayer is on, you should reboot the Base Transceiver and the 
TerraPlayer Radio. 
But I’ve already run the Librarian Utility, and some album covers are still not showing. 
Take note of which covers are still not showing and check the following: 

1. There is a .jpg file of the album cover in the same directory, and that .jpg file is name 
using the album cover name. 

2. There is only one (1) .jpg in a given directory.  The Librarian Utility will not choose a .jpg if 
there is more than one in a directory. 

Once you’ve verified and/or fixed these, please run the Librarian Utility again, then reboot the Base 
and TerraPlayer Radio. 
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The TerraPlayer cannot find music on the computer(s) 

If the TerraTouch OS comes up, but cannot find music you know to be on the computer 
or network: 

Things to look for 
Is the Base Transceiver connected by USB or Ethernet? 
A Base connected through USB will see only the files on the computer it is directly connected to, 
whether or not it is on a network.  If you want the Base to locate files over a network, it must be 
connected via Ethernet. 
Are the folders containing digital audio files on all networked computers set for File Sharing, 
or otherwise set with proper access permissions? 
If you know there are audio files you want to listen to on a networked computer, you must ensure 
that the folder(s) they are stored in are configured as shared.   

 Refer to Shared Music Folders on page 15 for more information. 
 
For UNIX or Mac OSX machines, file permissions must be set to allow users to access a folder or 
directory over the network.  

 Refer to Non-Windows Platforms in a Network on page 16  for more information. 
 
Creating Shared Folders on a network requires Admin persmissions 
In Windows 2000, NT, or XP, if you are trying to create a Shared folder on a networked computer 
you must be logged in with Admin permissions. 
File Sharing on Windows XP 
-Has File Sharing been enabled? 
-Under Internet Protocol (TCP/IP) Settings, has DHCP been enabled? 
-Have the music folders been set to File Sharing? 
File Sharing on Windows 2000?. 
-On shared folders: Share Permissions for Everyone, TerraUser, and Adminsitrators must be set to 
allow Full Control, Change, and Read. 
-On shared folders: Security  must be set to allow Full Control, Modify, Read & Execute, List Folder 
Contents, Read, and Write. 

 

The TerraPlayer lets me select and play music, but there is no sound 

No sound could be caused by loose connections between the TerraPlayer Radio and the 
stereo, or by a dropped RF link. 

Things to look for 
Are the Base Transceiver and TerraPlayer Radio connecting? 
To verify if the Base Transceiver and TerraPlayer Radio are currently connected by the RF link, 
press the following buttons on the TerraTouch OS: SETTINGS  SYSTEM  NETWORK  
WIRELESS.  Check the LINK STATE field.  If it is OFFLINE, you will need to join the RF link and 
TerraPlayer Radio.  To double-check the online status, press the MEMBER LIST button.  If the 
Node states are OFFLINE you will need to JOIN the Base and TerraPlayer Radio. 

 Refer to Register/Join the TerraPlayer Radio and Base Transceiver on page Error! Bookmark not 
defined. for information. 

Are the RCA-stereo cables loose? 
Check the RCA-stereo cables running from the TerraPlayer Radio to the component stereo system 
to ensure that the connection is tight. 
Is the stereo set up correctly? 
On a typical stereo system, the TerraPlayer would be plugged into the AUX channel of the stereo 
system.  In order to hear the TerraPlayer through the stereo, the AUX channel must be on. 
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A Firewall is blocking the TerraPlayer 

If you have a firewall, the setting of the security level can affect the TerraPlayer. 

Things to look for 
Norton Personal Firewall 2003 
-High Level Protection.  When you install the TerraPlayer Utility Suite, each executable must be 
added as permitted application to the “Manual Program Control” list to work properly.  When you run 
configuration.exe, Firewall will ask you to accept it – if you accept, it should work fine. 
-To enable file sharing from the Base Transceiver, ports udp-137 and tcp-139 may need to be set to 
allow both inbound and outbound in the advanced firewall settings.   
-NetBIOS default settings are set to ‘Block’ by default – these may need to be changed to ‘Permit’. 
McAfee Firewall 4.0 
-Filter All Traffic.  When you run configuration.exe, Firewall will ask you to accept it – if you accept, it 
should work fine.  TerraPlayer Utility Suite programs will also cause Firewall to prompt you to accept 
them – if you accept, they should work fine. 
ZoneAlarm 
-Program Control at Medium setting.  The firewall will prompt you to accept TerraPlayer programs 
when they are run, and add them to the list of secure programs. 
-In order to allow file sharing, you may need to set the Trusted Zone to medium, then go to the 
Firewall > Zones page and set the local network interface to be a Trusted Zone. 
SyGate Personal Firewall 
-Normal Security Level.  Firewall will prompt you to allow TerraPlayer programs when they run – if 
you accept, they are added to the list of allowable programs. 
-Block All.  Will block all programs, even if added to the allowed applications list. 
-To enable file sharing from the Base Transceiver, rules for ports udp-137 and tcp-139 may need to 
be set to allow both inbound and outbound in the advanced firewall settings.   
BlackICE 
-? 
-To enable file sharing from the Base Transceiver, rules for ports udp-137 and tcp-139 may need to 
be set to allow both inbound and outbound in the advanced firewall settings.   
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Appendix B: 

Specifications*

TerraPlayer Radio 
Dimensions 

TR-100: 13.85″ wide x 4.11″ tall x 10.05″ deep 
CR-100: 17.0″ wide x 4.07″ tall x 12.17″ deep 

Weight 
TR-100: 8.75 lbs. 
CR-100: 7.6 lbs. 

Power Supply 
120 Vac, 60 Hz (U.S.  2-prong plug) 

Power Consumption 
CR-100: 15 Watts maximum 
TR-100: 90 Watts maximum 

Fuse 
CR-100: 2 AG, 500 mA, Slo-Blo, 250 V 
TR-100: 2 AG, 2 Amp, Slo-Blo, 250 V 

Compressed Audio Standard 
MP3, Windows Media Audio 

Streaming Audio Standard 
Streaming MP3 support 

Maximum Compressed Audio Data Rate 
320 Kbps 

Audio Output  
Stereo (L/R) line-level, RCA connectors 

Digital Audio Output 
CR-100 only: Optical, TOSlink 

Digital-to-Analog Converter 
High-quality Burr-Brown, 24-bit, 192 KHz,  
106 dB dynamic range 

Graphic Equalizer 
5-band, low-Q, digital bandpass filters 

Processor 
200 MHz ARM 9 

Flash Memory 
32 Mb 

RAM  
64 Mb 

Display 
6.2″ diagonal , 640 x 240 pixels, 4096-color, 
Color Super Twisted Nematic (CSTN), Liquid 
Crystal, Integrated touch screen – 1024 x 1024 
(10-bit) resolution 

Remote Control 
CR-100 only: 
RS-232, DB-9, DCE, 9600 baud, N, 8, 1 

Operating Environment 
+5° to +40° C 

Expansion 
External – SmartMedia 
CR-100 only:  
Internal –  
Up to 256 MB, SDRAM, 100-pin DIMM 

Wireless RF Link 
Reliable high-speed link, up to 500’ range 

Audio Subsystem 
TR-100 only: 
6″ full-range speaker element 
2″ water-resistant stereo (L/R) tweeter elements 
Power: 75 Watts 

Headphone Jack  
TR-100 only: 1/8″ mini stereo 

TerraPlayer Remote Control 
IR, 23 keys 
Batteries: 2 x AAA (included) 
Transmission range: 25′  (typical) 

TerraPlayer Base 
Power Supply 

120 Vac, 60 Hz, external 3.3 Vdc adapter 
Power Consumption 

2.3 Watts maximum 
Dimensions 

1-1.58″ (tapered) wide x 4.53″ tall x 4.30″ deep 
Weight 

0.4 lbs. 
LAN Connectivity  

RJ-45 10/100 Mbps Ethernet 
PC Connectivity 

USB 1.1 standard 
Wireless Link 

Reliable high-speed link, up to 500′ range 
Processor 

66 MHz ARM 7 
Flash Memory 

16 Mb 
RAM 

16 Mb 
 
*Specifications subject to change without notice. 
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Appendix C: 

Index

Index 

AM/FM Radio, 10, 11, 19, 22, 23, 42, 45, 46, 56, 67, 
86 
call letters, 56, 58, 67, 75, 86, 87, 88 

audio files 
broken, 56, 88 

Bit rate, 97 
component stereo system, 11, 18 
component stereo systems, 10 
Connection 

Ethernet, 10, 11, 12, 14, 20, 114 
LAN, 10, 14, 99, 114 
USB, 10, 11, 12, 14, 20, 114 

Connections, 17, 22 
digital audio formats 

.mp3, 12, 96, 97 

.wma, 12, 96, 97 
Digital Audio Jukebox, 2, 10 
FAV (Favorites 

Adding Favorites, 40 
Deleting Favorites, 41 
FAV View, 40, 41 
Playing Favorites, 41 

FAV (Favorites) Mode, 39 
filepath, 12, 77, 90, 92, 93 
Hardware, 5, 17 
Icons and Music, 24 
Internet Radio, 58, 84 

Add an Internet, 66, 67, 84, 85, 86 
License Agreement, 2 
MP3, 62, 92, 97, 114 
Music Information, 11, 12, 57, 66, 102, 105, 106 

ID3 tags, 12 
metadata, 12, 77, 98 

Music Library, 12, 23, 26, 69, 77, 78 
network, 11, 14, 20, 80, 99, 115 
Operating Systems 

Linux, 11 
Mac OS X, 11 
UNIX, 11 
Windows, 11, 13, 14, 78, 97, 114 

Partners 
Gracenote, 2, 16, 90, 98, 99, 106, 115 

LoudEye, 16 
SHOUTcast, 16 

requirements, 5, 11, 115 
Ripper 

buffer, 95 
encoder, 96 
jitter, 95, 96 
Quality Slider, 97 
Read Mode, 94 
VBR Methods, 97 

shared folders, 12, 13, 14, 82 
Tap and Double-Tap, 24 
TerraPlayer 

Base, 10, 14, 15, 20, 22, 48, 49, 72, 73, 114 
BT-100, 10, 12, 20, 67, 86 
How it Works, 12 
Radio, 10, 11, 12, 17, 18, 19, 20, 21, 22, 23, 42, 45, 

56, 114 
Registering, 12, 15 
Remote, 21, 88, 114 
TerraTouch OS, 2, 4, 5, 10, 11, 23, 24, 31, 39, 48, 

49, 69, 87, 92 
TerraPlayer Radio, 14, 25, 100, 114 
TerraPlayer Utility Suite, 2, 10, 11, 13, 14, 16, 24, 26, 

57 
Librarian, 10, 24, 26, 74, 75, 76, 77, 78, 81 
Monitor, 10 
MusicInfo, 10, 11, 66, 105, 106, 108, 109, 110 
Playlist, 10, 24, 57, 68, 79, 86, 100, 101, 102, 111 
Ripper, 10, 11, 69, 89, 91, 92, 95 
WebServer, 10, 69, 70, 89, 100, 106, 108, 111 

TerraTouch OS 
Library Mode, 23, 25, 27, 29, 31, 34, 40 
Queue Mode, 23, 26, 40, 50, 51, 52 
Radio Mode, 23, 40, 42, 43 
REMOTE Mode, 53 
System Mode, 15, 23, 47 

Touch and Hold, Drag and Drop, 24, 26 
Touchscreen 

Cleaning, 18, 19 
wireless, 10, 11, 15, 18, 19, 20, 48, 72, 114 
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