Chapter 24 Web Authentication

Avuthentication Type

Custom Web Portal File

Custom User Agreement File

Global Setting
( Enable Web AurhemicotioD

Web Portal General Setting
Enable Session Page

oy | et |

Logout IP: 1.1.1.1 i ]
User Agreement General Sefting
[l Enforce data collection @
Exceptional Services
QAdd W
1 DNS
Page |1 of 1 Show |50 v | items Displaying 1-1 of 1
Web Avuthentication Policy Summary
.
1 ? 1 any any any none SSOfforce default-web-portal defaul..
2 Default  any any any none unnecessary n/a n/a
Page |1 of 1 Show |50 |~ | items Displaying 1-2of 2

Make sure you select Enable Policy, Single Sign-On and choose required in Authentication.

Do NOT select any as the source address unless you want all incoming connections to be

authenticated!

& Auth. Policy Add

«5 Create new Object ¥

General Settings
Description:

User Authentication Policy
Incoming Interface:
Source Address:

Destination Address:

Schedule:

Authentication:
Single Sign-on

Force User Authentication @
Authentication Type:

Bl
(Optional)

any v
LAN e INTERFACE SUBNET, 192.168.1.0/24
any v
none v
required v )
defauli-web-porta v

[ ox_|
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See Table 184 on page 462 and Table 185 on page 465 for more information on configuring these
screens.

24.4.4 Create a Security Policy

Configure a Security Policy for SSO traffic source and destination direction in order to prevent the
security policy from blocking this traffic. Go to Configuration > Security Policy > Policy Control and add a
new policy if a default one does not cover the SSO web authentication traffic direction.

[ I

[ Hide Filter

General Seftings

Wl Enable Policy Control

IPv4 Configuration

From: arry ! Service: any b
Tar any ¥ User: any 2
IFv4 Source: Schedule:

IPv4 Destination:

Tl Allow Asymmetrical Route

1 9 LAMI_Qutg... =lAN any [E... any any any any none al.. no G
2 ?  LANZ Outg... =l any (E... any any any any none al... no
3 ] DhI_to_WAN  a DT a WARN any any any any none al... no
4 T IPSec_VPN_... =lFiec... any (E... any any any any none al... no
) ? SSL_VPN_O... . any {E... any any any any noene al.. no
[ ] TUNNEL_Ou... any (E... any any any any none al... no
7 ? LANI _to_D... IyWall any any any any none al.. no
& ] LANZ_to_D... IyWALL any any any any none al... no
? ¥ DMItoDe.. IyWALL  any any Def none al... no
10 ] WAN_to_De... IyWALL any any none al... no
1 ? IPSec VPM_... . LyWALL  any any none al... no
12 @ S VPN te S5 W FuWALL anw any none ol nn

Configure the fields as shown in the following screen. Configure the source and destination addresses
according to the SSO web authentication traffic in your network.
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€ Add corresponding Zx
«= Create new Object v
Name: MySSOSecurePolicy
Description: (Optional)
From: any v
To: any (Excluding ZyV v
ource: LANT_SUBNET Ee
Destination: any v
ervice: 350 v
User: any v
Schedule: none v
(Action: allow ~)
Log matched traffic: no v
- ok

24.4.5 Configure User Information

Configure a User account of the ext-group-user type.

User Group Setting MAC Address
Configuration

@ Add | |
1 admin admin Administration account 1
2  Idap-users ext-user External LDAP Users 0
3 radius-users ext-user External RADIUS Users 0
4  ad-users ext-user External AD Users 0
5 ua-users dynamic-guest User Agreement Users 0
6 leo ext-user Leo 0

Page |1 of 1 Show |50 |w | items Displaying 1 -6 of 6

Configure Group ldentifier to be the same as Group Membership on the SSO agent.
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€ Add A User el |5
User Configuration
User Name : | ()
User Type: GxT—group—user v>
| o
Associated AAA Server Object: ad v
Description: [$50 Usef
Authentication Timeout Setfings @ yse Default Settings © Use Manual Settings
Lease Time: 1440 minutes
Reauthentication Time: 1440 minutes

[[] User VLAN ID:

Configuration Validation

Please enter a user account existed in the configured group to validate above settings.

User Name : m

-

24.4.6 Configure an Authentication Method

Configure Active Directory (AD) for authentication with SSO.

Authentication Method

Configuration
w

1 default local

Page |1 of 1 Show 50 |» | items Displaying 1-1 of 1

Choose group ad as the authentication server for SSO.

€ Add Authentication Method

General Seftings
Name: | |0
@ Add H Ecit W Remove oM Move

1| v
ey

group ad

group ldap

group radius

group New
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24.4.7 Configure Active Directory

You must configure an Active Directory (AD) server in AAA Setup o be the same as AD configured on
the SSO agent.

Active Directory LDAP RADIUS

AD Server Summary

1 ad

Page |1 of 1 Show 50 |» | items Displaying 1-1 of 1

The default AD server port is 389. If you change this, make sure you make the same changes on the SSO.
Configure the Base DN exactly the same as on the Domain Conftroller and SSO. Bind DN is a user name
and password that allows the Zyxel Device to join the domain with administrative privileges. It is a
required field.

& Add Active Directory e

General Settings
Name: New (1]

Description: (Optional)

Server Settings

L
Backup Server Address: (IP or FQDN){Optional)
Port: 389 (1-65535)

e
TOseSS5L
Search time limit: 5 (1-300 seconds)

Case-sensifive User Names @

Server Authentication
Bind DN:
Password:

Retype to Confirm:
User Login Settings

Login Name Attribute: sAMAcCcountName
Altfemative Login Name Affribute: (Optional)
Group Membership Affribute: mempberof

Domain Authentication for MSChap
[ Enable
User Name: i ]
User Password:
Retype to Confirm:
Realm:

NetBIOS Name:

Configuration Validation

Please enter an existing user account in this server to validate the above seftings.
Username:

ZyWALL ATP Series User’s Guide

485



Chapter 24 Web Authentication

24.5 SSO Agent Configuration

This section shows what you have to do on the SSO agent in order to work with the Zyxel Device.

After you install the SSO agent, you will see anicon in the system fray (bottom right of the screen)

m B e & - Fd % D) FE030s

Disable ZyXEL S5O Agent
B Configure ZyXEL 550 Agent

Log
Logon user lists
Diagnestic tools
Change Service Setting
Help

About ZyXEL 550 Agent

Pd M T g TEE0306

Configure the Agent Listening Port, AD server exactly as you have done on the Zyxel Device. Add the
Zyxel Device IP address as the Gateway. Make sure the Zyxel Device and SSO agent are able to
communicate with each other.
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General Setting:
Agent Listening Port: 2158 (1025 - 65535)
Logon List Check Interval {rinute): 30 (10- 1440)
Configure LDAP/AD server

Gateway Settings

l Add ] l Modify ] l Delete ]

Active  Index  Description IP Port Share Key

El 1 et 19216311 2158 |~ |

Configure the Server Address, Port, Base DN, Bind DN, Login Name Attribute and Group Membership for
the AD server settings exactly as you have done on the Zyxel Device. Group Membership is called Group
Identifier on the Zyxel Device.

LDAP/AD Server Configuration
73 029/2D serercon |

General Settings
Name ad-server|
Description
Server Settings
Server Address 192.168.1.220
Backup Server Address
Port 383
Base DN do=sso.de=win2012,dc=com
7] Use SSL
Search time limit 5
Server Authentication
Bind DN agent
Password e
Retype to Confim "es
User Settings
Group Membership Attribute memberCf
Configuration Validation
Please enter the existing user account in this server to validate the above settings
Usemame Test
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Configure the Gateway IP address, Gateway Port and PreShareKey exactly as you have done in the
Zyxel Device Configuration > Web Authentication > SSO screen. If you want to use Generate Key to have
the SSO create a random password, select Check to show PreShareKey as clear Text so as fo see the
password, then copy and paste it to the Zyxel Device.

—
A Gateway Setting u

Gateway |P: | IPv4 Address

Gateway Port 2158 (1025 - 65535)

Description

[ Check to show PreShareKey as clear Text

(o< ] [cme

After all SSO agent configurations are done, right-click the SSO icon in the system fray and select Enable
Zyxel SSO Agent.

Configurr Zy4EL S50 Agent
Leg

= Logon user lists

Diagnastic toals
Change Service Setting
/ (S ’ . __,--—-“""_—"'\‘ Help
e B T M e U > " Apost THARL S50 Atk
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CHAPTER 25
Security Policy

25.1 Overview

A security policy is a template of security settings that can be applied to specific traffic at specific times.
The policy can be applied:

* to a specific direction of fravel of packets (from / to)
* fo a specific source and destination address objects
» to a specific type of traffic (services)

* fo a specific user or group of users

* af a specific schedule

The policy can be configured:

¢ to allow or deny traffic that matches the criteria above
¢ send a log or alert for traffic that matches the criteria above

« to apply the actions configured in the profiles (application patrol, content filter, IDP, anti-malware,
email security) to traffic that matches the criteria above

Note: Security policies can be applied fo both IPv4 and IPvé traffic.

The security policies can also limit the number of user sessions.

The following example shows the Zyxel Device’s default security policies behavior for a specific direction
of tfravel of packets. WAN to LAN fraffic and how stateful inspection works. A LAN user can initiate a
Telnet session from within the LAN zone and the Zyxel Device allows the response. However, the Zyxel

Device blocks incoming Telnet traffic initiated from the WAN zone and destined for the LAN zone.

Figure 341 Default Directional Security Policy Example

LAN

==
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25.2 One Security

OneSecurity is a website with guidance on configuration walkthroughs, tfroubleshooting, and other
information. This is an example of a port forwarding configuration walkthrough.

Figure 342 Example of a Port Forwarding Configuration Walkthrough.

Welcome to the Port Forwarding Wizard 1 Welcome to the Port Forwarding Wizard 2
\Welcome to the USG/ZyWALL Port Forwarding Walkihrough Generator. In the next We need to gather information about your network including the Port(s) that need
step you will be given an option to choose the type of forwarding you would like to to be forwarded and what address they need to be forwarded to.
do and input some basic information about your network Once finished a custom
walkthrough will be generated for you.
Step 1
Select Wizard Type What is the port # that you need to forward?
Port Forwarding E|
With port forwarding, devices on the inside of your network are reached by a What is the IP address that you need to forward to?:
specified port on your Public IP. Port Forwarding is often used for applications such
as Remote Desktop. Web Servers. software applications, and gaming consoles.
«— Prev Next—
Next—
Step 2 3 Finish Wizard 4
In the USG. we wil create objects for the port and the address that the part will be Please ensure the following information is correct. If it is not, please go back and
forwarded to. . Down below, please enter in the name for these objects. Do not use correct the item.
spaces.
Port: 8080
What do you want to call the Port Forward Object?
Port Name: web
Forwarding Address: 1.1.1.1
What do you want to call the Address Object?
Forwarding Address Name: addr
— Prev «— Prev

This is an example of L2TP over IPSec VPN Troubleshooting troubleshooting.
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Figure 343 Example of L2TP over IPSec Troubleshooting - 1

L2TP over IPSec VPN Troubleshooting

Is the VPN established?

(@] Yesl
i Mo -1 receive an err0r2
@ My connection is intermittent 3

Mo Connection 2

Commaon Configuration 1ssues
* Verily i the USGE has defaull s2Tings for he Defaull_LSTP_WPN nules In the IPSec VPN memu
- 0 WIPN Cateway ansune your SATIngs manch below. You will also nead 5 olick The Show Advanoed SaTings option &t T 100

Phase 1 Sritngs

S Ly Ty Beacz {0 - MR Sk
Hegomamon bpge: var ~
Pt Qas ]
@ Bnorygfoe - Asaeicsion
1 xes a1
oS ugs
ces a1
R AT L -

] FAT Trmvernal
W CeadPos Deternon D0

Phuase node Tt jou will Rot e stk 00 assaniish T LETP conmaction I jour WAN connaction IS assigran & privace 1P You mus: fase & public 1P soinss sssignan dinsctly 50 T WAN port

o VPN Cormeciion, ansane pour S2TIngs manch below. You will aiso need %o Click e Show Aovanced S2Tings opthon &t e oo,
Phase 7 Seifing

A Lify T B el - W) Secas]
e Prosscn = =
Ereapmistiorc f— -
s CL 1
" O B
=i frr
=2 [
oS SHAL
Perfect Pormard Sececy (RS e b

Yo willl e 50 cresne an atidress iofec for pour WAN (cusigepulic) IR, and sk this ook for e Local Pallcy,

) Create AdER LIE
i -
e Tyme: HOBT -
TP Ao T8 2T 2L D

& ARemariely you Can S5H Mo e LSO and Issue & Series of commands 10 detsult ;e LITP Sesings,

b Create Adderss 1%
Home: L
sckdress Tyoe: HOET ~
P addem: T 1377134

OnOR o hae The SASTION aSanlishan FOuSE ™Il R 50 arar STConTgrs SarmInSISE™ and press amar. TREN §P2 THe COMISN SETIDD-OMA DA Meoouer et insas-DolicySE ™ 1D satsull TE nules

* erify T firewall s s20u0 propery 20 allow Taffic from IPSec zone 2o aliany).

Logs To Look For

LETP Conneched

LETP Disconnecied
IICOMETT LSS RSSO
o propasail chose
Phase 1 proposal mismanch
ncomect PSK
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Figure 344 Example of L2TP over IPSec Troubleshooting - 2

Intermittent Connection 3

® ISP Issues’

o In some cases your ISP may be blocking specific ports necessary to establish and maintain the VPN connection
= An easy way to verify this would be to initiate the connection to the USG, if nothing displays in the logs it is likely that cerfain poris are being blocked even before they reach the USG
= Services Necessary:

= [KE

= GRE

= AH

= NATT
e Slow Speeds

o There are several factors that influence the overall bandwidth of the VPN tunnel
= Additional delays can be caused by the encryption and decryption process, especially with internet traffic.
= The network speeds of the L2TP client

« Remote Network Issues

o In certain cases we may need to check the settings of the remoie router or gateway.
= [f available, we want to ensure that any IPSec or L2TP pass-through is enabled
= We may need to forward ports to the L2TP client to ensure a stable connection

= Services Necessary
= L2TP
= GRE
e Logs to Look For:
o L2TP Connect/Disconnect
o No tunnel found errors

Go Back To Start

In the Zyxel Device, you will see icons that link to OneSecurity walkthroughs, froubleshooting and so onin

certain screens.

For example, at the time of writing, these are the OneSecurity icons you can see.

Table 191 OneSecurity Icons

ONESECURITY ICON SCREEN

Click this icon to go to a series of screens that guide you how to configure the

Lonmguration show you how to do it.
* Walkthrougr
* Device HA > General
* Licensing > Registration
e Network > NAT
* Network > Routing > Policy Route
e Security Service > App Patrol
e Security Service > Content Filter
e Security Service > IDP
* Security Service > Anti-Malware
e Security Service > Email Security
* VPN >[PSec VPN
* VPN >SSL VPN
e VPN >L2TP VPN

feature. Note that the walkthroughs do not perform the actual configuring, but just

feature.

C"!. roubleshooting | | Device HA > General

*  Network > NAT

¢ Network > Routing > Policy Route
e Security Service > App Patrol

e Security Service > Content Filter
e Security Service > IDP

e Security Service > Anti-Malware
» Security Service > Email Security
e VPN >[PSec VPN

e VPN >SSL VPN

* VPN >L2TP VPN

Click this icon to go to a series of screens that guide you how fo fix problems with the
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Table 191 OneSecurity Icons (continued)
ONESECURITY ICON SCREEN

Click this icon for more information on Application Patrol, which identifies fraffic that
. . passes through the Zyxel Device, so you can decide what to do with specific types
Bgm Application of traffic. Traffic not recognized by application patrol is ignored.

*B patrol .

Security Service > Application Patrol

Click this icon for more information on Content Filter, which controls access to
specific web sites or web content.

G': Content Filter

* Security Service > Content Filter

Click this icon for more information on IPSec and SSL VPN. Internet Protocol Security
(IPSec) VPN connects IPSec routers or remote users using IPSec client software. SSL
ﬂ /PN VPN allows users to use a web browser for secure remote user login without need of
a VPN router or VPN client software.

* VPN >[PSec VPN
*  VPN>SSLVPN

Click this icon to download VPN client software.

Download e VPN >|PSec VPN
e VPN Cliont ¢ VPN >SSL VPN

Click this icon for more information on the Wireless AP Controller which sets how the
Zyxel Device allows APs to connect to the wireless network.

Py ontroller *  Wireless > AP Management > Mgnt. AP List

25.3 What You Can Do in this Chapter

* Use the Security Policy Control screens (Section 25.4 on page 495) to enable or disable policies,
asymmetrical routes, and manage and configure policies.

¢ Use the Anomaly Detection and Prevention (ADP) screens (Section 25.5 on page 501) to detect fraffic
with protocol anomalies and take appropriate action.

* Use the Session Control screens (see Section 25.5 on page 501) to limit the number of concurrent NAT/
security policies traffic sessions a client can use.

25.3.1 What You Need to Know

Stateful Inspection
The Zyxel Device uses stateful inspection in its security policies. The Zyxel Device restricts access by

screening data packets against defined access rules. It also inspects sessions. For example, fraffic from
one zone is not allowed unless it is initiated by a computer in another zone first.

Zones

A zone is a group of interfaces. Group the Zyxel Device's interfaces into different zones based on your
needs. You can configure security policies for data passing between zones or even between interfaces.
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Default Directional Security Policy Behavior

Security Policies can be grouped based on the direction of tfravel of packets to which they apply. Here
is the The Zyxel Device has default Security Policy behavior for fraffic going through the Zyxel Device in
various directions.

Table 192 Directional Security Policy Behavior

FROM ZONE TO ZONE BEHAVIOR

From any fo Device DHCP traffic from any interface to the Zyxel Device is allowed.

From LAN1 to any (other than Traffic from the LAN1 to any of the networks connected to the Zyxel Device is
the Zyxel Device) allowed.

From LAN2 to any (other than Traffic from the LAN2 to any of the networks connected to the Zyxel Device is
the Zyxel Device) allowed.

From LANT1 to Device Traffic from the LAN1 to the Zyxel Device itself is allowed.
From LAN2 to Device Traffic from the LAN2 to the Zyxel Device itself is allowed.
From WAN fo Device The default services listed in To-Device Policies are allowed from the WAN fo the

Zyxel Device itself. All other WAN to Zyxel Device fraffic is dropped.

From any to any Traffic that does not match any Security policy is dropped. This includes traffic
from the WAN to any of the networks behind the Zyxel Device.

This also includes fraffic to or from interfaces that are not assigned to a zone
(extra-zone fraffic).

To-Device Policies
Policies with Device as the To Zone apply to traffic going to the Zyxel Device itself. By default:

* The Security Policy allows only LAN, or WAN computers to access or manage the Zyxel Device.
¢ The Zyxel Device allows DHCP traffic from any interface to the Zyxel Device.

* The Zyxel Device drops most packets from the WAN zone to the Zyxel Device itself and generates a
log except for AH, ESP, GRE, HTTPS, IKE, NATT.

When you configure a Security Policy rule for packets destined for the Zyxel Device itself, make sure it
does not conflict with your service control rule. The Zyxel Device checks the security policy before the
service control rules for traffic destined for the Zyxel Device.

A From Any To Device direction policy applies to traffic from an interface which is not in a zone.

Global Security Policies

Security Policies with from any and/or to any as the packet direction are called global Security Policies.
The global Security Policies are the only Security Policies that apply fo an interface that is not included in
a zone. The from any policies apply to traffic coming from the interface and the to any policies apply to
fraffic going to the interface.

Security Policy Rule Criteria

The Zyxel Device checks the schedule, user name (user’s login name on the Zyxel Device), source IP
address and object, destination IP address and object, IP protocol type of network traffic (service) and
Security Service profile criteria against the Security Policies (in the order you list them). When the traffic
matches a policy, the Zyxel Device takes the action specified in the policy.
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User Specific Security Policies

You can specify users or user groups in Security Policies. For example, to allow a specific user from any
computer to access a zone by logging in to the Zyxel Device, you can set up a policy based on the user
name only. If you also apply a schedule to the Security Policy, the user can only access the network at
the scheduled fime. A user-aware Security Policy is activated whenever the user logs in to the Zyxel
Device and will be disabled after the user logs out of the Zyxel Device.

Session Limits

Accessing the Zyxel Device or network resources through the Zyxel Device requires a NAT session and
corresponding Security Policy session. Peer to peer applications, such as file sharing applications, may
use a large number of NAT sessions. A single client could use all of the available NAT sessions and
prevent others from connecting to or through the Zyxel Device. The Zyxel Device lets you limit the
number of concurrent NAT/Security Policy sessions a client can use.

25.4 The Security Policy Screen

Asymmetrical Routes

If an alternate gateway on the LAN has an IP address in the same subnet as the Zyxel Device's LAN IP
address, return traffic may not go through the Zyxel Device. This is called an asymmetrical or “triangle”
route. This causes the Zyxel Device to reset the connection, as the connection has not been
acknowledged.

You can have the Zyxel Device permit the use of asymmetrical route topology on the network (not reset
the connection). However, allowing asymmetrical routes may let traffic from the WAN go directly to the
LAN without passing through the Zyxel Device. A better solution is to use virtual interfaces to put the Zyxel
Device and the backup gateway on separate subnets. Virtual interfaces allow you to partition your
network into logical sections over the same interface. See the chapter about interfaces for more
information.

By putting LAN 1 and the alternate gateway (A in the figure) in different subnets, all returning network

traffic must pass through the Zyxel Device to the LAN. The following steps and figure describe such a
scenario.

1 A computer on the LANT1 initiates a connection by sending a SYN packet to a receiving server on the
WAN,

2 The Zyxel Device reroutes the packet to gateway A, which is in Subnet 2.
3 Thereply from the WAN goes to the Zyxel Device.

4  The Zyxel Device then sends it to the computer on the LANT in Subnet 1.
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Figure 345 Using Virtual Interfaces to Avoid Asymmetrical Routes

LAN 1 Subnet 11

25.4.1 Configuring the Security Policy Control Screen

Click Configuration > Security Policy > Policy Control to open the Security Policy screen. Use this screen
fo enable or disable the Security Policy and asymmetrical routes, set a maximum number of sessions per
host, and display the configured Security Policies. Specify from which zone packets come and to which
zone packets travel to display only the policies specific to the selected direction. Note the following.

* Besides configuring the Security Policy, you also need to configure NAT rules to allow computers on
the WAN fo access LAN devices.

* The Zyxel Device applies NAT (Destination NAT) settings before applying the Security Policies. So for
example, if you configure a NAT entry that sends WAN fraffic to a LAN IP address, when you configure
a corresponding Security Policy to allow the fraffic, you need to set the LAN IP address as the
destination.

¢ The ordering of your policies is very important as policies are applied in sequence.

The following screen shows the Security Policy summary screen.

ZyWALL ATP Series User’s Guide

496



Chapter 25 Security Policy

Figure 346 Configuration > Security Policy > Policy Control

[ Hide Filter

General Settings

[l Enable Palicy Control

IPv4 Configuration

From: any N Service: any N
To: any N User: any N
IPv4 Source: Schedule: C]

IPv4 Destination:

[C] Allow Asymmetrical Route

© Add |

1 Q@  LANI_Oufg... =LANI  any[E.. any any any any none al... no &
2 ? LAN2 Outg... =LAN2 any (E... any any any any none al... no

3 ? DMZ_to_WAN = DA a WAN any any any any none al... no

4 ? IPSec_VPN_... =lIPSec... any(E... any any any any none al... no

5 ? SSL_LVPN_O... aSSL_... any(E.. any any any any none al... no

6 ? TUNNEL_Ou... alUNNEL any (E... any any any any none al... no

7 ? LANT_to_D... alAN IyWALL  any any any any none al... no

8 ? LAN2 to_D... =alAN2 IyWALL any any any any none al... no

? ? DMZ_to_De... IyWALL any any aDefa... any none al... no

10 9 WAN_foD... IyWALL any any aDefa... any none al... no

1 ? IPSec_VPN_... IyWALL  any any any any none al... no

12 ? SSL_VPN_fo... IyWALL any any any any none al... no

13 ? TUNNEL_fo_... IyWALL any any any any none al... no

D... any any any any any none d... log

Page |1 of 1 Show |50 | ¥ | items Displaying 1- 14 of 14

IPvé Configuration

From: any - Service: any -
To: any N User: any N
Source: Schedule: C]
Destination:

seorcn | perer|

] Allow Asymmetrical Route

© Add |

1 ? Device_Def... any IyWALL  any any aDefa... any none al... no
2 ? LANT_Outg... =LAN any (E... any any any any none al... no
3 ? LANZ_Outg... =LANZ any (E... any any any any none al... no
4 Q@ DMI_to_WAN =Dk aWAN  any any any any none al... no
5 ? IPSec_VPN_... any (E... any any any any none al... no
6 ? SSLLVPN_O... =SSl ... any(E.. any any any any none al... no
7 ? TUNNEL_Ou... =TUNMNEL any (E... any any any any none al... no
8 ? LAN1_to D... =aLAN IyWALL any any any any none al... no
? ? LAN2_fo_D... alANZ IyWALL  any any any any none al... no
10 ? DMZ_to_De... =DMZ IyWALL any any aDefa... any none al... no
1 ? WAN_to_D... aWAN IyWALL  any any aDefa... any none al... no
12 ? IPSec_VPN_... = IyWALL any any any any none al... no
13 ? SSLLVPN_fo... =SSL... ZIyWALL any any any any none al.. no
14 ? TUNNEL_fo_... =TUNNEL ZyWALL any any any any none al... no
D... any any any any any any none d... log

Page |1 of 1 Show |50 | v | items Displaying 1-15of 15

Covey | roer
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The following table describes the labels in this screen.

Table 193 Configuration > Security Policy > Policy Control

LABEL

DESCRIPTION

Show Filter/Hide
Filter

Click Show Filter to display IPv4 and IPvé (if enabled) security policy search filters.

General Settings

Enable or disable the Security Policy feature on the Zyxel Device.

Enable Policy

Select this to activate Security Policy on the Zyxel Device to perform access control.

Control
IPv4 / IPvé Use IPv4 / IPvé search filters to find specific IPv4 and IPvé (if enabled) security policies based on
Configuration direction, application, user, source, destination and/or schedule.
From / To Select a zone to view all security policies from a particular zone and/or to a particular zone.
any means all zones.
IPv4 / IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé source
Source address object used.
¢ AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPv6 address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
IPv4 /IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé destination
Destination | address object used.
* AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPvé address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
Service View all security policies based the service object used.
User View all security policies based on user or user group object used.
Schedule View all security policies based on the schedule object used.
IPv4/IPvé Policy Use the following items to manage IPv4 and IPvé policies.
Management
Allow ) If an alternate gateway on the LAN has an IP address in the same subnet as the Zyxel Device's
é\syrpmemcol LAN IP address, return fraffic may not go through the Zyxel Device. This is called an
oure asymmetrical or “tfriangle” route. This causes the Zyxel Device to reset the connection, as the
connection has not been acknowledged.
Select this check box to have the Zyxel Device permit the use of asymmetrical route topology
on the network (not reset the connection).
Note: Allowing asymmetrical routes may let traffic from the WAN go directly fo the
LAN without passing through the Zyxel Device. A better solution is fo use virtual
intferfaces to put the Zyxel Device and the backup gateway on separate
subnefs.
Add Click this to create a new entry. Select an entry and click Add to create a new entry after the
selected enfry.
Edit Double-click an entry or select it and click Edit to open a screen where you can modify the
entry’s seftings.
Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove
it before doing so.
Activate To turn on an entry, select it and click Activate.
Inactivate To turn off an enftry, select it and click Inactivate.
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Table 193 Configuration > Security Policy > Policy Control (continued)

LABEL DESCRIPTION
Move To change a policy’s position in the numbered list, select the policy and click Move to display a
field to type a number for where you want to put that policy and press [ENTER] fo move the
policy to the number that you typed.
The ordering of your policies is important as they are applied in order of their numbering.
Clone Use Clone to create a new entry by modifying an existing one.

* Select an existing entry.
* Click Clone, type a number where the new enfry should go and then press [ENTER].

* A configuration copy of the selected enfry pops up. You must at least change the name as
duplicate entry names are not allowed.

The following read-only fields summarize the policies you have created that apply to fraffic traveling in the
selected packet direction.

Priority This is the position of your Security Policy in the global policy list (including all through-Zyxel
Device and to-Zyxel Device policies). The ordering of your policies is important as policies are
applied in sequence. Default displays for the default Security Policy behavior that the Zyxel
Device performs on traffic that does not match any other Security Policy.

Status This icon is lit when the enftry is active and dimmed when the entry is inactive.

Name This is the name of the Security policy.

From / To This is the direction of fravel of packets. Select from which zone the packets come and to

which zone they go.

Security Policies are grouped based on the direction of tfravel of packets to which they apply.
For example, from LAN to LAN means packets traveling from a computer or subnet on the LAN
to either another computer or subnet on the LAN.

From any displays all the Security Policies for fraffic going to the selected To Zone.
To any displays all the Security Policies for fraffic coming from the selected From Zone.
From any to any displays all of the Security Policies.

To ZyWALL policies are for traffic that is destined for the Zyxel Device and control which
computers can manage the Zyxel Device.

IPv4 / IPv6 Source

This displays the IPv4 / IPvé source address object, including geographic address and FQDN
(group) objects, to which this Security Policy applies.

IPv4 / IPvé This displays the IPv4 / IPvé destination address object, including geographic address and
Destination FQDN (group) objects, to which this Security Policy applies.
Service This displays the service object to which this Security Policy applies.

User This is the user name or user group name to which this Security Policy applies.

Schedule This field tells you the schedule object that the policy uses. none means the policy is active at all
fimes if enabled.

Action This field displays whether the Security Policy silently discards packets without nofification
(deny), permits the passage of packets (allow) or drops packets with notification (reject)

Log Select whether to have the Zyxel Device generate a log (log). log and alert (log alert) or not
(no) when the policy is matched fo the criteria listed above.

Profile This field shows you which Security Service profiles (application patrol, content filter, IDP, anti-
malware, email security) apply to this Security policy. Click an applied Security Service profile
icon to edit the profile directly.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings.
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25.4.2 The Security Policy Control Add/Edit Screen

In the Security Policy Control screen, click the Edit or Add icon to display the Security Policy Edit or Add
screen.

Figure 347 Configuration > Security Policy > Policy Control > Add

# Add corresponding FX
u Creafe new Objectw
[¥ Enable
Name: |0
Description: (Cptional)
From: any v
To: any (Excluding ZyV| v
Source: any v
Destination: any %
Service: any v
Schedule: none b
Action: allow v
Log matched fraffic: no %
Profile
Application Patrol: none %
Content Filter: none A
S3L Inspection: nong v
Cancel
The following table describes the labels in this screen.
Table 194 Configuration > Security Policy > Policy Control > Add

LABEL DESCRIPTION

Create new Use to configure any new settings objects that you need to use in this screen.

Object

Enable Select this check box to activate the Security policy.

Name Type a name to identify the policy

Description Enter a descriptive name of up to 60 printable ASCII characters for the Policy. Spaces are
allowed.

From For through-Zyxel Device policies, select the direction of travel of packets to which the policy
applies.

To
any means all interfaces.

Device means packets destined for the Zyxel Device itself.

Source Select an IPv4 / IPv6 address or address group object, including geographic address and FQDN
(group) objects, to apply the policy to traffic coming from it. Select any to apply the policy to all
traffic coming from IPv4 / IPvé addresses.

Destination Select an IPv4 / IPvé address or address group, including geographic address and FQDN (group)
objects, to apply the policy to traffic going to it. Select any to apply the policy fo all traffic going
to IPv4 / IPvé addresses.

Service Select a service or service group from the drop-down list box.
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Table 194 Configuration > Security Policy > Policy Control > Add (confinued)

LABEL DESCRIPTION

User This field is not available when you are configuring a to-Zyxel Device policy.
Select a user name or user group to which to apply the policy. The Security Policy is activated
only when the specified user logs info the system and the policy will be disabled when the user
logs out.
Otherwise, select any and there is no need for user logging.
Note: If you specified a source IP address (group) instead of any in the field below, the

user's IP address should be within the IP address range.

Schedule Select a schedule that defines when the policy applies. Otherwise, select none and the policy is
always effective.

Action Use the drop-down list box to select what the Security Policy is to do with packets that match this

policy.

Select deny to silently discard the packets without sending a TCP reset packet or an ICMP
destfination-unreachable message to the sender.

Select reject to discard the packets and send a TCP reset packet or an ICMP destination-
unreachable message to the sender.

Select allow to permit the passage of the packets.

Log matched
traffic

Select whether to have the Zyxel Device generate alog (log). log and alert (log alert) or not (no)
when the policy is matched to the criteria listed above..

Profile Use this section to apply anti- x profiles (created in the Configuration > Security Service screens)
to fraffic that matches the criteria above. You must have created a profile first; otherwise none
displays.

Use Log to generate alog (log), log and alert (log alert) or not (no) for all traffic that matches
criteria in the profile.
Application | Select an Application Patrol profile from the list box; none displays if no profiles have been
Patrol created in the Configuration > Security Service > App Patrol screen.
Content Select a Content Filter profile from the list box; none displays if no profiles have been created in
Filter the Configuration > Security Service > Content Filter screen.
SSL . Select an SSL Inspection profile from the list box; none displays if no profiles have been created in
Inspection the Configuration > Security Service > SSL Inspection screen.
oK Click OK to save your customized settings and exit this screen.
Cancel Click Cancel fo exit this screen without saving.

25.5 Anomaly Detection and Prevention Overview

Anomaly Detection and Prevention (ADP) protects against anomalies based on violations of protocol
standards (RFCs — Requests for Comments) and abnormal flows such as port scans. This section
infroduces ADP, anomaly profiles and applying an ADP profile to a traffic direction.

Traffic Anomalies

Traffic anomaly policies look for abnormal behavior or events such as port scanning, sweeping or
network flooding. They operate at OSI layer-2 and layer-3. Traffic anomaly policies may be updated
when you upload new firmware.
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Protocol Anomalies

Protocol anomalies are packets that do not comply with the relevant RFC (Request For Comments).
Protocol anomaly detection includes:

e TCP Decoder
e UDP Decoder
¢ |ICMP Decoder

Protocol anomaly policies may be updated when you upload new firmware.

Note: First, create an ADP profile in the In the Configuration > Security Policy > ADP > Profile
screen.

Then, apply the profile to traffic originating from a specific zone in the Configuration >
Security Policy > ADP > General screen.

25.5.1 The Anomaly Detection and Prevention General Screen

Click Configuration > Security Policy > ADP > General to display the next screen.

Figure 348 Configuration > Security Policy > ADP > General

General Settings

Enable Anomaly Defection and Prevention

Policies

© Add

1 ? ADP_PROFILE

Page |1 of 1 Show |50 |w items Displaying 1 -1 of 1

The following table describes the labels in this screen.

Table 195 Configuration > Security Policy > ADP > General

LABEL DESCRIPTION

General Seftings

Enable Anomaly Detection | Select this to enable traffic anomaly and protocol anomaly detection and

and Prevention prevention.
Add Select an entry and click Add to append a new row beneath the one selected. ADP
policies are applied in order (Priority) shown in this screen
Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this to delete it.
Activate To turn on an entry, select it and click Activate.
Inactivate To turn off an entry, select it and click Inactivate.
Move To change an entry’s position in the numbered list, select it and click Move to display

a field to type a number for where you want to put that entry and press [ENTER] to
move the entry to the number that you typed.

# This is the entry’s index number in the list.
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Table 195 Configuration > Security Policy > ADP > General

LABEL DESCRIPTION

Priority This is the rank in the list of anomaly profile policies. The list is applied in order of
priority.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the

entry is inactive.

From This is the direction of travel of packets to which an anomaly profile is bound. Traffic
direction is defined by the zone the fraffic is coming from.

Use the From field to specify the zone from which the traffic is coming. Select ZyWALL
to specify traffic coming from the Zyxel Device itself.

From LAN means packets fraveling from a computer on one LAN subnet to a
computer on another subnet via the Zyxel Device's LAN1 zone interfaces. The Zyxel
Device does not check packets traveling from a LAN computer to another LAN
computer on the same subnet.

From WAN means packets that come in from the WAN zone and the Zyxel Device
routes back out through the WAN zone.

Note: Depending on your network fopology and traffic load, applying
every packet direction to an anomaly profile may affect the Zyxel
Device's performance.

Anomaly Profile An anomaly profile is a set of anomaly policies with configured activation, log and
action settings. This field shows which anomaly profile is bound to which traffic
direction. Select an ADP profile to apply to the enfry’s fraffic direction. Configure the
ADP profiles in the ADP profile screens.

25.5.2 Creating New ADP Profiles

Create new ADP profiles in the Configuration > Security Policy > ADP > Profile screens.

When creating ADP profiles. you may find that certain policies are friggering too many false positives or
false negatives. A false positive is when valid fraffic is flagged as an attack. A false negative is when
invalid traffic is wrongly allowed to pass through the Zyxel Device. As each network is different, false
positives and false negatives are common on initial ADP deployment.

To counter this, you could create a ‘monitor profile’ that creates logs, but all actions are disabled.
Observe the logs over time and try to eliminate the causes of the false alarms. When you're satisfied that
they have been reduced to an acceptable level, you could then create an ‘in-line profile’ whereby you
configure appropriate actions to be taken when a packet matches a policy.

ADP profiles consist of fraffic anomaly profiles and protocol anomaly profiles. To create a new profile,
select a base profile and then click OK to go to the profile details screen. Type a new profile name,
enable or disable individual policies and then edit the default log options and actions.

Click Configuration > Security Policy > ADP > Profile to view the following screen.
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Figure 349 Configuration > Security Policy > ADP > Profile

Profile

Profile Management

@ Add

1 ADP_PROFILE all 1
Page |1 of 1 Show |50 |~ | items Displaying 1-1 of 1

The following table describes the labels in this screen.

Table 196 Configuration > Security Policy > ADP > Profile

LABEL DESCRIPTION

Profile Management Create ADP profiles here and then apply them in the Configuration > Security Policy
> ADP > Profile screen.

Add Click Add and first choose a none or all Base Profile.

* none base profile sets all ADP enfries to have Log set to no and Action set fo
none by default.

* all base profile sefs all ADP entries fo have Log set to log and Action setf to block

by default.
Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this o delete it.
References Select an entry and click References to open a screen that shows which settings use

the entry. Click Refresh to update information on this screen.

Clone Use Clone to create a new entry by modifying an existing one.

* Select an existing entry.
* Click Clone.

e A configuration copy of the selected entry pops up. You must at least change
the name as duplicate entry names are not allowed.

# This is the enftry’s index number in the list.

Name This is the name of the profile you created.

Description This is the description of the profile you created.

Base Profile This is the name of the base profile used to create this profile.
Reference This is the number of object references used to create this profile.

25.5.3 Traffic Anomaly Profiles

Traffic anomaly detection looks for abnormal behavior such as scan or flooding attempts. In the
Configuration > Security Policy > ADP > Profile screen, click the Edit or Add icon and choose a base
profile. Traffic Anomaly is the first tab in the profile.
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Figure 350 Configuration > Security Policy > ADP > Profile > Add-Traffic-Anomaly

# Edit Anomaly Profile 211
Protocel Anomaly
General
Name: ADP_PROFILE
Description:
Scan Detection
Sensitivity: medium N7
Block Period: 5 [1-3600 seconds)
1 @ (portscan) IP Protocol Scan log block
2 9 (portscan) TCP Portscan log block
3 9 (poriscan) UDP Porfscan log block
4 @ (sweep) ICMP Sweep log block
5 9 (sweep) IP Profocol Sweep log block
& 9 (sweep) TCP Port Sweep log block
7 9 (sweep) UDP Port Sweep log block
Page |1 of 1 Show |50 |» items Displaying 1-7 of 7
Flood Detection
Block Period: 5 [1-3600 seconds)
19 (flood) ICMP Flood log block 1000
2 ] (flood) IP Flood log block 1000
3 @ (flood) TCP Flood log block 1000
4 (flood) UDP Flood log block 1000
Page |1 of 1 Show |50 |w items Displaying 1 - 4 of 4
OK Cancel Save

The following table describes the labels in this screen.

Table 197 Configuration > Security Policy > ADP > Profile > Add-Traffic-Anomaly

LABELS DESCRIPTION

Name

A name is automatically generated that you can edit. The name must be the same
in the Traffic Anomaly and Protocol Anomaly screens for the same ADP profile. You
may use 1-31 alphanumeric characters, underscores(_), or dashes (-), but the first
character cannot be a number. This value is case-sensitive. These are valid, unique
profile names:

MyProfile
mYProfile
Mymy12_3-4

These are invalid profile names:

1mYProfile

My Profile

MyProfile?

Whatalongprofilename 123456789012

Description

In addition to the name, type additional information to help you identify this ADP
profile.
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Table 197 Configuration > Security Policy > ADP > Profile > Add-Traffic-Anomaly (continued)

LABELS

DESCRIPTION

Scan/Flood Detection

Scan detection, such as port scanning, tries to find attacks where an attacker scans
device(s) to determine what types of network protocols or services a device
supports.

Flood detection tries to find afttacks that saturate a network with useless data, use up
all available bandwidth, and so aim to make communications in the network
impossible.

Senisitivity

(Scan detection only.) Select a sensitivity level so as to reduce false positives in your
network. If you choose low sensitivity, then scan thresholds and sample times are set
low, so you will have fewer logs and false positives; however some fraffic anomaly
aftacks may not be detected.

If you choose high sensitivity, then scan thresholds and sample times are set high, so
most traffic anomaly attacks will be detected; however you will have more logs and
false positives.

Block Period

Specify for how many seconds the Zyxel Device blocks all packets from being sent
to the victim (destination) of a detected anomaly attack. Flood Detection applies
blocking to the destination IP address and Scan Detection applies blocking to the
source IP address.

Edit (Flood Detection

Select an entry and click this to be able to modify it.

only)

Activate To turn on an enfry, select it and click Activate.

Inactivate To turn off an enftry, select it and click Inactivate.

Log To edit an item’s log option, select it and use the Log icon. Select whether to have
the Zyxel Device generate alog (log), log and alert (log alert) or neither (no) when
fraffic matches this anomaly policy.

Action To edit what action the Zyxel Device takes when a packet matches a policy, select
the policy and use the Action icon.
none: The Zyxel Device takes no action when a packet matches the policy.
block: The Zyxel Device silently drops packets that matches the policy. Neither
sender nor receiver are nofified.

# This is the entry’s index number in the list.

Status The activate (light bulb) iconis lit when the entry is active and dimmed when the
entry is inactive.

Name This is the name of the anomaly policy. Click the Name column heading to sort in
ascending or descending order according to the protocol anomaly policy name.

Log These are the log options. To edit this, select an item and use the Log icon.

Action This is the action the Zyxel Device should take when a packet matches a policy. To

edit this, select an item and use the Action icon.

Threshold (pkt/sec)

(Flood detection only.) Select a suitable threshold level (the number of packets per
second that match the flood detection criteria) for your network. If you choose a
low threshold, most traffic anomaly attacks will be detected, but you may have
more logs and false positives.

If you choose a high threshold, some fraffic anomaly attacks may not be detected,
but you will have fewer logs and false positives.

oK Click OK to save your settings to the Zyxel Device, complete the profile and return to
the profile summary page.

Cancel Click Cancel to return to the profile summary page without saving any changes.

Save Click Save to save the configuration to the Zyxel Device but remain in the same

page. You may then go to the another profile screen (tab) in order fo complete the
profile. Click OK in the final profile screen to complete the profile.
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25.5.4 Protocol Anomaly Profiles

Protocol anomalies are packets that do not comply with the relevant RFC (Request For Comments).
Protocol anomaly detection includes:

e TCP Decoder
e UDP Decoder
e |CMP Decoder

e |P Decoder

Teardrop

When an IP packet is larger than the Maximum Transmission Unit (MTU) configured in the Zyxel Device, it
is fragmented using the TCP or ICMP protocol.

A Teardrop attack falsifies the offset which defines the size of the fragment and the original packet. A
series of IP fragments with overlapping offset fields can cause some systems to crash, hang, or reboot
when fragment reassembling is attempted at the destination.

IP Spoofing

IP Spoofing is used to gain unauthorized access to network devices by modifying packet headers so
that it appears that the packets originate from a host within a trusted network.

* InanIP Spoof from the WAN, the source address appears to be in the same subnet as a Zyxel Device
LAN interface.

¢ In an IP Spoof from a LAN interface, the source address appears to be in a different subnet from that
Zyxel Device LAN interface.

ZyWALL ATP Series User’s Guide

507



Chapter 25 Security Policy

Figure 351 Configuration > Security Policy > ADP > Profile > Add-Protfocol-Anomaly

[# Edit Anomaly Profile

Traffic Anomaly Protocol Anomaly

(1]

-

General
Name: ADP_PROFILE

TCP Decoder

¥ Aclivate @ Inactivate &3 Logy & Actionw

# Siatus Name « Log
1 ? (tcp_decoder) BAD-LENGTH-CPIL... log
2 9 (tcp_decoder) EXPERIMENTAL-CP... log
3 9 (tcp_decoder) OBSOLETE-OPTION... log
4 9@ (tcp_decoder) OVERSIZE-OFFSET ... log
5 9 (tcp_decoder) TRUNCATED-CPTL...  log
6 9 (tcp_decoder) TICP-DETECTED Al... log
7 9 (tcp_decoder) UNDERSIZE-LEN ATT... log
5 @ (tcp_decoder) UNDERSIZE-OFFSET ... log
? ] (tcp_decoder) tcp-fragment ATT...  log

Page El of 1

UDP Decoder

Show items

Acfion
drop
drop
drop
drop
drop
drop
drop
drop
drop

Displaying 1-9 of ¢

@ Activate @ Inactivate &5 Logy & Actionw

3

"
4

#  Status Name « Log Action
1 9 (udp_decoder) OVERSIZE-LEN ATT... log drop
2 9 (udp_decoder) TRUNCATED-HEA... log drop
3 9 (udp_decoder) UNDERSIZE-LEN AT... log drop
Page E of 1 Show v items Displaying 1-3 of 3
ICMP Decoder
¢ Activate @ Inaclivate & Logy & Actionw
#  Status Name « Log Action
1 ? (icmp_decoder) TRUNCATED-AD...  log drop
2 @ (icmp_decoder) TRUNCATED-HEA... log drop
3 @ (icmp_decoder) TRUNCATED-TIME... log drop
4 Q (icmp_decoder) icmp-fragment ... log drop
Page [1 | of I Show items Displaying 1-4 of 4
IP Decoder
@ Activate @ Inactivate & Logy £ Actionw
#  Status Name « Log Action
1 ? (ip_decoder) BAD-LENGTH-OPTIC... log drop
2 @ (ip_decoder) IP4and ATTACK log drop
3 @ (ip_decoder) TRUNCATED-OFTION... log drop
4 @ (ip_decoder) UNDERSIZE-LEN ATTA... log drop
5 @ (ip_decoder) ip-spoof ATTACK log drop
6 @ (ip_decoder) ip-teardrop ATTACK log drop

Page E of 1

Show items

Displaying 1 -6 of 6

.
[ ok [ cancel Save
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The following table describes the labels in this screen.

Table 198 Configuration > Security Policy > ADP > Profile > Add-Protocol-Anomaly

LABEL DESCRIPTION

Name A name is automatically generated that you can edit. The name must be the same
in the Traffic Anomaly and Protocol Anomaly screens for the same ADP profile. You
may use 1-31 alphanumeric characters, underscores(_), or dashes (-), but the first
character cannot be a number. This value is case-sensitive. These are valid, unique
profile names:
*  MyProfile
¢ mYProfile
* Mymyl2 3-4
¢ These are invalid profile names:
e ImYProfile
e My Profile
*  MyProfile2
*  Whatalongprofilename 123456789012

Description In addition to the name, type additional information to help you identify this ADP

profile.

TCP Decoder/UDP
Decoder/ICMP Decoder/IP
Decoder

Perform the following actions for each type of encoder.

Activate

To turn on an entry, select it and click Activate.

Inactivate

To turn off an enftry, select it and click Inactivate.

Log

To edit an item’s log option, select it and use the Log icon. Select whether to have
the Zyxel Device generate alog (log), log and alert (log alert) or neither (no) when
fraffic matches this anomaly policy.

Action

To edit what action the Zyxel Device takes when a packet matches a policy, select
the policy and use the Action icon.

original setting: Select this action to return each rule in a service group fo its
previously saved configuration.

none: Select this action to have the Zyxel Device take no action when a packet
matches a policy.

drop: Select this action fo have the Zyxel Device silently drop a packet that matches
a policy. Neither sender nor receiver are noftified.

reject-sender: Select this action to have the Zyxel Device send a reset to the sender
when a packet matches the policy. If it is a TCP attack packet, the Zyxel Device will
send a packet with a ‘RST’ flag. If it is an ICMP or UDP atftack packet, the Zyxel
Device will send an ICMP unreachable packet.

reject-receiver: Select this action to have the Zyxel Device send a reset to the
receiver when a packet matches the policy. If it is a TCP attack packet, the Zyxel
Device will send a packet with an a ‘RST’ flag. If it is an ICMP or UDP attack packet,
the Zyxel Device will do nothing.

reject-both: Select this action to have the Zyxel Device send a reset to both the
sender and receiver when a packet matches the policy. If it is a TCP attack packet,
the Zyxel Device will send a packet with a ‘RST’ flag to the receiver and sender. If it is
an ICMP or UDP attack packet, the Zyxel Device will send an ICMP unreachable
packet.

#

This is the enftry’s index number in the list.

Status

The activate (light bulb) iconis lit when the entry is active and dimmed when the
enfry is inactive.

Name

This is the name of the anomaly policy. Click the Name column heading fo sort in
ascending or descending order according to the protocol anomaly policy name.
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Table 198 Configuration > Security Policy > ADP > Profile > Add-Protocol-Anomaly

LABEL

DESCRIPTION

Log

These are the log opftions. To edif this, select an item and use the Log icon.

Action

This is the action the Zyxel Device should take when a packet matches a policy. To
edit this, select an item and use the Action icon.

OK

Click OK to save your settings to the Zyxel Device, complete the profile and return to
the profile summary page.

Cancel

Click Cancel to return to the profile summary page without saving any changes.

Save

Click Save to save the configuration to the Zyxel Device but remain in the same
page. You may then go to the another profile screen (tab) in order to complete the
profile. Click OK in the final profile screen to complete the profile.

25.6 The Session Control Screen

Click Configuration > Security Policy > Session Control to display the Security Policy Session Control
screen. Use this screen fo limit the number of concurrent NAT/Security Policy sessions a client can use.
You can apply a default limit for all users and individual limits for specific users, addresses, or both. The
individual limit takes priority if you apply both.

Figure 352 Configuration > Security Policy > Session Confrol

General Settings

UDP Session Time Qut: &0 (1-28800 seconds)

Session Limit Settings

[[] Enable Session Limit

IPv4 Configuration

© Add

Page of 0 Show 30 |~ | items

IPvé Configuration

© Add

Page of 0 Show 30 |~ | items

No data to display

No data to display

“ropy | _reser
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The following table describes the labels in this screen.

Table 199 Configuration > Security Policy > Session Confrol

LABEL DESCRIPTION

General Settings

UDP Session Time | Set how many seconds the Zyxel Device will allow a UDP session to remain idle (without UDP

Out fraffic) before closing it.
Session Limit
Settings
Enable Session Select this check box to confrol the number of concurrent sessions hosts can have.
[imit
IPv4 / IPvé This table lists the rules for limiting the number of concurrent sessions hosts can have.
Configuration
Default This field is configurable only when you enable session limit.
Session per
Host Use this field to set a common limit to the number of concurrent NAT/Security Policy sessions

each client computer can have.

If only a few clients use peer to peer applications, you can raise this number to improve their
performance. With heavy peer to peer application use, lower this number to ensure no single
client uses too many of the available NAT sessions.

Create rules below to apply other limits for specific users or addresses.

Add Click this to create a new entry. Select an entry and click Add to create a new entry after the
selected enfry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the
entry’s setfings.

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove
it before doing so.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an entry, select it and click Inactivate.

Move To change arule’s position in the numbered list, select the rule and click Move to display a field

fo type a number for where you want to put that rule and press [ENTER] to move the rule fo the
number that you typed.

The ordering of your rules is important as they are applied in order of their numbering.

# This field is a sequential value showing the number of the profile. The profile order is not
important.

Status This icon is lit when the entry is active and dimmed when the entry is inactive.

# This is the index number of a session limit rule. It is not associated with a specific rule.

User This is the user name or user group name to which this session limit rule applies.

IPv4 / IPvé Address | This is the IPv4 / IPvé address object, including geographic address (group) objects fo which
this session limit rule applies.

Description This is the information configured to help you identify the rule.

Limit This is how many concurrent sessions this user or address is allowed fo have.
Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings.

25.6.1 The Session Control Add/Edit Screen

Click Configuration > Security Policy > Session Control and the Add or Editicon to display the Add or Edit
screen. Use this screen to configure rules that define a session limit for specific users or addresses.
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Figure 353 Configuration > Security Policy > Session Confrol > Edit

€2 Add Session Limit X
«= Create new Object v

[¥] Enable Rule

Description: (Cptional)

User: any v

Address: any hd

Session Limit per Host: |0 (0-8192, Ois unlimited)
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The following table describes the labels in this screen.

Table 200 Configuration > Security Policy > Session Control > Add / Edit

LABEL

DESCRIPTION

Create new

Use to configure new settings for User or Address objects that you need to use in this

Object screen.Click on the down arrow to see the menu.

Enable Rule Select this check box to turn on this session limit rule.

Description Enter information to help you identify this rule. Use up to 60 printable ASCII characters. Spaces
are allowed.

User Select a user name or user group to which to apply the rule. The rule is activated only when the
specified user logs intfo the system and the rule will be disabled when the user logs out.
Otherwise, select any and there is no need for user logging.
Note: If you specified an IP address (or address group) instead of any in the field

below, the user’s IP address should be within the IP address range.

Address Select the IPv4 source address or address group, including geographic address (group)
object, to which this rule applies. Select any to apply the rule to all IPv4 source addresses.

IPvé6 Address Select the IPvé source address or address group, including geographic address (group)

object, to which this rule applies. Select any to apply the rule to all IPvé source addresses.

Session Limit per
Host

Use this field fo set a limit fo the number of concurrent NAT/Security Policy sessions this rule’s
users or addresses can have.

For this rule’s users and addresses, this setting overrides the Default Session per Host setting in
the general Security Policy Session Control screen.

OK

Click OK to save your customized settings and exit this screen.

Cancel

Click Cancel fo exit this screen without saving.

25.7 Security Policy Example Applications

Suppose you decide to block LAN users from using IRC (Internet Relay Chat) through the Internet. To do
this, you would configure a LAN to WAN Security Policy that blocks IRC traffic from any source IP address
from going to any destination address. You do not need to specify a schedule since you need the
Security Policy to always be in effect. The following figure shows the results of this policy.
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Figure 354 Blocking All LAN to WAN IRC Traffic Example
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Your Security Policy would have the following settings.

WAN

Table 201 Blocking All LAN to WAN IRC Traffic Example
# USER SOURCE DESTINATION SCHEDULE SERVICE ACTION
1 Any Any Any Any IRC Deny
2 Any Any Any Any Any Allow

¢ The first row blocks LAN access to the IRC service on the WAN.

¢ The second row is the Security Policy’s default policy that allows all LAN1T to WAN traffic.

The Zyxel Device applies the security policies in order. So for this example, when the Zyxel Device
receives traffic from the LAN, it checks it against the first policy. If the traffic matches (if it is IRC fraffic)
the security policy takes the action in the policy (drop) and stops checking the subsequent security
policies. Any traffic that does not match the first security policy will match the second security policy
and the Zyxel Device forwards it.

Now suppose you need to let the CEO use IRC. You configure a LAN1 to WAN security policy that allows
IRC fraffic from the IP address of the CEQ's computer. You can also configure a LAN to WAN policy that
allows IRC traffic from any computer through which the CEO logs info the Zyxel Device with his/her user
name. In order to make sure that the CEO's computer always uses the same IP address, make sure it
either:

e Has a static IP address,
or

* You configure a static DHCP enfry for it so the Zyxel Device always assigns it the same IP address.

Now you configure a LAN1 to WAN security policy that allows IRC fraffic from the IP address of the CEO’s
computer (172.16.1.7 for example) to go fo any destfination address. You do not need fo specify a
schedule since you want the security policy to always be in effect. The following figure shows the results
of your two custom policies.

ZyWALL ATP Series User’s Guide

513



Chapter 25 Security Policy

Figure 355 Limited LAN to WAN IRC Traffic Example
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Your security policy would have the following configuration.
Table 202 Limited LAN1 to WAN IRC Traffic Example 1
# USER SOURCE DESTINATION SCHEDULE SERVICE ACTION
1 Any 172.16.1.7 Any Any IRC Allow
2 Any Any Any Any IRC Deny
3 Any Any Any Any Any Allow

e The first row allows the LANT computer at IP address 172.16.1.7 to access the IRC service on the WAN.

¢ The second row blocks LANT access to the IRC service on the WAN.

* The third row is the default policy of allowing all fraffic from the LAN1 to go to the WAN.

Alternaftively, you configure a LANT to WAN policy with the CEQ’s user name (say CEQO) to allow IRC

tfraffic from any source IP address to go fo any destfination address.

Your Security Policy would have the following settings.

Table 203 Limited LAN1 fo WAN IRC Traffic Example 2

# USER SOURCE DESTINATION SCHEDULE SERVICE ACTION
1 CEO Any Any Any IRC Allow

2 Any Any Any Any IRC Deny

3 Any Any Any Any Any Allow

¢ The first row allows any LAN1 computer to access the IRC service on the WAN by logging into the Zyxel
Device with the CEQ’s user name.

¢ The second row blocks LAN1 access to the IRC service on the WAN.

¢ The third row is the default policy of allowing allows all traffic from the LAN1 to go to the WAN.

The policy for the CEO must come before the policy that blocks all LANT to WAN IRC traffic. If the policy
that blocks all LANT to WAN IRC traffic came first, the CEO’s IRC traffic would match that policy and the
Zyxel Device would drop it and not check any other security policies.
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CHAPTER 26
Application Patrol

26.1 Overview

Application patrol provides a convenient way to manage the use of various applications on the
network. It manages general protocols (for example, HTTP and FTP) and instant messenger (IM), peer-to-
peer (P2P), Voice over IP (VolP), and streaming (RSTP) applications. You can even control the use of a
particular application’s individual features (like text messaging, voice, video conferencing, and file
transfers).

26.1.1 What You Can Do in this Chapter

¢ Use the App Patrol summary screen (see Section 26.2 on page 516) to manage the application patrol
profiles. You can also view license registration and signature information.

* Use the App Patrol Add/Edit screens (see Section 26.2.2 on page 520 & Section 26.2.3 on page 521) to
set actions for application categories and for specific applications within the category.

26.1.2 What You Need to Know

If you want to use a service, make sure both the Security Policy and application patrol allow the
service's packets to go through the Zyxel Device.

Note: The Zyxel Device checks secure policies before it checks application patrol rules for
traffic going through the Zyxel Device.

Application patrol examines every TCP and UDP connection passing through the Zyxel Device and
identifies what application is using the connection. Then, you can specify whether or not the Zyxel
Device confinues to route the connection. Traffic not recognized by the application patrol signatures is
ignored.

Application Profiles & Policies

An application patrol profile is a group of categories of application patrol signatures. For each profile,
you can specify the default action the Zyxel Device takes once a packet matches a signature (forward,
drop, orreject a service's connections and/or create a log alert).

Use policies to link profiles to traffic flows based on criteria such as source zone, destination zone, source
address, destination address, schedule, user.

Classification of Applications

There are two ways the Zyxel Device can identify the application. The first is called auto. The Zyxel
Device looks at the IP payload (OSl level-7 inspection) and attempts to match it with known patterns for
specific applications. Usually, this occurs at the beginning of a connection, when the payload is more
consistent across connections, and the Zyxel Device examines several packets to make sure the match
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is correct. Before confirmation, packets are forwarded by App Patrol with no action taken. The number
of packets inspected before confirmation varies by signature.

Note: The Zyxel Device allows the first eight packets to go through the security policy,
regardless of the application patrol policy for the application. The Zyxel Device
examines these first eight packets to identify the application.

The second approach is called service ports. The Zyxel Device uses only OSl level-4 information, such as

ports, to identify what application is using the connection. This approach is available in case the Zyxel
Device identifies a lot of “false positives” for a particular application.

Custom Ports for SIP and the SIP ALG
Configuring applicatfion patrol to use custom port numbers for SIP fraffic also configures the SIP ALG to

use the same port numbers for SIP traffic. Likewise, configuring the SIP ALG to use custom port numbers
for SIP fraffic also configures application patrol to use the same port numbers for SIP fraffic.

26.2 Application Patrol Profile

Use the application patrol screens to customize action and log settings for a group of application patrol
signatures. You then link a profile to a policy. Use this screen to create an application patrol profile, and
view signature information. It also lists the registration status and details about the signature set the Zyxel
Device is using.

Note: You must register for the AppPatrol signature service (at least the trial) before you can
use it.

A profile is an application object(s) or application group(s) that has customized action and log settings.
Click Configuration > Security Service > App Patrol to open the following screen.
Click the Application Patrol icon for more information on the Zyxel Device's security features.

Figure 356 Configuration > Security Service > App Patrol

App Patrol

m.s Application
Profile Management *® Patrol
@ Add
1 default_profile 0 5
Page |1 of 1 Show [50 || items Displaying 1-1 of 1

Signature Information
Current Version:

Signature Numkber:

Released Date:

Update Signatures
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The following table describes the labels in this screen.

Table 204 Configuration > Security Service > App Patrol

LABEL DESCRIPTION

Add Click this to create a new entry. Select an entry and click Add to create a new entry after the
selected entry.

Edit Double-click an enftry or select it and click Edit to open a screen where you can modify the
entry’s seftings.

Remove Select an entry and click Remove to delete the selected entry.

References Select an entry and click References to open a screen that shows which settings use the entry.
Click Refresh to update information on this screen.

# This field is a sequential value showing the number of the profile. The profile order is not
important.

Name This displays the name of the profile created.

Description This displays the description of the App Patrol Profile.

Scan Option This field displays the scan options from the App Patrol profile.

Reference This displays the number of times an object reference is used in a profile.

Action Click this icon to apply the entry to a security policy.
Go to the Configuration > Security Policy > Policy Control screen fo check the result.

Signature The following fields display information on the current signature set that the Zyxel Device is

Information using.

Current Version

This field displays the App Patrol signature set version number. This number gets larger as the set
is enhanced.

Signature
Number

This field displays the number of IDP signatures in this set. This number usually gets larger as the
set is enhanced. Older signatures and rules may be removed if they are no longer applicable
or have been supplanted by newer ones.

Released Date

This field displays the date and time the set was released.

Update
Signatures

Click this link to go to the screen you can use to download signatures from the update server.

26.2.1 Apply to a Security Policy

Click the icon in the Action field of an existing application patrol file to apply the profile to a security

policy.

Go to the Configuration > Security Policy > Policy Control screen to check the result.
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Figure 357 Configuratfion > Security Service > App Patrol > Action
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The following table describes the labels in this screen.

Table 205 Configuration > Security Service > App Patrol > Action

LABEL

DESCRIPTION

Show Filter/Hide
Filter

Click Show Filter to display IPv4 and IPvé (if enabled) security policy search filters.

IPv4 / IPvé Use IPv4 / IPvé6 search filters to find specific IPv4 and IPvé (if enabled) security policies based on
Configuration direction, application, user, source, destination and/or schedule.
From / To Select a zone to view all security policies from a particular zone and/or to a particular zone.

any means all zones.
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Table 205 Configuration > Security Service > App Patrol > Action

LABEL DESCRIPTION
IPv4 / IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé source
Source address object used.
* AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPvé address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
IPv4 /IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé destination
Destination | address object used.
¢ AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPv6 address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
Service View all security policies based the service object used.
User View all security policies based on user or user group object used.
Schedule View all security policies based on the schedule object used.

Priority This is the position of your Security Policy in the global policy list (including all through-Zyxel
Device and to-Zyxel Device policies). The ordering of your policies is important as policies are
applied in sequence. Default displays for the default Security Policy behavior that the Zyxel
Device performs on traffic that does not match any other Security Policy.

Status This icon is lit when the entry is active and dimmed when the enfry is inactive.

Name This is the name of the Security policy.

From / To This is the direction of travel of packets. Select from which zone the packets come and to

which zone they go.

Security Policies are grouped based on the direction of travel of packets to which they apply.
For example, from LAN to LAN means packets fraveling from a computer or subnet on the LAN
to either another computer or subnet on the LAN.

From any displays all the Security Policies for traffic going to the selected To Zone.
To any displays all the Security Policies for traffic coming from the selected From Zone.
From any to any displays all of the Security Policies.

To ZyWALL policies are for traffic that is destined for the Zyxel Device and control which
computers can manage the Zyxel Device.

IPv4 / IPvé Source

This displays the IPv4 / IPvé source address object, including geographic address and FQDN
(group) objects, to which this Security Policy applies.

IPv4 / IPvé This displays the IPv4 / IPvé destination address object, including geographic address and
Destination FQDN (group) objects, to which this Security Policy applies.
Service This displays the service object to which this Security Policy applies.

User This is the user name or user group name to which this Security Policy applies.

Schedule This field tells you the schedule object that the policy uses. none means the policy is active at all
fimes if enabled.

Action This field displays whether the Security Policy silently discards packets without notification
(deny), permits the passage of packets (allow) or drops packets with notification (reject)

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or not
(no) when the policy is matched to the criteria listed above.

Profile This field shows you which Security Service profiles (application patrol, content filter, IDP, anti-
malware, email security) apply to this Security policy. Click an applied Security Service profile
icon to edit the profile directly.

oK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving.
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26.2.2 The Application Patrol Profile Add/Edit Screen - My Application

Use this screen to configure profile settings. Click Configuration > Security Service > App Patrol > Add/
Edit, then click My Application to open the following screen.

Figure 358 Configuration > Security Service > App Patrol > Add/Edit > My Application

&9 Add Rule

General Settings

My Application Rule

Summary
Total Category(s):

Total Application(s).
Antivirus: Of3
Comprassion: 02
File Transter: O/11
Microsolt Otfice: 01
Printer: 0/4
Terminal: 0/é
Webmail: 0/32

Mame: APPA38S
Description:

Frofile Management

My Applicatoin Query Result

Application Service: 0/30
Database: 0f11

Forum: O/15
Middleware: 0711
Roufing: 0/15

Thin Client: 0/15

Q
Q
Authentication: 0/10

Audiofvideo: 0/119 Behavioral; 0/2

Encrypted: 0/8 ERP: 0/1 File Server: 0/23

Game: (/52 Instant Messaging: /73 Aol 0f10

Metwork Management: 0/ 13 Network Service: /313 Peer to Peer: /105
Standard: 0/4

Wap: 0/7

Securty Senvice: 0/4 Telephony: 0/2

Tunneling: 0/37 Web: 0/1834

show 50 |+ ilems Mo dala o display

Save & Exit § Cancel Save

The following table describes the labels in this screen.

Table 206 Configuration > Security Service > App Patrol > Add/Edit > My Application

LABEL

DESCRIPTION

General Settings

Name Type the name of the profile. You may use 1-31 alphanumeric characters, underscores(_ ).
or dashes (-), but the first character cannot be a number. This value is case-sensitive. These
are valid, unique profile names:

e MyProfile
*  mYProfile
e Mymyl2_3-4
These are invalid profile names:
e ImYProfile
e My Profile
*  MyProfile2
*  Whatalongprofilename 123456789012
Description Type a description for the profile rule to help identify the purpose of rule. You may use 1-31

alphanumeric characters, underscores (_), or dashes (-), but the first character cannot be
a number. This value is case-sensitive. This field is optional.

Total Category(s)

This field displays the total number of the selected category(ies) in the Query Result screen.

Total Application(s)

This field displays the total number of the selected applications in the Query Result screen.

Remove

Select an entfry and click Remove to delete the selected entry.
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Table 206 Configuration > Security Service > App Patrol > Add/Edit (continued)> My Application

LABEL DESCRIPTION

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or
neither (no) by default when traffic matches a signature in this category.

Action Select the default action for all signatures in this category.
forward - the Zyxel Device routes packets that matches these signatures.

drop - the Zyxel Device silently drops packets that matches these signatures without
noftification.

reject - the Zyxel Device drops packets that matches these signatures and sends

nofification.

# This field is a sequential value showing the number of the profile. The profile order is not
important.

Application This field displays the application name of the policy.

Category This field displays the category type of the application.

Tag This field displays the tag information of the application.

Action Select the default action for all signatures in this category.

forward - the Zyxel Device routes packets that matches these signatures.

drop - the Zyxel Device silently drops packets that matches these signatures without
noftification.

reject - the Zyxel Device drops packets that matches these signatures and sends
noftification.

Log Select whether to have the Zyxel Device generate a log (log). log and alert (log alert) or
neither (no) by default when traffic matches a signature in this category.

Save & Exit A profile consists of separate category editing screens. If you want to configure just one
category for a profile, click OK to save your settings to the Zyxel Device, complete the
profile and return to the profile summary page.

Cancel Click Cancel fo return to the profile summary page without saving any changes.

Save If you want to configure more than one category for a profile, click Save to save your
settings to the Zyxel Device without leaving this page.

26.2.3 The Application Patrol Profile Add/Edit Screen - Query Result

Click Configuration > Security Service > App Patrol > Add, then click Query Result to search for certain
applications within a specific category, and the selected applications will be added to My Application
screen. You can also click an existing profile, click Edit (or double-click it), then click Query Result to
open the following screen.
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Figure 359 Configuratfion > Security Service > App Patrol > Add/Edit > Query Result
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Query Application
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Query Result
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[linstant Messaging: 0/73 I Mail: 0410 1] Microsoft Office: 01

[T Network Management: 0713 I Metwork Service: 0/313 [C1Peer to Peer:. 0105
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Add To My Application

The following table describes the labels in this screen.

Table 207 Configuration > Security Service > App Patrol > Add/Edit > Query Result

LABEL

DESCRIPTION

General Settings

Name Type the name of the profile. You may use 1-31 alphanumeric characters, underscores(_ ).
or dashes (-), but the first character cannot be a number. This value is case-sensitive. These
are valid, unique profile names:

e MyProfile
* mYProfile
e Mymyl2_3-4
These are invalid profile names:
e ImYProfile
e My Profile
*  MyProfile2
*  Whatalongprofilename 123456789012
Description Type a description for the profile rule to help identify the purpose of rule. You may use 1-31

alphanumeric characters, underscores (_), or dashes (-), but the first character cannot be
a number. This value is case-sensitive. This field is optional.

Search Application(s)
By Name

Enter a name to search for relevant applications.

Search Application(s)
By Category

Select a category(ies) below to search for relevant applications.

Filter by Tags

Add or delete a tag(s) to display or not display an application(s).

# This field is a sequential value showing the number of the profile. The profile order is not
important.

Application This field displays the application name of the policy.

Category This field displays the category type of the application.
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Table 207 Configuration > Security Service > App Patrol > Add/Edit (continued)> Query Result

LABEL DESCRIPTION

Tag This field displays the tag information of the policy.

Action Select the default action for all signatures in this category.
forward - the Zyxel Device routes packets that matches these signatures.
drop - the Zyxel Device silently drops packets that matches these signatures without
nofification.
reject - the Zyxel Device drops packets that matches these signatures and sends
noftification.

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or
neither (no) by default when traffic matches a signature in this category.

Add to My Select an application(s) to show in the My Application profile screen.

Application

Reset Click this button to reset the fields to default settings.

Cancel Click Cancel fo return to the profile summary page without saving any changes.
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CHAPTER 27
Content Filter

27.1 Overview

Use the content filtering feature to control access to specific web sites or web content.

27.1.1 What You Can Do in this Chapter

¢ Use the Filter Profile screens (Section 27.2 on page 526) to set up content filtering profiles.

* Use the Trusted Web Sites screens (Section 27.3 on page 539) to create a common list of good
(allowed) web site addresses.

¢ Use the Forbidden Web Sites screens (Section 27.4 on page 540) to create a common list of bad
(blocked) web site addresses.

27.1.2 What You Need to Know

Content Filtering

Content filtering allows you to block certain web features, such as cookies, and/or block access to
specific web sites. It can also block access to specific categories of web site content. You can create
different content filter policies for different addresses, schedules, users or groups and content filter
profiles. For example, you can configure one policy that blocks John Doe’s access to arts and
entertainment web pages during the workday and another policy that lets him access them after work.

Content Filtering Policies
A content filtering policy allows you to do the following.

* Use schedule objects to define when to apply a content filter profile.

* Use address and/or user/group objects o define to whose web access to apply the content filter
profile.

¢ Apply a content filter profile that you have custom-tailored.
Content Filtering Profiles
A content filtering profile conveniently stores your custom settings for the following features.

* Category-based Blocking

The Zyxel Device can block access to particular categories of web site content, such as pornography
or racial infolerance.
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e Restrict Web Features

The Zyxel Device can disable web proxies and block web features such as ActiveX controls, Java
applets and cookies.

e Customize Web Site Access

You can specify URLs to which the Zyxel Device blocks access. You can alternatively block access to
all URLs except ones that you specify. You can also have the Zyxel Device block access to URLs that
contain particular keywords.

Content Filtering Configuration Guidelines

When the Zyxel Device receives an HTTP request, the content filter searches for a policy that matches
the source address and time (schedule). The content filter checks the policies in order (based on the
policy numbers). When a matching policy is found, the content filter allows or blocks the request
depending on the settings of the filtering profile specified by the policy. Some requests may not match
any policy. The Zyxel Device allows the request if the default policy is not set to block. The Zyxel Device
blocks the request if the default policy is set to block.

External Web Filtering Service

When you register for and enable the external web filtering service, your Zyxel Device accesses an
external database that has millions of web sites categorized based on content. You can have the Zyxel
Device block, block and/or log access to web sites based on these categories.

HTTPS Domain Filter

HTTPS Domain Filter works with the Content Filter category feature to identify HTTPS traffic and take
appropriate action. SSL Inspection identifies HTTPS traffic for all Security Service traffic and has higher
priority than HTTPS Domain Filter. HTTPS Domain Filter only identifies keywords in the domain name of an
URL and matches it to a category. For example, if the keyword is 'picture’ and the URL is http://
www.google.com/picture/index.htm, then HTTPS Domain Filter cannot identify 'picture' because that
keyword in not in the domain name 'www.google.com'. However, SSL Inspection can identify 'picture’ in
the URL http://www.google.com/picture/index.htm.

Keyword Blocking URL Checking

The Zyxel Device checks the URL's domain name (or IP address) and file path separately when
performing keyword blocking.

The URL's domain name or IP address is the characters that come before the first slash in the URL. For
example, with the URL www.zyxel.com.tw/news/pressroom.php, the domain name is
www.zyxel.com.tw.

The file path is the characters that come after the first slash in the URL. For example, with the URL
www.zyxel.com.tw/news/pressroom.php, the file path is news/pressroom.php.

Since the Zyxel Device checks the URL's domain name (or IP address) and file path separately, it will not
find items that go across the two. For example, with the URL www.zyxel.com.tw/news/pressroom.php,
the Zyxel Device would find “tw” in the domain name (www.zyxel.com.tw). It would also find *news” in
the file path (news/pressroom.php) but it would not find “tw/news”.
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Finding Out More

» See Section 27.5 on page 541 for content filtering background/technical information.

27.1.3 Before You Begin

* You must configure an address object, a schedule object and a filtering profile before you can set up
a content security policy.

* You must have Content Filtering license in order to use the function.subscribe fo use the external
database content filtering (see the Licensing > Registration screens).

27.2 Content Filter Profile Screen

Click Configuration > Security Service> Content Filter > Profile to open the Content Filter Profile screen.
Use this screen to enable content filtering, view and order your list of content filter policies, create a

denial of access message or specify a redirect URL and check your external web filtering service
registration status.

Click the Content Filter icon for more information on the Zyxel Device's security features.

Figure 360 Configuration > Security Service > Content Filter > Profile
Profile Trusted Web Sites Forbidden Web Sites

General Seftings EY.‘ Content Filter

Enable HTTPS Domain Filter for HTTPS traffic @
Crop connection when HTTFS connection with $5L V3 or previous version

Content Filter Category Service Timeout: 10 (1~60 Seconds)

Meszsage to display when a site is blocked

Denied Access Messags: Web access is restricted. Please contact th

Redirect URL:

Profile Management

Q@ Add E
1 BPP Business Productivity Prote... 0 =5
2 CP Children's Internet Protection 0 i
Page |1 of 1 Show [50 || iterms Displaying 1 -2 of 2

[ appty | reset
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The following table describes the labels in this screen.

Table 208 Configuration > Security Service > Content Filter > Profile

LABEL

DESCRIPTION

General Settings

Enable HTTPS Domain Filter
for HTTPS traffic

Select this check box to have the Zyxel Device block HTTPS web pages using the
cloud category service.

In an HTTPS connection, the Zyxel Device can extract the Server Name Indication
(SNI) from a client request, check if it matches a category in the cloud content filter
and then take appropriate action. The keyword match is for the domain name only.

Drop connection when
HTTPS connection with SSL
V3 or previous version

Select this check box to have the Zyxel Device block HTTPS web pages using SSL V3 or
a previous version.

Content Filter Category
Service Timeout

Specify the allowable time period in seconds for accessing the external web filtering
service's server.

Denied Access Message

Enter a message to be displayed when content filter blocks access to a web page.
Use up to 127 characters (0-9a-zA-Z;/2:@&=+$\.-_I~*'()%."). For example, “Access to
this web page is not allowed. Please contact the network administrator”.

It is also possible to leave this field blank if you have a URL specified in the Redirect URL
field. In this case if the content filter blocks access to a web page, the Zyxel Device
just opens the web page you specified without showing a denied access message.

Redirect URL

Enter the URL of the web page to which you want to send users when their web
access is blocked by content filter. The web page you specify here opens in a new
frame below the denied access message.

Use “http://" or “https://" followed by up to 262 characters (0-9a-zA-Z;/2:@&=+$\..-
_I~*()%). For example, http://192.168.1.17/blocked access.

Profile Management

Add Click Add to create a new content filter rule.
Edit Click Edit to make changes to a content filter rule.
Remove Click Remove the delete a content filter rule.
References Select an entry and click References to open a screen that shows which settings use
the entry. Click Refresh to update information on this screen.
# This column lists the index numbers of the content filter profile.
Name This column lists the names of the content filter profile rule.
Description This column lists the description of the content filter profile rule.
Reference This displays the number of times an Object Reference is used in a rule.
Action Click this icon to apply the content filter profile with a security policy.
Go to the Configuration > Security Policy > Policy Control screen to check the result.
Apply Click Apply to save your changes back to the Zyxel Device.
Reset Click Reset to return the screen to its last-saved settings.

27.2.1 Apply to a Security Policy

Click the icon in the Action field to apply the entry to a security policy.

Go to the Configuration > Security Policy > Policy Control screen to check the result.

ZyWALL ATP Series User’s Guide

527




Chapter 27 Content Filter

Figure 361 Configuratfion > Security Service > Content Filter > Action
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The following table describes the labels in this screen.

Table 209 Confi

guration > Security Service > Content Filter > Action

LABEL

DESCRIPTION

Show Filter/Hide
Filter

Click Show Filter to display IPv4 and IPvé (if enabled) security policy search filters.

IPv4 / IPvé Use IPv4 / IPvé search filters to find specific IPv4 and IPvé (if enabled) security policies based on
Configuration direction, application, user, source, destination and/or schedule.
From / To Select a zone to view all security policies from a particular zone and/or to a particular zone.

any means all zones.
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Table 209 Configuration > Security Service > Content Filter > Action

LABEL DESCRIPTION
IPv4 / IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé source
Source address object used.
* AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPvé address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
IPv4 /IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé destination
Destination | address object used.
¢ AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPv6 address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
Service View all security policies based the service object used.
User View all security policies based on user or user group object used.
Schedule View all security policies based on the schedule object used.

Priority This is the position of your Security Policy in the global policy list (including all through-Zyxel
Device and to-Zyxel Device policies). The ordering of your policies is important as policies are
applied in sequence. Default displays for the default Security Policy behavior that the Zyxel
Device performs on traffic that does not match any other Security Policy.

Status This icon is lit when the entry is active and dimmed when the enfry is inactive.

Name This is the name of the Security policy.

From / To This is the direction of travel of packets. Select from which zone the packets come and to

which zone they go.

Security Policies are grouped based on the direction of travel of packets to which they apply.
For example, from LAN to LAN means packets fraveling from a computer or subnet on the LAN
to either another computer or subnet on the LAN.

From any displays all the Security Policies for traffic going to the selected To Zone.
To any displays all the Security Policies for traffic coming from the selected From Zone.
From any to any displays all of the Security Policies.

To ZyWALL policies are for traffic that is destined for the Zyxel Device and control which
computers can manage the Zyxel Device.

IPv4 / IPvé Source

This displays the IPv4 / IPvé source address object, including geographic address and FQDN
(group) objects, to which this Security Policy applies.

IPv4 / IPvé This displays the IPv4 / IPvé destination address object, including geographic address and
Destination FQDN (group) objects, to which this Security Policy applies.
Service This displays the service object to which this Security Policy applies.

User This is the user name or user group name to which this Security Policy applies.

Schedule This field tells you the schedule object that the policy uses. none means the policy is active at all
fimes if enabled.

Action This field displays whether the Security Policy silently discards packets without notification
(deny), permits the passage of packets (allow) or drops packets with notification (reject)

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or not
(no) when the policy is matched to the criteria listed above.

Profile This field shows you which Security Service profiles (application patrol, content filter, IDP, anti-
malware, email security) apply to this Security policy. Click an applied Security Service profile
icon to edit the profile directly.

oK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving.
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27.2.2 Content Filter Add Profile Category Service

Click Configuration > Security Service > Content Filter > Profile > Add or Edit to open the Add Filter Profile

screen.

Figure 362 Content Filter > Profile > Add Filter Profile > Category Service

@ Add Filter Profile FX
Category Service Custom Service
General Settings
Name: | |0
Description: (Optional)
[l Enable SafeSearch
[] Enable Content Filter Category Service
Action for Managed Web Pages: Block |~
Action for Unrated Web Pages: Wam i
Action When Category Server Is Unavailable:  |Wam (v
Select Categories
[[13elect All Categories [l Clear All Categories
Managed Categories
[[] Advertisements & Pop-Ups [[] Alcohol/Tobacco [ Aris
[[] Business [ Transportation [ Chat
[] Forums & Newsgroups [ Computers & Technology [] Criminal Activity
[[] Dating & Personals [[] Download Sites [[] Education
[[] Entertainment [ Finance [[] Gambling
[[] Games [[] Government [l Hate & Intolerance
[[] Hedlth & Medicine [C]megal Drugs [ Job Search
[[] streaming Media & Downloads [ News [[] Non-profits & NGOs
[C1 Nudity [[] Personal Sites [ Politics
[[] Pomography/Sexually Explicit [l Real Estate [[] Religion
[[] Restaurants & Dining [[] Search Engines/Portals [[] Shopping
[[1Social Networking [ISports I Translators
O Travel [ violence [[] weapons
[ Web-based Email [l General [[] Leisure & Recreation
] Cults [[1Fashion & Beauty [] Greeting Cards
[[] Hacking [l egal Software [[]Image Sharing
[ Information Security [ Instant Messaging [ Peer to Peer
[ Private IP Addresses [[1School Cheating [[1Sex Education -
[ Tasteless 1 Child Abuse Images
Test Web Site Category
URL to test:
f you think the category is incorrect, click this link to submit a request to review i
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The following table describes the labels in this screen.

Table 210 Configuration > Security Service > Content Filter > Profile > Add > Category Service

LABEL DESCRIPTION

Name Enter a descriptive name for this content filtering profile name. You may use 1-31
alphanumeric characters, underscores(_), or dashes (-), but the first character
cannot be a number. This value is case-sensitive.

Description Enter a description for the content filtering profile rule to help identify the purpose

of rule. You may use 1-31 alphanumeric characters, underscores(_), or dashes (-),
but the first character cannot be a number. This value is case-sensitive.

This field is optional.

Enable SafeSearch

SafeSearch is a search engine that can automatically filter sexually explicit videos
and images from the search result without overloading the Zyxel Device. It does
this by adding a parameter in the search URL:

https://www.google.com.tw/?gws_rd=ssi#q=porn&safe=active.
Supported search engines at the time of writing are:

Yahoo, Google, MSN Live Bing, Yandex

Enable Content Filter
Category Service

Enable external database content filtering to have the Zyxel Device check an
external database to find to which category a requested web page belongs. The
Zyxel Device then blocks or forwards access to the web page depending on the
configuration of the rest of this page.

Log all web pages

Select this to record attempts to access web pages when:

* They match the other categories that you select below.
* They are not categorized.
¢ The external contfent filtering database is unavailable.

Action for Managed Web
Pages

Select Pass to allow users to access web pages that match the other categories
that you select below.

Select Block to prevent users from accessing web pages that match the other
categories that you select below. When external database content filtering
blocks access to a web page, it displays the denied access message that you
configured in the Content Filter General screen along with the category of the
blocked web page.

Select Log to record aftempts to access web pages that match the other
categories that you select below.

Action for Unrated Web
Pages

Select Pass to allow users to access web pages that the external web filtering
service has not categorized.

Select Block to prevent users from accessing web pages that the external web
filtering service has not categorized. When the external database content filtering
blocks access fo a web page, it displays the denied access message that you
configured in the Content Filter General screen along with the category of the
blocked web page.

Select Warn to display a warning message before allowing users to access web
pages that the external web filtering service has not categorized.

Select Log fo record attempts to access web pages that are not categorized.
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Table 210 Configuration > Security Service > Content Filter > Profile > Add > Category Service

LABEL

DESCRIPTION

Action When Category
Server Is Unavailable

Select Pass to allow users to access any requested web page if the external
content filtering database is unavailable.

Select Block to block access to any requested web page if the external content
filtering database is unavailable.

Select Warn to display a warning message before allowing users to access any
requested web page if the external content filtering database is unavailable.

The following are possible causes for the external content filtering server not being
available:

* There is no response from the external content filtering server within the fime
period specified in the Content Filter Server Unavailable Timeout field.

e The Zyxel Device is not able to resolve the domain name of the external
contfent filtering database.

* Thereis an error response from the external content filtering database. This can
be caused by an expired content filtering registration (External content
filtering's license key is invalid”).

Select Log to record attempts to access web pages that occur when the external
content filtering database is unavailable.

Select Categories

Select All Categories

Select this check box to restrict access to all site categories listed below.

Clear All Categories

Select this check box to clear the selected categories below.

Managed Categories

These are categories of web pages based on their content. Select categories in
this section to control access to specific types of Internet content.

You must have the Category Service content filtering license to filter these
categories. See the next table for category details.

Test Web Site Category

URL fo test

You can check which category a web page belongs fo. Enter a web site URL in
the text box.

When the content filter is active, you should see the web page’'s category. The
query fails if the content filter is not active.

Content Filtering can query a category by full URL string (for example, http://
www.google.com/picture/index.htm), but HTTPS Domain Filter can only query a
category by domain name (‘www.google.com’), so the category may be
different in the query result. URL to test displays both results in the test.

If you think the category is
incorrect

Click this link to see the category recorded in the Zyxel Device's content filtering
database for the web page you specified (if the database has an entry for it).

Test Against Content Filter
Category Server

Click this button to see the category recorded in the external content filter server’s
database for the web page you specified.

OK

Click OK to save your changes back to the Zyxel Device.

Cancel

Click Cancel to exit this screen without saving your changes.

The following table describes the managed categories.

Table 211

Managed Category Descriptions

CATEGORY

DESCRIPTION

Advertisements & Pop-Ups

Sites that provide advertising graphics or other ad content files such as banners
and pop-ups. For example, pagead2.googlesyndication.com,
ad.yieldmanager.com.
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Table 211 Managed Category Descriptions (continued)

Alcohol & Tobacco

Sites that promote or sell alcohol- or tobacco-related products or services. For
example, www.drinks.com.tw, www.p9.com.tw, beer.ttl.com.tw.

Arts

Sites with artistic content or relating to artistic institutions such as theaters,
museums, galleries, dance companies, photography, and digital graphic
resources. For example, www.npm.gov.tw, www.nmh.gov.tw.

Business

Sites that provide business related information such as corporate Web sites.
Information, services, or products that help businesses of all sizes fo do their day-fo-
day commercial activities. For example, www .kinkos.com,
www.proctorgamble.com, www.bbb.org.

Transportation

Sites that provide information about motor vehicles such as cars, motorcycles,
boats, trucks, RVs and the like. Includes manufacturer sites, dealerships, review
sites, pricing,, online purchase sites, enthusiasts clubs, etc. For example,
www.toyota.com.tw, www.ford.com.tw, www.sym.com.tw.

Chat

Sites that enable web-based exchange of real time messages through chat
services or chat rooms. For example, me.sohu.com, blufiles.storage.live.com.

Forums & Newsgroups

Sites for sharing information in the form of newsgroups, forums, bulletin boards. For
example, ck101.com, my.xuite.net, ptt.cc.

Computers & Technology

Sites that contain information about computers, software, hardware, IT, peripheral
and computer services, such as product reviews, discussions, and IT news. For
example, www.informationsecurity.com.tw, blog.ithome.com.tw.

Criminal Activity

Sites that offer advice on how to commit illegal or criminal activities, or to avoid
detection. These can include how to commit murder, build bombs, pick locks, etc.
Also includes sites with information about illegal manipulation of electronic
devices, hacking, fraud and illegal distribution of software. For example,
www.hackbase.com, jia.hackbase.com, ad.adver.com.tw.

Dating & Personals

Sites that promote networking for interpersonal relationships such as dating and
marriage. Includes sites for match-making, online dating, spousal infroduction. For
example, www.i-part.com.tw, www.imatchi.com.

Download Sites

Sites that contain downloadable software, whether shareware, freeware, or for a
charge. Includes peer-to-peer sites. For example, www.hotdl.com,
toget.pchome.com.tw, www.azroo.com.

Education

Sites sponsored by educational institutions and schools of all types including
distance education. Includes general educational and reference materials such
as dictionaries, encyclopedias, online courses, teaching aids and discussion
guides. For example, www.tfam.museum, www.lksf.org, www.1980.org.tw.

Entertainment

Sites related to television, movies, music and video (including video on demand),
such as program guides, celebrity sites, and entertainment news. For example,
www.ctitv.com.tw, www.hboasia.com, www.startv.com.tw.

Finance

Sites related to banking, finance, payment or investment, including banks,
brokerages, online stock trading, stock quotes, fund management, insurance
companies, credit unions, credit card companies, and so on. For example,
www.concords.com.tw, www.polaris.com.tw, www.bochk.com.

Gambling

Sites that offer or are related to online gambling, lottery, casinos and betting
agencies involving chance. For example, www.taiwanloftery.com.tw, www.i-
win.com.tw, www.hkjc.com.

Games

Sites relating to computer or other games, information about game producers, or
how to obtain cheat codes. Game-related publication sites. For example,
www.gamer.com.tw, www.wowtaiwan.com.tw, tw.lineage.gamania.com.

Government

Sites run by governmental organizations, departments, or agencies, including
police departments, fire departments, customs bureaus, emergency services, civil
defense, counter-terrorism organizations, military and hospitals. For example,
www.ey.gov.tw, www.whitehouse.gov, www.npa.gov.tw.
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Table 211 Managed Category Descriptions (continued)

Hate & Intolerance

Sites that promote a supremacist political agenda, encouraging oppression of
people or groups of people based on their race, religion, gender, age, disability,
sexual orientation or nationality. For example, www.racist-jokes.com, aryan-
nations.org, whitepower.com.

Health & Medicine

Sites containing information pertaining fo health, healthcare services, fitness and
well-being, including information about medical equipment, hospitals, drugstores,
nursing, medicine, procedures, prescription medications, etc. For example,
www.lksf.org, www.ohayo.com.tw.

lllegal Drugs Sites with information on the purchase, manufacture, and use of illegal or
recreational drugs and their paraphernalia, and misuse of prescription drugs and
other compounds For example, www.cannabis.net, www.amphetamines.com.

Job Search Sites containing job listings, career information, assistance with job searches (such

as resume writing, interviewing tips, etc.), employment agencies or head hunters.
For example, www.104.com.tw, www.1111.com.tw, www.yes123.com.tw.

Streaming Media &

Sites that deliver streaming content, such as Internet radio, Internet TV or MP3 and

Downloads live or archived media download sites. Includes fan sites, or official sites run by
musicians, bands, or record labels. For example, www.youtube.com,
pfp.sina.com.cn, my.xunlei.com.

News Sites covering news and current events such as newspapers, newswire services,

personalized news services, broadcasting sites, and magazines. For example,
www.tvbs.com.tw2Awww.ebc.net.tw2 Awww.iset.com.tw.

Non-profits & NGOs

Sites devoted to clubs, communities, unions, and non-profit organizations. Many of
these groups exist for educational or charitable purposes. For example,
www.tzuchi.org.tw, web.redcross.org.tw, www.lksf.org.

Nudity

Sites that contain full or partial nudity that are not necessarily overtly sexual in
intent. Includes sites that advertise or sell lingerie, intimate apparel, or swim wear.
For example, www.easyshop.com.tw, www.faster-swim.com.tw,
image.baidu.com.

Personal Sites

Sites about or hosted by personal individuals, including those hosted on
commercial sites. For example, blog.yam.com, www.wretch.cc, blog.xuite.net.

Politics

Sites that promote political parties or political advocacy, or provide information
about political parties, interest groups, elections, legislation or lobbying. Also
includes sites that offer legal information and advice. For example,
www.kmt.org.tw, www.dpp.org.tw, cpc.people.com.cn.

Pornography/Sexually Explicit

Sites that contain explicit sexual content. Includes adult products such as sex toys,
CD-ROMs, and videos, adulf services such as videoconferencing, escort services,
and strip clubs, erotic stories and textual descriptions of sexual acts. For example,
www.dvd888.com, www.18center.com, blog.sina.com.tw.

Real Estate Sites relating to commercial or residential real estate services, including renting,
purchasing, selling or financing homes, offices, etc. For example,
www.sinyi.com.tw, www.yungching.com.tw, house.focus.cn.

Religion Sites that deal with faith, human spirituality or religious beliefs, including sites of

churches, synagogues, mosques and other houses of worship. For example,
www.fgs.org.tw, www.twtaoism.net, www.fhl.net.

Restaurants & Dining

Sites that list, review, promote or advertise food, dining or catering services.
Includes sites for recipes, cooking instruction and tips, food products, and wine
advisors. For example, www.jogoya.com.tw, www.dintaifung.com.tw,
www?2.pizzahut.com.tw.

Search Engines & Portals

Sites enabling the searching of the Web, newsgroups, images, directories, and
other online content. Includes portal and directory sites such as white/yellow
pages. For example, tw.yahoo.com, www.pchome.com.tw, www.google.com.tw.

Shopping

Sites for online shopping, catalogs, online ordering, auctions, classified ads.
Excludes shopping for products and services exclusively covered by another
category such as health & medicine. For example, shopping.pchome.com.tw,
buy.yahoo.com.tw, www.tkec.com.tw.
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Table 211 Managed Category Descriptions (continued)

Social Networking

Sites that enable social networking for online communities of various topics, for
friendship, dating, or professional reasons. For example, www.facebook.com,
www.flickr.com, www.groups.google.com.

Sports

Sites relating to sports teams, fan clubs, scores and sports news. Relates to all
sports, whether professional or recreational. For example, www.yankees.com,
www.nba.com, mib.mib.com.

Translators

Sites that franslate Web pages or phrases from one language to another. These
sites may be used to attempt to bypass a filtering system. For example,
franslate.google.com.tw, www.smartlinkcorp.com, translation.paralink.com.

Travel

Sites that provide fravel and tourism information or online booking of fravel
services such as airlines, accommodations, car rentals. Includes regional or city
information sites. For example, www .startravel.com.tw, taipei.grand.hyatt.com.tw,
www.car-plus.com.tw.

Violence

Sites that contain images or text depicting or advocating physical assault against
humans, animals, or institutions. Sites of a particularly gruesome nature such as
shocking depictions of blood or wounds, or cruel animal treatment. For example,
crimescene.com, deathnet.com, michiganmilitia.com.

Weapons

Sites that depict, sell, review or describe guns and weapons, including for sport. For
example, www.ak-47.net, warfare.ru.

Web-based Email

Sites that enable users to send and receive email through a web-accessible email
account. For example, mail.163.com, mail.google.com, mail.yahoo.com.tw.

General

Sites that do not clearly fall into other categories, for example, blank Web pages.
For example, bs.serving-sys.com, simg.sinajs.cn, i0.itc.cn.

Leisure & Recreation

Sites relating to recreational activities and hobbies including zoos, public
recreation centers, pools, amusement parks, and hobbies such as gardening,
literature, arts & crafts, home improvement, home d2cor, family, etc. For example,
tpbg.tfri.gov.tw, tw.fashion.yahoo.com, www.relaxtimes.com.tw.

Cults

Sites relating to non-traditional religious practice typically known as "cults,”" that is,
considered fo be false, unorthodox, extremist, or coercive, with members often
living under the direction of a charismatic leader. For example,
www.churchofsatan.com, www.ccya.org.tw.

Fashion & Beauty

Sites concerning fashion, jewelry, glamour, beauty, modeling, cosmetics or related
products or services. Includes product reviews, comparisons, and general
consumer information. For example, women.sohu.com,
baodian.women.sohu.com.

Greeting cards

Sites that allow people to send and receive greeting cards and postcards. For
example, www.e-card.com.tw, card.ivy.net.tw.

Hacking

Sites that promote or give advice about how to gain unauthorized access to
proprietary computer systems, for the purpose of stealing information,
perpetrating fraud, creating viruses, or committing other illegal activity related to
theft of digital information. For example, www.hackbase.com,
www.chinahacker.com.

llegal Software

Sites that illegally distribute software or copyrighted materials such as movies or
music, software cracks, illicit serial numbers, illegal license key generators. For
example, www.zhaokey.com.cn, www.fiansha.net.

Image Sharing

Sites that host digital photographs and images, online photo albums and digital
photo exchanges. For example, photo.pchome.com.tw, photo.xuite.neft,
photobucket.com.

Information Security

Sites that provide legitimate information about data protection, including newly
discovered vulnerabilities and how to block them. For example,
www.informationsecurity.com.tw, www.ifis.tw.

Instant Messaging

Sites that enable logging in o instant messaging services such as ICQ, AOL Instant
Messenger, IRC, MSN, Jabber, Yahoo Messenger, and the like. For example,
www.meebo.com, www.aim.com, www. ebuddy.com.
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Table 211 Managed Category Descriptions (continued)

Peer-to-Peer

Sites that enable direct exchange of files between users without dependence on
a central server. For example, www.eyny.com.

Private IP Addresses

Sites that are private IP addresses as defined in RFC 1918, that is, hosts that do not
require access to hosts in other enterprises (or require just limited access) and
whose IP address may be ambiguous between enterprises but are well defined
within a certain enterprise. For example, 172.21.20.123, 192.168.35.62.

School Cheating

Sites that promote unethical practices such as cheating or plagiarism by providing
test answers, written essays, research papers, or tferm papers. For example,
www.zydk788.com, www.huafengksw.com.

Sex Education

Sites relating to sex education, including subjects such as respect for partner,
abortion, gay and lesbian lifestyle, contraceptives, sexually transmitted diseases,
and pregnancy. For example, apps.rockyou.com, www.howmama.com.tw,
www.mombaby.com.tw.

Tasteless

Sites with offensive or tasteless content such as bathroom humor or profanity. For
example, comedycentral.com, dilbert.com.

Child Abuse Images

Sites that portray or discuss children in sexual or other abusive acts. For example,
a.uuzhijia.info.

Unknown

Unknown For example, www.669.com.tw, www.appleballoon.com.tw,
www.uimco.com.tw.

27.2.3 Content Filter Add Filter Profile Custom Service

Click Configuration > Security Service > Content Filter > Filter Profile > Add or Edit > Custom Service to
open the Custom Service screen. You can create a list of good (allowed) web site addresses and a list
of bad (blocked) web site addresses. You can also block web sites based on whether the web site's
address contains a keyword. Use this screen to add or remove specific sites or keywords from the filter

list.
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Figure 363 Configuration > Security Service > Content Filter > Filter Profile > Custom Service

&> Add Filter Profile

General Settings

Descripfion:

[[] Enable Custom Service

Restricted Web Features

Block: ] ActiveX

Trusted Web Sites
@ Add

Forbidden Web Sites

@ Add

Blocked URL Keywords

© Add

example, *.zyxel*.com).

Category Service Cuslom Service

B

S —

[C] Allow Java/ActiveX/Cookies/Web proxy to trusted web sites

Page of 0 Show |50 |» | items No data to display

Page of 0 Show |50 | » | items No data fo display

Page of 0 Show |50 |» | items No data fo display

* Note: Use "*' as a wildcard to match any string in trusted/forbidden web sites and blocked URL keywords (for

{Optional)

[ Java [ Cookies [[] Web Proxy

The following table describes the labels in this screen.

Table 212 Configuration > Security Service > Content Filter > Profile > Custom Service

LABEL DESCRIPTION

Name Enter a descriptive name for this content filtering profile name. You may use 1-31
alphanumeric characters, underscores(_), or dashes (-), but the first character
cannot be a number. This value is case-sensitive.

Description Enter a description for the content filtering profile rule to help identify the

purpose of rule. You may use 1-31 alphanumeric characters, underscores(_), or
dashes (-), but the first character cannot be a number. This value is case-
sensitive.

This field is optional.

Enable Custom Service

Select this check box to allow tfrusted web sites and block forbidden web sites.
Content filter list customization may be enabled and disabled without re-
entering these site names.

Allow Web fraffic for tfrusted web
sites only

When this box is selected, the Zyxel Device blocks Web access to sites that are
not on the Trusted Web Sites list. If they are chosen carefully, this is the most
effective way to block objectionable material.
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Table 212 Configuration > Security Service > Content Filter > Profile > Custom Service (continued)

LABEL

DESCRIPTION

Check Common Trusted/
Forbidden List

Select this check box to check the common trusted and forbidden web sites
lists. See Section 27.3 on page 539 and Section 27.4 on page 540 for information
on configuring these lists.

Restricted Web Features

Select the check box(es) to restrict a feature. Select the check box(es) to
restrict a feature.

*  When you download a page contfaining ActiveX or Java, that part of the
web page will be blocked with an X.

*  When you download a page coming from a Web Proxy, the whole web
page will be blocked.

¢  When you download a page containing cookies, the cookies will be
removed, but the page will not be blocked.

Block ActiveXis a tool for building dynamic and active web pages and distributed
. object applications. When you visit an ActiveX web site, ActiveX controls are
ActiveX downloaded to your browser, where they remain in case you visit the site again.
Java Java is a programming language and development environment for building
downloadable Web components or Infernet and intranet business applications
of all kinds.
Cookies Cookies are files stored on a computer’s hard drive. Some web servers use them
to track usage and provide service based on ID.
Web Proxy A server that acts as an infermediary between a user and the Internet to

provide security, administrative control, and caching service. When a proxy
server is located on the WAN it is possible for LAN users to circumvent content
filtering by pointfing fo this proxy server.

Allow Java/ActiveX/Cookies/
Web proxy fo trusted web sites

When this box is selected, the Zyxel Device will permit Java, ActiveX and
Cookies from sites on the Trusted Web Sites list to the LAN. In certain cases, it
may be desirable to allow Java, ActiveX or Cookies from sites that are known
and trusted.

Trusted Web Sites

These are sites that you want to allow access to, regardless of their content
rafing, can be allowed by adding them to this list.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this to delete it.

# This displays the index number of the frusted web sites.

Trusted Web Site

This column displays the trusted web sites already added.

Enfer host names such as www.good-site.com info this text field. Do not enter
the complete URL of the site — that is, do not include “http://". All subdomains
are allowed. For example, entering “*zyxel.com” also allows “www.zyxel.com”,
“partner.zyxel.com”, “press.zyxel.com”, and so on. You can also enter just a tfop

level domain. For example, enter “*.com” to allow all .com domains.

Use up to 127 characters (0-92a-z-). The casing does not matter. **" can be used
as a wildcard fo match any string. The entry must contain at least one “.” or it

will be invalid.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.
Remove Select an enfry and click this fo delete it.

# This displays the index number of the forbidden web sites.
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Table 212 Configuration > Security Service > Content Filter > Profile > Custom Service (continued)

LABEL DESCRIPTION

Forbidden Web Sites This list displays the forbidden web sites already added.

Enter host names such as www.bad-site.com into this text field. Do not enter the
complete URL of the site — that is, do not include “http://”. All subdomains are
also blocked. For example, entering “*bad-site.com” also blocks “www.bad-
site.com”, "partner.bad-site.com”, “press.bad-site.com”, and do on. You can
also enter just a top level domain. For example, enter “*.com” to block all .com

domains.

Use up to 127 characters (0-9a-z-). The casing does not matter. **" can be used

as a wildcard to match any string. The entry must contain at least one “.” or it
will be invalid.

Blocked URL Keywords This section allows you to block Web sites with URLs that contain certain
keywords in the domain name or IP address.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

# This displays the index number of the blocked URL keywords.

Blocked URL Keywords This list displays the keywords already added.

Enter a keyword or a numerical IP address to block. You can also enter a
numerical IP address.

Use up to 127 case-insensitive characters (0-9a-zA-Z;/2:@&=+$\.-_I~*()%). **"
can be used as a wildcard to match any string. Use “ | *” fo indicate a single
wildcard character.

For example entfer *Bad_Site* to block access to any web page that includes
the exact phrase Bad_Site. This does not block access to web pages that only
include part of the phrase (such as Bad for example).

oK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving your changes.

27.3 Content Filter Trusted Web Sites Screen

Click Configuration > Security Service > Content Filter > Trusted Web Sites o open the Trusted Web Sites
screen. You can create a common list of good (allowed) web site addresses. When you configure Filter
Profiles, you can select the option to check the Common Trusted Web Sites list. Use this screen to add or
remove specific sites from the filter list.

ZyWALL ATP Series User’s Guide

539



Chapter 27 Content Filter

Figure 364 Configuration > Security Service > Content Filter > Trusted Web Sites

Common Trusted Web Sites

* Note:
Enable "Check Common Trusted/Forbidden List" in the Cusiom Service of profile to apply all these
websites.
© Add
Page of 0 Show |50 |~ items No data fo display

Trusted Web Sites Forbidden Web Sites

Crey | reser |

The following table describes the labels in this screen.

Table 213 Configuration > Security Service > Content Filter > Trusted Web Sites

LABEL DESCRIPTION

Common Trusted Web Sites These are sites that you want to allow access o, regardless of their content
rating, can be allowed by adding them to this list.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

# This displays the index number of the trusted web sites.

Trusted Web Site This column displays the trusted web sites already added.
Enter host names such as www.good-site.com info this text field. Do not enter
the complete URL of the site — that is, do not include “http://". All subdomains
are allowed. For example, entering “zyxel.com” also allows “www.zyxel.com”,
“partner.zyxel.com”, “press.zyxel.com”, and so on. You can also enter just a top
level domain. For example, enter .com to allow all .com domains.
Use up to 127 characters (0-9a-z-). The casing does not matter.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings.

27.4 Content Filter Forbidden Web Sites Screen

Click Configuration > Security Service > Content Filter > Forbidden Web Sites to open the Forbidden Web
Sites screen. You can create a common list of bad (blocked) web site addresses. When you configure
Filter Profiles, you can select the option to check the Common Forbidden Web Sites list. Use this screen to

add or remove specific sites from the filter list.
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Figure 365 Configuration > Security Service > Content Filter > Forbidden Web Sites

Profile Trusted Web Sites

Common Forbidden Web Sites

* Note:
websites.

© Add

Page of 0

Enable "Check Common Trusted/Forbidden List" in the Custom Service of profile to apply all these

Show 50 |v| items No data fo display

Cvey | eser

The following table describes the labels in this screen.

Table 214 Configuration > Security Service > Content Filter > Forbidden Web Sites

LABEL

DESCRIPTION

Forbidden Web Site List

Sites that you want to block access to, regardless of their content rating, can be
allowed by adding them fo this list.

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this to delete it.

# This displays the index number of the forbidden web sites.

Forbidden Web Sites

This list displays the forbidden web sites already added.

Enter host names such as www.bad-site.com into this text field. Do not enter the
complete URL of the site — that is, do not include “http://". All subdomains are
also blocked. For example, entering “bad-site.com” also blocks “www.bad-
site.com”, "partner.bad-site.com”, “press.bad-site.com”, and do on. You can
also enter just a top level domain. For example, enter .com to block all .com

domains.

Use up to 127 characters (0-9a-z-). The casing does not matter.

Apply

Click Apply to save your changes back to the Zyxel Device.

Cancel

Click Reset to return the screen to its last-saved settings.

27.5 Content Filter Technical Reference

This section provides content filtering background information.

External Content Filter Server Lookup Procedure

The content filter lookup process is described below.
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Figure 366 Content Filter Lookup Procedure

1 2 AS/YE
%E

A computer behind the Zyxel Device tries to access a web site.

The Zyxel Device looks up the web site in its cache. If an attempt to access the web site was made in the
past, a record of that web site’s category will be in the Zyxel Device's cache. The Zyxel Device blocks,
blocks and logs or just logs the request based on your configuration.

Use the Content Filter Cache screen to configure how long a web site address remains in the cache as
well as view those web site addresses. All of the web site address records are also cleared from the local
cache when the Zyxel Device restarts.

If the Zyxel Device has no record of the web site, it queries the external content filter database and
simultaneously sends the request to the web server.

The external content filter server sends the category information back to the Zyxel Device, which then
blocks and/or logs access to the web site based on the settings in the content filter profile. The web
site’'s address and category are then stored in the Zyxel Device's content filter cache.
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CHAPTER 28
Anti-Malware

28.1 Overview

Use the Zyxel Device's anti-malware feature to protect your connected network from malware
(malicious software) infection, such as computer virus, worms, and spyware. The Zyxel Device checks
traffic going in both directions for signature matches. In the following figure, the Zyxel Device checks
traffic coming from the WAN zone (which includes two interfaces) to the LAN zone.

Figure 367 Zyxel Device Anfi-Malware Example

e e
LAN

The anti-malware matches a file with those in a malware database. This is done as files go through the
Zyxel Device.

Virus, Worm, and Spyware

A computer virus is a type of malicious software designed to corrupt and/or alter the operation of other
legitimate programs. A wormis a self-replicating virus that resides in active memory and duplicates itself.
The effect of a virus attack varies from doing so little damage that you are unaware your computer is
infected to wiping out the entire contents of a hard drive fo rendering your computer inoperable.
Spyware infiltrate your device and secretly gathers information about you, such as your network activity,
passwords, bank details, and so on.

ZyWALL ATP Series User’s Guide

543



Chapter 28 Anfi-Malware

Hash Value

A hash function is an algorithm that maps data of arbitrary size to data of fixed size. The value returned
by a hash function is a hash value. Hash values can be used to identify the contents of a file. During an
anti-malware file scan, the hash value of a file is matched with signatures. At the time of writing, MD5
(Message Digest 5) is supported. MD5 is a hash algorithm used to authenticate packet data.

Local Signature Databases

The Zyxel Device downloads the signature(s) after it is registered and the anfi-malware license is
activated at myZyxel. A signature is a unique string of bits, or binary pattern, of a malware. A signature
acts as a fingerprint that can be used to detect and identify specific malware. The Zyxel Device
downloads the following signatures:

* Anti-malware signature

¢ Threat Inteligence Machine Learning

These signatures are periodically updated if you have a valid license. See Section 28.2 on page 548 for
how the Zyxel Device updates these signatures for the anti-malware license.

Cloud Query

Another method of malware protection is through cloud query. This process is illustrated in the next
figure. If Cloud Query is enabled, the Zyxel Device queries the Defend Center database by sending the
file's hash value (A) and receiving the scan results (B) through the Defend Center (DC).

Figure 368 Cloud Query

""" : I B Database

Anti-Malware Licensing
Having extensive, up-to-date signatures with the most common malware is critical o making the anti-
malware service work effectively. Section 7.2 on page 189 shows licensing information for the different

signature databases that can be used by the Zyxel Device.

After the anfi-malware license expires, you need to purchase an iCard to update your local signature
database and use cloud query. Extend your license in the Registration > Service screen.

Anti-Malware Scan Process

Before going through the Anti-Malware scan, the Zyxel Device first identifies the packets sent by the
following four major protocols with corresponding standard ports:

e FTP (File Transfer Protocol)
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* HTTP (Hyper Text Transfer Protocol)
* SMTP (Simple Mail Transfer Protocol)
» POP3 (Post Office Protocol version 3)

The Zyxel Device records the order of packets in TCP connection-oriented sessions to check for
matching malware signatures. The order of non-setup packets such as SYN, ACK and FIN is ignored.

Anti-Malware Scanning Procedure:

The Zyxel Device checks every packet of the file for matches with the local signature databases.

If a malware pattern signature is matched, the actions you specify for identified malware will be
applied. If Destroy infected file is enabled, the file will be modified. Logs/alerts will be sent according to
your settings.

Note: The receiver is not nofified if a file is modified by the Zyxel Device. If the file cannot be
used, the receiver should contact the Zyxel Device administrator fo confirm if the Zyxel
Device modified the file by checking the logs.

If no match is found with the local databases, the Zyxel Device uses Cloud Query to forward the file's
hash value to Defend Center.

Defend Center checks its database for malware signature matches and sends the results back to the
Zyxel Device.

If a malware signature is matched, the actions you specify for identified malware will be applied. If
Destroy infected file is enabled, the file will be modified. Logs/alerts will be sent according to your
settings.

The next figure shows a flow chart detailing the anti-malware scan.
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Figure 369 Anti-Malware flowchart

Start

Check for
malware patterns

Check for N
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Match? Modify the file*

Modify the file*

Cloud Query

Modify the file*
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*Destroy infected file must be enabled
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Cloud Query Supported File Types

At the fime of wrifing, the following file types are supported by Cloud Query:

e 7z Archive (7z) * AVIVideo (avi) * BMPImage (bmp) <« BZ2 Archive (bz2)
e Executables (exe) ¢ Macromedia Flash ¢ GIF Image (gif) e GZ Archive (gz)
Data (swf)
e JPG Image (jpg) ¢ MOV Video (mov) ¢ MP3 Audio (mp3) ¢ MPG Video (mpg)
* MS Office * PDF Document * PNG Image (png) <« RAR Archive (rar)
Document (doc...) (pdf)
* RM Video (rm) e RTF Document (rtf) ¢ TIFF Image (fif) * WAV Audio (wav)

* 7IP Archive (zip)

Notes About the Zyxel Device Anti-Malware

The following lists important notes about the Zyxel Device's anti-malware feature:

1 Zyxel's anti-malware feature can detect polymorphic malware (see Section 28.6 on page 554).

2 When malware is detected, a log is created or an alert message is sent to the administrator depending
on your log settings.

3 Changes to the Zyxel Device's anfi-malware settings only affect new sessions, not sessions that already
existed before you applied the changed settings.

4 Enabling Cloud Query may affect file fransfer speeds.

5 The Zyxel Device does not scan the following file/traffic types:

» Simultaneous downloads of a file using multiple connections. For example, when you use FlashGet
to download sections of a file simultaneously.

* Encrypted fraffic. This could be password-protected files or VPN traffic where the Zyxel Device is not
the endpoint (pass-through VPN traffic).

* Traffic through custom (non-standard) ports. The Zyxel Device scans whatever port number is
specified for FTP in the ALG screen.

* All compressed files within a compressed file. Note that a single file can still be decompressed and
scanned if you select Enable file decompression (ZIP and RAR).

* Traffic compressed or encoded using a method the Zyxel Device does not support.

Finding Out More

¢ See Section 28.6 on page 554 for anti-malware background information.

28.1.1 What You Can Do in this Chapter

¢ Use the Anti-Malware screen (Section 28.2 on page 548) to turn anti-malware on or off, and check
the anfi-malware signature status. In addition, you can set up anfi-malware black (blocked) and
white (allowed) lists of malware patterns.

¢ Use the Signature screen (Section 28.5 on page 553) to search for particular signatures and get more
information about them.
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28.2 Anti-Malware Screen

Click Configuration > Security Service > Anti-Malware to display the configuration screen as shown next.

Click the Anti-Malware icon for more information on the Zyxel Device's security features.

Note: The threat inteligence machine learning (TIML) feature is not available if the gold
security pack is expired. Neither will the Zyxel Device update the TIML signatures, nor will
it scan the TIML signatures that were downloaded when you used the gold security
pack.

See Subscription Services Available on page 186 for more information on the
subscription services for the two types of security packs.

Note: If “Destroy infected file” is disabled and "log” is set to “no”, the Zyxel Device will still
perform the scan but will not do anything else. It is recommended to enable at least
one of the two functions.

If “Destroy infected file” is disabled, any malicious file found can still be
executed by the end user after it is forwarded. The administrator would
have to inform the user if there is an infected file.
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Figure 370 Configuration > Security Service > Anfi-Malware

Anti-Malware Black/White List Signature

-’!k Anti-Malware

General Settings
Enable
Scan and detect EICAR test virus

Cloud Query
[[1Enable Cloud Query (1)

7z Archive (7z)
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BMP Image [bmp)
BZ2 Archive (bz2)

Executables (exe)
Macromedia Flash Data (swf)
MS Office Document (doc...)
PDF Document (pdf)

GIF Image (gif] RTF Document (rif)
GI Archive (gz) IIP Archive (Zip)
JPG Image (jpg)

MOV Video (mov)

MP3 Audio (mp3)

MPC Video (mpg)
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RAR Archive (rar)

RM Video (rmy) -

Actions When Matched

Destroy infected file
Log: og v

File decompression
Enable file decompression (ZIP and RAR)

[] Destroy compressed files that could not be decompressed

Signature Information
Anfi-Malware Signature
1.0.0.000

2017-12-31 16:00:00 (UTC+00:00)

Current Version:
Released Date:
Threat Intelligence Machine Learning
1.0.0.20171211.1
2017-12-11 05:46:40 {UTC+00:00)

Current Version:
Released Date:

Update Signatures

oy | Reser |
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The following table describes the labels in this screen.

Table 215 Configuration > Security Service > Antfi-Malware

LABEL

DESCRIPTION

General Setting

Enable

Select this checkbox to activate the anti-malware feature to protect your connected
network from infection and the installation of malicious software.

Selecting this checkbox also activates the threat intelligence machine learning (TIML)
feature. TIML signatures come from the sandboxing inspection results and helps the Zyxel
Device block possible malicious or suspicious files.

Scan and detect
EICAR test virus

Select this option to have the Zyxel Device check for the EICAR test file and treat it in the
same way as a real malware file. The EICAR test file is a standardized test file for signature
based anti-malware scanners. When the scanner detects the EICAR file, it responds in the
same way as if it found a real malware. Besides straightforward detection, the EICAR file
can also be compressed to test whether the anti-malware software can detect itin a
compressed file. The test string consists of the following human-readable ASCII characters.

XSO!IP%@AP [4\PZX54(PA)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILEI$H+H*

Enable Cloud Query

Select this check box to enable the cloud query service. This improves the effectiveness of
malware detection, but can affect file fransfer speeds as it needs to send information to the
cloud.

Available File Types

File types that can be checked by the Zyxel Device through cloud query are listed here.
Note that the files on this list are currently bypassed. To use the cloud query feature on a
specific file type, click this file type and then click the right arrow button.

See available file types in Section 28.1 on page 543.

Applied File Types

File types that go through the cloud query process are listed here. If you don’t want a file
type to be checked, click this file type and then click the left arrow button.

Destroy infected file

When you select this check box, if a malware signature is matched, the Zyxel Device
overwrites the infected portion of the file with zeros before being forwarded to the user. The
uninfected portion of the file will pass through unmodified.

Log

These are the log options:

¢ no: Do not create alog when a packet matches a signature(s).
* log: Create alog on the Zyxel Device when a packet matches a signature(s).

¢ log alert: An alert is an emailed log for more serious events that may need more
immediate aftention. Select this option to have the Zyxel Device send an alert when a
packet matches a signature(s).

Check White List

Select this check box to have the Zyxel Device not perform the anti-malware check on files
with names that match the white list patterns.

Add Click this to create a new entry.

Edit Select an entry and click this to be able fo modify it.

Remove Select an entry and click this to delete it.

Activate To turn on an enftry, select it and click Activate.

Inactivate To turn off an enftry, select it and click Inactivate.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is
inactive.

# This is the entry’s index number in the list.

File Pattern This is the file name pattern. If a file's name matches this pattern, the Zyxel Device does not
check the file for malware.

Check Black List Select this check box to log and delete files with names that match the black list patterns.

Add Click this to create a new entry.

Edit Select an entry and click this to be able fo modify it.

Remove Select an entry and click this to delete it.
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Table 215 Configuration > Security Service > Anfi-Malware (continued)

LABEL DESCRIPTION

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an enftry, select it and click Inactivate.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is
inactive.

# This is the enftry’s index number in the list.

File Pattern This is the file name pattern. If a file’s name that matches this pattern, the Zyxel Device logs

and then destroys the file.

File decompression

Enable file
decompression (ZIP
and RAR)

Select this check box to have the Zyxel Device scan a compressed file (the file does not
need to have a "zip" or “rar” file extension). The Zyxel Device first decompresses the file and
then scans the contents for malware.

Note: The Zyxel Device decompresses a compressed file once. The Zyxel Device
does NOT decompress any file(s) within a compressed file.

Destroy
compressed files
that could not
be
decompressed

When you select this check box, the Zyxel Device deletes compressed files that use
password encryption.

Select this check box to have the Zyxel Device delete any compressed files that it cannot
decompress. The Zyxel Device cannot decompress password protected files or a file within
another compressed file. There are also limits to the number of compressed files that the
Zyxel Device can concurrently decompress.

Note: The Zyxel Device's firmware package cannot go through the Zyxel Device
with this check box enabled. The Zyxel Device classifies the firmware
package as a file that cannot be decompressed and then deletes it. Clear
this check box when you download a firmware package from the Zyxel
website. It's OK to upload a firmware package to the Zyxel Device with the
check box selected.

Signature
Information

The following fields display information on the current signature set that the Zyxel Device is
using.

Current Version

This field displays the signature set version number currently used by the Zyxel Device. This
number gets larger as the setf is enhanced.

Released Date

This field displays the date and time the set was released.

Update Click this link to go to the screen you can use tfo download signatures from the update
Signatures server.

Apply Click Apply fo save your changes.

Reset Click Reset to refurn the screen to its last-saved settings.

28.3 The Black List Screen

A black list allows you to specify the file or encryption pattern that you want to block. False positives
occur when a non-infected file matches a malware signature.

Enter a file or encryption pattern that would cause the Zyxel Device to log and then destroy this file.

Click Configuration > Security Service > Anti-Malware > Black/White List > Black List fo display the
following screen. Use Add to put a new entry in the list or Edit to change an existing one or Remove to
delete an existing entry.
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Figure 371 Configuration > Security Service > Anti-Malware > Black/White List > Black List

Black List White List

Check Black List
© Add

Page of 0 Show |50 |» | items No data to display

“hony | peser |

The following table describes the fields in this screen.

Table 216 Configuration > Security Service > Anfi-Malware > Black/White List > Black List

LABEL DESCRIPTION

Check Black List Select this check box to log and delete files with names or encryption algorithm (MD5 Hash)
that match the black list patterns.

Add Click this to create a new enfry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an enfry, select it and click Inactivate.

# This is the entry’s index number in the list.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is
inactive.

Type This field displays the type (MD5 Hash or File Pattern) used to distinguish whether a file should
be blocked.

Select the type (MD5 Hash or File Pattern) that you want to use to distinguish whether a file
should be blocked.

Value This field displays the file or encryption pattern of the entry.

Enter the file or encryption pattern for this entry.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings.

28.4 The White List Screen

A white list allows you to specify the file or encryption pattern to allow in order to avoid false positives.
False positives occur when a non-infected file matches a malware signature.

Enter a file or encryption pattern that would cause the Zyxel Device to allow this file.
Click Configuration > Security Service > Anti-Malware > Black/White List > White List to display the

following screen. Use Add to put a new entry in the list or Edit fo change an existing one or Remove fo
delete an existing entry.
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Figure 372 Configuration > Security Service > Anti-Malware > Black/White List > White List

Check White List
© Add

Page of 0 Show |50 |» | items No data to display

Cavey | ket |

The following table describes the fields in this screen.

Table 217 Configuration > Security Service > Anfi-Malware > Black/White List > White List

LABEL DESCRIPTION

Check White List Select this check box to have the Zyxel Device not perform the anti-malware check on files
with names or algorithm (MD5 Hash) that match the white list patterns.

Add Click this to create a new enfry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an enfry, select it and click Inactivate.

# This is the entry’s index number in the list.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the enftry is
inactive.

Type This field displays the type (MD5 Hash or File Pattern) used to distinguish whether a file should
be allowed.

Select the type (MD5 Hash or File Pattern) that you want to use to distinguish whether a file
should be allowed.

Value This field displays the file or encryption pattern of the entry.

Enter the file or encryption pattern for this entry.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings.

28.5 Anti-Malware Signature Searching

Click Configuration > Security Service > Anti-Malware > Signature to display this screen. Use this screen
to locate signatures and display details about them.

If your web browser opens a warning screen about a script making the web browser run slowly and the
computer unresponsive, just click No to continue. Click a column’s heading cell to sort the table entries
by that column'’s criteria. Click the heading cell again to reverse the sort order.
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Figure 373 Configuration > Security Service > Anfi-Malware > Signature

Anti-Malware Signature

Query Signatures

Signatures Search

Query Result

Query all signatures and export m

Page of 0

[ e

Show |80 || items No data to display

The following table describes the labels in this screen.

Table 218 Configuration > Security Service > Anti-Malware > Signature

LABEL

DESCRIPTION

Signatures Search

Enter the name, part of the name or keyword of the signature(s) you want to find and click
Search. This search is not case-sensitive and accepts numerical strings.

Query all signatures
and export

Click Export to have the Zyxel Device save all of the anti-malware signatures to your
computerin a .ixt file.

Query Result

#

This is the entry’s index number in the list.

Name

This is the name of the anti-malware signature. Click the Name column heading to sort your
search results in ascending or descending order according to the signature name.

Click a signature’s name to see details about the malware.

28.6 Anti-Malware Technical Reference

Types of Malware

The following table describes some of the common malware.

Table 219 Common Malware Types

TYPE

DESCRIPTION

File Infector

This is a small program that embeds itself in a legitimate program. A file infector is able fo
copy and attach itself to other programs that are executed on an infected computer.

Boot Sector Virus

This type of virus infects the area of a hard drive that a computer reads and executes
during startup. The virus causes computer crashes and to some extend renders the infected
computer inoperable.

Macro Virus Macro viruses or Macros are small programs that are created to perform repetitive actions.
Macros run automatically when a file to which they are attached is opened. Macros
spread more rapidly than other types of viruses as data files are often shared on a network.

Email Virus Email viruses are malicious programs that spread through email.

Polymorphic Virus

A polymorphic virus (also known as a mutation virus) tries to evade detection by changing
a portion of its code structure after each execution or self replication. This makes it harder
for an anfi-malware scanner to detect or intercept it.

A polymorphic virus can also belong to any of the virus types discussed above.
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Malware Infection and Prevention

The following describes a simple life cycle of malware.

A computer gets a copy of malware from a source such as the Internet, email, file sharing or any
removable storage media. The malware is harmless until the execution of an infected program.

The malware spreads to other files and programs on the computer.
The infected files are unintentionally sent to another computer thus starting the spread of the malware.

Once the malware is spread through the network, the number of infected networked computers can
grow exponentially.

Types of Anti-Malware Scanner
The section describes two types of anfi-malware scanner: host-based and network-based.

A host-based anfi-malware (HAM) scanner is often software installed on computers and/or servers in the
network. It inspects files for malware patterns as they are moved in and out of the hard drive. However,
host-based anti-malware scanners cannot eliminate all malware for a number of reasons:

* HAM scanners are slow in stopping malware threats through real-time traffic (such as from the
Internet).

*« HAM scanners may reduce computing performance as they also share the resources (such as CPU
time) on the computer for file inspection.

* You have fo update the malware signatures and/or perform malware scans on all computers in the
network regularly.

A network-based anti-malware (NAM) scanner is often deployed as a dedicated security device (such
as your Zyxel Device) on the network edge. NAM scanners inspect real-time data traffic (such as email
messages or web) that tends to bypass HAM scanners. The following lists some of the benefits of NAM
scanners.

¢ NAM scanners stop malware threats at the network edge before they enter or exit a network.

* NAM scanners reduce computing loading on computers as the read-time data traffic inspection is
done on a dedicated security device.
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Reputation Filter

29.1 Overview

Use the Reputation Filter screens to configure settings for IP reputation and botnet filtering.

29.1.1 What You Need to Know

IP Reputation

IP reputation checks the reputation of an IP address from a database. An IP address with bad
reputation associates with suspicious activities, such as spam, virus, and/or phishing. The Zyxel Device will
respond when there are packets coming from an IPv4 address with bad reputation.

Botnet Filtering

A botnet is a network consisting of computers that are infected with malware and remotely controlled.
The infected computers will contact and wait for instructions from a command and control (C&C)
server(s). An attacker can control the botnet by setting up a C&C server and sending commands to the
infected computers. Alternatively, a peer-to-peer network approach is used. The infected computer
scans and communicates with the peer devices in the same botnet to share commands or malware
sent by the C&C server.

29.1.2 What You Can Do in this Chapter
* Use the IP Reputation screen (Section 29.2 on page 556) to enable IP reputation and specify what
action the Zyxel Device takes when any IP address with bad reputation is detected.

¢ Use the Botnet Filter screen (Section 29.3 on page 561) to enable botnet filtering and specify what
action the Zyxel Device takes when any suspicious activity is detected.

29.2 IP Reputation Screen

When you register for and enable the IP reputation service, your Zyxel Device downloads signature files
that identifies reputation of IPv4 addresses. You can have the Zyxel Device forward, block, and/or log
packets from IPv4 addresses based on these signatures and categories.

Use this screen to enable IP reputation and specify the action the Zyxel Device takes when it detects a
suspicious activity or a connection attempt to or from an IPv4 address with bad reputation.

Click Configuration > Security Service > Reputation Filter > IP Reputation > General to display the
configuration screen as shown next.
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Figure 374 Configuratfion > Security Service > Reputation Filter > IP Reputation > General

IP Reputation Botnet Filter
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IP Blocking
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Current Version:
Signature Numkber:
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Update Signatures
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Types of Cyber Threats Coming From The Internet And Local Networks

[F] Denial of Service [[] Exploits
[[1Scanners [[1Spam Sources

[l Web Attacks

[C] Phishing
1.0.0.20190122.0
1460521
2019-01-30 10:51:44

| apply ] Reset |

The following table describes the labels in this screen.

Table 220 Configuration > Security Service > Reputation Filter > IP Reputation > General

LABEL DESCRIPTION

IP Blocking

Enable Select this option to turn on IP blocking on the Zyxel Device. Otherwise, deselect it.

Action Set what action the Zyxel Device takes when packets come from an IPv4 address with bad

reputation.
forward: Select this action to have the Zyxel Device allow the packet fo go through.

block: Select this action to have the Zyxel Device deny the packets and send a TCP RST to
both the sender and receiver when a packet comes from an IPv4 address with bad
reputation.

Threat Level
Threshold

Select the threshold threat level fo which the Zyxel Device will take action (high, medium
and above, Low and above).

The threat level is determined by the IP reputation engine. It grades IPv4 addresses.

* high: An IPv4 address that scores 0 fo 20 poinfs.
¢ medium and above: An IPv4 address that scores 0-60 points.
¢ Low and above: An IPv4 address that scores 0-80 pointgs.
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Table 220 Configuration > Security Service > Reputation Filter > IP Reputation > General (continued)

Threats Coming From
The Internet

LABEL DESCRIPTION

Log These are the log options:
no: Do not create a log when the packet comes from an IPv4 address with bad reputation.
log: Create alog on the Zyxel Device when the packet comes from an IPv4 address with
bad reputation.
log alert: An alert is an emailed log for more serious events that may need more immediate
attention. Select this option to have the Zyxel Device send an alert when the packet comes
from an IPv4 address with bad reputation.

Types of Cyber Select the categories of packets that come from the Internet and are known to pose a

security threat to users or their computers. Otherwise, deselect it.

Anonymous
Proxies

Sites and proxies that act as an intermediary for surfing to other websites in an anonymous
fashion, whether to circumvent Web filtering or for other reasons. For example, blog.go2.tw,
anonymizer.com, www.qu3é5.com.

Denial of Service

Sites that issue Denial of Service (DoS) attacks, such as DoS, DDoS, SYN flood, and
anomalous traffic detection.

DoS attacks can flood your Internet connection with invalid packets and connection
requests, using so much bandwidth and so many resources that Internet access becomes
unavailable. The goal of DoS attacks is not to steal information, but to disable a device or
network on the Internet.

A Distributed Denial of Service (DDoS) attack is one in which multiple compromised systems
attack a single target, thereby causing denial of service for users of the targeted system.

SYN flood is an attack that attackers flood SYN packets to a server in TCP handshakes, and
not respond with ACK packets on purpose. This keeps the server waiting for attackers’
responses to establish TCP connections, and make the server unavailable.

Anomalous fraffic detection could be malicious activities, such as malware outbreaks or
hacking attempts.

Exploits Sites that distribute exploits or exploit kits to infect website visitors' devices. Exploits include
shellcode, root kits, worms, or viruses that download additional malware to infect devices.
An exploit kit consists of different exploits.

Negative Sites that have bad reputation and associate with suspicious activities, such as spam, virus,

Reputation and/or phishing.

Scanners Sites that run unauthorized system vulnerabilities scan to look for vulnerabilities in website

visitors' devices.

Spam Sources

Sites that have been promoted through spam techniques. For example,
img.tongji.linezing.com, banner.chinesegamer.net.

TOR Proxies

Sites that act as the exit nodes in a Tor (The Onion Router) network.

Tor is a service that keep users anonymous in the Internet and make users’ Internet activities
untraceable. Tor hides user’s real IP addresses by encrypting data and transmitting the
encrypted data in a chain of selected nodes acting as intermediaries. Each node can only
decrypt the data sent from the node before it. The first node that receives the encrypted
datais called the entry node. The last node is the last intfermediary that the encrypted data
will go through before it arrives at the desfination.
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Table 220 Configuration > Security Service > Reputation Filter > IP Reputation > General (continued)

LABEL DESCRIPTION

Web Attacks Sites that launch web attacks, such as SQL injection, cross site scripting, iframe injection,
and brute force attack.

SQL injection (SQLI) is an attack that attackers insert malicious SQL (Structured Query
Language) code into a web application database query. Attackers can then access, add,
modify, or delete data in users’ databases.

Cross site scripting (XSS) is an attack that afttackers injects malicious scripts to websites or
web applications in the form of HTML or JavaScript code. The scripts execute when users
visit the infected web page or perform the infected web applications. XSS will cause failures
to encrypt traffic, cookie stealing, identity impersonation, and phishing.

Iframe injection is an attack that attackers injects malicious iframe (inline frame) tags to
websites. The malicious iframe tag downloads malware to the devices of the infected
websites’ visitors, and steal users’ sensitive information. An iframe tag is an HTML tag that is
used to embed contents from another source in a website, but attackers misuse this feature.

Brute force aftack is an aftack that attackers attempt to gain access to websites or device
via a succession of different passwords.

Types of Cyber Select the categories of packets that come from the Internet and local network. The
Threats Coming From | categories of packets are known to pose a security threat to users or their computers.
The Internet And Otherwise, deselect it.
Local Networks

Botnets Sites that use bots (zombies) including command-and-control (C&C) servers.

Phishing Sites that are used for deceptive or fraudulent purposes (e.g. phishing), such as stealing

financial or other user account information. These sites are most often designed to appear
as legitimate sites in order to mislead users into entering their credentials. For example,
optimizedby.rmxads.com, 218.1.71.226/.../e3b.

Test IP Threat Category

IP to test Enter an IPv4 address of a website, and click the Query button to check if the website
associates with suspicious activities that could pose a security threat to users or their
computers.

Signature The Zyxel Device comes with signatures for IP reputation. These signatures are continually
Information updated as new malware evolves. New signatures can be downloaded to the Zyxel Device

periodically if you have subscribed for the IP reputation signatures service.

You need fo create an account at myZyxel, register your Zyxel Device and then subscribe
for IP reputation service in order to be able to download new signatures from myZyxel (see
the Registration screens).

The following fields display information on the current signature set that the Zyxel Device is
using.

Current Version This field displays the signature set version number currently used by the Zyxel Device. This
number gets larger as new signatfures are added.

Signature Number This field displays the number of signatures in this set.

Released Date This field displays the date and time the set was released.

Update Signatures Click this to go to the Configuration > Licensing > Signature Update screen to check for new
signatures at myZyxel. You can schedule or immediately download signatures.

Apply Click Apply to save your changes.

Reset Click Reset to return the screen to ifs last-saved settings.

29.2.1 IP Reputation White List Screen

Use this screen to create white list entries. The Zyxel Device will allow the incoming and outgoing packets
from the listed IPv4 addresses.
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You can add up to 256 entries in the IP reputation white list.

Figure 375 Configuratfion > Security Service > Reputation Filter > IP Reputation > White List

White List
[Tl Check White List
© Add

Page of 0

IP Reputation Botnet Filter
General m Black List

Show 50 || items No data fo display

ooy | eser

The following table describes the labels in this screen.

Table 221 Configuration > Security Service > Reputation Filter > IP Reputation > White List
LABEL DESCRIPTION
White List

Check White List

Select this check box and the Zyxel Device will allow the incoming packets that come
from the listed IPv4 addresses.

Note: Enable IP blocking in the Configuration > Security Service > Reputation
Filter > IP Reputation > General screen for the white list fo take effect.

Add Click this to create a new enfry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an entry, select it and click Inactivate.

# This is the entry’s index number in the list.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the enftry is
inactive.

IPv4 Address This field displays the IPv4 address of this entry.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset o return the screen to its last-saved settings.

29.2.2 IP Reputation Black List Screen

Use this screen to create black list entries. The Zyxel Device will block the incoming and outgoing
packets from the listed IPv4 addresses.

You can add up to 256 entries in the IP reputation black list.
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Figure 376 Configuration > Security Service > Reputation Filter > IP Reputation > Black List
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The following table describes the labels in this screen.

Table 222 Configuration > Security Service > Reputation Filter > IP Reputation > Black List

LABEL DESCRIPTION

Black List

Check Black List Select this check box and the Zyxel Device will block the incoming packets that come
from the listed IPv4 addresses.
Note: Enable IP blocking in the Configuration > Security Service > Reputation

Filter > IP Reputation > General screen for the black list to take effect.

Add Click this to creafte a new enfry.

Edit Select an entry and click this fo be able to modify it.

Remove Select an entry and click this to delete it.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an enfry, select it and click Inactivate.

# This is the entry’s index number in the list.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is
inactive.

IPv4 Address This field displays the IPv4 address of this entry.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset fo refurn the screen to its last-saved settings.

29.3 Botnet Filter Screen

The Zyxel Device's botnet filtering service allows you to detect and block connection attempts to or
from the C&C server or known botnet IP addresses.

When you register for and enable the botnet filtering service, your Zyxel Device downloads signature
files that contain known botnet domain names and IP addresses. The Zyxel Device will also access an
external database that has millions of web sites categorized based on content. You can have the Zyxel
Device allow, block, block and/or log access to web sites or hosts based on these signatures and

categories.
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Use this screen to enable botnet filtering and specify the action the Zyxel Device takes when it detects a
suspicious activity or a connection attempt to or from a botnet C&C server.

Click the Botnet Filter icon for more information on the Zyxel Device's security features.

Click Configuration > Security Service > Reputation Filter > Botnet Filter to display the configuration

screen as shown next.

Figure 377 Configuration > Security Service > Reputation Filter > Botnet Filter > General
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The following table describes the labels in this screen.

Table 223 Configuration > Security Service > Reputation Filter > Botnet Filter > General

LABEL DESCRIPTION
URL Blocking
Enable Select this option to turn on URL blocking on the Zyxel Device.
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Table 223 Configuration > Security Service > Reputation Filter > Botnet Filter > General (continued)

LABEL DESCRIPTION

Action Set what action the Zyxel Device takes when it detects a connection attempt to or from the
web pages of the specified categories.
block: Select this action to have the Zyxel Device block access to the web pages that
match the categories that you select above.
warn: Select this action to have the Zyxel Device display a warning message to the access
requesters for the web pages before allowing users fo access web pages that match the
categories that you select above.
pass: Select this action to have the Zyxel Device allow access to the web pages that match
the categories that you select above.

Log These are the log options:

no: Do not create alog when it detects a connection attempt to or from the web pages of
the specified categories.

log: Create alog on the Zyxel Device when it detects a connection atfempt to or from the
web pages of the specified categories.

Message to display when a site is blocked

Denied Access
Message

Enter a message to be displayed when the botnet filter blocks access to a web page. Use
up to 127 characters (0-90-zA-Z;/2:@&=+$\.-_I~*'()%."). For example, “Access to this web
page is not allowed. Please contact the network administrator”.

It is also possible to leave this field blank if you have a URL specified in the Redirect URL field.
In this case if the botnet filter blocks access to a web page, the Zyxel Device just opens the
web page you specified without showing a denied access message.

Redirect URL

Enfer the URL of the web page to which you want to send users when their web access is
blocked by the botnet filter. The web page you specify here opens in a new frame below
the denied access message.

Use “http://" or “https://" followed by up to 262 characters (0-90-zA-Z;/2:@&=+$\.-_I~*'()%).
For example, http://192.168.1.17/blocked access.

Managed Select the categories of web pages that are known to pose a security threat to users or their
Categories computers. Otherwise, deselect it.

Anonymizers Sites and proxies that act as an intermediary for surfing to other Web sites in an anonymous
fashion, whether to circumvent Web filtering or for other reasons. For example, blog.go2.tw,
anonymizer.com, www.qu3é5.com.

Botnet C&C Sites that use bots (zombies) including command-and-control (C&C) servers.

Compromised

Sites that have been compromised by someone other than the site owner in order to install
mallicious programs without the user's knowledge. Includes sites that may be vulnerable to a
particular high-risk attack. For example, www.wokoo.net, movie.sx.zj.cn.

Malware

Sites that install unwanted software on a user's computer with the intent fo enable third-
party monitoring or make system changes without the user's consent. For example,
www.tglkg.com, aladel.neft.

Phishing & Fraud

Sites that are used for deceptive or fraudulent purposes (e.g. phishing), such as stealing
financial or other user account information. These sites are most often designed to appear
as legitimate sites in order to mislead users into entering their credentials. For example,
optimizedby.rmxads.com, 218.1.71.226/.../e3b.

Spam Sites

Sites that have been promoted through spam techniques. For example,
img.tongiji.linezing.com, banner.chinesegamer.net.
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Table 223 Configuration > Security Service > Reputation Filter > Botnet Filter > General (continued)

LABEL DESCRIPTION
Signature The Zyxel Device comes with signatures for the botnet filter. These signatures are continually
Information updated as new malware evolves. New signatures can be downloaded to the Zyxel Device

periodically if you have subscribed for the botnet filter signatures service.

You need to create an account at myZyxel, register your Zyxel Device and then subscribe
for botnet filter service in order to be able to download new signatures from myZyxel (see
the Registration screens).

The following fields display information on the current signature set that the Zyxel Device is
using.

Current Version

This field displays the signature set version number currently used by the Zyxel Device. This
number gefts larger as new signatures are added.

Signature Number

This field displays the number of signatures in this sef.

Released Date

This field displays the date and time the set was released.

Update Signatures

Click this fo go to the Configuration > Licensing > Signature Update screen to check for new
signatures at myZyxel. You can schedule or immediately download signatures.

Apply

Click Apply to save your changes.

Reset

Click Reset to refurn the screen to its last-saved settings.

29.3.1 Botnet Filter White List Screen

Use this screen to create white list entries. The Zyxel Device will allow the incoming packets from the
listed IPv4 addresses and URLs.

Figure 378 Configuratfion > Security Service > Reputation Filter > Botneft Filter > White List

White List
@ Add

Page

Botnet Filter

_Gonerc [ITEIENN ookt

Show |50 |» items No data to display

| apply ]| Reset |

The following table describes the labels in this screen.

Table 224 Configuration > Security Service > Reputation Filter > Botnef Filter > White List

LABEL DESCRIPTION

White List

Add Click this to create a new enfry.

Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this to delete it.

# This is the entry’s index number in the list.

White List This field displays the URL of this entry.

Apply Click Apply to save your changes back to the Zyxel Device.
Reset Click Reset fo refurn the screen to its last-saved settings.
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29.3.2 Botnet Filter Black List Screen

Use this screen to create black list entries. The Zyxel Device will block the incoming packets from the
listed IPv4 addresses and URLs.

Figure 379 Configuration > Security Service > Reputation Filter > Botnet Filter > Black List

General White List m

Black List

@ Add

Page of 0 Show |50 |+ | itermns No data to display

__pply ] Reset |

The following table describes the labels in this screen.

Table 225 Configuration > Security Service > Reputation Filter > Botnet Filter > Black List

LABEL DESCRIPTION

Black List

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this to delete it.

# This is the entry’s index number in the list.

Black List This field displays the URL of this entry.

Apply Click Apply to save your changes back to the Zyxel Device.
Reset Click Reset to return the screen to its last-saved settings.
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CHAPTER 30
IDP

30.1 Overview

This chapter introduces packet inspection IDP (Intrusion, Detection and Prevention), custom signatures,
and updating signatures. An IDP system can detect malicious or suspicious packets and respond
instantaneously. IDP on the Zyxel Device protects against network-based intrusions.

30.1.1 What You Can Do in this Chapter

¢ Use the Security Service > IDP screen (Section 30.2 on page 566) to view registration and signature
information.

¢ Use the Security Service > IDP > Custom Signature > Add screens (Section 30.3 on page 572) to create
a new custom signature, edit an existing signature, delete existing signatures or save signatures to
your computer.

30.1.2 What You Need To Know

Packet Inspection Signatures

A signature is a pattern of malicious or suspicious packet activity. You can specify an action to be taken
if the system matches a stfream of data to a malicious signature. You can change the action in the
profile screens. Packet inspection examine OSI (Open System Interconnection) layer-4 to layer-7 packet
contents for malicious data. Generally, packet inspection signatures are created for known attacks
while anomaly detection looks for abnormal behavior.

Applying Your IDP Configuration

Changes to the Zyxel Device's IDP settings affect new sessions, but not the sessions that already existed
before you applied the new settings.

30.1.3 Before You Begin

¢ Register for a trial IDP subscription in the Registration screen. This gives you access to free signature
updates. This is important as new signatures are created as new atftacks evolve. When the trial
subscription expires, purchase and enter a license key using the same screens to continue the
subscription.

30.2 The IDP Screen

An IDP profile is a set of packet inspection signatures.
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Click Configuration > Security Service > IDP to open this screen. Use this screen to view registration and
signature information.

Note: You must register in order to update packet inspection signatures. See the Registration
screens.

If you try to enable IDP when the IDP service has not yet been registered, a warning screen displays and
IDP is not enabled.

Click the IDP icon for more information on the Zyxel Device's security features.

Figure 380 Configuration > Security Service > IDP

=] Hide Advanced Settings
General Settings @ oF
71 Enable
Query Signatures
Name: (Optional) m
Signature ID: {Opftional)
-[<] Advance
[7] Search all custom signatures
Any - Any - \O‘SN - - Any - Any -
Very-Low Misc Android MISC nong
Low Web-Atftacks . . EXPLOIT drop
. Windows-Mobile .
Medium Buffer-Overflow Symbian WEB reject-sender
don . BackdoorTian | other - (WESCUENT . |refectreceiver
Activation: any A Log: any N
Query Result
- [<] Advance
Custom Signature Rules
@ Add |
1 9916408 Cs
Page |1 of 1 Show |50 |» | items Displaying 1-1of 1
Customer Signature Rule Importing
File Path: Select an file ®
Signature Information
Current Version: 1.0.0.000
Signature Number: 3335
Released Date: 2018-01-01 05:10:00 (UTC+00:00)
Update Signatures
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The following table describes the fields in this screen.

Table 226 Configuration > Security Service > IDP

LABEL

DESCRIPTION

General Settings

Enable

Select this check box to activate the IDP feature which detects and prevents malicious
or suspicious packets and responds instantaneously.

Query Signatures

Name

Type the name or part of the name of the signature(s) you want fo find.

Signature ID

Type the ID or part of the ID of the signature(s) you want to find.

Search all custom

Select this check box to include signatfures you created or imported in the Custom

signatures Signatures screen in the search. You can search for specific signatures by name or ID. If
the name and ID fields are left blank, then all signatures are searched according fo the
criteria you select.

Severity Search for signatures by severity level(s). Hold down the [Ctrl] key if you want to make

multiple selections.

These are the severities as defined in the Zyxel Device. The number in brackets is the
number you use if using commands.

Severe (5): These denote attacks that fry to run arbitrary code or gain system privileges.

High (4): These denote known serious vulnerabilities or attacks that are probably not
false alarms.

Medium (3): These denote medium threats, access control attacks or attacks that could
be false alarms.

Low (2): These denote mild threats or attacks that could be false alarms.

Very-Low (1): These denote possible afttacks caused by fraffic such as Ping, trace route,
ICMP queries etc.

Classification Type

Search for signatures by attack type(s) (see Table 227 on page 569). Attack types are
known as policy types in the group view screen. Hold down the [Cirl] key if you want to
make multiple selections.

Platform Search for signatures created to prevent infrusions targeting specific operating
system(s). Hold down the [C1rl] key if you want to make multiple selections.

Service Search for signatures by IDP service group(s). See Table 227 on page 569 for group
details. Hold down the [Ctrl] key if you want fo make mulfiple selections.

Action Search for signatures by the response the Zyxel Device takes when a packet matches a
signature.Hold down the [Cirl] key if you want fo make multiple selections.

Activation Search for activated and/or inactivated signatures here.

Log Search for signatures by log option here.

Query Result

The results are displayed in a table showing the SID, Name, Severity, Classification Type,
Platform, Service, Log, and Action criteria as selected in the search. Click the SID column
header to sort search results by signature ID.

Custom Signature Rules

Use this part of the screen to create, edit, delete or export (save to your computer)
custom signatures.

Add Click this to create a new enfry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Export To save an enfry or enfries as a file on your computer, select them and click Export. Click

Save in the file download dialog box and then select a location and name for the file.

Custom signatures must end with the ‘rules’ file name extension, for example,
MySig.rules.
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Table 226 Configuratfion > Security Service > IDP (continued)

LABEL DESCRIPTION

# This is the entry’s index number in the list.

SID SID is the signature ID that uniquely identifies a signature. Click the SID header to sort
signatures in ascending or descending order. It is automatically created when you click
the Add icon to create a new signature. You can edit the ID, but it cannot already exist
and it must be in the 2000000 to 9999999 range.

Name This is the name of your custom signature. Duplicate names can exist, but it is advisable

fo use unique signature names that give some hint as to intent of the signature and the
type of afttack it is supposed to prevent.

Customer Signature Rule
Importing

Use this part of the screen to import custom signatures (previously saved to your
computer) to the Zyxel Device.

Note: The name of the complete custom signature file on the Zyxel Device is
‘custom.rules’. If you import a file named ‘custom.rules’, then all custom
signatures on the Zyxel Device are overwritten with the new file. If this is
not your intention, make sure that the files you import are not named
‘custom.rules’.

File Path

Type the file path and name of the custom signature file you want to import in the text
box (or click Browse to find it on your computer) and then click Importing to transfer the
file to the Zyxel Device.

New signatures then display in the Zyxel Device IDP > Custom Signatures screen.

Signature Information

The following fields display information on the current signature set that the Zyxel Device
is using.

Current Version

This field displays the IDP signature set version number. This number gets larger as the set
is enhanced.

Signature Number

This field displays the number of IDP signatures in this set. This number usually gets larger
as the setis enhanced. Older signatures and rules may be removed if they are no longer
applicable or have been supplanted by newer ones.

Released Date

This field displays the date and time the set was released.

Update Signatures

Click this link to go to the screen you can use to download signatures from the update
server.

Policy Types

This table describes Policy Types as categorized in the Zyxel Device.

Table 227 Policy Types

POLICY TYPE

DESCRIPTION

Access Control

Access confrol refers to procedures and controls that limit or detect access. Access
control attacks fry to bypass validation checks in order to access network resources such
as servers, directories, and files.

Any

Any attack includes all other kinds of attacks that are not specified in the policy such as
password, spoof, hijack, phishing, and close-in.

Backdoor/Trojan Horse

A backdoor (also called a trapdoor) is hidden software or a hardware mechanism that
can be triggered to gain access to a program, online service or an entire computer
system. A Trojan horse is a harmful program that is hidden inside apparently harmless
programs or data.

Although a virus, a worm and a Trojan are different types of aftacks, they can be
blended into one attack. For example, W32/Blaster and W32/Sasser are blended attacks
that feature a combination of a worm and a Trojan.
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Table 227 Policy Types (continued)

POLICY TYPE

DESCRIPTION

BotNet

A Botnet is a number of Internet computers that have been set up to forward
fransmissions including spam or viruses to other computers on the Internet though their
owners are unaware of it. It is also a collection of Internet-connected programs
communicating with other similar programs in order to perform tasks and participate in
distributed Denial-Of-Service attacks.

Buffer Overflow

A buffer overflow occurs when a program or process tries to store more data in a buffer
(temporary data storage area) than it was intended to hold. The excess information can
overflow info adjacent buffers, corrupting or overwriting the valid data held in them.

Infruders could run codes in the overflow buffer region to obtain control of the system,
install a backdoor or use the victim fo launch attacks on other devices.

DoS/DDoS

The goal of Denial of Service (DoS) aftacks is not to steal information, but fo disable a
device or network on the Internet.

A Distributed Denial of Service (DDoS) attack is one in which multiple compromised
systems attack a single target, thereby causing denial of service for users of the targeted
system.

Instant Messenger

IM (Instant Messenger) refers to chat applications. Chat is real-time, text-based
communication between two or more users via networks-connected computers. After
you enter a chat (or chat room), any room member can type a message that will
appear on the monitors of all the other participants.

Mail

A Mail or email bombing attack involves sending several thousand identical messages fo
an electronic mailbox in order to overflow it, making it unusable.

Misc

Miscellaneous attacks takes advantage of vulnerable computer networks and web
servers by forcing cache servers or web browsers into disclosing user-specific information
that might be sensitive and confidential. The most common type of Misc. attacks are
HTTP Response Smuggling, HTTP Response Splitting and JSON Hijacking.

P2P

Peer-to-peer (P2P) is where computing devices link directly to each other and can
directly initiate communication with each other; they do not need an intermediary. A
device can be both the client and the server. In the Zyxel Device, P2P refers to peer-to-
peer applications such as e-Mule, e-Donkey, BitTorrent, iMesh, etfc.

Scan

A scan describes the action of searching a network for an exposed service. An attack
may then occur once a vulnerability has been found. Scans occur on several network
levels.

A network scan occurs at layer-3. For example, an attacker looks for network devices
such as a router or server running in an IP network.

A scan on a protocol is commonly referred to as a layer-4 scan. For example, once an
attacker has found a live end system, he looks for open ports.

A scan on a service is commonly referred to a layer-7 scan. For example, once an
attacker has found an open port, say port 80 on a server, he determines that it is a HTTP
service run by some web server application. He then uses a web vulnerability scanner (for
example, Nikto) to look for documented vulnerabilities.

SPAM

Spam is unsolicited “junk” email sent to large numbers of people to promote products or
services.

Stream Media

A Stream Media aftack occurs when a malicious network node downloads an
overwhelming amount of media stream data that could potentially exhaust the entire
system. This method allows users to send small requests messages that result in the
streaming of large media objects, providing an opportunity for malicious users to exhaust
resources in the system with little effort expended on their part.

Tunnel

A Tunneling aftack involves sending IPvé traffic over IPv4, slipping viruses, worms and
spyware through the network using secret tunnels. This method infilfrates standard
security measures through IPvé tunnels, passing through IPv4 undetected. An external
signal then triggers the malware to spring to life and wreak havoc from inside the
network.
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Table 227 Policy Types (continued)

POLICY TYPE DESCRIPTION

Virus/Worm A computer virus is a small program designed to corrupt and/or alter the operation of
other legitimate programs. A worm is a program that is designed to copy itself from one
computer to another on a network. A worm's uncontrolled replication consumes system
resources, thus slowing or stopping other tasks.

Web Attack Web attacks refer to attacks on web servers such as IIS (Internet Information Services).

IDP Service Groups

An IDP service group is a setf of related packet inspection signatfures.

Table 228 IDP Service Groups

WEB_PHP WEB_MISC WEB_IIS WEB_FRONTPAGE
WEB_CGI WEB_ATTACKS TFTP TELNET

SQL SNMP SMTP RSERVICES

RPC POP3 POP2 p2pP

ORACLE NNTP NETBIOS MYSQL
MISC_EXPLOIT MISC_DDOS MISC_BACKDOOR MISC

IMAP IM ICMP FTP

FINGER DNS n/a

30.2.1 Query Example

This example shows a search with these criteria:

e Severity: Severe

» Classification Type: Misc

e Platform: Windows

* Service: Any

e Actions: Any
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Figure 381 Query Example Search

Query Signatures
Name: (Optional) m
Signature ID: [Opticnal)
2] Advance
Search all custem signatures
,H,”\: Low - Any Any Any
:er“,- ow Misc Windows none
o Web-Attacks Linux drop
Medium . .
N Buffer-Overflow FreeBSD reject-sender
High ~ . . : o
= Backdoor-Trojan  + Solaris - - reject-recelver o

Severe N P e S

Activation: cny — Log: any —

Query Result
1 ? 110001 ATTACK-110001 severs Misc Windows Fr... WEB log reject-r...
2 @ 110002 ATTACK-110002 severe Misc Windows MISC log rejectr...
3 9 110114 ATTACK-110114 severe Misc Windows Fr... MISC log reject-r...
4 @ 110170 ATTACK-110170 severe Misc Windows Li... FTP log reject-r...
5 e 110200 ATTACK-110200 severe Misc Windows MISC log reject-r...
3 e 110202 ATTACK-110202 severe Misc Windows Fr... DNS log reject-r...
7 ? 110204 ATTACK-110204 severe Misc Windows Fr... [MAP log reject-r...
8 ? 110217 ATTACK-110217 severe Misc Windows Fr... SCADA log reject-r.. h
»

30.3 IDP Custom Signatures

Create custom signatures for new attacks or attacks peculiar fo your network. Custom signatures can
also be saved to/from your computer so as to share with others.

You need some knowledge of packet headers and attack types to create your own custom signatures.

IP Packet Header
These are the fields in an Internet Protocol (IP) version 4 packet header.

Figure 382 [P v4 Packet Headers

0 4 8 16 18 3
Version IHL Type cof Service Tetal Length
Identification Flags Fragment Offset
Time To Live Protocol Header Checksum

Eource IP Address

Destination IP Address

Opticns Padding

ZyWALL ATP Series User’s Guide

572



Chapter 30 IDP

The header fields are discussed in the following table.

Table 229 |IP v4 Packet Headers

HEADER DESCRIPTION
Version The value 4 indicates IP version 4.
IHL IP Header Length is the number of 32 bit words forming the total length of the header

(usually five).

Type of Service

The Type of Service, (also known as Differentiated Services Code Point (DSCP)) is
usually set to 0, but may indicate particular quality of service needs from the network.

Total Length

This is the size of the datagram in bytes. It is the combined length of the header and
the data.

Identification This is a 16-bit number, which tfogether with the source address, uniquely identfifies this
packet. It is used during reassembly of fragmented datagrams.
Flags Flags are used to control whether routers are allowed fo fragment a packet and to

indicatfe the parts of a packet to the receiver.

Fragment Offset

This is a byte count from the start of the original sent packet.

Time To Live This is a counter that decrements every time it passes through a router. When it
reaches zero, the datagram is discarded. It is used to prevent accidental routing
loops.

Protocol The protocol indicates the type of transport packet being carried, for example, 1 =

ICMP; 2= IGMP; 6 = TCP; 17= UDP.

Header Checksum

This is used to detect processing errors infroduced into the packet inside a router or
bridge where the packet is not protected by a link layer cyclic redundancy check.
Packets with an invalid checksum are discarded by all nodes in an IP network.

Source IP Address

This is the IP address of the original sender of the packet.

Destination IP Address

This is the IP address of the final destination of the packet.

Options

IP options is a variable-length list of IP options for a datagram that define IP Security
Option, IP Stream Identifier, (security and handling restrictions for the military), Record
Route (have each router record its IP address), Loose Source Routing (specifies a list of
IP addresses that must be traversed by the datagram), Strict Source Routing (specifies
a list of IP addresses that must ONLY be traversed by the datagram), Timestamp (have
each router record its IP address and time), End of IP List and No IP Options.

Padding

Padding is used as a filler to ensure that the IP packet is a multiple of 32 bits.

Select Configuration > Security Service. The Custom Signature Rules section shows a summary of alll
custom signatures created. Click the SID or Name heading to sort. Click the Add icon to create a new
signature or click the Edit icon to edit an existing signature. You can also delete custom signatures here
or save them to your computer.

Note: The Zyxel Device checks all signafures and confinues searching even after a match is
found. If two or more rules have conflicting actions for the same packet, then the Zyxel
Device applies the more restrictive action (reject-both, reject-receiver or reject-sender,
drop, none in this order). If a packet matches a rule for reject-receiver and it also
matches a rule for reject-sender, then the Zyxel Device will reject-both.

30.3.1 Add / Edit Custom Signatures

Click the Add icon to create a new signature or click the Edit icon to edit an existing signature in the
screen as shown in Figure 380 on page 567.
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A packet must match all items you configure in this screen before it matches the signature. The more
specific your signature (including packet contents), then the fewer false positives the signature will
tfrigger.

Try to write signatures that target a vulnerability, for example a certain type of traffic on certain
operating systems, instead of a specific exploit.

Figure 383 Configuration > Security Service > IDP > Custom Signatures > Add/Edit

&) Add Custom Signature
Setup
Name: Cs
Signature ID: 2091435
Information
Severity: n
Platform: [ windows [T Linux [[] FreeBSD [ Solaris
[[] Other-Unix [[] Network-Device CIMAC [1ios
[C] Android [ windows-Mobile [C1Symbian [[] Others
Classification Type: Any N
Frequency
[ Threshold
Header Options -
Network Protocol: Pv4

[ Type of Service
[Clidentification

[C] Fragmentation
] Fragment Offset
[ Time fo Live
1P Options
[1same IP

Transport Protocol: cp >

Port Source Port: |0 (0:any) Destination Port: |0 (0:any)
[ Fow

[CIFags

[ sequence Number
[[1 Ack Number
[ Window Size

Payload Options
[[] Payload Size

@ Add

OK Cancel

ZyWALL ATP Series User’s Guide

574



Chapter 30 IDP

The following table describes the fields in this screen.

Table 230 Configuration > Security Service > IDP > Custom Signatures > Add/Edit

LABEL

DESCRIPTION

Name

Type the name of this custom signature. You may use 1-31 alphanumeric characters,
underscores(_), or dashes (-), but the first character cannot be a number. This value is
case-sensitive.

Duplicate names can exist but it is advisable to use unique signature names that give
some hint as to infent of the signature and the type of attack it is supposed to prevent.
Refer to (but do not copy) the packet inspection signature names for hints on creating a
naming convention.

Signature ID

A signature ID is automatically created when you click the Add icon to create a new
sighatfure. You can edit the ID to create a new one (in the 9000000 to 9999999 range),
but you cannot use one that already exists. You may want to do that if you want to order
custom signatures by SID.

Information

Use the following fields to set general information about the signature as denoted below.

Severity

The severity level denotes how serious the intrusion is. Categorize the seriousness of the
infrusion here.

Platform

Some intrusions target specific operating systems only. Select the operating systems that
the intrusion targets, that is, the operating systems you want to protect from this intrusion.
SGl refers to Silicon Graphics Incorporated, who manufactures multi-user Unix
workstations that run the IRIX operating system (SGI's version of UNIX). A router is an
example of a network device.

Classification Type

Categorize the attack type here. See Table 227 on page 569 as a reference.

Frequency Recurring packets of the same type may indicate an attack. Use the following field to
indicate how many packets per how many seconds constitute an intrusion
Threshold Select Threshold and then type how many packets (that meet the criteria in this
signature) per how many seconds constitute an intrusion.
Header Options

Network Protocol

Configure signatures for IP version 4.

Type Of Service

Type of service in an IP header is used to specify levels of speed and/or reliability. Some
intrusions use an invalid Type Of Service number. Select the check box, then select Equal
or Not-Equal and then type in a number.

Identification The identification field in a datagram uniquely identifies the datagram. If a datagram is
fragmented, it contains a value that identifies the datagram to which the fragment
belongs. Some infrusions use an invalid Identification number. Select the check box and
then type in the invalid number that the intrusion uses.

Fragmentation A fragmentation flag identifies whether the IP datagram should be fragmented, not

fragmented or is a reserved bit. Some intrusions can be identified by this flag. Select the
check box and then select the flag that the intrusion uses.

Fragment Offset

When an IP datagram is fragmented, it is reassembled at the final destination. The
fragmentation offset identifies where the fragment belongs in a set of fragments. Some
intrusions use an invalid Fragment Offset number. Select the check box, select Equal,
Smaller or Greater and then type in a number

Time to Live

Time to Live is a counter that decrements every time it passes through a router. When it
reaches zero, the datagram is discarded. Usually it's used to set an upper limit on the
number of routers a datagram can pass through. Some intrusions can be identified by
the number in this field. Select the check box, select Equal, Smaller or Greater and then
type in a number.
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Table 230 Configuration > Security Service > IDP > Custom Signatures > Add/Edit (continued)

LABEL

DESCRIPTION

IP Options

IP options is a variable-length list of IP options for a datagram that define IP Security
Option, IP Stream Identifier, (security and handling restrictions for the military), Record
Route (have each router record its IP address), Loose Source Routing (specifies a list of IP
addresses that must be traversed by the datagram), Strict Source Routing (specifies a list
of IP addresses that must ONLY be traversed by the datagram), Timestamp (have each
router record its IP address and time), End of IP List and No IP Options. IP Options can help
identify some intrusions. Select the check box, then select an item from the list box that
the infrusion uses

Same IP

Select the check box for the signature to check for packets that have the same source
and destination IP addresses.

Transport Protocol

The following fields vary depending on whether you choose TCP, UDP or ICMP.

Transport Protocol: TCP

Port

Select the check box and then enter the source and destination TCP port numbers that
will trigger this signature.

Flow

The selected keyword sets the criteria as to which traffic is matched. You can match
fraffic based on direction or whether the connection is established or not. You can also
specify whether you want to match signatures per packet or in a stream of packets.

Established: Match established connections.

Stateless: Match packets that are not part of an established connection.
To Client: Match packets that flow from server to client..

To Server: Match packets that flow from client to server.

From Client: Match packets that flow from client to server.

From Servers: Match packets that flow from server to client.

No Stream: Match packets that have not been reassembled by the stream engine. It will
not match packets that have been reassembled.

Only Stream: Match packets that have been reassembled.

Flags

Select what TCP flag bits the signature should check.

Sequence Number

Use this field to check for a specific TCP sequence number.

Ack Number

Use this field o check for a specific TCP acknowledgment number.

Window Size

Use this field to check for a specific TCP window size.

Transport Protocol: UDP

Port

Select the check box and then enter the source and destination UDP port numbers that
will trigger this signature.

Transport Protocol:
ICMP

Type Use this field to check for a specific ICMP type value.
Code Use this field to check for a specific ICMP code value.
D Use this field o check for a specific ICMP ID value. This is useful for covert channel

programs that use statfic ICMP fields when they communicate.

Sequence Number

Use this field fo check for a specific ICMP sequence number. This is useful for covert
channel programs that use static ICMP fields when they communicate.

Payload Options

The longer a payload option is, the more exact the match, the faster the signature
processing. Therefore, if possible, it isrecommended to have at least one payload option
in your signature.
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Table 230 Configuration > Security Service > IDP > Custom Signatures > Add/Edit (continued)

LABEL DESCRIPTION

Payload Size This field may be used to check for abnormally sized packets or for detecting buffer
overflows.

Select the check box, then select Equal, Smaller or Greater and then type the payload
size.
Stream rebuilt packets are not checked regardless of the size of the payload.

Add Click this to create a new enfry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

# This is the entry’s index number in the list.

Offset This field specifies where to start searching for a patftern within a packet. For example, an
offset of 5 would start looking for the specified pattern after the first five bytes of the
payload.

Content Type the content that the signature should search for in the packet payload.

Hexadecimal code entered between pipes is converted to ASCII. For example, you
could represent the ampersand as either & or | 26| (26 is the hexadecimal code for the
ampersand).

Case-insensitive

Select Yes if content casing does NOT matter.

Decode as URI

A Uniform Resource Identifier (URI) is a string of characters for identifying an abstract or
physical resource (RFC 2396). A resource can be anything that has identity, for example,
an electronic document, an image, a service (“today's weather report for Taiwan”), a
collection of other resources. An identifier is an object that can act as a reference to
something that has identity. Example URIs are:

ftp://ftp.is.co.za/rfc/rfc1808.1xt; fip scheme for File Transfer Protocol services

http://www.math.uio.no/fag/compression-fag/part1.html; http scheme for Hypertext
Transfer Protocol services

mailto:mduerst@ifi.unizh.ch; mailto scheme for electronic mail addresses
telnet://melvyl.ucop.edu/; telnet scheme for interactive services via the TELNET Protocol

Select Yes for the signature to search for normalized URI fields. This means that if you are
writing signatures that includes normalized content, such as %2 for directory fraversals,
these signatures will not be triggered because the content is normalized out of the URI
buffer.

For example, the URI:
/scripts/..%c0%af../winnt/system32/cmd.exe?/c+ver
will get normalized info:

/winnt/system32/cmd.exe?/c+ver

OK Click this button to save your changes to the Zyxel Device and return to the summary
screen.
Cancel Click this button to return to the summary screen without saving any changes.

30.3.2 Custom Signature Example

Before creating a custom signature, you must first clearly understand the vulnerability.
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30.3.2.1 Understand the Vulnerability

Check the Zyxel Device logs when the attack occurs. Use web sites such as Google or Security Focus to
get as much information about the attack as you can. The more specific your signature, the less chance
it will cause false positives.

As an example, say you want to check if your router is being overloaded with DNS queries so you create
a signature to detect DNS query traffic.

30.3.2.2 Analyze Packets

Use the packet capture screen and a packet analyzer (also known as a network or protocol analyzer)
such as Wireshark or Ethereal to investigate some more.

Figure 384 DNS Query Packet Details
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From the details about DNS query you see that the protocol is UDP and the port is 53. The type of DNS
packet is standard query and the Flag is 0x0100 with an offset of 2. Therefore enter |010]| as the first
pattern.

The final custom signature should look like as shown in the following figure.

Figure 385 Example Custom Signature

TOITOToTS T

Information
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Header Options -
Network Protocol: IPv4
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[[] Fragment Offset
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[ Port
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[[] Seguence Number
] Ack Number
[[] window Size

Payload Options
[[] Payload Size
© Add B Edit @ Remove
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1 2 010 no no

»
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30.3.3 Applying Custom Signatures

After you create your custom signature, it becomes available in an IDP profile (Configuration > Security
Service > IDP > Profile > Edit screen). Custom signatures have an SID from 9000000 to 9999999.
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Search for, then activate the signature, configure what action to take when a packet matches it and if
it should generate a log or alert in a profile. Then bind the profile to a zone.

30.3.4 Verifying Custom Signatures

Configure the signature to create a log when traffic matches the signature. (You may also want to
configure an alert if it is for a serious attack and needs immediate attention.) After you apply the
signature to a zone, you can see if it works by checking the logs (Monitor > Log).

The Priority column shows warn for signatures that are configured to generate alog only. It shows critical
for signatures that are configured to generate a log and alert. All IDP signatures come under the IDP
category. The Note column displays ACCESS FORWARD when no action is configured for the signature. It
displays ACCESS DENIED if you configure the signature action to drop the packet. The destination port is
the service port (53 for DNS in this case) that the attack tries to exploit.

Figure 386 Custom Signature Log

View Log View AP Log

M Show Filter

Logs
Category: DA ~

B9 Email Log Now | @ Refresh & Clear

13 2018-... info IDP IDP profile defauli_profile has been ... IDP

829 2018-... info IDP IDP profile defauli_profile has been ... IDP

830 2018-... info IDP IDP profile defauli_profile has been ... IDP
Page |1 of 1 Show (50 |» | items Displaying 1 -3 of 3

30.4 The White List Screen

Use this screen to view the IDP white list. The Zyxel Device will exclude the incoming packets of the listed
signature(s), and these packets won't be intercepted and will be passed through uninspected.

Click Configuration > Security Service > IDP > White List to display the following screen. Use Add to put a
new item in the list or Edit fo change an existing one or Remove to delete an existing entry.
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Figure 387 Configuration > Security Service > IDP > White List

White List

White List Setftings

© Add H Edit W Remove

Page of 0 Show |50 || items No data to display

The following table describes the fields in this screen.

Table 231 Configuration > Security Service > IDP > White List

LABEL DESCRIPTION

White List Settings

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this o delete it.

# This is the entry’s index number in the list.

Signature ID This field displays the signature ID of this entry.

Signature Name This field displays the signature name of this entry.

Apply Click Apply to save your changes back to the Zyxel Device.
Reset Click Reset fo refurn the screen to its last-saved settings.

30.5 IDP Technical Reference

This section contains some background information on IDP.

Host Intrusions

The goal of host-based intrusions is to infiltrate files on an individual computer or server in with the goal of
accessing confidential information or destroying information on a computer.

You must install a host IDP directly on the system being protected. It works closely with the operating
system, monitoring and intercepting system calls to the kernel or APIs in order to prevent attacks as well
as log them.

Disadvantages of host IDPs are that you have to install them on each device (that you want to protect)
in your network and due to the necessarily fight infegration with the host operating system, future
operating system upgrades could cause problems.
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Network Intrusions

Network-based intrusions have the goal of bringing down a network or networks by attacking
computer(s), switch(es), router(s) or modem(s). If a LAN switch is compromised for example, then the
whole LAN is compromised. Host-based intrusions may be used to cause network-based infrusions when
the goal of the host virus is fo propagate attacks on the network, or attack computer/server operating
system vulnerabilities with the goal of bringing down the computer/server. Typical “network-based
infrusions” are SQL slammer, Blaster, Nimda MyDoom etc.

Snort Signatures

You may want to refer fo open source Snort signatures when creating custom Zyxel Device ones. Most
Snort rules are written in a single line. Snort rules are divided into two logical sections, the rule header
and the rule options as shown in the following example:

alert tcp any any -> 192.168.1.0/24 111 (content:"|00 01 a5|”; msg:”“mountd access”;)

The text up to the first parenthesis is the rule header and the section enclosed in parenthesis contains the
rule options. The words before the colons in the rule options section are the option keywords.

The rule header contains the rule's:

e Action
e Protocol
¢ Source and destination IP addresses and netmasks

* Source and destination ports information.

The rule opftion section contains alert messages and information on which parts of the packet should be
inspected to determine if the rule action should be taken.

These are some equivalent Snort terms in the Zyxel Device.

Table 232 Zyxel Device - Snort Equivalent Terms

ZYXEL DEVICE TERM SNORT EQUIVALENT TERM
Type Of Service fos

Identification id

Fragmentation fragbits

Fragmentation Offset fragoffset

Time to Live al

IP Options ipopts

Same IP sameip

Transport Protocol

Transport Protocol: TCP

Port

(In Snort rule header)

Flow flow
Flags flags
Sequence Number seq
Ack Number ack
Window Size window
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Table 232 Zyxel Device - Snort Equivalent Terms (continued)

ZYXEL DEVICE TERM SNORT EQUIVALENT TERM
Transport Protocol: UDP (In Snort rule header)
Port (In Snort rule header)
Transport Protocol: ICMP
Type itype
Code icode
ID icmp_id
Sequence Number icmp_seq
Payload Options (Snort rule options)
Payload Size dsize
Offset (relative to start of payload) offset
Relative to end of last match distance
Content content
Case-insensitive nocase
Decode as URI uricontent

Note: Not all Snort functionality is supported in the Zyxel Device.
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Sandboxing

31.1 Overview

Zyxel cloud sandboxing is a security mechanism which provides a safe environment to separate running
programs from your network and host devices. Unknown or untrusted programs/codes are uploaded to
the Defend Center and executed within an isolated virtual machine (VM) to monitor and analyze the
zero-day malware and advanced persistent threats (APTs) that may evade the Zyxel Device's
detection, such as antfi-malware. Results of cloud sandboxing are sent from the server to the Zyxel
Device.

By default, the Zyxel Device sandbox forwards all unknown files and uploads a copy of the files for
inspection after checking the received files against its local cache. The scan result from the Defend
Center (DC) is added to the Zyxel Device cache and used for future inspection. When a file with
malicious or suspicious codes is detected, the Zyxel Device can take specific actions on the threats.

Note: The scan result will be removed from the Zyxel Device cache after the Zyxel Device
restarts.

Figure 388 General Zyxel Sandbox Inspection

Alternatively, you can select to hold and inspect the downloaded files for up to two seconds if the
downloaded files have never been inspected before.
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Figure 389 Advanced Zyxel Sandbox Inspection

31.1.1 What You Need to Know

The Zyxel Device may forward files with attachments before Sandbox has completed checking. If
Sandbox discovers a suspect file, please contact the receiver of the suspect file and advise him/her not
to open it. If he/she already opened it, then please urge him/her to run an up-to-date anfi-malware
scanner.

If the receiver of a suspect file cannot open a file, Sandbox may have already modified the file by
deleting the infected portion. Please check the logs and let the receiver know if this is so.

Sandbox can only check the types of files listed under File Submission Options in the Sandboxing screen.
If you disabled Scan and detect EICAR test virus in the Anti-Malware screen, then EICAR test files will be
sent fo Sandbox.

To use the sandbox, you need to register your Zyxel Device and activate the service license at myZyxel,

and then turn on the sandboxing function on the Zyxel Device. See Chapter 7 on page 186 for more
information about registration and service licenses.

31.2 Sandboxing Screen

Click Configuration > Security Service > Sandboxing fo display the configuration screen as shown next.

Use this screen to enable sandboxing and specify the actions the Zyxel Device takes when malicious or
suspicious files are detected.

Click the Sandboxing icon for more information on the Zyxel Device's security features.
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Figure 390 Configuration > Security Service > Sandboxing

Sandboxing

General

["]Enable Sandboxing

Action For Malicious File:  destroy v
Log For Malicious File: log v
Action For Suspicious File:  destroy b
Log For Suspicious File: log ~

Advanced Inspection
[[lInspect Selected Downloaded Files

The file types you select will be regarded as a possible threat. This feature inspects the files which are being downloaded
from the Internet and have never been inspected before. Safe files will be passed through affer inspection.

* Note:
Downloads may be inferrupted and need to be restaried.
File Submission Options

Archives|(.zip)
Executables

MS Office Documents
Macromedia Flash Data

ooty ] Reset |

The following table describes the labels in this screen.

Table 233 Configuration > Security Service > Sandboxing

¥ PDF -

-

Not Licensed. The configuration will be saved but will not take effect. W @

LABEL DESCRIPTION

General

Enable Sandboxing | Select this option fo turn on sandboxing on the Zyxel Device. Otherwise, deselect it.

Action For Malicious | Specify whether the Zyxel Device deletes (destroy) or forwards (allow) malicious files.

File Malicious files are files given a high score for malware characteristics by the Defend Center.

Log For Malicious File | These are the log options for malicious files:
no: Do not create a log when a malicious file is detected.

log: Create alog on the Zyxel Device when a malicious file is detected.

log alert: An alert is an emailed log for more serious events that may need more immediate

no: Do nof create a log when a suspicious file is detected.

log: Create alog on the Zyxel Device when a suspicious file is detected.

attention. Select this option to have the Zyxel Device send an alert when a suspicious
detected.

attention. Select this option to have the Zyxel Device send an alert when a malicious file is
detected.

Action For Suspicious | Specify whether the Zyxel Device deletes (destroy) or forwards (allow) suspicious files.

File Suspicious files are files given a medium score for malware characteristics by the Defend
Center.

Log For Suspicious These are the log options for suspicious files:

File

log alert: An alert is an emailed log for more serious events that may need more immediate
file is
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Table 233 Configuration > Security Service > Sandboxing (continued)

LABEL

DESCRIPTION

Advanced
Inspection

Inspect Selected
Downloaded Files

Select the check box to have the Zyxel Device hold the downloaded file for up to two

seconds if the downloaded file has never been inspected before. The Zyxel Device will wait
for the Defend Center’s result and forward the file in two seconds. Sandbox detection may
take longer than two seconds, so infected files could still possibly be forwarded to the user.

Note: The Zyxel Device only checks the file types you selected for sandbox
inspection.
The scan result will be removed from the Zyxel Device cache after the Zyxel
Device restarts.

File Submission
Options

Specify the type of files to be sent for sandbox inspection.

Terms of Use

Click this link to see what data Zyxel collects from you and how it is used.

Apply

Click Apply fo save your changes.

Reset

Click Reset to return the screen to its last-saved settings.
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Email Security

32.1 Overview

The email security feature can mark or discard spam (unsolicited commercial or junk email). Use the
white list to identify legitimate email. Use the black list to identify spam email. The Zyxel Device can also
check email against a DNS black list (DNSBL) of IP addresses of servers that are suspected of being used
by spammers.

32.1.1 What You Can Do in this Chapter

¢ Use the Email Security screens (Section 32.3 on page 590) to tfurn email security on or off and manage
email security policies. Also, you can enable and configure the mail scan functions and have the
Zyxel Device check email against DNS Black Lists.

* Use the Black/White List screens (Section 32.4 on page 593) to set up a black list fo identify spam and
a white list to identify legitimate email.

32.1.2 What You Need to Know

White List

Configure white list entries to identify legitimate email. The white list entries have the Zyxel Device classify
any email that is from a specified sender or uses a specified header field and header value as being
legitimate (see Email Headers for more on mail headers). The email security feature checks an email
against the white list entries before doing any other email security checking. If the email matches a
white list entry, the Zyxel Device classifies the email as legitimate and does not perform any more email
security checking on that individual email. A properly configured white list helps keep important email
from being incorrectly classified as spam. The white list can also increases the Zyxel Device's email
security speed and efficiency by not having the Zyxel Device perform the full email security checking
process on legitimate email.

Black List

Configure black list entries to identify spam. The black list enfries have the Zyxel Device classify any email
that is from or forwarded by a specified IP address or uses a specified header field and header value as
being spam. If an email does not match any of the white list entries, the Zyxel Device checks it against
the black list entries. The Zyxel Device classifies an email that matches a black list entry as spam and
immediately takes the configured action for dealing with spam. If an email matches a blacklist entry,
the Zyxel Device does not perform any more email security checking on that individual email. A properly
configured black list helps catch spam email and increases the Zyxel Device's email security speed and
efficiency.
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SMTP and POP3

Simple Mail Transfer Protocol (SMTP) is the Internet’s message transport standard. It controls the sending
of email messages between servers. Email clients (also called email applications) then use mail server
protocols such as POP (Post Office Protocol) or IMAP (Intfernet Message Access Protocol) fo retrieve
email. Email clients also generally use SMTP to send messages to a mail server. The older POP2 requires
SMTP for sending messages while the newer POP3 can be used with or without it. This is why many email
applications require you to specify both the SMTP server and the POP or IMAP server (even though they
may actually be the same server).

The Zyxel Device's email security feature checks SMTP (TCP port 25) and POP3 (TCP port 110) emails by
default. You can also specify custom SMTP and POP3 ports for the Zyxel Device to check.

Email Headers

Every email has a header and a body. The header is structured into fields and includes the addresses of
the recipient and sender, the subject, and other information about the email and its journey. The body is
the actual message text and any attachments. You can have the Zyxel Device check for specific
header fields with specific values.

Email programs usually only show you the To:, From:, Subject:, and Date: header fields but there are
others such as Received: and Content-Type:. To see all of an email's header, you can select an email in
your email program and look at its properties or details. For example, in Microsoft’s Outlook Express,
select a mail and click File > Properties > Details. This displays the email’s header. Click Message Source
to see the source for the entire mail including both the header and the body.

Email Header Buffer Size

The Zyxel Device has a 5 K buffer for an individual email header. If an email’'s header is longer than 5K,
the Zyxel Device only checks up to the first 5 K.

DNSBL
A DNS Black List (DNSBL) is a server that hosts a list of IP addresses known or suspected of having sent or
forwarded spam. A DNSBL is also known as a DNS spam blocking list. The Zyxel Device can check the

routing addresses of email against DNSBLs and classify an email as spam if it was sent or forwarded by a
computer with an IP address in the DNSBL.

Finding Out More

See Section 32.5 on page 595 for more background information on email security.

32.2 Before You Begin

* Before using the email security features (IP Reputation, Mail Content Analysis and Virus Outbreak
Detection) you must activate your email security Service license.

¢ Configure your zones before you configure email security.
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32.3 The Email Security Screen

Click Configuration > Security Service > Email Security to open the Email Security screen. Use this screen
to turn the email security feature on or off and manage email security policies. You can also select the

action the Zyxel Device takes when the mail sessions threshold is reached.

Click the Email Security icon for more information on the Zyxel Device's security features.

Figure 391 Configuration > Security Service > Email Security
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The following table describes the labels in this screen.

Table 234 Configuration > Security Service > Email Security

LABEL

DESCRIPTION

General Settings

Enable Select this check box to activate the settings in this section.
Check White Select this check box to check email against the white list. The Zyxel Device classifies email
List that matches a white list entry as legitimate (not spam).
Check Black Select this check box to check email against the black list. The Zyxel Device classifies email
List that matches a black list entry as spam.
Black List Spam | Enter a message or label (up to 15 ASCII characters) to add to the mail subject of emails that
Tag match the Zyxel Device's spam black list.
Check IP Select this to use IP reputation to identify Spam or Unwanted Bulk Email by the sender’s IP
RepUTOﬂOn address.
(SMTP Only)
Check Mail Select this to identify spam email by content, such as malicious content.
Content
Mail Content Enter a message or label (up to 15 ASCII characters) to add to the beginning of the mail
Spam Tag subject of emails that are determined to spam based on the mail content analysis.
This tag is only added if the email security policy is configured to forward spam mail with a
spam tag.
Check Virus Select this to scan emails for attached viruses.
Outbreak
Virus Outbreak | Enter a message or label (up to 15 ASCIl characters) to add to the beginning of the mail
Tag subject of emails that are determined to have an attached viruses.
This tag is only added if the email security policy is configured to forward spam mail with a
spam tag.
Check Mail Phishing is an act of fricking you into providing login or personal information with malicious
Phishing emails or website links.
Select this to identify emails sent from suspicious websites known for phishing.
Mail Phishing Enter a message or label (up to 15 ASCII characters) to add to the beginning of the mail
Tag subject of emails that have suspicious websites links.
This tag is only added if the email security action is configured to forward spam mail with a
spam tag.
Check DNSBL Select this check box to check email against the Zyxel Device's configured DNSBL domains.
The Zyxel Device classifies email that matches a DNS black list as spam.
DNSBL Spam Enter a message or label (up to 15 ASCII characters) to add to the beginning of the mail
Tag subject of emails that have a sender or relay IP address in the header that matches a black

list maintained by one of the DNSBL domains listed in the Zyxel Device.

This tag is only added if the email security policy is configured to forward spam mail with a
spam tag.

DNSBL Domain List

Add Click this fo create a new entry.

Edit Select an entry and click this to be able to modify it.

Remove Select an entry and click this to delete it.

Activate To turn on an enfry, select it and click Activate.

Inactivate To turn off an enftry, select it and click Inactivate.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the entry is
inactive.

# This is the entry’s index number in the list.
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Table 234 Configu

ration > Security Service > Email Security

LABEL

DESCRIPTION

DNSBL Domain

This is the name of a domain that maintains DNSBL servers. Enter the domain that is
maintaining a DNSBL.

Actions for Spam
Mail

Use this section to set how the Zyxel Device is to handle spam mail.

SMTP

Select how the Zyxel Device is fo handle spam SMTP mail.
Select drop to discard spam SMTP mail.
Select forward to allow spam SMTP mail to go through.

Select forward with tag to add a spam tag to an SMTP spam mail’s mail subject and send it
on to the destination.

POP3

Select how the Zyxel Device is to handle spam POP3 mail.
Select forward to allow spam POP3 mail to go through.

Select forward with tag fo add a spam tag to an POP3 spam mail’s mail subject and send it
on fo the destination.

Log

Select whether to have the ZyXEL device generate a log (log), log and alert (log alert) or
neither (no) by default when traffic matches a signature in this category.

Action taken when
mail sessions
threshold is
reached

An email session is when an email client and email server (or two email servers) connect
through the Zyxel Device. Select how to handle concurrent email sessions that exceed the
maximum number of concurrent email sessions that the email security feature can handle.
See the chapter of product specifications for the threshold.

Select Forward Session to have the Zyxel Device allow the excess email sessions without any
spam filtering.

Select Drop Session to have the Zyxel Device drop mail connections to stop the excess email
sessions. The email client or server will have to re-attempt to send or receive email later when
the number of email sessions is under the threshold.

Query Timeout Settin

as

SMTP

Select how the Zyxel Device is to handle SMTP mail query fimeout.
Select drop to discard SMTP mail.
Select forward to allow SMTP mail to go through.

Select forward with tag to add a tag to an SMTP query timeout mail's mail subject and send it
on to the destination.

POP3

Select how the Zyxel Device is to handle POP3 mail query fimeout.
Select forward to allow POP3 mail to go through.

Select forward with tag to add a tag to an POP3 query timeout mail’s mail subject and send it
on to the destination.

Timeout Value

Set how long the Zyxel Device waits for a reply from the mail scan server. If there is no reply
before this time period expires, the Zyxel Device takes the action defined in the relevant
Actions when Query Timeout field.

Timeout Tag

Enter a message or label (up to 15 ASCIl characters) to add to the mail subject of emails that
the Zyxel Device forwards if queries to the mail scan servers time out.

Timeout X-Header

Specify the name and value for the X-Header to be added when queries to the mail scan
servers time out.

Max. IPs Checking
Per Mail

Set the maximum number of sender and relay server IP addresses in the mail header to check

against the DNSBL domain servers.
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Table 234 Configuration > Security Service > Email Security

LABEL DESCRIPTION
IP Selection Per Select first N IPs fo have the Zyxel Device start checking from the first IP address in the mail
Mail header. This is the IP of the sender or the first server that forwarded the mail.

Select last N IPs to have the Zyxel Device start checking from the last IP address in the mail
header. This is the IP of the last server that forwarded the mail.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings.

32.4 The Black List / White List Screen

Click Configuration > Security Service > Email Security > Black /White List fo display the Black List / White
List screen.

Configure the black list to identify spam email. You can create black list entries based on the sender’s or
relay server's IP address or email address. You can also create entries that check for particular email
header fields with specific values or specific subject text. Click a column’s heading cell to sort the table
entries by that column’s criteria. Click the heading cell again to reverse the sort order.

Figure 392 Configuration > Security Service > Email Security > Black/White List

Black List White List

Rule Summary

@ Add

Page of 0 Show 50 |» | items No data to display

“opy | peser |

The following table describes the labels in this screen.

Table 235 Configuration > Security Service > Email Security > Black/White List

LABEL DESCRIPTION

Rule Summary

Add Click this to create a new enfry.

Edit Select an entry and click this o be able to modify it.

Remove Select an entry and click this to delete it.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an enfry, select it and click Inactivate.

Status The activate (light bulb) icon is lit when the entry is active and dimmed when the enftry is
inactive.

# This is the entry’s index number in the list.

Type This field displays whether the entry is based on the email’'s subject, source or relay IP
address, source email address, or header.
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Table 235 Configuration > Security Service > Email Security > Black/White List (continued)

LABEL DESCRIPTION

Content This field displays the subject content, source or relay IP address, source email address, or
header value for which the entry checks.

Apply Click Apply to save your changes back to the Zyxel Device.

Reset Click Reset to return the screen to its last-saved settings.

32.4.1 The Black or White List Add/Edit Screen

In the Black List or White List screen, click the Add icon or an Edit icon to display the following screen.

Use this screen to configure an email security black list entry to identify spam email. You can create
entries based on specific subject text, or the sender’s orrelay’s IP address or email address. You can also
create entries that check for particular header fields and values.

Figure 393 Configuration > Security Service > Email Security > Black/White List > Black List (or White List) >

Add
@ Add Rule 2]
V] Enable Rule
Type: Subject v
Mail Subject Keyword: (]

The following table describes the labels in this screen.

Table 236 Configuration > Security Service > Email Security > Black/White List > Black/White List > Add

LABEL DESCRIPTION

Enable Rule Select this to have the Zyxel Device use this entry as part of the black or white list.
To actually use the entry, you must also turn on the use of the list in the corresponding list
screen, enable the email security feature in the email security general screen, and configure
an email security policy to use the list.

Type Use this field fo base the entry on the email’s subject, source or relay IP address, source email

address, or header.
Select Subject to have the Zyxel Device check email for specific content in the subject line.

Select IP Address to have the Zyxel Device check email for a specific source or relay IP
address.

Select IPv6 Address to have the Zyxel Device check email for a specific source or relay IPvé
address.

Select E-Mail Address to have the Zyxel Device check email for a specific source email
address or domain name.

Select Mail Header to have the Zyxel Device check email for specific header fields and
values. Configure black list header entries to check for email from bulk mail programs or with
content commonly used in spam. Configure white list header entries to allow certain header
values that identify the email as being from a trusted source.
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Table 236 Configuration > Security Service > Email Security > Black/White List > Black/White List > Add

LABEL DESCRIPTION
Mail Subject This field displays when you select the Subject type. Enter up to 63 ASCIl characters of text to
Keyword check for in email headers. Spaces are not allowed, although you could substitute a

question mark (2). See Section 32.4.2 on page 595 for more details.

Sender or Mail Relay
IP Address

This field displays when you select the IP Address type. Enter an IP address in dotted decimal
notation.

Sender or Mail Relay

This field displays when you select the IPv6 Address type. Enter an IPvé address with prefix.

IPv6 Address

Netmask This field displays when you select the IP type. Enfer the subnet mask here, if applicable.
Sender E-Mail This field displays when you select the E-Mail type. Enter a keyword (up fo 63 ASCII
Address characters). See Section 32.4.2 on page 595 for more details.

Mail Header Field
Name

This field displays when you select the Mail Header type.

Type the name part of an email header (the part that comes before the colon). Use up to 63
ASCIl characters.

For example, if you want the entry to check the “Received:” header for a specific mail
server's domain, enter “Received” here.

Field Value This field displays when you select the Mail Header type.

Keyword .
Type the value part of an email header (the part that comes after the colon). Use up to 63
ASCIl characters.
For example, if you want the entry to check the “Received:” header for a specific mail
server's domain, enter the mail server's domain here.
See Section 32.4.2 on page 595 for more details.

OK Click OK to save your changes.

Cancel Click Cancel to exit this screen without saving your changes.

32.4.2 Regular Expressions in Black or White List Entries

The following applies for a black or white list entry based on an email subject, email address, or email

header value.

* Use a question mark (2) to let a single character vary. For example, use “a2c” (without the quotation
marks) to specify abc, acc and so on.

¢ You can also use a wildcard (*). For example, if you configure *def.com, any email address that ends
in def.com matches. So “mail.def.com” matches.

* The wildcard can be anywhere in the text string and you can use more than one wildcard. You
cannot use two wildcards side by side, there must be other characters between them.

¢ The Zyxel Device checks the first header with the name you specified in the entry. So if the email has
more than one "Received” header, the Zyxel Device checks the first one.

32.5 Email Security Technical Reference

Here is more detailed email security information.
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DNSBL

The Zyxel Device checks only public sender and relay IP addresses, it does not check private IP
addresses.

The Zyxel Device sends a separate query (DNS lookup) for each sender or relay IP address in the
email's header to each of the Zyxel Device's DNSBL domains at the same time.

The DNSBL servers send replies as to whether or not each IP address matches an entry in their list. Each
IP address has a separate reply.

As long as the replies are indicating the IP addresses do not match entries on the DNSBL lists, the Zyxel
Device waits until it receives at least one reply for each IP address.

If the Zyxel Device receives a DNSBL reply that one of the IP addresses is in the DNSBL list, the Zyxel
Device immediately classifies the email as spam and takes the email security policy’s configured
action for spam. The Zyxel Device does not wait for any more DNSBL replies.

If the Zyxel Device receives at least one non-spam reply for each of an email’s routing IP addresses,
the Zyxel Device immediately classifies the email as legitimate and forwards it.

Any further DNSBL replies that come after the Zyxel Device classifies an email as spam or legitimate
have no effect.

The Zyxel Device records DNSBL responses for IP addresses in a cache for up to 72 hours. The Zyxel
Device checks an email’'s sender and relay IP addresses against the cache first and only sends DNSBL
queries for IP addresses that are not in the cache.

Here is an example of an email classified as spam based on DNSBL replies.

Figure 394 DNSBL Spam Detection Example

~| DNSBL A
IPs: a.a.a.a .
b.b.b.b
[ 11 :
~| DNSBL B
4
~| DNSBLC

3

The Zyxel Device receives an email that was sent from IP address a.a.a.a and relayed by an email server

at IP address b.b.b.b. The Zyxel Device sends a separate query to each of its DNSBL domains for IP
address a.a.a.a. The Zyxel Device sends another separate query to each of its DNSBL domains for IP
address b.b.b.b.

DNSBL A replies that IP address a.a.a.a does not match any entries in ifs list (not spam).
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DNSBL C replies that IP address b.b.b.b matches an entry in its list.

The Zyxel Device immediately classifies the email as spam and takes the action for spam that you
defined in the email security policy. In this example it was an SMTP mail and the defined action was o
drop the mail. The Zyxel Device does not wait for any more DNSBL replies.

Here is an example of an email classified as legitimate based on DNSBL replies.

Figure 395 DNSBL Legitimate Email Detection Example

= DNSBLA
IPs: c.c.c.c .
d.d.d.d -
"~ —— 1l :
= DNSBLB
-
4
* DNSBLC

The Zyxel Device receives an email that was sent from IP address c.c.c.c and relayed by an email server
at IP address d.d.d.d. The Zyxel Device sends a separate query to each of its DNSBL domains for IP
address c.c.c.c. The Zyxel Device sends another separate query to each of its DNSBL domains for IP
address d.d.d.d.

DNSBL B replies that IP address d.d.d.d does not match any entries in its list (not spam).

DNSBL C replies that IP address c.c.c.c does not match any entries in ifs list (not spam).

Now that the Zyxel Device has received at least one non-spam reply for each of the email’s routfing IP
addresses, the Zyxel Device immediately classifies the email as legitimate and forwards it. The Zyxel

Device does not wait for any more DNSBL replies.

If the Zyxel Device receives conflicting DNSBL replies for an email routing IP address, the Zyxel Device
classifies the email as spam. Here is an example.
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Figure 396 Conflicting DNSBL Replies Example

~| DNSBLA

IPs: a.b.c.d ]

W.X.Y.Z

" I aved? = osos

9 -

W.X.y.Z. > -

4 - a.b.c.d Spam! 3

® DNSBLC

The Zyxel Device receives an email that was sent from IP address a.b.c.d and relayed by an email server
at IP address w.x.y.z. The Zyxel Device sends a separate query to each of its DNSBL domains for IP
address a.b.c.d. The Zyxel Device sends another separate query to each of its DNSBL domains for IP
address w.x.y.z.

DNSBL A replies that IP address a.b.c.d does not match any entries in its list (not spam).

While waiting for a DNSBL reply about IP address w.x.y.z, the Zyxel Device receives a reply from DNSBL B
saying IP address a.b.c.d is in its list.

The Zyxel Device immediately classifies the email as spam and takes the action for spam that you
defined in the email security policy. In this example it was an SMTP mail and the defined action was to
drop the mail. The Zyxel Device does not wait for any more DNSBL replies.
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SSL Inspection

33.1 Overview

Secure Socket Layer (SSL) traffic, such as hitps://www.google.com/HTTPS, FTPs, POP3s, SMTPs, efc. is
encrypted, and cannot be inspected using Security Service profiles such as App Patrol, Content Filter,
Intrusion, Detection and Prevention (IDP), or Anti-Malware. The Zyxel Device uses SSL Inspection to
decrypt SSL traffic, sends it to the Security Service engines for inspection, then encrypts traffic that
passes inspection and forwards it to the destination server, such as Google.

An example process is shown in the following figure. User U sends a HTTPS request (SSL) fo destination
server D, via the Zyxel Device, Z. The traffic matches an SSL Inspection profile in a security policy, so the
Zyxel Device decrypts the fraffic using SSL Inspection. The decrypted traffic is then inspected by the
Security Service profiles in the same security profile that matched the SSL Inspection profile. If all is OK,
then the Zyxel Device re-encrypts the traffic using SSL Inspection and forwards it to the destination server
D. SSL traffic could be in the opposite direction for other examples.

Figure 397 SSL Inspection Overview

D
U
Vi -
— W 11—
_— -
HTTPS SSL — Security Service — SS|

Inspection AP Inspection

Decrypt CF Encrypt

IDP

Anfi-Malware

Note: Email security cannot be applied to traffic decrypted by SSL Inspection.

33.1.1 What You Can Do in this Chapter

* Use the Security Service > SSL Inspection > Profile screen (Section 33.2 on page 600) fo view SSL
Inspection profiles. Click the Add or Edit icon in this screen to configure the CA certificate, action and
log in an SSL Inspection profile.

* Use the Security Service > SSL Inspection > Exclude List screens (Section 33.3 on page 405) fo create a
whitelist of destination servers to which fraffic is passed through uninspected.

33.1.2 What You Need To Know

» Supported Cipher Suite
* DES (Data Encryption Standard)
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» 3DES

e AES (Advanced Encryption Standard)

e SSLv3/TLS1.0 (Transport Layer Security) Support

e SSLv3/TLS1.0is currently supported with option to pass or block SSLv2 traffic

¢ Traffic using TLS1.1 (Transport Layer Security) or TLS1.2 is downgraded to TLS1.0 for SSL Inspection

¢ No Compression Support Now

* No Client Authenticatfion Request Support Now

* Finding Out More

¢ See Configuration > Object > Certificate > My Certificates for information on creating cerfificates

on the Zyxel Device.

* See Monitor > Security Statistics > SSL Inspection to get usage data and easily add a destination

server to the whitelist of exclusion servers.

¢ See Configuration > Security Policy > Policy Control > Policy to bind an SSL Inspection profile to a

fraffic flow(s).

33.1.3 Before You Begin

* If you don't want fo use the default Zyxel Device certificate, then create a new certificate in Object >

Certificate > My Certificates.

¢ Decide what destination servers to which traffic is sent directly without inspection. This may be a
matter of privacy and legality regarding inspecting an individual’'s encrypted session, such as

financial websites. This may vary by locale.

33.2 The SSL Inspection Profile Screen

An SSL Inspection profile is a template with pre-configured certfificate, action and log.

Click Configuration > Security Service > SSL Inspection > Profile fo open this screen.

Figure 398 Configuration > Security Service > SSL Inspection > Profile

Profile Management

© Add

1TSSk
Page |1

Profile Exclude List Cerlificate Update

fest default 0

Show |50 |~ | items

S

Displaying 1-1 of 1

The following table describes the fields in this screen.

Table 237 Configuratfion > Security Service > SSL Inspection > Profile

LABEL DESCRIPTION
Profile Management
Add Click Add to create a new profile.
Edit Select an entry and click this to be able to modify it.
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Table 237 Configuration > Security Service > SSL Inspection > Profile (continued)

LABEL DESCRIPTION
Remove Select an entry and click this o delete it.
References Select an entry and click References to open a screen that shows which setftings use the
enftry. Click Refresh to update information on this screen.
# This is the entry’s index number in the list.
Name This displays the name of the profile.
Description This displays the description of the profile.
CA Certificate This displays the CA certificate being used in this profile.
Reference This displays the number of times an object reference is used in a profile.
Action Click this icon to apply the entry to a security policy.
Go to the Configuration > Security Policy > Policy Control screen to check the result.

33.2.1 Apply to a Security Policy

Click the icon in the Action field to apply the entry to a security policy.

Go to the Configuration > Security Policy > Policy Control screen to check the result.
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Figure 399 Configuratfion > Security Service > SSL Inspection > Action
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The following table describes the labels in this screen.

Table 238 Configuration > Security Service > SSL Inspection > Action

LABEL

DESCRIPTION

Show Filter/Hide
Filter

Click Show Filter to display IPv4 and IPvé (if enabled) security policy search filters.

IPv4 / IPvé Use IPv4 / IPvé6 search filters to find specific IPv4 and IPvé (if enabled) security policies based on
Configuration direction, application, user, source, destination and/or schedule.
From / To Select a zone to view all security policies from a particular zone and/or to a particular zone.

any means all zones.
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Table 238 Configuration > Security Service > SSL Inspection > Action

LABEL DESCRIPTION
IPv4 / IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé source
Source address object used.
* AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPvé address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
IPv4 /IPvé Type an IPv4 or IPvé IP address to view all security policies based on the IPv4 / IPvé destination
Destination | address object used.
¢ AnIPv4IP address is written as four integer blocks separated by periods. This is an example
IPv4 address: 172.16.6.7.
* An 128-bit IPv6 address is written as eight 16-bit hexadecimal blocks separated by colons
(:). This is an example IPvé address: 2001:0db8:1a2b:0015:0000:0000:1a2f:0000.
Service View all security policies based the service object used.
User View all security policies based on user or user group object used.
Schedule View all security policies based on the schedule object used.

Priority This is the position of your Security Policy in the global policy list (including all through-Zyxel
Device and to-Zyxel Device policies). The ordering of your policies is important as policies are
applied in sequence. Default displays for the default Security Policy behavior that the Zyxel
Device performs on traffic that does not match any other Security Policy.

Status This icon is lit when the entry is active and dimmed when the enfry is inactive.

Name This is the name of the Security policy.

From / To This is the direction of travel of packets. Select from which zone the packets come and to

which zone they go.

Security Policies are grouped based on the direction of travel of packets to which they apply.
For example, from LAN to LAN means packets fraveling from a computer or subnet on the LAN
to either another computer or subnet on the LAN.

From any displays all the Security Policies for traffic going to the selected To Zone.
To any displays all the Security Policies for traffic coming from the selected From Zone.
From any to any displays all of the Security Policies.

To ZyWALL policies are for traffic that is destined for the Zyxel Device and control which
computers can manage the Zyxel Device.

IPv4 / IPvé Source

This displays the IPv4 / IPvé source address object, including geographic address and FQDN
(group) objects, to which this Security Policy applies.

IPv4 / IPvé This displays the IPv4 / IPvé destination address object, including geographic address and
Destination FQDN (group) objects, to which this Security Policy applies.
Service This displays the service object to which this Security Policy applies.

User This is the user name or user group name to which this Security Policy applies.

Schedule This field tells you the schedule object that the policy uses. none means the policy is active at all
fimes if enabled.

Action This field displays whether the Security Policy silently discards packets without notification
(deny), permits the passage of packets (allow) or drops packets with notification (reject)

Log Select whether to have the Zyxel Device generate a log (log), log and alert (log alert) or not
(no) when the policy is matched to the criteria listed above.

Profile This field shows you which Security Service profiles (application patrol, content filter, IDP, anti-
malware, email security) apply to this Security policy. Click an applied Security Service profile
icon to edit the profile directly.

oK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving.
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33.2.2 Add / Edit SSL Inspection Profiles

Click Configuration > Security Service > SSL Inspection > Profile > Add to create a new profile or select
an existing profile and click Edit to change its settings.

Figure 400 Configuration > Security Service > SSL Inspection > Profile > Add / Edit

© Add rvle X
General Seftings
Name: [ e
Description:
CA Certificate: default ¥
SSL/TLS version supported minimum: 5513 A Log: no >
Action for connection with unsupported suit: pass > Log: no 5
Action for connection with unfrusted cert chain: pass 7 Log: log e

The following table describes the fields in this screen.

Table 239 Configuration > Security Service > SSL Inspection > Profile > Add / Edit

LABEL

DESCRIPTION

Name

This is the name of the profile. You may use 1-31 alphanumeric characters, underscores(_), or
dashes (-), but the first character cannot be a number. This value is case-sensitive. These are
valid, unique profile names:

* MyProfile

* mYProfile

* Mymyl12_3-4

These are invalid profile names:

e ImYProfile

* My Profile

* MyProfile?

¢ Whatalongprofilename 123456789012

Description

Enter additional information about this SSL Inspection entry. You can enter up to 60 characters
('0-9", "az", "A-Z", " and "),

CA Certificate

This contains the default cerfificate and the certificates created in Object > Certificate > My
Certificates. Choose the certfificate for this profile.

SSL/TLS version

SSL Inspection supports SSLv3, TLS1.0, TLS1.1, and TLS1.2 to use Secure Sockets Layer (SSL) or

supported Transport Layer Security (TLS) if you want encrypted traffic.
minimum
Log These are the log options for unsupported traffic that matches traffic bound to this policy:

¢ no: Select this option to have the Zyxel Device create no log for unsupported fraffic that
matches fraffic bound to this policy.

* log: Select this option o have the Zyxel Device create a log for unsupported traffic that
matches traffic bound to this policy

* log alert: An alert is an emailed log for more serious events that may need more immediate
attention. They also appear in red in the Monitor > Log screen. Select this option to have the
Zyxel Device send an alert for unsupported fraffic that matches traffic bound to this policy.
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Table 239 Configuration > Security Service > SSL Inspection > Profile > Add / Edit (continued)

LABEL

DESCRIPTION

Action for
Connection with
unsupported suit

SSL Inspection supports these cipher suites:

e DES
* 3DES
e AES

Select to pass or block unsupported traffic (such as other cipher suites, compressed traffic,
client authentication requests, and so on) that matches traffic bound to this policy here.

connection with
untrusted cert
chain

Log These are the log options for unsupported traffic that matches traffic bound to this policy:
¢ no: Select this option to have the Zyxel Device create no log for unsupported fraffic that
matches fraffic bound to this policy.
* log: Select this option to have the Zyxel Device create a log for unsupported traffic that
matches fraffic bound to this policy
* log alert: An alert is an emailed log for more serious events that may need more immediate
attention. They also appear in red in the Monitor > Log screen. Select this option to have the
Zyxel Device send an alert for unsupported fraffic that matches traffic bound to this policy.
Action for A cerfificate chain is a certification process that involves the following certfificates between the

SSL/TLS server and a client. A certificate chain will fail if one of the following certificates is not
correct.

* A certificate owned by a user
* The certificate signed by a certification authority
* Arooft certificate

Select to pass, inspect, or block an untrusted certification chain.

Log These are the log options for unsupported traffic that matches fraffic bound to this policy:
* no: Select this option to have the Zyxel Device create no log for unsupported traffic that
matches traffic bound to this policy.
* log: Select this opfion to have the Zyxel Device create a log for unsupported traffic that
matches traffic bound to this policy
¢ log alert: An alert is an emailed log for more serious events that may need more immediate
attention. They also appear in red in the Monitor > Log screen. Select this option to have the
Zyxel Device send an alert for unsupported traffic that matches traffic bound fo this policy.
OK Click OK to save your setftings to the Zyxel Device, and return fo the profile summary page.
Cancel Click Cancel to return to the profile summary page without saving any changes.

33.3 Exclude List Screen

There may be privacy and legality issues regarding inspecting a user's encrypted session. The legal issues
may vary by locale, so it's important to check with your legal department to make sure that it's OK to
intercept SSL fraffic from your Zyxel Device users.

To ensure individual privacy and meet legal requirements, you can configure an exclusion list to exclude
matching sessions to destination servers. This traffic is not infercepted and is passed through

uninspected.

Click Configuration > Security Service > SSL Inspection > Exclude List to display the following screen. Use
Add to put a new item in the list or Edit to change an existing one or Remove to delete an existing entry.
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Figure 401 Configuratfion > Security Service > SSL Inspection > Exclude List (> Add/Edit)
Profile Exclude List Certificate Update

General Settings
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Page |1

[l Enable Logs for Exclude List
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service-dispatcher.cloud.zyxel.com

of 1 Show |50 |» items Displaying 1-50f 5

ooy | reser |

The following table describes the fields in this screen.

Table 240 Configuration > Security Service > SSL Inspection > Exclude List

LABEL

DESCRIPTION

General Settings

Enable Logs for

Click this to create a log for traffic that bypasses SSL Inspection.

Exclude List
Exclude List Use this part of the screen fo create, edit, or delete items in the SSL Inspection exclusion list.
Settings
Add Click this to create a new enfry.
Edit Select an entry and click this to be able to modify it.
Remove Select an entry and click this to delete it.
# This is the entry’s index number in the list.
Exclude List of | SSL fraffic to a server fo be excluded from SSL Inspection is identified by its certificate. Identify
Certificate the certificate in one of the following ways:
Identity
* The Common Name (CN) of the certificate. The common name of the certificate can be
created in the Object > Certificate > My Certificates screen.
* Type an IPv4 or IPvé address. For example, type 192.168.1.35, or 2001:7300:3500::1
* Type an IPv4/IPvé in CIDR notation. For example, type 192.168.1.1/24, or 2001:7300:3500::1/
64
e Type an IPv4/IPvé address range. For example, type 192.168.1.1-192.168.1.35, or
2001:7300:3500::1-2001:7300:3500::35
¢ Type an email address. For example, type abc@zyxel.com.tw
¢ Type a DNS name or a common name (wildcard char: *', escape char: '\'). Use up to 127
case-insensitive characters (0-9a-zA-Z ~1@#$%A&*()-_=+[1{}\ | ;:',.<>/2). **' can be used as
a wildcard to match any string. Use ‘\*' to indicate a single wildcard character.
Alternatively, to automatically add an entry for existing SSL traffic to a destination server, go to
Monitor > Security Statistics > SSL Inspection > Certificate Cache List, select an item and then
click Add to Exclude List. The item will then appear here.
Apply Click Apply to save your settings to the Zyxel Device.
Reset Click Reset o return to the profile summary page without saving any changes.
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33.4 Certificate Update Screen

Use this screen to update the latest certificates of servers using SSL connections to the Zyxel Device
network. User U sends an SSL request to destination server D (1), via the Zyxel Device, Z. D replies (2); Z
intercepts the response from D and checks if the certificate has been previously signed. Z then replies to
D (3) and also to U (4). D’s latest certificate is stored at myZyxel (M) along with other server certificates

and can be downloaded to the Zyxel Device.

Figure 402 SSL Inspection Certificate Update Overview

M

— >
-

Click Configuration > Security Service > SSL Inspection > Certificate Update to display the following

screen.

Figure 403 Configuration > Security Service > SSL Inspection > Certificate Update

Certificate Information

Current Version: 1.0.001

Released Date: 20150422-10:45

Certificate Update

Synchronize the SSL-inspection Default Certificate to the latest version with online update server. (myZyXEL.com
activation required)

Update Now

[¥] Auto Update

ooy | heset |
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The following table describes the fields in this screen.

Table 241 Configuration > Security Service > SSL Inspection > Certificate Update

LABEL DESCRIPTION

Certificate Information

Current Version This displays the current certificate set version.
Released Date This field displays the date and time the current certificate set was released.
Certificate Update You should have Internet access and have activated SSL Inspection on the Zyxel
Device at myZyxel.
Update Now Click this button to download the latest certificate set (Windows, MAC OS X, and
Android) from the myZyxel and update it on the Zyxel Device.
Auto Update Select this to automatically have the Zyxel Device update the certificate set when a
new one becomes available on myZyxel.
Apply Click Apply to save your settings to the Zyxel Device.
Reset Click Reset to return to the profile summary page without saving any changes.

33.5 Install a CA Certificate in a Browser

Certificates used in SSL Inspection profiles should be installed in user web browsers. Do the following
steps to install a certificate in a computer with a Windows operating system (PC). First, save the
certificate to your computer.

1 Run the certificate manager using certmgr.msc.

Iﬁ certmgr - [Certificates - Current User\Trusted Root Certification Authariti

File Action View Help
=B olc=|HE

_?)J Certificates - Current User Issued To

| Persanal

T | Raot Certification A __oJA(I(ITrust External CA Root
o r.UStE( - _OOt et |ca&m Y alAmerica Online Root Certificati...
| Certificates

- R [l Baltimore CyberTrust Root

2 Go to Trusted Root Certification Authorities > Certificates.
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3

= certmgr - [Certificates - Current User\Trusted Root Certification Authorities\Certificates]

m@ﬂ

File  Action

L ol AN

WView Help

Blozl HB

_a}J Certificates - Current User

|| Persanal

4 [ TrustedReetle ifica&m Au
> [] Enterprise Trust

» || Intermediate Certification Au

> || Trusted Publishers

> || Untrusted Certificates

> [] Third-Party Root Certificatior
> ] Trusted People

> [] Active Directory User Object

> [] Other Peaple
> || Smart Card Trusted Roats

4 I 2

Issued To

ol AddTrust External CA Root

alAmerica Online Root Certificati...

5l Baltimore CyberTrust Root
ol Certum CA

=5l Class 3 Public Primary Certificat...
=5l Class 3 Public Primary Certificat...
5l Copyright () 1997 Microsoft C...
Rl DigiCert High Assurance EV Ro...

[ DST Root CA X3

rlEntrust.net Certification Author...
alEntrust.net Secure Server Certifi...
rlEquifax Secure Certificate Auth...

5l GeoTrust Global CA
5l GlobalSign Root CA

5l Go Daddy Class 2 Certification ...

LI T N I e I

4 | i

Issued By

AddTrust External CA Root
America Online Root Certification...
Baltimare CyberTrust Root

Certum CA

Class 3 Public Primary Certificatio...
Class 3 Public Primary Certificatio...
Copyright (¢} 1997 Microsoft Corp.
DigiCert High Assurance EV Root ...
DST Root CAX3

Entrust.net Certification Autharity...
Entrust.net Secure Server Certifica...
Equifax Secure Certificate Authaority
GeaTrust Global CA

GlobalSign Root CA

Go Daddy Class 2 Certification Au...

P T T S .S S R

3

11

From the main menu, select Action > All Tasks > Import and run the Certificate Import Wizard to install
the certificate on the PC.
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certmgr - [Certificates - Current User\Trusted Root Certification Authorities\Certificates] ll‘:' of x|

File | Action | View Help

@@= All Tasks 3 Impaort...
]
% Pty Certificate Import Wizard @
T 5 Export List...
4 u o
Help Welcome to the Certificate Import

Wizard

> [ Intermediate Certification Au
This wizard helps you copy certificates, certificate trust
lists, and certificate revocation lists From your disk o a
certificate store,

> [ Active Directory User Object
> || Trusted Publishers
- || Untrusted Certificates

- . I A certificate, which is issued by a certification autharity, is
> [] Third-Party Root Certificatior L\\’ a confirmation of your identity and conkains information
> [ Trusted Peaple used to prokect data or ko establish secure network.
. 7] Other People connections. A certificate store is the system area where

. certificates are kept,
- || Smart Card Trusted Roots

To continue, click Mext,

4 I 2

Add a certificate to a store

< Back Mexk = ] [ Cancel
ertificate Import Wizard @

File to Import

Specify the file you want o import,

File: name:

| Browse. ..

Mote: More than one certificate can be stored in a single file in the Following Formats:

Personal Information Exchange- PKCS #12 {.PFX,.P12)
Cryptographic Message Syntax Standard- PKCS #7 Certificates {.P7E)

Microsoft Serialized Certificate Store (55T}

Learn mare about certificate file Formats

< Back ][ Mexk = ][ Cancel

33.5.0.1 Firefox Browser

If you're using a Firefox browser, in addition to the above you need to do the following to import a
certificate into the browser.

Click Tools > Options > Advanced > Encryption > View Certificates, click Import and enter the filename
of the certificate you want to import. See the browser's help for further information.
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IP EXception

34.1 Overview

The Zyxel Device won't intercept nor inspect the incoming packets that match the rules in the IP
exception list for the anti-malware and/or IDP (Intrusion, Detection, and Prevention) features.

34.2 The IP Exception Screen

Use this screen to view the IP exception list for the anti-malware and IDP (Intrusion, Detection, and
Prevention) features. The Zyxel Device will exclude the incoming packets coming from the listed source
IP address(es) and destined for the listed destination IP address(es). These packets won't be intercepted
and will be passed through uninspected.

Click Configuration > Security Service > IP Exception to display the following screen. Use Add to put a
new entry in the list or Edit fo change an existing one or Remove fo delete an existing entry.

Figure 404 Configuration > Security Service > IP Exception

IPv4 Exception List Setftings

@ Add

1 test1234 any = YYYYY Anti-Malware, IDP No
Page 1 | of Show [50 |w /| items Displaying 1-1 of 1

IPvé Exception List Setftings

© Add
1 fest any a fest IDP Yes
2 it a fest any Anfi-Malware, IDP No
Page |1 of 1 Show |50 || items Displaying 1 -2 of 2

The following table describes the fields in this screen.

Table 242 Configuration > Security Service > IP Exception

LABEL DESCRIPTION

IPv4/IPvé Exception List Settings

Add Click this to create a new entry.

Edit Select an entry and click this to be able to modify it.
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Table 242 Configuration > Security Service > IP Exception (continued)

LABEL DESCRIPTION

Remove Select an entry and click this to delete it.

# This is the entry’s index number in the list.

Name This field displays the descriptive name of this entry.

IPv4/IPvé Source

This field displays the source IP address (or address object) of incoming traffic. It displays any if
there is no restriction on the source IP address.

IPv4/IPvé
Destination

This field displays the destination IP address (or address object) of incoming traffic. It displays
any if there is no restriction on the destination IP address.

Service to Bypass

This field displays to which feature (anti-malware and/or IDP) the entry applies.

Log

This field displays if the Zyxel Device will generate a log when the incoming traffic is in the
exception list.

34.2.1 The IP Exception Add/Edit Screen

Use this screen to add or edit entries of IPv4 or IPvé address in the IP exception list.

Click Configuration > Security Service > IP Exception > Add/Edit to display the following screen.

Figure 405 Configuration > Security Service > IP Exception > Add/Edit

Name:
Description:
Source:
Destination:

Log:

] IDP

# Edit Exception IP

% Create New Object¥

Service To Bypass

¥ Anti-Malware

alE
test1234
tsertsdetrsert
any v
YYYYY N
No v
OK Cancel

The following table describes the fields in this screen.

Table 243 Configuration > Security Service > IP Exception > Add/Edit

LABEL DESCRIPTION

Create New Use this to configure any new settings objects that you need to use in this screen.

Object

Name Enter a descriptive name of this entry.

Description Enter the description for this entry. You can use up to 60 printable ASCII characters.

Source Select any or an address object of the source IP address for this entry. Select any so there’s no

restriction on the source IP address.
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Table 243 Configuration > Security Service > IP Exception > Add/Edit (continued)

LABEL DESCRIPTION

Destination Select any or an address object of the destination IP address for this entry. Select any so
there’s no restriction on the destination IP address.

Log Select Yes to have the Zyxel Device generate a log when the incoming traffic is in the

exception list. Otherwise, select No.

Service to Bypass

Select Anti-Malware and/or IDP that the entry will apply to.

OK

Click OK to save your customized settings and exit this screen.

Cancel

Click Cancel to exit this screen without saving.
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35.1 Zones Overview

Set up zones to configure network security and network policies in the Zyxel Device. A zone is a group of
interfaces and/or VPN tunnels. The Zyxel Device uses zones instead of interfaces in many security and
policy settings, such as Secure Policies rules, Security Service, and remote management.

Zones cannot overlap. Each Ethernet inferface, VLAN interface, bridge interface, PPPoE/PPTP interface
and VPN tunnel can be assigned to at most one zone. Virtual interfaces are automatically assigned fo

the same zone as the interface on which they run.

Figure 406 Example: Zones

o

#

| Ethernet
LAN2 ;

(1
(1
(]
(]
1
1
"
[}
.,

Tt ——————

.
',

Use the Zone screens (see Section 35.8.2 on page 670) to manage the Zyxel Device's zones.

35.1.1 What You Need to Know

Zones effectively divide traffic into three types--intra-zone traffic, inter-zone traffic, and extra-zone
fraffic.
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Intra-zone Traffic

* Intra-zone fraffic is traffic between interfaces or VPN tunnels in the same zone. For example, in Figure
406 on page 614, traffic between VLAN 2 and the Ethernet is intra-zone fraffic.

Inter-zone Traffic

Inter-zone fraffic is traffic between interfaces or VPN tunnels in different zones. For example, in Figure 406
on page 614, traffic between VLAN 1 and the Internet is inter-zone traffic. This is the normal case when
zone-based security and policy settings apply.

Extra-zone Traffic

¢ Extra-zone traffic is traffic to or from any interface or VPN tunnel that is not assigned to a zone. For
example, in Figure 406 on page 614, traffic to or from computer C is extra-zone traffic.

* Some zone-based security and policy seftings may apply to extra-zone traffic, especially if you can
set the zone aftribute in them to Any or All. See the specific feature for more information.

35.1.2 The Zone Screen

The Zone screen provides a summary of all zones. In addition, this screen allows you to add, edit, and
remove zones. To access this screen, click Configuration > Object > Zone.

Figure 407 Configuration > Object > Zone

User Configuration

© Add
age of 0 Show |50 |v | items No data to display

System Default

T LANI lan 4
2 LAN2 lan2 4
3 DMI dmz 4
4 WAN wanl, wan2,wanl_ppp,wan2_ppp 5
5  OPT sip.sip_ppp 0
& 35L_WVPN 4
7 IPSec_WPN WIZ_VPN,WIZ_VPN_PROVISIONING, Test, WIZ_L2TP_VPN 4
8  TUNMEL 4
Page |1 of 1 Show |30 |» | items Displaying 1 -8 of 8
The following table describes the labels in this screen.
Table 244 Configuration > Object > Zone
LABEL DESCRIPTION
User Configuration / The Zyxel Device comes with pre-configured System Default zones that you cannot
System Default delete. You can create your own User Configuration zones
Add Click this to create a new, user-configured zone.
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Table 244 Configuration > Object > Zone (contfinued)

LABEL

DESCRIPTION

Edit

Double-click an entry or select it and click Edit to open a screen where you can modify
the entry’s seftings.

Remove

To remove a user-configured trunk, select it and click Remove. The Zyxel Device
confirms you want to remove it before doing so.

References

Select an entry and click References to open a screen that shows which settings use the
entry. Click Refresh to update information in this screen.

#

This field is a sequential value, and it is not associated with any interface.

Name

This field displays the name of the zone.

Member

This field displays the names of the interfaces that belong to each zone.

Reference

This field displays the number of times an Object Reference is used in a policy.

35.1.2.1 Zone Edit

The Zone Edit screen allows you to add or edit a zone. To access this screen, go to the Zone screen (see
Section 35.8.2 on page 670), and click the Add icon or an Edit icon.

Figure 408 Configuration > Object > Zone > Add

& Add Zone [
Group Members
Name: [ e
Member List
=== Interface ===
reserved
»

The following table describes the labels in this screen.

Table 245 Configuration > Object > Zone > Add/Edit

LABEL

DESCRIPTION

Name

For a system default zone, the name is read only.

For a user-configured zone, type the name used to refer to the zone. You may use 1-31
alphanumeric characters, underscores (_), or dashes (-), but the first character cannot be
a number. This value is case-sensitive.

Member List

Available lists the interfaces and VPN tunnels that do not belong to any zone. Select the
interfaces and VPN ftunnels that you want to add to the zone you are editing, and click the
right arrow button to add them.

Member lists the interfaces and VPN tunnels that belong to the zone. Select any interfaces
that you want to remove from the zone, and click the left arrow button to remove them.
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Table 245 Configuration > Object > Zone > Add/Edit (continued)

LABEL DESCRIPTION
OK Click OK to save your customized settings and exit this screen.
Cancel Click Cancel to exit this screen without saving.

35.2 User/Group Overview

This section describes how fo set up user accounts, user groups, and user settings for the Zyxel Device.
You can also set up rules that control when users have to log in fo the Zyxel Device before the Zyxel
Device routes traffic for them.

* The User screen (see Section 35.13.1 on page 713) provides a summary of all user accounts.

* The Group screen (see Section 35.2.3 on page 624) provides a summary of all user groups. In addition,
this screen allows you to add, edit, and remove user groups. User groups may consist of access users
and other user groups. You cannot put admin users in user groups.

* The Setting screen (see Section 35.2.4 on page 625) confrols default seftings, login setftings, lockout
settings, and other user settings for the Zyxel Device. You can also use this screen fo specify when
users must log in fo the Zyxel Device before it routes traffic for them.

¢ The MAC Address screen (see Section 35.2.5 on page 630) allows you to configure the MAC
addresses or OUI (Organizationally Unique Identifier) of wireless clients for MAC authentication using
the local user database. The OUl is the first three octets in a MAC address and uniquely identifies the
manufacturer of a network device.

35.2.1 What You Need To Know

User Account

A user account defines the privileges of a user logged into the Zyxel Device. User accounts are used in
security policies and application patrol, in addition o controlling access to configuration and services in
the Zyxel Device.

User Types

These are the types of user accounts the Zyxel Device uses.

Table 246 Types of User Accounts
TYPE ABILITIES LOGIN METHOD(S)

Admin Users

admin Change Zyxel Device configuration (web, CLI) WWW, TELNET, SSH, FTP, Console
limited-admin Look atf Zyxel Device configuration (web, CLI) WWW, TELNET, SSH, Console

Perform basic diagnostics (CLI)

Access Users

user Access network services WWW, TELNET, SSH

Browse user-mode commands (CLI)

guest Access network services WWW

ext-user External user account WWW
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Table 246 Types of User Accounts (continued)

TYPE ABILITIES LOGIN METHOD(S)
ext-group-user External group user account WWW
guest-manager Create dynamic guest accounts WWW
dynamic-guest Access network services Hotspot Portal

Note: The default admin account is always authenticated locally, regardless of the
authentication method setting. (See Chapter 35 on page 685 for more information
about authentication methods.)

Ext-User Accounts

Set up an ext-user account if the user is authenticated by an external server and you want to set up
specific policies for this user in the Zyxel Device. If you do not want to set up policies for this user, you do
not have to set up an ext-user account.

All ext-user users should be authenticated by an external server, such as AD, LDAP or RADIUS. If the Zyxel
Device tries to use the local database to authenticate an ext-user, the authentication attempt always
fails. (This is related to AAA servers and authentication methods, which are discussed in those chapters in
this guide.)

Note: If the Zyxel Device fries to authentficate an ext-user using the local database, the
afttempt always fails.

Once an ext-user user has been authenticated, the Zyxel Device tries fo get the user type (see Table 246
on page 617) from the external server. If the external server does not have the information, the Zyxel

Device sets the user type for this session to User.

For the rest of the user attributes, such as reauthentication time, the Zyxel Device checks the following
places, in order.

User account in the remote server.
User account (Ext-User) in the Zyxel Device.

Default user account for AD users (ad-users), LDAP users (Idap-users) or RADIUS users (radius-users) in
the Zyxel Device.

See Sefting up User Attributes in an External Server for a list of aftributes and how to set up the attributes
in an external server.

Ext-Group-User Accounts
Ext-Group-User accounts work are similar to ext-user accounts but allow you to group users by the value

of the group membership attribute configured for the AD or LDAP server. See Section 35.9.5.1 on page
679 for more on the group membership attribute.

Dynamic-Guest Accounts

Dynamic guest accounts are guest accounts, but are created dynamically and stored in the Zyxel
Device's local user database. A dynamic guest account has a dynamically-created user name and
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password. A dynamic guest account user can access the Zyxel Device's services only within a given
period of time and will become invalid after the expiration date/fime.

There are three types of dynamic guest accounts depending on how they are created or
authenticated: billing-users, ua-users and trial-users.

billing-users are guest account created with the guest manager account or an external printer and
paid by cash or created and paid via the on-line payment service. ua-users are users that log in from
the user agreement page. trial-users are free guest accounts that are created with the Free Time
function.

User Groups

User groups may consist of user accounts or other user groups. Use user groups when you want to create
the same rule for several user accounts, instead of creating separate rules for each one.

Note: You cannot put access users and admin users in the same user group.
Note: You cannot put the default admin account into any user group.

The sequence of members in a user group is not important.

User Awareness

By default, users do not have to log info the Zyxel Device to use the network services it provides. The
Zyxel Device automatically routes packets for everyone. If you want to restrict network services that
certain users can use via the Zyxel Device, you can require them to log in to the Zyxel Device first. The
Zyxel Device is then ‘aware’ of the user who is logged in and you can create ‘user-aware policies’ that
define what services they can use. See Section 35.2.6 on page 632 for a user-aware login example.

Finding Out More

e See Section 35.2.6 on page 632 for some information on users who use an external authentication
server in order to log in.

* The Zyxel Device supports TTLS using PAP so you can use the Zyxel Device's local user database to
authenticate users with WPA or WPA?2 instead of needing an external RADIUS server.

35.2.2 User/Group User Summary Screen

The User screen provides a summary of all user accounts. To access this screen, login to the Web
Configurator, and click Configuration > Object > User/Group.
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Figure 409 Configuration > Object > User/Group > User

User Group Setting MAC Address
Configuration
© Add
1 admin admin Administration account 0
2  |dap-users ext-user External LDAP Users 0
3 radivs-users ext-user External RADIUS Users 0
4  ad-users ext-user External AD Users 0
5 ua-users dynamic-guest User Agreement Users 0
Page |1 of 1 Show |50 |» | itemns Displaying 1 -5 of &
The following table describes the labels in this screen.
Table 247 Configuration > Object > User/Group > User
LABEL DESCRIPTION
Add Click this to create a new enfry.
Edit Double-click an entry or select it and click Edit to open a screen where you can modify the
entry’s seftings.
Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove
it before doing so.
References Select an entry and click References to open a screen that shows which settings use the entry.
# This field is a sequential value, and it is not associated with a specific user.
User Name This field displays the user name of each user.
User Type This field displays the types of user accounts the Zyxel Device uses:

admin - this user can look at and change the configuration of the Zyxel Device

limited-admin - this user can look at the configuration of the Zyxel Device but not to
change it

dynamic-guest - this user has access to the Zyxel Device's services but cannot look at the
configuration.

user - this user has access to the Zyxel Device's services and can also browse user-mode
commands (CLI).

guest - this user has access to the Zyxel Device's services but cannot look at the
configuration

ext-user - this user account is maintained in a remote server, such as RADIUS or LDAP. See
Ext-User Accounts on page 618 for more information about this type.

ext-group-user - this user account is maintained in a remote server, such as RADIUS or
LDAP. See Ext-Group-User Accounts on page 618 for more information about this type.

guest-manager - this user can log in via the web configurator login screen and create
dynamic guest accounts using the Account Generator screen that pops up.

Description This field displays the description for each user.

Reference This displays the number of times an object reference is used in a profile.

35.2.2.1 User Add/Edit Screen

The User Add/Edit screen allows you o create a new user account or edit an existing one.

35.2.2.2 Rules for User Names

Enter a user name from 1 to 31 characters.

The user name can only contain the following characters:

* Alphanumeric A-z 0-9 (there is no unicode support)
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e _ [underscores]

e - [dashes]

The first character must be alphabetical (A-Z a-z), an underscore (_), or a dash (-). Other limitations on

user names are:

¢ User names are case-sensitive. If you enter a user 'bob' but use 'BOB' when connecting via CIFS or FTP,
it will use the account settings used for 'BOB' not ‘bob’.

* User names have to be different than user group names.

e Here are the reserved user names:

e adm .
e debug .
e |dap-users .
* operator .
* sync .

admin o

devicehaoecived

Ip o
radius-users .
uucp .

any
ftp

mail
root

zyxel

e bin
e games
¢ news

¢ shutdown

* daemon
e halt

e nobody
e sshd

To access this screen, go to the User screen (see Section 35.13.1 on page 713), and click either the Add

icon or an Edit icon.

Figure 410 Configuration > Object > User/Group > User > Add

& Edit User admin

User Configuration

User Name :

Password:
Retype:
Description:

Email:

Mobile Number:

Authentication Timeout Settings

Lease Time:

Reauthenfication Time:

admin

Administration ac

© Use Default Sett]
30

0

cou

ings
minutes

minutes

@ Use Manual Settings
ok |
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The following table describes the labels in this screen.

Table 248 Configuration > Object > User/Group > User > Add

LABEL

DESCRIPTION

User Name

Type the user name for this user account. You may use 1-31 alphanumeric characters,
underscores(_), or dashes (-), but the first character cannot be a number. This value is case-
sensitive. User names have to be different than user group names, and some words are
reserved. See Section 35.2.2.2 on page 620.

User Type

This field displays the types of user accounts the Zyxel Device uses:

* admin - this user can look at and change the configuration of the Zyxel Device

* limited-admin - this user can look at the configuration of the Zyxel Device but not to
change it

* user - this user has access to the Zyxel Device's services and can also browse user-mode
commands (CLI).

» guest - this user has access to the Zyxel Device's services but cannot look at the
configuration.

e ext-user - this user account is maintained in a remote server, such as RADIUS or LDAP.
See Ext-User Accounts on page 618 for more information about this type.

e ext-group-user - this user account is maintained in a remote server, such as RADIUS or
LDAP. See Ext-Group-User Accounts on page 618 for more information about this type.

Password

This field is not available if you select the ext-user or ext-group-user type.

Enter a password of from 1 to 64 characters for this user account. If you selected Enable
Password Complexity in Configuration > Object > User/Group > Setting, it must consist of at
least 8 characters and at most 64. Af least 1 character must be a number, at least 1 a lower
case letter, at least 1 an upper case letter and at least 1 a special character from the
keyboard, such as |@#$%A&*()_+.

Retype

This field is not available if you select the ext-user or ext-group-user type.

Group Identifier

This field is available for a ext-group-user type user account.

Specify the value of the AD or LDAP server’s Group Membership Attribute that identifies the
group to which this user belongs.

Associated AAA
Server Object

This field is available for a ext-group-user type user account. Select the AAA server to use to
authenticate this account’s users.

Description Enter the description of each user, if any. You can use up to 60 printable ASCIl characters.
Default descriptions are provided.
Emaill Type one or more valid email addresses for this user so that email messages can be sent to

this user if required. A valid email address must contain the @ character. For example, this is
a valid email address: abc@example.com.

Mobile Number

Type a valid mobile telephone number for this user so that SMS messages can be sent fo this
user if required. A valid mobile telephone number can be up to 20 characters in length,
including the numbers 1~9 and the following characters in the square brackets [+*#()-].
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Table 248 Configuration > Object > User/Group > User > Add (confinued)

LABEL DESCRIPTION
Send Code This button is available when the user type is admin or limited-admin.
Click this and an authorization email or SMS message with a code of six digits will be sent to
the email addresses or mobile telephone number you putin.
Enter the verification code to verify your email addresses or mobile telephone number.
Figure 411 Verification Code for Email
€ Verify Email EFX|
Email:
Code: (1]
Figure 412 Verification Code for Mobile Telephone Number
& Verify Mobile X
Mobile Number: 0%
Code: o
Authentication If you want the system to use defaulf settings, select Use Default Settings. If you want to set

Timeout Settings

authentication fimeout to a value other than the default settings, select Use Manual Settings
then fill your preferred values in the fields that follow.

Lease Time

If you select Use Default Settings in the Authentication Timeout Settings field, the default
lease time is shown.

If you select Use Manual Settings, you need to enter the number of minutes this user has to
renew the current session before the user is logged out. You can specify 1 o 1440 minutes.
You can enter 0 fo make the number of minutes unlimited. Admin users renew the session
every time the main screen refreshes in the Web Configurator. Access users can renew the
session by clicking the Renew button on their screen. If you allow access users to renew time
automatically (see Section 35.2.4 on page 625), the users can select this check box on their
screen as well. In this case, the session is automatically renewed before the lease time
expires.

Reauthentication
Time

If you select Use Default Settings in the Authentication Timeout Settings field, the default
lease time is shown.

If you select Use Manual Settings, you need to type the number of minutes this user can be
logged into the Zyxel Device in one session before the user has fo log in again. You can
specify 1 to 1440 minutes. You can enter 0 fo make the number of minutes unlimited. Unlike
Lease Time, the user has no opportunity to renew the session without logging out.

User VLAN ID

This field is available for a ext-group-user type user account.

Select this option to enable dynamic VLAN assignment on the Zyxel Device. When a user is
authenticated successfully, all data traffic from this user is tagged with the VLAN ID number
you specify here.

This allows you to assign a user of the ext-group-user type to a specific VLAN based on the
user credentials instead of using an AAA server.

ZyWALL ATP Series User’s Guide

623




Chapter 35 Object

Table 248 Configuration > Object > User/Group > User > Add (confinued)

LABEL DESCRIPTION

Configuration Use a user account from the group specified above to test if the configuration is correct.
Validation Enter the account’s user name in the User Name field and click Test.

oK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving your changes.

35.2.3 User/Group Group Summary Screen

User groups consist of access users and other user groups. You cannot put admin users in user groups.
The Group screen provides a summary of all user groups. In addition, this screen allows you to add, edit,
and remove user groups. To access this screen, login to the Web Configurator, and click Configuration >
Object > User/Group > Group.

Figure 413 Configuration > Object > User/Group > Group
Seffing MAC Address

Configuration

@ Add

Page of 0 Show |50 |~ | items No data to display

The following table describes the labels in this screen. See Section 35.2.3.1 on page 624 for more
information as well.

Table 249 Configuration > Object > User/Group > Group

LABEL DESCRIPTION

Add Click this to create a new enfry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the
entry’s seftings.

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want fo remove
it before doing so. Removing a group does not remove the user accounts in the group.

References Select an entry and click References to open a screen that shows which settings use the entry.

# This field is a sequential value, and it is not associated with a specific user group.

Group Name This field displays the name of each user group.

Description This field displays the description for each user group.

Member This field lists the members in the user group. Each member is separated by a comma.

Reference This displays the number of times an object reference is used in a profile.

35.2.3.1 Group Add/Edit Screen

The Group Add/Edit screen allows you to create a new user group or edit an existing one. To access this
screen, go to the Group screen (see Section 35.2.3 on page 624), and click either the Add icon or an
Edit icon.
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Figure 414 Configuration > Object > User/Group > Group > Add

& Add Group

Configuration
Name:

Description:

Member List

ad-users
Idap-users
radius-users
Ug-uUsers

=== Object ===

Fx]

e

{Opticnal)

(+] 4]

3

The following table describes the labels in this screen.

Table 250 Configuration > Object > User/Group > Group > Add

LABEL

DESCRIPTION

Name

Type the name for this user group. You may use 1-31 alphanumeric characters,
underscores(_), or dashes (-), but the first character cannot be a number. This value is case-
sensitive. User group names have to be different than user names.

Description

Enter the description of the user group, if any. You can use up to 60 characters, punctuation
marks, and spaces.

Member List

The Member list displays the names of the users and user groups that have been added to the
user group. The order of members is not important. Select users and groups from the Available
list that you want to be members of this group and move them to the Member list. You can
double-click a single entry to move it or use the [Shift] or [Ctrl] key to select multiple entries and
use the arrow button to move them.

Move any members you do not want included to the Available list.

OK

Click OK to save your changes back to the Zyxel Device.

Cancel

Click Cancel to exit this screen without saving your changes.

35.2.4 User/Group Setting Screen

The Setting screen controls default settings, login settings, lockout settings, and other user settings for the
Zyxel Device. You can also use this screen to specify when users must log in to the Zyxel Device before it
routes traffic for them.

To access this screen, login to the Web Configurator, and click Configuration > Object > User/Group >
Setting.
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Figure 415 Configuration > O

bject > User/Group > Setting

User Group Setting MAC Address

User Default Setting

Default Authentication Timeout Settings
1 admin 1440 1440
2 limited-admin 1440 1440
3 user 1440 1440
4  guest 1440 1440
5 ext-user 1440 1440
6  exi-group-user 1440 1440

Page |1 of 1 Show |90 || items Displaying 1 - 6 of 6

Miscellaneous Settings

[ Enable useridle detection

[ Enable Password Complexity

Complexity requirerment:

User Logon Settings

[T Lirit the number of simultaneous |o:

User Lockout Settings
¥ Enable logon retfry limit
Maximum retry count:

Lockout period:

¥ Allow renewing lease time automatically

User idle timeout: 3 {1-60 minutes)
Login Security
[¥ Password must changed every (days) | 180 {1-345 days)
Password reset link(FQDN/IP): Default ~| myroufer

* Minimun password length should be of & characters.
* Include at least 1 Upper case alphabetic characters.
*Include af least 1 Lower case alphabetic characters.
*Include af least 1 numeric character.

* Include at least 1 special characters like '@','$,1'...

IMaximum number per adminisiration account: |1 (1-128)
[ Lirnit the number of simultaneous logons for access account

Maximum number per access account: 1 (1-128)

gons for administration account

5 (1-99)
30 {1-65535 minufeas)

e

The following table describes the labels in this screen.

Table 251 Configuration > Object > User/Group > Setting

LABEL

DESCRIPTION

User Authentication Timeout Settings

Default Authentication Timeout
Settings

These authentication timeout settings are used by default when you create a
new user account. They also control the settings for any existing user accounts
that are set to use the default settings. You can sfill manually configure any user
account’s authentication timeout settings.

Edit

Double-click an entry or select it and click Edit to open a screen where you can
modify the enfry’s settings.
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Table 251 Configuration > Object > User/Group > Setting (confinued)
LABEL DESCRIPTION
# This field is a sequential value, and it is not associated with a specific entry.
User Type These are the kinds of user account the Zyxel Device supports.
e admin - this user can look at and change the configuration of the Zyxel
Device
* limited-admin - this user can look at the configuration of the Zyxel Device
but not to change it
» user - this user has access to the Zyxel Device's services but cannot look at
the configuration
e guest - this user has access to the Zyxel Device's services but cannot look
af the configuration
* ext-user - this user account is maintained in a remote server, such as RADIUS
or LDAP. See Ext-User Accounts on page 618 for more information about this
type.
e ext-group-user - this user account is maintained in a remote server, such as
RADIUS or LDAP. See Ext-Group-User Accounts on page 618 for more
information about this type.
Lease Time This is the defaulf lease time in minutes for each type of user account. It defines

the number of minutes the user has to renew the current session before the user
is logged out.

Admin users renew the session every time the main screen refreshes in the Web
Configurator. Access users can renew the session by clicking the Renew button
on their screen. If you allow access users to renew time automatically (see
Section 35.2.4 on page 625), the users can select this check box on their screen
as well. In this case, the session is automatically renewed before the lease time
expires.

Reauthentication Time

This is the default reauthentication tfime in minutes for each type of user
account. It defines the number of minutes the user can be logged into the Zyxel
Device in one session before having to log in again. Unlike Lease Time, the user
has no opportunity to renew the session without logging out.

Miscellaneous Seftings

Allow renewing lease time
automatically

Select this check box if access users can renew lease time automatically, as well
as manually, simply by selecting the Updating lease time automatically check
box on their screen.

Enable user idle detection

This is applicable for access users.

Select this check box if you want the Zyxel Device to monitor how long each
access user is logged in and idle (in other words, there is no traffic for this access
user). The Zyxel Device automatically logs out the access user once the User idle
timeout has been reached.

User idle timeout

This is applicable for access users.

This field is effective when Enable user idle detection is checked. Type the
number of minutes each access user can be logged in and idle before the Zyxel
Device automatically logs out the access user.

Login Security

Password must changed
every (days):

Enter how often users must change their password when they log into the Zyxel
Device. You can choose from once a day to once a year.

Password reset link (FQDN/
IP):

Associate the password expiration to a specific Zyxel Device. Default is this Zyxel
Device (myrouter) or select Custom and enter the IP address or Fully Qualified
Domain Name (FQDN).

Enable Password
Complexity

Select this to enforce the following conditions in a user password. Requiring a
strong password is good for security. The conditions are that the password must
consist of at least 8 characters and at most 64. At least 1 character must be a
number, at least 1 a lower case letter, at least 1 an upper case letter and at
least 1 a special character from the keyboard, such as |@#$%A&*()_+.
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Table 251 Configuration > Object > User/Group > Setting (confinued)

LABEL

DESCRIPTION

User Logon Settings

Limit the number of
simultaneous logons for
administration account

Select this check box if you want to set a limit on the number of simultaneous
logins by admin users. If you do not select this, admin users can login as many
times as they want at the same time using the same or different IP addresses.

Maximum number per
administration account

This field is effective when Limit ... for administration account is checked. Type
the maximum number of simultaneous logins by each admin user.

Limit the number of
simultaneous logons for
access account

Select this check box if you want to set a limit on the number of simultaneous
logins by non-admin users. If you do noft select this, access users can login as
many times as they want as long as they use different IP addresses.

Maximum number per
access account

This field is effective when Limit ... for access account is checked. Type the
maximum number of simultaneous logins by each access user.

User Lockout Seftings

Enable logon retry limit

Select this check box to set a limit on the number of times each user can login
unsuccessfully (for example, wrong password) before the IP address is locked
out for a specified amount of fime.

Maximum retry count

This field is effective when Enable logon retry limit is checked. Type the
maximum number of times each user can login unsuccessfully before the IP
address is locked out for the specified lockout period. The number must be
between 1 and 99.

Lockout period

This field is effective when Enable logon retry limit is checked. Type the number
of minutes the user must wait fo fry fo login again, if logon retry limit is enabled
and the maximum retry count is reached. This number must be between 1 and
65,535 (about 45.5 days).

Apply

Click Apply to save the changes.

Reset

Click Reset fo refurn the screen to its last-saved settings.

35.2.4.1 Default User Authentication Timeout Settings Edit Screens

The Default Authentication Timeout Settings Edit screen allows you fo set the default authentication
timeout settings for the selected type of user account. These default authentication timeout seftings
also control the settings for any existing user accounts that are setf to use the default settings. You can
still manually configure any user account’s authentication timeout settings.

To access this screen, go to the Configuration > Object > User/Group > Setting screen (see Section 35.2.4
on page 625), and click one of the Default Authentication Timeout Settings section’s Edit icons.

Figure 416 Configuration > Object > User/Group > Setting > Edit

Z Edit User Auth Setftings

User Type:
Lease Time:

Reauthentication Time:

Bl

[0-1440 minutes, O is unlimited)

(0-1440 minutes, O is unlimited)

ok Cancel
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The following table describes the labels in this screen.

Table 252 Configuration > Object > User/Group > Sefting > Edit

LABEL DESCRIPTION

User Type This read-only field identifies the type of user account for which you are configuring the
default settings.

e admin - this user can look at and change the configuration of the Zyxel Device

* limited-admin - this user can look at the configuration of the Zyxel Device but not to
change it.

¢ dynamic-guest - this user has access to the Zyxel Device's services but cannot look at
the configuration.

e user - this user has access to the Zyxel Device's services but cannot look at the
configuration.

» guest - this user has access to the Zyxel Device's services but cannot look at the
configuration.

e ext-user - this user account is maintained in a remote server, such as RADIUS or LDAP.
See Ext-User Accounts on page 618 for more information about this type.

e ext-group-user - this user account is maintained in a remote server, such as RADIUS or
LDAP. See Ext-Group-User Accounts on page 618 for more information about this type.

e guest-manager - this user can log in via the web configurator login screen and create
dynamic guest accounts using the Account Generator screen that pops up.

Lease Time Enter the number of minutes this type of user account has to renew the current session
before the user is logged out. You can specify 1 to 1440 minutes. You can enter 0 to make
the number of minutes unlimited.

Admin users renew the session every time the main screen refreshes in the Web
Configurator. Access users can renew the session by clicking the Renew button on their
screen. If you allow access users to renew time automatically (see Section 35.2.4 on page
625), the users can select this check box on their screen as well. In this case, the session is
automatically renewed before the lease time expires.

Reauthentication Type the number of minutes this type of user account can be logged into the Zyxel Device in
Time one session before the user has to log in again. You can specify 1 to 1440 minutes. You can
enter 0 to make the number of minutes unlimited. Unlike Lease Time, the user has no
opportunity to renew the session without logging out.

oK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving your changes.

35.2.4.2 User Aware Login Example

Access users cannof use the Web Configurator to browse the configuration of the Zyxel Device. Instead,
after access users log info the Zyxel Device, the following screen appears.
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Figure 417 Web Configurator for Non-Admin Users

ZYXEL

Click the logout button to terminate the access session.
You could ren i

For security reason you must login in agair

User-defined lease time (max 1440 minutes): 1440 @

Remaining time before lease timeout (hh:mm:ss): 23:59:58

Remaining fime before auth. timeout (hhimm:ss): 23:59:58

You now have logged in.

ng the Renew button.
1 affer 23 hours 59 minutes.

[ ] Updating lease time automatically

Logout

The following table describes the labels in this screen.

Table 253 Web Configurator for Non-Admin Users

LABEL

DESCRIPTION

User-defined
lease time (max
... minutes)

Access users can specify a lease time shorter than or equal to the one that you specified. The
default value is the lease time that you specified.

Renew

Access users can click this button to reset the lease time, the amount of fime remaining before
the Zyxel Device automatically logs them out. The Zyxel Device sets this amount of fime
according to the:

¢ User-defined lease time field in this screen
¢ Lease time field in the User Add/Edit screen (see Section 35.2.5.1 on page 631)
¢ Lease time field in the Setting screen (see Section 35.2.4 on page 625).

Updating lease
fime
automatically

This box appears if you checked the Allow renewing lease time automatically box in the
Setting screen. (See Section 35.2.4 on page 625.) Access users can select this check box to
reset the lease time automatically 30 seconds before it expires. Otherwise, access users have
fo click the Renew button to reset the lease time.

Remaining time
before lease
fimeout

This field displays the amount of lease time that remains, though the user might be able to reset
it.

Remaining time
before auth.
fimeout

This field displays the amount of time that remains before the Zyxel Device automatically logs
the access user out, regardless of the lease time.

35.2.5 User/Group MAC Address Summary Screen

This screen shows the MAC addresses of wireless clients, which can be authenticated by their
MAC addresses using the local user database. Click Configuration > Object > User/Group > MAC
Address fo open this screen.

Note: You need to configure an SSID security profile’s MAC authentication setftings to have
the AP use the Zyxel Device's local database to authenticate wireless clients by their
MAC addresses.

ZyWALL ATP Series User’s Guide

630




Chapter 35 Object

Figure 418 Configuration > Object > User/Group > MAC Address

MAC Address

MAC Authentication

© Add

Page

of 0 Show |50 || items No daia fo display

The following table describes the labels in this screen.

Table 254 Configuration > Object > User/Group > MAC Address

LABEL DESCRIPTION

Add Click this to create a new enfry.

Edit Double-click an entry or select it and click Edit to open a screen where you can modify the
entry’s settings.

Remove To remove an entry, select it and click Remove. The Zyxel Device confirms you want to remove

it before doing so.

MAC Address/
oul

This field displays the MAC address or OUI (Organizationally Unique Identifier of computer
hardware manufacturers) of wireless clients using MAC authentication with the Zyxel Device
local user database.

Description

This field displays a description of the device identified by the MAC address or OUL.

35.2.5.1 MAC Address Add/Edit Screen

This screen allows you to create a new allowed device or edit an existing one. To access this screen, go
fo the MAC Address screen (see Section 35.2.5 on page 630), and click either the Add icon or an Edit

icon.

Figure 419 Configuration > Object > User/Group > MAC Address > Add

Description:

& Add MAC Auth Address

MAC Address/OUL:

e

The following table describes the labels in this screen.

Table 255 Configuration > Object > User/Group > MAC Address > Add

LABEL DESCRIPTION

MAC Address/ Type the MAC address (six hexadecimal number pairs separated by colons or hyphens) or OUI

oul (three hexadecimal number pairs separated by colons or hyphens) to identify specific wireless
clients for MAC authentication using the Zyxel Device local user database. The OUl is the first
three octets in a MAC address and uniquely identifies the manufacturer of a network device.

Description Enter an optional description of the wireless device(s) identified by the MAC or OUL. You can
use up to 60 characters, punctuation marks, and spaces.

OK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving your changes.
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35.2.6 User /Group Technical Reference

This section provides some information on users who use an external authentication server in order to log
in.

Setting up User Attributes in an External Server

To set up user attributes, such as reauthentication time, in LDAP or RADIUS servers, use the following
keywords in the user configuration file.

Table 256 LDAP/RADIUS: Keywords for User Attributes

KEYWORD CORRESPONDING ATTRIBUTE IN WEB CONFIGURATOR

type User Type. Possible Values: admin, limited-admin, dynamic-guest, user, guest.
leaseTime Lease Time. Possible Values: 1-1440 (minutes).

reauthTime Reauthentication Time. Possible Values: 1-1440 (minutes).

The following examples show you how you might set up user attributes in LDAP and RADIUS servers.

Figure 420 LDAP Example: Keywords for User Attributes
type: admin

leaseTime: 99

reauthTime: 199

Figure 421 RADIUS Example: Keywords for User Attributes

type=user;leaseTime=222;reauthTime=222

Creating a Large Number of Ext-User Accounts

If you plan to create a large number of Ext-User accounts, you might use CLI commands, instead of the
Web Configurator, to create the accounts. Exiract the user names from the LDAP or RADIUS server, and
create a shell script that creates the user accounts.

35.3 AP Profile Overview

This section shows you how to configure preset profiles for the Access Points (APs) connected fo your
Zyxel Device's wireless network.

* The Radio screen (Section 35.3.1 on page 633) creates radio configurations that can be used by the
APs.

¢ The SSID screen (Section 35.3.2 on page 639) configures three different types of profiles for your
networked APs.

35.3.0.1 What You Need To Know

The following terms and concepts may help as you read this section.
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Wireless Profiles

At the heart of all wireless AP configurations on the Zyxel Device are profiles. A profile represents a group
of saved setftings that you can use across any number of connected APs. You can set up the following
wireless profile types:

* Radio - This profile type defines the properties of an AP’s radio fransmitter. You can have a maximum
of 32 radio profiles on the Zyxel Device.

¢ SSID - This profile type defines the properties of a single wireless network signal broadcast by an AP.
Each radio on a single AP can broadcast up to 8 SSIDs. You can have a maximum of 32 SSID profiles
on the Zyxel Device.

* Security - This profile type defines the security settings used by a single SSID. It controls the encryption
method required for a wireless client to associate itself with the SSID. You can have a maximum of 32
security profiles on the Zyxel Device.

* MAC Filtering - This profile provides an additional layer of security for an SSID, allowing you to block
access or allow access to that SSID based on wireless client MAC addresses. If a client’'s MAC address
is on the list, then it is either allowed or denied, depending on how you set up the MAC Filter profile.
You can have a maximum of 32 MAC filtering profiles on the Zyxel Device.

SSID
The SSID (Service Set IDentfifier) is the name that identifies the Service Set with which a wireless station is

associated. Wireless stations associating to the access point (AP) must have the same SSID. In other
words, it is the name of the wireless network that clients use to connect to it.

WEP
WEP (Wired Equivalent Privacy) encryption scrambles all data packets fransmitted between the AP and

the wireless stations associated with it in order o keep network communications private. Both the
wireless stations and the access points must use the same WEP key for data encryption and decryption.

WPA and WPA2
Wi-Fi Protected Access (WPA) is a subset of the IEEE 802.11i standard. WPA2 (IEEE 802.11i) is a wireless

security standard that defines stronger encryption, authentication and key management than WPA.
Key differences between WPA(2) and WEP are improved data encryption and user authentication.

IEEE 802.1x

The IEEE 802.1x standard outlines enhanced security methods for both the authentication of wireless
stations and encryption key management. Authentication is done using an external RADIUS server.

35.3.1 Radio Screen

This screen allows you to create radio profiles for the APs on your network. A radio profile is a list of
settings that a supported managed AP (NWA5121-N for example) can use to configure either one of its
two radio fransmitters. To access this screen click Configuration > Object > AP Profile.

Note: You can have a maximum of 32 radio profiles on the Zyxel Device.
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Figure 422 Configuration > Object > AP Profile > Radio

Radio Summary

@ Add

[ Disabled-2G 2.4G nene
2 @ Disabled-5G 5G none
3 9 default 2.4G none
4 9 default2 5G none
Page |1 of 1 Show |90 |v | itemns Displaying 1 - 4 of 4

| Apply || Reset |

The following table describes the labels in this screen.

Table 257 Configuration > Object > AP Profile > Radio

LABEL DESCRIPTION

Add Click this to add a new radio profile.

Edit Click this to edit the selected radio profile.

Remove Click this to remove the selected radio profile.

Activate To turn on an entry, select it and click Activate.

Inactivate To turn off an entry, select it and click Inactivate.

References Click this to view which other objects are linked to the selected radio profile.
# This field is a sequential value, and it is not associated with a specific profile.
Status This icon is lit when the enftry is active and dimmed when the entry is inactive.

Profile Name

This field indicates the name assigned fo the radio profile.

Frequency Band

This field indicates the frequency band which this radio profile is configured to use.

Schedule This field displays the schedule object which defines when this radio profile can be used.
Apply Click Apply to save your changes back to the Zyxel Device.
Reset Click Reset to return the screen to its last-saved settings.
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35.3.1.1 Add/Edit Radio Profile

This screen allows you to create a new radio profile or edit an existing one. To access this screen, click
the Add button or select a radio profile from the list and click the Edit button.

Figure 423 Configuration > Object > AP Profile > Add/Edit Radio Profile

€ Add Radio Profile
Show Advanced Seftings  uf] Create New Object ~
General Seftings
Activate
Profile Name: l:lo
Schedule: none 7
802.11 Band: 11b/g/n v
Channel Width: 20MHz ¥
Channel Selecfion: @ DCS ) Manual
Enable DCS Client Aware
2.4 GHz Channel Selection Method: auto i
2.4 GHz Channel Deployment: Three-Channel Deployment | ¥
@ Time Interval
DCS Time Interval: 720 (10~1440 minutes)
O schedule
Aclvance
==1

The following table describes the labels in this screen.

Table 258 Configuration > Object > AP Profile > Add/Edit Radio Profile

LABEL

DESCRIPTION

Hide / Show
Advanced Settings

Click this to hide or show the Advanced Settings in this window.

Create New Object

Use this to configure any new settings objects that you need to use in this screen.

General Seftings

Activate

Select this option to make this profile active.

Profile Name

Enter up to 31 alphanumeric characters to be used as this profile’'s name. Spaces and
underscores are allowed.

Schedule

This field displays the schedule object which defines when this radio profile can be used.

802.11 Band

Select how to let wireless clients connect to the AP.

* 11b/g: allows either IEEE 802.11b or IEEE 802.11g compliant WLAN devices fo associate
with the AP. The AP adjusts the transmission rate automatically according to the
wireless standard supported by the wireless devices.

e 11b/g/n: allows IEEE802.11b, IEEE802.11g and IEEE802.11n compliant WLAN devices to
associate with the AP. The transmission rate of your AP might be reduced.

e 1lla: allows only IEEE 802.11a compliant WLAN devices to associate with the AP.

e 1la/n: allows both IEEE802.11n and IEEE802.11a compliant WLAN devices to associate
with the AP. The fransmission rate of your AP might be reduced.

e llac: allows only IEEE802.11ac compliant WLAN devices to associate with the AP.

Note: If you select 11ac but the WLAN devices in the network do not support IEEE
802.11ac, the Zyxel Device automatically sets the AP to use 11a/n.
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Table 258 Configuration > Object > AP Profile > Add/Edit Radio Profile (continued)

LABEL

DESCRIPTION

Channel Width

Select the wireless channel bandwidth you want the AP to use.

A standard 20 MHz channel offers transfer speeds of up to 144Mbps (2.4GHz) or 217Mbps
(5GHZ) whereas a 40MHz channel uses two standard channels and offers speeds of up to
300Mbps (2.4GHz) or 450Mbps (5GHZ). An IEEE 802.11ac-specific 80MHz channel offers
speeds of up to 1.3Gbps.

40 MHz (channel bonding or dual channel) bonds two adjacent radio channels to increase
throughput. A 80 MHz channel consists of two adjacent 40 MHz channels. The wireless
clients must also support 40 MHz or 80 MHz. It is often better to use the 20 MHz setting in a
location where the environment hinders the wireless signal.

Because not all devices support 40 MHz and/or 80 MHz channels, select 20/40MHz or 20/
40/80MHz to allow the AP to adjust the channel bandwidth automatically.

Select 20MHz if you want to lessen radio interference with other wireless devices in your
neighborhood or the wireless clients do not support channel bonding.

Note: If the environment has poor signal-to-noise (SNR), the Zyxel Device wiill
switch to a lower bandwidth.

Channel
Selection

Select the wireless channel which this radio profile should use.

It is recommended that you choose the channel least in use by other APs in the region
where this profile will be implemented. This will reduce the amount of inferference between
wireless clients and the AP to which this profile is assigned.

Select DCS to have the AP automatically select the radio channel upon which it
broadcasts by scanning the area around it and determining what channels are currently
being used by other devices.

Select Manual and specify the channels the AP uses.

Enable DCS
Client Aware

This field is available when you set Channel Selection to DCS.

Select this to have the AP wait until all connected clients have disconnected before
switching channels.

If you disable this then the AP switches channels immediately regardless of any client
connections. In this instance, clients that are connected to the AP when it switches
channels are dropped.

2.4 GHz Channel
Selection Method

This field is available when you set Channel Selection to DCS.

Select auto to have the AP search for available channels automatically in the 2.4 GHz
band. The available channels vary depending on what you select in the 2.4 GHz Channel
Deployment field.

Select manual and specify the channels the AP uses in the 2.4 GHz band.

Channel ID This field is available only when you set Channel Selection to DCS and set 2.4 GHz Channel
Selection Method to manual.
Select the check boxes of the channels that you want the AP to use.

Time Interval Select this option to have the AP survey the other APs within its broadcast radius at the end

of the specified time interval.

DCS Time Interval

This field is available when you set Channel Selection to DCS.

Enter a number of minutes. This regulates how often the AP surveys the other APs within its
broadcast radius. If the channel on which it is currently broadcasting suddenly comes into
use by another AP, the AP will then dynamically select the next available clean channel or
a channel with lower interference.

Schedule

Select this option to have the AP survey the other APs within its broadcast radius at a
specific fime on selected days of the week.
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Table 258 Configuration > Object > AP Profile > Add/Edit Radio Profile (continued)

LABEL DESCRIPTION

Start Time Specify the time of the day (in 24-hour format) to have the AP use DCS to automatically
scan and find a less-used channel.

Week Days Select each day of the week to have the AP use DCS to automatically scan and find a less-
used channel.

2.4 GHz Channel | This field is available only when you set Channel Selection to DCS and set 2.4 GHz Channel

Deployment Selection Method fo auto.
Select Three-Channel Deployment to limit channel switching to channels 1,6, and 11, the
three channels that are sufficiently attenuated to have almost no impact on one another.
In other words, this allows you to minimize channel interference by limiting channel-
hopping to these three “safe” channels.
Select Four-Channel Deployment to limit channel switching to four channels. Depending
on the country domain, if the only allowable channels are 1-11 then the Zyxel Device uses
channels 1, 4,7, 11 in this configuration; otherwise, the Zyxel Device uses channels 1, 5, 9, 13
in this configuration. Four channel deployment expands your pool of possible channels
while keeping the channel interference to a minimum.
Note: For US and Canada models, country code is fixed to US or Canada

respectively and is not user selectable.

Enable 5 GHz DFS | This field is available only when you select 11a, 11a/n or 11ac in the 802.11 Band field.

Aware
Select this if your APs are operating in an area known to have RADAR devices. This allows
the device to downgrade its frequency to below 5 GHz in the event a RADAR signal is
detected, thus preventing it from interfering with that signal.
Enabling this forces the AP to select a non-DFS channel.

5 GHz Channel This shows auto and allows the AP to search for available channels automatically in the 5

Selection Method

GHz band.

Advanced Settings

Country Code

Select the country code of APs that are connected to the Zyxel Device to be the same as
where the Zyxel Device is located/installed.

The available channels vary depending on the country you select. Be sure to select the
correct/same country for both radios on an AP and all connected APs, in order fo prevent
roaming failure and interference to other systems.

Note: For US and Canada models, country code is fixed to US or Canada
respectively and is not user selectable.

Guard Interval

This field is available only when the channel width is 20/40MHz or 20/40/80MHz.
Set the guard interval for this radio profile to either Short or Long.

The guard interval is the gap infroduced between data transmission from users in order to
reduce interference. Reducing the interval increases data transfer rates but also increases
interference. Increasing the interval reduces data transfer rates but also reduces
interference.

Enable A-MPDU

Select this to enable A-MPDU aggregation.

Aggregation
Message Protocol Data Unit (MPDU) aggregation collects Ethernet frames along with their
802.11n headers and wraps them in a 802.11n MAC header. This method is useful for
increasing bandwidth throughput in environments that are prone to high error rates.

A-MPDU Limit Enter the maximum frame size to be aggregated.

A-MPDU Enter the maximum number of frames to be aggregated each time.

Subframe
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Table 258 Configuration > Object > AP Profile > Add/Edit Radio Profile (continued)

LABEL DESCRIPTION

Enable A-MSDU Select this to enable A-MSDU aggregation.

Aggregation
Mac Service Data Unit (MSDU) aggregation collects Ethernet frames without any of their
802.11n headers and wraps the header-less payload in a single 802.11n MAC header. This
method is useful for increasing bandwidth throughput. It is also more efficient than A-MPDU
except in environments that are prone to high error rates.

A-MSDU Limit Enfer the maximum frame size to be aggregated.

RTS/CTS Threshold | Use RTS/CTS to reduce data collisions on the wireless network if you have wireless clients

that are associated with the same AP but out of range of one another. When enabled, a
wireless client sends an RTS (Request To Send) and then waits for a CTS (Clear To Send)
before it fransmits. This stops wireless clients from transmitting packets at the same time
(and causing data collisions).

A wireless client sends an RTS for all packets larger than the number (of bytes) that you
enter here. Set the RTS/CTS equal to or higher than the fragmentation threshold to turn RTS/
CTS off.

Beacon Interval

When a wirelessly networked device sends a beacon, it includes with it a beacon interval.
This specifies the time period before the device sends the beacon again. The interval tells
receiving devices on the network how long they can wait in low-power mode before
waking up to handle the beacon. A high value helps save current consumption of the
access point.

DTIM

Delivery Traffic Indication Message (DTIM) is the time period after which broadcast and
multicast packets are fransmitted to mobile clients in the Active Power Management
mode. A high DTIM value can cause clients to lose connectivity with the network. This value
can be set from 1 to 255.

Enable Signal
Threshold

Select the check box to use the signal threshold to ensure wireless clients receive good
throughput. This allows only wireless clients with a strong signal to connect to the AP.

Clear the check box to not require wireless clients fo have a minimum signal strength to
connect to the AP.

Station Signal
Threshold

Set a minimum client signal strength. A wireless client is allowed to connect to the AP only
when its signal strength is sfronger than the specified threshold.

-20 dBm is the strongest signal you can require and -76 is the weakest.

Disassociate
Station Threshold

Set a minimum kick-off signal strength. When a wireless client’s signal strength is lower than
the specified threshold, the Zyxel Device disconnects the wireless client from the AP.

-20 dBm is the strongest signal you can require and -90 is the weakest.

Allow Station
Connection after
Multiple Retries

Select this option to allow a wireless client to try fo associate with the AP again after it is
disconnected due to weak signal strength.

Station Retry
Count

Set the maximum number of tfimes a wireless client can attempt to re-connect to the AP

Multicast Settings

Use this section to set a transmission mode and maximum rate for multicast traffic.

Transmission
Mode

Set how the AP handles multicast fraffic.

Select Multicast to Unicast fo broadcast wireless multicast fraffic to all of the wireless clients
as unicast traffic. Unicast traffic dynamically changes the data rate based on the
application’s bandwidth requirements. The retransmit mechanism of unicast traffic
provides more reliable tfransmission of the multicast traffic, although it also produces
duplicate packets.

Select Fixed Multicast Rate to send wireless multicast traffic at a single data rate. You must
know the multicast application’s bandwidth requirements and set it in the following field.

Multicast Rate
(Mbps)

If you set the multicast fransmission mode to fixed multicast rate, set the data rate for
multicast fraffic here. For example, to deploy 4 Mbps video, select a fixed mulficast rate
higher than 4 Mbps.
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Table 258 Configuration > Object > AP Profile > Add/Edit Radio Profile (contfinued)

LABEL DESCRIPTION
OK Click OK to save your changes back to the Zyxel Device.
Cancel Click Cancel to exit this screen without saving your changes.

35.3.2 SSID Screen

The SSID screens allow you to configure three different types of profiles for your networked APs: an SSID
list, which can assign specific SSID configurations to your APs; a security list, which can assign specific
encryption methods to the APs when allowing wireless clients to connect to them; and a MAC filter list,
which can limit connections to an AP based on wireless clients MAC addresses.

35.3.2.1 SSID List

This screen allows you to create and manage SSID configurations that can be used by the APs. An SSID,
or Service Set IDentifier, is basically the name of the wireless network to which a wireless client can
connect. The SSID appears as readable text to any device capable of scanning for wireless frequencies
(such as the WiFi adapter in a laptop), and is displayed as the wireless network name when a person
makes a connection to it.

To access this screen click Configuration > Object > AP Profile > SSID.

Note: You can have a maximum of 32 SSID profiles on the Zyxel Device.

Figure 424 Configuratfion > Object > AP Profile > SSID List

m Security Liss  MAC Filter List

SSID Summary

@ Add

1 default TyXEL default WHAR localbridge disable 1

Page |1 of 1 Show |50 |w | items Displaying 1-1 of 1

The following table describes the labels in this screen.

Table 259 Configuration > Object > AP Profile > SSID List

LABEL DESCRIPTION

Add Click this to add a new SSID profile.

Edit Click this to edit the selected SSID profile.

Remove Click this to remove the selected SSID profile.

References Click this to view which other objects are linked to the selected SSID profile (for example, radio
profile).

# This field is a sequential value, and it is not associated with a specific profile.

Profile Name This field indicates the name assigned to the SSID profile.

SSID This field indicates the SSID name as it appears to wireless clients.

Security Profile This field indicates which (if any) security profile is associated with the SSID profile.

QoS This field indicates the QoS type associated with the SSID profile.
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Table 259 Configuration > Object > AP Profile > SSID List (continued)

LABEL DESCRIPTION

MAC Filtering This field indicates which (if any) MAC Filter Profile is associated with the SSID profile.
Profile

VLAN ID This field indicates the VLAN ID associated with the SSID profile.

35.3.2.2 Add/Edit SSID Profile

This screen allows you to create a new SSID profile or edit an existing one. To access this screen, click the
Add button or select an SSID profile from the list and click the Edit button.

Figure 425 Configuration > Object > AP Profile > SSID > Add/Edit SSID Profile
€ Add SSID Profile 7=l

= Create new Objectw

Profle Name: [ e

SSID: Zyxel
Security Profile: default v
MAC Filtering Profile: disable v
QoS: WM v
Rate Limiting {Per Station Traffic Rate) @
Downlink: |0 mbps A [0~160, 0 is unlimited)
Uplink: o] mbps s [0~160, 0 is unlimited)
Band Select: disable v
Forwarding Mode: Local bridge v
VLAN ID: 1 [1~4094)
[l Hidden SSID

[ Enable Intra-BSS Traffic blocking
[Cschedule ssiD @

The following table describes the labels in this screen.

Table 260 Configuration > Object > AP Profile > SSID > Add/Edit SSID Profile

LABEL DESCRIPTION

Create new Select an object type from the list fo create a new one associated with this SSID profile.

Object

Profile Name Enter up to 31 alphanumeric characters for the profile name. This name is only visible in the
Web Configurator and is only for management purposes. Spaces and underscores are
allowed.

SSID Enter the SSID name for this profile. This is the name visible on the network to wireless clients.

Enter up to 32 characters, spaces and underscores are allowed.

Security Profile Select a security profile from this list to associate with this SSID. If none exist, you can use the
Create new Object menu to create one.

Note: It is highly recommended that you create security profiles for all of your SSIDs to
enhance your network security.
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Table 260 Configuration > Object > AP Profile > SSID > Add/Edit SSID Profile (continued)

LABEL DESCRIPTION
MAC Filtering Select a MAC filtering profile from the list to associate with this SSID. If none exist, you can use
Profile the Create new Object menu to create one.
MAC filtering allows you tfo limit the wireless clients connecting to your network through a
particular SSID by wireless client MAC addresses. Any clients that have MAC addresses not in
the MAC filtering profile of allowed addresses are denied connections.
The disable setting means no MAC filtering is used.
QoS Select a Quality of Service (QoS) access category to associate with this SSID. Access categories

minimize the delay of data packets across a wireless network. Certain categories, such as
video or voice, are given a higher priority due to the time sensitive nature of their data packets.

QoS access categories are as follows:

disable: Turns off QoS for this SSID. All data packets are tfreated equally and not tagged with
access categories.

WMM: Enables automatic tagging of data packets. The Zyxel Device assigns access categories
to the SSID by examining data as it passes through it and making a best guess effort. If
something looks like video traffic, for instance, it is tagged as such.

WMM_VOICE: All wireless traffic to the SSID is tagged as voice data. This is recommended if an
SSID is used for activities like placing and receiving VolP phone calls.

WMM_VIDEO: All wireless traffic to the SSID is tagged as video data. This is recommended for
activifies like video conferencing.

WMM_BEST_EFFORT: All wireless traffic to the SSID is tagged as “best effort,” meaning the data
fravels the best route it can without displacing higher priority traffic. This is good for activities
that do not require the best bandwidth throughput, such as surfing the Internet.

WMM_BACKGROUND: All wireless traffic to the SSID is tagged as low priority or “background
fraffic”, meaning all other access categories take precedence over this one. If traffic from an
SSID does not have strict throughput requirements, then this access category is recommended.
For example, an SSID that only has network printers connected to it.

Rate Limiting (Per
Station Traffic

Define the maximum incoming and outgoing transmission data rate per wireless station

Rate)
Downlink: Define the maximum incoming fransmission data rate (either in Mbps or Kbps) on a per-station
basis.
Uplink: Define the maximum outgoing transmission data rate (either in Mbps or Kbps) on a per-station

basis.

Band Select:

To improve network performance and avoid interference in the 2.4 GHz frequency band, you
can enable this feature to use the 5 GHz band first. You should set 2.4GHz and 5 GHz radio
profiles to use the same SSID and security settings.

Select standard to have the AP try fo connect the wireless clients o the same SSID using the 5
GHZ band. Connections to an SSID using the 2.4GHz band are still allowed.

Otherwise, select disable to turn off this feature.

Stop
Threshold

This field is not available when you disable Band Select.

Select this option and set the threshold number of the connected wireless clients at which the
Zyxel Device disables the band select feature.

Balance Ratio

This field is not available when you disable Band Select.

Select this option and set a rafio of the wireless clients using the 5 GHz band to the wireless
clients using the 2.4 GHz band.

Forwarding Mode

Select a forwarding mode (Tunnel or Local bridge) for traffic from this SSID.

ZyWALL ATP Series User’s Guide

641




Chapter 35 Object

Table 260 Configuration > Object > AP Profile > SSID > Add/Edit SSID Profile (continued)

LABEL DESCRIPTION

VLAN ID If you selected Local Bridge forwarding mode, entfer the VLAN ID that will be used to tag alll
fraffic originating from this SSID if the VLAN is different from the native VLAN. All the wireless
stafion’s tfraffic goes through the associated AP's gateway.

VLAN Interface If you selected the Tunnel forwarding mode, select a VLAN interface. All the wireless station’s
fraffic is forwarded to the Zyxel Device first.

Hidden SSID Select this if you want to “hide” your SSID from wireless clients. This tells any wireless clients in the
vicinity of the AP using this SSID profile not to display its SSID name as a potential connection.
Not all wireless clients respect this flag and display it anyway.

When an SSID is “hidden™ and a wireless client cannot see it, the only way you can connect to
the SSID is by manually entering the SSID name in your wireless connection setup screen(s)
(these vary by client, client connectivity software, and operating system).

Enable Intra-BSS Select this option to prevent crossover fraffic from within the same SSID.
Traffic Blocking

Schedule SSID Select this option and set whether the SSID is enabled or disabled on each day of the week.
You also need to select the hour and minute (in 24-hour format) to specify the time period of
each day during which the SSID is enabled/enabled.

OK Click OK to save your changes back to the Zyxel Device.

Cancel Click Cancel to exit this screen without saving your changes.

35.3.2.3 Security List

This screen allows you fo manage wireless security configurations that can be used by your SSIDs.
Wireless security is implemented strictly between the AP broadcasting the SSID and the stations that are
connected to if.

To access this screen click Configuration > Object > AP Profile > SSID > Security List.

Note: You can have a maximum of 32 security profiles on the Zyxel Device.

Figure 426 Configuration > Object > AP Profile > SSID > Security List
Radio SSID

SSID List Security List MAC Filter List

Security Summary

© Add

1 default Open
Page |1 of 1 Show |50 |w | ifems Displaying 1-1 of 1

The following table describes the labels in this screen.

Table 261 Configuration > Object > AP Profile > SSID > Security List

LABEL DESCRIPTION

Add Click this to add a new security profile.

Edit Click this to edit the selected security profile.
Remove Click this to remove the selected security profile.
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Table 261 Configuration > Object > AP Profile > SSID > Security List (continued)

LABEL DESCRIPTION

References Click this to view which other objects are linked to the selected security profile (for example,
SSID profile).

# This field is a sequential value, and it is not associated with a specific profile.

Profile Name

This field indicates the name assigned to the security profile.

Security Mode

This field indicates this profile's security mode (if any).
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