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INTRODUCTION

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Getting Started

Macromedia Dreamweaver is a professional HTML editor for visually designing 
and managing Web sites and pages. Whether you enjoy the control of hand-
coding HTML or prefer to work in a visual editing environment, Dreamweaver 
makes it easy to get started and provides you with helpful tools to enhance your 
Web design experience. 

Dreamweaver includes many coding tools and features: an HTML, CSS, and 
JavaScript reference, a JavaScript Debugger, and code editors (the Code view and 
Code inspector) that allow you to edit JavaScript, XML, and other text documents 
directly in Dreamweaver. Macromedia Roundtrip HTML technology imports 
HTML documents without reformatting the code—and you can set 
Dreamweaver to clean up and reformat HTML when you want it to.

The visual editing features in Dreamweaver also let you quickly add design and 
functionality to your pages without writing a line of code. You can view all your 
site elements or assets and drag them from an easy-to-use panel directly into a 
document. Streamline your development workflow by creating and editing images 
in Macromedia Fireworks, then importing them directly into Dreamweaver, or by 
adding Flash objects you create directly in Dreamweaver. 

Dreamweaver is fully customizable. Use Dreamweaver to create your own 
objects and commands, modify keyboard shortcuts, and even write JavaScript 
code to extend Dreamweaver capabilities with new behaviors, Property inspectors, 
and site reports.
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System requirements
The following hardware and software is required to run Dreamweaver. 

For Microsoft Windows: 

• An Intel Pentium processor or equivalent, 166 MHz or faster, running 
Windows 95, Windows 98, Windows 2000, Windows ME, or Windows NT 
(with Server Pack 3)

• Version 4.0 or later of Netscape Navigator or Microsoft Internet Explorer

• 32 MB of random-access memory (RAM) plus 110 MB of available disk space

• A 256-color monitor capable of 800 x 600 pixel resolution 

• A CD-ROM drive

For the Macintosh:

• A Power Macintosh running Mac OS 8.6 or 9.x

• 32 MB of random-access memory (RAM) plus 135 MB of available disk space

• A 256-color monitor capable of 800 x 600 pixel resolution

• A CD-ROM drive

Installing Dreamweaver
Follow these steps to install Dreamweaver on either a Windows or a 
Macintosh computer.

To install Dreamweaver:

1 Insert the Dreamweaver CD into the computer’s CD-ROM drive.

2 Choose from the following options:

• In Windows, choose Start > Run. Click Browse and choose the Dreamweaver 4 
Installer.exe file on the Dreamweaver CD. Click OK in the Run dialog box to 
begin the installation.

• On the Macintosh, double-click the Dreamweaver Installer icon.

3 Follow the onscreen instructions.

4 If prompted, restart your computer.
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Learning Dreamweaver
Macromedia Dreamweaver includes a variety of resources to help you learn the 
program quickly and become proficient in creating your own Web sites and pages. 
These resources include a printed book, online help pages, Guided Tour movies, 
a tutorial, and interactive lessons. You can also find regularly updated tips, 
TechNotes, examples, and information at the Dreamweaver Support Center on 
the Macromedia Web site.

Start by viewing the Guided Tour movies to learn about Dreamweaver features. 
Next, complete the Dreamweaver tutorial. Finally, try the Dreamweaver lessons to 
learn how to accomplish specific tasks in Dreamweaver.

Guided Tour movies

The Guided Tour movies provide an animated overview of the Web development 
process and take you through a tour of Dreamweaver features. 

To view a Guided Tour movie, choose Help > Guided Tours and click one of the 
movie titles. When each movie is over, click the Home button to return to the list 
of movies, then click another movie. You can watch the whole tour or skip ahead 
to see particular sections. 

Tutorial

The Dreamweaver tutorial is the best place to start if you want to get some hands-
on experience creating pages in Dreamweaver. By working through the tutorial, 
you’ll learn how to create a sample Web site with some of the most useful and 
powerful features of Dreamweaver. The tutorial is in both Dreamweaver Help and 
the Using Dreamweaver book. You can also download a printable version of the 
tutorial at the Macromedia Web site.

The tutorial includes sample pages and assets (images and Macromedia Flash files) 
to help you get started developing a Web site. 

Dreamweaver lessons

Dreamweaver comes with a set of interactive lessons. Each lesson takes you 
through the steps of a specific task and includes sample pages that contain all the 
design and functional elements needed. Use the lessons as step-by-step guides with 
the sample pages, or as a guide as you work in your own pages.

To locate the lessons, choose Help > Lessons and select a topic.
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Dreamweaver user guide (printed book)

Using Dreamweaver provides a printed alternative to Dreamweaver Help, and 
contains information on using Dreamweaver commands and features. Certain 
reference topics about program options are not included in the printed book; see 
Dreamweaver Help for information on those topics.

If you purchased the Electronic Software Download (ESD) version of 
Dreamweaver, you can download a printable version of Using Dreamweaver from 
the Dreamweaver Support Center at http://www.macromedia.com/support/
dreamweaver/documentation.html.

Dreamweaver Help 

Dreamweaver Help provides comprehensive information about all Dreamweaver 
features, optimized for use online. 

For best results viewing Dreamweaver Help, use Netscape Navigator 4.0 or later 
or Microsoft Internet Explorer 4.0 or later.

Dreamweaver Help makes extensive use of JavaScript. Make sure that JavaScript is 
enabled in your browser. If you plan to use the search feature, make sure that Java 
is enabled as well. 
Introduction14



                   
Dreamweaver Help includes the following components:

Contents enables you to see all of the information organized by subject. Click 
top-level entries to view subtopics. 

The index, like a traditional printed index, can be used to find important terms 
and go to related topics.

Search allows you to find any character string in all topic text. The search feature 
requires a 4.0 browser with Java enabled.

Note: When you click Search, a Java security window may appear, asking for permission 
to read files on your hard disk. You must grant this permission for the search to work. The 
applet does not write anything to your hard disk, nor does it read any files outside 
Dreamweaver Help.

• To search for a phrase, simply type the phrase in the text field. 

• To search for files that contain two keywords (for example, layers and styles), 
separate the search terms with a plus (+) sign.
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Context-sensitive help provides a Help button in each dialog box, or a question 
mark icon in inspectors, windows, and panels, that opens a relevant help topic. 

The Dreamweaver Help navigation bar provides buttons you can click to move 
through topics. The right and left arrow buttons move to the previous or next 
topic in a section (following the topic order listed in the table of contents).

Extending Dreamweaver

The Extending Dreamweaver help system provide information on the 
Dreamweaver Document Object Model and the APIs (application programming 
interfaces) that allow JavaScript and C developers to create objects, commands, 
property inspectors, behaviors, and translators.

Dreamweaver Support Center

The Dreamweaver Support Center Web site is updated regularly with the latest 
information on Dreamweaver, plus advice from expert users, examples, tips, 
updates, and information on advanced topics. Check the Web site often for the 
latest news on Dreamweaver and how to get the most out of the program at 
http://www.macromedia.com/support/dreamweaver/.

Dreamweaver discussion group

Discuss technical issues and share helpful hints with other Dreamweaver 
users by visiting the Dreamweaver discussion group. You’ll find information 
about accessing the discussion group on the Macromedia Web site at 
http://www.macromedia.com/software/dreamweaver/discussiongroup/. 

Click here to open Help
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Web development workflow
The Web development workflow starts with the process of defining a site’s strategy 
or goals, progresses to design (where you work out the look and feel of a 
prospective site), and moves into the production or development phase (where 
the site is built and pages are coded); the site is tested for functionality and to see 
if it meets its defined objectives, and then the site is published. Many developers 
also schedule periodic maintenance to ensure that the site remains current 
and functional. 

To make it easier for you to find the information you need as you develop Web 
sites, the Using Dreamweaver documentation is divided into broad sections that 
model this standard approach to Web development—site planning, design, 
development, testing, and publishing and maintenance.

About site Planning

Planning and organizing your site carefully from the start can save you time later 
on. Organizing your site includes much more than determining where the files 
will go: site planning often involves examining site requirements, audience 
profiles, and site goals. Additionally, you should consider technical requirements 
such as user access, and browser, plugin or download restrictions. 

Once you’ve organized your information and determined an operating structure, 
you begin creating your site. 

• Determine what strategy to employ and user issues to consider as you plan your 
site. See “Planning and Setting Up Your Site” on page 95.

• Use the Dreamweaver site map to set up your site’s organizational structure. In 
the Dreamweaver Site window you can easily add, delete, and rename files and 
folders to change the organization as you need. See “Site Management and 
Collaboration” on page 107.

If you work on a Web Development team, you may also be interested in 
these topics:

• Set up systems that will prevent team members from overwriting files; see 
“Setting up the Check In/Check Out system” on page 132.

• Use Design Notes to communicate with Web team members; see “Saving file 
information in Design Notes” on page 135.
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About designing Web pages

Most Web design projects start with storyboards or flowcharts that are turned 
into sample pages. Use Dreamweaver to create mock-up sample pages as you 
work toward a final design. Mock-ups usually show the design layout, site 
navigation, technical components, themes and color, and graphic images or 
other media elements. 

• Create HTML documents in Dreamweaver, easily add page title, or 
background color. See, “Setting Up a Document” on page 149.

• Dreamweaver Layout view and layout tools let you quickly design Web pages 
by drawing and then rearranging the page structure. See, “Designing Page 
Layout” on page 167.

• Use the Dreamweaver Objects panel to design and quickly add tables, create 
frame documents, design forms, and work with layers. See “Using Tables to 
Present Content” on page 183, “Using Frames” on page 203, “Using Dynamic 
Layers” on page 407, and “Creating Forms” on page 481. 

About adding content

Using Dreamweaver, you can easily add a variety of content to Web pages. Add 
assets and design elements, such as text, images, colors, movies, sound, and other 
forms of media. 

• The Assets panel lets you easily organize the assets in a site; you can then drag 
most assets directly from the Assets panel into a Dreamweaver document. See 
“Managing and Inserting Assets” on page 221. 

• Type directly in a Dreamweaver document, or import text from other 
documents, then format the text using the Dreamweaver Property inspector, or 
HTML Styles panel. You can also easily create your own Cascading Style 
Sheets. See “Inserting and Formatting Text” on page 233. 

• Insert images, including rollover images, image maps, and Fireworks sliced 
images. Use alignment tools to position images in a page. See “Inserting 
Images” on page 267 and “Using Dreamweaver and Fireworks Together” on 
page 281.

• Insert other types of media in a Web page, such as Flash, Shockwave, and 
QuickTime movies, sound, and applets. See “Inserting Media” on page 297.

• Add content in the Dreamweaver code editor: Use the Dreamweaver Code 
view or Code inspector to write your own HTML or JavaScript code. “Editing 
HTML in Dreamweaver” on page 321.
Introduction18



• With Dreamweaver you can create standard HTML links, including anchor 
links and e-mail links, or easily set up graphical navigation systems, such as 
jump menus and navigation bars. See “Linking and Navigation” on page 353.

• Dreamweaver templates and library files let you easily apply reusable content in 
your site. You can create new pages from the template, then add or change 
content in the editable areas. See “Reusing Content with Templates 
and Libraries” on page 375.

About interactivity and animation

Many Web pages are static, containing only text and images. Dreamweaver allows 
you to go beyond static pages, using interactivity and animation to capture 
visitors’ interest. You can give visitors feedback as they move and click, 
demonstrate concepts, validate form data without contacting the server—in short, 
you can let visitors see and do more within the page.

There are several ways to add interactivity and animation to your pages 
using Dreamweaver:

• Use timelines to create animations that do not require plugins, ActiveX controls, 
or Java. Timelines use dynamic HTML to change the position of a layer or the 
source of an image over time or to call behavior actions automatically after the 
page has loaded. See “Using Dynamic Layers” on page 407.

• Use behaviors to perform tasks in response to specific events, such as highlighting 
a button when the visitor passes the pointer over it, validating a form when the 
visitor clicks the Submit button, or opening a second browser window when the 
main page is finished loading. See “Using Behaviors” on page 435.

• Debug custom JavaScript code. See “Debugging JavaScript Code” on page 473.

• Use forms to allow your site visitors to enter data directly on the Web page. See 
“Creating Forms” on page 481.
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About testing and publishing your site

Your site is complete and ready for the world—but before you publish it on a 
server, you must test the site. Depending on the size of the project, client 
specifications, and kinds of browsers that visitors will use, you may need to move 
your site to a staging server where it can be tested and edited. When corrections 
have been made, you publish the site where the public can access it. Once the site 
is published, establish a maintenance cycle to ensure quality, respond to user 
feedback, and update the site’s information.

Use the following Dreamweaver features to test and publish your sites: 

• To add new tags in a page or fix your code, use the Dreamweaver Reference 
panel to look up JavaScript, CSS and HTML code. See “Using the 
Dreamweaver Reference panel” on page 328. 

• Use the JavaScript Debugger to help you fix JavaScript errors in your code. 
The debugger lets you set breakpoints in the code, then allows you to view the 
code as a page is debugged right in Dreamweaver. See “Debugging JavaScript 
Code” on page 473.

• Run browser and plugin checks, test and fix links in your documents, and run 
site reports to check HTML files for common mistakes. See “Testing and 
Publishing a Site” on page 501.

• In the Dreamweaver Site window you’ll find many tools to help you manage your 
site, transfer files to and from a remote server, set up a Check In/Check Out 
process to prevent files from being overwritten, and synchronize the files on your 
local and remote sites. See “Site Management and Collaboration” on page 107.

Where to start
This guide includes information for readers at a variety of levels. To get the most 
out of the documentation, start by reading the parts that are most relevant to your 
level of experience.

For HTML novices:

1 Begin by watching the Guided Tour movies. From the Dreamweaver main 
menu, choose Help > Guided Tours.

2 Next, work through the Dreamweaver tutorial. Choose Help > Tutorial, or 
follow the steps in the printed manual.

3 Work through the lessons for the topics that interest you. Choose Help > 
Lessons, then select a lesson.
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4 Progress through “Dreamweaver Basics” on page 71, “Planning and Setting Up 
Your Site” on page 95, “Site Management and Collaboration” on page 107, and 
“Linking and Navigation” on page 353.

5 To learn about formatting text and including images in your pages, read “Inserting 
and Formatting Text” on page 233 and “Inserting Images” on page 267.

That’s all you really need to begin producing high-quality Web sites, but when 
you’re ready to learn how to use more advanced layout and interaction tools, you 
can proceed through the rest of the book in order. You may want to skip 
“Customizing Dreamweaver,” at least at first.

For experienced Web designers who are new to Dreamweaver:

1 Begin by watching the Guided Tour movies. From the Dreamweaver main 
menu, choose Help > Guided Tours.

2 Work through the Dreamweaver tutorial to learn the basics of using 
Dreamweaver. Choose Help > Tutorial, or follow the steps in the 
printed manual.

3 Work through the lessons for the topics that interest you. Choose Help > 
Lessons, then select a lesson.

4 Read “Dreamweaver Basics” on page 71 for a further overview of the 
Dreamweaver user interface.

5 Although much of the material in “Site Management and Collaboration” on 
page 107 and “Linking and Navigation” on page 353 is probably familiar to 
you, skim those chapters to see how these familiar concepts are implemented in 
Dreamweaver; pay particular attention to Using Dreamweaver to set up a new 
site. Then read “Site Management and Collaboration” on page 107.

6 “Inserting and Formatting Text” on page 233 and “Inserting Images” on page 
267 provide useful information on the details of using Dreamweaver to create 
basic HTML pages.

7 Read the overview at the beginning of each subsequent chapter to determine 
whether its topics are of interest to you.

For experienced Web designers who are familiar with Dreamweaver 3:

1 Begin by reading “What’s new in Dreamweaver 4” on page 22. Follow the 
cross-references from that section to sections covering new Dreamweaver 
features. 

2 You may want to skim “Dreamweaver Basics” on page 71 to learn about new 
aspects of the Dreamweaver user interface.

3 Check out the Dreamweaver lessons; choose Help > Lessons for a list of 
interactive lessons you can try.

4 If you’re interested in customizing and extending Dreamweaver, read 
“Customizing Dreamweaver” on page 513.
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Typographical conventions
The following typographical conventions are used in this guide:

• Code font indicates HTML tag and attribute names as well as literal text 
used in examples.

• Italic code font indicates replaceable items (sometimes called 
metasymbols) in code. 

• Bold roman text indicates text for you to enter verbatim.

What’s new in Dreamweaver 4
The new features in Dreamweaver 4 enhance HTML editing, make it easier to 
design pages, improve site and asset management, let you create your own Flash 
objects, streamline your workflow, improve team collaboration, and allow you to 
customize and extend Dreamweaver. 

Enhanced code editing

The Dreamweaver toolbar allows you to manage how you view a page—Design 
view, Code view, or a view of both code and design. The toolbar provides easy 
access to commonly used features such as Preview in Browser and Design Notes. 
See “Using the toolbar” on page 78

Code view provides a new way to view HTML source code directly in the 
Dreamweaver Document window. See “Opening the Code view (or Code 
inspector)” on page 331. You can also edit non-HTML documents such as 
JavaScript files and XML files directly in the Dreamweaver Code view. See 
“Inserting scripts” on page 335. 

Integrated code editors Dreamweaver now has integrated, state-of-the-art code 
editors—the Code view and the Code inspector. You can set word wrapping, code 
indenting, live syntax coloring, and more from the Options menu in either of 
these editors. See “Setting Code view (or Code inspector) options” on page 333.

The Reference panel is a quick reference tool for HTML, JavaScript, and CSS. It 
provides information about the specific tags you are working with in the Code view 
(or Code inspector). See “Using the Dreamweaver Reference panel” on page 328.

The Code Navigation pop-up menu allows you to select code for JavaScript 
functions in a page; by using this menu, you can quickly navigate JavaScript code 
while working in Code view. See “Viewing script functions” on page 337.

The JavaScript Debugger lets you debug JavaScript document while in 
Dreamweaver. For example, you can set breakpoints to control the code you want 
to examine. See “Debugging JavaScript Code” on page 473.
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Easier page design

Layout view lets you quickly design your Web pages by drawing boxes (tables or cells) 
to which you can add content. See “Drawing layout cells and tables” on page 170.

Improved templates make it easier for you to identify the editable regions in a 
template file. Templates now display a tab that contains the editable region’s name 
and a bounding rectangle. See “Creating templates” on page 377.

CSS style sheets can now be defined as soon as you create a new style. You can 
also easily attach an existing CSS style sheet with a button in the CSS Styles panel. 
See “Using CSS style sheets” on page 248.

Improved integration

Flash buttons and Flash text are now built right into Dreamweaver. You can pick 
from a set of predefined Flash buttons and insert them into your document or 
have your Flash designer create custom button templates for you. See “Using Flash 
button objects” on page 301 and “Using Flash text objects” on page 304.

Roundtrip slicing lets you work seamlessly between Dreamweaver and Fireworks 4. 
You can edit and update images and HTML tables you import from Fireworks. 
You can also edit in Dreamweaver or Fireworks and have the changes preserved in 
both places. See “Editing Fireworks files placed in Dreamweaver” on page 288.

The Web-safe color picker allows you to easily match colors with graphics. With 
just one click, you can select a color from anywhere on the desktop and the color 
picker snaps to the nearest Web-safe color. See “Working with colors” on page 87.
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Streamlining your workflow

The Assets panel allows you to manage your site’s assets. You can see all the 
images, colors, external URLs, and scripts, as well as Flash, Shockwave, 
QuickTime, template, and library items in a central location. Preview assets, and 
then drag them right into place on your HTML document. Save commonly used 
assets in a favorites list and reuse them across sites. See “Using the Assets panel” on 
page 222 and “Using favorite assets” on page 229.

Improved Design Notes let you attach notes to a file so you can track changes or 
communicate about development issues with other members of your team. You can 
insert and view comments directly in the Dreamweaver Site window. See “About 
Design Notes” on page 134 and “Using reports to improve workflow” on page 141.

Integrated e-mail allows you to communicate with team members. When a file is 
checked out by someone else, you can now click on the team member’s name to send 
an e-mail message. See “Setting up the Check In/Check Out system” on page 132. 

Site reporting lets you use several predefined reports to test common HTML 
document problems, such as untitled documents or missing alt tags. You can also 
write custom reports to suit your needs, display report results, and open problem 
files within the Report results window. See “Setting up the Check In/Check Out 
system” on page 132 and “Creating reports” on page 510.

SourceSafe integration If you own SourceSafe, you can now check files into and 
out of SourceSafe while working in Dreamweaver. See “Using Dreamweaver with 
Visual SourceSafe” on page 128.

WebDAV integration now use Dreamweaver to transfer files using the WebDAV 
protocol. See “Using Dreamweaver with the WebDAV protocol” on page 127.

The Package Manager (formerly the Extension Manager) easily install extensions 
with a single click. Visit the Macromedia Exchange and download useful extensions 
to make your job easier. See “Adding extensions to Dreamweaver” on page 93.

Common user interface

Keyboard shortcuts have a new interface that is common to all Macromedia Web 
publishing products. This new interface allows you to edit existing keyboard 
shortcuts, create new shortcuts for menu items, and delete keyboard shortcuts you 
don’t want. You can also switch between sets of keyboard shortcut configurations. 
See “Using the Keyboard Shortcut Editor” on page 90.

Window management is now improved: all windows snap into place. When you 
open a new window, Dreamweaver prevents it from overlapping visible panels.

Panels now have a new Macromedia look and behave consistently across the Web 
publishing products. All panels have icons and text so that you can easily identify 
them. Panels all use system colors and fonts on both Windows and Macintosh 
systems, and have consistent snapping and dragging behaviors. 
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HTML and Web technologies resources
The following are some useful resources available on the Web:

The HTML 4.0 specification (http://www.w3.org/TR/REC-html40/) is the official 
specification for HTML from the World Wide Web Consortium.

Index DOT HTML (http://www.blooberry.com/indexdot/html/) is a comprehensive 
listing of HTML tags, attributes, and values, as well as their compatibility with 
the various browsers.

The ZDNet Developer Tag Library (http://www.zdnet.com/devhead/resources/
tag_library/) is another listing of information about all HTML tags.

The Cascading Style Sheets, level 1 specification (CSS1) (http://www.w3.org/TR/
REC-CSS1) is the official specification for style sheets from the World Wide Web 
Consortium.

Web Review Style Sheets Reference Guide (http://webreview.com/guides/style/
style.html) explains what CSS styles are and which browsers they work in.

“CGI Scripts for Fun and Profit” (http://www.hotwired.lycos.com/webmonkey/
99/26/index4a.html) is an article from the Hotwired Webmonkey site on 
incorporating ready-made CGI (Common Gateway Interface) scripts 
into your pages.

The CGI Resource Index (http://www.cgi-resources.com/) is a repository of all 
things related to CGI, including ready-made scripts, documentation, books, and 
even programmers for hire.

The Common Gateway Interface site (http://hoohoo.ncsa.uiuc.edu/cgi/) includes 
an introduction to CGI.

Entities Table (http://www.bbsinc.com/iso8859.html) lists the entity names used 
in ISO 8859-1 (Latin-1).

The Dynamic HTML Events page (http://msdn.microsoft.com/workshop/author/
dhtml/reference/events.asp#om40_event) provides information about events in 
Microsoft Internet Explorer.

Microsoft ASP Overview pages (http://msdn.microsoft.com/workshop/server/
asp/ASPover.asp) provide information about Active Server Pages (ASP).

Sun JSP page (http://java.sun.com/products/jsp/) provides information about 
JavaServer Pages (JSP).

The PHP pages (http://www.php.net/) provide information about PHP: 
Hypertext Preprocessor.

Allaire ColdFusion product page (http://www.allaire.com/Products/ColdFusion) 
provides information about ColdFusion.
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The XML.com site (http://www.xml.com) provides information, tutorials, and tips 
about Extensible Markup Language (XML), as well as other Web technologies.

JavaScript Bible, by Danny Goodman (IDG Books), comprehensively covers the 
JavaScript 1.2 language. 

JavaScript: The Definitive Guide, by David Flanagan (O’Reilly & Associates), 
provides reference information for every JavaScript function, object, method, 
property, and event handler.

Accessibility and Dreamweaver
Macromedia supports the creation of great Web experiences that are accessible to 
everyone, including those with disabilities. We encourage the implementation of 
international standards to guide developers of accessible sites, including the 
guidelines offered by the World Wide Web Consortium (W3C). Many 
government policies on Web accessibility, including those of the United States, 
reference W3C guidelines. W3C guidelines on Web content encourage developers 
to adopt design and coding practices for accessibility, many of which are robustly 
supported by Macromedia products. For more information on W3C guidelines, 
please consult the Web Content Authoring Guidelines (http://www.w3.org/TR/
WAI-WEBCONTENT/full-checklist.html).

For the latest information on product features and resources that support 
accessible design, please see Macromedia's accessibility page (http://
www.macromedia.com/accessibility/).
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Dreamweaver Tutorial

The Dreamweaver tutorial walks you through the steps of building Web pages. 
You’ll learn how to use Macromedia Dreamweaver to define a local site, and you’ll 
use Dreamweaver panels and tools to create and edit Web documents. 

In this tutorial, you’ll create Web pages for Compass, a fictitious company that 
specializes in adventure travel. If you’re new to Dreamweaver, start at the 
beginning of the tutorial and work your way through the end. If you’re already 
familiar with Dreamweaver, you may want to start at “Use the Assets panel” on 
page 56; this section and those that follow it focus on new or changed features in 
Dreamweaver such as the Assets panel, Flash buttons and text, using a template, 
running a site report and adding a Design Note. 

The tutorial takes approximately one to two hours to complete, depending on 
your experience, and focuses on the following Dreamweaver tasks:

• Defining a local site

• Creating a page in Layout view 

• Inserting an image and a rollover image

• Working with tables in Standard view

• Creating a link to another document

• Inserting assets from the Assets panel

• Inserting Flash Text and Flash Button objects

• Creating and applying a template 

• Running a site report

• Adding a Design Note

Note: This tutorial demonstrates some features that are supported only in 4.0 or 
later browsers.
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Take a guided tour of Dreamweaver
Before you get started, watch the Guided Tour movies to familiarize yourself with 
the Web development process and with Dreamweaver features. 

1 In Dreamweaver, choose Help > Guided Tour.

2 Click a movie title. 

3 Close the movie when you finish. 

The Dreamweaver work area
Let’s start with a brief overview of the Dreamweaver work area.

• If you haven’t already launched Dreamweaver, double-click the Dreamweaver 
icon to launch it.

The Dreamweaver work area accommodates different styles of working 
and levels of expertise. When you launch Dreamweaver, the following work 
area items open: 

• The Document window displays the current document as you create and edit it.

• The Objects panel contains icons you click to insert objects in your document, 
and to change the way you work in a document.

Objects panel

Property inspector

Document window

Launcher barTag selector

Toolbar

Floating panel
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• Dreamweaver provides many floating panels, such as the HTML Styles panel and 
the Code inspector, which enable you to work with other Dreamweaver elements. 

• The Launcher bar contains buttons for opening and closing your most 
frequently used inspectors and panels. 

• The Property inspector displays properties for the selected object or text, and 
lets you modify those properties. (Which properties appear in the inspector 
depend on the object actively selected in the document.)

To open Dreamweaver windows, inspectors, and panels, use the Window menu. A 
check mark next to an item in the Window menu indicates that the named item is 
currently open (though it may be hidden behind other windows). To display an 
item that isn’t currently open, choose the item name from the menu or use its 
keyboard shortcut.

Working in Dreamweaver

Dreamweaver can display a document in three ways: in Design view, in Code 
view, and in a split view that shows both the design and code. (To change the view 
in which you’re working, select a view in the Dreamweaver toolbar.) By default, 
Dreamweaver displays the Document window in Design view. 

In addition, you can work with the Dreamweaver Design view in two different 
ways—in Layout view and Standard view. (You select these views in the View 
category of the Objects panel.) In Layout view you can design a page layout, insert 
graphics, text, and other media; in Standard view, in addition to inserting graphics 
text and media, you can also insert layers, create frame documents, create tables, 
and apply other changes to your page—options that aren’t available in Layout view.

How the tutorial files are arranged

Both the completed and partially completed HTML files used in this tutorial 
are in the Compass_Site folder in the Tutorial folder. Images and other associated 
files for the site are also in the Compass_Site folder. 

Each tutorial file has a meaningful name—for example, the HTML file that 
contains travel destination information is named Destinations.html. The partially 
completed files—which you’ll be working on—have names similar to their 
completed file counterparts, except they begin with DW4_; the partially 
completed version of Destinations.html, for example, is called 
DW4_Destinations.html. 
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Preview the completed Web site

Next, view pages in the completed Web site to get an idea of what you’ll be 
working toward. 

1 If you haven’t already done so, launch Dreamweaver.

2 In Dreamweaver, choose File > Open. In the file browsing dialog box, navigate 
to the Dreamweaver 4 folder (where you installed Dreamweaver); then navigate 
to Tutorial/Compass_Site.

3 In the Compass_Site folder, select CompassHome.html, and then click Open 
to open the Compass home page in the Document window. 

Do not edit this page; you will create your own version of this page.

4 Choose File > Preview in Browser and select a browser in which to view the 
Compass home page. (Use a version 4.0 or later browser to view this site.)  

5 Move the pointer over the navigation buttons to see rollover image effects. 

Click the navigation buttons to explore the site. 

6 Close the browser when you’re finished looking at the site.

7 Open a new blank document in Dreamweaver, choose File > Open.

8 Close the CompassHome.html file, which is open in Dreamweaver.
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Set up the site structure for the tutorial
There are two ways you can work with the tutorial files—use a predefined local 
site or define a local site. 

• If you’re new to Dreamweaver, you may want to define the local site for the 
tutorial so you’ll know how to set up a local site when you’re ready to work on 
your own sites. 

• If you’re already familiar with defining a site using Dreamweaver, you may want 
to use the predefined tutorial site. From the Dreamweaver main menu 
choose Site > Open Site, then select Tutorial - Dreamweaver. The Tutorial - 
Dreamweaver site links to the Compass_Site files located in the Dreamweaver 
4/Tutorial folder. After selecting the local site, skip to the “Create the site home 
page” on page 34 section of the tutorial.

Note: If you select the predefined site, the site name displayed in the tutorial 
screenshots will not match; instead of seeing my_tutorial, you’ll see Tutorial - 
Dreamweaver as the site name in your screens.

Define a local site
When you define a local site, you tell Dreamweaver where you plan to store all the 
files for a particular site. To work effectively in Dreamweaver, always define a local 
site for each Web site you create. 

For this tutorial, you’ll specify the Compass_Site folder as the local site folder.

1 If it isn’t already open, launch Dreamweaver.

A blank document opens.

2 Choose Site > New Site.

3 In the Site Definition dialog box, make sure Local Info is selected in the 
Category list.

4 In the Site Name field, type my_tutorial.

The site name lets you easily identify and select a site from a list of sites 
you’ve defined. 

5 Click the folder icon to the right of the Local Root Folder field. 
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6 In the dialog box that appears, navigate to the Tutorial/Compass_Site folder, 
and do one of the following:

• In Windows, click Open, then click Select when Compass_Site appears in 
the Select field. 

• On the Macintosh, click Choose to select the Compass_Site folder. 

The Local Root Folder field updates to display the path to the local site. 

Note: The complete path to the Compass_Site folder may vary, depending on where 
you installed Dreamweaver.

7 Under Cache, do one of the following:

• Select Enable Cache (Windows) to create a cache file for the site.

• Select Use Cache to Speed Link Updates (Macintosh) to create a cache 
file for the site.

Caching the files in the Compass_Site folder creates a record of existing 
files so Dreamweaver can quickly update links when you move, rename, 
or delete a file.

8 Click OK to close the dialog box.
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9 Click OK to the cache message.

The Site window now displays a list of all the folders and files in the local site. 
The list also acts as a file manager, allowing you to copy, paste, delete, move, 
and open files just as you would on a computer desktop. 
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Create the site home page
Now that a site structure is set up for storing pages and assets for the Compass 
site, you’ll create the first page—a home page for the site. As you build this page, 
you’ll add images, text, and Flash assets; your document will contain the same 
design components as the completed Compass home page. 

Save your document

Begin by saving the document you’re working in. 

1 Leave the Site window open, and click the Document window to make 
it active.

The Site window remains open in the background.

2 Choose File > Save. 

3 In the Save As dialog box, select the Compass_Site folder as the location for 
this document.

4 In the File Name field, type my_CompassHome.html.

5 Click Save.

Notice that the document name now appears at the top of the Document window.
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Define the document page title

Though the document has a file name, notice it is still labelled Untitled 
Document; that’s because it needs an HTML document name, or page title. 
Defining a page title helps site visitors identify the page they’re browsing: the 
page title appears in the browser title bar and in the bookmark list. If you create 
a document without a page title, the document appears in the browser with the 
title Untitled Document. 

In this part of the tutorial, you’ll title your page.

1 With the Document window active, choose View > Toolbar if the toolbar isn’t 
already visible.

The Dreamweaver toolbar appears above the Document window

2 In the Title field, type Compass Home Page; then click in the Document 
window to see the page title update in the Document window’s title bar.

3 Save your file.

Design a page in Layout view
You’ll start your first page while working in the Dreamweaver Design view. You’ll 
lay out the page then insert images and text. 

The page you complete in this section of the tutorial will look similar to this page. 
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Work in Layout view 

Dreamweaver has two visual design views—Standard view and Layout view. You’ll 
start by working in Layout view, which allows you to draw layout cells or layout 
tables into which you can add content such as images, text, or other media. 

In this part of the tutorial, you’ll lay out the page; in the next section you’ll add 
content. (Once you’re comfortable with these two tasks, you may find it easier to 
add layout and content together.)

1 In the Objects panel, click the Layout View icon if it isn’t already selected. 

The Getting Started in Layout View dialog box appears and describes the 
Layout view options.

2 Review the options, then click OK to close the dialog box. 

3 In the Objects panel under Layout notice the Layout options—Draw Layout 
Cell and Draw Layout Table—are now available; these options aren’t available 
in Standard view.

Layout View icon

Draw Layout Cell icon

Draw Layout Table icon
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Draw layout cells

In Layout view you can draw layout cells and layout tables to define the design 
areas of a document. This task is easier to accomplish if you prepare a sample of 
the page you’re creating before you begin laying out a page.

Look at the following sample layout to get an idea of the page layout you’re 
creating in this section of the tutorial. There’s a cell for the Compass logo, a table 
with three cells for site navigation buttons, a cell for another graphic, and a table 
for three cells that will hold text.

You’ll draw tables and cells similar to this layout as you work in your document. 
First, you’ll draw a layout cell in which you’ll insert the Compass logo.

1 Click in the Document window of the my_CompassHome document to make 
the document active.

2 If they aren’t already open, open the following work area tools:

• The Objects panel (choose Window > Objects), which you’ll use to add objects 
to your document.

• The Property inspector (choose Window > Properties), which you’ll use to set 
properties or attributes for objects in your document. If the Property inspector 
isn’t already expanded, click the expander arrow in the lower right corner so 
you can see all the property options. 

3 In the Objects panel, click the Draw Layout Cell icon.
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4 Move the pointer to the Document window; the mouse pointer changes to a 
drawing tool (looks like a small cross). Click in the upper left corner of the 
document, then drag to draw a layout cell.

When you release the mouse, a layout cell appears in a layout table. 

The layout table expands to fill the Document window, and defines the page 
layout area. The white rectangle is the layout cell you drew. You can place 
additional layout cells in the gray area of the layout table. 

Resize layout cells

To precisely design a page, you can set the size of cells you add in a document. You 
can also reposition cells in the page.

1 Click the border of the layout cell to select it.

Handles appear around a selected layout cell:

Layout 
Table

Layout 
Cell
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2 To resize this layout cell, do one of the following: 

• In the Property inspector for the layout cell, type 510 in the Fixed field to set the 
cell’s width to 510 pixels, then click in the document to see the cell width change.

Note: If you enter a pixel width that is larger than the width of the layout table, or that 
causes the cell to overlap another cell in a layout table, Dreamweaver alerts you and 
adjusts the cell width to a valid width.

• On the right side of the layout cell, drag the middle resize handle to the right 
until the cell is the desired width. When you release the mouse, the cell’s width 
is displayed in the column header area along the top of the layout table.

Add multiple layout cells

Next you’ll add three layout cells below the logo cell you just created. Later you’ll 
insert the page’s navigation buttons in these cells. 

1 In the Objects panel, click the Draw Layout Cell icon; then hold down the 
Control key (Windows) or Command key (Macintosh). 

2 In the Document window, position the pointer below the cell you drew for the 
logo; then drag to draw a layout cell. 

Continue to hold the Control key (Windows) or Command key (Macintosh) 
and draw two more layout cells. Your screen should look similar to this. 
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Move a layout cell

If you need to line up the cells next to each other you can resize and move the 
layout cells as you need. You change the size of a layout cell by using one of its 
resize handles. 

You cannot click and drag a cell to move it to a new position. If you need to move 
a layout cell to reposition it in a document, follow these steps.

1 Click the border of a layout cell to select it.

2 To move the layout cell, do one of the following:

• Use the arrow keys. 

• Hold down Shift and use the arrow keys to move a layout cell 5 pixels at a time. 

Group cells in a layout table

Now you’ll create a table of the navigation button cells you just created. Grouping 
the cells in a table enables you to control the cell spacing and to easily move the 
cells as a group if you want change the page layout. You’ll create a table for the 
navigation buttons that is the same width as the logo cell above it. 

Use Draw Layout Table to group the navigation button images.

1 In the Objects panel, click the Draw Layout Table icon.

2 In the Document window, position the pointer at the top left corner of the first 
navigation button cell; then drag the pointer so the table contains the three 
cells and is the length of the logo cell.
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3 Release the mouse to see the cells grouped in a new table.

You’ve created a table that contains three layout cells (the white area in the 
table) and an empty space (the gray area in the table).

Move the layout table

You can select and move a layout table to other areas in a document. You cannot, 
however, move a layout table so that it overlaps another. 

Next you’ll move the table you just created a few pixels to the right to offset the 
alignment of the navigation buttons to the logo when they are inserted in the page.

1 In the Document window click the tab on the Layout table to move it.

2 Drag the layout table a few pixels to the right to reposition it, then drag one of 
the table’s right resize handles to align the right sides of the logo and navigation 
button layout cells.

Notice that as you create new tables and cells, gridlines appear outlining the 
layout area. You can use these gridlines to align the layout elements.
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Add another layout cell

Next add a layout cell for the Learn More About graphic.

1 In the Objects panel, click the Draw Layout Cell icon.

2 In the Document window, draw a new cell in the space below the navigation 
button table.

Your page should look similar to this:

Create a layout table

In the last section you used cells to create a table. Now, you’ll start with a table 
and add cells. 

1 In the Objects panel, click the Draw Layout Table icon.

2 Move the pointer to the Document window. In the area below the layout cell 
you just added, drag the pointer to the right to align with the right side of the 
topmost cell; then drag down to the bottom of the Document window. 
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Draw layout cells in a table

Now add layout cells into which you’ll add text about travel locations.

1 In the Objects panel, click the Draw Layout Cell icon and move the pointer to 
the layout table you just drew.

2 Draw a table cell approximately one-third the space in the table. 

3 Click the border of the layout cell to select it; then in the Property inspector’s 
Fixed field, type 170 to set the cells width.

4 Draw another table cell approximately one-third the space in the table next to 
the first cell. 

5 Click the border of the layout cell to select it; then in the Property inspector’s 
Fixed field, type 170 to set the cells width.

6 Draw the last table cell in the remaining space in the table. Resize or move the 
cells to adjust the size or position of the cells as needed.

Your screen should look similar to this: 
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Add content to the page
Now that you’ve laid out the areas of the page, you’ll add the graphical content, 
such as the logo, and rollover images.

Insert images

You’ll learn two ways to insert images in Dreamweaver—using Dreamweaver’s 
main menu and using the Objects panel. 

1 Click anywhere in the logo layout cell (the topmost layout cell). 

Clicking in a layout cell places the insertion point in the cell without 
selecting the cell.

2 Choose Insert > Image.

3 In the Select Image Source dialog box, locate the Compass_Site folder 
and navigate to the Assets folder, then the images folder; click the 
compass_logo.gif to select it.

4 Make sure the Relative To pop-up menu located at the bottom of the dialog 
box is set to Document, then click Select (Windows) or Open (Macintosh) to 
select the image. 

The image appears in the layout cell.

5 Click anywhere in the Learn More About layout cell to place the insertion 
point in the cell.

6 In the Objects panel’s Common category, click the Insert Image icon. 

7 In the Select Image Source dialog box, locate the Compass_Site/Assets/images 
folder, and navigate to learnMoreAbout.gif; then click Select (Windows) or 
Open (Macintosh) to select the image.

The image appears in the layout cell.

8 Choose File > Save to save the changes you made to the home page.
Chapter 144



Create a rollover image 

A rollover image is an image whose display changes when the pointer passes 
(“rolls”) over it. 

You’ll use the Insert Rollover Image command to create three rollover images for 
the navigation buttons—Trip Planner, Destinations, and Travel Logs.

A rollover image consists of two images: the image displayed when the page first 
loads in the browser, and the image displayed when the pointer moves over the 
original image. Be sure to use images that are the same size. The first image 
dictates the size of the display, so if the second image is much smaller or much 
larger, the results will look distorted or unprofessional.

Next, you’ll add a navigation button with a rollover image to your page. 
Then you’ll add the other navigation buttons and preview the page in a browser 
to test the rollovers.

1 In the Document window, click in the first cell of the navigation button table.

This tells Dreamweaver where you want the image inserted. 

2 To insert a rollover image, do one of the following:

• In the Common category of the Objects panel, click the Insert Rollover 
Image icon.

• Choose Insert > Interactive Image > Rollover Image.

3 In the Insert Rollover Image dialog box, type planner in the Image Name field.

This gives the image a unique name, and makes it easily identifiable in the 
HTML code.

4 In the Original Image field, click Browse; then navigate to 
MenuTripPlanner.gif and click Select (Windows) or Open (Macintosh). 

This tells Dreamweaver which image to display when the page first loads.

5 In the Rollover Image field, click Browse; then navigate to 
MenuTripPlanner_on.gif and click Select (Windows) or Open (Macintosh).

This tells Dreamweaver which image to display when the pointer is over 
the original image.
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6 Make sure the Preload Rollover Image option is selected so the rollover images 
load when the page loads in the browser, ensuring a quick transition between 
images when a user moves the pointer over the original image.

7 Click OK to close the dialog box.

The image appears in the document.

8 Resize the layout cell to fit the image.

Create the other rollover images

Now you’ll add rollover images for the other navigation buttons.

1 In the Document window, click in the second navigation button cell; then in the 
Common category of the Objects panel, click the Insert Rollover Image icon.

2 In the Insert Rollover Image dialog box, type destinations in the Image Name 
field to provide the image a unique name.

3 In the Original Image field, click Browse, then navigate to and select 
MenuDestinations.gif.

4 In the Rollover Image field, click Browse, then navigate to and select 
MenuDestinations_on.gif.

5 Make sure the Preload Rollover Image option is selected, then click OK to close 
the dialog box.

6 In the Document window, click in the third navigation button cell; then in the 
Objects panel’s Common category, click the Insert Rollover Image icon.

7 In the Insert Rollover Image dialog box, type travellog in the Image Name field 
to provide the image a unique name.

8 In the Original Image field, click Browse then navigate to and select 
MenuTravelLogs.gif. 

9 In the Rollover Image field, click Browse then navigate to and select 
MenuTravelLogs_on.gif.

10 Make sure the Preload Rollover Image option is selected, then click OK to close 
the dialog box.

11 Resize the two layout cells to fit the image.
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Preview your document

You cannot view rollover behavior in the Dreamweaver Document window; 
rollover images work only in a browser. However, you can preview the document 
in Dreamweaver to see its browser-related functions. You do not have to save the 
document before you preview it. 

1 Press F12 to see your document in a Web browser.

Move the mouse pointer over the rollover images you created to see them change. 

2 When you finish previewing the file, close the browser window.

3 Return to the Dreamweaver Document window and choose File > Save to save 
the changes you made to the home page.
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Insert text

Now you’ll add text in the cells of the bottom layout table. 

In Dreamweaver, you can type content directly into a layout cell, or you can cut 
and paste content from another document into a layout cell. In this tutorial, you’ll 
add text to the layout cell by copying and pasting content from an existing text file 
to a layout cell. 

1 Choose File > Open; then, in the Compass_Site folder, open 
DW4_HomeText.txt. 

The DW4_HomeText.txt document opens in a new Dreamweaver 
Document window. 

2 In DW4_HomeText.txt select the first two lines of text, “Fly Fishing” 
through “ravioli.”

3 Choose Edit > Copy to copy the text.

4 In the my_CompassHome document, click in the first layout cell in the text-
description layout table. 

5 Choose Edit > Paste to paste the text into the layout cell. 

6 In DW4_HomeText.txt select the next two lines of text, “Level 5 Rapids” 
through “Siberia.”

7 Choose Edit > Copy to copy the text.

8 In the my_CompassHome document, click in the second cell in the text 
description layout table. 

9 Choose Edit > Paste to paste the text into the layout cell. 

10 In DW4_HomeText.txt select the last two lines of text, “Puget Sound 
Kayaking” through “Puget Sound.”

11 Copy the text, then paste it in the third cell in the layout table.

12 Close DW4_HomeText.txt, then click in the my_CompassHome.html to 
make it the active document.

Format text

You can format text in the Document window by setting properties in the 
Property inspector. First, select the text you want to format, then apply the 
changes. You’ll change the font type and size of the text. 

1 If the Property inspector isn’t open, choose Window > Properties.

2 In the first text description layout cell, select all the text from the word “Fly,” 
through the last word “ravioli.”
Chapter 148



3 In the Property inspector’s second Format pop-up menu, which currently reads 
Default Font, select Verdana, Arial, Helvetica, sans-serif.

4 In the Size pop-up menu, select 2.

The text in your document automatically updates to reflect the changes.

5 Repeat the above steps to select and format the text in the other two text-
description layout cells.

Apply color and style

Now you’ll apply additional formatting changes to the text; you’ll apply color and 
style to create heading text.

1 In the first text description layout cell, select the heading text from the word 
“Fly,” through the word “Mountains.”

2 In the Property inspector, click the color picker; then move the eyedropper to 
the Learn More About image in the document window and select the brown 
color of the text in the image. 

3 Still in the Property inspector, click the B icon to apply bold style to the text.

4 Repeat the above steps to apply color and style to the heading text in the other 
text description layout cells.

5 Press F12 to preview your page in a browser.

Your page should look similar to the page below.

Notice the text. There is little separation between text in one layout cell and the 
next. You’ll fix that in the upcoming tutorial steps.

6 Close the browser window, then click in the Document window to 
make it active.
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Work in Standard view
Layout view is helpful for laying out Web pages. Though you can adjust most of 
your design elements in Layout view, certain changes must be completed in 
Standard view. When you switch to Standard view, you’ll see how Dreamweaver 
uses tables to create your page structure. The Layout tables in Layout view are 
<table> tags in Standard view.

Now you’ll learn how to work with tables to continue fine-tuning your design. 
First, you’ll switch to the Dreamweaver Standard view.

• In the Objects panel, click the Standard View icon.

Your page should look similar to the screen below.

Set cell properties

Cell height determines the height of the space within a cell row. Notice the space 
around the Compass logo. You want to remove the extra space between the logo 
and navigation buttons. 

1 Click anywhere in the blank area of the cell containing the Compass logo 
image (but not the image itself ).

2 In the cell Property inspector, in the H field (height), that currently contains a 
value, delete the value.

3 Still in the Property inspector, click the Bg color box icon located in the bottom 
area of the Property inspector; then use the eyedropper to select black.

The background color is applied to the cell.

4 Click anywhere in the Document window to see the change.
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Selecting a table

Next you’ll adjust the space in the navigation button table. The easiest way to 
select a table in Standard view is by using the tag selector, which displays HTML 
tags of elements in the document. 

You’ll use the tag selector to select the table containing the navigation buttons.

1 Click in the cell that contains the Trip Planner image. 

Notice the tag selector at the bottom left of the Document window.

Note: The tags in your tag selector may vary based on the number of tables you created 
while in Layout view.

2 In the tag selector, click the rightmost <table> tag.

In the Document window a border appears around the navigation button table, 
and the Property inspector now reflects properties for a table.

Set table properties

Now you’ll use the table Property inspector to clear the extra space in the 
navigation buttons table and to add a background color in the table.

1 In the Property inspector, click the Clear Row Heights icon. It’s the top left 
button in the lower half of the Property inspector. 

The extra space is removed from the table. 

2 Still in the Property inspector, click the Bg Color color box icon, then use the 
eyedropper to select the color black.

The black background color is applied to the navigation buttons table.
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Add cell padding

Next, you’ll make changes to the cells that contain text. As you can see, the text is 
too close the edges of the cells. You’ll add padding to the cells to leave room 
between the text and cells.

1 Click in the first cell in the text description table.

2 In the tag selector, click the rightmost <table> tag to select the table. 

3 In the Property inspector’s CellPad field, type 10 to add 10 pixels of space 
between the text and the table cells.

4 Click anywhere in the Document window to see the changes.

5 Save your document.

View the site files

To see a high-level representation of the structure of a local site, you use the 
Dreamweaver Site Map view. You can also use the site map to add new files to the 
site; to add, remove, and change links; and to create a graphic file of the site that 
you can export to and print from an image-editing application. 

The site map always displays the home page for a site at the top of the map; below 
the home page you can see which files the home page links to. 

There are a number of ways to define a site’s home page. The easiest way to set a 
home page is by using the context menu within the Site window.

1 Click the title bar of the Site window to make it active. (If the Site window is 
not visible, choose Window > Site Files.)

2 In the Site window’s Local Folder list, right-click (Windows) or Control-click 
(Macintosh) the my_CompassHome.html document; then in the context 
menu, choose Set as Home Page.

3 Click the Site Map icon in the top left area of the Site window; then in the Site 
Map pop-up menu, select Map and Files. 

Site Map icon
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The Site window now appears with two views of your local site: on the left is a site 
map, which graphically represents the current structure of the Compass site (with 
my_CompassHome.html as the home page), and on the right is a list of the local 
folder’s contents. 

The my_CompassHome.html page currently has no links. You’ll add links to this 
page in the next section of this tutorial.

Leave the Site window open for now, so you can see how the site map updates as 
you add links to the home page.
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Link your documents

Images in the top area of the Compass home page guide visitors to specific pages 
in the site. Now you’ll add links for the navigation buttons. 

You’ll see that there are a number of ways to create links using Dreamweaver. First, 
you’ll add a link from the Trip Planner image to the TripPlanner.html page using 
the Property inspector.

1 In the Site window, double-click the icon for the my_CompassHome.html file 
in either pane. 

The my_CompassHome.html file becomes the active window.

2 In the Document window, click the Trip Planner image once to select it. 

3 Choose Window > Properties to open the Property inspector if it isn’t 
already open. 

The Property inspector displays information about the selected image. 

Note: The Link field contains a number sign (#), often referred to as a null or “dummy” 
link, created when you inserted the rollover image. Don’t remove this character. It will 
soon be replaced with the file name of the document you link to.

4 In the Property inspector, click the folder icon to the right of the Link field.

5 In the Select File dialog box, browse to the Compass_Site folder and then to 
DW4_TripPlanner.html; click Select (Windows) or Open (Macintosh) to 
select the file to open when the Trip Planner button is clicked.

The file name appears in the Link field of the Property inspector. Now 
you’ll add a link to the Destinations image using the Property inspector and 
the Site window.

6 Click the title bar of the Site window to make it active, or choose Window > 
Site Files. Resize your Document window, if necessary, so that you can position 
the left side of the Document window and the Site window side by side.

7 In the Document window, click the Destinations image to select it.
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8 In the Property inspector, click the Drag to File icon (located to the right of the 
Link field), then drag the pointer to the Site window; in the Local Folder List, 
point to the file DW4_Destinations.html. 

The file name appears in the Link field in the Property inspector for the 
products image. 

9 Click the Site Map icon in the Site window. The site map updates to reflect the 
link you added. 

A plus (+) sign next to any file in the site map indicates that the file contains 
links to other documents. Click the plus sign to expand the site map to display 
the associated files; click the minus (–) sign to collapse the site map.

Next, you’ll add a link for the Travelogs image. 

10 In the Document window, click the Travelogs image to select it.

11 In the Property inspector, drag the Point-to-File icon to the Site window, and 
point to the file DW4_Travelog.html. 

12 Choose File > Save to save the changes you’ve made to the home page.
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Test your page

You can’t test your links in Dreamweaver, you must check your links in a browser 
to make sure the pages operate as you expect. 

1 Press F12 to preview the page in a browser.

Click the navigation buttons to check your links. Click your browser’s back 
button to return to your home page.

2 When you’re finished testing your page, choose File > Close to close the page.

Use the Assets panel
The Assets panel lets you view your site assets such as images, HTML colors, 
links, Flash movies, other types of movies, scripts, templates, and library items. 
You can view all your site assets in one place and then easily add content to your 
page directly from the panel. 

Now you’ll learn how to use the Assets panel to add assets to a page. 

Select a new document

So you don’t need to create additional tables in your home page, this tutorial 
includes an HTML file that is similar to the home page you created; it includes a 
new table cell on the right side of the document. 

To start this part of the tutorial do one of the following:

• If you’re continuing the tutorial from the previous section, choose File > Open 
then select DW4_CompassHome2.html.

• If you’re starting the tutorial in this section, choose Site > Open Site, then in 
the Sites list select Tutorial - Dreamweaver to open a defined site. In the 
Document window’s main menu choose File > Open; in the dialog box that 
appears, select DW4_CompassHome2.html.

The DW4_CompassHome2.html file opens.
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View site assets

Begin by opening the Assets panel.

1 Open the Assets panel by doing one of the following:

• Choose Window > Assets.

• Click the Show Asset icon in the Launcher Bar. 

The Assets panel appears. 

Assets preview area

Asset options
Dreamweaver Tutorial 57



Insert an image 

You’ll start by using the Assets panel to insert two images in the page—a rock 
climber image and a text image.

1 In the Assets panel, click the Images icon and make sure the Site radio button 
located at the top of the Assets panel is selected so you can view all of the 
images in the Compass site.

2 In the Names list, select the image icon for climber.jpg then drag it to the 
middle table cell in the right side of the page. 

3 Press the right arrow key (this deselects the climber image and places the 
insertion point after the image), then press Shift+Enter (Windows) or 
Shift+Return (Macintosh) to insert a line break.

4 In the Name list, select featureText.gif then drag it to the line break you just 
created placing the featureText image under the climber image.

Insert a Flash movie

Now you’ll add a different type of asset. You’ll drag a Flash movie into the cell 
below the navigation buttons.

1 Click the Flash icon in the Assets panel to view all the Flash files in the 
Compass site.

2 In the Names list, click welcome.swf to select the Flash movie you’re inserting 
in the document.

In the Assets panel’s preview area you see a placeholder for the Flash movie.
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3 Click the Play button in the Assets panel’s preview area to view the Flash movie. 

4 In the Names list, drag the Welcome.swf to the cell below the Trip Planner 
navigation button.

A Flash move placeholder appears in the selected cell. 

Apply a color using the Assets panel

Colors you apply to HTML elements, such as to text or as a background color, 
are automatically added to the color category of the Assets panel. You can select 
a color from the Assets panel and apply it to text in the same page or to other 
pages in your site.

1 Place the insertion point after the rock climber image, then press Enter 
(Windows) or Return (Macintosh) to add a new paragraph, then type Yosemite.

2 Double-click Yosemite to select the text.

3 In the Assets panel, click the Colors icon to view HTML colors in the 
Compass site.

4 In the Value list, select the color icon for #993300 then drag it to the selected 
text to apply the color.

Create a favorite assets list

Use the Assets panel to manage your assets. You can create your own group of 
favorites assets in the Assets panel. Next, you’ll add the Compass logo and 
navigation button image to your site Favorites list. 

1 In the Assets panel, select the Images icon. 

2 In the Name list, click compass_logo.gif to select it, then do one of the 
following:

• Right-click (Windows) or Control-click (Macintosh) to use the context menu, 
then select Add to Favorites.

• Click the Add to Favorites icon located in the lower right of the Assets panel.

You are alerted that the selected asset was added to your site’s Favorites list.

3 Click OK.

Play button
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Add multiple images to favorites

Now, you’ll add the navigation button images to the favorites list. You can select 
multiple images in the Assets panel, then add them to your favorites at one time.

1 In the Assets panel’s Images list click the first navigation button image 
(MenuDestinations.gif ).

2 Select the other navigation buttons by doing one of the following:

• Press Shift (Windows) and in the Images list click MenuTripPlanner_on.gif (the 
last navigation button in the list) to select all of the navigation button images.

• Press Shift (Macintosh) and hold it while you select each of the navigation 
button images.

3 Click the Add to Favorites icon.

4 Click OK to the alert message.

View favorite assets

You can view the assets you’ve added to your Favorites list, and use this view for 
inserting assets in your document. 

To view images you’ve added to the Favorites list, click the Favorites radio button 
at the top of the Assets panel.

Insert Flash objects
Flash objects are small graphic SWF (Shockwave) files you can create while working 
in Dreamweaver. You can create Flash Text and Flash Button objects. Using Flash 
Text allows you to design Web pages that use nonstandard fonts without worrying 
about which fonts visitors to your site have available on their computers. Flash 
buttons are created from Flash templates that ship with Dreamweaver. You can 
easily customize a template button and add it to your Web pages.
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Create a Flash Text object

Now you’ll create a Flash Text object to use as a title in your home page.

1 In the Document window, place the insertion point above the image of the 
rock climber. 

2 In the Object panel, click the Insert Flash Text icon. 

The Insert Flash Text dialog box appears.

3 In the Insert Flash Text dialog box, set the following options:

• For Font, select Verdana or choose one of your favorite fonts. 

• For Size, type 18.

• For Color, click the color box, then use the eyedropper to select brownish color 
of the heading text in the document. 

• For Rollover Color, click the color box; then move the eyedropper to the 
Document window and select the gold color in the table’s background.

• In the Text field, type Featured Destination.

• In the Save As field, type myText.swf.

4 Click OK to close the Insert Flash Text dialog box.
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View the Flash Text object in the document

The Flash Text object appears in the document. You must play the Flash object to 
see the text with its rollover effect.

1 If it isn’t already expanded, in the Property inspector click the expander 
arrow to see all.

2 In the Flash Text Property inspector, click Play.

3 In the Document window, roll the pointer over the Flash Text object.

4 To stop playing the object, click Stop in the Property inspector.

Create a Flash button object

Now you’ll see how easy it is to add a Flash button to a document. You’ll create a 
Flash button, and add it below the climber image.

1 In the Document window, place the insertion point where you want the object 
to appear, below the image of the rock climber, then in the Objects panel, click 
the Insert Flash Button icon. 

The Insert Flash Button dialog box appears.
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2 In the Insert Flash Button dialog box, set the following options:

• In the Style list, select Beveled Rect-Bronze. 

• For Button Text, type More Details. 

• For Font, select Verdana, or choose one of your favorite fonts. 

• For Size, type 11. 

• Click Apply to see the Flash button in the document. 

• In Save As, type myButton.swf 

3 Click OK to close the dialog box.

The Flash Button object appears in the document.

View the Flash button in the document

The Flash button you inserted has a rollover effect, now you’ll play the button to 
see how it looks.

1 In the Flash button Property inspector, click Play to play the button in 
the document.

2 In the Document window, roll the pointer over the object to see the Flash 
button’s rollover effect.

3 To stop playing the object, click Stop in the Property inspector.

Create a template
You can use templates to create documents that have a common structure and 
appearance. Templates are useful when you want to make sure that all of the pages 
in a site share certain characteristics. 

Once you apply a single template to a group of pages, you can change information 
on the group of pages by editing the template and then reapplying it to those 
pages. While elements unique to each page (such as text describing an item for 
sale) remain unchanged, common template elements (such as navigation bars) are 
updated on all of the pages that use the template.

The Compass trip destination page links to several travel detail pages that describe 
places site viewers may be interested in traveling to. You’ll use the design of an 
existing travel detail page to create a template. Using a template ensures that your 
travel information pages will have an identical layout and format. 
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Create a template from an existing page

In this section, you’ll create a template from an existing travel page and then use 
the template to create a new travel page. 

1 In the Site window’s Local Folder list, double-click the icon for 
DW4_TravelDetail_surf.html to open the file.

2 Choose File > Save as Template.

The Save As Template dialog box appears.

The existing templates, travelDetail and travelDetail_v2, were created for and 
applied to the completed Compass site travel pages. You’ll create your own 
version of this template.

3 In the Save As field, change the template name: type myTravelDetail and 
click Save.

In the Document window a new document replaces the DW4_TravelDetail 
document. In the document title bar, notice the document contains a Template 
identifier <<Template>>, and a Dreamweaver template file extension (.dwt).

Modify the template

At this point, the new template is the same as the page from which you saved the 
template. A template contains both locked and editable regions. Locked regions 
can be edited only inside the template itself. Editable regions are placeholders for 
content that is unique to each page the template is applied to. In your template, 
the logo and navigation buttons aren’t editable; the destination’s title, related 
banner ad, and destination description are editable.

Your first step is to create editable regions in the template.

1 In the myTravelDetail.dwt template in the Document window, click the 
topmost Flash placeholder to select it; this movie displays the destination’s title. 
Chapter 164



2 Choose Modify > Templates > New Editable Region.

The New Editable Region dialog box appears.

3 In the Name field, type titleCell as the name for this region of the template.

4 Click OK.

A template region is created. Notice the tab that contains the template region’s 
name. The placeholder is also surrounded by a light-blue line that identifies the 
boundaries of the editable area. 

5 In the Document window, select the Flash banner placeholder, then choose 
Modify > Templates > New Editable Region to make this an editable region in 
the template. 

6 In the Name field in the New Editable Region dialog box, type adCell and 
then click OK.

The template area identifiers appear in the document.

7 In the Document window, select all of the text in the first cell below the banner 
ad, and then choose Modify > Templates > New Editable Region to make this 
an editable area of the template. 

8 In the Name field in the New Editable Region dialog box, type textCell1 
and click OK.

9 In the Document window, select all of the text in the second cell below the 
banner ad, and then choose Modify > Templates > New Editable Region to 
make this an editable section of the template. 

10 In the Name field in the New Editable Region dialog box, type textCell2 
and click OK.

11 Choose File > Save to save the template file.
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Apply the template to a new page

Now that you’ve set the editable regions in your template, you’ll use the template 
to create a travel detail page for a trip to New Zealand.

1 Choose File > New from Template to open a new document.

2 In the Templates list in the Select Template dialog box, select myTravelDetail, 
then click Select to select the template you want to apply to the new page. 

The template is applied to the new document. 

This page contains the same regions and content as the template you created. 

Note: If you move the mouse pointer to a noneditable region of this template, such as 
the logo or navigation button areas, the mouse pointer changes to indicate that you 
can’t access the locked region.

3 Save your document, and name the file myTravelDetail_mtnBike.html.
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Editing a template-based page

Now you’ll update the myTravelDetail_mtnBike.html document, updating the 
editable regions with assets and text that refer to travel details about mountain 
biking in New Zealand. 

1 In the Document window, click the Flash placeholder in the titleCell region to 
select the object you want to replace.

2 In the Property inspector’s File field, click the folder icon; then in the dialog 
box that appears, navigate to Assets/swfs and select text_mtnBike.swf. 

3 In the adCell region, click the Flash placeholder to select the object you 
want to replace.

4 In the Property inspector’s File field, click the folder icon; then in the dialog 
box that appears, navigate to Assets/swfs then select bikeAd.swf. 

5 Choose File > Open, then navigate to DW4_MtnBikeText.txt to open a 
document that contains the text for this destination.

6 In DW4_MtnBikeText.txt, copy the paragraph of text under Cell 1; in the 
myTravelDetail_mtnBike document replace the current text in the textCell1 
region by selecting it, then pasting the copied text.

7 In DW4_MtnBikeText.txt, copy the paragraph of text under Cell 2; in the 
myTravelDetail_mtnBike document replace the current text in the textCell2 
region by selecting that text then pasting the copied text.

The travel details information is updated. 

8 Close DW4_MtnBikeText.text.

9 In the Title field of the toolbar, type New Zealand biking.

10 Save your document.
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Check your site
Before posting your pages to a remote server you should always check your files. 
So far you’ve learned how to test your pages by previewing them in a browser, now 
you’ll learn about other Dreamweaver tools available for creating a follow-up for a 
file and for testing your pages.

First, you’ll learn how to add a Design Note to a file, and then you’ll see how to 
run a report on files in your site. 

Create a Design Note

Design Notes are a great way to manage your site by inserting comments in 
your document’s Site window. Use Design Notes to schedule production work, 
place follow-ups on files, or to communicate file or site details with team 
members. Next you’ll create a Design Note to follow-up on making a change 
to one of your site pages. 

1 In the Dreamweaver Site Window (Site > Site Files), in the Local Folder pane 
select DW4_Destinations.html.

2 In the main menu choose File > Design Notes.

The Design Notes dialog box appears.

3 In the Basic Info tab, in the Status pop-up menu select Needs Attention.

4 Click the calendar icon to add the date in the Notes field.

5 Click in the Notes field, then type Need to create Devil’s Tower page and add 
links to documents.

6 Select the Show When File Is Opened option so the Design Note automatically 
opens when this page is opened.
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7 Click OK to close the dialog box.

A Design Note icon appears in the Notes column in the Local Folder pane. 

8 In the Site Window, select DW4_Destinations.html and open it. 

The document and its associated Design Note opens; you can easily see what 
actions are required for this file.
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Sitewide reports

You can run site reports to check HTML file conditions and to manage workflow. 
Run reports at the document, folder, or site level. You’ll run a report to see if you 
have any untitled documents in your site. 

1 Choose Site > Reports.

The Reports dialog box appears.

2 In the Reports dialog in the Report On pop-up menu, select Entire Local Site; 
then under HTML Reports, select Untitled Document.

3 Click Run to run a report.

A Results dialog box appears listing any documents without a page title.

4 In the File list click the file to select it.

The Detailed Description field updates with detailed warning information.

5 Click Open File to open the file and correct the problem.

The file opens.

6 In the Title field of the toolbar, type Featured Destinations.

7 Save and close the file when you’re done.

8 Close the Results dialog box.

The next steps
Congratulations, you’ve completed the Dreamweaver tutorial. You know how to 
design pages, add content, and test your pages. If you want, you can continue 
creating pages and links for the Compass site. You know how to do everything 
required to complete the pages (or you can use the completed pages as a 
reference). After you’ve updated the pages, preview your pages to test the rollovers 
and links to make sure they work.

If you want to learn more about using Dreamweaver, try the Dreamweaver 
lessons; in the Dreamweaver main menu choose Help> Lessons then select one 
of the lessons. 

If you have a copy of both Dreamweaver and Fireworks, and want to learn how to 
work with these tools together, see the Dreamweaver and Fireworks tutorials. 

If you’re interested in learning more about using HTML code, JavaScript code, or 
cascading style sheets, check out the Reference materials that ship with 
Dreamweaver. Choose Windows > Reference.
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Dreamweaver Basics

Getting started in Macromedia Dreamweaver is as easy as opening an existing 
HTML document or creating a new one. However, to get the most out of your 
Dreamweaver experience, you should understand the basic concepts behind the 
Dreamweaver work area and how to choose options, use inspectors and panels, 
and set preferences that fit your work style best.
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About the Dreamweaver work area
The Dreamweaver work area accommodates different styles of working and levels 
of expertise. Here are some of the most commonly used components:

• The Document window displays the current document as you create 
and edit it.

• The Launcher bar at the bottom right of the Document window contains 
buttons for opening and closing your most frequently used inspectors and 
panels. The icons on the Launcher bar also appear on the Launcher, a floating 
panel that you can choose from the Window menu. You can specify which 
icons appear in the Launcher bar and Launcher by setting Panels preferences.

• The toolbar contains buttons and pop-up menus that let you view the 
Document window in different ways, set view options, and access some 
common operations, for example, previewing in a browser.

• Context menus let you quickly access useful commands pertaining to the 
current selection or area. To display a context menu, right-click (Windows) or 
Control-click (Macintosh) an item in a window.

• The Objects panel contains buttons for creating and inserting various types of 
objects, such as images, tables, layers, and frames. You can also switch between 
Standard and Layout view and access the Layout view drawing tools.

• The Property inspector displays properties for the selected object or text, and 
lets you modify those properties. (Which properties appear in the inspector 
depend on the object or text selected.)

Objects panel

Toolbar

Context menu

Launcher bar

Property 
inspector

Document 
window

Tag selector
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• Dreamweaver provides many other inspectors, panels, and windows not shown 
here, such as the History panel and the Code inspector. Many of these items 
can be “docked”—that is, you can combine windows, inspectors, and panels 
into tabbed windows.

To open Dreamweaver windows, inspectors, and panels, use the Window menu. A 
check mark next to an item in the Window menu indicates that the named item is 
currently open (though it may be hidden behind other windows). To display an 
item that isn’t currently open, choose the item name from the menu. 

If a panel or inspector is checked but does not appear, choose Window > 
Arrange Panels.

About the different views in Dreamweaver
Dreamweaver allows you to work in your document in several ways—using 
Design view, using Code view, or using a combined view that displays both the 
design and code of the document. You can change the view in which you’re 
working by selecting a view in the Dreamweaver toolbar. For more information, 
see “Using the toolbar” on page 78.

Working with the Code view

As you create and work with documents, Dreamweaver automatically generates 
their underlying HTML source code. To examine or edit this code, use one of the 
Dreamweaver code editors: the Code view in the Document window or the Code 
inspector. For more detailed information, see “Using the Code view (or Code 
inspector)” on page 330.

Working with the Design view

The Dreamweaver Design view displays a visual representation of your document, 
rather than the underlying code. When you work in the Design view, there are 
two views in which you can design—Layout view and Standard view. You select 
these views in the Objects panel under View.

In Layout view you can design a page layout and insert graphics, text, and other 
media. For more information, see “Designing Page Layout” on page 167. 

Work in Standard view to insert layers, create frame documents, create tables, or 
to use other features that aren’t available in Layout view. To work in Standard view, 
click the Standard View icon in the Objects panel.
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About the Document window

In Design view, the Document window displays the current document 
approximately as it appears in a Web browser. The title bar of the Document 
window displays the page title and, in parentheses, the name of the root folder, the 
file name, and an asterisk if the file contains unsaved changes. 

The status bar, found at the bottom of the Document window, provides 
additional information about the document you are creating.

The tag selector displays the HTML parent tags that control selected text or 
objects. Click one of these tags to highlight its contents in the Document window. 
Click <body> to select the whole body of the document.

The Window Size pop-up menu lets you resize the Document window to predetermined 
or custom dimensions. See “Resizing the Document window” on page 75.

To the right of the Window Size pop-up menu, you’ll see the estimated document 
size and download time of the page, including all dependent files such as images 
and other media files. See “Checking download time and size” on page 509.

The Launcher bar appears along the bottom of the Document window. By 
default, the Launcher bar buttons open the Site window, the Assets panel, the 
HTML Styles panel, the CSS Styles panel, the Behaviors panel, the History panel, 
and the Code inspector. To specify which buttons appear in the Launcher bar (and 
the floating Launcher), see “Customizing the Launcher bar” on page 77.

Window Size 
pop-up menu

Launcher bar

Document size and 
estimated download time

Tag selector
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Resizing the Document window

The Document window status bar displays the window’s current dimensions (in 
pixels). If you click this window size, Dreamweaver displays the Window Size 
pop-up menu, which lets you set the window size to fit any of several common 
monitor sizes. To design a page that looks its best at a specific size, you can adjust 
the Document window to any of the predetermined sizes, edit those 
predetermined sizes, or create new sizes.

Note: The window size given reflects the inside dimensions of the browser window, 
without borders; the monitor size is listed in parentheses. For example, you would 
use the size “536 x 196 (640 x 480, Default)” if your visitors are likely to be using 
Microsoft Internet Explorer or Netscape Navigator in their default configurations on a 
640 x 480 monitor. 

To resize the Document window to a predetermined size:

Choose one of the sizes from the pop-up menu at the bottom of the 
Document window. 

To change the values listed in the Window Size pop-up menu:

1 Choose Edit Sizes from the Window Size pop-up menu. 

2 Click any of the width or height values in the Window Sizes list and type 
a new value.

To make the Document window adjust only to a specific width (leaving the 
height unchanged), select a height value and delete it. 

3 Click the Description field to enter descriptive text about a specific size.

4 Click OK to save the change and return to the Document window.
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To add a new size to the Window Size pop-up menu: 

1 Choose Edit Sizes from the Window Size pop-up menu. 

2 Click the blank space below the last value in the Width column.

3 Enter values for Width and Height. To set the Width or Height only, simply 
leave one field empty.

4 Click the Description field to enter descriptive text about the size you added.

5 Click OK to save the change and return to the Document window.

For example, you might type SVGA or average PC next to the entry for an 
800 x 600 pixel monitor, and 17-in. Mac next to the entry for an 832 x 624 
pixel monitor. Note that most monitors can be adjusted to a variety of pixel 
dimensions.

Minimizing and restoring windows and panels (PC users only)

You can minimize and restore all open Dreamweaver windows—Document 
windows, inspectors, and panels.

• To minimize all Dreamweaver windows, press Shift+F4, or select Window > 
Minimize All. 

• To restore all Dreamweaver windows, press Alt+Shift+F4. If you have at least 
one window open, you can select Window > Restore All to restore any 
additional window.

Setting Status Bar preferences

Use Status Bar preferences to set options for the status bar at the bottom of the 
Document window. To display these preferences, choose Edit > Preferences and 
select Status Bar.

Window Sizes lets you customize the window sizes that appear in the status bar’s 
pop-up menu. See “Resizing the Document window” on page 75. 

Connection Speed determines the connection speed (in kilobits per second) used 
to calculate the download size. The download size for the page is displayed in the 
status bar. The download size for images and other assets is displayed in the 
Property inspector when an image is selected. 

Show Launcher in Status Bar displays the Launcher bar at the bottom of the 
Document window. The buttons in the Launcher bar launch windows, panels, and 
inspectors. The Launcher contains the same buttons (with text) and functions. For 
more information, see “Customizing the Launcher bar” on page 77.
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Using the Launcher bar

 The Launcher bar contains buttons for opening and closing various panels, 
windows, and inspectors. You can also display the Launcher, a floating panel with 
identical buttons.

To show or hide the Launcher: 

Choose Window > Launcher. 

If the Launcher bar does not appear at the bottom of the Doc window, turn on 
the Show Launcher in Status Bar option in Status Bar preferences.

To switch the Launcher orientation from horizontal to vertical:

Click the orientation icon at the lower right.

For information on the items that the default Launcher buttons open, see “About 
the Site window” on page 108, “Managing and Inserting Assets” on page 221, 
“Using HTML styles to format text” on page 244, “Using the CSS Styles panel” 
on page 255, “Using the Behaviors panel” on page 436, “About automating tasks” 
on page 160, and “Using the Code view (or Code inspector)” on page 330.

Customizing the Launcher bar

Use Panels preferences to specify which items appear in the Launcher bar 
and Launcher.

To specify which buttons appear in the Launcher bar and Launcher:

1 Choose Edit > Preferences, then select Panels from the category list. 

The items selected to display in the Launcher and Launcher bar are listed in the 
Show in Launcher box.

2 To add an item to the Launcher and Launcher bar, click the Plus (+) button. 

3 To remove an item from the Launcher and Launcher bar, highlight the item 
and click the Minus (-) button.

4 To change the order of the items in the Launcher or Launcher bar, select an 
item in the list and click an arrow button.

For example, to move an item to the right in the Launcher, move the item 
down in the list.

5 Click OK.

The Launcher and Launcher bar change to show the items you specified.
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Using the toolbar

The Dreamweaver toolbar contains buttons that let you toggle between different 
views of your document quickly: Code, Design, and a third view that comprises 
both Code and Design view. The toolbar also contains some common commands 
related to your view selection and your document’s status. The Options menu 
items (button located on the right) change depending on the view you select.

• To view or hide the toolbar, choose View > Toolbar.

• To display code only in the Document window, click the Show Code 
View button.

• To display a view containing both Code and Design views, click the Show 
Code and Design Views button.

When you select this view, the option Design View on Top becomes available 
in the View menu. Use this option to specify which view appears at the top of 
your Document window.

• To display the Design view only, click the Show Design View button.

You can also access these views through the View menu.

• To enter a title for your document, use the Title field.

If your document already has a title, it appears in this field.

• To display the File Status pop-up menu, click the File Status Menu button.

• To preview or debug your document in a browser, click the Preview/Debug in 
Browser button and choose one of the browsers listed in the pop-up menu.

To add or change the browsers listed in the menu, choose Edit Browser List. 

• To refresh your Design view, click the Refresh Design View button.

• To access the Reference panel, click the Reference button.

The Reference panel contains reference information on HTML, CSS, and 
JavaScript code. For more information, see “Using the Dreamweaver Reference 
panel” on page 328.

Code View

Design View

Document Title

Refresh Design View

Reference

Code Navigaton

Options Menu

Code and Design View

Preview in browser

File Status
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• To navigate through your code, click the Code Navigation button. For more 
information, see “Debugging JavaScript Code” on page 473.

• To access the Options menu, click the Options Menu button.

The Options menu lists different options for each view. For more information 
on Code view options, see “Using the Code view (or Code inspector)” on page 
330. For more information on Design view options, see “Designing Page 
Layout” on page 167.

Note: When the Document window displays both views, you can access either view’s 
Options menu by clicking in the desired view, then clicking the Options menu.

Using context menus

Dreamweaver makes extensive use of context menus, which let you quickly access 
the most useful commands and properties related to the object or window you’re 
working with. Context menus list only those commands that pertain to the 
current selection.

To use a context menu:

1 Right-click (Windows) or Control-click (Macintosh) the object or window.

The context menu for the selected object or window appears.

2 Choose the command from the context menu and release the mouse button.
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Using the Objects panel

The Objects panel contains buttons for creating and inserting objects such 
as tables, layers, and images. To show or hide the Objects panel, choose 
Window > Objects. 

To insert an object: 

Click the corresponding Objects panel button or drag the button’s icon into the 
Document window. Depending on the object, a corresponding object-insertion 
dialog box appears, prompting you to select or insert the file or object you want.

To bypass this dialog box and insert an empty placeholder object: 

Hold down the Control (Windows) or Option (Macintosh) key while inserting 
the object. (For example, to insert a placeholder for an image without specifying 
an image file, hold down Control or Option and click the Image button.)

Note: This does not bypass all dialog boxes. Certain objects such as navigation bars, 
layers, Flash buttons, frames, and so on, do not insert placeholders.

The Objects panel contains seven categories by default: Characters, Common, 
Forms, Frames, Head, Invisibles, and Special. It also contains buttons that change 
the view: Standard and Layout.
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• The Characters category contains special characters such as the copyright 
symbol, curved quotation marks, and trademark symbols. Note that these 
symbols may not display correctly in browsers (Navigator and IE) older than 
versions 3.0.

• The Common category contains buttons for creating and inserting the most 
commonly used objects, such as images, tables, and layers.

• The Forms category contains buttons for creating forms and inserting 
form elements.

• The Frames category contains common frameset structures.

• The Head category contains buttons for adding various head elements, such as 
meta, keywords, and base tags. 

• The Invisibles category contains buttons for creating objects that are not visible 
in the browser window, such as named anchors. Choose View > Visual Aids > 
Invisible Elements to display icons that mark the locations of these objects. 
Click invisible-element icons in the Document window to select the objects 
and change their properties. See “About invisible elements” on page 156.

• The Special category contains buttons for inserting special items such as Java 
applets, plugins, and ActiveX objects. For more information, see .

• The View section of the Objects panel lets you choose between Standard 
(default) or Layout view. If Layout view is selected, you can also select the 
Layout tools—Draw Layout Cell and Draw Layout Table. For more 
information, see “Designing Page Layout” on page 167.

To switch categories, use the pop-up menu at the top of the panel. You can modify 
any object in the panel or create your own objects; see “Modifying the Objects 
panel” on page 515 and “Creating a simple object” on page 516. For information 
on each panel’s options, see the related topics in Dreamweaver Help.

Some of the General preference settings affect the Objects panel. To modify these 
preferences, choose Edit > Preferences and then select General. 

• When you insert objects such as images, tables, scripts, and head elements, a 
dialog box prompts you for additional information. You can suppress these 
dialog boxes by turning off the Show Dialog When Inserting Objects option or 
by holding down the Control key while creating the object. When you insert 
an object with this option off, the object is given default attribute values. Use 
the Property inspector to change object properties after inserting the object.

• The Objects panel preference lets you display the contents of the Objects panel 
as text only, icons only, or text and icons. 
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Using the Property inspector 

The Property inspector lets you examine and edit properties for the currently 
selected page element. (A page element is an object or text.) You can select page 
elements in either the Document window or the Code inspector.

To show or hide the Property inspector, choose Window > Properties.

Most changes you make to properties are immediately applied in the 
Document window. (For some properties, changes are not applied until you click 
outside the property-editing text fields, press Return, or press Tab to switch to 
another property.)

The contents of the Property inspector vary depending on the element 
selected. For information on specific properties, select an element in the 
Document window and then click the Help icon in the upper right corner of 
the Property inspector.

The Property inspector initially displays the most commonly used properties 
of the selected element. Click the expander arrow in the lower right corner of 
the Property inspector to see more of the element’s properties. (In a few cases, 
certain obscure properties may not appear even in the expanded Property 
inspector; in these cases, use the Code inspector or Code view to code these 
properties by hand.)

Using dockable floating panels

Most of the panels in Dreamweaver can be docked—that is, combined into a 
single floating panel with multiple tabs. This makes it easy to access the 
information you need without cluttering your workspace. (However, the 
Launcher, Property inspector, and Site window cannot be docked.) Also, panels 
and inspectors now “snap” automatically to each other, the sides of the screen, or 
the Document window. This makes it easier to move and arrange the different 
floating panels and windows in Dreamweaver. 
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To combine two or more panels to create one tabbed panel:

1 Drag the tab (not the title bar) of one floating panel over another floating 
panel. When a highlighted border appears around the target panel, release the 
mouse button.

2 Click any tab in the tabbed panel to bring the corresponding panel to the front. 

Because the Objects panel does not have a tab, you can’t dock it with another 
panel by dragging the Objects panel onto the other panel; however, you can drag 
the tab of another panel over the Objects panel to combine them. You can move 
tabbed panels back and forth between floating panels, rearranging them to suit 
your workflow, by using the process described above.

To remove a panel from a tabbed panel:

Drag its tab out of the window. 

Setting Panels preferences

Use Panels preferences to specify which panels and inspectors always appear in 
front of the Document and Site windows, and which ones are allowed to be 
obscured. You can also use Panels preferences to specify which panels and 
inspectors appear in the Launcher and Launcher bar.

To specify where each panel appears in relation to the Document window: 

1 Choose Edit > Preferences, then select Panels from the category list. 

By default, all windows, panels, and inspectors appear in front of the 
Document window. 

2 Deselect the windows, panels, and inspectors that you want to place behind the 
Document window.

For example, if you want to allow the Document window to obscure the Code 
inspector, deselect the Code Inspector option. The Code inspector now appears 
in front of the Document window only when it is active.

Similarly, if you want to allow the Document window to obscure any floating 
panels that you have added by customizing Dreamweaver, deselect All 
Other Floaters.

History panel tab History panel being dragged 
to the Layers panel
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About the History panel

The History panel shows a list of all the steps you’ve performed in the active 
document since you created or opened that document. (The History panel doesn’t 
show steps you’ve performed in other frames, in other Document windows, or in 
the Site window.) It allows you to undo one or more steps; it also allows you to 
replay steps and to create new commands to automate repetitive tasks.

The slider, or thumb, in the History panel initially points to the last step that 
you performed.

Using the History panel

The History panel keeps track of every step of your work in Dreamweaver. You 
can use the History panel to undo multiple steps at once.

If you want to undo the last operation you performed in a document, choose 
Edit > Undo, just as you would do in any other application. (The name of 
the Undo command changes in the Edit menu to reflect the last operation 
you performed.)

The History panel also lets you replay steps you’ve already performed and 
automate tasks by creating new commands. For more information, see “About 
automating tasks” on page 160.

Slider (thumb)

Replay button

Copy Steps button Save As Command button

Steps
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To open the History panel:

Choose Window > History.

To undo the last step:

Drag the History panel slider up one step in the list. This has the same effect as 
choosing Edit > Undo.

The undone step turns gray.

To undo multiple steps at once, do one of the following:

• Drag the slider to point to any step.

• Click to the left of a step along the path of the slider; the slider scrolls 
automatically to that step, undoing steps as it scrolls.

Note: To scroll automatically to a particular step, you must click to the left of the step; 
clicking the step itself selects the step. Selecting a step is different from going back to that 
step in your undo history.

As with undoing a single step, if you undo a series of steps and then do something 
new in the document, you can no longer redo the undone steps; they disappear 
from the History panel.

The History panel also allows you to repeat steps that appear in your step history, 
and to automate tasks based on steps you’ve performed.See “About automating 
tasks” on page 160
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To set the number of steps that the History panel retains and shows:

1 Choose Edit > Preferences and select General from the Category list.

2 Enter a number for Maximum Number of History Steps.

The default value should be sufficient for most users’ needs. The higher the 
number, the more memory the History panel requires. This can affect 
performance and slow your computer down significantly. When the History 
panel reaches this maximum number of steps, the earliest steps are discarded.

Note: You can’t rearrange the order of steps in the History panel. Don’t think of the History 
panel as an arbitrary collection of commands; think of it as a way to view the steps you’ve 
performed, in the order in which you performed them.

To erase the history list for the current document:

In the History panel’s context menu, choose Clear History.

This command also clears all undo information for the current document; after 
choosing Clear History, you will be unable to undo the steps that are cleared. 
(Note that Clear History does not undo steps; it merely removes the record of 
those steps from Dreamweaver memory.)

Using other Dreamweaver panels

The Dreamweaver work area comprises many other panels. Here are just a few:

The Code inspector shows the code that browsers use to display the document 
as a Web page. To show or hide the Code inspector, choose Window > 
Code Inspector.

Changes you make in the Document window are immediately reflected in 
the Code inspector. When you enter HTML into the Code inspector and then 
click outside the inspector, corresponding changes appear in the Document 
window. For more information, see “Using the Code view (or Code inspector)” 
on page 330.

For minor editing of HTML tags, you can use the Quick Tag Editor instead of the 
Code inspector. To display the Quick Tag Editor, press Control+T (Windows) or 
Command+T (Macintosh), or choose Modify > Quick Tag Editor. For more 
information, see “Editing an HTML tag in the Design view” on page 338.

The Reference panel provides detailed information about the HTML tag you are 
working on, including tag attributes. You can open the Reference panel from the 
Window menu, the Launcher bar, or the Code inspector.

For example, you can select an img tag, click the Reference button in the toolbar, 
and find out what attributes apply (align, border, and so on). For more 
information, see “Using the Dreamweaver Reference panel” on page 328.

The Dreamweaver JavaScript Debugger lets you debug client-side JavaScript. You 
can open the JavaScript Debugger from the Window menu. For more 
information, see “Debugging JavaScript Code” on page 473.
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Working with colors
In Dreamweaver, many of the dialog boxes, as well as the Property inspector for 
many page elements, contain a color box, which opens a color picker. Use the 
color picker to choose a color for a page element.

To choose a color in Dreamweaver:

1 Click a color box in any dialog box or in the Property inspector. 

The color picker appears.

2 Do one of the following:

• Use the eyedropper to select a color swatch from the palette. All colors in the 
Color Cubes (default) and Continuous Tone palettes are Web-safe; other 
palettes are not. 

• Use the eyedropper to pick up a color from anywhere on your screen—even 
outside the Dreamweaver windows. (If you click the desktop or another 
application, Dreamweaver picks up the color where you clicked, but you 
may switch into the other application; in that case, click a Dreamweaver 
window to continue working in Dreamweaver, or hold down the mouse 
button when moving from Dreamweaver to the desktop to keep from 
switching out of Dreamweaver.)

• To expand your color selection, use the pop-up menu at the top right corner of 
the color picker. You can select Color Cubes, Continuous Tone, Windows OS, 
Mac OS, Grayscale, and Snap to Web Safe. 

Note that the Color Cubes and Continuous Tone palettes are Web safe, 
whereas Windows OS, Mac OS and Grayscale are not. If you are using a palette 
that isn’t Web-safe and then choose Snap to Web Safe, Dreamweaver replaces 
the selected color with the closest Web-safe color. In other words, you may not 
get the color you see.

• To clear the current color without choosing a different color, click the 
Strikethrough button.

• To open the system color picker, click the Color Wheel button. 

Property inspector 
color box
Dreamweaver Basics 87



About Web-safe colors
In HTML, colors are expressed either as hexadecimal values (for example, 
#FF0000) or as color names (red). A Web-safe color is one that appears the same 
in Netscape Navigator and Microsoft Internet Explorer on both Windows and 
Macintosh systems when running in 256-color mode. The conventional wisdom 
is that there are 216 common colors, and that any hexadecimal value that 
combines the pairs 00, 33, 66, 99, CC, or FF (RGB values 0, 51, 102, 153, 204, 
and 255, respectively) represents a Web-safe color.

Testing, however, reveals that there are only 216 Web-safe colors. Internet 
Explorer on Windows does not correctly render the colors #0033FF (0,51,255), 
#3300FF (51,0,255), #00FF33 (0,255,51), and #33FF00 (51,255,0).

The Color Cubes (default) and the Continuous Tone palettes in Dreamweaver use 
the 216-color Web-safe palette; selecting a color from these palettes displays the 
color’s hexadecimal value.

To choose a color outside the Web-safe range, open the system color picker by 
clicking the Color Wheel button in the upper right corner of the Dreamweaver 
color picker. The system color picker is not limited to Web-safe colors.

UNIX versions of Netscape Navigator use a different color palette than the 
Windows and Macintosh versions. If you are developing exclusively for UNIX 
browsers (or your target audience is Windows or Macintosh users with 24-bit 
monitors and UNIX users with 8-bit monitors), consider using hexadecimal 
values that combine the pairs 00, 40, 80, BF, or FF, which produce Web-safe 
colors for SunOS.

Setting preferences
Dreamweaver has preference settings that control the general appearance of the 
Dreamweaver user interface as well as options related to specific features such as 
layers, style sheets, displaying HTML and JavaScript code, external editors, and 
previewing in browsers. Information about specific preference options is provided 
throughout this guide in conjunction with the associated feature or topic.  

This guide describes only the most common of the preference options. 
For information on a specific preference option not covered here, see the 
corresponding topic in Dreamweaver Help.

Setting General preferences

The General preferences control the general appearance of Dreamweaver. To 
change these preferences, choose Edit > Preferences, and then click General. The 
General preferences are divided into two subcategories: File options and Editing 
options. For detailed information on these preferences, see Dreamweaver Help.
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Setting Fonts/Encoding preferences

Use Fonts/Encoding preferences to set a default font encoding for new documents 
and to set the fonts that Dreamweaver uses to display each font encoding. A 
document’s encoding determines how the document is displayed in a browser. 
Dreamweaver font settings let you work with text in the font and size you prefer 
without affecting how the document appears when viewed by others in a browser.

To change the encoding of the current document:

Choose Modify > Page Properties and then select an encoding from the 
Document Encoding pop-up menu.

To change the default encoding to be used when creating new documents:

Choose Edit > Preferences, click Fonts/Encoding in the Category list, and choose 
an encoding from the Default Encoding pop-up menu.

To set the fonts to use for each type of encoding:

1 Choose Edit > Preferences and click Fonts/Encoding in the Category list.

2 Select the encoding type (such as Western [Latin1] or Japanese) from the Font 
Settings list, then choose fonts to use for that encoding from the font pop-up 
menus below the Font Settings list.

For more information about Fonts/Encoding preferences, see Dreamweaver Help.

Using Dreamweaver with other applications
Dreamweaver accommodates your Web design and development process by 
making it easy for you to work with other applications. For information about 
working with other applications such as browsers, HTML editors, image editors, 
and animation tools, see the following topics: 

• For information about using Dreamweaver with other HTML editors, such as 
HomeSite or BBEdit, see “Using external HTML editors” on page 350. 

• You can specify preferred browsers for previewing your site. See “Previewing in 
browsers” on page 504.

• You can launch an external image editor, such as Macromedia Fireworks, from 
within Dreamweaver. See “Using an external image editor” on page 277. 

• You can configure Dreamweaver to launch a different editor for each file type. 
See “Launching an external editor” on page 298.

• For information about adding animation to your site with Flash movies, see 
“About Flash content” on page 300.

• To learn how to add interactivity to your site with Shockwave movies, see 
“About Shockwave movies” on page 310.
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Basic Customizing in Dreamweaver
There are some basic techniques you can use to customize Dreamweaver to suit 
your needs. For example, by setting preferences, creating your own keyboard 
shortcuts, and adding extensions, you can set up your work area without knowing 
complex code or editing text files. For more information on advanced customizing 
features, see “Customizing Dreamweaver” on page 513.

Using the Keyboard Shortcut Editor

Use the Keyboard Shortcut Editor to create your own shortcut keys, edit existing 
shortcuts, or use the predetermined shortcut sets. 

To access the Keyboard Shortcut Editor: 

Choose Edit > Keyboard Shortcuts.

The Keyboard Shortcut dialog box appears containing several options you can 
select and commands you can edit.

Duplicate Set button

Rename Icon button

Delete Set button

Save as HTML 
File button
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Current Set is a menu that displays the sets of predetermined shortcuts that are 
included with Dreamweaver, and any custom sets you’ve defined. By default, the 
current set is the one that Dreamweaver is using in the current doc. The 
predetermined sets are listed at the top of the menu. If you are familiar with the 
shortcuts found in Dreamweaver 3, you can use them by choosing the 
predetermined Dreamweaver 3 set. (In this set, the Dreamweaver 3 set contains 
the Dreamweaver 3 shortcuts for Dreamweaver 3 features, and the Dreamweaver 
4 shortcuts for features that weren’t in Dreamweaver 3.

Commands is a pop-up menu that lets you select the command category you want 
to edit. For example, you can edit menu commands, such as the Open File 
command, or one of thee code editing commands, such as Balance Braces.

Command List displays the commands associated with the category you selected 
from the Commands pop-up menu, along with the assigned shortcuts. The Menu 
and Site Menu commands categories display this list as a tree view that replicates 
the structure of the menus. The other categories list the commands by name (for 
example, Quit Application).

Shortcuts window displays the list of shortcuts assigned to the selected command.

Press key displays the new key combination you enter.

Plus adds a new shortcut to the current command. Click Plus (+) to activate the 
Shortcuts field. Enter a new key command and click Change to add a new 
keyboard shortcut for this command. You can assign two different keyboard 
shortcuts for each command.

Minus removes the selected shortcut from the list of shortcuts.

Change applies the new shortcut to the command and adds it to the list of 
shortcuts. 

• Click the Duplicate button to duplicate the current set. You have the option to 
name the set or keep the default name (the current set’s name with “copy” suffix).

• Click the Rename button to rename the current set.

• Click the Save as HTML File button to save the current set in an HTML table 
format for easy viewing and printing. You can open the HTML file in your 
browser and print the shortcuts for easy reference.

• Click the Delete button to delete copies and custom sets. (You cannot 
delete active sets.)
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To remove a shortcut from a command:

1 From the Commands pop-up menu, select the command category that 
contains the command shortcut you want to remove; for example, Site 
Menu Commands.

The Command list displays the commands associated with that category.

2 From the Command list, select the command shortcut you want to remove.

You’ll see a list of shortcuts assigned to the commands.

3 Select the shortcuts you want to remove.

4 Click the Minus (-) button.

To add a shortcut to a command: 

1 Select the command category that contains the command you want. 

 The Command list displays the commands associated with that category.

2 Select the command from the Command list. 

You’ll see any shortcuts already assigned to the command in the Shortcuts list.

3 Click the Plus (+) button. The Shortcuts entry field activates and the insertion 
point moves to the Press Key field.

4 Press the key combination you want to add; the key combination appears in the 
Press Key Field.

If there is a problem with the shortcut—for example, if the key combination is 
already assigned to another command—an alert appears letting you reassign 
the key combination or cancel.

5 Click Change. The new key combination is assigned to the command.

To edit an existing shortcut: 

1 Select the command category that contains the command you want. 

The Command list displays the commands in the chosen category.

2 Select the command from the Command list. 

You’ll see the shortcuts already assigned to the command in the Shortcuts field. 
If more than one shortcut is assigned to a command, you’ll need to select the 
one you want to change.

3 Click in the Press Key field and type the desired key combination.

4 Click the Change button to change the shortcut. 

Note: If there is a problem with the key combination, an explanatory message is displayed 
just below the Shortcuts field and you may be unable to add, delete, or edit the shortcut. 
For example, if the key combination is already assigned to another command, warning text 
is displayed just below the Shortcuts field.
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Adding extensions to Dreamweaver

Extensions are new features that you can add easily to Dreamweaver 4. You can use 
many types of extensions; for example, there are extensions that let you reformat 
tables, connect to back-end databases, or help you write scripts for browsers.

To find the latest extensions for Dreamweaver, use the Macromedia Exchange 
Web site at http://www.macromedia.com/exchange/dreamweaver/. Once there, 
you can log in and download extensions (many of which are free), join discussion 
groups, view user ratings and reviews, and install and use the Package Manager. 
You must install the Package Manager before you can download extensions.

The Package Manager runs in conjunction with Dreamweaver and lets you install 
and manage extensions. After you’ve downloaded and installed the Package 
Manager from the Exchange site, launch the Package Manager directly from 
Dreamweaver by choosing Manage Extensions from the Commands menu.
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To install and manage extensions:

1 Click the download link found at the Web site for the extension you want.

You can choose to open and install it directly from the site or save it to disk.

• If you are opening it directly, the Package Manager handles the installation 
automatically.

• If you are saving it to disk, save the extension package file (.mxp) to the 
Downloaded Extensions folder within the Dreamweaver folder on your 
computer. (For example, My Computer\c:\Program 
Files\Macromedia\Dreamweaver 4\Configuration\Extensions.)

2 Double-click the extension package file or choose Install Extension from the 
Package Manager File menu. 

The file will be installed in Dreamweaver. Some extensions aren’t accessible 
until Dreamweaver has restarted; you may be prompted to quit and restart 
the application.

Use the Package Manager to remove extensions or to see more information 
about the extension.
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Planning and Setting Up Your Site

A Web site is a set of linked documents with shared attributes, such as related 
topics, a similar design, or a shared purpose.

Macromedia Dreamweaver is a site creation and management tool, so you can use 
it to create complete Web sites, in addition to individual documents. For best 
results, design and plan your Web site before you create any of the pages that the 
site will contain.

Note: If you can’t wait to start creating documents immediately, you can try out some of the 
Dreamweaver document-creation tools and make a sample document. (See “Creating, 
opening, and saving HTML documents” on page 150.) But don’t start serious document 
development until you’ve set up a site.

The first step in creating a Web site is planning. See “About site planning and 
design” on page 95. The next step is to set up the basic structure of the site; see 
“Using Dreamweaver to set up a new site” on page 102. If you already have a site 
on a Web server and you want to begin using Dreamweaver to edit that site, see 
“Setting up a remote site” on page 123.

About site planning and design
In Dreamweaver, the term site can refer either to a Web site or to a local storage 
location for the documents belonging to a Web site. When you begin thinking 
about creating a Web site, you should follow a series of planning steps to make 
sure your site succeeds. Even if you are just creating a personal home page that 
only friends and family will see, it can still be to your advantage to plan the site 
carefully in order to make sure everyone will be able to use it successfully.
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Determining your goals

Deciding what your site goals are is the very first step you should take when you 
create a Web site. Ask yourself or your client questions about the site. What do 
you hope to accomplish by having a Web site? Write down your goals so that you 
remember them as you go through the design process. Goals help you focus and 
target your Web site to your particular needs. 

A Web site that provides news about a specific subject should have a very different 
look and navigation than a Web site that will sell products. The complexity of 
your goals will affect the navigation, the media that you use (Flash, Director, and 
so on), and even the look and feel of your site.

Choosing a target audience

After you have decided what you want to accomplish with your Web site, you 
need to decide who you want to visit your site. This may seem to be a silly 
question, since most people want everyone to visit their Web site. However, it is 
difficult to create a Web site that every single person in the world will be able to 
use. People use different browsers, connect at different speeds, and may or may 
not have media plug-ins. All these factors can affect the use of your site. That is 
why you need to determine a target audience.

Think about the people who will be attracted to your Web site, or who you hope 
to attract. What kinds of computers do you think they will be using, what 
platform might be the dominant one (Macintosh, Windows, Linux, and so on)? 
What is the average connection speed (33.6 modem or DSL)? What kinds of 
browsers and monitor sizes will they be using? Are you creating an intranet site 
where everyone will be using the same computer OS and browser? All of these 
factors can greatly affect the way your Web page appears to visitors.

Once you choose the audience and have determined what types of computers, 
connection speeds, and browsers they will be using, you can target your design. 

For example, say your target audience is predominantly Windows users with 17-
inch monitors and using Internet Explorer 3.0 or above. As you design your Web 
page, you should test that your site works best in Microsoft Internet Explorer on a 
Windows computer with a screen size of 800 x 600 pixels. Fewer viewers may use 
Netscape Navigator on a Macintosh platform, but you should also make sure your 
site still works on those machines, although it may not display as precisely as it 
does for your target audience.
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Creating sites for browser compatibility

As you create your site, you should be aware of the variety of Web browsers your 
visitors are likely to use. Where possible, design sites for maximum browser 
compatibility, given other design constraints.

There are over two dozen different Web browsers in use, most of which have been 
released in more than one version. Even if you target only Netscape Navigator and 
Microsoft Internet Explorer, which are used by the majority of Web users, be 
aware that not everyone uses the very latest versions of those browsers. If your site 
is on the Web, sooner or later someone will visit it using Netscape Navigator 
2.0—or the browser that AOL provides its customers, or a text-only browser 
such as Lynx.

There are some circumstances under which there’s no need to create cross-
browser-compatible sites. For example, if your site is available only on your 
company’s intranet, and you know that all of your company’s employees use the 
same browser, you can optimize your site to rely on features of that browser. 
Similarly, if you’re creating HTML content to be distributed on CD-ROM, and 
you distribute a browser on the CD, you can assume that all of your customers 
have access to that particular browser.

Under most circumstances, for Web sites designed for public viewing, it’s a 
good idea to make your site viewable in as many browsers as possible. Pick one 
or two browsers as your target browsers, and design the site for those browsers, 
but try exploring the site in other browsers now and then to avoid including too 
much incompatible content. You can also post a message on a discussion board 
to ask others to view your site. This can be a good way to get feedback from a 
wide audience.

The more sophisticated your site is—in terms of layout, animation, multimedia 
content, and interaction—the less likely it is to be cross-browser compatible. Not 
all browsers can run JavaScript, for example. A page of plain text that uses no 
special characters will probably display well in any browser, but such a page may 
have much less aesthetic appeal than one that uses graphics, layout, and 
interaction effectively. Try to strike a balance between designing for maximum 
effect and designing for maximum browser compatibility.

One useful approach is to provide multiple versions of certain important pages, 
such as your site’s home page. For example, you can design both a framed version 
and a frameless version of such a page. You can then include in your Web page a 
behavior that automatically shifts visitors without frame-capable browsers to the 
frameless version. For more information, see “Using the behavior actions that 
come with Dreamweaver” on page 444.
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Organizing the site structure

Organizing your site carefully from the start can save you frustration and time later 
on. If you begin creating documents without thinking about where in your folder 
hierarchy they should go, you may end up with a huge, unwieldy folder full of files, 
or with related files scattered through a half-dozen similarly named folders.

The usual way to set up a site is to create a folder on your local disk that contains 
all the files for your site (referred to as the local site), and to create and edit 
documents within that folder. You then copy those files to a Web server when you 
are ready to publish your site and allow the public to view it. This approach is 
better than creating and editing files on the live public Web site itself, because it 
allows you to test changes in the local site before making them publicly viewable, 
and then when you’re finished, you can upload the local site files and update the 
entire public site at once.

See “Using Dreamweaver to set up a new site” on page 102 to coordinate your 
local site with Dreamweaver. Once you set up the local site with Dreamweaver, 
you are better able to manage your site files, track links, update pages, and more.

Break down your site into categories. Put related pages in the same folder. For 
example, your company press releases, contact information, and job postings 
might all go in one folder, and your online catalog pages in another folder. Use 
subfolders where necessary. This type of organization will make your site easier to 
maintain and navigate.
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Decide where to put items such as images and sound files. It’s convenient to place 
all your images, for example, in one location, so that when you want to insert an 
image into a page you know where to find it. Designers sometimes place all of the 
non-HTML items to be used on a site in a folder called Assets. That folder may 
contain other folders—for example, an Images folder, a Shockwave folder, and a 
Sound folder. Or you might have a separate Assets folder for each group of related 
pages on your site, if there aren’t many assets shared among such groups.

Use the same structure for local and remote sites. Your local site and your remote 
Web site should have exactly the same structure. If you create a local site using 
Dreamweaver and then upload everything to the remote site, Dreamweaver 
ensures that the local structure is precisely duplicated in the remote site.

my_site1 (root folder)

Site 1

About_the_Company

Catalog

Assets (for whole site)

index.html (home page)

my_site2 (root folder)

Site 2

index.html (home page)

About_the_Company

Assets

Catalog

Assets
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Creating your design look

You save a lot of time later in the process if you plan your design and layout before 
you actually begin working in Dreamweaver. It can be as simple as creating a 
mock-up drawing of how you want the site layout to look on a piece of paper. A 
more advanced approach would be to create a composite drawing of your site 
using software such as Macromedia Freehand or Fireworks. The important thing 
is to have a mock-up of your layout and design so you can follow it later as you 
build your site.

It is important to maintain consistency in your page layout and design. You want 
users to be able to click through the pages in your site without getting confused 
because all the pages have a different look, or the navigation is in a different place 
on each page.

Designing the navigation scheme

Another area where planning pays off is navigation. As you design your site, think 
about the experience you want your visitors to have. Think about how a visitor to your 
site will be able to move from one area to another. Consider the following points:

“You are here.” Visitors should easily know where they are in your site and how to 
return to your top-level page.

Searching and indexes make it easy for visitors to find any information they 
are looking for.

Feedback provides a way for visitors to contact the webmaster (if appropriate) if 
something is wrong with the site, and to contact other relevant people associated 
with the company or the site.

Design the way your navigation will look. Navigation should be consistent 
throughout your site. If you place a navigation bar across the top of your home 
page, try to keep it there for all the linked pages. 

Dreamweaver has two navigation tools that you can use to create your navigation 
scheme. For more information, see “Linking and Navigation” on page 353. 
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Planning and gathering your assets

Once you know what your design and layout will look like, you can create and 
gather the assets that you will need. Assets can be items such as images, text, or 
media (Flash, Shockwave, and more). Make sure you have all of these items 
gathered and ready to go before you begin developing your site. Otherwise, you’ll 
have to continually stop development to find an image or to create a button.

If you are using images and graphics from a clip-art site or someone else is creating 
them, make sure you collect them and put them in a folder on your site (see 
“Organizing the site structure” on page 98). If you are creating the assets yourself, 
make sure you create them all before you start development, including any images 
you need if you are using roll-overs. Then organize your assets so you can access 
them easily while creating your site in Dreamweaver.

Dreamweaver can make it easier for you to reuse page layouts and page elements 
in various documents by using templates and libraries. However, it is easier 
to create new pages with templates and libraries than it is to apply them to 
existing documents.

Use templates if many of your pages will use the same layout. Plan and design a 
template for that layout, and then you can create new pages based on that 
template. If you decide to change the layout for all the pages, you can simply 
change the template.

Note: There are certain restrictions on what changes you can make to documents that are 
based on templates. Templates are best used in collaborative environments, to ensure that 
everyone is using the same page layout. Library items may provide more flexibility for use 
outside of collaborative environments.

Use library items if you know that a certain image or other content will appear on 
many pages throughout your site; design that content ahead of time and make it a 
library item. Then if you change that item later, the updated version appears on all 
pages that use it.

For more information on reusing page layouts and elements, see “Reusing 
Content with Templates and Libraries” on page 375.
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Using Dreamweaver to set up a new site
Once you create your site structure (see “Organizing the site structure” on page 
98), you must designate the new site in Dreamweaver. Setting up this local site in 
Dreamweaver means that you can use Dreamweaver with FTP to upload your site 
to the Web server, automatically track and maintain your links, and 
collaboratively share files. It is best to set up your local site in Dreamweaver before 
you begin creating your pages.

The local site is the site structure that you set up on your computer to contain all 
your folders, assets, and files for a particular site (see “Organizing the site 
structure” on page 98).

The local root folder of your site should be the folder you set up specifically for 
that site. One good organizational approach is to create a folder named Sites, and 
then create local root folders inside that folder, one local root folder for each site 
you’re working on.

To create a new site:

1 Choose Site > New Site. 

In the Site Definition dialog box that appears, the Local Info category 
is selected.
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2 Enter the following options:

• In the Site Name field, enter a name for the site. The site name appears in the 
Site window and on the Site > Open Site submenu. Use any name you like, it 
will not appear in the browser and is only for your reference.

• In the Local Root Folder field, specify the folder on your local disk where site 
files, templates, and library items will be stored. When Dreamweaver resolves 
root-relative links, it does so relative to this folder (see “Root-relative paths” on 
page 357). Click the folder icon to browse to and select the folder, or enter a 
path and folder name in the text field. If the local root folder does not yet exist, 
create it from within the file-browsing dialog box.

• For the Refresh Local File List Automatically option, indicate whether or not to 
automatically refresh the local file list every time you copy files into your local 
site. Deselecting this option improves the speed of Dreamweaver when copying 
such files, but when this option is deselected, the Local pane of the Site window 
does not automatically refresh. To manually refresh the Site window, click the 
Site window’s Refresh button. To manually refresh the Local pane only, choose 
View > Refresh Local in the Site window (Windows) or Site > Site Files View > 
Refresh Local (Macintosh). 

• In the HTTP Address field, enter the URL that your completed Web site 
will use, so that Dreamweaver can verify links within the site that use 
absolute URLs. (See “Checking links in a page or site” on page 506.) 
For example, the absolute HTTP address for the Macromedia Web site is 
http://www.macromedia.com.

• For the Cache option, indicate whether or not to create a local cache to 
improve the speed of link and site management tasks. If you do not select this 
option, Dreamweaver will ask you if you want to create a cache again before it 
creates the site. It is a good idea to select this option because the Assets panel 
only works if a cache is created. For more information about the Assets panel, 
see “Managing and Inserting Assets” on page 221.

3 Click OK.

The Site Files window opens. For more information about the site window and 
site management, see “Site Management and Collaboration” on page 107.

Later, when you’re ready to publish the site on a remote server, you will need to 
add additional information about the site. For information about remote sites, see 
“Setting up a remote site” on page 123.
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Editing an existing Web site
You can use Dreamweaver to edit an existing site on your local disk, even if you 
didn’t use Dreamweaver to create the original site.

To edit an existing Web site: 

1 Choose Site > Define Sites and click New, or choose Site > Open Site > 
Define Sites.

In the Site Definition dialog box that appears, the Local Info category 
is selected.

2 Enter the following options:

• In the Site Name field, enter a name for the site. The site name appears in the 
Site window and on the Site > Open Site submenu. Use any name you like, it 
will not appear in the browser and is only for your reference.

• In the Local Root Folder field, specify the folder on your local disk where 
the existing site files, templates, and library items are stored. Click the folder 
icon to browse to and select the folder, or enter a path and folder name in 
the text field. 

• For the Refresh Local File List Automatically option, indicate whether or not to 
automatically refresh the local file list every time you copy files into your local 
site. Deselecting this option improves the speed of Dreamweaver when copying 
such files, but when this option is deselected, the Local pane of the Site window 
does not automatically refresh. To manually refresh the Site window, click the 
Site window’s Refresh button. To manually refresh the Local pane only, choose 
View > Refresh Local in the Site window (Windows) or Site > Site Files View > 
Refresh Local (Macintosh). 

• In the HTTP Address field, enter the URL that your completed Web site 
will use, so that Dreamweaver can verify links within the site that use 
absolute URLs. (See “Checking links in a page or site” on page 506.) 
For example, the absolute HTTP address for the Macromedia Web site is 
http://www.macromedia.com.

• For the Cache option, indicate whether or not to create a local cache to 
improve the speed of link and site management tasks. If you do not select this 
option, Dreamweaver will ask you if you want to create a cache again before it 
creates the site. It is a good idea to select this option because the Assets panel 
only works if a cache is created. For more information about the Assets panel, 
see “Managing and Inserting Assets” on page 221.

3 Click OK.

The Site Files window opens. For more information about the site window and 
site management, see “Site Management and Collaboration” on page 107.
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Editing a remote site
You can use Dreamweaver to copy an existing remote site (or any branch of a 
remote site) to your local disk and edit it there, even if you didn’t use 
Dreamweaver to create the original site.

Note that even if you intend to edit only part of the remote site, you must locally 
duplicate the entire structure of the relevant branch of the remote site, from the 
remote site’s root folder down to the files you want to edit. For example, if your 
remote site’s root folder, named public_html, contains two folders, Project1 and 
Project2, and if you want to work only on the HTML files in Project1, you don’t 
need to download the files in Project2, but you must map your local root folder to 
public_html, not to Project1. 

Remote site

public_html

Project1

Assets

HTML

Project2

Assets

HTML

Local site

local root folder
(map this to public_html, not to
Project1 or Project1/HTML)

Project1
(must be present on local
site; corresponds to Project1
 on remote site)

HTML
(must be present on
local site; corresponds
to Project1/HTML on
remote site)
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To edit an existing remote site: 

1 Create a local folder to contain the existing site, then set it up as the local root 
folder for the site (see “Using Dreamweaver to set up a new site” on page 102).

2 Set up a remote site, using information about your existing site. See “Setting up 
a remote site” on page 123. Be sure to choose the correct root folder for 
the remote site.

3 Connect to the remote site using the Connect button in the Site window.

4 Depending on how much of the remote site you want to edit, do one of 
the following:

• If you want to work with the entire site, select the root folder of the remote site, 
and click Get to download the entire site to your local disk.

• If you want to work with just one of the files or folders of the site, locate the file 
or folder in the Remote pane of the Site window, and click Get File(s) to 
download that file to your local disk. (Dreamweaver automatically duplicates as 
much of the remote site’s structure as is necessary to place the downloaded file 
in the correct part of the site hierarchy.) When editing only one part of a site, 
you should generally choose to include dependent files.

5 Proceed as if creating a site from scratch: edit documents, preview and test 
them, and upload them again to the remote site.

For more information about site management, see “Site Management and 
Collaboration” on page 107.

Removing a site from your list of sites
If you no longer want to work with a site in Dreamweaver, you can remove the site 
from your list of sites. The files in the site are not removed.

Note: When you remove a site from the list, all setup information about the site is 
permanently lost.

To remove a site from your site list:

1 Choose Site > Define Sites.

2 Select a site name.

3 Click Remove.

A dialog box appears asking you to confirm the removal.

4 Click Yes to remove the site from your list.
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Site Management and Collaboration

Macromedia Dreamweaver helps you organize the files in your local and remote 
sites using the Site window. It lets you duplicate the structure of your local site on 
a remote server, or duplicate a remote Web site’s structure on your local system. 
The relative links you create on your local site continue to work after you transfer 
files to the remote site, because the structure of the two sites is identical.

You create a local site in Dreamweaver by using the New Site command to create a 
local root folder for the site (or by making an existing folder into the local root 
folder); see “Using Dreamweaver to set up a new site” on page 102. You define a 
remote site when creating a new site, or add that information later using the Define 
Sites command; see “Associating a remote server with a local site” on page 124.

Dreamweaver includes a number of features for structuring a site and transferring 
files to and from a remote server. When you transfer files between local and 
remote sites, Dreamweaver maintains parallel file and folder structures between 
them. When transferring files between sites, Dreamweaver automatically creates 
necessary folders when they do not yet exist in a site. You can also synchronize the 
files between your local and remote sites; Dreamweaver copies files in both 
directions as necessary, and removes unwanted files as appropriate.

Dreamweaver contains features to make collaborative work on a Web site easier. 
You can check files in and out of a remote server so that other members of a Web 
team can see who is working on a file. You can add Design Notes to your files to 
share information with team members about a file’s status, priority, and so on. You 
can also use the Workflow Reports feature to run reports on your site to display 
information on the check in/check out status, and to search for Design Notes 
attached to files.

Dreamweaver can be integrated with some of the most popular source- and 
version-control applications. For source-control integration, you can connect to 
SourceSafe databases and other source-control systems that support the WebDAV 
protocol. (Note, however, that Dreamweaver does not perform version control.)
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Once you’ve published your site, you or someone on your team can continue to 
maintain it using these same tools. Before and after publishing, you’ll also want to 
troubleshoot your site on a continual basis. For more information, see “Testing 
and Publishing a Site” on page 501.

About the Site window
Use the Site window for standard file maintenance operations, such as creating 
new HTML documents; viewing, opening and moving files; creating folders; and 
deleting items. You can also use the Site window to transfer files between local and 
remote sites, and you can lay out your site navigation using the site map (see 
“Setting up a remote site” on page 123 and “Using the site map” on page 117.)

By default, the remote site or site map appears in the left pane, and the local site 
appears in the right pane. You can change this setting in Site preferences. See 
“Setting Site preferences” on page 110.

Using Site window controls

To open the Site window, choose Window > Site Files. Use the following buttons 
and options on the Site window toolbar to set what the Site window displays and 
to transfer files back and forth between a local and remote site:
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Site Files view displays the file structure of the remote and local sites in the panes 
of the Site window. (Which site is displayed in which pane, right or left, is 
determined by preference settings; see “Setting Site preferences” on page 110.) Site 
Files view is the default view for the Site window.

Site Map view displays a graphical map of your site based on how the documents 
are linked to one another. Hold this button down to choose Map Only or Map 
and Files from the pop-up menu.

The site pop-up menu lists sites you’ve defined. To switch sites, choose a different site 
from the list. To add a site or edit the information for an existing site, choose Define 
Sites from the bottom of the menu (see “Setting up a remote site” on page 123).

Connect/Disconnect (available with FTP and WebDAV protocol and SourceSafe) 

connects to or disconnects from the remote site. By default, Dreamweaver 
disconnects from the remote site if it has been idle for more than 30 minutes 
(FTP only). To change the time limit, choose Edit > Preferences and select Site. 

Refresh refreshes the local and remote directory lists. Use this button to manually 
refresh the directory lists if you deselected either Refresh Local File List Automatically 
or Refresh Remote File List Automatically in the Site Definition dialog box (see 
“Associating a remote server with a local site” on page 124). For example, if you 
mount a drive that contains a remote site after you open the Site window, you won’t 
see that remote site’s directory list until you click the Refresh button.

Get File(s) copies the selected files from the remote site to your local site 
(overwriting the existing local copy of the file, if any). If Enable File Check In and 
Check Out is turned on, the local copies are read-only; the files remain available 
on the remote site for other team members to check out. If Enable File Check In 
and Check Out is turned off, getting a file transfers a copy that has both read and 
write privileges. Note that the files copied are the ones selected in whichever pane 
of the Site window is currently active. If the Remote pane is active, the selected 
remote files are copied to the local site; if the Local pane is active, the remote 
versions of the selected local files are copied to the local site. See “Getting files 
from a remote server” on page 143.

Put File(s) copies the selected files from the local site to the remote site. Note that the 
files copied are the ones selected in whichever pane of the Site window is currently 
active. If the Local pane is active, the selected local files are copied to the remote site; 
if the Remote pane is active, the local versions of the selected remote files are copied 
to the remote site. See “Putting files onto a remote server” on page 144.

Note: If you are adding a file that doesn’t already exist on the remote site and Enable File 
Check In and Out is on, the file will be added to the remote site as “checked out.” Choose 
the Check In Files option instead to add a file without the checked out status.
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Check Out File(s) transfers a copy of the file from the remote server to your local 
site (overwriting the existing local copy of the file, if any) and marks the file as 
checked out on the server. This option is not available if Enable File Check In and 
Check Out is turned off for the current site. See “Checking in and checking out 
files on a remote server” on page 133.

Check In File(s) transfers a copy of the local file to the remote server and makes the 
file available for editing by others. The local file becomes read-only. This option is 
not available if the Enable File Check In and Check Out option in the Site 
Definitions dialog box is turned off for the current site. See “Checking in and 
checking out files on a remote server” on page 133.

Stop Current Task aborts any current activity, including getting and putting files. 
The button, a red stop-sign (octagon) shape with a white X, appears in the lower 
right corner of the window only when a task is in progress. Note that it may take a 
little time for the server to process the stop request, so the file transfer may not 
halt immediately. This button appears only when a task is in progress.

The collapse/expand triangle button in the lower left of the Site window lets you 
collapse or expand the Site window to display one or two panes.

Setting Site preferences

Choose Edit > Preferences and select Site, then choose from the following Site 
preferences to control file-transfer features available in the Site window.
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Always Show specifies which site (remote or local) is always shown, and in which 
Site window pane (left or right) the local and remote files appear. By default, the 
local site always appears on the right. Whichever pane is not chosen (the left one 
by default) is the changeable pane: this pane can display either the site map or the 
files in the other site (the remote site by default).

Dependent Files displays a prompt for transferring dependent files (such as 
images, external style sheets, and other files referenced in the HTML file) that the 
browser loads when it loads the HTML file. By default, both Prompt on Get/
Check Out and Prompt on Put/Check In are selected.

Note: To force the Include Dependent Files prompt to appear even when these options are 
deselected, hold down Alt (Windows) or Option (Macintosh) while choosing the Get, Put, 
Check In, or Check Out commands.

FTP Connection determines whether the connection to the remote site is 
terminated after the specified number of minutes have passed with no activity.

FTP Time Out specifies the number of seconds in which Dreamweaver attempts to 
make a connection with the remote server. If there is no response after the 
specified amount of time, Dreamweaver displays a warning dialog box alerting 
you to this fact.

Firewall Host specifies the address of the proxy server through which you connect 
to outside servers if you are behind a firewall. If you are not behind a firewall, 
leave this space blank.

Note: If you are behind a firewall, select the Use Firewall option in the Site Definition dialog 
box. See “Associating a remote server with a local site” on page 124.

Firewall Port specifies the port in your firewall through which you pass to connect 
to the remote server. If you connect through a port other than 21 (the default for 
FTP), enter the number here.

Put Options: Save Files Before Putting indicates that unsaved files are saved 
automatically before being put onto the remote site.

Define Sites brings up the Define Sites dialog box, where you can edit an existing site 
or create a new one. See “Associating a remote server with a local site” on page 124.

You can also define whether the types of files that you want to transfer should 
be transferred as ASCII (text) or binary. To do so, open the FTPExtensionMap.txt 
file in the Dreamweaver/Configuration folder (on the Mac, FTPExtensionMapMac.txt). 
You can modify and delete the list of which file types are transferred in each 
format, as well as add your own file types. If a file’s extension is not defined in this 
file, Dreamweaver automatically transfers the file in binary mode.

Note: On the Macintosh, the FTPExtensionMapMac.txt file also contains information 
about mapping file extensions to Macintosh creators and file types. This mapping allows a 
downloaded file to be given the correct icon and to be opened by the correct application 
when you double-click the file in the Finder.
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Note that when a file is transferred as ASCII, your Line Breaks preference setting 
is ignored. See “Setting code formatting preferences” on page 343.

Viewing and opening files in the 
Site window
Use the Site window for viewing local and remote sites, adding or removing site 
documents, or laying out the navigational structure of your site with a site map. 
For more information, see “About the Site window” on page 108.

You can set each of the two Site window views to show the local site, the remote 
site, or a graphical map of the local site. For example, you can view the local site in 
one pane and the remote site in the other, or you can view the local site in Site 
Files view in one pane and Site Map view in the other. (For information on 
viewing site maps, see “About the site map” on page 116.)

Viewing local sites

The Site window can display the contents of both local and remote sites. Local 
sites can be viewed in the Site window as a list of files, a visual map, or both. 
Remote sites can be viewed as a list of files only. (Before you can view a remote 
site, you must set one up; see “Setting up a remote site” on page 123.)

To view local site files, do one of the following:

• Choose Window > Site Files.

• In the Site window, if the site map is showing, click the Site Files button.

The Site window displays two sets of files: one side of the window lists the files 
in your local site, and one side lists the associated remote site files.

Note: If you are viewing a local site that has no corresponding remote site, the Remote 
Site view is empty.
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To view the site map and the site files, do one of the following:

• Choose Window > Site Map. (If you previously viewed the map only, without 
the site’s files, this displays the map only.)

• In the Site window, click the Site Map button, or hold down the mouse button 
with the pointer over the Site Map button and select Map and Files from the 
pop-up menu.

The Site window displays two views: the local site as a map, labeled Site 
Navigation; and, depending on how you set your preferences, either the local 
site files (labeled Local Folder) or the remote site files (labeled Remote Site). 

To view only the site map:

Hold down the mouse button with the pointer over the Site Map button and 
select Map Only from the pop-up menu. For more information, see “Using the 
site map” on page 117.
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Changing Site window layout

By default, the remote site (or the local site map) appears on the left side of 
the Site window and the local site appears on the right. You can switch 
these displays.

To change the Site window layout:

1 Choose Edit > Preferences and select the Site category.

2 Do either of the following:

• Select Local Files from the Always Show menu, and then choose whether to 
display the local files on the right or left side of the Site window.

The local site appears on the side you have selected, and the remote site (or the 
site map) appears on the opposite side. When you choose this option, the local 
site files view is always shown in the Site window, even when you collapse the 
window to one pane.

• Select Remote Files from the Always Show menu, and then choose whether to 
display the remote files on the right or the left.

The remote site appears on the side you have selected, and the local site (or the 
site map, which is always local) appears on the opposite side. When you choose 
this option, the remote site files view is always shown in the Site window, even 
when you collapse the window to one pane.

3 Click OK to apply changes and close the Preferences dialog box.

To change the view area:

In the Site window, do one of the following:

• Drag the bar that separates the two views to increase or decrease the view area 
of the right or left window.

• Use the scroll bars at the bottom of the Site window to scroll through the 
views’ contents.

• In the site map, drag the arrow above a file to change the space between files.

To collapse the Site window to one view:

Click the small white triangle button in the lower left of the Site window.

Note: The view that remains visible is the one you chose to always show in the Site 
preferences dialog box.

For more information about site preferences, see “Setting Site preferences” on 
page 110.
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Working with files in the Site Files view

Use the Site Files view to view local and remote sites as lists of files, to open files, 
to rename files, to add new folders or files to a site, or to refresh the view of a site 
after changes have been made. You can also use Site Files view to determine which 
files (on either site) have been updated since the last time they were transferred. 
For information on synchronizing the local site with the remote site, see 
“Synchronizing the files on your local and remote sites” on page 146.

To view the site files:

Do one of the following:

• Choose Window > Site Files to open the Site window in Site Files view.

• In the Site window, click the Site Files button.

To open a file from the Site Files view:

Double-click the file’s icon.

To add a new folder to a site:

1 Make sure a file or folder is selected in the Site window; the new folder is 
created inside the current selected folder, or in the same folder as the 
current selected file.

2 Choose File > New Folder in the Site window (Windows) or Site > Site Files 
View > New Folder (Macintosh). 

You can also access this option from the context menu within the Site window.

3 Enter a name for the new folder.

To add a new file to a site:

1 Make sure a file or folder is selected in the Site window; the new file is 
created inside the current selected folder, or in the same folder as the 
current selected file.

2 Choose File > New File in the Site window (Windows) or Site > Site Files 
View > New File (Macintosh). 

You can also access this option from the context menu within the Site window.

3 Enter a name for the new file.
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To rename a file or folder in a site:

1 In the Site window, select the file or folder you want to rename and do one of 
the following to activate the name field next to the file or folder:

• Choose File > Rename (Windows) or Site > Rename (Macintosh)

• Click on the file, pause, then click again.

2 Type in the new name and press Enter.

To refresh the Site Files view after making changes outside of Dreamweaver:

Do one of the following:

• Choose View > Refresh Local in the Site window(Windows) or Site > Site Files 
View > Refresh Local (Macintosh).

• Choose View > Refresh Remote in the Site window (Windows) or Site > Site 
Files View > Refresh Remote (Macintosh).

• Click the Refresh button in the Site window to refresh both panes.

To locate and select checked out files:

Choose Edit > Select Checked Out Files in the Site window (Windows) or Site > 
Site Files View > Select Checked Out Files (Macintosh).

To locate and select newer local files:

Choose Edit > Select Newer Local in the Site window (Windows) or Site > Site 
Files View > Select Newer Local (Macintosh).

To locate and select newer remote files:

Choose Edit > Select Newer Remote in the Site window (Windows) or Site > Site 
Files View > Select Newer Remote (Macintosh).

For more information about working with local and remote sites, see “Using 
Check In/Check Out” on page 131.

About the site map
Use the site map to view a local site as a visual map of linked icons, to add new 
files to a site, or to add, modify, or remove links. The site map is ideal for laying 
out a site structure. You can quickly set up the entire structure of the site and then 
create a graphic image of the site map.

Note: The site map applies to local sites only. If you want to create a map of a remote site, 
copy the contents of the remote site into a folder on your local disk and use the Define 
Sites command to define the site as a local site.
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Using the site map
You must define a home page for your site before you can display the site map. 
The site’s home page is the starting point of the map. 

To define a home page for your site: 

1 Choose Site > Define Sites. 

2 Choose New or Edit to define a new site or open an existing one.

The Site Definition dialog box appears. 

3 Select Site Map Layout.

4 Click the folder icon to browse for a home page for the site, or type a file path 
in the Home Page field.

To view a site map, do one of the following: 

• Choose Window > Site Map to open the Site window.

• In the Site window, click the Site Map button.

Note: If no home page has been defined, or if Dreamweaver can’t find an index.html or 
index.htm page in the current site to use as the home page, a dialog box appears 
prompting you to select a home page by clicking Define Sites. Choose the site you want, 
then click Edit. Then select Site Map Layout in the Site Definition dialog box.

The site map shows HTML files and other page content as icons. Links are 
displayed in the order in which they are encountered in the HTML source code.

• Text displayed in red indicates a broken link.

• Text displayed in blue and marked with a globe icon indicates a file on another 
site or a special link (such as an e-mail or script link).

• A green check mark indicates a file checked out by you.

• A red check mark indicates a file checked out by someone else.

• A lock icon indicates a file that is read-only (Windows) or locked (Macintosh).
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By default, the site map displays the site structure two levels deep, starting from 
the current home page. Click the plus (+) and minus (-) signs next to a page to 
show or hide pages linked below the second level.

By default, hidden files and dependent files are not displayed in the site map. 
Hidden files are HTML files marked as hidden. Dependent files are non-HTML 
page content such as images, templates, Shockwave files, or Flash files. See 
“Modifying the site map layout” on page 118 and “Showing and hiding site map 
files” on page 121.

Modifying the site map layout

Use the Site Map Layout options to customize the appearance of your site map. 
You can specify the home page, the number of columns displayed, whether the 
icon labels display the file name or the page title, and whether to show hidden and 
dependent files.

To modify the site map layout:

1 Open the Site Definition dialog box using one of these methods:

• Choose Site > Define Sites and then click Edit. Select Site Map Layout in the 
Category list on the left.

• Choose View > Layout (Windows) or Site > Site Map View > Layout 
(Macintosh).

2 Click the folder icon to browse for a home page for the site, or type a file path 
in the Home Page field. The home page must be on the local site. 

If you don’t specify a home page—and Dreamweaver cannot find a file called 
index.html or index.htm at the root—Dreamweaver will prompt you to select a 
home page when you open the site map.
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3 Choose from the Column options:

• In the Number of Columns field, type a number to set the number of pages to 
display per row in the site map window.

• In the Column Width field, type a number to set the width in pixels of the 
site map columns.

4 Under Icon Labels, select whether the name displayed with the document icons 
in the site map is represented as a file name or as a page title.

5 Under Options, select which files to display in the site map:

• Choose Display Files Marked as Hidden to display HTML files that are 
marked as hidden by the user in the site map. If a page is hidden, its name and 
links are displayed in italics. For information about hiding files, see “Showing 
and hiding site map files” on page 121.

• Choose Display Dependent Files to show all dependent files in the site’s 
hierarchy. A dependent file is an image or other non-HTML content that is 
loaded by the browser when the main page is loaded. 

Working with pages in the site map

When working in the site map, you can select pages, open a page for editing, add 
new pages to the site, create links between files, and change the page title. 

To select multiple pages in the site map, do one of the following:

• Press Shift-click to select multiple pages. 

• Starting from a blank part of the view, drag around a group of files to 
select them. 

• Press Control-click (Windows) or Command-click (Macintosh) to select 
nonadjacent pages.

To open a page for editing, do one of the following:

• Double-click the file.

• Select the file and choose File > Open Selection (Windows) or Site > 
Open (Macintosh). 

To add an existing file to the site, do one of the following:

• Drag a file from the Windows Explorer or the Macintosh Finder and drop it on 
a file in the site map. The page is added to the site, and a link is created between 
it and the file you dropped it on.

• Select Site > Link to Existing File (Windows) or Site > Site Map View > Link to 
Existing File (Macintosh).
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To create a new file and add a link:

1 Select an HTML file in the site map, then do one of the following: 

• Choose Site > Link to New File (Windows) or Site > Site Map View > Link to 
New File (Macintosh).

• Choose Link to New File from the context menu.

2 In the File Name field of the Link to New File dialog box, type a file name.

3 In the Title field, type a page title for the file.

4 In the Text of Link field, type the text of the link that connects the selected file 
to the new file. The text and link appears in the selected file.

5 Click OK. 

The file is saved in the same folder as the selected file. If a new file is added to a 
hidden branch, the new file is also hidden. See “Showing and hiding site map 
files” on page 121.

To modify the title of a page:

1 Make sure the Show Page Titles option is selected.

Choose View > Show Page Titles (Windows) or Site > Site Map View > 
Show Page Titles (Macintosh).

2 Do one of the following:

• Select a page and then click the title. When the title becomes an editable field, 
enter a new document title.

• Select a page and then choose File > Rename (Windows) or Site > Rename 
(Macintosh).

Note: When you work in the Site window, Dreamweaver automatically updates all links to 
files whose names have changed.

To change the home page, do one of the following:

• In the Local Folder view of the Site Window, click the file you want to change 
to the home page and choose Set as Home Page from the context menu.

• Select a file in the Site map, and choose Site > New Home Page (Windows) or 
Site > Site Map View > New Home Page (Macintosh) to create a new home page.

• In the Local Folder view of the Site Window, click the file you want to change 
to the home page, and choose Site > Set as Home Page (Windows) or Site > 
Site Map View > Set as Home Page (Macintosh) to make an existing page 
the home page.

• Choose Site > Define Sites and click Edit. Select Site Map Layout in the Site 
Definition dialog box.
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To update the site map display after making changes:

1 Click anywhere in the site map to deselect any files.

2 Choose View > Refresh Local (Windows) or Site > Site Map View > Refresh 
Local (Macintosh).

Showing and hiding site map files

You can modify the layout of the site map to show or hide hidden and dependent 
files. This is useful when you want to emphasize key topics or content and de-
emphasize less important material.

To hide a file using the site map, you must first mark it as hidden. When you hide 
a file, its links are also hidden. When you display a file marked as hidden, the icon 
and its links are visible in the site map, but the names appear in italics.

To mark files as hidden:

1 In the site map, select one or more files.

2 Choose View > Show/Hide Link (Windows) or Site > Site Map View > Show/
Hide Link (Macintosh).

To show or hide files marked as hidden, do one of the following:

• Choose View > Show Files Marked as Hidden (Windows) or Site > Site Map 
View > Show Files Marked as Hidden (Macintosh).

• Choose View > Layout (Windows) or Site > Site Map View > Layout 
(Macintosh) to open the Site Definition dialog box, and select the Display Files 
Marked as Hidden option.

By default, dependent files are already hidden. You can choose whether to show 
them in the site map.

To show dependent files, do one of the following:

• Choose View > Show Dependent Files (Windows) or Site > Site Map View > 
Show Dependent Files (Macintosh).

• Choose View > Layout (Windows) or Site > Site Map View > Layout 
(Macintosh) to open the Site Definition dialog box, and select the Display 
Dependent Files option.

To unmark files marked as hidden:

1 In the site map, select one or more files.

2 Choose View > Show Files Marked as Hidden (Windows) or Site > Site Map 
View > Show Files Marked as Hidden (Macintosh).

3 Choose View > Show/Hide Link (Windows) or Site > Site Map View >
Show/Hide Link (Macintosh).
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Viewing the site from a branch

You can view the details of a specific section of a site by making a branch the focus 
of the site map.

To view a different branch:

Select the page you want to view and choose View > View as Root (Windows) or 
Site > Site Map View > View as Root (Macintosh).

The site map is redrawn in the window as if the specified page were at the root of 
the site. The Site Navigation field above the site map displays the path from the 
home page to the specified page. Select any item in the path to view the site map 
from that level by clicking once.

To expand and contract branches:

Click the plus (+) and minus (–) signs to expand or contract the branch.

Saving the site map 

You can save the site map as an image and then view the image in (or print it 
from) an image editor.

To create an image file of the current site map:

1 From the site map, do one of the following:

• Using Windows, choose File > Save Site Map. In the Save Site Map dialog 
box, enter a name in the File Name field. In the File Type pop-up menu, 
select .bmp or .png.

• Using Macintosh, select Site > Site Map View > Save Site Map > Save Site Map 
As PICT or Site > Site Map View > Save Site Map > Save Site Map As JPEG.

2 Choose a location, enter a name for the image, and click Save.

Finding files in the Site window

You can search for a file in your local and remote sites from the Document 
window or the Site window. For more information on searching for and replacing 
files, see “Searching and replacing text, tags, and attributes” on page 258.

To display the Site window, choose Window > Site Files.
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To find a file in your local site:

1 Select the file in the Remote Site view of the Site window or open the file in a 
Document window.

2 Choose Site > Locate in Local Site. (On Windows only, if the Site window is 
active, choose Edit > Locate in Local Site.)

The file is highlighted in the Local Folder of the Site window.

To find a file in your remote site:

1 Select the file in the Local folder of the Site window or open the file in a 
Document window.

2 Choose Site > Locate in Remote Site. (On Windows only, if the Site window is 
active, choose Edit > Locate in Remote Site.) You can also select the file in the 
Local Folder and right-click (Windows) control-click (Macintosh) and choose 
Locate in Remote Site from the context menu.

The file is highlighted in the Remote Site view of the Site window.

Note: If you select Site > Locate in Local Site or Site > Locate in Remote Site while the 
Document window is active, and if the current file is not part of the currently open site, 
Dreamweaver attempts to determine which of your locally defined sites the current file 
belongs to; if the current file belongs to only one local site, Dreamweaver opens that site 
and then locates the file in it.

Setting up a remote site
Before you set up a remote site, create a local site (which you will then associate 
with the remote site). See “Using Dreamweaver to set up a new site” on page 102.

The next step in setting up a remote site is to determine where the site will be 
located—that is, what server the site will be served from. Your client, employer, or 
ISP probably has a server already set up to serve Web pages (whether Internet or 
intranet); ask a system administrator or your client for the name of that server, and 
find out how to transfer files to that server.

In particular, determine whether to use FTP to connect to the server, or whether 
you can instead mount the server as a network-accessible disk drive from your 
desktop. If you’re connecting using FTP, find out the name of the FTP server and 
determine the host directory, as well as login and password information.

When you’ve gathered this information, use the Define Sites command to 
associate the server with your local site. If you encounter problems setting up your 
remote site, see “Troubleshooting remote site setup” on page 130.

After you’ve set up a remote site, you can upload files to it, or download files from 
it if there are already files on the site. See “Using Check In/Check Out” on page 
131 and “Getting and putting files” on page 143.
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Associating a remote server with a local site

After you’ve created a local site, use the Define Sites command to add or change 
associated remote server information and Check In/Check Out preferences.

To associate a remote server with an existing local site:

1 Choose Define Sites from the current sites pop-up menu in the Site window, or 
choose Site > Define Sites.

2 A dialog box appears listing currently defined sites; select an existing site 
and click Edit. 

If you have no currently defined sites, create a local site before proceeding; see 
“Using Dreamweaver to set up a new site” on page 102. 

3 In the Category list at the left, click Remote Info.

4 Choose one of the following Server Access options:

• Use None if you do not plan to upload your site to a server. Then click OK and 
skip the rest of this procedure.

• Use Local/Network if your Web server is mounted as a network drive 
(Windows) or as an AppleTalk or NFS server (Macintosh), or if you are 
running a Web server on your local machine. Click the folder icon to browse to 
and select the folder where your site files are stored on the server. If you want 
the Remote pane of the Site window to update automatically as files are added 
and deleted, select the Refresh Remote File List Automatically option; for 
increased speed when copying files to the remote site, leave this option 
unselected. (To manually refresh the Site window at any time, click the Site 
window’s Refresh button.) Click OK and skip the rest of this procedure.

Note: To manually refresh the Remote pane only, choose View > Refresh Remote in the 
Site window (Windows) or Site > Site Files View > Refresh Remote (Macintosh). 

• Use FTP if you connect to your Web server using FTP.
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To connect to a Web server using FTP:

1 Enter the host name of the FTP host to which you upload files for your 
Web site.

Your FTP host name is the full Internet name of a computer system, such as 
ftp.mindspring.com. Enter the full host name without any additional text; in 
particular, don’t add a protocol name in front of the host name. For example:

• Right: ftp.mindspring.com

• Wrong: ftp://ftp.mindspring.com

• Wrong: mindspring.com

2 Enter the name of the host directory at the remote site where documents visible 
to the public are stored. See “Determining the remote site’s host directory (FTP 
only)” on page 126.

3 Enter the login name and password that you use to connect to the FTP server.

Dreamweaver saves your password by default. Deselect Save if you prefer to be 
prompted for a password each time you connect to the remote server.

4 Select appropriate firewall options for your site:

• Select the Use Firewall option if you are connecting to the remote server from 
behind a firewall. (For more information on firewall options, see “Associating a 
remote server with a local site” on page 124.

• If your firewall configuration requires use of passive FTP (which lets your local 
software set up the FTP connection rather than requesting the remote server to 
set it up), select Use Passive FTP. If you’re not sure, check with your system 
administrator.

5 Click OK.
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Determining the remote site’s host directory (FTP only)

The host directory you specify in the Site Definition dialog box should be the same 
as the root folder for the local site. If the structure of your remote site doesn’t match 
the structure of your local site, your files are uploaded to the wrong place and aren’t 
visible to visitors to the site. Also, your image and link paths will be broken.

The remote root directory must exist before Dreamweaver can connect to it. If 
you don’t have a root directory for your site on the remote server, create one before 
attempting to connect, or ask the server’s administrator to create a root directory 
for you if you can’t do it.

If you’re uncertain what to enter in the Host Directory field, try leaving it blank. 
On some servers, your root directory is the same as the directory you first connect 
to with FTP. To find out, connect to the server. If a folder with a name like 
public_html, or www, or your login name, appears in the Remote File view in 
your Site window, that’s probably the directory you should use in the Host 
Directory field. Write down the directory name, disconnect, and reopen the Site 
Definition dialog box. Then enter the directory name in the Host Directory field 
and connect again.

Should be Host
Directory

Shouldn’t be Host
Directory

Shouldn’t be Host 
Directory in this case

no

no

yes
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About WebDAV and SourceSafe 
integration
Dreamweaver lets you access source- and version-control applications from the 
Site window. You can connect to SourceSafe databases and servers or source-
control systems that support the WebDAV protocol. 

Using the Site Definition dialog box, you select the a connection type or source-
control system. Once connected, you can use Dreamweaver file sharing features 
such as Check In/Check Out, Refresh, Get and Put, and Design Notes to access 
corresponding features found in your own source-control system.

Note: To use this feature, you must have Visual SourceSafe installed on your system or 
have access to a system supported by WebDAV.

Using Dreamweaver with the WebDAV protocol

You can use Dreamweaver to connect using the WebDAV (Web-based Distributed 
Authoring and Versioning) protocol if you have a system that supports that 
protocol. Two examples of WebDAV servers currently available are Microsoft 
Internet Information Server (IIS) 5.0 and Apache Web Server.

To connect to a site using the WebDAV protocol:

1 Choose Site > Define Sites. 

2 In the Define Sites dialog box, select Edit.

3 In the Site Definition dialog box, select the Remote Info category.

4 In the Access pop-up menu, choose WebDAV.

5 If you want, select the Check Out Files when Opening to check out files 
automatically when opening.

6 Click Info. 

The WebDAV Connection dialog box appears.
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7 In the URL field, enter the complete URL to the directory on the WebDAV 
server that you want to connect to. 

This URL includes the protocol, port, and directory (if not the root 
directory)—for example, http://apache1/WebDAV/mysite.

8 Enter your username and password in the appropriate fields. 

This information is for server authentication and is not related to 
Dreamweaver. If you are not sure of your username and password, check 
with your system administrator or webmaster.

9 In the Email field, enter your e-mail address. 

This is required and is used to identify ownership on the WebDAV server and 
appears in the Site window for contact purposes.

10 Click Save Password to store your password once you’ve exited Dreamweaver. 

Each time you start a new session, the password is still saved.

11 Click OK.

12 Choose Site > Connect or click the Connect button on the Site window toolbar 
to connect to the remote site. To disconnect, choose Site > Disconnect or click 
the Disconnect button.

Once connected, you can use the Dreamweaver file sharing features (Get and Put 
files, Design Notes, and so on). 

You can change your connection information at any time by following the 
steps just listed and entering the new information in the WebDAV Connection 
dialog box.

Using Dreamweaver with Visual SourceSafe

You can access an existing Visual SourceSafe (VSS) database using the Site 
window in Dreamweaver. Once connected, you can use Dreamweaver file 
transfer features.

Note: To use this feature with Windows, you must have Microsoft Visual SourceSafe Client 
version 6 installed. To use this feature on the Macintosh, you must have MetroWerks 
SourceSafe version 1.1.0 client installed. MetroWerks Visual SourceSafe users can access 
Microsoft version 5.0 SourceSafe databases, but not version 6.0 databases. If you want to 
ensure that your entire team can access any VSS database across platforms, use a version 
5.0 database. For more information, see your SourceSafe documentation.
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To connect to a SourceSafe database:

1 In the Site Definition dialog box, select the Remote Info category.

2 In the Access pop-up menu, choose SourceSafe Database. 

3 If you want, select Check Out Files when Opening to check out files 
automatically when opening.

4 Click Info. 

The Open SourceSafe Database dialog box appears.

5 In the Database Path field, click Browse to browse for the VSS database you 
want, or enter the full file path.

The file you choose will become the srcsafe.ini file and is used to initialize 
SourceSafe.

6 In the Project field, enter the project within the VSS database that you want to 
use as the remote site’s root directory.

7 In the Username and Password fields, enter your login username and password 
for the selected database.

If you don’t know your username and password, check with your system 
administrator.

8 Click OK and return to the Site window.

9 Choose Site > Connect or click the Connect button on the Site window toolbar 
to connect to the remote site. To disconnect, choose Site > Disconnect or click 
the Disconnect button.
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Troubleshooting remote site setup
A Web server can be configured in a wide variety of ways. This section provides 
information on some common issues you may encounter in setting up a remote 
site, and how to resolve them.

• The Dreamweaver FTP implementation may not work properly with certain 
proxy servers, multilevel firewalls, and other forms of indirect server access. If you 
encounter problems with FTP access, ask your local system administrator for help.

• The Dreamweaver FTP implementation is different from some common FTP 
applications. In particular, you must connect to the remote system’s root folder 
and you cannot navigate through the remote file system. (In many applications, 
you can connect to any remote directory, then navigate through the remote file 
system to find the directory you want.) 

• If you are having problems connecting and you’ve specified the host directory 
using a single slash (/), you may need to specify a relative path from the 
directory you are connecting to and the remote root folder. For example, if the 
remote root folder is a higher level directory, you may need to specific a ../../ for 
the host directory. 

• Sometimes with slow connections the default FTP time-out value of 60 
seconds results in too many time-outs. Increase this value (in Site preferences) if 
you experience frequent time-outs. But don’t increase it too much, or you’ll 
have to wait a long time when a connection really can’t be made. Generally, 
time-out values of 30 to 120 seconds are the most useful.

• File and folder names that contain spaces and special characters often cause 
problems when transferred to a remote site. Use underscores in place of spaces, 
and avoid special characters in file and folder names wherever possible. In 
particular, colons, slashes, periods, and apostrophes in file or folder names can 
cause problems. Special characters in file or folder names may also sometimes 
prevent Dreamweaver from creating a site map.

• On the Macintosh, file names cannot be more than 31 characters long. If you 
encounter problems with long file names, rename them with shorter names.

• Note that many servers use symbolic links (UNIX), shortcuts (Windows), or 
aliases (Macintosh) to connect a folder on one part of the server’s disk with 
another folder elsewhere. For example, the public_html subdirectory of your 
home directory on the server may really be a link to another part of the server 
entirely. In most cases, such aliases have no effect on your ability to connect to 
the appropriate folder or directory, but if you can connect to one part of the 
server but not another, there may be an alias discrepancy.

• In general, when you encounter a problem with an FTP transfer, examine the 
FTP log by choosing Window > Site FTP Log in the Site window (Windows) 
or Site > FTP Log (Macintosh). If you encounter an error message such as 
“cannot put file,” your remote site may be out of space. Look at the FTP log for 
more detailed information.
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Using Check In/Check Out
When working in a collaborative environment, you can check files in and out 
from local and remote servers and use Design Notes to add comments and notes 
for your team. Checking out a file is the equivalent of declaring “I’m working on 
this file now—don’t touch it!” When a file is checked out, Dreamweaver displays a 
check mark next to the file’s icon in the Site window. A green check mark indicates 
that the file was checked out by you, and a red check mark indicates that the file 
was checked out by another team member. The name of the person who checked 
out the file is also displayed in the Site window.   

Checking in a file makes the file available to other team members to check out and 
edit. The local version becomes read-only to prevent you from making changes to 
the file while someone else has it checked out.

Dreamweaver does not make checked-out files read-only on the remote server. 
If you transfer files with an application other than Dreamweaver, you can 
overwrite checked-out files. However, in applications other than Dreamweaver, 
the .LCK file is visible next to the checked-out file in the file hierarchy to help 
prevent such accidents.

You can enable Check In/Check Out for some sites and disable it for others. For 
information about transferring files between local and remote sites without 
checking them in or out, see “Getting files from a remote server” on page 143 and 
“Putting files onto a remote server” on page 144.
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Setting up the Check In/Check Out system

Before you can use the Check In/Check Out system, you must have associated 
your local site with a remote FTP or network server (see “Associating a remote 
server with a local site” on page 124). Then you must set up the following options.

To set Check In/Check Out options:

1 Choose Site > Define Sites, select a site, and click Edit.

2 In the Category list at the left, click Remote Info.

3 Do any of the following:

• Select the Enable File Check In and Check Out option if you are working in a 
team environment (or working alone but from several different machines).

This option is useful for letting others know that you have a file checked out 
for editing, or for alerting yourself that you may have left a more recent version 
of a file on another machine. See “Using Check In/Check Out” on page 131.

• Select the Check Out Files when Opening option if you want files to 
automatically be checked out when you double-click to open them from the 
Site window. (Using File > Open to open a file doesn’t check the file out even 
when this option is selected.)

• Enter a check-out name.

The check-out name appears in the Site window alongside any files that you 
have checked out, enabling other team members to locate you if you have a file 
that they need. If you work alone from several different machines, use a 
different check-out name on each machine (for example, AmyR-HomeMac 
and AmyR-OfficePC) so you’ll know where the latest version of the file is if you 
forget to check it back in.

• Enter an e-mail address.

If you enter an e-mail address and then check out a file, your name appears in 
the Site window next to that file as a clickable link (blue and underlined). If a 
team member clicks on the link, their default e-mail program pops up with a 
new message. The To field will contain the e-mail address, and the Subject field 
will contain the corresponding file and site name. 
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Checking in and checking out files on a remote server

Use the Site window or the Site menu in the Document window to check in and 
check out files on a remote server.

If you’ve checked out a file but have decided not to edit it (or have decided to 
discard the changes you’ve made), you can undo a check out, to make the file on 
the server available to other team members to check out.

Note: If you select Site > Check In or Site > Check Out while the Document window is active, 
and if the current file is not part of the currently open site, Dreamweaver attempts to 
determine which of your locally defined sites the current file belongs to; if the current file 
belongs to only one local site, Dreamweaver opens that site and then performs the check in 
or check out operation.

To check out files from a remote server:

1 Choose the desired site from the current sites pop-up menu at the top of 
the Site window.

2 Check out files using one of the following approaches:

• Select one or more files and click the Check Out icon at the top of 
the Site window.

• Choose Check Out from the context menu or the Site menu.

3 To download dependent files along with the selected files, click Yes at the 
prompt. To refrain from downloading dependent files, click No.

To check in files to a remote server:

1 Choose the desired site from the current sites pop-up menu at the top of 
the Site window.

2 Select one or more checked-out or new files in the Local pane and do one 
of the following:

• Click the Check In icon at the top of the Site window. 

• Choose Check In from the context menu or the Site menu.

Files checked out by you are marked with a green check mark. If a file has a 
red check mark next to it, it’s currently checked out by another user; don’t 
check in such files.

A lock symbol next to a file indicates that the file is read-only (Windows) or 
locked (Macintosh).

New files have neither a check mark nor a lock symbol next to them.

3 To upload dependent files along with the selected file, click Yes at the prompt. 
To refrain from uploading dependent files, click No. It’s usually a good idea 
to upload dependent files when checking in a new file, but if the latest versions 
of the dependent files are already on the remote server, there’s no need to 
upload them again.
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To undo a check out:

Select the file and choose Site > Undo Check Out, or right-click (Windows) or 
Control-click (Macintosh) the file and choose Undo Check Out from the context 
menu. The local copy of the file becomes read-only, and any changes you’ve made 
to it are lost.

To check in or check out a currently active file:

In the Document window, choose Site > Check In or Site > Check Out, or use the 
icons found on the toolbar.

If you check out the currently active file, the currently open version of the file is 
overwritten by the new checked-out version. If you check in the currently active 
file, the file may be automatically saved before it’s checked in, depending on the 
preference options you’ve set; see “Setting Site preferences” on page 110. 

About Design Notes
You can keep track of extra file information associated with your documents, such 
as image source-file names and comments on file status, by using the Design 
Notes command.

For example, if you copy a document from one site to another, you can add 
Design Notes for that document, with the comment that the original document is 
in the other site folder. Then if you update that document (or someone else does), 
you’ll know that you need to update the original page as well.

You can also use Design Notes to keep track of sensitive information that you 
can’t put inside a document for security reasons. For example, you can include 
information about how the document was created, or notes on how a particular 
price or configuration was chosen, or what marketing factors influenced a 
design decision. You can see which files have Design Notes attached in the Site 
window: a Design Notes icon appears in the Notes column of the Site Files view.
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Saving file information in Design Notes

You can create a Design Notes file for each document or template in your site. 
(Note that if you add Design Notes to a template, the documents created with the 
template do not inherit the Design Notes.) You can also create Design Notes for 
applets, ActiveX controls, images, Flash movies, Shockwave objects, and image 
fields in your documents.

To set up Design Notes for your site:

1 Choose Site > Define Sites, select a site, and click Edit.

2 In the Category list at the left, click Design Notes.

• Enable Design Notes for your site by selecting Maintain Design Notes (if it’s 
not already selected).

When Maintain Design Notes is selected, you can create Design Notes for files 
in your site. Whenever a file is copied, moved, renamed, or deleted, the 
associated Design Notes file is also copied, moved, renamed, or deleted.

• Choose whether the Design Notes associated with your site are uploaded 
with the rest of your documents, by selecting or deselecting Upload Design 
Notes for Sharing.

When Upload Design Notes for Sharing is selected, you can share Design 
Notes with the rest of your team. When you put or get a file, Dreamweaver 
automatically puts or gets the associated Design Notes file. If you work alone 
on your site, you can deselect this option to improve performance of file 
transfers; when the option is deselected, Design Notes are maintained locally 
but are not uploaded with your files.

3 Click OK.
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To add Design Notes to a document:

1 While the document is active in the Document window, choose File > 
Design Notes.

You can also select the file in the Site window, and then choose File > Design 
Notes, or double-click on the Notes column. If the file resides on a remote site, 
you must first check out or get the file, then select it in the local folder. (See 
“Checking in and checking out files on a remote server” on page 133 or 
“Getting and putting files” on page 143.)

2 In the Basic Info tab, add notes of various sorts:

• Choose the status of the document from the Status pop-up menu.

• Type comments in the Notes text field.

• Click the date icon (just above the Notes text field) to insert the current 
local date.

• To make the Design Notes file appear every time the file is opened, select Show 
When File Is Opened.

3 In the All Info tab, add other keys and values that might be useful to other 
developers of your site. For example, you could name a key Author (in the 
Name field) and define the value as Heidi (in the Value field). Click the 
Plus (+) button to add a new key/value pair; select a pair and click the 
Minus (–) button to remove it.

4 Click OK to save the notes.

The notes you entered are saved to a subfolder called _notes, in the same 
location as the current file. The file name is the document’s file name, plus the 
extension .mno. For example, if the file name is index.html, the associated 
Design Notes file is named index.html.mno.

To add Design Notes to an object:

1 Choose Design Notes from the object’s context menu. (Open the context menu 
for the object by right-clicking (Windows) or Control-clicking (Macintosh) 
the object.)

2 Follow steps 2 through 4 above for adding Design Notes to a document.

Note that an object’s Design Notes file is saved in a _notes subfolder in the 
same directory as the object’s source file, which is not necessarily in the same 
directory as the document that the object appears in.

To open Design Notes associated with a file, do one of the following:

• Select the file in the Site window, or open the file itself; then choose File > 
Design Notes. The Design Notes associated with that file opens.

• In Notes column of the Site window, double-click the yellow Design Notes icon. 
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To assign a status that isn’t listed in the Status pop-up menu:

1 Open Design Notes for a file or object.

2 Click the All Info tab.

3 Click the Plus (+) button.

4 In the Name field, enter the word status.

5 In the Value field, enter the status.

If a status value already existed, it’s replaced with the new one.

6 Click the Basic Info tab and note that the new status value appears in the 
Status pop-up menu.

Note: You can have only one new value in the status menu at a time. If you follow this 
procedure again, the new status value you entered the first time is replaced with the new 
status value you enter the second time.

To disable Design Notes:

1 Choose Site > Define Sites.

2 In the Define Sites dialog box, select the site and click Edit.

3 In the Site Definition dialog box, click Design Notes.

4 Deselect Maintain Design Notes.

Deselecting this option disables the Design Notes capability. If you deselect 
this option and then click Clean Up, all local Design Notes files for your 
site are deleted. 

5 Click OK.

A dialog box appears, asking if you would like to delete existing Design Notes 
files. Click Yes to delete such files, or No to leave them in place.

To use Design Notes locally only:

1 Choose Site > Define Sites.

2 In the Define Sites dialog box, select the site and click Edit.

3 In the Site Definition dialog box, select Maintain Design Notes in the 
Design Notes box.

4 Deselect Upload for Sharing.

Design Notes will not be transferred to the remote site when you check in/put 
your files. You will still be able to add and modify the Design Notes for 
your site locally.
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To delete unassociated Design Notes from your site:

1 Choose Site > Define Sites.

2 In the Define Sites dialog box, select the site and click Edit.

3 In the Site Definition dialog box, click Design Notes.

4 Click Clean Up. Dreamweaver prompts you to verify that it should delete any 
Design Notes that are no longer associated with a file in your site. (If you use 
Dreamweaver to delete a file that has an associated Design Notes file, the 
Design Notes file is deleted too, so usually orphan Design Notes files occur 
only if you delete or rename a file outside of Dreamweaver.)

Note: If you deselect the Maintain Design Notes option before you click Clean Up, 
Dreamweaver deletes all Design Notes files for your site.

Using file view columns with Design Notes

You can customize the columns displayed in the Site window’s Local Folder and 
Remote Site lists. You can reorder columns, add new columns (for a maximum of 
10 columns), delete columns, hide columns, associate Design Notes to column 
data, and designate columns to be shared with all users connected to a site. The 
default columns are Name, Notes, Size, Type, Modified, and Checked Out By. 
You can sort by any column by clicking on the column heading in the Site 
window. Clicking more than once on a column reverses the order (ascending and 
descending) by which the column is sorted.

Note: You cannot delete, rename, or associate a Design Note with a built-in column 
(Name, Notes, Size, Type, Modified, Checked Out By). You can change the ordering and 
alignment of these columns, as well as hide them, with the exception of the Name column, 
which cannot be hidden.
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To access File View Columns options, do one of the following:

• Choose View > File View Columns in the Site window (Windows) or Site > 
Site Files View > File View Columns (Macintosh).

• Choose > Define Sites, select a site, and click Edit. Then select File View 
Columns from the Site Definition Dialog box.

• In the Site window, right-click (Windows) or Control-click (Macintosh) a 
column and select File View Columns.

The Site Definition dialog box appears, displaying File View Columns options.

To change the order of the columns:

1 From the File View Columns display of the Site Definition dialog box, select a 
column name.

2 Click the up or down arrow button to change the position of the selected column. 

You can change the order of any column except Name, which always remains in 
the primary position.
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To add a new column:

1 In the File View Columns display of the Site Definition dialog box, click the 
Plus (+) button.

2 In the Column Name field, enter a name for your column. 

3 Choose a value from the Associate with Design Note pop-up menu, or type 
in your own.

You must associate a new column with a Design Note, so that there is data to 
display in the Site window.

4 Choose an alignment option: left, right, or center. This determines how the 
text is aligned within the column.

5 To reveal or hide the column, select or deselect the Show option.

6 To share the column with all users connected to the site, select the Share with 
All Users of This Site option.

To delete an added column:

1 Select the column you want to delete.

2 Click the Minus (-) button. 

Note: The column is deleted immediately and without confirmation, so be very sure you 
want to delete the column before clicking the Minus (-) button.

Using Design Notes in Fireworks and Dreamweaver

If you open a graphic in Macromedia Fireworks 4.0 and export it to another format, 
Fireworks automatically saves the name of the original source file in a Design Notes 
file. For example, if you open myhouse.png in Fireworks and export it to 
myhouse.gif, Fireworks automatically creates a Design Notes file called 
myhouse.gif.mno, which contains the name of the original file, as an absolute file: 
URL. For example, the Design Notes for myhouse.gif might contain this line:

fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"

If the image contains hotspots or rollovers, the HTML source for those items is 
also added to the Design Notes file.

When you import the graphic into Dreamweaver, the Design Notes file is 
automatically copied into your site along with the graphic. When you select 
the image in Dreamweaver and choose to edit it using Fireworks (see “Launching 
an external editor” on page 298), Fireworks opens the original file for 
editing. For more information, see “Using Dreamweaver and Fireworks Together” 
on page 281.
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Using reports to improve workflow
Use the Site > Reports command to improve collaboration among members of a 
Web team. You can run workflow reports that display who has checked out a file 
and which files have Design Notes associated with them. You can further refine 
Design Note reports by specifying name/value parameters. For information on 
running other types of reports, see “Using Reports to test a site” on page 509. 

Note: You must have a remote site connection defined to run the Workflow reports.

To run a Checked Out By report:

1 Choose Site > Reports. 

The Reports dialog box appears.

2 Choose an option from the Report On pop-up menu. You can choose to report 
on a document, an entire site, selected files in a site, or a specific folder. 

3 Under Workflow, select Checked Out By.

4 Click the Reports Setting button. 

The Checked Out By dialog box appears.

5 Enter the name of a team member and click OK.

6 Click Run.

The report runs, and the Reports dialog box displays a summary of the files 
that have been checked out by the specified person.
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To run a report on specific Design Notes:

1 Choose Site > Reports. 

The Reports dialog box appears.

2 Choose an option from the Report On pop-up menu. You can choose to report 
on a document, an entire site, selected files in a site, or a specific folder. 

3 Under Workflow, select Design Notes. 

The Report Settings button becomes available.

4 Click the Report Settings button.

The Design Notes dialog box appears.

5 Enter one or more name and value pairs, and select comparison values from the 
corresponding pop-up menus. 

For example, if you specify “status contains draft,” your report will look for files 
whose Design Notes have a status of “draft.”

6 Click OK to return to the Reports dialog box. 

7 Click Run to run the report.
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Getting and putting files
If you’re working in a collaborative environment, use the Check In/Check Out 
system to transfer files between local and remote sites (see “Using Check In/Check 
Out” on page 131). If you’re the only person working on the remote site, however, 
you can instead use the Get and Put commands to transfer files without checking 
them in or out.

Note: If you select Site > Get or Site > Put while the Document window is active, and if the 
current file is not part of the currently open site, Dreamweaver attempts to determine which 
of your locally defined sites the current file belongs to; if the current file belongs to only one 
local site, Dreamweaver opens that site and then performs the Get or Put operation. 

Getting files from a remote server

Getting files copies them from the remote site to your local site.

If you’re using the Check In/Check Out system (that is, if the Enable File Check 
In and Check Out option is on), the Get command results in a read-only local 
copy of the file; the file remains available on the remote site for other team 
members to check out. If Enable File Check In and Check Out is turned off, then 
getting a file transfers a copy that has both read and write privileges. See “Using 
Check In/Check Out” on page 131.

Note: If you’re working in a collaborative environment—that is, if others are working on the 
same files—then turning off Enable File Check In and Check Out is not recommended. In 
particular, if other people are using the Check In/Check Out system with the site, you 
should use that system as well.

Note that the files that are copied when you click Get are the ones selected in 
whichever pane of the Site window is currently active. If the Remote pane is 
active, then the selected remote files are copied to the local site; if the Local 
pane is active, then the remote versions of the selected local files are copied to 
the local site.

If you are not working in a collaborative environment and you want to have read/
write privileges for files that you get, turn off the Enable File Check In and Check 
Out option for the site; see “Associating a remote server with a local site” on page 124.

To get only those files for which the remote version is more recent than the local 
version, use the Synchronize command; see “Synchronizing the files on your local 
and remote sites” on page 146.
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To get files from a remote server:

1 Choose Window > Site Files to open the Site window.

2 At the top of the Site window, choose the desired site from the current sites 
pop-up menu.

3 If you’re using FTP to transfer files, click Connect to open a connection to 
the remote server.

If a connection is already open (indicated by the Disconnect button displayed), 
skip this step. If the remote files are visible in the Remote pane from a previous 
connection, clicking Connect isn’t required; when you click Get, Dreamweaver 
connects automatically.

4 Select the desired files to download. (Usually you select these in the Remote 
pane, but you may instead select the corresponding files in the Local pane 
if you prefer.)

5 Click Get, or choose Get from the context menu or the Site menu. If the file is 
currently open in a Document window, you can instead choose Site > Get from 
the Document window.

6 To download dependent files, click Yes; to skip them, click No. (If you already 
have local copies of the dependent files, click No.) To avoid being asked about 
dependent files in future downloads, select the Don’t Ask Me Again option.

Note: To stop the file transfer at any time, click the Stop Current Task button (the red stop 
sign with the white X in the lower right corner of the Site window) or press Esc (Windows) 
or Command+period (Macintosh). The transfer may not stop immediately.

Dreamweaver records all FTP file transfer activity. If an error occurs when you are 
transferring a file using FTP, the Site FTP log can help you determine the 
problem. To display the log, choose Window > Site FTP Log from the Site 
window (Windows) or Site > Site FTP Log (Macintosh).

Putting files onto a remote server

Using the Put command copies files from the local site to the remote site, 
generally without changing the file’s checked out status. There are two common 
situations in which you use Put instead of Check In: when you’re not in a 
collaborative environment and you aren’t using the Check In/Check Out system, 
or when you want to put the current version of the file on the server but you’re 
going to keep editing it.

Note: If you put a file that didn’t previously exist on the remote site and you’re using the 
Check In/Check Out system, the file is copied to the remote site and is then checked out to 
you for continued editing.

If you want to put a file on a remote server and check it in, use the Check In 
command. See “Checking in and checking out files on a remote server” on page 133.
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To put only those files for which the local version is more recent than the remote 
version, see “Synchronizing the files on your local and remote sites” on page 146.

Note: Do not use special characters (such as é, ç, or ¥) or punctuation such as colons, 
slashes, or periods in the names of files you intend to put on a remote server. Many 
servers change these characters during the upload process, which causes any links to 
the files to break.

To put files on a remote server:

1 Choose Window > Site Files to open the Site window.

2 At the top of the Site window, choose the desired site from the current sites list 
pop-up menu.

3 If you’re using FTP to transfer files, you may click Connect to open a 
connection to the remote server, which allows you to see what’s on the remote 
site before transferring any files. However, clicking Connect is not required; 
when you click Put, Dreamweaver connects automatically. 

4 Select the desired files to upload. (Usually you select these in the Local 
pane, but you may instead select the corresponding files in the Remote pane 
if you prefer.)

5 Click Put, or choose Put from the context menu or the Site menu.

6 If the file hasn’t been saved, a dialog box may appear (depending on your 
preference setting in the Site panel of the Preferences dialog box) allowing you 
to save the file before putting it on the remote server. To save the file, click Yes; 
to put the previously saved version on the remote server, click No.

If you choose not to save the file, any changes you’ve made since last time you 
saved will not be put onto the remote server. However, the file remains open, so 
you can still save the changes after putting the file on the server if you want.

7 To upload dependent files, click Yes; to skip them, click No. (If the remote site 
already contains copies of the dependent files, click No.) To avoid being asked 
about dependent files in future uploads, select the Don’t Ask Me Again option.

Note: To stop the file transfer at any time, click the Stop Current Task button (the red stop 
sign with the white X in the lower right corner of the Site window) or press Esc (Windows) 
or Command+period (Macintosh). The transfer may not stop immediately.

If the file is currently open in a Document window, you can instead choose Site > 
Put from the Document window.

Dreamweaver records all FTP file transfer activity. If an error occurs when you are 
transferring a file using FTP, the Site FTP log can help you determine the 
problem. To display the log, choose Window > FTP Log from the Site window 
(Windows) or Site > FTP Log (Macintosh).
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Synchronizing the files on your local and 
remote sites
Once you’ve created files in your local and remote sites, you can synchronize the 
files between the two sites. Use the Site > Synchronize command to transfer the 
latest versions of your files to and from your remote site.

If your remote site is an FTP server (rather than a networked server), then 
synchronizing your files uses FTP. For more information on using FTP, see 
“Associating a remote server with a local site” on page 124.

Before you synchronize your sites, Dreamweaver lets you verify which files you 
want to put onto or get from your remote server. Dreamweaver also confirms 
which files have been updated after you complete the synchronization.

To see which files are newer on the local site or which files are newer on the 
remote site, without synchronizing, choose Edit > Select Newer Local or 
Edit > Select Newer Remote (Windows, from the Site window) or Site > 
Site Files View > Select Newer Local or Site > Site Files View > Select Newer 
Remote (Macintosh).

To synchronize your files:

1 If you want to synchronize specific files or folders rather than the whole 
site, choose those files or folders in either the Local or the Remote pane of 
the Site window.

2 Choose Site > Synchronize in the Site window (Windows) or from the menu 
bar (Macintosh).

3 To synchronize the entire site, choose Entire ‘Site Name’ Site from the 
Synchronize pop-up menu. To synchronize selected files only, choose Selected 
Local Files Only (or Selected Remote Files Only if the Remote pane was where 
you made the most recent selection).

4 Choose the direction in which you want to copy the files:

• Choose Put Newer Files to Remote if you want to upload all the local files that 
have more recent modification dates than their remote counterparts.

• Choose Get Newer Files from Remote if you want to download all the remote 
files that have more recent modification dates than their local counterparts.

• Choose Get and Put Newer Files to place the most recent versions of all the files 
on both the local and the remote sites.
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5 Choose whether to delete the files on the destination site that don’t have 
counterparts on the origin site. (This is not available if you have selected 
“Get and Put”.)

If you choose Put Newer Files to Remote and you select the Delete option, 
then Dreamweaver deletes any files in your remote site for which there are no 
corresponding local files. If you choose Get Newer Files from Remote, then 
Dreamweaver deletes any files in your local site for which there are no 
corresponding remote files.

6 Click Preview.

If the newest version of each chosen file is already in both places and nothing 
needs to be deleted, an alert appears, informing you that no synchronization 
is necessary.

7 In the Synchronize Files dialog box, verify which files you want to delete, 
put, and get. If you don’t want Dreamweaver to delete, put, or get a 
particular file, deselect it by clicking the checkbox to the left of the file (in 
the Action column).

8 Click OK. The files are automatically transferred (and deleted as necessary), 
and Dreamweaver updates the Synchronize Files dialog box with the status.

9 To save the verification information to a local file, click Save Log.
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Setting Up a Document

Once you’ve created a local site, you can create documents to put in the site. 
(If you haven’t set up a site yet, see “Using Dreamweaver to set up a new site” on 
page 102.) A document—that is, a page of your Web site—can contain text 
and images, as well as more sophisticated content such as animation, video, 
links to other documents, and sound. As you create and work with documents, 
Macromedia Dreamweaver automatically generates their underlying HTML 
and JavaScript source code. To examine or edit this code, use one of the 
Dreamweaver code editors: the Code view in the Document window, or the Code 
inspector. (For detailed information, see “Using the Code view (or Code 
inspector)” on page 330.)

You can create new documents in Dreamweaver starting from blank HTML pages 
or from templates; alternatively, you can open and modify HTML documents 
created in other applications. (See “Creating, opening, and saving 
HTML documents” on page 150.)

When you set up a document, you can define basic page elements. For example, 
the page title identifies the document to the site visitor; it usually appears in the 
title bar of the browser window. Background images, background colors, and text 
and link colors customize the page and distinguish regular text from hypertext. 
Margin properties allow you to specify the sizes of top and left margins for your 
page. (See “Setting document properties” on page 152.)

As you add content, you can select and modify objects directly in the Document 
window. In some cases, you may need to select markers that represent page 
elements that are not visible in the Document window, such as comments and 
scripts. (See “Selecting elements in the Document window” on page 154.)

While creating your documents, you can perform the same task numerous times 
by using the History panel. (See “About automating tasks” on page 160.)
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Creating, opening, and saving 
HTML documents
Dreamweaver offers various ways to create a document. You can create new, blank 
HTML documents; you can open an existing HTML document, even if it wasn’t 
created in Dreamweaver; or you can create a new document based on a template.

You can also open non-HTML text files, such as JavaScript files, plain text e-mail 
files, or text files saved by word processors or text editors. You can’t use all of the 
Dreamweaver document-editing tools on a plain text document, but you can use 
basic text-editing features. Reasons to open text documents might include editing 
and debugging JavaScript code, looking at the contents of a Dreamweaver 
configuration file, or opening a piece of e-mail that contains a snippet of HTML, 
to copy that code and paste it into another document.

To create a blank HTML document in a new Document window, do one of 
the following:

• In Windows, choose File > New from an existing Document window, or 
choose File > New Window from the Site window.

• On the Macintosh, choose File > New.

If you open the Code view (in the Document window) or the Code inspector, you 
can see that the new document isn’t completely blank—it contains html, head, 
and body tags to get you started. As you type in the Document window’s Design 
view or insert objects such as tables and images, you can leave a code editor open 
and watch as the HTML source code is created. For more information on the 
code editors, see “Using the Code view (or Code inspector)” on page 330.

To open an existing HTML file, do one of the following:

• Choose File > Open.

• If the file was created using Microsoft Word, choose File > Import > 
Import Word HTML.

If you choose Import Word HTML, Dreamweaver opens the file and then lets 
you specify options for removing extraneous HTML code generated by Word. 
(Microsoft Word 97 and later versions provide a Save as HTML feature, which 
adds unnecessary HTML code as it converts a document to HTML.) For more 
information, see “Cleaning up Microsoft Word HTML” on page 348.

Note: You can’t directly import a Microsoft Word (.doc) file into Dreamweaver. If you 
want to import the contents of a Word file, launch Word and save the file as HTML 
before importing the resulting HTML file into Dreamweaver.
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To create a new document based on a template: 

1 Choose File > New from Template. 

A dialog box appears, listing the templates available for the current site. (You 
must create templates before you can create documents based on them; see 
“Creating templates” on page 377.)

When you create a document based on a template, some parts of the document 
are locked so that they can’t be edited. (The template file determines which 
regions are editable and which are not.) This ensures consistency when you 
use a template for multiple documents in a site.

2 Select a template and click Select. 

A new document is created based on the template. Each editable part of the 
new document is surrounded by a blue border by default. The entire document 
is surrounded by a yellow border (by default), as a reminder that it’s based on a 
template and that some parts of it are therefore locked. (To customize the 
colors of the borders, see “Setting template preferences” on page 383.) To 
modify an editable part of the template, select the placeholder content in the 
editable region and type over it. In some cases, there is no placeholder content 
in the editable region; in those cases, click inside the editable region.

To learn more about designing and working with templates, see “Reusing Content 
with Templates and Libraries” on page 375.

To save a document:

1 Choose File > Save.

2 Provide a name for the file and navigate to where you want the file to be saved.

Note: Dreamweaver automatically adds .htm (Windows) or .html (Macintosh) to the file 
name when the dialog box first appears. (You can control what file extension is added by 
using an option in General preferences.) To save a file as plain text in Windows, give it a 
.txt file name extension. To save a file as plain text on the Macintosh, simply remove the 
.html from the name of the Macintosh file. (To make Dreamweaver see the file as an 
HTML file again, save it again with the .html (or .htm) extension.) After you save a file as 
text, Dreamweaver does not interpret any HTML code in the file.

When you save your documents, avoid using spaces and special characters in 
file and folder names whenever possible. In particular, do not use special 
characters (such as é, ç, or ¥) or punctuation (such as colons, slashes, or 
periods) in the names of files you intend to put on a remote server; many 
servers change these characters during upload, which will cause any links to 
the files to break. Also, do not begin a file name with a numeral.

3 Click the Save button to save the file.
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Setting document properties
Page titles, background images and colors, text and link colors, and margins are 
basic properties of every HTML document. The page title identifies and names 
the document. A background image or color sets the overall appearance of the 
document. Text and link colors help site visitors distinguish regular text from 
hypertext and to see which links have been visited and which have not.

Changing the title of a page

The title of an HTML page helps site visitors keep track of what they’re viewing 
as they browse, and it identifies the page in the visitor’s history and bookmark 
lists. If you don’t title a page, the page will appear in the browser window, 
bookmark lists, and history lists as Untitled Document. Note that giving the 
document a file name (by saving it) is not the same as giving the page a title. To 
locate all untitled documents in your site, use the Site > Reports command; see 
“Creating reports” on page 510.

To change the title of a page:

1 Do one of the following:

• Choose Modify > Page Properties.

• Click in an empty space on your page to make sure nothing is selected. Then 
choose Page Properties from the context menu by right-clicking (Windows) or 
Control-clicking (Macintosh) in the Design view of the Document window.

• Choose View > Head Content, click the Title button when it appears, and then 
open the Property inspector.

• Choose View > Toolbar.

2 Enter the title for the page in the Title text box.

3 If you’re editing the title in the Page Properties dialog box, click OK.

The title appears in the title bar of the Document window (and in the toolbar, 
if it’s showing). The file name of the page and the folder the file is saved in 
appear in parentheses next to the title in the title bar. An asterisk indicates the 
document contains changes that have not yet been saved.
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Defining a background image or page color

To define an image or color for the page background, use the Page Properties dialog 
box. If you use both a background image and a background color, the color appears 
while the image downloads, and then the image covers up the color. If the background 
image contains any transparent pixels, the background color shows through.  

To define a background image or color:

1 Choose Modify > Page Properties, or select Page Properties from the 
context menu in the Design view of the Document window.

2 To set a background image, click the Browse button, then browse to and select 
the image. Alternatively, enter the path to the background image in the 
Background Image box. 

Dreamweaver tiles (repeats) the background image if it does not fill the 
entire window, just as browsers do. (To prevent the background image from 
tiling, use Cascading Style Sheets to disable image tiling. See “Using CSS style 
sheets” on page 248.)

3 To set a background color, click the Background color box and select a color 
from the color picker. (See “Working with colors” on page 87.)

Defining default text colors

Define default colors for regular text, links, visited links, and active links in 
the Page Properties dialog box, or choose a preset color scheme to define 
the page background and text colors. (See “Working with colors” on page 87.) 

Note: The active link color is the color that a link changes to while it’s being clicked. Some 
Web browsers may not use the color you specify.

To define default text colors, do one of the following:

• Choose Modify > Page Properties and then choose colors for the Text Color, 
Link Color, Visited Links, and Active Links options.

• Choose Commands > Set Color Scheme and then choose a background color 
and a color set for text and links.

The sample box shows how the color scheme will look in the browser.

Note: Color-blind people may find it difficult to see certain low-contrast combinations of 
text colors and background colors. It’s a good idea to show your page to a color-blind 
person to determine whether it’s readable.
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Selecting elements in the 
Document window
To select an element in the Design view of the Document window, you generally 
click the element. If an element is invisible, you must make it visible before 
you can select it.   

To select elements, use these techniques:

• To select a visible element in the Document window, click the element or drag 
across the element.

• To select an invisible element, choose View > Visual Aids > Invisible Elements 
(if that menu item isn’t already selected) and then click the element’s marker in 
the Document window.

Some objects appear on the page in a place other than where their code is 
inserted. For example, a layer can be anywhere on the page, but the code 
defining the layer is in a fixed location. When invisible elements are showing, 
Dreamweaver displays markers in the Document window to show the location 
of the code for such elements. Selecting a marker selects the entire element; for 
example, selecting the marker for a layer selects the entire layer. (See “About 
invisible elements” on page 156.)
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• To select a complete tag (including its contents, if any), click a tag in the tag 
selector at the bottom left of the Document window. (The tag selector appears 
only when the Design view is active.) The tag selector always shows the tags 
that contain the current selection or insertion point. The leftmost tag is the 
outermost tag containing the current selection or insertion point. The next tag 
is contained in that outermost tag, and so on; the rightmost tag is the 
innermost one that contains the current selection or insertion point.

For example, when you define a link for an image, the HTML code looks 
something like this:

<a href="http://www.macromedia.com"><img src="agraphic.gif"></a>

Clicking the image in the Document window changes the tag selector to show 
the tags for the selection:

<body><a><img>

Because the image is selected, the <img> tag in the tag selector appears in 
boldface. Clicking that tag in the tag selector corresponds to selecting 
<img src="agraphic.gif"> in a code editor.

To select the link (the a tag and everything inside it) instead of the image, click 
the image in the Document window and then click <a> in the tag selector.

To see the HTML code associated with the selected text or object, do one of 
the following:

• To display the Code view in the Document window, choose View > Code or 
View > Code and Design. For more information about the Code view, see  
“Using the Code view (or Code inspector)” on page 330.

• To open the Code inspector (in a separate window), choose Window > 
Code Inspector.

When you select something in either code editor (the Code view or the Code 
inspector), it’s generally also selected in the Document window. You may need to 
synchronize the two views before the selection appears; see “Using the Code view 
(or Code inspector)” on page 330.

Tag selector
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About invisible elements

Some HTML code doesn’t have a visible representation in a browser. For example, 
comment tags don’t appear in browsers. However, it can be useful while you’re 
creating a page to be able to select such invisible elements, edit them, move them, 
and delete them. Dreamweaver allows you to specify whether it shows icons marking 
the location of invisible elements in the Design view of the Document window. 

To show or hide marker icons for invisible elements, choose View > Visual Aids > 
Invisible Elements. Showing invisible elements lets you select them and change 
their properties in the Property inspector; hiding them lets you see the page closer 
to the way it will appear in a browser. Note that showing invisible elements may 
slightly change the layout of a page, moving other elements by a few pixels, so for 
precision layout, hide the invisible elements.

To indicate which element markers appear when you choose View > Visual Aids > 
Invisible Elements, you can set options in Invisible Elements preferences. For 
example, you can specify that named anchors should be visible, but not line breaks.

You can create certain invisible elements (such as comments, named anchors, and 
scripts) using the buttons in the Invisibles category of the Objects panel (see 
“Using the Objects panel” on page 80). You can then modify these elements using 
the Property inspector.

Setting Invisible Elements preferences

Use Invisible Elements preferences to specify which kinds of elements will be 
visible when you select View > Visual Aids > Invisible Elements.    

To change Invisible Elements preferences:

1 Choose Edit > Preferences, then click Invisible Elements.

2 Select which elements should be made visible. A check mark next to the name 
of the element in the dialog box means the element is visible when View > 
Visual Aids > Invisible Elements is selected.

For an explanation of each Invisible Elements preference, see Dreamweaver Help. 
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Using visual guides in the design process
Dreamweaver provides several kinds of visual guides to help you design 
documents and predict (approximately) how they will appear in browsers. You can 
do all of the following:  

• Instantly snap the Document window to a desired window size to see how the 
elements fit on the page. See “Resizing the Document window” on page 75.

• Use rulers to provide a visual cue for positioning and resizing layers or tables.

• Use a tracing image as the page background to help you duplicate a 
design created in an illustration or image-editing application such as 
Macromedia Fireworks.

• Use the grid for precise positioning and resizing of layers. Grid marks on the 
page help you align layers, and when snapping is enabled, layers automatically 
snap to the closest grid point when moved or resized. (Other objects, such as 
images and paragraphs, do not snap to the grid.) Snapping works regardless of 
whether the grid is visible. See “Snapping layers to the grid” on page 416.  

Displaying rulers

Rulers can be displayed on the left and top borders of the page, marked in pixels, 
inches, or centimeters.   

To change ruler settings, do one of the following:

• To toggle rulers on and off, choose View > Rulers > Show. 

• To change the origin, drag the ruler-origin icon anywhere on the page. (This 
icon appears at the upper left corner of the Design view of the Document 
window when rulers are showing.) To reset the origin to its default position, 
choose View > Rulers > Reset Origin.

• To change the unit of measure, choose Pixels, Inches, or Centimeters from the 
View > Rulers submenu.
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Using a tracing image

Use a tracing image as a guide to re-create a page design that was mocked up in a 
graphics application. A tracing image is a JPEG, GIF, or PNG image that is placed 
in the background of the Document window. You can hide the image, set its 
opacity, and change its position.   

The tracing image is visible only in Dreamweaver. It is never visible when you view 
the page in a browser. When the tracing image is visible, the page’s real background 
image and color are not visible in the Document window; however, the 
background image and color will be visible when the page is viewed in a browser. 

To place a tracing image in the Document window:

1 Do one of the following:

• Choose View > Tracing Image > Load.

• Choose Modify > Page Properties and then click the Browse button next to the 
Tracing Image text box.

2 In the dialog box that appears, select an image file and click Select (Windows) 
or Choose (Macintosh). 

3 The Page Properties dialog box appears. Specify the transparency for the image 
by dragging the Image Transparency slider; then click OK.

To switch to another tracing image or change the transparency of the current 
tracing image at any time, choose Modify > Page Properties.

To show or hide the tracing image:  

Choose View > Tracing Image > Show. 

To change the position of a tracing image:  

Choose View > Tracing Image > Adjust Position. Then do one of the following:

• To precisely specify the position of the tracing image, enter coordinate values in 
the X and Y text boxes.

• To move the image one pixel at a time, use the arrow keys.

• To move the image five pixels at a time, press Shift and an arrow key.

To reset the position of the tracing image:

Choose View > Tracing Image > Reset Position. The tracing image returns to the 
upper left corner of the document window (0,0).
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To align the tracing image to a selected element:  

1 Select an element in the Document window. 

2 Choose View > Tracing Image > Align with Selection. 

The upper left corner of the tracing image is aligned with the upper left corner 
of the selected element. 

Viewing and editing head content
HTML files are made up of two main sections: the head section and the body 
section. The body section is the main part of the document, the visible part 
containing text and images and so on. The head section is invisible, except for the 
document title, which appears in window title bars in browsers and in 
Dreamweaver. Give a title to every page you create.   

The head section also contains other important information, including the 
document type, the language encoding, JavaScript and VBScript functions and 
variables, keywords and content indicators for search engines, and style 
definitions. You don’t need to provide all of these elements for every page; you 
might, for example, provide keywords and content indicators for your home page 
only. You can view the elements in the head section using the View menu, the 
Document window’s Code view, or the Code inspector.

To view elements in the head section of a document:

Choose View > Head Content. For each element of the head content, an icon 
appears at the top of the Document window’s Design view.

Note: If your Document window is set to show only Code view, View > Head Content 
is dimmed.

To insert an element into the head section of a document:

1 Do one of the following:

• Choose Head from the pop-up menu at the top of the Objects panel and click 
one of the object buttons.

• Choose an item from the Insert > Head submenu.

2 Enter options for the element in the dialog box that appears, or in the 
Property inspector.
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To edit an element in the head section of a document:

1 Choose View > Head Content.

2 Click one of the icons in the head section to select it.

3 Set or modify the properties of the element in the Property inspector.

For information about the properties of specific head elements, see the following 
topics in Dreamweaver Help:

• Meta properties

• Title properties

• Keywords properties

• Description properties

• Refresh properties

• Editing a script

• Base properties

• Link properties

About automating tasks
While creating your documents, you may want to perform the same task 
numerous times. This section explains how to use the History panel to automate 
repetitive tasks.

To repeat a series of steps once or twice, replay them directly from the History 
panel, which records your steps as you work on a document. (For basic 
information about the History panel, see “About the History panel” on page 84.) 
To automate a task that you perform often, you can create a new command that 
performs that task automatically.

Some mouse movements, such as selecting something in the Document window 
by clicking or dragging, can’t be played back or saved as part of saved commands. 
When you make such a movement, a black line appears in the History panel 
(although the line does not become obvious until you perform another action). To 
avoid movements that can’t be played back, use the arrow keys instead of the 
mouse to move the insertion point within the Document window. To make or 
extend a selection, hold down the Shift key while pressing an arrow key.

Note: If a black mouse-movement indicator line appears while you’re performing a task you 
want to repeat later, you can undo back past that step and try another approach, perhaps 
using the arrow keys. 
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Certain other steps also aren’t repeatable, such as dragging a page element to 
somewhere else on the page. When you perform such a step, a menu-command 
icon with a small red X appears in the History panel.

Steps are replayed exactly as they were originally performed; you can’t modify 
the steps as you replay them. For example, if you previously changed the color 
of a table cell to red, applying that step to another table cell changes that cell’s 
color to red as well; you can’t specify a different color when you apply the step 
to a new cell.

Repeating steps

To repeat the last step you performed, use the Edit > Repeat command, or use the 
keyboard shortcut Control+Y (Windows) or Command+Y (Macintosh). The 
name of this command changes in the Edit menu to reflect the last step you 
performed; for example, if you’ve just typed some text, the command name is 
Repeat Typing. (You can’t use the Repeat command immediately after an Undo 
or Redo operation.)

To repeat steps other than the most recent one, or to repeat multiple steps at once, 
use the History panel.

Note that when you replay steps, the steps that are played are the steps that are 
selected (highlighted), not necessarily the step currently pointed to by the slider.

To repeat one step:

In the History panel, select a step and click the Replay button. The step is 
replayed, and a copy of it appears in the History panel.  

To repeat a series of adjacent steps:

1 Select steps in the History panel by doing one of the following:

• Drag from one step to another. (Don’t drag the slider; just drag from the text 
label of one step to the text label of another step.)

• Select the first step, then Shift-click the last step; or select the last step and then 
Shift-click the first step.

Note: Although you can select a series of steps that includes a black mouse-movement 
indicator line, that mouse movement is skipped when you replay the steps.

2 Click Replay.

The steps are replayed in order, and a new step, labeled Replay Steps, appears in 
the History panel.
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To repeat nonadjacent steps:

1 Select a step, then Control-click (Windows) or Command-click (Macintosh) 
other steps.

You can also Control-click or Command-click to deselect a selected step.

2 Click Replay.

The selected steps are replayed in order, and a new step, labeled Replay Steps, 
appears in the History panel.

Applying steps to another object

You can apply a set of steps from the History panel to any object in the 
Document window.

To apply History panel steps to a new object:

1 Select the object.

2 Select the relevant steps in the History panel, then click Replay.

Applying steps to multiple objects

If you select multiple objects in a document and then apply steps to them from 
the History panel, the objects are treated as a single selection, and Dreamweaver 
attempts to apply the steps to that combined selection. For example, you can’t 
select five images and apply the same size change to each of them all at once; a size 
change is an operation that must be applied to each individual image, not to a 
collective combination of images.

To apply a series of steps to each object in a set of objects, you must make the last 
step in the series select the next object in the set. The following procedure 
demonstrates this principle in a particular scenario: setting the vertical and 
horizontal spacing of a series of images.
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To set the vertical and horizontal spacing of a series of images:

1 Start with a document in which each line consists of a small image (such as a 
graphical bullet or an icon) followed by text. The goal is to set the images off 
from the text and from the other images above and below them. 

2 Select the first image.

3 In the Property inspector, click the Expand button (the arrow in the lower right 
corner) if necessary to see all of the image properties.

4 Enter numbers in the V Space and H Space text boxes to set the image’s spacing.

5 Click the Document window’s title bar (rather than clicking inside the 
document window) to make the Document window active without moving the 
insertion point.

6 Press the Left Arrow key to move the insertion point to the left of the image. 
Then press the Down Arrow key to move the insertion point down one line, 
leaving it just to the left of the second image in the series. Then press 
Shift+Right Arrow to select that second image.

Note: Do not select the image by clicking it, or you won’t be able to replay all the steps.

7 In the History panel, select the steps that correspond to changing the image’s 
spacing and selecting the next image. Click the Replay button to replay 
those steps.

The current image’s spacing changes, and the next image is selected.

8 Continue to click Replay until all the images are spaced correctly.

To apply steps to an object in another document, use the Copy Steps button.
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Copying and pasting steps between documents

Each open document has its own history of steps. You can copy steps from one 
document and paste them into another.

Note: Copy Steps (a button in the History panel) is different from Copy (in the Edit menu). 
You can’t use Edit > Copy to copy steps, though you do use Edit > Paste to paste them.

Closing a document clears its history. If you know you will want to use steps from 
a document after that document is closed, copy the steps with Copy Steps (or save 
them as a command; see “Creating new commands from history steps” on page 
165) before you close the document.

Be careful when copying steps that include a Copy or a Paste command:

• Don’t use Copy Steps if one of the steps is a Copy command; you may not be 
able to paste such steps the way you want.

• If your steps include a Paste command, you can’t paste those steps, unless the 
steps also include a Copy command before the Paste command.

If you paste steps into a text editor or into the Code view or the Code inspector, 
they appear as JavaScript code. This can be useful for learning to write your own 
scripts. For more information on using JavaScript in Dreamweaver, see 
“Extending Dreamweaver: Basics” on page 536.

To reuse steps from one document in another document:

1 Start from the document containing the steps you want to reuse.

2 Select the steps in the History panel.

3 Click the History panel’s Copy Steps button to copy those steps.

4 Open the other document.

5 Place the insertion point where you want it, or select an object to apply 
the steps to.

6 Choose Edit > Paste to paste the steps.

The steps are played back as they’re pasted into the document’s History panel. 
The History panel shows them as only one step, called Paste Steps.
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Creating new commands from history steps

You can save a set of history steps as a named command, which then becomes 
available in the Commands menu.

Create and save a new command if there’s any chance you’ll want to use a given 
set of steps again in the future, especially if you want to use those steps again the 
next time you start Dreamweaver; saved commands are retained permanently 
(unless you delete them), while recorded commands are discarded when you exit 
from Dreamweaver, and copied sequences of steps are discarded when you copy 
something else.

You can edit the names of commands that you’ve placed in the Commands menu, 
and you can delete them from the Commands menu, using Commands > Edit 
Command List. It’s more complicated to edit and delete commands that are built 
into the Commands menu (that is, commands that you didn’t explicitly add); see 
“About customizing Dreamweaver menus” on page 517.

To create a command:

1 Select a step or set of steps in the History panel.

2 Click the Save As Command button, or choose Save As Command from the 
History panel’s context menu.

3 Enter a name for the command and click OK.

The command appears in the Commands menu.

Note: The command is saved as a JavaScript file (or sometimes an HTML file) in your 
Dreamweaver/Configuration/Commands folder.

To use a saved command:

1 Select an object to apply the command to, or place the insertion point where 
you want it.

2 Choose the command from the Commands menu.

To edit the names of commands in the Commands menu:

1 Choose Commands > Edit Command List.

2 Select a command to rename and enter a new name for it.

3 Click Close.

To delete a name from the Commands menu:

1 Choose Commands > Edit Command List.

2 Select a command.

3 Click Delete, then click Close.
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Recording commands

Dreamweaver allows you to record a temporary command for short-term use. The 
main differences between this approach and playing back steps from the History 
panel (see “Repeating steps” on page 161) are as follows:

• The steps are recorded as you perform them, so you don’t have to select them in 
the History panel before playing them back.

• During recording, Dreamweaver prevents you from performing nonrecordable 
mouse movements (such as clicking to select something in a window, or 
dragging a page element to a new location).

• If you switch to another document while recording, Dreamweaver doesn’t 
record the changes you make in the other document. To determine whether 
you’re recording or not at any given moment, look at the mouse pointer.

Dreamweaver retains only one recorded command at a time; as soon as you start 
recording a new command, the old one is lost. To save a new command without 
losing a recorded one, save the command from the History panel.

Once you’ve recorded a command, you can save it using the History panel.

To temporarily record a series of frequently used steps:

1 Choose Commands > Start Recording, or press Control+Shift+X (Windows) 
or Command+Shift+X (Macintosh).

The pointer changes to indicate that you’re recording a command.

2 When you finish recording, choose Commands > Stop Recording, or press 
Control+Shift+X (Windows) or Command+Shift+X (Macintosh).

To play back a recorded command:

Choose Commands > Play Recorded Command, or press Control+P (Windows) 
or Command+P (Macintosh).

To save a recorded command:

1 Choose Commands > Play Recorded Command to play the command back.

A step named Run Command appears in the History panel’s step list.

2 Select the Run Command step and click the Save As Command button.

3 Enter a name for the command and click OK.

The command appears in the Commands menu.
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Designing Page Layout

Page layout is an important part of Web design. The term page layout refers to the 
way your page will look in the browser, such as where a menu or images will go. 
Macromedia Dreamweaver gives you several different ways to create and control 
your Web page layout.   

One common method for creating a page layout is with HTML tables. Tables can 
be difficult to use, however, since they weren’t originally created for Web page 
layout, but for displaying tabular data. 

To simplify the process of using tables for page layout, Dreamweaver provides 
Layout view. In Layout view, you can design your page using tables as the 
underlying structure, but avoid the traditional pitfalls of using tables. For 
example, you can easily draw cells (table cells) onto your page, then customize and 
move the cells where you want them. Your layout can have a fixed width, or it can 
grow to fill the browser window (see “Setting layout width” on page 179).

You can still lay out your pages using tables in the traditional way (see “Using 
Tables to Present Content” on page 183), or lay out pages using layers and 
then convert them to tables (see “Using tables and layers for layout” on page 421). 
However, the Dreamweaver Layout view is the easiest way to set up your 
page layout.

To use Layout view, you must switch out of Dreamweaver Standard view.
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To switch into Layout view:

Choose View > Table View> Layout View or click the Layout View button in 
the Objects panel. 

Show Layout Table Tabs is automatically enabled in Layout View. To turn off the table 
tabs when in Layout View, choose View > Table View > Show Layout Table Tabs.

Note: If you create a table in Dreamweaver Standard view, then switch into Layout 
view, your table will have empty layout cells that you may need to delete before you can 
create new cells.

Layout View icon

Draw Layout Cell icon

Draw Layout Table icon
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About layout cells and tables
When you switch into Layout view, you can add layout cells to your page. These 
cells will help you block out your page layout. For example, you could draw a cell 
along the top of your page to hold a menu, a cell on the right side of the page for 
submenus, and a cell next to it to hold content. It can be useful to think of the 
layout in terms of a grid of rows and columns.

When you create a layout cell on your page, Dreamweaver automatically creates a 
layout table as a container for the cell. A layout cell cannot exist outside of a layout 
table. You can create your page layout using several layout cells within one layout 
table or you can use multiple layout tables for a more advanced layout.

Using multiple layout tables isolates sections of your layout, so that they 
aren’t affected by another section. This is especially useful when the content in 
a layout cell may change and cause the cell to grow. As the cell grows, it affects 
the other cells near it because cells cannot overlap. If you have created your 
layout with multiple layout tables, the rows and columns of one table will not 
affect another table.

You can also nest layout tables (inserting a layout table into an already existing 
layout table). The cells inside a nested table are not constrained by the rows and 
columns of the outer table. See “Drawing a nested layout table” on page 173.
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Drawing layout cells and tables
You can draw layout cells and tables on your page when in Layout view. If you 
create a layout cell first, a layout table will also automatically be inserted to act as a 
container for the layout cell. A layout cell will always be in a layout table. 

Note: The Layout table that is automatically created by Dreamweaver is the width of your 
Document window. You can resize it or make it autostretch as necessary.

To draw a layout cell:

1 Make sure you are in Layout view, then click the Draw Layout Cell button 
in the Layout category of the Objects panel. The mouse pointer will change 
to a plus sign (+).

2 Position the mouse pointer where you want to start the cell on the page, 
then drag to create the layout cell. To create a number of cells without 
clicking the layout cell button each time, hold down Control (Windows) or 
Command (Macintosh).

The cell will appear outlined in blue on your page. Blue is the default outline color 
for layout cells, see “Setting Layout View preferences” on page 182 to change it. 
The size of each cell is displayed in the column header area along the top of the cell. 
For more information about width, see “Setting layout width” on page 179.
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 Your page layout follows a grid with columns and rows, so cells can span several 
rows or several columns, but they can never overlap each other on the page. 
Dreamweaver helps you maintain this structure by automatically snapping new 
cells that you create to existing cells if you draw them near each other (within 8 
pixels). The cells will also automatically snap to the side of the page if you draw 
them close to the edge (within 8 pixels). To temporarily disable snapping, hold 
down Alt (Windows) or Option (Macintosh) while drawing the cell on the page.

This does not mean that all of your cells must be the same size or width. You can 
have cells in the same column that are different widths, or cells in rows that have 
different heights.
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To draw a layout table:

1 Make sure you are in Layout view, then click the Draw Layout Table button 
in the Layout category of the Objects panel. The mouse pointer will change 
to a plus sign (+).

2 Position the mouse pointer on the page, then click and drag your mouse to 
create the layout table. If it is the first table you have drawn on the page, it will 
automatically be positioned at the top left corner of your page. 

To create a number of tables without clicking the layout table button each 
time, hold down Control (Windows) or Command (Macintosh).

The table will appear outlined in green on your page. Green is the default outline 
color for layout tables, see “Setting Layout View preferences” on page 182 to 
change it. A Layout Table tab also appears at the top of each table you draw and 
helps you distinguish and select the table. The size of each table is displayed in the 
Column Header area along the top of the table. 

For more information about width, see “Setting layout width” on page 179.

Tables cannot overlap each other. Your page layout follows a grid with columns 
and rows, so tables can span several rows or several columns, but they can never 
actually overlap on the page. Dreamweaver helps you maintain this structure by 
automatically snapping new tables that you create to existing tables or cells if you 
draw them near each other (within 8 pixels). The tables will also automatically 
snap to the side of the page if you draw them close to the edge (within 8 pixels). 
To turn off snapping, hold down Alt (Windows) or Option (Mac) while drawing 
the table on the page.

You can create layout tables into empty areas of your page layout, into an existing 
layout table (nesting), or around existing layout cells and tables. When you create 
a Layout table in a blank document, it will automatically snap to the upper left 
corner of your Document window. 

Note: If your page already contains content, a layout table can only be drawn below the 
bottom of the content.

To draw a layout table around existing tables or cells:

1 Make sure you are in Layout view, then click the Draw Layout Table button 
in the Layout category of the Objects panel. The mouse pointer will change 
to a plus sign (+).

2 Click and drag your mouse around existing layout cells or tables. The layout 
table will enclose the existing cells or tables.
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Drawing a nested layout table

You can draw a layout table in an already existing layout table (this creates a nested 
table). The cells inside a nested table are not constrained by the rows and columns 
of the outer table. You can insert multiple nested tables.

To draw a nested table:

1 Click the Draw Layout Table button in the Layout category of the Objects 
panel. The mouse pointer will turn into a plus sign (+).

2 Position the mouse pointer inside the gray space of an existing layout table, 
then click and drag your mouse to create the nested layout table.

A nested layout table cannot be larger than the table that contains it.
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Using the Dreamweaver grid

You can turn on the Dreamweaver grid to use as a guide when you draw your 
layout. You can also have your layout automatically snap to the grid, and change 
the grid or control the snapping behavior by specifying grid settings.

To show or hide the grid in the Document window:

Choose View > Grid > Show Grid or select Grid from the Options drop-down 
menu on the toolbar. 

To change grid settings:

1 Click View > Grid > Edit Grid to open the Grid Settings dialog cell.

2 Do any of the following:

• Click the arrow next to the color swatch and select a color from the palette or 
type the hexadecimal number in the cell. This controls the color of the grid lines.

• Select Show Grid to show the grid in the Document window.

• Select Snap to Grid to enable snapping.

• Type the amount of spacing you want and select Pixels, Inches, or Centimeters 
from the pop-up menu. This controls how far apart the grid lines will appear.

• Choose lines or dots for the grid lines.

3 Click Apply to view the changes, then OK to close the dialog box.

Adding content to a cell

You can add text, images, and other media to layout cells in Layout view just as 
you would in Dreamweaver normal display (Standard view). Click in the cell 
where you want to insert content, then type text or insert other files.

Content can only be inserted into a layout cell, so you must create the layout cells 
first (see “Drawing layout cells and tables” on page 170). The gray spaces in your 
page indicate areas that are not available for adding content, unless you insert a 
layout cell there.

A layout cell expands automatically as you add material that is larger than the cell. 
As the cell expands, surrounding cells may also be affected, and the column that 
the cell is in will also expand.
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To add text to a cell:

Click in the layout cell where you want to add text and do one of the following:

• Type text into the cell. The cell will automatically expand as you type.

• Paste text copied from another document. Use the Paste command. For more 
information, see “Inserting text and objects” on page 234.

To add an image to a cell:

1 Click in the layout cell where you want to add the image.

2 Click the Insert Image button in the Objects panel, choose Insert > Image, or 
drag the Insert Image button from the Objects panel to the page.

3 In the Select Image dialog box, select an image file.

For more information, see “Setting image properties” on page 269.

Clearing automatic cell heights

After you insert content into your cells, you can clear the cell heights to remove 
the setting. Dreamweaver automatically creates the cells with a specified height, 
but once you add content to the cell, you no longer need the specified height.

To clear heights, do one of the following:

• Select Clear Cell Heights from the Column Header menu. The heights are 
cleared and some rows may shrink.

• Select a layout table (click the table tab or edge), then click the Clear Row 
Heights button in the Property inspector. 
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Moving and resizing layout cells and tables
Every cell and table in your layout can be moved or resized, which makes it easy to 
adjust your page layout. To use the Dreamweaver grid as a guide while you move 
or resize your cells and tables, see “Using the Dreamweaver grid” on page 174.

To resize a cell:

1 Click the cell edge or hold down Control (Windows) or Command (Mac) and 
click anywhere in the cell.

Selection handles will appear around the cell.

2 Use the selection handles to drag the cell to your chosen size.

The cell will automatically snap to existing cells (when within 8 pixels of their 
borders). A layout cell cannot overlap other cells and you cannot resize it outside 
the boundaries of its layout table. A layout cell is always at least as large as the 
content it contains.

To move a cell:

1 Click the cell edge.

2 Drag the cell where you want it on the page or use the arrow keys. The arrow key 
moves it 1 pixel at a time, holding down Shift will move it 10 pixels at a time.

To resize a table:

1 Click the table tab. 

Selection handles will appear around the layout table.

2 Use the selection handles to drag the table to your chosen size.

The table will automatically snap to existing cells and tables (when within 8 pixels 
of the existing cell). The layout table cannot be resized so that it will be smaller 
than the boundary of the cells it contains. It also cannot be resized so that it will 
overlap surrounding tables or cells. 

To move a table:

1 Click the table tab.

2 Drag the table where you want it on the page or use the arrow keys. The arrow 
key moves it 1 pixel at a time, holding down Shift will move it 10 pixels at a time.
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Formatting layout cells and tables
You can change the appearance of any layout cell or table in the Property Inspector. 

Formatting a layout cell

You can set content alignment, width and height, and background colors in the 
Property inspector. 

To format a layout cell in the Property inspector:

1 Click the cell edge or hold down Control (Windows) or Command (Mac) and 
click anywhere in the cell.

2 Choose Window > Properties to open the Property inspector.

3 Choose from the following appearance options:

• To change the width, choose Fixed and type a width in pixels in the box, or 
choose Autostretch (see “Setting layout width” on page 179).

• To change the height, specify the height in pixels in the text box.

• To set a background color for the layout cell, choose a color from the 
Bg drop-down color picker or type the hexadecimal code for the color 
you want in the text box.

• To set the horizontal alignment, select from the Horz pop-up menu. You 
can set the alignment of the layout cell’s contents to either Left, Center, 
Right, or Default. 

• To set the vertical alignment, select from the Vert pop-up menu. You can set 
the alignment of the layout cell’s contents to either Top, Middle, Bottom, 
Baseline, or Default. 

• Select No Wrap to prevent word wrapping. If selected, the layout cell widens 
to accommodate all the content, without breaking to a new line.
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Formatting layout tables

You can set width and height, padding and spacing, and more in the 
Property inspector.

To format a layout table:

1 Click the table tab or edge.

2 Choose Window > Properties to open the Property inspector.

3 Choose from the following appearance options:

• To change the width, choose Fixed and type a width in pixels in the box, or 
choose Autostretch (see “Setting layout width” on page 179).

• To change the height, specify the height in pixels in the text field.

• To set cell padding, specify the number of pixels in the CellPad field. Cell 
padding is the amount of space between the content of a layout cell and the cell 
boundary (or wall). When you set this above 0, all the layout cells in the layout 
table you have selected will have this spacing. If you see two numbers appear in 
the column header area, use the Make Widths Consistant option below.

• To set cell spacing, specify the number of pixels in the CellSpace text field. Cell 
spacing is the amount of space between each layout cell. When you set this 
above 0, all the layout cells in the layout table you have selected will have this 
spacing.  If you see two numbers appear in the column header area, use the 
Make Widths Consistant option below.

• To clear the height settings for all the cells in the layout table you selected, click 
the Clear Height Attributes button. If there are no elements in the table, the 
table will collapse completely.

• If you have fixed-width cells in your layout, click the Make Widths Consistent 
button. This automatically resets the HTML widths of each cell to match the 
content within that cell. For example, if you set the width to 200 pixels, then 
added content that stretches the width to 250, you will see these two numbers 
displayed in the top bar of the table: 250 in quotes and 200 in parentheses. 
Clicking Make Widths Consistent removes the 200-pixel setting and keeps 250. 

• To remove spacer images (transparent images that are used to control the 
spacing in your layout) from your layout table, click the Remove All Spacers 
button. (For more information, see “Using spacer images” on page 181).

• If the layout table you selected is nested within another layout table, click 
Remove Nesting to remove the nested layout table without losing any of its 
contents. The layout table will disappear and the layout cells and their contents 
will become part of the parent table.
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Setting layout width
There are two types of widths you can use in Layout view: Fixed width and 
Autostretch. The width appears in the column header area at the top of each 
column. Fixed width is a specific numeric width, such as 300 pixels, and is 
displayed as a number. Autostretch sets the width to resize automatically 
depending on the window size and is displayed as a wavy line. With autostretch, 
your layout always fills the browser window, no matter what size window the 
viewer has set. Although fixed width is the default setting, you’ll typically set some 
of your layout cells or tables to be fixed width and one to be autostretch. The 
settings you specify affects all the cells or tables in that column. Only one column 
in a layout can be autostretch.

For example, suppose your layout has a menu bar on the left side of the page, the 
title at the top, and the main content area on the right. You might set the left 
column to a fixed width and the main content area to autostretch.
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To set autostretch width, do one of the following:

• Go to the top of the column that you want to set to autostretch and select 
Make Column Autostretch from the Column Header menu. Only one column 
can be autostretch.

• Select the column, then click Autostretch in the Property inspector.

When you set a column to autostretch, Dreamweaver will insert spacer images in 
the fixed width columns to control the layout. A spacer image is a transparent 
image that is not visible in the browser window, but is used to control spacing. See 
“Using spacer images” on page 181 for more information.

To set fixed width, do one of the following:

• Go to the top of the column that you want to make a fixed width and select 
Make Column Fixed Width from the column header menu. 

Make Column Fixed Width automatically sets the width of the column to 
match the width of the content in that column.

• In the Property inspector, click Fixed and type a numeric value.

If you enter a numeric value that is less than the width of your content, 
Dreamweaver will automatically set the width to the correct pixel size.

Sometimes two numbers will appear in the Column Header menu: the actual 
width of the column and the width that appears in the HTML code. This can 
happen for a variety of reasons, such as inserting content that is wider than the 
width you drew or specified. It is good practice to make the widths consistent, so 
that only one number appears.

To make the width consistent (so only the actual width is specified):

Select Make Cell Widths Consistent from the column header menu.
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Using spacer images

A spacer image is a transparent image that does not show in the browser window, 
but is used to control spacing in autostretch tables. The spacer image maintains 
the width you set for each table and cell on the page. If you choose not to use 
spacer images in autostretch tables, columns will change size or even visually 
disappear completely if they do not contain content. 

You can insert and remove spacer images in each column or let Dreamweaver add 
them automatically when creating an autostretch column. Columns that contain 
spacer images have a double bar along the top.

When you insert a spacer image in a column or set a column to autostretch, a 
dialog box appears that asks how you want to set up your spacer image file. If you 
have already set a spacer image for the site in the Dreamweaver preferences, the 
dialog box does not appear. See “Setting Layout View preferences” on page 182.

To set up your spacer image:

1 Set a column to autostretch or choose Add Spacer Image from the 
Column Header menu. 

2 In the dialog box that appears, choose from the following options:

• Tell Dreamweaver where to create the spacer image file: If you select this option 
and click OK, another dialog box appears to let you navigate to the directory in 
your site where you would like to store the spacer image file, such as an images 
folder. This is the recommended choice.

• Browse to an existing spacer image file: If you have already created a spacer 
image file for your site, choose this option and then navigate to your spacer 
image in the next dialog box that appears. The spacer image should be a 1 pixel 
by 1 pixel transparent GIF.

• Turn off spacer images for autostretch columns: If you select this option, a 
dialog box appears that warns you that the other columns in your layout may 
collapse to a small width. When you choose not to use spacer images, the 
widths of your columns will be as small as the content in them. Columns 
without content will collapse to nothing. The spacer images help maintain the 
structure of your layout as you originally drew it.

You can insert and remove spacer images in specific columns or remove all spacer 
images in the page.
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To insert a spacer image into a column:

Select Add Spacer Image from the column header menu. The spacer image will be 
inserted into the column. You will not see the image, but the column may shift 
slightly and a double bar will appear at the top.

To remove a spacer image from a column:

Select Remove Spacer Image from the column header menu. The spacer image 
will be removed and the column may shift. 

To remove all spacer images from your page:

Select Remove all Spacer Images from the column header menu or click the 
Remove all Spacers button in the layout table Property inspector. Your whole 
layout may shift slightly or dramatically depending on your content. If there is no 
content in some columns, the columns may disappear completely.

Setting Layout View preferences
Use the Layout View category in the Preferences to set or change spacer image files 
and locations, as well as the colors that Layout view uses to draw the tables and 
cells, and so on.

To open Layout view preferences:

Choose Edit > Preferences, then select Layout View from the Category list.

Autoinsert Spacers specifies whether or not Dreamweaver should automatically 
insert spacer images when you make a column autostretch.

Spacer Image sets the spacer image file for your sites. Choose a site from the drop-
down menu and then create a new image spacer or browse to an existing image 
spacer in that site.

Cell Outline sets the color used to draw the cell outline.

Cell Highlight sets the color that highlights the cell when you move the mouse over 
or choose a cell.

Table Outline sets the color used to draw the table outline.

Table Background sets the background color of the Document window.
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Using Tables to Present Content

Tables are an extremely powerful tool for laying out data and images on an 
HTML page. Tables provide Web designers ways to add vertical and horizontal 
structure to a page. 

Tables consist of three basic components:

• Rows (horizontal spacing)

• Columns (vertical spacing)

• Cells (the container created when a row and column intersect)
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Use tables to lay out tabular data, to design columns on a page, or to lay out text 
and graphics on a Web page. Once you create a table you can easily modify both 
the appearance and the structure of the table. You can add content; add, delete, 
split, and merge rows and columns; modify table, row, or cell properties to add 
color and alignment; and copy and paste cells.

Note: It is recommended that you use Layout view for page layout (See “Designing Page 
Layout” on page 167). Layout view is an easy way to implement your page layout with tables 
as the underlying structure. Use tables in Dreamweaver to add tabular data to your page.

Inserting a table
Use the Objects panel or the Insert menu to create a new table.

To insert a table:

1 Do one of the following:

• In the Document window, place the insertion point where you want the table 
to appear, then click the Table button on the Common category of the Objects 
panel, or choose Insert > Table.

• Drag the Table button from the Objects panel to the desired insertion point 
on the page.

The Insert Table dialog box appears. 

2 In the dialog box, accept the current values or type new values.

Note: The Insert Table dialog box retains the values of the most recent settings you 
entered for a table.
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• In the Rows field, specify the number of table rows. 

• In the Columns field, specify the number of table columns.

• In the Cell Padding field, specify the number of pixels between the cell content and 
the cell boundary (or wall). The default padding is 1 pixel. Enter 0 for no padding.

• In the Cell Spacing field, specify the number of pixels between each table cell. 
The default spacing is 2 pixels. Enter 0 for no spacing.

• In the Width field, specify the width of the table as a number of pixels or as a 
percentage of the browser window. 

• In the Border field, specify the pixel width of the table border. Enter 0 if you 
don’t want a border. 

3 Click OK to create the table.

If you want to insert a table without having to first specify these options, turn off 
the Show Dialog When Inserting Objects option in the General preferences. See 
“Setting preferences” on page 88. 

Adding content to a table cell

You can add text and images to table cells. 

To add text to a table:

1 Click in a cell in which you want to add text, and do one of the following:

• Type text into the table. Table cells automatically expand as you type. 

• Paste text copied from another document. See “Inserting text and objects” 
on page 234. 

2 Press Tab to move to the next cell or press Shift+Tab to move to the 
previous cell. Pressing Tab in the last cell of a table automatically adds 
another row to the table.

You can also use the arrow keys to move between cells. 
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To add an image to a table:

1 Click in the cell in which you want to add an image.

2 Click the Insert Image button in the Common category of the Objects panel, 
or choose Insert > Image.

3 In the Select Image Source dialog box, select an image file. 

For information on setting image properties, see “Setting image properties” on 
page 269.

Importing table data

Data that has been created in another application (such as Microsoft Excel) and 
saved in a delimited format (separated by tabs, commas, colons, semicolons, or 
other delimiters) can be imported into Macromedia Dreamweaver and 
reformatted as a table. 

To import table data:

1 Do one of the following:

• Choose File > Import > Import Tabular Data.

• Choose Insert > Tabular Data.

The Import Table Data or Insert Tabular Data dialog box appears, depending 
on your selection. Aside from their titles, these dialog boxes are identical.

2 In the Data File field, enter the name of the file to import.
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3 From the Delimiter pop-up menu, select the delimiter format that matches the 
format of the document you’re importing.

If you select Other, a field appears to the right of the pop-up menu. Enter the 
delimiter that was used to separate the table data. 

Note: If you do not select (or specify) the delimiter used when the file was saved, the file 
will not import properly, and your data will not be correctly formatted in a table. No error 
or warning message displays to alert that there is a problem.

4 For Table Width, select one of the following options:

• Select Fit to Data to create a table that adjusts to the longest text string in each 
table column.

• Select Set to specify a table width as a percentage of the browser window or as a 
number of pixels.

5 Select table formatting options:

• In the Cell Padding field, specify the number of pixels between the cell content 
and the cell boundary (or wall).

• In the Cell Spacing field, specify the number of pixels between each table cell.

• In the Format Top Row field, select from four formatting options: no 
formatting, bold, italic, or bold italic.

• In the Border field, specify the pixel width of the table border. Enter 0 if you 
don’t want a border.

6 Click OK.

Selecting table elements 
With a single gesture you can select an entire table, row, or column, or a 
contiguous range of cells within the table. Once the table or individual cells are 
selected, you can do the following:

• Modify the appearance of selected cells or the text contained in them. See 
“Formatting tables and cells” on page 189.

• Copy and paste adjacent cells. See “Copying and pasting cells” on page 199.

You can also select multiple nonadjacent cells in a table and modify the properties 
of those cells. You cannot copy or paste nonadjacent cell selections. 
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To select the entire table, do one of the following:

• Click the top left corner of the table, or click anywhere on the right or 
bottom edge.

• Click once in the table and choose Modify > Table > Select Table. 

• Click once in the table and choose Edit > Select All.

• Position the insertion point anywhere inside the table, and select the <table> 
tag in the tag selector at the bottom left corner of the Document window.

Selection handles appear around the table when it is selected. 

To select rows or columns, do one of the following:

• Position the insertion point at the left margin of a row or at the top of a 
column. Click when the selection arrow appears.

• Click in a cell, and drag across or down to select multiple rows or columns.

To select one or more cells, do one of the following:

• Click in a cell, and drag down or across to another cell. 

• Click in one cell and then Shift-click another cell. All of the cells within the 
rectangular region are selected. 
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To select nonadjacent cells, do one of the following:

• Press Control (Windows) or Command (Macintosh) and click in the table to 
add cells, rows, or columns to the selection. 

• Select multiple cells in the table, and then press Control (Windows) or 
Command (Macintosh) and click cells, rows, or columns to deselect 
individual cells. 

Formatting tables and cells
You can change the appearance of tables by setting properties for the table and 
table cells or by applying a preset design to the table. See “Setting table properties” 
on page 190, “Setting column, row, and cell properties” on page 191, and “Using 
a design scheme to format a table” on page 193.

To format text in tables, you can apply formatting to selected text or use styles. See 
“Inserting and Formatting Text” on page 233.

About table tags

When formatting tables in the Document window, you can define properties that 
apply to the entire table or to selected rows, columns, or cells in the table. When a 
property such as background color or alignment is set one way for the whole table 
and another way for individual table cells, it is useful to understand how 
Dreamweaver interprets the HTML source code. 

When the same property is set more than once in a table, it is interpreted in this 
way: cell formatting, which is part of the td tag, takes precedence over table row 
formatting (the tr tag), which in turn takes precedence over table formatting (the 
table tag). Therefore, if you specify a background color of blue for a single cell 
and then set the background color of the entire table to yellow, the blue cell will 
not change to yellow, since the td tag takes precedence over the table tag. 

In the following example, the table tag sets a background color of yellow 
(#FFFF99) for the entire table. The first tr tag changes those cells to green 
(#33FF66), and the second td tag changes the top center cell to blue (#333399). 
The tr and td tags in the bottom row have not been altered, so those cells take on 
the table color, which is yellow.

<table border="1" width="75%" bgcolor="#FFFF99">
<tr bgcolor="#33FF66"> 
    <td>&nbsp;</td>
    <td bgcolor="#333399">&nbsp;</td>
    <td>&nbsp;</td>
  <tr>
  <tr>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
  </tr>
</table>
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Setting table properties

The Property inspector displays table properties when a table is selected.

You can also use the Format Table command to quickly apply a preset design to a 
selected table. See “Using a design scheme to format a table” on page 193.

To specify table properties:

1 Select the table.

2 Choose Window > Properties to open the Property inspector. Click the 
expander arrow in the lower right corner to see all properties.

To name the table:

• In the Table Name field, type a name for the table. 

To select table layout options:

• In the Rows and Cols fields, specify the number of rows and columns 
in the table. 

• In the W and H fields, specify the width and height of the table as a number of 
pixels or as a percentage of the browser window. You usually don’t need to set 
the height of a table. 

• Use the Align field to specify how a table aligns with other elements in the same 
paragraph, such as text or images. Left aligns the table to the left of other 
elements, right aligns the table to the right of other elements, and Center 
centers the table. You can left-align, right-align, or center the table relative to 
the other elements. You can also choose the browser’s default alignment. 

• Use the Clear Row Heights and Clear Column Widths buttons to delete all 
table row height and column width values from the table. 

• Use the Convert Table Widths to Pixels button to convert the table width from 
a percentage of the browser window to its current width in pixels.

• Use the Convert Table Widths to Percent button to convert the current table 
width from pixels to a percentage of the browser window.
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To set cell padding and spacing, choose from the following options:

• In the CellPad field, specify the number of pixels between the cell content and 
the cell boundary (or wall).

• In the CellSpace field, specify the number of pixels between each table cell.

When cell spacing and cell padding are not assigned specific values, Netscape 
Navigator, Microsoft Internet Explorer, and Dreamweaver all display the table as 
if cell spacing were set to 2 and cell padding were set to 1. 

To set table borders, choose from the following options:

• In the Border field, specify the width of the table border in pixels. Most 
browsers display the border as a three-dimensional line. 

If you are using the table for page layout, specify a border value of 0. To 
view cell and table boundaries when the border is set to 0, choose View > 
Visual Aids > Table Borders.

• Use the Brdr Color field to select a border color for the entire table. 

• Use the Bg Color options to select the background image or background color 
for the table. 

• Use the Bg Image field to select the background image for the table. 

Setting column, row, and cell properties

Select any combination of cells and then use the Property inspector to change the 
appearance of individual cells, rows, or columns. To select cells, rows, and 
columns, see “Selecting table elements” on page 187. To apply formatting to the 
entire table, see “Setting table properties” on page 190. 

To format a row, column, or cell:

1 Select any combination of cells in the table. 

2 Choose Window > Properties to open the Property inspector, and click the 
expander arrow in the lower right corner to see all properties.
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3 Choose from the following appearance options:

• Use the Horz pop-up menu to set the horizontal alignment of a cell’s, column’s, 
or row’s contents. You can align the contents to the left, right, or center, or to 
the browser’s default (usually left for regular cells and center for header cells).

• Use the Vert pop-up menu to set the vertical alignment of the cell’s, column’s, 
or row’s contents. You can align the contents to the top, middle, bottom, or 
baseline, or to the browser’s default (usually middle). 

• In the W and H fields, specify the width and height of selected cells in pixels. 
To use percentages, follow the value with a percent symbol (%).

• To set a background image for a cell, column, or row, use the top Bg field. 
Click the folder icon to browse to an image; you can also type the image’s 
path or use the Point-to-File icon. 

• To set the background color for a cell, column, or row, use the bottom 
Bg field. You can use the color picker or type the hexadecimal code for 
the color you want. 

• To set a border color for cells, use the Brdr option. 

4 Choose from the following layout options: 

• Click the Merge Cells button to combine selected cells, rows, or columns, 
creating one cell. See “Splitting and merging cells” on page 198.

• Click the Split Cell button to divide a cell, creating two cells. See “Splitting and 
merging cells” on page 198.

• Select No Wrap to prevent word wrapping. This causes cells to widen to 
accommodate all data as you type it or paste it into a cell. (Normally, 
cells expand horizontally to accommodate the longest word and then 
expand vertically.)

• Select Header to format the selected cells or rows as a table header. The 
contents of table header cells are bold and centered by default. 
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Using a design scheme to format a table

Use the Format Table command to quickly apply a preset design to a table. You 
can then select options to further customize the design. 

To use a preset design:

1 Select the table and choose Commands > Format Table. 

2 In the dialog box that appears, choose a design scheme from the list on the left. 
The table updates to display a sample of the design.

3 To further customize the design, make changes to the Row Colors, Top Row, 
and Left Col options. 

4 To modify the border width, enter a value in the Border field. Enter 0 if you 
don’t want a border. 

5 To apply the design to the table cells (td tags) rather than table rows (tr tags), 
select Apply All Attributes to TD Tags Instead of TR Tags.

Table cell formatting will override any formatting you specified for the row the 
cell is in. However, if you want all the cells in the row to be formatted in the 
same way, it is better to format the table row instead of each cell. This will 
result in cleaner, more concise HTML source code. See “Formatting tables and 
cells” on page 189.

6 Click Apply or OK to format the table with the selected design.
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Resizing tables and cells
You can resize the entire table or individual rows and columns. When you resize 
the entire table, all of the cells in the table change proportionally. 

To resize the table:

1 Select the table.

2 Drag one of the selection handles to resize the table along that dimension. 
Dragging the corner handle resizes both dimensions. 

To change the size of a row or column, do one of the following:

• To change row height, drag the bottom row border. 

• To change column width, drag the right column border. 

Changing column widths

The Property inspector lets you specify the width of a column in three ways. 

To set the column width:

1 Click in any of the column’s cells or select the column. 

2 Choose Window > Properties to open the Property inspector.

3 In the W field, do one of the following:

• Enter a number to set the column width to the specified number of pixels.

• Enter a number followed by the percent symbol (%) to set the column width to 
a percentage of the table width.

• Leave the field blank (the default) to let the browser and Dreamweaver 
determine the proper width based on the contents of the cell and the widths of 
the other columns. Generally, space is allocated based on the longest line or the 
widest image. This is why one column sometimes becomes much larger than 
the other columns in the table when you add content to it.
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Resetting width and height

The simplest way to set column widths and row heights is to drag the borders of 
the table. Dragging a column or row border automatically sets specific values for 
all of the columns or rows, either in pixels or as percentages of the table’s current 
dimensions, depending on how the table width is specified.

If you can’t get the desired result by dragging table borders, you can clear the 
column widths and start over. 

To change widths and heights, do one of the following:

• Select the table, choose Modify > Table, and choose Clear Cell Heights or 
Clear Cell Widths.

• Open the Code view (or Code inspector) and change the widths and heights 
directly in the HTML code.

• In the Property inspector, enter specific width and height values in the 
W and H boxes.
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Adding and removing rows and columns
Use the commands in the Modify > Table submenu or the commands in the 
context menu to add and remove rows and columns from a table.

To add rows or columns:

1 Click in a cell where you want the new row or column to appear.

2 Do one of the following:

• To add a row, choose Modify > Table > Insert Row, or choose Table > Insert 
Row from the context menu.

• To add a column, choose Modify > Table > Insert Column, or choose Table > 
Insert Column from the context menu. 

• To add both rows and columns, choose Modify > Table > Insert Rows 
or Columns, or choose Table > Insert Rows or Columns from the 
context menu.

3 In the dialog box that appears, enter the number of rows or columns you want 
to add, and specify whether the new rows or columns should appear before or 
after the selected row or column. 

4 Click OK.

To delete a row or column:

1 Click in a cell within the row or column you want to delete.

2 Choose one of the following options:

• To delete a row, choose Modify > Table > Delete Row, or choose Table > Delete 
Row from the context menu.

• To delete a column, choose Modify > Table > Delete Column, or choose 
Table > Delete Column from the context menu.

To add or delete rows or columns from the bottom and right of a table:

1 Select the entire table. (Click the table’s upper left corner, or click once in the 
table and choose Modify > Table > Select Table.)

2 In the Property inspector, do one of the following:

• Increase the row or column value to add rows. 

• Decrease the row or column value to delete rows.

Dreamweaver adds and removes rows from the bottom of the table, and it adds 
and removes columns to the right. Dreamweaver does not warn you if you are 
deleting rows and columns that contain data.
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Nesting tables

A nested table is a table within a table. You can configure a nested table as you 
would any other table; however, its width is limited by the width of the cell in 
which it appears.

To nest a table within a table cell:

1 Do one of the following:

• Click in the cell where you want to insert the second table and choose 
Insert > Table.

• Click in the cell where you want to insert the second table.

• Drag the Table button from the Common category of the Objects panel to the 
cell where you want to insert the second table.

2 Specify the table properties in the Insert Table dialog box, and click OK.
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Splitting and merging cells

Use the Property inspector or the commands in the Modify > Table submenu to 
split or merge cells. You can merge any number of adjacent cells—as long as the 
entire selection is rectangular—to produce a single cell that spans several columns 
or rows. You can split a cell into any number of rows or columns, regardless of 
whether it was previously merged. Dreamweaver automatically restructures the 
table (adds any necessary COLSPAN or ROWSPAN attributes) to create the specified 
arrangement. 

In the following illustration, the cells in the middle of the first two rows have been 
merged so that they span two rows.

To merge two or more cells in a table:

1 Select the cells you want to merge. The selected cells must be contiguous and in 
the shape of a rectangle.

This selection is in the form of a rectangle, so the cells can be merged. 

This table selection is not in the shape of a rectangle, so the cells can’t be merged. 

2 Choose Modify > Table > Merge Cells, or click the Merge Cell button in the 
Property inspector.

The contents of the individual cells are placed in the resulting merged cell. The 
properties of the first cell selected are applied to the merged cell.
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To split a merged cell:

1 Click in the cell or select a cell.

2 Choose Modify > Table > Split Cell, or click the Split Cell button in the 
Property inspector. 

3 In the Split Cell dialog box, choose whether to split the cell into rows or 
columns, and then enter the number of rows or columns.

Copying and pasting cells
You can copy and paste multiple table cells at one time, preserving the cell’s 
formatting, or you can copy and paste only the contents of the cell. 

Cells can be pasted at an insertion point or in place of a selection in an existing 
table. To paste multiple table cells, the contents of the Clipboard must be 
compatible with the structure of the table or the selection in the table in which 
the cells will be pasted.

To cut or copy cells in a table:

1 Select one or more cells in the table.
To be cut or copied, the selected cells must form a rectangle. (See “Selecting 
table elements” on page 187.

Correct selection: The cells can be cut or copied.

Incorrect selection: These cells can’t be cut or copied.

2 Cut or copy the cells using the commands in the Edit menu. 

If you select the entire row or column, the row or column is removed from the 
table when you choose Edit > Cut.
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To paste table cells:

1 Choose where you want to paste the cells. 

• To paste cells before or above a particular cell, click in that cell.

• To create new table with the pasted cells, click wherever you want the table to 
appear (as long you don’t click inside another table).

2 Choose Edit > Paste. 

If you are pasting entire rows or columns into an existing table, the rows or 
columns are added to the table. If you are pasting an individual cell, the 
contents of the selected cell are replaced. If you are pasting outside a table, the 
rows, columns, or cells are used to define a new table.

To remove cell content but leave the cells intact:

1 Select one or more cells.

2 Choose Edit > Clear or press Delete. 

Note: If you select all the cells in a row or column, the row or column—not just its contents—
is removed from the table.
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Sorting tables
You can perform a simple table sort based on the contents of a single column. 
You can also perform a more complicated table sort based on the contents of 
two columns.

You cannot sort tables that contain COLSPAN or ROWSPAN attributes—that is, tables 
that contain merged cells. (For details about merged cells, see “Splitting and 
merging cells” on page 198.)

To sort a table:

1 Select the table and choose Commands > Sort Table. 

2 In the dialog box that appears, choose from the following options:

• Select the column to sort in the Sort By option. 

• Select whether you want to sort the column alphabetically or numerically in 
the Order option. 

This option is important when the contents of a column are numerical. An 
alphabetic sort applied to a list of one- and two-digit numbers will result in an 
alphanumeric sort (such as 1, 10, 2, 20, 3, 30) rather than a straight numeric 
sort (such as 1, 2, 3, 10, 20, 30). 

• Select Ascending (A to Z or low to high) or Descending for the sort order. 

3 To perform a secondary sort on a different column, specify the sort options in 
the Then By pop-up menu. 

4 Select the Sort Includes First Row option to include the first row in the sort. If 
the first row is a heading that shouldn’t be moved, leave this option deselected. 

5 Click Apply or OK to sort the table. 
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Exporting table data
To export table data you create in Dreamweaver, you must save the data in a file 
format that accepts delimited data. Delimiter separators you can use are commas, 
colons, semicolons, or spaces. 

You cannot select portions of a table to export; when you export a table, the entire 
table is exported. If you want only particular data from a table—for example, the 
first six rows or the first six columns—create a new table, copy the information to 
the new table, and export the new table.

To export a table:

1 Place the insertion point in any cell of the table to be exported.

2 Choose File > Export > Export Table.

The Export Table dialog box appears.

3 In the Delimiter pop-up menu, select a delimiter value for the table data. 

4 In the Line Breaks pop-up menu, select line breaks for the operating system for 
which you are exporting the file—Windows, Macintosh, or UNIX.

5 Click Export.

6 In the dialog box that appears, type a name for the file and click Save.
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Using Frames

Frames are used in a Web page to divide it into multiple HTML pages. For 
example, a Web page consists of three frames. One thin frame on the side that 
contains a scrolling menu, one frame that runs along the top that contains the 
logo and title of the Web site, and one large frame that takes up the rest of the 
page and contains the main content. Each of these frames is an independent 
HTML page. They all work together on the page through the use of one or more 
framesets, which is an HTML page that defines the structure and properties for 
the Web page, including information about the number of frames displayed on a 
page, the size of the frames, the source of the page loaded into a frame, and other 
definable properties. The frameset page isn’t displayed in a browser; it simply 
stores information about how the frames on a page will display. (It is the page you 
should preview when you use Preview in Browser, however.) 
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In this example, the top frame would remain static and never change from page to 
page in the site. The side frame menu will have links that change the content of 
the main frame area, but otherwise remain static. The main frame area is the 
dynamic area, that changes depending on what menu item you choose.

You can format all of the frames and framesets in your page through the Property 
inspector. You can set scrolling on or off, set width and height, name each page, and 
more. For more information, see “About frame and frameset properties” on page 212.

A Web page that contains three frames consists of four separate HTML pages: the 
frameset file and the three files containing the content that appears inside 
the frames. When you design a page using framesets, you must save each of these 
four files in order for the page to work properly in the browser. For more 
information about how to create successful Web pages that utilize frames, see 
“About creating frame-based Web pages” on page 205.

Deciding whether to use frames
The most common use of frames is for navigation. A Web page can use one frame 
to hold the navigation menu and another frame to hold the page content. Since 
the navigation menu is in a frame, a visitor to your site can click a menu item and 
the content will appear in the content frame, but the navigation menu does not 
change at all. This can keep the user oriented within your site.
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Frames can be confusing to implement, however, and you can often create a Web 
page without frames that accomplishes the same goals as a page using frames. For 
example, if you want the navigation on the left side of your page, you can either 
split your page into two frames, or just include the left navigation on every page in 
your site. The difference is that with frames you only have to create the navigation 
one time. If you do decide to go ahead and use frames in your Web site, make sure 
that you understand the relationship between frames and framesets because 
linking with frames can be confusing.

About creating frame-based Web pages
Frames can be a great tool for Web designers, but they must be implemented 
correctly in order to work. Complete the following steps to ensure that your Web 
page works correctly (not necessarily in any particular order):

• Create the frameset and frames in your page. See “Creating frames” on page 206.

• Save every file used in the site. Remember that each frame and frameset is an 
independent HTML page and each page must be saved. See “Saving frame and 
frameset files” on page 211.

• Set the properties for each frame and frameset. This includes naming each 
frame and frameset, setting scrolling and non-scrolling options, and more. See 
“About frame and frameset properties” on page 212.

• Make sure all your links include targets so the linked content appears in the 
correct area. See “Controlling frame content with links” on page 218.
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Creating frames
There are two ways to create a frameset in Macromedia Dreamweaver: you can 
design it yourself, or you can select from several predefined framesets. Choosing a 
predefined frameset automatically sets up all the framesets and frames needed to 
create the layout and is the easiest way to quickly insert a frame layout into your 
page. You can only create frames in the Document window’s Design view. 

Inserting a predefined frameset

Predefined framesets make it easy for you to select the type of frameset you 
want to create. 

The predefined frameset icons in the Frames category of the Objects panel provide 
a visual representation of each frameset as applied to a selected document.

The selected frameset surrounds the current document—the document in which 
the insertion point is located. The blue area of a predefined frameset icon 
represents the currently selected page or frame in a document, and the white area 
represents the new frame or frames. 

To insert a predefined frameset:

1 Place the insertion point in the document. 

2 Then do one of the following:

• In the Frames category of the Objects panel, select a predefined frameset. 
To insert the frameset, you can click an icon or drag an icon directly to 
the document. 

• To select a predefined frameset, choose Insert > Frames > Left, Right, Top, 
Bottom, Left and Top, Left Top, Top Left, or Split.
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Designing and inserting a frameset

Before creating a frameset or working with frames, make the frame borders visible 
in the document window.

To view frame borders in a document, choose View >Visual Aids > Frame Borders.

When frame borders are displayed, space is added around the document border, 
providing you with a visual indicator of the frame areas in your document.

To create a frameset, do one of the following:

• Choose Modify > Frameset > Split Frame Left, Right, Up, or Down. 

• Drag one of the frame borders into the Document window to split the 
document vertically or horizontally. Drag a frame border from one of the 
corners to divide the document into four frames. 

• Use Alt-drag (Windows) or Option-drag (Macintosh) if you are splitting 
an inner frame.

To delete a frame:

Drag the frame border off the page or to the border of the parent frame.
Using Frames 207



Creating a nested frameset

A frameset inside another frameset is called a nested frameset. Each new frameset 
you create includes its own frameset HTML document and frame documents. 
Most Web pages that use frames are actually using nested frames, and several of 
the predefined framesets in Dreamweaver also use nesting.

For example, a document with three frames might display a company’s logo in a 
frame at the top of the document, navigation controls in a frame on the left side of 
a document, and content in a third frame.

To create a nested frameset:

1 Place the insertion point in the frame where you want to insert a 
nested frameset.

2 Do one of the following:

• Choose Modify > Frameset > Split Frame Up, Down, Left, or Right.

• In the Frames category of the Objects panel, select a frameset icon.

• Choose Insert > Frames > Left, Right, Top, Bottom, Left and Top, Left Top, 
Top Left, or Split.

Selecting a frame or frameset
Frames and framesets are individual HTML documents. To make changes to a 
frame or to the frameset, begin by selecting the frame or frameset you want to 
change. You can select a frame or frameset either in the Document window or by 
using the Frames panel.

When you select a frame or the frameset, selection lines appear in both the Frames 
panel and the Document window. 

Main frameset

Menu frame and 
content frame 
are nested within 
the main 
frameset
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Using the Frames panel

The Frames panel provides a visual representation of the frames within a 
document. You can click a frame or frameset in the Frames panel to select that 
frame or frameset in the document, and then you can view or edit the properties 
of the selected item in the Property inspector. See “About frame and frameset 
properties” on page 212.

The Frames panel shows the hierarchy of the frameset structure in a way that may 
not be apparent in the document window. In the Frames panel, a thick three-
dimensional border surrounds a frameset; frames are surrounded by a thin gray 
line, and each frame is identified by a frame name.

To display the Frames panel, do one of the following:

• Choose Window > Frames. 

• Press Ctrl+F10 (Windows) or Command+F10 (Macintosh).

To select a frame in the Frames panel:

Click the frame in the Frames panel.

To select a frameset in the Frames panel:

Click the border that surrounds the frames in the Frames panel.
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Selecting a frame or frameset in the Document window

In the Document window, when a frame is selected, its borders are outlined with a 
dotted line; when a frameset is selected, all the borders of the frames within the 
frameset are outlined with a dotted line.

Select frames and framesets to change their properties. The Property inspector 
displays the properties of the selected frame or frameset. See “About frame and 
frameset properties” on page 212.

To select a frame in the Document window:

Alt-click (Windows) or Option-Shift-click (Macintosh) inside a frame.

To select a frameset in the Document window:

Click a frame border in the Document window.

To move the selection to another frame, do one of the following:

• To move the selection to the next frame, 
Hold down Alt (Windows) or Command (Macintosh), and press the Left or 
Right Arrow key.

• To move the selection to the parent frameset (containing nested frames), 
Press Alt-Up Arrow (Windows) or Command-Up Arrow (Macintosh).

• To move the selection to the child frame (the frame that is nested in 
another frame), Press Alt-Down Arrow(Windows) or Command-Down 
Arrow (Macintosh).
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Saving frame and frameset files
A frameset file and its associated frame files must be saved before you can preview 
the page in a browser. You can individually save a frameset page or a frame page, 
or you can save all open frame files and the frameset page.

When you use Dreamweaver to create frame documents, each new frame 
document is given a temporary file name—for example, UntitledFrame-1 for the 
frameset page, Untitled-1, Untitled-2, and so forth for the frame pages.

When you select one of the save options, the Save File dialog box opens ready 
to save a document with its temporary file name. Because each file is “untitled,” 
it may be difficult for you to determine which frame file you are saving. Look at 
the frame selection lines in the Document window to identify the current 
document being saved. The selected area identifies the frame currently referenced 
in the Save File dialog box. The file name of the selected frame or frameset also 
appears in the title bar.

To save a frameset file:

1 Select the frameset in the Frames panel or the Document window.

2 Choose one of the following:

• To save the frameset file, choose File > Save Frameset.

• To save the frameset file as a new file, choose File > Save Frameset As.
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To save a document that is inside a frame:

Click in the frame to select it, then choose File > Save Frame or File > 
Save Frame As.

To save all files in a frameset:

Choose File > Save All Frames.

This saves all open documents, including individual documents, frame 
documents, and frameset documents.

Note: Use the frame selection lines in the Document window to help you identify frameset 
and frame documents as you are saving files.

About frame and frameset properties
Frames and framesets each have a Property inspector. 

• Frame properties determine the frame name, source file, margins, scrolling, 
resizing, and borders of individual frames within a frameset. 

• Frameset properties control the dimensions of the frames and the color and 
width of the borders between frames. 

To view frame properties:

1 Choose Window > Properties to display the Property inspector if it isn’t 
already open.

2 Do one of the following:

• Alt-click (Windows) or Option-Shift-click (Macintosh) a frame. 

• Click a frame in the Frames panel.

Setting frame properties

Use the Property inspector to name a frame and to set borders and margins. To see 
all of the frame properties, click the expander arrow in the lower right corner of 
the Property inspector. Naming each of your frames is necessary for your page 
links to work properly

To specify frame properties:

1 Select a frame by doing one of the following:

• Click a frame in the Frames panel.

• Alt-click (Windows) or Option-Shift-click (Macintosh) a frame in the 
Document window.
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2 Choose Window > Properties to open the Property inspector. Click the 
expander arrow in the lower right corner to see all the properties.

3 To name the frame, type a name in the Frame Name field.

Note: Frame Name determines the name of the current frame to use for hyperlink target 
and scripting references. A frame name should be a single word. Underscores (_) are 
allowed, but hyphens (-), periods (.), and spaces are not. Frame names should start with 
a letter (as opposed to a numeral). Don’t use JavaScript reserved words (such as top or 
navigator) for frame names.

4 Choose from the following frame options:

• Src determines the source document for the frame. Enter a file name or click 
the folder icon to browse to and select the file. You can also open a file in a 
frame by placing the pointer in the frame and choosing File > Open in Frame.

• Scroll determines whether scroll bars appear when there is not enough room to 
display the content of the current frame. Most browsers default to Auto.

• No Resize restricts the size of the current frame and prevents users from dragging 
the frame borders. You can always resize frames in the Document window; 
however, if this option is selected a user can’t resize frames in their browser.

• Borders controls the border of the current frame. The options are Yes, No, and 
Default. Choosing a Borders option overrides border settings defined for the 
frameset. (See “Setting frameset properties” on page 214.) Most browsers 
default to Yes. A border can be turned off only when all adjacent frames are set 
to No or when they are set to Default with the parent frameset set to No. 

• Border Color sets a border color for all borders adjacent to the current frame. 
This setting overrides the border color of the frameset..

5 Set the following margin options (if margin options aren’t visible, click the 
expander arrow in the lower right corner): 

Margin Width sets the width in pixels of the left and right margins (the space 
between the frame border and the content).

Margin Height sets the height in pixels of the top and bottom margins (the 
space between the frame borders and the content).
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Setting frameset properties 

Use frameset properties to set borders and frame size. Setting a frame property 
overrides the setting for that property in a frameset. For example, setting border 
properties in a frame overrides the border properties set in the frameset.

Predefined framesets are used to quickly apply a frameset to a document. 
Predefined framesets share the following default property values: no borders, no 
scroll bars, and no resizing of frames when viewed in a browser. To change the 
default values, select the options you want in the Property inspector.

To view frameset properties:

1 Choose Window > Properties to display the Property inspector, if it isn’t 
already open.

2 Do one of the following:

• Click a border between two frames in the Document window.

• Click the border that surrounds the frames in the Frames panel. 

3 To see all the frameset properties, click the expander arrow in the lower right 
corner of the Property inspector.
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To specify frameset properties:

1 Select a frameset.

2 In the Borders pop-up menu, select whether you want to display borders 
around frames when the document is viewed in a browser.

• If you want to display borders, select Yes.

• If you don’t want to display borders, select No.

• If you want the user’s browser to determine how borders are displayed, 
select Default.

3 In the Border Width field, type a number to specify the width of the borders in 
the current frameset.

4 In the Border Color field, use the color picker to select a color for the border, or 
type the hexadecimal value for a color.

5 To select frame size options, click the tabs on the RowCol Selection box to 
select a row or the tabs on top to select a column. Then in the Value field, type 
a number to set the size of the selected row or column, and in the Units pop-up 
menu, set the unit of measure for the number in the Value field. 

Naming a frameset document

To add a title to a frameset page, you use the page properties option.

To name a frameset page:

1 Select a frameset by doing one of the following:

• Click the border of the frameset in the Frames panel.

• Alt-click (Windows) or Option-Shift-click (Macintosh) a frame in the 
Document window. You may have to press Alt-Up Arrow (Windows) or 
Command-Up Arrow (Macintosh) to select the frameset.

2 Choose Modify > Page Properties.

3 In the Title field, type a name for the document.
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Specifying frame sizes

Drag a frame border in the Document window to set approximate sizes for frames; 
then use the Property inspector to specify how much space the browser allocates to 
a frame when the screen size doesn’t allow the frames to display at full size.

To specify frame sizes:

1 Click a frame border to select the frameset.

Choose View > Visual Aids > Frame Borders if the borders aren’t visible. 

2 In the Property inspector, click the expander arrow to view all properties. 

3 In the RowCol Selection box, click the row or column you want to change.

4 To specify how space is allocated when the browser window is resized, enter a 
number in the Value field and choose from the following Units options:

• Pixels sets the size of the selected column or row at an absolute value. This 
option is the best choice for a frame that should always be the same size, such as 
a navigation bar. If you set a different Units option for the other frames, they 
are allocated space only after frames specified in pixels are their full size.

• Percent specifies that the current frame should make up a specified percentage 
of its frameset. Frames specified with units set to Percent are allocated space 
after frames with units set to Pixels, but before frames with units set to Relative.

• Relative specifies that the current frame be allocated space proportionally to 
other frames. Frames with units set to Relative are allocated space after frames 
with units set to Pixels and Percent, but they fill all of the remaining space in 
the browser window.
Chapter 8216



Setting frame and frameset borders

You can specify how frame and frameset borders appear in a document. 
When you specify border options for a frame, the corresponding frameset 
option is overridden.

To set frame borders:

1 Select the frame by Alt-clicking (Windows) or Option-Shift-clicking 
(Macintosh) or click the frame in the Frames panel.

2 Set the following options in the Property inspector:

• Borders controls the border of the current frames. The options are Yes, No, 
and Default. Most browsers default to Yes. A border can be turned off only 
when all adjacent frames are set to No (or set to Default with the parent 
frameset set to No).

• Border Color sets a border color for all borders adjacent to the current frame. 

To set frameset borders:

1 Select the frameset by clicking a frame border in the Document window or 
clicking the border enclosing the frames in the Frames panel. 

2 Set the following options in the Property inspector: 

• Borders controls the border of frames within the current frameset. Choose Yes 
to display borders in three-dimensional color, choose No to display borders as 
flat and gray, or choose Default to let the browser determine how borders are 
displayed. Most browsers default to Yes.

• Border Color sets a color for all borders in the current frameset. This setting 
can be overridden for a single frame by a setting a border color for that frame. 

• Border Width specifies the width of the borders in the current frameset. Enter 
0 to specify no borders. 

Changing the background color of a frame

You change the background color of a frame by setting the background color of 
the document in the frame.

To change the background color of a document in a frame:

1 Do one of the following:

• Place the pointer in the frame and choose Modify > Page Properties.

• Right-click (Windows) or Control-click (Macintosh) inside the frame and 
choose Page Properties from the context menu.

2 Click the Background pop-up menu to select a color.
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Controlling frame content with links
To use links in frames, you must set a target for the link. The target is the frame in 
which the linked content will open. For example, if the navigation menu is in the 
left frame, and you want the linked material to appear in the main content frame, 
you must use targets for all the navigation menu links. The target will be the name 
of the main content frame—for example, main_frame. When a user clicks a a 
navigation link, the content will open in the main frame.

To select a frame in which to open a file, you use the Target pop-up menu in the 
Property inspector. You can set a file to open in a new frame, replace information 
in the same frame as the link, or replace information in another frame. You can 
also cause the linked content to overwrite the current frame (by not choosing a 
target) or to appear in an entirely new browser window.

To target a frame:

1 Select text or an object.

2 In the Link field of the Property inspector, do one of the following:

• Type the name of the file to link to.

• Click the folder icon and select the file to link to.

• Click and drag the Point to File icon to select the file to link to. 

To specify an anchor (specific place) in the file to link to, enter a number 
sign (#) before the anchor name. See “Linking to a specific place within a 
document” on page 362.

3 In the Target pop-up menu, choose the location in which the linked document 
should appear.

• If you named your frames in the Property inspector, the frame names appear in 
this menu. Select a named frame to open the linked document in that frame.

• _blank opens the linked document in a new browser window and keeps the 
current window available.

• _parent opens the linked document in the parent frameset of the link. 

• _self opens the link in the current frame, replacing the content in that frame. 

• _top opens the link in the outermost frameset of the current document, 
replacing all frames.
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Handling browsers that can’t display frames
Dreamweaver lets you specify content to display in older and text-based browsers 
that do not support frames. Dreamweaver inserts the content you specify in the 
frameset document using a statement similar to the following:

<noframes><body bgcolor="#FFFFFF">
this is the noframes content.
</body></noframes>

When a browser that doesn’t support frames loads the frameset file, the browser 
displays only the content enclosed by the noframes tags.

To define content for browsers that don’t support frames:

1 Choose Modify > Frameset > Edit NoFrames Content.

Dreamweaver clears the Document window, and the words “NoFrames 
Content” appear at the top of the body area.

2 To create the NoFrames content, do one of the following:

• In the Document window, type or insert the content.

• Choose Window > Code Inspector, and between the noframes tags, type the 
content or HTML code for the content.

3 Choose Modify > Frameset > Edit NoFrames Content again to return to the 
normal view of the frameset document.
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Using behaviors with frames
You can apply a number of behaviors that take advantage of the way frames 
operate. Frames are usually used when the Web page designer wants to control the 
display of content on a Web page. There are several behaviors that facilitate 
changing the contents of a frame.

• Set Text of Frame replaces the content and formatting of a frame with the 
content you specify. The content can include any valid HTML. Use this action 
to dynamically display information. See “Set Text of Frame” on page 461.

• Go to URL opens a new page in the current window or in the specified frame. 
This action is particularly useful for changing the contents of two or more 
frames with one click. See “Go to URL” on page 454.

• Insert Navigation Bar is used to direct a user to specific pages in a Web site. You 
can attach behaviors to navigation bar images and set which image displays 
based on a user’s actions. For example, you may want to show a button image 
in its Up or Down state to let a user know which page of a site is being viewed. 
See “Inserting a navigation bar” on page 372.

• Insert Jump Menu lets you set up a pop-up menu list of links that open 
files in a browser window when clicked. You can also target a particular 
window or frame in which the document will open. See “Inserting a jump 
menu” on page 369.
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Managing and Inserting Assets

Assets are elements, such as images or movie files, that you use in building a 
page or a site.        

The Assets panel helps you manage and organize your site’s assets more easily than 
you can in the Site window. The panel displays the assets in your site, dividing 
into the following categories:

• Images

• Colors

• URLs

• Flash movies

• Shockwave movies

• MPEG and QuickTime movies

• Scripts

• Templates

• Library items

Note: Only files that fit the above categories are shown in the Assets panel. There are other 
types of files that are sometimes called assets, but they aren’t shown in the panel. 

If you haven’t already gathered assets for your site, you can obtain them from 
various sources. For example, you might create assets in an application such as 
Macromedia Fireworks or Macromedia Flash, receive them from a co-worker or 
client, or copy them from a clip-art CD. For more information about planning 
and gathering assets, see “About site planning and design” on page 95.
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You can use the Assets panel in two different ways: as an easily accessible list of 
the assets in your site (the Site list), or as a way to organize the assets that you 
use most frequently (the Favorites list). The Assets panel automatically puts your 
site’s assets in the Site list. The Favorites list starts out empty; you add whatever 
assets you want to it.

Most of the operations of the Assets panel are the same in the Site list and in the 
Favorites list. There are a few tasks, however, that you can perform only in the 
Favorites list (see “Using favorite assets” on page 229).

Templates and library items are covered in more depth in “Reusing Content with 
Templates and Libraries” on page 375.

Using the Assets panel
The Assets panel provides two ways to view assets: the Site list, which shows all of 
the assets (of the types the panel recognizes) in your site, and the Favorites list, 
which shows only the assets you’ve explicitly chosen. Most of the following 
procedures can be performed in either the Site list or the Favorites list.

In both lists, assets are divided into categories; you choose which category of assets 
to list by clicking one of the category buttons on the left side of the panel. (The 
Site list and the Favorites list are both available for all categories of assets except 
templates and library items.)

The Site list displays all assets (in recognized categories) that exist as files in your 
site (whether or not any document uses them), as well as all colors and URLs that 
are used in any document in your site.

You can work with the following categories of assets: 

Images are image files, in GIF, JPEG, or PNG formats. For information about 
images, see “Inserting Images” on page 267.

Colors are the colors used in documents and style sheets in your site, including 
text colors, background colors, and link colors.

URLs are the external URLs that documents in your site contain links to. This 
category includes the following types of links: FTP, gopher, HTTP, HTTPS, 
JavaScript, e-mail (mailto), and local file (file://). 

Flash movies are files in any version of Macromedia Flash format. The Assets 
panel displays only SWF (compressed Flash) files, not FLA (Flash source) files. See 
“About Flash content” on page 300.

Shockwave movies are files in any version of Macromedia Shockwave format. See 
“About Shockwave movies” on page 310.

Movies are movie files in QuickTime or MPEG format. See “Inserting Media” 
on page 297.
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Scripts are JavaScript or VBScript files. Note that scripts in HTML files (rather 
than in independent JavaScript or VBScript files) do not appear in the Assets 
panel. For information on working with JavaScript in Macromedia Dreamweaver, 
see “Debugging JavaScript Code” on page 473.

Templates provide a way to use the same page layout on multiple pages, and to 
easily modify that layout on all pages at once. See “Reusing Content with 
Templates and Libraries” on page 375.

Library items are elements that you use in multiple pages; when you modify a 
library item, all pages that contain that item are updated. See “Reusing Content 
with Templates and Libraries” on page 375.

To open the Assets panel: 

Choose Window > Assets. The Assets panel appears. 

It may take a few seconds for the panel to create the Site list, because it has to read 
the site cache to create the list.

Note: You must define a site and create a site cache before you can use the Assets panel. 
See “Using Dreamweaver to set up a new site” on page 102.
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Certain changes don’t appear immediately in the Assets panel:

• When you add an asset or remove one from your site, the changes aren’t 
reflected in the Assets panel until you refresh the Site list by clicking the 
Refresh Site List button. (If you add or remove an asset outside of 
Dreamweaver—using Windows Explorer or the Finder, for example—you 
must rebuild the site cache to make the change appear in the Assets panel.)

• When you remove the only instance in your site of a particular color or 
URL, or when you save a new file that contains a color or URL that wasn’t 
previously used in the site, the changes aren’t reflected in the Assets panel 
until you refresh the Site list.

To manually refresh the Site list: 

1 Click Site at the top of the Assets panel to ensure the Site list is showing.

2 Click the Refresh Site List button at the bottom of the Assets panel.

The site cache is created or updated as necessary, and the Assets panel is 
updated to show all the recognized assets in your site.

To manually rebuild the site cache from scratch and refresh the Site list:

Control-click (Windows) or Command-click (Macintosh) the Refresh Site List 
button at the bottom of the Assets panel.

To view the Favorites list:

Click Favorites at the top of the Assets panel.

The Favorites list is empty until you explicitly add assets to it.

To view the Site list:

Click Site at the top of the Assets panel.

Note: In the Templates and Library categories, the Site and Favorites choices are unavailable.

To display assets in a particular category:

Click the appropriate category icon, and click either Site or Favorites. For 
example, to display all of the images in your site, click the Images icon and 
then click Site.

To preview an asset:

Select the asset in the Assets panel.

The preview area at the top of the panel shows a visual preview of the asset.

When a movie asset is selected, the preview area shows an icon. To view the movie, 
click the Play button (the green triangle) in the upper right corner of the preview area.
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To change the size of the preview area:

Drag the splitter bar (between the preview area and the list of assets) up or down.

To add assets to your Favorites list: 

1 Select one or more assets in the Site list.

2 Click the Add to Favorites button.

The assets are added to your Favorites list. To see the Favorites list, click 
Favorites at the top of the panel.

For other methods of adding assets to your Favorites list, see “Adding assets to 
and removing assets from the Favorites list” on page 229.

Note: There are no Favorites lists for templates and library items.

Adding an asset to a page

You insert most kinds of assets into a document by dragging them into the 
Document window’s Design view, or by using the Insert button. You can either 
insert colors and URLs or apply them to selected text in the Design view. (URLs 
can also be applied to other elements in the Design view, such as images.) 
Templates are applied to the entire document. 

To insert an asset in a document:

1 Place the insertion point in the Design view where you want the asset to appear.

2 Choose Window > Assets to open the Assets panel if it’s not already open.

3 Select the category of the asset. 

Select any category other than Templates. (A template can be applied only to an 
entire document; it can’t be inserted into a document.)

4 Select either Site or Favorites and locate the desired asset.

There are no Site or Favorites lists for library items; skip this step if you’re 
inserting a library item.

5 Do one of the following:

• Drag the asset from the panel into the Design view. (For scripts, you can drag 
into the head content area of the Document window; if that area isn’t showing, 
first choose View > Head Content.)

• Select the asset in the panel and click Insert.

The asset is inserted into the document. (If the asset is a color, it applies 
starting at the insertion point; that is, subsequent typing appears in that color.)
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To change the color of selected text in a document: 

1 Select the Colors category in the Assets panel.

2 Select the color to apply.

3 Click Apply.

To add a link to the current selection in a document: 

1 Select the URLs category in the Assets panel, and locate a URL to apply.

2 Do one of the following:

• Drag the URL from the panel to the selection in the Design view.

• Select the URL and click the Apply button.

To apply a template to the active document: 

1 Select the Template category in the Assets panel, and locate a template to apply.

2 Do one of the following:

• Drag the template from the panel to the Design view.

• Select the template and click the Apply button.

Changing the order of assets

By default, assets in a given category are listed in alphabetical order by name. The 
asset name may be a file name (as for images), a hexadecimal number (as for 
colors), or a URL. You can instead list the assets by any of several other criteria.

To list assets in a different order:

Click one of the column headings.

For example, to sort the list of images by type (so that all the GIF images are together, 
all the JPEG images are together, and so on), click the Type column heading.

To change the width of a column:

1 Position the pointer over the line that separates two column headings.

2 Drag that line to change the column width.
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Selecting and editing assets

The Assets panel allows you to select multiple assets at once. It also provides a 
quick way to begin editing assets.

To select multiple assets: 

1 Select one of the assets by clicking it. Then select the other assets in one of the 
following ways:

• Shift-click to select a consecutive series of assets.

• Control-click (Windows) or Command-click (Macintosh) to add an individual 
asset to the selection (whether or not it’s adjacent to the existing selection). 
Control-click or Command-click a selected asset to deselect it.

To edit an asset: 

1 Do one of the following:

• Double-click the asset.

• Select the asset, then click Edit.

For some kinds of assets, such as images, editing the asset starts an external 
editing application. For colors and URLs, editing the asset lets you change the 
asset’s value in the Favorites list only. (You can’t edit colors and URLs in the Site 
list.) For templates and library items, editing the asset allows you to make 
changes to the asset within Dreamweaver.

If an external editor doesn’t open for an asset that’s supposed to use one, choose 
Edit > Preferences, select the File Types/Editors category, and make sure you 
have an external editor defined for the asset’s file type. See “Launching an 
external editor” on page 298.

2 Change the asset as desired.

3 When you’re done editing the asset, do one of the following:

• If the asset is a file-based asset (anything other than a color or URL), save it 
(using whatever editor you used to edit it) and close it. 

• If the asset is a URL, click OK when you’re finished editing in the Edit 
URL dialog box.

If the asset is a color, the Dreamweaver color picker is dismissed automatically 
when you pick a color. (To dismiss the color picker without picking a 
color, press Esc.)
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Working with assets and sites

You may want to locate the file in the Site window that corresponds to an asset in 
the Assets panel. This can be useful, for example, when you want to transfer the 
asset to or from your remote site.

The Assets panel shows all the assets (of recognized types) in your current site. (The 
current site is the site that contains the active document.) To use an asset from the 
current site in another site, you must copy it to the other site. You can copy an 
individual asset, a set of individual assets, or an entire Favorites folder at once.

Note: The Site window may show a different site from the one that the Assets panel shows. 
This is because the Assets panel is associated with the active document. To determine 
which site the Assets panel is showing, look at the panel’s title bar.

To locate an asset’s file in the Site window:

Right-click (Windows) or Control-click (Macintosh) the asset’s name or icon in 
the Assets panel, and choose Locate in Site from the context menu.

The Site window appears, with the asset file selected.

Locate in Site is unavailable for colors and URLs, which do not correspond to 
files in the site.

Note that Locate in Site locates the file corresponding to the asset itself; it does not 
locate a file that uses that asset.

To copy assets from the Site list or the Favorites list to another site:

1 Right-click (Windows) or Control-click (Macintosh) the icon or name of the 
asset or assets to copy. 

In the Favorites list, you can copy a Favorites folder as well as individual assets.

2 From the context menu, choose Copy to Site, and choose the target site name 
from the submenu. (The submenu lists all the sites you’ve defined.)

The assets are copied to the specified site, into locations corresponding to their 
locations in the current site. Dreamweaver creates new folders in the target site’s 
hierarchy as needed.

The assets are also added to the specified site’s Favorites list.

When you open a document in the target site, the Assets panel switches to that 
site, and shows the copied asset.

Note: If the asset you copied is a color or a URL, it appears only in the other site’s 
Favorites list, not in the other site’s Site list. This is because there is no file 
corresponding to the color or URL, so there’s no file to copy into the other site.
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Using favorite assets
Most of the operations of the Assets panel are the same in the Favorites list as in 
the Site list (see “Using the Assets panel” on page 222). However, there are several 
tasks that you can perform only in the Favorites list. 

Because the Assets panel’s Site list always shows all of the recognized assets in the 
site, this list can become cumbersome for some large sites. If you add frequently 
used assets to your Favorites list, you can group related assets together, give them 
nicknames to remind you what they’re for, and find them easily in the Assets panel.

Note: Favorite assets are not stored as separate files on your disk; they’re references to the 
assets in the Site list. Dreamweaver keeps track of which assets from the Site list to display 
in the Favorites list.

Adding assets to and removing assets from the Favorites list

There are several ways to add assets to your site’s Favorites list.

To add assets to your Favorites list, do one of the following:

• Select one or more assets in the Site list, and click the Add to Favorites button.

• Select one or more assets in the Site list, and choose Add to Favorites from the 
context menu.

• Right-click (Windows) or Control-click (Macintosh) an element in the 
Document window’s Design view, and choose the context menu command to 
add the element to the appropriate Favorites category. 

For example, you can select an image and choose Add to Image Favorites from 
the context menu. Note that the context menu for text contains either Add to 
Color Favorites or Add to URL Favorites, depending on whether the text has a 
link attached. Also note that only elements that fit one of the categories in the 
Assets panel can be added to the Favorites list.

• Select one or more files in the Site window and choose Add to Favorites from 
the context menu. Files that don’t fit a category in the Assets panel are ignored.

Whichever method you choose, the assets are added to your Favorites list, and the 
Assets panel displays the Favorites list.

Note: There are no Favorites lists for templates and library items.
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To remove assets from your Favorites list:

1 Select one or more assets (or a Favorites folder) in the Favorites list.

2 Click the Remove From Favorites button at the bottom of the Assets panel.

The assets are removed from the Favorites list, but they still appear in the Site 
list. If you remove a Favorites folder, the folder and all of the assets in it are 
removed from the Favorites list.

Creating a nickname for a favorite asset

You can give nicknames to assets in the Favorites list. The nickname is displayed 
instead of the asset’s file name or value. For example, if you have a color named 
#999900, you might use a more descriptive nickname, such as 
PageBackgroundColor or ImportantTextColor.

You can give nicknames only to assets in the Favorites list. In the Site list, the 
assets are listed by their real file names (or values, in the case of colors and URLs).

To give a nickname to a favorite asset:

1 Click the category that contains your asset.

2 Click Favorites to display the Favorites list.

3 Do one of the following:

• Right-click (Windows) or Control-click (Macintosh) the asset’s name or icon 
in the Assets panel, and choose Edit Nickname from the context menu.

• Click the asset’s name once, pause, then click it again. (Don’t double-click.)

4 Type a nickname for the asset, then press Enter (Windows) or Return 
(Macintosh).

The nickname appears in the Nickname column.
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Grouping assets in a Favorites folder

In the Favorites list, within a given category, you can create named groups of 
assets, called Favorites folders. For example, if you have a set of images that you 
use on numerous catalog pages in an e-commerce site, you could group them 
together in a folder called CatalogImages. 

Note: Placing an asset in a Favorites folder does not change the location of the asset’s 
file on your disk.

To create a Favorites folder:

1 Click Favorites (at the top of the Assets panel) to display the Favorites list.

2 Click the New Favorites Folder button.

3 Name the folder.

4 Drag assets into the folder.

Creating a new color, URL, template, or library item

You can use the Assets panel to create colors, URLs, templates, and library items. 
Note that you can’t add new colors or URLs to the Site list; the Site list contains 
only assets that are already in use in your site.

To create a new color:

1 Click the Colors category button.

2 Click Favorites to show the Favorites list.

3 Click the New Color button.

4 Select a color using the color picker. 

To exit from the color picker without choosing a color, press Esc or click the 
gray bar at the top of the color picker. (For more information on using the 
color picker, see “Working with colors” on page 87.) 

5 Give the color a nickname if desired.

To create a new URL:

1 Click the URLs category button.

2 Click Favorites to show the Favorites list.

3 Click the New URL button.

4 Enter a URL and a nickname in the Add URL dialog box, and click OK.
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To create a new template:

1 Click the Templates category button.

2 Click the New Template button.

For more information on creating new templates, see “Reusing Content with 
Templates and Libraries” on page 375.

To create a new library item, do one of the following:

• Click the Library category button, then click the New Library Item button.

• Select an element or text in the Document window’s Design view, then drag 
that element or text to the Assets panel. Regardless of what kind of element you 
drag, a new library item is created containing that element.

For more information on creating new library items, see “Reusing Content with 
Templates and Libraries” on page 375. 
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Inserting and Formatting Text

Formatting in Macromedia Dreamweaver is similar to using a standard word 
processor. Use the Text > Paragraph Format submenu or the Format drop-down 
menu in the Property inspector to set the default formatting style (Paragraph, 
Preformatted, Heading 1, Heading 2, and so on) for a block of text. To change the 
font, size, color, and alignment of selected text, use the Text menu or the Property 
inspector. To apply formatting such as bold, italic, code, underline, and so on, use 
the Text > Style submenu.

You can also combine several standard HTML tags to form a single style, called an 
HTML style. For example, you can manually apply HTML formatting using a 
combination of tags and attributes, and then save that formatting as an HTML 
style; it’s stored in the HTML Styles panel. The next time you want to format text 
using that combination of HTML tags, you can simply select the saved style from 
the HTML Styles panel. HTML styles are supported by almost all Web browsers 
and save time over manually formatting text. 

Another kind of style, called a CSS style (CSS stands for Cascading Style Sheets), 
lets you apply text and page formatting with the advantage of automatic updating. 
You can store CSS styles directly in the document or, for more power and 
flexibility, in an external style sheet. If you attach an external style sheet to several 
Web pages, all the pages automatically reflect any changes you make to the style 
sheet. To access CSS styles, use the CSS Style panel.

Manual HTML formatting and HTML styles apply formatting using standard 
HTML tags (such as b, font, and code) that are supported by all popular Web 
browsers. CSS styles define the formatting for all text in a particular class or 
redefine the formatting for a particular tag (such as h1, h2, p, or li). CSS is 
supported only by the following Web browsers—Netscape Navigator 4.0 and later 
and Microsoft Internet Explorer 4.0 and later. 
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You can use CSS styles, HTML styles, and manual HTML formatting within the 
same page. Manual HTML formatting overrides formatting applied by an HTML 
style or CSS style, so although it is labor intensive, it can be a convenient method 
of modifying formatting applied by HTML styles or CSS styles. Also, page-level 
CSS styles override external CSS styles. See “Using CSS style sheets” on page 248.

Inserting text and objects
Add content to your pages by typing or pasting text and inserting objects such as 
images, tables, and layers.

To add text to your document, do one of the following:

• Type text directly into the Document window.

• Copy text from another application, switch to Dreamweaver, position the 
insertion point in the Design view of the Document window, and choose 
Edit > Paste. Dreamweaver doesn’t preserve text formatting applied in the other 
application, but it does preserve line breaks.

To insert tables, tabular data, images, and other objects into your document, do 
one of the following:

• Use the commands on the Insert menu to insert the specified objects into your 
document at the insertion point location.

• Choose Window > Objects to open the Objects panel. Find the type of object 
you want and click or drag it to insert the object into the Document window.

For most objects, a dialog box appears, prompting you to select options or to 
select a file. To bypass these dialog boxes, choose Edit > Preferences, select 
General, and then deselect the Show Dialog When Inserting Objects option.

Note: To insert multiple consecutive spaces, use Insert > Special Characters > Non-
Breaking Space (Ctrl+Shift+Space) or press Enter/Return. (But if you want to line up items 
in columns, use a table instead.)

You can import tabular data into your document by first saving these files (such as 
Microsoft Excel files or a database) as delimited text files.
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To import tabular data:

1 Choose File > Import > Import Tabular Data, or choose Insert > Tabular Data.

The Import Table dialog box appears.

2 Browse for the file you want or enter its name in the text field.

3 Select the delimiter used when the file was saved as delimited text. Your options 
are Tab, Comma, Semicolon, Colon, and Other.

• If you select Other, a blank field appears next to the option. Enter the character 
that was used as a delimiter.

4 Use the remaining options to format or define the table into which the data 
will be imported.

5 Click OK when you’re done.

Inserting dates

Dreamweaver provides a convenient Date object, which inserts the current date in 
whatever format you prefer (with or without the time) and provides the option of 
updating that date whenever you save the file. 

Note: Keep in mind that the dates and times shown in the Insert Date dialog box are not the 
current date, nor do they reflect the dates/times that a visitor sees when they display your 
site. They are examples only of the way you want to display this information.

To insert the current date into a document:

1 In the Document window, place the insertion point where you want the date 
to be inserted.

2 Do one of the following:

• Choose Insert > Date.

• Open the Objects panel by choosing Window > Objects, then open the 
Common category and click the Date button.

3 In the resulting dialog box, select a format for the name of the day of the week, 
a format for the date, and a format for the time.

4 If you want the inserted date to be updated every time you save the document, 
select Update Automatically on Save. If you want the date to become plain text 
when it’s inserted, and never update automatically, deselect that option.

5 Click OK to insert the date.

Tip: If you have selected Update Automatically on Save, you can edit the date format after 
it has been inserted into the document by clicking on the formatted text and selecting Edit 
Date Format in the Property inspector.
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About special characters

Certain special characters are represented in HTML by a name or a number, 
referred to as an entity. HTML includes entity names for characters such as the 
copyright symbol (&copy;) the ampersand (&amp;), and the registered-trademark 
symbol (&reg;). Each entity has both a name (such as &mdash;) and a numeric 
equivalent (such as &#151;).

Tip: HTML uses the angle brackets <> in its code, but you may need to express the special 
characters for greater than or less than without Dreamweaver interpreting them as code. In 
this case, use &gt; for greater than (>) and &it; for less than (<).

Unfortunately, many browsers (especially older browsers, and browsers other than 
Navigator and Internet Explorer) don’t properly display many of the named 
entities. Most browsers display most of the commonly used numeric entities, but 
remembering an entity’s number is harder than remembering its name.

Inserting special text characters

You can insert several special characters (in the form of HTML entities) by 
choosing the Characters category from Objects panel’s drop-down menu. 

To insert a special character into a document:

1 In the Document window, place the insertion point where you want to insert a 
special character.

2 Do one of the following:

• Choose the name of the character from the Insert > Characters submenu.

• Open the Objects panel (by choosing Window > Objects), choose the 
Characters category from the drop-down menu and select the character 
you want.

There are many other special characters available; to select one of them, choose 
Insert > Characters > More and select a character, then click OK.
Chapter 10236



Copying and pasting HTML source code in Dreamweaver

You can copy and paste HTML source code from another application or from the 
Code view itself. You can choose to have the HTML code copied and pasted as 
text or as code with tags intact, depending on how you copy and paste it.

To copy HTML source code and paste in Code view:

1 Copy the code from another application (like BBEdit or HomeSite) or from 
the Code view or Code inspector in Dreamweaver, and place the insertion 
point in the Code view.

2 Choose Edit > Paste, and select Refresh Design View from the toolbar.

For example, copy the HTML source code for a table from BBEdit and paste 
it in the Code view of Dreamweaver in order for it to appear as a table in 
the Design view.

If you want the HTML source code to appear as text, place the insertion point in 
in the Design view directly and choose Edit > Paste to paste the code as text. You 
might choose to do this if your Dreamweaver document contained instructions on 
writing HTML and you wanted the code to appear as text in the Document.

To copy and paste as HTML source code:

1 Select and copy the code from another application.

2 Place the insertion point in the Design view, and choose Edit > Paste as HTML.

You can also select an item in the Design view, for example, a table, and choose 
Edit > Copy as HTML. You can then paste this in another application as HTML 
source code. For more information on editing HTML source code, see “Writing 
and editing code” on page 334.

Creating lists
You can create numbered (ordered) lists, bulleted (unordered) lists, and definition 
lists from existing text or from new text as you type in the Document window. 
Definition lists do not use leading characters like bullet points or numbers and are 
often used in glossaries or descriptions. Lists can also be nested. Nested lists are 
lists that contain other lists. For example, you might want an ordered or bulleted 
list nested within another numbered or ordered list.
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To create a new list:

1 In Design view, place the insertion point on the line where you want to add a 
list of new items.

2 Click the Bulleted or Numbered List buttons in the Property inspector, or 
choose Text > List and select the type of list desired—Unordered (bulleted) 
List, Ordered (numbered) List, or Definition List.

You can insert a list while in Code view by using the Text menu, but 
Dreamweaver adds only the first and last HTML list tags and then you must 
hand code the individual list items.

3 Begin typing the list, pressing Enter (Windows) or Return (Macintosh) to 
begin another list item.

4 To complete the list, press Enter twice (Windows) or press Return 
twice (Macintosh).

To create a list using existing text:

1 Select a series of paragraphs to make into a list.

2 Click the Bulleted or Numbered List button in the Property inspector, or 
choose Text > List and select the type of list desired—Unordered List, Ordered 
List, or Definition List.

To create a nested list:

1 Select the list items you want to nest.

2 Click the Indent button in the Property inspector, or choose Text > Indent.

Dreamweaver indents the text and creates a separate list with the original list’s 
HTML attributes.

3 Apply a new list type or style to the indented text by following the same 
procedure used above.

Setting fonts, styles, color, and alignment
You can apply HTML text formatting to one letter or build an entire site using 
Text > Paragraph Format commands or options in the Property inspector. 
This kind of manual formatting replaces or overrides formatting set by an 
HTML style or CSS style.

When you apply HTML text formatting, you use the Property inspector and 
commands in the Text menu, such as Text > Paragraph Format and Text > Style.
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Setting and changing fonts and styles

Use the Property inspector or the Text menu to set or change font characteristics 
for selected text.

To set or change font characteristics:

1 Select the text. If no text is selected, the change applies to subsequent text you type.

2 Choose from the following options:

• To change the font, choose a font combination from the Property inspector or 
from the Text > Font submenu.

Browsers display the text using the first font in the combination that is installed on 
the user’s system. If none of the fonts in the combination is installed, the browser 
displays the text as specified by the browser preferences. (See also “Modifying font 
combinations” on page 242.) Choose Default to remove previously applied fonts; 
Default applies the default font for the selected text (either the browser default 
font or the font assigned to that tag in the CSS style sheet). 

• To change the font style, click Bold or Italic in the Property inspector, or choose 
a font style (Bold, Italic, Underline, and so on) from the Text > Style submenu.

• To change the font size, choose a size (1 through 7) from the Property inspector 
or from the Text > Size submenu.

HTML font sizes are relative, not specific point sizes. Users set the point size of 
the default font for their browsers; this is the font size that they will see when 
you select Default or 3 in the Property inspector or Text > Size submenu. Sizes 
1 and 2 will appear smaller than the default font size; sizes 4 through 7 will 
appear larger. Also, fonts generally look bigger in Windows than on the 
Macintosh, though Macintosh Internet Explorer 5 uses the same default font 
size as Windows.

• To increase or decrease the size of selected text, choose a relative size (+ or –1 to + 4 
or –3) from the Property inspector or from either the Text > Size Change submenu.

Tip: One way to ensure consistency with font size is to use CSS styles with your font size 
set in pixels. For more information on CSS, see “Using CSS style sheets” on page 248.

These numbers indicate a relative difference from the basefont size. The default 
basefont value is 3. Thus, a +4 value results in a font size of 3 + 4, or 7. 7 is the 
maximum sum for your font size values. If you try to set them higher, they 
display as 7. Dreamweaver does not display the basefont tag (which goes in 
the head section), although the font size should display properly in a browser. 
To test this, compare text set at 3 and text set at +3.
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Using paragraphs and headings

Use the Format pop-up menu in the Property inspector or the Text > Paragraph 
Format submenu to apply the standard paragraph and heading tags. (To redefine 
the appearance of paragraph and heading tags, use CSS style sheets; see “Using 
CSS style sheets” on page 248.)

To apply a paragraph or heading tag:

1 Place the insertion point in the paragraph, or select some of the text in 
the paragraph.

2 Using the Text > Paragraph Format submenu or the Format drop-down menu 
in the Property inspector, choose an option:

• Choose a paragraph format (for example, Heading 1, Heading 2, Preformatted 
Text, and so on). The HTML tag associated with the selected style (for 
example, h1 for Heading 1, h2 for Heading 2, pre for Preformatted text, and so 
on) is applied to the entire paragraph.

• Choose None to remove a paragraph format.

Changing the text color

You can change the color of selected text so that the new color overrides the text 
color set in Page Properties. (If no text color has been set in Page Properties, the 
default text color is black.)

To change the color of text:

1 Select the text.

2 Choose from the following options:

• Choose a color from the palette of browser-safe colors by clicking the color 
picker in the Property inspector.

• Choose Text > Color. The system color picker dialog box appears. Select a color 
and click OK.

• Enter the color name or hexadecimal number directly into the Property 
inspector field.

• To define the default text color, use the Modify > Page Properties command. 
See “Defining default text colors” on page 153.

To return text to the default color:

1 In the Property inspector, click the color box to open the palette of 
browser-safe colors.

2 Click the Strike through button (the white square button with a red line 
through it, found in the upper-right corner).
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Aligning text

Align text on the page using the Property inspector or the Text > Align submenu. 
Center any element on a page using the Text > Align > Center command.

To align text:

1 Select the text you want to align or simply insert the pointer at the beginning 
of the text.

2 Click an alignment option (Left, Right, or Center) in the Property inspector, or 
choose Text > Align and choose an alignment command.

To center elements:

1 Select the element (image, plug-in, table, or other page element) you 
want to center.

2 Choose Text > Align > Center.

Note: You can align and center complete blocks of text; you cannot align or center part of a 
heading or part of a paragraph.

To indent text and remove indentation:

1 Select the desired text.

2 Click the Indent or Outdent button in the Property inspector, choose 
Text > Indent or Outdent, or choose List > Indent or Outdent from the 
context menu.

This applies or removes the blockquote tag when the selected text is a 
paragraph or heading; it adds or removes an extra ul or ol tag when the 
selected text is a list.
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Modifying font combinations

Use the Edit Font List command to set the font combinations that appear in the 
Property inspector and the Text > Font submenu.

Font combinations determine how a browser displays your Web page’s text. A 
browser uses the first font in the combination that is installed on the user’s system; 
if none of the fonts in the combination are installed, the browser displays the text 
as specified by the user’s browser preferences.

To modify font combinations:

1 Choose Text > Font > Edit Font List.

2 Select the font combination from the list at the top of the dialog box.

The fonts in the selected combination are listed in the Chosen Fonts list in the 
lower left corner of the dialog box. To its right is a list of all available fonts 
installed on your system.

3 Choose from the following options:

• To add or remove fonts from a font combination, click the << or >> button 
between the Chosen Fonts list and the Available Fonts list.

• To add or remove a font combination, click the Plus (+) and Minus (-) buttons 
at the top of the dialog box.

• To add a font that is not installed on your system, type the font name in 
the text field below the Available Fonts list and click the << button to add 
it to the combination. Adding a font not installed on your system is useful, 
for example, for specifying a Windows-only font when you are authoring 
on a Macintosh.

• To move the font combination up or down in the list, click the arrow buttons 
at the top of the dialog box.
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To add a new combination to the font list:

1 Choose Text > Font > Edit Font List.

2 Select a font from the Available Fonts list and click the << button to move the 
font to the Chosen Fonts list.

3 Repeat step 2 for each subsequent font in the combination.

To add a font that is not installed on your system, type the font name in 
the text field below the Available Fonts list and click the << button to add 
the font to the combination. Adding a font not installed on your system is 
useful, for example, for specifying a Windows-only font when you are 
authoring on a Macintosh.

4 When you have finished selecting specific fonts, select a generic font family 
from the Available Fonts menu and click the << button to move the generic 
font family to the Chosen Fonts list.

Generic font families include cursive, fantasy, monospace, sans-serif, and serif. 
If none of the fonts in the Chosen Fonts list are available on the user’s system, 
the text appears in the default font associated with the generic font family. For 
example, the default monospace font on most systems is Courier.

Using horizontal rules

Horizontal rules (lines) are useful for organizing information. On a page, you can 
visually separate text and objects with one or more rules.

To create a horizontal rule:

1 In the Document window, place the insertion point where you want to insert a 
horizontal rule.

2 Do one of the following:

• Choose Insert > Horizontal Rule.

• Choose Window > Objects to open the Objects panel, and then click the 
Horizontal Rule button in the Common category.

To modify a horizontal rule:

1 In the Document window, select the horizontal rule.

2 Choose Window > Properties to open the Property inspector, and modify the 
properties as desired.
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Using HTML styles to format text 
An HTML style is defined by one or more HTML tags (such as b, i, font, and 
center) that apply formatting to text. The HTML 4.0 specification released by the 
World Wide Web Consortium (W3C) in early 1998 discourages the use of HTML 
formatting tags in favor of CSS style sheets. In practice, however, HTML formatting 
tags—while offering more limited control over appearance than CSS style sheets 
and taking longer to load—are supported by a wider range of browsers than CSS 
style sheets, and are likely to remain part of the Web developer’s arsenal for as long as 
3.0 and earlier browsers make up a measurable proportion of Web traffic.

For specific information on formatting with HTML tags, see one of the 
following topics:

• “Setting and changing fonts and styles” on page 239

• “Changing the text color” on page 240

• “Aligning text” on page 241

HTML tags that define the structure of the document rather than its 
appearance—for example, headings, paragraphs, and lists—are still very much 
part of the HTML specification. In fact, if you are planning to use CSS style 
sheets to define the font characteristics for your page, it’s important to use 
standard heading tags, because they help to preserve the structure of your page in 
browsers that do not support CSS style sheets. (To see an example of how this 
works, try viewing Dreamweaver Help in a 3.0 browser.) See “Using paragraphs 
and headings” on page 240.

Using HTML styles

Use HTML styles to save text and paragraph formatting that you want to use 
elsewhere in your documents. Once you have created an HTML style based on 
one or more HTML tags, you can reapply that formatting to any text in any 
document using the HTML Styles panel. 

Auto Apply New Style

Context menu

Delete Style
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Unlike CSS styles, HTML style formatting only affects text that you apply it to, 
or text that you create using a selected HTML style. If you change the formatting 
of an HTML style you have created, text that was originally formatted with that 
style is not updated. If you want the ability to change formatting, and 
automatically update all instances of that formatting, use CSS styles; see “Using 
CSS style sheets” on page 248.

To display the O’Reilly HTML reference guide included with Dreamweaver, click 
the Reference button found on the toolbar and choose O’Reilly HTML Reference 
from the drop-down menu.

You can use the HTML Styles panel to record the HTML styles you use in your 
site, and then share them with other users, local sites, or remote sites.

To display the HTML Styles panel, do one of the following:

• Choose Window > HTML Styles.

• Click the HTML Styles icon in the Launcher bar or Launcher.

To view an existing HTML style:

1 In the HTML Styles panel, select a style.

Note that Clear Paragraph Style and Clear Selection Style are used on text 
that has a style applied, but they are not styles themselves; they cannot be 
viewed or edited.

2 While in the HTML Styles panel, right-click (Windows) or Control-click 
(Macintosh) and choose Edit from the context menu, or double-click the 
HTML style and choose Edit from the context menu.

3 In the Define HTML Style dialog box, specify the settings for the style.

The Apply To options determine whether the style applies to the selected text 
(Selection) or the current text block (Paragraph). The When Applying options 
determine whether the settings for the style are added to the original text 
formatting (Add to Existing Style), or removed from the existing formatting 
and replaced with the new settings (Clear Existing Style).

To apply an existing HTML style:

In the HTML Styles panel, select a style.

• If the Auto Apply checkbox at the bottom of the panel is selected, click 
the style once.

• If the Auto Apply checkbox is not selected, click the style, then click Apply.
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To clear text formatting in your document:

1 Select the formatted text.

2 In the HTML Styles panel, click Clear Paragraph Style or Clear Selection Style.

Clear Paragraph Style removes any formatting from the current text block 
in the document. Clear Selection Style removes any formatting from the 
selected text.

Note: You can use Clear Paragraph Style and Clear Selection Style to remove any 
formatting (except CSS formatting), regardless of how the original formatting was applied 
(for example, through the HTML Styles panel or the Property inspector).

To remove a style from the HTML Styles panel:

1 In the HTML Styles panel, deselect the checkbox to turn off the Auto Apply option.

2 Select an HTML style.

3 Click the Delete Style (trash can) icon in the lower right corner of the panel.

To create a new HTML style based on existing text:

1 In your document, select or create text that has the formatting you want to use 
as the basis of your new HTML style. You can use the Property inspector to 
view and apply formatting.

2 In the HTML Styles panel, click the New Style icon (plus sign) in the lower 
right corner.

3 In the Define HTML Style dialog box, name the style and adjust the 
formatting, if necessary.

• Select whether to apply the HTML style to selected text or the entire 
paragraph. Note that a paragraph style applies to the entire text block in which 
the insertion point is located, regardless of what text is actually selected.

• Select whether to apply the HTML style in addition to the existing style (CSS 
or HTML) of the selected text or paragraph, or to clear the formatting of the 
selection or paragraph with the new HTML style. Keep in mind the hierarchy 
for applying styles: HTML styles take precedence over CSS styles, which take 
precedence over external CSS styles. See “Using CSS style sheets” on page 248.

Note that the formatting options in the HTML Styles panel match those in the 
Property inspector.

4 Click OK.
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To create a new HTML style based on an existing HTML style:

1 Make sure no text is selected in the Document window.

2 In the HTML Styles panel, select a style, then do one of the following:

• Click the triangle in the upper right corner of the panel to display the drop-
down context menu.

• Right-click (Windows) or Control-click (Macintosh), then choose Duplicate 
from the context menu.

The Define HTML Style dialog box appears. To reset it to the default 
options, click Clear.

3 Complete steps 3 and 4 in the instructions for creating a new style based on 
existing text.

To create a new HTML style from scratch:

1 In the HTML Styles panel, click the New Style icon; you can also choose 
Text > HTML Styles > New Style.

The Define HTML Style dialog box appears.

2 Complete steps 3 and 4 in the instructions for creating a new style based on 
existing text.

Click Clear to reset the dialog box to the default options.

3 Click OK.

To edit an existing HTML style:

1 Make sure no text is selected in the Document window.

2 In the HTML Styles panel, make sure the Auto Apply checkbox is deselected.

If the Auto Apply option is turned on, the HTML style will be applied when 
you select it in the HTML Styles panel.

3 In the HTML Styles panel, right-click (Windows) or Control-click 
(Macintosh) the style, then choose Edit from the context menu.

The Define HTML Style dialog box appears. To reset it to the default 
options, click Clear.

When you edit an HTML style, Dreamweaver does not automatically update 
text that was previously formatted using the HTML style. If you want to 
update formatting applied with a style, use a CSS style sheet; see “Using CSS 
style sheets” on page 248.
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To share your HTML styles with other sites or users:

1 Choose Window > Site Files to open the Site window in Site Files view.

2 In the right pane, open the site root folder, then open the Library folder.

You’ll notice a file called styles.xml. This file contains all your HTML styles for 
the site. You can put, get, check in, check out, and copy this file as you would 
any other file in your site. You can also create Design Notes for the styles.xml 
file. Note that you must first check out the styles.xml file before you can create 
or edit a style for a remote site.

For more information on using these options, see “Setting up a remote site” 
on page 123.

Using CSS style sheets
A style is a group of formatting attributes that control the appearance of a range of 
text in a single document. A CSS (Cascading Style Sheets) style can be used to 
control many documents at once and includes all of the styles for a document. 
The advantage of using a CSS style sheet over an HTML style is that in addition 
to being linked to multiple documents, when a CSS style is updated or changed, 
the formatting of all the documents that use that style sheet are automatically 
updated as well.

For example, imagine managing a very large Web site like Yahoo or 
Macromedia.com. You can make font and formatting changes to the entire site or 
many pages quickly and accurately by using CSS styles. Also, CSS styles let you 
control many properties that cannot be controlled using HTML alone. For 
example, you can assign custom list bullets and specify different font sizes and 
units (pixels, points and so on). By using CSS styles and setting font sizes in pixels, 
you can ensure a more consistent treatment of your page layout and appearance 
with multiple browsers.

CSS styles have been around for sometime, but many Web site designers and creators 
have been reluctant to use them because of inconsistent browser support. However, if 
your audience includes viewers who are using browsers that support CSS styles (4.0 
and later), you should avail yourself of the power and control they offer.

CSS styles are identified by name or by HTML tag, allowing you to change an 
attribute of a style and instantly see the change reflected in all the text to which 
that style applies. CSS styles in HTML documents can control most of the 
traditional text formatting attributes such as font, size, and alignment. CSS styles 
can also specify unique HTML attributes such as positioning, special effects, and 
mouse rollovers. 
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CSS style sheets reside in the head area of a document. CSS styles can define the 
formatting attributes for HTML tags, ranges of text identified by a class 
attribute, or text that meets criteria conforming to the Cascading Style Sheets 
(CSS) specification. Dreamweaver recognizes styles defined in existing documents 
as long as they conform to CSS style guidelines.

CSS style sheets work in 4.0 and later browsers. Internet Explorer 3.0 recognizes 
some CSS style sheets, but most earlier browsers ignore them.

Three types of CSS style sheets are available in Dreamweaver:

• Custom CSS styles are similar to the styles you use in a word processor, except 
that there is no distinction between character and paragraph styles. You can 
apply CSS custom styles to any range or block of text. If the CSS style is 
applied to a block of text (such as an entire paragraph or unordered list), a 
class attribute is added to the block’s tag (for example, p class="myStyle" 
or ul class="myStyle"). If the CSS style is applied to a range of text, span 
tags containing the class attribute are inserted around the selected text. See 
“Applying a custom (class) CSS style” on page 254.

• HTML tag styles redefine the formatting for a particular tag, such as h1. When 
you create or change a CSS style for the h1 tag, all text formatted with the h1 
tag is immediately updated.

Note: Be careful when redefining tags in a linked CSS, as this can change the layout of 
many pages. For example, if you redefine the table tag to look a certain way, it will alter 
the layout of other pages using tables.

• CSS selector styles redefine the formatting for a particular combination of tags 
(for example, td h2 applies whenever an h2 header appears inside a table cell) 
or for all tags that contain a specific id attribute (for example, #myStyle 
applies to all tags that contain the attribute-value pair ID="myStyle").

Manual HTML formatting overrides formatting applied with CSS (or HTML) 
styles. For CSS styles to control the formatting of a paragraph, you must remove 
all manual HTML formatting or HTML styles.

Although you can set an unlimited number of CSS style attributes defined by the 
CSS1 specification in Dreamweaver, not all of the attributes appear in the 
Document window. The attributes that do not appear are marked with an asterisk 
(*) in the Style Definition dialog box. Note also that some of the CSS style 
attributes that you can set with Dreamweaver appear differently in Microsoft 
Internet Explorer 4.0 and Netscape Navigator 4.0, and some are not currently 
supported by any browser.

Note: To display the O’Reilly CSS reference guide included with Dreamweaver, click 
the Reference button found on the toolbar and choose O’Reilly CSS Reference from 
the pop-up menu.
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About CSS style properties

The Cascading Style Sheets specification (CSS1), which is controlled by the 
World Wide Web Consortium, defines the CSS style properties (for example, 
font, color, padding, margin, word spacing) that control the appearance of Web 
page elements. You can set any CSS1 property using Dreamweaver.

In Internet Explorer 4.0 and later, you can use a scripting language such as 
JavaScript or VBScript to change the positioning and CSS style properties of 
elements after the page has loaded. In Netscape Navigator 4.0 and later, you 
cannot change CSS style properties after the page has loaded, but you can change 
positioning properties.

Creating and linking to an external CSS style sheet

A CSS style sheet is an external text file containing styles and formatting 
specifications. When you edit an external CSS style sheet, all documents linked to 
that CSS style sheet are updated to reflect those edits. You can export the CSS 
styles found in a document to create a new CSS style sheet, and attach or link to 
an external style sheet to apply the styles found there.

Dreamweaver Help consists of HTML pages that use a linked CSS style sheet 
called help.css. To see what the code for a CSS style definition looks like, open 
the help.css file (located in the Help/html folder) in a text editor. Open any of 
the topic files (those that begin with a number) to see how the CSS style sheet is 
linked to the document using a link tag, as well as how specific CSS styles 
are applied. You can also copy the help.css file to your local root folder and apply 
its styles to a test page.

To attach an external CSS style sheet:

1 Choose Window > CSS Styles, or click the CSS Styles icon in the Launcher.

2 In the CSS Styles panel, right-click (Windows) or Control-click (Macintosh) 
and choose Attach Style Sheet from the pop-up menu. You can also click the 
Attach Style Sheet icon at the bottom of the CSS Styles panel.

3 In the Select Style Sheet dialog box, enter the file name in the URL field, or 
browse for the file you want.
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4 Select a document or site root-relative path. See “About document locations 
and paths” on page 354.

5 Click Open. The style sheet is attached to your Dreamweaver document and its 
styles appear in the CSS Styles panel.

To link to or create an external CSS style sheet:

1 Choose Window > CSS Styles, or click the CSS Styles icon in the Launcher.

2 In the CSS Styles panel, right-click (Windows) or Control-click (Macintosh) 
and choose Edit Style Sheet from the pull-down menu.

3 In the Edit Style Sheet dialog box, click Link.

4 In the Link External Style Sheet dialog box, do one of the following:

• Click Browse (Windows) or Choose (Macintosh) to browse to an external CSS 
style sheet, or type the path to the style sheet in the File/URL box. (Browsing is 
recommended because it ensures that the correct path to the style sheet is entered.)

• Create a new external CSS style sheet by entering a new file name (one that 
doesn’t already exist at the specified location). The file name must end in the 
.css extension.

5 Select the Link or Import option to specify and create the tag used to attach the 
external CSS style sheet to the document, and then click OK.

Import brings the information in the external CSS style sheet file into the 
current document, while Link accesses and relays the information without 
transferring it.While both Import and Link call all styles in the external CSS 
style sheet into the current document, Link offers more features and works 
in more browsers.

The name of the external CSS style sheet appears with the identifier (link or 
import) in the list of styles in the Edit Style Sheet dialog box. Complete the 
steps below to create or edit the styles defined in the external CSS style sheet.

6 In the Edit Style Sheet dialog box, select the name of the external style sheet 
and click Edit.

The Edit Style Sheet dialog box appears for that style sheet.

7 Click New to define styles in the external CSS style sheet.

8 In the New Style dialog box, define the new style. See “Creating a CSS style in 
Dreamweaver” on page 252.

9 Click Save when you have finished defining styles.
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Editing an external CSS style sheet

When you edit a CSS style sheet that controls the text in your document, you 
instantly reformat all of the text controlled by that CSS style sheet. Your edits 
affect all the documents linked to the style sheet.

To edit an external CSS style sheet:

1 Open any document that is linked to the external CSS style sheet you 
want to change.

2 Do one of the following:

• Choose Window > CSS Styles, or click CSS Styles in the Launcher. In the CSS 
Styles panel, right-click (Windows) or Control-click (Macintosh) and choose 
the Edit Style Sheet from the pull-down menu.

• Choose Text > CSS Styles > Edit Style Sheet.

3 In the Edit Style Sheet dialog box, select the name of the external style sheet 
and click Edit.

A second Edit Style Sheet dialog box displays the styles in the external style 
sheet. Select the style you want to edit.

4 Edit the style. See “Creating a CSS style in Dreamweaver” on page 252.

5 Click Save when you have finished editing styles.

Creating a CSS style in Dreamweaver

Create a CSS style to automate the formatting of HTML tags or a range of text 
identified by a class attribute.

To create a CSS style:

1 Choose Window > CSS Styles and in the CSS Styles panel, right-click 
(Windows) or Control-click (Macintosh) and choose New Style from the pop-
up menu. You can also click the New Style icon found at the bottom of the 
CSS Styles panel.

2 Choose from the following CSS style options:

Make Custom Style (Class) creates a style that can be applied as a class 
attribute to a range or block of text.

Redefine HTML Tag redefines the default formatting of a specified HTML tag. 
Keep in mind that you can alter the layout of many pages when you redefine a tag.

Use CSS Selector defines the formatting for a particular combination of tags 
or for all tags that contain a specific 1d attribute. 
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3 Enter a name, tag, or selector for the new style: 

• Custom style (class) names must begin with a period. If you don’t enter the 
period yourself, Dreamweaver enters it for you. These names can contain any 
combination of letters and numbers, but a letter must follow the period. For 
example, .myhead1.

• To redefine an HTML tag style, enter an HTML tag or choose one from the 
pop-up menu.

• For a CSS selector, enter any valid criteria for a selector (for example, td, or 
#myStyle), or choose a selector from the pop-up menu. The selectors available 
from the menu are a:active, a:hover, a:link, and a:visited. 

4 Select the location in which the style will be defined: New Style Sheet File 
(external) or This Document Only.

5 Click OK. The Style Definition dialog box appears.

6 Choose the formatting settings for the new CSS style. Leave attributes empty if 
they are not important to the style.

Attributes that do not appear in the Document window are marked with an 
asterisk (*) in the Style Definition dialog box. Some of the CSS style attributes 
that you can set with Dreamweaver appear differently in Microsoft Internet 
Explorer 4.0 and Netscape Navigator 4.0, and some are not currently 
supported by any browser.

7 Click OK or Apply.

See the following topics in Dreamweaver Help for information on specific settings:

• Style Definition Type panel

• Style Definition Background panel

• Style Definition Block panel

• Style Definition Box panel

• Style Definition Border panel

• Style Definition List panel

• Style Definition Positioning panel

• Style Definition Extensions panel

When you create a custom (class) style, it appears in the CSS Styles panel and in 
the Text > CSS Styles submenu. HTML tag styles and CSS selector styles do 
not appear in the CSS Styles panel because they cannot be applied; they are 
reflected in the Document window automatically wherever the tag or 
selector occurs.
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Applying a custom (class) CSS style

Custom (class) CSS styles are the only type of CSS style that can be applied to any 
text in a document, regardless of which tags control the text. The CSS Styles panel 
displays the names of all available styles.

Do not confuse CSS styles with options such as Bold or Variable in the Text > 
Style submenu; these options are predefined formatting attributes that correspond 
to specific HTML tags.

When you apply two or more CSS styles to the same text, the styles may conflict 
and produce unexpected results. See “About conflicting styles” on page 255.

To apply a custom CSS style:

1 Choose Window > CSS Styles.

2 Select the text to which you want to apply a CSS style.

Place the insertion point in a paragraph to apply the style to the entire paragraph.

To specify the exact tag to which the CSS style should be applied, select the 
tag with the tag selector at the bottom left of the Document window. You can 
also select the exact tag in the tag selector, right-click (Windows) or Control-
click (Macintosh) to reveal a context menu, and choose Set Class to see a list of 
CSS styles to apply.

If you select a range of text within a single paragraph, the CSS style affects only 
the selected range.

3 Click a style name in the CSS Styles panel.

You can also apply a CSS style by choosing a style name from the Text > CSS 
Styles submenu, or by right-clicking (Windows) or Control-clicking (Macintosh) 
and choosing the style name from the CSS Styles submenu in the context menu. 
The tag of the current selection appears next to the Custom Style command.

Exporting styles to create a CSS style sheet

You can export styles from a document to create a new CSS style sheet. You can 
then link to other documents to apply these styles.

To export CSS styles from a document and create a CSS style sheet:

1 Choose File > Export > Export CSS Styles or choose Text > Export Style Sheet. 
The Export Styles as CSS File dialog box appears. 

2 Enter a name for your style and click Save. The style is saved as a CSS style sheet.
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About conflicting styles

When you apply two or more CSS styles to the same text, the styles may conflict 
and produce unexpected results. Browsers apply style attributes according to the 
following rules:

• If two styles are applied to the same text, the browser displays all attributes of 
both styles unless specific attributes conflict. For example, one style may specify 
blue as the text color and the other style may specify red.

• If attributes from two styles applied to the same text conflict, the browser 
displays the attribute of the innermost style (the style closest to the text itself ).

• If there is a direct conflict, the attributes from CSS styles (styles applied with 
the class attribute) overrule attributes from HTML tag styles.

In the example that follows, the style defined for h1 might specify the font, size, 
and color for all h1 paragraphs, but the custom CSS style .Blue applied to this 
paragraph overrules the color setting in the H1 style. The second custom CSS style 
.Red overrules .Blue because it is inside the .Blue style.

<h1><span class="Blue">This paragraph is controlled by the .Blue 
custom style and h1
HTML tag style.<span class="Red">Except this sentence is 
controlled by the .Red style.</span>
Now we're back to the .Blue style.</span></h1>

Using the CSS Styles panel 

Use the CSS Styles panel to apply custom CSS styles to the current selection. The 
CSS Styles panel displays custom (class) CSS styles only; redefined HTML tags 
and CSS selector styles do not appear in the CSS Styles panel, because they are 
automatically applied to any text controlled by the specified tag or selector. (If you 
want to simply cut and paste reusable but not updatable and customizable styles, 
use the HTML Styles panel.)

Choose Window > CSS Styles to display the CSS Styles panel.

Apply displays the tag of the current selection. Choose a tag from the pop-up 
menu to select a different tag.

New Style opens the New Style dialog box. Create a new style for a particular 
document or create a new external style sheet.

Attach Style Sheet opens the Select Style Sheet File dialog box. Select an external 
style sheet to attach to your current document.

Edit Style Sheet opens the Edit Style Sheet dialog box. Edit any of the styles in the 
current document or in an external style sheet. 

See also “Using CSS style sheets” on page 248.

Note: Right-click (Windows) or Control-click (Macintosh) the CSS Styles panel to open a 
context menu that includes Edit, Duplicate, Delete, Apply New Style, Edit Style Sheet, and 
Attach Style Sheet commands.
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Setting CSS Styles preferences

CSS Styles preferences control how Dreamweaver writes the code that defines CSS 
styles. CSS styles can be written in a shorthand form that some people find easier 
to work with. Some older versions of browsers do not correctly interpret the 
shorthand. Unless you want Dreamweaver to write styles in shorthand, there is no 
reason to change any of the CSS Style preferences.

Choose Edit > Preferences and select CSS Styles to display CSS Styles Sheet 
Format preferences. See also “Using CSS style sheets” on page 248.

Use Shorthand For determines which CSS style attributes Dreamweaver writes 
in shorthand.

When Editing CSS Styles Use Shorthand controls whether Dreamweaver rewrites 
existing styles in shorthand. Choose If Original Used Shorthand to make 
Dreamweaver leave all styles as they are. Choose According to Settings Above to 
make Dreamweaver rewrite styles in shorthand according to the attributes 
specified in the Use Shorthand For checkboxes.

Converting CSS styles to HTML tags
If you have used CSS styles to specify text formatting (such as the family, size, 
color, and decoration of fonts) and later decide that you want to make the 
formatting viewable on a 3.0 browser, you can use the File > Convert > 3.0 
Browser Compatible command to convert as much of the style information as 
possible to HTML tags.

Note: Not all CSS styles can be converted to HTML, because HTML tags do not cover or 
support all the attributes possible in CSS. 

To convert a file that uses CSS styles to a 3.0 browser–compatible file:

1 Choose File > Convert > 3.0 Browser Compatible.

2 In the dialog box that appears, select CSS Styles to HTML Markup.

When you choose the Layers to Tables option, Dreamweaver replaces all layers 
with a single table that preserves the original positioning.

CSS styles are replaced, where possible, with HTML tags such as b and font. 
Any CSS markup that cannot be converted to HTML is removed. See “CSS to 
HTML markup conversion table” on page 257 for information on which styles 
are converted and which are removed.

3 Click OK. Dreamweaver opens the converted file in a new, untitled window.

Note: You must perform this conversion procedure each time you change the original file in 
order to update the 3.0-compatible file. For this reason, it’s best to perform this procedure 
only after you are completely satisfied with your original file.
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CSS to HTML markup conversion table

The CSS attributes listed in the following table are converted to HTML markup 
with the File > Convert > 3.0 Browser Compatible command. (See “Converting 
CSS styles to HTML tags” on page 256.) Attributes not listed in the table 
are removed. 

CSS attribute Converted to

color FONT COLOR

font-family FONT FACE

font-size FONT SIZE="[1-7]"

font-style: oblique I

font-style: italic I

font-weight B

list-style-type: square UL TYPE="square"

list-style-type: circle UL TYPE="circle"

list-style-type: disc UL TYPE="disc"

list-style-type: upper-roman OL TYPE="I"

list-style-type: lower-roman OL TYPE="i"

list-style-type: upper-alpha OL TYPE="A"

list-style-type: lower-alpha OL TYPE="a"

list-style UL or OL with TYPE as 
appropriate

text-align P ALIGN or DIV ALIGN as 
appropriate

text-decoration: underline U

text-decoration: line-through STRIKE
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Checking spelling
Use the Check Spelling command in the Text menu to check the spelling in the 
current document. The Check Spelling command ignores HTML tags and 
attribute values.

By default, the spelling checker uses the U.S. English spelling dictionary. To 
change the dictionary, choose Edit > Preferences > General and select a different 
dictionary from the pop-up menu. Dictionaries for additional languages are 
available for downloading from the Dreamweaver Support Center. 

Running a spell check using the Check Spelling dialog box

Use the following options in the Check Spelling dialog box to check the spelling 
in your document. (To display the dialog box, choose Text > Check Spelling.)

Add to Personal adds the unrecognized word to your personal dictionary. 
To remove words from your personal dictionary, edit the Personal.dat file in 
a text editor. This file can be found in Dreamweaver 4/Configuration/
Dictionaries.

Ignore ignores this instance of the unrecognized word.

Ignore All ignores all instances of the unrecognized word.

Change replaces this instance of the unrecognized word with text that you type in 
the Change To box or with the selection in the Suggestions list.

Change All replaces all instances of the unrecognized word in the same manner.

Searching and replacing text, tags, 
and attributes
You can search the current document, selected files, a directory, or an entire site 
for text, text surrounded by specific tags, or HTML tags and attributes. Note that 
you use different commands to search for files, and to search for text and/or 
HTML 1 tags within files: Locate in Local Site and Locate in Remote Site search 
for files, while Edit > Find and Replace search for text and tags within files.

To search for text and/or HTML within documents:

1 Choose from the following options:

• In Design view, from the Document or Site window, choose Edit > 
Find and Replace. 

• While in Code view, right-click (Windows) or Control-click (Macintosh) 
and choose Find and Replace from the context menu.
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2 In the Find or Replace dialog box that appears, use the Find In option to 
specify which files to search:

• Current Document confines the search to the active document. This option is 
available only when you choose Find or Replace with the Document window 
active, or from the context menu in the Code inspector.

• Entire Local Site expands the search to all the HTML documents, library files, 
and text documents in the current site. After you choose Current Site, the 
name of the current site appears to the right of the pop-up menu. If this is not 
the site you want to search, choose a different site from the current site’s pop-
up menu in the Site window.

• Selected Files in Site confines the search to the files and folders that are 
currently selected in the Site window. This option is available only when you 
choose Find or Replace with the Site window active (that is, in front of the 
Document window).

• Folder confines the search to a specific group of files. After choosing Folder, 
click the folder icon to browse to and select the directory you want to search.

3 Use the Search For option to specify the kind of search you want to perform.

• Source Code lets you search for specific text strings in the HTML source code. 
See “About HTML source code searches” on page 260.

• Text lets you search for specific text strings in the Document window. A text 
search ignores any HTML that interrupts the string. For example, a search for 
the black dog would match both the black dog and the <i>black</i> dog. 

• Text (Advanced) lets you search for specific text strings that are either within or 
not within a tag or tags. For example, in a document that contains the 
following HTML, searching for tries not inside i would find only the second 
instance of the word tries: John <i>tries</i> to get his work done on 
time, but he doesn’t always succeed. He tries very hard. See 
“Searching for text contained in specific tags” on page 262.

• Specific Tag lets you search for specific tags, attributes, and attribute values, 
such as all td tags with valign set to top. See “Searching for HTML tags and 
attributes” on page 260.

Note: Pressing Control+Enter or Shift+Enter (Windows), or Control+Return, 
Shift+Return, or Command+Return (Macintosh), adds line breaks within the text search 
fields, allowing you to search for a Return character. Be sure to deselect the Ignore 
Whitespace Differences option when performing this search, if you’re not using regular 
expressions. Note that this finds a Return character in particular, not simply the 
occurrence of a line break; for instance, it doesn’t find a <br> tag or a <p> tag. 
Return characters appear as spaces in the Design view, not as line breaks.
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4 Use the following options to expand or limit the search:

• The Match Case option limits the search to text that exactly matches the case 
of the text you want to find. For example, if you search for the brown derby, 
you will not find The Brown Derby.

Note: The Ignore Whitespace Differences option, when selected, treats all whitespace as a 
single space for the purposes of matching. For example, with this option selected, this text 
would match this text but not thistext. This option is not available when the Use 
Regular Expressions option is selected; you must explicitly write your regular expression to 
ignore whitespace. Note that <p> and <br> tags do not count as whitespace.

• The Use Regular Expressions option causes certain characters and short strings 
(such as ?, *, \w, and \b) in your search string to be interpreted as regular expression 
operators. For example, a search for the b\w*\b dog will match both the black 
dog and the barking dog. See “About regular expressions” on page 264.

Note: If you are working in Code view and make changes to your document, and try to find 
and replace anything other than source code, a dialog box appears letting you know that 
Dreamweaver is synchronizing the two views before doing the search. For more information 
on synchronizing views, see “Using the Code view (or Code inspector)” on page 330. 

About HTML source code searches

Use the Source Code option in the Find or Replace dialog box to search for 
specific text strings in the HTML source code. For example, a search for black dog 
in the following code would produce two matches (in the alt attribute and in the 
first sentence):

<img src="barnaby.gif" width="100" height="100"
alt="Barnaby, a black dog."><br>
We saw several black dogs in the park yesterday. The black 
<a href="barnaby.html">dog</a> we liked best was called Barnaby.

The phrase black dog also appears in the second sentence, but it does not match 
because it is interrupted by a link.

See “Searching and replacing text, tags, and attributes” on page 258 for step-by-
step instructions on initiating a search.

Searching for HTML tags and attributes

Use the Specific Tag option in the Find or Replace dialog box to search for specific 
tags, attributes, and attribute values. For example, you can search for all img tags 
with no alt attribute. See “Searching and replacing text, tags, and attributes” on 
page 258 for information about the various types of searches. 
Chapter 10260



To perform a tag search:

1 Choose Edit > Find and Replace, and specify which files to search, as detailed 
in “Searching and replacing text, tags, and attributes” on page 258.

2 Choose Specific Tag from the Search For pop-up menu.

3 Choose a specific tag from the pop-up menu next to Search For pop-up menu, 
or choose [any tag].

If you only want to search for all occurrences of the specified tag, press the 
Minus (-) button and skip to step 6. Otherwise, proceed with step 4.

4 Limit the search with one of the following tag modifiers:

• With Attribute chooses an attribute that must be in the tag for it to match. You 
can specify a particular value for the attribute or choose [any value].

• Without Attribute chooses an attribute that cannot be in the tag for it to match. 
For example, choose this option to search for all IMG tags with no ALT attribute.

• Containing specifies text or a tag that must be contained within the original tag 
for it to match. For example, in the code <b><font face="Arial">heading 
1</font></b>, the font tag is contained within the b tag.

• Not Containing specifies text or a tag that cannot be contained within the 
original tag for it to match.

• Inside Tag specifies a tag that the target tag must be inside of for it to match.

• Not Inside Tag specifies a tag that the target tag cannot be inside of for it to match.

5 Click the Plus (+) button and repeat step 4 to further limit the search.

6 Initiate the search:

• Click Find Next to highlight the next instance of the search text in the 
current document.

• Click Find All to generate a list of all the instances of the search text in the 
current document.

• Click Find Next to highlight the next instance of the search text in the current 
document or if there is none, open the next document that contains the search text.

• Click Find All to generate a list of all the instances of the search text in the 
current document or, if you are searching a directory or site, generate a list of 
documents that contain the search text.
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Searching for text contained in specific tags

Use the Text (Advanced) option in the Find or Replace dialog box to search for 
specific text strings that are either within or not within a set of container tags. For 
example, you can search for the word Untitled between <title> tags to find all 
the untitled pages on your site. See “Searching and replacing text, tags, 
and attributes” on page 258 for information about the various types of searches.

To perform an advanced text search:

1 Choose Edit > Find and Replace, and specify which files to search, as detailed 
in “Searching and replacing text, tags, and attributes” on page 258.

2 Choose Text (Advanced) from the Search For pop-up menu.

3 Enter the text you want to search for in the text field adjacent to the Search For 
pop-up menu.

For example, type the word Untitled.

4 Choose Inside Tag or Not Inside Tag, and then choose a tag from the adjacent 
pop-up menu.

For example, choose Inside Tag and then title.

5 Click the Plus (+) button to limit the search to tags with a specific attribute 
or attributes.

Since the <title> tag has no attributes, you won’t need to use this option to 
find all the untitled pages on your site.

6 Click Find Next to open the next document that contains the search text, or 
click Find All to generate a list of documents that contain this text.
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Saving search patterns

You can save search patterns for later use by clicking the Save Query button in the 
Find or Replace dialog box. Saving a query is a good idea if you regularly perform 
the same search and do not want to reconstruct the search pattern every time. For 
example, you might want to strip out nonstandard tags from documents created 
with another visual HTML editor, or to confirm that all images in a file have 
height, width, and alt attributes before the document goes live on the Web.

To save a search pattern:

1 Set the parameters for the search by following the steps outlined in “Searching 
and replacing text, tags, and attributes” on page 258.

If you are performing a tag or advanced text search, see “Searching for HTML 
tags and attributes” on page 260 or “Searching for text contained in specific 
tags” on page 262 for information about setting additional search parameters.

2 Click the Save Query button (identified with a disk icon).

The default location where queries are saved is the Configuration/Queries 
folder inside the Dreamweaver application folder.

3 In the dialog box that appears, give the file a name that identifies the query 
and click Save.

For example, if the search pattern involves looking for img tags with no alt 
attribute, you might name the query img_no_alt.dwr. Find queries end in the 
extension .dwq; Replace queries end in the extension .dwr.

To recall a search pattern:

1 Choose Edit > Find and Replace.

2 Click the Load Query button (identified with a folder icon).

The Load Query dialog box automatically opens in the Configuration/Queries 
folder. You can navigate to another folder if you have saved queries elsewhere.

3 Select a query file and click Open.

If you are in the Find dialog box, only Find queries (.dwq files) are available. If 
you are in the Replace dialog box, both Find queries (.dwq files) and Replace 
queries (.dwr files) are available.

4 Click Find Next, Find All, Replace, or Replace All to initiate the search.
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About regular expressions

Regular expressions are patterns that describe character combinations in text. Use 
them in your searches to help describe concepts such as “sentences that begin with 
‘The’” and “attribute values that contain a number.” The following table lists the 
special characters in regular expressions, their meanings, and usage examples.

To search for text containing one of the special characters in the table, “escape” the 
special character by preceding it with a backslash. For example, to search for the 
actual asterisk in the phrase some conditions apply*, your search pattern 
might look like this: apply\*. If you don’t escape the asterisk, you’ll find all the 
occurrences of “apply” (as well as any of “appl”, “applyy”, and “applyyy”), not just 
the ones followed by an asterisk.

Character Matches Example

^ Beginning of input or line. ^T matches “T” in “This 
good earth” but not in 
“Uncle Tom’s Cabin”

$ End of input or line. h$ matches “h” in “teach” but not in 
“teacher”

* The preceding character 0 or 
more times.

um* matches “um” in “rum”, “umm” 
in “yummy”, and “u” in “huge”

+ The preceding character 1 or 
more times.

um+ matches “um” in “rum” and 
“umm”  in “yummy” but nothing in 
“huge”

? The preceding character at most 
once (that is, indicates that the 
preceding character is optional).

st?on matches “son” in 
“Johnson” and “ston” in 
“Johnston” but nothing in 
“Appleton” or “tension”

. Any single character except 
newline.

.an matches “ran” and “can” in the 
phrase “bran muffins can be tasty”

x|y Either x or y. FF0000|0000FF matches 
“FF0000” in 
bgcolor=”#FF0000” and 
“0000FF’” in font 
color=”#0000FF”

{n} Exactly n occurrences of the 
preceding character.

o{2} matches “oo” in “loom” and 
the first two o’s in “mooooo” but 
nothing in “money”

{n,m} At least n and at most 
m occurrences of the 
preceding character.

F{2,4} matches “FF” in 
“#FF0000” and the first four F’s in 
#FFFFFF
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[abc] Any one of the characters enclosed 
in the brackets. Specify a range of 
characters with a hyphen (for 
example, [a-f] is equivalent to 
[abcdef]). 

[e-g] matches “e” in “bed”, “f” in 
“folly”, and ”g” in “guard”

[^abc] Any character not enclosed in 
the brackets. Specify a range of 
characters with a hyphen (for 
example, [^a-f] is equivalent 
to [^abcdef]).

[^aeiou] initially matches “r” 
in “orange”, “b” in “book”, and “k” 
in “eek!”

\b A word boundary (such as a 
space or carriage return).

\bb matches “b” in “book” but 
nothing in “goober” or “snob”

\B A nonword boundary. \Bb matches “b” in “goober” but 
nothing in “book”

\d Any digit character. 
Equivalent to [0-9].

\d matches “3” in “C3PO” and “2” 
in “apartment 2G”

\D Any nondigit character. Equivalent 
to [^0-9].

\D matches “S” in “900S” and “Q”  
in “Q45”

\f Form feed.

\n Line feed.

\r Carriage return.

\s Any single white-space 
character, including space, 
tab, form feed, or line feed.

\sbook matches ”book” in “blue 
book” but nothing in “notebook”

\S Any single non-white-space 
character.

\Sbook matches “book” in 
“notebook” but nothing in 
“blue book”

\t A tab.

\w Any alphanumeric character, 
including underscore. Equivalent to 
[A-Za-z0-9_].

b\w* matches “barking” in “the 
barking dog” and both “big” and 
“black” in “the big black dog”

Character Matches Example
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Use parentheses to set off groupings within the regular expression to be referred to 
later; use $1, $2, $3, and so on (use ($) in the Find field and use the backslash (\) 
in the Replace field), to refer to the first, second, third, and later parenthetical 
groupings. For example, searching for (\d+)\/(\d+)\/(\d+) and replacing it with $2/
$1/$3 swaps the day and month in a date separated by slashes (to convert between 
American-style dates and European-style dates).

\W Any non-alphanumeric character. 
Equivalent to [^A-Za-z0-9_].

\W matches “&” in “Jake & Mattie” 
and “%” in “100%”

Control+Enter 
or Shift+Enter 
(Windows), or 
Control+ 
Return or 
Shift+Return or 
Command+ 
Return 
(Macintosh)

Return character. Be sure to 
deselect the Ignore Whitespace 
Differences option when searching 
for this, if not using regular 
expressions. Note that this matches 
a particular character, not the 
general notion of a line break; for 
instance, it doesn’t match a <br> 
tag or a <p> tag. Return characters 
appear as spaces in the Document 
window, not as line breaks.

Character Matches Example
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Inserting Images

Three graphic file formats are generally used in Web pages—GIF, JPEG, and 
PNG. Currently, only GIF and JPEG file formats are fully supported by most 
browsers. Microsoft Internet Explorer (4.0 and later) and Netscape Navigator 
(4.04 and later) partially support the display of PNG images. Unless you are 
targeting your site to users with browsers that support the PNG format, use 
GIFs or JPEGs for broader appeal. 

GIF (Graphic Interchange Format) files use a maximum of 256 colors. GIFs are 
best for displaying noncontinuous-tone images or those with large areas of flat 
colors, such as navigation bars, buttons, icons, logos, or other images with 
uniform colors and tones. You can create GIFs with transparent backgrounds; 
interlaced GIFs, which slowly come into focus as an image loads in the browser; or 
animated GIFs, which are a number of GIFs saved as a single file. 

JPEG (Joint Photographic Experts Group) file format is the superior format for 
photographic or continuous-tone images, because JPEG files can contain millions 
of colors. JPEG files tend to be larger than GIF and PNG files. As the quality of a 
JPEG file increases, so does the file size and the file download time. You can often 
strike a good balance between the quality of the image and the file size by 
compressing the JPEG file. 

PNG (Portable Network Group) file format is a patent-free replacement for GIFs 
that includes support for indexed-color, grayscale, and true-color images, and 
alpha channel support for transparency. PNG is the native file format of 
Macromedia Fireworks. PNG files retain all the original layer, vector, color, and 
effects information (such as a drop shadow), and all elements are fully editable at 
all times. Files must have the .png file extension to be recognized as PNG files by 
Macromedia Dreamweaver.

You can insert GIFs, JPEGs, and PNGs in Dreamweaver documents. In addition 
to inserting an image in a page, you can also insert an image in a table, in a form, 
or in a layer. 
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As you add images, you can select and modify them directly in the Document 
window. For example, you can use the Property inspector to add links to an 
image, add a border around an image, set an image’s size, add space around an 
image, and set the alignment. To create interactive graphics, such as rollover 
images, navigation bars, or image maps, use Dreamweaver behaviors.

To set up an efficient production workflow, use the Dreamweaver Preferences 
dialog box to set a preferred image editor (such as Fireworks). Setting an image 
editor lets you launch the editor and edit an image while working in 
Dreamweaver. When using Fireworks as the preferred editor, you can make edits 
in Fireworks and with a single click automatically update the image in the 
Dreamweaver file. For more information, see “Using Dreamweaver and 
Fireworks Together” on page 281.

In addition to inserting images in a page, you can set a page background image; 
see “Defining a background image or page color” on page 153. To overlap images, 
insert them in layers; see “Using Dynamic Layers” on page 407.

Inserting an image
When you insert an image into a Dreamweaver document, Dreamweaver 
automatically generates a reference to the file in the HTML source code. To 
ensure that this reference is correct, the image file must be in the current site. If it 
is not in the current site, Dreamweaver asks whether you want to copy the file to 
the root folder.

To insert an image:

1 Do one of the following:

• Place the insertion point where you want the image to appear in the Document 
window, and then choose Insert > Image or click the Insert Image button on 
the Common category of the Objects panel. 

• Place the insertion point where you want the image to appear in the Document 
window, and then press Control+Alt+I (Windows) or Command+Option+I 
(Macintosh).

• Drag the Insert Image button from the Objects panel to the desired location in 
the Document window.

• Drag an image from the Assets panel to the desired location in the Document 
window; then skip to step 3.

• Drag an image from the Site Window to the desired location in the Document 
window; then skip to step 3.

• Drag an image from the desktop to the desired location in the Document 
window; then skip to step 3. 
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2 In the dialog box that appears, click Browse to choose a file, or type the path 
for the image file.

If you are working in an unsaved document, Dreamweaver generates a 
file:// reference to the image file. When you save the document anywhere in 
the site, Dreamweaver converts the reference to a document-relative path.

3 Set image properties in the Property inspector. 

See “Setting image properties” on page 269.

Setting image properties
To set the following image properties, select an image in the Document window; 
then choose Window > Properties to display the Property inspector. The Property 
inspector initially displays the most commonly used properties. To see all 
properties, click the expander arrow in the lower right corner.

Use the text field below the thumbnail image to set an image so you can refer to 
the image when using a Dreamweaver behavior (such as a Swap Image) or when 
using a scripting language such as JavaScript or VBScript.

W and H reserve space for an image on a page as it loads in a browser. 
Dreamweaver automatically fills these fields with the image’s original size. Default 
and unlabeled values are pixels. You can also specify the following units: pc (picas), 
pt (points), in (inches), mm (millimeters), and cm (centimeters), and 
combinations thereof, such as 2in+5mm; Dreamweaver converts the values to 
pixels in the HTML source code. 

If you set W and H values that do not correspond to the actual width and height 
of the image, your image may not display properly in a browser. (To restore the 
original values, click the field labels.) You can change these values to scale the 
display size of this instance of the image, but this does not reduce download time, 
because the browser downloads all image data before scaling the image. To reduce 
download time and to ensure that all instances of an image appear at the same 
size, use an image-editing application to scale images.

Src specifies the source file for the image. Click the folder icon to browse to the 
source file, or type the path. For information on entering paths, see “Absolute 
paths” on page 354.
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Link specifies a hyperlink for the image. Drag the Point-to-File icon to a file in 
the Site window, click the folder icon to browse to a document on your site, or 
type manually the URL path. 

Align aligns an image and text on the same line. See “Aligning elements” on page 271.

Alt specifies alternative text that appears in place of the image for text-only 
browsers or for browsers that have been set to download images manually. For 
visually impaired users who use speech synthesizers with text-only browsers, the 
text is spoken out loud. In some browsers, this text also appears when the pointer 
is over the image. 

Map Name Field enables you to create client-side image maps. See “Creating 
image maps” on page 273.

V Space and H Space add space, in pixels, along the sides of the image. V Space 
adds space along the top and bottom of an image. H Space adds space along the 
left and right of an image. 

Target specifies the frame or window in which the linked page should load. (This 
option is not available when the image isn’t linked to another file.) The names of 
all the frames in the current document appear in the Target list. You can also 
choose from the following reserved target names:

• _blank loads the linked file into a new, unnamed browser window. 

• _parent loads the linked file into the parent frameset or window of the frame 
that contains the link. If the frame containing the link is not nested, the linked 
file loads into the full browser window.

• _self loads the linked file into the same frame or window as the link. This 
target is the default, so you usually don’t need to specify it.

• _top loads the linked file into the full browser window, thereby removing 
all frames.

Low Src specifies the image that should load before the main image. Many 
designers use a 2-bit (black and white) version of the main image because it loads 
quickly and gives visitors an idea of what they’re waiting to see.

Border sets the width, in pixels, of a border around the image. Enter 0 for 
no border. You can apply a border to both linked and unlinked images. You set 
link color in the Page Properties dialog box.  If you set a border for an image 
which has no links, the border will be the same color as text in the paragraph in 
which the image is inserted. 

Edit launches the image editor you specified in External Editors preferences and 
opens the selected image. When you save your image file and return to 
Dreamweaver, Dreamweaver updates the Document window with the edited 
image. See “Using an external image editor” on page 277.

Reset Size resets the W and H values to the original size of the image. 
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Aligning elements

Use the image Property inspector to set the alignment of an image in relation to 
other elements in the same paragraph or line. HTML does not provide a way to 
wrap text around the contours of an image, as you can with some word processing 
applications. You can align an image to text, another image, a plugin, or other 
elements in the same line. You can also use the alignment buttons (left, right, and 
center) to set the horizontal alignment of an image.   

Browser Default generally specifies a baseline alignment. (The default may differ 
depending on the site visitor’s browser.) 

Baseline and Bottom align the baseline of the text (or other element) to the 
bottom of the selected object. 

Top aligns an image to the top of the tallest item (image or text) in the current line. 

Middle aligns the text baseline with the middle of the selected object. 

TextTop aligns the selected object with the top of the tallest character in the text line. 

Absolute Middle aligns to the absolute middle of the current line. 

Absolute Bottom aligns to the absolute bottom (which includes descenders, as in 
the letter g) with the bottom of the selected object. 

Left places the selected object on the left margin, wrapping text around it to the 
right. If left-aligned text precedes the object on the line, it generally forces left-
aligned objects to wrap to a new line. 

Right places the object on the right margin, wrapping text around the object to 
the left. If right-aligned text precedes the object on the line, it generally forces 
right-aligned objects to wrap to a new line. 
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Resizing images and other elements

You can visually resize elements such as images, plugins, Macromedia Shockwave 
or Flash movies, applets, and ActiveX controls in the Dreamweaver Document 
window. Visual resizing helps you determine how an element affects the layout at 
different dimensions.

Resizing resets the width and height attributes of the element. The W and H 
fields in the Property inspector display the current width and height of the 
element as you resize it. The element’s file size does not change. 

Macromedia Flash movies and other vector-based elements are scalable and do not 
lose quality as you resize them. However, bitmap elements such as GIF, JPEG, and 
PNG images may become pixelated or distorted if you increase or decrease their 
width and height attributes. To maintain the same aspect ratio, hold down the 
Shift key while you resize a bitmap. However, it is recommended that you visually 
resize bitmaps in Dreamweaver only to determine the layout. Once you have 
determined the ideal size for your image, edit the file in an image-editing 
application. Editing the image may also reduce its file size and thus reduce 
download time. 

To resize an element:

1 Select the element (for example, an image or Shockwave movie) in the 
Document window.

Resize handles appear at the bottom and right sides of the element and in the 
bottom right corner. If resize handles don’t appear, either click away from the 
element you want to resize and then reselect it, or click <img> in the tag 
selector to select the element.

2 Resize the element by doing one of the following:

• To adjust the width of the element, drag the selection handle on the right side.

• To adjust the height of the element, drag the bottom selection handle.

• To adjust the width and the height of the element at the same time, drag the 
corner selection handle.

• To preserve the element’s  proportions (its width-to-height ratio) as you adjust 
its dimensions, Shift-drag the corner selection handle.

Elements can be visually resized to a minimum of 8 x 8 pixels. To adjust the width 
and height of an element to a smaller size (for example, 1 x 1 pixel), use the 
Property inspector to enter a numeric value.

To return a resized element to its original dimensions, in the Property inspector, 
delete the values in the W and H fields, or click the Resize Size button. 
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Creating image maps
An image map is an image that has been divided into regions, or “hotspots”; when 
a hotspot is clicked an action occurs, for example a new file opens. Use the image 
Property inspector to graphically create and edit client-side image maps.

Client-side image maps store the hyperlink information in the HTML document, 
not in a separate map file as do server-side image maps. When a site visitor clicks a 
hotspot in the image, the associated URL is sent directly to the server. This makes 
client-side image maps faster than server-side image maps, because the server does 
not need to interpret where the visitor clicked. Client-side image maps are 
supported by Navigator 2.0 and later, NCSA Mosaic 2.1 and 3.0, and all versions 
of Internet Explorer.

Dreamweaver does not alter references to server-side image maps in existing 
documents; you can use both client-side image maps and server-side image maps 
in the same document. However, browsers that support both types of image maps 
give priority to client-side image maps. To include a server-side image map in a 
document, you must write the appropriate HTML code.

To create a client-side image map:

1 Select the image.

2 Click the expander arrow in the lower right corner of the Property inspector to 
see all properties.

3 In the Map Name field, type a unique name for the image map. 

Note: If you are using multiple image maps in the same document, make sure each map 
has a unique name. 

4 To define the image map areas, do one of the following:

• Select the circle tool and drag the pointer over the image to create a 
circular hotspot. 

• Select the rectangle tool and drag the pointer over the image to create a 
rectangular hotspot.

• Select the polygon tool and define an irregularly shaped hotspot by clicking 
once for each corner point. Click the arrow tool to close the shape.

Once the hotspot is created, the hotspot Property inspector appears. (For 
information about the hotspot Property inspector, see “Setting hotspot 
properties” on page 274.) 

5 In the hotspot Property inspector’s Link field, click the folder icon to browse to the 
file you want opened when the hotspot is clicked. Alternatively, type the file name.
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6 To set where the linked file opens, type the name of the window in which the 
file should open in the Target field. Alternatively, choose a frame name from the 
Target pop-up menu. 

7 In the Alt field, type the text you want to appear as alternative text in 
text-only browsers. 

Some browsers display this text as a tooltip when the user pauses the mouse 
pointer over the hotspot.

8 Repeat steps 4 through 7 to define additional hotspots in the image map.

9 When you’re finished mapping the image, click a blank area in the document to 
change the Property inspector. 

Setting hotspot properties

The properties listed below appear in the Property inspector when a hotspot 
is selected.

Map specifies the image map’s name. Create a unique name for each image map 
within a document. 

Link specifies the file or URL to be displayed when the user clicks the hotspot. If 
you are linking to a file from within the same site, enter a path that is relative to 
your document. (File names that begin with file:// are not relative).

Target specifies the frame or window in which the linked page should load. The 
target option isn’t available until the selected hotspot contains a link. 

The names of all the frames in the current document appear in the list. If you 
specify a  frame that doesn’t exist, when the  document  opens in a browser, the 
linked page loads into a new window that has the name you specified. You can 
also choose from the following reserved target names:

• _blank loads the linked file into a new, unnamed browser window. 

• _parent loads the linked file into the parent frameset or window of the frame 
that contains the link. If the frame containing the link is not nested, the linked 
file loads into the full browser window.

• _self loads the linked file into the same frame or window as the link. This 
target is the default, so you usually don’t need to specify it.

• _top loads the linked file into the full browser window, thereby removing 
all frames.

Alt specifies alternative text that appears in place of the image for text-only 
browsers or for browsers that have been set to download images manually. 
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Modifying an image map

You can easily edit the hotspots you create in an image map. You can move a 
hotspot area, resize hotspots, or move a hotspot forward or back in layer. 

You can also copy an image with hotspots from one document to another, or copy 
one or more hotspots from an image and paste them on another image; hotspots 
associated with the image are also copied to the new document. 

To select multiple hotspots in an image map:

1 Use the pointer hotspot tool to select a hotspot.

2 Do one of the following:

• Shift-click the other hotspots you want to select.

• Press Control+A (Windows) or Command+A (Macintosh) to select all of 
the hotspots.

To move a hotspot:

1 Use the pointer hotspot tool to select the hotspot you want to move.

2 Do one of the following:

• Drag the hotspot to a new area.

• Use the Shift + arrow keys to move a hotspot by 10 pixels in the selected direction.

• Use the arrow keys to move a hotspot by 1 pixel in the selected direction.

To resize a hotspot:

1 Use the pointer hotspot tool to select the hotspot you want to resize.

2 Drag a hotspot selector handle to change the size or shape of the hotspot.
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Creating a rollover image

A rollover is an image that changes when the pointer moves across it. A rollover 
actually consists of two images: the primary image (the image displayed when the 
page first loads) and the rollover image (the image that appears when the pointer 
moves over the primary image). Both images in a rollover should be the same size; 
if the images are not the same size, Dreamweaver automatically resizes the second 
image to match the properties of the first image.

Rollover images are automatically set to respond to the MouseOver event. For 
information about setting an image to respond to a different event (for example, a 
mouse click) or about editing a rollover image to display a different image, see 
“Swap Image” on page 467.

A more complex form of rollover image is a navigation bar. To create a navigation 
bar, use the Insert > Interactive Images > Navigation Bar command; see “Inserting 
a navigation bar” on page 372.

To create a rollover:

1 In the Document window, place the insertion point where you want the 
rollover to appear.

2 Insert the rollover by using one of these methods:

• In the Objects panel’s Common category, click the Insert Rollover Image icon.

• In the Objects panel’s Common category, drag the Insert Rollover Image icon 
to the desired location in the Document window.

• Choose Insert > Interactive Images >Rollover Image.

The Insert Rollover Image dialog box appears.

3 In the Image Name field, type a name for the rollover image.

4 In the Original Image field, click Browse and select the image or type the path 
of the image you want displayed when the page loads. 

5 In the Rollover Image field, click Browse and select the image or type the path 
of the image you want displayed when the pointer rolls over the original image.

6 If you want the images preloaded in the browser’s cache so they load faster, 
select the Preload Images option.

7 In the When Clicked Go to URL field, click Browse and select the file, or type 
the path to the file you want to open when a user clicks the rollover image.

Note: If you don’t set a link for the image, Dreamweaver inserts a null link (#) in the 
HTML source code to which the rollover behavior is attached. If you remove the null link, 
the rollover image will no longer work. 

8 Click OK to close the Insert Rollover Image dialog box. 
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To test a rollover:

1 Choose File > Preview in Browser or press F12.

2 In the browser, move the pointer over the original image. 

The display should switch to the rollover image.

Using an external image editor
Dreamweaver makes it easy for you to design your HTML pages and work in an 
image editor to edit your graphics. While in Dreamweaver, you can open a 
selected image in an external image editor; when you return to Dreamweaver after 
saving the image file, any changes you made to the image are visible in the 
Document window.

You can use Macromedia Fireworks as your external image editor. Fireworks 3 and 
Fireworks 4 use Design Notes to track where the original PNG file is stored on 
your local hard disk.

Fireworks 2 doesn’t use Design Notes, but will prompt you to locate the original 
PNG file. Fireworks 1 automatically searches the folder that contains the selected 
file for a PNG file with the same name. For example, if you select an image whose 
source file is images/myPhoto.gif and the images folder also contains a file called 
myPhoto.png, Fireworks opens the PNG file. 

For more information, see “Using Dreamweaver and Fireworks Together” on page 281.

If you set any other image-editing application as the external image editor and 
launch the editor from within Dreamweaver, the application launches and opens 
the selected image (for example, images/myPhoto.gif ). Use the image editor to 
modify the image, save your changes, and then view the updated changed image 
in Dreamweaver.

If you prefer, you can manually open the original file from which the GIF was 
generated (for example, mylogo.png might be the original Fireworks file), make  
changes, and save the changed image. Dreamweaver still updates the image in the 
Document window when you return.

If you don’t see an updated image after returning to the Dreamweaver window, 
select the image and then click the Refresh button in the Property inspector. 
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Setting external image editor preferences

You can use the Dreamweaver preference dialog box to specify which image editor 
to launch to edit images with specific file extensions. For example, you can tell 
Dreamweaver to launch Fireworks when you want to edit a GIF, and to launch a 
different image editor when you want to edit a JPEG. 

You can set more than one external editor for a file extension; then, when you’re ready 
to edit the image, you can use the context menu to choose which editor to launch.
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To set an external image editor for an existing file type:

1 Open the File Types/Editor dialog box by doing one of the following:

• Choose Edit > Preferences and select File Types/Editors.

• Choose Edit > Edit with External Editor and select File Types/Editors.

2 In the Extensions list, select the file extension you want to set an external 
editor for.

3 Click the Add (+) button above the Editors list.

4 In the Select External Editor dialog box, browse to the application you want to 
launch as an editor for this file type. 

5 In the Preferences dialog box, click Make Primary if you want this editor to be 
the primary editor for this file type.

6 If you want to set up an additional editor for this file type, repeat steps 3 and 4.

Dreamweaver automatically uses the primary editor when you choose to edit 
this image type. You can choose the other listed editors from the context menu 
for the image in the Document window.

To add a new file type to the Extensions list:

1 Open the File Types/Editor dialog box by doing one of the following:

• Choose Edit > Preferences and select File Types/Editors.

• Choose Edit > Edit with External Editor and select File Types/Editors.

2 Click the Add (+) button above the Extensions list.

3 Type the file name extension of the type of image you want to edit (for 
example, .JPEG).

4 To set an external editor, click the Add (+) button above the Editors list.

5 In the dialog box that appears, choose the application you want to use to edit 
this image type.

6 Click Make Primary if you want this editor to be the primary editor for 
the image type. 

To change an existing editor preference:

1 In External Editors preferences, click the file extension whose editor you 
want to change.

2 Use the Add (+) or Delete (–) buttons above the Editors list to add or 
remove an editor.

For more information on the other options in External Editors preferences, see 
“Launching an external editor” on page 298.
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Launching an external image editor

You choose Edit > Preferences > File Types/Editor to set an external image editor for 
the image file types you specify. Once you’ve selected an external image editor, you 
can launch it and edit images while you work in your Dreamweaver document.

To launch the external image editor, do one of the following:

•  Double-click the image you want to edit.

• Right-click (Windows) or Control-click (Macintosh) the image you want to 
edit, the choose Edit With from the context menu to select an editor you 
previously defined, or choose Browse and select an editor.

• Select the image you want to edit, and click Edit in the Property inspector.

• Double-click the image file in the Site window to launch the primary image 
editor. If you haven’t specified an image editor, Dreamweaver launches the 
default editor for the file type.

Note: When you open an image from the Site window, the Fireworks integration features 
described above are not in effect; Fireworks does not open the original PNG file. To use 
the Fireworks integration features, open images from within the Document window.

Applying behaviors to images
You can apply any available behavior to an image or image hotspot. When you 
apply a behavior to a hotspot, Dreamweaver inserts the HTML source code into 
the area tag. Three behaviors apply specifically to images: Preload Images, Swap 
Image, and Swap Image Restore.

Preload Images loads images that do not appear on the page right away (such as 
those that will be swapped in with timelines, behaviors, layers, or JavaScript) into 
the browser cache. This prevents delays caused by downloading when it is time for 
the images to appear. See “Preload Images” on page 459.

Swap Image swaps one image for another by changing the SRC attribute of the img 
tag. Use this action to create button rollovers and other image effects (including 
swapping more than one image at a time). See “Swap Image” on page 467.

Swap Image Restore restores the last set of swapped images to their previous 
source files. This action is automatically added whenever you attach the Swap 
Image action to an object by default; you should never need to select it manually. 
See “Swap Image Restore” on page 468.

You can also use behaviors to create more sophisticated navigation systems, such 
as a navigation bar or a jump menu. See “Creating navigation bars” on page 371 
and “Creating jump menus” on page 369.
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Fireworks Together

Unique integration features make it easy to work on files interchangeably in 
Macromedia Dreamweaver 4 and Macromedia Fireworks 4. Dreamweaver and 
Fireworks recognize and share many of the same file edits, including changes to 
links, image maps, table slices, and more. Together, the two applications provide 
a streamlined workflow for editing, optimizing, and placing Web graphics files 
in HTML pages.

If you want to modify Fireworks images and tables placed in a Dreamweaver 
document, you can launch Fireworks to make edits, and then return to the 
updated document in Dreamweaver. If you want to make quick optimization edits 
to placed Fireworks images and animations, you can launch the Fireworks 
optimization dialog box and enter updated settings. In either case, updates are 
made to the placed files in Dreamweaver, as well as to the source Fireworks files, if 
those source files were launched.
281



Getting Fireworks files into Dreamweaver
You can place Fireworks images and HTML code in Dreamweaver in a number of 
different ways. In Dreamweaver, you can use the insert features to place Fireworks 
files into documents. From Fireworks, you can export files directly to a 
Dreamweaver site folder, or you can copy and paste HTML code into a 
Dreamweaver document. 

Placing Fireworks images in Dreamweaver

You can place Fireworks-generated GIF, JPEG, or PNG images directly in a 
Dreamweaver document.

To insert a Fireworks image into a Dreamweaver document:

1 Place the insertion point where you want the image to appear in the 
Dreamweaver Document window. 

2 Do one of the following:

• Choose Insert > Image.

• Click the Insert Image button in the Common category of the Objects panel. 

3 Navigate to the desired Fireworks file, and click Open.

If the Fireworks file is not in the current Dreamweaver site, a message appears, 
asking whether you want to copy the file to the root folder.

Inserting Fireworks HTML code into Dreamweaver

Dreamweaver lets you insert Fireworks-generated HTML code, complete with 
associated images, slices, and JavaScript, into a document. This insertion feature 
makes it easy for you to add tables or image maps created in Fireworks to a 
Dreamweaver document.

To insert Fireworks HTML into a Dreamweaver document:

1 In Dreamweaver, save your document in a defined site. 

2 Place the insertion point in the document where you want the inserted HTML 
code to begin.

3 Do one of the following:

• Choose Insert > Interactive Images > Fireworks HTML.

• Click the Insert Fireworks HTML button in the Common category of the 
Objects panel.

4 In the dialog box that appears, click Browse to choose the desired Fireworks 
HTML file.
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5 Select the Delete File After Insertion option to move the HTML file to the 
Recycle Bin (Windows) or Trash (Macintosh) when the operation is complete. 

Use this option if you no longer need the Fireworks HTML file after inserting it. 
This option does not affect the source PNG file associated with the HTML file.

Note: If the HTML file is on a network drive, it is permanently deleted, not moved to the 
Recycle Bin or Trash.

6 Click OK to insert the HTML code, along with its associated images, slices, 
and JavaScript, into the Dreamweaver document.

Copying and pasting Fireworks HTML into Dreamweaver

A fast way to place Fireworks-generated images and tables in Dreamweaver involves 
copying and pasting Fireworks HTML code directly into a Dreamweaver document.

To copy and paste Fireworks HTML into Dreamweaver:

1 In Fireworks, choose Edit > Copy HTML Code. 

2 Follow the wizard as it guides you through the settings for exporting your 
HTML and images. When prompted, specify your Dreamweaver site folder as 
the destination for the exported images.

The wizard exports the images to the specified destination and copies the 
HTML code to the Clipboard.

3 In Dreamweaver, place the insertion point in the document where you want to 
paste the HTML code, and choose Edit > Paste.

All HTML and JavaScript code associated with the Fireworks files you exported 
is copied into the Dreamweaver document, and all links to images are updated.

To export and paste Fireworks HTML into Dreamweaver:

1 In Fireworks, choose File > Export.

2 In the Export dialog box, specify your Dreamweaver site folder as the 
destination for the exported images.

3 Choose HTML and Images from the Save As pop-up menu.

4 Choose Copy to Clipboard from the HTML pop-up menu, and click Save.

5 In Dreamweaver, place the insertion point in the document where you want to 
paste the HTML code, and choose Edit > Paste.

All HTML and JavaScript code associated with the Fireworks files you exported 
is copied into the Dreamweaver document, and all links to images are updated.
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Exporting Fireworks files to Dreamweaver

The File > Export command in Fireworks lets you export and save optimized 
images and HTML files to a location inside the desired Dreamweaver site folder. 
You can then open the files for editing in Dreamweaver.

Alternatively, you can export Fireworks files as Cascading Style Sheet (CSS) layers 
or Dreamweaver library items. Dreamweaver library items simplify the process of 
editing and updating a frequently used Web site component, such as a series of 
footer links or a navigation bar. A library item is a portion of an HTML file 
located in a folder named Library at your site root. You can drag copies of a library 
item to any page in your Web site. 

To export Fireworks images and HTML to Dreamweaver:

1 In Fireworks, choose File > Export.

2 Choose HTML and Images from the Save As pop-up menu.

3 Choose Export HTML File from the HTML pop-up menu.

4 Specify a destination folder inside your Dreamweaver site folder.

5 Click Save to export your files.

To export Fireworks files as CSS layers:

1 In Fireworks, choose File > Export.

2 Choose CSS Layers (.htm) from the Save As pop-up menu.

3 Specify a destination folder inside your Dreamweaver site folder.

4 Click Save to export your files.
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To export a Fireworks file as a Dreamweaver library item:

1 In Fireworks, choose File > Export.

2 Choose Dreamweaver Library (.lbi) from the Save As pop-up menu. 

3 Name the file, and specify a destination folder named Library located at the 
Dreamweaver site root.

If necessary, Fireworks prompts you to create this folder.

4 Click Save to export your file.

Launching Fireworks from within 
Dreamweaver
You can launch Fireworks directly from a Dreamweaver document by targeting a 
placed Fireworks image, table slice, or table for either editing or optimization. In 
order for these launch-and-edit features to work properly, you must designate 
Fireworks as the primary external image editor in Dreamweaver.
Using Dreamweaver and Fireworks Together 285



Designating Fireworks as the primary external image editor 
for Dreamweaver

Dreamweaver 4 provides preferences for automatically launching specific 
applications to edit specific file types. To use the Fireworks launch-and-edit 
features, make sure that Fireworks 4 is set as the primary editor for GIF, JPEG, 
and PNG files in Dreamweaver. 

Although you can use earlier versions of Fireworks as external image editors, 
these versions offer limited launch-and-edit capabilities. Fireworks 3 does not 
fully support the launch and edit of placed tables and slices within tables, 
while Fireworks 2 does not support the launch and edit of source PNG files for 
placed images.

To set Fireworks 4 as the primary external image editor for Dreamweaver 4:

1 In Dreamweaver, choose Edit > Preferences and select File Types/Editors. 

2 In the Extensions list, select a Web file extension (.gif, .jpg, or .png).

3 In the Editors list, select Fireworks 4 and click Make Primary.

4 Repeat steps 2 and 3 to set Fireworks 4 as the primary editor for other Web 
file extensions.
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About Design Notes and source files

Whenever you export a Fireworks file from a saved PNG source to a Dreamweaver 
site, Fireworks writes a Design Note that contains information about the file. For 
example, when you export a Fireworks table, Fireworks writes a Design Note for 
each exported slice file and for the HTML file that assembles the table slices. 
These Design Notes contain references to the source PNG file that spawned the 
exported files.

When you launch and edit a Fireworks image from within Dreamweaver, 
Dreamweaver uses the Design Note to locate a source PNG for that file. For best 
results, always save your Fireworks source PNG file and exported files in a 
Dreamweaver site. This ensures that any user sharing the site will be able to locate 
the source PNG when launching Fireworks from within Dreamweaver.

Specifying launch-and-edit preferences for 
Fireworks source files

The Fireworks launch-and-edit preferences let you specify how to handle source 
PNG files when launching Fireworks files from another application, such as 
Macromedia Director or Dreamweaver.

Dreamweaver recognizes the Fireworks launch-and-edit preferences only in 
certain cases where you launch and optimize a Fireworks image. Specifically, you 
must be launching and optimizing an image that is not part of a Fireworks table 
and that does not contain a correct Design-Note path to a source PNG file. In all 
other cases, including all launch-and-edit cases of Fireworks images, Dreamweaver 
automatically launches the source PNG file, prompting you to locate the source 
file if it cannot be found.

To specify launch-and-edit preferences for Fireworks:

1 In Fireworks, choose Edit > Preferences, and click the Launch and Edit tab 
(Windows) or choose Launch and Edit from the pop-up menu (Macintosh).

2 Specify the preference options to use when editing or optimizing Fireworks 
images placed in an external application:

Always Use Source PNG automatically launches the Fireworks PNG file that is 
defined in the Design Note as the source for the placed image. Updates are 
made to both the source PNG and its corresponding placed image.

Never Use Source PNG automatically launches the placed Fireworks image, 
whether or not a source PNG file exists. Updates are made to the placed 
image only.

Ask When Launching lets you specify each time whether or not to launch the 
source PNG file. When you edit or optimize a placed image, Fireworks displays 
a message prompting you to make a launch-and-edit decision. You can also 
specify global launch-and-edit preferences from this message. 
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Editing Fireworks files placed in 
Dreamweaver
Launch-and-edit integration lets you use Fireworks to edit Fireworks-generated 
images and tables placed in a Dreamweaver document. Dreamweaver 
automatically launches Fireworks, letting you make the desired Fireworks edits to 
the image. The updates you make in Fireworks are automatically applied to the 
placed image in Dreamweaver.

Fireworks recognizes and preserves many edits made to the document in 
Dreamweaver, including changed links, edited image maps, and edited text in text 
slices. The Property inspector in Dreamweaver helps you identify Fireworks-
generated images, table slices, and tables in a document.

Editing Fireworks images

You can launch Fireworks to edit individual images placed in a Dreamweaver 
document. 

To launch and edit a Fireworks image placed in Dreamweaver:

1 In Dreamweaver, choose Window > Properties to open the Property 
inspector if needed.

2 Do one of the following:

• Select the desired image. (The Property inspector identifies the selection as a 
Fireworks image and displays the name of the known PNG source file for the 
image.) Then click Edit in the Property inspector.

• Hold down Control (Windows) or Command (Macintosh), and double-click 
the image you want to edit.

• Right-click (Windows) or Control-click (Macintosh) the desired image, and 
choose Edit With Fireworks 4 from the context menu.

Dreamweaver launches Fireworks, if it is not already open. 
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3 If prompted, specify whether to launch a source Fireworks file for the placed image.

4 In Fireworks, edit the image. The document window indicates that you are 
modifying an image from Dreamweaver.

Dreamweaver recognizes and preserves all edits applied to the image in Fireworks.

5 When you are finished making edits, click Done in the document window. 

Clicking Done exports the image using the current optimization settings for 
the source PNG file, updates the GIF or JPEG used by Dreamweaver, and saves 
the PNG source file if a source file was selected.

Note: When you open an image from the Dreamweaver Site window, the Fireworks 
integration features described above are not in effect; Fireworks does not open the 
original PNG file. To use the Fireworks integration features, open images from within the 
Dreamweaver Document window. 

Editing Fireworks tables

When you launch and edit an image slice that is part of a placed Fireworks table, 
Dreamweaver automatically launches the source PNG file for the entire table.

To launch and edit a Fireworks table placed in Dreamweaver:

1 In Dreamweaver, choose Window > Properties to open the Property 
inspector if needed. 

2 Do one of the following:

• Click inside the table, and click the TABLE tag in the status bar to select the 
entire table. (The Property inspector identifies the selection as a Fireworks table 
and displays the name of the known PNG source file for the table.) Then click 
Edit in the Property inspector.

• Click the top left corner of the table to select it, and then click Edit in the 
Property inspector.

• Select the desired table slice, and click Edit in the Property inspector.

• Hold down Control (Windows) or Command (Macintosh), and double-click 
the image you want to edit.

• Right-click (Windows) or Control-click (Macintosh) the desired table slice, 
and choose Edit With Fireworks 4 from the context menu.

Dreamweaver launches Fireworks, if it is not already open. The source PNG file 
for the entire table appears in the document window.

3 In Fireworks, edit the table image. 

Dreamweaver recognizes and preserves all edits applied to the image 
in Fireworks.
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4 When you are finished making edits, click Done in the document window.

Clicking Done exports HTML and image slice files for the table using the 
current optimization settings, updates the table placed in Dreamweaver, and 
saves the PNG source file. Fireworks exports and replaces only those HTML 
and image slice files that are needed to update the table in Dreamweaver.

Optimizing Fireworks images and 
animations placed in Dreamweaver
You can launch Fireworks from Dreamweaver to make quick export changes, such 
as resampling or changing the file type, to placed Fireworks images and 
animations. Fireworks lets you make changes to optimization settings, animation 
settings, and the size and area of the exported image.

To change optimization settings for a Fireworks image placed in Dreamweaver:

1 In Dreamweaver, select the desired image and choose Commands > Optimize 
Image in Fireworks. 

2 If prompted, specify whether to launch a source Fireworks file for the placed image.

3 In Fireworks, make the desired edits in the optimization dialog box:

• To edit optimization settings, click the Options tab. For more information, 
see Using Fireworks. 

• To edit the size and area of the exported image, click the File tab. For more 
information, see “Resizing placed Fireworks images” on page 291.

• To edit animation settings for the image, click the Animation tab. For more 
information, see “Editing placed Fireworks animations” on page 292.
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4 When you are finished editing the image, click Update. 

Clicking Update exports the image using the new optimization settings, 
updates the GIF or JPEG placed in Dreamweaver, and saves the PNG source 
file if a source file was selected. 

If you changed the format of the image, the Dreamweaver link checker 
prompts you to update references to the image. For example, if you changed 
the format of an image called my_image from GIF to JPEG, clicking OK 
at this prompt changes all references to my_image.gif in your site to 
my_image.jpg.

Resizing placed Fireworks images

When launching and optimizing a Fireworks image from Dreamweaver, you can 
resize the image and select a specific image area to be exported.

To specify exported image dimensions:

1 In Fireworks, in the optimization dialog box, click the File tab. 

2 To scale the image as it is exported, specify a scale percentage or enter the 
desired width and height in pixels. Select Constrain to scale the width and 
height proportionally.

3 To export a selected area of the image, select the Export Area option and specify 
the export area:

• Drag the dotted border that appears around the preview until it encloses the 
desired export area. (Drag inside the preview to move hidden areas into view.)

• Enter pixel coordinates for the boundaries of the export area.
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Editing placed Fireworks animations

If you are launching and optimizing a placed Fireworks animation, you can also 
edit the animation settings. The animation options in the optimization dialog box 
are similar to those available in the Fireworks Frames panel. 

To edit an animated image:

1 In Fireworks, in the optimization dialog box, click the Animation tab. 

2 Use the following techniques to preview animation frames at any time:

• To display a single frame, select the desired frame in the list on the left side of the 
dialog box, or use the frame controls in the lower right area of the dialog box.

• To play the animation, click the Play/Stop control in the lower right area of 
the dialog box.

3 Make edits to the animation:

• To specify the frame disposal method, select the desired frame in the list and 
choose an option from the pop-up menu (indicated by the trash icon).

• To set the frame delay, select the desired frame in the list and enter the delay 
time in hundredths of a second. 

• To set the animation to play repeatedly, click the Looping button and choose 
the desired number of repetitions from the pop-up menu.

• Select the Auto-Crop option to crop each frame as a rectangular area, so that 
only the image area that differs between frames is output. Selecting this option 
reduces file size.

• Select the Auto-Difference option to output only pixels that change between 
frames. Selecting this option reduces file size.
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Updating Fireworks HTML placed in 
Dreamweaver
The File > Update HTML command in Fireworks provides an alternative to the 
launch-and-edit technique for updating Fireworks files placed in Dreamweaver. 
With Update HTML, you can edit a source PNG image in Fireworks and then 
automatically update any exported HTML code and image files placed in a 
Dreamweaver document. This command lets you update Dreamweaver files even 
when Dreamweaver is not running.

To update Fireworks HTML placed in Dreamweaver:

1 In Fireworks, choose File > Update HTML. 

2 Navigate to the Dreamweaver file containing the HTML you wish to update, 
and click Open.

3 Navigate to the folder destination where you want to place the updated image 
files, and click Choose.

Fireworks updates the HTML and JavaScript code in the Dreamweaver 
document. Fireworks also exports updated images associated with the HTML 
and places the images in the specified destination folder.

If Fireworks cannot find matching HTML code to update, it gives you the 
option of inserting new HTML code into the Dreamweaver document. 
Fireworks places the JavaScript section of the new code at the beginning of the 
document and places the HTML table or link to the image at the end.

Creating Web photo albums
The Create Web Photo Album command in Dreamweaver lets you automatically 
generate a Web site that showcases an album of images from a given folder. This 
command uses JavaScript to call Fireworks, which creates a thumbnail and a 
larger-sized image for each of the images in the folder. Dreamweaver then creates a 
Web page containing all the thumbnails, as well as links to the larger images. To 
use the Create Web Photo Album, you must have both Dreamweaver and 
Fireworks installed on your system.

Before you begin, place all of the images for your photo album in a single folder. 
(The folder is not required to be in a site.) In addition, make sure that the image 
file names end in extensions recognized by the Create Web Photo Album 
command (.gif, .jpg, .jpeg, .png, .psd, .tif, or .tiff ). Images with unrecognized file 
extensions are not included in the photo album.
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To create a Web photo album:

1 In Dreamweaver, choose Commands > Create Web Photo Album.

2 In the Photo Album Title text field, enter a title. The title will be displayed in a 
gray rectangle at the top of the page containing the thumbnails.

If desired, you may enter up to two lines of additional text to appear directly 
beneath the title, in the Subheading Info and Other Info text fields.

3 Choose the folder containing source images by clicking the Browse button next 
to the Source Images Folder text field. Then choose (or create) a destination 
folder in which to place all the exported images and HTML files by clicking the 
Browse button next to the Destination Folder text field.

The destination folder should not already contain a photo album; if it does, 
and if any new images have the same names as previously used images, you may 
overwrite existing thumbnail and image files.

4 Specify display options for the thumbnail images:

• Choose a size for the thumbnail images from the Thumbnail Size pop-up 
menu. Images are scaled proportionally to create thumbnails that fit within a 
square that has the indicated pixel dimensions.

• To display the file name of each original image below the corresponding 
thumbnail, select Show Filenames.

• Enter the number of columns for the table that displays the thumbnails.

5 Choose a format for the thumbnail images from the Thumbnail Format 
pop-up menu:

GIF WebSnap 128 creates GIF thumbnails that use a Web adaptive palette of 
up to 128 colors.

GIF WebSnap 256 creates GIF thumbnails that use a Web adaptive palette of 
up to 256 colors.

JPEG - Better Quality creates JPEG thumbnails with relatively higher quality 
and larger file sizes.

JPEG - Smaller File creates JPEG thumbnails with relatively lower quality and 
smaller file sizes.

6 Choose a format for the large-size images from the Photo Format pop-up 
menu. A large-size image of the specified format is created for each of your 
original images. You may specify a format for the large-size images that differs 
from the format you specified for the thumbnails.

Note: The Create Web Photo Album command does not let you use your original 
image files as the large-size images, because original image formats other than GIF and 
JPEG might not display properly on all browsers. Note that if your original images are 
JPEG files, the large-size images generated may have larger file sizes or lower quality 
than the original files.
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7 Choose a Scale percentage for the large-size images.

Setting Scale to 100% creates large-size images the same size as the originals. 
Note that the scale percentage is applied to all of the images; if your original 
images aren’t all the same size, scaling them by the same percentage may not 
produce the desired results.

8 Select Create Navigation Page for Each Photo to create an individual Web page for 
each source image, containing navigation links labeled Back, Home, and Next. 

If you select this option, the thumbnails link to the navigation pages. If you 
don’t select this option, the thumbnails link directly to the large-size images. 

9 Click OK to create the HTML and image files for the Web photo album.

Fireworks launches (if it’s not already running) and creates the thumbnails and 
large-size images. This may take several minutes if you’ve included a large 
number of image files. When the processing is complete, Dreamweaver 
becomes active again, and creates the page containing the thumbnails.

10 When a dialog appears that says “Album Created,” click OK. You may have to 
wait a few seconds for your photo album page to appear. The thumbnails are 
shown in alphabetical order by file name.

Note: Clicking the Cancel button in the Dreamweaver dialog box after processing has 
begun does not stop the process of creating the photo album; it merely prevents 
Dreamweaver from displaying the main photo album page. 
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Inserting Media

Macromedia Dreamweaver lets you add sound and movies to your Web site 
quickly and easily. You can incorporate and edit multimedia files and objects, such 
as Java applets; QuickTime, Flash, and Shockwave movies; and MP3 audio files. 
You can also attach Design Notes to these objects. And now you can insert Flash 
button and text objects from within Dreamweaver itself.

Inserting media objects
You can insert a Java applet, QuickTime or Shockwave movie, Flash movie or 
object, ActiveX control, or other audio or video objects in a page.

To insert a media object in a page, do one of the following:

• Place the insertion point where you want to insert the object, and click the 
appropriate button on the Objects panel. 

Shockwave, ActiveX and Flash objects have defined buttons. Use the Netscape 
Navigator plugin button to insert QuickTime movies and audio files. For more 
information, see “Inserting Netscape Navigator plugin content” on page 313.

• Drag the appropriate button from the Objects panel to the place you want the 
object to appear in the Document window.

• Place the insertion point in the Document window where you want to insert the 
object, then choose the appropriate object from the Insert > Media or Insert > 
Interactive Images submenu.
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In most cases, a dialog box appears letting you select a source file and specify 
certain parameters for the media object.

Tip: To prevent such dialog boxes from appearing, choose Edit > Preferences > General and 
deselect the Show Dialog When Inserting Objects option. To override whatever preference 
is set for showing dialog boxes, hold down the Control (Windows) or Option (Macintosh) 
key while inserting the object. (For example, to insert a placeholder for a Shockwave movie 
without specifying the file, hold down Control or Option and click the Shockwave button.) 

Each Objects panel button inserts the necessary HTML source code to make the 
object or placeholder appear on the page. To specify a source file, set dimensions 
and other parameters and attributes, use the Property inspector for each object.

Launching an external editor
You can double-click most files in the Site window to edit them directly. If the file is 
an HTML file, it opens in Dreamweaver. If it’s another kind of file, such as an image 
file, it opens in an appropriate external editor, such as Macromedia Fireworks. 

Each file type that Dreamweaver doesn’t handle directly can be associated with 
one or more external editors found on your system. The editor that launches when 
you double-click the file in the Site window is called the primary editor. You can 
set which editor is associated with a file type in File Types/Editors preferences.

If more than one editor is associated with the file type, you can launch a secondary 
editor for a particular file: right-click (Windows) or Control-click (Macintosh) the 
file name in the Site window, and choose an editor from the Open With submenu 
of the context menu.

Most of the time, the primary editor is the same application that would be 
launched if you double-clicked the file’s icon on the desktop. To explicitly specify 
which external editors should be launched for a given file type, choose Edit > 
Preferences and select File Types/Editors from the Category list. File name 
extensions, such as .gif, .wav, and .mpg, are listed on the left under Extensions. 
Associated editors for a selected extension are listed on the right under Editors.

You can also browse to find an external editor to edit your file. Right-click 
(Windows) or Control-click (Macintosh) the file in the Design view of the 
Document window, and choose Edit With > Browse or select the file and choose > 
Edit > Edit with External Editor.
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To add a file type to the list of extensions in File Types/Editors preferences:

1 Click the Plus (+) button above the Extensions list.

2 Enter a file type extension (including the period at the beginning of the 
extension), or several related extensions separated by spaces. 

For example, you might enter .png .jpg.

To add an editor for a given file type:

1 Select the file type extension in the Extensions list.

2 Click the Plus (+) button above the Editors list.

3 In the dialog box that appears, choose an application to add to the Editors list. 

For example, choose the application icon for Excel to add that application to 
your Editors list.

To remove a file type from the list:

1 Select the file type in the Extensions list.

Note: You can’t undo after removing a file type, so be sure you want to remove it.

2 Click the Minus (-) button above the Extensions list.

To make an editor the primary editor for a file type:

1 Select the file type.

2 Select the editor (or add it if it isn’t on the list).

3 Click the Make Primary button.

To dissociate one editor from a file type:

1 Select the file type in the Extensions list.

2 Select the editor in the Editors list.

3 Click the Minus (-) button above the Editors list.
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Using Design Notes with media objects
As with other objects in Dreamweaver, you can add Design Notes to a 
media object.

To add Design Notes to a media object:

1 Right-click (Windows) or Control-click (Macintosh) the object in the 
Document window.

Note: You must define your site before adding Design Notes to any object. See “About 
Design Notes” on page 134.

2 Choose Design Notes from the context menu.

3 Enter the information you want in the Design Note.

You can also add a Design Note to a media object from the Site window by 
selecting the file, revealing the context menu, and choosing Design Notes from 
the context menu.

For details, see “About Design Notes” on page 134.

About Flash content
Macromedia Flash technology is the premier solution for the delivery of vector-
based graphics and animations. Flash Player is available as both a Netscape 
Navigator plugin and an ActiveX control for Microsoft Internet Explorer on the 
PC, and it is incorporated in the latest versions of Netscape Navigator, Microsoft 
Windows, and America Online. Before you use the Flash commands available in 
Dreamweaver, you may want to review the three different Flash file types.

The Flash file (.fla) is the source file for any project and is created in the Flash 
program. This type of file can only be opened in Flash, not in Dreamweaver or in 
browsers. You can open the Flash file in Flash, then export it as an SWF or SWT 
file to use in browsers. For more information, see “Using Flash button objects” on 
page 301 and “Creating new button templates” on page 306.

The Flash movie file (.swf) is a compressed version of the Flash (.fla) file, optimized 
for viewing on the Web. This file can be played back in browsers and previewed in 
Dreamweaver, but cannot be edited in Flash. This is the type of file you create 
when using the Flash button and text objects. For more information, see “Using 
Flash button objects” on page 301 and “Using Flash text objects” on page 304.

The Flash Generator template (.swt) files enable you to modify and replace 
information in a Flash movie file. These files are used in the Flash button object, 
which lets you modify the template with your own text or links, to create a custom 
SWF to insert in your document. In Dreamweaver, these template files can be 
found in the Dreamweaver/Configuration/Flash Objects/Flash Buttons and 
Flash Text folders.
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If you use Flash to design your own Generator template files (see “Creating new 
button templates” on page 306), you can distribute these templates to members of 
your Web design team. They in turn can save these files to the Configuration/
Flash Objects/Flash Buttons folder, then access these templates using the 
Flash button object.

Using Flash button objects
The Flash button object lets you customize and insert a set of predesigned 
Flash buttons.

Note: You must save your document before inserting a Flash button or text object.
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To insert a Flash button object:

1 While in the Design view of the Document window, select Insert Flash Button 
from the Objects panel or choose Insert > Interactive Images > Flash Button. 
You can also drag the Flash button icon over to the Document window.

The Insert Flash Button dialog box appears.

2 Select the button style you want from the Style list.

You’ll see an example of the button in the Sample field. You can click this 
sample to see how it functions in the browser. However, the Sample field does 
automatically update to show the changes to text or font that you might make. 
These changes will appear in Design view.

3 In the Button Text field (optional), type the text you want to appear.

For example, type Press me! This field only accepts changes if the selected 
button has a {Button Text} parameter defined. This is shown in the Sample 
field. The text you type in replaces the {Button Text} when you preview the file.

4 In the Font field, specify a font size and select the font you want from the 
pop-up menu. 

You only need to make font and size selections if your button has text 
parameters defined. If the default font for a button is not available on your 
system, select another font from the pop-up menu. Keep in mind that you will 
not see the font you selected in the Sample field, but you can click Apply to 
insert the button in the page to see a what the text will look like.

5 In the Link field (optional), enter a document-relative or absolute link for 
the button. 

Site-relative links are not accepted because browsers don’t recognize them 
within Flash movies. If you use a document-relative link, be sure to save the 
SWF file to the same directory as the HTML file. (Browsers vary in their 
interpretation of document-relative links and saving to the same directory 
ensures that the links will work correctly.)

6 In the Target field (optional), specify a target frame or target window for the 
Flash button’s link to go to.

7 In the Bg Color field (optional), set the background color for the Flash movie. 
Use the color picker or type in a Web hexadecimal value (such as #FFFFFF).

8 In the Save As field, enter a file name to save the new SWF file. 

You can use the default file name (for example, button1.swf ), or type in a 
new name. If the file contains a document-relative link, you must save the 
file to the same directory as the current HTML document to maintain 
document-relative links.
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9 Click Get More Styles to go the Macromedia Exchange site and download 
more button styles. 

For more information, see “Adding extensions to Dreamweaver” on page 93.

10 Click Apply or OK to insert the Flash button in the Document window.

Tip: Select Apply to see changes in Design view, while keeping the dialog box open—this 
way you can continue making changes to the button.

To modify a Flash button object:

1 While in Design view, select the Flash button object.

2 The Property inspector displays the Flash button properties. You can make 
some changes in the Property inspector. These changes just modify HTML 
attributes like width, height, and Bg color. 

3 To make changes to content, display the Insert Flash Button dialog box by 
using one of the following methods:

• Double-click the Flash button object.

• Click Edit in the Property inspector.

• Right-click (Windows) or Control-click (Macintosh) and choose Edit from the 
context menu.

4 In the Insert Flash Button dialog box, make your edits in the fields described in 
the previous procedure.

In the Design view, you can resize the object easily by using the resizing 
handles. You can return the object to its original size by selecting Reset Size on 
the Property inspector. See “Resizing images and other elements” on page 272.

To see the Flash button object play in the Document window:

1 While in Design view, select the Flash button object.

2 In the Property inspector, click the green Play button.

3 Click the red Stop button to end the preview.

Note: You can’t edit the Flash button object while it is playing. 

It’s also always a good idea to preview your document in the browser to see exactly 
how the Flash button looks in the browser.
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Using Flash text objects
The Flash text object lets you create and insert a Flash movie that contains just 
text. This allows you to create a small, vector-graphic movie with the designer 
fonts and the text of your choice.

To insert a Flash text object: 

1 With the Document window in Design view, select Insert Flash Text from the 
Objects panel or choose Insert > Interactive Images > Flash Text.

The Insert Flash Text dialog box appears.

2 Select a font from the Font pop-up menu.

This menu lists all TrueType fonts currently loaded on your system.

3 Enter a font size in the Size field; these are point sizes.

4 Specify style attributes like bold or italic, and text alignment by clicking the 
appropriate style buttons.

5 In the Color field, set the color of the text by using the color picker or entering 
a Web hexadecimal value (such as #FFFFFF).

6 In the Rollover Color field, set the color that appears when the pointer rolls 
over the Flash text object. Use the color picker or enter a Web hexadecimal 
value (such as #FFFFFF).

7 Enter the text you want in the Text field.

To see the font style displayed in the Text field, select Show Font.
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8 If you want to associate a link with the Flash text object, enter a document-
relative or absolute link in the Link field. 

Site-relative links are not accepted because browsers don’t recognize them 
within Flash movies. If you use a document-relative link, be sure to save the 
SWF file to the same directory as the HTML file. (Browsers vary in their 
interpretation of document-relative links and saving to the same directory 
ensures that the links will work correctly.)

9 If you entered a link, you can specify a target frame or target window for that 
link to go to in the Target field.

10 In the Bg Color field, choose a background color for the text. Use the color 
picker or enter a Web hexadecimal value (such as #FFFFFF).

11 In the Save As field, enter a name for the file.

You can use the default file name (for example, tex1.swf ), or type in a new name. 
If the file contains a document-relative link, you must save the file to the same 
directory as the current HTML document to maintain document-relative links.

12 Click Apply or OK to insert the Flash text in the Document window.

If you click Apply, the dialog box remains open, and you can preview the text 
in your document.

To modify or play the Flash text object, use the same procedure as you would for a 
Flash button. See “Using Flash button objects” on page 301.

Setting Flash object properties
The Property inspector for Flash objects initially displays the most commonly used 
properties. Click the expander arrow in the lower right corner to see more properties.

The Property inspector also contains a Play button that lets you preview the Flash 
object in the Document window. When you click the green Play button, you’ll see 
what the object will look like in a browser.

Name specifies the name to identify the button for scripting. Enter a name in the 
unlabeled field on the far left side of the Property inspector.

W and H specify the width and height of the object in pixels. You can also specify 
the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm 
(centimeters), or % (percentage of the parent object’s width or height). The 
abbreviations must follow the value without a space: for example, 3mm.

File specifies the path to the Flash object file. Click the folder icon to browse to a 
file, or type a path.

Align determines how the object is aligned on the page. For a description of each 
option, see “Aligning elements” on page 271.
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Bg specifies a background color for the object.

Edit accesses the Flash object dialog box.

Reset Size resets the selected button to the original movie size.

Play/Stop lets you preview the Flash object in the Document window. Click the 
green Play button to see the object in Play mode; click the red Stop button to stop 
the movie and be able to edit the object.

ID defines the optional ActiveX ID parameter. This parameter is most often used 
to pass information between ActiveX controls.

V Space and H Space specify the number of pixels of white space above, below, 
and on both sides of the button.

Quality sets the quality parameter for the object and embed tags that define the 
button. A movie looks better with a high setting, but it requires a faster processor 
to render correctly on the screen. Low emphasizes speed over appearance, whereas 
High favors appearance over speed. Auto Low emphasizes speed to begin with, but 
improves appearance when possible. Auto High emphasizes both qualities at first, 
but sacrifices appearance for speed if necessary.

Scale sets the scale parameter for the object and embed tags that defines the 
button or text object. This parameter defines how the movie displays within the 
area defined for the movie by the width and height values. The choices are 
Default (Show All), No Border, and Exact Fit. Show All makes the entire movie 
visible in the specified area, maintaining the aspect ratio of the movie and 
preventing distortion; borders may appear on two sides of the movie. No Border is 
similar to Show All, except portions of the movie may be cropped. With Exact Fit, 
the entire movie fills the specified area, but the aspect ratio of the movie is not 
maintained and distortion may occur. 

Parameters opens a dialog box for entering additional parameters. See “Using 
parameters” on page 319.

Creating new button templates

Use Flash together with the free Generator authoring templates to create new 
button templates, complete with Generator Text objects. You can also download 
new button templates from the Macromedia Exchange for Dreamweaver Web site 
and place them in your Flash Button folder. For more information on creating 
new button templates, see the article on that topic found on the Macromedia Web 
site at http://www.macromedia.com/support/dreamweaver/insert_media.html. 
For more information on the using extensions, see “Adding extensions to 
Dreamweaver” on page 93.
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Inserting Flash movies
When you insert a Flash movie into a document, Dreamweaver uses both the 
object tag (defined by Internet Explorer for ActiveX controls) and the embed tag 
(defined by Netscape Navigator) to get the best results in all browsers. When you 
make changes in the Property inspector for the movie, Dreamweaver maps your 
entries to the appropriate parameters for both the object and embed tags.

Note: If you insert a movie using the Flash movie object, it inserts a codebase parameter 
that instructs Internet Explorer for Windows to automatically download the necessary (Flash 4 
and later) ActiveX control. If you don’t want this to happen, you can change the attribute.

To insert a and preview a Flash movie:

1 In the Design view of the Document window, place the insertion point where 
you want to insert the movie.

2 Insert the movie in one of the following ways:

• Click the Insert Flash icon in the Objects panel.

• Choose Insert > Media > Flash.

• Drag the Insert Flash icon from the Objects panel to the insertion point in 
your document.

3 In the dialog box that appears, select a Flash movie file (.swf ). A Flash 
placeholder appears in the Document window (unlike Flash button and 
text objects).

4 To see a preview of the Flash movie in the Document window, click the Green 
play button in the Property inspector. Click Stop to end the preview. You can 
also preview the Flash movie in a browser by pressing F12. 

Tip: To preview all Flash content in a page, press Control+Alt+Shift+P (Windows) or 
Shift+Option+Command+P (Macintosh). All Flash objects and movies are set to Play.
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Setting Flash movie properties

 To view the following properties in the Property inspector, select a Flash movie. 

The Property inspector initially displays the most commonly used properties. To 
see all properties, click the expander arrow in the lower right corner.

Name specifies a name to identify the movie for scripting. Enter a name in the 
unlabeled field on the far left side of the Property inspector.

W and H specify the width and height of the movie in pixels. You can also specify 
the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm 
(centimeters), or % (percentage of the parent object’s value). The abbreviations 
must follow the value without a space: for example, 3mm.

File specifies the path to the Flash movie file. Click the folder icon to browse to a 
file, or type a path.

Align determines how the movie is aligned on the page. For a description of each 
option, see “Aligning elements” on page 271.

Bg specifies a background color for the movie area. This color also appears while 
the movie is not playing (while loading and after playing).

ID defines the optional ActiveX ID parameter. This parameter is most often used 
to pass information between ActiveX controls.

V Space and H Space specify the number of pixels of white space above, below, 
and on both sides of the movie.

Parameters opens a dialog box for entering additional parameters to pass to the 
movie. See “Using parameters” on page 319. The movie must have been designed 
to receive these additional parameters.

Quality sets the quality parameter for the object and embed tags that run the 
movie. The settings relate to the level of anti-aliasing used during playback of the 
movie. A movie looks better with a high setting, but it requires a faster processor 
to render correctly on the screen. Low emphasizes speed over appearance, whereas 
High favors appearance over speed. Auto Low emphasizes speed to begin with, but 
improves appearance when possible. Auto High emphasizes both qualities at first, 
but sacrifices appearance for speed if necessary.

Scale sets the scale parameter for the object and embed tags that run the movie. 
For more information, see “Setting Flash object properties” on page 305. 

Autoplay plays the movie automatically when the page loads.

Loop makes the movie loop indefinitely.

Reset Size returns the selected movie to its original size.
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Inserting Generator objects
Macromedia Generator provides a way to serve dynamic Web content. You can 
create Generator files with Flash 4 or 5 using free Generator authoring templates; 
the files are then served by a Web server running Generator server software. You 
can insert a Generator object into a Dreamweaver document.

To insert a Generator object:

1 In the Document window, place the insertion point where you want to 
insert the object.

2 Click the Generator button in the Objects panel.

3 In the dialog box that appears, select a Generator template (.swt) file.

4 If desired, click the Plus (+) button to add a name=value parameter pair. Then 
enter a name for the parameter in the Name field, and a value for the parameter 
in the Value field. Repeat this step for each parameter.

5 To remove a parameter, select it in the Parameters list and click the
Minus (–) button.

6 When you finish entering parameters, click OK to insert the Generator object.

To edit the parameters after the Generator object has been inserted, use the Code 
inspector or the Code view of the Document window.

The name=value pairs are used by the Generator server, in conjunction with other 
data sources, to dynamically create the Flash movie or image file.
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About Shockwave movies
Shockwave, the Macromedia standard for interactive multimedia on the Web, is a 
compressed format that allows media files created in Macromedia Director to be 
downloaded quickly and played by most popular browsers.

Inserting Shockwave movies

The software that plays Shockwave movies is available as both a Netscape 
Navigator plugin and an ActiveX control. When you insert a Shockwave movie, 
Dreamweaver uses both the object tag (for the ActiveX control) and the embed 
tag (for the plugin) to get the best results in all browsers. When you make changes 
in the Property inspector for the movie, Dreamweaver maps your entries to the 
appropriate parameters for both the object and embed tags.

To insert a Shockwave movie:

1 In the Design view of Document window, place the insertion point where you 
want to insert a Shockwave movie.

2 Click the Shockwave button on the Objects panel, or choose Insert > Media > 
Shockwave or drag the Shockwave button over to your document.

3 In the dialog box that appears, select a movie file.

4 In the Property inspector, enter the width and height of the movie in the 
W and H boxes.

Setting Shockwave properties

To ensure the best results in both Microsoft Internet Explorer and Netscape 
Navigator, Dreamweaver inserts Shockwave movies using both the object and 
embed tags. (object is the tag defined by Microsoft for ActiveX controls; embed is 
the tag defined by Navigator for plugins.) To view the properties in the Property 
inspector, select a Shockwave movie.

The Property inspector initially displays the most commonly used properties. 
Click the expander arrow in the lower right corner to see all properties.

Name specifies a name to identify the movie for scripting. Enter a name in the 
unlabeled field on the far left side of the Property inspector.

W and H specify the width and height of the movie in pixels. You can also specify 
the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm 
(centimeters), or % (percentage of the parent object’s width or height). The 
abbreviations must follow the value without a space: for example, 3mm.

File specifies the path to the Shockwave movie file. Click the folder icon to 
browse, or type a path to the file.
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Align determines how the movie is aligned on the page. For a description of each 
option, see “Aligning elements” on page 271.

Bg specifies a background color for the movie area. This color also appears while 
the movie is not playing (while loading and after playing).

Play lets you see a preview of the movie in the Design view of the Document 
window. Click the Stop button to stop the movie and return to the Shockwave 
placeholder.

Parameters opens a dialog box in which to enter additional parameters to pass to 
the Shockwave movie. See “Using parameters” on page 319. The Shockwave 
movie must have been designed to receive these parameters.

ID defines the optional ActiveX ID parameter. This parameter is most often used 
to pass information between ActiveX controls.

V Space and H Space specify the number of pixels of white space above, below, 
and on both sides of the movie.

Adding sound to a page
There are several different types of sound files and formats, and several different 
ways to add sound to a Web page. Some factors to consider before deciding on a 
format and method for adding sound are its purpose, your audience, file size, 
sound quality, and differences in browsers.   

Note: Sound files are handled very differently and inconsistently by different browsers. You 
may want to save sound files as SWFs to improve consistency. 

About audio file formats

The following list describes the more common audio file formats along with some 
of the advantages and disadvantages of each for Web design. 

.midi or .mid (Musical Instrument Digital Interface) format is for instrumental music. 
MIDI files are supported by many browsers and don’t require a plugin. Although 
their sound quality is very good, it can vary depending on a visitor’s sound card. A 
small MIDI file can provide a long sound clip. MIDI files cannot be recorded and 
must be synthesized on a computer with special hardware and software.

.wav (Waveform Extension) format files have good sound quality, are supported by 
many browsers, and don’t require a plugin. You can record your own WAV files 
from a CD, tape, microphone, and so on. However, the large file size severely 

limits the length of sound clips that you can use on your Web pages.
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.aif (Audio Interchange File Format, or AIFF) format, like WAV format, has good 
sound quality, can be played by most browsers, and don’t require a plugin; you 
can also record AIFF files from a CD, tape, microphone, and so on. However, 
the large file size severely limits the length of sound clips that you can use on 
your Web pages.

.mp3 (Motion Picture Experts Group Audio, or MPEG-Audio Layer-3) format is a 
compressed format that makes sound files substantially smaller. The sound quality 
is very good: if an MP3 file is recorded and compressed properly, its quality can 
rival that of a CD. New technology lets you “stream” the file so that a visitor 
doesn’t have to wait for the entire file to download before hearing it. However, the 
file size is larger than a Real Audio file, so a whole song could still take quite a 
while to download over a normal phone line connection. To play MP3 files, 
visitors must download and install a helper application or plugin such as 
QuickTime, Windows Media Player or RealPlayer. 

.ra, .ram, .rpm, or Real Audio format has a very high degree of compression with 
smaller file sizes than MP3. Whole song files can be downloaded in a reasonable 
amount of time. Because the files can be “streamed” from a normal Web server, 
visitors can begin listening to the sound before the file has completely 
downloaded. The sound quality is poorer than that of MP3 files, but new players 
and encoders have improved quality considerably. Visitors must download and 
install the RealPlayer helper application or plugin in order to play these files.

Linking to an audio file

Linking to an audio file is a simple and effective way to add sound to a Web page. 
This method of incorporating sound files lets visitors choose whether they want to 
listen to the file, and makes the file available to the widest audience. (Some 
browsers may not support embedded sound files.) 

To create a link to an audio file:

1 Select the text or image you want to use as the link to the audio file.

2 In the Property inspector, click the folder icon to browse for the audio file, or 
type the file’s path and name in the Link field.
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Embedding audio

Embedding audio incorporates the sound player directly into the page, but the 
sound only plays if visitors to your site have the appropriate plugin for the chosen 
sound file. Embed files if you want to use the sound as background music, or if 
you want more control over the sound presentation itself. For example, you can 
set the volume, the way the player looks on the page, and the beginning and 
ending points of the sound file. 

To embed an audio file:

1 In Design view, place the insertion point where you want to embed the file.

2 Click the Plugin button in the Objects panel, or choose Insert > Media > Plugin.

For more information about the Plugin object, see “Inserting Netscape 
Navigator plugin content” on page 313.

3 In the Property inspector, click the folder icon to browse for the audio file, or 
type the file’s path and name in the Link field.

4 Enter the width and height by entering the values in the appropriate fields or 
by resizing the plugin placeholder in the Document window.

These values determine the size at which the audio controls are displayed in the 
browser. For example, try a width of 144 pixels and a height of 60 pixels to see 
how the audio player appears in both Navigator and Internet Explorer. 

Inserting Netscape Navigator plugin content
Plugins enhance Netscape Navigator, providing ways to view media content in a 
wide variety of formats. Plugins are the means by which content files are played 
and displayed on your Web site. For example, typical plugins include RealPlayer 
and QuickTime, while some content files themselves include MP3s and 
QuickTime movies.

After you create content for a Navigator plugin, you can use Dreamweaver to 
insert that content into an HTML document. Dreamweaver uses the embed tag to 
mark the reference to the content file.

To insert Navigator plugin content:

1 In the Design view of the Document window, place the insertion point where 
you want to insert the content.

2 Click the Plugin button in the Objects panel.

3 In the dialog box that appears, select a content file for a Navigator plugin.
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Setting Netscape Navigator plugin properties

After inserting content for a Netscape Navigator plugin, use the Property 
inspector to set parameters for that content. To view the following properties 
in the Property inspector, select a Netscape Navigator plugin object.

The Property inspector initially displays the most commonly used properties. 
Click the expander arrow in the lower right corner to see all properties.

Name specifies a name to identify the plugin for scripting. Enter a name in the 
unlabeled field on the far left side of the Property inspector.

W and H specify, in pixels, the width and height allocated to the object on 
the page. You can also specify the following units: pc (picas), pt (points), in 
(inches), mm (millimeters), cm (centimeters), or % (percentage of the parent 
object’s width and height). The abbreviations must follow the value without a 
space: for example, 3mm.

Src specifies the source data file. Click the folder icon to browse to a file, or 
enter a file name.

Plg Url specifies the URL of the pluginspace attribute. Enter the complete URL 
of the site where users can download the plugin. If the user viewing your page 
does not have the plugin, the browser tries to download it from this URL.

Align determines how the object is aligned on the page. For a description of each 
option, see “Aligning elements” on page 271.

V Space and H Space specify the amount of white space in pixels above, below, 
and on both sides of the plugin.

Border specifies the width of the border around the plugin.

Parameters opens a dialog box for entering additional parameters to pass to the 
Netscape Navigator plugin. See “Using parameters” on page 319. Many plugins 
respond to special parameters. The Flash plugin, for example, includes parameters 
for bgcolor, salign, and scale.

You can also view the attributes assigned to the selected plugin by clicking the 
Attribute button. You can edit, add, and delete attributes such as width and height 
in this dialog box.
Chapter 13314



Playing plugins in the Document window

You can preview movies and animations that rely on Navigator plugins—that is, 
elements that use the embed tag—directly in the Design view of the Document 
window. (It is not possible to preview movies or animations that rely on ActiveX 
controls in the Document window.) You can play all plugin elements at one time 
to see how the page will look to the user, or you can play each one individually to 
ensure that you have embedded the correct media element.

To play movies, the proper plugins must be installed on your computer. When 
Dreamweaver starts up, it automatically searches for all installed plugins, looking 
first in the Configuration/Plugins folder and then in the plugin folders of all 
installed browsers.

To play plugin content in the Document window:

1 Insert one or more media elements by choosing Insert > Media > Shockwave, 
Insert > Interactive Images > Flash, or Insert > Media > Plugin.

2 Play plugin content:

• Select one of the media elements you have inserted, and choose View > 
Plugins > Play or click the Play button in the Property inspector.

• Choose View > Plugins > Play All to play all of the media elements on the 
selected page that rely on plugins.

Note: Play All only applies to the current document; it does not apply to other documents in 
a frameset, for example.

To stop playing plugin content:

Select a media element and choose View > Plugins > Stop, or click the Stop button 
in the Property inspector.

You can also choose View > Plugins > Stop All to stop all plugin content from playing.

Troubleshooting Navigator plugins

If you have followed the steps to play plugin content in the Document window, 
but some of the plugin content does not play, try the following:

• Make sure the associated plugin is installed on your computer, and that the 
content is compatible with the version of the plugin you have.

• Open the file Configuration/Plugins/UnsupportedPlugins.txt in a text editor 
and look to see if the problematic plugin is listed. This file keeps track of plugins 
that cause problems in Dreamweaver and are therefore unsupported. (If you 
experience problems with a particular plugin, consider adding it to this file.)

• Check that you have enough memory (and on the Macintosh, check that 
enough memory is allocated to Dreamweaver). Some plugins require an 
additional 2 to 5 MB of memory to run.
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Inserting an ActiveX control
ActiveX controls (formerly known as OLE controls) are reusable components, 
somewhat like miniature applications, that can act like browser plugins. They run 
in Internet Explorer with Windows, but they don’t run on the Macintosh or in 
Netscape Navigator. The ActiveX object in Dreamweaver lets you supply 
attributes and parameters for an ActiveX control in your visitor’s browser.

Dreamweaver uses the object tag to mark the place on the page where the 
ActiveX control will appear, and to provide parameters for the ActiveX control.

To insert ActiveX control content:

1 In the Document window, place the insertion point where you want to insert 
the content and do one of the following:

• Click the ActiveX button in the Objects panel.

• Choose Insert > Media > ActiveX.

• Drag and drop the ActiveX icon. 

An icon marks where the ActiveX control will appear on the page in 
Internet Explorer.

Setting ActiveX properties

After inserting an ActiveX object, use the Property inspector to set attributes of 
the object tag and parameters for the ActiveX control. Click Parameters in the 
Property inspector to enter names and values for properties that don’t appear in 
the Property inspector. There is no widely accepted standard format for 
parameters for ActiveX controls; to find out which parameters to use, consult the 
documentation for the ActiveX control you’re using.

The Property inspector initially displays the most commonly used properties. 
Click the expander arrow in the lower right corner to see all properties.

Name specifies a name to identify the ActiveX object for scripting. Enter a name 
in the unlabeled field on the far left side of the Property inspector.

W and H specify the width and height of the object in pixels. You can also specify 
the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm 
(centimeters), or % (percentage of the parent object’s width and height). The 
abbreviations must follow the value without a space: for example, 3mm.

Class ID identifies the ActiveX control to the browser. Enter a value or choose one 
from the pop-up menu. When the page is loaded, the browser uses the class ID to 
locate the ActiveX control required for the ActiveX object associated with the 
page. If the browser doesn’t locate the specified ActiveX control, it attempts to 
download it from the location specified in Base.
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Embed makes Dreamweaver add an embed tag within the object tag for the 
ActiveX control. If the ActiveX control has a Netscape Navigator plugin 
equivalent, the embed tag activates the plugin. Dreamweaver assigns the 
values you’ve entered as ActiveX properties to their Netscape Navigator 
plugin equivalents.

Align determines how the object is aligned on the page. For a description of each 
option, see “Aligning elements” on page 271.

Parameters opens a dialog box for entering additional parameters to pass to the 
ActiveX object. See “Using parameters” on page 319. Many ActiveX controls 
respond to special parameters.

Src defines the data file to be used for a Netscape Navigator plugin if the Embed 
option is turned on. If you don’t enter a value, Dreamweaver attempts to 
determine the value from the ActiveX properties entered already.

V Space and H Space specify the amount of white space in pixels above, below, 
and on both sides of the object.

Base specifies the URL containing the ActiveX control. Internet Explorer 
downloads the ActiveX control from this location if it has not been installed in 
the visitor’s system. If you don’t specify a Base parameter and if your visitor doesn’t 
already have the relevant ActiveX control installed, the browser can’t display 
the ActiveX object.

Alt Img specifies an image to be displayed if the browser doesn’t support the 
object tag. This option is available only when the Embed option is deselected.

ID defines the optional ActiveX ID parameter. This parameter is most often used 
to pass information between ActiveX controls.

Data specifies a data file for the ActiveX control to load. Many ActiveX controls, 
such as Shockwave and RealPlayer, do not use this parameter.

Borders specifies the width of the border around the object.
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Inserting a Java applet
Java is a programming language that allows the development of lightweight 
applications (applets) that can be embedded in Web pages.

After you create a Java applet, you can insert that applet into an HTML document 
using Dreamweaver. Dreamweaver uses the applet tag to mark the reference to 
the applet file.

To insert a Java applet:

1 In the Document window, place the insertion point where you want to 
insert the applet.

2 Click the Applet button in the Objects panel.

3 In the dialog box that appears, select a file containing a Java applet.

Setting Java applet properties

After inserting a Java applet, use the Property inspector to set parameters. To view 
the following properties in the Property inspector, select a Java applet.

The Property inspector initially displays the most commonly used properties. 
Click the expander arrow in the lower right corner to see all properties.

Name specifies a name to identify the applet for scripting. Enter a name in the 
unlabeled field on the far left side of the Property inspector.

W and H specify the width and height of the applet in pixels. You can also specify 
the following units: pc (picas), pt (points), in (inches), mm (millimeters), cm 
(centimeters), or % (percentage of the parent object’s width or height). The 
abbreviations must follow the value without a space: for example, 3mm.

Code specifies the file containing the applet’s Java code. Click the folder icon to 
browse to a file, or enter a file name.

Base identifies the folder containing the selected applet. When you choose an 
applet, this field is filled automatically.

Align determines how the object is aligned on the page. For a description of each 
option, see “Aligning elements” on page 271.

Alt specifies alternative content (usually an image) to be displayed if the user’s 
browser doesn’t support Java applets or has Java disabled. If you enter text, 
Dreamweaver renders the text with the alt attribute of the applet tag. If you 
choose an image, Dreamweaver inserts an img tag between the opening and 
closing applet tags.

Note: To specify alternative content that is viewable in both Netscape Navigator (with Java 
disabled) and Lynx (a text-based browser), select an image and then manually add an alt 
attribute to the img tag in the Code inspector.
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V Space and H Space specify the amount of white space in pixels above, below, 
and on both sides of the applet.

Parameters opens a dialog box for entering additional parameters to pass to the 
applet. Many applets respond to special parameters.

Using parameters
Use the Parameters dialog box to enter values for special parameters defined for 
Shockwave and Flash movies, ActiveX controls, Netscape Navigator plugins, and 
Java applets. Parameters are used with the object, embed, and applet tags. 
Parameters set attributes specific to the type of object being inserted. For example, 
a Flash movie object can have a quality parameter <param name=”quality” 
value=”best”> for the object tag. The Parameter dialog box is available from the 
Property inspector. See the documentation for the object you’re using for 
information on the parameters it requires.

Note: There is no widely accepted standard for identifying data files for ActiveX controls. 
Consult the documentation for the ActiveX control you’re using to find out which 
parameters to use. 

To open the Parameters dialog box:

1 Select an object that can have parameters (such as a Shockwave movie, an 
ActiveX control, a Navigator plugin, or a Java applet) in the Document window.

2 Open the dialog box by using one of these methods:

• Right-click (Windows) or Control-click (Macintosh) the object, and choose 
Parameters from the context menu.

• Open the Property inspector if it isn’t already open, and click the Parameters 
button found in the lower half of the Property inspector. (Make sure the 
Property inspector is expanded.)

To enter a value for a parameter in the Parameters dialog box:

1 Click the Plus (+) button.

2 Enter the name of the parameter in the Parameter column.

3 Enter the value of the parameter in the Value column.

To remove parameters:

Select a parameter and press the Minus (-) button.

To reorder parameters:

Select a parameter and use the up and down arrow buttons.
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Using behaviors to control media
You can add behaviors to your page to start and stop various media objects.

Control Shockwave or Flash lets you play, stop, rewind, or go to a frame in a 
Shockwave or Flash movie. See “Control Shockwave or Flash” on page 450.

Play Sound lets you play a sound. For example, you can play a sound effect whenever 
the user moves the mouse pointer over a link. See “Play Sound” on page 458.

Check Plugin lets you check to see if visitors to your site have the required plugin 
installed, then route them to different URLs, depending on whether they have the 
right plug-in. This only applies to Netscape Plugins, as the Check plugin behavior 
does not check for ActiveX controls. See “Check Plugin” on page 449.
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Editing HTML in Dreamweaver

Although Macromedia Dreamweaver allows you to create and edit Web pages 
visually without worrying about the HTML source code, there are times 
when you may need access to your page’s underlying HTML. Being able to 
edit the HTML can provide you with more control to modify and troubleshoot 
your Web page.

For example, suppose you select text on your document and apply a new font, but 
it only affects half the sentence. By looking at the HTML code in Dreamweaver 
Code view (or Code inspector), you discover that the closing </font> tag is in the 
middle of the sentence; all you have to do is move </font> to the end of your 
sentence and the problem is fixed. 

If you are interested in learning HTML, using the Dreamweaver visual editing 
capabilities along with its Code view (or Code inspector) is a great way to 
understand how HTML works. You can compare the HTML code to the visual 
view to see how it corresponds.

Dreamweaver provides access to the HTML code through the Code view, the 
Code inspector, and the Quick Tag Editor. For help in understanding and writing 
HTML code, use the Dreamweaver Reference panel.

Dreamweaver also gives you the ability to open HTML files written elsewhere 
without worrying about your code being compromised. Dreamweaver uses 
Roundtrip HTML to make sure your HTML content and structure do not 
change as you switch back and forth between Dreamweaver and an external 
HTML editor. In addition, you can use Dreamweaver to clean up HTML files 
that contain messy or unreadable code. 
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Understanding basic HTML tags
It can be useful to have a basic understanding of HTML when using 
Dreamweaver. You can easily see both the HTML code and the visual design at 
the same time, which gives you the opportunity to figure out how HTML code 
works. Understanding and being able to modify the code can help you 
troubleshoot your Web pages. If you are new to HTML, the following 
explanations provide a brief overview. If you already know HTML, skip ahead 
to the next section.

HTML is a text markup language. This means that HTML documents are plain 
text documents that have specific “markup” tags that tell the Web browser how to 
display the text. 

For example, the i tag controls italic text. By placing <i> in your HTML, you tell 
the browser that the subsequent text should be italic. By placing </i> in your 
HTML, you tell the browser that the subsequent text should revert to the default 
text. The tag with a slash (/) is called the closing tag.

Web browsers interpret these tags in your HTML document and display the text 
with the proper formatting. Some tags have attributes that you can use with them. 
For example, you can specify the alignment of an image within the image tag: 
<IMG SRC="image.gif" align="left">. align is an attribute of the image tag.

Structure of a document

Every HTML document (Web page) must contain certain standard tags—the 
head tag and body tag. The head section contains the title of the Web page (and 
any scripts), and the body section contains the actual text that will appear in the 
Web page as it is displayed in the browser.

Here is the structure of a sample document: 

<html>
<head>
<title>Title goes here</title>
</head>
<body>
<center>
<p>
<font size=+2>Welcome to my page</font>
</p>
<p>
The p is a paragraph tag, which tells the browser that this is all 
one paragraph.
</p>
</center>
</body>
</html>
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The required tags for every HTML document are html, head, and body.

Head tags

The head section (surrounded by head tags) contains only the page title 
(surrounded by title tags) and programming scripts, such as JavaScript code that 
implements an image rollover in your page.

The text that you put between <title> and </title> will appear in the top title 
bar of the browser window. It will not appear on the page.

For example, the following HTML results in the page shown below: 

<html>
<head>

<title>Purcy the cat</title>
</head>
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Body tags

The body of your document contains the content of your page. All your text, 
images, tables, and other content must be placed between <body> and </body>.

<html>
<head>

<title>Purcy the cat</title>
</head>
<body>
<center>

<h2>
Welcome to my home page.
</h2>
<p>
I am a two-year-old part Siamese cat who lives in 
San Francisco with my two owners.
</p>
<br>
<img src="cat.gif" width="400" height="250” align=”center”>
<br>
<p>
I like to eat all kinds of food, especially cheese.
</p>

</center>
</body>
</html>

All of the tags in the body section of the example can be used to format your content. 
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Heading tags—that is, h1 through h6 tags—mark the text as headings. Headings 
are typically displayed in the Web page with larger or bolder text than normal 
body text; h1 is the largest and h6 is the smallest. You always need the opening tag 
in front of your content, followed by the closing tag at the end of the content, as 
in this example: 

<h1> This is a heading 1</h1>

Paragraph tags (p) separate your text content into paragraphs. Because Web 
browsers wrap lines and ignore carriage returns, you must use p tags to prevent 
browsers from running all your text content together. The p tag adds extra white 
space between lines. You always need the opening tag in front of your paragraph 
content, followed by the closing tag at the end of the content, as in this example:

<p>
I am a two-year-old Siamese cat who lives in San Francisco with my 
two owners.
</p>

<p>
I like to eat all kinds of food, especially cheese.
</p>

Line break tags (br) force line breaks in your page, rather than adding extra white 
space like the paragraph tag. Because the br tag inserts a single line break, you do 
not need to include a closing tag.

Line break tags

Space created 
by line breaks
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Image tags insert images in your page. An image tag follows the format 
<img src="imagefilename">; you must put the file name of the image between 
quotation marks. Image tags also have attributes that you can use, such as width, 
height, border, align, and valign. The width and height attributes specify 
the size of your image for the Web browser to interpret; you can set the border 
width to 0 or above (images display a border by default when used as links). The 
align and valign attributes set alignment of your image: align (for horizontal 
alignment) can be set to left, right, or center, and valign (vertical alignment) 
can be set to top, bottom, or middle.

The following example shows a complete image tag:

<img src="cat.gif" width="400" height="250” align=”center”>

Text formatting tags

You can use HTML source code to format the text in your Web page. For 
example, you can specify text to be bold or italic and display in a particular font:

<b>This text will appear bold in the Web page</b>.
<i>This text will appear italic in the Web page</i>.
<font face=”verdana” size=”2”>This text will display with the 
Verdana font face and will be larger than the other text.</font>
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Inserting comments
A comment is descriptive text that you insert in the HTML code to explain the 
code or provide other information. The comment appears only in the Code view 
(or Code inspector), and will not display in your Web page in the browser. 

To insert a comment:

1 Place the insertion point where you want the comment, either in the Code 
view (or Code inspector) or Design view. 

See “Using the Code view (or Code inspector)” on page 330.

2 Click the Comment button in the Invisibles category of the Objects panel, or 
choose Insert > Invisible Tags > Comment. 

Creating a comment generates the following HTML code:

<!-- Comment text-->

To display comment markers in the Design view, choose View > Visual Aids > 
Invisible Elements. Make sure that comments are selected in the Invisible 
Elements preferences, or the comment marker will not appear. For more 
information, see “Setting Invisible Elements preferences” on page 156.

To add to an existing comment, do one of the following:

• Select the Comments marker in the Design view and enter text in the 
Property inspector.

• Find the comment in the code (see earlier example) and add text directly to it. 
Editing HTML in Dreamweaver 327



Using the Dreamweaver Reference panel
The Reference panel provides you with a quick reference tool for HTML tags, 
JavaScript objects, and CSS styles and their attributes. The Reference panel 
provides you with information regarding the specific tags, objects, or styles that 
you are working with in the Code view (or Code inspector). 

To open the Reference panel:

1 Select the tag, object, or style in the Code or Design view that you want 
information about.

2 Click the Reference button in the toolbar (View > Toolbar) or choose 
Window > Reference. 

The Reference panel opens, displaying information about the tag, object, or style that 
you selected. To adjust the text size in the Reference panel, select Large Font, Medium 
Font, or Small Font from the options menu (small arrow at top-right of panel).

The Book pop-up menu displays the name of the book that the reference material 
comes from: The O’Reilly HTML Reference, JavaScript Reference, or CSS 
Reference. To display tags, objects, or styles from another book, choose a book 
from the Book menu. 
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The Tag, Object, or Style (depending on which book you have selected) pop-up 
menu displays the tag, object, or style that you selected in the Code view (or Code 
inspector). To view information about another tag, object, or style, select a new 
one from the menu.

Next to the Tag, Object, or Style pop-up menu is a menu that contains the list of 
attributes for the tag you choose. The default selection is Description, which 
displays a description of the chosen tag. You can also select an attribute from the 
menu to view more information about it. Attributes are used to format the 
content in the tag. For example, you can use the align attribute to specify the 
alignment of an image within the image tag: <img src="image.gif" 
align="left">. 

About Roundtrip HTML
Roundtrip HTML is a unique feature in Dreamweaver that lets you move your 
documents back and forth between a text-based HTML editor and Dreamweaver 
with little or no effect on the content and structure of the document’s original 
HTML source code. Dreamweaver even maintains and renders some HTML that 
is technically invalid (such as a font tag enclosing multiple p tags) if such code is 
supported by browsers. However, the HTML source code that Dreamweaver 
generates as you edit graphically is always technically valid.

The following are key features of Roundtrip HTML:

• By default, Dreamweaver rewrites overlapping tags, closes open tags that aren’t 
allowed to remain open, and removes extra closing tags when you switch back to 
Dreamweaver from an external HTML editor or when you open an existing 
HTML document. If you don’t want Dreamweaver to rewrite any HTML, 
choose Edit > Preferences, then select Code Rewriting to turn off all rewriting. See 
“Setting Code Rewriting preferences” on page 346. If you turn off code rewriting, 
any HTML that Dreamweaver would have rewritten is displayed as invalid. 

• When Highlight Invalid HTML is turned on, Dreamweaver highlights invalid 
HTML (that it does not support) in yellow. When you select an invalid tag, 
Dreamweaver displays information in the Property inspector about how to 
correct the error. Highlight Invalid HTML is turned on by default in the Code 
view (or Code inspector). To turn it off, choose Highlight Invalid HTML from 
the Options menu in the Code view (or Code inspector) window. Error 
highlighting is always on in the Design view.

Note: Enable/Disable Invalid HTML Highlighting is only available in the Code view (or 
Code inspector). Design view always displays error highlighting.
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• Dreamweaver does not change tags that it does not recognize—including XML 
tags—because it has no criteria by which to judge them valid or invalid. If an 
unrecognizable tag overlaps a valid one, Dreamweaver may mark it as erroneous 
but does not rewrite the code. For example, the custom tag in the following 
would be marked erroneous: <MyNewTag><b>text</MyNewTag></b>.

• Dreamweaver does not alter ColdFusion Markup Language (CFML) or 
Microsoft Active Server Pages (ASP) tags, and it displays icons to identify 
blocks of CFML or ASP code in the Document window whenever possible. See 
“Editing ColdFusion and Active Server files in Dreamweaver” on page 352.

• Dreamweaver lets you launch a text-based HTML editor to edit the current 
document. Dreamweaver is integrated with HomeSite (Windows) and BBEdit 
(Macintosh). See “Using external HTML editors” on page 350.

Using the Code view (or Code inspector)
You can view the HTML source code for the current document in several ways: 
you can display only the Code view in the Document window, you can split the 
Document window so that it displays both the Code view and the Design view, or 
you can open the Code inspector. The Code view and the Code inspector work in 
exactly the same way; the only difference is that the Code inspector is in a separate 
window. Splitting the Document window to view the code makes it easier to view 
the visual design while you make changes in the HTML code.

As you add or change content in the Design view, Dreamweaver immediately 
displays the changes in the Code view or inspector. This makes the Code view or 
inspector a useful tool for learning HTML if you don’t already know it, or for 
reminding yourself of proper syntax or values for specific tags or attributes. HTML 
tags and scripts are color coded and can be adjusted in the preference settings. 

Changes or additions that you make in the code appear in the Design view only 
after you synchronize the Code and Design views. 

To synchronize the Code and Design views:

Click in the Design view after working in a code editor or click the Refresh Design 
view button in the toolbar. (Choose View > Toolbar to display the toolbar.) 

Dreamweaver never rewrites HTML that you type directly into a code editor. If 
you enter invalid code and Highlight Invalid HTML is turned on, Dreamweaver 
highlights the invalid code in the code editor. Error highlighting is on by default 
in the code editors. Error highlighting always appears in the Design view, even 
when Highlight Invalid HTML is turned off in the Code view.
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Opening the Code view (or Code inspector)

You can view the HTML source code in several ways: by displaying both code and 
design in the Document window, by displaying code only, and by opening the 
Code inspector.

To display both the Code and Design views:

Choose View > Code and Design, or click the Show Code and Design Views 
button on the toolbar. 

The HTML code appears in the top pane, and the Design view appears in 
the bottom pane. 

You can adjust the size of the panes by dragging the splitter bar.
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To adjust the split Code and Design view, do one of the following:

• To display the Design view on top, choose View > Design View on Top. 
Alternatively, select Design View on Top from the Options pop-up menu 
in the toolbar.

• To view only HTML code in the Document window, choose View > Code or 
click the Show Code View button in the toolbar.

• To view only the visual design, choose View > Design or click the Show Design 
View button in the toolbar.

If you prefer to work with the HTML code in a separate window, use the Code 
inspector to view your code.

To open the Code inspector, do one of the following:

• Choose Window > Code inspector.

• Click the Code Inspector icon in the Launcher bar (in the lower right corner of 
the Document window).

• Press F10.

To toggle between the Document window and the Code inspector:

Press Control-Tab (Windows) or Option-Tab (Macintosh). 
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Setting Code view (or Code inspector) options

You can set word wrapping, code indenting, syntax coloring and more from the 
Options menu in the code editors.

To access the Options menu, the Code view (or Code inspector) must be active. 
Click in the Code view (or Code inspector) to make it active.

To set Code view (or Code inspector) options:

1 Access the options by doing one of the following:

• Click the Options pop-up menu in the toolbar. (Choose View > Toolbar to 
view the toolbar.)

• Choose View > Code View Options. 

The options menu is also available at the top of the Code inspector.

2 Set the options you want:

• Line Wrap wraps the code so that is viewable without horizontal scrolling. This 
setting does not insert line breaks, but makes the code easier to view.

• Line Numbers adds line numbers along the side.

• Highlight Invalid HTML turns on error highlighting. When Highlight Invalid 
HTML is turned on, Dreamweaver highlights invalid HTML (that it does not 
support) in yellow. When you select an invalid tag, Dreamweaver displays 
information in the Property inspector about how to correct the error.

• Syntax Coloring marks the different parts of your code with colors so that you 
can quickly determine the different code elements. To change the colors, see 
“Setting Code Colors preferences” on page 343.

• Auto Indent makes your code indent automatically. To change the indent 
spacing or tags that automatically indent, see “Setting Code Format 
preferences” on page 344.
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Writing and editing code

As you write and edit your code in the Code view (or Code inspector), you can 
indent specific lines of code or check to make sure your tags are balanced. 
Indenting a specific line or section of code will help you separate that code from 
the rest, making it easier to find. Checking to see if your tags are balanced will 
help you ensure that all the tags have matching opening tags and closing tags, and 
is especially useful when you use multiple nesting levels in your code—for 
example, if you have nested several tables within other tables.

To indent selected code:

1 Select the line or lines of code you want to indent. 

For indenting to work, the whole line must be selected.

2 Choose Edit > Indent Code.

The code will be indented. Choose Edit > Outdent Code to move indented 
code back.

To check for balanced tags:

1 Place the insertion point in the nested code you want to check.

2 Choose Edit > Select Parent Tag. 

The enclosing matching tags will be highlighted in your code. Choosing Edit > 
Select Parent Tag again will highlight the matching tags that enclosed the 
previous selection.
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Inserting scripts
You can write or insert scripts in the Code view (or Code inspector), or you can 
enter JavaScript and VBScript in the Design view without having to use the Code 
view. You can also open script files in Dreamweaver Code view. Dreamweaver does 
not alter or rewrite the file. For more information, see “Opening and editing non-
HTML files in Dreamweaver” on page 338.

To display script markers in the Document window, choose View > Visual Aids > 
Invisible Elements. (See also “Setting Invisible Elements preferences” on page 156.) 

To insert a script in code or Design view:

1 Place the insertion point where you want the script.

2 Click the Script button on the Objects panel, or choose Insert > 
Invisible Tags > Script.

3 In the dialog box that appears, choose the scripting language from the 
Language pop-up menu.

If you are using JavaScript and are unsure of the version, choose JavaScript 
rather than JavaScript1.1 or JavaScript1.2. 

4 Enter your script code in the Content text box. 

To link to an external script file:

1 Follow steps 1 through 3 above. 

2 Click OK without typing anything in the Content text box.

3 Select the script marker in the Design view of the Document window. 

Choose View > Visual Aids > Invisible Elements to view the marker. Make sure 
that scripts are selected in Invisible Elements preferences, or the script marker 
will not appear. For more information, see “Setting Invisible Elements 
preferences” on page 156.

4 In the Property inspector, click the folder icon to browse to and select the 
external script file, or type the file name in the Source box.
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Editing a script

You can edit a script in a code editor or the Design view.

To edit the script in the Code view:

Find the script in the Code view and edit it directly. Selecting the Script marker in 
the design view will highlight the script in the code view.

To edit the script in the Design view:

1 Select the Script marker.

2 In the Property inspector, click the Edit button. 

If you linked to an external script file, the file automatically opens in Code view, 
where you can make your edits. Otherwise, the Script Properties dialog box opens 
and you can edit the script in the Script text box. 

Note: If there is code between the script tags, the Script Properties dialog box will open, 
even if there is also a link to an external script file.

The following properties appear in the Script Properties dialog box (and the 
Property inspector) when a script marker is selected:

• Language specifies either JavaScript or VBScript as the language of the script.

• Type specifies the type of script, either client-side or server-side.

• Source specifies an externally linked script file. Click the folder icon to choose 
the file, or type the path.

• Script is where you edit/write your script.
Chapter 14336



To check for balanced braces:

1 Place the insertion point in the nested code you want to check.

2 Choose Edit > Balance Braces. 

The enclosing matching tags are highlighted in your code. Choosing Edit > 
Balance Braces again will highlight the matching tags that enclosed the 
previous selection.

Viewing script functions

You can view all of the JavaScript or VB Script functions in your code from the 
Code Navigation pop-up menu in the toolbar (View > Toolbar).

To view the script functions:

Click the Code Navigation button in the toolbar. 

If your code contains JavaScript or VB Script functions, they will appear in the 
menu. To see the functions listed in alphabetical order, hold down Control 
(Windows) or Option (Macintosh) while clicking the Code Navigation button.

To go to a function in your code:

Select a function from the Code Navigation pop-up menu. The function will be 
highlighted in the Code view (or Code inspector).
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Opening and editing non-HTML files in 
Dreamweaver
When you open a non-HTML file (for example, a .js file) in Dreamweaver, 
Dreamweaver does not alter it. These files open in the Code view (or Code 
inspector), with the Design view disabled. You can edit the file and save it as an 
HTML file or a non-HTML file.

You can set Dreamweaver to automatically open non-HTML files with certain 
extensions by default. For example, you can set the default preferences so that .js 
files automatically open in the Code view (or Code inspector).

To set the default preferences for non-HTML files:

1 Choose Edit > Preferences, then select File Types/Editors.

2 In the Open in Code View field, type the file name extensions you want to 
open automatically in Code view. Put a space between each file type.

The default file extensions listed are .js, .txt, and .asa. You can add as 
many as you want.

Editing an HTML tag in the Design view
Use the Quick Tag Editor to quickly inspect and edit the HTML source of a single 
tag from within the Design view, without having to switch to the Code view and 
back again. The easiest way to open the Quick Tag Editor is to press Control+T 
(Windows) or Command+T (Macintosh).

The Quick Tag Editor has three modes: 

• Insert HTML, used to insert new HTML code 

• Edit Tag, used to edit an existing tag 

• Wrap Tag, used to wrap a new tag around the current selection 

The current selection in the Design view determines the mode in which the 
Quick Tag Editor opens. In all three modes, the basic operation of the Quick Tag 
Editor is the same: you open the editor, enter or edit tags and attributes, and then 
close the editor.

If you use any invalid HTML in the Quick Tag Editor, Dreamweaver attempts 
to correct it for you by inserting closing quotation marks and closing angle 
brackets where needed.

To perform more extensive HTML editing, use the Code view (or Code inspector).
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To open the Quick Tag editor in Insert HTML mode:

1 Click in the Design view to place the insertion point where you want 
to insert code.

2 Press Control+T (Windows) or Command+T (Macintosh), or click the 
Quick Tag Editor button in the Property inspector. 

The Quick Tag Editor opens.

3 Enter the HTML tag, then press Enter. 

The tag is inserted into your code. Press Esc to exit without making any changes.

To open the Quick Tag editor in Edit Tag mode:

1 Select the text or object that you are editing in the Design view. 

You can also select the tag you want to edit from the tag selector at the bottom 
of the Document window.

2 Press Control+T (Windows) or Command+T (Macintosh), or click the Quick 
Tag Editor button in the Property inspector. 

The Quick Tag Editor opens.

3 Enter new attributes, edit existing attributes, or edit the tag’s name; 
then press Enter.

The edited tag is inserted into your code. Press Esc to exit without 
making any changes.
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To open the Quick Tag Editor in Wrap Tag mode:

1 Select unformatted text or an object. 

If you select text or an object that includes an opening or closing HTML tag, 
the Quick Tag Editor will open in Edit Tag mode.

2 Press Control+T (Windows) or Command+T (Macintosh), or click the Quick 
Tag Editor button in the Property inspector. 

The Quick Tag Editor opens.

3 Enter a single opening tag, such as <font="verdana">, and press Enter.

The tag is inserted at the beginning of the current selection, and a matching 
closing tag is inserted at the end. Press Esc to exit without making any changes.

To apply your changes immediately:

After editing a tag, press Tab or Shift+Tab. The change you made is applied 
immediately, rather than when you exit the Quick Tag Editor.

If you want to prevent this behavior, deselect the Apply Changes Immediately 
While Editing option in Quick Tag Editor preferences. (See “Setting Quick Tag 
Editor preferences” on page 342.)

Note: When the Apply Changes Immediately While Editing option is deselected, multiple 
changes that you apply at once appear as a single step in the History panel and are undone 
with a single Undo operation.

To cycle through the Quick Tag Editor modes:

With the Quick Tag Editor active, press Control+T (Windows) or Command+T 
(Macintosh).

The Quick Tag Editor changes modes each time you use the keyboard shortcut, 
cycling among Insert HTML mode, Edit Tag mode, and Wrap Tag mode.

To move the Quick Tag Editor on the screen:

Drag the editor’s handle (where the mode name appears).
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Using the hints menu

While in the Quick Tag Editor, you can access an attributes hint menu that lists all 
the valid attributes of the tag you are editing or inserting. (If Dreamweaver doesn’t 
recognize the tag you’re editing, the hints menu contains all the attributes that 
Dreamweaver recognizes for any tag.) The hints menu does not appear if you 
deselected the Enable Tag Hints option in Quick Tag Editor preferences.

To see a list of valid attributes for a tag you’re editing:

Pause for a few seconds while editing an attribute name. A hints menu appears, 
listing all the valid attributes for the tag you’re editing. Control the hints menu in 
the following ways:

• As you begin to type an attribute name, the hints menu scrolls to highlight the 
first attribute name that starts with the letters you’ve typed. 

• To move the highlighting up and down in the menu, use the Up and Down 
Arrow keys or the scroll bar.

• To choose the highlighted attribute name, press Enter (Windows) or Return 
(Macintosh). Alternatively, double-click an attribute name in the menu.

• To dismiss the hints menu without selecting an entry, press Esc or simply 
continue typing.

When you pause while entering or editing a tag name, a similar hints menu 
appears, listing tag names instead of attribute names.

The tags and attributes that the hints menu displays come from the 
TagAttributeList.txt file, located in your Dreamweaver/Configuration folder. If 
you’re an advanced Dreamweaver user and you want to add tags to or remove tags 
from the hints menu, you can edit this file. (See “Opening and editing non-
HTML files in Dreamweaver” on page 338.)

To edit existing attribute values in Edit Tag mode:

Press Tab to move forward from one item to the next, until the attribute (or tag) 
that you want to edit is selected. Press Shift+Tab to move backward to the 
previous attribute name, attribute value, or tag name.
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To add a new attribute to a tag:

1 Use Tab, the arrow keys, and the Spacebar to move the insertion point to where 
you want to add an attribute. 

2 Type a valid attribute name for the tag. 

If you pause in typing, the hints menu appears.

Removing a tag

You can remove a tag from your document, leaving its content (if any) in place.

To remove a tag:

1 Do one of the following: 

• Select the tag in the tag selector at the bottom left of the Document window. 

• Select anything in the Document window, or click to place the insertion point 
in the window. 

2 Right mouse-click (Windows) or Control-click (Macintosh) in the Design 
view, and choose Remove Tag from the context menu.

Setting Quick Tag Editor preferences

Quick Tag Editor preferences let you control whether the edits you make in the 
Quick Tag Editor are automatically updated in the Document window. You can 
also adjust the controls for the hints menu. To display these preferences, choose 
Edit > Preferences and select Quick Tag Editor.

Apply Changes Immediately While Editing controls whether your Quick Tag 
Editor changes are automatically updated in your document as you move between 
attributes in Edit Tag mode. If you turn off this option, you must press Enter to 
apply your changes to the document. (This option is ignored in Insert HTML 
mode and in Wrap Tag mode; in those modes, you must always press Enter to 
apply your changes to the document.)

Enable Tag Hints controls whether the hints menu appears while you’re typing in 
the Quick Tag Editor. You can also adjust the length of the delay before the menu 
displays for the current attribute or tag.
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Setting code formatting preferences 
You can set the following preferences for formatting code in Dreamweaver:

• Code Colors preferences control how HTML tags (and the text between them) 
and scripts are color coded in the Code view or Code inspector. See “Setting 
Code Colors preferences” on page 343.

• Code Format preferences determine common code formatting options, such as 
line length and indentation. See “Setting Code Format preferences” on page 
344. These preferences provide a user interface for changing the 
SourceFormat.txt file.

• Code Rewriting preferences determine what changes, if any, Dreamweaver 
makes to your code when you open an HTML or script document. See 
“Setting Code Rewriting preferences” on page 346.

• Fonts/Encoding preferences let you specify the font in which your code appears 
in the Code view (or Code inspector). See “Setting Fonts/Encoding 
preferences” on page 89.

Finally, the SourceFormat.txt file (in the Dreamweaver/Configuration folder) 
provides precise specifications for formatting code. Editing this file in a text editor 
gives you the greatest degree of control over exactly how Dreamweaver writes code; 
you can change certain tag-specific options in this file that you can’t change using the 
Code Format preferences. However, do not edit this file unless you are an advanced 
Dreamweaver user or developer, because you may cause serious errors to your 
Dreamweaver program. See “Changing default HTML formatting” on page 530.

Setting Code Colors preferences

Use Code Colors preferences to control the background, text, tag, and reserved 
keyword colors in the Code view (or Code inspector). To work with these 
preferences, choose Edit > Preferences and select Code Colors.

Background specifies the background color of the Code view (or Code inspector). 
This color appears only when you click or type in the Code view or inspector. 

Text specifies the color of text that appears between tags. For example, in the 
code <b>some text</b>, the words “some text” appear in the specified text color, 
but the tags do not. To override the text color for a specific tag, select the Include 
Contents option.

Comments specifies the color for comment tags (<!-- -->) and their contents.

Tag Default specifies the color for all tags except comments. To override this color, 
set the Tag Specific option.

Reserved Keywords specifies the color for all reserved keywords. To override this 
color, set the Tag Specific option.
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Other Keywords specifies the color for all other keywords. To override this color, 
set the Tag Specific option.

Strings specifies the color for all strings in your code. To override this color, set the 
Tag Specific option.

Tag Specific allows you to override the other color settings by specifying colors 
for specific tags.

To set a color for a specific tag:

1 Select a tag in the Tag Specific box.

Shift-click to select adjacent tags. To select nonadjacent tags, Control-click 
(Windows) or Command-click (Macintosh). 

2 Click the radio button next to the color swatch at the bottom of the panel, and 
use one of these methods to choose a new color value:

• Click the color swatch and select a new color from the palette of browser-safe 
colors or the system color picker.

• In the text field next to the swatch, enter a hexadecimal value.

3 To color the text between the opening and closing tags, select Apply Color 
to Tag Contents.

Setting Code Format preferences

Use the following Code Format preferences to control code formatting such as 
indentation, line length, and the case of tag and attribute names. (For information 
on additional code formatting controls, see “Changing default HTML 
formatting” on page 530.) 

Note that all the preferences except Override Case Of affect only new documents 
and new additions to existing documents. That is, when you open a previously 
created HTML document, these formatting options are not applied to it; to 
reformat existing HTML documents, use the Apply Source Formatting command. 
(See “Formatting the HTML source code in existing documents” on page 348.)

Indent turns on indentation of all tags marked indent in the SourceFormat.txt 
file. See “Changing default HTML formatting” on page 530. 

Use specifies whether to indent using spaces or tabs.

Table Rows and Columns automatically indents tr and td tags to make table code 
easier to read. The Indent option must be selected for this option to work.

Frames and Framesets automatically indents frame and nested frameset tags to 
make frameset files easier to read. The Indent option must be selected for this 
option to work. 
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Indent Size determines the size of indents. The size is measured in spaces if Use is 
set to spaces, or in tabs if Use is set to tabs. 

Tab Size determines the size of tabs (measured in character spaces).

Automatic Wrapping adds “hard” returns once a line reaches the specified column 
width. (Note that Dreamweaver inserts hard returns only in places where they 
don’t change the appearance of the document in browsers, so some lines may 
remain longer than the Automatic Wrapping option specifies.) By contrast, the 
Wrap option in the Code view (or Code inspector) adds a “soft” return for lines 
that extend beyond the width of the window. 

Line Breaks specifies the type of remote server (Windows, Macintosh, or UNIX) 
that hosts your remote site. Choosing the correct type of line break characters 
ensures that your HTML source code appears correctly when viewed on the 
remote server. (Note that for FTP, this setting applies only to binary transfer 
mode; Dreamweaver ASCII transfer mode ignores this setting. If you download 
files using ASCII mode, Dreamweaver sets line breaks based on the operating 
system of your computer; if you upload files using ASCII mode, the line breaks 
are all set to CR LF.) This setting is also useful when you are working with an 
external text editor that recognizes only certain kinds of line breaks. For example, 
use CR LF (Windows) if Notepad is your external editor, and CR (Macintosh) if 
SimpleText is your external editor.

Case for Tags and Case for Attributes control the capitalization of tag and 
attribute names. These options are applied to tags and attributes that you insert or 
edit in the Document window, but they are not applied to the tags and attributes 
that you enter directly in the Code view (or Code inspector), or to the tags and 
attributes in a document when you open it (unless you also select one or both of 
the Override Case Of options). 

Override Case Of: Tags and Attributes specify whether to enforce your specified 
case options at all times, including when you open an existing HTML document. 
When you select one of these options, all tags or attributes in open documents are 
immediately converted to the specified case, as are all tags or attributes in each 
document you open from then on (until you deselect this option again). Tags or 
attributes you type in the Code view (or Code inspector) and the Quick Tag 
Editor are also converted to the specified case, as are tags or attributes you insert 
using the Objects panel. For example, if you want tag names always to be 
converted to lowercase, specify lowercase in Case for Tags, and then select the 
Override Case Of: Tags option. Then when you open a document that contains 
uppercase tag names, Dreamweaver converts them all to lowercase.

Centering specifies whether elements should be centered using div 
align="center" or center. Both are part of the HTML 4.0 Transitional 
specification, but center is supported by a wider range of browsers.
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Setting Code Rewriting preferences

Code Rewriting preferences determine what Dreamweaver does while opening 
HTML or script documents. (These preferences have no effect when you edit 
HTML or scripts in the Code view or Code inspector.) If you turn off these 
rewriting options, Dreamweaver displays invalid markup items in the Document 
window for HTML that it would have rewritten. If you are importing an HTML 
document from Microsoft Word, you can use the Clean Up Word HTML 
command to remove any unnecessary HTML code. For more information, see 
“Cleaning up Microsoft Word HTML” on page 348.

Fix Invalidly Nested and Unclosed Tags rewrites overlapping tags. For example, 
<b><i>text</b></i> is rewritten as <b><i>text</i></b>. This option also 
inserts closing quotation marks and closing brackets if they are missing. 

Remove Extra Closing Tags deletes closing tags that have no corresponding 
opening tag.

Warn When Fixing or Removing Tags displays a summary of technically invalid 
HTML that Dreamweaver attempted to correct. The summary notes the location 
of the problem (using line and column numbers) so that you can find the 
correction and ensure it is rendering as intended.

Never Rewrite HTML: In Files with Extensions allows you to prevent Dreamweaver 
from rewriting HTML in files with the specified file name extensions. This option 
is particularly useful for files that contain third-party tags (such as ASP tags). For 
more information, see “Avoiding rewriting third-party tags” on page 544.

The two Special Characters options allow you control over whether Dreamweaver 
encodes certain characters in certain contexts. In general, it’s best to leave these 
options selected unless your files contain certain third-party tags that use the 
characters in question. For more information on these options, see “Avoiding 
rewriting third-party tags” on page 544.
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Cleaning up HTML source code
Use the Clean Up HTML command to remove empty tags, combine nested font 
tags, and otherwise improve messy or unreadable HTML code.

To clean up HTML source code:

1 Open an existing document and choose Commands > Clean Up HTML.

2 In the dialog box that appears, select from the following options:

• Remove Empty Tags removes any tags that have no content between them. For 
example, <b></b> and <font color="FF0000"></font> are considered 
empty tags, but the <b> tag in <b>some text</b> is not.

• Remove Redundant Nested Tags removes all redundant instances of a tag. 
For example, in the code <b>This is what I <b>really</b> wanted to 
say </b>, the b tags surrounding the word “really” are redundant and would 
be removed.

• Remove Non-Dreamweaver HTML Comments removes all comments that 
were not inserted by Dreamweaver. For example, <!--begin body text--> 
would be removed, but <!-- #BeginEditable "doctitle" --> would not 
(because it is a Dreamweaver comment that marks the beginning of an editable 
region in a template).

• Remove Dreamweaver HTML Comments removes all comments that were 
inserted by Dreamweaver. For example, <!-- #BeginEditable "doctitle" 
--> would be removed, but <!--begin body text--> would not (because it 
is not a Dreamweaver comment). Removing Dreamweaver comments turns 
template-based documents into ordinary HTML documents and library items 
into normal HTML code (that is, they cannot be updated whenever the 
original template or library item changes).

• Remove Specific Tag(s) removes the tags specified in the adjacent text field. Use 
this option to remove custom tags inserted by other visual editors and other 
tags that you do not want to appear on your site (for example, blink). Separate 
multiple tags with commas (for example, font, blink).

• Combine Nested <font> Tags When Possible consolidates two or more 
font tags when they control the same range of text. For example, <font 
size="7"><font color="#FF0000">big red</font></font> would be 
changed to <font font="7" font="#FF0000">big red</font>.

• Show Log on Completion displays an alert box with details about the changes 
made to the document as soon as the cleanup is finished.

3 Click OK.

Depending on the size of your document and the number of options selected, 
it may take several seconds to complete the cleanup.
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Formatting the HTML source code in existing documents

The HTML source formatting options that you specify in HTML Format 
preferences and the SourceFormat.txt file apply only to any subsequent new 
documents that you create with Dreamweaver. To apply these formatting options 
to existing HTML documents, use the Apply Source Formatting command.

To apply HTML source formatting options to an existing document:

1 Choose File > Open to open an existing HTML file in the Document window.

2 Choose Commands > Apply Source Formatting.

Cleaning up Microsoft Word HTML
In Dreamweaver, you can open or import documents saved by Microsoft Word 
as HTML files, then use the Clean Up Word HTML command to remove the 
extraneous HTML code generated by Word. The code that Dreamweaver removes 
is primarily used by Word to format and display documents in Word and is not 
needed to display the HTML file. Retain a copy of your original Word (.doc) file 
as a backup, because you may not be able to reopen the HTML document in 
Word once you’ve applied the Clean Up Word HTML feature. The Clean Up 
Word HTML command is available for documents saved as HTML files by 
Word 97 or later.

To clean up Word HTML: 

1 In Microsoft Word, save your document as an HTML file.

2 Open the HTML document in Dreamweaver using either of the 
following methods:

• Choose File > Import > Import Word HTML and select a file to open.

Dreamweaver opens the file and then automatically opens the Clean Up Word 
HTML dialog box.

• Choose File > Open and select a file to open.

An HTML Corrections log file is automatically generated if Warn when Fixing 
or Removing Tags is selected in HTML Rewriting preferences. This is not part 
of the Clean Up Word HTML feature. Click Continue to exit the dialog box. 
Then, in Dreamweaver, choose Commands > Clean Up Word HTML.

3 With either of these methods, there may be a slight delay while Dreamweaver 
attempts to determine which version of Word was used to save the file. If 
Dreamweaver is unable to determine this, select the correct version using 
the pop-up menu. 
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4 Choose which options the Clean Up Word HTML feature should use. The 
Basic tab displays the following options: 

• Remove all Word Specific Markup removes all Word-specific HTML, 
including XML from html tags, Word custom meta data and link tags in the 
head of the document, Word XML markup, conditional tags and their 
contents, and empty paragraphs and margins from styles. You can select each of 
these options individually using the Detailed tab.

• Clean up CSS removes all Word-specific CSS, including inline CSS styles when 
possible (where the parent style has the same style properties), style attributes 
beginning with “mso,” non-CSS style declarations, CSS style attributes from 
tables, and all unused style definitions from the head. You can further 
customize this option using the Detailed tab.

• Clean up <font> Tags removes HTML tags, converting the default body text to 
size 2 HTML text. 

• Fix Invalidly Nested Tags removes the font markup tags inserted by Word 
outside the paragraph and heading (block-level) tags. 

• Set Background Color allows you to enter a hexadecimal value to set the 
background color of your document. If you do not set a background color, 
your Word HTML document will have a gray background. The default 
hexadecimal value set by Dreamweaver is white. 

• Apply Source Formatting applies the source formatting options you specify in 
HTML Format preferences and SourceFormat.txt to the document.

• Show Log on Completion displays an alert box with details about the changes 
made to the document as soon as the cleanup is finished.

5 Click OK.

Depending on the size of your document and the number of options selected, 
it may take several seconds to complete the cleanup. The preferences you 
entered are automatically saved as the default Clean Up Word HTML settings.
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Using external HTML editors
You may want to use a text editor to hand-code large amounts of HTML, 
JavaScript, or VBScript. You can use any external text editor with Dreamweaver, 
including Notepad (bundled with Windows 95 and NT) or SimpleText (bundled 
with the Macintosh), BBEdit, HomeSite, vi, emacs, and TextPad. See “Using an 
external text editor with Dreamweaver” on page 350 and “Using BBEdit with 
Dreamweaver (Macintosh only)” on page 351. 

Using an external text editor with Dreamweaver

You can launch your primary external text editor from Dreamweaver to edit the 
source HTML for the current document and then switch back to Dreamweaver to 
continue editing graphically. Dreamweaver detects any changes that have been 
saved to the document externally and prompts you to reload the document 
upon returning.

If you use BBEdit on the Macintosh, follow the steps in “Using BBEdit with 
Dreamweaver (Macintosh only)” on page 351 instead of the following steps.

To set up external editors for file types other than text and HTML, see 
“Launching an external editor” on page 298.

To choose an external HTML editor:

1 Choose Edit > Preferences, and select File Types/Editors.

2 (Macintosh only) To use an HTML editor other than BBEdit, deselect the 
Enable BBEdit Integration option. To use BBEdit, leave Enable BBEdit 
Integration selected and skip the rest of these steps.

3 Click the Browse button next to the External Code Editor box to choose 
a text editor.

4 In the Reload Modified Files option, specify what you want Dreamweaver to 
do when it detects that changes have been made externally to a document that 
is open in Dreamweaver.

5 In the Save on Launch option, specify whether Dreamweaver should always 
save the current document before launching the editor, never save the 
document, or prompt you to ask whether to save or not each time you launch 
the external editor.

To launch the external HTML editor:

Choose Edit > Edit with (editor name).
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Using BBEdit with Dreamweaver (Macintosh only)

When BBEdit integration is turned on, once you have a document open in 
both BBEdit and Dreamweaver, switching from one application to the other 
automatically updates the document with the latest changes. In addition, 
both programs track the current selection; for example, you can make a 
selection in Dreamweaver and then switch to BBEdit, where the same element 
will be selected. 

You can disable BBEdit integration if you prefer working with an older version of 
BBEdit or a different HTML text editor. Selections are not tracked if BBEdit 
integration is turned off.

To use BBEdit with Dreamweaver:

1 Choose Edit > Edit with BBEdit.

2 Edit the document in BBEdit.

3 Click the Dreamweaver button on the HTML Tools palette in BBEdit to 
return to Dreamweaver.

To disable BBEdit integration:

1 Choose Edit > Preferences, and select File Types/Editors.

2 Deselect Enable BBEdit Integration and click OK.
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Editing ColdFusion and Active Server files in Dreamweaver

Dreamweaver displays icons to identify blocks of ColdFusion Markup 
Language (CFML) or Active Server Pages (ASP) code in the Design 
view whenever possible.

Note: By default, Dreamweaver never rewrites HTML found in ColdFusion and ASP files.

To edit a block of ASP code from the Design view:

1 Click the yellow ASP marker to select it.

2 In the Property inspector, click the Edit button.

3 Edit the ASP code in the dialog box that appears, and then click OK.

To edit a block of CFML code from the Design view:

1 Click the CFML marker to select it.

2 In the Property inspector, do one of the following:

• Click the Attributes button to edit the tag’s attributes and their values or to 
add new ones.

• Click the Content button to edit the content that appears between the opening 
and closing CFML tags. If the selected tag is an empty tag (that is, if it has no 
closing tag), the Content button is disabled.

If you don’t see markers or highlighted text where you know ASP or CFML code 
exists, first make sure that View > Visual Aids > Invisible Elements is enabled. If 
that option is selected and the icons are still not visible, Dreamweaver can’t display 
the code as CFML or ASP. This can happen, for example, when conditionals are 
inserted into HTML tags, as in the following ASP code:

<input type="checkbox" name="month" value="October"
<% if month="October" then %>checked<% end if %>
>

To edit CFML or ASP code in the code editors, do one of the following:

Find the code in the Code view or Code inspector and edit it directly.

To find the CFML or ASP code:

Position the insertion point near the location of the CFML or ASP code in the 
Design view. The CFML or ASP code will be highlighted in the Code view or 
Code inspector and you can edit it directly.

For information about processing CFML or ASP code and viewing the results 
in the Document window, see “Customizing the interpretation of third-party 
tags” on page 537.
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Linking and Navigation

Once you’ve set up a local site in which to store your Web site documents and 
have created HTML pages, you’ll want to create connections from your 
documents to other documents or file types. (For information on setting up a 
local site, see “Using Dreamweaver to set up a new site” on page 102.)

Macromedia Dreamweaver provides several ways to create hypertext links to 
documents, images, multimedia files, or downloadable software. You can establish 
links to any text or image anywhere within a document, including text or images 
located in a heading, list, table, layer, or frame. For details on creating links, see 
“Creating links” on page 358.

For a visual representation of how your files are linked together, use the site 
map. In the site map you can add new documents to your site, create and 
remove document links, and check links to dependent files. See “Using the site 
map” on page 117.

There are several different ways of creating and managing links. Some Web 
designers prefer creating links to nonexistent pages or files as they work, while 
others prefer creating all the files and pages first, then adding the links. Another 
way to manage links is to create “placeholder” pages which stand in for the final 
file and let you add links quickly and check them before you have actually 
completed all the pages. See “Checking links in a page or site” on page 506.
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About document locations and paths
Understanding the file path between the document you’re linking from and the 
document you’re linking to is essential to creating links.

Each Web page has a unique address, called a Uniform Resource Locator (URL). 
(For detailed information on URLs, see the World Wide Web Consortium page 
on naming and addressing.) However, when you create a local link (a link from 
one document to another on the same site), you generally don’t specify the entire 
URL of the document you’re linking to; instead, you specify a relative path from 
the current document or from the site’s root folder. The following are the three 
types of link paths:

• Absolute paths (such as http://www.macromedia.com/support/dreamweaver/
contents.html).

• Document-relative paths (such as dreamweaver/contents.html).

• Root-relative paths (such as /support/dreamweaver/contents.html).

Using Dreamweaver, you can easily select the type of document path to create for 
your links. See “Linking documents using the Property inspector and the Point-
to-File icon” on page 359.

Note: It is best to use the type of linking you prefer and are most comfortable with, either 
site or document relative. Browsing to links, as opposed to typing in the paths, ensures that 
you always enter the right path.

Absolute paths

Absolute paths provide the complete URL of the linked document, including 
the protocol to use (usually http:// for Web pages). For example, http://
www.macromedia.com/support/dreamweaver/contents.html is an absolute path. 
You must use an absolute path to link to a document on another server. You can 
also use absolute-path links for local links (to documents in the same site), but 
that approach is discouraged; if you move the site to another domain, all of your 
local absolute-path links will break. Also, using relative paths for local links 
provides greater flexibility if you need to move files within your site.

Note: When inserting images (not links): if you use an absolute path to an image that 
resides on a remote server and is not available on the local hard drive, you will not be able to 
view the image in your document window. Instead, you must preview the document in a 
browser to see it. If possible, use document or root-relative paths for images. For more 
information, see “Inserting an image” on page 268.
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Document-relative paths

Document-relative paths are the most appropriate paths to use for local links in 
most Web sites. They’re particularly useful when the current document and the 
linked document are in the same folder and are likely to remain together. You can 
also use a document-relative path to link to a document in another folder, by 
specifying the path through the folder hierarchy from the current document to the 
linked document. The basic concept behind document-relative paths is to omit 
the part of the absolute URL that is the same for both the current document and 
the linked document, providing only the portion of the path that differs.

• To link to another file in the same folder as the current document, simply enter 
the file name. 

• To link to a file in a subfolder of the current document’s folder, provide the 
name of the subfolder, then a forward slash (/), and then the file name.

• To link to a file in the parent folder of the current document’s folder, precede 
the file name with ../ (where “..” means “up one level in the folder hierarchy”).

For example, suppose you have a site with this structure:

resources

tips.html

my_site (root folder)

support

contents.html

hours.html

products

catalog.html

index.html (home page)
Linking and Navigation 355



To link from contents.html to other files:

• To link from contents.html to hours.html (both files are in the same folder), 
the file name is the relative path: hours.html.

• To link to tips.html (in the subfolder named resources), use the relative path 
resources/tips.html.

Each forward slash (/) represents moving down one level in the folder hierarchy.

• To link to index.html (in the parent folder, one level above contents.html), use 
the relative path ../index.html.

Each ../ represents moving up one level the folder hierarchy.

• To link to catalog.html (in a different subfolder of the parent folder), use the 
relative path ../products/catalog.html.

The ../ moves up to the parent folder; the products/ moves down into the 
products subfolder.

Note: Always save a new file before creating a document-relative path; a document-
relative path is not valid without a definite starting point. If you create a document-relative 
path before saving the file, Dreamweaver temporarily uses an absolute path beginning with 
file:// until the file is saved; when you save the file, Dreamweaver converts the file:// path 
into a relative path.

When you move a group of files as a group—for example, when you move an 
entire folder, so that all the files inside that folder retain the same relative paths to 
each other—you don’t need to update document-relative links between those files. 
When you move an individual file that contains document-relative links, however, 
or an individual file that’s linked to by a document-relative link, you do need to 
update those links. (If you move or rename files using the Site window, 
Dreamweaver updates all relevant links automatically.)
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Root-relative paths

Root-relative paths provide the path from the site’s root folder to a document. You 
might want to use these types of paths if you are working on a large Web site that uses 
several servers, or one server that hosts several different sites. However, if you are not 
familiar with this type of path, you may want to stick to document-relative paths.

A root-relative path begins with a leading forward slash, which stands for the site 
root folder. For example, /support/tips.html is a root-relative path to a file 
(tips.html) in the support subfolder of the site’s root folder. 

A root-relative path often provides the best way to specify links in a Web site in 
which you need to frequently move HTML files from one folder to another. 
When you move a document that contains root-relative links, you don’t need to 
change the links; for example, if your HTML files use root-relative links for 
dependent files (such as images), then if you move an HTML file, its dependent-
file links are still valid. However, when you move or rename the documents linked 
to with root-relative links, you do need to update those links, even if the 
documents’ paths relative to each other haven’t changed. For example, if you move 
a folder, all root-relative links to files within that folder must be updated. (If you 
move or rename files using the Site window, Dreamweaver updates all relevant 
links automatically.)

• To use root-relative paths, first define a local site in Dreamweaver by choosing a 
local root folder to serve as the equivalent of the document root on a server. 
(See “Using Dreamweaver to set up a new site” on page 102.)

Dreamweaver uses this folder to determine the root-relative paths to files.

Note: Root-relative links are interpreted by servers, not by browsers, so if you open a local 
page that uses root-relative links in your browser (without using Preview in Browser from 
within Dreamweaver), the links don’t work. When you use the Preview in Browser 
command to preview a document that uses root-relative links, Dreamweaver temporarily 
converts those links (in the previewed file only) to use absolute file:// paths. However, you 
can preview only one page at a time that uses root-relative links—if you follow a link from 
the previewed page, the next page’s root-relative links are not converted, and the browser 
can’t follow such links. Previewing pages in framesets that use root-relative links results in 
similar problems.

To preview a set of pages that use root-relative links, do one of the following:

• Put the files on a remote server and view them from there.

• (Windows only) Choose Edit > Preferences, and in Preview in Browser 
preferences, select Preview Using Local Server. To use this option, you must be 
running a Web server on your local computer.
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Creating links
The HTML tag for creating a hypertext link is called an anchor tag or an a tag. 
Dreamweaver creates an anchor tag for objects, text, or images you create links 
from. You can create links to other documents and files, and links to specific 
places in a single document using the a href tag.

For example, if you selected the text Home Page in the Document window, then 
created a link to a file named home.htm, the HTML source code for the link 
would look like this:

<a href="home.htm">Home Page</a>

If you are creating a link to a specific place in a document, you first create a named 
anchor, for example, a name="MainMenu". Then you create a link within the page 
that refers back to that named anchor, for example, a href="#MainMenu".

Before creating links, be sure you understand how document-relative paths, root-
relative paths, and absolute paths work. See “About document locations and 
paths” on page 354.

You can create several types of links in a document:

• A link to another document or to a file, such as a graphic, movie, PDF, 
or sound file.

• A named anchor link, which jumps to a specific location within a document.

• An e-mail link, which creates a new blank e-mail message with the recipient’s 
address already filled in.

• Null and script links, which enable you to attach behaviors to an object or to 
create a link that executes JavaScript code.

Using Dreamweaver, there are several ways to easily create local links (between 
documents in the same site):

• Use the site map to view, create, change, or delete links.

• In the Document window, use Modify > Make Link to select a file to link to.

• Use the Property inspector to link to a file, by using the folder icon to browse 
to and select a file, using the Point-to-File icon to select a file, or typing the 
path of the file.

Note: Typing URLs or paths to a file can lead to incorrect paths and links that don’t 
work. To ensure that the path is correct, use the folder icon to browse to your link.

• Choose Make Link from the context menu, then select a file to link to.

To create an external link (to a document on another site), you must type the 
absolute path (with proper protocol) in the Property inspector. Be sure you enter 
the entire path (including http://) when creating external links.
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Linking documents using the Property inspector and the 
Point-to-File icon

Use the Property inspector and the Point-to-File icon to create links from an 
image, an object, or text to another document or file.

For more information, see “Creating and modifying links in the site map” on page 367.

To create links between documents using folder icon or link text box:

1 Select text or an image in the Document window’s Design view.

2 Open the Property inspector (Window > Properties) and do one of 
the following:

• Click the folder icon to the right of the Link field to browse to and select a file.

The path to the linked document appears in the URL field. Use the Relative To 
pop-up menu in the Select HTML File dialog box to indicate whether to make 
the path document-relative or root-relative, then click Select.

Note: When you change the path type in the Relative To field, Dreamweaver uses your 
choice as the default path type for any future links until you change the path type again.

• In the Link field, type the path and file name of the document.

To link to a document in your site, enter a document-relative or root-relative 
path. To link to a document outside your site, enter an absolute path including 
the protocol (such as http://). You can use this approach to enter a link for a file 
that hasn’t been created yet.

3 Select a location in which to open the document.

To make the linked document appear somewhere other than in the current 
window or frame, select an option from the Target pop-up menu on the 
Property inspector.

Tip: If all the links on your page will be set to the same target, you can specify this target 
once by choosing Insert > Head Tag > Base and selecting the target information.

For information about targeting frames, see “Controlling frame content with 
links” on page 218.
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To link to a document using the Point-to-File icon:

1 Select text or an image in the Document window’s Design view.

2 Drag the Point-to-File icon at the right of the Link field in the Property 
inspector and point to another open document, a visible anchor in an open 
document, or a document in the Site window. 

The Link field updates to show the link. 

Note: The open document or site-window file you point to will move to the foreground of 
your screen while you are making your selection.

3 Release the mouse button. 

Dragging the Point-to-File icon from the Property inspector to a file in the 
Site window
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To create a link from a selection in an open document:

1 Select text in the Document window’s Design view.

2 Shift-drag from the selection. 

The Point-to-File icon appears as you drag. 

3 Point to another open document, a visible anchor in an open document, or a 
document in the Site window. 

4 Release the mouse button. 

Shift-dragging the Point-to-File icon from text in the Document window to a file in 
the Site window
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To create a link using the site map and the Point-to-File icon:

1 In the Site window, display both the Site Files and the Site Map views by 
holding down the Site Map icon and choosing Map and Files.

2 Select an HTML file in the site map. 

The Point-to-File icon appears next to the file. 

3 Drag the Point-to-File icon and point to another file in the site map or to a 
local file in the Site Files view.

4 Release the mouse button.

A hypertext link with the name of the linked file is placed at the bottom of the 
selected HTML file. This method works well when you are building your site 
and you want to create links across the site quickly. 

For information about displaying a site map, see “Using the site map” on page 117.

Linking to a specific place within a document 

You can use the Property inspector to link to a particular section of a document by 
first creating named anchors. Named anchors let you set markers in a document 
and are often placed at a specific topic or at the top of a document. You can then 
create links to these named anchors, which quickly take your visitor to the 
specified position.

Creating a link to a named anchor is a two-step process. First, create a named 
anchor, then create a link to the named anchor.
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To create a named anchor:

1 In the Document window’s Design view, place the insertion point where you 
want the named anchor.

2 Do one of the following:

• Choose Insert > Invisible Tags > Named Anchor.

• Press Control+Alt+A (Windows) or Command+Option+A (Macintosh).

• In the Invisibles category of the Objects panel, click the Named Anchor button.

3 In the Anchor Name field of the Insert Named Anchor dialog box, type a name 
for the anchor.

If an anchor marker doesn’t appear at the insertion point location, choose 
View > Visual Aids > Invisible Elements.

Note: Anchor names cannot contain spaces and should not be placed inside a layer.

To link to a named anchor:

1 In the Document window’s Design view, select text or an image to create 
a link from.

2 In the Link field of the Property inspector, type a number sign (#) and the 
name of the anchor. For example:

• To link to an anchor named “top” in the current document, type #top.

• To link to an anchor named “top” in a different document in the same folder, 
type filename.html#top.

Note: Anchor names are case sensitive.

To link to a named anchor using the point-to-file method:

1 Open the document containing the named anchor you want. 

2 Choose View > Visual Aids > Invisible Elements to make the anchor visible.

3 In the Document window’s Design view, select text or an image you want to 
link from. (If this is another open document, you must switch to it.)

4 Do one of the following:

• Click the Point-to-File icon to the right of the Link field in the Property 
inspector and drag it to the anchor you want to link to: either an anchor within 
the same document or an anchor in another open document.

• Shift-drag in the Document window from the selected text or image to the 
anchor you want to link to: either an anchor within the same document or an 
anchor in another open document.
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Creating an e-mail link

An e-mail link opens a new blank message window (using the mail program 
associated with the user’s browser) when clicked. In the e-mail message window, 
the To field is automatically updated with the address specified in the e-mail link. 

To create an e-mail link using the Insert E-Mail Link command:

1 In the Document window’s Design view, position the insertion point where 
you want the e-mail link to appear, or select the text or image you want to 
appear as the e-mail link. Then do one of the following:

• Choose Insert > E-Mail Link.

• In the Common category of the Objects panel, select Insert E-Mail Link.

2 In the Text field of the Insert E-Mail Link dialog box, type or edit the text to 
appear in the document as an e-mail link.

3 In the E-Mail field, type the e-mail address that the mail should be addressed to.

4 Click OK.

To create an e-mail link using the Property inspector:

1 Select text or an image in the Document window’s Design view.

2 In the Link field of the Property inspector, type mailto: followed by an 
e-mail address. 

Do not type any spaces between the colon and the e-mail address. For example, 
type mailto:jdoe@macromedia2.com.
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Creating null and script links

The most familiar kinds of links are those to documents and named anchors 
(described in “Linking documents using the Property inspector and the Point-to-
File icon” on page 359 and “Linking to a specific place within a document” on 
page 362, respectively), but there are other types of links as well.

A null link is an undesignated link. Use null links to attach behaviors to objects or text 
on a page. Once you have created a null link, you can attach a behavior to it to swap an 
image or to display a layer when the pointer is moved over the link. For information 
about attaching behaviors to objects, see “Attaching a behavior” on page 439.

Script links execute JavaScript code or call a JavaScript function and are useful for 
giving visitors additional information about an item without leaving the current 
Web page. Script links can also be used to perform calculations, form validations, 
and other processing tasks when a visitor clicks a specific item.

To create a null link:

1 Select text, an image, or an object in the Document window’s Design view.

2 In the Property inspector, type a number sign (#) in the Link field.

To create a script link:

1 Select text, an image, or an object in the Document window’s Design view.

2 In the Link field of the Property inspector, type javascript: followed by some 
JavaScript code or a function call.

For example, typing javascript:alert('This link leads to the index') in the Link 
field produces a link that, when clicked, displays a JavaScript alert box with the 
message This link leads to the index.

Note: Because the JavaScript code appears in the HTML between double quotation 
marks (as the value of the href attribute), you must use single quotation marks in the 
script code or “escape” any double quotation marks by preceding them with a 
backslash (for example, \"This link leads to the index\").
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Managing links
Dreamweaver can update links to and from a document whenever you move or 
rename the document within a local site. This feature works best when you store 
your entire site (or an entire self-contained section of it) on your local disk. No 
changes are made to files on the remote site until you put or check in the local files 
to the remote server.

To turn on link management in Dreamweaver:

1 Choose Edit > Preferences, then select the General category.

2 Select Always or Prompt from the Update Links when Moving Files pop-up 
menu and click OK.

If you choose Always, Dreamweaver automatically updates all links to and from 
a selected document whenever you move or rename it. (For specific instructions 
on what to do when you delete a file, see “Changing a link sitewide” on page 
368.) If you choose Prompt, Dreamweaver first displays a dialog box that lists 
all the files affected by the change. Click Update to update the links in these 
files, or click Don’t Update to leave the files unchanged.

To make the updating process faster, Dreamweaver can create a cache file in which 
to store information about all the links at your local site. This cache file is created 
when you select the Cache option in the Site Definition dialog box, and the cache 
file is updated invisibly as you use Dreamweaver to add, change, or delete links to 
files on your local site.

To create a cache file for your site:

1 Choose Site > Define Sites.

2 Select the site in the Define Sites dialog box, then click Edit. In the Local Info 
category, select the Enable Cache checkbox.

The first time you change or delete links to files in your local site after launching 
Dreamweaver, Dreamweaver prompts you to load the cache. If you click Yes, the 
cache loads and all links to the file you just changed are automatically updated. If 
you click No, the change is noted in the cache, but the cache does not load and 
links are not updated.

It may take a few minutes for the cache to load on larger sites; most of this time is 
spent comparing the time stamps of the files on the local site with the time stamps 
recorded in the cache to see if the cache is out of date. If you have not changed any 
files outside Dreamweaver, you can safely click the Stop button when it appears.

To re-create the cache for your site:

In the Site window, choose Recreate Site Cache.
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Creating and modifying links in the site map

You can modify the structure of the site in the site map by adding, changing, 
and removing links. The site map is updated automatically to display the 
changes to the site.

To add a link, do one of the following:

• Drag a page from the Windows Explorer or the Macintosh Finder onto a page 
in the site map.

• Select an HTML page and choose Site > Link to Existing File (Windows) or 
Site > Site Map View > Link to Existing File (Macintosh), or choose Link to 
Existing File from the context menu.

• Select an HTML page in the site map. The Point-to-File icon appears. Drag the 
icon to the object you want to link to: either a file in the Site Files view, an 
open Dreamweaver document, or a named anchor in a document open on the 
desktop. See “Linking documents using the Property inspector and the Point-
to-File icon” on page 359.

To change a link:

1 In the site map, select the page whose link you’re changing, and choose Site > 
Change Link (Windows) or Site > Site Map View > Change Link (Macintosh). 

2 Browse to the file or type a URL.

To remove a link, do one of the following:

• Select the page in the site map and choose Site > Remove Link (Windows) or 
Site > Site Map View > Remove Link (Macintosh).

• Select the page in the site map and choose Remove Link from the 
context menu. Removing a link does not delete the file, but removes the link 
from the HTML source on the page that is pointing to the link.

To open the source of a link:

1 Select a file in the site map.

2 Choose Site > Open Source of Link (Windows) or Site > Site Map View > 
Open Source of Link (Macintosh).

The Property inspector and the source file containing the link are opened. The 
link is highlighted.
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Changing a link sitewide

In addition to having Dreamweaver update links automatically whenever you 
move or rename a file, you can manually change all links (including e-mail, FTP, 
null, and script links) to point somewhere else. You can use this option at any time 
(for example, you might have the words “this month’s movies” linked to /movies/
july.html throughout your site, and on August 1 you must change those links to 
point to /movies/august.html), but it’s particularly useful when you want to delete 
a file that other files link to.

To change a link sitewide:

1 Select a file in the Local Folder pane of the Site window.

2 Choose Site > Change Link Sitewide.

3 In the dialog box that appears, click the folder icon to browse to and select a 
file. You can also type the path and file name in the Into Links To field.

4 Click OK.

Dreamweaver updates any documents that link to the selected file, making 
them point to the new file, using the path format already used in the document 
(for example, if the old path was document relative, the new path is also 
document relative). The type of link, whether document or root-relative, 
doesn’t matter. The link is updated automatically. 

After a link is changed sitewide, the selected file becomes an orphan (that is, no 
files on your local disk point to it). You can safely delete it without breaking any 
links in your local site.

Note: Because these changes are occurring locally, you must manually delete the 
corresponding orphan file on the remote site and put or check in any files in which links 
were changed; otherwise, visitors to your site won’t be able to see the changes.

To change e-mail, FTP, null, or script links sitewide:

1 Choose Site > Change Link Sitewide.

2 In the Change Link Sitewide dialog box, enter the following information:

• In the Change All Links To field, type the full text of the link you are changing.

• In the Into Links To field, type the full text of the replacement link.

3 Click OK.

For example, to update all the e-mail links that point to your old address, you 
might type mailto:juser@isp.com in the Change All Links To field, and type 
mailto:juser-interface@isp.com in the Into Links To field.
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Creating jump menus
A jump menu is a pop-up menu in a document, visible to your site visitors, listing 
options that link to documents or files. You can create links to documents in your 
Web site, links to documents on other Web sites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser.

There are three basic components a jump menu can contain:

• A menu selection prompt, such as a category description for the menu items, or 
instructions, such as “Choose one:”. (Optional)

• A list of linked menu items: a user chooses an option and a linked document or 
file opens. (Required)

• A Go button. (Optional)

Inserting a jump menu

To insert a jump menu in your document, use the Jump Menu form object.

To create a jump menu:

1 Choose Insert > Form Object > Jump Menu.

The Insert Jump Menu dialog box appears.

2 If you want to create a selection prompt, type the prompt text in the Text field 
of the dialog box. Under Options, select the Select First Item After URL 
Change checkbox, then click the Plus (+) button to add a menu item.

3 In the Text field of the Insert Jump Menu dialog box, type the text you want to 
appear in the menu list.

4 In the When Selected, Go To URL field, select the file to open by doing either 
of the following:

• Click Browse, then select the file to open.

• Type the path of the file to open.

5 In the Open URLs In pop-up menu, select a location in which the file will open:

• Select Main Window to open the file in the same window.

• Select a frame in which the file will open.

Note: If the frame you want to target doesn’t appear on the Open URLs In pop-up 
menu, close the Insert Jump Menu dialog box and name the frame. For information 
about naming a frame, see “Setting frame properties” on page 212.

6 To add a Go button instead of a menu selection prompt: Under Options, select 
the Insert Go Button After Menu option.
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7 To add additional menu items, click the Plus (+) button and repeat steps 3 
through 6 of this procedure.

8 Click OK.

Editing jump menu items

To make changes to jump menu items, you use the Property inspector or the 
Behaviors panel. You can change the list order or the file an item links to, or you 
can add, delete, or rename an item.

To change the location in which a linked file opens, or to add or change a menu 
selection prompt, you must use the Behaviors panel; see “Jump Menu” on page 455.

To edit a jump menu item using the Property inspector: 

1 In the Property inspector, choose Window > Properties.

2 In the Document window’s Design view, click the jump menu object to select it.

The List/Menu icon appears in the Property inspector.

3 In the Property inspector, click the List Values button.

4 Make changes to the menu items, then click OK.

Troubleshooting jump menus

Once users choose a jump menu item, there is no way to reselect that menu item 
if they navigate back to that page, or if the Open URL In field specifies a frame. 
There are two ways to work around this problem:

• Use a menu selection prompt, such as a category, or a user instruction, 
such as “Choose one:”. The menu selection prompt is reselected automatically 
after each menu selection.

• Use a Go button, which allows a user to revisit the currently chosen link.

Note: Select only one of these options per jump menu, because they apply to an 
entire jump menu. 
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Creating navigation bars
A navigation bar consists of an image (or set of images) whose display changes 
based on the actions of a user. Navigation bars often provide an easy way to move 
between pages and files on a site.

Before using the Insert Navigation Bar command, create a set of images for the 
display states of each navigation element. (It can be helpful to think of a 
navigation bar element as a button, because when clicked, it takes the user to 
another page.)

A navigation bar element can have four states:

• Up: the image that appears when the user hasn’t yet clicked or interacted with the 
element. For example, the element in this state looks like it hasn’t been clicked.

• Over: the image that appears when the pointer is moved over the Up image. 
The element’s appearance changes (for example, it may get lighter) to let users 
know they can interact with it.

• Down: the image that appears after the element has been clicked. For example, 
when a user clicks an element, a new page loads and the navigation bar is still 
displayed, but the clicked element is darkened to show that it’s been selected.

• Over While Down: the image that appears when the pointer is rolled over the 
Down image after the element has been clicked. For example, the element may 
appear dimmed or gray. You can use this state as a visual clue to users that this 
element cannot be clicked again while they are in this part of the site.

You don’t have to include navigation bar images for all four of these states; for 
example, you may just want Up and Down states. 

You can create a navigation bar, copy it to other pages in your site, use it with 
frames, and edit the page behaviors to show different states as pages are accessed.
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Inserting a navigation bar

When you insert a navigation bar, you name the navigation bar elements and 
select images to use for them.

To create a navigation bar:

1 Do one of the following:

• Choose Insert > Interactive Images > Navigation Bar.

• In the Common category of the Objects panel, select Insert Navigation Bar.

The Insert Navigation Bar dialog box appears.

2 In the Element Name field, type a name for a navigation bar element—for 
example, Home.

Each element corresponds to a button with a set of up to four state images. 
Element names appear in the Nav Bar Elements list. Use the arrow buttons to 
arrange elements in the navigation bar.
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3 Select image state options for this element (you must select an Up image; other 
image states are optional):

• In the Up Image field, click Browse to select the image to display initially.

• In the Over Image field, click Browse to select the image to display when the 
user moves the pointer over the element when the Up image is showing.

• In the Down Image field, click Browse to select the image to display after the 
user has clicked the element.

• In the Over While Down Image field, click Browse to select the image to 
display when the user moves the pointer over the Down image.

• In the When Clicked, Go To URL field, select a location in which the linked 
file will open by doing one of the following:

• Select Main Window to open the file in the same window.

• Select a frame in which to open the file.

Note: If the frame you want to target doesn’t appear in the pop-up menu, close the 
Insert Navigation Bar dialog box and name the frame. For information about naming a 
frame, see “Setting frame properties” on page 212.

4 Select image loading options: 

• Preload Images downloads the images when the page loads. If this option 
isn’t selected, there may be a delay when the user moves the pointer over the 
rollover image.

• Select Show “Down Image” Initially to display the selected element in its 
Down state when the page is displayed instead of its default Up state. For 
example, when the home page loads, the “Home” element on the navigation 
bar should be in its Down state. 

When this option is selected, an asterisk appears after the element in the Nav 
Bar Elements list.

5 Under Insert, select from these options:

• To choose whether to insert the navigation bar elements vertically or 
horizontally in the document, use the Insert pop-up menu.

• To insert the navigation bar elements as a table, select the Use Tables checkbox.

6 Click the Plus (+) button to add another element to the navigation bar, then 
follow steps 2 through 5 to repeat until you’ve defined all elements.

7 Click OK.
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Modifying a navigation bar 

Once you create a navigation bar for a document, you can add images to or 
remove them from the navigation bar by using the Modify Navigation Bar 
command. You can use this command to change an image or set of images, to 
change which file opens when an element is clicked, to select a different window 
or frame in which to open a file, and to reorder the images.

To modify a navigation bar:

1 Choose Modify > Navigation Bar.

2 In the Nav Bar Elements list, select the element you want to edit.

3 Make your edits, then click OK.

Attaching behaviors to links
You can attach a behavior to any link in a document. Consider using the following 
behaviors when inserting linked elements into your documents. For more 
information, see “Attaching a behavior” on page 439.

Set Text of Status Bar determines the text of a message and displays it in the 
status bar at the bottom left of the browser window. For example, you can use this 
action to describe the destination of a link in the status bar instead of showing the 
URL associated with it. See “Set Text of Status Bar” on page 463.

Open Browser Window is used to open a URL in a new window. You can specify the 
properties of the new window, including its size, attributes (whether it is resizable, 
has a menu bar, and so on), and name. See “Open Browser Window” on page 456.

Jump Menu is used to edit a jump menu. You can change the menu list, specify a 
different linked file, or change the browser location in which the linked document 
opens. See “Jump Menu” on page 455.

Set Nav Bar Image lets you change how a navigation bar behaves. Use this behavior 
to customize how the images in a navigation bar display. For example, when the 
pointer is over part of the navigation bar, the display of other images in the 
navigation bar or in the document change. See “Set Nav Bar Image” on page 460.
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CHAPTER 16

Reusing Content with Templates 
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and Libraries

The Assets panel (see “Managing and Inserting Assets” on page 221) provides 
access to all of the assets in your site. Macromedia Dreamweaver provides two 
special “linked” categories of assets: templates and libraries. A page that uses a 
linked asset is automatically updated when you change the linked asset.  

Dreamweaver templates and libraries can help you create Web pages with a 
consistent design. Using templates and libraries also makes it easier to maintain your 
Web site, since you can redesign your site and change hundreds of pages in seconds.

A template is a document you can use to create multiple pages that share the same 
layout. When you create a template, you can indicate which elements of a page 
should remain constant (noneditable, or locked) in documents based on that 
template, and which elements can be changed.

For example, if you’re publishing an online magazine, the masthead and overall 
layout probably won’t change from one issue to the next, or even from one story in 
the magazine to the next, but the title and content of each story will be different. 
A designer can create the layout of a story page for the magazine, with placeholder 
text where the story’s title and contents will be (and with those regions marked as 
editable); the designer can then save that layout as a template. The person putting 
together a new issue of the magazine creates a new page based on the template, 
and replaces the placeholder text with the actual title and text of the new story.

You can modify a template even after you’ve created documents based on it. When 
you modify a template, the locked (noneditable) regions in documents that are 
based on the template are updated to match the changes to the template.

Note: If you open a template file, you can edit everything in that file, whether it’s marked as 
editable or locked. If you open a document that is based on a template file, you can edit 
only the regions that are marked as editable. So the terms editable and locked refer to 
whether a region is editable in a document based on a template, not to whether the region 
is editable in the template file itself.
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Templates are best for situations in which you want a set of pages to have an 
identical layout—where you want to design the complete final layout for a set of 
pages first, and then add content later. If you simply want your pages to have the 
same headers and footers, with different layouts in between, use library items to 
store the headers and footers. (Library items are stored page elements that you can 
reuse in multiple pages; as with templates, you can update all the pages that use a 
library item whenever you change the item’s contents. For more information, see 
“Creating, managing, and editing library items” on page 396.) It’s important to 
note that for pages created with templates, you can’t convert tables to layers or 
layers to tables.

Note: Using a template may limit your later changes to design and layout. If you intend 
to make major layout changes to your pages later, you may want to use library items 
instead of templates.

Templates are particularly useful in a collaborative environment in which a 
designer controls the page layouts, and other people add content to the pages but 
aren’t allowed to change the layout. 

Dreamweaver also provides other kinds of reusable content: server-side includes 
and library items. You might use these elements for content that appears on every 
page of the site (such as a header or footer) or for content that appears on only a 
few pages but must be updated frequently (such as news headlines or sales 
discounts). These approaches are appropriate for different kinds of sites:

• Server-side includes can be used only for sites that are viewed from a server, not 
for sites that are viewed on a local system without a server. They can be seen 
only on servers that are configured to process server-side includes. (Ask your 
webmaster or system administrator whether your Web server supports server-
side includes.) See “Using server-side includes” on page 404.

• Library items can be used on sites that are viewed locally as well as those that 
reside on a server. On sites that are viewed locally, without a server, you must 
use library items rather than server-side includes. See “Creating, managing, and 
editing library items” on page 396.
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Creating templates
You can create a template from an existing HTML document and then modify it 
to suit your needs, or you can create a template from scratch, starting with a blank 
HTML document.

Dreamweaver saves templates with the file extension .dwt in a folder named 
Templates in your site’s local root folder. If the Templates folder does not already 
exist, Dreamweaver creates it when you save a new template.

Note: Do not move your templates out of the Templates folder, or put any nontemplate files 
in the Templates folder. Also, do not move the Templates folder out of your local root folder. 
Doing so causes errors in paths in the templates.

If you want to store additional information about a template, such as who created 
it or when it was last changed or why you made certain layout decisions, you can 
create a Design Notes file for the template. The documents based on the template 
do not inherit the template’s Design Notes. (For more information, see “About 
Design Notes” on page 134.)

Most template-related operations are available only when the Design view is 
active. If a template-related command is dimmed when the Code view is active, 
click in the Design view.

To save an existing document as a template:

1 Choose File > Open and select a document.

2 When the document opens, choose File > Save as Template.

Note: If the document is based on a template, you must detach it from that template 
before you can save the document as a template in its own right.

3 In the dialog box that appears, select a site from the pop-up menu, then enter a 
name for the template in the Save As box.

4 Click Save.

The template file is saved in the site’s Templates folder, with a .dwt file extension.

To create a new, blank template:

1 Choose Window > Templates.

The Assets panel appears, with the Templates category selected.

2 In the Assets panel, click the New Template button at the bottom of the 
Assets panel.

A new, untitled template is added to the list of templates in the panel. 

3 While the template is still selected, enter a name for the template.
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To edit the template file that a document is based on:

Choose Modify > Templates > Open Attached Template.

To edit a template file:

1 Choose Window > Templates.

The Assets panel appears, open to the Templates category. The bottom pane of 
the Assets panel lists all of the available templates for your site. The top pane 
displays a preview of the selected template.

2 In the Assets panel, do one of the following:

• Double-click the name of the template.

• Click the Edit Template button at the bottom of the Assets panel. 

3 Edit the template in the Document window. Create editable regions in the 
template as desired (see “Defining a template’s editable regions” on page 381).

4 Save the edited template by choosing File > Save. 

Note: If you haven’t defined any editable regions, you’ll be warned at this point that 
your template contains no editable regions. You can save the template anyway, and you 
can modify the template file even if it doesn’t contain editable regions, but you won’t be 
able to modify documents based on the template until you’ve created an editable region 
in the template.

To rename a template in the Assets panel:

1 Click the name of the template once to select it.

2 After a brief pause, click again.

3 When the name becomes editable, enter a new name.

Note: This method of renaming works the same way that renaming a file in Windows 
Explorer (Windows) or the Finder (Macintosh) does. As with Windows Explorer and the 
Finder, be sure to pause briefly between clicks. Do not double-click the name; that 
opens the template for editing.

4 Click elsewhere, or press Enter (Windows) or Return (Macintosh).

5 Dreamweaver asks if you want to update documents that are based on 
this template.

• To update all documents in the site that are based on this template, 
click Update.

• To refrain from updating any documents that are based on this template, click 
Don’t Update. A document that you choose not to update is still based on the 
template (not detached); to update such a document later, open the template 
and choose Modify > Templates > Update.
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To delete a template file:

1 Select the template in the Assets panel.

2 Click the Delete button and confirm that you want to delete the template. (Be 
careful; if you delete a template file, you can’t retrieve it.)

The template file is deleted from your site. Documents that were based on this 
template are not detached from the template; they retain the structure and 
editable regions that the template file had before it was deleted. To turn such a 
document into a normal HTML file without editable or locked regions, use 
Modify > Templates > Detach from Template. For more information, see 
“Detaching a document from a template” on page 391.

Setting template page properties

Documents created from a template inherit the template’s page properties, except 
for the page title. If a document is based on a template, you can change that 
document’s title, but any changes you make to its other page properties are 
ignored. If you apply a template to a document and then you need to change the 
document’s page properties, you must modify the template’s page properties and 
then update the pages that use the template. (Which means that the page 
properties of all documents based on that template are modified.)

To modify the template’s page properties:

1 Open the template file and choose Modify > Page Properties. 

2 Specify the desired options for the page and click OK.

3 Update the pages based on the template, if any; for further information, see 
“Updating pages based on a template” on page 391.

To learn more about page properties, see “Setting document properties” on page 152.
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About links in templates

To create a link in a template file, use the folder icon or the Point-to-File icon in 
the Property inspector; don’t type in the name of the file to link to. If you type the 
name, the link may not work as expected. The following information explains 
why this problem occurs and provides an example of a situation in which you 
might encounter it.

When you create a template file by opening an existing page and then saving that 
page as a template, Dreamweaver ensures that all links in the page continue to 
point to the same files they pointed to before. Since templates are saved in a 
special template folder, this means that the path shown for a document-relative 
link changes when you save the page as a template. Don’t be concerned about this 
change; when you create a new document based on that template, and then save 
the new document, all the document-relative links are updated to continue to 
point to the correct files, just as you would expect.

When you add a new document-relative link to a template file, however, if you 
type the path into the link text box in the Property inspector, it’s easy to enter the 
wrong path by mistake. The correct path is the path from the Templates folder to 
the document you’re linking to, not the path from the document folder.

To avoid this problem, use the folder icon or the Point-to-File icon to select files to 
link to. For information about linking using the Point-to-File icon, see “Linking 
documents using the Property inspector and the Point-to-File icon” on page 359.

The following example demonstrates the problem. Suppose you have a site 
in which individual catalog pages (called gadgets.html, gewgaws.html, and 
thingamajigs.html) are based on a template file called Catalog_Page.dwt. The 
site’s folder structure looks like this: 
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Suppose you want each page based on the template to contain a link pointing to 
the file home.html. You open the Catalog_Page template to add the link, and you 
select the image that you want to attach the link to. But if you type home.html 
into the link text box in the Property inspector, you’ll encounter the document-
relative link problem: when you save the edited template, the documents based on 
the template will point to the wrong place, because the link in the template file is 
interpreted as relative to the Templates folder rather than relative to the Catalog 
folder. That is, the home.html link in the template file points to home.html in the 
Templates folder, instead of to ../Catalog/home.html. When Dreamweaver 
updates the documents based on the template, it modifies the document-relative 
links in the documents; for documents in the Catalog folder, a link in the 
template file to ../Catalog/home.html is converted to home.html, but a link in the 
template file to home.html is converted to ../Templates/home.html.

If you select the home.html file using the folder icon or the Point-to-File icon 
rather than typing its name manually, Dreamweaver automatically updates all 
documents based on the template to use the correct relative paths to home.html.

Note: In some cases (such as file paths in event handlers in templates) you can’t use the 
folder icon or the Point-to-File icon; in those cases, be sure to enter the correct path by hand.

Defining a template’s editable regions
In a template, editable regions are the parts of the page that can be changed in files 
based on the template—for example, the text of an article in a newsletter would 
appear in an editable region, so that every article could contain different text. 
Locked (noneditable) regions are the parts of the page layout that remain constant 
from one page to another. 

All regions in a new template are locked when you create the template, so to make 
the template useful, you must make some regions editable (unlock them).

While you are editing the template file itself, you can make changes to both 
editable and locked regions. In a document based on the template, however, you 
can make changes only to the editable regions of the document; the locked regions 
of the document can’t be modified.

Note: When you name a region, you can’t use the following characters: single or double 
quotation marks (' "), angle brackets (< >), and ampersands (&). 
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To define existing template content as an editable region:

1 In the template file, select the text or content you want to change to an 
editable region.

2 Do one of the following:

• Choose Modify > Templates > New Editable Region.

• Right-click (Windows) or Control-click (Macintosh) the selected text, and 
choose New Editable Region from the context menu.

3 In the New Editable Region dialog box, enter a unique name for the region. 
(You cannot use the same name for more than one editable region in a 
particular template.)

The editable region is enclosed in a highlighted rectangular outline in the 
template, using the highlighting color set in preferences. A tab at the upper left 
corner of the region shows the name of the region.

You can mark an entire table or an individual table cell as editable; however, 
you can’t mark multiple table cells as a single editable region. Note that 
Dreamweaver does not distinguish between marking a table cell as editable and 
marking the contents of the cell as editable.

Layers and layer content are separate elements; making a layer editable lets you 
change the position of the layer as well as its contents, while making a layer’s 
contents editable lets you change only the content of the layer, not its position. 
To select the layer’s content, click in the layer and choose Edit > Select All; to 
select the layer itself, make sure invisible elements are showing, then click the 
icon representing the location of the layer. For more information about layers, 
see “Using Dynamic Layers” on page 407.

Note: If you’ve made a layer’s contents editable, and you later want to also make its 
position editable, you must remove the editable region around the contents before you 
can mark the layer itself as editable. See “Locking an editable region” on page 387.

To insert an empty editable region in a template:

1 In the template, place the insertion point where you want to insert an 
editable region.

2 Choose Modify > Templates > New Editable Region.

3 In the New Editable Region dialog box, enter a name for the region.

The region name, surrounded by braces ({}), is inserted into the template as a 
placeholder, enclosed in a rectangular outline of the appropriate highlight color.

When you apply the template to a document, you can then select the braces 
and region name and replace them with text, images, or other content.
Chapter 16382



Setting template preferences

You can use the Dreamweaver highlighting preferences to customize the highlight 
colors for the outlines around the editable and locked regions of a template. 
The editable region color appears in the template itself as well as in documents 
based on the template; the locked region color appears only in documents based 
on the template.

To change template highlight colors:

1 Choose Edit > Preferences and select the Highlighting category.

2 Click the Editable Regions color box and select a highlight color using the 
color picker (or enter the hexadecimal value for the highlight color in the text 
box). Do the same for Locked Regions. For information about using the color 
picker, see “Working with colors” on page 87.

3 Click the Show option to enable or disable the display of these colors in the 
Document window.

4 Click OK.

To view highlight colors in the Document window:

Choose View > Visual Aids > Invisible Elements.

Highlight colors appear in the document window only when View > Visual Aids > 
Invisible Elements is enabled and the appropriate options are enabled in 
Highlighting preferences.

Note: If invisible elements are showing but the highlight colors are not, choose Edit > 
Preferences and make sure that the Show option next to the appropriate highlight color is 
selected. Also make sure that the chosen color is visible against the background color of 
your page. (If you’re color-blind, you may need to change the highlight color from its default 
to a more visible color.)
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Viewing editable and locked regions

In template files and documents based on templates, editable regions appear in the 
Document window’s Design view surrounded by rectangular outlines in the 
appropriate highlight color.  A small tab appears at the upper left of each editable 
region, showing the name of the editable region.

In template files, only editable regions are marked with highlighted outlines. You 
can make changes to both editable and locked content.

Both locked and 
editable regions 
can be modified

Editable regions are 
surrounded by 
highlighted outlines
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In documents based on templates, in addition to the editable-region outlines, the 
entire page is surrounded by a different-colored outline, with a tab at the upper 
right giving the name of the template that the document is based on. This 
highlighted rectangle is there to remind you that the document is based on a 
template and that you can’t change anything outside the editable regions.

Note: If you try to edit a locked region in a document based on a template when 
highlighting is turned off, the mouse pointer changes to indicate that you can’t click in 
a locked region. 

Only editable 
regions can 
be modified

Highlighted 
boundary 
around page
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Viewing editable and locked HTML source code

Editable content is marked in HTML with the Dreamweaver comments 
#BeginEditable and #EndEditable. Everything between those comments is 
editable. The HTML source code for an editable region named Edit_Region 
might look like this:

<!-- #BeginEditable "Edit_Region" -->
{Edit_Region}

<!-- #EndEditable -->

The HTML for an editable table named Editable_Table might look like this:

<!-- #BeginEditable "Editable_Table" -->
<table width="77%" border="1">

<tr> 
<td>&nbsp;</td>
<td>&nbsp;</td>

</tr>
</table>
<!-- #EndEditable -->

In template files, editable regions are not highlighted in the Document window’s 
Code view (or the Code inspector); you can make changes to both editable and 
locked HTML source code.
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For documents based on templates, if syntax coloring is enabled, locked regions 
are highlighted in the code editors. (For information about enabling syntax 
coloring, see “Setting Code view (or Code inspector) options” on page 333.) You 
can make changes only to the editable (nonhighlighted) HTML source code. 

Note: Dreamweaver does not prevent you from typing in locked regions in the Code 
inspector or the Code view of the Document window. However, Dreamweaver discards all 
changes you make to locked regions, so be careful to type only in editable regions.

Locking an editable region

If you’ve marked a region of your template file as editable and you want to lock it 
(make it noneditable) again, use the Remove Editable Region command. 

Note: You can’t lock a region in a file based on a template; you can lock a region only in a 
template file.

To lock a region (make it noneditable) in a template file:

1 Choose Modify > Templates > Remove Editable Region. 

2 Select the region name from the list and click OK. 

The region is locked. It no longer has a name (since only editable regions 
are named).

Only editable
HTML can be

modified

Locked
HTML is

highlighted
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Using styles, timelines, behaviors, and head tags in templates

CSS styles, timelines, behaviors, and head section tags are not fully supported in 
documents based on templates.

All of those elements insert information in the head section of a document. Since 
the head section of a document based on a template is locked (except for the 
document’s title), Dreamweaver can’t insert a style sheet or JavaScript code in such 
a document. To use these items in a document based on a template, you must add 
them to the template file that the document is based on. (To allow a style sheet in 
a template file to be editable without having to update pages every time you 
change the style sheet, use an external style sheet.)

If adding these elements to the template file isn’t possible, you can detach the 
document from the template, which makes the head section editable. However, 
after you detach the document from the template, the document will no longer 
update when you change the template. See “Detaching a document from a 
template” on page 391.

For more information about these elements, see “Using CSS style sheets” on page 
248, “Animating your layers” on page 425, and “Using Behaviors” on page 435.

Creating documents based on templates
You can use a template as a starting point for a new document, or apply a template 
to an existing document.

When you create a new document based on a template, you can choose whether 
the document will remain attached to the template. By default, when you change 
a template, a document based on that template is updated to reflect changes in the 
template. But if you deselect the Update Page When Template Changes option in 
the New from Template dialog box, the new document is created as stationery: a 
copy of the template that’s an independent HTML file, with no locked or editable 
regions. In that case, updating the template does not change the document. In 
other words, deselecting this option is equivalent to creating a new document 
based on a template and then detaching the document from the template.

Note: The option of not updating the document when the template changes is provided for 
those who want to use templates like stationery files—a one-time starting point, to create 
completely independent documents. If you want to use the Dreamweaver default template 
behavior, in which documents based on a template are updated when the template 
changes, leave the option selected.
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To create a new document based on a template, do one of the following:

• Choose File > New from Template. In the dialog box that appears, choose a 
template. (If you don’t want your new document to update when the template 
changes, deselect Update Page When Template Changes.) Then click Select.

• Choose File > New to create a new document, and then apply a template to it 
by selecting a template in the Templates category of the Assets panel and 
clicking the Apply button. (Alternatively, you can drag a template from the 
Assets panel to the document.)

To apply a template to an existing Dreamweaver document:

Open the document. Then do one of the following:

• Click in the Document window’s Design view, then choose Modify > 
Templates > Apply Template to Page. Choose a template from the list and 
click Select.

• Select the template in the Templates category of the Assets panel, and click the 
Apply button.

• Drag the template from the Templates category of the Assets panel to the 
Document window’s Design view.

Note: Saying that a template has been applied to a document is equivalent to saying that 
the document is based on the template. Those phrases are used interchangeably.

When you apply a template to an existing document that isn’t already based on a 
template, Dreamweaver turns the document into a copy of the template file, 
placing the material from the document’s existing body section into a single 
editable region of your choice. 

Note: Behaviors and other scripts in the existing document that are associated with body 
content remain in the head section of the document after you apply a template to it. 
Other head items in the existing document, such as meta tags, are discarded when 
you apply the template.

When you apply a new template to an existing document that’s based on another 
template, Dreamweaver turns the document into a copy of the new template, 
placing the material from the document’s existing editable regions into 
corresponding editable regions of the new template wherever possible. 
Dreamweaver does this by comparing the names of the editable regions in the 
document to the names of the editable regions in the new template; for each 
region name that matches, Dreamweaver places the existing contents of that 
region into the new region with the same name.
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For example, suppose you want to try out a new look for your site but you aren’t 
ready to change all of your pages yet. You can create a new template with the new 
layout and design, giving the editable regions in the new template the same names 
as the editable regions in your old template; then when you apply the new 
template to one of your pages, the material in the editable regions of the page is 
placed in the corresponding editable regions of your new layout.

If there are editable regions in the old template that don’t have corresponding 
regions in the new template, the Choose Editable Region for Orphaned Content 
dialog box asks you which new editable region the old “orphaned” content should 
be moved to. Choose an editable region name; all of the content from 
nonmatching editable regions is appended to the region you choose. (All of the 
orphaned content from the existing document must go into a single editable 
region.) If you select the (None) item instead of a region name, the content from 
nonmatching regions in the existing document is discarded.

If you think that the editable regions of your document match the editable regions 
of the new template you’re applying, but the orphaned-content dialog box appears 
anyway, you can click Cancel and the new template will not be applied to the 
document. Then you can examine the editable regions in the document and the 
editable regions in the new template to find out which editable regions in the 
document do not appear in the new template. You can then add new regions with 
those names to the new template file.

Any new editable regions that are in the new template (but weren’t in the old 
template) are added to the document. The new regions contain the default 
placeholder text given in the new template file.

After you’ve applied a template to a document, if the results aren’t what you 
expected, you can use Edit > Undo Apply Template to revert to the document’s 
state before the template was applied. 

Finding a document’s editable regions

All of the editable regions in a template’s body are listed at the bottom of the 
Modify > Templates submenu. Use this list to select and edit the regions.

To find an editable region and select it in the document:

Choose Modify > Templates, and choose the name of the region from the list at 
the bottom of that submenu. 

The region is selected in the document. You can type new text in the region, or 
click in the region to edit the contents.
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Detaching a document from a template

To make changes to both the locked and editable regions of a page that uses a 
template, you must first detach the page from the template. When the page is 
detached, it becomes a normal document, with no editable or locked regions, and 
no connection to any template file. Note that this means that the page will no 
longer be updated when the template is updated.

To detach a document from a template:

1 Open the document you want to detach.

2 Choose Modify > Templates > Detach from Template.

The page is detached from the template and all regions become editable.

Updating pages based on a template
When you make a change to a template, Dreamweaver prompts you to update the 
pages based on the template. You can also use the update commands to manually 
update the current page or the entire site. Using the update commands is the same 
as reapplying the template.

For information on editing templates, see “Creating templates” on page 377 and 
“Defining a template’s editable regions” on page 381.

To open and modify the template used to create the current document:

1 Choose Modify > Templates > Open Attached Template.

2 Modify the content of the template as desired. To modify the template’s page 
properties, choose Modify > Page Properties. (Documents based on a template 
inherit the template’s page properties, except for the page title.) 

To update the current document to use the current version of a template:

Choose Modify > Templates > Update Current Page. 
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To update the entire site or all documents that use a particular template:

1 Choose Modify > Templates > Update Pages. 

The Update Pages dialog box appears.

2 In the Look In pop-up menu, do one of the following:

• Choose Entire Site, and then choose the site name from the adjacent 
pop-up menu. This updates all pages in the selected site to their 
corresponding templates.

• Choose Files That Use, and then choose the template name from the 
adjacent pop-up menu. This updates all pages in the current site that 
use the selected template.

3 Make sure Templates is selected in the Update option. (To update library items 
at the same time, make sure Library Items is also selected. See “Creating, 
managing, and editing library items” on page 396 for more information.)

4 Click Start.

Dreamweaver updates the files as indicated. If you selected the Show Log 
option, Dreamweaver provides information about the files it attempts to 
update, including information on whether they were updated successfully.

Exporting and importing XML content
You can think of a document based on a template as containing a set of data 
represented by name/value pairs. Each pair consists of the name of an editable 
region, and the contents of that region. For example, suppose your template 
contains three editable regions: item_number, item_price, and item_color. You 
could fully describe a document based on that template by providing the name of 
the template and three name/value pairs, one for each editable region.

Dreamweaver lets you export those name/value pairs into an XML file so that you 
can work with the data from the document outside of Dreamweaver (in an XML 
editor, for example, or a text editor, or even a database application). Conversely, if 
you have an XML document that’s structured appropriately, you can import the 
data from it into a document based on a Dreamweaver template. 
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To export a document’s editable regions as XML:

1 Choose File > Open, and open a document that’s based on a template (and 
contains editable regions).

2 Choose File > Export > Export Editable Regions as XML. 

3 In the XML dialog box, choose a tag notation and click OK.

See “Using XML tag notations” on page 395 for details.

4 In the dialog box that appears, enter a name for the XML file and click Save.

Dreamweaver generates an XML file containing the material from the 
document’s editable regions. The XML file includes the name of the 
template the document is based on, as well as the name and contents of 
each editable region.

Note: Material in the locked regions is not exported to the XML file.

To import XML content:

1 Choose File > Import > Import XML into Template.

2 Select the XML file and click Open.

Dreamweaver creates a new document based on the template specified in the 
XML file. It then fills in the contents of each editable region in that document 
using the data in the XML file. The resulting document appears in a new 
Document window. If the specified template is not found, Dreamweaver prompts 
you to select a template to use.

Note that if your XML file isn’t set up exactly the way Dreamweaver expects, you 
may not be able to import your data. One solution to this problem is to export a 
dummy XML file from Dreamweaver, so that you’ll have an XML file with exactly 
the right structure. Then copy the data from your original XML file into the 
exported XML file. The result is an XML file with the correct structure that 
contains the appropriate data, all ready to be imported.
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About XML

XML is the Extensible Markup Language, a markup language for structured 
documents. You can think of it as being like a generalization of HTML that lets 
you define your own tags. XML is derived from SGML, the Standard Generalized 
Markup Language; like SGML, XML is a language for defining sets of tags and 
the relationships among them.  

Tags in XML look similar to HTML tags: they consist of a tag name plus optional 
attributes, surrounded by angle brackets. As with HTML, an opening tag and a 
closing tag (in which the tag name is preceded by a slash) are used to mark the 
content between the tags. One syntactical difference is that in XML, an empty 
tag (one that uses only a single tag, such as <img>, instead of an opening tag and a 
closing tag containing text or other material) must end with a slash just before the 
closing angle bracket. For example, an <img> tag in XML might look like this:

<img src="test.png" />

True XML is much stricter and less forgiving about its syntax than HTML is; files 
that do not strictly conform to XML syntax are rejected by XML parsers.

XML provides a way to mark literal strings, which can include tags that should 
not be parsed: an element called a CDATA section, which includes a literal string in 
square brackets. Anything inside the square brackets is not parsed by the XML 
parser. Dreamweaver exported XML makes extensive use of CDATA sections.

A full introduction to XML is beyond the scope of this book. For more information 
about XML, see “HTML and Web technologies resources” on page 25.
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Using XML tag notations

Dreamweaver lets you export XML content using either of two tag notations: 
editable region name tags or standard Dreamweaver XML tags. Choose the 
notation that best suits how XML content is incorporated into your Web site.

The easiest way to see the differences between the two tag notations, if you 
understand XML syntax, is to look at examples. The following XML code was 
exported from a document based on a template named newstemplate. The 
document contains one defined editable region, named News_Story (and a 
default editable region, doctitle, which contains the document’s title tag).  

• Editable region name tags use the names of your document’s editable regions as 
XML tags. The content from each editable region is included as a CDATA 
section. In this example, the doctitle tag identifies the title of the document, 
and the News_Story tag identifies the editable region.

<?xml version="1.0"?>
<newstemplate template="/Templates/newstemplate.dwt">

<doctitle>
<![CDATA[<title>Today’s Headline Story</title>]]>

</doctitle>
<News_Story>

<![CDATA[<p>This is where the story goes.</p>]]>
</News_Story>

</newstemplate>

• Standard Dreamweaver XML tags use a tag named item. The item tag has a name 
attribute that gives the name of the editable region; the tag contains a CDATA 
section that in turn contains the contents of the editable region. In this example, 
the item tag with name="doctitle" identifies the title of the document, and the 
item tag with name="News_Story" identifies the editable region.

<?xml version="1.0"?>
<templateItems template="/Templates/newstemplate.dwt">

<item name="doctitle">
<![CDATA[<title>Today’s Headline Story</title>]]>

</item>
<item name="News_Story">

<![CDATA[<p>This is where the story goes.</p>]]>
</item>

</templateItems>
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Creating, managing, and editing 
library items
Libraries are a way to store page elements such as images, text, and other objects 
that you want to reuse or update frequently throughout your Web site. These 
elements are called library items.  

When you place a library item in a document, Dreamweaver inserts a copy of the 
HTML source code for that item into the document, and adds an HTML 
comment containing a reference to the original, external item. The reference to 
the external library item makes it possible to update the content on an entire site 
all at once by changing the library item and then using the update commands in 
the Modify > Library submenu.

Dreamweaver stores library items in a Library folder within the local root folder 
for each site. Each site has its own library; to copy a library item from one site to 
another site, use the Assets panel’s Copy to Site command. See “Managing and 
Inserting Assets” on page 221 for more information. Note that if the library item 
contains links, the links may not work in the new site. Also note that images in a 
library item aren’t copied to the new site.

Here’s an example of how you might use a library item: suppose you’re building a 
large site for a company. The company has a slogan that it wants to appear on 
every page of the site, but the marketing department is still ironing out the details 
of just what the slogan should say. If you create a library item to contain the 
slogan and use that library item on every page, then when the marketing 
department provides the final slogan, you can change the library item and 
automatically update every page that uses it.

Creating a library item

You can create a library item from any element in the body section of a document, 
including text, tables, forms, Java applets, plug-ins, ActiveX elements, navigation 
bars, and images.

For linked items such as images, the library stores only a reference to the item. The 
original file must remain at the specified location for the library item to work 
correctly. It can still be useful to store an image in a library item, though; for 
example, you could store a complete img tag in a library item, which would allow 
you to easily change the image’s alt text, or even its src attribute, throughout the 
site. (Don’t use this technique to change an image’s width and height attributes, 
though, unless you also use an image editor to change the actual size of the image.)

Library items can also contain behaviors, but there are special requirements for 
editing the behaviors in library items; see “Editing a behavior in a library item” on 
page 401. Library items cannot contain timelines or style sheets, because the code 
for those elements is part of the head section.

Note: In general, be cautious about mixing library items and templates on the same page; 
the results may sometimes be confusing.
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To create a library item:

1 Select a portion of a document to save as a library item.

2 Do one of the following:

• Choose Window > Library and drag the selection into the Library category of 
the Assets panel.

• Click the New Library Item button at the bottom of the Assets panel (in the 
Library category).

• Choose Modify > Library > Add Object to Library.

3 Enter a name for the new library item.

Each library item is saved as a separate file (with the file extension .lbi) in the 
Library folder of the site’s local root folder.

Setting library preferences

You can customize the highlight color for library items and show or hide 
highlighting of library items by setting Highlighting preferences. 

To change the highlight color for library items:

1 Choose Edit > Preferences and select the Highlighting category.

2 Click the Library Items color box and select a highlight color using the color 
picker (or enter the hexadecimal value for the highlight color in the text box). For 
information about using the color picker, see “Working with colors” on page 87.

3 Select Show to toggle the display of the library highlight color.

4 Click the Show control to enable or disable the display of library-item 
highlighting in the Document window.

5 Click OK to close the Preferences dialog box. 

To view highlight colors in the Document window:

Choose View > Visual Aids > Invisible Elements.

Highlight colors appear in the document window only when View > Visual Aids > 
Invisible Elements is enabled and the appropriate options are enabled in 
Highlighting preferences.
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Inserting a library item in a document

When you add a library item to a page, the actual content is inserted in the 
document along with a reference to the library item.

To insert a library item in a document:

1 Place the insertion point in the Document window.

2 Choose Window > Library.

The Assets panel appears, showing the Library category.

3 Drag a library item from the Assets panel to the Document window, or select 
an item and click the Insert button.

To insert the contents of a library item without including a reference to the 
item in the document, press Control (Windows) or Option (Macintosh) while 
dragging an item out of the Library category of the Assets panel. If you insert 
an item this way, you can edit the item in the document, but the document 
won’t update when you update pages that use that library item.

Making changes to a library item

When you change a library item, you can choose to update all documents that use that 
item. If you choose not to update, the documents remain associated with the library 
item; you can update them later by choosing Modify > Library > Update Pages.

Other kinds of changes to library items include renaming items to break their 
connection with documents or templates, deleting items from the site’s library, 
and recreating a missing library item.

Note: The CSS Styles panel, Timelines panel, and Behaviors panel are unavailable when 
you are editing a library item, because library items can contain only body elements. 
Timeline and CSS style sheet code is part of the head section, and the Behaviors panel is 
unavailable because it inserts code into the head section as well as the body section. (For 
instructions on editing behaviors, see “Editing a behavior in a library item” on page 401.) 
The Page Properties dialog box is also unavailable, because a library item can’t include a 
body tag or its attributes.

To edit a library item:

1 Choose Window > Library.

The Library category of the Assets panel appears.

2 Select a library item.

A preview of the library item appears at the top of the Assets panel. (You can’t 
edit anything in the preview.)
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3 Click the Edit button at the bottom of the Assets panel. Alternatively, double-
click the library item.

Dreamweaver opens a new window for editing the library item. This window is 
much like a Document window, but its Design view has a gray background to 
indicate that you’re editing a library item instead of a document.

4 Edit the library item and then save your changes.

5 In the dialog box that appears, choose whether to update the documents on the 
local site that use the edited library item:

• Choose Update to update all documents in the local site with the edited 
library item.

• Choose Don’t Update to avoid changing any documents until you use 
Modify > Library > Update Current Page or Update Pages.

To update the current document to use the current version of all library items:

Choose Modify > Library > Update Current Page. 

To update the entire site or all documents that use a particular library item:

1 Choose Modify > Library > Update Pages.

The Update Pages dialog box appears.

2 In the Look In pop-up menu, do one of the following:

• Choose Entire Site, and then choose the site name from the adjacent 
pop-up menu. This updates all pages in the selected site to use the current 
version of all library items.

• Choose Files That Use, and then choose a library item name from the 
adjacent pop-up menu. This updates all pages in the current site that use 
the selected library item.

3 Make sure Library Items is selected in the Update option. (To update templates 
at the same time, make sure Templates is also selected. See “Updating pages 
based on a template” on page 391 for more information.)

4 Click Start.

Dreamweaver updates the files as indicated. If you selected the Show Log 
option, Dreamweaver provides information about the files it attempts to 
update, including information on whether they were updated successfully.
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To rename a library item in the Assets panel:

1 Click the name of the library item once to select it.

2 After a brief pause, click again.

3 When the name becomes editable, enter a new name.

Note: This method of renaming works the same way that renaming a file in Windows 
Explorer (Windows) or the Finder (Macintosh) does. As with Windows Explorer and the 
Finder, be sure to pause briefly between clicks. Do not double-click the name; that 
opens the library item for editing.

4 Click elsewhere, or press Enter (Windows) or Return (Macintosh).

5 Dreamweaver asks if you want to update documents that use the item. 

• To update all documents in the site that use the item, click Update.

• To refrain from updating any documents that use the item, click Don’t Update.

To delete a library item from a library:

1 Select the item in the Library category of the Assets panel.

2 Click the Delete button and confirm that you want to delete the item. 

Be careful; if you delete a library item, you can’t use Undo to retrieve it. You 
may be able to recreate it, however, as described in the next procedure.

Deleting a library item removes the item from the library, but doesn’t change 
the contents of any documents that use the item.

To recreate a missing or deleted library item:

1 Select an instance of the item in one of your documents.

2 Click the Recreate button in the Property inspector.
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Making library items editable in a document 

If you’ve added a library item to your document and you want to edit the item 
specifically for that page, you must break the link between the item in the 
document and the library. Once you’ve made an instance of a library item 
editable, that instance cannot be updated when the library item changes.

To make a library item editable:

1 Select a library item in the current document.

2 Click Detach from Original in the Property inspector.

The selected instance of the library item loses its highlighting (if you had 
highlighting visible), and can no longer be updated when the original 
library item changes.

Editing a behavior in a library item

When you create a library item that includes an element with a Dreamweaver 
behavior attached to it, Dreamweaver copies the element and its event handler 
(the attribute that specifies which event triggers the action (such as onClick, 
onLoad, or onMouseOver), and which action to call when the event occurs) to the 
library item file. Dreamweaver does not copy the associated JavaScript functions 
into the library item. Instead, when you insert the library item into a document, 
Dreamweaver automatically inserts the appropriate JavaScript functions into the 
head section of that document (if they aren’t already there).

Note: If you hand-code JavaScript (that is, if you create it without using Dreamweaver 
behaviors), you can make it part of a library item if you use the Call JavaScript behavior to 
execute the code. If you don’t use a Dreamweaver behavior to execute the code, the code 
isn’t retained as part of the library item.

The JavaScript functions are not stored with the library item because they are 
elements of the head section of the document, while library items can only 
contain body elements. Thus, the Behaviors panel is unavailable when you are 
editing a library item, because only part of the behavior code (the event handler) 
is included in the library item. To edit a behavior in a library item, you must first 
insert the item in a document, then make the item editable in that document. 
After you’ve made the desired changes, you can re-create the library item, 
replacing the item in the library with the edited item from your document.

For more information about behaviors, see “Using Behaviors” on page 435.
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To edit a behavior in a library item:

1 Open a document that contains the library item.

Note the name of the library item, as well as the exact tags it contains. You’ll 
need this information in steps 8 and 9.

2 Select the library item and click Detach from Original in the 
Property inspector.

3 Select the element that has the behavior attached to it.

4 Choose Window > Behaviors to open the Behaviors panel. In the Behaviors 
panel, double-click the action you want to change.

5 In the dialog box that appears, make the necessary changes and click OK.

6 Choose Window > Library to open the Library category of the Assets panel.

7 Make sure you have recorded the exact name of the original library item; then 
select the original library item, and delete it by clicking the Delete button in 
the Assets panel.

8 In the Document window, select all of the elements that make up the 
library item.

Be careful to select exactly the same elements that were in the original 
library item.

9 In the Assets panel, click the New Library Item button, and give the new item 
the same name as the item you deleted in step 7. 

Be sure to use exactly the same spelling and capitalization.

10 To update the library item in your site’s other documents, choose Modify > 
Library > Update Pages.

11 In the Update Pages dialog box, in the Look in pop-up menu, select 
Files That Use.

12 In the adjacent pop-up menu, choose the name of the library item 
you just created.

13 In the Update option, make sure Library Items is selected, and then click Start.

14 When the updates are complete, click Close to exit the Update Pages dialog box.
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Setting Library item properties

Use library item properties to specify the source file of an item, to make it 
editable, or to re-create the original library item after editing an instance of it in a 
document. To open the Property inspector, select a library item in a document.

Src displays the file name and location of the source file for the library item. You 
can’t edit this information.

Open opens the library item’s source file for editing. This is equivalent to selecting 
the item in the Assets panel and clicking the Edit button.

Detach from Original breaks the link between the selected library item and its source 
file. When an item is detached it can be edited in the document, but it’s no longer a 
library item and can’t be updated when you change the original library item.

Recreate overwrites the original library item with the current selection. Use this 
option to re-create library items if the original library item is missing or has been 
accidentally deleted.  
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Using server-side includes
Server-side includes are instructions to the server to include a specified file in the 
current document before sending the document to the user who requested it. (You 
can think of it as something like a library item that’s provided by the server.)   

When you open a document that’s on a server, the server processes the include 
instructions and creates a new document in which the include instructions are 
replaced by the contents of the included file. The server then sends this new 
document to your browser. When you open a local document in a browser, 
however, there’s no server to process the include instructions in that document, so 
the browser opens the document without processing those instructions, and the 
file that’s supposed to be included doesn’t appear in the browser. It can thus be 
difficult, without using Dreamweaver, to look at local files and see them as they’ll 
appear to visitors after you’ve put them on the server.

With Dreamweaver, though, you can preview documents just as they’ll appear 
after they’re on the server, both in the Design view and when you preview in a 
browser. To display included files, Dreamweaver uses a translator to mimic the 
way a server would process the include instructions.

Placing a server-side include in a document inserts a reference to an external file; it 
doesn’t insert the contents of the specified file in the current document. 
Dreamweaver displays the contents of the external file in the Document window, 
making it easier to design pages, but you cannot edit the included file directly in a 
document. To edit the contents of a server-side include, you must directly edit the 
file that you’re including. Any changes to the external file are automatically 
reflected in every document that includes it.

There are two types of server-side includes: Virtual and File. Choose which to use 
depending on what type of Web server you use:

• If your server is an Apache Web server, choose Virtual. (This is the default 
choice in Dreamweaver.) In Apache, Virtual works in all cases, while File works 
only in some cases.

• If your server is a Microsoft IIS server, choose File. (Virtual works with IIS only 
in certain specific circumstances.) Unfortunately, IIS won’t allow you to include 
a file in a folder above the current folder in the folder hierarchy, unless special 
software has been installed on the server. If you need to include a file from a 
folder higher in the folder hierarchy on an IIS server, ask your system 
administrator if the necessary software is installed.

• For other kinds of servers, or if you don’t know what kind of server you’re 
using, ask your system administrator which option to use.
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Some servers are configured to examine all files to see if they contain server-side 
includes; other servers are configured to examine only files with a particular file 
extension, such as .shtml, .shtm, or .inc. If a server-side include isn’t working for 
you, ask your system administrator if you need to use a special extension in the 
name of the file that uses the include. (For example, if the file is named 
canoe.html, you may have to rename it to canoe.shtml.) If you want your files to 
retain .html or .htm extensions, ask your system administrator to configure the 
server to examine all files (not just files with a certain extension) for server-side 
includes. Parsing a file for server-side includes takes a little extra time, though, so 
pages that the server parses are served a little more slowly than other pages; some 
system administrators therefore won’t provide the option of parsing all files.

To insert a server-side include:

1 Choose Insert > Server-Side Include or click the SSI button in the Common 
category of the Objects panel.

2 In the dialog box that appears, browse to and select a file.

To change which file is included:

1 Select the server-side include in the Document window.

2 Open the Property inspector.

3 Do one of the following:

• Click the folder icon and browse to and select a new file to include.

• In the text box, type the path and file name of the new file to include.
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Editing the contents of a server-side include

Like library items, server-side includes are selected as a whole unit in the 
Document window. Unlike library items, for server-side includes the HTML 
source code contained in the included file does not appear in the Code inspector 
or the Code view of the Document window. Instead, the actual server instruction 
appears, looking (for example) like this:

<!--#include virtual="/uber/html/footer.html" -->

To edit the content associated with the included file, you must open the file.

Note: Server-side includes cannot contain head or body tags.

To edit a server-side include:

1 Select the server-side include in either the Document window or the Code 
inspector, and click Edit in the Property inspector.

The included file opens in a new Document window.

2 Edit the file; then save it.

The changes are immediately reflected in the current document and in any 
subsequent document you open that includes the file. 
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Using Dynamic Layers

A layer is a container in your Web page that holds HTML page elements. Using 
layers in your page gives you more control and flexibility to make your page 
dynamic. Layers were created for use in Web design to give designers the same 
kind of control and flexibility that they have in traditional print design.   

You can stack one layer on top of another, hide some layers while showing others, 
or move a layer across the screen with a timeline. For example, you could have a 
background image on one layer, then stack another layer on top that holds text. 
You could also have images on your page that appear and then fade off the page. 
All of this can be done using layers in Macromedia Dreamweaver, without having 
to do any JavaScript or HTML coding.

A disadvantage to using layers in your Web page is that layers are not widely 
viewable in older Web browsers. Only Internet Explorer 4.0 and Netscape 4.0 and 
above browsers show layers, and not always consistently. In order for everyone to 
be able to view your Web page, you can use layers in conjunction with tables. You 
can design your page layout using layers, then convert the layers to tables. For 
more information, see “Using tables and layers for layout” on page 421.

Note: It is recommended that you use Layout view for page layout (See “Designing Page 
Layout” on page 167). Layout view is an easier way to implement your page layout with 
tables as the underlying structure.
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About layers and HTML code
When you insert layers into your Web page, Dreamweaver inserts the HTML tag 
for those layers in your code. You can set four different tags for your layers: div, 
span, layer, and ilayer. div and span are the most common tags and are 
recommended for use so that the widest audience will be able to view your layers. 
Both Internet Explorer 4.0 and Netscape Navigator 4.0 support layers created 
using the div and span tags. Only Navigator 4.0 versions support layers created 
with the layer and ilayer tags (Netscape discontinued support in later 
browsers). Earlier versions of both browsers display the contents of a layer but do 
not display the positioning.

By default, Dreamweaver creates layers with the div tag and inserts layer code at 
the insertion point, or at the top of the page, just after the body tag. If you create 
a nested layer, Dreamweaver inserts the code inside the tag that defines the parent 
layer. To change the default tag, see “Setting Layers preferences” on page 412.

The following is sample HTML code for a single layer (as it would look in 
Dreamweaver):

<div id="Layer1" style="position:absolute; visibility:inherit; 
width:200px; height:115px; z-index:1">
</div>

The following is sample HTML code for a nested layer (as it would look in 
Dreamweaver):

<div id="Parent" style="position:absolute; left:56px; top:54px; 
width:124px; height:158px; z-index:1;">
Content inside the parent layer. 

<div id="Nested" style="position:absolute; left:97px; top:114px; 
width:54px; height:69px; z-index:1;">
Content inside the nested layer. 
</div>
</div>

You can set properties for positioning the layers on your page. These properties 
include left and top (x and y coordinates, respectively), z-index (also called the 
stacking order), and visibility. For more information, see “Setting layer properties” 
on page 417.
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Creating layers on your page
Dreamweaver allows you to create layers on your page easily and precisely. You can 
draw a layer on the page, insert a layer through the menu, or drag it onto your 
page. Create as many layers as you need to hold all of your page elements.

You can also create a layer within another layer (nest), put layers on top of each 
other (stacking), or hide certain layers while showing others. Use the Layers panel 
to easily manage your layers and perform these actions. For more information, see 
“About the  Layers panel” on page 410.

Each layer that you create in your page has certain default characteristics, such as 
tag, visibility, height and width, and so on. To change the default settings, choose 
Edit > Preferences and select Layers. For more information about these 
characteristics, see “Setting Layers preferences” on page 412.

If you don’t want your layers to overlap each other as you create them on the page, 
turn on the Prevent Overlaps option in the Layers panel or choose Modify > 
Arrange > Prevent Layer Overlaps. See “Preventing layer overlaps” on page 423.

To create a layer, do one of the following:

• To draw a layer, click the Draw Layer button in the Objects panel, then drag to 
draw the layer in the Document window.

• To insert a layer, place the insertion point in the Document window where you 
want the layer to go and then choose Insert > Layer.

• To drag and drop a layer, drag the Draw Layer button from the Objects panel 
to the Document window. 

To draw more than one layer at a time, click the Draw Layer button in the Objects 
panel and hold down Control (Windows) or Command (Macintosh) as you draw 
out all the layers. You can continue to draw new layers as long as you do not 
release the Control key.

If you have Invisible Elements turned on, a layer marker will appear in the 
Document window each time you draw a layer on the page. If layer markers aren’t 
visible and you want to see them, choose View > Visual Aids > Invisible Elements. 
For more information, see “Setting Invisible Elements preferences” on page 156.
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Note: When the Invisible Elements option is turned on, the elements on your page may 
appear to shift position. Invisible elements are visible only in the Document window, so 
when you view your page in a browser, everything will appear in the correct position.

About the  Layers panel

The Layers panel is a way to manager the layers in your document. Choose 
Window > Layers or press F11 to open the Layers panel. Layers are displayed as a 
stacked list of names; the first created layer at the bottom of the stacking order, 
and the most recently created layer at the top of the stacking order. Nested layers 
are displayed as names connected to parent layers. Click the expander arrow to 
show or hide nested layers.

Use the Layers panel to prevent overlaps, to change the visibility of layers, to nest 
or stack layers, and to select one or more layers.
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Nesting layers

A nested layer is a layer created inside another layer. Use the Layer panel or the 
insertion, drag and drop, or drawing technique to create nested layers.

Nesting is often used to group layers together. A nested layer moves with its parent 
layer and can be set to inherit visibility from its parent. 

If you want to force layers to automatically nest as you draw them on the page, set 
the Layer preferences. Choose Edit > Preferences, then select Layers and select the 
Nesting check box. All layers that you draw inside other layers will then 
automatically be nested. For more information, see “Setting Layers preferences” 
on page 412.

Note: Use the Netscape Resize Fix when you use nested layers in your page (Commands > 
Add/Remove Netscape Resize Fix). Otherwise, layers will lose their position in 4.0 versions 
of Netscape. 

To create a nested layer, do one of the following:

• To insert a nested layer, place the insertion point inside an existing layer and 
choose Insert > Layer.

• To drag and drop a nested layer, drag the Draw Layer button from the Objects 
panel, then drop it inside an existing layer.

• To draw a nested layer, click the Draw Layer button in the Objects panel, then 
drag to draw the layer inside another layer. If Nesting is turned off in Layers 
preferences, press and hold Alt (Windows) or Option (Macintosh) to draw a 
layer inside an existing layer.

To create a nested layer using the Layers panel:

1 Choose Window > Layers or press F11 to open the Layers panel.

2 Select a layer in the Layers panel, then press and hold the Control key 
(Windows) or Command key (Macintosh) and drag it to the target layer in the 
Layers panel.

3 Release the mouse button when a box appears around the name of the 
target layer. 
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Setting Layers preferences

Use layer preferences to define the default settings for new layers you create. 
Choose Edit > Preferences, then click Layers to change layer preferences. 

Tag set the default HTML tag to use when creating layers. The options are DIV 
(default), span, layer, or ilayer. div or span are recommended to ensure that 
the layers work in all 4.0 and later browsers. layer and ilayer only work in 
Netscape 4.x browsers.

Visibility determines whether layers are visible by default.

Width and Height set the default width and height of layers created by 
Insert > Layer.

Background Color specifies the default background color. Select the color from the 
color picker.

Background Image specifies a default background image. Click Browse to locate 
the file on your computer, or enter the path to the image file in the text box.

Nesting makes a layer drawn within the boundaries of an existing layer a nested 
layer. Hold down Alt (Windows) or Option (Macintosh) to temporarily change 
this setting while you’re drawing a layer.

Netscape 4 Compatibility inserts JavaScript in the head content of a document 
and fixes a known problem in Netscape 4.x browsers that causes layers to lose their 
positioning coordinates when a user resizes their browser window. The JavaScript 
forces the page to reload each time the browser window is resized, re-assigning the 
layers to the correct position. You can also add or remove the JavaScript, by 
choosing Commands > Add/Remove Netscape Resize Fix.

Manipulating layers
As you work with your page layout, layers can be selected, resized, or activated. 
You must select a layer before you can move, resize, or align it. Resizing layers lets 
you change the dimensions of a single layer or make two or more layers the same 
height and width. Activating layers only lets you place content in them. 

To prevent layers from overlapping each other as you move and resize them, use 
the Prevent Overlap option. See “Preventing layer overlaps” on page 423.
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Selecting layers

Select one or more layers to make them the same width and height, reposition 
them, align them, and so on. For a complete list of options, see “Setting layer 
properties” on page 417.

To select a layer, do one of the following:

• Click the name of the layer in the Layers panel.

• Click a layer’s selection handle. If the handle isn’t visible, click anywhere inside 
the layer to make it visible.

• Click a layer’s border. 

• If no layers are active or selected, Shift-click inside a layer.

• If multiple layers are selected, Control-Shift-click (Windows) or Command-
Shift-click (Macintosh) inside a layer. This will deselect all other layers and 
select only the one that you chose.

• Click the layer marker in the Document window that represents the layer’s 
location in the HTML code. If the layer marker isn’t visible, choose View > 
Visual Aids > Invisible Elements. 

To select multiple layers, do one of the following:

• Shift-click two or more layer names in the Layers panel.

• Shift-click inside or on the border of two or more layers.

When multiple layers are selected, the handles of the last selected layer are 
highlighted in black. The handles of the other layers are highlighted in white.
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Resizing layers

You can resize an individual layer or simultaneously resize multiple layers to make 
them the same width and height.

If the Prevent Overlaps option is on, you will not be able to resize a layer so that it 
overlaps with another layer. See “Preventing layer overlaps” on page 423.

To resize a layer, do one of the following:

• To resize by dragging, select the layer and drag any of its resize handles.

• To resize 1 pixel at a time, select the layer and press Control-arrow (Windows) 
or Option-arrow (Macintosh). 

• To resize by the grid snapping increment, press Shift-Control (Windows) or 
Option (Macintosh), while pressing an arrow key. For information about setting 
the grid snapping increment, see “Snapping layers to the grid” on page 416.

• In the Property inspector, type a value for width and height.

Resizing a layer changes the width and height of the layer. It does not define how 
much of the layer’s content is visible. To define the visible region within a layer, see 
“Setting layer properties” on page 417.

To resize multiple layers:

1 In the Document window, select two or more layers. 

2 Do one of the following:

• Choose Modify > Align> Make Same Width or Modify > Align > 
Make Same Height. 

The first selected layers will conform to the width or height of the last selected 
layer (highlighted in black).

• In the Property inspector, under Multiple Layers, enter width and height 
values. The values are applied to all selected layers.
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Moving layers

Moving layers in the Document window will be familiar to anyone who has 
worked with basic graphics applications.

If the Prevent Overlaps option is on, you will not be able to move a layer so that it 
overlaps another layer. See “Preventing layer overlaps” on page 423.

To move one or more layers, do one of the following:

• To move by dragging, select the layers and drag the selection handle of the last 
selected layer (highlighted in black).

• To move 1 pixel at a time, select the layers and use the arrow keys. Use Shift 
and an arrow key to move the layer by the current grid snapping increment. For 
information about setting the grid snapping increment, see “Snapping layers to 
the grid” on page 416.

Aligning layers

Use the layer alignment commands to align one or more layers with a border of 
the last layer selected.

When you align layers, child layers that aren’t selected may move because their 
parent layer is selected and moved. To prevent this, don’t use nested layers.

To align two or more layers:

1 Select the layers. 

2 Choose Modify > Align, then select an alignment option. 

For example, if you select Top, all of the layers move so that their top borders are 
in the same vertical position as the top border of the last selected layer 
(highlighted in black).
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Snapping layers to the grid

Use the grid as a visual guide for positioning or resizing layers in the Document 
window. You can turn this grid on to use as a guide when you draw your layers. 
You can also have your layers automatically snap to the grid, and change the grid 
or control the snapping behavior by specifying grid settings. Snapping works 
regardless of whether the grid is visible. 

To display the grid, do one of the following:

• Choose View > Grid > Show Grid.

• Choose View > Grid > Edit Grid and select the Show Grid option.

To snap a layer:

1 Choose View > Grid > Snap To Grid to turn snapping on (or to turn it off ).

2 Select the layer and drag it. The layer jumps to the nearest snapping position.

To change grid settings:

1 Click View > Grid > Edit Grid to open the Grid Settings dialog cell.

2 Do any of the following:

• Click the arrow next to the color swatch and select a color from the palette or 
type the hexadecimal number in the cell. This controls the color of the grid lines.

• Select Show Grid to show the grid in the Document window.

• Select Snap to Grid to enable snapping. 

• Type the amount of spacing you want and select Pixels, Inches, or Centimeters 
from the pop-up menu. This controls how far apart the grid lines will appear.

• Choose lines or dots for the grid lines.

3 Click Apply to view the changes, then OK to close the dialog box.

Making layers active

Before you place objects in a layer, you must activate the layer. Activating a layer 
places the insertion point in the layer, highlights the layer’s border, and displays 
the selection handle, but it does not actually select the layer.

To activate a layer:

Click anywhere inside the layer.
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Setting layer properties 
Use the Property inspector to specify the name and location of a layer as well as to 
set other layer options. To see all of the following properties, click the expander 
arrow in the lower right corner of the Property inspector.

Layer ID allows you to specify a name to identify the layer in the Layers panel and 
for scripting. Enter a name in the unlabeled box on the left side of the Property 
inspector. Use only standard alphanumeric characters for a layer name. Do not use 
special characters such as spaces, hyphens, slashes, or periods. Every layer must 
have its own unique name.

L and T (left and top) specify the position of the layer relative to the top left corner 
of the page or parent layer (if nested).

W and H specify the width and height of the layer. These values are overridden if 
the content of the layer exceeds the specified size. 

If you have div or span set as the default tag, the default values for location and 
size are in pixels (px). You can also specify the following units: pc (picas), pt 
(points), in (inches), mm (millimeters), cm (centimeters), or % (percentage of the 
parent’s value). The abbreviations must follow the value without a space: for 
example, 3mm. The Overflow setting controls how layers react when the content 
exceeds the layer’s size.

Z-Index determines the z-index, or stacking order, of the layer. Higher-numbered 
layers appear above lower-numbered layers. Values can be positive or negative. It’s 
easier to change the stacking order of layers using the Layers panel than to enter 
specific z-index values. See “Changing the stacking order of layers” on page 420.

Netscape layers (those with the layer or ilayer tag) can also be stacked relative 
to other layers on the page. When you select a Netscape layer, two additional 
options appear in the lower right corner of the Property inspector. Use the A/B 
option to select a relative stacking position and then choose the name of another 
layer from the pop-up menu directly to the right. (A specifies a layer above the 
current layer; B specifies a layer below the current layer.)
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Vis determines the initial display condition of the layer (visible or not). Use a 
scripting language, such as JavaScript, to control the visibility property and 
dynamically display layer contents. Choose from the following options:

• Default does not specify a visibility property, but most browsers interpret 
this as Inherit.

• Inherit uses the visibility property of the layer’s parent. 

• Visible displays the layer contents, regardless of the parent’s value.

• Hidden hides the layer contents, regardless of the parent’s value. Note that hidden 
layers created with ilayer still take up the same space as if they were visible. 

Bg Image specifies a background image for the layer. Click the folder icon to 
Browse to and select an image file, or type the path for the image in the text field.

Bg Color specifies a background color for the layer. Leave this option blank to 
specify a transparent background.

Tag determines the HTML tag to be used. span and div are recommended. 
layer and ilayer create Netscape Navigator layers, but are only viewable in 
Netscape Navigator 4 browsers.

Overflow determines what happens if the contents of a layer exceed its set size. 
Choose from the following options:

• Visible increases the layer size so that all of the layer’s contents ares visible. The 
layer expands downward and to the right.

• Hidden maintains the layer’s size and clips any content that doesn’t fit. No 
scroll bars are provided.

• Scroll adds scroll bars to the layer regardless of whether the contents exceed the 
layer’s size. Specifically providing scroll bars avoids confusion resulting from the 
appearance and disappearance of scroll bars in a dynamic environment. This 
option works only in browsers that support scroll bars.

• Auto makes scroll bars appear only when the layer’s contents exceed 
its boundaries.

Clip defines the visible area of a layer and can be used to cut content from the edges 
of the layer. Specify values that represent the distance in pixels from the layer’s 
boundaries. T (top) and L (left) settings are relative to the layer, not to the page.

Use Left, Top or PageX, PageY (layer and ilayer only) lets you position a layer 
in relation to its parent. The Left, Top option places the layer in relation to the top 
left corner of its parent. The PageX, PageY option places the layer in an absolute 
location relative to the top left corner of the page, regardless of the position of the 
parent layer.

Src (later and ilayer only) lets you display another HTML document within 
the layer. Click the folder icon to browse to and select the document, or type the 
path of the document. Note that Dreamweaver does not display this property in 
the Document window. 
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A/B (layer and ilayer only) specifies the layer above (A) or below (B) the 
current layer in the stacking order (z-index). Only layers previously defined in the 
document will appear in the list of layer names to the right of the A/B menu.

Setting properties for multiple layers

When you select two or more layers, the layer Property inspector displays text 
properties and a subset of the regular layer properties, allowing you to modify 
several layers at once. To select multiple layers, press Shift while selecting layers. 
See “Manipulating layers” on page 412.

L and T specify the position of the layers relative to the top left corner of the page 
or parent layer.

W and H specify the width and height of the layers. These values are overridden if 
the content of the layers exceeds the specified size. 

If you have div or span set as the default tag, the default values for location and 
size are in pixels (px). You can also specify the following units: pc (picas), pt 
(points), in (inches), mm (millimeters), cm (centimeters), or % (percentage of the 
parent’s value). The abbreviations must follow the value without a space: for 
example, 3mm. 

Vis determines the initial display condition of the layers. Choose from the 
following options:

• Default does not specify a visibility property, but most browsers interpret 
this as Inherit.

• Inherit uses the visibility property of the layer’s parent. 

• Visible displays the layer contents, regardless of the parent’s value.

• Hidden displays the layer contents as transparent, regardless of the parent’s 
value. Note that hidden layers created with layer and ilayer still occupy the 
same space as if they were visible. 

Tag determines the HTML tag to be used. span and div are recommended. 
layer and ilayer create Netscape Navigator layers, but are only viewable in 
Netscape 4 browsers

Bg Image specifies a background image for the layers. Click the folder icon to 
browse to and select an image file, or type the path for the image in the text field. 

Bg Color specifies a background color for the layers. Leave this option blank to 
specify a transparent background.
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Changing the stacking order of layers
Use the Property inspector or the Layers panel to change the stacking order 
of layers. The layer at the top of the Layers panel list is at the top of the 
stacking order.

In HTML code, the stacking order, or z-index, determines the order in which 
layers are drawn in a browser. You can change the z-index for each layer using the 
Layers panel or using the Property inspector.

To change the stacking order of layers in the Layers panel:

Choose Window > Layers to open the Layers panel. Then do one of the following:

• Select and drag a layer up or down to the desired stacking order. You’ll see a line 
appear as you move the layer. Release the mouse button when the placement 
line appears in the desired stacking order.

• In the Z column, click the number of the layer you are changing. Type a higher 
number than the existing number to move the layer up in the stacking order, or 
type a lower number to move the layer down in the stacking order.

To change the stacking order of layers using the Property inspector:

1 Choose Window > Layers to open the Layers panel to see the current 
stacking order.

2 Select a layer in the Layers panel or in the Document window.

3 In the layer Property inspector, type a number in the Z-index field. 

• Type a higher number to move the layer up in the stacking order.

• Type a lower number to move the layer down in the stacking order.

Changing layer visibility
While working on your document, you can show and hide layers to see how the 
page will appear under different conditions. Use the Layers panel to change the 
visibility of layers. Use the Layer preferences panel to set the default visibility for 
new layers. See “Setting Layers preferences” on page 412.
Chapter 17420



To change layer visibility:

1 Choose Window > Layers to open the Layers panel.

2 In the row of the layer you’re affecting, click in the eye-icon column so you can 
set the desired visibility.

• An open eye means the layer is visible. 

• A closed eye means the layer is invisible. 

• If there is no eye icon, the layer inherits visibility from its parent. (When layers 
are not nested, the parent is the document body, which is always visible.) 

To change the visibility of all layers at once: 

1 Choose Window > Layers to open the Layers panel.

2 Click the header eye icon at the top of the column.

Using tables and layers for layout
Instead of using layout cells and tables in layout view to create your layout (see 
“Designing Page Layout” on page 167), some users prefer to work with layers and 
tables. Dreamweaver allows you to create your layout using layers, than convert 
them into tables, since 3.0 browsers don’t support layers. You can convert back 
and forth between layers and tables to tweak the layout and optimize page design.

You can’t convert layers to tables or tables to layers in a template document or in a 
document to which a template has been applied. Create your original layout, and 
convert it prior to saving it as a template. 

A single table or layer cannot be converted. You can only convert layers to tables 
and back for the entire page.

If you want to generate 3.0 browser-compatible files from your current file, use 
the Convert option in the File menu. See “Converting to 3.0 version 
compatibility” on page 424.
Using Dynamic Layers 421



Converting between layers and tables

Create your layout using layers, then convert the layers to tables so that your 
layout can be viewed in most browsers.

To convert layers to a table:

1 Choose Modify > Convert > Layers to Table. 

2 In the dialog box that appears, select the desired layout options.

• Most Accurate creates a cell for every layer, plus any additional cells that are 
necessary to preserve the space between layers.

• Smallest: Collapse Empty Cells specifies that the layers’ edges should be aligned 
if they are positioned within the specified number of pixels. If you select this 
option, the resulting table will have fewer empty rows and columns, but may 
not match your layout precisely. 

• Use Transparent GIFs fills the table’s last row with transparent GIFs. This 
ensures that the table is displayed with the same column widths in all browsers. 

When this option is on, you cannot edit the resulting table by dragging its 
columns. When it is off, the resulting table will not contain transparent GIFs, 
but its appearance may vary slightly in different browsers. 

• Center on Page centers the resulting table on the page. 

If this option is off, the table is left aligned. 

3 Select the desired layout tools and grid options, and click OK.

To convert a table to layers:

1 Choose Modify > Convert > Tables to Layers.

2 In the dialog box that appears, select the desired options. 

• Show Grid and Snap to Grid let you use a grid to help position layers. See 
“Snapping layers to the grid” on page 416.

• Prevent Layer Overlaps constrains the positions of layers when they are created, 
moved, and resized so that they don’t overlap. See “Preventing layer overlaps” 
on page 423.

• Show Layers panel displays the Layers panel. See “About the  Layers panel” 
on page 410.

3 Click OK. 

The tables are converted to layers. Empty cells are not converted to layers unless 
they have a background color. 

Note: Page elements that you placed outside of tables in the page are also placed in layers.
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Preventing layer overlaps

Because table cells cannot overlap, Dreamweaver cannot create a table from 
overlapping layers. If you plan to convert the layers in a document to tables for 
compatibility with 3.0 browsers, use the Prevent Overlap option to constrain layer 
movement and positioning so that layers don’t overlap. 

To prevent layers from overlapping:

Choose Modify > Arrange > Prevent Layer Overlaps or select the Prevent Overlaps 
option in the Layers panel.

When this option is on, a layer can’t be created in front of, moved or resized 
over, or nested within an existing layer. If you activate this option after creating 
overlapping layers, drag the overlapping layer to move it away from the 
other layer. Dreamweaver does not automatically fix existing overlapping layers in 
the page when you turn on Prevent Layer Overlaps.

When this option and snapping are enabled, a layer won’t snap to the grid if 
it would cause two layers to overlap. Instead, it will snap to the edge of the 
closest layer. 

Note: Certain actions allow you to overlap layers even when the Prevent Overlaps option is 
on. If you insert a layer from the menu, enter numbers in the Property inspector, or 
reposition layers by editing the HTML source code in the HTML inspector, you can cause 
layers to overlap or nest while the option is turned on. If this happens, drag overlapping 
layers in the Document window to separate them. 
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Converting to 3.0 version compatibility

Use the Convert option in the File menu to create a 3.0 browser-compatible 
version of a page that uses layers. Dreamweaver creates a separate, converted 
document and preserves the original document.

In general, you should convert a document only when you are completely satisfied 
with your original file—otherwise, you must convert the file each time you change 
the original file. 

To convert a file for use with 3.0 browsers:

1 Choose File > Convert > 3.0 Browser Compatible.

2 In the dialog cell that appears, choose whether to convert layers to tables, CSS 
styles to HTML markup (character styles), or both.

3 Click OK.

Dreamweaver opens the converted file in a new, untitled window. If you selected 
Convert Layers to Table or Both, all layers are replaced with a single table that 
preserves the original positioning.

Note: Overlapping layers cannot be converted, nor can layers that are off the page to the 
left or top.

If you selected Convert CSS Styles to HTML Markup or Both, CSS markup is 
replaced, where possible, with HTML character styles. Any CSS markup that 
cannot be converted to HTML is removed. See the “CSS to HTML markup 
conversion table” on page 257 for information on which styles are converted and 
which are removed.

Timeline code that animates layers is removed. Timeline code that is unrelated to 
layers (for example, behaviors or changes to the image source) will execute as 
specified. The timeline is automatically rewound to frame 1. For more 
information about timelines, see “Creating a timeline animation” on page 427.
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Animating your layers
Dynamic HTML, or DHTML, refers to the ability to change style or 
positioning properties of HTML elements with a scripting language. Timelines 
use dynamic HTML to change the properties of layers and images in a series of 
frames over time. Use timelines to create animations that do not require any 
ActiveX controls, plugins, or Java applets (but do require JavaScript). 

Timelines create animation by changing the position, size, visibility, and stacking 
order of a layer over time. Timelines are also useful for other actions that you want 
to occur after a page loads. For example, timelines can change the source file of an 
image tag so different images will appear over a period of time in the page. The 
layer functions of timelines work only in 4.0 or later browsers.

To see the JavaScript code generated by a timeline, open the HTML inspector. 
The timeline code is in the MM_initTimelines function, inside a script tag in 
the head content of the document.

When editing the HTML of a document containing timelines, be careful not to 
move, rename, or delete anything that a timeline refers to. 

Using the Timelines panel

The Timelines panel represents the properties of layers and images over time. 
Choose Window > Timelines to open the Timelines panel. 

Right-click (Windows) or Control-click (Macintosh) the Timelines panel to open 
a context menu that includes all of the relevant commands.

Keyframes

Behaviors channel

Timeline pop-up menu

Animation channel

Animation bars

Playback head

Frame numbers
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Playback head shows which frame of the timeline is currently displayed on the page.

Timeline pop-up menu specifies which of the document’s timelines is currently 
displayed in the Timelines panel.

Animation channels display bars for animating layers and images.

Animation bars show the duration of each object’s animation. A single row can 
include multiple bars representing different objects. Different bars cannot control 
the same object in the same frame.

Keyframes are frames in a bar where you have specified properties (such as 
position) for the object. Dreamweaver calculates intermediate values for frames in 
between keyframes. Small circles mark keyframes.

Behaviors channel is the channel for behaviors that should be executed at a 
particular frame in the timeline.

Frame numbers indicate the sequential numbering of frames. The number between 
the Back and Play buttons is that of the current frame. You control the duration of 
animation by setting the total number of frames and the number of frames per 
second (fps). The default setting of 15 frames per second is a good average rate to 
use for most browsers running on common Windows and Macintosh systems. 
Faster rates may not improve performance. Browsers always play every frame of the 
animation, even if they cannot attain the specified frame rate on the user’s system. 
The frame rate is ignored if it is higher than the browser can manage.

Playback options

Listed below are the playback options for viewing the animation.

Rewind moves the playback head to the first frame in the timeline.

Back moves the playback head one frame to the left. Click Back and hold down 
the mouse button to play the timeline backward.

Play moves the playback head one frame to the right. Click Play and hold down 
the mouse button to play the timeline continuously. 

Autoplay makes a timeline begin playing automatically when the current page 
loads in a browser. Autoplay attaches a behavior to the page’s body tag that 
executes the Play Timeline action when the page loads. 

Loop makes the current timeline loop indefinitely while the page is open in a 
browser. Loop inserts the Go to Timeline Frame behavior in the Behaviors 
channel after the last frame of the animation. Double-click the marker in this 
frame to edit the parameters for this behavior and change the number of loops. 
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Creating a timeline animation

Timelines create animation by changing the position, size, visibility, and stacking 
order of layers. Timelines can also change the source files of images, so you could 
create an image slideshow with timelines.

Timelines can move only layers. To make images or text move, create a layer using 
the Draw Layer button on the Objects panel and then insert images, text, or any 
other type of content in the layer. See “Creating layers on your page” on page 409.

To create a timeline animation:

1 To animate a layer, move the layer to where it should be when the 
animation begins.

2 Choose Window > Timelines. 

3 Select the layer you want to animate. 

Make sure you have selected the desired element. Click the layer marker, the 
layer selection handle, or use the Layers panel to select a layer. See also 
“Manipulating layers” on page 412. When a layer is selected, handles appear 
around it as shown in the following illustration.

Clicking inside the layer places a blinking insertion point inside the layer, but it 
does not select the layer. 

Click the layer marker 
to select the layer

Draw Layer 
button

Selected layer with 
image inside
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4 Choose Modify > Timeline > Add Object to Timeline or simply drag the 
selected object into the Timelines panel.

A bar appears in the first channel of the timeline. The name of the layer 
appears in the bar.

5 Click the keyframe marker at the end of the bar.

6 Move the layer on the page to where it should be at the end of the animation. A 
line appears showing the path of the animation in the Document window.

7 If you want the layer to move in a curve, select its animation bar and Control-
click (Windows) or Command-click (Macintosh) a frame in the middle of the 
bar to add a keyframe at the frame you clicked, or click a frame in the middle of 
the animation bar and choose Add Keyframe from the context menu.

Repeat this step to define additional keyframes.

8 Hold down the Play button to preview the animation on the page. 

Repeat the procedure to add additional layers and images to the timeline and to 
create a more complex animation. 

Creating a timeline by dragging a path

If you want to create an animation with a complex path, it may be more efficient 
to record the path as you drag the layer rather than creating individual keyframes.

To create a timeline by dragging a path:

1 Select a layer.

2 Move the layer to where it should be when animation begins.

Make sure you have selected the right element. Click the layer marker, the 
layer selection handle, or use the Layers panel to select a layer. See also 
“Manipulating layers” on page 412.

3 Choose Modify > Timeline > Record Path of Layer.

4 Drag the layer around the page to create a path.

5 Release the mouse at the point where the animation should stop.

Dreamweaver adds an animation bar to the timeline with the appropriate 
number of keyframes.

6 In the Timelines panel, click the Rewind button; then hold down the Play 
button to preview your animation.
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Modifying timelines

After defining a timeline’s basic components, you can make changes such as 
adding and removing frames, changing the start time of the animation, and so on.

To modify a timeline, do any of the following:

• To make the animation play longer, drag the end frame marker to the right. All 
the keyframes in the animation shift so that their relative positions remain 
constant. To prevent the other keyframes from moving, press Alt (Windows) or 
Option (Macintosh) while dragging the end frame marker.

• To make the layer reach the keyframe position earlier or later, move the 
keyframe marker left or right in the bar. 

• To change the start time of an animation, select one or all of the bars associated 
with the animation (press Shift to select more than one bar at a time) and 
drag left or right.

• To shift the location of an entire animation path, select the entire bar and 
then drag the object on the page. Dreamweaver adjusts the position of all 
keyframes. Making any type of change with an entire bar selected changes 
all the keyframes.

• To add or remove frames in the Timeline, choose Modify > Timeline > Add 
Frame or Modify > Timeline > Remove Frame.

• To make the timeline play automatically when the page opens in a browser, 
click Autoplay. Autoplay attaches a behavior to the page that executes the Play 
Timeline action when the page loads.

• To make the timeline loop continuously, click Loop. Loop inserts the Go To 
Timeline Frame action in the Behaviors channel after the last frame of the 
animation. You can edit the parameters for this behavior to define the 
number of loops.
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Changing image and layer properties with timelines

In addition to moving layers with timelines, you can change the source file of an 
image and the visibility, size, and stacking order of a layer.

To change image and layer properties with a timeline:

1 In the Timelines panel, do one of the following:

• Select an existing keyframe in the bar controlling the object you want to 
change. (The start and end frames are always keyframes.) 

• To create a new keyframe, click a frame in the middle of the animation bar and 
choose Modify > Timeline > Add Keyframe, or Control-click (Windows) or 
Command-click (Macintosh) a frame in the animation bar.

2 Define new properties for the object by choosing one of the following options:

• To change the source file of an image, click the folder icon next to the Src field 
in the Property inspector to browse to and select a new image.

• To change the visibility of a layer, choose inherit, visible, or hidden from the 
pop-up menu in the Vis field of the Property inspector. Or user the eye icons in 
the Layers panel. See “Changing layer visibility” on page 420.

• To change the size of a layer, drag the layer’s resize handles or enter new 
values in the Width and Height fields in the Property inspector. Internet 
Explorer versions 4.0 and later are currently the only browsers that can 
dynamically change the size of a layer.

• To change the stacking order of a layer, enter a new value in the Z-Index field 
or use the Layers panel to change the stacking order of the current layer. See 
“Changing the stacking order of layers” on page 420.

3 Hold down the Play button to see the animation.

The currently selected layer is always visible and at the top of the stacking order. 
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Using multiple timelines

Instead of trying to control all the action on a page with one timeline, it’s easier to 
work with separate timelines that control discrete parts of the page. For example, a 
page might include interactive elements that each trigger a different timeline.

To manage multiple timelines, use the following options:

• To create a new timeline, choose Modify > Timeline > Add Timeline.

• To remove the selected timeline, choose Modify > Timeline > Remove 
Timeline. This permanently removes all animations from this timeline.

• To rename the selected timeline, choose Modify > Timeline > Rename 
Timeline or enter a new name in the Timeline pop-up menu in the 
Timelines panel.

• To view a different timeline in the Timelines panel, choose a new timeline from 
the Timeline pop-up menu in the Timelines panel.

Copying and pasting animations

Once you have an animation sequence that you like, you can copy and paste it in 
another area of the current timeline, in another timeline in the same document, or 
in a timeline in another document. You can also copy and paste multiple 
sequences at one time.

To cut or copy and paste animation sequences:

1 Click an animation bar to select a sequence. To select multiple sequences, 
Shift-click, or press Control+A (Windows) or Command+A (Macintosh) 
to select all sequences.

2 Copy or cut the selection.

3 Do one of the following:

• Move the playback head to another spot in the current timeline.

• Select another timeline from the Timeline pop-up menu.

• Open another document or create a new one and then click in the 
Timeline inspector.

4 Paste the selection into the timeline.

Animation bars for the same object cannot overlap, because a layer cannot be in 
two places at one time (nor can an image have two different sources at one 
time). If the animation bar you are pasting would overlap another animation 
bar for the same object, Dreamweaver automatically shifts the selection to the 
first frame that doesn’t overlap.
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There are two principles to keep in mind when pasting animation sequences into 
another document:

• If you copy an animation sequence for a layer and the new document contains 
a layer with the same name, Dreamweaver applies the animation properties to 
the existing layer in the new document.

• If you copy an animation sequence for a layer and the new document does not 
contain a layer with the same name, Dreamweaver pastes the layer and its 
contents from the original document along with the animation sequence. To 
apply the pasted animation sequence to another layer in the new document, 
choose Change Object from the context menu and select the name of the 
second layer from the pop-up menu. Delete the pasted layer if desired. See 
“Applying an animation sequence to a different object” on page 432.

Applying an animation sequence to a different object

To save time, you can create an animation sequence once and apply it to each of 
the remaining layers in your document.

To apply an existing animation sequence to other objects:

1 In the Timelines panel, select the animation sequence and copy it.

2 Click any frame of the Timelines panel and paste the sequence at that frame.

3 Right-click (Windows) or Control-click (Macintosh) the pasted animation 
sequence and choose Change Object from the context menu.

4 In the dialog box that appears, choose another object from the pop-up menu 
and click OK.

5 Repeat steps 2 through 4 for any remaining objects that you want to follow the 
same animation sequence.

You can also change your mind about which layer should be animated after 
creating an animation sequence; simply follow steps 3 and 4 above (no copying or 
pasting is necessary).
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Animation tips for timelines

The following suggestions can improve the performance of your animations and 
make creating animations easier:

• Show and hide layers instead of changing the source file for multiple-image 
animations. Switching the source file of an image can slow down the 
animation, because the new image must be downloaded. There will be no 
noticeable pauses or missing images if all images are downloaded at once in 
hidden layers before the animation runs.

• Extend animation bars to create smoother motion. If animation looks 
choppy and images jump between positions, drag the end frame of the 
layer’s animation bar to extend the motion over more frames. Making the 
animation bar longer creates more data points between the start and end 
point of the movement and also makes the object move more slowly. Try 
increasing the number of frames per second (fps) to improve speed, but be 
aware that most browsers running on average systems cannot animate much 
faster than 15 fps. Test the animation on different systems with different 
browsers to find the best settings.

• Don’t animate large bitmaps. Animating large images results in slow 
animations. Instead, create composites and move small parts of the image. For 
example, show a car moving by animating only the wheels.

• Create simple animations. Do not create animations that demand more than 
current browsers can provide. Browsers always play every frame in a timeline 
animation, even when system or Internet performance decreases.
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Behavior actions for controlling 
layers timelines
Attach the behavior actions listed here to a link, button, or other object to control 
timelines and layers. To create interesting effects, you can place behaviors 
containing these actions in the Behaviors channel. For example, you can make a 
timeline stop itself. For more information, see “Attaching a behavior to a timeline” 
on page 442 and “Using Behaviors” on page 435.

Drag Layer lets the user drag a layer. Use this action to create puzzles, slider controls, 
and other moveable user interface elements. See “Drag Layer” on page 451.

Show-Hide Layers shows, hides, or restores the default visibility of one or more 
layers. This action is useful for showing information as the user interacts with the 
page. See “Show-Hide Layers” on page 465.

Play Timeline and Stop Timeline let users start and stop a timeline by clicking a 
link or button. These actions can also start and stop a timeline automatically when 
the user rolls over a link, image, or other object. See “Play Timeline and Stop 
Timeline” on page 469.

Go To Timeline Frame causes the timeline to jump to a certain frame. The 
Loop check box in the Timelines panel adds the Go To Timeline Frame 
action after the last frame of the animation, causing it to go to frame 1 and 
start the animation again. See “Go to Timeline Frame” on page 468.

Set Text of Layer replaces the content and formatting of an existing layer on a 
page with the content you specify. The content can include any valid HTML. See 
“Set Text of Layer” on page 462. 
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Using Behaviors

Behaviors allow visitors to interact with a Web page to change the page in various 
ways, or to cause certain tasks to be performed. A behavior is a combination of an 
event with an action triggered by that event. In the Behaviors panel, you add a 
behavior to a page by specifying an action and then specifying the event that 
triggers that action.    

Events are, effectively, messages generated by browsers indicating that a visitor to 
your page has done something. For example, when a visitor moves the pointer 
over a link, the browser generates an onMouseOver event for that link; the browser 
then checks to see whether there’s some JavaScript code it’s supposed to call when 
that event is generated for that link. Different events are defined for different page 
elements; for example, in most browsers onMouseOver and onClick are events 
associated with links, whereas onLoad is an event associated with images and with 
the body section of the document.

An action consists of prewritten JavaScript code that performs a specific task, such 
as opening a browser window, showing or hiding a layer, playing a sound, or 
stopping a Shockwave movie. The actions provided with Macromedia 
Dreamweaver are carefully written by Dreamweaver engineers to provide 
maximum cross-browser compatibility.

After you attach a behavior to a page element, whenever the event you’ve specified 
occurs for that element, the browser calls the action (the JavaScript code) that 
you’ve associated with that event. (The events that you can use to trigger a given 
action vary from browser to browser.) For example, if you attach the Popup 
Message action to a link and specify that it will be triggered by the onMouseOver 
event, then whenever someone points to that link with the mouse pointer in the 
browser, your message pops up in a dialog box.

A single event can trigger several different actions, and you can specify the order in 
which those actions occur.
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Dreamweaver provides about two dozen behavior actions; additional actions can 
be found on the Macromedia Exchange Web site as well as on third-party 
developer sites. (See “Downloading and installing third-party behaviors” on page 
443.) You can write your own behavior actions if you are proficient in JavaScript. 
For more information on writing behavior actions, see Extending Dreamweaver.

Note: The terms behavior and action are Dreamweaver terms, not HTML terms. From the 
browser’s point of view, an action is just like any other piece of JavaScript code.

Using the Behaviors panel
Use the Behaviors panel to attach behaviors to page elements (more specifically to 
tags) and to modify parameters of previously attached behaviors. 

To open the Behaviors panel, choose Window > Behaviors.

The tag that’s currently selected in the Document window appears in the title bar of 
the Behaviors panel. Behaviors that have already been attached to the currently 
selected page element appear in the behavior list (the main area of the panel), listed 
alphabetically by event. If there are several actions for the same event, the actions 
appear in the order in which they will execute. If no behaviors appear in the behavior 
list, then no behaviors have been attached to the currently selected element.

For detailed information about the options in the Behaviors panel, see 
Dreamweaver Help.

About events
The following list describes the events that you can associate with the actions listed 
in the Behaviors panel’s Actions (+) pop-up menu. When a visitor to your Web 
page interacts with the page—for example, by clicking an image—the browser 
generates events; those events can be used to call JavaScript functions that cause an 
action to occur. (Events can also be generated without user interaction, such as 
when you set a page to automatically reload every 10 seconds.) Dreamweaver 
supplies many common actions that you can trigger using these events.

The list also specifies which browsers can generate each event. NS3 means 
Netscape Navigator 3.0; NS4 means Netscape Navigator 4.0; IE3 means Internet 
Explorer 3.0; IE4 means Internet Explorer 4.0. For more information about 
events in Microsoft Internet Explorer, see the Microsoft Dynamic HTML events 
page (listed in “HTML and Web technologies resources” on page 25).
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Note that most events can be used only with certain page elements. To find 
out what events a given browser supports for a given page element, insert the 
page element in your document and attach a behavior to it, then look at the 
Events pop-up menu in the Behaviors panel. For a very detailed advanced look 
at precisely which tags can be used with a given event in a given browser, search 
for the event in one of the files in your Dreamweaver/Configuration/Behaviors/
Events folder.

onAbort (NS3, NS4, IE4, IE5) is generated when the visitor stops the browser 
from completely loading an image (for example, when the visitor clicks the 
browser’s Stop button while an image is loading).

onAfterUpdate (IE4, IE5) is generated when a bound data element on the page 
has finished updating the data source.

onBeforeUpdate (IE4, IE5) is generated when a bound data element on the 
page has been changed and is about to lose focus (and is therefore about to 
update the data source).

onBlur (NS3, NS4, IE3, IE4, IE5) is the opposite of onFocus. The onBlur event 
is generated when the specified element is no longer the focus of the visitor’s 
interaction. For example, when a visitor clicks outside a text field after clicking in 
the text field, the browser generates an onBlur event for the text field.

onBounce (IE4, IE5) is generated when a marquee element’s contents have 
reached the boundary of the marquee.

onChange (NS3, NS4, IE3, IE4, IE5) is generated when the visitor changes a 
value on the page, such as when the visitor chooses an item from a menu, or when 
the visitor changes the value of a text field and then clicks elsewhere on the page. 

onClick (NS3, NS4, IE3, IE4, IE5) is generated when the visitor clicks the 
specified element, such as a link, button, or image map. (The click is not complete 
until the visitor releases the mouse button; use onMouseDown to make 
something happen as soon as the button is pressed down.)

onDblClick (NS4, IE4, IE5) is generated when the visitor double-clicks the 
specified element. (Double-clicking is defined as quickly pressing and releasing the 
mouse button while pointing to the element.)

onError (NS3, NS4, IE4, IE5) is generated when a browser error occurs while a 
page or image is loading.

onFinish (IE4, IE5) is generated when the contents of a marquee element have 
completed a loop.

onFocus (NS3, NS4, IE3, IE4, IE5) is generated when the specified element 
becomes the focus of the visitor’s interaction. For example, clicking in a text field 
of a form generates an onFocus event.

onHelp (IE4, IE5) is generated when the visitor clicks the browser’s Help button 
or chooses Help from a browser menu.
Using Behaviors 437



onKeyDown (NS4, IE4, IE5) is generated as soon as the visitor presses any key. 
(The visitor does not have to release the key for this event to be generated.) The 
browser cannot detect which key has been pressed.

onKeyPress (NS4, IE4, IE5) is generated when the visitor presses and releases any 
key; this event is like a combination of the onKeyDown and onKeyUp events. The 
browser cannot detect which key has been pressed.

onKeyUp (NS4, IE4, IE5) is generated when the visitor releases a key after 
pressing it. The browser cannot detect which key has been pressed.

onLoad (NS3, NS4, IE3, IE4, IE5) is generated when an image or page 
finishes loading.

onMouseDown (NS4, IE4, IE5) is generated when the visitor presses the mouse 
button. (The visitor does not have to release the mouse button to generate this event.)

onMouseMove (IE3, IE4, IE5) is generated when the visitor moves the mouse 
while pointing to the specified element. (That is, the pointer stays within the 
boundaries of the element.)

onMouseOut (NS3, NS4, IE4, IE5) is generated when the pointer moves off the 
specified element. (The specified element is usually an image, or a link attached to 
an image.) This event is often used in conjunction with the Swap Image Restore 
behavior to return an image to its original state when the visitor is no longer 
pointing at it.

onMouseOver (NS3, NS4, IE3, IE4, IE5) is generated when the mouse first 
moves to point to the specified element (that is, when the pointer moves from not 
pointing to the element to pointing to the element). The specified element for this 
event is usually a link.

onMouseUp (NS4, IE4, IE5) is generated when a pressed mouse button is released.

onMove (NS4) is generated when a window or frame moves.

onReadyStateChange (IE4, IE5) is generated when the state of the specified 
element changes. Possible element states include uninitialized, loading, 
and complete.

onReset (NS3, NS4, IE3, IE4, IE5) is generated when a form is reset to its 
default values.

onResize (NS4, IE4, IE5) is generated when the visitor resizes the browser 
window or a frame.

onRowEnter (IE4, IE5) is generated when the current record pointer of the bound 
data source has changed.

onRowExit (IE4, IE5) is generated when the current record pointer of the bound 
data source is about to change.

onScroll (IE4, IE5) is generated when the visitor scrolls up or down.
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onSelect (NS3, NS4, IE3, IE4, IE5) is generated when the visitor selects text 
in a text field.

onStart (IE4, IE5) is generated when a marquee element’s contents begin a loop.

onSubmit (NS3, NS4, IE3, IE4, IE5) is generated when the visitor submits a form.

onUnload (NS3, NS4, IE3, IE4, IE5) is generated when the visitor leaves the page.

Attaching a behavior
You can attach behaviors to the entire document (that is, to the body tag) or to 
links, images, form elements, or any of several other HTML elements. The target 
browser you choose determines which events are supported for a given element. 
Internet Explorer 4.0, for example, has a much wider array of events for each 
element than Navigator 4.0 or any 3.0 browser.

Note: You can’t attach a behavior to plain text. For details, see “About behaviors and text” 
on page 441.

You can specify more than one action for each event. Actions occur in the order in 
which they’re listed in the Actions column of the Behaviors panel. For information 
on changing the order of actions, see “Changing a behavior” on page 442.

To attach a behavior:

1 Select an element on the page, such as an image or a link. 

To attach a behavior to the entire page, click the <body> tag in the tag selector 
at the bottom left of the Document window.

2 Choose Window > Behaviors to open the Behaviors panel.

The HTML tag of the selected object appears in the title bar of the 
Behavior panel. 

3 Click the Plus (+) button and choose an action from the Actions pop-up menu.

Actions that are dimmed in the menu can’t be chosen. They may be dimmed 
because a required object doesn’t exist in the current document. For example, 
the Play Timeline action is dimmed if the document has no timelines, and the 
Control Shockwave or Flash action is dimmed if the document contains no 
Shockwave or Flash movies. If no events are available for the selected object, all 
actions are dimmed.

When you choose an action, a dialog box appears, displaying parameters and 
instructions for the action.
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4 Enter parameters for the action, and click OK.

All actions provided in Dreamweaver work in 4.0 and later browsers. Some 
actions do not work in older browsers. See “Using the behavior actions that 
come with Dreamweaver” on page 444.

5 The default event to trigger the action appears in the Events column. If this 
is not the trigger event you want, choose another event from the Events 
pop-up menu. (To open the Events pop-up menu, select an event or action in 
the Behaviors panel, and click the downward-pointing black arrow that appears 
between the event name and the action name.)

Different events appear in the Events pop-up menu depending on the selected 
object and on the browsers specified in the Show Events For submenu. Events 
may be dimmed if the relevant objects do not yet exist on the page or if the 
selected object cannot receive events. If the expected events don’t appear, make 
sure the correct object is selected, or change the target browsers in the Show 
Events For pop-up menu.

If you’re attaching a behavior to an image, some events (such as onMouseOver) 
appear in parentheses. These events are available only for links. When you 
choose one of them, Dreamweaver wraps an a tag around the image to define a 
null link. The null link is represented by javascript:; in the Property 
inspector’s Link box. You can change the link value if you want to turn it into a 
real link to another page, but if you delete the JavaScript link without replacing 
it with another link, you will remove the behavior.
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About behaviors and text
You can’t attach a behavior to plain text. Tags like p and span don’t generate events 
in browsers, so there’s no way to trigger an action from those tags.

However, you can attach a behavior to a link. Therefore, to attach a behavior to 
text, the easiest approach is to add a null link (that doesn’t point to anything) to 
the text, then attach the behavior to the link. Note that if you do this, your text 
will appear as a link. (You can change the link color and remove the underlining if 
you really don’t want it to look like a link, though site visitors may then be 
unaware that there’s a reason to click that text.)

To attach a behavior to the selected text:

1 In the Property inspector, enter javascript:; in the Link field. Be certain to 
include both the colon and the semicolon.

Note: You can instead use a number sign (#) in the Link field if you want. The problem 
with using a number sign is that when a visitor clicks the link, the browser jumps to the 
top of the page. Clicking the JavaScript null link has no effect at all on the page, so the 
JavaScript approach is generally preferable.

2 With the text still selected, open the Behaviors panel (Window > Behaviors).

3 Choose an action from the Actions pop-up menu, enter parameters for the 
action, and choose an event to trigger the action. For details, see “Attaching a 
behavior” on page 439.

To change the appearance of linked text:

1 Open the Code inspector (Window > Code Inspector) or the Document 
window’s Code view.

2 Find the link.

3 In the link’s a href tag, insert this attribute: style="text-decoration:none; 
color:black". 

This attribute setting disables underlining and sets the color of the text to 
black. (Of course, if the surrounding text is a different color, use that color 
instead of black.)

To change the appearance of linked text everywhere on a page or across your 
entire site, use CSS styles to create a new style for links. For details, see 
“Inserting and Formatting Text” on page 233.
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Attaching a behavior to a timeline
To trigger a behavior at a certain frame in a timeline (rather than having a visitor’s 
interaction trigger it), place the behavior in the timeline. (For information on 
creating a timeline, see “Animating your layers” on page 425.) For example, you 
can start a sound playing at frame 15 of a timeline.

Only one kind of event can trigger an action in a timeline: the animation reaching 
a certain frame number (an onFrame7 event, for example).

The behavior can affect any object on the page, not just objects in the timeline. 
Preview the timeline in a browser to see the behavior working. You cannot preview 
behaviors inside Dreamweaver.

To place a behavior in a timeline:

1 Click in a frame in the Behaviors channel in the Timelines panel.

2 Use the Behaviors panel to choose an action to perform at that frame.

The action appears in the Behaviors panel, with an event indicating the frame 
number at which the action is triggered. A minus sign (–) appears in the 
Behaviors channel of the timeline frame.

Changing a behavior
After attaching a behavior, you can change the event that triggers the action, add 
or remove actions, and change parameters for actions.

To change a behavior:

1 Select an object with a behavior attached.

2 Choose Window > Behaviors to open the Behaviors panel.

Behaviors appear in the panel alphabetically by event. If there are 
several actions for the same event, the actions appear in the order in which 
they will execute.

3 Choose from the following options:

• To edit an action’s parameters, double-click the behavior name, or select it and 
press Enter (Windows) or Return (Macintosh); then change parameters in the 
dialog box and click OK.

• To change the order of actions for a given event, select an action and click the 
up or down arrow button.

• To delete a behavior, select it and click the Minus (–) button or press Delete.
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Updating a behavior
If your pages contain behaviors created with Dreamweaver 1 or Dreamweaver 2, 
those behaviors are not updated automatically when you open the pages in 
the current version of Dreamweaver. However, when you update one occurrence 
of a behavior in a page (by following the procedure below), all other occurrences 
of that behavior in that page are also updated. Behaviors created in Dreamweaver 
3 work without modification in Dreamweaver 4.

To update a behavior in a page:

1 Select an element that has the behavior attached to it.

2 Open the Behaviors panel.

3 Double-click the behavior.

4 Click OK in the behavior’s dialog box.

All occurrences of that behavior in that page are updated.

Creating new actions
Actions consist of JavaScript and HTML code. If you are proficient with 
JavaScript, you can write new actions and add them to the Actions pop-up menu 
in the Behaviors panel. For more information, see Extending Dreamweaver. 

Downloading and installing 
third-party behaviors
One of the most useful features of Dreamweaver is its extensibility—that is, it 
offers users who are proficient in JavaScript the opportunity to write JavaScript 
code that extends Dreamweaver’s capabilities. Many of these users have chosen to 
share their extensions with others by submitting them to the Macromedia 
Exchange for Dreamweaver Web site. 

To download and install new behaviors from the Exchange site:

1 Open the Behaviors panel and choose Get More Behaviors from the 
Actions (+) pop-up menu.

Your primary browser opens, and the Exchange site appears. (You must be 
connected to the Web to download behaviors.)

2 Browse or search for packages.

3 Download and install the extension package you want.

For details, see “Adding extensions to Dreamweaver” on page 93.
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Using the behavior actions that come 
with Dreamweaver
The behavior actions included with Dreamweaver have been written to work in all 
releases of Netscape Navigator 4, and in Internet Explorer 4.0 and later. (Netscape 
Navigator 5 was never released externally; Netscape Navigator 6 has not yet been 
released at the time of this writing.)  

Note: The Dreamweaver actions have been carefully written to work in as many browsers 
as possible. If you remove code from a Dreamweaver action by hand, or replace it with your 
own code, you may lose cross-browser compatibility. 

Although the Dreamweaver actions were written to maximize cross-browser 
compatibility, some actions do not work in older browsers. Also, some browsers 
do not support JavaScript at all, and many people who browse the Web keep 
JavaScript turned off in their browsers. For best cross-platform results, provide 
alternative interfaces enclosed in noscript tags so that people without JavaScript 
can still use your site.

Refer to the following table for details on how actions work in specific pre-4.0 
versions of Navigator and Internet Explorer. For an explanation of what each 
action does and how to choose options for it, see the topics following the table.

Macintosh Windows

Action Netscape 
Navigator 3.0

Internet 
Explorer 3.0x

Netscape 
Navigator 3.0

Internet 
Explorer 3.01

Call JavaScript OK Fails without 
error

OK OK

Change Property OK Fails without 
error

OK OK

Check Browser OK Fails without 
error

OK OK

Check Plugin OK Fails without 
error

OK OK

Control 
Shockwave or 
Flash

OK Fails without 
error

OK Fails without 
error

Drag Layer Fails without 
error

Fails without 
error

Fails without 
error

Fails without 
error

Go to URL OK Fails without 
error

OK OK

Jump Menu OK Fails without 
error

OK Fails without 
error
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Jump Menu Go OK Fails without 
error

OK Fails without 
error

Open Browser 
Window

OK Fails without 
error

OK OK

Play Sound OK Fails without 
error

OK Fails without 
error

Popup Message OK Fails without 
error

OK OK

Preload Images OK Fails without 
error

OK Fails without 
error

Set Nav Bar 
Image 

OK Fails without 
error

OK Fails without 
error

Set Text of 
Frame

OK Fails without 
error

OK OK

Set Text of Layer Fails without 
error

Fails without 
error

Fails without 
error

Fails without 
error

Set Text of 
Status Bar

OK Fails without 
error

OK OK

Set Text of Text 
Field

OK Fails without 
error

OK OK

Show-Hide 
Layers

Fails without 
error

Fails without 
error

Fails without 
error

Fails without 
error

Swap Image OK Fails without 
error

OK Fails without 
error

Swap Image 
Restore

OK Fails without 
error

OK Fails without 
error

Go to Timeline 
Frame

Play Timeline and 
Stop Timeline

Image source 
animation and 
invoking 
behaviors work, 
but layer 
animation fails 
without error

Fails without 
error

Image source 
animation and 
invoking 
behaviors work, 
but layer 
animation fails 
without error

Fails without 
error

Validate Form OK Fails without 
error

OK OK

Macintosh Windows

Action Netscape 
Navigator 3.0

Internet 
Explorer 3.0x

Netscape 
Navigator 3.0

Internet 
Explorer 3.01
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Call JavaScript

The Call JavaScript action lets you use the Behaviors panel to specify that 
a custom function or line of JavaScript code should be executed when an 
event occurs. (You can write the JavaScript yourself, or you can use code 
provided by various freely available JavaScript libraries on the Web.)

To use the Call JavaScript action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Call JavaScript from the 
Actions pop-up menu.

3 Type the exact JavaScript to be executed, or type the name of a function.

For example, to create a Back button, you might type 
if (history.length > 0){history.back()}. If you have encapsulated 
your code in a function, type only the function name (for example, goBack()). 

4 Click OK.

5 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.

Change Property

Use the Change Property action to change the value of one of an object’s 
properties (for example, the background color of a layer or the action of a form). 
The properties you can affect are determined by the browser; many more 
properties can be changed by this behavior in Internet Explorer 4.0 than in 
IE 3.0 or Navigator 3.0 or 4.0. For example, you can set the background color 
of a layer dynamically.

Note: Use this action only if you are very familiar with HTML and JavaScript.
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To use the Change Property action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Change Property from the Actions
pop-up menu.

3 From the Type of Object pop-up menu, choose the type of object whose 
property you want to change.

The Named Object pop-up menu now lists all the named objects of the 
type you chose. 

4 Choose an object from the Named Object pop-up menu.

5 Choose a property from the Property pop-up menu, or enter the name of the 
property in the text field.

To see the properties that can be changed in each browser, choose different 
browsers or browser versions from the browser pop-up menu. If you are typing 
a property name, be sure to use the exact JavaScript name of the property (and 
remember that JavaScript properties are case-sensitive).

6 Enter the new value for the property in the New Value field, and click OK.

7 Check that the default event is the one you want. (When the event occurs, the 
action will execute and the property will change.)

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.

Check Browser

Use the Check Browser action to send visitors to different pages depending on 
their browser brands and versions. For example, you might want visitors to go to 
one page if they have Navigator 4.0 or later, to go to another page if they have 
Internet Explorer 4.0 or later, and to stay on the current page if they have any 
other kind of browser.

It’s useful to attach this behavior to the body tag of a page that is compatible with 
practically any browser (and that does not use any other JavaScript); this way, 
visitors who come to the page with JavaScript turned off will still see something.

Another option is to attach this behavior to a null link (such as 
<a href="javascript:;">) and have the action determine the link’s destination 
based on the visitor’s browser brand and version.
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To use the Check Browser action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Check Browser from the Actions 
pop-up menu.

3 Determine how you want to separate your visitors: by browser brand, by 
browser version, or both.

For example, do you want everyone with a 4.0 browser to see one page, and all 
others to see a different page? Or perhaps you want Netscape Navigator users to 
see one page and Internet Explorer users to see another.

4 Specify a version of Netscape Navigator.

5 In the adjacent pop-up menus, choose options for what to do if the browser is 
the Netscape Navigator version you specified or later and what to do otherwise.

The options are Go to URL, Go to Alt URL, and Stay on This Page.

6 Specify a version of Internet Explorer.

7 In the adjacent pop-up menus, choose options for what to do if the browser is 
the Internet Explorer version you specified or later and what to do otherwise.

The options are Go to URL, Go to Alt URL, and Stay on This Page.

8 Choose an option from the Other Browsers pop-up menu to specify what to do 
if the browser is neither Navigator nor Internet Explorer. (For example, the 
visitor may be using a text-based browser like Lynx.)

Stay on This Page is the best option for browsers other than Navigator and IE 
because most do not support JavaScript—and if they cannot read this behavior, 
they will stay on the page anyway.

9 Enter the paths and file names of the URL and the alternate URL in the text 
fields at the bottom of the dialog box. If you enter a remote URL, you must 
enter the http:// prefix in addition to the www address.

10 Click OK.

11 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu. 
Remember that the purpose of this behavior is to check for different browser 
versions, so it’s best to choose an event that works on 3.0 and later browsers.
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Check Plugin

Use the Check Plugin action to send visitors to different pages depending on 
whether they have the specified plugin installed. For example, you might want 
visitors to go to one page if they have Shockwave and another page if they do not.

Note: You cannot detect specific plugins in Internet Explorer using JavaScript. However, 
selecting Flash or Director will add the appropriate VBScript code to your page to detect 
those plugins in IE on Windows. Plugin detection is impossible in IE on the Macintosh.

To use the Check Plugin action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Check Plugin from the Actions 
pop-up menu.

3 Choose a plugin from the Plugin pop-up menu, or click Enter and type the 
exact name of the plugin in the adjacent field.

You must use the exact name of the plugin as specified in bold on the About Plug-
ins page in Navigator. (In Windows, choose Navigator’s Help > About Plug-ins 
command; on the Macintosh, choose About Plug-ins from the Apple menu.) 

4 In the If Found, Go To URL field, specify a URL for visitors who have the plugin.

If you specify a remote URL, you must include the http:// prefix in the address.

To make visitors with the plugin stay on the same page, leave this field blank.

5 In the Otherwise, Go To URL field, specify an alternative URL for visitors who 
don’t have the plugin.

To make visitors without the plugin stay on the same page, leave this field blank.

6 Plugin detection is not possible in Internet Explorer on the Macintosh, and 
most plugins cannot be detected in Internet Explorer on Windows. By default, 
when detection is impossible, the visitor is sent to the URL listed in the 
Otherwise field. To instead send the visitor to the first (If Found) URL, select 
the Always go to first URL if detection is not possible option. When selected, 
this option effectively means “assume that the visitor has the plugin, unless the 
browser explicitly indicates that the plugin is not present.”

In general, if the plugin content is integral to your page, select the “Always go 
to first URL if detection is not possible” option; visitors without the plugin will 
often be prompted by the browser to download the plugin. If the plugin 
content is not essential to your page, leave this option unselected.

This option applies only to Internet Explorer; Navigator can always detect plugins.

7 Click OK.

8 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu. 
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Control Shockwave or Flash

Use the Control Shockwave or Flash action to play, stop, rewind, or go to a frame 
in a Macromedia Shockwave or Macromedia Flash movie.   

To use the Control Shockwave or Flash action:

1 Choose Insert > Media > Shockwave or Insert > Media > Flash to insert a 
Shockwave or Flash movie, respectively.

2 Choose Window > Properties and enter a name for the movie in the upper 
leftmost field (next to the Shockwave or Flash icon). You must name the movie 
to control it with the Control Shockwave or Flash action.

3 Select the item you want to use to control the Shockwave or Flash movie. For 
example, if you have an image of a “Play” button that will be used to make the 
movie play, select that image.

4 Open the Behaviors panel (Window > Behaviors).

5 Click the Plus (+) button and choose Control Shockwave or Flash from the 
Actions pop-up menu.

A parameters dialog box appears.

6 Choose a movie from the Movie pop-up menu.

Dreamweaver automatically lists the names of all Shockwave and Flash movies 
in the current document. (Specifically, Dreamweaver lists movies with file 
names ending in .dcr, .dir, .swf, or .spl that are in object or embed tags.)

7 Choose to play, stop, rewind, or go to a frame in the movie. The Play option 
plays the movie starting from the frame where the action occurs.

8 Click OK.

9 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For submenu of 
the Events pop-up menu.
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Drag Layer

The Drag Layer action lets the visitor drag a layer. Use this action to create 
puzzles, slider controls, and other movable interface elements. 

You can specify in which direction the visitor can drag the layer (horizontally, 
vertically, or in any direction), a target to which the visitor should drag the layer, 
whether to snap the layer to the target if the layer is within a certain number of 
pixels of the target, what to do when the layer hits the target, and more.

Because the Drag Layer action must be called before the layer can be dragged by 
the visitor, make sure the event that triggers the action occurs before the visitor 
attempts to drag the layer. It’s best to attach Drag Layer to the body object (with 
the onLoad event), though you can also attach it to a link that fills the entire layer 
(such as a link around an image) using the onMouseOver event.

To use the Drag Layer action:

1 Choose Insert > Layer or click the Layer button on the Objects panel and draw 
a layer in the Document window’s Design view.

2 Select the body tag by clicking <body> in the tag selector at the bottom of the 
Document window.

3 Open the Behaviors panel.

4 Click the Plus (+) button and choose Drag Layer from the Actions
pop-up menu.

If Drag Layer is unavailable, you probably have a layer selected. Because layers 
do not accept events in both 4.0 browsers, you must select a different object—
such as the body tag or a link (a tag)—or change the target browser to IE 4.0 in 
the Show Events For pop-up menu.

5 In the Layer pop-up menu, select the layer that you want to make draggable.

6 Choose either Constrained or Unconstrained from the Movement pop-up menu.

Unconstrained movement is appropriate for puzzles and other drag-and-drop 
games. For slider controls and moveable scenery such as file drawers, curtains, 
and mini-blinds, choose constrained movement.

7 For constrained movement, enter values (in pixels) in the Up, Down, Left, and 
Right fields.

Values are relative to the starting position of the layer. To constrain movement 
within a rectangular region, enter positive values in all four fields. To allow only 
vertical movement, enter positive values for Up and Down and 0 for Left and 
Right. To allow only horizontal movement, enter positive values for Left and 
Right and 0 for Up and Down.
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8 Enter values (in pixels) for the drop target in the Left and Top fields.

The drop target is the spot to which you want the visitor to drag the layer. A 
layer is considered to have reached the drop target when its left and top 
coordinates match the values you enter in the Left and Top fields. Values are 
relative to the top left corner of the browser window. Click Get Current 
Position to automatically fill the fields with the current position of the layer.

9 Enter a value (in pixels) in the Snap if Within field to determine how close the 
visitor must get to the drop target before the layer snaps to the target.

Larger values make it easier for the visitor to find the drop target.

10 For simple puzzles and scenery manipulation, you can stop here. To define 
the drag handle for the layer, track the movement of the layer while it is 
being dragged, and trigger an action when the layer is dropped, click the 
Advanced tab.

11 To specify that the visitor must click a particular area of the layer to drag the 
layer, choose Area Within Layer from the Drag Handle pop-up menu; then 
enter the left and top coordinates and the width and height of the drag handle.

This option is useful when the image inside the layer has an element that 
suggests dragging, such as a title bar or drawer handle. Do not set this option if 
you want the visitor to be able to click anywhere in the layer to drag it.

12 Choose any While Dragging options that you want to use:

• Select Bring Layer to Front if the layer should move to the front of the stacking 
order while it is being dragged. If you select this option, use the pop-up menu 
to choose whether to leave the layer in front or restore it to its original position 
in the stacking order.

• Enter JavaScript code or a function name (for example, monitorLayer()) in 
the Call JavaScript field to repeatedly execute the code or function while the 
layer is being dragged. For example, you could write a function that monitors 
the coordinates of the layer and displays hints such as “you’re getting warmer” 
or “you’re nowhere near the drop target” in a text field. 

13 Enter JavaScript code or a function name (for example, evaluateLayerPos()) 
in the second Call JavaScript field to execute the code or function when the 
layer is dropped. Select Only if Snapped if the JavaScript should be executed 
only if the layer has reached the drop target.

14 Click OK.

15 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu. 
Remember that layers are not supported by 3.0 browsers.

Note: You cannot attach the Drag Layer action to an object with the onMouseDown or 
onClick events.
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Gathering information about the draggable layer

When you attach the Drag Layer action to an object, Dreamweaver inserts the 
MM_dragLayer() function into the head section of your document. In addition 
to registering the layer as draggable, this function defines three properties for each 
draggable layer—MM_LEFTRIGHT, MM_UPDOWN, and MM_SNAPPED—that you can use 
in your own JavaScript functions to determine the relative horizontal position of 
the layer, the relative vertical position of the layer, and whether the layer has 
reached the drop target.

Note: The information provided here is intended for the use of experienced JavaScript 
programmers only.

For example, the following function displays the value of the MM_UPDOWN property 
(the current vertical position of the layer) in a form field called curPosField. 
(Form fields are useful for displaying continuously updated information because 
they are dynamic—that is, you can change their contents after the page has 
finished loading—in both Navigator and Internet Explorer.)

function getPos(layername){
var layerRef = MM_findObj(layername); 
var curVertPos = layerRef.MM_UPDOWN;
document.tracking.curPosField.value = curVertPos;

}

Instead of displaying the value of MM_UPDOWN or MM_LEFTRIGHT in a form field, 
you could write a function that displays a message in the form field depending on 
how close the value is to the drop zone, or you could call another function to show 
or hide a layer depending on the value. How you react to the value of MM_UPDOWN 
or MM_LEFTRIGHT is limited only by your imagination and your JavaScript skills.

It is especially useful to read the MM_SNAPPED property when you have several 
layers on the page, all of which must reach their targets before the visitor can 
advance to the next page or task. For example, you could write a function to count 
how many layers have an MM_SNAPPED value of true and call it whenever a layer is 
dropped. When the snapped count reaches the desired number, you could send 
the visitor to the next page or display a message of congratulations.

If you have used the onMouseOver event to attach the Drag Layer action to links 
within several layers, you must make a minor change to the MM_dragLayer() 
function to prevent the MM_SNAPPED property of a snapped layer from being reset to 
false if the mouse pointer rolls over the layer. (This can happen if you have used 
Drag Layer to create a picture puzzle, because the visitor is likely to roll the mouse 
pointer over snapped pieces while positioning others.) The MM_dragLayer() 
function does not prevent this behavior, because it is sometimes desirable—for 
example, if you want to set multiple drop targets for a single layer.
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To prevent re-registration of snapped layers:

1 Make a backup copy of your document before making any changes to the code. 
(You can do this in the Site window in Dreamweaver, or in Windows Explorer 
(Windows) or the Finder (Macintosh).)

2 Choose Edit > Find.

3 Choose HTML Source from the Find What pop-up menu.

4 Type (!curDrag) in the adjacent text field. 

5 Click Find Next.

If Dreamweaver asks if you want to continue searching from the beginning of 
the document, click Yes. Dreamweaver finds a statement that reads:

if (!curDrag) return false;

6 Close the Find dialog box and then modify the statement in the Document 
window’s Code view or in the Code inspector so that it reads:

if (!curDrag || curDrag.MM_SNAPPED != null) return false;

The two pipes (||) mean “or,” and curDrag is a variable that represents the 
layer that is being registered as draggable. In English the statement means “If 
curDrag is not an object, or if it already has an MM_SNAPPED value, don’t bother 
executing the rest of the function.”

Go to URL

The Go to URL action opens a new page in the current window or in the specified 
frame. This action is particularly useful for changing the contents of two or more 
frames with one click. It can also be called in a timeline to jump to a new page 
after a specified time interval.

To use the Go To URL action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Go to URL from the Actions
pop-up menu.

3 Choose a destination for the URL from the Open In list.

The Open In list automatically lists the names of all frames in the current 
frameset as well as the main window. If there are no frames, the main window is 
the only option.

Note: This action may produce unexpected results if any frame is named top, blank, self, 
or parent. Browsers sometimes mistake these names for reserved target names.

4 Click Browse to select a document to open, or enter the path and file name of 
the document in the URL field.
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5 Repeat steps 3 and 4 to open additional documents in other frames.

6 Click OK.

7 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want are 
not listed, change the target browser in the Show Events For pop-up menu.

Jump Menu

When you create a jump menu by using Insert > Form Objects > Jump Menu, 
Dreamweaver creates a menu object and attaches the Jump Menu (or Jump Menu 
Go) behavior to it. There is usually no need to attach the Jump Menu action to an 
object by hand. For information about jump menus and how to create them, see 
“Inserting a jump menu” on page 369.

You can edit an existing jump menu in either of two ways:

• You can edit and rearrange menu items, change the files to jump to, and change 
the window in which those files open, by double-clicking an existing Jump 
Menu action in the Behaviors panel.

• You can edit the items in the menu just as you would edit items in any menu, 
by selecting the menu and using the List Values button in the Property 
inspector. See “Creating a pop-up menu” on page 495 for details.

To edit a jump menu using the Behaviors panel:

1 Create a jump menu object if there isn’t one already in your document.

2 Select the jump menu object and open the Behaviors panel.

3 Double-click Jump Menu in the Actions column.

4 Make changes as desired in the Jump Menu dialog box, then click OK.
Using Behaviors 455



Jump Menu Go

The Jump Menu Go action is closely associated with the Jump Menu action; 
Jump Menu Go lets you associate a Go button with a jump menu. (Before you use 
this action, a jump menu must already exist in the document.) Clicking the Go 
button opens the link that’s selected in the jump menu. A jump menu doesn’t 
normally need a Go button; choosing an item from a jump menu generally causes 
a URL to load without any need for further user action. But if the visitor chooses 
the same item that’s already chosen in the jump menu, the jump doesn’t occur. In 
general, that doesn’t matter, but if the jump menu appears in a frame, and the 
jump menu items link to pages in other frames, a Go button is often useful, to 
allow visitors to re-choose an item that’s already selected in the jump menu.

To add a Jump Menu Go action: 

1 Select an object to use as the Go button (generally a button image), and open 
the Behaviors panel.

2 Click the Plus (+) button and choose Jump Menu Go from the Actions 
pop-up menu.

3 In the Choose Jump Menu pop-up menu, choose a menu for the Go 
button to activate. 

4 Click OK.

Open Browser Window

Use the Open Browser Window action to open a URL in a new window. You can 
specify the properties of the new window, including its size, attributes (whether it 
is resizable, has a menu bar, and so on), and name. For example, you can use this 
behavior to open a larger image in a separate window when the visitor clicks a 
thumbnail image; with this behavior, you can make the new window the exact 
size of the image.

If you specify no attributes for the window, it opens at the size and with the 
attributes of the window that launched it. Specifying any attribute for the window 
automatically turns off all other attributes that are not explicitly turned on. For 
example, if you set no attributes for the window, it might open at 640 x 480 pixels 
and have a navigation bar, location toolbar, status bar, and menu bar. If you 
explicitly set the width to 640 and the height to 480 and set no other attributes, 
the window opens at 640 x 480 pixels and has no navigation bar, no location 
toolbar, no status bar, no menu bar, no resize handles, and no scroll bars.
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To use the Open Browser Window action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Open Browser Window from the 
Actions pop-up menu.

3 Click Browse to select a file, or enter the URL you want to display.

4 Set any of the following options:

Window Width specifies the width of the window in pixels.

Window Height specifies the height of the window in pixels.

Navigation Toolbar is the row of browser buttons that includes Back, Forward, 
Home, and Reload.

Location Toolbar is the row of browser options that includes the location field.

Status Bar is the area at the bottom of the browser window in which messages 
(such as the load time remaining and the URLs associated with links) appear.

Menu Bar is the area of the browser window (Windows) or the desktop 
(Macintosh) where menus such as File, Edit, View, Go, and Help appear. You 
should explicitly set this option if you want visitors to be able to navigate from 
the new window. If you do not set this option, the user can only close or 
minimize the window (Windows) or close the window or quit the application 
(Macintosh) from the new window.

Scrollbars as Needed specifies that scroll bars should appear if the content 
extends beyond the visible area. If you do not explicitly set this option, scroll 
bars do not appear. If the Resize Handles option is also turned off, visitors have 
no easy way of seeing content that extends beyond the original size of the 
window. (Though they may be able to make the window scroll by dragging off 
the edge of the window.)

Resize Handles specifies that the user should be able to resize the window, 
either by dragging the lower right corner of the window or by clicking the 
maximize button (Windows) or size box (Macintosh) in the upper right corner. 
If this option is not explicitly set, the resize controls are unavailable and the 
lower right corner is not draggable.

Window Name is the name of the new window. You should name the new 
window if you want to target it with links or control it with JavaScript. This 
name cannot contain spaces or special characters.

5 Click OK.

6 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.
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Play Sound 

Use the Play Sound action to play a sound. For example, you might want to play a 
sound effect whenever the mouse pointer rolls over a link, or you might want to 
play a music clip when the page loads.

Note: Browsers may require some kind of additional audio support (such as an audio 
plugin) to play sounds. Therefore, different browsers with different plugins often play 
sounds differently. It’s difficult to reliably predict how visitors to your site will experience the 
sounds you provide.

To use the Play Sound action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Play Sound from the Actions
pop-up menu.

3 Click Browse to select a sound file, or enter the path and file name in the 
Play Sound field.

4 Click OK.

5 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.

Popup Message

The Popup Message action displays a JavaScript alert with the message you 
specify. Because JavaScript alerts have only one button (OK), use this action to 
provide information rather than to present the user with a choice.

You can embed any valid JavaScript function call, property, global variable, or 
other expression in the text. To embed a JavaScript expression, place it inside 
braces ({}). To display a brace, precede it with a backslash (\{).

Example

The URL for this page is {window.location}, and today is 
{new Date()}.

Note: You can’t control how the JavaScript alert looks; that’s determined by the visitor’s 
browser. If you want more control over the appearance of your message, consider using the 
Open Browser Window behavior. For details, see “Open Browser Window” on page 456.
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To use the Popup Message action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Popup Message from the Actions
pop-up menu.

3 Enter your message in the Message field.

4 Click OK.

5 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.

Preload Images

The Preload Images action loads images that do not appear on the page right away 
(such as those that will be swapped in with timelines, behaviors, or JavaScript) 
into the browser cache. This prevents delays caused by downloading when it is 
time for the images to appear. 

Note: The Swap Image action automatically preloads all highlight images when you select 
the Preload Images option in the Swap Image dialog box, so you do not need to manually 
add Preload Images when using Swap Image.

To use the Preload Images action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Preload Images from the Actions
pop-up menu.

3 Click Browse to select an image file to preload, or enter the path and file name 
of an image in the Image Source File field.

4 Click the Plus (+) button at the top of the dialog box to add the image to the 
Preload Images list.

Note: If you do not click the Plus button before entering the next image, the image you 
have just chosen will be replaced in the list with the image you choose next.

5 Repeat steps 3 and 4 for all remaining images that you want to preload on 
the current page.

6 To remove an image from the Preload Images list, select the image in the list 
and click the Minus (–) button.

7 Click OK.

8 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.
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Set Nav Bar Image

Use the Set Nav Bar Image action to turn an image into a navigation bar image, or 
to change the display and actions of images in a navigation bar. (For more 
information, see “Inserting a navigation bar” on page 372.)

Use the Basic tab of the Set Nav Bar Image dialog box to create or update a 
navigation bar image or set of images, to change which URL is displayed when a 
navigation-bar button is clicked, and to select a different window in which to 
display a URL.

Use the Advanced tab of the Set Nav Bar Image dialog box to change the state 
of other images in a document based on the current button’s state. By default, 
clicking an element in a navigation bar automatically causes all other elements 
in the navigation bar to return to their Up states; use the Advanced tab if you 
want to set a different state for an image when the selected image is in its 
Down or Over state.

To edit a Set Nav Bar Image action:

1 Select an image in the navigation bar to edit, and open the Behaviors panel.

2 In the Behaviors panel, in the Actions column, double-click the Set Nav Bar 
Image action associated with the event you’re altering.

3 In the Basic tab of the Set Nav Bar Image dialog box, select image edit options.

To set multiple images for a navigation bar button: 

1 Select an image in the navigation bar to edit, and open the Behaviors panel.

2 In the Behaviors panel, in the Actions column, double-click the Set Nav Bar 
Image action associated with the event you’re altering.

3 Click the Advanced tab of the Set Nav Bar Image dialog box.

4 In the When Element Is Displaying pop-up menu, choose an image state. For 
information about image states, see “Creating navigation bars” on page 371.

• Choose Down Image if you want to change the display of another image after a 
user has clicked the selected image.

• Choose Over Image or Over While Down Image if you want to change the 
display of another image when the pointer is over the selected image.

5 In the Also Set Image list, select another image on the page to set.

6 Click Browse to select the image file to display, or type the path of the image 
file in the To Image File field.

7 If you selected Over Image or Over While Down Image in step 4, you have an 
additional option. In the If Down, To Image File text field, click Browse to 
select the image file, or type the path to the image file to display.
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Set Text of Frame

The Set Text of Frame action allows you to dynamically set the text of a frame, 
replacing the content and formatting of a frame with the content you specify. 
The content can include any valid HTML code. Use this action to dynamically 
display information.

Although the Set Text of Frame action replaces the formatting of a frame, you 
can select Preserve Background Color to preserve the page background and text 
color attributes. 

You can embed any valid JavaScript function call, property, global variable, or 
other expression in the text. To embed a JavaScript expression, place it inside 
braces ({}). To display a brace, precede it with a backslash (\{).

Example

The URL for this page is {window.location}, and today is 
{new Date()}.

To create a frameset:

Choose Modify > Frameset > Split Frame Left, Right, Up, or Down.

For more information, see “Creating frames” on page 206.

To use the Set Text of Frame action:

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Set Text > Set Text of Frame from the 
Actions pop-up menu.

3 In the Set Text of Frame dialog box, choose the target frame from the 
Frame pop-up menu.

4 Click the Get Current HTML button to copy the current contents of the target 
frame’s body section.

5 Enter a message in the New HTML field, then click OK.

6 Check that the default event is the one you want. If it isn’t, choose another 
event from the pop-up menu. 

If you don’t see the events you want, change the target browser in the Show 
Events For pop-up menu.
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Set Text of Layer

The Set Text of Layer action replaces the content and formatting of an existing 
layer on a page with the content you specify. The content can include any valid 
HTML source code. 

Set Text of Layer replaces the content and formatting of the layer, but retains layer 
attributes, including color. Format the content by including HTML tags in the 
New HTML field of the Set Text of Layer dialog box.

You can embed any valid JavaScript function call, property, global variable, or 
other expression in the text. To embed a JavaScript expression, place it inside 
braces ({}). To display a brace, precede it with a backslash (\{).

Example

The URL for this page is {window.location}, and today is {new Date()}.

To create a layer:

1 Choose Insert > Layer.

For more information, see “Creating layers on your page” on page 409.

2 In the Property inspector, type a name for the layer.

To attach a Set Text of Layer action:

1 Select an object and open the Behaviors panel. 

2 Click the Plus (+) button and choose Set Text > Set Text of Layer from the 
Actions pop-up menu.

3 In the Set Text of Layer dialog box, use the Layer pop-up menu to choose the 
target layer.

4 Enter a message in the New HTML field, then click OK.

5 Check that the default event is the one you want. If it isn’t, choose another 
event from the pop-up menu. 

If you don’t see the events you want, change the target browser in the Show 
Events For pop-up menu.
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Set Text of Status Bar

The Set Text of Status Bar action shows a message in the status bar at the bottom 
left of the browser window. For example, you can use this action to describe the 
destination of a link in the status bar instead of showing the URL associated with 
it. To see an example of a status message, roll your mouse over any of the 
navigation buttons in Dreamweaver Help. Note, however, that visitors often 
ignore or overlook messages in the status bar; if your message is important, 
consider displaying it as a pop-up message or as the text of a layer.

You can embed any valid JavaScript function call, property, global variable, or 
other expression in the text. To embed a JavaScript expression, place it inside 
braces ({}). To display a brace, precede it with a backslash (\{).

Example

The URL for this page is {window.location}, and today is {new Date()}.

To use the Set Text of Status Bar action: 

1 Select an object and open the Behaviors panel.

2 Click the Plus (+) button and choose Set Text > Set Text of Status Bar from the 
Actions pop-up menu.

3 In the Set Text of Status Bar dialog box, type your message in the Message field.

Keep the message concise. The browser truncates the message if it doesn’t fit in 
the status bar.

4 Click OK.

5 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.
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Set Text of Text Field

The Set Text of Text Field action replaces the content of a form’s text field with the 
content you specify.

You can embed any valid JavaScript function call, property, global variable, or 
other expression in the text. To embed a JavaScript expression, place it inside 
braces ({}). To display a brace, precede it with a backslash (\{).

Example

The URL for this page is {window.location}, and today is {new Date()}.

To create a named text field:

1 Choose Insert > Form Objects > Text Field.

If Dreamweaver prompts you to add a form tag, click Yes. For more 
information, see “Creating Forms” on page 481.

2 In the Property inspector, type a name for the text field. Make sure the name is 
unique on the page (don’t use the same name for multiple elements on the same 
page, even if they’re in different forms).

To use the Set Text of Text Field action:

1 Select a text field and open the Behaviors panel.

2 Click the Plus (+) button and choose Set Text > Set Text of Text Field from the 
Actions pop-up menu.

3 In the Set Text of Text Field dialog box, choose the target text field from the 
Text Field pop-up menu.

4 Enter text in the New Text field, then click OK.

5 Check that the default event is the one you want. If it isn’t, choose another 
event from the pop-up menu. 

If you don’t see the events you want, change the target browser in the Show 
Events For pop-up menu.
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Show-Hide Layers

The Show-Hide Layers action shows, hides, or restores the default visibility of one 
or more layers. This action is useful for showing information as the user interacts 
with the page. For example, as the user rolls the mouse pointer over an image of a 
plant, you could show a layer that gives details about the plant’s growing season 
and region, how much sun it needs, how large it can grow, and so on. 

Show-Hide Layers is also useful for creating a preload layer—that is, a large layer 
that obscures the contents of the page at first and then disappears when all the 
page components have finished loading.

To use the Show-Hide Layers action:

1 Choose Insert > Layer or click the Layer button on the Objects panel, and draw 
a layer in the Document window.

Repeat this step to create additional layers.

2 Click in the Document window to deselect the layer, then open the 
Behavior panel.

3 Click the Plus (+) button and choose Show-Hide Layers from the Actions 
pop-up menu.

If Show-Hide Layers is unavailable, you probably have a layer selected. Because 
layers do not accept events in both 4.0 browsers, you must select a different 
object—such as the body tag or a link (a tag)—or change the target browser to 
IE 4.0 in the Show Events For pop-up menu.

4 From the Named Layers list, select the layer whose visibility you want to change.

5 Click Show to show the layer, Hide to hide the layer, or Default to restore the 
layer’s default visibility.

6 Repeat steps 4 and 5 for all remaining layers whose visibility you want to 
change at this time. (You can change the visibility of multiple layers with a 
single behavior.)

7 Click OK.

8 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.

When viewed in a Netscape Navigator browser window, layers may shrink to 
fit the content. To keep this from happening, add text or images to layers, or set 
layer clip values.
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To create a preload layer:

1 Click the Draw Layer button in the Common category of the Objects panel 
and draw a large layer in the Document window’s Design view.

Be sure the layer covers all the content on the page.

2 In the Layers panel, drag the layer name to the top of the list of layers to specify 
that the layer should be at the front of the stacking order.

3 Select the layer if it’s not selected, and name it loading, using the leftmost field 
in the layer Property inspector.

4 With the layer still selected, set the background color of the layer to the same 
color as the page background in the Property inspector.

5 Click inside the layer (which should now be obscuring the rest of the page 
contents) and type a message, if desired.

For example, “Please wait while the page loads” or “Loading...” are messages that 
tell visitors what is happening so that they know the page contains content.

6 Click the <body> tag in the tag selector in the bottom left corner of the 
Document window.

7 In the Behaviors panel, choose Show-Hide Layers from the Actions 
pop-up menu.

8 Select the layer called loading from the Named Layers list.

9 Click Hide.
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10 Click OK.

11 Make sure that the event listed next to the Show-Hide Layers action in the 
behaviors list is onLoad. (If it isn’t, select the event and click the downward-
pointing triangle that appears between the event and the action. Choose 
onLoad from the list of events in the pop-up menu.)

Swap Image

The Swap Image action swaps one image for another by changing the src 
attribute of the img tag. Use this action to create button rollovers and other 
image effects (including swapping more than one image at a time).

Note: Because only the src attribute is affected by this action, you should swap in an 
image that has the same dimensions (height and width) as the original. Otherwise, the 
image you swap in appears compacted or expanded to fit the original image’s dimensions.

To use the Swap Image action:

1 Choose Insert > Image or click the Image button on the Objects panel to 
insert an image.

2 In the Property inspector, enter a name for the image in the leftmost text field.

The Swap Image action still works if you do not name your images; it names 
unnamed images automatically when you attach the behavior to an object. 
However, it is easier to distinguish images in the Swap Image dialog box if all of 
the images are named beforehand. 

3 Repeat steps 1 and 2 to insert additional images.

4 Select an object (generally the image you’re going to swap) and open the 
Behaviors panel.

5 Click the Plus (+) button and choose Swap Image from the Actions
pop-up menu.

6 From the Images list, select the image whose source you want to change.

7 Click Browse to select the new image file, or enter the path and file name of the 
new image in the Set Source To field.

8 Repeat steps 6 and 7 for any additional images you want to change. Use the same 
Swap Image action for all the images you want to change at once; otherwise, the 
corresponding Swap Image Restore action won’t restore all of them.

9 Select the Preload Images option to load the new images into the 
browser’s cache when the page is loaded.

This prevents delays caused by downloading when it is time for the 
images to appear.
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10 Click OK.

11 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.

Swap Image Restore

The Swap Image Restore action restores the last set of swapped images to their 
previous source files. This action is automatically added whenever you attach the 
Swap Image action to an object; if you left the Restore option selected while 
attaching Swap Image, you should never need to select the Swap Image Restore 
action manually.

Go to Timeline Frame

The Go to Timeline Frame action moves the playback head to the specified frame. 
You can use this action in the Behavior channel of the Timelines panel to make 
portions of the timeline loop a specific number of times, to create a Rewind link 
or button, or to let the user jump to different parts of the animation.

To use the Go To Timeline Frame action:

1 Choose Window > Timeline to open the Timelines panel, and make sure that 
your document contains a timeline.

If you don’t see any purple animation bars in the Timelines panel, your 
document does not contain a timeline. See “Creating a timeline animation” 
on page 427.

2 Select an object to attach the behavior to.

To attach the behavior to a frame in the Timeline, click in the Behavior channel 
at the desired frame.

3 Open the Behaviors panel.

4 Click the Plus (+) button and choose Timeline > Go to Timeline Frame from 
the Actions pop-up menu. (If this action is dimmed, your document doesn’t 
contain a timeline.)

5 Choose a timeline from the Timeline pop-up menu.

6 Enter a frame number in the Go to Frame field.
Chapter 18468



7 If you are adding this action in the Behavior channel of a timeline and want a 
portion of the timeline to loop, enter the number of times the segment should 
loop in the Loop field.

You must leave this field blank if you are not attaching Go to Timeline Frame 
to a frame in a timeline.

8 Click OK.

9 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.

Play Timeline and Stop Timeline

Use the Play Timeline and Stop Timeline actions to let visitors start and stop a 
timeline by clicking a link or button, or to start and stop a timeline automatically 
when the user rolls over a link, image, or other object. The Play Timeline action is 
automatically attached to the body tag with the onLoad event when you select 
Autoplay in the Timelines panel.

To use the Play Timeline and Stop Timeline actions:

1 Choose Window > Timeline to open the Timelines panel, and make sure that 
your document contains a timeline.

If you don’t see any purple animation bars in the Timelines panel, your 
document does not contain a timeline. See “Creating a timeline animation” 
on page 427.

2 Select an object and open the Behaviors panel.

3 Click the Plus (+) button and choose Play Timeline or Stop Timeline from the 
Actions pop-up menu.

4 Select the timeline you want to play or stop, or choose to stop all timelines, 
from the pop-up menu. 

5 Click OK.

6 Check that the default event is the one you want.

If it isn’t, choose another event from the pop-up menu. If the events you want 
are not listed, change the target browser in the Show Events For pop-up menu.
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Validate Form

The Validate Form action checks the contents of specified text fields to ensure that 
the user has entered the correct type of data. Attach this action to individual text 
fields with the onBlur event to validate the fields as the user is filling out the form, 
or attach it to the form with the onSubmit event to evaluate several text fields at 
once when the user clicks the Submit button. Attaching this action to a form 
prevents the form from being submitted to the server if any of the specified fields 
contains invalid data.

To use the Validate Form action:

1 Choose Insert > Form or click the Form button on the Objects panel to 
insert a form.

2 Choose Insert > Form Objects > Text Field or click the Text Field button on the 
Objects panel to insert a text field.

Repeat this step to insert additional text fields.

3 Do one of the following:

• To validate individual fields as the user fills out the form, select a text field and 
choose Window > Behaviors.

• To validate multiple fields when the user submits the form, click the <form> 
tag in the tag selector in the bottom left corner of the Document window and 
choose Window > Behaviors.

4 Choose Validate Form from the Actions pop-up menu.

5 Do one of the following:

• If you are validating individual fields, select the same field that you have 
selected in the Document window from the Named Fields list.

• If you are validating multiple fields, select a text field from the 
Named Fields list.

6 Select the Required option if the field must contain some data.

7 Choose from one of the following Accept options:

• Use Anything if the field is required but need not contain any particular kind 
of data. (If the Required option is not selected, the Anything option is 
meaningless—that is, it is the same as if the Validate Form action were not 
attached to the field.)

• Use E-mail address to check that the field contains an @ symbol.

• Use Number to check that the field contains only numerals.

• Use Number From to check that the field contains a number in a specific range.
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8 If you are validating multiple fields, repeat steps 6 and 7 for any additional 
fields that you want to validate.

9 Click OK.

If you are validating multiple fields when the user submits the form, the 
onSubmit event automatically appears in the Events pop-up menu. 

10 If you are validating individual fields, check that the default event is onBlur 
or onChange.

If it isn’t, select onBlur or onChange from the pop-up menu. Both of these 
events trigger the Validate Form action when the user moves away from the 
field. The difference between them is that onBlur occurs whether or not the 
user has typed in the field, and onChange occurs only if the user changed the 
contents of the field. The onBlur event is preferred when you have specified 
that the field is required.  
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Debugging JavaScript Code

Macromedia Dreamweaver JavaScript Debugger allows you to uncover errors 
in your client-side JavaScript code. You can write the code using Dreamweaver 
Code view (or Code inspector), then run the debugger to check your code for 
syntax and logical errors. A syntax error causes the browser to report an error 
message; a logical error causes your page to function incorrectly, but is not 
reported by the browser. The debugger works with Microsoft Internet Explorer 
and Netscape Navigator on the Windows platform and Netscape Navigator on 
the Macintosh platform. For more information about writing scripts, see 
“Inserting scripts” on page 335. 

The debugger checks your code for syntax errors first, then runs with the browser 
to help you check for logical errors. If you have logical errors, the JavaScript 
Debugger window helps you isolate the errors in your JavaScript code by letting 
you examine variables and document properties while your program is running. 
You can set breakpoints (similar to alert statements) in your code to stop the 
execution of the program and display the values of JavaScript objects and 
properties in a variable list. You can also step to the next statement or step into a 
function call to see the variable values change.

The JavaScript Debugger can significantly reduce the time it takes you to find and 
isolate errors in your code.
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Running the debugger
After you write your code, you can start the JavaScript Debugger to check for 
errors. The debugger checks for syntax errors first, then opens your page in the 
browser so you can check for logical errors.

To start debugging:

1 Choose File > Debug in Browser, then select the browser from the list. 
Alternatively, click the Preview/Debug in Browser button in the toolbar 
(View > Toolbar) and select Debug in Internet Explorer or Debug in 
Netscape Communicator.

If the debugger finds syntax errors, it stops and lists them in the JavaScript 
Syntax Errors window. See “Finding syntax errors” on page 475.

2 If you are using Netscape Navigator, click OK in the debugger warning box 
that appears, then click Grant in the Java Security dialog box. 

Note: If you have already accepted a Macromedia Security Certificate, the Java 
Security dialog box may not appear. 

3 If you are using Internet Explorer (Windows only), click Yes in the Java 
Security dialog box, then OK in the debugger warning box that appears.

The debugger connects with the browser, but does not actually make a network 
connection or connect to any Internet servers. The browser appears with the 
JavaScript Debugger window, which is stopped automatically at the first line of code.

The JavaScript Debugger window appears with the browser window. The 
debugger stops automatically at the first line of code.

To run the debugger:

Click the Run button in the JavaScript Debugger window.

To stop the debugger:

Click the Stop Debugging button in the JavaScript Debugger window. The 
debugger will close.
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Finding syntax errors

If the debugger finds syntax errors, it stops and lists the errors in the JavaScript 
Syntax Errors window. 

To view the error description:

Select an error in the JavaScript Syntax Errors window. A description of the error 
will appear in the Detailed Description area.

To go to the selected error in your code, do one of the following:

• Double-click the error. 

• Click the Go To Line button.

The code is highlighted in the Code view (or Code inspector).
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Finding and fixing logical errors
When the debugger finds logical errors, the JavaScript Debugger window opens. A 
breakpoint (similar to an alert) is automatically set in the first line of your code. 
The debugger stops executing at each breakpoint, giving you the opportunity to 
view the values of JavaScript objects and properties in the variable list window. 

After the debugger stops at a breakpoint, you can step through your code (execute 
one statement at a time). This allows you to see if the program executes as it 
should. The debugger can even step into linked code. For example, if your code 
contains a link to a source file, the debugger steps into the source file and displays 
it in the JavaScript Debugger window. As you step through the code, you can 
watch as the values of your variables change through your program.

Run

Stop 
Debugging

Set/Remove 
Breakpoint

Remove All 
Breakpoints

Step Over

Step Into

Step Out
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Setting breakpoints

A breakpoint marks a spot in the code where you want the program execution to 
stop. When you set a breakpoint, it is marked with a small red dot in the left 
margin of the JavaScript Debugger window. When the program stops executing at 
that breakpoint, a small arrow appears over the dot, and you can examine the 
objects and properties that exist at that point. This allows you to quickly pinpoint 
the source of the bug in the JavaScript code. 

Breakpoints can only be set in the JavaScript code (between script tags) or on a 
line with an event handler. If you set a breakpoint elsewhere, Dreamweaver will 
automatically set the breakpoint on the next valid line of code (or place the 
insertion point there, if the line already has a breakpoint set on it). If there are no 
valid lines on which a breakpoint can be set, you will hear a beep.

To set a breakpoint, do one of the following:

• In the JavaScript Debugger window, place the insertion point in the line where 
you want the breakpoint, then click the Set/Remove Breakpoint button at the 
top of the debugger window. To remove the breakpoint, click the Set/Remove 
Breakpoint button again.

• In the Code view (or Code inspector), place the insertion point in the line 
where you want the breakpoint, then select Edit > Set Breakpoint or choose Set 
Breakpoint from the Code Navigation pop-up menu in the toolbar. You can 
also right-click (Windows) or Control-click (Macintosh) and choose Set 
Breakpoint from the context menu. To remove the breakpoint, select Remove 
Breakpoint from the context menu.
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To remove all breakpoints, do one of the following:

• In the JavaScript Debugger window, click the Remove All Breakpoints button.

• In the Code view (or Code inspector), select Remove All Breakpoints 
from the Code Navigation pop-up menu in the toolbar or choose Edit > 
Remove All Breakpoints.

Stepping through code

You can step through your code to execute your statements one at a time and 
monitor their effects in your program. For example, you can step over an if 
condition and see if the program stops at the first line within the conditional 
statement or at the next executable line after the if statement. 

When the debugger stops at a statement with a function call, you can check the 
function to make sure it executes correctly. If the function is correct, you can step 
out of it to allow the debugger to run until the function returns. The program will 
stop again at the next statement after the function call location. If you attempt to 
step into a statement that contains a nonstandard JavaScript function, the 
behavior will be that of stepping over.

To step over a statement:

Click the Step Over button at the top of the JavaScript Debugger window.

When the program stops at any statement (including those with a function call), 
you can step over that statement to continue and pause before the next statement.

To step into a function:

Click the Step In button at the top of the JavaScript Debugger window.

To step out of a function:

Click the Step Out button.

You can only use Step Out when the debugger is within a user-defined function. 
Stepping out causes the remaining statements in the function definition to be 
executed. The debugger will pause at the next statement.
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Watching and editing variable values

To check the values of your variables as you step through the code, you use the 
Dreamweaver variable list located in the bottom pane of the JavaScript Debugger 
window. You enter variable names in the left column; the right column lists the 
current values of each variable when the program stops execution at a breakpoint 
or after you’ve stepped in the code. 

To add a variable to your variable list, do one of the following:

• Select the name of the variable in the code portion of the JavaScript Debugger 
window. Click the Plus (+) button and press Enter.

• Click the Plus (+) button, type the name of the variable you want to watch, 
and press Enter.

The values will appear next to each variable as you step through the code. If the 
variable is an object with properties, you can expand the variable (show its 
properties and values) by clicking the Plus (+) button (Windows) or triangle 
button (Macintosh) next to it in the list. The expanded variable is automatically 
collapsed each time you step through the code.
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To remove a variable list item:

1 Select the item in the variable list.

2 Click the Minus (-) button.

To edit a value:

1 Select the item in the variable list.

2 Click the value in the value list. 

3 Edit the value by typing in the text box that appears.
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Creating Forms

Forms allow you to interact with or gather information from visitors to your site. 
For example, you can ask for a user’s name and e-mail address, or have visitors take 
a survey, sign a guest book, or provide feedback on your site. 

Forms have two parts: HTML source code describing the form (for example, the 
fields, labels, and buttons a user sees on the page), and a script or application to 
process the information submitted (such as a CGI script). You can’t collect form 
data without using a processing script.

You can use Macromedia Dreamweaver to create a variety of form objects such as 
text fields, password fields, radio buttons, checkboxes, pop-up menus, or 
“clickable” images (such as a Submit button).

You can also use the Dreamweaver Validate Form behavior to verify the 
information a visitor provides; for example, you can check that an e-mail address 
contains an “@” symbol, or that a “required” field contains an entry.

CGI-bin

1. Visitor completes form 
and submits it to a Web 
server for processing

2. CGI script 
processes 
the form

3. A new HTML document is 
created and sent to the visitor
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About CGI scripts
Forms are usually processed by CGI (Common Gateway Interface) scripts. CGI 
is a standardized way of sending information between a server and a processing 
script. CGI scripts are typically written in Perl or some other programming 
language such as C++, Java, VBScript, or JavaScript. Before creating interactive 
forms, check with your ISP or server administrator to see if CGI scripts can 
run on your server. 

About form objects
In Dreamweaver, form input types are called form objects. You can insert form 
objects by using the Objects panel’s Forms category, or by choosing Insert > Form, 
and Insert > Form Objects.

The Forms category provides the following buttons:

Insert Form inserts a form in the document. Dreamweaver inserts opening and 
closing form tags in the HTML source code. Any additional form objects, such as 
text fields, buttons, and so on must be inserted between the form tags for the data 
to be processed correctly by all browsers.

Insert Text Field inserts a text field in a form. Text fields accept any type of text, 
alphabetic, or numeric entries. The entered text can be displayed as a single line, 
as multiple lines, or as bullets or asterisks (for password protection).

Insert Button inserts a text button in a form. Buttons perform tasks when clicked, 
such as submitting or resetting forms. You can add a custom name or label for a 
button, or use one of the predefined labels—Submit or Reset. 
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Insert Checkbox inserts a checkbox in a form. Checkboxes allow multiple 
responses in a single group of options, a user can select as many options as apply. 

Insert Radio Button inserts a radio button in a form. Radio buttons represent 
exclusive choices. Selecting a button within a group deselects all others in the 
group, for example a user can select Yes or No. 

Insert List/menus allows you to create user choices in a list. The List option 
displays the option values in a scrolling list and allows users to select multiple 
options in the list. The Menu option displays the option values in a drop-down 
list and allows users to select only a single choice. 

Insert File field inserts a blank text field and a Browse button in a document. File 
fields let users browse to files on their hard disks and upload the files as form data. 

Insert Image Field allows you to insert an image in a form. Image fields can be 
used in place of Submit buttons to make graphical buttons. 

Insert Hidden field inserts a field in the document in which user data can be 
stored. Hidden fields let you store information entered by a user, such as a 
name, e-mail address, or purchase preference, and then use that data when the 
user next visits your site. 

Insert Jump Menu inserts a navigational list or pop-up menu. Jump menus let you 
insert a menu in which each option links to a document or file. See “Creating 
jump menus” on page 369.

Creating a form
A form contains properties that are invisible to the user. The properties specify 
how the form will be processed

A form consists of three basic parts: 

• form tags, which include the URL of the CGI script that will process the form, 
and the method in which the data will be sent to a server

• Form fields, which include text fields, menus, checkboxes, or radio buttons

• Submit button, which sends the data to the CGI script on the server

Note: If you attempt to insert a form object without first creating the form, you’ll get a 
Dreamweaver message “Add form tags?” Choose Yes to have Dreamweaver create form 
tags for the object.
Creating Forms 483



To add a form to a document:

1 In the document, place the insertion point where you want the form to appear, 
then do one of the following:

• In the Objects panel’s Forms category, select the Insert Form icon.

• Choose Insert > Form.

When a form is created a dotted red outline appears in the Document 
window. If you don’t see this outline, check that View > Visual Aids > 
Invisible Elements is selected.

2 In the document, click the form outline to select the form, if it isn’t 
already selected.

3 In the Property inspector’s Form Name field, type a unique name to 
label the form. 

Naming a form makes it possible to reference or control the form with a 
scripting language, such as JavaScript or VBScript. 
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4 In the Action field, specify the path to the URL where the processing script or 
application that will process the form information resides, by doing one of 
the following:

• Click the folder icon, then navigate to the appropriate folder. 

• Type the complete path to the folder.

If you’re specifying a path to a CGI script, the path to the URL will look 
similar to this example: 

http://www.mysite.com/cgi-bin/process.cgi

5 In the Method pop-up menu, choose the method in which the form data will 
be handled.

• Choose POST to send the form values in the body of a message.

• Choose GET to send information to the server with the submitted form values 
appended to the URL.

Note: Don’t use the GET method with long forms. URLs are limited to 8,192 characters; 
if the amount of data sent is too long, data will be truncated, leading to unexpected 
processing results. Nor should you use GET when dealing with credit card numbers or 
other confidential information, as this method of passing information is not secure. 

• Choose Default to use the user’s browser default setting for sending form data 
which is generally the GET method.

About form fields
Once you add form tags to your document you can start adding form objects. You 
use form objects to request information from site visitors. 

Use form fields when you want to set up a form in which visitors type their 
response, such as their name and address. There are three types of fields you can 
insert in a form—text fields (in which a user types a response), file fields (in which 
a user enters the path of a file to upload to your server, and hidden fields (which 
store information a user entered in another field). 

As you add a field to a form you can set the field’s length, number of lines the field 
contains, number of characters a user can enter, and whether the field is a 
password field.
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Creating text fields 

A text field is a form object in which users type a response. 

There are three types of text fields:

Single-line text fields are typically used to provide a single word or short phrase 
response, such as a name, or an address. 

Multiple-line text field provides a visitor with a larger area in which to type a 
response. You can easily determine the number of characters or number of lines a 
visitor has available in which to write text. 

Password fields are a special type of text field; when a user types in a password field, 
the typed text is hidden and replaced by asterisks or bullets to obscure the text.

Note: Passwords sent to a server by this mode are not encrypted, therefore; the data 
transferred is not secure. 
Chapter 20486



To create a single-line or a password text field:

1 Place the insertion point inside the form outline, then do one of the following:

• Choose Insert > Form Object > Text Field.

• In the Objects panel’s Forms category, click the Insert Text Field icon.

A text field appears in the document.

2 In the Property inspector’s TextField field, type a unique name for the field. 

Make sure the name is unique—you cannot duplicate a text field’s name within 
a form. Do not leave blank spaces, instead use an underscore to separate words. 
For example, type last_name rather than last name. 

3 In the Char Width field, do one of the following:

• Accept the default setting, which sets the text field’s length to approximately 
24 characters.

• Type a number to specify the length of the text field.

4 In the Max Chars field, do one of the following.

• Leave the field blank, allowing users to type as much text as they want. If the user’s 
input exceeds the character width (length) of the text field the text will scroll. 

• Type a number to set the maximum number or characters a user can type 
into the field. 

For example, you may want to limit an age field to three digits, or a password 
field to eight characters. If a user exceeds the maximum number of characters, 
the form produces an alert sound.

5 For Type, select the type of text field you’re creating, by doing one of 
the following:

• Select Single-line to create a single-line text field.

• Select Password to create a password field.

6 If you want to set default text for a text field, type the text in the Property 
inspector’s Init Value field

This text will be displayed in the text field when the form first loads in a 
user’s browser. 

7 Type a label or descriptive text, if desired, next to the object. 

You can apply text formatting to form object labels. For more information, see 
“Setting and changing fonts and styles” on page 239.
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To create a multiple-line text area:

1 Place the insertion point inside the form outline, then do one of the following:

• Choose Insert > Form Object > Text Field.

• In the Objects panel’s Forms category, click the Insert Text Field icon.

A text field appears in the document.

2 In the Property inspector’s TextField field, type a name for the text field object. 

Make sure the name is unique—you cannot duplicate a text field’s name within 
a form. Do not leave blank spaces, instead use underscore to separate words. 
For example, type user_feedback rather than user feedback. 

3 For Type, select Multi-line.

4 In the Char Width field, do one of the following:

• Accept the default setting, which sets the length of the text area to 20 characters.

• Type a number to specify the length of the text area. 

5 In the Num Lines field, do one of the following:

• Accept the default setting, which sets a two-line text field. 

• Type a number to specify the number of lines for the text area.

6 In the Wrap pop-up menu, select a setting to set how a user’s input will be displayed 
when a user types more information than can be displayed in the text area.

• Select Off or Default if you want to prevent text from wrapping to the next line.

When the user’s input exceeds the right boundary of the text area, text will 
scroll toward the left. User’s must press Return to move the insertion point to 
the next line in the text area.

• Select Virtual to set word wrap in the text area.

When the user’s input exceeds the right boundary of the text area, text wraps to 
the next line. When data is submitted for processing, however, word wrap isn’t 
applied to the data; it is submitted as one string of data.

• Select Physical to set word wrap in the text area, as well as to the data when it is 
submitted for processing.

7 If you want to set default text for a text field, type the text in the Property 
inspector’s Init Value field.

This text will be displayed in the text field when the form first loads in a 
user’s browser. 

8 Type a label or descriptive text, if desired, next to the object. 

You can apply text formatting to form object labels. For more information, see 
“Setting and changing fonts and styles” on page 239.
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Allowing visitors to upload a file to your server

In some cases the information you need from the visitors to your site may be too 
complicated to respond to in a text field. You may want visitors to send an entire 
file to your server, for example a nicely formatted resume, a graphics file, or some 
other document. You can set up a file field in a form to accomplish this task.

A file field looks like other text fields except it also contains a Browse button. A 
user can type the path to the file they’re sending or use the Browse button to locate 
and select the document they’re sending.

To use a file field, the form Method must be set to POST. Visitors post a file to the 
address you set up in the form’s Action field. 

Note: Confirm with your server’s administrator that anonymous file uploads are allowed 
before using the file field. If you insert a file field with Dreamweaver, you must manually 
insert ENCTYPE="multipart/form-data" into the form tag to ensure that the file is 
encoded properly.

To create a file field in a form: 

1 Click the form outline to select the form, then in the Property inspector set the 
form Method to POST.

2 Place the insertion point inside the form outline, then do one of the following:

• Choose Insert > Form Object > File Field.

• In the Objects panel’s Forms category, click the Insert File Field icon.

A file field appears in the document.

3 In the Property inspector’s FileField Name field, type a name for the 
file field object. 

4 In the Char Width field, type a number to set the maximum number of 
characters you want the field to display.

5 In the Max Char field, type a number to set the maximum number of 
characters the field will hold.
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Creating a hidden field

Hidden fields aren’t visible to your site visitors, they are invisible elements you 
place in a document to gather or send information. The hidden field information 
is passed back to the server when a form is submitted, and uses the name and 
value pair you define when you set up the hidden field.

Dreamweaver adds a marker in the document when you insert a hidden field. If 
you insert a hidden field and don’t see a marker, choose View > Visual Aids > 
Invisible Elements to reveal the marker. 

To create a hidden field:

1 Place the insertion point inside the form outline, then do one of the following:

• Choose Insert > Form Object > Hidden Field.

• In the Objects panel’s Forms category, click the Insert Hidden Field icon.

A marker appears in the document.

2 In the Property inspector’s HiddenField field, type a unique name for the field.

3 In the Value field, type the value you want to assign the field.
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Inserting checkboxes and radio buttons
Use checkbox and radio button form objects to set up predefined selection 
objects. A user clicks a checkbox or radio button to make a choice. 

The difference between checkboxes and radio buttons is how they operate. 
With checkboxes users toggle each individual response “off ” and “on.” Each 
checkbox option operates individually. A user can select more than one option 
in a checkbox group. 
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Radio buttons work as a group and provide mutually exclusive selection values. 
Only one option in a radio button group may be selected. 

Inserting a checkbox

Checkboxes allow the user to select more than one option from a set of options.

Each checkbox form object is an individual element and must have a unique name 
in the Name field.

To insert a checkbox:

1 Place the insertion point inside the form outline, then do one of the following:

• Choose Insert > Form Object > Check Box. 

• In the Objects panel’s Forms category, click the Insert Checkbox icon. 

2 In the Property inspector’s Checkbox Name field, type a descriptive name for 
the checkbox. 

Note: Each checkbox you add to a form must have a unique name.

3 In the Checked Value field, type a value for the checkbox. 

For example, in a survey you might set a value of 4 for strongly agree and a 
value of 1 for strongly disagree. 

4 For Initial State, click Checked if you want an option to appear selected when 
the form first loads in the browser. 
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Inserting a radio button

Use radio buttons when the user must select only one choice from a set of options. 
Radio buttons are typically used in groups. All radio buttons in a group must have 
the same name and must contain different field values. 

To insert radio buttons:

1 Place the insertion point inside the form outline, then do one of the following:

• Choose Insert > Form Object > Radio Button.

• In the Objects panel’s Forms category, click the Insert Radio Button icon

2 In the Property inspector’s RadioButton Name field, type a descriptive name 
for the group of choices. 

Note: If you create multiple radio button interactions in a form, be sure each set of radio 
buttons has a unique name.

3 In the Checked Value field, type the value you want sent to the server-side 
application or processing script when a user selects this radio button. 
For example, you might type skiing in the CheckedValue field to indicate 
a user chose skiing.

4 For Initial State, click Checked if you want an option to appear selected when 
the form first loads in the browser. 

Tip: To add additional radio buttons to the group, select the original radio button, then 
Control-drag (Windows) or Option-drag (Macintosh) and change the Checked Value field 
for each new button.

About lists and menus
Use an options list or menu when you want to present a user with lots of choices 
in a limited space. Although you create a form list or form menu in the same 
Property inspector, lists and menus provide different functionality to the user.

Use a list when you want to control the number of options displayed. You set the 
list’s line height; when the number of list options exceed the line height, a scroll 
bar appears, allowing users to view all the options. You can also allow users to 
select multiple items in a list.

Use a menu when space is very limited. A menu displays a single-line entry, and 
includes a down arrow that a user clicks to reveal the other menu choices. A user can 
only choose one menu item at a time. See also, “Creating jump menus” on page 369.
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Creating a scrolling list

Scrolling lists allow you to set up multiple options in a confined space. You can set 
the line height of the list, and allow users to make multiple selections within the list. 

To create a scrolling list:

1 Place the insertion point inside the form outline, then do one of the following:

• In the Objects panel’s Forms category, click the Insert List/Menu icon. 

• Choose Insert > Form Object > List/Menu and select the resulting List/Menu 
element if necessary.

2 In the Property inspector’s List/Menu field, type a unique name for the list.

3 Under Type, select List.

4 In the Height field, type a number to specify the number of lines the 
list will display.

The default line height is set to 4. Scroll bars appear when the number you 
specify is less than the number of options the list contains.

5 If you want to allow users to select more than one option in the list, select 
Allow Multiple (next to Selections).

6 Click List Values to add the option choices.

The List Values dialog box appears.

7 With the insertion point in the Item Label field, type the text you want to 
appear in the list.

8 In the Value field, type the text or data you want sent to the server when a user 
selects this item. 

9 To add another item to the options list, click the Plus (+) button, then 
repeat steps 7 and 8.

10 When you finish adding items to the list, click OK to close the List 
Values dialog box.

The Property inspector appears. The option choices are visible in the Initially 
Selected field.

11 Select one of the items on the list to make that item be selected when the list 
initially appears.
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Creating a pop-up menu 

A pop-up menu allows you to set up multiple options in a confined space. Only 
one option choice is visible when the form loads in a browser. 

Users click the down arrow to display all the options in a menu.

To create a pop-up menu:

1 Place the insertion point inside the form outline, then do one of the following:

• In the Objects panel’s Forms category, click the Insert List/Menu icon. 

• Choose Insert > Form Object > List/Menu.

2 In the Property inspector’s List/Menu field, type a unique name for the menu.

3 Under Type, select Menu.

4 Click List Values to add the option choices.

The List Values dialog box appears.

5 With the insertion point in the Item Label field, type the text you want to 
appear in the list.

6 In the Value field, type the text or data you want sent to the server when a user 
selects this item. 

7 To add another item to the options list, click the Plus (+) button, then 
repeat steps 6 and 7.

8 When you finish adding items to the list, click OK to close the List 
Values dialog box.

The Property inspector appears. The option choices are visible in the Initially 
Selected field. 
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About form buttons
Form buttons control form operations. You can use a form button to submit data 
a user entered to a server for processing, or use a form button to reset a form, 
allowing users to correct information before submitting their data. You can also 
use a button to perform other processing tasks you’ve defined in a processing 
script. For example, your form button might calculate an order based on values 
in specified fields.

Creating text form buttons

A text form button is a standard browser-style default button which contains the 
text you want displayed, such as Submit, Reset, Send, or Calculate Order.

To create a text button:

1 Place the insertion point inside the form outline, then do one of the following:

• Choose Insert > Form Object > Button.

• In the Objects panel’s Forms category, click the Insert Button icon.

2 In the Property inspector’s Button Name field, type a name for the button.

Note: There are two reserved names: Submit, which submits the form data for 
processing, and Reset, which resets all the form fields to their original values.

3 In the Property inspector’s Label field, type the text you want to appear 
on the button.

4 In the Action field, do one of the following:

• Select Submit to submit the form for processing when the button is clicked.

• Select Reset to reset the form when the button is clicked.

• Select None to activate a different action based on the processing script when 
the button is clicked, for example, to calculate a total.
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Creating a graphical Submit button

You can make a more appealing Submit button by using the Insert Image Field 
command to insert an image in a form. 

You can also use graphical buttons to perform other form operations such as 
resetting a form, or playing a sound. Using an image to perform tasks other than 
submitting data requires attaching a behavior to the form object. You can use the 
Dreamweaver Behaviors panel to attach a behavior or you can affect the form 
using JavaScript code. To see how to attach a behavior to an object, see “Attaching 
a behavior” on page 439.

To create a graphical Submit button:

1 In the document, place the insertion point inside the form outline, then do one 
of the following:

• Choose Insert > Form Object > Image Field.

• In the Objects panel’s Forms category, click the Insert Image Field icon.

2 In the Property inspector for the image field, change the text in the ImageField 
field to Submit.

3 In the SRC field, click the folder icon, then browse to the image you want to 
insert in the page.

4 In the Alt field, type text you want to appear in place of the image for text-only 
browsers or for browsers set to download images manually.
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About form design
You can use line breaks, paragraph breaks, preformatted text, or tables to format 
your forms. You cannot insert a form in another form (that is, you cannot overlap 
tags), though you can include more than one form in a page.

When designing forms, remember to label the form fields with descriptive text to 
let users know what they’re responding to—for example, “Type your name” to 
request name information.

Adding multiple objects to a form

You can set up multiple forms within a single document or Web page. Just make 
sure the form tags don’t overlap.

To add multiple objects to a form:

1 Place the insertion point inside the form outline, then do one of the following:

• Choose an object from the Insert > Form Object menu.

• In the Objects panel’s Forms category, click the icon of the object you want to 
insert in the form.

2 Specify the properties for the object in the Property inspector (choose Window > 
Properties to display the Property inspector if it is not already open).

Inserting tables in forms

You can design more attractive forms by inserting a table in a form. Use tables to 
provide structure for form objects and field labels. Tables make it easier to line 
choices up both vertically and horizontally. When using tables in forms make sure 
all the table tags are included between the form tags. 
Chapter 20498



Processing forms
Forms are processed by the script or application specified in the action attribute 
of the form tag. Select a form and look in the Property inspector to see what the 
associated action is.

The simplest forms use JavaScript or VBScript to perform all form processing on 
the client side (as opposed to sending the form data to the server for processing). 
For example, you might have a small form at the bottom of a page that contains 
only two radio buttons labeled Yes and No, plus a Submit button. The form 
action might be a JavaScript function defined in the head section of the document 
that displays one alert if the user selects Yes and another alert if the user selects No:

function processForm(){
if (document.forms[0].elements[0].checked){

alert('Yes');
}else{

alert('No');
}

}

To use a client-side JavaScript function as the form action:

1 Select a Submit button in a form.

2 Attach the Call JavaScript behavior to the button. (See “Call JavaScript” on 
page 446.)

3 In the JavaScript text box that appears while attaching the behavior, enter 
processForm().

4 Add a processForm() JavaScript function (like the one shown above) to the 
head section of your document.

You can handle many form-processing tasks using client-side scripting, but you 
can’t save the data entered by the user or send it to someone else. For such 
purposes you need a server-side application such as a Common Gateway Interface 
(CGI) script. CGI scripts can be written in Perl, C, Java, or other programming 
languages. There are several sites on the Web that offer free CGI scripts that you 
can use (see “HTML and Web technologies resources” on page 25). You can 
modify those scripts to fit your needs. You can also ask your Internet service 
provider or Web team if there are any available CGI scripts that are already 
configured to run on your server.

For an introduction to CGI scripting, see the CGI resources listed in “HTML and 
Web technologies resources” on page 25.
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Using behaviors with forms
You can attach behaviors to forms and form objects by using any of the behaviors 
that appear in the Behaviors panel when the form or form object is selected. The 
Validate Form and Set Text of Text Field behaviors are available only if a text field 
has been inserted into the document. When attaching the Validate Form behavior 
to a form object, you must specify which text field is to be validated. For example, 
if you attach Validate Form to the Submit button, you might specify a text field 
created for “Name” to check that the user entered text in the Name field.

When applying behaviors, you need to make sure that every form object in your 
document (and every other object) has a unique name. If you use the same name 
for two different objects, behaviors may not work properly—even if the objects 
are in different forms.

The two form-specific behaviors are explained below. For information on other 
behaviors, see “Using Behaviors” on page 435.

Validate Form checks the contents of specified text fields to ensure that the user 
has entered the correct type of data. See “Validate Form” on page 470. 

Set Text of Text Field replaces the content of a specified text field with the content 
you specify. See “Set Text of Text Field” on page 464.
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Testing and Publishing a Site

Before uploading your site to a server and declaring it ready for viewing, it’s a good 
idea to test it locally. (In fact, it’s a good idea to test and troubleshoot your site 
frequently throughout its construction—you can catch problems early and avoid 
repeating them.) You want to make sure that your pages look and work as 
expected in the browsers you’re targeting, that there are no broken links, and that 
the pages don’t take too long to download. You can also test and troubleshoot your 
entire site by running a site report before you publish your site.

The following guidelines will help you create a good experience for visitors 
to your site:

• Make sure your pages function as expected in the browsers you’re targeting and that 
they “fail gracefully” in other browsers. Your pages should be legible and functional 
in browsers that do not support styles, layers, plug-ins, or JavaScript. (See 
“Checking for browser compatibility” on page 502.) For pages that will fail badly 
in older browsers, consider using the Check Browser behavior to automatically 
redirect visitors to another page. (See “Check Browser” on page 447.)

• Preview your pages in as many different browsers and on as many different 
platforms as possible. This gives you an opportunity to see differences in layout, 
color, font sizes, and default browser window size that cannot be predicted in a 
target browser check. (See “Previewing in browsers” on page 504.)

• Check your site for broken links (and fix them). Other sites undergo redesign 
and reorganization too, and the page you’re linking to may have been moved or 
deleted. For a simple list of links to external sites, you can run a link check. 
Alternatively, you can run a site-wide report that checks for and produces a 
report on invalid external links. (See “Checking links in a page or site” on page 
506, “Opening linked documents in Dreamweaver” on page 508, or “Creating 
reports” on page 510.)
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• Monitor the size of your pages and the time they take to download. Keep in mind 
that for pages that consist of one large table, visitors will see nothing until the 
entire table has finished loading. Consider breaking up large tables; if this is not 
possible, consider putting a small amount of content—such as a welcome 
message or an advertising banner—outside the table at the top of the page so 
users can view this material while the table downloads. (See “Checking download 
time and size” on page 509; for more information on using layer behaviors to 
cover the screen while a page loads, see “Show-Hide Layers” on page 465.)

• Run a few site reports to test and troubleshoot the entire site. You can check 
your entire site for problems such as untitled documents, empty tags, and 
redundant nested tags. Running these reports before you publish your site 
means fewer problems later on. (See “Creating reports” on page 510.)

• Publishing your site—that is, pushing it out and making it live—can be 
accomplished in several ways and is an ongoing process. Once the bulk of the 
site has been published, you or your team will continue to update and maintain 
it. Defining and implementing a version-control system, either with the tools 
Dreamweaver includes or through an external version-control application, is an 
important process.

• Use the Macromedia Dreamweaver discussion forums found at the 
Macromedia Web site. This is a great resource for getting information on 
different browsers, platforms, and so on. 

Checking for browser compatibility
Dreamweaver lets you construct Web pages with elements that are supported by 
all browsers (for example, images and paragraph text), as well as elements that are 
supported only by newer browsers (for example, styles and layers).

The Check Target Browsers feature tests the HTML in your documents to see if 
any tags or attributes are unsupported by your target browsers. The check does not 
alter the document in any way.

The Check Target Browsers feature uses text files called browser profiles to determine 
which tags particular browsers support. Dreamweaver includes predefined profiles 
for Netscape Navigator versions 2.0, 3.0, and 4.0, and for Microsoft Internet 
Explorer versions 2.0, 3.0, 4.0, and 5.0. To modify the existing profiles or to create 
new ones, see “Creating and editing a browser profile” on page 534.

You can run a target browser check on a document, on a directory, or on an 
entire site. Note that doing so does not check scripts in your site.
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To run a target browser check:

1 Choose from the following options:

• To run the check on the current document, save your file. The check is 
performed on the last saved version of the file and does not include 
unsaved changes.

• To run the check on a directory or site, choose Window > Site Files to open the 
Site FTP window; then select a folder from the local directory. The target 
browser check is performed on all the HTML files in this folder and any folders 
inside it. Target browser checks can be performed only on local files.

2 Choose File > Check Target Browsers.

If you have not yet selected a primary browser, you are prompted to do so.

3 From the list of browsers, select the target browser against which you want 
to check your site.

4 Click Do Check.

The target browser report opens in your primary browser (which launches if it 
is not already open). 

5 To save the report for later reference, choose File > Save from the browser.

Note: As the target browser report is a temporary file, it will be lost if you don’t save it 
before browsing to another site.

Using Behaviors to detect browsers 
and plugins
You can use behaviors to determine which browser your visitors are using and to 
determine whether they have a particular plugin installed. For more information 
on behaviors, see “Using Behaviors” on page 435.

Check Browser sends visitors to different pages depending on their browser 
brands and versions. For example, you might want visitors to go to one page if 
they have Navigator 4.0 or later, to go to another page if they have Internet 
Explorer 4.0 or later, and to stay on the current page if they have any other kind of 
browser. (See “Check Browser” on page 447.) 

Check Plugin sends visitors to different pages depending on whether they have the 
specified plugin installed. For example, you might want visitors to go to one page 
if they have Macromedia Shockwave and another page if they do not. (See “Check 
Plugin” on page 449.)
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Previewing in browsers
It’s a good idea to test your pages by previewing them in browsers often 
throughout the Web design and creation process. By using this strategy, you can 
catch errors early and not copy or repeat them.

You can preview documents in your target browsers at any time; you don’t have to 
save the document first. All browser-related functions work, including JavaScript 
behaviors, document-relative and absolute links, ActiveX controls, and Netscape 
plugins, provided that you have installed the required plugins or ActiveX controls. 

Content linked with a root-relative path does not appear when you preview 
documents in a local browser. This is because browsers don’t recognize site roots, 
servers do. To preview content linked with root-relative paths, put the file on a 
remote server and view it from there. (For more information, see “Root-relative 
paths” on page 357.)

You can define up to 20 browsers for previewing. All the browsers you define 
appear on the Preview in Browser menu. It’s a good idea to preview in the 
following browsers: IE 3.0 or 4.0; Netscape 3.0 and 4.0, and at least one text-only 
browser like Lynx.

To preview your document in a browser, do one of the following:

• Choose File > Preview in Browser, then choose one of the listed browsers.

1 If you haven’t selected a browser yet, choose Edit > Preferences > Preview in 
Browser to select one. 

• Press F12 to display the current document in the primary browser.

• Press Control+F12 (Windows) or Command+F12 (Macintosh) to display the 
current document in the secondary browser.

To change your primary browser or define a secondary browser:

1 Choose File > Preview in Browser > Edit Browser List or Edit > Preferences and 
select the Preview in Browser tab.

2 Set previewing preferences as desired.
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Setting Preview in Browser preferences

Preview in Browser preferences display the currently defined primary and 
secondary browsers. To open Preview in Browser preferences, choose Edit > 
Preferences and select Preview in Browser, or choose File > Preview in Browser > 
Edit Browser List.

Preview Using Local Server (Windows only) allows you to choose whether to use 
a local server when you preview a page in a browser. (For this option to work, you 
must be running server software on your local computer.) When this option is 
selected, Dreamweaver supplies the current page for previewing by a local server as 
a URL beginning with http://localhost/. When this option is deselected, 
Dreamweaver opens the document in a browser with a file path beginning with 
file://. In some cases, links specified as root-relative paths do not work correctly 
when opened in a browser with a file:// path. This also applies when you run a 
target browser check. See “Previewing in browsers” on page 504.

The Plus (+) button adds a browser to the list.

The Minus (-) button deletes the selected browser from the list.

Edit changes settings for the selected browser.

Primary Browser and Secondary Browser specify whether the selected browser is 
the primary or secondary browser. F12 opens the primary browser; Control+F12 
(Windows) or Command+F12 (Macintosh) opens the secondary browser.

Testing links by previewing in a browser

Because links are not active within the Document window, you must verify and 
test links by previewing your pages in a browser. For example, you may want to 
check links to images, audio and video files, and so on.

To test links in a browser:

1 Choose File > Preview in Browser or press F12.

2 Click on the active links to verify that the link is working properly. 
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Checking links in a page or site
Fixing broken links (links that no longer follow a valid path or point to a 
nonexistent file) on a large site can be a tedious and time-consuming problem. 
This is because a large site can contain hundreds of links to internal and external 
documents, and the links may change over time. Orphaned files (files that still 
exist in the site but are no longer linked to any file in the site) can be a problem 
too, because they may take up disk space and confuse other team members 
working on the site. 

Use the Check Links feature to search for broken links and unreferenced files in an 
open file, a portion of a local site, or an entire local site. The only links that 
Dreamweaver verifies are links to documents within the site; Dreamweaver 
compiles a list of external links that appear in the selected document or 
documents, but it does not verify them.

When Dreamweaver has finished checking the links in the specified files, it opens 
the Link Checker dialog box. This dialog box displays a list of broken links, 
external links (links that Dreamweaver can’t check because they are outside the 
site), and orphaned files. For more information, see “Opening linked documents 
in Dreamweaver” on page 508.

To check links within the current document:

1 Save the file to a location within a local site.

2 Choose File > Check Links.

To check links within a portion of a local site:

1 Choose Window > Site Files to open the Site window.

2 Choose a site from the Sites pop-up menu.

3 Under Local folder view, select the files or folders to check.

4 Initiate the check using either of these methods:

• Right-click (Windows) or Control-click (Macintosh) one of the selected files 
and choose Check Links > Selected Files/Folders from the context menu.

• Choose File > Check Links.

5 Select a specific link report from the Show pop-up menu. Your choices are 
Broken Links, External Links, and Orphaned Files.

You can only check for Orphaned Files when you check links across an entire site.

6 A list of files that fit the report type you selected appears in the Link Checker 
dialog box.
Chapter 21506



To check links in the entire site:

1 Choose Site > Check Links Sitewide.

The Link Checker dialog box appears.

2 Select a specific link report from the Show pop-up menu. Your choices are 
Broken Links, External Links, and Orphaned Files.

3 A list of files that fit the report type you selected appears in the Link 
Checker dialog box.

Note: If you selected Orphaned Files as your report type, you can delete orphaned 
files from the Link Checker dialog box directly by selecting a file from the list and 
pressing the Delete key. 

To save the complete report as a tab-delimited text file:

Click Save.

Fixing broken links

When you check links in Dreamweaver, the Link Checker dialog box appears with 
a report of broken links, external links, and—if you chose to check the entire 
site—orphaned files. 

You can fix broken links and image references directly in the Link Checker dialog 
box, or you can open files from the list and fix links in the Property inspector.

To fix links in the Link Checker dialog box:

1 In the Broken Links column of the Link Checker dialog box, select 
the broken link. 

A folder icon appears next to the broken link.

2 Click the folder icon to browse to the correct file to link to, or type the correct 
path and file name.

3 Press Tab or Enter.

If there are other broken references to this same file, a dialog box appears 
prompting you to fix the references in the other files as well. Click Yes to have 
Dreamweaver update all the documents on the list that reference this file. Click 
No to have Dreamweaver update the current reference only.

Note: If Enable File Check In and Check Out is turned on for the site, Dreamweaver 
attempts to check out files that require changes. If it cannot check out a file, Dreamweaver 
displays a warning dialog box and leaves broken references unchanged. See “Using Check 
In/Check Out” on page 131.
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To fix links in the Property inspector:

1 In the Link Checker dialog box, double-click an entry in the File column.

Dreamweaver opens the document, selects the offending image or link, and 
highlights the path and file name in the Property inspector. (If the Property 
inspector is not visible, choose Window > Properties to open it.)

2 To set a new path and file name, click the folder icon to browse to the correct 
file, or type over the highlighted text.

If you are updating an image reference and the new image appears at the 
incorrect size, click the W and H labels in the Property inspector or click the 
Refresh button to reset the height and width values. The W and H labels 
change from bold to normal type.

3 Save the file.

As links are fixed, their entries disappear from the Broken Links list. If an entry 
still appears in the list after you have entered a new path or file name in the Link 
Checker (or after you have saved any changes you made in the Property 
inspector), it means that Dreamweaver cannot find the new file. The link is still 
considered broken.

Opening linked documents in Dreamweaver

Links are not active within Dreamweaver; that is, you cannot open the linked 
document by clicking on the link in the Document window.

To open linked documents in Dreamweaver, do one of the following:

• Select the link and choose Modify > Open Linked Page.

• Press Control (Windows) or Command (Macintosh) and double-click the link.

Note: The linked document must reside on your local disk.
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Checking download time and size
The size and estimated download time of the current page appear at the bottom of 
the Document window. Dreamweaver calculates size based on the entire contents 
of the page, including all linked objects such as images and plugins. 

Dreamweaver estimates download time based on the connection speed entered in 
Status Bar preferences. Actual download time varies depending on general 
Internet conditions.

A good guideline to use when checking download times for a particular Web page 
is the eight-second rule. That is, most users will not wait longer than eight seconds 
for a page to load fully.

To set download time and size preferences:

1 Choose Edit > Preferences and then click Status Bar.

2 Choose a connection speed with which to calculate download time.

The average connection speed in the United States is 28.8. If you are designing 
for an intranet, you may want to choose 1500 (T1 speed).

Using Reports to test a site
When testing your site, you can compile and generate reports for several HTML 
attributes by using the Reports command. This command lets you check external 
links, combinable nested font tags, missing Alt text, redundant nested tags, 
removable empty tags, and untitled documents. You can test and troubleshoot 
selected documents or an entire site for these HTML problems before you publish.

Once a report is compiled, you save it as an XML file and import it into an 
existing template file. You can then import the template file into a database or 
spreadsheet and print it, or display it on a Web site. You can also add different 
report types to Dreamweaver through the Macromedia Dreamweaver Exchange 
Web site.(See “Adding extensions to Dreamweaver” on page 93.)

To use the Reports command to work with the check in/check out system and 
Design Notes, see “Using reports to improve workflow” on page 141.
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Creating reports

You can run various types of reports on documents, folders, and sites, sort the 
results, and get additional details about selected results. 

To create a report: 

1 Choose Site > Reports. 

The Reports dialog box appears.

2 Choose a Report category from the Report On pop-up menu.

The Report options are Current Document, Entire Local Site, Selected Files in 
Site, or Folder. (You cannot run a Selected Files in Site report unless you have 
already selected files in the Site window.)

3 Select a report type by clicking the appropriate box. 

You can select one report, or select several to run them simultaneously. 

• Combinable Nested Font Tags creates a report that lists all nested font tags 
that can be combined to clean up the code. For example, <font 
color="#FF0000"><font size="4">STOP!</font></font> is reported. 

• Missing Alt Text creates a report listing all the img tags that don’t have 
alternative text. (Alternative text appears in place of images for text-only 
browsers or for browsers that have been set to download images manually.)

• Redundant Nested Tags creates a report detailing nested tags that should be 
cleaned up. For example, <i> The rain <i> in</i> Spain stays mainly 
in the plain</i> would be reported.
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• Removable Empty Tags creates a report detailing all empty tags that can be 
removed in order to clean up the HTML code. For example, you may have 
deleted an item or image in Code view, but left behind the tags that applied 
to that item.

• Untitled Documents creates a reporting listing all the untitled documents 
found within the selected parameters. Documents with default titles, duplicate 
titles, or missing title tags are all reported.

4 Click Run to create the report.

Depending on what you chose to report on, you may be prompted to save your 
file, define your site, or select a folder (if you haven’t already done so).

5 A list of results is displayed in the Results window. 

To sort the results, click the column heading you want to sort by. You can sort 
by file name, line number, or description. You can also run several different 
reports and keep the different Results windows open.

6 Select a specific result to see a detailed description.

7 Click Open File to go to the selected item in the Document window. 

You can also double-click a result to open the file in the Document window.

8 Click Save Report to save the report as an XML file.

When you save a report, it is saved as an XML file and can be imported into an 
existing template file. You can then import the file into a database or 
spreadsheet and print it, or use the file to display the report on a Web site.

Tip: After running HTML reports, use the Clean Up HTML command to correct any HTML 
errors the reports listed.
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Customizing Dreamweaver

Macromedia Dreamweaver can be customized in many ways, allowing you to 
work in a manner that’s familiar, comfortable, and efficient for you. 

The following are some of the ways you can customize Dreamweaver:

• Set preferences for everything from color schemes and highlighting to site 
configurations and browsers. See “Setting preferences” on page 88.

• Change keyboard shortcuts. To change shortcuts using a graphical interface 
from within Dreamweaver, see “Using the Keyboard Shortcut Editor” on page 
90. If you prefer to edit a text file to change the keyboard shortcuts, see 
“Changing keyboard shortcuts” on page 521.

• Add third-party extensions. See “Adding extensions to Dreamweaver” on page 93.

• Rearrange the objects in the Objects panel so that the ones you use most often 
are always visible, create new categories to reorganize the objects, or add new 
objects. See “Modifying the Objects panel” on page 515.

• Change the names of menu items, add new commands to menus, and remove 
existing commands from menus. See “About customizing Dreamweaver 
menus” on page 517.

• Edit the source formatting profile to gain finer control over the format of 
HTML that Dreamweaver creates. The SourceFormat.txt file includes all the 
settings from the HTML Format preferences and more. See “Changing default 
HTML formatting” on page 530.

• Change how third-party tags (such as ASP and ColdFusion tags) appear in the 
Document window’s Design view. See “Customizing the interpretation of 
third-party tags” on page 537.

• Create your own commands and floating panels using JavaScript. See 
“Extending Dreamweaver: Basics” on page 536.
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Changing the default file type
By default, Dreamweaver shows all the file types it recognizes in the File > Open 
dialog box. You can use a pop-up menu in that dialog box to limit the display to 
certain types of files. If most of your work involves a specific file type (such as ASP 
files), you can change the default display. Whatever file type is listed on the first 
line of the Dreamweaver Extensions.txt file becomes the default.

Note: If you want to see all file types in the File > Open dialog box, even the files 
Dreamweaver can’t open, you must select All Files (*.*). This is different from All 
Documents, which shows only the files Dreamweaver can open.

To change the Dreamweaver default File > Open file type:

1 Make a backup copy of the Extensions.txt file in the Configuration folder.

2 Open Extensions.txt in Dreamweaver or in a text editor.

3 Cut the line corresponding to the new default, and paste it at the beginning of 
the file, to make it the first line of the file. 

4 Save the file, quit Dreamweaver, and start Dreamweaver again.

To see the new default, select File > Open and look at the pop-up menu 
of file types.

To add new file types to the menu in the File > Open dialog box:

1 Make a backup copy of the Extensions.txt file in the Configuration folder.

2 Open Extensions.txt in Dreamweaver or a text editor.

3 Add a new line for each new file type. In capital letters, enter the file name 
extensions that the new file type can have, separated by commas; then add a 
colon and a brief descriptive phrase to show in the pop-up menu for file 
types that appears in the File > Open dialog box. For example, for JPEG files, 
enter the following:

JPG,JPEG,JFIF:JPEG Image Files

4 Save the file, quit Dreamweaver, and start Dreamweaver again.

To see the changes, select File > Open and click the pop-up menu of file types.
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Modifying the Objects panel
By default, the Objects panel is divided into several categories: Characters, 
Common, Forms, Frames, Head, Invisibles, and Special. (For information on the 
objects in these categories, see “Using the Objects panel” on page 80.) The 
categories correspond to folders in the Configuration/Objects folder within the 
Dreamweaver application folder.

You can move objects from one category to another, rename categories, and remove 
objects from the panel altogether. To make your changes appear in the Objects 
panel, you must either quit Dreamweaver and start it again, or reload extensions.

For each object in an Objects panel category, there are two or three files in the 
corresponding folder:

• A GIF file containing an icon for the object

• An HTML file containing either the HTML to be inserted into your file 
or an HTML form that lets you specify data to be inserted (such as the text 
of a comment)

• A JavaScript file (optional) that generates the HTML to be inserted into your file

To move an object from one Objects panel category to another:

Move all of the object’s files (its GIF file, its HTML file, and its JavaScript file if it 
has one) from one folder to another within the Configuration/Objects folder.

To rename a category on the Objects panel:

Rename the corresponding folder in the Configuration/Objects folder.

To remove an object from the Objects panel:

Move the object’s HTML, GIF, and JavaScript files out of the Configuration/
Objects folder. (You can delete those files entirely if you’re sure you want to 
remove the object, but it’s a good idea to keep a backup around just in case you 
need to restore the object later.)

To reload extensions:

1 Control-click (Windows) or Option-click (Macintosh) the categories pop-up 
menu at the top of the Objects panel.

2 Choose Reload Extensions.
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Creating a simple object
You can create your own objects to add to the Objects panel. Many simple objects 
require no JavaScript; they contain only the HTML source code to be inserted 
into the document. (For basic information about creating more complex objects 
using JavaScript, see “Extending Dreamweaver: Basics” on page 536.)

After you create an object, you can package it and distribute it on the Macromedia 
Exchange site if you want other Dreamweaver users to be able to use it. For more 
information, see the Macromedia Exchange for Dreamweaver site. To package an 
extension, you must first download the Package Manager installer from that site, 
then install the Package Manager with the developer option.

To create a simple object:

1 Create a new blank document in a text editor (such as BBEdit or HomeSite).

Note: When you create a new blank document in Dreamweaver, it contains several 
default HTML tags, such as html, head, and body. If you want to use one of the 
Dreamweaver code editors (the Document window’s Code view or the Code inspector) 
as your text editor for creating a simple object, you must first delete all the default tags 
that appear in the code editor when you create a new document.

2 Add the tags that you want this object to insert into your documents.

For example, type the following:

<p>
&copy; 2000 Z Productions, Inc.<BR>
All Rights Reserved
</p>

3 Save the file.

If you want the new object to appear in one of the existing Objects panel 
categories, save it in one of the subfolders of the Objects folder. To create a new 
category, create a new folder within the Configuration/Objects folder and save 
your file there. Additional folders inside any category subfolder (such as folders 
created inside the Characters subfolder) are ignored.

4 In a graphics or image-editing application (such as Macromedia Fireworks), 
create an 18 x 18 pixel GIF image that will serve as the icon for your object in 
the Objects panel.

If you create a larger image, Dreamweaver automatically scales it to 18 x 18 
pixels. If you do not create an icon for your object, Dreamweaver displays a 
generic object icon for your object in the Objects panel.
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5 Give your icon the same file name as your object file, but use .gif as the 
extension; then save the icon in the same directory as the object file.

For example, if your object is called Copyright_Z.htm and you saved it in the 
Common directory, name your icon Copyright_Z.gif and save it in the 
Common directory as well.

6 Restart Dreamweaver, or reload extensions, to use your new object. 

The object appears at the bottom of the Insert menu as well as on the Objects 
panel. (For information on reloading extensions, see “Modifying the Objects 
panel” on page 515.)

About customizing Dreamweaver menus
Dreamweaver creates all of its menus from the structure defined in an XML file 
called menus.xml, in the Configuration/Menus subfolder of the Dreamweaver 
application folder. Editing the menus.xml file changes the Dreamweaver menus 
the next time you start Dreamweaver. (For basic information about XML, see 
“About XML” on page 394.)

By editing the menus.xml file, you can add, change, and remove keyboard 
shortcuts for menu items, though in most cases it’s easier to do that using the 
Keyboard Shortcut Editor. (See “Using the Keyboard Shortcut Editor” on page 
90.) You can also rearrange, rename, and remove menu items.

If you open menus.xml in an XML editor, you may see error messages regarding 
the ampersands (&) in the menus.xml file. It’s best to edit menus.xml in an 
ordinary text editor. (Don’t edit it in Dreamweaver.)

Note: Always make a backup copy of the current menus.xml file, or any other 
Dreamweaver configuration file, before you modify it. It’s easy to make mistakes in editing 
the menu configuration file, and there’s no way to revert to a previous set of menus other 
than replacing the menus.xml file. In case you forget to make a backup, though, the 
Configuration folder contains a backup of the default menus.xml file, called menus.bak; to 
revert to the default menu set, replace menus.xml with a copy of menus.bak.
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Modifying the Commands menu

You can add certain kinds of commands to the Commands menu, and change 
their names, without editing the menus.xml file.

Note: The term command has two meanings in Dreamweaver. Strictly speaking, a 
command is a particular kind of extension. In some contexts, however, command is used 
interchangeably with menu item to mean any item that appears in a Dreamweaver menu, no 
matter what it does or how it’s implemented. 

To create new commands that are automatically placed in the Commands 
menu, use the History panel (see “Creating new commands from history steps” on 
page 165). You can also use the Package Manager to install new extensions, 
including commands; see “Adding extensions to Dreamweaver” on page 93.

To reorder the items in the Commands menu, or to move items between menus, 
you must edit the menus.xml file. 

To rename a command you’ve created:

1 Choose Commands > Edit Command List.

A dialog box appears, listing all of the commands whose names you can change. 
(Commands that are in the default Commands menu don’t appear on this list 
and can’t be edited using this approach.)

2 Select a command to rename.

3 Enter a new name for it.

4 Click Close.

The command is renamed in the Commands menu.

To delete a command you’ve created:

1 Choose Commands > Edit Command List.

A dialog box appears listing all of the commands you can delete. (Commands 
that are in the default Commands menu don’t appear on this list and can’t be 
deleted using this approach.)

2 Select a command to delete.

3 Click Delete, then confirm that you want to delete the command.

The command is deleted. Note that the file containing the code for the 
command is also deleted; deleting a command does not simply remove the 
menu item from the menu. Be certain that you really want to delete the 
command before you use this approach. If you want to remove it from the 
Commands menu without deleting the file, you can find the file in 
Configuration/Commands and move it to another folder.

4 Click Close.
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Rearranging menus and menu items

By editing the menus.xml file, you can move menu items within a menu or from 
one menu to another, add separators to or remove them from menus, and move 
menus within a menu bar or even from one menu bar to another.

Note that you can move items into or out of context menus using the same 
procedure as for other menus.

For information about the syntax of the menus.xml file, see “About menus.xml tag 
syntax” on page 522.

To move a menu item:

1 Quit Dreamweaver.

2 Make a backup copy of the menus.xml file.

3 Open menus.xml in a text editor such as BBEdit, HomeSite, or Wordpad. 
(Don’t open it in Dreamweaver.)

4 Cut an entire menuitem tag, from the <menuitem at the beginning to the /> 
at the end. 

5 Place the insertion point at the new location for the menu item. (Make sure it’s 
between a <menu> tag and the corresponding </menu> tag.)

6 Paste the menu item into its new location.

To create a submenu while moving a menu item:

1 Place the insertion point inside a menu (somewhere between a <menu> tag and 
the corresponding </menu> tag).

2 Insert a new <menu></menu> pair inside the menu.

3 Add new menu items to the new submenu.

To insert a separator between two menu items:

Enter <separator /> between the two menuitem tags.

To remove an existing separator:

Delete the corresponding <separator /> line.
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To move a menu:

1 Quit Dreamweaver.

2 Make a backup copy of the menus.xml file.

3 Open menus.xml in a text editor such as BBEdit, HomeSite, or Wordpad. 
(Don’t open it in Dreamweaver.)

4 Cut an entire menu and its contents, from the opening <menu> tag to the 
closing </menu> tag. 

5 Place the insertion point at the new location for the menu. (Make sure it’s 
between a <menubar> tag and the corresponding </menubar> tag.)

6 Paste the menu into its new location.

Changing the name of a menu item or menu

You can easily change the name of any menu item or menu by editing the 
menus.xml file. For information about the syntax of the menus.xml file, see 
“About menus.xml tag syntax” on page 522.

To change the name of a menu item or menu:

1 Quit Dreamweaver.

2 Make a backup copy of the menus.xml file.

3 Open menus.xml in a text editor such as HomeSite, BBEdit, or Wordpad 
(don’t open it in Dreamweaver).

4 If you’re changing a menu item, find the appropriate menuitem tag, and change 
the value of its name attribute. If you’re changing a menu, find the appropriate 
menu tag, and change the value of its name attribute.

Note: In either case, do not change the id attribute.

5 Save and close menus.xml; then start Dreamweaver again to see your changes.
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Changing keyboard shortcuts

If the default keyboard shortcuts aren’t convenient for you, you can change or 
remove existing shortcuts or add new ones. The easiest way to do this is to use the 
Keyboard Shortcut Editor (see “Using the Keyboard Shortcut Editor” on page 
90). However, you can also modify keyboard shortcuts directly in menus.xml if 
you prefer, though it’s much easier to make mistakes entering shortcuts in 
menus.xml than in the Keyboard Shortcut Editor. For information about the 
syntax of the menus.xml file, see “About menus.xml tag syntax” on page 522.

To change a keyboard shortcut:

1 Quit Dreamweaver.

2 Make a backup copy of the menus.xml file.

3 Open menus.xml in a text editor such as BBEdit, HomeSite, or Wordpad. 
(Don’t open it in Dreamweaver.)

4 Look at the “Keyboard Shortcut Matrix” on page 558 and find a shortcut that’s 
not being used, or one that you want to reassign. 

If you reassign a keyboard shortcut, cross it off on a printed copy of the matrix 
for future reference.

5 If you’re reassigning a keyboard shortcut, find the menu item that the shortcut 
is assigned to, and remove the key="shortcut" attribute from that menu item.

6 Find the menu item to assign or reassign the keyboard shortcut to.

7 If the menu item already has a keyboard shortcut, find the key attribute on that 
line. If it doesn’t already have a shortcut, add key="" anywhere between 
attributes inside the menuitem tag.

8 Between the double quotation marks of the key attribute, enter the new 
keyboard shortcut.

Use a plus (+) sign between the keys in a key combination. For more 
information about modifiers, see the description of the menuitem tag in 
“<menuitem>” on page 524.

If the keyboard shortcut is in use elsewhere and you didn’t remove the other 
use of it, the shortcut will apply only to the first menu item that uses it 
in menus.xml.

Note: You can use the same keyboard shortcut for a Macintosh-only menu item and for 
a Windows-only menu item.

9 Write your new shortcut in the appropriate location in the Keyboard 
Shortcut Matrix.
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About menus.xml tag syntax

The menus.xml file contains a structured list of menu bars, menus, menu items, 
separators, shortcut lists, and keyboard shortcuts. These items are described by 
XML tags which you can edit in a text editor.

Note: Be careful when making changes to menus. Dreamweaver ignores any menu or 
menu item that contains an XML syntax error.

A menu bar (tagged with opening and closing menubar tags) is a discrete menu or 
set of menus—for example, there’s a main menu bar, a separate Site window menu 
bar (which appears only in Windows, not on the Macintosh), and a menu bar for 
each context menu. Each menu bar contains one or more menus; a menu is 
contained in a menu tag. Each menu contains one or more menu items, each 
described by a menuitem tag and its attributes. A menu can also contain separators 
(described by separator tags) and submenus.

In addition to the keyboard shortcuts associated with menu items, Dreamweaver 
provides a variety of other keyboard shortcuts, including alternate shortcuts and 
shortcuts that are available only in certain contexts. For example, Control+Y 
(Windows) or Command+Y (Macintosh) is the shortcut for Redo; but 
Control+Shift+Z or Command+Shift+Z is an alternate shortcut for Redo. These 
alternates—and other shortcuts that can’t be represented in the tags for menu 
items—are defined in shortcut lists in the menus.xml file. Each shortcut list 
(described by a shortcutlist tag) contains one or more shortcuts, each 
described by a shortcut tag.

The following sections describe the syntax of the menus.xml tags. Optional 
attributes are marked in the attribute lists with braces ({}); all attributes not 
marked with braces are required.
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<menubar>

Description

Provides information about a menu bar in the Dreamweaver menu structure.

Attributes

name, {app}, id, {platform}

name The name of the menu bar. Although name is a required attribute, you can 
give it the value "".

app The name of the application in which the menu bar is available. Valid 
values are "dreamweaver" and "ultradev". The default is for the menu bar to be 
available in both Dreamweaver and UltraDev.

id The menu ID for the menu bar. Each menu ID in the menus.xml file should 
be unique.

platform Indicates that the menu bar should appear only on the given 
platform. Valid values are "win" and "mac".

Contents

This tag must contain one or more menu tags.

Container

None.

Example

The main (Document window) menu bar uses the following menubar tag:

<menubar name="Main Window" id="DWMainWindow">
<!-- menu tags here -->

</menubar>
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<menu>

Description

Provides information about a menu or submenu to appear in the Dreamweaver 
menu structure.

Attributes

name, {app}, id, {platform}

name The name of the menu as it will appear in the menu bar. To set the menu’s 
access key (mnemonic) in Windows, use an underscore (_) before the access letter. 
The underscore is automatically removed on the Macintosh.

app The name of the application in which the menu is available. Valid values are 
"dreamweaver" and "ultradev". The default is for the menu to be available in 
both Dreamweaver and UltraDev.

id The menu ID for the menu. Every ID in the file should be unique.

platform Indicates that the menu should appear only on the given platform. 
Valid values are "win" and "mac".

Contents

This tag can contain one or more menuitem tags, and one or more separator 
tags. It can also contain other menu tags (to create submenus) and standard 
HTML comment tags. 

Container

This tag must be contained in a menubar tag.

Example

<menu name="_File" id="DWMenu_File">
<!-- menuitem, separator, menu, and comment tags here -->

</menu>

<menuitem>

Description

Defines a menu item for a Dreamweaver menu.

Attributes

name, id, {app}, {key}, {platform}, {enabled}, {arguments}, {command}, 
{file}, {checked}, {dynamic}

name The menu item name that appears in the menu. An underscore indicates that 
the following letter is the command’s access key (mnemonic), for Windows only.

id Used by Dreamweaver to identify the item. This ID must be unique 
throughout the menu structure. If you add new menu items to menus.xml, ensure 
uniqueness by using your company name or another unique string as a prefix for 
each menu item’s ID.
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app The name of the application in which the menu item is available. Valid 
values are "dreamweaver" and "ultradev". The default is for the menu item to 
be available in both Dreamweaver and UltraDev.

key The keyboard shortcut for the command, if any. Use the following strings to 
specify modifier keys: 

• Cmd specifies the Control key (Windows) or Command key (Macintosh).

• Alt and Opt interchangeably specify the Alt key (Windows) or Option 
key (Macintosh).

• Shift specifies the Shift key on both platforms.

• Ctrl specifies the Control key on both platforms.

• A plus (+) sign separates modifier keys if a given shortcut uses more than one 
modifier. For example, Cmd+Opt+5 in the key attribute means the menu item is 
executed when the user presses Control+Alt+5 (Windows) or 
Command+Option+5 (Macintosh).

• Special keys are specified by name: F1 through F12, PgDn, PgUp, Home, 
End, Ins, Del, Tab, Esc, BkSp, and Space. Modifier keys can also be applied 
to special keys.

platform Indicates which platform the item appears on. Valid values are "win", 
meaning Windows-only, or "mac", meaning Macintosh-only. If you don’t specify 
the platform attribute, the menu item appears on both platforms. If you want a 
menu item to behave differently on different platforms, supply two menu items 
with the same name (but different IDs): one with platform="win" and the other 
with platform="mac".

enabled Provides JavaScript code (usually a JavaScript function call) that 
determines whether the menu item is currently enabled. If the function returns 
false, the menu item is dimmed. The default value is "true", but it’s best to 
always specify a value for clarity even if the value is "true".

arguments Provides arguments for Dreamweaver to pass to the code in the 
JavaScript file that you specify in the file attribute. Enclose arguments in single 
quotation marks ('), inside the double quotation marks used to delimit an 
attribute’s value.

command Specifies a JavaScript expression that’s executed when the user selects 
this item from the menu. For complex JavaScript code, use a JavaScript file 
(specified in the file attribute) instead. You must specify either file or command 
for each menu item.
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file The name of an HTML file containing JavaScript that controls the menu 
item. Specify a path to the file relative to the Configuration folder. (For example, 
the Help > Welcome menu item specifies file="Commands/Welcome.htm".) 
Note that the file attribute overrides the command, enabled, and checked 
attributes. You must specify either file or command for each menu item. For 
information on creating a command file using the History panel, see “Creating 
new commands from history steps” on page 165. For information on writing your 
own JavaScript commands from scratch, see Extending Dreamweaver.

checked A JavaScript expression that indicates whether the menu item has a 
check mark next to it in the menu; if the expression evaluates as true, the item is 
displayed with a check mark.

dynamic If present, indicates that a menu item is to be determined dynamically, 
by an HTML file; the file contains JavaScript code to set the text and state of the 
menu item. If you specify a tag as dynamic, you must also specify a file attribute.

isdomrequired Indicates whether to synchronize the Design view and the Code 
view before executing the code for this menu item. Valid values are "true" (the 
default) and "false". If you set this attribute to "false", it means that the 
changes to the file that this menu item makes do not use the Dreamweaver DOM. 
(For information about the DOM, see Extending Dreamweaver.)

Contents

None (empty tag).

Container

This tag must be contained in a menu tag.

Example

<menuitem name="_New" key="Cmd+N" enabled="true" 
command="dw.createDocument()" id="DWMenu_File_New" />
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<separator>

Description

Indicates that a separator should be displayed at the corresponding location 
in the menu.

Attributes

{app}

app The name of the application in which the separator is shown. Valid values 
are "dreamweaver" and "ultradev". The default is for the separator to be shown 
in both Dreamweaver and UltraDev.

Contents

None (empty tag).

Container

This tag must be contained in a menu tag.

Example

<separator />

<shortcutlist>

Description

Specifies a shortcut list in the menus.xml file.

Attributes

{app}, id, {platform}

app The name of the application in which the shortcut list is available. Valid 
values are "dreamweaver" and "ultradev". The default is for the shortcut list to 
be available in both Dreamweaver and UltraDev.

id The ID for the shortcut list. It should be the same as the menu ID for the 
menu bar (or context menu) in Dreamweaver that the shortcuts are associated 
with. Valid values are "DWMainWindow", "DWMainSite", "DWTimelineContext", 
and "DWHTMLContext". 

platform Indicates that the shortcut list should appear only on the given 
platform. Valid values are "win" and "mac".

Contents

This tag can contain one or more shortcut tags. It can also contain one or more 
comment tags (which use the same syntax as HTML comment tags).

Container

None.

Example

<shortcutlist id="DWMainWindow">
<!-- shortcut and comment tags here -->

</shortcutlist>
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<shortcut>

Description

Specifies a keyboard shortcut in the menus.xml file.

Attributes

key, {app}, {platform}, {file}, {arguments}, {command}, id, {name}

key The key combination that activates the keyboard shortcut. For syntax 
details, see “<menuitem>” on page 524.

app The name of the application in which the shortcut is available. Valid values 
are "dreamweaver" and "ultradev". The default is for the shortcut to be 
available in both Dreamweaver and UltraDev.

platform Specifies that the shortcut works only on the indicated platform. 
Valid values are "win" and "mac". If you do not specify this attribute, the shortcut 
works on both platforms.

file The path to a file containing the JavaScript code that Dreamweaver 
executes when you use the keyboard shortcut. The file attribute overrides the 
command attribute. You must specify either file or command for each shortcut.

arguments Provides arguments for Dreamweaver to pass to the code in the 
JavaScript file that you specify in the file attribute. Enclose arguments in single 
quotation marks ('), inside the double quotation marks used to delimit an 
attribute’s value.

command The JavaScript code that Dreamweaver executes when you use the 
keyboard shortcut. Specify either file or command for each shortcut.

id A unique identifier for a shortcut.

name A name for the command executed by the keyboard shortcut, in the style 
of a menu item name. For example, the name attribute for the F12 shortcut is 
"Preview in Primary Browser".

Contents

None (empty tag).

Container

This tag must be contained in a shortcutlist tag.

Example

<shortcut key="Cmd+Shift+Z" file="Menus/MM/Edit_Clipboard.htm" 
arguments="'redo'" id="DWShortcuts_Edit_Redo" />
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Customizing the appearance of 
dialog boxes
The dialog box layouts for objects, commands, and behaviors are specified as 
HTML forms; they reside in HTML files in the Configuration folder within the 
Dreamweaver application directory. You edit those forms just as you would edit 
any form in Dreamweaver; see “Creating Forms” on page 481.)

To change the appearance of a dialog box:

1 Find the appropriate .htm file in Configuration/Objects, Configuration/
Commands, or Configuration/Behaviors.

2 Make a copy of the file, somewhere other than the Configuration folder.

3 Open the copy in Dreamweaver, edit the form, and save it.

4 Quit Dreamweaver.

5 Copy the changed file back to the Configuration folder, in place of the original. 
(It’s a good idea to first make a backup of the original, so you can restore it later 
if you need to.)

6 Start Dreamweaver again to see the changes.

You should change only the appearance of the dialog box, not how it works; it 
still must contain the same types of form elements with the same names, so 
that the information Dreamweaver obtains from the dialog box can still be used 
in the same way.

For example, the Comment object takes text input from a text area in a dialog 
box, then uses a simple JavaScript function to turn that text into an HTML 
comment and insert the comment into your document. The form that describes 
the dialog box is in Configuration/Objects/Invisibles/Comment.htm. You can 
open that file and change the size and other attributes of the text area, but if you 
remove the textarea tag entirely, or change the value of its name attribute, the 
Comment object will no longer work properly.
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Changing default HTML formatting
The HTML source formatting profile determines how Dreamweaver formats the 
HTML source code for a document. The profile includes both the Code Format 
preferences (which you can easily set with Edit > Preferences; see “Setting code 
formatting preferences” on page 343 for details) and additional formatting 
preferences for individual tags and groups of tags. The only way to change the 
formatting preferences that aren’t shown in Code Format preferences is to edit the 
SourceFormat.txt file in a text editor. That file can be found in the Configuration 
folder within the Dreamweaver application folder.

Code Format preferences set with the Edit > Preferences command are saved in 
SourceFormat.txt when you quit Dreamweaver. You must therefore quit the 
application before editing the profile; otherwise, your changes may be overwritten 
when you quit Dreamweaver.

The HTML source formatting profile follows a specific format, which is described 
in the file. Note the following conventions:

• Each section of the profile begins with a tag of the form <?keyword> (such as 
<?options>, <?elements>, or <?attributes>).

• The parameters for each section are defined within HTML comments 
(<!-- -->) directly above the section.

• The omit line in the <?options> section is reserved for future use (it currently 
does not affect HTML source formatting).

• You can mark an individual tag as belonging to an indentation group (igroup) 
in the <?elements> section. By default, indentation group 1 contains table 
rows and columns, and indentation group 2 contains framesets and frames. 
These groupings correspond to the Indent Table Rows and Columns and 
Indent Framesets and Frames options in HTML Format preferences. You can 
turn off indentation for the entire group by removing its number from the 
active attribute in the <?options> section. You can also add other tags to 
either indentation group so you can control them with the options in HTML 
Format preferences.

The four numbers given in the break attribute for each tag indicate respectively 
how many line breaks to use before the opening tag, how many to use immediately 
after the opening tag (and before the contents of the tag), how many to use 
immediately before the closing tag, and how many to place after the closing tag.

For example, the default settings for the p tag in SourceFormat.txt are 
<p break="1,0,0,1" indent>, which produces the following formatting:

<p> A paragraph of text that is indented from the left margin 
(after the first line) and that has a line break before the 
opening p tag and after the closing p tag, but no line break 
after the opening p and none before the closing p.</p>

<p>Next paragraph.</p>
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If you change the settings to <p break="1,1,1,2">, the Code view and Code 
inspector will display text paragraphs in the following way:

<p>
A paragraph of text that is not indented from the left margin 
and that has one line break before and after the opening p tag, 
one line break before the closing p tag, and two line breaks 
after the closing p tag.
</p>

<p>
Next paragraph.
</p>

(Note that the number of line breaks after the closing tag and before the following 
opening tag is the greater of the two numbers specified—if you specify two line 
breaks before a tag and three after, the result is three line breaks between the 
closing tag and the next opening tag.)

Some tag and attribute settings include the term namecase, which specifies that 
the tag or attribute is to be capitalized in exactly the way that you specify as the 
value of the namecase attribute. For example, onClick is specified in the 
SourceFormat.txt file as <onClick namecase="onClick">; therefore, onClick is 
always displayed using that particular combination of uppercase and lowercase, 
regardless of user capitalization preferences.

Another term used to specify capitalization is samecase, which specifies that the 
value of an attribute is to be capitalized the same way that the attribute’s name is 
capitalized. For example, <align samecase> indicates that if Dreamweaver 
generates an align attribute, the value of the attribute will appear with the same 
capitalization as the attribute name. It also applies to attribute names that don’t 
have values, so don’t remove samecase from any of the attribute formatting 
specifications where it appears.

The term noformat associated with a tag indicates that the line breaks, 
indentation, and capitalization of an existing instance of the tag are never changed 
to use the format specified in SourceFormat.txt. For a tag marked noformat, the 
format specified in SourceFormat.txt is used only when creating a new instance of 
the tag using Dreamweaver. For example, <pre break="1,0,0,1" noformat> 
means that if you create a new pre tag using Dreamweaver tools, it will use the 
"1,0,0,1" line break specification when creating it; but if you already have a pre 
tag that you created by hand whose line breaks don’t match this specification, and 
you edit that tag in the Design view, the line breaks don’t change.

Any attribute not specified in the SourceFormat.txt file uses the default formatting 
settings that you specify in the HTML Format preferences category.
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Working with browser profiles
Browser profiles are the files Dreamweaver uses to check your documents when 
you run a target browser check (see “Checking for browser compatibility” on page 
502). Each profile contains information about the HTML tags and attributes that 
a particular browser supports. A browser profile can also contain warnings, error 
messages, and suggestions for tag substitutions.

Browser profiles are stored in the Configuration/BrowserProfiles folder within the 
Dreamweaver application folder. You can edit existing profiles or create new ones 
using Dreamweaver or a text editor (such as BBEdit, HomeSite, Notepad, or 
SimpleText). It is not necessary to quit Dreamweaver before editing or creating 
browser profiles.

About browser-profile formatting

Browser profiles follow a specific format. To avoid parsing errors during target 
browser checks, follow these rules when editing or creating profiles:

• The first line is reserved for the name of the profile. It must be followed by a 
single carriage return. The name on this line appears in the Target Browser 
Check dialog box and in the target check report. It must be unique.

• The second line is reserved for the designator 
PROFILE_TYPE=BROWSER_PROFILE. Dreamweaver uses this line to determine 
which documents are browser profiles. Do not change or move this line.

• Two hyphens (--) at the beginning of a line indicate a comment (that is, that 
the line will be ignored during the target check process). A comment must start 
at the beginning of a line—you can’t put two hyphens in the middle of a line.

• You must use a space in these places: before the closing angle bracket (>) on the 
!ELEMENT line, after the opening parenthesis in a list of values for an attribute, 
before a closing parenthesis in a list of values, and before and after each pipe (|) 
in a list of values.

• You must include an exclamation point without a space before each of the 
following words: ELEMENT, ATTLIST, Error, msg, and htmlmsg (!ELEMENT, 
!ATTLIST, !Error, !msg, !htmlmsg). 

• You can include !Error and !Warning within the !ELEMENT or the 
!ATTLIST area.

• !msg messages can contain only plain text. !htmlmsg messages can contain 
any valid HTML, including hyperlinks.

• HTML comments (<!-- -->) cannot be listed as tags in browser profiles 
because they interfere with parsing. Dreamweaver does not report an error 
for comments, because all browsers support them.
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The syntax for a tag entry is as follows:

<!ELEMENT htmlTag NAME="tagName" >
<!ATTLIST htmlTag 
unsupportedAttribute1!Error !msg="The unsupportedAttribute1 
attribute of the htmlTag tag is not supported. Try using 
supportedAttribute1 for a similar effect."
supportedAttribute1
supportedAttribute2( validValue1 | validValue2 | validValue3 )
unsupportedAttribute2!Error !htmlmsg="<b>Don't ever use the 
unsupportedAttribute2 attribute of the  htmlTag tag!</b>"
>

The elements shown in the above syntax are defined as follows:

htmlTag is the tag as it appears in an HTML document.

tagName is an explanatory name for the tag (for example, the name for the HR tag 
is “Horizontal Rule”). The NAME attribute is optional. If specified, tagName is used 
in error messages; if you do not supply a name, htmlTag is used in error messages.

unsupportedAttribute is an attribute that is not supported. Any tags or attributes 
not specifically mentioned as supported attributes are assumed to be unsupported. 
Specify unsupported tags or attributes only when you want to create a custom 
error message.

supportedAttribute is an attribute that is supported by htmlTag. Only tags listed 
without an !Error designation are considered to be supported by the browser.

validValue indicates a value that is supported by the attribute.
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The following example shows an entry for the APPLET tag that would be accurate 
for Navigator 3.0:

<!ELEMENT APPLET Name="Java Applet" >
<!ATTLIST APPLET

Align ( top | middle | bottom | left | right | absmiddle | 
absbottom | baseline | texttop )
Alt
Archive
Class !Warning !htmlmsg="This browser ignores the 
<CODE>CLASS</CODE> attribute for the <CODE>APPLET</CODE> tag."
Code
Codebase
Height
HSpace
ID !Warning !htmlmsg="This browser ignores the 
<CODE>ID</CODE> attribute for the <CODE>APPLET</CODE> tag. 
Use <CODE>NAME</CODE> instead."
Name
Style !Warning !htmlmsg="This browser ignores the 
<CODE>STYLE</CODE> attribute for the <CODE>APPLET</CODE> tag."
VSpace
Width

>

Creating and editing a browser profile

Create a browser profile by modifying an existing profile. For example, to create 
a profile for a future version of Microsoft Internet Explorer, you can open the 
profile for the most recent version of Internet Explorer that has a profile, add 
any new tags or attributes introduced in the new version, and save it as a profile 
for the new version.

Note: Before you create a browser profile for a new version of a browser, check the 
Macromedia Exchange for Dreamweaver site to see if Macromedia has supplied a browser 
profile that you can download and install using the Package Manager.
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To create or edit a browser profile:

1 Using a text editor, open an existing profile.

If you’re creating a new profile, open the profile that most closely resembles the 
profile you intend to create, then save the file under a new file name.

2 If you’re creating a new profile, change the name that appears on the first line of 
text in the file.

Two profiles cannot have the same name.

3 Add any new tags or attributes you know to be supported by the browser, using 
the syntax shown in “About browser-profile formatting” on page 532.

If you don’t want to receive error messages about a particular unsupported tag, 
add it to the list of supported tags. If you do this, save the profile in a separate 
file with a new file name (such as Browsername x.x limited). Renaming the 
profile preserves the original profile with only the tags that are truly supported.

4 Delete any tags or attributes that are not supported by the browser.

This step is probably unnecessary if you are creating a profile for a new version 
of Netscape Navigator or Microsoft Internet Explorer, because browsers rarely 
drop support for tags.

5 Add any custom error messages according to the syntax shown in “About 
browser-profile formatting” on page 532.

The profiles that come with Dreamweaver list all supported tags for the 
specified browsers. To add a custom error message to a tag, add either !msg 
"message" or !htmlmsg "<tag>message</tag>" after !Error. For example, 
this information appears in the Netscape Navigator 3.0 profile (along with 
other attributes not shown here):

<!ELEMENT HR name="Horizontal Rule" >
<!ATTLIST HR

COLOR    !Error
>

To add a custom error message enter !msg: and then your error message, in 
quotation marks:

<!ELEMENT HR name="Horizontal Rule" >
<!ATTLIST HR

COLOR    !Error !msg "Internet Explorer 3.0 supports the 
COLOR tag in horizontal rules, but Netscape Navigator 3.0 
does not."

>

6 You can use !Error for all error situations, or you can use !Warning to indicate 
that a tag will be ignored but will not actually cause an error.
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Extending Dreamweaver: Basics
Dreamweaver is designed to be extensible. It includes a JavaScript interpreter, so it 
can read and execute JavaScript code; and it provides an application programming 
interface (API), a large set of JavaScript functions that allow developers to extend 
the capabilities of Dreamweaver. Dreamweaver also provides a Document Object 
Model (DOM), which allows extensions to examine and modify a document’s 
structure and contents.

Using the JavaScript API, you can create objects, behavior actions, commands, 
Property inspectors, floating panels, and data translators (all of which are 
collectively called extensions).

You can also create new objects and simple commands without knowing 
anything about programming; for details, see “Creating a simple object” on page 
516 and “Creating new commands from history steps” on page 165. But to 
add more advanced capabilities to Dreamweaver, you must write extensions in 
either JavaScript or C. For information about the DOM and the API, see 
Extending Dreamweaver.

After you create a Dreamweaver extension, you can package it and distribute it on 
the Macromedia Exchange site if you want other Dreamweaver users to be able to 
use it. For more information, see the Macromedia Exchange for Dreamweaver site. 
To package an extension, you must first download the Package Manager installer 
from that site, then install the Package Manager with the developer option.

About JavaScript

JavaScript is an interpreted programming language. To learn more about 
JavaScript, read a good JavaScript book, such as JavaScript Bible by Danny 
Goodman (IDG) or JavaScript: The Definitive Guide by David Flanagan 
(O’Reilly). For information on using JavaScript to extend Dreamweaver, see 
Extending Dreamweaver.

Note: Despite the resemblance between the two names, JavaScript is not related to 
Java in any way. 
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Editing Dreamweaver commands

All the commands in Dreamweaver menus, including those you create and save 
using the History panel (see “Creating new commands from history steps” on 
page 165), are implemented in JavaScript. This JavaScript code usually consists 
mostly of calls to functions provided by the Dreamweaver extensibility API. If you 
know JavaScript and understand the Dreamweaver extensibility API, you can edit 
the JavaScript to change the operation of Dreamweaver commands.

Note: Don’t attempt to change any JavaScript code unless you’re certain you know what 
you’re doing. Even if you do know what you’re doing, make a backup copy of the file 
containing the code before you modify it.

To rename a command, move a command to a different menu, or add a keyboard 
shortcut to a command, see “About customizing Dreamweaver menus” on page 517.

Customizing the interpretation of 
third-party tags
Server-side processing technologies such as ASP, ColdFusion, JSP, and PHP use 
special non-HTML code in HTML files; servers create and serve HTML content 
based on that code. When Dreamweaver encounters non-HTML tags, it 
compares them with information in its third-party tag files, which define how 
Dreamweaver reads and displays non-HTML tags.

For example, ASP files contain—in addition to regular HTML—ASP code for the 
server to interpret. ASP code looks something like a tag, but is marked by a pair of 
delimiters: it begins with <% and ends with %>. The Dreamweaver Configuration/
ThirdPartyTags folder contains a file named ASP.xml, which describes the format 
of ASP code and defines how Dreamweaver displays that code. Because of the way 
ASP code is specified in ASP.xml, Dreamweaver doesn’t try to interpret anything 
between the delimiters; instead, in the Design view of the Document window, it 
simply displays an icon indicating ASP code.

You can define your own tags and create tag database files that define how 
Dreamweaver reads and displays your tags. Creating tag database files is 
particularly useful if you’re using a server-side markup system other than ASP, JSP, 
ColdFusion, or PHP; create a new tag database file for each such markup system, 
to tell Dreamweaver how to display the tags. (There is no separate JSP tag 
database file; JSP code uses the same delimiters as ASP code, so Dreamweaver uses 
the ASP tag database file for JSP.)

Note: This section explains how to define the way Dreamweaver displays a custom tag, but 
doesn’t describe how to provide a way to edit the content or properties of a custom tag. For 
information on how to create a Property inspector to inspect and change the properties of 
a custom tag, see “Property Inspectors” in Extending Dreamweaver.
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Each tag database file defines the name, type, content model, rendering scheme, 
and icon for one or more custom tags. You can create any number of tag 
database files, but all of them must reside in the Configuration/ThirdPartyTags 
folder to be read and processed by Dreamweaver. Tag database files have the file 
extension .xml.

Tip: If you are working on several different unrelated sites at once (for example, as a 
freelance developer), you can put all the tag specifications for a particular site in one file. 
Then simply include that tag database file with the custom icons and Property inspectors 
that you hand over to the people who will maintain the site.

You define a tag specification with an XML tag called tagspec; for example, the 
following code describes the specification for a tag named happy:

<tagspec tag_name="happy" tag_type="nonempty" 
render_contents="false" 
content_model="marker_model" icon="happy.gif" icon_width="18" 
icon_height="18"></tagspec>

You can define two different kinds of tags using tagspec: normal HTML-style 
tags and string-delimited tags. String-delimited tags start with one string and end 
with another string; they’re like empty HTML tags (such as img) in that they don’t 
surround content and don’t have closing tags. The happy tag shown above is a 
normal HTML-style tag; it starts with an opening <happy> tag, contains data 
between opening and closing tags, and ends with a closing </happy> tag. (If the 
tag were a string-delimited tag, the tag specification would include the 
start_string and end_string attributes.) An ASP tag is a string-delimited tag; 
it starts with the string <% and ends with the string %>, and it has no closing tag.

The following information describes the attributes and valid values for the 
tagspec tag. Attributes marked with an asterisk (*) are ignored by string-
delimited tags.

<tagspec>

Description

Provides information about a third-party tag.

Attributes

tag_name, tag_type, render_contents, content_model, start_string, 
end_string, detect_in_attribute, parse_attributes, icon, icon_width, 
icon_height

tag_name The name of the custom tag. (For string-delimited tags, tag_name is 
used only to determine whether a given Property inspector can be used for the tag. 
If the first line of the Property inspector contains this tag name with an asterisk on 
each side, then the inspector can be used for tags of this type. For example, the tag 
name for ASP code is ASP; Property inspectors that can examine ASP code should 
have *ASP* on the first line. For information on the Property inspector API, see 
“Property Inspectors” in Extending Dreamweaver.)
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tag_type* Determines whether the tag is empty (as with img), or whether 
it contains anything between its opening and closing tags (as with code). This 
attribute is required for normal (non-string-delimited) tags. It’s ignored for 
string--delimited tags, since they’re always empty. Valid values are "empty" 
and "nonempty".

render_contents* Determines whether the contents of the tag should appear 
in the Document window’s Design view, or whether the icon appears instead. This 
attribute is required for nonempty tags, and ignored for empty tags. (Empty tags 
have no content.) This attribute applies only to tags that appear outside of 
attributes; the contents of tags that appear inside the values of attributes of other 
tags are not rendered. Valid values are "true" or "false".

content_model* Describes what kinds of content the tag can contain and 
where in an HTML file the tag can appear. Valid values are "block_model", 
"head_model", "marker_model", and "script_model":

• block_model Specifies that the tag can contain block-level elements such as 
div and p, and that the tag can appear only in the body section or inside other 
body-content tags such as div, layer, or td.

• head_model Specifies that the tag can contain text content, and that it can 
appear only in the head section.

• marker_model Specifies that the tag can contain any valid HTML code, and 
that it can appear anywhere in an HTML file. The HTML validator in 
Dreamweaver ignores tags that are specified as marker_model. However, the 
validator doesn’t ignore the contents of such a tag; so even though the tag itself 
can appear anywhere, the contents of the tag may result in invalid HTML in 
certain places. For example, plain text can’t appear (outside a valid head 
element) in the head section of a document, so you can’t place a marker_model 
tag that contains plain text in the head section. (To place a custom tag 
containing plain text in the head section, specify the tag’s content model as 
head_model instead of marker_model.) Use marker_model for tags that 
should be displayed inline (inside a block-level element such as p or div—for 
example, inside a paragraph). If the tag should be displayed as a paragraph of its 
own, with line breaks before and after it, don’t use this model.

• script_model Allows the tag to exist anywhere between the opening and 
closing HTML tags of a document. When Dreamweaver encounters a tag with 
this model, it ignores all of the tag’s content. Used for third-party markup (like 
certain ColdFusion tags) that Dreamweaver shouldn’t parse.

start_string Specifies a delimiter that marks the beginning of a string-
delimited tag. String-delimited tags can appear anywhere in the document where a 
comment can appear. Dreamweaver does not parse tags or decode entities or 
URLs between start_string and end_string. This attribute is required if 
end_string is specified.

end_string Specifies a delimiter that marks the end of a string-delimited tag. 
This attribute is required if start_string is specified.
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detect_in_attribute Indicates whether to ignore everything between 
start_string and end_string (or between opening and closing tags if those 
strings aren’t defined) even when those strings appear inside attribute names or 
values. You should generally set this to "true" for string-delimited tags; the 
default is "false". For example, ASP tags sometimes appear inside attribute 
values, and sometimes contain quotation marks ("); because the ASP tag 
specification specifies detect_in_attribute="true", Dreamweaver ignores the 
ASP tags, including the internal quotation marks, when they appear inside 
attribute values.

parse_attributes* Indicates whether to parse the attributes of the tag. If this 
is set to "true" (the default), Dreamweaver parses the attributes; if it’s set to 
"false", Dreamweaver ignores everything until the next closing angle bracket 
that appears outside quotation marks. For example, this attribute should be set to 
"false" for a tag like cfif (as in <cfif a is 1>, which Dreamweaver would be 
unable to parse as a set of attribute name/value pairs).

icon Specifies the path and file name of the icon associated with the tag. This 
attribute is required for empty tags, and for nonempty tags whose contents are not 
displayed in the Document window’s Design view.

icon_width Specifies the width of the icon in pixels.

icon_height Specifies the height of the icon in pixels

Contents

None (empty tag).

Container

None.

Example

<tagspec tag_name="happy" tag_type="nonempty" 
render_contents="false" 
content_model="marker_model" icon="happy.gif" icon_width="18" 
icon_height="18"></tagspec>
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How custom tags appear in the Design view

How custom tags appear in the Design view of the Document window depends on 
the values of the tag_type and render_contents attributes of the tagspec tag. If 
the value of tag_type is "empty", the icon specified in the icon attribute appears. 
If the value of tag_type is "nonempty" but the value of render_contents is 
"false", the icon appears as it would for an empty tag. For example, an instance of 
the happy tag defined earlier might appear in the HTML like this:

<p>This is a paragraph that includes an instance of the 
<code>happy</code> 
tag (<happy>Joe</happy>).</p>

That paragraph might appear in the Design view like this:

Note that since render_contents is set to "false" in the tag specification, the 
contents of the happy tag (the word Joe) are not rendered; instead the start and 
end tags and their contents are displayed as a single icon.

For nonempty tags that have a render_contents value of "true", the icon does 
not appear in the Design view; instead, the contents between the opening and 
closing tags (such as the text between the tags in <mytag>This is the contents 
between the opening and closing tags</mytag>) appears. If View > 
Invisible Elements is enabled, the content is highlighted using the third-party tag 
color specified in Highlighting preferences. (Note that highlighting applies only to 
tags defined in tag database files.)

To change the highlighting color of third-party tags:

1 Choose Edit > Preferences and select the Highlighting category.

2 Click the Third-Party Tags color box to display the color picker.

3 Choose a color, then click OK to close the Preferences dialog box. For 
information about choosing a color, see “Working with colors” on page 87.
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About ASP

Microsoft ASP (Active Server Pages) is a way to combine HTML, scripts written 
in JavaScript or VBScript, and ActiveX controls to dynamically serve HTML. 
When a browser requests an ASP page from a Microsoft Web server, the server 
interprets the ASP code and sends the resulting HTML to the requesting browser. 
(The browser receives only HTML, not ASP code.) For more information on ASP, 
see the Microsoft ASP overview pages, as described in “HTML and Web 
technologies resources” on page 25.  

A block of ASP code begins with <% and ends with %>. If View > Invisible 
Elements is selected, and Server Markup Tags is selected in Invisible Elements 
preferences, Dreamweaver displays an ASP icon in the Document window’s 
Design view to mark the location of ASP code. Otherwise, Dreamweaver does not 
display anything to mark the code’s location. For more information about 
invisible elements, see “About invisible elements” on page 156.

About JSP

Sun JSP (JavaServer Pages) provides a Java-based way to dynamically serve HTML 
and other Web content. When a browser requests a JSP page from a JSP-enabled 
server, the server interprets the JSP code and sends the resulting HTML to the 
requesting browser. (The browser receives only HTML, not JSP code.) For more 
information on JSP, see the Sun JSP page, as described in “HTML and Web 
technologies resources” on page 25.

A block of JSP code begins with <% and ends with %>.  Since JSP uses the same 
delimiters as ASP, Dreamweaver displays an ASP icon for JSP code.

About PHP

PHP (which stands for PHP: Hypertext Preprocessor) is a server-side scripting 
language. When a browser requests a PHP page from a PHP-enabled server, the 
server interprets the PHP code and sends the resulting HTML to the requesting 
browser. (The browser receives only HTML, not PHP code.) For more 
information on PHP, see the PHP pages, as described in “HTML and Web 
technologies resources” on page 25.

A block of PHP code begins with <? and ends with ?>. If View > Invisible 
Elements is selected, and Server Markup Tags is selected in Invisible Elements 
preferences, Dreamweaver displays a PHP icon in the Document window’s Design 
view to mark the location of PHP code. Otherwise the code doesn’t appear in the 
Design view. For more information about invisible elements, see “About invisible 
elements” on page 156.
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About ColdFusion

Allaire ColdFusion is another way to serve pages dynamically. When a browser 
requests a ColdFusion page from a server, the server passes the page to the 
ColdFusion Server software, which interprets the scripts on the page and sends the 
resulting HTML to the requesting browser. (The browser receives only HTML, not 
ColdFusion code.) For more information on ColdFusion, see the ColdFusion 
product page, as described in “HTML and Web technologies resources” on page 25.

Dreamweaver recognizes about fifty ColdFusion tags; see the ColdFusion.xml file 
in the Configuration/ThirdPartyTags folder for details. If View > Invisible 
Elements is selected, and Server Markup Tags is selected in Invisible Elements 
preferences, Dreamweaver displays a ColdFusion icon in the Document 
window’s Design view to mark the location of ColdFusion tags for which 
render_contents is set to "false" (in ColdFusion.xml). Otherwise, 
Dreamweaver does not display anything to mark the code’s location. For more 
information about invisible elements, see “About invisible elements” on page 156.
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Avoiding rewriting third-party tags

Dreamweaver corrects certain kinds of errors in HTML (for details, see “Setting 
Code Rewriting preferences” on page 346). By default, Dreamweaver refrains 
from changing HTML in files with certain file name extensions, including .asp 
(ASP), .cfm (ColdFusion), .jsp (JSP), and .php (PHP). This default is set so that 
Dreamweaver won’t accidentally modify the code contained in any such 
third-party tags. You can change the Dreamweaver default rewriting behavior so 
that it rewrites HTML when it opens such files, and you can add other file types 
to the list of types that Dreamweaver doesn’t rewrite.

Note also that Dreamweaver encodes certain special characters (by replacing them 
with numerical values) when you enter them in the Property inspector. It’s usually 
best to let Dreamweaver perform this encoding, because the special characters will 
be more likely to display correctly across platforms and browsers. However, 
because such encoding may interfere with third-party tags, you may want to 
change the Dreamweaver encoding behavior when you’re working with files 
containing third-party tags.

To allow Dreamweaver to rewrite HTML in more kinds of files:

1 Choose Edit > Preferences and select Code Rewriting.

2 Do one of the following:

• Delete one or more extensions from the list of extensions.

• Deselect the Never Rewrite Code: In Files with Extensions option. (Deselecting 
this option allows Dreamweaver to rewrite HTML in all types of files.)

To add file types that Dreamweaver shouldn’t rewrite:

1 Choose Edit > Preferences and select Code Rewriting.

2 Make sure the Never Rewrite Code: In Files with Extensions option is selected, 
and add the new file extensions to the list in the text field.

If the new file type doesn’t appear in the file-types pop-up menu in the File > 
Open dialog box, you may want to add it to the Configuration/Extensions.txt 
file. For details, see “Changing the default file type” on page 514.

To turn off Dreamweaver encoding options:

1 Choose Edit > Preferences and select Code Rewriting.

2 Deselect either or both Special Characters options.

For information on the other Code Rewriting preferences, see “Setting Code 
Rewriting preferences” on page 346.
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APPENDIX

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Keyboard Shortcuts

You can obtain a printable keyboard shortcuts list from the Dreamweaver Support 
Center (www.macromedia.com/support/dreamweaver/documentation.html).

File menu    

Action Windows Macintosh

New document Control+N Command+N

Open an HTML file Control+O, or drag the file 
from the Explorer or Site 
window to the Document 
window

Command+O

Open in frame Control+Shift+O Command+Shift+O

Close Control+W Command+W

Save Control+S Command+S

Save as Control+Shift+S Command+Shift+S

Check links Shift + F8 Command+F8

Exit/Quit Control+Q Command+Q
545



Edit menu

Page views

Action Windows Macintosh

Undo Control+Z Command+Z

Redo Control+Y or 
Control+Shift+Z

Command+Y or 
Command+Shift+Z

Cut Control+X or
Shift+Del

Command+X or 
Shift+Del

Copy Control+C or
Control+Ins

Command+C or
Command+Ins

Paste Control+V or
Shift+Ins

Command+V or
Shift+Ins

Clear Delete Delete

Select All Control+A Command+A

Select parent tag Control+Shift+< Command+Shift+<

Select child Control+Shift+> Command+Shift+>

Find and Replace Control+F Command+F

Find next F3 Command+G

Indent Code Control+Shift+] Command+Shift+]

Outdent Code Control+Shift+[ Control+Shift+[

Balance Braces Control+’ Command+’

Launch External Editor Control+E Command+E

Preferences Control+U Command+U

To toggle the display of Windows Macintosh

Standard view Control+Shift+F6 Command+Shift+F6

Layout view Control+F6 Command+F6

Toolbar Control+Shift+T Command+Shift+T
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Viewing page elements

Code editing

To toggle the display of Windows Macintosh

Visual Aids Control+Shift+I Command+Shift+I

Rulers Control+Alt+R Command+Option+R

Show Grid Control+Alt+G Command+Option+G

Snap to Grid Control+Alt+Shift+G Command+Option+
Shift+G

Head content Control+Shift+W Command+Shift+W

Page properties Control+Shift+J Command+Shift+J

Action Windows Macintosh

Switch to design view Control+Tab Option+Tab

Open Quick Tag Editor Control+T Command+T

Select parent tag Control+Shift+< Command+Shift+<

Balance Braces Control+’ Command+’

Select All Control+A Command+A

Copy Control+C Command+C

Find and Replace Control+F Command+F

Find Next F3 Command+G

Replace Control+H Command+H

Paste Control+V Command+V

Cut Control+X Command+X

Redo Control+Y Command+Y

Undo Control+Z Command+Z

Toggle breakpoint Control+Alt+B Command+Option+B

Select line up Shift+Up Shift+Up

Select line down Shift+Down Shift+Down
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Character select left Shift+Left Shift+Left

Character select right Shift+Right Shift+Right

Move to page up Page Up Page Up

Move to page down Page Down Page Down

Select to page up Shift+Page Up Shift+Page Up

Select to page down Shift+Page Down Shift+Page Down

Select word left Control+Shift+Left Command+Shift+Left

Select word right Control+Shift+Right Command+Shift+Right

Move to start of line Home Home

Move to end of line End End

Move to top of code Control+Home Command+Home

Move to end of code Control+End Command+End

Select to top of code Control+Shift+Home Command+Shift+Home

Select to end of code Control+Shift+End Command+Shift+End

Action Windows Macintosh
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Editing text

Action Windows Macintosh

Create a new paragraph Enter Return

Insert a line break <BR> Shift+Enter Shift+Return

Insert a nonbreaking space Control+Shift+Spacebar Option+Spacebar

Move text or object to another 
place in the page

Drag selected item 
to new location

Drag selected item to new 
location

Copy text or object to another 
place in the page

Control-drag selected 
item to new location

Option-drag selected 
item to new location

Select a word Double-click Double-click

Add selected items to library Control+Shift+B Command+Shift+B

Switch between design view  and 
code editors

Control+Tab Option+Tab

Open and close the 
Property inspector

Control+Shift+J Command+Shift+J

Check spelling Shift+F7 Shift+F7
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Formatting text

Note: Some text formatting shortcuts have no effect when working in the code editors.

Finding and replacing text

Action Windows Macintosh

Indent Control+] Command+]

Outdent Control+[ Command+[

Format > None Control+0 (zero) Command+0 (zero)

Paragraph Format Control+Shift+P Command+Shift+P

Apply Headings 1 through 6 to a 
paragraph

Control+1 through 6 Command+1 through 6

Alignment > Left Control+Shift+Alt+L Command+Shift+
Option+L

Alignment > Center Control+Shift+Alt+C Command+Shift+
Option+C

Alignment > Right Control+Shift+Alt+R Command+Shift+
Option+R

Make selected text bold Control+B Command+B

Make selected text italic Control+I Command+I

Edit Style Sheet Control+Shift+E Command+Shift+E

Action Windows Macintosh

Find Control+F Command+F

Find Next/Find Again F3 Command+G

Replace Control+H Command+H
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Working in tables

Note: Some table shortcuts do not work in Layout view.

Working with frames

Action Windows Macintosh

Select table (with cursor inside the 
table)

Control+A Command+A

Move to the next cell Tab Tab

Move to the previous cell Shift+Tab Shift+Tab

Insert a row (before current) Control+M Command+M

Add a row at end of table Tab in the last cell Tab in the last cell

Delete the current row Control+Shift+M Command+Shift+M

Insert a column Control+Shift+A Command+Shift+A

Delete a column Control+Shift+ - (hyphen) Command+Shift+ - 
(hyphen)

Merge selected table cells Control+Alt+M Command+Option+M

Split table cells Control+Alt+S Command+Option+S 

Update table layout (forces a 
redraw when in “faster table 
editing” mode)

Control+Spacebar Command+Spacebar

Action Windows Macintosh

Select a frame Alt-click in frame Shift+Option-click 
in frame

Select next frame or frameset Alt+Right Arrow Command+Right Arrow

Select previous 
frame or frameset

Alt+Left Arrow Command+Left Arrow

Select parent frameset Alt+Up Arrow Command+Up Arrow

Select first child frame or frameset Alt+Down Arrow Command+Down Arrow

Add a new frame to frameset Alt-drag frame border Option-drag frame border

Add a new frame to frameset using 
push method

Alt+Control-drag 
frame border

Command+Option-drag 
frame border
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Working with layers

Working with timelines

Action Windows Macintosh

Select a layer Control+Shift-click Command+Shift-click

Select and move layer Shift+Control-drag Command+Shift-drag

Add or remove layer from selection Shift-click layer Shift-click layer

Move selected layer by pixels Arrow keys Arrow keys

Move selected layer by 
snapping increment

Shift+arrow keys Shift+arrow keys

Resize selected layer by pixels Control+Arrow keys Option+arrow keys

Resize selected layer by 
snapping increment

Control+Shift+arrow keys Option+Shift+arrow keys

Align selected layers to the 
Top/Bottom/Left/Right of the 
last selected layer

Control+Up/Down/Left/
Right Arrow

Command+Up/Down/
Left/Right Arrow

Make selected layers 
the same width

Control+Shift+[ Command+Shift+[

Make selected layers 
the same height 

Control+Shift+] Command+Shift+]

Toggle nesting preference on 
or off when creating a layer

Control-drag Command-drag

Toggle the display of the grid Control+Shift+Alt+G Command+Shift+
Option+G

Snap To grid Control+Alt+G Command+Option+G

Action Windows Macintosh

Add object to timeline Control+Alt+Shift+T Command+Option+
Shift+T

Add a keyframe Shift+F9 Shift+F9

Remove a keyframe Delete Delete
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Working with images

Managing hyperlinks

Targeting and previewing in browsers

Action Windows Macintosh

Change image source attribute Double-click image Double-click image

Edit image in external editor Control–double-click 
image

Command–double-click 
image

Action Windows Macintosh

Create hyperlink (select text) Control+L Command+L

Remove hyperlink Control+Shift+L Command+Shift+L

Drag and drop to create a 
hyperlink from a document

Select the text, image, or 
object, then Shift-drag 
the selection to a file in 
the Site window

Select the text, image, or 
object, then Shift-drag 
the selection to a file in 
the Site window

Drag and drop to create 
a hyperlink using the 
Property inspector

Select the text, image, or 
object, then drag the 
point-to-file icon in 
Property inspector to a 
file in the Site window

Select the text, image, or 
object, then drag the 
point-to-file icon in 
Property inspector to a 
file in the Site window

Open the linked-to document 
in Dreamweaver

Control–double-click link Command–
double-click link

Check links selected Shift+F8 Shift+F8

Check links in the entire site Control+F8 Command+F8

Action Windows Macintosh

Preview in primary browser F12 F12

Preview in secondary browser Control+F12 Command+F12
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Debugging in browsers

Site management and FTP

Action Windows Macintosh

Debug in primary browser Alt+F12 Option+F12

Debug in secondary browser Control+Alt+F12 Command+Option+F12

Action Windows Macintosh

Create new file Control+Shift+N Command+Shift+N

Create new folder Control+Shift+Alt+N Command+Shift+
Option+N

Open selection Control+Shift+Alt+O Command+Shift+
Option+O

Get selected files or folders 
from remote FTP site

Control+Shift+D or 
drag files from Remote 
to Local pane in Site 
window

Command+Shift+D or 
drag files from Remote to 
Local pane in Site 
window

Put selected files or folders 
to remote FTP site

Control+Shift+U or drag 
files from Local to 
Remote pane in Site 
window

Command+Shift+U or 
drag files from Local to 
Remote pane in Site 
window

Check out Control+Shift+Alt+D Command+Shift+
Option+D

Check in Control+Shift+Alt+U Command+Shift+
Option+U

View site map Alt+F8 Option+F8

Refresh remote site Alt+F5 Option+F5
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Site map 

Playing plugins

Working with templates

Action Windows Macintosh

View site files F8 F8 

Refresh Local pane Shift+F5 Shift+F5 

Make root Control+Shift+R Command+Shift+R 

Link to existing file Control+Shift+K Command+Shift+K 

Change link Control+L Command+L 

Remove link Delete Delete

Show/Hide link Control+Shift+Y Command+Shift+Y 

Show page titles Control+Shift+T Command+Shift+T 

Rename file F2 n/a

Zoom in site map Control+ + (plus) Command+ + (plus)

Zoom out site map Control+ - (hyphen) Command+ - (hyphen)

Action Windows Macintosh

Play plugin Control+Alt+P Command+Option+P

Stop plugin Control+Alt+X Command+Option+X

Play all plugins Control+Shift+Alt+P Command+Shift+
Option+P

Stop all plugins Control+Shift+Alt+X Command+Shift+
Option+X

Action Windows Macintosh

Create new editable region Control+Alt+V Command+Option+V
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Inserting objects

History panel

To insert Windows Macintosh

Any object (image, Shockwave 
movie, and so on)

Drag file from the 
Explorer or Site 
window to the 
Document window

Drag file from the 
Finder or Site 
window to the 
Document window

Image Control+Alt+I Command+Option+I

Table Control+Alt+T Command+Option+T

Flash movie Control+Alt+F Command+Option+F

Shockwave Director movie Control+Alt+D Command+Option+D

Named anchor Control+Alt+A Command+Option+A

Action Windows Macintosh

Open the History panel Shift F10 Shift F10

Start/stop recording command Control+Shift+X Command+Shift+X

Play recorded command Control+P Command+P
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Opening and closing panels

Getting help

To toggle the display of Windows Macintosh

Objects Control+F2 Command+F2

Properties Control+F3 Command+F3

Site Files F5 F5 

Site Map Control+F5 Command+F5 

Assets F11 F11

CSS Styles Shift+F11 Shift+F11

HTML Styles Control+F11 Command+F11

Behaviors Shift+F3 Shift+F3

History Shift+F10 Shift+F10

Timelines Shift+F9 Shift+F9

Code inspector F10 F10

Frames Shift+F2 Shift+F2

Layers F2 F2

Reference Control+Shift+F1 Command+Shift+F1

Show/Hide Floating panels F4 F4

Minimize all windows Shift+F4 

Restore all windows Alt+Shift+F4

Action Windows Macintosh

Using Dreamweaver Help Topics F1 F1

Reference Shift+F1 Shift+F1

Dreamweaver Support Center Control+F1 Command+F1
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Keyboard Shortcut Matrix

Note: An asterisk (*) indicates an unused key combination. Italics indicate system-level 
commands.       

Keyboard 
character

Control (Windows) 
or
Command 
(Macintosh)

Control+Shift 
(Windows) or
Command+Shift 
(Macintosh)

Control+Alt 
(Windows) or
Command+
Option (Macintosh)

Control+Shift+Alt 
(Windows) or
Command+
Shift+Option 
(Macintosh)

A Select All, Select 
Table

Insert Table Column Insert Named Anchor *

B Bold (toggle) Add to Library * *

C Copy * * Center justify

D Duplicate Get Selected Files or 
Folders

Insert Shockwave 
Director Movie

Check Out Selected 
Files or Folders

E Launch External 
Editor

Edit Style Sheet * *

F Find and Replace * Insert Flash Movie *

G Find Next
(Macintosh only) 

* Show/Hide Grids Snap to Grid (toggle)

H Replace * * *

I Italic (toggle) Show Invisibles 
(toggle)

Insert Image *

J Page Properties Property inspector 
(toggle)

* *

K * * * *

L Create Link Remove Link * Left Justify

M Insert Table Row Delete Table Row Merge Selected Table 
Cells

*

N New Window 
(Windows)
New Page 
(Macintosh)

New Page (Windows 
only)

* New Site Folder

O Open Open in Frame * Open Selected Site File

P Play Recorded 
Command

Paragraph Format Play Plugin Play All Plugins

Q Quit * * *

R * Make Root Show/Hide Rulers Right Justify
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S Save Save All Split Table Cell *

T Quick Tag Editor Show Page Titles in 
Site Toolbar

Insert Table Add Object to Timeline

U Preferences Put Selected Files or 
Folders

* Check In Selected Files 
or Folders

V Paste * Create New Editable 
Region

*

W Close View Head Content * *

X Cut Start Recording 
Command

Stop Plugin Stop All Plugins

Y Redo Show/Hide Link * *

Z Undo Redo * *

0 (zero) Set Paragraph 
Format to None

* * *

1 Apply Heading 1 to 
Paragraph

* * *

2 Apply Heading 2 to 
Paragraph

* * *

3 Apply Heading 3 to 
Paragraph

* * *

4 Apply Heading 4 to 
Paragraph

* * *

5 Apply Heading 5 to 
Paragraph

* * *

6 Apply Heading 6 to 
Paragraph

* * *

7 * * * *

8 * * * *

9 * * * *

- (minus) and 
_ (Underscore)

Site Map Zoom Out Delete Table Column * *

= and + Fit to Window Site Map Zoom In * *

Keyboard 
character

Control (Windows) 
or
Command 
(Macintosh)

Control+Shift 
(Windows) or
Command+Shift 
(Macintosh)

Control+Alt 
(Windows) or
Command+
Option (Macintosh)

Control+Shift+Alt 
(Windows) or
Command+
Shift+Option 
(Macintosh)
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[ and { Outdent (Move 
Backward)

Make Layers Same 
Width (Layers)

* *

] and } Indent (Move 
Forward)

Make Layers Same 
Height (Layers)

* *

> * Select Child Tag *

< * Select Parent Tag * *

? and / * * * *

; and : * * * *

‘ and “ * * * *

‘ and ~ * * * *

\ and | * * * *

Spacebar Update Table Layout Insert Non-breaking 
Space (Windows) 
(Option+
Spacebar on 
Macintosh)

* *

Function 
Key

No modifier Shift Alt 
(Windows) 
or Option 
(Macintosh)

Control 
(Windows) 
or
Command 
(Macintosh)

Control+
Shift 
(Windows) 
or
Command+
Shift 
(Macintosh)

Control+
Alt 
(Windows) 
or
Command+
Option 
(Macintosh)

Control+
Shift+Alt 
(Windows) or
Command+
Shift+
Option 
(Macintosh)

F1 Using 
Dreamweav
er Help

Reference * Dreamweave
r Support 
Center

Reference 
Panel

* *

F2 Layers Frames * Object panel * * *

F3 Find again 
(Windows 
only)

Behaviors 
panel

* Property 
Inspector

* * *

F4 Hide/Show 
Floating 
panels

Minimize all 
windows 
(Windows 
only)

Close 
Windows

Close 
Window 
(Macintosh 
only)

* * *

F5 Site Files Refresh 
Local Pane

Refresh 
Remote Pane

Site Map * * *

Keyboard 
character

Control (Windows) 
or
Command 
(Macintosh)

Control+Shift 
(Windows) or
Command+Shift 
(Macintosh)

Control+Alt 
(Windows) or
Command+
Option (Macintosh)

Control+Shift+Alt 
(Windows) or
Command+
Shift+Option 
(Macintosh)
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F6 * * * Switch to 
Layout view

Switch to 
Standard 
view

* *

F7 * Check 
Spelling

* * * * *

F8 * Check 
Links -
Selected

* Check Links -
Entire Site

* * *

F9 * Timeline 
and Add 
keyframe

* * * * *

F10 Code 
inspector

History 
panel

* * * * *

F11 Assets CSS Styles * HTML Styles * * *

F12 Preview in 
Primary 
Browser

* Debug in 
Primary 
Browser 

Preview in 
Secondary 
Browser 

* Debug in 
Secondary 
Browser

*

Function 
Key

No modifier Shift Alt 
(Windows) 
or Option 
(Macintosh)

Control 
(Windows) 
or
Command 
(Macintosh)

Control+
Shift 
(Windows) 
or
Command+
Shift 
(Macintosh)

Control+
Alt 
(Windows) 
or
Command+
Option 
(Macintosh)

Control+
Shift+Alt 
(Windows) or
Command+
Shift+
Option 
(Macintosh)
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INDEX

A

Absolute Bottom alignment (image Property 
inspector) 271

Absolute Middle alignment (image Property 
inspector) 271

Absolute paths 354
actions

browser compatibility 444
changing in behaviors 442
choosing in Behaviors panel 439
controlling timelines 434
creating 443
defined 435
included with Dreamweaver 444–471
See also individual actions by name

Active Links color option (Page Properties) 153
Active Server Pages (ASP)

about 542
editing 352
tags, customizing parsing and appearance 537

ActiveX controls
inserting 316
overview 316
properties 316
resizing 272

Add Frame command 427
Add Object to Library command 397
Add Object to Timeline command 427
Add/Remove Netscape Resize Fix command 412
adding

extensions to Dreamweaver 93
frames to a timeline 429
links 226
objects to a timeline 427

Adjust Position command 158
Align image property 270
Align with Selection command 159
aligning
layers 415
options 271
page elements 271
text 241
tracing images 159

All Info tab (Design Notes) 136
Alt image property 270
Always Nest When Created Within Existing 

Layer option 412
Anchor object (Objects panel) 363
anchors, named 362
animation, editing Fireworks animations 292
animations

along complex path 428
applying to objects 432
copying and pasting 431
creating 427
improving 433
overview 19
timelines 425

anonymous file upload 489
AppleTalk servers 124
applets. See Java applets
applications, other, using with Dreamweaver 89
Apply Source Formatting command 348
Apply Source Formatting option (Clean Up Word 

HTML command) 349
Apply Template to Page command 389
applying colors to text 226
arranging views 332
ASP. See Active Server Pages
assets 221, 232

adding to Favorites list 225
applying colors to text 226
categories 222
colors, creating 231
editing 227
Favorites folders 231
Favorites lists 229
563



assets (continued)
inserting 225
opening the Assets panel 223
overview 221
planning 101
refreshing the Site list 224
selecting multiple 227
URLs, creating 231

attributes
in browser profiles 532
searches 260
See also tags

audio. See sound
Auto Apply option (HTML Styles panel) 245
Automatic Wrapping option (Code Format 

preferences) 345
automating tasks 160
Autoplay option 425
Autoplay option (Timelines panel) 426
autostretch (Layout view) 179

B

background
page image and color 153
transparency in 153

Background option (Code Colors preferences) 343
balancing braces 337
Baseline alignment (image Property inspector) 271
Basic Info tab (Design Notes) 136
basics of Dreamweaver 20
BBEdit integration (Macintosh only) 351
behaviors 435–471

actions, creating 443
and forms 500
and images 280
and library items 401
and links 374
and media 320
and templates 388
and timelines 442
attaching 439
changing 442
channel in timelines 425
compatibility with browsers 444
defined 435
deleting 442
third-party 443
triggering 439

Behaviors panel 436
bitmaps, resizing 272

See also images
body tag 159
bold text 239
Border image property 270
borders

adding to a table 190
in a frame 217
table, removing 185

Bottom alignment (image Property inspector) 271
braces, balancing 337
branches, expanding and collapsing in site map 122
breakpoints in JavaScript debugger 477
broken links 506
Browser Default alignment (image Property 

inspector) 271
browsers

3.0 compatible files 424
and CSS styles 256
colors, safe 88
compatibility, planning 97
compatibility, testing 502
detecting 503
previewing in 504
primary, defining 504
profiles, creating 534
profiles, editing 532
secondary, defining 505
targeting 502
versions, checking 447

buttons
creating form buttons 496
Go buttons 456
Submit buttons, graphical 497

C

Cache option (Site Definition dialog box) 103, 104
Call JavaScript action 446
Case for Attributes option (Code Format 

preferences) 345
Case for Tags option (Code Format preferences) 345
categories

assets 222
preferences 88

Cell Padding option (Insert Table) 184
Cell Spacing option (Insert Table) 184
cells. See layout cells, table cells
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Centering option (Code Format preferences) 345
CFML. See ColdFusion Markup Language
CGI, reference material 25
CGI (Common Gateway Interface), scripts 499
Change Link Sitewide command 368
Change Property action 446
characters, special 236
Check Browser action 447
Check In/Check Out options 132

entering a check-out name 132
entering an e-mail address 132

Check In/Check Out reports 141
Check Links Sitewide command 507
Check Out Files When Opening option 132
Check Plugin action 449
Check Spelling command 258
Check Target Browsers command 502
checkboxes 491
checking files in and out 131, 134

overview 131
undoing a check out 134

checking links 506
class attribute 252
Clean up <font> Tags option 349
Clean up CSS option 349
Clean Up HTML command 347
Clean Up Word HTML command 348
Clear Paragraph Style option 246
Clear Selection Style option 246
code

editing with BBEdit 351
formatting preferences 343

Code inspector
Document window, switching to 332
opening 332

Code view
arranging views 332
opening 331
opening non-HTML files 338
options 333
writing and editing code 334

ColdFusion Markup Language (CFML)
and Dreamweaver 330
editing CFML tags 352
overview 543
tags, customizing parsing and appearance 537

color box option 87

Color command 240
Color Cubes color palette 87
color picker

Dreamweaver 87
system 87

Color Wheel (System Color) button 87
color-blindness 153
colors

as assets. See assets
choosing 87
contrast 153
creating color assets 231
default for page text 153
eyedropper, using 87
frame background 217
page background 153
swatches 87
text, changing 226, 240
Web-safe 88

column header menu 180
Columns option (Insert Table) 184
columns, rows, and cells

adding and removing 196
background color, adding 192
formatting 191

Combinable Nested Font Tags 510
Combine Nested  Tags When Possible option 347
combining floating panels 82
commands

accessing from context menu 78, 79
creating, from history steps 165
recording 166
renaming 520

Commands menu, editing 518
Comments option (Code Colors preferences) 343
comments, inserting 327
Common Gateway Interface (CGI). See CGI 499
Configuration folder

Behaviors subfolder 529
BrowserProfiles subfolder 532
Commands subfolder 529
Extensions.txt file 514
menus.xml file 517
Objects subfolder 515
SourceFormat.txt file 530
ThirdPartyTags subfolder 537
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Connecting to remote sites, using, source-control 
systems 127

Connection Speed option 76
content, adding to tables 185
context menus 78, 79

customizing 519
Continuous Tone color palette 87
Control Shockwave or Flash action 450
conventions 22
Convert Layers to Tables command 422
Convert Tables to Layers command 424
copying and pasting, Fireworks HTML 283
copying history steps 164
Create Web Photo Album command 294
creating, templates 377
creating colors and URLs 231
creating new Flash button templates 306
Creating radio buttons 493
creating reports 510
CSS Layers, exporting from Fireworks 284
CSS Styles, exporting 254
CSS styles

applying custom 254
attributes, converting to HTML 257
class attribute 252
creating 252
selectors 252

CSS Styles panel 255
custom styles. See style sheets
customizing Dreamweaver 513, 544

basics 90
dialog boxes 529
Launcher bar and Launcher 77
menus 517
Objects panel 515
tags, third-party 537

D

dates, inserting 235
debugger. See JavaScript debugger
Default Color button 87
default file type, changing 514
Define HTML Style dialog box 245
dependent files

getting 144
putting 145
showing and hiding 121

Design Notes
adding status choices 137
disabling 137
for documents and objects 136
for Dreamweaver and Fireworks integration 287
for Fireworks files 140
for media objects 300
overview 134
reports 141
running a report 142
saving file information 135
setting up 135

design of pages 100
Design view

arranging views 332
displaying with Code view 331

Detach from Original option 401
Detach from Template command 391
detecting browsers and plugins 503
dialog boxes, customizing 529
Director, creating Shockwave movies with 310
directory structure, site. See sites
display options

floating panels 83
fonts 89

displaying
layers 420
tracing images 158

docking floating panels 82
Document window

basics 74
Code inspector, switching to 332
frames in 211
Launcher bar 74
opening documents 150
page size and download time 74
playing Navigator plugins 315
resizing 75
searching for text 258
selecting elements 154
tag selector 74
title bar 74
Window Size pop-up menu 74

document-relative paths
about 355
setting 359
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documents
checking links 506
creating 150
creating, based on templates 388
Design Notes, using with 134
download size, time 509
new 150
opening 150
page title 152
previewing in browsers 504
saving 151
searching 258
setting properties 152
templates, detaching from 391
text, adding 234

download time 74
downloading

behaviors 443
size, time estimates 509

Drag Layer action 451
drawing

layers 409
layout cells and tables 170

Dreamweaver and Fireworks integration
creating Web photo albums 294
Design Notes 287
editing Fireworks animations 292
exporting CSS Layers 284
exporting Dreamweaver library items 285
external editor preference 286
inserting Fireworks files 282
Launch and Edit preferences 287
launching and editing Fireworks images 288
launching and editing Fireworks tables 289
launching and optimizing Fireworks images 290
Optimize Image in Fireworks command 290
resizing Fireworks images 291
updating Fireworks HTML 293

Dreamweaver discussion group 16
Dreamweaver Help Pages 14
Dreamweaver libraries, exporting from Fireworks 285
Dreamweaver Support Center 16

E

Edit button (image Property inspector) 270
Edit Font List command 242
Edit NoFrames Content command 219
Edit Style Sheet command 252
editing

assets 227
Flash button objects 303
keyboard shortcuts 90
templates 377

editing code (Code view or Code inspector) 334
editors. See external editors
elements

aligning 271
viewing invisible 547

e-mail address, using with check in/check out system 132
e-mail files 150
e-mail links

changing 368
creating 364, 365

embedding audio 313
Enable File Check In and Check Out option 132
encodings 89
entities 236
errors in JavaScript code 476
event handlers. See events
events

available for different browsers and objects 436
changing in behaviors 442
defined 435
triggering actions 439

Excel. See Microsoft Excel files, importing.
Export Table command 202
exporting

CSS Layers from Fireworks 284
Fireworks files to Dreamweaver 284
library items from Fireworks 285
XML, tag notations for 395

exporting styles 254
Extending Dreamweaver book and Help pages 16
extensibility

JavaScript 536
overview 536
third-party behaviors 443

extensions 93
reloading 515
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external editors
BBEdit (Macintosh only), integration with 351
Fireworks. See Dreamweaver and Fireworks 

integration
HomeSite (Windows) 330
HTML, overview 350
images 277
media 298
preference 286
text, overview 350

external links 506
external style sheets

creating 250
editing 252
linking to 250

eyedropper 87

F

Favorites folders 231
Favorites list (Assets panel). See assets 225
features, new in Dreamweaver 22
fields

about form fields 485
creating hidden fields 490
creating text fields 486
file fields 489
uploading files to a server 489

file formats, image 267
file types, Flash files 300
File Types/Editors preferences 299
File View Columns

accessing 139
adding a column 140
changing the order 139
deleting 140
using with Design Notes 138

files
downloading 143
getting from remote site 143
managing 108
putting 144
searching 258
synchronizing local and remote sites 146
text 150
transferring with FTP 124
types, default 514
uploading 144
viewing in Site window 115

Find In options 259
finding and replacing. See searching
firewalls

defining host and port 111
options 125

Fireworks, Design Notes in 140
Fireworks and Dreamweaver integration. See 

Dreamweaver and Fireworks integration
Fix Invalidly Nested and Unclosed Tags option (Code 

Rewriting preferences) 346
Fix Invalidly Nested Tags option (Clean Up Word 

HTML) 349
Flash button dialog box 301
Flash button objects 301, 306

modifying 303
previewing 303
properties 305

Flash content, overview 300
Flash movies

as assets. See assets
controlling 450
inserting 307
overview 300
properties 308
resizing 272

Flash object properties 305
Flash Text dialog box 304
Flash Text objects, inserting 304
Flash text objects

previewing 303
properties 305

floating panels, See panels
folders

root 102
searching 258

folders, Favorites 231
Font Combination option 242
fonts

changing characteristics 239
changing combinations 242
encodings, setting fonts for 89

Fonts/Encoding preferences 89
Format option 242
Format Table command 193
formatting HTML source code

customizing 530
preferences 343
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forms
adding multiple objects 498
adding to a document 484
behaviors, using with 500
client-side scripting 499
creating 483
creating file fields 489
fields, validating 470
inserting tables 498
jump menus, creating 369
objects, adding 485
overview 481
password field 486
processing 499
server-side scripting 499
Submit buttons 497

fps (frames per second) 425
frames 203–220

behaviors, using with 220
borders 217
browser compatibility 219
changing background color 217
changing content 218
creating 206, 207
deleting 207
nested 208
overview 203
panel 209
properties 212
resizing 216
saving 211
selecting 208
shortcuts 551
steps in creating 205
targeting 218
using links 218

Frames and Framesets option (Code Format 
preferences) 344

Frames panel 209
frames per second (fps) 425

framesets 206–217
borders 217
naming 212
nested 208
predefined, inserting 206
properties 214
saving 211
selecting 208
targeting links in 359
See also frames

FTP
connecting to a Web server 124
determining a host directory 126
log 144
transferring files with 124
troubleshooting 130

FTP Host Name field 125

G

General preferences 88
Generator objects, overview 309
Get and Put Newer Files option 146
Get command 143
Get More Behaviors command 443
Get Newer Files from Remote option 146
getting files from a remote server 143
GIF images

as tracing image 158
uses for 267

Go button, associating with a jump menu 456
Go To Timeline Frame action 468
Go To URL action 454
graphics. See images
Grayscale color palette 87
grid

as guide 157
showing 174, 416
snap to 174
snapping layers to 416
spacing 174

Guided Tour overview 13
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H

head section, editing content in 159
header cell, formatting 192
heading tags 240
Help 14

Dreamweaver discussion group 16
Dreamweaver Support Center 16
shortcuts 557

hidden files, showing and hiding 121
hiding invisible elements 156
History panel

automating tasks with 160
clearing the history list 86
commands, creating from history steps 165
maximum steps, setting 86
overview 84
steps, applying to other objects 162
steps, copying and pasting 164
steps, repeating 161

home page, setting 120
HomeSite (Windows) 330
horizontal rules, inserting and modifying 243
Host Directory field 126
hotspots

applying behaviors to 280
in image maps 273
properties 274
resizing 275
selecting multiple in an image map 275

hr (horizontal rule), inserting 243
HTML Corrections log file 348
HTML documents. See documents 150
HTML files, importing 150
HTML source code

cleaning up 347
cleaning up MS Word HTML 348
copying and pasting from Fireworks to 

Dreamweaver 283
copying and pasting, general 237
CSS attributes conversion 257
editing with BBEdit 351
external editors 350
formatting in existing documents 348
formatting preferences overview 343
formatting preferences, setting 344
formatting profile 530
inserting from Fireworks into Dreamweaver 282

HTML source code (continued)
options 333
overview 321
reference 328
reference material 25
rewriting preferences 346
searching 258, 260
selecting in the Document window 154
structure 322
tag color preferences 343
tag searches 260
tag styles 248
tags, removing 342
updating Fireworks HTML placed in 

Dreamweaver 293
viewing with Code inspector 86
writing and editing 334

HTML Source option 260
HTML styles

applying 245
clearing 246
creating 246–247
deleting 246
editing 247
modifying 247
New Style icon 247
removing from panel 246
using in other sites 248
viewing 245

HTML tags. See tags 322
HTTP Address field 103, 104

I

Ignore Whitespace Differences option 260
image inspector 273
image maps

creating client-side 273
hotspots 273
overview 273
selecting multiple hotspots 275

images
aligning 241
applying behaviors to 280
as assets. See assets
changing source file with timelines 430
editing 277
external image editors 277
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images (continued)
formats, supported 267
image maps 273
in tables 186
inserting 268
inserting in Layout view 174
preloading (behavior) 459
properties 269
resizing visually 272
restoring swapped (behavior) 468
scalability 272
shortcuts 553
swapping (behavior) 467

Import Table Data command 186
Import Word HTML command 150, 348
importing, Word HTML files 150
Indent and Outdent options (text 

Property inspector) 242
Indent option (Code Format preferences) 344
Indent Size option (Code Format preferences) 345
Index, Help 15
Insert E-Mail Link dialog box 364
Insert Image Field command 497
Insert Jump Menu dialog box 369
Insert Named Anchor dialog box 363
Insert Navigation Bar dialog box 372
Insert Tabular Data command 186
inserting

ActiveX controls 316
assets 225
dates 235
Fireworks HTML into Dreamweaver 282
Fireworks images into Dreamweaver 282
Flash button objects 301
Flash movies 307
Flash Text objects 304
Generator objects 309
images 268
Java applets 318
media elements 297
rollover images 276
server-side includes 405
Shockwave movies 310
special characters 236

inserting assets. See assets

inspectors
image inspector 273
opening and closing with Launcher bar 77
Property inspector 82
shortcuts 557
See also panels

installing Dreamweaver 12
integrating Dreamweaver with other applications 89
integrating with SourceSafe 127
integrating with WebDAV 127
interactivity 19
invalid tags, displaying 329
invisible elements

comments 327
preferences 156
scripts 335
selecting 154
showing and hiding 156

italics 239

J

Java applets
inserting 297, 318
overview 318
properties 318
resizing 272

JavaScript
actions 436
alerts 458
executing 446
extending Dreamweaver 536
files 150
inserting scripts 335

JavaScript debugger 473
logical errors 476
running 473
setting breakpoints 477
step in, step out, step over 478
syntax errors 475
variable list 479
warning box 474
watching variables 479
window 476

JavaServer Pages (JSP) 542
JPEG images

as tracing image 158
uses for 267
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JS debugger. See JavaScript debugger
JSP (JavaServer Pages) 542
Jump Menu action 455
Jump Menu Go action 456
jump menus

adding menu items 369
changing menu items 370
creating a selection prompt for 369
editing 455
Go buttons 456
Go buttons, adding automatically 369

K

Keyboard Shortcut Editor 90
keyboard shortcuts 545–558

editing 90
editing, in menus.xml file 521

keyframes
creating 427
overview 425

L

Language script property 336
Launch and Edit preferences 287
Launcher

Launcher bar 77
Launcher and Launcher bar

customizing 77
default buttons 74

launching Fireworks from Dreamweaver. See 
Dreamweaver and Fireworks integration

layers 407–434
activating 416
aligning 415
anchor points 156
changing stacking order of 420
changing visibility with behaviors 465
changing visibility with Layers panel 420
converting for 3.0 browsers 424
converting to tables 422
creating 409
draggable 453
drawing multiple 409
in table design 422
inserting 409
manipulating 412

layers (continued)
markers, displaying 409
moving 415
nesting 411
overview 407
positioning 417
preferences 412
preventing overlap 423
properties 417
properties for multiple 419
resizing 414
selecting 413
selecting multiple 419
shortcuts 552
snapping to grid 416
visibility 420

Layers panel 410
layout cells 169

alignment 177
bg color 177
clearing heights 175
drawing 170
formatting 177
highlight 182
moving 176
No Wrap 177
preferences 182
resizing 176
selecting 176

layout tables 169
alignment 178
background 182
bg color 178
cell padding 178
cell spacing 178
clearing heights 178
drawing 170
formatting 178
Make Widths Consistent 178
moving 176
nested 173
outline 182
preferences 182
Remove all Spacers 178
Remove Nesting 178
resizing 176
selecting 176
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Layout view 167–182
about layout cells and tables 169
adding content to 174
autoinsert spacers 182
autostretch 179
background 182
cell highlight 182
cell padding 178
cell spacing 178
Clear Height attributes 178
clearing cell heights 175
column header menu 180
drawing layout cells and tables 170
fixed width 179
formatting layout cells 177
formatting layout tables 178
grid 174
Make Widths Consistent 178
moving layout cells and tables 176
nested layout tables 173
overview 167
preferences 182
Remove All Spacers 178
Remove Nesting 178
resizing layout cells and tables 176
selecting layout cells and tables 176
setting width 179
spacer image preferences 181
spacer images 181
switching into 167
table outline 182

layout, planning 100
See alsoLayout view, templates

learning Dreamweaver 20
Left alignment (image Property inspector) 271
lessons overview 13
library items 396, 403

adding to pages 398, 404
as assets. See assets
changing highlight color 397
creating 396
deleting 400
editing 398, 404
editing behaviors in 401
exporting from Fireworks 285
making editable in documents 401
overview 396

library items (continued)
preferences 397
properties 403

Line Breaks option (Code Format preferences) 345
Link Checker dialog box 507
Link Color option (Page Properties) 153
Link External Style Sheet dialog box 251
Link image property 270
Link option 242
Link to Existing File command 119
Link to New File command 120
linked documents, opening 508
linking

anchors 362
documents 359
to document using point-to-file icon 360
to external CSS style sheet 251
to named anchor using point-to-file icon 363

links
applying to selection 226
cache file 366
changing frames with 218
changing sitewide 368
checking 506
fixing 507
opening source 367
Relative to Document 359
Relative to Site Root 359
removing 367
shortcuts 553
site map 367
specifying 242
targeting 358
testing 505
to anchors 362
to document 358
to style sheets 250
updating 366

List Item option 242
lists, creating 238
Load Query button 263
Local Files option 114
local root folder 102
Local Root Folder field 103, 104
local sites. See sites 102
locked regions, clicking in 385
logical errors in JavaScript code 476
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Loop option 425
looping timelines 429
Low Src image property 270

M

Mac OS color palette 87
Macromedia Director, creating Shockwave 

movies with 310
macros (creating commands) 165
managing assets. See assets
managing links 366
Map Name Field image property 270
map tag 273
markers for invisible elements 156
Match Case option 260
media elements

inserting 297
parameters 319

menus, customizing 517
menus.xml file, syntax 522
Merge Cells command 198
Microsoft Excel files, importing 186
Microsoft Word files, opening 150
Microsoft Word HTML

cleaning up 348
importing 348

Middle alignment (image Property inspector) 271
Mini-Launcher. See Launcher and Launcher bar 74
Missing Alt Text 510
modifying, page properties 152
monitor size, resizing pages to fit 75
movies, inserting 297
MPEG movies as assets. See assets
multimedia. See media

N

Name property (image Property inspector) 269
Named Anchor command 363
named anchors, creating 362
navigation bar

adding images to 372
creating 371
displaying horizontally in a page 373
displaying vertically in a page 373
image states 371
inserting in a table 373
modifying elements 374

nesting 412
frames 208
layers 411

Netscape 4 layer compatibility 412
Netscape Navigator plugins

playing in Document window 315
properties 314
troubleshooting 315

Never Rewrite HTML In Files with Extensions option 
(Code Rewriting preferences) 346

New command 150
new features in Dreamweaver 22
New From Template command 151
New from Template command 389
NFS servers 124
NOFRAMES content 219
null links

changing 368
creating 365

O

objects
adding Design Notes 136
adding to forms 485
checkboxes and radio buttons 491
creating 516
inserting 234
inserting with Objects panel 80
shortcuts 556

Objects panel
categories 80
customizing 515
docking 82
overview 80
preferences 81
reloading 515

onBlur event 470
Open Attached Template command 391
Open Browser Window action 456
Open command 150
Open Linked Page command 508
Open Style Sheet icon 250, 251
opening

documents 150
file types other than HTML by default 514
text files 150

Opening linked documents 508
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opening non-HTML files 338
preferences 338

opening Word HTML files 150
Optimize Image in Fireworks command 290
Ordered List option 242
orphaned files 506
Other Keywords option (Code Colors preferences) 344
overlapping tags 329
Override Case Of option (Code Format 

preferences) 345
overview of Dreamweaver 11

P

Package Manager 93
page layout. See Layout view, templates
page properties, titles, changing 152
page size, resizing to fit monitor 75
pages

background image 153
changing title 152
color 153
default text colors 153
design 100
Design Notes, using with 134
download time, estimated 509
previewing in browsers 504
properties, and templates 379
size 509

palettes, color 87
panels

Behaviors panel 436
Code inspector 86
docking 82
History panel 84
Launcher bar 77
Objects panel 80
opening and closing with Launcher bar 77
setting floating preferences 83
shortcuts 557

paragraph tags 240
Parameters dialog box 319
Paste as Text command 234
pasting history steps 164
paths

absolute 354
document-relative 355
root-relative 357

personal spelling dictionary 258
photographs 267
PHP Hypertext Preprocessor 542
pixels, transparent, in background 153
planning, design 100
Play Sound action 458
Play Timeline action 469
playback head 425
playing Flash objects 303
plugins

checking 449
detecting 503
Netscape Navigator 314
playing in Document window 315
playing shortcuts 555
resizing 272
troubleshooting 315

PNG images
as tracing image 158
uses for 267

pop-up menu, creating 495
Popup Message action 458
preferences

Code Colors 343
Code Format 344
Code Rewriting 346
dictionary for spell checking 258
External Editors 298
File Types/Editors 299
floating panels 83
Fonts/Encoding 89
General 88
Invisible Elements 156
Launch and Edit 287
Layers 412
Layout View 182
libraries 397
Objects panel 81
overview 88
Panels 83
Preview in Browser 505
Preview Using Local Server (root-relative links) 357
Quick Tag Editor 342
Site 110
Status Bar 76
template 383
updating links 366
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Preload Images action 459
Prevent Layer Overlaps command 423
Preview in Browser command 504
Preview Using Local Server command 357
previewing in browsers

overview 504
shortcuts 553, 554

primary browser 505
processing forms 499
profiles

browsers 532
HTML source format 530

properties
ActiveX controls 316
changing with behaviors 446
column, row, and cell 191
displaying 82
document, setting 152
Flash movies 308
frame 212
frameset 214
hotspots 274
image 269
Java applets 318
layer 417
layout cell 177
layout tables 178
multiple layer 419
Shockwave movies 310
table 190

Property inspector
ActiveX control properties 316
displaying 82
expanding 82
fixing broken links 508
Flash movie properties 308
hotspots 274
images 269
Java applet properties 318
library item properties 403
Netscape Navigator plugin properties 314
Shockwave movie properties 310

proportion, maintaining 272
publishing sites 501
Put command 144
Put Newer Files to Remote option 146
putting files on a remote server 144

Q

Quick Tag Editor
attributes hints menu 341
opening 338
overview 338
preferences 342

QuickTime movies
as assets. See assets
inserting 313

R

radio buttons 491
Record Path of Layer command 428
recording commands 166
Redefine HTML Tag option 252
Redundant Nested Tags 510
reference material 25
Reference panel 328
Refresh image property 270
Refresh Local File List Automatically option 103, 104
refreshing, Site list (Assets panel) 224
regions, locked, clicking in 385
regular expressions 264
reloading extensions 515
Remote Files option 114
Removable Empty Tags 511
Remove all Word Specific Markup option 349
Remove Dreamweaver HTML Comments option 347
Remove Empty Tags option 347
Remove Extra Closing Tags option (Code Rewriting 

preferences) 346
Remove Frame command 427
Remove Non-Dreamweaver HTML Comments 

option 347
Remove Redundant Nested Tags option 347
Remove Specific Tag(s) option 347
Remove Timeline command 431
removing frames from a timeline 429
repeating steps 160
Replay button 161
Reports, Checked Out By 141
reports 141

creating 510
testing a site with 510
Workflow 141

Reserved Keywords option (Code Colors 
preferences) 343
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Reset Origin command 157
Reset Position command 158
resizing

frames 216
handles 272
layers 414
layout cells and tables 176
page elements 272
table cells 194

resizing Fireworks images from Dreamweaver 291
resources for information on Web technologies 25
reusing

library items 398
searches 263
templates 388

Right alignment (image Property inspector) 271
roadmap (where to start) 20
Rollover Image text field 276
rollovers 276

creating 276
making a link 276
testing 277

root folder
local 102
remote 126

root-relative paths
about 357
Preview Using Local Server preference 357
setting 359

Roundtrip HTML 329
Rows option (Insert Table) 184
rulers 157

S

Save All Frames command 212
Save as Template command 377
Save command 151
Save Frame As command 212
Save Frame command 212
Save Frameset As command 211
Save Frameset command 211
Save Query button 263
saving

documents 151
files in frames and framesets 211
searches 263

script links
changing 368
creating 365

scripts
as assets. See assets
balanced braces 337
editing 336
editing external 335
entering 335
showing in Document 156
viewing functions 337

scrolling lists 494
Search For options 259
searching

Dreamweaver Help 15
for files 258
HTML tags and attributes 260
regular expressions 264
saving search patterns 263
shortcuts 550
text between specific tags 262
text in HTML source 260
text within files 258

secondary browser 505
Select Newer Local command 146
Select Newer Remote command 146
selecting

frames and framesets 208
layers 413
layout cells and tables 176
objects in the Document window 154

Server Access options 124
servers

access options 124
AppleTalk 124
defining remote sites 124
NFS 124
setup troubleshooting 130

server-side image maps 273
server-side includes 404–406

editing 406
inserting 405
overview 404

Set as Home Page command 120
Set Background Color option (Clean Up Word 

HTML) 349
Set Color Scheme command 153
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Set Nav Bar Image action 460
Set Text of Frame action 461
Set Text of Layer action 462
Set Text of Status Bar action 463
Set Text of Text Field action 464
setting breakpoints 477
setting document properties 152
Shockwave movies

as assets. See assets
controlling 450
inserting 310
overview 310
properties 310
resizing 272

shortcut menus. See context menus
shortcuts, keyboard. See keyboard shortcuts
Show Launcher bar in Status Bar option 76
Show Layout Table Tabs option 168
Show Log on Completion option 347
Show Page Titles in site map 120
Show-Hide Layers action 465
showing invisible elements 156
Site Files view 115
Site list, refreshing 224
site maps

adding files to a site 119
changing links in 367
collapsing a branch 122
Display Dependent Files option 121
editing pages 119
expanding a branch 122
Link to Existing File command 119
Link to New File command 120
links 367
marking files hidden 121
Refresh Local command 121
removing links in 367
renaming pages in 120
saving as an image file 122
selecting multiple pages in 119
Set as Home Page command 120
shortcuts 555
show hidden files 121
Show Page Titles option 120
showing dependent files in 121
updating after changes 121
viewing 113
viewing a branch of 122

Site Name field 103, 104
site planning 95

assets 101
audience 95
goals 95
structure 98

Site preferences 110
site reports 141
site root relative paths. See root-relative paths
Site window

basics 112
changing the display 114
Get command 143
overview 108
Put command 144
searching for files 123
searching for text 258
Site Files view 109
Site Map view 109
site maps 113
toolbar options 108
viewing local sites 112

sites
adding files and folders 115
browser compatibility 97, 502
cache 366
changing display 114
changing links sitewide 368
checking files in and out 131
checking links 506
create new 102
Design Notes, using with 134
edit existing 104
editing remote 105
fixing broken links 507
large, assets in 229
local versus remote 95
local, associating a remote server with 124
local, creating 102
local, locating files in 123
local, root folder 102
local, viewing 112
previewing in browsers 504
publishing 501
reference material 25
remote, access options 124
remote, defining 124
remote, locating files in 123
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sites (continued)
remote, root folder 126
remote, setting up 123
remote, setup troubleshooting 130
removing from site list 106
reports, running 141
searching for files in 258
selecting updated files 115
shortcuts 554
structure and navigation 107
testing 501
viewing 112

Size option (font) 242
slider controls, creating 451
Snap to Web Safe color palette. 87
sound 311–313

adding to a page 311
playing 458

source format profile 530
Source script property 336
SourceFormat.txt file 343
SourceSafe integration 127
spacer image 182
spacer images 181

preferences 181
special characters

inserting 236
overview 236

Special Characters options (Code Rewriting 
preferences) 346

spelling
checking 258
dictionaries, editing 258

Split Cells command 199
Split Frame commands 206
Src image property 269
stacking order

changing with timelines 430
layers 420

starting out 20
status bar

overview 74
preferences 76
setting text (behavior) 463
Window Size pop-up menu 74

stepping through code 478
Stop Timeline action 469

Strikethrough (Default Color) button 87
Strings option (Code Colors preferences) 344
style sheets

editing external style sheets 252
external 250
overview 248
See also styles

Style submenu 239
styles 248

applying custom styles 254
conflicting 255
converting to HTML 256
creating 252
CSS to HTML markup conversion table 257
HTML 244
in templates 388
See also style sheets

Submit buttons 497
Swap Image action 467
Swap Image Restore action 468
swatches, color 87
synchronizing local and remote sites 146
syntax errors 475
syntax of menus.xml 522
System Color button 87
system color picker 87
system requirements

Macintosh 12
Windows 12

T

Tab Size option 345
table border

colors 191
width 191

table cells
background color, adding 192
background image, adding 192
copying and pasting 199
formatting 191
header cells, designating 192
merging 198
splitting 198
See also layout cells, tables

Table of Contents, Help 15
Table Rows and Columns option (Code Format 

preferences) 344
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tables 498
adding and removing rows and columns 196
adding background color to 191
adding background images to 191
adding borders to 190
adding content to 185
adjusting rows and columns 194
aligning 192
cells, splitting 199
changing column width 194
clearing cell width and height 195
columns, rows, and cells 191
converting from layers 422
creating 184
editing Fireworks tables from Dreamweaver 289
formatting 189
HTML tags 189
importing 186
merging cells 198
nesting 197
No Wrap option 192
overview 183
preset designs for 193
properties 190
resizing 194
See also layout view
See layout tables
selecting elements 187
shortcuts 551
sorting 201
See also columns, rows, and cells

tabular data, importing 186
Tag Default option (Code Colors preferences) 343
Tag Specific option (Code Colors preferences) 344
tags

applying 240
ASP 352
body 159
body 323
CFML 352
editing 338
head 323
HTML 322
in browser profiles 532
invalid 329
menus.xml syntax 522
overlapping 329

tags (continued)
removing 342
searches 260
selecting 154
specifications 538
table 189
tagspec 538
text formatting 326
third-party, customizing 537
wrapping 338
XML 330

Target image property 270
Target option 242
targeting browsers

browser profiles 532
converting file to 3.0 compatible 424
shortcuts 553, 554

targeting frames to
_blank 218
_parent 218
_self 218
_top 218

targeting links
in documents 359
opening document in a new window 359

templates 375–395
applying to document 226
applying to existing document 389
as assets. See assets
changing highlight colors 383
clicking in locked regions 385
creating 377
creating Flash button templates 306
creating new documents with 151, 389
defining editable regions 382
detaching document from 391
documents based on, creating 388
editable versus locked regions 381
editing 377, 378
finding editable regions 390
making region noneditable 387
modifying 391
overview 375
page properties 379
preferences 383
renaming 378
shortcuts 555
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templates (continued)
Templates folder 377
using behaviors 388
using styles 388
using timelines 388
viewing regions 384
XML 392

testing sites 501
text

adding to documents 234
alignment 241
changing color of 226, 240
changing font combinations 242
color, changing 240
default color in pages 153
editing shortcuts 549
external editors. See external editors
formating shortcuts 550
formatting 233
formatting tags 326
formatting with HTML styles 244
searching within documents 258

Text Color option 242
Text Color option (Page Properties) 153
text editors, files created by 150
text editors. See external editors
text fields, setting text with behaviors 464
text files, opening 150
Text option (Code Colors preferences) 343
text-based HTML editors. See external editors
TextTop alignment (image Property inspector) 271
third-party tags

avoiding rewriting 544
customizing 537

timelines
adding and removing frames 429
adding objects to 427
animation tips 433
attaching a behavior 442
changing image source file 430
changing layer properties 430
complex paths 428
controlling with behaviors 434
creating 427
in templates 388
keyframes 427
looping 429

timelines (continued)
modifying 429
multiple 431
playback head 425
playing and stopping using behaviors 469
playing automatically 429
shortcuts 552

Timelines panel 425
titles, changing 152
toolbar, document titles, changing 152
Top alignment (image Property inspector) 271
tracing images 158
transferring files, troubleshooting 144
transparent pixels in background 153
troubleshooting

clicking in locked regions 385
Navigator plugins 315
transferring files 144

typographical conventions 22

U

underline 239
Unmark Editable Region command 387
Unordered List option 242
unordered lists, creating 237
Untitled Documents 511
Update Current Page command 391, 399
Update HTML command 293
Update Pages command 392
updating links 366
uploading files 144
URLs

applying to selection 226
as assets. See assets
creating URL assets 231

URLs. See paths
Use Firewall option 125
Use FTP option 124
Use Local/Network option 124
Use None option 124
Use option (Code Format preferences) 344
Use Passive FTP option 125
Use Regular Expressions option 260
usemap attribute 273
Using Dreamweaver book 14
Using Dreamweaver with Visual SourceSafe 128
Using Reports to test a site 509
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V

V Space and H Space image properties 270
Validate Form action 470
variable list 479
VBScript 335
viewing

arranging views 332
Code view and Design view 331
editable and locked HTML in templates 386
editable and locked regions in templates 384
head content 159
invisible elements 156
sites 112

Visited Links color option (Page Properties) 153
visual guides

overview 157
rulers 157
tracing images 158

Visual SourceSafe, integration with Dreamweaver 128

W

W and H image properties 269
Warn When Fixing or Removing Tags option (Code 

Rewriting preferences) 346
Web design, levels of experience in 20
Web photo albums, creating 294
Web Server Info 124
Web servers. See servers
WebDAV integration 127
Window Size pop-up menu 74
windows

shortcuts 557
See also inspectors, panels

Windows OS color palette 87
Word HTML. See Microsoft Word HTML
word processors, files created by 150
work area 72
Workflow reports 141
writing code (Code view or Code inspector) 334

X

XML
in templates 392
menus.xml file 522
overview 394
tag notations when exporting 395
tags 330
tagspec tag 538

Z

Z-Index option (for layers), changing 
stacking order 420
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