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Getting Started with Adobe Illustrator CC Development

This document describes how to start developing plug-ins for Adobe® lllustrator® CC, using the Software
Development Kit (SDK). The target audience for this document is developers who need to develop
plug-ins for Illustrator.

The Illustrator CC SDK is available for download from:

http://www.adobe.com/devnet/illustrator/

To start developing plug-ins for lllustrator, follow these steps:

1. Set up your machine for development. Follow the instructions in “Setting up your development
platform” on page 6.

2. Explore the documentation; see “Exploring the documentation” on page 7.

3. Explore, compile, and run the samples; see “Exploring the samples” on page 8.

4. Continue exploring the APl using code snippets; see “Exploring the APl using code snippets” on
page 17.

5. Write a new plug-in using the supplied SDK plug-in project templates; see “Using the plug-in project
templates” on page 25.

6. Write a “HelloWorld” plug-in from scratch to learn about configuring your development environment;
see “Creating a plug-in” on page 9.

» <sDk> refers to your locally installed SDK root folder. The actual root location depends on the
installation and operating system.

» <arsrefers to the installed location of lllustrator CC. The actual location depends on the installation
and operating system.

» <vssindicates the installed location of Microsoft Visual Studio 2010 (also known as VC++ 10.0). The
actual location depends on the installation; the default is ¢: \Program Files\Microsoft Visual
Studio 10.0/.


http://www.adobe.com/devnet/illustrator/
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1. Check that your platform meets the basic requirements:

Platform Component

Windows XP  Windows XP Service Pack 2 or higher

Visual Studio 2010 SP1 Developing lllustrator CC plug-ins in Windows

Visual C++ 10 requires VC++ 10.0, a component of Visual
Studio 2010. If you have the Professional or
Standard Editions of Visual Studio 2010, you
must install the Visual C++ components.

Mac OS Mac OS 10.7 or higher
Xcode 4.5.2 Xcode can be downloaded from
http://developer.apple.com/tools/download/
LLVM Clang

(com.apple.compilers.llvm. clang.1l 0)
Apple 10.7 SDK
Apple 10.6 OS X Deployment Target

2. Download the lllustrator CC SDK for your platform from:

http://www.adobe.com/devnet/illustrator/

> In Windows, extract the contents of the downloaded zip archive to a location of your choice.

> In Mac OS, mount the downloaded disk image file (DMG) as a new volume, and copy the lllustrator
CC SDK folder to a location of your choice.

3. Fordetailed instructions on configuring the development environment for plug-in creation, see:

> “Creating a plug-in in Windows" on page 28

> “Creating a plug-in in Mac OS” on page 32

The SDK contains documentation and code samples to help you in developing your own lllustrator CC
plug-ins, and in porting plug-ins from previous releases.


http://developer.apple.com/tools/download/
http://www.adobe.com/devnet/illustrator/
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The following documents are included with the SDK:

7

Title

Description

Adobe lllustrator CC
Programmer’s Guide

Adobe lllustrator CC
Porting Guide

Using the Adobe Text
Engine

API Reference

APl Advisor

Describes the basic concepts of developing plug-ins for lllustrator CC. It is
aimed at all developers and is the recommended resource for plug-in
developers after reading this document.

This document is in the file <spx>/docs/guides/programmers-guide.pdf

Describes how to update CS6 SDK plug-in code for lllustrator CC; it is aimed at
developers with pre-existing plug-ins. It lists new features and changes in the
API since the previous release.

This document is in the file <spx>/docs/guides/porting-guide.pdf.

Describes how to configure your plug-in to use the Adobe text engine API,
provided with the Illustrator CC SDK. It describes procedures for creating,
editing, deleting, styling, and iterating text, with references to sample code and
the AP/ Reference.

This document is in the file
<SDK>/docs/guides/using-adobe-text-engine.pdf.

Provides reference documentation for the suites, classes, structures, functions,
variables, and constants available in the API. It is a key resource for all
developers.

This document is provided in two formats:

» <SDK>/docs/references/index.chm— This compiled HTML file allows
text searches to be performed on the content.

> To view the contents in Windows, double-click the index . chm file icon
in Windows Explorer to open the home page.

> To view the contents on a Macintosh, you need a CHM viewer; see
Document viewers.

» <SDK>/docs/references/sdkdocs.tar.gz — This file contains the AP/
Reference in HTML format. This format does not support text searches, but it
provides the ability to view individual HTML files if desired. To view the
contents, first decompress the archive, then open index.html in your
browser.

Reports the class, structure, and file differences between the APl included in the
CS6 SDK and CC SDK. It is aimed at all developers using the API, but it is most
useful for developers updating plug-in code for Illustrator CC.

This document is in the file
<SDK>/docs/references/apiadvisor-ail6é-vs-ail7.html.
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Document viewers

» To view PDF-based documentation, you need Adobe Reader or Adobe Acrobat.
To view HTML-based documentation, you need a web browser.

To view compiled HTML documentation (CHM) in Mac OS, you need a CHM viewer. Two such viewers
are chmox (http://chmox.sourceforge.net/) and xcum (http://sourceforge.net/projects/xchm/).

The samples provided show how to implement key lllustrator plug-in features like tools, filters, menus, and
file formats. The following table shows which features are implemented by each sample:

Annotator
DrawArt
EmptyPanel
FreeGrid
LiveDropShadow
MarkedObjects
MenuPlay
MultiArrowTool
ScriptMessage
StrokeFilter
TextFileFormat
TransformButtons
TwirlFilter
Webter

Feature

> SnippetRunner

< Tutorial

Action

AGM Port X

Annotator X X
File Format X

Filter X X
Flash/Flex Ul X X X X X X X X X
Effect X
Menu Item X X X X X X X X X X X X X X
Notifier X X X X
Panel X X X X X
Plug-in Group X

Scripting X

Theme Sync X X X

Timer X

Tool Palette X X X X

Transform X X



http://chmox.sourceforge.net/
http://sourceforge.net/projects/xchm/
http://sourceforge.net/projects/xchm/
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Use this table to identify the sample most suitable as a starting point for your own plug-in: the sample that
implements the most features your plug-in requires will give you the best base from which to work.

» Fora more detailed description of each sample, see “Samples guide” on page 10

» Foramore detailed description of these plug-in features and what they do, see the “Types of Plug-ins”
section in Adobe lllustrator CC Programmer’s Guide.

The SDK samples are based on the p1ugin and suites classes. The P1ugin class constructs the basic
requirements for an Illustrator plug-in, using the suites class to acquire and release the required suites.

To create your own plug-in using this framework:

D> Create a new project, and add Plugin.cpp and Suites.cpp to your new project from
<SDK>/samplecode/common/source/.

D> Create aclass in your project that is a subclass of the p1ugin class. This class should implement the
required functionality of the plug-in.

For a step-by-step example of configuring the development environment and creating a basic plug-in, see:

» “Creating a plug-in in Windows” on page 28

» “Creating a plug-inin Mac OS” on page 32

To build all the samples, use the projects provided in the <Spk>/samplecode/MasterProjects/ folder.
After compiling and linking, the plug-in binaries can be found in the <spx>/samplecode/output/ folder.

We recommend you use the Additional Plug-ins Folder preference when developing and debugging
plug-ins. Set this preference in the application’s Preferences > Plug-ins & Scratch Disk dialog.

For a complete list of the locations where Illustrator looks for plug-ins, see Adobe Illustrator CC
Programmer’s Guide.

To debug a sample (or your own plug-in), see “Debugging plug-ins” on page 22.
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This section describes the individual samples in more detail.

Uses the ATAnnotatorSuite and AIAnnotatorDrawerSuite to annotate artwork in the document and
update the annotations as selection or cursor position changes.

Adds a tool to the toolbar, using this icon: =

When the annotator tool is selected and the cursor is over an item on the artboard, the item becomes
selected, an annotation displaying the bounds of the art appears at the right-hand side of the artitem. A

smaller annotation displaying the cursor position appears next to the cursor, which updates as the cursor
moves within the art.

Tep: 430,37
(227 74, w4z 7] Left: 212 .47
Bettom: 370,49
Right: 365,11

The DrawArt sample demonstrates how to use the AIDrawArtSuite to obtain preview bitmap images to
display in Flash panels. The sample draws a swatch to an AGM port, retrieves a bitmap from that port, and
passes the bitmap to a Flash panel for display as an image.

This sample is a CS Extension; to run it, choose Window > Extensions > DrawArt.

Image will appear below

Get Bitmap from AGMPort
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EmptyPanel

The EmptyPanel sample demonstrates how to use native Windows or Mac OS components in a control bar
or panel, combining native controls with bars and panels created with ATControlBarsSuite and
AIPanelSuite. The bar and panel that the sample creates contain controls that are implemented using
native window components.

In the panel, the native controls implement a simple calculator. In the control bar, the values in the native
controls are tied to the dimensions of the container, allowing you to resize the control bar dynamically.

The Mac OS examples demonstrate loading a native NIB or XIB file into a panel, so that you can use all the
standard Xcode Interface Builder features, and mix objective-C and C++.

2 Third Party Panel e

Value 1 100

WValue 2 100

Add

Panel and Control Bar using native Mac OS components

I Min Width 800 [ Commit ) Max Width 1600 ( Commit ) Width 1000 [ Commit ) X 100 ¥ 100 ( Move )( Get )

2 Third Party Panel

N T

Show Dialog Panel and Control Bar using native Windows components

bin Width 50§ Commit WMaxwidth1200 | Commit Mwidth: {500 | Commilbc] v |
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FreeGrid

The FreeGrid sample demonstrates the usage of the ATperspectiveGridsuite and
AlPerspectiveTransformSuite APl to manipulate the Perspective Grid, a feature that was added in CS5.
AIPerspectiveGridsuite allows you to query and set parameters of the currently defined Perspective
Grid in a document, and to convert points between the Artwork and Perspective Grid coordinate systems.
AlPerspectiveTransformSuite allows you to project or reverse-project points and art objects according
to the Perspective Grid.

The FreeGridUl extension provides a user interface for the FreeGrid sample, demonstrating how to create a
Ul for a plug-in using the Flash/Flex-based Creative Suite Extension Builder, which is recommended as a
replacement for the deprecated ADM Ul solution.

To use this plug-in, first show perspective grid by choosing View > Perspective Grid > Show Grid or by
selecting the Perspective Grid Tool in the Tools panel. Draw or select a path art object on the active plane,
then choose Window > SDK > FreeGrid.

The resulting dialog allows you to perform one of four operations:
» Translate the art object's position by specifying X and Y offsets.
P Scale the art object's size by specifying a zoom percentage.

» Rotate the art object by specifying an angle.

» Move the art object from one perspective plane to another.

RN
[N

|

FREEGRIDUI

|

—
S Pt Fe=t—g
R o=t T e Lt
B ko e .
R -'-\-\?hb:""‘-\-\ o gy =
o ot e e e e
[ e iy - B e e L I
- o I o o L e e = S
] EH‘"‘:.. . """-:_H_HLH:- e
] ] - - - -
e e . - .
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LiveDropShadow

Uses the pP1ugin group suite. It creates “live” drop shadows on objects; these work like the DropShadow
filter, except the shadow follows any edits to the object.

Adds the menu item Object > SDK > Live Drop Shadow.

The first object has a live drop shadow. To demonstrate the “live” nature of the drop shadow, the second
object shows the result of changing the shape of the object using the Filter > Distort & Transform > Pucker

& Bloat tool.

MarkedObjects

Implements a way to mark diagrams with art, in order to help lay out books during publishing. The plug-in
creates the art using a tool in the Anchor group in the tool palette. When the tool is selected, you click on
the document to add a new marked object. You also can view and edit the details of these marked objects

from the Marked Objects dialog.
Adds the menu item Window > SDK > Marked Objects, which brings up this panel:

MarkedObjects

Update Hide All

Bounding Bosx: 73

The plug-in also adds a tool in the Pen Tool group on the Tools palette, using this icon: Ny

7]

This is an example of an object created by the Marked Object tool, a group containing two art items
representing the cross and two text items representing the label and ID: %, Default Text
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Demonstrates how to add and manipulate menu items. This sample also contains a V52008 project in
addition to the VS2010 project, in order to demonstrate how to build plug-ins for lllustrator CC using the
older version of Microsoft Visual Studio.

Adds the menu item Window > SDK > Menu Play, with a submenu.

Workspace b oW If enabled, Art/Layer is unlocked
.
Extensions [
Check me

Application Frame Disable the above menu item

« Annliratinn Rar
The plug-in demonstrates these types of menu manipulation:
» Highlighting menu items when particular item types are selected.
Highlighting menu items when the art layer has a particular state.
Changing the text displayed by the menu item when an item has a particular state.

Allowing a menu item to affect the availability of another menu item.

vV v. v v

Showing the platform-specific selection marker for a toggle-type item.

Demonstrates how to add multiple tools to the tool palette, change icons, and handle dynamic redraw of
tool modifications.

This sample creates its own tool group on the tools palette, with the most recently selected arrow icon at
the front of the group. It also demonstrates Ul themes, by defining both a light and dark version of the tool
icon.

m % Head Arrow Tool
Tail Arrow Tool
\ Both Ends Arrow Tool : -
™ Straight Line Tool light theme dark theme

0
Once one of the arrow tools is selected, the user can click and drag in the document to create a new path

in the shape of an arrow. The Head Arrow tool creates an arrow with the head at the end of the path; the
Tail arrow tool, at the beginning of the path.

This sample demonstrates how to display an annotation while drawing a path by dragging the cursor. The
annotation is activated by the left mouse button, and remains active while the button is held down.
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4, Ny L[h: 121, v: -506 |

ScriptMessage

Demonstrates how to make a plug-in scriptable using the aATscriptMessage structure. The sample
includes a Flash extension that calls into the scriptable plug-in through ActionScript.

This sample also demonstrates the use fo the AlUIThemeSuite to detect Illustrator’s Ul theme and respond
to theme changes by restyling the Flex 4.5 extension dynamically.

ScriptMessagell
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SnippetRunner

A code snippet in lllustrator is a source file, containing a class, in which you can quickly and easily
prototype SDK API calls. The SnippetRunner plug-in hosts and runs code snippets within Illustrator CC. A
set of illustrative code snippets is provided. You can also use the framework to create your own snippets,
enabling you to explore APl without all the overhead of creating an entire plug-in.

The framework it provides includes the following:

» A userinterface that allows code snippets to be chosen and run.

» A parameter-input mechanism.

» Alog-output mechanism.

» Built-in unit testing of snippets, enabled through the panel fly-out menu.

This plug-in adds the menu item Window > SDK > SnippetRunner, which brings up this panel:

SnippetRunner
] All Snippets
» [ ] Color Snippets

[ ] Data Utility Snippets

[ ] F¥G Snippets

[ ] Helper Snippets
B[] Text Snippets

p [ ] Tracing Snippets
B [ Utility Snippets
B[] ¥ML Snippets

Run button — Runs the selected snippet or snippet operation.
Save log /Save log buttons — Saves or clears the log.

Prefs button — Allows the user to specify the parameter input mode, toggle unit testing, and set the
path to the assets folder. Three parameter-input modes are available:
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D> Default Parameters (parameters are provided in the code)
D> Prompt Parameters (prompts are provided for parameter values)

D> CSV Parameters (values are provided in a CSV string).

Running and testing snippets

Code snippets can be run or unit tested from the operation, snippet, or category level.

The assets/ folder contains the files used for unit testing; it also is the location where modified unit-test
documents are saved. This folder is set up the first time a code snippet is run, and it remains the same until
either the preference is deleted or the assets folder is changed through the Set Assets Folder option in the
panel flyout menu.

The assets/ folder must be located in <SDk>/samplecode/CodeSnippets/examplefiles/. This folder
contains a . ai file and supporting image files that provide the required context for several snippet
operations.

P Seethe <SDk>/samplecode/CodeSnippets/ folder for the list of snippets provided with
SnippetRunner, and see the brief snippet descriptions in the SnippetRunner user interface for details
of what each snippet does.

» In particular, examine snpTemplate, which provides a basic framework for new snippets and
instructions on how to tailor the template to the new snippets needs.

Exploring the APl using code snippets

The SnippetRunner plug-in makes it quick and easy to use code snippets to explore the API. It is much
faster and easier to create a code snippet, rather than an entire plug-in.

All you have to do is add the template code-snippet file to the Xcode or Visual C++ project file. The
template file, <SDK>/samplecode/codesnippets/SnpTemplate . cpp, contains the hooks you need to get
any new code snippet running in SnippetRunner.

Follow the instructions in the template file to create and tailor a new code snippet to your requirements.
You will have to acquire any suites your code snippet requires that are not already provided with
SnippetRunner; just follow the instruction on where to add them.
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StrokeFilter

This sample demonstrates how to use the AlBeautifulStrokesSuite, which was added in lllustrator CS5. The
Beautiful Strokes functionality:

» Improves the ability to apply arrowheads.
» Enhances miter-ends behavior, changing the default miter limit from 4 to 10.

» Provides variable-width strokes, allowing you to adjust and alter stroke widths across the length of a
stroke.

» Provides dash adjustment to improve control over the dashed strokes.
» Allows you to scale brushes based on path length.

This sample adds two filters, the Dashed Stroke Filter to demonstrate dash adjustment and the Waved
Stroke Filter to demonstrate variable width strokes.

Dashed Strokes Filter

To invoke this filter, select a path art object, then choose Object > Filters > Additional Filters > SDK >
Dashed Stroke. The resulting dialog is similar to the middle part of the Stroke Panel (Windows > Stroke):

» "Dashed Stoke" controls whether the art is drawn with a dashed or solid stoke.
» "Adjust Dash" enables or disables dash adjustment.

» When the stroke is dashed, you can set a specific dashing patterns by specifying lengths for a
sequence of three dashes and gaps.

StrokeFilterll

Waved Stroke Filter

To invoke this filter, select a path art object, then choose Object > Filters > Additional Filters > SDK >
Waved Stroke. In the resulting dialog:

» "Number" controls the number of wave segments in the stroke.

» For n wave segments, variable widths are set at n+1 points along the path, alternating width 1 and
width 2.
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e

StrokeFilterUl

e

» Width 1 is used first, unless you select "Exchange Width 1/2".

» If you select "Replace”, old width parameters are replaced by new ones. Otherwise, new width
parameters are appended to old ones.

>

- ~

StrokeFilterUL

TextFileFormat

Shows how to add new file formats to Illustrator. The plug-in adds the “All Text as TEXT” format to
lllustrator’s Open dialog and Save dialog. It also adds the “Selected Text as TEXT” format to lllustrator’s
Save dialog.
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TransformButtons

Uses the ATITransformArtSuite suite to create a palette that executes one-click transformations to art
objects.

Adds the menu item Window > SDK > Transform Buttons, which brings up this panel:

TransformButtons

Tutorial

This plug-in illustrates the basics of plug-in development. It is the sample used in the “Tutorial” section of
Adobe lllustrator CC Programmers Guide.

Adds the menu item Object > Filters > SDK > Tutorial, which brings up this modal dialog:

.
Tutorial

This sample creates an art item from the entered parameters. The dialog comes up with default values. The
sample also defines minimum and maximum values for each data item.

This art is created using the default values:
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TwirlFilter

Demonstrates how to create filters and live effects that add menu items and manipulate selected artwork.
This sample adds menu items to the Filter and Effect menus, implementing the functionality of a filter and
an effect.

Adds the menu items Object > Filters > SDK > Twirl,, and Effect > SDK > Twirl. Both items bring up this
dialog:

Twirl

TwirlFilter works better with many points

Angle: |

The Filter and the Effect perform the same change on the selected item. The selected item is rotated by a
radian value calculated from the entered angle. The dialog comes up with a default value.

Webter

Manipulates the dictionary for document and art objects , using AIDictionarySuite.

Adds the menu item Window > SDK > Webter, which brings up this panel:

Webter

Docurment: Path

Entry: #document ILJ ILJ

Defintion:

Type: L Unknown - J l Unknown - J

Add |Add|
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Debugging plug-ins

This section summarizes how to debug your plug-in in Visual Studio 2010 and Xcode 3.2.5.

To debug your plug-in under Visual Studio:

1.

5.

6.

Make sure your plug-in is in a location where lllustrator can find it. See “Building and running the
samples” on page 9.

Open your plug-in project in Visual Studio.

Right-click the project folder and choose Properties. In the Configuration Properties, select
Debugging.

RC1 Property Pages @
Configuration: | Active(Debug) " Platform: |Active(Win32) ,J I P e I
. Commeon Properties Debugger to launch:
4 Configuration Properties ILocaI Windows Debugger ,I
General
v sargepat] B
WE++ Directories Command Arguments
a CfC++ i ] . .
General Working Directory S(ProjectDir)
Optimization Attach No
Preprocessor Debugger Type Auto
Code Generation Environment
Language Merge Environment Yes
Precompiled Headers SQL Debugging No

Change the Command to point to your lllustrator executable. The default location is: ¢: \Program
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Files\Adobe\Adobe Illustrator CC\Support Files\Contents\Windows\Illustrator.exe, Or

for 64bit installations, under ¢: \Program Files (x86)\.

Set a breakpoint in your code. If you are getting started, you can set the initial breakpoint in the
plug-in’s entry-point function, PluginMain () . For plug-ins that use the plug-in framework (such as
AnnotatorPlugin.cpp), you can set a breakpointin startupPlugin (), which is called after
initialization.

Start the debug session using Visual Studio’s Debug > Start Debugging menu.

Click OK to start debugging your plug-in under lllustrator.

To debug your plug-in under Xcode:

1.

Make sure your plug-in is in a location where lllustrator can find it. See “Building and running the
samples” on page 9.

Open your plug-in project in Xcode.

Set a breakpoint in your code. If you are getting started, you can set the initial breakpoint in the
plug-in’s entry-point function, PluginMain () . For plug-ins that use the plug-in framework (such as
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AnnotatorPlugin.cpp), you can set a breakpointin startupPlugin (), which is called after
initialization.

4. Add the Illustrator application as an executable to your plug-in's Xcode project, so Xcode can find the
Illustrator application. See details in “Adding Illustrator to the executable group” on page 23.

5. Start the debug session using Xcode’s Debug Executable menu.

Adding lllustrator to the executable group

To debug an lllustrator plug-in from an Xcode project, Xcode must be able to start the lllustrator
application. Xcode keeps this information in the Executable group for a project.

To define the executable for your project:

1. Choose Product > Edit Scheme.

m Window Help

L)

e | .I. b E

| Fromnie ot

J Analyze G4H#HE =

& Archive B
Build For > =
Perform Action > @

| Build 3B
Clean {+38K
Cenerate Output 2 =
Debug »
Debug Workflow [ 2
Attach to Process B
Edit Scheme... #<
New Scheme...
Manage Schemes... ult

2. In the Edit Scheme dialog, click Executable and choose Other from the dropdown menu.

3. Inthe resulting file browser, navigate the lllustrator CC application. The path to the default install
location is:

/Applications/Adobe Illustrator CC/Adobe Illustrator CC.app

4, Click Choose.
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Choose an executable to launch

|« |» [|22]| = m Il || = v ||-'ﬁuﬁﬂaﬂe-i.i.lu_t.tramr.rffé.
FAVORITES 41| Adobe Illustrator CC
= All My Files (] Configuration >
] Cool Extras P
DT et Lt o i Gl Legal e
(= Desktop W Plug-ins "
"1 Documents il Presets >
[ Scripting P
O e ) uninstall Adobe lllustrator CC

H Movies
J7 Music
[E] Pictures
|':| Dropbox
12} rmccubbi
(] Sites

[ sdk

] Lemonmonger
[_] Google Drive

Mame Adobe lllustrator CCL
E| Creative Clouw... Kind Application ‘
S5ize 479.3 MB
SHARED Created 26 Mar 2013 14:38 |
IEJ achouhan-xp24 Modified 26 Mar 2013 14:38
: Last opened 26 Mar 2013 14:38
L1 Albrecht-Mac B
=] aledawso-w7
| Cancel | [ Choose j

5.

Click OK.

If you set up only one executable for the project, it becomes the active executable. When you choose

Build > Build And Debug, Xcode starts the application and shows a debug window. You must make sure
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An Executable Info window appears, which summarizes the executable environment you just created.

the plug-in you want to debug is loaded by Illustrator on start-up; see “Building and running the samples”
on page 9.

If llustrator is already running, you can use Run > Attach to Process in Xcode to attach the debugger and
current project to the running process, as long as you have previously set the executable for the project to
be lllustrator.
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Setting the debug information format

Different formats are available for debugging information. lllustrator plug-ins use DWARF format (rather
than Stabs format). To specify this format, set the “Debug Information Format”
(DERUG_INFORMATION FORMAT) build setting.

Xcode supports two kinds of DWARF settings:

» The “DWARF” option generates symbols embedded in the . o object file.

» The “DWARF with dSYM File” option puts the symbols in a separate .dsyufile.

For more information on choosing the proper DWARF option for your plug-in, see the Xcode

documentation.

Formatting program data for the debugger

The Xcode debugger variable view shows information about variable values for your program. A summary
column provides additional information about a variable’s content. To edit a variable summary,
double-click the Summary column or choose Run > Variables View > Edit Summary Format.

When you are using an Xcode debugger to view a variable that uses a complex data structure, you may
find yourself clicking to expand the class variable to see the one member you care about. To simplify, you
can create a data formatter to customize how variables are displayed or summarized in the debugger. For
details, see the chapter on “Examining Program Data and Information” in:

http://developer.apple.com/documentation/DeveloperTools/Conceptual/XcodeUserGuide/Con
tents/Resources/en.lproj/index.html

Problems stepping through code in the Xcode debugger

If you have problems stepping through your plug-in code using the Xcode debugger’s Step Over or Step
Into buttons, make sure you are using the supported version of Xcode. See “Setting up your development
platform” on page 6.

If you are stepping over an lllustrator API call and you see the message, “Previous frame inner to this frame
(corrupt stack?),” try one of these workarounds:

P> Use the Xcode debugger’s Continue button to resume execution.

» Use the Xcode debugger “Continue to Here” command to run to a subsequent line of code. The
“Continue to Here” command is available by right-clicking the left of the code-editor pane in the
Xcode debugger window.

» Step using gdb instead of the Step Over button. Use Xcode’s Debug > Console Log menu to open the
debugger console, and type step at the prompt.

As a starting point for creating your own plug-in, we recommend you use the provided templates, which
give you a new project with the same configuration as the sample plug-ins. The templates discussed in this
section are in the <SpDk>/samplecode/Templates/ folder.


http://developer.apple.com/documentation/DeveloperTools/Conceptual/XcodeUserGuide/Con
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For detailed instructions on configuring the development environment for plug-in creation, see:

» “Creating a plug-inin Windows" on page 28

» “Creating a plug-inin Mac OS” on page 32

This template creates valid projects for both Visual Studio and Xcode. The default installation folder,
indicated here by <vs>,is C:\Program Files (x86)\Microsoft Visual Studio 10.0.

1. Quit Visual Studio if it is running.
2. Copy IllustratorSDKdefault.vexproj to <VS>\VC\VCWizards\.

3. Copythe folder <spk>\samplecode\Templates\Win\IllustratorSDK\ tO
<VS>\VC\VCWizards\AppWiz\.

4. Copythefile I111lustratorsSDK.vsz t0 <VS>\VC\vcprojects)\.

5. Create a new folder <vs>\vC\vcprojects\IllustratorsDK\, and copy the folder
IllustratorSDK.vsdir into the new folder.

6. Start Visual Studio.

7. Choose File > New > Project.

8. Inthe Project Types pane of the New Project dialog, select Visual C++ > lllustratorPlugin.
9. Inthe Templates pane, select SDKProject.

10. Set the Name of the project to a name of your choice.

11. Set the Location of the project to the <spk>\samplecode folder. (If you save to a different location, you
will have to update the relative paths.)

12. Ensure Create Directory For Solution is not checked. (If this option is selected, the relative paths will
have to be updated, as the project file will not be at the top level.)

13. Click OK.

14. Build the project and load it into Illustrator; see “Build the project” on page 31.

In addition to the template itself, the Templates/Mac folder contains a tool that you can use to create
Xcode projects from the template. To use it, open a command shell and type:

cd <SDK _root>/samplecode/Templates/Mac
create project.sh <ProjectName>

This tool follow the steps you would use to create a project from the template by hand:

1. Copy the “Template” project from <SDK_root>/samplecode/Templates/Mac iNto your SampleCode
folder.

2. Open the Xcode Project inside your newly copied project.
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3. Use the Find command to find all instances of “[PROJECT_NAME]” and replace all instances with the
name of your project.

4. Rename all of the source files from “Template*.*" t0 “project name*.*"
For example, rename TemplatePlugin.cpp t0 MyProjectPlugin. cpp.

5. In the folders pane, expand the Targets item. Rename the “Template” bundle in that section to the
name of your project (right-click “Templates” and choose Rename).

6. Double-click the project in the folders pane, then select the Build tab. Use the search box to find the
string “Template”, in order to narrow down the build options. Look for "Product Name" under the
“Packaging” item and “PROJECTNAME” under the User-defined item. In both of these, change the
value from “Template” to the name of your project.

7. Build and run llustrator to see your working project.
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This section describes how to write from scratch a plug-in that extends Illustrator in a very basic way. The
instructions create a HelloWorld plug-in for lllustrator, which pops an alert when lllustrator starts up or
shuts down.

P This section provides instructions for the Windows platform. See also “Creating a plug-in in Mac OS”
on page 32.

1. Start Visual C++.
2. Choose File > New > Project...
3. Inthe New Project dialog, do the following:
D> Expand the Visual C++ filter.
In the Project Types window, highlight Win32.
In the Templates window, select Win32 Project.
Set the Name property of the project to HelloWorld.

Set the Location property of the project to <spk>samplecode.

v Vv VvV V V

Deselect Create Directory For Solution.
> Click OK.
4. Inthe Win 32 Application Wizard, do the following:
> Select Application Settings.
> Under Application Type, select DLL.
> Under Additional Options, select Empty Project.

> Click Finish.

1. In the Solution Explorer, right-click the Source Files folder.
2. Choose Add > New Item...
3. Inthe Add New Item dialog, do the following:

D> Expand the Visual C++ filter.

> Highlight Code, and select C++ File (.cpp).

D> Set the Name property of the file to HelloWorld. cpp.

> Click Add.
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4. Copy this code to the source file, and save.

#include "IllustratorSDK.h"

// Tell Xcode to export the following symbols

#if defined( GNUC_ )

#pragma GCC visibility push (default)

#endif

// Plug-in entry point

extern "C" ASAPI ASErr PluginMain (char * caller, char* selector, void* message) ;
// Tell Xcode to return to default visibility for symbols
#if defined( GNUC_ )

#fpragma GCC visibility pop

#endif

extern "C"
AlUnicodeStringSuite* sAIUnicodeString = NULL;
SPBlocksSuite* sSPBlocks = NULL;

}

extern "C" ASAPI ASErr PluginMain (char* caller, char* selector, void* message)
{
ASErr error = KNOErr;
SPBasicSuite* sSPBasic = ((SPMessageData*)message) ->basic;
if (sSPBasic->IsEqual (caller, kSPInterfaceCaller)) ({
AIUserSuite *sAIUser = NULL;
error = sSPBasic->AcquireSuite (kAIUserSuite, kAIUserSuiteVersion, (const void**)
&sAIUser) ;
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error = sSPBasic->AcquireSuite (kAIUnicodeStringSuite, kAIUnicodeStringSuiteVersion, (const

void**) &sAIUnicodeString) ;
error = sSPBasic->AcquireSuite (kSPBlocksSuite, kSPBlocksSuiteVersion, (const void**)
&sSPBlocks) ;
if (sSPBasic->IsEqual (selector, kSPInterfaceStartupSelector)) {
sAIUser->MessageAlert (ai::UnicodeString ("Hello World!")) ;
}

else if (sSPBasic->IsEqual (selector, kSPInterfaceShutdownSelector)) {
sAIUser->MessageAlert (ai: :UnicodeString ("Goodbye World!")) ;
}

error = sSPBasic->ReleaseSuite (kAIUserSuite, kAIUserSuiteVersion) ;
error = sSPBasic->ReleaseSuite (kAIUnicodeStringSuite, kAIUnicodeStringSuiteVersion) ;

}

return error;

}

5. In the Solution Explorer, right-click the Source Files folder and choose Add > Existing item.
6. Navigate to the folder <SDK_root>\Illustratorapilillustrator.
7. Select the file 1ATUnicodesString. cpp.

8. Click Add.

1. In the Solution Explorer, right-click the Resource Files folder.
2. Choose Add > New Item...

3. Inthe Add New Item dialog, do the following:
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7.

D> Expand the Visual C++ filter.

> Highlight Resource, and select Resource File (.rc).

D> Set the Name property of the file to HellowWworld. rc.
> Click Add.

Close the Resource View window.

In the Solution Explorer, right-click HellowWworld. rc.

Select View Code.

Just before the line containing #ifdef APSTUDIO_ INVOKED, insert this code:

#define kMySDKPluginName "HelloWorld"
#define PIPL PLUGIN NAME kMySDKPluginName

[I1110170077717007771707777171777717171707717170117717171711711177111111117

//

// PIPL

//

#define LC(a,b,c,d) #d, #c, #b, #a

160

00 PiPL DISCARDABLE

BEGIN

END

8.

1.

0x0001, /* Reserved (for Photoshop) */

0L, /* kCurrentPiPLVersion */

4L, /* Property Count */

LC(A,D,B,E), /* vendorID */

LC(k,i,n,d), /* propertyKey = PIKindProperty */
0L, /* propertyID */

41, /* propertyLength */

LC(S,P,E,A), /* propertyData */

LC(A,D,B,E), /* vendorID */
LC(i,v,r,s), /* propertyKey
0L, /* propertyID */

4L, /* propertyLength */
2L, /* propertyData */
LC(A,D,B,E), /* vendorID */
LC(w,x,8,6), /* propertyKey = PIWin32X86CodeProperty */

0L, /* propertyID */

12L, /* propertyLength */

"PluginMain\0\0", /* propertyData = Entry Point */

/* (Long Word padded C String) */

LC(A,D,B,E), /* Vendor Key */

LC(p,i,n,m), /* propertyKey = PIPluginNameProperty */

0L, /* propertyID */

12L, /* propertyLength */

PIPL_ PLUGIN NAME "\0\0" /* propertyData = Plug-in name (padded to 4
bytes) */

PISPVersionProperty */

Save the file.

Right-click the project name in the Solution Explorer, and select Properties to open the Property Pages
dialog.
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2.

10.

11.

12.

13.

14.

2.
3.

In the project Property Pages dialog, expand the Configuration Properties filter.

Expand the C/C++ filter.

Choose Configuration Properties > C/C++ > General.

In the Additional Include Directories field, enter the following:
..\..\illustratorapilate;..\common\includes;..\..\illustratorapi\adm;
..\..\illustratorapilillustrator\legacy;..\..\illustratorapi\illustrator;
..\..\illustratorapi\pica_ sp

Choose Configuration Properties > C/C++ > Code Generation.

Set Runtime Library to Multi-threaded Debug (/MTd).

Set Struct Member Alignment to 8 Bytes (/Zp8).

Expand the Linker filter.

Choose Configuration Properties > Linker > General.

Set Output File to . . \output\win\debug\HelloWorld.aip

Choose Configuration Properties > Linker > Input.

Set Module Definition File to . . \common\win\PluginMain.def

Click Apply, then OK.

The settings we have chosen are for a debug configuration, so ensure that Debug is selected in the
drop-down list.

Build the project by choosing Build > Build HelloWorld.

Fix any build errors. See “Debugging plug-ins” on page 22.

After compiling and linking, the plug-in binary file is in the following location:

<SDK>\samplecode\output\win\debug\

You must ensure that the plug-in binary is in a location searched by Illustrator for plug-ins to load; see
“Building and running the samples” on page 9.

To test the plug-in, start lllustrator CC. During start-up, an alert is popped, displaying a short greeting.
Once the application has started, your plug-in's name should be listed in the Help > System Info... dialog.
During shut-down, an alert is popped, displaying another short message.

31
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Creating a plug-in in Mac OS

This section describes how to write from scratch a plug-in that extends Illustrator in a very basic way. The
instructions create a HelloWorld plug-in for lllustrator, which pops an alert when lllustrator starts up or
shuts down.

» This section provides instructions for the Mac OS platform. See also “Creating a plug-in in Windows"
on page 28.

Create a new project

1. Start Xcode.
2. Choose File > New > New Project.

3. Inthe New Project Assistant, choose Other > Empty Project as the template and click Next.

Choose a template for your new project:

B ios i
Application ﬁ'
Framework & Library i .

Other :

5 Empty External Build
i i Mac0s X System

| Application

Framework & Library
Application Plug-in
Systermn Plug-in

Bt

1

4, Set the Project Name to HelloWorld.

5. Set the Project Directory to <SDK>/samplecode.
6. Click Create.

7. Inthe main menu, choose New Group.

B = ® & = » 8 |m| < > [hen

. Helloworld
(v

missing Show in Finder
Open with External Editor L—
Open As >

New File...
MNew Project...

New Group from Selection
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8. Name the new group Source.

9. Add another new group, called Resources.

Add a target

1. Click the project to show the project page, and choose Add Target.

2. Inthe New Target Assistant, choose Mac OS X > Framework & Library > Bundle as the template and
click Next.

i I ios

~ -
Application ‘ﬂ: ]! Ei A

Framework & Library

Choose a template for your new target:

Oth
= Cocoa Framework Cocoa Library
i MacO0s X
Application
_Ii I L U I I-\.Il 1"::.'“ ﬁ 4 'I{ak f
Application Plug-in .]r:* 'IT",
System Plug-in i e
Other C/C++ Library STL C++ Library

3. Set the Product Name to HelloWorld and click Finish to return to the project page.
4. Inthe project page, select the Build Settings tab.

5. Search for the Wrapper Extension setting, and set it to "aip"

Add a source file

1. Rlght click the Source folder and choose New File.

e IlUnicodes Show in Finder Irg::
I r I (] -

2 S Open with External Editor

b | | HelloWorld2 D. A R

> [_—| Frameworks pen As

b [ | Products
| NewfFile.. B

New Project... ight
ghts
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2. Choose Mac OS X > Cand C++ > C++ Class file as the template.

Choose a template for your new file:

| ios
Cocoa Touch L h .C

Cand C++ L. e 2

User Interface . E il
o Dara eader File ile ++ Class

Resource
Other

K 05X

Caocoa

User Interface
Core Data
Resource
Other

’C++ C++ Class

A C++ class implementation with header.

| Cancel | Previous

3. Name the new file HelloWorld. This creates files Helloworld. cpp and HelloWorld.h; delete
HelloWorld.h.

4. Open the file HelloWorld. cpp, copy in the following code, and save:

#include "IllustratorSDK.h"

// Tell Xcode to export the following symbols

#if defined(_ GNUC_ )

#pragma GCC visibility push (default)

#endif

// Plug-in entry point

extern "C" ASAPI ASErr PluginMain (char * caller, char* selector, void* message) ;
// Tell Xcode to return to default visibility for symbols
#if defined(_ GNUC_ )

#fpragma GCC visibility pop

#endif

extern "C"

{

AlUnicodeStringSuite* sAIUnicodeString = NULL;
SPBlocksSuite* sSPBlocks = NULL;
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extern "C" ASAPI ASErr PluginMain (char* caller, char* selector, void* message)

{

ASErr error = kNOErr;
SPBasicSuite* sSPBasic = ((SPMessageData*)message) ->basic;
if (sSPBasic->IsEqual (caller, kSPInterfaceCaller)) {
AIUserSuite *gAIUser = NULL;
error = sSPBasic->AcquireSuite (kAIUserSuite, kAIUserSuiteVersion, (const
void**) &sAIUser) ;
error = sSPBasic->AcquireSuite (kAIUnicodeStringSuite,
kAIUnicodeStringSuiteVersion, (const void**) &sAIUnicodeString) ;
error = sSPBasic->AcquireSuite (kSPBlocksSuite, kSPBlocksSuiteVersion, (const
void**) &sSPBlocks) ;
if (sSPBasic->IsEqual (selector, kSPInterfaceStartupSelector)) {
sAIUser->MessageAlert (ai: :UnicodeString ("Hello World!")) ;
}

else if (sSPBasic->IsEqual (selector, kSPInterfaceShutdownSelector)){
sAIUser->MessageAlert (ai: :UnicodeString ("Goodbye World!")) ;

error = sSPBasic->ReleaseSuite (kAIUserSuite, kAIUserSuiteVersion) ;

error = sSPBasic->ReleaseSuite (kAIUnicodeStringSuite,
kAIUnicodeStringSuiteVersion) ;

}

return error;

}

1. Inthe folders pane, right-click the Source folder and choose Add Files to "HelloWorld".
2. Navigate to the folder <sDK_root>\Illustratorapilillustrator.
3. Select the file IaATUnicodestring. cpp

4. Click Add.

1. Under Folders, right-click the Resources folder and choose New File.

2. Under Mac OS X > Other, choose Empty as the template and click Next.
3. Set the File Name to HelloWorld.r.

4. Select the Target and click Create.

5. Copy the following to the new resource file:

#define PIPL PLUGIN NAME "HelloWorld"
#include "Plugin.r"

1. Under Folders, click the project to show the project page, and select the Build Settings tab.

35
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2. Setthe following values:

Setting Value

Base SDK Mac OS X 10.7

Architecture 64-bit Intel

Compiler forC/C++/Objective C com.apple.compilers.llvm.clang.1l 0
Build Products Path ./../output/mac/$ (AI_CONFIGURATION)

Per-configuration Build Products Path
Intermediate Build Files Path

Header Search Paths .. /common/ **
../../illustratorapi/**
/Developers/Headers/FlatCocoa/**

Info.plist File ../common/mac/Info.plist

Info.plist Preprocessor Prefix File ../common/includes/SDKDef .h

Prefix Header > Debug ./../common/includes/IllustratorSDKdebug.pch
Prefix Header > Release

./../common/includes/IllustratorSDKrelease.pch

Deployment Target 0SX10.6
CLanguage Dialect Compiler Default
C++ Language Dialect

C++ Standard Library

Force Package Info Generation Yes

Preprocess Info.plist File Yes

3. Choose Add Build Setting > Add User-Defined Setting, and enter a setting named
"Al_CONFIGURATION."
Expand its definition and set the Debug value to "debug", and the Release value to "release":

| ¥ User-Defined

¥ Al_CONFIGURATION <Multiple valuess>
Debug
Any Architecture | Any SDK » debug
Release

Any Architecture | Any SDK 5 & release

O O.

Validate Settings Add Build Setting

4. Under Targets on the left, select the HelloWorld target and navigate to the Build Phases tab.
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PROJECT Info Build Settings | Build Phases | Build Rules
™ Helloworld Q
TARGETS | b Target Dependencies (0 items)

| b Compile Sources (4 items)

| P Link Binary With Libraries (0 items)

| = Copy Bundie Resources (0 items)

P Build Carbon Resources (1 item)

L

5. Click Add Build Phase and choose "Add Build Carbon Resources".

JT Build Carbon Resources (0 items)

Add Carbon resource files here

6. Click"+" and choose HellowWorld.r as the new resource.

Build the project

1. Choose Product > Edit Scheme, and select "Debug" as the build configuration.
2. Build the project by choosing Product > Build.

3. Fixany build errors. See “Debugging plug-ins” on page 22.

After compiling and linking, the plug-in binary file is in the following location:
<SDK>/samplecode/output/mac/debug/

You must ensure that the plug-in binary is in a location searched by lllustrator for plug-ins to load; see
“Building and running the samples” on page 9. To test the plug-in, start lllustrator CC. During start-up, an
alert is popped, displaying a short greeting. Once the application has started, your plug-in's name should
be listed in the Help > System Info... dialog. During shut-down, an alert is popped, displaying another short
message.
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