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Using Help

 

About online Help

 

Adobe Systems, Inc. provides complete documentation in the Adobe PDF Help system. 
The Help system includes information on all the tools, commands, and features for both 
Windows and Mac OS. The PDF format is designed for easy navigation online, and support 
for third-party screen readers compatible with Windows. The Help can also be printed as a 
desktop reference.

 

Navigating in Help

 

The Help will open in an Acrobat window with the bookmark pane open. If the bookmark 
pane is not open choose Window > Bookmarks. You can also navigate using the 
navigation bar, the index, or search the document.

At the top and bottom of each page is a navigation bar. Click Using Help to return to this 
introduction. Clicking Contents, or Index will take you to that section.

The Next Page  and the Previous Page  arrows let you move through the pages 
sequentially. Click Back to return to the last page you viewed. You can also use the 
navigation arrows in the Acrobat toolbar. 

 

Using bookmarks, the table of contents, the index, and Find

 

The contents of Help are shown as bookmarks in the bookmark pane. To view subtopics, 
click the plus sign next to a bookmark. Each bookmark is a hyperlink to the associated 
section of the Help document. 

To go to the information, click its bookmark. As the information is displayed in the 
document pane, its bookmark is highlighted.

You can turn highlighting on or off by selecting the Highlight Current Bookmark option 
from the bookmark pane menu.

 

To find a topic using the table of contents:

1

 

Click Contents in the navigation bar at the top or bottom of any page.

 

2

 

Click a topic on the Contents page to move to the first page of that topic.

 

3

 

In the bookmark pane, expand the topic to see its subtopics.

 

To find a topic using the index:

1

 

Click Index in the navigation bar at the top or bottom of any page.

 

2

 

Click the appropriate letter at the top of the page.

You can also expand the Index bookmark, and click the letter in the bookmark pane.

 

3

 

Locate your entry, and click the page number link to view the information.

 

4

 

To view multiple entries, click Back to return to the same place in the index.
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To find a topic using the Find command:

1

 

Choose Edit > Find.

 

2

 

Enter a word or a phrase in the text box, and click OK.

Acrobat will search the document, starting from the current page, and display the first 
occurrence of the word or phrase you are searching for. 

 

3

 

To find the next occurrence, choose Edit > Find Again.

 

Printing the Help file

 

Although the Help has been optimized for on-screen viewing, you can print pages you 
select, or the entire file.

To print, choose Print from the File menu, or click the printer icon in the Acrobat toolbar.
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Working with Projects, 

 

Windows, and Palettes 

 

Working in a project

 

An After Effects 

 

project

 

 is a single file that stores references to all the footage you use in 
that project. It also contains information about how you’ve arranged the footage in 
compositions, including the details of any effects or animation you applied. Inside a 
project, you create one or more compositions. After you have imported source footage 
into the project, you can add footage items into the compositions.

 

Where you work with footage items

 

In a project, you work with footage items using primarily three windows: the 

 

Project 
window

 

, which lists all the source footage items you import; the 

 

Composition window

 

, 
which displays images as they relate in space; and the 

 

Timeline window

 

, which displays 
compositions and animation events in terms of time. Add footage items to a composition 
by dragging them from the Project window into either the Composition window or the 
Timeline window. 

Each Composition window has a corresponding Timeline window. When you edit a 
composition in a Composition window, After Effects automatically displays the corre-
sponding Timeline window, and vice versa. 

 

A.

 

 Source footage

 

B.

 

 Project window

 

C.

 

 Composition window

 

D.

 

 Timeline window

 

As you work with compositions, you also use three other types of windows: Footage 
windows, Layer windows, and Effect Controls windows. 

A

B C

D
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•

 

Footage windows are useful for viewing and evaluating footage items in their original 
form (see “Viewing imported footage” on page 50). 

 

•

 

To view a layer’s original source independently of other layers or to trim footage, you 
can open a Layer window (see “Composition, Layer, and Footage window controls” on 
page 16). 

 

•

 

As you work with effects, you use the Effect Controls window to modify and animate 
the effects (see “Working with effects” on page 170).

When you render your compositions into a movie, you work in the Render Queue window 
to select rendering options and queue compositions for rendering (see “Using the Render 
Queue window” on page 279). 

 

How you start a project

 

Starting a project involves two tasks: (1) planning your project based on the formats of the 
final output and (2) creating a project file. Once you have planned your project and 
learned how to perform some basic tasks related to working in After Effects, you’ll be 
ready to start importing footage (see “Importing files into a project” on page 28). You then 
create a composition and begin working with your source footage (see “Working with 
imported footage” on page 50).

 

Planning your project

 

Planning your project before you start importing footage makes your work easier. A large 
part of planning is simply determining the best settings for your source footage based on 
the media for which you will render your finished project. This step is essential to 
achieving optimal image quality. Rendering order and nesting may also be part of project 
planning (see “Organizing a project using nesting” on page 265). 

 

Choosing the right media 

 

Before you start importing footage items into your project, decide which media you’ll use 
for your finished movies. Then determine the best settings for your compositions and 
source material. For example, if you will be rendering your project to videotape, create 
footage at an image size, color bit-depth, and frame rate that will produce the best image 
quality on videotape. Likewise, if your project is intended for streaming video on the Web, 
the image size, color bit-depth, and frame rate may need to be reduced to work with the 
data-rate limits of streaming video on the Web. However, any footage item that can be 
imported can be used in any composition.

If you will be rendering a project to more than one media format, always match the 
resolution setting for your composition to the highest resolution setting used for your 
output. Then set up the Render Queue window to render a separate version of the project 
for each format.
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For film and video, try to match import and composition settings with settings in the 
output module used to render a movie. For example, to ensure smooth playback, the 
footage frame rate selected in the Interpret Footage dialog box should match the setting 
in the Composition Settings dialog box and the output module in the Render Queue 
window. Also, the composition-frame size should be determined by the image size in the 
playback medium. However, any footage item that can be imported can be used in any 
composition. See “Preparing motion-footage frame rates for final output” on page 42, 
“Understanding basic composition settings” on page 57, and “Changing output module 
settings” on page 284.

If you will be mixing source footage with different pixel aspect ratios, correctly specify this 
ratio for each footage item in the Interpret Footage dialog box. See “About D1, DV, and 
various pixel aspect ratio footage” on page 46.

The suggestions that follow will help you select composition settings. However, the best 
way to ensure that your project is suitable for a specific medium is to make a test compo-
sition and view it using the same type of equipment your audience will use to view it. 

 

Film

 

If you will be rendering for film, consider both the aspect ratio of the frame size you 
select for your composition and the frame rate of your source footage. For footage that 
was transferred from film to video using the 3:2 pulldown telecine method, you must 
remove 3:2 pulldown before adding effects. See “Removing 3:2 pulldown from video 
transferred from film” on page 45.

 

CD-ROM

 

When you create a movie that you plan to render for playback from a CD-ROM, 
you may need to specify import and composition settings that take into account the wide 
range of hardware that your audience may be using, possibly including older single- or 
double-speed CD-ROM drives.

To make your final output compatible with older CD-ROM drives, try to reduce the data-
transfer rate of your final output by specifying certain settings for footage items: 

 

•

 

Lower the frame rate as far as you can in the Composition Settings dialog box without 
making motion seem too jerky. Start at 15 frames per second (fps). 

 

•

 

When rendering your final composition, choose a file type and compressor/decom-
pressor (

 

codec

 

) appropriate for the final media. For example, for a cross-platform CD-
ROM, you might specify a QuickTime codec or a codec designed for low data rates, such 
as Indeo, Cinepak, or Sorenson Video. Regardless of which codec you select, however, it 
must be available on the system used by your intended audience to ensure successful 
playback. Also consider the key frame rate of the codec you have selected. See the 
Adobe Web site for more information on QuickTime compressors and codec key frame 
rates. 

 

Videotape

 

If your final output will be videotape, set up your composition with a specific 
video format in mind, such as NTSC or PAL. Using broadcast-safe colors and maintaining 
frame size and compression ratios are also important considerations. These guidelines will 
help in setting up a composition intended for videotape:

 

•

 

Select a frame size in the Composition Settings dialog box that matches the frame size 
of the destination video format.

 

•

 

Use only NTSC-safe colors when adding or changing color in a project. 
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•

 

If you will be using an MJPEG codec, keep in mind that the frame sizes and resolutions 
available for rendering are determined by the specific MJPEG board you are using. Refer 
to the specifications for your MJPEG board. 

 

Animated GIF

 

When you render an animated GIF, colors are dithered to an 8-bit palette. 
Before rendering your final project, render a test composition so that you can adjust colors 
if the results are not what you expected. If any source footage includes an alpha channel, 
be sure that you know how it will affect your final project before you start rendering. 

 

Streaming video over the World Wide Web

 

Streaming video resembles a conventional 
television signal in that video is sent to the viewer frame by frame, instead of by 
downloading a large file to the hard disk. Streaming video on the Web is constrained by 
the limited bandwidth (56 Kbps or less) of most consumer modems, which is even lower 
than those used for CD-ROM playback. Use the same techniques that are listed for CD-
ROM playback, but adapt them for further reduction in file size and data-transfer rate. You 
can export QuickTime streaming directly from After Effects. See “Exporting footage using 
QuickTime components” on page 289.

 

Downloading video over the World Wide Web

 

If your final output will be downloaded 
as a file from the World Wide Web, the main concern is the size of the file, which directly 
affects how long it takes to download the file. QuickTime and Microsoft Video for Windows 
are formats often used when rendering final output that will be downloaded. When you 
render a QuickTime movie, After Effects automatically creates a movie that can play on 
both Windows and Mac OS without modification. 

 

Intranet playback

 

An 

 

intranet

 

 is an in-house or private network that uses Internet 
network protocols. Intranets generally use higher-quality communications lines than 
standard telephone lines, so they are usually much faster than the Internet. The data-
transfer rate for playback can be 100K per second or faster, depending on the speed 
of your intranet. 

 

Flash (.swf) files

 

When you export compositions as Flash (.swf ) movies, After Effects 
maintains vectors as much as possible. However, some items cannot be represented as 
vectors in the Flash file. See “Exporting to Macromedia Flash (SWF) format” on page 286.

 

Considerations for cross-platform projects

 

After Effects project files are compatible with both the Mac OS and Windows platforms. 
You can do several things to ease the process of exchanging projects between platforms.

 

Project hierarchy

 

When you move a project to a different computer and open it, After 
Effects attempts to locate the project’s footage files, first looking in the folder in which the 
project file is located, second using the file’s original path or folder location, and third 
searching the root of the directory where the project is located.

If you are building cross-platform projects, it is best if the full paths have the same names 
on Mac OS and Windows systems. If the footage is on a different volume than the project, 
make sure that the appropriate volume is mounted before opening the project, and that 
network volume names are the same on both systems.

It helps to store footage in the same folder as the project file or in another folder within 
that folder. Here's a sample hierarchy:

c:\newproject\project_file.aep 
c:\newproject\source\footage1.psd 
c:\newproject\source\footage2.avi 
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The newproject folder can then be copied in its entirety across platforms, and After Effects 
will properly locate all of the footage. 

 

File-naming conventions 

 

When possible, name your footage and project files with 
Windows-compatible filename extensions, such as .mov for QuickTime movies and .aep 
for After Effects projects. If files will be used on the World Wide Web, be sure that filenames 
adhere to the appropriate conventions for extensions and paths. 

 

Mac OS file types

 

On Mac OS systems, footage files should have proper Mac OS file 
types. Using services for Macintosh in Windows NT Server or Windows 2000 Server, you 
can set up explicit extension-to-file-type mappings; see the system’s server documen-
tation. If footage files are not properly recognized on Mac OS systems, select All Files for 
Show in the Import File dialog box to override the Mac OS file types. To open a Windows 
project on a Mac OS system, the project must have the correct .aep extension.

For a list of common extensions and their associated file types, see the Adobe Web 
site. 

 

Resources

 

Ensure that all resources are available on both systems. Resources can include 
fonts, effects, and compressors. 

 

Time basics

 

Time is central to many operations in After Effects. You can view, specify, and manage time 
in various ways. Whichever way you handle time, there are several specific time concepts 
you should understand as you create a project.

 

Time display

 

The way you view and specify time in After Effects depends on the display style, or unit of 
measure, that you use to describe time. By default, After Effects displays time in Society of 
Motion Picture and Television Engineers (SMPTE) 

 

timecode

 

: hours, minutes, seconds, and 
frames. You can change to another system of time display, such as film frames, or feet and 
frames of 16mm or 35mm film. See “Setting time-display options” on page 9. 

Video-editing workstations use SMPTE timecode that is often striped (encoded) onto 
videotape for reference. If you are creating video that will be synchronized with video that 
uses SMPTE timecode, use the default timecode display style.

 

Frame rate

 

Each composition you create can have its own 

 

frame rate

 

. The frame rate is the number of 
frames the rendered composition produces in every second when played back. The frame 
rate you use is generally determined by the type of output you will produce. For example, 
video for NTSC television plays at 29.97 frames per second (fps), and PAL plays at 25 fps.

When you set up changes over time, After Effects treats the changes as continuous 
throughout a composition timeline. Each frame is rendered as a slice out of the timeline at 
the frame rate you specify. Because After Effects treats time continuously, it is possible to 
change a composition’s frame rate at any time or override the frame rate of a composition 
when you render the final movie. See “Setting frame rate” on page 58.
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NTSC (29.97) drop-frame timecode

 

When you work with a composition that is set to a frame rate of 29.97 fps, After Effects 
uses SMPTE 30-fps drop-frame timecode by default, making adjustments using the 
SMPTE-standard method of renumbering the first two frame numbers of every minute, 
except at every tenth minute. For example, the frame after 59:29 is labeled 1:00:02 instead 
of 1:00:00. Non-drop-frame timecode is also available. In both cases, frames are not 
discarded or skipped; they are merely numbered differently.

After Effects displays drop-frame timecode by using semicolons between the numbers 
and displays non-drop-frame timecode using colons between the numbers. In the Project 
Settings dialog box, you can choose how 29.97-fps compositions and footage display their 
timecode. See “Setting time-display options” on page 9.

 

Duration

 

Each video footage item, layer, and composition in a project has its own duration. 
Duration determines the beginning and ending times of the timelines in the Footage, 
Layer, and Timeline windows. It is important to notice which duration you are viewing 
while you edit in multiple windows. See “Understanding trimming” on page 81 and 
“Positioning a layer in time” on page 76. 

 

Frames and fields

 

Each frame in an interlaced video source is made up of 

 

fields

 

. It’s important not to confuse 
frames with fields. For video, every frame contains two interlaced fields. If you want to use 
interlaced video as source footage, you’ll usually want After Effects to separate the inter-
laced fields. Separating fields ensures maximum image quality when you apply anima-
tions and effects to video that was originally interlaced. If you’re producing a movie for 
videotape, you can render the composition to fields in a process known as 

 

field-rendering

 

. 
See “Interlaced and noninterlaced footage” on page 40 and “Field rendering” on page 44.

 

Setting time-display options

 

After Effects supports several methods of measuring and displaying time. The method you 
choose applies to time display in the current project and in any subsequent project you 
create. Changing the method does not alter the frame rate of footage or a composition—
it changes only how frames are numbered. You can choose from three time-display 
options:

 

•

 

Timecode, which counts frames in frames per second (hours, minutes, seconds, frames).

 

•

 

Frames, which counts frames of footage without reference to time.

 

•

 

Feet and Frames, which counts feet of 16mm or 35mm motion-picture film, and counts 
fractions of feet in frames; 35mm film has 16 frames per foot, and 16mm film has 40 
frames per foot.

 

A.

 

 Timecode

 

B.

 

 Frames

 

C.

 

 Feet and Frames

A B C
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When working with footage digitized from NTSC video, you usually use the 30-fps, drop-
frame timecode base. This counts NTSC-created frames using standard drop-frame 
timecode for maximum device compatibility. For frames (or feet and frames) timecode, 
you can also change the starting frame number to match the time-counting method of 
another editing system you may be using.

 

To change the time display:

1

 

Open the project and choose File > Project Settings.

 

2

 

Select a time setting:

 

•

 

To use timecode, click Timecode Base, and then select a frame rate from the Timecode 
pop-up menu.

 

•

 

To use drop-frame time code for footage and compositions with a frame rate of 29.97 
fps, click Timecode Base, and then select 30 fps from the Timecode Base pop-up menu 
and Drop Frame from the NTSC menu.

 

•

 

To use non-drop-frame timecode for footage and compositions with a frame rate of 
29.97 fps, click Timecode Base and then select 30 fps from the Timecode Base pop-up 
menu and Non-Drop Frame from the NTSC menu.

 

•

 

To use frames for the display style, click Frames.

 

•

 

To use feet and frames for the display style, click Feet + Frames, and then choose a film 
type from the Feet + Frames pop-up menu.

 

3

 

If desired, type a value in the Start Numbering Frames At option. This value applies only 
when you have chosen Frames or Feet + Frames.

 

4

 

Click OK.

To instantly cycle through Timecode, Frames, and Feet + Frames, Ctrl+click (Windows) 
or Command+click (Mac OS) the timecode display at the bottom of the Composition 

window or at the top of the Timeline window.

 

Setting up a project

 

After you create a new project, you import footage into the project. You can also specify 
project settings or application-wide preferences. 

 

Creating a new project

 

By default, After Effects opens a new Project window when you start the application. 
When you know the media for your final project, you are ready to create a project by 
importing your footage items into a new Project window. You can also open a new Project 
window at any time from the File menu. See “Working with the Project window” on 
page 15.

 

To create a new project after closing the current project in After Effects:

 

Choose File > New > New Project.

 

Importing footage items

 

When you import a footage item, After Effects creates only a reference to the file and does 
not copy or move the file itself. These references to your source files are displayed in the 
Project window. 
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To import source footage items into an After Effects project:

1

 

Choose File > Import > File or Multiple Files.

 

2

 

Locate and select footage files and click Open.

For details, see “Importing files into a project” on page 28.

 

Opening and closing a project

 

You can have only one project open at a time. If you try to open another project, After 
Effects prompts you to save changes in the first project, and then closes the first project. 
Closing the Project window closes any associated windows, but palettes remain open. 

 

To open a project:

 

Choose File > Open Project, locate the project, and then click Open.

 

To close a project:

 

Click the Project window title bar to make it active and choose File > Close.

 

Saving a project

 

Save your work frequently as you develop a project. 

 

To save a project:

 

Choose File > Save.

 

To save a project using a different name or location:

 

Choose File > Save As. Specify a filename and location and click Save. 

The project currently open takes the new name and location; the original file remains as it 
was.

 

To save a copy of the project using a different name or location:

 

Choose File > Save a Copy. Specify a filename and location and click Save.

The project currently open retains its original name and location, and a copy is created but 
not opened.

 

Correcting mistakes

 

If you change your mind or make a mistake, undo your work. You can undo only those 
actions that alter the project; for example, you can undo an edit, but you cannot undo 
scrolling a window. Specify the number of levels that can be undone. The default is 20. 
Specifying more levels increases memory requirements but may not affect performance.

 

Note:

 

 The Vector Paint effect (PB only) can perform only one level of undo, regardless of 
the number of levels you set.

 

You can also discard changes by reverting to the last saved version of the project. Note 
that when you revert to the last saved version, all editing and footage imported since you 
last saved are lost. You cannot undo this action.
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To undo the most recent change:

 

Choose Edit > Undo. You can sequentially undo as many as 99 of the most recent changes 
made to the program in any After Effects window, depending on how many undo levels 
are set in Preferences.

 

To set the number of undo levels:

1

 

Choose Edit > Preferences > General.

 

2

 

Specify a number for Levels of Undo, and then click OK.

 

To revert to the last saved version:

 

Choose File > Revert.

 

Selecting 16-bpc color depth (PB only)

 

After Effects can work in 16-bit-per-channel mode, making a larger range of colors 
available. When you work with high-resolution images that use a narrow range of colors, 
such as when you’re creating subtle gradients for film effects or HDTV output, transitions 
between colors are smoother with less visible banding, and more detail is preserved.

You can choose whether to work in 8-bit-per-channel or 16-bit-per-channel color mode 
for each project. Directly import 16-bit images, including those from Photoshop, and 
composite and color-correct footage in 16-bit mode. Take advantage of 16-bit color when 
performing most After Effects tasks, including layer adjustment, frame blending, 3D, and 
Cineon file import. The Info palette displays 16-bit color values with exact precision. 

Many effects support 16 bits per channel. If an effect supports only 8 bits, and your project 
is set to 16 bits, After Effects displays a warning icon ( ) next to the effect name in the 
Effect Controls palette. Using an 8-bit effect in a 16-bit project will result in a loss of detail 
for the effect’s layer.

When rendering to output module depths of Trillions of Colors, set the project to 16-bit 
color depth to take advantage of the output file’s extra color precision. To optimize perfor-
mance, rough out a composition in 8-bit color mode, and then finalize and output 16-bit 
files for maximum quality.

 

To specify color depth:

1

 

Open the project and choose File > Project Settings.

 

2

 

For Depth, choose 8 bits per channel or 16 bits per channel, and then click OK.

Hold down Alt (Windows) or Option (Mac OS) and click the color depth indicator at 
the bottom of the project window to toggle between 8- and 16-bits per channel color.

 

Setting preferences

 

When you start After Effects for the first time, the default settings are used. You may want 
to change some of these default settings so that each time After Effects is opened, it uses 
your selections instead of the standard defaults. After changing settings, you can easily 
restore the default settings at any time. All After Effects default settings are stored in a 
single file. 
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After Effects saves the location and type of each open window with the project. Palette 
positions are saved in the After Effects Preferences file, which applies to all projects. You 
can also save custom workspaces; see “Customizing the workspace” on page 13.

 

To open a preferences dialog box:

1

 

Choose the preferences command you want from the Edit > Preferences submenu.

 

2

 

To switch to another dialog box, do any of the following:

 

•

 

Choose an option from the menu at the top of the dialog box.

 

•

 

Click Next to display the next dialog box in the menu list; click Previous to display the 
previous dialog box.

For information on a specific option, see the index. 

 

To restore all preferences to their default settings:

1

 

Make sure that After Effects is not running. If it is, choose File > Exit (Windows) or File > 
Quit (Mac OS). 

 

2

 

Do one of the following:

 

•

 

(Windows) Search for the “Adobe After Effects 5 Prefs” file (use quotation marks to 
narrow the search) and delete it or move it to another folder. 

 

• (Mac OS) Use the Finder to locate the “Adobe After Effects 5 Prefs” file in the Preferences 
folder in your System folder and delete it or move it to another folder.

When you start After Effects again, it creates a new preferences file. 

Customizing the workspace
Depending on the type of work you are doing, you may want to size and arrange palettes 
and windows. This arrangement of windows is called a workspace. You can save custom 
workspaces. 

To restore default palette and window positions:

Do one of the following:

• Hold down Shift when starting After Effects. 

• Choose Window > Workspace > Default.

• Choose Window > Reset Palette Locations.

To save the workspace:

1 Arrange the palettes and windows the way you want them, including size and location.

2 Choose Window > Workspace > Save Workspace.

3 Type a name for the workspace, and click OK. The new workspace is added to the 
Workspace menu.

To select or delete a custom workspace:

1 To select a workspace, choose Window > Workspace, and then choose the name of the 
workspace.

2 To delete a workspace, choose Window > Workspace > Delete Workspace, choose a 
name, and click OK.
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Using context menus
In addition to the menus at the top of your screen, context menus display commands 
relative to the active tool or selected item.

To display context menus:

1 Position the pointer over the footage or over a label in a palette or window, such as a 
button in the Time Controls palette.

2 Click the right mouse button (Windows) or press Control and hold down the mouse 
button (Mac OS).

Using windows
Many After Effects windows are organized in groups by default. You can customize and 
display these windows in certain ways depending on the type of window:

Composition window The title of a Composition window appears as a tab under the 
group window’s title bar. By default, Composition windows are grouped into one window. 
You can combine Composition windows with Layer and Footage windows.

Layer and Footage windows As with Composition windows, the title of a Layer or 
Footage window appears as a tab under the group window’s title bar. By default, Layer 
and Footage windows are grouped into one window. They can also be combined with the 
Composition windows and other Layer and Footage windows.

Timeline windows Each composition name appears as a tab in the Timeline window. You 
can combine Timeline windows only with other Timeline windows.

Effect Controls windows By default, effects you apply to layers are grouped in one Effect 
Controls window. You can combine Effect Controls tabs only with other Effect Controls 
windows.

Project window You cannot group Project windows with any other windows. 

Reorganizing windows
Use the following techniques to reorganize windows:

• To change the default from grouped windows to ungrouped windows, choose Edit > 
Preferences > General, deselect Tabbed Windows, and click OK. 

• To rearrange or separate a group window, drag the tab for a window. 

• To move a window to another group window, drag its tab to that group. 

• To group Layer or Footage windows with Composition windows by default, open a 
Layer or Footage window and choose Window > Group Tab with Comps.

• To display a window menu, click the triangle in the upper right corner of the palette or 
window (not available for all windows or palettes). 

• To resize a window, drag any edge (Windows) or drag its lower right corner (Mac OS). 

• If a window contains more grouped windows than After Effects can display at once, 
drag the slider bar that appears above the tabs.

• To open a Timeline window from its Composition window (and vice versa), select the 
tab for the window and then click the Comp Family button above the vertical scroll bar. 
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• To display a window that is obscured by other windows, select it from the Window 
menu.

• If both the Composition and Timeline windows are closed, double-click the compo-
sition’s icon in the Project window to open both windows again.

• When you close a single window in a group, you can make sure that related windows, 
such as the Timeline and Composition window for the same composition, are closed at 
the same time. To turn on this option, choose Window > Closing in Groups to select it. 
To close individual windows without closing related windows, deselect this menu 
command.

Working with the Project window
The Project window is a storage area for compositions and references to footage items. In 
the Project window you import, identify, replace, remove, and interpret footage items and 
compositions. You can organize footage and compositions in the Project window using 
folders. The folders you create in the Project window exist only in the Project window. You 
can expand a folder to reveal its contents. You can also put folders inside other folders. 

To remove footage from a project: 

Do any of the following:

• To eliminate an item from a project, select the item and press Delete.

• To remove all unused footage items from a project, choose File > Remove Unused 
Footage. 

• To remove all compositions and footage items that are not used in the selected compo-
sition, choose File > Reduce Project.

• To remove all duplicate footage items from a project, Choose File > Consolidate All 
Footage. 

To organize footage items using folders:

Do any of the following:

• To create a folder in the Project window, choose File > New > New Folder, or click the 
create folder icon ( ) at the bottom of the Project window.

• To move a file or folder into a Project folder, drag the file or folder from the Project 
window list into a folder.
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• To move a file or folder from a folder to the top level of the Project window, drag the file 
or folder to the gray information area at the top of the window.

• To show or hide the contents of a folder, click the triangle to the left of the folder icon.

To customize the Project window:

• To resize a panel, drag the bar on the right side of the panel’s heading. Drag left to make 
the panel smaller, or right to make it larger.

• To hide a panel, right-click (Windows) or Control-click (Mac OS) any panel heading and 
choose Hide This.

• To show a panel, right click (Windows) or Control-click (Mac OS) any panel heading and 
choose Panels > panel heading.

• To show or hide a panel, choose Panels > panel heading from the Project window menu.

• To disable thumbnails, choose Edit > Preferences > Display, select Disable Thumbnails 
in Project Window, and then click OK.

To create a new composition from the Project window:

Click the create new composition icon ( ) at the bottom of the Project window.

To create a new composition that automatically uses the same dimensions, duration, 
and frame-rate settings as a footage item, drag the selected item or items onto the 

create new composition icon at the bottom of the Project window. 

To manage footage items in the Project window:

Do any of the following:

• To display information about a footage item or composition, select the footage or 
composition. Information is displayed at the top of the Project window next to the 
thumbnail image.

• To sort footage items by any column, click the column name in the Project window. For 
example, click Type to sort items by footage type.

• To rename a composition or folder, select the composition name or folder, press Enter 
(Windows) or Return (Mac OS), type the new name, and then press Enter or Return 
again.

• To find footage items in the Project window, choose File > Find, type the name of the 
footage item, and click OK. Select Find Missing Footage to locate all footage items that 
refer to a file that has been moved, deleted, or renamed.

Composition, Layer, and Footage window controls
Use the Composition, Layer, and Footage windows to preview and edit different parts of a 
project. These windows share a set of controls that you can use to view safe zones (the 
visible areas of a television screen), view RGB and alpha channels, and change the magnifi-
cation. These controls function the same way in all three windows.
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Displaying After Effects viewing controls in the Footage window
By default, the Footage window displays movie controls for movie footage rather than the 
After Effects viewing controls found in the Layer and Composition windows. QuickTime 
and Video for Windows controls are fast and familiar tools for playing movie footage, and 
they play audio if it’s included in the footage. However, for the preview options discussed 
in this section, you must open the footage in a standard After Effects Footage window.

Note: A standard After Effects Footage window is always used for non–QuickTime and 
non–Video for Windows footage.

To display a footage item in the Footage window:

Double-click a footage item in the Project window.

To display .mov or .avi movies in the standard After Effects Footage window:

Press Alt (Windows) or Option (Mac OS) as you double-click a footage item in the Project 
window. After Effects Footage windows provide editing commands not available in Video 
for Windows or QuickTime Footage windows.

Changing magnification in windows
The lower left corner of a Composition, Layer, or Footage window shows the current 
magnification. When you change magnification, you change the appearance of the pixels 
in the window, not the actual resolution of the composition.

To zoom in or out:

Do one of the following:

• Using the zoom tool, click inside the window you want to magnify.

• Using the zoom tool, press Alt (Windows) or Option (Mac OS) as you click inside the 
window you want to reduce.

• Double-click the zoom tool in the toolbox to view at actual size.

• Choose a magnification from the menu in the lower left corner of a Footage, Layer, or 
Composition window. 

Viewing safe zones and grids
In Footage, Layer, or Composition windows, you can display safe zones for titles and 
action, as well as grids used for aligning layers.

Television sets enlarge a video image and allow some portion of its outer edges to be cut 
off by the edge of the screen. This is known as overscan. The amount of overscan is not 
consistent across television sets, so you should keep important parts of a video image, 
such as action or titles, within margins known as safe zones. When you arrange layers in a 
composition, do the following:

• Keep important scene elements, graphics, and actors within the action-safe zone.

• Keep titles and other text within the title-safe zone.
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After Effects also provides grids that you can use to help arrange and align layers. Set the 
grid spacing using the Grids & Guides Preferences dialog box. 

A. Grid B. Title-safe zone C. Action-safe zone D. Overscan

To view safe zones:

In a Footage, Layer, or Composition window, click the safe-zones icon ( ) to show or hide 
the safe zones.

To view a standard grid:

With a Footage, Layer, or Composition window active, choose View > Show Grid or Hide 
Grid.

To view a proportional grid:

Press and hold down Alt (Windows) or Option (Mac OS) and click the safe zones icon.

To snap a layer to a grid:

With a Footage, Layer, or Composition window active and the grid shown, choose View > 
Snap to Grid and then drag a layer until it snaps to the desired grid lines.

Changing safe-zone margins and grid spacing
You can change the percentage of window area marked as title-safe or action-safe, and 
you can change the number of grid cells. Safe-zone margins represent the percentage of 
image area not included in the safe area. You can set spacing options for standard grids or 
proportional grids. The size of proportional grids increases or decreases when the compo-
sition size changes; the size of standard grid squares remains the same regardless of 
composition size.

To change safe-zone margins:

Choose Edit > Preferences > Grids & Guides, type values for Action-Safe Margin and Title-
Safe Margin, and click OK.

To change grid spacing:

Choose Edit > Preferences > Grids & Guides, type a value for Gridline Every, type a value for 
Subdivisions, and click OK.
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To change proportional grid spacing:

Choose Edit > Preferences > Grids & Guides, type Horizontal and Vertical values for Propor-
tional Grid, and click OK.

Using rulers and guides
You can display rulers along the sides of the Composition, Layer, and Footage windows to 
provide a visual guide for positioning and editing your footage. Using the cross hair in the 
upper left corner of the rulers, you can change the origin, or zero point, in both rulers. 
Changing the zero point makes it easy to measure from a specific point in the image. By 
default, rulers are hidden. 

For added precision in positioning objects, you can create guide lines. You can also lock 
guide lines to prevent them from being repositioned. 

Note: Rulers and guide lines are only a reference in the Composition, Layer, and Footage 
windows. They do not appear in your rendered movie. 

To display or hide rulers:

Choose View > Show Rulers or Hide Rulers.

To set the zero point in rulers:

Drag the cross hair from the intersection of the two rulers (in the upper left corner) into 
the image area. 

To create, reposition, lock, hide, or remove a guide line:

Do any of the following:

• Position the pointer inside either ruler and drag where you want to create a guide line. 

• In the image area, drag a guide to reposition it. 

• To lock or unlock guides, choose View > Lock Guides.

• In the image area, drag a guide line into a ruler to remove it. 

• To display or hide all guide lines, choose View > Show Guides or Hide Guides.

• To remove all guide lines, choose View > Clear Guides.
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Viewing color and alpha channels
You can preview the red, green, blue, and alpha channels of a still image or movie in a 
Footage window, Layer window, or Composition window. When you view a color channel, 
areas with that color are displayed according to the color value of each pixel. For example, 
if you view the red channel, areas with high red values are displayed as white.

To see the color values in a color channel displayed in the channel’s own color instead 
of white, hold down Shift and click the desired color channel icon. 

When you preview the alpha channel, After Effects displays transparent and opaque areas 
as black and white to make identification easier. Degrees of opacity appear as shades of 
gray.

To view a color channel or alpha channel:

1 Open the Composition, Layer, or Footage window to view a channel for a composition, 
layer, or footage item, respectively. 

2 At the bottom of the window, click the icon that corresponds to the channel you want 
to display.

A. Red channel B. Green channel C. Blue channel D. Alpha channel

Taking and viewing a window snapshot
When you want to compare one view to another in the Composition, Layer, or Footage 
window, take a snapshot of one view and temporarily replace the window image with the 
snapshot. For example, you might want to compare two frames in different locations in a 
movie. You can instantly show and hide the snapshot to identify differences between the 
views. If you have a sound card installed, you hear a sound when you take a snapshot.

When working with snapshots, here are some tips to keep in mind:

• Snapshots taken in one kind of window can be displayed in another kind. For example, 
you can take a snapshot of a Layer window and display the snapshot in the Compo-
sition or Footage window. 

• Displaying a snapshot does not replace the content of the window.

• If the snapshot has a different size or aspect ratio than the window in which you display 
it, the snapshot is resized to fit the window. 

• Choose Edit > Purge > Snapshot to free up memory used by your snapshots.

• Snapshots are for reference only and do not become part of the layer, composition, or 
rendered movie. 

To take a snapshot:

Click the take-snapshot icon at the bottom of the window, or press Shift+F5.

To view a snapshot:

Click and hold the display-snapshot icon at the bottom of the window, or press F5. 
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To take and view multiple snapshots:

Do any of the following:

• Hold down Shift and press F5, F6, F7, or F8 to take separate snapshots. 

• Press and hold F5, F6, F7, or F8 to view the corresponding snapshots. 

• To purge any snapshot, hold down Ctrl+Shift (Windows) or Command+Shift (Mac OS) 
and press F5, F6, F7, or F8.

For more information on using shortcut keystrokes, see the Quick Reference Card.

Viewing a specific frame
The duration of a composition, a layer, or a footage file is represented visually by the time 
ruler. On the time ruler, the current-time marker indicates the frame you are viewing or 
editing, and the frame appears in the corresponding window. You can view a different 
frame by typing a number or by dragging the current-time marker.

In a Layer or Footage window, the time ruler appears near the bottom of the window. In a 
Composition window, the time ruler appears in the corresponding Timeline window. Keep 
in mind that the time rulers in different windows represent different durations. The time 
ruler in Layer and Footage windows represent the duration of the contents of that 
window, in contrast to the time ruler in the Timeline window, which represents the 
duration of the entire composition.

Current-time marker in the Timeline window (left) and in the Layer window (right) 

Like the Timeline window, Layer and Footage windows include viewing-area markers that 
you can use to magnify or shrink the part of the time ruler displayed.

To view a specific frame by dragging:

In the time ruler, drag the current-time marker to a new point in time.

To view a specific frame numerically:

1 Choose View > Go to Time, or click the current-time display in a Footage, Layer, Compo-
sition, or Timeline window.
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2 Type a new time and click OK.

To step forward or back a specified number of frames from the Go to Time dialog box, 
type + or +- in front of the number, such as +5 or +-5. (If you simply type - in front of 

the number, After Effects jumps to a negative time.)

Discontinuing window updates
Press the Caps Lock key to prevent After Effects from updating Footage, Layer, or Compo-
sition windows. This is useful for a Layer or Composition window that takes a long time to 
update. When Caps Lock is active, all open Footage, Layer, or Composition windows 
display the last update you made before pressing Caps Lock, regardless of the changes 
you make. As soon as you make a change that would appear in a window, After Effects 
adds a red outline to any affected windows, and the windows are not updated. After 
Effects continues to update window controls such as motion paths, anchor points, and 
mask outlines as you move them. To resume window updates and display all changes 
made while Caps Lock was active, press Caps Lock again to deactivate it.

Viewing tool tips
You can turn on or off tool tips that provide descriptions when you hold the mouse 
pointer over tools and buttons.

To turn on or off tool tips:

1 Choose Edit > Preferences > General.

2 Select Show Tool Tips to turn on tool tips, and then click OK.

Toolbox
Use the tools in the toolbox to select, edit, and view layers. You can edit layer properties, 
masks, and motion paths graphically, and you can change the view of a Footage, Layer, or 
Composition window. The small triangle to the right of a tool indicates that additional 
tools are available. Procedures for using these tools are included throughout this book. 
See the tool name in the index.

To select a tool:

Do one of the following:
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• If the tool is visible, click its icon. To view a tool tip, hold the mouse pointer over a tool.

A. Selection B. Pen C. Add Point D. Delete Point E. Convert Point  
F. Orbit Camera G. Track XY Camera H. Track Z Camera I. Hand  
J. Rotation K. Rectangle Mask L. Oval Mask M. Pan Behind N. Zoom  
O. Local Axis Mode P. World Axis Mode Q. View Axis Mode

• If the tool is not visible, position the pointer on the appropriate tool and drag to 
highlight the tool you want.

To select a tool quickly, press its shortcut key on the keyboard. These keys are listed on 
the After Effects Quick Reference Card.

Info palette
The Info palette describes the area under the mouse pointer as you drag across a footage 
frame in the Composition, Layer, or Footage window. This palette displays values for the 
pixel color (R,G,B), alpha channel (A), and coordinates of the current position. When you 
modify a layer property graphically, the bottom portion of this palette displays precise 
values that relate to the layer instead of the pointer. For example, when you drag a layer, 
the Info palette displays the coordinates of the layer’s center point and the offset from its 
last position. This makes it easy to move a layer by a specific number of pixels in either axis. 
During other operations, the Info palette provides context-sensitive information, such as 
the progress of rendering a window preview.

The X coordinate represents position in the horizontal axis, and the Y coordinate repre-
sents position in the vertical axis. Values for these coordinates are in pixels. The X and Y 
coordinates are relative to the origin (0,0), which is fixed at the upper left corner of the 
image area. The upper right portion of the Info palette displays the X and Y coordinates of 
the pointer. As you drag a layer, the lower portion of the Info palette displays the X and Y 
coordinates of the layer’s anchor point. The lower portion of the Info palette also displays 
Z coordinates if the layer includes 3D animation.

If the zero point differs from the origin, X' and Y' coordinates appear in the Info palette 
below the X and Y coordinates. These values measure the distance from the zero point or 
the ruler.

Note: The origin of the image area is different than the origin, or zero point, of the rulers. 
You can set the ruler’s zero point to match the origin of the image area, but you cannot 
change the origin of the image area. 
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To change the Info palette RGBA display:

Choose an option such as Percent or Web from the Info palette menu. Selecting Auto 
Color Display automatically switches between 8 bits per channel and 16 bits per channel 
depending on the project’s color depth. Clicking anywhere on the palette cycles through 
the display options.
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Preparing and Importing Footage

How After Effects works with imported files
When you import files, After Effects does not copy the footage item itself into your project 
but creates a reference link in the Project window to the footage item. This saves disk 
space. 

If you delete, rename, or move an imported source file, you break the reference link to that 
file. When a link is broken, the name of the source file appears in italics in the Project 
window, and the File Path column lists it as missing. If the footage item is available, you 
can reestablish the link—usually just by double-clicking the item and selecting the file 
again. See “Replacing and substituting footage” on page 52.

If you use another application to modify footage that is used in a project, the changes 
appear in After Effects the next time you open the project. See “Opening footage in its 
original application” on page 51.

When you add a footage item to an After Effects composition, you create a new layer, and 
the footage item becomes the source for the new layer. You can replace the source without 
affecting any edits you make to the layer properties.

Working with file formats
You can import and export the file formats listed below into After Effects 5.0. For more 
information and an extensive list of QuickTime-supported formats, see the Apple Web site. 
You can also check the Adobe Web site for updates. Supported formats include:

File formats supported by After Effects: QuickTime, Direct Show (Windows only), AVI 
(Windows only), WAV (Windows only), Adobe Photoshop, JPEG, SGI, Softimage PIC, Targa, 
TIFF, PICT, Cineon, RLA, Electric Image, Filmstrip, FLC/FLI, EPS (import only), Adobe Illus-
trator (import only), Adobe Premiere (import only), GIF89a (export only), SWF (export 
only), PDF (import only). 

File formats supported using Adobe Photoshop plug-ins: Amiga IFF, BMP, PCX, Pixar, PNG, 
GIF (import only). 

Notable audio formats supported by QuickTime: AIFF, AU, WAV (Mac OS only), Mac Sound 
(Mac OS only). For a complete listing, see your QuickTime documentation.

Preparing a still-image file for import into After Effects
Before you import a still image into After Effects, prepare the file as completely as possible. 
It is usually easier and faster to prepare a file in its original application; this also reduces 
rendering time in After Effects. Consider doing the following before you import still-image 
files into After Effects:

• Set the pixel dimensions to the resolution you will use in After Effects. If you plan to 
scale the image over time, set image dimensions that provide enough detail at the 



Using Help | Contents | Index Back 26  

Adobe After Effects Help Preparing and Importing Footage 

Using Help | Contents | Index Back 26  

largest size the image has in the project. The maximum resolution you can use in After 
Effects is 30,000 x 30,000 pixels. For D1 or DV, see “Using square-pixel footage for 
output to D1 or DV NTSC” on page 48. 

• Specify an even-numbered resolution for files imported into compositions that also use 
even-numbered resolution, and odd numbers for compositions using odd-numbered 
resolution. See the Adobe Web site for technical papers with more information.

• Crop the parts of the image that you do not want to be visible in After Effects.

• Correct the contrast and color balance for broadcast video, if necessary.

• Create an alpha channel if you want to designate areas as transparent.

• If final output will be broadcast video, avoid using thin lines (such as 1-pixel lines) for 
images or text because they may appear to flicker. If you must use thin lines, add a 
slight blur so the line or text displays on both video fields instead of flickering between 
them. 

• Save the file using the correct naming convention. For example, if you plan to import 
the file to After Effects on a Windows system, save the file using a three-character 
extension. If you plan to import the file to a Mac OS, use a name of 31 characters or 
fewer.

• Make sure that the file format is supported on the operating system you plan to use.

For information on preparing and importing interlaced motion video to After Effects, see 
“Preparing motion footage for import” on page 39.

Working with higher image resolutions
After Effects supports a maximum image resolution of 30,000 x 30,000 pixels for importing 
and rendering files. Resolution refers to the dimensions (width and height) of an image 
measured in pixels. When you work with higher resolutions, you can use a wider variety of 
formats, such as IMAX frames (4096 x 3002 pixels), full-aperture/silent frames (4096 x 3112 
pixels), and other large-format media.

When working with high-resolution images, consider the following:

• All input and output modules in After Effects support increased resolutions except PICT 
(4,000 x 4,000 pixels), BMP (16,000 x 30,000 pixels), and PXR (30,000 x 16,000 pixels).

• The maximum resolution you can import or export is limited by the amount of physical 
RAM available to After Effects. When working with large frame sizes, minimize the 
RAM used by the system or other software running on your computer, but be sure to 
leave at least 4 MB unused to handle system software requirements for additional RAM. 

• The following formula helps you determine the amount of RAM you need based on the 
footage: Image Width in Pixels x Image Height in Pixels x 4 Bytes of Memory for 32 bits-
per-pixel (bpp) or 8 Bytes of Memory for 64 bpp. For example, a 30,000-x-30,000-pixel 
image requires 3.5 GB of RAM to import and display each frame. However, a 30,000-x-
486-pixel image requires only 60 MB of RAM. Memory requirements for 16 bits-per-
channel (bpc) project color depth are approximately double those for 8 bpc.
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Changing the default duration of still images
When you add a still image to a composition, its default duration is the duration of the 
composition. You can manually trim the duration of a still image and change the default 
duration of still footage in the Import Preferences dialog box. See “Understanding 
trimming” on page 81.

To change the default duration of still footage:

1 Choose Edit > Preferences > Import.

2 Under Still Footage, do one of the following, and then click OK:

• Select Length of Composition: sets the same duration for the still image as the compo-
sition into which it is placed.

• Type numbers in the text box for the duration you want to use.

Specifying interpretation rules
The Interpretation Rules.txt file describes how After Effects interprets field order, alpha 
channel, frame rate, and pixel aspect ratio when importing footage. You can customize 
this file in any text editor and add or delete entries, to save time. When you import, After 
Effects reads the file and follows any applicable rules, as long as Interpretation Rules.txt is 
stored in the same folder as the After Effects application. You can always override these 
interpretations after importing. For more information, see “Using interpretation rules” on 
page 27.

Using interpretation rules
You can automate how After Effects interprets different types of imported footage. For 
example, each time you import a clip with unlabeled fields, you must specify the field 
separation order. When you import dozens of clips, you can save time by using the Inter-
pretation Rules.txt file, which handles this for you. 

The Interpretation Rules.txt file defines how After Effects identifies and matches footage 
using parameters for frame dimensions, frame rates, file type, and codec. If it finds a match 
for the footage you’re importing, it then automatically sets the field order, frame rate, 
alpha channel interpretation, and pixel aspect ratio. 

Ordinarily, the After Effects Interpretation Rules.txt file is stored in the same location as the 
application. You can modify this file to produce the custom rules file you need. Editing this 
file is straightforward if you follow the samples listed in the file. However, the more 
experience you have with scripting or related tasks, the more comfortable you’ll feel 
editing this file. You might make a backup copy of the file before changing the original as a 
precaution.

When you edit the Interpretation Rules.txt file, you must supply a four-character file-type 
code for each footage type or codec. If you don’t know the file-type code for a file or codec 
in a project, press Alt (Windows) or Option (Mac OS) as you select the file in the Project 
window. The file’s file-type code and codec code (if compressed) appear in the last line of 
the file description at the top of the Project window.

Note: Any changes to the Interpretation Rules.txt file take effect the next time you open 
After Effects. If After Effects is already open when you edit the rules, you must exit and 
reopen the application to activate the new rules.
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Importing files into a project
With After Effects 5.0, you use the same Import File dialog box to import any usable file 
into After Effects. To save time and minimize the size and complexity of a project, import a 
footage item once and then use it multiple times in a composition. It is occasionally useful, 
however, to import a footage item more than once, such as when you want to use it at two 
different frame rates.

After Effects supports 24- and 32-bit files using 8 bits per channel (bpc)—including alpha 
channel—and the RGB, Grayscale, and Black-and-White color modes. For information on 
supported formats, see “Working with file formats” on page 25.  

Note: The After Effects Production Bundle provides support for 16 bpc.

To import footage into a Project window:

1 Open a project or choose File > New > New Project.

2 With the Project window active, choose File > Import > File. 

3 In the Files of Type pop-up menu, choose the setting you want to use:

• All Acceptable Files (the default selection). Shows files that After Effects recognizes as 
supported formats.

• All Footage. Shows only supported footage files. Project files are not shown.

• All Files (*.*). Shows all files, whether or not After Effects recognizes them as supported 
formats. (This is useful for compatible files transferred from another platform, such as a 
Silicon Graphics workstation.) This option requires you to identify the format.

• A specific format. Restricts the files shown to the format you choose from the menu. (Use 
this option as a convenience when the files you want are in large folders containing files 
of mixed types.)

4 Do one of the following:

• To import a file, locate and select it, and then click Open. 

• To import multiple files from the same location, hold down Ctrl (Windows) or Shift 
(Mac OS), select the items you want, and then click Open. 

• To import all the files in a folder, locate and select the folder, and then click the Import 
Folder button.

The imported footage appears in the Project window. For more information about 
importing folder contents, see “Importing a sequence of still-image files” on page 29.

Note: If the Interpret Footage dialog box appears instead, the imported footage item 
contains an unlabeled alpha channel, and you’ll need to select a type or click Guess to let 
After Effects determine the type. See “Interpreting alpha channels as straight or premulti-
plied” on page 31.

To search for a file in Mac OS, click Find, type the name of a file or folder, and click OK. 
After Effects finds the first file or folder that matches the text.

To import items by dragging:

From the desktop or a folder, select one or more items you want to import and drag them 
to the After Effects application icon (on the Windows Explorer or Macintosh Finder) or to 
the Project window (in After Effects).
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If you import a folder by dragging it from the desktop, the contents of that folder are 
imported as a sequence. To import the contents as individual footage files, press Alt 
(Windows) or Option (Mac OS) as you drag. (This is the equivalent of clicking the Import 
Folder button in step 4 of the previous procedure, “To import footage into a Project 
window.”) If you always want the layered footage that you drag into After Effects to be 
imported as a composition, you can specify this in your Import Preferences.

To set default preference for dragging layered footage:

1 Choose Edit > Preferences > Import.

2 In the Default Drag Import As pop-up menu, choose Comp.

For more information about importing sequences, see “Importing a sequence of still-
image files” on page 29.

Importing a sequence of still-image files
After Effects can import a sequence of still images with the same numeric or alphabetic 
filename pattern and automatically combine them into a single sequence file. In sequence 
files, each original file represents one frame. After Effects uses the dimensions and bit 
depth of the first image in the sequence. It then imports (in numeric or alphabetic order) 
all still images in the folder that have the same filename pattern and file type as 
the one you selected.

A sequence of still-image files (left) becomes one image sequence when imported into After Effects 
(right).

To import a sequence of still images:

1 Move all the files in the sequence to the same folder.

2 In After Effects, choose File > Import > File.

3 Locate and select any file in the sequence. 

4 Select the file format name Sequence option.

5 If you want to import alphabetically, select Force Alphabetical Order. Then click Open.

Note: You can import a subset of a numbered sequence by using a variation of this 
procedure. In step 3, select the first file you want to include, hold down Shift, and select the 
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last file you want to include. In this case, only the two files you selected appear highlighted 
in the Import File dialog box, but all files that fall between those two in the sequence will 
also be imported. 

To import a folder of still images as a sequence by dragging:

1 Drag the folder from the desktop to the After Effects Project window. 

After Effects imports the first sequence that is listed in the folder, based on the filename.

You can also import an existing sequence as individual footage files. There are two ways to 
accomplish this.

To import a sequence as individual footage files:

Do either of the following:

• Choose File > Import > File to open the Import File dialog box, locate and select the 
folder, and then click the Import Folder button.

• On the desktop, hold down Alt (Windows) or Option (Mac OS) and drag the folder into 
either the After Effects icon on the desktop or into the Project window.

When you import a sequence of still images, they assume the frame rate specified in the 
Preferences. The default rate is 30 frames per second (fps). You can change the frame rate 
for the sequence either before or after importing. 

To change the default frame rate for a sequence before importing:

1 Choose Edit > Preferences > Import.

2 Under Sequence Footage, type a new default frame rate, and then click OK.

To assign a frame rate to a sequence you’ve already imported:

1 In the Project window, select the sequence of still images.

2 Choose File > Interpret Footage > Main.

3 Select Assume This Frame Rate and type the frame rate you want.

Importing footage containing an alpha channel
The color information in a typical footage item is contained in three channels: red, green, 
and blue. In addition, a footage item can include a fourth channel, called an alpha channel, 
that contains transparency information for the parts of the image that are partially or 
completely transparent. An alpha channel is often used as a matte for creating effects. 
When used in After Effects, a matte defines the transparent areas for its own or another 
layer. White areas define what is opaque, and black areas define what is transparent. See 
“Using a footage item with an alpha channel” on page 149.

Many file formats can include an alpha channel, including Adobe Photoshop, 
ElectricImage IMAGE, TGA, TIFF, EPS, PDF, QuickTime (saved at a bit depth of Millions of 
Colors+), and Adobe Illustrator. For Adobe Illustrator EPS and PDF files, After Effects 
automatically converts empty areas to an alpha channel.
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Using straight or premultiplied alpha channels
Footage files with alpha channels fall into two categories: straight and premultiplied. 
Although the alpha channels are the same, the color channels differ.

With a straight alpha channel, a footage item keeps the transparency information in a 
separate channel (the alpha channel only), not in any of the visible color channels. This 
kind of alpha channel is also known as unmatted alpha. With a straight alpha channel, the 
effects of transparency are not visible until the image is displayed in an application that 
supports straight alpha.

With a premultiplied alpha channel, a footage item keeps the transparency information in 
the alpha channel and also keeps the same information in the visible RGB channels, which 
are modified, or multiplied, with a background color. A premultiplied alpha channel is 
known as matted alpha with a background color. The colors of semitransparent areas, such 
as feathered edges, are shifted toward the background color in proportion to their degree 
of transparency.

Some software lets you specify the background color with which the alpha channel is 
premultiplied; otherwise, the background color is usually black or white.

Straight alpha channels can produce better results when used in movies that require the 
highest level of color precision. Premultiplied alpha channels are compatible with a wider 
range of programs, such as Apple QuickTime Player. After Effects recognizes both types, so 
for most projects, either type will produce satisfactory results.

Interpreting alpha channels as straight or premultiplied
When you import a footage file containing an alpha channel, After Effects determines if 
it is straight or premultiplied. If the alpha channel is unlabeled, After Effects displays the 
Interpret Footage dialog box and prompts you to select Ignore Alpha, Straight 
(Unmatted), Premultiplied (Matted with Black), Premultiplied (Matted with White), or 
Guess. When you select Guess, After Effects determines the interpretation method. For 
information on straight and premultiplied alpha channels, see “Using straight or premulti-
plied alpha channels” on page 31. For information on interpretation methods, see 
“Choosing an interpretation method for alpha channels” on page 31. 

Correctly identifying the type of alpha channel when you import a file can prevent 
problems, such as undesirable colors at the edge of an image or a loss of image quality at 
the edges of the alpha channel. If a color inaccuracy, such as a halo, appears along the 
edges of an alpha channel in a composition, try changing the interpretation method. 

If a footage item doesn’t have an alpha channel or transparency information, you can 
create an alpha channel in After Effects using a layer mask. See “Working with masks” on 
page 149.

Choosing an interpretation method for alpha channels
You can change the interpretation method for a file after you import the file. You can also 
change the default alpha channel interpretation in the Import Preferences dialog box, in 
the Interpret Unlabeled Alpha As pop-up menu. This is especially useful for importing 
footage from an application that consistently uses one type of unlabeled alpha channel.

The interpretation methods include:

Ask User Displays a dialog box containing interpretation options each time you import 
an unlabeled alpha channel. 
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Guess Attempts to determine the type of alpha channel used in the image. If After Effects 
cannot guess confidently, it beeps.

Ignore Disregards all transparency data in the file.

Straight (Unmatted) Interprets the alpha channel as straight alpha. If the application you 
used to create the footage does not premultiply the alpha channel, select this option.

Premultiplied (Matted with Black) Interprets the alpha channel as premultiplied with 
black. 

Premultiplied (Matted with White) Interprets the alpha channel as premultiplied with 
white. 

To import a footage file containing an alpha channel:

1 Choose File > Import > File. Locate and select the file and click Open.

2 In the Interpret Footage dialog box, select an option for alpha channel type. If you 
select Treat As Premultiplied (Matted with Color), you can click the eyedropper and select 
a color.

3 Click OK.

To set the alpha channel interpretation method for a file:

1 In the Project window, select a footage item that includes an alpha channel.

2 Choose File > Interpret Footage > Main.

3 In the Alpha section, select an interpretation method.

4 Select Inverted to switch the opaque and transparent areas of the image, and click OK.

To set the default alpha channel interpretation:

1 Choose Edit > Preferences > Import.

2 For Interpret Unlabeled Alpha As, select the interpretation methods you want used by 
default, and click OK. 

Importing Adobe Photoshop files
You can import an Adobe Photoshop file directly into an After Effects project with the 
option of preserving individual layers, layer masks, and so forth from Adobe Photoshop. 
Importing layers makes it easy to prepare still images for animation using the image-
editing tools in Adobe Photoshop.

Preparing layered Adobe Photoshop files
Importing layers into After Effects makes it possible to prearrange a composition in Adobe 
Photoshop using layers, and preserve those layers in After Effects so that they are ready for 
animation. Preserving layers is also useful if you want to use a single Adobe Photoshop file 
as a source for both print and dynamic media.

Before you import a layered Adobe Photoshop file, prepare it thoroughly to reduce 
preview and rendering time. Avoid problems importing and updating Adobe Photoshop 
layers by naming them properly. Before you import them into After Effects, do the 
following:
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• Organize and name layers. If you change a layer name or delete a layer in an Adobe 
Photoshop file after you have imported it into After Effects, After Effects is unable to 
find the original layer name, and the Project window lists that layer as Missing.

• Make sure that each layer has a unique name, because After Effects manages layers by 
their names. Duplicate layer names can cause problems when you update footage.

• If you want to import a composited version of a layered Photoshop file along with a 
layered version, select the Include Composited Image With Layered Files option in the 
Photoshop Saving Files Preferences dialog box.

Importing layered Photoshop files
After Effects imports attributes that were applied in Adobe Photoshop, including position, 
transfer modes, opacity, visibility, transparency (alpha channel), layer masks, adjustment 
layers, common layer effects, layer clipping-paths, vector masks, and clipping groups. 

You can import a multilayered Adobe Photoshop file in the following ways:

• As a new composition, with each layer in the Adobe Photoshop file becoming a 
separate layer in the composition

• As a single still footage item imported from any one layer in the Adobe Photoshop file

• As a single still footage item imported from all the Adobe Photoshop layers merged 
together

When you import a layered Adobe Photoshop file as a composition, all the layers 
contained in the composition retain their original positions as set in Adobe Photoshop. 
You can open the composition in After Effects and animate the layers.

To import a layered Adobe Photoshop file as a new composition: 

1 Choose File > Import > File.

2 In the Import File dialog box, make sure that All Acceptable Files is selected for Files of 
Type, and then locate and select the Adobe Photoshop file you want to import. 

3 Choose Composition in the Import As pop-up menu, and then click Open.

The original filename is used twice in the Project window: for the file as a composition and 
for the folder containing each Adobe Photoshop layer as a separate footage items.

To import an Adobe Photoshop file or one of its layers as a single footage item:

1 Choose File > Import > File.

2 In the Import File dialog box, make sure that All Acceptable Files is selected in the Files 
of Type box, and then locate and select the Adobe Photoshop file you want to import.

3 Choose Footage in the Import As pop-up menu, and then click Open. The Interpret 
Footage dialog box appears (unless you have set Preferences to skip this dialog box).

4 Select the layer you want to import from the file, or choose Merged Layers to import all 
layers in the file as a single layer. Then click OK.

Note: When you import one Adobe Photoshop layer as a single footage item, its name in 
the Project window consists of the layer name followed by the Adobe Photoshop filename.
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Using transparent areas and layer masks from Adobe Photoshop 
Adobe Photoshop supports a transparent area and one optional layer mask (alpha 
channel) for each layer in a file. You can use these layer masks to specify how different 
areas within a layer are hidden or revealed. When you import one layer of an Adobe 
Photoshop file, After Effects combines the layer mask (if present) with the transparent area 
and imports it as a straight alpha channel.

If you import a layered Adobe Photoshop file as a merged file, After Effects merges the 
transparent areas and layer masks of all the layers into one alpha channel that is premulti-
plied with white. See “Importing layered Photoshop files” on page 33.

If a layered Adobe Photoshop file contains clipping groups, After Effects imports each 
clipping group as a composition nested within the main composition. After Effects 
automatically applies its Preserve Underlying Transparency option to each layer in the 
clipping-group composition, to maintain transparency settings. 

When you import a Adobe Photoshop file as a composition, any clipping paths in the 
imported layers are converted to After Effects masks. You can then modify and animate 
these masks within After Effects.

After Effects also supports any blending modes applied to the file. For more information 
on the Preserve Underlying Transparency option, see “Preserving underlying transparency 
during compositing” on page 165.

Using adjustment layers from Adobe Photoshop 
Adjustment layers in Adobe Photoshop versions 4.0 and later change the color and tonal 
qualities of an image without permanently modifying the original image. Adobe 
Photoshop adjustment layers affect the appearance of all layers below them. When you 
import an Adobe Photoshop file containing one or more adjustment layers, After Effects 
directly converts the Adobe Photoshop adjustment layers to After Effects adjustment 
layers. Turn off the Adjustment Layer switch in After Effects to remove the effect and 
display the layer as a white solid. To remove the effect and the white solid, either delete 
the adjustment layer or turn off the Video switch for the layer. See “Creating an adjustment 
layer” on page 73 and “About After Effects Audio/Video switches” on page 86.

Using Adobe Photoshop layer effects (styles) 
In Adobe Photoshop 5.0 and later, you can use a layer effect (or style) to modify the layer 
to which it is applied. When you import an Adobe Photoshop file as a composition, and 
one or more of the layers contain layer effects, then After Effects includes the effects and 
the layer as two or more separate layers in the Timeline window. 

Note: Only some Adobe Photoshop styles (effects) can be imported into After Effects. 
These include Drop Shadow, Inner Shadow, Outer Glow, Inner Glow, Bevel and Emboss, 
and Color Fill. 

You can edit or remove a layer effect by using either the Timeline window or the Effect 
Controls window. You can also animate these Adobe Photoshop layer effects over time. 

To edit an Adobe Photoshop layer effect in After Effects:

1 Open the composition containing the layer effect.

2 In the Timeline window, select the layer containing the effect and press E to display the 
effect properties.
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3 Click the underlined value you want to change and type a new value.

A single Adobe Photoshop layer effect can become up to five layers and effects in After 
Effects. You may need to edit multiple copies to achieve the desired result.

Importing an Adobe Illustrator, PDF, or EPS file
You can import Adobe Illustrator, many PDF, and EPS files directly into After Effects. When 
you import an Adobe Illustrator file, After Effects converts all text information to paths, 
eliminating the need to create outlines in Adobe Illustrator before importing. If you import 
a file without creating outlines, make sure that all fonts used in the file are available to 
After Effects when you import.

When you import an Adobe Illustrator file, After Effects automatically makes all empty 
areas transparent by converting them into an alpha channel. 

After Effects can import Adobe Illustrator CMYK files. However, to maintain accurate 
color, convert your CMYK images to RGB images in Adobe Illustrator. When you import 

Adobe Illustrator CMYK images, After Effects remaps the CMYK colors to RGB, and may 
subtly shift colors. 

Continuously rasterizing an Adobe Illustrator file
You can continuously rasterize an Illustrator file at any time while designing your project. 
Whether you choose to continuously rasterize or not, if you view and render a compo-
sition using Best Quality, After Effects anti-aliases (smooths) the art. 

Adobe Illustrator file imported and rasterized in After Effects A. Original B. Enlarged with 
Continuously Rasterize switch turned off C. Enlarged with Continuously Rasterize switch turned on

To continuously rasterize an Adobe Illustrator file:

1 Select the layer containing the Adobe Illustrator file in the Timeline window.

2 Click the Collapse Transformations/Continuously Rasterize switch so that the “on” 
icon ( ) appears for that layer.

Importing layers from Adobe Illustrator 5.0 and later
You can import a multilayered Adobe Illustrator file in the following ways:

• As a new composition, with each layer in the Adobe Illustrator file becoming a separate 
layer in the composition

• As a single still image imported from any one layer in the Adobe Illustrator file

• As a single still image imported from all the Adobe Illustrator layers merged together

A B C
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To import a layered Adobe Illustrator file as a layered composition:

1 Choose File > Import > File.

2 In the Import File dialog box, make sure that All Acceptable Files is selected in the Files 
of Type box; then locate and select an Adobe Illustrator file.

3 In Import File As, choose Composition, and then click Open. 

The original filename is used twice in the Project window: for the file as a composition and 
for the folder containing all the layers as separate footage items.

To import an Adobe Illustrator file or one of its layers as a single footage item:

1 Choose File > Import > File.

2 In the Import File dialog box, make sure that All Acceptable Files is selected in the Files 
of Type box; then locate and select an Adobe Illustrator file.

3 In Import File As, choose Footage, and then click Open. 

4 In the Import Adobe Illustrator dialog box, select a layer to import from the file, or 
choose Merged Layers to import all layers in the file as a single layer in After Effects. Then 
click OK. 

Importing Adobe Illustrator paths as masks
You can use an Adobe Illustrator path as a mask in an After Effects layer composition by 
copying the path in Adobe Illustrator and pasting it directly into the Layer or Composition 
window in After Effects. After Effects creates a mask for each closed path copied from 
Adobe Illustrator. For more information on using masks, see “Working with masks” on 
page 149.

Note: You can also use an copied Adobe Illustrator or Photoshop path as an After Effects 
motion path.

Shape drawn in Adobe Illustrator (left) and pasted into After Effects as a mask (right)

To import an Adobe Illustrator path as a mask:

1 In Adobe Illustrator, create your path, select all of the points along the path, and then 
choose Edit > Copy.

2 In After Effects, open the Layer window for the layer into which you want to import the 
path.

3 Choose Edit > Paste.

Note: This process works best if your Adobe Illustrator Preferences are set with AICB 
Clipboard and Preserve Paths selected.
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Importing an After Effects project
You can import one After Effects project into another. Everything from the imported 
project, including footage files, compositions, and folders, appears inside a new folder in 
the current Project window. When you want to repeat a complicated mask, effect, or 
animation in a different project, you can import the project containing the effect and 
simply replace the source footage, keeping all the effect, composition, and layer settings 
intact. 

See “Importing files into a project” on page 28 for the procedure for importing.

Importing After Effects projects from different platforms
You can open and import an After Effects project from a different operating system as 
long as you maintain the filenames, folder names, and either full paths or relative paths 
(folder locations) for all files in the project. To maintain relative paths, the source footage 
must reside on the same volume as the project file. 

If a file format is not supported on the operating system you are using, if the file is missing, 
or if the reference link is broken, After Effects substitutes a placeholder item containing 
color bars. You can reconnect the placeholder to the appropriate file. You can use the same 
process to connect a footage item in the Project window to a different source file.

To relink a reference:

1 Select the placeholder or footage file in the Project window, and choose File > Replace 
Footage > File. 

2 In the Replace Footage File dialog box, locate and select the footage file you want to 
use. 

Note: You can also open this dialog box by double-clicking the footage item.

For more information on substituting footage, see “Replacing and substituting footage” 
on page 52. 

For information about creating projects for both Windows and Mac OS, see “Consider-
ations for cross-platform projects” on page 7.

Importing Adobe Premiere projects
The ability to import Adobe Premiere projects eliminates the need to render the project 
before applying visual effects and animations in After Effects. When you import an Adobe 
Premiere 5.0 or later project, After Effects imports it into the Project window as both a new 
composition containing each Adobe Premiere clip as a layer, and as a folder containing 
each clip as an individual footage item. If your Adobe Premiere project contains bins, After 
Effects converts them to folders within the Adobe Premiere project folder. 

After Effects preserves the order of clips in the Timeline, the footage duration (including all 
trimmed In and Out points), and the marker and transition locations. The arrangement of 
layers in the Timeline window is based on the arrangement of clips in the Premiere 
Timeline. After Effects adds Adobe Premiere clips to the Timeline window as layers in the 
order they appeared—from the bottom up and from left to right—in the Premiere 
Timeline. 
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Transitions and titles included in your Adobe Premiere project appear in the After Effects 
composition as solid layers, maintaining their original location and duration. After Effects 
discards all transparency and motion settings. See “Importing files into a project” on 
page 28 for the procedure for importing. 

Import Adobe Premiere projects in the same way you import footage files: choosing File > 
Import > File, and locating the Adobe Premiere project file that you want to import.

Importing 3D-image files
After Effects can import 3D-image files saved in Softimage PIC, RLA, and Electric Image EI 
format. These 3D-image files contain red, green, blue, and alpha (RGBA) channels, as well 
as auxiliary channels with optional information, such as z depth, object IDs, texture coordi-
nates, and more. The Standard Version of After Effects reads and displays the RGBA infor-
mation. 

With RLA files, all of the auxiliary channels are included in a single file. Softimage PIC files 
have a corresponding ZPIC file that contains the z-depth channel information. Although 
you can’t import a ZPIC file, you can access the additional channel information as long as 
the ZPIC file is stored in the same folder as the imported PIC file.

Similarly, Electric Image (EI) files can now have associated EIZ files with z-depth channel 
data. Just as with ZPIC files, you cannot import EIZ files into After Effects; instead, you store 
them in the same folder as the EI files. For information about creating EIZ files, see your 
Electric Image documentation.

Importing an audio file
You can import a variety of audio file formats directly into After Effects. When you add 
audio-only files to a composition, they appear as layers in the Timeline window. You can 
adjust the audio preview settings, such as sample rate, in the General Preferences dialog 
box. These settings change the quality of audio playback when you preview the compo-
sition, not when you render it. For more information, see “Using audio layers” on page 91.

Importing Cineon files
You can import Cineon 4.5 or Digital Picture Exchange (DPX) files directly into an After 
Effects project as individual frames or as a sequence of numbered stills. Once you have 
imported a Cineon file, you can use it in a composition and then render the composition 
as a Cineon sequence. See “Importing a sequence of still-image files” on page 29.

Cineon files are commonly used to transfer motion-picture film to a digital format. To 
preserve the full dynamic range of motion-picture film, Cineon files are stored using 
logarithmic 10 bits per channel (bpc). However, After Effects internally uses linear 8-bpc 
color, (or 16-bpc, for the Production Bundle only). By default, After Effects stretches the 
attendant logarithmic values to the full range of values available. You can then use the 
Cineon Import Options dialog box or the Cineon Converter effect to control the 
conversion. (If you are working with a film sequence in which exposure conditions vary 
over time, you can vary the conversion over time by setting keyframes.) For information on 
using the Cineon converter, see “Cineon Converter” on page 190.
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To import a Cineon sequence:

1 Choose File > Import > File.

2 For the file type, select Cineon, and then select Cineon Sequence.

3 Locate and select the first numbered Cineon sequence file.

4 Select the Cineon Sequence option, and then click Open.

The Cineon file or sequence appears in the Project window.

To convert a Cineon sequence from logarithmic to linear: 

1 Select the sequence in the Project window, and choose File > Interpret Footage > Main.

2 In the Interpret Footage dialog box, click More Options. 

3 In the Cineon Conversion dialog box, select the Logarithmic Conversion option, click 
OK, and click OK again.

When you are ready to produce output from the Cineon file, it is important that you 
reverse the conversion from logarithmic to linear. 

Preparing motion footage for import
Some of the source footage you use may have been created digitally (for example, in 
Adobe Photoshop or Adobe Premiere), but other footage may need to be transferred to 
the computer from analog sources, such as film and videotape. When you work with After 
Effects, understanding some of the differences among media can help you decide how to 
handle footage as you transfer it between digital and analog devices. For more infor-
mation, see “Analog video” on page 39, “Analog film” on page 39, “Digital video” on 
page 40, and “Interlaced and noninterlaced footage” on page 40. 

Analog video
Analog video carries picture and sound information by creating variations in an electro-
magnetic signal. Before you can import analog video into After Effects, you need to 
digitize it. Digitizing converts the electromagnetic signal to a binary signal, which can be 
read by a computer. 

Analog film
Analog film, such as a still transparency or common motion-picture film, carries picture 
information by creating variations in colored dyes on a strip of acetate. 

To apply digital effects to motion-picture film using After Effects, you must first transfer 
the film to a digital format. You can transfer film in two ways: 

• Use a film scanner to transfer each analog film frame directly to a digital movie frame. 
This method best preserves the image quality. Using a film scanner is preferable, 
because you scan the footage directly to the computer as noninterlaced, full-resolution, 
24-fps footage; in other words, it is ready to use in After Effects. See “Importing Cineon 
files” on page 38.

• Transfer the analog film to analog videotape, and then digitize the videotape. This 
process is called telecine transfer. It converts 24-fps film footage to 30-fps videotape 
using 3:2 pulldown. Transferring using the 3:2 pulldown method introduces two issues: 
you must resolve the different frame rates of videotape and motion-picture film, and 
you must separate the fields of the interlaced video. After Effects can automatically 
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resolve both of these issues while preserving image quality. See “About 3:2 pulldown” 
on page 44.

Note: To use an After Effects movie in an analog motion-picture film, you must transfer the 
movie back to the analog film medium. This transfer process is generally done at a post-
production facility.

Digital video
Digital video carries picture information by representing each pixel of a video frame as a 
discrete color value, and transmitting and storing the pixel values in the binary data 
format used by computers. Sound is also carried as binary data.

Digital video is not one format, but a medium within which many file formats exist. Even if 
your source footage was created digitally, you still need to make sure that it is stored in a 
file format that After Effects can import.

If you plan to distribute the movie digitally, for example on CD-ROM, you must render it in 
a file format appropriate for your distribution method. For more information, see “Making 
(rendering) a movie” on page 278.

Note: DV video format is a form of digital video that can be downloaded directly to your 
hard disk for editing in applications such as Adobe After Effects and Adobe Premiere. Many 
DV decks can connect directly to a computer using an IEEE 1394 (FireWire™/i.Link) 
interface. See “About D1, DV, and various pixel aspect ratio footage” on page 46.

Interlaced and noninterlaced footage
Another way to classify analog or digital footage is as interlaced or noninterlaced. Currently, 
most broadcast video is interlaced; each frame consists of two fields displayed in turn. The 
computer operating system and After Effects display noninterlaced video, also known as 
progressive scan, in which each frame is displayed completely from top to bottom. When 
you finish creating a movie for display on a television, After Effects can render it back to 
fields, maintaining high quality for broadcast display.

Interlaced video consists of two fields, known either as Field 1 and Field 2, even and odd, 
or (as After Effects refers to them) upper and lower. When these fields are presented 
sequentially on an NTSC or PAL video monitor they create a smooth, unified picture. See 
“Frames and fields” on page 9.
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In interlaced video, a frame is divided into two fields. Each field contains every other 
horizontal line in the frame. A TV displays the first field of alternating lines over the entire 
screen, and then displays the second field to fill in the alternating gaps left by the first 
field. One NTSC video frame, displayed for approximately 1/30 of a second, contains two 
interlaced fields, displayed for approximately 1/60 of a second each.

Interlaced video describes a frame with two passes of alternating scan lines.

In noninterlaced video, scan lines are drawn in order from top to bottom, in one pass. 
Computer video and computer movie formats are generally noninterlaced. Motion-
picture film is similar to noninterlaced video because it also displays an entire frame in one 
pass.

Interlacing is a factor in image quality only for certain effects, such as rotating a frame or 
compositing video with digital effects. It is a characteristic of footage capture and display, 
not a structural component of file formats or media. You can easily play back a digitized 
NTSC or PAL movie (interlaced) on a computer display (noninterlaced), or display a 35mm 
photograph (noninterlaced) on an NTSC or PAL video monitor (interlaced). 

If you use interlaced video in a composition or want to use an After Effects movie in an 
interlaced-video medium such as NTSC, you must separate fields as you import and field-
render the composition to a finished movie file. For more information, see “Using inter-
laced video in After Effects” on page 43 and “Testing the field-rendering order” on 
page 302.
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Preparing a movie for import when final output is NTSC inter-
laced video
You can edit and prepare video footage in other applications, such as Adobe Premiere, 
before importing it into After Effects. If you want to render the footage from After Effects 
as NTSC interlaced video, do not field-render or create interlaced frames when you render 
the movie from the other application. It’s acceptable to render interlaced video for 
temporary files, but 60 progressive gives better quality. Make sure that you keep track of 
the original field order so you can correctly render it in After Effects. See “Field rendering” 
on page 44 and “Testing the field-rendering order” on page 302.

As long as the footage is on a computer, it should remain noninterlaced. Keeping the 
footage in noninterlaced format preserves more image quality and saves you the extra 
step of separating fields in After Effects. Once it’s ready to go to your nonlinear editor, such 
as Adobe Premiere, it should be interlaced.

When you render the movie from the other application, render it at 60 fps of frame-
rendered (noninterlaced) video. After you integrate it into a composition, After Effects can 
render it to high-quality field-rendered (interlaced) frames at 30 fps for videotape.

Preparing motion-footage frame rates for final output
When you import motion footage into After Effects, the file’s frame rate does not change. If 
you plan to output your footage to a different frame rate, you can make it conform to the 
new frame rate in After Effects. Conforming ensures that frames disperse evenly over the 
new output frame rate. 

Conforming footage does not alter the original footage, only the reference that is used by 
After Effects. When it conforms, After Effects changes the internal duration of frames but 
does not change the frame content. If the conformation is a large amount, the footage 
plays back at a different speed. For example, if you change the frame rate from 15 fps to 30 
fps, the footage plays back faster. 

It’s best to make the frame rate the same as the final output frame rate for your project. 
This way, After Effects renders each frame, and the final output does not omit or duplicate 
frames. However, in order not to drastically change the speed of your motion footage, it 
may be beneficial to conform only by a small amount, making the new frame rate divisible 
by the output rate. For example, if your original footage has a frame rate of 29.97 fps and 
you want to output it for playback on CD-ROM at 10 fps, you can conform to 30 fps. At 30 
fps, the frames are divisible by 10, so After Effects can evenly render every third frame.

Note: If you want to output original NTSC footage as PAL or vice versa, you must have 
access to hardware that supports each format. 

To change the frame rate of a motion footage file:

1 Select the footage file in the Project window.

2 Choose File > Interpret Footage > Main.

3 Select Conform to Frame Rate, and type a new frame rate in the Frames Per Second box. 
Then click OK.

Note: This procedure can change the synchronization of audio and video files. Be sure to 
check your files and make any necessary adjustments.
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Using interlaced video in After Effects
If you want to use interlaced or field-rendered footage (such as from NTSC video) in an 
After Effects project, you will get the best results if you separate the video fields when you 
import the footage. After Effects separates video fields by creating a full frame from each 
field, preserving all of the image data from the original footage. 

When importing interlaced video that was originally transferred from film, you can 
remove the 3:2 pulldown that was applied during the transfer from film to video as you 
separate fields so that effects you apply in After Effects don’t appear distorted. See 
“Removing 3:2 pulldown from video transferred from film” on page 45.

Separating fields
Separating fields is critical if you plan to make significant changes to the footage. When 
you scale, rotate, or apply effects to interlaced video, unwanted artifacts, such as crossed 
fields, are often introduced. By separating fields, After Effects accurately converts the two 
interlaced frames in the video to noninterlaced frames, while preserving the maximum 
amount of image quality. Using noninterlaced frames allows After Effects to apply edits 
and effects consistently and at the highest quality. 

After Effects creates field-separated footage from a single formerly interlaced field by 
splitting fields into two independent frames. Each new frame has only half the information 
of the original frame, so some frames may appear to have a lower resolution than others 
when viewed at Draft quality. When you render the final composition, After Effects repro-
duces high-quality interlaced frames for videotape. When you render a movie at Best 
quality, After Effects interpolates between the scan lines of a field to produce maximum 
image quality.

Note: After Effects automatically separates fields for D1 and DV video footage files. You 
can manually separate fields for all other types of video footage in the Interpret Footage 
dialog box. For more information, see “Specifying interpretation rules” on page 27.

To separate video fields in imported footage:

1 Select the footage item in the Project window.

2 Choose File > Interpret Footage > Main.

3 Select an option from the Separate Fields pop-up menu.

4 Click Motion Detect to increase image quality in nonmoving areas when the image is 
rendered at Best quality. Then click OK.

Interpreting field order
Interlaced video has a field order defining the order in which the two video fields (upper 
and lower) are displayed. A system that draws the upper lines before the lower lines is 
called upper-field first; one that draws the lower lines before the upper lines is called lower-
field first. The order in which the fields are displayed is important, especially when the 
fields contain motion. If you separate video fields using the wrong field order, motion will 
not appear smooth.



Using Help | Contents | Index Back 44  

Adobe After Effects Help Preparing and Importing Footage 

Using Help | Contents | Index Back 44  

Some programs, including After Effects and current versions of Media 100, label the field 
order when rendering interlaced video files. When you import a labeled video file, After 
Effects honors the field order label automatically. You can override the field order using 
the Interpretation Rules file. For more information about field order, see “Specifying inter-
pretation rules” on page 27.

If a file does not contain a field order label, you can match the original field order of your 
footage. If you are not sure which field order was used to interlace a footage item, use the 
procedure below to find out. 

To determine the original field order:

1 Select the item in the Project window.

2 Choose File > Interpret Footage > Main.

3 In the Interpret Footage dialog box, select Upper Field First from the Separate Fields 
pop-up menu, and then click OK.

4 In the Project window, press Alt (Windows) or Option (Mac OS) as you double-click the 
footage to open it in a Footage window.

5 If the Time Controls palette is not visible, choose Window > Show Time Controls.

6 In the Footage window, find a segment that contains one or more moving areas.

7 Using the Frame Advance button ( ) on the Time Controls palette, step forward at least 
five frames in the Footage window. Moving areas should move consistently in one 
direction. If the moving areas move backward every other frame, the wrong field-
separation option has been applied to the footage.

Note: Analog capture cards can vary. DV or footage captures from IEEE 1394 FireWire/
i.Link are always lower field first. 

Field rendering
When you render a composition containing separated footage, set the Field Rendering 
option to the same field order as your video equipment. If you don’t field-render the 
composition, or if you field-render with the incorrect settings, the final movie may appear 
too soft, jerky, or distorted. See “Testing the field-rendering order” on page 302.

About 3:2 pulldown
When you transfer 24-fps film to 29.97-fps (NTSC) video, you use a process called 3:2 
pulldown, in which the film frames are distributed across video fields in a repeating 3:2 
pattern. The first frame of film is copied to fields 1 and 2 of the first frame of video, and also 
to field 1 of the second video frame. The second frame of film is then spread across the 
next two fields of video—field 2 of the second video frame and field 1 of the third frame of 
video. This 3:2 pattern is repeated until four frames of film are spread over five frames of 
video, and is then repeated. 

The 3:2 pulldown process results in whole frames (represented by a W) and split-field 
frames (represented by an S). The three whole video frames contain two fields from the 
same film frame. The remaining two split-field frames contain a video frame from two 
different film frames. The two split-field frames are always adjacent to each other. The 
phase of 3:2 pulldown refers to the point at which the two split-field frames fall within the 
first five frames of the footage.
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Phase occurs as a result of two conversions that happen during 3:2 pulldown: 24-fps film is 
redistributed through 30-fps video, so each of four frames of 24-fps film is spread out over 
five frames of 30(29.97)-fps video. First, the film is slowed down 0.1% to match the speed 
difference between 29.97 fps and 30 fps. Next, each film frame is repeated in a special 
pattern and mated to fields of video. 

When you apply 3:2 pulldown to footage, one frame of the film (A) is separated into two or three 
interlaced video fields (B), which are grouped into video frames containing two fields each.

Removing 3:2 pulldown from video transferred from film
When you transfer 24-fps film to 29.97-fps (NTSC) video, you use a process called 3:2 
pulldown, in which the film frames are distributed across video fields in a repeating 3:2 
pattern. It’s important to remove 3:2 pulldown from video footage that was originally film, 
so that effects you add in After Effects synchronize perfectly with the original frame rate of 
film. Removing 3:2 pulldown reduces the frame rate by 4/5: from 30 to 24 fps or from 29.97 
to 23.976 fps, which also reduces the number of frames you have to change. To remove 3:2 
pulldown, you must also indicate the phase of the 3:2 pulldown. For more information, see 
“About 3:2 pulldown” on page 44.  

Before you remove 3:2 pulldown, separate the fields as either upper-field first or lower-
field first. Once the fields are separated, After Effects can analyze the footage and 
determine the correct 3:2 pulldown phase and field order. If you already know the phase 
and field order, choose them. 

Note: If your footage file contains frames from different sources, the phase may not be 
consistent. If this is the case, import the footage once for each phase. Then, add the 
footage to your composition as many times as there are phases and trim each layer to use 
only the appropriate frames for each phase. 

To remove 3:2 pulldown from video transferred from film:

1 In the Project window, select the footage from which you want to remove 3:2 pulldown.

2 Choose File > Interpret Footage > Main.

3 In the Fields and Pulldown section, select Upper Field First or Lower Field First from the 
Separate Fields pop-up menu.

4 Do one of the following and click OK:
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• To have After Effects determine the correct settings, click Guess 3:2 Pulldown.

• If you know the phase of the 3:2 pulldown, choose it from the Remove Pulldown pop-
up menu.

About D1, DV, and various pixel aspect ratio footage
Pixel aspect ratio specifies the ratio of width to height of one pixel in an image. Frame 
aspect ratio describes the ratio of width to height in the frame dimensions of an image. For 
example, D1 NTSC has a pixel aspect ratio of 0.9 (or 0.9 width by 1.0 height). It also has a 
frame aspect ratio of 4:3 (or 4.0 width by 3.0 height). 

A 4:3 frame aspect ratio (left), and a wider 16:9 frame aspect ratio (right)

Some video formats output the same frame aspect ratio but use a different pixel aspect 
ratio. For example, some NTSC digitizers produce a 4:3 frame aspect ratio, with square 
pixels (1.0 pixel aspect ratio), and a resolution of 640 x 480. D1 NTSC produces the same 
4:3 frame aspect ratio but uses rectangular pixels (0.9 pixel aspect ratio) and a resolution 
of 720 x 486. D1 pixels, which are always rectangular, are vertically oriented in systems 
producing NTSC video and horizontally oriented in systems producing PAL video.

If you display rectangular pixels on a square-pixel monitor without alteration, images and 
motion appear distorted; for example, circles distort into ovals. However, when displayed 
on a broadcast monitor, the images will be correct. 

A. Square pixels and 4:3 frame aspect ratio B. Nonsquare pixels and 4:3 frame aspect ratio  
C. Nonsquare pixels displayed on a square-pixel monitor

When you import D1 NTSC or DV source footage into After Effects, the image looks slightly 
wider than it does on a D1 or DV system. (D1 PAL footage looks slightly narrower.) The 
opposite effect occurs when you import anamorphic footage using D1/DV NTSC 
Widescreen or D1/DV PAL Widescreen. Widescreen video formats have a frame aspect 
ratio of 16:9.

3

4 16

9

A B C



Using Help | Contents | Index Back 47  

Adobe After Effects Help Preparing and Importing Footage 

Using Help | Contents | Index Back 47  

If a file uses rectangular pixels, After Effects displays the pixel aspect ratio next to the file’s 
image thumbnail in the Project window. You can change the pixel aspect ratio interpre-
tation for individual files in the Interpret Footage dialog box. By ensuring that all footage 
files are interpreted correctly, you can combine footage with different ratios in the same 
project or composition and generate output that plays correctly. 

When you import footage with either the D1 resolution of 720 x 486, or the DV resolution 
of 720 x 480, After Effects automatically sets the pixel aspect ratio for that file to D1/DV 
NTSC. When you import footage with the D1 or DV resolution of 720 x 576, After Effects 
automatically sets the pixel aspect ratio for that file to D1/DV PAL. However, it is always a 
good idea to make sure that all files are interpreted correctly by looking in the Project 
window or the Interpret Footage dialog box. For information about using interpretation 
rules to automate the import process, see “Specifying interpretation rules” on page 27.

Note: Make sure to reset the pixel aspect ratio to Square Pixels when you import a square-
pixel file that happens to have a D1 or DV resolution—for example, an Adobe Photoshop 
image with a resolution of 720 x 480.

Setting pixel aspect ratio
It is important to set the pixel aspect ratio for a footage file at its original ratio, not the ratio 
of the final output. For general information about pixel aspect ratio, see “About D1, DV, 
and various pixel aspect ratio footage” on page 46.

Set pixel aspect ratios for footage and compositions with these approximate values: 

Square Pixels Uses a 1.0 pixel aspect ratio. Use this setting if your footage has a 640 x 
480 or 648 x 486 frame size.

D1/DV NTSC Uses a 0.9 pixel aspect ratio. Use this setting if your footage has a 720 x 480 
or 720 x 486 frame size, and your desired result is a 4:3 frame aspect ratio.

D1/DV NTSC Widescreen Uses a 1.2 pixel aspect ratio. Use this setting if your footage 
has a 720 x 480 or 720 x 486 frame size, and your desired result is a 16:9 frame aspect ratio.

D1/DV PAL Uses a 1.0666 pixel aspect ratio. Use this setting if your footage has a 720 x 
576 frame size, and your desired result is a 4:3 frame aspect ratio.

D1/DV PAL Widescreen Uses a 1.422 pixel aspect ratio. Use this setting if your footage 
has a 720 x 576 frame size, and your desired result is a 16:9 frame aspect ratio.

Anamorphic 2:1 Uses a 2.0 pixel aspect ratio. Use this setting if your footage was shot 
using an anamorphic film lens.

D4/D16 Standard Uses a 0.948 pixel aspect ratio. Use this setting if your footage has a 
1440 x 1024 or 2880 x 2048 frame size, and your desired result is a 4:3 frame aspect ratio.

D4/D16 Anamorphic Uses a 1.896 pixel aspect ratio. Use this setting if your footage has 
a 1440 x 1024 or 2880 x 2048 frame size, and your desired result is an 8:3 frame aspect 
ratio.

To set the pixel aspect ratio for imported footage:

1 Select the footage in the Project window.

2 Choose File > Interpret Footage > Main.

3 Select a ratio from the Pixel Aspect Ratio pop-up menu and click OK.
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If you are planning to render to the same pixel aspect ratio as your footage, you also need 
to set the pixel aspect ratio for the composition.

To set the pixel aspect ratio for a composition:

1 Open the composition.

2 Choose Composition > Composition Settings.

3 Select a ratio from the Pixel Aspect Ratio pop-up menu and click OK.

In some circumstances, you may need to work on a monitor that doesn’t match the pixel 
ratio, so that your working view doesn’t match the final output. You can correct the pixel 
aspect for previewing purposes.

To correct pixel aspect distortion (for previewing only):

With the appropriate composition open, click the arrow above the vertical scroll bar in the 
Composition window and choose Pixel Aspect Correction.

Using square-pixel footage for output to D1 or DV NTSC
You can use square-pixel footage in a D1/DV NTSC composition and generate output that 
does not appear distorted. Note that the pixel aspect ratio is identical between D1 and DV, 
but there is a slight difference in composition frame size. The steps that follow contain 
information about issues discussed elsewhere in this guide. 

To use square-pixel footage when outputting to D1 or DV NTSC:

1 Prepare square-pixel footage that fills the entire frame using one of the following 
methods:

• If your final output is DV, create and save it at a 720 x 534 frame size. 

• If your final output is D1, create and save it at a 720 x 540 frame size.

2 Import the file into After Effects. 

Note: If your square-pixel footage was created and saved at 720 x 486 or 720 x 480, select 
it and choose File > Interpret Footage > Main. Then choose Square Pixels from the Pixel 
Aspect Ratio pop-up menu and click OK.

3 Choose Composition > New Composition, and then select one of the following:

• If your final output is DV, choose NTSC DV, 720 x 480 for Frame Size, and D1/DV NTSC for 
Pixel Aspect Ratio. 

• If your final output is D1, choose NTSC D1, 720 x 486 for Frame Size, and D1/DV NTSC for 
Pixel Aspect Ratio.

4 Select your other Composition settings as desired, and then click OK. 

5 Add your footage to the new composition.

Note: If your footage was created and saved at a frame size other than those noted in step 
1, skip step 6.

6 Select the layer containing the square-pixel footage and apply the Shrink to Fit 
command: press Ctrl+Alt+F (Windows) or Command+Option+F (Mac OS). 
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Importing DDR-based footage
To find out if After Effects plug-ins are available for your digital disk recorder (DDR), 
contact your DDR manufacturer. 

You can bring DDR-based footage into an After Effects project in two ways. First, you can 
work with the footage while it remains on the DDR, essentially treating the DDR as a 
remote hard disk. You can also transfer the footage to your hard disk and import it into an 
After Effects project as you would any other file.

For information on using your specific DDR with After Effects, refer to your DDR manufac-
turer’s plug-in documentation. 

Setting up frames and fields for DDR-based footage
When working with DDR-based footage in After Effects, make sure that your Composition 
Settings, Render Settings, and the Interpret Footage dialog boxes for the footage files are 
all set to the fps used by your DDR. If the frame rate in the Interpret Footage dialog box is 
29.97 and the Composition Settings frame rate is 30 fps, the footage will appear with 
duplicate frames. 

It is also important to separate fields when importing DDR-based footage. Make sure that 
the field settings in the Interpret Footage and Render Settings dialog boxes are the same; 
otherwise, the footage will preview and render with the wrong field order, causing the 
footage to play back with a jerky appearance. See “Using interlaced video in After Effects” 
on page 43.

For information on using your specific DDR with After Effects, refer to your DDR manufac-
turer’s plug-in documentation. 
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Building a Composition

Working with imported footage
After you have imported footage, you can view, edit, and change settings for your 
imported footage without using a Composition window. 

Viewing imported footage
You can view any movie or graphic item listed in a Project window at full size by opening it 
in a Footage window. You can also view the footage at different magnifications and 
examine individual frames.

When you double-click a movie in the Project window, it opens by default in the appro-
priate Footage window: QuickTime (.mov) files open in the QuickTime Footage window; 
Video for Windows (.avi) files open in the Video for Windows Footage window. Still images 
always appear in an After Effects Footage window. 

The QuickTime and Video for Windows Footage windows do not display the effect of 
settings made in the Interpret Footage dialog box, such as the alpha channel interpre-
tation. However, for any footage item that includes audio, the QuickTime and Video for 
Windows Footage windows play the audio, while the After Effects Footage window does 
not.

To view the footage with more controls and information but without audio, view it in an 
After Effects Footage window, where you can trim the footage and insert it into the 
Timeline window. For more information about playing back, magnifying or reducing, 
viewing the alpha channel of a footage item, and trimming video, see “Composition, Layer, 
and Footage window controls” on page 16 and “Trimming layer footage” on page 82.

To open a movie in the default Footage window:

Double-click a movie in the Project window.
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To open a movie in an After Effects Footage window:

Press Alt (Windows) or Option (Mac OS) as you double-click a movie in the Project window.

In the After Effects Footage window, you can trim the footage and insert it into the Timeline window.

Opening footage in its original application
You can open and edit a footage item in the application in which it was created, directly 
from an After Effects project. The original application must be installed on the computer 
you are using, and there must be enough unused RAM for it to run. When you edit and 
save changes to the footage in the original application, the changes are applied to all 
instances of the footage in the After Effects project the next time you open the project. 

When you edit a still-image sequence selected in the Timeline or Composition windows, 
After Effects opens the individual image that is currently displayed. When you edit a still-
image sequence selected in the Project window, the first image in the sequence opens.

To open a footage item in the original application:

1 In the Project window, Composition window, or Timeline window, select the footage or 
a layer containing the footage. If you selected a still-image sequence from the Compo-
sition or Timeline window, move the current-time marker to the frame displaying the still 
image you want to edit.

2 Choose Edit > Edit Original.

3 Edit the footage in its original application, and save the changes.

Note: If you’re editing footage that has an alpha channel, make sure that you’re viewing 
and editing all the channels, including the alpha channel, in the other application. 
Otherwise, changes you make might not be applied to the alpha channel, and it may 
become misaligned with the color channels.

If your project is open when you make a change to a footage file, After Effects can reload 
the new version of the file while the project is open.

To reload an edited file:

1 In After Effects, select the footage file in the Project window. 

2 Choose File > Reload Footage.



Using Help | Contents | Index Back 52  

Adobe After Effects Help Building a Composition 

Using Help | Contents | Index Back 52  

Setting the frame rate for footage
You can change the frame rate for any movie or sequence of still images. For example, you 
can import a sequence of ten still images and specify a frame rate of 5 frames per 
second (fps). 

To set the frame rate for footage:

1 Select an item in the Project window.

2 Choose File > Interpret Footage > Main.

3 In the Frame Rate section of the Interpret Footage dialog box, specify a frame rate for 
Conform to Frame Rate.

Note: If you remove 3:2 pulldown from interlaced video footage, After Effects automati-
cally sets the frame rate of the resulting footage to four-fifths of the original frame rate. 
When removing 3:2 pulldown from NTSC video, the resulting frame rate is 24 fps. See 
“About 3:2 pulldown” on page 44. 

Looping footage
If you intend to loop visual footage continuously in your project, you need to create only 
one cycle of the footage in After Effects.

To loop footage:

1 In the Project window, select the footage you want to loop.

2 Choose File > Interpret Footage > Main.

3 Type an integer value for Looping and click OK.

Copying Interpret Footage settings
If you want to ensure that different footage items use the same Interpret Footage settings, 
copy settings from one item and apply them to others. 

To apply Interpret Footage settings to several footage items:

1 In the Project window, select the item whose footage interpretations you want to apply.

2 Choose File > Interpret Footage > Remember Interpretation.

3 Select one or more footage items.

4 Choose File > Interpret Footage > Apply Interpretation. After Effects applies the footage 
interpretation options to the selected items.

Replacing and substituting footage
After Effects offers a number of ways to replace and substitute footage in a composition. 
Using proxies or other items in place of original footage can be useful when the footage 
you want to use is not available. Also, when you are working with large, high-resolution 
items, you may want to use low-resolution proxies to work more quickly and efficiently. 
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Replacing footage throughout a project
You can replace one footage item with another at any time while working on a project. 
This can be useful if you receive a new version of a source file used in your project, and you 
want to replace the original footage with the new version. The new footage item replaces 
the existing one in layers and compositions throughout the project. When you replace 
footage, all values (property settings, effect settings, and so on) remain applied to the 
layer.

To replace footage throughout a project:

1 In the Project window, select the name of the footage item you want to replace.

2 To import a replacement file, choose File > Replace Footage > File, select the file, and 
then click Open.

Note: If the new footage item is a different size, it is not scaled to fit the original item’s size.

Replacing footage of one or more layers
You can replace the original source footage of one or more layers without changing any 
settings applied to the original footage. The new source footage or composition takes the 
place of the old source to the layers, but uses the existing keyframes.

To replace the source footage of one or more layers:

1 In a Timeline window, select the layer or layers to be replaced.

2 Hold down Alt (Windows) or Option (Mac OS) as you drag a footage item or compo-
sition from the Project window to any of the following places containing the selected 
layers: the Composition window, the Timeline window, or the Composition icon in the 
Project window. 

About placeholders and proxies
When you want to temporarily use a substitute for footage, choose one of two alterna-
tives: a placeholder or a proxy.

Placeholder A still image of color bars used to temporarily take the place of missing 
footage. Use a placeholder when you are building a composition and want to try out ideas 
for footage that is not yet available. After Effects generates placeholders automatically, so 
you do not have to provide any placeholder footage.

Proxy Most often a lower-resolution or still version of existing footage used to replace 
the original to save processing time. Use a proxy when you have the actual footage but 
you want to speed up previewing or rendering of test movies. You must have a file 
available to use as a proxy. 

Using either method, any attributes and keyframes you apply to the placeholder or proxy 
are transferred to the actual footage when you insert it. You can even set a proxy for a 
placeholder, so that you use a low-resolution or still version of full-resolution footage that 
is not yet available. See “Working with missing source footage” on page 54 and “Substi-
tuting a low-resolution proxy for footage” on page 54.

If final footage is unavailable, and you simply want to substitute draft footage or a story-
board still image, you can import the draft footage and replace it with final footage later. 
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Working with missing source footage
If After Effects cannot find footage when you open a project, it appears in the Project 
window labeled Missing, and the name of the missing footage appears in italics. Any 
composition using that item as a layer replaces it with placeholder color bars.

You can still work with the missing item in the project, and any effects you have already 
applied to the missing layer remain intact.

If you replace the placeholder with the actual footage, it returns to its correct place in all 
the compositions that use it. See “Substituting a placeholder for footage” on page 54.

Substituting a placeholder for footage
A placeholder appears in After Effects as a still image of color bars. You can apply a mask, 
effects, and geometric properties to a placeholder. When the actual footage item becomes 
available, you can replace the placeholder with it, and the applied attributes and 
keyframes are transferred to the actual footage.

For best results, set the placeholder to exactly the same size, duration, and frame rate as 
the actual footage.

To use a placeholder:

1 Choose File > Import > Placeholder or File > Replace Footage > Placeholder. 

2 In the New Placeholder dialog box that appears, specify the placeholder’s name, size, 
frame rate, and duration, and then click OK.

To replace a placeholder with the actual footage:

1 In the Project window, double-click the placeholder you want to replace.

2 Locate and select the actual footage, and then click OK, or choose File > Replace 
Footage > File to locate the file.

Substituting a low-resolution proxy for footage
Movies, images, and compositions used as layers can take up significant amounts of RAM 
and disk space when used in compositions, and can slow down working and rendering in 
elaborate projects. Using low-resolution proxy items in place of actual items is a way to 
lighten the burden on your computer and speed your work. Effects, masks, and properties 
applied to the proxy are applied to the actual footage item when you replace the proxy 
with the actual footage.

When you use a proxy, After Effects replaces the actual footage with the proxy in all 
compositions that use the actual footage item. When you finish working, you can switch 
back to the actual footage item in the project list. After Effects then replaces the proxy 
with the actual footage item in any composition.

When you render your composition as a movie, you may choose to use either all the actual 
high-resolution footage items or their proxies. You might want to use the proxies for a 
rendered movie if, for example, you simply want to test motion using a rough movie that 
renders quickly.
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For best results, set a proxy so that it has the same aspect ratio as the actual footage item. 
For example, if the actual footage item is a 640 x 480-pixel movie, create and use a 
160 x 120-pixel proxy. When a proxy item is imported, After Effects scales the item to the 
same size and duration as the actual footage. If you create a proxy with an aspect ratio that 
is different from that of the actual footage item, scaling will take longer. 

To locate and use a proxy:

1 In the Project window, select a footage item.

2 Choose File > Set Proxy > File.

3 In the Set Proxy File dialog box, locate and select the file you want to use as the proxy, 
and click Open (Windows) or Import (Mac OS).

To toggle between using the original footage and its proxy:

In the Project window, click the proxy indicator to the left of the footage name.

To stop using a proxy:

1 In the Project window, select the original footage item.

2 Choose File > Set Proxy > None.

Identifying proxy items in the Project window
In the Project window, After Effects marks the footage name to indicate whether the 
actual footage item or its proxy is currently in use:

• A box containing a black square indicates that a proxy item is currently in use 
throughout the project; the name of the proxy appears in boldface in the project list.

• An empty box indicates that the actual footage item is in use throughout the project.

• No box indicates that no proxy is assigned to the footage item.

A. Proxy assigned and in use B. Proxy assigned, but original in use 
C. No proxy assigned D. Proxy name

A

D

B

C
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Creating a composition
When you first create a new project, you must create a composition before you can start 
working with your footage items. When you create a composition without changing 
settings in the Composition Settings dialog box, the new composition uses the same 
settings as the previous composition. For information on changing composition settings, 
see “Understanding basic composition settings” on page 57. 

Once you have created a composition, you can change its settings at any time. Remember, 
however, that changing frame size or pixel aspect ratio can affect your final movie, so set 
these as early in the project as possible. Use the Flowchart View to get a “big picture” 
perspective of complex projects; see “Visualizing organization with Flowchart View” on 
page 264.

Note: When you set up a new composition, the settings you use become the default 
settings that will appear the next time you create a composition.

To create a composition:

1 Choose Composition > New Composition.

2 Type a Composition Name.

3 Choose a Preset from the menu or specify basic settings as follows. For detailed descrip-
tions of basic settings, see “Understanding basic composition settings” on page 57.

• Specify the frame’s Width and Height. As a general rule, frame size and aspect ratio 
should match your source footage and intended output media.

• Select Lock Aspect Ratio if you want to type a width or height not included in the menu 
and if you want After Effects to ensure that the composition dimensions conform to the 
aspect ratio for the current values. 

• Choose a Pixel Aspect Ratio from the pop-up menu. This is set automatically if you 
choose a digital format (D1, D4, D16, or DV) for Preset. See “Setting pixel aspect ratio for 
compositions” on page 58. 

• Specify a Frame Rate in frames per second. See “Setting frame rate” on page 58.

• Choose a Resolution from the pop-up menu. “Setting resolution” on page 59.

• Specify the Start Timecode or Start Frame to determine the time value that will be 
displayed for the first frame of the composition. This value does not affect rendering. 
See “Setting start timecode or start frame” on page 60.

• Type a Duration for your composition. “Setting duration” on page 60.

4 Click the Advanced tab, specify advanced settings as follows, and then click OK. For 
detailed descriptions of advanced settings, see “Understanding advanced composition 
settings” on page 60. 

• Use the Anchor control if you want to anchor the layers to a corner or edge of the 
composition as it is resized. “Setting the anchor” on page 61.

• If desired, specify Shutter Angle and Shutter Phase settings for motion blur. See 
“Adjusting the shutter angle for motion blur” on page 91.

• If desired, select the Preserve Resolution When Nested option so that the nested 
composition retains its resolution setting. Select the Preserve Frame Rate When Nested 
option to lock a composition to a specific frame rate. “Setting nesting options” on 
page 61.
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• For Rendering Plug-In, you may want to specify a third-party plug-in for rendering 3D 
compositions. “Setting the rendering plug-in” on page 61.

To change a composition’s settings:

1 Choose Composition > Composition Settings.

2 Adjust basic settings as explained in “Understanding basic composition settings” on 
page 57.

3 Click the Advanced tab and adjust advanced settings as explained in “Understanding 
advanced composition settings” on page 60 and click OK.

Note: You cannot undo changes that were made before changing the composition 
settings.

Understanding basic composition settings
When you create a new composition, it appears as a new item in the Project window. 
Before you set up a new composition, determine the specifications of the final output. 
These specifications influence the composition settings you choose for frame size, 
duration, frame rate, and pixel aspect ratio. Three factors determine composition settings:

• The type of movie you are producing

• The requirements of any systems that will process the movie that After Effects renders

• The final delivery medium of the movie

For best results, specify the composition settings at the beginning of your design process. 
After Effects bases certain calculations on the composition settings, so changing settings 
such as frame size and pixel aspect ratio late in the project can affect your final movie. 
(However, you can override some composition settings when creating a movie. For 
example, you might change the composition-frame size to a smaller image size when 
rendering.)

Setting frame size
The Composition window in After Effects contains the viewing frame and an area outside 
the frame that you can use to move layers into and out of the frame. For your convenience, 
After Effects includes a variety of presets, each containing settings for frame size, pixel 
aspect ratio, and frame rate. You can also create a custom preset and save it for later use.

Because After Effects can position footage items outside the frame, specify a frame size no 
larger than the actual size of the final viewing screen. After Effects previews and renders 
only the footage items within the frame. For information on working with high-resolution 
images, see “Working with higher image resolutions” on page 26.



Using Help | Contents | Index Back 58  

Adobe After Effects Help Building a Composition 

Using Help | Contents | Index Back 58  

The viewing frame occupies the center of the frame’s pixel area, which is centered in a 
larger work area. You can position items outside the frame if, for example, you want a layer 
to enter the frame from one side, cross the screen, and leave the frame on the other side.

You can move layers into and out of the frame. 

Saving custom preset values
You can save values you set in the Composition Settings dialog box so that you can 
reapply them to other compositions. Settings for Width, Height, Pixel Aspect Ratio, and 
Frame Rate options are saved with the presets. However, Resolution, Start Timecode, 
Duration, and Advanced composition options are not saved.

To save custom preset values:

1 In the Composition Settings dialog box, specify the width, height, pixel aspect ratio, 
and frame rate values, and then click the Save button ( ).

2 Type a name for the preset and then click OK.

To reuse custom preset values:

In the Composition Settings dialog box, select the custom name from the Preset pop-up 
menu.

To delete a preset:

Select the custom name from the Preset pop-up menu and click the trash icon ( ).

Setting pixel aspect ratio for compositions
Most computer monitors use square pixels, while ITU-R 601 (D1) and DV video use rectan-
gular pixels. The Pixel Aspect Ratio option compensates for the rectangular pixels of D1 
video format. Set the pixel aspect ratio that corresponds to your final output format. See 
“Setting pixel aspect ratio” on page 47.

If you intend to create a movie for the D1 output format, choose D1 NTSC or D1 PAL. For 
more information about D1 format, see “About D1, DV, and various pixel aspect ratio 
footage” on page 46. 

Note: The correct pixel aspect ratio for D1 NTSC or D1 PAL is chosen automatically when 
you choose the corresponding preset item.

Setting frame rate
The composition frame rate determines the number of frames displayed per second. 
Frame rate is usually determined by the type of output you produce. NTSC video has a 
frame rate of 29.97 frames per second (fps), PAL video has a frame rate of 25 fps, and 
motion picture film has a frame rate of 24 fps. Video intended for CD-ROM or the World 
Wide Web is often 10 to 15 fps. 
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Each motion-footage item in a composition can also have a frame rate, and the 
relationship between the footage-item frame rate and the composition frame rate deter-
mines how smoothly the layer plays. For example, if the footage-item frame rate is 30 fps 
and the composition frame rate is 30 fps, whenever the layer advances one frame, the next 
composition frame is displayed. If the footage-item frame rate is 15 fps and the compo-
sition frame rate is 30 fps, then two composition frames are displayed before the current 
layer advances one frame, unless frame blending is enabled. (See “Using frame blending” 
on page 89.) 

When you use footage that was shot or rendered at the NTSC-standard rate of 29.97 fps 
and the composition frame rate is 30 fps, approximately two footage frames will be 
repeated every minute to compensate for the differing rates. To avoid repeated frames, 
make sure that your composition frame rate matches your source footage, or enable frame 
blending for the layers.

Setting resolution
Resolution determines the dimensions of the image in pixels, which affects the image 
quality of the rendered composition. Setting a low resolution significantly increases 
frame-rendering speed and decreases the amount of memory required to render. You can 
use a low-resolution setting when animating or previewing a movie, and then increase the 
resolution before rendering your final movie.

Choose from the following resolution settings in the Composition Settings dialog box:

Full Resolution Renders each pixel in a composition. This setting gives you the best 
image quality, but takes the longest to render.

Half Resolution Renders one-quarter of the pixels contained in the full-resolution 
image—half the columns and half the rows. This results in a rendering time approximately 
one-fourth of the time required to render the entire image at full resolution.

Third Resolution Renders one-ninth of the pixels contained in the full-resolution image. 
This results in a rendering time approximately one-ninth of the time required to render 
the entire image at full resolution.

Quarter Resolution Renders one-sixteenth of the pixels contained in the full-resolution 
image. This results in a rendering time approximately one-sixteenth of the time required 
to render the entire image at full resolution.

Custom Resolution Renders the image at the resolution you specify.
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Adjusting the appearance of low-resolution compositions
When setting resolution, you can determine the size and appearance of the composition. 
When you lower the resolution of a composition, you can maintain image clarity by 
reducing the composition’s size. You can also maintain its size but reduce image clarity, 
with the layers appearing blockier and more pixelated. The smaller on-screen image will 
update faster than the original-size image with a lower resolution.

A. Original composition resolution B. Half resolution with the same clarity but with a reduction in 
screen size C. Half resolution with the same screen size but with a reduction in clarity

To determine the appearance of lower-resolution compositions:

1 Choose Edit > Preferences > Display.

2 Select Auto-Zoom When Resolution Changes to reduce the size of the composition 
while maintaining image clarity. Deselect this option to maintain the composition size in 
the Composition window but display layers with less clarity.

3 Click OK.

You can also set the magnification using the pop-up menu in the Composition 
window.

Setting start timecode or start frame
Use the Composition Settings dialog box to determine when the composition will begin. 
The name of the option in the Composition Settings dialog box is determined by whether 
Timecode, Frames, or Feet + Frames is selected in the Project Settings dialog box. For 
example, if Timecode Base is specified, you can use the Start Timecode option to specify 
when the composition will begin; if Frames is selected, you can use the Start Frame option 
to specify the frame number where the composition will begin. See “Setting time-display 
options” on page 9.

Setting duration
The duration is the overall length of the composition. Set duration by typing values in the 
Duration box in the Composition Settings dialog box.

When you preview or render a movie, you can choose to preview or render only a portion 
of the total duration. See “Setting up a work area” on page 70.

Understanding advanced composition settings
When you click the Advanced tab in the Composition Settings dialog box, you can change 
the anchor setting, adjust the shutter angle for motion blur, specify when the shutter 
opens relative to the frame start, set precompose options, and specify a rendering plug-in.

A B C
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For information on adjusting the shutter angle and shutter phase for motion blur, see 
“Adjusting the shutter angle for motion blur” on page 91.

Setting the anchor
When you change the frame size of a composition, by default the layers are centered 
within the new dimensions. Use the Anchor control to anchor the layers to a corner or 
edge of the composition as it is resized. Set the anchor by clicking the arrow button in the 
Anchor diagram (in the Advanced panel of the Composition Settings dialog box) to 
indicate where to position the existing layers. 

Setting nesting options
The Advanced panel of the Composition Settings dialog box includes two nesting options. 
If the Preserve Resolution When Nested option is selected, the nested composition retains 
its resolution setting. If this option is not selected, the containing composition’s resolution 
overrides the nested composition’s resolution.

When selected, the Preserve Frame Rate When Nested option locks a composition to a 
specific frame rate, which should improve performance in many cases as well as eliminate 
the need to use Posterize Time in creating reduced frame rate effects. If this option is not 
selected, the containing composition’s frame rate overrides the nested composition’s 
frame rate.

Setting the rendering plug-in
You can animate layers inside a 3D space. This 3D environment includes shadows, specular 
highlights, rack focus, and an automatic method of compositing layers based on depth. 
The default 3D renderer is Standard. However, you can use the Advanced panel of the 
Composition Settings dialog box to specify other rendering plug-ins for rendering 3D 
compositions as they become available. 

Adding footage items to a composition
Once you have created a new composition and imported footage into the project, you can 
add footage items or another composition to it. To do this, drag footage items or folders 
from the Project window to a Timeline window, a Composition window, or a composition 
name or icon in the Project window. You can use individual items in the Project window 
any number of times in one or more compositions. 

Note: Although you cannot directly add a composition to itself, you can duplicate a 
composition and add the copy to the original.

When you drag a footage item to the Timeline window, you can specify a precise layer 
order and start time for the item. If you add multiple footage items to a composition, the 
items appear in the order in which they were selected in the Project window. If you drag a 
footage item into the Composition window, the layer appears where you drop it. If you 
drag a footage item onto a composition in the Project window, the layer snaps to the 
center of the Composition window. After you add a layer, you can move it to any position 
within the Composition window. When you add multiple footage items, they appear in the 
composition in the order selected.
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Items added to a composition begin at the time indicated on the current-time marker in 
the Timeline window. For example, if the current time box displays 0:00:04:00 (4 seconds), 
when you place the item in the Composition window, the item begins its first frame at 4 
seconds. By changing the location of the current-time marker (Timeline window) or the 
time displayed in the Current Time button (Composition window), you can add a layer at 
any point in the composition. 

In the Composition window, layers are visible only if they are active at the time currently 
displayed. For example, if you have three layers in a composition, with two of the layers 
starting at the beginning of the composition and one layer starting at 6 seconds, only two 
of the layers appear in the Composition window when the current-time marker is set to 
the beginning of the composition. 

For more information on adjusting the duration or speed of a layer, see “Understanding 
trimming” on page 81 and “Time-stretching a layer” on page 139. For more information on 
setting and adjusting the current time, see “Viewing and setting the current time” on 
page 69. 

To add a footage item to a composition:

1 Activate the Timeline window for the composition to which you want to add an item.

2 To set the current-time marker, click the current-time display, specify a new time, and 
then click OK.

3 Drag the name of the footage item, the footage-item thumbnail, or a folder from the 
Project window to one of three places:

• The Composition window.

• The Timeline window. When you drag the item into the Timeline window, a highlight 
bar indicates where the layer will appear when you release the mouse button. If you 
drag the item over the time graphic area, a time marker indicates where the layer’s In 
point will be when you release the mouse button.

While dragging an item into the Timeline window, you can specify the layer order and In point.

• The composition name or icon in the Project window.

You can also add a footage item to a composition by selecting the name of the 
footage item in the Project window and pressing Ctrl+/ (Windows) or Command+/ 

(Mac OS).

To add several footage items to a composition at the same time:

1 Do any of the following:

• Select multiple footage items. To select a contiguous range of items, press Shift as you 
click the footage items in the Project window. To select a discontiguous set of items, 
press Ctrl (Windows) or Command (Mac OS) as you select the footage item names.
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• Move multiple footage items into a folder in the Project window. For information on 
creating folders, see “Working with the Project window” on page 15.

2 Drag the names of the footage items or the folder from the Project window onto a 
composition name in the Project window, into the Composition window, or into the 
Timeline window. The items appear in the order in which they were selected in the Project 
window.

Nesting a composition
When creating an elaborate composition, you may find it easier to organize the layers that 
make up the composition by using a technique called nesting—putting one or more 
compositions into another composition. You can create many levels of nesting. For further 
information, see “Organizing a project using nesting” on page 265.

Using the Composition window
Use the Composition window to preview the composition and animate its contents 
manually. Move a layer by dragging it; scale a layer by dragging its handle. The Compo-
sition window contains a number of features and controls to help you work with layers. 
You can also change the background color of the composition. 

A. Rulers Used to align layers in the composition window. The ruler scale is in pixels. See 
“Using rulers and guides” on page 19.

B. Magnification menu button Used to choose a new magnification from the menu. See 
“Changing magnification in windows” on page 17. Hold down Alt (Windows) or Option 
(Mac OS) as you press the mouse button to view composition information. 

C. Safe zones button Toggles between viewing the title-safe and action-safe zones and 
viewing just the image. To display the animator grid, hold down Alt (Windows) or Option 
(Mac OS) and click this button. See “Viewing safe zones and grids” on page 17.

D. Take- and display-snapshot icons Captures a screen image of the window. Snapshots 
are not saved to disk, and only the most recent snapshot can be viewed. Click and hold the 
Display-snapshot icon to view the most recent snapshot instead of the active compo-
sition. See “Taking and viewing a window snapshot” on page 20.
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E. Red, green, blue, and alpha channel icons Click one of the first three icons to view 
the composition’s red, green, or blue channel. Areas with high values of that channel’s 
color are displayed as white. Click the fourth icon to view the composition’s alpha channel. 
Transparent and opaque areas are displayed as black and white, and degrees of opacity 
appear as shades of gray. See “Viewing color and alpha channels” on page 20.

F. Region of interest Used to narrow the composition area for previewing. See 
“Changing the region of interest” on page 65.

G. Composition window menu Used to display the Composition Settings dialog box, 
enable frame blending and motion blur, and display effect layer controls such as handles 
and paths. 

H. Comp family button Displays the Timeline window for this composition. 

Arranging a footage item in a composition by dragging
You can change the spatial position of a layer in a composition by selecting and dragging 
the layer in the Composition window. When you want to move a layer into or out of the 
frame, you can position it completely or partially outside the frame.

When you arrange a layer in the Composition window, you determine the position of the 
layer at the current time, indicated by the current-time marker in the Timeline window. If 
no keyframes are set for a layer, the position values you set will apply for the duration of 
the layer. The layer remains in position until you set up a change over time in the Timeline 
window; see “Understanding keyframes” on page 96. For information about changing the 
order of layers, see “Changing the layer stacking order” on page 75. 

To arrange a layer in a composition by dragging:

1 Select the selection tool from the Tools palette.

2 Click a layer in the Composition window to select it or, if the layer is obscured by 
another layer, select the layer name in the Timeline window.

You can select layers behind other layers in a Composition window. Using the 
selection tool, right-click (Windows) or Control-click (Mac OS) the top layer, choose 

Select, and then choose a layer name.

3 Position the pointer within the layer (but not on a handle) and drag the layer to a 
location within the Composition window.

After you start dragging a layer, hold down Shift to constrain the dragging to 
horizontal or vertical movements, or hold down Ctrl+Shift (Windows) or 

Command+Shift (Mac OS) to snap to the frame edges or center.

Setting the background color of a composition
The default background color for the Composition window is black, but you can change 
the color at any time. When you add one composition to a second composition (nesting), 
the second composition’s background color is preserved, and the first composition’s 
background becomes transparent. If you want to preserve the first composition’s solid 
background color, create a new, colored solid to use as a background layer in the first 
composition. See “Creating a new solid layer” on page 73. For more information on 
nesting, see “Organizing a project using nesting” on page 265.

You can also change the color of the pasteboard in the Composition window.
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To set the background color of a composition:

1 Choose Composition > Background Color.

2 Click the color swatch to select a color, or click the eyedropper to sample a color from 
anywhere on the screen. Then click OK.

To set the pasteboard color of a composition:

1 Choose Edit > Preferences > Display.

2 Click the color swatch to select a color, or click the eyedropper to sample a color from 
anywhere on the screen. Then click OK.

Using checkerboard backgrounds to display transparency
You can toggle a checkerboard pattern on or off (like the checkerboard that Adobe 
Photoshop uses to indicate transparency). Viewing the checkerboard pattern may slow 
down window redraw.

To turn on or off the checkerboard background:

Choose Checkerboard Backgrounds from the Composition window menu.

Changing the region of interest 
Use the Region of Interest button to create a rectangular preview of the composition 
window. Reducing the region of interest requires less memory when previewing, thereby 
improving interaction speed and increasing RAM preview duration. Changing the region 
of interest does not affect file output. 

To change the region of interest:

1 In the Composition window, do any of the following:

• To draw a region of interest, click the Region of Interest button ( ), and then drag the 
marquee tool across the area of the composition window where you want images to 
appear.

• To toggle between viewing the region of interest and the full composition area, click 
the Region of Interest button again. 

• To start over with the marquee tool, hold down Alt (Windows) or Option (Mac OS) and 
click the Region of Interest button.

Using the Timeline window
Use the Timeline window to set up changes over time, animate layer properties numeri-
cally, and set In and Out points for a layer. The Timeline window controls are organized in 
panels of related functions. 
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Default controls and panels
By default, the Timeline window contains a number of panels and controls. Optional 
panels are also available. See “Optional panels” on page 66. 

A. Composition tab Use to close or move the window. Click a tab to display its compo-
sition in the current window. Drag a tab to move its composition to another existing 
window or to put it in a new window. 

B. Current time Displays the current time in the project. Click to open the Go to Time 
dialog box. “Viewing and setting the current time” on page 69.

C. Audio/Video Features panel Contains switches for enabling and disabling audio and 
video. This panel also includes a lock switch for locking layers and a solo switch for 
displaying only one layer. See “About After Effects Audio/Video switches” on page 86.

D. Layer Outline Includes a label, a number (assigned by After Effects), and a source 
name for each layer. Clicking the triangle to the left of a layer lets you examine and set 
properties for the masks, effects, and transform functions. See “About layer properties” on 
page 95.

E. Switches panel button Displays or hides the Switches panel. 

F. Switches panel Contains options for controlling a number of display and performance 
features for a layer. See “About After Effects Audio/Video switches” on page 86. 

G. Time graph Visually represents the values of the In/Out panel (see “Optional panels” 
on page 66) and displays the positions of the keyframes and timeline for each layer. See 
“Understanding the time graph” on page 68.

H. Comp Family button Opens the corresponding composition window.

Optional panels
You can display or hide several optional panels in the Timeline window. 

A B

C D E F G

H
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To display or hide optional panels:

Right-click (Windows) or Control-click (Mac OS) a Timeline window panel heading, and 
then choose the panel you want to display or hide in the Panels submenu. 

A. Comment panel Type comments for the layer. 

B. Modes panel Specify layer modes and track mattes. See “Using layer modes” on 
page 166 and “Creating track mattes and traveling mattes” on page 164.

C. Parent panel Specify a parent layer. See “Understanding parent layers” on page 113.

D. Keys panel Move the keyframe navigator controls closer to the time graph. See 
“Keyframe navigator” on page 97.

E. In panel View or change the In point of a layer. See “Understanding trimming” on 
page 81. You can also display or hide this panel by clicking the Optional panel button ( ) 
in the lower left corner of the time graph.

F. Out panel View or change the Out point of a layer. See “Understanding trimming” on 
page 81.

G. Duration panel View or change the duration of a layer. See “Understanding trimming” 
on page 81.

H. Stretch panel Time-stretch a layer. See “Understanding trimming” on page 81.

I. Optional panel button Display or hide the In, Out, Duration, and Stretch panels. 

To rearrange panels:

Drag the panel heading to a different location along the Timeline window. When the panel 
outline appears where you want the panel to appear, release the mouse.

A gray outline appears when you drag a panel (left). When you release, panels are rearranged (right).

Note: All layer switches move together—you can move the entire switch panel to a 
different position between other panels, but you can’t rearrange the switches within the 
panel.

A B C D E F G H I



Using Help | Contents | Index Back 68  

Adobe After Effects Help Building a Composition 

Using Help | Contents | Index Back 68  

To change the width of a panel:

Drag the raised vertical bar left or right to set the new width. If the panel does not have a 
raised vertical bar at its right edge, it cannot be resized.

Understanding the time graph
The time graph portion of the Timeline window contains a time ruler, markers to indicate 
specific times and current work area, and duration bars for the layers in your composition. 
Use the time graph to adjust the range of time shown in the Timeline window, and to 
specify a range of time to render when creating or previewing a movie. 

The time graph also contains controls for adjusting time for layers and controlling motion 
and changes over time. For more information on working with time for an individual layer, 
see “Positioning a layer in time” on page 76.

A. Time graph Use to view layer durations, a time ruler, markers, and keyframes. 

B. Viewing-area markers Indicate the area displayed in detail in the time graph. These 
markers are part of the navigator view, described below. Drag to view a specific area. See 
“Viewing and setting the current time” on page 69.

C. Navigator view Uses smaller versions of the work-area markers and current-time 
marker to show their relationship to the entire composition. As you drag the viewing-area 
markers to change the view, the miniature markers in the navigator view show your view 
and the location of the current-time marker in the context of the full duration of the 
composition. 

D. Work-area markers Indicate an area of the composition for rendering or previewing. 
To render only part of the composition, drag the work-area marker to specify the part of 
the composition to render. See “Setting up a work area” on page 70.

E. Time ruler Indicates the part of the composition duration currently displayed in the 
time graph. For information on ways to display time on the time ruler, see “Setting time-
display options” on page 9.

F. Window menu button Displays the Timeline window menu, which includes functions 
affecting layers and keyframes, as well as providing access to the Composition Settings 
dialog box. 

G. Composition-time marker Used to add markers to the time ruler. Drag the marker to 
a point on the time ruler. Drag it back to remove it. 

H. Comp Family button Click to open the active Timeline window’s associated Compo-
sition window. 
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I. Zoom slider Drag to magnify a portion of the time graph or to see more of the time 
graph. You can also use the zoom-in icon ( ) or the zoom-out icon ( ). 

Viewing and setting the current time
A composition’s current time is indicated by the current-time marker. For convenience, 
you can view and move the current-time marker in both the navigator view and the time 
ruler. The navigator view shows the complete duration of a composition. When you view 
the duration of the entire composition, detailed work can be difficult. You can magnify a 
portion of the time graph so as to work on only the portion you need.

To move the current-time marker by dragging:

In the navigator view or on the time ruler, drag the current-time marker to a new location 
on the time graph, or click a new setting on the time ruler.

To move the current-time marker numerically:

1 Click the current time in the Timeline or Composition window.

2 Type a new time and click OK.

To magnify a portion of the time graph:

Do one of the following:

• In the Timeline window, click the zoom-in icon ( ) or drag the zoom slider.

• Press the = (equal sign) key on the main keyboard.

• In the navigator view, drag the left, right, or both viewing-area markers until the time 
ruler displays the portion you want.

Drag left and right viewing-area markers to magnify 
or shrink the part of the time ruler displayed.

To see more of the time graph:

Do one of the following:

• In the Timeline window, click the zoom-out icon ( ).

• Press the – (minus) key on the main keyboard.

• In the navigator view, drag the left and right viewing-area markers until the time ruler 
displays the portion you want.
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Setting up a work area
When you work on a composition, you may want to preview or render only part of the 
composition. Do this by specifying a part of the composition time ruler as a work area. In 
the Timeline window, the work area appears in a lighter shade of gray. For more infor-
mation, see “Previewing animation” on page 118 or “Making (rendering) a movie” on 
page 278.

Set the work area start and end points to the current time by pressing B (begin) or N 
(end), respectively.

To set up a work area:

In the time ruler, move the left and right work-area markers until they mark the beginning 
and end of the part of the composition you want to use as a work area.

The work-area markers indicate the part of the composition displayed when previewing or 
rendering.

To move the work area:

In the time ruler, drag the center of the work area bar left or right.



Using Help | Contents | Index Back 71  

Adobe After Effects Help Managing Layers 

Using Help | Contents | Index Back 71  

Managing Layers

Managing layers
Layers are the components you use to build a composition. Any item you add to a compo-
sition—such as a still image, moving image file, audio file, lights and cameras, or even 
another composition—becomes a new layer. Without layers, a composition consists only 
of an empty frame.

Using layers, you can work with specific footage items in a composition without affecting 
any other footage. For example, you can move, rotate, and draw masks for one layer 
without disturbing any other layers in the composition, or you can use the same footage 
in more than one layer and use it differently in each instance. For more information on 
masks, see “Working with masks” on page 149.

Three layers as viewed in the Timeline window (left) and the Composition window (right)

Adding layers to compositions
When you add an item to a composition, you create a new layer for that composition. You 
can duplicate layers within a composition or even copy and paste layers from one compo-
sition to another. Use as many layers as necessary to create your composition.

A composition layer can be any of the following:

• Any footage item in the Project window list (including audio)

• Another composition in the project

• A solid, camera, or light you create

• An After Effects adjustment layer, which modifies all layers below it

• A duplicate of another existing layer

• A split layer

• A null object
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Creating new layers
Of the numerous ways to create layers in an After Effects composition, the most obvious is 
to begin with a footage file you want to use. You can create a new layer from any footage 
item in your Project window, including audio. After you add a footage item to a compo-
sition, you can modify and animate the resulting layer.

To create a layer from a footage item:

1 In the Project window, double-click the composition you want to work on to open its 
Composition and Timeline windows.

2 In the Timeline window, move the current-time marker to the time where you want the 
layer to begin playing.

3 Drag the footage item from the Project window to the Composition window.

Note: To position the new layer in a particular order among existing layers or at a specific 
starting time in the composition, drag the item to the Timeline window and release it in 
that layer position and starting time instead of dragging it to the Composition window.

To create multiple layers simultaneously, follow this procedure but hold down Ctrl 
(Windows) or Command (Mac OS) and click to select footage files in Step 3. When you 

drag them to the Timeline window, the footage files form layers in the order in which you 
clicked them.

Creating layers by nesting compositions
When you add a composition to another composition, it creates a new layer in a process 
called nesting. The composition you add becomes a layer in the other (target) compo-
sition. Nested compositions can change composition structure, memory usage, and 
rendering order.

For more information, see “Organizing a project using nesting” on page 265.

To create a layer from another composition:

1 Display the Composition window or Timeline window for the target composition.

2 Drag a composition from the Project window list to the target Composition window or 
Timeline window.

For nested compositions, if you change certain settings in the parent composition, these 
propagate through to the nested (child) compositions. These settings include the Quality 
options under Layer > Quality, several options under Layer > Switches, and three options 
on the Timeline window menu: Enable Motion Blur, Enable Frame Blending, and Draft 3D. 
The Resolution setting for the parent composition also applies to nested compositions.

If you do not want these switch settings for the parent compositions to apply to the 
individual nested compositions, you can change that at the preferences level.

To prevent switches from operating through nested compositions:

1 Choose Edit > Preferences > General.

2 Deselect the Switches Affect Nested Comps option, and click OK.
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Creating a new solid layer 
You can create solid images of any color or size (up to 32,000 x 32,000 pixels) using After 
Effects. After Effects treats solids as it does any other footage item: You can modify the 
mask, transform properties, and apply effects to the solid. Use solids to color a background 
or create simple graphic images.

To create a solid-color layer:

1 With the Composition or Timeline window active, choose Layer > New > Solid.

2 In the Solid Settings dialog box under Size, type a name and dimensions for the solid.

3 Under Color, set the color of the layer in one of two ways:

• Use the color picker: Click the color swatch, select the color you want, and click OK.

• Use any color visible in the After Effects interface: Click the Eyedropper ( ), and then 
click the color you want.

Note: In Mac OS, you can click the eyedropper in any area of your screen.

In the Timeline window, you can then drag the new solid layer to any position above or 
below, as needed.

Creating a light or camera layer
Light and camera layers create interesting effects for the 3D layers in a composition. To 
learn more about lights and cameras, see “Using cameras” on page 235 and “Using lights” 
on page 239.

To create a light or camera layer:

1 With the Composition or Timeline window active, choose Layer > New > Camera, or 
Layer > New > Light.

2 In the Camera or Light Settings dialog box, select the settings you want.

Creating an adjustment layer
When you apply an effect to an ordinary layer, the effect affects only that layer and no 
others. However, an effect can exist independently if you create an adjustment layer for it. 
Any effects applied to an adjustment layer affect all layers below it in the composition 
stacking order. An adjustment layer at the bottom of the stacking order has no visible 
effect.

Because adjustment layer effects apply to all layers beneath them, they are useful for 
applying effects to many layers at once. In all other aspects, an adjustment layer behaves 
exactly like other layers; for example, you can use keyframes with any adjustment layer 
property, and rename the layer. You can also create masks on adjustment layers.

To create a new adjustment layer:

1 Display the Composition or Timeline window to which you want to add an adjustment 
layer.

2 Choose Layer > New > Adjustment Layer. A new adjustment layer appears at the top of 
the Timeline window.

3 Apply one or more effects to the adjustment layer.
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For information about effects, see “Working with effects” on page 170.

Note: Transformations on adjustment layers behave slightly differently; they transform 
only the matte but not the fill.

To change an existing layer into an adjustment layer: 

1 In the Timeline window, select the name of the layer you want to make into an 
adjustment layer. (Typically, this layer already has effects applied to it, but you can add 
effects after making it an adjustment layer.)

2 Choose Layers > Switch > Adjustment Layer.

If you want to apply an effect to just part of an image, draw a mask on an adjustment 
layer (see “Working with masks” on page 149). The mask restricts the area to which the 

effect applies. You can animate the mask to follow a moving subject.

For more information about switches, see “About After Effects Audio/Video switches” on 
page 86.

Duplicating a layer
When you duplicate a layer, After Effects copies all property keyframes, masks, and effects 
to the duplicate. The duplicate is added above the original layer and automatically 
selected. If you want to duplicate a layer without duplicating its keyframes, masks, or 
effects, add the original source footage file to the composition again.

To duplicate a layer:

In a Composition or Timeline window, select the layer and choose Edit > Duplicate.

Creating new layers by splitting
You can split a layer at any point along its timeline, creating two independent layers. This is 
a time-saving alternative to duplicating and trimming the layer—something you might do 
when you want to change the stacking-order position of the layer in the middle of the 
composition, such as an object revolving in front of and then behind another object.

When you split a layer, both resulting layers contain all the keyframes that were in the 
original layer in their original positions; see “Understanding keyframes” on page 96.

To split a layer:

1 In the Timeline or Composition window, select a layer.

2 In the Timeline window, move the current-time marker to the time where you want to 
split the layer.

3 Choose Edit > Split Layer.

Rearranging layers
You can change the stacking order (which layers appear above or below other layers), the 
positions of layers in visual space, and the point in the play time at which different layers 
appear. The Timeline window provides intuitive methods for dragging layers vertically into 
different stacking orders and dragging time indicators for a layer horizontally to achieve 
the results you want. The Align palette makes it easy to arrange spatial relationships 
between elements on different layers.
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Changing the layer stacking order
The Timeline window displays the layer stacking order. The uppermost layer appears at the 
top of the layer outline list, the second layer is immediately below it, and so on. Changing 
the order of footage layers modifies the appearance of your composition by repositioning 
footage in front of or behind other footage.

Changing the position of an adjustment layer in the stacking order changes which layers it 
affects (because it affects only the layers below it). For more information, see “Creating an 
adjustment layer” on page 73.

Note: The stacking order of 3D layers has somewhat different implications. For infor-
mation, see “Combining 2D and 3D layers” on page 233.

To rearrange layer order:

In the Timeline window, select the layers you want to move by name and drag up or down 
the stacking order.

Note: As you drag a layer name up or down, a horizontal line appears between other layer 
names, indicating the position to which the layer will move if you release the mouse.

For more information on 2D and 3D layers, see “Combining 2D and 3D layers” on 
page 233.

To move a layer to a specific position in the order:

In the Composition or Timeline window, select the layer and do one of the following:

• To move a layer up or down one level, choose Layer > Bring Forward or Layer > Send 
Backward.

• To move a layer to the top of the composition, choose Layer > Bring to Front.

• To move the layer to the bottom of the composition, choose Layer > Send to Back.

Selecting a layer by position number
After Effects automatically numbers all layers in a composition. The number reflects the 
position of that layer in the stacking order. When the stacking order changes, After Effects 
changes all numbers accordingly.

Select a layer by its number by pressing the layer number on the numeric keypad. If the 
layer number has more than one digit, type the numbers quickly so that After Effects can 
recognize them as a unit.

Aligning and distributing layers in space
Use the Align palette to line up or evenly space selected layers across a composition. You 
can align or distribute layers along the vertical or horizontal axes of selected objects.

When you align and distribute selected layers, keep the following in mind:

• An alignment option aligns selected layers to the object that most closely represents 
the new alignment. For example, for right-edge alignment, all selected layers align to 
the selected object that is farthest to the right.

• A distribution option evenly spaces selected layers between the two most extreme 
layers. For example, for a vertical distribution option, the selected layers are distributed 
between the highest and lowest selected objects.
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• When you distribute layers of different sizes, the spaces between layers may not be 
uniform. For example, distributing layers by their centers will create equal space 
between the centers—but different-sized layers will extend by different amounts into 
the space between layers.

• Locked layers cannot be moved by alignment or distribution options.

• Text alignment is not affected by the Align palette. For information on aligning Basic 
Text, see “Basic Text” on page 221.

To align or distribute layers:

1 Select the layers you want to align or distribute.

Note: To align, you must select two or more layers; to distribute, you must select three or 
more layers.

2 Choose Window > Align & Distribute.

3 In the Align palette, click the icon representing the type of alignment or distribution 
you want.

Positioning a layer in time
Move a layer in time by changing its In or Out point in the Timeline window. After Effects 
provides two ways to view and change the In and Out points of a layer in the Timeline 
window:

• The In and Out panels represent the layer duration numerically.

• The duration bar represents the layer duration visually.

To change the In and Out points of a layer numerically:

1 If the In and Out panels are not visible in the Timeline window for the composition layer 
you want to change, open the Timeline menu (click the right arrow above the vertical 
scroll bar) and choose Panels > In. On the same menu, choose Panels > Out.

2 Click the number in the In or Out panel of the layer you want to change.

3 In the Layer In Time or Layer Out Time dialog box, type a new time and click OK.

Note: Do not use this method to adjust the In and Out points in the Timeline window if 
your aim is to trim, speed up, slow down, or distort time within layer footage. For infor-
mation, see “Understanding trimming” on page 81 and “About time-remapping” on 
page 142.

To move a layer in time by dragging:

In the Timeline window, drag the layer duration bar to the left or right. To snap the layer 
duration bar to significant points in time (such as markers, or the start or end of the 
composition), press Shift as you drag.

Before and after moving the duration bar
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To move a layer in time by moving its In point:

1 In the Timeline window, drag the current-time marker to the time at which you want 
the layer to begin playing.

2 In the Timeline window, right-click (Windows) or Control+click (Mac OS) any panel 
heading, and then choose Panels > In.

3 In the In panel, press Alt (Windows) or Option (Mac OS) and click the number that 
appears for that layer.

Note: To move a layer by its Out point, use the same steps with the Out point panel.

Automatically arranging layers as a sequence
Use the Sequence Layers keyframe assistant to automatically arrange layers in a sequence. 
When you apply the keyframe assistant, the first layer you select remains in its initial time 
position, and the other selected layers move to new positions in the Timeline window 
based on the order in which you select them.

Layers selected in Timeline window (top). Layers arranged in sequence after applying the Sequence 
Layers Keyframe Assistant (bottom).

You can specify whether the layers overlap or are arranged end to end. For overlapping 
layers, you determine how long the layers overlap and whether they cut or crossfade from 
one to the next. If you specify a crossfade, After Effects creates opacity keyframes that 
control how the layers fade into each other.

Overlapping layers can have opacity keyframes set automatically to create a crossfade.

For a layer to be sequenced, its duration must be less than the length of the composition 
so that it leaves time for other layers. If you plan to sequence still-image footage that you 
haven’t imported yet, choose File > Preferences > Import before you import, and specify a 
short Still Footage duration. If you’ve already imported still images that are the length of 
the composition, you can trim all of them at once by selecting all of the still image layers, 
positioning the current-time marker to set the duration you want them to have, and 
pressing Alt+] (Windows) or Option+] (Mac OS).
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To arrange layers in a sequence:

1 In the Timeline window, hold down Ctrl (Windows) or Command (Mac OS) and select 
layers in sequential order, beginning with the layer you want to appear first.

2 Choose Animation > Keyframe Assistant > Sequence Layers.

3 In the Sequence Layers dialog box, do one of the following, and then click OK:

• To arrange the layers end to end, leave the Overlap option unselected.

• To overlap ends of layers, select the Overlap option and type a duration in timecode for 
how long the layers should overlap.

4 If you selected the Overlap option in step 3, choose a Crossfade option to specify which 
layers’ opacity After Effects adjusts to create crossfades.

• If none of the selected layers uses an alpha channel or mask, choose Front Layer Only.

• If any of the selected layers uses an alpha channel or a mask, choose Front & Back 
Layers.

Creating simple cuts and transitions between layers
A simple cut (shifting view from one layer to another) is easy to create in the Timeline 
window.

To cut from one layer to another:

1 Display the Timeline window containing the two layers for which you want to create the 
transition.

2 Set the In point of the second layer at one frame later than the Out point of the first 
layer.

For more information about setting In and Out points, see “Understanding trimming” on 
page 81.

Other kinds of transitions, such as fading or dissolving one layer into another, involve 
opacity settings, In and Out points, and keyframes. However, you can apply certain effects 
(including transition effects) to create a different transitions instead of building them 
yourself, as described in “Applying and controlling effects” on page 170. For more infor-
mation about creating your own transitions, see “Setting layer opacity” on page 110, 
“Understanding trimming” on page 81, and “Understanding keyframes” on page 96.

Customizing layer work and views
You can change a number of layer properties to suit the way you work. For example, you 
can rename a layer, giving it a unique name. This is especially helpful when you use the 
same source footage for more than one layer. You can also change color labels.

Certain settings affect both the working view and the rendered view. For more infor-
mation, see “Changing the layer image quality” on page 88 and “Showing and hiding 
applied effects” on page 88.
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Renaming a layer
By default, the layer outline in the Timeline window uses the source footage names for 
layers. You can rename any layer at any time. Unique layer names can help you identify 
layers when you use the same source footage for more than one layer. You can switch 
between displaying the original filename and the layer name you’ve specified; see 
“Viewing the source name of a layer” on page 79.

After you rename a layer, all other layers in the composition display with brackets around 
the names. Renamed layers display without brackets.

To rename a layer:

1 In the Timeline window’s layer outline, select the layer you want to rename.

2 Press Enter (Windows) or Return (Mac OS) and type a new name.

3 Press Enter or Return again to apply the new name.

Viewing the source name of a layer
The Timeline window can list a layer by the name of its source footage or by a name you 
give the layer. You can switch between viewing source names and layer names. After 
Effects can also display the source filename in the Info palette, which is useful when the 
source footage is a still-frame sequence (because each still image has a different filename).

For information about renaming layers, see “Renaming a layer” on page 79.

To switch the type of layer name in the Timeline:

In the layer outline in the Timeline window, click the heading Source Name or Layer Name.

To see a layer source name in the Info palette:

1 Choose Window > Info if the Info palette is not already open.

2 In the Timeline window, select the layer.

3 Press Ctrl+Alt+E (Windows) or Command+Option+E (Mac OS). The name of the source 
footage appears in the Info palette.

Changing layer color labels
The Timeline window uses different colored boxes as labels to indicate different kinds of 
layers, such as compositions or source footage layers. Use the Edit > Label submenu to 
select all layers of a particular type, either by a specific label color or to match the current 
layer selection (using the Select Label Group command).

You can customize the label colors at any time for an individual layer, for all similarly 
labeled layers in a composition, or at the default level.

To change a color label for an individual layer:

1 In the Timeline window, select the layer.

2 Choose Edit > Label > color name.

Note: To change all the similar labels in a composition, right-click (Windows) or Option-
click (Mac OS) the label and choose Select Label Group. Then, select a new color, as above.

To change the default color label and options for a source type:

1 Choose Edit > Preferences > Label Colors.
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2 Click a color swatch or Eyedropper button, select new colors to replace the existing 
colors you want to change, and type new names for the colors, as needed.

3 Click Next, or click the Label Colors pop-up menu and choose Label Defaults.

4 Using the pop-up menus for each type of composition element (Composition, Video, 
Audio, and so forth), choose new default colors. When finished, click OK.

Hiding layers in the Composition window
Use the Video switch to exclude or include layers from appearing in the Composition 
window. The Video switch is on by default, so the layer displays in the Composition 
window. When you want to speed up redraw or exclude a layer from appearing in both the 
preview and the rendered version, turn off the Video switch.

To show or hide a layer in the Composition window:

Do either of the following:

• To show or hide a layer, click the Video ( ) switch for that layer in the Timeline window.

• Select a layer, choose Layer > Switches, and make sure that the Video command is 
selected (to display the layer) or deselected (to hide the layer).

To hide all layers that are not selected in the Composition window:

Choose Layer > Switches > Hide Other Video.

To show all layers in the Composition window:

Choose Layer > Switches > Show All Video.

Showing and hiding layers in the Timeline window
You can mark a layer as shy and then use the Hide Shy Layers button in the Timeline 
window to hide all shy layers on the Timeline list. Making layers shy is useful when you 
want to make room in the Timeline window to show the layers and layer properties you 
want to adjust.

Shy layers still appear in the Composition window. If you want to hide or show layers in the 
Composition window, use the eye icon (see “Hiding layers in the Composition window” on 
page 80).

To mark a layer as shy or not shy:

Select the layer in the Timeline window, and choose Layer > Switches > Shy to apply or 
undo shy status for that layer.

The icon in the Timeline Switches panel indicates whether a layer is shy ( ) or not shy ( ). 
You can also click this Shy switch to toggle between shy and not shy status.

To hide or show all shy layers:

Click to select or deselect the Hide Shy Layers button ( ) at the top of the Timeline 
window.

You can also choose Hide Shy Layers from the Timeline window menu to switch back and 
forth between showing and hiding shy layers.
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Locking and unlocking a layer
The Lock switch prevents accidental selection of layers that you do not want to alter. When 
a layer is locked, you cannot select it in either the Composition or Timeline windows. If you 
try to select or modify a locked layer, the layer flashes in the Timeline window.

When a layer is locked, the Lock icon ( ) appears in Features panel, which appears by 
default to the left of the layer name in the Timeline window.

To lock or unlock layers:

Do one of the following:

• In the Timeline window, click the Lock switch for the layer to place (lock) or clear 
(unlock) the Lock icon ( ).

• Select one or more layers in the Timeline window and choose Layer > Switches > Lock.

• To unlock all layers in the active composition, choose Layer > Switches > Unlock All 
Layers.

Soloing a layer
You can isolate one or more layers for animating, previewing, or rendering by soloing. 
Soloing excludes all other layers of the same type from appearing in the Composition 
window. For example, if you solo a video layer, any lights and audio layers are unaffected, 
so they appear when you preview or render the composition. However, the other video 
layers do not appear. Soloing is useful for speeding up redraw and rendering.

To isolate a layer:

In the Timeline window, select the layers you want to isolate, and choose Layer > 
Switches > Solo to add a checkmark next to the Solo command.

The Solo icon ( ) appears in the switches panel to the left of the layer names in the 
Timeline window. You can also click this icon to toggle soloing off and on for a layer.

Understanding trimming
You can trim (hide) footage at the beginning or end of a layer, changing which frames are 
first or last in the composition. The first frame to appear is called the In point, and the last 
frame is called the Out point.

A. Original In point B. Original Out point C. Out point after trimming D. Underlying (trimmed) 
footage or composition E. Original Out point reference 

A CB D E
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When you use a footage item as a source for different layers, you can trim it differently in 
each layer. Trimming does not alter the original source file.

Note: Trimming a still image layer changes the length of time the image appears in the 
composition; it does not crop the image (affect what portion of the image appears).

Trimming layer footage
You can trim by changing the In and Out points in the Layer window or the Timeline 
window, depending on what you want to change.

In the Layer window, In and Out points relate to time positions within source files, not the 
time at which the layer appears in the composition. For example, if you want to show just 
specific frames of a movie, trim the movie footage in the Layer window. However, if you 
want to begin the movie at the first frame in the source file and then cut it at some point in 
the play time, trim the Out point in either the Layer window or the Timeline window.

The numbers below the layer image indicate the In ( ) and Out ( ) times relative to running 
the source file, and the duration ( ) (the difference between the In point and the Out 
point).

In the Timeline window, the In and Out panels tell you at what points in the composition 
the footage appears. For example, if you want a still image to appear at a specific point in 
the composition and then disappear again, trim the image In and Out points in the 
Timeline window.

Note: If the In and Out panels do not appear in the Timeline window, click Expand or 
Collapse ( ) below the left edge of the timeline display bars panel.

To trim or restore layer footage:

Use one of the following techniques:

• Drag either end of the layer duration bar in the Timeline window.

• Move the current-time marker in the Timeline window to the time at which you want 
the footage to begin or end, and press Alt+[ (Windows) or Option+[ (Mac OS) (to set the 
In point) or press Alt+] (Windows) or Option+] (Mac OS) (to set the Out point).

• Move the current-time marker in the Layer window to the time at which you want the 
footage to begin or end, and then click the In ( ) or Out ( ) button to set the In or Out 
point.

A pale rectangle behind the layer duration bar represents the footage you trimmed.

Move the current-time marker precisely in either the Layer or Timeline window by 
choosing View > Go to Time.

Note: If the entire layer duration bar moves when you drag, you’ve accidentally grabbed 
the layer itself; choose Edit > Undo Layer Time Change and try again.
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Moving a trimmed layer in time
After you trim a layer by setting In and Out points, you can adjust the duration position in 
two ways that have different results.

Dragging the duration bar If you drag the colored area of the duration bar, the trimmed 
footage starts and finishes playing at a different point in time. The length of the play time 
and the frames that appear remain unchanged.

Dragging the dimmed outline If you drag the pale rectangle behind the duration bar, 
the footage starts and ends at the same point in time as the original position, but different 
frames appear. For example, if you drag the pale rectangle to the left, then the In and Out 
points shift to later frames in the footage. (This is similar to a “slip edit” in common editing 
applications.)

Removing a section of a layer
Remove a portion from the middle of one or more layers from the Timeline using the 
following two methods: 

• Lifting removes a section from the layers and leaves a gap of the same duration as the 
section you remove.

• Extracting removes a section from the layers and closes the resulting gap by ripple 
deletion.

To remove a section and leave a gap in time (lift):

1 In the Timeline window, adjust the work area to include only the portion of the layer or 
layers that you want to remove:

• Move the time marker to the time at which you want the work area to begin and press B 
on your keyboard.

• Move the time marker to the point where you want the work area to end, and press N.

2 Turn on the lock switch ( ) for any layers you do not want affected by the extraction.

3 Choose Edit > Lift Work Area to remove the section from all unlocked layers.

Note: If any layers are selected, this procedure affects only those layers.

To remove a section and close the resulting gap (extracting):

1 Follow steps 1 and 2 of the procedure for lifting (above).

2 Choose Edit > Extract Work Area.

Using markers
Use composition-time and layer-time markers to mark important points in a composition or 
in a specific layer. Composition-time markers are numbered, while layer-time markers use 
specified text labels. Markers also make it easier to align layers or the current-time marker 
with specific points in time: You can snap items to markers when you drag them in the 
Timeline window by holding down Shift as you drag.

Layer-time markers can also include a comment, a Web link, or a chapter link. Comments 
appear only in the Timeline window. Web links initiate a jump to a Web page in your 
browser. Chapter links initiate a jump to a chapter in a QuickTime movie or in other 
formats that support chapter marks.
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Creating composition-time markers
Composition-time markers appear on the time ruler in the Timeline window. After Effects 
automatically numbers them with a single digit that reflects the order in which you add 
them. You can place up to ten composition-time markers within a composition. If you 
remove a marker, the other markers remain numbered as they were.

To add a composition-time marker:

Do one of the following:

• Drag from the Time-marker button ( ) above the Timeline vertical scroll bar to the 
desired point in the composition.

• Move the current-time marker to the position you want to mark and press Shift+a 
number key on the main keyboard (not on the numeric keypad). The new composition-
time marker appears at the current-time position, labeled with number of the key you 
pressed.

Note: If the number you press is already used by another composition-time marker, After 
Effects does not create a new marker. Instead, it moves the existing marker with that 
number to the new position.

To move a composition-time marker:

Do one of the following:

• Drag the composition-time marker to another position on the timeline.

• Move the current-time marker to the position you want, and then press the number (on 
the main keyboard, not the keypad) of the composition-time marker you want to move.

To snap the current-time marker or layer duration bars to a marker:

Press Shift as you drag the current-time marker or a layer duration bar.

To remove a composition-time marker:

Drag the marker onto the time-marker button ( ) on the Timeline window above the 
vertical scroll bar.
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Creating layer-time markers
Layer-time markers appear as small triangles on a layer-duration bar. You can have any 
number of layer-time markers in a layer. You can also drag existing markers to new time 
locations or remove them, as needed.

Layer-time markers

To add a layer-time marker:

1 With the appropriate layer selected, move the current-time marker to the frame you 
want marked.

2 Choose Layer > Add Marker.

3 Double-click the layer-time marker.

4 In the Marker dialog box, type a name or comment in the Comment box and click OK.

To remove a layer-time marker:

1 Press Ctrl (Windows) or Command (Mac OS) and move the pointer near the marker you 
want to remove.

2 When the pointer appears as a pair of scissors, click the layer-time marker.

Creating Web links from markers
When you create a marker, you can type a Uniform Resource Locator (URL) under Web 
Links in the Marker dialog box to create an automatic link to that site. After Effects embeds 
this information within movies. When these movies are included in Web pages created by 
programs such as Adobe GoLive, the embedded URL is recognized at playback, initiating a 
jump to the specified URL. You can even target a specific frame within the site.

Web link markers work only with layer-time markers and supported output formats, such 
as QuickTime, Macromedia Flash (SWF), and others.

To create a Web link: 

1 Create a layer-time marker and then double-click it to open the Marker dialog box.

2 For Web Links, type the URL for the site.

3 To activate a specific frame in a site, type the filename of the frame for Frame Target and 
click OK.

To view or modify information for a Web link: 

1 Double-click a layer-time marker.

2 In the Marker dialog box, view the information and make any changes you want; then 
click OK.



Using Help | Contents | Index Back 86  

Adobe After Effects Help Managing Layers 

Using Help | Contents | Index Back 86  

Creating chapter links
You can also create a layer-time marker as a chapter reference point, similar to chapters 
used in CD-ROM and DVD discs. Like the chapters of a book, a chapter link divides a movie 
into segments. Chapter links are supported in QuickTime movies.

To create a chapter link: 

1 Create a layer-time marker and then double-click it to open the Marker dialog box.

2 For Chapter Links, type the chapter name and number (if available), and click OK.

Nesting compositions containing layer-time markers
If you add one composition to another, the original composition becomes a layer in the 
parent composition. All the nested composition’s composition-time markers become 
layer-time markers in the Timeline window of the parent composition. These markers are 
not linked to the original composition-time markers: Changes you make to the compo-
sition-time markers in the original composition do not affect layer-time markers in the 
nested composition. For example, if you remove one of the original composition-time 
markers, the corresponding layer-time marker for the nested composition remains in 
place. For more information about nesting, see “Organizing a project using nesting” on 
page 265.

Adding markers synchronized to audio
After Effects provides a quick way to add and label markers for significant points in a 
layer’s audio track, such as a rhythmic beat in music or spoken words in dialogue. Once 
markers are created, you can use them to synchronize video or other effects.

To synchronize markers to dialogue:

1 In the Time Controls window, select the Audio button ( ) and then click the RAM 
preview button ( ).

2 At the points in time where you want to add a marker, press the asterisk key (*) on the 
numeric keypad to create a layer marker.

3 When previewing is complete, double-click a marker you just created, type a 
descriptive label in the Comment box (such as a word being spoken at that time), and click 
OK. Repeat for any other markers you added.

About After Effects Audio/Video switches
The Timeline window contains the Audio/Video Features and the Switches panels. By 
default, these panels appear to the left (A/V Features) and right (Switches) sides of each 
layer name, but you can hide a panel or arrange panels in a different order. For general 
information about using panels, see “Default controls and panels” on page 66 and 
“Optional panels” on page 66.

Use the switches to adjust the balance between display performance and display quality 
during your work session, clicking switch icons for individual layers to turn them off or on. 
You can also control them for selected layers by choosing Layer > Switches > command. 
Check marks next to commands indicate that those switches are currently turned on.
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The A/V Features panel includes the Video ( ), Audio ( ), Solo ( ), and Lock ( ) switches. 
The Switches panel contains the Shy ( ), Collapse Transformations ( ), Quality ( ), Effects 
( ), Frame Blending ( ), Motion Blur ( ), Adjustment Layer ( ), and 3D Layer ( ) switches.

Quickly change switches for multiple layers by clicking the switch for one layer and 
dragging up or down that column for the adjacent layers.

By default, the layer Switches panel shares space in the Timeline window with the Transfer 
Modes panel (see “Using layer modes” on page 166), so one or the other is visible—but 
not both. You can toggle between the two panels or show both panels simultaneously.

To toggle between the layer Switches panel and the transfer Modes panel:

Click Switches/Modes at the bottom of the panel in the Timeline window.

Note: The Expand or Collapse button ( ) at the bottom of the layer names panel hides 
and reshows the Switches/Modes panel. If you do not see the Switches/Modes button, click 
the Expand or Collapse button.

To display both the Switches and Transfer Modes panels:

1 Click the right arrow above the Timeline window vertical scroll bar to open the Timeline 
window menu.

2 Choose Panels > Modes (if Modes is not checked) or Panels > Switches (if Switches is 
not checked).

When you set switches in a composition with other compositions nested within it, After 
Effects also applies those switches to the subordinate compositions. These settings 
include the Quality, Collapse Transformations, Motion Blur, and Frame Blending switches.

If you do not want the switch settings you add to parent compositions to apply to the 
compositions nested within them, change that at the Preferences level.

To prevent switches from operating through nested compositions:

1 Choose Edit > Preferences > General.

2 Deselect the Switches Affect Nested Comps option, and click OK.

Altering appearances on the layer level
Use switches to make changes at the layer level that affect the appearance of your final 
output. These switches include Collapse Transformations/Continuously Rasterize, Quality, 
Motion Blur, hiding or showing effects, Frame Blending, and 3D. Using the switches, you 
can specify the balance you want between the way the image looks and rendering time.

For information about changing only the appearance on your screen while you work 
without changing final output, see “Customizing layer work and views” on page 78.

Collapsing transformation properties
The Collapse Transformations/Continuously Rasterize layer switch ( ) in the Timeline 
window affects nested compositions and Adobe Illustrator files. However, it affects these 
layers differently.

When the layer source is a composition, this switch acts as the Collapse Transformations 
switch. Selecting it may improve image quality and decrease viewing and rendering time. 
You cannot select this switch if a mask or effect is applied to the layer.
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When the layer source is an Adobe Illustrator file, this switch acts as the Continuously 
Rasterize switch. Selecting this switch causes After Effects to rerasterize the Illustrator file 
for each frame, which improves image quality but also increases the time required for 
previewing and rendering.

You cannot apply masks and some effects to a layer when the Collapse Transformations/
Continuously Rasterize switch is active. If you want to apply an effect to a layer that uses 
this switch, either apply an adjustment layer higher up in the stacking order (see “Creating 
an adjustment layer” on page 73), or nest or precompose the layer with the switch applied 
and then apply the effect or mask. See “Importing an Adobe Illustrator, PDF, or EPS file” on 
page 35.

To collapse transformations or change the rasterization method for a layer:

Do one of the following:

• In the Timeline window, click the Collapse Transformations/Continuously Rasterize 
switch.

• Select a layer, choose Layer > Switches, and make sure that the Collapse command is 
selected (to turn it on), or deselected (to turn it off ).

Changing the layer image quality
You can select three levels of quality for the layer image: Best, Draft, and Wireframe. A 
higher quality setting shows more detail at higher resolution, but at the expense of redraw 
and rendering speed. The three levels of quality are as follows:

• Best quality displays and renders a layer using subpixel positioning, anti-aliasing, 
3D shading, and complete calculation of any applied plug-in effects. Best provides the 
slowest display and rendering time.

• Draft quality displays a layer so that you can see it, but only at rough quality. It displays 
and renders a layer without anti-aliasing and subpixel positioning, and some effects 
are not precisely calculated. Draft quality is often the most useful setting for general 
work and for video layers (to avoid blurring when matching compositions to raw video 
footage).

• Wireframe quality represents a layer as a box with an X across it. Layer wireframes 
display and render faster than other settings. However, layer contents or masks are not 
visible—only position and size. Because of this limitation, wireframe quality is available 
only from the Layer menu.

To change the layer image quality:

With the layer selected in the Timeline window, choose Layer > Quality, and choose Best, 
Draft, or Wireframe.

Showing and hiding applied effects
Using the Effect switch, you can control whether a layer’s effects appear in both previews 
and rendered versions. When you deselect this switch, the layer is displayed and rendered 
without its effects, saving previewing and rendering time. This switch is available only if a 
layer has effects applied to it.

To show or hide all effects applied to one layer:

Do one of the following:
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• In the Timeline window, click the Effect switch icon for a layer to toggle between 
showing and hiding effects.

• Select a layer, choose Layer > Switches, and make sure that the Effect command is 
selected (to show effects) or deselected (to hide effects).

You can temporarily turn on or off an individual effect applied to a layer. For more infor-
mation, see “Applying and controlling effects” on page 170.

Enhancing time-altered motion by blending frames
When you time-stretch (see “Time-stretching a layer” on page 139) or time-remap (see 
“About time-remapping” on page 142) footage to a slower frame rate or to a rate lower 
than that of its composition, movement can appear jerky. This jerky appearance results 
because the layer now has fewer frames per second than the composition. By default, 
After Effects fills in the missing frames in slow-motion footage by repeating the last frame 
shown. After Effects can create a more gradual transition between frames by interpolating 
new frames between existing ones.

When you time-stretch or time-remap footage to a frame rate that is faster than the 
original or higher than that of its composition, After Effects skips many of the original 
frames to achieve the new rate and, consequently, movement can appear jerky. Frame 
blending combines the remaining original frames to create smoother fast motion.

Using frame blending
Use the Frame Blending switch when motion already exists in the source footage for a 
layer, such as live-action video. You can apply frame blending to a sequence of still images, 
but not to a single still image. If you are animating a layer—for example, moving a layer of 
type across the screen—use the motion blur switch. For more information, see “About 
motion blur” on page 90.

Frame blending slows previewing and rendering. To speed things up, you can apply frame 
blending without using it to redraw or render. The Quality setting you select also affects 
frame blending. When the layer is set to Best quality, frame blending results in smoother 
motion but may take longer to render than when set to Draft quality. You can also enable 
frame blending for all compositions when you render a movie. For more information, see 
“Changing render settings” on page 281.

To apply frame blending to a layer:

Select the layer in the Timeline window and choose Layer > Switches > Frame Blending.

A check mark by the Frame Blending command indicates that it is applied to the selected 
layer. Also, the Frame Blending switch ( ) appears in the Timeline window Switches panel 
for the layer. Remove frame blending either by clicking the Frame Blending switch or by 
choosing the Frame Blending command again.

To enable or disable Frame Blending for redraw and rendering:

Select Enable Frame Blending from the Timeline window menu, or click the Enable Frame 
Blending button ( ) at the top of the Timeline window.

Using three dimensions
Use the 3D switch ( ) to turn a layer into a 3D item that you can manipulate. When you use 
the 3D switch for a layer, you can add camera and light layers to take full advantage of the 
additional dimension.
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For more information, see “Using cameras” on page 235 and “Using lights” on page 239.

About motion blur
When you view one frame of motion-picture film or video containing a moving object, the 
image is often blurred. This is because a frame represents a sample of time (in film, a 
sample is 1/24 of a second long). In that time, a moving object occupies more than one 
position as it travels across the frame, so it cannot be shown as a sharp, still object. The 
faster the object moves, the more it blurs. The camera shutter angle also affects the 
appearance of the blur.

In contrast, in a single frame of a computer-generated animation, you may not be able to 
tell which objects are moving because all moving objects may appear as sharp and clear 
as nonmoving objects. Without motion blur, layer animation produces a strobe-like effect 
of distinct steps instead of an appearance of continuous change. Adding motion blur to 
layers you animate in After Effects makes layer motion appear smoother and more natural.

You can use motion blur when you animate a layer—for example, moving a layer of text 
across the screen. You cannot add motion blur to motion that already exists within a layer, 
such as live-action video. If you want to smooth live-action video where you assigned a 
frame rate much lower or higher than the original, use frame blending. See “Enhancing 
time-altered motion by blending frames” on page 89 and “Using frame blending” on 
page 89.

Note: Previous versions of After Effects included an effect called Motion Blur. That effect is 
now named Directional Blur, to avoid confusion with motion blurring applied to layers.

Applying motion blur to layers
The Motion Blur switch creates a true motion blur based on the layer’s movement in a 
composition and what you specify for the shutter angle and phase (see “Adjusting the 
shutter angle for motion blur” on page 91).

Note: For information about the Directional Blur effect (called “the Motion Blur effect” in 
earlier versions of After Effects), see “Blur and sharpen effects” on page 186.

Motion Blur slows previewing and rendering, but you can apply motion blur without 
displaying it in the Composition window. Use the Enable Motion Blur button ( ) near the 
top of the Timeline window to control whether layers that use motion blur affect redraw 
and rendering. You can also enable motion blur for all compositions when you render a 
movie. For more information, see “Changing render settings” on page 281.

To apply motion blur to a layer:

Select the layer or composition you want to blur in the Timeline window, and choose Layer 
> Switches > Motion Blur.

You can also apply motion blur by clicking the Motion Blur switch to place a checkmark for 
that layer.

Note: A checkmark by the Motion Blur command indicates that motion blurring is turned 
on for the selected layer or composition. The checkmark also appears in the Motion Blur 
switch ( ) for that layer in the Timeline window.
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Adjusting the shutter angle for motion blur
Adjust the intensity of motion blur by changing the shutter angle setting. The shutter 
angle is measured in degrees, simulating the exposure allowed by a rotating shutter. If you 
are not applying motion blur, shutter angle has no effect.

The shutter angle uses the footage frame rate to determine the simulated exposure. For 
example, typing 90 degrees (12.5% of 720 degrees) for 24-fps footage creates an effective 
exposure of 1/96 of a second (25% of 1/24 of a second). Typing 1 degree applies almost no 
motion blur, and typing 720 degrees applies a high degree of blur. By default, the shutter 
angle is set to 180 degrees.

To set the shutter angle and phase for motion blur:

1 Choose Composition > Composition Settings.

2 On the Advanced tab, type a value for Shutter Angle.

3 In Shutter Phase, type a number (up to 360) for when you want the shutter to open 
relative to the frame start (optional) and click OK.

Note: You can also change the shutter angle for a composition in the Render Queue 
window. See “Changing render settings” on page 281.

Using audio layers
In After Effects, you can change volume levels of audio layers, preview them at a specified 
quality, and identify and mark locations. An audio layer contains different properties than 
a video layer, but you modify them the same way. You can apply special audio effects to 
audio layers, and adjust the waveform values.

For information about using markers with audio, see “Adding markers synchronized to 
audio” on page 86.

Previewing audio
When you preview audio, you control the quality and length of the preview. The audio 
preview preferences you set do not affect rendering; the quality or audio in rendered 
video is determined by the output module setting. See “Changing output module 
settings” on page 284.

While previewing audio, After Effects displays clipping signals that indicate when the 
audio is clipping. Clipping is a distortion that occurs when the audio signal exceeds the 
maximum level that the audio device allows.



Using Help | Contents | Index Back 92  

Adobe After Effects Help Managing Layers 

Using Help | Contents | Index Back 92  

After Effects also displays a Volume Unit (VU) meter that actively displays audio levels 
during playback. To view the VU meter and levels controls in more detail, increase the 
height of the Audio palette.

A. Audio clipping warning icons B. VU meter  
C. Level controls D. Level units E. Audio 
Options menu F. Level values

You can also preview audio synchronized with layer motion. For more information, see 
“Previewing animation” on page 118.

To set display options for the Audio palette:

1 In the Audio palette, click the triangle in the upper-right corner and choose Options.

2 In the Audio Options dialog box, select one of the following:

• Decibels to display audio levels as decibels.

• Percentage to display audio levels as a percentage, where 100% equals 0 dB.

3 From the Slider Minimum menu, select the minimum decibel level you want to display 
in the Audio palette, and then click OK.

To set preferences for audio preview:

1 Choose Edit > Preferences > Previews.

2 In the Audio Preview section, type a duration for the audio preview. An audio preview 
begins at the current-time marker and continues for the duration you specify here. This 
option is useful when you are checking short passages of a composition, although you can 
interrupt an audio preview at any time.

3 Choose an audio sample rate from the first menu.

4 Choose an audio sample size from the second menu.

5 Choose Stereo or Mono playback from the third menu.

6 Click OK.

CD-quality sound is 44.1 KHz, 16-bit stereo. However, to reduce the time and memory 
required to preview, you may want to choose a lower bit depth and sample rate.

To preview audio:

1 In the Composition window or Timeline window, move the current-time marker to the 
time where you want the preview to begin.

2 Choose Composition > Preview > Audio Preview (Here Forward), or press the period 
key (.) on the numeric keypad.

A

B

DC

F

E
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To preview audio and rendered images:

1 If the Time Controls palette is not open, choose Window > Time Controls. Click the 
double arrow ( ) on the Time Controls tab, as needed, until you see the RAM Preview 
Options, and then do one of the following:

• If the From Current Time option is selected, then move the current-time marker (in 
either the Composition or Timeline window) to the time at which you want the preview 
to begin.

• If From Current Time is not selected, set the work area for the area you want to preview. 
For more information, see “Setting up a work area” on page 70.

2 On the Time Controls palette, select the Audio button ( ).

3 If needed, click the Loop button repeatedly to select the preview direction you want: 
looping from start to finish ( ), single play (forward) ( ), or cycling forward and backward 
( ).

4 Click the RAM Preview button ( ) or press 0 (zero) on the numeric keypad.

Dragging to preview composition audio
You can preview audio by dragging the time marker. in a composition. Use this technique 
to easily identify and mark a location to synchronize audio and visual effects. Instead of 
using the audio waveform, you can identify a location in the layer by moving the current-
time marker in the Timeline window and listening to audio playback.

To preview composition audio:

In the Timeline window, press Ctrl (Windows) or Command (Mac OS) while you move the 
current-time marker.

As you drag across time, After Effects plays segments of the audio. You can play the audio 
forward or backward. If you stop moving the current-time marker while keeping the 
mouse button depressed, a short section of audio will loop.

Changing volume levels of an audio layer
When you use footage containing audio, the audio level in the footage plays at 0 db, 
meaning that the level is unadjusted in After Effects. Setting a positive decibel level 
increases volume, and setting a negative decibel level decreases volume.

The VU meter in the Audio palette displays the volume range for the audio as it plays. The 
red blocks at the top of the meter represent the limit of what your system can handle. 
When the audio volume extends past the top of the meter, After Effects makes the speaker 
icons red as a warning that audio is clipping. If you don’t lower the level, the audio 
playback may be distorted when rendered. Reset the warning signal to black by clicking 
the red speaker icon.

Adjust the audio level and set level keyframes by dragging the level sliders as you preview 
an audio layer.

To set the volume level of an audio layer in the Audio palette:

1 Select the layer in the Composition window or Timeline window.

2 If the Audio palette is not visible, choose Window > Show Audio. For greater precision 
in setting levels, drag the resize icon in the lower right corner of the Audio palette to 
increase its size.
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3 In the Audio palette, adjust volume in one of the following ways:

• To set the level of the left and right channels together, drag the center slider up or 
down.

• To set the level of the left channel, drag the left slider up or down, or type a new value in 
the levels box at the bottom of the left slider.

• To set the level of the right channel, drag the right slider up or down, or type a new 
value in the levels box at the bottom of the right slider.

Including and excluding audio
You can include or exclude audio in the preview or rendered version, applying this option 
at either the composition or layer level. By default, audio is included.

To include or exclude an audio track from a composition:

Choose Layer > Switches > Audio to remove or add the checkmark by the Audio 
command.

By default, a check mark appears by the Audio command to indicate that audio is included 
for previews and rendering of the selected composition or layer. Audio icons ( ) in the 
Features switches in the Timeline window also indicate whether or not audio is included. 
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Animating Layers

About layer properties
Each layer can contain several sets of properties. Layers that contain video or still images 
have mask and transform properties, such as mask shape or layer rotation. A layer can also 
include other properties, such as time remapping, video effects, and audio effects. 

After Effects provides three ways to animate layer properties. You can animate a layer 
graphically in a Composition or Layer window, by dragging a particular layer property 
value, or by typing numbers into the selected value or a dialog box. Each method is 
slightly different:

• When you animate a layer graphically, you change a value relative to the previous value. 
For example, you move a layer by selecting it at its existing position and then dragging 
it ten pixels to the left.

• When you animate a layer by dragging a particular layer property value, you change a 
value by positioning the pointer over the underlined value and dragging to decrease or 
increase the value.

• When you animate a layer numerically, you change a value by specifying an absolute 
number. For example, you move a layer by typing new coordinate values for the 
Position property. 

Viewing layer properties in the Timeline window
As you add layers to a composition, they appear in the layer outline in the Timeline 
window. You can expand the layer outline to display layer properties and change property 
values. 

Keyboard shortcuts can help you quickly display a layer property, hide others, and save 
space in the Timeline window. For more information, see the After Effects Quick Reference 
Card.

To expand a layer outline heading:

1 Click the triangle to the left of the layer name so that it points downward.

2 Click the triangle to left of Masks, Effects, or Transform to further expand the outline.



Using Help | Contents | Index Back 96  

Adobe After Effects Help Animating Layers 

Using Help | Contents | Index Back 96  

To collapse a layer outline heading:

Click the triangle to the left of the layer name so that it points to the right.

To expand or collapse all layer outline headings:

Select the layer and then press the grave accent (`) key. 

Understanding keyframes
After Effects uses keyframes to create and control animation. (After Effects can also use 
expressions to create and control animation. See “Using expressions” on page 244.) A 
keyframe marks the point in time in a composition where you specify a value for a layer 
property. Animation using keyframes requires at least two keyframes. After Effects creates 
animation between keyframes by interpolating transition frames between each keyframe 
using intermediate values based on the changing property values from one keyframe to 
the next. A keyframe contains information on the type and speed of change between the 
adjacent intermediate values.

Two Position keyframes and the interpolated frames in between create a motion path.

You can modify layer properties with or without setting keyframes. If you do not set 
keyframes, or if you set only one keyframe, changes you make to the property value 
remain in effect for the duration of the layer. 
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Time-vary stopwatch
Each layer property has a time-vary stopwatch icon ( ) that you click to begin the 
animation process. Once the stopwatch is active for a specific property, After Effects 
automatically sets new keyframes whenever you change the current time and the 
property value. When the stopwatch is inactive, no keyframes are present. If you type a 
value for a layer property while the stopwatch is inactive, the value remains in effect for 
the duration of the layer.

A. Selected stopwatch B. Deselected stopwatch

Keyframe navigator
After you set the initial keyframe for a property, After Effects displays the keyframe 
navigator, which you can use to move from keyframe to keyframe or to set or remove 
keyframes. When the keyframe navigator box is selected, the current-time marker lies 
precisely at a keyframe for that layer property. When it is deselected, the current-time 
marker lies between keyframes. When arrows appear on each side of the keyframe 
navigator box, other keyframes for that property exist on both sides of the current time. 
Click the arrows to move to the previous or next keyframe. The keyframe navigator can 
be detached from the A/V Features panel to function as its own panel by choosing 
Panel > Keys from the Timeline window menu.

A. Keyframe at current time B. No keyframe at current time C. No keyframes for layer property

Keyframe icons
The appearance of a keyframe icon depends on the interpolation method you chose for 
the interval between keyframes. When half of the icon is gray, the gray half indicates that 
there is no keyframe adjacent to that side, or that its interpolation is overridden by the 
Hold interpolation applied to the preceding keyframe. See “Comparing interpolation 
methods” on page 123 for more information on the keyframe icons.

A

B

A

B

C
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Change the keyframe icons to numbers by choosing Use Keyframe Indices in the Timeline 
window menu, located on the right side of the window.

Keyframes as indices (numbers)

Setting keyframes
You can set keyframes for any type of layer and any combination of layer properties at any 
point in time. You can also move, delete, or change the value or interpolation method of a 
keyframe. 

This section provides an overview of setting keyframes. For details on setting or changing 
individual layer properties, see the specific sections for each property, for example, 
“Setting layer position” on page 103. For details on animating layer properties, see 
“Setting and animating a layer property in the Timeline window” on page 114.

To set the first keyframe for a layer property:

1 In the Timeline window, select the layer you want to animate, and then display the layer 
property you want to animate.

2 Move the current-time marker to a point in time where you want to add a keyframe.

3 Set the layer property to the value you want at that point in time; for example, move the 
layer to a new position. 

4 Do one of the following:

• Click the stopwatch icon ( ) next to the property name to activate it. After Effects 
creates a keyframe at the current time for that property value.

• Choose Animation > Add x Keyframe, where x is the name of the property you are 
keyframing.

To add additional keyframes for a layer property:

1 In the Timeline window, select the layer you want to animate.

2 Display the layer property for which you want to add a keyframe. It must already 
contain at least one keyframe, and the stopwatch must be activated.

3 Move the current-time marker to the point where you want to add a new keyframe, and 
change the value for the layer property you are animating. After Effects adds a keyframe 
automatically.

To add a keyframe without changing a value:

1 Display the Timeline window for the composition containing the layer you want to 
animate.

2 Display the layer property for which you want to add a keyframe. The property must 
already contain at least one keyframe, and the stopwatch must be activated.
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3 Move the current-time marker to the point where you want to add a new keyframe. If 
the current-time marker is after the last keyframe for that layer property, the new 
keyframe will have the same value as the preceding keyframe. Otherwise, the new 
keyframe’s value will be an interpolated value based on the previous and next keyframe 
values.

4 Do one of the following:

• Click the keyframe check box for the layer property. 

• Choose Animation > Add x Keyframe, where x is the name of the property you are 
keyframing.

Navigating and selecting keyframes
If you want to modify or copy a keyframe, first select it. After Effects provides many 
methods for navigating to and selecting one or more keyframes.

To move the current-time marker to the previous or next keyframe:

Click a keyframe navigator arrow. The arrow to the left moves the current-time marker to 
the previous keyframe. The arrow to the right moves the current-time marker to the next 
keyframe.

To snap the current-time marker to a keyframe:

Press Shift as you drag the current-time marker to a keyframe.

To select a keyframe:

Click the keyframe icon in the Timeline window’s time graph.

To select multiple keyframes:

Do one of the following:

• Press Shift as you click to select multiple contiguous or noncontiguous keyframes.

• Drag a marquee around the keyframes to select contiguous keyframes. 

To select all keyframes for a layer property:

In the layer outline, click the layer property name. For example, click the word “Position” to 
select all the Position keyframes for a layer.

Deleting keyframes
If you make a mistake while setting keyframes, or if you decide a keyframe is no longer 
needed, you can easily delete one or more keyframes from a layer.

To delete a keyframe:

1 Select a keyframe. See “Navigating and selecting keyframes” on page 99.

2 Press Delete on the keyboard. Do not press Delete on the keypad (Windows).
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To delete all keyframes of one layer property:

Click the stopwatch icon to the left of the name of the layer property to deactivate it.

Note: When you deselect the stopwatch icon, keyframes for that property are permanently 
removed and the value of that property becomes the value at the current time. You cannot 
restore deleted keyframes by reselecting the stopwatch. If you accidentally delete 
keyframes, choose Edit > Undo.

Moving and copying keyframes
You can easily move keyframes to different points in time or copy them to different layers. 
Moving keyframes makes it easy to change when animations occur. Copying keyframes 
makes it easy to use the same property setting in different layers. You can also copy a 
property value from a layer that contains no keyframes. For more information, see 
“Copying a value from a layer without keyframes” on page 102.

Note: To copy an entire layer, including the source footage and keyframes, see “Dupli-
cating a layer” on page 74.

Moving keyframes
You can move any keyframe to a different point in time. When you move keyframes, you 
move the values and settings they contain. 

To move a keyframe to another time:

Drag one keyframe icon to the desired time.

To move multiple keyframes to another time:

1 Select the keyframes you want to move. See “Navigating and selecting keyframes” on 
page 99.

2 Drag any selected keyframe icon to the desired time. All of the other selected 
keyframes maintain their relative distance from the keyframe you drag.

To expand or contract a group of keyframes:

1 Select at least three keyframes. See “Navigating and selecting keyframes” on page 99.

2 Hold down Alt (Windows) or Option (Mac OS) and drag the first or last selected 
keyframe to the desired time.

To move a keyframe precisely to a different time:

1 Move the current-time marker to the desired time.

2 Hold down Shift after you begin to drag a keyframe icon to the current-time marker. 
When you drag over the current-time marker, the keyframe snaps to the current-time 
marker.

Copying and pasting keyframes
To use the same keyframe values at another point in time or in another layer, copy and 
paste them. You can copy keyframes between layers for the same property (such as 
Position) or between different properties that use the same type of data. The keyframe 
properties you can copy between include the following:
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• Properties within the same dimension, for example, Opacity and Rotation, which have 
adjustable parameters in one dimension; or Mask Feather and 2D scale, which have 
adjustable parameters in two dimensions

• Rotation, effect angle control, and effect slider control properties

• Effect color properties

• Mask properties and spatial properties (effect points, Anchor Points, etc.).

You can copy keyframes from only one layer at a time. When you paste keyframes into 
another layer, they appear in the corresponding property in the destination layer. The 
earliest keyframe appears at the current time, and the other keyframes follow in relative 
order. The keyframes remain selected after pasting, so you can immediately move them in 
the destination layer. 

Note: When copying and pasting between the same properties, you can copy from more 
than one property to more than one property at a time. However, when copying and 
pasting to different properties, you can copy only from one property to one property at a 
time.

To copy and paste keyframes:

1 In the Timeline window, display the layer property containing the keyframes you want 
to copy. 

2 Select one or more keyframes. See “Navigating and selecting keyframes” on page 99.

3 Choose Edit > Copy.

4 In the Timeline window containing the destination layer, move the current-time marker 
to the point in time where you want the keyframes to appear.

5 Do one of the following:

• To paste to the same property of the copied keyframes, select the destination layer. 

• To paste to a different property from the copied keyframes, select the destination 
property.

6 Choose Edit > Paste.

Moving a layer duration bar independently of its keyframes
Once you set keyframes, they maintain their position relative to their layer’s duration bar. If 
you move the duration bar earlier or later in the composition, its keyframes move with it. 
You can prevent this by cutting and pasting keyframes. 

To move keyframes without moving the layer duration bar, select the keyframes and drag 
them. See “Moving keyframes” on page 100. You can also change the displayed frames of a 
trimmed layer without moving either its keyframes or the layer duration bar. See “Moving 
a trimmed layer in time” on page 83.

To move a layer duration bar but not its keyframes:

1 Make a note of the time at which the first keyframe appears.

2 In the layer outline, click the name of one or more layer properties containing the 
keyframes you want to keep at the same times.

3 Choose Edit > Cut.

4 Move or stretch the layer duration bar to its new In and Out points.
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5 Move the current-time marker to the time at which the first keyframe appeared before 
you cut the keyframes.

6 Choose Edit > Paste.

Copying a value from a layer without keyframes
You can copy the current value of a layer property to another layer, even when the original 
layer contains no keyframes. This can save you the time of having to set up a property the 
same way on various layers.

To copy a value from a layer without keyframes:

1 In the Timeline window, display the layer property containing the value you want to 
copy.

2 Click the I-beam icon for the layer property to select it.

3 Choose Edit > Copy.

4 Select the layer into which you want to paste the value.

5 If the target layer contains keyframes, move the current-time marker to the time where 
you want to paste the value. If the target layer does not contain keyframes, the new value 
applies to the entire duration of the layer.

6 Choose Edit > Paste.

Changing several keyframe values at once
You can change the values of multiple keyframes on multiple layers at one time; however, 
all the selected keyframes must belong to the same layer property. The way the values 
change depends on how you make the change:

• If you change a value numerically, all selected keyframes use the new value exactly. In 
other words, you make an absolute change. For example, if you select several Position 
keyframes on a motion path and numerically specify a Position value for one of them, 
all selected keyframes move to the same position.

• If you change a value graphically in the Composition or Layer window, all selected 
keyframes change using the difference between the old and new values, not the values 
themselves. In other words, you make a relative change. For example, if you select 
several Position keyframes on a motion path and then drag one of them 10 pixels to the 
left, they all move 10 pixels to the left of their original positions.

You can also change the value of several layers at once by parenting them. For information 
on parenting layers, see“Understanding parent layers” on page 113.
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To set multiple keyframes to the same value:

1 Select the keyframes you want to change. See “Navigating and selecting keyframes” on 
page 99. All keyframes you select must be for the same property.

2 Change the value of any selected keyframe.

Determining where to set and modify keyframes
You can freely change any keyframe attribute. Because After Effects provides more than 
one view of a keyframe, where you modify it depends on what you want to do as well as 
the type of keyframe and layer property. All layer properties are temporal—they can 
change the layer over time. Some layer properties, such as Position, are also spatial—they 
can move the layer across composition space. You modify some attributes of a spatial layer 
property in different windows than you do temporal properties. See “Comparing interpo-
lation methods” on page 123.

Before you make any changes to a keyframe, make sure that the current-time marker is 
positioned at an existing keyframe. If you change a property value when the current-time 
marker is not at an existing keyframe, After Effects adds a new keyframe. However, if you 
double-click a keyframe to modify it, the current-time marker location is not relevant, nor 
is it relevant when you change a keyframe’s interpolation method. See “Comparing inter-
polation methods” on page 123.

Note: You can also copy and paste keyframes into a tab-delimited spreadsheet appli-
cation, such as Microsoft Excel, and modify the values. This method works for all keyframe 
types except masks and some effects properties. 

Setting layer position
Every layer appears at a specific position in the Composition window. You determine the 
initial position when you add a layer to a composition. You can move the layer in the 
Composition window, in the Timeline window, or by using keys on your keyboard. For 
information on layer coordinates, see “Info palette” on page 23.

When you animate position values, After Effects displays the movement as a motion path. 
(For information on animating position values, see “Setting and animating a layer property 
in the Timeline window” on page 114.) The position motion path displays in the Compo-
sition window. The anchor point motion path displays in the Layer window. A motion path 
appears as a sequence of dots, where each dot marks the position of the layer at each 
frame. An X in the path marks the position of a keyframe. The density of dots between the 
Xs indicates the layer’s relative speed. Dots close together indicate a slower speed; dots 
farther apart indicate a greater speed.

To move a layer by dragging in the Composition window:

In the Composition window, drag the layer to a new location. 

If you have difficulty selecting a layer in the Composition window, first select it in the 
Timeline window, and then drag it in the Composition window. Make sure that you do 

not drag the layer by its layer handle.

To move a layer precisely:

To move a layer by a specific amount, do one of the following:
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• To nudge a layer by 1 pixel at the current magnification, press the Left, Right, Up, or 
Down arrow key.

• To nudge a layer by 10 pixels at the current magnification, hold down Shift as you press 
the Left, Right, Up, or Down arrow key.

• To constrain horizontal and vertical movement while dragging a layer, press Shift after 
you start dragging the layer in the Composition window.

• To snap the edge of the layer to the edge of the Composition window frame, press 
Alt+Shift (Windows) or Option+Shift (Mac OS) after you start dragging the layer in the 
Composition window.

Modifying a motion path
You can modify a motion path either by changing an existing keyframe or adding a new 
keyframe. A motion path is less complex and generally easier to modify when you use 
fewer keyframes to describe the path. If you want to add a new keyframe to a motion path, 
make sure that the current-time marker is positioned at the time you want the new 
keyframe to occur. If you want to change an existing keyframe, make sure that the current-
time marker is positioned at the existing keyframe; otherwise, After Effects adds a new 
keyframe. For information on controlling speed on a motion path, see “Controlling speed 
along a motion path” on page 132.

The motion-path controls you see in the Composition window depend on the options 
selected in the Composition window menu. For maximum control over the shape of a 
motion path, use the pen tools and the spatial interpolation methods that After Effects 
provides. See “Comparing interpolation methods” on page 123 and “Applying Bezier inter-
polation graphically” on page 127.

A. Layer handle B. Layer keyframe C. Direction handle on direction line  
D. Composition window menu E. Layer path

To move a position keyframe:

1 Display the Timeline and Composition windows for a composition.

2 In the Timeline window, select the layer you want to modify.

A

D

B C

E
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3 Press P to display the Position property for the layer.

4 If you cannot see the keyframe you want to modify in the Composition window, move 
the current-time marker in the Timeline window to the keyframe.

5 In the Composition window, use the pointer tool to drag a keyframe marker or its 
control handles on the motion path to a new position.

Note: The current-time marker does not need to be located on a keyframe before you drag 
it.

To add a position keyframe by moving the layer:

1 Display the Timeline and Composition windows for a composition.

2 In the Timeline window, select the layer you want to modify.

3 Press P to display the Position property.

4 In the Timeline window, move the current-time marker to the time where you want to 
add a new keyframe.

5 Move the layer by dragging it in the Composition window or by changing its Position 
property value.

To add a keyframe using the pen tool:

1 Display the Timeline and Composition windows for a composition.

2 Select the layer you want to modify.

3 Select the pen tool ( ) or pen + tool ( ) from the toolbox.

4 In the Composition window, move the pen tool over the motion path where you want 
to add the new keyframe and click to add the keyframe. 

A new keyframe appears at the frame you clicked, on the motion path and in the Timeline 
window. To move the keyframe, use the selection tool.
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To move all points on a motion path in unison:

1 Display the Composition and Timeline windows for a composition.

2 In the Timeline window, select the layer containing the motion path you want to move.

3 Press P to open the Position property.

4 Click the word “Position” to select all Position keyframes.

5 In the Composition window, click a keyframe and drag the path to a new position.

Changing the number of visible motion-path keyframes
By default, After Effects displays motion path keyframes and dots in the Composition 
window that fall within a 15-second range from the current-time marker. However, you 
can change this default. For greater precision when extensively modifying a motion path, 
you can display more keyframes. If you want to speed up screen updates, you can display 
fewer keyframes.

To change the number of visible motion-path keyframes:

1 Choose Edit > Preferences > Display.

2 In the Motion Path section of the Display Preferences dialog box, select one of the 
following options, and then click OK:

• Click No Motion Path to prevent the display of a motion path and its keyframes.

• Click All Keyframes to display every keyframe in the window.

• Click No More Than __ Keyframes to specify a maximum number of keyframes to 
display, centered on the current-time marker.

• Click No More Than __ to specify a range of time within which keyframes display, 
centered on the current-time marker.

Using Motion Sketch to draw a motion path
You can draw a path for the motion of a selected layer using Motion Sketch, which records 
the position of the layer and the speed at which you draw. As you create the path, After 
Effects generates a position keyframe at each frame, using the frame rate specified in the 
composition. 

Motion Sketch does not affect keyframes that you have set for other properties. For 
example, if you set rotation keyframes for an image of a ball, you can use Motion Sketch to 
generate position keyframes, so that the ball appears to roll along the path you created.

For a more fluid animation after you create a motion path using Motion Sketch, use the 
Smoother to eliminate unnecessary keyframes. See “Smoothing motion and velocity” on 
page 107 for information on using the Smoother.



Using Help | Contents | Index Back 107  

Adobe After Effects Help Animating Layers 

Using Help | Contents | Index Back 107  

To sketch a motion path:

1 In the Composition or Timeline window, select the layer for which you want to sketch a 
motion path.

2 In the Timeline window, set the work-area markers to the area in which you want to 
sketch motion.

3 Choose Window > Motion Sketch.

4 Select one of the following Motion Sketch options:

• Show Wireframe displays a wireframe view of the layer as you sketch the motion path. 
In addition, you can see any rotation or scaling that you have applied to the layer.

• Keep Background displays the contents of the Composition window while you sketch. 
This is useful if you want to sketch motion relative to other images in your composition. 
After Effects does not show the animation of other layers, however; while you sketch, 
After Effects displays only the first frame at the time you start sketching. If you do not 
select this option, After Effects displays the motion path as a series of white dots on a 
black background.

5 If the composition contains audio, choose Window > Time Controls and click the Audio 
button to play all audio in the composition as you sketch. 

6 For Capture Speed At, set the capture speed of the motion by specifying a percentage 
for how fast the motion plays back in relation to how fast you draw the path. Set the 
playback speed in one of the following ways:

• To set the playback speed to the exact speed at which you sketch, set the capture speed 
to 100%. 

• To set the playback speed faster than the sketching speed, set the capture speed 
greater than 100%. 

• To set the playback speed slower than the sketching speed, set the capture speed less 
than 100%. 

7 Click Start Capture and then, in the Composition window, drag the layer to create the 
motion path. Release the mouse button to end the path. 

Note: After Effects automatically ends the motion path when the capture time reaches the 
end of either your composition or the work area.

Smoothing motion and velocity
Smooth motion paths, value curves, and velocity curves to eliminate bumpiness or excess 
keyframes using The Smoother, which adds keyframes or removes unnecessary keyframes. 
(You can also use the smooth expression to accomplish this. See “Property attributes and 
methods” on page 262.)

Although you can smooth a curve for any property, The Smoother is most useful when 
applied to curves that have been automatically generated by either Motion Math or 
Motion Sketch, where you may have excess keyframes. Applying The Smoother to 
keyframes that have been set manually may result in unexpected changes to the curve. 
(For information on using Motion Sketch, see “Using Motion Sketch to draw a motion 
path” on page 106.)
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When you apply The Smoother to properties that change spatially (such as position), you 
can smooth only the spatial curve (the curve defined by the motion). When you apply The 
Smoother to properties that change only in time (such as opacity), you can smooth only 
the value and velocity curves (the curve defined by the value or the velocity). 

In addition to adding keyframes or eliminating unnecessary keyframes, The Smoother also 
applies Bezier interpolation at each keyframe when smoothing the temporal curve.

To smooth a spatial or temporal curve:

1 In the Timeline window, either select all the keyframes for a property to smooth the 
entire curve, or select at least three keyframes to smooth only a portion of a curve. 

2 Choose Window > The Smoother.

In the Apply To menu, The Smoother automatically selects Spatial Path or Temporal Graph, 
depending on the type of property for which you selected keyframes in step 1. 

3 Set a value for Tolerance. The units of Tolerance match those of the property you are 
smoothing. New keyframe values will vary no more than the specified value from the 
original curve. Higher values produce smoother curves, but too high a value may not 
preserve the original shape of the curve. 

4 Click Apply and preview the results.

5 If necessary, choose Edit > Undo The Smoother to reset the keyframes, adjust the value 
for Tolerance, and then reapply The Smoother.

Creating motion paths with masks
You can instantly create a motion path from any mask that you draw in After Effects (or 
from a path that you copy from Adobe Illustrator or Adobe Photoshop), by pasting the 
mask or path into a layer’s Position property, a layer’s Anchor Point property, or the effect 
point property of an effect. The assigned keyframes are set to rove in time, except for the 
first and last ones, to create a constant velocity along the mask or path. By default, After 
Effects assigns a duration of 2 seconds to the motion path. Adjust the default duration by 
dragging the first or last keyframe to a new point in time.

To create a motion path from a mask:

1 Do one of the following:

• Select a mask.

• Create and select a path from Adobe Illustrator or Adobe Photoshop. For information 
on creating paths in those products, see the respective User Guides.

2 Copy the mask or path to the clipboard.

3 In the Timeline window, select the destination keyframe property. 

4 Paste the mask or path.



Using Help | Contents | Index Back 109  

Adobe After Effects Help Animating Layers 

Using Help | Contents | Index Back 109  

Setting layer size
By default, a layer appears at 100% of its original size in the Layer window. Change the 
scale of a layer over time by dragging the layer’s handles in the Composition window or by 
changing the Scale property values in the Timeline window. You can scale the layer 
partially or completely outside the frame. When you scale, the layer is scaled around its 
anchor point. For more information, see “Setting and animating an anchor point” on 
page 111.

To scale a layer by dragging in the Composition window:

Do one of the following:

• To scale proportionally, hold down Shift as you drag any layer handle.

• To scale freely, drag a corner layer handle.

• To scale one dimension only, drag a side layer handle.

To scale a layer by nudging it 1%:

Select a layer and then hold down Alt (Windows) or Option (Mac OS) as you press + or – on 
the numeric keypad. 

To scale a layer by nudging it 10%:

Select a layer and then hold down Alt+Shift (Windows) or Option+Shift (Mac OS) as you 
press + or – on the numeric keypad. 

Flipping a layer using Scale property keyframes
You can flip a layer using the numerical Scale option. A layer flips around its anchor point, 
so if you move the anchor point away from the center of the layer, it may move when you 
flip it. For more information, see “Setting and animating an anchor point” on page 111.

To flip a layer by dragging in the Composition window:

Drag a layer handle over and past the layer’s anchor point.

To flip a layer numerically:

1 In the Timeline window, select the layer you want to modify.

2 Expand the layer outline to display the Scale property (under Transform) or press S.

3 Click the underlined Scale value.

4 In the Scale dialog box, deselect Preserve Frame Aspect Ratio.

5 Do one of the following and then click OK:

• To flip horizontally, type a negative Width value.
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• To flip vertically, type a negative Height value.

A. Width 100, Height 100 B. Width -100, Height 100 C. Width 100, Height -100  
D. Width -100, Height -100

Setting layer opacity
By default, a layer is displayed at full opacity except for areas excluded by a mask or alpha 
channel. Make a layer more transparent by setting an opacity value of less than 100%. Set 
and change opacity only in the Timeline window. For information on setting a property in 
the Timeline window, see “Setting and animating a layer property in the Timeline window” 
on page 114. 

Setting layer rotation
A layer can rotate any number of degrees in relation to its original orientation. You can 
rotate a layer as many times as you want, which is useful when you want to spin an object 
continuously over time. You can animate a layer’s rotation in the Composition window 
using the rotation tool, or in the Timeline window by typing a revolution or degree value. 
You can rotate a layer partially or completely outside the frame. Rotation in 3D adds other 
options for rotation. See “Understanding 3D rotation” on page 232.

When you rotate a layer, it rotates around its anchor point. For more information, see 
“Setting and animating an anchor point” on page 111.

To change the angle of a layer by dragging in the Composition window:

1 Select the rotation tool ( ) from the toolbox.

2 In the Composition window, click anywhere on the layer and drag in an arc around the 
layer. For finer control over rotation, drag in a wide arc away from the layer’s anchor point. 
To add multiple rotations, drag the rotation tool around the layer continuously for the 
desired number of rotations. To constrain rotation to 45-degree increments, hold down 
Shift as you drag.

To rotate a selected layer by nudging it 1 degree:

Press + or – on the numeric keypad.

To rotate a selected layer by nudging it 10 degrees:

Hold down Shift as you press + or – on the numeric keypad.

A B C D
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Rotating a layer along a motion path
You can make a layer rotate automatically as it moves along a motion path. For example, if 
you animate a toy airplane careening through the sky, you can apply auto-orient rotation 
to make the plane turn and change direction.

Before applying auto-orient rotation (left) and after (right)

To activate or deactivate Auto-Orient for a layer:

1 Display the Timeline and Composition windows for a composition.

2 In the Timeline window, select the layer you want to modify.

3 Choose Layer > Transform > Auto-Orient.

4 Do one of the following, and click OK:

• To activate Auto-Orient, choose Orient Along Path.

• To deactivate Auto-Orient, choose Off.

Setting and animating an anchor point
After Effects rotates and scales from a layer’s anchor point. By default, the anchor point is 
at the center of a layer. You can move the anchor point to change rotation into revolution, 
making the layer rotate from one end or the other. For example, if you want to animate a 
maraca so it appears to be shaking, you first need to move the anchor point from the 
center of the maraca to the end of the handle. 

With anchor point in center of layer (left), layer rotates around the center. With anchor point moved 
to end of handle (right), layer rotates from one end.

Move an anchor point in the Layer window. As you do so, the selected layer moves in the 
Composition window, so you can view its position in relation to other layers. 
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You can also use the pan behind tool to move a layer’s anchor point without moving the 
layer’s relative position in the Composition window. When you select a layer in either the 
Composition or Timeline window and then select the pan behind tool, that layer’s anchor 
point becomes active and adjustable. Again the pan behind tool saves you steps, because 
moving the layer’s anchor point with the selection tool would shift its resulting position in 
the Composition window; using the pan behind tool changes the layer’s position in order 
to compensate for your anchor point adjustment. As a result, you can move the anchor 
point without disturbing the Composition window.

When you use the Pan Behind tool to move the anchor point in the Composition window (left), After 
Effects automatically compensates for the move so that the layer maintains its position relative to 
the Composition window (right).

Note: Because a layer’s Anchor Point and Position properties change when you drag the 
anchor point using the pan behind tool, using the pan behind tool to change the anchor 
point of a moving layer alters the motion path. If your layer contains a motion path, move 
the anchor point in the Layer window, and then select the motion path and adjust it 
accordingly.

To move the anchor point by dragging in the Layer window:

1 In the Composition or Timeline window, double-click the layer you want to modify or 
select the layer and choose Layer > Open Layer Window.

2 Choose Anchor Point Path from the Layer window menu at the top right of the Layer 
window. The anchor point appears as a circle with an X through it.

3 Drag the anchor point to a new location.

To move a layer anchor point by nudging it 1 pixel at the current magnification:

1 In the Timeline window, double-click the layer.

2 In the Layer window, select Anchor Point Path from the Layer window menu.

3 Press the Left, Right, Up, or Down arrow key.

To move a layer anchor point by nudging it 10 pixels at the current magnification:

1 In the Timeline window, double-click the layer.

2 In the Layer window, select Anchor Point Path from the Layer window menu.

3 Hold down Shift as you press the Left, Right, Up, or Down arrow key.

To move a layer’s anchor point using the pan behind tool:

1 Select a layer in either the Composition or Timeline window.

2 Select the pan behind tool.

3 In the Composition window, use the pan behind tool to drag the anchor point to a new 
location. Notice that the Position and Anchor point values change for that layer.
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Understanding parent layers
To assign one layer’s transformations to the transformations of another layer, use 
parenting. Parenting can affect all transform properties except opacity. Assign parent 
layers in the Parent column in the Timeline window. A layer can have only one parent, but 
a layer can be a parent to any number of 2D or 3D layers within the same composition. You 
cannot animate the act of assigning and removing the parent designation. Parenting 
layers is useful for creating complex animations such as linking the movements of a mario-
nette or depicting the orbits of planets in the solar system. 

Dragging the pick whip to designate the car layer as the parent 
to the cloud layer

Once a layer is made a parent to another layer, the other layer is called the child layer. 
Creating a parenting relationship between layers synchronizes the changes in the parent 
layer with the corresponding transformation values of the child layers. For example, if a 
parent layer moves 5 pixels to the right of its starting position, then the child layer will also 
move 5 pixels to the right of its position. You can animate child layers independent of their 
parent layers. You can also parent using null objects, which are hidden layers. See “Using 
null objects” on page 114 for information on null objects.

When you assign a parent, the child layer’s properties become relative to the parent layer 
instead of to the composition. By default, After Effects adjusts the keyframe values of the 
child layer so that its properties appear to remain relative to the composition and, thereby, 
there is no visible alteration to the layer itself. However, you can choose to have the child 
layer jump, or visibly alter its properties relative to the parent layer. For example, consider 
two layers in a composition, where one of the layer’s position property has been changed 
and the other has not. If you assign the unchanged layer as the child of the changed layer 
and do not choose the jump option, then the child layer will not move. If you do choose 
the jump option, then the child layer’s position shifts so that its position is now relative to 
the parent layer.

Alternately, when you remove a parent from a child layer, you can choose to have the child 
layer jump to show that its transform properties are now relative to the composition.

Jumping a layer is useful to depict a change in focus for a particular layer or layers’ 
animation. For example, you could animate one child layer to encircle a parent layer, then 
jump the child to another layer which may be positioned away from the first parent layer. 
The child layer can then encircle the new parent at a position relative to the new parent. 

To show or hide the Parent column:

Choose Panels > Parent from the Timeline window menu.
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To parent a layer:

1 In the Parent column in the Timeline window, do one of the following:

• Drag the pick whip of the layer you want to be the child layer to the layer you want to 
be the parent.

• Click the menu of the layer you want to be the child, and choose a parent layer name 
from the menu.

To remove a parent from a layer:

In the Parent column, click the menu of the layer you want to remove the parent from, and 
choose None.

To make a child layer jump when a parent is assigned or removed:

Hold down Alt (Windows) or Option (Mac OS) as you assign or remove the parent.

Using null objects
If you want to assign a parent layer, but do not want that layer to be a visible element in 
your project, use a null object. A null object is an invisible layer that has all the properties 
of a visible layer, except opacity, so it can be a parent to any layer in the composition. (For 
information on parent layers, see “Understanding parent layers” on page 113.) Adjust and 
animate a null object as you would any other layer. For information on setting layer 
properties, see the section corresponding to the transformation you want to perform; for 
example, to set layer position, see “Setting layer position” on page 103. For information on 
animating layers, see “Setting and animating a layer property in the Timeline window” on 
page 114. Effects are not visible on null objects. 

A composition can contain any number of null objects. A null object is visible only in the 
Composition and Layer windows and appears in the Composition window as a rectan-
gular outline with layer handles.

To create a null object:

Select the Timeline or Composition window and choose New > Null Object.

Note: The anchor point of a new null object layer appears in the upper left corner of the 
layer, and the layer is anchored in the center of the composition at its anchor point. 
Change the anchor point as you would for any other layer. For information on adjusting 
the anchor point, see “Setting and animating an anchor point” on page 111.

Setting and animating a layer property in the Timeline 
window
You can change a keyframe attribute in the Timeline window either by dragging the corre-
sponding underlined transform value or by typing new values in a dialog box. After 
setting an initial keyframe, changing layer values creates animated layers. Follow the 
guidelines below to set and animate any layer property in the Timeline and Composition 
windows.

To set a layer property by dragging in the Timeline window:

1 Select a layer.

2 Expand the layer outline to display the layer Transform properties.
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3 Place the cursor over the underlined value and drag to the left or right to change the 
value. 

To change a layer value numerically in the Timeline window:

1 In the Timeline window, select the layer you want to modify.

2 Display the layer property that you want to change. See the previous section for infor-
mation on displaying layer properties.

3 Do one of the following:

• Click the underlined value that you want to change, type a new value, then press Enter 
(Windows) or Return (Mac OS).

• Right-click (Windows) or Control-click (Mac OS) the underlined value you want to 
change and choose Edit Value. Type new values and click OK.

Note: If you are changing Anchor Point values, note that the anchor point’s coordinates 
are relative to the Layer window, not the Composition window. For information on layer 
coordinates, see “Info palette” on page 23.

To animate a layer property:

1 Display the Timeline and Composition windows for a composition.

2 In the Timeline window, select the layer that you want to animate.

3 Move the current-time marker to the time where you want to begin the animation.

4 Display the layer property that you want to change.

5 Set the layer’s value. See the above procedures “To set a layer property by dragging in 
the Timeline window” or “To change a layer’s value numerically in the Timeline window” 
for information on setting a layer’s value.

6 Set an initial keyframe. For information on setting keyframes, see “Setting keyframes” 
on page 98.

7 Move the current-time marker to the time where you want to add the second keyframe.

8 Change the value for the layer.

9 Repeat steps 7 and 8 as many times as you want to add more keyframes.

Setting and animating mask properties
Masks are paths that you draw or import into a Composition or Layer window to create 
transparent areas for a layer. In the Timeline window, you can set mask shape, mask 
feather, mask opacity, and mask expansion properties and change these properties over 
time. You can also set interactions between different masks within a layer and set the type 
of interaction used between the mask and the layer itself. For information on setting mask 
properties, see the corresponding section for the property you want to set. For example, 
to set the Mask Opacity property, see “Adjusting the opacity of a mask” on page 157. For 
information on animating mask properties, see “Animating a mask” on page 160.
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Setting and animating effects
Once you apply an effect to a layer, you can set keyframes for the effect property values. 
You can also set multiple keyframes to animate effects. The properties available vary 
depending on the effect. For more information on changing and animating effect 
properties, see “Changing effect property values” on page 172 and “Changing effects over 
time” on page 174.

Setting preview options
After Effects provides four options for previewing your animations: RAM preview, standard 
preview, manual preview, and wireframe preview. You can access RAM, standard, and 
manual previews using the Time Controls palette. Access wireframe preview from the 
Composition > Preview menu.

A. First Frame B. Frame Reverse C. Play  
D. Frame Advance E. Last Frame F. Audio  
G. Loop H. RAM Preview I. Jog control  
J. Time indicator K. Shuttle control

The preview options represent different balances between preview quality and speed:

RAM preview This option plays a preview of the frames (including audio) at the frame 
rate of your composition or as fast as your system allows. Use RAM preview to preview the 
footage in the Timeline, Layer, or Footage windows.The number of frames previewed 
depends on the amount of available contiguous RAM allocated to the application. After 
Effects displays the total number of frames requested for the preview and the number it 
can render. 

You have two choices of RAM preview settings: RAM Preview and Shift+RAM Preview. Each 
provides different options. In the Timeline, RAM preview previews only the span of time 
you specify as the work area. In the Layer and Footage windows, RAM preview previews 
only untrimmed footage. Before you preview the Timeline, check which frames are desig-
nated as the work area. See “Setting up a work area” on page 70. Before you preview the 
Layer or Footage windows, check to see that footage you may want to preview has not 
been trimmed.

Audio plays only for layers in which the Audio switch is on. To preview audio alone, see 
“Previewing audio” on page 91.

J
K

I

BA C D E F G H
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Standard preview This option provides a preview of all frames in your composition. 
When you use this option, After Effects displays every frame as quickly as it can using the 
current settings of the layer switches, composition switches, and composition resolution. 
This preview generally plays slower than real time.

Manual preview Using the shuttle control, the jog control, and the current time 
indicator, you can manually navigate through a composition, layer, or footage file. The 
current time indicator shows the position of a frame relative to the beginning and end of a 
composition, layer, or footage file. Because the current time indicator travels only a fixed 
distance in the Time Controls palette, it is less precise with long compositions. 

Wireframe preview This option displays a preview of the frames for all layers in your 
active workspace. Each layer is represented by a rectangle or, if a still-image layer has a 
mask or an alpha channel created in another program, by the outline of the mask or alpha 
channel. 

You can also use the Motion with Trails preview, which preserves the outline of each frame 
of each selected layer so that you can see an outline trail for every frame. See the 
procedure “To use the wireframe preview” in “Previewing animation” on page 118 for 
information on using the Motion with Trails preview.

Setting Video Preview preferences
You can preview the contents of your Layer, Footage, or Composition window on an 
external video monitor if you have a third-party device that facilitates this, such as a video 
digitizing card or a FireWire port. Set the Video Preview preferences to identify the device 
After Effects uses for output and to adjust the display.

To set Video Preview preferences:

1 Choose Edit > Preferences > Video Preview.

2 Set any of the options below, and click OK:

• Choose a device from the Output Device menu. If a device is available, it will appear 
here. 

• Choose a mode from the Output Mode menu. The choices listed here depend on the 
device you are using. The Frame Size and Frame Rate indicators below the menu reflect 
the choices you made in the Output Mode menu and are independent of any After 
Effects setting.

• Select Update Desktop During Video Playback to play the preview simultaneously on 
the computer screen and the external monitor.

• Select a Show Output option. Select During RAM Previews to see all RAM previews on 
the external monitor. Select For All Window Updates to always update the video 
preview on the external monitor. Select Including Renders to view each frame on the 
external monitor as it renders.
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Previewing animation
When you preview a composition in After Effects, the more detail and precision you want 
to see, the more slowly the composition displays in standard preview and the more RAM is 
required for RAM preview. You can control the amount of detail shown in either the 
standard or RAM preview by changing the resolution, magnification, and preview quality 
of your composition. See “Setting resolution” on page 59 and “Changing the layer image 
quality” on page 88.

You can also limit the number of layers previewed by turning off the video switch for 
certain layers, or limit the number of frames previewed by adjusting the composition’s 
work area. See “Hiding layers in the Composition window” on page 80 or “Setting up a 
work area” on page 70. For information on all the previewing shortcuts available, see the 
After Effects Quick Reference card.

After Effects also uses caching and dynamic resolution to facilitate quicker previews and 
Composition window updates whether you’re using RAM preview, advancing sequentially 
or nonsequentially through the frames, or dragging layers in the Composition window. 
Wireframe mode is also available to speed up Composition window updates. See 
“Previewing 3D” on page 242 for information on using Wireframe mode.

To stop any preview before it is complete:

Press the spacebar.

To display the Time Controls palette:

Choose Window > Time Controls.

To use RAM preview:

1 Activate the Timeline window or display a Layer or Footage window, depending on 
which one contains the footage you want to preview.

2 Do one of the following:

• If you are previewing footage in the Timeline, make sure that the video is turned on for 
the layers you want to preview, and set the work area to the time span you want to 
preview.

• If you are previewing footage in a Layer or Footage window, make sure that the layers 
you want to preview have not been trimmed.

3 Click the Audio button ( ) on the Time Controls palette if you want to preview audio 
with video.

4 In the Time Controls window menu, choose Show RAM Preview Options or Show 
Shift+RAM Preview Options.

5 Set the Preview Options as follows:

• For Frame Rate, either choose a desired frame rate from the list or type a frame rate in 
the box. To enter a two-digit frame rate, choose a two-digit frame rate from the list, and 
then change each digit individually. Choose Auto to have After Effects use the compo-
sition frame rate.

• For Skip Frames, type the number of interim frames you want to remain unrendered. 
For example, if you type “2,” After Effects renders the first frame and then each third 
frame following.
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• For Resolution, choose an option from the list. Choose Auto to use the current compo-
sition resolution.

• Select From Current Time to render the RAM preview from the current time.

• Select Full Screen to have the RAM preview play back on a black screen at the compo-
sition size.

6 Do one of the following:

• To have the RAM preview play back using the RAM Preview Options settings, click the 
RAM Preview button ( ).

• To have the RAM preview play back using the Shift+RAM Preview Options settings, hold 
down Shift and click the RAM Preview button ( ).

To change the number of times the RAM preview plays back:

Do one of the following:

• To have the preview play back once, click the Loop button until it displays the loop once 
icon ( ), and then click the Play or RAM Preview button.

• To have the preview loop continuously, click the Loop button until it displays the loop 
icon ( ), and then click the Play or RAM Preview button.

• To have the preview play back forward and then backward continuously, click the Loop 
button until it displays the palindrome icon ( ), and then click the Play or RAM Preview 
button.

To use standard preview:

1 In the Timeline window, make sure that the video switch is selected for the layers you 
want to preview.

2 Move the work-area markers to set the time span you want to preview.

3 Do one of the following:

• Choose Window > Show Time Controls, and then in the Time Controls palette, click the 
Play button ( ).

• Press the spacebar to start; press again to stop.

To use the manual preview options:

Do any of the following:

• To go forward one frame, click the Frame Advance button ( ).

• To go forward ten frames, press Shift as you click the Frame Advance button.

• To go backward one frame, click the Frame Reverse button ( ).

• To go backward ten frames, press Shift as you click the Frame Reverse button.

• To preview with finer precision, drag anywhere along the jog control or drag the time 
indicator or shuttle control ( ). 

• To go to the beginning of the composition, layer, or footage, click the First Frame 
button ( ).

• To go to the end of the composition, layer, or footage, click the Last Frame button ( ).
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To use the wireframe preview:

1 In the Timeline window, select the layers you want to preview. To preview all layers, 
make no selection.

2 Set the work area to the time span you want to preview.

3 Do one of the following:

• Choose Composition > Preview > Wireframe Preview. To display a rectangular layer 
boundary instead of an alpha channel outline, press Ctrl (Windows) or Command (Mac 
OS) as you choose the preview method. 

• Choose Composition > Preview > Motion with Trails. 

About caching
As After Effects displays a frame or compiles a RAM preview, it places each of those 
displayed or compiled frames into a cache. Once the frames are cached, they display or 
play back quicker because they are now playing or displaying from RAM. Currently cached 
frames are designated by green bars in the time ruler. 

When you advance either sequentially or nonsequentially through frames in your compo-
sition, or play back using the Standard Preview option, each of the frames is compiled and 
placed into the cache, and the green bars appear in the Timeline at the point where the 
cached frame occurs. When you compile a RAM preview, the frames you designate to be 
included in the preview are compiled, and the green bars appear in the time ruler to 
indicate which frames were cached. If you make a change to any of the cached frames in 
the composition, the cache purges only the frames affected by that change. You can also 
manually purge the entire cache.

Once the cache is full, and you continue to advance either sequentially or nonsequentially 
through frames in your composition, any additional frame added to the cache replaces the 
earliest cached frame in order to make room for the new frame. When you compile frames 
for RAM previews, once the cache is full, After Effects ceases adding frames to the cache 
and the preview begins playback of only the frames that could fit in the cache. The size of 
the cache is limited to the amount of RAM available to After Effects. The number of frames 
that can occupy the cache depends on the composition settings.

To purge the cache:

Make sure that the Timeline window is selected, and choose Edit > Purge > Image Caches.

About dynamic resolution
As you drag layers in the Composition window, or use the Manual Preview option, After 
Effects dynamically updates each frame in the Composition window. If necessary, After 
Effects dynamically degrades the resolution of the layer. This reduces the amount of data 
that needs to be compiled during the edit and thereby facilitates a smooth, quick update. 
Once the update is complete, the layer returns to the designated composition resolution. 
You can set the maximum level of degradation to apply to a layer.

To set dynamic resolution:

1 Choose Edit > Preferences > Previews.

2 Select the Use Dynamic Resolution option to turn dynamic resolution on or off. 
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To set the degradation limit:

1 Turn on dynamic resolution as outlined in the above procedure.

2 Click the Degradation Limit menu and select an option. The options represent the 
maximum fraction of data removed from a layer’s current composition resolution when 
After Effects enacts dynamic resolution.
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Fine-tuning Animation 

Controlling change through interpolation
After Effects provides several interpolation methods that affect how change occurs 
through and between keyframes. For example, if you are setting up motion, you can 
choose to make a layer change direction abruptly or smoothly through a curve. After 
Effects interpolates values for a change using the values at the keyframes on both ends of 
the change.

You can control temporal interpolation (the interpolation between keyframe values over 
time) for all layer properties. For layer properties that involve movement, such as Position, 
Anchor Point, Effect Point, and 3D Orientation, you can also control spatial interpolation 
(the interpolation between motion-path keyframes through space). 

When you make a layer property vary over time, After Effects records the resulting values 
of temporal interpolation in the Value graph in the Timeline window. If the layer property 
includes spatial interpolation, the resulting values of spatial interpolation are displayed as 
a motion path in either the Composition or the Layer window, depending on the property. 
You can add or delete keyframes in the Value graph or motion path using the pen tool.

Spatial interpolation and the motion path
When you apply or change the spatial interpolation for a property such as Position, you 
adjust the motion path in the Composition window. The different keyframes on the 
motion path provide information about the type of interpolation at any point in time.

Motion path interpolation A. Linear B. Auto Bezier C. Continuous Bezier D. Bezier E. Hold

A B C D E
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Temporal interpolation and the Value graph
Using the Value graph in the Timeline window, you can make precise adjustments to 
the temporal property keyframes you’ve created for your animation. The Value graph 
provides complete information about and control of the value at any point in time in a 
composition. The Timeline window also provides information about the speed of changes 
between values (or speed along a motion path) in the Speed or Velocity graph. See “Using 
the Value graph to change a layer property value” on page 130. 

The Value graph appears when a nonspatial layer property contains two or more keyframes.

Each temporal interpolation method appears as a specific icon, so you can immediately 
see what kind of interpolation is applied to a keyframe. Press Ctrl (Windows) or Command 
(Mac OS) as you click a keyframe icon to switch between Linear and Auto Bezier interpo-
lation. For information on each type of interpolation, see “Comparing interpolation 
methods” on page 123.

Timeline keyframe icons A. Linear B. Linear in, Hold out 
C. Auto Bezier D. Continuous Bezier or Bezier 

Comparing interpolation methods
All interpolation methods provided by After Effects are based on the Bezier interpolation 
method, which provides direction handles so that you can control the transitions between 
keyframes. Interpolation methods that don’t use direction handles are constrained 
versions of Bezier interpolation, and are convenient for certain tasks.

To learn more about how different temporal interpolation methods affect layer properties, 
experiment by setting up at least three keyframes with different values for a temporal 
property such as Rotation, and change the interpolation methods for all keyframes as you 
view the Value graph in the Timeline window.

To learn more about how different spatial interpolation methods affect a motion path, 
experiment by setting up three keyframes for Position with different values on a motion 
path, and change the interpolation methods as you view the motion path in the Compo-
sition window. For more information, see “Determining where to set and modify 
keyframes” on page 103 and “Adding keyframes to a Value graph” on page 130.

A B C D
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In the following descriptions of interpolation methods, the effect of each method is 
described as if you had applied it to all the keyframes for a layer property. This is done to 
clarify the examples. In practice, you can apply any available interpolation method to any 
layer property keyframe.

No interpolation
No interpolation is the state in which there are no keyframes for a layer property—when 
the stopwatch is turned off and the I-beam icon ( ) displays in the Timeline window under 
the current-time marker. In this state, when you set the value of a layer property, it 
maintains that value for the layer’s duration, unless overridden by an expression. By 
default, no interpolation is applied to a layer property. If any keyframes are present for a 
layer property, some kind of interpolation is in use. Removing all keyframes from a layer 
property also removes all interpolation methods from the layer property.

Linear interpolation
Linear interpolation creates a uniform rate of change between keyframes, adding a 
rhythmic or mechanical look to animations. After Effects interpolates the values to the 
next keyframe as directly as possible without accounting for the values of other 
keyframes.

If you apply Linear temporal interpolation to all keyframes of a layer property, change 
begins instantly at the first keyframe and continues to the next keyframe at a constant 
speed. At the second keyframe, the rate of change switches immediately to the rate 
between it and the third keyframe. When the layer reaches the final keyframe value, 
change stops instantly. In the Value graph, the graph segment connecting two Linear 
keyframes appears as a straight line.

If you apply Linear spatial interpolation to all keyframes of a motion path, After Effects 
creates a straight line between each keyframe. At each Linear keyframe where a change 
of direction occurs, the motion path forms a corner. For example, you might use Linear 
spatial interpolation to create the path of a pinball. The speed of motion along the path is 
controlled by the temporal interpolation applied at each keyframe.

Auto Bezier interpolation
Auto Bezier interpolation creates a smooth rate of change through a keyframe. You might 
use Auto Bezier spatial interpolation to create the path of a car turning on a curving road. 

As you change an Auto Bezier keyframe value, the positions of Auto Bezier direction 
handles change automatically to maintain a smooth transition between keyframes. The 
automatic adjustments change the shape of the Value graph or motion path segments on 
either side of the keyframe. If the previous and next keyframes also use Auto Bezier inter-
polation, the shape of the segments on the far side of the previous or next keyframes also 
changes. If you adjust an Auto Bezier direction handle manually, you convert it to a 
Continuous Bezier keyframe.

Auto Bezier is the default spatial interpolation. To change the default, see “Setting the 
default spatial interpolation to Linear” on page 129.
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Continuous Bezier interpolation
Like Auto Bezier interpolation, Continuous Bezier interpolation creates a smooth rate of 
change through a keyframe. However, you set the positions of Continuous Bezier direction 
handles manually. Adjustments you make change the shape of the Value graph or motion 
path segments on either side of the keyframe.

If you apply Continuous Bezier spatial interpolation to all keyframes of a motion path, 
After Effects adjusts the motion path at each keyframe to create a smooth transition at 
each keyframe. As with temporal properties, After Effects maintains these smooth transi-
tions as you move a Continuous Bezier keyframe on the motion path. The speed of motion 
along the path is controlled by the temporal interpolation applied at each keyframe.

Bezier temporal interpolation
Bezier interpolation provides the most precise control because you manually adjust the 
shape of the Value graph or motion path segments on either side of the keyframe. Unlike 
Auto Bezier or Continuous Bezier, the two direction handles on a Bezier keyframe operate 
independently in both the Value graph and motion path.

If you apply Bezier temporal interpolation to all keyframes of a layer property, by default 
After Effects creates a smooth transition between keyframes. The initial position of the 
direction handles is calculated using the same method used in Auto Bezier interpolation. 
After Effects maintains existing direction handle positions as you change a Bezier 
keyframe value.

Unlike other interpolation methods, you can create any combination of curves and 
straight lines along the motion path. Because the two Bezier direction handles operate 
independently, a curving motion path can suddenly turn into a corner at a Bezier 
keyframe. Bezier spatial interpolation is ideal for drawing a motion path that follows a 
complex shape, such as a map route or the outline of a logo.

Existing direction handle positions persist as you move a motion-path keyframe. The 
speed of motion along the path is controlled by the temporal interpolation applied at 
each keyframe. For more information on controlling the speed, see“Controlling speed 
along a motion path” on page 132.

Hold interpolation
Hold interpolation is available only as a temporal interpolation method. Use it to change 
the value of a layer property over time, but without a gradual transition. This method is 
useful for strobe effects, or when you want layers to appear or disappear suddenly.

If you apply Hold temporal interpolation to all keyframes of a layer property, the value of 
the first keyframe holds steady until the next keyframe, when the values change immedi-
ately. In the Value graph, the graph segment following a Hold keyframe appears as a 
horizontal straight line. 

Even though Hold interpolation is available only as a temporal interpolation method, the 
keyframes on the motion path are visible, but they are not connected by layer-position 
dots. For example, if you animate a layer’s Position property using Hold interpolation, the 
layer holds at the position value of the previous keyframe until the current-time marker 
reaches the next keyframe, at which point the layer disappears from the old position and 
appears at the new position.
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You can use Hold interpolation only for outgoing temporal interpolation (for the frames 
following a keyframe). If you create a new keyframe following a Hold keyframe, the new 
keyframe will use incoming Hold interpolation. See “Adjusting direction handles to create 
curves and corners” on page 128.

Changing the interpolation method
You can apply and change the interpolation method for any property keyframe. Setting 
different interpolation methods for different keyframes can create a more complex 
appearance and add variety to your animations.

Change the interpolation method for a keyframe using the Keyframe Interpolation dialog 
box, or change it directly on a Value graph or motion path. Before you use the Value graph 
or motion path, note which kind of interpolation you want to change. Editing interpo-
lation on a Value graph affects only the temporal interpolation of a layer property. Editing 
interpolation on a motion path affects only the spatial interpolation of a layer property. 
For more information on using the Value graph, see “Controlling change through interpo-
lation” on page 122.

To change an interpolation method for a keyframe using the Keyframe Interpolation 
dialog box:

1 In the Timeline window, select the keyframes you want to change.

2 Choose Animation > Keyframe Interpolation.

3 For Temporal Interpolation, choose one of the following options:

• Current Settings preserves the interpolation values already applied to the selected 
keyframes. Choose this option when multiple or manually adjusted keyframes are 
selected and you do not want to change the existing settings.

• Linear, Bezier, Continuous Bezier, Auto Bezier, and Hold apply a temporal interpolation 
method using default values.

4 If you selected keyframes of a spatial layer property, choose one of the following 
options for Spatial Interpolation (available only for Position, Anchor Point, Effect Point, and 
3D Orientation keyframes):

• Current Settings preserves the interpolation settings already applied to the selected 
keyframes.

• Linear, Bezier, Continuous Bezier, and Auto Bezier apply a spatial interpolation method 
using default values.

5 If you selected keyframes of a spatial layer property, use the Roving menu to choose 
how a keyframe determines its position in time, and then click OK:

• Current Settings preserves the currently applied method of positioning the selected 
keyframes in time.

• Rove Across Time smooths the rate of change through the selected keyframes by 
automatically varying their position in time, based on the positions of the keyframes 
immediately before and after the selection. See “Creating smooth changes using roving 
keyframes” on page 137.

• Lock to Time keeps the selected keyframes at their current position in time. They stay in 
place unless you move them manually.
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To change an interpolation method directly in a window:

1 Display the Value graph in the Timeline window or the motion path in the Composition 
or Layer window.

2 Using the selection tool, press Ctrl (Windows) or Command (Mac OS) as you click the 
keyframe marker you want to change. The interpolation method that the keyframe 
changes to depends on the current interpolation:

• If the keyframe uses Linear interpolation, it changes to Auto Bezier.

• If the keyframe uses Bezier, Continuous Bezier, or Auto Bezier, it changes to Linear.

Note: You can change interpolation methods directly for temporal keyframes in the 
Timeline window and for spatial keyframes in the Composition and Layer windows.

A Linear keyframe (left) changes to Auto Bezier (right).

Applying Bezier interpolation graphically
One way to apply Bezier interpolation is to use the Keyframe Interpolation dialog box. See 
“Changing the interpolation method” on page 126. However, when you are using the 
mouse intensively on a Value graph or motion path, you may prefer to apply Bezier inter-
polation graphically. 

To enable Bezier direction handles graphically:

1 Using the selection tool, do one of the following:

• If the current keyframe interpolation is Linear, press Ctrl (Windows) or Command 
(Mac OS) as you click the keyframe to change it to Auto Bezier.

• If the current interpolation is Auto Bezier, drag one of the direction handles. Direction 
lines appear, visually connecting the direction handles to the keyframe and indicating 
that you have changed the interpolation to Continuous Bezier.

An Auto Bezier keyframe (left) changes to a Continuous Bezier keyframe (right).

2 Press Ctrl (Windows) or Command (Mac OS) as you drag one of the direction handles. 
This changes the interpolation to Bezier. Each direction handle now moves independently.
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Adjusting direction handles to create curves and corners
By default, Bezier interpolation creates a curved transition at a keyframe. Clicking the 
keyframe with the Convert Control Point tool ( ) creates a corner at the keyframe. On a 
Value graph, a corner results in an abrupt transition. On a motion path, the keyframe 
becomes a corner in the path.

You can also change a Bezier keyframe so that the two handles move together, forming a 
curve through the keyframe.

To change a Bezier keyframe from a curve to a corner:

1 Select the pen tool ( ) or Convert Control Point tool ( ) from the toolbox.

2 In the Composition window, drag a keyframe’s direction handle in any direction.

Continuous Bezier direction handles (left) become two separate Bezier 
direction handles (right).

Retracting and extending Bezier direction handles
You can retract or extend the direction handles that appear by default. When the direction 
handles are extended, the keyframe represents Continuous Bezier interpolation (see 
“Continuous Bezier interpolation” on page 125). When both direction handles are 
retracted, the interpolation method is Linear, which creates a corner point instead of a 
curve (see “Linear interpolation” on page 124).

To retract one direction handle:

Using the selection tool, on a Value graph in the Timeline window or motion path in the 
Composition or Layer window, drag the direction handle to the center of its keyframe.

To retract both Bezier direction handles:

1 Select the Convert Control Point tool ( ) from the toolbox.

2 On a Value graph or motion path, click the keyframe.

To extend retracted Bezier direction handles:

1 Select the Convert Control Point tool ( ) from the toolbox.

2 On a Value graph or motion path, click the keyframe and drag outward from the 
keyframe.

To toggle between the selection tool and the pen tool:

Hold down Ctrl (Windows) or Command (Mac OS).
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Mixing incoming and outgoing interpolation methods
By default, a keyframe icon uses one interpolation method, but you can apply two 
methods: the incoming method applies to the property value as the current time 
approaches a keyframe, and the outgoing method applies to the property value as the 
current time leaves a keyframe. When you set different incoming and outgoing interpo-
lation methods, the keyframe icon changes accordingly. It displays the left half of the 
incoming interpolation method icon and the right half of the outgoing interpolation icon.

You can freely mix Linear and Bezier interpolation methods using the Speed or Velocity 
graph. See “Fine-tuning speed” on page 134. Because Auto Bezier interpolation automati-
cally adjusts both incoming and outgoing direction handles, once you mix Auto Bezier 
with another method, the original half of the keyframe becomes Bezier.

To mix Bezier and Linear interpolation methods:

1 In the Timeline window, select the Bezier or Linear keyframe you want to change.

2 Expand the layer outline to display the Speed or Velocity graph for the layer property 
containing the keyframe.

Note: Make sure that you adjust the handles on the Speed or Velocity graph, not the Value 
graph. See “Factors affecting speed” on page 131.

3 Drag the incoming or outgoing handle to adjust the speed of the keyframe. 

To apply or remove Hold interpolation as outgoing interpolation:

1 In the Timeline window, select the keyframe you want to change.

2 Choose Animation > Toggle Hold Keyframe.

Setting the default spatial interpolation to Linear
When you create spatial changes in a layer, After Effects uses Auto Bezier as the default 
spatial interpolation. You can change this default to Linear. 

To set the default spatial interpolation to Linear:

1 Choose Edit > Preferences > General.

2 Select the Default Spatial Interpolation to Linear option and click OK.
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Using the Value graph to change a layer property value
The Timeline window displays the values for each keyframe and the interpolated values 
between keyframes. When the Value graph of a layer property is level, the value of a layer 
property is unchanged between keyframes. When the Value graph goes up or down, the 
value of a layer property increases or decreases between keyframes.

A. A level value graph indicates unchanging values. B. A rising graph indicates 
increasing values. C. A falling graph indicates decreasing values.

You can change layer property values by moving the points on the Value graph up or 
down. For example, you can increase a Rotation keyframe’s value by dragging a point on 
the Rotation property’s Value graph higher up the graph. 

Note: Values for the Anchor Point, Mask Shape, Effect point controls, 3D Orientation, and 
Position properties are spatial, so they are graphically represented in the Composition 
window, not in the Value graph in the Timeline window.

To change the value of a layer property:

1 In the Timeline window, display the property for a layer.

2 To change the marker at the current time, do one of the following:

• Click the underlined value and type a new value.

• Position the pointer over the underlined value and drag to change the value; hold 
down Shift to drag using greater increments (in multiples of 10).

• Click the triangle next to the property name to display the Value graph, and then drag a 
value marker up or down.

3 To change the value of a keyframe at any time, double-click the keyframe icon to type a 
different value.

To see the new value displayed next to the property name, position the current-time 
marker on the keyframe.

Adding keyframes to a Value graph
The pen tools provide the most flexible way to change temporal properties in the Value 
graph or a motion path. Editing with the pen tool is similar to modifying a path in a 
drawing application such as Adobe Illustrator. For more information on using the pen 
tools, see “Drawing a Bezier mask with the pen tool” on page 152.

A B C
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For best results with the pen tool, you should understand how Bezier interpolation affects 
the Value graph and the motion path. When you use Bezier interpolation on a graph or 
path, you can control the shapes of corners, making them into smooth curves or angled 
corners. See “Bezier temporal interpolation” on page 125.

To add a keyframe to a Value graph using the pen tool:

1 In the Timeline window, display a layer property containing at least one keyframe.

2 Click the triangle to the left of the property name to display the Value graph.

3 Select the pen tool ( ) from the toolbox.

4 In the Timeline window, move the pen tool over the time on the Value graph where you 
want to add the new keyframe, and then click to add a new keyframe.

Factors affecting speed
After you create your keyframes and motion paths, you may want to make more precise 
adjustments to the way the spatial coordinates or speed of a moving layer changes 
through keyframes.

You can fine-tune nearly all changes over time using the Speed graph or Velocity graph in 
the Timeline window. The Speed graph provides complete information about and control 
of the value and rate of change for all spatial values (such as Position) at any frame in a 
composition. The Velocity graph provides complete information about and control of the 
value and rate of change for all nonspatial values (such as Opacity) at any frame in a 
composition.

A. Speed at the current-time marker B. Minimum and maximum speed (not limits) 
C. Speed graph D. Speed control 

The change of value or speed over time is affected by the following factors:

Time difference The time difference between keyframes in the Timeline window. The 
shorter the time interval between keyframes, the more quickly the layer has to change 
before reaching the next keyframe value. If the interval is longer, the layer changes more 
slowly, since it must make the change over a longer period of time. Use distance to adjust 
speed by moving keyframes forward or backward along the timeline.

A B C D
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Value difference The difference between the values of adjacent keyframes. A large 
difference between keyframe values, such as the difference between 75% and 20% 
opacity, creates a faster rate of change than a smaller difference, such as the difference 
between 30% and 20% opacity. Use value differences to adjust the rate of change by 
increasing or decreasing the value of a layer property at a keyframe.

Larger difference (left) creates faster change. Smaller difference (right) creates slower change.

Interpolation type The type of interpolation applied for a keyframe. For example, it is 
difficult to make a value change smoothly through a keyframe when the keyframe is set 
to Linear interpolation; but at any time, you can switch to Bezier interpolation, which 
provides a smooth change through a keyframe. If you use Bezier interpolation, you can 
adjust the rate of change even more precisely using ease handles. For more information, 
see “Fine-tuning speed” on page 134.

Controlling speed along a motion path
When you animate a spatial property such as Position, Anchor Point, Effect Point, 3D 
Orientation, or Mask Shape, you can view and adjust the speed of the layer in the Speed 
graph in the Timeline window or on the motion path in the Composition or Layer window. 
As you adjust the speed in one window, you can view the changes in the other window. In 
the Timeline window’s Speed graph, change in the graph height indicates changes in 
speed. Level values indicate constant speed; higher values indicate increased speed. 
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In the Composition or Layer window, the spacing between dots in a motion path indicates 
speed. Each dot represents a frame, based on the frame rate of the composition. Even 
spacing indicates a constant speed, and wider spacing indicates a higher speed. 
Keyframes using Hold interpolation display no dots because there is no intermediate 
transition between keyframe values; the layer simply appears at the next keyframe’s 
position.

A. Dots are close together, indicating slower speed. 
B. Dots are far apart, indicating faster speed. 
C. Inconsistent spacing of dots indicates changing speed. 

To control speed between keyframes:

Use any combination of the following options:

• In the Composition or Layer window, adjust the spatial distance between two 
keyframes on the motion path. Increase speed by moving one keyframe position 
farther away from the other, or decrease speed by moving one keyframe position closer 
to the other.

More spatial distance between keyframes increases layer speed.

A B C
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• In the Timeline window, adjust the time difference between two keyframes. Decrease 
speed by moving one keyframe farther away from the other, or increase speed by 
moving one keyframe closer to the other.

Shorter temporal distance between keyframes increases layer speed.

• Apply the Easy Ease keyframe assistant, which automatically adjusts the speed of 
change as motion advances toward and retreats from a keyframe. See “Automatically 
easing speed using the Easy Ease keyframe assistant” on page 139.

Fine-tuning speed
Using the Speed or Velocity graph, you can adjust motion or the rate of change for a value 
so that it occurs more slowly just before or just after a keyframe, or so that a layer moves 
quickly over a certain distance and then slows down smoothly. By adjusting the rise and 
fall of the graph, you can control how fast or slow a value changes from keyframe to 
keyframe. Each temporal interpolation method affects acceleration and deceleration 
differently. If you don’t get the results you want, try a different temporal interpolation 
method.

When adjusting speed on a motion path, set the shape of a motion path first, and then use 
ease handles to fine-tune the speed relationships in the Speed graph. Ease handles 
provide the most direct control over acceleration and deceleration. You can control the 
values approaching or leaving a keyframe together or separately. The incoming handle 
increases the influence of a keyframe value on the previous keyframe when you drag it to 
the left, and decreases the influence on the previous keyframe when you drag it to the 
right. It increases or decreases the speed when you drag it up or down. The outgoing 
handle influences the next keyframe in the same way.

Note: If you want a handle to have influence over more than one keyframe, use roving 
keyframes. See “Creating smooth changes using roving keyframes” on page 137.

To fine-tune speed between keyframes:

1 In the Timeline window, expand the outline for the keyframe you want to adjust. Then 
click the triangle to the left of the property to display the Speed graph or the Velocity 
graph.

2 At the keyframe you want to adjust, drag either ease handle up to accelerate, or down 
to decelerate, entering and leaving the keyframe.
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By default, if you drag a handle beyond the top or bottom of the graph area, the graph line 
is automatically resized to fit within the graph area. However, if you deselect the icon ( ) 
to the right of the property values, the graph line will not be resized; see “Adjusting the 
Speed or Velocity graph border” on page 135.

To fine-tune speed separately for incoming and outgoing frames:

1 In the Timeline window, display the Speed or Velocity graph for the keyframe you want 
to adjust.

2 At the keyframe you want to adjust, press Ctrl (Windows) or Command (Mac OS) as you 
drag either ease handle up or down.

To rejoin split ease handles:

1 In the Timeline window, display the Speed or Velocity graph for the keyframe you want 
to adjust.

2 At the keyframe you want to adjust, press Ctrl (Windows) or Command (Mac OS) as you 
drag either split ease handle up or down until it meets the other handle.

Adjusting the Speed or Velocity graph border
When you drag an ease handle beyond the top or bottom of the graph area, After Effects 
calculates a new minimum or maximum value based on how far you dragged outside the 
graph, and it redraws the graph so that all the values you specified for that layer property 
are visible in the graph by default. You can manually adjust the size of the Speed or 
Velocity graph border when you want to make greater changes to the speed.

To adjust the Speed or Velocity graph border:

Position the pointer tool on the graph border and, when the pointer becomes a double-
arrow cursor, drag up or down.

Speed graph border at default location (left) and expanded for precision editing (right)

If you do not want the graph to be resized automatically when you drag a handle beyond 
the top or bottom of the graph area, deselect the icon ( ) to the right of the property 
values. Deselecting this icon lets you zoom in on a portion of the graph resized beyond 
the graph area, but note that part of the graph may not be displayed. 

To change the default graph area size:

1 Choose Edit > Preferences > Display.

2 For Default Height of Timeline Graphs, specify the number of cells (one cell equals 14 
pixels).
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Creating a bounce or intense peak
Use ease handles to simulate the type of acceleration seen in a bouncing ball. When you 
create this type of effect, the Speed or Velocity graph appears to rise quickly and peak.

To create a bounce or peak:

1 In the Timeline window, expand the outline for the keyframe you want to adjust. Then 
click the triangle to the left of the property to display the Speed graph or the Velocity 
graph.

2 At the desired keyframe, drag the ease handle up until it is near the top of the graph.

Starting or stopping change gradually
Ease handles can also create gradual starts and stops, such as a boat slowing to a stop and 
then starting again. When you use this technique, the Speed or Velocity graph resembles a 
smooth U shape.

To start or stop change gradually:

1 In the Timeline window, expand the outline for the keyframe you want to adjust. Then 
click the triangle to the left of the property to display the Speed graph or the Velocity 
graph.

2 At the desired keyframe, drag the ease handle down until it is near the bottom of the 
graph.

Extending the influence of an ease handle
Along with controlling the level of acceleration and deceleration, you can also extend the 
influence of a keyframe outward or inward in relation to an adjacent keyframe. Influence 
determines how quickly the Speed graph reaches the speed you set at the keyframe, 
giving you an additional degree of control over the shape of the graph.

As you adjust an ease handle, the effects of the change are visible in the Speed graph and 
in the motion path in the Composition window.
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To adjust the influence of an ease handle on the previous or next keyframe:

1 In the Timeline window, expand the outline for the keyframe you want to adjust. Then 
click the triangle to the left of the property to display the Speed graph or the Velocity 
graph.

2 At the desired keyframe, drag the ease handle left or right.

Changing speed numerically
You may want to specify speed more precisely than you can by dragging ease handles. In 
such cases, specify speed numerically in the Keyframe Velocity dialog box.

The exact options available in the dialog box vary depending on the layer property you 
are editing, and may also vary for plug-in effects. For each, speed is expressed as follows:

Anchor Point and Position Pixels per second.

Mask Shape Units per second.

Mask Feather Pixels per second for both the x (horizontal) and y (vertical) dimensions.

Scale Percent per second for both the x (horizontal) and y (vertical) dimensions.

Rotation Degrees per second.

Opacity Percent per second.

To specify speed numerically:

1 Display the Speed graph for the keyframe you want to adjust.

2 Select the keyframe you want to edit.

3 Choose Animation > Keyframe Velocity.

4 Type values for Incoming and Outgoing Velocity Speed.

5 Type values for the following options, and then click OK:

• Influence specifies the amount of influence toward the previous keyframe (for 
incoming interpolation) or the next keyframe (for outgoing interpolation).

• Continuous creates a smooth transition by maintaining equal incoming and outgoing 
velocities.

Creating smooth changes using roving keyframes
Using the roving keyframe option in After Effects, you can easily create smooth movement 
across several keyframes at once. Roving keyframes are keyframes that are not linked to 
a specific time; their speed and timing are determined by adjacent keyframes. When you 
change the position of a keyframe adjacent to a roving keyframe in a motion path, the 
timing of the roving keyframe may change.
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Roving keyframes are available only for spatial layer properties such as Position. In 
addition, a keyframe can rove only if it is not the first or last keyframe in a layer, because a 
roving keyframe must interpolate its speed from the previous and next keyframes.

The original motion path (left) indicates different velocities between keyframes. After the keyframes 
are set to rove (right), the motion path displays consistent speed over the range of keyframes.

To smooth motion over several keyframes:

1 In the Timeline window, set up the keyframes for the motion you will smooth. See 
“Setting layer position” on page 103.

2 Determine the beginning and ending keyframes for the range you want to smooth.

3 Do one of the following:

• For every keyframe in the range (except the beginning and ending keyframes), deselect 
the roving-keyframe option directly below the keyframe. The intermediate keyframes 
adjust their positions on the timeline to smooth the speed curve between the 
beginning and ending keyframes.

When you deselect the roving-keyframe option (left), the keyframe may shift to smooth the motion 
(right).

• Select the keyframes you want to rove and choose Animation > Keyframe Interpolation. 
Then choose Rove Across Time from the Roving pop-up menu.

To change a roving keyframe back to a nonroving keyframe:

Do one of the following:

• Select the roving keyframe option, or drag the roving keyframe left or right.
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• Select the keyframes you want to change and choose Animation > Keyframe Interpo-
lation. Then choose Lock to Time from the Roving pop-up menu.

Automatically easing speed using the Easy Ease keyframe 
assistant
Eliminate sudden changes in a property’s speed using the Easy Ease keyframe assistant. 
Although you can manually adjust the speed of a keyframe by dragging ease handles, 
using Easy Ease automates the work.

After you apply Easy Ease, each keyframe has a speed of 0 with an influence of 33.33% on 
either side. When you ease the speed of an object, for example, the object slows down as it 
approaches a keyframe, and gradually accelerates as it leaves. You can ease speed only 
when coming into or out of a keyframe, or both. 

To ease speed:

1 In the Timeline window, select a range of keyframes.

2 Choose Animation > Keyframe Assistant > Easy Ease (to ease speed coming both 
into and out of selected keyframes), Easy Ease In (to ease speed coming into selected 
keyframes), or Easy Ease Out (to ease speed coming out of selected keyframes).

Time-stretching a layer
Using the Time Stretch command, you can easily change how fast or slow a layer 
containing either audio or video is played back. Speeding up or slowing down a layer is 
also known as time-stretching. When you time-stretch a layer, the audio file or the original 
frames in the footage (and all keyframes that belong to the layer) are redistributed along 
the new duration. Use this command only when you want the layer and all layer keyframes 
to change to the new duration.

Time-stretching a layer redistributes keyframes along the new duration.

If you time-stretch a layer so that the resulting frame rate is significantly different from the 
original speed, the quality of motion within the layer may suffer. Turn on frame blending 
to improve slow-motion or fast-motion effects. See “Enhancing time-altered motion by 
blending frames” on page 89.

To time-stretch a layer from a specific time:

1 In the Timeline or Composition window, select the layer.

2 Choose Layer > Time Stretch.

3 Type a new duration for the layer, or type a Stretch Factor.

4 Click one of the Hold in Place options to specify the point in time from which the layer 
will be time-stretched, and then click OK:
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• Layer In-point holds the layer’s current starting time, and time-stretches the layer by 
moving the Out point.

• Current Frame holds the layer at the position of the current-time marker (also the frame 
displayed in the Composition window), and time-stretches the layer by moving the In 
and Out points.

• Layer Out-point holds the layer’s current ending time and time-stretches the layer by 
moving the In point.

To time-stretch a layer to a specific time:

1 In the Timeline window, move the current-time marker to the frame where you want 
the layer to begin or end.

2 Display the In and Out panels in the Timeline window by choosing Panels > In and 
Panels > Out from the palette menu. 

3 Do one of the following:

• To stretch the In point to the current time, press Ctrl (Windows) or Command (Mac OS) 
as you click the In time for the layer in the In panel.

• To stretch the Out point to the current time, press Ctrl (Windows) or Command (Mac 
OS) as you click the Out time for the layer in the Out panel.

Keeping keyframes intact when time-stretching a layer
When you time-stretch a layer, the positions of its keyframes stretch with it by default. You 
can circumvent this behavior by cutting and pasting keyframes. 

To time-stretch a layer but not its keyframes:

1 Make a note of the time at which the first keyframe appears.

2 In the layer outline, click the name of one or more layer properties containing the 
keyframes you want to keep at the same times.

3 Choose Edit > Cut.

4 Move or stretch the layer to its new In and Out points.

5 Move the current-time marker to the time at which the first keyframe appeared before 
you cut the keyframes.

6 Choose Edit > Paste.



Using Help | Contents | Index Back 141  

Adobe After Effects Help Fine-tuning Animation 

Using Help | Contents | Index Back 141  

Using the Time-Reverse Keyframes keyframe assistant
For any property in a layer, you can select a range of keyframes and reverse their order. For 
example, you can reverse keyframes in the Position property to reverse the motion of an 
object. You can select and reverse keyframes across multiple layers and properties, but 
each set of keyframes for a property is reversed only within its original time range, not that 
of any other selected property. Markers in the Timeline window are not reversed, so you 
may need to move markers after reversing keyframes. 

Original property values

Scale property values reversed using the Time-Reverse Keyframes keyframe assistant

To reverse keyframes:

1 In the Timeline window, select a range of keyframes you want to reverse.

2 Choose Animation > Keyframe Assistant > Time-Reverse Keyframes.

For information on reversing the direction in which a layer plays and changing the order of 
the keyframes, see “Reversing the playback direction of a layer” on page 141. For infor-
mation on reversing the direction in which a layer plays without changing the order of the 
keyframes, see “About time-remapping” on page 142.

Reversing the playback direction of a layer
You can easily reverse a layer’s playback direction. When you do, all keyframes for all 
properties on the selected layer also reverse position relative to the layer. The layer itself 
maintains its original In and Out points relative to the composition. 

Note: For best results, replace the layer with a composition having the same frame size as 
the layer, and reverse the layer inside the composition. This is the most accurate way to 
reverse footage. For more information on nesting compositions, see “Organizing a project 
using nesting” on page 265.

To reverse a layer’s playback direction:

1 In a Timeline window, select the layer you want to reverse.

2 Press Ctrl+Alt+R (Windows) or Command+Option+R (Mac OS).

Note: You can also play a layer backward by typing a negative time-stretch value in the 
Time Stretch dialog box.

To reverse the order of keyframes without reversing the layer’s playback direction, select 
keyframes and choose Animation > Keyframe Assistant > Time-Reverse Keyframes (see 
“Using the Time-Reverse Keyframes keyframe assistant” on page 141). 
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To reverse a layer’s playback direction without reversing the order of its keyframes, use 
time-remapping to reverse the layer (see “About time-remapping” on page 142).

About time-remapping 
In After Effects you can easily expand, compress, play backwards, or freeze a portion of a 
layer’s duration using a process known as time-remapping. For example, if you are using 
footage of a person tearing a movie ticket, you can play footage of the tearing, freeze the 
motion as the ticket is torn halfway, and then play a few frames backwards to make the 
ticket appear whole again. 

Footage is usually displayed at a constant speed in one direction.

Time-remapping distorts time for a range of frames within a layer.

You can also time-remap layers containing audio or both audio and video. When you 
apply time-remap to a layer containing audio and video, the audio and video remain 
synchronized. You can remap audio files to gradually decrease or increase the pitch, play 
audio backwards, or create a warbled or scratchy sound. 

You can remap time in either the Layer window or the Timeline window. Remapping video 
in one window displays the results in both windows. Each window provides a different 
view of the layer duration:
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• The Layer window provides a visual reference of the frames you change, as well as the 
frame number. The window displays the current-time marker and a remap-time marker, 
which you move to select the frame you want to play at the current time. 

A. Current-time marker B. Remap-time marker C. Time-remap value 
D. Navigator bar 

• The Timeline window provides a precise view of the changes you specify over time by 
marking your changes with keyframes and a graph similar to the one displayed for 
other layer properties. You must be familiar with using keyframes to remap time in the 
Timeline window. For more information, see “Understanding keyframes” on page 96.

A. First frame B. Last frame C. Active frame D. Top speed E. Current speed F. Lowest speed

When remapping time in the Timeline window, use the values represented in the Time 
Remap graph to determine and control which frame of the movie plays at which point in 
time:

Time Remap This value indicates which frame plays at the current time. As you drag a 
Value graph marker up or down, this value changes accordingly. You can click this value 
and type a new one. The Time Remap value also appears in the Layer window next to the 
Out point value.

Value: Time Remap The top value represents the last (highest) frame in the layer, and the 
bottom value represents the first (lowest) frame. 

A B C

D

C DBA E F
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Velocity: Time Remap The top value indicates the layer’s fastest speed. The bottom value 
is always a negative of the top value. The middle value indicates how fast the video is 
playing at the current time. Normal speed is 100%, slow-motion is less than 100%, and 
fast-motion is greater than 100%.

When you turn on Enable Time Remapping, After Effects adds a Time Remap keyframe at 
the start and end points of the layer in the Timeline window. By setting additional remap 
keyframes, you can create complex motion effects. Every time you add a Time Remap 
keyframe, a Value graph marker appears on the graph directly below the keyframe. As you 
move this marker up or down, the Time Remap value changes to the frame of the video set 
to play at the current time. After Effects then interpolates intermediate frames and plays 
the footage forward or backward from that point. 

The speed at which remapped video plays depends on the number of frames you are 
remapping and the amount of time allocated in the timeline for the changes. For example, 
if you freeze a frame for one second and do not increase the duration of the layer by one 
second, the footage following the freeze frame must play faster than normal to play all 
frames in the limited time remaining.

The original duration of the source footage may no longer be valid when remapping time, 
because parts of the layer no longer play at the original rate. If necessary, set the new 
duration of the layer before you remap time. See “Understanding trimming” on page 81.

If you remap time and the resulting frame rate is significantly different from the original, 
the quality of motion within the layer may suffer. Apply frame blending to improve slow- 
or fast-motion effects; see “Using frame blending” on page 89.

Time-remapping parts of a motion footage or audio layer
There are limitless options for time-remapping in After Effects. For example, you can time-
remap an entire layer, making it play backwards. You can time-remap a few frames at the 
beginning or end of the layer, creating a freeze-frame effect. Or you can time-remap 
frames in the middle of the layer, creating a slow-motion effect. 

You can remap time for video footage only; still images cannot be remapped. For best 
results, do not remap video footage that has been time-stretched.

To freeze the first frame without changing the speed: 

1 In a Composition window or Timeline window, select the layer you want to remap.

2 Choose Layer > Enable Time Remapping.

3 Click the triangle to the left of the layer name to expand the layer outline.

4 Click the triangle to the left of the Time Remap heading to display the time graph for 
time remapping.

5 Move the current-time marker to where you want the movie to begin.

6 Shift-click the keyframes at the layer’s start and end, or click “Time Remap” to select the 
start and end keyframes.

7 Drag the first keyframe to the current-time marker, which moves the start and end 
keyframes.

To freeze the last frame without changing the speed: 

1 In a Composition window or Timeline window, select the layer you want to remap.
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2 Choose Layer > Enable Time Remapping.

3 Click the triangle to the left of the layer name to expand the layer outline.

4 Click the triangle to the left of the Time Remap heading to display the time graph for 
time remapping.

5 Drag the triangle at the end of the layer duration bar to the time where you want the 
freeze frame to end.

To remap time in the Timeline window:

1 In a Composition window or Timeline window, select the layer you want to remap.

2 Choose Layer > Enable Time Remapping.

3 Click the triangle to the left of the layer name to expand the layer outline.

4 Click the triangle to the left of the Time Remap heading to display the time graph for 
time remapping.

5 Move the current-time marker to the frame where you want change to begin, and then 
click the keyframe check box.

6 On the Time Remap graph below the keyframe, drag the Value graph marker, watching 
the Time Remap value as you drag. To prevent the graph from dropping below the dotted 
line, press Shift as you drag the graph marker.

Dragging the value graph marker down slows down the layer.

• To slow down the layer, drag the Value graph marker down. (If the layer is playing in 
reverse, drag up.)

• To speed up the layer, drag the Value graph marker up. (If the layer is playing in reverse, 
drag down.)

• To play frames backward, drag the Value graph marker down to a value below the 
previous keyframe value.

• To play frames forward, drag the Value graph marker up to a value above the previous 
keyframe value.

• To freeze the previous keyframe, drag the Value graph marker up to a value equal to the 
previous keyframe value so that the graph line is flat. Another method is to select the 
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keyframe and choose Animation > Toggle Hold Keyframe, and then add another 
keyframe where you want the motion to start again.

A. No change B. Fast motion C. Freeze frame D. Backward motion

To remap time in a Layer window:

1 Open the Layer window for the layer you want to remap.

2 Choose Layer > Enable Time Remapping. A second time ruler appears in the Layer 
window above the default time ruler and the navigator bar.

3 On the lower time ruler, move the current-time marker to the first frame where you 
want the change to occur.

4 On the upper time ruler, the remap-time marker indicates the frame currently mapped 
to the time indicated on the lower time ruler. To display a different frame at the time 
indicated on the lower time ruler, move the remap-time marker accordingly.

5 Move the current-time marker on the lower time ruler to the last frame where you want 
change to occur.

6 Move the remap-time marker on the upper time ruler to the frame you want to display 
at the time indicated on the lower time ruler:

• To move the preceding portion of the layer forward, set the remap-time marker to a 
later time than the current-time marker.

• To move the preceding portion of the layer backward, set the remap-time marker to an 
earlier time than the current-time marker.

• To freeze a frame, set the remap-time marker to the frame you want frozen. Then, move 
the current-time marker (lower ruler) to the last point in time where the frame will 
appear frozen and move the remap-time marker again to the frame you want frozen.

C DBA
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Time-remapping audio pitch
The Velocity graph in the Time-remap property directly relates to the pitch of an audio file. 
By making subtle changes to the Velocity graph, you can create a variety of interesting 
effects. To avoid screeching audio, you may want to keep the Velocity below 200%. When 
the velocity (speed) is too high, use the Levels controls, located under the Audio property, 
to control the volume.

You may hear clicks at the beginning and end of an audio (or an audio and video) layer 
after setting new In and Out points in the Time Remap graph. Use the Levels controls to 
remove these clicks; see “Using audio layers” on page 91.

To change the pitch of an audio layer:

1 In a Composition window or Timeline window, select the layer you want to remap.

2 Choose Layer > Enable Time Remapping.

3 Click the triangle to the left of the layer name to expand the layer outline.

4 Click the triangle to the left of the Time Remap heading to display the time graph for 
time-remapping.

5 Move the current-time marker to the frame where you want change to begin, and then 
click the keyframe navigator box.

6 On the Velocity graph below the keyframe, drag a marker, watching the Velocity value 
as you drag.

• To lower the pitch, drag the Velocity graph marker down. 

• To increase the pitch, drag the Velocity graph marker up.

To remove clicks from new In and Out points in the Time Remap graph:

1 If necessary, choose Window > Audio.

2 In the Timeline window, select the audio (or audio and video) layer to which you 
applied time-remapping.

3 Expand the layer outline to display the Audio property and then the Levels property.

4 Move the current-time marker to the new In point and click the stopwatch icon next to 
Levels to set a keyframe.

5 In the Audio palette, change the decibel value to 0.0.

6 Press the Page Up key on your keyboard to move the current-time marker to the 
previous frame.

7 In the Audio palette, change the decibel level to -96.0.

8 Move the current time to the new Out point and set the decibel level to 0.

9 Press the Page Down key on your keyboard to move the current-time marker to the 
next frame.

10 In the Audio palette, change the decibel level to -96.0.

You can change the decibel Slider Minimum value in the Audio Options dialog box, 
which is available from the Audio palette window menu. See “Previewing audio” on 

page 91.
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Working with Masks and 
Transparency

Understanding transparency in After Effects
When part of a layer is transparent, that transparency information is stored in the layer’s 
alpha channel. If the alpha channel of a layer doesn’t meet your requirements, you can use 
any combination of masks, mattes, and keying to display or hide different parts of a layer. 
You can also combine layers to achieve visual effects, apply layer modes to control the 
intensity or transparency of colors or brightness values, and use a color channel in one 
layer to create an effect in another layer. With a combination of layers and layer masks, you 
can create an array of effects. 

To create effects by combining images, parts of each image must be transparent. The 
terminology of transparency varies by media and by software. After Effects refers to trans-
parent areas using the following terms:

Alpha channel An invisible channel that defines transparent areas for the footage item or 
layer that contains the channel. With imported items, an alpha channel provides a way to 
store both the footage and its transparency information in a single file without disturbing 
the footage item’s color channels. Each After Effects layer can accommodate an alpha 
channel included with a footage item. See “Importing footage containing an alpha 
channel” on page 30.

Mask A path, or outline, that modifies a layer’s alpha channel. Use a mask when you want 
to draw areas of transparency in After Effects. A mask belongs to a specific layer, but each 
After Effects layer can contain multiple masks.

Matte A layer (or any of its channels) that defines the transparent areas of that layer or 
another layer. Use a matte when you have a channel or layer that defines the desired area 
of transparency better than the alpha channel (or in cases where footage does not include 
an alpha channel).

Keying Defining transparency by a particular color (color key) or brightness value 
(luminance key) in an image. Pixels matching the key color become transparent. Use 
keying to remove a background with a uniform color, such as a blue screen.
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Using a footage item with an alpha channel
An alpha channel is a fourth 8- or 16-bit channel (see “Selecting 16-bpc color depth (PB 
only)” on page 12 for information on working with 16-bit color in After Effects), included in 
addition to the three 8- or 16-bit red, green, and blue color channels of video footage or an 
RGB image. When a file contains an alpha channel, its image is defined as containing a 
total of 32 or 64 bits, or using Millions of Colors + or Trillions of Colors +. An alpha channel 
has the same function as a key in analog video compositing or a matte in optical film 
compositing—it describes the areas of an image that are transparent. See “Importing 
footage containing an alpha channel” on page 30.

Working with masks
Each layer in a composition can contain up to 127 masks. Create and view masks in either 
the Composition or Layer window, and set interactions between mask properties in the 
Timeline window or in the Layer menu. See “Creating masks” on page 149 for information 
on creating masks. You can also animate the shape of the mask by animating individual 
control points on a mask path. For more information on creating keyframes, see “Setting 
keyframes” on page 98.

To view masks in the Composition window:

Select Layer Masks from the Composition Window menu.

To view masks in the Layer window:

Select Masks from the Layer Window menu.

To specify a mask in the Layer window as the target for all new mask shapes:

Select the mask name from the Target pop-up menu. For more information on the Target 
menu, see “Specifying one mask as the target for animation” on page 159.

Creating masks
You can create one or more masks for each layer in a composition. Masks appear in the 
Timeline window in the order you create them. 

You can create a mask using any of the following methods: 

• Draw a path using the tools from the toolbox.

• Specify the dimensions of the mask shape in the Mask Shape dialog box.

• Paste a path copied from another layer or from Adobe Illustrator or Adobe Photoshop. 
For more information, see “Importing masks from Adobe Illustrator and Adobe 
Photoshop” on page 161.

Working with multiple masks in one layer
You can create multiple masks in a single layer using any of the methods listed in“Types of 
masks” on page 150, “Creating masks from motion paths” on page 151, and “Importing 
masks from Adobe Illustrator and Adobe Photoshop” on page 161. 



Using Help | Contents | Index Back 150  

Adobe After Effects Help Working with Masks and Transparency 

Using Help | Contents | Index Back 150  

Mask names appear in the order you create them in the Timeline window outline. To 
organize and keep track of your masks, rename them as you would rename layers (see 
“Renaming a layer” on page 79). To make it easier to work with multiple masks in the 
Composition window, you can apply different colors to each mask outline.

When creating additional masks for one layer in the Layer window, make sure that the 
Target pop-up menu in the Layer window is set to None; otherwise, you will replace the 
targeted mask instead of creating a new mask. See “Specifying one mask as the target for 
animation” on page 159.

To apply a new color to a mask outline:

1 Select the mask whose outline you want to change. See “Selecting masks and control 
points” on page 153 for information on selecting masks.

2 If necessary, expand the Mask properties.

3 Click the color swatch just to the left of the mask name, pick a new color, and click OK.

Types of masks
You can draw three types of masks:

Rectangular A rectangular mask can also be square. This type of mask is previewed and 
rendered faster than any other kind of drawn mask.

Oval An oval mask can also be circular.

Bezier Use the pen tool to draw a freeform Bezier path as a mask. This is the most flexible 
type of mask; you can create any shape with the pen tool.

After you first create a mask, you can resize it or rotate it as a whole (see “Scaling and 
rotating selected masks or points” on page 154), or you can change parts of it (see 
“Changing the shape of a mask” on page 155).

Drawing rectangular and oval masks
Use the rectangle and oval tools to create mask shapes, or specify a mask shape numeri-
cally.

To create a rectangular or oval mask by dragging:

1 Select a layer in the Composition window or display a layer in the Layer window.

2 Select the rectangle tool ( ) or the oval tool ( ) in the toolbox.

3 Position the cursor in the Composition or Layer window at one corner of the mask you 
want to draw and drag to the opposite corner. 

4 Use either of the following techniques to alter the mask as you draw:

• Press Shift as you drag to create a square with the rectangle tool or a circle with the oval 
tool.

• Press Alt (Windows) or Command (Mac OS) while dragging to create a mask that 
extends from its center.

For more information about moving, scaling, and rotating masks, see “Scaling and rotating 
selected masks or points” on page 154.
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To create a rectangular or oval mask the size of the layer:

1 Select a layer in the Composition window or display a layer in the Layer window.

2 In the toolbox, double-click either the rectangle tool or the oval tool.

To create a rectangular or oval mask by specifying a mask shape numerically:

1 Select a layer in the Composition window or display a layer in the Layer window.

2 Choose Layer > Mask > New Mask. A new mask appears in the Composition or Layer 
window with its handles at the outer edges of the frame.

3 Choose Layer > Mask > Mask Shape.

4 Select Rectangle or Oval.

5 If you want, specify the size and location of the mask’s bounding box. For information 
on coordinates, see “Info palette” on page 23.

6 Click OK.

About Mask Paths
A mask in After Effects is a drawn path consisting of path segments and control points. 
Segments are the lines or curves that connect two control points. Control points define 
where each segment of a path starts and ends.

In addition, the mask you create can be either an open or closed path. An open path has 
different beginning and ending points; for example, a straight line is an open path. A 
closed path is continuous and has no beginning or end; for example, a circle is a closed 
path. Closed-path masks can create transparent areas for a layer. Open paths cannot 
create transparent areas for a layer, but are useful when used as a parameter for an effect; 
for example, creating a visible line or shape from the mask using the Stroke effect. For 
more information, see “Applying effects to a mask” on page 161.

Creating masks from motion paths
You can copy Position, Anchor Point, or an effect’s point position keyframes and paste 
those keyframes to a selected mask. This is useful to create animations that follow the edges 
of a mask. When you create masks from motion paths, make sure that you copy keyframes 
from a single position property only—do not copy the keyframes of any other property. For 
information on motion paths, see “Setting layer position” on page 103.

To create a mask from a motion path:

1 In the Composition window, display the motion path from which you want to create the 
mask.

2 In the Timeline window, select the successive keyframes along the motion path you 
want to use as a mask. Click the Position property name to select all the keyframes. Shift-
click successive keyframes to select only a few keyframes.

3 Choose Edit > Copy.

4 In the Timeline window, select the layer you want to apply the mask to and expand its 
properties, or open the layer in its Layer window.

5 Do one of the following: 

• To use the motion path as a new mask, choose Layer > Mask > New Mask.
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• To use the motion path as a replacement for an existing mask, select the mask you want 
to replace.

6 In the Timeline, expand the Mask property for the mask you want to create or replace 
and select the Mask Shape value name.

7 Choose Edit > Paste.

Drawing a Bezier mask with the pen tool
Using the pen tools, you can create a Bezier mask of any shape, including straight lines at 
any angle or smooth flowing curves. The pen tools provide the most precise control over 
straight lines and curves.

You can easily adjust the shape of the path by dragging the mask’s control points or the 
direction lines associated with a control point. You can also quickly add points to or delete 
points from a segment, or change a control point from one type to another. For infor-
mation on changing control points, see the related procedure in “Changing the shape of a 
mask” on page 155.

Drawing straight lines with the pen tool
With the pen tool, draw straight lines by clicking the pen tool to create control points. 
Each time you click the tool in a new location, After Effects draws a straight path segment 
from the previous point to the new point. To close the path, position the cursor directly 
over the first control point and, when you see a closed circle icon ( ) next to the cursor, 
click.

Drawing curves with the pen tool
Create a curved mask by dragging the pen tool in the direction you want the curve to go. 
As with straight segments, control points mark a change in direction, but instead of 
creating a corner, control points on curves create smooth changes in direction. On curved 
segments, each selected control point displays one or two direction lines, ending in 
direction handles. The shape of a curved segment depends on the direction line at either 
end of the segment. As a path exits one control point, that point’s direction line shapes the 
curve. As the path approaches the next control point, its shape is less influenced by the 
previous point and more influenced by the direction line at the next control point. Moving 
these elements reshapes the curves in a path.

The direction lines always touch the curve at the control points. The angle and length of a 
direction line determine the shape of the curve as it exits that control point.

Continuous curved paths—that is, paths along a continuous wave shape—are connected 
by control points called smooth points. Noncontinuous curved paths are connected by 
corner points. You can change a control point to either a smooth or corner point as you 
draw.

When you move a direction line on a smooth point, the curves on both sides of the point 
adjust simultaneously. By contrast, when you move a direction line on a corner point, only 
the curve on the same side of the point as the direction line is adjusted. Complete the 
shape by clicking the first control point or by double-clicking the last point.

To change a control point:

Do one of the following:
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• Position the pen tool over the control point you want to change and click the control 
point when the pen tool icon becomes the corner point tool icon ( ).

• In the toolbox, select the corner point tool. If the corner point tool is not visible, click 
and hold one of the visible pen tool icons ( ) and choose the corner point tool from the 
menu.

Selecting masks and control points
Before you can modify or animate masks, you must know how to select them, especially 
when you’ve created more than one mask on a layer. Also, unlike layers, masks can have 
more than one level of selection. You can select a mask as a whole path, which is appro-
priate when you want to move or resize a mask. However, if you want to change the shape 
of a mask, select one or more points on a mask. Selected points appear solid, and 
unselected points appear hollow.

To select all or part of one or more masks in the Layer or Composition window:

1 Click the selection tool ( ).

2 Do one of the following:

• To select a point on a mask, click it.

• To select an entire mask by clicking, press Alt (Windows) or Option (Mac OS) as you click 
a mask. To select more masks, hold down Alt+Shift (Windows) or Option+Shift (Mac OS) 
as you click other masks.

• To select masks by dragging, hold down Shift, click inside the mask, and draw a 
marquee completely around the points or masks you want to select.

To use the selection tool when the pen tool is selected, hold down Ctrl (Windows) or 
Command (Mac OS).

To select masks in the Timeline window:

1 Click the right-facing arrow next to a layer name to expand it.

2 Click the right-facing arrow next to the Masks heading to expand it, revealing all masks 
on that layer.

3 Do any of the following:

• To select one mask, click its name.

• To select a contiguous range of masks, hold down Shift as you click the names of the 
first and last masks in the range.

• To select several discontiguous masks together, hold down Ctrl (Windows) or 
Command (Mac OS) as you click the names of any masks you want to include.

Note: You can select only whole masks in the Timeline window. To select individual points 
on a mask, use the Composition or Layer window.

To add or remove masks or control points to or from the selection:

Do one of the following:

• In the Composition window, use the selection tool ( ) to drag a marquee to enclose all 
points on all desired masks.
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• In the Layer window, press Shift as you drag a marquee over other unselected control 
points.

• In either the Layer or Composition window, select a mask and press Shift as you click 
other unselected masks with the selection tool.

To select all masks on a layer:

Choose Edit > Select All.

Scaling and rotating selected masks or points
In one step, you can scale and rotate an entire mask (or selected points in one or more 
masks) using the Free Transform Points command. When you use this command, a 
bounding box surrounds the selected points, and an anchor point displays in the center of 
the bounding box to mark the effect point for the current transformation. You can scale 
and rotate the selected control points by dragging the bounding box or its handles. You 
can also change the point from which the mask rotates or scales by moving the bounding 
box anchor point. The Free Transform Points bounding box handles and anchor point exist 
independently of the handles and anchor point for the layer.

Note: When you animate rotation using Free Transform Points, the vertices of the mask 
are interpolated in a straight line from keyframe to keyframe. Because of this, the results 
may be different than you expect.

A. Free Transform Points bounding box B. Bounding box handle  
C. Bounding box anchor point D. Layer anchor point

To move, scale, or rotate a mask or control points:

1 Display the layer containing the mask or masks you want to transform in the Compo-
sition or Layer window.

2 With the selection tool chosen, do one of the following:

• To change a certain number of points, select the control points you want to transform 
and choose Layer > Mask > Free Transform Points.

• To transform the entire mask, select it in the Timeline window and choose Layer > Mask 
> Free Transform Points.

3 To move the bounding box’s anchor point, position the selection tool over the 
bounding box anchor point ( ) until the selection tool changes to a move anchor point 
icon ( ). Drag to position the anchor point.

A

B

D

C
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4 Do any combination of the following:

• To move the mask or selected points, position the pointer inside the bounding box 
and drag.

• To scale the mask or selected points, position the pointer on a bounding box handle 
and, when the pointer changes to a straight, double-sided arrow ( ), drag to a new size. 
Hold down Shift as you drag to constrain the scale. Hold down Ctrl (Windows) or 
Command (Mac OS) as you drag to scale around the bounding box’s anchor point.

• To rotate the mask or selected points, position the pointer just outside the Free 
Transform bounding box and, when the pointer changes to a curved double-sided 
arrow ( ), drag to rotate.

5 To close the Free Transform bounding box, double-click anywhere in the Composition 
or Layer window.

Changing the shape of a mask
In the Layer or Composition window, you can freely change the shape of a mask. You can 
move, delete, or add control points to reshape a mask; create a flexible outline to accom-
modate any shape; and even change a mask shape over time.

Some changes require the use of tools grouped with the pen tool in the toolbox. To reveal 
these tools, click and hold the pen tool in the toolbox. When modifying a mask, make sure 
that you click only existing control points or segments; otherwise, you may create a new 
mask instead.

To change a mask shape numerically:

1 Select the mask.

2 In the Timeline window, expand the Mask options.

3 Next to the Mask Shape property, click the underlined word “Shape,” and specify the 
changes.

4 Click OK.

To replace one mask shape with another:

1 In the Layer window, select the mask you want to replace from the Target pop-up 
menu.

2 Draw a new mask shape.

Note: After you create the new mask shape in the Layer window, select None from the 
Target pop-up menu; otherwise, all subsequent masks you create will replace the targeted 
mask. See “Specifying one mask as the target for animation” on page 159.

To reset a mask to its default boundaries:

Select the mask in the Timeline window and choose Layer > Mask > Reset Mask.

To delete one mask:

Select the mask in the Timeline window and press Delete.
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To delete all masks:

Select the layer containing the masks you want to remove and choose Layer > Masks > 
Remove All Masks.

To move a control point:

Using the selection tool ( ), drag the control point.

You can temporarily switch from the pen tool to the selection tool by pressing Ctrl 
(Windows) or Command (Mac OS).

To add a control point to a mask:

Using the Add Control Point tool ( ), click the line between two existing control points.

To delete a control point from a mask:

1 Using the Delete Control Point tool ( ), click a point.

To adjust the shape of a curve segment:

Do one of the following with the selection tool:

• Drag a control point.

• Drag the direction lines extending from an adjoining smooth point.

• Drag a curved segment.

To change a control point from a corner to a smooth point or vice versa:

Do one of the following:

• Using the Convert Control Point tool ( ), click the control point. 

• Using the selection tool, press Ctrl (Windows) or Control (Mac OS) as you click the 
control point.

• Using the pen tool, click the control point.

Feathering mask edges
Using the Mask Feather property, you make mask edges hard-edged or soft-edged 
(feathered). By default, the feather width straddles the mask edge, half inside and half 
outside. For example, if you set the feather width to 25, the feathering extends 12.5 pixels 
inside the mask edge and 12.5 pixels outside it. You can also extend or contract the mask 
edges to control where the mask feathering appears. See “Adjusting the edges of a mask” 
on page 157.

A. No feather B. 2-pixel feather C. 40-pixel feather

A B C



Using Help | Contents | Index Back 157  

Adobe After Effects Help Working with Masks and Transparency 

Using Help | Contents | Index Back 157  

Mask feathering takes place only within the dimensions of the layer frame area. Therefore, 
a feathered mask shape should always be slightly smaller than the layer area. If a mask 
feather extends beyond the layer area, the feathered edge ends abruptly.

You can adjust the feathering of a layer’s mask by specifying precise values or by dragging 
in the Timeline window.

To adjust feathering by specifying precise values:

1 Select the mask that you want to adjust.

2 Expand the desired layer and its Mask Properties, right-click (Windows) or control-click 
(Mac OS) the underlined value for Mask Feather, and choose Edit Value.

3 Specify amounts for horizontal and vertical feathering (or type one value and select 
Lock to make both values the same) and click OK.

To adjust feathering in the Timeline window:

1 Expand the desired layer and its Mask properties.

2 Drag the underlined value for Mask Feather.

Note: When you adjust feathering by dragging the single underlined value in the Timeline 
window, you change both the horizontal and vertical feathering. To have the Timeline 
display both the horizontal and vertical values, first type different values for horizontal 
and vertical feathered edges using the above method for adjusting precise values.

Adjusting the edges of a mask
To finely expand or contract all the edges of a mask, use the Mask Expansion property. This 
property value represents, in pixels, how far from the original mask edge you are 
expanding or contracting the adjusted edge.

To adjust the edges of the mask using Mask Expansion:

1 In the Timeline window, expand the Mask properties of the layer you want to adjust.

2 Drag the underlined value for Mask Expansion.

Adjusting the opacity of a mask
Masks have an opacity property that you can use to adjust the transparency of any mask, 
or even to turn masks on and off temporarily.

To adjust the opacity of a mask:

1 In the Timeline window, expand the mask properties of the mask you want to adjust.

2 Drag the underlined value for Mask Opacity.



Using Help | Contents | Index Back 158  

Adobe After Effects Help Working with Masks and Transparency 

Using Help | Contents | Index Back 158  

Specifying which parts of a mask are inside and outside
The image area inside the mask outline is fully opaque, and the area outside the mask 
outline is transparent. If you want to create the appearance of a hole in a video layer to 
reveal a layer underneath, switch the inside and outside areas by inverting the mask. You 
cannot change the mask state using keyframes; a mask is either inverted or not inverted 
for the entire duration of a composition.

Default behavior for a drawn mask (left); same mask inverted (right)

To invert a drawn mask:

1 Select the mask you want to invert.

2 In the Timeline window, select the Inverted option next to the mask name.

If you have multiple masks in one layer, you can apply mask modes to create complex 
transparent shapes or varying levels of transparency. For more information, see 
“Controlling how masks in the same layer interact” on page 162.

Moving a mask and panning a layer behind a mask
You can adjust the area that displays through a mask by either moving the mask in the 
Layer or Composition window or panning (moving) the layer behind the mask in the 
Composition window. When you move a mask, the mask layer’s Position values remain 
constant, and the mask moves in relation to other objects in the Composition window. 
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When you use the Pan Behind tool to pan a layer behind a mask, the mask’s position 
remains constant in the Composition window, but changes in the Layer window. The 
masked layer’s Position values change in relation to the composition. As you pan past the 
edges of the layer’s frame, the layer’s Mask Shape values also change. Using the Pan 
Behind tool saves steps; without it, you would have to change the masked layer’s Position 
and Mask Shape properties manually. You can animate a layer panning behind another 
layer by setting keyframes for the masked layer’s Position and Mask Shape properties (see 
“Setting keyframes” on page 98).

When you use the Pan Behind tool in the Composition window, After Effects automatically makes 
two adjustments for you. In the Layer window, the mask is moved in relation to its layer (top), while 
in the Composition window, the layer is moved in relation to the composition (bottom).

To move a mask:

1 Select the mask or masks you want to move. See “Selecting masks and control points” 
on page 153 for information on selecting masks. 

2 In the Composition window, drag the mask or masks to a new location. To constrain the 
movement of the mask or masks to horizontal or vertical, press Shift after you start 
dragging.

To pan a layer behind its mask:

1 Select the Pan Behind tool in the toolbox ( ).

2 Click inside the mask area in the Composition window and drag the layer to a new 
position.

Specifying one mask as the target for animation
As soon as you draw the first point on your first mask for a layer, the Layer window displays 
a Target pop-up menu, which you use to specify a mask as the target for all new mask 
shapes. 

When you create a new mask shape while a mask is selected in the Target pop-up menu, 
the targeted mask is replaced by the new shape. You can change this behavior by 
selecting None from the pop-up menu so that any new mask shape you create in the Layer 
window creates a new mask instead of replacing an existing mask. You can also lock a 
mask to prevent changes to it. See “Locking a mask” on page 163.
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To specify a mask as the target of all new shapes:

In the Layer window, select the mask name from the Target pop-up menu.

To specify no mask as a target for changes:

In the Layer window, select None from the Target pop-up menu.

Animating a mask
You can change all of a layer’s Mask property values—Mask Shape, Mask Feather, Mask 
Opacity, or Mask Expansion—over time by using keyframes (see “Understanding 
keyframes” on page 96). 

To animate a mask shape, After Effects designates the topmost control point at the initial 
keyframe as the first vertex and “numbers” each successive control point in ascending 
order from the first vertex. After Effects then assigns the same numbers to the corre-
sponding control points at all successive keyframes. After Effects interpolates the 
movement of each control point from its initial position at one keyframe to the position of 
the correspondingly numbered control point at the next keyframe. At any time during an 
animation, you can designate another control point as the first vertex; this causes After 
Effects to renumber the control points of the shape you assigned a new first vertex, and 
the mask animates differently as After Effects now maps the new vertex numbers to the 
corresponding “old” vertex numbers still saved at successive keyframes.

To animate a mask property:

1 In the Timeline or Composition window, select the mask that you want to animate.

2 Move the current-time marker to the time where you want to begin the animation.

3 Expand the Mask properties and locate the property that you want to change.

4 Set a value for the mask property. For information on setting a mask value, see the 
corresponding section for the value you want to set. For example, for information on 
setting Mask Opacity, see “Adjusting the opacity of a mask” on page 157.

5 Set an initial keyframe. For information on setting keyframes, see “Setting keyframes” 
on page 98.

6 Move the current-time marker to the time where you want to add the second keyframe.

7 Change the value for the mask property.

Repeat steps 7 and 8 as many times as you want to add more keyframes.

Note: By default, when you add a control point to a mask, the new point appears on the 
mask throughout the mask’s duration but reshapes the mask only at the time it was 
added. When you delete a control point from a mask at a specific point in time, the point is 
deleted from the mask throughout the mask’s duration. Prevent After Effects from adding 
and deleting control points throughout the mask’s duration by choosing Edit > Prefer-
ences > General and deselecting Preserve Constant Vertex Count When Editing Masks. 

To designate another control point as the first vertex:

1 Create an animated mask shape, as described in the previous procedure.

2 In the Timeline window, move the current time marker to the point where you want to 
designate a new first vertex.
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3 Select the control point you want to designate as the first vertex. (See “Selecting masks 
and control points” on page 153 for information on selecting a control point.) 

4 Choose Layer > Mask > Set First Vertex.

Note: The control point designated as the first vertex appears slightly larger than the other 
control points in the Composition window.

Importing masks from Adobe Illustrator and Adobe 
Photoshop
You can import paths from Adobe Illustrator or Adobe Photoshop and use them in After 
Effects layers. Using the special path-editing tools available in these applications, you can 
create a wider variety of shapes for your After Effects masks.

Path in Adobe Illustrator (left), and that same path imported into an After Effects Layer window as a 
mask (right)

To import a path from Adobe Illustrator or Adobe Photoshop:

1 Open Adobe Illustrator or Adobe Photoshop and create a path. For more information 
about creating a path in Adobe Illustrator or Adobe Photoshop, see the user guide for the 
application.

2 Select all of the control points on the path that you want to copy to After Effects.

3 Choose Edit > Copy.

4 Open After Effects.

5 Open the Layer or Composition window into which you want to paste the path, and 
choose Edit > Paste.

Note: Each path from Adobe Illustrator or Adobe Photoshop is imported into After Effects 
as one mask.

Applying effects to a mask
You can apply the following standard After Effects effects to a mask shape: Path Text, 
Audio Waveform, Audio Spectrum, Stroke, Fill (closed paths only), and Smear (closed paths 
only). You can apply the following After Effects Production Bundle effects to a mask shape: 
Reshape (closed paths only), Vegas, and the Inner Outer Key (closed paths only). The 
Production Bundle effect Particle Playground can also use a mask shape to define effect 
boundaries.

You may also be able to use masks with effects from other manufacturers. To find out 
where to get more information on the effects listed, see the index.
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Creating visible lines and solid shapes from masks
To outline or fill a mask, apply the Stroke (outline) and/or the Fill effect. Each mask in a 
layer can have different fill and stoke settings. You can apply an outline to an open or 
closed mask path, but if you want to fill a mask, it must be a closed path. See “Working 
with effects” on page 170 for information on using effects.

Controlling how masks in the same layer interact
Transfer modes for masks control how different masks within a layer interact with one 
another. By default, all masks are set to Add, which combines the transparency values of 
any masks that overlap on the same layer. You can apply one mode to each mask, but you 
cannot change a mask’s mode over time. 

The first mask you create interacts with the layer’s alpha channel. If that channel doesn’t 
define the entire image as opaque, then the mask interacts with the layer frame. Each 
additional mask you create interacts with masks located above it in the Timeline window 
outline. The results of mask modes vary depending on the modes set for the masks higher 
up in the outline. You can use mask modes only between masks in the same layer. For 
more information on working with mask modes, see “Using mask modes” on page 162. 

Using mask modes
Using mask modes, you can create complex mask shapes with multiple transparent areas. 
For example, you can set a mask mode that combines two masks and sets the opaque area 
to the areas where the two masks intersect.

Mask shapes that result when different modes are applied to circle mask:  
A. Original masks B. None C. Add D. Subtract E. Intersect F. Difference 

The following mask mode descriptions are based on interactions between two layer 
masks—the top set to Add, the other set to the mask mode described:

A B C

D E F
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None After Effects treats the mask as if it does not exist. The mask has no impact on the 
layer or composition. This option is useful when you want to use the mask’s path for an 
effect such as Stroke or Fill, but do not want it to create transparent areas in the layer. For 
more information, see “Applying effects to a mask” on page 161.

Add Adds the selected mask area to the other masks for that layer, displaying all mask 
contents in the Composition window. Where multiple masks intersect, the opacity of all 
intersecting masks is added together.

Subtract Subtracts the mask from all masks located above it in the Timeline window. The 
contents of the subtracted mask area display as a hole in the Composition window. This 
option is useful when you want to create the appearance of a hole in the center of another 
mask.

Intersect Adds the mask to all masks above it, but displays in the Composition window 
only the area where the selected mask and any of the previous masks intersect. Where 
multiple masks intersect, the opacity of all intersecting masks is added together.

Lighten Adds the mask to all the masks above it, displaying contents of all masked areas 
in the Composition. Where multiple masks intersect, the highest opacity value is used, so 
opacity doesn’t build up.

Darken Adds the mask to all masks above it, but displays in the Composition window 
only the area where the selected mask and any of the others intersect. Where multiple 
masks intersect, the highest transparency value is used, so transparency doesn’t build up.

Difference Adds the selected mask to the masks above it, and displays in the Compo-
sition window the mask contents of all masked areas except those areas where the masks 
intersect.

To apply a mask mode: 

1 In the Timeline window, select the layer containing the mask to which you want to 
apply a mode and press M.

2 Click the menu next to the mask name and choose a mask mode.

Modifying multiple masks
If you have selected several masks, you can lock, unlock, invert, or change the modes of all 
of the selected masks at once. The choice you make for one mask is applied to all the 
masks.

To modify several masks at once:

1 Select the masks you want to modify. See “Selecting masks and control points” on 
page 153.

2 Select a mask mode; or lock, unlock, or invert one layer’s mask.

Locking a mask
Locking a mask prevents you from selecting it in the Timeline, Composition, and Layer 
windows or setting it as a target in the Layer window. Use this feature to avoid unwanted 
changes to the mask.
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To lock or unlock a mask:

1 In the Timeline window, expand the Mask property.

2 In the Switches column, click the box underneath the lock icon ( ) next to the mask you 
want to lock or unlock. A layer is locked when the lock icon appears in the box.

Reusing a mask
You can reuse masks in other layers and compositions. It is particularly useful to store 
Bezier masks you’ve spent a long time perfecting. You can even create a project with 
compositions that exist just to store complex layer masks. Mask shapes are stored inside a 
composition, not as an external file on your hard disk. When you want to use a mask from 
another project, import that project into your current project.

To save a mask:

1 In the Timeline window for the composition containing the layer and mask you want to 
save, expand the layer and its mask properties.

2 Do one of the following:

• To save an animated mask, select the mask keyframes you want to save. For more infor-
mation, see “Setting keyframes” on page 98.

• To save a nonanimated mask, select the I-beam for the mask.

3 Copy the mask or keyframes and paste to a new layer (this can be a simple solid).

To reuse a mask:

1 Open the composition containing the mask you want to reuse. If you saved the mask in 
another project, import the project and then open the mask’s composition.

2 In the Timeline window, expand the saved mask’s layer and mask properties.

3 Select the mask path or keyframes.

4 Copy the mask or keyframes and paste to the new layer.

Creating track mattes and traveling mattes
When you want one layer to show through a hole in another layer, set up a track matte. 
You’ll need two layers—one to act as a matte, and another to fill the hole in the matte.

You can animate either the track matte layer or the fill layer. When you animate the track 
matte layer, you create a traveling matte. If you want to animate the track matte and fill 
layers using identical settings, consider precomposing them (see “Understanding precom-
posing” on page 270).
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Using alpha channel or luminance values for a track matte
Define transparency in a track matte using values from either its alpha channel or the 
luminance of its pixels. Using luminance is useful when you want to create a track matte 
using a layer without an alpha channel or a layer imported from a program that can’t 
create an alpha channel. In both alpha channel mattes and luminance mattes, pixels with 
higher values are more transparent. In most cases, you use a high-contrast matte so that 
areas are either completely transparent or completely opaque. Intermediate shades 
should appear only where you want partial or gradual transparency, such as along a soft 
edge.

To create a track matte:

1 Click the Switches/Modes button at the bottom of the Timeline window. The Transfer 
Modes panel appears in place of the Layer Features panel. You can also show the Transfer 
Modes panel and the Switches panel simultaneously. See “Optional panels” on page 66 for 
information on showing panels.

2 Arrange two layers in the Timeline window. Make sure that the designated matte layer 
is directly above the designated fill layer.

3 From the TrkMat menu for the fill layer, define transparency in the next layer above by 
choosing one of the following:

No Track Matte No transparency created; next layer above acts as a normal layer.

Alpha Matte Opaque when alpha channel pixel value is 100%.

Alpha Inverted Matte Opaque when alpha channel pixel value is 0%.

Luma Matte Opaque when a pixel’s luminance value is 100%.

Luma Inverted Matte Opaque when a pixel’s luminance value is 0%.

After Effects converts the next layer above into a track matte, turns off the video of the 
track matte layer, and adds a track matte icon ( ) next to the track matte layer’s name in 
the Timeline window. The Composition window displays the fill layer viewed through the 
alpha channel of the matte layer.

Note: Although the video is turned off for the matte layer, you can still select the layer to 
reposition, scale, or rotate it. Select the layer in the Timeline window, and then drag the 
center (indicated by a circle with an X) of the layer in the Composition window.

Preserving underlying transparency during compositing
The Preserve Underlying Transparency option specifies that the opaque areas of a layer 
display only when positioned over opaque areas in underlying layers. With this option, 
you can make a layer display only when it is positioned over the layer below it. It’s useful 
for creating effects such as glints or light reflecting off a polished surface.
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To preserve underlying transparency:

Select the T option in the Layer Switches column for the appropriate layer.

Using layer modes
Layer modes control how each layer blends with or reacts to layers beneath it. The stencil 
and silhouette layer modes affect the alpha channels of layers beneath them. Other layer 
modes affect how colors appear when blended with the colors from other layers. Layer 
modes in After Effects are identical to layer modes in Adobe Photoshop.

Layer modes cannot be animated using keyframes. If you want a layer mode to change at 
a certain time, split the layer at that time and apply the new layer mode to the part of the 
layer that continues. You can also use the Compound Arithmetic effects, which are similar 
to layer modes but can change over time. For more information on splitting layers, see 
“Creating new layers by splitting” on page 74. For more information on Compound Arith-
metic effects, see “Compound Arithmetic” on page 190.

When using layer modes, it is helpful to think of the effects in the following terms:

• The underlying colors are the colors of the layers located below the layer to which you 
want to apply the mode.

• The layer colors are the original colors in the layer where you set the layer mode.

• The resulting colors are the final colors displayed.

Specifying a layer mode
You can apply one of the following layer modes to a layer:

Normal Composites the layer on top of underlying layers.

Dissolve Randomly replaces layer colors with colors from underlying layers, based on 
layer transparency.

Dancing Dissolve Functions the same as the Dissolve option, except that the placement 
of random color changes varies over time.

Add Combines the color values of the layer and underlying colors. The resulting color is 
lighter than the original. This is a good way to combine nonoverlapping images in two 
layers. Pure black in a layer does not change the underlying color. Pure white in the under-
lying color is never changed.

Multiply Multiplies the color values in the layers and divides the result by the maximum 
pixel value of either 8-bit or 16-bit pixels, depending on which mode you are in. The 
resulting color is never brighter than the original.

Screen Multiplies the inverse brightness values of the colors in all layers. The resulting 
color is never darker than the original. Using the Screen option is similar to the traditional 
technique of superimposing two different film negatives and printing the result.
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Overlay Mixes colors between layers, preserving highlights and shadows to reflect the 
light and dark areas of the layer colors.

Soft Light Darkens or lightens resulting colors, depending on the layer color. The effect is 
similar to shining a diffused spotlight on the layer. If the underlying color is lighter than 
50% gray, the layer lightens. If the underlying color is darker than 50% gray, the layer 
darkens. A layer with pure black or white becomes markedly darker or lighter, but does not 
result in pure black or white.

Hard Light Multiplies or screens the resulting color depending on the original layer 
color. The effect is similar to shining a harsh spotlight on the layer. If the underlying color is 
lighter than 50% gray, the layer lightens as if it were screened. If the underlying color is 
darker than 50% gray, the layer darkens as if it were multiplied. This option is useful for 
creating the appearance of shadows on a layer.

Color Dodge Brightens the resulting color based on the original layer color. The lighter 
the original layer color, the brighter the resulting color. Pure black in the original layer 
does not change the underlying color. Pure white in the original layer usually changes the 
underlying color to white.

Color Burn Darkens the resulting color based on the original layer color. The darker the 
original layer color, the darker the resulting color. Pure white in the original layer does not 
change the underlying color. Pure black in the original layer usually changes the under-
lying color to black.

Darken Compares the channel values of the underlying and layer colors and displays the 
darker of the two. Specifying this option can cause color shifts in layers with color.

Lighten Compares the channel values of the underlying and layer colors and displays the 
lighter of the two. Specifying this option can cause color shifts in layers with color.

Difference Subtracts the channel values of the layer and underlying colors and displays 
the absolute value of the result.

Exclusion Creates an effect similar to but lower in contrast than the Difference mode. 
Blending with white inverts the base color values. Blending with black produces no 
change.

Hue Creates resulting colors with the luminance and saturation of the underlying colors 
and the hue of the layer colors.

Saturation Creates resulting colors with the luminance and hue of the underlying colors 
and the saturation of the layer colors. If you use this option with a layer having no 
saturation (gray), there is no change.

Color Creates resulting colors with the luminance of the underlying colors and the hue 
and saturation of the layer colors. This preserves the gray levels in the image.

Luminosity Creates resulting colors with the hue and saturation of the underlying colors 
and the luminance of the layer colors. This option is the inverse of the Color option.

Alpha Add Composites layers normally, but adds complementary alpha channels 
together to create a seamless area of transparency. Useful for removing visible edges from 
two alpha channels that are inverted relative to each other, or from the alpha channel 
edges of two touching layers that are being animated.
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Luminescent Premul Prevents clipping of color values that exceed the alpha channel 
value after compositing by adding them to the composition. Useful for compositing 
rendered lens or light effects (such as lens flare) from footage with premultiplied alpha 
channels. May also improve results when compositing footage from other manufacturers’ 
matting software. When applying this mode, you may get the best results by changing 
After Effects’ interpretation of the premultiplied-alpha source footage to straight alpha 
(see “Interpreting alpha channels as straight or premultiplied” on page 31).

To apply a layer mode:

1 If the Mode menu is not visible in the Timeline window, click the Switches/Mode button 
at the bottom of the Timeline window.

2 From the layer’s Mode pop-up menu, choose a mode.

Using stencil and silhouette layer modes
The stencil and silhouette layer modes use either a layer’s alpha channel or its luminance 
(luma) values to affect the alpha channel of all layers beneath the layer. This differs from 
the track matte, which affects only one layer. 

Stencil mode Cuts through all layers, so you can show multiple layers through the frame 
of the stencil layer’s alpha channel.

Silhouette mode Blocks out all layers below it, so you can cut a hole through several 
layers at once.

Note: The stencil and silhouette layer modes affect all layers below the layer to which they 
are applied. To keep the silhouette and stencil layer modes from cutting through or 
blocking all layers underneath, nest the layer in a composition. For more information on 
nesting, see “Creating animations by nesting compositions” on page 267.

With Stencil Luma, the lighter pixels of the layer are more opaque than the darker pixels. 
With Silhouette Luma, the lighter pixels of the layer are more transparent than the darker 
pixels.

Stencil (left) shows all layers below through the frame of the stencil layer’s alpha 
channel. Silhouette (right) cuts a hole through all layers below.

To use the stencil or silhouette modes on a layer:

1 Choose Transfer Controls from the pop-up menu at the bottom of the Timeline window.

2 From the Mode pop-up menu for the layer you want to use as a stencil or silhouette, 
choose one of the following:

• Stencil Alpha creates a stencil using the layer’s alpha channel.

• Stencil Luma creates a stencil using the layer’s luma values.

• Silhouette Alpha creates a silhouette using the layer’s alpha channel.

• Silhouette Luma creates a silhouette using the layer’s luma values.
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Creating transparency using keying
You can make parts of a footage file transparent by keying out a color or luminance value. 
Keying makes it easy to key objects moving across a consistent background color or 
objects too complex to mask easily. When you key out a value, all pixels that have similar 
colors or luminance values become transparent. This technique is often called 
bluescreening, although you do not have to use blue; you can use any solid color for a 
background. For information on using keying effects, see “Using keying effects” on 
page 176.

Note: To get more powerful keying capabilities, use the advanced keying effects available 
in the Adobe After Effects Production Bundle.
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Applying Effects

Learning about specific effects
All effects included in After Effects are listed and described in online Help. You can print 
any Help topic at any time.

For detailed information about an effect’s controls, and specific procedures on certain 
effects, see the After Effects product section on Adobe’s Web site.

Working with effects
When you apply an effect to a layer, the Effect Controls window opens; the effect is listed 
there. Each layer to which you apply effects appears on its own tab in the Effect Controls 
window. The effect is also listed in the Effects section under the layer name in the Timeline 
window. If you apply additional effects to the layer, they are listed under the first effect in 
the Timeline window. Effects are rendered in order from top to bottom in this list. You 
change the order in which effects are rendered by dragging the effect name to a new 
position in the list.

The Effect Controls window contains a variety of controls that modify the properties of an 
effect, including sliders, options, color swatches, effect points, and angles. 

Applying and controlling effects
You can apply or remove an effect at any time. Once you’ve applied effects to a layer, you 
can temporarily turn off one or all the effects in the layer to concentrate on another aspect 
of your composition. Effects that are turned off do not appear in the Composition window 
and typically are not included when the layer is previewed or rendered. (However, in the 
Render Queue window, you can specify that the composition is rendered with all effects 
on, regardless of which effects you are displaying in the Composition window.) Turning off 
an effect does not delete the keyframes created for any of the effect properties; all 
keyframes remain until the effect is deleted from the layer.

By default, when you apply an effect to a layer, the effect is active for the duration of the 
layer. However, you can make an effect start and stop at specific times, or make the effect 
more or less intense over time, by using keyframes.

To apply an effect to a layer:

1 In the Timeline or Composition window, select a layer.

2 Choose a category from the Effect menu, and then choose an effect from the submenu.

Using this procedure, you can apply multiple instances of a single effect to a layer.

To open the Effect Controls window:

In the Timeline window, double-click an effect name, or choose Effect > Effect Controls.
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To change the color of hot text in the Effect Controls window (or any window):

1 Choose Edit > Preferences > Display.

2 Click the Hot Text Color color swatch to select a color, or click the eyedropper to sample 
a color from anywhere on the screen. Then click OK.

To select a layer in the Effect Controls window:

Click the tab below the Effect Controls title bar for the layer you want to select.

To open the Options dialog box for an effect:

In the Effect Controls window, click Options to the right of the effect name.

Note: Not all effects include an Options dialog box.

To copy effects in a layer and paste them into other layers:

1 In the Effect Controls window, select one or more effects, and then choose Edit > Copy.

2 In the Timeline window, select one or more layers, and then choose Edit > Paste.

To temporarily turn off an effect:

In the Effect Controls or Timeline window, select the layer, and then click the Effect option 
to the left of the effect name.

A. The Effect option in the Effect Controls window turns a specific effect on or off. B. The Effect 
option in 
the Timeline window also turns a specific effect on or off. C. The Effect switch in the Switches panel 
of the 
Timeline window turns all effects in a layer on or off.

To temporarily turn off all effects in a layer:

In the Timeline window, click the Effect switch in the Switches panel for the desired layer.

To remove an effect:

In the Effect Controls window, select an effect name and press Delete.

To apply multiple effects to one or more layers:

1 In the Timeline window, select a layer or group of layers.

2 Choose a category from the Effect menu, and then choose an effect from the submenu.

3 Repeat step 2.

A CB
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To remove all effects applied to a layer:

1 In the Timeline or Composition window, select the layer or layers from which you want 
to remove all effects.

2 Choose Effect > Remove All.

Note: This command eliminates all keyframes for the deleted effects. If you choose 
Remove All accidentally, immediately choose Edit > Undo to restore the effects and 
keyframes.

Saving favorite effects for instant reuse
You can save settings of one or more effects as a favorite effect. Saving an effect as a 
favorite saves any set keyframes, as well as expressions used in the effect. For example, 
suppose you design an effect for a ray gun hitting its target by using a complex combi-
nation of brightness, lens flare, and distortion settings that change over time. The 20 most 
recently saved or applied favorites appear under Recent Favorites in the Effect menu.

To save a favorite effect:

1 Select a layer in the Timeline or Composition window, and apply one or more effects to 
it. If you want, animate the effect using keyframes.

2 In the Effect Controls window for that layer, select one or more effects to include in this 
favorite.

3 Choose Effect > Save Favorite. Specify a filename and location, and click Save.

To apply a favorite effect:

1 Select one or more layers.

2 Do one of the following:

• To apply a recently used or saved favorite, choose Effect > Recent Favorites, and then 
choose the favorite.

• To apply a favorite that isn’t available on the Recent Favorites menu, choose Effect > 
Apply Favorite, locate the favorite effects (.FFX) file you want, and click Open.

Working with effects in 16 bits (PB only)
Many effects in After Effects support 16 bits per channel. If an effect supports only 8 bits, 
and your project is set to 16 bits, After Effects displays a warning icon ( ) next to the effect 
name in the Effect Controls palette. Using an 8-bit effect in a 16-bit project will result in a 
loss of detail.

Changing effect property values
The Effect Controls window shows all the controls used to change the property values for 
an effect. These controls can include underlined values, sliders, effect point icons, angle 
controls, menus, color swatches, eyedroppers, and graphs.
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You can also change the property values for an effect in the Timeline window, although 
using the Effect Controls window is often quicker and easier.

A. Click to expand or collapse an effect’s controls. B. Drag left to 
decrease or right to increase a value. C. Click to set or remove 
keyframes. D. Click to return to the default values. E. Drag or 
type to set a new value. F. Drag the line in the angle control 
to set a new value.

To change the value of an effect property:

1 In the Effect Controls window, click the effect name to select it.

2 If the effect’s controls are not visible, click the triangle to the left of the effect name.

3 Change the value using one of the following methods:

• Drag the slider left or right, if available.

• Drag the highlighted value or type a new value directly over the existing value.

• Click Reset to select default values.

To set an angle:

Set the angle using one of the following methods:

• Click a point inside the angle control ( ).

• Click and drag the angle control line.

Note: Once you have clicked inside the angle control, you can drag outside of it for more 
precision.

• Drag the highlighted value or type a new value directly over the existing value.

Note: You can set an angle of more than 360 degrees by dragging the angle line around 
the circle more than once or by typing a new angle value.

To set a color value for an effect:

Set the color value using one of the following methods:

• In the Effect Controls window, click the color swatch, select a color in the Color dialog 
box, and click OK.

• Click the eyedropper ( ), position it on the desired color anywhere on the screen, and 
click to select the color.

A
D

E

F

B

C
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Placing an effect using effect points
Some effects require that you identify specific positions on a layer to determine how the 
effect will be applied. Often, these effect points enable After Effects to properly position 
the effect on the layer. A given effect may require as few as one or as many as four or more 
effect points.

Note: The positions of these effect points are based on the coordinate system for the layer, 
not for the composition. The coordinates shown in the Info palette are layer coordinates 
when you’re working in the Layer window.

To set an effect point:

Select the effect and then do one of the following:

• Click the effect point icon ( ) in the Composition window and drag. The coordinates in 
the Effect Controls window change as you drag.

• Click the effect point icon ( ) in the Effect Controls window; then, in the Composition 
or Layer window, position the cursor where you want the effect point, and click.

• In the Effect Controls palette, drag the x-axis, y-axis, and z-axis (if available) position 
coordinates (located to the right of the effect point icon) or type over the highlighted 
coordinates.

To view the effect point or path in the Layer or Composition window:

Select the effect name in the Layer window menu.

Changing effects over time
By default, when you apply an effect to a layer, the controls you specify do not change for 
the duration of a layer. However, you can change an effect over time by assigning a 
keyframe to one of the effect’s properties at the time you want a change to happen, and 
then changing the effect controls at that keyframe. For more information about setting 
keyframes and creating changes over time, see “Setting keyframes” on page 98.

To set a keyframe for an effect:

In the Effect Controls window or the Timeline, click the stopwatch next to the effect 
property for which you want to set a keyframe.

Positioning effects on layers
After Effects renders all effects using subpixel positioning, a highly accurate interpolation 
that calculates a layer’s position to thousandths of a pixel. Effects are calculated to a level 
of precision higher than the resolution displayed on-screen, which results in smooth, high-
quality effects and animations. Positioning with subpixel accuracy may soften pixels when 
used with blending or smoothing effects.

To position an effect exactly where you want it:

1 Select Effect Controls from the Composition window menu to make the effect points 
visible.
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2 Zoom in on the layer in the Composition window. The more you zoom in, the more 
accurate you can be. Effect points for effects are interpolated throughout the area of the 
image.

Note: A layer must be set to Best quality to take advantage of subpixel accuracy. However, 
for faster editing you can keep layers at Draft quality until you render a finished movie.

Applying an effect to several layers with an adjustment 
layer
You apply and edit effects to an adjustment layer just as you do to any other layer. 
However, when you apply an effect to an adjustment layer, the effect is applied to all layers 
below it in the Timeline window. For more information, see “Creating an adjustment layer” 
on page 73.

Changing rendering order
When you apply more than one effect to a layer, the final result may depend on the order 
in which those effects are applied. To change the order in which effects are applied, drag 
the effect name to a new position in the Effect Controls window or the Timeline window.

The order in which After Effects renders masks, effects, and transform properties, called 
the rendering order, may affect the final result of an applied effect. To achieve certain 
effects, change the default rendering order so that a transform property is rendered 
before an effect in a layer, instead of after the effect. For information on changing the 
rendering order, see “Understanding default rendering order” on page 266.

Using audio effects
Any audio effect can be customized to radically change the sound of the original audio. 
For more impact, you can duplicate a layer that contains audio effects, add additional 
audio effects to the duplicate layer, and then turn off the original layer’s effects to hear 
only the processed audio.

Many audio effects include Dry Out and Wet Out options. Use these to specify the mix of 
unprocessed (Dry) and processed (Wet) audio in the final output.

For information on audio effects, see “Audio effects” on page 184.

Using cameras and lights with effects
Some of the After Effects effects, called Comp Camera effects, can use a composition's 
camera and lights. Some always use the composition camera, while others include light 
and camera options in the Effect Controls window. Comp Camera effects are characterized 
with a 3D cube beside their names in the Effect Controls window. When you apply a Comp 
Camera effect to a layer (2D only), it can track the composition’s camera and light positions 
and render a 3D image on the 2D layer to which it is applied. For more information on 
cameras and lights, see “Using cameras” on page 235 and “Using lights” on page 239.

The effect’s results appear 3D; however, the layer with the Comp Camera effect applied 
remains a 2D layer and consequently has the following characteristics:
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• 3D layers above and below it in the Timeline window cannot interact with one another.

• It can be relocated anywhere in the Timeline window’s stacking order.

• It cannot interact with other Comp Camera effects, 3D layers, or shadows.

• The image is rendered on the layer, not the composition. Consequently, apply Comp 
Camera effects to layers that are the same size as the composition and are exactly 
centered in the composition.

Using Adobe Photoshop layer styles in After Effects
After Effects supports the following layer styles from Adobe Photoshop: Drop Shadow, 
Inner Shadow, Bevel/Emboss, Inner Glow, Outer Glow, and Solid Fill. If you apply layer 
styles in Photoshop and then import the file into After Effects, the styles are also imported; 
however, not all options in each style are transferred over. You can edit the styles in the 
Effect Controls window. 

Using keying effects
After Effects includes several different effects that key out, or make transparent, parts of an 
image. Each effect is called a key, and the color specified for transparency is called the key 
color. A key locates pixels in an image that match the specified key color and makes them 
transparent or semitransparent, depending on the type of key. When you place a layer 
over another layer using transparency, the result forms a composite, in which the 
background is visible wherever the first layer is transparent, making the first layer appear 
to be part of the background.

After Effects creates an alpha channel for identifying areas in an image that are partially or 
completely transparent. The view of an image in its alpha channel is often called the matte 
view. The matte represents opaque, transparent, and partially transparent areas as white, 
black, and gray, respectively. For more information on alpha channels and mattes, see 
“Importing footage containing an alpha channel” on page 30. For information on using 
the keys included with After Effects, see “Keying effects” on page 199.

You often see composites in movies, for example, when an actor appears to dangle from a 
helicopter or float in outer space. To create this effect, the actor is filmed in an appropriate 
position against a color screen. The color screen is then keyed out and the actor’s scene is 
composited over the background footage item. 

For satisfactory keying results, start with the highest-quality materials you can gather, 
such as film that you scan and digitize. Strive for lighting that is constant for the 

duration of the color-screen scene. Use footage files with the least amount of 
compression. Files with lossy compression, especially DV and Motion JPEG files, discard 
subtle differences in blue. These differences may be necessary to create a good matte 
from a bluescreen.

Adjusting keying controls on a single frame
For evenly lit bluescreen footage, adjust keying controls on only one frame. Choose the 
most intricate frame of the scene, one involving fine detail such as hair and transparent or 
semitransparent objects, such as smoke or glass. If the lighting is constant, the same 
settings you apply to the first frame are applied to all subsequent frames. 



Using Help | Contents | Index Back 177  

Adobe After Effects Help Applying Effects 

Using Help | Contents | Index Back 177  

If lighting changes, you may need to adjust keying controls for other frames. Place 
keyframes for the first set of keying properties at the start of the bluescreen scene. If you 
are setting keyframes for one property only, use Linear interpolation. For footage that 
requires keyframes for multiple interacting properties, use Hold interpolation (see “Hold 
interpolation” on page 125).

If you set keyframes for keying properties, you may want to check the results frame by 
frame. Intermediate keying values may appear, producing unexpected results.

Using a background color
To help you view transparency, temporarily change the background color of the compo-
sition, or include a background layer behind the layer you are keying out. As you apply the 
key to the layer in the foreground, the composition background (or a background layer) 
shows through, making it easy to view transparent areas.

Working with binary keys
The simplest type of key is the binary key, which creates pixels that are either transparent 
or opaque. Pixels that match the specified key color are made transparent; those that don’t 
match remain opaque. Because binary keys do not create semitransparent pixels, they are 
best for solid objects with sharp, defined edges, such as titles or credits, or for footage 
items with a solid color background and no changes in background lighting.

Working with linear keys
Linear keys create a range of transparency across an image. A linear key compares each 
pixel in the image to the key color you specified. If the color of a pixel closely matches the 
key color, it becomes completely transparent. Pixels that don’t match as well are made less 
transparent, and pixels that don’t match at all remain opaque. The range of transparency 
values, therefore, forms a linear progression.

Working with matte tools
Once you have used a key to create transparency, use matte tools to remove traces of key 
color and create clean edges. The Production Bundle includes the following matte tools: 
Simple Choker, Matte Choker, Alpha Levels, and Spill Suppressor. 

Using a garbage matte
A garbage matte is merely a portion of a bluescreen scene that contains only the subject 
that you need. The remainder of the scene, which may contain undesired objects, is not 
important and is masked out. The keyed subject can be placed in another scene for still 
sequences or simple effects.

To create a garbage matte:

1 Use the Mask Tool to roughly outline a subject in bluescreen footage.

2 Apply one or more keys to mask out the remainder of the bluescreen scene.

3 Apply matte tools as necessary to fine-tune the matte.
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Using a hold-out matte
A hold-out matte (also known as a hold-back matte) is a duplicate of the layer you have 
keyed. The hold-out matte, however, is masked to include only the area of the image 
containing the key color that you want to preserve as opaque. The hold-out matte is then 
placed directly on top of the keyed layer; when rendered, the hold-out matte prevents the 
area from becoming transparent.

Typically, you would create a hold-out matte for only one or two frames, when the subject 
is in a particular position that makes the color visible. Hold-out mattes are not recom-
mended for preserving color for longer periods of time because the effect may become 
more obviously visible.

A. Original bluescreen image. The number’s background is also blue. B. After keying, the number’s 
background is also transparent. C. Hold-out matte containing the part of the image you want to 
remain opaque D. When the hold-out matte is placed on top of the keyed image, the number’s 
background is now opaque.

To create a hold-out matte:

1 Apply any Transform property keyframes to the original layer containing the color 
screen.

2 Duplicate the layer containing the color screen.

3 In the original, apply keys and matte tools to create transparency.

4 In the copy, find the frame that contains the area you want to preserve, and then use 
the Mask Tool to mask out everything in the image except the area you want to preserve.

5 Make sure that the copy (the hold-out matte) is positioned directly on top of the keyed 
layer and contains exactly the same keyframes with the same values. Then render the 
movie.

A B

C D
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Sequencing and combining keys
When creating transparency in footage, you may need to try different keys before you are 
satisfied with the results. You can also combine two or more keys or matte tools. Because 
keys are treated as effects, you can easily turn them on or off by clicking the Effect option 
to the left of the effect name in the Effect Controls window or in the Timeline window. Use 
the following recommendations for combining keys for specific types of footage items:

• To create transparency in well-lit footage shot against a bluescreen or greenscreen, 
start with the Color Difference Key. Add the Spill Suppressor to remove traces of the key 
color, and then use one or more of the other matte refinement tools, if necessary. If you 
are not satisfied with the results, try starting again with the Linear Color Key.

• To create transparency in footage shot against multiple colors, or to create trans-
parency in unevenly lit footage shot against a bluescreen or greenscreen, start with the 
Color Range key. Add the Spill Suppressor and other tools to refine the matte. If you are 
not completely satisfied with the results, try starting with or adding the Linear Color 
Key.

• To create transparency in dark areas or shadows, use the Extract Key on the Luminance 
channel.

• To make a static background scene transparent, use the Difference Matte Key. Add the 
Simple Choker and other tools as needed to refine the matte.

Effects included with After Effects
After Effects includes an array of visual and audio effects. And, because of After Effects’ 
plug-in technology, you can use additional effects from other Adobe plug-in-compatible 
applications, such as Adobe Photoshop.

When you register your copy of After Effects, you can download the following effects from 
the After Effects product section on Adobe’s Web site: Card Dance, Card Wipe, Caustics, 
Foam, and Wave World.

Effects are categorized by functionality. Because you can add new effects and delete 
unused ones at any time, your menu and submenu selections may be different than those 
described here. Check the Read Me file included with After Effects for the latest available 
effects.

Standard version effects
The standard version of After Effects include the following categories and effects:

Adjust Brightness & Contrast, Channel Mixer, Color Balance, Curves, Hue/Saturation, 
Levels, Posterize, and Threshold

Audio Backwards, Bass & Treble, Delay, and Stereo Mixer

Blur & Sharpen Channel Blur, Compound Blur, Directional Blur, Fast Blur, Gaussian Blur, 
Radial Blur, Sharpen, and Unsharp Mask

Channel Arithmetic, Blend, Cineon Converter, Compound Arithmetic, Invert, Minimax, 
Remove Color Matting, Set Channels, Set Matte, and Shift Channels

Distort Mirror, Offset, Polar Coordinates, PS+Pinch, PS+Ripple, PS+Spherize, PS+Twirl, 
PS+Wave, PS+ZigZag, Smear, Spherize, and Transform
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Image Control Change Color, Color Balance (HLS), Colorama, Equalize, Gamma/Pedestal/
Gain, Median, PS Arbitrary Map, and Tint

Keying Color Key and Luma Key

Perspective Basic 3D, Bevel Alpha, Bevel Edges, and Drop Shadow

Render Audio Spectrum, Audio Waveform, Beam, Ellipse, Fill, Fractal, PS+Lens Flare, 
Ramp, Radio Waves, Stroke, and Vegas

Simulation Card Dance, Caustics, Foam, Shatter, and Wave World

Stylize Brush Strokes, Color Emboss, Emboss, Find Edges, Leave Color, Mosaic, Motion 
Tile, Noise, PS+Extrude, PS+Tiles, Strobe Light, Texturize, and Write-on

Text Basic Text, Numbers, and Path Text

Time Echo and Posterize Time

Transition Block Dissolve, Card Wipe, Gradient Wipe, Iris Wipe, Linear Wipe, Radial Wipe, 
and Venetian Blinds

Video Broadcast Colors, Reduce Interlace Flicker, and Timecode

Production Bundle-only effects
The Production Bundle version of After Effects includes all of the effects available in the 
standard version as well as the following:

3D Channel 3D Channel Extract, Depth Matte, Depth of Field, Fog 3D, and ID Matte

Audio Flange & Chorus, High-Low Pass, Modulator, Parametric EQ, Reverb, and Tone

Channel Alpha Levels

Distort Bezier Warp, Bulge, Corner Pin, Displacement Map, Mesh Warp, Optics Compen-
sation, Reshape, Ripple, Twirl, and Wave Warp

Keying Color Difference Key, Color Range, Difference Matte, Extract, Inner Outer Key, 
Linear Color Key, and Spill Suppressor

Matte Tools Simple Choker and Matte Choker

Paint Vector Paint

Render Lightning and Fractal Noise

Simulation Particle Playground

Stylize Glow and Scatter

Time Time Displacement

3D Channel effects (PB only)
These effects integrate 3D scenes into 2D composites, and alter 3D scenes. You can import 
3D channel image files saved in RLA, Softimage PIC/ZPIC, and Electric Image EI/EIZ 
formats. For PIC and EI files, the 3D channel information lives in the ZPIC or EIZ files, 
respectively. You don’t actually import ZPIC and EIZ files, but as long as they’re stored in 
the same folder with the PIC and EI files, you can access their 3D channels using these 
effects.
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3D Channel effects read and manipulate the additional channels of information, including 
z depth, surface normals, object ID, texture coordinates, background color, unclamped 
RGB, and material ID. You can matte 3D elements along a z axis, insert other elements in a 
3D scene, blur areas in a 3D scene, isolate 3D elements, apply a foggy effect with depth, 
and extract 3D channel information for use as parameters in other effects.

3D Channel Extract (PB only)
This effect makes auxiliary channels visible as either grayscale or multichannel color 
images. You can then use the resulting layer as parameters for other effects. For example, 
extract the z-depth information in a 3D channel file and then use it as an influence map in 
the Particle Playground effect, or extract values from the Unclamped RGB channel to 
produce a matte that generates glowing highlights.

For more information, see the After Effects product section on Adobe’s Web site.

Depth Matte (PB only)
This effect reads the z-depth information in a 3D channel image file and can slice the 
image anywhere along that z axis. Use this effect to matte everything in front of or behind 
the value you specify. For example, remove a background in a 3D scene or insert objects 
into a 3D scene. Simply create two layers with the 3D channel file; then, in one layer, matte 
everything behind a certain point. In the other layer, matte everything in front of that 
same point, so together, the two layers make up the original image. Then insert a layer 
between them with the object that you want to composite into the scene.

For more information, see the After Effects product section on Adobe’s Web site.

Depth of Field (PB only)
This effect simulates a camera that’s focusing in on one area in a 3D scene (along the z 
axis) while allowing other areas to blur. Use the Focal Plane option to specify the specific 
distance, or plane, along the z axis that you want to focus on in the 3D scene. You can 
identify this distance by clicking different parts of the 3D scene in the Composition 
window, while keeping an eye on the z-axis values that appear in the Info palette. The 
Focal Bias sets the speed with which the out-of-focus elements lose focus. This value works 
like a gamma correction: the higher the value, the more quickly elements drop out of 
focus.

For more information, see the After Effects product section on Adobe’s Web site.

Fog 3D (PB only)
This effect applies fog along the z axis, so that the distant parts of a 3D scene look hazier or 
disappear behind the fog. Fog 3D simulates fog by behaving as though there is a 
scattering medium in the air that makes objects look more and more diffuse as they get 
more distant along the z axis. To specify the Fog Start Depth, first select different elements 
in the 3D scene and check their z depth in the Info palette. After Effects uses the 
luminance value in the gradient layer (grayscale layer) and applies it as the scattering 
medium. You could, for example, create a gradient layer from a swirling, drifting texture to 
create a more atmospheric fog effect. For best results, make sure that the dimensions of 
the gradient layer are the same as the footage, not the composition.

For more information, see the After Effects product section on Adobe’s Web site.
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ID Matte (PB only)
This effect isolates elements in a 3D channel image. Many 3D programs tag each element 
in a scene with a unique Object ID. After Effects uses this information to create a matte 
that excludes everything in the scene except the element you want. Identify each object’s 
ID by applying the ID Matte effect and then clicking different parts of the image in the 
Composition window as you watch the Info palette. You can isolate objects based on their 
Material ID as well. Select Use Coverage to create a cleaner matte by removing the color 
stored behind object.

For more information, see the After Effects product section on Adobe’s Web site.

Adjust effects
Use the Adjust effects to adjust color attributes such as brightness, balance, and levels in a 
layer.

Brightness & Contrast
This effect adjusts the brightness and contrast of the entire layer (not individual channels). 
The center point of each slider is neutral and indicates no effect. The layer’s quality setting 
does not affect Brightness & Contrast. Using the Brightness & Contrast effect is the easiest 
way to make simple adjustments to the tonal range of the image (it does not work on 
individual channels). It adjusts all pixel values in the image at once—highlights, shadows, 
and midtones.

Channel Mixer
This effect modifies a color channel using a mix of the current color channels. Use it to 
make creative color adjustments not easily done with the other color adjustment tools: 
create high-quality grayscale images by choosing the percentage contribution from each 
color channel, create high-quality sepia-tone or other tinted images, and swap or 
duplicate channels. The Constant option specifies the base amount of the input channel 
to be added to the output channel. Monochrome applies the same settings to all the 
output channels, creating a color image that contains only gray values. This is useful for 
images that you plan to convert to grayscale. If you select and then deselect Monochrome, 
you can modify the blend of each channel separately, creating a hand-tinted appearance.

Color Balance
This effect changes the amount of red, green, and blue color in a layer. The center point of 
each slider is neutral and indicates no effect. A setting of –100 removes all of the color; a 
setting of +100 intensifies the color. The layer’s quality setting does not affect Color 
Balance.

The Shadow/Midtone/Hilight (Channel) Balance option specifies the amount of a 
channel’s color in the darker, middle, and lighter color intensity ranges of a layer. Preserve 
Luminosity preserves the average brightness of the image while changing the color. This 
option maintains the tonal balance in the image.
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Curves
Use Curves to adjust the tonal range of an image. You can adjust any point along a 0–255 
scale while keeping up to 15 other values constant. The horizontal axis of the graph repre-
sents the original brightness values of the pixels (Input levels); the vertical axis represents 
the new brightness values (output levels). In the default diagonal line, all pixels have 
identical input and output values. To create a variety of interesting tonal and color effects, 
create or import curves and arbitrary maps from Adobe Photoshop. Curves supports all 
settings files created in the Photoshop Curves dialog box: either Curves files (.acv) or 
Arbitrary map files (.amp). The Curves effect does not support Adobe Photoshop color 
tables (.act).

A. Shadows B. Midtones C. Highlights

For more information, see the After Effects product section on Adobe’s Web site.

Hue/Saturation
This effect adjusts the hue, saturation, and lightness of individual color components in an 
image. It is based on the color wheel. Adjusting the hue, or color, represents a move 
around the color wheel. Adjusting the saturation, or purity of the color, represents a move 
across its radius. Use the Colorize option to add color to a grayscale image converted to 
RGB, or add color to an RGB image.

For more information, see the After Effects product section on Adobe’s Web site.

Levels
This effect remaps the range of input color levels onto a new range of output color levels, 
and changes the gamma correction curve at the same time. It is useful for basic image 
quality adjustment. This effect functions the same as the Levels adjustment in Adobe 
Photoshop 5.0 and displays in the same way, as long as monitor calibration is off.

A
B

C
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Use Levels to adjust the gamma to change the brightness values of the middle range of 
gray tones without dramatically altering the shadows and highlights.

A. Channel B. Histogram C. Input Black D. Output Black E. Gamma F. Output White G. Input 
White

For more information, see the After Effects product section on Adobe’s Web site.

Posterize
Use this effect to specify the number of tonal levels (or brightness values) for each channel 
in an image. Posterize then maps pixels to the closest matching level. For example, 
choosing two tonal levels in an RGB image gives you two tones for red, two tones for 
green, and two tones for blue. Values range from 2 to 255. Although the results of this 
effect are most evident when you reduce the number of gray levels in a grayscale image, 
Posterize also produces interesting effects in color images.

Use Level to adjust the number of tonal levels for each channel to which Posterize will map 
existing colors.

A. Original image B. Posterize applied with five levels of color C. Threshold applied

Threshold
Use this effect to convert grayscale or color images to high-contrast, black-and-white 
images. Specify a certain level as a threshold; all pixels lighter than the threshold are 
converted to white and all pixels darker to black.

Audio effects
This category contains audio effects that add ambiance to a layer, enhance or correct 
audio characteristics, and create effects. You can apply audio effects to existing audio 
footage, or synthesize just about any sound by combining the Tone effect with other 
audio effects.

A

B F

C D E

A B C
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Backwards
This effect reverses an audio footage item by playing it from the last frame or keyframe to 
the first frame or keyframe. The frames remain in their original order when viewed in the 
Timeline window.

Bass & Treble
Make basic adjustments to the audio tone of an audio layer using this effect by specifying 
the amount of boost or cut applied to the low frequencies of the audio layer. If you need 
greater control in working with audio tone, use the Parametric Equalization effect in the 
After Effects Production Bundle. The Bass/Treble option specifies the amount of boost or 
cut applied to the low frequencies of the audio layer.

Delay
This effect repeats the sounds in the audio footage after a specified amount of time. It 
simulates sound bouncing off a surface, such as a wall some distance away.

For more information, see the After Effects product section on Adobe’s Web site.

Flange & Chorus (PB only)
This effect combines two separate audio effects, Flange and Chorus, into a single effect. 
Chorus is commonly used to add depth and character to audio footage that contains a 
single instrument or voice. Chorus makes one voice sound like many voices.

Flange applies a copy of the sound that is detuned, or played at a frequency slightly offset 
from the original. By experimenting with the voice-separation time and the modulation 
depth, you can create a wavy, rushing sound. The default settings apply to the Flange 
effect alone.

For more information, see the After Effects product section on Adobe’s Web site.

High-Low Pass (PB only)
This effect sets a limit above or below which frequencies can pass. High Pass allows 
frequencies above the limit and blocks frequencies below. Conversely, Low Pass allows 
frequencies below the limit and blocks frequencies above. Use High-Low Pass to enhance 
or attenuate (reduce) a sound, change the focus from one sound to another over time, 
protect equipment from potentially damaging frequencies, or direct certain frequencies 
to specific equipment.

For more information, see the After Effects product section on Adobe’s Web site.

Modulator (PB only)
This effect adds both vibrato and tremolo to audio by modulating (varying) the frequency 
and amplitude. You can create a Doppler effect, such as when a train whistle gets higher in 
pitch as it approaches an observer, and then drops in pitch as it passes. Use Sine 
modulation to produce the purest sounds; use Triangle to produce more distorted sounds.

For more information, see the After Effects product section on Adobe’s Web site.
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Parametric EQ (PB only)
This effect either emphasizes or attenuates specific frequency ranges. It is useful for 
enhancing music—for example, boosting low frequencies to bring up bass. Use this effect 
to enhance up to three different bands of the audio footage. As you specify controls, a 
Frequency Response graph indicates the combined equalization curve you create. On the 
Frequency Response graph, Band 1 is red, Band 2 is green, and Band 3 is blue. You may find 
it easier to specify controls if you determine in advance the frequency-response curve you 
want.

For more information, see the After Effects product section on Adobe’s Web site.

Reverb (PB only)
This effect simulates a spacious or acoustically live interior by simulating random reflec-
tions of a sound off of a surface. Using the Reverb Time option, specify the average time in 
milliseconds between the original audio and the reverberated audio. Use Diffusion to 
specify how much the effect scatters the original audio. More diffusion can make the 
audio sound further from the microphone. Set Decay to specify the amount of time it 
takes for the effect to subside. A longer decay simulates a larger space.

For more information, see the After Effects product section on Adobe’s Web site.

Stereo Mixer
Use this effect to mix the left and right channels of an audio layer and pan the entire signal 
from one channel to the other. Use the Invert Phase option to invert the phase of one 
channel of the stereo signal and prevent two sounds at the same frequency from 
cancelling each other out.

For more information, see the After Effects product section on Adobe’s Web site.

Tone (PB only)
This effect synthesizes simple tones to create effects such as the low rumble of a 
submarine, a telephone ringing in the background, sirens, or a laser blast. You can add up 
to five tones for each effect to create a chord, for example, in a composition. When you 
apply this effect to audio footage, the dry (unprocessed) audio is ignored, and only the 
tone plays.

You can also apply this effect to a layer that has no audio, such as an Adobe Illustrator 
object, to synthesize audio. When you render the movie, make sure that you select an 
output format that supports audio—for example, QuickTime or Video for Windows.

For more information, see the After Effects product section on Adobe’s Web site.

Blur and sharpen effects
Use these effects to soften or sharpen an image.



Using Help | Contents | Index Back 187  

Adobe After Effects Help Applying Effects 

Using Help | Contents | Index Back 187  

Channel Blur
This effect blurs a layer’s red, green, blue, or alpha channels individually. You can specify 
that the blur is horizontal, vertical, or both. At Best quality, the blur is smooth. Use this 
effect for glow effects or if you want a blur that does not become transparent near the 
edges of the layer. The Edge Behavior option describes how to treat the edges of a blurred 
image. If you deselect it, pixels outside of the image are transparent, which makes the 
edges of the blurred image semitransparent. Select the Repeat Edge Pixels option to 
repeat the pixels around the edges, preventing the edges from darkening and becoming 
more transparent.

Compound Blur 
This effect blurs pixels in the selected layer based on the luminance values of a blur layer, 
also known as a blurring map. The blur layer, which can be any layer that contains pixels of 
different luminance values, is essentially overlaid on top of the selected layer and the 
pixels of both layers are matched, one to one. Where the blur layer is black, no blurring 
occurs in the same location in the selected layer. The blur layer is used only as a map; it is 
not visible in the composition.

The Blur Layer specifies the layer in the composition to use as the blurring map. Bright 
values in the blur layer correspond to more blurring of the affected layer, while dark values 
correspond to less blurring. Maximum Blur specifies the maximum amount, in pixels, that 
any part of the affected layer can be blurred. The Stretch Map to Fit option stretches the 
blur layer to the dimensions of the layer to which it is applied; otherwise, it is centered. 
Invert Blur inverts the values, so areas that were previously more blurred will be less 
blurred, and vice versa.

This effect is useful for simulating smudges and fingerprints, or changes in visibility due to 
atmospheric conditions such as smoke or heat, especially with animated blurring layers. 
Compound Blur is especially effective in combination with other effects, such as 
Displacement Map (see “Displacement Map (PB only)” on page 193).

Directional Blur
This effect gives a layer the illusion of motion. At Draft quality, the effect is a blur of the 
image in which each pixel is the unweighted average of its adjacent pixels. At Best quality, 
the effect uses Gaussian weighting, producing a smoother, more graduated blur. The 
Direction option specifies the direction of the blur. The blur is applied equally around a 
pixel’s center; therefore, a setting of 180 degrees and a setting of 0 degrees look the same.

A. Original B. Directional Blur C. Radial Blur 

A B C
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Fast Blur
Use this effect to blur an image. Specify whether the blur is horizontal, vertical, or both. At 
Best quality, the Fast Blur effect is a close approximation of a Gaussian Blur, but it blurs 
large areas more quickly. Select Repeat Edge Pixels to blur the contents of the image while 
keeping the edges of the image sharp.

Gaussian Blur
This effect blurs and softens the image and can reduce noise. Specify whether the blur is 
horizontal, vertical, or both. The layer’s quality setting does not affect Gaussian Blur.

Radial Blur
This effect creates blurs around a specific point in a layer, simulating the effects of a 
zooming or rotating camera. At Draft quality, the blur appears somewhat grainy. You may 
prefer the draft results for special effects, but the grain may flicker on interlaced displays.

The Amount option specifies the amount of blur, depending on the selection for Type. For 
a Spin blur, which applies blurs in circles around the center point, the Amount value 
indicates the degree of rotation. For a Zoom blur, which applies blur that radiates out from 
the center point, the Amount value specifies the degree of radial blurring. You can specify 
the level of anti-aliasing applied at Best quality; no anti-aliasing is applied at Draft quality.

Sharpen
This effect increases the contrast where color changes occur. The layer’s quality setting 
does not affect Sharpen.

A. Original image B. Sharpen C. Unsharp Mask 

Unsharp Mask
This effect increases the contrast between colors that define an edge. Use the Radius 
option to specify the depth of pixels that will be affected at an edge. If you specify a high 
value, more of the pixels surrounding the edge are adjusted for contrast. If you specify a 
low value, only pixels at the edge are adjusted. Use the Threshold option to specify a 
tolerance to define edges and prevent overall contrast adjustment that might generate 
noise or cause unexpected results. Values define the range of contrast allowed between 
adjacent pixels before contrast is adjusted. A lower value produces a more pronounced 
effect.

A B C
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Channel effects
Use these effects to manipulate, extract, insert, and convert the channels of an image. The 
channels themselves include the component color values (red, green, and blue), calcu-
lated color values (hue, saturation, and luminance), and transparency values (alpha 
channel).

For more information, see the After Effects product section on Adobe’s Web site.

Alpha Levels (PB only)
This effect increases or decreases the transparency of a matte. Use it to adjust pure black 
or pure white areas of a matte to be semitransparent or to adjust grays (semitransparent 
areas) to be pure black and white.

For more information, see the After Effects product section on Adobe’s Web site.

Arithmetic
This effect performs various simple mathematical operations on an image’s red, green, and 
blue channels. The Operator option specifies the mathematical operation to perform 
between the value you specify for each channel and the existing value of that channel for 
each pixel in the image: And, Or, and Xor apply bitwise logical combinations of the 
specified value; Add, Subtract, and Difference apply basic math functions using the 
specified value; Max selects each pixel in the color channel that is less than the specified 
value and sets it at the specified value; Min selects each pixel in the channel that is greater 
than the specified value and sets it at the specified value. Block Above and Block Below turn 
the channel off everywhere that it is respectively greater or less than the specified value; 
Slice turns the channel off where it is below the value specified and turns it on where it is 
above the specified value.

The Clip Result Values option prevents all functions from creating color values that exceed 
the valid range. If this option is not selected, some color values may wrap around from on 
to off, or vice versa.

Blend
This effect blends two layers using one of five modes. A crossfade is a standard transition 
between two images: the original image fades out while the new image fades in. After you 
blend layers using this effect, hide the layer you selected from the Blend with Layer menu 
by clicking the video switch for that layer in the Timeline window.

Two images blended together to create a textured butterfly.

Note: You can create blends more easily and quickly using layer modes, but you can’t 
animate layer modes. The advantage of using the Blend effect is that you can animate it. 
For more information on layer modes, see “Using layer modes” on page 166.

For more information, see the After Effects product section on Adobe’s Web site.
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Cineon Converter
This effect provides a high degree of control over color conversions of Cineon frames. In 
After Effects 5.0, you can convert the color in a Cineon file using controls in the Interpret 
Footage dialog box or using the Cineon Converter effect. To use the Cineon Converter, 
import a Cineon file and leave it in its default state; After Effects will either condense the 
colors to 8 bit or expand them to 16 bit, depending on the mode you are working in. You 
can then apply the Cineon Converter to the file and precisely adjust the colors while inter-
actively viewing the results in the Composition window. Set keyframes to adjust for 
changes in tone over time and use keyframe interpolation and ease handles to precisely 
match the most irregular lighting changes.

The 10 bits of data available in each Cineon channel make it easier to enhance an 
important range of tones while preserving overall tonal balance. By carefully specifying 
the range, you can create a version of the image that faithfully resembles the original.

For more information, see the After Effects product section on Adobe’s Web site.

Compound Arithmetic
This effect mathematically combines the layer to which it is applied with another layer. It is 
intended only to provide compatibility with projects created in earlier versions of After 
Effects that use the Compound Arithmetic effect. Using layer modes is more effective than 
using the Compound Arithmetic effect in most situations. For more information on layer 
modes, see “Using layer modes” on page 166.

For more information, see the After Effects product section on Adobe’s Web site.

Invert
This effect inverts the color information of an image. Choose a color space to invert from 
the Channel menu. If you want, select Blend with Original to combine the inverted image 
with the original. You can apply a fade to the inverted image.

For more information, see the After Effects product section on Adobe’s Web site.

Minimax
This effect enlarges or reduces a matte for a specific channel or all channels. It assigns each 
pixel the minimum or maximum pixel value found within the specified radius. For 
example, a white solid layer with a square mask shrinks one pixel on each side using 
Minimum and a radius of one. The layer’s quality setting does not affect Minimax.

For more information, see the After Effects product section on Adobe’s Web site.

Remove Color Matting
This effect removes color fringes from layers that are premultiplied with a color. It is useful 
when merging alpha and fill from separate files. If you import footage with a premultiplied 
alpha channel, or if you create alpha channels with After Effects, you may need to remove 
halos from an image. Halos are caused by a large contrast between the image’s color and 
the background, or matte, color. Removing or changing the color of the matte can remove 
the halos. (Halos can also be caused by a misinterpretation of an alpha channel’s premulti-
plied color. See “Importing footage containing an alpha channel” on page 30.)

Use Background Color to specify the new background color when you want to change the 
color of a matte.
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Set Channels
This effect copies channels from other layers to the red, green, blue, and alpha channels of 
the current layer. For example, you can take the luminance of one layer and put it into the 
color channel of the selected layer. All source layers are centered in the current layer. With 
Best quality selected, any stretched layers are anti-aliased.

Use Stretch Layers to Fit to resize all other layers to the size of the layer to which Set 
Channels is being applied.

Set Matte
This effect replaces the alpha channel (matte) of a layer with a channel from another layer 
above it for the creation of traveling matte effects.The effect is intended only to provide 
compatibility with projects created in earlier versions of After Effects that use the Set 
Matte effect. It is easier and faster to create traveling mattes using a track matte. See 
“Creating track mattes and traveling mattes” on page 164.

For more information, see the After Effects product section on Adobe’s Web site.

Shift Channels
This effect replaces red, green, blue, and alpha channels in the image with other channels. 
In Take (Channel) From, specify which channel to use as a source.

Note: You can use this effect to display the alpha channel for a layer if you set the RGB 
channels to Alpha and set the alpha channel to Full.

Distort effects
Use these effects to geometrically distort an image.

A. Original B. Mirror C. Polar Coordinates

A B C
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Bezier Warp (PB only)
This effect shapes an image using a closed Bezier curve along the boundary of a layer. The 
curve consists of four segments. Each segment has four control points (two vertices and 
two tangents). The vertices control the position of the segments, and the tangents control 
the curvature of the segments. Drag them to reshape the curves that form the edge, thus 
distorting the image.

A. Vertex 1 B. Tangent 1 C. Tangent 2 D. Vertex 2 E. Tangent and vertex positioned to create a 
curved edge

For example, use Bezier Warp to reshape one image to fit another, as in wrapping a label 
around a jar. Or correct lens aberrations, such as the fish-eye effect (barrel distortion) that 
can occur when using a wide-angle lens. You can also bend the image back to achieve an 
undistorted look. Animate the effect and choose a high elasticity setting to create fluid 
visual effects, such as a jiggling gelatin dessert or a fluttering flag.

A. Unaltered image B. Fitting a label to a jar C. Nesting that composition into another and 
reshaping the jar 

For more information, see the After Effects product section on Adobe’s Web site.

Bulge (PB only)
This effect distorts an image around a specified point, making the image appear to bulge 
toward or away from the viewer, depending on the options you select. You can position 
and shape the bulge in the Composition window or the Effect Controls window. Use the 
Pin All Edges option to prevent edges of the layer from bulging.

For more information, see the After Effects product section on Adobe’s Web site.

A EB C D

A B C
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Corner Pin (PB only)
This effect distorts an image by changing the position of each of its four corners. Use it to 
stretch, shrink, skew, or twist an image, or to simulate perspective or movement that 
pivots from the edge of a layer, such as a door opening. You can also use it to attach a layer 
to a moving rectangular region tracked by the Motion Tracker. See “About tracking motion 
(PB only)” on page 305. You can move the corner pins in the Composition window or the 
Effect Controls window.

Displacement Map (PB only)
This effect distorts a layer by displacing pixels horizontally and vertically based on the 
color values of pixels in a second layer, called the displacement map. The type of distortion 
created by the Displacement Map effect can vary greatly, depending on the displacement 
map and options you select. Maximum displacement occurs only when the value of the 
specified color property is either 0 or 255. Values between 0 and 255 produce displace-
ments calculated using the equation below. Negative values reverse the direction of 
displacement.

Displacement amount = maximum_displacement * (2 * (color value – 128)/256)

A. Displacement map B. Map centered C. Map stretched D. Map tiled

For more information, see the After Effects product section on Adobe’s Web site.

Mesh Warp (PB only)
This effect applies a grid of Bezier patches (squares in the grid) over a layer, which you can 
manipulate to distort areas of an image. Each corner of a patch includes a vertex and two 
to four tangents (points that control the curvature of the line segment that makes up the 
edge of the patch). The number of tangents depends on whether the vertex is in a corner, 
on an edge, or inside the grid. Move the vertices and tangents to manipulate the shape of 
the curved line segment. The image follows the grid shape according to the elasticity 
setting you have chosen and the boundary created by the adjacent patch. Each patch 
becomes a boundary for the distortion.

A B C D
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You can also use Mesh Warp to create smooth transitions between multiple images and 
layers. Using keyframes for effects and opacity, you can animate the transition between 
layers, revealing and distorting layers over time.

A. Original layer with grid applied B. Same layer with modified grid C. Final image 

For more information, see the After Effects product section on Adobe’s Web site.

Mirror
This effect splits the image along a line and reflects one side onto the other. The Reflection 
Center specifies the position of the line.The Reflection Angle determines which side is 
reflected and where the reflection appears. An angle of 0 degrees reflects the left side 
onto the right. An angle of 180 degrees reflects the right side onto the left. An angle of 90 
degrees reflects the top onto the bottom. An angle of 270 degrees reflects the bottom 
onto the top. The layer’s quality setting influences the Mirror effect. At Best quality, the 
reflected image is smoother and more accurate.

Offset
This effect pans the image within a layer. Visual information pushed off one side 
of the image appears on the opposite side. At Best quality, the offset is performed with 
subpixel precision.

The Shift Center To option specifies the new position of the original image’s center point. 
Blend with Original specifies the amount by which the offset image is blended with the 
original image. 

Optics Compensation (PB only)
This effect adds or removes camera lens distortions. Use it when you have composited 
elements with mismatched lens distortions to avoid anomalies in the animation. To use 
this effect, first determine the Field of View value for the distorted footage; then apply that 
value in reverse to the computer-generated image. This process matches the distortion 
between the two images.

For more information, see the After Effects product section on Adobe’s Web site.

Polar Coordinates
This effect distorts a layer by transposing each pixel in the layer’s x, y coordinate system to 
the corresponding position in the polar coordinate system, or the reverse. It produces 
unusual and surprising distortions that can vary greatly depending on the image and the 
controls you select. The standard coordinate system specifies points by measuring the 
horizontal distance (x axis) and the vertical distance (y axis) from the origin. Each point is 
specified as (x, y). The polar coordinate system specifies points by measuring the length of 
a radius from the origin and its angle from the x axis. Each point is specified as (r, ).
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For more information, see the After Effects product section on Adobe’s Web site.

PS+Pinch
See the Adobe Photoshop User Guide or online Help for information on using this effect.

PS+Ripple
See the Adobe Photoshop User Guide or online Help for information on using this effect.

PS+Spherize
See the Adobe Photoshop User Guide or online Help for information on using this effect.

PS+Twirl
See the Adobe Photoshop User Guide or online Help for information on using this effect.

PS+Wave
See the Adobe Photoshop User Guide or online Help for information on using this effect.

PS+Zig Zag
See the Adobe Photoshop User Guide or online Help for information on using this effect.

Reshape (PB only)
This effect transforms one shape into another shape on the same layer, dragging the 
underlying image with it. The image is distorted to fit the shape of the new area. Create or 
import masks to define the area you want to distort.

A. Source mask B. Destination mask C. Reshaped image within the triangular boundary mask 

Note: Use Reshape to create unusual transitions between multiple images and layers. 
Using keyframes for effects and opacity, you can animate the transition between layers, 
revealing and distorting layers over time.

For more information, see the After Effects product section on Adobe’s Web site.
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Ripple (PB only)
This effect creates the appearance of ripples in a specified layer, moving away from a 
center point in concentric circles. The effect is similar to dropping a stone in a pond. You 
can also specify that ripples move toward the center point. Animate ripples at a constant 
speed using the Wave Speed control, which does not require keyframes for animation. 
Animate ripples at varying speeds by creating keyframes for the Ripple Phase control.

For more information, see the After Effects product section on Adobe’s Web site.

Smear
Using Smear, you define an area within an image and then move that area to a new 
location, stretching, or smearing, the surrounding part of the image with it. Create masks 
to define the area you want to distort.

A. Boundary mask B. Mask offset C. Source mask

Processing can take up to several minutes with certain settings. Computation time 
increases as the source mask gets closer to the boundary mask. Processing is interrupted 
when you click a control.

A. Original B. Source and Boundary masks set C. Resulting smear

For more information, see the After Effects product section on Adobe’s Web site.
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Spherize
This effect distorts a layer by wrapping a region of the image onto a spherical shape of 
variable size. The layer’s quality setting influences the Spherize effect. Best quality samples 
the displaced pixels to subpixel accuracy; Draft quality samples to the nearest whole pixel.

The Radius option specifies the radius of the sphere in pixels. You can exceed the highest 
slider value by clicking the Radius value and typing a higher number in the dialog box. 
Center of Sphere specifies the position of the sphere’s center on the layer.

Transform
This effect applies 2D geometric transformations to the source layer and supplements the 
transform properties available for each layer in the Timeline window. Using this effect, you 
can skew a layer along any axis. Also, if motion blur is enabled, you can specify motion blur 
independent of the composition’s shutter angle. Anchor Point, Position, Rotation, and 
Opacity function the same as the layer transform properties in the Timeline window.

Note: This effect is relative to the input layer. Therefore, to make a layer rotate around the 
upper left corner, open the layer window, select Transform in the Layer window menu, and 
then move the anchor point and the position to the upper left corner.

For more information, see the After Effects product section on Adobe’s Web site.

Twirl (PB only)
This effect twirls the pixels of an image around a specified point at a specified amount. 
Pixels nearer the center point are twirled faster than pixels in outer regions, resulting in a 
whirlpool effect. Because distortion in this effect is significant, After Effects uses special 
anti-aliasing techniques to produce the highest-quality image. As a result, the Twirl effect 
can be particularly slow to render.

For more information, see the After Effects product section on Adobe’s Web site.

Wave Warp (PB only)
This effect produces the appearance of a wave traveling across an image. You can produce 
a variety of different wave shapes, including square, circular, and sine waves. The Wave 
Warp effect is automatically animated at a constant speed across the time range (without 
keyframes). Set keyframes to vary speeds.

For more information, see the After Effects product section on Adobe’s Web site.
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Image control effects
Use these effects to alter an image’s color values.

Change Color
This effect adjusts the hue, saturation, and lightness of a range of colors. Choose the range 
by specifying a base color and similarity values. Choose to work from the Corrected Layer, 
which shows the results of the Change Color effect, or from the Color Correction Mask, 
which shows the areas of the layer that will be changed. White areas in the color correction 
mask are transformed the most, and dark areas are transformed the least.

For more information, see the After Effects product section on Adobe’s Web site.

Color Balance (HLS)
This effect alters an image’s levels of hue, lightness, and saturation. It is intended only to 
provide compatibility with projects created in earlier versions of After Effects that use the 
Color Balance (HLS) effect. For new projects, use the Hue/Saturation effect, which operates 
the same as the Hue/Saturation command in Adobe Photoshop. You can convert a movie 
to grayscale by setting the Saturation to –100.

The Hue option specifies the color scheme of the image.

Colorama
This effect colorizes a selected element in an image, and cycles smoothly through the 
colors in the new color palette. Use keyframes to animate the colors; for example, make 
colors pulse as they follow a gradient path or zoom out of a radial gradient.

Colorama converts the selected channel to grayscale (you can combine channels using 
the Add Phase option); then it remaps the grayscale values that you’ve chosen to a color 
palette (Output Cycle) that you’ve loaded (or created from scratch). It then “wraps” the 
grayscale file around the color wheel, mapping the successive colors to the increasingly 
lighter grays. When it gets to the white areas of the image, it completes the cycle by 
mapping those corresponding pixels to the color at the top of the Output Cycle’s color 
wheel. You can then animate the cycle, so that in one revolution, each pixel of your layer 
travels through the complete color cycle you’ve chosen.

For more information, see the After Effects product section on Adobe’s Web site.

Equalize
This effect alters an image’s pixel values to produce a more consistent brightness or color 
component distribution. The effect works similarly to the Equalize command in Adobe 
Photoshop. Equalization can be performed using either RGB values or the brightness 
component. Pixels with 0 alpha (completely transparent) values are not considered, so 
masked layers are equalized based on the mask area. Layer quality settings do not affect 
Equalize.

For more information, see the After Effects product section on Adobe’s Web site.

Gamma/Pedestal/Gain
This effect adjusts the response curve independently for each channel. For pedestal and 
gain, a value of 0.0 is completely off, and a value of 1.0 is completely on.
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The Black Stretch option remaps the low pixel values of all channels. Large Black Stretch 
values brighten dark areas. The effect is the same in all quality settings. Gamma specifies 
an exponent describing the shape of the intermediate curve. The Pedestal and Gain 
options specify the lowest and highest attainable output value for a channel.

Median
This effect replaces each pixel with the median pixel value of neighboring pixels within a 
given radius. At low values, this effect is useful for reducing some types of noise. At higher 
values, this effect gives a layer a painterly effect. This effect is the same at both Draft and 
Best quality. Use Radius to specify how many pixels to examine for the Median effect. For 
instance, when Radius is set to 1, the Median is performed on the eight neighboring pixels 
that are within one pixel of the center pixel.

PS Arbitrary Map
This effect applies an Adobe Photoshop arbitrary map file to a layer. An arbitrary map 
adjusts the brightness levels of an image, remapping a specified brightness range to 
darker or brighter tones. It is intended only to provide compatibility with projects created 
in earlier versions of After Effects that use the Arbitrary Map effect. For new work, use the 
Curves effect.

For more information, see the After Effects product section on Adobe’s Web site.

Tint
This effect alters an image’s color information. For each pixel, the luminance value 
specifies a blend between two colors. Map Black To and Map White To specify the colors to 
which dark and bright pixels are mapped. Intermediate pixels are assigned intermediate 
values. Amount to Tint specifies the intensity of the effect. The layer’s quality setting does 
not affect Tint. For more complex tinting, use the Colorama effect.

Keying effects
Use these effects to key out (make transparent) parts of an image. For more information 
on using keying effects, see “Creating track mattes and traveling mattes” on page 164.

After Effects includes two basic keying effects. The Production Bundle includes seven 
additional, more powerful keying effects.

Color Difference Key (PB only)
This Key creates transparency from opposite starting points by dividing an image into two 
mattes, Matte Partial A and Matte Partial B. Matte Partial B bases the transparency on the 
specified key color, and Matte Partial A bases transparency on areas of the image that do 
not contain a second, different color. By combining the two mattes into a third matte, 
called the alpha( ) matte, the Color Difference Key creates well-defined transparency 
values.
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The Color Difference Key produces high-quality keying for all well-lit footage items shot 
against a bluescreen or greenscreen and works especially well with images that contain 
transparent or semitransparent areas, such as smoke, shadows, or glass.

A. Original image thumbnail B. White eyedropper C. Matte controls D. Thumbnail eyedropper E. 
Black eyedropper F. Matte thumbnail G. Matte buttons H. View I. Key Color swatch and 
eyedropper J. Color Matching Accuracy

To apply the Color Difference Key:

1 Select the layer you want to make transparent, and then choose Effect > Keying > Color 
Difference Key.

2 In the Effect Controls window, choose Matte Corrected from the View menu. To view 
and compare the source image, both partial mattes, and the final matte at the same time, 
choose [A, B, Matte] Corrected, Final from the View menu. Other views available in the 
View menu are described in step 10.

3 Select the appropriate key color in one of the following ways:

• To key out a bluescreen, use the default blue color.

• To key out a non-bluescreen, select a key color in one of the following ways:

Thumbnail eyedropper Select and then click in the Composition window or the original 
image thumbnail on an appropriate area.

Key Color eyedropper Select and then click in the Composition or Layer window on an 
appropriate area.

Key Color swatch Click to select a color from the specified color space.

Note: The eyedropper tools move the sliders accordingly. Use the sliders in step 9 to fine-
tune the keying results.

4 Click the  matte button to display the final combined matte in the matte thumbnail.
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5 Select the Black eyedropper, and then click inside the matte thumbnail on the lightest 
area of black to specify transparent regions. The transparency values in the thumbnail and 
Composition window are adjusted.

6 Select the White eyedropper, and then click inside the matte thumbnail on the darkest 
area of white to specify opaque regions. The opaque values in the thumbnail and the 
Composition window are adjusted.

To produce the best possible key, make the black and white areas as different as you 
can so that the image retains as many shades of gray as possible.

7 Select a matching accuracy from the Color Matching Accuracy menu. Choose Faster 
unless you are using a screen that is not a primary color, such as orange. For those screens, 
choose More Accurate, which increases rendering time but produces better results.

8 If you need to further adjust transparency values, repeat steps 5 and 6 for one or both of 
the partial mattes. Click the Partial Matte B button or the Partial Matte A button to select a 
partial matte, and then repeat the steps.

9 Adjust transparency values for each partial matte and for the final matte by dragging 
one or more of the following slider bars in the Matte Controls section:

• Black slider bars adjust the transparency levels of each matte. You can adjust the same 
levels using the Black eyedropper.

• White slider bars adjust the opaque levels of each matte. You can adjust the same levels 
using the White eyedropper.

• Gamma slider bars control how closely the transparency values follow a linear 
progression. At a value of 1 (the default), the progression is linear. Other values produce 
nonlinear progressions for particular adjustments or visual effects.

10 When adjusting individual mattes, you can choose the following views from the View 
menu to compare the mattes with and without adjustments:

• Choose Uncorrected to view a matte without adjustments made by the slider bars in 
step 9.

• Choose Corrected to view a matte with all adjustments made by the slider bars in step 
9.
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11 Before closing the Effect Controls window, select Final Output from the View menu. 
Final Output must be selected for After Effects to render the transparency.

To remove traces of reflected key color from the image, apply Spill Suppressor using 
Better for Color Accuracy. If the image still has a lot of color, apply the Simple Choker 

or Matte Choker matte tool. For more information, see “Simple Choker (PB only)” on 
page 211 or “Matte Choker (PB only)” on page 211.

Color Key
The Color Key effect keys out all image pixels that are similar to a specified key color. 
This effect modifies only the alpha channel of a layer. The layer’s quality setting does not 
affect Color Key.

Footage shot against a bluescreen (left); blue color keyed out to reveal layer behind (right)

When you key out a color value in a layer, that color or range of colors becomes trans-
parent for the entire layer. Control the range of transparent colors by adjusting the 
tolerance level. You can also feather the edges of the transparent area to create a smooth 
transition between the transparent and opaque areas.

To key out a single color:

1 Select the layer.

2 Choose Effect > Keying > Color Key.

3 In the Effect Controls window, specify a key color in one of two ways:

• Click the Key Color swatch to open the Color dialog box and specify a color.

• Click the eyedropper, and then click a color on the screen.

4 Drag the Color Tolerance slider to specify the range of color to key out. Lower values key 
out a smaller range of colors near the key color. Higher values key out a wider range of 
color.

5 Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values 
enlarge the mask, increasing the transparent area. Negative values shrink the mask, 
decreasing the transparent area.

6 Drag the Edge Feather slider to specify the softness of the edge. Higher values create a 
softer edge but take longer to render.
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Color Range Key (PB only)
This key creates transparency by keying out a specified range of colors in either the Lab, 
YUV, or RGB color space. You can use this key on screens that consist of more than one 
color or on bluescreen or greenscreens that have been unevenly lit and contain different 
shades of the same color.

A. Matte thumbnail B. Fuzziness control C. Color Space controls D. Key Color eyedropper E. Plus 
(+) eyedropper F. Minus (-) eyedropper G. Color Space

To apply the Color Range Key:

1 Select the layer you want to make transparent, and then choose Effect > Keying > Color 
Range.

2 Choose the Lab, YUV, or RGB color space from the Color Space menu. If you’re having 
trouble isolating the subject using one color space, try using a different one.

3 Select the Key Color eyedropper, and then click in the matte thumbnail to select the 
area that corresponds to a color in the Composition window you want to make trans-
parent. Typically, this first color is the one that covers the largest area of the image. 

4 Select the Plus eyedropper, and then click other areas in the matte thumbnail to add 
other colors or shades to the range of colors keyed out for transparency.

5 Select the Minus eyedropper, and then click areas in the matte thumbnail to subtract 
other colors or shades from the range of colors keyed out.

6 Drag the Fuzziness slider to soften the edges between transparent and opaque regions. 

7 Use the slider bars in the Color Space Controls section to fine-tune the color range you 
selected with the Plus and Minus eyedroppers. The L, Y, R slider bars control the first 
component of the specified color space; the a, U, G slider bars control the second 
component; and the b, V, B slider bars control the third component. Drag Min slider bars to 
fine-tune the beginning of the color range. Drag Max slider bars to fine-tune the end of 
the color range.
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Difference Matte (PB only)
This matte creates transparency by comparing a source layer with a difference layer, and 
then keying out pixels in the source layer that match both the position and color in the 
difference layer. Typically, it is used to key out a static background behind a moving object, 
which is then placed on a different background. Often the difference layer is simply a 
frame of background footage (before the moving object has entered the scene). For this 
reason, the Difference Matte Key is best used for scenes that have been shot with a 
stationary camera.

A. The difference layer is typically a static frame of the movie before the subject enters the scene. B. 
The background is keyed out by comparing the static frame (difference layer) with the source 
layer. C. The source layer is composited onto a new background.

To apply the Difference Matte:

1 Select a motion footage layer as the source layer.

2 Find a frame in the source layer that consists only of background.

3 Save this background frame as an image file; then import it into After Effects and add it 
to the composition. This is the difference layer. For more information, see “Exporting a 
single frame of a composition” on page 292. Make sure that the duration of the difference 
layer is at least as long as that of the source layer.

Note: If there is no full-background frame in the shot, you may be able to assemble the full 
background by combining parts of several frames in After Effects or Adobe Photoshop. For 
example, you can use the Photoshop rubber stamp tool to take a sample of the 
background in one frame, and then paint the sample over part of the background in 
another frame.

4 Turn off the display of the difference layer by clicking the Video switch in the Timeline 
window.

5 Make sure that the original source layer is still selected, and then choose Effect > Keying 
> Difference Matte.

6 In the Effect Controls window, choose Final Output or Matte Only from the View menu. 
Use the Matte Only view to check for holes in the transparency. To fill undesired holes after 
you complete the keying process, see “Matte Choker (PB only)” on page 211.

7 Select the background file from the Difference Layer menu.

8 If the difference layer is not the same size as the source layer, choose one of the 
following controls from the If Layer Sizes Differ menu:

• Center places the difference layer in the center of the source layer. If the difference layer 
is smaller than the source layer, the rest of the layer is filled with black.

A B C
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• Stretch to Fit stretches or shrinks the difference layer to the size of the source layer, but 
it may distort background images.

9 Adjust the Matching Tolerance slider to specify the amount of transparency based on 
how closely colors must match between the layers. Lower values produce less trans-
parency; higher values produce more.

10 Adjust the Matching Softness slider to soften the edges between transparent and 
opaque areas. Higher values make matched pixels more transparent, but do not increase 
the number of matching pixels.

11 If there are still extraneous pixels in the matte, adjust the Blur Before Difference slider. 
This option suppresses noise by slightly blurring both layers before making the 
comparison. Note that the blurring occurs only for comparison and does not blur final 
output.

12 Before closing the Effect Controls window, make sure that you have selected Final 
Output from the View menu to ensure that After Effects renders the transparency.

Extract (PB only)
This effect creates transparency by keying out (or extracting) a specified brightness range, 
based on a histogram of a specified channel. It is best used to create transparency in an 
image shot against a black or white background or against a background that is very dark 
or bright but consists of more than one color. You can also use it to remove shadows from 
a composition.

In the Effect Controls window, the Extract effect displays a histogram for a channel 
specified in the Channel menu. The histogram displays a representation of the brightness 
levels in the layer, showing the relative number of pixels at each level. From left to right, 
the histogram extends from the darkest (a value of 0) to the lightest (a value of 255).

Using the transparency control bar beneath the histogram, you can adjust the range of 
pixels that are made transparent. The position and shape of the bar in relation to the 
histogram determine transparency. Pixels corresponding to the area covered by the bar 
remain opaque; pixels corresponding to the areas not covered by the bar are made trans-
parent.

To apply Extract:

1 Select the layer you want to make transparent, and then choose Effect > Keying > 
Extract.

2 If you are keying out bright or dark areas, choose Luminance from the Channel menu. 
To create visual effects, choose Red, Green, Blue, or Alpha.

3 Adjust the amount of transparency by dragging the transparency control bar in the 
following ways:

• Drag the upper right and upper left selection handles to adjust the length of the bar to 
shorten or lengthen the transparency range. You can also adjust the length by moving 
the White Point and Black Point slider bars. Values above the white point and below the 
black point are made transparent.

• Drag the lower right and lower left selection handles to taper the bar. Tapering the bar 
on the left affects the softness of transparency in the darker areas of the image; 
tapering it on the right affects the softness in the lighter areas. You can also adjust the 



Using Help | Contents | Index Back 206  

Adobe After Effects Help Applying Effects 

Using Help | Contents | Index Back 206  

softness levels by adjusting White Softness (lighter areas) and Black Softness (darker 
areas).

• Drag the entire bar left or right to position it under the histogram.

A. Black point B. Black softness C. White softness D. White point E. Histogram

Inner Outer (PB only)
This key isolates a foreground object from its background. Even objects with wispy, 
intricate, or undefinable edges can be clipped from their backgrounds with minimal work. 
To use the Inner Outer key, create a mask to define the inside and outside edge of the 
object you want to isolate. The mask can be fairly rough—it does not need to fit exactly 
around the edges of the object. 

In addition to masking a soft-edged object from its background, Inner Outer Key modifies 
the colors around the border to remove contaminating background colors. This color 
decontamination process determines the background's contribution to the color in each 
border pixel, and removes that contribution—thus removing the halo that can appear if a 
soft-edged object is matted against a new background. 

To apply the Inner 0uter key:

1 Select the border of the object that you want to extract by doing one of the following:

• Draw a single closed path near the object's border; then select the path from the 
Foreground menu and leave the Background menu set to None. Adjust the Single Mask 
Highlight Radius to control the size of the border around this path. (This method works 
well only on objects with simple edges.)

• Draw two closed paths: an inner path just inside the object, and outer path just outside 
the object. Make sure that any fuzzy or uncertain areas of the object lie within these 
two paths. Select the inner path from the Foreground menu and the outer path from 
the Background menu. 

Note: Make sure that the mask mode for all paths is set to None.

2 If you want, move the masks around to find the location that provides the best results.

3 To extract more than one object, or to create a hole in an object, draw additional paths 
and then select them from the Additional Foreground and Additional Background menus. 
For example to key out a woman’s hair blowing in the wind against a blue sky, draw the 
inner path inside her head, draw the outer path around the outside edge of her hair, and 
then draw an additional path around the gap in her hair where you can see sky. Select the 
additional path from the Additional Foreground menu to extract the gap and remove the 
background image.
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4 Create additional open or closed paths to clean up other areas of the image, and then 
select them from the Cleanup Foreground or Cleanup Background menu. Cleanup 
Foreground paths increase the opacity along the path; Cleanup Background paths 
decrease the opacity along the path. Use the Brush Radius and Brush Pressure options to 
control the size and density of each stroke.

Note: You can select the Background (outer) mask as a Cleanup Background path to clean 
up noise from the background portions of the image. 

5 Set Edge Thin to specify how much of the matte’s border is affected by the key. A 
positive value moves the edge away from the transparent region, increasing the trans-
parent area; Negative values move the edge toward the transparent region and increase 
the size of the foreground area. 

6 Increase the Edge Feather values to soften edges of the keyed area. High Edge Feather 
values take longer to render.

7 Specify the Edge Threshold, which is a soft cutoff for removing low opacity pixels that 
can cause unwanted noise in the image background. 

8 Select Invert Extraction to reverse the foreground and background regions. 

9 Set Blend with Original to specify the amount you want the resulting extracted image 
to blend with the original image.

Linear Color Key (PB only)
This key uses RGB, hue, or chroma information to create transparency from a specified key 
color. In the Effect Controls window, it displays two thumbnails; the left thumbnail repre-
sents the unaltered source image, and the right thumbnail represents the view you’ve 
selected in the View menu.

You can adjust the key color, the matching tolerance, and the matching softness. The 
matching tolerance specifies how closely pixels must match the key color before they start 
becoming transparent. The matching softness controls the softness of edges between the 
image and the key color. 
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You can also reapply this key to preserve a color that was made transparent by the first 
application of the key. For example, if you are keying out a medium-blue screen, you 
might lose some or all of a light-blue piece of clothing your subject is wearing. You can 
bring back the light-blue color by applying another instance of the Linear Color Key and 
choosing Keep This Color from the Key Operation menu.

A. Original image thumbnail B. Minus (-) eyedropper C. Key Color swatch D. Matching Tolerance 
control E. Matching Softness control F. Thumbnail eyedropper G. Plus (+) eyedropper H. Preview 
thumbnail I. View J. Key Color eyedropper K. Match Colors L. Key operation

To apply the Linear Color Key:

1 Select a layer as the source layer, and then choose Effect > Keying > Linear Color Key.

2 In the Effect Controls window, choose Key Colors from the Key Operation menu.

3 Choose a color space from the Match Colors menu. In most cases, use the default RGB 
setting. If you’re having trouble isolating the subject using one color space, try using a 
different color space. 

4 In the Effect Controls window, choose Final Output from the View menu. The view you 
choose appears in the right thumbnail and in the Composition window. If you need to see 
other results, work in one of the other views:

• Source Only shows the original image without the key applied.

• Matte Only shows the alpha channel matte. Use this view to check for holes in the trans-
parency. To fill undesired holes after you complete the keying process, see “Matte 
Choker (PB only)” on page 211.

5 Select a key color in one of the following ways:

• Select the Thumbnail eyedropper, and then click an appropriate area in the Compo-
sition window or the original image thumbnail.

• Select the Key Color eyedropper, and then click an appropriate area in the Composition 
or Layer window. 

• To preview transparency for different colors, select the Key Color eyedropper, hold 
down the Alt key (Windows) or Option key (Mac OS), and move the cursor to different 
areas in the Composition window or the original image thumbnail. The transparency of 
the image in the Composition window changes as you move the cursor over different 
colors or shades. Click to select the color.
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• Click the Key Color swatch to select a color from the specified color space.

The selected color becomes transparent.

Note: The eyedropper tools move the sliders accordingly. Use the sliders in steps 6 and 7 to 
fine-tune the keying results.

6 Adjust matching tolerance in one of the following ways:

• Select the Plus (+) or the Minus (-) eyedropper, and then click a color in the left 
thumbnail. The Plus eyedropper adds the specified color to the key color range, 
increasing the matching tolerance and the level of transparency. The Minus eyedropper 
subtracts the specified color from the key color range, decreasing the matching 
tolerance and the level of transparency. 

• Drag the matching tolerance slider. A value of 0 makes the entire image opaque; a value 
of 100 makes the entire image transparent.

7 Drag the Matching Softness slider bar to soften the matching tolerance by tapering the 
tolerance value. Typically, values under 20% produce the best results.

8 Before closing the Effect Controls window, make sure that you have selected Final 
Output from the View menu to ensure that After Effects renders the transparency.

To preserve a color after applying the Linear Color Key:

1 In the Effect Controls or Timeline window, turn off any current instances of keys or 
matte tools by deselecting the Effect option to the left of the key name or tool name. This 
displays the original image in the Composition window so that you can select a color to 
preserve.

2 Choose Effect > Keying > Linear Color Key. A second set of Linear Color Key controls 
appears in the Effect Controls window below the first set.

3 In the Effect Controls window, choose Keep Colors from the Key Operation menu.

4 Select the color you want to keep.

5 In the first application of the Linear Color Key, choose Final Output from the View menu 
in the Effect Controls window, and then turn other instances of the Linear Color Key back 
on to examine the transparency. You may need to adjust colors or reapply the key a third 
time to find the results you need.

Luma Key
This key keys out all the regions of a layer with a specified luminance or brightness. The 
layer’s quality setting does not influence the Luma Key effect.

Original footage with a light background (left); light background keyed out and replaced with a color 
(right)
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When the object you want to matte has a markedly different luminance value than its 
background, you can make the background value transparent by keying it out. For 
example, if you want to create a matte for musical notes on a white background, you can 
key out the brighter values; the dark musical notes become the only opaque area. 

To key out a luminance value:

1 Select the layer.

2 Choose Effect > Keying > Luma Key.

3 Select a Key Type to specify the range to be keyed out.

4 Drag the Threshold slider on the Effect Controls window to set the luminance value on 
which you want the matte to be based.

5 Drag the Tolerance slider to specify the range of values to be keyed out. Lower values 
key out a smaller range of values near the threshold. Higher values key out a wider range 
of values.

6 Drag the Edge Thin slider to adjust the width of the keyed area’s border. Positive values 
make the mask grow, increasing the transparent area. Negative values shrink the mask.

7 Drag the Edge Feather slider to specify the softness of the edge. Higher values create a 
softer edge but take longer to render.

Spill Suppressor (PB only)
The Spill Suppressor removes traces of the key color from an image with a screen that has 
already been keyed out. Typically, the Spill Suppressor is used to remove key color spills 
from the edges of an image. Spills are caused by light reflecting off the screen and onto 
the subject. 

If you are not satisfied with the results from using the Spill Suppressor, try applying the 
Hue/Saturation effect to a layer after keying, and then decrease the saturation value to 

de-emphasize the key color. (See “Hue/Saturation” on page 183.)

To apply the Spill Suppressor:

1 Select the layer and choose Effect > Keying > Spill Suppressor.

2 Choose the color you want to suppress in one of the following ways:

• If you have already keyed out the color with a key in the Effects Window, click the Color 
to Suppress eyedropper, and then click the screen color in the key’s Key Color swatch.

• In Spill Suppressor, click the Key Color swatch and choose a color from the color wheel.

3 In the Color Accuracy menu, choose Faster to suppress blue, green, or red. Choose 
Better to suppress other colors, because After Effects may need to analyze the colors more 
carefully to produce accurate transparency. The Better option may increase rendering 
time.

4 Drag the Suppression slider until the color is adequately suppressed.

Matte Tools effects (PB only)
Use the matte tools to refine existing mattes. Matte tools should be applied and rendered 
after the keys. 
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Simple Choker (PB only)
The Simple Choker shrinks or expands the edges of a matte in small increments to create a 
clean matte.

A. Original matte B. Negative values used to spread borders C. Positive values used to choke 
borders

Matte Choker (PB only)
The Matte Choker repeats a sequence of choking and spreading the matte to fill undesired 
holes (transparent areas) in opaque regions. The repetition is necessary because the entire 
matte must be choked and spread; the spreading fills the hole, but the edges of the matte 
must be choked back to preserve the matte shape. 

The sequence of choking and spreading occurs in two stages, each with its own set of 
identical controls. Typically, stage two does the opposite of stage one. After a specified 
number of back-and-forth adjustments (which are handled automatically by the Matte 
Choker), the hole is filled and the matte shape is preserved. 

Undesired transparent and semitransparent pixels (holes) in image (left). Holes filled by Matte 
Choker, preserving shape of image (right).

To close a hole in a matte using the Matte Choker:

1 Select the layer and choose Effect > Matte Tools > Matte Choker.

2 Set stage-one controls (the first three sliders) to spread the matte as far as possible 
without altering its shape, as follows:

• Geometric Softness specifies (in pixels) the largest spread or choke.

• Choke sets the amount of choke. Negative values spread the matte; positive values 
choke it.

• Gray Level Softness specifies how soft to make the edges of the matte. At 0%, the matte 
edges contain only fully opaque and fully transparent values. At 100%, the matte edges 
have a full range of gray values, but may appear blurred. 

3 Set stage-two controls (sliders four, five, and six) to choke the matte by the same 
amount you spread it in stage one.

A B C
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4 Use the Iterations slider to specify how many times After Effects repeats the spread-
and-choke sequence. You may need to try a few different settings so that the sequence is 
repeated as many times as necessary to close any unwanted holes.

Paint effects (PB only)
For information on using the Paint effect, see “About Vector Paint (PB only)” on page 333.

Perspective effects
Use these effects to adjust an image’s position in an imaginary 3D space, add depth, or 
create an adjustable z axis.

Basic 3D
This effect manipulates a layer in an imaginary 3D space. You can rotate your image 
around horizontal and vertical axes and move it toward or away from you. With Basic 3D, 
you can also create a specular highlight to give the effect of light reflecting off a rotated 
surface. The light source for the specular highlight is always above, behind, and to the left 
of the viewer. Because the light comes from above, the image must be tilted backwards to 
see this reflection. This can enhance the realism of the 3D appearance. The specular 
highlight can be viewed only at Best quality. 

Note: You can now use the 3D layer features instead of this effect to create 3D effects. See 
“Working with 3D layers” on page 229.

For more information, see the After Effects product section on Adobe’s Web site.

Bevel Alpha
This effect gives a chiseled and lighted appearance to the alpha boundaries of an image, 
often giving 2D elements a 3D appearance. (If the layer’s alpha channel is completely 
opaque, the effect is applied to the bounding box of the layer.) The edge created in this 
effect is somewhat softer than that of the Bevel Edges effect. This effect works especially 
well for elements with text in the alpha channel.

Bevel Edges
This effect gives a chiseled and lighted 3D appearance to the edges of an image. Edge 
locations are determined by the alpha channel of the source image. Unlike Bevel Alpha, 
the edges created in this effect are always rectangular, so images with nonrectangular 
alpha channels do not produce the proper appearance. All edges have the same thickness. 
Best quality calculates the thickness of the chiseled area; the edge thickness is interpo-
lated with smooth visual results.
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Drop Shadow
This effect adds a shadow that appears behind the layer. The shape of the shadow is deter-
mined by the layer’s alpha channel. Drop Shadow can create a shadow outside the bounds 
of the layer; however, memory requirements for this effect grow as the distance setting 
increases. The layer’s quality setting affects the subpixel positioning of the shadow and 
the smoothness of the shadow’s soft edges. It works well with 32-bit footage files from 3D 
rendering programs and drawing programs that support the alpha channel. If you want to 
render the shadow without the image, select Shadow only.

Note: To apply a Drop Shadow to a layer that rotates, rotate the layer using the Transform 
effect and then apply the Drop Shadow effect. You can also use nesting, precomposing, or 
an adjustment layer to achieve this effect. If you do not use one of these methods, the 
shadow rotates with the layer. See “Changing the rendering order” on page 266 and 
“Understanding 3D layer material options” on page 232.

Render effects
Use these effects to create elements in a layer such as ellipses or fills, or to render a visual 
display of an audio file.

Audio Spectrum
This effect displays the spectrum of an audio layer in the range you define using Start 
Frequency and End Frequency. It can display the audio spectrum in a number of different 
ways, including along a Bezier path of a layer. Apply the effect to a layer that contains a 
solid or an image, and that may contain audio. The audio layer’s adjustments, such as time-
remapping, effects, stretch, and levels, will not be present. To graph this information for 
the audio layer, precompose the audio before applying this effect. 

Note: This effect is a visual effect, not an audio effect, and it must be applied to a video 
layer. 

For more information, see the After Effects product section on Adobe’s Web site.

Audio Waveform
This effect displays the waveform amplitude of an audio layer. You can display the audio 
waveform in a number of different ways, including along a Bezier path created by an open 
or closed mask of a layer. You apply the effect to a layer that contains a solid or an image, 
and that may contain audio. The audio layer’s adjustments, such as time-remapping, 
effects, stretch, and levels, will not be present. To graph this information for the audio 
layer, precompose the audio before applying this effect.

For more information, see the After Effects product section on Adobe’s Web site.
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Beam
This effect animates the movement of a laser beam. You can make the laser shoot, or you 
can create a wand-like laser with stationary start and end points. This effect uses a 3D 
perspective based on the change in Starting Thickness and Ending Thickness. The beam 
looks best when motion blur is enabled and the shutter angle is set to 360.

To make a shooting laser beam, use keyframes to change the start point, end point, and length over 
time. 

The Length option specifies the length of the beam based on a percent of the Time 
specified. For example, a setting of 100% means that the visible beam length is at its 
maximum when the Time option is 50%. Time specifies the time of the beam’s travel from 
start to end as a percent. The 3D Perspective option uses 3D perspective when animating 
Time.

Ellipse
This effect draws an ellipse based on the dimensions you specify in the Effect Controls 
window. In addition to width and height, you can specify the thickness, softness, and color 
of the ellipse. 

The Width/Height options specify the width and height of the ellipse in pixels. Values 
range from 0 to 2000 pixels. Thickness specifies the thickness of the arc forming the 
ellipse. Values range from 0 to 1000 pixels. Softness specifies the softness or degree of blur 
of the ellipse’s arc.

Fill
This effect is used to fill a mask with a specified color. The Fill Mask menu displays the 
available masks. If you want to add both a stroke and a fill to a closed path, the order in 
which you apply the stroke and fill effects determines the visible width of the stroke. If the 
fill is applied before the stroke, the full stroke brush size is visible. If the stroke is applied 
before the fill, the fill appears on top of the stroke, obscuring the half of the stroke that 
falls inside the path. See “Stroke” on page 216.

Fractal
This effect renders the Mandelbrot or Julia set, creating colorful textures. When you first 
apply the effect, the picture you see is the classic sample of the Mandelbrot Set (the “set” is 
the area that is colored black). Any pixel lying outside of the set is colorized, depending on 
how close it is to the set. Pixels near the border appear chaotic (noisy), but as you zoom in, 
a quite startling and beautiful structure is revealed. 

For more information, see the After Effects product section on Adobe’s Web site.
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Fractal Noise (PB only)
This effect uses randomness to create textures and objects that cannot be described using 
simple geometric shapes. Use this effect to create organic-looking backgrounds, 
displacement maps, textures, and mattes. You can also simulate things like caustics, 
clouds, lava, flowing water, and gas. 

If you animate the Evolution option, the result is smooth changes of the noise over time, 
such as clouds passing by or flowing water. Use the Evolution options to create loops for 
faster rendering time. 

For more information, see the After Effects product section on Adobe’s Web site.

Lightning (PB only)
This effect creates lightning bolts and other electrical effects, including a “Jacob’s Ladder” 
effect (as seen in old horror movies) between two specified points in a layer. The lightning 
effect is automatically animated without keyframes across the time range.

Set keyframes for the Start Point and End Point properties to create a “Jacob’s Ladder” effect.

Use the Wiggler to add randomness to the lightning bolt. For more information on 
using the Wiggler, see “Adding randomness (PB only)” on page 304.

For more information, see the After Effects product section on Adobe’s Web site.

PS+Lens Flare (PB only)
See the Adobe Photoshop User Guide or online Help for information on using this effect.

Radio Waves
This effect generates waves from an effect point and can be used to create pond ripples, 
sound waves, or intricate geometric patterns. Use the effect’s options to control the 
emitted shape’s number of sides; the width, color, and quality of the line; and the speed, 
rotation, life span, and the fade rate of the shapes. The Reflection option makes the 
emanating shapes bounce off the sides of the layer. 

Radio Waves generates realistic wave displacement maps that work well when combined 
with the Wave World and Caustics effects.

For more information, see the After Effects product section on Adobe’s Web site.

Ramp
This effect creates a color gradient, blending it with the original image contents. Create 
linear or radial ramps and vary the position and colors of the ramp over time. Use the Start 
and End of Ramp options to specify the start and end positions. Use the Ramp Scatter 
control to disperse the ramp colors and eliminate banding, or use Ramp in 16-bit mode.

Note: Traditionally, ramps do not broadcast well; serious banding occurs because the 
broadcast chrominance signal does not contain sufficient resolution to reproduce the 
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ramp smoothly. The Ramp Scatter control disperses the ramp colors, eliminating the 
banding apparent to the human eye.

Stroke
This effect creates a stroke or border around a mask or along a Bezier path. You can also 
specify stroke color, opacity, and spacing, as well as brush characteristics. Specify whether 
the stroke appears on top of the image, on a transparent image, or if it reveals the original 
alpha channel. To use a path created in Illustrator, copy the path and paste it into a layer in 
After Effects. 

The Brush Hardness option specifies the edge quality of the stroke, between hard and soft. 
Spacing specifies the spacing between stroke segments. Paint On specifies whether the 
stroke is applied to the original layer or to a transparent layer. 

Vegas
This effect generates casino-style running lights—and other path-based pulse anima-
tions—around any object. You can outline just about anything on screen, surround it with 
any number of lights or longer pulses, and then animate it to make the lights move around 
the object. Use the Segments controls to adjust the size, length, and rotation of the stroke. 
This effect uses the same Contour controls as the Radio Waves effect.

For more information, see the After Effects product section on Adobe’s Web site.

Simulation effects
Use these effects to simulate real-world occurrences such as reflections of light, bubbles, 
explosions, and waves.

Card Dance (available from the Adobe Web site)
This effect generates card choreography by controlling all geometric aspects of the cards 
using a second layer. For example, use Card Dance to create the appearance of a crowd 
doing the wave, simulate an extruded pin sculpture, or create the appearance of the 
letters of a logo floating on the surface of a pond. Apply Card Dance to the layer you want 
to be on the front of the cards.

For more information, see the After Effects product section on Adobe’s Web site.

Caustics (available from the Adobe Web site)
This effect creates reflections of light, similar to what you see at the bottom of a body of 
water, which are generated by the light refracting through the water surface. It generates 
realistic water surfaces when used in conjunction with Wave World or Radio Wave. Use the 
Bottom controls to specify the layer you want at the bottom of the pool. Use the Water 
Surface option to specify a layer’s luminance as a height map for generating a 3D water 
surface. 

For more information, see the After Effects product section on Adobe’s Web site.
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Foam (available from the Adobe Web site)
This effect generates bubbles. Use the effect’s controls to adjust bubble properties such as 
stickiness, viscosity, life span, bubble strength, and how the Foam particles interact with 
each other and with their environment. You can specify a separate layer to act as a “flow 
map,” controlling precisely where the Foam travels. For example, you can have bubbles 
flow around a logo, or fill a logo with bubbles. You can also substitute bubbles with an 
image or a movie.

For more information, see the After Effects product section on Adobe’s Web site.

Particle Playground (PB only)
Use this effect to create animations in which a large number of similar objects must be 
animated independently, such as a swarm of bees. Particle effects simulate the physical 
interactions between objects in the real world. For example, if you want to create a 
snowfall effect, you normally have to animate many individual snowflake layers manually, 
hoping that you animated each layer’s motion path realistically. For more information, see 
“Creating Particle Effects (PB only)” on page 351.

For more information, see the After Effects product section on Adobe’s Web site.

Shatter 
This effect blows up images. Use the effect’s options to set explosion points, and adjust 
the strength and radius. Anything outside of the radius doesn’t explode, leaving portions 
of the layer unaltered. You can choose from a variety of shapes for the shattered pieces, 
and extrude the pieces to give them bulk and depth. 

For more information, see the After Effects product section on Adobe’s Web site.

Wave World (available from the Adobe Web site)
This effect creates liquid waves. Waves emanate from an effect point, interact with each 
other, and reflect off their environment. Use the effect’s controls to set the waves’ 
properties, such as the direction of the wave, the vertical and horizontal size, the speed 
and strength of travel, and the transparency. Wave World generates a grayscale 
displacement map that you can use with the Colorama or Caustics effects.

For more information, see the After Effects product section on Adobe’s Web site.

Stylize effects
Use these effects to produce abstract or impressionistic images by altering and displacing 
pixels and manipulating an image’s color scheme.

A. Brushstrokes B. Mosaic C. Motion Tile 

A B C
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For more information, see the After Effects product section on Adobe’s Web site.

Brush Strokes
This effect applies a rough painted look to an image. You can also use this effect to achieve 
a pointillist-style look by setting the length of the brush strokes to zero and increasing the 
stroke density. Although you specify the direction of strokes, they are scattered randomly 
by a small amount to give a more natural effect. This effect alters the alpha channel, as well 
as the color channels; if you have masked out a portion of the image, the brush strokes 
“paint” over the edges of the mask.

For more information, see the After Effects product section on Adobe’s Web site.

Color Emboss
This effect works like the Emboss effect, without suppressing the image’s original colors.

Emboss
This effect sharpens the edges of objects in the image and suppresses colors. The effect 
also highlights the edges from a specified angle. The layer’s quality setting influences the 
Emboss effect by controlling the Relief setting. Relief is calculated at the subpixel level in 
Best quality and rounded off to the pixel level in Draft quality.

The Direction option specifies the apparent direction from which the highlight source is 
shining, in degrees. A setting of 45 degrees causes the shadow to be cast from the 
northeast direction. Relief specifies the apparent height of the embossing, in pixels. The 
Relief setting actually controls the maximum width of highlighted edges. Contrast 
specifies the sharpness of the image content’s edges. At lower settings, only distinct edges 
show the effect. As you increase the setting, the highlight becomes more extreme.

Find Edges
This effect identifies the areas of the image that have significant transitions and empha-
sizes the edges. Edges can appear as dark lines against a white background or colored 
lines against a black background. When the Find Edges effect is applied, images often look 
like sketches or photographic negatives of the original.

The Invert option inverts the image after the edges are found. When selected, edges 
appear as bright lines on a black background; when not selected, edges appear as dark 
lines on a white background. 

Glow (PB only)
This effect finds the brighter parts of an image, and then brightens those and surrounding 
pixels to create a diffuse, glowing halo. It can also simulate overexposure of brightly lit 
objects. Base the glow on either the original colors of the image or on its alpha channel. 
Glows based on alpha channels produce diffuse brightness only at the edges of the image, 
between the opaque and transparent regions. You can also use this effect to create a 
gradient glow between two colors and to create multicolor effects with looping.
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Rendering this effect at Best quality can change the appearance of the layer. This is 
especially true if you are using Adobe Photoshop arbitrary maps to color your glows. Glow 
supports Photoshop arbitrary map files (.amp), which are created and saved from the 
Curves dialog box. Be sure to preview this effect at Best quality before rendering.

For more information, see the After Effects product section on Adobe’s Web site.

Leave Color
This effect removes all the colors from a layer except those similar to a given color. For 
example, a movie of a basketball game could be decolored except for the orange of the 
ball itself. The layer’s quality setting does not affect Leave Color.

For more information, see the After Effects product section on Adobe’s Web site.

Mosaic
This effect fills a layer with solid color rectangles. It is useful for simulating low-resolution 
displays and for obscuring faces. You can also animate it for a transition. At Best quality, 
the edges of the mosaic are anti-aliased.

The Horizontal/Vertical Blocks options specify the number of mosaic divisions in each 
direction. Use the Sharp Colors option to give each tile the color of the pixel in its center in 
the unaffected layer; otherwise, the tiles are colored with the average color of the corre-
sponding region in the unaffected layer.

Motion Tile
This effect replicates the source image across the output image. It is called Motion Tile 
because, when changing the placement of the tiles, it uses motion blur to accentuate the 
movement if motion blur is enabled. Tile Center controls the position of the main tile. 

For more information, see the After Effects product section on Adobe’s Web site.

Noise
This effect randomly changes pixel values throughout the image. The layer’s quality 
setting does not affect Noise. When the color of a pixel gets as large as it can, clipping 
makes it stay at that value. With unclipped noise, the color value wraps around or starts 
again at low values.

For more information, see the After Effects product section on Adobe’s Web site.

PS+Extrude
See the Adobe Photoshop User Guide or online Help for information on using this effect.

PS+Tiles
See the Adobe Photoshop User Guide or online Help for information on using this effect.



Using Help | Contents | Index Back 220  

Adobe After Effects Help Applying Effects 

Using Help | Contents | Index Back 220  

Scatter (PB only)
This effect scatters the pixels in a layer, creating a blurry or smeared appearance. Without 
changing the color of each individual pixel, the Scatter effect redistributes the pixels 
randomly, but in the same general area as their original positions. You can automatically 
animate the Scatter effect over the time range without keyframes by randomizing every 
frame.

For more information, see the After Effects product section on Adobe’s Web site.

Strobe Light
This effect performs an arithmetic operation on a layer at periodic or random intervals. For 
example, every 5 seconds the layer could appear completely white for one-tenth of a 
second, or a layer’s colors could invert at random intervals. The layer’s quality setting does 
not affect Strobe Light.

For more information, see the After Effects product section on Adobe’s Web site.

Texturize
This effect gives a layer the appearance of having the texture of another layer. For 
example, you could make the image of a tree appear as if it had the texture of bricks, and 
control the depth of the texture and the apparent light source. At Best quality, the texture 
layer is positioned and scaled with subpixel accuracy.

For more information, see the After Effects product section on Adobe’s Web site.

Write-on 
This effect animates strokes on a layer. For example, you can simulate the writing of 
cursive text or create snakelike movement for a stroke. Use this effect to animate the brush 
size, color, hardness, and opacity of a stroke. After Effects Production Bundle also includes 
the Vector Paint effect, which you can also use to animate strokes. For more information 
on Vector Paint, see “About Vector Paint (PB only)” on page 333.

At each keyframe, you can apply a new property value to the current segment of the 
stroke, or you can apply the value to the entire stroke. For example, you can make a stroke 
become gradually thicker as it is drawn by increasing the stroke’s brush size at each 
keyframe. You control whether a property is applied to stroke segments or to the entire 
stroke using the Paint Time and Brush Time menus.
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In addition, you can apply a stroke to the original layer or to a transparent layer. Applying a 
stroke on a transparent layer is useful when you want to use the brush stroke as a track 
matte or when you want to combine it with other layers using blending modes. With this 
effect, you can use an open path to create the stroke. 

For more information, see the After Effects product section on Adobe’s Web site.

Text effects
Use these effects to create text and numbers for overlays, credit scrolls, titles, and other 
text.

Basic Text
Use this effect to create text and text animation. Specify font, style, and alignment of text; 
select horizontal or vertical text orientation. Animation is created by changing the Position 
point over time. Basic Text also gives you the choice of either compositing the text over 
the layer image or using the text by itself. Best quality creates anti-aliased text that 
animates smoothly.

The Basic Text effect places text on an existing layer (unlike imported text created in 
Adobe Photoshop or Adobe Illustrator, which becomes its own layer). Use it for basic title 
text; for more flexibility in working with text, import text created in an illustration or 
imaging program, or use the Path Text effect. The font you select when creating text must 
be available on the system you use to render the composition. If the font is not available, 
an available font is substituted. After Effects creates an alpha channel for text it creates. 
You can use a text effect’s alpha channel with features such as track matte. 

Note: The width and height of text are not constrained by the dimensions of the layer; the 
layer dimensions merely define the visible region of the text. This feature makes it simple to 
scroll text over a layer.

For more information, see the After Effects product section on Adobe’s Web site.

Numbers
This effect generates random and sequential numbers in different formats. Use it to 
display random times and dates or timecodes. 

For more information, see the After Effects product section on Adobe’s Web site.

Path Text
This effect simplifies the process of animating text along a path. Use it to animate words or 
groups of characters on a single layer instead of animating each character on a separate 
layer. Define a path as a straight line, a circle of any diameter, or a Bezier curve; or import a 
path created in another application, such as Adobe Photoshop. You can also add 
randomness to a number of controls to make text jump or dance.
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Animate text on an existing layer; or, for additional control over placement of text, you can 
create a solid and animate the text on it. The layer on which you animate text is trans-
parent, unless you specify compositing. To modify and animate text, type the text using a 
specified font, define the path, and then create keyframes for the text properties you want 
to change over time. To move text along a path, create keyframes for the left margin or 
right margin.

Path Text applied to a motion path

To enter text: 

1 In the Timeline window, select the layer on which you want to animate text, or create a 
new layer by choosing Layer > New > Solid. 

2 Choose Effect > Text > Path Text. 

3 In the dialog box that appears, choose the font and style for your text, and then type 
the text. You can display the text in the font you’ve chosen by selecting Show Font. 

4 Click OK. The text appears on the layer in the default color of red; by default, the layer 
itself is transparent. To display the layer, select Composite on Original in the Effect Controls 
window. 

5 If you need to change the text or font, click the Options button in the Effect Controls 
window. 

Path text is animated primarily on the location of the path control points. Text will move 
with the position of these points or on a closed path that can be selected from the Path 
Control Points option. You can also animate text by creating keyframes for margin, 
kerning, tracking and size.

To animate path text:

1 In the Timeline window, select the layer that has the Path Text effect applied. Display 
the properties for Path Text and expand the controls under Path Control Points.

2 Move the current-time marker to a point where you want to add a keyframe.

3 Adjust the path control points so that the text is displayed as desired. 

4 Click the stopwatch next to the path control points or other properties for which you 
will be creating keyframes. See “Setting keyframes” on page 98.

5 Repeat steps 2 and 3 until you have created the keyframes needed to animate the text.

6 Select the Path Text effect name in the Effect Controls window to make the path visible 
in the Composition window; then select one of the following shapes from the Shape Type 
menu:

• Select Bezier to shape text along a Bezier curve, defined by four control points (Vertex 
1/Circle Center, Tangent 1/Circle Point, Tangent 2, Vertex 2). Characters that don’t fit on 
the path are placed off the end in a straight line.
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• Select Circle to shape text around the circumference of a circle, defined by two control 
points (Tangent 1/Circle Point, Vertex 1/Circle Center). If the text is longer than the 
circumference of the circle, the text overlaps itself. If an arbitrary path is chosen and if 
the path is closed, this property forms the text around the path, as opposed to looping 
it. 

• Select Loop to shape text around the circumference of the circle, defined by two control 
points (Vertex 1/Circle Center, Tangent 1/Circle Point). If text is longer than the circum-
ference of the circle, it flows off the Tangent 1 point in a straight line. You can also use 
margin controls to make text enter or exit a circle in a straight line.

• Select Line to shape text in a straight line, defined by two control points (Vertex 1/Circle 
Center, Vertex 2). Note that, as with the Bezier path, the distance between the two 
control points does not affect the spacing of the text, unless alignment is set to Force 
(see Alignment below).

For more information, see the After Effects product section on Adobe’s Web site.

Time effects
Use these effects to manipulate the timing of a layer. These effects use the source of a layer 
as the basis of time, so all effects previously applied to a layer are ignored when Time 
effects are applied.

Echo 
This effect combines frames from many different times in a layer. It has a variety of uses, 
from a simple visual echo to streaking and smearing effects. This effect must be applied 
and is visible only in the Composition window, not the Layer window, and it is visible only 
when there is motion in the layer. By default, a layer’s mask and any previously applied 
effects are ignored when you apply the Echo effect. If you do not want them ignored, 
precompose the layer with other effects before applying the Echo effect. This creates a 
new composition with the mask already applied. Whenever Echo needs to retrieve a 
frame, it can do so from that composition.

The Echo effect is based on the positions of the previous or subsequent frames.

For more information, see the After Effects product section on Adobe’s Web site.

Posterize Time
This effect locks a layer to a specific frame rate. It is useful on its own as a special effect, but 
it also has more subtle uses. For example, 60-field video footage can be locked to 24 fps 
(and then field rendered at 60 fps) to give a film-like look. Also, nested compositions can 
be locked to a given frame rate. This effect is sometimes called Strobe in hardware devices.
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A layer’s mask and any previously applied effects are ignored when the Posterize Time 
effect is applied. To posterize the time of a masked layer, create the mask in another 
composition or precompose the layer with other effects before applying the Posterize 
Time effect.

Animating the value of the Frame Rate slider can give unpredictable results. For this 
reason, the only interpolation of the frame rate allowed is Hold. 

Time Displacement (PB only)
This effect distorts the image by shifting pixels across time, producing a wide variety of 
effects. For example, use it to simulate the traditional slit-scan technique, which captures 
different stages of a moving image across time. It uses a displacement map and bases the 
time displacement of pixels in the layer on luminance values in the map. Pixels in the layer 
that correspond to bright areas in the displacement map are replaced by pixels in the 
same position but at a specified number of seconds forward in time. Likewise, pixels in 
dark areas are replaced by pixels at a specified number of seconds backward in time. The 
Time Displacement effect automatically replaces pixels across time without keyframes. 
However, you can also set keyframes for other controls to vary the effect over time.

For more information, see the After Effects product section on Adobe’s Web site.

Transition effects
Use these effects as transitions between one layer and another, or between several layers. 
Place the transition layer in front of other layers you want to transition into. Apply the 
effect to the transition layer. Set keyframe values for the Transition Completion slider to 
animate the change from the transition layer to the layers beneath.

Block Dissolve
This effect makes a layer disappear in random blocks. The width and height of the blocks, 
in pixels, can be set independently. At Draft quality, the blocks are placed with pixel 
accuracy and have sharply defined edges; at Best quality, the blocks can be positioned 
with subpixel accuracy and have soft edges.

A. Draft quality B. Best quality C. Best quality with different block dimensions

A B C
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Card Wipe (available from the Adobe Web site)
This effect simulates the effect a group of people in a stadium with cards, holding the 
cards that make a picture, and then flipping them over to reveal a different picture. Card 
Wipe gives you full control over the number of rows and columns of cards, the flip 
direction, and the transition direction, including the ability to use a gradient to determine 
flip order. Use the effects controls to adjust randomness and jitter. You can vary the rows 
and columns to create venetian blind and chinese lantern effects.

For more information, see the After Effects product section on Adobe’s Web site.

Gradient Wipe
This effect creates transitions based on the luminance values of a second layer, called the 
gradient layer. The luminance of a pixel in the gradient determines the time at which the 
corresponding pixel in the first layer will become transparent. Dark areas of the gradient 
layer represent those areas which will become transparent first, followed by lighter areas.

A. Grayscale gradient image B. Gradient Wipe near beginning C. Gradient Wipe near end

For more information, see the After Effects product section on Adobe’s Web site.

Iris Wipe
This effect creates a radial transition that reveals an underlying layer. Specify the number 
of points used to create the iris using a range of 6 to 32 points, and specify whether an 
inner Radius is used. When Use Inner Radius is selected, you can specify values for both the 
Inner and Outer Radius; the iris is not visible when Outer Radius, Inner Radius, or both are 
set to 0. The iris is roundest when both Outer Radius and Inner Radius are set to the same 
value.

Iris Wipe creates a transition from one layer to another using an iris with seven points.

Linear Wipe
This effect performs a simple linear wipe of a layer in a specified direction. At Draft quality, 
the edge of the wipe is not anti-aliased; at Best quality, the edge of the wipe is anti-aliased 
and the feather is smooth.

The Wipe Angle option specifies the direction that the wipe travels. For example, at 90 
degrees the wipe travels from left to right.

A B C
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Radial Wipe
This effect reveals an underlying layer using a wipe that circles around a specified point. At 
Best quality, the edges of the wipe are anti-aliased.

The Start Angle option specifies the position or angle at which the transition starts. With a 
start angle of 0 degrees, the transition starts at the top of the layer. Wipe specifies whether 
the transition moves clockwise, counterclockwise, or alternates between the two. 

Venetian Blinds
This effect reveals an underlying layer using strips of specified direction and width. At 
Draft quality, the strips are animated with pixel accuracy; at Best quality the strips are 
animated with subpixel accuracy.

Venetian Blinds creates a striped transition from one layer to another.

Video effects
Use these effects to prepare your movie for video.

Broadcast Colors
This effect alters pixel color values so that the layer can be accurately represented in a 
television broadcast. Computers represent colors as combinations of red, green, and blue. 
Consumer video equipment represents colors using different composite signals. Home 
video equipment cannot reproduce signals above a certain amplitude, and computer-
generated colors can easily exceed this limit. (Signal amplitude is measured in IRE units; 
120 IRE units is the maximum possible transmission amplitude.) This effect reduces 
luminance or saturation to a safe level. The layer’s quality setting does not affect the 
Broadcast Colors effect.

Reducing saturation requires greater amplitude modification than reducing luminance to 
achieve the same IRE unit level, which alters the appearance of your image more. Key Out 
Unsafe and Key Out Safe make it easy for you to determine which portions of the layer will 
be affected by the Broadcast Colors effect at the current settings. If you make your 
background a contrasting color and temporarily select Key Out Unsafe or Key Out Safe, the 
background will be visible through affected or unaffected areas of the layer, respectively.

For more information, see the After Effects product section on Adobe’s Web site.

Reduce Interlace Flicker
This effect reduces high vertical frequencies to make images more suitable for use in an 
interlaced medium (such as NTSC video). For example, images with very thin horizontal 
lines can flicker annoyingly when broadcast. Reduce Interlace Flicker softens horizontal 
edges to reduce the flickering.

Note: Flicker may result from fields that have not been separated. For information on 
separating fields, see “Using interlaced video in After Effects” on page 43.
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Timecode
This effect displays timecode or frame number information within a layer. It can also 
encode the timecode information into the layer for later display within After Effects. This 
effect cannot modify timecode embedded from external sources, such as QuickTime 
movies rendered with or assigned a timecode track. Although you can’t render movies 
containing embedded timecode information, you can render movies containing visible 
timecode. 

For more information, see the After Effects product section on Adobe’s Web site.
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3D Compositing

Understanding 3D
Many graphics programs, including After Effects, display images in two dimensions, or 2D, 
which means that these images exist in and can only be moved to locations along the 
horizontal (X) and vertical (Y) axes.

A conventional After Effects 2D image (left) and an image with 3D properties (right).

Programs that work in 3D add distance, or depth, as another dimension in which an 
element of the image, or object, can be placed. Depth is expressed as an additional 
coordinate, called “Z.” As with X and Y coordinates, the Z coordinate defines the position of 
an object along the depth axis, called the Z axis. 3D coordinates are expressed as the 
variable (x, y, z). A positive Z coordinate indicates that an image is located farther from the 
viewer; a negative Z coordinate indicates that an image is nearer to the viewer. Adding 
depth allows objects to display more realistic depictions of how they reflect light, cast 
shadows, and move through space.

In most 3D programs, lights of varying intensities and positions are combined with images 
and views. All of them can be animated in 3D space. Colors and surfaces change realisti-
cally as the objects move through the lights, often creating dramatic and complex anima-
tions that can effectively simulate actual motion and perspective.

Understanding 3D compositing in After Effects
After Effects 3D layers are two-dimensional rectangles that can be moved in three dimen-
sions. When they are first created they are placed at 0 on the Z axis. 

Any layer, except an adjustment layer, can be a 3D layer. You can also create and animate 
camera and light layers to respectively view or illuminate images from any angle. Though 
you can import composited files with 3D information into After Effects, you cannot manip-
ulate the objects of those files nor can you create models within the program. 
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Working with 3D layers
Designating a layer as 3D activates the additional layer properties associated with manip-
ulating and modifying that layer in a 3D environment: Z-position for the layer and anchor 
point, X- and Y- rotation, orientation, and the layer material options. The layer material 
options determine how the layer interacts with light. For more information on these 
options, see “Understanding 3D layer material options” on page 232. A layer is 3D layer if a 
cube icon ( ) shows in the 3D layer column in the Timeline window. 

To designate a layer as 3D:

Do one of the following:

• In the Timeline window, locate the layer you want to designate as 3D and click the 3D 
layer switch for that layer.

3D layer switch.

• Select the layer you want to designate as 3D in the Timeline or Composition window, 
and choose Layer > 3D Layer.

Moving a 3D layer in the Composition window
To move a 3D layer in the Composition window, drag either the axes or the layer itself.

Once you have designated a layer as 3D and have selected the layer, three arrows, called 
the axes, appear on the layer in the Composition window. Each arrow on the axes controls 
a corresponding axis and is color-coded. The red arrow represents the X axis, the green 
arrow represents the Y axis, and the blue arrow represents the Z axis. When you position 
the selection or rotation tool over an arrow on the axes, an X, Y, or Z appears next to the 
pointer, identifying the axis. 
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When you drag one of the arrows with a selection or rotation tool, you adjust the layer’s 
location in space. If you are adjusting the position of a layer, the layer travels along the 
corresponding axis. If you are adjusting the rotation of a layer, the layer pivots around the 
corresponding axis at the layer anchor point. You can adjust the layer’s anchor point by 
dragging it with the pan behind tool (see “Setting and animating an anchor point” on 
page 111 for information on using the pan behind tool to adjust an anchor point). The Info 
palette updates to show the coordinate of the layer you are adjusting.

A. Y axis  B. X axis  C. Z axis

The axes also appear on camera and light layers and perform the same functions for those 
layers. For more information on the camera and its axes, see “Using cameras” on page 235. 
For more information on lights, see“Using lights” on page 239.

You can also move 3D layers by dragging the layer in the Composition window. Dragging 
within a layer using the selection tool moves the layer within the camera’s plane of view. 
Dragging a layer handle using the rotation tool constrains the rotation to a particular axis. 

Note: The axis along which you can drag a layer depends on the composition 3D view. For 
information on 3D views, see “Understanding 3D views” on page 234. 

To adjust the position or rotation of a 3D layer in the Composition window:

1 Select the 3D layer you want to move.

2 In the toolbox, do one of the following:

• To adjust the position of a layer, click the selection tool ( ).

• To rotate a layer, click the rotation tool ( ) or ( ). (The latter icon indicates that you are 
adjusting a different Rotation property value. See “Understanding 3D rotation” on 
page 232 for more information.)

3 In the Composition window, do one of the following:

• Using the selection or rotation tool, position the pointer over any one of the axis arrows 
(until the name of the axis appears next to the pointer) and drag the axis. You can drag 
the pointer inside or outside the Composition window.

• Using the selection or rotation tool, drag anywhere on a layer.

• Using the rotation tool, drag a layer handle. If you drag a layer corner point, the layer 
rotates along the Z axis; if you drag a left or right layer handle, the layer rotates along 
the Y axis; if you drag a top or bottom layer handle, the layer rotates along the X axis.

A

B

C
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To move the anchor point in 3D space using the axes:

1 Select the layer whose anchor point you want to move.

2 In the toolbox, click the pan behind tool ( ).

3 In the Composition window, position the pointer over the center of the axes and drag.

Note: This procedure also adjusts the layer position relative to the composition so that the 
layer remains in the same place in the composition that it occupied before you moved the 
anchor point. To move the layer relative only to the anchor point, either move the anchor 
point in the layer window or change the anchor position value in the Timeline window.

To move a layer faster when adjusting position, or to rotate the layer in 45- degree 
increments:

Hold down Shift while dragging an axis.

To show a wireframe representation of the layer movement:

In the Timeline window, click the Wireframe Interactions button ( ). See “Using Wireframe 
Interactions” on page 242 for more information on using this feature.

Understanding 3D Transform properties
Designating a layer as 3D increases the number of transform properties. In the Timeline 
window, each of the standard 2D transform properties of Anchor Point, Position, and Scale 
have adjustable Z-axis values in 3D layers. Changing these values adjusts the layer’s 
position along the Z-axis. 3D layers also add Rotation Transform properties that can be 
changed for each axis independently, as well as an additional Rotation Transform property 
called Orientation (see “Understanding 3D rotation” on page 232 for information on the 
rotation property values). 

For information on changing Transform properties, see “Setting keyframes” on page 98 
and “Setting and animating a layer property in the Timeline window” on page 114.

Z-axis values highlighted

Understanding 3D auto-orientation
In contrast to 2D layers, 3D layers in After Effects include additional auto-orientation 
options in the Auto-Orient dialog box. The additional options that are added depend on 
the layer to which auto-orientation is applied. 3D footage layers add the Orient Toward 
Camera option which, when chosen, sets the layer so that it will always face the active 
camera. For information on setting auto-orient options, see “Rotating a layer along a 
motion path” on page 111.

Light and camera layers add the Orient Toward Point of Interest option. For more infor-
mation about this option, see “Understanding camera Transform properties” on page 237 
or “Understanding Light Transform properties” on page 240.
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Understanding Z scale
Usually, scaling a layer’s Z axis has no effect on the layer because the layer itself has no 
depth. However, changing the position of the layer anchor point or establishing a 
parenting relationship with other layers adds depth to a layer either relative to its anchor 
point, or to child layers. In these cases, scaling a layer’s Z axis will appear to affect the layer. 

If the Z-axis value of a layer’s anchor point has been adjusted so that the anchor point rests 
somewhere behind or in front of the layer (has a value greater or less than 0) or if the 
scaled layer is a parent to other 3D layers, then changing the Z axis of that layer expands or 
contracts the area between either the layer and the anchor point, or the parent and child 
layers. This contraction or expansion of the area between the anchor point or child layer 
and the scaled layer makes the scaled layer or layers appear to change position.

Understanding 3D rotation
You can adjust 3D rotation two ways: changing a layer’s Orientation values, or changing its 
X Rotation, Y Rotation, and Z Rotation values.

When you animate any of a 3D layer’s Orientation property values, the layer moves along 
the shortest possible rotational path in 3D space (you can smooth this path by changing 
the spatial keyframe interpolation to Auto Bezier; see “Changing the interpolation 
method” on page 126 for more information). This property is useful for creating natural 
and predictable rotations.

When you animate any of a 3D layer’s X, Y, or Z Rotation property values, the layer rotates 
along each individual axis. You adjust the number of rotations as well as the angle of 
rotation. You can also add keyframes to the layer’s rotation on each axis individually. 
Animating using these Transform properties allows for more keyframing options than the 
orientation transform property does, but also may result in motion that is less predictable. 
This property is useful for creating rotations with multiple revolutions along a single axis.

By default, the rotation tool adjusts rotation by changing the Orientation values. You can 
also use the rotation tool to adjust rotation by changing the X, Y, or Z Rotation values. 

To adjust rotation by changing the X, Y, or Z Rotation Transform properties:

Hold down Alt (Windows) or Option (Mac OS) as you select the rotation tool ( ) in the 
toolbox. The rotation tool looks like  when you are adjusting the X, Y, or Z Rotation 
property. For information on using the rotation tool, see “Moving a 3D layer in the Compo-
sition window” on page 229.

Understanding 3D layer material options
In the Timeline window, 3D layers have an additional set of properties called Material 
Options. These determine how a 3D layer interacts with light and shadow, both of which 
are important components of realism and perspective in 3D animation. 

Layer material options
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In the timeline, when you expand a 3D layer and then expand the Material Options for that 
layer, the following properties appear:

Casts Shadows Used to cast a shadow on layers within the range of that shadow. The 
direction and angle of the shadows is determined by the direction and angle of the light 
sources.

Accepts Shadows Used to show the shadow cast on a layer by another layer. 

Accepts Lights Lets the layer be illuminated by any light that reaches it.

Ambient Sets the level of ambient (nondirectional) reflectivity of the layer. A setting of 
100% creates the most reflectivity; a setting of 0% means that the layer does not exhibit 
any ambient reflective properties.

Diffuse Sets the level of diffuse (omnidirectional) reflectivity of the layer. Applying diffuse 
reflectivity to a layer is like draping a dull, plastic sheet over it. Light that falls on this sheet 
reflects equally in all directions. A setting of 100% creates the most reflectivity; a setting of 
0% means that the layer does not exhibit any diffuse reflective properties.

Specular Sets the level of specular (directional) reflectivity of the layer. Light reflecting 
from a layer with specular reflective attributes reflects from the layer as if the layer were a 
mirror. A setting of 100% creates the most reflectivity; a setting of 0% means that the layer 
does not exhibit any specular reflective properties.

Shininess Sets the size of the specular highlight. This value is only active if the specular 
setting is greater than zero. A setting of 100% produces a reflection with a small specular 
highlight. A setting of 0% produces a large specular highlight.

Understanding 3D layer order
Because of their depth properties, After Effects 3D layers can be placed behind or in front 
of each other in the Composition window, but they do not change their position in the 
Timeline window layer hierarchy. Therefore, the layer order of After Effects 3D layers in the 
Timeline window does not necessarily represent their order in the Composition window 
(as would happen with 2D layers).

In addition to determining the actual positioning of the layers, the order in the Compo-
sition window also determines how Transfer Modes work. Transfer Modes affect only layers 
positioned behind the original layer (the layer to which the Transfer Mode is applied) in 
the Composition window. 

However, layer order in the Timeline window is still honored when you use Track Mattes. 
Track Mattes work only between layers that are adjacent in the Timeline window. 

Use the additional views available from the 3D View menu to determine the actual 
position of the 3D layers. For more information on 3D views, see “Understanding 3D 
views” on page 234.

Combining 2D and 3D layers
Because 3D is a layer property in After Effects, compositions can contain both 2D and 3D 
layers. Though you can combine 2D and 3D layers in your animations, lights do not affect 
2D layers, nor will shadows cast by 3D layers affect 2D layers.

The position of 3D and 2D layers in a composition can also affect how a composition is 
rendered. See “3D rendering” on page 242 for more information.
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Understanding 3D views
You can view your 3D layers from several angles, using orthogonal views or custom views 
that employ perspective. The orthogonal views (Front, Back, Left, Top, Right, and Bottom) 
show a layer’s position in the composition but do not show perspective.

3D Views

The three custom views place you at a certain height and angle within the composition, 
depending on the view you choose. You can save up to three views for quick access using 
keyboard shortcuts. Adjust your angle and height within custom views with the camera 
tools. For information on adjusting the custom view, see “Using the camera tools” on 
page 238.

To set a 3D view:

Do one of the following:

• Click the 3D view menu at the bottom right of the Composition window and choose a 
view.

• Choose View > Switch 3D View and select a view from the menu.

• Choose View > Switch to Last 3D View to switch to the previous view.

To set or replace 3D view shortcuts:

1 Set the 3D View as described in the “To set a 3D View” procedure above.

2 Choose View > Set 3D View Shortcut > Replace n, where n is a view you want to replace. 
After Effects replaces the view shown in the menu with the current-composition 3D view.

To toggle among 3D views:

Do one of the following:

• To toggle among the three 3D view shortcuts in the View > Set 3D View Shortcut menu, 
press F10, F11, or F12 to display the first, second and third view, respectively.

• To switch to the previous 3D view, press Esc.
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Using cameras
After Effects 3D layers can be viewed from any number of angles and distances using 
cameras. When you set a particular camera view for your composition, you look at the 
layers as though you were looking through that camera. You can choose between viewing 
your composition through the Active Camera or through a particular named camera. The 
Active Camera is the topmost camera in the layer order at the current time. If you have not 
created a camera, then the Active Camera is the same as the default composition view. The 
Active Camera is the only camera view that will be rendered. This includes nested compo-
sitions, and final renders, regardless of the view showing in the Composition window. All 
other cameras that you create are included in the View list; you can access their views at 
any time. 

Though you can add multiple cameras to any composition, the views affect only 3D layers, 
or 2D layers with Comp Camera effects applied (see “Using cameras and lights with 
effects” on page 175 for more information on Comp Camera effects). You can animate 
cameras along the X, Y, and Z axes. Each camera has its own set of properties, which 
include varying focal lengths, apertures, and focus distances. This allows you to create 
custom cameras in order to simulate a large range of real cameras. Because camera layers 
are inherently 3D, they cannot be designated as 2D. Camera layers can be both a parent 
and child to 2D and 3D layers.

A. Point of interest  B. Frame  C. Camera

To create a camera:

1 Select either the Timeline or Composition window.

2 Choose Layer > New > Camera.

3 Adjust settings as explained in “Understanding camera settings” on page 236 and click 
OK.

To change the camera used in the view:

Click the menu at the bottom right of the Composition window and choose a camera 
view.

B

A

C
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Understanding camera settings
When you create a new camera, it becomes a new layer in the Timeline window and its 
name appears in the 3D View pop-up menu. Though the cameras’ locations in the layer 
order in the Timeline window do not affect their positions in the Composition window, 
they do determine which of the cameras is rendered. After Effects renders the Active 
Camera view, regardless of the view selected in the 3D View menu. 

The After Effects camera is intended to simulate the capabilities of real-world cameras. 
Therefore, you can configure the camera view either to match settings you may have used 
to record video footage or to create a custom view.

Use the guidelines below to determine the optimal setting. You can change the camera 
settings at any time.

Name After Effects, by default, assigns the name Camera 1 to the first camera you create 
in a composition, and all subsequent cameras are numbered in ascending order. If you 
delete a camera, and are still using the After Effects default naming convention, then After 
Effects names the next camera you create with the lowest available number. You should 
choose distinctive names for multiple cameras to make it easier to distinguish them. 

Preset Cameras come with several presets. The presets are named according to focal 
lengths. Each preset is meant to represent the behavior of a 35mm camera with a lens of a 
certain focal length. Therefore, the preset also sets the angle of view, zoom, focus distance, 
focal length, and aperture values. The default preset is 50mm. You can also create a 
custom camera by specifying new values for any of the settings.

Zoom The distance from the position of the camera to the image plane.

Angle of View This is the width of the scene captured in the image. The focal length, film 
size, and zoom determine the angle of view. A wider angle of view creates the same effect 
as a wide-angle lens.

Enable Depth of Field The depth of field is the distance range within which the image is 
in focus. Images outside of the distance range are blurred. Select this option to apply 
custom variables to the focus distance, aperture, f-stop, and blur level. Using these 
variables, you can manipulate the depth of field to create more realistic camera-focusing 
effects.

Focus Distance Distance from the camera’s position to the plane that is in perfect focus.

Aperture The size of the lens opening. The aperture setting also affects the depth of 
field—increasing the aperture increases the depth of field blur. When you specify new 
values for the aperture, the values for f-stop change dynamically to match it.

F-stop A number representing the ratio of the focal length to aperture. Most cameras 
specify aperture size using the f-stop measurement; thus, many photographers prefer to 
set the aperture size in f-stop units. When you specify new values for the f-stop setting, the 
values for aperture change dynamically to match it.

Blur Level Controls the amount of depth-of-field blur in an image. A setting of 100% 
creates a natural blur as dictated by the camera settings. Lower values reduce the blur.

Film Size The size of the exposed area of film, which is directly related to the composition 
size. When you specify new values for film size, the zoom changes to match the 
perspective of a real camera.
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Focal Length In After Effects’ camera model, the distance from the film plane to the 
camera lens. In After Effects, the camera’s position represents the center of the lens. When 
you specify new values for the focal length, the zoom changes to match the perspective of 
a real camera.

Units The units of measurement in which the camera setting values are expressed.

Measure Film Size The dimensions used to depict the film size.

Understanding camera Transform properties
Cameras can be animated in 3D space just like 3D layers. Use the Camera Transform 
properties to change the angle and distance of the composition view. Cameras have all 
the Transform properties that a layer has, except for scale and anchor point, and are 
adjusted just like other 3D Transform properties (see “Setting and animating a layer 
property in the Timeline window” on page 114 for information on adjusting Transform 
properties in the Timeline window). Cameras also add a transform value called the point of 
interest.

The point of interest is the spot in the composition at which the camera points. It is 
indicated by the point of interest icon in the Composition window. By default, the point of 
interest is the center of the composition, and the camera’s view is auto-oriented to it. You 
can have the camera continue to point at the point of interest as it changes position, have 
the camera’s view oriented toward the motion path, or turn off orientation altogether, 
thereby freeing the camera’s view from any related element. You can adjust the point of 
interest only if the camera is auto-oriented toward the point of interest.

If the camera is auto-oriented toward the point of interest, it continues to point that 
direction as you change its position. When you change the camera’s position by dragging 
the camera icon in the Composition window, or by changing the camera’s position value 
in the Timeline window, the point of interest remains stationary within the composition 
and, as the camera moves along the motion path, it continues to point at the point of 
interest. When you adjust the camera’s position by dragging the axes in the Composition 
window, the point of interest moves as well, and the camera continues to point at it. You 
could use this option to the depict an auto passenger’s perspective, looking at a single 
tree outside of a side window while driving past.

If the camera is auto-oriented toward the motion path, then the camera points only in the 
direction of the motion path. You could use this option to depict a driver’s perspective 
looking at the road ahead when driving.

If the camera auto-orientation is turned off, then the camera rotates freely, independent of 
the motion path or the point of interest.

Note: If you change the camera's Orientation or X, Y, or Z Rotation property while auto-
orientation is on, then the camera will point away from the object to which it is auto-
oriented. The auto-orientation is still on, but it will be offset by any additional rotation you 
specified with Orientation or X, Y, or Z Rotation. You could use this feature to depict a 
passenger's perspective looking out the side window of a car while the auto moves 
forward. This feature may make interactions more complicated. After Effects warns you 
before you use this feature.

To move a camera or point of interest in the Composition window:

1 In the Timeline or Composition window, select the camera you want to transform.
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2 In the Composition window, choose a 3D view based on the position from which you 
want to view the transformation. The active camera’s point of interest icon and the bound-
aries defining its angle of view are not visible in the Active Camera view. Choose another 
view to monitor the exact position of these elements when transforming the active 
camera.

3 Choose the selection or rotation tool.

4 Do one of the following:

• To move the camera and, if applicable, the point of interest, position the cursor over the 
axis you want to adjust and drag.

• To move the camera along a single axis without moving the point of interest, hold 
down Ctrl (Windows) or Command (Mac OS) while dragging the axis along which you 
want to move the camera.

• To move the camera freely without moving the point of interest, drag the camera icon.

• To move the point of interest, drag the point of interest icon.

To change the orientation of the camera:

1 In the Timeline, select the camera whose orientation you want to adjust.

2 Choose Layer > Transform > Auto-Orient.

3 Select the appropriate option and click OK.

To reset the camera Transform properties to default:

1 In the Timeline or Composition window, select the camera you want to return to 
default.

2 Choose Layer > Transform > Reset.

Using the camera tools
Use the camera tools to adjust your view. They manipulate the position of the camera 
viewing the scene indicated by the Camera View popup. Use the orbit camera tool ( ) to 
rotate the current view around the point of interest. Use the track xy camera tool ( ) to 
adjust the view horizontally or vertically. Use the track z camera tool ( ) to adjust the view 
along the line leading to and from the point of interest or, if you are using an orthogonal 
view, to adjust the scale of the view. These tools are specifically for manipulating the 
camera and views and do not become active until you create a 3D layer, a camera, or a 
light. 

To adjust a view using the camera tools:

1 In the toolbox, click and hold a camera tool to see all the available tools and choose the 
one that you want to use.

2 In the Composition window, select the view you want to adjust.

3 Drag in the Composition window. You can drag outside of the window once you’ve 
begun dragging within it.

Using Axes modes
Use the Axes modes to specify the set of axes for which the layer, light, or camera is being 
transformed. You can transform a layer on either the local axes, the world axes, or the view 
axes.
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The Local Axes mode aligns the axes to the surface of a particular 3D layer. 

The World Axes mode aligns the axes to the absolute coordinates of the composition. 
Regardless of the rotations you perform on a layer, the axes always represent 3D space 
relative to the 3D world. 

The View Axes mode aligns the axes to the view you have selected. For example, suppose 
that a layer has been rotated and the view changed to a custom view. Any subsequent 
transformation made to that layer while in View Axes mode happens along the axes corre-
sponding to the direction from which you are looking at the layer.

Note: The camera tools always adjust along the view’s local axes, so their action will not 
be affected by the axes modes.

To change Axes modes:

In the toolbox, select the mode you want to use.

Using lights
You can create lights that shine on other layers. Lights, by default, point at the center of 
the composition, along a vector to a location called the point of interest. Choose among 
four different types of lights and modify them with varying settings. Like other layers, 
lights can be animated.

A. Point of interest  B. Spotlight cone  C. Light

To create a new light:

1 From the Timeline or Composition window, choose Layer > New > Light.

2 Choose settings according to the guidelines in “Understanding light settings” on 
page 239, and click OK.

Understanding light settings
Use the guidelines below to adjust light options. All the options, except Casts Shadows, 
can be animated.

Note: For a layer to show a shadow, you must turn on the Accepts Shadows layer material 
option. See “Understanding 3D layer material options” on page 232 for more information.

A B C
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Light Type Parallel light rays emanate directional, unconstrained light from an infinitely 
distant source. A Spot light emits light from a source that is constrained by a cone, like the 
spotlight used in stage productions. A Point light emits unconstrained omnidirectional 
light, like the rays emitted from a bare light bulb. Ambient light has no source but rather 
contributes to the overall brightness of a scene and casts no shadows.

Intensity Sets the brightness of the light. Negative values create nonlight. Nonlight 
subtracts color from a layer. For example, if a layer is already lit, then creating a directional 
light also pointing at that layer and employing negative values to this new light creates an 
area of negative light, or a dark area, on the layer.

Cone Angle Sets the width of the Spot light by adjusting the angle of the cone 
surrounding the source. This option is active only if Spot is the Light Type.

Cone Feather Adjusts the edge softness of the Spot light. This option is active only if Spot 
is the Light Type.

Color Sets the color of the light. 

Casts Shadows Indicates whether the light source causes a layer to cast a shadow.

Shadow Darkness Sets the darkness level of the shadow. This option is active only if 
Casts Shadows is checked. 

Shadow Diffusion Sets the softness of a shadow based on its apparent distance from the 
shadowing layer. Larger values create softer shadows. This option is active only if Casts 
Shadows is checked.

Understanding Light Transform properties
Like cameras, lights can be animated in 3D space. Use the light Transform properties to 
change the angle and distance of the light source. Lights have all the Transform properties 
that a layer has, except for scale and anchor point. Also, like cameras, the directional lights, 
Spot and Parallel, have a point of interest.

The light’s point of interest, shown by the point of interest icon ( ), indicates the spot in 
the composition to which the light is directed. By default, the point of interest is the center 
of the composition, and the light is auto-oriented to it. You can have the light continue to 
point at the point of interest as it changes position, have the light oriented toward the 
motion path, or turn off orientation altogether. You can adjust the point of interest only if 
the light is auto-oriented toward the point of interest.

If the light is auto-oriented toward the point of interest, it continues to point at that point 
as you change its position. When you change the light’s position by dragging the light 
icon in the Composition window, or by changing the light’s position value in the Timeline 
window, the point of interest remains stationary within the composition and, as the light 
moves along the motion path, it continues to point at the point of interest. When you 
adjust the light’s position by dragging its axes in the Composition window, the point of 
interest moves with the light, but the light continues to be oriented toward it. You could 
use this option to depict a light falling on a single subject as the light source moves past 
the subject. You could also use this option to follow a moving element.

If the light is auto-oriented toward the motion path, then the light points only in the 
direction of the motion path. You could use this option to the depict a driver’s perspective 
in viewing his own headlights while travelling down a dark road.
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If the light auto-orientation is turned off, then the light rotates freely along the motion 
path independent of the orientation of the motion path or the location of a point of 
interest.

To move a light or point of interest in the Composition window:

1 In the Timeline or Composition window, move the current-time marker to the point in 
time where the light you want to transform is active, and select the light layer you want to 
transform. 

2 Choose the selection or rotation tool.

3 Do one of the following:

• To move the light and, if applicable, the point of interest, position the cursor over the 
axis you want to adjust and drag the axes.

• To move the light along a particular axis without moving the point of interest, hold 
down Ctrl (Windows) or Command (Mac OS) while dragging the axis along which you 
want to move the light.

• To move the point of interest, drag the point of interest icon ( ).

Using 3D compositing with effects
Though all After Effects effects are 2D effects, you can apply them to any 3D layer except 
light and camera layers.

With some effects, called Comp Camera effects, you can use the active composition 
camera or lights to view or light an effect from various angles in order to simulate more 
sophisticated 3D effects. For more information on using Comp Camera effects, see “Using 
cameras and lights with effects” on page 175.

Note: Because After Effects effects are 2D, effects that appear to cause protrusions in a 
layer, such as Bulge or Wave Warp, do not have Z space values and do not give you the 
option of viewing layers through a camera. So, when a layer with those effects applied is 
rotated and viewed from the side, the effect does not protrude into 3D space.

Using 3D compositing with masks
You can draw a mask on any 3D layer in After Effects. The mask coordinates correspond to 
the layer coordinates in 2D space. However, the mask itself has no 3D properties except 
those of the layer itself, so you cannot draw a mask along the Z axis. However, once you’ve 
drawn the mask on the layer, the entire layer can be animated along the Z axis.

Using third-party files with depth information
Though After Effects can import third-party files with depth information such as 
ElectricImage (.eiz) files and .rla file formats, and interpret the z-space channel in those 
files, it cannot animate individual objects within those files. After Effects treats composited 
third-party 3D files as a single layer. That layer, as a whole, can be given 3D attributes and 
treated like any After Effects 3D layer, but the objects contained within that 3D file cannot 
be manipulated individually.
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Previewing 3D
You can reduce the amount of data displayed in a 3D layer to facilitate faster renders 
and screen redraws when you are animating them using Wireframe Interactions or Draft 
3D mode.

Using Wireframe Interactions
Clicking the Wireframe Interactions button disables After Effects’ real-time update in the 
Composition window of layers being transformed. Instead, the layers are replaced with 
wireframe representations of the layer. The layer is updated in the Composition window 
only after you stop moving it. You can choose when Wireframe Interactions is enabled or 
disabled.

To enable or disable Wireframe Interactions mode:

Do one of the following:

• Click the Wireframe Interactions button ( ) in the Timeline Window.

• Choose Edit > Preferences > Previews and select an option from the either Use 
Wireframe Interactions While Alt Key (Windows) or Use Wireframe Interactions While 
Option Key (Mac OS) menu. Select Up to enable Wireframe Interactions. Select Down to 
enable Wireframe Interactions only when you hold down the Alt (Windows) or Option 
(MacOS) keys while moving a layer.

To temporarily disable or enable Wireframe Interactions mode:

Hold down Alt (Windows) or Option (Mac OS) as you move a layer.

Working in Draft 3D mode
Clicking the Draft 3D mode button disables all lights and shadows that fall on 3D layers. It 
also disables the camera’s depth-of-field blur.

To enable or disable Draft 3D mode:

Click the Draft 3D mode button ( ) in the Timeline Window.

3D rendering
Compositing the 3D information in After Effects requires different algorithms than those 
needed for rendering 2D information. After Effects provides a 3D renderer that computes 
the motion blur, lighting, shadow, and depth-of-field information unique to 3D. 

The 3D rendering order differs from that of 2D. In the standard rendering order, After 
Effects renders layers according to their Timeline order, from the bottom layer to the top 
layer. In contrast, the 3D renderer calculates 3D layers according to their spatial order in 
the Composition window, from the most distant layer, or the one with the highest Z 
coordinate value, to the closest layer, or the one with the lowest Z coordinate value. If 
compositions contain both 2D and 3D layers, then the rendering order becomes more 
complex. See “Rendering compositions containing both 2D and 3D layers” on page 243 for 
more information on how After Effects handles rendering such compositions.
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After Effects renders the X, Y, and Z rotation Transform properties in their descending 
Timeline order, regardless of the original order in which you set those Transform 
properties.

Note: After Effects does not render intersecting layers.

Rendering compositions containing both 2D and 3D layers
If compositions contain both 2D and 3D layers, After Effects renders the 3D layers in 
independent, noninteractive groups that are separated by the 2D layers. 

For example, if the Timeline contains (from top to bottom) two 3D layers, two 2D layers, 
then two final 3D layers, After Effects first renders the bottom two 3D layers as a set, 
according to their spatial order in the Composition window. Next, it renders the 2D layers 
according to their Timeline order, from bottom to top. Finally, it renders the Timeline’s top 
set of 3D layers. 

However, this top set of 3D layers is rendered in a geometric space independent of the 
lower Timeline set of 3D layers. In effect, the 2D layers have split the 3D space into 
identical, but separate universes. The result is that shadows cast by either Timeline set of 
3D layers do not fall on the other set, and the two sets of 3D layers do not interact geomet-
rically. For example, if the animation calls for a single 3D layer to pass in front of a second 
3D layer and cast a shadow on the second layer as it passed, then this occurs if there is not 
a 2D layer between them in the Timeline. However, if there is a 2D layer between them 
(and it is small enough to allow you to see both 3D layers in the Composition window), 
then the 3D layers are rendered in separate 3D universes, and, therefore the first layer does 
not pass in front of the second and does not cast a shadow upon it. Instead, though the 
animation will still occur, it will happen on separate sides of the 2D layer.

The sets of 3D layers do, however, share both cameras and lights, since these two elements 
are global to the composition.

Using the Adobe render plug-in
After Effects uses the included render plug-in to composite both RAM previews and 
output files. It is chosen by default. After selecting the 3D renderer, you still need to adjust 
your render and output settings through the Render Queue. For information on rendering 
After Effects files, see “Using the Render Queue window” on page 279. 

When rendering a composition that includes cameras, After Effects renders only the 
topmost, active camera in the Timeline window.

To use the After Effects 3D renderer:

1 Select the composition you want to render and choose Composition > Composition 
Settings.

2 Click the Advanced tab.

3 Click the Rendering Plug-in list, choose Standard 3D, and click OK.
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Creating Expressions

Using expressions
Expressions can create a relationship between two properties. For example, if a layer 
rotates and has the Drop Shadow effect applied, you can add an expression to the 
Rotation property to link the rotation values with the Drop Shadow’s Direction values so 
that as the layer rotates, the drop shadow changes accordingly. See “Creating expressions 
with the pick whip” on page 246.

Note: The After Effects Production Bundle also includes Motion Math scripts (see “Using 
Motion Math (PB only)” on page 317). Some scripts may be easier to use than expressions; 
for example, to create effects that synchronize all the audio layers in a composition, use 
the cmpaud.mm script, or to scale and reposition all layers in a composition, use the 
scaleall.mm script.

Expressions are based on the standard JavaScript language—but you don't need to know 
JavaScript to use expressions. Instead, you can create expressions by using the pick whip, 
by using simple examples and modifying them to suit your needs, or by chaining objects 
and methods together using the expression language guide (see “After Effects expression 
language guide” on page 254). If you have even a basic understanding of JavaScript, you 
can write expressions that create sophisticated relationships between layer properties. 

To learn about the more powerful aspects of JavaScript, consult a JavaScript reference 
manual, such as JavaScript: The Definitive Guide, by David Flanagan. 

Note: After Effects uses only the core standard JavaScript language, not the Web browser-
specific extensions. Instead of Web browser extensions, After Effects contains its own set of 
extension objects such as Layer, Comp, Footage, and Camera that you can use to access 
most of the values in an After Effects project.

Creating expressions
All of your work adding, editing, and writing expressions occurs in the Timeline window. 
When you add an expression to a layer property, a default expression appears in a text 
field under the property. Use this field to type new expressions or edit expression 
variables. Some expressions rely on the names of layers in your project; if you change the 
name of a layer that is involved in an expression, the expression will not work.

To create an expression:

1 Select a property in the Timeline window and do one of the following:

• Choose Animation > Add Expression.

• Alt-click (Windows) or Option-click (Mac OS) the property’s stopwatch icon. 

Note: After Effects automatically fills the expression field with a default expression that 
copies the fixed value of the property, or the value of the keyframes, if any. 



Using Help | Contents | Index Back 245  

Adobe After Effects Help Creating Expressions 

Using Help | Contents | Index Back 245  

2 Create the expression by doing one of the following:

• Drag the pick whip ( ) to another property in the Timeline or Effect Controls window. If 
you want, modify the pick whip results. See “Creating expressions with the pick whip” 
on page 246.

• Type an expression directly over the existing text. See “Writing your own expressions” 
on page 248. If you want, use the language elements menu to enter properties, 
functions, and constants. See “Using the expression language menu” on page 252. 

3 Click outside of the expression field or press Enter on the numeric keypad to activate 
the expression.

Note: If an expression cannot be processed, After Effects displays a message explaining 
the error and automatically disables the expression. A yellow warning icon ( ) appears 
next to the expression; click the warning icon to view the error message again. 

A. On/Off switch B. Graph overlay icon C. Pick whip D. Language elements menu E. Expression 
field

Turning an expression on or off
You can turn an expression on or off at any time.

To turn an expression on or off:

Click the On/Off switch ( ) next to the layer property on which the expression is written. 
When an expression is off, a slash appears through the switch ( ).

Resizing the expression field
Expressions can use multiple lines. If you need to increase (or decrease) the size of the 
expression field, position the cursor on the bottom edge of the expression field; when the 
cursor turns into a double-pointing arrow ( ), drag up or down. 

Viewing the expression graph
To see how an expression changes the value or velocity graph, click the graph overlay 
icon ( ). The black graph displays the value or velocity before the expression, and the red 
graph displays value or velocity after the expression.

Turning on the graph overlay for the Position property moves the motion path display into 
the Composition window so that you can see the expression-affected path.

Viewing all expressions in a composition
To view all of the expressions on selected layers, press EE on the keyboard.

B C D EA
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Converting expressions to keyframes
In some situations, it may be useful to convert an expression to keyframes. For example, if 
you want to freeze the values in an expression for a period of time, you can convert the 
expression to keyframes and then adjust the keyframes accordingly; if an expression takes 
a long time to evaluate, you can convert it to keyframes so that it renders faster. When you 
convert to keyframes, After Effects evaluates the expression, creating a keyframe at every 
frame, and then disables the expression.

To convert an expression to keyframes:

In the Timeline window, select the property in which the expression is written and choose 
Animation > Keyframe Assistant > Convert Expression to Keyframes. 

Creating expressions with the pick whip 
Use the pick whip to create expressions that link the values of one property or effect to 
another. For example, link the Rotation property of layer 1 to the Rotation property of layer 
2 to make layer 1’s rotation values the same as layer 2’s; or, link a camera’s Point of Interest 
property to the Position property of another 3D layer to make the camera follow the layer 
as it moves through space. 

Selecting properties and values with the pick whip
To use the pick whip, click the pick whip icon ( ) and drag it to another property or to a 
specific property value. Once you select a property or value, After Effects automatically 
inserts the appropriate expression in the expression field at the location of the cursor; if 
text is already selected in the expression field, that text is replaced by the new expression 
text. If the cursor is not in the expression field, all text in the field is replaced by the new 
text.

Determining which values are used in an expression
Different properties in After Effects have different value dimensions (1D, 2D, 3D, or 4D) 
depending on the number of value parameters they have. In the expression language, 
property values are either single values (numbers) or arrays (see “Numbers and arrays” on 
page 251). Arrays, such as position values, are always enclosed in square brackets and 
separated by commas; a single value, such as an opacity value, does not use brackets. 
Following are examples of different property-value dimensions:

• 1D values: Rotation ° and Opacity %

• 2D values: Scale [x=width, y=height], Position [x, y], and Anchor Point [x, y]

• 3D values: Scale [width, height, depth], Position [x, y, z], and Anchor Point [x, y, z]

• 4D values: Color [red, green, blue, alpha]
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To learn how to select a specific value in a vector or array, such as Position’s y value, see 
“Accessing specific values in a vector or array” on page 252.

An example of using the pick whip 
The following example shows how to use the pick whip to simulate dimming a light bulb 
while rotating a dial. 

Note: To learn what the text in an expression means, see “Understanding the expression 
language” on page 249.

Linking opacity to rotation:

1 Start with a composition containing two solids: make layer 1 a circle named Light and 
layer 2 a rectangle named Dial. 

2 Create keyframes to animate the rotation of Dial. 

3 Select the Opacity property for Light and choose Animation > Add Expression. A 
default expression appears under the property.

4 Click the pick whip ( ) next to the Opacity expression and drag it to the Rotation 
property for Dial. After Effects automatically fills in the following expression:

this_comp.layer("Dial").rotation

5 Press Enter on the numeric keypad or click outside of the expression to activate it.

6 Preview the animation. Notice that the Opacity property of Light is animated, yet there 
are no opacity keyframes.

Note: Make sure to use Rotation values that are compatible with the Opacity property. For 
example, Opacity values range from 0 to 100, so rotating the Dial layer backward using a 
negative value results in an Opacity value of 0.

Editing a pick-whip expression
Once you use the pick whip to create an expression, you can perform simple edits to alter 
the expression’s effect. For example, you can add a scale factor to the expression to 
increase or decrease the effect. To edit a pick-whip expression, type directly in the 
expression field and then press Enter on the numeric keypad or click outside of the field to 
activate it.

Modify a pick-whip expression by using simple math operations, such as the following: 

+ (add)

- (subtract)

/ (divide)

* (multiply)

*-1 (perform opposite of original, such as counterclockwise instead of clockwise)

Using math functions that are a little more complex provide a high degree of flexibility. For 
example, adding “/360*100” to an expression converts a parameter’s values that range 
from 0 to 360, such as a dial, to values that range from 0 to 100, such as a slider.

Examples of edited pick-whip expressions
The following are examples of pick-whip expressions that have been altered with simple 
functions. These expressions are easy to create and result in sophisticated effects that 
would otherwise require dozens of keyframes.
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Animating a clock Start with two layers: an hour hand and a minute hand. Set the anchor 
points for the hands at the center of the clock (see “Setting and animating an anchor 
point” on page 111). Set Rotation keyframes for the hour hand; select the Rotation 
property for the minute hand and choose Animation > Add Expression. Drag the pick 
whip to the hour hand’s Rotation property. The following expression appears:

this_comp.layer("hour hand").rotation

To make the minute hand rotate 12 times faster than the hour hand, type “*12” at the end 
of the expression as follows:

this_comp.layer("hour hand").rotation*12

Controlling blur by its horizontal position Start with one layer that is of smaller dimen-
sions than the composition. Set Position keyframes for the layer and then apply the Fast 
Blur effect. Select the Fast Blur’s Blurriness property in the Timeline window and choose 
Animation > Add Expression. Drag the pick whip to the Position property, and the 
following expression appears:

position[0]

If the blur is too intense, cut the blur amount by one-tenth by adding “/10” to the end of 
the expression as follows:

position[0]/10

Successive scaling up of objects Start with three layers, positioned at the location you 
want them to stream in from. Create Scale keyframes for the first layer. For example, make 
Scale = 0 at 0 seconds and Scale = 100 at 6 seconds. Select the Scale property for the 
second layer and choose Animation > Add Expression. Drag the pick whip to the Scale 
property of the first layer. The following expression appears:

this_comp.layer("layer name").scale

To make the second layer scale 2 seconds later than the first, add the “value_at_time” 
function to the end of the expression, such as:

this_comp.layer("layer name").scale.value_at_time(time-2)

Writing your own expressions
After Effects uses JavaScript 1.2 for expressions. JavaScript provides all the necessary state-
ments, functions, and operators for constructing expressions. To write your own expres-
sions, it may help to have some basic knowledge of JavaScript syntax and mathematics. 
However, once you learn the basic logic behind creating an expression, you can write fairly 
sophisticated expressions without ever looking at a JavaScript reference guide.

Write expressions directly in the expression field, or in any text editor, and then copy and 
paste them to the expression field. For a quick reference to expression elements and their 
proper syntax, use the language element menus. See “Using the expression language 
menu” on page 252. For information on After Effects–specific language requirements, see 
“Understanding the expression language” on page 249. For more information about 
JavaScript, see a JavaScript reference manual, such as JavaScript: The Definitive Guide, by 
David Flanagan.

Important: In JavaScript, a value stored in an object is called a property. However, After 
Effects uses the term “property” to refer to layer attributes as defined in the Timeline 
window. Consequently, for clarity, After Effects documentation refers to a JavaScript 
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property as a “method” when the property takes arguments, or an “attribute” when it does 
not.

When writing expressions, keep the following guidelines in mind:

• JavaScript is case-sensitive.

• Semicolons are required to separate statements or lines.

• Spaces between words are ignored.

Saving an expression
Once you have written an expression, you can save it for future use by copying and 
pasting it into a text-editing application, such as Notepad, Simple Text, or even Stickies. 
However, because expressions are written in relation to other layers in a project and may 
use specific layer names, it doesn’t always work to simply save and load expressions into a 
project. If you want to save an expression for use in another project, you may want to add 
comments to the expression or save the entire project file so that you can use it as a 
reference when you reuse the expression.

Note: You can save a favorite effect that includes an expression and use it in other 
projects, as long as the expression does not refer to properties that don’t exist in the other 
projects. See “Saving favorite effects for instant reuse” on page 172.

To add comments to an expression:

Do either of the following:

• Type // at the beginning of the comment. Any text between // and the end of a line is 
ignored. For example:

// This is a comment.

• Type /* at the beginning of the comment and */ at the end of the comment. Any text 
between /* and */ is ignored. For example:

/* This is a 
multiline 
comment */

Understanding the expression language
The After Effects expression language is based on JavaScript 1.2, with an extended set of 
built-in objects. All expressions start with a global object. Only an attribute or method of 
the global object can appear in an expression with nothing to the left of it.

The global object for any expression is the layer on which the expression is written. For 
example, if you add an expression to the Scale property of a layer named Solid1 and you 
want the expression to return Solid1’s Position property values, you can use any of the 
following expressions, as they are equivalent:

this_comp.layer("Solid1").position

this_layer.position

position
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To retrieve values from an object other than the layer containing the expression, insert the 
object in the expression. For example, if you write an expression on a layer named Solid1 
and you want to retrieve position values from a layer named Solid2, use the following 
expression:

this_comp.layer("Solid2").position

Accessing elements in an expression
Use the expression language to access properties in After Effects that have a numeric 
value. To access a value, use a chain of object references, separated by the period (.) 
operator. To understand the order in which you can add elements to an expression, use 
the “After Effects expression language guide” on page 254 to learn what the element 
returns. 

Consider the following procedure as an example of how to construct an expression using 
the After Effects expression language guide:

To construct a simple expression:

1 Start with two layers.

2 Select the Position property for the first layer in the composition and choose Animation 
> Add Expression. The following expression appears by default:

position

3 Type the following directly over the word “position:” 

this_comp

4 The element “this_comp” is a global attribute whose value is a Comp object repre-
senting the current composition.

5 To determine what can follow “this_comp” in your expression, look up the return value 
for “this_comp” under “Global attributes and methods” on page 255. 

6 Note that “this_comp” returns a Comp. Next, look at the “Comp attributes and 
methods” on page 258 to see what you can use with a Comp. One option is “layer(index)”. 
The index, or number, inside the parentheses specifies the layer that you want to use. To 
retrieve values from the second layer in the active composition, type the following:

this_comp.layer(2)

7 Again, look at the expression language guide to determine that “layer(index)” returns a 
Layer. Look at “Layer attributes and methods” on page 259, and find the element you want 
to use. For example, if you want to access the Position property values for the layer, type 
the following:

this_comp.layer(2).position 

8 From “Layer attributes and methods” on page 259, determine that the position 
attribute returns a Property. Look up “Property attributes and methods” on page 262 and 
notice that you can add a time factor to the expression. To add a specific time, such as 
current time minus 2 seconds, type the following:

this_comp.layer(2).position.value_at_time(time-2)

9 From “Property attributes and methods” on page 262, notice that the time factor 
“value_at_time(time)” returns a Number. When an element returns a Number, Array, or 
Boolean (such as true or false), you cannot add other attributes or methods to the 
expression (if you want, however, you can add operators such as +, -, *, or /).
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10 Click outside of the expression to activate it.

Expression values
The value of an expression is the value of the last statement evaluated. For example, in the 
following expressions the results are the same: 

x = rotation * 10; [x, 20]

[rotation * 10, 20] 

Expression time
Time within an expression is always measured in seconds. The default time for any 
expression is the current composition time at which the expression is being evaluated. The 
following expressions both use the default composition time and return the same values: 

this_comp.layer(1).position

this_comp.layer(1).position.value_at_time(time)

To use a relative time, add a time value to the “(time)” argument. For example, to get a 
value at a time 5 seconds before the current time, use the following expression:

this_comp.layer(1).position.value_at_time(time-5)

Expression time in nested comps
Default time references to properties in nested compositions use the original default 
composition time, not remapped time. However, if you use the “source” function to 
retrieve a property, the remapped time is used. 

For example, if the source of a layer in the parent composition is a nested composition, 
and in the parent composition you have remapped time, when you access the position 
values of a layer in the nested composition with the following expression, the position 
values use the composition’s default time:

comp("nested comp").layer(1).position

However, if you access layer 1 using the “source” function, the position values use the 
remapped time:

source.layer(1).position

Note: If you use a specific time in an expression, After Effects ignores the remapped time. 

Numbers and arrays
Arrays represent multidimensional values in expressions. The value of each property in an 
expression is a single number or Boolean value for values such as opacity, or an array for 
2D, 3D, or 4D values such as position or “bg_color”. Many properties in After Effects, such as 
position, scale, and color, have more than one value parameter and thus are represented 
by different dimensions of arrays. For example, position is represented as a 2D or 3D array 
because the Position property can have 2 [x, y], or 3 [x, y, z] parameter values. Colors are 
represented as 4D arrays, [r, g, b, a]. Values in a color array range from 0 (black) to 1 (white). 

Note: The members of an array are always separated by commas. For example, the 
expression [10, 20] sets the property’s x value to 10 and y value to 20.

Indexing vectors and arrays
Indexing is a way of retrieving values in vectors and arrays. Vector and array indexing starts 
from 0—for example:
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• Position[0] is the x coordinate of position

• Position[1] is the y coordinate of position

• Position[2] is the z coordinate of position

The After Effects-specific elements Layer, Effect, and Mask use an indexing process that 
starts from 1. For example, the first layer in the Timeline window is as follows:

layer(1)

Generally, it’s best to use the name of a layer, effect, or a mask instead of a number to avoid 
confusion and errors if the layer, effect, or mask is moved. When you use a name, always 
enclose it in straight quotes. For example, the first expression below is easier to under-
stand than the second expression, and it will still work if you change the order of effects:

effect("Colorama").param("Get Phase From")

effect(1).param(5)

Accessing specific values in a vector or array
You can create an expression that references just one value within the array of a 2D or 3D 
property. By default, the first value is used, unless you specify otherwise. For example, if 
you drag the pick whip from layer 1’s Rotation property to layer 2’s Scale property, the 
following expression appears:

this_comp.layer(2).scale[0]

By default, the above expression uses the first value of the Scale property, which is width. 
If you prefer to use the height value instead, drag the pick whip directly to the second 
value instead of the property name, or change the expression as follows:

this_comp.layer(2).scale[1]

Conversely, if you drag the pick whip from layer 2’s Scale property to layer 1’s Rotation 
property, After Effects automatically duplicates the expression so that two values are 
available for the scale. The following expression appears:

[this_comp.layer(1).rotation, this_comp.layer(1).rotation]

To use a different value as one of the value parameters instead of doubling the one 
rotation value, remove the duplicate expression and insert a value. For example, to use the 
rotation value for the scale’s height and 10 for the width, use the following expression: 

[this_comp.layer(1).rotation, 10]

Using the expression language menu
The expression language menu contains all the After Effects–specific language elements 
that you can use in an expression. This menu is helpful for determining valid elements and 
their correct syntax; use it as a reference for available elements. 

Select any object, attribute, or method, and After Effects automatically inserts it in the 
expression field at the location of the cursor. Then, edit and add to it as needed. For 
example, if you want to begin an expression with the comp as the object, select 
“this_comp” from the Global menu: 

this_comp

To continue the expression, add a period (.) to the end and then choose an attribute from 
the Comp menu, such as “layer”:



Using Help | Contents | Index Back 253  

Adobe After Effects Help Creating Expressions 

Using Help | Contents | Index Back 253  

this_comp.layer(

Insert the specific layer information you want, such as:

this_comp.layer(1)

Next, choose an attribute or method from the Layer, Light, or Camera menu. For example, 
if layer 1 has Position keyframes, choose “position,” and so on.

this_comp.layer(1).position

To insert expression language elements:

1 Select language elements from the Expression language menu. The element appears in 
the expression field at the location of the cursor.

2 Edit and add to the inserted elements, as needed.

Sample expressions
Use the following expressions in your own projects by setting up similar layer properties 
as those described and then adding the expression.

Averaging one layer between two others
This expression positions and maintains one layer at a balanced distance between two 
other layers. To achieve this effect, you need three layers in your composition.

To average one layer between two others:

1 Start with three layers. 

2 Create motion paths for the first two layers in the Timeline.

3 Select the Position property for the third layer and choose Animation > Add Expression.

4 Select the default expression text and type the following:

mul(.5, add(this_comp.layer(1).position, 
this_comp.layer(2).position))

5 Click outside the expression to activate it.

Creating a trail of images
This expression instructs a layer to be at the same position as the next higher layer in the 
Timeline window, but delayed by a specified amount of time (in this case, .5 seconds). You 
can set similar expressions for the other geometric properties. This expression requires 
two or more layers. 

To create a trail of images:

1 Start with two solids that are scaled to about 30%.

2 Create a motion path for the first layer.

3 Select the Position property for the second layer and choose Animation > Add 
Expression.

4 Select the default expression text and type:

this_comp.layer(this_layer, -1).position.value_at_time(time - .5)

5 Duplicate the last layer five times. 
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6 Click outside the expression to activate it. All layers follow the same path, and each is 
delayed .5 seconds from the previous.

Creating a bulge between two layers
Use an expression to synchronize the Bulge Center parameter of the Bulge effect in one 
layer with the position of another layer. For example, move a magnifying glass over a layer 
and make the contents under the magnifying glass bulge as the glass (or the underlying 
layer) moves. This expression uses the “from_world” element, which makes the expression 
work correctly regardless of whether you move the magnifying glass layer or the under-
lying layer. You can rotate or scale the underlying layer and the expression stays intact.

You can also use other effects, such as Ripple, with this expression. 

To create a bulge between two layers:

1 Start with two layers. Make one layer a magnifying glass or similar object with a hole in 
the middle and name it Magnifier.

2 Create a motion path for the magnifying glass layer.

3 Apply the Bulge effect to the other, underlying layer. 

4 Select the Bulge effect’s Bulge Center property in the Timeline window and choose 
Animation > Add Expression.

5 Select the default expression text and type the following:

from_world(this_comp.layer("Magnifier").position)

6 Click outside the expression to activate it.

Moving a layer in a perfect circle
You can create an expression without using properties from other layers. For example, you 
can make a layer revolve in a perfect circle or move back and forth diagonally.

To create a circular movement in one layer:

1 Start one layer. 

2 Select the Position property for the layer and choose Animation > Add Expression.

3 Select the default expression text and type:

add([this_comp.width/2, this_comp.height/2],

[Math.sin(time)*50, -Math.cos(time)*50]) 

4 Click outside the expression to activate it.

After Effects expression language guide
Use the elements in the following sections, along with standard JavaScript elements to 
write your expressions. Remember that you can also use the Expression Language menu 
at any time to insert functions into an expression. 

See “Accessing elements in an expression” on page 250 for procedures on using this 
guide.

Expression language guide key
Use the following key when referencing the expression language guide:
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• Headings represent expression objects. All elements listed below a heading are 
attributes (that you can retrieve from the object) or methods (that you can call on the 
object). Many of the attributes and methods return other objects—look up those 
object types in this guide to determine how to continue your expression.

• Italic text at the beginning of a description represents the return value type. Some 
return values include a number in square brackets—this number specifies the 
dimension of the returned property or array. If a specific dimension is not included, the 
dimension of the returned array depends on the dimension of the input.

• Bold text represents the expression language element to type in your expression.

• (Bold Italic) text inside parentheses represents the argument(s), which is the type of 
information that you need to add inside the parentheses. If an argument contains an 
equal sign (=) and a value (such as t=time or width =.2), the argument uses the included 
default value if you don’t specify a different value. 

• {Italic and Roman} text inside curly brackets represents the argument description. Some 
argument descriptions include a number in square brackets—this number indicates 
the dimension of the expected property or array. If a specific dimension is not included, 
any dimension will work.

• Roman text is a description and possibly an example of the element.

Global attributes and methods
Only a global attribute or method, or a constant value, can appear in an expression with 
nothing to the left of it.

Global objects
Layer, Light, or Camera this_layer Represents the Layer itself. Because “this_layer” is the 
default object, its use is optional. For example, you can start an expression with 
“this_layer.width” or “width” and get the same result.

Comp this_comp Represents the composition containing the expression. For example, 
you can start an expression with “this_comp.layer(2)”.

Number time Represents the composition time, in seconds, at which the expression is 
being evaluated. See “Expression time” on page 251. 

Number value Represents the value at the current time for the property containing the 
expression. For example, you can include “value + 5” in an expression.

Comp comp(name) Retrieves another composition by name.

Footage footage(name) Retrieves a footage item by name.

Vector math methods
These are global methods that perform operations on arrays, treating them as mathe-
matical vectors. Unlike built-in JavaScript methods, such as Math.sin(), you do not use the 
Math prefix with these methods. Unless otherwise specified, vector math methods are 
lenient about dimensions and return a value that is the dimension of the largest array, 
filling in missing elements with zeros. For example, the expression “add([10, 20], [1, 2, 3])” 
returns [11, 22, 3].

Array add(v1, v2) {v1 and v2 are arrays} Adds two vectors, componentwise.

Array sub(v1, v2) {v1 and v2 are arrays} Subtracts two vectors, componentwise.
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Array mul(v1, amount) {v1 is an array, amount is a number} Multiplies every element of 
the vector by the amount.

Array div(v1, amount) {v1 is an array, amount is a number} Divides every element of the 
vector by the amount.

Number length(v) {v is an array} Returns the length of vector v.

Number length(p1, p2) {p1 and p2 are arrays} Returns the distance between two points. P2 
is optional. For example, “length(p1, p2)” is the same as “length(sub(p1, p2))”.

Array normalize(v) {v is an array} Normalizes the vector so that its length is 1.0. This is a 
short way of writing “div(v, length(v))”.

Array [2 or 3] cross(v1, v2) {v1 and v2 are arrays [2 or 3]} Returns a vector cross-product. 
Refer to a math reference guide or JavaScript guide for more information.

Number dot(v1, v2) {v1 and v2 are arrays} Returns a dot product, which is the result of 
multiplying the two vectors together componentwise.

Array [3] look_at(from_pt, at_pt) {from_pt and at_pt are arrays [3]} From_pt is the location 
in world space of the layer you want to orient. At_pt is the point in world space you want 
to point the layer at. The return value can be used as an expression for the Orientation 
property, making the layer’s z-axis point at at_pt. It is especially useful for cameras and 
lights. For example, “look_at(position, this_comp.layer(1).position)”. If you use this on a 
camera, turn off auto-orientation. 

Random number methods
Number random() The resulting value is a random number between 0 and 1.

Number random(max) {max is a number} The resulting value is a number between 0 and 
max, and is the same dimension as max.

Number random(min, max) {min and max are numbers} The resulting value is a number 
between min and max. 

Array random(max_arr) {max_arr is an array} The resulting value is an array with the same 
dimension as max_arr, with each component ranging between 0 and max_arr.

Array random(min_arr, max_arr) {min_arr and max_arr are arrays} The resulting value is 
an array with the same dimension as min_arr and max_arr, with each component ranging 
between min_arr and max_arr. For example, the expression “random([100, 200], [300, 
400])” returns an array whose first value is between 100 and 300, and whose second value 
is between 200 and 400. If the two input dimensions don’t match, the shorter one is filled 
out with zeros.

Number gauss_random() The resulting value is a random number between 0 and 1. The 
results have a bell-shaped distribution. About 90% of the results are between 0 and 1, and 
the remaining 10% are beyond the edges.

Number gauss_random(max) {max is a number} The resulting value is a random number 
between 0 and max. The results have a bell-shaped distribution. About 90% of the results 
are in the 0 to max range, and the remaining 10% are beyond the edges.

Number gauss_random(min, max) {min and max are numbers} The resulting value is a 
random number between min and max. The results have a bell-shaped distribution. About 
90% of the results are in the min to max range, and the remaining 10% are beyond the 
edges.



Using Help | Contents | Index Back 257  

Adobe After Effects Help Creating Expressions 

Using Help | Contents | Index Back 257  

Array gauss_random(max_arr) {max_arr is an array} The resulting value is an array with 
the same dimension as max_arr, with 90% of the results ranging between 0 and max_arr 
and the remaining 10% beyond the edges. The results have a bell-shaped distribution.

Array gauss_random(min_arr, max_arr) {min_arr and max_arr are numbers} The 
resulting value is an array with the same dimension as max_arr, with each component 
ranging between min_arr and max_arr. The results have a bell-shaped distribution. About 
90% of the results are in the min_arr to max_arr range, and the remaining 10% are beyond 
the edges.

Nothing seed_random(n) {n is a number} This expression takes the existing seed and 
increments it by the argument. Use it when you don’t like the results you get from random 
or gauss_random. For example, “seed_random(3); random(10,20)”.

Number noise(val) {val is a number or an array [2 or 3]} This returns a number between 0 
and 1. Noise is not actually random, but is used when you want a seemingly random 
number with some correlation between nearby samples. It is based on Perlin Noise (see a 
computer graphics reference book for more information). For example, “add(position, 
[noise(position)*50])”.

Interpolation methods
Number or Array linear(t, val1, val2) {t is a number, and val1 and val2 are numbers or 
arrays} The resulting value linearly interpolates from val1 to val2 as t ranges from 0 to 1. 
When t is l <= 0, the result is val1, and when t is >= 1, it is val2.

Number or Array linear(t, tmin, tmax, val1, val2) {t, tmin, and tmax are numbers, and val1 
and val2 are numbers or arrays} When t <= tmin, the output is val1. When t >= tmax, the 
output is val2. While tmin < t < tmax, the resulting output is a linear combination of val1 
and val2.

Number or Array ease(t, val1, val2) {t is a number, and val1 and val2 are numbers or arrays} 
Similar to linear, except that the interpolation eases in and out so that the velocity is 0 at 
the start and end points. This method results in a very smooth animation.

Number or Array ease(t, tmin, tmax, val1, val2) {t, tmin, and tmax are numbers, and val1 
and val2 are numbers or arrays} Similar to linear, except that the interpolation eases in and 
out so that the velocity is 0 at the start and end points. This method results in a very 
smooth animation.

Number or Array ease_in(t, val1, val2) {t is a number, and val1 and val2 are numbers or 
arrays} Similar to ease, except that the tangent is 0 only on the val1 side and is linear on the 
val2 side.

Number or Array ease_in(t, tmin, tmax, val1, val2) {t, tmin, and tmax are numbers, and 
val1 and val2 are numbers or arrays} Similar to ease, except that the tangent is 0 only on 
the tmin side and is linear on the tmax side.

Number or Array ease_out(t, val1, val2) {t is a number, and val1 and val2 are numbers or 
arrays} Similar to ease, except that the tangent is 0 only on the val2 side and is linear on the 
val1 side.

Number or Array ease_out(t, tmin, tmax, val1, val2) {t, tmin, and tmax are numbers, and 
val1 and val2 are numbers or arrays} Similar to ease, except that the tangent is 0 only on 
the tmax side and is linear on the tmin side.
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Color conversion methods
Array [4] rgb_to_hsl(rgba) {rgba is an array [4]} Converts a color in RGBA space to HSLA 
space. The input is an array specifying red, green, blue, and alpha, all in the range of 0.0 to 
1.0. The resulting value is an array specifying hue, saturation, lightness, and alpha, also in 
the range of 0.0 to 1.0. For example, “rgb_to_hsl(effect("Change Color").param("Color To 
Change"))”.

Array [4] hsl_to_rgb(hsla) {hsla is an array [4]}. This is the opposite of rgb_to_hsl. 

Comp attributes and methods
Camera active_camera Use this to retrieve a value from the camera through which the 
composition is rendered at the current frame. This is not necessarily the camera through 
which you are looking in the Composition window.

Number width Returns the composition’s width value in pixels.

Number height Returns the composition’s height value in pixels.

Number duration Returns the composition’s duration value in seconds. 

Number frame_duration Returns the frame duration in seconds.

Array [4] bg_color Returns the background color of the composition.

Number shutter_angle Returns the shutter-angle value of the composition in degrees.

Number shutter_phase Returns the shutter-phase of the composition in degrees.

Number num_layers Returns the number of layers in the composition.

Number pixel_aspect Returns the pixel aspect ratio of the composition expressed as 
width/height. 

Layer, Light, or Camera layer(index) {index is a number} Retrieves the layer by number 
(order in the Timeline window). For example, “this_comp.layer(3)”.

Layer, Light, or Camera layer(“name”) {name is a string} Retrieves the layer by name. 
Names are matched by layer name, or source name if there is no layer name. If duplicate 
names exist, After Effects uses the first one in the Timeline window. For example, 
“this_comp.layer("Solid 1")”.

Layer, Light, or Camera layer(other_layer, rel_index) {other_layer is a layer object, and 
rel_index is a number} Retrieves the layer that is the rel_index (number) of layers above or 
below the other_layer (name). For example, “layer(this_layer, -2)” returns the layer that is 
two layers higher in the Timeline window than the layer on which the expression is 
written.

Footage attributes and methods
To use footage from the Project window as an object in an expression, use the global 
footage() method, as in “footage("filename")” and then use any of the attributes below. 
You can also access a footage object using the source attribute on a layer whose source is 
a footage item.

Number width Returns the width of the footage in pixels.

Number height Returns the height of the footage in pixels.

Number duration Returns the duration of the footage in seconds.

Number frame_duration Returns the duration of a frame in seconds.



Using Help | Contents | Index Back 259  

Adobe After Effects Help Creating Expressions 

Using Help | Contents | Index Back 259  

Number pixel_aspect Returns the pixel aspect ratio of the footage, expressed as width/
height.

Layer attributes and methods
Number width Returns the width of the layer in pixels. It is the same as “source.width”.

Number height Returns the height of the layer in pixels. It is the same as “source.height”. 

Number start_time Returns the start time of the layer in seconds.

Number in_point Returns the In point of the layer in seconds.

Number out_point Returns the Out point of the layer in seconds.

Boolean has_video Returns a true value if the layer has video, or a false if it doesn’t.

Boolean has_audio Returns a true value if the layer has audio, or a false if it doesn’t.

Boolean active Returns a true value (1) if the layer’s video switch ( )is on, or a false (0) if it 
isn’t.

Boolean audio_active Returns a true value (1) if the layer’s audio switch ( ) is on, or a false 
(0) if it isn’t.

Number index Returns the Number of the layer in the composition.

Layer, Light, or Camera parent Returns the parent Layer object of the layer, if there is one. 
For example, “position[0] + parent.width”.

Property [2 or 3] anchor_point Returns the Anchor Point value of the layer in the layer’s 
space.

Property [2 or 3] scale Returns the Scale value of the layer, expressed as a percentage.

Property [2 or 3] position Returns the Position value of the layer, in world space if the layer 
has no parent, or in the parent’s layer space if there is a parent.

Property rotation Returns the Rotation value of the layer in degrees. For a 3D layer, it 
returns the Z rotation value in degrees.

Property [1] rotationX Returns the X Rotation value in degrees for a 3D layer.

Property [1] rotationY Returns the Y Rotation value in degrees for a 3D layer.

Property [1] rotationZ Returns the Z Rotation value in degrees for a 3D layer.

Property [3] orientation Returns the 3D Orientation value in degrees for a 3D layer.

Property [1] opacity Returns the Opacity value for the layer, expressed as a percentage.

Property [2] audio_levels Returns the Audio Level of the layer, in decibels. This is a 2D 
value; the first value represents the left audio channel, and the second value represents 
the right. The value is not the amplitude of the source material’s audio track; instead, it is 
the value of the keyframed Audio Levels property.

Property time_remap Returns the value of the Time Remap property in seconds, if Time 
Remap is enabled.

Comp or Footage source Returns the source Comp or source Footage object for the layer. 
Default time is adjusted to the time in the source. For example, “source.layer(1).position”.

Mask mask(index) {index is a number} Returns a layer Mask object. After Effects finds the 
mask by its index in the Timeline window, starting at 1 and counting down from the top.
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Mask mask(name) {name is a string} Returns a layer Mask object. The name can be the 
default name or a user-defined name.

Effect effect(index) {index is a number} Returns an Effect object. After Effects finds the 
effect by its index in the Effect Controls window, starting at 1 and counting down from the 
top.

Effect effect(name) {name is a string} Returns an Effect object. After Effects finds the effect 
by its name in the Effect Controls window. The name can be the default name or a user-
defined name. If there is more than one effect with the same name, the effect closest to 
the top of the Effect Controls window is used.

Material properties for 3D layers
Property casts_shadows If the layer casts shadows, the returned value is 1.0.

Property accepts_shadows If the layer accepts shadows, the returned value is 1.0.

Property accepts_lights If the layer accepts lights, the returned value is 1.0.

Property ambient Returns the ambient component value as a percentage.

Property diffuse Returns the diffuse component value as a percentage.

Property specular Returns the specular component value as a percentage.

Property shininess Returns the shininess component value as a percentage.

Layer space transform methods
The “from_” methods transform values from the layer’s space to the named space (comp or 
world). The “to_” methods transform values from the named space (comp or world) to the 
layer space. 

Use the _vec methods when transforming a direction vector, such as the difference 
between two positions. Use the plain (non-vec) methods when transforming a point, such 
as position. 

Comp and world space are the same for 2D layers. For 3D layers, however, comp space is 
relative to the active camera, and world space is independent of the camera. 

Each of these methods takes an optional parameter to determine the time at which the 
layer’s transform is computed; however, you can almost always use the current (default) 
time. 

Array [2 or 3] to_comp(point, t = time) {point is an array [2 or 3], and t is a number} Trans-
forms a point from layer space to comp space. For example, “to_comp(anchor_point)”.

Array [2 or 3] from_comp (point, t=time) {point is an array [2 or 3], and t is a number} Trans-
forms a point from comp space to layer space. The resulting point in a 3D layer may have a 
nonzero value even though it is in layer space. For example (2D layer), 
“from_comp(this_comp.layer(2).position)”.

Array [2 or 3] to_world(point, t=time) {point is an array [2 or 3], and t is a number} Trans-
forms a point from layer space to view-independent world space. For example, 
“to_world(effect("Bulge").param("Bulge Center")”.

Array [2 or 3] from_world(point, t=time) {point is an array [2 or 3], and t is a number} Trans-
forms a point from world space to layer space. For example, 
“from_world(this_comp.layer(2).position)”.
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Array [2 or 3] to_comp_vec(point, t=time) {point is an array[2 or 3], and t is a number} 
Transforms a vector from layer space to comp space. For example, “to_comp_vec([1, 0])”.

Array [2 or 3] from_comp_vec(point, t=time) {point is an array[2 or 3], and t is a number} 
Transforms a vector from comp space to layer space. For example (2D layer), 
“dir=sub(position, this_comp.layer(2).position); from_comp_vec(dir)”.

Array [2 or 3] to_world_vec(point, t=time) {point is an array[2 or 3], and t is a number} 
Transforms a vector from layer space to world space. For example, “p1 = effect("Eye Bulge 
1").param("Bulge Center"); p2 = effect("Eye Bulge 2").param("Bulge Center"); 
to_world(sub(p1, p2))”.

Array [2 or 3] from_world_vec(point, t=time) {point is an array [2 or 3], and t is a number} 
Transforms a vector from world space to layer space. For example, 
“from_world(this_comp.layer(2).position)”.

Array [2] from_comp_to_surface(point, t=time) {point is an array [2 or 3], and t is a 
number} Use with 3D layers only. Projects a point located in comp space to a point on the 
surface of the layer (zero z-value) at the location where it appears when viewed from the 
active camera. This is useful for setting effect control points. 

Camera attributes and methods
Camera objects have all of the same attributes and methods as Layer objects, except for 
source, effect, mask, width, height, anchor_point, scale, opacity, audio_levels, time_remap, 
and all of the material properties. In addition, Cameras have the following:

Property [3] point_of_interest Returns the camera’s Point of Interest values in world space.

Property zoom Returns the camera’s Zoom values in pixels.

Property depth_of_field Returns a 1 if the camera’s Depth of Field property is on, or 
returns a 0 if it is off.

Property focus_distance Returns the camera’s Focus Distance values in pixels.

Property aperture Returns the camera’s Aperture value in pixels.

Property blur_level Returns the camera’s Blur Level value as a percentage.

Boolean active Returns a true value if the camera’s video switch ( )is on, the current time 
is between the camera’s In and Out points, and it is the first such camera listed in the 
Timeline window. Returns a false value if the above conditions are not met.

Light attributes and methods
Light objects have all of the same attributes and methods as Layer objects, except for 
source, effect, mask, width, height, anchor_point, scale, opacity, audio_levels, time_remap, 
and all of the material properties. In addition, Lights have the following:

Property [3] point_of_interest Returns the light’s Point of Interest values in work space. 

Property intensity Returns the light’s Intensity values as a percentage.

Property [4] color Returns the light’s Color value.

Property cone_angle Returns the light’s Cone Angle value in degrees.

Property cone_feather Returns the light’s Cone Feather value as a percentage.

Property shadow_darkness Returns the light’s Shadow Darkness value as a percentage.

Property shadow_diffusion Returns the light’s Shadow Diffusion value in pixels.
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Effect attributes and methods
Boolean active Returns a true value if the effect is turned on, or a false value if it is off.

Property param(name) {name is a string} Returns a property within an effect. For example, 
“effect("Bulge").param("Bulge Height")”. Effect point controls are always in layer space.

Property param(index) {index is a number} Returns a property within an effect. After 
Effects finds the effect by its index in the Effect Controls window, starting at 1 and 
counting down from the top. This form is not recommended because indexes are not 
always in contiguous order in the Effect Controls window. If an effect parameter doesn’t 
have a name, use the pick whip to select it. 

Mask attributes and methods
You cannot access the mask shape when using expressions.

Property opacity Returns the mask’s Opacity value as a percentage.

Property feather Returns the mask’s Feather value in pixels.

Property expansion Returns the mask’s Expansion value in pixels.

Boolean invert Returns a true value if the mask is inverted, or a false if it is not. 

Property attributes and methods
Number or Array value Returns the property’s value at the current time. 

Number or Array value_at_time(t) {t is a number} Returns the property’s value at the 
specified time in seconds.

Number or Array velocity Returns the temporal velocity value at the current time. For 
spatial properties, such as position, it returns the tangent vector value. The result is the 
same dimension as the property. 

Number or Array velocity_at_time(t) {t is a number} Returns the temporal velocity value at 
the specified time. 

Number speed Returns a 1D, positive speed value equal to the speed at which the 
property is changing at the default time. This element can be used only for spatial 
properties. 

Number speed_at_time(t) {t is a number} Returns the spatial speed value at the specified 
time.

Number or Array smooth(width=.2, samples=5, t=time) {width, samples, and t are 
numbers} Applies a box filter to the value of the property at the specified time, and 
smooths the result over time. Width (in seconds) is the range of time over which the filter is 
averaged. Samples equals the number of discrete samples evenly spaced over time. 
Generally, you’ll want samples to be an odd number so that the value at the current time is 
included in the average. For example, “position.smooth(.1, 5)”.

Number or Array temporal_wiggle(freq, amp, octaves=1, amp_mult=.5, t=time) {freq, 
amp, octaves, amp_mult, and t are numbers} Samples the property at a wiggled time. Freq 
is calculated in wiggles per second, amp is calculated in units of the property to which it is 
applied, octaves is the number of octaves of noise to add together, amp_mult is the 
amount that amp is multiplied by for each octave, and t is the base start time. For this 
function to be meaningful, the property it samples must be animated, because the 
function alters only the time of sampling, not the value. For example, 
“scale.temporal_wiggle(5, .2)”.
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Number or Array wiggle(freq, amp, octaves=1, amp_mult=.5, t=time) {freq, amp, octaves, 
amp_mult, and t are numbers} Randomly shakes (wiggles) the value of the property. Freq is 
calculated in wiggles per second, amp is calculated in units of the property to which it is 
applied, octaves is the number of octaves of noise to add together, amp_mult is the 
amount that amp is multiplied by for each octave, and t is the base start time. For example, 
“position.wiggle(7, 30, 3)”.
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Managing Projects Effectively

Visualizing organization with Flowchart View
After Effects provides a separate Flowchart View for each composition and for the overall 
project to help you keep a “big picture” perspective on complex projects. In Flowchart 
View, individual boxes (or tiles) represent each composition, layer, and footage item, 
including any applied effects. Directional arrows represent the relationships between 
components. 

Note: Flowchart View only shows you the existing relationships. You cannot use this view 
to change relationships between project elements.

The elements included in Flowchart View depend on what is selected and on whether the 
compositions are nested (used inside another composition as a layer) or root compositions 
(not nested). In Flowchart View of a project, all root compositions appear. Nested composi-
tions and other elements that make up the composition appear when you expand a 
composition tile. 

The expansion button [+] for a composition in Flowchart View 
reveals any nested compositions, source footage, and applied effects.

To open Flowchart Views: 

Do one of the following:

• To open Flowchart View for a project, choose Window > Project Flowchart View.

• To open Flowchart View for a composition, select the composition in the Project 
window, and choose Composition > Comp Flowchart View.

When you click a tile in Flowchart View, that element becomes active (selected) in the 
Project window. If the tile represents a layer, that layer also becomes active in the Timeline 
window.

Note: Gray lines between tiles in Flowchart View indicate that the Video or Audio switch 
for those items are turned off in the Timeline window. Black lines indicate the switch is 
turned on.
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Customizing Flowchart View
You can customize Flowchart View using the Flowchart View menu. Specify the type of 
lines between elements (angled or straight), justification, what tiles appear (layers with or 
without showing effects), and flow direction. The menu also includes a Cleanup command 
to reorganize elements in aligned flowcharts. 

You can also use the four buttons along the bottom of the Flowchart View window, which 
are shortcuts for many of these menu commands. The Show Effects button ( ) is unique 
because it also serves as a slider for the justification commands. Use the slider by holding 
down Alt (Windows) or Option (Mac OS) as you drag the slider.

For keyboard shortcuts for these and other procedures, see the After Effects 5.0 Quick 
Reference Card. For tool tips identifying the buttons in the Flowchart View window, 

let your pointer hover over a button until the tool tip appears.

You can change the tile label colors in Flowchart View using a context menu.

To change label colors in Flowchart View:

1 Select the tile you want to change to a different color.

2 Right-click (Windows) or Control+click (Mac OS) the name section of the tile, and 
choose the color (or None) you want to apply.

To apply the new color to all elements in that label group, choose Select Label Group 
from the context menu to select all those items before you do step 2.

Using Flowchart View to make changes
You can make some changes to your project from within the Flowchart View window. 
You can delete elements by selecting them and pressing Delete. If the selected element is 
a footage item or composition, it is deleted from the project and no longer appears in the 
Timeline and Project windows. If the selected element is a layer, it is deleted from the 
composition in which it appears.

You can change other properties of a selected element by right-clicking (Windows) or 
Control-clicking (Mac OS) the icon to the left of the name in the element tile. The icons 
have various appearances, depending on the element type, such as layers ( ), composi-
tions ( ), audio footage ( ), and so forth. For example, you can use the icon context 
menu to work with masks and effects or to change switches, apply transformations, and 
adjust quality.

Note: When you change element properties in Flowchart View, be careful to click the icon 
in the tile, not the name of the element. The context menu associated with the element 
icon is different from the one that opens from the element name.

Organizing a project using nesting 
When you nest compositions, you organize your project into a hierarchy. In its simplest 
form, nesting means that you combine two or more compositions into one main compo-
sition from which you render the final movie. A composition inside another composition 
becomes a layer within the parent composition.

Use composition nesting to save time working and rendering. With composition nesting, 
you can do the following:
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• Apply complex changes to an entire composition. For example, you can create a 
composition containing multiple still images, nest the composition within the overall 
composition, and animate the nested composition so that all the still images change in 
the same ways over the same time period.

• Reuse anything you build. For example, you can build an animation in its own compo-
sition and then drag that composition into other compositions as many times as you 
want. This can save large amounts of space, especially for complicated effects, such as 
3D layers.

• Update many composition copies in one step by editing the original animated compo-
sition. 

• Alter the default rendering order of a layer. For example, you can render a transform 
change (such as rotation) before rendering effects.

Note: Parenting is another way to apply complex changes to an entire composition. For 
information, see “Understanding parent layers” on page 113.

Understanding default rendering order
The order in which After Effects renders the various parts of a composition can affect the 
look of some visual effects in a rendered movie. An understanding of how After Effects 
renders a composition will help you get the effects you want.

In rendering a composition, After Effects processes 2D layers in the order in which they are 
listed in the Timeline window, starting at the bottom of the list. (However, After Effects 
processes 3D layers in Z order within their 3D bins. For more information, see “3D 
rendering” on page 242.) In processing each layer, After Effects processes changes from 
the top down, as these three categories appear in the Timeline window: first the masks, 
then effects, and finally the transformations. The transfer modes and track mattes are 
processed after that. For elements with multiple effects, After Effects processes these in 
the order in which they are listed in the Effect Controls and the Timeline windows.

Changing the rendering order
Sometimes, projects require a visual effect that cannot be achieved using the default 
rendering order. For example, you may be constructing an animation in which you want a 
rotated object to have a drop shadow effect. By default, After Effects renders an effect 
before rotation, which would create shadows with different orientations. 

A. Original layer B. Drop shadow applied at effect stage C. Rotation applied at transform stage 
results in the shadow rotating with the layer 

A B C
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To render the animation so that the shadows appear as if created by a single light source, 
you need to apply rotation before you apply the drop shadow effect.

A. Original layer B. Rotation applied using the Transform effect C. Drop shadow applied at the 
effect stage results in a properly oriented shadow

Although you can’t instruct After Effects to change the order of processing within a layer, 
there are three ways to get the rendering order you want: applying the Transform effect, 
including an adjustment layer above the layer, or using nesting or precomposing. 

Note: You could also achieve this effect using 3D lights and shadows. See “Using lights” on 
page 239.

Transform effect Apply Transform effects (choose Effect > Perspective > Transform) 
when you want a transform property to render before another effect. (See “Transform” on 
page 197.) These transform changes will be rendered before subsequent effects. Other 
transform properties, set in the Timeline window, will be rendered last. 

Adjustment layer Use an adjustment layer in your composition when you want to 
change rendering order and apply transform properties or effects to more than one layer 
at a time. When you apply an effect to an adjustment layer, After Effects renders the effect 
after rendering all properties in the other layers. See “Creating an adjustment layer” on 
page 73. 

To apply an adjustment layer to some (but not all) of the layers below it, you must either 
nest or precompose the adjustment layer with those layers.

Nesting or precomposing Use either nesting or precomposing to change the rendering 
order while also applying an effect to continuously rasterized or collapsed layers. Precom-
posing is a form of nesting and changes the rendering order in the same way. To make an 
effect render after a transform property, apply the effect to the nested composition 
instead of to the layer inside that composition. See “Organizing a project using nesting” 
on page 265 and “Understanding precomposing” on page 270. 

For more information about gathering project files in a special location for rendering or 
archiving, see the Watch folders section under “Collecting files in one location” on 
page 294 and “Rendering using a watch folder (PB only)” on page 296.

Creating animations by nesting compositions
Nesting is useful when you want to apply a single transform property to a layer in more 
than one way. It adds another opportunity to apply masks, effects, or transform changes. 

A B C
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To nest a composition:

Drag a composition icon from the Project window into another composition in the 
Timeline window.

Note: If the target composition is currently active in the Composition window, you can 
also drag the composition icon you want to nest directly into the Composition window.

For example, you could use nesting to make a head both rotate and revolve (moving like 
the Earth, which spins on its own axis and also travels around the sun). By nesting, you can 
apply rotation to the head in one composition and then move that composition into 
another composition containing the background. The head composition becomes a new 
layer in the composition containing the background. You can then apply rotation to this 
new layer to make it revolve around the circle.

Another way to configure this example would be to use parenting. For more information, 
see “Understanding parent layers” on page 113.

Synchronizing time displays of nested compositions
When you open windows associated with a composition, such as the Timeline, the Layer, 
and the Effect Controls windows, changing the current time in one window updates the 
other windows associated with that composition. However, changing the current time in 
one composition does not change the current time in windows belonging to other 
compositions, unless you are working with nested compositions.

You can synchronize the current-time markers in open windows belonging to a nested 
composition. After Effects provides a preference that updates all windows of nested 
compositions when you move the current-time marker in any nested composition.

To synchronize time displays in windows of nested compositions:

Choose Edit > Preferences > General, click the Synchronize Time of All Related Items 
option to add a checkmark, and click OK.

Maintaining image quality of nested compositions
There are two methods of calculating changes to transform properties (such as rotation or 
scaling) during rendering of a nested composition. The default method applies transform 
properties and rasterizes at every level of nested compositions. The alternative method, 
collapsing transformations, postpones the calculation of transform properties and raster-
ization of nested compositions until the rendering process reaches a layer you select. (You 
cannot collapse a layer’s transform properties if a mask or effect is applied to it.) You can 
increase image quality and significantly reduce rendering time by collapsing transforma-
tions. 

To collapse transformations of a nested composition:

In the Layer Feature panel of the Timeline window, click the Collapse Transformations 
switch icon next to the layer containing the nested composition.
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Collapsing transformations can preserve resolution when a nested composition is scaled 
down and then scaled back up in successive compositions. Without collapsed transforma-
tions, a nested composition that is scaled down loses the resolution of its original larger 
size. When you collapse transformations, the original resolution of a nested composition is 
preserved; its final resolution is determined by its size within the composition that uses 
collapsed transformations.

Default method When a nested composition is scaled down and then up again 
in successive compositions, it retains the lower resolution of the scaled-down version. 

Collapsed transformation When a nested composition is scaled down and then 
up again in successive compositions, it retains the resolution of the original layer.

When you collapse the transform properties of a layer, all compositions nested inside it 
combine their opacity setting with the opacity setting of the layer that uses collapsed 
transform properties.

Because you can collapse transformations but not mask or effect properties, After Effects 
automatically disables all composition and layer switches related to masks or effects when 
you collapse transformations. If you click a disabled layer switch, After Effects prompts you 
to turn off Collapse Transformations. You cannot turn on the Effect, Mask, Mask Feather, or 
Motion Blur layer properties or apply transfer controls to a layer in which you collapsed 
transform properties. You can still apply these properties to a composition nested within 
the composition with transform properties collapsed, as long as the Collapse Transforma-
tions switch is not turned on for that composition.

When a layer contains an Adobe Illustrator file instead of a nested composition, the 
Collapse Transformations switch for that layer becomes the Continuously Rasterize switch, 
which you can use to improve the image quality of footage. See “Importing an Adobe 
Illustrator, PDF, or EPS file” on page 35 and “Collapsing transformation properties” on 
page 87.

Collapsing transformations also adds some flexibility when you work with 3D layers in 
nested compositions. If you have a subordinate composition that has 3D objects within it 
without Collapse Transformations, After Effects renders the composition as a 2D image of 
the 3D arrangement in the higher composition. However, if you turn on Collapse Transfor-
mations, After Effects renders the 3D layers into the next higher composition so that they 
retain their 3D relationships among themselves and with other 3D layers in the higher 
composition. You can continue to manipulate the relative positions of the 3D layers from 
the lower composition as a group.
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Saving time by prerendering nested compositions
A complex nested composition can take a long time to preview and render. If you have a 
nested composition that you do not expect to work on any further, render the nested 
composition into a movie and use it as a proxy for the actual nested composition. As a 
rendered movie, it will require less calculation and time to display and render in the larger 
project. You can still make changes to the prerendered composition, because the original 
nested composition remains in the project list. If you make a significant change to the 
original nested composition, simply render it again. Prerendering a nested composition is 
particularly beneficial when you use a nested composition multiple times in a project.

Using a prerendered movie in place of a nested composition also saves time and memory 
when you render the final version of the main composition. Just be sure to apply your final 
output settings when you prerender the nested composition. For more information about 
rendering options, see “Changing render settings” on page 281.

There are three phases to prerendering a composition:

• Creating a composition. See “Creating a composition” on page 56.

• Rendering the composition you created. See “Understanding rendering and 
compression” on page 278.

• Creating a proxy using the rendered composition. See “Substituting a low-resolution 
proxy for footage” on page 54.

To edit a prerendered composition:

1 In the Project window, click the proxy indicator for the prerendered composition until it 
displays an empty box. This turns off the proxy so that After Effects uses the actual compo-
sition in the project.

2 In the Project window, double-click the composition from which the proxy movie was 
rendered.

3 Edit the composition.

4 Save the project.

5 Render the composition into a movie again, using the same filename as the previous 
version of the movie.

6 After rendering is complete, set up the movie as a proxy for the composition. The next 
time you view the composition containing the movie, the new movie is displayed.

Understanding precomposing
Sometimes it’s necessary to nest compositions after you have already created a complex 
project hierarchy. It can be tedious or difficult to use nesting in an existing composition. 

Precomposing is an easier way to nest layers within an existing composition. Precom-
posing moves the layers to a new composition. When you want to change the order in 
which layer components are rendered (see “Understanding default rendering order” on 
page 266), precomposing is a quick way to create intermediate levels of nesting in an 
existing hierarchy.
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When you precompose, one or more layers that you select move into a new composition. 
This new composition takes the place of the selected layers—something that does not 
occur in ordinary nesting. Precomposing also places the new composition in the Project 
window, available for use in any composition.

When you precompose only one layer, you can transfer the keyframes, masks, effects, and 
transform properties from the original layer to the new layer. You can also choose to keep 
the keyframes and properties with the original layer while it moves one rendering step 
further from the main composition. When you precompose more than one layer, the 
keyframes and properties stay with the original layers.

After Effects offers two options for working with layer properties and keyframes during 
precomposing:

Leave All Attributes In (selected composition) Leaves the selected layer properties and 
keyframes in the original composition. The frame size of the new composition is the same 
as that of the selected layer. Select this option when you do not need to change the 
rendering order, such as when you precompose layers only to simplify or reuse a compo-
sition, not to change the rendering order of layer properties. This option is not available 
when you select more than one layer.

Note: After you precompose using the Leave All Attributes In option, changes you applied 
to the properties of the original layer are still applied to that layer in the original compo-
sition. 

Move All Attributes into the New Composition Moves the properties and keyframes of 
one or more selected layers one level further from the main composition in the compo-
sition hierarchy. The frame size of the new composition is the same as that of the original 
composition. Choose this option when you want to change the rendering order in the 
selected layers, such as when you want to rotate a layer but not its drop shadow. See 
“Creating animations by nesting compositions” on page 267.

To precompose one or more layers:

1 In the Timeline window containing the layers you want to precompose, select the 
layers.

2 Choose Layer > Pre-compose.

3 Select a method for handling layer properties and keyframes (either Leave All 
Attributes In or Move All Attributes into the New Composition), and then click OK.

Reducing the project 
Use the Reduce Project command to automatically delete any items that are not used, 
either directly or indirectly, in selected compositions. For example, this command removes 
both unused footage items and all other compositions that are not included within a 
selected composition as nested (subordinate) compositions.

It’s useful to refer to Flowchart View when you select the compositions you want to 
keep. For information about opening Flowchart View, see “Visualizing organization 

with Flowchart View” on page 264.

Be aware of two special cases when you use Reduce Project:



Using Help | Contents | Index Back 272  

Adobe After Effects Help Managing Projects Effectively 

Using Help | Contents | Index Back 272  

• If the selected composition includes elements that are turned off (that is, the Video or 
Audio switch is deselected in the Timeline window), the Reduce Project command does 
not remove that switched-off item.

• If an expression in a selected composition refers to an element in a nonsubordinate 
composition, Reduce Project removes the nonsubordinate composition and the 
applied expression. The message that appears after you choose Reduce Project 
reminds you of this possibility, so you can undo the command if needed.

To avoid removing the expressions from a nonsubordinate composition, drag the 
nonsubordinate composition into the composition that refers to it. Then turn off the 

Audio and Video switches for the composition you added. 

To delete unused project elements:

1 In the Project window, select all the compositions you want to keep in the project.

2 Choose File > Reduce Project.

Note: The Reduce Project command is available only when the Project window is active.

Techniques for working efficiently
Projects you create using high resolution or many layers can take longer to work with 
because of long previewing times or complex navigation. After Effects provides many 
options and techniques for working faster and more efficiently.

In many cases you can work more quickly by displaying an appropriate level of detail for 
the layers you are working on. For example, imagine you are animating a frame containing 
a small moving layer in front of a larger layer. If you’re adjusting the motion of the small 
layer in relation to the large layer, you may need to see both layers. If you’re adjusting only 
the effect applied to the smaller layer, you can speed previewing by preventing a detailed 
display of the larger layer, displaying the layer at a lower resolution or as a wireframe, or 
turning off the display of the layer. As you work on other parts of the project, use the 
following techniques to speed screen updates on the area in which you are currently 
working.

Lower the composition’s resolution Displaying a composition at a lower resolution 
than is set in its Composition Settings dialog box speeds previewing, especially when you 
adjust the window size accordingly. See “Setting resolution” on page 59. 

Use folders in the Project window To make it easier to locate and move items, organize 
items by creating and using folders in the Project window. See “Working with the Project 
window” on page 15. Use the Find button ( ) at the bottom of the Project window to 
locate files and compositions by name.

Close unneeded windows and tabs Keep open only those windows and tabs that you 
need to see as you work. After Effects must spend time updating all Layer or Composition 
windows that are open, which takes time from the one or two windows that are most 
important. Tabs consume memory that could otherwise be used to speed up other opera-
tions. 

Substitute a proxy for a source item When working at full resolution, substitute a low-
resolution or still-image proxy for a layer to speed previewing and working. See “Substi-
tuting a low-resolution proxy for footage” on page 54.
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Lower a layer’s display quality Selecting Draft for a layer while working with it is often a 
good compromise in quality that will speed previewing. See “Changing the layer image 
quality” on page 88.

Hide layers When you don’t need to see one or more layers in the Timeline window, hide 
them or mark them as shy, which simplifies navigation. See “Showing and hiding layers in 
the Timeline window” on page 80.

Lock layers To avoid wasting time undoing accidental modifications, lock a layer when 
you want to see it but do not want to modify it. See “Locking and unlocking a layer” on 
page 81.

Prerender nested compositions Render a completed composition as a movie so that 
After Effects doesn’t use the time and memory required to calculate its changes every time 
it displays. See “Saving time by prerendering nested compositions” on page 270.

Collapse transformations of nested compositions In some cases, you can improve 
preview speed, rendering speed, and image quality by collapsing transformations of a 
layer containing nested compositions. See “Collapsing transformation properties” on 
page 87.

Deselect Continuously Rasterize for Illustrator files Deselect the Continuously 
Rasterize switch for an Adobe Illustrator file until you need to view or render it in detail. 
This prevents After Effects from rasterizing the entire file after each change, thus saving 
you time. See “Importing an Adobe Illustrator, PDF, or EPS file” on page 35, and “Collapsing 
transformation properties” on page 87.

Stop window updates Press the Caps Lock key to prevent After Effects from updating 
Footage, Layer, or Composition windows. This is useful for a Layer or Composition window 
that takes a long time to update. When Caps Lock is active, all open Footage, Layer, or 
Composition windows display the last update you made before pressing Caps Lock, 
regardless of the changes you make. As soon as you make a change that would appear in a 
window, After Effects adds a red outline to any affected windows, and the windows are 
not updated. After Effects continues to update window controls such as motion paths, 
anchor points, and mask outlines as you move them. To resume window updates and 
display all changes made while Caps Lock was active, press Caps Lock again to deactivate 
it.

Solo the layer you’re working on Isolate the layer by using the Solo switch. See “Soloing 
a layer” on page 81.

Use Draft 3D Use this option to prevent highlight and shadow calculations. See “Under-
standing 3D” on page 228.

Use Wireframe Interactions Use this previewing option to turn off updating, for faster 
interaction. To specify this, choose Edit > Preferences > Preview and use the pop-up menu 
to specify whether pressing the Alt (Windows) or Option (Mac OS) turns Wireframe Inter-
actions off or is required to turn it on. See also “Changing the layer image quality” on 
page 88.

Use rectangular masks When possible, use a rectangular mask, which renders faster 
than an oval or Bezier mask. The difference in speed is greatest when you set the layer 
display quality to Best, or when you feather the edge of the mask. For more information on 
creating and masks, see “Changing the shape of a mask” on page 155.
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Allocate more memory (Mac OS 9.x only) Rendering performance on a Mac OS 9.x 
system is significantly affected by the amount of RAM you allocate to After Effects. The 
more RAM you allocate, the faster it can render. See “Using RAM effectively” on page 274. 
To avoid unnecessary rendering, After Effects stores and reuses rendered layer compo-
nents in RAM. However, it can do this only if there is enough memory available to store the 
rendered components. 

In general, assign as much memory to After Effects as you can, up to 90% of the largest 
unused block. Leave the remaining 10% unused so that the system software has room to 
expand when additional system components are loaded.

To allocate more memory to After Effects (Mac OS):

1 Quit After Effects and all other applications.

2 In the Finder, choose About this Computer in the Apple menu.

3 Note the Largest Unused Block value, and then close the dialog box.

4 Click the After Effects application icon (not an alias) and choose File > Get Info > 
Memory.

5 In the After Effects Info dialog box for Memory, increase the Preferred Size value, but 
don’t exceed 90% of the Largest Unused Block value noted previously. Do not change the 
Minimum Size value.

6 Close the After Effects Info dialog box.

Using RAM effectively
Occasionally, After Effects may display an alert message indicating that it requires more 
memory to display or render a composition. To render more efficiently, it’s helpful to 
understand how After Effects uses memory and what parts of a composition may be 
increasing the memory load. Many variables, such as memory management controlled by 
QuickTime or other system software, make it impossible to predict the exact amount of 
memory required for displaying or rendering a particular layer. However, you can usually 
identify memory-intensive layers with enough certainty to get a composition to render.

When rendering a composition, the following factors determine memory requirements:

• The resolution of the composition frame. A higher resolution frame requires more 
memory.

• The memory requirement of the most memory-intensive layer in the composition.

• The size of the project file.

If you have no problems displaying every frame of a full-resolution, best-quality preview of 
a composition, then you have enough memory to render the composition. Rendering a 
composition into a movie takes somewhat less memory than displaying it on-screen.
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Setting image caching preferences
As you work on a composition, After Effects temporarily stores rendered composition and 
source images in RAM, so that previewing and editing can occur more quickly. For 
example, once you view a specific frame in a composition, that frame is stored in RAM until 
you run out of memory or until you edit the composition in some way that affects that 
frame. You can control how After Effects stores images in RAM by setting different image-
caching preferences. The controls available differ on Mac OS and Windows systems.

To specify image caching (Windows):

1 Choose Edit > Preferences > Cache.

2 For Image Cache Size, type a value to set the maximum amount of installed RAM to use 
for cached frames. The default value is 60%. Values over 90% are not recommended. 

3 For Maximum Memory Usage, type a value to set the maximum amount of memory to 
use for any purpose. You can specify values over 100% (where 100% equals the amount of 
physical RAM you have installed) because virtual memory uses hard-disk space. However, 
values over 200% are not recommended.

4 Click OK.

Note: The Image Cache Size setting directly affects the number of frames that you can 
play back in RAM preview. Increase the value to play back more frames. Decrease it if you 
notice that your RAM previews jerk and halt during playback. This jerky playback often 
occurs because of virtual memory paging activity, which is affected by the memory usage 
the other applications you have running.

To specify image caching (Mac OS):

1 Choose Edit > Preferences > Cache.

2 For Image Cache Size, type a value (as described in step 3 of the procedure for speci-
fying image caching on Windows, above in this topic).

3 For Mode, select one of the following options:

• Select Favor Memory to have After Effects rearrange the image cache and make it more 
compact as you work, ensuring the most memory-efficient rendering. This option 
favors memory over speed, and may noticeably slow down After Effects.

• Select Favor Speed to have After Effects rearrange the image cache only when it's 
almost out of memory. This option significantly speeds up the editing and rendering 
processes, but you may run out of memory sooner. 

4 Click OK.

No matter which setting you choose, After Effects makes the image cache more compact 
when you choose About Adobe After Effects, when you perform a RAM preview, or when 
you are between renders in the Render Queue.

Identifying memory-intensive layers in a composition
After Effects renders each frame of a composition one layer at a time. This means that the 
memory requirement of each individual layer is more important than the duration of the 
composition or the number of layers in the composition. The memory requirement for a 
composition is equivalent to the memory requirement for the most memory-intensive 
single layer in the composition. For example, it generally takes less memory to render 30 
layers at NTSC resolution than two layers at motion-picture film resolution.
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The memory requirements of a layer increase in the following situations:

• When you use larger image sizes.

• When you add a mask in After Effects.

• When the source of a layer is a composition. When a layer contains a composition, 
everything in that composition must be rendered before the next layer, so look for 
memory-intensive layers within that composition.

• When you apply certain plug-in effects or transfer options, especially those that 
combine the layer with other layers. For example, After Effects must set aside an 
additional memory buffer for the Set Channels effect.

• When you apply certain output options, such as 3:2 pulldown, cropping, and stretching.

• When you add shadows or depth of field.

• When you use 16 bpc (approximately doubles memory requirement).

Reducing a composition’s memory requirements
Once you identify the layers that use memory-intensive features, you can employ several 
strategies to reduce the memory load:

• Collapse transformations of nested compositions where possible. Collapsing transfor-
mations calculates the transform property changes once for all nested compositions 
instead of calculating at every level in the composition hierarchy. This saves memory 
and improves performance. This technique cannot be used if the nested composition 
uses a mask or effect. See “Collapsing transformation properties” on page 87 and 
“Maintaining image quality of nested compositions” on page 268.

• Prerender nested compositions. When you render nested compositions into movies, 
After Effects saves the time and memory required to calculate the changes in them. See 
“Saving time by prerendering nested compositions” on page 270.

• Render compositions in draft mode. Although draft quality is not sufficient for final 
output, it produces a movie that is good enough for previewing your project. 

• Reduce the number of changes you can undo with the Undo command by choosing 
Edit > Preferences > General and typing a lower number for Undo-able Actions. 

• Free up RAM currently used to cache images by choosing Edit > Purge > Image Caches. 
You can also free up RAM currently used to store undo changes by choosing Edit > 
Purge > Undo. 

If insufficient-memory problems persist, try the following:

• On Mac OS systems, disable unnecessary system extensions. This will also improve 
rendering performance.

• On Mac OS systems, make sure that you have allocated the maximum amount of 
available RAM to After Effects.

• Estimate the amount of RAM required for the composition, and add additional RAM to 
your computer. You can review the contributing factors for a specific composition by 
selecting it, choosing Composition > Composition Settings, and then looking on both 
the Basic and Advanced tabs.
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• When a memory error message is displayed, temporarily remove effects from the 
project in order to finish rendering. 

Note: Although After Effects can run with RAM-extending utilities, such as RAM Doubler, 
use of such utilities significantly slows the application and is not recommended. The use of 
virtual memory on Mac OS systems is also not recommended for the same reason. 

Running After Effects on multiprocessor systems
When running on a Windows NT, Windows 2000, or Mac OS multiprocessor system, After 
Effects employs an MP plug-in to make use of the added processing power available. With 
this plug-in, a multiprocessing system previews and renders certain operations much 
faster than single processor systems. The MP plug-in accelerates movement, rotation, 
motion blur, blending modes, and other computation-intensive operations, including 
plug-in effects such as Compound Arithmetic and Bevel Alpha. 

The degree to which the MP plug-in improves performance depends on the type of 
operation being performed. Memory-intensive operations are accelerated only minimally. 
Performance improvement also depends on system variables, such as the operating 
system, the type and number of processors, hard drive type, and compression. To 
determine the impact on rendering speed, render a project using the plug-in, move the 
plug-in out of the Plug-ins folder, render the project again, and compare the rendering 
times. 

Using the Windows MP plug-in (Windows only)
The MThread.aex plug-in enhances After Effects performance on multiprocessor systems 
under Windows NT. The Adobe MP Accelerator plug-in is installed automatically during 
the After Effects installation process. 

Using the Multiprocessor Support plug-in (Mac OS)
The Adobe Multiprocessor Support plug-in enhances After Effects performance on 
Mac OS multiprocessor systems, such as Apple G4. The Adobe Multiprocessor Support 
plug-in is installed automatically during the After Effects installation process.
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Rendering a Movie

Understanding rendering and compression
Rendering is a series of operations performed on your composition. First, each layer or 
nested composition is rendered with its masks, effects, and layer transformations. Next, 
transfer modes are applied. Finally, the composited frame is sent to each output module to 
create the final movie.

The output module specifies the compression scheme to be used in rendering the movie. 
The quality of the audio for a movie is determined by the settings in the output modules.

For a list of compressors and file formats, see the Adobe Web site.

Making (rendering) a movie
Making a movie from your final composition can take a few minutes or many hours, 
depending on the composition’s frame size, quality, complexity, and compression method. 
When you place your composition in the render queue, it becomes a render item that uses 
the render settings assigned to it. An audio alert indicates that rendering is complete. You 
will not be able to work in After Effects while making a movie.

To make a movie from a composition:

1 Save the project.

2 Do one of the following:

• Select the composition in the Project window, choose Composition > Make Movie, 
specify the name and location of the output file, and then click Save.

• Choose Window > Render Queue, and then drag the composition you want to render 
from the Project window to the Render Queue window. Default render settings and 
output module templates are assigned automatically. See “Using the Render Queue 
window” on page 279.

3 Click the underlined setting to the right of Render Settings to change the default 
render settings template, or choose a render settings template from the pop-up menu. 
See “Changing render settings” on page 281.

4 Choose a Log type from the Log menu.

5 Click the triangle to the left of the Output Module heading to view the default output 
module settings template, or choose a template from the Output Module pop-up menu. 
See “Changing output module settings” on page 284.

6 Click the underlined text after Output To to specify the name and location of the output 
file.

7 Select the Render option under the Render column heading. The status of the item 
changes to Queued.
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8 Click the Render button.

Note: To view more information about the composition as it renders, click the triangle to 
the left of Show Details. To view details of a completed rendering, review the log file.

Using the Render Queue window
Use the Render Queue window to render compositions, apply rendering and output 
module options, and obtain information on the rendering process. You can queue items to 
be rendered in any order.

All the settings for rendering a movie or sequence are included in the Render Queue 
window. When you drag or place a composition into the Render Queue window, it 
becomes a render item. You can then queue, or line up, a number of items for rendering, 
so that After Effects can render multiple items unattended. The settings you change in the 
Render Queue window affect only rendering and do not change the original composi-
tions.

The top section of the Render Queue window monitors an item that After Effects is 
rendering. In the bottom section, you can arrange a queue of items to be rendered and 
specify render settings and output modules for each one.

A. Information on an item that is rendering B. Information on items queued for rendering, 
including settings you can change 

Working in the Render Queue window
You can place multiple items in the render queue. When rendering is complete, each item 
remains in the queue with its status changed to Done until you remove it. You cannot 
render a completed item again, but you can duplicate it to create a new item in the queue 
with the same settings or with new settings you specify.

To add compositions to the queue:

Drag the composition from the Project window to the Render Queue window, or make 
sure that the composition is selected and choose Composition > Make Movie or 
Composition > Add to Render Queue.

To remove render items from the render queue:

Select the composition in the Render Queue window and press Delete or choose 
Edit > Clear.

To rearrange render items in the render queue:

Drag the composition up or down the queue. A heavy black line appears between compo-
sitions, indicating where the composition will be placed.

B

A



Using Help | Contents | Index Back 280  

Adobe After Effects Help Rendering a Movie 

Using Help | Contents | Index Back 280  

To pause rendering:

Click the Pause button.

Note: While the rendering process is paused, you will not be able to change settings or use 
After Effects in any other way, but you can use other applications.

To stop rendering:

Click the Stop button.

Note: If you stop the rendering process, the item you stopped is assigned the status User 
Stopped, and a new item with the status of Needs Output is added to the render queue and 
set to resume rendering at the first unrendered frame.

To rerender a render item with the same or different settings:

1 In the Render Queue window, select the render item.

2 Do one of the following:

• To render with the same filename, choose Edit > Duplicate with Filename.

• To render with a new filename, choose Edit > Duplicate, click the underlined Output to 
filename, type a new filename, and then click Save.

3 Click Render.

 Close the Composition window to increase rendering speed. 

Monitoring the rendering process 
The Render Queue window displays both elapsed time and estimated time remaining for 
the composition being rendered. In addition, the Render Queue window displays the 
following information for all queued items:

Message Contains a status message.

RAM Shows the memory available for the rendering process.

Renders Started Lists which items in the queue have started rendering.

Total Time Elapsed Shows the time elapsed for all items that have been rendered or are 
currently being rendered.

Log File Shows the name and location of the file to which rendering status messages are 
written. After Effects creates a log file, AE Log (date/time).txt. The path of the log file is 
displayed in the Render Queue window during rendering. Use the Log menu in the Render 
Queue window to select which information is written to the log file.

Checking rendering status
The status line in the Render Queue window provides important information on the 
results of the rendering process. Render queue status options include the following:

Unqueued The render item is listed in the Render Queue window but is not ready to 
render. Confirm that you have selected the desired render and output module settings, 
and then select the Render option to queue the composition.

Queued The composition is ready to render.

Needs Output An output filename has not been specified for one of the output modules.
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Failed After Effects was unsuccessful in rendering the movie. Use a text editor to view the 
log file for specific information on why the rendering was unsuccessful.

User Stopped The rendering process was stopped.

Done The rendering process for the item is complete.

Changing render settings
The Render Queue window displays the current render settings—either default settings or 
settings you made when you created the composition. You can change these settings or 
override the settings for all layers or compositions.

When you set the quality and resolution of a composition while editing, it does not neces-
sarily change the quality or resolution of compositions nested within it. When rendering, 
you can have After Effects automatically adjust the settings of all layers and compositions 
in your final rendered item.

You can change render settings in the Render Queue window by clicking the underlined 
render settings template name or by selecting a render settings template from the Render 
Settings pop-up menu. Several basic templates are provided. Use the Draft Settings 
template for reviewing motion or for testing. The Best Settings template works well for 
final rendering. To use the composition’s current settings, use the Current Settings 
template.

To change render settings, click the underlined settings name. These settings affect the 
composition and all nested compositions. The Render Settings dialog box has the 
following options:

Quality Determines the quality setting for all layers.

Resolution Determines the size and clarity of the rendered composition, relative to the 
original composition dimensions.

Note: When rendering at reduced resolution, set the Quality option to Draft. Rendering at 
Best quality while reducing resolution does not produce a clear image and takes longer to 
render than rendering at draft quality.

Proxy Use Determines whether proxies will be used when rendering. Current Settings 
uses the settings for each item.

Effects Determines which effects are enabled for the rendered composition. You can 
choose to use current settings or to turn all effects on or off. If you select All On, all applied 
effects are used in a composition or a layer. If you select All Off, all effects for the compo-
sition are disabled.

Frame Blending Determines the frame blending settings for all layers. Use On for 
Checked Layers to render frame blending only for layers with frame blending enabled in 
the Switches panel in the Timeline window, regardless of the composition’s Enable Frame 
Blending setting. See “Using frame blending” on page 89.

Field Render Determines the field-rendering technique used for the rendered compo-
sition. Choose Off if you are rendering for film or for display on a computer screen. For 
information on determining field order, see “Field-rendering considerations” on page 282 
and “Testing the field-rendering order” on page 302. For general information on fields, see 
“Interlaced and noninterlaced footage” on page 40 and “Using interlaced video in After 
Effects” on page 43.
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3:2 Pulldown Determines the phase of 3:2 pulldown introduction. See “Introducing 3:2 
pulldown” on page 285.

Motion Blur Determines when motion blur is applied. Use On for Checked Layers to 
render motion blur only for layers with motion blur enabled in the Switches panel in the 
Timeline window, regardless of the composition’s Enable Motion Blur setting. See “About 
motion blur” on page 90. Shutter angle affects the amount of Motion Blur. Select Override 
Shutter Angle if you don’t want After Effects to use the shutter angle selected in the 
Composition Settings dialog box, and specify a different shutter angle. For more infor-
mation on how shutter angle affects motion blur, see “Adjusting the shutter angle for 
motion blur” on page 91.

Use Storage Overflow Determines whether rendering continues when the first 
assigned storage volume overflows. If this option isn’t selected, rendering stops when the 
first assigned volume reaches capacity. See “Working with overflow volumes” on 
page 300.

Time Span Indicates how much of the composition is being rendered. To render the 
entire composition, choose Length of Comp. To render only the part of your composition 
indicated by the work-area markers, choose Work Area Only. To render a custom time 
span, choose Custom or simply click Set, type timecodes in Start, End, and Duration, and 
then click OK.

Frame Rate Determines the sampling frame rate used to render the composition. Select 
Use Comp’s Frame Rate to use the frame rate specified in the Composition Settings dialog 
box, or select Use this Frame Rate to type in a different frame rate. The actual frame rate of 
the composition is unchanged.

Skip Existing Files When this option is selected, you can rerender part of a sequence of 
files without wasting time on previously rendered frames. When rendering a sequence of 
files, After Effects locates files that are part of the current sequence, identifies the missing 
frames, and then renders only those frames, inserting them where they belong in the 
sequence. You can also use this option to render single-frame sequences on multiple 
systems.

Note: The current sequence must have the same name as the existing sequence, and the 
starting frame number, frame rate, and time span must be the same.

Field-rendering considerations
If vertical scaling, translation, rotation, or effects are applied to the image, the two fields of 
a video frame should be separated so that rendering can occur separately. If the field 
settings in the Interpret Footage dialog box are correct for the input footage and the field 
settings in the Render Settings dialog box are correct for the output device, you can mix 
footage items of different field orders in a composition. If either of these settings is 
incorrect, however, the frames will be in the correct order, but the field order may be 
reversed, resulting in jerky, unacceptable images. The Upper Field First option corresponds 
to Even Field First in an ElectricImage file. For more information, see “Testing the field-
rendering order” on page 302.
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Creating and using render settings templates
You can create templates that save commonly used render settings. These templates 
appear in the Render Settings pop-up menu in the Render Queue window. You can specify 
a default render settings template for movie rendering as well as another for creating a 
single frame. You can also save all render settings templates to a file to use on another 
computer.

To set the default render settings templates:

1 Choose Edit > Templates > Render Settings.

2 To select a default template to be used when rendering movies, select a template from 
the Movie Default pop-up menu. To select a default template to be used when rendering a 
single frame, select a template from the Frame Default pop-up menu.

To create a new render settings template:

1 Choose Edit > Templates > Render Settings.

2 Click New.

3 Specify the render settings you want and click OK.

4 Type a name for the new template and click OK.

To edit an existing render settings template:

1 Choose Edit > Templates > Render Settings.

2 Select a template from the Settings Name pop-up menu.

3 Click Edit.

4 Specify the render settings you want and click OK.

5 Click OK to close the Render Settings Templates dialog box.

Note: Changes to an existing template do not affect render items that are already in the 
render queue.

To save all currently loaded templates to a file:

1 Choose Edit > Templates > Render Settings.

2 Click Save.

3 Select a location for the file, type a filename, and then click OK.

4 Click OK to close the Render Settings Templates dialog box.

To load a saved template file:

1 Choose Edit > Templates > Render Settings.

2 Click Load.

3 Select the template file, and then click Open.

4 Click OK to close the Render Settings Templates dialog box.
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Changing output module settings
An output module includes options for the specific video and audio output format to 
which you are rendering the movie, as well as video compression options. The Render 
Queue window shows the current settings for an output module.

Change output module settings from the Render Queue window by clicking the under-
lined output module template name or by selecting a template from the Output Module 
pop-up menu. Several templates are provided, including the Lossless template for 
creating movies for transfer to video or film.

Note: Before rendering, check the Audio Output settings in the Output Module Settings 
dialog box to ensure that they are correct. If your project includes audio, be sure that 
Audio Output is selected. If your project does not include audio, do not select Audio Output 
so that the size of the rendered file will not increase needlessly.

You can specify the following settings in the Output Module Settings dialog box:

Format Specifies the format for the output file or sequence of files. File formats include 
QuickTime, Video for Windows, and file types available from plug-in file format modules.

Embed Specifies whether to include information in the output file that links to the source 
project in After Effects. When you open the output file in another application such as 
Adobe Premiere, you can use the Edit Original command to edit the source project in After 
Effects. Selecting Project Link creates a link between the output file and the source 
project. Selecting Project Link and Copy creates a link and adds an embedded copy of the 
linked project to the output file; if the project is missing or updated when you choose Edit 
Original in another application, you can choose whether to open the source project or the 
saved copy of the project.

Import into Project When Done When selected, imports the rendered movie into the 
project. Use this option to import prerendered compositions back into a project.

Format Options Opens a dialog box with format-specific information. For example, if 
QuickTime is your format, Format Options opens a QuickTime Compression dialog box. 
For information on compression settings, see “Choosing compression options” on 
page 289.

Channels Specifies the output channels contained in the rendered movie. After Effects 
creates a movie with an alpha channel if you choose RGB+Alpha, implying a depth of 
Millions of Colors+.

Note: All files created with a color depth of Millions of Colors+ or Trillions of Colors+ have 
labeled alpha channels; information describing the alpha channel is stored in the file. 
Therefore, you do not have to specify an alpha interpretation each time you import an 
item created in After Effects.

Depth Specifies the color depth of the rendered movie. Choose from color or grayscale 
options, and note that certain formats may limit depth and color settings.

Color Specifies how colors are created with the alpha channel. Choose from either 
Premultiplied (Matted) or Straight (Unmatted). For information on alpha channels, see 
“Importing footage containing an alpha channel” on page 30.
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Stretch Specifies the size of your rendered movie. Select Lock Aspect To if you want to 
retain the existing frame aspect ratio when stretching the frame size. Select Low Stretch 
Quality when rendering tests, and select High Stretch Quality when rendering a final 
movie.

Crop Used to trim or add pixels to the edges of the rendered movie. You can specify the 
number of pixels to be added or subtracted from the top, left, bottom, and right sides of 
the movie. Type positive values to crop, and type negative values to add pixels.

Note: By adding one pixel to the top of a rendered movie with field rendering, you can 
change the field-rendering order. See “Making a movie smaller than the rendered compo-
sition” on page 300.

Audio Output Specifies the sample rate, sample depth (8 Bit or 16 Bit), and playback 
format (Mono or Stereo). Choose a sample rate that corresponds to the capability of the 
output format. Choose an 8-bit sample depth for playback on the computer, and a 16-bit 
sample depth for compact disc and digital audio playback or for hardware that supports 
16-bit playback.

Introducing 3:2 pulldown
If you are creating output for film that’s been transferred to video or if you want to 
simulate a film look for animation, use 3:2 pulldown. Footage items that were originally 
film transferred to video and had 3:2 pulldown removed when imported into After Effects 
can be rendered back to video with 3:2 pulldown reintroduced. You can set the intro-
duction of 3:2 pulldown using any of five different phases. For more information on 3:2 
pulldown, see “Removing 3:2 pulldown from video transferred from film” on page 45.

Note: It is important to match the phase of a segment that had 3:2 pulldown removed if it 
will be edited back into the video footage it came from.

To introduce 3:2 pulldown:

1 In the Render Queue window, select the render item and then click the underlined 
Render Settings name.

2 For Field Render, choose a field order.

3 For 3:2 Pulldown, select a phase.

4 Select other settings as appropriate, and then render.

Creating and using output module templates
You can create templates that save commonly used output module settings. These 
templates appear in the Output Module pop-up menu in the Render Queue window. You 
can specify a default output module template for movie rendering and another for 
creating a single frame. You can also save all output module settings templates to a single 
file to use on another computer.

To set the default output module template:

1 Choose Edit > Templates > Output Module.

2 To select a default template to be used when creating movies, select a template for 
Movie Default. To select a default template to be used when creating a single frame, select 
a template for Frame Default.
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To create a new output module template:

1 Choose Edit > Templates > Output Module.

2 Click New.

3 Type the output module settings you want, and then click OK.

4 Type a name for the new template, and then click OK.

To edit an existing output module template:

1 Choose Edit > Templates > Output Module.

2 Select a template from the Settings Name menu.

3 Click Edit.

4 Change the settings you want, and then click OK.

5 Click OK to close the Output Module Templates dialog box.

Note: Changes to an existing template do not affect render items that are already in the 
render queue.

To save all currently loaded output module templates to a file:

1 Choose Edit > Templates > Output Module.

2 Click Save.

3 Select a location for the file, type a filename, and then click OK.

4 Click OK to close the Output Module Templates dialog box.

To load a saved output module template file:

1 Choose Edit > Templates > Output Module.

2 Click Load.

3 Select the template file, and then click Open.

4 Click OK to close the Output Module Templates dialog box.

Exporting to Macromedia Flash (SWF) format
You can export compositions as Macromedia Flash (.swf ) movies. Web browsers with the 
Flash player plug-in can play the SWF format. During export, After Effects maintains 
vectors as much as possible. However, raster images and certain features such as pixel 
effects, layer modes, and motion blur cannot be represented as vectors in the SWF file. For 
information on which After Effects features are supported for SWF export, see “Supported 
features for SWF export” on page 287.

You can choose to ignore these unsupported items so that the SWF file includes only 
those After Effects features that can be converted into native SWF elements, or you can 
choose to rasterize frames that contain unsupported features and add them to the SWF 
file as JPEG-compressed bitmaps, which may reduce the efficiency of the SWF file.

Audio is encoded in MP3 format and added to the SWF file as a stream sound.

To export a composition to Macromedia Flash (SWF) format:

1 Select the composition you want to export, and then choose File > Export > Macro-
media Flash (SWF).
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2 Specify a filename and location, and click Save (Windows) or OK (Mac OS).

3 Specify the following options and then click OK.

• For JPEG Quality, specify the image quality by typing a number, selecting an option for 
JPEG Quality, or dragging the slider. The higher the quality, the larger the file. The JPEG 
quality setting is used for all JPEG-compressed bitmaps exported to the SWF file, 
including bitmaps generated from composition frames or Adobe Illustrator files if 
Rasterize is selected for Unsupported Features.

• For Unsupported Features, select Ignore to skip all features that are not supported by 
the SWF format, or select Rasterize to render all frames that contain unsupported 
features as bitmap images. Selecting Rasterize increases the file size and may signifi-
cantly reduce the streaming quality.

• Under Audio, specify the sample rate, mono or stereo channels, and bit rate. Select Auto 
for Bit Rate to get the lowest bit rate available given the Sample Rate and Channels 
settings. Higher bit rates increase file size. For more information on audio output, see 
“Changing output module settings” on page 284.

• Select Loop Continuously if you want the exported SWF file to loop continuously during 
playback. If you plan to specify looping by writing HTML to control the Flash player, 
select Loop Continuously.

• Select Prevent Import to prevent the SWF file from being imported into editing 
programs.

• Select Include Object Names to include layer, mask, and effect names. Selecting this 
option increases file size. See “Including object names in a SWF file” on page 288.

• Select Include Layer Marker Web Links if you want layer markers to be used as URL Web 
links. See “Including Web links in a SWF file” on page 288.

A report is created in the same folder into which the SWF file was exported. The report has 
the same name as the SWF file, followed by R.htm. Open the report in a browser to see 
which items in the composition were unsupported in the SWF file.

Supported features for SWF export
When creating compositions intended for the SWF format, note the following:

Layers Only Normal mode is supported. Track Mattes, 3D Layers, 3D Cameras, and 3D 
Lights are unsupported. The following layer switches are unsupported: Preserve Trans-
parency, Adjustment Layer, Collapse Transformations, and Motion Blur.

Masks Only Add mode and Difference mode are supported. If multiple masks are applied 
to a layer, they must all have the same mode to be supported. Partial Opacity and the 
mask Inverted option are supported only if Add mode is specified. Nonzero Mask feathers 
are unsupported.

Effects Path Text is the only supported effect. Several Path Text options are unsupported, 
including Composite on Original, Fill and Stroke/Options/Fill Over Stroke, and Advanced/
Mode/Difference. Multiple effects per layer are unsupported.

Adobe Illustrator files Only stroked paths and filled paths in CMYK or RGB color spaces 
are supported. Note that if Rasterize is selected for Unsupported Features, unsupported 
elements in an Illustrator file will result in the rasterization of only the layer to which the 
Illustrator file is source, not the entire composition frame.
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The source for each layer in the composition is rendered and added to the SWF file as a 
JPEG-compressed bitmap, unless the layer is a solid or its source is an Adobe Illustrator file. 
If the layer source is an Illustrator file, the source is automatically converted to the corre-
sponding native SWF elements. The Collapse Transformations option for nested composi-
tions is not supported—the composition used as source for a layer in the exported 
composition will be rendered and added to the SWF file as a JPEG-compressed bitmap.

Including object names in a SWF file
If the Include Object Names option is selected in the SWF Settings dialog box, the layers, 
masks, and effects in the SWF movie have the same names they have in After Effects. The 
layer, mask, or effect name will be either the default name given by After Effects or the 
name you specified. If individual objects were not exported for a given frame (because the 
composition frame was rasterized), names cannot be written out for that frame.

Each mask is exported as a separate SWF object. The name of each object is the Layer 
name followed by the Mask name, with no space separating the names. If all masks are 
Difference mode, then one SWF object is exported, and the name is the Layer name.

Each Path Text character is exported as a separate SWF object. The name of each object 
will be the Layer name followed by the Effect name followed by the character index 
(starting at 0). No space separates the names or the character index.

Including Web links in a SWF file
If the Include Layer Marker Web Links option is selected in the SWF Settings dialog box, a 
frame label is added to each SWF frame that has a layer marker, and a GetURL action is 
added to each SWF frame in which a layer marker has a specified URL. For more infor-
mation on creating Web links from markers, see “Creating Web links from markers” on 
page 85.

The Macromedia Flash format honors the following standard frame targets:

• _blank causes the document to be loaded into a new browser window.

• _parent causes the document to be loaded into the parent frame of the frame in which 
the current movie is playing.

• _self causes the document to be loaded into the current frame. This is the default if no 
target is specified.

• _top causes the document to be loaded into the top frame in the current window.

• _level0 causes another SWF movie to be loaded into level 0. The current movie typically 
plays at level 0; another movie loaded into level 0 usually replaces the current movie. 
Note that the URL must refer to another SWF movie.

• _level1 causes another SWF movie to be loaded into level 1. Note that the URL must 
refer to another SWF movie.

Saving a RAM preview as a rendered movie
Use RAM preview to preview frames, including audio, at the frame rate of your compo-
sition or as quickly as your system allows. To simplify the rendering process, save RAM 
preview frames as a movie. When saving a RAM preview, keep in mind the following:

• After Effects uses the composition frame size and resolution setting to determine the 
final dimension in pixels of a saved RAM preview. It does not consider the zoom level.



Using Help | Contents | Index Back 289  

Adobe After Effects Help Rendering a Movie 

Using Help | Contents | Index Back 289  

• RAM preview does not generate interlaced fields, so a saved RAM preview never 
contains fields. If you require interlaced fields, render the movie normally.

To save a RAM preview:

1 Choose Composition > Save RAM Preview.

2 Type a name, specify a location, and click Save.

Exporting footage using QuickTime components
If you have QuickTime 4.1 or later installed on your system, you can export items using 
components provided by QuickTime. This rendering process exports the movie directly 
without using the Render Queue window in After Effects. The specific file formats you can 
export to depend on how you’ve configured QuickTime. If you install new export modules 
as they become available from Apple or other third parties, those modules will appear on 
the File > Export submenu in After Effects. With this QuickTime support, you can export 
AVI files on both platforms or prepare streaming video and audio for Web distribution. If 
you want to apply QuickTime effects, you can do so during export.

For more information about effects and file formats supported by QuickTime, start the 
QuickTime Player program included with QuickTime 4.1 and choose Help > On-line 
QuickTime Player Help.

Note: The composition is exported using the Composition window’s current quality and 
resolution settings. Only the work area in the Time Layout is exported.

To export files using QuickTime export formats:

1 Select an item in the Project window.

2 Choose File > Export, select the export module you want to use, specify options as 
necessary, and click Save.

Rendering an item to multiple formats
You can apply more than one output module to each render item in the queue. This is 
useful when you want to make more than one version of a movie. For example, you can 
automate the creation of a movie and its alpha matte, or you can create high-resolution 
and low-resolution versions of a movie.

When you apply more than one output module to a render item, After Effects renders to 
the various output formats simultaneously, saving you time.

To apply an additional output module:

1 In the Render Queue window, select an item.

2 Choose Composition > Add Output Module.

Choosing compression options
Compression is essential to reduce the data size of movies that would otherwise be so 
large as to prohibit effective playback. When compressing a movie file, you can fine-tune it 
for the best-quality playback on a computer, on a video playback device, on the Web, or 
from a CD-ROM drive.
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QuickTime and Video for Windows have several built-in, software-based compression 
algorithms. For a list of QuickTime compressors, see the Adobe Web site.

Setting QuickTime compression options
Choices you make in the Compression Settings dialog box require trade-offs between file 
size and movie quality. The higher the visual quality of your movie, the larger the file size.

Quality The Quality control specifies the spatial compression of the movie, which 
compresses the data in each frame of a composition. Higher quality produces better 
image quality but results in a bigger movie file. Lower quality results in a blocky and 
slightly blurred image (although it is still recognizable) and a smaller, more compressed 
movie file. Note that this quality is unrelated to each layer’s quality setting in After Effects.

Key Frame Every In QuickTime terminology, the term key frames is different from the 
change-over-time keyframes placed in the After Effects Timeline window. In QuickTime, 
key frames are frames that occur at regular intervals in the movie. During compression 
they are stored as complete frames. Each intermediate frame that separates them is 
compared to the previous frame, and only changed data is stored. This greatly reduces 
movie size. Shorter intervals between key frames enable faster seeking and reverse 
playback but can significantly increase the size of the file.

To specify QuickTime compression settings:

1 In the Render Queue window, click the underlined name of the output module.

2 For Format, choose QuickTime.

3 Click Format Options in the Video Output section.

4 In the Compression Settings dialog box, choose a compressor from the first menu in the 
Compressor section.

Note: Set the color depth in the Compression Settings dialog box instead of in the Output 
Module Settings dialog box. This ensures that non-Adobe plug-ins receive color depth 
information from After Effects. See step 8.

5 Select a Quality level from Least to Best.

Note (Mac OS Only): If you intend to use key frames in the movie, hold down Option and 
adjust the Quality slider to control the temporal compression of the movie. Temporal 
compression compresses a movie by comparing successive frames and keeping only 
changed data. High temporal quality maintains smoothness of motion. Low temporal 
quality tends to produce jerkiness of motion because a pixel doesn’t change unless the 
difference between frames is great.

6 If you want the smallest possible files, and your compressor choice allows for a key 
frame rate, select the box and type a number in the Key Frame Every box. Generally, you 
should type a number equal to the frame rate. For example, if you set a frame rate of 30 
fps, type 30 in the Key Frame box. This sets one key frame every 30 frames of your movie.

Note: If you are going to use the resulting movie in another After Effects composition, type 
a small value (less than 5) in the Key Frame Every box or deselect the Key Frame Every 
option. The presence of key frames greatly increases the memory required to edit and 
render a movie.

7 Click OK.
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8 If your compressor choice supports different image color depths, choose the appro-
priate color depth in the Output Module Settings dialog box:

• Choose Millions of Colors+ if you want 24-bit color quality and you want your compo-
sition background to be transparent (to include an alpha channel). The composition’s 
background color is disregarded. Only Animation and None can support the Millions of 
Colors+ color depth.

• Choose Millions of Colors if you want 24-bit color quality but want to include your 
composition background color (no alpha channel).

Note: Color depth settings of Thousands of Colors or lower may cause banding and 
dithered images. 

9 Choose other options in the Output Module Settings dialog box, as described in 
“Changing output module settings” on page 284. Then click OK.

Setting Video for Windows compression options
When setting Video for Windows compression options, you can specify the compressor 
and compression quality. Compressors available for Video for Windows include Microsoft 
Video 1, Cinepak, Microsoft RLE, Microsoft DV, and Intel Video. Choose a compressor based 
on the type of original images you have and the purpose of the rendered movie:

Cinepak Use when compressing 16-bit and 24-bit video for playback from CD or for 
desktop presentations. For best results, use the Cinepak compressor on raw source data 
that has not been previously compressed with a highly lossy compressor. Note that this is 
a slow compression method. With Cinepak, decompression is much faster than 
compression, and the data rate for playback can be defined by the user. However, you 
cannot save an alpha channel using the Cinepak compressor.

Microsoft RLE Use for lossless compression limited to 256 colors.

Microsoft DV Use for digital video camcorders.

Intel Indeo/Microsoft Video Use when compressing video for playback from CD.

Full Frames (Uncompressed) Use for a depth setting of Millions of Colors+ when an 
alpha channel is required.

To specify Video for Windows compression settings:

1 In the Render Queue window, click the underlined name of the output module.

2 Choose Video for Windows from the Format menu.

3 Click Format Options in the Video Output section.

4 In the Video Compression dialog box, choose a compressor from the first menu in the 
Compressor section.

5 Select a Compression Quality level.

6 If you selected either Cinepak or Microsoft Video in step 4, click the Configure button to 
set other options:

• For Cinepak, choose whether the movie is compressed to color or to black and white.

• For Microsoft Video, choose a level for the temporal compression quality of the movie. 
Temporal compression compresses a movie by comparing successive frames and 
keeping only changed data. High temporal quality maintains smoothness of motion. 
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Lower temporal quality tends to produce jerkiness of motion because a pixel doesn’t 
change unless the difference between frames is great.

7 If you want the smallest possible files, and your compressor choice allows for a key 
frame rate, select the Key Frame Every option and type a number of frames. Generally, you 
should type a number equal to the frame rate. For example, if you set a frame rate of 30 
fps, type 30 in the Key Frame box. This sets one key frame every 30 frames of your movie.

Note: If you are going to use the resulting movie in another After Effects composition, type 
a small value (less than 5) in the Key Frame Every field or deselect the Key Frame Every 
option. The presence of key frames greatly increases the memory required to edit and 
render a movie.

8 Click OK.

9 If your compressor choice supports different image color depths, choose the appro-
priate color depth in Output Module Settings dialog box. See “Setting QuickTime 
compression options” on page 290.

10 Choose other options in the Output Module Settings dialog box, as described in 
“Changing output module settings” on page 284. Then click OK.

Exporting a single frame of a composition
You can save a single frame from a composition to any output format or as an Adobe 
Photoshop file with layers intact. One frame of the composition is rendered at the current 
time as set in the Composition window. This is useful for editing files in Adobe Photoshop 
or creating a proxy.

You can preserve the individual layers of a composition and save a frame of the compo-
sition as an Adobe Photoshop file. This makes it possible to use footage imported into 
After Effects as images in Adobe Photoshop. Preserving layers is also useful if you want to 
use a composition frame as a source for both print and dynamic media.

To export one frame of a composition:

1 In the Composition window, display the frame you want to export.

2 Choose Composition > Save Frame As > File.

3 Type a filename and click OK.

4 The Render Queue window is displayed. Adjust settings if necessary, and then click 
Render.

To export a single composition frame as an Adobe Photoshop file with layers:

1 In the Composition window, display the frame you want to export.

2 Choose Composition > Save Frame As > Photoshop Layers.

3 Type a filename and click OK.
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Creating a filmstrip file for editing in Photoshop
Use the Filmstrip format to paint directly on video frames, a process known as rotoscoping. 
You can render part or all of a composition as a filmstrip, a single file that contains all the 
frames of a composition or portion of a composition. Because video compression is not 
used in creating a filmstrip file, these files can be large. You can break the filmstrip file into 
any number of smaller files by setting the work area to a different portion of the compo-
sition before rendering each portion.

A filmstrip opens in Adobe Photoshop as a series of frames in a column, with each frame 
labeled by number, reel name, and timecode. If the column created by the filmstrip frames 
is more than 30,000 pixels tall, the frames continue in a second column. The number of 
frames displayed depends on the duration of the footage and the frame rate selected 
when you render the filmstrip.

When editing a filmstrip in Adobe Photoshop, use the following guidelines for best results:

• You can paint on the gray lines dividing the frames of the filmstrip without damaging 
the file. After Effects will display only the part of each frame that lies within the frame 
border.

• You can edit the red, green, blue, and alpha channels in the filmstrip file. Use only 
channel #4 as the alpha channel.

• Do not resize or crop the filmstrip.

• Flatten any layers you add in Adobe Photoshop.

Note: If you simply want to export a single frame, you don’t need to use the Filmstrip 
format. See “Exporting a single frame of a composition” on page 292.

To render a composition as a filmstrip:

1 Be sure that the composition you want to render is active. If you want to render only 
part of the composition, set the work-area markers to define the part you want to render. 

2 Choose Composition > Make Movie.

3 Type a filename.

4 In the Render Queue window, click the underlined Output Module template name.

5 Choose Filmstrip from the Format pop-up menu. Specify the rest of the settings you 
want and click OK.

6 In the Render Queue window, click Render.

Rendering frames as a sequence of still images
Movies are the type of output most useful for easy previewing. However, a sequence of 
still images from a composition can be used for movie-making and desktop presentations. 
You can use a sequence of stills in the following ways:

• Transfer frames to film using a film recorder.

• Create still images for high-end video systems.

• Create still images and use them in a presentation.

• Select images for publishing or creating storyboards.
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• Export source images for a graphics program in which the images can be edited or 
retouched and imported back into After Effects as footage items.

To export a range of frames as a sequence of stills:

1 Choose Composition > Make Movie.

2 Type a filename.

Note: When rendering frames on a Mac OS system for use on a Windows system, the 
filename must be in this format: filename[###].tga. As each frame is rendered and a 
filename created for it, After Effects replaces the [###] portion of the name with a number 
indicating the order of the frame in the sequence.

3 In the Render Queue window, click the underlined Output Module template name.

4 Choose one of the sequence formats from the Format pop-up menu. Specify the rest of 
the settings you want and click OK.

5 In the Render Queue window, click Render.

Rendering cross-platform movies and stills
Because the UNIX platform and some Windows versions play only single-fork movies 
(sometimes called flattened movies), files created in After Effects for Mac OS systems and 
intended for use across platforms must be rendered as single-fork files. Earlier versions of 
After Effects included a plug-in for flattening movies. After Effects 4.0 and later creates 
flattened movies automatically, and the Cross Platform plug-in available for earlier 
versions is no longer needed. For more information on project hierarchy, file naming, and 
other related topics, see “Considerations for cross-platform projects” on page 7.

Note: Make sure that the codec you use to render a QuickTime movie is available on the 
platforms you want to support; otherwise the movie will not play.

Collecting files in one location 
The Collect Files command gathers copies of all of the files in a project or composition into 
a single location for rendering or archiving. When you use this command, After Effects 
creates a new folder in which it saves a new copy of the project, copies of the specified 
footage files, proxy files as specified, and a report describing the files, effects, and fonts 
necessary to render the project.

After you collect files, you can continue making changes to a project, but be aware that 
those changes are stored with the original project and not with the newly collected 
version.

When you collect files, options include the following:

Obey Proxy Settings: Use this option with compositions that include proxies to specify 
whether you want the copy to include the current proxy settings. If this is selected, only 
the files used in the composition are copied. If this is not selected, the copy contains both 
proxies and source files, so you can later change proxy settings in the collected version.

Note: If you chose For Queued Comps in the Collect Source Files, After Effects uses the 
proxy settings from the render settings, not the composition.

Generate Report Only: Selecting this option does not copy the files and proxies.
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Change Render Output To: Use to redirect the output modules to render files to a 
named folder in the collected files folder. This option ensures that you have access to your 
rendered files when you’re rendering the project from another system. Note that the 
rendering status must be valid (Queued, Unqueued, or Will Continue) for the output 
modules to render files to this folder.

Enable ‘Watch Folder’ render (PB only): You can use the Collect Files command to save 
projects to a specified watch folder and then initiate watch-folder rendering over a 
network. After Effects also includes a render control file called project name_RCF.txt, which 
signals to watching systems that the project is available for rendering. After Effects and 
any installed render engines can then render the project together across a network. For 
more information about using the Watch Folder command, see “Rendering using a watch 
folder (PB only)” on page 296.

For Maximum Number of Machines (PB only): Use to specify the number of render 
engines or licensed copies of After Effects that you want to allocate to render the collected 
project. Below this option, After Effects reports how many items in the project will be 
rendered using more than one machine.

Note: If rendering time is unusually slow, you may have set the Maximum Number of 
Machines too high, and the network overhead required to track rendering progress among 
all machines is out of proportion to the time spent actually rendering frames. The optimal 
number depends on many variables related to the network configuration and the 
machines on it; experiment to determine the optimal number for your network.

To gather files for rendering or archiving:

1 Choose File > Collect Files.

2 In the Collect Files dialog box, choose an option for Collect Source Files:

• All. Collects all footage files, including unused footage and proxies.

• For All Comps. Collects all footage files and proxies used in any project compositions.

• For Selected Comps. Collects all footage files and proxies used in currently selected 
compositions (in the Project window).

• For Queued Comps. Collects all footage files and proxies used directly or indirectly in 
any of the compositions with a valid rendering status in the Render Queues.

• None. Copies the project to a new location without collecting any source footage.

3 Select appropriate check boxes, as needed. (For descriptions of each option, see the 
preceding paragraphs in this topic.)

4 To add your own information to the report that will be generated, click Comments, type 
your notes, and click OK. The comments appear at the end of the report.

5 Click OK. Name the folder and specify a location for your collected files.

Once you start the file collection, After Effects creates the folder and copies the specified 
files to it. The folder hierarchy is the same as the hierarchy of folders and footage in your 
project. The new folder includes a (Footage) folder and may include an output folder (if 
you selected Change Render Output To).

The names of these folders appear in parentheses to signal any attending render engines 
not to search these folders for projects (PB only).
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Rendering using a watch folder (PB only)
The Production Bundle version provides a Watch Folder feature that speeds up the 
rendering process on a network. If you have a full licensed copy of the Production Bundle, 
you can set it up to work with render-only versions of After Effects. Your license entitles 
you to install as many copies of the render engine as you want on your network, as long as 
one copy of the Production Bundle is installed on that network.

When you have multiple render engines on multiple systems monitoring a watch folder, 
they cooperate to achieve optimal efficiency. If your queued rendering items are set to 
Skip Existing Files (a Render Settings option), the render engines will all work on a single 
render item at once. If this option is not selected, each render engine handles a render 
item itself.

Note: You cannot use multiple machines to render a single movie file. However, you can 
use multiple machines to render a sequence of individual still-image files.

To set up a watch-folder rendering process:

1 Install the After Effects render engine on as many machines as you want to involve in 
network rendering.

Note: If rendering time is unusually slow, you may be rendering to too many machines, 
and the network overhead required to track rendering progress among all machines is out 
of proportion to the time spent actually rendering frames. The optimal number depends 
on many variables related to the network configuration and the machines on it; exper-
iment to determine the optimal number for your network.

2 Create a watch folder on a system that’s accessible to all of the After Effects render 
engines on your network. For example, create a folder called AE Watch Folder.

Note: All Windows machines monitoring the watched folder as a mapped network drive 
must map that drive using the same drive letter. If this is a problem, make sure that the 
machine creating or collecting the project does not access the volume being watched as a 
mapped drive letter. For example, connect to the volume as \\network\watch instead of 
X:\watch.

3 In each render engine, choose File > Watch Folder, and select the watch folder that 
you’ve created.

4 Create your projects and compositions, and set them up in the Render Queue with the 
render settings and output modules you want to use. For multiple-machine rendering, 
After Effects includes a “Multi-machine” sample template that you can use as a starting 
point. 

5 Choose File > Collect Files to copy completed projects (which are set up to use the 
Render Queue) to your specified watch folder. You must perform the collect-files process 
using the full licensed copy of the Production Bundle. In the Collect Files dialog box, be 
sure to select the Enable Watch Folder Render option. In addition, you may want to select 
the Change Render Output To option, so that the output directories for each project are 
stored in the watch folder. All of the render engines need access to these output direc-
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tories to complete their rendering tasks. Once you choose Collect Files, After Effects copies 
the project or composition and all source files to the watch folder. For more information 
on the Collect Files options, see “Collecting files in one location” on page 294.

Once the collected files appear in the watch folder, all monitoring render engines 
start rendering automatically. If you prefer, you can use the Collect Files command to 

store compositions and their source footage to a specified location and then initiate the 
watch-folder rendering process later. Doing so renders the projects in alphabetical order, 
rather than in the order in which they were saved to the location.

6 Monitor the progress of the render engines by using a Web browser to navigate to 
HTML pages saved in the watch folder. After Effects generates these pages automatically 
when the rendering begins. Click the Reload button in your Web browser to see the 
updated status. If errors occur, these HTML pages will describe the errors.

After Effects renders the item to the specified destination folder, and if necessary, to the 
overflow volumes you have specified in the Output preferences. When After Effects 
finishes rendering all of the queued items in a given project, it closes that project without 
saving it and then scans the watch folder for new projects to render. Because it doesn’t 
save the project, After Effects ignores the Import into Project When Done option if that’s 
set in the Render Queue Settings.

Computer with full version of After Effects Production Bundle (A) saves a project and all source 
files to a folder (B) on a server. Computers with the render engine installed (C) open the project 
and render a still-frame sequence to a designated output folder (D) on the server.

When rendering across a network that includes volumes using different network or 
operating systems, such as Windows, Mac OS, Novell, and Unix, make sure that you 

specify output files using a file-naming convention that’s compatible with all rendering or 
destination volumes.

Rendering single-frame sequences on multiple systems
Although the preferred method of rendering for multiple systems is using the Watch 
Folder feature, you can also use multiple systems and multiple copies of After Effects to 
render a project across a network. Rendering in each copy of After Effects starts at approx-
imately the same time. By specifying that each copy skip existing frames or frames in 
progress, multiple systems can render the project simultaneously, writing the single-frame 
sequence to a single folder.

A

B

D

C 
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You can use multiple systems to render only single-frame sequences; you cannot use 
multiple systems to render movies. You can use any combination of Windows or MacOS 
systems.

Note: If you are rendering a project using Production Bundle effects on multiple systems, 
each system must be running the Production Bundle version of After Effects.

To render a single-frame sequence with multiple systems:

1 Install After Effects on each system that will be rendering the project. Make sure that 
you have the same fonts installed on each system.

Note: Do not share plug-ins across a network. Make sure that you have a copy of the plug-
ins folder on each system that is running After Effects. When using third-party plug-ins, 
also be sure that the same plug-ins are available on all systems and that you have suffi-
cient licenses for the plug-ins.

2 Open the project on one system, and then choose Composition > Add to Render 
Queue. 

3 In the Render Queue window, specify the Skip Existing Files option in the Render 
Settings section so that multiple systems do not render the same frames. Make sure that 
the Use Storage Overflow option is deselected.

4 In the Render Queue window, specify a single-frame sequence in the Output Module 
section and specify a folder in the Output To section. This folder must be available for all 
the systems that are rendering.

5 Save the project on the system where you opened it in step 2.

6 On each system that will be rendering, open and save the project. This ensures that 
After Effects records the new relative paths to each system in the following step.

7 Unless the network can handle large file transfers rapidly, copy the project file and all its 
source footage to each system that will be rendering.

8 Open the Render Queue window on each system and click Render. You do not need to 
start rendering on each system simultaneously, but to ensure equal workloads, start them 
at approximately the same time. As each system finishes rendering a frame, After Effects 
searches the Output folder for the next unrendered frame and starts rendering again.

9 You can stop and start any system at any time. However, if you stop a system without 
starting it again, the frame that it was rendering may not be finished. If one or more 
systems stop during rendering, starting any one system will ensure that all frames in the 
sequence get rendered.

Network performance
There is no limit to the number of systems you can use for rendering; in general, the more 
systems, the faster the rendering. However, if too many systems are used across a busy 
network, network traffic may be significant enough to slow down the entire process. You 
can detect network slowdown by observing the time spent in the Compressing & Writing 
stage in the Show Details section of the Render Queue window.

Note: Adobe does not provide technical support for general network configuration; 
consult your network administrator.
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Tracking discrepancies and load-sharing (Mac OS only)
With After Effects for Mac OS, you can use Finder labels to track discrepancies and load-
sharing when rendering with multiple systems. When the After Effects application is given 
a Finder label, it renders each frame with the same label. If you give each copy of After 
Effects a different label, you can track single frames to a particular copy of the application.

For example, if you discover a discrepancy in a certain frame created with network 
rendering, you can adjust options in the copy of After Effects that rendered the frame. You 
can also view the difference in rendering speed between the networked systems by 
counting the number of frames for each label, and then make any necessary adjustments 
to balance the workload.

To give the After Effects program a Finder label:

1 Quit After Effects.

2 Select the After Effects icon, and then choose a label from the Finder’s Label menu.

Starting After Effects in watch-folder mode (PB only)
You can start After Effects in watch-folder mode automatically. Simply save a project called 
Watch This Folder.aep. After Effects will watch the folder containing the project if you open 
that project. To start After Effects in watch-folder mode when you start your Windows or 
Mac OS computer, create a shortcut (Windows) or alias (Mac OS) to the Watch This 
Folder.aep project and move it to your Startup folder (Windows) or your Startup Items 
folder (Mac OS).

If you’re running a Windows system, you can also launch After Effects in watch-folder 
mode using a command-line option. Choose Start > Run, type "C:\Program 
Files\Adobe\After Effects\afterfx.exe" -wf C:\temp (adjust the application path as 
needed to reflect the exact folder name where you installed After Effects, and replace 
C:\temp with the path to your watch folder), and press Enter. You can also use this 
command line in batch files.

Using multiple machines to render plug-in effects (PB only)
When a composition contains layers that use a plug-in effect, the plug-in that created the 
effect must be present on all of the machines that will render the composition.

When you install an After Effects render engine on a machine, it contains all the plug-ins 
included with the After Effects Production Bundle. If a composition uses a plug-in from 
another manufacturer, that plug-in must be present on all machines that will render the 
composition. However, support for network rendering varies among plug-in manufac-
turers. Before you set up a network to render effects created by third-party plug-ins, see 
your plug-in’s documentation or contact the plug-in manufacturer and get answers to the 
following questions:

• Does the plug-in’s license agreement allow installing multiple copies on a network for 
the purposes of rendering?

• Are there any other limitations or tips that apply to using that plug-in for network 
rendering?
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Working with overflow volumes
A situation in which After Effects reaches a disk space limit while rendering a composition 
is called an overflow. Specify this limit for Minimum Diskspace Before Overflowing in the 
Output Preferences dialog box. When After Effects overflows a volume, the resulting files 
go into a folder on the root of the next volume in the After Effects Overflows list. You can 
specify multiple volumes to which rendered compositions can be directed.

Overflow behavior occurs in the following instances:

• A drive fills up. In this case, After Effects tries the next drive on the Preferences list. 

• You have more than a specified number of sequence files in a folder. In this case, After 
Effects makes a new folder next to the current one and continues rendering images to 
the new folder.

• A single movie file is larger than a specified size. In this case, After Effects starts a new 
file next to the current one.

Note: It is important to look at the log file after rendering; the log file reports when a 
render overflows.

To specify overflow settings:

1 Choose Edit > Preferences > Output.

2 To set overflow volumes, choose the volumes you want from the Volume menus under 
Overflow Volumes.

3 To set a maximum number of files, select the Segment Sequences At option and type a 
maximum number of files.

4 To set a maximum movie file size before creating an overflow, select the Segment 
Movie Files At option, and then type a maximum file size.

5 Specify the minimum number of megabytes left on your volume before overflowing to 
the next volume, and then click OK.

Rendering movies at different sizes
You can create output in sizes other than the size of your rendered composition. For 
example, you can create a full-sized movie for recording to videotape and a smaller movie 
for use on CD-ROM or in an on-screen presentation.

Making a movie smaller than the rendered composition
Several methods exist for producing a reduced-size movie, each with trade-offs between 
speed and quality.

• Create a new composition at the smaller dimensions, and nest the large composition 
inside it. For example, if you create a 640 x 480 composition, you can place it in a 320 x 
240 composition. Scale the composition to fit the new smaller composition size, and 
collapse transformations by choosing Layer > Switches > Collapse. The resulting 
composition rendered at full resolution and best quality will have excellent image 
quality, better than if you had rendered using a reduced resolution.

• Stretch the movie. This method produces the highest quality reduced-size movie but is 
slower than nesting. For example, if you create a 640 x 480 composition and render it at 
full resolution, you can set the stretch value in Output Module Settings to 50% to create 
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a 320 x 240 movie. For a composition rendered at full resolution, the image quality is 
excellent when the Stretch Quality is set to High.

Note: Do not use stretching to change the vertical dimensions of a movie when field 
rendering is on. Stretching vertically mixes the field order, which distorts motion. Use 
either cropping or composition nesting if you need to vertically resize a field-rendered 
movie.

• Crop the movie. This method is ideal for reducing the size of a movie by a few pixels. Use 
the Crop options in the Output Module Settings dialog box. Remember that cropping 
cuts off part of the movie, so objects centered in the composition may not appear 
centered unless the movie is cropped evenly on opposite edges.

Note: Cropping an odd number of pixels from the top of a field-rendered movie reverses 
the field order. For example, if you crop one row of pixels from the top of a movie with 
Upper Field First field rendering, the field-rendering order then becomes Lower Field First. 
Remember that if you crop pixels from the top of the movie, you need to add to the bottom 
row of the movie to maintain the original size. If you are willing to lose one scan line, this 
gives you a way to output two movies from one render, each with a different field order. 
See “Using interlaced video in After Effects” on page 43 and “Field-rendering consider-
ations” on page 282.

• Render the movie at a reduced resolution. This is the fastest method to create reduced-
size movies. For example, if you create a 640 x 480 composition, you can set the compo-
sition resolution to one half, reducing the size of the rendered composition to 320 x 
240. You can then create movies or images at this size. Note that the reduced resolution 
reduces the sharpness of the image and is best used for creating preview or draft 
movies.

Note: When rendering at reduced resolution, set the quality of the composition to Draft. 
Rendering at Best quality while reducing resolution does not produce a clean image and 
takes longer to render than rendering at Draft quality.

Making a movie larger than the rendered composition
Increasing the size of the output from a rendered composition reduces the image quality 
of a movie and is not recommended. If you must enlarge a movie, to maintain highest 
image quality, always enlarge a composition that was rendered at full resolution and 
highest quality.

You can create a movie larger than the rendered composition using these methods:

• Create a new composition at the larger dimensions and nest the smaller composition 
inside it. For example, if you create a 320 x 240 composition, you can place it in a 640 x 
480 composition. Stretch the composition to fit the new larger composition size, and 
then collapse transformations by choosing Layers > Switches > Collapse. The resulting 
composition rendered at full resolution and best quality will have better image quality 
than if you had stretched the movie. However, this method also renders slower than if 
you created a composition and stretched it.

Note: To create a draft movie with specific dimensions, use both the Stretch option and 
reduced resolution in the rendered composition.

• Stretch the movie. For example, if you create a 320 x 240 composition and render it at 
full resolution, you can set the stretch value in the Output Module Settings dialog box 
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to 200% to create a 640 x 480 movie. For a composition rendered at full resolution, the 
image quality will usually be acceptable.

Note: Do not use stretching to change the vertical dimensions of a movie with field 
rendering. Stretching vertically mixes the field order, which distorts any motion. Use either 
cropping or composition nesting if you need to vertically resize a field-rendered movie.

• Crop the movie. To enlarge a movie by a few pixels, increase the size using negative 
values for the Crop options in the Output Module Settings dialog box. For example, to 
increase the size of a movie by 2 pixels, type –2 in the Cropping section of the Output 
Module Settings dialog box. Remember that negative cropping adds to one side of a 
movie, so objects originally centered in the composition may not appear centered 
when the movie is cropped.

Note: Adding an odd number of pixels to the top of a field-rendered movie reverses the 
field order. For example, if you add one row of pixels to the top of a movie with Upper Field 
First field rendering, the field-rendering order then becomes Lower Field First. Remember 
that if you add pixels to the top of the movie, you need to crop from the bottom row of the 
movie to maintain the original size. See “Using interlaced video in After Effects” on page 43 
and “Field-rendering considerations” on page 282.

Creating low-resolution movies for testing motion
You can test the motion of a high-quality composition by quickly creating a low-
resolution, or thumbnail, movie. Do this by making a movie at a resolution less than full 
(using the Resolution pop-up menu in the Render Settings dialog box). After Effects 
creates a movie with dimensions proportional to the resolution.

For example, if your composition is 640 x 480 pixels and you make a movie at quarter 
resolution, the resulting movie will be 160 x 120 pixels (one-sixteenth the size of the 
composition). This thumbnail renders almost 16 times faster than at full resolution. You 
can then play the thumbnail on your system to get a good idea of what motion will be like 
in your final, full-sized movie. You can also enlarge the thumbnail in a movie-playing appli-
cation to see playback at full size. In addition, you can use RAM preview for testing 
purposes.

Testing the field-rendering order
A simple test can determine the order in which your video equipment requires fields. 
When you make a movie, the rendering order (Upper Field First or Lower Field First) should 
be synchronized with the method used by your equipment, or your movie will appear 
distorted.

Note: The field order with which you record to video equipment can be altered by changes 
in the hardware or software of your production setup. For example, changing your video 
board, device control software, or VCR after setting the field order can reverse your fields. 
Therefore, any time you make a change to your setup, run this test for field-rendering 
order.

The test takes about 15 to 20 minutes and involves creating two movie versions of the 
same composition (one rendered with Upper Field First and one with Lower Field First), 
and then taping and playing the movies to see which choice looks right.
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To test field-rendering order:

1 Create a simple composition with the correct frame size and frame rate. Choose an 
NTSC or PAL preset in the Composition Settings dialog box, and make the composition at 
least 3 seconds long.

2 Within the composition, make a layer that is a small rectangular solid. The layer can be 
any color as long as it contrasts sharply with the composition background. You may wish 
to add a title such as “Upper Field First” to the solid, to make identification of the movie 
easier.

3 Apply some fast movement to the solid using keyframes in its Position property. Set 
keyframes from the upper left of the Composition window to the lower right, for 1 second.

4 Save the project, and then drag the composition to the Render Queue window.

5 Click the underlined Render Settings name, and then choose Upper Field First.

6 Click OK, and then click Render to make the movie.

7 In the composition, change the color of the solid in the Composition window, and add a 
new title such as “Lower Field First” to identify it.

8 Render the composition again, choosing Lower Field First.

9 Record both movies to videotape with the same device.

10 Play both movies.

One movie will look distorted and have jumpy horizontal motion or shape distortion 
during vertical motion. The other movie will play correctly, with sharply defined edges. 
The Field Render choice used for the correctly played movie is the choice you should use 
whenever you intend to record a movie with the setup you used in this test.
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Using Property and Tracking 
Controls (PB only)

Adding randomness (PB only)
You can add randomness to any property as it varies over time by using The Wiggler. (You 
can also use the wiggle expression to accomplish this. See “Property attributes and 
methods” on page 262.) Depending on the property and the options you specify, The 
Wiggler adds a certain number of deviations to a property by adding keyframes and 
randomizing interpolations coming into or out of existing keyframes. You need at least 
two keyframes to use The Wiggler. 

Using The Wiggler, you can more closely simulate natural movement within specified 
limits. For example, add randomness to an animated butterfly to produce fluttering. Add it 
to brightness or opacity to simulate the flicker of an old projector.

To add randomness to a property:

1 Select a range of keyframes for the property.

2 Choose Window > The Wiggler.

3 For Apply To, select the type of curve you want The Wiggler to change. If you selected 
keyframes for a property that varies spatially, you can select Spatial Path to add deviations 
to the motion, or Temporal Graph to add deviations to the velocity. If you selected 
keyframes for a property that does not vary spatially, you can select only Temporal Graph.

4 Select a Noise Type option to specify the type of deviation due to randomly distributed 
pixel values (noise):

• Smooth Noise produces deviations that occur more gradually, without sudden 
changes. 

• Jagged Noise produces sudden changes. 

5 Select the dimensions of the property you want to affect:

• One Dimension adds deviations to only one dimension of the selected property. 
Choose the dimension from the menu. 

• All Dimensions Independently adds a different set of deviations to each dimension.

• All Dimensions the Same adds the same set of deviations to all dimensions.

6 Set a Frequency to specify how many deviations (keyframes) per second After Effects 
adds to the selected keyframes. A low value produces only occasional deviations, while a 
high value produces more erratic effects. A value between 0 and 1 creates a keyframe at 
intervals of less than one per second. For example, a value of 0.5 creates one keyframe 
every 2 seconds.
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7 Set a Magnitude to specify the maximum size of the deviations. After Effects sets the 
specified magnitude to the units of the selected property, so a value for one property may 
produce very different results in another property.

8 Click Apply and preview the results.

9 If necessary, choose Edit > Undo The Wiggler to reset the keyframes, adjust the values 
for Frequency and Magnitude, and then reapply The Wiggler.

Simulating a zoom lens (PB only)
You can simulate a more realistic accelerating effect of a zoom lens when working with 2D 
layers by using Exponential Scale, which converts linear scaling of a layer to exponential 
scaling. This is useful for creating a cosmic zoom, for example. Zooming optically with a 
lens is not linear—the rate of change of scaling accelerates as you zoom. To simulate this 
acceleration, Exponential Scale converts the velocity of the scaling to an exponential 
curve.

To apply Exponential Scale:

1 In the Timeline window, hold down the Shift key and select starting and ending 
keyframes for the scale property.

2 Choose Animation > Keyframe Assistant > Exponential Scale.

Note: Exponential Scale replaces any existing keyframes between the selected starting 
and ending keyframes.

About tracking motion (PB only)
The Tracker/Stabilizer tracks motion by matching pixels from a selected area in the first frame 
to pixels in each succeeding frame, thereby following that motion. For example, suppose you 
have footage of a bareheaded person walking, and you’d like to add a hat to this person’s 
head. Use the Tracker controls to isolate the top of the head and track its motion in the first 
layer, and apply the tracked motion to an image of a hat in a second layer.
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Working with the Tracker/Stabilizer Controls (PB only)
The Tracker/Stabilizer is a panel added to the Layer window once you select the Tracker/
Stabilizer controls from the Layer window menu. The window displays the layer you 
selected to track. To specify an area for tracking, set a feature region, a search region, and a 
track point in the layer shown. The tracker tracks from the location of the current-time 
indicator. If the current-time indicator is outside the visible range of a trimmed clip, it 
tracks from the beginning to the end of the clip. If the current-time indicator is within the 
visible range of a clip, it tracks from the current-time indicator to the end of the visible 
range.

Controls for the Tracker/Stabilizer are described below:

A. Image area Displays the tracked image.

B. Tracking regions Specifies the search region, feature region, and track point you are 
tracking. (See “Defining tracking regions (PB only)” on page 307.)

C. Type menu Select whether you want to track or stabilize the image or track the image 
using either the affine corner pin or perspective corner pin options.

D. Analyze button Begins the tracking.

E. Tracking coordinates The first set of numbers in parentheses indicates the layer 
coordinates of the corners of the feature region. The second set of numbers in paren-
theses indicates the x and y coordinates of the track point. The number of coordinate 
groups listed here depends on the tracking type you choose. For example, if you choose 
Perspective Corner Pinning, then four groups of coordinates display, each group repre-
senting a particular feature region and track point.

F. Current-time marker Indicates the current time in the layer. 

G. The Tracker/Stabilizer controls work area Shows where tracking begins and ends. A 
black bar indicates tracked areas.

H. In and Out buttons Set the In point or Out point to the current time. 

I. Position and Rotation check boxes Select to track rotation, position, or both.

J. Apply button Click to apply keyframes to the appropriate layer or effect point.
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K. Tracking accuracy Indicates how accurately each feature region is tracking at the 
current time.

L. Options button Opens the Options dialog box, in which you further refine tracking. 
For details, see “Defining tracking settings (PB only)” on page 308.

M. Reset button Deletes tracking information.

Defining tracking regions (PB only)
Before tracking motion, define three tracking regions in the motion footage layer: a search 
region, a feature region, and a track point. Resize each region by dragging a handle. 

Make both regions as small as possible so that the Tracker/Stabilizer can more 
accurately and quickly track the selected region. Increasing the size of either region 

increases the time required for tracking.

A. Search region B. Feature region C. Track point

Search region Resize the box to define the area outside the feature region that the 
Tracker/Stabilizer uses to locate the tracked object or region in the next frame. Large 
feature movements between frames require a larger search region to accurately find and 
match the feature from one frame to the next.The box must be large enough to contain 
the largest possible movement of the feature region from one frame to the next. Although 
increasing the search region increases tracking time, it’s better for the search region to be 
too large than too small.

Feature region Resize the box to precisely define the element you want to track.

Track point Move the cross hair to specify the point of attachment between the tracked 
area and the second layer. The Tracker/Stabilizer generates keyframes for the specified 
track point and copies them to the position property of the second layer; when you play 
back the layers, the second layer is attached to the track point of the first. If you are stabi-
lizing a layer, the Tracker/Stabilizer copies the tracking data to the stabilized layer’s anchor 
point. If you are attaching an effect instead of a second layer, the Tracker/Stabilizer copies 
the keyframes to the specified effect point. You can place this effect point anywhere in the 
image. The cross hair is not visible when the tracker is in stabilize mode, because the track 
point is always the center of the feature region.

To move the search region, feature region, and track point all at once, drag between 
the handles of the feature region. To move the feature region without moving the 

track point, Alt-drag (Windows) or Option-drag (Mac OS) the feature region.
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Defining tracking settings (PB only)
Use the Options dialog box, available from the Tracker/Stabilizer Controls, to specify the 
second layer or the effect, and to define other tracking settings. The controls are as 
follows:

Layer menu Specifies the layer you want to attach to the tracked layer.

Effect Point Control menu Specifies an effect to attach to the track point. Note that you 
can attach only those effects that have position properties.

Frames per Second Specifies a frame rate for tracking. In general, the tracking frame rate 
should match the frame rate of the footage, which should match the composition’s frame 
rate. 

If you are attaching a motion graphic to the tracked area, be sure to match the frame 
rates of the two layers.

Track Fields Tracks the motion in both video fields of interlaced video. The Track Fields 
option doubles the frame rate to ensure that both video fields are tracked. 

Track in Reverse Tracks backward in time. For example, if you are tracking an object that 
comes in from off-screen, you can define your tracking regions at the end of the clip and 
then track backward in time.

Use Specifies the type of comparison method to use for tracking an object in subsequent 
frames. RGB bases tracking on all three color channels. Luminance compares the contrast 
in brightness values in the tracking region. Saturation looks at how much color is present 
in the tracking region.

Process Before Match Blurs or sharpens an image to enhance the search capabilities. 
Select Blur to specify the number of pixels that the Tracker/Stabilizer blurs before 
processing a match. Blurring temporarily reduces noise in the footage to help produce 
better tracks. 

Note that blurring occurs only for the purpose of tracking. The footage is restored to its 
original clarity after tracking. Usually a value of 2 to 3 pixels can help produce better tracks, 
especially on grainy or noisy footage. Enhance exaggerates the edges of an image to 
make them easier to track. 

Track Adaptiveness Controls how much of the original frame and the following frame 
are used for matching. A value of 100% means that the Tracker/Stabilizer updates the 
feature information from one frame to the next, based on the location of the feature 
region. A value of 0% means that the Tracker/Stabilizer uses feature information from only 
the original image when matching each subsequent frame. Use larger values if your 
feature changes shape, color, or brightness during the tracked frames. Use smaller values if 
the feature doesn’t vary across the tracked frames or if subpixel drifting is a problem. 

Extrapolate Motion if Accuracy is Below _% Specifies a tolerance level that determines 
when the Tracker/Stabilizer extrapolates the motion of hidden objects. If the accuracy 
percentage falls below the specified tolerance, the Tracker/Stabilizer extrapolates the 
position of the feature region while it is obscured by another object. For example, if you 
track a dog that walks behind a person, the Tracker/Stabilizer can estimate the position of 
the dog in those frames where it is obscured. 
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Subpixel Matching Divides each pixel in the feature region into smaller divisions. The 
Tracker/Stabilizer tracks a selected feature region by matching pixels and fractions of 
pixels from one frame to the next. The smaller the fraction, the more accurately the 
Tracker/Stabilizer tracks the selected region. Depending on the size of the feature region, 
however, selecting a small pixel fraction can significantly increase the tracking time.

Save button Saves a data file that contains the currently selected options, positions for 
the feature region, search region, and track point, and any tracked areas for the layer.

Load button Loads a saved tracking data file.

Tracking different types of motion (PB only)
The Tracker/Stabilizer can track five different kinds of motion—position, rotation, position 
and rotation, affine corner pinning, and perspective corner pinning. For each type of 
motion, define one or more tracking regions. If you switch between tracking types, the 
Tracker/Stabilizer retains the track points, tracker settings, and tracking data of your last 
track type, and displays them correctly the next time you choose that track type. 

Tracking position (PB only)
When you track position, you are attaching a layer or an effect to a single point. The 
attached layer floats over (or under) the tracked point and is not distorted or skewed to 
simulate perspective. For perspective, use perspective corner pinning. For more infor-
mation, see “Tracking position using perspective corner pinning (PB only)” on page 311.

To define tracking regions for position:

1 Size the feature region to include only the object you are tracking.

2 Size the search region to accommodate the movement you are tracking. If the motion is 
jumpy and sudden in one or more directions, stretch the search region in those directions, 
so that the Tracker/Stabilizer can accurately find and match the suddenly shifting pixels. If 
motion is smooth in all directions, you can size the search region to be just outside the 
feature region, to minimize tracking time.

3 Drag the track point anywhere within the layer. If you want to attach the second layer 
directly on top of the feature region, place the track point in the center of the feature 
region. If you find that the second layer is not positioned correctly during tracking, you 
can stop the track and adjust the track point by dragging it and, if necessary, monitoring 
the tracking coordinates (for details on the tracking coordinates, see “Working with the 
Tracker/Stabilizer Controls (PB only)” on page 306). After you apply the tracking to the 
second layer, you can also adjust the layer’s anchor point to reposition it.

Tracking rotation (PB only)
When you track rotation, you duplicate the rotation of a specified region in one layer in 
another layer. When tracking only rotation, the Tracker/Stabilizer does not track position 
but generates only rotation keyframes for the second layer. In other words, the second 
layer is not attached to the first; the second layer remains in the position you have 
specified in the composition, rotating relative to the specified region’s arc of rotation.
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The rotation in the first layer is defined by two feature regions and the axis that runs 
between them. An arrow on the axis points from the first feature region to the second. The 
Tracker/Stabilizer tracks the rotation by measuring the angle of the axis in relation to the 
first feature region: as either feature region moves, the angle of the axis changes. Note that 
even if the objects tracked inside both feature regions are moving up, down, or across, the 
Tracker/Stabilizer tracks only the relative rotation between the regions, not the overall 
movement. Because the second layer is not attached to the first, there is no track point.

To define tracking regions for rotation:

1 Place the first feature region (on the left by default) over the object you want to specify 
as the base of the axis. Rotation is measured relative to the center of this region. If the 
object is moving, size the search region appropriately. 

2 Place the second feature region over the object that defines the angle of rotation. Size 
the search region appropriately.

Tracking position and rotation (PB only)
When you track both position and rotation, you attach a layer to a single track point, so 
that the attached layer not only follows the tracked region but also duplicates the 
rotation. This type of tracking is useful when the feature regions contain a lot of motion. 
With position and rotation, the track point is fixed in the center of the first feature region. 
To adjust the position of the attached layer, adjust its anchor point after applying the 
tracking. 

To define tracking regions for both position and rotation:

1 Size the first feature region (on the left by default) over the object you want to track. 
The second layer is attached to the center of this region. This region defines the base of 
the axis. 

2 Size the second feature region over the object that defines the angle of rotation.

3 Size both search regions appropriately.

Tracking position using affine corner pinning (PB only)
When you track position using affine corner pinning, you simultaneously track three 
points in a motion footage layer with three points in a second layer. The position of a 
fourth, inactive point is determined by the three active points. As the three points move, 
the layer is distorted to simulate skewing, scaling, and rotation, but not perspective. 
Parallel lines remain parallel, and relative distances are preserved. For example, suppose 
that you have footage shot by a handheld camera that zoomed in or out during shooting 
but remained perpendicular to the background; you want to replace the background. 
Using affine corner pinning, the Tracker/Stabilizer calculates the relative movement 
between the feature regions and track points to create the correct scaling of the 
background.
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Place the track points anywhere in the motion footage layer; they do not need to be in the 
center or in the corner of the feature regions. The Tracker/Stabilizer applies the Corner Pin 
effect to the second layer, generating keyframes for the layer and Corner Pin effect 
keyframes for each corner.

When you choose affine corner pinning, the default positions of the track points form a rectangle in 
the center of the motion footage layer (left). Moving the upper left tracking region moves the lower 
right (inactive) tracking region in tandem (center). You can place the track points anywhere in the 
motion footage layer (right).

To define tracking regions for affine corner pinning:

1 Specify the tracking region that will be inactive by Alt-clicking (Windows) or Option-
clicking (Mac OS) the region.

2 Place and resize the three active feature and search regions over the areas you want to 
track. 

3 Place the three track points at the locations where you want to attach the three corners 
of the second layer. You can place the track points in the center, in the corner, or outside 
the feature regions.

In this sequence, the three active feature regions are placed on three corresponding markers in the 
motion footage layer. Each search region is slightly extended in the direction of its track point’s 
motion. The track points are placed in the center of the feature regions.

Tracking position using perspective corner pinning (PB only)
When you track position using perspective corner pinning, you are simultaneously 
tracking four points in a motion footage layer with four corners in a second layer. As the 
four points move, the layer is distorted to simulate perspective. The Tracker/Stabilizer 
applies the Corner Pin effect to the second layer, generating keyframes for the layer and 
Corner Pin-effect keyframes for each corner.
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As with affine corner pinning, you can place the track points for perspective corner 
pinning anywhere in the motion footage layer; they do not need to be in the center or in 
the corner of the feature regions. For example, if you are replacing a sign on the side of a 
moving bus, the edges of the sign may be partially obscured because of shadows or 
objects; but a window on the bus may be visible throughout the footage. You can first 
define four feature regions that are distinct and easy to track, and then move the track 
points to the four corners of the sign. When the new image appears in the sign, the 
Tracker/Stabilizer calculates the relative movement between the feature regions and track 
points to create the correct perspective.

When you choose perspective corner pinning, the default positions of the track points form a 
rectangle in the center of the motion footage layer (left). Moving each feature region extends the 
rectangle in the direction of motion (center). You can place the track points anywhere in the motion 
footage layer (right).

Fine-tune the motion of the individual corner pins within the Layer window by dragging 
the feature regions and noting the changes in the corresponding tracking coordinates. 
See “Working with the Tracker/Stabilizer Controls (PB only)” on page 306 for details on 
tracking coordinates.

To define tracking regions for perspective corner pinning:

1 Size feature and search regions on separate areas that you want to track in the motion 
footage layer. All four feature regions should lie in a single plane in the real world (for 
example, on the side of a bus, on the same wall, or on the floor). The four track points must 
also lie in a single plane, but not necessarily the same plane as the feature region.

2 Place the four track points at the locations where you want to attach the four corners of 
the second layer. You can place the track points in the center, in the corner, or outside the 
feature regions.

Attaching an effect to a tracked location (PB only)
You can also use the Tracker/Stabilizer to apply an effect point to a tracked location. Just as 
you would attach a second layer to a tracked region, attach an effect point to a tracked 
region. The effect then follows the tracked region. For information on effect points, see 
“Placing an effect using effect points” on page 174.



Using Help | Contents | Index Back 313  

Adobe After Effects Help Using Property and Tracking Controls (PB only) 

Using Help | Contents | Index Back 313  

Tracking a moving region or object (PB only)
For best results, first prepare the object or region you are tracking before you begin 
filming. Because The Tracker/Stabilizer compares pixels from one frame to the next to 
produce an accurate track, attaching high-contrast markers to the object or region lets 
After Effects more easily follow the motion from frame to frame. Lightweight, brightly 
colored balls, such as Ping-Pong balls placed on the feature, work particularly well to 
preserve the shape of the track point. The number of markers you use corresponds to the 
number of points you are tracking. 

If you are not able to attach markers, choose a high-contrast region or object. 

To track a moving region or object:

1 Select the motion footage layer you want to track and open it in a Layer window. You 
must have at least two layers in the Composition window.

Note: The Tracker/Stabilizer can track either an original motion footage layer or a precom-
posed layer that includes additional effects or other properties in the composition. 

2 In the Layer window menu, choose Tracker/Stabilizer Controls.

3 In the Track and Stabilize section, click the Type pop-up menu and choose one of the 
following:

• Choose Track to track the motion of a layer.

• Choose Affine Corner Pin to track three points in a motion footage layer.

• Choose Perspective Corner Pin to track four points in a motion footage layer.

4 Next to the Type pop-up menu, select either the Position or Rotation box, or both, 
depending on what you want to track.

5 In the Tracker panel, specify the work area you want to track by dragging the In and Out 
points to the desired locations.

6 Drag the current-time marker to the point you want tracking to begin.

7 Define the feature region, search region, and track point, as described in “Defining 
tracking regions (PB only)” on page 307.

8 Click Options to specify the second layer or effect and to define other tracking settings, 
as described in “Defining tracking settings (PB only)” on page 308, and then click OK.

9 In the Tracker panel, click Analyze. Watch the tracking to make sure it is accurate. If not, 
press any key to stop the tracking, and then correct the problem as described in 
“Correcting a drifting feature region (PB only)” on page 314. A black line appears in the 
time bar, indicating the portion of the layer that has been tracked. Keyframes are not 
generated until you click Apply.

10 To track multiple areas in the same layer, repeat steps 3 through 8 for as many areas as 
you need. If you track a previously tracked area within the same track type, After Effects 
generates new track data for the area. 

11 When you are satisfied with the track, click Apply to generate keyframes for the 
selected layer or effect point control you are attaching.
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To delete a tracked area:

1 Reposition the In and Out points to include only the area of the track you want to 
delete.

2 Press the Delete key. After Effects deletes only the tracked area between the In and Out 
buttons.

Correcting a drifting feature region (PB only)
There are two main methods for realigning a feature region if it drifts off track during 
tracking. If most of the footage tracked accurately, you may need only to move the feature 
region in selected frames. If drifting occurs early in the footage, you can modify the 
tracking settings and then track again from the beginning. 

Under certain conditions, you can correct drifting by simply enlarging the search region 
(for example, if the search region is too small to contain erratic movement of the feature 
region from one frame to the next). Note that increasing the size of the search region 
increases the tracking time.

To correct drifting by moving the feature region:

1 Drag the current-time indicator to the last well-tracked frame.

2 Do one of the following:

• To correct a single frame, drag the feature region or track point to new locations. Alt-
drag (Windows) or Option-drag (Mac OS) the feature region to move it without moving 
the track point. Use the Details section of the window to monitor the feature region 
position. The tracker automatically updates the previous tracking data to this new 
feature region/track point position. 

• To correct several contiguous frames, drag the feature region or track point to new 
locations as described above and click Analyze. Watch the tracking to make sure it is 
accurate. If not, press any key to stop tracking, adjust the feature region, and begin 
again. 

3 To preview tracking, press the spacebar.

4 When you are satisfied with the track, click Apply to copy keyframes to the selected 
layer. 

To correct drifting by modifying tracking settings:

1 Drag the current-time indicator to the last well-tracked frame.

2 Click Options and change the following settings:

• If colors change in the feature region, increase the Track Adaptiveness value.

• Select Process Before Match, select Blur, and then type a value of 2 to 3 pixels. Select 
Enhance if the edges of the feature are fuzzy. Deselect the Blur option if you want to use 
Subpixel Matching. 

• Choose a value from 1/2 to 1/16 for Subpixel Matching. A smaller fraction increases the 
accuracy of the tracker but also increases tracking time. 

• If the area to be tracked has high contrast, change the Use option to Luminance. Try 
Saturation if the area has a high concentration of color.

• If the area is partially obscured during tracking, set a tolerance value for Extrapolate 
Motion if Accuracy Is Below_%. Determine the proper value by creating a trial track and 
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then examining the accuracy displayed in the Tracker controls panel for any frames 
with an obscured feature region. Type a value that is slightly larger than the largest 
accuracy value for the problem frames.

• If you can clearly track backward from some point at the end of the motion, select Track 
in Reverse. When used with forward tracking, Track in Reverse can help isolate problem 
areas where the Tracker controls can’t maintain a good track.

3 Click OK in the Motion Tracker Options dialog box and, in the Tracker panel, click 
Analyze. Watch the tracking to make sure it is accurate. If not, press any key to stop 
tracking, adjust the settings, and begin again. 

4 To preview tracking, press the spacebar.

5 When you are satisfied with the track, click Apply to copy keyframes to the selected 
layer.

Stabilizing motion (PB only)
If you shoot with a handheld or airborne camera, or bump a camera during shooting, you 
may need to stabilize footage. The Stabilizer controls track the specified range of bumpy 
motion and then adjust the layer’s anchor point or rotation. When played back, the motion 
appears smooth because the layer itself moves incrementally to offset the unwanted 
motion. 

Track a bright, stationary object in the range of footage you are stabilizing, to ensure that 
you are stabilizing only unwanted motion. If the size of your motion footage layer is the 
same as or smaller than the size of the composition, frame the layer to hide its edges by 
precomposing it. Otherwise, the offset motion that the Stabilizer controls create for the 
layer will be visible.

Like the Tracker, the Stabilizer tracks position, rotation, or both. If you track position, the 
Stabilizer controls generate keyframes for the layer’s anchor point, offsetting the position 
of the object you tracked. If you track rotation, the Stabilizer controls generate rotation 
keyframes for the layer, offsetting the rotation you tracked.

To stabilize motion:

1 Select the motion footage layer you want to stabilize and open it in a Layer window.

2 In the Layer window menu, choose Tracker/Stabilizer Controls.

3 In the Track and Stabilize section, click the Type menu and choose Stabilize.

4 Next to the Type menu, choose the motion that you want to stabilize.

5 Specify the work area you want to track by moving the current-time marker and using 
the In and Out buttons to set In and Out points. Make sure that the first frame you track is 
stable. Position and rotation in subsequent frames will be adjusted relative to the first 
frame. 

6 Define the feature region, search region, and track point, as described in “Defining 
tracking regions (PB only)” on page 307.

7 Click Options to define other tracking settings, as described in “Tracking a moving 
region or object (PB only)” on page 313.
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8 In the Motion Stabilizer panel, click Analyze. Watch the tracking to make sure it is 
accurate. If not, press any key to stop tracking, adjust the settings, and begin again. 
Keyframes are not generated until you click Apply.

9 When you are satisfied with the track, click Apply to copy keyframes to the layer.

10 To stabilize one or more additional time ranges in the layer, follow the steps for 
tracking multiple areas, as described in “Tracking a moving region or object (PB only)” on 
page 313. You can stabilize as many ranges as you need.

If the image creeps in from the margins of the action-safe zone, increase the scale just 
enough to extend past the margins. Find the frame that creeps in the most, and then 

nudge the scale (in the Composition window) using the Alt + + (plus) and Alt + – (minus) 
keys on the numeric keypad (Windows), or the Option + + (plus) and Option + – (minus) 
keys on the numeric keypad (Mac OS). This technique adjusts the scale for the duration of 
the footage.
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Using Motion Math (PB only)

Using Motion Math (PB only)
Use Motion Math to write and run scripts that use a special language and mathematical 
equations to generate keyframes. Motion Math can create complex changes for any 
property, using scripts included with the Production Bundle or scripts that you write.

Motion Math scripts create motion or effects by applying mathematical equations to 
specified layers, properties, and other values and then automatically generating 
keyframes. Even a basic equation can simplify the creation of complex effects that might 
otherwise require painstakingly specifying individual keyframes. More complex manipula-
tions of keyframes using Motion Math requires a basic understanding of how formulas 
work, how approximate values will be derived from the formula, and how these values will 
affect the keyframes to which they are assigned.

Scripts are written in the Motion Math language, a simplified version of the widely used 
C programming language. The Motion Math language provides these basic programming 
tools: assignments, if statements, loops, and numerous math functions, including those 
for trigonometry, the natural logarithm, and vectors.

Using Expressions instead of Motion Math (PB only)
Many of the effects created using Motion Math can now be created using Expressions. For 
example, instead of running the Copy Values script to link different properties, simply click 
the Expression’s pick whip, and drag it from one property to another. For information on 
expressions, see “Using expressions” on page 244.

For some effects, however, it may be easier to use Motion Math. For example, to 
synchronize audio and property changes, you may find it more efficient to use the Motion 
Math script Layeraud.mm than to write your own expression. Also, the Scale All Layers 
script makes it easy to automatically scale and position objects correctly, whereas to 
replicate the effect using expressions requires two separate expressions for each layer. 



Using Help | Contents | Index Back 318  

Adobe After Effects Help Using Motion Math (PB only) 

Using Help | Contents | Index Back 318  

Working in the Motion Math window (PB only)
All of your work running, editing, and writing scripts occurs in the Motion Math window. In 
this window, you load a new script, save a script you’ve written, and apply a script to a 
composition. When you first open the Motion Math window, the Copy Values script 
appears. You can use this script as it is, edit it, or load a new script.

The Copy Values script A. Script editor B. Language element menus  
C. Layer, Property, and Channel menus D. Error notification area

Note: When you rerun a particular script on the same elements and time range, Motion 
Math generates new keyframes in place of the old ones in the current work area.

Motion Math scripts included with the Production Bundle 
(PB only)
Several prewritten scripts, along with sample movies, are available from the After Effects 
CD. Each script creates keyframes for specified properties and channels in one of two 
layers, depending on the motion or effect you want. Most of the prewritten scripts create 
new keyframes automatically, but you can use some scripts to change the values of 
existing keyframes. By changing the scale factors or variable numerical values in the 
scripts, you can achieve the effect you want. As you experiment with the prewritten 
scripts, you will learn more about the Motion Math scripting language, and you will gain 
the confidence to create and save your own scripts. Scripts are named using a .mm 
extension.

The After Effects CD provides the following prewritten scripts and movies:

Apply from Effect Point (frmeffct.mm and frmeffct.mov) Copies the values of an effect 
point from one layer, multiplies them by a scale factor, and then creates position 
keyframes in a second layer using the new values. 

Apply to Effect Point (toeffect.mm and toeffect.mov) Copies the horizontal or vertical 
(or both) position values of one layer, multiplies them by a scale factor, and then creates 
specified effect keyframes in a second layer using the new values. 

A

C

B

D
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Blink (blink.mm and blink.mov) Varies the opacity using the cosine function, cycling 
through a specified range of opacity percentages, and then creates keyframes for the 
specified layer’s opacity. 

Comp Audio (cmpaud.mm and cmpaud.mov) Copies the values of the audio amplitude 
of the combined audio for all layers in a composition, multiplies them by a specified scale 
factor, and then creates keyframes for the specified property using the new values. 

Copy Relative Values (parallax.mm and parallax.mov) Multiplies relative values of a 
property in one layer by a scale factor and then copies them to a second layer. 

Copy Values (copyvalu.mm and copuvalu.mov) Copies specified property values from 
one layer, multiplies them by a scale factor, and then applies the new values to a second 
layer. This script appears by default when you first open the Motion Math window. 

Double Spring (dbspring.mm and dbspring.mov) Simulates the motion of two objects 
attached to the ends of a spring and creates position keyframes for both layers. If you have 
created position keyframes for either layer before the start of the work area, the velocity of 
each layer at the start of the work area is included with the motion of the layer.

Gravity (gravity.mm and gravity.mov) Applies both a gravitational and a frictional force 
to a specified layer. 

Layer Audio (layeraud.mm and layeraud.mov) Copies the values of the audio 
amplitude of a single layer, multiplies them by a specified scale factor, and then creates 
keyframes for the specified property using the new values.

Point At (pointat.mm and pointat.mov) Creates rotation keyframes for one layer, 
keeping the top of its y-axis pointing at the anchor point of the other layer. Both layers can 
be moving.

Relative Corner to Absolute Corner (cornpin.mm and cornpin.mov) Bases the motion 
path of the layer on the position of the corner-pin keyframes instead of on the anchor 
point. In other words, this script makes the motion paths of the corner pins relative to the 
composition.

Scale All Layers (scaleall.mm and scaleall.mov) Scales both the size and position of all 
selected layers. Use this script to resize all layers in a composition by the same amount.

Scale Layers by Comp Size (scaleby.mm and scaleby.mov) Scales layers in a compo-
sition to new sizes and positions based on new composition dimensions. Use this script to 
resize layers proportionally after changing the dimensions of a composition. 

Span (span.mm and span.mov) Attaches each end of a third layer to the anchor point of 
the two moving layers, creating position, rotation, and scale keyframes for the third layer, 
as necessary. 

Spring (spring.mm and spring.mov) Simulates the motion of one object dragging 
another with a spring attached between them. This script creates position keyframes for 
only one of the two layers.
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Running and editing existing scripts (PB only)
The following procedure outlines the overall process for loading and running a script. 
Note, however, that each of the prewritten scripts varies slightly in its application. Editing 
existing scripts makes it easy to create unique effects for your composition. After editing 
an existing script, make sure that you save the script to a different name so the original 
script stays intact.

To run a script:

1 Open the composition and set the work area to the time span over which you want 
Motion Math to create keyframes.

2 Select a layer.

3 Choose Layer > Keyframe Assistant > Motion Math. The Copy Values script appears by 
default in the script editor the first time you start Motion Math.

4 To run a different script, click the Load button, and locate the script you want to run.

5 Select the script, and click Open. The script you selected appears in the script editor.

6 Use the Layer, Property, and Channel menus to select the elements that will have 
keyframes generated or modified by the Motion Math script.

7 Specify how Motion Math generates keyframes:

• Sample At creates the specified number of new keyframes per second. To keep the 
number of keyframes manageable, type 10 or fewer.

Note: When you choose Sample At, Motion Math deletes and replaces any existing 
keyframes in the work area for the specified property and layer. Keyframes outside the 
work area are not affected.

• Sample Only at Existing Keyframes creates no new keyframes but changes the values of 
existing keyframes.

8 Click Apply, and then preview the result.

9 To modify or reapply the motion or effect, reopen the Motion Math window, change 
your selections in step 7, adjust the scale factor as needed, and then click Apply.

10 To save the changes you’ve made to the script, click Save, and then type a new name 
for the script.

In addition to specifying the number of new keyframes per second, you can reduce 
the number of keyframes by applying The Smoother. See “Smoothing motion and 

velocity” on page 107.

Writing your own scripts (PB only)
The Motion Math language provides all the necessary statements, functions, and 
operators for constructing both simple and complex scripts. To write your own scripts, you 
should have some basic knowledge of programming and mathematics.
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Motion Math scripts use the Motion Math language, a simplified version of the C 
programming language. You can write scripts in the Motion Math script editor, or you can 
write them in any text editor and then load them into the Motion Math script editor. When 
writing scripts in Motion Math, the language element menus help you more easily create 
statements. See “Using the language element menus (PB only)” on page 329.

Note: To ensure that After Effects can properly run your script, make sure that the script’s 
file size does not exceed 32K.

Saving a script (PB only)
Once you have modified an existing script or written one from scratch, you can save it for 
future use.

To save a script:

1 In the Motion Math window, click the Save button.

2 Type the name of the script you want to save. Scripts are saved with a .mm extension.

Controlling the built-in loop (PB only)
When writing scripts, note that Motion Math runs a script using a built-in loop, cycling 
through it at a sampling rate you specify in the Motion Math window.

For example, if you type a Sample At rate of 15 samples per second, Motion Math runs the 
script 15 times each second over the range of the selected work area. If the work area is 4 
seconds, Motion Math runs the script 60 times, creating 60 keyframes for one or more 
properties. Motion Math also includes a loop statement for use inside scripts so that you 
can repeat a statement or series of statements more frequently than the sample rate.

The values of keyframes created by Motion Math are based on the values of variables at 
the time of the sample. To base the values of keyframes on some other time, use the tmap 
() function (see “Motion Math language reference (PB only)” on page 329).

Assignments and operators (PB only)
Assignments are the core of any Motion Math script, used to assign values or expressions 
to variables and create keyframes for specified properties. Create assignments using 
standard mathematical operators, such as the plus sign (+) for addition and the asterisk (*) 
for multiplication. Operators available in Motion Math are listed in “Mathematical 
operators (PB only)” on page 331.

Motion Math uses three types of assignments: those that assign a specific value to a 
variable, those that assign an expression to a variable, and those that create or modify 
keyframes. The following example shows the most basic type of assignment, which 
assigns a specific value on the right to a variable on the left:

length = 2.1;

Each assignment in Motion Math must end with a semicolon, which indicates that the 
assignment is complete. 

The second type of assignment assigns an expression to a variable, as shown in the 
following example:

L1 = length * 10;
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The third type of assignment creates a keyframe by placing the value function or the 
effect_value function on the left. In the following example, the value function creates a 
rotation keyframe in layer 1 from the current value of the variable angle: 

value (layer1, rotation) = angle;

For a description of the value function, see “Layer property functions (PB only)” on 
page 322.

Numbers (PB only)
In Motion Math scripts, numbers must be expressed either as whole numbers or as 
decimals. Numbers between –1 and 1 must be expressed with the preceding 0. For 
example, the value .5 must be expressed as 0.5.

Variables (PB only)
In Motion Math, variables do not need to be declared a particular type, such as integer or 
vector. Variables automatically assume the types you assign them. For example, if the 
variable P1 is assigned the value of sin(a), P1 is automatically a real or floating point 
number, in radians. If V1 is assigned a two-dimensional vector, such as {2, 7}, then V1 
automatically becomes a vector with values 2 and 7 for its dimensions. For more infor-
mation about vectors, see “About vectors (PB only)” on page 327.

The names of variables must adhere to the following requirements:

• Must start with a letter, but can contain numbers after the first letter.

• Cannot contain a space or operators.

• Cannot be x or y, since this would conflict with vector indexing (see “About vectors (PB 
only)” on page 327). However, the name can contain the letter x or y.

In addition, the Motion Math language is not case-sensitive. For example, the variables 
circle, CIRCLE, and Circle are identical in Motion Math.

Layer property functions (PB only)
Using layer property functions, you can obtain values of specified properties or create 
keyframes, depending on how the properties and keyframes are used in an assignment. A 
layer property function uses the following format:

function () 

The function acts on variables inside the parentheses and then returns a value. For 
example, the function value (layer, property) obtains a value for the specified property in 
the specified layer at the currently sampled frame.

Motion Math includes three different types of layer property functions: 

Functions that obtain only values Functions such as time () or comp_audio_amplitude 
() can be used only on the right side of an assignment. In the following example, the 
current time is assigned to the variable T1:

T1 = time ();

Functions that can either obtain a value or create a keyframe Three functions obtain 
values or create keyframes, depending on which side of an assignment they are placed on:

value()

velocity()

effect_value()
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When used on the right side of an assignment, the functions obtain values of specified 
properties and channels in a specified layer. In the following example, the current value of 
the Position property in the layer called square1 is multiplied by 1.5, and the result is 
assigned to the variable V1:

V1 = value (square1, position) * 1.5;

When used on the left side of an assignment, the functions create or modify keyframes. In 
the following example, a rotation keyframe with a value of 60 is created for the layer called 
arrow1: 

value (arrow1, rotation) = 60;

Functions that obtain a value from the menus Three functions obtain values from the 
Layer, Property, and Channel menus:

pop_layer()

pop_property()

pop_channel()

These functions can be used on either side of an assignment. In the following example, 
the name of the layer selected in the second Layer menu is assigned to the variable L2. 

L2 = pop_layer (2);

If menu functions are used on the left side of an assignment, they must be inside another 
function. In other words, you cannot assign a value directly to a menu function. In the 
following example, the Scale property in the layer specified by the pop_layer function is 
assigned the value of 10:

value (pop_layer (1), scale) = 10;

Using these menu functions makes it easy for other users to run the script by selecting 
layers, properties, and channels from the menus. For more information on these functions, 
see “Using the Layer, Property, and Channel menus (PB only)” on page 328.

If statements (PB only)
Use If statements to create a conditional portion of the script, which Motion Math 
executes only if a specified condition is true or false. The If statement uses the following 
format:

if (condition)

 statement;

else

 statement;

You can also include multiple statements inside the If statement, using braces to group 
them:

if (condition) {

 statement 1;

 statement 2; 

} else {

 statement 3;

 statement 4; 

}
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If the condition is true, Motion Math executes the statement before the else clause. If the 
condition is false, Motion Math executes the statement after the else clause. In the 
following example, if the current time is less than 0.5, Motion Math creates a scale 
keyframe with a value of 0.3. If the current time is equal to or greater than 0.5, then Motion 
Math creates a scale keyframe with a value of 1.5:

if (time() < 0.5)

 value(solid_1, scale) = 0.3;

else

 value(solid_1, scale) = 1.5;

The condition inside the parentheses must contain logic operators, which are described in 
“Logical operations (use If statements) (PB only)” on page 332. To create compound logical 
statements, you can use the logical operators for AND, OR, and NOT. To compare values, 
you must use the == operator. In the following example, the time must equal 1 second for 
the first statement to be evaluated:

if (time () == 1)

 statement;

else

 statement;

Because Motion Math runs an entire script multiple times at the specified sampling rate, 
you may need to use the If statement to set parameters at the beginning of the work area, 
as shown in the following example:

if (time () == start_time)

 statement;

else

 statement;

The statement before the else clause can set an initialization value; statements after the 
else clause create motion or effects.

In some cases, you may not need to use the else clause. Without an else clause, the 
statement immediately following the if clause is executed if the condition is true, and is 
not executed if the condition is false.

Loops (PB only)
Although Motion Math runs a script using a built-in loop specified by the sampling rate, 
you can also include loops inside scripts, using the following format:

while (expression) {

statement; 

}

Statements contained inside the braces are repeatedly evaluated until the expression is no 
longer true. In the following example, the loop cycles through each layer in the compo-
sition, creating a scale keyframe with a value of 35:

n = 1;

while (n <= num_layers) {

value(n, scale) = 35;
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n = n+1; 

}

To prevent infinite loops, Motion Math stops a loop after 32,000 cycles. You can also stop a 
loop by pressing the Escape key (Windows) or both the Command and . (period) keys (Mac 
OS) while the script is running.

Constants (PB only)
Motion Math treats certain functions as constants for the duration of the work area. 
Constants always return the same value in the same composition and work area. For 
example, the constant comp_width obtains the width of the composition, which does not 
vary. Because you cannot assign new values to constants, they can be used only on the 
right side of an assignment. In the following example, the height of the composition is 
assigned to the variable H1:

H1 = comp_height;

For a list of constants in Motion Math, see “Constants (PB only)” on page 331.

Math functions (PB only)
Motion Math provides a number of math functions, including logarithms, trigonometry, 
and vector functions. Math functions always require variables or expressions in order to 
obtain a value, using the following format:

function (variable)

Some math functions require vectors as variables, while others require integers or rational 
numbers. For a list of math functions available in Motion Math, see “Math functions (PB 
only)” on page 330. For more information about vectors, see “About vectors (PB only)” on 
page 327.

Comments (PB only)
Use comments in scripts to describe or identify portions of the script. To insert a comment 
in a line of script, precede it with two slash marks (/ /). Any characters appearing after the 
two slash marks are ignored by Motion Math when you run the script. In the following 
example, the comments appear on the same line as an assignment:

scale_factor = 1.0; // Increase or decrease scaling by editing the 
number

Specifying layers and properties (PB only)
To specify a layer in a script, type its name as it appears in the Timeline window. If the 
name contains a space, you must enclose the name in quotes. For example, the layer name 
Red Boat must be specified as “Red Boat” in the script.

For functions that require a property, you can specify, by name, any of the following 
default properties: mask feather, anchor point, position, scale, rotation, and opacity. When 
specifying properties with two words, such as anchor point, enclose them in quotes, as 
shown in the following example:

value (circle, "anchor point") = value (square, "anchor point") * 
1.5;
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To specify effect properties, use either the pop_property function or the effect_value 
function. The pop_property function obtains the value of the property currently selected 
in the specified Property menu. After you select a layer and load a script into Motion Math, 
both Property menus list all properties for all effects in the selected layer. For more infor-
mation on using the pop_property function, see “Using the Layer, Property, and Channel 
menus (PB only)” on page 328.

The effect_value function obtains a value for an effect property or creates a keyframe for 
an effect property, depending on which side of an assignment it is used. The effect_value 
function uses the following format:

effect_value (layer, effect index, property index)

The effect index and the property index are numbers that specify a property in the Effect 
Controls window. The effect_index starts numbering at 0, and the property index starts 
numbering at 1. To specify a property in the Effect Controls window, use the effect index 
and the property index together to identify the order of the property in the window. In the 
following example, the Effect Controls window shows three effects for the layer Solid1.

To specify the Blurriness property for the Fast Blur effect, for example, specify the 
following values in the effect_value function:

effect_value (Solid1, 1, 0)

Starting at the top of the Effect Controls window, the Fast Blur effect is the second effect 
listed, and Blurriness is the first (and only) property. Note that because effect_index starts 
numbering at 0, the second effect is identified by 1.

When the effect_value function is used on the right side of an assignment, it obtains the 
value from the specified property. You can obtain values only from properties with 
numerical values.

When the effect_value function is used on the left side of an assignment, it creates a 
keyframe for the specified property. You can assign values only to numerical properties, 
such as point controls, angles, and properties controlled by slider bars in the Effect 
Controls window.

When you specify a property by indexing, all properties are counted, regardless of their 
value types or controls. 

Testing a script (PB only)
To view any syntax errors while testing and modifying your scripts, use the Errors notifi-
cation area in the Motion Math window. To display the current value of any variable or 
expression in the Errors area, use the print () function, using the following format:

P = print (a)

The variable a can be any variable or expression. To display the value, assign the value 
obtained by the function to a second variable (p, in the example). You can use any letter 
(except x or y) as this second variable.

In the following example, the vector for the Position property for layer1 is displayed:

P = print (value (layer1, position))

The print () function stops the script at the point where you place it.
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About vectors (PB only)
In Motion Math, vectors contain values for properties that require two or more dimen-
sions. For example, the Position property requires two dimensions: one for the x-
coordinate and one for the y-coordinate. A vector for the Position property contains values 
for both dimensions, and is represented by the following format:

{x, y}

The x-coordinate specifies the number of pixels on the horizontal axis, and the y-
coordinate specifies the number of pixels on the vertical axis.

Likewise, a vector for a property involving color requires four dimensions, one for R, G, B, 
and the alpha channel, as shown in the following example:

{133, 102, 54, 133}

In Motion Math, the maximum number of dimensions vectors can use is four.

Vectors as single variables (PB only)
A single variable can contain all the values of a vector and is treated as a vector. In the 
following example, the variable P1 is a vector with two dimensions, assigned the values of 
12 and 35:

P1 = {12, 35};

When assigning values in a vector to a variable, you must separate the values with 
commas and enclose them with braces. 

Using functions with vectors (PB only)
Functions that obtain values from properties with two or more dimensions obtain those 
values in a vector. Motion Math automatically creates a vector with the appropriate 
number of dimensions for any property with more than one dimension. In the following 
example, the value () function obtains a position vector for the layer named box1 and 
assigns it to the variable P1, which contains two values:

P1 = value (box1, position);

Using an index (PB only)
Use an index to assign or obtain a value for a specific dimension of a vector. An index is a 
number in brackets following a vector that specifies a certain dimension. Numbering 
starts at 0, so the first dimension is specified by 0, the second is specified by 1, and so on. 
By using an index, you can vary one dimension while keeping the others the same. In the 
following example, the value 35 is assigned to the second dimension (or y-coordinate) of 
the position vector in the Knob layer, creating a keyframe:

value (Knob, position) [1] = 35;

In another example, the current value of first dimension (or x-coordinate) of the Position 
property in the boat layer is assigned to the variable M1:

M1 = value (boat, position) [0];

In this example, the variable M1 contains only a single value.

In addition to using numbers to specify an index, you can use x and y with a two-dimen-
sional vector, as shown in the following example:

Loc2 = value (car, position) [x];
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The letter x is equivalent to the index 0, and the letter y is equivalent to the index 1.

Using mathematical functions and operations on vectors (PB 
only)
In assignments, vector variables can be treated exactly as other variables, except that any 
function or mathematical operation applied to a vector is applied to each dimension, 
unless an index is used. In the following example, both dimensions of the position vector 
for the boat layer are multiplied by 1.5 and then assigned to the variable M2:

M2 = value (boat, position) * 1.5;

In another example, only the first dimension of the position vector is multiplied by 1.5:

M2 = value (boat, position) [0] * 1.5;

Performing vector operations (PB only)
Motion Math includes three functions that are special to vectors: dot product, cross 
product, and distance.

The dot product of two vectors produces a single value. It multiplies the same indexed 
values together and adds the products, as shown below:

V = {x, y}

W = {a, b}

V • W = x*a + y*b

The Motion Math dot-product function uses the following format, in which a and b are 
vectors:

dot (a, b)

The cross product of two vectors produces a third vector, which is perpendicular to the 
plane formed by the other two and points in the direction indicated by the coordinate 
system. The cross product of two vectors produces a vector with the same number of 
dimensions. The Motion Math cross-product function uses the following format, in which 
a and b are vectors:

cross (a, b)

The distance between two vectors can be determined if each vector is plotted as a point in 
a coordinate system. The Motion Math distance function uses the following format, in 
which a and b are vectors:

dist (a, b)

The resulting value is in pixels. You can use the Motion Math distance function to calculate 
the distance between two layers, using vectors for the Position property.

Using the Layer, Property, and Channel menus (PB only)
To allow easy substitution of different layers and parameters into Motion Math scripts, use 
the Layer, Property, and Channel menus to select layers, properties, or channels, and then 
run the script on the selected elements. In this way, you can quickly run a script on 
different layers or compositions. 

To write a script that uses these menus, include one or more of the substitution functions: 

• The pop_layer () function obtains the current selection from the specified Layer menu.
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• The pop_property () function obtains the current selection from the specified Property 
menu.

• The pop_channel () obtains the current selection from the specified Channel menu.

For each function, you must specify which of the two sets of menus to use. Type a 1 in the 
parentheses to specify a menu in the first set; type a 2 in the parentheses to specify a 
menu in the second set. Your script need not use all six menus; any selections in the 
unused menus are ignored. In general, substitution functions are used inside other 
functions that require layers, properties, or channels as variables, such as the value () or 
velocity () functions. For example, the following line uses the pop_layer () function inside 
the value () function:

delta = value(pop_layer(1),position) - value(pop_layer(2),position);

The line above obtains the position value for the layer selected in the first Layer menu and 
subtracts the position value for the layer selected in the second Layer menu. You can also 
use a substitution function on the left side of an assignment when creating a keyframe. In 
the following example, a rotation keyframe is created for the layer selected in the first 
Layer menu:

value(pop_layer(1), rotation) = ang;

Use the substitution functions to select properties and channels in up to two layers. Both 
sets of menus list layers, properties, or channels, as follows:

• The Layer menus list all available layers in the composition.

• The Property menus list the properties available for the layer selected in the corre-
sponding Layer menu.

• The Channel menus list the channels available for the property selected in the corre-
sponding Property menu.

If you need to select a third layer, you can create a variable in the script where you type the 
name of the layer. For an example, see the Span script.

Using the language element menus (PB only)
In the Motion Math window, you can save time writing scripts by using the language 
element menus, which insert selected language elements in the script editor. Without 
having to type or remember formats, you can insert any layer property functions, math 
functions, operators, and constants into a script, and then edit them as needed.

To insert language elements in a script:

1 In the script editor, click the insertion point at the appropriate location.

2 In the Motion Math window, select language elements from one of the four language 
element menus: Functions, Math Functions, Operators, and Constants.

3 Edit the inserted elements, as needed, to create your script.

Motion Math language reference (PB only)
The Motion Math language includes the functions, math functions, operators, and 
constants shown in the following sections.
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Composition, layer, and property functions (PB only)
value (layer, property) When used on the right side of an equation, obtains the value of 
the specified property in the specified layer. When used on the left side, creates a keyframe 
for the specified property.

velocity (layer, property) When used on the right side of an equation, obtains the 
velocity of the specified property in the specified layer. When used on the left side, creates 
a keyframe for the specified property.

effect_value (layer, effect index, property index) When used on the right side of an 
equation, obtains the value of the effect property in the specified layer, indicated by the 
effect index and the property index, using the order of effects in the Effect Controls window 
(see “Specifying layers and properties (PB only)” on page 325). When used on the left side, 
creates a keyframe for the specified effect property.

comp_audio_amplitude ( ) Obtains and normalizes the combined amplitude of all audio 
layers in the composition at the current time, and returns a value between 0.0 and 1.0.

layer_audio_amplitude (layer) Obtains and normalizes the amplitude of the audio layer 
at the current time, and returns a value between 0.0 and 1.0.

layer_size (layer) Obtains the original size of the layer in pixels as a vector with two 
dimensions {width, height}. Any scaling of the layer is ignored.

layer_time_bounds (layer) Obtains the in and out times for the layer in seconds as a 
vector with two dimensions {in time, out time}.

time ( ) Obtains the current time in seconds the script has reached.

tmap (t, statement) Evaluates statement at time t (in seconds) rather than at the current 
time.

frame_num ( ) Obtains the frame number of the composition at the point the script is 
currently sampling.

sample_num ( ) Obtains the current sample number that the script is currently running.

frame_to_time (f) Converts the frame number f to a time in seconds.

layer_to_comp (layer, v) Transforms the position vector v from layer coordinates in the 
layer to composition coordinates. Use this function to transform the layer coordinates of 
anchor points and effect point controls to composition coordinates.

comp_to_layer (layer, v) Transforms the position vector v from composition coordinates 
to coordinates in the layer coordinate system for the layer. Use this function to transform 
effect point control positions or anchor points from composition coordinates to layer 
coordinates.

Substitution functions (PB only)
pop_layer (n) Obtains the layer selected in the Layer menu n.

pop_property (n) Obtains the property selected in the Property menu n.

pop_channel (n) Obtains the channel selected in the Channel menu n.

Math functions (PB only)
abs (a) Obtains the absolute value of a.

atan (a) Obtains the arc tangent of a.

atan2 (x, y) Obtains the arc tangent of the point x, y.
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ceil (a) Obtains the smallest integer greater than or equal to a.

cos (a) Obtains the cosine of a, where a is in radians.

acos (a) Obtains the arc cosine of a, where a is a number between –1 and 1.

cross (a, b) Obtains the cross product of vectors a and b.

dist (a, b) Obtains the distance between vectors a and b.

dot (a, b) Obtains the dot product of vectors a and b.

fmod (a, b) Obtains the remainder that results from dividing a by b.

floor (a) Obtains the largest integer not greater than a.

round (a) Rounds a to the nearest integer.

log (a) Obtains the natural log of a.

exp (a) Obtains the result of raising the natural constant e to the power of a.

pow (a, b) Obtains the result of raising a to the power of b.

random (d) Returns a random vector with d dimensions (1–4). To obtain a single random 
number, specify d as 1.

sqrt (a) Obtains the square root of a.

square (a) Obtains the square of a.

sin (a) Obtains the sine of a, where a is in radians.

asin (a) Obtains the arc sine of a, where a is a number between –1 and 1.

tan (a) Obtains the tangent of a, where a is in radians.

tangent (layer, property) Obtains the spatial tangent of the specified spatial property in 
the specified layer. The property must be spatial, such as position. Use this function to 
determine the direction of the spatial property’s curve at the point the script is running.

deg_to_rad (a) Converts degrees a to its equivalent in radians.

rad_to_deg (a) Converts radians a to its equivalent in degrees.

length (v) Obtains the magnitude of vector v.

normalize (v) Creates unit vector from vector v in same direction.

Constants (PB only)
comp_width Width of the composition in pixels.

comp_height Height of the composition in pixels.

comp_size Dimensions of composition in pixels, as a two-dimensional vector.

comp_frame_duration Duration in seconds of 1 frame in the composition.

start_time Start time of the work area, in seconds.

end_time End time of the work area, in seconds.

step_time Duration in seconds of 1 Motion Math sample based on value set in the 
Sample At control in the Motion Math window.

num_layers Number of layers in composition.

Mathematical operators (PB only)
+ add
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- subtract

* multiply

/ divide

= assign

Logical operations (use If statements) (PB only)
&& and

|| or

! not

== equals

!= not equal

< less than

<= less than or equal to

> greater than

>= greater than or equal to
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Using Vector Paint (PB only)

About Vector Paint (PB only)
Vector Paint is an effect you use directly within After Effects. You can apply the Vector Paint 
effect to solid layers, to existing images on a layer, and to create mattes. Each stroke is 
recorded in real time and can be animated and played back in various ways.

Note: Vector Paint strokes are nondestructive, so painting and erasing actions affect only 
the appearances on a layer; they do not alter the original source file of any image on the 
layer.

Most of the settings for Vector Paint appear in the Effect Controls window and the Compo-
sition window. Many settings can be changed either before or after you paint a stroke.

Vector Paint supports the Wacom and Creation Station tablets’ pressure-stylus and erase 
functions. For more information, see “Configuring a stylus for Vector Paint (PB only)” on 
page 347.

When you use Vector Paint on a layer, you can start over at any time by deleting all 
strokes or the Vector Paint effect itself. To delete the effect, select Vector Paint in the 

Effect Controls window and press Delete or Backspace. For information about selecting 
strokes, see “Selecting strokes (PB only)” on page 337.

Working with vector-based strokes (PB only)
Vector Paint uses high-quality, vector-based paint strokes that you draw in the Compo-
sition window. You cannot paint in a Layer window.

To paint on a layer:

1 Select the arrow tool ( ) in the After Effects Tools palette.

2 In either the Composition or Timeline window, select the layer on which you want to 
paint.

3 Choose Effect > Paint >Vector Paint. The Vector Paint effect appears and is selected in 
the Effect Controls window, and the Vector Paint toolbar appears on the left side of the 
Composition window.

Note: This toolbar appears only when Vector Paint is selected (highlighted) in the Effect 
Controls window.

4 Select the paint tool you want to use from the Vector Paint toolbar. For information, see 
“Selecting a painting tool (PB only)” on page 334.

5 In the Effect Controls window, select the options you want for Brush Settings and 
Composite Paint. For information about these settings, see “Specifying a Brush type (PB 
only)” on page 335 and “Selecting Brush Settings options in Effect Controls (PB only)” on 
page 335. For information about paint compositing, see“Selecting Composite Paint 
options (PB only)” on page 338.
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6 In the Timeline window, move the Time Marker to the appropriate point in time. For 
information about timing, see “Playing back your painting (PB only)” on page 340 and 
“Painting with Shift-Paint Records (PB only)” on page 343.

7 In the Composition window, drag to draw strokes on the layer.

Note: If the rulers in the Composition window interfere with your view of the Vector Paint 
tools, choose View > Hide Rulers.

All paint strokes are recorded and stored as they are drawn, so you can make the strokes 
appear in various sequences, such as animated over time or all at once. For animated 
strokes, the exact timing (real time) you used to draw the strokes can be played back and 
rendered. You can also adjust the playback speed to fit the timing you want. For infor-
mation, see “Playing back your painting (PB only)” on page 340.

You can also create new strokes by blending existing strokes, both in space and in time. 
These can be done only by selecting the strokes you want to use and using keyboard 
shortcuts. Another keyboard shortcut will close an open stroke, so that the starting point 
and end point are connected. For information, see “Selecting strokes (PB only)” on 
page 337 and “Vector Paint keyboard shortcuts (PB only)” on page 349.

Selecting and modifying paint tools (PB only)
You can select options for painting in various locations: the Vector Paint toolbar, the 
contextual menu, the Effect Controls window, and the Timeline window. You can also 
choose how your painting work appears on screen as you create it. For more information 
on setting work views, see “Selecting viewing options (PB only)” on page 347.

The Vector Paint toolbar appears in the Composition window when Vector Paint is 
selected in the Effect Controls window. This toolbar includes ten buttons when a painting 
tool is selected, but only four buttons if no tool is selected. For information on the 
functions of these buttons, see “Selecting a painting tool (PB only)” on page 334, “Speci-
fying a Brush type (PB only)” on page 335, and “Editing your paint work (PB only)” on 
page 336.

Note: The Vector Paint contextual menu contains some unique commands and settings 
that are not otherwise accessible. Open this by clicking the Vector Paint toolbar button 
( ) or by right-clicking (Windows) or Control-clicking (Mac OS) in the Composition 
window when a painting tool is selected.

Selecting a painting tool (PB only)
You can use three tools to work with paint:

Selection tool ( ) Select a stroke by clicking or dragging across it. You can drag across 
several strokes to select them simultaneously. You select strokes in order to edit or delete 
them.

Paint tool ( ) Paint directly on the layer, using settings defined in the Effect Controls 
window. When you use the Paint tool, the pointer appears as a circle (or square) in the 
actual size of the brush.
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Eraser tool ( ) Erase areas of the layer, using Brush Type settings defined in the Effect 
Controls window. The Eraser pointer appears as a circle with an X through it. If you are 
using an installed tablet with stylus eraser support, Vector Paint automatically switches to 
eraser mode when you use the stylus eraser.

Clicking the active tool (Selection, Paint, or Brush) deactivates painting and hides the 
other buttons on the Vector Paint toolbar. You can then drag and scale the layer. To 

return to working with Vector Paint, select one of the three Vector Paint tool buttons 
again, and the entire Vector Paint toolbar reappears.

Specifying a Brush type (PB only)
Vector paint includes three Brush types: Paint, Air, and Square. These define the shapes 
and performance of both the paintbrush tool and the eraser tool. Of the three, the Air 
brush type is unique because you cannot set a Feather setting for this type.

To change brush types:

Do one of the following:

• In the Vector Paint toolbar, select the Paint ( ), Air ( ), or Square ( ) button.

• In the Effect Controls window, click the current Brush type setting (Paint, Air, or Square) 
repeatedly to cycle through the three brushes until the brush you want is selected.

With increased Feather and reduced Opacity settings, Paint brushstrokes may resemble 
Air brushstrokes. However, when you paint a single stroke that crosses itself, the two brush 
types produce different results. Air brushstrokes build up opacity as the stroke crosses 
itself. Paint brushstrokes don’t build up opacity within the same stroke, whether it crosses 
itself or not. To increase opacity with Paint brushstrokes, create multiple strokes over the 
area (like multiple coats of paint).

Note: Each Brush Type is also available for the eraser tool. When the eraser tool is selected 
in the Paint Toolbar, the name appears with a -E after it in the Effect Controls window. 
Also, if a tablet is installed and the stylus has eraser support, Vector Paint automatically 
switches to eraser mode when you use the stylus eraser.

Selecting Brush Settings options in Effect Controls (PB only)
The Effect Controls window organizes settings for Vector Paint, beginning with Brush 
Settings for painting. Use this window to specify:

• Brush shape and quality.

• Paint color and opacity.

• Stylus settings for a Wacom or Creation Station tablet. For more information, see 
“Configuring a stylus for Vector Paint (PB only)” on page 347.

The first three controls on the left column can be changed in two ways. You can click the 
underlined value to open a dialog box in which you can type a specific value, or you can 
drag across the value to change it, dragging left to decrease it and right to increase it.

Note: If you select strokes with different settings (such as Color, Radius, Brush Type, and so 
forth), a question mark [-?-] appears for those option in the Effect Controls window. To 



Using Help | Contents | Index Back 336  

Adobe After Effects Help Using Vector Paint (PB only) 

Using Help | Contents | Index Back 336  

apply a single setting to all the selected strokes, select a new value, option, or color, as 
appropriate.

When you drag to change Radius, Feather, or Opacity values, hold down Ctrl 
(Windows) or Command (Mac OS) to reduce the size of the increments. To change the 

value by larger increments, hold down Shift as you drag.

Radius Controls the size of the brush or eraser.

Feather Controls the softness of brush or eraser edges (but does not affect the airbrush).

To quickly set your brush Radius and Feather amounts as you paint, press Ctrl 
(Windows) or Command (Mac OS) and click anywhere in the Composition window; 

then drag in or out to resize the brush.When you release the Ctrl or Command key, you can 
then drag in or out to resize the feather.

Opacity Controls the transparency of the paint or erasures.

Brush Type Shows the brush type you selected in the Vector Paint toolbar in the Compo-
sition window. For more information, see “Specifying a Brush type (PB only)” on page 335.

Color This Color swatch represents the paint color used to draw strokes. Select a new 
color by clicking the Color swatch and then using the Color Picker, or by using the 
Eyedropper to sample a color from the desktop.

When one or more strokes of the same color are selected, this swatch displays the Color of 
those strokes. You can change the color of the selected strokes. For information about the 
Eyedropper, see “Editing your paint work (PB only)” on page 336.

Color Clone When Color Clone is turned on, the brush behaves like a combination 
eyedropper and brush. The color of the stroke is determined by the pixels at the position 
where the stroke begins. The Color swatch in the Effect Controls Brush Settings displays 
the new sampled color. When you begin another stroke, a new group of pixels is sampled 
and used to color that stroke.

The Color Clone affects strokes only while you draw; it has no effect on an already 
completed stroke.This is the only Brush Setting you can’t apply after drawing. Clicking 
either the Eyedropper or Color swatch turns off the Color Clone feature.

Editing your paint work (PB only)
Use tools on the Vector Paint toolbar in the Composition window to revise your paint 
work. Three of these tools do not require you to select a stroke first.

Undo button ( ) Click the Undo button to cancel your last (one) painting action, if it can 
be undone. If the action cannot be undone, this tool is dimmed (not available). You can 
also undo paint actions using the Undo command on the Vector Paint contextual menu or 
pressing Ctrl+Z (Windows) or Command+Z (Mac OS).

Note: Do not use the Undo command on the Edit menu to undo Vector Paint actions.

Eyedropper tool ( ) Use the eyedropper to select a color to paint with from a sampling 
anywhere on the desktop. Press the Escape key to cancel the eyedropper.

Note: By default, Eyedropper samples a single pixel. Hold down Ctrl (Windows) or 
Command (Mac OS) and click the Eyedropper to sample a 3-x-3-pixel average. Hold down 
Shift and drag to sample a range of multiple pixels.
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Color swatch (  ) Displays the current selection as a solid color. When clicked, opens 
the Color picker dialog box. If the Opacity setting is less than 100%, the Color Swatch icon 
appears checkered, not solid.

Note: If Color Clone is turned on, this swatch represents the sampled color. For more infor-
mation, see “Color Clone” under “Selecting Brush Settings options in Effect Controls (PB 
only)” on page 335.

Shift-click the Color Swatch to open the Set Value dialog box for Opacity without 
turning off Color Clone.

Selecting strokes (PB only)
To edit a specific paint stroke, first select it. Use the selection tool ( ) on the Vector Paint 
toolbar and click or drag, or use the Select submenu on the Vector Paint contextual menu. 
You can select and then move, revise attributes, or delete either a paint stroke or erasure 
stroke.

Important: To use either method of opening the menu, Vector Paint must be selected 
(highlighted) in the Effect Controls window.

The following commands are in the contextual menu, under Select. Use these commands 
for selecting and editing strokes in a painting layer. Some of these are tied to the current 
position of the Time Marker in the Timeline window.

All Selects all strokes on a layer.

None Deselects all strokes on a layer. (Available only if some strokes are selected.)

Visible Selects all strokes visible at the current frame.

Current Time Selects all strokes that were drawn at the current time position. (Playback 
Speed does not affect the original start time of strokes.)

Last Painted Selects the last-painted brush stroke (or erase stroke). If you painted several 
strokes with the Shift key held down, this command selects that group of strokes.

Similar With one or more strokes selected, this selects additional strokes with similar 
Brush Settings properties. If strokes with dissimilar properties are initially selected, this 
command selects a broader range of strokes.

Inverse Toggles to a selection of all unselected strokes, leaving the previously selected 
strokes unselected.

After you select one or more strokes, you can use keyboard shortcuts to transform them, 
such as by rotating, scaling (vertically, horizontally, or both), or nudging (repositioning one 
pixel at a time). For a list of these shortcuts, see “Vector Paint keyboard shortcuts (PB only)” 
on page 349.

Editing brush strokes by changing settings (PB only)
After strokes are drawn, you can edit their Brush Settings by selecting them and choosing 
new settings. When you select a single stroke or strokes with the same Brush Settings, you 
can edit the enabled Brush Settings in the Effect Controls window. Your changes to the 
strokes immediately appear in the Composition window as you complete them.
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When you select multiple strokes that have different Brush Settings, a question mark [-?-] 
appears next to that Brush Setting in the Effect Controls window. If you edit that value, all 
of the selected strokes are reset to the new value. For example, if you select strokes with 
different Radius values, a question mark appears in place of the Radius setting. If you then 
type a new Radius value of 5.0 (for example), all the selected strokes will have a Radius 
value of  5.0.

Editing the Radius using Relative Values (PB only)
Use relative values to edit the Radius settings of selected strokes based on their original 
values.

If you press Alt (Windows) or Option (Mac OS) when clicking the question mark repre-
senting the Radius value, a Set Value dialog box appears. You can then type a Relative 
Radius, reducing the radius of each stroke by that percentage. The default value is 100%, 
which produces no change in the stroke radii.

For example, if you have selected three strokes with Radius values of 5, 10 and 20, and 
type a Relative Radius value of 50%, the value of each stroke is multiplied by that 
percentage, resulting in radius values of 2.5, 5, and 10, respectively. Each stroke is half its 
original width. To double the widths, type a Relative Radius of 200%.

Smoothing a stroke (PB only)
The Smoother command in the Vector Paint contextual menu removes points from a 
selected stroke or strokes. This simplifies stroke paths, smoothing out the curves. By elimi-
nating unneeded points, the Smoother can also dramatically reduce the size of the project 
file when you have complex drawings composed of many strokes.

When you select a path and choose Smoother, a dialog box appears in which you can type 
a Set Max Error value. This sets the tolerance for the smoothing. Higher values remove 
more points on the path, resulting in a smoother stroke. Set values within the range 0–
100. The default value, 1.0, removes only redundant points, maintaining details in the 
stroke.

After you click OK in the dialog box, the stroke paths immediately reflect the smoothing in 
the Composition window.

Important: Smoothing cannot be undone. Removing these points may alter the shape of 
the path. If you want to preview the results before you commit, create a duplicate of the 
layer and apply Smoothing to test the result. If these are satisfactory, then apply the 
command to the original layer. 

Selecting Composite Paint options (PB only)
Various options control the way Vector Paint composites strokes on a layer. Select the 
option you want in the Effect Controls window for a layer, in the Composite Paint pop-up 
menu under Vector Paint. These options control two things: what you see in the Compo-
sition window as you work and what aspects of the layer the strokes affect, including what 
happens when you preview and render the composition.

As you paint and erase, you can either hide or display the footage image. You have similar 
viewing options when you paint using matte and alpha-channel options.
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As you work, painting and erasing can block pixels in an original image, such as a footage 
file or solid. You can also paint on a virtual layer above or below that image (although this 
does not appear as a separate layer in the Timeline window). You can paint and erase to 
adjust mattes and alpha channels for the original image. You can restrict Vector Paint 
strokes to the areas inside or outside the original alpha channel.

Each Composite Paint option specifies a unique combination of work view, layer type 
(image, matte, or alpha channel), and placement of strokes relative to the original image. 
You can select strokes later and change the Composite Paint option, but it is a good idea 
to understand what results each option produces before you start painting.

The following illustrations use the same basic example of an imported image. A straight 
paint stroke has been applied, followed by a curving erasure stroke. The original image is a 
textured fill and mask that reveals only a circular area of the fill. For these examples, Check-
erboard Background is selected (in the Composition window menu, click the right arrow 
above the vertical stroll bar to open that menu).

A. In Original (default setting), before painting The imported image is visible.

B. In Original, with paint stroke The paint strokes appear above the original image.

C. In Original, with paint stroke and erasure stroke An erasure stroke removes under-
lying portions of both the paint stroke and the original image.

D. Only The original image on the layer does not appear in the working view; only paint 
strokes are shown. Erasures remove only paint, not the original image.

E. Over Original The original image is visible in the working view, similar to the In 
Original option. Painting and erasing occur as with the Only option: Erasing removes 
pixels from underlying paint strokes but does not alter the original image.

F. Under Original The layer image is visible in the working view. Painting does not alter 
the original image; it affects only areas of the layer that are outside the original image. 
Erasures remove only paint pixels, not the original image.

A B C D

E F G H

I J K L



Using Help | Contents | Index Back 340  

Adobe After Effects Help Using Vector Paint (PB only) 

Using Help | Contents | Index Back 340  

G. Track Original Matte The original image is not visible in the working view. Paint 
strokes are visible. Painting affects only the area within the original image alpha channel 
(that is, paint applied within the original circle area). Erasures remove only existing paint 
pixels.

H. Track Original Matte Visible The original image is visible in the working view. 
Otherwise, Vector Paint strokes behave exactly as with Track Original Matte, so erasures do 
not affect the original image.

I. As Matte Before you paint, nothing is visible in working view. Paint strokes affect only 
the matte, revealing the underlying original image. Erasures add back areas of opacity, so 
that they appear to erase the underlying image again. Both types of strokes are restricted 
to the area of the original alpha channel.

J. As Inverse Matte Before you paint, the original image is visible in the working view. 
Painting affects only areas within the original image alpha channel. Paint strokes block 
(rather than reveal) the original image, appearing to erase the original image. Erasures 
remove only painting strokes, (that is, they re-reveal the underlying image within the 
alpha channel).

K. In Original Alpha Only The original image appears within its alpha channel in 
working view. Strokes affect the alpha channel itself. Painting adds areas of opacity. 
Erasures add areas of transparency.

Note: You do not need to switch colors when you paint in the alpha channel, even if you 
paint with gray. The changes to the opacity of the painted area are determined by the 
values shown for Opacity and Feather under Brush Settings in the Effect Controls window, 
not by the color of paint.

L. Under Original Alpha Only The original image appears within its alpha channel in 
working view. Strokes do not affect the original image alpha channel, only areas outside of 
it. Painting adds areas of opacity; erasing restores transparency to painted areas only.

Note: The difference between using Under Original and Under Original Alpha Only is that 
in the latter, strokes affect only the alpha channel; RGB is unchanged.

Playing back your painting (PB only)
Use the Playback Mode pop-up menu in the Effect Controls window to specify when and 
how quickly your strokes appear in your composition. When you draw strokes, Vector Paint 
records information for the stroke start time and the drawing time of each stroke (in real 
time). The Playback Mode you select determines when a stroke starts and for how long it 
appears. You can set the speed at which the strokes play back using Playback Speed.

Play back your strokes using the Spacebar or RAM Preview, or by viewing the results of a 
rendered Composition.

Note: Regardless of how you record your strokes and which Playback Mode you select 
when recording, you can always switch to another Playback Mode at any time.

While the Playback Mode chosen affects what you see during playback, it also determines 
what you see while you are drawing strokes. Onion Skin mode, for example, is used 
primarily while drawing strokes, and then another mode is selected before rendering.

Important: Notice the position of the Time Marker when you begin drawing strokes. This 
position affects the appearance of strokes in all modes except All Strokes.
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Choosing a Playback mode (PB only)
There are six modes for playing back the strokes in your paint composition:

All Strokes Displays all strokes for the full duration of the layer, regardless of the position 
of the Time Marker when you drew them.

Past Strokes Strokes cut in at the time at which they were recorded and remain visible 
until the end of the layer (the Out point).

Hold Strokes Displays strokes from the frame on which they were drawn and holds them 
only until the point at which the next stroke was drawn. This treats strokes like Hold 
keyframes; as a stroke appears, it replaces the next, as in a slide show.

Animate Strokes Begins drawing the stroke at the current time (that is, at the frame 
where the Time Marker is when you draw the stroke). The stroke animates in the same way 
as it was drawn.

Current Frame The default Draw Strokes setting. It displays the stroke only at the frame 
at which it was painted.

Onion Skin Displays strokes drawn on the current frame plus strokes drawn on the 
surrounding few frames. These additional strokes appear color-coded and at reduced 
opacity, to distinguish them from the strokes on the current frame. Those strokes actually 
exist only on the frames in which they are drawn. Onion-skinning is very useful for 
drawing frame-by-frame animations because it gives you reference points for the stroke 
positions. 

Use the Onion Skinning options in the Vector Paint Preferences dialog box to specify how 
previous and forward strokes appear when Onion Skin is the active Playback Mode. (To 
open Vector Paint Preferences, use the Vector Paint contextual menu and choose Options.) 
These options include:

• Frames Backward/ Frames Forward. Sets the number of frames backward or forward 
that are displayed. Both backward and forward frames are displayed unless one or both 
of these values is set to 0.

• Color Backward/Color Forward. Sets the color of the display of backward and forward 
strokes.

• Skin Opacity. Sets the percentage of opacity for onion-skin strokes.

Drawing a three-frame animation in Onion Skin Playback Mode: As you draw on successive frames, 
the 
strokes you drew on previous (or forward) frames also appear for your reference.
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For information about setting Vector Paint Preferences, see “Selecting viewing options (PB 
only)” on page 347.

Setting playback speed (PB only)
The Playback Speed value in the Effect Controls window can change the timing at which 
painted strokes appear in previews and rendered compositions. Playback Speed affects 
the Vector Paint strokes only when you set the Playback Mode to Past Strokes, Hold 
Strokes, or Animate Strokes.

When you create strokes on a layer, the stroke is tied to the location of the Time Marker in 
the Timeline when you start drawing. Vector Paint also records the amount of time you 
take to draw the stroke. For example, you might start painting a stroke with the Time 
Marker set to 0:00 and use 1.5 seconds to draw the stroke. Then, you might move the time 
marker to 2:00 and draw a second stroke (leaving 0.5 seconds between the completion of 
the first stroke and the beginning of the second one). For this example, let’s say you use 
1.0 second to draw the second stroke. The entire process covers 3.0 seconds on the 
Timeline.

By changing the playback speed, you can change the timing for stroke appearances in 
previews and rendered compositions. The results that your changes produce depend on 
the Playback Mode setting that you select in the Effect Controls window:

Animate Strokes With the Playback Speed at 1.0, each stroke appears as if drawn by an 
unseen hand, taking the same amount of time as you used to create it. When you increase 
the Playback Speed value, the amount of time used to draw each stroke is reduced. The 
gaps between strokes are also reduced. If you decrease Playback Speed, both the time 
taken to draw the strokes and the length of the gaps between strokes increases.

Using the example described above in this topic, if you increase the Playback Speed value 
to 2.0 (double the speed), the first stroke would be drawn in 0.75 seconds, the gap 
between the two strokes would be shortened to 0.25 seconds, and the second stroke 
would be drawn in 0.5 seconds. The entire animation would be complete after 1.5 seconds 
of playback.

Past Strokes At Playback Speed 1.0, each stroke appears in completed form at the frame 
in which you started drawing and remains visible for the duration of the layer playtime. 
When you increase Playback Speed, each stroke appears at an earlier point in time. If you 
decrease Playback Speed, strokes occur at later points in time.

Hold Strokes Like Past Strokes mode, each stroke appears in completed form at the 
frame in which it was drawn. The difference between this and Past Strokes mode is that in 
Hold Strokes mode, each stroke disappears when the next stroke appears (without any 
gap between the disappearance of the first stroke and the appearance of the second). 
Otherwise, the results of changing Playback Speed are similar to those in Past Strokes 
mode.

To adjust the Playback Speed:

1 In the Effect Controls window under Vector Paint, make sure that the Playback Mode 
option is one of the following: Past Strokes, Hold Strokes, or Animate Strokes.

2 In the Effect Controls window, click the underlined Playback Speed value and type a 
new value, using a number between 0 and 100.
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You can also change the playback speed by dragging the value itself or the slider below it: 
left to decrease the speed, right to increase it.

For animations, always begin painting strokes at the layer In point, especially when 
adjusting the Playback Speed. Doing this locks the In point (first stroke’s start time) to 

the In point of the layer, making it easier to locate the beginning of the animation. Then, 
simply place the layer’s In point where you want the animation to begin in the compo-
sition.

Using the Re-timer (PB only)
The results you get from either using the Re-timer or changing the Playback Speed value 
are similar, but there are several important differences:

• You apply the Re-timer to individual strokes you select before choosing the Re-timer 
option. In comparison, changes in Playback Speed applies to all paint strokes on the 
layer.

• The Re-timer affects only playbacks that use Animate Strokes mode. Playback Speed 
changes can also influence Hold Strokes and Past Strokes modes.

• The Re-timer does not affect the start times of strokes. Changing the Re-timer value 
shortens or lengthens the amount of time previews and rendered versions take to draw 
the stroke. The strokes begin to appear at the same points in time as before, but they 
are drawn more quickly or more slowly.

• The values for Re-timer are percentages of the original time required to draw the stroke. 
The default value is 100%. A higher value causes the drawing time to increase, so that a 
setting of 200% uses twice the time to draw the selected strokes. A lower value draws 
the selected strokes more quickly.

To change playback time with the Re-timer:

Using the Vector Paint Selection tool ( ), click or drag to select the strokes.

1 Right-click (Windows) or Control-click (Mac OS) to open the contextual menu, and 
choose Re-timer.

2 In the Set Value dialog box, type a value for Relative Duration (%), and click OK.

Note: You cannot use the Undo command to reverse the Re-timer after you apply it. 
However, you can apply the Re-timer again, using the inverse of the value you typed previ-
ously to revert to the original value. For example, if you changed the Re-timer value to 
200% and then wanted to go back to the earlier setting, choose Re-timer again and type a 
value of 50%.

Painting with Shift-Paint Records (PB only)
Ordinarily, when you create strokes with Vector Paint, those strokes are associated with 
the position of the Time Marker when you draw those strokes. After you draw a stroke, you 
can draw more strokes at the same time setting or at different time settings. The results 
you see when you preview or render the composition depend on your Playback Mode 
setting (see “Choosing a Playback mode (PB only)” on page 341).

The Shift-Paint Records options change the way that strokes associate with time settings. 
This is called QuickPaint mode. One of the advantages of this feature is that you can create 
fast continuous recordings of a sequence of strokes without redraw delays after each one. 
To work using QuickPaint mode, you must do two things:
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• First, choose the Shift-Paint Records option you want to apply before you paint the 
strokes that will use this option. These options are available only on the Shift-Paint 
Records submenu of the Vector Paint contextual menu.

Note: You cannot apply a Shift-Paint Records option to strokes you have already created.

• Second, hold down Shift as you paint. Otherwise, the Shift-Paint Records options will 
not apply to those strokes.

When you draw, the Info palette displays the abbreviation QP followed by a description of 
the selected option: Current Frame, Next Frame (for To Sequential Frames), Realtime, or 
Continuously. These options affect stroke start times in the following ways:

To Current Frame All strokes start at the current frame (the Time Marker position when 
you draw the strokes). This is similar to ordinary painting mode except that Shift-Paint 
Records has no redraw delays.

To Sequential Frames All stroke start times are offset by one frame. The next frame is 
calculated according to the composition frame rate at the time of drawing.

For example, if the Time Marker is at 0:00 when you draw three strokes, then the start 
point is 0:00 for the first stroke, 00:01 for the second stroke, and 00:02 for the third stroke.

In Realtime Stroke start times are determined by how they are drawn. The strokes are 
recorded and played back in real time even if you lift the brush while drawing. Strokes play 
back exactly as they were recorded, including any time that elapsed (gaps) between the 
creation of the strokes (provided that you continued to hold down Shift during the time 
gap).

Continuously Stroke start times follow one another, without any gaps. When one stroke 
is finished drawing, the next one begins immediately. Otherwise, this is similar to the In 
Realtime option.

Setting Wiggle Control options (PB only)
Vector Paint strokes are made up of many tiny points that create the stroke path. You 
cannot isolate or individually adjust these individual points, but you can affect them using 
Vector Paint features such as Smoothing and Wiggling. The wiggling of a stroke is created 
by manipulating and displacing these points along the stroke path.

Set wiggle options in the Effect Controls window under Vector Paint. Click the arrow 
beside Wiggle Control to display or hide the following options: Enable Wiggling, Wiggles/
sec, Displacement Variation, Pressure Variation, Pressure Detail, and Individual Stroke 
Seeds. Click the arrows beside each of these to see or hide more options.

Enable Wiggling When Enable Wiggling is checked, all strokes on that layer are set to 
wiggle using the Wiggle Control values set in the Effect Controls window (described 
below).

Wiggles/sec This value determines the number of Wiggles per second of Composition 
time. Wiggling is spline-based morphing of paint strokes. Wiggles/sec controls the speed 
at which the morph completely shifts shape. Lower values result in a smooth animation of 
morphing strokes. Higher values create more rapid wiggling.

Example: In a 30-fps composition, setting the Wiggle/sec value to 30 creates one wiggle 
per frame.
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Set the Wiggle/sec value by using the slider in the Effect Controls window (preset to values 
between 0 and 30), by dragging the underlined Wiggle/sec value (to a value from 0 to 
100), or by clicking the Wiggle/sec value and typing a number from 0 to 100.

Displacement Variation Determines how far the stroke moves from its original position 
while wiggling. The greater the value, the greater the deviation in shape.

No Displacement Variation (left), Medium Displacement Variation (center), and High Displacement 
Variation (right)

In the Effect Controls window, set the Displacement Variation value by clicking it and 
typing any number between -30,000 and 30,000, or by dragging the Displacement 
Variation slider. To increase the intervals, hold down Shift as you drag.

Displacement Detail This value determines how much the original shape of the path is 
altered while wiggling. Greater values increase the detail of displacement (or change in 
shape) in the stroke. Lower values produce less displacement, leaving the path closer to its 
original shape.

When Displacement Detail values are set very high, the stroke may not resemble its 
original shape at all. This is useful in creating randomly animated strokes.

Low Displacement Detail (left), Medium Displacement Detail (center), and High Displacement Detail 
(right)

Set the Displacement Detail value by using the slider in the Effect Controls window (preset 
to values between 0 and 100) or by clicking the underlined Displacement Detail value and 
typing a number between 0 and 1000.

Selecting pressure settings (PB only)
Note: Strokes that do not have either Stylus Radius or Stylus Opacity options selected are 
not affected by the Wiggle Pressure Settings. However, these options can be enabled even 
when a tablet is not installed.

To make the Radius and Opacity of mouse-drawn strokes wiggle, select those strokes in 
the Composition window, and then select the Stylus Radius and Stylus Opacity options in 
the Effect Controls window.



Using Help | Contents | Index Back 346  

Adobe After Effects Help Using Vector Paint (PB only) 

Using Help | Contents | Index Back 346  

Checking the Stylus Radius and Stylus Opacity flags for strokes drawn with a pressure- 
sensitive pen allows pressure information to be recorded. This information then 
contributes to the variation of the stroke while wiggling is enabled.

Pressure Variation This value determines how much the Radius and Opacity values of 
the stroke vary while wiggling. For strokes that have Stylus: Radius enabled, the Radius 
wiggles. For strokes that have Stylus: Opacity enabled, the Opacity wiggles. The amount of 
variation in either the Radius or Opacity value while wiggling depends on the value 
specified for Pressure Variation.

The Radius and Opacity settings in the Brush Settings act as maximum amounts, not to be 
exceeded while wiggling.

No Pressure Variation (left), Low Pressure Variation (center), and High Pressure Variation (right)

In the Effect Controls window, set the Pressure Variation value by clicking the underlined 
Pressure Variation value and typing a number between -30,000 and 30,000, or by dragging 
the Pressure Variation slider.

Pressure Detail This value determines how tight the pressure variation appears along 
the stroke. Higher values create more dense variations.

Low Pressure Detail (left), Medium Pressure Detail (center), and High Pressure Detail (right)

In the Effect Controls window, set the Pressure Detail value by clicking the underlined 
Pressure Detail value and typing a number between 0 and 1000, or by dragging the 
Pressure Detail slider.

Individual Stroke Seeds When selected, this option creates a different random wiggle 
seed for each stroke on a layer.

Because the Wiggle Controls apply to all strokes on a layer, the wiggle parameters are 
always the same. To randomize the wiggling of the individual strokes, select the Individual 
Stroke Seeds option.
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If Individual Stroke Seeds is not selected, all strokes use the same wiggle seed, so they all 
have the same spatial wiggle values. For example, two strokes exactly on top of each other 
will wiggle equally. By setting individual seeds for each stroke, you avoid identical strokes 
wiggling in the same way.

Original (left), Individual Stroke Seeds Off (center), and Individual Stroke Seeds On (right)

Selecting viewing options (PB only)
Use the following Interface Options in the Vector Paint Preferences dialog box to 
customize the way you view your work in Vector Paint. It is important to understand that, 
unlike most other effects, the options you select as Vector Paint Preferences apply to all 
your Vector Paint work, both on the current layer and on other layers. Your current 
preference settings are also used for subsequent uses of Vector Paint, including future 
sessions.

With Vector Paint selected in the Effect Controls window, open the Vector Paint Prefer-
ences dialog box in any of the following ways:

• Click the menu button( )in the Vector Paint toolbar in the Composition window, and 
choose Options.

• Right-click (Windows) or Control-click (Mac OS) anywhere in the Composition window, 
and choose Options.

• In the Effect Controls window, click the word Options next to the name Vector Paint. 

By default, the following three options are selected in this dialog box:

Better Preview While Drawing When selected, this option enables drawing an anti-
aliased preview in the Composition window. When it is not selected, Vector Paint draws a 
rough preview that works with any graphics card.

Note: If the preview does not appear to be drawing correctly, you may have an incom-
patible graphics card. Also, Better Preview While Drawing is temporarily disabled in low-
memory situations, and Draft quality is used instead.

Show Actual Brush Size When selected, the cursor represents brush size in the Compo-
sition window by changing into a circle or square of the appropriate size. When 
deselected, the normal brush cursor arrow appears.

Show Toolbar When selected, the toolbar appears in the Composition window.

Configuring a stylus for Vector Paint (PB only)
You can specify your preferences for your Wacom or Creation Station tablet in several 
areas of the After Effects interface.
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Changing stroke weight with Stylus Radius (PB only)
Under Brush Settings in the Vector Paint effects, the Stylus Radius option affects stylus 
sensitivity. When you select this option, the pressure of the pen on the tablet changes the 
weight of the stroke as it is drawn. Lighter pressure decreases the radius (creating a 
thinner stroke), and increased pressure increases the radius (creating a wider one). The 
Radius value setting indicates the maximum radius amount. Use the tablet settings to 
adjust the pressure-width sensitivity for the pen.

Use the Effect Controls window to turn this option off and on: Select the Radius option for 
Stylus under Vector Paint. When this option is turned on, an X appears in the Radius check 
box and a checkmark appears by the Stylus command in the Vector Paint contextual 
menu.

Note: You can choose Stylus Radius even when no tablet is installed. This affects strokes 
when wiggling is enabled.

Using stylus pressure to affect opacity (PB only)
The pressure variation of the pen on the tablet alters the opacity of the stroke as you draw. 
Light pressure results in lower opacity values, while increased pressure creates more 
opaque strokes. The Opacity value defines the maximum of the Opacity range.

As with Stylus Radius, you can select and specify a stylus Opacity. When stylus Opacity is 
active, a checkmark appears by the command on the Vector Paint contextual menu and 
and an X appears in the Stylus Opacity check box in the Effect Controls window.

Selecting Preferences for stylus settings (PB only)
The following appear in the Vector Paint Preferences dialog box under Stylus Options:

Stylus Vendor (Mac OS only) If a tablet is installed, vendor information appears here. If 
the system does not detect a stylus, “No stylus detected” appears.

Use High Res. Coordinates When this option is checked, data is recorded with high 
resolution (if supported by the stylus). This setting overrides normal mouse coordinates to 
use the higher resolution of the tablet, recording strokes with greater precision and 
subpixel accuracy.

For other information about using your stylus with Vector Paint, see “Stylus Settings” 
under “Selecting Brush Settings options in Effect Controls (PB only)” on page 335. For 
information about opening the Vector Paint Preferences dialog box, see “Selecting 
viewing options (PB only)” on page 347.

Note: Wacom tablets do not support High Res. Coordinates when Proportional mode is 
selected in the Wacom control panel.

If you experience offset coordinates with your pen, try the following:

• Check that screen resolution and monitor settings haven’t changed.

• If using a Wacom tablet, make sure that your tablet-mapping aspect isn't set to Propor-
tional. Select To Fit mode or One to One mode instead.

• Restart your system.

• If all else fails, turn off Use High Res. Coordinates. (Subpixel accuracy will be lost, but 
Pressure and Eraser modes will still be available.)
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Vector Paint keyboard shortcuts (PB only)
Important: To enable Vector Paint keyboard shortcuts, Vector Paint must be selected in 
the Effect Controls window and the Composition window must be active.

General

Ctrl + Z (Windows) or Command + Z (Mac OS): Undo

Right-click (Windows) or Control + click (Mac OS): Open Vector Paint contextual menu

Alt + right-click (Windows) or Control + Option + click (Mac OS): Open general contextual 
menu for After Effects

Tools

V: Toggle between paint or erase tool and the selection tool

C: Temporarily switch to Eyedropper tool

Ctrl + drag (Windows) or Command + drag (Mac OS): Set Radius and Feather for Brush 
Settings.

Shift + painting: QuickPaint (in mode selected in the Vector Paint contextual menu)

Esc: Cancel an Eyedropper color selection, a stroke selection made by dragging, or a value 
setting changed by dragging.

Ctrl + click Eyedropper tool (Windows) or Command + click Eyedropper tool (Mac OS): 
Select 3-x-3-pixel color sample (average)

Shift + drag Eyedropper tool: Select multiple-pixel color sample (average)

Stroke selection

Ctrl + A (Windows) or Command + A (Mac OS): Select all strokes

Shift + L: Select last-painted stroke

Shift + W: Select visible strokes

Shift + T: Select current time

F2; or Ctrl + Shift + A (Windows) or Command + Shift + A (Mac OS): Deselect strokes

Shift + select: Toggle selection

Ctrl + select (Windows) or Command + select (Mac OS): Select by rectangular marquee

Backspace or Delete: Delete selected strokes

Ctrl + C (Windows) or Command + C (Mac OS): Copy selected stroke as keyframe

Setting strokes in time

[ (left bracket): Set start time of selected strokes to current time

] (right bracket): Set end time of selected strokes to current time

Alt + ] (right bracket): Set duration of selected strokes to current time

Alt + Page Up (Windows) or Option + Page Up (Mac OS): Move selected strokes to previous 
frame.

Alt + Page Down (Windows) or Option + Page Down (Mac OS): Move selected strokes to 
next frame.
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Shift + Alt + Page Up (Windows) or Shift + Option + Page Up (Mac OS): Move selected 
strokes 10 frames earlier on the Timeline.

Shift + Alt + Page Down (Windows) or Shift + Option + Page Down (Mac OS): Move 
selected strokes 10 frames later on the Timeline.

Drawing strokes

Shift + B: Blend selected strokes

Shift + I: Draw sequential blend strokes on intermediate frames between selected strokes 
that were drawn on different frames

Shift + J: Close selected stroke (connect start and end points)

Shift + 2: Create stroke sequence in the order in which the selected strokes were drawn

Scale selected strokes

Alt + plus sign (+) on the numeric keypad (Windows) or Option + plus sign (+) on the 
numeric keypad (Mac OS): Scale up by 1%.

Alt + minus sign (-) on the numeric keypad (Windows) or Option + minus sign (-) on the 
numeric keypad (Mac OS): Scale down by 1%.

Alt +  (Windows) or Option +  (Mac OS): Increase the vertical scale (height) by 1%.

Alt +  (Windows) or Option +  (Mac OS): Decrease the vertical scale (height) by 1%.

Alt +  (Windows) or Option +  (Mac OS): Increase the horizontal scale (width) by 1%.

Alt +  (Windows) Option +  (Mac OS): Decrease the horizontal scale (width) by 1%.

Rotate selected strokes

+ (on the numeric keypad): Rotate clockwise by 1°.

- (on the numeric keypad): Rotate counterclockwise by 1°.

Reposition selected strokes

 or : Nudge the position up, down, right, or left by 1 pixel.

Amplifying transformations

Combine the Scale, Rotate, and Reposition keyboard shortcuts with the following keys to 
alter the transformation:

• Shift + transform shortcut: Increase increment by a factor of 10.

• Ctrl + transform shortcut (Windows) or Command +transform shortcut (Mac OS): Scale or 
rotate selected strokes individually (not as a group).
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Creating Particle Effects (PB 
only)

Creating Particle Effects (PB only)
Use the Particle Playground effect to create animations in which a large number of similar 
objects must be animated independently, such as a swarm of bees. Particle effects 
simulate the physical interactions between objects in the real world. For example, if you 
want to create a snowfall effect, you normally have to animate many individual snowflake 
layers manually, hoping that you animated each layer’s motion path realistically. 

By changing Particle Playground options, you can control whether a single snowflake you 
create results in a gentle dusting of snow or a driving blizzard. The built-in physics, 
including gravity, ensure realistic movement. Using Particle Playground’s detailed level of 
control over particles, you can even make the snowflakes stick to a surface.

Note: Because of the complexity of Particle Playground, you may experience long compu-
tation, preview, and render times.

Snowflakes created using Particle Playground

Overview of Particle Playground workflow (PB only)
Start by creating a stream or plane of particles, or by “exploding” an existing layer into 
particles. Once you have a layer of particles, you can control their properties, such as 
speed, size, and color. However, the effects available in Particle Playground go beyond the 
obvious. For example, you can replace the default dot particles with the footage from an 
existing layer, which is how you create an entire snowstorm from a single snowflake layer. 
You can also use text characters as particles. For example, you can shoot words across the 
screen, or you can create a sea of text in which a few letters change color, revealing a 
message.

General workflow for creating particle effects:

1 Select the layer on which you want particles to exist, or create a new solid layer.

2 Choose Effect > Simulation > Particle Playground. The layer becomes an invisible layer 
in which only the particles will be visible. Animating the layer in the Timeline window 
animates the entire layer of particles.
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3 Set up a particle generator to determine how particles are created. You can shoot a 
stream of particles from the Cannon, generate a flat plane full of particles from the Grid, or 
use the Layer Exploder to create particles from an existing layer. If you’ve already created 
particles, you can apply the Particle Exploder to explode them into more new particles. 
See “Preparing to use Particle Playground (PB only)” on page 352.

4 Select your particles. By default, Particle Playground creates dot particles. You can 
replace the dots with footage from a layer already in the composition or with text 
characters you specify. If you want to use footage from a layer as particles, see “Replacing 
default particles with a layer (PB only)” on page 358. If you want to use text as particles, see 
“Replacing default particles with text (PB only)” on page 361.

5 Specify the overall behavior of some or all particles. Use Gravity to pull particles in a 
specified direction, Repel to push particles apart from or toward one another, or Wall to 
contain or exclude particles from a certain area. See “Influencing the behavior of existing 
particles (PB only)” on page 362.

6 Use an image to specify the behavior of individual particles. You can modify properties 
that change particle motion, such as speed and force, and properties that change particle 
appearance, such as color, opacity, and size. See “About Property Mappers (PB only)” on 
page 366.

Particle Playground properties A. Use to generate particles. B. Use to specify footage from a layer 
in place of each default dot particle. C. Use to influence overall particle behavior. D. Use to 
influence particle properties. E. Use to set options, including those for substituting text characters 
in place of dots.

The Particle Playground effect renders with anti-aliasing when the layer to which it is 
applied is set to Best Quality. It also applies motion blur to moving particles when both the 
Motion Blur switch and the Enable Motion Blur option are enabled. When you use Best 
Quality and motion blur, the layer will take longer to render.

When you use another layer as a source for particles, Particle Playground ignores any 
property or keyframe changes you made to that layer within that composition, such as 
changing the Position values. Instead it uses the layer in its original state. To keep property 
or keyframe changes for a layer when you use it as a particle source, precompose the layer.

Preparing to use Particle Playground (PB only)
Before creating a particle effect, decide how you want the particles to first appear and 
what they will consist of. 

A

B

C

D

E



Using Help | Contents | Index Back 353  

Adobe After Effects Help Creating Particle Effects (PB only) 

Using Help | Contents | Index Back 353  

How particles first appear on the layer (PB only)
Use the Cannon to create a stream of particles from a specific point on the layer, or use the 
Grid to generate a plane of particles. The Layer Exploder and Particle Exploder can create 
new particles from existing layers or particles. You can use any combination of particle 
generators on the same layer. To learn how to create particles using these three methods, 
see “Creating particles (PB only)” on page 354.

Particles generated from the Cannon (left) and from the Grid (right)

Particle content (PB only)
Particle Playground can generate three kinds of particles—dots, footage from a layer, or 
text characters. You can specify only one kind of particle per particle generator. For more 
information, see “Replacing default particles with a layer (PB only)” on page 358 and 
“Replacing default particles with text (PB only)” on page 361.

Particles generated from the Cannon A. Dots B. Footage from a layer C. Text characters

Particles generated from the Grid A. Dots B. Footage from a layer C. Text characters 

The particle generators set the properties of particles at the moment they are created. 
After that, particle behavior is influenced by the Gravity, Repel, Wall, Exploder, and 
Property Mapper options. For example, if you want particles to stick to grid intersections, 
you might use the Static Friction property in the Property Mapper to hold particles in 
place; otherwise, as soon as particles are created they will begin moving away from their 
original grid positions.

A B C

A B C
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Improving performance with Particle Playground (PB only)
You can animate a large number of similar objects so that they move independently but 
produce a consistent group behavior overall, such as animating falling snow, swarming 
bees, or exploding fireworks. The following guidelines can help you work more efficiently:

• When you’re generating a Particle Playground effect, keep an eye on the Info palette to 
see how many particles are being produced. If an effect contains more than 10,000 
particles, it can significantly slow rendering.

• The Grid and Layer Exploder generate particles on every frame, which may generate too 
many particles for the effect you’re creating and slow down rendering. To avoid 
continuous particle generation, animate these options to decline to zero over time: 
Layer Exploder, Radius of New Particles, Grid Radius, Particle Radius, and Font Size. Then 
the Particle Playground generates new particles only at the start of a sequence.

The grid generates particles for every frame by default.

In this example, a keyframe for the point size of the grid particles was set to zero on the second 
frame, so only particles generated on the first frame appear.

• When you apply a Particle Playground effect to a layer, the particle positions aren’t 
limited to the bounds of that layer. To control particles that you can't see or that appear 
near the edge of the image, use a Selection or Property Map that’s larger than the area 
of the Particle Playground layer. Also, note that After Effects takes an image map’s alpha 
channel into account. If you want transparent areas of your map to affect the particles, 
precompose the map layer with a black solid behind it.

To specify field-rendering with a Particle Playground effect, select Enable Field Rendering 
in the Particle Playground Options dialog box. Then Particle Playground calculates the 
simulation at double the frame rate of the current composition, which is what field 
rendering requires.

Creating particles (PB only)
Create particles using the Cannon, the Grid, the Layer Exploder, and the Particle Exploder. 
The Cannon is on by default and must first be turned off before using a different method 
to create particles. It creates particles in a continuous stream, as though they were shot 
out of a cannon. The Grid creates particles in an organized grid format with straight rows 
and columns. The exploders create particles randomly, like firecracker sparks.

Particle Playground Cannon (PB only)
By default, the Cannon shoots red particles toward the top of the frame at 100 particles 
per second.
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When creating particles using the Cannon, you can adjust the following options:

Position Determines the X, Y coordinates from which particles are created.

Barrel Radius Sets the size of the Cannon’s barrel radius. Negative values create a circular 
barrel, and positive values create a square barrel. For a narrow source such as a ray gun, 
specify a low value. For a wide source such as a school of fish, specify a high value. 

Particles Per Second Determines how often particles are created. A value of 0 (zero) 
creates no particles. A high value increases the density of the particle stream. If you don’t 
want the Cannon to fire continuously during the composition, set keyframes for this 
property so that the value is 0 at the times when you don’t want to create any particles.

Direction Sets the angle at which particles are fired.

Direction Random Spread Determines how much each particle’s direction deviates 
randomly from the Cannon Direction. For example, specifying a 10-degree spread sprays 
particles in random directions within +/–5 degrees of the Cannon Direction. For a highly 
focused stream such as a ray gun, specify a low value. For a stream that widens quickly, 
specify a high value. You can specify up to 360 degrees.

Velocity Determines the initial speed of particles in pixels per second as they emanate 
from the Cannon.

Velocity Random Spread Determines the amount of random velocity of particles. A 
higher value results in more variation in the velocity of particles. For example, if you set 
Velocity to 20 and Velocity Random Spread to 10, particles leave the Cannon at velocities 
ranging from 15 to 25 pixels per second.

Color Sets the color of dots or text characters. This setting has no effect if you use a layer 
as the particle source.

Particle Radius/Font Size Sets the radius of dots, in pixels or the size of text characters in 
points. This setting has no effect if you use a layer as the particle source.

To turn off the particle stream:

1 In the Effect Controls window, click the right-facing triangle next to Cannon so that it 
points downward.

2 Click Particles Per Second, type 0 (zero), and click OK.

Particle Playground Grid (PB only)
The Grid creates a continuous plane of particles from a set of grid intersections. Grid 
particles are created without any velocity, so the movement of Grid particles is completely 
determined by the Gravity, Repel, Wall, and Property Mapper settings. By default, Grid 
particles fall toward the bottom of the frame because by default the Force property of 
Gravity is on.

With the Grid, a new particle appears on every frame at each grid intersection. You can’t 
adjust this frequency, but if you want the grid to stop generating particles at specific 
times, set the Particle Radius/Font Size option to 0, or use keyframes to animate the value 
of the Particles Across and Particles Down properties. To make more particles appear each 
frame, increase the values for Particles Across and Particles Down.

Note: By default, the Cannon is on and the Grid is off. If you are using the Grid and want to 
stop the Cannon from generating particles, turn off the Cannon by setting its Particles Per 
Second to 0 (zero).
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When creating particles using the Grid, adjust the following:

Position Determines the X, Y coordinates of the grid center. When a grid particle is 
created, it is centered over its grid intersection, regardless of whether it is a dot, a layer, or 
a text character. If you’re using text characters as particles, the Use Grid option in the Edit 
Grid Text dialog box (see “Replacing default particles with text (PB only)” on page 361) is 
on by default, placing each character on its own grid intersection, so normal character 
spacing, word spacing, and kerning do not apply. If you want text characters to appear at 
the grid position with normal spacing, use a text alignment other than the Use Grid 
option.

Width/Height Horizontal and vertical dimensions of the grid, in pixels.

Particles Across/Particles Down Number of particles to distribute horizontally and verti-
cally across grid area. Particles are generated only when the value is 1 or more.

Note: If the Width, Height, Particles Across, and Particles Down options are not available, 
the Use Grid option has been turned off in the Edit Grid Text dialog box. For more infor-
mation, see “Replacing default particles with text (PB only)” on page 361.

Color Sets the color of dots or text characters. This setting has no effect if you use a layer 
as the particle source.

Particle Radius/Font Size Sets the radius of dots in pixels or the size of text characters in 
points. (See “Replacing default particles with text (PB only)” on page 361.) This setting has 
no effect if you use a layer as the particle source.

To turn off the grid:

1 In the Effect Controls window, click the right-facing triangle next to Grid so that it 
points downward.

2 Do one of the following:

• Click the underlined value next to Particles Across, type 0, and click OK.

• Click the underlined value next to Particles Down, type 0, and click OK.

• Click the underlined value next to Particle Radius/Font Size, type 0, and click OK.

Layer Exploder and Particle Exploder (PB only)
The Layer Exploder explodes a layer into new particles, and the Particle Exploder explodes 
a particle into more new particles. In addition to explosion effects, the exploders are also 
handy for simulating fireworks or for rapidly increasing the number of particles.

The following guidelines can help you control particles resulting from an explosion:

• A layer is exploded once for each frame. By default, this creates a continuous shower of 
particles for the duration of the composition. If you want to start or stop a layer 
explosion, animate the Radius of New Particles option using keyframes so that its value 
is zero at times when you don’t want particles to be created.

• If the source of the layer is a nested composition, you can set different Opacity property 
values or In and Out points for the layers within the nested composition to make the 
exploding layer transparent at different points in time. The Layer Exploder does not 
create particles where the source of the layer is transparent.

• To change the position of the exploding layer, precompose the layer with its new 
position (use the Move All Attributes into The New Composition option), and then use 
the precomposed layer as the exploding layer.
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• When you explode particles, the new particles inherit the position, velocity, opacity, 
scale, and rotation of the original particles.

• After you explode layers or particles, the movement of particles is influenced by the 
Gravity, Repel, Wall, and Property Mapper options.

Applying the Layer Exploder to a layer

Applying the Particle Exploder to particles

The Layer Exploder and Particle Exploder use the term “explode” in a purely physical 
sense— the breakup of layers and particles and how the resulting particles are pushed 
away from the original position. If you want to create a fiery explosion with smoke and 
sparks, composite this effect with other layers containing fire, smoke, and sparks (either as 
additional particle effects or from actual footage).

Some Property Mapper options can make explosions more realistic (see “About 
Property Mappers (PB only)” on page 366). For example, change Opacity to make the 

resulting particles fade out, or change the Red, Green, and Blue color channels to make 
resulting particles change color as they appear to cool.

You can adjust the following options for Layer Exploder and Particle Exploder:

Explode Layer (Layer Exploder only) Choose the layer you want to explode. To make the 
video disappear the moment the particles appear, either turn off the video for the layer or 
trim the layer’s Out point.

Radius of New Particles Type a value for the radius of the particles resulting from the 
explosion. This value must be smaller than the radius of the original layer or particle.

Velocity Dispersion Type a value, in pixels per second, as the maximum speed of the 
range within which Particle Playground varies the velocity of the resulting particles. High 
values create a more dispersed or cloudlike explosion. Low values keep the new particles 
closer together and can make the exploded particles resemble a halo or shock wave.

To explode a layer:

1 In the Effect Controls window for the composition, click the right-facing triangle next to 
Layer Exploder so that it points downward.

2 Specify options.
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To explode particles:

1 In the Effect Controls window, click the right-facing triangle next to Particle Exploder so 
that it points downward.

2 Specify options.

3 To apply the effect to a subset of particles, specify the Affects properties as necessary 
(see “Using Affects options to specify particles (PB only)” on page 372).

Replacing default particles with a layer (PB only)
By default, the Cannon, Grid, and Exploders create dot particles. However, you can use the 
Layer Map to assign any other layer in the composition as a particle source layer that 
replaces the dots. For example, if you use a movie of a single bird flapping wings as a 
particle source layer, After Effects replaces all dots with an instance of the bird movie, 
which results in a flock of birds on the layer. A particle source layer can be a still image, a 
solid, or a nested After Effects composition.

If you replace a particle with a layer containing motion footage, you can specify which 
frame each particle uses at the time it is created. This makes it possible to have animated 
particles or to create variations among particles on the same layer. The frame that a 
particle takes from a source layer is determined by the current time and the Time Offset 
settings (see “Specifying the frames you want to map (PB only)” on page 359).

A. Layer of a movie source that contains different sequential frames B. Using the movie for the 
particle source allows wide variations in particle appearance.

Note: When you choose a layer for the Layer Map, Particle Playground ignores any 
property or keyframe changes that you made to that layer within that composition; 
instead, it uses the layer in its original state. To keep transformations, effects, masks, 
rasterization options, or keyframe changes for a layer when you use it as a particle source, 
precompose the layer.

A

B
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Specifying the frames you want to map (PB only)
A multiframe layer is any layer whose source varies over time, such as a movie or a compo-
sition. When you map new particles from a multiframe layer, use Time Offset to specify 
how you want to use the layer’s frames. This provides even more flexibility for the range of 
source footage you can use in a single particle animation.

For example, use Absolute Time Offset to map an unchanging image onto a particle, or 
use Relative Time Offset to map an animating sequence of frames onto a particle. Both 
Relative and Absolute Time Offset can be randomized across particles.

A. Layer of a movie source that stores different, nonsequential objects in each frame B. Using 
Absolute Random Time Offset to create particles from that layer

Using Time Offset, you can choose a frame from which to start playing sequential frames 
from the source layer you’re using to create particles. This way, you can achieve more 
realistic particle effects. For example, if you are using a source layer of a bird flapping its 
wings with a Relative Time Offset of 0 (zero), the flapping wings for all the instances of the 
bird will be synchronized. While this might be realistic for a marching band, it is not 
realistic for a flock of birds. To make each bird start flapping its wings from a different 
frame in the source layer, specify a Relative Random Time Offset when you set Layer Map 
options.

You can adjust the following Time Offset types for Layer Map:

Relative Starts playing the source layer (the layer selected in the Use Layer menu of the 
Layer Map property) at a frame based on the Time Offset you specify, relative to the 
Playground layer’s current time. When you use this option, the source layer frame, which 
displays as each particle, advances in step with the Playground layer’s current time.

A

B
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If you choose Relative and specify a Time Offset of 0, all particles shows the frame of the 
source layer that corresponds to the Playground layer's current time. However, if you 
choose Relative and specify a Time Offset of 0.1 (and your composition is set to 30 fps), 
each new particle starts displaying the source layer frame that is 0.1 seconds after the 
previous particle’s frame, or every third frame. Therefore, as the Playground layer plays, the 
first particle shows the frame of the source layer that corresponds to the Playground 
layer’s current time, the second particle shows the frame of the source layer that is 0.1 
seconds later than the current time, the third particle shows the frame of the source layer 
that is 0.2 seconds later than the current time, and so on.

Note that regardless of the Time Offset you specify, the first particle always displays the 
frame of the source layer that corresponds to the Playground layer’s current time.

Absolute Displays a frame from the source layer based on the Time Offset you specify, 
regardless of the current time. Use this option when you want a particle to show the same 
frame of a multiframe source layer for its entire lifespan, instead of cycling through 
different frames as the Playground layer advances in time.

For example, if you choose Absolute and specify a Time Offset of 0, every particle shows 
the first frame of the source layer for its entire lifespan. If you want to show a frame other 
than the first frame, move the source layer earlier in time until the frame you want to show 
corresponds to the In point of the Playground layer. If you specify a Time Offset of 0.1, each 
new particle will display a frame that is 0.1 seconds after that of the previous particle (or 
every third frame of a 30-fps animation).

Relative Random Starts playing the source layer from a frame chosen at random, within 
the range between the Playground layer’s current time and the Random Time Max you 
specify (when you use a random Time Offset type, the Time Offset option changes to the 
Random Time Max option). For example, if you choose Relative Random and specify a 
Random Time Max of 1, each particle starts playing from a source layer frame chosen at 
random from between the current time and 1 second after the current time. If you choose 
Relative Random and specify a negative Random Time Max value, the Random Time Max 
will be before the current time, so that the range within which new particles start playing 
will advance as the current time advances, but will always be between the current time 
and one second earlier than the current time.

Absolute Random Takes a frame at random from the source layer, using a time between 
0 and the Random Time Max you specify. Use this option when you want each particle to 
represent a different single frame of a multiframe source layer. For example, if you choose 
Absolute Random and specify a Random Time Max of 1, each particle shows a source layer 
frame from a random time between 0 and 1 second into the source layer’s duration.

Choosing Layer Map options (PB only)
After you have created default particles, use the Layer Map to replace dots with a particle 
source layer.

To replace default particles with a layer:

1 If necessary, import the source footage and add it to the composition.

2 In the Timeline window, click the layer’s eye icon ( ) to hide it.

3 In the Effect Controls window under Particle Playground, expand the Layer Map 
property.
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4 For Use Layer, select a layer from the menu. The menu lists all layers used in the compo-
sition.

5 For Time Offset Type, specify how you want particles to take frames from times other 
than the current time. This option applies only when you are mapping particles to a multi-
frame layer, such as a movie or a composition. For more information, see “Specifying the 
frames you want to map (PB only)” on page 359.

6 For Time Offset (or Random Time Max), specify a value. This option applies only if you 
are mapping particles to a multiframe layer.

Note: The name of this option changes from Time Offset to Random Time Max when you 
select either Relative Random or Absolute Random from the Time Offset Type menu.

7 To replace only some of the default particles with the mapped layer, specify the Affects 
options as necessary (see “Using Affects options to specify particles (PB only)” on 
page 372).

To stop using a mapped layer:

In the Effect Controls window, under Particle Playground, expand the Layer Map property 
and choose None from the Use Layer menu. 

Replacing default particles with text (PB only)
By default, the Cannon and the Grid create dot particles. However, you can also use text 
characters as particles. For example, you can type a message that the Cannon shoots 
across the frame. You can also change the properties of any three sets of characters; for 
example, you can make some of the characters larger or brighter than others (see “Using 
Affects options to specify particles (PB only)” on page 372).

The Cannon shooting characters (left), and the Grid generating the same characters (right)

To replace default Cannon particles with text:

1 In the Effect Controls window, click Options.

2 Click Edit Cannon Text.

3 Type text in the text box, and then set the following options:

• For Font/Style, choose the font and style for Cannon characters.

• For Order, click to specify the sequence in which characters exit the Cannon. The 
sequence is relative to the character order typed in the text box. For example, if the 
Cannon Direction is set to 90 degrees (making it point to the right), English text must 
exit the Cannon last letter first to be in readable order. Therefore, select Right to Left.

• For Loop Text, select to continuously generate the characters you typed. Deselect to 
generate only one instance of the characters.
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4 Click OK.

5 Click the right-facing triangle next to Cannon so that it points downward.

6 Click the underlined Font Size value, type a value of 10 or greater, and click OK.

To replace default Grid particles with text:

1 In the Effect Controls window, click Options, and then click Edit Grid Text.

2 Set the following options:

• For Font/Style, choose the font and style for Grid characters.

• For Alignment, click Left, Center, or Right to position text in the text box at the Position 
specified in the Grid property; or click Use Grid to position each letter in the text on 
consecutive grid intersections.

• For Loop Text, select to repeat the characters you typed until all the grid intersections 
contain one character. (Grid intersections are specified by the Particle Across and 
Particle Down options; see “Particle Playground Grid (PB only)” on page 355.) Deselect 
to generate only one instance of the text. This option is available only if you selected 
Use Grid alignment.

Alignment options A. Left B. Center C. Right D. Use Grid

3 Type text in the text box. If you chose Use Grid alignment and want to skip a grid inter-
section, type a space; to force the next character down to the next grid row, press Enter 
(Windows) or Return (Mac OS).

4 Click OK.

5 Click the right-facing triangle next to Grid so that it points downward.

6 Click the underlined Font Size value, type a value of 10 or greater, and click OK.

To stop replacing default particles with text:

1 In the Effect Controls window, click Options.

2 To stop using text in the Cannon or Grid, click Edit Cannon Text or Edit Grid Text, delete 
all text from the text box, and click OK.

3 Click OK to close the Options dialog box.

Influencing the behavior of existing particles (PB only)
After particles have been created by the Cannon, Grid, Layer Exploder, or Particle Exploder, 
you can influence the physical behavior of those particles in the following ways:

• Use Gravity to pull objects in a specific direction. Applied in a vertical direction, Gravity 
is useful for creating falling particles such as rain or snow, or rising particles such as 
champagne bubbles. Applied in a horizontal direction, Gravity can simulate wind.

A B C D
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• Use Repel to avoid collisions between particles. Repel is useful for pushing particles 
apart, such as after applying the Layer Exploder. Use Repel to cause particles to attract 
by typing a negative value.

• Use Wall to contain particles within an area. Wall is useful for ping-pong effects.

Particle behavior works in conjunction with other Particle Playground properties. For 
example, if you set a Cannon particle velocity that fires particles across the frame and out 
the opposite side, you can increase the Gravity Strength until it pulls those particles down 
before they exit the frame.

Influencing individual particles over their lifespan (PB 
only)
To have full control over particle movement and appearance, you must balance the 
properties you assign to particles at particle birth (Cannon, Grid, Layer Exploder, and 
Particle Exploder) with the properties you assign to the particle’s lifespan (Gravity, Repel, 
Wall, and Property Mapper). For example, if you want to use the Cannon to shoot sparks 
that fade over time, it may seem that you need only animate the Cannon’s Color option. 
However, using this method, you change only the color of each new particle as it’s created. 
To control the color for the lifespan of particles, you must create a layer map and use the 
Property Mapper to alter the particles’ color channels.

The following list covers common particle behavior. For more information on these items, 
see “About Property Mappers (PB only)” on page 366.

Speed At particle creation, particle velocity is set by the Cannon and the exploders; Grid 
particles have no initial speed. After particle creation, use the Force option in the Gravity 
and Repel properties. You can also influence the speed of individual particles by using a 
layer map to set values for the Speed, Kinetic Friction, Force, and Mass properties in the 
Property Mappers.

Direction At particle creation, the Cannon includes particle direction, the Layer Exploder 
and Particle Exploder send new particles in all directions, and Grid particles have no initial 
direction. After particle creation, direction can be influenced by the Direction option in 
the Gravity property, or by using a mask with the Wall property. You can also influence the 
direction of individual particles by using a layer map to set values for the Gradient Force, X 
Speed, and Y Speed properties in the Property Mappers.

Area Use a Wall mask to contain particles to a different area or to remove all barriers. You 
can also restrict particles to an area by using a layer map to set values for the Gradient 
Force property in the Property Mappers.

Appearance At particle creation, the Cannon, Grid, Layer Exploder, and Particle Exploder 
operators set particle size unless you replace the default dots with a layer map. The 
Cannon and Grid set the initial color, while the Layer Exploder and Particle Exploder take 
color from the exploded dot, layer, or character. The Options dialog box affects the initial 
appearance of text. After particle creation, you can use the Property Mappers to set values 
for the Red, Green, Blue, Scale, Opacity, and Font Size properties.
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Rotation At particle creation, the Cannon and Grid set no rotation; the Particle Exploder 
takes rotation from the exploded dot, layer, or character. Use Auto-Orient Rotation to 
make particles rotate automatically along their respective trajectories; for instance, a 
particle can point up as it climbs an arc, and point down as it descends. Rotation isn’t 
easily visible for a dot particle. It is easier to observe only when you replace the dot 
particle with text characters or a layer. After particle creation, use a layer map to set values 
for the Angle, Angular Velocity, and Torque properties in the Property Mappers. 

Note: The appearance and rotation of a layer map particle changes in relation to the 
mapped layer’s original appearance and rotation. For instance, if you replace the default 
dot particles with a movie of a spinning wheel, the spinning-wheel particles appear to 
spin when no particle rotation is applied.

To rotate particles automatically along their trajectories:

1 In the Effect Controls window under Particle Playground, click Options.

2 Select Auto-Orient Rotation to turn it on, and click OK.

Using gravity to pull particles (PB only)
Use Gravity to pull existing particles in a direction you specify. As in the physical universe, 
particles accelerate in the direction of gravity.

Gravity set to zero (left) does not affect particle direction. Increased gravity (right) pulls particles 
down.

You can adjust the following options for Gravity:

Force Specifies the force of gravity. Positive values increase the force, pulling particles 
more strongly. Negative values reduce the force.

Force Random Spread Specifies a range of randomness for the Force. At zero, all 
particles fall at the same rate. At a higher value, particles fall at slightly different rates. 
Although pure gravity accelerates all objects equally, increasing the Force Spread can 
produce more realistic results with subjects such as leaves falling through air, where there 
is enough air resistance to vary the leaves’ rates of descent.

Direction Specifies the angle along which gravity pulls. The default is 180 degrees, which 
simulates the real world by pulling particles toward the bottom of the frame.

Affects Specifies a subset of the layer’s particles to which Gravity applies. See “Using 
Affects options to specify particles (PB only)” on page 372.
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Repelling and attracting particles (PB only)
Use Repel to control how nearby particles repel or attract each other. This feature 
simulates adding a positive or negative magnetic charge to each particle. You can specify 
which particles, layers, or characters are the repelling force and which are repelled.

Note: If you want to repel an entire layer of particles away from a specific area, use Wall 
(see “Containing particles with a wall (PB only)” on page 365) or Gradient Force in Property 
Mappers (see “About Property Mappers (PB only)” on page 366).

You can adjust the following options for Repel:

Force Specifies the repel force. Greater values repel particles with more force; negative 
values result in particle attraction.

Force Radius Specifies the radius (measured in pixels) within which particles are repelled. 
Another particle must be within this radius to be repelled.

Repeller Specifies which particles act as the repellers or attractors to another subset you 
specify using the Affects option. See “Using Affects options to specify particles (PB only)” 
on page 372.

Affects Specifies a subset of the layer’s particles to which repulsion or attraction applies. 
See “Using Affects options to specify particles (PB only)” on page 372.

Containing particles with a wall (PB only)
Use Wall to contain particles, limiting the area within which particles can move. A wall is a 
closed mask that you create using a mask tool, such as the pen tool. By creating a wall you 
can make particles stay within a specific area. When a particle hits the wall, it bounces off 
at a velocity based on the force with which it hit.

Without walls, particles can roam about or exit a frame (left). Walls added to the left and right sides 
restrict particle movement to the middle of the frame (right).

To contain particles within an area:

1 Open the Particle Playground layer in the Layer window and create a closed path to use 
as a wall.

2 In the Effect Controls window under Particle Playground, expand the Wall property.

3 From the Boundary menu, choose the path you created.

To apply the effect to a subset of particles, specify the Affects options as necessary 
(see “Using Affects options to specify particles (PB only)” on page 372).

To turn off the wall:

1 In the Effect Controls window under Particle Playground, expand the Wall property.
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2 From the Boundary menu, choose None.

About Property Mappers (PB only)
Control specific properties of individual particles using the Property Mapper. You can’t 
alter a specific particle directly, but you can use a layer map to specify what will happen to 
any particle that passes over a specific pixel in the layer. Particle Playground interprets the 
brightness of each layer map pixel as a specific value (see “About layer maps (PB only)” on 
page 374). The Property Mapper options associate a specific layer map channel (Red, 
Green, or Blue) with a specific property, so that as a particle passes over a certain pixel, 
Particle Playground uses the brightness value provided by the layer map at that pixel to 
modify the specified property for that particle.

For example, if you want to control the size of particles at certain areas within the frame, 
create a layer map and associate it with the Scale property so that the particle size 
increases as the pixel brightness value increases. Particles passing over lighter areas will be 
larger than particles passing over darker areas. If you associate the layer map with the 
Angular Velocity property instead, particles passing over lighter areas rotate around their 
own centers faster than they would when passing over darker areas of the layer map.

Persistent and Ephemeral Property Mappers (PB only)
A particle property can be modified in either a persistent or an ephemeral way:

• A persistent change to a particle property retains the most recent value set by a layer 
map for the remaining lifespan of the particle, unless the particle is modified by 
another operator such as Repel, Gravity, or Wall. For example, if you use a layer map to 
modify particle size, and you animate the layer map so it exits the frame, the particles 
will keep the last size value set by the layer map after it has exited the frame.

• An ephemeral change to a particle property causes the property to revert to its original 
value after each frame. For example, if you use a layer map to modify particle size, and 
you animate the layer map so that it exits the frame, each particle returns to its original 
size value as soon as no layer map pixels correspond to it. Similarly, if you apply an 
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operator such as Add, each time a particle passes over a different layer map pixel, the 
value of the layer map pixel is added to the original value of the particle.

The white circle was placed in a composition, and its position was animated.

The white circle composition was used as a map in the Persistent Property Mapper and was 
associated with the scale of the particles.

The white circle composition was used as a map in the Ephemeral Property Mapper and was 
associated with the scale of the particles.

For more information, see “Using Property Mappers (PB only)” on page 367.

Using Property Mappers (PB only)
In combination with keyframes, the Property Mapper options provide complete control 
over individual particle properties in space and time. Using layer maps, you can change 
particle properties at any location within a frame. By applying keyframes to Property 
Mapper options and animating a layer map, you can control how particle properties 
change.

To set particle properties:

1 In the Effect Controls window under Particle Playground, expand the Persistent 
Property Mapper or Ephemeral Property Mapper. You can use one or both as necessary.

2 For Use Layer as Map, choose a layer map to use as the source for values that modify 
particle values. The layer map must be part of the composition. For more information, see 
“About layer maps (PB only)” on page 374.

3 To apply the effect to a subset of particles, specify the Affects properties as necessary 
(see “Using Affects options to specify particles (PB only)” on page 372).
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4 For each of the Map Red To, Map Green To, and Map Blue To option groups, choose a 
property from the menu to associate it with the color channel as necessary. You don’t have 
to map properties to all of the color channels. For example, if you want to change scale 
over an image map, you can map the color red to scale without setting other properties.

5 If necessary, for each Map To option group, specify the lowest and highest values you 
want the layer map to produce using the Mix and Max options. Min is the value to which a 
black pixel will be mapped, and Max is the value to which a white pixel will be mapped. 
The complete tonal distribution between Min and Max is then scaled proportionally. See 
“Using Min and Max options to adjust the output range of a layer map (PB only)” on 
page 368.

6 If you’re using the Ephemeral Property Mapper, you can also choose an operator to 
apply to the value of a particle property and the value of the corresponding layer map 
pixel. For more information, see “Using Ephemeral Property Mapper operators to adjust 
values (PB only)” on page 369.

Note: Because particle properties use many kinds of units, such as pixels, degrees, and 
seconds, you may want to compress or expand the range of values from the layer map so 
that all the resulting values are usable in the measurement system of a specific particle 
property. First, use the Min and Max options, which define the range of values to use from 
the layer map. If further adjustment is necessary and you’re using the Ephemeral Property 
Mapper, use mathematical operators that can amplify, attenuate, or limit the effect of a 
layer map. 

Using Min and Max options to adjust the output range of a layer 
map (PB only)
When the overall range of layer map brightness values is too wide or narrow, use the Min 
and Max options to stretch, compress, or shift the range of values produced by the layer 
map. The following examples describe when you might want to adjust Min and Max:

• You want to set the smallest font size for your text to be 10 points and the largest size to 
be 96 points. Set the Min value to 10 and the Max value to 96.

• You set the initial color of a particle and then use a layer map to change particle colors. 
If you find that the color changes aren’t dramatic enough, you can lower the Min value 
and raise the Max value to increase the contrast of the color changes.

• You set the initial velocity of a particle and then use a layer map to affect the X Speed 
property. However, you find that the difference between the fastest and slowest 
particles is too great. By raising the Min value and lowering the Max value for the layer 
map channel that is mapped to the X Speed property, you narrow the resulting range 
of particle speeds.

• You use a layer map to affect the Scale property of particles and find that the smallest 
particles aren’t small enough while the largest resulting particles are too large. In this 
case the entire output range needs to be shifted down; lower both the Min and 
Max values. 
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• You have a layer map that modifies particles in the opposite direction from the one you 
want. Swap the Min and Max values, which will have the same effect as inverting the 
layer map.

Note: The alpha channel of the layer map is used as the selection map for the Persistent 
and Ephemeral Property Mappers. See “Using Affects options to specify particles (PB only)” 
on page 372.

Using Ephemeral Property Mapper operators to adjust values (PB 
only)
By default, Particle Playground replaces the value of a particle’s property with the value 
represented by the layer map pixel at the particle’s current location. You can also amplify, 
attenuate, or limit the resulting values by specifying a mathematical operator in the 
Ephemeral Property Mapper, and then using both the value of a particle’s property and its 
corresponding layer map pixel value. Operators are available only in the Ephemeral 
Property Mapper. The following operators are available:

Set Replaces the value of a particle property by the value of the corresponding layer map 
pixel. This is the default operator.

Add Uses the sum of the value of a particle property and the value of the corresponding 
layer map pixel. 

Difference Uses the absolute value of the difference of the value of a particle property 
and the brightness value of the corresponding pixel on the layer map. Because it takes the 
absolute value of the difference, the resulting value is always positive. This operator is 
useful when you want to limit values to only positive values. If you’re trying to model 
realistic behavior, the difference operator may not be ideal.

Subtract Starts with the value of a particle property and subtracts the value of the 
brightness value of the corresponding pixel on the layer map.

Multiply Multiplies the value of a particle property by the value of the brightness value of 
the corresponding pixel on the layer map and uses the result.

Min Compares the brightness value of the layer map to the value of the particle property 
and uses the lower value.

Max Compares the brightness value of the layer map to the value of the particle property 
and uses the higher value.

If you are not familiar with mathematical operators, the following guidelines can help you 
decide whether you should use an operator:

• The most predictable operator to use is Set, which is the default, because it simply 
replaces the value of a particle property with the value of the brightness value of the 
corresponding pixel on the layer map.

• To amplify existing values of properties, try applying the Add operator with positive 
values or the Multiply operator with values above 1.0.

• To attenuate (tone down) property value changes, try applying the Multiply operator 
using values between 0 and 1.0.

• To limit a particle property so it is less than or equal to a value, use the Min operator and 
set both the Min and Max properties to that value. If you use a white solid as a layer 
map, you need only set the Max property to that value.
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Using a layer map to specify particles affected by a Property 
Mapper (PB only)
In both the Persistent and Ephemeral Property Mappers, you can use the layer map’s alpha 
channel to make more subtle changes to the value of a particle property. For example, 
particles over a layer-map pixel in which the alpha channel value is 255 are fully affected, 
while lower values affect particles less. Layer-map pixels that are completely transparent 
have no effect on particle properties. For more information, see “About layer maps (PB 
only)” on page 374.

Note: As with other sets of options in Particle Playground, you can also use the Affects 
options in both the Persistent and Ephemeral Property Mappers to narrow the set of 
particles that are affected. See “Using Affects options to specify particles (PB only)” on 
page 372.

When you set any of the following properties, Particle Playground copies the value from 
the layer map (that is, the layer selected in the Use Layer as a Map menu) and applies it to 
the particle.

None Modifies no particle property.

Red Copies the value of the particle’s red channel within a range of 0.0–1.0.

Green Copies the value of the particle’s green channel within a range of 0.0–1.0.

Blue Copies the value of the particle’s blue channel within a range of 0.0–1.0.

Kinetic Friction Copies the amount of resisting force against a moving object, typically 
within a range of 0.0–1.0. Increase this value to slow down or stop moving particles as if 
braking.

Static Friction Copies the amount of inertia that holds a stationary particle in place, 
typically within a range of 0.0–1.0. At zero, a particle will move when any other force, such 
as gravity, is present. If you increase this value, a stationary particle requires more of 
another force to start moving.

Angle Copies the direction in which the particle points, in degrees relative to the 
particle’s original angle. The angle is easily observable when a particle is a text character or 
a layer without radial symmetry.

Angular Velocity Copies the velocity of particle rotation in degrees per second. This 
determines how fast a particle rotates around its own axis. 

Torque Copies the force of particle rotation. The angular velocity of a particle is increased 
by a positive torque and is increased more slowly for particles of greater mass. Brighter 
pixels affect angular velocity more forcefully; if enough torque is applied against angular 
velocity, the particle starts spinning in the opposite direction.

Scale Copies the scale value of a particle along both the X and Y axis. Use this to stretch a 
particle proportionally. A value of 1.0 scales the particle to its full size; a value of 2.0 scales 
it 200%, and so on.

X Scale/Y Scale Copies the scale value of a particle along the X or Y axis. Use these to 
stretch a particle horizontally or vertically.

X/Y Copies the position of a particle along the X or Y axis in the frame, in pixels. A value of 
zero specifies a position at the left of the frame (for X) or at the top of the frame (for Y).

X Speed/Y Speed Copies the horizontal speed (X-axis velocity) or vertical speed (Y-axis 
velocity) of a particle in pixels per second.
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Gradient Force Copies the force adjustment based on areas of a layer map on both the X 
and Y planes of motion. The pixel brightness values in the color channel define the resis-
tance to particle force at each pixel, so the color channel acts like a layer map of hills and 
valleys that decrease or increase particle force. In the layer map, areas of equal brightness 
result in no adjustment, similar to flat land. Lower pixel values represent less resistance to 
a particle’s force, similar to a downhill grade. Higher pixel values represent more resistance 
to a particle’s force, similar to an uphill grade. For best results, use a soft-edged layer map 
image.

 If you are using a layer map for Gradient Force where flat areas equal no adjustment, 
and you are using the Min and Max properties (not the Min or Max operators) to set 

the range of values for Gradient Force, set them to positive and negative values of the 
same number (for example, –30 and +30). This ensures that the middle of the range 
remains centered at zero.

Gradient Velocity Copies the velocity adjustment based on areas of a layer map on both 
the X and Y planes of motion. See Gradient Force.

X Force Copies the coercion along the X axis of motion. Positive values push a particle to 
the right.

Y Force Copies the coercion along the Y axis of motion. Positive values push a particle 
down.

Opacity Copies the transparency of a particle, where zero is invisible and 1 is solid. Adjust 
this value to fade particles in or out.

Mass Copies the particle mass, which interacts with all properties that adjust force, such 
as Gravity, Static Friction, Kinetic Friction, Torque, and Angular Velocity properties. It takes 
greater force to move particles with a larger mass.

Lifespan Copies the elapsed length of time a particle will exist, in seconds. At the end of 
its lifespan, the particle is removed from the layer. The default lifespan is effectively 
immortal.

Character Copies the value that corresponds to an ASCII text character, making it replace 
the current particle. Applies only if you’re using text characters as particles. You can specify 
which text characters appear by painting or drawing shades of gray on the layer map that 
correspond to the ASCII characters you want. A value of zero produces no character. For 
U.S. English characters, use values between 32 and 127. The range of possible values can 
accommodate Japanese characters. For more information about the ASCII character 
values for a font you’re using, see the documentation for the font, use a utility such as 
Character Map (Windows), or contact the font manufacturer.

Note: If you simply want to make certain characters spell a message, it’s much easier to 
type the text directly in the Options dialog box. The Character property is more useful as a 
secret message effect in which you scramble text characters. For more information, see 
“Replacing default particles with text (PB only)” on page 361.

Font Size Copies the point size of characters. Applies only if you’re using text characters 
as particles. Increase this value to make characters larger.

Time Offset Copies the Time Offset value used by the Layer Map property. Applies only if 
you used the Layer Map property to specify a multiframe layer (such as a movie) as a 
particle source (see “Replacing default particles with a layer (PB only)” on page 358).
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Using layer-map RGB channels to alter multiple properties 
independently (PB only)
In both the Persistent or Ephemeral Property Mappers, you can control up to three particle 
properties independently by using a single RGB image as a layer map. Particle Playground 
achieves this by extracting brightness values separately from the red, green, and blue 
channels in the image. The Persistent and Ephemeral Property Mapper options map the 
red, green, and blue channels to different properties through the individual color map 
menus: Map Red To, Map Green To, and Map Blue To. You don’t have to use all three 
channels if you want to modify just one property. To change just one property or change 
up to three properties using the same values, use a grayscale image as the layer map, 
because the RGB channels are identical. For more information, see “Creating an RGB layer 
map (PB only)” on page 375.

A. Layer map viewed in RGB mode. B. The red channel contains a spiral layer. C. The green channel 
contains a horizontal-gradient layer map. D. The blue channel contains a vertical-gradient layer 
map.

Using Affects options to specify particles (PB only)
Many Particle Playground properties include a group of settings under the heading 
Affects that specify which particles are affected by an option. You can include or exclude 
particles based on their properties.

Using the Older/Younger Than option to make particles older than a certain age (left) change color 
(right)

To specify the particles that are affected by an option:

Under the property name, click the right-facing triangle next to Affects, and specify the 
following settings:

Particles From Choose the particle generator or combination of particle generators 
whose particles you want to be affected by the current option.

A B C D
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Selection Map Choose a layer map that influences which particles are affected by the 
current option (see “About layer maps (PB only)” on page 374). Selection is based on the 
brightness, or luminance, of each pixel in the layer, so a particle is affected more or less as 
it passes over layer map pixels of different brightness. By default, a property affects a 
particle 100% where the brightness value of a corresponding layer map pixel is 255 
(white), and has no effect where the brightness value of a corresponding layer map pixel is 
0 (black).

Note: The simulation space is not bounded by the dimensions of the layer to which 
Particle Playground is applied. You may need to use a selection map that is larger than the 
Playground layer so that dots that are not visible are still affected by Selection Map 
options.

Characters Choose a text field containing the characters you want to be affected by the 
current option. This option applies only if you are using text characters as the particle type. 
For example, if you’re setting up the Gravity property and you define a text field 
containing the characters A, E, I, O, and U, the current option affects those characters only. 
(The Characters option is case-sensitive.) To define the text fields, click Options at the top 
of the Particle Playground effect controls section, type text in Selection Text 1, Selection 
Text 2, and Selection Text 3 as necessary, and click OK. (The characters you type here are 
also case-sensitive.) Once you’ve created selection text, choose the selection from the 
Characters menu under Affects. For more information, see “Replacing default particles 
with text (PB only)” on page 361.

Older/Younger Than Specify the age threshold, in seconds, above or below which you 
want a particle to be affected by the current option. Specify positive values to affect older 
particles, or negative values to specify younger particles. For example, if you set this 
option to 10, all particles older than 10 seconds use the new value. As soon as a particle 
reaches 10 seconds, it changes to the new value.

Age Feather Specify the age range in seconds within which the Older/Younger Than 
value is feathered, or softened. Feathering creates a gradual, rather than abrupt, change. 
For example, if you set Older/Younger Than to 10 and Age Feather to 4, about 20% of 
particles will start changing when they’re 8 seconds old, 50% will change when they’re 10 
seconds old (the Older/Younger Than value), and the remainder will change by the time 
they’re 12 seconds old. 
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About layer maps (PB only)
A layer map is an image in which each pixel’s brightness value is used by an effect in a 
calculation. Particle Playground uses a layer map to exercise precise control of a particle 
property such as opacity. In this way, After Effects doesn’t use a layer map as a picture but 
as a matrix of numbers. In many cases, you never see the actual layer map in the final 
movie—you only see the result of an effect applying the layer map’s pixel values to the 
corresponding pixels in a destination layer.

Layer maps (left) can change properties of the particles that pass over them, such as scale (right).

Regardless of the color depth of the image that you use as a layer map, After Effects always 
uses its red, green, and blue channels as if each were an 8-bit grayscale image. If you 
create a layer map using colors, the Property Mappers in Particle Playground can extract 
the brightness values from each RGB color channel separately (see “Using layer-map RGB 
channels to alter multiple properties independently (PB only)” on page 372).

Creating a layer map (PB only)
Layer maps are often created by painting them in an image-editing program such as 
Adobe Photoshop, although you can use any program that can save an image compatible 
with After Effects. The key to creating a good layer map is to remember that the brightness 
value of each pixel influences an effect property. Here are some hints and tips for creating 
layer maps:

• If you want a layer map to match the shape of an image that already exists, simply use 
that image. For best results, create a layer map that has the same dimensions as the 
layer containing the image.

• You can create a layer map by precomposing a white solid layer, a black solid layer, and 
a mask on the top layer that determines which areas are white and black. Increasing the 
mask’s Mask Feather property softens the transition between black and white values. 

• In Photoshop, an easy way to create a layer map is to create a layer with a black or white 
background, draw a selection, and fill the selection with the opposite color. Blurring the 
entire layer softens the transition between black and white values.

• You can set layer map values more precisely by painting shades of gray within a range 
from 0 (black) to 255 (white). This is the tonal range of an 8-bit channel. To simplify 
painting or drawing, see if your painting or drawing program provides or allows you to 
create a palette of 256 gray shades.

Note: While images created for use as displacement maps (in other effects or programs) 
often map tones to values on a scale from –127 to +127, Particle Playground interprets 
tones of gray as values on a scale from 0.0 (black) to 1.0 (white). If you’re using images 
created as displacement maps, use the Min and Max properties to modify the range of 
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tones produced by the layer map. See “Using Min and Max options to adjust the output 
range of a layer map (PB only)” on page 368.

• The alpha channel in a layer map modifies the value before it’s applied to the desti-
nation layer. Areas where the alpha channel is completely off (transparent areas of a 
layer map) have no effect on particle values. Areas where the alpha channel has a 
partial value (semitransparent areas of a layer map) partially affect the particle value. 
For example, if a layer-map pixel has a value of 10 and the layer-map alpha channel has 
a value of 127 (50%), the layer-map pixel is affected by 50% and its true value is 5. When 
you use the Persistent and Ephemeral Property Mappers, the actual value applied to a 
particle is also affected by the range set for the Min and Max options; see “Using Min 
and Max options to adjust the output range of a layer map (PB only)” on page 368.

• If you want to change any of the layer map’s layer properties (Masks, Effects, or 
Transform), change them, precompose the layer, and then use the resulting compo-
sition as the layer map. Otherwise, Particle Playground ignores any property settings.

• The contrast between adjacent pixel values determines how smoothly the values 
change across the surface of the layer map. To create smooth changes, paint using a 
soft or anti-aliased brush, or apply gradients. To create abrupt changes, avoid interme-
diate shades, using just a few widely spaced shades such as 50% gray, black, and white.

• You can adjust overall edge contrast with blur or sharpen filters, if your painting or 
drawing program provides them.

Note: If you want to edit individual pixels, open the layer map in the program you used to 
create it and make the change.

Creating an RGB layer map (PB only)
Particle Playground can extract brightness values separately from the red, green, and blue 
channels in an image. If you want to create different layer maps for each channel, use a 
program that can edit individual color channels, such as Adobe Photoshop, and then paint 
or paste each layer map into its own channel. Save the layer map as an RGB image in a 
format After Effects can import. The image may look unusual when viewed in RGB mode 
because it’s intended to be used as a single hidden layer containing three different layer 
maps, not as a visible color layer.

When you apply an effect that can use each color channel as a separate layer map, you can 
still use a grayscale image; the RGB channels will be identical.

If you already have three separate images, you can combine them into a single RGB file 
using the Set Channels effect. Set Channels can load each image into its own channel 

in a combined file, making it suitable for use as an RGB layer map. 

Setting up a layer map in a composition (PB only)
Before you apply a layer map to a particle layer, the layer map and the particle layer must 
be contained within the same composition, in a stacking order that will produce the 
results you want.

To set up a layer map:

1 Add the layer map to the composition.

2 Do one of the following:
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• If you want particles to be visible in front of the layer map, make sure that the layer with 
Particle Playground applied is in front of the layer map.

• If you don’t want the layer map to be visible, hide it by clicking the layer’s eye icon ( ) in 
the Timeline window.

Animating a layer map (PB only)
A layer map is often used as a stationary layer of the same dimensions as its destination 
layer. The value of each pixel in the layer map applies only to one specific pixel at the corre-
sponding position in the destination layer. However, when you animate a layer, the 
appearance of the pixels in the destination layer changes depending on which layer-map 
pixel corresponds to it at a particular point in time. Layer maps are often animated so that 
the layer map effect appears to sweep through the destination layer.

A layer map larger than the frame, rotated to animate value changes in the layer that uses it

The result of the layer map above associated with the Scale property of particles—brighter values 
create bigger particles, and darker values create smaller particles
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(5.5) Working with 
After Effects 5.5 to Build a 
Composition

Deleting the preference file upon launching
Delete the preference file while After Effects 5.5 launches to save the step of manually 
deleting the preference file from its folder. To delete the preference file upon launch, hold 
down Ctrl (Windows) or Command (Mac OS) as you launch the application, and click OK to 
confirm deletion. 

Note: Deleting the preference file resets all custom settings to default values. This includes 
all custom presets, render settings templates, output module templates, and workspaces. 
To prevent loss of your templates and workspaces, save them to your hard drive. For infor-
mation on saving templates, in the User Guide see “Creating and using render settings 
templates” in chapter 14 and “Creating and using output module templates” in 
chapter 14. For information on saving workspaces, see “Customizing the workspace” in 
chapter 3.

Using the new import options
After Effects 5.5 now can import the following file formats: 

• Macromedia® Flash™ .swf

• 8-bits-per-channel and 16-bits-per-channel Maya IFF

• 8-bits-per-channel and 16-bits-per-channel Discreet RLA/RPF

• 16-bits-per-channel SGI

• MPEG-1

Using 16-bits-per-channel support
After Effects 5.5 now supports 16-bits-per-channel Adobe Photoshop plug-in modules.

Using the Project window
The Project window supports several new features.

Creating compositions from Project window footage
You can quickly create compositions from multiple Project window items. The New 
Composition from Selection dialog box includes several options for creating new compo-
sitions from footage items you select. 
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To create single or multiple compositions from multiple Project window items:

1 In the Project window, select at least two footage items.

2 Do one of the following:

• Drag the selected footage to the New Composition button.

• Choose File > New Composition from Selection. 

3 Specify the following options in the New Composition from Selection dialog box as 
they apply, and click OK:

Single Composition Specifies that one composition is created containing all of the 
selected items.

Multiple Compositions Specifies that one composition is created for each of the 
selected items. The composition size, frame rate, and duration are the same as those of 
each respective source.

Use Dimensions From Specifies which of the selected footage items’ dimensions are 
used as the overall composition dimensions. This is unavailable if you choose Multiple 
Compositions. The composition frame rate and duration will be the same as the footage 
you choose in this menu. If you choose a still image from this menu, the resulting compo-
sition will have the same frame rate and duration as the most recently created compo-
sition. 

Still Duration Specifies the duration of the stills in the new compositions.

Add to Render Queue Specifies that each new composition is added to the render 
queue.

Sequence Layers Specifies how the layers are staggered in the new composition. This is 
unavailable if you choose Multiple Compositions.The options here are the same as in the 
Sequence Layers Keyframe Assistant. For more information on using this keyframe 
assistant, see “Automatically arranging layers as a sequence” in chapter 6.

Replacing source footage globally by dragging in the Project 
window
When working on a project, you may want to replace the source for a layer with another 
item that is in the Project window and, subsequently, have the new source appear in all 
the compositions that use the replaced (old) source. In After Effects 5.5, you can replace 
every instance of a layer’s source by dragging within the Project window. To perform this 
global replacement, hold down Alt (Windows) or Option (Mac OS) as you drag the new 
item in the Project window to the item you want it to replace.

Revealing a layer in the Timeline or Composition window
In your work, you may have used one particular source footage or composition several 
times over several open compositions, but want to reveal only one instance of its use. You 
can now do this from the Project window. To reveal an instance of source footage or of a 
composition used in the Timeline window, right-click (Windows) or Control-click (Mac OS) 
the source footage in the Project window and choose Reveal in Composition > (Compo-
sition Name, Layer Name) where Composition Name is the composition in which the 
footage resides and Layer Name is the layer in which you used the source footage or 
composition.
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Deleting items in the Project window without an alert
When you are sure you want to delete a Project window item, you may not need a warning 
dialog box to appear before the deletion takes place. To delete a Project window item 
without a warning dialog box appearing first, select the item or items you want to delete 
and press Ctrl+Backspace (Windows) or Command+Delete (Mac OS).

Using new palette and window features
After Effects 5.5 introduces new palettes and additions to existing windows that allow for 
quick access to settings, footage, and tools. 

In addition to the features below, After Effects 5.5 adds multiple composition views that 
you can use for more precise layer and effect placement. Multiple views work in both 2D 
and 3D. For details on multiple composition views, see “Using multiple views” in 
chapter 23.

Cycling through tools 
You can now cycle quickly through all the available tools in the toolbox. A triangle in the 
bottom right corner of a tool button indicates that other tools are accessible for that 
button, but hidden. To access these hidden tools quickly, hold down Alt (Windows) or 
Option (Mac OS) as you click the tool button. You can also press the tool’s corresponding 
keyboard shortcut repeatedly. For example, press C multiple times to cycle through the 
camera tools.

Setting Wireframe view in the Composition window
The ability to quickly switch your Composition window view to Wireframe mode is useful if 
you want to quickly reposition a high-resolution or data-intensive layer. To turn Wireframe 
mode on or off, click the Layer Wireframes button  at the bottom of the Composition 
window.

Resetting the anchor point
Dragging the anchor point with the pan behind tool repositions both the layer’s anchor 
point and adjusts the layer’s position in order to maintain its visual location in the compo-
sition. New to After Effects 5.5 is the ability to quickly reset the anchor point to be the 
center of the layer. Once you reset the anchor point, the layer retains the same position 
value but changes its visual location to account for the new anchor point position. To reset 
the anchor point, double-click the pan behind tool  in the toolbox. To reset the anchor 
point and reset the position to the center of the composition, hold down Alt (Windows) or 
Option (Mac OS) and double-click the pan behind tool.
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Undoing composition settings
If you make a mistake in your composition settings after you have closed the Composition 
Settings window, you can now undo them. To undo the composition settings immediately 
after you’ve closed the settings window, choose Edit > Undo Composition Settings. If you 
must perform multiple undos, continue choosing Edit > Undo to cycle through all of your 
previous actions, and then choose Undo Composition Settings.

Note: When you perform multiple undos, the maximum number is the number that you 
have set in Preferences. To check or change your available undo levels, choose Edit > 
Preferences > General.

Setting view options
Manage the combination of layer handles, motion paths, wireframes, and so forth that you 
see in the Composition window from within the View Options dialog box. Access this 
dialog box either from the Composition window or View menus or by Alt-clicking 
(Windows) or Option-clicking (Mac OS) the Layer Wireframes button  at the bottom of 
the Composition window. In the View Options dialog box, select, deselect, or choose the 
particular element you want to be visible; in the case of the Camera and Light wireframes, 
you can also choose that they become visible only when they are selected. 

For more information on the other View Options settings, see the corresponding option in 
the After Effects 5.0 User Guide.

You can also choose a command from the application menu bar to hide or show all the 
layer controls simultaneously. To do this, choose View > Hide/Show Layer Controls.

The View Options dialog box
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(5.5) Layers

Duplicating and splitting a layer and its track matte
After Effects 5.5 now preserves the order of a layer and its track matte when you duplicate 
them or split them. In the duplicated or split set, the track matte layer remains on top of 
the fill layer. For example, previously, if your project contained layers AB, where A is the 
track matte and B the fill layer, duplicating or splitting these resulted in the layer order 
AA'BB'. Now, when you duplicate or split these layers, the layer order is ABA'B'. For infor-
mation on duplicating and splitting layers, see “Duplicating a layer” in chapter 6 and 
“Creating new layers by splitting” in chapter 6.

Copying and pasting layers
After Effects 5.5 introduces new ways to manipulate and place layers and layer attributes.

Pasting layers at the current time
When copying and pasting a layer in the Timeline window, it is useful to be able to paste a 
copied layer’s In point at a specific time in the Timeline window. 

To paste a layer at the current time:

1 In the Timeline or Project window, copy the layers or source footage you want to place 
at a precise point in time.

2 Drag the current-time marker to the time where you want the layer with the earliest In 
point to rest.

3 Press Ctrl+Alt+V (Windows) or Command+Option+V (Mac OS) to paste the layer.

Pasting into multiple layers and from one property to another
If you want to copy the keyframe attributes from one layer to multiple layers, or from one 
property to another property (or properties) on a single layer, there’s no need to perform 
multiple copy-and-paste procedures. In After Effects 5.5, you can do this in one operation. 

To paste keyframe attributes from a single layer to other layers or between 
properties in a single layer:

1 Copy the keyframes in a single layer that you want to distribute to other layers or to 
other properties within the layer you copied from.

2 Select the layers, or properties within the same layer you copied, to which you want to 
apply the copied keyframes.

3 Choose Edit > Paste. 

Note: You can copy keyframes from only one layer at a time.
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Previewing audio
A new feature aids you in creating quick previews of the composition.

Previewing audio in the work area
As you work, you may need to quickly preview audio in the work area of the Timeline 
window without rendering frames or wireframes of the video. To activate the preview, 
select the layer and press Alt (Windows) or Option (Mac OS) + . (period) on the keypad. To 
halt the preview, press the spacebar.

Accessing and editing keyframe values
When working in a Timeline window with multiple keyframes, you may want to quickly 
check the value of a single keyframe and then edit the value immediately, if necessary. To 
access a keyframe value, right-click (Windows) or Control-click (Mac OS) the keyframe you 
want to check. The context menu shows the keyframe value at the top. If you want to 
change this value, choose Edit Value.

Viewing only modified properties
When working on a composition containing a mix of animated, modified, and unmodified 
properties, you can now choose to have only the modified properties display. This allows 
for easier access to the properties for editing. To view only modified properties, select the 
layers whose properties you want to view and press U twice in rapid succession, or choose 
Animation > Reveal Modified Properties.

Scaling Mask Feather and x, y, and z values simultaneously
Sometimes, when adjusting a layer's Scale or Mask Feather value, you want to preserve the 
proportions of the current value. An option in the Timeline window for each property now 
easily facilitates this. This option, when active, performs the same function as the choices 
in the Preserve menu in the Scale dialog box and the Lock box in the Mask Feather dialog 
box. To access the Timeline option, display the underlined Scale or Mask Feather value for 
the layer you want to modify and note the box to the left of the values. The box displays a 
link icon  by default, which means that the option is on. To turn it off, click the box to 
remove the icon.
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(5.5) Working with Masks and 
Transparency

Using Smart Mask Interpolation (Production Bundle 
only)
Previous versions of After Effects provided limited controls for interpolating masks. Now, 
Smart Mask Interpolation increases your ability to control how mask shape keyframes are 
created and gives you greater possibility for smooth, realistic animation. You select the 
mask shape keyframes to interpolate between, and Smart Mask Interpolation creates 
intermediate keyframes based on settings you provide. The Info palette displays the 
progress of the interpolation and, upon completion of the interpolation, displays the 
number of keyframes created.

The Smart Mask Interpolation palette, showing the basic 
controls (left) and the optional controls (right)

To use Smart Mask Interpolation:

1 Select at least two adjacent keyframes between which you want the mask shape inter-
polated.

2 Choose Animation > Keyframe Assistant > Smart Mask Interpolation.

3 Set the options in the Smart Mask Interpolation palette based on the following guide-
lines and click Apply:

Keyframe Rate Sets how many keyframes per second to add between the selected 
keyframes. For example, a value of 10 means that a new keyframe will be added every 1/10 
of a second. Type the value in the box or choose a rate from the menu. Choosing Auto 
from the menu choices sets the keyframe rate equal to the composition frame rate. If you 
choose Auto, the keyframe rate appears in parentheses. 

Note: Regardless of the keyframe rate, Smart Mask Interpolation always adds keyframes 
at the frame just after the first mask shape keyframe and at the frame just before the 
second mask shape keyframe. For example, if Smart Mask Interpolation interpolates 
between keyframes at 0 seconds and 1 second in a 30-fps composition with a keyframe 
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rate of 10 per second, then mask shape keyframes are added at frame numbers 1, 3, 6, 9, 
12, 15, 18, 21, 24, 27, and 29.

Keyframe Fields If this box is checked, the specified keyframe rate is doubled. A 
keyframe is added at each field if this box is checked and if Keyframe Rate is set to the 
composition frame rate.

Use Linear Vertex Paths If this box is checked, vertices in the first keyframe move along a 
straight path to their corresponding vertices in the second keyframe. Leave this 
unchecked if you want some vertices to interpolate along curved paths as, for example, 
when the desired interpolation involves rotating parts.

Note: If this box is unchecked, Smart Mask Interpolation attempts to choose a natural 
path along which to move the changing mask shape in the interpolated keyframes. (There 
is no such ambiguity if this box is checked, since each vertex must move along a straight 
line to its corresponding vertex in the second input keyframe.) If the first vertices of the 
input keyframes are in the same position, then the first vertex in the interpolated mask 
shapes will remain fixed in this position. You can then move the changing mask shape 
along a desired path by other means, for example, by setting position keyframes.

Optional controls are also available for Smart Mask Interpolation. Access these by clicking 
the arrows  on the left corner of the palette tab or by choosing Show Options from the 
Smart Mask Interpolation palette menu. Set those values based on the following guide-
lines:

Bending Resistance Specifies how susceptible the interpolated mask shape is to 
bending as opposed to stretching. Click the arrow on the text box and drag the slider to 
adjust the value. A Bending Resistance of 0 specifies that, as the mask shape animates, it 
tends to bend much more than it stretches; a value of 100 means that the mask shape 
tends to stretch much more than it bends.

Quality Specifies how strictly Smart Mask Interpolation matches vertices from one 
keyframe to another. A value of 0 means that a particular vertex in the first keyframe may 
match only the same-numbered vertex in the second keyframe. For example, the 10th 
vertex in the first keyframe must match the 10th vertex in the second keyframe. A value of 
100 means that a vertex in the first keyframe can potentially match any vertex in the 
second keyframe. Larger quality values usually yield better interpolations; however, the 
larger the quality value, the longer the processing time.

Add Mask Shape Vertices If this box is checked, Smart Mask Interpolation adds vertices 
to facilitate quality interpolations. In general, Smart Mask Interpolation works best when 
the mask shapes have dense sets of vertices. Also, a vertex on the first mask shape cannot 
match the middle of a curve or straight-line segment on the second mask shape, so 
adding vertices before matching is sometimes necessary to produce the desired result. 
Smart Mask Interpolation does not modify the input, or original, keyframes. Only the new 
mask shape keyframes computed by Smart Mask Interpolation have additional vertices. 
Selecting the Add Mask Shape Vertices box activates the corresponding text box and 
menu. The number in the text box specifies how finely to subdivide the input mask 
shapes, according to one of the following parameters you choose from the menu:

Pixels Between Vertices Specifies the distance, in pixels, between vertices on the larger perimeter mask 
shape after subdivision.

Total Vertices Specifies the number of vertices you want on the interpolated mask shapes.
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Percentage of Outline Specifies that a vertex is added at each indicated percent of the mask shape outline 
length. For example, a value of 5 means that a vertex is added at each successive segment of the outline 
that represents 5% of the total perimeter. 

Leave this box unchecked to use only the vertices that were there at the first frame. 

Note: Smart Mask Interpolation may add vertices at existing vertex locations even if Add 
Mask Shape Vertices is not checked. If two vertices on one mask shape match a single 
vertex on the other, the single vertex is duplicated at the same spot so that the segment 
between the two vertices shrinks to that spot.

Matching Method Specifies the algorithm that Smart Mask Interpolation uses to match 
vertices on one mask shape to vertices on the other. Choose one of the following from the 
menu:

Auto Specifies that if either of the two selected keyframes has a curved piece, the matching algorithm for 
curves is applied. If not, the algorithm for polylines is applied.

Curve Specifies that the algorithm for mask shapes that have curved pieces is applied.

Polyline Specifies that the algorithm for mask shapes that have only straight pieces is applied.

Note: The mask shape keyframes added by Smart Mask Interpolation are polylines when 
the Polyline Matching Method is selected, whether or not the input mask shapes contained 
curved pieces.

Use 1:1 Vertex Matches If this box is checked, then Smart Mask Interpolation forces a 
vertex on one mask shape to match the same-numbered vertex on the other mask shape. 
On each of the input mask shapes, Smart Mask Interpolation matches the first vertices, the 
second vertices, the third vertices, etc. If the two shapes have unequal numbers of 
vertices, then this action may produce undesirable results.

First Vertices Match If this box is checked, Smart Mask Interpolation matches the first 
vertices in the two mask shape keyframes. If this box is unchecked, Smart Mask Interpo-
lation searches for the best first-vertex match between the two input mask shapes.

Note: To quickly get good results, make sure that the first vertices of the input mask shapes 
match and then run Smart Mask Interpolation with the First Vertices Match box checked.

To interrupt the interpolation process:

Press Esc. The Info palette indicates that the process has been interrupted and reports the 
number of keyframes created before the interruption.

Duplicating masks
If you create a mask on one area of a layer and want to put a copy of it on another area of a 
layer, there’s no need to use separate copy and paste operations. Instead, in After Effects 
5.5, duplicate the mask and then drag the duplicate to another location on the layer. To 
duplicate a mask, select the mask and choose Edit > Duplicate.

Adding motion blur to masks
You can now enable motion blur on any one of the individual masks on a layer. 

Note: To see the motion blur, you must have the Motion Blur switch turned on in the 
Timeline.
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To enable motion blur for a mask:

1 Select one or more masks.

2 Choose Layer > Masks > Motion Blur and choose one of the following options from the 
menu:

Same as Layer Specifies that the individual mask motion blur will be automatically 
controlled by the layer Motion Blur switch.

On Specifies that the mask motion blur will be rendered regardless of whether the overall 
layer Motion Blur switch is on or off, as long as the composition master Motion Blur switch 
is on.

Off Specifies that no motion blur is applied to the mask.

Using new and updated layer modes
After Effects 5.5 includes the following new layer modes: 

Linear Burn Similar to the Multiply layer mode, except that the resulting blend is darker

Linear Dodge Similar to the Add layer mode

Linear Light Similar to the Add layer mode, except that the resulting colors are inten-
sified

Vivid Light A combination of the Color Dodge and Color Burn layer modes

Pin Light A combination of the Lighten and Darken layer modes

After Effects 5.5 also includes updates to some layer modes so that they now match the 
Adobe Photoshop® 6 blend modes. These updated layer modes are Color Dodge, Color 
Burn, and Difference. The older modes are preceded by the word “Classic” and are present 
to preserve compatibility with older projects.

For information on accessing and using layer modes, see “Using layer modes” in chapter 9.

Cycling through layer modes
Quickly cycle through all the layer modes using only a keyboard shortcut. This is useful for 
rapidly experimenting with several modes without manually selecting them from the 
layer mode menu. To cycle through a layer’s modes, first make sure that the layer is 
selected. Then, hold down Shift as you either press the plus/equal key (+/=) to cycle 
forward through the transfer mode list, or as you press the underscore/minus key (_/-) to 
cycle backward through the transfer mode list.
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(5.5) Applying Effects

Working with new and enhanced effects in After Effects
The new additions to the After Effects effects give you more flexibility as you modify your 
images. 

After Effects 5.5 adds the following new effects in these categories:

Adjust Levels (Individual Controls), Color Stabilizer

Render 4-Color Gradient, Advanced Lightning (Production Bundle only), Cell Pattern, 
Grid

Stylize Roughen Edges

Time Time Difference

Using Levels (Individual Controls)
After Effects 5.5 adds the Levels (Individual Controls) effect in the Effect > Adjust category. 
This effect functions exactly like the Levels effect; however, the Levels (Individual Controls) 
effect simultaneously displays all the adjustable tracks for each channel. Because you have 
access to each parameter of each channel individually, you can add expressions to 
individual properties or keyframe one property independently of the others. To see each 
property individually, click the arrow next to the channel color to expand it and reveal the 
options.

Using Color Stabilizer
Color Stabilizer samples the exposure of specified areas of a single reference, or “pivot,” 
frame; it then adjusts the total exposure of all the other frames to maintain the value of the 
selected point in the pivot frame. This is useful to remove flicker from footage and to 
equalize the exposure of footage with color shifts caused by varying lighting situations.

Adjust the following controls for Color Stabilizer:

Set Frame Specifies the pivot frame. Go to the frame that displays the areas of brightness 
or color that you want to match and click this option.

Stabilize Specifies the method by which the stabilization is performed. Choose one of 
the following options from the menu:

Brightness Specifies that the brightness is to be stabilized throughout the footage. You can sample one 
point in the pivot frame to specify this value.

Levels Specifies that black-point and white-point values in the pivot frame are to be stabilized 
throughout the footage.

Curves Specifies that black-point, white-point, and midpoint values in the pivot frame are to be stabi-
lized throughout the footage.
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The following options indicate the particular point on the pivot frame that remains 
constant throughout the footage. Place the effect points to select an area for stabilization. 
If you select multiple points, consider that Color Stabilizer is most effective when those 
points vary widely in color or brightness.

Black Point Specifies a single point that will remain constant, if you choose to stabilize 
brightness only. If you choose to stabilize levels or curves, this specifies a dark point that 
remains constant.

Mid Point Specifies a point between two values of color or brightness that will remain 
constant. This option is available only if you choose to stabilize curves.

White Point Specifies a light point that will remain constant. This option is available only 
if you choose to stabilize levels or curves.

Sample Size Specifies the size, in radius of pixels, of the sampled area.

Filling all masks in a layer
The Fill effect now includes an All Masks option that fills all the layer’s closed mask paths 
with the chosen color. Activating this option also fills the mask path of a mask that has 
None chosen as its mode. Choose Effect > Render > Fill to access the effect. To fill each 
layer mask, make sure that the All Masks option box is checked in the Effect Controls 
window.

Fill All Masks behavior when Add is chosen as the mask mode (top) and when None is chosen as the 
mask 
mode (bottom)

Constraining scale in the Transform effect
You can now scale both the width and height of an image with a single control in the 
Transform effect. To to do this, make sure that the Uniform Scale box is checked in the 
Transform Effect Controls window, and then scale the footage.



Using Help | Contents | Index Back 389  

Adobe After Effects Help (5.5) Applying Effects 

Using Help | Contents | Index Back 389  

Selecting multiple points in the Mesh Warp effect
You can now select more than one grid point in the Mesh Warp effect. This is useful if you 
want to move a group of points in the same direction. To select multiple grid points, hold 
down Shift as you click the points you want to select.

Using the Effects palette
Work more efficiently with effects using the Effects palette. Access all available effects 
from this palette, either by browsing the categories and effect names or by using the find 
feature, and apply the effects to your footage. You can see effects and effect favorites three 
ways: by category, as they are stored in file-system folders, or as a simple alphabetical list. 
To display the Effects palette, click the Effects tab in the palette group. If the Effects palette 
or the palette group is not visible, choose Window > Effects.

To locate an effect in the Effects palette:

1 Display the Effects palette, as described above.

2 Do one of the following:

• Scroll through the list. If the effects are listed by category, expand the category to see 
the effect names.

• Type the effect name in the Contains text box. The list displays effects whose names 
contain the letters you type.

To apply an effect from the Effects palette:

1 Locate the effect you want to apply, as described in the above steps. 

2 Drag the effect from the Effects palette to one of the following target layer locations 
(the target layer attribute mentioned below is highlighted when you drag over it):

• The layer name in the Timeline window.

• The Effects heading name for the layer in the Timeline window.

• A point between any one of the layer’s effects already listed in the Timeline window.

• The layer in the Composition window. The Info palette displays the name of the 
targeted layer.

• The layer’s Effect Controls window.

Note: After you apply the effect to a layer, that layer becomes selected in the Timeline, 
even if another layer had been previously selected. If you decide not to apply the effect and 
drag to any other place not mentioned in the above procedure, the previously selected 
layer remains selected.

To specify how effects are listed in the Effects palette:

Display the Effects palette menu by clicking the triangle in the right corner of the palette, 
and choose one of the following views from the menu:

Note: If you close and reopen the Effects palette menu, it retains the choices you made in 
the menu.

• Categories: to show and organize the effects according to their categories as listed in 
the Effects menu.
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• Explorer Folders (Windows) or Finder Folders (Mac OS): to show your effects as they 
appear in your file system folders. If a Folder A contains only Folder B, a listing for 
“Folder A” will not appear. Otherwise, this options shows all folders that contain effects 
or favorites.

• Alphabetical: to show all the effects in alphabetical order. 

• Show Effects: to switch the effect list between showing and not showing the effects.

• Show Favorites: to switch between showing or not showing favorites. The only favorites 
that are shown are those stored in the After Effects application folder on your hard 
drive. For information on how to designate favorite effects, see “Saving favorite effects 
for instant reuse” in chapter 10.

Note: The Show Favorites view shows only folders that are in the folder containing the application. If you want 
to store your effects in a folder outside this, make a shortcut or an alias to your effect folder and place that 
shortcut or alias anywhere inside the folder containing After Effects.

• Show 16 Bit Effects: to show only the 16-bits-per-channel effects.

• Reveal in Explorer (Windows) or Reveal in Finder (Mac OS): to open the folder on your 
hard drive that contains the selected effect. The selected effect is highlighted in the 
folder window.

• Refresh List: to manually update the list of favorites without relaunching After Effects. 
This is useful when, while using your browser, you add or remove favorites while the 
program is still running. However, when you add or remove effects not designated as 
favorites, you still must quit and restart After Effects.

Remembering fonts in effects
For effects that use fonts, After Effects now remembers the last font used for that effect. 
The effects that use fonts are Path Text, Basic Text, Numbers, and Particle Playground 
(Production Bundle only). 

Using new 16-bits-per-channel effects
The following effects, listed by category, are now enabled for 16-bits-per-channel use:

Blur & Sharpen Compound Blur, Directional Blur

Distort Displacement Map

Image Control Tint, Color Balance (HLS)

Render Fractal
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(5.5) 3D Compositing

Importing camera data from Maya files
You can now import the camera data from Maya ASCII project files (.ma). After Effects 
imports these files as compositions. For each Maya file, After Effects creates either one or 
two compositions:

• If the Maya project has a square pixel aspect ratio, After Effects creates a single, square-
pixel composition containing the camera data and transformations. 

• If the Maya project has a nonsquare pixel aspect ratio, After Effects creates two compo-
sitions. One composition, which retains the name of the Maya project prefixed by the 
word “Square,” is a square-pixel-based composition containing the camera data. The 
second, or parent, composition is a nonsquare-pixel-based composition that retains the 
dimensions of the original file and contains the square-pixel composition. 

When you import a Maya file with a 1-node camera, After Effects creates a camera in the 
square composition that carries the camera's focal length, film size, and transformation 
data. If you import a Maya file with a 2-node or targeted camera, After Effects creates a 
camera and an additional parent node in the square composition. The parent node 
contains only the camera’s transformation data. 

Once you import the Maya data, work with 3D layers and square-pixel footage in the 
square-pixel composition. Work with all nonsquare footage in the parent composition. 

Note: After Effects reads only the rendering cameras in Maya files and ignores the ortho-
graphic and perspective cameras. Therefore, always generate a rendering camera from Maya, 
even if it is the same as the perspective camera.

The animation information for the Maya cameras must be “baked.” This means that there 
should be a keyframe at each frame of the animation. There can be 0, 1, or K keyframes for 
each camera or transform parameter, where K is a fixed number. For example, if a 
parameter is not to be animated, the animator will either set no keyframes for this 
parameter or one keyframe, at the start of the animation. If a parameter has more than 
one keyframe, then it must have the same number as any other animation parameter with 
more than one keyframe.

Reduce import time by creating or saving the most simple Maya file possible because 
After Effects reads the entire file to find the camera transformations that can be imported. 
In Maya, delete static channels before baking to reduce keyframes, and save a trimmed-
down version of the Maya project (containing the camera animation only) before 
importing it into After Effects.

Note: The following transformation flags are not supported: query, relative, euler, 
objectSpace, worldSpace, worldSpaceDistance, preserve, shear, scaleTranslation, 
rotatePivot, rotateOrder, rotateTranslation, matrix, boundingBox, boundingBoxInvisible, 
pivots, CenterPivots, and zeroTransformPivots. After Effects skips the above mentioned 
unsupported flags, and no warnings or error messages appear.
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Importing camera data from RLA/RPF files
After Effects 5.5 imports camera data saved with RLA/RPF sequence files. That data is 
incorporated into a camera layer that After Effects creates in the Timeline window. To 
access the camera data of an imported RLA/RPF sequence and create a camera layer 
containing that data, place the imported sequence in the Timeline window, select it, and 
choose Animation > Keyframe Assistant > RPF Camera Import.

Note: To create an RLA or RPF file with the camera data in 3D Studio Max, save your 
rendering in rpf format with coverage, z depth, and alpha channels enabled.

Using multiple views
When working with a composition, it may be useful to monitor several views of it at once 
so that you can see how a change you make in one view is reflected in other views, 
especially when working in 3D. This facilitates more accurate placement of images and a 
more comprehensive vision of how your images animate. 

In After Effects 5.5, you can create multiple composition views, with each view in its own 
window. You can add additional views to any composition or use one of the new built-in 
multiple-view workspaces. If you are working with 3D layers, each Composition window 
view is labeled according to the composition name and the particular 3D view selected 
from the 3D View Popup menu. You can also create multiple views when you work in 2D. 
Each 2D view can have a different region of interest and a different magnification view.

You can have as many views of your composition as you want. You can also make the 
current multiple view conform to a saved workspace or save your view as a custom 
workspace. For more information on conforming your view to a saved workspace, see the 
procedure below. For more information on saving and using workspaces, see “Custom-
izing the workspace” in chapter 3. After Effects saves the total number of views you create 
for each composition and custom workspace. 

By default, you close any view by clicking the close box for that view window. If you want 
all of the windows to close when you click the close box, you must activate a preference. 
To do this, see the procedure below.

To create initial multiple-view windows for a composition:

Do one of the following:

• Choose Window > Workspace > Two Comp Views or Four Comp Views, depending on 
the number of initial views you want.

• Right-click (Windows) or Control-click (Mac OS) the Composition window and follow 
the above step in the context menu.

Note: You can change any view to one of the above choices at any time.

To add a view to a multiple-view layout:

1 Activate one of the composition views.

2 Do one of the following:

• Choose View > New View.

• Press Shift+Alt+N (Windows) or Shift+Option+N (Mac OS).

3 Do one of the following:
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• If you are working in 3D, choose a new 3D view from the 3D View Popup menu.

• If you are working in 2D, choose a new magnification view or define a region of interest 
for the new view.

4 Do one of the following:

• Drag the new view window to a new location and resize the window, if necessary.

• Drag the new view tab to another composition view to nest the new view.

Note: If the composition has any previously created view windows that were closed, those 
views reopen before a new view is created.

To return to a single composition view:

Choose Window > Workspaces > One Comp View.

To conform all of the project’s compositions to a saved workspace:

Choose the name of your saved workspace from the Window > Workspace menu.

Note: When you conform a view to a saved workspace, After Effects converts all 3D views 
only to those available in the saved composition. Views from the current view that don’t 
exist in the saved workspace are renamed “Active Camera.” For example, if you have a 
current workspace with Camera 2, Top, and Left composition views, then when After 
Effects conforms that view to a saved workspace that does not have a view called “Camera 
2,” it sets the new views to Active Camera, Top, and Left. If there are no 3D elements in a 
composition, the standard 2D view is applied upon conversion.

To conform other application windows when you choose a workspace:

Select the Composition window and choose Window > Workspace >Conform All. 
Selecting a workspace from the Window > Workspace menu will affect all windows when 
this choice is checked. For information on workspaces, see “Customizing the workspace” in 
chapter 3.

To prevent other application windows from conforming when you choose a 
workspace:

Do one of the following:

• Select the Composition window and choose Window > Workspace. Make sure that 
Conform All Windows is not checked. Choosing a workspace from the Window > 
Workspace menu will affect only the composition views when this choice is not 
checked. For information on workspaces, see “Customizing the workspace” in 
chapter 3.

• Right-click (Windows) or Control-click (Mac OS) the Composition window and, in the 
context window, choose a workspace from the Window > Workspace menu. Choosing a 
workspace from this menu will affect only the composition views regardless of the 
status of the Conform All Windows menu choice.

To change view properties for all open views for a given composition:

1 Activate any of the view windows.

2 Do any one of the following:
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• To display the magnification level, RGBA channels, safe zones, or Layer Wireframe mode 
in all open views, Ctrl-click (Windows) or Command-click (Mac OS) the corresponding 
button or menu in the Composition window.

• To display the grids, Shift+Ctrl-click (Windows) or Shift+Command-click (Mac OS) the 
Title-Action Safe button.

• To switch all views to Checkerboard Backgrounds, hold down Ctrl (Windows) or 
Command (Mac OS) as you choose Checkerboard Backgrounds from the Composition 
window menu.

To change view properties for one view for a given composition:

Do any one of the following:

• To display the RGBA channels, safe zones, Layer Wireframe mode button, or magnifi-
cation level, click the corresponding button or menu in the Composition window.

• To display the grid, Shift-click the Title-Action Safe button.

To close all views of the composition:

1 Choose Edit > Preferences > General.

2 Make sure that the Close Multiple Views Simultaneously box is checked and click OK.

Note: If this preference is chosen, holding down Alt (Windows) or Option (Mac OS) as you 
close a composition overrides the preference and closes only one composition view. Alter-
nately, if this preference is not chosen, then holding down Alt or Option as you close one 
view closes all composition views.

Changing 3D Rotation values 
When you now access 3D Rotation values from either the Layer menu or with a keyboard 
shortcut, you now enter those values in a single dialog box that displays a text box for 
each axis coordinate—rather than choosing each coordinate separately from a menu, as 
was the case in After Effects 5.0. This makes it quicker to enter coordinates. To access the 
Rotation dialog box, choose Layer > Transform > Rotation.

Using new layer Material Options
Use the new layer Material Options to do the following:

• Specify how much light shines through a layer to create colored shadows and stained-
glass effects

• Control a layer’s shadow-casting ability

• Establish the “metallic” quality of the reflected light

Creating colored shadows and stained-glass effects
Instead of merely casting black shadows, layers can now act like transparencies and can 
cast their color on another layer. Using a new Transform property called Light Trans-
mission, you set the percentage of light that shines through a layer. You can also create the 
effect of light passing through stained glass by placing a light behind a layer and adjusting 
its light transmission. 
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To access the Light Transmission property, expand the layer's Material Options. A light 
transmission value of 0 means that no light passes through the layer and it casts a black 
shadow. This setting renders faster and is recommended if you don’t want to cast a 
colored shadow or want previews to render quickly. A value of 100 means that the full 
color value of the shadow-casting layer is projected on the layer accepting the shadow.

Note: To cast a colored shadow, make sure that you turn on the Cast Shadows option for 
both the shadow-casting layer and the corresponding light layer. 

Casting shadows from a layer that has been turned off
Even if a layer is invisible, sometimes it is important to have that layer cast a shadow. 
Create this scenario by choosing a new Cast Shadows option called Only. Choosing Only 
turns off the layer but leaves the shadow it casts. Use this in conjunction with the Light 
Transmission option to project the colors from the invisible layer onto a visible one. To 
choose Only, click the current underlined Cast Shadow option until Only displays. 

Using the Metal Material Option 
This option controls the color of the specular highlight. A setting of 100% means that the 
color of the specular light is the color of the layer. For example, with a Metal setting of 
100%, an image of a gold ring reflects golden light. A setting of 0% means the color of the 
reflected light is the color of the light source. The default Metal value is 100%. 

Using lights as adjustment layers
Now you can choose which 3D layers a light will affect by designating the light layer as an 
adjustment layer. Just as with any adjustment layer, you place the light layer in the 
Timeline window above only the layers you want the light to shine on. To designate a light 
as an adjustment layer, select the light layer’s Adjustment Layer switch  in the Timeline 
window.

Using the Advanced 3D Renderer
The Advanced 3D Renderer, previously available as a Web download only, is now installed 
with After Effects 5.5. Use the Advanced 3D Renderer to render compositions whose 
animations have intersecting 3D layers. The Advanced 3D Renderer not only accurately 
calculates the look of intersecting layers but also accurately calculates anti-aliasing, 
motion blur, and layer modes for the intersecting layers. 

The Advanced 3D Renderer also allows you to set the shadow map resolution. Advanced 
3D renders its shadows using “shadow maps,” which are images rendered from the point 
of view of each light source. Normally, the resolution of these images is computed 
automatically based on factors such as the composition resolution and quality switches. 
However, in some cases you will want to set the resolution manually. For example, if 
shadows appear blurry even when the Shadow Diffusion material option is set to 0, 
increase the shadow map resolution. If shadows are rendering slowly, decrease the 
shadow map resolution.

Note: If your animation does not include intersections and you do not want to set the 
shadow map resolution, use the Standard 3D Renderer. It is identical to the Advanced 3D 
Renderer, except for the above features, and results in a quicker render.
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To choose the Advanced 3D Renderer:

1 Choose Composition > Composition Settings.

2 Click the Advanced tab.

3 Choose Advanced 3D from the Rendering Plug-in menu.

Note: The 3D Renderer setting is remembered as a preference. The last 3D renderer you 
select appears in the Rendering Plug-in menu the next time you access it.

To adjust the shadow map resolution:

1 Choose the Advanced 3D Renderer, as described in the steps above.

2 Click the Options button.

3 Choose an option from the Shadow Map menu. These options represent the resolution 
in pixels. Choose Comp Size or a resolution larger than the composition size for best 
results.

4 Click OK. 

Anti-aliasing in the Standard 3D Renderer
Rendered edge-on 3D animations, or animations where the edges of rotated layers are 
angled toward the viewer, can display a ragged edge if they are not accurately anti-aliased. 
In the Standard 3D Renderer, you now can apply more advanced anti-aliasing to those 
edges for a smoother appearance. 

To access the Standard 3D Renderer options:

1 Choose Composition > Composition Settings.

2 Click the Advanced tab.

3 Make sure that Standard 3D is displayed in the Rendering Plug-in menu and click the 
Options button. Choose one of the following options from the Anti-aliasing menu:

Faster Renders the animation without employing any advanced anti-aliasing, which 
results in a faster render, but with possibly ragged edges on edge-on animations.

More Accurate Employs advanced anti-aliasing when rendering the animation, which 
may slow the render time, but will create edge-on animations with smoother edges.
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(5.5) Expressions

Using Expression Controls
In After Effects 5.5, six new effects reside in the effects category Expression Controls. They 
do not actually affect the footage you apply them to; instead, they provide controls to 
which you can refer in any expression. A single control affects several properties at once. 
You apply these effects to a null layer, and name the layer and effect to clarify their 
purpose. For example, you can name the null layer “Controls,” apply a slider effect to it, and 
name the effect “Springiness.” You can then refer to the layer and effect in an expression 
on another layer as, for example:

spring = this_comp.layer("Controls").param("Springiness"); 

Expression Controls consist of the following:

Slider Control Contains a slider with a default value range of 0–100. To change the slider 
range, right-click (Windows) or Control-click (Mac OS) the underlined slider value and 
choose Edit Value from the context menu. Type the new values in the Slider Range text 
box.

Angle Control Contains an angle adjustment control.

Checkbox Control Contains a single checkbox.

Color Control Contains a color swatch control and an eyedropper.

Point Control Contains an effect point control.

Layer Control Contains a layer menu that lists all of the layers in the active composition.

Creating an expression for a single property
When you write an expression in After Effects 5.5, you do not need to specify the property 
on which the expression is written. The default object for the expression is now the 
property on which the expression is written, followed by the layer containing the 
expression. This shortens the expression. For example, a wiggle expression written on a 
layer’s Position property in After Effects 5.5 may merely read as follows:

wiggle(5,10)

In After Effects 5.0, by contrast, the same expression reads as follows:

position.wiggle(5,10);

You must still specify the layer and property when retrieving them from outside the layer 
and property that the expression is written on—for example:

this_comp.layer("OtherLayer").position.wiggle(5, 10);
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Using operators in expressions
Expressions that contain several math functions can get complex and difficult to read. 
Now, use the operators + (add), - (subtract), * (multiply), and / (divide) in place of the add(), 
sub(), mul(), and div() functions to simplify those expressions. Use the “-” operator also for 
unary negation. For example, when you use the new operators, the following expression:

div(add(pos1, add(pos2, pos3)), 3)

becomes as follows:

(pos1 + pos2 + pos3) / 3

Using new keyframe-looping methods
After Effects 5.5 includes four new keyframe-looping methods usable on any property 
except marker. They are as follows:

loop_in(type = “cycle”, num_keyframes = 0) Loops a segment of time that is measured 
from the first keyframe on the layer forward toward the layer’s Out point. The loop occurs 
from the layer’s In point to the first keyframe on the layer. The segment to loop is delin-
eated by the specified number of keyframes.

loop_out(type = “cycle”, num_keyframes = 0) Loops a segment of time that is 
measured from the last keyframe on the layer back toward the layer’s In point. The loop 
occurs from the last keyframe on the layer to the layer’s Out point. The segment to loop is 
delineated by the specified number of keyframes.

loop_in_duration(type = “cycle”, duration = 0) Loops a segment of time that is 
measured from the first keyframe on the layer forward toward the layer’s Out point. The 
loop occurs from the layer’s In point to the first keyframe on the layer. The segment to loop 
is delineated by a user-specified duration.

loop_out_duration(type = “cycle”, duration = 0) Loops a segment of time that is 
measured from the last keyframe on the layer back toward the layer’s In point. The loop 
occurs from the last keyframe on the layer to the layer’s Out point. The segment to loop is 
delineated by a user-specified duration.

Setting type parameters
Available types are listed below:

Cycle Repeats the specified segment. 

Pingpong Repeats the specified segment but alternates between repeating forward and 
backward in the segment. 

Offset Repeats the specified segment but offsets each cycle by the difference in the value 
of the property at the start and end of the segment, multiplied by the number of times the 
segment has looped. 

Continue Does not repeat the specified segment but continues to animate a property 
based on the velocity at the first or last keyframe on the property. For example, if the last 
keyframe of a layer’s Scale property indicates that the layer’s scale value is 100%, and the 
loop_out(type=“continue”) expression is present on that property, then the layer, instead 
of looping to the Out point, continues to scale, from 100% to the Out point. This type does 
not accept a “keyframes” or “duration” parameter.
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Setting values for keyframes and duration
Define segments by setting values for the keyframe and duration parameters according to 
the following descriptions of their function:

Keyframes Sets the number of keyframe segments to loop. For the loop_in expression, 
the specified range is measured from the first keyframe. For example, loop_in(“cycle”, 1) 
loops the segment bounded by the first and second keyframes. For the loop_out 
expression, the specified range is measured backward from the last keyframe. For 
example, loop_out(“cycle”, 1) loops the segment bounded by the last keyframe and 
second-to-last keyframe. The default value of 0 means that all keyframes will loop.

Duration Sets the number of composition seconds in a segment to loop. For the 
loop_in_duration expression, the specified range is measured from the first keyframe. For 
example, loop_in_duration(“cycle”, 1) loops the first second of the entire animation. For the 
loop_out expression, the specified range is measured backward from the last keyframe. 
For example, loop_out_duration(“cycle”, 1) loops the last second of the entire animation. 
The default of 0 means that, for the loop_in_duration expression, the segment to loop 
begins at the layer Out point; for the loop_out_duration expression, the segment to loop 
begins at the layer In point.

Note: Keyframes or duration values that are too large are clipped to the maximum legal 
value. Values that are too small result in a constant loop.

Viewing function arguments and default values
The expressions function menu now lists arguments and default values. This makes it 
easier to remember what elements you can control when you write an expression. For 
example, in the function menu, the Property function for wiggle lists “wiggle(freq, amp, 
octaves = 1, amp_mult =.5, t = time).” The parenthetical listings indicate that the wiggle 
function accepts five arguments. The “=” in the last three arguments indicates that using 
those parameters is optional. If you specify no values for them, they default, respectively, 
to 1, .5, and the current time.

Using the “has_parent()” function
You can now indicate in your expression that you want to retrieve a parent layer’s property 
by using the “has_parent()” function. You can also allow for the possibility that there may 
not be a parent layer at present. For example, the following expression indicates that the 
layer to which you apply it would wiggle based on the position of the layer’s parent. If the 
layer has no parent, then it would wiggle based on its own position. If the layer is parented 
later, then its behavior will change at that point:

idx = index;

if (has_parent) {

idx = parent.index;

}

this_comp.layer(idx).position.wiggle(5, 20)
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Getting a random value that doesn’t depend on time
Using the seed_random() function, you can now write an expression calling for a random 
value that depends on the layer’s index (number) and the stream (property) but not the 
time. For example, the following expression passes true as the second parameter to the 
seed_random() function to get a random number between 0 and 1 which depends on the 
layer and property number but not the time:

seed_random(<any number>, true);

r = random()

Using the “.name” attribute
After Effects 5.5 adds the expression “.name” to Comp, Footage, Layer, Mask, and Effect 
objects. This is useful when you want to apply the same expression to several layers, 
varying the behavior based on the name of an object. For example, the following 
expression wiggles the position of a layer differently depending on whether or not the 
layer is named “hero”:

amp = 20;

if (name == "hero") {

amp = 40;

}

wiggle(5, amp)

Accessing keyframes and markers in expressions
You can now write expressions that access keyframes and markers. These expressions are 
useful for accessing values at particular times as delineated by keyframe and marker 
locations and values. Access keyframes or markers using the following attributes and 
methods:

this_comp.marker(marker_num) Returns the time of a composition marker. You can 
use this to fade out a layer's opacity at the time where the marker resides—for example:

mark_time = this_comp.marker(1);

linear(time, mark_time - .5, mark_time, 100, 0)

num_keys Returns the number of keyframes in a property.

nearest_key(time) Returns the keyframe object nearest to a designated time. 

key(idx) Returns the keyframe by number. For example, key(1) returns the first key.

When you access a key object, you can get time, index, and value properties from it. For 
example, the following expression gives you the value of the third position key:

position.key(3).value

The following expression, when written on a layer’s animated Opacity property, ignores 
the keyframe values and only uses the keyframes’ placement in time to determine where a 
flash should occur:

d = Math.abs(time - nearest_key(time).time);

ease_out(d, 0, .1, 100, 0)
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marker Returns the marker property for a layer. A marker property is unlike other 
properties such as Position in that the only methods and attributes available from it are 
key(), nearest_key, and num_keys. You can retrieve the keys in two ways: either by index, 
for example, as in the following expression:

marker.key(1)

You can also retrieve it by the name of the marker, as typed in the comment field in the 
marker dialog box: 

marker.key("foo")

The value for marker keys is a string name, instead of a numeric value. For example, note 
the following expression, written on a layer’s Opacity property:

m1 = marker.key("Start").time;

m2 = marker.key("End").time;

linear(time, m1, m2, 0, 100);
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(5.5) Rendering a Movie

Dragging footage to the render queue
In After Effects 5.5, you can simultaneously create a composition from source footage and 
immediately prepare that footage for rendering. You do this by dragging source footage 
from the Project window to the render queue. This procedure is useful if you want to 
change some aspect of the source footage’s format, such as frame rate or compression 
method, and have that rendered version available to work with as (for example) a 
replacement for the original source. 

To both render source footage from the Project window and create a composition:

1 Choose Window > Render Queue.

2 Select one or more source footage items that you want to render and drag them from 
the Project window to the render queue. This creates both a new render queue item and a 
new composition for each source footage item. 

3 Adjust the pertinent render settings and postrender actions and render the footage. 
(For more information on adjusting render settings, see “Changing render settings” in 
chapter 14 and “Changing output module settings” in chapter 14. For more information 
on setting postrender actions, see “Using postrender actions in the render queue” in 
chapter 25).

Creating default output filenames
When the new Use Default File Name and Folder preference is enabled, all compositions 
added to the render queue have a unique output filename automatically assigned to their 
output modules. The output folder for each subsequent composition is the same as the 
previous output folder that you specified. The folder remains the same for any project you 
open until you change the path. To access this preference, choose Edit > Preferences > 
Output and note the Use Default File Name and Folder box. The preference is enabled by 
default.
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Using postrender actions in the render queue
The render queue has become more interactive with the Project window and has more 
options to create varied outputs and automate the rendering process. These options, 
called postrender actions, improve workflow because you can now queue specific events 
to take place after a composition has been rendered. The new render queue options also 
have opened up other features accessible from within the application that make it easier 
to prerender footage and set proxies.

The Post-Render Actions menu

Understanding the Post-Render Actions menu
Postrender actions set up duties that you want After Effects to perform once footage is 
rendered. All of the options for postrender actions are available in the render queue. 
Postrender actions are useful for setting up multiple renders without having to return 
continuously to the render queue.

To access the Post-Render Action menu:

1 Place the item you want to render in the render queue. For information on placing 
items in the render queue, see “Working in the Render Queue window” in chapter 14.

2 Expand the Output Module heading in the render item to which you want to apply the 
postrender action.

3 Choose one of the following from the Post-Render Action menu as it applies to your 
project:

None Performs no postrender action. This is the default setting.

Import Imports the rendered file to the project when the render is complete.

Import & Replace Usage Imports the rendered file and substitutes it for each use of the 
specified project item. Drag the pick whip to the pertinent Project window item to specify 
it.

Set Proxy Sets the rendered file as a proxy for the specified project item. Drag the pick 
whip to the pertinent Project window item to specify it.



Using Help | Contents | Index Back 404  

Adobe After Effects Help (5.5) Rendering a Movie 

Using Help | Contents | Index Back 404  

Creating a proxy from a still or moving image
The Create Proxy command provides a quick way to create a still or movie proxy from 
footage or compositions selected in the Project or Timeline window. The command opens 
the render queue and sets a render item for the selected footage with Set Proxy chosen as 
the postrender action. For more information on postrender actions, see “Understanding 
the Post-Render Actions menu” in chapter 25. For more information on working with 
proxies, see “About placeholders and proxies” in chapter 5.

To create a still or moving proxy:

1 Select the footage or composition in the Project or Timeline window from which you 
want to create a proxy. If you want to create a still proxy from a moving image, use the 
Footage window to go to the frame in the footage that you want to represent as the 
poster frame for the proxy. For information on using the Footage window, see “Displaying 
After Effects viewing controls in the Footage window” in chapter 3.

2 Choose File > Create Proxy > Still to create a still proxy or choose File > Create Proxy > 
Movie to create a moving proxy.

3 Create a name and output designation for the proxy.

4 Adjust the render settings as necessary and render the footage. For information on 
render settings, see “Changing render settings” in chapter 14.

Using the Pre-render command
The new Pre-render command provides an easy way to flatten your nested compositions, 
greatly shortening your preview times. The command opens the render queue and creates 
a render item for the selected composition with Import and Replace chosen as the 
postrender action. To prerender a composition, select it in the Project or Composition 
window and choose Composition > Pre-render. Adjust the pertinent render settings and 
render the footage. 

Using new output templates
After Effects includes default templates for the new Pre-render and Create Proxy 
commands. As with previous templates, you can choose a different default template or 
create your own. For information on using and changing templates, see “Creating and 
using render settings templates” in chapter 14 and “Creating and using output module 
templates” in chapter 14.

Note: Because you can choose a postrender action in each Output Module template, 
changing the Output Module template could also change the postrender action.

Creating output chains
You can now drag output modules from the render queue to the Project window to create 
a placeholder for the render queue output. This sets the postrender action for the render 
queue item to Import and Replace. This is called “creating output chains” and can be useful 
for creating files to be used in different compositions. For example, you can create a place-
holder for the render of a 24-fps movie and subsequently drag that placeholder into a 30-
fps composition. You can then work with other footage in the 30-fps composition; when 
you are ready to render, the first composition will render at 24 fps, and the rendered 
footage will replace the placeholder in the new 30-fps composition.
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Tracking render dependencies
Use this feature to set postrender actions for files rendered on multiple machines. While 
performing a render, the render engine checks to confirm that any item that it needs to 
begin rendering has completed its own render. For example, if render item B depends on 
render item A, which has not finished rendering or has received an error, then render item 
B will not render. This feature, called “tracking dependencies,” works both when rendering 
a single project or performing a watch-folder render. By using this feature in conjunction 
with postrender actions, you can set the output of a watch-folder render to be rerendered 
as a single Quicktime™ or AVI movie.

To output a multiple machine render as a Quicktime or AVI movie:

1 Create a multimachine render. See “Rendering using a watch folder (PB only)” in 
chapter 14 for information on multimachine renders.

2 Drag the multimachine render’s output module to the Project window. This creates a 
placeholder for that render's output.

3 Drag the placeholder back to the render queue.

4 Set the desired Render Settings and Output Module settings for the placeholder and 
render the footage.

Note: The subsequent render of a Quicktime or AVI movie from a multimachine-rendered 
sequence file will be rendered by only one machine.

Working with new file export options
After Effects 5.5 features several new file export options.

Rendering as a RealMedia file
Use the RealMedia Output Plug-in to generate RealMedia files that can then be embedded 
in Web pages for both streaming and downloading. This plug-in supports RealVideo®, 
RealAudio®, and RealVideo with audio.

To render as a RealMedia file:

1 Place the item to be rendered into the render queue. For information on placing items 
in the render queue, see “Working in the Render Queue window” in chapter 14.

2 In the Output Module Settings dialog box, choose RealMedia from the Format menu. 

3 In the Video Output section, click the Format Options button.

4 Set the pertinent options in the RealMedia Output Options dialog according to the 
following descriptions and click OK:

RealMedia Clip Settings Indicates how the RealMedia file is optimized according to the 
content of the file and the intended playback quality. 

Video Quality Specifies the image and playback quality of the file. Choose Normal Motion Video for clips 
that contain mixed-format video. This choice creates the largest file in most cases. Choose Smoothest 
Motion Video for clips that contain high action. Choose Sharpest Image Video for limited-motion clips. 
Choose Slideshow for video that appears as a series of still photos. This choice creates the smallest file in 
most cases.
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Audio Content Specifies the type of audio in the file. Choose Voice Only for movies that contain only 
speech. Choose Voice with Background Music for clips that contain both voice and music audio. Choose 
Music for monophonic music-only clips. Choose Stereo Music if your original clip is in stereo.

Target Audience Settings Specifies the bandwidths for which the exported RealMedia 
file is optimized. Select the box that corresponds to the intended bandwidths. Targeting 
the file to multiple bandwidths activates a feature called SureStream, which allows the 
playback device to dynamically choose the most appropriate stream based on the user’s 
available bandwidth. 

Note: To minimize the final file size, choose no more than four bandwidths.

RealAudio and RealVideo buttons Click either of these buttons to open the respective Target Settings 
dialog boxes to select detailed options for audio and video tracks. The RealAudio Target Settings and 
RealVideo Target Settings dialog boxes both contain menus for choosing target audience and audio 
content bit rates. The audio frequency response, measured in kilohertz (kHz), is shown to the right of the 
audio bit-rate menus. The RealVideo dialog box adds options for Maximum Video Frame Rate and Total 
Target Bitrate. Click the Restore Defaults buttons within the respective dialog boxes to reset all settings to 
default.

Note: The settings in the RealAudio Target Settings dialog box apply only if you are encoding an audio-only 
file.

More Options Click this button to access the following menus and choices:

RealMedia File Properties Specifies certain features to be included with the file. Make sure that the corre-
sponding box is checked to activate the feature. Activate Allow Recording to enable the file to be copied 
when played in Real Player. Activate Allow Download to give the users the option to download your 
RealMedia clip. Activate File Should Not Be Indexed by Search Engines to prevent search engines from 
pointing users to your clip. Choose an item from the Audience Rating menu to assign a rating to your clip.

SureStream and Video Codec Options Specify various details about the encoded file. Make sure that the 
check box for the appropriate option is checked, choose an item from a menu, or type a number into the 
pertinent text box according to the below guidelines:

Emphasize Audio (Downgrade Video Before Audio) Gives priority to audio over video during 
periods of poor bandwidth.

Video Codec RealVideo G2 creates files that are compatible with RealPlayer versions from G2 and 
higher. RealVideo G2 with SVT creates files that are compatible with RealPlayer versions 6.0.6 and 
above. RealVideo 8.0 provides the best-quality output for all bit rates.

Variable Bit Rate Encoding Enables the video codec to vary the bit rate throughout the clip, 
depending on the type of the content being encoded.

Loss Protection Ensures that the streaming video data is not lost during transition from the server 
to the user.

VBR Maximum Startup Latency Specifies the maximum amount of time that latency will occur 
before the clip begins. Use this option if Variable Bit Rate encoding is active.

Maximum Time Between Keyframes Specifies how frequently the video images are reset during 
encoding.

Clip Information Indicates specific metadata about the file. Type the categorical infor-
mation into the text box.
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5 Set the pertinent options in the render queue and render the file. For information on 
setting render queue options, see “Changing render settings” in chapter 14 and 
“Changing output module settings” in chapter 14.

Rendering and exporting 16-bits-per-channel files
After Effects 5.5 can read and write 16-bits-per-channel color depth to some QuickTime 
codecs. Trillions of Colors is enabled in the Output Module dialog box if a selected 
QuickTime codec supports 16 bits per channel. Contact the specific video hardware or 
codec manufacturer for more information concerning that product’s support of 16 bits per 
channel. Also, see the After Effects 5.5 Readme file for information concerning the codecs 
that support 16 bits per channel.

After Effects also exports the following files in 16-bits-per-channel format: Maya IFF, SGI, 
and RLA/RPF. After Effects no longer exports Amiga IFF files. Amiga files, however, may still 
be imported.

For information on the 16-bits-per-channel files that After Effects imports, see “Using the 
new import options” in chapter 19.



Using Help | Contents | Index Back 408  

Adobe After Effects Help Macintosh shortcuts 

Using Help | Contents | Index Back 408  

Macintosh shortcuts

Working with footage items (Project window)

RESULT ACTION

Open last project  +  +  + P

When opening a 
project, suppress 
opening of all 
windows (except the 
Project window)

Hold down 

Open selected 
footage item or 
composition

Double-click or Enter 
on numeric keypad 

Open movie in an 
After Effects footage 
window

-double-click 

Activate most recent 
composition

\

Add selected item to 
most recently 
activated compo-
sition

 + /

Replace a selected 
layer’s source footage 
in Composition 
window with 
selected footage

 +  + /

Replace a selected 
layer’s footage item 
or 
composition 

-drag footage item 
from Project window 
into composition

Replace footage file  + H

Set Interpret Footage 
options

 + F 
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 Command  Shift  Option  Key

Viewing windows (Composition, Layer, and Footage windows)

Scan for changed 
footage

 +  +  + Q

New folder  +  +  + N

Remember footage 
interpretation

 +  + C

Apply footage inter-
pretation

 +  + V

Set proxy file  +  + P

Project Settings  +  +  + K

RESULT ACTION

Display/hide title-
safe and action-safe 
zones

' (apostrophe)

Display/hide grid  +  ' (apostrophe)

Display/hide propor-
tional grid

 + ' (apostrophe)

Center active 
window

 +  + \

Suspend window 
updates

Caps Lock

Cycle through tabs in 
the frontmost 
window

 + , (comma) and  
+ . (period) 
Add  to zoom 
window to fit

Take multiple (up to 
four) snapshots 

 + F5, F6, F7, and F8

Display snapshot in 
active window

F5, F6, F7, and F8

Purge snapshot  +  + F5, F6, F7 
and F8

Purge all   +  + / on 
numeric keypad
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 Command  Shift  Option  Key

Moving around (Timeline window)

Display channel 
(RGBA)

 + 1, 2, 3, or 4

Display channel 
(RGBA) in color

 +  + 1, 2, 3, or 4

Display channel in 
color

 + click channel 
icon

Display unmatted 
color channels 

 + click alpha 
channel icon

Display Project 
window

 + 0 

Display Project 
Flowchart view

 + F11

Display/hide palettes Tab 

Close active tab/
window 

 + W 

Close active window 
(all tabs)

 +  + W 

Close all windows 
(except Project 
window)

 +  + W 

RESULT ACTION

Go to beginning of 
work area 

 + Home

Go to end of work 
area 

 + End

Go to previous visible 
keyframe or layer 
marker

J

Go to next visible 
keyframe or layer 
marker

K

Go to a composition-
time marker

0–9 on main 
keyboard
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 Command  Shift  Option  Key

Moving around (Composition, Timeline, Footage, and Layer windows)

 Command  Shift  Option  Key

Previewing (Timeline window)

Scroll selected layer 
to top of Timeline 
window

X

Scroll current time to 
center of window

D

Go to time  + G

RESULT ACTION

Go to beginning Home or  +  + 

Go to end End or  +  + 

Step forward 1 frame Page Down or  + 

Step forward 10 
frames

 +  +  or 
 + Page Down

Step backward 1 
frame

Page Up or  + 

Step backward 10 
frames

 + Page Up or  + 
 + 

Go to layer In point i

Go to layer Out point o

Snap items, such as 
visible keyframes, 
time markers, and In 
and Out points to 
each other on a time 
ruler

-drag item 

RESULT ACTION

Start/pause playback Spacebar

Preview audio from 
the current time

. (period) on numeric 
keypad 

RAM preview 0 on numeric keypad
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Note: If no layers are selected, commands are applied to all layers.

Note: Visual previews honor loop and audio toggles in Time Controls palette.

 Command  Shift  Option  Key

Working with layers (Composition and Timeline windows)

RAM preview every 
other frame 

 + 0 on numeric 
keypad  

Save RAM preview  + 0 on numeric 
keypad

Scrub video Drag or -drag 
current-time marker, 
depending on 
Preview Preferences 
setting 

Scrub audio -drag current-time 
marker

Wireframe preview  + 0 on numeric 
keypad

Display rectangle 
instead of alpha 
outline during 
wireframe preview

 +  + 0 on 
numeric keypad

Leave window 
contents during 
wireframe preview

 +  + 0 on 
numeric keypad

Leave window 
contents during 
rectangle preview

 +    +  + 0 on 
numeric keypad

RESULT ACTION

Rename layer, 
composition, folder, 
or effect 

Return

Select next layer back  + 

Select next layer 
forward

 + 

Select a layer by its 
layer-outline number

1–9 on numeric 
keypad
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Select noncon-
tiguous layers

-click layers

Deselect all layers  +  + A, or F2

Lock selected layers  + L

Unlock all layers  +  + L

Split selected layer  +  + D

Activate Composition 
window with layer

\

Display selected layer 
in Layer window

Enter on numeric 
keypad

Show/hide video  +  +  + V

Hide other video  +  + V

Display or close Effect 
Controls window for 
selected layers

 +  + T, or F3

Switch between 
Composition and 
Timeline windows

\

Open source of a 
layer

-double-click a 
layer, or press 

-Enter on numeric 
keypad

Scale layer without 
dragging a handle in 
Composition window

-drag layer

Snap layer to edges 
or center of frame in 
Composition window

 + -drag layer 
(begin dragging 
before pressing keys)

Constrain layer 
movement along x-
axis or y-axis

-drag layer (begin 
dragging before 
pressing keys)

Stretch layer to fit 
Composition window

 +  + F

Stretch layer to fit 
vertically, preserving 
frame aspect ratio

 +  +  + G
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Stretch layer to fit 
horizontally, 
preserving frame 
aspect ratio

 +  +  + H

Reverse a layer’s 
playback

 +  + R

Set In point [ (left bracket) 

Set Out point ] (right bracket) 

Trim In point of a 
layer

 + [ (left bracket)

Trim Out point of a 
layer

 + ] (right bracket) 

Display solid settings  +  + Y

Add/remove 
expression

-click property 
stopwatch

Set In point by time-
stretching

 +  + , (comma)

Set Out point by 
time-stretching

 +  + , (comma)

Move In point to 
beginning of compo-
sition

 + Home

Move Out point to 
end of composition

 + End

Constrain rotation to 
45-degree 
increments

-drag rotation tool

Constrain scaling to 
footage frame 
aspect ratio

-drag layer handle

Constrain movement 
along x or y axis

-drag layer

Reset rotation angle 
to 0 degrees

Double-click rotation 
tool

Reset scale to 100% Double-click 
selection tool
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 Command  Shift  Option  Key

Zooming (Composition, Layer, and Footage windows)

 Command  Shift  Option  Key

Viewing layer properties (Timeline window)

Change property 
value

Drag underlined 
values in Switches/
Modes panel

Change property 
value x 10

-drag underlined 
values

Change property 
value / 10

-drag underlined 
values

RESULT ACTION

Zoom in . (period) or  +  + 
= 

Zoom out , (comma) or  +  
+ - (hyphen) on main 
keyboard

Zoom in and resize 
window

 + . (period) or 
 + =  on main 

keyboard

Zoom out and resize 
window

 + , (comma) or 
 + - (hyphen) on 

main keyboard

Zoom to 100% / (on main keyboard) 
or double-click 
zoom tool

Zoom to 100% and 
resize window

 + / on main 
keyboard

Zoom window  + \ 

Zoom window to fill 
monitor

 +  + \ 

RESULT ACTION

Anchor Point A

Audio Levels L
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Audio Waveform LL

Effects E

Expressions EE

Mask Feather F

Mask Shape M

Mask Opacity TT

Mask properties MM

Material options (3D) AA

Opacity T

Position P

Rotation R

Time Remapping RR

Scale S

Show all animating 
values

U

Set layer property 
value in dialog box 
(works with P, S, R, F, 
and M)

 +  + property 
shortcut

Hide property or 
category

+  -click property 
or category name

Display/hide Parent 
column

Shift + F4

Add/remove 
property 

 + property 
shortcut

Toggle switches/
modes

F4

Turn off all other solo 
switches

-click solo switch

Change a setting 
(such as video or 
lock) for all selected 
layers

Click a layer switch

Open Opacity dialog 
box

 +  + O
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 Command  Shift  Option  Key

Working with compositions (Composition window)

 Command  Shift  Option  Key

Using the Tools palette (Tools palette)

Open Anchor Point 
dialog box

 +  +  + A

Zoom to or from 
frame view

; (semicolon)

Zoom in time = on main keyboard

Zoom out time - (hyphen) on main 
keyboard

RESULT ACTION

Set composition 
resolution to custom 

 +  + J

Composition 
Flowchart view

 +  + F11

Toggle window 
display options in 
palette menu

 +  + H

RESULT ACTION

Selection tool: 
Selects, moves, and 
resizes layers, masks, 
and controls 

V

Rotation tool: Rotates 
layers in the 
Composition window 

W

Camera tools (3D): 
Orbit, Track XY, and 
Track Z

C, or  + C to cycle 
through tools
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 Command  Shift  Option  Key

Modifying keyframes (Timeline window)

Rectangle tool or 
Oval tool: Draws a 
rectangular or ellip-
tical mask in the 
Layer window; 
double-click to reset 
the mask

Q, or  + Q to toggle 
between tools

Pen tool: Edits Bezier 
masks, motion paths, 
and Value graphs 

G

Pan Behind tool: 
Moves a layer behind 
a mask, or moves the 
anchor point without 
moving the layer 

Y

Hand tool: Scrolls 
window to reveal 
areas beyond 
window edge; hold 
down spacebar to 
use Hand tool in any 
window

H, or hold down 
spacebar

Zoom tool: Magnifies 
(or reduces using ) 
an area of a page 

Z

RESULT ACTION

Add or remove 
keyframe (if 
stopwatch is  on) or 
turn on time-vary 
stopwatch (if off )

 +  + property 
display shortcut

Select all keyframes 
for a property

Click property name

Deselect all 
keyframes 

Shift + F2

Snap keyframe to 
significant times

-drag keyframe
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 Command  Shift  Option  Key

Nudging layers (Composition and Timeline windows)

Nudge keyframe 1 
frame forward

 + 

Nudge keyframe 1 
frame backward

 + 

Select all visible 
keyframes 

 +  + A

Go to previous visible 
keyframe

J

Go to next visible 
keyframe

K

Switch interpolation 
between Linear and 
Auto Bezier

-click keyframe

Change Auto Bezier 
interpolation to 
Continuous Bezier

Drag keyframe 
handle

Toggle between 
Continuous Bezier 
and Bezier interpo-
lation

-drag keyframe 
handle

Easy ease F9

Easy ease in Shift + F9

Easy ease out  + Shift + F9

RESULT ACTION

Nudge layer 1 pixel in 
specific direction

Arrow key (nudges in 
direction of arrow) 

Nudge layer 1 frame 
earlier

Alt + Page Up

Nudge layer 1 frame 
later

Alt + Page Down

Nudge layer rotation  
+1 degree

+  (plus) on numeric 
keypad

Nudge layer rotation  
–1 degree

– (minus) on numeric 
keypad
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Note: Nudging counts pixels at the current magnification, not at actual size. For example, nudging an 
item 1 pixel at 50% magnification is the same as nudging the item 2 pixels at 100% magnification. 

Note: Hold down  to amplify nudging, scaling, or rotation by 10.

 Command  Shift  Option  Key

Setting the work area (Timeline window)

 Command  Shift  Option  Key

Working with masks (Composition and Layer windows)

Nudge layer scaling   
+1%

 +  +  (plus) on 
numeric keypad

Nudge layer scaling –
1%

 + – (minus) on 
numeric keypad

RESULT ACTION

Set beginning of 
work area to current 
time 

B

Set end of work area 
to current time 

N

Set work area to 
selected layers 

 +  + B 

Set work area to 
composition 
duration when no 
layers are selected 

 +  + B 

RESULT ACTION

Reset oval or 
rectangle mask to fill 
window

Double-click tool

Scale around center 
point in Free 
Transform mode

 + drag

Select all points on a 
mask

-click mask

Free transform mask  + T, or double-click 
mask
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 Command  Shift  Option  Key

Working with effects  (Effect Controls window)

 Command  Shift  Option  Key

Working with 3D animation (Composition and Timeline windows)

Exit free transform 
mode

Return

RESULT ACTION

Expand/collapse 
effect controls

` (grave accent)

Add keyframe for 
effect control

-click effect 
property name

Activate Composition 
window 
containing layer

\

RESULT ACTION

New camera  +  +  + C

New light  +  +  + L

Orientation (for 3D 
layer)

 +  +  + R

Remember view A Shift + F10

View stored view A 
(defaults to Front)

F10

Remember view B Shift + F11

View stored view B 
(defaults to Custom 
View 1)

F11

Remember view C Shift + F12

View stored view C 
(defaults to Active 
Camera)

F12

Return to previous 
view

Esc
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 Command  Shift  Option  Key

Using markers (Composition and Timeline windows)

 Command  Shift  Option  Key

Using other palettes (any window)

 Command  Shift  Option  Key

Toggle Casts 
Shadows property

 +  + C

RESULT ACTION

Set layer-time marker * on numeric keypad 

Remove layer-time 
marker

-click marker

Go to previous visible 
layer-time marker or 
keyframe

J

Go to next visible 
layer-time marker or 
keyframe

K

Go to a composition-
time marker

0–9 on main 
keyboard

Set and number a 
composition-time 
marker at the current 
time

 + 0–9 on main 
keyboard

RESULT ACTION

Switch from selection 
tool to pen tool

Hold down 

Switch from pen tool 
to selection tool

Hold down 

Display filename in 
Info palette

 +  + E
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Windows shortcuts

Working with footage items (Project window)

RESULT ACTION

When opening a 
project, suppress 
opening of all 
windows (except the 
project window)

Hold down 

Open last project  + Alt +  + P

Open selected 
footage item or 
composition

Double-click or Enter 
on numeric keypad 

Open movie in an 
After Effects footage 
window

Alt-double-click 

Activate most recent 
composition

\

Add selected item to 
most recently 
activated compo-
sition

 + /

Replace a selected 
layer’s source footage 
in Composition 
window with 
selected footage

 + Alt +  /

Replace a selected 
layer’s source footage 
item or composition  

Alt-drag footage item 
from Project window 
into composition

Replace footage file  + H

Set Interpret Footage 
options

 + F

Scan for changed 
footage

 + Alt +  + Q
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 Control  Shift  Key

Viewing windows (Composition, Layer, and Footage windows)

New folder  + Alt +  + N

Remember footage 
interpretation

 + Alt + C

Apply footage inter-
pretation

 + Alt + V

Set proxy file  + Alt + P

Project Settings  + Alt +  + K

RESULT ACTION

Cycle through open 
windows

 + Tab

Display/hide title-
safe and action-safe 
zones

' (apostrophe)

Display/hide grid  + ' (apostrophe)

Display/hide propor-
tional grid

Alt + ' (apostrophe)

Center active 
window

 + Alt + \

Suspend window 
updates

Caps Lock

Cycle through tabs in 
the frontmost 
window

 + , (comma) and  
+ . (period) 
Add Alt to zoom the 
window to fit

Take multiple (up to 
four) snapshots

 + F5, F6, F7, and F8

Display snapshot in 
active window

F5, F6, F7, and F8

Purge snapshot  +  + F5, F6, F7, 
and F8

Purge all  + Alt + / on 
numeric keypad
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 Control  Shift  Key

Moving around (Timeline window)

Display channel 
(RGBA)

Alt + 1, 2, 3, or 4

Display channel 
(RGBA) in color

Alt +  + 1, 2, 3, or 4

Display channel in 
color

 + click channel 
icon

Display unmatted 
color channels 

 + click alpha 
channel icon

Display Project 
window

 + 0

Display Project 
Flowchart view

 + F11

Display/hide palettes Tab

Close active tab/
window 

 + W

Close active window 
(all tabs) 

 +  + W

Close all windows 
(except Project 
window)

 + Alt + W

RESULT ACTION

Go to beginning of 
work area 

 + Home

Go to end of work 
area 

 + End

Go to previous visible 
keyframe or layer 
marker

J

Go to next visible 
keyframe or layer 
marker

K

Go to a composition-
time marker

0–9 on main 
keyboard
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 Control  Shift  Key

Moving around (Composition, Timeline, Footage, and Layer windows)

 Control  Shift  Key

Previewing (Timeline window)

Scroll selected layer 
to top of Timeline 
window

X

Scroll current time to 
center of window

D

Go to time  + G

RESULT ACTION

Go to beginning Home or  + Alt + 

Go to end End or  + Alt + 

Step forward 1 frame Page Down or  + 

Step forward 10 
frames

 + Page Down or  
+  + 

Step backward 1 
frame

Page Up or  + 

Step backward 10 
frames

 + Page Up or  + 
 + 

Go to layer In point i

Go to layer Out point o

Snap items such as 
keyframes, time 
markers, and In and 
Out points to each 
other on a time ruler

 -drag item

RESULT ACTION

Start/pause playback Spacebar

Preview audio from 
the current time

. (period) on numeric 
keypad 

RAM preview  0 on numeric keypad
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Note: If no layers are selected, commands are applied to all layers.

Note: Visual previews honor loop and audio toggles in Time Controls palette.

 Control  Shift  Key

Working with layers (Composition and Timeline windows)

RAM preview every 
other frame 

  + 0 on numeric 
keypad  

Save RAM preview  + 0 on numeric 
keypad

Scrub video Drag or Alt-drag 
current-time marker, 
depending on 
Preview Preferences 
setting 

Scrub audio -drag current-time 
marker

Wireframe preview  Alt + 0 on numeric 
keypad

Display rectangle 
instead of alpha 
outline during 
wireframe preview

 + Alt + 0 on 
numeric keypad 

Leave window 
contents during 
wireframe preview 

 + Alt + 0 on 
numeric keypad  

Leave window 
contents during 
rectangle preview

 +  + Alt + 0 on 
numeric keypad

RESULT ACTION

Rename layer, 
composition, folder, 
or effect 

Enter key on main 
keyboard

Select next layer back  + 

Select next layer 
forward

 + 

Select a layer by its 
layer-outline number

1–9 on numeric 
keypad
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Select noncon-
tiguous layers

-click layers

Deselect all layers  +  + A, or F2

Lock selected layers  + L

Unlock all layers  +  + L

Split selected layer  +  + D

Activate Composition 
window with layer

\

Display selected layer 
in Layer window

Enter on numeric 
keypad

Show/hide video  + Alt +  + V

Hide other video  +  + V

Display or close Effect 
Controls window for 
selected layer 

 +  + T, or F3

Switch between 
Composition and 
Timeline windows

\

Open source of a 
layer

Alt-double-click a 
layer, or press Alt-
Enter on numeric 
keypad

Scale layer without 
dragging a handle in 
Composition window

Alt-drag layer

Snap layer to edges 
or center of frame in 
Composition window

 + -drag layer 
(begin dragging 
before pressing keys)

Constrain layer 
movement along x-
axis or y-axis

-drag layer 
(begin dragging 
before pressing keys)

Stretch layer to fit 
Composition window

 + Alt + F

Stretch layer to fit 
horizontally, 
preserving frame 
aspect ratio

 + Alt +  + H
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Stretch layer to fit 
vertically, preserving 
frame aspect ratio

 + Alt +  + G

Reverse a layer’s 
playback

 + Alt + R

Set In point [ (left bracket)

Set Out point ] (right bracket) 

Trim In point of a 
layer

Alt + [ (left bracket)

Trim Out point of a 
layer

Alt + ] (right bracket) 

Display solid settings  +  + Y

Create new null 
object

 + Alt +  + Y

Add/remove 
expression

Alt-click property 
stopwatch

Set In point by time-
stretching

 +  + , (comma)

Set Out point by 
time-stretching

 + Alt + , (comma)

Move In point to 
beginning of compo-
sition

Alt + Home

Move Out point to 
end of composition

Alt + End

Constrain rotation to 
45-degree 
increments

-drag rotation tool

Constrain scaling to 
footage frame 
aspect ratio

-drag layer handle

Constrain movement 
along x or y axis

-drag layer

Reset rotation angle 
to 0 degrees

Double-click rotation 
tool

Reset scale to 100% Double-click 
selection tool
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 Control  Shift  Key

Zooming

 Control  Shift  Key

Viewing layer properties (Timeline window)

Change property 
value

Drag underlined 
values in Switches/
Modes panel

Change property 
value x 10

-drag underlined 
values

Change property 
value / 10

-drag underlined 
values

RESULT ACTION

Zoom in . (period) or  + Alt + 
= 

Zoom out , (comma) or  + Alt 
+ - (hyphen) on main 
keyboard

Zoom in and resize 
window

Alt + . (period) or  + 
=  on main keyboard 

Zoom out and resize 
window

Alt + , (comma) or  
+ - (hyphen) on main 
keyboard 

Zoom to 100% / (on main keyboard) 
or double-click 
zoom tool 

Zoom to 100% and 
resize window

Alt + / on main 
keyboard

Zoom window  + \ 

Zoom window to fill 
monitor

 +  + \ 

RESULT ACTION

Anchor Point A

Audio Levels L

Audio Waveform LL
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Effects E

Expressions EE

Mask Feather F

Mask Shape M

Mask Opacity TT

Mask properties MM

Material options (3D) AA

Opacity T

Position P

Rotation R

Time Remapping RR

Scale S

Show all animating 
values

U

Set layer property 
value in dialog box 
(works with P, S, R, F, 
and M)

 +  + property 
shortcut

Hide property or 
category

Alt +  -click 
property or category 
name

Display/hide Parent 
column

Shift + F4

Add/remove 
property 

 + property 
shortcut

Toggle switches/
modes

F4

Turn off all other solo 
switches

Alt-click solo switch

Change a setting 
(such as video or 
lock) for all selected 
layers

Click layer switch

Open Opacity dialog 
box

 +  + O
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 Control  Shift  Key

Working with compositions (Composition window)

 Control  Shift  Key

Using the Tools palette (Tools palette)

Open Anchor Point 
dialog box

 +  + Alt + A

Zoom to or from 
frame view

; (semicolon)

Zoom in time = on main keyboard 

Zoom out time - (hyphen) on main 
keyboard 

RESULT ACTION

Set composition 
resolution to custom

 + Alt + J

Composition 
Flowchart view

 +  + F11

Toggle window 
display options in 
palette menu

 +  + H

RESULT ACTION

Selection tool: 
Selects, moves, and 
resizes layers, masks, 
and controls 

V 

Rotation tool: Rotates 
layers in the 
Composition window 

W 

Camera tools (3D): 
Orbit, Track XY, 
and Track Z

C, or  + C to cycle 
through tools
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 Control  Shift  Key

Modifying keyframes (Timeline window)

Rectangle tool or 
Oval tool: Draws a 
rectangular or ellip-
tical mask in the 
Layer window; 
double-click to reset 
the mask

Q, or  + Q to toggle 
between tools

Pen tool: Edits Bezier 
masks, motion paths, 
and Value graphs 

G 

Pan Behind tool: 
Moves a layer behind 
a mask, or moves the 
anchor point without 
moving the layer 

Y 

Hand tool: Scrolls 
window to reveal 
areas beyond 
window edge; hold 
down spacebar to 
use Hand tool in any 
window

H, or hold down 
spacebar

Zoom tool: Magnifies 
(or reduces using Alt) 
an area of a page 

Z

RESULT ACTION

Add or remove 
keyframe (if 
stopwatch is  on) or 
turn on time-vary 
stopwatch (if off )

Alt +  + property 
display shortcut

Select all keyframes 
for a property

Click property name

Deselect all 
keyframes 

Shift + F2

Snap keyframe to 
significant times

-drag keyframe
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 Control  Shift  Key

Nudging layers (Composition and Timeline windows)

Nudge keyframe 1 
frame forward

Alt + 

Nudge keyframe 1 
frame backward

Alt + 

Select all visible 
keyframes 

 + Alt + A

Go to previous visible 
keyframe

J

Go to next visible 
keyframe

K

Switch interpolation 
between Linear and 
Auto Bezier

-click keyframe

Change Auto Bezier 
interpolation to 
Continuous Bezier

Drag keyframe 
handle

Toggle between 
Continuous Bezier 
and Bezier interpo-
lation

 + drag keyframe 
handle

Easy ease F9

Easy ease in Shift + F9

Easy ease out  + Shift + F9

RESULT ACTION

Nudge layer 1 pixel in 
specific direction

Arrow key (nudges in 
direction of arrow) 

Nudge layer 1 frame 
earlier

Alt + page up

Nudge layer 1 frame 
later

Alt + page down

Nudge layer rotation  
+1 degree

+ (plus) on numeric 
keypad

Nudge layer rotation  
–1 degree

– (minus) on numeric 
keypad
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Note: Nudging counts pixels at the current magnification, not at actual size. For example, nudging an 
item 1 pixel at 50% magnification is the same as nudging the item 2 pixels at 100% magnification. 

Note: Hold down  to amplify nudging, scaling, or rotation by 10.

 Control  Shift  Key

Setting the work area (Timeline window)

 Control  Shift  Key

Working with masks (Composition and Layer windows)

Nudge layer scaling   
+1%

 + + (plus) on 
numeric keypad

Nudge layer scaling –
1%

 + – (minus) on 
numeric keypad

RESULT ACTION

Set beginning of 
work area to current 
time

B 

Set end of work area 
to current time

N 

Set work area to 
selected layers

 + Alt + B 

Set work area to 
composition 
duration when no 
layers are selected

 + Alt + B 

RESULT ACTION

Reset oval or 
rectangle mask to fill 
window

Double-click tool

Scale around center 
point in Free 
Transform mode

 + drag

Select all points in a 
mask

Alt-click mask

Free transform mask  + T, or double-click 
mask



Using Help | Contents | Index Back 436  

Adobe After Effects Help Windows shortcuts 

Using Help | Contents | Index Back 436  

 Control  Shift  Key

Working with effects  (Effect Controls window)

 Control  Shift  Key

Working with 3D animation (Composition and Timeline windows)

Exit free transform 
mask

Enter

RESULT ACTION

Expand/collapse 
effect controls

` (grave accent)

Add keyframe for 
effect control

Alt-click effect 
property name

Activate compo-
sition window 
containing layer

\

RESULT ACTION

New camera  + Alt +  + C

New light  + Alt +  + L

Orientation (for 3D 
layer)

 + Alt +  + R

Remember view A Shift + F10

View stored view A 
(defaults to Front)

F10

Remember view B Shift + F11

View stored view B 
(defaults to Custom 
View 1)

F11

Remember view C Shift + F12

View stored view C 
(defaults to Active 
Camera)

F12

Return to previous 
view

Esc
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 Control  Shift  Key

Using markers (Composition and Timeline windows)

 Control  Shift  Key

Using other palettes (any  window)

 Control  Shift  Key

Toggle Casts 
Shadows property

Alt +  + C

RESULT ACTION

Set layer-time marker * on numeric keypad 

Remove layer-time 
marker

-click marker

Go to previous visible 
layer-time marker or 
keyframe

J

Go to next visible 
layer-time marker or 
keyframe

K

Go to a composition-
time marker

0–9 on main 
keyboard

Set and number a 
composition-time 
marker at the current 
time

 + 0–9 on main 
keyboard

RESULT ACTION

Switch from selection 
tool to pen tool

Hold down 

Switch from pen tool 
to selection tool

Hold down 

Display filename in 
Info palette

 + Alt + E
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Legal Notice

Copyright
© 2001 Adobe Systems Incorporated. All rights reserved.

Adobe After Effects 5.5 User Guide Supplement for Windows and Macintosh

If this guide is distributed with software that includes an end-user agreement, this guide, as well as the software described in it, is furnished 
under license and may be used or copied only in accordance with the terms of such license. Except as permitted by any such license, no part of 
this guide may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, recording, or 
otherwise, without the prior written permission of Adobe Systems Incorporated. Please note that the content in this guide is protected under 
copyright law even if it is not distributed with software that includes an end-user license agreement.

The content of this guide is furnished for informational use only, is subject to change without notice, and should not be construed as a 
commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies 
that may appear in the informational content contained in this guide.

Please remember that existing artwork or images that you may want to include in your project may be protected under copyright law. The 
unauthorized incorporation of such material into your new work could be a violation of the rights of the copyright owner. Please be sure to 
obtain any permission required from the copyright owner.

Any references to company names in sample templates are for demonstration purposes only and are not intended to refer to any actual 
organization.

Adobe, the Adobe logo, Acrobat, After Effects, and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorporated 
in the United States and/or other countries. Apple, Macintosh, and Mac OS are trademarks of Apple Computer, Inc., registered in the U. S. and 
other countries. QuickTime and the QuickTime logo are trademarks used under license. Microsoft, Windows, and Windows NT are registered 
trademarks of Microsoft Corporation in the U.S. and/or other countries. Flash is a trademark of Macromedia Inc. MPEG Layer 3 audio 
compression technology is licensed by Fraunhofer IIS and Thompson. RealNetworks, RealMedia, RealAudio, and RealVideo are registered 
trademarks of RealNetworks, Inc. All other trademarks are the property of their respective owners. 

Contains an implementation of the LZW algorithm licensed under U.S. Patent 4,558,302.

Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA

Notice to U.S. government end users. The software and documentation are “Commercial Items,” as that term is defined at 48 C.F.R. §2.101, 
consisting of “Commercial Computer Software” and “Commercial Computer Software Documentation,” as such terms are used in 48 C.F.R. 
§12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the 
Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) 
only as Commercial items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein. 
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Index

Numerics
0,0 (image area origin) 23

16-bpc color depth 12

2D effects 241

2D layers

combining with 3D layers 233

rendering with 3D layers 243

3:2 pulldown

defined 44

introducing 285

option 282

removing 45, 52

split-field frames 44

whole frames 44

30-fps drop-frame timecode 9

3D Channel effects category 180

3D Channel Extract effect 181

3D layers 89

auto-orientation 231

cameras 235

combining with 2D layers 233

creating 229

defined 228

intersecting 243

layer order 233

lights 239

material options 232

moving 229

previewing 242

rendering 242

rendering with 2D layers 243

Transform properties 231

3D rotation, understanding 232

3D views

Local Axes mode tool 22

orthogonal 234

perspective 234

setting and replacing 234

toggling 234

View Axes mode tool 22

World Axes mode tool 22

3-point tracking 310

4-point tracking 311

A
acceleration

fine-tuning 134

gradual 136

interpolation method and 134

rapid 136

Accepts Lights 3D layer material option 233

Accepts Shadows 3D layer material option 233

action-safe zones 17, 63

Active Camera 235

Add Control Point tool 23, 156

Add Expression command 244

Add layer mode 166

Add Marker command 85

Add mask mode 163

Add Output Module command 289

Add Point tool 22

Add to Render Queue command 279

adding

footage to composition 61

keyframes to Value graph 130

layers to composition 71

Adjust effects category 182

adjusting

appearance of low-resolution compositions 
60

direction handles 128

particle behavior 363
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adjustment layers

applying effects 175

changing rendering order with 267

creating 73

effects, and 175

from Adobe Photoshop 34

Adobe Illustrator

alpha channel 30, 35

importing files 35

importing masks from 161

layers 35

rasterizing 35, 87

Adobe Photoshop 25, 30, 32

adjustment layers 34

alpha channel 30, 34

exporting with layers 292

importing files 32, 34

importing files as compositions 33

importing masks from 161

layer effects 34

layer styles 176

layered files 32

Saving Files Preferences 33

transparent areas 34

using layer effects from 34

Adobe Premiere 37

Affects options 372

affine corner pin tracking 310

After Effects 3D renderer, using 243

After Effects product section (Web) 170

air brush tool 335

Align palette 75

aligning layers 75

All option (Vector Paint contextual menu) 337

All Strokes (paint Playback Mode) 341

Alpha Add layer mode 167

alpha channel 31, 191

defined 148, 176

editing considerations 51

Filmstrip format and 293

for a track matte 165

from Adobe Illustrator 35

Glow effect and 218

importing footage containing 30

matted with color 31, 32

premultiplied 31, 32

removing color matte 190

removing halos 190

straight 31, 32

unmatted 31, 32

using straight or premultiplied 30

using with track matte 165

viewing 20

working with footage containing 149

Alpha Levels effect 189

alpha matte 199

alpha-channel options (Vector Paint) 338

Ambient 3D layer material option 233

analog film

and video 39

importing 39

Anamorphic 2:1 setting 47

anamorphic aspect ratio 46, 47

Anchor diagram, in Composition Settings 
dialog box 61

Anchor option 56

anchor point

and Free Transform Points 154

and pan behind tool 159

animating 111

coordinates 23

moving 112

nudging values 112

speed 137

angle icon 173

Angle of View camera setting 236

angle, setting 173

Animate Strokes

Playback Mode 341

Playback Speed 342

animated GIF 6

animating

anchor point 111, 114

blending paint strokes 350

bouncing 136
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in the Timeline window 114

layer map 376

layers 95

mask properties 160

mask shape or feather 115

opacity 110, 114

paint strokes 340

position 103, 114

previewing 118, 120

rotation 110, 114

scale 109, 114

anti-aliasing, and Adobe Illustrator 35

Aperture camera setting 236

Apply Favorite command 172

Apply from Effect Point script 318

Apply to Effect Point script 318

arbitrary map 199

Arithmetic effect 189

arrays 246

As Inverse Matte (Composite Paint) 340

As Matte (Composite Paint) 340

Ask User import option 31

aspect ratio 46

anamorphic 46

D1 46

D4/D16 47

DV 46

square pixels 47

audio

adjusting levels 91

adjusting tone 185

clipping warning 93

decay 186

diffusion 186

effects 175, 184

effects See online help

importing 25, 38

layers 91

layers, time-remapping 144

output 278

preferences 92

previewing 91

remapping pitch 147

removing clicks 147

reversing 185

sample rate 92, 285

setting levels 93

VU meter 93

Audio command 94, 285

Audio effects category 184

audio files, importing 25, 38

Audio layer property 91

Audio Output options 285

Audio palette

options 92

resizing 92

Audio Spectrum effect 213

Audio switch 94, 116

Audio Waveform effect 213

Auto Bezier interpolation 124, 126

auto-orient 231

camera 237

changing 238

motion path 237

options 231

Auto-Orient Rotation command 111

Auto-Zoom When Resolution Changes option 
60

axes

defined 229

moving 230

Axes modes 238, 239

B
background

checkerboard 65

color 64

Background Color option 65

backward previews 93

backward tracking 308

Backwards effect 185

Basic 3D effect 212

Bass & Treble effect 185

Beam effect 214
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Best quality 88

subpixel accuracy 175

Best Settings template 281

Better Preview While Drawing option 347

Bevel Alpha effect 212

Bevel Edges effect 212

Bezier Handles command 104

Bezier interpolation

applying graphically 127

Auto Bezier 124

editing curves at keyframes 128

extending control handles 128

mixing with Linear 128

option 126

retracting control handles 128

temporal 125

Bezier mask

about 152

drawing with the pen tool 152

Bezier Warp effect 192

binary keys 177

black-and-white images

converting to grayscale 184

creating 184

black-and-white points, setting 183

Blend effect 189

blending

paint strokes 350

strokes 334, 350

Blink script 319

blink.mm/blink.mov script 319

Block Dissolve effect 224

Blur and Sharpen effects category 186

Blur Level camera setting 236

blur, motion 90

bounce

in animation 136

in sound 185

simulating with Speed graph 136

bounding box

Free Transform Points and 154

masks 155

Brightness & Contrast effect 182

Bring Forward command 75

Bring to Front command 75

Broadcast Colors effect 226

brush shape 335

brush size 334

Brush Strokes effect 218

brush tool. See paint tools

brush types 336

changing 335

Vector Paint 335

brushes

feather setting 336

radius 336

Bulge effect 192

bumping a camera 315

C
C programming language 317

Cache preferences 275

caching 120

purging the cache 120

camera settings 236

camera tools

orbit camera tool 238

track xy camera tool 238

track z camera tool 238

using 238

cameras

Active Camera 235

attributes and methods 261

auto-orient 237

auto-oriented toward motion path 237

auto-oriented toward point of interest 237

changing auto-orient 238

changing the view 235

creating and using 235

effects and 175

handheld 315

moving point of interest 237

point of interest 237

resetting Transform properties 238
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settings 236

tools 238

transform values 237

using for effects 241

Cannon 354, 355

Caps Lock key, stopping window updates 22, 
273

Card Dance effect 216

Card Wipe effect 225

Casts Shadows 3D layer material option 233

Casts Shadows light setting 240

Catmull-ROM interpolation. See Auto Bezier 
interpolation

Caustics effect 216

CD-ROM

best compressor for 291

Change Color effect 198

Channel Blur effect 187

Channel effects category 189

Channel Mixer effect 182

channels

mixing 186

setting 191

shifting 191

viewing 20

chapter links 83, 86

Checkerboard Background option 65, 339

checkered, color swatch 337

child layers 113

jumping 114

choking mattes 202, 211

Cineon Converter

effect 190

using 38

Cinepak compressor 291

clearing keyframes 99

Close command 11

closing

a project 11

strokes 334, 350

Closing in Groups command 15

cmpaud.mm/cmpaud.mov script 319

Collapse command 301

Collapse Transformations switch 35

Collect Files command 295

color

screen 176

selecting 336

viewing 20

color adjustments 182

Color Backward/Color Forward (paint option) 
341

Color Balance (HLS) effect 198

Color Balance effect 182

color bars as placeholders 54

Color Burn layer mode 167

Color Clone 336

Color conversion methods 258

color corrections

contrast 182

highlight 183

midtone 183

shadow 183

color depth

16-bit 12

8-bit 12

selecting for project 12

Color Difference Key 199

Color Dodge layer mode 167

Color Emboss effect 218

Color Key 202

Color layer mode 167

Color light setting 240

Color Range Key 203

color swatch 173, 337

checkered 337

Color swatch (painting) 336

Colorama effect 198

Colorize option 183

colors

levels, remapping 183

NTSC-Safe 6

options, changing 79

paint 335

pasteboard 65

value 20
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Comment panel 67

Comp attributes and methods 258

Comp Audio script 319

Comp Camera effects 175, 235, 241

Comp Family button 14

Comp Flowchart View command 264

Composite Paint options 338

compositing

defined 176

preserving transparency during 165

Composition Settings

command 57

Pixel Aspect Ratio 48

Composition window

adding footage to 62

defined 63

menu 14

opening 14

outputting from 117

pasteboard color 65

setting frame size 57

viewing a track matte in 165

working in 63

compositions

adding layers to 71

adding to Render Queue 279

adjusting appearance 60

arranging footage in 64

background color 64

changing settings 57

collapsing 269

coordinates 174

creating 56

default settings 56

defined 56

deleting 271

duplicating 61

duration 60

Enable Frame Blending button 89

Enable Motion Blur button 90

frame rate 59

low-resolution 60

naming 56

nesting options 61

overview 50

presets 56

region of interest 65

saving preset values 58

setting anchor 61

setting background color 64

setting frame size for 57

setting start timecode 60

settings 6, 57, 60

composition-time markers 83

Compound Arithmetic effect 190

Compound Blur effect 187

compression

for QuickTime output 289

Video for Windows output 291

compressors, list 278, 291

Cone Angle light setting 240

Cone Feather light setting 240

conforming footage to new frame rate 42

Constant interpolation 124

constants, Motion Math 325

containing particles within an area 365

contextual menus 14

Flowchart View 265

Vector Paint 334

Vector Paint commands 337

Continuous Bezier interpolation 124, 126

Continuously (paint option) 344

Continuously Rasterize switch 35, 268

contrast, setting 176

control point 156

changing 152

controlling

property output 368

property persistence 366

speed along a motion path 132

controls. See Effect Controls window

conventions, file-naming 8

Convert Control Point tool 23, 128

Convert Point tool 22
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coordinates 23

Copy command 100

Copy Relative Values script 319

Copy Values script 318, 319

copying, effects 171

copyvalu.mov/copyvalu.mm script 319

Corner Pin effect 193, 311

corner points 152

corners

creating in graph or path 128

smoothing 156

cornpin.mm/cornpin.mov script 319

correcting

drift 314

mistakes 11

creating particles

exploding a layer or particle 356

replacing dots with a layer 358

using Cannon 354

using exploders 356

using Grid 355

Creation Station tablet and Vector Paint 333

Crop option in Output Module dialog box 285

cropping a movie 302

cross hair, ruler 19

cross-platform

movies 294

projects 7

Current Frame (paint Playback Mode) 341

Current Time option (Vector Paint contextual 
menu) 337

current-time marker 21, 69, 99

effect on display of layers 62

effect when adding footage item 62

in Footage window 51

in Layer window 21

moving 69

curves 183

adding deviations 304

creating in graph or path 128

drawing with pen tool 152

segment, adjusting shape of 156

spatial 108, 304

temporal 108, 304

Curves effect 183

customizing Flowchart View 265

cuts, creating between layers 78

D
D1 footage 25, 46, 48

aspect ratio 46

frame size 46

pixel aspect ratio 58

D1/DV NTSC 47

setting 47

Widescreen 47

D1/DV PAL 47

Widescreen 47

D4/D16

Anamorphic 47

footage, aspect ratio 47

Standard 47

Dancing Dissolve layer mode 166

Darken layer mode 167

Darken mask mode 163

data rate 7

dbspring.mm/dbspring.mov script 319

DDR plug-ins. See your DDR manufacturer’s 
documentation.

DDR-based footage. See Digital Disk Recorders 
(DDRs)

deactivating Vector Paint 335

deceleration

fine-tuning 134

gradual 136

interpolation method and 134

rapid 136

default

duration, changing 27

frame rate 30

Import Preferences 27, 29

preferences 13

settings 12

spatial interpolation 129

Default Drag Import As 29
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Default Height of Timeline Graphs command 
135

degradation limit 121

Delay effect 185

Delete Control Point tool 23, 156

Delete Point tool 22

deleting

paint strokes 333

project elements 265

unused files 271

Vector Paint effect 333

Depth Matte effect 181

Depth of Field effect 181

Difference layer mode 167

Difference mask mode 163

Difference Matte 204

Diffuse 3D layer material option 233

digital

footage 40

video 40

Digital Disk Recorders (DDRs), setting frames 
and fields for 49

Digital Picture Exchange (DPX) 38

direction handles, creating curves and corners 
with 128

direction lines 152

Directional Blur effect 187

Disable Thumbnails in Project Window option 
16

Displacement Detail (paint option) 345

Displacement Map effect, edge behavior 193

Displacement Variation (paint option) 345

displacing pixels

across an image 193

over time 224

displaying

rulers and guides 19

time 9

display-snapshot icon 63

Dissolve layer mode 166

Distort effects category 191

distributing layers 75

dots

replacing with a layer 358

replacing with text 361

Double Spring script 319

downloading video 7

Draft 3D mode 273

enabling and disabling 242

Draft quality 88

dragging

audio 93

current-time marker 21

to import 28

drawing

motion path 106

rectangular and oval masks 150

drift, correcting 308, 314

drop shadow and rotation 266

Drop Shadow effect 176, 213

drop-frame timecode display 9

duplicating

composition 61

layers 74

duration 9

bar 76

bar, repositioning 101

defined 9, 50

of still images 27

setting 60

time-stretching and 139

Duration option 56, 282

Duration panel 67

DV footage

aspect ratio 46

importing 25

using 46

DV NTSC 48

DV video format 40

pixel aspect ratio 58

dynamic resolution 120

E
ease handles 134, 136

description 134
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Easy Ease keyframe assistant 139

influencing adjacent keyframes 136

splitting and rejoining 135

ease, expressions and 257

Easy Ease keyframe assistant 139

Echo effect 223

Edit Original command 51

editing footage. See  trimming

Effect Controls window 4, 14, 170, 172

changing settings 172

tabs 14

effect points 174, 312

interpolation 175

setting visually 174

Effect property, animating 116

Effect switch 88

effects

16 bits 172

3D Channel 180

3D Channel Extract 181

adding 171, 265

Adjust 182

Alpha Levels 189

applying 170

applying multiple 171

applying to a mask 161

applying to adjustment layer 175

Arithmetic 189

attributes and methods 262

audio 175

Audio Spectrum 213

Audio Waveform 213

Backwards 185

Basic 3D 212

Bass & Treble 185

Beam 214

Bevel Alpha 212

Bevel Edges 212

Bezier Warp 192

Blend 189

Block Dissolve 224

Blur and Sharpen 186

Brightness & Contrast 182

Broadcast Colors 226

Brush Strokes 218

Bulge 192

Card Dance 216

Card Wipe 225

Caustics 216

Change Color 198

changing order 170

changing over time 173, 174

changing rendering order 175

changing settings 172

changing values 172

Channel 189

Channel Blur 187

Channel Mixer 182

Cineon Converter 190

Color Balance 182

Color Balance (HLS) 198

Color Difference Key 199

Color Emboss 218

Color Key 202

Color Range Key 203

Colorama 198

Comp Camera effects 175

Compound Arithmetic 190

Compound Blur 187

copying 171

Corner Pin 193

Curves 183

Delay 185

Depth Matte 181

Depth of Field 181

Difference Matte 204

Directional Blur 187

disabled when nesting 269

disabled with collapsed transformations 269

Distort 191

Drop Shadow 213

Echo 223

Ellipse 214

Emboss 218
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Equalize 198

Extract 205

Fast Blur 188

Fill 214

Find Edges 218

Foam 217

Fog 3D 181

Fractal 214

Fractal Noise 215

Gamma/Pedestal/Gain 198

Gaussian Blur 188

Glow 218

Gradient Wipe 225

Hue/Saturation 183

ID Matte 182

Image Control 198

Invert 190

Iris Wipe 225

Keying 199

learning about 170

Leave Color 219

Levels 183

Lightning 215

Linear Color Key 207

Linear Wipe 225

Luma Key 209

Matte Choker 211

Matte Tools 210

Median 199

Mesh Warp 193

Minimax 190

Mirror 194

Mosaic 219

Motion Tile 219

Noise 219

Numbers 221

Offset 194

on the Web 170

Optics Compensation 194

Paint 212

Parametric EQ 186

Particle Playground 217

Path Text 221

Perspective 212

Polar Coordinates 194

positioning on layers 174

Posterize 184

Posterize Time 223

Production Bundle only 180

PS Arbitrary Map 199

PS+Extrude 219

PS+Lens Flare 215

PS+Pinch 195

PS+Ripple 195

PS+Spherize 195

PS+Tiles 219

PS+Twirl 195

PS+Wave 195

PS+Zig Zag 195

Radial Blur 188

Radial Wipe 226

Radio Waves 215

Ramp 215

Reduce Interlace Flicker 226

Remove Color Matting 190

removing 171

removing all from layer 172

Render 213

rendering order 266

Reshape 195

Reverb 186

Ripple 196

saving favorite 172

Scatter 220

Set Channels 191

Set Matte 191

setting a tint value 173

setting an angle 173

Sharpen 188

Shatter 217

Shift Channels 191

showing and hiding 88

Simple Choker 211

Simulation 216
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Smear 196

Spherize 197

Spill Suppressor 210

standard 179

Stereo Mixer 186

Strobe Light 220

Stroke 216

Stylize 217

Texturize 220

Threshold 184

Time 223

Time Displacement 224

Timecode 227

Tone 186

Transform 197

Transition 224

turning off and on 171

Twirl 197

Unsharp Mask 188

using lights and cameras 175

Vector Paint 333

Vegas 216

Venetian Blinds 226

Video 226

Wave Warp 197

Wave World 217

working with 170

Write-On 220

Effects option in Render Settings dialog box 
281

eiz files 241

elapsed time 280

ElectricImage

alpha channel 30

Ellipse effect 214

Emboss effect 218

Enable Depth of Field camera setting 236

Enable Frame Blending 89

Enable Motion Blur button 90

Enable Time Remapping command 144, 147

Enable Wiggling (paint option) 344

End option 282

ephemeral property change, defined 366

EPS files, importing 35

Equalize effect 198

Eraser mode (stylus setting) 335

eraser tool (Vector Paint) 335

erasing

paint strokes 333

radius 336

errors. See log file

Exclusion layer mode 167

exploding a layer or particle 357

Exponential Scale 305

Export command 289

exporting

as Adobe Photoshop file 293

to Macromedia Flash (SWF) 286

using QuickTime components 289

expression field, resizing 245

expression graph overlay 245

expressions

accessing properties 250

adding noise 257

Camera attributes and methods 261

Color conversion methods 258

Comp attributes and methods 258

constructing 250

converting to keyframes 246

creating 244

defined 244

easing in and out 257

editing 247

Effect attributes and methods 262

example of opacity and rotation 247

examples 247

Footage attributes and methods 258

Global attributes and methods 255

Global objects 255

Interpolation methods 257

language guide key 254

layer attributes and methods 259

layer space transform methods 260

Light attributes and methods 261

Mask attributes and methods 262
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Material properties for 3D layers 260

pick whip 246

Property attributes and methods 262

Random number methods 256

selecting values with pick whip 246

space 260

speed 262

text field 244

turning off 245

using JavaScript 244

Vector math methods 255

velocity 262

viewing multiple 245

wiggle 262

world space 260

extensions, filename 8

Extract effect 205

eyedropper tool 173, 336

F
Fast Blur effect 188

fast motion 142

Favor Memory preference 275

Favor Speed preference 275

Feather (paint setting) 336

feathering mask edges 156

feature region 307

Feet+Frames option 9, 60

Feet, time-display options 9

field order

interpreting 43

lower field first 43

reversing 302

testing 302

upper field first 43

field rendering 43, 281, 282

Field Rendering option 44

fields

interlaced 9

interlaced and noninterlaced 40

separating 43

setting up for DDR-based footage 49

File command (for importing) 28, 29

file formats

importing 25

list 278

supported for import 25

supporting alpha channels 30

file types, Mac OS 8

filenames

compositions 56

conventions 8

extensions 8

files

importing files with depth information 38

reloading edited 51

Fill effect 214

film scanner 39

Film Size camera setting 236

Filmstrip format 293

filters. See effects

Find Edges effect 218

Finder labels, for tracking discrepancies 299

fine-tuning

animation 122

speed 134

fingerprints, simulating with effects 187

first vertex 160

Flash (.swf) files 7, 286

flipping layers 109

Flowchart View 264

buttons 265

customizing 265

Foam effect 217

Focal Length camera setting 237

Focus Distance camera setting 236

Fog 3D effect 181

folders

creating 15

moving files 15, 16

project hierarchy 7

renaming 16

showing and hiding contents 16

working in 15
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footage

conforming to new frame rate 42

grainy 308

importing alpha channel 30

interlaced and noninterlaced 40

interpreting automatically 27

painting on 338

pixel aspect ratio 46

relinking 37

removing from a project 15

replacing and substituting 52

replacing throughout a project 53

separating fields 43

setting the frame rate for 52

footage attributes and methods 258

footage items

about 4

adding multiple 62

adding to composition 61

alpha channel 149

arranging in composition 64

as layer source 25

as reference link 25

assigning frame rate to 52

creating new layer from 72

defined 25, 50

editing in original application 51

frame rate of 59

importing 10, 25, 28

importing multiple 28

looping 52

managing 15, 53

opening in original application 51

organizing 15

reloading an edited file 51

removing 15

replacing 53

trimming 81

using a proxy for 53

using placeholders for 53, 54

viewing 50

when used in a layer 71

Footage window 4, 14, 51

outputting from 117

tabs 14

viewing controls 17

viewing movies 50

formats, files for importing 25

four-point tracking 311

Fractal effect 214

Fractal Noise effect 215

frame aspect ratio 46

frame blending

and speed 89

applying to a layer 89

Frame Blending option, Render Settings 
dialog box 281

Frame Blending switch 89

frame rate

assigning to a sequence of still images 30

changing before importing 30

default for a sequence 30

defined 8, 58

film 58

footage versus composition 59

for tracking motion 308

motion footage 52

setting for footage 52

Frame Rate option

in Composition Settings dialog box 56

in Render Settings dialog box 282

frame size 57

frames 9

blending 89

separating video fields 43

setting up for DDR-based footage 49

starting number 10

time-display options 9

viewing 21

Frames Backward/ Frames Forward (paint 
option) 341

Frames option 60

Free Transform Points 154

freeze frame 144

frmeffct.mm/frmeffct.mov script 318
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F-stop camera setting 236

full resolution 59

G
Gamma/Pedestal/Gain effect 198

garbage matte 177

Gaussian Blur effect 188

geometrics. See Transform properties

Global attributes and methods 255

Global objects 255

Glow effect 218

Go to Time command 21

Gradient Wipe effect 225

grainy footage 308

Gravity script 319

gravity, options 364

gravity.mm/gravity.mov script 319

grayscale images

converting to 182

converting to black-and-white 184

grids 18

changing 18

controlling direction of particles 355

controls 356

defined 17

proportional 18, 19

snapping a layer to 18

spacing 18

turning off 356

viewing 18

Group Tab with Comps command 14

Guess import option 31, 32

guides 17, 18, 19

hiding 19

H
half resolution 59

halos in images 190

hand tool 22

handheld camera 315

handles. See direction handles, ease handles

hand-tinted images 182

Hard Light layer mode 167

heat, simulating with effects 187

Hide Other Video command 80

Hide Shy Layers button 80

hierarchy, project 7, 265

histogram 205

Hold Strokes

paint Playback Mode 341

Playback Speed 342

hold-out matte 178

Hue layer mode 167

Hue/Saturation command 183

I
ID Matte effect 182

Ignore import option 32

Illustrator. See Adobe Illustrator

image area 23

image cache 275

Image Cache Size preference 275

Image Control effects category 198

images

alpha channel 30

blurring and sharpening 186

importing 25

importing moving 25

reshaping 192

Import Preferences

Default Drag Import As 29

default frame rate 30

Interpret Unlabeled Alpha As 31

Sequence Footage 30

Still Footage 27

imported files

movie 50

working with 50

importing

Adobe Illustrator files 35

Adobe Photoshop files 32, 34

Adobe Premiere projects 37

After Effects projects 37

and platforms 37
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and resolution 26

audio files 38

Cineon files 38

DDR-based footage 49

EPS files 35

file formats 25

files into project 29

files with depth information 38, 241

footage in projects 28

footage items 10

footage items with alpha channel 30

layers from Adobe Illustrator 5.0 and later 35

masks from Adobe Illustrator 161

masks from Adobe Photoshop 161

multiple footage items 28

preparing footage for 25

still images 25, 29

still-image sequences 29

In Original (Composite Paint) 339

In Original Alpha Only (Composite Paint) 340

In panel 67

positioning a layer in time 76

In point 81

changing 77

defined 81

In Realtime (paint option) 344

Include Composited Image with Layered Files 
(Adobe Photoshop) 33

Individual Stroke Seeds (paint option) 346

Info palette 23, 174

changing RGBA display 24

channel information 23

viewing layer name 79

X/Y coordinates 23

Inner Glow effect 176

Inner Shadow effect 176

Intel Indeo compressor 291

intense peak, simulating with Speed graph 
136

Intensity light setting 240

Interface Options, painting 347

interlaced and noninterlaced footage 40

interlaced video 41, 43

and motion tracking 308

Internet. See World Wide Web

interpolation 122

acceleration and 134

Bezier 124, 125

changing 126

choosing a method 123

Continuous Bezier 125

deceleration and 134

frames for smooth motion 89

Hold 125

Linear 124

mixing methods 129

none 123, 124

spatial 122

temporal 122

types 132

interpolation methods 257

keying 177

mixing 129

Interpret Footage command 52

Interpret Footage settings

copying 52

field order 43, 44

interpretation rules 27

looping 52

Motion Detect option 43

Separate Fields options 43

Interpret Unlabeled Alpha As 31

interpretation

field order 43

rules 27

Intersect mask mode 163

intersecting layers 243

intranet playback 7

Inverse option (Vector Paint contextual menu) 
337

Invert effect 190

Iris Wipe effect 225

isolating layers 81, 273
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J
JavaScript language 244

K
key color

defined 176

removing traces of 210

keyboard shortcuts

Mac OS 408

Windows 423

keyboard shortcuts, Vector Paint 349

keyframe assistants

Easy Ease 139

Time-Reverse Keyframes 141

keyframe icon 97

Keyframe Interpolation command 126, 139

keyframe navigator 97

Keyframe Velocity command 137

keyframes

adding 98, 105

adding to Value graph 130

Anchor Point 111

and duration bar 101

and precomposing 271

and Value graph 130

changing interpolation 126

controlling speed between 133

copying and pasting 100

creating for Motion Math 322

deleting 99

excess 107

fine-tuning speed between 134

freezing 145

influence 136

mask shapes and feathers 115

modifying 103

modifying in Value graph 130

motion path 106

motion path display preference 106

moving 100

opacity 110

Position 103

reversing 141

Rotation 110

roving 137

Scale 109

selecting 99

setting 98, 103

values 102

keying

binary keys 177

combining keys 179

defined 176

for a single frame 176

interpolation methods 177

linear keys 177

matte tools 177

removing color spill 210

static background 204

using a background color 177

keying effects 176

Keying effects category 199

Keys panel 67

L
language element menus 252, 329

Last Painted option (Vector Paint contextual 
menu) 337

Layer Audio script 319

layer duration bar 101, 139

layer effects from Adobe Photoshop 34

Layer Exploder

controls 357

dissolving a layer 356

Layer Handles command 104

layer map

animating 376

creating 374

modifying particle properties 370, 372

options 360

setting up in a composition 375

using RGB channels 375

using the alpha channel 370, 375

layer masks from Adobe Photoshop 34
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layer modes

applying 168

defined 166

options 166

specifying 166

layer outline, expanding or collapsing 96

Layer Paths command 104

layer properties

about 95

Anchor Point 111

and precomposing 271

changing values 130

Effects 116

keyframes for 98, 99

Masks 115

Opacity 110

rendering order 278

Rotation 110

Scale 109

viewing 95

layer space

and expressions 260

transform methods 260

layer styles from Adobe Photoshop 176

Layer Switches panel 87

Layer Tangents command 104

Layer window 4, 14

menu 14

outputting from 117

specifying a layer mask 149, 159

tabs 14

Target menu 159

layeraud.mm/layeraud.mov script 319

layered Adobe Photoshop files, importing 32

layers

3D 89, 228

adding to composition 71

adjustment layers 73

aligning and distributing 75

alpha channel 148

anchor point 23, 111

animating 95, 103

applying an effect to 170

applying motion blur 90

arranging 75

attributes and methods 259

audio 91

bringing closer or farther 75

cameras 73

changing into adjustment layers 74

changing stacking order 75

child 113

creating 61, 71, 72

creating a new solid 73

creating from a footage item 72

creating parent 114

creating simple cuts between 78

defined 50, 71

distributing 75

dragging 76

duplicating 74

duration 101

effect 88

exploding 356

flipping 109

frame blending 89

hiding and showing 80

hiding in Composition window 80

In point 77

including and excluding audio 94

isolating 81, 273

label colors 79

layer-time markers 85

lights 73

locking and unlocking 81

making transparent 110

memory requirements for 275

missing 33

motion blur 90

moving 103

moving in space 103

moving in time 76

naming 33

numbers 75
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order 233

Out point 77

painting 333

parent 113

placing an effect on 174

position 103

positioning effects on 174

positioning in time 76

properties of 95

property functions 323

quality 88

rearranging 74

renaming 79

replacing dots with a layer 360

reversing playback 141

rotating 110

rotating along a motion path 111

scaling 109

sequencing 77

setting 103

solid-color 73

soloing 81, 273

source name 79

splitting 74

stacking order 75

time-remapping 142

time-stretching 139

transitions between 78

trimming 81

updating 266

viewing name in Info palette 79

viewing source or layer name 79

layer-time markers 83, 85

Leave All Attributes In option 271

Leave Color effect 219

Length of Composition, import preferences 27

Levels effect 183

Light attributes and methods 261

Light Type light setting 240

Lighten layer mode 167

Lighten mask mode 163

Lightning effect 215

lights

auto-orient off 240

auto-oriented toward motion path 240

auto-oriented toward point of interest 240

creating 239

defined 239

effects and 175

settings 239

Transform properties 240

using for effects 241

Linear Color Key 207

preserving color 209

Linear interpolation 124

changing from spatial 129

defined 124

mixing with Bezier 128

option 126

linear keys 177

Linear Wipe effect 225

lines. See  visible lines

links

chapter 86

Web 85

load-sharing on multiple systems 299

Local Axes mode tool 22

location of an effect point 174

Lock Aspect Ratio option 56

Lock switch 81

locking a guide 19

log file

overflow and 300

rendering 278, 280

Loop button, direction 93

loop, Motion Math 321, 324

looping footage 52

lower field ordered 43, 302

low-resolution compositions 60

low-resolution movies for testing motion 302

low-resolution proxy 54

Luma Key 209

Luma Matte option 165

luminance value for a track matte 165
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Luminescent Premul layer mode 168

Luminosity layer mode 167

M
Mac OS file types 8

magnification 17

Main command (for Interpret Footage) 30, 52

Make Movie command 278, 279, 293, 294

manual preview 117, 119

mapping particles to a multiframe layer 358

margins 18

margins, paint strokes. See  Feather

markers

chapter link 86

composition-time 83

converting from composition to layer 86

current-time 21, 97

layer-time 85

synchronizing 86

tracking motion 313

marquee 153

Mask attributes and methods 262

Mask Expansion property, adjusting 157

Mask Feather command 137

disabled when nesting 269

with continuous rasterization 87

Mask Feather property, animating 160

mask modes, applying 163

Mask Opacity property, adjusting 157

mask paths 151

Mask property 115

mask shape

and pan behind tool 159

animating 160

speed 137

storing and reusing 164

Mask Shape command, disabled when 
nesting 269

masks 149

adding a control point to 155

adjusting opacity of 157

adjusting the edges of 157

animating 160

applying effects to 161

Bezier 150

changing the shape of 155

color 150

converting motion paths to 151

creating 149

creating lines from 162

defined 148

deleting 155

editing 155

feathering 156

first vertex 160

inverting 158

memory requirements for 275

modes 162

modifying multiple masks 163

moving 155, 159

outline 158

oval 150

panning 158

rectangle 150

removing 154

rendering order 266

replacing 155

resetting 155

resizing 154

reusing 164

rotating 154

saving 164

scaling 154

selecting 153, 154

setting interactions 162

specifying inside and outside 158

specifying with Target menu 149, 159

types 150

using rectangular for speed 273

material options for 3D layers 232

material properties for 3D layers 260

Matte Choker effect 202, 211

matte options (Vector Paint) 338

Matte Tools effects category 210
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matte view, defined 176

matted alpha channel 31

mattes

choking 202

defined 148

refining 177

removing 190

spreading 211

tools 177

track 164

traveling 164

Maximum Memory Usage preference 275

Measure Film Size camera setting 237

measuring time 9

media 5

Median effect 199

memory

allocating more to After Effects 274

reducing requirement for 276

using effectively 274

Mesh Warp effect 193

Microsoft

RLE compressor 291

Video compressor 291

Millions of Colors for MJPEG cards 6

Millions of Colors+, effect on background 
color 64

Minimax effect 190

Minimum Diskspace before overflowing 
option 300

Mirror effect 194

missing source footage 54

mistakes, correcting and undoing 11, 12

mixing audio 186

MJPEG compression 6, 7

Mode preferences (caching) 275

Modes panel 67

modes.  See layer modes and mask modes

Monochrome option 182

Mosaic effect 219

motion

randomizing 304

sketching 106

smoothing 138

testing 302

tracking 305

motion blur 90, 187

Motion Blur render setting 282

Motion Blur switch 90

Motion Detect option 43

motion footage

changing frame rate 42

preparing for final output 42

preparing to import 39, 42

separating fields 43

time-remapping 144

Motion Math

assignments and operators 321

built-in loop 321

comments 325

constants 325

creating keyframes 322

defined 317

functions 325

If statements 323

language element menus 329

language reference 249, 329

layer property functions 322

learning more 321

loops 324

math functions 325

numbers 322

running a script 320

specifying layers and properties 325

substitution menus, in scripts 328

testing scripts 326

using vectors 327

variables 322

vector indexing 327

vector operations 328

vectors as variables 327

writing scripts 320

Motion Math window 318

motion path 106, 122, 125

changing keyframe interpolation 127



Using Help | Contents | Index Back 459  

Adobe After Effects Help Index 

Using Help | Contents | Index Back 459  

A  B  C  D  E  F  G  H   I   J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z

changing keyframe number 106

changing speed numerically 137

Composition window and 104

controlling speed 132, 133

controls 104

creating 106

creating with mask 108

defined 104

direction handles and 128

display preferences 106

Easy Ease keyframe assistant 134

editing 104

editing with pen tool 127

keyframes 104

modifying 104

moving all points in 106

rotating a layer along 106, 111

spatial interpolation and 122

speed 133

motion picture film 41

Motion Sketch 106

Motion Tile effect 219

Move All Attributes into The New 
Composition option 271

movies

building 4

changing the frame rate for 52

opening in the Footage window 50

preparing for import 42

rendering 278

resizing 300

viewing 50

MP plug-in 277

MP3 format 286

multiframe source layers

randomizing 359

using sequential frames 359

multilayered Adobe Photoshop files, 
importing 33

multiple systems

load-sharing 299

rendering on 297

Multiply layer mode 166

multiprocessors and After Effects 277

N
Name camera setting 236

naming

composition 56

conventions for files 8

layers 33

National Television Standards Committee 
(NTSC) 6, 40

field order 43

frame rate 58

interlacing and 40

navigator, keyframe 97

nesting 72

changing rendering order 267

collapsing transformations 87, 268

common uses for 265

definition 265

opacity and 269

options 61

prerendering and 270

network performance on multiple systems 
298

New Adjustment Layer command 73

New Composition command 56

New Solid command 73

Noise effect 219

non-drop-frame timecode display 9

None mask mode 163

None option (Vector Paint contextual menu) 
337

noninterlaced video 41

nonlight 240

Normal layer mode 166

NTSC. See  National Television Standards 
Committee (NTSC)

NTSC-Safe colors 6

null objects

creating 114

defined 114

Numbers effect 221
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O
Offset effect 194

offset motion 315

offsetting in unison 359

one-third resolution 59

Onion Skin (paint Playback Mode) 341

Only option (Composite Paint) 339

opacity

building up 335

increasing 335

nesting and 269

paint 335

speed 137

stylus pressure 348

stylus settings 345

Opacity property

animating 114

setting 110

Open Project command 11

opening footage in original application 51

Optics Compensation effect 194

Options, effect 171

Orbit Camera tool 22

orbit view tool 238

order of effects, changing 170

organization chart. See Flowchart View

organizing

footage 15

projects 264

Orient Toward Camera option 231

orientation 232

orthogonal views 234

Out panel 67

positioning a layer in time 76

Out point 81

changing 77

Outer Glow effect 176

Output Module

adding 289

creating and saving 285

definition 284

Output Module Templates command 284

Oval Mask tool 22

oval masks, drawing 150

oval tool 23, 150

Over Original (Composite Paint) 339

overflow

log file 300

types of 300

Overlay layer mode 167

overscan 17

P
paint

color selection 336

color swatch 337

eyedropper tool 336

opacity 335

selection tool 337

Undo button 336

paint color 335

Paint effects category 212

paint strokes

changing 337

selecting 334

paint tools 334, 335

changing shape of 335

painting 333

applying Vector Paint effect 333

brush shape 335

deactivating 335

eraser tool 335

how to 333

on footage 338

toolbar 333

PAL video 6, 40, 46

palette and window positions, restoring 13

palettes

Info 23

pan behind tool 22, 112, 159

moving the anchor point 159

panning

audio 186

mask 158
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parallax.mm/parallax.mov script 319

Parametric EQ effect 186

Parent column, showing or hiding 113

parent layers

creating 114

defined 113

removing 114

Parent panel 67

particle behavior

adjusting after creation 363

attracting particles 365

containing particles 365

repelling particles 365

rotating along trajectories 364

using gravity 364

particle behavior. See also particles

particle effects 217, 351

particle exploders

controls 358

dissolving a particle 356

Particle Playground 217, 351, 354

overview 351

particle generators 353

properties 352

particle properties

displayed 352

modifying with a layer map 370

modifying with RGB channels 372

specifying which ones are affected 370, 372

particle source layer, defined 358

particles

adjusting behavior 352, 362

attracting 365

Cannon and 354

controlling direction 354

controlling velocity 354

default 352

dissolving 356

exploding 356

generating a continuous stream 354

gravity and 364

grid of 355

layer maps and 374

lifespan of 363

offsetting from a different source 360

offsetting from the same frame 360

pulling 364

repelling 365

replacing default 358, 361

replacing dots with a layer 358

replacing dots with text 361

specifying 372

types of 353

walling 365

Past Strokes

Playback Mode 341

Playback Speed 342

Paste command 100

pasteboard color 65

patches, defined 193

Path Text effect 221

pen tool 22, 128, 131

Add Control Point 156

adding keyframes with 105

Convert Control Point 156

Delete Control Point 156

drawing a Bezier mask with 152

drawing curves 152

drawing straight lines 152

editing a motion path 105

mask shape and 155

Value graph and 130

persistent property change, defined 366

perspective corner pin tracking 311

Perspective effects category 212

Phase Alternate Line (PAL) See PAL

Photoshop Layers command 292

pick whip 113

using with expressions 246

pitch, changing 147

pixel aspect ratio 47, 56

defined 46

option 58

setting 48
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pixels

color values 20, 23, 176

displacing 193, 220, 224

Placeholder command 54

placeholders, substituting for footage 54

planning a project 5

platforms and importing 37

playback

adjusting with Re-timer 343

reversing direction 141

speed 107

Playback Mode (painting) 340

Playback Speed

adjusting 342

Re-timer, compared to 343

playback speed (paint) 342

Playground. See Particle Playground

playing backward or forward 93

plug-ins

adding 170

effects 170

folder 170

rendering over a network 299

Point At script 319

point of interest

camera 237

lights 240

moving camera point of interest 237

moving light point of interest 241

pointat.mm/pointat.mov script 319

Polar Coordinates effect 194

position and rotation tracking 310

position keyframes 105

Position property

animating 114

nudging layer values 103

pan behind tool and 158

setting 103

position tracking 309

positioning effects on layers 174

posterize 184

Posterize effect 184

Posterize Time effect 223

Pre-compose command 271

precomposing

changing rendering order 267

description 270

options 271

Preference

deleting 377

Preferences

action-safe 18

alpha channel interpretation 32

Default Drag Import As 29

dialog box 13

Display 18

display options 60

for stylus (Vector Paint) 348

Grids and Guides 18

image cache 275

Import 27

interpolation 129

Interpret Unlabeled Alpha As 31

Labels 79

motion-path keyframe display 106

Output 300

Overflow Volumes 300

shutter angle 91

still footage duration 27

synchronizing window times 268

Time 9

title-safe 18

Video Preview preferences 117

Wireframe Interactions 273

Premiere. See Adobe Premiere

Premultiplied (Matted with Black) import 
option 32

Premultiplied (Matted with White) import 
option 32

premultiplied alpha channel 31

prerendering 270

Preserve Frame Rate When Nested option 61

Preserve Resolution When Nested option 56, 
61

Preserve Underlying Transparency option 165
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Preset camera setting 236

presets, composition

deleting 58

reusing 58

saving 58

Pressure Detail (paint option) 346

pressure settings (paint) 345

Pressure Variation (paint option) 346

preview, playing 118

previewing

3D layers 241

alpha channels 20

animation 118

audio 91

backward or forward 93

color 20

frames 21

manual 117

on external monitor 117

options 118

preferences 273

RAM 116

region of interest 65

saving RAM preview 288

setting 116

Shift+RAM 118

standard 117

stopping 118

Video Preview preferences 117

wireframe 117, 120

Wireframe Interactions 242, 273

Production Bundle, Vector Paint 333

progressive scan 40

project

creating new 10

opening 11

Project Flowchart View command 264

Project window 14, 15

creating a folder 15

managing footage items in 15

using 15

projects

building 4

choosing media 5

closing 11

creating 10

cross-platform 7

defined 4

finished 5

hierarchy 7

importing one into another 37

opening 11

organizing 264

planning 5

reducing 15, 271

removing footage from 15

reverting 12

saving 11

setting up 10

starting 5

properties

layer 95

setting particle 367

Property attributes and methods 262

Property Mapper

defined 366

Ephemeral 366

options 367

Persistent 366, 367

property mapping

controlling output ranges 368

property output 369

property persistence 366

property persistence 366

proportional grids 18, 19

proxies 281

compared to placeholders 53

identifying 55

rendering with 54

stopping use of 55

switching with original 55

PS Arbitrary Map effect 199

PS+Extrude effect 219

PS+Lens Flare effect 215
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PS+Pinch effect 195

PS+Ripple effect 195

PS+Spherize effect 195

PS+Tiles effect 219

PS+Twirl effect 195

PS+Wave effect 195

PS+Zig Zag effect 195

pulldown, 3:2. See  3:2 pulldown

Q
Quality option in Render Settings dialog box 

281

Quality switch 88

quality, adjusting 265

quarter resolution 59

question mark symbol (Vector Paint) 335

question mark, in Brush Settings 338

Queue status 280

quick menus 14

Quick Reference, keyboard shortcuts for 
Vector Paint only 349

QuickPaint 343

QuickTime

alpha channel 30

compression settings 290

compressors 290

exporting through 289

output format 278

R
Radial Blur effect 188

Radial Wipe effect 226

Radio Waves effect 215

radius (paint brush), editing 338

Radius (paint setting) 336

radius, stylus settings 345

RAM (random access memory)

allocating more 274

RAM preview 288

using effectively 274

utilities 277

virtual memory 277

RAM (random access memory) preview 116

playing back 119

setting Preferences 275

Shift+RAM preview 116

Ramp effect 215

random number methods 256

randomizing motion 304

rasterizing continuously with Adobe 
Illustrator files 35

Recent Favorites command 172

Rectangle Mask tool 22

rectangle tool 23, 150

rectangular pixels 46

red outline 22

Reduce Interlace Flicker effect 226

Reduce Project command 15, 271

reducing the size of a movie 300

reference link 25

refining mattes 177

Region of Interest option 64, 65

Relative Corner to Absolute Corner script 319

relative radius values (paint brushes) 338

relinking footage 37

Reload Footage command 51

reloading an edited file 51

remap-time marker 143

Remove Color Matting effect 190

Remove Unused (footage) command 15

removing

3:2 pulldown 45

excess keyframes 107

footage from a project 15

guides 19

Render effects category 213

render farm 296

Render Queue window

defined 279

status line 280

render settings 281

Render Settings Templates command 283

rendered images, previewing 93

rendering

3D layers 242
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and frame blending 89

and memory requirements 274, 276

audio options 285

changing order using adjustment layer 175

changing settings 281

compositions with 2D and 3D layers 243

cross-platform movies 294

elapsed time 280

fields 43, 282

frame blending 89

increasing speed 280

log file 280

making a smaller movie 300

on multiple systems 297

order 175, 266

over a network 296

overview 278

pausing 280

prerendering 270

render farm 296

render plug-in 243

render queue information 280

rerendering 280

sequences 293

status 280

templates 281, 283

watch folders 296

Rendering Plug-In option 57, 61

Repel options 365

repelling particles 365

Replace Footage command 53, 54

replacing default particles

with a layer 358

with text 361

replacing dots with a layer 358

precomposing a layer 358

stopping 361

using a layer’s original state 358

replacing dots with text 361

replacing footage throughout a project 53

repositioning a guide 19

Reset Palette Locations command 13

Reshape effect 195

reshaping images 192

resizing

layer 109

movie 300

resolution

and importing 26

and importing still footage 25

half 59

one quarter 59

one third 59

options 59

preserving 269

proxies 54

setting 59

using maximum 26

Resolution option

in Composition Settings dialog box 56

in Render Settings dialog box 281

resources 8

Re-timer (paint) 343

Reverb effect 186

reversing audio 185

reversing keyframes 141

Revert command 12

revolving a layer.  See rotation

RGBA display, changing 24

Ripple effect 196

rla files 241

rotation

along a motion path 111

selected masks 154

speed 137

tracking 309

with motion blur applied 90

X Rotation 232

Y Rotation 232

Z Rotation 232

Rotation property

animating 110, 114

nudging layer values 110

setting 110
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rotation tool 22

rotoscoping 293

roving keyframes 137

rulers 63

defined 63

displaying 19

hiding 19

setting the zero point 19

time. See  time ruler 21

zero point 23

S
safe zones 18, 63

margins 18

viewing 17

sample rate 92, 285

Saturation layer mode 167

Save A Copy command 11

Save As command 11

Save command 11

Save Favorite command 172

Save Frame As command 292

Save RAM Preview command 289

saving

project 11

single frame of a movie 292

Scale All Layers script 319

Scale Layers by Comp Size script 319

Scale property

about 109

animating 114

for a layer 109

keyframes 109

nudging layer values 109

scale, exponential 305

scaleall.mm/scaleall.mov script 319

scaleby.mm/scaleby.mov script 319

scaling masks and points 154

Scatter effect 220

Screen layer mode 166

scripts for Motion Math

saving 321

testing 326

writing your own 320

scrubbing. See  dragging

search region 307

SECAM 6

segment, as part of a mask

 See also curve segment

drawing 152

Select All command 154

Select Label Group 265

selecting

all objects 154

keyframes 99

masks 153

paint strokes 334, 337

paint strokes (shortcuts) 349

selection marquee 153

selection tool 22, 64

paint strokes 337

selection tool (Vector Paint) 334

Send Backward command 75

Send to Back command 75

separating

fields 43

video fields 43

sepia-tone images 182

Sequence Footage 30

Sequence Layers command 78

sequences

frame blending 89

importing 29

rendering still images 293

Set Channels effect 191

set first vertex 160

Set Matte effect 191

Set Max Error value (paint) 338

Set Proxy command 55

setting

background color of a composition 64

current time 69

duration 60

frame rate 58
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frame rate for footage 52

frame size for a composition 57

keyframes 98, 103

particle properties 367

pixel aspect ratio 47

preferences 12

preview options 116

time-display preferences 9

zero-point in rulers 19

setting and animating

layer position 103

opacity 110

rotation 110

setting up

project 10

work area 70

settings

camera 236

changing composition 56

lights 239

Shadow Darkness light setting 240

Shadow Diffusion light setting 240

shadows 239

shapes

adjusting a curve segment 156

brush types (painting) 335

changing mask 155

creating from masks 162

shaping a layer to a grid 18

Sharpen effect 188

sharpening images 186

Shatter effect 217

Shift Channels effect 191

Shift-Paint Records 343

Shininess 3D layer material option 233

shortcuts

Mac OS 408

Windows 423

shortcuts, Vector Paint. 349

Show Actual Brush Size option 347

Show All Video command 80

Show Effects (Flowchart View) 265

Show Tool Tips option 22

Show Toolbar paint option 347

shutter angle in Render Settings dialog box 
282

Shutter Angle option 56

Shutter Phase option 56

Shy switch 80

Silhouette Alpha option 168

Silhouette layer mode 168

Silhouette Luma option 168

Similar option (Vector Paint contextual menu) 
337

Simple Choker effect 211

simple cuts 78

simplifying stroke paths 338

simulating a zoom lens 305

Simulation effects category 216

single frame, saving 292

single-frame sequence 297

size, of a layer 109

sketching a motion path 106

Skin Opacity (paint option) 341

Skip Existing Files option, in Render Settings 
dialog box 282

slip edit 83

slow motion. See  time-remapping and time-
stretching

Smear effect 196

smoke, simulating with effects 187

smooth points 152

Smoother 107

Smoother command (Vector Paint) 338

smoothing

motion 138

paint strokes 338

smudges, simulating with effects 187

Snap to Grid command 18

snapshots 20

multiple 21

purging 20

taking 20

viewing 20
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Society of Motion Picture and Television 
Engineers (SMPTE) 8, 9

Soft Light layer mode 167

solid layer 73

solid shapes, creating from masks 162

Solo command 81

soloing layers 273

sound effects. See audio

source footage

importing 10

missing 54

spacing, changing grid 18

Span script 319

span.mm/span.mov script 319

spatial curve, defined 108

spatial interpolation 122

setting default 129

Specular 3D layer material option 233

speed

and the motion path 132

changing 137

controlling along a motion path 132

easing 139

expressions, and 262

factors affecting 131

fine-tuning 134

Speed graph

about 131

interpolation type 132

time difference 131

value difference 132

Spherize effect 197

Spill Suppressor effect 202, 210

split-field frames 44

splitting layers 74

spreading mattes 211

Spring script 319

spring.mm/spring.mov script 319

square brush tool 335

square pixels 46, 47, 48, 58

Square Pixels setting 47

stabilizing motion 315

stacking order, changing the layer 75

standard grid 18

Standard preview 117, 119

start frame 60

Start Frame option in Composition Settings 
dialog box 56

Start option in Render Settings dialog box 282

start timecode 60

Start Timecode option in Composition 
Settings dialog box 56

starting

project 5

status, rendering 280

Stencil Alpha option 168

Stencil layer modes 168

Stencil Luma option 168

Stereo Mixer effect 186

Still Footage option 27

still images

changing the frame rate for 52

default duration 27

duration 27

exporting 293

importing 25, 29

rendering movie frames as 293

stopping window updates 22

Storage Overflow option in Render Settings 
dialog box 282

Straight (Unmatted) import option 32

straight alpha channel 31

straight lines, drawing 152

streaming video over the World Wide Web 6

Stretch option in Output Module dialog box 
285

Stretch panel 67

stretching

layer in time 139

movie 300, 301

Strobe Light effect 220

Stroke effect 216

stroke weight 348

stroke widths, changing 338

strokes (paint)

animation 340
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blending 334, 350

closing 334

editing 337

selecting 334, 337

selecting (shortcuts) 349

smoothing 338

styles (Adobe Photoshop) 34

Stylize effects category 217

stylus

and stroke weight 348

configuring for Vector Paint 347

eraser mode 335

pressure and opacity 348

settings 348

Stylus Options, for painting 348

Stylus Radius paint option 348

Stylus Vendor (paint option) 348

subpixel positioning 174

substituting

low-resolution proxy for footage 54

placeholder for footage 54

substitution menus in scripts 328

Subtract mask mode 163

swf files 7

switches 86

Audio 94

Audio/Video 86

changing 265

Collapse Transformations 35, 87

Continuously Rasterize 35, 87

defined 86

Effect 88

Frame Blending 89

Lock 81

Motion Blur 90

Quality 88

rearranging panels 67

Shy 80

using 67, 86

Video 80

Switches/Modes button 165

T
take-snapshot icon 20

tangent, defined 193

Target menu 159

telecine transfer 39

templates

for output module settings 285

for render settings 283

temporal curve, defined 108

temporal interpolation 122

testing

motion before rendering 302

scripts 326

text

adding to a layer 221

as particles 361

creating with alpha channels 221

Text effects category 221

Texturize effect 220

TGA, alpha channel 30

third-party files with depth information 241

three-dimensional layers 89

three-point tracking 310

Threshold effect 184

TIFF, alpha channel 30

time

basics 8

display style 8

duration 9

frame rate 8

ruler 21

synchronizing window display 268

Time Controls palette, using to preview 116

time difference, and the Speed graph 131

Time Displacement effect 224

Time effects category 223

time graph 68

defined 68

defining the work area 70

expanding 69

magnifying 69

Time Layout window
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Effect switch in 171

In and Out panels 76

Time Marker and paint strokes 343

Time Offset

Absolute 360

Absolute Random 360

Relative 359

Relative Random 360

uses of 358

Time Span option in Render Settings dialog 
box 282

Time Stretch command 139

timecode

defined 8

drop-frame 9

non-drop-frame 9

setting time display preferences 9

time-display option 9

Timecode effect 227

Timecode option 60

Timeline window 14

adding footage items 62

defined 4

markers 83

menu 14, 68

opening 14

overview 65

panels 66

tabs 14

time graph 68

time-remapping

audio 147

audio pitch 147

defined 142

freeze frame 144

graph 143

marker 143

removing audio clicks 147

slow motion 145

the Layer window 143, 146

Value graph 143

Velocity graph 144

Time-Reverse Keyframes command 141

time-stretching

defined 140

from a specific time 139

layers 140

time-vary stopwatch 97

Tint effect 199

tint value, setting 173

tinted images 182

title-safe zones 17, 63

To Current Frame (paint option) 344

To Sequential Frames (paint option) 344

toeffect.mm/toeffect.mov script 318

Toggle Hold Keyframe command 129

tonal levels, posterizing 183

tonal range

adjusting 183

remapping pixels in channel 184

Tone effect 186

toolbar, Vector Paint 333

toolbox 22

track matte

defined 164

using an alpha channel 165

using luma values 165

Track Original Matte (Composite Paint) 340

Track Original Matte Visible (Composite Paint) 
340

track point 307

track xy camera tool 22, 238

track z camera tool 22, 238

tracked area, deleting 314

Tracker/Stabilizer controls 305, 306

adjusting 306

tracking backward 308

tracking motion 305

affine corner pinning 310

applying an effect point 312

attaching markers 313

backward tracking 308

blending feature information 308

comparison method 308

correcting drift 308, 314

defining areas 313
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deleting a tracked area 314

enhancing edges 308

feature region 307

frame rate 308

grainy footage 308

interlaced video 308

markers 313

matching pixels 309

obscured objects 308

position 309

position and rotation 310

rotation 309

search region 307

three-point tracking 310

track point 307

Transfer Modes panel 87, 165

transfer modes, rendering order 278

transferring between video and film 39

Transform effect 197

changing rendering order with 267

Transform properties 231

Anchor Point 111

camera 237

Opacity 110

orientation 232

point of interest 237

postponing calculation 268

rendering order 266

Rotation 110, 232

Scale 109

X Rotation 232

Y Rotation 232

Z Rotation 232

Z scale 232

transform values 260

transformations, adding 265

Transition effects category 224

transitions between layers 78

transparency 148

Adobe Photoshop and 34

creating transparency 169

preserving during compositing 165

See also Opacity property

traveling matte 164

trimming

in Layer window 82

in Time Layout window 82

layers 81

restoring trimmed footage 82

turning effects on and off 171

Twirl effect 197

U
Under Original Alpha Only (Composite Paint) 

340

underlying transparency, preserving 166

Undo button for paint strokes 336

Undo command 12, 172

undoing changes 11, 57

Units camera setting 237

unlocking all layers 81

unmatted alpha 31

Unqueued status 280

Unsharp Mask effect 188

updates, stopping 22

Upper Field First option 44

upper field ordered 43, 302

Use High Res. Coordinates (paint option) 348

User Stopped status 280

V
value

changing layer property 130

copying 101

pixel 23

Time Remap 143

value difference, and the Speed graph 132

Value graph

adding keyframes to 130

Bezier temporal interpolation and 125

changing keyframe interpolation 127

changing layer property 130

defined 130

direction handles and 128
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Hold interpolation and 125

increasing or decreasing property value 130

pen tool 127

time-remapping and 144

using to change layer property 130

variables, Motion Math 322

Vector math methods 255

Vector Paint 333

applying 333

blending strokes 350

brush types 335

contextual menu 334

contextual menu commands 337

eraser tool 335

matte and alpha-channel options 338

playback speed 342

selection tool 334

temporarily deactivating 335

toolbar 333, 334, 336

vectors, Motion Math 251, 327

Vegas effect 216

velocity

easing 137

expressions, and 262

fine-tuning 134

randomizing 304

Velocity graph

border 134

fine-tuning speed and 134

interpolation type 132

time difference 131

value difference 132

Velocity Time Remap 142

Venetian Blinds effect 226

Video effects category 226

Video for Windows, compression 291

video formats

analog 39

digital 40

DV 40

film 39

interlaced 40

noninterlaced 40

Video Preview preferences, setting 117

video transferred from film, removing 3:2 
pulldown 45

videotape

downloading over the World Wide Web 7

hiding and showing 80

planning for 6

View Axes mode tool 22

viewing

and setting the current time 69

color 20

frame, numerically 21

frame, visually 21

imported footage 50

on external monitor 117

source name of a layer 79

specific frame 21

window snapshot 20

views

orthogonal 234

using camera tools to change 238

virtual memory 277

visible lines, creating from masks 162

Visible option (Vector Paint contextual menu) 
337

VU meter 93

W
Wacom tablet and Vector Paint 333

Watch Folder command 296

watch folders 296

watch-folder mode 299

Wave Warp effect 197

Wave World effect 217

Web links 83, 85

whole frames 44

Wiggle Control 344

Wiggler 304

Wiggles/sec (paint option) 344

wiggling in expressions 262

window menu, displaying 14

window updates, stopping 22
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window, snapshot 20

windows

 See also individual window names

After Effects 13

changing 14

changing display 14

comparing 20

grouping 14

resizing 14

size and resolution 272

stopping updates 22

using 14

wireframe interactions 273

wireframe interactions, enabling and 
disabling 242

Wireframe preview 117, 120

Wireframe quality 88

work area

defined 70

markers, moving 70

moving 70

setting up 70

workspace

customizing 13

deleting 13

saving 13

selecting 13

World Axes mode tool 22

world space, and expressions 260

World Wide Web 6, 7

Write-On effect 220

X
X and Y coordinates 23

Z
Z coordinate 228

Z scale, understanding 232

zero point 19

Zoom camera setting 236

zoom lens 305

zoom tool 22

zooming preview area 65
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